GLSysHelp v.2.5: Introduction

 GLScene v.2.5 for VCL

Introduction

GLScene is an OpenGL based 3D library for Delphi, C++Builder and Lazarus. It provides visual components and objects allowing description and effective rendering of 3D scenes. GLScene is not only an OpenGL wrapper or utility library, but it's grown to become a set of founding classes for a generic 3D engine for the Rapid Application Development. GLScene allows you to design and render 3D scenes quickly and without having to learn the intricacies of OpenGL: if you know how to design a TForm, you'll easily master the basic operation of TGLScene. Make sure to checkout the introduction tutorial included in the help folder. GLScene includes more than many components and a variety of founding classes. The library comes with a comfortable set of demos showcasing the ease of use and demonstrating RAD wasn't done at the expense of CPU horsepower. The GLScene Sound System allows positional 3D audio via low-level APIs like FMOD, BASS, OpenAL and WaveOut. Advanced demos and samples could be found in the project directory GLScene\Examples. Some additional options for compiler are in GLS.Scene.inc (activated/deactivated, all are inactive by default): The option DEFINE GLS_Graphics32_SUPPORT controls support Alex Denissov's Graphics32 library (http://www.graphics32.org), once activated will redirect assignments from TBitmap32 to TGLBitmap32.

GLXS Team

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: All Units

All Units

Name Description
BASS.Import

Cg.GL

* * Copyright (c) 2002, NVIDIA Corporation. * * * * NVIDIA Corporation("NVIDIA") supplies this software to you in consideration * of your agreement to the following terms, and your use, installation, * modification or redistribution of this NVIDIA software constitutes * acceptance of these terms. If you do not agree with these terms, please do * not use, install, modify or redistribute this NVIDIA software. * * In consideration of your agreement to abide by the following terms, and * subject to these terms, NVIDIA grants you a personal, non-exclusive license, * under NVIDIARs copyrights in this original NVIDIA software (the "NVIDIA * Software"), to use, reproduce, modify and redistribute the NVIDIA * Software, with or without modifications, in source and/or binary forms; * provided that if you redistribute the NVIDIA Software, you must retain the * copyright notice of NVIDIA, this notice and the following text and * disclaimers in all such redistributions of the NVIDIA Software. Neither the * name, trademarks, service marks nor logos of NVIDIA Corporation may be used * to endorse or promote products derived from the NVIDIA Software without * specific prior written permission from NVIDIA. Except as expressly stated * in this notice, no other rights or licenses express or implied, are granted * by NVIDIA herein, including but not limited to any patent rights that may be * infringed by your derivative works or by other works in which the NVIDIA * Software may be incorporated. No hardware is licensed hereunder. * * THE NVIDIA SOFTWARE IS BEING PROVIDED ON AN "AS IS" BASIS, WITHOUT * WARRANTIES OR CONDITIONS OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING * WITHOUT LIMITATION, WARRANTIES OR CONDITIONS OF TITLE, NON-INFRINGEMENT, * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR ITS USE AND OPERATION * EITHER ALONE OR IN COMBINATION WITH OTHER PRODUCTS. * * IN NO EVENT SHALL NVIDIA BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL, * EXEMPLARY, CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, LOST * PROFITS; PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR * PROFITS; OR BUSINESS INTERRUPTION) OR ARISING IN ANY WAY OUT OF THE USE, * REPRODUCTION, MODIFICATION AND/OR DISTRIBUTION OF THE NVIDIA SOFTWARE, * HOWEVER CAUSED AND WHETHER UNDER THEORY OF CONTRACT, TORT (INCLUDING * NEGLIGENCE), STRICT LIABILITY OR OTHERWISE, EVEN IF NVIDIA HAS BEEN ADVISED * OF THE POSSIBILITY OF SUCH DAMAGE. *
Cg.Import

* Copyright (c) 2002, NVIDIA Corporation. * * NVIDIA Corporation("NVIDIA") supplies this software to you in consideration * of your agreement to the following terms, and your use, installation, * modification or redistribution of this NVIDIA software constitutes * acceptance of these terms. If you do not agree with these terms, please do * not use, install, modify or redistribute this NVIDIA software. * * In consideration of your agreement to abide by the following terms, and * subject to these terms, NVIDIA grants you a personal, non-exclusive license, * under NVIDIAs copyrights in this original NVIDIA software (the "NVIDIA * Software"), to use, reproduce, modify and redistribute the NVIDIA * Software, with or without modifications, in source and/or binary forms; * provided that if you redistribute the NVIDIA Software, you must retain the * copyright notice of NVIDIA, this notice and the following text and * disclaimers in all such redistributions of the NVIDIA Software. Neither the * name, trademarks, service marks nor logos of NVIDIA Corporation may be used * to endorse or promote products derived from the NVIDIA Software without * specific prior written permission from NVIDIA. Except as expressly stated * in this notice, no other rights or licenses express or implied, are granted * by NVIDIA herein, including but not limited to any patent rights that may be * infringed by your derivative works or by other works in which the NVIDIA * Software may be incorporated. No hardware is licensed hereunder. * * THE NVIDIA SOFTWARE IS BEING PROVIDED ON AN "AS IS" BASIS, WITHOUT * WARRANTIES OR CONDITIONS OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING * WITHOUT LIMITATION, WARRANTIES OR CONDITIONS OF TITLE, NON-INFRINGEMENT, * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR ITS USE AND OPERATION * EITHER ALONE OR IN COMBINATION WITH OTHER PRODUCTS. * * IN NO EVENT SHALL NVIDIA BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL, * EXEMPLARY, CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, LOST * PROFITS; PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR * PROFITS; OR BUSINESS INTERRUPTION) OR ARISING IN ANY WAY OUT OF THE USE, * REPRODUCTION, MODIFICATION AND/OR DISTRIBUTION OF THE NVIDIA SOFTWARE, * HOWEVER CAUSED AND WHETHER UNDER THEORY OF CONTRACT, TORT (INCLUDING * NEGLIGENCE), STRICT LIABILITY OR OTHERWISE, EVEN IF NVIDIA HAS BEEN ADVISED * OF THE POSSIBILITY OF SUCH DAMAGE.
CUDA.DataAccess

The graphics engine GLScene https://github.com/glscene
CUDA.FourierTransform

The graphics engine GLScene https://github.com/glscene
CUDA.Import

The graphics engine GLScene https://github.com/glscene
CUDA.ParallelPrimitives

The graphics engine GLScene https://github.com/glscene
CUDA.Parser

The graphics engine GLScene https://github.com/glscene
CUDA.Runtime

The graphics engine GLScene https://github.com/glscene
CUDA.Utility

The graphics engine GLScene https://github.com/glscene
FmCUDAEditor

The graphics engine GLScene https://github.com/glscene
FmGuiLayoutEditor

The graphics engine GLScene https://github.com/glscene
FmGuiSkinEditor

The graphics engine GLScene https://github.com/glscene
FmInfo

The graphics engine GLScene https://github.com/glscene
FmLibMaterialPicker

The graphics engine GLScene https://github.com/glscene
FmMaterialEditor

The graphics engine GLScene https://github.com/glscene
FMOD.errors

The graphics engine GLScene https://github.com/glscene
FMOD.Import

The graphics engine GLScene https://github.com/glscene
FMOD.presets

The graphics engine GLScene https://github.com/glscene
FMOD.types

The graphics engine GLScene https://github.com/glscene
FmSceneEditor

The graphics engine GLScene https://github.com/glscene
FmShaderMemo

The graphics engine GLScene https://github.com/glscene
FmShaderUniformEditor

The graphics engine GLScene https://github.com/glscene
FmVectorEditor

The graphics engine GLScene https://github.com/glscene
FmXCollectionEditor

The graphics engine GLScene https://github.com/glscene
Formats.B3D

The graphics engine GLScene https://github.com/glscene
Formats.DDSImage

The graphics engine GLScene https://github.com/glscene
Formats.DXTC

The graphics engine GLScene https://github.com/glscene
Formats.GL2

The graphics engine GLScene https://github.com/glscene
Formats.HDRImage

The graphics engine GLScene https://github.com/glscene
Formats.LWO

The graphics engine GLScene https://github.com/glscene
Formats.m3DS

The graphics engine GLScene https://github.com/glscene
Formats.m3DSConst

The graphics engine GLScene https://github.com/glscene
Formats.m3DSTypes

The graphics engine GLScene https://github.com/glscene
Formats.m3DSUtils

The graphics engine GLScene https://github.com/glscene
Formats.MD2

The graphics engine GLScene https://github.com/glscene
Formats.MD3

The graphics engine GLScene https://github.com/glscene
Formats.OCT

The graphics engine GLScene https://github.com/glscene
Formats.Q3BSP

The graphics engine GLScene https://github.com/glscene
Formats.TGA

The graphics engine GLScene https://github.com/glscene
Formats.VFW

The graphics engine GLScene https://github.com/glscene
Formats.VRML

The unit is part of the GLScene Engine, http://glscene.org
Formats.X

The graphics engine GLScene https://github.com/glscene
FRColorEditor

The graphics engine GLScene https://github.com/glscene
FRFaceEditor

The graphics engine GLScene https://github.com/glscene
FRMaterialPreview

The graphics engine GLScene https://github.com/glscene
FRTextureEdit

The graphics engine GLScene https://github.com/glscene
FRTrackBarEdit

Frame combining a TrackBar and an Edit.
GLS.AnimatedSprite

The graphics engine GLScene https://github.com/glscene
GLS.ApplicationFileIO

The graphics engine GLScene https://github.com/glscene
GLS.ArchiveManager

The graphics engine GLScene https://github.com/glscene
GLS.AsyncHDS

The graphics engine GLScene https://github.com/glscene
GLS.AsyncTimer

The graphics engine GLScene https://github.com/glscene
GLS.Atmosphere

The graphics engine GLScene https://github.com/glscene
GLS.AVIRecorder

The graphics engine GLScene https://github.com/glscene
GLS.BaseMeshSilhouette

The graphics engine GLScene https://github.com/glscene
GLS.Behaviours

The graphics engine GLScene https://github.com/glscene
GLS.BitmapFont

The graphics engine GLScene https://github.com/glscene
GLS.Blur

The graphics engine GLScene https://github.com/glscene
GLS.BumpmapHDS

The graphics engine GLScene https://github.com/glscene
GLS.Cadencer

The graphics engine GLScene https://github.com/glscene
GLS.CameraController

The graphics engine GLScene https://github.com/glscene
GLS.Canvas

The graphics engine GLScene https://github.com/glscene
GLS.CgBombShader

The graphics engine GLScene https://github.com/glscene
GLS.CgPostTransformationShader

The graphics engine GLScene https://github.com/glscene
GLS.CgRegister

The graphics engine GLScene https://github.com/glscene
GLS.CgShader

The graphics engine GLScene https://github.com/glscene
GLS.Collision

The graphics engine GLScene https://github.com/glscene
GLS.CompositeImage

The graphics engine GLScene https://github.com/glscene
GLS.Console

The graphics engine GLScene https://github.com/glscene
GLS.Context

The graphics engine GLScene https://github.com/glscene
GLS.CUDA.APIComps

The graphics engine GLScene https://github.com/glscene
GLS.CUDA.Compiler

The graphics engine GLScene https://github.com/glscene
GLS.CUDA.Context

The graphics engine GLScene https://github.com/glscene
GLS.CUDA.FFTPlan

The graphics engine GLScene https://github.com/glscene
GLS.CUDA.Graphics

The graphics engine GLScene https://github.com/glscene
GLS.CUDA.PropEditors

The graphics engine GLScene https://github.com/glscene
GLS.CUDA.Register

The graphics engine GLScene https://github.com/glscene
GLS.CyborgManager

GLS.DCE

The graphics engine GLScene https://github.com/glscene
GLS.DynamicTexture

The graphics engine GLScene https://github.com/glscene
GLS.EllipseCollision

The graphics engine GLScene https://github.com/glscene
GLS.EParticleMasksManager

The graphics engine GLScene https://github.com/glscene
GLS.ExplosionFx

The graphics engine GLScene https://github.com/glscene
GLS.Extrusion

The graphics engine GLScene https://github.com/glscene
GLS.FBORenderer

The graphics engine GLScene https://github.com/glscene
GLS.Feedback

The graphics engine GLScene https://github.com/glscene
GLS.File3DPDF

The graphics engine GLScene https://github.com/glscene
GLS.File3DS

The graphics engine GLScene https://github.com/glscene
GLS.File3DSSceneObjects

The graphics engine GLScene https://github.com/glscene
GLS.FileASE

The graphics engine GLScene https://github.com/glscene
GLS.FileB3D

The graphics engine GLScene https://github.com/glscene
GLS.FileBMP

The graphics engine GLScene https://github.com/glscene
GLS.FileDDS

The graphics engine GLScene https://github.com/glscene
GLS.FileDEL

The graphics engine GLScene https://github.com/glscene
GLS.FileDXF

The graphics engine GLScene https://github.com/glscene
GLS.FileGL2

The graphics engine GLScene https://github.com/glscene
GLS.FileGLTF

The graphics engine GLScene https://github.com/glscene
GLS.FileGRD

The graphics engine GLScene https://github.com/glscene
GLS.FileGTS

The graphics engine GLScene https://github.com/glscene
GLS.FileHDR

The graphics engine GLScene https://github.com/glscene
GLS.FileJPEG

The graphics engine GLScene https://github.com/glscene
GLS.FileLMTS

The graphics engine GLScene https://github.com/glscene
GLS.FileLWO

The graphics engine GLScene https://github.com/glscene
GLS.FileMD2

The graphics engine GLScene https://github.com/glscene
GLS.FileMD3

The graphics engine GLScene https://github.com/glscene
GLS.FileMD5

The graphics engine GLScene https://github.com/glscene
GLS.FileMDC

The graphics engine GLScene https://github.com/glscene
GLS.FileMP3

The graphics engine GLScene https://github.com/glscene
GLS.FileMS3D

The graphics engine GLScene https://github.com/glscene
GLS.FileNMF

The graphics engine GLScene https://github.com/glscene
GLS.FileNurbs

The graphics engine GLScene https://github.com/glscene
GLS.FileOBJ

The graphics engine GLScene https://github.com/glscene
GLS.FileOCT

The graphics engine GLScene https://github.com/glscene
GLS.FilePGM

The graphics engine GLScene https://github.com/glscene
GLS.FilePLY

The graphics engine GLScene https://github.com/glscene
GLS.FilePNG

The graphics engine GLScene https://github.com/glscene
GLS.FileQ3BSP

The graphics engine GLScene https://github.com/glscene
GLS.FileQ3MD3

The graphics engine GLScene https://github.com/glscene
GLS.FileSMD

The graphics engine GLScene https://github.com/glscene
GLS.FileSTL

The graphics engine GLScene https://github.com/glscene
GLS.FileTGA

The graphics engine GLScene https://github.com/glscene
GLS.FileTIN

The graphics engine GLScene https://github.com/glscene
GLS.FileVfsPAK

The graphics engine GLScene https://github.com/glscene
GLS.FileVOR

The graphics engine GLScene https://github.com/glscene
GLS.FileVRML

The graphics engine GLScene https://github.com/glscene
GLS.FileWAV

The graphics engine GLScene https://github.com/glscene
GLS.FileX

The graphics engine GLScene https://github.com/glscene
GLS.FileZLIB

The graphics engine GLScene https://github.com/glscene
GLS.FireFX

The graphics engine GLScene https://github.com/glscene
GLS.FPSMovement

The graphics engine GLScene https://github.com/glscene
GLS.FullScreenViewer

The graphics engine GLScene https://github.com/glscene
GLS.GameMenu

The graphics engine GLScene https://github.com/glscene
GLS.GeomObjects

The graphics engine GLScene https://github.com/glscene
GLS.Gizmo

The graphics engine GLScene https://github.com/glscene
GLS.GizmoEx

The graphics engine GLScene https://github.com/glscene
GLS.Graph

The graphics engine GLScene https://github.com/glscene
GLS.Graphics

The graphics engine GLScene https://github.com/glscene
GLS.Gui

The graphics engine GLScene https://github.com/glscene
GLS.HeightData

The graphics engine GLScene https://github.com/glscene
GLS.HeightTileFileHDS

The graphics engine GLScene https://github.com/glscene
GLS.HUDObjects

The graphics engine GLScene https://github.com/glscene
GLS.ImageUtils

The graphics engine GLScene https://github.com/glscene
GLS.Imposter

The graphics engine GLScene https://github.com/glscene
GLS.InitOpenGL

The graphics engine GLScene https://github.com/glscene
GLS.Isolines

The graphics engine GLScene https://github.com/glscene
GLS.Isosurface

The graphics engine GLScene https://github.com/glscene
GLS.Joystick

The graphics engine GLScene https://github.com/glscene
GLS.LensFlare

The graphics engine GLScene https://github.com/glscene
GLS.LinePFX

The graphics engine GLScene https://github.com/glscene
GLS.Material

The graphics engine GLScene https://github.com/glscene
GLS.MaterialEx

The graphics engine GLScene https://github.com/glscene
GLS.MaterialMultiProxy

The graphics engine GLScene https://github.com/glscene
GLS.MaterialScript

The graphics engine GLScene https://github.com/glscene
GLS.Memo

The graphics engine GLScene https://github.com/glscene
GLS.Mesh

The graphics engine GLScene https://github.com/glscene
GLS.MeshBSP

The graphics engine GLScene https://github.com/glscene
GLS.MeshBuilder

The graphics engine GLScene https://github.com/glscene
GLS.MeshCSG

The graphics engine GLScene https://github.com/glscene
GLS.MeshLines

The graphics engine GLScene https://github.com/glscene
GLS.MeshUtils

The graphics engine GLScene https://github.com/glscene
GLS.Mirror

The graphics engine GLScene https://github.com/glscene
GLS.Movement

The graphics engine GLScene https://github.com/glscene
GLS.MultiPolygon

The graphics engine GLScene https://github.com/glscene
GLS.MultiProxy

The graphics engine GLScene https://github.com/glscene
GLS.MultiSampleImage

The graphics engine GLScene https://github.com/glscene
GLS.Navigator

The graphics engine GLScene https://github.com/glscene
GLS.NGDManager

The graphics engine GLScene https://github.com/glscene
GLS.NGDRagdoll

The graphics engine GLScene https://github.com/glscene
GLS.Nodes

The graphics engine GLScene https://github.com/glscene
GLS.ObjectManager

The graphics engine GLScene https://github.com/glscene
GLS.Objects

The graphics engine GLScene https://github.com/glscene
GLS.Octree

The graphics engine GLScene https://github.com/glscene
GLS.ODEManager

The graphics engine GLScene https://github.com/glscene
GLS.ODERagdoll

The graphics engine GLScene https://github.com/glscene
GLS.ODESkeletonColliders

The graphics engine GLScene https://github.com/glscene
GLS.ODEUtils

The graphics engine GLScene https://github.com/glscene
GLS.OpenGLAdapter

The graphics engine GLScene https://github.com/glscene
GLS.PAKArchive

The graphics engine GLScene https://github.com/glscene
GLS.ParametricSurfaces

The graphics engine GLScene https://github.com/glscene
GLS.ParticleFX

The graphics engine GLScene https://github.com/glscene
GLS.Particles

The graphics engine GLScene https://github.com/glscene
GLS.Perlin

The graphics engine GLScene https://github.com/glscene
GLS.PerlinPFX

The graphics engine GLScene https://github.com/glscene
GLS.PhysFields

The graphics engine GLScene https://github.com/glscene
GLS.PhysForces

The graphics engine GLScene https://github.com/glscene
GLS.Physics.Register

The graphics engine GLScene https://github.com/glscene
GLS.PhysInertias

The graphics engine GLScene https://github.com/glscene
GLS.PhysJoints

The graphics engine GLScene https://github.com/glscene
GLS.PhysManager

The graphics engine GLScene https://github.com/glscene
GLS.PolygonTesselation

The graphics engine GLScene https://github.com/glscene
GLS.Polyhedra

The graphics engine GLScene https://github.com/glscene
GLS.Portal

The graphics engine GLScene https://github.com/glscene
GLS.ProcTextures

The graphics engine GLScene https://github.com/glscene
GLS.ProjectedTextures

The graphics engine GLScene https://github.com/glscene
GLS.ProxyObjects

The graphics engine GLScene https://github.com/glscene
GLS.Pythons.Script

The graphics engine GLScene https://github.com/glscene
GLS.Ragdoll

The graphics engine GLScene https://github.com/glscene
GLS.RandomHDS

The graphics engine GLScene https://github.com/glscene
GLS.RenderContextInfo

The graphics engine GLScene https://github.com/glscene
GLS.ROAMPatch

The graphics engine GLScene https://github.com/glscene
GLS.Scene

The graphics engine GLScene https://github.com/glscene
GLS.SceneForm

The graphics engine GLScene https://github.com/glscene
GLS.SceneRegister

The graphics engine GLScene https://github.com/glscene
GLS.SceneViewer

The graphics engine GLScene https://github.com/glscene
GLS.Screen

The graphics engine GLScene https://github.com/glscene
GLS.ScreenSaver

The graphics engine GLScene https://github.com/glscene
GLS.ScriptBase

The graphics engine GLScene https://github.com/glscene
GLS.SDL.Context

The graphics engine GLScene https://github.com/glscene
GLS.SDL.Window

The graphics engine GLScene https://github.com/glscene
GLS.Selection

The graphics engine GLScene https://github.com/glscene
GLS.ShadowHDS

The graphics engine GLScene https://github.com/glscene
GLS.ShadowPlane

The graphics engine GLScene https://github.com/glscene
GLS.ShadowVolume

The graphics engine GLScene https://github.com/glscene
GLS.Silhouette

The graphics engine GLScene https://github.com/glscene
GLS.SimpleNavigation

The graphics engine GLScene https://github.com/glscene
GLS.SkyDome

The graphics engine GLScene https://github.com/glscene
GLS.SmartObjects

The graphics engine GLScene https://github.com/glscene
GLS.SmoothNavigator

The graphics engine GLScene https://github.com/glscene
GLS.SoundFileObjects

The graphics engine GLScene https://github.com/glscene
GLS.SoundManager

The graphics engine GLScene https://github.com/glscene
GLS.Sounds.BASS

The graphics engine GLScene https://github.com/glscene
GLS.Sounds.FMOD

The graphics engine GLScene https://github.com/glscene
GLS.Sounds.OpenAL

The graphics engine GLScene https://github.com/glscene
GLS.Sounds.Register

The graphics engine GLScene https://github.com/glscene
GLS.Sounds.WaveOut

The graphics engine GLScene https://github.com/glscene
GLS.SpacePartition

The graphics engine GLScene https://github.com/glscene
GLS.SpaceText

The graphics engine GLScene https://github.com/glscene
GLS.State

The graphics engine GLScene https://github.com/glscene
GLS.TerrainRenderer

The graphics engine GLScene https://github.com/glscene
GLS.TexLensFlare

The graphics engine GLScene https://github.com/glscene
GLS.Texture

The graphics engine GLScene https://github.com/glscene
GLS.TextureCombiners

The graphics engine GLScene https://github.com/glscene
GLS.TexturedHDS

The graphics engine GLScene https://github.com/glscene
GLS.TextureImageEditors

The graphics engine GLScene https://github.com/glscene
GLS.ThorFX

The graphics engine GLScene https://github.com/glscene
GLS.TilePlane

The graphics engine GLScene https://github.com/glscene
GLS.TimeEventsMgr

The graphics engine GLScene https://github.com/glscene
GLS.Trail

The graphics engine GLScene https://github.com/glscene
GLS.Tree

The graphics engine GLScene https://github.com/glscene
GLS.VectorFileObjects

The graphics engine GLScene https://github.com/glscene
GLS.VerletClothify

The graphics engine GLScene https://github.com/glscene
GLS.VerletTypes

The graphics engine GLScene https://github.com/glscene
GLS.WaterPlane

The graphics engine GLScene https://github.com/glscene
GLS.Windows

The graphics engine GLScene https://github.com/glscene
GLS.WindowsContext

The graphics engine GLScene https://github.com/glscene
GLS.WindowsFont

The graphics engine GLScene https://github.com/glscene
GLS.XCollectionRegister

The graphics engine GLScene https://github.com/glscene
GLS.XOpenGL

The graphics engine GLScene https://github.com/glscene
GLS.zBuffer

The graphics engine GLScene https://github.com/glscene
GLScene.AnimationUtils

The graphics engine GLScene https://github.com/glscene
GLScene.GeometryBB

The graphics engine GLScene https://github.com/glscene
GLScene.Keyboard

The graphics engine GLScene https://github.com/glscene
GLScene.Logger

The graphics engine GLScene https://github.com/glscene
GLScene.Manager

The graphics engine GLScene https://github.com/glscene
GLScene.OpenGL4

The graphics engine GXScene https://github.com/glscene
GLScene.OpenGLTokens

The graphics engine GLScene https://github.com/glscene
GLScene.PipelineTransform

The graphics engine GLScene https://github.com/glscene
GLScene.Polynomials

The graphics engine GLScene https://github.com/glscene
GLScene.RandomLib

The graphics engine GLScene https://github.com/glscene
GLScene.RedBlackTree

The graphics engine GXScene https://github.com/glscene
GLScene.RGBE

The graphics engine GLScene https://github.com/glscene
GLScene.Spline

The graphics engine GLScene https://github.com/glscene
GLScene.Strings

The graphics engine GLScene https://github.com/glscene
GLScene.TextureFormat

The graphics engine GLScene https://github.com/glscene
GLScene.Triangulation

The graphics engine GLScene https://github.com/glscene
GLScene.Utils

The graphics engine GLScene https://github.com/glscene
GLScene.VectorGeometry

The graphics engine GLScene https://github.com/glscene
GLScene.VectorTypes

The graphics engine GLScene https://github.com/glscene
GLScene.VectorTypesExt

The graphics engine GLScene https://github.com/glscene
GLScene.XCollection

The graphics engine GLScene https://github.com/glscene
GLSL.AsmShader

The graphics engine GLScene https://github.com/glscene
GLSL.BumpShaders

The graphics engine GLScene https://github.com/glscene
GLSL.CustomShader

The graphics engine GLScene https://github.com/glscene
GLSL.DiffuseSpecularShader

The graphics engine GLScene https://github.com/glscene
GLSL.LineShaders

The graphics engine GLScene https://github.com/glscene
GLSL.MultiMaterialShader

The graphics engine GLScene https://github.com/glscene
GLSL.PhongShader

The graphics engine GLScene https://github.com/glscene
GLSL.PostEffects

The graphics engine GLScene https://github.com/glscene
GLSL.PostShaders

The graphics engine GLScene https://github.com/glscene
GLSL.ProjectedTextures

The graphics engine GLScene https://github.com/glscene
GLSL.Shader

The graphics engine GLScene https://github.com/glscene
GLSL.ShaderCombiner

The graphics engine GLScene https://github.com/glscene
GLSL.ShaderParameter

The graphics engine GLScene https://github.com/glscene
GLSL.ShapeShaders

The graphics engine GLScene https://github.com/glscene
GLSL.TextureShaders

The graphics engine GLScene https://github.com/glscene
GLSL.UserShader

The graphics engine GLScene https://github.com/glscene
gnugettext

*—————————————————————————— GNU gettext translation system for Delphi, Kylix, C++ Builder and others. All parts of the translation system are kept in this unit.

——————————————————————————-
GnuGetTextInit

Delphi-Unit - Initialization for GnuGetText =============================

© Dr. J. Rathlev, D-24222 Schwentinental (kontakt(a)rathlev-home.de)

The contents of this file may be used under the terms of the Mozilla Public License ("MPL") or GNU Lesser General Public License Version 2 or later (the "LGPL")

Software distributed under this License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License.

Vers. 1 - July 2023 last mdified: July 2023
ModuleLoader

The graphics engine GLScene https://github.com/glscene
Newton.Import

Copyright (c) <2003-2020> <Julio Jerez, Newton Game Dynamics> * * This software is provided 'as-is', without any express or implied * warranty. In no event will the authors be held liable for any damages * arising from the use of this software. * * Permission is granted to anyone to use this software for any purpose, * including commercial applications, and to alter it and redistribute it * freely, subject to the following restrictions: * * 1. The origin of this software must not be misrepresented; you must not * claim that you wrote the original software. If you use this software * in a product, an acknowledgment in the product documentation would be * appreciated but is not required. * * 2. Altered source versions must be plainly marked as such, and must not be * misrepresented as being the original software. * * 3. This notice may not be removed or altered from any source distribution.
ODE.Import

The graphics engine GLScene https://github.com/glscene
OpenAL.Import

Version: MPL 1.1/GPL 2.0/LGPL 2.1 * * The contents of this file are subject to the Mozilla Public License Version * 1.1 (the "License"); you may not use this file except in compliance with * the License. You may obtain a copy of the License at * http://www.mozilla.org/MPL/ * * Software distributed under the License is distributed on an "AS IS" basis, * WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License * for the specific language governing rights and limitations under the * License. * * The Original Code is OpenAL1.0 - Headertranslation to Object Pascal. * * The Initial Developer of the Original Code is * Delphi OpenAL Translation Team. * Portions created by the Initial Developer are Copyright (C) 2001-2004 * the Initial Developer. All Rights Reserved. * * Contributor(s): * Tom Nuydens (delphi3d@gamedeveloper.org) * Dean Ellis (dean.ellis@sxmedia.co.uk) * Amresh Ramachandran (amreshr@hotmail.com) * Pranav Joshi (pranavjosh@yahoo.com) * Marten van der Honing (mvdhoning@noeska.com) * Benjamin Rosseaux (BeRo) * * Alternatively, the contents of this file may be used under the terms of * either the GNU General Public License Version 2 or later (the "GPL"), or * the GNU Lesser General Public License Version 2.1 or later (the "LGPL"), * in which case the provisions of the GPL or the LGPL are applicable instead * of those above. If you wish to allow use of your version of this file only * under the terms of either the GPL or the LGPL, and not to allow others to * use your version of this file under the terms of the MPL, indicate your * decision by deleting the provisions above and replace them with the notice * and other provisions required by the GPL or the LGPL. If you do not delete * the provisions above, a recipient may use your version of this file under * the terms of any one of the MPL, the GPL or the LGPL.
OpenCL.GL

The graphics engine GLScene https://github.com/glscene
OpenCL.Import

The graphics engine GLScene https://github.com/glscene
OpenCL.Platform

The graphics engine GLScene https://github.com/glscene
PasDblStrUtils

***************************************************************************** * PasDblStrUtils * ****************************************************************************** * Version 2021-06-21-01-13-0000 * ****************************************************************************** * zlib license * *============================================================================* * * * Copyright (C) 2016-2021, Benjamin Rosseaux (benjamin@rosseaux.de) * * * * This software is provided 'as-is', without any express or implied * * warranty. In no event will the authors be held liable for any damages * * arising from the use of this software. * * * * Permission is granted to anyone to use this software for any purpose, * * including commercial applications, and to alter it and redistribute it * * freely, subject to the following restrictions: * * * * 1. The origin of this software must not be misrepresented; you must not * * claim that you wrote the original software. If you use this software * * in a product, an acknowledgement in the product documentation would be * * appreciated but is not required. * * 2. Altered source versions must be plainly marked as such, and must not be * * misrepresented as being the original software. * * 3. This notice may not be removed or altered from any source distribution. * * * ****************************************************************************** * General guidelines for code contributors * *============================================================================* * * * 1. Make sure you are legally allowed to make a contribution under the zlib * * license. * * 2. The zlib license header goes at the top of each source file, with * * appropriate copyright notice. * * 3. After a pull request, check the status of your pull request on * http://github.com/BeRo1985/pasdblstrutils * * 4. Write code, which is compatible with Delphi >=XE7 and FreePascal * * >= 3.0 * * 5. Don't use Delphi-only, FreePascal-only or Lazarus-only libraries/units, * * but if needed, make it out-ifdef-able. * * 6. No use of third-party libraries/units as possible, but if needed, make * * it out-ifdef-able. * * 7. Try to use const when possible. * * 8. Make sure to comment out writeln, used while debugging. * * 9. Make sure the code compiles on 32-bit and 64-bit platforms (x86-32, * * x86-64, ARM, ARM64, etc.). * * 10. Make sure the code runs on platforms with weak and strong memory * * models without any issues. * * * *****************************************************************************
PasJSON

***************************************************************************** * PasJSON * ****************************************************************************** * Version 2020-03-04-02-20 * ****************************************************************************** * zlib license * *============================================================================* * * * Copyright (C) 2016-2020, Benjamin Rosseaux (benjamin@rosseaux.de) * * * * This software is provided 'as-is', without any express or implied * * warranty. In no event will the authors be held liable for any damages * * arising from the use of this software. * * * * Permission is granted to anyone to use this software for any purpose, * * including commercial applications, and to alter it and redistribute it * * freely, subject to the following restrictions: * * * * 1. The origin of this software must not be misrepresented; you must not * * claim that you wrote the original software. If you use this software * * in a product, an acknowledgement in the product documentation would be * * appreciated but is not required. * * 2. Altered source versions must be plainly marked as such, and must not be * * misrepresented as being the original software. * * 3. This notice may not be removed or altered from any source distribution. * * * ****************************************************************************** * General guidelines for code contributors * *============================================================================* * * * 1. Make sure you are legally allowed to make a contribution under the zlib * * license. * * 2. The zlib license header goes at the top of each source file, with * * appropriate copyright notice. * * 3. After a pull request, check the status of your pull request on * * http://github.com/BeRo1985/pasjson * * 4. Write code which's compatible with newer modern Delphi versions and * * FreePascal >= 3.0.0 * * 5. Don't use Delphi-only, FreePascal-only or Lazarus-only libraries/units, * * but if needed, make it out-ifdef-able. * * 6. No use of third-party libraries/units as possible, but if needed, make * * it out-ifdef-able. * * 7. Try to use const when possible. * * 8. Make sure to comment out writeln, used while debugging. * * 9. Make sure the code compiles on 32-bit and 64-bit platforms (x86-32, * * x86-64, ARM, ARM64, etc.). * * * *****************************************************************************
PhysX.Import

The graphics engine GLScene https://github.com/glscene
SDL.Import

The graphics engine GLScene https://github.com/glscene


GLSysHelp v.2.5: BASS.Import

Unit BASS.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • Winapi.Windows

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record BASS_DEVICEINFO |
Record BASS_INFO |
Record BASS_RECORDINFO |
Record BASS_SAMPLE |
Record BASS_CHANNELINFO |
Record BASS_PLUGINFORM |
Record BASS_PLUGININFO |
Record BASS_3DVECTOR |
Record BASS_FILEPROCS |
Record TAG_ID3 |
Record TAG_APE_BINARY |
Packed Record TAG_BEXT |
Record BASS_DX8_CHORUS |
Record BASS_DX8_COMPRESSOR |
Record BASS_DX8_DISTORTION |
Record BASS_DX8_ECHO |
Record BASS_DX8_FLANGER |
Record BASS_DX8_GARGLE |
Record BASS_DX8_I3DL2REVERB |
Record BASS_DX8_PARAMEQ |
Record BASS_DX8_REVERB |
Record BASS_FX_VOLUME_PARAM |

Functions and Procedures

function BASS_SPEAKER_N(n: DWORD): DWORD;
function BASS_SetEAXPreset(env: LongInt): BOOL;
function BASS_Load(LibName: PChar ): Boolean;
procedure BASS_UnLoad;
function BASS_IsLoaded:boolean;

Types

BOOL = LongBool;
DOWNLOADPROC = procedure(buffer: Pointer; length: DWORD; user: Pointer); stdcall;
DSPPROC = procedure(handle: HDSP; channel: DWORD; buffer: Pointer; length: DWORD; user: Pointer); stdcall;
DWORD = Cardinal;
FILECLOSEPROC = procedure(user: Pointer); stdcall;
FILELENPROC = function(user: Pointer): QWORD; stdcall;
FILEREADPROC = function(buffer: Pointer; length: DWORD; user: Pointer): DWORD; stdcall;
FILESEEKPROC = function(offset: QWORD; user: Pointer): BOOL; stdcall;
HCHANNEL = DWORD;
HDSP = DWORD;
HFX = DWORD;
HMUSIC = DWORD;
HPLUGIN = DWORD;
HRECORD = DWORD;
HSAMPLE = DWORD;
HSTREAM = DWORD;
HSYNC = DWORD;
PBASS_PLUGINFORMS = ˆTBASS_PLUGINFORMS;
PBASS_PLUGININFO = ˆBASS_PLUGININFO;
PTAG_APE_BINARY = ˆTAG_APE_BINARY;
PTAG_BEXT = ˆTAG_BEXT;
PTAG_ID3 = ˆTAG_ID3;
QWORD = Int64;
RECORDPROC = function(handle: HRECORD; buffer: Pointer; length: DWORD; user: Pointer): BOOL; stdcall;
STREAMPROC = function(handle: HSTREAM; buffer: Pointer; length: DWORD; user: Pointer): DWORD; stdcall;
SYNCPROC = procedure(handle: HSYNC; channel, data: DWORD; user: Pointer); stdcall;
TBASSModuleHandle = HINST;
TBASS_PLUGINFORMS = array[0..maxInt div sizeOf(BASS_PLUGINFORM) - 1] of BASS_PLUGINFORM;

Constants

bassdll = 'bass32.dll';
BASSVERSION = $204;
BASSVERSIONTEXT = '2.4';
DW_ERROR = Cardinal(-1);
QW_ERROR = Int64(-1);
BASS_OK = 0;
BASS_ERROR_MEM = 1;
BASS_ERROR_FILEOPEN = 2;
BASS_ERROR_DRIVER = 3;
BASS_ERROR_BUFLOST = 4;
BASS_ERROR_HANDLE = 5;
BASS_ERROR_FORMAT = 6;
BASS_ERROR_POSITION = 7;
BASS_ERROR_INIT = 8;
BASS_ERROR_START = 9;
BASS_ERROR_SSL = 10;
BASS_ERROR_REINIT = 11;
BASS_ERROR_ALREADY = 14;
BASS_ERROR_NOTAUDIO = 17;
BASS_ERROR_NOCHAN = 18;
BASS_ERROR_ILLTYPE = 19;
BASS_ERROR_ILLPARAM = 20;
BASS_ERROR_NO3D = 21;
BASS_ERROR_NOEAX = 22;
BASS_ERROR_DEVICE = 23;
BASS_ERROR_NOPLAY = 24;
BASS_ERROR_FREQ = 25;
BASS_ERROR_NOTFILE = 27;
BASS_ERROR_NOHW = 29;
BASS_ERROR_EMPTY = 31;
BASS_ERROR_NONET = 32;
BASS_ERROR_CREATE = 33;
BASS_ERROR_NOFX = 34;
BASS_ERROR_NOTAVAIL = 37;
BASS_ERROR_DECODE = 38;
BASS_ERROR_DX = 39;
BASS_ERROR_TIMEOUT = 40;
BASS_ERROR_FILEFORM = 41;
BASS_ERROR_SPEAKER = 42;
BASS_ERROR_VERSION = 43;
BASS_ERROR_CODEC = 44;
BASS_ERROR_ENDED = 45;
BASS_ERROR_BUSY = 46;
BASS_ERROR_UNSTREAMABLE = 47;
BASS_ERROR_PROTOCOL = 48;
BASS_ERROR_DENIED = 49;
BASS_ERROR_UNKNOWN = -1;
BASS_CONFIG_BUFFER = 0;
BASS_CONFIG_UPDATEPERIOD = 1;
BASS_CONFIG_GVOL_SAMPLE = 4;
BASS_CONFIG_GVOL_STREAM = 5;
BASS_CONFIG_GVOL_MUSIC = 6;
BASS_CONFIG_CURVE_VOL = 7;
BASS_CONFIG_CURVE_PAN = 8;
BASS_CONFIG_FLOATDSP = 9;
BASS_CONFIG_3DALGORITHM = 10;
BASS_CONFIG_NET_TIMEOUT = 11;
BASS_CONFIG_NET_BUFFER = 12;
BASS_CONFIG_PAUSE_NOPLAY = 13;
BASS_CONFIG_NET_PREBUF = 15;
BASS_CONFIG_NET_PASSIVE = 18;
BASS_CONFIG_REC_BUFFER = 19;
BASS_CONFIG_NET_PLAYLIST = 21;
BASS_CONFIG_MUSIC_VIRTUAL = 22;
BASS_CONFIG_VERIFY = 23;
BASS_CONFIG_UPDATETHREADS = 24;
BASS_CONFIG_DEV_BUFFER = 27;
BASS_CONFIG_REC_LOOPBACK = 28;
BASS_CONFIG_VISTA_TRUEPOS = 30;
BASS_CONFIG_IOS_SESSION = 34;
BASS_CONFIG_IOS_MIXAUDIO = 34;
BASS_CONFIG_DEV_DEFAULT = 36;
BASS_CONFIG_NET_READTIMEOUT = 37;
BASS_CONFIG_VISTA_SPEAKERS = 38;
BASS_CONFIG_IOS_SPEAKER = 39;
BASS_CONFIG_MF_DISABLE = 40;
BASS_CONFIG_HANDLES = 41;
BASS_CONFIG_UNICODE = 42;
BASS_CONFIG_SRC = 43;
BASS_CONFIG_SRC_SAMPLE = 44;
BASS_CONFIG_ASYNCFILE_BUFFER = 45;
BASS_CONFIG_OGG_PRESCAN = 47;
BASS_CONFIG_MF_VIDEO = 48;
BASS_CONFIG_AIRPLAY = 49;
BASS_CONFIG_DEV_NONSTOP = 50;
BASS_CONFIG_IOS_NOCATEGORY = 51;
BASS_CONFIG_VERIFY_NET = 52;
BASS_CONFIG_DEV_PERIOD = 53;
BASS_CONFIG_FLOAT = 54;
BASS_CONFIG_NET_SEEK = 56;
BASS_CONFIG_AM_DISABLE = 58;
BASS_CONFIG_NET_PLAYLIST_DEPTH = 59;
BASS_CONFIG_NET_PREBUF_WAIT = 60;
BASS_CONFIG_ANDROID_SESSIONID = 62;
BASS_CONFIG_WASAPI_PERSIST = 65;
BASS_CONFIG_REC_WASAPI = 66;
BASS_CONFIG_ANDROID_AAUDIO = 67;
BASS_CONFIG_SAMPLE_ONEHANDLE = 69;
BASS_CONFIG_NET_META = 71;
BASS_CONFIG_NET_RESTRATE = 72;
BASS_CONFIG_REC_DEFAULT = 73;
BASS_CONFIG_NORAMP = 74;
BASS_CONFIG_NET_AGENT = 16;
BASS_CONFIG_NET_PROXY = 17;
BASS_CONFIG_ANDROID_JAVAVM = 63;
BASS_CONFIG_LIBSSL = 64;
BASS_CONFIG_FILENAME = 75;
BASS_CONFIG_THREAD = $40000000;
BASS_IOS_SESSION_MIX = 1;
BASS_IOS_SESSION_DUCK = 2;
BASS_IOS_SESSION_AMBIENT = 4;
BASS_IOS_SESSION_SPEAKER = 8;
BASS_IOS_SESSION_DISABLE = 16;
BASS_IOS_SESSION_DEACTIVATE = 32;
BASS_IOS_SESSION_AIRPLAY = 64;
BASS_IOS_SESSION_BTHFP = 128;
BASS_IOS_SESSION_BTA2DP = $100;
BASS_DEVICE_8BITS = 1;
BASS_DEVICE_MONO = 2;
BASS_DEVICE_3D = 4;
BASS_DEVICE_16BITS = 8;
BASS_DEVICE_REINIT = 128;
BASS_DEVICE_LATENCY = $100;
BASS_DEVICE_CPSPEAKERS = $400;
BASS_DEVICE_SPEAKERS = $800;
BASS_DEVICE_NOSPEAKER = $1000;
BASS_DEVICE_DMIX = $2000;
BASS_DEVICE_FREQ = $4000;
BASS_DEVICE_STEREO = $8000;
BASS_DEVICE_AUDIOTRACK = $20000;
BASS_DEVICE_DSOUND = $40000;
BASS_DEVICE_SOFTWARE = $80000;
BASS_OBJECT_DS = 1;
BASS_OBJECT_DS3DL = 2;
BASS_DEVICE_ENABLED = 1;
BASS_DEVICE_DEFAULT = 2;
BASS_DEVICE_INIT = 4;
BASS_DEVICE_LOOPBACK = 8;
BASS_DEVICE_DEFAULTCOM = 128;
BASS_DEVICE_TYPE_MASK = $ff000000;
BASS_DEVICE_TYPE_NETWORK = $01000000;
BASS_DEVICE_TYPE_SPEAKERS = $02000000;
BASS_DEVICE_TYPE_LINE = $03000000;
BASS_DEVICE_TYPE_HEADPHONES = $04000000;
BASS_DEVICE_TYPE_MICROPHONE = $05000000;
BASS_DEVICE_TYPE_HEADSET = $06000000;
BASS_DEVICE_TYPE_HANDSET = $07000000;
BASS_DEVICE_TYPE_DIGITAL = $08000000;
BASS_DEVICE_TYPE_SPDIF = $09000000;
BASS_DEVICE_TYPE_HDMI = $0a000000;
BASS_DEVICE_TYPE_DISPLAYPORT = $40000000;
BASS_DEVICES_AIRPLAY = $1000000;
DSCAPS_EMULDRIVER = $00000020;
DSCAPS_CERTIFIED = $00000040;
DSCAPS_HARDWARE = $80000000;
DSCCAPS_EMULDRIVER = DSCAPS_EMULDRIVER;
DSCCAPS_CERTIFIED = DSCAPS_CERTIFIED;
BASS_SAMPLE_8BITS = 1;
BASS_SAMPLE_FLOAT = 256;
BASS_SAMPLE_MONO = 2;
BASS_SAMPLE_LOOP = 4;
BASS_SAMPLE_3D = 8;
BASS_SAMPLE_SOFTWARE = 16;
BASS_SAMPLE_MUTEMAX = 32;
BASS_SAMPLE_VAM = 64;
BASS_SAMPLE_FX = 128;
BASS_SAMPLE_OVER_VOL = $10000;
BASS_SAMPLE_OVER_POS = $20000;
BASS_SAMPLE_OVER_DIST = $30000;
BASS_STREAM_PRESCAN = $20000;
BASS_STREAM_AUTOFREE = $40000;
BASS_STREAM_RESTRATE = $80000;
BASS_STREAM_BLOCK = $100000;
BASS_STREAM_DECODE = $200000;
BASS_STREAM_STATUS = $800000;
BASS_MP3_IGNOREDELAY = $200;
BASS_MP3_SETPOS = BASS_STREAM_PRESCAN;
BASS_MUSIC_FLOAT = BASS_SAMPLE_FLOAT;
BASS_MUSIC_MONO = BASS_SAMPLE_MONO;
BASS_MUSIC_LOOP = BASS_SAMPLE_LOOP;
BASS_MUSIC_3D = BASS_SAMPLE_3D;
BASS_MUSIC_FX = BASS_SAMPLE_FX;
BASS_MUSIC_AUTOFREE = BASS_STREAM_AUTOFREE;
BASS_MUSIC_DECODE = BASS_STREAM_DECODE;
BASS_MUSIC_PRESCAN = BASS_STREAM_PRESCAN;
BASS_MUSIC_CALCLEN = BASS_MUSIC_PRESCAN;
BASS_MUSIC_RAMP = $200;
BASS_MUSIC_RAMPS = $400;
BASS_MUSIC_SURROUND = $800;
BASS_MUSIC_SURROUND2 = $1000;
BASS_MUSIC_FT2PAN = $2000;
BASS_MUSIC_FT2MOD = $2000;
BASS_MUSIC_PT1MOD = $4000;
BASS_MUSIC_NONINTER = $10000;
BASS_MUSIC_SINCINTER = $800000;
BASS_MUSIC_POSRESET = $8000;
BASS_MUSIC_POSRESETEX = $400000;
BASS_MUSIC_STOPBACK = $80000;
BASS_MUSIC_NOSAMPLE = $100000;
BASS_SPEAKER_FRONT = $1000000;
BASS_SPEAKER_REAR = $2000000;
BASS_SPEAKER_CENLFE = $3000000;
BASS_SPEAKER_SIDE = $4000000;
BASS_SPEAKER_LEFT = $10000000;
BASS_SPEAKER_RIGHT = $20000000;
BASS_SPEAKER_FRONTLEFT = BASS_SPEAKER_FRONT or BASS_SPEAKER_LEFT;
BASS_SPEAKER_FRONTRIGHT = BASS_SPEAKER_FRONT or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_REARLEFT = BASS_SPEAKER_REAR or BASS_SPEAKER_LEFT;
BASS_SPEAKER_REARRIGHT = BASS_SPEAKER_REAR or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_CENTER = BASS_SPEAKER_CENLFE or BASS_SPEAKER_LEFT;
BASS_SPEAKER_LFE = BASS_SPEAKER_CENLFE or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_SIDELEFT = BASS_SPEAKER_SIDE or BASS_SPEAKER_LEFT;
BASS_SPEAKER_SIDERIGHT = BASS_SPEAKER_SIDE or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_REAR2 = BASS_SPEAKER_SIDE;
BASS_SPEAKER_REAR2LEFT = BASS_SPEAKER_SIDELEFT;
BASS_SPEAKER_REAR2RIGHT = BASS_SPEAKER_SIDERIGHT;
BASS_ASYNCFILE = $40000000;
BASS_UNICODE = $80000000;
BASS_RECORD_PAUSE = $8000;
BASS_VAM_HARDWARE = 1;
BASS_VAM_SOFTWARE = 2;
BASS_VAM_TERM_TIME = 4;
BASS_VAM_TERM_DIST = 8;
BASS_VAM_TERM_PRIO = 16;
BASS_ORIGRES_FLOAT = $10000;
BASS_CTYPE_SAMPLE = 1;
BASS_CTYPE_RECORD = 2;
BASS_CTYPE_STREAM = $10000;
BASS_CTYPE_STREAM_VORBIS = $10002;
BASS_CTYPE_STREAM_OGG = $10002;
BASS_CTYPE_STREAM_MP1 = $10003;
BASS_CTYPE_STREAM_MP2 = $10004;
BASS_CTYPE_STREAM_MP3 = $10005;
BASS_CTYPE_STREAM_AIFF = $10006;
BASS_CTYPE_STREAM_CA = $10007;
BASS_CTYPE_STREAM_MF = $10008;
BASS_CTYPE_STREAM_AM = $10009;
BASS_CTYPE_STREAM_SAMPLE = $1000a;
BASS_CTYPE_STREAM_DUMMY = $18000;
BASS_CTYPE_STREAM_DEVICE = $18001;
BASS_CTYPE_STREAM_WAV = $40000;
BASS_CTYPE_STREAM_WAV_PCM = $50001;
BASS_CTYPE_STREAM_WAV_FLOAT = $50003;
BASS_CTYPE_MUSIC_MOD = $20000;
BASS_CTYPE_MUSIC_MTM = $20001;
BASS_CTYPE_MUSIC_S3M = $20002;
BASS_CTYPE_MUSIC_XM = $20003;
BASS_CTYPE_MUSIC_IT = $20004;
BASS_CTYPE_MUSIC_MO3 = $00100;
BASS_PLUGIN_PROC = 1;
BASS_3DMODE_NORMAL = 0;
BASS_3DMODE_RELATIVE = 1;
BASS_3DMODE_OFF = 2;
BASS_3DALG_DEFAULT = 0;
BASS_3DALG_OFF = 1;
BASS_3DALG_FULL = 2;
BASS_3DALG_LIGHT = 3;
EAX_ENVIRONMENT_GENERIC = 0;
EAX_ENVIRONMENT_PADDEDCELL = 1;
EAX_ENVIRONMENT_ROOM = 2;
EAX_ENVIRONMENT_BATHROOM = 3;
EAX_ENVIRONMENT_LIVINGROOM = 4;
EAX_ENVIRONMENT_STONEROOM = 5;
EAX_ENVIRONMENT_AUDITORIUM = 6;
EAX_ENVIRONMENT_CONCERTHALL = 7;
EAX_ENVIRONMENT_CAVE = 8;
EAX_ENVIRONMENT_ARENA = 9;
EAX_ENVIRONMENT_HANGAR = 10;
EAX_ENVIRONMENT_CARPETEDHALLWAY = 11;
EAX_ENVIRONMENT_HALLWAY = 12;
EAX_ENVIRONMENT_STONECORRIDOR = 13;
EAX_ENVIRONMENT_ALLEY = 14;
EAX_ENVIRONMENT_FOREST = 15;
EAX_ENVIRONMENT_CITY = 16;
EAX_ENVIRONMENT_MOUNTAINS = 17;
EAX_ENVIRONMENT_QUARRY = 18;
EAX_ENVIRONMENT_PLAIN = 19;
EAX_ENVIRONMENT_PARKINGLOT = 20;
EAX_ENVIRONMENT_SEWERPIPE = 21;
EAX_ENVIRONMENT_UNDERWATER = 22;
EAX_ENVIRONMENT_DRUGGED = 23;
EAX_ENVIRONMENT_DIZZY = 24;
EAX_ENVIRONMENT_PSYCHOTIC = 25;
EAX_ENVIRONMENT_COUNT = 26;
BASS_STREAMPROC_END = $80000000;
STREAMFILE_NOBUFFER = 0;
STREAMFILE_BUFFER = 1;
STREAMFILE_BUFFERPUSH = 2;
BASS_FILEDATA_END = 0;
BASS_FILEPOS_CURRENT = 0;
BASS_FILEPOS_DECODE = BASS_FILEPOS_CURRENT;
BASS_FILEPOS_DOWNLOAD = 1;
BASS_FILEPOS_END = 2;
BASS_FILEPOS_START = 3;
BASS_FILEPOS_CONNECTED = 4;
BASS_FILEPOS_BUFFER = 5;
BASS_FILEPOS_SOCKET = 6;
BASS_FILEPOS_ASYNCBUF = 7;
BASS_FILEPOS_SIZE = 8;
BASS_FILEPOS_BUFFERING = 9;
BASS_FILEPOS_AVAILABLE = 10;
BASS_SYNC_POS = 0;
BASS_SYNC_END = 2;
BASS_SYNC_META = 4;
BASS_SYNC_SLIDE = 5;
BASS_SYNC_STALL = 6;
BASS_SYNC_DOWNLOAD = 7;
BASS_SYNC_FREE = 8;
BASS_SYNC_SETPOS = 11;
BASS_SYNC_MUSICPOS = 10;
BASS_SYNC_MUSICINST = 1;
BASS_SYNC_MUSICFX = 3;
BASS_SYNC_OGG_CHANGE = 12;
BASS_SYNC_DEV_FAIL = 14;
BASS_SYNC_DEV_FORMAT = 15;
BASS_SYNC_THREAD = $20000000;
BASS_SYNC_MIXTIME = $40000000;
BASS_SYNC_ONETIME = $80000000;
BASS_ACTIVE_STOPPED = 0;
BASS_ACTIVE_PLAYING = 1;
BASS_ACTIVE_STALLED = 2;
BASS_ACTIVE_PAUSED = 3;
BASS_ACTIVE_PAUSED_DEVICE = 4;
BASS_ATTRIB_FREQ = 1;
BASS_ATTRIB_VOL = 2;
BASS_ATTRIB_PAN = 3;
BASS_ATTRIB_EAXMIX = 4;
BASS_ATTRIB_NOBUFFER = 5;
BASS_ATTRIB_VBR = 6;
BASS_ATTRIB_CPU = 7;
BASS_ATTRIB_SRC = 8;
BASS_ATTRIB_NET_RESUME = 9;
BASS_ATTRIB_SCANINFO = 10;
BASS_ATTRIB_NORAMP = 11;
BASS_ATTRIB_BITRATE = 12;
BASS_ATTRIB_BUFFER = 13;
BASS_ATTRIB_GRANULE = 14;
BASS_ATTRIB_USER = 15;
BASS_ATTRIB_TAIL = 16;
BASS_ATTRIB_PUSH_LIMIT = 17;
BASS_ATTRIB_DOWNLOADPROC = 18;
BASS_ATTRIB_VOLDSP = 19;
BASS_ATTRIB_VOLDSP_PRIORITY = 20;
BASS_ATTRIB_MUSIC_AMPLIFY = $100;
BASS_ATTRIB_MUSIC_PANSEP = $101;
BASS_ATTRIB_MUSIC_PSCALER = $102;
BASS_ATTRIB_MUSIC_BPM = $103;
BASS_ATTRIB_MUSIC_SPEED = $104;
BASS_ATTRIB_MUSIC_VOL_GLOBAL = $105;
BASS_ATTRIB_MUSIC_ACTIVE = $106;
BASS_ATTRIB_MUSIC_VOL_CHAN = $200;
BASS_ATTRIB_MUSIC_VOL_INST = $300;
BASS_SLIDE_LOG = $1000000;
BASS_DATA_AVAILABLE = 0;
BASS_DATA_NOREMOVE = $10000000;
BASS_DATA_FIXED = $20000000;
BASS_DATA_FLOAT = $40000000;
BASS_DATA_FFT256 = $80000000;
BASS_DATA_FFT512 = $80000001;
BASS_DATA_FFT1024 = $80000002;
BASS_DATA_FFT2048 = $80000003;
BASS_DATA_FFT4096 = $80000004;
BASS_DATA_FFT8192 = $80000005;
BASS_DATA_FFT16384 = $80000006;
BASS_DATA_FFT32768 = $80000007;
BASS_DATA_FFT_INDIVIDUAL = $10;
BASS_DATA_FFT_NOWINDOW = $20;
BASS_DATA_FFT_REMOVEDC = $40;
BASS_DATA_FFT_COMPLEX = $80;
BASS_DATA_FFT_NYQUIST = $100;
BASS_LEVEL_MONO = 1;
BASS_LEVEL_STEREO = 2;
BASS_LEVEL_RMS = 4;
BASS_LEVEL_VOLPAN = 8;
BASS_LEVEL_NOREMOVE = 16;
BASS_TAG_ID3 = 0;
BASS_TAG_ID3V2 = 1;
BASS_TAG_OGG = 2;
BASS_TAG_HTTP = 3;
BASS_TAG_ICY = 4;
BASS_TAG_META = 5;
BASS_TAG_APE = 6;
BASS_TAG_MP4 = 7;
BASS_TAG_WMA = 8;
BASS_TAG_VENDOR = 9;
BASS_TAG_LYRICS3 = 10;
BASS_TAG_CA_CODEC = 11;
BASS_TAG_MF = 13;
BASS_TAG_WAVEFORMAT = 14;
BASS_TAG_AM_NAME = 16;
BASS_TAG_ID3V2_2 = 17;
BASS_TAG_AM_MIME = 18;
BASS_TAG_LOCATION = 19;
BASS_TAG_RIFF_INFO = $100;
BASS_TAG_RIFF_BEXT = $101;
BASS_TAG_RIFF_CART = $102;
BASS_TAG_RIFF_DISP = $103;
BASS_TAG_RIFF_CUE = $104;
BASS_TAG_RIFF_SMPL = $105;
BASS_TAG_APE_BINARY = $1000;
BASS_TAG_MUSIC_NAME = $10000;
BASS_TAG_MUSIC_MESSAGE = $10001;
BASS_TAG_MUSIC_ORDERS = $10002;
BASS_TAG_MUSIC_AUTH = $10003;
BASS_TAG_MUSIC_INST = $10100;
BASS_TAG_MUSIC_CHAN = $10200;
BASS_TAG_MUSIC_SAMPLE = $10300;
BASS_POS_BYTE = 0;
BASS_POS_MUSIC_ORDER = 1;
BASS_POS_OGG = 3;
BASS_POS_END = $10;
BASS_POS_LOOP = $11;
BASS_POS_FLUSH = $1000000;
BASS_POS_RESET = $2000000;
BASS_POS_RELATIVE = $4000000;
BASS_POS_INEXACT = $8000000;
BASS_POS_DECODE = $10000000;
BASS_POS_DECODETO = $20000000;
BASS_POS_SCAN = $40000000;
BASS_NODEVICE = $20000;
BASS_INPUT_OFF = $10000;
BASS_INPUT_ON = $20000;
BASS_INPUT_TYPE_MASK = $FF000000;
BASS_INPUT_TYPE_UNDEF = $00000000;
BASS_INPUT_TYPE_DIGITAL = $01000000;
BASS_INPUT_TYPE_LINE = $02000000;
BASS_INPUT_TYPE_MIC = $03000000;
BASS_INPUT_TYPE_SYNTH = $04000000;
BASS_INPUT_TYPE_CD = $05000000;
BASS_INPUT_TYPE_PHONE = $06000000;
BASS_INPUT_TYPE_SPEAKER = $07000000;
BASS_INPUT_TYPE_WAVE = $08000000;
BASS_INPUT_TYPE_AUX = $09000000;
BASS_INPUT_TYPE_ANALOG = $0A000000;
BASS_FX_DX8_CHORUS = 0;
BASS_FX_DX8_COMPRESSOR = 1;
BASS_FX_DX8_DISTORTION = 2;
BASS_FX_DX8_ECHO = 3;
BASS_FX_DX8_FLANGER = 4;
BASS_FX_DX8_GARGLE = 5;
BASS_FX_DX8_I3DL2REVERB = 6;
BASS_FX_DX8_PARAMEQ = 7;
BASS_FX_DX8_REVERB = 8;
BASS_FX_VOLUME = 9;
BASS_DX8_PHASE_NEG_180 = 0;
BASS_DX8_PHASE_NEG_90 = 1;
BASS_DX8_PHASE_ZERO = 2;
BASS_DX8_PHASE_90 = 3;
BASS_DX8_PHASE_180 = 4;
STREAMPROC_DUMMY = Pointer(0);
STREAMPROC_PUSH = Pointer(-1);
STREAMPROC_DEVICE = Pointer(-2);
STREAMPROC_DEVICE_3D = Pointer(-3);

Variables

BASS_SetConfig: function(option, value: DWORD): BOOL; stdcall;
BASS_GetConfig: function(option: DWORD): DWORD; stdcall;
BASS_SetConfigPtr: function(option: DWORD; value: Pointer): BOOL; stdcall;
BASS_GetConfigPtr: function(option: DWORD): Pointer; stdcall;
BASS_GetVersion: function(): DWORD; stdcall;
BASS_ErrorGetCode: function(): LongInt; stdcall;
BASS_GetDeviceInfo: function(device: DWORD; var info: BASS_DEVICEINFO): BOOL; stdcall;
BASS_Init: function(device: LongInt; freq, flags: DWORD; win: HWND; clsid: PGUID): BOOL; stdcall;
BASS_SetDevice: function(device: DWORD): BOOL; stdcall;
BASS_GetDevice: function():DWORD; stdcall;
BASS_Free: function():BOOL; stdcall;
BASS_GetDSoundObject: function(obj: DWORD): Pointer; stdcall;
BASS_GetInfo: function(var info: BASS_INFO): BOOL; stdcall;
BASS_Update: function(length: DWORD): BOOL; stdcall;
BASS_GetCPU: function():Single; stdcall;
BASS_Start: function():BOOL; stdcall;
BASS_Stop: function():BOOL; stdcall;
BASS_Pause: function():BOOL; stdcall;
BASS_SetVolume: function(volume: Single): BOOL; stdcall;
BASS_GetVolume: function():Single; stdcall;
BASS_PluginLoad: function(filename: PChar; flags: DWORD): HPLUGIN; stdcall;
BASS_PluginFree: function(handle: HPLUGIN): BOOL; stdcall;
BASS_PluginGetInfo: function(handle: HPLUGIN): PBASS_PLUGININFO; stdcall;
BASS_Set3DFactors: function(distf, rollf, doppf: Single): BOOL; stdcall;
BASS_Get3DFactors: function(var distf, rollf, doppf: Single): BOOL; stdcall;
BASS_Set3DPosition: function(var pos, vel, front, top: BASS_3DVECTOR): BOOL; stdcall;
BASS_Get3DPosition: function(var pos, vel, front, top: BASS_3DVECTOR): BOOL; stdcall;
BASS_Apply3D: procedure(); stdcall;
BASS_SetEAXParameters: function(env: LongInt; vol, decay, damp: Single): BOOL; stdcall;
BASS_GetEAXParameters: function(var env: DWORD; var vol, decay, damp: Single): BOOL; stdcall;
BASS_MusicLoad: function(mem: BOOL; f: Pointer; offset: QWORD; length, flags, freq: DWORD): HMUSIC; stdcall;
BASS_MusicFree: function(handle: HMUSIC): BOOL; stdcall;
BASS_SampleLoad: function(mem: BOOL; f: Pointer; offset: QWORD; length, max, flags: DWORD): HSAMPLE; stdcall;
BASS_SampleCreate: function(length, freq, chans, max, flags: DWORD): HSAMPLE; stdcall;
BASS_SampleFree: function(handle: HSAMPLE): BOOL; stdcall;
BASS_SampleSetData: function(handle: HSAMPLE; buffer: Pointer): BOOL; stdcall;
BASS_SampleGetData: function(handle: HSAMPLE; buffer: Pointer): BOOL; stdcall;
BASS_SampleGetInfo: function(handle: HSAMPLE; var info: BASS_SAMPLE): BOOL; stdcall;
BASS_SampleSetInfo: function(handle: HSAMPLE; var info: BASS_SAMPLE): BOOL; stdcall;
BASS_SampleGetChannel: function(handle: HSAMPLE; onlynew: BOOL): HCHANNEL; stdcall;
BASS_SampleGetChannels: function(handle: HSAMPLE; channels: Pointer): DWORD; stdcall;
BASS_SampleStop: function(handle: HSAMPLE): BOOL; stdcall;
BASS_StreamCreate: function(freq, chans, flags: DWORD; proc: STREAMPROC; user: Pointer): HSTREAM; stdcall;
BASS_StreamCreateFile: function(mem: BOOL; f: Pointer; offset, length: QWORD; flags: DWORD): HSTREAM; stdcall;
BASS_StreamCreateURL: function(url: PAnsiChar; offset: DWORD; flags: DWORD; proc: DOWNLOADPROC; user: Pointer):HSTREAM; stdcall;
BASS_StreamCreateFileUser: function(system, flags: DWORD; var procs: BASS_FILEPROCS; user: Pointer): HSTREAM; stdcall;
BASS_StreamFree: function(handle: HSTREAM): BOOL; stdcall;
BASS_StreamGetFilePosition: function(handle: HSTREAM; mode: DWORD): QWORD; stdcall;
BASS_StreamPutData: function(handle: HSTREAM; buffer: Pointer; length: DWORD): DWORD; stdcall;
BASS_StreamPutFileData: function(handle: HSTREAM; buffer: Pointer; length: DWORD): DWORD; stdcall;
BASS_RecordGetDeviceInfo: function(device: DWORD; var info: BASS_DEVICEINFO): BOOL; stdcall;
BASS_RecordInit: function(device: LongInt):BOOL; stdcall;
BASS_RecordSetDevice: function(device: DWORD): BOOL; stdcall;
BASS_RecordGetDevice: function():DWORD; stdcall;
BASS_RecordFree: function():BOOL; stdcall;
BASS_RecordGetInfo: function(var info: BASS_RECORDINFO): BOOL; stdcall;
BASS_RecordGetInputName: function(input: LongInt): PAnsiChar; stdcall;
BASS_RecordSetInput: function(input: LongInt; flags: DWORD; volume: Single): BOOL; stdcall;
BASS_RecordGetInput: function(input: LongInt; var volume: Single): DWORD; stdcall;
BASS_RecordStart: function(freq, chans, flags: DWORD; proc: RECORDPROC; user: Pointer): HRECORD; stdcall;
BASS_ChannelBytes2Seconds: function(handle: DWORD; pos: QWORD): Double; stdcall;
BASS_ChannelSeconds2Bytes: function(handle: DWORD; pos: Double): QWORD; stdcall;
BASS_ChannelGetDevice: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelSetDevice: function(handle, device: DWORD): BOOL; stdcall;
BASS_ChannelIsActive: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelGetInfo: function(handle: DWORD; var info: BASS_CHANNELINFO):BOOL; stdcall;
BASS_ChannelGetTags: function(handle: HSTREAM; tags: DWORD): PAnsiChar; stdcall;
BASS_ChannelFlags: function(handle, flags, mask: DWORD): DWORD; stdcall;
BASS_ChannelUpdate: function(handle, length: DWORD): BOOL; stdcall;
BASS_ChannelLock: function(handle: DWORD; lock: BOOL): BOOL; stdcall;
BASS_ChannelPlay: function(handle: DWORD; restart: BOOL): BOOL; stdcall;
BASS_ChannelStop: function(handle: DWORD): BOOL; stdcall;
BASS_ChannelPause: function(handle: DWORD): BOOL; stdcall;
BASS_ChannelSetAttribute: function(handle, attrib: DWORD; value: Single): BOOL; stdcall;
BASS_ChannelGetAttribute: function(handle, attrib: DWORD; var value: Single): BOOL; stdcall;
BASS_ChannelSlideAttribute: function(handle, attrib: DWORD; value: Single; time: DWORD): BOOL; stdcall;
BASS_ChannelIsSliding: function(handle, attrib: DWORD): BOOL; stdcall;
BASS_ChannelSetAttributeEx: function(handle, attrib: DWORD; value: Pointer; size: DWORD): BOOL; stdcall;
BASS_ChannelGetAttributeEx: function(handle, attrib: DWORD; value: Pointer; size: DWORD): DWORD; stdcall;
BASS_ChannelSet3DAttributes: function(handle: DWORD; mode: LongInt; min, max: Single; iangle, oangle, outvol: LongInt): BOOL; stdcall;
BASS_ChannelGet3DAttributes: function(handle: DWORD; var mode: DWORD; var min, max: Single; var iangle, oangle, outvol: DWORD): BOOL; stdcall;
BASS_ChannelSet3DPosition: function(handle: DWORD; var pos, orient, vel: BASS_3DVECTOR): BOOL; stdcall;
BASS_ChannelGet3DPosition: function(handle: DWORD; var pos, orient, vel: BASS_3DVECTOR): BOOL; stdcall;
BASS_ChannelGetLength: function(handle, mode: DWORD): QWORD; stdcall;
BASS_ChannelSetPosition: function(handle: DWORD; pos: QWORD; mode: DWORD): BOOL; stdcall;
BASS_ChannelGetPosition: function(handle, mode: DWORD): QWORD; stdcall;
BASS_ChannelGetLevel: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelGetLevelEx: function(handle: DWORD; levels: PSingle; length: Single; flags: DWORD): BOOL; stdcall;
BASS_ChannelGetData: function(handle: DWORD; buffer: Pointer; length: DWORD): DWORD; stdcall;
BASS_ChannelSetSync: function(handle: DWORD; type_: DWORD; param: QWORD; proc: SYNCPROC; user: Pointer): HSYNC; stdcall;
BASS_ChannelRemoveSync: function(handle: DWORD; sync: HSYNC): BOOL; stdcall;
BASS_ChannelSetDSP: function(handle: DWORD; proc: DSPPROC; user: Pointer; priority: LongInt): HDSP; stdcall;
BASS_ChannelRemoveDSP: function(handle: DWORD; dsp: HDSP): BOOL; stdcall;
BASS_ChannelSetLink: function(handle, chan: DWORD): BOOL; stdcall;
BASS_ChannelRemoveLink: function(handle, chan: DWORD): BOOL; stdcall;
BASS_ChannelSetFX: function(handle, type_: DWORD; priority: LongInt): HFX; stdcall;
BASS_ChannelRemoveFX: function(handle: DWORD; fx: HFX): BOOL; stdcall;
BASS_FXSetParameters: function(handle: HFX; par: Pointer): BOOL; stdcall;
BASS_FXGetParameters: function(handle: HFX; par: Pointer): BOOL; stdcall;
BASS_FXReset: function(handle: HFX): BOOL; stdcall;
BASS_FXSetPriority: function(handle: HFX; priority: LongInt): BOOL; stdcall;

Description

Functions and Procedures

function BASS_SPEAKER_N(n: DWORD): DWORD;

external bassdll;

function BASS_SetEAXPreset(env: LongInt): BOOL;

This item has no description.

function BASS_Load(LibName: PChar ): Boolean;

This item has no description.

procedure BASS_UnLoad;

This item has no description.

function BASS_IsLoaded:boolean;

This item has no description.

Types

BOOL = LongBool;

This item has no description.

DOWNLOADPROC = procedure(buffer: Pointer; length: DWORD; user: Pointer); stdcall;

User file stream callback function. action : The action to perform, one of BASS_FILE_xxx values. param1 : Depends on "action" param2 : Depends on "action" user : The 'user' parameter value given when calling BASS_StreamCreate RETURN : Depends on "action"

DSPPROC = procedure(handle: HDSP; channel: DWORD; buffer: Pointer; length: DWORD; user: Pointer); stdcall;

Sync callback function. NOTE: a sync callback function should be very quick as other syncs cannot be processed until it has finished. If the sync is a "mixtime" sync, then other streams and MOD musics can not be mixed until it's finished either. handle : The sync that has occured channel: Channel that the sync occured in data : Additional data associated with the sync's occurance user : The 'user' parameter given when calling BASS_ChannelSetSync

DWORD = Cardinal;

This item has no description.

FILECLOSEPROC = procedure(user: Pointer); stdcall;

User file stream callback functions

FILELENPROC = function(user: Pointer): QWORD; stdcall;

This item has no description.

FILEREADPROC = function(buffer: Pointer; length: DWORD; user: Pointer): DWORD; stdcall;

This item has no description.

FILESEEKPROC = function(offset: QWORD; user: Pointer): BOOL; stdcall;

This item has no description.

HCHANNEL = DWORD;

sample handle

HDSP = DWORD;

synchronizer handle

HFX = DWORD;

DSP handle

HMUSIC = DWORD;

This item has no description.

HPLUGIN = DWORD;

effect handle

HRECORD = DWORD;

sample stream handle

HSAMPLE = DWORD;

MOD music handle

HSTREAM = DWORD;

sample playback handle

HSYNC = DWORD;

recording handle

PBASS_PLUGINFORMS = ˆTBASS_PLUGINFORMS;

This item has no description.

PBASS_PLUGININFO = ˆBASS_PLUGININFO;

This item has no description.

PTAG_APE_BINARY = ˆTAG_APE_BINARY;

Binary APEv2 tag structure

PTAG_BEXT = ˆTAG_BEXT;

BWF "bext" tag structure

PTAG_ID3 = ˆTAG_ID3;

ID3v1 tag structure

QWORD = Int64;

This item has no description.

RECORDPROC = function(handle: HRECORD; buffer: Pointer; length: DWORD; user: Pointer): BOOL; stdcall;

DSP callback function. NOTE: A DSP function should obviously be as quick as possible... other DSP functions, streams and MOD musics can not be processed until it's finished. handle : The DSP handle channel: Channel that the DSP is being applied to buffer : Buffer to apply the DSP to length : Number of bytes in the buffer user : The 'user' parameter given when calling BASS_ChannelSetDSP

STREAMPROC = function(handle: HSTREAM; buffer: Pointer; length: DWORD; user: Pointer): DWORD; stdcall;

callback function types

SYNCPROC = procedure(handle: HSYNC; channel, data: DWORD; user: Pointer); stdcall;

Internet stream download callback function. buffer : Buffer containing the downloaded data... NULL=end of download length : Number of bytes in the buffer user : The 'user' parameter value given when calling BASS_StreamCreateURL

TBASSModuleHandle = HINST;

This function is defined in the implementation part of this unit. It is not part of BASS.DLL but an extra function which makes it easier to set the predefined EAX environments. env : a EAX_ENVIRONMENT_xxx constant

TBASS_PLUGINFORMS = array[0..maxInt div sizeOf(BASS_PLUGINFORM) - 1] of BASS_PLUGINFORM;

This item has no description.

Constants

bassdll = 'bass32.dll';

libraries

BASSVERSION = $204;

This item has no description.

BASSVERSIONTEXT = '2.4';

API version

DW_ERROR = Cardinal(-1);

Use these to test for error from functions that return a DWORD or QWORD

QW_ERROR = Int64(-1);

-1 (DWORD)

BASS_OK = 0;

-1 (QWORD) Error codes returned by BASS_ErrorGetCode()

BASS_ERROR_MEM = 1;

all is OK

BASS_ERROR_FILEOPEN = 2;

memory error

BASS_ERROR_DRIVER = 3;

can't open the file

BASS_ERROR_BUFLOST = 4;

can't find a free sound driver

BASS_ERROR_HANDLE = 5;

the sample buffer was lost

BASS_ERROR_FORMAT = 6;

invalid handle

BASS_ERROR_POSITION = 7;

unsupported sample format

BASS_ERROR_INIT = 8;

invalid position

BASS_ERROR_START = 9;

BASS_Init has not been successfully called

BASS_ERROR_SSL = 10;

BASS_Start has not been successfully called

BASS_ERROR_REINIT = 11;

SSL/HTTPS support isn't available

BASS_ERROR_ALREADY = 14;

device needs to be reinitialized

BASS_ERROR_NOTAUDIO = 17;

already initialized/paused/whatever

BASS_ERROR_NOCHAN = 18;

file does not contain audio

BASS_ERROR_ILLTYPE = 19;

can't get a free channel

BASS_ERROR_ILLPARAM = 20;

an illegal type was specified

BASS_ERROR_NO3D = 21;

an illegal parameter was specified

BASS_ERROR_NOEAX = 22;

no 3D support

BASS_ERROR_DEVICE = 23;

no EAX support

BASS_ERROR_NOPLAY = 24;

illegal device number

BASS_ERROR_FREQ = 25;

not playing

BASS_ERROR_NOTFILE = 27;

illegal sample rate

BASS_ERROR_NOHW = 29;

the stream is not a file stream

BASS_ERROR_EMPTY = 31;

no hardware voices available

BASS_ERROR_NONET = 32;

the file has no sample data

BASS_ERROR_CREATE = 33;

no internet connection could be opened

BASS_ERROR_NOFX = 34;

couldn't create the file

BASS_ERROR_NOTAVAIL = 37;

effects are not available

BASS_ERROR_DECODE = 38;

requested data/action is not available

BASS_ERROR_DX = 39;

the channel is/isn't a "decoding channel"

BASS_ERROR_TIMEOUT = 40;

a sufficient DirectX version is not installed

BASS_ERROR_FILEFORM = 41;

connection timedout

BASS_ERROR_SPEAKER = 42;

unsupported file format

BASS_ERROR_VERSION = 43;

unavailable speaker

BASS_ERROR_CODEC = 44;

invalid BASS version (used by add-ons)

BASS_ERROR_ENDED = 45;

codec is not available/supported

BASS_ERROR_BUSY = 46;

the channel/file has ended

BASS_ERROR_UNSTREAMABLE = 47;

the device is busy

BASS_ERROR_PROTOCOL = 48;

unstreamable file

BASS_ERROR_DENIED = 49;

unsupported protocol

BASS_ERROR_UNKNOWN = -1;

access denied

BASS_CONFIG_BUFFER = 0;

some other mystery problem BASS_SetConfig options

BASS_CONFIG_UPDATEPERIOD = 1;

This item has no description.

BASS_CONFIG_GVOL_SAMPLE = 4;

This item has no description.

BASS_CONFIG_GVOL_STREAM = 5;

This item has no description.

BASS_CONFIG_GVOL_MUSIC = 6;

This item has no description.

BASS_CONFIG_CURVE_VOL = 7;

This item has no description.

BASS_CONFIG_CURVE_PAN = 8;

This item has no description.

BASS_CONFIG_FLOATDSP = 9;

This item has no description.

BASS_CONFIG_3DALGORITHM = 10;

This item has no description.

BASS_CONFIG_NET_TIMEOUT = 11;

This item has no description.

BASS_CONFIG_NET_BUFFER = 12;

This item has no description.

BASS_CONFIG_PAUSE_NOPLAY = 13;

This item has no description.

BASS_CONFIG_NET_PREBUF = 15;

This item has no description.

BASS_CONFIG_NET_PASSIVE = 18;

This item has no description.

BASS_CONFIG_REC_BUFFER = 19;

This item has no description.

BASS_CONFIG_NET_PLAYLIST = 21;

This item has no description.

BASS_CONFIG_MUSIC_VIRTUAL = 22;

This item has no description.

BASS_CONFIG_VERIFY = 23;

This item has no description.

BASS_CONFIG_UPDATETHREADS = 24;

This item has no description.

BASS_CONFIG_DEV_BUFFER = 27;

This item has no description.

BASS_CONFIG_REC_LOOPBACK = 28;

This item has no description.

BASS_CONFIG_VISTA_TRUEPOS = 30;

This item has no description.

BASS_CONFIG_IOS_SESSION = 34;

This item has no description.

BASS_CONFIG_IOS_MIXAUDIO = 34;

This item has no description.

BASS_CONFIG_DEV_DEFAULT = 36;

This item has no description.

BASS_CONFIG_NET_READTIMEOUT = 37;

This item has no description.

BASS_CONFIG_VISTA_SPEAKERS = 38;

This item has no description.

BASS_CONFIG_IOS_SPEAKER = 39;

This item has no description.

BASS_CONFIG_MF_DISABLE = 40;

This item has no description.

BASS_CONFIG_HANDLES = 41;

This item has no description.

BASS_CONFIG_UNICODE = 42;

This item has no description.

BASS_CONFIG_SRC = 43;

This item has no description.

BASS_CONFIG_SRC_SAMPLE = 44;

This item has no description.

BASS_CONFIG_ASYNCFILE_BUFFER = 45;

This item has no description.

BASS_CONFIG_OGG_PRESCAN = 47;

This item has no description.

BASS_CONFIG_MF_VIDEO = 48;

This item has no description.

BASS_CONFIG_AIRPLAY = 49;

This item has no description.

BASS_CONFIG_DEV_NONSTOP = 50;

This item has no description.

BASS_CONFIG_IOS_NOCATEGORY = 51;

This item has no description.

BASS_CONFIG_VERIFY_NET = 52;

This item has no description.

BASS_CONFIG_DEV_PERIOD = 53;

This item has no description.

BASS_CONFIG_FLOAT = 54;

This item has no description.

BASS_CONFIG_NET_SEEK = 56;

This item has no description.

BASS_CONFIG_AM_DISABLE = 58;

This item has no description.

BASS_CONFIG_NET_PLAYLIST_DEPTH = 59;

This item has no description.

BASS_CONFIG_NET_PREBUF_WAIT = 60;

This item has no description.

BASS_CONFIG_ANDROID_SESSIONID = 62;

This item has no description.

BASS_CONFIG_WASAPI_PERSIST = 65;

This item has no description.

BASS_CONFIG_REC_WASAPI = 66;

This item has no description.

BASS_CONFIG_ANDROID_AAUDIO = 67;

This item has no description.

BASS_CONFIG_SAMPLE_ONEHANDLE = 69;

This item has no description.

BASS_CONFIG_NET_META = 71;

This item has no description.

BASS_CONFIG_NET_RESTRATE = 72;

This item has no description.

BASS_CONFIG_REC_DEFAULT = 73;

This item has no description.

BASS_CONFIG_NORAMP = 74;

This item has no description.

BASS_CONFIG_NET_AGENT = 16;

BASS_SetConfigPtr options

BASS_CONFIG_NET_PROXY = 17;

This item has no description.

BASS_CONFIG_ANDROID_JAVAVM = 63;

This item has no description.

BASS_CONFIG_LIBSSL = 64;

This item has no description.

BASS_CONFIG_FILENAME = 75;

This item has no description.

BASS_CONFIG_THREAD = $40000000;

This item has no description.

BASS_IOS_SESSION_MIX = 1;

flag: thread-specific setting BASS_CONFIG_IOS_SESSION flags

BASS_IOS_SESSION_DUCK = 2;

This item has no description.

BASS_IOS_SESSION_AMBIENT = 4;

This item has no description.

BASS_IOS_SESSION_SPEAKER = 8;

This item has no description.

BASS_IOS_SESSION_DISABLE = 16;

This item has no description.

BASS_IOS_SESSION_DEACTIVATE = 32;

This item has no description.

BASS_IOS_SESSION_AIRPLAY = 64;

This item has no description.

BASS_IOS_SESSION_BTHFP = 128;

This item has no description.

BASS_IOS_SESSION_BTA2DP = $100;

This item has no description.

BASS_DEVICE_8BITS = 1;

BASS_Init flags

BASS_DEVICE_MONO = 2;

unused

BASS_DEVICE_3D = 4;

mono

BASS_DEVICE_16BITS = 8;

unused

BASS_DEVICE_REINIT = 128;

limit output to 16-bit

BASS_DEVICE_LATENCY = $100;

reinitialize

BASS_DEVICE_CPSPEAKERS = $400;

unused

BASS_DEVICE_SPEAKERS = $800;

unused

BASS_DEVICE_NOSPEAKER = $1000;

force enabling of speaker assignment

BASS_DEVICE_DMIX = $2000;

ignore speaker arrangement

BASS_DEVICE_FREQ = $4000;

use ALSA "dmix" plugin

BASS_DEVICE_STEREO = $8000;

set device sample rate

BASS_DEVICE_AUDIOTRACK = $20000;

limit output to stereo

BASS_DEVICE_DSOUND = $40000;

use AudioTrack output

BASS_DEVICE_SOFTWARE = $80000;

use DirectSound output

BASS_OBJECT_DS = 1;

disable hardware/fastpath output DirectSound interfaces (for use with BASS_GetDSoundObject)

BASS_OBJECT_DS3DL = 2;

IDirectSound

BASS_DEVICE_ENABLED = 1;

IDirectSound3DListener BASS_DEVICEINFO flags

BASS_DEVICE_DEFAULT = 2;

This item has no description.

BASS_DEVICE_INIT = 4;

This item has no description.

BASS_DEVICE_LOOPBACK = 8;

This item has no description.

BASS_DEVICE_DEFAULTCOM = 128;

This item has no description.

BASS_DEVICE_TYPE_MASK = $ff000000;

This item has no description.

BASS_DEVICE_TYPE_NETWORK = $01000000;

This item has no description.

BASS_DEVICE_TYPE_SPEAKERS = $02000000;

This item has no description.

BASS_DEVICE_TYPE_LINE = $03000000;

This item has no description.

BASS_DEVICE_TYPE_HEADPHONES = $04000000;

This item has no description.

BASS_DEVICE_TYPE_MICROPHONE = $05000000;

This item has no description.

BASS_DEVICE_TYPE_HEADSET = $06000000;

This item has no description.

BASS_DEVICE_TYPE_HANDSET = $07000000;

This item has no description.

BASS_DEVICE_TYPE_DIGITAL = $08000000;

This item has no description.

BASS_DEVICE_TYPE_SPDIF = $09000000;

This item has no description.

BASS_DEVICE_TYPE_HDMI = $0a000000;

This item has no description.

BASS_DEVICE_TYPE_DISPLAYPORT = $40000000;

This item has no description.

BASS_DEVICES_AIRPLAY = $1000000;

BASS_GetDeviceInfo flags

DSCAPS_EMULDRIVER = $00000020;

BASS_INFO flags (from DSOUND.H)

DSCAPS_CERTIFIED = $00000040;

device does not have hardware DirectSound support

DSCAPS_HARDWARE = $80000000;

device driver has been certified by Microsoft

DSCCAPS_EMULDRIVER = DSCAPS_EMULDRIVER;

hardware mixed BASS_RECORDINFO flags (from DSOUND.H)

DSCCAPS_CERTIFIED = DSCAPS_CERTIFIED;

device does not have hardware DirectSound recording support

BASS_SAMPLE_8BITS = 1;

WAVE_FORMAT_1M08 = $00000001; // 11.025 kHz, Mono, 8-bit WAVE_FORMAT_1S08 = $00000002; // 11.025 kHz, Stereo, 8-bit WAVE_FORMAT_1M16 = $00000004; // 11.025 kHz, Mono, 16-bit WAVE_FORMAT_1S16 = $00000008; // 11.025 kHz, Stereo, 16-bit WAVE_FORMAT_2M08 = $00000010; // 22.05 kHz, Mono, 8-bit WAVE_FORMAT_2S08 = $00000020; // 22.05 kHz, Stereo, 8-bit WAVE_FORMAT_2M16 = $00000040; // 22.05 kHz, Mono, 16-bit WAVE_FORMAT_2S16 = $00000080; // 22.05 kHz, Stereo, 16-bit WAVE_FORMAT_4M08 = $00000100; // 44.1 kHz, Mono, 8-bit WAVE_FORMAT_4S08 = $00000200; // 44.1 kHz, Stereo, 8-bit WAVE_FORMAT_4M16 = $00000400; // 44.1 kHz, Mono, 16-bit WAVE_FORMAT_4S16 = $00000800; // 44.1 kHz, Stereo, 16-bit

BASS_SAMPLE_FLOAT = 256;

8 bit

BASS_SAMPLE_MONO = 2;

32 bit floating-point

BASS_SAMPLE_LOOP = 4;

mono

BASS_SAMPLE_3D = 8;

looped

BASS_SAMPLE_SOFTWARE = 16;

3D functionality

BASS_SAMPLE_MUTEMAX = 32;

unused

BASS_SAMPLE_VAM = 64;

mute at max distance (3D only)

BASS_SAMPLE_FX = 128;

unused

BASS_SAMPLE_OVER_VOL = $10000;

unused

BASS_SAMPLE_OVER_POS = $20000;

override lowest volume

BASS_SAMPLE_OVER_DIST = $30000;

override longest playing

BASS_STREAM_PRESCAN = $20000;

override furthest from listener (3D only)

BASS_STREAM_AUTOFREE = $40000;

scan file for accurate seeking and length

BASS_STREAM_RESTRATE = $80000;

automatically free the stream when it stops/ends

BASS_STREAM_BLOCK = $100000;

restrict the download rate of internet file streams

BASS_STREAM_DECODE = $200000;

download/play internet file stream in small blocks

BASS_STREAM_STATUS = $800000;

don't play the stream, only decode

BASS_MP3_IGNOREDELAY = $200;

give server status info (HTTP/ICY tags) in DOWNLOADPROC

BASS_MP3_SETPOS = BASS_STREAM_PRESCAN;

ignore LAME/Xing/VBRI/iTunes delay & padding info

BASS_MUSIC_FLOAT = BASS_SAMPLE_FLOAT;

This item has no description.

BASS_MUSIC_MONO = BASS_SAMPLE_MONO;

This item has no description.

BASS_MUSIC_LOOP = BASS_SAMPLE_LOOP;

This item has no description.

BASS_MUSIC_3D = BASS_SAMPLE_3D;

This item has no description.

BASS_MUSIC_FX = BASS_SAMPLE_FX;

This item has no description.

BASS_MUSIC_AUTOFREE = BASS_STREAM_AUTOFREE;

This item has no description.

BASS_MUSIC_DECODE = BASS_STREAM_DECODE;

This item has no description.

BASS_MUSIC_PRESCAN = BASS_STREAM_PRESCAN;

This item has no description.

BASS_MUSIC_CALCLEN = BASS_MUSIC_PRESCAN;

calculate playback length

BASS_MUSIC_RAMP = $200;

This item has no description.

BASS_MUSIC_RAMPS = $400;

normal ramping

BASS_MUSIC_SURROUND = $800;

sensitive ramping

BASS_MUSIC_SURROUND2 = $1000;

surround sound

BASS_MUSIC_FT2PAN = $2000;

surround sound (mode 2)

BASS_MUSIC_FT2MOD = $2000;

apply FastTracker 2 panning to XM files

BASS_MUSIC_PT1MOD = $4000;

play .MOD as FastTracker 2 does

BASS_MUSIC_NONINTER = $10000;

play .MOD as ProTracker 1 does

BASS_MUSIC_SINCINTER = $800000;

non-interpolated sample mixing

BASS_MUSIC_POSRESET = $8000;

sinc interpolated sample mixing

BASS_MUSIC_POSRESETEX = $400000;

stop all notes when moving position

BASS_MUSIC_STOPBACK = $80000;

stop all notes and reset bmp/etc when moving position

BASS_MUSIC_NOSAMPLE = $100000;

stop the music on a backwards jump effect

BASS_SPEAKER_FRONT = $1000000;

don't load the samples Speaker assignment flags

BASS_SPEAKER_REAR = $2000000;

front speakers

BASS_SPEAKER_CENLFE = $3000000;

rear speakers

BASS_SPEAKER_SIDE = $4000000;

center & LFE speakers (5.1)

BASS_SPEAKER_LEFT = $10000000;

side speakers (7.1)

BASS_SPEAKER_RIGHT = $20000000;

modifier: left

BASS_SPEAKER_FRONTLEFT = BASS_SPEAKER_FRONT or BASS_SPEAKER_LEFT;

modifier: right

BASS_SPEAKER_FRONTRIGHT = BASS_SPEAKER_FRONT or BASS_SPEAKER_RIGHT;

This item has no description.

BASS_SPEAKER_REARLEFT = BASS_SPEAKER_REAR or BASS_SPEAKER_LEFT;

This item has no description.

BASS_SPEAKER_REARRIGHT = BASS_SPEAKER_REAR or BASS_SPEAKER_RIGHT;

This item has no description.

BASS_SPEAKER_CENTER = BASS_SPEAKER_CENLFE or BASS_SPEAKER_LEFT;

This item has no description.

BASS_SPEAKER_LFE = BASS_SPEAKER_CENLFE or BASS_SPEAKER_RIGHT;

This item has no description.

BASS_SPEAKER_SIDELEFT = BASS_SPEAKER_SIDE or BASS_SPEAKER_LEFT;

This item has no description.

BASS_SPEAKER_SIDERIGHT = BASS_SPEAKER_SIDE or BASS_SPEAKER_RIGHT;

This item has no description.

BASS_SPEAKER_REAR2 = BASS_SPEAKER_SIDE;

This item has no description.

BASS_SPEAKER_REAR2LEFT = BASS_SPEAKER_SIDELEFT;

This item has no description.

BASS_SPEAKER_REAR2RIGHT = BASS_SPEAKER_SIDERIGHT;

This item has no description.

BASS_ASYNCFILE = $40000000;

This item has no description.

BASS_UNICODE = $80000000;

This item has no description.

BASS_RECORD_PAUSE = $8000;

This item has no description.

BASS_VAM_HARDWARE = 1;

start recording paused DX7 voice allocation & management flags

BASS_VAM_SOFTWARE = 2;

Play the sample in hardware. If no hardware voices are available then the "play" call will fail

BASS_VAM_TERM_TIME = 4;

These flags enable hardware resource stealing... if the hardware has no available voices, a currently playing buffer will be stopped to make room for the new buffer. NOTE: only samples loaded/created with the BASS_SAMPLE_VAM flag are considered for termination by the DX7 voice management.

BASS_VAM_TERM_DIST = 8;

If there are no free hardware voices, the buffer to be terminated will be the one with the least time left to play.

BASS_VAM_TERM_PRIO = 16;

If there are no free hardware voices, the buffer to be terminated will be one that was loaded/created with the BASS_SAMPLE_MUTEMAX flag and is beyond it's max distance. If there are no buffers that match this criteria, then the "play" call will fail.

BASS_ORIGRES_FLOAT = $10000;

This item has no description.

BASS_CTYPE_SAMPLE = 1;

BASS_CHANNELINFO types

BASS_CTYPE_RECORD = 2;

This item has no description.

BASS_CTYPE_STREAM = $10000;

This item has no description.

BASS_CTYPE_STREAM_VORBIS = $10002;

This item has no description.

BASS_CTYPE_STREAM_OGG = $10002;

This item has no description.

BASS_CTYPE_STREAM_MP1 = $10003;

This item has no description.

BASS_CTYPE_STREAM_MP2 = $10004;

This item has no description.

BASS_CTYPE_STREAM_MP3 = $10005;

This item has no description.

BASS_CTYPE_STREAM_AIFF = $10006;

This item has no description.

BASS_CTYPE_STREAM_CA = $10007;

This item has no description.

BASS_CTYPE_STREAM_MF = $10008;

This item has no description.

BASS_CTYPE_STREAM_AM = $10009;

This item has no description.

BASS_CTYPE_STREAM_SAMPLE = $1000a;

This item has no description.

BASS_CTYPE_STREAM_DUMMY = $18000;

This item has no description.

BASS_CTYPE_STREAM_DEVICE = $18001;

This item has no description.

BASS_CTYPE_STREAM_WAV = $40000;

This item has no description.

BASS_CTYPE_STREAM_WAV_PCM = $50001;

WAVE flag (LOWORD=codec)

BASS_CTYPE_STREAM_WAV_FLOAT = $50003;

This item has no description.

BASS_CTYPE_MUSIC_MOD = $20000;

This item has no description.

BASS_CTYPE_MUSIC_MTM = $20001;

This item has no description.

BASS_CTYPE_MUSIC_S3M = $20002;

This item has no description.

BASS_CTYPE_MUSIC_XM = $20003;

This item has no description.

BASS_CTYPE_MUSIC_IT = $20004;

This item has no description.

BASS_CTYPE_MUSIC_MO3 = $00100;

This item has no description.

BASS_PLUGIN_PROC = 1;

MO3 flag BASS_PluginLoad flags

BASS_3DMODE_NORMAL = 0;

3D channel modes

BASS_3DMODE_RELATIVE = 1;

normal 3D processing

BASS_3DMODE_OFF = 2;

The channel's 3D position (position/velocity/ orientation) are relative to the listener. When the listener's position/velocity/orientation is changed with BASS_Set3DPosition, the channel's position relative to the listener does not change.

BASS_3DALG_DEFAULT = 0;

software 3D mixing algorithms (used with BASS_CONFIG_3DALGORITHM)

BASS_3DALG_OFF = 1;

default algorithm (currently translates to BASS_3DALG_OFF)

BASS_3DALG_FULL = 2;

Uses normal left and right panning. The vertical axis is ignored except for scaling of volume due to distance. Doppler shift and volume scaling are still applied, but the 3D filtering is not performed. This is the most CPU efficient software implementation, but provides no virtual 3D audio effect. Head Related Transfer Function processing will not be done. Since only normal stereo panning is used, a channel using this algorithm may be accelerated by a 2D hardware voice if no free 3D hardware voices are available.

BASS_3DALG_LIGHT = 3;

This algorithm gives the highest quality 3D audio effect, but uses more CPU. Requires Windows 98 2nd Edition or Windows 2000 that uses WDM drivers, if this mode is not available then BASS_3DALG_OFF will be used instead.

EAX_ENVIRONMENT_GENERIC = 0;

EAX environments, use with BASS_SetEAXParameters

EAX_ENVIRONMENT_PADDEDCELL = 1;

This item has no description.

EAX_ENVIRONMENT_ROOM = 2;

This item has no description.

EAX_ENVIRONMENT_BATHROOM = 3;

This item has no description.

EAX_ENVIRONMENT_LIVINGROOM = 4;

This item has no description.

EAX_ENVIRONMENT_STONEROOM = 5;

This item has no description.

EAX_ENVIRONMENT_AUDITORIUM = 6;

This item has no description.

EAX_ENVIRONMENT_CONCERTHALL = 7;

This item has no description.

EAX_ENVIRONMENT_CAVE = 8;

This item has no description.

EAX_ENVIRONMENT_ARENA = 9;

This item has no description.

EAX_ENVIRONMENT_HANGAR = 10;

This item has no description.

EAX_ENVIRONMENT_CARPETEDHALLWAY = 11;

This item has no description.

EAX_ENVIRONMENT_HALLWAY = 12;

This item has no description.

EAX_ENVIRONMENT_STONECORRIDOR = 13;

This item has no description.

EAX_ENVIRONMENT_ALLEY = 14;

This item has no description.

EAX_ENVIRONMENT_FOREST = 15;

This item has no description.

EAX_ENVIRONMENT_CITY = 16;

This item has no description.

EAX_ENVIRONMENT_MOUNTAINS = 17;

This item has no description.

EAX_ENVIRONMENT_QUARRY = 18;

This item has no description.

EAX_ENVIRONMENT_PLAIN = 19;

This item has no description.

EAX_ENVIRONMENT_PARKINGLOT = 20;

This item has no description.

EAX_ENVIRONMENT_SEWERPIPE = 21;

This item has no description.

EAX_ENVIRONMENT_UNDERWATER = 22;

This item has no description.

EAX_ENVIRONMENT_DRUGGED = 23;

This item has no description.

EAX_ENVIRONMENT_DIZZY = 24;

This item has no description.

EAX_ENVIRONMENT_PSYCHOTIC = 25;

This item has no description.

EAX_ENVIRONMENT_COUNT = 26;

total number of environments

BASS_STREAMPROC_END = $80000000;

This item has no description.

STREAMFILE_NOBUFFER = 0;

end of user stream flag BASS_StreamCreateFileUser file systems

STREAMFILE_BUFFER = 1;

This item has no description.

STREAMFILE_BUFFERPUSH = 2;

This item has no description.

BASS_FILEDATA_END = 0;

BASS_StreamPutFileData options

BASS_FILEPOS_CURRENT = 0;

end & close the file BASS_StreamGetFilePosition modes

BASS_FILEPOS_DECODE = BASS_FILEPOS_CURRENT;

This item has no description.

BASS_FILEPOS_DOWNLOAD = 1;

This item has no description.

BASS_FILEPOS_END = 2;

This item has no description.

BASS_FILEPOS_START = 3;

This item has no description.

BASS_FILEPOS_CONNECTED = 4;

This item has no description.

BASS_FILEPOS_BUFFER = 5;

This item has no description.

BASS_FILEPOS_SOCKET = 6;

This item has no description.

BASS_FILEPOS_ASYNCBUF = 7;

This item has no description.

BASS_FILEPOS_SIZE = 8;

This item has no description.

BASS_FILEPOS_BUFFERING = 9;

This item has no description.

BASS_FILEPOS_AVAILABLE = 10;

This item has no description.

BASS_SYNC_POS = 0;

Sync types (with BASS_ChannelSetSync() "param" and SYNCPROC "data" definitions) & flags.

BASS_SYNC_END = 2;

Sync when a channel reaches a position. param: position in bytes data : not used

BASS_SYNC_META = 4;

Sync when a channel reaches the end. param: not used data : not used

BASS_SYNC_SLIDE = 5;

Sync when metadata is received in a stream. param: not used data : pointer to the metadata

BASS_SYNC_STALL = 6;

Sync when an attribute slide is completed. param: not used data : the type of slide completed (one of the BASS_SLIDE_xxx values)

BASS_SYNC_DOWNLOAD = 7;

Sync when playback has stalled. param: not used data : 0=stalled, 1=resumed

BASS_SYNC_FREE = 8;

Sync when downloading of an internet (or "buffered" user file) stream has ended. param: not used data : not used

BASS_SYNC_SETPOS = 11;

Sync when a channel is freed. param: not used data : not used

BASS_SYNC_MUSICPOS = 10;

Sync when a channel's position is set. param: not used data : 0 = playback buffer not flushed, 1 = playback buffer flushed

BASS_SYNC_MUSICINST = 1;

Sync when a MOD music reaches an order:row position. param: LOWORD=order (0=first, -1=all) HIWORD=row (0=first, -1=all) data : LOWORD=order HIWORD=row

BASS_SYNC_MUSICFX = 3;

Sync when an instrument (sample for the non-instrument based formats) is played in a MOD music (not including retrigs). param: LOWORD=instrument (1=first) HIWORD=note (0=c0...119=b9, -1=all) data : LOWORD=note HIWORD=volume (0-64)

BASS_SYNC_OGG_CHANGE = 12;

Sync when the "sync" effect (XM/MTM/MOD: E8x/Wxx, IT/S3M: S2x) is used. param: 0:data=pos, 1:data="x" value data : param=0: LOWORD=order HIWORD=row, param=1: "x" value

BASS_SYNC_DEV_FAIL = 14;

This item has no description.

BASS_SYNC_DEV_FORMAT = 15;

This item has no description.

BASS_SYNC_THREAD = $20000000;

This item has no description.

BASS_SYNC_MIXTIME = $40000000;

flag: call sync in other thread

BASS_SYNC_ONETIME = $80000000;

flag: sync at mixtime, else at playtime

BASS_ACTIVE_STOPPED = 0;

flag: sync only once, else continuously BASS_ChannelIsActive return values

BASS_ACTIVE_PLAYING = 1;

This item has no description.

BASS_ACTIVE_STALLED = 2;

This item has no description.

BASS_ACTIVE_PAUSED = 3;

This item has no description.

BASS_ACTIVE_PAUSED_DEVICE = 4;

This item has no description.

BASS_ATTRIB_FREQ = 1;

Channel attributes

BASS_ATTRIB_VOL = 2;

This item has no description.

BASS_ATTRIB_PAN = 3;

This item has no description.

BASS_ATTRIB_EAXMIX = 4;

This item has no description.

BASS_ATTRIB_NOBUFFER = 5;

This item has no description.

BASS_ATTRIB_VBR = 6;

This item has no description.

BASS_ATTRIB_CPU = 7;

This item has no description.

BASS_ATTRIB_SRC = 8;

This item has no description.

BASS_ATTRIB_NET_RESUME = 9;

This item has no description.

BASS_ATTRIB_SCANINFO = 10;

This item has no description.

BASS_ATTRIB_NORAMP = 11;

This item has no description.

BASS_ATTRIB_BITRATE = 12;

This item has no description.

BASS_ATTRIB_BUFFER = 13;

This item has no description.

BASS_ATTRIB_GRANULE = 14;

This item has no description.

BASS_ATTRIB_USER = 15;

This item has no description.

BASS_ATTRIB_TAIL = 16;

This item has no description.

BASS_ATTRIB_PUSH_LIMIT = 17;

This item has no description.

BASS_ATTRIB_DOWNLOADPROC = 18;

This item has no description.

BASS_ATTRIB_VOLDSP = 19;

This item has no description.

BASS_ATTRIB_VOLDSP_PRIORITY = 20;

This item has no description.

BASS_ATTRIB_MUSIC_AMPLIFY = $100;

This item has no description.

BASS_ATTRIB_MUSIC_PANSEP = $101;

This item has no description.

BASS_ATTRIB_MUSIC_PSCALER = $102;

This item has no description.

BASS_ATTRIB_MUSIC_BPM = $103;

This item has no description.

BASS_ATTRIB_MUSIC_SPEED = $104;

This item has no description.

BASS_ATTRIB_MUSIC_VOL_GLOBAL = $105;

This item has no description.

BASS_ATTRIB_MUSIC_ACTIVE = $106;

This item has no description.

BASS_ATTRIB_MUSIC_VOL_CHAN = $200;

This item has no description.

BASS_ATTRIB_MUSIC_VOL_INST = $300;

+ channel #

BASS_SLIDE_LOG = $1000000;

+ instrument # BASS_ChannelSlideAttribute flags

BASS_DATA_AVAILABLE = 0;

BASS_ChannelGetData flags

BASS_DATA_NOREMOVE = $10000000;

query how much data is buffered

BASS_DATA_FIXED = $20000000;

flag: don't remove data from recording buffer

BASS_DATA_FLOAT = $40000000;

unused

BASS_DATA_FFT256 = $80000000;

flag: return floating-point sample data

BASS_DATA_FFT512 = $80000001;

256 sample FFT

BASS_DATA_FFT1024 = $80000002;

512 FFT

BASS_DATA_FFT2048 = $80000003;

1024 FFT

BASS_DATA_FFT4096 = $80000004;

2048 FFT

BASS_DATA_FFT8192 = $80000005;

4096 FFT

BASS_DATA_FFT16384 = $80000006;

8192 FFT

BASS_DATA_FFT32768 = $80000007;

16384 FFT

BASS_DATA_FFT_INDIVIDUAL = $10;

32768 FFT

BASS_DATA_FFT_NOWINDOW = $20;

FFT flag: FFT for each channel, else all combined

BASS_DATA_FFT_REMOVEDC = $40;

FFT flag: no Hanning window

BASS_DATA_FFT_COMPLEX = $80;

FFT flag: pre-remove DC bias

BASS_DATA_FFT_NYQUIST = $100;

FFT flag: return complex data

BASS_LEVEL_MONO = 1;

FFT flag: return extra Nyquist value BASS_ChannelGetLevelEx flags

BASS_LEVEL_STEREO = 2;

get mono level

BASS_LEVEL_RMS = 4;

get stereo level

BASS_LEVEL_VOLPAN = 8;

get RMS levels

BASS_LEVEL_NOREMOVE = 16;

apply VOL/PAN attributes to the levels

BASS_TAG_ID3 = 0;

don't remove data from recording buffer BASS_ChannelGetTags types : what's returned

BASS_TAG_ID3V2 = 1;

ID3v1 tags : TAG_ID3 structure

BASS_TAG_OGG = 2;

ID3v2 tags : variable length block

BASS_TAG_HTTP = 3;

OGG comments : series of null-terminated UTF-8 strings

BASS_TAG_ICY = 4;

HTTP headers : series of null-terminated ASCII strings

BASS_TAG_META = 5;

ICY headers : series of null-terminated ANSI strings

BASS_TAG_APE = 6;

ICY metadata : ANSI string

BASS_TAG_MP4 = 7;

APEv2 tags : series of null-terminated UTF-8 strings

BASS_TAG_WMA = 8;

MP4/iTunes metadata : series of null-terminated UTF-8 strings

BASS_TAG_VENDOR = 9;

WMA tags : series of null-terminated UTF-8 strings

BASS_TAG_LYRICS3 = 10;

OGG encoder : UTF-8 string

BASS_TAG_CA_CODEC = 11;

Lyric3v2 tag : ASCII string

BASS_TAG_MF = 13;

CoreAudio codec info : TAG_CA_CODEC structure

BASS_TAG_WAVEFORMAT = 14;

Media Foundation tags : series of null-terminated UTF-8 strings

BASS_TAG_AM_NAME = 16;

WAVE format : WAVEFORMATEEX structure

BASS_TAG_ID3V2_2 = 17;

Android Media codec name : ASCII string

BASS_TAG_AM_MIME = 18;

ID3v2 tags (2nd block) : variable length block

BASS_TAG_LOCATION = 19;

Android Media MIME type : ASCII string

BASS_TAG_RIFF_INFO = $100;

redirected URL : ASCII string

BASS_TAG_RIFF_BEXT = $101;

RIFF "INFO" tags : series of null-terminated ANSI strings

BASS_TAG_RIFF_CART = $102;

RIFF/BWF "bext" tags : TAG_BEXT structure

BASS_TAG_RIFF_DISP = $103;

RIFF/BWF "cart" tags : TAG_CART structure

BASS_TAG_RIFF_CUE = $104;

RIFF "DISP" text tag : ANSI string

BASS_TAG_RIFF_SMPL = $105;

RIFF "cue " chunk : TAG_CUE structure

BASS_TAG_APE_BINARY = $1000;

RIFF "smpl" chunk : TAG_SMPL structure

BASS_TAG_MUSIC_NAME = $10000;

+ index #, binary APEv2 tag : TAG_APE_BINARY structure

BASS_TAG_MUSIC_MESSAGE = $10001;

MOD music name : ANSI string

BASS_TAG_MUSIC_ORDERS = $10002;

MOD message : ANSI string

BASS_TAG_MUSIC_AUTH = $10003;

MOD order list : BYTE array of pattern numbers

BASS_TAG_MUSIC_INST = $10100;

MOD author : UTF-8 string

BASS_TAG_MUSIC_CHAN = $10200;

+ instrument #, MOD instrument name : ANSI string

BASS_TAG_MUSIC_SAMPLE = $10300;

+ channel #, MOD channel name : ANSI string

BASS_POS_BYTE = 0;

+ sample #, MOD sample name : ANSI string BASS_ChannelGetLength/GetPosition/SetPosition modes

BASS_POS_MUSIC_ORDER = 1;

byte position

BASS_POS_OGG = 3;

order.row position, MAKELONG(order,row)

BASS_POS_END = $10;

OGG bitstream number

BASS_POS_LOOP = $11;

trimmed end position

BASS_POS_FLUSH = $1000000;

loop start positiom

BASS_POS_RESET = $2000000;

flag: flush decoder/FX buffers

BASS_POS_RELATIVE = $4000000;

flag: reset user file buffers

BASS_POS_INEXACT = $8000000;

flag: seek relative to the current position

BASS_POS_DECODE = $10000000;

flag: allow seeking to inexact position

BASS_POS_DECODETO = $20000000;

flag: get the decoding (not playing) position

BASS_POS_SCAN = $40000000;

flag: decode to the position instead of seeking

BASS_NODEVICE = $20000;

flag: scan to the position BASS_ChannelSetDevice/GetDevice option

BASS_INPUT_OFF = $10000;

BASS_RecordSetInput flags

BASS_INPUT_ON = $20000;

This item has no description.

BASS_INPUT_TYPE_MASK = $FF000000;

This item has no description.

BASS_INPUT_TYPE_UNDEF = $00000000;

This item has no description.

BASS_INPUT_TYPE_DIGITAL = $01000000;

This item has no description.

BASS_INPUT_TYPE_LINE = $02000000;

This item has no description.

BASS_INPUT_TYPE_MIC = $03000000;

This item has no description.

BASS_INPUT_TYPE_SYNTH = $04000000;

This item has no description.

BASS_INPUT_TYPE_CD = $05000000;

This item has no description.

BASS_INPUT_TYPE_PHONE = $06000000;

This item has no description.

BASS_INPUT_TYPE_SPEAKER = $07000000;

This item has no description.

BASS_INPUT_TYPE_WAVE = $08000000;

This item has no description.

BASS_INPUT_TYPE_AUX = $09000000;

This item has no description.

BASS_INPUT_TYPE_ANALOG = $0A000000;

This item has no description.

BASS_FX_DX8_CHORUS = 0;

BASS_ChannelSetFX effect types

BASS_FX_DX8_COMPRESSOR = 1;

This item has no description.

BASS_FX_DX8_DISTORTION = 2;

This item has no description.

BASS_FX_DX8_ECHO = 3;

This item has no description.

BASS_FX_DX8_FLANGER = 4;

This item has no description.

BASS_FX_DX8_GARGLE = 5;

This item has no description.

BASS_FX_DX8_I3DL2REVERB = 6;

This item has no description.

BASS_FX_DX8_PARAMEQ = 7;

This item has no description.

BASS_FX_DX8_REVERB = 8;

This item has no description.

BASS_FX_VOLUME = 9;

This item has no description.

BASS_DX8_PHASE_NEG_180 = 0;

This item has no description.

BASS_DX8_PHASE_NEG_90 = 1;

This item has no description.

BASS_DX8_PHASE_ZERO = 2;

This item has no description.

BASS_DX8_PHASE_90 = 3;

This item has no description.

BASS_DX8_PHASE_180 = 4;

This item has no description.

STREAMPROC_DUMMY = Pointer(0);

Special STREAMPROCs

STREAMPROC_PUSH = Pointer(-1);

"dummy" stream

STREAMPROC_DEVICE = Pointer(-2);

push stream

STREAMPROC_DEVICE_3D = Pointer(-3);

device mix stream

Variables

BASS_SetConfig: function(option, value: DWORD): BOOL; stdcall;

Recording callback function. handle : The recording handle buffer : Buffer containing the recorded sample data length : Number of bytes user : The 'user' parameter value given when calling BASS_RecordStart RETURN : TRUE = continue recording, FALSE = stop

BASS_GetConfig: function(option: DWORD): DWORD; stdcall;

external bassdll;

BASS_SetConfigPtr: function(option: DWORD; value: Pointer): BOOL; stdcall;

external bassdll;

BASS_GetConfigPtr: function(option: DWORD): Pointer; stdcall;

external bassdll;

BASS_GetVersion: function(): DWORD; stdcall;

external bassdll;

BASS_ErrorGetCode: function(): LongInt; stdcall;

external bassdll;

BASS_GetDeviceInfo: function(device: DWORD; var info: BASS_DEVICEINFO): BOOL; stdcall;

external bassdll;

BASS_Init: function(device: LongInt; freq, flags: DWORD; win: HWND; clsid: PGUID): BOOL; stdcall;

external bassdll;

BASS_SetDevice: function(device: DWORD): BOOL; stdcall;

external bassdll;

BASS_GetDevice: function():DWORD; stdcall;

external bassdll;

BASS_Free: function():BOOL; stdcall;

external bassdll;

BASS_GetDSoundObject: function(obj: DWORD): Pointer; stdcall;

external bassdll;

BASS_GetInfo: function(var info: BASS_INFO): BOOL; stdcall;

external bassdll;

BASS_Update: function(length: DWORD): BOOL; stdcall;

external bassdll;

BASS_GetCPU: function():Single; stdcall;

external bassdll;

BASS_Start: function():BOOL; stdcall;

external bassdll;

BASS_Stop: function():BOOL; stdcall;

external bassdll;

BASS_Pause: function():BOOL; stdcall;

external bassdll;

BASS_SetVolume: function(volume: Single): BOOL; stdcall;

external bassdll;

BASS_GetVolume: function():Single; stdcall;

external bassdll;

BASS_PluginLoad: function(filename: PChar; flags: DWORD): HPLUGIN; stdcall;

external bassdll;

BASS_PluginFree: function(handle: HPLUGIN): BOOL; stdcall;

external bassdll;

BASS_PluginGetInfo: function(handle: HPLUGIN): PBASS_PLUGININFO; stdcall;

external bassdll;

BASS_Set3DFactors: function(distf, rollf, doppf: Single): BOOL; stdcall;

external bassdll;

BASS_Get3DFactors: function(var distf, rollf, doppf: Single): BOOL; stdcall;

external bassdll;

BASS_Set3DPosition: function(var pos, vel, front, top: BASS_3DVECTOR): BOOL; stdcall;

external bassdll;

BASS_Get3DPosition: function(var pos, vel, front, top: BASS_3DVECTOR): BOOL; stdcall;

external bassdll;

BASS_Apply3D: procedure(); stdcall;

external bassdll;

BASS_SetEAXParameters: function(env: LongInt; vol, decay, damp: Single): BOOL; stdcall;

external bassdll;

BASS_GetEAXParameters: function(var env: DWORD; var vol, decay, damp: Single): BOOL; stdcall;

external bassdll;

BASS_MusicLoad: function(mem: BOOL; f: Pointer; offset: QWORD; length, flags, freq: DWORD): HMUSIC; stdcall;

external bassdll;

BASS_MusicFree: function(handle: HMUSIC): BOOL; stdcall;

external bassdll;

BASS_SampleLoad: function(mem: BOOL; f: Pointer; offset: QWORD; length, max, flags: DWORD): HSAMPLE; stdcall;

external bassdll;

BASS_SampleCreate: function(length, freq, chans, max, flags: DWORD): HSAMPLE; stdcall;

external bassdll;

BASS_SampleFree: function(handle: HSAMPLE): BOOL; stdcall;

external bassdll;

BASS_SampleSetData: function(handle: HSAMPLE; buffer: Pointer): BOOL; stdcall;

external bassdll;

BASS_SampleGetData: function(handle: HSAMPLE; buffer: Pointer): BOOL; stdcall;

external bassdll;

BASS_SampleGetInfo: function(handle: HSAMPLE; var info: BASS_SAMPLE): BOOL; stdcall;

external bassdll;

BASS_SampleSetInfo: function(handle: HSAMPLE; var info: BASS_SAMPLE): BOOL; stdcall;

external bassdll;

BASS_SampleGetChannel: function(handle: HSAMPLE; onlynew: BOOL): HCHANNEL; stdcall;

external bassdll;

BASS_SampleGetChannels: function(handle: HSAMPLE; channels: Pointer): DWORD; stdcall;

external bassdll;

BASS_SampleStop: function(handle: HSAMPLE): BOOL; stdcall;

external bassdll;

BASS_StreamCreate: function(freq, chans, flags: DWORD; proc: STREAMPROC; user: Pointer): HSTREAM; stdcall;

external bassdll;

BASS_StreamCreateFile: function(mem: BOOL; f: Pointer; offset, length: QWORD; flags: DWORD): HSTREAM; stdcall;

external bassdll;

BASS_StreamCreateURL: function(url: PAnsiChar; offset: DWORD; flags: DWORD; proc: DOWNLOADPROC; user: Pointer):HSTREAM; stdcall;

external bassdll;

BASS_StreamCreateFileUser: function(system, flags: DWORD; var procs: BASS_FILEPROCS; user: Pointer): HSTREAM; stdcall;

external bassdll;

BASS_StreamFree: function(handle: HSTREAM): BOOL; stdcall;

external bassdll;

BASS_StreamGetFilePosition: function(handle: HSTREAM; mode: DWORD): QWORD; stdcall;

external bassdll;

BASS_StreamPutData: function(handle: HSTREAM; buffer: Pointer; length: DWORD): DWORD; stdcall;

external bassdll;

BASS_StreamPutFileData: function(handle: HSTREAM; buffer: Pointer; length: DWORD): DWORD; stdcall;

external bassdll;

BASS_RecordGetDeviceInfo: function(device: DWORD; var info: BASS_DEVICEINFO): BOOL; stdcall;

external bassdll;

BASS_RecordInit: function(device: LongInt):BOOL; stdcall;

external bassdll;

BASS_RecordSetDevice: function(device: DWORD): BOOL; stdcall;

external bassdll;

BASS_RecordGetDevice: function():DWORD; stdcall;

external bassdll;

BASS_RecordFree: function():BOOL; stdcall;

external bassdll;

BASS_RecordGetInfo: function(var info: BASS_RECORDINFO): BOOL; stdcall;

external bassdll;

BASS_RecordGetInputName: function(input: LongInt): PAnsiChar; stdcall;

external bassdll;

BASS_RecordSetInput: function(input: LongInt; flags: DWORD; volume: Single): BOOL; stdcall;

external bassdll;

BASS_RecordGetInput: function(input: LongInt; var volume: Single): DWORD; stdcall;

external bassdll;

BASS_RecordStart: function(freq, chans, flags: DWORD; proc: RECORDPROC; user: Pointer): HRECORD; stdcall;

external bassdll;

BASS_ChannelBytes2Seconds: function(handle: DWORD; pos: QWORD): Double; stdcall;

external bassdll;

BASS_ChannelSeconds2Bytes: function(handle: DWORD; pos: Double): QWORD; stdcall;

external bassdll;

BASS_ChannelGetDevice: function(handle: DWORD): DWORD; stdcall;

external bassdll;

BASS_ChannelSetDevice: function(handle, device: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelIsActive: function(handle: DWORD): DWORD; stdcall;

external bassdll;

BASS_ChannelGetInfo: function(handle: DWORD; var info: BASS_CHANNELINFO):BOOL; stdcall;

external bassdll;

BASS_ChannelGetTags: function(handle: HSTREAM; tags: DWORD): PAnsiChar; stdcall;

external bassdll;

BASS_ChannelFlags: function(handle, flags, mask: DWORD): DWORD; stdcall;

external bassdll;

BASS_ChannelUpdate: function(handle, length: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelLock: function(handle: DWORD; lock: BOOL): BOOL; stdcall;

external bassdll;

BASS_ChannelPlay: function(handle: DWORD; restart: BOOL): BOOL; stdcall;

external bassdll;

BASS_ChannelStop: function(handle: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelPause: function(handle: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelSetAttribute: function(handle, attrib: DWORD; value: Single): BOOL; stdcall;

external bassdll;

BASS_ChannelGetAttribute: function(handle, attrib: DWORD; var value: Single): BOOL; stdcall;

external bassdll;

BASS_ChannelSlideAttribute: function(handle, attrib: DWORD; value: Single; time: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelIsSliding: function(handle, attrib: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelSetAttributeEx: function(handle, attrib: DWORD; value: Pointer; size: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelGetAttributeEx: function(handle, attrib: DWORD; value: Pointer; size: DWORD): DWORD; stdcall;

external bassdll;

BASS_ChannelSet3DAttributes: function(handle: DWORD; mode: LongInt; min, max: Single; iangle, oangle, outvol: LongInt): BOOL; stdcall;

external bassdll;

BASS_ChannelGet3DAttributes: function(handle: DWORD; var mode: DWORD; var min, max: Single; var iangle, oangle, outvol: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelSet3DPosition: function(handle: DWORD; var pos, orient, vel: BASS_3DVECTOR): BOOL; stdcall;

external bassdll;

BASS_ChannelGet3DPosition: function(handle: DWORD; var pos, orient, vel: BASS_3DVECTOR): BOOL; stdcall;

external bassdll;

BASS_ChannelGetLength: function(handle, mode: DWORD): QWORD; stdcall;

external bassdll;

BASS_ChannelSetPosition: function(handle: DWORD; pos: QWORD; mode: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelGetPosition: function(handle, mode: DWORD): QWORD; stdcall;

external bassdll;

BASS_ChannelGetLevel: function(handle: DWORD): DWORD; stdcall;

external bassdll;

BASS_ChannelGetLevelEx: function(handle: DWORD; levels: PSingle; length: Single; flags: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelGetData: function(handle: DWORD; buffer: Pointer; length: DWORD): DWORD; stdcall;

external bassdll;

BASS_ChannelSetSync: function(handle: DWORD; type_: DWORD; param: QWORD; proc: SYNCPROC; user: Pointer): HSYNC; stdcall;

external bassdll;

BASS_ChannelRemoveSync: function(handle: DWORD; sync: HSYNC): BOOL; stdcall;

external bassdll;

BASS_ChannelSetDSP: function(handle: DWORD; proc: DSPPROC; user: Pointer; priority: LongInt): HDSP; stdcall;

external bassdll;

BASS_ChannelRemoveDSP: function(handle: DWORD; dsp: HDSP): BOOL; stdcall;

external bassdll;

BASS_ChannelSetLink: function(handle, chan: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelRemoveLink: function(handle, chan: DWORD): BOOL; stdcall;

external bassdll;

BASS_ChannelSetFX: function(handle, type_: DWORD; priority: LongInt): HFX; stdcall;

external bassdll;

BASS_ChannelRemoveFX: function(handle: DWORD; fx: HFX): BOOL; stdcall;

external bassdll;

BASS_FXSetParameters: function(handle: HFX; par: Pointer): BOOL; stdcall;

external bassdll;

BASS_FXGetParameters: function(handle: HFX; par: Pointer): BOOL; stdcall;

external bassdll;

BASS_FXReset: function(handle: HFX): BOOL; stdcall;

external bassdll;

BASS_FXSetPriority: function(handle: HFX; priority: LongInt): BOOL; stdcall;

external bassdll;


GLSysHelp v.2.5: BASS.Import: Record BASS_DEVICEINFO

Record BASS_DEVICEINFO

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DEVICEINFO = record

Description

plugin handle Device info structure

Overview

Fields

Public | name: PAnsiChar;
Public | driver: PAnsiChar;
Public | flags: DWORD;

Description

Fields

Public name: PAnsiChar;

This item has no description.

Public driver: PAnsiChar;

description

Public flags: DWORD;

driver


GLSysHelp v.2.5: BASS.Import: Record BASS_INFO

Record BASS_INFO

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_INFO = record

Description

This item has no description.

Overview

Fields

Public | flags: DWORD;
Public | hwsize: DWORD;
Public | hwfree: DWORD;
Public | freesam: DWORD;
Public | free3d: DWORD;
Public | minrate: DWORD;
Public | maxrate: DWORD;
Public | eax: BOOL;
Public | minbuf: DWORD;
Public | dsver: DWORD;
Public | latency: DWORD;
Public | initflags: DWORD;
Public | speakers: DWORD;
Public | freq: DWORD;

Description

Fields

Public flags: DWORD;

This item has no description.

Public hwsize: DWORD;

device capabilities (DSCAPS_xxx flags)

Public hwfree: DWORD;

unused

Public freesam: DWORD;

unused

Public free3d: DWORD;

unused

Public minrate: DWORD;

unused

Public maxrate: DWORD;

unused

Public eax: BOOL;

unused

Public minbuf: DWORD;

unused

Public dsver: DWORD;

recommended minimum buffer length in ms

Public latency: DWORD;

DirectSound version

Public initflags: DWORD;

average delay (in ms) before start of playback

Public speakers: DWORD;

BASS_Init "flags" parameter

Public freq: DWORD;

number of speakers available


GLSysHelp v.2.5: BASS.Import: Record BASS_RECORDINFO

Record BASS_RECORDINFO

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_RECORDINFO = record

Description

Recording device info structure

Overview

Fields

Public | flags: DWORD;
Public | formats: DWORD;
Public | inputs: DWORD;
Public | singlein: BOOL;
Public | freq: DWORD;

Description

Fields

Public flags: DWORD;

This item has no description.

Public formats: DWORD;

device capabilities (DSCCAPS_xxx flags)

Public inputs: DWORD;

supported standard formats (WAVE_FORMAT_xxx flags)

Public singlein: BOOL;

number of inputs

Public freq: DWORD;

only 1 input can be set at a time


GLSysHelp v.2.5: BASS.Import: Record BASS_SAMPLE

Record BASS_SAMPLE

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_SAMPLE = record

Description

Sample info structure

Overview

Fields

Public | freq: DWORD;
Public | volume: Single;
Public | pan: Single;
Public | flags: DWORD;
Public | length: DWORD;
Public | max: DWORD;
Public | origres: DWORD;
Public | chans: DWORD;
Public | mingap: DWORD;
Public | mode3d: DWORD;
Public | mindist: Single;
Public | maxdist: Single;
Public | iangle: DWORD;
Public | oangle: DWORD;
Public | outvol: Single;
Public | vam: DWORD;
Public | priority: DWORD;

Description

Fields

Public freq: DWORD;

This item has no description.

Public volume: Single;

default playback rate

Public pan: Single;

default volume (0-100)

Public flags: DWORD;

default pan (-100=left, 0=middle, 100=right)

Public length: DWORD;

BASS_SAMPLE_xxx flags

Public max: DWORD;

length (in samples, not bytes)

Public origres: DWORD;

maximum simultaneous playbacks

Public chans: DWORD;

original resolution

Public mingap: DWORD;

number of channels

Public mode3d: DWORD;

The following are the sample's default 3D attributes (if the sample is 3D, BASS_SAMPLE_3D is in flags) see BASS_ChannelSet3DAttributes

Public mindist: Single;

BASS_3DMODE_xxx mode

Public maxdist: Single;

minimum distance

Public iangle: DWORD;

maximum distance

Public oangle: DWORD;

angle of inside projection cone

Public outvol: Single;

angle of outside projection cone

Public vam: DWORD;

The following are the defaults used if the sample uses the DirectX 7 voice allocation/management features.

Public priority: DWORD;

unused


GLSysHelp v.2.5: BASS.Import: Record BASS_CHANNELINFO

Record BASS_CHANNELINFO

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_CHANNELINFO = record

Description

Channel info structure

Overview

Fields

Public | freq: DWORD;
Public | chans: DWORD;
Public | flags: DWORD;
Public | ctype: DWORD;
Public | origres: DWORD;
Public | plugin: HPLUGIN;
Public | sample: HSAMPLE;
Public | filename: PChar;

Description

Fields

Public freq: DWORD;

This item has no description.

Public chans: DWORD;

default playback rate

Public flags: DWORD;

channels

Public ctype: DWORD;

This item has no description.

Public origres: DWORD;

type of channel

Public plugin: HPLUGIN;

original resolution

Public sample: HSAMPLE;

This item has no description.

Public filename: PChar;

This item has no description.


GLSysHelp v.2.5: BASS.Import: Record BASS_PLUGINFORM

Record BASS_PLUGINFORM

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_PLUGINFORM = record

Description

This item has no description.

Overview

Fields

Public | ctype: DWORD;
Public | name: PAnsiChar;
Public | exts: PAnsiChar;

Description

Fields

Public ctype: DWORD;

This item has no description.

Public name: PAnsiChar;

channel type

Public exts: PAnsiChar;

format description


GLSysHelp v.2.5: BASS.Import: Record BASS_PLUGININFO

Record BASS_PLUGININFO

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_PLUGININFO = record

Description

This item has no description.

Overview

Fields

Public | version: DWORD;
Public | formatc: DWORD;
Public | formats: PBASS_PLUGINFORMS;

Description

Fields

Public version: DWORD;

This item has no description.

Public formatc: DWORD;

version (same form as BASS_GetVersion)

Public formats: PBASS_PLUGINFORMS;

number of formats


GLSysHelp v.2.5: BASS.Import: Record BASS_3DVECTOR

Record BASS_3DVECTOR

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_3DVECTOR = record

Description

3D vector (for 3D positions/velocities/orientations)

Overview

Fields

Public | x: Single;
Public | y: Single;
Public | z: Single;

Description

Fields

Public x: Single;

This item has no description.

Public y: Single;

+=right, -=left

Public z: Single;

+=up, -=down


GLSysHelp v.2.5: BASS.Import: Record BASS_FILEPROCS

Record BASS_FILEPROCS

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_FILEPROCS = record

Description

This item has no description.

Overview

Fields

Public | close: FILECLOSEPROC;
Public | length: FILELENPROC;
Public | read: FILEREADPROC;
Public | seek: FILESEEKPROC;

Description

Fields

Public close: FILECLOSEPROC;

This item has no description.

Public length: FILELENPROC;

This item has no description.

Public read: FILEREADPROC;

This item has no description.

Public seek: FILESEEKPROC;


GLSysHelp v.2.5: BASS.Import: Record TAG_ID3

Record TAG_ID3

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type TAG_ID3 = record

Description

This item has no description.

Overview

Fields

Public | id: Array[0..2] of AnsiChar;
Public | title: Array[0..29] of AnsiChar;
Public | artist: Array[0..29] of AnsiChar;
Public | album: Array[0..29] of AnsiChar;
Public | year: Array[0..3] of AnsiChar;
Public | comment: Array[0..29] of AnsiChar;
Public | genre: Byte;

Description

Fields

Public id: Array[0..2] of AnsiChar;

This item has no description.

Public title: Array[0..29] of AnsiChar;

This item has no description.

Public artist: Array[0..29] of AnsiChar;

This item has no description.

Public album: Array[0..29] of AnsiChar;

This item has no description.

Public year: Array[0..3] of AnsiChar;

This item has no description.

Public comment: Array[0..29] of AnsiChar;

This item has no description.

Public genre: Byte;


GLSysHelp v.2.5: BASS.Import: Record TAG_APE_BINARY

Record TAG_APE_BINARY

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type TAG_APE_BINARY = record

Description

This item has no description.

Overview

Fields

Public | key: PAnsiChar;
Public | data: PAnsiChar;
Public | length: DWORD;

Description

Fields

Public key: PAnsiChar;

This item has no description.

Public data: PAnsiChar;

This item has no description.

Public length: DWORD;


GLSysHelp v.2.5: BASS.Import: Packed Record TAG_BEXT

Packed Record TAG_BEXT

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type TAG_BEXT = packed record

Description

This item has no description.

Overview

Fields

Public | Description: Array[0..255] of AnsiChar;
Public | Originator: Array[0..31] of AnsiChar;
Public | OriginatorReference: Array[0..31] of AnsiChar;
Public | OriginationDate: Array[0..9] of AnsiChar;
Public | OriginationTime: Array[0..7] of AnsiChar;
Public | TimeReference: QWORD;
Public | Version: Word;
Public | UMID: Array[0..63] of Byte;
Public | Reserved: Array[0..189] of Byte;
Public | CodingHistory: AnsiChar;

Description

Fields

Public Description: Array[0..255] of AnsiChar;

This item has no description.

Public Originator: Array[0..31] of AnsiChar;

description

Public OriginatorReference: Array[0..31] of AnsiChar;

name of the originator

Public OriginationDate: Array[0..9] of AnsiChar;

reference of the originator

Public OriginationTime: Array[0..7] of AnsiChar;

date of creation (yyyy-mm-dd)

Public TimeReference: QWORD;

time of creation (hh-mm-ss)

Public Version: Word;

first sample count since midnight (little-endian)

Public UMID: Array[0..63] of Byte;

BWF version (little-endian)

Public Reserved: Array[0..189] of Byte;

SMPTE UMID

Public CodingHistory: AnsiChar;


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_CHORUS

Record BASS_DX8_CHORUS

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_CHORUS = record

Description

This item has no description.

Overview

Fields

Public | fWetDryMix: Single;
Public | fDepth: Single;
Public | fFeedback: Single;
Public | fFrequency: Single;
Public | lWaveform: DWORD;
Public | fDelay: Single;
Public | lPhase: DWORD;

Description

Fields

Public fWetDryMix: Single;

This item has no description.

Public fDepth: Single;

This item has no description.

Public fFeedback: Single;

This item has no description.

Public fFrequency: Single;

This item has no description.

Public lWaveform: DWORD;

This item has no description.

Public fDelay: Single;

0=triangle, 1=sine

Public lPhase: DWORD;


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_COMPRESSOR

Record BASS_DX8_COMPRESSOR

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_COMPRESSOR = record

Description

This item has no description.

Overview

Fields

Public | fGain: Single;
Public | fAttack: Single;
Public | fRelease: Single;
Public | fThreshold: Single;
Public | fRatio: Single;
Public | fPredelay: Single;

Description

Fields

Public fGain: Single;

This item has no description.

Public fAttack: Single;

This item has no description.

Public fRelease: Single;

This item has no description.

Public fThreshold: Single;

This item has no description.

Public fRatio: Single;

This item has no description.

Public fPredelay: Single;


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_DISTORTION

Record BASS_DX8_DISTORTION

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_DISTORTION = record

Description

This item has no description.

Overview

Fields

Public | fGain: Single;
Public | fEdge: Single;
Public | fPostEQCenterFrequency: Single;
Public | fPostEQBandwidth: Single;
Public | fPreLowpassCutoff: Single;

Description

Fields

Public fGain: Single;

This item has no description.

Public fEdge: Single;

This item has no description.

Public fPostEQCenterFrequency: Single;

This item has no description.

Public fPostEQBandwidth: Single;

This item has no description.

Public fPreLowpassCutoff: Single;


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_ECHO

Record BASS_DX8_ECHO

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_ECHO = record

Description

This item has no description.

Overview

Fields

Public | fWetDryMix: Single;
Public | fFeedback: Single;
Public | fLeftDelay: Single;
Public | fRightDelay: Single;
Public | lPanDelay: BOOL;

Description

Fields

Public fWetDryMix: Single;

This item has no description.

Public fFeedback: Single;

This item has no description.

Public fLeftDelay: Single;

This item has no description.

Public fRightDelay: Single;

This item has no description.

Public lPanDelay: BOOL;


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_FLANGER

Record BASS_DX8_FLANGER

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_FLANGER = record

Description

This item has no description.

Overview

Fields

Public | fWetDryMix: Single;
Public | fDepth: Single;
Public | fFeedback: Single;
Public | fFrequency: Single;
Public | lWaveform: DWORD;
Public | fDelay: Single;
Public | lPhase: DWORD;

Description

Fields

Public fWetDryMix: Single;

This item has no description.

Public fDepth: Single;

This item has no description.

Public fFeedback: Single;

This item has no description.

Public fFrequency: Single;

This item has no description.

Public lWaveform: DWORD;

This item has no description.

Public fDelay: Single;

0=triangle, 1=sine

Public lPhase: DWORD;


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_GARGLE

Record BASS_DX8_GARGLE

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_GARGLE = record

Description

This item has no description.

Overview

Fields

Public | dwRateHz: DWORD;
Public | dwWaveShape: DWORD;

Description

Fields

Public dwRateHz: DWORD;

This item has no description.

Public dwWaveShape: DWORD;

Rate of modulation in hz


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_I3DL2REVERB

Record BASS_DX8_I3DL2REVERB

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_I3DL2REVERB = record

Description

This item has no description.

Overview

Fields

Public | lRoom: Integer;
Public | lRoomHF: Integer;
Public | flRoomRolloffFactor: Single;
Public | flDecayTime: Single;
Public | flDecayHFRatio: Single;
Public | lReflections: Integer;
Public | flReflectionsDelay: Single;
Public | lReverb: Integer;
Public | flReverbDelay: Single;
Public | flDiffusion: Single;
Public | flDensity: Single;
Public | flHFReference: Single;

Description

Fields

Public lRoom: Integer;

This item has no description.

Public lRoomHF: Integer;

[-10000, 0] default: -1000 mB

Public flRoomRolloffFactor: Single;

[-10000, 0] default: 0 mB

Public flDecayTime: Single;

[0.0, 10.0] default: 0.0

Public flDecayHFRatio: Single;

[0.1, 20.0] default: 1.49s

Public lReflections: Integer;

[0.1, 2.0] default: 0.83

Public flReflectionsDelay: Single;

[-10000, 1000] default: -2602 mB

Public lReverb: Integer;

[0.0, 0.3] default: 0.007 s

Public flReverbDelay: Single;

[-10000, 2000] default: 200 mB

Public flDiffusion: Single;

[0.0, 0.1] default: 0.011 s

Public flDensity: Single;

[0.0, 100.0] default: 100.0 %

Public flHFReference: Single;

[0.0, 100.0] default: 100.0 %


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_PARAMEQ

Record BASS_DX8_PARAMEQ

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_PARAMEQ = record

Description

This item has no description.

Overview

Fields

Public | fCenter: Single;
Public | fBandwidth: Single;
Public | fGain: Single;

Description

Fields

Public fCenter: Single;

This item has no description.

Public fBandwidth: Single;

This item has no description.

Public fGain: Single;


GLSysHelp v.2.5: BASS.Import: Record BASS_DX8_REVERB

Record BASS_DX8_REVERB

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_DX8_REVERB = record

Description

This item has no description.

Overview

Fields

Public | fInGain: Single;
Public | fReverbMix: Single;
Public | fReverbTime: Single;
Public | fHighFreqRTRatio: Single;

Description

Fields

Public fInGain: Single;

This item has no description.

Public fReverbMix: Single;

[-96.0,0.0] default: 0.0 dB

Public fReverbTime: Single;

[-96.0,0.0] default: 0.0 db

Public fHighFreqRTRatio: Single;

[0.001,3000.0] default: 1000.0 ms


GLSysHelp v.2.5: BASS.Import: Record BASS_FX_VOLUME_PARAM

Record BASS_FX_VOLUME_PARAM

Description
Hierarchy
Fields
Methods
Properties

Unit

BASS.Import

Declaration

type BASS_FX_VOLUME_PARAM = record

Description

This item has no description.

Overview

Fields

Public | fTarget: Single;
Public | fCurrent: Single;
Public | fTime: Single;
Public | lCurve: DWORD;

Description

Fields

Public fTarget: Single;

This item has no description.

Public fCurrent: Single;

This item has no description.

Public fTime: Single;

This item has no description.

Public lCurve: DWORD;


GLSysHelp v.2.5: Cg.GL

Unit Cg.GL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

* * Copyright (c) 2002, NVIDIA Corporation. * * * * NVIDIA Corporation("NVIDIA") supplies this software to you in consideration * of your agreement to the following terms, and your use, installation, * modification or redistribution of this NVIDIA software constitutes * acceptance of these terms. If you do not agree with these terms, please do * not use, install, modify or redistribute this NVIDIA software. * * In consideration of your agreement to abide by the following terms, and * subject to these terms, NVIDIA grants you a personal, non-exclusive license, * under NVIDIARs copyrights in this original NVIDIA software (the "NVIDIA * Software"), to use, reproduce, modify and redistribute the NVIDIA * Software, with or without modifications, in source and/or binary forms; * provided that if you redistribute the NVIDIA Software, you must retain the * copyright notice of NVIDIA, this notice and the following text and * disclaimers in all such redistributions of the NVIDIA Software. Neither the * name, trademarks, service marks nor logos of NVIDIA Corporation may be used * to endorse or promote products derived from the NVIDIA Software without * specific prior written permission from NVIDIA. Except as expressly stated * in this notice, no other rights or licenses express or implied, are granted * by NVIDIA herein, including but not limited to any patent rights that may be * infringed by your derivative works or by other works in which the NVIDIA * Software may be incorporated. No hardware is licensed hereunder. * * THE NVIDIA SOFTWARE IS BEING PROVIDED ON AN "AS IS" BASIS, WITHOUT * WARRANTIES OR CONDITIONS OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING * WITHOUT LIMITATION, WARRANTIES OR CONDITIONS OF TITLE, NON-INFRINGEMENT, * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR ITS USE AND OPERATION * EITHER ALONE OR IN COMBINATION WITH OTHER PRODUCTS. * * IN NO EVENT SHALL NVIDIA BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL, * EXEMPLARY, CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, LOST * PROFITS; PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR * PROFITS; OR BUSINESS INTERRUPTION) OR ARISING IN ANY WAY OUT OF THE USE, * REPRODUCTION, MODIFICATION AND/OR DISTRIBUTION OF THE NVIDIA SOFTWARE, * HOWEVER CAUSED AND WHETHER UNDER THEORY OF CONTRACT, TORT (INCLUDING * NEGLIGENCE), STRICT LIABILITY OR OTHERWISE, EVEN IF NVIDIA HAS BEEN ADVISED * OF THE POSSIBILITY OF SUCH DAMAGE. *

Uses

  • Winapi.Windows
  • Cg.Import

Overview

Functions and Procedures

function cgGLIsProfileSupported(profile: TCGprofile): TCGbool; cdecl; external CgGLlibrary;
procedure cgGLEnableProfile(profile: TCGprofile); cdecl; external CgGLlibrary;
procedure cgGLDisableProfile(profile: TCGprofile); cdecl; external CgGLlibrary;
function cgGLGetLatestProfile(profile_type: TCGGLenum): TCGprofile; cdecl; external CgGLlibrary;
procedure cgGLSetOptimalOptions(profile: TCGprofile); cdecl; external CgGLlibrary;
procedure cgGLLoadProgram(_program: PCGprogram); cdecl; external CgGLlibrary;
function cgGLIsProgramLoaded(_program: PCGprogram): TCGbool; cdecl; external CgGLlibrary;
procedure cgGLBindProgram(_program: PCGprogram); cdecl; external CgGLlibrary;
procedure cgGLUnbindProgram(profile: TCGprofile); cdecl; external CgGLlibrary;
function cgGLGetProgramID(_program: PCGprogram): Cardinal; cdecl; external CgGLlibrary;
procedure cgGLSetParameter1f(param: PCGparameter; x: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2f(param: PCGparameter; x, y: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3f(param: PCGparameter; x, y, z: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4f(param: PCGparameter; x, y, z, w: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1d(param: PCGparameter; x: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2d(param: PCGparameter; x, y: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3d(param: PCGparameter; x, y, z: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4d(param: PCGparameter; x, y, z, w: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter1f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter2f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter3f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter4f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter1d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter2d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter3d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter4d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray1f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray2f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray3f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray4f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray1d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray2d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray3d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray4d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray1f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray2f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray3f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray4f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray1d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray2d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray3d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray4d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterPointer(param: PCGparameter; fsize: Integer; _type: Cardinal; stride: Integer; const _pointer: Pointer); cdecl; external CgGLlibrary;
procedure cgGLEnableClientState(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLDisableClientState(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterdr(param: PCGparameter; const matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterfr(param: PCGparameter; const matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterdc(param: PCGparameter; const matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterfc(param: PCGparameter; const matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterdr(param: PCGparameter; matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterfr(param: PCGparameter; matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterdc(param: PCGparameter; matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterfc(param: PCGparameter; matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetStateMatrixParameter(param: PCGparameter; matrix: TCGGLenum; transform: TCGGLenum); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArrayfc(param: PCGparameter; offset, nelements: Longint; const matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArrayfr(param: PCGparameter; offset, nelements: Longint; const matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArraydc(param: PCGparameter; offset, nelements: Longint; const matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArraydr(param: PCGparameter; offset, nelements: Longint; const matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArrayfc(param: PCGparameter; offset, nelements: Longint; matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArrayfr(param: PCGparameter; offset, nelements: Longint; matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArraydc(param: PCGparameter; offset, nelements: Longint; matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArraydr(param: PCGparameter; offset, nelements: Longint; matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetTextureParameter(param: PCGparameter; texobj: Cardinal); cdecl; external CgGLlibrary;
function cgGLGetTextureParameter(param: PCGparameter): Cardinal; cdecl; external CgGLlibrary;
procedure cgGLEnableTextureParameter(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLDisableTextureParameter(param: PCGparameter); cdecl; external CgGLlibrary;
function cgGLGetTextureEnum(param: PCGparameter): Cardinal; cdecl; external CgGLlibrary;
procedure cgGLSetManageTextureParameters(ctx: PCGcontext; flag: TCGbool); cdecl; external CgGLlibrary;
function cgGLGetManageTextureParameters(ctx: PCGcontext): TCGbool; cdecl; external CgGLlibrary;

Types

CGGLenum = TCGGLenum;
TCGGLenum = Cardinal;

Constants

CgGLlibrary = 'cgGL.dll';
CG_GL_MATRIX_IDENTITY = 0;
CG_GL_MATRIX_TRANSPOSE = 1;
CG_GL_MATRIX_INVERSE = 2;
CG_GL_MATRIX_INVERSE_TRANSPOSE = 3;
CG_GL_MODELVIEW_MATRIX = 4;
CG_GL_PROJECTION_MATRIX = 5;
CG_GL_TEXTURE_MATRIX = 6;
CG_GL_MODELVIEW_PROJECTION_MATRIX = 7;
CG_GL_VERTEX = 8;
CG_GL_FRAGMENT = 9;

Description

Functions and Procedures

function cgGLIsProfileSupported(profile: TCGprofile): TCGbool; cdecl; external CgGLlibrary;

***************************************************************************** *** Profile Functions ****************************************************************************

procedure cgGLEnableProfile(profile: TCGprofile); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLDisableProfile(profile: TCGprofile); cdecl; external CgGLlibrary;

This item has no description.

function cgGLGetLatestProfile(profile_type: TCGGLenum): TCGprofile; cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetOptimalOptions(profile: TCGprofile); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLLoadProgram(_program: PCGprogram); cdecl; external CgGLlibrary;

***************************************************************************** *** Program Managment Functions ****************************************************************************

function cgGLIsProgramLoaded(_program: PCGprogram): TCGbool; cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLBindProgram(_program: PCGprogram); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLUnbindProgram(profile: TCGprofile); cdecl; external CgGLlibrary;

This item has no description.

function cgGLGetProgramID(_program: PCGprogram): Cardinal; cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter1f(param: PCGparameter; x: Single); cdecl; external CgGLlibrary;

***************************************************************************** *** Parameter Managment Functions ****************************************************************************

procedure cgGLSetParameter2f(param: PCGparameter; x, y: Single); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter3f(param: PCGparameter; x, y, z: Single); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter4f(param: PCGparameter; x, y, z, w: Single); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter1fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter2fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter3fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter4fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter1d(param: PCGparameter; x: Double); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter2d(param: PCGparameter; x, y: Double); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter3d(param: PCGparameter; x, y, z: Double); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter4d(param: PCGparameter; x, y, z, w: Double); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter1dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter2dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter3dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameter4dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameter1f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameter2f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameter3f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameter4f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameter1d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameter2d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameter3d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameter4d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterArray1f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterArray2f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterArray3f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterArray4f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterArray1d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterArray2d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterArray3d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterArray4d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameterArray1f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameterArray2f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameterArray3f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameterArray4f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameterArray1d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameterArray2d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameterArray3d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetParameterArray4d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetParameterPointer(param: PCGparameter; fsize: Integer; _type: Cardinal; stride: Integer; const _pointer: Pointer); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLEnableClientState(param: PCGparameter); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLDisableClientState(param: PCGparameter); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetMatrixParameterdr(param: PCGparameter; const matrix: PDouble); cdecl; external CgGLlibrary;

***************************************************************************** *** Matrix Parameter Managment Functions ****************************************************************************

procedure cgGLSetMatrixParameterfr(param: PCGparameter; const matrix: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetMatrixParameterdc(param: PCGparameter; const matrix: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetMatrixParameterfc(param: PCGparameter; const matrix: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetMatrixParameterdr(param: PCGparameter; matrix: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetMatrixParameterfr(param: PCGparameter; matrix: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetMatrixParameterdc(param: PCGparameter; matrix: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetMatrixParameterfc(param: PCGparameter; matrix: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetStateMatrixParameter(param: PCGparameter; matrix: TCGGLenum; transform: TCGGLenum); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetMatrixParameterArrayfc(param: PCGparameter; offset, nelements: Longint; const matrices: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetMatrixParameterArrayfr(param: PCGparameter; offset, nelements: Longint; const matrices: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetMatrixParameterArraydc(param: PCGparameter; offset, nelements: Longint; const matrices: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetMatrixParameterArraydr(param: PCGparameter; offset, nelements: Longint; const matrices: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetMatrixParameterArrayfc(param: PCGparameter; offset, nelements: Longint; matrices: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetMatrixParameterArrayfr(param: PCGparameter; offset, nelements: Longint; matrices: PSingle); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetMatrixParameterArraydc(param: PCGparameter; offset, nelements: Longint; matrices: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLGetMatrixParameterArraydr(param: PCGparameter; offset, nelements: Longint; matrices: PDouble); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetTextureParameter(param: PCGparameter; texobj: Cardinal); cdecl; external CgGLlibrary;

***************************************************************************** *** Texture Parameter Managment Functions ****************************************************************************

function cgGLGetTextureParameter(param: PCGparameter): Cardinal; cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLEnableTextureParameter(param: PCGparameter); cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLDisableTextureParameter(param: PCGparameter); cdecl; external CgGLlibrary;

This item has no description.

function cgGLGetTextureEnum(param: PCGparameter): Cardinal; cdecl; external CgGLlibrary;

This item has no description.

procedure cgGLSetManageTextureParameters(ctx: PCGcontext; flag: TCGbool); cdecl; external CgGLlibrary;

This item has no description.

function cgGLGetManageTextureParameters(ctx: PCGcontext): TCGbool; cdecl; external CgGLlibrary;

This item has no description.

Types

CGGLenum = TCGGLenum;

This item has no description.

TCGGLenum = Cardinal;

***************************************************************************

Constants

CgGLlibrary = 'cgGL.dll';

This item has no description.

CG_GL_MATRIX_IDENTITY = 0;

This item has no description.

CG_GL_MATRIX_TRANSPOSE = 1;

This item has no description.

CG_GL_MATRIX_INVERSE = 2;

This item has no description.

CG_GL_MATRIX_INVERSE_TRANSPOSE = 3;

This item has no description.

CG_GL_MODELVIEW_MATRIX = 4;

This item has no description.

CG_GL_PROJECTION_MATRIX = 5;

This item has no description.

CG_GL_TEXTURE_MATRIX = 6;

This item has no description.

CG_GL_MODELVIEW_PROJECTION_MATRIX = 7;

This item has no description.

CG_GL_VERTEX = 8;

This item has no description.

CG_GL_FRAGMENT = 9;


GLSysHelp v.2.5: Cg.Import

Unit Cg.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

* Copyright (c) 2002, NVIDIA Corporation. * * NVIDIA Corporation("NVIDIA") supplies this software to you in consideration * of your agreement to the following terms, and your use, installation, * modification or redistribution of this NVIDIA software constitutes * acceptance of these terms. If you do not agree with these terms, please do * not use, install, modify or redistribute this NVIDIA software. * * In consideration of your agreement to abide by the following terms, and * subject to these terms, NVIDIA grants you a personal, non-exclusive license, * under NVIDIAs copyrights in this original NVIDIA software (the "NVIDIA * Software"), to use, reproduce, modify and redistribute the NVIDIA * Software, with or without modifications, in source and/or binary forms; * provided that if you redistribute the NVIDIA Software, you must retain the * copyright notice of NVIDIA, this notice and the following text and * disclaimers in all such redistributions of the NVIDIA Software. Neither the * name, trademarks, service marks nor logos of NVIDIA Corporation may be used * to endorse or promote products derived from the NVIDIA Software without * specific prior written permission from NVIDIA. Except as expressly stated * in this notice, no other rights or licenses express or implied, are granted * by NVIDIA herein, including but not limited to any patent rights that may be * infringed by your derivative works or by other works in which the NVIDIA * Software may be incorporated. No hardware is licensed hereunder. * * THE NVIDIA SOFTWARE IS BEING PROVIDED ON AN "AS IS" BASIS, WITHOUT * WARRANTIES OR CONDITIONS OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING * WITHOUT LIMITATION, WARRANTIES OR CONDITIONS OF TITLE, NON-INFRINGEMENT, * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR ITS USE AND OPERATION * EITHER ALONE OR IN COMBINATION WITH OTHER PRODUCTS. * * IN NO EVENT SHALL NVIDIA BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL, * EXEMPLARY, CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, LOST * PROFITS; PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR * PROFITS; OR BUSINESS INTERRUPTION) OR ARISING IN ANY WAY OUT OF THE USE, * REPRODUCTION, MODIFICATION AND/OR DISTRIBUTION OF THE NVIDIA SOFTWARE, * HOWEVER CAUSED AND WHETHER UNDER THEORY OF CONTRACT, TORT (INCLUDING * NEGLIGENCE), STRICT LIABILITY OR OTHERWISE, EVEN IF NVIDIA HAS BEEN ADVISED * OF THE POSSIBILITY OF SUCH DAMAGE.

Uses

  • Winapi.Windows

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record _CGcontext |
Record _CGprogram |
Record _CGparameter |

Functions and Procedures

function cgCreateContext: PCGcontext; cdecl; external CgLibrary;
procedure cgDestroyContext(ctx: PCGcontext); cdecl; external CgLibrary;
function cgIsContext(ctx: PCGcontext): TCGbool; cdecl; external CgLibrary;
function cgGetLastListing(ctx: PCGcontext): PChar; cdecl; external CgLibrary;
procedure cgSetAutoCompile(ctx: PCGcontext; flag: TCGenum); cdecl; external CgLibrary;
function cgCreateProgram(ctx: PCGcontext; program_type: TCGenum; const _program: PCharCG; profile: TCGprofile; const entry: PCharCG; const args: PPCharCG): PCGprogram; cdecl; external CgLibrary;
function cgCreateProgramFromFile(ctx: PCGcontext; program_type: TCGenum; const program_file: PCharCG; profile: TCGprofile; const entry: PCharCG; const args: PPCharCG): PCGprogram; cdecl; external CgLibrary;
function cgCopyProgram(_program: PCGprogram): PCGprogram; cdecl; external CgLibrary;
procedure cgDestroyProgram(_program: PCGprogram); cdecl; external CgLibrary;
function cgGetFirstProgram(ctx: PCGcontext): PCGprogram; cdecl; external CgLibrary;
function cgGetNextProgram(current: PCGprogram): PCGprogram; cdecl; external CgLibrary;
function cgGetProgramContext(prog: PCGprogram): PCGcontext; cdecl; external CgLibrary;
function cgIsProgram(_program: PCGprogram): TCGbool; cdecl; external CgLibrary;
procedure cgCompileProgram(_program: PCGprogram); cdecl; external CgLibrary;
function cgIsProgramCompiled(_program: PCGprogram): TCGbool; cdecl; external CgLibrary;
function cgGetProgramString(prog: PCGprogram; pname: TCGenum): PCharCG; cdecl; external CgLibrary;
function cgGetProgramProfile(prog: PCGprogram): TCGprofile; cdecl; external CgLibrary;
function cgCreateParameter(ctx: PCGcontext; type_: TCGtype): PCGparameter; cdecl; external CgLibrary;
function cgCreateParameterArray(ctx: PCGcontext; type_: TCGtype; length: Integer): PCGparameter; cdecl; external CgLibrary;
function cgCreateParameterMultiDimArray(ctx: PCGcontext; type_: TCGtype; dim: Integer; const lengths: PInteger): PCGparameter; cdecl; external CgLibrary;
procedure cgDestroyParameter(param: PCGparameter); cdecl; external CgLibrary;
procedure cgConnectParameter(from, to_: PCGparameter); cdecl; external CgLibrary;
procedure cgDisconnectParameter(param: PCGparameter); cdecl; external CgLibrary;
function cgGetConnectedParameter(param: PCGparameter): PCGparameter; cdecl; external CgLibrary;
function cgGetNumConnectedToParameters(param: PCGparameter): Integer; cdecl; external CgLibrary;
function cgGetConnectedToParameter(param: PCGparameter; index: Integer): PCGparameter; cdecl; external CgLibrary;
function cgGetNamedParameter(prog: PCGprogram; const name: PCharCG): PCGparameter; cdecl; external CgLibrary;
function cgGetNamedProgramParameter(prog: PCGprogram; name_space: TCGenum; const name: PCharCG): PCGparameter; cdecl; external CgLibrary;
function cgGetFirstParameter(prog: PCGprogram; name_space: TCGenum): PCGparameter; cdecl; external CgLibrary;
function cgGetNextParameter(current: PCGparameter): PCGparameter; cdecl; external CgLibrary;
function cgGetFirstLeafParameter(prog: PCGprogram; name_space: TCGenum): PCGparameter; cdecl; external CgLibrary;
function cgGetNextLeafParameter(current: PCGparameter): PCGparameter; cdecl; external CgLibrary;
function cgGetFirstStructParameter(param: PCGparameter): PCGparameter; cdecl; external CgLibrary;
function cgGetNamedStructParameter(param: PCGparameter; const name: PCharCG): PCGparameter; cdecl; external CgLibrary;
function cgGetFirstDependentParameter(param: PCGparameter): PCGparameter; cdecl; external CgLibrary;
function cgGetArrayParameter(aparam: PCGparameter; index: Integer): PCGparameter; cdecl; external CgLibrary;
function cgGetArrayDimension(param: PCGparameter): Integer; cdecl; external CgLibrary;
function cgGetArrayType(param: PCGparameter): TCGtype; cdecl; external CgLibrary;
function cgGetArraySize(param: PCGparameter; dimension: Integer): Integer; cdecl; external CgLibrary;
procedure cgSetArraySize(param: PCGparameter; size: Integer); cdecl; external CgLibrary;
procedure cgSetMultiDimArraySize(param: PCGparameter; const sizes: PInteger); cdecl; external CgLibrary;
function cgGetParameterProgram(param: PCGparameter): PCGprogram; cdecl; external CgLibrary;
function cgGetParameterContext(param: PCGparameter): PCGcontext; cdecl; external CgLibrary;
function cgIsParameter(param: PCGparameter): TCGbool; cdecl; external CgLibrary;
function cgGetParameterName(param: PCGparameter): PCharCG; cdecl; external CgLibrary;
function cgGetParameterType(param: PCGparameter): TCGtype; cdecl; external CgLibrary;
function cgGetParameterNamedType(param: PCGparameter): TCGtype; cdecl; external CgLibrary;
function cgGetParameterSemantic(param: PCGparameter): PCharCG; cdecl; external CgLibrary;
function cgGetParameterResource(param: PCGparameter): TCGresource; cdecl; external CgLibrary;
function cgGetParameterBaseResource(param: PCGparameter): TCGresource; cdecl; external CgLibrary;
function cgGetParameterResourceIndex(param: PCGparameter): LongWord; cdecl; external CgLibrary;
function cgGetParameterVariability(param: PCGparameter): TCGenum; cdecl; external CgLibrary;
function cgGetParameterDirection(param: PCGparameter): TCGenum; cdecl; external CgLibrary;
function cgIsParameterReferenced(param: PCGparameter): TCGbool; cdecl; external CgLibrary;
function cgGetParameterValues(param: PCGparameter; value_type: TCGenum; out nvalues: Integer): PDouble; cdecl; external CgLibrary;
function cgGetParameterOrdinalNumber(param: PCGparameter): Integer; cdecl; external CgLibrary;
function cgIsParameterGlobal(param: PCGparameter): TCGbool; cdecl; external CgLibrary;
function cgGetParameterIndex(param: PCGparameter): Integer; cdecl; external CgLibrary;
procedure cgSetParameterVariability(param: PCGparameter; vary: TCGenum); cdecl; external CgLibrary;
procedure cgSetParameterSemantic(param: PCGparameter; const semantic: PCharCG); cdecl; external CgLibrary;
procedure cgSetParameter1f(param: PCGparameter; x: Single); cdecl; external CgLibrary;
procedure cgSetParameter2f(param: PCGparameter; x, y: Single); cdecl; external CgLibrary;
procedure cgSetParameter3f(param: PCGparameter; x, y, z: Single); cdecl; external CgLibrary;
procedure cgSetParameter4f(param: PCGparameter; x, y, z, w: Single); cdecl; external CgLibrary;
procedure cgSetParameter1d(param: PCGparameter; x: Double); cdecl; external CgLibrary;
procedure cgSetParameter2d(param: PCGparameter; x, y: Double); cdecl; external CgLibrary;
procedure cgSetParameter3d(param: PCGparameter; x, y, z: Double); cdecl; external CgLibrary;
procedure cgSetParameter4d(param: PCGparameter; x, y, z, w: Double); cdecl; external CgLibrary;
procedure cgSetParameter1fv(param: PCGparameter; const v: PSingle); cdecl; external CgLibrary;
procedure cgSetParameter2fv(param: PCGparameter; const v: PSingle); cdecl; external CgLibrary;
procedure cgSetParameter3fv(param: PCGparameter; const v: PSingle); cdecl; external CgLibrary;
procedure cgSetParameter4fv(param: PCGparameter; const v: PSingle); cdecl; external CgLibrary;
procedure cgSetParameter1dv(param: PCGparameter; const x: PDouble); cdecl; external CgLibrary;
procedure cgSetParameter2dv(param: PCGparameter; const x: PDouble); cdecl; external CgLibrary;
procedure cgSetParameter3dv(param: PCGparameter; const x: PDouble); cdecl; external CgLibrary;
procedure cgSetParameter4dv(param: PCGparameter; const x: PDouble); cdecl; external CgLibrary;
procedure cgSetMatrixParameterdr(param: PCGparameter; const matrix: PDouble); cdecl; external CgLibrary;
procedure cgSetMatrixParameterfr(param: PCGparameter; const matrix: PSingle); cdecl; external CgLibrary;
procedure cgSetMatrixParameterdc(param: PCGparameter; const matrix: PDouble); cdecl; external CgLibrary;
procedure cgSetMatrixParameterfc(param: PCGparameter; const matrix: PSingle); cdecl; external CgLibrary;
function cgGetTypeString(_type: TCGtype): PCharCG; cdecl; external CgLibrary;
function cgGetType(const type_string: PCharCG): TCGtype; cdecl; external CgLibrary;
function cgGetNamedUserType(program_: CGprogram; const name: PCharCG): TCGtype; cdecl; external CgLibrary;
function cgGetNumUserTypes(program_: CGprogram): Integer; cdecl; external CgLibrary;
function cgGetUserType(program_: CGprogram; index: Integer): TCGtype; cdecl; external CgLibrary;
function cgGetNumParentTypes(type_: TCGtype): Integer; cdecl; external CgLibrary;
function cgGetParentType(type_: TCGtype; index: Integer): TCGtype; cdecl; external CgLibrary;
function cgIsParentType(parent, child: TCGtype): TCGbool; cdecl; external CgLibrary;
function cgIsInterfaceType(type_: TCGtype): TCGbool; cdecl; external CgLibrary;
function cgGetResourceString(resource: TCGresource): PCharCG; cdecl; external CgLibrary;
function cgGetResource(const resource_string: PCharCG): TCGresource; cdecl; external CgLibrary;
function cgGetEnumString(en: TCGenum): PCharCG; cdecl; external CgLibrary;
function cgGetEnum(const enum_string: PCharCG): TCGenum; cdecl; external CgLibrary;
function cgGetProfileString(profile: TCGprofile): PCharCG; cdecl; external CgLibrary;
function cgGetProfile(const profile_string: PCharCG): TCGprofile; cdecl; external CgLibrary;
function cgGetError: TCGerror; cdecl; external CgLibrary;
function cgGetErrorString(error: TCGerror): PCharCG; cdecl; external CgLibrary;
function cgGetLastErrorString(error: PCGerror): PCharCG; cdecl; external CgLibrary;
procedure cgSetErrorCallback(func: TCGerrorCallbackFunc); cdecl; external CgLibrary;
function cgGetErrorCallback: TCGerrorCallbackFunc; cdecl; external CgLibrary;
function cgGetString(sname: TCGenum): PCharCG; cdecl; external CgLibrary;
function cgGetNextParameter_depr1_1(current: PCGparameter): PCGparameter; cdecl; external CgLibrary;
function cgGetNextLeafParameter_depr1_1(current: PCGparameter): PCGparameter; cdecl; external CgLibrary;

Types

CGbool = TCGbool;
CGcontext = PCGcontext;
CGenum = TCGenum;
CGerror = TCGerror;
CGerrorCallbackFunc = TCGerrorCallbackFunc;
CGparameter = PCGparameter;
CGprofile = TCGprofile;
CGprogram = PCGprogram;
CGresource = TCGresource;
CGtype = TCGtype;
PCGcontext = ˆ_CGcontext;
PCGerror = ˆTCGerror;
PCGparameter = ˆ_CGparameter;
PCGprogram = ˆ_CGprogram;
PCharCG = PAnsiChar;
PPCharCG = ˆPCharCG;
StringCG = AnsiString;
TCGbool = Integer;
TCGenum = (...);
TCGerror = DWORD;
TCGerrorCallbackFunc = procedure; cdecl;
TCGprofile = (...);
TCGresource = (...);
TCGtype = (...);

Constants

CgLibrary = 'cg.dll';
CG_VERSION_1_2 = 1;
CG_VERSION_NUM = 1200;
CG_FALSE = TCGbool(0);
CG_TRUE = TCGbool(1);
CG_NO_ERROR = 0;
CG_COMPILER_ERROR = 1;
CG_INVALID_PARAMETER_ERROR = 2;
CG_INVALID_PROFILE_ERROR = 3;
CG_PROGRAM_LOAD_ERROR = 4;
CG_PROGRAM_BIND_ERROR = 5;
CG_PROGRAM_NOT_LOADED_ERROR = 6;
CG_UNSUPPORTED_GL_EXTENSION_ERROR = 7;
CG_INVALID_VALUE_TYPE_ERROR = 8;
CG_NOT_MATRIX_PARAM_ERROR = 9;
CG_INVALID_ENUMERANT_ERROR = 10;
CG_NOT_4x4_MATRIX_ERROR = 11;
CG_FILE_READ_ERROR = 12;
CG_FILE_WRITE_ERROR = 13;
CG_NVPARSE_ERROR = 14;
CG_MEMORY_ALLOC_ERROR = 15;
CG_INVALID_CONTEXT_HANDLE_ERROR = 16;
CG_INVALID_PROGRAM_HANDLE_ERROR = 17;
CG_INVALID_PARAM_HANDLE_ERROR = 18;
CG_UNKNOWN_PROFILE_ERROR = 19;
CG_VAR_ARG_ERROR = 20;
CG_INVALID_DIMENSION_ERROR = 21;
CG_ARRAY_PARAM_ERROR = 22;
CG_OUT_OF_ARRAY_BOUNDS_ERROR = 23;
CG_CONFLICTING_TYPES_ERROR = 24;
CG_CONFLICTING_PARAMETER_TYPES_ERROR = 25;
CG_PARAMETER_IS_NOT_SHARED_ERROR = 26;
CG_INVALID_PARAMETER_VARIABILITY_ERROR = 27;
CG_CANNOT_DESTROY_PARAMETER_ERROR = 28;
CG_NOT_ROOT_PARAMETER_ERROR = 29;
CG_PARAMETERS_DO_NOT_MATCH_ERROR = 30;
CG_IS_NOT_PROGRAM_PARAMETER_ERROR = 31;
CG_INVALID_PARAMETER_TYPE_ERROR = 32;
CG_PARAMETER_IS_NOT_RESIZABLE_ARRAY_ERROR = 33;
CG_INVALID_SIZE_ERROR = 34;
CG_BIND_CREATES_CYCLE_ERROR = 35;
CG_ARRAY_TYPES_DO_NOT_MATCH_ERROR = 36;
CG_ARRAY_DIMENSIONS_DO_NOT_MATCH_ERROR = 37;
CG_ARRAY_HAS_WRONG_DIMENSION_ERROR = 38;
CG_TYPE_IS_NOT_DEFINED_IN_PROGRAM_ERROR = 39;

Description

Functions and Procedures

function cgCreateContext: PCGcontext; cdecl; external CgLibrary;

** Context functions **

procedure cgDestroyContext(ctx: PCGcontext); cdecl; external CgLibrary;

This item has no description.

function cgIsContext(ctx: PCGcontext): TCGbool; cdecl; external CgLibrary;

This item has no description.

function cgGetLastListing(ctx: PCGcontext): PChar; cdecl; external CgLibrary;

This item has no description.

procedure cgSetAutoCompile(ctx: PCGcontext; flag: TCGenum); cdecl; external CgLibrary;

This item has no description.

function cgCreateProgram(ctx: PCGcontext; program_type: TCGenum; const _program: PCharCG; profile: TCGprofile; const entry: PCharCG; const args: PPCharCG): PCGprogram; cdecl; external CgLibrary;

** Program functions **

function cgCreateProgramFromFile(ctx: PCGcontext; program_type: TCGenum; const program_file: PCharCG; profile: TCGprofile; const entry: PCharCG; const args: PPCharCG): PCGprogram; cdecl; external CgLibrary;

This item has no description.

function cgCopyProgram(_program: PCGprogram): PCGprogram; cdecl; external CgLibrary;

This item has no description.

procedure cgDestroyProgram(_program: PCGprogram); cdecl; external CgLibrary;

This item has no description.

function cgGetFirstProgram(ctx: PCGcontext): PCGprogram; cdecl; external CgLibrary;

This item has no description.

function cgGetNextProgram(current: PCGprogram): PCGprogram; cdecl; external CgLibrary;

This item has no description.

function cgGetProgramContext(prog: PCGprogram): PCGcontext; cdecl; external CgLibrary;

This item has no description.

function cgIsProgram(_program: PCGprogram): TCGbool; cdecl; external CgLibrary;

This item has no description.

procedure cgCompileProgram(_program: PCGprogram); cdecl; external CgLibrary;

This item has no description.

function cgIsProgramCompiled(_program: PCGprogram): TCGbool; cdecl; external CgLibrary;

This item has no description.

function cgGetProgramString(prog: PCGprogram; pname: TCGenum): PCharCG; cdecl; external CgLibrary;

This item has no description.

function cgGetProgramProfile(prog: PCGprogram): TCGprofile; cdecl; external CgLibrary;

This item has no description.

function cgCreateParameter(ctx: PCGcontext; type_: TCGtype): PCGparameter; cdecl; external CgLibrary;

** Parameter functions **

function cgCreateParameterArray(ctx: PCGcontext; type_: TCGtype; length: Integer): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgCreateParameterMultiDimArray(ctx: PCGcontext; type_: TCGtype; dim: Integer; const lengths: PInteger): PCGparameter; cdecl; external CgLibrary;

This item has no description.

procedure cgDestroyParameter(param: PCGparameter); cdecl; external CgLibrary;

This item has no description.

procedure cgConnectParameter(from, to_: PCGparameter); cdecl; external CgLibrary;

This item has no description.

procedure cgDisconnectParameter(param: PCGparameter); cdecl; external CgLibrary;

This item has no description.

function cgGetConnectedParameter(param: PCGparameter): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetNumConnectedToParameters(param: PCGparameter): Integer; cdecl; external CgLibrary;

This item has no description.

function cgGetConnectedToParameter(param: PCGparameter; index: Integer): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetNamedParameter(prog: PCGprogram; const name: PCharCG): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetNamedProgramParameter(prog: PCGprogram; name_space: TCGenum; const name: PCharCG): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetFirstParameter(prog: PCGprogram; name_space: TCGenum): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetNextParameter(current: PCGparameter): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetFirstLeafParameter(prog: PCGprogram; name_space: TCGenum): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetNextLeafParameter(current: PCGparameter): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetFirstStructParameter(param: PCGparameter): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetNamedStructParameter(param: PCGparameter; const name: PCharCG): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetFirstDependentParameter(param: PCGparameter): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetArrayParameter(aparam: PCGparameter; index: Integer): PCGparameter; cdecl; external CgLibrary;

This item has no description.

function cgGetArrayDimension(param: PCGparameter): Integer; cdecl; external CgLibrary;

This item has no description.

function cgGetArrayType(param: PCGparameter): TCGtype; cdecl; external CgLibrary;

This item has no description.

function cgGetArraySize(param: PCGparameter; dimension: Integer): Integer; cdecl; external CgLibrary;

This item has no description.

procedure cgSetArraySize(param: PCGparameter; size: Integer); cdecl; external CgLibrary;

This item has no description.

procedure cgSetMultiDimArraySize(param: PCGparameter; const sizes: PInteger); cdecl; external CgLibrary;

This item has no description.

function cgGetParameterProgram(param: PCGparameter): PCGprogram; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterContext(param: PCGparameter): PCGcontext; cdecl; external CgLibrary;

This item has no description.

function cgIsParameter(param: PCGparameter): TCGbool; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterName(param: PCGparameter): PCharCG; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterType(param: PCGparameter): TCGtype; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterNamedType(param: PCGparameter): TCGtype; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterSemantic(param: PCGparameter): PCharCG; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterResource(param: PCGparameter): TCGresource; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterBaseResource(param: PCGparameter): TCGresource; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterResourceIndex(param: PCGparameter): LongWord; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterVariability(param: PCGparameter): TCGenum; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterDirection(param: PCGparameter): TCGenum; cdecl; external CgLibrary;

This item has no description.

function cgIsParameterReferenced(param: PCGparameter): TCGbool; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterValues(param: PCGparameter; value_type: TCGenum; out nvalues: Integer): PDouble; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterOrdinalNumber(param: PCGparameter): Integer; cdecl; external CgLibrary;

This item has no description.

function cgIsParameterGlobal(param: PCGparameter): TCGbool; cdecl; external CgLibrary;

This item has no description.

function cgGetParameterIndex(param: PCGparameter): Integer; cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameterVariability(param: PCGparameter; vary: TCGenum); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameterSemantic(param: PCGparameter; const semantic: PCharCG); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter1f(param: PCGparameter; x: Single); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter2f(param: PCGparameter; x, y: Single); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter3f(param: PCGparameter; x, y, z: Single); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter4f(param: PCGparameter; x, y, z, w: Single); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter1d(param: PCGparameter; x: Double); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter2d(param: PCGparameter; x, y: Double); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter3d(param: PCGparameter; x, y, z: Double); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter4d(param: PCGparameter; x, y, z, w: Double); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter1fv(param: PCGparameter; const v: PSingle); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter2fv(param: PCGparameter; const v: PSingle); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter3fv(param: PCGparameter; const v: PSingle); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter4fv(param: PCGparameter; const v: PSingle); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter1dv(param: PCGparameter; const x: PDouble); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter2dv(param: PCGparameter; const x: PDouble); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter3dv(param: PCGparameter; const x: PDouble); cdecl; external CgLibrary;

This item has no description.

procedure cgSetParameter4dv(param: PCGparameter; const x: PDouble); cdecl; external CgLibrary;

This item has no description.

procedure cgSetMatrixParameterdr(param: PCGparameter; const matrix: PDouble); cdecl; external CgLibrary;

This item has no description.

procedure cgSetMatrixParameterfr(param: PCGparameter; const matrix: PSingle); cdecl; external CgLibrary;

This item has no description.

procedure cgSetMatrixParameterdc(param: PCGparameter; const matrix: PDouble); cdecl; external CgLibrary;

This item has no description.

procedure cgSetMatrixParameterfc(param: PCGparameter; const matrix: PSingle); cdecl; external CgLibrary;

This item has no description.

function cgGetTypeString(_type: TCGtype): PCharCG; cdecl; external CgLibrary;

** Type Functions **

function cgGetType(const type_string: PCharCG): TCGtype; cdecl; external CgLibrary;

This item has no description.

function cgGetNamedUserType(program_: CGprogram; const name: PCharCG): TCGtype; cdecl; external CgLibrary;

This item has no description.

function cgGetNumUserTypes(program_: CGprogram): Integer; cdecl; external CgLibrary;

This item has no description.

function cgGetUserType(program_: CGprogram; index: Integer): TCGtype; cdecl; external CgLibrary;

This item has no description.

function cgGetNumParentTypes(type_: TCGtype): Integer; cdecl; external CgLibrary;

This item has no description.

function cgGetParentType(type_: TCGtype; index: Integer): TCGtype; cdecl; external CgLibrary;

This item has no description.

function cgIsParentType(parent, child: TCGtype): TCGbool; cdecl; external CgLibrary;

This item has no description.

function cgIsInterfaceType(type_: TCGtype): TCGbool; cdecl; external CgLibrary;

This item has no description.

function cgGetResourceString(resource: TCGresource): PCharCG; cdecl; external CgLibrary;

** Resource Functions **

function cgGetResource(const resource_string: PCharCG): TCGresource; cdecl; external CgLibrary;

This item has no description.

function cgGetEnumString(en: TCGenum): PCharCG; cdecl; external CgLibrary;

*** Enum Functions ***

function cgGetEnum(const enum_string: PCharCG): TCGenum; cdecl; external CgLibrary;

This item has no description.

function cgGetProfileString(profile: TCGprofile): PCharCG; cdecl; external CgLibrary;

** Profile Functions **

function cgGetProfile(const profile_string: PCharCG): TCGprofile; cdecl; external CgLibrary;

This item has no description.

function cgGetError: TCGerror; cdecl; external CgLibrary;

** Error Functions **

function cgGetErrorString(error: TCGerror): PCharCG; cdecl; external CgLibrary;

This item has no description.

function cgGetLastErrorString(error: PCGerror): PCharCG; cdecl; external CgLibrary;

This item has no description.

procedure cgSetErrorCallback(func: TCGerrorCallbackFunc); cdecl; external CgLibrary;

This item has no description.

function cgGetErrorCallback: TCGerrorCallbackFunc; cdecl; external CgLibrary;

This item has no description.

function cgGetString(sname: TCGenum): PCharCG; cdecl; external CgLibrary;

*** Misc Functions ***

function cgGetNextParameter_depr1_1(current: PCGparameter): PCGparameter; cdecl; external CgLibrary;

*** Support for deprecated Cg 1.1 API ***

function cgGetNextLeafParameter_depr1_1(current: PCGparameter): PCGparameter; cdecl; external CgLibrary;

This item has no description.

Types

CGbool = TCGbool;

This item has no description.

CGcontext = PCGcontext;

This item has no description.

CGenum = TCGenum;

This item has no description.

CGerror = TCGerror;

This item has no description.

CGerrorCallbackFunc = TCGerrorCallbackFunc;

This item has no description.

CGparameter = PCGparameter;

This item has no description.

CGprofile = TCGprofile;

This item has no description.

CGprogram = PCGprogram;

This item has no description.

CGresource = TCGresource;

This item has no description.

CGtype = TCGtype;

CG_DATATYPE_MACRO(Bool4x4,bool4x4,CG_BOOL4x4,4,4)

PCGcontext = ˆ_CGcontext;

This item has no description.

PCGerror = ˆTCGerror;

* The following macro invocations define error codes returned by various cg * API functions. * * The macros have the form : * * CG_ERROR_MACRO(code, enum_name, message) * * code : The integer error code associated with the error. * enum_name : The name of enumerant of the error code in the API. * message : A description string associated with the error. *

PCGparameter = ˆ_CGparameter;

This item has no description.

PCGprogram = ˆ_CGprogram;

This item has no description.

PCharCG = PAnsiChar;

***********************************************************************

PPCharCG = ˆPCharCG;

This item has no description.

StringCG = AnsiString;

This item has no description.

TCGbool = Integer;

This item has no description.

TCGenum = (...);

"Connecting the parameters failed because The type of the source parameter is not defined within the given program or does not match the type with the same name in the program."

Values
  • CG_UNKNOWN = 4096: todo: Insert code from here: # include <Cg/cg_enums.h> todo: FIX BCB6 issues with {$IFDEF BCB}
  • CG_IN
  • CG_OUT
  • CG_INOUT
  • CG_MIXED
  • CG_VARYING
  • CG_UNIFORM
  • CG_CONSTANT
  • CG_PROGRAM_SOURCE
  • CG_PROGRAM_ENTRY
  • CG_COMPILED_PROGRAM
  • CG_PROGRAM_PROFILE
  • CG_GLOBAL
  • CG_PROGRAM
  • CG_DEFAULT
  • CG_ERROR
  • CG_SOURCE
  • CG_OBJECT
  • CG_COMPILE_MANUAL
  • CG_COMPILE_IMMEDIATE
  • CG_COMPILE_LAZY
  • CG_CURRENT
  • CG_LITERAL
  • CG_VERSION
TCGerror = DWORD;

This item has no description.

TCGerrorCallbackFunc = procedure; cdecl;

This item has no description.

TCGprofile = (...);

* The following macro invocations define the supported CG profiles. * * The macros have the form : * * CG_PROFILE_MACRO(name, compiler_id, compiler_opt) * * name : The name of the profile. Used consistently with the API. * compiler_id : The identifier string for the profile used by the compiler. * compiler_id_caps : compiler_id in caps. * compiler_opt : The command-line switch used to force compilation into * the profile. * int_id : Integer enumerant associated with this bind location. * vertex_profile : Non-zero if this is a vertex profile, otherwise it * is considered to be a fragment profile. * *

Values
  • CG_PROFILE_START = 6144
  • CG_PROFILE_UNKNOWN
  • CG_PROFILE_VP20 = 6146: # define CG_PROFILE_MACRO(name, compiler_id, compiler_id_caps, compiler_opt,int_id,vertex_profile) \ CG_PROFILE_##compiler_id_caps = int_id,
  • CG_PROFILE_FP20 = 6147: CG_PROFILE_MACRO(Vertex,vp20,VP20,"vp20",6146,1)
  • CG_PROFILE_VP30 = 6148: CG_PROFILE_MACRO(Fragment20,fp20,FP20,"fp20",6147,0)
  • CG_PROFILE_FP30 = 6149: CG_PROFILE_MACRO(Vertex30,vp30,VP30,"vp30",6148,1)
  • CG_PROFILE_ARBVP1 = 6150: CG_PROFILE_MACRO(Fragment,fp30,FP30,"fp30",6149,0)
  • CG_PROFILE_ARBFP1 = 7000: CG_PROFILE_MACRO(ARBVertex,arbvp1,ARBVP1,"arbvp1",6150,1)
  • CG_PROFILE_VP40 = 7001: CG_PROFILE_MACRO(ARBFragment,arbfp1,ARBFP1,"arbfp1",7000,0)
  • CG_PROFILE_FP40 = 6151: CG_PROFILE_MACRO(Vertex40,vp40,VP40,"vp40",7001,1)
  • CG_PROFILE_VS_1_1 = 6153: CG_PROFILE_MACRO(Fragment40,fp40,FP40,"fp40",6151,0)
  • CG_PROFILE_VS_2_0 = 6154: CG_PROFILE_MACRO(DX9Vertex11,vs_1_1,VS_1_1,"vs_1_1",6153,1)
  • CG_PROFILE_VS_2_X = 6155: CG_PROFILE_MACRO(DX9Vertex20,vs_2_0,VS_2_0,"vs_2_0",6154,1)
  • CG_PROFILE_PS_1_1 = 6159: CG_PROFILE_MACRO(DX9Vertex2x,vs_2_x,VS_2_X,"vs_2_x",6155,1)
  • CG_PROFILE_PS_1_2 = 6160: CG_PROFILE_MACRO(DX9Pixel11,ps_1_1,PS_1_1,"ps_1_1",6159,0)
  • CG_PROFILE_PS_1_3 = 6161: CG_PROFILE_MACRO(DX9Pixel12,ps_1_2,PS_1_2,"ps_1_2",6160,0)
  • CG_PROFILE_PS_2_0 = 6162: CG_PROFILE_MACRO(DX9Pixel13,ps_1_3,PS_1_3,"ps_1_3",6161,0)
  • CG_PROFILE_PS_2_X = 6163: CG_PROFILE_MACRO(DX9Pixel20,ps_2_0,PS_2_0,"ps_2_0",6162,0)
  • CG_PROFILE_MAX = 7100: CG_PROFILE_MACRO(DX9Pixel2x,ps_2_x,PS_2_X,"ps_2_x",6163,0)
TCGresource = (...);

* The following macro invocations define the supported CG basic hardware * bind locations. * * The macros have the form : * * CG_BINDLOCATION_MACRO(name, compiler_name, enum_int) * * name : The name of the location. * enum_name : The C enumerant. * compiler_name : The name of the location within the compiler syntax. * int_id : Integer enumerant associated with this bind location. * addressable : The bind location must have an integer address * associated with it. * ParamType : the cgParamType of this register. *

Values
  • CG_TEXUNIT0 = 2048: # define CG_BINDLOCATION_MACRO(name,enum_name,compiler_name,\ enum_int,addressable,param_type) \ enum_name = enum_int,
  • CG_TEXUNIT1 = 2049: CG_BINDLOCATION_MACRO(TexUnit0,CG_TEXUNIT0,"texunit 0",2048,0,cgTexObjParam)
  • CG_TEXUNIT2 = 2050: CG_BINDLOCATION_MACRO(TexUnit1,CG_TEXUNIT1,"texunit 1",2049,0,cgTexObjParam)
  • CG_TEXUNIT3 = 2051: CG_BINDLOCATION_MACRO(TexUnit2,CG_TEXUNIT2,"texunit 2",2050,0,cgTexObjParam)
  • CG_TEXUNIT4 = 2052: CG_BINDLOCATION_MACRO(TexUnit3,CG_TEXUNIT3,"texunit 3",2051,0,cgTexObjParam)
  • CG_TEXUNIT5 = 2053: CG_BINDLOCATION_MACRO(TexUnit4,CG_TEXUNIT4,"texunit 4",2052,0,cgTexObjParam)
  • CG_TEXUNIT6 = 2054: CG_BINDLOCATION_MACRO(TexUnit5,CG_TEXUNIT5,"texunit 5",2053,0,cgTexObjParam)
  • CG_TEXUNIT7 = 2055: CG_BINDLOCATION_MACRO(TexUnit6,CG_TEXUNIT6,"texunit 6",2054,0,cgTexObjParam)
  • CG_TEXUNIT8 = 2056: CG_BINDLOCATION_MACRO(TexUnit7,CG_TEXUNIT7,"texunit 7",2055,0,cgTexObjParam)
  • CG_TEXUNIT9 = 2057: CG_BINDLOCATION_MACRO(TexUnit8,CG_TEXUNIT8,"texunit 8",2056,0,cgTexObjParam)
  • CG_TEXUNIT10 = 2058: CG_BINDLOCATION_MACRO(TexUnit9,CG_TEXUNIT9,"texunit 9",2057,0,cgTexObjParam)
  • CG_TEXUNIT11 = 2059: CG_BINDLOCATION_MACRO(TexUnit10,CG_TEXUNIT10,"texunit 10",2058,0,cgTexObjParam)
  • CG_TEXUNIT12 = 2060: CG_BINDLOCATION_MACRO(TexUnit11,CG_TEXUNIT11,"texunit 11",2059,0,cgTexObjParam)
  • CG_TEXUNIT13 = 2061: CG_BINDLOCATION_MACRO(TexUnit12,CG_TEXUNIT12,"texunit 12",2060,0,cgTexObjParam)
  • CG_TEXUNIT14 = 2062: CG_BINDLOCATION_MACRO(TexUnit13,CG_TEXUNIT13,"texunit 13",2061,0,cgTexObjParam)
  • CG_TEXUNIT15 = 2063: CG_BINDLOCATION_MACRO(TexUnit14,CG_TEXUNIT14,"texunit 14",2062,0,cgTexObjParam)
  • CG_ATTR0 = 2113: CG_BINDLOCATION_MACRO(TexUnit15,CG_TEXUNIT15,"texunit 15",2063,0,cgTexObjParam)
  • CG_ATTR1 = 2114: CG_BINDLOCATION_MACRO(Attr0,CG_ATTR0,"ATTR0",2113,0,cgConnectorMemberParam)
  • CG_ATTR2 = 2115: CG_BINDLOCATION_MACRO(Attr1,CG_ATTR1,"ATTR1",2114,0,cgConnectorMemberParam)
  • CG_ATTR3 = 2116: CG_BINDLOCATION_MACRO(Attr2,CG_ATTR2,"ATTR2",2115,0,cgConnectorMemberParam)
  • CG_ATTR4 = 2117: CG_BINDLOCATION_MACRO(Attr3,CG_ATTR3,"ATTR3",2116,0,cgConnectorMemberParam)
  • CG_ATTR5 = 2118: CG_BINDLOCATION_MACRO(Attr4,CG_ATTR4,"ATTR4",2117,0,cgConnectorMemberParam)
  • CG_ATTR6 = 2119: CG_BINDLOCATION_MACRO(Attr5,CG_ATTR5,"ATTR5",2118,0,cgConnectorMemberParam)
  • CG_ATTR7 = 2120: CG_BINDLOCATION_MACRO(Attr6,CG_ATTR6,"ATTR6",2119,0,cgConnectorMemberParam)
  • CG_ATTR8 = 2121: CG_BINDLOCATION_MACRO(Attr7,CG_ATTR7,"ATTR7",2120,0,cgConnectorMemberParam)
  • CG_ATTR9 = 2122: CG_BINDLOCATION_MACRO(Attr8,CG_ATTR8,"ATTR8",2121,0,cgConnectorMemberParam)
  • CG_ATTR10 = 2123: CG_BINDLOCATION_MACRO(Attr9,CG_ATTR9,"ATTR9",2122,0,cgConnectorMemberParam)
  • CG_ATTR11 = 2124: CG_BINDLOCATION_MACRO(Attr10,CG_ATTR10,"ATTR10",2123,0,cgConnectorMemberParam)
  • CG_ATTR12 = 2125: CG_BINDLOCATION_MACRO(Attr11,CG_ATTR11,"ATTR11",2124,0,cgConnectorMemberParam)
  • CG_ATTR13 = 2126: CG_BINDLOCATION_MACRO(Attr12,CG_ATTR12,"ATTR12",2125,0,cgConnectorMemberParam)
  • CG_ATTR14 = 2127: CG_BINDLOCATION_MACRO(Attr13,CG_ATTR13,"ATTR13",2126,0,cgConnectorMemberParam)
  • CG_ATTR15 = 2128: CG_BINDLOCATION_MACRO(Attr14,CG_ATTR14,"ATTR14",2127,0,cgConnectorMemberParam)
  • CG_C = 2178: CG_BINDLOCATION_MACRO(Attr15,CG_ATTR15,"ATTR15",2128,0,cgConnectorMemberParam)
  • CG_TEX0 = 2179: CG_BINDLOCATION_MACRO(VertUniform,CG_C,"c",2178,1,cgUniformParam)
  • CG_TEX1 = 2180: CG_BINDLOCATION_MACRO(Tex0,CG_TEX0,"TEX0",2179,0,cgConnectorMemberParam)
  • CG_TEX2 = 2181: CG_BINDLOCATION_MACRO(Tex1,CG_TEX1,"TEX1",2180,0,cgConnectorMemberParam)
  • CG_TEX3 = 2192: CG_BINDLOCATION_MACRO(Tex2,CG_TEX2,"TEX2",2181,0,cgConnectorMemberParam)
  • CG_TEX4 = 2193: CG_BINDLOCATION_MACRO(Tex3,CG_TEX3,"TEX3",2192,0,cgConnectorMemberParam)
  • CG_TEX5 = 2194: CG_BINDLOCATION_MACRO(Tex4,CG_TEX4,"TEX4",2193,0,cgConnectorMemberParam)
  • CG_TEX6 = 2195: CG_BINDLOCATION_MACRO(Tex5,CG_TEX5,"TEX5",2194,0,cgConnectorMemberParam)
  • CG_TEX7 = 2196: CG_BINDLOCATION_MACRO(Tex6,CG_TEX6,"TEX6",2195,0,cgConnectorMemberParam)
  • CG_HPOS = 2243: CG_BINDLOCATION_MACRO(Tex7,CG_TEX7,"TEX7",2196,0,cgConnectorMemberParam)
  • CG_COL0 = 2245: CG_BINDLOCATION_MACRO(HPos,CG_HPOS,"HPOS",2243,0,cgConnectorMemberParam)
  • CG_COL1 = 2246: CG_BINDLOCATION_MACRO(Col0,CG_COL0,"COL0",2245,0,cgConnectorMemberParam)
  • CG_COL2 = 2247: CG_BINDLOCATION_MACRO(Col1,CG_COL1,"COL1",2246,0,cgConnectorMemberParam)
  • CG_COL3 = 2248: CG_BINDLOCATION_MACRO(Col2,CG_COL2,"COL2",2247,0,cgConnectorMemberParam)
  • CG_PSIZ = 2309: CG_BINDLOCATION_MACRO(Col3,CG_COL3,"COL3",2248,0,cgConnectorMemberParam)
  • CG_WPOS = 2373: CG_BINDLOCATION_MACRO(PSiz,CG_PSIZ,"PSIZ",2309,0,cgConnectorMemberParam)
  • CG_POSITION0 = 2437: CG_BINDLOCATION_MACRO(WPos,CG_WPOS,"WPOS",2373,0,cgConnectorMemberParam)
  • CG_POSITION1 = 2438: CG_BINDLOCATION_MACRO(Position0,CG_POSITION0,"POSITION0",2437,0,cgConnectorMemberParam)
  • CG_POSITION2 = 2439: CG_BINDLOCATION_MACRO(Position1,CG_POSITION1,"POSITION1",2438,0,cgConnectorMemberParam)
  • CG_POSITION3 = 2440: CG_BINDLOCATION_MACRO(Position2,CG_POSITION2,"POSITION2",2439,0,cgConnectorMemberParam)
  • CG_POSITION4 = 2441: CG_BINDLOCATION_MACRO(Position3,CG_POSITION3,"POSITION3",2440,0,cgConnectorMemberParam)
  • CG_POSITION5 = 2442: CG_BINDLOCATION_MACRO(Position4,CG_POSITION4,"POSITION4",2441,0,cgConnectorMemberParam)
  • CG_POSITION6 = 2443: CG_BINDLOCATION_MACRO(Position5,CG_POSITION5,"POSITION5",2442,0,cgConnectorMemberParam)
  • CG_POSITION7 = 2444: CG_BINDLOCATION_MACRO(Position6,CG_POSITION6,"POSITION6",2443,0,cgConnectorMemberParam)
  • CG_POSITION8 = 2445: CG_BINDLOCATION_MACRO(Position7,CG_POSITION7,"POSITION7",2444,0,cgConnectorMemberParam)
  • CG_POSITION9 = 2446: CG_BINDLOCATION_MACRO(Position8,CG_POSITION8,"POSITION8",2445,0,cgConnectorMemberParam)
  • CG_POSITION10 = 2447: CG_BINDLOCATION_MACRO(Position9,CG_POSITION9,"POSITION9",2446,0,cgConnectorMemberParam)
  • CG_POSITION11 = 2448: CG_BINDLOCATION_MACRO(Position10,CG_POSITION10,"POSITION10",2447,0,cgConnectorMemberParam)
  • CG_POSITION12 = 2449: CG_BINDLOCATION_MACRO(Position11,CG_POSITION11,"POSITION11",2448,0,cgConnectorMemberParam)
  • CG_POSITION13 = 2450: CG_BINDLOCATION_MACRO(Position12,CG_POSITION12,"POSITION12",2449,0,cgConnectorMemberParam)
  • CG_POSITION14 = 2451: CG_BINDLOCATION_MACRO(Position13,CG_POSITION13,"POSITION13",2450,0,cgConnectorMemberParam)
  • CG_POSITION15 = 2452: CG_BINDLOCATION_MACRO(Position14,CG_POSITION14,"POSITION14",2451,0,cgConnectorMemberParam)
  • CG_DIFFUSE0 = 2501: CG_BINDLOCATION_MACRO(Position15,CG_POSITION15,"POSITION15",2452,0,cgConnectorMemberParam)
  • CG_TANGENT0 = 2565: CG_BINDLOCATION_MACRO(Diffuse0,CG_DIFFUSE0,"DIFFUSE0",2501,0,cgConnectorMemberParam)
  • CG_TANGENT1 = 2566: CG_BINDLOCATION_MACRO(Tangent0,CG_TANGENT0,"TANGENT0",2565,0,cgConnectorMemberParam)
  • CG_TANGENT2 = 2567: CG_BINDLOCATION_MACRO(Tangent1,CG_TANGENT1,"TANGENT1",2566,0,cgConnectorMemberParam)
  • CG_TANGENT3 = 2568: CG_BINDLOCATION_MACRO(Tangent2,CG_TANGENT2,"TANGENT2",2567,0,cgConnectorMemberParam)
  • CG_TANGENT4 = 2569: CG_BINDLOCATION_MACRO(Tangent3,CG_TANGENT3,"TANGENT3",2568,0,cgConnectorMemberParam)
  • CG_TANGENT5 = 2570: CG_BINDLOCATION_MACRO(Tangent4,CG_TANGENT4,"TANGENT4",2569,0,cgConnectorMemberParam)
  • CG_TANGENT6 = 2571: CG_BINDLOCATION_MACRO(Tangent5,CG_TANGENT5,"TANGENT5",2570,0,cgConnectorMemberParam)
  • CG_TANGENT7 = 2572: CG_BINDLOCATION_MACRO(Tangent6,CG_TANGENT6,"TANGENT6",2571,0,cgConnectorMemberParam)
  • CG_TANGENT8 = 2573: CG_BINDLOCATION_MACRO(Tangent7,CG_TANGENT7,"TANGENT7",2572,0,cgConnectorMemberParam)
  • CG_TANGENT9 = 2574: CG_BINDLOCATION_MACRO(Tangent8,CG_TANGENT8,"TANGENT8",2573,0,cgConnectorMemberParam)
  • CG_TANGENT10 = 2575: CG_BINDLOCATION_MACRO(Tangent9,CG_TANGENT9,"TANGENT9",2574,0,cgConnectorMemberParam)
  • CG_TANGENT11 = 2576: CG_BINDLOCATION_MACRO(Tangent10,CG_TANGENT10,"TANGENT10",2575,0,cgConnectorMemberParam)
  • CG_TANGENT12 = 2577: CG_BINDLOCATION_MACRO(Tangent11,CG_TANGENT11,"TANGENT11",2576,0,cgConnectorMemberParam)
  • CG_TANGENT13 = 2578: CG_BINDLOCATION_MACRO(Tangent12,CG_TANGENT12,"TANGENT12",2577,0,cgConnectorMemberParam)
  • CG_TANGENT14 = 2579: CG_BINDLOCATION_MACRO(Tangent13,CG_TANGENT13,"TANGENT13",2578,0,cgConnectorMemberParam)
  • CG_TANGENT15 = 2580: CG_BINDLOCATION_MACRO(Tangent14,CG_TANGENT14,"TANGENT14",2579,0,cgConnectorMemberParam)
  • CG_SPECULAR0 = 2629: CG_BINDLOCATION_MACRO(Tangent15,CG_TANGENT15,"TANGENT15",2580,0,cgConnectorMemberParam)
  • CG_BLENDINDICES0 = 2693: CG_BINDLOCATION_MACRO(Specular0,CG_SPECULAR0,"SPECULAR0",2629,0,cgConnectorMemberParam)
  • CG_BLENDINDICES1 = 2694: CG_BINDLOCATION_MACRO(BlendIndices0,CG_BLENDINDICES0,"BLENDINDICES0",2693,0,cgConnectorMemberParam)
  • CG_BLENDINDICES2 = 2695: CG_BINDLOCATION_MACRO(BlendIndices1,CG_BLENDINDICES1,"BLENDINDICES1",2694,0,cgConnectorMemberParam)
  • CG_BLENDINDICES3 = 2696: CG_BINDLOCATION_MACRO(BlendIndices2,CG_BLENDINDICES2,"BLENDINDICES2",2695,0,cgConnectorMemberParam)
  • CG_BLENDINDICES4 = 2697: CG_BINDLOCATION_MACRO(BlendIndices3,CG_BLENDINDICES3,"BLENDINDICES3",2696,0,cgConnectorMemberParam)
  • CG_BLENDINDICES5 = 2698: CG_BINDLOCATION_MACRO(BlendIndices4,CG_BLENDINDICES4,"BLENDINDICES4",2697,0,cgConnectorMemberParam)
  • CG_BLENDINDICES6 = 2699: CG_BINDLOCATION_MACRO(BlendIndices5,CG_BLENDINDICES5,"BLENDINDICES5",2698,0,cgConnectorMemberParam)
  • CG_BLENDINDICES7 = 2700: CG_BINDLOCATION_MACRO(BlendIndices6,CG_BLENDINDICES6,"BLENDINDICES6",2699,0,cgConnectorMemberParam)
  • CG_BLENDINDICES8 = 2701: CG_BINDLOCATION_MACRO(BlendIndices7,CG_BLENDINDICES7,"BLENDINDICES7",2700,0,cgConnectorMemberParam)
  • CG_BLENDINDICES9 = 2702: CG_BINDLOCATION_MACRO(BlendIndices8,CG_BLENDINDICES8,"BLENDINDICES8",2701,0,cgConnectorMemberParam)
  • CG_BLENDINDICES10 = 2703: CG_BINDLOCATION_MACRO(BlendIndices9,CG_BLENDINDICES9,"BLENDINDICES9",2702,0,cgConnectorMemberParam)
  • CG_BLENDINDICES11 = 2704: CG_BINDLOCATION_MACRO(BlendIndices10,CG_BLENDINDICES10,"BLENDINDICES10",2703,0,cgConnectorMemberParam)
  • CG_BLENDINDICES12 = 2705: CG_BINDLOCATION_MACRO(BlendIndices11,CG_BLENDINDICES11,"BLENDINDICES11",2704,0,cgConnectorMemberParam)
  • CG_BLENDINDICES13 = 2706: CG_BINDLOCATION_MACRO(BlendIndices12,CG_BLENDINDICES12,"BLENDINDICES12",2705,0,cgConnectorMemberParam)
  • CG_BLENDINDICES14 = 2707: CG_BINDLOCATION_MACRO(BlendIndices13,CG_BLENDINDICES13,"BLENDINDICES13",2706,0,cgConnectorMemberParam)
  • CG_BLENDINDICES15 = 2708: CG_BINDLOCATION_MACRO(BlendIndices14,CG_BLENDINDICES14,"BLENDINDICES14",2707,0,cgConnectorMemberParam)
  • CG_COLOR0 = 2757: CG_BINDLOCATION_MACRO(BlendIndices15,CG_BLENDINDICES15,"BLENDINDICES15",2708,0,cgConnectorMemberParam)
  • CG_COLOR1 = 2758: CG_BINDLOCATION_MACRO(Color0,CG_COLOR0,"COLOR0",2757,0,cgConnectorMemberParam)
  • CG_COLOR2 = 2759: CG_BINDLOCATION_MACRO(Color1,CG_COLOR1,"COLOR1",2758,0,cgConnectorMemberParam)
  • CG_COLOR3 = 2760: CG_BINDLOCATION_MACRO(Color2,CG_COLOR2,"COLOR2",2759,0,cgConnectorMemberParam)
  • CG_COLOR4 = 2761: CG_BINDLOCATION_MACRO(Color3,CG_COLOR3,"COLOR3",2760,0,cgConnectorMemberParam)
  • CG_COLOR5 = 2762: CG_BINDLOCATION_MACRO(Color4,CG_COLOR4,"COLOR4",2761,0,cgConnectorMemberParam)
  • CG_COLOR6 = 2763: CG_BINDLOCATION_MACRO(Color5,CG_COLOR5,"COLOR5",2762,0,cgConnectorMemberParam)
  • CG_COLOR7 = 2764: CG_BINDLOCATION_MACRO(Color6,CG_COLOR6,"COLOR6",2763,0,cgConnectorMemberParam)
  • CG_COLOR8 = 2765: CG_BINDLOCATION_MACRO(Color7,CG_COLOR7,"COLOR7",2764,0,cgConnectorMemberParam)
  • CG_COLOR9 = 2766: CG_BINDLOCATION_MACRO(Color8,CG_COLOR8,"COLOR8",2765,0,cgConnectorMemberParam)
  • CG_COLOR10 = 2767: CG_BINDLOCATION_MACRO(Color9,CG_COLOR9,"COLOR9",2766,0,cgConnectorMemberParam)
  • CG_COLOR11 = 2768: CG_BINDLOCATION_MACRO(Color10,CG_COLOR10,"COLOR10",2767,0,cgConnectorMemberParam)
  • CG_COLOR12 = 2769: CG_BINDLOCATION_MACRO(Color11,CG_COLOR11,"COLOR11",2768,0,cgConnectorMemberParam)
  • CG_COLOR13 = 2770: CG_BINDLOCATION_MACRO(Color12,CG_COLOR12,"COLOR12",2769,0,cgConnectorMemberParam)
  • CG_COLOR14 = 2771: CG_BINDLOCATION_MACRO(Color13,CG_COLOR13,"COLOR13",2770,0,cgConnectorMemberParam)
  • CG_COLOR15 = 2772: CG_BINDLOCATION_MACRO(Color14,CG_COLOR14,"COLOR14",2771,0,cgConnectorMemberParam)
  • CG_PSIZE0 = 2821: CG_BINDLOCATION_MACRO(Color15,CG_COLOR15,"COLOR15",2772,0,cgConnectorMemberParam)
  • CG_PSIZE1 = 2822: CG_BINDLOCATION_MACRO(PSize0,CG_PSIZE0,"PSIZE0",2821,0,cgConnectorMemberParam)
  • CG_PSIZE2 = 2823: CG_BINDLOCATION_MACRO(PSize1,CG_PSIZE1,"PSIZE1",2822,0,cgConnectorMemberParam)
  • CG_PSIZE3 = 2824: CG_BINDLOCATION_MACRO(PSize2,CG_PSIZE2,"PSIZE2",2823,0,cgConnectorMemberParam)
  • CG_PSIZE4 = 2825: CG_BINDLOCATION_MACRO(PSize3,CG_PSIZE3,"PSIZE3",2824,0,cgConnectorMemberParam)
  • CG_PSIZE5 = 2826: CG_BINDLOCATION_MACRO(PSize4,CG_PSIZE4,"PSIZE4",2825,0,cgConnectorMemberParam)
  • CG_PSIZE6 = 2827: CG_BINDLOCATION_MACRO(PSize5,CG_PSIZE5,"PSIZE5",2826,0,cgConnectorMemberParam)
  • CG_PSIZE7 = 2828: CG_BINDLOCATION_MACRO(PSize6,CG_PSIZE6,"PSIZE6",2827,0,cgConnectorMemberParam)
  • CG_PSIZE8 = 2829: CG_BINDLOCATION_MACRO(PSize7,CG_PSIZE7,"PSIZE7",2828,0,cgConnectorMemberParam)
  • CG_PSIZE9 = 2830: CG_BINDLOCATION_MACRO(PSize8,CG_PSIZE8,"PSIZE8",2829,0,cgConnectorMemberParam)
  • CG_PSIZE10 = 2831: CG_BINDLOCATION_MACRO(PSize9,CG_PSIZE9,"PSIZE9",2830,0,cgConnectorMemberParam)
  • CG_PSIZE11 = 2832: CG_BINDLOCATION_MACRO(PSize10,CG_PSIZE10,"PSIZE10",2831,0,cgConnectorMemberParam)
  • CG_PSIZE12 = 2833: CG_BINDLOCATION_MACRO(PSize11,CG_PSIZE11,"PSIZE11",2832,0,cgConnectorMemberParam)
  • CG_PSIZE13 = 2834: CG_BINDLOCATION_MACRO(PSize12,CG_PSIZE12,"PSIZE12",2833,0,cgConnectorMemberParam)
  • CG_PSIZE14 = 2835: CG_BINDLOCATION_MACRO(PSize13,CG_PSIZE13,"PSIZE13",2834,0,cgConnectorMemberParam)
  • CG_PSIZE15 = 2836: CG_BINDLOCATION_MACRO(PSize14,CG_PSIZE14,"PSIZE14",2835,0,cgConnectorMemberParam)
  • CG_BINORMAL0 = 2885: CG_BINDLOCATION_MACRO(PSize15,CG_PSIZE15,"PSIZE15",2836,0,cgConnectorMemberParam)
  • CG_BINORMAL1 = 2886: CG_BINDLOCATION_MACRO(BiNormal0,CG_BINORMAL0,"BINORMAL0",2885,0,cgConnectorMemberParam)
  • CG_BINORMAL2 = 2887: CG_BINDLOCATION_MACRO(BiNormal1,CG_BINORMAL1,"BINORMAL1",2886,0,cgConnectorMemberParam)
  • CG_BINORMAL3 = 2888: CG_BINDLOCATION_MACRO(BiNormal2,CG_BINORMAL2,"BINORMAL2",2887,0,cgConnectorMemberParam)
  • CG_BINORMAL4 = 2889: CG_BINDLOCATION_MACRO(BiNormal3,CG_BINORMAL3,"BINORMAL3",2888,0,cgConnectorMemberParam)
  • CG_BINORMAL5 = 2890: CG_BINDLOCATION_MACRO(BiNormal4,CG_BINORMAL4,"BINORMAL4",2889,0,cgConnectorMemberParam)
  • CG_BINORMAL6 = 2891: CG_BINDLOCATION_MACRO(BiNormal5,CG_BINORMAL5,"BINORMAL5",2890,0,cgConnectorMemberParam)
  • CG_BINORMAL7 = 2892: CG_BINDLOCATION_MACRO(BiNormal6,CG_BINORMAL6,"BINORMAL6",2891,0,cgConnectorMemberParam)
  • CG_BINORMAL8 = 2893: CG_BINDLOCATION_MACRO(BiNormal7,CG_BINORMAL7,"BINORMAL7",2892,0,cgConnectorMemberParam)
  • CG_BINORMAL9 = 2894: CG_BINDLOCATION_MACRO(BiNormal8,CG_BINORMAL8,"BINORMAL8",2893,0,cgConnectorMemberParam)
  • CG_BINORMAL10 = 2895: CG_BINDLOCATION_MACRO(BiNormal9,CG_BINORMAL9,"BINORMAL9",2894,0,cgConnectorMemberParam)
  • CG_BINORMAL11 = 2896: CG_BINDLOCATION_MACRO(BiNormal10,CG_BINORMAL10,"BINORMAL10",2895,0,cgConnectorMemberParam)
  • CG_BINORMAL12 = 2897: CG_BINDLOCATION_MACRO(BiNormal11,CG_BINORMAL11,"BINORMAL11",2896,0,cgConnectorMemberParam)
  • CG_BINORMAL13 = 2898: CG_BINDLOCATION_MACRO(BiNormal12,CG_BINORMAL12,"BINORMAL12",2897,0,cgConnectorMemberParam)
  • CG_BINORMAL14 = 2899: CG_BINDLOCATION_MACRO(BiNormal13,CG_BINORMAL13,"BINORMAL13",2898,0,cgConnectorMemberParam)
  • CG_BINORMAL15 = 2900: CG_BINDLOCATION_MACRO(BiNormal14,CG_BINORMAL14,"BINORMAL14",2899,0,cgConnectorMemberParam)
  • CG_FOG0 = 2917: CG_BINDLOCATION_MACRO(BiNormal15,CG_BINORMAL15,"BINORMAL15",2900,0,cgConnectorMemberParam)
  • CG_FOG1 = 2918: CG_BINDLOCATION_MACRO(FOG0,CG_FOG0,"FOG0",2917,0,cgConnectorMemberParam)
  • CG_FOG2 = 2919: CG_BINDLOCATION_MACRO(FOG1,CG_FOG1,"FOG1",2918,0,cgConnectorMemberParam)
  • CG_FOG3 = 2920: CG_BINDLOCATION_MACRO(FOG2,CG_FOG2,"FOG2",2919,0,cgConnectorMemberParam)
  • CG_FOG4 = 2921: CG_BINDLOCATION_MACRO(FOG3,CG_FOG3,"FOG3",2920,0,cgConnectorMemberParam)
  • CG_FOG5 = 2922: CG_BINDLOCATION_MACRO(FOG4,CG_FOG4,"FOG4",2921,0,cgConnectorMemberParam)
  • CG_FOG6 = 2923: CG_BINDLOCATION_MACRO(FOG5,CG_FOG5,"FOG5",2922,0,cgConnectorMemberParam)
  • CG_FOG7 = 2924: CG_BINDLOCATION_MACRO(FOG6,CG_FOG6,"FOG6",2923,0,cgConnectorMemberParam)
  • CG_FOG8 = 2925: CG_BINDLOCATION_MACRO(FOG7,CG_FOG7,"FOG7",2924,0,cgConnectorMemberParam)
  • CG_FOG9 = 2926: CG_BINDLOCATION_MACRO(FOG8,CG_FOG8,"FOG8",2925,0,cgConnectorMemberParam)
  • CG_FOG10 = 2927: CG_BINDLOCATION_MACRO(FOG9,CG_FOG9,"FOG9",2926,0,cgConnectorMemberParam)
  • CG_FOG11 = 2928: CG_BINDLOCATION_MACRO(FOG10,CG_FOG10,"FOG10",2927,0,cgConnectorMemberParam)
  • CG_FOG12 = 2929: CG_BINDLOCATION_MACRO(FOG11,CG_FOG11,"FOG11",2928,0,cgConnectorMemberParam)
  • CG_FOG13 = 2930: CG_BINDLOCATION_MACRO(FOG12,CG_FOG12,"FOG12",2929,0,cgConnectorMemberParam)
  • CG_FOG14 = 2931: CG_BINDLOCATION_MACRO(FOG13,CG_FOG13,"FOG13",2930,0,cgConnectorMemberParam)
  • CG_FOG15 = 2932: CG_BINDLOCATION_MACRO(FOG14,CG_FOG14,"FOG14",2931,0,cgConnectorMemberParam)
  • CG_DEPTH0 = 2933: CG_BINDLOCATION_MACRO(FOG15,CG_FOG15,"FOG15",2932,0,cgConnectorMemberParam)
  • CG_DEPTH1 = 2934: CG_BINDLOCATION_MACRO(DEPTH0,CG_DEPTH0,"DEPTH0",2933,0,cgConnectorMemberParam)
  • CG_DEPTH2 = 2935: CG_BINDLOCATION_MACRO(DEPTH1,CG_DEPTH1,"DEPTH1",2934,0,cgConnectorMemberParam)
  • CG_DEPTH3 = 2936: CG_BINDLOCATION_MACRO(DEPTH2,CG_DEPTH2,"DEPTH2",2935,0,cgConnectorMemberParam)
  • CG_DEPTH4 = 2937: CG_BINDLOCATION_MACRO(DEPTH3,CG_DEPTH3,"DEPTH3",2936,0,cgConnectorMemberParam)
  • CG_DEPTH5 = 2938: CG_BINDLOCATION_MACRO(DEPTH4,CG_DEPTH4,"DEPTH4",2937,0,cgConnectorMemberParam)
  • CG_DEPTH6 = 2939: CG_BINDLOCATION_MACRO(DEPTH5,CG_DEPTH5,"DEPTH5",2938,0,cgConnectorMemberParam)
  • CG_DEPTH7 = 2940: CG_BINDLOCATION_MACRO(DEPTH6,CG_DEPTH6,"DEPTH6",2939,0,cgConnectorMemberParam)
  • CG_DEPTH8 = 2941: CG_BINDLOCATION_MACRO(DEPTH7,CG_DEPTH7,"DEPTH7",2940,0,cgConnectorMemberParam)
  • CG_DEPTH9 = 29542: CG_BINDLOCATION_MACRO(DEPTH8,CG_DEPTH8,"DEPTH8",2941,0,cgConnectorMemberParam) TODO: what THE @#$% !!! ('29542')
  • CG_DEPTH10 = 2943: CG_BINDLOCATION_MACRO(DEPTH9,CG_DEPTH9,"DEPTH9",29542,0,cgConnectorMemberParam)
  • CG_DEPTH11 = 2944: CG_BINDLOCATION_MACRO(DEPTH10,CG_DEPTH10,"DEPTH10",2943,0,cgConnectorMemberParam)
  • CG_DEPTH12 = 2945: CG_BINDLOCATION_MACRO(DEPTH11,CG_DEPTH11,"DEPTH11",2944,0,cgConnectorMemberParam)
  • CG_DEPTH13 = 2946: CG_BINDLOCATION_MACRO(DEPTH12,CG_DEPTH12,"DEPTH12",2945,0,cgConnectorMemberParam)
  • CG_DEPTH14 = 2947: CG_BINDLOCATION_MACRO(DEPTH13,CG_DEPTH13,"DEPTH13",2946,0,cgConnectorMemberParam)
  • CG_DEPTH15 = 2948: CG_BINDLOCATION_MACRO(DEPTH14,CG_DEPTH14,"DEPTH14",2947,0,cgConnectorMemberParam)
  • CG_SAMPLE0 = 2949: CG_BINDLOCATION_MACRO(DEPTH15,CG_DEPTH15,"DEPTH15",2948,0,cgConnectorMemberParam)
  • CG_SAMPLE1 = 2950: CG_BINDLOCATION_MACRO(SAMPLE0,CG_SAMPLE0,"SAMPLE0",2949,0,cgConnectorMemberParam)
  • CG_SAMPLE2 = 2951: CG_BINDLOCATION_MACRO(SAMPLE1,CG_SAMPLE1,"SAMPLE1",2950,0,cgConnectorMemberParam)
  • CG_SAMPLE3 = 2952: CG_BINDLOCATION_MACRO(SAMPLE2,CG_SAMPLE2,"SAMPLE2",2951,0,cgConnectorMemberParam)
  • CG_SAMPLE4 = 2953: CG_BINDLOCATION_MACRO(SAMPLE3,CG_SAMPLE3,"SAMPLE3",2952,0,cgConnectorMemberParam)
  • CG_SAMPLE5 = 2954: CG_BINDLOCATION_MACRO(SAMPLE4,CG_SAMPLE4,"SAMPLE4",2953,0,cgConnectorMemberParam)
  • CG_SAMPLE6 = 2955: CG_BINDLOCATION_MACRO(SAMPLE5,CG_SAMPLE5,"SAMPLE5",2954,0,cgConnectorMemberParam)
  • CG_SAMPLE7 = 2956: CG_BINDLOCATION_MACRO(SAMPLE6,CG_SAMPLE6,"SAMPLE6",2955,0,cgConnectorMemberParam)
  • CG_SAMPLE8 = 2957: CG_BINDLOCATION_MACRO(SAMPLE7,CG_SAMPLE7,"SAMPLE7",2956,0,cgConnectorMemberParam)
  • CG_SAMPLE9 = 2958: CG_BINDLOCATION_MACRO(SAMPLE8,CG_SAMPLE8,"SAMPLE8",2957,0,cgConnectorMemberParam)
  • CG_SAMPLE10 = 2959: CG_BINDLOCATION_MACRO(SAMPLE9,CG_SAMPLE9,"SAMPLE9",2958,0,cgConnectorMemberParam)
  • CG_SAMPLE11 = 2960: CG_BINDLOCATION_MACRO(SAMPLE10,CG_SAMPLE10,"SAMPLE10",2959,0,cgConnectorMemberParam)
  • CG_SAMPLE12 = 2961: CG_BINDLOCATION_MACRO(SAMPLE11,CG_SAMPLE11,"SAMPLE11",2960,0,cgConnectorMemberParam)
  • CG_SAMPLE13 = 2962: CG_BINDLOCATION_MACRO(SAMPLE12,CG_SAMPLE12,"SAMPLE12",2961,0,cgConnectorMemberParam)
  • CG_SAMPLE14 = 2963: CG_BINDLOCATION_MACRO(SAMPLE13,CG_SAMPLE13,"SAMPLE13",2962,0,cgConnectorMemberParam)
  • CG_SAMPLE15 = 2964: CG_BINDLOCATION_MACRO(SAMPLE14,CG_SAMPLE14,"SAMPLE14",2963,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT0 = 3028: CG_BINDLOCATION_MACRO(SAMPLE15,CG_SAMPLE15,"SAMPLE15",2964,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT1 = 3029: CG_BINDLOCATION_MACRO(BlendWeight0,CG_BLENDWEIGHT0,"BLENDWEIGHT0",3028,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT2 = 3030: CG_BINDLOCATION_MACRO(BlendWeight1,CG_BLENDWEIGHT1,"BLENDWEIGHT1",3029,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT3 = 3031: CG_BINDLOCATION_MACRO(BlendWeight2,CG_BLENDWEIGHT2,"BLENDWEIGHT2",3030,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT4 = 3032: CG_BINDLOCATION_MACRO(BlendWeight3,CG_BLENDWEIGHT3,"BLENDWEIGHT3",3031,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT5 = 3033: CG_BINDLOCATION_MACRO(BlendWeight4,CG_BLENDWEIGHT4,"BLENDWEIGHT4",3032,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT6 = 3034: CG_BINDLOCATION_MACRO(BlendWeight5,CG_BLENDWEIGHT5,"BLENDWEIGHT5",3033,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT7 = 3035: CG_BINDLOCATION_MACRO(BlendWeight6,CG_BLENDWEIGHT6,"BLENDWEIGHT6",3034,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT8 = 3036: CG_BINDLOCATION_MACRO(BlendWeight7,CG_BLENDWEIGHT7,"BLENDWEIGHT7",3035,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT9 = 3037: CG_BINDLOCATION_MACRO(BlendWeight8,CG_BLENDWEIGHT8,"BLENDWEIGHT8",3036,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT10 = 3038: CG_BINDLOCATION_MACRO(BlendWeight9,CG_BLENDWEIGHT9,"BLENDWEIGHT9",3037,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT11 = 3039: CG_BINDLOCATION_MACRO(BlendWeight10,CG_BLENDWEIGHT10,"BLENDWEIGHT10",3038,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT12 = 3040: CG_BINDLOCATION_MACRO(BlendWeight11,CG_BLENDWEIGHT11,"BLENDWEIGHT11",3039,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT13 = 3041: CG_BINDLOCATION_MACRO(BlendWeight12,CG_BLENDWEIGHT12,"BLENDWEIGHT12",3040,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT14 = 3042: CG_BINDLOCATION_MACRO(BlendWeight13,CG_BLENDWEIGHT13,"BLENDWEIGHT13",3041,0,cgConnectorMemberParam)
  • CG_BLENDWEIGHT15 = 3043: CG_BINDLOCATION_MACRO(BlendWeight14,CG_BLENDWEIGHT14,"BLENDWEIGHT14",3042,0,cgConnectorMemberParam)
  • CG_NORMAL0 = 3092: CG_BINDLOCATION_MACRO(BlendWeight15,CG_BLENDWEIGHT15,"BLENDWEIGHT15",3043,0,cgConnectorMemberParam)
  • CG_NORMAL1 = 3093: CG_BINDLOCATION_MACRO(Normal0,CG_NORMAL0,"NORMAL0",3092,0,cgConnectorMemberParam)
  • CG_NORMAL2 = 3094: CG_BINDLOCATION_MACRO(Normal1,CG_NORMAL1,"NORMAL1",3093,0,cgConnectorMemberParam)
  • CG_NORMAL3 = 3095: CG_BINDLOCATION_MACRO(Normal2,CG_NORMAL2,"NORMAL2",3094,0,cgConnectorMemberParam)
  • CG_NORMAL4 = 3096: CG_BINDLOCATION_MACRO(Normal3,CG_NORMAL3,"NORMAL3",3095,0,cgConnectorMemberParam)
  • CG_NORMAL5 = 3097: CG_BINDLOCATION_MACRO(Normal4,CG_NORMAL4,"NORMAL4",3096,0,cgConnectorMemberParam)
  • CG_NORMAL6 = 3098: CG_BINDLOCATION_MACRO(Normal5,CG_NORMAL5,"NORMAL5",3097,0,cgConnectorMemberParam)
  • CG_NORMAL7 = 3099: CG_BINDLOCATION_MACRO(Normal6,CG_NORMAL6,"NORMAL6",3098,0,cgConnectorMemberParam)
  • CG_NORMAL8 = 3100: CG_BINDLOCATION_MACRO(Normal7,CG_NORMAL7,"NORMAL7",3099,0,cgConnectorMemberParam)
  • CG_NORMAL9 = 3101: CG_BINDLOCATION_MACRO(Normal8,CG_NORMAL8,"NORMAL8",3100,0,cgConnectorMemberParam)
  • CG_NORMAL10 = 3102: CG_BINDLOCATION_MACRO(Normal9,CG_NORMAL9,"NORMAL9",3101,0,cgConnectorMemberParam)
  • CG_NORMAL11 = 3103: CG_BINDLOCATION_MACRO(Normal10,CG_NORMAL10,"NORMAL10",3102,0,cgConnectorMemberParam)
  • CG_NORMAL12 = 3104: CG_BINDLOCATION_MACRO(Normal11,CG_NORMAL11,"NORMAL11",3103,0,cgConnectorMemberParam)
  • CG_NORMAL13 = 3105: CG_BINDLOCATION_MACRO(Normal12,CG_NORMAL12,"NORMAL12",3104,0,cgConnectorMemberParam)
  • CG_NORMAL14 = 3106: CG_BINDLOCATION_MACRO(Normal13,CG_NORMAL13,"NORMAL13",3105,0,cgConnectorMemberParam)
  • CG_NORMAL15 = 3107: CG_BINDLOCATION_MACRO(Normal14,CG_NORMAL14,"NORMAL14",3106,0,cgConnectorMemberParam)
  • CG_FOGCOORD = 3156: CG_BINDLOCATION_MACRO(Normal15,CG_NORMAL15,"NORMAL15",3107,0,cgConnectorMemberParam)
  • CG_TEXCOORD0 = 3220: CG_BINDLOCATION_MACRO(FogCoord,CG_FOGCOORD,"FOGCOORD",3156,0,cgConnectorMemberParam)
  • CG_TEXCOORD1 = 3221: CG_BINDLOCATION_MACRO(TexCoord0,CG_TEXCOORD0,"TEXCOORD0",3220,0,cgConnectorMemberParam)
  • CG_TEXCOORD2 = 3222: CG_BINDLOCATION_MACRO(TexCoord1,CG_TEXCOORD1,"TEXCOORD1",3221,0,cgConnectorMemberParam)
  • CG_TEXCOORD3 = 3223: CG_BINDLOCATION_MACRO(TexCoord2,CG_TEXCOORD2,"TEXCOORD2",3222,0,cgConnectorMemberParam)
  • CG_TEXCOORD4 = 3224: CG_BINDLOCATION_MACRO(TexCoord3,CG_TEXCOORD3,"TEXCOORD3",3223,0,cgConnectorMemberParam)
  • CG_TEXCOORD5 = 3225: CG_BINDLOCATION_MACRO(TexCoord4,CG_TEXCOORD4,"TEXCOORD4",3224,0,cgConnectorMemberParam)
  • CG_TEXCOORD6 = 3226: CG_BINDLOCATION_MACRO(TexCoord5,CG_TEXCOORD5,"TEXCOORD5",3225,0,cgConnectorMemberParam)
  • CG_TEXCOORD7 = 3227: CG_BINDLOCATION_MACRO(TexCoord6,CG_TEXCOORD6,"TEXCOORD6",3226,0,cgConnectorMemberParam)
  • CG_TEXCOORD8 = 3228: CG_BINDLOCATION_MACRO(TexCoord7,CG_TEXCOORD7,"TEXCOORD7",3227,0,cgConnectorMemberParam)
  • CG_TEXCOORD9 = 3229: CG_BINDLOCATION_MACRO(TexCoord8,CG_TEXCOORD8,"TEXCOORD8",3228,0,cgConnectorMemberParam)
  • CG_TEXCOORD10 = 3230: CG_BINDLOCATION_MACRO(TexCoord9,CG_TEXCOORD9,"TEXCOORD9",3229,0,cgConnectorMemberParam)
  • CG_TEXCOORD11 = 3231: CG_BINDLOCATION_MACRO(TexCoord10,CG_TEXCOORD10,"TEXCOORD10",3230,0,cgConnectorMemberParam)
  • CG_TEXCOORD12 = 3232: CG_BINDLOCATION_MACRO(TexCoord11,CG_TEXCOORD11,"TEXCOORD11",3231,0,cgConnectorMemberParam)
  • CG_TEXCOORD13 = 3233: CG_BINDLOCATION_MACRO(TexCoord12,CG_TEXCOORD12,"TEXCOORD12",3232,0,cgConnectorMemberParam)
  • CG_TEXCOORD14 = 3234: CG_BINDLOCATION_MACRO(TexCoord13,CG_TEXCOORD13,"TEXCOORD13",3233,0,cgConnectorMemberParam)
  • CG_TEXCOORD15 = 3235: CG_BINDLOCATION_MACRO(TexCoord14,CG_TEXCOORD14,"TEXCOORD14",3234,0,cgConnectorMemberParam)
  • CG_COMBINER_CONST0 = 3284: CG_BINDLOCATION_MACRO(TexCoord15,CG_TEXCOORD15,"TEXCOORD15",3235,0,cgConnectorMemberParam)
  • CG_COMBINER_CONST1 = 3285: CG_BINDLOCATION_MACRO(CombinerConst0,CG_COMBINER_CONST0,"COMBINER_CONST0",3284,0,cgUniformParam)
  • CG_COMBINER_STAGE_CONST0 = 3286: CG_BINDLOCATION_MACRO(CombinerConst1,CG_COMBINER_CONST1,"COMBINER_CONST1",3285,0,cgUniformParam)
  • CG_COMBINER_STAGE_CONST1 = 3287: CG_BINDLOCATION_MACRO(CombinerStageConst0,CG_COMBINER_STAGE_CONST0,"COMBINER_STAGE_CONST0",3286,1,cgUniformParam)
  • CG_OFFSET_TEXTURE_MATRIX = 3288: CG_BINDLOCATION_MACRO(CombinerStageConst1,CG_COMBINER_STAGE_CONST1,"COMBINER_STAGE_CONST1",3287,1,cgUniformParam)
  • CG_OFFSET_TEXTURE_SCALE = 3289: CG_BINDLOCATION_MACRO(OffsetTextureMatrix,CG_OFFSET_TEXTURE_MATRIX,"OFFSET_TEXTURE_MATRIX",3288,0,cgUniformParam)
  • CG_OFFSET_TEXTURE_BIAS = 3290: CG_BINDLOCATION_MACRO(OffsetTextureScale,CG_OFFSET_TEXTURE_SCALE,"OFFSET_TEXTURE_SCALE",3289,0,cgUniformParam)
  • CG_CONST_EYE = 3291: CG_BINDLOCATION_MACRO(OffsetTextureBias,CG_OFFSET_TEXTURE_BIAS,"OFFSET_TEXTURE_BIAS",3290,0,cgUniformParam)
  • CG_TESSFACTOR = 3255: CG_BINDLOCATION_MACRO(ConstEye,CG_CONST_EYE,"CONST_EYE",3291,0,cgUniformParam)
  • CG_UNDEFINED: CG_BINDLOCATION_MACRO(TessFactor,CG_TESSFACTOR,"TESSFACTOR",3255,0,cgConnectorMemberParam)
TCGtype = (...);

* The following macro invocations define the supported CG basic data types. * * The macros have the form : * * CG_DATATYPE_MACRO(name, compiler_name, nrows, ncols) * * name : The name of the data type. * compiler_name : The name of the data type within the compiler syntax. * enum_name : The C enumerant. * nrows : Number of rows for matrix types. Should be 0 other-wise. * ncols : Number of columns for matrix types. Should be 0 * other-wise. *

Values
  • CG_UNKNOWN_TYPE
  • CG_STRUCT
  • CG_ARRAY
  • CG_TYPE_START_ENUM = 1024
  • CG_HALF: # define CG_DATATYPE_MACRO(name, compiler_name, enum_name, ncols, nrows) \ enum_name ,
  • CG_HALF2: CG_DATATYPE_MACRO(Half,half,CG_HALF,0,0)
  • CG_HALF3: CG_DATATYPE_MACRO(Half2,half2,CG_HALF2,0,0)
  • CG_HALF4: CG_DATATYPE_MACRO(Half3,half3,CG_HALF3,0,0)
  • CG_HALF1x1: CG_DATATYPE_MACRO(Half4,half4,CG_HALF4,0,0)
  • CG_HALF1x2: CG_DATATYPE_MACRO(Half1x1,half1x1,CG_HALF1x1,1,1)
  • CG_HALF1x3: CG_DATATYPE_MACRO(Half1x2,half1x2,CG_HALF1x2,1,2)
  • CG_HALF1x4: CG_DATATYPE_MACRO(Half1x3,half1x3,CG_HALF1x3,1,3)
  • CG_HALF2x1: CG_DATATYPE_MACRO(Half1x4,half1x4,CG_HALF1x4,1,4)
  • CG_HALF2x2: CG_DATATYPE_MACRO(Half2x1,half2x1,CG_HALF2x1,2,1)
  • CG_HALF2x3: CG_DATATYPE_MACRO(Half2x2,half2x2,CG_HALF2x2,2,2)
  • CG_HALF2x4: CG_DATATYPE_MACRO(Half2x3,half2x3,CG_HALF2x3,2,3)
  • CG_HALF3x1: CG_DATATYPE_MACRO(Half2x4,half2x4,CG_HALF2x4,2,4)
  • CG_HALF3x2: CG_DATATYPE_MACRO(Half3x1,half3x1,CG_HALF3x1,3,1)
  • CG_HALF3x3: CG_DATATYPE_MACRO(Half3x2,half3x2,CG_HALF3x2,3,2)
  • CG_HALF3x4: CG_DATATYPE_MACRO(Half3x3,half3x3,CG_HALF3x3,3,3)
  • CG_HALF4x1: CG_DATATYPE_MACRO(Half3x4,half3x4,CG_HALF3x4,3,4)
  • CG_HALF4x2: CG_DATATYPE_MACRO(Half4x1,half4x1,CG_HALF4x1,4,1)
  • CG_HALF4x3: CG_DATATYPE_MACRO(Half4x2,half4x2,CG_HALF4x2,4,2)
  • CG_HALF4x4: CG_DATATYPE_MACRO(Half4x3,half4x3,CG_HALF4x3,4,3)
  • CG_FLOAT: CG_DATATYPE_MACRO(Half4x4,half4x4,CG_HALF4x4,4,4)
  • CG_FLOAT2: CG_DATATYPE_MACRO(Float,float,CG_FLOAT,0,0)
  • CG_FLOAT3: CG_DATATYPE_MACRO(Float2,float2,CG_FLOAT2,0,0)
  • CG_FLOAT4: CG_DATATYPE_MACRO(Float3,float3,CG_FLOAT3,0,0)
  • CG_FLOAT1x1: CG_DATATYPE_MACRO(Float4,float4,CG_FLOAT4,0,0)
  • CG_FLOAT1x2: CG_DATATYPE_MACRO(Float1x1,float1x1,CG_FLOAT1x1,1,1)
  • CG_FLOAT1x3: CG_DATATYPE_MACRO(Float1x2,float1x2,CG_FLOAT1x2,1,2)
  • CG_FLOAT1x4: CG_DATATYPE_MACRO(Float1x3,float1x3,CG_FLOAT1x3,1,3)
  • CG_FLOAT2x1: CG_DATATYPE_MACRO(Float1x4,float1x4,CG_FLOAT1x4,1,4)
  • CG_FLOAT2x2: CG_DATATYPE_MACRO(Float2x1,float2x1,CG_FLOAT2x1,2,1)
  • CG_FLOAT2x3: CG_DATATYPE_MACRO(Float2x2,float2x2,CG_FLOAT2x2,2,2)
  • CG_FLOAT2x4: CG_DATATYPE_MACRO(Float2x3,float2x3,CG_FLOAT2x3,2,3)
  • CG_FLOAT3x1: CG_DATATYPE_MACRO(Float2x4,float2x4,CG_FLOAT2x4,2,4)
  • CG_FLOAT3x2: CG_DATATYPE_MACRO(Float3x1,float3x1,CG_FLOAT3x1,3,1)
  • CG_FLOAT3x3: CG_DATATYPE_MACRO(Float3x2,float3x2,CG_FLOAT3x2,3,2)
  • CG_FLOAT3x4: CG_DATATYPE_MACRO(Float3x3,float3x3,CG_FLOAT3x3,3,3)
  • CG_FLOAT4x1: CG_DATATYPE_MACRO(Float3x4,float3x4,CG_FLOAT3x4,3,4)
  • CG_FLOAT4x2: CG_DATATYPE_MACRO(Float4x1,float4x1,CG_FLOAT4x1,4,1)
  • CG_FLOAT4x3: CG_DATATYPE_MACRO(Float4x2,float4x2,CG_FLOAT4x2,4,2)
  • CG_FLOAT4x4: CG_DATATYPE_MACRO(Float4x3,float4x3,CG_FLOAT4x3,4,3)
  • CG_SAMPLER1D: CG_DATATYPE_MACRO(Float4x4,float4x4,CG_FLOAT4x4,4,4)
  • CG_SAMPLER2D: CG_DATATYPE_MACRO(Sampler1D,sampler1D,CG_SAMPLER1D,0,0)
  • CG_SAMPLER3D: CG_DATATYPE_MACRO(Sampler2D,sampler2D,CG_SAMPLER2D,0,0)
  • CG_SAMPLERRECT: CG_DATATYPE_MACRO(Sampler3D,sampler3D,CG_SAMPLER3D,0,0)
  • CG_SAMPLERCUBE: CG_DATATYPE_MACRO(SamplerRECT,samplerRECT,CG_SAMPLERRECT,0,0)
  • CG_FIXED: CG_DATATYPE_MACRO(SamplerCUBE,samplerCUBE,CG_SAMPLERCUBE,0,0)
  • CG_FIXED2: CG_DATATYPE_MACRO(Fixed,fixed,CG_FIXED,0,0)
  • CG_FIXED3: CG_DATATYPE_MACRO(Fixed2,fixed2,CG_FIXED2,0,0)
  • CG_FIXED4: CG_DATATYPE_MACRO(Fixed3,fixed3,CG_FIXED3,0,0)
  • CG_FIXED1x1: CG_DATATYPE_MACRO(Fixed4,fixed4,CG_FIXED4,0,0)
  • CG_FIXED1x2: CG_DATATYPE_MACRO(Fixed1x1,fixed1x1,CG_FIXED1x1,1,1)
  • CG_FIXED1x3: CG_DATATYPE_MACRO(Fixed1x2,fixed1x2,CG_FIXED1x2,1,2)
  • CG_FIXED1x4: CG_DATATYPE_MACRO(Fixed1x3,fixed1x3,CG_FIXED1x3,1,3)
  • CG_FIXED2x1: CG_DATATYPE_MACRO(Fixed1x4,fixed1x4,CG_FIXED1x4,1,4)
  • CG_FIXED2x2: CG_DATATYPE_MACRO(Fixed2x1,fixed2x1,CG_FIXED2x1,2,1)
  • CG_FIXED2x3: CG_DATATYPE_MACRO(Fixed2x2,fixed2x2,CG_FIXED2x2,2,2)
  • CG_FIXED2x4: CG_DATATYPE_MACRO(Fixed2x3,fixed2x3,CG_FIXED2x3,2,3)
  • CG_FIXED3x1: CG_DATATYPE_MACRO(Fixed2x4,fixed2x4,CG_FIXED2x4,2,4)
  • CG_FIXED3x2: CG_DATATYPE_MACRO(Fixed3x1,fixed3x1,CG_FIXED3x1,3,1)
  • CG_FIXED3x3: CG_DATATYPE_MACRO(Fixed3x2,fixed3x2,CG_FIXED3x2,3,2)
  • CG_FIXED3x4: CG_DATATYPE_MACRO(Fixed3x3,fixed3x3,CG_FIXED3x3,3,3)
  • CG_FIXED4x1: CG_DATATYPE_MACRO(Fixed3x4,fixed3x4,CG_FIXED3x4,3,4)
  • CG_FIXED4x2: CG_DATATYPE_MACRO(Fixed4x1,fixed4x1,CG_FIXED4x1,4,1)
  • CG_FIXED4x3: CG_DATATYPE_MACRO(Fixed4x2,fixed4x2,CG_FIXED4x2,4,2)
  • CG_FIXED4x4: CG_DATATYPE_MACRO(Fixed4x3,fixed4x3,CG_FIXED4x3,4,3)
  • CG_HALF1: CG_DATATYPE_MACRO(Fixed4x4,fixed4x4,CG_FIXED4x4,4,4)
  • CG_FLOAT1: CG_DATATYPE_MACRO(Half1,half1,CG_HALF1,0,0)
  • CG_FIXED1: CG_DATATYPE_MACRO(Float1,float1,CG_FLOAT1,0,0)
  • CG_INT: CG_DATATYPE_MACRO(Fixed1,fixed1,CG_FIXED1,0,0)
  • CG_INT1: CG_DATATYPE_MACRO(Int,int,CG_INT,0,1)
  • CG_INT2: CG_DATATYPE_MACRO(Int1,int1,CG_INT1,0,1)
  • CG_INT3: CG_DATATYPE_MACRO(Int2,int2,CG_INT2,0,2)
  • CG_INT4: CG_DATATYPE_MACRO(Int3,int3,CG_INT3,0,3)
  • CG_INT1x1: CG_DATATYPE_MACRO(Int4,int4,CG_INT4,0,4)
  • CG_INT1x2: CG_DATATYPE_MACRO(Int1x1,int1x1,CG_INT1x1,1,1)
  • CG_INT1x3: CG_DATATYPE_MACRO(Int1x2,int1x2,CG_INT1x2,1,2)
  • CG_INT1x4: CCG_DATATYPE_MACRO(Int1x3,int1x3,CG_INT1x3,1,3)
  • CG_INT2x1: CCG_DATATYPE_MACRO(Int1x4,int1x4,CG_INT1x4,1,4)
  • CG_INT2x2: CCG_DATATYPE_MACRO(Int2x1,int2x1,CG_INT2x1,2,1)
  • CG_INT2x3: CCG_DATATYPE_MACRO(Int2x2,int2x2,CG_INT2x2,2,2)
  • CG_INT2x4: CCG_DATATYPE_MACRO(Int2x3,int2x3,CG_INT2x3,2,3)
  • CG_INT3x1: CCG_DATATYPE_MACRO(Int2x4,int2x4,CG_INT2x4,2,4)
  • CG_INT3x2: CCG_DATATYPE_MACRO(Int3x1,int3x1,CG_INT3x1,3,1)
  • CG_INT3x3: CCG_DATATYPE_MACRO(Int3x2,int3x2,CG_INT3x2,3,2)
  • CG_INT3x4: CCG_DATATYPE_MACRO(Int3x3,int3x3,CG_INT3x3,3,3)
  • CG_INT4x1: CCG_DATATYPE_MACRO(Int3x4,int3x4,CG_INT3x4,3,4)
  • CG_INT4x2: CCG_DATATYPE_MACRO(Int4x1,int4x1,CG_INT4x1,4,1)
  • CG_INT4x3: CCG_DATATYPE_MACRO(Int4x2,int4x2,CG_INT4x2,4,2)
  • CG_INT4x4: CCG_DATATYPE_MACRO(Int4x3,int4x3,CG_INT4x3,4,3)
  • CG_BOOL: CCG_DATATYPE_MACRO(Int4x4,int4x4,CG_INT4x4,4,4)
  • CG_BOOL1: CG_DATATYPE_MACRO(Bool,bool,CG_BOOL,0,1)
  • CG_BOOL2: CG_DATATYPE_MACRO(Bool1,bool1,CG_BOOL1,0,1)
  • CG_BOOL3: CG_DATATYPE_MACRO(Bool2,bool2,CG_BOOL2,0,2)
  • CG_BOOL4: CG_DATATYPE_MACRO(Bool3,bool3,CG_BOOL3,0,3)
  • CG_BOOL1x1: CG_DATATYPE_MACRO(Bool4,bool4,CG_BOOL4,0,4)
  • CG_BOOL1x2: CG_DATATYPE_MACRO(Bool1x1,bool1x1,CG_BOOL1x1,1,1)
  • CG_BOOL1x3: CG_DATATYPE_MACRO(Bool1x2,bool1x2,CG_BOOL1x2,1,2)
  • CG_BOOL1x4: CG_DATATYPE_MACRO(Bool1x3,bool1x3,CG_BOOL1x3,1,3)
  • CG_BOOL2x1: CG_DATATYPE_MACRO(Bool1x4,bool1x4,CG_BOOL1x4,1,4)
  • CG_BOOL2x2: CG_DATATYPE_MACRO(Bool2x1,bool2x1,CG_BOOL2x1,2,1)
  • CG_BOOL2x3: CG_DATATYPE_MACRO(Bool2x2,bool2x2,CG_BOOL2x2,2,2)
  • CG_BOOL2x4: CG_DATATYPE_MACRO(Bool2x3,bool2x3,CG_BOOL2x3,2,3)
  • CG_BOOL3x1: CG_DATATYPE_MACRO(Bool2x4,bool2x4,CG_BOOL2x4,2,4)
  • CG_BOOL3x2: CG_DATATYPE_MACRO(Bool3x1,bool3x1,CG_BOOL3x1,3,1)
  • CG_BOOL3x3: CG_DATATYPE_MACRO(Bool3x2,bool3x2,CG_BOOL3x2,3,2)
  • CG_BOOL3x4: CG_DATATYPE_MACRO(Bool3x3,bool3x3,CG_BOOL3x3,3,3)
  • CG_BOOL4x1: CG_DATATYPE_MACRO(Bool3x4,bool3x4,CG_BOOL3x4,3,4)
  • CG_BOOL4x2: CG_DATATYPE_MACRO(Bool4x1,bool4x1,CG_BOOL4x1,4,1)
  • CG_BOOL4x3: CG_DATATYPE_MACRO(Bool4x2,bool4x2,CG_BOOL4x2,4,2)
  • CG_BOOL4x4: CG_DATATYPE_MACRO(Bool4x3,bool4x3,CG_BOOL4x3,4,3)

Constants

CgLibrary = 'cg.dll';

This item has no description.

CG_VERSION_1_2 = 1;

This item has no description.

CG_VERSION_NUM = 1200;

This item has no description.

CG_FALSE = TCGbool(0);

This item has no description.

CG_TRUE = TCGbool(1);

This item has no description.

CG_NO_ERROR = 0;

# define CG_ERROR_MACRO(code, enum_name, new_enum_name, message) \ new_enum_name = code,

CG_COMPILER_ERROR = 1;

"No error has occurred."

CG_INVALID_PARAMETER_ERROR = 2;

"The compile returned an error."

CG_INVALID_PROFILE_ERROR = 3;

"The parameter used is invalid."

CG_PROGRAM_LOAD_ERROR = 4;

"The profile is not supported."

CG_PROGRAM_BIND_ERROR = 5;

"The program did could not load."

CG_PROGRAM_NOT_LOADED_ERROR = 6;

"The program could not bind."

CG_UNSUPPORTED_GL_EXTENSION_ERROR = 7;

"The program must be loaded before this operation may be used."

CG_INVALID_VALUE_TYPE_ERROR = 8;

"An unsupported GL extension was required to perform this operation."

CG_NOT_MATRIX_PARAM_ERROR = 9;

"An unknown value type was assigned to a parameter."

CG_INVALID_ENUMERANT_ERROR = 10;

"The parameter is not of matrix type."

CG_NOT_4x4_MATRIX_ERROR = 11;

"The enumerant parameter has an invalid value."

CG_FILE_READ_ERROR = 12;

"The parameter must be a 4x4 matrix type."

CG_FILE_WRITE_ERROR = 13;

"The file could not be read."

CG_NVPARSE_ERROR = 14;

"The file could not be written."

CG_MEMORY_ALLOC_ERROR = 15;

"nvparse could not successfully parse the output from the Cg compiler backend."

CG_INVALID_CONTEXT_HANDLE_ERROR = 16;

"Memory allocation failed."

CG_INVALID_PROGRAM_HANDLE_ERROR = 17;

"Invalid context handle."

CG_INVALID_PARAM_HANDLE_ERROR = 18;

"Invalid program handle."

CG_UNKNOWN_PROFILE_ERROR = 19;

"Invalid parameter handle."

CG_VAR_ARG_ERROR = 20;

"The specified profile is unknown."

CG_INVALID_DIMENSION_ERROR = 21;

"The variable arguments were specified incorrectly."

CG_ARRAY_PARAM_ERROR = 22;

"The dimension value is invalid."

CG_OUT_OF_ARRAY_BOUNDS_ERROR = 23;

"The parameter must be an array."

CG_CONFLICTING_TYPES_ERROR = 24;

"Index into the array is out of bounds."

CG_CONFLICTING_PARAMETER_TYPES_ERROR = 25;

"A type being added to the context conflicts with an existing type."

CG_PARAMETER_IS_NOT_SHARED_ERROR = 26;

"The parameters being bound have conflicting types."

CG_INVALID_PARAMETER_VARIABILITY_ERROR = 27;

"The parameter must be global."

CG_CANNOT_DESTROY_PARAMETER_ERROR = 28;

"The parameter could not be changed to the given variability."

CG_NOT_ROOT_PARAMETER_ERROR = 29;

"Cannot destroy the parameter. It is bound to other parameters or is not a root parameter."

CG_PARAMETERS_DO_NOT_MATCH_ERROR = 30;

"The parameter is not a root parameter."

CG_IS_NOT_PROGRAM_PARAMETER_ERROR = 31;

"The two parameters being bound do not match."

CG_INVALID_PARAMETER_TYPE_ERROR = 32;

"The parameter is not a program parameter."

CG_PARAMETER_IS_NOT_RESIZABLE_ARRAY_ERROR = 33;

"The type of the parameter is invalid."

CG_INVALID_SIZE_ERROR = 34;

"The parameter must be a resizable array."

CG_BIND_CREATES_CYCLE_ERROR = 35;

"The size value is invalid."

CG_ARRAY_TYPES_DO_NOT_MATCH_ERROR = 36;

"Cannot bind the given parameters. Binding will form a cycle."

CG_ARRAY_DIMENSIONS_DO_NOT_MATCH_ERROR = 37;

"Cannot bind the given parameters. Array types do not match."

CG_ARRAY_HAS_WRONG_DIMENSION_ERROR = 38;

"Cannot bind the given parameters. Array dimensions do not match."

CG_TYPE_IS_NOT_DEFINED_IN_PROGRAM_ERROR = 39;

"The array is has the wrong dimension."


GLSysHelp v.2.5: Cg.Import: Record _CGcontext

Record _CGcontext

Description
Hierarchy
Fields
Methods
Properties

Unit

Cg.Import

Declaration

type _CGcontext = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: Cg.Import: Record _CGprogram

Record _CGprogram

Description
Hierarchy
Fields
Methods
Properties

Unit

Cg.Import

Declaration

type _CGprogram = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: Cg.Import: Record _CGparameter

Record _CGparameter

Description
Hierarchy
Fields
Methods
Properties

Unit

Cg.Import

Declaration

type _CGparameter = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.DataAccess

Unit CUDA.DataAccess

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class GCUDAHostElementAccess |

Functions and Procedures

procedure SetElementAccessAddress(AValue: PByte; ASize: Cardinal);
function GetElementAccessAddress: PByte;
function GetElementAccessSize: Cardinal;

Types

ByteElement = GCUDAHostElementAccess<ShortInt>;
DoubleElement = GCUDAHostElementAccess<Double>;
FloatElement = GCUDAHostElementAccess<Single>;
HalfElement = GCUDAHostElementAccess<THalfFloat>;
IntElement = GCUDAHostElementAccess<LongInt>;
ShortElement = GCUDAHostElementAccess<SmallInt>;
THalfFloat = type Word;
UByteElement = GCUDAHostElementAccess<Byte>;
UIntElement = GCUDAHostElementAccess<LongWord>;
UShortElement = GCUDAHostElementAccess<Word>;

Description

Functions and Procedures

procedure SetElementAccessAddress(AValue: PByte; ASize: Cardinal);

This item has no description.

function GetElementAccessAddress: PByte;

This item has no description.

function GetElementAccessSize: Cardinal;

This item has no description.

Types

ByteElement = GCUDAHostElementAccess<ShortInt>;

This item has no description.

DoubleElement = GCUDAHostElementAccess<Double>;

This item has no description.

FloatElement = GCUDAHostElementAccess<Single>;

This item has no description.

HalfElement = GCUDAHostElementAccess<THalfFloat>;

This item has no description.

IntElement = GCUDAHostElementAccess<LongInt>;

This item has no description.

ShortElement = GCUDAHostElementAccess<SmallInt>;

This item has no description.

THalfFloat = type Word;

This item has no description.

UByteElement = GCUDAHostElementAccess<Byte>;

This item has no description.

UIntElement = GCUDAHostElementAccess<LongWord>;

This item has no description.

UShortElement = GCUDAHostElementAccess<Word>;


GLSysHelp v.2.5: CUDA.DataAccess: Class GCUDAHostElementAccess

Class GCUDAHostElementAccess

Description
Hierarchy
Nested Types
Fields
Methods
Properties

Unit

CUDA.DataAccess

Declaration

type GCUDAHostElementAccess<TScalar> = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • GCUDAHostElementAccess

Overview

Nested Types

Public | TVector2 = array [0 .. 1] of TScalar;
Public | TVector3 = array [0 .. 2] of TScalar;
Public | TVector4 = array [0 .. 3] of TScalar;

Fields

Public nested const ElementSize = SizeOf(TScalar);

Methods

Private | class function GetScalar: TScalar;
Private | class function GetVector2: TVector2;
Private | class function GetVector3: TVector3;
Private | class function GetVector4: TVector4;
Private | class procedure CheckElementSize(ACNum: Cardinal); inline;
Private | class procedure SetScalar(const AValue: TScalar);
Private | class procedure SetVector2(const AValue: TVector2);
Private | class procedure SetVector3(const AValue: TVector3);
Private | class procedure SetVector4(const AValue: TVector4);

Properties

Public | property Scalar: TScalar read GetScalar write SetScalar;
Public | property Vector2: TVector2 read GetVector2 write SetVector2;
Public | property Vector3: TVector3 read GetVector3 write SetVector3;
Public | property Vector4: TVector4 read GetVector4 write SetVector4;

Description

Nested Types

Public TVector2 = array [0 .. 1] of TScalar;

This item has no description.

Public TVector3 = array [0 .. 2] of TScalar;

This item has no description.

Public TVector4 = array [0 .. 3] of TScalar;

This item has no description.

Fields

Public nested const ElementSize = SizeOf(TScalar);

This item has no description.

Methods

Private class function GetScalar: TScalar;

This item has no description.

Private class function GetVector2: TVector2;

This item has no description.

Private class function GetVector3: TVector3;

This item has no description.

Private class function GetVector4: TVector4;

This item has no description.

Private class procedure CheckElementSize(ACNum: Cardinal); inline;

This item has no description.

Private class procedure SetScalar(const AValue: TScalar);

This item has no description.

Private class procedure SetVector2(const AValue: TVector2);

This item has no description.

Private class procedure SetVector3(const AValue: TVector3);

This item has no description.

Private class procedure SetVector4(const AValue: TVector4);

This item has no description.

Properties

Public property Scalar: TScalar read GetScalar write SetScalar;

This item has no description.

Public property Vector2: TVector2 read GetVector2 write SetVector2;

This item has no description.

Public property Vector3: TVector3 read GetVector3 write SetVector3;

This item has no description.

Public property Vector4: TVector4 read GetVector4 write SetVector4;


GLSysHelp v.2.5: CUDA.FourierTransform

Unit CUDA.FourierTransform

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • CUDA.Import
  • CUDA.RunTime

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TcufftDoubleComplex |
Record TcufftComplex |

Functions and Procedures

function InitCUFFT: Boolean;
procedure CloseCUFFT;
function InitCUFFTFromLibrary(const LibName: WideString): Boolean;
function IsCUFFTInitialized: Boolean;
function Get_CUDA_FFT_Error_String(AError: TcufftResult): string;

Types

PcufftComplex = ˆTcufftComplex;
PcufftDoubleComplex = ˆTcufftDoubleComplex;
PcufftDoubleReal = ˆTcufftDoubleReal;
PcufftReal = ˆTcufftReal;
TcudaRoundMode = (...);
TcufftCompatibility = type Cardinal;
TcufftDestroy = function(plan: TcufftHandle): TcufftResult; stdcall;
TcufftDoubleReal = Double;
TcufftExecC2C = function(plan: TcufftHandle; idata: PcufftComplex; odata: PcufftComplex; direction: Integer): TcufftResult; stdcall;
TcufftExecC2R = function(plan: TcufftHandle; idata: PcufftComplex; odata: PcufftReal): TcufftResult; stdcall;
TcufftExecD2Z = function(plan: TcufftHandle; idata: PcufftDoubleReal; odata: PcufftDoubleComplex): TcufftResult; stdcall;
TcufftExecR2C = function(plan: TcufftHandle; idata: PcufftReal; odata: PcufftComplex): TcufftResult; stdcall;
TcufftExecZ2D = function(plan: TcufftHandle; idata: PcufftDoubleComplex; odata: PcufftDoubleReal): TcufftResult; stdcall;
TcufftExecZ2Z = function(plan: TcufftHandle; idata: PcufftDoubleComplex; odata: PcufftDoubleComplex; direction: Integer): TcufftResult; stdcall;
TcufftHandle = type Cardinal;
TcufftPlan1d = function(out plan: TcufftHandle; nx: Integer; atype: TcufftType; batch: Integer): TcufftResult; stdcall;
TcufftPlan2d = function(out plan: TcufftHandle; nx: Integer; ny: Integer; atype: TcufftType): TcufftResult; stdcall;
TcufftPlan3d = function(out plan: TcufftHandle; nx: Integer; ny: Integer; nz: Integer; atype: TcufftType): TcufftResult; stdcall;
TcufftPlanMany = function(out plan: TcufftHandle; rank: Integer; var n: Integer; var inembed: Integer; istride, idist: Integer; var onembed: Integer; ostride, odist: Integer; ctype: TcufftType; batch: Integer): TcufftResult; stdcall;
TcufftReal = Single;
TcufftRealfloat = Single;
TcufftResult = type Byte;
TcufftSetCompatibilityMode = function(plan: TcufftHandle; mode: TcufftCompatibility): TcufftResult; stdcall;
TcufftSetStream = function(p: TcufftHandle; stream: Integer): TcufftResult; stdcall;
TcufftType = type Cardinal;

Constants

CUFFTDLLNAMES: array [0 .. 9] of string = ( 'cufft32_42_9', 'cufft32_41_28', 'cufft32_40_10', 'cufft32_32_16', 'cufft32_31_4', 'cufft32_30_14', 'cufft32_30_9', 'cufft32_30_8', 'cufft32', 'cufft');
INVALID_CUFFT_HANDLE = $FFFFFFFF;
CUFFT_SUCCESS: TcufftResult = $00;
CUFFT_INVALID_PLAN: TcufftResult = $01;
CUFFT_ALLOC_FAILED: TcufftResult = $02;
CUFFT_INVALID_TYPE: TcufftResult = $03;
CUFFT_INVALID_VALUE: TcufftResult = $04;
CUFFT_INTERNAL_ERROR: TcufftResult = $05;
CUFFT_EXEC_FAILED: TcufftResult = $06;
CUFFT_SETUP_FAILED: TcufftResult = $07;
CUFFT_INVALID_SIZE: TcufftResult = $08;
CUFFT_FORWARD = -1;
CUFFT_INVERSE = 1;
CUFFT_R2C: TcufftType = $2A;
CUFFT_C2R: TcufftType = $2C;
CUFFT_C2C: TcufftType = $29;
CUFFT_D2Z: TcufftType = $6A;
CUFFT_Z2D: TcufftType = $6C;
CUFFT_Z2Z: TcufftType = $69;
CUFFT_COMPATIBILITY_NORMAL: TcufftCompatibility = $00;
CUFFT_COMPATIBILITY_FFTW_PADDING: TcufftCompatibility = $01;
CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC: TcufftCompatibility = $02;
CUFFT_COMPATIBILITY_FFTW: TcufftCompatibility = $03;

Variables

cufftPlan1d: TcufftPlan1d;
cufftPlan2d: TcufftPlan2d;
cufftPlan3d: TcufftPlan3d;
cufftDestroy: TcufftDestroy;
cufftPlanMany: TcufftPlanMany;
cufftExecC2C: TcufftExecC2C;
cufftExecR2C: TcufftExecR2C;
cufftExecC2R: TcufftExecC2R;
cufftExecZ2Z: TcufftExecZ2Z;
cufftExecD2Z: TcufftExecD2Z;
cufftExecZ2D: TcufftExecZ2D;
cufftSetStream: TcufftSetStream;
cufftSetCompatibilityMode: TcufftSetCompatibilityMode;

Description

Functions and Procedures

function InitCUFFT: Boolean;

This item has no description.

procedure CloseCUFFT;

This item has no description.

function InitCUFFTFromLibrary(const LibName: WideString): Boolean;

This item has no description.

function IsCUFFTInitialized: Boolean;

This item has no description.

function Get_CUDA_FFT_Error_String(AError: TcufftResult): string;

This item has no description.

Types

PcufftComplex = ˆTcufftComplex;

This item has no description.

PcufftDoubleComplex = ˆTcufftDoubleComplex;

This item has no description.

PcufftDoubleReal = ˆTcufftDoubleReal;

This item has no description.

PcufftReal = ˆTcufftReal;

This item has no description.

TcudaRoundMode = (...);

This item has no description.

Values
  • cudaRoundNearest
  • cudaRoundZero
  • cudaRoundPosInf
  • cudaRoundMinInf
TcufftCompatibility = type Cardinal;

Certain R2C and C2R transforms go much more slowly when FFTW memory layout and behaviour is required. The default is "best performance", which means not-compatible-with-fftw. Use the cufftSetCompatibilityMode API to enable exact FFTW-like behaviour.

These flags can be ORed together to select precise FFTW compatibility behaviour. The two levels presently supported are:

CUFFT_COMPATIBILITY_FFTW_PADDING Inserts extra padding between packed in-place transforms for batched transforms with power-of-2 size.

CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC Guarantees FFTW-compatible output for non-symmetric complex inputs for transforms with power-of-2 size. This is only useful for artificial (i.e. random) datasets as actual data will always be symmetric if it has come from the real plane. If you don't understand what this means, you probably don't have to use it.

CUFFT_COMPATIBILITY_FFTW For convenience, enables all FFTW compatibility modes at once.

TcufftDestroy = function(plan: TcufftHandle): TcufftResult; stdcall;

This item has no description.

TcufftDoubleReal = Double;

This item has no description.

TcufftExecC2C = function(plan: TcufftHandle; idata: PcufftComplex; odata: PcufftComplex; direction: Integer): TcufftResult; stdcall;

This item has no description.

TcufftExecC2R = function(plan: TcufftHandle; idata: PcufftComplex; odata: PcufftReal): TcufftResult; stdcall;

This item has no description.

TcufftExecD2Z = function(plan: TcufftHandle; idata: PcufftDoubleReal; odata: PcufftDoubleComplex): TcufftResult; stdcall;

This item has no description.

TcufftExecR2C = function(plan: TcufftHandle; idata: PcufftReal; odata: PcufftComplex): TcufftResult; stdcall;

This item has no description.

TcufftExecZ2D = function(plan: TcufftHandle; idata: PcufftDoubleComplex; odata: PcufftDoubleReal): TcufftResult; stdcall;

This item has no description.

TcufftExecZ2Z = function(plan: TcufftHandle; idata: PcufftDoubleComplex; odata: PcufftDoubleComplex; direction: Integer): TcufftResult; stdcall;

This item has no description.

TcufftHandle = type Cardinal;

CUFFT API function return values CUFFT defines and supports the following data types cufftHandle is a handle type used to store and access CUFFT plans.

TcufftPlan1d = function(out plan: TcufftHandle; nx: Integer; atype: TcufftType; batch: Integer): TcufftResult; stdcall;

This item has no description.

TcufftPlan2d = function(out plan: TcufftHandle; nx: Integer; ny: Integer; atype: TcufftType): TcufftResult; stdcall;

This item has no description.

TcufftPlan3d = function(out plan: TcufftHandle; nx: Integer; ny: Integer; nz: Integer; atype: TcufftType): TcufftResult; stdcall;

This item has no description.

TcufftPlanMany = function(out plan: TcufftHandle; rank: Integer; var n: Integer; var inembed: Integer; istride, idist: Integer; var onembed: Integer; ostride, odist: Integer; ctype: TcufftType; batch: Integer): TcufftResult; stdcall;

This item has no description.

TcufftReal = Single;

This item has no description.

TcufftRealfloat = Single;

This item has no description.

TcufftResult = type Byte;

This item has no description.

TcufftSetCompatibilityMode = function(plan: TcufftHandle; mode: TcufftCompatibility): TcufftResult; stdcall;

This item has no description.

TcufftSetStream = function(p: TcufftHandle; stream: Integer): TcufftResult; stdcall;

This item has no description.

TcufftType = type Cardinal;

This item has no description.

Constants

CUFFTDLLNAMES: array [0 .. 9] of string = ( 'cufft32_42_9', 'cufft32_41_28', 'cufft32_40_10', 'cufft32_32_16', 'cufft32_31_4', 'cufft32_30_14', 'cufft32_30_9', 'cufft32_30_8', 'cufft32', 'cufft');

This item has no description.

INVALID_CUFFT_HANDLE = $FFFFFFFF;

This item has no description.

CUFFT_SUCCESS: TcufftResult = $00;

This item has no description.

CUFFT_INVALID_PLAN: TcufftResult = $01;

This item has no description.

CUFFT_ALLOC_FAILED: TcufftResult = $02;

This item has no description.

CUFFT_INVALID_TYPE: TcufftResult = $03;

This item has no description.

CUFFT_INVALID_VALUE: TcufftResult = $04;

This item has no description.

CUFFT_INTERNAL_ERROR: TcufftResult = $05;

This item has no description.

CUFFT_EXEC_FAILED: TcufftResult = $06;

This item has no description.

CUFFT_SETUP_FAILED: TcufftResult = $07;

This item has no description.

CUFFT_INVALID_SIZE: TcufftResult = $08;

This item has no description.

CUFFT_FORWARD = -1;

CUFFT transform directions

CUFFT_INVERSE = 1;

Forward FFT

CUFFT_R2C: TcufftType = $2A;

Inverse FFT CUFFT supports the following transform types

CUFFT_C2R: TcufftType = $2C;

Real to Complex (interleaved)

CUFFT_C2C: TcufftType = $29;

Complex (interleaved) to Real

CUFFT_D2Z: TcufftType = $6A;

Complex to Complex, interleaved

CUFFT_Z2D: TcufftType = $6C;

Double to Double-Complex

CUFFT_Z2Z: TcufftType = $69;

Double-Complex to Double

CUFFT_COMPATIBILITY_NORMAL: TcufftCompatibility = $00;

This item has no description.

CUFFT_COMPATIBILITY_FFTW_PADDING: TcufftCompatibility = $01;

The default value

CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC: TcufftCompatibility = $02;

This item has no description.

CUFFT_COMPATIBILITY_FFTW: TcufftCompatibility = $03;

This item has no description.

Variables

cufftPlan1d: TcufftPlan1d;

This item has no description.

cufftPlan2d: TcufftPlan2d;

This item has no description.

cufftPlan3d: TcufftPlan3d;

This item has no description.

cufftDestroy: TcufftDestroy;

This item has no description.

cufftPlanMany: TcufftPlanMany;

This item has no description.

cufftExecC2C: TcufftExecC2C;

This item has no description.

cufftExecR2C: TcufftExecR2C;

This item has no description.

cufftExecC2R: TcufftExecC2R;

This item has no description.

cufftExecZ2Z: TcufftExecZ2Z;

This item has no description.

cufftExecD2Z: TcufftExecD2Z;

This item has no description.

cufftExecZ2D: TcufftExecZ2D;

This item has no description.

cufftSetStream: TcufftSetStream;

This item has no description.

cufftSetCompatibilityMode: TcufftSetCompatibilityMode;


GLSysHelp v.2.5: CUDA.FourierTransform: Record TcufftDoubleComplex

Record TcufftDoubleComplex

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.FourierTransform

Declaration

type TcufftDoubleComplex = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Double
Public | X: Double;
Public | Y: Double

Description

Fields

Public V: array[0..1] of Double

This item has no description.

Public X: Double;

This item has no description.

Public Y: Double


GLSysHelp v.2.5: CUDA.FourierTransform: Record TcufftComplex

Record TcufftComplex

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.FourierTransform

Declaration

type TcufftComplex = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Single
Public | X: Single
Public | Y: Single

Description

Fields

Public V: array[0..1] of Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single


GLSysHelp v.2.5: CUDA.Import

Unit CUDA.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TCUcontext |
Record TCUmodule |
Record TCUfunction |
Record TCUarray |
Record TCUtexref |
Record TCUevent |
Record TCUstream |
Record TCUgraphicsResource |
Record TCUdevprop |
Record TcudaFuncAttributes |
Record TCUDA_MEMCPY2D |
Record TCUDA_MEMCPY3D |
Record TCUDA_ARRAY_DESCRIPTOR |
Record TCUDA_ARRAY3D_DESCRIPTOR |

Functions and Procedures

function InitCUDA: Boolean;
procedure CloseCUDA;
function InitCUDAFromLibrary(const LibName: WideString): Boolean;
function IsCUDAInitialized: Boolean;
function Get_CUDA_API_Error_String(AError: TCUresult): string;

Types

HGPUNV = Pointer;
PCUarray = ˆTCUarray;
PCUcontext = ˆTCUcontext;
PCUDA_ARRAY_DESCRIPTOR = ˆTCUDA_ARRAY_DESCRIPTOR;
PCUDA_MEMCPY2D = ˆTCUDA_MEMCPY2D;
PCUevent = ˆTCUevent;
PCUfunction = ˆTCUfunction;
PCUgraphicsResource = ˆTCUgraphicsResource;
PCUmodule = ˆTCUmodule;
PCUstream = ˆTCUstream;
PCUtexref = ˆTCUtexref;
PPCUgraphicsResource = ˆPCUgraphicsResource;
TCUaddress_mode = (...);
TcuArray3DCreate = function(var pHandle: PCUarray; var pAllocateArray: TCUDA_ARRAY3D_DESCRIPTOR): TCUresult; stdcall;
TcuArray3DGetDescriptor = function(var pArrayDescriptor : TCUDA_ARRAY3D_DESCRIPTOR; hArray: PCUarray): TCUresult; stdcall;
TcuArrayCreate = function(var pHandle: PCUarray; var pAllocateArray: TCUDA_ARRAY_DESCRIPTOR): TCUresult; stdcall;
TcuArrayDestroy = function(hArray: PCUarray): TCUresult; stdcall;
TcuArrayGetDescriptor = function(var pArrayDescriptor: TCUDA_ARRAY_DESCRIPTOR; hArray: PCUarray): TCUresult; stdcall;
TCUarray_cubemap_face = (...);
TCUarray_format = (...);
TCUcomputemode = (...);
TcuCtxAttach = function(var pctx: PCUcontext; Flags: Cardinal): TCUresult; stdcall;
TcuCtxCreate = function(var pctx: PCUcontext; Flags: Cardinal; dev: TCUdevice): TCUresult; stdcall;
TcuCtxDestroy = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxDetach = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxGetDevice = function(var device: TCUdevice): TCUresult; stdcall;
TcuCtxPopCurrent = function(var pctx: PCUcontext): TCUresult; stdcall;
TcuCtxPushCurrent = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxSynchronize = function: TCUresult; stdcall;
TCUctx_flags = (...);
TcudaFuncCache = (...);
TcudaLimit = (...);
TCUdevice = Integer;
TcuDeviceComputeCapability = function(var major: Integer; var minor: Integer; dev: TCUdevice): TCUresult; stdcall;
TcuDeviceGet = function(var device: TCUdevice; ordinal: Integer): TCUresult; stdcall;
TcuDeviceGetAttribute = function(pi: PSize_t; attrib: TCUdevice_attribute; dev: TCUdevice): TCUresult; stdcall;
TcuDeviceGetCount = function(var count: Integer): TCUresult; stdcall;
TcuDeviceGetName = function(name: PAnsiChar; len: Integer; dev: TCUdevice): TCUresult; stdcall;
TcuDeviceGetProperties = function(var prop: TCUdevprop; dev: TCUdevice): TCUresult; stdcall;
TCUdeviceptr = Pointer;
TcuDeviceTotalMem = function(bytes: PSize_t; dev: TCUdevice): TCUresult; stdcall;
TCUdevice_attribute = (...);
TcuDriverGetVersion = function(out driverVersion: Integer): TCUresult; stdcall;
TcuEventCreate = function(var phEvent: PCUevent; Flags: Cardinal): TCUresult; stdcall;
TcuEventDestroy = function(hEvent: PCUevent): TCUresult; stdcall;
TcuEventElapsedTime = function(var pMilliseconds: Single; hStart: PCUevent; hEnd: PCUevent): TCUresult; stdcall;
TcuEventQuery = function(hEvent: PCUevent): TCUresult; stdcall;
TcuEventRecord = function(hEvent: PCUevent; hStream: PCUstream): TCUresult; stdcall;
TcuEventSynchronize = function(hEvent: PCUevent): TCUresult; stdcall;
TCUevent_flags = (...);
TCUfilter_mode = (...);
TcuFuncGetAttribute = function(var pi: Integer; attrib: TCUfunction_attribute; hfunc: PCUfunction): TCUresult; stdcall;
TcuFuncSetBlockShape = function(hfunc: PCUfunction; x: Integer; y: Integer; z: Integer): TCUresult; stdcall;
TcuFuncSetSharedSize = function(hfunc: PCUfunction; bytes: Cardinal): TCUresult; stdcall;
TCUfunction_attribute = (...);
TcuGLCtxCreate = function(var pctx: PCUcontext; Flags: Cardinal; device: TCUdevice): TCUresult; stdcall;
TcuGLInit = procedure(); stdcall;
TcuGLMapBufferObject = function(var dptr: TCUdeviceptr; var size: Cardinal; buffer: Cardinal): TCUresult; stdcall;
TcuGLMapBufferObjectAsync = function(var dptr: TCUdeviceptr; var size: Cardinal; buffer: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TCUGLmap_flags = (...);
TcuGLRegisterBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGLSetBufferObjectMapFlags = function(buffer: Cardinal; Flags: Cardinal) : TCUresult; stdcall;
TcuGLUnmapBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGLUnmapBufferObjectAsync = function(buffer: Cardinal; hStream: PCUstream) : TCUresult; stdcall;
TcuGLUnregisterBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGraphicsGLRegisterBuffer = function(var pCudaResource: PCUgraphicsResource; buffer: Cardinal; Flags: TCUgraphicsMapResourceFlags): TCUresult; stdcall;
TcuGraphicsGLRegisterImage = function(var pCudaResource: PCUgraphicsResource; image, target: Cardinal; Flags: TCUgraphicsMapResourceFlags): TCUresult; stdcall;
TCUgraphicsMapResourceFlags = (...);
TcuGraphicsMapResources = function(count: Cardinal; resources: PPCUgraphicsResource; hStream: PCUstream): TCUresult; stdcall;
TCUgraphicsRegisterFlags = (...);
TcuGraphicsResourceGetMappedPointer = function(var pDevPtr: TCUdeviceptr; out psize: Cardinal; resource: PCUgraphicsResource): TCUresult; stdcall;
TcuGraphicsResourceSetMapFlags = function(resource: PCUgraphicsResource; Flags: Cardinal): TCUresult; stdcall;
TcuGraphicsSubResourceGetMappedArray = function(var pArray: PCUarray; resource: PCUgraphicsResource; arrayIndex: Cardinal; mipLevel: Cardinal) : TCUresult; stdcall;
TcuGraphicsUnmapResources = function(count: Cardinal; resources: PPCUgraphicsResource; hStream: PCUstream): TCUresult; stdcall;
TcuGraphicsUnregisterResource = function(resource: PCUgraphicsResource): TCUresult; stdcall;
TcuInit = function(Flags: Cardinal): TCUresult; stdcall;
TCUjit_fallback = (...);
TCUjit_option = (...);
TCUjit_target = (...);
TcuLaunch = function(f: PCUfunction): TCUresult; stdcall;
TcuLaunchGrid = function(f: PCUfunction; grid_width: Integer; grid_height: Integer): TCUresult; stdcall;
TcuLaunchGridAsync = function(f: PCUfunction; grid_width: Integer; grid_height: Integer; hStream: PCUstream): TCUresult; stdcall;
TcuMemAlloc = function(var dptr: TCUdeviceptr; bytesize: Cardinal): TCUresult; stdcall;
TcuMemAllocHost = function(var pp; bytesize: Cardinal): TCUresult; stdcall;
TcuMemAllocPitch = function(var dptr: TCUdeviceptr; var pPitch: Cardinal; WidthInBytes: Cardinal; Height: Cardinal; ElementSizeBytes: Cardinal): TCUresult; stdcall;
TcuMemcpy2D = function(const pCopy: PCUDA_MEMCPY2D): TCUresult; stdcall;
TcuMemcpy2DAsync = function(var pCopy: TCUDA_MEMCPY2D; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpy2DUnaligned = function(var pCopy: TCUDA_MEMCPY2D): TCUresult; stdcall;
TcuMemcpy3D = function(var pCopy: TCUDA_MEMCPY3D): TCUresult; stdcall;
TcuMemcpy3DAsync = function(var pCopy: TCUDA_MEMCPY3D; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyAtoA = function(dstArray: PCUarray; dstIndex: Cardinal; srcArray: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoD = function(dstDevice: TCUdeviceptr; hSrc: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoH = function(dstHost: Pointer; srcArray: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoHAsync = function(var dstHost; srcArray: PCUstream; SrcIndex: Cardinal; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyDtoA = function(dstArray: PCUarray; dstIndex: Cardinal; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoD = function(dstDevice: TCUdeviceptr; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoDAsync = function(dstDevice: TCUdeviceptr; srcDevice: TCUdeviceptr; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyDtoH = function(const dstHost: Pointer; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoHAsync = function(var dstHost; srcDevice: TCUdeviceptr; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyHtoA = function(dstArray: PCUarray; dstIndex: Cardinal; pSrc: Pointer; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyHtoAAsync = function(dstArray: PCUarray; dstIndex: Cardinal; var pSrc; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyHtoD = function(dstDevice: TCUdeviceptr; const srcHost: Pointer; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyHtoDAsync = function(dstDevice: TCUdeviceptr; var srcHost; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemFree = function(dptr: TCUdeviceptr): TCUresult; stdcall;
TcuMemFreeHost = function(p: Pointer): TCUresult; stdcall;
TcuMemGetAddressRange = function(var pbase: TCUdeviceptr; var psize: Cardinal; dptr: TCUdeviceptr): TCUresult; stdcall;
TcuMemGetInfo = function(var free: Cardinal; var total: Cardinal): TCUresult; stdcall;
TcuMemHostAlloc = function(var pp: Pointer; bytesize: Cardinal; Flags: Cardinal): TCUresult; stdcall;
TcuMemHostGetDevicePointer = function(var pdptr: TCUdeviceptr; p: Pointer; Flags: Cardinal): TCUresult; stdcall;
TcuMemHostGetFlags = function(var pFlags: Cardinal; var p): TCUresult; stdcall;
TCUmemorytype = (...);
TcuMemsetD16 = function(dstDevice: TCUdeviceptr; uw: Word; N: Cardinal): TCUresult; stdcall;
TcuMemsetD2D16 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; uw: Word; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuMemsetD2D32 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; ui: Cardinal; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuMemsetD2D8 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; ub: Byte; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuMemsetD32 = function(dstDevice: TCUdeviceptr; ui: Cardinal; N: Cardinal): TCUresult; stdcall;
TcuMemsetD8 = function(dstDevice: TCUdeviceptr; ub: Byte; N: Cardinal): TCUresult; stdcall;
TcuModuleGetFunction = function(out hfunc: PCUfunction; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuModuleGetGlobal = function(out dptr: TCUdeviceptr; var bytes: Cardinal; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuModuleGetTexRef = function(out pTexRef: PCUtexref; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuModuleLoad = function(var module: PCUmodule; const fname: PAnsiChar): TCUresult; stdcall;
TcuModuleLoadData = function(var module: PCUmodule; const image: PAnsiChar): TCUresult; stdcall;
TcuModuleLoadDataEx = function(var module: PCUmodule; var image; numOptions: Cardinal; var options: TCUjit_option; var optionValues): TCUresult; stdcall;
TcuModuleLoadFatBinary = function(var module: PCUmodule; var fatCubin): TCUresult; stdcall;
TcuModuleUnload = function(hmod: PCUmodule): TCUresult; stdcall;
TcuParamSetf = function(hfunc: PCUfunction; offset: Integer; value: Single) : TCUresult; stdcall;
TcuParamSeti = function(hfunc: PCUfunction; offset: Integer; value: Cardinal) : TCUresult; stdcall;
TcuParamSetSize = function(hfunc: PCUfunction; numbytes: Cardinal): TCUresult; stdcall;
TcuParamSetTexRef = function(hfunc: PCUfunction; texunit: Integer; hTexRef: PCUtexref): TCUresult; stdcall;
TcuParamSetv = function(hfunc: PCUfunction; offset: Integer; var ptr; numbytes: Cardinal): TCUresult; stdcall;
TCUresult = type Cardinal;
TcuStreamCreate = function(var phStream: PCUstream; Flags: Cardinal): TCUresult; stdcall;
TcuStreamDestroy = function(hStream: PCUstream): TCUresult; stdcall;
TcuStreamQuery = function(hStream: PCUstream): TCUresult; stdcall;
TcuStreamSynchronize = function(hStream: PCUstream): TCUresult; stdcall;
TcuTexRefCreate = function(var pTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefDestroy = function(hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefGetAddress = function(var pdptr: TCUdeviceptr; hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefGetAddressMode = function(var pam: TCUaddress_mode; hTexRef: PCUtexref; dim: Integer): TCUresult; stdcall;
TcuTexRefGetArray = function(var phArray: PCUarray; hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefGetFilterMode = function(var pfm: TCUfilter_mode; hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefGetFlags = function(var pFlags: Cardinal; hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefGetFormat = function(var pFormat: TCUarray_format; var pNumChannels: Integer; hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefSetAddress = function(var ByteOffset: Cardinal; hTexRef: PCUtexref; dptr: TCUdeviceptr; bytes: Cardinal): TCUresult; stdcall;
TcuTexRefSetAddress2D = function(hTexRef: PCUtexref; var desc: TCUDA_ARRAY_DESCRIPTOR; dptr: TCUdeviceptr; Pitch: Cardinal) : TCUresult; stdcall;
TcuTexRefSetAddressMode = function(hTexRef: PCUtexref; dim: Integer; am: TCUaddress_mode): TCUresult; stdcall;
TcuTexRefSetArray = function(hTexRef: PCUtexref; hArray: PCUarray; Flags: Cardinal): TCUresult; stdcall;
TcuTexRefSetFilterMode = function(hTexRef: PCUtexref; fm: TCUfilter_mode) : TCUresult; stdcall;
TcuTexRefSetFlags = function(hTexRef: PCUtexref; Flags: Cardinal): TCUresult; stdcall;
TcuTexRefSetFormat = function(hTexRef: PCUtexref; fmt: TCUarray_format; NumPackedComponents: Integer): TCUresult; stdcall;
TcuWGLGetDevice = function(var pDevice: TCUdevice; hGpu: HGPUNV): TCUresult; stdcall;
TDim3 = array [0 .. 2] of LongWord;

Constants

CUDAAPIDLL = 'nvcuda.dll';
CUDA_SUCCESS: TCUresult = 0;
CUDA_ERROR_INVALID_VALUE = 1;
CUDA_ERROR_OUT_OF_MEMORY = 2;
CUDA_ERROR_NOT_INITIALIZED = 3;
CUDA_ERROR_DEINITIALIZED = 4;
CUDA_ERROR_NO_DEVICE = 100;
CUDA_ERROR_INVALID_DEVICE = 101;
CUDA_ERROR_INVALID_IMAGE = 200;
CUDA_ERROR_INVALID_CONTEXT = 201;
CUDA_ERROR_CONTEXT_ALREADY_CURRENT = 202;
CUDA_ERROR_MAP_FAILED = 205;
CUDA_ERROR_UNMAP_FAILED = 206;
CUDA_ERROR_ARRAY_IS_MAPPED = 207;
CUDA_ERROR_ALREADY_MAPPED = 208;
CUDA_ERROR_NO_BINARY_FOR_GPU = 209;
CUDA_ERROR_ALREADY_ACQUIRED = 210;
CUDA_ERROR_NOT_MAPPED = 211;
CUDA_ERROR_NOT_MAPPED_AS_ARRAY = 212;
CUDA_ERROR_NOT_MAPPED_AS_POINTER = 213;
CUDA_ERROR_INVALID_SOURCE = 300;
CUDA_ERROR_FILE_NOT_FOUND = 301;
CUDA_ERROR_INVALID_HANDLE = 400;
CUDA_ERROR_NOT_FOUND = 500;
CUDA_ERROR_NOT_READY = 600;
CUDA_ERROR_LAUNCH_FAILED = 700;
CUDA_ERROR_LAUNCH_OUT_OF_RESOURCES = 701;
CUDA_ERROR_LAUNCH_TIMEOUT = 702;
CUDA_ERROR_LAUNCH_INCOMPATIBLE_TEXTURING = 703;
CUDA_ERROR_POINTER_IS_64BIT = 800;
CUDA_ERROR_SIZE_IS_64BIT = 801;
CUDA_ERROR_UNKNOWN = 999;
CU_MEMHOSTALLOC_PORTABLE = $01;
CU_MEMHOSTALLOC_DEVICEMAP = $02;
CU_MEMHOSTALLOC_WRITECOMBINED = $04;
CU_TRSA_OVERRIDE_FORMAT = $01;
CU_TRSF_READ_AS_INTEGER = $01;
CU_TRSF_NORMALIZED_COORDINATES = $02;
CU_PARAM_TR_DEFAULT = -1;

Variables

cuInit: TcuInit;
cuDriverGetVersion: TcuDriverGetVersion;
cuDeviceGet: TcuDeviceGet;
cuDeviceGetCount: TcuDeviceGetCount;
cuDeviceGetName: TcuDeviceGetName;
cuDeviceComputeCapability: TcuDeviceComputeCapability;
cuDeviceTotalMem: TcuDeviceTotalMem;
cuDeviceGetProperties: TcuDeviceGetProperties;
cuDeviceGetAttribute: TcuDeviceGetAttribute;
cuCtxCreate: TcuCtxCreate;
cuCtxDestroy: TcuCtxDestroy;
cuCtxAttach: TcuCtxAttach;
cuCtxDetach: TcuCtxDetach;
cuCtxPushCurrent: TcuCtxPushCurrent;
cuCtxPopCurrent: TcuCtxPopCurrent;
cuCtxGetDevice: TcuCtxGetDevice;
cuCtxSynchronize: TcuCtxSynchronize;
cuModuleLoad: TcuModuleLoad;
cuModuleLoadData: TcuModuleLoadData;
cuModuleLoadDataEx: TcuModuleLoadDataEx;
cuModuleLoadFatBinary: TcuModuleLoadFatBinary;
cuModuleUnload: TcuModuleUnload;
cuModuleGetFunction: TcuModuleGetFunction;
cuModuleGetGlobal: TcuModuleGetGlobal;
cuModuleGetTexRef: TcuModuleGetTexRef;
cuMemGetInfo: TcuMemGetInfo;
cuMemAlloc: TcuMemAlloc;
cuMemAllocPitch: TcuMemAllocPitch;
cuMemFree: TcuMemFree;
cuMemGetAddressRange: TcuMemGetAddressRange;
cuMemAllocHost: TcuMemAllocHost;
cuMemFreeHost: TcuMemFreeHost;
cuMemHostAlloc: TcuMemHostAlloc;
cuMemHostGetDevicePointer: TcuMemHostGetDevicePointer;
cuMemHostGetFlags: TcuMemHostGetFlags;
cuMemcpyHtoD: TcuMemcpyHtoD;
cuMemcpyDtoH: TcuMemcpyDtoH;
cuMemcpyDtoD: TcuMemcpyDtoD;
cuMemcpyDtoDAsync: TcuMemcpyDtoDAsync;
cuMemcpyDtoA: TcuMemcpyDtoA;
cuMemcpyAtoD: TcuMemcpyAtoD;
cuMemcpyHtoA: TcuMemcpyHtoA;
cuMemcpyAtoH: TcuMemcpyAtoH;
cuMemcpyAtoA: TcuMemcpyAtoA;
cuMemcpy2D: TcuMemcpy2D;
cuMemcpy2DUnaligned: TcuMemcpy2DUnaligned;
cuMemcpy3D: TcuMemcpy3D;
cuMemcpyHtoDAsync: TcuMemcpyHtoDAsync;
cuMemcpyDtoHAsync: TcuMemcpyDtoHAsync;
cuMemcpyHtoAAsync: TcuMemcpyHtoAAsync;
cuMemcpyAtoHAsync: TcuMemcpyAtoHAsync;
cuMemcpy2DAsync: TcuMemcpy2DAsync;
cuMemcpy3DAsync: TcuMemcpy3DAsync;
cuMemsetD8: TcuMemsetD8;
cuMemsetD16: TcuMemsetD16;
cuMemsetD32: TcuMemsetD32;
cuMemsetD2D8: TcuMemsetD2D8;
cuMemsetD2D16: TcuMemsetD2D16;
cuMemsetD2D32: TcuMemsetD2D32;
cuFuncSetBlockShape: TcuFuncSetBlockShape;
cuFuncSetSharedSize: TcuFuncSetSharedSize;
cuFuncGetAttribute: TcuFuncGetAttribute;
cuArrayCreate: TcuArrayCreate;
cuArrayGetDescriptor: TcuArrayGetDescriptor;
cuArrayDestroy: TcuArrayDestroy;
cuArray3DCreate: TcuArray3DCreate;
cuArray3DGetDescriptor: TcuArray3DGetDescriptor;
cuTexRefCreate: TcuTexRefCreate;
cuTexRefDestroy: TcuTexRefDestroy;
cuTexRefSetArray: TcuTexRefSetArray;
cuTexRefSetAddress: TcuTexRefSetAddress;
cuTexRefSetAddress2D: TcuTexRefSetAddress2D;
cuTexRefSetFormat: TcuTexRefSetFormat;
cuTexRefSetAddressMode: TcuTexRefSetAddressMode;
cuTexRefSetFilterMode: TcuTexRefSetFilterMode;
cuTexRefSetFlags: TcuTexRefSetFlags;
cuTexRefGetAddress: TcuTexRefGetAddress;
cuTexRefGetArray: TcuTexRefGetArray;
cuTexRefGetAddressMode: TcuTexRefGetAddressMode;
cuTexRefGetFilterMode: TcuTexRefGetFilterMode;
cuTexRefGetFormat: TcuTexRefGetFormat;
cuTexRefGetFlags: TcuTexRefGetFlags;
cuParamSetSize: TcuParamSetSize;
cuParamSeti: TcuParamSeti;
cuParamSetf: TcuParamSetf;
cuParamSetv: TcuParamSetv;
cuParamSetTexRef: TcuParamSetTexRef;
cuLaunch: TcuLaunch;
cuLaunchGrid: TcuLaunchGrid;
cuLaunchGridAsync: TcuLaunchGridAsync;
cuEventCreate: TcuEventCreate;
cuEventRecord: TcuEventRecord;
cuEventQuery: TcuEventQuery;
cuEventSynchronize: TcuEventSynchronize;
cuEventDestroy: TcuEventDestroy;
cuEventElapsedTime: TcuEventElapsedTime;
cuStreamCreate: TcuStreamCreate;
cuStreamQuery: TcuStreamQuery;
cuStreamSynchronize: TcuStreamSynchronize;
cuStreamDestroy: TcuStreamDestroy;
cuGLInit: TcuGLInit;
cuGLCtxCreate: TcuGLCtxCreate;
cuGraphicsGLRegisterBuffer: TcuGraphicsGLRegisterBuffer;
cuGraphicsGLRegisterImage: TcuGraphicsGLRegisterImage;
cuWGLGetDevice: TcuWGLGetDevice;
cuGraphicsUnregisterResource: TcuGraphicsUnregisterResource;
cuGraphicsSubResourceGetMappedArray: TcuGraphicsSubResourceGetMappedArray;
cuGraphicsResourceGetMappedPointer: TcuGraphicsResourceGetMappedPointer;
cuGraphicsResourceSetMapFlags: TcuGraphicsResourceSetMapFlags;
cuGraphicsMapResources: TcuGraphicsMapResources;
cuGraphicsUnmapResources: TcuGraphicsUnmapResources;
cuGLRegisterBufferObject: TcuGLRegisterBufferObject;
cuGLMapBufferObject: TcuGLMapBufferObject;
cuGLUnmapBufferObject: TcuGLUnmapBufferObject;
cuGLUnregisterBufferObject: TcuGLUnregisterBufferObject;
cuGLSetBufferObjectMapFlags: TcuGLSetBufferObjectMapFlags;
cuGLMapBufferObjectAsync: TcuGLMapBufferObjectAsync;
cuGLUnmapBufferObjectAsync: TcuGLUnmapBufferObjectAsync;

Description

Functions and Procedures

function InitCUDA: Boolean;

This item has no description.

procedure CloseCUDA;

This item has no description.

function InitCUDAFromLibrary(const LibName: WideString): Boolean;

This item has no description.

function IsCUDAInitialized: Boolean;

This item has no description.

function Get_CUDA_API_Error_String(AError: TCUresult): string;

This item has no description.

Types

HGPUNV = Pointer;

This item has no description.

PCUarray = ˆTCUarray;

CUDA array

PCUcontext = ˆTCUcontext;

CUDA context

PCUDA_ARRAY_DESCRIPTOR = ˆTCUDA_ARRAY_DESCRIPTOR;

Array descriptor

PCUDA_MEMCPY2D = ˆTCUDA_MEMCPY2D;

2D memory copy parameters

PCUevent = ˆTCUevent;

CUDA event

PCUfunction = ˆTCUfunction;

CUDA function

PCUgraphicsResource = ˆTCUgraphicsResource;

This item has no description.

PCUmodule = ˆTCUmodule;

CUDA module

PCUstream = ˆTCUstream;

CUDA stream

PCUtexref = ˆTCUtexref;

CUDA texture reference

PPCUgraphicsResource = ˆPCUgraphicsResource;

CUDA graphics interop resource

TCUaddress_mode = (...);

Texture reference addressing modes

Values
  • CU_TR_ADDRESS_MODE_WRAP = 0: Wrapping address mode
  • CU_TR_ADDRESS_MODE_CLAMP = 1: Clamp to edge address mode
  • CU_TR_ADDRESS_MODE_MIRROR = 2: Mirror address mode
TcuArray3DCreate = function(var pHandle: PCUarray; var pAllocateArray: TCUDA_ARRAY3D_DESCRIPTOR): TCUresult; stdcall;

This item has no description.

TcuArray3DGetDescriptor = function(var pArrayDescriptor : TCUDA_ARRAY3D_DESCRIPTOR; hArray: PCUarray): TCUresult; stdcall;

This item has no description.

TcuArrayCreate = function(var pHandle: PCUarray; var pAllocateArray: TCUDA_ARRAY_DESCRIPTOR): TCUresult; stdcall;

This item has no description.

TcuArrayDestroy = function(hArray: PCUarray): TCUresult; stdcall;

This item has no description.

TcuArrayGetDescriptor = function(var pArrayDescriptor: TCUDA_ARRAY_DESCRIPTOR; hArray: PCUarray): TCUresult; stdcall;

This item has no description.

TCUarray_cubemap_face = (...);

Array indices for cube faces

Values
  • CU_CUBEMAP_FACE_POSITIVE_X = $00000000: Positive X face of cubemap
  • CU_CUBEMAP_FACE_NEGATIVE_X = $00000001: Negative X face of cubemap
  • CU_CUBEMAP_FACE_POSITIVE_Y = $00000002: Positive Y face of cubemap
  • CU_CUBEMAP_FACE_NEGATIVE_Y = $00000003: Negative Y face of cubemap
  • CU_CUBEMAP_FACE_POSITIVE_Z = $00000004: Positive Z face of cubemap
  • CU_CUBEMAP_FACE_NEGATIVE_Z = $00000005: Negative Z face of cubemap
TCUarray_format = (...);

Array formats

Values
  • CU_AD_FORMAT_UNSIGNED_INT8 = $01: Unsigned 8-bit integers
  • CU_AD_FORMAT_UNSIGNED_INT16 = $02: Unsigned 16-bit integers
  • CU_AD_FORMAT_UNSIGNED_INT32 = $03: Unsigned 32-bit integers
  • CU_AD_FORMAT_SIGNED_INT8 = $08: Signed 8-bit integers
  • CU_AD_FORMAT_SIGNED_INT16 = $09: Signed 16-bit integers
  • CU_AD_FORMAT_SIGNED_INT32 = $0A: Signed 32-bit integers
  • CU_AD_FORMAT_HALF = $10: 16-bit floating point
  • CU_AD_FORMAT_FLOAT = $20: 32-bit floating point
TCUcomputemode = (...);

Compute Modes

Values
  • CU_COMPUTEMODE_DEFAULT = 0: Default compute mode (Multiple contexts allowed per device)
  • CU_COMPUTEMODE_EXCLUSIVE = 1: Compute-exclusive mode (Only one context can be present on this device at a time)
  • CU_COMPUTEMODE_PROHIBITED = 2: Compute-prohibited mode (No contexts can be created on this device at this time)
TcuCtxAttach = function(var pctx: PCUcontext; Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TcuCtxCreate = function(var pctx: PCUcontext; Flags: Cardinal; dev: TCUdevice): TCUresult; stdcall;

This item has no description.

TcuCtxDestroy = function(ctx: PCUcontext): TCUresult; stdcall;

This item has no description.

TcuCtxDetach = function(ctx: PCUcontext): TCUresult; stdcall;

This item has no description.

TcuCtxGetDevice = function(var device: TCUdevice): TCUresult; stdcall;

This item has no description.

TcuCtxPopCurrent = function(var pctx: PCUcontext): TCUresult; stdcall;

This item has no description.

TcuCtxPushCurrent = function(ctx: PCUcontext): TCUresult; stdcall;

This item has no description.

TcuCtxSynchronize = function: TCUresult; stdcall;

This item has no description.

TCUctx_flags = (...);

Context creation flags

Values
  • CU_CTX_SCHED_AUTO = 0: Automatic scheduling
  • CU_CTX_SCHED_SPIN = 1: Set spin as default scheduling
  • CU_CTX_SCHED_YIELD = 2: Set yield as default scheduling
  • CU_CTX_SCHED_MASK = 3
  • CU_CTX_BLOCKING_SYNC = 4: Use blocking synchronization
  • CU_CTX_MAP_HOST = 8: Support mapped pinned allocations
  • CU_CTX_FLAGS_MASK = 15
TcudaFuncCache = (...);

* * CUDA function cache configurations

Values
  • cudaFuncCachePreferNone = 0: Default function cache configuration, no preference
  • cudaFuncCachePreferShared = 1: Prefer larger shared memory and smaller L1 cache
  • cudaFuncCachePreferL1 = 2: Prefer larger L1 cache and smaller shared memory
TcudaLimit = (...);

* * CUDA Limits

Values
  • cudaLimitStackSize = $00: GPU thread stack size
  • cudaLimitPrintfFifoSize = $01: GPU printf FIFO size
TCUdevice = Integer;

CUDA device

TcuDeviceComputeCapability = function(var major: Integer; var minor: Integer; dev: TCUdevice): TCUresult; stdcall;

This item has no description.

TcuDeviceGet = function(var device: TCUdevice; ordinal: Integer): TCUresult; stdcall;

This item has no description.

TcuDeviceGetAttribute = function(pi: PSize_t; attrib: TCUdevice_attribute; dev: TCUdevice): TCUresult; stdcall;

This item has no description.

TcuDeviceGetCount = function(var count: Integer): TCUresult; stdcall;

This item has no description.

TcuDeviceGetName = function(name: PAnsiChar; len: Integer; dev: TCUdevice): TCUresult; stdcall;

This item has no description.

TcuDeviceGetProperties = function(var prop: TCUdevprop; dev: TCUdevice): TCUresult; stdcall;

This item has no description.

TCUdeviceptr = Pointer;

CUDA device pointer

TcuDeviceTotalMem = function(bytes: PSize_t; dev: TCUdevice): TCUresult; stdcall;

This item has no description.

TCUdevice_attribute = (...);

Device properties

Values
  • CU_DEVICE_ATTRIBUTE_MAX_THREADS_PER_BLOCK = 1: Maximum number of threads per block
  • CU_DEVICE_ATTRIBUTE_MAX_BLOCK_DIM_X = 2: Maximum block dimension X
  • CU_DEVICE_ATTRIBUTE_MAX_BLOCK_DIM_Y = 3: Maximum block dimension Y
  • CU_DEVICE_ATTRIBUTE_MAX_BLOCK_DIM_Z = 4: Maximum block dimension Z
  • CU_DEVICE_ATTRIBUTE_MAX_GRID_DIM_X = 5: Maximum grid dimension X
  • CU_DEVICE_ATTRIBUTE_MAX_GRID_DIM_Y = 6: Maximum grid dimension Y
  • CU_DEVICE_ATTRIBUTE_MAX_GRID_DIM_Z = 7: Maximum grid dimension Z
  • CU_DEVICE_ATTRIBUTE_MAX_SHARED_MEMORY_PER_BLOCK = 8: Maximum shared memory available per block in bytes
  • CU_DEVICE_ATTRIBUTE_SHARED_MEMORY_PER_BLOCK = 8: Deprecated, use CU_DEVICE_ATTRIBUTE_MAX_SHARED_MEMORY_PER_BLOCK
  • CU_DEVICE_ATTRIBUTE_TOTAL_CONSTANT_MEMORY = 9: Memory available on device for __constant__ variables in a CUDA C kernel in bytes
  • CU_DEVICE_ATTRIBUTE_WARP_SIZE = 10: Warp size in threads
  • CU_DEVICE_ATTRIBUTE_MAX_PITCH = 11: Maximum pitch in bytes allowed by memory copies
  • CU_DEVICE_ATTRIBUTE_MAX_REGISTERS_PER_BLOCK = 12: Maximum number of 32-bit registers available per block
  • CU_DEVICE_ATTRIBUTE_REGISTERS_PER_BLOCK = 12: Deprecated, use CU_DEVICE_ATTRIBUTE_MAX_REGISTERS_PER_BLOCK
  • CU_DEVICE_ATTRIBUTE_CLOCK_RATE = 13: Peak clock frequency in kilohertz
  • CU_DEVICE_ATTRIBUTE_TEXTURE_ALIGNMENT = 14: Alignment requirement for textures
  • CU_DEVICE_ATTRIBUTE_GPU_OVERLAP = 15: Device can possibly copy memory and execute a kernel concurrently
  • CU_DEVICE_ATTRIBUTE_MULTIPROCESSOR_COUNT = 16: Number of multiprocessors on device
  • CU_DEVICE_ATTRIBUTE_KERNEL_EXEC_TIMEOUT = 17: Specifies whether there is a run time limit on kernels
  • CU_DEVICE_ATTRIBUTE_INTEGRATED = 18: Device is integrated with host memory
  • CU_DEVICE_ATTRIBUTE_CAN_MAP_HOST_MEMORY = 19: Device can map host memory into CUDA address space
  • CU_DEVICE_ATTRIBUTE_COMPUTE_MODE = 20: Compute mode (See ::CUcomputemode for details)
TcuDriverGetVersion = function(out driverVersion: Integer): TCUresult; stdcall;

This item has no description.

TcuEventCreate = function(var phEvent: PCUevent; Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TcuEventDestroy = function(hEvent: PCUevent): TCUresult; stdcall;

This item has no description.

TcuEventElapsedTime = function(var pMilliseconds: Single; hStart: PCUevent; hEnd: PCUevent): TCUresult; stdcall;

This item has no description.

TcuEventQuery = function(hEvent: PCUevent): TCUresult; stdcall;

This item has no description.

TcuEventRecord = function(hEvent: PCUevent; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuEventSynchronize = function(hEvent: PCUevent): TCUresult; stdcall;

This item has no description.

TCUevent_flags = (...);

Event creation flags

Values
  • CU_EVENT_DEFAULT = 0: Default event flag
  • CU_EVENT_BLOCKING_SYNC = 1: Event uses blocking synchronization
TCUfilter_mode = (...);

Texture reference filtering modes

Values
  • CU_TR_FILTER_MODE_POINT = 0: Point filter mode
  • CU_TR_FILTER_MODE_LINEAR = 1: Linear filter mode
TcuFuncGetAttribute = function(var pi: Integer; attrib: TCUfunction_attribute; hfunc: PCUfunction): TCUresult; stdcall;

This item has no description.

TcuFuncSetBlockShape = function(hfunc: PCUfunction; x: Integer; y: Integer; z: Integer): TCUresult; stdcall;

This item has no description.

TcuFuncSetSharedSize = function(hfunc: PCUfunction; bytes: Cardinal): TCUresult; stdcall;

This item has no description.

TCUfunction_attribute = (...);

Function properties

Values
  • CU_FUNC_ATTRIBUTE_MAX_THREADS_PER_BLOCK = 0: The number of threads beyond which a launch of the function would fail. * This number depends on both the function and the device on which the * function is currently loaded.
  • CU_FUNC_ATTRIBUTE_SHARED_SIZE_BYTES = 1: The size in bytes of statically-allocated shared memory required by * this function. This does not include dynamically-allocated shared * memory requested by the user at runtime.
  • CU_FUNC_ATTRIBUTE_CONST_SIZE_BYTES = 2: * The size in bytes of user-allocated constant memory required by this * function.
  • CU_FUNC_ATTRIBUTE_LOCAL_SIZE_BYTES = 3: * The size in bytes of thread local memory used by this function.
  • CU_FUNC_ATTRIBUTE_NUM_REGS = 4: * The number of registers used by each thread of this function.
  • CU_FUNC_ATTRIBUTE_MAX
TcuGLCtxCreate = function(var pctx: PCUcontext; Flags: Cardinal; device: TCUdevice): TCUresult; stdcall;

This item has no description.

TcuGLInit = procedure(); stdcall;

This item has no description.

TcuGLMapBufferObject = function(var dptr: TCUdeviceptr; var size: Cardinal; buffer: Cardinal): TCUresult; stdcall;

This item has no description.

TcuGLMapBufferObjectAsync = function(var dptr: TCUdeviceptr; var size: Cardinal; buffer: Cardinal; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TCUGLmap_flags = (...);

Flags to map or unmap a resource

Values
  • CU_GL_MAP_RESOURCE_FLAGS_NONE
  • CU_GL_MAP_RESOURCE_FLAGS_READ_ONLY
  • CU_GL_MAP_RESOURCE_FLAGS_WRITE_DISCARD
TcuGLRegisterBufferObject = function(buffer: Cardinal): TCUresult; stdcall;

This item has no description.

TcuGLSetBufferObjectMapFlags = function(buffer: Cardinal; Flags: Cardinal) : TCUresult; stdcall;

This item has no description.

TcuGLUnmapBufferObject = function(buffer: Cardinal): TCUresult; stdcall;

This item has no description.

TcuGLUnmapBufferObjectAsync = function(buffer: Cardinal; hStream: PCUstream) : TCUresult; stdcall;

This item has no description.

TcuGLUnregisterBufferObject = function(buffer: Cardinal): TCUresult; stdcall;

This item has no description.

TcuGraphicsGLRegisterBuffer = function(var pCudaResource: PCUgraphicsResource; buffer: Cardinal; Flags: TCUgraphicsMapResourceFlags): TCUresult; stdcall;

This item has no description.

TcuGraphicsGLRegisterImage = function(var pCudaResource: PCUgraphicsResource; image, target: Cardinal; Flags: TCUgraphicsMapResourceFlags): TCUresult; stdcall;

This item has no description.

TCUgraphicsMapResourceFlags = (...);

Flags for mapping and unmapping interop resources

Values
  • CU_GRAPHICS_MAP_RESOURCE_FLAGS_NONE = $00000000
  • CU_GRAPHICS_MAP_RESOURCE_FLAGS_READ_ONLY = $00000001
  • CU_GRAPHICS_MAP_RESOURCE_FLAGS_WRITE_DISCARD = $00000002
TcuGraphicsMapResources = function(count: Cardinal; resources: PPCUgraphicsResource; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TCUgraphicsRegisterFlags = (...);

Flags to register a graphics resource

Values
  • CU_GRAPHICS_REGISTER_FLAGS_NONE = $00000000
TcuGraphicsResourceGetMappedPointer = function(var pDevPtr: TCUdeviceptr; out psize: Cardinal; resource: PCUgraphicsResource): TCUresult; stdcall;

This item has no description.

TcuGraphicsResourceSetMapFlags = function(resource: PCUgraphicsResource; Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TcuGraphicsSubResourceGetMappedArray = function(var pArray: PCUarray; resource: PCUgraphicsResource; arrayIndex: Cardinal; mipLevel: Cardinal) : TCUresult; stdcall;

This item has no description.

TcuGraphicsUnmapResources = function(count: Cardinal; resources: PPCUgraphicsResource; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuGraphicsUnregisterResource = function(resource: PCUgraphicsResource): TCUresult; stdcall;

This item has no description.

TcuInit = function(Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TCUjit_fallback = (...);

Cubin matching fallback strategies

Values
  • CU_PREFER_PTX = 0: ** Prefer to compile ptx */
  • CU_PREFER_BINARY: ** Prefer to fall back to compatible binary code */
TCUjit_option = (...);

Online compiler options

Values
  • CU_JIT_MAX_REGISTERS = 0: * Max number of registers that a thread may use.
  • CU_JIT_THREADS_PER_BLOCK: * IN: Specifies minimum number of threads per block to target compilation * for\n * OUT: Returns the number of threads the compiler actually targeted. * This restricts the resource utilization fo the compiler (e.g. max * registers) such that a block with the given number of threads should be * able to launch based on register limitations. Note, this option does not * currently take into account any other resource limitations, such as * shared memory utilization.
  • CU_JIT_WALL_TIME: * Returns a float value in the option of the wall clock time, in * milliseconds, spent creating the cubin
  • CU_JIT_INFO_LOG_BUFFER: * Pointer to a buffer in which to print any log messsages from PTXAS * that are informational in nature
  • CU_JIT_INFO_LOG_BUFFER_SIZE_BYTES: * IN: Log buffer size in bytes. Log messages will be capped at this size * (including null terminator)\n * OUT: Amount of log buffer filled with messages
  • CU_JIT_ERROR_LOG_BUFFER: * Pointer to a buffer in which to print any log messages from PTXAS that * reflect errors
  • CU_JIT_ERROR_LOG_BUFFER_SIZE_BYTES: * IN: Log buffer size in bytes. Log messages will be capped at this size * (including null terminator)\n * OUT: Amount of log buffer filled with messages
  • CU_JIT_OPTIMIZATION_LEVEL: * Level of optimizations to apply to generated code (0 - 4), with 4 * being the default and highest level of optimizations.
  • CU_JIT_TARGET_FROM_CUCONTEXT: * No option value required. Determines the target based on the current * attached context (default)
  • CU_JIT_TARGET: * Target is chosen based on supplied CUjit_target_enum.
  • CU_JIT_FALLBACK_STRATEGY: * Specifies choice of fallback strategy if matching cubin is not found. * Choice is based on supplied CUjit_fallback_enum.
TCUjit_target = (...);

Online compilation targets

Values
  • CU_TARGET_COMPUTE_10 = 0: Compute device class 1.0
  • CU_TARGET_COMPUTE_11: Compute device class 1.1
  • CU_TARGET_COMPUTE_12: Compute device class 1.2
  • CU_TARGET_COMPUTE_13: Compute device class 1.3
TcuLaunch = function(f: PCUfunction): TCUresult; stdcall;

This item has no description.

TcuLaunchGrid = function(f: PCUfunction; grid_width: Integer; grid_height: Integer): TCUresult; stdcall;

This item has no description.

TcuLaunchGridAsync = function(f: PCUfunction; grid_width: Integer; grid_height: Integer; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuMemAlloc = function(var dptr: TCUdeviceptr; bytesize: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemAllocHost = function(var pp; bytesize: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemAllocPitch = function(var dptr: TCUdeviceptr; var pPitch: Cardinal; WidthInBytes: Cardinal; Height: Cardinal; ElementSizeBytes: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpy2D = function(const pCopy: PCUDA_MEMCPY2D): TCUresult; stdcall;

This item has no description.

TcuMemcpy2DAsync = function(var pCopy: TCUDA_MEMCPY2D; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuMemcpy2DUnaligned = function(var pCopy: TCUDA_MEMCPY2D): TCUresult; stdcall;

This item has no description.

TcuMemcpy3D = function(var pCopy: TCUDA_MEMCPY3D): TCUresult; stdcall;

This item has no description.

TcuMemcpy3DAsync = function(var pCopy: TCUDA_MEMCPY3D; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuMemcpyAtoA = function(dstArray: PCUarray; dstIndex: Cardinal; srcArray: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpyAtoD = function(dstDevice: TCUdeviceptr; hSrc: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpyAtoH = function(dstHost: Pointer; srcArray: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpyAtoHAsync = function(var dstHost; srcArray: PCUstream; SrcIndex: Cardinal; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuMemcpyDtoA = function(dstArray: PCUarray; dstIndex: Cardinal; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpyDtoD = function(dstDevice: TCUdeviceptr; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpyDtoDAsync = function(dstDevice: TCUdeviceptr; srcDevice: TCUdeviceptr; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuMemcpyDtoH = function(const dstHost: Pointer; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpyDtoHAsync = function(var dstHost; srcDevice: TCUdeviceptr; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuMemcpyHtoA = function(dstArray: PCUarray; dstIndex: Cardinal; pSrc: Pointer; ByteCount: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpyHtoAAsync = function(dstArray: PCUarray; dstIndex: Cardinal; var pSrc; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuMemcpyHtoD = function(dstDevice: TCUdeviceptr; const srcHost: Pointer; ByteCount: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemcpyHtoDAsync = function(dstDevice: TCUdeviceptr; var srcHost; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuMemFree = function(dptr: TCUdeviceptr): TCUresult; stdcall;

This item has no description.

TcuMemFreeHost = function(p: Pointer): TCUresult; stdcall;

This item has no description.

TcuMemGetAddressRange = function(var pbase: TCUdeviceptr; var psize: Cardinal; dptr: TCUdeviceptr): TCUresult; stdcall;

This item has no description.

TcuMemGetInfo = function(var free: Cardinal; var total: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemHostAlloc = function(var pp: Pointer; bytesize: Cardinal; Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemHostGetDevicePointer = function(var pdptr: TCUdeviceptr; p: Pointer; Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemHostGetFlags = function(var pFlags: Cardinal; var p): TCUresult; stdcall;

This item has no description.

TCUmemorytype = (...);

Memory types

Values
  • CU_MEMORYTYPE_HOST = $01: Host memory
  • CU_MEMORYTYPE_DEVICE = $02: Device memory
  • CU_MEMORYTYPE_ARRAY = $03: Array memory
TcuMemsetD16 = function(dstDevice: TCUdeviceptr; uw: Word; N: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemsetD2D16 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; uw: Word; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemsetD2D32 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; ui: Cardinal; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemsetD2D8 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; ub: Byte; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemsetD32 = function(dstDevice: TCUdeviceptr; ui: Cardinal; N: Cardinal): TCUresult; stdcall;

This item has no description.

TcuMemsetD8 = function(dstDevice: TCUdeviceptr; ub: Byte; N: Cardinal): TCUresult; stdcall;

This item has no description.

TcuModuleGetFunction = function(out hfunc: PCUfunction; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;

This item has no description.

TcuModuleGetGlobal = function(out dptr: TCUdeviceptr; var bytes: Cardinal; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;

This item has no description.

TcuModuleGetTexRef = function(out pTexRef: PCUtexref; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;

This item has no description.

TcuModuleLoad = function(var module: PCUmodule; const fname: PAnsiChar): TCUresult; stdcall;

This item has no description.

TcuModuleLoadData = function(var module: PCUmodule; const image: PAnsiChar): TCUresult; stdcall;

This item has no description.

TcuModuleLoadDataEx = function(var module: PCUmodule; var image; numOptions: Cardinal; var options: TCUjit_option; var optionValues): TCUresult; stdcall;

This item has no description.

TcuModuleLoadFatBinary = function(var module: PCUmodule; var fatCubin): TCUresult; stdcall;

This item has no description.

TcuModuleUnload = function(hmod: PCUmodule): TCUresult; stdcall;

This item has no description.

TcuParamSetf = function(hfunc: PCUfunction; offset: Integer; value: Single) : TCUresult; stdcall;

This item has no description.

TcuParamSeti = function(hfunc: PCUfunction; offset: Integer; value: Cardinal) : TCUresult; stdcall;

This item has no description.

TcuParamSetSize = function(hfunc: PCUfunction; numbytes: Cardinal): TCUresult; stdcall;

This item has no description.

TcuParamSetTexRef = function(hfunc: PCUfunction; texunit: Integer; hTexRef: PCUtexref): TCUresult; stdcall;

This item has no description.

TcuParamSetv = function(hfunc: PCUfunction; offset: Integer; var ptr; numbytes: Cardinal): TCUresult; stdcall;

This item has no description.

TCUresult = type Cardinal;

************************************ ** ** Error codes ** ***********************************/ Error codes

TcuStreamCreate = function(var phStream: PCUstream; Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TcuStreamDestroy = function(hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuStreamQuery = function(hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuStreamSynchronize = function(hStream: PCUstream): TCUresult; stdcall;

This item has no description.

TcuTexRefCreate = function(var pTexRef: PCUtexref): TCUresult; stdcall;

This item has no description.

TcuTexRefDestroy = function(hTexRef: PCUtexref): TCUresult; stdcall;

This item has no description.

TcuTexRefGetAddress = function(var pdptr: TCUdeviceptr; hTexRef: PCUtexref): TCUresult; stdcall;

This item has no description.

TcuTexRefGetAddressMode = function(var pam: TCUaddress_mode; hTexRef: PCUtexref; dim: Integer): TCUresult; stdcall;

This item has no description.

TcuTexRefGetArray = function(var phArray: PCUarray; hTexRef: PCUtexref): TCUresult; stdcall;

This item has no description.

TcuTexRefGetFilterMode = function(var pfm: TCUfilter_mode; hTexRef: PCUtexref): TCUresult; stdcall;

This item has no description.

TcuTexRefGetFlags = function(var pFlags: Cardinal; hTexRef: PCUtexref): TCUresult; stdcall;

This item has no description.

TcuTexRefGetFormat = function(var pFormat: TCUarray_format; var pNumChannels: Integer; hTexRef: PCUtexref): TCUresult; stdcall;

This item has no description.

TcuTexRefSetAddress = function(var ByteOffset: Cardinal; hTexRef: PCUtexref; dptr: TCUdeviceptr; bytes: Cardinal): TCUresult; stdcall;

This item has no description.

TcuTexRefSetAddress2D = function(hTexRef: PCUtexref; var desc: TCUDA_ARRAY_DESCRIPTOR; dptr: TCUdeviceptr; Pitch: Cardinal) : TCUresult; stdcall;

This item has no description.

TcuTexRefSetAddressMode = function(hTexRef: PCUtexref; dim: Integer; am: TCUaddress_mode): TCUresult; stdcall;

This item has no description.

TcuTexRefSetArray = function(hTexRef: PCUtexref; hArray: PCUarray; Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TcuTexRefSetFilterMode = function(hTexRef: PCUtexref; fm: TCUfilter_mode) : TCUresult; stdcall;

This item has no description.

TcuTexRefSetFlags = function(hTexRef: PCUtexref; Flags: Cardinal): TCUresult; stdcall;

This item has no description.

TcuTexRefSetFormat = function(hTexRef: PCUtexref; fmt: TCUarray_format; NumPackedComponents: Integer): TCUresult; stdcall;

This item has no description.

TcuWGLGetDevice = function(var pDevice: TCUdevice; hGpu: HGPUNV): TCUresult; stdcall;

This item has no description.

TDim3 = array [0 .. 2] of LongWord;

This item has no description.

Constants

CUDAAPIDLL = 'nvcuda.dll';

This item has no description.

CUDA_SUCCESS: TCUresult = 0;

This item has no description.

CUDA_ERROR_INVALID_VALUE = 1;

< No errors

CUDA_ERROR_OUT_OF_MEMORY = 2;

< Invalid value

CUDA_ERROR_NOT_INITIALIZED = 3;

< Out of memory

CUDA_ERROR_DEINITIALIZED = 4;

< Driver not initialized

CUDA_ERROR_NO_DEVICE = 100;

< Driver deinitialized

CUDA_ERROR_INVALID_DEVICE = 101;

< No CUDA-capable device available

CUDA_ERROR_INVALID_IMAGE = 200;

< Invalid device

CUDA_ERROR_INVALID_CONTEXT = 201;

< Invalid kernel image

CUDA_ERROR_CONTEXT_ALREADY_CURRENT = 202;

< Invalid context

CUDA_ERROR_MAP_FAILED = 205;

< Context already current

CUDA_ERROR_UNMAP_FAILED = 206;

< Map failed

CUDA_ERROR_ARRAY_IS_MAPPED = 207;

< Unmap failed

CUDA_ERROR_ALREADY_MAPPED = 208;

< Array is mapped

CUDA_ERROR_NO_BINARY_FOR_GPU = 209;

< Already mapped

CUDA_ERROR_ALREADY_ACQUIRED = 210;

< No binary for GPU

CUDA_ERROR_NOT_MAPPED = 211;

< Already acquired

CUDA_ERROR_NOT_MAPPED_AS_ARRAY = 212;

< Not mapped

CUDA_ERROR_NOT_MAPPED_AS_POINTER = 213;

< Mapped resource not available for access as an array

CUDA_ERROR_INVALID_SOURCE = 300;

< Mapped resource not available for access as a pointer

CUDA_ERROR_FILE_NOT_FOUND = 301;

< Invalid source

CUDA_ERROR_INVALID_HANDLE = 400;

< File not found

CUDA_ERROR_NOT_FOUND = 500;

< Invalid handle

CUDA_ERROR_NOT_READY = 600;

< Not found

CUDA_ERROR_LAUNCH_FAILED = 700;

< CUDA not ready

CUDA_ERROR_LAUNCH_OUT_OF_RESOURCES = 701;

< Launch failed

CUDA_ERROR_LAUNCH_TIMEOUT = 702;

< Launch exceeded resources

CUDA_ERROR_LAUNCH_INCOMPATIBLE_TEXTURING = 703;

< Launch exceeded timeout

CUDA_ERROR_POINTER_IS_64BIT = 800;

< Launch with incompatible texturing

CUDA_ERROR_SIZE_IS_64BIT = 801;

< Attempted to retrieve 64-bit pointer via 32-bit API function

CUDA_ERROR_UNKNOWN = 999;

< Attempted to retrieve 64-bit size via 32-bit API function

CU_MEMHOSTALLOC_PORTABLE = $01;

* If set, host memory is portable between CUDA contexts. * Flag for ::cuMemHostAlloc()

CU_MEMHOSTALLOC_DEVICEMAP = $02;

* If set, host memory is mapped into CUDA address space and * ::cuMemHostGetDevicePointer() may be called on the host pointer. * Flag for ::cuMemHostAlloc()

CU_MEMHOSTALLOC_WRITECOMBINED = $04;

* If set, host memory is allocated as write-combined - fast to write, * faster to DMA, slow to read except via SSE4 streaming load instruction * (MOVNTDQA). * Flag for ::cuMemHostAlloc()

CU_TRSA_OVERRIDE_FORMAT = $01;

* Override the texref format with a format inferred from the array. * Flag for ::cuTexRefSetArray()

CU_TRSF_READ_AS_INTEGER = $01;

* Read the texture as integers rather than promoting the values to floats * in the range [0,1]. * Flag for ::cuTexRefSetFlags()

CU_TRSF_NORMALIZED_COORDINATES = $02;

* Use normalized texture coordinates in the range [0,1) instead of [0,dim). * Flag for ::cuTexRefSetFlags()

CU_PARAM_TR_DEFAULT = -1;

* For texture references loaded into the module, use default texunit from * texture reference.

Variables

cuInit: TcuInit;

This item has no description.

cuDriverGetVersion: TcuDriverGetVersion;

This item has no description.

cuDeviceGet: TcuDeviceGet;

This item has no description.

cuDeviceGetCount: TcuDeviceGetCount;

This item has no description.

cuDeviceGetName: TcuDeviceGetName;

This item has no description.

cuDeviceComputeCapability: TcuDeviceComputeCapability;

This item has no description.

cuDeviceTotalMem: TcuDeviceTotalMem;

This item has no description.

cuDeviceGetProperties: TcuDeviceGetProperties;

This item has no description.

cuDeviceGetAttribute: TcuDeviceGetAttribute;

This item has no description.

cuCtxCreate: TcuCtxCreate;

This item has no description.

cuCtxDestroy: TcuCtxDestroy;

This item has no description.

cuCtxAttach: TcuCtxAttach;

This item has no description.

cuCtxDetach: TcuCtxDetach;

This item has no description.

cuCtxPushCurrent: TcuCtxPushCurrent;

This item has no description.

cuCtxPopCurrent: TcuCtxPopCurrent;

This item has no description.

cuCtxGetDevice: TcuCtxGetDevice;

This item has no description.

cuCtxSynchronize: TcuCtxSynchronize;

This item has no description.

cuModuleLoad: TcuModuleLoad;

This item has no description.

cuModuleLoadData: TcuModuleLoadData;

This item has no description.

cuModuleLoadDataEx: TcuModuleLoadDataEx;

This item has no description.

cuModuleLoadFatBinary: TcuModuleLoadFatBinary;

This item has no description.

cuModuleUnload: TcuModuleUnload;

This item has no description.

cuModuleGetFunction: TcuModuleGetFunction;

This item has no description.

cuModuleGetGlobal: TcuModuleGetGlobal;

This item has no description.

cuModuleGetTexRef: TcuModuleGetTexRef;

This item has no description.

cuMemGetInfo: TcuMemGetInfo;

This item has no description.

cuMemAlloc: TcuMemAlloc;

This item has no description.

cuMemAllocPitch: TcuMemAllocPitch;

This item has no description.

cuMemFree: TcuMemFree;

This item has no description.

cuMemGetAddressRange: TcuMemGetAddressRange;

This item has no description.

cuMemAllocHost: TcuMemAllocHost;

This item has no description.

cuMemFreeHost: TcuMemFreeHost;

This item has no description.

cuMemHostAlloc: TcuMemHostAlloc;

This item has no description.

cuMemHostGetDevicePointer: TcuMemHostGetDevicePointer;

This item has no description.

cuMemHostGetFlags: TcuMemHostGetFlags;

This item has no description.

cuMemcpyHtoD: TcuMemcpyHtoD;

This item has no description.

cuMemcpyDtoH: TcuMemcpyDtoH;

This item has no description.

cuMemcpyDtoD: TcuMemcpyDtoD;

This item has no description.

cuMemcpyDtoDAsync: TcuMemcpyDtoDAsync;

This item has no description.

cuMemcpyDtoA: TcuMemcpyDtoA;

This item has no description.

cuMemcpyAtoD: TcuMemcpyAtoD;

This item has no description.

cuMemcpyHtoA: TcuMemcpyHtoA;

This item has no description.

cuMemcpyAtoH: TcuMemcpyAtoH;

This item has no description.

cuMemcpyAtoA: TcuMemcpyAtoA;

This item has no description.

cuMemcpy2D: TcuMemcpy2D;

This item has no description.

cuMemcpy2DUnaligned: TcuMemcpy2DUnaligned;

This item has no description.

cuMemcpy3D: TcuMemcpy3D;

This item has no description.

cuMemcpyHtoDAsync: TcuMemcpyHtoDAsync;

This item has no description.

cuMemcpyDtoHAsync: TcuMemcpyDtoHAsync;

This item has no description.

cuMemcpyHtoAAsync: TcuMemcpyHtoAAsync;

This item has no description.

cuMemcpyAtoHAsync: TcuMemcpyAtoHAsync;

This item has no description.

cuMemcpy2DAsync: TcuMemcpy2DAsync;

This item has no description.

cuMemcpy3DAsync: TcuMemcpy3DAsync;

This item has no description.

cuMemsetD8: TcuMemsetD8;

This item has no description.

cuMemsetD16: TcuMemsetD16;

This item has no description.

cuMemsetD32: TcuMemsetD32;

This item has no description.

cuMemsetD2D8: TcuMemsetD2D8;

This item has no description.

cuMemsetD2D16: TcuMemsetD2D16;

This item has no description.

cuMemsetD2D32: TcuMemsetD2D32;

This item has no description.

cuFuncSetBlockShape: TcuFuncSetBlockShape;

This item has no description.

cuFuncSetSharedSize: TcuFuncSetSharedSize;

This item has no description.

cuFuncGetAttribute: TcuFuncGetAttribute;

This item has no description.

cuArrayCreate: TcuArrayCreate;

This item has no description.

cuArrayGetDescriptor: TcuArrayGetDescriptor;

This item has no description.

cuArrayDestroy: TcuArrayDestroy;

This item has no description.

cuArray3DCreate: TcuArray3DCreate;

This item has no description.

cuArray3DGetDescriptor: TcuArray3DGetDescriptor;

This item has no description.

cuTexRefCreate: TcuTexRefCreate;

This item has no description.

cuTexRefDestroy: TcuTexRefDestroy;

This item has no description.

cuTexRefSetArray: TcuTexRefSetArray;

This item has no description.

cuTexRefSetAddress: TcuTexRefSetAddress;

This item has no description.

cuTexRefSetAddress2D: TcuTexRefSetAddress2D;

This item has no description.

cuTexRefSetFormat: TcuTexRefSetFormat;

This item has no description.

cuTexRefSetAddressMode: TcuTexRefSetAddressMode;

This item has no description.

cuTexRefSetFilterMode: TcuTexRefSetFilterMode;

This item has no description.

cuTexRefSetFlags: TcuTexRefSetFlags;

This item has no description.

cuTexRefGetAddress: TcuTexRefGetAddress;

This item has no description.

cuTexRefGetArray: TcuTexRefGetArray;

This item has no description.

cuTexRefGetAddressMode: TcuTexRefGetAddressMode;

This item has no description.

cuTexRefGetFilterMode: TcuTexRefGetFilterMode;

This item has no description.

cuTexRefGetFormat: TcuTexRefGetFormat;

This item has no description.

cuTexRefGetFlags: TcuTexRefGetFlags;

This item has no description.

cuParamSetSize: TcuParamSetSize;

This item has no description.

cuParamSeti: TcuParamSeti;

This item has no description.

cuParamSetf: TcuParamSetf;

This item has no description.

cuParamSetv: TcuParamSetv;

This item has no description.

cuParamSetTexRef: TcuParamSetTexRef;

This item has no description.

cuLaunch: TcuLaunch;

This item has no description.

cuLaunchGrid: TcuLaunchGrid;

This item has no description.

cuLaunchGridAsync: TcuLaunchGridAsync;

This item has no description.

cuEventCreate: TcuEventCreate;

This item has no description.

cuEventRecord: TcuEventRecord;

This item has no description.

cuEventQuery: TcuEventQuery;

This item has no description.

cuEventSynchronize: TcuEventSynchronize;

This item has no description.

cuEventDestroy: TcuEventDestroy;

This item has no description.

cuEventElapsedTime: TcuEventElapsedTime;

This item has no description.

cuStreamCreate: TcuStreamCreate;

This item has no description.

cuStreamQuery: TcuStreamQuery;

This item has no description.

cuStreamSynchronize: TcuStreamSynchronize;

This item has no description.

cuStreamDestroy: TcuStreamDestroy;

This item has no description.

cuGLInit: TcuGLInit;

This item has no description.

cuGLCtxCreate: TcuGLCtxCreate;

This item has no description.

cuGraphicsGLRegisterBuffer: TcuGraphicsGLRegisterBuffer;

This item has no description.

cuGraphicsGLRegisterImage: TcuGraphicsGLRegisterImage;

This item has no description.

cuWGLGetDevice: TcuWGLGetDevice;

This item has no description.

cuGraphicsUnregisterResource: TcuGraphicsUnregisterResource;

This item has no description.

cuGraphicsSubResourceGetMappedArray: TcuGraphicsSubResourceGetMappedArray;

This item has no description.

cuGraphicsResourceGetMappedPointer: TcuGraphicsResourceGetMappedPointer;

This item has no description.

cuGraphicsResourceSetMapFlags: TcuGraphicsResourceSetMapFlags;

This item has no description.

cuGraphicsMapResources: TcuGraphicsMapResources;

This item has no description.

cuGraphicsUnmapResources: TcuGraphicsUnmapResources;

This item has no description.

cuGLRegisterBufferObject: TcuGLRegisterBufferObject;

This item has no description.

cuGLMapBufferObject: TcuGLMapBufferObject;

This item has no description.

cuGLUnmapBufferObject: TcuGLUnmapBufferObject;

This item has no description.

cuGLUnregisterBufferObject: TcuGLUnregisterBufferObject;

This item has no description.

cuGLSetBufferObjectMapFlags: TcuGLSetBufferObjectMapFlags;

This item has no description.

cuGLMapBufferObjectAsync: TcuGLMapBufferObjectAsync;

This item has no description.

cuGLUnmapBufferObjectAsync: TcuGLUnmapBufferObjectAsync;


GLSysHelp v.2.5: CUDA.Import: Record TCUcontext

Record TCUcontext

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUcontext = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.Import: Record TCUmodule

Record TCUmodule

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUmodule = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.Import: Record TCUfunction

Record TCUfunction

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUfunction = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.Import: Record TCUarray

Record TCUarray

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUarray = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.Import: Record TCUtexref

Record TCUtexref

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUtexref = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.Import: Record TCUevent

Record TCUevent

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUevent = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.Import: Record TCUstream

Record TCUstream

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUstream = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.Import: Record TCUgraphicsResource

Record TCUgraphicsResource

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUgraphicsResource = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: CUDA.Import: Record TCUdevprop

Record TCUdevprop

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUdevprop = record

Description

Legacy device properties

Overview

Fields

Public | maxThreadsPerBlock: Integer;
Public | maxThreadsDim: array [0 .. 2] of Integer;
Public | maxGridSize: array [0 .. 2] of Integer;
Public | sharedMemPerBlock: Integer;
Public | totalConstantMemory: Integer;
Public | SIMDWidth: Integer;
Public | memPitch: Integer;
Public | regsPerBlock: Integer;
Public | clockRate: Integer;
Public | textureAlign: Integer;

Description

Fields

Public maxThreadsPerBlock: Integer;

Maximum number of threads per block

Public maxThreadsDim: array [0 .. 2] of Integer;

Maximum size of each dimension of a block

Public maxGridSize: array [0 .. 2] of Integer;

Maximum size of each dimension of a grid

Public sharedMemPerBlock: Integer;

Shared memory available per block in bytes

Public totalConstantMemory: Integer;

Constant memory available on device in bytes

Public SIMDWidth: Integer;

Warp size in threads

Public memPitch: Integer;

Maximum pitch in bytes allowed by memory copies

Public regsPerBlock: Integer;

32-bit registers available per block

Public clockRate: Integer;

Clock frequency in kilohertz

Public textureAlign: Integer;

Alignment requirement for textures


GLSysHelp v.2.5: CUDA.Import: Record TcudaFuncAttributes

Record TcudaFuncAttributes

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TcudaFuncAttributes = record

Description

* CUDA function attributes

Overview

Fields

Public | sharedSizeBytes: NativeUInt;
Public | constSizeBytes: NativeUInt;
Public | localSizeBytes: NativeUInt;
Public | maxThreadsPerBlock: Integer;
Public | numRegs: Integer;
Public | ptxVersion: Integer;
Public | binaryVersion: Integer;
Public | __cudaReserved: array [0 .. 5] of Integer;

Description

Fields

Public sharedSizeBytes: NativeUInt;

Size of shared memory in bytes

Public constSizeBytes: NativeUInt;

Size of constant memory in bytes

Public localSizeBytes: NativeUInt;

Size of local memory in bytes

Public maxThreadsPerBlock: Integer;

Maximum number of threads per block

Public numRegs: Integer;

Number of registers used

Public ptxVersion: Integer;

\brief PTX virtual architecture version for which the function was * compiled. This value is the major PTX version * 10 + the minor PTX * version, so a PTX version 1.3 function would return the value 13. * For device emulation kernels, this is set to 9999.

Public binaryVersion: Integer;

* \brief Binary architecture version for which the function was compiled. * This value is the major binary version * 10 + the minor binary version, * so a binary version 1.3 function would return the value 13. * For device emulation kernels, this is set to 9999.

Public __cudaReserved: array [0 .. 5] of Integer;


GLSysHelp v.2.5: CUDA.Import: Record TCUDA_MEMCPY2D

Record TCUDA_MEMCPY2D

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUDA_MEMCPY2D = record

Description

This item has no description.

Overview

Fields

Public | srcXInBytes: Cardinal;
Public | srcY: Cardinal;
Public | srcMemoryType: TCUmemorytype;
Public | srcHost: Pointer;
Public | srcDevice: TCUdeviceptr;
Public | srcArray: PCUarray;
Public | srcPitch: Cardinal;
Public | dstXInBytes: Cardinal;
Public | dstY: Cardinal;
Public | dstMemoryType: TCUmemorytype;
Public | dstHost: Pointer;
Public | dstDevice: TCUdeviceptr;
Public | dstArray: PCUarray;
Public | dstPitch: Cardinal;
Public | WidthInBytes: Cardinal;
Public | Height: Cardinal;

Description

Fields

Public srcXInBytes: Cardinal;

This item has no description.

Public srcY: Cardinal;

< Source X in bytes

Public srcMemoryType: TCUmemorytype;

< Source Y

Public srcHost: Pointer;

< Source memory type (host, device, array)

Public srcDevice: TCUdeviceptr;

< Source host pointer

Public srcArray: PCUarray;

< Source device pointer

Public srcPitch: Cardinal;

< Source array reference

Public dstXInBytes: Cardinal;

< Source pitch (ignored when src is array)

Public dstY: Cardinal;

< Destination X in bytes

Public dstMemoryType: TCUmemorytype;

< Destination Y

Public dstHost: Pointer;

< Destination memory type (host, device, array)

Public dstDevice: TCUdeviceptr;

< Destination host pointer

Public dstArray: PCUarray;

< Destination device pointer

Public dstPitch: Cardinal;

< Destination array reference

Public WidthInBytes: Cardinal;

< Destination pitch (ignored when dst is array)

Public Height: Cardinal;

< Width of 2D memory copy in bytes


GLSysHelp v.2.5: CUDA.Import: Record TCUDA_MEMCPY3D

Record TCUDA_MEMCPY3D

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUDA_MEMCPY3D = record

Description

3D memory copy parameters

Overview

Fields

Public | srcXInBytes: Cardinal;
Public | srcY: Cardinal;
Public | srcZ: Cardinal;
Public | srcLOD: Cardinal;
Public | srcMemoryType: TCUmemorytype;
Public | srcHost: Pointer;
Public | srcDevice: TCUdeviceptr;
Public | srcArray: PCUarray;
Public | reserved0: Pointer;
Public | srcPitch: Cardinal;
Public | srcHeight: Cardinal;
Public | dstXInBytes: Cardinal;
Public | dstY: Cardinal;
Public | dstZ: Cardinal;
Public | dstLOD: Cardinal;
Public | dstMemoryType: TCUmemorytype;
Public | dstHost: Pointer;
Public | dstDevice: TCUdeviceptr;
Public | dstArray: PCUarray;
Public | reserved1: Pointer;
Public | dstPitch: Cardinal;
Public | dstHeight: Cardinal;
Public | WidthInBytes: Cardinal;
Public | Height: Cardinal;
Public | Depth: Cardinal;

Description

Fields

Public srcXInBytes: Cardinal;

This item has no description.

Public srcY: Cardinal;

< Source X in bytes

Public srcZ: Cardinal;

< Source Y

Public srcLOD: Cardinal;

< Source Z

Public srcMemoryType: TCUmemorytype;

< Source LOD

Public srcHost: Pointer;

< Source memory type (host, device, array)

Public srcDevice: TCUdeviceptr;

< Source host pointer

Public srcArray: PCUarray;

< Source device pointer

Public reserved0: Pointer;

< Source array reference

Public srcPitch: Cardinal;

< Must be NULL

Public srcHeight: Cardinal;

< Source pitch (ignored when src is array)

Public dstXInBytes: Cardinal;

< Source height (ignored when src is array; may be 0 if Depth==1)

Public dstY: Cardinal;

< Destination X in bytes

Public dstZ: Cardinal;

< Destination Y

Public dstLOD: Cardinal;

< Destination Z

Public dstMemoryType: TCUmemorytype;

< Destination LOD

Public dstHost: Pointer;

< Destination memory type (host, device, array)

Public dstDevice: TCUdeviceptr;

< Destination host pointer

Public dstArray: PCUarray;

< Destination device pointer

Public reserved1: Pointer;

< Destination array reference

Public dstPitch: Cardinal;

< Must be NULL

Public dstHeight: Cardinal;

< Destination pitch (ignored when dst is array)

Public WidthInBytes: Cardinal;

< Destination height (ignored when dst is array; may be 0 if Depth==1)

Public Height: Cardinal;

< Width of 3D memory copy in bytes

Public Depth: Cardinal;

< Height of 3D memory copy


GLSysHelp v.2.5: CUDA.Import: Record TCUDA_ARRAY_DESCRIPTOR

Record TCUDA_ARRAY_DESCRIPTOR

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUDA_ARRAY_DESCRIPTOR = record

Description

This item has no description.

Overview

Fields

Public | Width: Cardinal;
Public | Height: Cardinal;
Public | Format: TCUarray_format;
Public | NumChannels: Cardinal;

Description

Fields

Public Width: Cardinal;

This item has no description.

Public Height: Cardinal;

< Width of array

Public Format: TCUarray_format;

< Height of array

Public NumChannels: Cardinal;

< Array format


GLSysHelp v.2.5: CUDA.Import: Record TCUDA_ARRAY3D_DESCRIPTOR

Record TCUDA_ARRAY3D_DESCRIPTOR

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Import

Declaration

type TCUDA_ARRAY3D_DESCRIPTOR = record

Description

3D array descriptor

Overview

Fields

Public | Width: Cardinal;
Public | Height: Cardinal;
Public | Depth: Cardinal;
Public | Format: TCUarray_format;
Public | NumChannels: Cardinal;
Public | Flags: Cardinal;

Description

Fields

Public Width: Cardinal;

This item has no description.

Public Height: Cardinal;

< Width of 3D array

Public Depth: Cardinal;

< Height of 3D array

Public Format: TCUarray_format;

< Depth of 3D array

Public NumChannels: Cardinal;

< Array format

Public Flags: Cardinal;

< Channels per array element


GLSysHelp v.2.5: CUDA.ParallelPrimitives

Unit CUDA.ParallelPrimitives

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TCUDPPConfiguration |

Functions and Procedures

function cudppPlan(var planHandle: TCUDPPHandle; config: TCUDPPConfiguration; n: NativeUInt; rows: NativeUInt; rowPitch: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppDestroyPlan(plan: TCUDPPHandle): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppScan(planHandle: TCUDPPHandle; var d_out; var d_in, numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppMultiScan(planHandle: TCUDPPHandle; var d_out; var d_in; numElements: NativeUInt; numRows: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSegmentedScan(planHandle: TCUDPPHandle; var d_out; var d_idata; const d_iflags: PCardinal; numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppCompact(planHandle: TCUDPPHandle; var d_out; var d_numValidElements: NativeUInt; var d_in; const d_isValid: PCardinal; numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSort(planHandle: TCUDPPHandle; var d_keys; var d_values; keybits: Integer; numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSparseMatrix(var sparseMatrixHandle: TCUDPPHandle; config: TCUDPPConfiguration; n: NativeUInt; rows: NativeUInt; var A; const h_rowIndices: PCardinal; const h_indices: PCardinal): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppDestroySparseMatrix(sparseMatrixHandle: TCUDPPHandle): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSparseMatrixVectorMultiply(sparseMatrixHandle: TCUDPPHandle; var d_y; var d_x): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppRand(planHandle: TCUDPPHandle; var d_out; numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppRandSeed(const planHandle: TCUDPPHandle; seed: Cardinal): TCUDPPResult; stdcall; external CUDPPDLL;

Types

TCUDPPAlgorithm = (...);
TCUDPPDatatype = (...);
TCUDPPHandle = NativeUInt;
TCUDPPOperator = (...);
TCUDPPOption = (...);
TCUDPPResult = (...);

Constants

CUDPPDLL = 'cudpp32.dll';
CUDPP_INVALID_HANDLE = $C0DABAD1;

Description

Functions and Procedures

function cudppPlan(var planHandle: TCUDPPHandle; config: TCUDPPConfiguration; n: NativeUInt; rows: NativeUInt; rowPitch: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;

Plan allocation (for scan, sort, and compact)

function cudppDestroyPlan(plan: TCUDPPHandle): TCUDPPResult; stdcall; external CUDPPDLL;

This item has no description.

function cudppScan(planHandle: TCUDPPHandle; var d_out; var d_in, numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;

Scan and sort algorithms

function cudppMultiScan(planHandle: TCUDPPHandle; var d_out; var d_in; numElements: NativeUInt; numRows: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;

This item has no description.

function cudppSegmentedScan(planHandle: TCUDPPHandle; var d_out; var d_idata; const d_iflags: PCardinal; numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;

This item has no description.

function cudppCompact(planHandle: TCUDPPHandle; var d_out; var d_numValidElements: NativeUInt; var d_in; const d_isValid: PCardinal; numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;

This item has no description.

function cudppSort(planHandle: TCUDPPHandle; var d_keys; var d_values; keybits: Integer; numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;

This item has no description.

function cudppSparseMatrix(var sparseMatrixHandle: TCUDPPHandle; config: TCUDPPConfiguration; n: NativeUInt; rows: NativeUInt; var A; const h_rowIndices: PCardinal; const h_indices: PCardinal): TCUDPPResult; stdcall; external CUDPPDLL;

Sparse matrix allocation

function cudppDestroySparseMatrix(sparseMatrixHandle: TCUDPPHandle): TCUDPPResult; stdcall; external CUDPPDLL;

This item has no description.

function cudppSparseMatrixVectorMultiply(sparseMatrixHandle: TCUDPPHandle; var d_y; var d_x): TCUDPPResult; stdcall; external CUDPPDLL;

Sparse matrix-vector algorithms

function cudppRand(planHandle: TCUDPPHandle; var d_out; numElements: NativeUInt): TCUDPPResult; stdcall; external CUDPPDLL;

random number generation algorithms

function cudppRandSeed(const planHandle: TCUDPPHandle; seed: Cardinal): TCUDPPResult; stdcall; external CUDPPDLL;

This item has no description.

Types

TCUDPPAlgorithm = (...);

Maximum of two operands

Values
  • CUDPP_SCAN
  • CUDPP_SEGMENTED_SCAN
  • CUDPP_COMPACT
  • CUDPP_REDUCE
  • CUDPP_SORT_RADIX
  • CUDPP_SPMVMULT
  • CUDPP_RAND_MD5: Sparse matrix-dense vector multiplication
  • CUDPP_ALGORITHM_INVALID: Pseudo Random Number Generator using MD5 hash algorithm
TCUDPPDatatype = (...);

Each key has an associated value

Values
  • CUDPP_CHAR
  • CUDPP_UCHAR: Character type (C char)
  • CUDPP_INT: Unsigned character (byte) type (C unsigned char)
  • CUDPP_UINT: Integer type (C int)
  • CUDPP_FLOAT: Unsigned integer type (C unsigned int)
TCUDPPHandle = NativeUInt;

This item has no description.

TCUDPPOperator = (...);

Float type (C float)

Values
  • CUDPP_ADD
  • CUDPP_MULTIPLY: Addition of two operands
  • CUDPP_MIN: Multiplication of two operands
  • CUDPP_MAX: Minimum of two operands
TCUDPPOption = (...);

Unknown or untraceable error.

Values
  • CUDPP_OPTION_FORWARD
  • CUDPP_OPTION_BACKWARD: Algorithms operate forward: from start to end of input array
  • CUDPP_OPTION_EXCLUSIVE: Algorithms operate backward: from end to start of array
  • CUDPP_OPTION_INCLUSIVE: Exclusive (for scans) - scan includes all elements up to (but not including) the current element
  • CUDPP_OPTION_CTA_LOCAL: Inclusive (for scans) - scan includes all elements up to and including the current element
  • CUDPP_OPTION_KEYS_ONLY: Algorithm performed only on the CTAs (blocks) with no communication between blocks. @todo Currently ignored.
  • CUDPP_OPTION_KEY_VALUE_PAIRS: No associated value to a key (for global radix sort)
TCUDPPResult = (...);

This item has no description.

Values
  • CUDPP_SUCCESS
  • CUDPP_ERROR_INVALID_HANDLE: No error.
  • CUDPP_ERROR_ILLEGAL_CONFIGURATION: Specified handle (for example, to a plan) is invalid.
  • CUDPP_ERROR_UNKNOWN: Specified configuration is illegal. For example, an invalid or illogical combination of options.

Constants

CUDPPDLL = 'cudpp32.dll';

————————————————————- cuDPP – CUDA Data Parallel Primitives library ————————————————————- $Revision: 4567 $ $Date: 2020-05-17 ————————————————————- This source code is distributed under the terms of license.txt in the root directory of this source distribution. ————————————————————-

CUDPP_INVALID_HANDLE = $C0DABAD1;


GLSysHelp v.2.5: CUDA.ParallelPrimitives: Record TCUDPPConfiguration

Record TCUDPPConfiguration

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.ParallelPrimitives

Declaration

type TCUDPPConfiguration = record

Description

Placeholder at end of enum

Overview

Fields

Public | algorithm: TCUDPPAlgorithm;
Public | op: TCUDPPOperator;
Public | datatype: TCUDPPDatatype;
Public | options: TCUDPPoption;

Description

Fields

Public algorithm: TCUDPPAlgorithm;

This item has no description.

Public op: TCUDPPOperator;

The algorithm to be used

Public datatype: TCUDPPDatatype;

The numerical operator to be applied

Public options: TCUDPPoption;

The datatype of the input arrays


GLSysHelp v.2.5: CUDA.Parser

Unit CUDA.Parser

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • CUDA.RunTime

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TCUDATexRefInfo |
Record TCUDAFuncArgInfo |
Record TCUDAFuncInfo |
Record TCUDAConstantInfo |
Class TCUDAModuleInfo |

Types

TCUDAType = (...);

Description

Types

TCUDAType = (...);

This item has no description.

Values
  • customType
  • char1
  • uchar1
  • char2
  • uchar2
  • char3
  • uchar3
  • char4
  • uchar4
  • short1
  • ushort1
  • short2
  • ushort2
  • short3
  • ushort3
  • short4
  • ushort4
  • int1
  • uint1
  • int2
  • uint2
  • int3
  • uint3
  • int4
  • uint4
  • long1
  • ulong1
  • long2
  • ulong2
  • long3
  • ulong3
  • long4
  • ulong4
  • float1
  • float2
  • float3
  • float4
  • longlong1
  • ulonglong1
  • longlong2
  • ulonglong2
  • longlong3
  • ulonglong3
  • longlong4
  • ulonglong4
  • double1
  • double2
  • double3
  • double4
  • int8
  • int16
  • int32
  • uint8
  • uint16
  • uint32


GLSysHelp v.2.5: CUDA.Parser: Record TCUDATexRefInfo

Record TCUDATexRefInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Parser

Declaration

type TCUDATexRefInfo = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | DataType: TCUDAType;
Public | Dim: Byte;
Public | ReadMode: TcudaTextureReadMode;

Description

Fields

Public Name: string;

This item has no description.

Public DataType: TCUDAType;

This item has no description.

Public Dim: Byte;

This item has no description.

Public ReadMode: TcudaTextureReadMode;


GLSysHelp v.2.5: CUDA.Parser: Record TCUDAFuncArgInfo

Record TCUDAFuncArgInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Parser

Declaration

type TCUDAFuncArgInfo = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | DataType: TCUDAType;
Public | CustomType: string;
Public | Ref: Boolean;

Description

Fields

Public Name: string;

This item has no description.

Public DataType: TCUDAType;

This item has no description.

Public CustomType: string;

This item has no description.

Public Ref: Boolean;


GLSysHelp v.2.5: CUDA.Parser: Record TCUDAFuncInfo

Record TCUDAFuncInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Parser

Declaration

type TCUDAFuncInfo = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | KernelName: string;
Public | Args: array of TCUDAFuncArgInfo;

Description

Fields

Public Name: string;

This item has no description.

Public KernelName: string;

This item has no description.

Public Args: array of TCUDAFuncArgInfo;


GLSysHelp v.2.5: CUDA.Parser: Record TCUDAConstantInfo

Record TCUDAConstantInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Parser

Declaration

type TCUDAConstantInfo = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | DataType: TCUDAType;
Public | CustomType: string;
Public | Ref: Boolean;
Public | DefValue: Boolean;

Description

Fields

Public Name: string;

This item has no description.

Public DataType: TCUDAType;

This item has no description.

Public CustomType: string;

This item has no description.

Public Ref: Boolean;

This item has no description.

Public DefValue: Boolean;


GLSysHelp v.2.5: CUDA.Parser: Class TCUDAModuleInfo

Class TCUDAModuleInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Parser

Declaration

type TCUDAModuleInfo = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TCUDAModuleInfo

Overview

Fields

Private | ping: TStrings;
Private | pong: TStrings;
Public | Owner: TComponent;
Public | TexRef: array of TCUDATexRefInfo;
Public | Func: array of TCUDAFuncInfo;
Public | Constant: array of TCUDAConstantInfo;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure ParseModule(ASource, AProduct: TStrings);
Private | procedure BreakStrings(inlist, outlist: TStrings);
Private | procedure FindConst(inlist: TStrings);
Private | procedure FindFunc(inlist: TStrings);
Private | procedure FindFuncKernelName(inlist: TStrings);
Private | procedure FindTexRef(inlist: TStrings);
Private | procedure RemoveComents(inlist, outlist: TStrings);
Private | procedure RemoveSpaces(inlist, outlist: TStrings);
Private | procedure ReplaceUnsigned(inlist, outlist: TStrings);
Private | procedure Reset;

Description

Fields

Private ping: TStrings;

This item has no description.

Private pong: TStrings;

This item has no description.

Public Owner: TComponent;

This item has no description.

Public TexRef: array of TCUDATexRefInfo;

This item has no description.

Public Func: array of TCUDAFuncInfo;

This item has no description.

Public Constant: array of TCUDAConstantInfo;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure ParseModule(ASource, AProduct: TStrings);

This item has no description.

Private procedure BreakStrings(inlist, outlist: TStrings);

This item has no description.

Private procedure FindConst(inlist: TStrings);

This item has no description.

Private procedure FindFunc(inlist: TStrings);

This item has no description.

Private procedure FindFuncKernelName(inlist: TStrings);

This item has no description.

Private procedure FindTexRef(inlist: TStrings);

This item has no description.

Private procedure RemoveComents(inlist, outlist: TStrings);

This item has no description.

Private procedure RemoveSpaces(inlist, outlist: TStrings);

This item has no description.

Private procedure ReplaceUnsigned(inlist, outlist: TStrings);

This item has no description.

Private procedure Reset;


GLSysHelp v.2.5: CUDA.Runtime

Unit CUDA.Runtime

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • CUDA.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TCudaChannelFormatDesc |
Record TcudaArray |
Record TcudaPitchedPtr |
Record TcudaExtent |
Record TcudaPos |
Record TcudaMemcpy3DParms |
Record TCudaDeviceProp |
Record TTextureReference |

Functions and Procedures

function cudaGetLastErrorString: string;
function InitCUDART: Boolean;
procedure CloseCUDART;
function InitCUDARTFromLibrary(const LibName: WideString): Boolean;
function IsCUDARTInitialized: Boolean;

Types

cudaError_t = TcudaError;
cudaEvent_t = Integer;
cudaStream_t = Integer;
PcudaArray = ˆTcudaArray;
PcudaChannelFormatDesc = ˆTCudaChannelFormatDesc;
PCudaDeviceProp = ˆTCudaDeviceProp;
PTextureReference = ˆTTextureReference;
TCudaChannelFormatKind = (...);
TcudaError = (...);
TCudaGLMapFlags = (...);
TcudaMemcpyKind = (...);
TcudaTextureAddressMode = (...);
TcudaTextureFilterMode = (...);
TcudaTextureReadMode = (...);

Constants

CUDARTDLLNAMES: array [0 .. 9] of string = ( 'cudart32_42_9', 'cudart32_41_28', 'cudart32_40_10', 'cudart32_32_16', 'cudart32_31_4', 'cudart32_30_14', 'cudart32_30_9', 'cudart32_30_8', 'cudart32', 'cudart');
CUDART_INF_F: Single = $7F800000;
CUDART_NAN_F: Single = $7FFFFFFF;
CUDART_MIN_DENORM_F: Single = $00000001;
CUDART_MAX_NORMAL_F: Single = $7F7FFFFF;
CUDART_NEG_ZERO_F: Single = $80000000;
CUDART_ZERO_F = 0.0;
CUDART_ONE_F = 1.0;
CUDART_SQRT_HALF_F = 0.707106781;
CUDART_SQRT_TWO_F = 1.414213562;
CUDART_THIRD_F = 0.333333333;
CUDART_PIO4_F = 0.785398163;
CUDART_PIO2_F = 1.570796327;
CUDART_3PIO4_F = 2.356194490;
CUDART_2_OVER_PI_F = 0.636619772;
CUDART_PI_F = 3.141592654;
CUDART_L2E_F = 1.442695041;
CUDART_L2T_F = 3.321928094;
CUDART_LG2_F = 0.301029996;
CUDART_LGE_F = 0.434294482;
CUDART_LN2_F = 0.693147181;
CUDART_LNT_F = 2.302585093;
CUDART_LNPI_F = 1.144729886;
CUDART_TWO_TO_M126_F = 1.175494351E-38;
CUDART_TWO_TO_126_F = 8.507059173E37;
CUDART_NORM_HUGE_F = 3.402823466E38;
CUDART_TWO_TO_23_F = 8388608.0;
CUDART_TWO_TO_24_F = 16777216.0;
CUDART_TWO_TO_31_F = 2147483648.0;
CUDART_TWO_TO_32_F = 4294967296.0;
CUDART_REMQUO_BITS_F = 3;
CUDART_REMQUO_MASK_F = CUDART_REMQUO_BITS_F;
CUDART_TRIG_PLOSS_F = 48039.0;
CUDART_INF: Double = $7FF0000000000000;
CUDART_NAN: Double = $FFF8000000000000;
CUDART_NEG_ZERO: Double = $8000000000000000;
CUDART_MIN_DENORM: Double = $0000000000000001;
CUDART_ZERO = 0.0;
CUDART_ONE = 1.0;
CUDART_SQRT_TWO = 1.4142135623730951E+0;
CUDART_SQRT_HALF = 7.0710678118654757E-1;
CUDART_THIRD = 3.3333333333333333E-1;
CUDART_TWOTHIRD = 6.6666666666666667E-1;
CUDART_PIO4 = 7.8539816339744828E-1;
CUDART_PIO4_HI = 7.8539816339744828E-1;
CUDART_PIO4_LO = 3.0616169978683830E-17;
CUDART_PIO2 = 1.5707963267948966E+0;
CUDART_PIO2_HI = 1.5707963267948966E+0;
CUDART_PIO2_LO = 6.1232339957367660E-17;
CUDART_3PIO4 = 2.3561944901923448E+0;
CUDART_2_OVER_PI = 6.3661977236758138E-1;
CUDART_PI = 3.1415926535897931E+0;
CUDART_PI_HI = 3.1415926535897931E+0;
CUDART_PI_LO = 1.2246467991473532E-16;
CUDART_SQRT_2PI_HI = 2.5066282746310007E+0;
CUDART_SQRT_2PI_LO = -1.8328579980459167E-16;
CUDART_SQRT_PIO2_HI = 1.2533141373155003E+0;
CUDART_SQRT_PIO2_LO = -9.1642899902295834E-17;
CUDART_L2E = 1.4426950408889634E+0;
CUDART_L2E_HI = 1.4426950408889634E+0;
CUDART_L2E_LO = 2.0355273740931033E-17;
CUDART_L2T = 3.3219280948873622E+0;
CUDART_LG2 = 3.0102999566398120E-1;
CUDART_LG2_HI = 3.0102999566398120E-1;
CUDART_LG2_LO = -2.8037281277851704E-18;
CUDART_LGE = 4.3429448190325182E-1;
CUDART_LGE_HI = 4.3429448190325182E-1;
CUDART_LGE_LO = 1.09831965021676510E-17;
CUDART_LN2 = 6.9314718055994529E-1;
CUDART_LN2_HI = 6.9314718055994529E-1;
CUDART_LN2_LO = 2.3190468138462996E-17;
CUDART_LNT = 2.3025850929940459E+0;
CUDART_LNT_HI = 2.3025850929940459E+0;
CUDART_LNT_LO = -2.1707562233822494E-16;
CUDART_LNPI = 1.1447298858494002E+0;
CUDART_LN2_X_1024 = 7.0978271289338397E+2;
CUDART_LN2_X_1025 = 7.1047586007394398E+2;
CUDART_LN2_X_1075 = 7.4513321910194122E+2;
CUDART_LG2_X_1024 = 3.0825471555991675E+2;
CUDART_LG2_X_1075 = 3.2360724533877976E+2;
CUDART_TWO_TO_23 = 8388608.0;
CUDART_TWO_TO_52 = 4503599627370496.0;
CUDART_TWO_TO_54 = 18014398509481984.0;
CUDART_TWO_TO_M54 = 5.5511151231257827E-17;
CUDART_TWO_TO_M1022 = 2.22507385850720140E-308;
CUDART_TRIG_PLOSS = 2147483648.0;

Variables

cudaBindTexture: function(var offset: NativeUInt; const texref: PTextureReference; var devPtr: Pointer; var desc: TCudaChannelFormatDesc; size: NativeUInt): cudaError_t; stdcall;
cudaBindTexture2D: function(var offset: NativeUInt; const texref: PTextureReference; const devPtr: Pointer; var desc: TCudaChannelFormatDesc; width, height, pitch: NativeUInt): cudaError_t; stdcall;
cudaBindTextureToArray: function(const texref: PTextureReference; const cudaArray: PcudaArray): cudaError_t; stdcall;
cudaUnbindTexture: function(const texref: PTextureReference): cudaError_t; stdcall;
cudaGetTextureAlignmentOffset: function(offset: NativeUInt; const texref: PTextureReference): cudaError_t; stdcall;
cudaGetTextureReference: function(const texref: PTextureReference; const symbol: PAnsiChar): cudaError_t; stdcall;
cudaGetChannelDesc: function(var desc: TCudaChannelFormatDesc; const array_: Pointer): cudaError_t; stdcall;
cudaCreateChannelDesc: function(x, y, z, w: Integer; f: TCudaChannelFormatKind): TCudaChannelFormatDesc; stdcall;
cudaMalloc3D: function(var pitchedDevPtr: TcudaPitchedPtr; extent: TcudaExtent): cudaError_t; stdcall;
cudaMalloc3DArray: function(var arrayPtr: PcudaArray; const desc: TCudaChannelFormatDesc; extent: TcudaExtent; flags: Cardinal): cudaError_t; stdcall;
cudaMemset3D: function(pitchedDevPtr: TcudaPitchedPtr; value: Integer; extent: TcudaExtent): cudaError_t; stdcall;
cudaMemcpy3D: function(const p: TcudaMemcpy3DParms): cudaError_t; stdcall;
cudaMemcpy3DAsync: function(const p: TcudaMemcpy3DParms; stream: cudaStream_t): cudaError_t; stdcall;
cudaMalloc: function(var devPtr; size: NativeUInt): cudaError_t; stdcall;
cudaMallocHost: function(var ptr: Pointer; size: NativeUInt): cudaError_t; stdcall;
cudaMallocPitch: function(var devPtr; var pitch: NativeUInt; width: NativeUInt; height: NativeUInt): cudaError_t; stdcall;
cudaMallocArray: function(var aarray: Pointer; var desc: TCudaChannelFormatDesc; width: NativeUInt; height: NativeUInt): cudaError_t; stdcall;
cudaFree: function(devPtr: Pointer): cudaError_t; stdcall;
cudaFreeHost: function(ptr: Pointer): cudaError_t; stdcall;
cudaFreeArray: function(const aarray: Pointer): cudaError_t; stdcall;
cudaHostAlloc: function(var pHost: Pointer; bytes: NativeUInt; flags: Cardinal): cudaError_t; stdcall;
cudaHostGetDevicePointer: function(var pDevice: Pointer; pHost: Pointer; flags: Cardinal): cudaError_t; stdcall;
cudaHostGetFlags: function(var pFlags: Cardinal; pHost: Pointer): cudaError_t; stdcall;
cudaMemGetInfo: function(var free: NativeUInt; var total: NativeUInt): cudaError_t; stdcall;
cudaMemcpy: function(dst: Pointer; src: Pointer; count: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpyToArray: function(var dst: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; var src; count: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpyFromArray: function(var dst; const src: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; count: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpyArrayToArray: function(dst: PcudaArray; wOffsetDst: NativeUInt; hOffsetDst: NativeUInt; const src: PcudaArray; wOffsetSrc: NativeUInt; hOffsetSrc: NativeUInt; count: NativeUInt; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToDevice): cudaError_t; stdcall;
cudaMemcpy2D: function(var dst; dpitch: NativeUInt; var src; spitch: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DToArray: function(dst: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; var src; spitch: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DFromArray: function(var dst; dpitch: NativeUInt; src: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DArrayToArray: function(dst: PcudaArray; wOffsetDst: NativeUInt; hOffsetDst: NativeUInt; src: PcudaArray; wOffsetSrc: NativeUInt; hOffsetSrc: NativeUInt; width: NativeUInt; height: NativeUInt; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToDevice): cudaError_t; stdcall;
cudaMemcpyToSymbol: function(symbol: PAnsiChar; var src; count: NativeUInt; const offset: NativeUInt = 0; const kind: TcudaMemcpyKind = cudaMemcpyHostToDevice): cudaError_t; stdcall;
cudaMemcpyFromSymbol: function(var dst; symbol: PAnsiChar; count: NativeUInt; const offset: NativeUInt = 0; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToHost): cudaError_t; stdcall;
cudaMemcpyAsync: function(var dst; const src; count: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyToArrayAsync: function(dst: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; const src; count: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyFromArrayAsync: function(var dst; const src: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; count: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DAsync: function(var dst; dpitch: NativeUInt; const src; spitch: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DToArrayAsync: function(dst: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; const src; spitch: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DFromArrayAsync: function(var dst; dpitch: NativeUInt; const src: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyToSymbolAsync: function(const symbol: PAnsiChar; const src; count: NativeUInt; offset: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyFromSymbolAsync: function(var dst; const symbol: PAnsiChar; count: NativeUInt; offset: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemset: function(var devPtr; value: Integer; count: NativeUInt): cudaError_t; stdcall;
cudaMemset2D: function(var devPtr; pitch: NativeUInt; value: Integer; width: NativeUInt; height: NativeUInt): cudaError_t; stdcall;
cudaGetSymbolAddress: function(var devPtr: Pointer; const symbol: PAnsiChar): cudaError_t; stdcall;
cudaGetSymbolSize: function(var size: NativeUInt; const symbol: PAnsiChar): cudaError_t; stdcall;
cudaGetDeviceCount: function(var count: Integer): cudaError_t; stdcall;
cudaGetDeviceProperties: function(var prop: TCudaDeviceProp; device: Integer): cudaError_t; stdcall;
cudaChooseDevice: function(var device: Integer; const prop: PCudaDeviceProp): cudaError_t; stdcall;
cudaSetDevice: function(device: Integer): cudaError_t; stdcall;
cudaGetDevice: function(var device: Integer): cudaError_t; stdcall;
cudaSetDeviceFlags: function(flags: Integer): cudaError_t; stdcall;
cudaSetValidDevices: function(device_arr: PInteger; len: Integer): cudaError_t; stdcall;
cudaConfigureCall: function(gridDim, blockDim: TDim3; sharedMem: NativeUInt; stream: cudaStream_t): cudaError_t; stdcall;
cudaSetupArgument: function(const arg: Pointer; size: NativeUInt; offset: NativeUInt): cudaError_t; stdcall;
cudaFuncSetCacheConfig: function(const func: PAnsiChar; cacheConfig: TcudaFuncCache): cudaError_t; stdcall;
cudaLaunch: function(const entry: PAnsiChar): cudaError_t; stdcall;
cudaFuncGetAttributes: function(var attr: TcudaFuncAttributes; const func: PAnsiChar): cudaError_t; stdcall;
cudaGetLastError: function: cudaError_t; stdcall;
cudaGLSetGLDevice: function(device: Integer): cudaError_t; stdcall;
cudaGLRegisterBufferObject: function(bufObj: Cardinal): cudaError_t; stdcall;
cudaGraphicsGLRegisterImage: function(const resource: PCUgraphicsResource; image: Cardinal; target: Cardinal; flags: Cardinal): cudaError_t; stdcall;
cudaGraphicsGLRegisterBuffer: function(const resource: PCUgraphicsResource; buffer: Cardinal; flags: Cardinal): cudaError_t; stdcall;
cudaGLMapBufferObject: function(devPtr: Pointer; bufObj: Cardinal): cudaError_t; stdcall;
cudaGLUnmapBufferObject: function(bufObj: Cardinal): cudaError_t; stdcall;
cudaGLUnregisterBufferObject: function(bufObj: Cardinal): cudaError_t; stdcall;
cudaGLSetBufferObjectMapFlags: function(bufObj: Cardinal; flags: TCudaGLMapFlags): cudaError_t; stdcall;
cudaGLMapBufferObjectAsync: function(var devPtr: Pointer; bufObj: Cardinal; stream: cudaStream_t): cudaError_t; stdcall;
cudaGLUnmapBufferObjectAsync: function(bufObj: Cardinal; stream: cudaStream_t): cudaError_t; stdcall;
cudaGraphicsUnregisterResource: function(resource: PCUgraphicsResource): cudaError_t; stdcall;
cudaGraphicsResourceSetMapFlags: function(resource: PCUgraphicsResource; flags: Cardinal): cudaError_t; stdcall;
cudaGraphicsMapResources: function(count: Integer; const resources: PCUgraphicsResource; stream: cudaStream_t): cudaError_t; stdcall;
cudaGraphicsUnmapResources: function(count: Integer; const resources: PCUgraphicsResource; stream: cudaStream_t): cudaError_t; stdcall;
cudaGraphicsResourceGetMappedPointer: function(var pDevPtr: TCUdeviceptr; var pSize: Cardinal; resource: PCUgraphicsResource): cudaError_t; stdcall;
cudaGraphicsSubResourceGetMappedArray: function(var pArray: PCUarray; resource: PCUgraphicsResource; arrayIndex: Cardinal; mipLevel: Cardinal): cudaError_t; stdcall;
cudaGetErrorString: function(error: cudaError_t): PAnsiChar; stdcall;
cudaDriverGetVersion: function(out driverVersion: Integer): cudaError_t; stdcall;
cudaRuntimeGetVersion: function(out runtimeVersion: Integer): cudaError_t; stdcall;
cudaSetDoubleForDevice: function(var d: Double): cudaError_t; stdcall;
cudaSetDoubleForHost: function(var d: Double): cudaError_t; stdcall;
cudaStreamCreate: function(var pStream: cudaStream_t): cudaError_t; stdcall;
cudaStreamDestroy: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaStreamSynchronize: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaStreamQuery: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaEventCreate: function(var event: cudaEvent_t): cudaError_t; stdcall;
cudaEventCreateWithFlags: function(var event: cudaEvent_t; flags: Integer): cudaError_t; stdcall;
cudaEventRecord: function(event: cudaEvent_t; stream: cudaStream_t): cudaError_t; stdcall;
cudaEventQuery: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventSynchronize: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventDestroy: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventElapsedTime: function(var ms: Single; start: cudaEvent_t; ending: cudaEvent_t): cudaError_t; stdcall;
cudaWGLGetDevice: function(var device: Integer; hGpu: HGPUNV): cudaError_t; stdcall;
cudaThreadExit: function(): cudaError_t; stdcall;
cudaThreadSynchronize: function(): cudaError_t; stdcall;
cudaThreadSetLimit: function(limit: TcudaLimit; value: NativeUInt): cudaError_t; stdcall;
cudaThreadGetLimit: function(var value: NativeUInt; limit: TcudaLimit): cudaError_t; stdcall;

Description

Functions and Procedures

function cudaGetLastErrorString: string;

This item has no description.

function InitCUDART: Boolean;

This item has no description.

procedure CloseCUDART;

This item has no description.

function InitCUDARTFromLibrary(const LibName: WideString): Boolean;

This item has no description.

function IsCUDARTInitialized: Boolean;

This item has no description.

Types

cudaError_t = TcudaError;

+//DEVICE_BUILTIN*/

cudaEvent_t = Integer;

+//DEVICE_BUILTIN*/

cudaStream_t = Integer;

+//DEVICE_BUILTIN*/

PcudaArray = ˆTcudaArray;

This item has no description.

PcudaChannelFormatDesc = ˆTCudaChannelFormatDesc;

+//DEVICE_BUILTIN*/

PCudaDeviceProp = ˆTCudaDeviceProp;

+//DEVICE_BUILTIN*/

PTextureReference = ˆTTextureReference;

This item has no description.

TCudaChannelFormatKind = (...);

+//DEVICE_BUILTIN*/

Values
  • cudaChannelFormatKindSigned
  • cudaChannelFormatKindUnsigned
  • cudaChannelFormatKindFloat
TcudaError = (...);

This item has no description.

Values
  • cudaSuccess
  • cudaErrorMissingConfiguration
  • cudaErrorMemoryAllocation
  • cudaErrorInitializationError
  • cudaErrorLaunchFailure
  • cudaErrorPriorLaunchFailure
  • cudaErrorLaunchTimeout
  • cudaErrorLaunchOutOfResources
  • cudaErrorInvalidDeviceFunction
  • cudaErrorInvalidConfiguration
  • cudaErrorInvalidDevice
  • cudaErrorInvalidValue
  • cudaErrorInvalidPitchValue
  • cudaErrorInvalidSymbol
  • cudaErrorMapBufferObjectFailed
  • cudaErrorUnmapBufferObjectFailed
  • cudaErrorInvalidHostPointer
  • cudaErrorInvalidDevicePointer
  • cudaErrorInvalidTexture
  • cudaErrorInvalidTextureBinding
  • cudaErrorInvalidChannelDescriptor
  • cudaErrorInvalidMemcpyDirection
  • cudaErrorAddressOfConstant
  • cudaErrorTextureFetchFailed
  • cudaErrorTextureNotBound
  • cudaErrorSynchronizationError
  • cudaErrorInvalidFilterSetting
  • cudaErrorInvalidNormSetting
  • cudaErrorMixedDeviceExecution
  • cudaErrorCudartUnloading
  • cudaErrorUnknown
  • cudaErrorNotYetImplemented
  • cudaErrorMemoryValueTooLarge
  • cudaErrorInvalidResourceHandle
  • cudaErrorNotReady
  • cudaErrorStartupFailure
  • cudaErrorApiFailureBase
TCudaGLMapFlags = (...);

This item has no description.

Values
  • cudaGLMapFlagsNone
  • cudaGLMapFlagsReadOnly: < Default; Assume resource can be read/written
  • cudaGLMapFlagsWriteDiscard: < CUDA kernels will not write to this resource
TcudaMemcpyKind = (...);

+//DEVICE_BUILTIN*/

Values
  • cudaMemcpyHostToHost
  • cudaMemcpyHostToDevice: = 0
  • cudaMemcpyDeviceToHost
  • cudaMemcpyDeviceToDevice
TcudaTextureAddressMode = (...);

This item has no description.

Values
  • cudaAddressModeWrap
  • cudaAddressModeClamp
  • cudaAddressModeMirror
TcudaTextureFilterMode = (...);

This item has no description.

Values
  • cudaFilterModePoint
  • cudaFilterModeLinear
TcudaTextureReadMode = (...);

This item has no description.

Values
  • cudaReadModeElementType
  • cudaReadModeNormalizedFloat

Constants

CUDARTDLLNAMES: array [0 .. 9] of string = ( 'cudart32_42_9', 'cudart32_41_28', 'cudart32_40_10', 'cudart32_32_16', 'cudart32_31_4', 'cudart32_30_14', 'cudart32_30_9', 'cudart32_30_8', 'cudart32', 'cudart');

This item has no description.

CUDART_INF_F: Single = $7F800000;

single precision constants

CUDART_NAN_F: Single = $7FFFFFFF;

This item has no description.

CUDART_MIN_DENORM_F: Single = $00000001;

This item has no description.

CUDART_MAX_NORMAL_F: Single = $7F7FFFFF;

This item has no description.

CUDART_NEG_ZERO_F: Single = $80000000;

This item has no description.

CUDART_ZERO_F = 0.0;

This item has no description.

CUDART_ONE_F = 1.0;

This item has no description.

CUDART_SQRT_HALF_F = 0.707106781;

This item has no description.

CUDART_SQRT_TWO_F = 1.414213562;

This item has no description.

CUDART_THIRD_F = 0.333333333;

This item has no description.

CUDART_PIO4_F = 0.785398163;

This item has no description.

CUDART_PIO2_F = 1.570796327;

This item has no description.

CUDART_3PIO4_F = 2.356194490;

This item has no description.

CUDART_2_OVER_PI_F = 0.636619772;

This item has no description.

CUDART_PI_F = 3.141592654;

This item has no description.

CUDART_L2E_F = 1.442695041;

This item has no description.

CUDART_L2T_F = 3.321928094;

This item has no description.

CUDART_LG2_F = 0.301029996;

This item has no description.

CUDART_LGE_F = 0.434294482;

This item has no description.

CUDART_LN2_F = 0.693147181;

This item has no description.

CUDART_LNT_F = 2.302585093;

This item has no description.

CUDART_LNPI_F = 1.144729886;

This item has no description.

CUDART_TWO_TO_M126_F = 1.175494351E-38;

This item has no description.

CUDART_TWO_TO_126_F = 8.507059173E37;

This item has no description.

CUDART_NORM_HUGE_F = 3.402823466E38;

This item has no description.

CUDART_TWO_TO_23_F = 8388608.0;

This item has no description.

CUDART_TWO_TO_24_F = 16777216.0;

This item has no description.

CUDART_TWO_TO_31_F = 2147483648.0;

This item has no description.

CUDART_TWO_TO_32_F = 4294967296.0;

This item has no description.

CUDART_REMQUO_BITS_F = 3;

This item has no description.

CUDART_REMQUO_MASK_F = CUDART_REMQUO_BITS_F;

This item has no description.

CUDART_TRIG_PLOSS_F = 48039.0;

This item has no description.

CUDART_INF: Double = $7FF0000000000000;

double precision constants */

CUDART_NAN: Double = $FFF8000000000000;

This item has no description.

CUDART_NEG_ZERO: Double = $8000000000000000;

This item has no description.

CUDART_MIN_DENORM: Double = $0000000000000001;

This item has no description.

CUDART_ZERO = 0.0;

This item has no description.

CUDART_ONE = 1.0;

This item has no description.

CUDART_SQRT_TWO = 1.4142135623730951E+0;

This item has no description.

CUDART_SQRT_HALF = 7.0710678118654757E-1;

This item has no description.

CUDART_THIRD = 3.3333333333333333E-1;

This item has no description.

CUDART_TWOTHIRD = 6.6666666666666667E-1;

This item has no description.

CUDART_PIO4 = 7.8539816339744828E-1;

This item has no description.

CUDART_PIO4_HI = 7.8539816339744828E-1;

This item has no description.

CUDART_PIO4_LO = 3.0616169978683830E-17;

This item has no description.

CUDART_PIO2 = 1.5707963267948966E+0;

This item has no description.

CUDART_PIO2_HI = 1.5707963267948966E+0;

This item has no description.

CUDART_PIO2_LO = 6.1232339957367660E-17;

This item has no description.

CUDART_3PIO4 = 2.3561944901923448E+0;

This item has no description.

CUDART_2_OVER_PI = 6.3661977236758138E-1;

This item has no description.

CUDART_PI = 3.1415926535897931E+0;

This item has no description.

CUDART_PI_HI = 3.1415926535897931E+0;

This item has no description.

CUDART_PI_LO = 1.2246467991473532E-16;

This item has no description.

CUDART_SQRT_2PI_HI = 2.5066282746310007E+0;

This item has no description.

CUDART_SQRT_2PI_LO = -1.8328579980459167E-16;

This item has no description.

CUDART_SQRT_PIO2_HI = 1.2533141373155003E+0;

This item has no description.

CUDART_SQRT_PIO2_LO = -9.1642899902295834E-17;

This item has no description.

CUDART_L2E = 1.4426950408889634E+0;

This item has no description.

CUDART_L2E_HI = 1.4426950408889634E+0;

This item has no description.

CUDART_L2E_LO = 2.0355273740931033E-17;

This item has no description.

CUDART_L2T = 3.3219280948873622E+0;

This item has no description.

CUDART_LG2 = 3.0102999566398120E-1;

This item has no description.

CUDART_LG2_HI = 3.0102999566398120E-1;

This item has no description.

CUDART_LG2_LO = -2.8037281277851704E-18;

This item has no description.

CUDART_LGE = 4.3429448190325182E-1;

This item has no description.

CUDART_LGE_HI = 4.3429448190325182E-1;

This item has no description.

CUDART_LGE_LO = 1.09831965021676510E-17;

This item has no description.

CUDART_LN2 = 6.9314718055994529E-1;

This item has no description.

CUDART_LN2_HI = 6.9314718055994529E-1;

This item has no description.

CUDART_LN2_LO = 2.3190468138462996E-17;

This item has no description.

CUDART_LNT = 2.3025850929940459E+0;

This item has no description.

CUDART_LNT_HI = 2.3025850929940459E+0;

This item has no description.

CUDART_LNT_LO = -2.1707562233822494E-16;

This item has no description.

CUDART_LNPI = 1.1447298858494002E+0;

This item has no description.

CUDART_LN2_X_1024 = 7.0978271289338397E+2;

This item has no description.

CUDART_LN2_X_1025 = 7.1047586007394398E+2;

This item has no description.

CUDART_LN2_X_1075 = 7.4513321910194122E+2;

This item has no description.

CUDART_LG2_X_1024 = 3.0825471555991675E+2;

This item has no description.

CUDART_LG2_X_1075 = 3.2360724533877976E+2;

This item has no description.

CUDART_TWO_TO_23 = 8388608.0;

This item has no description.

CUDART_TWO_TO_52 = 4503599627370496.0;

This item has no description.

CUDART_TWO_TO_54 = 18014398509481984.0;

This item has no description.

CUDART_TWO_TO_M54 = 5.5511151231257827E-17;

This item has no description.

CUDART_TWO_TO_M1022 = 2.22507385850720140E-308;

This item has no description.

CUDART_TRIG_PLOSS = 2147483648.0;

This item has no description.

Variables

cudaBindTexture: function(var offset: NativeUInt; const texref: PTextureReference; var devPtr: Pointer; var desc: TCudaChannelFormatDesc; size: NativeUInt): cudaError_t; stdcall;

*****************************************************************************

cudaBindTexture2D: function(var offset: NativeUInt; const texref: PTextureReference; const devPtr: Pointer; var desc: TCudaChannelFormatDesc; width, height, pitch: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaBindTextureToArray: function(const texref: PTextureReference; const cudaArray: PcudaArray): cudaError_t; stdcall;

This item has no description.

cudaUnbindTexture: function(const texref: PTextureReference): cudaError_t; stdcall;

This item has no description.

cudaGetTextureAlignmentOffset: function(offset: NativeUInt; const texref: PTextureReference): cudaError_t; stdcall;

This item has no description.

cudaGetTextureReference: function(const texref: PTextureReference; const symbol: PAnsiChar): cudaError_t; stdcall;

This item has no description.

cudaGetChannelDesc: function(var desc: TCudaChannelFormatDesc; const array_: Pointer): cudaError_t; stdcall;

This item has no description.

cudaCreateChannelDesc: function(x, y, z, w: Integer; f: TCudaChannelFormatKind): TCudaChannelFormatDesc; stdcall;

This item has no description.

cudaMalloc3D: function(var pitchedDevPtr: TcudaPitchedPtr; extent: TcudaExtent): cudaError_t; stdcall;

****************************************************************************** * * * * * * ******************************************************************************

cudaMalloc3DArray: function(var arrayPtr: PcudaArray; const desc: TCudaChannelFormatDesc; extent: TcudaExtent; flags: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaMemset3D: function(pitchedDevPtr: TcudaPitchedPtr; value: Integer; extent: TcudaExtent): cudaError_t; stdcall;

This item has no description.

cudaMemcpy3D: function(const p: TcudaMemcpy3DParms): cudaError_t; stdcall;

This item has no description.

cudaMemcpy3DAsync: function(const p: TcudaMemcpy3DParms; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaMalloc: function(var devPtr; size: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaMallocHost: function(var ptr: Pointer; size: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaMallocPitch: function(var devPtr; var pitch: NativeUInt; width: NativeUInt; height: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaMallocArray: function(var aarray: Pointer; var desc: TCudaChannelFormatDesc; width: NativeUInt; height: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaFree: function(devPtr: Pointer): cudaError_t; stdcall;

This item has no description.

cudaFreeHost: function(ptr: Pointer): cudaError_t; stdcall;

This item has no description.

cudaFreeArray: function(const aarray: Pointer): cudaError_t; stdcall;

This item has no description.

cudaHostAlloc: function(var pHost: Pointer; bytes: NativeUInt; flags: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaHostGetDevicePointer: function(var pDevice: Pointer; pHost: Pointer; flags: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaHostGetFlags: function(var pFlags: Cardinal; pHost: Pointer): cudaError_t; stdcall;

This item has no description.

cudaMemGetInfo: function(var free: NativeUInt; var total: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaMemcpy: function(dst: Pointer; src: Pointer; count: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;

This item has no description.

cudaMemcpyToArray: function(var dst: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; var src; count: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;

This item has no description.

cudaMemcpyFromArray: function(var dst; const src: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; count: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;

This item has no description.

cudaMemcpyArrayToArray: function(dst: PcudaArray; wOffsetDst: NativeUInt; hOffsetDst: NativeUInt; const src: PcudaArray; wOffsetSrc: NativeUInt; hOffsetSrc: NativeUInt; count: NativeUInt; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToDevice): cudaError_t; stdcall;

This item has no description.

cudaMemcpy2D: function(var dst; dpitch: NativeUInt; var src; spitch: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;

This item has no description.

cudaMemcpy2DToArray: function(dst: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; var src; spitch: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;

This item has no description.

cudaMemcpy2DFromArray: function(var dst; dpitch: NativeUInt; src: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind): cudaError_t; stdcall;

This item has no description.

cudaMemcpy2DArrayToArray: function(dst: PcudaArray; wOffsetDst: NativeUInt; hOffsetDst: NativeUInt; src: PcudaArray; wOffsetSrc: NativeUInt; hOffsetSrc: NativeUInt; width: NativeUInt; height: NativeUInt; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToDevice): cudaError_t; stdcall;

This item has no description.

cudaMemcpyToSymbol: function(symbol: PAnsiChar; var src; count: NativeUInt; const offset: NativeUInt = 0; const kind: TcudaMemcpyKind = cudaMemcpyHostToDevice): cudaError_t; stdcall;

This item has no description.

cudaMemcpyFromSymbol: function(var dst; symbol: PAnsiChar; count: NativeUInt; const offset: NativeUInt = 0; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToHost): cudaError_t; stdcall;

This item has no description.

cudaMemcpyAsync: function(var dst; const src; count: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;

=*****************************************************************************

cudaMemcpyToArrayAsync: function(dst: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; const src; count: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaMemcpyFromArrayAsync: function(var dst; const src: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; count: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaMemcpy2DAsync: function(var dst; dpitch: NativeUInt; const src; spitch: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaMemcpy2DToArrayAsync: function(dst: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; const src; spitch: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaMemcpy2DFromArrayAsync: function(var dst; dpitch: NativeUInt; const src: PcudaArray; wOffset: NativeUInt; hOffset: NativeUInt; width: NativeUInt; height: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaMemcpyToSymbolAsync: function(const symbol: PAnsiChar; const src; count: NativeUInt; offset: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaMemcpyFromSymbolAsync: function(var dst; const symbol: PAnsiChar; count: NativeUInt; offset: NativeUInt; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaMemset: function(var devPtr; value: Integer; count: NativeUInt): cudaError_t; stdcall;

***************************************************************************** * * * * * * ****************************************************************************

cudaMemset2D: function(var devPtr; pitch: NativeUInt; value: Integer; width: NativeUInt; height: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaGetSymbolAddress: function(var devPtr: Pointer; const symbol: PAnsiChar): cudaError_t; stdcall;

**************************************************************************** * * * * * * ****************************************************************************

cudaGetSymbolSize: function(var size: NativeUInt; const symbol: PAnsiChar): cudaError_t; stdcall;

This item has no description.

cudaGetDeviceCount: function(var count: Integer): cudaError_t; stdcall;

=*****************************************************************************

cudaGetDeviceProperties: function(var prop: TCudaDeviceProp; device: Integer): cudaError_t; stdcall;

This item has no description.

cudaChooseDevice: function(var device: Integer; const prop: PCudaDeviceProp): cudaError_t; stdcall;

This item has no description.

cudaSetDevice: function(device: Integer): cudaError_t; stdcall;

This item has no description.

cudaGetDevice: function(var device: Integer): cudaError_t; stdcall;

This item has no description.

cudaSetDeviceFlags: function(flags: Integer): cudaError_t; stdcall;

This item has no description.

cudaSetValidDevices: function(device_arr: PInteger; len: Integer): cudaError_t; stdcall;

This item has no description.

cudaConfigureCall: function(gridDim, blockDim: TDim3; sharedMem: NativeUInt; stream: cudaStream_t): cudaError_t; stdcall;

***************************************************************************** * * * ****************************************************************************

cudaSetupArgument: function(const arg: Pointer; size: NativeUInt; offset: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaFuncSetCacheConfig: function(const func: PAnsiChar; cacheConfig: TcudaFuncCache): cudaError_t; stdcall;

This item has no description.

cudaLaunch: function(const entry: PAnsiChar): cudaError_t; stdcall;

This item has no description.

cudaFuncGetAttributes: function(var attr: TcudaFuncAttributes; const func: PAnsiChar): cudaError_t; stdcall;

This item has no description.

cudaGetLastError: function: cudaError_t; stdcall;

=*******************************************************************************/

cudaGLSetGLDevice: function(device: Integer): cudaError_t; stdcall;

=*******************************************************************************/

cudaGLRegisterBufferObject: function(bufObj: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaGraphicsGLRegisterImage: function(const resource: PCUgraphicsResource; image: Cardinal; target: Cardinal; flags: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaGraphicsGLRegisterBuffer: function(const resource: PCUgraphicsResource; buffer: Cardinal; flags: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaGLMapBufferObject: function(devPtr: Pointer; bufObj: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaGLUnmapBufferObject: function(bufObj: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaGLUnregisterBufferObject: function(bufObj: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaGLSetBufferObjectMapFlags: function(bufObj: Cardinal; flags: TCudaGLMapFlags): cudaError_t; stdcall;

This item has no description.

cudaGLMapBufferObjectAsync: function(var devPtr: Pointer; bufObj: Cardinal; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaGLUnmapBufferObjectAsync: function(bufObj: Cardinal; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaGraphicsUnregisterResource: function(resource: PCUgraphicsResource): cudaError_t; stdcall;

This item has no description.

cudaGraphicsResourceSetMapFlags: function(resource: PCUgraphicsResource; flags: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaGraphicsMapResources: function(count: Integer; const resources: PCUgraphicsResource; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaGraphicsUnmapResources: function(count: Integer; const resources: PCUgraphicsResource; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaGraphicsResourceGetMappedPointer: function(var pDevPtr: TCUdeviceptr; var pSize: Cardinal; resource: PCUgraphicsResource): cudaError_t; stdcall;

This item has no description.

cudaGraphicsSubResourceGetMappedArray: function(var pArray: PCUarray; resource: PCUgraphicsResource; arrayIndex: Cardinal; mipLevel: Cardinal): cudaError_t; stdcall;

This item has no description.

cudaGetErrorString: function(error: cudaError_t): PAnsiChar; stdcall;

This item has no description.

cudaDriverGetVersion: function(out driverVersion: Integer): cudaError_t; stdcall;

This item has no description.

cudaRuntimeGetVersion: function(out runtimeVersion: Integer): cudaError_t; stdcall;

This item has no description.

cudaSetDoubleForDevice: function(var d: Double): cudaError_t; stdcall;

****************************************************************************** * * * * * * ******************************************************************************

cudaSetDoubleForHost: function(var d: Double): cudaError_t; stdcall;

This item has no description.

cudaStreamCreate: function(var pStream: cudaStream_t): cudaError_t; stdcall;

****************************************************************************** * * * * * * ******************************************************************************

cudaStreamDestroy: function(stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaStreamSynchronize: function(stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaStreamQuery: function(stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaEventCreate: function(var event: cudaEvent_t): cudaError_t; stdcall;

****************************************************************************** * * * * * * ******************************************************************************

cudaEventCreateWithFlags: function(var event: cudaEvent_t; flags: Integer): cudaError_t; stdcall;

This item has no description.

cudaEventRecord: function(event: cudaEvent_t; stream: cudaStream_t): cudaError_t; stdcall;

This item has no description.

cudaEventQuery: function(event: cudaEvent_t): cudaError_t; stdcall;

This item has no description.

cudaEventSynchronize: function(event: cudaEvent_t): cudaError_t; stdcall;

This item has no description.

cudaEventDestroy: function(event: cudaEvent_t): cudaError_t; stdcall;

This item has no description.

cudaEventElapsedTime: function(var ms: Single; start: cudaEvent_t; ending: cudaEvent_t): cudaError_t; stdcall;

This item has no description.

cudaWGLGetDevice: function(var device: Integer; hGpu: HGPUNV): cudaError_t; stdcall;

This item has no description.

cudaThreadExit: function(): cudaError_t; stdcall;

****************************************************************************** * * * * * * ******************************************************************************

cudaThreadSynchronize: function(): cudaError_t; stdcall;

This item has no description.

cudaThreadSetLimit: function(limit: TcudaLimit; value: NativeUInt): cudaError_t; stdcall;

This item has no description.

cudaThreadGetLimit: function(var value: NativeUInt; limit: TcudaLimit): cudaError_t; stdcall;


GLSysHelp v.2.5: CUDA.Runtime: Record TCudaChannelFormatDesc

Record TCudaChannelFormatDesc

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Runtime

Declaration

type TCudaChannelFormatDesc = record

Description

This item has no description.

Overview

Fields

Public | x: Integer;
Public | y: Integer;
Public | z: Integer;
Public | w: Integer;
Public | f: TCudaChannelFormatKind;

Description

Fields

Public x: Integer;

This item has no description.

Public y: Integer;

This item has no description.

Public z: Integer;

This item has no description.

Public w: Integer;

This item has no description.

Public f: TCudaChannelFormatKind;


GLSysHelp v.2.5: CUDA.Runtime: Record TcudaArray

Record TcudaArray

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Runtime

Declaration

type TcudaArray = record

Description

+//DEVICE_BUILTIN*/


GLSysHelp v.2.5: CUDA.Runtime: Record TcudaPitchedPtr

Record TcudaPitchedPtr

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Runtime

Declaration

type TcudaPitchedPtr = record

Description

+//DEVICE_BUILTIN*/

Overview

Fields

Public | ptr: Pointer;
Public | pitch: NativeUInt;
Public | xsize: NativeUInt;
Public | ysize: NativeUInt;

Description

Fields

Public ptr: Pointer;

This item has no description.

Public pitch: NativeUInt;

This item has no description.

Public xsize: NativeUInt;

This item has no description.

Public ysize: NativeUInt;


GLSysHelp v.2.5: CUDA.Runtime: Record TcudaExtent

Record TcudaExtent

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Runtime

Declaration

type TcudaExtent = record

Description

+//DEVICE_BUILTIN*/

Overview

Fields

Public | width: NativeUInt;
Public | height: NativeUInt;
Public | depth: NativeUInt;

Description

Fields

Public width: NativeUInt;

This item has no description.

Public height: NativeUInt;

This item has no description.

Public depth: NativeUInt;


GLSysHelp v.2.5: CUDA.Runtime: Record TcudaPos

Record TcudaPos

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Runtime

Declaration

type TcudaPos = record

Description

+//DEVICE_BUILTIN*/

Overview

Fields

Public | x: NativeUInt;
Public | y: NativeUInt;
Public | z: NativeUInt;

Description

Fields

Public x: NativeUInt;

This item has no description.

Public y: NativeUInt;

This item has no description.

Public z: NativeUInt;


GLSysHelp v.2.5: CUDA.Runtime: Record TcudaMemcpy3DParms

Record TcudaMemcpy3DParms

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Runtime

Declaration

type TcudaMemcpy3DParms = record

Description

+//DEVICE_BUILTIN*/

Overview

Fields

Public | srcArray: Pointer;
Public | srcPos: TcudaPos;
Public | srcPtr: TcudaPitchedPtr;
Public | dstArray: Pointer;
Public | dstPos: TcudaPos;
Public | dstPtr: TcudaPitchedPtr;
Public | extent: TcudaExtent;
Public | kind: TcudaMemcpyKind;

Description

Fields

Public srcArray: Pointer;

This item has no description.

Public srcPos: TcudaPos;

This item has no description.

Public srcPtr: TcudaPitchedPtr;

This item has no description.

Public dstArray: Pointer;

This item has no description.

Public dstPos: TcudaPos;

This item has no description.

Public dstPtr: TcudaPitchedPtr;

This item has no description.

Public extent: TcudaExtent;

This item has no description.

Public kind: TcudaMemcpyKind;


GLSysHelp v.2.5: CUDA.Runtime: Record TCudaDeviceProp

Record TCudaDeviceProp

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Runtime

Declaration

type TCudaDeviceProp = record

Description

This item has no description.

Overview

Fields

Public | name: array [0 .. 256 - 1] of AnsiChar;
Public | totalGlobalMem: NativeUInt;
Public | sharedMemPerBlock: NativeUInt;
Public | regsPerBlock: Integer;
Public | warpSize: Integer;
Public | memPitch: NativeUInt;
Public | maxThreadsPerBlock: Integer;
Public | maxThreadsDim: array [0 .. 3 - 1] of Integer;
Public | maxGridSize: array [0 .. 3 - 1] of Integer;
Public | clockRate: Integer;
Public | totalConstMem: NativeUInt;
Public | major: Integer;
Public | minor: Integer;
Public | textureAlignment: NativeUInt;
Public | deviceOverlap: Integer;
Public | multiProcessorCount: Integer;
Public | kernelExecTimeoutEnabled: Integer;
Public | egrated: Integer;
Public | canMapHostMemory: Integer;
Public | computeMode: Integer;
Public | maxTexture1D: Integer;
Public | maxTexture2D: array[0..1] of Integer;
Public | maxTexture3D: array[0..2] of Integer;
Public | maxTexture2DArray: array[0..2] of Integer;
Public | surfaceAlignment: NativeUInt;
Public | concurrentKernels: Integer;
Public | ECCEnabled: Integer;
Public | pciBusID: Integer;
Public | pciDeviceID: Integer;
Public | tccDriver: Integer;
Public | __cudaReserved: array [0 .. 20] of Integer;

Description

Fields

Public name: array [0 .. 256 - 1] of AnsiChar;

This item has no description.

Public totalGlobalMem: NativeUInt;

This item has no description.

Public sharedMemPerBlock: NativeUInt;

This item has no description.

Public regsPerBlock: Integer;

This item has no description.

Public warpSize: Integer;

This item has no description.

Public memPitch: NativeUInt;

This item has no description.

Public maxThreadsPerBlock: Integer;

This item has no description.

Public maxThreadsDim: array [0 .. 3 - 1] of Integer;

This item has no description.

Public maxGridSize: array [0 .. 3 - 1] of Integer;

This item has no description.

Public clockRate: Integer;

This item has no description.

Public totalConstMem: NativeUInt;

This item has no description.

Public major: Integer;

This item has no description.

Public minor: Integer;

This item has no description.

Public textureAlignment: NativeUInt;

This item has no description.

Public deviceOverlap: Integer;

This item has no description.

Public multiProcessorCount: Integer;

This item has no description.

Public kernelExecTimeoutEnabled: Integer;

Specified whether there is a run time limit on kernels

Public egrated: Integer;

Device is egrated as opposed to discrete

Public canMapHostMemory: Integer;

Device can map host memory with cudaHostAlloc/cudaHostGetDevicePoer

Public computeMode: Integer;

Compute mode (See ::cudaComputeMode)

Public maxTexture1D: Integer;

Maximum 1D texture size

Public maxTexture2D: array[0..1] of Integer;

Maximum 2D texture dimensions

Public maxTexture3D: array[0..2] of Integer;

Maximum 3D texture dimensions

Public maxTexture2DArray: array[0..2] of Integer;

Maximum 2D texture array dimensions

Public surfaceAlignment: NativeUInt;

Alignment requirements for surfaces

Public concurrentKernels: Integer;

Device can possibly execute multiple kernels concurrently

Public ECCEnabled: Integer;

Device has ECC support enabled

Public pciBusID: Integer;

PCI bus ID of the device

Public pciDeviceID: Integer;

PCI device ID of the device

Public tccDriver: Integer;

1 if device is a Tesla device using TCC driver, 0 otherwise

Public __cudaReserved: array [0 .. 20] of Integer;


GLSysHelp v.2.5: CUDA.Runtime: Record TTextureReference

Record TTextureReference

Description
Hierarchy
Fields
Methods
Properties

Unit

CUDA.Runtime

Declaration

type TTextureReference = record

Description

This item has no description.

Overview

Fields

Public | normalized: Integer;
Public | filterMode: TcudaTextureFilterMode;
Public | addressMode: array [0 .. 2] of TcudaTextureAddressMode;
Public | channelDesc: TCudaChannelFormatDesc;
Public | __cudaReserved: array [0 .. 15] of Integer;

Description

Fields

Public normalized: Integer;

This item has no description.

Public filterMode: TcudaTextureFilterMode;

This item has no description.

Public addressMode: array [0 .. 2] of TcudaTextureAddressMode;

This item has no description.

Public channelDesc: TCudaChannelFormatDesc;

This item has no description.

Public __cudaReserved: array [0 .. 15] of Integer;


GLSysHelp v.2.5: CUDA.Utility

Unit CUDA.Utility

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows

Overview

Functions and Procedures

function InitCUTIL: Boolean;
procedure CloseCUTIL;
function InitCUTILFromLibrary(const LibName: WideString): Boolean;
function IsCUTILInitialized: Boolean;

Constants

CUTILDLL = 'cutil32.dll';

Variables

cutFindFilePath: function(const filename: PAnsiChar; const executablePath: PAnsiChar): PAnsiChar; stdcall;
cutLoadPGMf: function(const filename: PAnsiChar; var data: System.PSingle; var w: Integer; var h: Integer): Boolean; stdcall;
cutSavePGMf: function(const filename: PAnsiChar; data: System.PSingle; w: Integer; h: Integer): Boolean; stdcall;
cutLoadPGMub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPPMub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPPM4ub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPGMi: function(const filename: PAnsiChar; var data: PInteger; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPGMs: function(const filename: PAnsiChar; var data: PWord; var w: Integer; var h: Integer): Boolean; stdcall;
cutSavePGMub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePPMub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePPM4ub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePGMi: function(const filename: PAnsiChar; data: PInteger; w: Integer; h: Integer): Boolean; stdcall;
cutSavePGMs: function(const filename: PAnsiChar; data: PWord; w: Integer; h: Integer): Boolean; stdcall;
cutComparef: function(const reference: PSingle; const data: PSingle; const len: Cardinal): Boolean; stdcall;
cutComparei: function(const reference: PInteger; const data: PInteger; const len: Cardinal): Boolean; stdcall;
cutCompareuit: function(const reference: PInteger; const data: PInteger; const len: Cardinal; const epsilon: Single; const threshold: Single): Boolean; stdcall;
cutCompareub: function(const reference: PByte; const data: PByte; const len: Cardinal): Boolean; stdcall;
cutCompareubt: function(const reference: PByte; const data: PByte; const len: Cardinal; const epsilon: Single; const threshold: Single): Boolean; stdcall;
cutCompareube: function(const reference: PByte; const data: PByte; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutComparefe: function(const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutComparefet: function(const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single; const threshold: Single): Boolean; stdcall;
cutCompareL2fe: function(const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutCreateTimer: function(var name: Cardinal): Boolean; stdcall;
cutStartTimer: function(const name: Cardinal): Boolean; stdcall;
cutStopTimer: function(const name: Cardinal): Boolean; stdcall;
cutResetTimer: function(const name: Cardinal): Boolean; stdcall;
cutDeleteTimer: function(const name: Cardinal): Boolean; stdcall;
cutGetTimerValue: function(const name: Cardinal): Single; stdcall;
cutGetAverageTimerValue: function(const name: Cardinal): Single; stdcall;
cutFree: procedure(ptr: Pointer); stdcall;

Description

Functions and Procedures

function InitCUTIL: Boolean;

This item has no description.

procedure CloseCUTIL;

This item has no description.

function InitCUTILFromLibrary(const LibName: WideString): Boolean;

This item has no description.

function IsCUTILInitialized: Boolean;

This item has no description.

Constants

CUTILDLL = 'cutil32.dll';

This item has no description.

Variables

cutFindFilePath: function(const filename: PAnsiChar; const executablePath: PAnsiChar): PAnsiChar; stdcall;

This item has no description.

cutLoadPGMf: function(const filename: PAnsiChar; var data: System.PSingle; var w: Integer; var h: Integer): Boolean; stdcall;

This item has no description.

cutSavePGMf: function(const filename: PAnsiChar; data: System.PSingle; w: Integer; h: Integer): Boolean; stdcall;

This item has no description.

cutLoadPGMub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;

This item has no description.

cutLoadPPMub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;

This item has no description.

cutLoadPPM4ub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;

This item has no description.

cutLoadPGMi: function(const filename: PAnsiChar; var data: PInteger; var w: Integer; var h: Integer): Boolean; stdcall;

This item has no description.

cutLoadPGMs: function(const filename: PAnsiChar; var data: PWord; var w: Integer; var h: Integer): Boolean; stdcall;

This item has no description.

cutSavePGMub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;

This item has no description.

cutSavePPMub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;

This item has no description.

cutSavePPM4ub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;

This item has no description.

cutSavePGMi: function(const filename: PAnsiChar; data: PInteger; w: Integer; h: Integer): Boolean; stdcall;

This item has no description.

cutSavePGMs: function(const filename: PAnsiChar; data: PWord; w: Integer; h: Integer): Boolean; stdcall;

This item has no description.

cutComparef: function(const reference: PSingle; const data: PSingle; const len: Cardinal): Boolean; stdcall;

This item has no description.

cutComparei: function(const reference: PInteger; const data: PInteger; const len: Cardinal): Boolean; stdcall;

This item has no description.

cutCompareuit: function(const reference: PInteger; const data: PInteger; const len: Cardinal; const epsilon: Single; const threshold: Single): Boolean; stdcall;

This item has no description.

cutCompareub: function(const reference: PByte; const data: PByte; const len: Cardinal): Boolean; stdcall;

This item has no description.

cutCompareubt: function(const reference: PByte; const data: PByte; const len: Cardinal; const epsilon: Single; const threshold: Single): Boolean; stdcall;

This item has no description.

cutCompareube: function(const reference: PByte; const data: PByte; const len: Cardinal; const epsilon: Single): Boolean; stdcall;

This item has no description.

cutComparefe: function(const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single): Boolean; stdcall;

This item has no description.

cutComparefet: function(const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single; const threshold: Single): Boolean; stdcall;

This item has no description.

cutCompareL2fe: function(const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single): Boolean; stdcall;

This item has no description.

cutCreateTimer: function(var name: Cardinal): Boolean; stdcall;

This item has no description.

cutStartTimer: function(const name: Cardinal): Boolean; stdcall;

This item has no description.

cutStopTimer: function(const name: Cardinal): Boolean; stdcall;

This item has no description.

cutResetTimer: function(const name: Cardinal): Boolean; stdcall;

This item has no description.

cutDeleteTimer: function(const name: Cardinal): Boolean; stdcall;

This item has no description.

cutGetTimerValue: function(const name: Cardinal): Single; stdcall;

This item has no description.

cutGetAverageTimerValue: function(const name: Cardinal): Single; stdcall;

This item has no description.

cutFree: procedure(ptr: Pointer); stdcall;


GLSysHelp v.2.5: FmCUDAEditor

Unit FmCUDAEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.SysUtils
  • System.Variants
  • System.Classes
  • System.Win.Registry
  • System.ImageList
  • Vcl.Graphics
  • Vcl.Controls
  • Vcl.Forms
  • Vcl.Dialogs
  • Vcl.ImgList
  • Vcl.StdCtrls
  • Vcl.ComCtrls
  • Vcl.ToolWin
  • DesignIntf
  • VCLEditors
  • GLScene.Strings
  • GLS.CUDA.APIComps
  • GLS.CUDA.FFTPlan
  • GLS.CUDA.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCUDAEditorForm |

Functions and Procedures

function GLCUDAEditorForm: TGLCUDAEditorForm;
procedure ReleaseGLCUDAEditorForm;

Description

Functions and Procedures

function GLCUDAEditorForm: TGLCUDAEditorForm;

This item has no description.

procedure ReleaseGLCUDAEditorForm;


GLSysHelp v.2.5: FmCUDAEditor: Class TGLCUDAEditorForm

Class TGLCUDAEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmCUDAEditor

Declaration

type TGLCUDAEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLCUDAEditorForm

Overview

Fields

Public | ToolBar1: TToolBar;
Public | AddModuleButton: TToolButton;
Public | DeleteButton: TToolButton;
Public | ListBox1: TListBox;
Public | ImageList1: TImageList;
Public | AddMemDataButton: TToolButton;
Public | AddFFTPlanButton: TToolButton;
Public | AddGeometryResButton: TToolButton;
Public | AddImageResButton: TToolButton;
Private | FClassList: TList;
Private | FCUDA: TGLCUDA;
Private | FCurrentDesigner: IDesigner;

Methods

Public | procedure AddItemButtonClick(Sender: TObject);
Public | procedure DeleteButtonClick(Sender: TObject);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormDestroy(Sender: TObject);
Public | procedure ListBox1Click(Sender: TObject);
Public | procedure SetCUDAEditorClient(Client: TGLCUDA; Designer: IDesigner);

Description

Fields

Public ToolBar1: TToolBar;

This item has no description.

Public AddModuleButton: TToolButton;

This item has no description.

Public DeleteButton: TToolButton;

This item has no description.

Public ListBox1: TListBox;

This item has no description.

Public ImageList1: TImageList;

This item has no description.

Public AddMemDataButton: TToolButton;

This item has no description.

Public AddFFTPlanButton: TToolButton;

This item has no description.

Public AddGeometryResButton: TToolButton;

This item has no description.

Public AddImageResButton: TToolButton;

This item has no description.

Private FClassList: TList;

This item has no description.

Private FCUDA: TGLCUDA;

This item has no description.

Private FCurrentDesigner: IDesigner;

This item has no description.

Methods

Public procedure AddItemButtonClick(Sender: TObject);

This item has no description.

Public procedure DeleteButtonClick(Sender: TObject);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure ListBox1Click(Sender: TObject);

This item has no description.

Public procedure SetCUDAEditorClient(Client: TGLCUDA; Designer: IDesigner);


GLSysHelp v.2.5: FmGuiLayoutEditor

Unit FmGuiLayoutEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.ShellApi
  • System.SysUtils
  • System.Variants
  • System.Classes
  • Vcl.Graphics
  • Vcl.Controls
  • Vcl.Forms
  • Vcl.Dialogs
  • Vcl.Buttons
  • Vcl.ExtDlgs
  • Vcl.StdCtrls
  • Vcl.ExtCtrls
  • Vcl.Samples.Spin
  • Vcl.Grids
  • GLS.BaseClasses
  • GLS.ImageUtils
  • GLS.Gui
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLayoutEditorForm |

Functions and Procedures

function GUILayoutEditorForm: TGLLayoutEditorForm;
procedure ReleaseGUILayoutEditorForm;

Description

Functions and Procedures

function GUILayoutEditorForm: TGLLayoutEditorForm;

This item has no description.

procedure ReleaseGUILayoutEditorForm;


GLSysHelp v.2.5: FmGuiLayoutEditor: Class TGLLayoutEditorForm

Class TGLLayoutEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmGuiLayoutEditor

Declaration

type TGLLayoutEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLLayoutEditorForm

Overview

Fields

Public | Panel1: TPanel;
Public | Panel2: TPanel;
Public | items_list: TListBox;
Public | x_label: TLabel;
Public | y_label: TLabel;
Public | open_image_button: TBitBtn;
Public | open_button: TBitBtn;
Public | save_button: TBitBtn;
Public | OpenDialog1: TOpenDialog;
Public | SaveDialog1: TSaveDialog;
Public | delete_item_button: TBitBtn;
Public | add_button: TBitBtn;
Public | Label1: TLabel;
Public | Label2: TLabel;
Public | left_edit: TSpinEdit;
Public | top_edit: TSpinEdit;
Public | Label3: TLabel;
Public | Label4: TLabel;
Public | height_edit: TSpinEdit;
Public | width_edit: TSpinEdit;
Public | Label5: TLabel;
Public | name_edit: TEdit;
Public | elements_grid: TStringGrid;
Public | Panel3: TPanel;
Public | BitBtn4: TBitBtn;
Public | BitBtn5: TBitBtn;
Public | ScrollBox1: TScrollBox;
Public | Image2: TImage;
Public | PaintBox1: TPaintBox;
Public | Image1: TImage;
Public | BitBtn6: TBitBtn;
Public | BitBtn1: TBitBtn;
Public | GLGuiLayout1: TGLGuiLayout;

Methods

Private | function GetEnabledSpins: Boolean;
Public | procedure add_buttonClick(Sender: TObject);
Public | procedure BitBtn4Click(Sender: TObject);
Public | procedure BitBtn6Click(Sender: TObject);
Public | procedure delete_item_buttonClick(Sender: TObject);
Public | procedure elements_gridClick(Sender: TObject);
Public | procedure elements_gridDblClick(Sender: TObject);
Public | procedure Execute(AGUILayout: TGLGuiLayout);
Public | procedure FormCreate(Sender: TObject);
Public | procedure height_editChange(Sender: TObject);
Public | procedure Image1MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure Image1MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public | procedure Image1MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure items_listClick(Sender: TObject);
Public | procedure left_editChange(Sender: TObject);
Public | procedure name_editExit(Sender: TObject);
Public | procedure name_editKeyPress(Sender: TObject; var Key: Char);
Public | procedure open_buttonClick(Sender: TObject);
Public | procedure open_image_buttonClick(Sender: TObject);
Public | procedure save_buttonClick(Sender: TObject);
Public | procedure top_editChange(Sender: TObject);
Public | procedure width_editChange(Sender: TObject);
Private | procedure DrawCurrentElement;
Private | procedure RefreshComponentBox;
Private | procedure SetEnabledSpins(Value: Boolean);
Private | procedure SyncImages;

Properties

Public property EnabledSpins: Boolean read GetEnabledSpins write SetEnabledSpins;

Description

Fields

Public Panel1: TPanel;

This item has no description.

Public Panel2: TPanel;

This item has no description.

Public items_list: TListBox;

This item has no description.

Public x_label: TLabel;

This item has no description.

Public y_label: TLabel;

This item has no description.

Public open_image_button: TBitBtn;

This item has no description.

Public open_button: TBitBtn;

This item has no description.

Public save_button: TBitBtn;

This item has no description.

Public OpenDialog1: TOpenDialog;

This item has no description.

Public SaveDialog1: TSaveDialog;

This item has no description.

Public delete_item_button: TBitBtn;

This item has no description.

Public add_button: TBitBtn;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public left_edit: TSpinEdit;

This item has no description.

Public top_edit: TSpinEdit;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public height_edit: TSpinEdit;

This item has no description.

Public width_edit: TSpinEdit;

This item has no description.

Public Label5: TLabel;

This item has no description.

Public name_edit: TEdit;

This item has no description.

Public elements_grid: TStringGrid;

This item has no description.

Public Panel3: TPanel;

This item has no description.

Public BitBtn4: TBitBtn;

This item has no description.

Public BitBtn5: TBitBtn;

This item has no description.

Public ScrollBox1: TScrollBox;

This item has no description.

Public Image2: TImage;

This item has no description.

Public PaintBox1: TPaintBox;

This item has no description.

Public Image1: TImage;

This item has no description.

Public BitBtn6: TBitBtn;

This item has no description.

Public BitBtn1: TBitBtn;

This item has no description.

Public GLGuiLayout1: TGLGuiLayout;

This item has no description.

Methods

Private function GetEnabledSpins: Boolean;

This item has no description.

Public procedure add_buttonClick(Sender: TObject);

This item has no description.

Public procedure BitBtn4Click(Sender: TObject);

This item has no description.

Public procedure BitBtn6Click(Sender: TObject);

This item has no description.

Public procedure delete_item_buttonClick(Sender: TObject);

This item has no description.

Public procedure elements_gridClick(Sender: TObject);

This item has no description.

Public procedure elements_gridDblClick(Sender: TObject);

This item has no description.

Public procedure Execute(AGUILayout: TGLGuiLayout);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure height_editChange(Sender: TObject);

This item has no description.

Public procedure Image1MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure Image1MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure Image1MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure items_listClick(Sender: TObject);

This item has no description.

Public procedure left_editChange(Sender: TObject);

This item has no description.

Public procedure name_editExit(Sender: TObject);

This item has no description.

Public procedure name_editKeyPress(Sender: TObject; var Key: Char);

This item has no description.

Public procedure open_buttonClick(Sender: TObject);

This item has no description.

Public procedure open_image_buttonClick(Sender: TObject);

This item has no description.

Public procedure save_buttonClick(Sender: TObject);

This item has no description.

Public procedure top_editChange(Sender: TObject);

This item has no description.

Public procedure width_editChange(Sender: TObject);

This item has no description.

Private procedure DrawCurrentElement;

This item has no description.

Private procedure RefreshComponentBox;

This item has no description.

Private procedure SetEnabledSpins(Value: Boolean);

This item has no description.

Private procedure SyncImages;

This item has no description.

Properties

Public property EnabledSpins: Boolean read GetEnabledSpins write SetEnabledSpins;


GLSysHelp v.2.5: FmGuiSkinEditor

Unit FmGuiSkinEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.SysUtils
  • System.Classes
  • VCL.Graphics
  • VCL.Controls
  • VCL.Forms
  • VCL.Dialogs
  • VCL.StdCtrls
  • VCL.ComCtrls
  • VCL.ExtCtrls
  • VCL.Menus
  • GLS.Texture
  • GLS.Scene
  • GLS.Objects
  • GLS.Windows
  • GLS.HudObjects
  • GLS.SceneViewer
  • GLS.Gui
  • GLS.Graphics
  • GLScene.Utils
  • GLS.Coordinates
  • GLS.BaseClasses
  • GLS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSkinEditorForm |

Functions and Procedures

function GUIComponentDialog(GuiComponent: TGLGuiElementList): Boolean;

Variables

GLSkinEditorForm: TGLSkinEditorForm;

Description

Functions and Procedures

function GUIComponentDialog(GuiComponent: TGLGuiElementList): Boolean;

This item has no description.

Variables

GLSkinEditorForm: TGLSkinEditorForm;


GLSysHelp v.2.5: FmGuiSkinEditor: Class TGLSkinEditorForm

Class TGLSkinEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmGuiSkinEditor

Declaration

type TGLSkinEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLSkinEditorForm

Overview

Fields

Public | GLScene1: TGLScene;
Public | GLCamera1: TGLCamera;
Public | GLPanel1: TGLPanel;
Public | HUDSprite1: TGLHUDSprite;
Public | GLMemoryViewer1: TGLMemoryViewer;
Public | GLLightSource1: TGLLightSource;
Public | StatusBar: TStatusBar;
Public | panBottom: TPanel;
Public | panZoomImage: TPanel;
Public | imgFull: TImage;
Public | sbarHorizontal: TScrollBar;
Public | sbarVertical: TScrollBar;
Public | Button5: TButton;
Public | Button6: TButton;
Public | panImageProperties: TPanel;
Public | Label5: TLabel;
Public | Label6: TLabel;
Public | Panel2: TPanel;
Public | imgPreview: TImage;
Public | Panel3: TPanel;
Public | Label2: TLabel;
Public | Label1: TLabel;
Public | Button3: TButton;
Public | Button4: TButton;
Public | CheckBox1: TCheckBox;
Public | WidthEdit: TEdit;
Public | HeightEdit: TEdit;
Public | panElements: TPanel;
Public | Bevel2: TBevel;
Public | Bevel1: TBevel;
Public | Label3: TLabel;
Public | Label4: TLabel;
Public | Label11: TLabel;
Public | Label12: TLabel;
Public | Label13: TLabel;
Public | Label9: TLabel;
Public | Label10: TLabel;
Public | Label14: TLabel;
Public | lbElements: TListBox;
Public | btnAdd: TButton;
Public | btnDelete: TButton;
Public | ComboBox1: TComboBox;
Public | LeftEdit: TEdit;
Public | TopEdit: TEdit;
Public | RightEdit: TEdit;
Public | BottomEdit: TEdit;
Public | ScaleXEdit: TEdit;
Public | ScaleYEdit: TEdit;
Public | popElements: TPopupMenu;
Public | mnuTopLeft: TMenuItem;
Public | mnuTop: TMenuItem;
Public | mnuTopRight: TMenuItem;
Public | mnuLeft: TMenuItem;
Public | mnuCenter: TMenuItem;
Public | mnuRight: TMenuItem;
Public | mnuBottomLeft: TMenuItem;
Public | mnuBottom: TMenuItem;
Public | mnuBottomRight: TMenuItem;
Public | N1: TMenuItem;
Public | mnuAddAll: TMenuItem;
Public | N2: TMenuItem;
Public | mnuAllTop: TMenuItem;
Public | mnuAllMiddle: TMenuItem;
Public | mnuAllBottom: TMenuItem;
Private | FOriginalWndProc: TWndMethod;
Private | FFocusRect: TRect;
Private | VisibleRect: TRect;
Private | PreviewMousePoint: TPoint;
Private | PreviewWidth: Integer;
Private | PreviewHeight: Integer;
Private | FullMousePoint: TPoint;
Private | MouseDown: Boolean;
Public | TheGuiComponent: TGLGuiElementList;
Public | SelectedElement: TGLGUIElement;
Public | Tex: TGLTexture;
Public | Zoom: Single;
Public | Width: Integer;
Public | Height: Integer;

Methods

Public | function Edit(GuiComponent: TGLGuiElementList): Boolean;
Public | procedure BottomEditChange(Sender: TObject);
Public | procedure btnAddClick(Sender: TObject);
Public | procedure btnDeleteClick(Sender: TObject);
Public | procedure Button3Click(Sender: TObject);
Public | procedure Button4Click(Sender: TObject);
Public | procedure CheckBox1Click(Sender: TObject);
Public | procedure ComboBox1Change(Sender: TObject);
Public | procedure EditKeyPress(Sender: TObject; var Key: Char);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormDestroy(Sender: TObject);
Public | procedure FormResize(Sender: TObject);
Public | procedure HeightEditChange(Sender: TObject);
Public | procedure imgFullMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure imgFullMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public | procedure imgFullMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure imgPreviewMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure imgPreviewMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public | procedure lbElementsClick(Sender: TObject);
Public | procedure lbElementsKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Public | procedure LeftEditChange(Sender: TObject);
Public | procedure MenuItemClick(Sender: TObject);
Public | procedure mnuAddAllClick(Sender: TObject);
Public | procedure mnuAllBottomClick(Sender: TObject);
Public | procedure mnuAllMiddleClick(Sender: TObject);
Public | procedure mnuAllTopClick(Sender: TObject);
Public | procedure Render;
Public | procedure RightEditChange(Sender: TObject);
Public | procedure ScaleXEditChange(Sender: TObject);
Public | procedure ScaleYEditChange(Sender: TObject);
Public | procedure ScrollbarChange(Sender: TObject);
Public | procedure ScrollBarScroll(Sender: TObject; ScrollCode: TScrollCode; var ScrollPos: Integer);
Public | procedure SetMax(Scrollbar: TScrollbar; Val: Integer);
Public | procedure TopEditChange(Sender: TObject);
Public | procedure WidthEditChange(Sender: TObject);
Private | procedure AddElement(Index: Integer);
Private | procedure AlignZoomPanel;
Private | procedure DrawCrossair(Point: TPoint);
Private | procedure DrawImageFocusRect(ARect: TRect);
Private | procedure ImageWndProc(var Message: TMessage);
Private | procedure SetEditState(Parent: TControl; Enabled: Boolean);
Private | procedure UpdateRegionEdits;

Description

Fields

Public GLScene1: TGLScene;

This item has no description.

Public GLCamera1: TGLCamera;

This item has no description.

Public GLPanel1: TGLPanel;

This item has no description.

Public HUDSprite1: TGLHUDSprite;

This item has no description.

Public GLMemoryViewer1: TGLMemoryViewer;

This item has no description.

Public GLLightSource1: TGLLightSource;

This item has no description.

Public StatusBar: TStatusBar;

This item has no description.

Public panBottom: TPanel;

This item has no description.

Public panZoomImage: TPanel;

This item has no description.

Public imgFull: TImage;

This item has no description.

Public sbarHorizontal: TScrollBar;

This item has no description.

Public sbarVertical: TScrollBar;

This item has no description.

Public Button5: TButton;

This item has no description.

Public Button6: TButton;

This item has no description.

Public panImageProperties: TPanel;

This item has no description.

Public Label5: TLabel;

This item has no description.

Public Label6: TLabel;

This item has no description.

Public Panel2: TPanel;

This item has no description.

Public imgPreview: TImage;

This item has no description.

Public Panel3: TPanel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Button3: TButton;

This item has no description.

Public Button4: TButton;

This item has no description.

Public CheckBox1: TCheckBox;

This item has no description.

Public WidthEdit: TEdit;

This item has no description.

Public HeightEdit: TEdit;

This item has no description.

Public panElements: TPanel;

This item has no description.

Public Bevel2: TBevel;

This item has no description.

Public Bevel1: TBevel;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public Label11: TLabel;

This item has no description.

Public Label12: TLabel;

This item has no description.

Public Label13: TLabel;

This item has no description.

Public Label9: TLabel;

This item has no description.

Public Label10: TLabel;

This item has no description.

Public Label14: TLabel;

This item has no description.

Public lbElements: TListBox;

This item has no description.

Public btnAdd: TButton;

This item has no description.

Public btnDelete: TButton;

This item has no description.

Public ComboBox1: TComboBox;

This item has no description.

Public LeftEdit: TEdit;

This item has no description.

Public TopEdit: TEdit;

This item has no description.

Public RightEdit: TEdit;

This item has no description.

Public BottomEdit: TEdit;

This item has no description.

Public ScaleXEdit: TEdit;

This item has no description.

Public ScaleYEdit: TEdit;

This item has no description.

Public popElements: TPopupMenu;

This item has no description.

Public mnuTopLeft: TMenuItem;

This item has no description.

Public mnuTop: TMenuItem;

This item has no description.

Public mnuTopRight: TMenuItem;

This item has no description.

Public mnuLeft: TMenuItem;

This item has no description.

Public mnuCenter: TMenuItem;

This item has no description.

Public mnuRight: TMenuItem;

This item has no description.

Public mnuBottomLeft: TMenuItem;

This item has no description.

Public mnuBottom: TMenuItem;

This item has no description.

Public mnuBottomRight: TMenuItem;

This item has no description.

Public N1: TMenuItem;

This item has no description.

Public mnuAddAll: TMenuItem;

This item has no description.

Public N2: TMenuItem;

This item has no description.

Public mnuAllTop: TMenuItem;

This item has no description.

Public mnuAllMiddle: TMenuItem;

This item has no description.

Public mnuAllBottom: TMenuItem;

This item has no description.

Private FOriginalWndProc: TWndMethod;

This item has no description.

Private FFocusRect: TRect;

This item has no description.

Private VisibleRect: TRect;

This item has no description.

Private PreviewMousePoint: TPoint;

This item has no description.

Private PreviewWidth: Integer;

This item has no description.

Private PreviewHeight: Integer;

This item has no description.

Private FullMousePoint: TPoint;

This item has no description.

Private MouseDown: Boolean;

This item has no description.

Public TheGuiComponent: TGLGuiElementList;

This item has no description.

Public SelectedElement: TGLGUIElement;

This item has no description.

Public Tex: TGLTexture;

This item has no description.

Public Zoom: Single;

This item has no description.

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Methods

Public function Edit(GuiComponent: TGLGuiElementList): Boolean;

This item has no description.

Public procedure BottomEditChange(Sender: TObject);

This item has no description.

Public procedure btnAddClick(Sender: TObject);

This item has no description.

Public procedure btnDeleteClick(Sender: TObject);

This item has no description.

Public procedure Button3Click(Sender: TObject);

This item has no description.

Public procedure Button4Click(Sender: TObject);

This item has no description.

Public procedure CheckBox1Click(Sender: TObject);

This item has no description.

Public procedure ComboBox1Change(Sender: TObject);

This item has no description.

Public procedure EditKeyPress(Sender: TObject; var Key: Char);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure FormResize(Sender: TObject);

This item has no description.

Public procedure HeightEditChange(Sender: TObject);

This item has no description.

Public procedure imgFullMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure imgFullMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure imgFullMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure imgPreviewMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure imgPreviewMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure lbElementsClick(Sender: TObject);

This item has no description.

Public procedure lbElementsKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

This item has no description.

Public procedure LeftEditChange(Sender: TObject);

This item has no description.

Public procedure MenuItemClick(Sender: TObject);

This item has no description.

Public procedure mnuAddAllClick(Sender: TObject);

This item has no description.

Public procedure mnuAllBottomClick(Sender: TObject);

This item has no description.

Public procedure mnuAllMiddleClick(Sender: TObject);

This item has no description.

Public procedure mnuAllTopClick(Sender: TObject);

This item has no description.

Public procedure Render;

This item has no description.

Public procedure RightEditChange(Sender: TObject);

This item has no description.

Public procedure ScaleXEditChange(Sender: TObject);

This item has no description.

Public procedure ScaleYEditChange(Sender: TObject);

This item has no description.

Public procedure ScrollbarChange(Sender: TObject);

This item has no description.

Public procedure ScrollBarScroll(Sender: TObject; ScrollCode: TScrollCode; var ScrollPos: Integer);

This item has no description.

Public procedure SetMax(Scrollbar: TScrollbar; Val: Integer);

This item has no description.

Public procedure TopEditChange(Sender: TObject);

This item has no description.

Public procedure WidthEditChange(Sender: TObject);

This item has no description.

Private procedure AddElement(Index: Integer);

This item has no description.

Private procedure AlignZoomPanel;

This item has no description.

Private procedure DrawCrossair(Point: TPoint);

This item has no description.

Private procedure DrawImageFocusRect(ARect: TRect);

This item has no description.

Private procedure ImageWndProc(var Message: TMessage);

This item has no description.

Private procedure SetEditState(Parent: TControl; Enabled: Boolean);

This item has no description.

Private procedure UpdateRegionEdits;


GLSysHelp v.2.5: FmInfo

Unit FmInfo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.SysUtils
  • System.Classes
  • Vcl.Forms
  • Vcl.Controls
  • Vcl.Buttons
  • Vcl.StdCtrls
  • Vcl.ComCtrls
  • Vcl.ExtCtrls
  • Vcl.Graphics
  • Vcl.Menus
  • Vcl.Imaging.jpeg
  • GLScene.OpenGLTokens
  • GLS.OpenGLAdapter
  • GLS.Scene
  • GLS.SceneViewer
  • GLS.Context
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLInfoForm |


GLSysHelp v.2.5: FmInfo: Class TGLInfoForm

Class TGLInfoForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmInfo

Declaration

type TGLInfoForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLInfoForm

Overview

Fields

Public | AccLabel: TLabel;
Public | AccumLabel: TLabel;
Public | AuxLabel: TLabel;
Public | ClipLabel: TLabel;
Public | ColorLabel: TLabel;
Public | CopyLabel: TLabel;
Public | DepthLabel: TLabel;
Public | DoubleLabel: TLabel;
Public | EvalLabel: TLabel;
Public | Image: TImage;
Public | Label1: TLabel;
Public | Label10: TLabel;
Public | Label11: TLabel;
Public | Label12: TLabel;
Public | Label13: TLabel;
Public | Label14: TLabel;
Public | Label15: TLabel;
Public | Label16: TLabel;
Public | Label17: TLabel;
Public | Label18: TLabel;
Public | Label2: TLabel;
Public | Label20: TLabel;
Public | Label23: TLabel;
Public | Label25: TLabel;
Public | Label26: TLabel;
Public | Label27: TLabel;
Public | Label28: TLabel;
Public | Label29: TLabel;
Public | Label3: TLabel;
Public | Label30: TLabel;
Public | LabelCommon: TLabel;
Public | LabelDepths: TLabel;
Public | LabelMaxValues: TLabel;
Public | Label34: TLabel;
Public | Label35: TLabel;
Public | Label37: TLabel;
Public | Label4: TLabel;
Public | Label5: TLabel;
Public | Label6: TLabel;
Public | Label7: TLabel;
Public | Label8: TLabel;
Public | Label9: TLabel;
Public | LightLabel: TLabel;
Public | ListLabel: TLabel;
Public | MemoAbout: TMemo;
Public | MemoContributors: TMemo;
Public | ModelLabel: TLabel;
Public | NameLabel: TLabel;
Public | OverlayLabel: TLabel;
Public | PageControl: TPageControl;
Public | PixelLabel: TLabel;
Public | ProjLabel: TLabel;
Public | RendererLabel: TLabel;
Public | ScrollBoxInfo: TScrollBox;
Public | TabSheetInformation: TTabSheet;
Public | StencilLabel: TLabel;
Public | StereoLabel: TLabel;
Public | SubLabel: TLabel;
Public | TabSheetAbout: TTabSheet;
Public | TabSheetContributors: TTabSheet;
Public | TexSizeLabel: TLabel;
Public | TexStackLabel: TLabel;
Public | TexUnitsLabel: TLabel;
Public | UnderlayLabel: TLabel;
Public | VendorLabel: TLabel;
Public | VersionLabel: TLabel;
Public | TabSheetExtensions: TTabSheet;
Public | ListBoxExtensions: TListBox;
Public | PMWebLink: TPopupMenu;
Public | MIRegistryLink: TMenuItem;
Public | MIDelphi3D: TMenuItem;
Public | TabSheetGLScene: TTabSheet;
Public | CloseButton: TButton;
Public | VersionLbl: TLabel;
Public | ViewLabel: TLabel;
Public | lblSfGLScene: TLabel;
Public | lblGithubGLScene: TLabel;

Methods

Public | procedure CloseButtonClick(Sender: TObject);
Public | procedure FormClose(Sender: TObject; var Action: TCloseAction);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormKeyPress(Sender: TObject; var Key: Char);
Public | procedure FormShow(Sender: TObject);
Public | procedure GetInfoFrom(aSceneBuffer: TGLSceneBuffer);
Public | procedure lblGithubGLSceneClick(Sender: TObject);
Public | procedure lblSfGLSceneClick(Sender: TObject);
Public | procedure ListBoxExtensionsClick(Sender: TObject);
Public | procedure ListBoxExtensionsDblClick(Sender: TObject);
Public | procedure ListBoxExtensionsKeyPress(Sender: TObject; var Key: Char);
Public | procedure MIDelphi3DClick(Sender: TObject);

Description

Fields

Public AccLabel: TLabel;

This item has no description.

Public AccumLabel: TLabel;

This item has no description.

Public AuxLabel: TLabel;

This item has no description.

Public ClipLabel: TLabel;

This item has no description.

Public ColorLabel: TLabel;

This item has no description.

Public CopyLabel: TLabel;

This item has no description.

Public DepthLabel: TLabel;

This item has no description.

Public DoubleLabel: TLabel;

This item has no description.

Public EvalLabel: TLabel;

This item has no description.

Public Image: TImage;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label10: TLabel;

This item has no description.

Public Label11: TLabel;

This item has no description.

Public Label12: TLabel;

This item has no description.

Public Label13: TLabel;

This item has no description.

Public Label14: TLabel;

This item has no description.

Public Label15: TLabel;

This item has no description.

Public Label16: TLabel;

This item has no description.

Public Label17: TLabel;

This item has no description.

Public Label18: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public Label20: TLabel;

This item has no description.

Public Label23: TLabel;

This item has no description.

Public Label25: TLabel;

This item has no description.

Public Label26: TLabel;

This item has no description.

Public Label27: TLabel;

This item has no description.

Public Label28: TLabel;

This item has no description.

Public Label29: TLabel;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label30: TLabel;

This item has no description.

Public LabelCommon: TLabel;

This item has no description.

Public LabelDepths: TLabel;

This item has no description.

Public LabelMaxValues: TLabel;

This item has no description.

Public Label34: TLabel;

This item has no description.

Public Label35: TLabel;

This item has no description.

Public Label37: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public Label5: TLabel;

This item has no description.

Public Label6: TLabel;

This item has no description.

Public Label7: TLabel;

This item has no description.

Public Label8: TLabel;

This item has no description.

Public Label9: TLabel;

This item has no description.

Public LightLabel: TLabel;

This item has no description.

Public ListLabel: TLabel;

This item has no description.

Public MemoAbout: TMemo;

This item has no description.

Public MemoContributors: TMemo;

This item has no description.

Public ModelLabel: TLabel;

This item has no description.

Public NameLabel: TLabel;

This item has no description.

Public OverlayLabel: TLabel;

This item has no description.

Public PageControl: TPageControl;

This item has no description.

Public PixelLabel: TLabel;

This item has no description.

Public ProjLabel: TLabel;

This item has no description.

Public RendererLabel: TLabel;

This item has no description.

Public ScrollBoxInfo: TScrollBox;

This item has no description.

Public TabSheetInformation: TTabSheet;

This item has no description.

Public StencilLabel: TLabel;

This item has no description.

Public StereoLabel: TLabel;

This item has no description.

Public SubLabel: TLabel;

This item has no description.

Public TabSheetAbout: TTabSheet;

This item has no description.

Public TabSheetContributors: TTabSheet;

This item has no description.

Public TexSizeLabel: TLabel;

This item has no description.

Public TexStackLabel: TLabel;

This item has no description.

Public TexUnitsLabel: TLabel;

This item has no description.

Public UnderlayLabel: TLabel;

This item has no description.

Public VendorLabel: TLabel;

This item has no description.

Public VersionLabel: TLabel;

This item has no description.

Public TabSheetExtensions: TTabSheet;

This item has no description.

Public ListBoxExtensions: TListBox;

This item has no description.

Public PMWebLink: TPopupMenu;

This item has no description.

Public MIRegistryLink: TMenuItem;

This item has no description.

Public MIDelphi3D: TMenuItem;

This item has no description.

Public TabSheetGLScene: TTabSheet;

This item has no description.

Public CloseButton: TButton;

This item has no description.

Public VersionLbl: TLabel;

This item has no description.

Public ViewLabel: TLabel;

This item has no description.

Public lblSfGLScene: TLabel;

This item has no description.

Public lblGithubGLScene: TLabel;

This item has no description.

Methods

Public procedure CloseButtonClick(Sender: TObject);

This item has no description.

Public procedure FormClose(Sender: TObject; var Action: TCloseAction);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormKeyPress(Sender: TObject; var Key: Char);

This item has no description.

Public procedure FormShow(Sender: TObject);

This item has no description.

Public procedure GetInfoFrom(aSceneBuffer: TGLSceneBuffer);

This item has no description.

Public procedure lblGithubGLSceneClick(Sender: TObject);

This item has no description.

Public procedure lblSfGLSceneClick(Sender: TObject);

This item has no description.

Public procedure ListBoxExtensionsClick(Sender: TObject);

This item has no description.

Public procedure ListBoxExtensionsDblClick(Sender: TObject);

This item has no description.

Public procedure ListBoxExtensionsKeyPress(Sender: TObject; var Key: Char);

This item has no description.

Public procedure MIDelphi3DClick(Sender: TObject);


GLSysHelp v.2.5: FmLibMaterialPicker

Unit FmLibMaterialPicker

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.Types
  • Vcl.Forms
  • Vcl.StdCtrls
  • Vcl.Buttons
  • Vcl.Controls
  • Vcl.Graphics
  • GLS.Scene
  • GLS.Objects
  • GLS.SceneViewer
  • GLS.Material
  • GLS.Color
  • GLS.Coordinates
  • GLS.BaseClasses
  • GLS.HUDObjects
  • GLS.GeomObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLibMaterialPickerForm |

Functions and Procedures

function GLLibMaterialPickerForm: TGLLibMaterialPickerForm;
procedure ReleaseLibMaterialPickerForm;

Description

Functions and Procedures

function GLLibMaterialPickerForm: TGLLibMaterialPickerForm;

For registration in GLScene

procedure ReleaseLibMaterialPickerForm;


GLSysHelp v.2.5: FmLibMaterialPicker: Class TGLLibMaterialPickerForm

Class TGLLibMaterialPickerForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmLibMaterialPicker

Declaration

type TGLLibMaterialPickerForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLLibMaterialPickerForm

Overview

Fields

Public | ListBoxMaterials: TListBox;
Public | Label1: TLabel;
Public | Label2: TLabel;
Public | BitBtnOk: TBitBtn;
Public | BitBtnCancel: TBitBtn;
Public | GLScene1: TGLScene;
Public | GLSceneViewer1: TGLSceneViewer;
Public | LightSource1: TGLLightSource;
Public | dcLight1: TGLDummyCube;
Public | dcWorld1: TGLDummyCube;
Public | Camera1: TGLCamera;
Public | Cube1: TGLCube;
Public | Sphere1: TGLSphere;
Public | FireSphere1: TGLSphere;
Public | Teapot1: TGLTeapot;
Public | GLMaterialLibrary1: TGLMaterialLibrary;
Public | ComboBoxObject1: TComboBox;
Public | ComboBoxBackGround1: TComboBox;
Public | BackGroundSprite1: TGLHUDSprite;
Public | LightSource2: TGLLightSource;
Private | mx: Integer;
Private | my: Integer;
Private | FLibMaterial1: TGLAbstractLibMaterial;

Methods

Public | function Execute(var MaterialName: TGLLibMaterialName; MaterialLibrary: TGLAbstractMaterialLibrary): Boolean;
Private | function GetLibMaterial1: TGLAbstractLibMaterial;
Private | function GetMaterial1: TGLMaterial;
Public | procedure ComboBoxBackGround1Change(Sender: TObject);
Public | procedure ComboBoxObject1Change(Sender: TObject);
Public | procedure FormCreate(Sender: TObject);
Public | procedure GLSceneViewer1MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure GLSceneViewer1MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public | procedure GLSceneViewer1MouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);
Public | procedure ListBoxMaterialsClick(Sender: TObject);
Public | procedure ListBoxMaterialsDblClick(Sender: TObject);
Public | procedure ListBoxMaterialsKeyPress(Sender: TObject; var Key: Char);
Private | procedure SetLibMaterial1(const Value: TGLAbstractLibMaterial);
Private | procedure SetMaterial1(const Value: TGLMaterial);

Properties

Public | property LibMaterial1: TGLAbstractLibMaterial read GetLibMaterial1 write SetLibMaterial1;
Public | property Material1: TGLMaterial read GetMaterial1 write SetMaterial1;

Description

Fields

Public ListBoxMaterials: TListBox;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public BitBtnOk: TBitBtn;

This item has no description.

Public BitBtnCancel: TBitBtn;

This item has no description.

Public GLScene1: TGLScene;

This item has no description.

Public GLSceneViewer1: TGLSceneViewer;

This item has no description.

Public LightSource1: TGLLightSource;

This item has no description.

Public dcLight1: TGLDummyCube;

This item has no description.

Public dcWorld1: TGLDummyCube;

This item has no description.

Public Camera1: TGLCamera;

This item has no description.

Public Cube1: TGLCube;

This item has no description.

Public Sphere1: TGLSphere;

This item has no description.

Public FireSphere1: TGLSphere;

This item has no description.

Public Teapot1: TGLTeapot;

This item has no description.

Public GLMaterialLibrary1: TGLMaterialLibrary;

This item has no description.

Public ComboBoxObject1: TComboBox;

This item has no description.

Public ComboBoxBackGround1: TComboBox;

This item has no description.

Public BackGroundSprite1: TGLHUDSprite;

This item has no description.

Public LightSource2: TGLLightSource;

This item has no description.

Private mx: Integer;

This item has no description.

Private my: Integer;

This item has no description.

Private FLibMaterial1: TGLAbstractLibMaterial;

This item has no description.

Methods

Public function Execute(var MaterialName: TGLLibMaterialName; MaterialLibrary: TGLAbstractMaterialLibrary): Boolean;

This item has no description.

Private function GetLibMaterial1: TGLAbstractLibMaterial;

This item has no description.

Private function GetMaterial1: TGLMaterial;

This item has no description.

Public procedure ComboBoxBackGround1Change(Sender: TObject);

This item has no description.

Public procedure ComboBoxObject1Change(Sender: TObject);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure GLSceneViewer1MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure GLSceneViewer1MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure GLSceneViewer1MouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

This item has no description.

Public procedure ListBoxMaterialsClick(Sender: TObject);

This item has no description.

Public procedure ListBoxMaterialsDblClick(Sender: TObject);

This item has no description.

Public procedure ListBoxMaterialsKeyPress(Sender: TObject; var Key: Char);

This item has no description.

Private procedure SetLibMaterial1(const Value: TGLAbstractLibMaterial);

This item has no description.

Private procedure SetMaterial1(const Value: TGLMaterial);

This item has no description.

Properties

Public property LibMaterial1: TGLAbstractLibMaterial read GetLibMaterial1 write SetLibMaterial1;

This item has no description.

Public property Material1: TGLMaterial read GetMaterial1 write SetMaterial1;


GLSysHelp v.2.5: FmMaterialEditor

Unit FmMaterialEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.TypInfo
  • VCL.Forms
  • VCL.ComCtrls
  • VCL.StdCtrls
  • VCL.Controls
  • VCL.Buttons
  • GLS.SceneViewer
  • GLS.State
  • GLS.Material
  • GLS.Texture
  • FRTrackBarEdit
  • FRMaterialPreview
  • FRColorEditor
  • FRFaceEditor
  • FRTextureEdit

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMaterialEditorForm |

Functions and Procedures

function GLMaterialEditorForm: TGLMaterialEditorForm;
procedure ReleaseMaterialEditorForm;

Description

Functions and Procedures

function GLMaterialEditorForm: TGLMaterialEditorForm;

This item has no description.

procedure ReleaseMaterialEditorForm;


GLSysHelp v.2.5: FmMaterialEditor: Class TGLMaterialEditorForm

Class TGLMaterialEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmMaterialEditor

Declaration

type TGLMaterialEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLMaterialEditorForm

Overview

Fields

Public | PageControl1: TPageControl;
Public | TSFront: TTabSheet;
Public | TSBack: TTabSheet;
Public | TSTexture: TTabSheet;
Public | FEFront: TRFaceEditor;
Public | FEBack: TRFaceEditor;
Public | GroupBox1: TGroupBox;
Public | MPPreview: TRMaterialPreview;
Public | BBOk: TBitBtn;
Public | BBCancel: TBitBtn;
Public | RTextureEdit: TRTextureEdit;
Public | CBBlending: TComboBox;
Public | Label1: TLabel;
Public | Label2: TLabel;
Public | CBPolygonMode: TComboBox;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function Execute(AMaterial: TGLMaterial): Boolean;
Public | procedure OnMaterialChanged(Sender: TObject);

Description

Fields

Public PageControl1: TPageControl;

This item has no description.

Public TSFront: TTabSheet;

This item has no description.

Public TSBack: TTabSheet;

This item has no description.

Public TSTexture: TTabSheet;

This item has no description.

Public FEFront: TRFaceEditor;

This item has no description.

Public FEBack: TRFaceEditor;

This item has no description.

Public GroupBox1: TGroupBox;

This item has no description.

Public MPPreview: TRMaterialPreview;

This item has no description.

Public BBOk: TBitBtn;

This item has no description.

Public BBCancel: TBitBtn;

This item has no description.

Public RTextureEdit: TRTextureEdit;

This item has no description.

Public CBBlending: TComboBox;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public CBPolygonMode: TComboBox;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function Execute(AMaterial: TGLMaterial): Boolean;

This item has no description.

Public procedure OnMaterialChanged(Sender: TObject);


GLSysHelp v.2.5: FMOD.errors

Unit FMOD.errors

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • FMOD.Types

Overview

Functions and Procedures

function FMOD_ErrorString(ErrorCode: TFModErrors): PChar;

Description

Functions and Procedures

function FMOD_ErrorString(ErrorCode: TFModErrors): PChar;

Disable warning for unsafe types in Delphi 7


GLSysHelp v.2.5: FMOD.Import

Unit FMOD.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • FMOD.Types

Overview

Functions and Procedures

function FMOD_Load(LibName: PChar): Boolean;
procedure FMOD_Unload;
function FSOUND_SetOutput(OutputType: TFSoundOutputTypes): ByteBool; stdcall;
function FSOUND_SetDriver(Driver: Integer): ByteBool; stdcall;
function FSOUND_SetMixer(Mixer: TFSoundMixerTypes): ByteBool; stdcall;
function FSOUND_SetBufferSize(LenMs: Integer): ByteBool; stdcall;
function FSOUND_SetHWND(Hwnd: THandle): ByteBool; stdcall;
function FSOUND_SetMinHardwareChannels(Min: Integer): ByteBool; stdcall;
function FSOUND_SetMaxHardwareChannels(Max: Integer): ByteBool; stdcall;
function FSOUND_SetMemorySystem(Pool: Pointer; PoolLen: Integer; UserAlloc: TFSoundAllocCallback; UserRealloc: TFSoundReallocCallback; UserFree: TFSoundFreeCallback): ByteBool; stdcall;
function FSOUND_Init(MixRate: Integer; MaxSoftwareChannels: Integer; Flags: Cardinal): ByteBool; stdcall;
procedure FSOUND_Close; stdcall;
procedure FSOUND_Update; stdcall;
procedure FSOUND_SetSpeakerMode(SpeakerMode: Cardinal); stdcall;
procedure FSOUND_SetSFXMasterVolume(Volume: Integer); stdcall;
procedure FSOUND_SetPanSeperation(PanSep: Single); stdcall;
procedure FSOUND_File_SetCallbacks(OpenCallback: TFSoundOpenCallback; CloseCallback: TFSoundCloseCallback; ReadCallback: TFSoundReadCallback; SeekCallback: TFSoundSeekCallback; TellCallback: TFSoundTellCallback); stdcall;
function FSOUND_GetError: TFModErrors; stdcall;
function FSOUND_GetVersion: Single; stdcall;
function FSOUND_GetOutput: TFSoundOutputTypes; stdcall;
function FSOUND_GetOutputHandle: Pointer; stdcall;
function FSOUND_GetDriver: Integer; stdcall;
function FSOUND_GetMixer: TFSoundMixerTypes; stdcall;
function FSOUND_GetNumDrivers: Integer; stdcall;
function FSOUND_GetDriverName(Id: Integer): PAnsiChar; stdcall;
function FSOUND_GetDriverCaps(Id: Integer; var Caps: Cardinal): ByteBool; stdcall;
function FSOUND_GetOutputRate: Integer; stdcall;
function FSOUND_GetMaxChannels: Integer; stdcall;
function FSOUND_GetMaxSamples: Integer; stdcall;
function FSOUND_GetSFXMasterVolume: Integer; stdcall;
function FSOUND_GetNumHWChannels(var num2d: Integer; var num3d: Integer; var total: Integer): ByteBool; stdcall;
function FSOUND_GetChannelsPlaying: Integer; stdcall;
function FSOUND_GetCPUUsage: Single; stdcall;
procedure FSOUND_GetMemoryStats(var CurrentAlloced: Cardinal; var MaxAlloced: Cardinal); stdcall;
function FSOUND_Sample_Load(Index: Integer; const NameOrData: PAnsiChar; Mode: Cardinal; Offset: Integer; Length: Integer): PFSoundSample; stdcall;
function FSOUND_Sample_Alloc(Index: Integer; Length: Integer; Mode: Cardinal; DefFreq: Integer; DefVol: Integer; DefPan: Integer; DefPri: Integer): PFSoundSample; stdcall;
procedure FSOUND_Sample_Free(Sptr: PFSoundSample); stdcall;
function FSOUND_Sample_Upload(Sptr: PFSoundSample; SrcData: Pointer; Mode: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_Lock(Sptr: PFSoundSample; Offset: Integer; Length: Integer; var Ptr1: Pointer; var Ptr2: Pointer; var Len1: Cardinal; var Len2: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_Unlock(Sptr: PFSoundSample; Ptr1: Pointer; Ptr2: Pointer; Len1: Cardinal; Len2: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_SetMode(Sptr: PFSoundSample; Mode: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_SetLoopPoints(Sptr: PFSoundSample; LoopStart, LoopEnd: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetDefaults(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetDefaultsEx(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri, VarFreq, VarVol, VarPan: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetMinMaxDistance(Sptr: PFSoundSample; Min, Max: Single): ByteBool; stdcall;
function FSOUND_Sample_SetMaxPlaybacks(Sptr: PFSoundSample; Max: Integer): ByteBool; stdcall;
function FSOUND_Sample_Get(SampNo: Integer): PFSoundSample; stdcall;
function FSOUND_Sample_GetName(Sptr: PFSoundSample): PAnsiChar; stdcall;
function FSOUND_Sample_GetLength(Sptr: PFSoundSample): Cardinal; stdcall;
function FSOUND_Sample_GetLoopPoints(Sptr: PFSoundSample; var LoopStart: Integer; var LoopEnd: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetDefaults(Sptr: PFSoundSample; var DefFreq: Integer; var DefVol: Integer; var DefPan: Integer; var DefPri: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetDefaultsEx(Sptr: PFSoundSample; var DefFreq: Integer; var DefVol: Integer; var DefPan: Integer; var DefPri: Integer;var VarFreq: Integer; var VarVol: Integer; var VarPan: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetMode(Sptr: PFSoundSample): Cardinal; stdcall;
function FSOUND_Sample_GetMinMaxDistance(Sptr: PFSoundSample; var Min: Single; var Max: Single): ByteBool; stdcall;
function FSOUND_PlaySound(Channel: Integer; Sptr: PFSoundSample): Integer; stdcall;
function FSOUND_PlaySoundEx(Channel: Integer; Sptr: PFSoundSample; Dsp: PFSoundDSPUnit; StartPaused: ByteBool): Integer; stdcall;
function FSOUND_StopSound(Channel: Integer): ByteBool; stdcall;
function FSOUND_SetFrequency(Channel: Integer; Freq: Integer): ByteBool; stdcall;
function FSOUND_SetVolume(Channel: Integer; Vol: Integer): ByteBool; stdcall;
function FSOUND_SetVolumeAbsolute(Channel: Integer; Vol: Integer): ByteBool; stdcall;
function FSOUND_SetPan(Channel: Integer; Pan: Integer): ByteBool; stdcall;
function FSOUND_SetSurround(Channel: Integer; Surround: ByteBool): ByteBool; stdcall;
function FSOUND_SetMute(Channel: Integer; Mute: ByteBool): ByteBool; stdcall;
function FSOUND_SetPriority(Channel: Integer; Priority: Integer): ByteBool; stdcall;
function FSOUND_SetReserved(Channel: Integer; Reserved: ByteBool): ByteBool; stdcall;
function FSOUND_SetPaused(Channel: Integer; Paused: ByteBool): ByteBool; stdcall;
function FSOUND_SetLoopMode(Channel: Integer; LoopMode: Cardinal): ByteBool; stdcall;
function FSOUND_SetCurrentPosition(Channel: Integer; Offset: Cardinal): ByteBool; stdcall;
function FSOUND_3D_SetAttributes(Channel: Integer; Pos: PFSoundVector; Vel: PFSoundVector): ByteBool; stdcall;
function FSOUND_3D_SetMinMaxDistance(Channel: Integer; Min: Single; Max: Single): ByteBool; stdcall;
function FSOUND_IsPlaying(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetFrequency(Channel: Integer): Integer; stdcall;
function FSOUND_GetVolume(Channel: Integer): Integer; stdcall;
function FSOUND_GetAmplitude(Channel: Integer): Integer; stdcall;
function FSOUND_GetPan(Channel: Integer): Integer; stdcall;
function FSOUND_GetSurround(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetMute(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetPriority(Channel: Integer): Integer; stdcall;
function FSOUND_GetReserved(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetPaused(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetLoopMode(Channel: Integer): Cardinal; stdcall;
function FSOUND_GetCurrentPosition(Channel: Integer): Cardinal; stdcall;
function FSOUND_GetCurrentSample(Channel: Integer): PFSoundSample; stdcall;
function FSOUND_GetCurrentLevels(Channel: Integer; l, r: PSingle): ByteBool; stdcall;
function FSOUND_GetNumSubChannels(Channel: Integer): Integer; stdcall;
function FSOUND_GetSubChannel(Channel: Integer; SubChannel: Integer): Integer; stdcall;
function FSOUND_3D_GetAttributes(Channel: Integer; Pos: PFSoundVector; Vel: PFSoundVector): ByteBool; stdcall;
function FSOUND_3D_GetMinMaxDistance(Channel: Integer; var Min: Single; var Max: Single): ByteBool; stdcall;
procedure FSOUND_3D_Listener_SetCurrent(current: Integer); stdcall;
procedure FSOUND_3D_Listener_SetAttributes(Pos: PFSoundVector; Vel: PFSoundVector; fx: Single; fy: Single; fz: Single; tx: Single; ty: Single; tz: Single); stdcall;
procedure FSOUND_3D_Listener_GetAttributes(Pos: PFSoundVector; Vel: PFSoundVector; fx: PSingle; fy: PSingle; fz: PSingle; tx: PSingle; ty: PSingle; tz: PSingle); stdcall;
procedure FSOUND_3D_SetDopplerFactor(Scale: Single); stdcall;
procedure FSOUND_3D_SetDistanceFactor(Scale: Single); stdcall;
procedure FSOUND_3D_SetRolloffFactor(Scale: Single); stdcall;
function FSOUND_FX_Enable(Channel: Integer; Fx: TFSoundFXModes): Integer; stdcall;
function FSOUND_FX_Disable(Channel: Integer): ByteBool; stdcall;
function FSOUND_FX_SetChorus(FXId: Integer; WetDryMix, Depth, Feedback, Frequency: Single; Waveform: Integer; Delay: Single; Phase: Integer): ByteBool; stdcall;
function FSOUND_FX_SetCompressor(FXId: Integer; Gain, Attack, Release, Threshold, Ratio, Predelay: Single): ByteBool; stdcall;
function FSOUND_FX_SetDistortion(FXId: Integer; Gain, Edge, PostEQCenterFrequency, PostEQBandwidth, PreLowpassCutoff: Single): ByteBool; stdcall;
function FSOUND_FX_SetEcho(FXId: Integer; WetDryMix, Feedback, LeftDelay, RightDelay: Single; PanDelay: Integer): ByteBool; stdcall;
function FSOUND_FX_SetFlanger(FXId: Integer; WetDryMix, Depth, Feedback, Frequency: Single; Waveform: Integer; Delay: Single; Phase: Integer): ByteBool; stdcall;
function FSOUND_FX_SetGargle(FXId, RateHz, WaveShape: Integer): ByteBool; stdcall;
function FSOUND_FX_SetI3DL2Reverb(FXId, Room, RoomHF: Integer; RoomRolloffFactor, DecayTime, DecayHFRatio: Single; Reflections: Integer; ReflectionsDelay: Single; Reverb: Integer; ReverbDelay, Diffusion, Density, HFReference: Single): ByteBool; stdcall;
function FSOUND_FX_SetParamEQ(FXId: Integer; Center, Bandwidth, Gain: Single): ByteBool; stdcall;
function FSOUND_FX_SetWavesReverb(FXId: Integer; InGain, ReverbMix, ReverbTime, HighFreqRTRatio: Single): ByteBool; stdcall;
function FSOUND_Stream_SetBufferSize(Ms: Integer): ByteBool; stdcall;
function FSOUND_Stream_Open(const name_or_data: PAnsiChar; Mode: Cardinal; Offset: Integer; Length: Integer): PFSoundStream; stdcall;
function FSOUND_Stream_Create(Callback: TFSoundStreamCallback; Length: Integer; Mode: Cardinal; SampleRate: Integer; UserData: Integer): PFSoundStream; stdcall;
function FSOUND_Stream_Close(Stream: PFSoundStream): ByteBool; stdcall;
function FSOUND_Stream_Play(Channel: Integer; Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_PlayEx(Channel: Integer; Stream: PFSoundStream; Dsp: PFSoundDSPUnit; StartPaused: ByteBool): Integer; stdcall;
function FSOUND_Stream_Stop(Stream: PFSoundStream): ByteBool; stdcall;
function FSOUND_Stream_SetPosition(Stream: PFSoundStream; Position: Cardinal): ByteBool; stdcall;
function FSOUND_Stream_GetPosition(Stream: PFSoundStream): Cardinal; stdcall;
function FSOUND_Stream_SetTime(Stream: PFSoundStream; Ms: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetTime(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetLength(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetLengthMs(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetMode(Stream: PFSoundStream; mode: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetMode(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetLoopPoints(Stream: PFSoundStream; LoopStartPCM, LoopEndPCM: Integer): ByteBool; stdcall;
function FSOUND_Stream_SetLoopCount(Stream: PFSoundStream; Count: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetOpenState(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetSample(Stream: PFSoundStream): PFSoundSample; stdcall;
function FSOUND_Stream_CreateDSP(Stream: PFSoundStream; Callback: TFSoundDSPCallback; Priority: Integer; Param: Integer): PFSoundDSPUnit; stdcall;
function FSOUND_Stream_SetEndCallback(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_SetSyncCallback(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_AddSyncPoint(Stream: PFSoundStream; PCMOffset: Cardinal; Name: PAnsiChar): PFSyncPoint; stdcall;
function FSOUND_Stream_DeleteSyncPoint(Point: PFSyncPoint): ByteBool; stdcall;
function FSOUND_Stream_GetNumSyncPoints(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetSyncPoint(Stream: PFSoundStream; Index: Integer): PFSyncPoint; stdcall;
function FSOUND_Stream_GetSyncPointInfo(Point: PFSyncPoint; var PCMOffset: Cardinal): PAnsiChar; stdcall;
function FSOUND_Stream_SetSubStream(Stream: PFSoundStream; Index: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetNumSubStreams(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetSubStreamSentence(Stream: PFSoundStream; var SentenceList: Cardinal; NumItems: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetNumTagFields(Stream: PFSoundStream; var Num: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetTagField(Stream: PFSoundStream; Num: Integer; var TagType: TFSoundTagFieldType; var Name: PAnsiChar; var Value: Pointer; var Length: Integer): ByteBool; stdcall;
function FSOUND_Stream_FindTagField(Stream: PFSoundStream; TagType: TFSoundTagFieldType; Name: PAnsiChar; var Value: Pointer; var Length: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_SetProxy(Proxy: PAnsiChar): ByteBool; stdcall;
function FSOUND_Stream_Net_GetLastServerStatus(): PAnsiChar; stdcall;
function FSOUND_Stream_Net_SetBufferProperties(BufferSize: Integer; PreBuffer_Percent: Integer; ReBuffer_Percent: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_GetBufferProperties(var Buffersize: Integer; var PreBuffer_Percent: Integer; var ReBuffer_Percent: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_SetMetadataCallback(Stream: PFSoundStream; Callback: TFMetaDataCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_GetStatus(Stream: PFSoundStream; var Status: TFSoundStreamNetStatus; var BufferPercentUsed: Integer; var BitRate: Integer; var Flags: Cardinal): ByteBool; stdcall;
function FSOUND_CD_Play(Drive: Byte; Track: Integer): ByteBool; stdcall;
procedure FSOUND_CD_SetPlayMode(Drive: Byte; Mode: Integer); stdcall;
function FSOUND_CD_Stop(Drive: Byte): ByteBool; stdcall;
function FSOUND_CD_SetPaused(Drive: Byte; Paused: ByteBool): ByteBool; stdcall;
function FSOUND_CD_SetVolume(Drive: Byte; Volume: Integer): ByteBool; stdcall;
function FSOUND_CD_SetTrackTime(Drive: Byte; ms: Integer): ByteBool; stdcall;
function FSOUND_CD_OpenTray(Drive: Byte; Open: Byte): ByteBool; stdcall;
function FSOUND_CD_GetPaused(Drive: Byte): ByteBool; stdcall;
function FSOUND_CD_GetTrack(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetNumTracks(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetVolume(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetTrackLength(Drive: Byte; Track: Integer): Integer; stdcall;
function FSOUND_CD_GetTrackTime(Drive: Byte): Integer; stdcall;
function FSOUND_DSP_Create(Callback: TFSoundDSPCallback; Priority: Integer; Param: Integer): PFSoundDSPUnit; stdcall;
procedure FSOUND_DSP_Free(DSPUnit: PFSoundDSPUnit); stdcall;
procedure FSOUND_DSP_SetPriority(DSPUnit: PFSoundDSPUnit; Priority: Integer); stdcall;
function FSOUND_DSP_GetPriority(DSPUnit: PFSoundDSPUnit): Integer; stdcall;
procedure FSOUND_DSP_SetActive(DSPUnit: PFSoundDSPUnit; Active: ByteBool); stdcall;
function FSOUND_DSP_GetActive(DSPUnit: PFSoundDSPUnit): ByteBool; stdcall;
function FSOUND_DSP_GetClearUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetSFXUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetMusicUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetFFTUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetClipAndCopyUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_MixBuffers(DestBuffer: Pointer; SrcBuffer: Pointer; Len: Integer; Freq: Integer; Vol: Integer; Pan: Integer; Mode: Cardinal): ByteBool; stdcall;
procedure FSOUND_DSP_ClearMixBuffer; stdcall;
function FSOUND_DSP_GetBufferLength: Integer; stdcall;
function FSOUND_DSP_GetBufferLengthTotal: Integer; stdcall;
function FSOUND_DSP_GetSpectrum: PSingle; stdcall;
function FSOUND_Reverb_SetProperties(var Prop: TFSoundReverbProperties): ByteBool; stdcall;
function FSOUND_Reverb_GetProperties(var Prop: TFSoundReverbProperties): ByteBool; stdcall;
function FSOUND_Reverb_SetChannelProperties(Channel: Integer; var Prop: TFSoundReverbChannelProperties): ByteBool; stdcall;
function FSOUND_Reverb_GetChannelProperties(Channel: Integer; var Prop: TFSoundReverbChannelProperties): ByteBool; stdcall;
function FSOUND_Record_SetDriver(OutputType: Integer): ByteBool; stdcall;
function FSOUND_Record_GetNumDrivers: Integer; stdcall;
function FSOUND_Record_GetDriverName(Id: Integer): PAnsiChar; stdcall;
function FSOUND_Record_GetDriver: Integer; stdcall;
function FSOUND_Record_StartSample(Sptr: PFSoundSample; Loop: ByteBool): ByteBool; stdcall;
function FSOUND_Record_Stop: ByteBool; stdcall;
function FSOUND_Record_GetPosition: Integer; stdcall;
function FMUSIC_LoadSong(const Name: PAnsiChar): PFMusicModule; stdcall;
function FMUSIC_LoadSongEx(Name_Or_Data: Pointer; Offset: Integer; Length: Integer; Mode: Cardinal; var SampleList: Integer; SampleListNum: Integer): PFMusicModule; stdcall;
function FMUSIC_GetOpenState(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_FreeSong(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_PlaySong(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_StopSong(Module: PFMusicModule): ByteBool; stdcall;
procedure FMUSIC_StopAllSongs; stdcall;
function FMUSIC_SetZxxCallback(Module: PFMusicModule; Callback: TFMusicCallback): ByteBool; stdcall;
function FMUSIC_SetRowCallback(Module: PFMusicModule; Callback: TFMusicCallback; RowStep: Integer): ByteBool; stdcall;
function FMUSIC_SetOrderCallback(Module: PFMusicModule; Callback: TFMusicCallback; OrderStep: Integer): ByteBool; stdcall;
function FMUSIC_SetInstCallback(Module: PFMusicModule; Callback: TFMusicCallback; Instrument: Integer): ByteBool; stdcall;
function FMUSIC_SetSample(Module: PFMusicModule; SampNo: Integer; Sptr: PFSoundSample): ByteBool; stdcall;
function FMUSIC_SetUserData(Module: PFMusicModule; userdata: Integer): ByteBool; stdcall;
function FMUSIC_OptimizeChannels(Module: PFMusicModule; MaxChannels: Integer; MinVolume: Integer): ByteBool; stdcall;
function FMUSIC_SetReverb(Reverb: ByteBool): ByteBool; stdcall;
function FMUSIC_SetLooping(Module: PFMusicModule; Looping: ByteBool): ByteBool; stdcall;
function FMUSIC_SetOrder(Module: PFMusicModule; Order: Integer): ByteBool; stdcall;
function FMUSIC_SetPaused(Module: PFMusicModule; Pause: ByteBool): ByteBool; stdcall;
function FMUSIC_SetMasterVolume(Module: PFMusicModule; Volume: Integer): ByteBool; stdcall;
function FMUSIC_SetMasterSpeed(Module: PFMusicModule; speed: Single): ByteBool; stdcall;
function FMUSIC_SetPanSeperation(Module: PFMusicModule; PanSep: Single): ByteBool; stdcall;
function FMUSIC_GetName(Module: PFMusicModule): PAnsiChar; stdcall;
function FMUSIC_GetType(Module: PFMusicModule): TFMusicTypes; stdcall;
function FMUSIC_GetNumOrders(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumPatterns(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumInstruments(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumSamples(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumChannels(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetSample(Module: PFMusicModule; SampNo: Integer): PFSoundSample; stdcall;
function FMUSIC_GetPatternLength(Module: PFMusicModule; OrderNo: Integer): Integer; stdcall;
function FMUSIC_IsFinished(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_IsPlaying(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_GetMasterVolume(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetGlobalVolume(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetOrder(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetPattern(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetSpeed(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetBPM(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetRow(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetPaused(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_GetTime(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetRealChannel(Module: PFMusicModule; modchannel: Integer): Integer; stdcall;
function FMUSIC_GetUserData(Module: PFMusicModule): Integer; stdcall;

Constants

FMOD_DLL = 'fmod32.dll';

Description

Functions and Procedures

function FMOD_Load(LibName: PChar): Boolean;

If no library name is passed to FMOD_Load, then the default library name used. These are stub functions.

procedure FMOD_Unload;

This item has no description.

function FSOUND_SetOutput(OutputType: TFSoundOutputTypes): ByteBool; stdcall;

PRE - FSOUND_Init functions. These can't be called after FSOUND_Init is called (they will fail). They set up FMOD system functionality.

function FSOUND_SetDriver(Driver: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetMixer(Mixer: TFSoundMixerTypes): ByteBool; stdcall;

This item has no description.

function FSOUND_SetBufferSize(LenMs: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetHWND(Hwnd: THandle): ByteBool; stdcall;

This item has no description.

function FSOUND_SetMinHardwareChannels(Min: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetMaxHardwareChannels(Max: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetMemorySystem(Pool: Pointer; PoolLen: Integer; UserAlloc: TFSoundAllocCallback; UserRealloc: TFSoundReallocCallback; UserFree: TFSoundFreeCallback): ByteBool; stdcall;

This item has no description.

function FSOUND_Init(MixRate: Integer; MaxSoftwareChannels: Integer; Flags: Cardinal): ByteBool; stdcall;

Main initialization / closedown functions. Note : Use FSOUND_INIT_USEDEFAULTMIDISYNTH with FSOUND_Init for software override with MIDI playback. : Use FSOUND_INIT_GLOBALFOCUS with FSOUND_Init to make sound audible no matter which window is in focus. (FSOUND_OUTPUT_DSOUND only)

procedure FSOUND_Close; stdcall;

This item has no description.

procedure FSOUND_Update; stdcall;

Runtime system level functions

procedure FSOUND_SetSpeakerMode(SpeakerMode: Cardinal); stdcall;

This is called to update 3d sound / non-realtime output

procedure FSOUND_SetSFXMasterVolume(Volume: Integer); stdcall;

This item has no description.

procedure FSOUND_SetPanSeperation(PanSep: Single); stdcall;

This item has no description.

procedure FSOUND_File_SetCallbacks(OpenCallback: TFSoundOpenCallback; CloseCallback: TFSoundCloseCallback; ReadCallback: TFSoundReadCallback; SeekCallback: TFSoundSeekCallback; TellCallback: TFSoundTellCallback); stdcall;

This item has no description.

function FSOUND_GetError: TFModErrors; stdcall;

System information functions

function FSOUND_GetVersion: Single; stdcall;

This item has no description.

function FSOUND_GetOutput: TFSoundOutputTypes; stdcall;

This item has no description.

function FSOUND_GetOutputHandle: Pointer; stdcall;

This item has no description.

function FSOUND_GetDriver: Integer; stdcall;

This item has no description.

function FSOUND_GetMixer: TFSoundMixerTypes; stdcall;

This item has no description.

function FSOUND_GetNumDrivers: Integer; stdcall;

This item has no description.

function FSOUND_GetDriverName(Id: Integer): PAnsiChar; stdcall;

This item has no description.

function FSOUND_GetDriverCaps(Id: Integer; var Caps: Cardinal): ByteBool; stdcall;

This item has no description.

function FSOUND_GetOutputRate: Integer; stdcall;

This item has no description.

function FSOUND_GetMaxChannels: Integer; stdcall;

This item has no description.

function FSOUND_GetMaxSamples: Integer; stdcall;

This item has no description.

function FSOUND_GetSFXMasterVolume: Integer; stdcall;

function FSOUND_GetSpeakerMode: Integer; {$IFDEF UNIX} cdecl {$ELSE} stdcall {$ENDIF};

function FSOUND_GetNumHWChannels(var num2d: Integer; var num3d: Integer; var total: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_GetChannelsPlaying: Integer; stdcall;

This item has no description.

function FSOUND_GetCPUUsage: Single; stdcall;

This item has no description.

procedure FSOUND_GetMemoryStats(var CurrentAlloced: Cardinal; var MaxAlloced: Cardinal); stdcall;

This item has no description.

function FSOUND_Sample_Load(Index: Integer; const NameOrData: PAnsiChar; Mode: Cardinal; Offset: Integer; Length: Integer): PFSoundSample; stdcall;

Sample creation and management functions Note : Use FSOUND_LOADMEMORY flag with FSOUND_Sample_Load to load from memory. Use FSOUND_LOADRAW flag with FSOUND_Sample_Load to treat as as raw pcm data.

function FSOUND_Sample_Alloc(Index: Integer; Length: Integer; Mode: Cardinal; DefFreq: Integer; DefVol: Integer; DefPan: Integer; DefPri: Integer): PFSoundSample; stdcall;

This item has no description.

procedure FSOUND_Sample_Free(Sptr: PFSoundSample); stdcall;

This item has no description.

function FSOUND_Sample_Upload(Sptr: PFSoundSample; SrcData: Pointer; Mode: Cardinal): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_Lock(Sptr: PFSoundSample; Offset: Integer; Length: Integer; var Ptr1: Pointer; var Ptr2: Pointer; var Len1: Cardinal; var Len2: Cardinal): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_Unlock(Sptr: PFSoundSample; Ptr1: Pointer; Ptr2: Pointer; Len1: Cardinal; Len2: Cardinal): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_SetMode(Sptr: PFSoundSample; Mode: Cardinal): ByteBool; stdcall;

Sample control functions

function FSOUND_Sample_SetLoopPoints(Sptr: PFSoundSample; LoopStart, LoopEnd: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_SetDefaults(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_SetDefaultsEx(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri, VarFreq, VarVol, VarPan: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_SetMinMaxDistance(Sptr: PFSoundSample; Min, Max: Single): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_SetMaxPlaybacks(Sptr: PFSoundSample; Max: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_Get(SampNo: Integer): PFSoundSample; stdcall;

Sample information functions

function FSOUND_Sample_GetName(Sptr: PFSoundSample): PAnsiChar; stdcall;

This item has no description.

function FSOUND_Sample_GetLength(Sptr: PFSoundSample): Cardinal; stdcall;

This item has no description.

function FSOUND_Sample_GetLoopPoints(Sptr: PFSoundSample; var LoopStart: Integer; var LoopEnd: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_GetDefaults(Sptr: PFSoundSample; var DefFreq: Integer; var DefVol: Integer; var DefPan: Integer; var DefPri: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_GetDefaultsEx(Sptr: PFSoundSample; var DefFreq: Integer; var DefVol: Integer; var DefPan: Integer; var DefPri: Integer;var VarFreq: Integer; var VarVol: Integer; var VarPan: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Sample_GetMode(Sptr: PFSoundSample): Cardinal; stdcall;

This item has no description.

function FSOUND_Sample_GetMinMaxDistance(Sptr: PFSoundSample; var Min: Single; var Max: Single): ByteBool; stdcall;

This item has no description.

function FSOUND_PlaySound(Channel: Integer; Sptr: PFSoundSample): Integer; stdcall;

Playing and stopping sounds. Note : Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you. Use FSOUND_ALL as the 'channel' variable to control ALL channels with one function call!

function FSOUND_PlaySoundEx(Channel: Integer; Sptr: PFSoundSample; Dsp: PFSoundDSPUnit; StartPaused: ByteBool): Integer; stdcall;

This item has no description.

function FSOUND_StopSound(Channel: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetFrequency(Channel: Integer; Freq: Integer): ByteBool; stdcall;

Functions to control playback of a channel. Note : FSOUND_ALL can be used on most of these functions as a channel value.

function FSOUND_SetVolume(Channel: Integer; Vol: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetVolumeAbsolute(Channel: Integer; Vol: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetPan(Channel: Integer; Pan: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetSurround(Channel: Integer; Surround: ByteBool): ByteBool; stdcall;

This item has no description.

function FSOUND_SetMute(Channel: Integer; Mute: ByteBool): ByteBool; stdcall;

This item has no description.

function FSOUND_SetPriority(Channel: Integer; Priority: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_SetReserved(Channel: Integer; Reserved: ByteBool): ByteBool; stdcall;

This item has no description.

function FSOUND_SetPaused(Channel: Integer; Paused: ByteBool): ByteBool; stdcall;

This item has no description.

function FSOUND_SetLoopMode(Channel: Integer; LoopMode: Cardinal): ByteBool; stdcall;

This item has no description.

function FSOUND_SetCurrentPosition(Channel: Integer; Offset: Cardinal): ByteBool; stdcall;

This item has no description.

function FSOUND_3D_SetAttributes(Channel: Integer; Pos: PFSoundVector; Vel: PFSoundVector): ByteBool; stdcall;

This item has no description.

function FSOUND_3D_SetMinMaxDistance(Channel: Integer; Min: Single; Max: Single): ByteBool; stdcall;

This item has no description.

function FSOUND_IsPlaying(Channel: Integer): ByteBool; stdcall;

Channel information functions

function FSOUND_GetFrequency(Channel: Integer): Integer; stdcall;

This item has no description.

function FSOUND_GetVolume(Channel: Integer): Integer; stdcall;

This item has no description.

function FSOUND_GetAmplitude(Channel: Integer): Integer; stdcall;

This item has no description.

function FSOUND_GetPan(Channel: Integer): Integer; stdcall;

This item has no description.

function FSOUND_GetSurround(Channel: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_GetMute(Channel: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_GetPriority(Channel: Integer): Integer; stdcall;

This item has no description.

function FSOUND_GetReserved(Channel: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_GetPaused(Channel: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_GetLoopMode(Channel: Integer): Cardinal; stdcall;

This item has no description.

function FSOUND_GetCurrentPosition(Channel: Integer): Cardinal; stdcall;

This item has no description.

function FSOUND_GetCurrentSample(Channel: Integer): PFSoundSample; stdcall;

This item has no description.

function FSOUND_GetCurrentLevels(Channel: Integer; l, r: PSingle): ByteBool; stdcall;

This item has no description.

function FSOUND_GetNumSubChannels(Channel: Integer): Integer; stdcall;

This item has no description.

function FSOUND_GetSubChannel(Channel: Integer; SubChannel: Integer): Integer; stdcall;

This item has no description.

function FSOUND_3D_GetAttributes(Channel: Integer; Pos: PFSoundVector; Vel: PFSoundVector): ByteBool; stdcall;

This item has no description.

function FSOUND_3D_GetMinMaxDistance(Channel: Integer; var Min: Single; var Max: Single): ByteBool; stdcall;

This item has no description.

procedure FSOUND_3D_Listener_SetCurrent(current: Integer); stdcall;

See also 3d sample and channel based functions above. Call FSOUND_Update once a frame to process 3d information.

procedure FSOUND_3D_Listener_SetAttributes(Pos: PFSoundVector; Vel: PFSoundVector; fx: Single; fy: Single; fz: Single; tx: Single; ty: Single; tz: Single); stdcall;

This item has no description.

procedure FSOUND_3D_Listener_GetAttributes(Pos: PFSoundVector; Vel: PFSoundVector; fx: PSingle; fy: PSingle; fz: PSingle; tx: PSingle; ty: PSingle; tz: PSingle); stdcall;

This item has no description.

procedure FSOUND_3D_SetDopplerFactor(Scale: Single); stdcall;

This item has no description.

procedure FSOUND_3D_SetDistanceFactor(Scale: Single); stdcall;

This item has no description.

procedure FSOUND_3D_SetRolloffFactor(Scale: Single); stdcall;

This item has no description.

function FSOUND_FX_Enable(Channel: Integer; Fx: TFSoundFXModes): Integer; stdcall;

Functions to control DX8 only effects processing.

- FX enabled samples can only be played once at a time, not multiple times at once. - Sounds have to be created with FSOUND_HW2D or FSOUND_HW3D for this to work. - FSOUND_INIT_ENABLESYSTEMCHANNELFX can be used to apply hardware effect processing to the global mixed output of FMOD's software channels. - FSOUND_FX_Enable returns an FX handle that you can use to alter fx parameters. - FSOUND_FX_Enable can be called multiple times in a row, even on the same FX type, it will return a unique handle for each FX. - FSOUND_FX_Enable cannot be called if the sound is playing or locked. - FSOUND_FX_Disable must be called to reset/clear the FX from a channel.

function FSOUND_FX_Disable(Channel: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetChorus(FXId: Integer; WetDryMix, Depth, Feedback, Frequency: Single; Waveform: Integer; Delay: Single; Phase: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetCompressor(FXId: Integer; Gain, Attack, Release, Threshold, Ratio, Predelay: Single): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetDistortion(FXId: Integer; Gain, Edge, PostEQCenterFrequency, PostEQBandwidth, PreLowpassCutoff: Single): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetEcho(FXId: Integer; WetDryMix, Feedback, LeftDelay, RightDelay: Single; PanDelay: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetFlanger(FXId: Integer; WetDryMix, Depth, Feedback, Frequency: Single; Waveform: Integer; Delay: Single; Phase: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetGargle(FXId, RateHz, WaveShape: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetI3DL2Reverb(FXId, Room, RoomHF: Integer; RoomRolloffFactor, DecayTime, DecayHFRatio: Single; Reflections: Integer; ReflectionsDelay: Single; Reverb: Integer; ReverbDelay, Diffusion, Density, HFReference: Single): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetParamEQ(FXId: Integer; Center, Bandwidth, Gain: Single): ByteBool; stdcall;

This item has no description.

function FSOUND_FX_SetWavesReverb(FXId: Integer; InGain, ReverbMix, ReverbTime, HighFreqRTRatio: Single): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_SetBufferSize(Ms: Integer): ByteBool; stdcall;

Note : Use FSOUND_LOADMEMORY flag with FSOUND_Stream_Open to stream from memory. Use FSOUND_LOADRAW flag with FSOUND_Stream_Open to treat stream as raw pcm data. Use FSOUND_MPEGACCURATE flag with FSOUND_Stream_Open to open mpegs in 'accurate mode' for settime/gettime/getlengthms. Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you.

function FSOUND_Stream_Open(const name_or_data: PAnsiChar; Mode: Cardinal; Offset: Integer; Length: Integer): PFSoundStream; stdcall;

This item has no description.

function FSOUND_Stream_Create(Callback: TFSoundStreamCallback; Length: Integer; Mode: Cardinal; SampleRate: Integer; UserData: Integer): PFSoundStream; stdcall;

This item has no description.

function FSOUND_Stream_Close(Stream: PFSoundStream): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_Play(Channel: Integer; Stream: PFSoundStream): Integer; stdcall;

This item has no description.

function FSOUND_Stream_PlayEx(Channel: Integer; Stream: PFSoundStream; Dsp: PFSoundDSPUnit; StartPaused: ByteBool): Integer; stdcall;

This item has no description.

function FSOUND_Stream_Stop(Stream: PFSoundStream): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_SetPosition(Stream: PFSoundStream; Position: Cardinal): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_GetPosition(Stream: PFSoundStream): Cardinal; stdcall;

This item has no description.

function FSOUND_Stream_SetTime(Stream: PFSoundStream; Ms: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_GetTime(Stream: PFSoundStream): Integer; stdcall;

This item has no description.

function FSOUND_Stream_GetLength(Stream: PFSoundStream): Integer; stdcall;

This item has no description.

function FSOUND_Stream_GetLengthMs(Stream: PFSoundStream): Integer; stdcall;

This item has no description.

function FSOUND_Stream_SetMode(Stream: PFSoundStream; mode: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_GetMode(Stream: PFSoundStream): Integer; stdcall;

This item has no description.

function FSOUND_Stream_SetLoopPoints(Stream: PFSoundStream; LoopStartPCM, LoopEndPCM: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_SetLoopCount(Stream: PFSoundStream; Count: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_GetOpenState(Stream: PFSoundStream): Integer; stdcall;

This item has no description.

function FSOUND_Stream_GetSample(Stream: PFSoundStream): PFSoundSample; stdcall;

This item has no description.

function FSOUND_Stream_CreateDSP(Stream: PFSoundStream; Callback: TFSoundDSPCallback; Priority: Integer; Param: Integer): PFSoundDSPUnit; stdcall;

This item has no description.

function FSOUND_Stream_SetEndCallback(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_SetSyncCallback(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_AddSyncPoint(Stream: PFSoundStream; PCMOffset: Cardinal; Name: PAnsiChar): PFSyncPoint; stdcall;

This item has no description.

function FSOUND_Stream_DeleteSyncPoint(Point: PFSyncPoint): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_GetNumSyncPoints(Stream: PFSoundStream): Integer; stdcall;

This item has no description.

function FSOUND_Stream_GetSyncPoint(Stream: PFSoundStream; Index: Integer): PFSyncPoint; stdcall;

This item has no description.

function FSOUND_Stream_GetSyncPointInfo(Point: PFSyncPoint; var PCMOffset: Cardinal): PAnsiChar; stdcall;

This item has no description.

function FSOUND_Stream_SetSubStream(Stream: PFSoundStream; Index: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_GetNumSubStreams(Stream: PFSoundStream): Integer; stdcall;

This item has no description.

function FSOUND_Stream_SetSubStreamSentence(Stream: PFSoundStream; var SentenceList: Cardinal; NumItems: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_GetNumTagFields(Stream: PFSoundStream; var Num: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_GetTagField(Stream: PFSoundStream; Num: Integer; var TagType: TFSoundTagFieldType; var Name: PAnsiChar; var Value: Pointer; var Length: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_FindTagField(Stream: PFSoundStream; TagType: TFSoundTagFieldType; Name: PAnsiChar; var Value: Pointer; var Length: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_Net_SetProxy(Proxy: PAnsiChar): ByteBool; stdcall;

Internet streaming functions

function FSOUND_Stream_Net_GetLastServerStatus(): PAnsiChar; stdcall;

This item has no description.

function FSOUND_Stream_Net_SetBufferProperties(BufferSize: Integer; PreBuffer_Percent: Integer; ReBuffer_Percent: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_Net_GetBufferProperties(var Buffersize: Integer; var PreBuffer_Percent: Integer; var ReBuffer_Percent: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_Net_SetMetadataCallback(Stream: PFSoundStream; Callback: TFMetaDataCallback; UserData: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_Stream_Net_GetStatus(Stream: PFSoundStream; var Status: TFSoundStreamNetStatus; var BufferPercentUsed: Integer; var BitRate: Integer; var Flags: Cardinal): ByteBool; stdcall;

This item has no description.

function FSOUND_CD_Play(Drive: Byte; Track: Integer): ByteBool; stdcall;

Note : 0 = default cdrom. Otherwise specify the drive letter, for example. 'D'.

procedure FSOUND_CD_SetPlayMode(Drive: Byte; Mode: Integer); stdcall;

This item has no description.

function FSOUND_CD_Stop(Drive: Byte): ByteBool; stdcall;

This item has no description.

function FSOUND_CD_SetPaused(Drive: Byte; Paused: ByteBool): ByteBool; stdcall;

This item has no description.

function FSOUND_CD_SetVolume(Drive: Byte; Volume: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_CD_SetTrackTime(Drive: Byte; ms: Integer): ByteBool; stdcall;

This item has no description.

function FSOUND_CD_OpenTray(Drive: Byte; Open: Byte): ByteBool; stdcall;

This item has no description.

function FSOUND_CD_GetPaused(Drive: Byte): ByteBool; stdcall;

This item has no description.

function FSOUND_CD_GetTrack(Drive: Byte): Integer; stdcall;

This item has no description.

function FSOUND_CD_GetNumTracks(Drive: Byte): Integer; stdcall;

This item has no description.

function FSOUND_CD_GetVolume(Drive: Byte): Integer; stdcall;

This item has no description.

function FSOUND_CD_GetTrackLength(Drive: Byte; Track: Integer): Integer; stdcall;

This item has no description.

function FSOUND_CD_GetTrackTime(Drive: Byte): Integer; stdcall;

This item has no description.

function FSOUND_DSP_Create(Callback: TFSoundDSPCallback; Priority: Integer; Param: Integer): PFSoundDSPUnit; stdcall;

DSP Unit control and information functions.

procedure FSOUND_DSP_Free(DSPUnit: PFSoundDSPUnit); stdcall;

This item has no description.

procedure FSOUND_DSP_SetPriority(DSPUnit: PFSoundDSPUnit; Priority: Integer); stdcall;

This item has no description.

function FSOUND_DSP_GetPriority(DSPUnit: PFSoundDSPUnit): Integer; stdcall;

This item has no description.

procedure FSOUND_DSP_SetActive(DSPUnit: PFSoundDSPUnit; Active: ByteBool); stdcall;

This item has no description.

function FSOUND_DSP_GetActive(DSPUnit: PFSoundDSPUnit): ByteBool; stdcall;

This item has no description.

function FSOUND_DSP_GetClearUnit: PFSoundDSPUnit; stdcall;

Functions to get hold of FSOUND 'system DSP unit' handles.

function FSOUND_DSP_GetSFXUnit: PFSoundDSPUnit; stdcall;

This item has no description.

function FSOUND_DSP_GetMusicUnit: PFSoundDSPUnit; stdcall;

This item has no description.

function FSOUND_DSP_GetFFTUnit: PFSoundDSPUnit; stdcall;

This item has no description.

function FSOUND_DSP_GetClipAndCopyUnit: PFSoundDSPUnit; stdcall;

This item has no description.

function FSOUND_DSP_MixBuffers(DestBuffer: Pointer; SrcBuffer: Pointer; Len: Integer; Freq: Integer; Vol: Integer; Pan: Integer; Mode: Cardinal): ByteBool; stdcall;

Miscellaneous DSP functions Note for the spectrum analysis function to work, you have to enable the FFT DSP unit with the following code FSOUND_DSP_SetActive(FSOUND_DSP_GetFFTUnit(), TRUE); It is off by default to save cpu usage.

procedure FSOUND_DSP_ClearMixBuffer; stdcall;

This item has no description.

function FSOUND_DSP_GetBufferLength: Integer; stdcall;

This item has no description.

function FSOUND_DSP_GetBufferLengthTotal: Integer; stdcall;

Length of each DSP update

function FSOUND_DSP_GetSpectrum: PSingle; stdcall;

Total buffer length due to FSOUND_SetBufferSize

function FSOUND_Reverb_SetProperties(var Prop: TFSoundReverbProperties): ByteBool; stdcall;

See structures above for definitions and information on the reverb parameters.

function FSOUND_Reverb_GetProperties(var Prop: TFSoundReverbProperties): ByteBool; stdcall;

This item has no description.

function FSOUND_Reverb_SetChannelProperties(Channel: Integer; var Prop: TFSoundReverbChannelProperties): ByteBool; stdcall;

This item has no description.

function FSOUND_Reverb_GetChannelProperties(Channel: Integer; var Prop: TFSoundReverbChannelProperties): ByteBool; stdcall;

This item has no description.

function FSOUND_Record_SetDriver(OutputType: Integer): ByteBool; stdcall;

Recording initialization functions

function FSOUND_Record_GetNumDrivers: Integer; stdcall;

This item has no description.

function FSOUND_Record_GetDriverName(Id: Integer): PAnsiChar; stdcall;

This item has no description.

function FSOUND_Record_GetDriver: Integer; stdcall;

This item has no description.

function FSOUND_Record_StartSample(Sptr: PFSoundSample; Loop: ByteBool): ByteBool; stdcall;

Recording functionality. Only one recording session will work at a time.

function FSOUND_Record_Stop: ByteBool; stdcall;

This item has no description.

function FSOUND_Record_GetPosition: Integer; stdcall;

This item has no description.

function FMUSIC_LoadSong(const Name: PAnsiChar): PFMusicModule; stdcall;

Song management / playback functions.

function FMUSIC_LoadSongEx(Name_Or_Data: Pointer; Offset: Integer; Length: Integer; Mode: Cardinal; var SampleList: Integer; SampleListNum: Integer): PFMusicModule; stdcall;

This item has no description.

function FMUSIC_GetOpenState(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_FreeSong(Module: PFMusicModule): ByteBool; stdcall;

This item has no description.

function FMUSIC_PlaySong(Module: PFMusicModule): ByteBool; stdcall;

This item has no description.

function FMUSIC_StopSong(Module: PFMusicModule): ByteBool; stdcall;

This item has no description.

procedure FMUSIC_StopAllSongs; stdcall;

This item has no description.

function FMUSIC_SetZxxCallback(Module: PFMusicModule; Callback: TFMusicCallback): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetRowCallback(Module: PFMusicModule; Callback: TFMusicCallback; RowStep: Integer): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetOrderCallback(Module: PFMusicModule; Callback: TFMusicCallback; OrderStep: Integer): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetInstCallback(Module: PFMusicModule; Callback: TFMusicCallback; Instrument: Integer): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetSample(Module: PFMusicModule; SampNo: Integer; Sptr: PFSoundSample): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetUserData(Module: PFMusicModule; userdata: Integer): ByteBool; stdcall;

This item has no description.

function FMUSIC_OptimizeChannels(Module: PFMusicModule; MaxChannels: Integer; MinVolume: Integer): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetReverb(Reverb: ByteBool): ByteBool; stdcall;

Runtime song functions.

function FMUSIC_SetLooping(Module: PFMusicModule; Looping: ByteBool): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetOrder(Module: PFMusicModule; Order: Integer): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetPaused(Module: PFMusicModule; Pause: ByteBool): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetMasterVolume(Module: PFMusicModule; Volume: Integer): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetMasterSpeed(Module: PFMusicModule; speed: Single): ByteBool; stdcall;

This item has no description.

function FMUSIC_SetPanSeperation(Module: PFMusicModule; PanSep: Single): ByteBool; stdcall;

This item has no description.

function FMUSIC_GetName(Module: PFMusicModule): PAnsiChar; stdcall;

Static song information functions.

function FMUSIC_GetType(Module: PFMusicModule): TFMusicTypes; stdcall;

This item has no description.

function FMUSIC_GetNumOrders(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetNumPatterns(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetNumInstruments(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetNumSamples(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetNumChannels(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetSample(Module: PFMusicModule; SampNo: Integer): PFSoundSample; stdcall;

This item has no description.

function FMUSIC_GetPatternLength(Module: PFMusicModule; OrderNo: Integer): Integer; stdcall;

This item has no description.

function FMUSIC_IsFinished(Module: PFMusicModule): ByteBool; stdcall;

Runtime song information.

function FMUSIC_IsPlaying(Module: PFMusicModule): ByteBool; stdcall;

This item has no description.

function FMUSIC_GetMasterVolume(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetGlobalVolume(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetOrder(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetPattern(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetSpeed(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetBPM(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetRow(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetPaused(Module: PFMusicModule): ByteBool; stdcall;

This item has no description.

function FMUSIC_GetTime(Module: PFMusicModule): Integer; stdcall;

This item has no description.

function FMUSIC_GetRealChannel(Module: PFMusicModule; modchannel: Integer): Integer; stdcall;

This item has no description.

function FMUSIC_GetUserData(Module: PFMusicModule): Integer; stdcall;

This item has no description.

Constants

FMOD_DLL = 'fmod32.dll';


GLSysHelp v.2.5: FMOD.presets

Unit FMOD.presets

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • FMOD.Types

Overview

Constants

FSOUND_PRESET_OFF: TFSoundReverbProperties = (Environment: 0; EnvSize: 7.5; EnvDiffusion: 1.00; Room: -10000; RoomHF: -10000; RoomLF: 0; DecayTime: 1.00; DecayHFRatio: 1.00; DecayLFRatio: 1.0; Reflections: -2602; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 200; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 0.0; Density: 0.0; Flags: $33f);
FSOUND_PRESET_GENERIC: TFSoundReverbProperties = (Environment: 0; EnvSize: 7.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -100; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -2602; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 200; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PADDEDCELL: TFSoundReverbProperties = (Environment: 1; EnvSize: 1.4; EnvDiffusion: 1.00; Room: -1000; RoomHF: -6000; RoomLF: 0; DecayTime: 0.17; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1204; ReflectionsDelay: 0.001; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 207; ReverbDelay: 0.002; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_ROOM: TFSoundReverbProperties = (Environment: 2; EnvSize: 1.9; EnvDiffusion: 1.00; Room: -1000; RoomHF: -454; RoomLF: 0; DecayTime: 0.40; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -1646; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 53; ReverbDelay: 0.003; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_BATHROOM: TFSoundReverbProperties = (Environment: 3; EnvSize: 1.4; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1200; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.54; DecayLFRatio: 1.0; Reflections: -370; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1030; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 60.0; Flags: $3f);
FSOUND_PRESET_LIVINGROOM: TFSoundReverbProperties = (Environment: 4; EnvSize: 2.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -6000; RoomLF: 0; DecayTime: 0.50; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1376; ReflectionsDelay: 0.003; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1104; ReverbDelay: 0.004; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_STONEROOM: TFSoundReverbProperties = (Environment: 5; EnvSize: 11.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -300; RoomLF: 0; DecayTime: 2.31; DecayHFRatio: 0.64; DecayLFRatio: 1.0; Reflections: -711; ReflectionsDelay: 0.012; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 83; ReverbDelay: 0.017; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_AUDITORIUM: TFSoundReverbProperties = (Environment: 6; EnvSize: 21.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -476; RoomLF: 0; DecayTime: 4.32; DecayHFRatio: 0.59; DecayLFRatio: 1.0; Reflections: -789; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-289; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CONCERTHALL: TFSoundReverbProperties = (Environment: 7; EnvSize: 19.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -500; RoomLF: 0; DecayTime: 3.92; DecayHFRatio: 0.70; DecayLFRatio: 1.0; Reflections: -1230; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-2; ReverbDelay: 0.029; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CAVE: TFSoundReverbProperties = (Environment: 8; EnvSize: 14.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 2.91; DecayHFRatio: 1.30; DecayLFRatio: 1.0; Reflections: -602; ReflectionsDelay: 0.015; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-302; ReverbDelay: 0.022; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_ARENA: TFSoundReverbProperties = (Environment: 9; EnvSize: 36.2; EnvDiffusion: 1.00; Room: -1000; RoomHF: -698; RoomLF: 0; DecayTime: 7.24; DecayHFRatio: 0.33; DecayLFRatio: 1.0; Reflections: -1166; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 16; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_HANGAR: TFSoundReverbProperties = (Environment: 10; EnvSize: 50.3; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 10.05; DecayHFRatio: 0.23; DecayLFRatio: 1.0; Reflections: -602; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 198; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CARPETTEDHALLWAY: TFSoundReverbProperties = (Environment: 11; EnvSize: 1.9; EnvDiffusion: 1.00; Room: -1000; RoomHF: -4000; RoomLF: 0; DecayTime: 0.30; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1831; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1630; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_HALLWAY: TFSoundReverbProperties = (Environment: 12; EnvSize: 1.8; EnvDiffusion: 1.00; Room: -1000; RoomHF: -300; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.59; DecayLFRatio: 1.0; Reflections: -1219; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 441; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_STONECORRIDOR: TFSoundReverbProperties = (Environment: 13; EnvSize: 13.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -237; RoomLF: 0; DecayTime: 2.70; DecayHFRatio: 0.79; DecayLFRatio: 1.0; Reflections: -1214; ReflectionsDelay: 0.013; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 395; ReverbDelay: 0.020; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_ALLEY: TFSoundReverbProperties = (Environment: 14; EnvSize: 7.5; EnvDiffusion: 0.30; Room: -1000; RoomHF: -270; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.86; DecayLFRatio: 1.0; Reflections: -1204; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-4; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 0.95; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_FOREST: TFSoundReverbProperties = (Environment: 15; EnvSize: 38.0; EnvDiffusion: 0.30; Room: -1000; RoomHF: -3300; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.54; DecayLFRatio: 1.0; Reflections: -2560; ReflectionsDelay: 0.162; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-229; ReverbDelay: 0.088; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 79.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CITY: TFSoundReverbProperties = (Environment: 16; EnvSize: 7.5; EnvDiffusion: 0.50; Room: -1000; RoomHF: -800; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.67; DecayLFRatio: 1.0; Reflections: -2273; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1691; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 50.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_MOUNTAINS: TFSoundReverbProperties = (Environment: 17; EnvSize: 100.0; EnvDiffusion: 0.27; Room: -1000; RoomHF: -2500; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.21; DecayLFRatio: 1.0; Reflections: -2780; ReflectionsDelay: 0.300; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1434; ReverbDelay: 0.100; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 27.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_QUARRY: TFSoundReverbProperties = (Environment: 18; EnvSize: 17.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -10000;ReflectionsDelay: 0.061; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 500; ReverbDelay: 0.025; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 0.70; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PLAIN: TFSoundReverbProperties = (Environment: 19; EnvSize: 42.5; EnvDiffusion: 0.21; Room: -1000; RoomHF: -2000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.50; DecayLFRatio: 1.0; Reflections: -2466; ReflectionsDelay: 0.179; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1926; ReverbDelay: 0.100; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 21.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PARKINGLOT: TFSoundReverbProperties = (Environment: 20; EnvSize: 8.3; EnvDiffusion: 1.00; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 1.65; DecayHFRatio: 1.50; DecayLFRatio: 1.0; Reflections: -1363; ReflectionsDelay: 0.008; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1153; ReverbDelay: 0.012; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_SEWERPIPE: TFSoundReverbProperties = (Environment: 21; EnvSize: 1.7; EnvDiffusion: 0.80; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 2.81; DecayHFRatio: 0.14; DecayLFRatio: 1.0; Reflections: 429; ReflectionsDelay: 0.014; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1023; ReverbDelay: 0.021; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 80.0; Density: 60.0; Flags: $3f);
FSOUND_PRESET_UNDERWATER: TFSoundReverbProperties = (Environment: 22; EnvSize: 1.8; EnvDiffusion: 1.00; Room: -1000; RoomHF: -4000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -449; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1700; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 1.18; ModulationDepth: 0.348; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_DRUGGED: TFSoundReverbProperties = (Environment: 23; EnvSize: 1.9; EnvDiffusion: 0.50; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 8.39; DecayHFRatio: 1.39; DecayLFRatio: 1.0; Reflections: -115; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 985; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 1.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_DIZZY: TFSoundReverbProperties = (Environment: 24; EnvSize: 1.8; EnvDiffusion: 0.60; Room: -1000; RoomHF: -400; RoomLF: 0; DecayTime: 17.23; DecayHFRatio: 0.56; DecayLFRatio: 1.0; Reflections: -1713; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-613; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.81; ModulationDepth: 0.310; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_PSYCHOTIC: TFSoundReverbProperties = (Environment: 25; EnvSize: 1.0; EnvDiffusion: 0.50; Room: -1000; RoomHF: -151; RoomLF: 0; DecayTime: 7.56; DecayHFRatio: 0.91; DecayLFRatio: 1.0; Reflections: -626; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 774; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 4.00; ModulationDepth: 1.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);

Description

Constants

FSOUND_PRESET_OFF: TFSoundReverbProperties = (Environment: 0; EnvSize: 7.5; EnvDiffusion: 1.00; Room: -10000; RoomHF: -10000; RoomLF: 0; DecayTime: 1.00; DecayHFRatio: 1.00; DecayLFRatio: 1.0; Reflections: -2602; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 200; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 0.0; Density: 0.0; Flags: $33f);

[DEFINE_START] [ [NAME] FSOUND_REVERB_PRESETS

[DESCRIPTION] A set of predefined environment PARAMETERS, created by Creative Labs These are used to initialize an FSOUND_REVERB_PROPERTIES structure statically. ie FSOUND_REVERB_PROPERTIES prop = FSOUND_PRESET_GENERIC;

[SEE_ALSO] FSOUND_Reverb_SetProperties ]

FSOUND_PRESET_GENERIC: TFSoundReverbProperties = (Environment: 0; EnvSize: 7.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -100; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -2602; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 200; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_PADDEDCELL: TFSoundReverbProperties = (Environment: 1; EnvSize: 1.4; EnvDiffusion: 1.00; Room: -1000; RoomHF: -6000; RoomLF: 0; DecayTime: 0.17; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1204; ReflectionsDelay: 0.001; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 207; ReverbDelay: 0.002; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_ROOM: TFSoundReverbProperties = (Environment: 2; EnvSize: 1.9; EnvDiffusion: 1.00; Room: -1000; RoomHF: -454; RoomLF: 0; DecayTime: 0.40; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -1646; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 53; ReverbDelay: 0.003; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_BATHROOM: TFSoundReverbProperties = (Environment: 3; EnvSize: 1.4; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1200; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.54; DecayLFRatio: 1.0; Reflections: -370; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1030; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 60.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_LIVINGROOM: TFSoundReverbProperties = (Environment: 4; EnvSize: 2.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -6000; RoomLF: 0; DecayTime: 0.50; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1376; ReflectionsDelay: 0.003; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1104; ReverbDelay: 0.004; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_STONEROOM: TFSoundReverbProperties = (Environment: 5; EnvSize: 11.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -300; RoomLF: 0; DecayTime: 2.31; DecayHFRatio: 0.64; DecayLFRatio: 1.0; Reflections: -711; ReflectionsDelay: 0.012; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 83; ReverbDelay: 0.017; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_AUDITORIUM: TFSoundReverbProperties = (Environment: 6; EnvSize: 21.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -476; RoomLF: 0; DecayTime: 4.32; DecayHFRatio: 0.59; DecayLFRatio: 1.0; Reflections: -789; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-289; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_CONCERTHALL: TFSoundReverbProperties = (Environment: 7; EnvSize: 19.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -500; RoomLF: 0; DecayTime: 3.92; DecayHFRatio: 0.70; DecayLFRatio: 1.0; Reflections: -1230; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-2; ReverbDelay: 0.029; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_CAVE: TFSoundReverbProperties = (Environment: 8; EnvSize: 14.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 2.91; DecayHFRatio: 1.30; DecayLFRatio: 1.0; Reflections: -602; ReflectionsDelay: 0.015; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-302; ReverbDelay: 0.022; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);

This item has no description.

FSOUND_PRESET_ARENA: TFSoundReverbProperties = (Environment: 9; EnvSize: 36.2; EnvDiffusion: 1.00; Room: -1000; RoomHF: -698; RoomLF: 0; DecayTime: 7.24; DecayHFRatio: 0.33; DecayLFRatio: 1.0; Reflections: -1166; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 16; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_HANGAR: TFSoundReverbProperties = (Environment: 10; EnvSize: 50.3; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 10.05; DecayHFRatio: 0.23; DecayLFRatio: 1.0; Reflections: -602; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 198; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_CARPETTEDHALLWAY: TFSoundReverbProperties = (Environment: 11; EnvSize: 1.9; EnvDiffusion: 1.00; Room: -1000; RoomHF: -4000; RoomLF: 0; DecayTime: 0.30; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1831; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1630; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_HALLWAY: TFSoundReverbProperties = (Environment: 12; EnvSize: 1.8; EnvDiffusion: 1.00; Room: -1000; RoomHF: -300; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.59; DecayLFRatio: 1.0; Reflections: -1219; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 441; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_STONECORRIDOR: TFSoundReverbProperties = (Environment: 13; EnvSize: 13.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -237; RoomLF: 0; DecayTime: 2.70; DecayHFRatio: 0.79; DecayLFRatio: 1.0; Reflections: -1214; ReflectionsDelay: 0.013; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 395; ReverbDelay: 0.020; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_ALLEY: TFSoundReverbProperties = (Environment: 14; EnvSize: 7.5; EnvDiffusion: 0.30; Room: -1000; RoomHF: -270; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.86; DecayLFRatio: 1.0; Reflections: -1204; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-4; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 0.95; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_FOREST: TFSoundReverbProperties = (Environment: 15; EnvSize: 38.0; EnvDiffusion: 0.30; Room: -1000; RoomHF: -3300; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.54; DecayLFRatio: 1.0; Reflections: -2560; ReflectionsDelay: 0.162; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-229; ReverbDelay: 0.088; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 79.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_CITY: TFSoundReverbProperties = (Environment: 16; EnvSize: 7.5; EnvDiffusion: 0.50; Room: -1000; RoomHF: -800; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.67; DecayLFRatio: 1.0; Reflections: -2273; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1691; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 50.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_MOUNTAINS: TFSoundReverbProperties = (Environment: 17; EnvSize: 100.0; EnvDiffusion: 0.27; Room: -1000; RoomHF: -2500; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.21; DecayLFRatio: 1.0; Reflections: -2780; ReflectionsDelay: 0.300; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1434; ReverbDelay: 0.100; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 27.0; Density: 100.0; Flags: $1f);

This item has no description.

FSOUND_PRESET_QUARRY: TFSoundReverbProperties = (Environment: 18; EnvSize: 17.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -10000;ReflectionsDelay: 0.061; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 500; ReverbDelay: 0.025; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 0.70; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_PLAIN: TFSoundReverbProperties = (Environment: 19; EnvSize: 42.5; EnvDiffusion: 0.21; Room: -1000; RoomHF: -2000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.50; DecayLFRatio: 1.0; Reflections: -2466; ReflectionsDelay: 0.179; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1926; ReverbDelay: 0.100; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 21.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_PARKINGLOT: TFSoundReverbProperties = (Environment: 20; EnvSize: 8.3; EnvDiffusion: 1.00; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 1.65; DecayHFRatio: 1.50; DecayLFRatio: 1.0; Reflections: -1363; ReflectionsDelay: 0.008; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1153; ReverbDelay: 0.012; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);

This item has no description.

FSOUND_PRESET_SEWERPIPE: TFSoundReverbProperties = (Environment: 21; EnvSize: 1.7; EnvDiffusion: 0.80; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 2.81; DecayHFRatio: 0.14; DecayLFRatio: 1.0; Reflections: 429; ReflectionsDelay: 0.014; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1023; ReverbDelay: 0.021; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 80.0; Density: 60.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_UNDERWATER: TFSoundReverbProperties = (Environment: 22; EnvSize: 1.8; EnvDiffusion: 1.00; Room: -1000; RoomHF: -4000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -449; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1700; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 1.18; ModulationDepth: 0.348; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);

This item has no description.

FSOUND_PRESET_DRUGGED: TFSoundReverbProperties = (Environment: 23; EnvSize: 1.9; EnvDiffusion: 0.50; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 8.39; DecayHFRatio: 1.39; DecayLFRatio: 1.0; Reflections: -115; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 985; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 1.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);

Non I3DL2 presets

FSOUND_PRESET_DIZZY: TFSoundReverbProperties = (Environment: 24; EnvSize: 1.8; EnvDiffusion: 0.60; Room: -1000; RoomHF: -400; RoomLF: 0; DecayTime: 17.23; DecayHFRatio: 0.56; DecayLFRatio: 1.0; Reflections: -1713; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-613; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.81; ModulationDepth: 0.310; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);

This item has no description.

FSOUND_PRESET_PSYCHOTIC: TFSoundReverbProperties = (Environment: 25; EnvSize: 1.0; EnvDiffusion: 0.50; Room: -1000; RoomHF: -151; RoomLF: 0; DecayTime: 7.56; DecayHFRatio: 0.91; DecayLFRatio: 1.0; Reflections: -626; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 774; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 4.00; ModulationDepth: 1.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);


GLSysHelp v.2.5: FMOD.types

Unit FMOD.types

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TFSoundVector |
Record TFSoundReverbProperties |
Record TFSoundReverbChannelProperties |
Record TFSoundTOCTag |

Types

FSOUND_SPEAKERMODES = TFSoundSpeakerModes;
PFMusicModule = Pointer;
PFSoundDSPUnit = Pointer;
PFSoundSample = Pointer;
PFSoundStream = Pointer;
PFSoundVector = ˆTFSoundVector;
PFSyncPoint = Pointer;
TFMetaDataCallback = function(Name: PChar; Value: PChar; userdata: Integer): ByteBool; stdcall;
TFModErrors = (...);
TFMusicCallback = procedure (Module: PFMusicModule; Param: Byte); stdcall;
TFMusicTypes = (...);
TFSoundAllocCallback = function(Size: Cardinal): Pointer; stdcall;
TFSoundCloseCallback = procedure (Handle: Cardinal); stdcall;
TFSoundDSPCallback = function (OriginalBuffer: Pointer; NewBuffer: Pointer; Length, Param: Integer): Pointer; stdcall;
TFSoundFreeCallback = procedure(Ptr: Pointer); stdcall;
TFSoundFXModes = (...);
TFSoundMixerTypes = (...);
TFSoundOpenCallback = function (Name: PChar): Cardinal; stdcall;
TFSoundOutputTypes = (...);
TFSoundReadCallback = function (Buffer: Pointer; Size: Cardinal; Handle: Cardinal): Cardinal; stdcall;
TFSoundReallocCallback = function(Ptr: Pointer; Size: Cardinal): Pointer; stdcall;
TFSoundSeekCallback = procedure (Handle: Cardinal; Pos: Cardinal; Mode: Byte); stdcall;
TFSoundSpeakerModes = (...);
TFSoundStreamCallback = function (Stream: PFSoundStream; Buff: Pointer; Length, Param: Integer): ByteBool; stdcall;
TFSoundStreamNetStatus = (...);
TFSoundTagFieldType = (...);
TFSoundTellCallback = function (Handle: Cardinal): Cardinal; stdcall;

Constants

FMOD_VERSION: Single = 3.75;
FSOUND_DSP_DEFAULTPRIORITY_CLEARUNIT = 0;
FSOUND_DSP_DEFAULTPRIORITY_SFXUNIT = 100;
FSOUND_DSP_DEFAULTPRIORITY_MUSICUNIT = 200;
FSOUND_DSP_DEFAULTPRIORITY_USER = 300;
FSOUND_DSP_DEFAULTPRIORITY_FFTUNIT = 900;
FSOUND_DSP_DEFAULTPRIORITY_CLIPANDCOPYUNIT = 1000;
FSOUND_CAPS_HARDWARE = $1;
FSOUND_CAPS_EAX2 = $2;
FSOUND_CAPS_EAX3 = $10;
FSOUND_LOOP_OFF = $00000001;
FSOUND_LOOP_NORMAL = $00000002;
FSOUND_LOOP_BIDI = $00000004;
FSOUND_8BITS = $00000008;
FSOUND_16BITS = $00000010;
FSOUND_MONO = $00000020;
FSOUND_STEREO = $00000040;
FSOUND_UNSIGNED = $00000080;
FSOUND_SIGNED = $00000100;
FSOUND_DELTA = $00000200;
FSOUND_IT214 = $00000400;
FSOUND_IT215 = $00000800;
FSOUND_HW3D = $00001000;
FSOUND_2D = $00002000;
FSOUND_STREAMABLE = $00004000;
FSOUND_LOADMEMORY = $00008000;
FSOUND_LOADRAW = $00010000;
FSOUND_MPEGACCURATE = $00020000;
FSOUND_FORCEMONO = $00040000;
FSOUND_HW2D = $00080000;
FSOUND_ENABLEFX = $00100000;
FSOUND_MPEGHALFRATE = $00200000;
FSOUND_XADPCM = $00400000;
FSOUND_VAG = $00800000;
FSOUND_NONBLOCKING = $01000000;
FSOUND_GCADPCM = $02000000;
FSOUND_MULTICHANNEL = $04000000;
FSOUND_USECORE0 = $08000000;
FSOUND_USECORE1 = $10000000;
FSOUND_LOADMEMORYIOP = $20000000;
FSOUND_NORMAL = (FSOUND_16BITS or FSOUND_SIGNED or FSOUND_MONO);
FSOUND_CD_PLAYCONTINUOUS = 0;
FSOUND_CD_PLAYONCE = 1;
FSOUND_CD_PLAYLOOPED = 2;
FSOUND_CD_PLAYRANDOM = 3;
FSOUND_FREE = -1;
FSOUND_UNMANAGED = -2;
FSOUND_ALL = -3;
FSOUND_STEREOPAN = -1;
FSOUND_SYSTEMCHANNEL = -1000;
FSOUND_SYSTEMSAMPLE = -1000;
FSOUND_REVERBFLAGS_DECAYTIMESCALE = $00000001;
FSOUND_REVERBFLAGS_REFLECTIONSSCALE = $00000002;
FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE = $00000004;
FSOUND_REVERBFLAGS_REVERBSCALE = $00000008;
FSOUND_REVERBFLAGS_REVERBDELAYSCALE = $00000010;
FSOUND_REVERBFLAGS_DECAYHFLIMIT = $00000020;
FSOUND_REVERBFLAGS_ECHOTIMESCALE = $00000040;
FSOUND_REVERBFLAGS_MODULATIONTIMESCALE = $00000080;
FSOUND_REVERB_FLAGS_CORE0 = $00000100;
FSOUND_REVERB_FLAGS_CORE1 = $00000200;
FSOUND_REVERBFLAGS_DEFAULT = FSOUND_REVERBFLAGS_DECAYTIMESCALE or FSOUND_REVERBFLAGS_REFLECTIONSSCALE or FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE or FSOUND_REVERBFLAGS_REVERBSCALE or FSOUND_REVERBFLAGS_REVERBDELAYSCALE or FSOUND_REVERBFLAGS_DECAYHFLIMIT or FSOUND_REVERB_FLAGS_CORE0 or FSOUND_REVERB_FLAGS_CORE1;
FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO = $01;
FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO = $02;
FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO = $04;
FSOUND_REVERB_CHANNELFLAGS_DEFAULT = FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO or FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO or FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO;
FSOUND_INIT_USEDEFAULTMIDISYNTH = $01;
FSOUND_INIT_GLOBALFOCUS = $02;
FSOUND_INIT_ENABLESYSTEMCHANNELFX = $04;
FSOUND_INIT_ACCURATEVULEVELS = $08;
FSOUND_INIT_PS2_DISABLECORE0REVERB = $10;
FSOUND_INIT_PS2_DISABLECORE1REVERB = $20;
FSOUND_INIT_PS2_SWAPDMACORES = $40;
FSOUND_INIT_DONTLATENCYADJUST = $80;
FSOUND_INIT_GC_INITLIBS = $100;
FSOUND_INIT_STREAM_FROM_MAIN_THREAD = $200;
FSOUND_INIT_PS2_USEVOLUMERAMPING = $400;
FSOUND_INIT_DSOUND_DEFERRED = $800;
FSOUND_INIT_DSOUND_HRTF_LIGHT = $1000;
FSOUND_INIT_DSOUND_HRTF_FULL = $2000;
FSOUND_INIT_XBOX_REMOVEHEADROOM = $4000;
FSOUND_INIT_PSP_SILENCEONUNDERRUN = $8000;
FSOUND_PROTOCOL_SHOUTCAST = $00000001;
FSOUND_PROTOCOL_ICECAST = $00000002;
FSOUND_PROTOCOL_HTTP = $00000004;
FSOUND_FORMAT_MPEG = $00010000;
FSOUND_FORMAT_OGGVORBIS = $00020000;

Description

Types

FSOUND_SPEAKERMODES = TFSoundSpeakerModes;

The audio is played through a speaker arrangement of surround speakers with a subwoofer.

PFMusicModule = Pointer;

This item has no description.

PFSoundDSPUnit = Pointer;

This item has no description.

PFSoundSample = Pointer;

FMOD defined types

PFSoundStream = Pointer;

This item has no description.

PFSoundVector = ˆTFSoundVector;

This item has no description.

PFSyncPoint = Pointer;

This item has no description.

TFMetaDataCallback = function(Name: PChar; Value: PChar; userdata: Integer): ByteBool; stdcall;

This item has no description.

TFModErrors = (...);

[ENUM] [ [DESCRIPTION] On failure of commands in FMOD, use FSOUND_GetError to attain what happened.

[SEE_ALSO] FSOUND_GetError ]

Values
  • FMOD_ERR_NONE
  • FMOD_ERR_BUSY: No errors
  • FMOD_ERR_UNINITIALIZED: Cannot call this command after FSOUND_Init. Call FSOUND_Close first.
  • FMOD_ERR_INIT: This command failed because FSOUND_Init was not called
  • FMOD_ERR_ALLOCATED: Error initializing output device.
  • FMOD_ERR_PLAY: Error initializing output device, but more specifically, the output device is already in use and cannot be reused.
  • FMOD_ERR_OUTPUT_FORMAT: Playing the sound failed.
  • FMOD_ERR_COOPERATIVELEVEL: Soundcard does not support the features needed for this soundsystem (16bit stereo output)
  • FMOD_ERR_CREATEBUFFER: Error setting cooperative level for hardware.
  • FMOD_ERR_FILE_NOTFOUND: Error creating hardware sound buffer.
  • FMOD_ERR_FILE_FORMAT: File not found
  • FMOD_ERR_FILE_BAD: Unknown file format
  • FMOD_ERR_MEMORY: Error loading file
  • FMOD_ERR_VERSION: Not enough memory or resources
  • FMOD_ERR_INVALID_PARAM: The version number of this file format is not supported
  • FMOD_ERR_NO_EAX: An invalid parameter was passed to this function
  • FMOD_ERR_CHANNEL_ALLOC: Tried to use an EAX command on a non EAX enabled channel or output.
  • FMOD_ERR_RECORD: Failed to allocate a new channel
  • FMOD_ERR_MEDIAPLAYER: Recording is not supported on this machine
  • FMOD_ERR_CDDEVICE: Windows Media Player not installed so cannot play wma or use internet streaming. */
TFMusicCallback = procedure (Module: PFMusicModule; Param: Byte); stdcall;

This item has no description.

TFMusicTypes = (...);

[ENUM] [ [DESCRIPTION] These definitions describe the type of song being played.

[SEE_ALSO] FMUSIC_GetType ]

Values
  • FMUSIC_TYPE_NONE
  • FMUSIC_TYPE_MOD
  • FMUSIC_TYPE_S3M: Protracker / FastTracker
  • FMUSIC_TYPE_XM: ScreamTracker 3
  • FMUSIC_TYPE_IT: FastTracker 2
  • FMUSIC_TYPE_MIDI: Impulse Tracker
  • FMUSIC_TYPE_FSB: MIDI file
TFSoundAllocCallback = function(Size: Cardinal): Pointer; stdcall;

This item has no description.

TFSoundCloseCallback = procedure (Handle: Cardinal); stdcall;

This item has no description.

TFSoundDSPCallback = function (OriginalBuffer: Pointer; NewBuffer: Pointer; Length, Param: Integer): Pointer; stdcall;

This item has no description.

TFSoundFreeCallback = procedure(Ptr: Pointer); stdcall;

This item has no description.

TFSoundFXModes = (...);

[ENUM] [ [DESCRIPTION] These values are used with FSOUND_FX_Enable to enable DirectX 8 FX for a channel.

[SEE_ALSO] FSOUND_FX_Enable FSOUND_FX_Disable FSOUND_FX_SetChorus FSOUND_FX_SetCompressor FSOUND_FX_SetDistortion FSOUND_FX_SetEcho FSOUND_FX_SetFlanger FSOUND_FX_SetGargle FSOUND_FX_SetI3DL2Reverb FSOUND_FX_SetParamEQ FSOUND_FX_SetWavesReverb ]

Values
  • FSOUND_FX_CHORUS
  • FSOUND_FX_COMPRESSOR
  • FSOUND_FX_DISTORTION
  • FSOUND_FX_ECHO
  • FSOUND_FX_FLANGER
  • FSOUND_FX_GARGLE
  • FSOUND_FX_I3DL2REVERB
  • FSOUND_FX_PARAMEQ
  • FSOUND_FX_WAVES_REVERB
  • FSOUND_FX_MAX
TFSoundMixerTypes = (...);

[ENUM] [ [DESCRIPTION] These mixer types are used with FSOUND_SetMixer, to choose which mixer to use, or to act upon for other reasons using FSOUND_GetMixer. It is not necessary to set the mixer. FMOD will autodetect the best mixer for you.

[SEE_ALSO] FSOUND_SetMixer FSOUND_GetMixer ]

Values
  • FSOUND_MIXER_AUTODETECT
  • FSOUND_MIXER_BLENDMODE: CE/PS2/GC Only - Non interpolating/low quality mixer.
  • FSOUND_MIXER_MMXP5: Removed / obsolete
  • FSOUND_MIXER_MMXP6: Removed / obsolete
  • FSOUND_MIXER_QUALITY_AUTODETECT: Removed / obsolete
  • FSOUND_MIXER_QUALITY_FPU: All platforms - Autodetect the fastest quality mixer based on your cpu.
  • FSOUND_MIXER_QUALITY_MMXP5: Win32/Linux only - Interpolating/volume ramping FPU mixer.
  • FSOUND_MIXER_QUALITY_MMXP6: Win32/Linux only - Interpolating/volume ramping P5 MMX mixer.
  • FSOUND_MIXER_MONO: Win32/Linux only - Interpolating/volume ramping ppro+ MMX mixer.
  • FSOUND_MIXER_QUALITY_MONO: CE/PS2/GC only - MONO non interpolating/low quality mixer. For speed
  • FSOUND_MIXER_MAX: CE/PS2/GC only - MONO Interpolating mixer. For speed
TFSoundOpenCallback = function (Name: PChar): Cardinal; stdcall;

This item has no description.

TFSoundOutputTypes = (...);

[ENUM] [ [DESCRIPTION] These output types are used with FSOUND_SetOutput, to choose which output driver to use.

FSOUND_OUTPUT_DSOUND will not support hardware 3d acceleration if the sound card driver does not support DirectX 6 Voice Manager Extensions.

FSOUND_OUTPUT_WINMM is recommended for NT and CE.

[SEE_ALSO] FSOUND_SetOutput FSOUND_GetOutput ]

Values
  • FSOUND_OUTPUT_NOSOUND
  • FSOUND_OUTPUT_WINMM: NoSound driver, all calls to this succeed but do nothing.
  • FSOUND_OUTPUT_DSOUND: Windows Multimedia driver.
  • FSOUND_OUTPUT_A3D: DirectSound driver. You need this to get EAX2 or EAX3 support, or FX api support.
  • FSOUND_OUTPUT_OSS: A3D driver.
  • FSOUND_OUTPUT_ESD: Linux/Unix OSS (Open Sound System) driver, i.e. the kernel sound drivers.
  • FSOUND_OUTPUT_ALSA: Linux/Unix ESD (Enlightment Sound Daemon) driver.
  • FSOUND_OUTPUT_ASIO: Linux Alsa driver.
  • FSOUND_OUTPUT_XBOX: Low latency ASIO driver.
  • FSOUND_OUTPUT_PS2: Xbox driver.
  • FSOUND_OUTPUT_MAC: PlayStation 2 driver.
  • FSOUND_OUTPUT_GC: Mac SoundMager driver.
  • FSOUND_OUTPUT_PSP: Gamecube driver.
  • FSOUND_OUTPUT_NOSOUND_NONREALTIME: PlayStation Portable driver.
TFSoundReadCallback = function (Buffer: Pointer; Size: Cardinal; Handle: Cardinal): Cardinal; stdcall;

This item has no description.

TFSoundReallocCallback = function(Ptr: Pointer; Size: Cardinal): Pointer; stdcall;

This item has no description.

TFSoundSeekCallback = procedure (Handle: Cardinal; Pos: Cardinal; Mode: Byte); stdcall;

This item has no description.

TFSoundSpeakerModes = (...);

[ENUM] [ [DESCRIPTION] These are speaker types defined for use with the FSOUND_SetSpeakerMode command. Note - Only reliably works with FSOUND_OUTPUT_DSOUND or FSOUND_OUTPUT_XBOX output modes. Other output modes will only interpret FSOUND_SPEAKERMODE_MONO and set everything else to be stereo.

[SEE_ALSO] FSOUND_SetSpeakerMode

[REMARKS] Note - Only reliably works with FSOUND_OUTPUT_DSOUND or FSOUND_OUTPUT_XBOX output modes. Other output modes will only interpret FSOUND_SPEAKERMODE_MONO and set everything else to be stereo.

Using either DolbyDigital or DTS will use whatever 5.1 digital mode is available if destination hardware is unsure. ]

Values
  • FSOUND_SPEAKERMODE_DOLBYDIGITAL
  • FSOUND_SPEAKERMODE_HEADPHONES: The audio is played through a speaker arrangement of surround speakers with a subwoofer.
  • FSOUND_SPEAKERMODE_MONO: The speakers are headphones.
  • FSOUND_SPEAKERMODE_QUAD: The speakers are monaural.
  • FSOUND_SPEAKERMODE_STEREO: The speakers are quadraphonic.
  • FSOUND_SPEAKERMODE_SURROUND: The speakers are stereo (default value).
  • FSOUND_SPEAKERMODE_DTS: The speakers are surround sound.
TFSoundStreamCallback = function (Stream: PFSoundStream; Buff: Pointer; Length, Param: Integer): ByteBool; stdcall;

Callback types

TFSoundStreamNetStatus = (...);

[ENUM] [ [DESCRIPTION] Status values for internet streams. Use FSOUND_Stream_Net_GetStatus to get the current status of an internet stream.

[SEE_ALSO] FSOUND_Stream_Net_GetStatus ]

Values
  • FSOUND_STREAM_NET_NOTCONNECTED
  • FSOUND_STREAM_NET_CONNECTING: Stream hasn't connected yet
  • FSOUND_STREAM_NET_BUFFERING: Stream is connecting to remote host
  • FSOUND_STREAM_NET_READY: Stream is buffering data
  • FSOUND_STREAM_NET_ERROR: Stream is ready to play
TFSoundTagFieldType = (...);

[ENUM] [ [DESCRIPTION] Describes the type of a particular tag field.

[SEE_ALSO] FSOUND_Stream_GetNumTagFields FSOUND_Stream_GetTagField FSOUND_Stream_FindTagField ]

Values
  • FSOUND_TAGFIELD_VORBISCOMMENT
  • FSOUND_TAGFIELD_ID3V1: A vorbis comment
  • FSOUND_TAGFIELD_ID3V2: Part of an ID3v1 tag
  • FSOUND_TAGFIELD_SHOUTCAST: An ID3v2 frame
  • FSOUND_TAGFIELD_ICECAST: A SHOUTcast header line
  • FSOUND_TAGFIELD_ASF: An Icecast header line
TFSoundTellCallback = function (Handle: Cardinal): Cardinal; stdcall;

This item has no description.

Constants

FMOD_VERSION: Single = 3.75;

Force four-byte enums

FSOUND_DSP_DEFAULTPRIORITY_CLEARUNIT = 0;

[DEFINE_START] [ [NAME] FSOUND_DSP_PRIORITIES

[DESCRIPTION] These default priorities are used by FMOD internal system DSP units. They describe the position of the DSP chain, and the order of how audio processing is executed. You can actually through the use of FSOUND_DSP_GetxxxUnit (where xxx is the name of the DSP unit), disable or even change the priority of a DSP unit.

[SEE_ALSO] FSOUND_DSP_Create FSOUND_DSP_SetPriority FSOUND_DSP_GetSpectrum ]

FSOUND_DSP_DEFAULTPRIORITY_SFXUNIT = 100;

DSP CLEAR unit - done first

FSOUND_DSP_DEFAULTPRIORITY_MUSICUNIT = 200;

DSP SFX unit - done second

FSOUND_DSP_DEFAULTPRIORITY_USER = 300;

DSP MUSIC unit - done third

FSOUND_DSP_DEFAULTPRIORITY_FFTUNIT = 900;

User priority, use this as reference for your own DSP units

FSOUND_DSP_DEFAULTPRIORITY_CLIPANDCOPYUNIT = 1000;

This reads data for FSOUND_DSP_GetSpectrum, so it comes after user units

FSOUND_CAPS_HARDWARE = $1;

[DEFINE_START] [ [NAME] FSOUND_CAPS

[DESCRIPTION] Driver description bitfields. Use FSOUND_Driver_GetCaps to determine if a driver enumerated has the settings you are after. The enumerated driver depends on the output mode, see FSOUND_OUTPUTTYPES

[SEE_ALSO] FSOUND_GetDriverCaps FSOUND_OUTPUTTYPES ]

FSOUND_CAPS_EAX2 = $2;

This driver supports hardware accelerated 3d sound.

FSOUND_CAPS_EAX3 = $10;

This driver supports EAX 2 reverb

FSOUND_LOOP_OFF = $00000001;

[DEFINE_START] [ [NAME] FSOUND_MODES

[DESCRIPTION] Sample description bitfields, OR them together for loading and describing samples. NOTE. If the file format being loaded already has a defined format, such as WAV or MP3, then trying to override the pre-defined format with a new set of format flags will not work. For example, an 8 bit WAV file will not load as 16bit if you specify FSOUND_16BITS. It will just ignore the flag and go ahead loading it as 8bits. For these type of formats the only flags you can specify that will really alter the behaviour of how it is loaded, are the following.

Looping behaviour - FSOUND_LOOP_OFF, FSOUND_LOOP_NORMAL, FSOUND_LOOP_BIDI Load destination - FSOUND_HW3D, FSOUND_HW2D, FSOUND_2D Loading behaviour - FSOUND_NONBLOCKING, FSOUND_LOADMEMORY, FSOUND_LOADRAW, FSOUND_MPEGACCURATE, FSOUND_MPEGHALFRATE, FSOUND_FORCEMONO Playback behaviour - FSOUND_STREAMABLE, FSOUND_ENABLEFX PlayStation 2 only - FSOUND_USECORE0, FSOUND_USECORE1, FSOUND_LOADMEMORYIOP

See flag descriptions for what these do. ]

FSOUND_LOOP_NORMAL = $00000002;

For non looping samples.

FSOUND_LOOP_BIDI = $00000004;

For forward looping samples.

FSOUND_8BITS = $00000008;

For bidirectional looping samples. (no effect if in hardware).

FSOUND_16BITS = $00000010;

For 8 bit samples.

FSOUND_MONO = $00000020;

For 16 bit samples.

FSOUND_STEREO = $00000040;

For mono samples.

FSOUND_UNSIGNED = $00000080;

For stereo samples.

FSOUND_SIGNED = $00000100;

For user created source data containing unsigned samples.

FSOUND_DELTA = $00000200;

For user created source data containing signed data.

FSOUND_IT214 = $00000400;

For user created source data stored as delta values.

FSOUND_IT215 = $00000800;

For user created source data stored using IT214 compression.

FSOUND_HW3D = $00001000;

For user created source data stored using IT215 compression.

FSOUND_2D = $00002000;

Attempts to make samples use 3d hardware acceleration. (if the card supports it)

FSOUND_STREAMABLE = $00004000;

Ignores any 3d processing. Overrides FSOUND_HW3D. Located in software.

FSOUND_LOADMEMORY = $00008000;

For a streamimg sound where you feed the data to it. */

FSOUND_LOADRAW = $00010000;

"name" will be interpreted as a pointer to data for streaming and samples.

FSOUND_MPEGACCURATE = $00020000;

Will ignore file format and treat as raw pcm.

FSOUND_FORCEMONO = $00040000;

For FSOUND_Stream_OpenFile - for accurate FSOUND_Stream_GetLengthMs/FSOUND_Stream_SetTime. WARNING, see FSOUND_Stream_OpenFile for inital opening time performance issues.

FSOUND_HW2D = $00080000;

For forcing stereo streams and samples to be mono - needed if using FSOUND_HW3D and stereo data - incurs a small speed hit for streams

FSOUND_ENABLEFX = $00100000;

2D hardware sounds. allows hardware specific effects

FSOUND_MPEGHALFRATE = $00200000;

Allows DX8 FX to be played back on a sound. Requires DirectX 8 - Note these sounds cannot be played more than once, be 8 bit, be less than a certain size, or have a changing frequency

FSOUND_XADPCM = $00400000;

For FMODCE only - decodes mpeg streams using a lower quality decode, but faster execution

FSOUND_VAG = $00800000;

For XBOX only - Contents are compressed as XADPCM */

FSOUND_NONBLOCKING = $01000000;

For PS2 only - Contents are compressed as Sony VAG format */

FSOUND_GCADPCM = $02000000;

For FSOUND_Stream_OpenFile - Causes stream to open in the background and not block the foreground app - stream plays only when ready.

FSOUND_MULTICHANNEL = $04000000;

For Gamecube only - Contents are compressed as Gamecube DSP-ADPCM format

FSOUND_USECORE0 = $08000000;

For PS2 only - Contents are interleaved into a multi-channel (more than stereo) format

FSOUND_USECORE1 = $10000000;

For PS2 only - Sample/Stream is forced to use hardware voices 00-23

FSOUND_LOADMEMORYIOP = $20000000;

For PS2 only - Sample/Stream is forced to use hardware voices 24-47

FSOUND_NORMAL = (FSOUND_16BITS or FSOUND_SIGNED or FSOUND_MONO);

For PS2 only - "name" will be interpreted as a pointer to data for streaming and samples. The address provided will be an IOP address

FSOUND_CD_PLAYCONTINUOUS = 0;

[DEFINE_START] [ [NAME] FSOUND_CDPLAYMODES

[DESCRIPTION] Playback method for a CD Audio track, using FSOUND_CD_SetPlayMode

[SEE_ALSO] FSOUND_CD_SetPlayMode FSOUND_CD_Play ]

FSOUND_CD_PLAYONCE = 1;

Starts from the current track and plays to end of CD.

FSOUND_CD_PLAYLOOPED = 2;

Plays the specified track then stops.

FSOUND_CD_PLAYRANDOM = 3;

Plays the specified track looped, forever until stopped manually.

FSOUND_FREE = -1;

[DEFINE_START] [ [NAME] FSOUND_CHANNELSAMPLEMODE

[DESCRIPTION] Miscellaneous values for FMOD functions.

[SEE_ALSO] FSOUND_PlaySound FSOUND_PlaySoundEx FSOUND_Sample_Alloc FSOUND_Sample_Load FSOUND_SetPan ]

FSOUND_UNMANAGED = -2;

value to play on any free channel, or to allocate a sample in a free sample slot.

FSOUND_ALL = -3;

value to allocate a sample that is NOT managed by FSOUND or placed in a sample slot.

FSOUND_STEREOPAN = -1;

for a channel index , this flag will affect ALL channels available! Not supported by every function.

FSOUND_SYSTEMCHANNEL = -1000;

value for FSOUND_SetPan so that stereo sounds are not played at half volume. See FSOUND_SetPan for more on this.

FSOUND_SYSTEMSAMPLE = -1000;

special 'channel' ID for all channel based functions that want to alter the global FSOUND software mixing output

FSOUND_REVERBFLAGS_DECAYTIMESCALE = $00000001;

[DEFINE_START] [ [NAME] FSOUND_REVERB_FLAGS

[DESCRIPTION] Values for the Flags member of the FSOUND_REVERB_PROPERTIES structure.

[SEE_ALSO] FSOUND_REVERB_PROPERTIES ]

FSOUND_REVERBFLAGS_REFLECTIONSSCALE = $00000002;

EnvironmentSize affects reverberation decay time

FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE = $00000004;

EnvironmentSize affects reflection level

FSOUND_REVERBFLAGS_REVERBSCALE = $00000008;

EnvironmentSize affects initial reflection delay time

FSOUND_REVERBFLAGS_REVERBDELAYSCALE = $00000010;

EnvironmentSize affects reflections level

FSOUND_REVERBFLAGS_DECAYHFLIMIT = $00000020;

EnvironmentSize affects late reverberation delay time

FSOUND_REVERBFLAGS_ECHOTIMESCALE = $00000040;

AirAbsorptionHF affects DecayHFRatio

FSOUND_REVERBFLAGS_MODULATIONTIMESCALE = $00000080;

EnvironmentSize affects echo time

FSOUND_REVERB_FLAGS_CORE0 = $00000100;

EnvironmentSize affects modulation time

FSOUND_REVERB_FLAGS_CORE1 = $00000200;

PS2 Only - Reverb is applied to CORE0 (hw voices 0-23)

FSOUND_REVERBFLAGS_DEFAULT = FSOUND_REVERBFLAGS_DECAYTIMESCALE or FSOUND_REVERBFLAGS_REFLECTIONSSCALE or FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE or FSOUND_REVERBFLAGS_REVERBSCALE or FSOUND_REVERBFLAGS_REVERBDELAYSCALE or FSOUND_REVERBFLAGS_DECAYHFLIMIT or FSOUND_REVERB_FLAGS_CORE0 or FSOUND_REVERB_FLAGS_CORE1;

PS2 Only - Reverb is applied to CORE1 (hw voices 24-47)

FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO = $01;

[DEFINE_START] [ [NAME] FSOUND_REVERB_CHANNELFLAGS

[DESCRIPTION] Values for the Flags member of the FSOUND_REVERB_CHANNELPROPERTIES structure.

[SEE_ALSO] FSOUND_REVERB_CHANNELPROPERTIES ]

FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO = $02;

Automatic setting of 'Direct' due to distance from listener

FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO = $04;

Automatic setting of 'Room' due to distance from listener

FSOUND_REVERB_CHANNELFLAGS_DEFAULT = FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO or FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO or FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO;

Automatic setting of 'RoomHF' due to distance from listener

FSOUND_INIT_USEDEFAULTMIDISYNTH = $01;

[DEFINE_START] [ [NAME] FSOUND_INIT_FLAGS

[DESCRIPTION] Initialization flags. Use them with FSOUND_Init in the flags parameter to change various behaviour.

FSOUND_INIT_ENABLESYSTEMCHANNELFX Is an init mode which enables the FSOUND mixer buffer to be affected by DirectX 8 effects. Note that due to limitations of DirectSound, FSOUND_Init may fail if this is enabled because the buffersize is too small. This can be fixed with FSOUND_SetBufferSize. Increase the BufferSize until it works. When it is enabled you can use the FSOUND_FX api, and use FSOUND_SYSTEMCHANNEL as the channel id when setting parameters.

[SEE_ALSO] FSOUND_Init ]

FSOUND_INIT_GLOBALFOCUS = $02;

Causes MIDI playback to force software decoding.

FSOUND_INIT_ENABLESYSTEMCHANNELFX = $04;

For DirectSound output - sound is not muted when window is out of focus.

FSOUND_INIT_ACCURATEVULEVELS = $08;

For DirectSound output - Allows FSOUND_FX api to be used on global software mixer output!

FSOUND_INIT_PS2_DISABLECORE0REVERB = $10;

This latency adjusts FSOUND_GetCurrentLevels, but incurs a small cpu and memory hit.

FSOUND_INIT_PS2_DISABLECORE1REVERB = $20;

PS2 only - Disable reverb on CORE 0 to regain SRAM.

FSOUND_INIT_PS2_SWAPDMACORES = $40;

PS2 only - Disable reverb on CORE 1 to regain SRAM.

FSOUND_INIT_DONTLATENCYADJUST = $80;

PS2 only - By default FMOD uses DMA CH0 for mixing, CH1 for uploads, this flag swaps them around.

FSOUND_INIT_GC_INITLIBS = $100;

Callbacks are not latency adjusted, and are called at mix time. Also information functions are immediate.

FSOUND_INIT_STREAM_FROM_MAIN_THREAD = $200;

Gamecube only - Initializes GC audio libraries.

FSOUND_INIT_PS2_USEVOLUMERAMPING = $400;

Turns off fmod streamer thread, and makes streaming update from FSOUND_Update called by the user.

FSOUND_INIT_DSOUND_DEFERRED = $800;

PS2 only - Turns on volume ramping system to remove hardware clicks.

FSOUND_INIT_DSOUND_HRTF_LIGHT = $1000;

Win32 only - For DirectSound output. 3D commands are batched together and executed at FSOUND_Update.

FSOUND_INIT_DSOUND_HRTF_FULL = $2000;

Win32 only - For DirectSound output. FSOUND_HW3D buffers use a slightly higher quality algorithm when 3d hardware acceleration is not present.

FSOUND_INIT_XBOX_REMOVEHEADROOM = $4000;

Win32 only - For DirectSound output. FSOUND_HW3D buffers use full quality 3d playback when 3d hardware acceleration is not present.

FSOUND_INIT_PSP_SILENCEONUNDERRUN = $8000;

XBox only - By default directsound attenuates all sound by 6db to avoid clipping/distortion. CAUTION. If you use this flag you are responsible for the final mix to make sure clipping / distortion doesn't happen.

FSOUND_PROTOCOL_SHOUTCAST = $00000001;

[DEFINE_START] [ [NAME] FSOUND_STATUS_FLAGS

[DESCRIPTION] These values describe the protocol and format of an internet stream. Use FSOUND_Stream_Net_GetStatus to retrieve this information for an open internet stream.

[SEE_ALSO] FSOUND_Stream_Net_GetStatus ]

FSOUND_PROTOCOL_ICECAST = $00000002;

This item has no description.

FSOUND_PROTOCOL_HTTP = $00000004;

This item has no description.

FSOUND_FORMAT_MPEG = $00010000;

This item has no description.

FSOUND_FORMAT_OGGVORBIS = $00020000;


GLSysHelp v.2.5: FMOD.types: Record TFSoundVector

Record TFSoundVector

Description
Hierarchy
Fields
Methods
Properties

Unit

FMOD.types

Declaration

type TFSoundVector = record

Description

This item has no description.

Overview

Fields

Public | x: Single;
Public | y: Single;
Public | z: Single;

Description

Fields

Public x: Single;

This item has no description.

Public y: Single;

This item has no description.

Public z: Single;


GLSysHelp v.2.5: FMOD.types: Record TFSoundReverbProperties

Record TFSoundReverbProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

FMOD.types

Declaration

type TFSoundReverbProperties = record

Description

[STRUCT_START] [ [NAME] FSOUND_REVERB_PROPERTIES

[DESCRIPTION] Structure defining a reverb environment.

[REMARKS] For more indepth descriptions of the reverb properties under win32, please see the EAX2/EAX3 documentation at http://developer.creative.com/ under the 'downloads' section. If they do not have the EAX3 documentation, then most information can be attained from the EAX2 documentation, as EAX3 only adds some more parameters and functionality on top of EAX2. Note the default reverb properties are the same as the FSOUND_PRESET_GENERIC preset. Note that integer values that typically range from -10,000 to 1000 are represented in decibels, and are of a logarithmic scale, not linear, wheras float values are typically linear. PORTABILITY: Each member has the platform it supports in braces ie (win32/xbox). Some reverb parameters are only supported in win32 and some only on xbox. If all parameters are set then the reverb should product a similar effect on either platform. Only WIN32 supports the reverb api.

The numerical values listed below are the maximum, minimum and default values for each variable respectively.

[SEE_ALSO] FSOUND_Reverb_SetProperties FSOUND_Reverb_GetProperties FSOUND_REVERB_PRESETS FSOUND_REVERB_FLAGS ]

Overview

Fields

Public | Environment: Cardinal;
Public | EnvSize: Single;
Public | EnvDiffusion: Single;
Public | Room: Integer;
Public | RoomHF: Integer;
Public | RoomLF: Integer;
Public | DecayTime: Single;
Public | DecayHFRatio: Single;
Public | DecayLFRatio: Single;
Public | Reflections: Integer;
Public | ReflectionsDelay: Single;
Public | ReflectionsPan: array [0..2] of Single;
Public | Reverb: Integer;
Public | ReverbDelay: Single;
Public | ReverbPan: array [0..2] of Single;
Public | EchoTime: Single;
Public | EchoDepth: Single;
Public | ModulationTime: Single;
Public | ModulationDepth: Single;
Public | AirAbsorptionHF: Single;
Public | HFReference: Single;
Public | LFReference: Single;
Public | RoomRolloffFactor: Single;
Public | Diffusion: Single;
Public | Density: Single;
Public | Flags: Cardinal;

Description

Fields

Public Environment: Cardinal;

MIN MAX DEFAULT DESCRIPTION

Public EnvSize: Single;

0 25 0 sets all listener properties (win32 only)

Public EnvDiffusion: Single;

1.0 100.0 7.5 environment size in meters (win32 only)

Public Room: Integer;

0.0 1.0 1.0 environment diffusion (win32/xbox)

Public RoomHF: Integer;

-10000 0 -1000 room effect level (at mid frequencies) (win32/xbox)

Public RoomLF: Integer;

-10000 0 -100 relative room effect level at high frequencies (win32/xbox)

Public DecayTime: Single;

-10000 0 0 relative room effect level at low frequencies (win32 only)

Public DecayHFRatio: Single;

0.1 20.0 1.49 reverberation decay time at mid frequencies (win32/xbox)

Public DecayLFRatio: Single;

0.1 2.0 0.83 high-frequency to mid-frequency decay time ratio (win32/xbox)

Public Reflections: Integer;

0.1 2.0 1.0 low-frequency to mid-frequency decay time ratio (win32 only)

Public ReflectionsDelay: Single;

-10000 1000 -2602 early reflections level relative to room effect (win32/xbox)

Public ReflectionsPan: array [0..2] of Single;

0.0 0.3 0.007 initial reflection delay time (win32/xbox)

Public Reverb: Integer;

0,0,0 early reflections panning vector (win32 only)

Public ReverbDelay: Single;

-10000 2000 200 late reverberation level relative to room effect (win32/xbox)

Public ReverbPan: array [0..2] of Single;

0.0 0.1 0.011 late reverberation delay time relative to initial reflection (win32/xbox)

Public EchoTime: Single;

0,0,0 late reverberation panning vector (win32 only)

Public EchoDepth: Single;

.075 0.25 0.25 echo time (win32 only)

Public ModulationTime: Single;

0.0 1.0 0.0 echo depth (win32 only)

Public ModulationDepth: Single;

0.04 4.0 0.25 modulation time (win32 only)

Public AirAbsorptionHF: Single;

0.0 1.0 0.0 modulation depth (win32 only)

Public HFReference: Single;

-100 0.0 -5.0 change in level per meter at high frequencies (win32 only)

Public LFReference: Single;

1000.0 20000 5000.0 reference high frequency (hz) (win32/xbox)

Public RoomRolloffFactor: Single;

20.0 1000.0 250.0 reference low frequency (hz) (win32 only)

Public Diffusion: Single;

0.0 10.0 0.0 like FSOUND_3D_SetRolloffFactor but for room effect (win32/xbox)

Public Density: Single;

0.0 100.0 100.0 Value that controls the echo density in the late reverberation decay. (xbox only)

Public Flags: Cardinal;

0.0 100.0 100.0 Value that controls the modal density in the late reverberation decay (xbox only)


GLSysHelp v.2.5: FMOD.types: Record TFSoundReverbChannelProperties

Record TFSoundReverbChannelProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

FMOD.types

Declaration

type TFSoundReverbChannelProperties = record

Description

[STRUCTURE] [ [DESCRIPTION] Structure defining the properties for a reverb source, related to a FSOUND channel. For more indepth descriptions of the reverb properties under win32, please see the EAX3 documentation at http://developer.creative.com/ under the 'downloads' section. If they do not have the EAX3 documentation, then most information can be attained from the EAX2 documentation, as EAX3 only adds some more parameters and functionality on top of EAX2.

Note the default reverb properties are the same as the FSOUND_PRESET_GENERIC preset. Note that integer values that typically range from -10,000 to 1000 are represented in decibels, and are of a logarithmic scale, not linear, wheras float values are typically linear. PORTABILITY: Each member has the platform it supports in braces ie (win32/xbox). Some reverb parameters are only supported in win32 and some only on xbox. If all parameters are set then the reverb should product a similar effect on either platform. Linux and FMODCE do not support the reverb api.

The numerical values listed below are the maximum, minimum and default values for each variable respectively.

[SEE_ALSO] FSOUND_Reverb_SetChannelProperties FSOUND_Reverb_GetChannelProperties FSOUND_REVERB_CHANNELFLAGS ]

Overview

Fields

Public | Direct: Integer;
Public | DirectHF: Integer;
Public | Room: Integer;
Public | RoomHF: Integer;
Public | Obstruction: Integer;
Public | ObstructionLFRatio: Single;
Public | Occlusion: Integer;
Public | OcclusionLFRatio: Single;
Public | OcclusionRoomRatio: Single;
Public | OcclusionDirectRatio: Single;
Public | Exclusion: Integer;
Public | ExclusionLFRatio: Single;
Public | OutsideVolumeHF: Integer;
Public | DopplerFactor: Single;
Public | RolloffFactor: Single;
Public | RoomRolloffFactor: Single;
Public | AirAbsorptionFactor: Single;
Public | Flags: Integer;

Description

Fields

Public Direct: Integer;

MIN MAX DEFAULT

Public DirectHF: Integer;

-10000 1000 0 direct path level (at low and mid frequencies) (win32/xbox)

Public Room: Integer;

-10000 0 0 relative direct path level at high frequencies (win32/xbox)

Public RoomHF: Integer;

-10000 1000 0 room effect level (at low and mid frequencies) (win32/xbox)

Public Obstruction: Integer;

-10000 0 0 relative room effect level at high frequencies (win32/xbox)

Public ObstructionLFRatio: Single;

-10000 0 0 main obstruction control (attenuation at high frequencies) (win32/xbox)

Public Occlusion: Integer;

0.0 1.0 0.0 obstruction low-frequency level re. main control (win32/xbox)

Public OcclusionLFRatio: Single;

-10000 0 0 main occlusion control (attenuation at high frequencies) (win32/xbox)

Public OcclusionRoomRatio: Single;

0.0 1.0 0.25 occlusion low-frequency level re. main control (win32/xbox)

Public OcclusionDirectRatio: Single;

0.0 10.0 1.5 relative occlusion control for room effect (win32)

Public Exclusion: Integer;

0.0 10.0 1.0 relative occlusion control for direct path (win32)

Public ExclusionLFRatio: Single;

-10000 0 0 main exlusion control (attenuation at high frequencies) (win32)

Public OutsideVolumeHF: Integer;

0.0 1.0 1.0 exclusion low-frequency level re. main control (win32)

Public DopplerFactor: Single;

-10000 0 0 outside sound cone level at high frequencies (win32)

Public RolloffFactor: Single;

0.0 10.0 0.0 like DS3D flDopplerFactor but per source (win32)

Public RoomRolloffFactor: Single;

0.0 10.0 0.0 like DS3D flRolloffFactor but per source (win32)

Public AirAbsorptionFactor: Single;

0.0 10.0 0.0 like DS3D flRolloffFactor but for room effect (win32/xbox)

Public Flags: Integer;

0.0 10.0 1.0 multiplies AirAbsorptionHF member of FSOUND_REVERB_PROPERTIES (win32)


GLSysHelp v.2.5: FMOD.types: Record TFSoundTOCTag

Record TFSoundTOCTag

Description
Hierarchy
Fields
Methods
Properties

Unit

FMOD.types

Declaration

type TFSoundTOCTag = record

Description

[STRUCTURE] [ [DESCRIPTION] Structure defining a CD table of contents. This structure is returned as a tag from FSOUND_Stream_FindTagField when the tag name "CD_TOC" is specified. Note: All tracks on the CD - including data tracks- will be represented in this structure so it's use for anything other than generating disc id information is not recommended. See the cdda example program for info on retrieving and using this structure.

[SEE_ALSO] FSOUND_Stream_Open FSOUND_Stream_FindTagField ]

Overview

Fields

Public | Name: array [0..3] of AnsiChar;
Public | NumTracks: Integer;
Public | Min: array [0..99] of Integer;
Public | Sec: array [0..99] of Integer;
Public | Frame: array [0..99] of Integer;

Description

Fields

Public Name: array [0..3] of AnsiChar;

This item has no description.

Public NumTracks: Integer;

The string "TOC" (4th character is 0), just in case this structure is accidentally treated as a string.

Public Min: array [0..99] of Integer;

The number of tracks on the CD.

Public Sec: array [0..99] of Integer;

The start offset of each track in minutes.

Public Frame: array [0..99] of Integer;

The start offset of each track in seconds.


GLSysHelp v.2.5: FmSceneEditor

Unit FmSceneEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • WinApi.Windows
  • System.Classes
  • System.SysUtils
  • System.Win.Registry
  • System.ImageList
  • System.Actions
  • VCL.ActnList
  • VCL.Controls
  • VCL.Forms
  • VCL.ComCtrls
  • VCL.ImgList
  • VCL.Dialogs
  • VCL.Menus
  • VCL.ToolWin
  • VCL.ExtCtrls
  • VCL.StdCtrls
  • VCL.ClipBrd
  • DesignIntf
  • VCLEditors
  • GLS.Scene
  • GLS.SceneViewer
  • GLScene.Strings
  • FmInfo
  • GLScene.XCollection
  • GLScene.Utils
  • GLS.SceneRegister

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSceneEditorForm |

Functions and Procedures

function GLSceneEditorForm: TGLSceneEditorForm;
procedure ReleaseGLSceneEditorForm;

Types

TSetSubItemsEvent = procedure(Sender: TObject) of object;

Constants

SCENE_SELECTED = 0;
BEHAVIOURS_SELECTED = 1;
EFFECTS_SELECTED = 2;

Description

Functions and Procedures

function GLSceneEditorForm: TGLSceneEditorForm;

This item has no description.

procedure ReleaseGLSceneEditorForm;

This item has no description.

Types

TSetSubItemsEvent = procedure(Sender: TObject) of object;

This item has no description.

Constants

SCENE_SELECTED = 0;

This item has no description.

BEHAVIOURS_SELECTED = 1;

This item has no description.

EFFECTS_SELECTED = 2;


GLSysHelp v.2.5: FmSceneEditor: Class TGLSceneEditorForm

Class TGLSceneEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmSceneEditor

Declaration

type TGLSceneEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLSceneEditorForm

Overview

Fields

Public | PopupMenu: TPopupMenu;
Public | MIAddObject: TMenuItem;
Public | N1: TMenuItem;
Public | MIDelObject: TMenuItem;
Public | ToolBar: TToolBar;
Public | ActionList: TActionList;
Public | TBAddObjects: TToolButton;
Public | TBMoveUp: TToolButton;
Public | pmToolBar: TPopupMenu;
Public | TBDeleteObject: TToolButton;
Public | TBMoveDown: TToolButton;
Public | acAddObject: TAction;
Public | ImageList: TImageList;
Public | acDeleteObject: TAction;
Public | acMoveUp: TAction;
Public | acMoveDown: TAction;
Public | N2: TMenuItem;
Public | MIMoveUp: TMenuItem;
Public | MIMoveDown: TMenuItem;
Public | acSaveScene: TAction;
Public | acLoadScene: TAction;
Public | OpenDialog: TOpenDialog;
Public | SaveDialog: TSaveDialog;
Public | TBLoadScene: TToolButton;
Public | TBSaveScene: TToolButton;
Public | acInfo: TAction;
Public | acCopy: TAction;
Public | acCut: TAction;
Public | acPaste: TAction;
Public | MICopy: TMenuItem;
Public | MIPaste: TMenuItem;
Public | MICut: TMenuItem;
Public | TBCut: TToolButton;
Public | TBCopy: TToolButton;
Public | TBPaste: TToolButton;
Public | pmBehavioursToolbar: TPopupMenu;
Public | acAddBehaviour: TAction;
Public | MIAddBehaviour: TMenuItem;
Public | MIAddEffect: TMenuItem;
Public | MIBehaviourSeparator: TMenuItem;
Public | acDeleteBehaviour: TAction;
Public | pmBehaviours: TPopupMenu;
Public | Delete1: TMenuItem;
Public | MoveUp1: TMenuItem;
Public | MoveDown1: TMenuItem;
Public | N4: TMenuItem;
Public | pmEffectsToolbar: TPopupMenu;
Public | acAddEffect: TAction;
Public | TBCharacterPanels: TToolButton;
Public | TBStayOnTop: TToolButton;
Public | acStayOnTop: TAction;
Public | TBSeparator4: TToolButton;
Public | TBExpand: TToolButton;
Public | acExpand: TAction;
Public | PATreeAll: TPanel;
Public | PATree: TPanel;
Public | Tree: TTreeView;
Public | TBInfo: TToolButton;
Public | PABehaviours: TPanel;
Public | ToolBarBehaviours: TToolBar;
Public | TBAddBehaviours: TToolButton;
Public | BehavioursListView: TListView;
Public | PAEffects: TPanel;
Public | EffectsListView: TListView;
Public | ToolBarEffects: TToolBar;
Public | TBAddEffects: TToolButton;
Public | TBGalleryPanel: TToolButton;
Public | TreeAll: TTreeView;
Private | FSelectedItems: Integer;
Private | FScene: TGLScene;
Private | FObjectNode: TTreeNode;
Private | FSceneObjects: TTreeNode;
Private | FCurrentDesigner: IDesigner;
Private | FLastMouseDownPos: TPoint;
Private | FPasteOwner: TComponent;
Private | FPasteSelection: IDesignerSelections;

Methods

Private | function AddNodes(ANode: TTreeNode; AObject: TGLBaseSceneObject): TTreeNode;
Private | function AddNodesAll(ANode: TTreeNode; AObject: TGLBaseSceneObject): TTreeNode;
Private | function CanPaste(obj, destination: TGLBaseSceneObject): Boolean;
Private | function IsPastePossible: Boolean;
Private | function IsValidClipBoardNode: Boolean;
Private | function PasteComponents(AOwner, AParent: TComponent; const Components: IDesignerSelections): Boolean;
Private | function UniqueName(Component: TComponent): string;
Public | procedure acAddBehaviourExecute(Sender: TObject);
Public | procedure acAddEffectExecute(Sender: TObject);
Public | procedure acAddObjectExecute(Sender: TObject);
Public | procedure acCopyExecute(Sender: TObject);
Public | procedure acCutExecute(Sender: TObject);
Public | procedure acDeleteObjectExecute(Sender: TObject);
Public | procedure acExpandExecute(Sender: TObject);
Public | procedure acInfoExecute(Sender: TObject);
Public | procedure acLoadSceneExecute(Sender: TObject);
Public | procedure acMoveDownExecute(Sender: TObject);
Public | procedure acMoveUpExecute(Sender: TObject);
Public | procedure acPasteExecute(Sender: TObject);
Public | procedure acSaveSceneExecute(Sender: TObject);
Public | procedure acStayOnTopExecute(Sender: TObject);
Public | procedure BehavioursListViewEnter(Sender: TObject);
Public | procedure BehavioursListViewSelectItem(Sender: TObject; Item: TListItem; Selected: Boolean);
Public | procedure DeleteBaseBehaviour(ListView: TListView);
Public | procedure EffectsListViewEnter(Sender: TObject);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormDestroy(Sender: TObject);
Public | procedure FormKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Public | procedure pmBehavioursToolbarPopup(Sender: TObject);
Public | procedure pmEffectsToolbarPopup(Sender: TObject);
Public | procedure PopupMenuPopup(Sender: TObject);
Public | procedure SetScene(Scene: TGLScene; Designer: IDesigner);
Public | procedure TBCharacterPanelsClick(Sender: TObject);
Public | procedure TreeAllChange(Sender: TObject; Node: TTreeNode);
Public | procedure TreeChange(Sender: TObject; Node: TTreeNode);
Public | procedure TreeDragDrop(Sender, Source: TObject; X, Y: Integer);
Public | procedure TreeDragOver(Sender, Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean);
Public | procedure TreeEditing(Sender: TObject; Node: TTreeNode; var AllowEdit: Boolean);
Public | procedure TreeEnter(Sender: TObject);
Public | procedure TreeKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Public | procedure TreeMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure TreeMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Private | procedure AddBehaviourClick(Sender: TObject);
Private | procedure AddEffectClick(Sender: TObject);
Private | procedure AddObjectClick(Sender: TObject);
Private | procedure ComponentRead(Component: TComponent);
Private | procedure CopyComponents(Root: TComponent; const Components: IDesignerSelections);
Private | procedure EnableAndDisableActions();
Private | procedure MethodError(Reader: TReader; const MethodName: string; var Address: Pointer; var Error: Boolean);
Private | procedure OnBaseSceneObjectNameChanged(Sender: TObject);
Private | procedure ReaderSetName(Reader: TReader; Component: TComponent; var Name: string);
Private | procedure ReadScene;
Private | procedure ResetTree;
Private | procedure SetBehavioursSubItems(parent: TMenuItem; XCollection: TXCollection);
Private | procedure SetEffectsSubItems(parent: TMenuItem; XCollection: TXCollection);
Private | procedure SetObjectsSubItems(parent: TMenuItem);
Private | procedure SetXCollectionSubItems(parent: TMenuItem; XCollection: TXCollection; Event: TSetSubItemsEvent);
Private | procedure ShowBehaviours(BaseSceneObject: TGLBaseSceneObject);
Private | procedure ShowBehavioursAndEffects(BaseSceneObject: TGLBaseSceneObject);
Private | procedure ShowEffects(BaseSceneObject: TGLBaseSceneObject);
Private | procedure TreeEdited(Sender: TObject; Node: TTreeNode; var S: string);

Description

Fields

Public PopupMenu: TPopupMenu;

This item has no description.

Public MIAddObject: TMenuItem;

This item has no description.

Public N1: TMenuItem;

This item has no description.

Public MIDelObject: TMenuItem;

This item has no description.

Public ToolBar: TToolBar;

This item has no description.

Public ActionList: TActionList;

This item has no description.

Public TBAddObjects: TToolButton;

This item has no description.

Public TBMoveUp: TToolButton;

This item has no description.

Public pmToolBar: TPopupMenu;

This item has no description.

Public TBDeleteObject: TToolButton;

This item has no description.

Public TBMoveDown: TToolButton;

This item has no description.

Public acAddObject: TAction;

This item has no description.

Public ImageList: TImageList;

This item has no description.

Public acDeleteObject: TAction;

This item has no description.

Public acMoveUp: TAction;

This item has no description.

Public acMoveDown: TAction;

This item has no description.

Public N2: TMenuItem;

This item has no description.

Public MIMoveUp: TMenuItem;

This item has no description.

Public MIMoveDown: TMenuItem;

This item has no description.

Public acSaveScene: TAction;

This item has no description.

Public acLoadScene: TAction;

This item has no description.

Public OpenDialog: TOpenDialog;

This item has no description.

Public SaveDialog: TSaveDialog;

This item has no description.

Public TBLoadScene: TToolButton;

This item has no description.

Public TBSaveScene: TToolButton;

This item has no description.

Public acInfo: TAction;

This item has no description.

Public acCopy: TAction;

This item has no description.

Public acCut: TAction;

This item has no description.

Public acPaste: TAction;

This item has no description.

Public MICopy: TMenuItem;

This item has no description.

Public MIPaste: TMenuItem;

This item has no description.

Public MICut: TMenuItem;

This item has no description.

Public TBCut: TToolButton;

This item has no description.

Public TBCopy: TToolButton;

This item has no description.

Public TBPaste: TToolButton;

This item has no description.

Public pmBehavioursToolbar: TPopupMenu;

This item has no description.

Public acAddBehaviour: TAction;

This item has no description.

Public MIAddBehaviour: TMenuItem;

This item has no description.

Public MIAddEffect: TMenuItem;

This item has no description.

Public MIBehaviourSeparator: TMenuItem;

This item has no description.

Public acDeleteBehaviour: TAction;

This item has no description.

Public pmBehaviours: TPopupMenu;

This item has no description.

Public Delete1: TMenuItem;

This item has no description.

Public MoveUp1: TMenuItem;

This item has no description.

Public MoveDown1: TMenuItem;

This item has no description.

Public N4: TMenuItem;

This item has no description.

Public pmEffectsToolbar: TPopupMenu;

This item has no description.

Public acAddEffect: TAction;

This item has no description.

Public TBCharacterPanels: TToolButton;

This item has no description.

Public TBStayOnTop: TToolButton;

This item has no description.

Public acStayOnTop: TAction;

This item has no description.

Public TBSeparator4: TToolButton;

This item has no description.

Public TBExpand: TToolButton;

This item has no description.

Public acExpand: TAction;

This item has no description.

Public PATreeAll: TPanel;

This item has no description.

Public PATree: TPanel;

This item has no description.

Public Tree: TTreeView;

This item has no description.

Public TBInfo: TToolButton;

This item has no description.

Public PABehaviours: TPanel;

This item has no description.

Public ToolBarBehaviours: TToolBar;

This item has no description.

Public TBAddBehaviours: TToolButton;

This item has no description.

Public BehavioursListView: TListView;

This item has no description.

Public PAEffects: TPanel;

This item has no description.

Public EffectsListView: TListView;

This item has no description.

Public ToolBarEffects: TToolBar;

This item has no description.

Public TBAddEffects: TToolButton;

This item has no description.

Public TBGalleryPanel: TToolButton;

This item has no description.

Public TreeAll: TTreeView;

This item has no description.

Private FSelectedItems: Integer;

This item has no description.

Private FScene: TGLScene;

This item has no description.

Private FObjectNode: TTreeNode;

This item has no description.

Private FSceneObjects: TTreeNode;

This item has no description.

Private FCurrentDesigner: IDesigner;

This item has no description.

Private FLastMouseDownPos: TPoint;

This item has no description.

Private FPasteOwner: TComponent;

This item has no description.

Private FPasteSelection: IDesignerSelections;

This item has no description.

Methods

Private function AddNodes(ANode: TTreeNode; AObject: TGLBaseSceneObject): TTreeNode;

Adds the given scene object as well as its children to the Tree and returns the last add node (e.g. for selection)

Private function AddNodesAll(ANode: TTreeNode; AObject: TGLBaseSceneObject): TTreeNode;

Adds All scene objects to the TreeAll the same as in menu toolbar TBAddObjects for moving selection to current list of active objects in Tree

Private function CanPaste(obj, destination: TGLBaseSceneObject): Boolean;

This item has no description.

Private function IsPastePossible: Boolean;

This item has no description.

Private function IsValidClipBoardNode: Boolean;

This item has no description.

Private function PasteComponents(AOwner, AParent: TComponent; const Components: IDesignerSelections): Boolean;

This item has no description.

Private function UniqueName(Component: TComponent): string;

This item has no description.

Public procedure acAddBehaviourExecute(Sender: TObject);

This item has no description.

Public procedure acAddEffectExecute(Sender: TObject);

This item has no description.

Public procedure acAddObjectExecute(Sender: TObject);

This item has no description.

Public procedure acCopyExecute(Sender: TObject);

This item has no description.

Public procedure acCutExecute(Sender: TObject);

This item has no description.

Public procedure acDeleteObjectExecute(Sender: TObject);

This item has no description.

Public procedure acExpandExecute(Sender: TObject);

This item has no description.

Public procedure acInfoExecute(Sender: TObject);

This item has no description.

Public procedure acLoadSceneExecute(Sender: TObject);

This item has no description.

Public procedure acMoveDownExecute(Sender: TObject);

This item has no description.

Public procedure acMoveUpExecute(Sender: TObject);

This item has no description.

Public procedure acPasteExecute(Sender: TObject);

This item has no description.

Public procedure acSaveSceneExecute(Sender: TObject);

This item has no description.

Public procedure acStayOnTopExecute(Sender: TObject);

This item has no description.

Public procedure BehavioursListViewEnter(Sender: TObject);

This item has no description.

Public procedure BehavioursListViewSelectItem(Sender: TObject; Item: TListItem; Selected: Boolean);

This item has no description.

Public procedure DeleteBaseBehaviour(ListView: TListView);

This item has no description.

Public procedure EffectsListViewEnter(Sender: TObject);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure FormKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

This item has no description.

Public procedure pmBehavioursToolbarPopup(Sender: TObject);

This item has no description.

Public procedure pmEffectsToolbarPopup(Sender: TObject);

This item has no description.

Public procedure PopupMenuPopup(Sender: TObject);

This item has no description.

Public procedure SetScene(Scene: TGLScene; Designer: IDesigner);

This item has no description.

Public procedure TBCharacterPanelsClick(Sender: TObject);

This item has no description.

Public procedure TreeAllChange(Sender: TObject; Node: TTreeNode);

This item has no description.

Public procedure TreeChange(Sender: TObject; Node: TTreeNode);

or onclick to simply select

Public procedure TreeDragDrop(Sender, Source: TObject; X, Y: Integer);

This item has no description.

Public procedure TreeDragOver(Sender, Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean);

This item has no description.

Public procedure TreeEditing(Sender: TObject; Node: TTreeNode; var AllowEdit: Boolean);

This item has no description.

Public procedure TreeEnter(Sender: TObject);

This item has no description.

Public procedure TreeKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

This item has no description.

Public procedure TreeMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure TreeMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

This item has no description.

Private procedure AddBehaviourClick(Sender: TObject);

This item has no description.

Private procedure AddEffectClick(Sender: TObject);

This item has no description.

Private procedure AddObjectClick(Sender: TObject);

This item has no description.

Private procedure ComponentRead(Component: TComponent);

This item has no description.

Private procedure CopyComponents(Root: TComponent; const Components: IDesignerSelections);

This item has no description.

Private procedure EnableAndDisableActions();

This item has no description.

Private procedure MethodError(Reader: TReader; const MethodName: string; var Address: Pointer; var Error: Boolean);

This item has no description.

Private procedure OnBaseSceneObjectNameChanged(Sender: TObject);

This item has no description.

Private procedure ReaderSetName(Reader: TReader; Component: TComponent; var Name: string);

This item has no description.

Private procedure ReadScene;

This item has no description.

Private procedure ResetTree;

This item has no description.

Private procedure SetBehavioursSubItems(parent: TMenuItem; XCollection: TXCollection);

This item has no description.

Private procedure SetEffectsSubItems(parent: TMenuItem; XCollection: TXCollection);

This item has no description.

Private procedure SetObjectsSubItems(parent: TMenuItem);

This item has no description.

Private procedure SetXCollectionSubItems(parent: TMenuItem; XCollection: TXCollection; Event: TSetSubItemsEvent);

This item has no description.

Private procedure ShowBehaviours(BaseSceneObject: TGLBaseSceneObject);

This item has no description.

Private procedure ShowBehavioursAndEffects(BaseSceneObject: TGLBaseSceneObject);

This item has no description.

Private procedure ShowEffects(BaseSceneObject: TGLBaseSceneObject);

This item has no description.

Private procedure TreeEdited(Sender: TObject; Node: TTreeNode; var S: string);

We can not use the IDE to define this event because the prototype is not the same between Delphi and Kylix !!


GLSysHelp v.2.5: FmShaderMemo

Unit FmShaderMemo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.SysUtils
  • System.Variants
  • System.Classes
  • System.Win.Registry
  • VCL.Controls
  • VCL.Forms
  • VCL.ComCtrls
  • VCL.ImgList
  • VCL.Dialogs
  • VCL.Menus
  • VCL.ActnList
  • VCL.ToolWin
  • VCL.ExtCtrls
  • VCL.StdCtrls
  • VCL.Graphics
  • GLS.Memo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TShaderMemoForm |

Functions and Procedures

function GLShaderEditorForm: TShaderMemoForm;
procedure ReleaseGLShaderEditor;

Description

Functions and Procedures

function GLShaderEditorForm: TShaderMemoForm;

This item has no description.

procedure ReleaseGLShaderEditor;


GLSysHelp v.2.5: FmShaderMemo: Class TShaderMemoForm

Class TShaderMemoForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmShaderMemo

Declaration

type TShaderMemoForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TShaderMemoForm

Overview

Fields

Public | ImageList: TImageList;
Public | ToolBar: TToolBar;
Public | TBOpen: TToolButton;
Public | TBSave: TToolButton;
Public | TBStayOnTop: TToolButton;
Public | TBHelp: TToolButton;
Public | ToolButton2: TToolButton;
Public | TBCopy: TToolButton;
Public | TBPaste: TToolButton;
Public | TBCut: TToolButton;
Public | ToolButton10: TToolButton;
Public | TBTemplate: TToolButton;
Public | TBUndo: TToolButton;
Public | TBRedo: TToolButton;
Public | ToolButton4: TToolButton;
Public | GLSLMemo: TGLSSynHiMemo;
Public | OpenDialog: TOpenDialog;
Public | SaveDialog: TSaveDialog;
Public | TemplateMenu: TPopupMenu;
Public | GLSL120: TMenuItem;
Public | GLSL330: TMenuItem;
Public | GLSL400: TMenuItem;
Public | N1: TMenuItem;
Public | N2: TMenuItem;
Public | CompilatorLog: TMemo;
Public | TBIncIndent: TToolButton;
Public | TBDecIndent: TToolButton;
Public | TBComment: TToolButton;
Public | TBUncoment: TToolButton;
Public | ToolButton1: TToolButton;
Public | Panel1: TPanel;
Public | CancelButton: TButton;
Public | OKButton: TButton;
Public | CheckButton: TButton;
Private | FLightLineStyle: Integer;
Private | FOnCheck: TNotifyEvent;

Methods

Public | procedure CheckButtonClick(Sender: TObject);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormDestroy(Sender: TObject);
Public | procedure FormShow(Sender: TObject);
Public | procedure GLSLMemoGutterClick(Sender: TObject; LineNo: Integer);
Public | procedure GLSLMemoGutterDraw(Sender: TObject; ACanvas: TCanvas; LineNo: Integer; rct: TRect);
Public | procedure GLSLMemoUndoChange(Sender: TObject; CanUndo, CanRedo: Boolean);
Public | procedure TBCommentClick(Sender: TObject);
Public | procedure TBCopyClick(Sender: TObject);
Public | procedure TBCutClick(Sender: TObject);
Public | procedure TBDecIndentClick(Sender: TObject);
Public | procedure TBIncIndentClick(Sender: TObject);
Public | procedure TBOpenClick(Sender: TObject);
Public | procedure TBPasteClick(Sender: TObject);
Public | procedure TBRedoClick(Sender: TObject);
Public | procedure TBSaveClick(Sender: TObject);
Public | procedure TBStayOnTopClick(Sender: TObject);
Public | procedure TBUncomentClick(Sender: TObject);
Public | procedure TBUndoClick(Sender: TObject);
Private | procedure OnTemplateClick(Sender: TObject);

Properties

Public property OnCheck: TNotifyEvent read FOnCheck write FOnCheck;

Description

Fields

Public ImageList: TImageList;

This item has no description.

Public ToolBar: TToolBar;

This item has no description.

Public TBOpen: TToolButton;

This item has no description.

Public TBSave: TToolButton;

This item has no description.

Public TBStayOnTop: TToolButton;

This item has no description.

Public TBHelp: TToolButton;

This item has no description.

Public ToolButton2: TToolButton;

This item has no description.

Public TBCopy: TToolButton;

This item has no description.

Public TBPaste: TToolButton;

This item has no description.

Public TBCut: TToolButton;

This item has no description.

Public ToolButton10: TToolButton;

This item has no description.

Public TBTemplate: TToolButton;

This item has no description.

Public TBUndo: TToolButton;

This item has no description.

Public TBRedo: TToolButton;

This item has no description.

Public ToolButton4: TToolButton;

This item has no description.

Public GLSLMemo: TGLSSynHiMemo;

This item has no description.

Public OpenDialog: TOpenDialog;

This item has no description.

Public SaveDialog: TSaveDialog;

This item has no description.

Public TemplateMenu: TPopupMenu;

This item has no description.

Public GLSL120: TMenuItem;

This item has no description.

Public GLSL330: TMenuItem;

This item has no description.

Public GLSL400: TMenuItem;

This item has no description.

Public N1: TMenuItem;

This item has no description.

Public N2: TMenuItem;

This item has no description.

Public CompilatorLog: TMemo;

This item has no description.

Public TBIncIndent: TToolButton;

This item has no description.

Public TBDecIndent: TToolButton;

This item has no description.

Public TBComment: TToolButton;

This item has no description.

Public TBUncoment: TToolButton;

This item has no description.

Public ToolButton1: TToolButton;

This item has no description.

Public Panel1: TPanel;

This item has no description.

Public CancelButton: TButton;

This item has no description.

Public OKButton: TButton;

This item has no description.

Public CheckButton: TButton;

This item has no description.

Private FLightLineStyle: Integer;

This item has no description.

Private FOnCheck: TNotifyEvent;

This item has no description.

Methods

Public procedure CheckButtonClick(Sender: TObject);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure FormShow(Sender: TObject);

This item has no description.

Public procedure GLSLMemoGutterClick(Sender: TObject; LineNo: Integer);

This item has no description.

Public procedure GLSLMemoGutterDraw(Sender: TObject; ACanvas: TCanvas; LineNo: Integer; rct: TRect);

This item has no description.

Public procedure GLSLMemoUndoChange(Sender: TObject; CanUndo, CanRedo: Boolean);

This item has no description.

Public procedure TBCommentClick(Sender: TObject);

This item has no description.

Public procedure TBCopyClick(Sender: TObject);

This item has no description.

Public procedure TBCutClick(Sender: TObject);

This item has no description.

Public procedure TBDecIndentClick(Sender: TObject);

This item has no description.

Public procedure TBIncIndentClick(Sender: TObject);

This item has no description.

Public procedure TBOpenClick(Sender: TObject);

This item has no description.

Public procedure TBPasteClick(Sender: TObject);

This item has no description.

Public procedure TBRedoClick(Sender: TObject);

This item has no description.

Public procedure TBSaveClick(Sender: TObject);

This item has no description.

Public procedure TBStayOnTopClick(Sender: TObject);

This item has no description.

Public procedure TBUncomentClick(Sender: TObject);

This item has no description.

Public procedure TBUndoClick(Sender: TObject);

This item has no description.

Private procedure OnTemplateClick(Sender: TObject);

This item has no description.

Properties

Public property OnCheck: TNotifyEvent read FOnCheck write FOnCheck;


GLSysHelp v.2.5: FmShaderUniformEditor

Unit FmShaderUniformEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Variants
  • System.Classes
  • VCL.Graphics
  • VCL.Controls
  • VCL.Forms
  • VCL.Dialogs
  • VCL.StdCtrls
  • VCL.ExtCtrls
  • VCL.Buttons
  • GLScene.Strings
  • GLSL.ShaderParameter
  • GLScene.TextureFormat
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShaderUniformEditor |

Functions and Procedures

function GLShaderUniformEditor: TGLShaderUniformEditor;
procedure ReleaseShaderUniformEditor;

Description

Functions and Procedures

function GLShaderUniformEditor: TGLShaderUniformEditor;

This item has no description.

procedure ReleaseShaderUniformEditor;


GLSysHelp v.2.5: FmShaderUniformEditor: Class TGLShaderUniformEditor

Class TGLShaderUniformEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

FmShaderUniformEditor

Declaration

type TGLShaderUniformEditor = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLShaderUniformEditor

Overview

Fields

Public | LBUniforms: TListBox;
Public | Labe1: TLabel;
Public | AutoSetBox: TComboBox;
Public | SamplerBox: TComboBox;
Public | Panel1: TPanel;
Public | RedGroup: TRadioGroup;
Public | GreenGroup: TRadioGroup;
Public | BlueGroup: TRadioGroup;
Public | AlphaGroup: TRadioGroup;
Public | Label1: TLabel;
Public | Label2: TLabel;
Public | Label3: TLabel;
Public | Label4: TLabel;
Public | TextureBox: TComboBox;
Public | Button1: TButton;
Private | FUniformList: array of IShaderParameter;

Methods

Public | procedure AddSamplerName(const S: string);
Public | procedure AddTextureName(const S: string);
Public | procedure AddUniform(AValue: IShaderParameter);
Public | procedure AutoSetBoxChange(Sender: TObject);
Public | procedure Clear;
Public | procedure ColorGroupClick(Sender: TObject);
Public | procedure Execute;
Public | procedure FormDestroy(Sender: TObject);
Public | procedure LBUniformsClick(Sender: TObject);
Public | procedure LBUniformsKeyPress(Sender: TObject; var Key: Char);
Public | procedure SamplerBoxChange(Sender: TObject);
Public | procedure TextureBoxChange(Sender: TObject);

Description

Fields

Public LBUniforms: TListBox;

This item has no description.

Public Labe1: TLabel;

This item has no description.

Public AutoSetBox: TComboBox;

This item has no description.

Public SamplerBox: TComboBox;

This item has no description.

Public Panel1: TPanel;

This item has no description.

Public RedGroup: TRadioGroup;

This item has no description.

Public GreenGroup: TRadioGroup;

This item has no description.

Public BlueGroup: TRadioGroup;

This item has no description.

Public AlphaGroup: TRadioGroup;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public TextureBox: TComboBox;

This item has no description.

Public Button1: TButton;

This item has no description.

Private FUniformList: array of IShaderParameter;

This item has no description.

Methods

Public procedure AddSamplerName(const S: string);

This item has no description.

Public procedure AddTextureName(const S: string);

This item has no description.

Public procedure AddUniform(AValue: IShaderParameter);

This item has no description.

Public procedure AutoSetBoxChange(Sender: TObject);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure ColorGroupClick(Sender: TObject);

This item has no description.

Public procedure Execute;

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure LBUniformsClick(Sender: TObject);

This item has no description.

Public procedure LBUniformsKeyPress(Sender: TObject; var Key: Char);

This item has no description.

Public procedure SamplerBoxChange(Sender: TObject);

This item has no description.

Public procedure TextureBoxChange(Sender: TObject);


GLSysHelp v.2.5: FmVectorEditor

Unit FmVectorEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • VCL.Forms
  • VCL.ComCtrls
  • VCL.StdCtrls
  • VCL.ToolWin
  • VCL.ExtCtrls
  • VCL.Buttons
  • VCL.Graphics
  • VCL.Controls
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLVectorEditorForm |

Functions and Procedures

function GLVectorEditorForm: TGLVectorEditorForm;
procedure ReleaseVectorEditorForm;

Description

Functions and Procedures

function GLVectorEditorForm: TGLVectorEditorForm;

This item has no description.

procedure ReleaseVectorEditorForm;


GLSysHelp v.2.5: FmVectorEditor: Class TGLVectorEditorForm

Class TGLVectorEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmVectorEditor

Declaration

type TGLVectorEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLVectorEditorForm

Overview

Fields

Public | EDx: TEdit;
Public | Label1: TLabel;
Public | Label2: TLabel;
Public | Label3: TLabel;
Public | EDy: TEdit;
Public | EDz: TEdit;
Public | BBok: TBitBtn;
Public | BBcancel: TBitBtn;
Public | IMx: TImage;
Public | IMy: TImage;
Public | IMz: TImage;
Public | SpeedButton1: TSpeedButton;
Public | SBmX: TSpeedButton;
Public | SpeedButton3: TSpeedButton;
Public | SBmY: TSpeedButton;
Public | SpeedButton5: TSpeedButton;
Public | SBmZ: TSpeedButton;
Public | SpeedButton7: TSpeedButton;
Public | SBUnit: TSpeedButton;
Public | SpeedButton9: TSpeedButton;
Public | Bevel1: TBevel;
Public | SBInvert: TSpeedButton;
Private | vx: Single;
Private | vy: Single;
Private | vz: Single;

Methods

Public | function Execute(var x, y, z: Single): Boolean;
Public | procedure EDxChange(Sender: TObject);
Public | procedure EDyChange(Sender: TObject);
Public | procedure EDzChange(Sender: TObject);
Public | procedure SBInvertClick(Sender: TObject);
Public | procedure SBmXClick(Sender: TObject);
Public | procedure SBmYClick(Sender: TObject);
Public | procedure SBmZClick(Sender: TObject);
Public | procedure SBUnitClick(Sender: TObject);
Public | procedure SpeedButton9Click(Sender: TObject);
Public | procedure TBnullClick(Sender: TObject);
Public | procedure TBxClick(Sender: TObject);
Public | procedure TByClick(Sender: TObject);
Public | procedure TBzClick(Sender: TObject);
Private | procedure TestInput(edit: TEdit; imError: TImage; var dest: Single);

Description

Fields

Public EDx: TEdit;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public EDy: TEdit;

This item has no description.

Public EDz: TEdit;

This item has no description.

Public BBok: TBitBtn;

This item has no description.

Public BBcancel: TBitBtn;

This item has no description.

Public IMx: TImage;

This item has no description.

Public IMy: TImage;

This item has no description.

Public IMz: TImage;

This item has no description.

Public SpeedButton1: TSpeedButton;

This item has no description.

Public SBmX: TSpeedButton;

This item has no description.

Public SpeedButton3: TSpeedButton;

This item has no description.

Public SBmY: TSpeedButton;

This item has no description.

Public SpeedButton5: TSpeedButton;

This item has no description.

Public SBmZ: TSpeedButton;

This item has no description.

Public SpeedButton7: TSpeedButton;

This item has no description.

Public SBUnit: TSpeedButton;

This item has no description.

Public SpeedButton9: TSpeedButton;

This item has no description.

Public Bevel1: TBevel;

This item has no description.

Public SBInvert: TSpeedButton;

This item has no description.

Private vx: Single;

This item has no description.

Private vy: Single;

This item has no description.

Private vz: Single;

This item has no description.

Methods

Public function Execute(var x, y, z: Single): Boolean;

This item has no description.

Public procedure EDxChange(Sender: TObject);

This item has no description.

Public procedure EDyChange(Sender: TObject);

This item has no description.

Public procedure EDzChange(Sender: TObject);

This item has no description.

Public procedure SBInvertClick(Sender: TObject);

This item has no description.

Public procedure SBmXClick(Sender: TObject);

This item has no description.

Public procedure SBmYClick(Sender: TObject);

This item has no description.

Public procedure SBmZClick(Sender: TObject);

This item has no description.

Public procedure SBUnitClick(Sender: TObject);

This item has no description.

Public procedure SpeedButton9Click(Sender: TObject);

This item has no description.

Public procedure TBnullClick(Sender: TObject);

This item has no description.

Public procedure TBxClick(Sender: TObject);

This item has no description.

Public procedure TByClick(Sender: TObject);

This item has no description.

Public procedure TBzClick(Sender: TObject);

This item has no description.

Private procedure TestInput(edit: TEdit; imError: TImage; var dest: Single);


GLSysHelp v.2.5: FmXCollectionEditor

Unit FmXCollectionEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Actions
  • System.ImageList
  • VCL.Forms
  • VCL.ImgList
  • VCL.Controls
  • VCL.ActnList
  • VCL.Menus
  • VCL.ComCtrls
  • VCL.ToolWin
  • VCL.Dialogs
  • DesignIntf
  • GLScene.Strings
  • GLS.Scene
  • GLS.Behaviours
  • GLS.MaterialEx
  • GLScene.XCollection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TXCollectionEditorForm |

Functions and Procedures

function XCollectionEditorForm: TXCollectionEditorForm;
procedure ReleaseXCollectionEditor;

Description

Functions and Procedures

function XCollectionEditorForm: TXCollectionEditorForm;

This item has no description.

procedure ReleaseXCollectionEditor;


GLSysHelp v.2.5: FmXCollectionEditor: Class TXCollectionEditorForm

Class TXCollectionEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FmXCollectionEditor

Declaration

type TXCollectionEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TXCollectionEditorForm

Overview

Fields

Public | ListView: TListView;
Public | PMListView: TPopupMenu;
Public | ActionList: TActionList;
Public | ACRemove: TAction;
Public | ACMoveUp: TAction;
Public | ACMoveDown: TAction;
Public | ImageList: TImageList;
Public | MIAdd: TMenuItem;
Public | N1: TMenuItem;
Public | N2: TMenuItem;
Public | Moveup1: TMenuItem;
Public | Movedown1: TMenuItem;
Public | ToolBar1: TToolBar;
Public | TBAdd: TToolButton;
Public | ToolButton2: TToolButton;
Public | ToolButton3: TToolButton;
Public | ToolButton4: TToolButton;
Public | ToolButton5: TToolButton;
Public | ToolButton6: TToolButton;
Public | PMToolBar: TPopupMenu;
Private | FXCollection: TXCollection;
Private | FDesigner: IDesigner;
Private | UpdatingListView: Boolean;

Methods

Public | procedure ACMoveDownExecute(Sender: TObject);
Public | procedure ACMoveUpExecute(Sender: TObject);
Public | procedure ACRemoveExecute(Sender: TObject);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormDestroy(Sender: TObject);
Public | procedure FormHide(Sender: TObject);
Public | procedure ListViewChange(Sender: TObject; Item: TListItem; Change: TItemChange);
Public | procedure PMListViewPopup(Sender: TObject);
Public | procedure PMToolBarPopup(Sender: TObject);
Public | procedure SetXCollection(aXCollection: TXCollection; designer: IDesigner );
Public | procedure TBAddClick(Sender: TObject);
Private | procedure OnAddXCollectionItemClick(Sender: TObject);
Private | procedure OnNameChanged(Sender: TObject);
Private | procedure OnXCollectionDestroyed(Sender: TObject);
Private | procedure PrepareListView;
Private | procedure PrepareXCollectionItemPopup(parent: TMenuItem);

Description

Fields

Public ListView: TListView;

This item has no description.

Public PMListView: TPopupMenu;

This item has no description.

Public ActionList: TActionList;

This item has no description.

Public ACRemove: TAction;

This item has no description.

Public ACMoveUp: TAction;

This item has no description.

Public ACMoveDown: TAction;

This item has no description.

Public ImageList: TImageList;

This item has no description.

Public MIAdd: TMenuItem;

This item has no description.

Public N1: TMenuItem;

This item has no description.

Public N2: TMenuItem;

This item has no description.

Public Moveup1: TMenuItem;

This item has no description.

Public Movedown1: TMenuItem;

This item has no description.

Public ToolBar1: TToolBar;

This item has no description.

Public TBAdd: TToolButton;

This item has no description.

Public ToolButton2: TToolButton;

This item has no description.

Public ToolButton3: TToolButton;

This item has no description.

Public ToolButton4: TToolButton;

This item has no description.

Public ToolButton5: TToolButton;

This item has no description.

Public ToolButton6: TToolButton;

This item has no description.

Public PMToolBar: TPopupMenu;

This item has no description.

Private FXCollection: TXCollection;

This item has no description.

Private FDesigner: IDesigner;

ownerComponent : TComponent;

Private UpdatingListView: Boolean;

This item has no description.

Methods

Public procedure ACMoveDownExecute(Sender: TObject);

This item has no description.

Public procedure ACMoveUpExecute(Sender: TObject);

This item has no description.

Public procedure ACRemoveExecute(Sender: TObject);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure FormHide(Sender: TObject);

This item has no description.

Public procedure ListViewChange(Sender: TObject; Item: TListItem; Change: TItemChange);

This item has no description.

Public procedure PMListViewPopup(Sender: TObject);

This item has no description.

Public procedure PMToolBarPopup(Sender: TObject);

This item has no description.

Public procedure SetXCollection(aXCollection: TXCollection; designer: IDesigner );

This item has no description.

Public procedure TBAddClick(Sender: TObject);

This item has no description.

Private procedure OnAddXCollectionItemClick(Sender: TObject);

This item has no description.

Private procedure OnNameChanged(Sender: TObject);

This item has no description.

Private procedure OnXCollectionDestroyed(Sender: TObject);

This item has no description.

Private procedure PrepareListView;

This item has no description.

Private procedure PrepareXCollectionItemPopup(parent: TMenuItem);


GLSysHelp v.2.5: Formats.B3D

Unit Formats.B3D

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.VectorLists

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TB3DChunk |
Record TBB3DChunk |
Record TTEXSChunk |
Record TBRUSChunk |
Record TVertexData |
Record TVRTSChunk |
Record TTRISChunk |
Record TMESHChunk |
Record TBONEChunk |
Record TKEYSChunk |
Record TANIMChunk |
Record TNODEChunk |
Class TB3DMaterial |
Class TB3DTexture |
Class TB3DNode |
Class TFileB3D |

Types

PANIMChunk = ˆTANIMChunk;
PB3DChunk = ˆTB3DChunk;
PBB3DChunk = ˆTBB3DChunk;
PBONEChunk = ˆTBONEChunk;
PBRUSChunk = ˆTBRUSChunk;
PKEYSChunk = ˆTKEYSChunk;
PMESHChunk = ˆTMESHChunk;
PNODEChunk = ˆTNODEChunk;
PTEXSChunk = ˆTTEXSChunk;
PTRISChunk = ˆTTRISChunk;
PVertexData = ˆTVertexData;
PVRTSChunk = ˆTVRTSChunk;
TB3DChunkType = (...);

Description

Types

PANIMChunk = ˆTANIMChunk;

This item has no description.

PB3DChunk = ˆTB3DChunk;

This item has no description.

PBB3DChunk = ˆTBB3DChunk;

This item has no description.

PBONEChunk = ˆTBONEChunk;

This item has no description.

PBRUSChunk = ˆTBRUSChunk;

This item has no description.

PKEYSChunk = ˆTKEYSChunk;

This item has no description.

PMESHChunk = ˆTMESHChunk;

This item has no description.

PNODEChunk = ˆTNODEChunk;

This item has no description.

PTEXSChunk = ˆTTEXSChunk;

This item has no description.

PTRISChunk = ˆTTRISChunk;

This item has no description.

PVertexData = ˆTVertexData;

This item has no description.

PVRTSChunk = ˆTVRTSChunk;

This item has no description.

TB3DChunkType = (...);

This item has no description.

Values
  • bctUnknown
  • bctHeader
  • bctTexture
  • bctBrush
  • bctNode
  • bctVertex
  • bctTriangle
  • bctMesh
  • bctBone
  • bctKeyFrame
  • bctAnimation


GLSysHelp v.2.5: Formats.B3D: Record TB3DChunk

Record TB3DChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TB3DChunk = record

Description

This item has no description.

Overview

Fields

Public | chunk: array[0..3] of char;
Public | length: Integer;

Description

Fields

Public chunk: array[0..3] of char;

This item has no description.

Public length: Integer;


GLSysHelp v.2.5: Formats.B3D: Record TBB3DChunk

Record TBB3DChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TBB3DChunk = record

Description

This item has no description.

Overview

Fields

Public Version: Integer;

Description

Fields

Public Version: Integer;


GLSysHelp v.2.5: Formats.B3D: Record TTEXSChunk

Record TTEXSChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TTEXSChunk = record

Description

This item has no description.

Overview

Fields

Public | fileName: array[0..255] of char;
Public | flags: Integer;
Public | blend: Integer;
Public | x_pos: Single;
Public | y_pos: Single;
Public | x_scale: Single;
Public | y_scale: Single;
Public | rotation: Single;

Description

Fields

Public fileName: array[0..255] of char;

This item has no description.

Public flags: Integer;

texture file name this is the filename of the texture, ie "wall.bmp" Has to be in the local Directory

Public blend: Integer;

texture file name this is the filename of the texture, ie "wall.bmp" Has to be in the local Directory

Public x_pos: Single;

blitz3D TextureFLags and TextureBlend: default=1,2 these are the same as far as I know as the flags for a texture in Blitz3D

Public y_pos: Single;

blitz3D TextureFLags and TextureBlend: default=1,2 these are the same as far as I know as the flags for a texture in Blitz3D

Public x_scale: Single;

x and y position of texture: default=0,0

Public y_scale: Single;

x and y position of texture: default=0,0

Public rotation: Single;

x and y scale of texture: default=1,1


GLSysHelp v.2.5: Formats.B3D: Record TBRUSChunk

Record TBRUSChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TBRUSChunk = record

Description

This item has no description.

Overview

Fields

Public | n_texs: Integer;
Public | name: array[0..255] of Char;
Public | red: Single;
Public | green: Single;
Public | blue: Single;
Public | alpha: Single;
Public | shininess: Single;
Public | blend: Integer;
Public | fx: Integer;
Public | texture_id: array of Integer;

Description

Fields

Public n_texs: Integer;

This item has no description.

Public name: array[0..255] of Char;

This item has no description.

Public red: Single;

eg "WATER" - just use texture name by default

Public green: Single;

eg "WATER" - just use texture name by default

Public blue: Single;

eg "WATER" - just use texture name by default

Public alpha: Single;

eg "WATER" - just use texture name by default

Public shininess: Single;

Blitz3D Brushcolor and Brushalpha: default=1,1,1,1

Public blend: Integer;

Blitz3D BrushShininess: default=0

Public fx: Integer;

Blitz3D BrushShininess: default=0

Public texture_id: array of Integer;

Blitz3D Brushblend and BrushFX: default=1,0


GLSysHelp v.2.5: Formats.B3D: Record TVertexData

Record TVertexData

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TVertexData = record

Description

This item has no description.

Overview

Fields

Public | next: PVertexData;
Public | x: Single;
Public | y: Single;
Public | z: Single;
Public | nx: Single;
Public | ny: Single;
Public | nz: Single;
Public | red: Single;
Public | green: Single;
Public | blue: Single;
Public | alpha: Single;
Public | tex_coords: array of Single;

Description

Fields

Public next: PVertexData;

This item has no description.

Public x: Single;

This item has no description.

Public y: Single;

This item has no description.

Public z: Single;

This item has no description.

Public nx: Single;

always present

Public ny: Single;

always present

Public nz: Single;

always present

Public red: Single;

vertex normal: present if (flags&1)

Public green: Single;

vertex normal: present if (flags&1)

Public blue: Single;

vertex normal: present if (flags&1)

Public alpha: Single;

vertex normal: present if (flags&1)

Public tex_coords: array of Single;

vertex color: present if (flags&2)


GLSysHelp v.2.5: Formats.B3D: Record TVRTSChunk

Record TVRTSChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TVRTSChunk = record

Description

This item has no description.

Overview

Fields

Public | flags: Integer;
Public | tex_coord_sets: Integer;
Public | tex_coord_set_size: Integer;
Public | vertices: PVertexData;

Description

Fields

Public flags: Integer;

This item has no description.

Public tex_coord_sets: Integer;

1=normal values present, 2=rgba values present

Public tex_coord_set_size: Integer;

texture coords per vertex (eg: 1 for simple U/V) max=8

Public vertices: PVertexData;

components per set (eg: 2 for simple U/V) max=4


GLSysHelp v.2.5: Formats.B3D: Record TTRISChunk

Record TTRISChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TTRISChunk = record

Description

This item has no description.

Overview

Fields

Public | next: PTRISChunk;
Public | brush_id: Integer;
Public | vertex_id: array of Integer;

Description

Fields

Public next: PTRISChunk;

This item has no description.

Public brush_id: Integer;

This item has no description.

Public vertex_id: array of Integer;

brush applied to these TRIs: default=-1


GLSysHelp v.2.5: Formats.B3D: Record TMESHChunk

Record TMESHChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TMESHChunk = record

Description

This item has no description.

Overview

Fields

Public | brush_id: Integer;
Public | vertices: TVRTSChunk;
Public | triangles: PTRISChunk;

Description

Fields

Public brush_id: Integer;

This item has no description.

Public vertices: TVRTSChunk;

'master' brush: default=-1

Public triangles: PTRISChunk;

vertices


GLSysHelp v.2.5: Formats.B3D: Record TBONEChunk

Record TBONEChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TBONEChunk = record

Description

This item has no description.

Overview

Fields

Public | vertex_id: Integer;
Public | weight: Single;

Description

Fields

Public vertex_id: Integer;

This item has no description.

Public weight: Single;

vertex affected by this bone


GLSysHelp v.2.5: Formats.B3D: Record TKEYSChunk

Record TKEYSChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TKEYSChunk = record

Description

This item has no description.

Overview

Fields

Public | next: PKEYSChunk;
Public | flags: Integer;
Public | frame: Integer;
Public | position: TAffineVector;
Public | scale: TAffineVector;
Public | rotation: TGLVector;

Description

Fields

Public next: PKEYSChunk;

This item has no description.

Public flags: Integer;

This item has no description.

Public frame: Integer;

1=position, 2=scale, 4=rotation

Public position: TAffineVector;

where key occurs

Public scale: TAffineVector;

present if (flags&1)

Public rotation: TGLVector;

present if (flags&2)


GLSysHelp v.2.5: Formats.B3D: Record TANIMChunk

Record TANIMChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TANIMChunk = record

Description

This item has no description.

Overview

Fields

Public | flags: Integer;
Public | frames: Integer;
Public | fps: Single;

Description

Fields

Public flags: Integer;

This item has no description.

Public frames: Integer;

unused: default=0

Public fps: Single;

how many frames in anim


GLSysHelp v.2.5: Formats.B3D: Record TNODEChunk

Record TNODEChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TNODEChunk = record

Description

This item has no description.

Overview

Fields

Public | name: array[0..255] of char;
Public | position: TAffineVector;
Public | scale: TAffineVector;
Public | rotation: TGLVector;
Public | meshes: PMESHChunk;
Public | keys: PKEYSChunk;
Public | nodes: PNODEChunk;
Public | animation: TANIMChunk;
Public | next: PNODEChunk;
Public | level: Integer;

Description

Fields

Public name: array[0..255] of char;

This item has no description.

Public position: TAffineVector;

name of node

Public scale: TAffineVector;

local...

Public rotation: TGLVector;

coord...

Public meshes: PMESHChunk;

system... array of node elements should be one of meshes or bones, support meshes only for now

Public keys: PKEYSChunk;

not supprot yet bones: PBONEChunk;

Public nodes: PNODEChunk;

optional animation keys

Public animation: TANIMChunk;

optional child nodes

Public next: PNODEChunk;

optional animation

Public level: Integer;

point to the next node


GLSysHelp v.2.5: Formats.B3D: Class TB3DMaterial

Class TB3DMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TB3DMaterial = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TB3DMaterial

Overview

Fields

Public MaterialData: TBRUSChunk;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetMaterialName: string;

Description

Fields

Public MaterialData: TBRUSChunk;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetMaterialName: string;


GLSysHelp v.2.5: Formats.B3D: Class TB3DTexture

Class TB3DTexture

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TB3DTexture = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TB3DTexture

Overview

Fields

Public TextureData: TTEXSChunk;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetTextureName: string;

Description

Fields

Public TextureData: TTEXSChunk;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetTextureName: string;


GLSysHelp v.2.5: Formats.B3D: Class TB3DNode

Class TB3DNode

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TB3DNode = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TB3DNode

Overview

Fields

Public NodeData: PNODEChunk;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetNodeName: string;
Public | procedure DestroyNodeData(Node: PNODEChunk);

Description

Fields

Public NodeData: PNODEChunk;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetNodeName: string;

This item has no description.

Public procedure DestroyNodeData(Node: PNODEChunk);


GLSysHelp v.2.5: Formats.B3D: Class TFileB3D

Class TFileB3D

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.B3D

Declaration

type TFileB3D = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TFileB3D

Overview

Fields

Private | fTextures: TStringList;
Private | fMaterials: TStringList;
Private | fNodes: TB3DNode;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Private | function GetChunkType(const aChunk: TB3DChunk): TB3DChunkType;
Private | function ReadMaterialChunk(aStream: TStream; const aChunk: TB3DChunk): Integer;
Private | function ReadMeshChunk(aStream: TStream; const aChunk: TB3DChunk; Mesh: PMESHChunk): Integer;
Private | function ReadNodeChunk(aStream: TStream; const aChunk: TB3DChunk; Node: PNODEChunk; level: Integer): Integer;
Private | function ReadTextureChunk(aStream: TStream; const aChunk: TB3DChunk): Integer;
Private | function ReadTrianglesChunk(aStream: TStream; const aChunk: TB3DChunk; Triangle: PTRISChunk): Integer;
Private | function ReadVerticesChunk(aStream: TStream; const aChunk: TB3DChunk; Vertices: PVRTSChunk): Integer;
Private | function SkipChunk(aStream: TStream; const aChunk: TB3DChunk): Integer;
Public | procedure Check;
Public | procedure LoadFromStream(aStream : TStream);
Private | procedure FreeLists;

Properties

Public | property Materials: TStringList read fMaterials;
Public | property Nodes: TB3DNode read fNodes;
Public | property Textures: TStringList read fTextures;

Description

Fields

Private fTextures: TStringList;

This item has no description.

Private fMaterials: TStringList;

This item has no description.

Private fNodes: TB3DNode;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetChunkType(const aChunk: TB3DChunk): TB3DChunkType;

This item has no description.

Private function ReadMaterialChunk(aStream: TStream; const aChunk: TB3DChunk): Integer;

This item has no description.

Private function ReadMeshChunk(aStream: TStream; const aChunk: TB3DChunk; Mesh: PMESHChunk): Integer;

This item has no description.

Private function ReadNodeChunk(aStream: TStream; const aChunk: TB3DChunk; Node: PNODEChunk; level: Integer): Integer;

This item has no description.

Private function ReadTextureChunk(aStream: TStream; const aChunk: TB3DChunk): Integer;

This item has no description.

Private function ReadTrianglesChunk(aStream: TStream; const aChunk: TB3DChunk; Triangle: PTRISChunk): Integer;

This item has no description.

Private function ReadVerticesChunk(aStream: TStream; const aChunk: TB3DChunk; Vertices: PVRTSChunk): Integer;

This item has no description.

Private function SkipChunk(aStream: TStream; const aChunk: TB3DChunk): Integer;

This item has no description.

Public procedure Check;

for test only

Public procedure LoadFromStream(aStream : TStream);

This item has no description.

Private procedure FreeLists;

This item has no description.

Properties

Public property Materials: TStringList read fMaterials;

This item has no description.

Public property Nodes: TB3DNode read fNodes;

This item has no description.

Public property Textures: TStringList read fTextures;


GLSysHelp v.2.5: Formats.DDSImage

Unit Formats.DDSImage

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • Vcl.Graphics
  • GLScene.VectorTypes
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLS.Graphics
  • GLS.Context
  • GLS.FileDDS
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TDDSImage |
Class EDDSException |


GLSysHelp v.2.5: Formats.DDSImage: Class TDDSImage

Class TDDSImage

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DDSImage

Declaration

type TDDSImage = class(TBitmap)

Description

This item has no description.

Hierarchy

  • TBitmap
  • TDDSImage

Overview

Methods

Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;


GLSysHelp v.2.5: Formats.DDSImage: Class EDDSException

Class EDDSException

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DDSImage

Declaration

type EDDSException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EDDSException


GLSysHelp v.2.5: Formats.DXTC

Unit Formats.DXTC

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TDDPIXELFORMAT |
Record TDDSURFACEDESC2 |
Record TDDSHeader |
Record DXTColBlock |
Record DXT3AlphaBlock |
Record DXT5AlphaBlock |
Record TDDS_HEADER_DXT10 |
Record TGLImageDataFormat |

Functions and Procedures

procedure DecodeDXT1toBitmap32(encData, decData: PByteArray; w, h: Integer; var trans: Boolean);
procedure DecodeDXT3toBitmap32(encData, decData: PByteArray; w, h: Integer);
procedure DecodeDXT5toBitmap32(encData, decData: PByteArray; w, h: Integer);
procedure flip_blocks_dxtc1(data: PGLubyte; numBlocks: Integer);
procedure flip_blocks_dxtc3(data: PGLubyte; numBlocks: Integer);
procedure flip_blocks_dxtc5(data: PGLubyte; numBlocks: Integer);
procedure flip_dxt5_alpha(block: PDXT5AlphaBlock);
function DDSHeaderToGLEnum(const DX9header: TDDSHeader; const DX11header: TDDS_HEADER_DXT10; const useDX11: Boolean; out iFormat: TGLinternalFormat; out colorFormat: Cardinal; out dataType: Cardinal; out bpe: Integer): Boolean;
function GLEnumToDDSHeader(var DX9header: TDDSHeader; var DX11header: TDDS_HEADER_DXT10; const useDX11: Boolean; const iFormat: TGLinternalFormat; const colorFormat: Cardinal; const dataType: Cardinal; const bpe: Integer): Boolean;
function FindDDSCompatibleDataFormat(const iFormat: TGLinternalFormat; out colorFormat: Cardinal; out dataType: Cardinal): Boolean;

Types

PDXT3AlphaBlock = ˆDXT3AlphaBlock;
PDXT5AlphaBlock = ˆDXT5AlphaBlock;
PDXTColBlock = ˆDXTColBlock;
TFOURCC = array [0 .. 3] of AnsiChar;

Constants

DDSD_CAPS = $00000001;
DDSD_HEIGHT = $00000002;
DDSD_WIDTH = $00000004;
DDSD_PITCH = $00000008;
DDSD_PIXELFORMAT = $00001000;
DDSD_MIPMAPCOUNT = $00020000;
DDSD_LINEARSIZE = $00080000;
DDSD_DEPTH = $00800000;
DDPF_ALPHAPIXELS = $00000001;
DDPF_A = $00000002;
DDPF_FOURCC = $00000004;
DDPF_RGB = $00000040;
DDPF_RGBA = $00000041;
DDPF_L = $00020000;
DDPF_LA = $00020001;
DDSCAPS_COMPLEX = $00000008;
DDSCAPS_TEXTURE = $00001000;
DDSCAPS_MIPMAP = $00400000;
DDSCAPS2_CUBEMAP = $00000200;
DDSCAPS2_CUBEMAP_POSITIVEX = $00000400;
DDSCAPS2_CUBEMAP_NEGATIVEX = $00000800;
DDSCAPS2_CUBEMAP_POSITIVEY = $00001000;
DDSCAPS2_CUBEMAP_NEGATIVEY = $00002000;
DDSCAPS2_CUBEMAP_POSITIVEZ = $00004000;
DDSCAPS2_CUBEMAP_NEGATIVEZ = $00008000;
DDSCAPS2_VOLUME = $00200000;
DXGI_FORMAT_FORCE_UINT = -1;
DXGI_FORMAT_UNKNOWN = 0;
DXGI_FORMAT_R32G32B32A32_TYPELESS = 1;
DXGI_FORMAT_R32G32B32A32_FLOAT = 2;
DXGI_FORMAT_R32G32B32A32_UINT = 3;
DXGI_FORMAT_R32G32B32A32_SINT = 4;
DXGI_FORMAT_R32G32B32_TYPELESS = 5;
DXGI_FORMAT_R32G32B32_FLOAT = 6;
DXGI_FORMAT_R32G32B32_UINT = 7;
DXGI_FORMAT_R32G32B32_SINT = 8;
DXGI_FORMAT_R16G16B16A16_TYPELESS = 9;
DXGI_FORMAT_R16G16B16A16_FLOAT = 10;
DXGI_FORMAT_R16G16B16A16_UNORM = 11;
DXGI_FORMAT_R16G16B16A16_UINT = 12;
DXGI_FORMAT_R16G16B16A16_SNORM = 13;
DXGI_FORMAT_R16G16B16A16_SINT = 14;
DXGI_FORMAT_R32G32_TYPELESS = 15;
DXGI_FORMAT_R32G32_FLOAT = 16;
DXGI_FORMAT_R32G32_UINT = 17;
DXGI_FORMAT_R32G32_SINT = 18;
DXGI_FORMAT_R32G8X24_TYPELESS = 19;
DXGI_FORMAT_D32_FLOAT_S8X24_UINT = 20;
DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS = 21;
DXGI_FORMAT_X32_TYPELESS_G8X24_UINT = 22;
DXGI_FORMAT_R10G10B10A2_TYPELESS = 23;
DXGI_FORMAT_R10G10B10A2_UNORM = 24;
DXGI_FORMAT_R10G10B10A2_UINT = 25;
DXGI_FORMAT_R11G11B10_FLOAT = 26;
DXGI_FORMAT_R8G8B8A8_TYPELESS = 27;
DXGI_FORMAT_R8G8B8A8_UNORM = 28;
DXGI_FORMAT_R8G8B8A8_UNORM_SRGB = 29;
DXGI_FORMAT_R8G8B8A8_UINT = 30;
DXGI_FORMAT_R8G8B8A8_SNORM = 31;
DXGI_FORMAT_R8G8B8A8_SINT = 32;
DXGI_FORMAT_R16G16_TYPELESS = 33;
DXGI_FORMAT_R16G16_FLOAT = 34;
DXGI_FORMAT_R16G16_UNORM = 35;
DXGI_FORMAT_R16G16_UINT = 36;
DXGI_FORMAT_R16G16_SNORM = 37;
DXGI_FORMAT_R16G16_SINT = 38;
DXGI_FORMAT_R32_TYPELESS = 39;
DXGI_FORMAT_D32_FLOAT = 40;
DXGI_FORMAT_R32_FLOAT = 41;
DXGI_FORMAT_R32_UINT = 42;
DXGI_FORMAT_R32_SINT = 43;
DXGI_FORMAT_R24G8_TYPELESS = 44;
DXGI_FORMAT_D24_UNORM_S8_UINT = 45;
DXGI_FORMAT_R24_UNORM_X8_TYPELESS = 46;
DXGI_FORMAT_X24_TYPELESS_G8_UINT = 47;
DXGI_FORMAT_R8G8_TYPELESS = 48;
DXGI_FORMAT_R8G8_UNORM = 49;
DXGI_FORMAT_R8G8_UINT = 50;
DXGI_FORMAT_R8G8_SNORM = 51;
DXGI_FORMAT_R8G8_SINT = 52;
DXGI_FORMAT_R16_TYPELESS = 53;
DXGI_FORMAT_R16_FLOAT = 54;
DXGI_FORMAT_D16_UNORM = 55;
DXGI_FORMAT_R16_UNORM = 56;
DXGI_FORMAT_R16_UINT = 57;
DXGI_FORMAT_R16_SNORM = 58;
DXGI_FORMAT_R16_SINT = 59;
DXGI_FORMAT_R8_TYPELESS = 60;
DXGI_FORMAT_R8_UNORM = 61;
DXGI_FORMAT_R8_UINT = 62;
DXGI_FORMAT_R8_SNORM = 63;
DXGI_FORMAT_R8_SINT = 64;
DXGI_FORMAT_A8_UNORM = 65;
DXGI_FORMAT_R1_UNORM = 66;
DXGI_FORMAT_R9G9B9E5_SHAREDEXP = 67;
DXGI_FORMAT_R8G8_B8G8_UNORM = 68;
DXGI_FORMAT_G8R8_G8B8_UNORM = 69;
DXGI_FORMAT_BC1_TYPELESS = 70;
DXGI_FORMAT_BC1_UNORM = 71;
DXGI_FORMAT_BC1_UNORM_SRGB = 72;
DXGI_FORMAT_BC2_TYPELESS = 73;
DXGI_FORMAT_BC2_UNORM = 74;
DXGI_FORMAT_BC2_UNORM_SRGB = 75;
DXGI_FORMAT_BC3_TYPELESS = 76;
DXGI_FORMAT_BC3_UNORM = 77;
DXGI_FORMAT_BC3_UNORM_SRGB = 78;
DXGI_FORMAT_BC4_TYPELESS = 79;
DXGI_FORMAT_BC4_UNORM = 80;
DXGI_FORMAT_BC4_SNORM = 81;
DXGI_FORMAT_BC5_TYPELESS = 82;
DXGI_FORMAT_BC5_UNORM = 83;
DXGI_FORMAT_BC5_SNORM = 84;
DXGI_FORMAT_B5G6R5_UNORM = 85;
DXGI_FORMAT_B5G5R5A1_UNORM = 86;
DXGI_FORMAT_B8G8R8A8_UNORM = 87;
DXGI_FORMAT_B8G8R8X8_UNORM = 88;
DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM = 89;
DXGI_FORMAT_B8G8R8A8_TYPELESS = 90;
DXGI_FORMAT_B8G8R8A8_UNORM_SRGB = 91;
DXGI_FORMAT_B8G8R8X8_TYPELESS = 92;
DXGI_FORMAT_B8G8R8X8_UNORM_SRGB = 93;
DXGI_FORMAT_BC6H_TYPELESS = 94;
DXGI_FORMAT_BC6H_UF16 = 95;
DXGI_FORMAT_BC6H_SF16 = 96;
DXGI_FORMAT_BC7_TYPELESS = 97;
DXGI_FORMAT_BC7_UNORM = 98;
DXGI_FORMAT_BC7_UNORM_SRGB = 99;
D3D11_RESOURCE_DIMENSION_UNKNOWN = 0;
D3D11_RESOURCE_DIMENSION_BUFFER = 1;
D3D11_RESOURCE_DIMENSION_TEXTURE1D = 2;
D3D11_RESOURCE_DIMENSION_TEXTURE2D = 3;
D3D11_RESOURCE_DIMENSION_TEXTURE3D = 4;
FOURCC_UNKNOWN = 0;
FOURCC_R8G8B8 = 20;
FOURCC_A8R8G8B8 = 21;
FOURCC_X8R8G8B8 = 22;
FOURCC_R5G6B5 = 23;
FOURCC_X1R5G5B5 = 24;
FOURCC_A1R5G5B5 = 25;
FOURCC_A4R4G4B4 = 26;
FOURCC_R3G3B2 = 27;
FOURCC_A8 = 28;
FOURCC_A8R3G3B2 = 29;
FOURCC_X4R4G4B4 = 30;
FOURCC_A2B10G10R10 = 31;
FOURCC_A8B8G8R8 = 32;
FOURCC_X8B8G8R8 = 33;
FOURCC_G16R16 = 34;
FOURCC_A2R10G10B10 = 35;
FOURCC_A16B16G16R16 = 36;
FOURCC_L8 = 50;
FOURCC_A8L8 = 51;
FOURCC_A4L4 = 52;
FOURCC_DXT1 = $31545844;
FOURCC_DXT2 = $32545844;
FOURCC_DXT3 = $33545844;
FOURCC_DXT4 = $34545844;
FOURCC_DXT5 = $35545844;
FOURCC_ATI1 = $31495441;
FOURCC_ATI2 = $32495441;
FOURCC_D16_LOCKABLE = 70;
FOURCC_D32 = 71;
FOURCC_D24X8 = 77;
FOURCC_D16 = 80;
FOURCC_D32F_LOCKABLE = 82;
FOURCC_L16 = 81;
FOURCC_R16F = 111;
FOURCC_G16R16F = 112;
FOURCC_A16B16G16R16F = 113;
FOURCC_R32F = 114;
FOURCC_G32R32F = 115;
FOURCC_A32B32G32R32F = 116;
FOURCC_DX10 = $47495844;
cImageDataFormat8bits: array [0 .. 3] of TGLImageDataFormat = ((ColorFlag: DDPF_RGB; RBits: $E0; GBits: $1C; BBits: $03; ABits: $00; colorFormat: GL_RGB; TexFormat: tfR3_G3_B2; dType: GL_UNSIGNED_BYTE_3_3_2), (ColorFlag: DDPF_LA; RBits: $0F; GBits: $00; BBits: $00; ABits: $F0; colorFormat: GL_LUMINANCE_ALPHA; TexFormat: tfLUMINANCE4_ALPHA4; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_A; RBits: $00; GBits: $00; BBits: $00; ABits: $FF; colorFormat: GL_ALPHA; TexFormat: tfALPHA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_L; RBits: $FF; GBits: $00; BBits: $00; ABits: $00; colorFormat: GL_LUMINANCE; TexFormat: tfLUMINANCE8; dType: GL_UNSIGNED_BYTE));
cImageDataFormat16bits: array [0 .. 4] of TGLImageDataFormat = ((ColorFlag: DDPF_RGBA; RBits: $0F00; GBits: $F0; BBits: $0F; ABits: $F000; colorFormat: GL_BGRA; TexFormat: tfRGBA4; dType: GL_UNSIGNED_SHORT_4_4_4_4_REV), (ColorFlag: DDPF_RGB; RBits: $F800; GBits: $07E0; BBits: $1F; ABits: $00; colorFormat: GL_RGB; TexFormat: tfRGB5; dType: GL_UNSIGNED_SHORT_5_6_5), (ColorFlag: DDPF_L; RBits: $FFFF; GBits: $00; BBits: $00; ABits: $00; colorFormat: GL_LUMINANCE; TexFormat: tfLUMINANCE16; dType: GL_UNSIGNED_SHORT), (ColorFlag: DDPF_LA; RBits: $FF; GBits: $00; BBits: $00; ABits: $FF00; colorFormat: GL_LUMINANCE_ALPHA; TexFormat: tfLUMINANCE8_ALPHA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $7C00; GBits: $03E0; BBits: $1F; ABits: $8000; colorFormat: GL_BGRA; TexFormat: tfRGB5_A1; dType: GL_UNSIGNED_SHORT_1_5_5_5_REV));
cImageDataFormat24bits: array [0 .. 0] of TGLImageDataFormat = ((ColorFlag: DDPF_RGB; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $00; colorFormat: GL_BGR; TexFormat: tfRGB8; dType: GL_UNSIGNED_BYTE));
cImageDataFormat32bits: array [0 .. 6] of TGLImageDataFormat = ((ColorFlag: DDPF_RGBA; RBits: $FF; GBits: $FF00; BBits: $FF0000; ABits: $FF000000; colorFormat: GL_RGBA; TexFormat: tfRGBA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $FF000000; colorFormat: GL_BGRA; TexFormat: tfRGBA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $3FF00000; GBits: $0FFC00; BBits: $03FF; ABits: $0C0000000; colorFormat: GL_RGBA; TexFormat: tfRGB10_A2; dType: GL_UNSIGNED_INT_2_10_10_10_REV), (ColorFlag: DDPF_RGBA; RBits: $03FF; GBits: $FFC00; BBits: $3FF00000; ABits: $C0000000; colorFormat: GL_BGRA; TexFormat: tfRGB10_A2; dType: GL_UNSIGNED_INT_2_10_10_10_REV), (ColorFlag: DDPF_RGBA; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $FF000000; colorFormat: GL_BGRA; TexFormat: tfRGB8; dType: GL_UNSIGNED_INT_8_8_8_8), (ColorFlag: DDPF_RGBA; RBits: $FF; GBits: $FF00; BBits: $FF0000; ABits: $FF000000; colorFormat: GL_RGBA; TexFormat: tfRGB8; dType: GL_UNSIGNED_INT_8_8_8_8), (ColorFlag: DDPF_RGB; RBits: $FFFF; GBits: $FFFF0000; BBits: $00; ABits: $00; colorFormat: GL_RG; TexFormat: tfRG16; dType: GL_UNSIGNED_SHORT));

Description

Functions and Procedures

procedure DecodeDXT1toBitmap32(encData, decData: PByteArray; w, h: Integer; var trans: Boolean);

This item has no description.

procedure DecodeDXT3toBitmap32(encData, decData: PByteArray; w, h: Integer);

This item has no description.

procedure DecodeDXT5toBitmap32(encData, decData: PByteArray; w, h: Integer);

This item has no description.

procedure flip_blocks_dxtc1(data: PGLubyte; numBlocks: Integer);

This item has no description.

procedure flip_blocks_dxtc3(data: PGLubyte; numBlocks: Integer);

This item has no description.

procedure flip_blocks_dxtc5(data: PGLubyte; numBlocks: Integer);

This item has no description.

procedure flip_dxt5_alpha(block: PDXT5AlphaBlock);

This item has no description.

function DDSHeaderToGLEnum(const DX9header: TDDSHeader; const DX11header: TDDS_HEADER_DXT10; const useDX11: Boolean; out iFormat: TGLinternalFormat; out colorFormat: Cardinal; out dataType: Cardinal; out bpe: Integer): Boolean;

This item has no description.

function GLEnumToDDSHeader(var DX9header: TDDSHeader; var DX11header: TDDS_HEADER_DXT10; const useDX11: Boolean; const iFormat: TGLinternalFormat; const colorFormat: Cardinal; const dataType: Cardinal; const bpe: Integer): Boolean;

This item has no description.

function FindDDSCompatibleDataFormat(const iFormat: TGLinternalFormat; out colorFormat: Cardinal; out dataType: Cardinal): Boolean;

This item has no description.

Types

PDXT3AlphaBlock = ˆDXT3AlphaBlock;

This item has no description.

PDXT5AlphaBlock = ˆDXT5AlphaBlock;

This item has no description.

PDXTColBlock = ˆDXTColBlock;

This item has no description.

TFOURCC = array [0 .. 3] of AnsiChar;

This item has no description.

Constants

DDSD_CAPS = $00000001;

This item has no description.

DDSD_HEIGHT = $00000002;

This item has no description.

DDSD_WIDTH = $00000004;

This item has no description.

DDSD_PITCH = $00000008;

This item has no description.

DDSD_PIXELFORMAT = $00001000;

This item has no description.

DDSD_MIPMAPCOUNT = $00020000;

This item has no description.

DDSD_LINEARSIZE = $00080000;

This item has no description.

DDSD_DEPTH = $00800000;

This item has no description.

DDPF_ALPHAPIXELS = $00000001;

This item has no description.

DDPF_A = $00000002;

This item has no description.

DDPF_FOURCC = $00000004;

This item has no description.

DDPF_RGB = $00000040;

This item has no description.

DDPF_RGBA = $00000041;

This item has no description.

DDPF_L = $00020000;

This item has no description.

DDPF_LA = $00020001;

This item has no description.

DDSCAPS_COMPLEX = $00000008;

This item has no description.

DDSCAPS_TEXTURE = $00001000;

This item has no description.

DDSCAPS_MIPMAP = $00400000;

This item has no description.

DDSCAPS2_CUBEMAP = $00000200;

This item has no description.

DDSCAPS2_CUBEMAP_POSITIVEX = $00000400;

This item has no description.

DDSCAPS2_CUBEMAP_NEGATIVEX = $00000800;

This item has no description.

DDSCAPS2_CUBEMAP_POSITIVEY = $00001000;

This item has no description.

DDSCAPS2_CUBEMAP_NEGATIVEY = $00002000;

This item has no description.

DDSCAPS2_CUBEMAP_POSITIVEZ = $00004000;

This item has no description.

DDSCAPS2_CUBEMAP_NEGATIVEZ = $00008000;

This item has no description.

DDSCAPS2_VOLUME = $00200000;

This item has no description.

DXGI_FORMAT_FORCE_UINT = -1;

TDXGI_FORMAT = (

DXGI_FORMAT_UNKNOWN = 0;

This item has no description.

DXGI_FORMAT_R32G32B32A32_TYPELESS = 1;

This item has no description.

DXGI_FORMAT_R32G32B32A32_FLOAT = 2;

This item has no description.

DXGI_FORMAT_R32G32B32A32_UINT = 3;

This item has no description.

DXGI_FORMAT_R32G32B32A32_SINT = 4;

This item has no description.

DXGI_FORMAT_R32G32B32_TYPELESS = 5;

This item has no description.

DXGI_FORMAT_R32G32B32_FLOAT = 6;

This item has no description.

DXGI_FORMAT_R32G32B32_UINT = 7;

This item has no description.

DXGI_FORMAT_R32G32B32_SINT = 8;

This item has no description.

DXGI_FORMAT_R16G16B16A16_TYPELESS = 9;

This item has no description.

DXGI_FORMAT_R16G16B16A16_FLOAT = 10;

This item has no description.

DXGI_FORMAT_R16G16B16A16_UNORM = 11;

This item has no description.

DXGI_FORMAT_R16G16B16A16_UINT = 12;

This item has no description.

DXGI_FORMAT_R16G16B16A16_SNORM = 13;

This item has no description.

DXGI_FORMAT_R16G16B16A16_SINT = 14;

This item has no description.

DXGI_FORMAT_R32G32_TYPELESS = 15;

This item has no description.

DXGI_FORMAT_R32G32_FLOAT = 16;

This item has no description.

DXGI_FORMAT_R32G32_UINT = 17;

This item has no description.

DXGI_FORMAT_R32G32_SINT = 18;

This item has no description.

DXGI_FORMAT_R32G8X24_TYPELESS = 19;

This item has no description.

DXGI_FORMAT_D32_FLOAT_S8X24_UINT = 20;

This item has no description.

DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS = 21;

This item has no description.

DXGI_FORMAT_X32_TYPELESS_G8X24_UINT = 22;

This item has no description.

DXGI_FORMAT_R10G10B10A2_TYPELESS = 23;

This item has no description.

DXGI_FORMAT_R10G10B10A2_UNORM = 24;

This item has no description.

DXGI_FORMAT_R10G10B10A2_UINT = 25;

This item has no description.

DXGI_FORMAT_R11G11B10_FLOAT = 26;

This item has no description.

DXGI_FORMAT_R8G8B8A8_TYPELESS = 27;

This item has no description.

DXGI_FORMAT_R8G8B8A8_UNORM = 28;

This item has no description.

DXGI_FORMAT_R8G8B8A8_UNORM_SRGB = 29;

This item has no description.

DXGI_FORMAT_R8G8B8A8_UINT = 30;

This item has no description.

DXGI_FORMAT_R8G8B8A8_SNORM = 31;

This item has no description.

DXGI_FORMAT_R8G8B8A8_SINT = 32;

This item has no description.

DXGI_FORMAT_R16G16_TYPELESS = 33;

This item has no description.

DXGI_FORMAT_R16G16_FLOAT = 34;

This item has no description.

DXGI_FORMAT_R16G16_UNORM = 35;

This item has no description.

DXGI_FORMAT_R16G16_UINT = 36;

This item has no description.

DXGI_FORMAT_R16G16_SNORM = 37;

This item has no description.

DXGI_FORMAT_R16G16_SINT = 38;

This item has no description.

DXGI_FORMAT_R32_TYPELESS = 39;

This item has no description.

DXGI_FORMAT_D32_FLOAT = 40;

This item has no description.

DXGI_FORMAT_R32_FLOAT = 41;

This item has no description.

DXGI_FORMAT_R32_UINT = 42;

This item has no description.

DXGI_FORMAT_R32_SINT = 43;

This item has no description.

DXGI_FORMAT_R24G8_TYPELESS = 44;

This item has no description.

DXGI_FORMAT_D24_UNORM_S8_UINT = 45;

This item has no description.

DXGI_FORMAT_R24_UNORM_X8_TYPELESS = 46;

This item has no description.

DXGI_FORMAT_X24_TYPELESS_G8_UINT = 47;

This item has no description.

DXGI_FORMAT_R8G8_TYPELESS = 48;

This item has no description.

DXGI_FORMAT_R8G8_UNORM = 49;

This item has no description.

DXGI_FORMAT_R8G8_UINT = 50;

This item has no description.

DXGI_FORMAT_R8G8_SNORM = 51;

This item has no description.

DXGI_FORMAT_R8G8_SINT = 52;

This item has no description.

DXGI_FORMAT_R16_TYPELESS = 53;

This item has no description.

DXGI_FORMAT_R16_FLOAT = 54;

This item has no description.

DXGI_FORMAT_D16_UNORM = 55;

This item has no description.

DXGI_FORMAT_R16_UNORM = 56;

This item has no description.

DXGI_FORMAT_R16_UINT = 57;

This item has no description.

DXGI_FORMAT_R16_SNORM = 58;

This item has no description.

DXGI_FORMAT_R16_SINT = 59;

This item has no description.

DXGI_FORMAT_R8_TYPELESS = 60;

This item has no description.

DXGI_FORMAT_R8_UNORM = 61;

This item has no description.

DXGI_FORMAT_R8_UINT = 62;

This item has no description.

DXGI_FORMAT_R8_SNORM = 63;

This item has no description.

DXGI_FORMAT_R8_SINT = 64;

This item has no description.

DXGI_FORMAT_A8_UNORM = 65;

This item has no description.

DXGI_FORMAT_R1_UNORM = 66;

This item has no description.

DXGI_FORMAT_R9G9B9E5_SHAREDEXP = 67;

This item has no description.

DXGI_FORMAT_R8G8_B8G8_UNORM = 68;

This item has no description.

DXGI_FORMAT_G8R8_G8B8_UNORM = 69;

This item has no description.

DXGI_FORMAT_BC1_TYPELESS = 70;

This item has no description.

DXGI_FORMAT_BC1_UNORM = 71;

This item has no description.

DXGI_FORMAT_BC1_UNORM_SRGB = 72;

This item has no description.

DXGI_FORMAT_BC2_TYPELESS = 73;

This item has no description.

DXGI_FORMAT_BC2_UNORM = 74;

This item has no description.

DXGI_FORMAT_BC2_UNORM_SRGB = 75;

This item has no description.

DXGI_FORMAT_BC3_TYPELESS = 76;

This item has no description.

DXGI_FORMAT_BC3_UNORM = 77;

This item has no description.

DXGI_FORMAT_BC3_UNORM_SRGB = 78;

This item has no description.

DXGI_FORMAT_BC4_TYPELESS = 79;

This item has no description.

DXGI_FORMAT_BC4_UNORM = 80;

This item has no description.

DXGI_FORMAT_BC4_SNORM = 81;

This item has no description.

DXGI_FORMAT_BC5_TYPELESS = 82;

This item has no description.

DXGI_FORMAT_BC5_UNORM = 83;

This item has no description.

DXGI_FORMAT_BC5_SNORM = 84;

This item has no description.

DXGI_FORMAT_B5G6R5_UNORM = 85;

This item has no description.

DXGI_FORMAT_B5G5R5A1_UNORM = 86;

This item has no description.

DXGI_FORMAT_B8G8R8A8_UNORM = 87;

This item has no description.

DXGI_FORMAT_B8G8R8X8_UNORM = 88;

This item has no description.

DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM = 89;

This item has no description.

DXGI_FORMAT_B8G8R8A8_TYPELESS = 90;

This item has no description.

DXGI_FORMAT_B8G8R8A8_UNORM_SRGB = 91;

This item has no description.

DXGI_FORMAT_B8G8R8X8_TYPELESS = 92;

This item has no description.

DXGI_FORMAT_B8G8R8X8_UNORM_SRGB = 93;

This item has no description.

DXGI_FORMAT_BC6H_TYPELESS = 94;

This item has no description.

DXGI_FORMAT_BC6H_UF16 = 95;

This item has no description.

DXGI_FORMAT_BC6H_SF16 = 96;

This item has no description.

DXGI_FORMAT_BC7_TYPELESS = 97;

This item has no description.

DXGI_FORMAT_BC7_UNORM = 98;

This item has no description.

DXGI_FORMAT_BC7_UNORM_SRGB = 99;

This item has no description.

D3D11_RESOURCE_DIMENSION_UNKNOWN = 0;

); TD3D11_RESOURCE_DIMENSION = (

D3D11_RESOURCE_DIMENSION_BUFFER = 1;

This item has no description.

D3D11_RESOURCE_DIMENSION_TEXTURE1D = 2;

This item has no description.

D3D11_RESOURCE_DIMENSION_TEXTURE2D = 3;

This item has no description.

D3D11_RESOURCE_DIMENSION_TEXTURE3D = 4;

This item has no description.

FOURCC_UNKNOWN = 0;

This item has no description.

FOURCC_R8G8B8 = 20;

This item has no description.

FOURCC_A8R8G8B8 = 21;

This item has no description.

FOURCC_X8R8G8B8 = 22;

This item has no description.

FOURCC_R5G6B5 = 23;

This item has no description.

FOURCC_X1R5G5B5 = 24;

This item has no description.

FOURCC_A1R5G5B5 = 25;

This item has no description.

FOURCC_A4R4G4B4 = 26;

This item has no description.

FOURCC_R3G3B2 = 27;

This item has no description.

FOURCC_A8 = 28;

This item has no description.

FOURCC_A8R3G3B2 = 29;

This item has no description.

FOURCC_X4R4G4B4 = 30;

This item has no description.

FOURCC_A2B10G10R10 = 31;

This item has no description.

FOURCC_A8B8G8R8 = 32;

This item has no description.

FOURCC_X8B8G8R8 = 33;

This item has no description.

FOURCC_G16R16 = 34;

This item has no description.

FOURCC_A2R10G10B10 = 35;

This item has no description.

FOURCC_A16B16G16R16 = 36;

This item has no description.

FOURCC_L8 = 50;

This item has no description.

FOURCC_A8L8 = 51;

This item has no description.

FOURCC_A4L4 = 52;

This item has no description.

FOURCC_DXT1 = $31545844;

This item has no description.

FOURCC_DXT2 = $32545844;

This item has no description.

FOURCC_DXT3 = $33545844;

This item has no description.

FOURCC_DXT4 = $34545844;

This item has no description.

FOURCC_DXT5 = $35545844;

This item has no description.

FOURCC_ATI1 = $31495441;

This item has no description.

FOURCC_ATI2 = $32495441;

This item has no description.

FOURCC_D16_LOCKABLE = 70;

This item has no description.

FOURCC_D32 = 71;

This item has no description.

FOURCC_D24X8 = 77;

This item has no description.

FOURCC_D16 = 80;

This item has no description.

FOURCC_D32F_LOCKABLE = 82;

This item has no description.

FOURCC_L16 = 81;

This item has no description.

FOURCC_R16F = 111;

Floating point surface formats s10e5 formats (16-bits per channel)

FOURCC_G16R16F = 112;

This item has no description.

FOURCC_A16B16G16R16F = 113;

This item has no description.

FOURCC_R32F = 114;

IEEE s23e8 formats (32-bits per channel)

FOURCC_G32R32F = 115;

This item has no description.

FOURCC_A32B32G32R32F = 116;

This item has no description.

FOURCC_DX10 = $47495844;

DX10 header indicator

cImageDataFormat8bits: array [0 .. 3] of TGLImageDataFormat = ((ColorFlag: DDPF_RGB; RBits: $E0; GBits: $1C; BBits: $03; ABits: $00; colorFormat: GL_RGB; TexFormat: tfR3_G3_B2; dType: GL_UNSIGNED_BYTE_3_3_2), (ColorFlag: DDPF_LA; RBits: $0F; GBits: $00; BBits: $00; ABits: $F0; colorFormat: GL_LUMINANCE_ALPHA; TexFormat: tfLUMINANCE4_ALPHA4; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_A; RBits: $00; GBits: $00; BBits: $00; ABits: $FF; colorFormat: GL_ALPHA; TexFormat: tfALPHA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_L; RBits: $FF; GBits: $00; BBits: $00; ABits: $00; colorFormat: GL_LUMINANCE; TexFormat: tfLUMINANCE8; dType: GL_UNSIGNED_BYTE));

This item has no description.

cImageDataFormat16bits: array [0 .. 4] of TGLImageDataFormat = ((ColorFlag: DDPF_RGBA; RBits: $0F00; GBits: $F0; BBits: $0F; ABits: $F000; colorFormat: GL_BGRA; TexFormat: tfRGBA4; dType: GL_UNSIGNED_SHORT_4_4_4_4_REV), (ColorFlag: DDPF_RGB; RBits: $F800; GBits: $07E0; BBits: $1F; ABits: $00; colorFormat: GL_RGB; TexFormat: tfRGB5; dType: GL_UNSIGNED_SHORT_5_6_5), (ColorFlag: DDPF_L; RBits: $FFFF; GBits: $00; BBits: $00; ABits: $00; colorFormat: GL_LUMINANCE; TexFormat: tfLUMINANCE16; dType: GL_UNSIGNED_SHORT), (ColorFlag: DDPF_LA; RBits: $FF; GBits: $00; BBits: $00; ABits: $FF00; colorFormat: GL_LUMINANCE_ALPHA; TexFormat: tfLUMINANCE8_ALPHA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $7C00; GBits: $03E0; BBits: $1F; ABits: $8000; colorFormat: GL_BGRA; TexFormat: tfRGB5_A1; dType: GL_UNSIGNED_SHORT_1_5_5_5_REV));

This item has no description.

cImageDataFormat24bits: array [0 .. 0] of TGLImageDataFormat = ((ColorFlag: DDPF_RGB; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $00; colorFormat: GL_BGR; TexFormat: tfRGB8; dType: GL_UNSIGNED_BYTE));

This item has no description.

cImageDataFormat32bits: array [0 .. 6] of TGLImageDataFormat = ((ColorFlag: DDPF_RGBA; RBits: $FF; GBits: $FF00; BBits: $FF0000; ABits: $FF000000; colorFormat: GL_RGBA; TexFormat: tfRGBA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $FF000000; colorFormat: GL_BGRA; TexFormat: tfRGBA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $3FF00000; GBits: $0FFC00; BBits: $03FF; ABits: $0C0000000; colorFormat: GL_RGBA; TexFormat: tfRGB10_A2; dType: GL_UNSIGNED_INT_2_10_10_10_REV), (ColorFlag: DDPF_RGBA; RBits: $03FF; GBits: $FFC00; BBits: $3FF00000; ABits: $C0000000; colorFormat: GL_BGRA; TexFormat: tfRGB10_A2; dType: GL_UNSIGNED_INT_2_10_10_10_REV), (ColorFlag: DDPF_RGBA; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $FF000000; colorFormat: GL_BGRA; TexFormat: tfRGB8; dType: GL_UNSIGNED_INT_8_8_8_8), (ColorFlag: DDPF_RGBA; RBits: $FF; GBits: $FF00; BBits: $FF0000; ABits: $FF000000; colorFormat: GL_RGBA; TexFormat: tfRGB8; dType: GL_UNSIGNED_INT_8_8_8_8), (ColorFlag: DDPF_RGB; RBits: $FFFF; GBits: $FFFF0000; BBits: $00; ABits: $00; colorFormat: GL_RG; TexFormat: tfRG16; dType: GL_UNSIGNED_SHORT));


GLSysHelp v.2.5: Formats.DXTC: Record TDDPIXELFORMAT

Record TDDPIXELFORMAT

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DXTC

Declaration

type TDDPIXELFORMAT = record

Description

This item has no description.

Overview

Fields

Public | dwSize: Cardinal;
Public | dwFlags: Cardinal;
Public | dwFourCC: Cardinal;
Public | dwRGBBitCount: Cardinal;
Public | dwRBitMask: Cardinal;
Public | dwGBitMask: Cardinal;
Public | dwBBitMask: Cardinal;
Public | dwRGBAlphaBitMask: Cardinal;

Description

Fields

Public dwSize: Cardinal;

This item has no description.

Public dwFlags: Cardinal;

This item has no description.

Public dwFourCC: Cardinal;

This item has no description.

Public dwRGBBitCount: Cardinal;

This item has no description.

Public dwRBitMask: Cardinal;

This item has no description.

Public dwGBitMask: Cardinal;

This item has no description.

Public dwBBitMask: Cardinal;

This item has no description.

Public dwRGBAlphaBitMask: Cardinal;


GLSysHelp v.2.5: Formats.DXTC: Record TDDSURFACEDESC2

Record TDDSURFACEDESC2

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DXTC

Declaration

type TDDSURFACEDESC2 = record

Description

This item has no description.

Overview

Fields

Public | dwSize: Cardinal;
Public | dwFlags: Cardinal;
Public | dwHeight: Cardinal;
Public | dwWidth: Cardinal;
Public | dwPitchOrLinearSize: Cardinal;
Public | dwDepth: Cardinal;
Public | dwMipMapCount: Cardinal;
Public | dwReserved1: array [0 .. 10] of Cardinal;
Public | ddpf: TDDPIXELFORMAT;
Public | dwCaps: Cardinal;
Public | dwCaps2: Cardinal;
Public | dwCaps3: Cardinal;
Public | dwCaps4: Cardinal;
Public | dwReserved2: Cardinal;

Description

Fields

Public dwSize: Cardinal;

This item has no description.

Public dwFlags: Cardinal;

This item has no description.

Public dwHeight: Cardinal;

This item has no description.

Public dwWidth: Cardinal;

This item has no description.

Public dwPitchOrLinearSize: Cardinal;

This item has no description.

Public dwDepth: Cardinal;

The number of bytes per scan line in an uncompressed texture; the total number of bytes in the top level texture for a compressed texture.

Public dwMipMapCount: Cardinal;

The number of bytes per scan line in an uncompressed texture; the total number of bytes in the top level texture for a compressed texture.

Public dwReserved1: array [0 .. 10] of Cardinal;

This item has no description.

Public ddpf: TDDPIXELFORMAT;

This item has no description.

Public dwCaps: Cardinal;

This item has no description.

Public dwCaps2: Cardinal;

This item has no description.

Public dwCaps3: Cardinal;

This item has no description.

Public dwCaps4: Cardinal;

This item has no description.

Public dwReserved2: Cardinal;


GLSysHelp v.2.5: Formats.DXTC: Record TDDSHeader

Record TDDSHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DXTC

Declaration

type TDDSHeader = record

Description

This item has no description.

Overview

Fields

Public | Magic: Cardinal;
Public | SurfaceFormat: TDDSURFACEDESC2;

Description

Fields

Public Magic: Cardinal;

This item has no description.

Public SurfaceFormat: TDDSURFACEDESC2;


GLSysHelp v.2.5: Formats.DXTC: Record DXTColBlock

Record DXTColBlock

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DXTC

Declaration

type DXTColBlock = record

Description

This item has no description.

Overview

Fields

Public | col0: Word;
Public | col1: Word;
Public | row: array [0 .. 3] of Byte;

Description

Fields

Public col0: Word;

This item has no description.

Public col1: Word;

This item has no description.

Public row: array [0 .. 3] of Byte;


GLSysHelp v.2.5: Formats.DXTC: Record DXT3AlphaBlock

Record DXT3AlphaBlock

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DXTC

Declaration

type DXT3AlphaBlock = record

Description

This item has no description.

Overview

Fields

Public row: array [0 .. 3] of Word;

Description

Fields

Public row: array [0 .. 3] of Word;


GLSysHelp v.2.5: Formats.DXTC: Record DXT5AlphaBlock

Record DXT5AlphaBlock

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DXTC

Declaration

type DXT5AlphaBlock = record

Description

This item has no description.

Overview

Fields

Public | alpha0: Byte;
Public | alpha1: Byte;
Public | row: array [0 .. 5] of Byte;

Description

Fields

Public alpha0: Byte;

This item has no description.

Public alpha1: Byte;

This item has no description.

Public row: array [0 .. 5] of Byte;


GLSysHelp v.2.5: Formats.DXTC: Record TDDS_HEADER_DXT10

Record TDDS_HEADER_DXT10

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DXTC

Declaration

type TDDS_HEADER_DXT10 = record

Description

);

Overview

Fields

Public | dxgiFormat: Integer;
Public | resourceDimension: Integer;
Public | miscFlag: Cardinal;
Public | arraySize: Cardinal;
Public | reserved: Cardinal;

Description

Fields

Public dxgiFormat: Integer;

This item has no description.

Public resourceDimension: Integer;

TDXGI_FORMAT;

Public miscFlag: Cardinal;

TD3D11_RESOURCE_DIMENSION;

Public arraySize: Cardinal;

This item has no description.

Public reserved: Cardinal;


GLSysHelp v.2.5: Formats.DXTC: Record TGLImageDataFormat

Record TGLImageDataFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.DXTC

Declaration

type TGLImageDataFormat = record

Description

This item has no description.

Overview

Fields

Public | ColorFlag: Cardinal;
Public | RBits: Cardinal;
Public | GBits: Cardinal;
Public | BBits: Cardinal;
Public | ABits: Cardinal;
Public | colorFormat: Cardinal;
Public | TexFormat: TGLinternalFormat;
Public | dType: Cardinal;

Description

Fields

Public ColorFlag: Cardinal;

This item has no description.

Public RBits: Cardinal;

This item has no description.

Public GBits: Cardinal;

This item has no description.

Public BBits: Cardinal;

This item has no description.

Public ABits: Cardinal;

This item has no description.

Public colorFormat: Cardinal;

This item has no description.

Public TexFormat: TGLinternalFormat;

This item has no description.

Public dType: Cardinal;


GLSysHelp v.2.5: Formats.GL2

Unit Formats.GL2

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLMHeader |
Record TGLMSurfaceHeirachy |
Record TGLMSurfaceHeader |
Record TGLMTriangle |
Record TGLMVertex |
Record TGLMSurface |
Record TGLMLODInfo |
Record TGLMLODs |
Record TGLAHeader |
Record TGLASkeleton |
Class TFileGLM |
Class TFileGLA |

Functions and Procedures

function G2_GetVertWeights(const vert: TGLMVertex): integer;
function G2_GetVertBoneIndex(const vert: TGLMVertex; iWeightNum: integer): integer;
function G2_GetVertBoneWeight(const vert: TGLMVertex; iWeightNum: Cardinal; var fTotalWeight: single; const iNumWeights: Cardinal): single;
procedure MC_UnCompressQuat(var mat: TGLMatrix; const comp: TGLACompQuatBone);

Types

TGLABone = array [0 .. 2] of TVector4f;
TGLACompQuatBone = array [0 .. 6] of Word;
TGLASkeletonOffsets = array of integer;
TGLMLODSurfaceOffsets = array of integer;
TGLMSurfaceHeirachyOffsets = array of integer;

Description

Functions and Procedures

function G2_GetVertWeights(const vert: TGLMVertex): integer;

This item has no description.

function G2_GetVertBoneIndex(const vert: TGLMVertex; iWeightNum: integer): integer;

This item has no description.

function G2_GetVertBoneWeight(const vert: TGLMVertex; iWeightNum: Cardinal; var fTotalWeight: single; const iNumWeights: Cardinal): single;

This item has no description.

procedure MC_UnCompressQuat(var mat: TGLMatrix; const comp: TGLACompQuatBone);

This item has no description.

Types

TGLABone = array [0 .. 2] of TVector4f;

This item has no description.

TGLACompQuatBone = array [0 .. 6] of Word;

This item has no description.

TGLASkeletonOffsets = array of integer;

14 bytes

TGLMLODSurfaceOffsets = array of integer;

This item has no description.

TGLMSurfaceHeirachyOffsets = array of integer;


GLSysHelp v.2.5: Formats.GL2: Record TGLMHeader

Record TGLMHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLMHeader = record

Description

This item has no description.

Overview

Fields

Public | fileID: array [0 .. 3] of char;
Public | version: integer;
Public | strFile: array [0 .. 63] of char;
Public | animName: array [0 .. 63] of char;
Public | animIndex: integer;
Public | numBones: integer;
Public | numLODs: integer;
Public | ofsLODs: integer;
Public | numSurfaces: integer;
Public | ofsSurfHierarchy: integer;
Public | ofsEnd: integer;

Description

Fields

Public fileID: array [0 .. 3] of char;

This item has no description.

Public version: integer;

This item has no description.

Public strFile: array [0 .. 63] of char;

This item has no description.

Public animName: array [0 .. 63] of char;

This item has no description.

Public animIndex: integer;

This item has no description.

Public numBones: integer;

This item has no description.

Public numLODs: integer;

This item has no description.

Public ofsLODs: integer;

This item has no description.

Public numSurfaces: integer;

This item has no description.

Public ofsSurfHierarchy: integer;

This item has no description.

Public ofsEnd: integer;


GLSysHelp v.2.5: Formats.GL2: Record TGLMSurfaceHeirachy

Record TGLMSurfaceHeirachy

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLMSurfaceHeirachy = record

Description

This item has no description.

Overview

Fields

Public | name: array [0 .. 63] of char;
Public | flags: LongWord;
Public | shader: array [0 .. 63] of char;
Public | shaderIndex: integer;
Public | parentIndex: integer;
Public | numChildren: integer;
Public | childIndices: array of integer;

Description

Fields

Public name: array [0 .. 63] of char;

This item has no description.

Public flags: LongWord;

This item has no description.

Public shader: array [0 .. 63] of char;

This item has no description.

Public shaderIndex: integer;

This item has no description.

Public parentIndex: integer;

This item has no description.

Public numChildren: integer;

This item has no description.

Public childIndices: array of integer;


GLSysHelp v.2.5: Formats.GL2: Record TGLMSurfaceHeader

Record TGLMSurfaceHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLMSurfaceHeader = record

Description

This item has no description.

Overview

Fields

Public | ident: integer;
Public | thisSurfaceIndex: integer;
Public | ofsHeader: integer;
Public | numVerts: integer;
Public | ofsVerts: integer;
Public | numTriangles: integer;
Public | ofsTriangles: integer;
Public | numBoneReferences: integer;
Public | ofsBoneReferences: integer;
Public | ofsEnd: integer;

Description

Fields

Public ident: integer;

This item has no description.

Public thisSurfaceIndex: integer;

This item has no description.

Public ofsHeader: integer;

This item has no description.

Public numVerts: integer;

This item has no description.

Public ofsVerts: integer;

This item has no description.

Public numTriangles: integer;

This item has no description.

Public ofsTriangles: integer;

This item has no description.

Public numBoneReferences: integer;

This item has no description.

Public ofsBoneReferences: integer;

This item has no description.

Public ofsEnd: integer;


GLSysHelp v.2.5: Formats.GL2: Record TGLMTriangle

Record TGLMTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLMTriangle = record

Description

This item has no description.

Overview

Fields

Public indices: array [0 .. 2] of integer;

Description

Fields

Public indices: array [0 .. 2] of integer;


GLSysHelp v.2.5: Formats.GL2: Record TGLMVertex

Record TGLMVertex

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLMVertex = record

Description

This item has no description.

Overview

Fields

Public | normal: TVector3f;
Public | vertex: TVector3f;
Public | uiNumWeightsAndBoneIndices: Cardinal;
Public | BoneWeightings: array [0 .. 3] of Byte;

Description

Fields

Public normal: TVector3f;

This item has no description.

Public vertex: TVector3f;

This item has no description.

Public uiNumWeightsAndBoneIndices: Cardinal;

This item has no description.

Public BoneWeightings: array [0 .. 3] of Byte;

packed int


GLSysHelp v.2.5: Formats.GL2: Record TGLMSurface

Record TGLMSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLMSurface = record

Description

This item has no description.

Overview

Fields

Public | SurfaceHeader: TGLMSurfaceHeader;
Public | Triangles: array of TGLMTriangle;
Public | Vertices: array of TGLMVertex;
Public | TexCoords: array of TVector2f;
Public | BoneReferences: array of integer;

Description

Fields

Public SurfaceHeader: TGLMSurfaceHeader;

This item has no description.

Public Triangles: array of TGLMTriangle;

This item has no description.

Public Vertices: array of TGLMVertex;

This item has no description.

Public TexCoords: array of TVector2f;

This item has no description.

Public BoneReferences: array of integer;


GLSysHelp v.2.5: Formats.GL2: Record TGLMLODInfo

Record TGLMLODInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLMLODInfo = record

Description

This item has no description.

Overview

Fields

Public ofsEnd: integer;

Description

Fields

Public ofsEnd: integer;


GLSysHelp v.2.5: Formats.GL2: Record TGLMLODs

Record TGLMLODs

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLMLODs = record

Description

This item has no description.

Overview

Fields

Public | LODInfo: TGLMLODInfo;
Public | LODSurfaceOffsets: TGLMLODSurfaceOffsets;
Public | Surfaces: array of TGLMSurface;

Description

Fields

Public LODInfo: TGLMLODInfo;

This item has no description.

Public LODSurfaceOffsets: TGLMLODSurfaceOffsets;

This item has no description.

Public Surfaces: array of TGLMSurface;


GLSysHelp v.2.5: Formats.GL2: Record TGLAHeader

Record TGLAHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLAHeader = record

Description

This item has no description.

Overview

Fields

Public | fileID: array [0 .. 3] of char;
Public | version: integer;
Public | name: array [0 .. 63] of char;
Public | fScale: single;
Public | numFrames: integer;
Public | ofsFrames: integer;
Public | numBones: integer;
Public | ofsCompBonePool: integer;
Public | ofsSkel: integer;
Public | ofsEnd: integer;

Description

Fields

Public fileID: array [0 .. 3] of char;

This item has no description.

Public version: integer;

This item has no description.

Public name: array [0 .. 63] of char;

This item has no description.

Public fScale: single;

This item has no description.

Public numFrames: integer;

This item has no description.

Public ofsFrames: integer;

This item has no description.

Public numBones: integer;

This item has no description.

Public ofsCompBonePool: integer;

This item has no description.

Public ofsSkel: integer;

This item has no description.

Public ofsEnd: integer;


GLSysHelp v.2.5: Formats.GL2: Record TGLASkeleton

Record TGLASkeleton

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TGLASkeleton = record

Description

This item has no description.

Overview

Fields

Public | name: array [0 .. 63] of char;
Public | flags: LongWord;
Public | parent: integer;
Public | BasePoseMat: TGLABone;
Public | BasePoseMatInv: TGLABone;
Public | numChildren: integer;
Public | children: array of integer;

Description

Fields

Public name: array [0 .. 63] of char;

This item has no description.

Public flags: LongWord;

This item has no description.

Public parent: integer;

This item has no description.

Public BasePoseMat: TGLABone;

This item has no description.

Public BasePoseMatInv: TGLABone;

This item has no description.

Public numChildren: integer;

This item has no description.

Public children: array of integer;


GLSysHelp v.2.5: Formats.GL2: Class TFileGLM

Class TFileGLM

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TFileGLM = class(TObject)

Description

Ghoul2 Model structure

Hierarchy

  • TObject
  • TFileGLM

Overview

Fields

Public | ModelHeader: TGLMHeader;
Public | SurfaceHeirachyOffsets: TGLMSurfaceHeirachyOffsets;
Public | SurfaceHeirachy: array of TGLMSurfaceHeirachy;
Public | LODs: array of TGLMLODs;

Methods

Public procedure LoadFromStream(aStream: TStream);

Description

Fields

Public ModelHeader: TGLMHeader;

This item has no description.

Public SurfaceHeirachyOffsets: TGLMSurfaceHeirachyOffsets;

This item has no description.

Public SurfaceHeirachy: array of TGLMSurfaceHeirachy;

This item has no description.

Public LODs: array of TGLMLODs;

This item has no description.

Methods

Public procedure LoadFromStream(aStream: TStream);


GLSysHelp v.2.5: Formats.GL2: Class TFileGLA

Class TFileGLA

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.GL2

Declaration

type TFileGLA = class(TObject)

Description

Ghoul2 Animation structure

Hierarchy

  • TObject
  • TFileGLA

Overview

Fields

Public | AnimHeader: TGLAHeader;
Public | SkeletonOffsets: TGLASkeletonOffsets;
Public | Skeleton: array of TGLASkeleton;
Public | BoneIndices: array of integer;
Public | CompBonePool: array of TGLACompQuatBone;

Methods

Public | function GetCompressedMatrix(Frame, Bone: integer): TGLACompQuatBone;
Public | function GetUnCompressedMatrix(Frame, Bone: integer): TGLMatrix;
Public | procedure LoadFromStream(aStream: TStream);

Description

Fields

Public AnimHeader: TGLAHeader;

This item has no description.

Public SkeletonOffsets: TGLASkeletonOffsets;

This item has no description.

Public Skeleton: array of TGLASkeleton;

This item has no description.

Public BoneIndices: array of integer;

This item has no description.

Public CompBonePool: array of TGLACompQuatBone;

This item has no description.

Methods

Public function GetCompressedMatrix(Frame, Bone: integer): TGLACompQuatBone;

This item has no description.

Public function GetUnCompressedMatrix(Frame, Bone: integer): TGLMatrix;

This item has no description.

Public procedure LoadFromStream(aStream: TStream);


GLSysHelp v.2.5: Formats.HDRImage

Unit Formats.HDRImage

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • Vcl.Graphics
  • GLScene.VectorTypes
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLScene.TextureFormat
  • GLS.FileHDR

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class THDRImage |


GLSysHelp v.2.5: Formats.HDRImage: Class THDRImage

Class THDRImage

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.HDRImage

Declaration

type THDRImage = class(TBitmap)

Description

This item has no description.

Hierarchy

  • TBitmap
  • THDRImage

Overview

Methods

Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;


GLSysHelp v.2.5: Formats.LWO

Unit Formats.LWO

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.IOUtils
  • System.Math
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TLWChunkRec |
Record TLWSubChunkRec |
Record TLWPolsInfo |
Record TLWPntsInfo |
Record TLWPolyTagMap |
Record TLWVertexMap |
Class TLWChunk |
Class TLWSubChunk |
Class TLWChunkList |
Class TLWParentChunk |
Class TLWPnts |
Class TLWPols |
Class TLWVMap |
Class TLWTags |
Class TLWSurf |
Class TLWLayr |
Class TLWPTag |
Class TLWObjectFile |
Class TLWClip |
Class TLWContentDir |

Functions and Procedures

procedure RegisterChunkClass(ChunkClass: TLWChunkClass);
function LoadLW0FromStream(Stream: TStream; ReadCallback: TLWOReadCallback; UserData: Pointer): LongWord; cdecl;
function LoadLWOFromFile(const AFilename: string; ReadCallback: TLWOReadCallback; UserData: Pointer): LongWord;
procedure ReadMotorolaNumber(Stream: TStream; data: Pointer; ElementSize: Integer; Count: Integer = 1);
function WriteMotorolaNumber(Stream: TStream; data: Pointer; ElementSize: Integer; Count: Integer = 1): Integer;
function ReadS0(Stream: TStream; out Str: string): Integer;
procedure WriteS0(Stream: TStream; data: string);
procedure WriteU4AsVX(Stream: TStream; data: Pointer; Count: Integer);
function ReadVXAsU4(Stream: TStream; data: Pointer; Count: Integer = 1) : Integer;
procedure ReverseByteOrder(ValueIn: Pointer; size: Integer; Count: Integer = 1);
function ToDosPath(const Path: string): string;
function ToUnixPath(const Path: string): string;
function ID4ToInt(const id: TID4): Integer;
procedure FindChunkById(AChunk: TLWChunk; data: Pointer; var Found: boolean);
procedure FindSurfaceByName(AChunk: TLWChunk; AName: Pointer; var Found: boolean);
procedure FindSurfaceByTag(AChunk: TLWChunk; ATag: Pointer; var Found: boolean);
procedure FindVMapByName(AChunk: TLWChunk; AName: Pointer; var Found: boolean);
procedure FindClipByClipIndex(AChunk: TLWChunk; AIndex: Pointer; var Found: boolean);
function GetContentDir: TLWContentDir;

Types

PANG4 = ˆTANG4;
PColr12 = ˆTColr12;
PColr4 = ˆTColr4;
PF4 = ˆTF4;
PF4Array = ˆTF4Array;
PI1 = ˆTI1;
PI2 = ˆTI2;
PI4 = ˆTI4;
PID4 = ˆTID4;
PLWChunkRec = ˆTLWChunkRec;
PLWPolyTagMap = ˆTLWPolyTagMap;
PLWSubChunkRec = ˆTLWSubChunkRec;
PU1 = ˆTU1;
PU2 = ˆTU2;
PU2Array = ˆTU2Array;
PU4 = ˆTU4;
PU4Array = ˆTU4Array;
PVec12 = ˆTVec12;
PVec12Array = ˆTVec12Array;
TANG4 = TF4;
TColr12 = TVec12;
TColr12DynArray = array of TColr12;
TColr4 = array [0 .. 3] of TU1;
TF4 = Single;
TF4Array = array [0 .. 65534] of TF4;
TF4DynArray = array of TF4;
TI1 = ShortInt;
TI2 = SmallInt;
TI4 = LongInt;
TID4 = array [0 .. 3] of AnsiChar;
TID4DynArray = array of TID4;
TLWChunkClass = class of TLWChunk;
TLWChunkFind = procedure(AChunk: TLWChunk; Criteria: Pointer; var Found: boolean);
TLWContentNotify = procedure(Sender: TObject; var Content: string) of object;
TLWOReadCallback = procedure(Chunk: TLWChunkRec; data: Pointer); cdecl;
TLWPntsInfoDynArray = array of TLWPntsInfo;
TLWPolsDynArray = TU2DynArray;
TLWPolsInfoDynArray = array of TLWPolsInfo;
TLWPolyTagMapDynArray = TU2DynArray;
TLWVertexMapDynArray = array of TLWVertexMap;
TU1 = Byte;
TU1DynArray = array of TU1;
TU2 = Word;
TU2Array = array [0 .. 65534] of TU2;
TU2DynArray = array of TU2;
TU4 = LongWord;
TU4Array = array [0 .. 65534] of TU4;
TU4DynArray = array of TU4;
TVec12 = array [0 .. 2] of TF4;
TVec12Array = array [0 .. 65534] of TVec12;
TVec12DynArray = array of TVec12;

Constants

ID_NULL = '#0#0#0#0';
ID_LWSC: TID4 = 'LWSC';
ID_FORM: TID4 = 'FORM';
ID_LWOB: TID4 = 'LWOB';
ID_LWLO: TID4 = 'LWLO';
ID_LAYR: TID4 = 'LAYR';
ID_PNTS: TID4 = 'PNTS';
ID_SRFS: TID4 = 'SRFS';
ID_POLS: TID4 = 'POLS';
ID_CRVS: TID4 = 'CRVS';
ID_PCHS: TID4 = 'PCHS';
ID_SURF: TID4 = 'SURF';
ID_COLR: TID4 = 'COLR';
ID_FLAG: TID4 = 'FLAG';
ID_LUMI: TID4 = 'LUMI';
ID_DIFF: TID4 = 'DIFF';
ID_SPEC: TID4 = 'SPEC';
ID_REFL: TID4 = 'REFL';
ID_TRAN: TID4 = 'TRAN';
ID_VLUM: TID4 = 'VLUM';
ID_VDIF: TID4 = 'VDIF';
ID_VSPC: TID4 = 'VSPC';
ID_VRFL: TID4 = 'VRFL';
ID_VTRN: TID4 = 'VTRN';
ID_GLOS: TID4 = 'GLOS';
ID_SIDE: TID4 = 'SIDE';
ID_RFLT: TID4 = 'RFLT';
ID_RFOP: TID4 = 'RFOP';
ID_RIMG: TID4 = 'RIMG';
ID_RSAN: TID4 = 'RSAN';
ID_RIND: TID4 = 'RIND';
ID_EDGE: TID4 = 'EDGE';
ID_SMAN: TID4 = 'SMAN';
ID_ALPH: TID4 = 'ALPH';
ID_CTEX: TID4 = 'CTEX';
ID_DTEX: TID4 = 'DTEX';
ID_STEX: TID4 = 'STEX';
ID_RTEX: TID4 = 'RTEX';
ID_TTEX: TID4 = 'TTEX';
ID_LTEX: TID4 = 'LTEX';
ID_BTEX: TID4 = 'BTEX';
ID_TFLG: TID4 = 'TFLG';
ID_TSIZ: TID4 = 'TSIZ';
ID_TCTR: TID4 = 'TCTR';
ID_TFAL: TID4 = 'TFAL';
ID_TVEL: TID4 = 'TVAL';
ID_TREF: TID4 = 'TREF';
ID_TCLR: TID4 = 'TCLR';
ID_TVAL: TID4 = 'TVAL';
ID_TAMP: TID4 = 'TAMP';
ID_TFP0: TID4 = 'TFP0';
ID_TFP1: TID4 = 'TFP1';
ID_TFP2: TID4 = 'TFP2';
ID_TIP0: TID4 = 'TIP0';
ID_TIP1: TID4 = 'TIP1';
ID_TIP2: TID4 = 'TIP2';
ID_TSP0: TID4 = 'TSP0';
ID_TSP1: TID4 = 'TSP1';
ID_TSP2: TID4 = 'TSP2';
ID_TFRQ: TID4 = 'TFRQ';
ID_TIMG: TID4 = 'TIMG';
ID_TALP: TID4 = 'TALP';
ID_TWRP: TID4 = 'TWRP';
ID_TAAS: TID4 = 'TAAS';
ID_TOPC: TID4 = 'TOPC';
ID_SHDR: TID4 = 'SHDR';
ID_SDAT: TID4 = 'SDAT';
ID_IMSQ: TID4 = 'IMSQ';
ID_FLYR: TID4 = 'FLYR';
ID_IMCC: TID4 = 'IMCC';
SURF_FLAG_LUMINOUS = 1;
SURF_FLAG_OUTLINE = 2;
SURF_FLAG_SMOOTHING = 4;
SURF_FLAG_COLORHIGHLIGHTS = 8;
SURF_FLAG_COLORFILTER = 16;
SURF_FLAG_OPAQUEEDGE = 32;
SURF_FLAG_TRANSPARENTEDGE = 64;
SURF_FLAG_SHARPTERMINATOR = 128;
SURF_FLAG_DOUBLESIDED = 256;
SURF_FLAG_ADDITIVE = 512;
SURF_FLAG_SHADOWALPHA = 1024;
CURV_CONTINUITY_FIRST = 1;
CURV_CONTINUITY_LAST = 2;
IMSQ_FLAG_LOOP = 1;
IMSQ_FLAG_INTERLACE = 2;
ID_LWO2: TID4 = 'LWO2';
ID_VMAP: TID4 = 'VMAP';
ID_TAGS: TID4 = 'TAGS';
ID_PTAG: TID4 = 'PTAG';
ID_VMAD: TID4 = 'VMAD';
ID_ENVL: TID4 = 'ENVL';
ID_CLIP: TID4 = 'CLIP';
ID_BBOX: TID4 = 'BBOX';
ID_DESC: TID4 = 'DESC';
ID_TEXT: TID4 = 'TEXT';
ID_ICON: TID4 = 'ICON';
ENVL_PRE: TID4 = 'PRE'#0;
ENVL_POST: TID4 = 'POST';
ENVL_KEY: TID4 = 'KEY'#0;
ENVL_SPAN: TID4 = 'SPAN';
ENVL_CHAN: TID4 = 'CHAN';
ENVL_NAME: TID4 = 'NAME';
ID_STIL: TID4 = 'STIL';
ID_ISEQ: TID4 = 'ISEQ';
ID_ANIM: TID4 = 'ANIM';
ID_STCC: TID4 = 'STCC';
ID_CONT: TID4 = 'CONT';
ID_BRIT: TID4 = 'BRIT';
ID_SATR: TID4 = 'SATR';
ID_HUE: TID4 = 'HUE'#0;
ID_GAMMA: TID4 = 'GAMM';
ID_NEGA: TID4 = 'NEGA';
ID_IFLT: TID4 = 'IFLT';
ID_PFLT: TID4 = 'PFLT';
POLS_TYPE_FACE: TID4 = 'FACE';
POLS_TYPE_CURV: TID4 = 'CURV';
POLS_TYPE_PTCH: TID4 = 'PTCH';
POLS_TYPE_MBAL: TID4 = 'MBAL';
POLS_TYPE_BONE: TID4 = 'BONE';
VMAP_TYPE_PICK: TID4 = 'PICK';
VMAP_TYPE_WGHT: TID4 = 'WGHT';
VMAP_TYPE_MNVW: TID4 = 'MNVW';
VMAP_TYPE_TXUV: TID4 = 'TXUV';
VMAP_TYPE_RGB: TID4 = 'RGB'#0;
VMAP_TYPE_RGBA: TID4 = 'RGBA';
VMAP_TYPE_MORF: TID4 = 'MORF';
VMAP_TYPE_SPOT: TID4 = 'SPOT';
PTAG_TYPE_SURF: TID4 = 'SURF';
PTAG_TYPE_PART: TID4 = 'PART';
PTAG_TYPE_SMGP: TID4 = 'SMGP';
PRE_POST_RESET = 0;
PRE_POST_CONSTANT = 1;
PRE_POST_REPEAT = 2;
PRE_POST_OSCILLATE = 3;
PRE_POST_OFFSET = 4;
PRE_POST_LINEAR = 5;
POLS_VCOUNT_MASK = $3FF;
POLS_FLAGS_MASK = $FC00;
SIDE_FRONT = 1;
SIDE_BACK = 2;
SIDE_FRONT_AND_BACK = SIDE_FRONT and SIDE_BACK;
RFOP_BACKDROP = 0;
RFOP_RAYTRACEANDBACKDROP = 1;
RFOP_SPHERICALMAP = 2;
RFOP_RAYTRACEANDSPHERICALMAP = 3;

Description

Functions and Procedures

procedure RegisterChunkClass(ChunkClass: TLWChunkClass);

This item has no description.

function LoadLW0FromStream(Stream: TStream; ReadCallback: TLWOReadCallback; UserData: Pointer): LongWord; cdecl;

This item has no description.

function LoadLWOFromFile(const AFilename: string; ReadCallback: TLWOReadCallback; UserData: Pointer): LongWord;

This item has no description.

procedure ReadMotorolaNumber(Stream: TStream; data: Pointer; ElementSize: Integer; Count: Integer = 1);

This item has no description.

function WriteMotorolaNumber(Stream: TStream; data: Pointer; ElementSize: Integer; Count: Integer = 1): Integer;

This item has no description.

function ReadS0(Stream: TStream; out Str: string): Integer;

This item has no description.

procedure WriteS0(Stream: TStream; data: string);

This item has no description.

procedure WriteU4AsVX(Stream: TStream; data: Pointer; Count: Integer);

This item has no description.

function ReadVXAsU4(Stream: TStream; data: Pointer; Count: Integer = 1) : Integer;

This item has no description.

procedure ReverseByteOrder(ValueIn: Pointer; size: Integer; Count: Integer = 1);

This item has no description.

function ToDosPath(const Path: string): string;

This item has no description.

function ToUnixPath(const Path: string): string;

This item has no description.

function ID4ToInt(const id: TID4): Integer;

This item has no description.

procedure FindChunkById(AChunk: TLWChunk; data: Pointer; var Found: boolean);

ChunkFind procedures

procedure FindSurfaceByName(AChunk: TLWChunk; AName: Pointer; var Found: boolean);

This item has no description.

procedure FindSurfaceByTag(AChunk: TLWChunk; ATag: Pointer; var Found: boolean);

This item has no description.

procedure FindVMapByName(AChunk: TLWChunk; AName: Pointer; var Found: boolean);

This item has no description.

procedure FindClipByClipIndex(AChunk: TLWChunk; AIndex: Pointer; var Found: boolean);

This item has no description.

function GetContentDir: TLWContentDir;

This item has no description.

Types

PANG4 = ˆTANG4;

This item has no description.

PColr12 = ˆTColr12;

This item has no description.

PColr4 = ˆTColr4;

This item has no description.

PF4 = ˆTF4;

This item has no description.

PF4Array = ˆTF4Array;

This item has no description.

PI1 = ˆTI1;

This item has no description.

PI2 = ˆTI2;

This item has no description.

PI4 = ˆTI4;

This item has no description.

PID4 = ˆTID4;

This item has no description.

PLWChunkRec = ˆTLWChunkRec;

Lightwave Chunk Struct - Used in TLWOReadCallback

PLWPolyTagMap = ˆTLWPolyTagMap;

This item has no description.

PLWSubChunkRec = ˆTLWSubChunkRec;

Lightwave SubChunk Struct - Used in TLWOReadCallback

PU1 = ˆTU1;

This item has no description.

PU2 = ˆTU2;

This item has no description.

PU2Array = ˆTU2Array;

This item has no description.

PU4 = ˆTU4;

This item has no description.

PU4Array = ˆTU4Array;

This item has no description.

PVec12 = ˆTVec12;

This item has no description.

PVec12Array = ˆTVec12Array;

This item has no description.

TANG4 = TF4;

This item has no description.

TColr12 = TVec12;

This item has no description.

TColr12DynArray = array of TColr12;

This item has no description.

TColr4 = array [0 .. 3] of TU1;

This item has no description.

TF4 = Single;

This item has no description.

TF4Array = array [0 .. 65534] of TF4;

This item has no description.

TF4DynArray = array of TF4;

This item has no description.

TI1 = ShortInt;

This item has no description.

TI2 = SmallInt;

This item has no description.

TI4 = LongInt;

This item has no description.

TID4 = array [0 .. 3] of AnsiChar;

This item has no description.

TID4DynArray = array of TID4;

This item has no description.

TLWChunkClass = class of TLWChunk;

This item has no description.

TLWChunkFind = procedure(AChunk: TLWChunk; Criteria: Pointer; var Found: boolean);

This item has no description.

TLWContentNotify = procedure(Sender: TObject; var Content: string) of object;

This item has no description.

TLWOReadCallback = procedure(Chunk: TLWChunkRec; data: Pointer); cdecl;

This item has no description.

TLWPntsInfoDynArray = array of TLWPntsInfo;

This item has no description.

TLWPolsDynArray = TU2DynArray;

This item has no description.

TLWPolsInfoDynArray = array of TLWPolsInfo;

This item has no description.

TLWPolyTagMapDynArray = TU2DynArray;

This item has no description.

TLWVertexMapDynArray = array of TLWVertexMap;

This item has no description.

TU1 = Byte;

This item has no description.

TU1DynArray = array of TU1;

This item has no description.

TU2 = Word;

This item has no description.

TU2Array = array [0 .. 65534] of TU2;

This item has no description.

TU2DynArray = array of TU2;

This item has no description.

TU4 = LongWord;

This item has no description.

TU4Array = array [0 .. 65534] of TU4;

This item has no description.

TU4DynArray = array of TU4;

This item has no description.

TVec12 = array [0 .. 2] of TF4;

TS0 = PAnsiChar;

TVec12Array = array [0 .. 65534] of TVec12;

This item has no description.

TVec12DynArray = array of TVec12;

This item has no description.

Constants

ID_NULL = '#0#0#0#0';

This item has no description.

ID_LWSC: TID4 = 'LWSC';

NULL ID

ID_FORM: TID4 = 'FORM';

Lightwave scene file

ID_LWOB: TID4 = 'LWOB';

IFF Form

ID_LWLO: TID4 = 'LWLO';

Lightwave Object version 1.0 - 5.x

ID_LAYR: TID4 = 'LAYR';

Lightwave Layered Object

ID_PNTS: TID4 = 'PNTS';

LAYER

ID_SRFS: TID4 = 'SRFS';

Points chunk

ID_POLS: TID4 = 'POLS';

Surface Names chunk

ID_CRVS: TID4 = 'CRVS';

Polygons chunk

ID_PCHS: TID4 = 'PCHS';

Curves chunk

ID_SURF: TID4 = 'SURF';

Patches chunk

ID_COLR: TID4 = 'COLR';

Surfaces chunk

ID_FLAG: TID4 = 'FLAG';

Color chunk

ID_LUMI: TID4 = 'LUMI';

Surface Flags

ID_DIFF: TID4 = 'DIFF';

Luminosity

ID_SPEC: TID4 = 'SPEC';

Diffuse

ID_REFL: TID4 = 'REFL';

Specular

ID_TRAN: TID4 = 'TRAN';

Reflective

ID_VLUM: TID4 = 'VLUM';

Transparency

ID_VDIF: TID4 = 'VDIF';

Luminosity

ID_VSPC: TID4 = 'VSPC';

Diffuse

ID_VRFL: TID4 = 'VRFL';

Specularity

ID_VTRN: TID4 = 'VTRN';

Reflective

ID_GLOS: TID4 = 'GLOS';

Transparency

ID_SIDE: TID4 = 'SIDE';

Glossiness SmallInt

ID_RFLT: TID4 = 'RFLT';

Sidedness

ID_RFOP: TID4 = 'RFOP';

REFLECTION MODE (PRE 6.0)

ID_RIMG: TID4 = 'RIMG';

REFLECTION OPTIONS

ID_RSAN: TID4 = 'RSAN';

REFLECTION IMAGE

ID_RIND: TID4 = 'RIND';

REFLECTION MAP SEAM ANGLE

ID_EDGE: TID4 = 'EDGE';

REFRACTIVE INDEX

ID_SMAN: TID4 = 'SMAN';

EDGE TRANSPARENCY THRESHOLD

ID_ALPH: TID4 = 'ALPH';

SMOOTHING ANGLE RADIANS

ID_CTEX: TID4 = 'CTEX';

ALPHA MODE

ID_DTEX: TID4 = 'DTEX';

COLOR TEXTURE

ID_STEX: TID4 = 'STEX';

DIFFUSE TEXTURE

ID_RTEX: TID4 = 'RTEX';

SPECULAR TEXTURE

ID_TTEX: TID4 = 'TTEX';

REFLECTIION TEXTURE

ID_LTEX: TID4 = 'LTEX';

TRANSPARENCY TEXTURE

ID_BTEX: TID4 = 'BTEX';

LUMINANCE TEXTURE

ID_TFLG: TID4 = 'TFLG';

BUMP TEXTURE

ID_TSIZ: TID4 = 'TSIZ';

TEXTURE FLAGS

ID_TCTR: TID4 = 'TCTR';

TEXTURE SIZE

ID_TFAL: TID4 = 'TFAL';

TEXTURE CENTER

ID_TVEL: TID4 = 'TVAL';

TEXTURE FALLOFF

ID_TREF: TID4 = 'TREF';

TEXTURE VALUE

ID_TCLR: TID4 = 'TCLR';

TEXTURE REFERENCE

ID_TVAL: TID4 = 'TVAL';

TEXTURE COLOR

ID_TAMP: TID4 = 'TAMP';

TEXTURE VALUE

ID_TFP0: TID4 = 'TFP0';

TEXTURE AMPLITUDE

ID_TFP1: TID4 = 'TFP1';

TEXTURE PARAMETERS

ID_TFP2: TID4 = 'TFP2';

This item has no description.

ID_TIP0: TID4 = 'TIP0';

This item has no description.

ID_TIP1: TID4 = 'TIP1';

This item has no description.

ID_TIP2: TID4 = 'TIP2';

This item has no description.

ID_TSP0: TID4 = 'TSP0';

This item has no description.

ID_TSP1: TID4 = 'TSP1';

This item has no description.

ID_TSP2: TID4 = 'TSP2';

This item has no description.

ID_TFRQ: TID4 = 'TFRQ';

This item has no description.

ID_TIMG: TID4 = 'TIMG';

This item has no description.

ID_TALP: TID4 = 'TALP';

TEXTURE IMG

ID_TWRP: TID4 = 'TWRP';

This item has no description.

ID_TAAS: TID4 = 'TAAS';

TEXTURE WRAP

ID_TOPC: TID4 = 'TOPC';

This item has no description.

ID_SHDR: TID4 = 'SHDR';

This item has no description.

ID_SDAT: TID4 = 'SDAT';

This item has no description.

ID_IMSQ: TID4 = 'IMSQ';

This item has no description.

ID_FLYR: TID4 = 'FLYR';

IMAGE SEQUENCE

ID_IMCC: TID4 = 'IMCC';

FLYER SEQUENCE

SURF_FLAG_LUMINOUS = 1;

This item has no description.

SURF_FLAG_OUTLINE = 2;

This item has no description.

SURF_FLAG_SMOOTHING = 4;

This item has no description.

SURF_FLAG_COLORHIGHLIGHTS = 8;

This item has no description.

SURF_FLAG_COLORFILTER = 16;

This item has no description.

SURF_FLAG_OPAQUEEDGE = 32;

This item has no description.

SURF_FLAG_TRANSPARENTEDGE = 64;

This item has no description.

SURF_FLAG_SHARPTERMINATOR = 128;

This item has no description.

SURF_FLAG_DOUBLESIDED = 256;

This item has no description.

SURF_FLAG_ADDITIVE = 512;

This item has no description.

SURF_FLAG_SHADOWALPHA = 1024;

This item has no description.

CURV_CONTINUITY_FIRST = 1;

This item has no description.

CURV_CONTINUITY_LAST = 2;

This item has no description.

IMSQ_FLAG_LOOP = 1;

This item has no description.

IMSQ_FLAG_INTERLACE = 2;

This item has no description.

ID_LWO2: TID4 = 'LWO2';

This item has no description.

ID_VMAP: TID4 = 'VMAP';

OBJECT

ID_TAGS: TID4 = 'TAGS';

VERTEX MAP

ID_PTAG: TID4 = 'PTAG';

TAGS?

ID_VMAD: TID4 = 'VMAD';

POLYGON TAG MAP

ID_ENVL: TID4 = 'ENVL';

DISCONTINUOUS VERTEX MAP

ID_CLIP: TID4 = 'CLIP';

ENVELOPE

ID_BBOX: TID4 = 'BBOX';

CLIP

ID_DESC: TID4 = 'DESC';

BOUNDING BOX

ID_TEXT: TID4 = 'TEXT';

DESCRIPTION

ID_ICON: TID4 = 'ICON';

TEXT

ENVL_PRE: TID4 = 'PRE'#0;

ICON

ENVL_POST: TID4 = 'POST';

PRE-BEHAVIOUR

ENVL_KEY: TID4 = 'KEY'#0;

POST

ENVL_SPAN: TID4 = 'SPAN';

KEY

ENVL_CHAN: TID4 = 'CHAN';

SPAN

ENVL_NAME: TID4 = 'NAME';

CHAN

ID_STIL: TID4 = 'STIL';

NAME

ID_ISEQ: TID4 = 'ISEQ';

STILL IMAGE FILENAME

ID_ANIM: TID4 = 'ANIM';

IMAGE SEQUENCE

ID_STCC: TID4 = 'STCC';

PLUGIN ANIMATION

ID_CONT: TID4 = 'CONT';

COLOR CYCLING STILL

ID_BRIT: TID4 = 'BRIT';

CONTRAST

ID_SATR: TID4 = 'SATR';

BRIGHTNESS

ID_HUE: TID4 = 'HUE'#0;

SATURATION

ID_GAMMA: TID4 = 'GAMM';

HUE

ID_NEGA: TID4 = 'NEGA';

GAMMA

ID_IFLT: TID4 = 'IFLT';

NEGATIVE IMAGE

ID_PFLT: TID4 = 'PFLT';

IMAGE PLUG-IN FILTER

POLS_TYPE_FACE: TID4 = 'FACE';

PIXEL PLUG-IN FILTER

POLS_TYPE_CURV: TID4 = 'CURV';

FACES

POLS_TYPE_PTCH: TID4 = 'PTCH';

CURVE

POLS_TYPE_MBAL: TID4 = 'MBAL';

PATCH

POLS_TYPE_BONE: TID4 = 'BONE';

METABALL

VMAP_TYPE_PICK: TID4 = 'PICK';

SKELEGON?

VMAP_TYPE_WGHT: TID4 = 'WGHT';

SELECTION SET

VMAP_TYPE_MNVW: TID4 = 'MNVW';

WEIGHT MAP

VMAP_TYPE_TXUV: TID4 = 'TXUV';

SUBPATCH WEIGHT MAP

VMAP_TYPE_RGB: TID4 = 'RGB'#0;

UV MAP

VMAP_TYPE_RGBA: TID4 = 'RGBA';

RGB MAP

VMAP_TYPE_MORF: TID4 = 'MORF';

RGBA MAP

VMAP_TYPE_SPOT: TID4 = 'SPOT';

MORPH MAP: RELATIVE VERTEX DISPLACEMENT

PTAG_TYPE_SURF: TID4 = 'SURF';

SPOT MAP: ABSOLUTE VERTEX POSITIONS

PTAG_TYPE_PART: TID4 = 'PART';

SURFACE

PTAG_TYPE_SMGP: TID4 = 'SMGP';

PARENT PART

PRE_POST_RESET = 0;

SMOOTH GROUP

PRE_POST_CONSTANT = 1;

RESET

PRE_POST_REPEAT = 2;

CONSTANT

PRE_POST_OSCILLATE = 3;

REPEAT

PRE_POST_OFFSET = 4;

OSCILLATE

PRE_POST_LINEAR = 5;

OFFSET REPEAT

POLS_VCOUNT_MASK = $3FF;

LINEAR

POLS_FLAGS_MASK = $FC00;

This item has no description.

SIDE_FRONT = 1;

This item has no description.

SIDE_BACK = 2;

This item has no description.

SIDE_FRONT_AND_BACK = SIDE_FRONT and SIDE_BACK;

This item has no description.

RFOP_BACKDROP = 0;

This item has no description.

RFOP_RAYTRACEANDBACKDROP = 1;

This item has no description.

RFOP_SPHERICALMAP = 2;

This item has no description.

RFOP_RAYTRACEANDSPHERICALMAP = 3;


GLSysHelp v.2.5: Formats.LWO: Record TLWChunkRec

Record TLWChunkRec

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWChunkRec = record

Description

This item has no description.

Overview

Fields

Public | id: TID4;
Public | size: TU4;
Public | data: Pointer;

Description

Fields

Public id: TID4;

This item has no description.

Public size: TU4;

This item has no description.

Public data: Pointer;


GLSysHelp v.2.5: Formats.LWO: Record TLWSubChunkRec

Record TLWSubChunkRec

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWSubChunkRec = record

Description

This item has no description.

Overview

Fields

Public | id: TID4;
Public | size: TU2;
Public | data: Pointer;

Description

Fields

Public id: TID4;

This item has no description.

Public size: TU2;

This item has no description.

Public data: Pointer;


GLSysHelp v.2.5: Formats.LWO: Record TLWPolsInfo

Record TLWPolsInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWPolsInfo = record

Description

This item has no description.

Overview

Fields

Public | norm: TVec12;
Public | vnorms: TVec12DynArray;
Public | surfid: TU2;

Description

Fields

Public norm: TVec12;

This item has no description.

Public vnorms: TVec12DynArray;

This item has no description.

Public surfid: TU2;


GLSysHelp v.2.5: Formats.LWO: Record TLWPntsInfo

Record TLWPntsInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWPntsInfo = record

Description

This item has no description.

Overview

Fields

Public | npols: TU2;
Public | pols: TU2DynArray;

Description

Fields

Public npols: TU2;

This item has no description.

Public pols: TU2DynArray;


GLSysHelp v.2.5: Formats.LWO: Record TLWPolyTagMap

Record TLWPolyTagMap

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWPolyTagMap = record

Description

This item has no description.

Overview

Fields

Public | poly: TU2;
Public | tag: TU2;

Description

Fields

Public poly: TU2;

This item has no description.

Public tag: TU2;


GLSysHelp v.2.5: Formats.LWO: Record TLWVertexMap

Record TLWVertexMap

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWVertexMap = record

Description

Value Map

Overview

Fields

Public | vert: TU2;
Public | values: TF4DynArray;

Description

Fields

Public vert: TU2;

This item has no description.

Public values: TF4DynArray;


GLSysHelp v.2.5: Formats.LWO: Class TLWChunk

Class TLWChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWChunk = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk

Overview

Fields

Private | FData: Pointer;
Private | FID: TID4;
Private | FSize: TU4;
Private | FParentChunk: TLWParentChunk;
Private | FOwner: TLWChunkList;

Methods

Public | destructor Destroy; override;
Public | class function GetID: TID4; virtual;
Private | function GetIndex: Integer;
Private | function GetRootChunks: TLWChunkList;
Public | procedure LoadFromStream(AStream: TStream); virtual;

Properties

Public | property data: Pointer read FData;
Public | property id: TID4 read FID;
Public | property Index: Integer read GetIndex;
Public | property Owner: TLWChunkList read FOwner;
Public | property ParentChunk: TLWParentChunk read FParentChunk;
Public | property RootChunks: TLWChunkList read GetRootChunks;
Public | property size: TU4 read FSize;

Description

Fields

Private FData: Pointer;

This item has no description.

Private FID: TID4;

This item has no description.

Private FSize: TU4;

This item has no description.

Private FParentChunk: TLWParentChunk;

This item has no description.

Private FOwner: TLWChunkList;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public class function GetID: TID4; virtual;

This item has no description.

Private function GetIndex: Integer;

This item has no description.

Private function GetRootChunks: TLWChunkList;

This item has no description.

Public procedure LoadFromStream(AStream: TStream); virtual;

This item has no description.

Properties

Public property data: Pointer read FData;

This item has no description.

Public property id: TID4 read FID;

This item has no description.

Public property Index: Integer read GetIndex;

This item has no description.

Public property Owner: TLWChunkList read FOwner;

This item has no description.

Public property ParentChunk: TLWParentChunk read FParentChunk;

ParentChunk may be nil indicating this is a root chunk. ie. TLWLayr

Public property RootChunks: TLWChunkList read GetRootChunks;

This item has no description.

Public property size: TU4 read FSize;


GLSysHelp v.2.5: Formats.LWO: Class TLWSubChunk

Class TLWSubChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWSubChunk = class(TLWChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWSubChunk

Overview

Methods

Public procedure LoadFromStream(AStream: TStream); override;

Description

Methods

Public procedure LoadFromStream(AStream: TStream); override;


GLSysHelp v.2.5: Formats.LWO: Class TLWChunkList

Class TLWChunkList

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWChunkList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TLWChunkList

Overview

Fields

Private | FOwnsItems: boolean;
Private | FOwner: TObject;

Methods

Public | constructor Create(AOwnsItems: boolean; AOwner: TObject);
Public | destructor Destroy; override;
Public | function Add(AChunk: TLWChunk): Integer;
Public | function FindChunk(ChunkFind: TLWChunkFind; Criteria: Pointer; StartIndex: Integer = 0): Integer;
Private | function GetItem(Index: Integer): TLWChunk;
Public | procedure Clear; override;
Public | procedure Delete(Index: Integer);

Properties

Public | property Items[Index: Integer]: TLWChunk read GetItem;
Public | property Owner: TObject read FOwner;
Public | property OwnsItems: boolean read FOwnsItems;

Description

Fields

Private FOwnsItems: boolean;

This item has no description.

Private FOwner: TObject;

This item has no description.

Methods

Public constructor Create(AOwnsItems: boolean; AOwner: TObject);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add(AChunk: TLWChunk): Integer;

This item has no description.

Public function FindChunk(ChunkFind: TLWChunkFind; Criteria: Pointer; StartIndex: Integer = 0): Integer;

This item has no description.

Private function GetItem(Index: Integer): TLWChunk;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure Delete(Index: Integer);

This item has no description.

Properties

Public property Items[Index: Integer]: TLWChunk read GetItem;

This item has no description.

Public property Owner: TObject read FOwner;

This item has no description.

Public property OwnsItems: boolean read FOwnsItems;


GLSysHelp v.2.5: Formats.LWO: Class TLWParentChunk

Class TLWParentChunk

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWParentChunk = class(TLWChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWParentChunk

Overview

Fields

Private FItems: TLWChunkList;

Methods

Private | function GetFloatParam(Param: TID4): Single;
Private | function GetItems: TLWChunkList;
Private | function GetLongParam(Param: TID4): LongWord;
Private | function GetVec3Param(Param: TID4): TVec12;
Private | function GetVXParam(Param: TID4): Word;
Private | function GetWordParam(Param: TID4): Word;

Properties

Public | property FloatParam[Param: TID4]: Single read GetFloatParam;
Public | property Items: TLWChunkList read GetItems;
Public | property LongParam[Param: TID4]: LongWord read GetLongParam;
Public | property ParamAddr[Param: TID4]: Pointer read GetParamAddr;
Public | property Vec3Param[Param: TID4]: TVec12 read GetVec3Param;
Public | property VXParam[Param: TID4]: Word read GetVXParam;
Public | property WordParam[Param: TID4]: Word read GetWordParam;

Description

Fields

Private FItems: TLWChunkList;

This item has no description.

Methods

Private function GetFloatParam(Param: TID4): Single;

This item has no description.

Private function GetItems: TLWChunkList;

This item has no description.

Private function GetLongParam(Param: TID4): LongWord;

This item has no description.

Private function GetVec3Param(Param: TID4): TVec12;

This item has no description.

Private function GetVXParam(Param: TID4): Word;

This item has no description.

Private function GetWordParam(Param: TID4): Word;

This item has no description.

Properties

Public property FloatParam[Param: TID4]: Single read GetFloatParam;

This item has no description.

Public property Items: TLWChunkList read GetItems;

This item has no description.

Public property LongParam[Param: TID4]: LongWord read GetLongParam;

This item has no description.

Public property ParamAddr[Param: TID4]: Pointer read GetParamAddr;

This item has no description.

Public property Vec3Param[Param: TID4]: TVec12 read GetVec3Param;

This item has no description.

Public property VXParam[Param: TID4]: Word read GetVXParam;

This item has no description.

Public property WordParam[Param: TID4]: Word read GetWordParam;


GLSysHelp v.2.5: Formats.LWO: Class TLWPnts

Class TLWPnts

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWPnts = class(TLWParentChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWPnts

Overview

Fields

Private | FPnts: TVec12DynArray;
Private | FPntsInfo: TLWPntsInfoDynArray;

Methods

Public | class function GetID: TID4; override;
Public | function GetVMap(VMapID: TID4; out VMap: TLWVMap): boolean;
Private | function AddPoly(PntIdx, PolyIdx: Integer): Integer;
Private | function GetPntsCount: LongWord;

Properties

Public | property Pnts: TVec12DynArray read FPnts;
Public | property PntsCount: LongWord read GetPntsCount;
Public | property PntsInfo: TLWPntsInfoDynArray read FPntsInfo;

Description

Fields

Private FPnts: TVec12DynArray;

This item has no description.

Private FPntsInfo: TLWPntsInfoDynArray;

This item has no description.

Methods

Public class function GetID: TID4; override;

This item has no description.

Public function GetVMap(VMapID: TID4; out VMap: TLWVMap): boolean;

This item has no description.

Private function AddPoly(PntIdx, PolyIdx: Integer): Integer;

This item has no description.

Private function GetPntsCount: LongWord;

This item has no description.

Properties

Public property Pnts: TVec12DynArray read FPnts;

This item has no description.

Public property PntsCount: LongWord read GetPntsCount;

This item has no description.

Public property PntsInfo: TLWPntsInfoDynArray read FPntsInfo;


GLSysHelp v.2.5: Formats.LWO: Class TLWPols

Class TLWPols

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWPols = class(TLWParentChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWPols

Overview

Fields

Private | FPolsType: TID4;
Private | FPols: TLWPolsDynArray;
Private | FPolsInfo: TLWPolsInfoDynArray;
Private | FPolsCount: Integer;

Methods

Public | class function GetID: TID4; override;
Public | function GetPolsByPntIdx(VertIdx: TU2; var VertPolys: TU2DynArray): Integer;
Private | function GetIndice(AIndex: Integer): TU2;
Private | function GetIndiceCount: TU4;
Private | function GetPolsByIndex(AIndex: TU2): Integer;
Private | function GetPolsCount: Integer;
Private | procedure CalcPntsNormals;
Private | procedure CalcPolsNormals;

Properties

Public | property IndiceCount: TU4 read GetIndiceCount;
Public | property Indices[AIndex: Integer]: TU2 read GetIndice;
Public | property PolsByIndex[AIndex: TU2]: Integer read GetPolsByIndex;
Public | property PolsCount: Integer read GetPolsCount;
Public | property PolsInfo: TLWPolsInfoDynArray read FPolsInfo;
Public | property PolsType: TID4 read FPolsType;

Description

Fields

Private FPolsType: TID4;

This item has no description.

Private FPols: TLWPolsDynArray;

This item has no description.

Private FPolsInfo: TLWPolsInfoDynArray;

This item has no description.

Private FPolsCount: Integer;

This item has no description.

Methods

Public class function GetID: TID4; override;

This item has no description.

Public function GetPolsByPntIdx(VertIdx: TU2; var VertPolys: TU2DynArray): Integer;

This item has no description.

Private function GetIndice(AIndex: Integer): TU2;

This item has no description.

Private function GetIndiceCount: TU4;

This item has no description.

Private function GetPolsByIndex(AIndex: TU2): Integer;

This item has no description.

Private function GetPolsCount: Integer;

This item has no description.

Private procedure CalcPntsNormals;

This item has no description.

Private procedure CalcPolsNormals;

This item has no description.

Properties

Public property IndiceCount: TU4 read GetIndiceCount;

This item has no description.

Public property Indices[AIndex: Integer]: TU2 read GetIndice;

This item has no description.

Public property PolsByIndex[AIndex: TU2]: Integer read GetPolsByIndex;

This item has no description.

Public property PolsCount: Integer read GetPolsCount;

This item has no description.

Public property PolsInfo: TLWPolsInfoDynArray read FPolsInfo;

This item has no description.

Public property PolsType: TID4 read FPolsType;


GLSysHelp v.2.5: Formats.LWO: Class TLWVMap

Class TLWVMap

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWVMap = class(TLWChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWVMap

Overview

Fields

Private | FDimensions: TU2;
Private | FName: string;
Private | FValues: TLWVertexMapDynArray;
Private | FVMapType: TID4;

Methods

Public | class function GetID: TID4; override;
Private | function GetValue(AIndex: TU2): TLWVertexMap;
Private | function GetValueCount: Integer;

Properties

Public | property Dimensions: TU2 read FDimensions;
Public | property Name: string read FName;
Public | property Value[AIndex: TU2]: TLWVertexMap read GetValue;
Public | property ValueCount: Integer read GetValueCount;
Public | property VMapType: TID4 read FVMapType;

Description

Fields

Private FDimensions: TU2;

This item has no description.

Private FName: string;

This item has no description.

Private FValues: TLWVertexMapDynArray;

This item has no description.

Private FVMapType: TID4;

This item has no description.

Methods

Public class function GetID: TID4; override;

This item has no description.

Private function GetValue(AIndex: TU2): TLWVertexMap;

This item has no description.

Private function GetValueCount: Integer;

This item has no description.

Properties

Public property Dimensions: TU2 read FDimensions;

This item has no description.

Public property Name: string read FName;

This item has no description.

Public property Value[AIndex: TU2]: TLWVertexMap read GetValue;

This item has no description.

Public property ValueCount: Integer read GetValueCount;

This item has no description.

Public property VMapType: TID4 read FVMapType;


GLSysHelp v.2.5: Formats.LWO: Class TLWTags

Class TLWTags

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWTags = class(TLWChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWTags

Overview

Fields

Private FTags: TStrings;

Methods

Public | destructor Destroy; override;
Public | class function GetID: TID4; override;
Public | function TagToName(tag: TU2): string;
Private | function GetTags: TStrings;

Properties

Public property Tags: TStrings read GetTags;

Description

Fields

Private FTags: TStrings;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public class function GetID: TID4; override;

This item has no description.

Public function TagToName(tag: TU2): string;

This item has no description.

Private function GetTags: TStrings;

This item has no description.

Properties

Public property Tags: TStrings read GetTags;


GLSysHelp v.2.5: Formats.LWO: Class TLWSurf

Class TLWSurf

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWSurf = class(TLWParentChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWSurf

Overview

Fields

Private | FName: string;
Private | FSource: string;

Methods

Public | destructor Destroy; override;
Public | class function GetID: TID4; override;
Private | function GetSurfId: Integer;

Properties

Public | property Name: string read FName;
Public | property Source: string read FSource;
Public | property surfid: Integer read GetSurfId;

Description

Fields

Private FName: string;

This item has no description.

Private FSource: string;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public class function GetID: TID4; override;

This item has no description.

Private function GetSurfId: Integer;

This item has no description.

Properties

Public property Name: string read FName;

This item has no description.

Public property Source: string read FSource;

This item has no description.

Public property surfid: Integer read GetSurfId;


GLSysHelp v.2.5: Formats.LWO: Class TLWLayr

Class TLWLayr

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWLayr = class(TLWParentChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWLayr

Overview

Fields

Private | FFlags: TU2;
Private | FName: string;
Private | FNumber: TU2;
Private | FParent: TU2;
Private | FPivot: TVec12;

Methods

Public | destructor Destroy; override;
Public | class function GetID: TID4; override;

Properties

Public | property Flags: TU2 read FFlags;
Public | property Name: string read FName;
Public | property Number: TU2 read FNumber;
Public | property Parent: TU2 read FParent;
Public | property Pivot: TVec12 read FPivot;

Description

Fields

Private FFlags: TU2;

This item has no description.

Private FName: string;

This item has no description.

Private FNumber: TU2;

This item has no description.

Private FParent: TU2;

This item has no description.

Private FPivot: TVec12;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public class function GetID: TID4; override;

This item has no description.

Properties

Public property Flags: TU2 read FFlags;

This item has no description.

Public property Name: string read FName;

This item has no description.

Public property Number: TU2 read FNumber;

This item has no description.

Public property Parent: TU2 read FParent;

This item has no description.

Public property Pivot: TVec12 read FPivot;


GLSysHelp v.2.5: Formats.LWO: Class TLWPTag

Class TLWPTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWPTag = class(TLWChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWPTag

Overview

Fields

Private | FMapType: TID4;
Private | FTagMaps: TLWPolyTagMapDynArray;
Private | FTags: TU2DynArray;

Methods

Public | constructor Create;
Public | class function GetID: TID4; override;
Public | function GetPolsByTag(tag: TU2; var PolyIndices: TU2DynArray): Integer;
Private | function AddTag(Value: TU2): Integer;
Private | function GetTag(AIndex: Integer): TU2;
Private | function GetTagCount: Integer;
Private | function GetTagMapCount: Integer;
Private | function GetTagMaps(AIndex: Integer): TLWPolyTagMap;
Private | procedure ValidateTagInfo;

Properties

Public | property MapType: TID4 read FMapType;
Public | property TagCount: Integer read GetTagCount;
Public | property TagMapCount: Integer read GetTagMapCount;
Public | property TagMaps[AIndex: Integer]: TLWPolyTagMap read GetTagMaps;
Public | property Tags[AIndex: Integer]: TU2 read GetTag;

Description

Fields

Private FMapType: TID4;

This item has no description.

Private FTagMaps: TLWPolyTagMapDynArray;

This item has no description.

Private FTags: TU2DynArray;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public class function GetID: TID4; override;

This item has no description.

Public function GetPolsByTag(tag: TU2; var PolyIndices: TU2DynArray): Integer;

This item has no description.

Private function AddTag(Value: TU2): Integer;

This item has no description.

Private function GetTag(AIndex: Integer): TU2;

This item has no description.

Private function GetTagCount: Integer;

This item has no description.

Private function GetTagMapCount: Integer;

This item has no description.

Private function GetTagMaps(AIndex: Integer): TLWPolyTagMap;

This item has no description.

Private procedure ValidateTagInfo;

This item has no description.

Properties

Public property MapType: TID4 read FMapType;

This item has no description.

Public property TagCount: Integer read GetTagCount;

This item has no description.

Public property TagMapCount: Integer read GetTagMapCount;

This item has no description.

Public property TagMaps[AIndex: Integer]: TLWPolyTagMap read GetTagMaps;

This item has no description.

Public property Tags[AIndex: Integer]: TU2 read GetTag;


GLSysHelp v.2.5: Formats.LWO: Class TLWObjectFile

Class TLWObjectFile

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWObjectFile = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TLWObjectFile

Overview

Fields

Private | FChunks: TLWChunkList;
Private | FFileName: string;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function TagToName(tag: TU2): string;
Private | function GetChunks: TLWChunkList;
Private | function GetCount: Integer;
Private | function GetSurfaceByName(Index: string): TLWSurf;
Private | function GetSurfaceByTag(Index: TU2): TLWSurf;
Public | procedure LoadFromFile(const AFilename: string);
Public | procedure LoadFromStream(AStream: TStream);

Properties

Public | property ChunkCount: Integer read GetCount;
Public | property Chunks: TLWChunkList read GetChunks;
Public | property FileName: string read FFileName;
Public | property SurfaceByName[Index: string]: TLWSurf read GetSurfaceByName;
Public | property SurfaceByTag[Index: TU2]: TLWSurf read GetSurfaceByTag;

Description

Fields

Private FChunks: TLWChunkList;

This item has no description.

Private FFileName: string;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TagToName(tag: TU2): string;

This item has no description.

Private function GetChunks: TLWChunkList;

This item has no description.

Private function GetCount: Integer;

This item has no description.

Private function GetSurfaceByName(Index: string): TLWSurf;

This item has no description.

Private function GetSurfaceByTag(Index: TU2): TLWSurf;

This item has no description.

Public procedure LoadFromFile(const AFilename: string);

This item has no description.

Public procedure LoadFromStream(AStream: TStream);

This item has no description.

Properties

Public property ChunkCount: Integer read GetCount;

This item has no description.

Public property Chunks: TLWChunkList read GetChunks;

This item has no description.

Public property FileName: string read FFileName;

This item has no description.

Public property SurfaceByName[Index: string]: TLWSurf read GetSurfaceByName;

This item has no description.

Public property SurfaceByTag[Index: TU2]: TLWSurf read GetSurfaceByTag;


GLSysHelp v.2.5: Formats.LWO: Class TLWClip

Class TLWClip

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWClip = class(TLWParentChunk)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWClip

Overview

Fields

Private FClipIndex: TU4;

Methods

Public class function GetID: TID4; override;

Properties

Public property ClipIndex: TU4 read FClipIndex;

Description

Fields

Private FClipIndex: TU4;

This item has no description.

Methods

Public class function GetID: TID4; override;

This item has no description.

Properties

Public property ClipIndex: TU4 read FClipIndex;


GLSysHelp v.2.5: Formats.LWO: Class TLWContentDir

Class TLWContentDir

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.LWO

Declaration

type TLWContentDir = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TLWContentDir

Overview

Fields

Private | FSubDirs: TStrings;
Private | FRoot: string;

Methods

Public | destructor Destroy; override;
Public | function FindContent(AFilename: string): string;
Private | function GetSubDirs: TStrings;
Private | procedure SetRoot(const Value: string);
Private | procedure SetSubDirs(const Value: TStrings);

Properties

Public | property Root: string read FRoot write SetRoot;
Public | property SubDirs: TStrings read GetSubDirs write SetSubDirs;

Description

Fields

Private FSubDirs: TStrings;

This item has no description.

Private FRoot: string;

This item has no description.

Methods

Public destructor Destroy; override;

function ContentSearch(AFilename: string): string;

Public function FindContent(AFilename: string): string;

This item has no description.

Private function GetSubDirs: TStrings;

This item has no description.

Private procedure SetRoot(const Value: string);

This item has no description.

Private procedure SetSubDirs(const Value: TStrings);

This item has no description.

Properties

Public property Root: string read FRoot write SetRoot;

This item has no description.

Public property SubDirs: TStrings read GetSubDirs write SetSubDirs;


GLSysHelp v.2.5: Formats.m3DS

Unit Formats.m3DS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Formats.m3DSTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMaterialList |
Class TObjectList |
Class TKeyFramer |
Class TFile3DS |

Types

TLoadProgress = procedure(StreamPos, StreamMax: Longint) of object;

Description

Types

TLoadProgress = procedure(StreamPos, StreamMax: Longint) of object;


GLSysHelp v.2.5: Formats.m3DS: Class TMaterialList

Class TMaterialList

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DS

Declaration

type TMaterialList = class(TObject)

Description

Progress : TProgressBar;

This allows to use something like that:

procedure TSomeForm.CreateForm(Sender: TObject); begin .... 3DSReader.OnProgress := LoadProgress; .... end; procedure TSomeForm.LoadProgress(StreamPos, StreamMax : Longint); begin if StreamMax <> 0 then Progress.MaxValue := StreamMax; Progress.Position := StreamPos; end; —– support classes —– All structure data of a 3DS file is actually held in TFile3DS.FDatabase as a tree with lots of links across the various chunks. For convinience and speed the data of the chunks is collected into some special structures (FMaterialList etc.) and presented to the user by the following helper classes:

Hierarchy

  • TObject
  • TMaterialList

Overview

Fields

Private | FOwner: TFile3DS;
Private | FLocalList: TList;

Methods

Public | constructor Create(AOwner: TFile3DS); virtual;
Public | destructor Destroy; override;
Private | function GetCount: Integer;
Private | function GetMaterial(Index: Integer): PMaterial3DS;
Private | function GetMaterialByName(const Name: String): PMaterial3DS;
Public | procedure ClearList;

Properties

Public | property Count: Integer read GetCount;
Public | property Material[Index: Integer]: PMaterial3DS read GetMaterial;
Public | property MaterialByName[const Name: String]: PMaterial3DS read GetMaterialByName;

Description

Fields

Private FOwner: TFile3DS;

This item has no description.

Private FLocalList: TList;

This item has no description.

Methods

Public constructor Create(AOwner: TFile3DS); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetCount: Integer;

This item has no description.

Private function GetMaterial(Index: Integer): PMaterial3DS;

This item has no description.

Private function GetMaterialByName(const Name: String): PMaterial3DS;

This item has no description.

Public procedure ClearList;

This item has no description.

Properties

Public property Count: Integer read GetCount;

This item has no description.

Public property Material[Index: Integer]: PMaterial3DS read GetMaterial;

This item has no description.

Public property MaterialByName[const Name: String]: PMaterial3DS read GetMaterialByName;


GLSysHelp v.2.5: Formats.m3DS: Class TObjectList

Class TObjectList

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DS

Declaration

type TObjectList = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TObjectList

Overview

Fields

Private | FOwner: TFile3DS;
Private | FMeshList: TList;
Private | FOmniList: TList;
Private | FSpotList: TList;
Private | FCameraList: TList;

Methods

Public | constructor Create(AOwner: TFile3DS); virtual;
Public | destructor Destroy; override;
Private | function GetCamCount: Integer;
Private | function GetCamera(Index: Integer): PCamera3DS;
Private | function GetMesh(Index: Integer): PMesh3DS;
Private | function GetMeshObjectCount: Integer;
Private | function GetOmniCount: Integer;
Private | function GetOmniLight(Index: Integer): PLight3DS;
Private | function GetSpotCount: Integer;
Private | function GetSpotLight(Index: Integer): PLight3DS;
Public | procedure ClearLists;

Properties

Public | property Camera[Index: Integer]: PCamera3DS read GetCamera;
Public | property CameraCount: Integer read GetCamCount;
Public | property Mesh[Index: Integer]: PMesh3DS read GetMesh;
Public | property MeshCount: Integer read GetMeshObjectCount;
Public | property OmniLight[Index: Integer]: PLight3DS read GetOmniLight;
Public | property OmniLightCount: Integer read GetOmniCount;
Public | property SpotLight[Index: Integer]: PLight3DS read GetSpotLight;
Public | property SpotLightCount: Integer read GetSpotCount;

Description

Fields

Private FOwner: TFile3DS;

This item has no description.

Private FMeshList: TList;

This item has no description.

Private FOmniList: TList;

This item has no description.

Private FSpotList: TList;

This item has no description.

Private FCameraList: TList;

This item has no description.

Methods

Public constructor Create(AOwner: TFile3DS); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetCamCount: Integer;

This item has no description.

Private function GetCamera(Index: Integer): PCamera3DS;

This item has no description.

Private function GetMesh(Index: Integer): PMesh3DS;

This item has no description.

Private function GetMeshObjectCount: Integer;

This item has no description.

Private function GetOmniCount: Integer;

This item has no description.

Private function GetOmniLight(Index: Integer): PLight3DS;

This item has no description.

Private function GetSpotCount: Integer;

This item has no description.

Private function GetSpotLight(Index: Integer): PLight3DS;

This item has no description.

Public procedure ClearLists;

This item has no description.

Properties

Public property Camera[Index: Integer]: PCamera3DS read GetCamera;

This item has no description.

Public property CameraCount: Integer read GetCamCount;

This item has no description.

Public property Mesh[Index: Integer]: PMesh3DS read GetMesh;

This item has no description.

Public property MeshCount: Integer read GetMeshObjectCount;

This item has no description.

Public property OmniLight[Index: Integer]: PLight3DS read GetOmniLight;

This item has no description.

Public property OmniLightCount: Integer read GetOmniCount;

This item has no description.

Public property SpotLight[Index: Integer]: PLight3DS read GetSpotLight;

This item has no description.

Public property SpotLightCount: Integer read GetSpotCount;


GLSysHelp v.2.5: Formats.m3DS: Class TKeyFramer

Class TKeyFramer

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DS

Declaration

type TKeyFramer = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TKeyFramer

Overview

Fields

Private | FOwner: TFile3DS;
Private | FMeshMotionList: TList;
Private | FOmniMotionList: TList;
Private | FSpotMotionList: TList;
Private | FCameraMotionList: TList;
Private | FAmbientMotion: PKFAmbient3DS;

Methods

Public | constructor Create(AOwner: TFile3DS); virtual;
Public | destructor Destroy; override;
Private | function GetAmbientMotion: PKFAmbient3DS;
Private | function GetCameraMotion(Index: Integer): PKFCamera3DS;
Private | function GetCamMotionCount: Integer;
Private | function GetKFSets: TKFSets3DS;
Private | function GetMeshMotion(Index: Integer): PKFMesh3DS;
Private | function GetMeshMotionCount: Integer;
Private | function GetOmniLightMotion(Index: Integer): PKFOmni3DS;
Private | function GetOmniMotionCount: Integer;
Private | function GetSpotLightMotion(Index: Integer): PKFSpot3DS;
Private | function GetSpotMotionCount: Integer;
Public | procedure ClearLists;

Properties

Public | property AmbientLightMotion: PKFAmbient3DS read GetAmbientMotion;
Public | property CameraMotion[Index: Integer]: PKFCamera3DS read GetCameraMotion;
Public | property CameraMotionCount: Integer read GetCamMotionCount;
Public | property MeshMotion[Index: Integer]: PKFMesh3DS read GetMeshMotion;
Public | property MeshMotionCount: Integer read GetMeshMotionCount;
Public | property OmniLightMotion[Index: Integer]: PKFOmni3DS read GetOmniLightMotion;
Public | property OmniLightMotionCount: Integer read GetOmniMotionCount;
Public | property Settings: TKFSets3DS read GetKFSets;
Public | property SpotLightMotion[Index: Integer]: PKFSpot3DS read GetSpotLightMotion;
Public | property SpotLightMotionCount: Integer read GetSpotMotionCount;

Description

Fields

Private FOwner: TFile3DS;

This item has no description.

Private FMeshMotionList: TList;

This item has no description.

Private FOmniMotionList: TList;

This item has no description.

Private FSpotMotionList: TList;

This item has no description.

Private FCameraMotionList: TList;

This item has no description.

Private FAmbientMotion: PKFAmbient3DS;

This item has no description.

Methods

Public constructor Create(AOwner: TFile3DS); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAmbientMotion: PKFAmbient3DS;

This item has no description.

Private function GetCameraMotion(Index: Integer): PKFCamera3DS;

This item has no description.

Private function GetCamMotionCount: Integer;

This item has no description.

Private function GetKFSets: TKFSets3DS;

This item has no description.

Private function GetMeshMotion(Index: Integer): PKFMesh3DS;

This item has no description.

Private function GetMeshMotionCount: Integer;

This item has no description.

Private function GetOmniLightMotion(Index: Integer): PKFOmni3DS;

This item has no description.

Private function GetOmniMotionCount: Integer;

This item has no description.

Private function GetSpotLightMotion(Index: Integer): PKFSpot3DS;

This item has no description.

Private function GetSpotMotionCount: Integer;

This item has no description.

Public procedure ClearLists;

This item has no description.

Properties

Public property AmbientLightMotion: PKFAmbient3DS read GetAmbientMotion;

This item has no description.

Public property CameraMotion[Index: Integer]: PKFCamera3DS read GetCameraMotion;

This item has no description.

Public property CameraMotionCount: Integer read GetCamMotionCount;

This item has no description.

Public property MeshMotion[Index: Integer]: PKFMesh3DS read GetMeshMotion;

This item has no description.

Public property MeshMotionCount: Integer read GetMeshMotionCount;

This item has no description.

Public property OmniLightMotion[Index: Integer]: PKFOmni3DS read GetOmniLightMotion;

This item has no description.

Public property OmniLightMotionCount: Integer read GetOmniMotionCount;

This item has no description.

Public property Settings: TKFSets3DS read GetKFSets;

This item has no description.

Public property SpotLightMotion[Index: Integer]: PKFSpot3DS read GetSpotLightMotion;

This item has no description.

Public property SpotLightMotionCount: Integer read GetSpotMotionCount;


GLSysHelp v.2.5: Formats.m3DS: Class TFile3DS

Class TFile3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DS

Declaration

type TFile3DS = class(TObject)

Description

The main class that supplies the user with all available data from a specific 3DS file. The data is currently read only, but the class might be finished sometime later...

Hierarchy

  • TObject
  • TFile3DS

Overview

Fields

Private | FNodeList: PNodeList;
Private | FDatabase: TDatabase3DS;
Private | FStream: TStream;
Private | FOwnStream: Boolean;
Private | FMaterialList: TMaterialList;
Private | FObjectList: TObjectList;
Private | FKeyFramer: TKeyFramer;
Private | FFileName: String;
Private | FOnLoadProgress: TLoadProgress;

Methods

Public | constructor Create; virtual;
Public | constructor CreateFromFile(const FileName: String); virtual;
Public | destructor Destroy; override;
Public | function InitChunkData(Chunk: PChunk3DS): Pointer;
Public | function ReadByte: Byte;
Public | function ReadCardinal: Cardinal;
Public | function ReadDouble: Double;
Public | function ReadFace: TFace3DS;
Public | function ReadInteger: Integer;
Public | function ReadKeyHeader: TKeyHeader3DS;
Public | function ReadPoint: TPoint3DS;
Public | function ReadShort: SmallInt;
Public | function ReadSingle: Single;
Public | function ReadString: PChar3DS;
Public | function ReadTexVert: TTexVert3DS;
Public | function ReadTrackHeader: TTrackHeader3DS;
Public | function ReadWord: Word;
Private | function GetAtmosphereData: TAtmosphere3DS;
Private | function GetBackgroundData: TBackground3DS;
Private | function GetDatabaseRelease: TReleaseLevel;
Private | function GetDatabaseType: TDBType3DS;
Private | function GetMeshRelease: TReleaseLevel;
Private | function GetMeshSettings: TMeshSet3DS;
Private | function GetViewportData: TViewport3DS;
Public | procedure ClearLists;
Public | procedure DumpDataBase(Strings: TStrings; DumpLevel: TDumpLevel);
Public | procedure FinishHeader(StartPos, EndPos: Cardinal);
Public | procedure LoadFromFile(const FileName: String);
Public | procedure LoadFromStream(const aStream: TStream);
Public | procedure ReadChunkData(Chunk: PChunk3DS);
Public | procedure ReadData(Size: Integer; Data: Pointer);
Public | procedure ReadHeader(var ChunkType: Word; var ChunkSize: Cardinal);
Public | procedure SeekChild(Chunk: PChunk3DS);
Public | procedure Skip(AValue: Integer);
Public | procedure WriteByte(AValue: Byte);
Public | procedure WriteCardinal(AValue: Cardinal);
Public | procedure WriteData(Size: Integer; Data: Pointer);
Public | procedure WriteDouble(AValue: Double);
Public | procedure WriteFace(const F: TFace3DS);
Public | procedure WriteFixedString(const AValue: String3DS; Len: Integer);
Public | procedure WriteHeader(ChunkType: Word; ChunkSize: Cardinal);
Public | procedure WriteInteger(AValue: Integer);
Public | procedure WriteKeyHeader(const K: TKeyHeader3DS);
Public | procedure WritePoint(const P: TPoint3DS);
Public | procedure WriteShort(AValue: SmallInt);
Public | procedure WriteSingle(AValue: Single);
Public | procedure WriteString(const AValue: String3DS);
Public | procedure WriteTexVertex(const T: TTexVert3DS);
Public | procedure WriteTrackHeader(const T: TTrackHeader3DS);
Public | procedure WriteWord(AValue: Word);

Properties

Public | property Atmosphere: TAtmosphere3DS read GetAtmosphereData;
Public | property Background: TBackground3DS read GetBackgroundData;
Public | property DatabaseRelease: TReleaseLevel read GetDatabaseRelease;
Public | property DatabaseType: TDBType3DS read GetDatabaseType;
Public | property FileName: String read FFileName;
Public | property KeyFramer: TKeyFramer read FKeyFramer;
Public | property Materials: TMaterialList read FMaterialList;
Public | property MeshRelease: TReleaseLevel read GetMeshRelease;
Public | property MeshSettings: TMeshSet3DS read GetMeshSettings;
Public | property Objects: TObjectList read FObjectList;
Public | property OnLoadProgress: TLoadProgress read FOnLoadProgress write FOnLoadProgress;
Public | property Viewport: TViewport3DS read GetViewportData;

Description

Fields

Private FNodeList: PNodeList;

This item has no description.

Private FDatabase: TDatabase3DS;

This item has no description.

Private FStream: TStream;

This item has no description.

Private FOwnStream: Boolean;

This item has no description.

Private FMaterialList: TMaterialList;

This item has no description.

Private FObjectList: TObjectList;

This item has no description.

Private FKeyFramer: TKeyFramer;

This item has no description.

Private FFileName: String;

This item has no description.

Private FOnLoadProgress: TLoadProgress;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public constructor CreateFromFile(const FileName: String); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function InitChunkData(Chunk: PChunk3DS): Pointer;

This item has no description.

Public function ReadByte: Byte;

basic access methods

Public function ReadCardinal: Cardinal;

This item has no description.

Public function ReadDouble: Double;

This item has no description.

Public function ReadFace: TFace3DS;

This item has no description.

Public function ReadInteger: Integer;

This item has no description.

Public function ReadKeyHeader: TKeyHeader3DS;

This item has no description.

Public function ReadPoint: TPoint3DS;

This item has no description.

Public function ReadShort: SmallInt;

This item has no description.

Public function ReadSingle: Single;

This item has no description.

Public function ReadString: PChar3DS;

This item has no description.

Public function ReadTexVert: TTexVert3DS;

This item has no description.

Public function ReadTrackHeader: TTrackHeader3DS;

This item has no description.

Public function ReadWord: Word;

This item has no description.

Private function GetAtmosphereData: TAtmosphere3DS;

This item has no description.

Private function GetBackgroundData: TBackground3DS;

This item has no description.

Private function GetDatabaseRelease: TReleaseLevel;

This item has no description.

Private function GetDatabaseType: TDBType3DS;

This item has no description.

Private function GetMeshRelease: TReleaseLevel;

This item has no description.

Private function GetMeshSettings: TMeshSet3DS;

This item has no description.

Private function GetViewportData: TViewport3DS;

This item has no description.

Public procedure ClearLists;

This item has no description.

Public procedure DumpDataBase(Strings: TStrings; DumpLevel: TDumpLevel);

database methods

Public procedure FinishHeader(StartPos, EndPos: Cardinal);

This item has no description.

Public procedure LoadFromFile(const FileName: String);

This item has no description.

Public procedure LoadFromStream(const aStream: TStream);

This item has no description.

Public procedure ReadChunkData(Chunk: PChunk3DS);

This item has no description.

Public procedure ReadData(Size: Integer; Data: Pointer);

This item has no description.

Public procedure ReadHeader(var ChunkType: Word; var ChunkSize: Cardinal);

This item has no description.

Public procedure SeekChild(Chunk: PChunk3DS);

This item has no description.

Public procedure Skip(AValue: Integer);

This item has no description.

Public procedure WriteByte(AValue: Byte);

This item has no description.

Public procedure WriteCardinal(AValue: Cardinal);

This item has no description.

Public procedure WriteData(Size: Integer; Data: Pointer);

This item has no description.

Public procedure WriteDouble(AValue: Double);

This item has no description.

Public procedure WriteFace(const F: TFace3DS);

This item has no description.

Public procedure WriteFixedString(const AValue: String3DS; Len: Integer);

This item has no description.

Public procedure WriteHeader(ChunkType: Word; ChunkSize: Cardinal);

This item has no description.

Public procedure WriteInteger(AValue: Integer);

This item has no description.

Public procedure WriteKeyHeader(const K: TKeyHeader3DS);

This item has no description.

Public procedure WritePoint(const P: TPoint3DS);

This item has no description.

Public procedure WriteShort(AValue: SmallInt);

This item has no description.

Public procedure WriteSingle(AValue: Single);

This item has no description.

Public procedure WriteString(const AValue: String3DS);

This item has no description.

Public procedure WriteTexVertex(const T: TTexVert3DS);

This item has no description.

Public procedure WriteTrackHeader(const T: TTrackHeader3DS);

This item has no description.

Public procedure WriteWord(AValue: Word);

This item has no description.

Properties

Public property Atmosphere: TAtmosphere3DS read GetAtmosphereData;

This item has no description.

Public property Background: TBackground3DS read GetBackgroundData;

This item has no description.

Public property DatabaseRelease: TReleaseLevel read GetDatabaseRelease;

This item has no description.

Public property DatabaseType: TDBType3DS read GetDatabaseType;

This item has no description.

Public property FileName: String read FFileName;

This item has no description.

Public property KeyFramer: TKeyFramer read FKeyFramer;

this is only valid if loaded from a file

Public property Materials: TMaterialList read FMaterialList;

This item has no description.

Public property MeshRelease: TReleaseLevel read GetMeshRelease;

This item has no description.

Public property MeshSettings: TMeshSet3DS read GetMeshSettings;

This item has no description.

Public property Objects: TObjectList read FObjectList;

This item has no description.

Public property OnLoadProgress: TLoadProgress read FOnLoadProgress write FOnLoadProgress;

This item has no description.

Public property Viewport: TViewport3DS read GetViewportData;


GLSysHelp v.2.5: Formats.m3DSConst

Unit Formats.m3DSConst

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Formats.m3DSTypes

Overview

Constants

FaceCAVisable3DS = $0001;
FaceBCVisable3DS = $0002;
FaceABVisable3DS = $0004;
FaceUWrap3DS = $0008;
FaceVWrap3DS = $0010;
KeyUsesTension3DS = $01;
KeyUsesCont3DS = $02;
KeyUsesBias3DS = $04;
KeyUsesEaseTo3DS = $08;
KeyUsesEaseFrom3DS = $10;
TrackSingle3DS = $0000;
TrackLoops3DS = $0003;
TrackRepeats3DS = $0002;
TrackLockX3DS = $0008;
TrackLockY3DS = $0010;
TrackLockZ3DS = $0020;
TrackNoLinkX3DS = $0100;
TrackNoLinkY3DS = $0200;
TrackNoLinkZ3DS = $0400;
DefPoint3DS : TPoint3DS = (X: 0; Y: 0; Z: 0);
DefTextVert3DS : TTexVert3DS = (U: 0; V: 0);
DefFace3DS : TFace3DS = (v1: 0; v2: 1; v3: 2; Flag: 0);
DefTrackHeader3DS : TTrackHeader3DS = (Flags: 0; nu1: 0; nu2: 0; KeyCount: 1);
DefKeyHeader3DS : TKeyHeader3DS = (Time: 0; RFlags: 0; Tension: 0; Continuity: 0; Bias: 0; EaseTo: 0; EaseFrom: 0);
DefObjMat3DS : TObjMat3DS = (NameStr: ''; NFaces: 0; FaceIndex: nil);
DefKFRotKey3DS : TKFRotKey3DS = (Angle: 0; X: 0; Y: 0; Z: 1);
LayerFogBgnd = $100000;
NoFalloff = $0;
TopFalloff = $2;
BottomFalloff = $1;
InitNoExtras3DS = $0000;
InitVertexArray3DS = $0001;
InitTextArray3DS = $0002;
InitFaceArray3DS = $0004;
InitMatArray3DS = $0008;
InitSmoothArray3DS = $0010;
InitProcData3DS = $0020;
InitVFlagArray3DS = $0040;
RelVertexArray3ds = $0001;
RelTextArray3ds = $0002;
RelFaceArray3ds = $0004;
RelMatArray3ds = $0008;
RelSmoothArray3ds = $0010;
RelProcData3ds = $0020;
RelVFlagArray3ds = $0040;
RelAll3DS = $FFFF;
Smooth01Group3DS = $00000001;
Smooth02Group3DS = $00000002;
Smooth03Group3DS = $00000004;
Smooth04Group3DS = $00000008;
Smooth05Group3DS = $00000010;
Smooth06Group3DS = $00000020;
Smooth07Group3DS = $00000030;
Smooth08Group3DS = $00000080;
Smooth09Group3DS = $00000100;
Smooth10Group3DS = $00000200;
Smooth11Group3DS = $00000400;
Smooth12Group3DS = $00000800;
Smooth13Group3DS = $00001000;
Smooth14Group3DS = $00002000;
Smooth15Group3DS = $00004000;
Smooth16Group3DS = $00008000;
Smooth17Group3DS = $00010000;
Smooth18Group3DS = $00020000;
Smooth19Group3DS = $00040000;
Smooth20Group3DS = $00080000;
Smooth21Group3DS = $00100000;
Smooth22Group3DS = $00200000;
Smooth23Group3DS = $00400000;
Smooth24Group3DS = $00800000;
Smooth25Group3DS = $01000000;
Smooth26Group3DS = $02000000;
Smooth27Group3DS = $04000000;
Smooth28Group3DS = $08000000;
Smooth29Group3DS = $10000000;
Smooth30Group3DS = $20000000;
Smooth31Group3DS = $40000000;
Smooth32Group3DS = $80000000;
DummyName3DS = '$$$DUMMY';
KfNodeOff3DS = 1 shl 3;
KfHideNode3DS = 1 shl 11;
KfFastNode3DS = 1 shl 12;
KfNodeHasPath3DS = 1;
KfNodeAutoSmooth3DS = 1 shl 1;
KfNodeFrozen3DS = 1 shl 2;
KfMotionBlur3DS = 1 shl 4;
KfBlurBranch3DS = 1 shl 5;
KfMorphMtl3DS = 1 shl 6;
KfMorphOb3DS = 1 shl 7;
FileNameStrMax3DS = 512;
FileAttrStrMax3DS = 128;
MasterScaleMin3DS = 0;
LoShadowBiasMin3DS = 0;
HiShadowBiasMin3DS = 0;
ShadowMapSizeMin3DS = 0;
ShadowSamplesMin3DS = 0;
ShadowRangeMin3DS = 0;
ShadowFilterMin3DS = 1;
ShadowFilterMax3DS = 10;
BitMapStrMax3DS = 12;
VGradientMin3DS = 0;
VGradientMax3DS = 1;
FogMin3DS = 0;
FogMax3DS = 1;
DistanceCueMin3DS = 0;
DistanceCueMax3DS = 1;
ViewCameraStrMax3DS = 10;
MatNameStrMax3DS = 16;
MatShadingMin3DS = 0;
MatShadingMax3DS = 3;
MatACubicFMin3DS = 1;
MatACubicAMin3DS = 0;
MatACubicAMax3DS = 3;
ACubicFirst3DS = $09;
ACubicFlat3DS = $11;
PointArrayMin3DS = 3;
FaceArrayMin3DS = 1;
MshMatGroupMin3DS = 1;
MshMatGroupStrMax3DS = 16;
ProcNameStrMax3DS = 12;
DLSpotlightMin3DS = 0;
DLSpotlightMax3DS = 160;
DLLocalShadow2SMin3DS = 10;
DLLocalShadow2SMax3DS = 4096;
DLLocalShadow2FMin3DS = 1;
DLLocalShadow2FMax3DS = 10;
ColorFMin3DS = 0;
ColorFMax3DS = 1;
IntPercentageMax3DS = 100;
FloatPercentageMax3DS = 1;
MatMapNameStrMax3DS = 12;
NamedObjectStrMax3DS = 10;
NCameraFOVMin3DS = 0.00025;
NCameraFOVMax3DS = 160;
NCameraFocMin3DS = 10.7813;
NCameraFocMax3DS = 10000000;
KFHdrStrMax3DS = 12;
NodeHdrStrMax3DS = 10;
InstanceNameStrMax3DS = 10;
MorphTrackStrMax3DS = 10;
MorphSmoothMin3DS = 0;
MorphSmoothMax3DS = 360;
KFTensionMin3DS = -1;
KFTensionMax3DS = 1;
KFContinuityMin3DS = -1;
KFContinuityMax3DS = 1;
KFBiasMin3DS = -1;
KFBiasMax3DS = 1;
KFEaseToMin3DS = 0;
KFEaseToMax3DS = 1;
KFEaseFromMin3DS = 0;
KFEaseFromMax3DS = 1;
TrackHeaderKeysMin3DS = 1;
ColTrackTagMin3DS = 0;
ColTrackTagMax3DS = 1;
FOVTrackTagMin3DS = NCameraFOVMin3DS;
FOVTrackTagMax3DS = NCameraFOVMax3DS;
HotTrackTagMin3DS = 0;
HotTrackTagMax3DS = 160;
FallTrackTagMin3DS = 0;
FallTrackTagMax3DS = 160;
KNoID = -1;
TEX_DECAL = 1;
TEX_MIRROR = 1 shl 1;
TEX_UNUSED1 = 1 shl 2;
TEX_INVERT = 1 shl 3;
TEX_NOWRAP = 1 shl 4;
TEX_SAT = 1 shl 5;
TEX_ALPHA_SOURCE = 1 shl 6;
TEX_TINT = 1 shl 7;
TEX_DONT_USE_ALPHA = 1 shl 8;
TEX_RGB_TINT = 1 shl 9;
NODE_RENDOB_HIDE = 1 shl 2;
NODE_OFF = 1 shl 3;
ATKEY1 = 1 shl 4;
ATKEY2 = 1 shl 5;
ATKEY3 = 1 shl 6;
ATKEY4 = 1 shl 7;
ATKEY5 = 1 shl 8;
ATKEYFLAGS = ATKEY1 or ATKEY2 or ATKEY3 or ATKEY4 or ATKEY5;
MARK_NODE = 1 shl 9;
DISABLE_NODE = 1 shl 10;
HIDE_NODE = 1 shl 11;
FAST_NODE = 1 shl 12;
PRIMARY_NODE = 1 shl 14;
NODE_CALC_PATH = 1 shl 15;
NODE_HAS_PATH = 1;
NODE_AUTO_SMOOTH = 1 shl 1;
NODE_FROZEN = 1 shl 2;
NODE_ANI_HIDDEN = 1 shl 3;
NODE_MOTION_BLUR = 1 shl 4;
NODE_BLUR_BRANCH = 1 shl 5;
NODE_MORPH_MTL = 1 shl 6;
NODE_MORPH_OB = 1 shl 7;
NULL_CHUNK = $0000;
ChunkType = $0995;
ChunkUnique = $0996;
NotChunk = $0997;
Container = $0998;
IsChunk = $0999;
DUMMY = $FFFF;
POINT_ARRAY_ENTRY = $F110;
POINT_FLAG_ARRAY_ENTRY = $F111;
FACE_ARRAY_ENTRY = $F120;
MSH_MAT_GROUP_ENTRY = $F130;
TEX_VERTS_ENTRY = $F140;
SMOOTH_GROUP_ENTRY = $F150;
POS_TRACK_TAG_KEY = $F020;
ROT_TRACK_TAG_KEY = $F021;
SCL_TRACK_TAG_KEY = $F022;
FOV_TRACK_TAG_KEY = $F023;
ROLL_TRACK_TAG_KEY = $F024;
COL_TRACK_TAG_KEY = $F025;
MORPH_TRACK_TAG_KEY = $F026;
HOT_TRACK_TAG_KEY = $F027;
FALL_TRACK_TAG_KEY = $F028;
M3DMAGIC = $4D4D;
SMAGIC = $2D2D;
LMAGIC = $2D3D;
MLIBMAGIC = $3DAA;
MATMAGIC = $3DFF;
M3D_VERSION = $0002;
M3D_KFVERSION = $0005;
MDATA = $3D3D;
MESH_VERSION = $3D3E;
COLOR_F = $0010;
COLOR_24 = $0011;
LIN_COLOR_24 = $0012;
LIN_COLOR_F = $0013;
INT_PERCENTAGE = $0030;
FLOAT_PERCENTAGE = $0031;
MASTER_SCALE = $0100;
BIT_MAP = $1100;
USE_BIT_MAP = $1101;
SOLID_BGND = $1200;
USE_SOLID_BGND = $1201;
V_GRADIENT = $1300;
USE_V_GRADIENT = $1301;
LO_SHADOW_BIAS = $1400;
HI_SHADOW_BIAS = $1410;
SHADOW_MAP_SIZE = $1420;
SHADOW_SAMPLES = $1430;
SHADOW_RANGE = $1440;
SHADOW_FILTER = $1450;
RAY_BIAS = $1460;
O_CONSTS = $1500;
AMBIENT_LIGHT = $2100;
FOG = $2200;
USE_FOG = $2201;
FOG_BGND = $2210;
DISTANCE_CUE = $2300;
USE_DISTANCE_CUE = $2301;
LAYER_FOG = $2302;
USE_LAYER_FOG = $2303;
DCUE_BGND = $2310;
DEFAULT_VIEW = $3000;
VIEW_TOP = $3010;
VIEW_BOTTOM = $3020;
VIEW_LEFT = $3030;
VIEW_RIGHT = $3040;
VIEW_FRONT = $3050;
VIEW_BACK = $3060;
VIEW_USER = $3070;
VIEW_CAMERA = $3080;
VIEW_WINDOW = $3090;
NAMED_OBJECT = $4000;
OBJ_HIDDEN = $4010;
OBJ_VIS_LOFTER = $4011;
OBJ_DOESNT_CAST = $4012;
OBJ_MATTE = $4013;
OBJ_FAST = $4014;
OBJ_PROCEDURAL = $4015;
OBJ_FROZEN = $4016;
OBJ_DONT_RCVSHADOW = $4017;
N_TRI_OBJECT = $4100;
POINT_ARRAY = $4110;
POINT_FLAG_ARRAY = $4111;
FACE_ARRAY = $4120;
MSH_MAT_GROUP = $4130;
OLD_MAT_GROUP = $4131;
TEX_VERTS = $4140;
SMOOTH_GROUP = $4150;
MESH_MATRIX = $4160;
MESH_COLOR = $4165;
MESH_TEXTURE_INFO = $4170;
PROC_NAME = $4181;
PROC_DATA = $4182;
MSH_BOXMAP = $4190;
N_D_L_OLD = $4400;
N_CAM_OLD = $4500;
N_DIRECT_LIGHT = $4600;
DL_SPOTLIGHT = $4610;
DL_OFF = $4620;
DL_ATTENUATE = $4625;
DL_RAYSHAD = $4627;
DL_SHADOWED = $4630;
DL_LOCAL_SHADOW = $4640;
DL_LOCAL_SHADOW2 = $4641;
DL_SEE_CONE = $4650;
DL_SPOT_RECTANGULAR = $4651;
DL_SPOT_OVERSHOOT = $4652;
DL_SPOT_PROJECTOR = $4653;
DL_EXCLUDE = $4654;
DL_RANGE = $4655;
DL_SPOT_ROLL = $4656;
DL_SPOT_ASPECT = $4657;
DL_RAY_BIAS = $4658;
DL_INNER_RANGE = $4659;
DL_OUTER_RANGE = $465A;
DL_MULTIPLIER = $465B;
N_AMBIENT_LIGHT = $4680;
N_CAMERA = $4700;
CAM_SEE_CONE = $4710;
CAM_RANGES = $4720;
HIERARCHY = $4F00;
PARENT_OBJECT = $4F10;
PIVOT_OBJECT = $4F20;
PIVOT_LIMITS = $4F30;
PIVOT_ORDER = $4F40;
XLATE_RANGE = $4F50;
POLY_2D = $5000;
SHAPE_OK = $5010;
SHAPE_NOT_OK = $5011;
SHAPE_HOOK = $5020;
PATH_3D = $6000;
PATH_MATRIX = $6005;
SHAPE_2D = $6010;
M_SCALE = $6020;
M_TWIST = $6030;
M_TEETER = $6040;
M_FIT = $6050;
M_BEVEL = $6060;
XZ_CURVE = $6070;
YZ_CURVE = $6080;
INTERPCT = $6090;
DEFORM_LIMIT = $60A0;
USE_CONTOUR = $6100;
USE_TWEEN = $6110;
USE_SCALE = $6120;
USE_TWIST = $6130;
USE_TEETER = $6140;
USE_FIT = $6150;
USE_BEVEL = $6160;
VIEWPORT_LAYOUT_OLD = $7000;
VIEWPORT_DATA_OLD = $7010;
VIEWPORT_LAYOUT = $7001;
VIEWPORT_DATA = $7011;
VIEWPORT_DATA_3 = $7012;
VIEWPORT_SIZE = $7020;
NETWORK_VIEW = $7030;
XDATA_SECTION = $8000;
XDATA_ENTRY = $8001;
XDATA_APPNAME = $8002;
XDATA_STRING = $8003;
XDATA_FLOAT = $8004;
XDATA_DOUBLE = $8005;
XDATA_SHORT = $8006;
XDATA_LONG = $8007;
XDATA_VOID = $8008;
XDATA_GROUP = $8009;
XDATA_RFU6 = $800A;
XDATA_RFU5 = $800B;
XDATA_RFU4 = $800C;
XDATA_RFU3 = $800D;
XDATA_RFU2 = $800E;
XDATA_RFU1 = $800F;
PARENT_NAME = $80F0;
MAT_ENTRY = $AFFF;
MAT_NAME = $A000;
MAT_AMBIENT = $A010;
MAT_DIFFUSE = $A020;
MAT_SPECULAR = $A030;
MAT_SHININESS = $A040;
MAT_SHIN2PCT = $A041;
MAT_SHIN3PCT = $A042;
MAT_TRANSPARENCY = $A050;
MAT_XPFALL = $A052;
MAT_REFBLUR = $A053;
MAT_SELF_ILLUM = $A080;
MAT_TWO_SIDE = $A081;
MAT_DECAL = $A082;
MAT_ADDITIVE = $A083;
MAT_SELF_ILPCT = $A084;
MAT_WIRE = $A085;
MAT_SUPERSMP = $A086;
MAT_WIRESIZE = $A087;
MAT_FACEMAP = $A088;
MAT_XPFALLIN = $A08A;
MAT_PHONGSOFT = $A08C;
MAT_WIREABS = $A08E;
MAT_SHADING = $A100;
MAT_TEXMAP = $A200;
MAT_OPACMAP = $A210;
MAT_REFLMAP = $A220;
MAT_BUMPMAP = $A230;
MAT_SPECMAP = $A204;
MAT_USE_XPFALL = $A240;
MAT_USE_REFBLUR = $A250;
MAT_BUMP_PERCENT = $A252;
MAT_MAPNAME = $A300;
MAT_ACUBIC = $A310;
MAT_SXP_TEXT_DATA = $A320;
MAT_SXP_TEXT2_DATA = $A321;
MAT_SXP_OPAC_DATA = $A322;
MAT_SXP_BUMP_DATA = $A324;
MAT_SXP_SPEC_DATA = $A325;
MAT_SXP_SHIN_DATA = $A326;
MAT_SXP_SELFI_DATA = $A328;
MAT_SXP_TEXT_MASKDATA = $A32A;
MAT_SXP_TEXT2_MASKDATA = $A32C;
MAT_SXP_OPAC_MASKDATA = $A32E;
MAT_SXP_BUMP_MASKDATA = $A330;
MAT_SXP_SPEC_MASKDATA = $A332;
MAT_SXP_SHIN_MASKDATA = $A334;
MAT_SXP_SELFI_MASKDATA = $A336;
MAT_SXP_REFL_MASKDATA = $A338;
MAT_TEX2MAP = $A33A;
MAT_SHINMAP = $A33C;
MAT_SELFIMAP = $A33D;
MAT_TEXMASK = $A33E;
MAT_TEX2MASK = $A340;
MAT_OPACMASK = $A342;
MAT_BUMPMASK = $A344;
MAT_SHINMASK = $A346;
MAT_SPECMASK = $A348;
MAT_SELFIMASK = $A34A;
MAT_REFLMASK = $A34C;
MAT_MAP_TILINGOLD = $A350;
MAT_MAP_TILING = $A351;
MAT_MAP_TEXBLUR_OLD = $A352;
MAT_MAP_TEXBLUR = $A353;
MAT_MAP_USCALE = $A354;
MAT_MAP_VSCALE = $A356;
MAT_MAP_UOFFSET = $A358;
MAT_MAP_VOFFSET = $A35A;
MAT_MAP_ANG = $A35C;
MAT_MAP_COL1 = $A360;
MAT_MAP_COL2 = $A362;
MAT_MAP_RCOL = $A364;
MAT_MAP_GCOL = $A366;
MAT_MAP_BCOL = $A368;
KFDATA = $B000;
KFHDR = $B00A;
AMBIENT_NODE_TAG = $B001;
OBJECT_NODE_TAG = $B002;
CAMERA_NODE_TAG = $B003;
TARGET_NODE_TAG = $B004;
LIGHT_NODE_TAG = $B005;
L_TARGET_NODE_TAG = $B006;
SPOTLIGHT_NODE_TAG = $B007;
KFSEG = $B008;
KFCURTIME = $B009;
NODE_HDR = $B010;
INSTANCE_NAME = $B011;
PRESCALE = $B012;
PIVOT = $B013;
BOUNDBOX = $B014;
MORPH_SMOOTH = $B015;
POS_TRACK_TAG = $B020;
ROT_TRACK_TAG = $B021;
SCL_TRACK_TAG = $B022;
FOV_TRACK_TAG = $B023;
ROLL_TRACK_TAG = $B024;
COL_TRACK_TAG = $B025;
MORPH_TRACK_TAG = $B026;
HOT_TRACK_TAG = $B027;
FALL_TRACK_TAG = $B028;
HIDE_TRACK_TAG = $B029;
NODE_ID = $B030;
CMAGIC = $C23D;
C_MDRAWER = $C010;
C_TDRAWER = $C020;
C_SHPDRAWER = $C030;
C_MODDRAWER = $C040;
C_RIPDRAWER = $C050;
C_TXDRAWER = $C060;
C_PDRAWER = $C062;
C_MTLDRAWER = $C064;
C_FLIDRAWER = $C066;
C_CUBDRAWER = $C067;
C_MFILE = $C070;
C_SHPFILE = $C080;
C_MODFILE = $C090;
C_RIPFILE = $C0A0;
C_TXFILE = $C0B0;
C_PFILE = $C0B2;
C_MTLFILE = $C0B4;
C_FLIFILE = $C0B6;
C_PALFILE = $C0B8;
C_TX_STRING = $C0C0;
C_CONSTS = $C0D0;
C_SNAPS = $C0E0;
C_GRIDS = $C0F0;
C_ASNAPS = $C100;
C_GRID_RANGE = $C110;
C_RENDTYPE = $C120;
C_PROGMODE = $C130;
C_PREVMODE = $C140;
C_MODWMODE = $C150;
C_MODMODEL = $C160;
C_ALL_LINES = $C170;
C_BACK_TYPE = $C180;
C_MD_CS = $C190;
C_MD_CE = $C1A0;
C_MD_SML = $C1B0;
C_MD_SMW = $C1C0;
C_LOFT_WITH_TEXTURE = $C1C3;
C_LOFT_L_REPEAT = $C1C4;
C_LOFT_W_REPEAT = $C1C5;
C_LOFT_UV_NORMALIZE = $C1C6;
C_WELD_LOFT = $C1C7;
C_MD_PDET = $C1D0;
C_MD_SDET = $C1E0;
C_RGB_RMODE = $C1F0;
C_RGB_HIDE = $C200;
C_RGB_MAPSW = $C202;
C_RGB_TWOSIDE = $C204;
C_RGB_SHADOW = $C208;
C_RGB_AA = $C210;
C_RGB_OVW = $C220;
C_RGB_OVH = $C230;
C_RGB_PICTYPE = $C240;
C_RGB_OUTPUT = $C250;
C_RGB_TODISK = $C253;
C_RGB_COMPRESS = $C254;
C_JPEG_COMPRESSION = $C255;
C_RGB_DISPDEV = $C256;
C_RGB_HARDDEV = $C259;
C_RGB_PATH = $C25A;
C_BITMAP_DRAWER = $C25B;
C_RGB_FILE = $C260;
C_RGB_OVASPECT = $C270;
C_RGB_ANIMTYPE = $C271;
C_RENDER_ALL = $C272;
C_REND_FROM = $C273;
C_REND_TO = $C274;
C_REND_NTH = $C275;
C_PAL_TYPE = $C276;
C_RND_TURBO = $C277;
C_RND_MIP = $C278;
C_BGND_METHOD = $C279;
C_AUTO_REFLECT = $C27A;
C_VP_FROM = $C27B;
C_VP_TO = $C27C;
C_VP_NTH = $C27D;
C_REND_TSTEP = $C27E;
C_VP_TSTEP = $C27F;
C_SRDIAM = $C280;
C_SRDEG = $C290;
C_SRSEG = $C2A0;
C_SRDIR = $C2B0;
C_HETOP = $C2C0;
C_HEBOT = $C2D0;
C_HEHT = $C2E0;
C_HETURNS = $C2F0;
C_HEDEG = $C300;
C_HESEG = $C310;
C_HEDIR = $C320;
C_QUIKSTUFF = $C330;
C_SEE_LIGHTS = $C340;
C_SEE_CAMERAS = $C350;
C_SEE_3D = $C360;
C_MESHSEL = $C370;
C_MESHUNSEL = $C380;
C_POLYSEL = $C390;
C_POLYUNSEL = $C3A0;
C_SHPLOCAL = $C3A2;
C_MSHLOCAL = $C3A4;
C_NUM_FORMAT = $C3B0;
C_ARCH_DENOM = $C3C0;
C_IN_DEVICE = $C3D0;
C_MSCALE = $C3E0;
C_COMM_PORT = $C3F0;
C_TAB_BASES = $C400;
C_TAB_DIVS = $C410;
C_MASTER_SCALES = $C420;
C_SHOW_1STVERT = $C430;
C_SHAPER_OK = $C440;
C_LOFTER_OK = $C450;
C_EDITOR_OK = $C460;
C_KEYFRAMER_OK = $C470;
C_PICKSIZE = $C480;
C_MAPTYPE = $C490;
C_MAP_DISPLAY = $C4A0;
C_TILE_XY = $C4B0;
C_MAP_XYZ = $C4C0;
C_MAP_SCALE = $C4D0;
C_MAP_MATRIX_OLD = $C4E0;
C_MAP_MATRIX = $C4E1;
C_MAP_WID_HT = $C4F0;
C_OBNAME = $C500;
C_CAMNAME = $C510;
C_LTNAME = $C520;
C_CUR_MNAME = $C525;
C_CURMTL_FROM_MESH = $C526;
C_GET_SHAPE_MAKE_FACES = $C527;
C_DETAIL = $C530;
C_VERTMARK = $C540;
C_MSHAX = $C550;
C_MSHCP = $C560;
C_USERAX = $C570;
C_SHOOK = $C580;
C_RAX = $C590;
C_STAPE = $C5A0;
C_LTAPE = $C5B0;
C_ETAPE = $C5C0;
C_KTAPE = $C5C8;
C_SPHSEGS = $C5D0;
C_GEOSMOOTH = $C5E0;
C_HEMISEGS = $C5F0;
C_PRISMSEGS = $C600;
C_PRISMSIDES = $C610;
C_TUBESEGS = $C620;
C_TUBESIDES = $C630;
C_TORSEGS = $C640;
C_TORSIDES = $C650;
C_CONESIDES = $C660;
C_CONESEGS = $C661;
C_NGPARMS = $C670;
C_PTHLEVEL = $C680;
C_MSCSYM = $C690;
C_MFTSYM = $C6A0;
C_MTTSYM = $C6B0;
C_SMOOTHING = $C6C0;
C_MODICOUNT = $C6D0;
C_FONTSEL = $C6E0;
C_TESS_TYPE = $C6f0;
C_TESS_TENSION = $C6f1;
C_SEG_START = $C700;
C_SEG_END = $C705;
C_CURTIME = $C710;
C_ANIMLENGTH = $C715;
C_PV_FROM = $C720;
C_PV_TO = $C725;
C_PV_DOFNUM = $C730;
C_PV_RNG = $C735;
C_PV_NTH = $C740;
C_PV_TYPE = $C745;
C_PV_METHOD = $C750;
C_PV_FPS = $C755;
C_VTR_FRAMES = $C765;
C_VTR_HDTL = $C770;
C_VTR_HD = $C771;
C_VTR_TL = $C772;
C_VTR_IN = $C775;
C_VTR_PK = $C780;
C_VTR_SH = $C785;
C_WORK_MTLS = $C790;
C_WORK_MTLS_2 = $C792;
C_WORK_MTLS_3 = $C793;
C_WORK_MTLS_4 = $C794;
C_WORK_MTLS_5 = $CB00;
C_WORK_MTLS_6 = $CB01;
C_WORK_MTLS_7 = $CB02;
C_WORK_MTLS_8 = $CB03;
C_WORKMTL = $CB04;
C_SXP_TEXT_DATA = $CB10;
C_SXP_TEXT2_DATA = $CB20;
C_SXP_OPAC_DATA = $CB11;
C_SXP_BUMP_DATA = $CB12;
C_SXP_SPEC_DATA = $CB24;
C_SXP_SHIN_DATA = $CB13;
C_SXP_SELFI_DATA = $CB28;
C_SXP_TEXT_MASKDATA = $CB30;
C_SXP_TEXT2_MASKDATA = $CB32;
C_SXP_OPAC_MASKDATA = $CB34;
C_SXP_BUMP_MASKDATA = $CB36;
C_SXP_SPEC_MASKDATA = $CB38;
C_SXP_SHIN_MASKDATA = $CB3A;
C_SXP_SELFI_MASKDATA = $C3CB;
C_SXP_REFL_MASKDATA = $CB3E;
C_BGTYPE = $C7A1;
C_MEDTILE = $C7B0;
C_LO_CONTRAST = $C7D0;
C_HI_CONTRAST = $C7D1;
C_FROZ_DISPLAY = $C7E0;
C_BOOLWELD = $C7f0;
C_BOOLTYPE = $C7f1;
C_ANG_THRESH = $C900;
C_SS_THRESH = $C901;
C_TEXTURE_BLUR_DEFAULT = $C903;
C_MAPDRAWER = $CA00;
C_MAPDRAWER1 = $CA01;
C_MAPDRAWER2 = $CA02;
C_MAPDRAWER3 = $CA03;
C_MAPDRAWER4 = $CA04;
C_MAPDRAWER5 = $CA05;
C_MAPDRAWER6 = $CA06;
C_MAPDRAWER7 = $CA07;
C_MAPDRAWER8 = $CA08;
C_MAPDRAWER9 = $CA09;
C_MAPDRAWER_ENTRY = $CA10;
C_BACKUP_FILE = $CA20;
C_DITHER_256 = $CA21;
C_SAVE_LAST = $CA22;
C_USE_ALPHA = $CA23;
C_TGA_DEPTH = $CA24;
C_REND_FIELDS = $CA25;
C_REFLIP = $CA26;
C_SEL_ITEMTOG = $CA27;
C_SEL_RESET = $CA28;
C_STICKY_KEYINF = $CA29;
C_WELD_THRESHOLD = $CA2A;
C_ZCLIP_POINT = $CA2B;
C_ALPHA_SPLIT = $CA2C;
C_KF_SHOW_BACKFACE = $CA30;
C_OPTIMIZE_LOFT = $CA40;
C_TENS_DEFAULT = $CA42;
C_CONT_DEFAULT = $CA44;
C_BIAS_DEFAULT = $CA46;
C_DXFNAME_SRC = $CA50;
C_AUTO_WELD = $CA60;
C_AUTO_UNIFY = $CA70;
C_AUTO_SMOOTH = $CA80;
C_DXF_SMOOTH_ANG = $CA90;
C_SMOOTH_ANG = $CAA0;
C_NET_USE_VPOST = $CC00;
C_NET_USE_GAMMA = $CC10;
C_NET_FIELD_ORDER = $CC20;
C_BLUR_FRAMES = $CD00;
C_BLUR_SAMPLES = $CD10;
C_BLUR_DUR = $CD20;
C_HOT_METHOD = $CD30;
C_HOT_CHECK = $CD40;
C_PIXEL_SIZE = $CD50;
C_DISP_GAMMA = $CD60;
C_FBUF_GAMMA = $CD70;
C_FILE_OUT_GAMMA = $CD80;
C_FILE_IN_GAMMA = $CD82;
C_GAMMA_CORRECT = $CD84;
C_APPLY_DISP_GAMMA = $CD90;
C_APPLY_FBUF_GAMMA = $CDA0;
C_APPLY_FILE_GAMMA = $CDB0;
C_FORCE_WIRE = $CDC0;
C_RAY_SHADOWS = $CDD0;
C_MASTER_AMBIENT = $CDE0;
C_SUPER_SAMPLE = $CDF0;
C_OBJECT_MBLUR = $CE00;
C_MBLUR_DITHER = $CE10;
C_DITHER_24 = $CE20;
C_SUPER_BLACK = $CE30;
C_SAFE_FRAME = $CE40;
C_VIEW_PRES_RATIO = $CE50;
C_BGND_PRES_RATIO = $CE60;
C_NTH_SERIAL_NUM = $CE70;
VPDATA = $D000;
P_QUEUE_ENTRY = $D100;
P_QUEUE_IMAGE = $D110;
P_QUEUE_USEIGAMMA = $D114;
P_QUEUE_PROC = $D120;
P_QUEUE_SOLID = $D130;
P_QUEUE_GRADIENT = $D140;
P_QUEUE_KF = $D150;
P_QUEUE_MOTBLUR = $D152;
P_QUEUE_MB_REPEAT = $D153;
P_QUEUE_NONE = $D160;
P_QUEUE_RESIZE = $D180;
P_QUEUE_OFFSET = $D185;
P_QUEUE_ALIGN = $D190;
P_CUSTOM_SIZE = $D1a0;
P_ALPH_NONE = $D210;
P_ALPH_PSEUDO = $D220;
P_ALPH_OP_PSEUDO = $D221;
P_ALPH_BLUR = $D222;
P_ALPH_PCOL = $D225;
P_ALPH_C0 = $D230;
P_ALPH_OP_KEY = $D231;
P_ALPH_KCOL = $D235;
P_ALPH_OP_NOCONV = $D238;
P_ALPH_IMAGE = $D240;
P_ALPH_ALPHA = $D250;
P_ALPH_QUES = $D260;
P_ALPH_QUEIMG = $D265;
P_ALPH_CUTOFF = $D270;
P_ALPHANEG = $D280;
P_TRAN_NONE = $D300;
P_TRAN_IMAGE = $D310;
P_TRAN_FRAMES = $D312;
P_TRAN_FADEIN = $D320;
P_TRAN_FADEOUT = $D330;
P_TRANNEG = $D340;
P_RANGES = $D400;
P_PROC_DATA = $D500;
NodeTagCount = 6;
NodeTags: array[1..NodeTagCount] of Word = (TARGET_NODE_TAG, OBJECT_NODE_TAG, CAMERA_NODE_TAG, LIGHT_NODE_TAG, L_TARGET_NODE_TAG, SPOTLIGHT_NODE_TAG );

Description

Constants

FaceCAVisable3DS = $0001;

—————- Constants for commonly used structures ——————– Flags used by the flag field of the Mesh3DS structure

FaceBCVisable3DS = $0002;

flags the CA edge as visible

FaceABVisable3DS = $0004;

flags the BC edge as visible

FaceUWrap3DS = $0008;

flags the AB edge as visible

FaceVWrap3DS = $0010;

flags the face as being at a texture coord u wrap seam

KeyUsesTension3DS = $01;

flags the face as being at a texture coord v wrap seam flags used by the rflags field of the keyheader3DS structure

KeyUsesCont3DS = $02;

This item has no description.

KeyUsesBias3DS = $04;

This item has no description.

KeyUsesEaseTo3DS = $08;

This item has no description.

KeyUsesEaseFrom3DS = $10;

This item has no description.

TrackSingle3DS = $0000;

flags used by the track flags field

TrackLoops3DS = $0003;

This item has no description.

TrackRepeats3DS = $0002;

This item has no description.

TrackLockX3DS = $0008;

This item has no description.

TrackLockY3DS = $0010;

This item has no description.

TrackLockZ3DS = $0020;

This item has no description.

TrackNoLinkX3DS = $0100;

This item has no description.

TrackNoLinkY3DS = $0200;

This item has no description.

TrackNoLinkZ3DS = $0400;

This item has no description.

DefPoint3DS : TPoint3DS = (X: 0; Y: 0; Z: 0);

Basic structure default contents for ease of initialization

DefTextVert3DS : TTexVert3DS = (U: 0; V: 0);

This item has no description.

DefFace3DS : TFace3DS = (v1: 0; v2: 1; v3: 2; Flag: 0);

This item has no description.

DefTrackHeader3DS : TTrackHeader3DS = (Flags: 0; nu1: 0; nu2: 0; KeyCount: 1);

This item has no description.

DefKeyHeader3DS : TKeyHeader3DS = (Time: 0; RFlags: 0; Tension: 0; Continuity: 0; Bias: 0; EaseTo: 0; EaseFrom: 0);

This item has no description.

DefObjMat3DS : TObjMat3DS = (NameStr: ''; NFaces: 0; FaceIndex: nil);

This item has no description.

DefKFRotKey3DS : TKFRotKey3DS = (Angle: 0; X: 0; Y: 0; Z: 1);

This item has no description.

LayerFogBgnd = $100000;

Fog Flags

NoFalloff = $0;

This item has no description.

TopFalloff = $2;

This item has no description.

BottomFalloff = $1;

This item has no description.

InitNoExtras3DS = $0000;

Flags for initflags parameter

InitVertexArray3DS = $0001;

This item has no description.

InitTextArray3DS = $0002;

This item has no description.

InitFaceArray3DS = $0004;

This item has no description.

InitMatArray3DS = $0008;

This item has no description.

InitSmoothArray3DS = $0010;

This item has no description.

InitProcData3DS = $0020;

This item has no description.

InitVFlagArray3DS = $0040;

This item has no description.

RelVertexArray3ds = $0001;

field codes for RelMeshObjField3ds

RelTextArray3ds = $0002;

This item has no description.

RelFaceArray3ds = $0004;

This item has no description.

RelMatArray3ds = $0008;

This item has no description.

RelSmoothArray3ds = $0010;

This item has no description.

RelProcData3ds = $0020;

This item has no description.

RelVFlagArray3ds = $0040;

This item has no description.

RelAll3DS = $FFFF;

This item has no description.

Smooth01Group3DS = $00000001;

Smoothing group Flags used in the smootharray field of the TMesh3DS structure

Smooth02Group3DS = $00000002;

This item has no description.

Smooth03Group3DS = $00000004;

This item has no description.

Smooth04Group3DS = $00000008;

This item has no description.

Smooth05Group3DS = $00000010;

This item has no description.

Smooth06Group3DS = $00000020;

This item has no description.

Smooth07Group3DS = $00000030;

This item has no description.

Smooth08Group3DS = $00000080;

This item has no description.

Smooth09Group3DS = $00000100;

This item has no description.

Smooth10Group3DS = $00000200;

This item has no description.

Smooth11Group3DS = $00000400;

This item has no description.

Smooth12Group3DS = $00000800;

This item has no description.

Smooth13Group3DS = $00001000;

This item has no description.

Smooth14Group3DS = $00002000;

This item has no description.

Smooth15Group3DS = $00004000;

This item has no description.

Smooth16Group3DS = $00008000;

This item has no description.

Smooth17Group3DS = $00010000;

This item has no description.

Smooth18Group3DS = $00020000;

This item has no description.

Smooth19Group3DS = $00040000;

This item has no description.

Smooth20Group3DS = $00080000;

This item has no description.

Smooth21Group3DS = $00100000;

This item has no description.

Smooth22Group3DS = $00200000;

This item has no description.

Smooth23Group3DS = $00400000;

This item has no description.

Smooth24Group3DS = $00800000;

This item has no description.

Smooth25Group3DS = $01000000;

This item has no description.

Smooth26Group3DS = $02000000;

This item has no description.

Smooth27Group3DS = $04000000;

This item has no description.

Smooth28Group3DS = $08000000;

This item has no description.

Smooth29Group3DS = $10000000;

This item has no description.

Smooth30Group3DS = $20000000;

This item has no description.

Smooth31Group3DS = $40000000;

This item has no description.

Smooth32Group3DS = $80000000;

This item has no description.

DummyName3DS = '$$$DUMMY';

This item has no description.

KfNodeOff3DS = 1 shl 3;

flag settings for TKFMesh3DS, TKFOmni3DS, TKFCamera3DS, TKFAmbient and TKFSpot3DS ml: these flags correspond directly to NODE_RENDOB_HIDE etc. (see below), I don't know what these duplications are for... for the flags field

KfHideNode3DS = 1 shl 11;

This item has no description.

KfFastNode3DS = 1 shl 12;

This item has no description.

KfNodeHasPath3DS = 1;

For the flags2 field

KfNodeAutoSmooth3DS = 1 shl 1;

This item has no description.

KfNodeFrozen3DS = 1 shl 2;

This item has no description.

KfMotionBlur3DS = 1 shl 4;

This item has no description.

KfBlurBranch3DS = 1 shl 5;

This item has no description.

KfMorphMtl3DS = 1 shl 6;

This item has no description.

KfMorphOb3DS = 1 shl 7;

This item has no description.

FileNameStrMax3DS = 512;

————– constants that define various value ranges for specific chunks 3DS filename

FileAttrStrMax3DS = 128;

3DS file attributes

MasterScaleMin3DS = 0;

MASTER_SCALE chunk

LoShadowBiasMin3DS = 0;

noninclusive minimum value for master scale LO_SHADOW_BIAS chunk

HiShadowBiasMin3DS = 0;

noninclusive minimum value for low shadow bias setting HI_SHADOW_BIAS chunk

ShadowMapSizeMin3DS = 0;

noninclusive minimum value for high shadow bias setting SHADOW_MAP_SIZE chunk

ShadowSamplesMin3DS = 0;

noninclusive minimum value for shadow map size SHADOW_SAMPLES chunk

ShadowRangeMin3DS = 0;

noninclusive minimum value for shadow samples SHADOW_RANGE chunk

ShadowFilterMin3DS = 1;

noninclusive minimum value for shadow range SHADOW_FILTER chunk

ShadowFilterMax3DS = 10;

inclusive minimum value for shadow filter

BitMapStrMax3DS = 12;

inclusive maximum value for shadow filter BITMAP chunk

VGradientMin3DS = 0;

maximum string length for filename V_GRADIENT chunk

VGradientMax3DS = 1;

minimum value for gradient midpoint

FogMin3DS = 0;

maximum value for gradient midpoint FOG chunk

FogMax3DS = 1;

minimum value for fogging plane density

DistanceCueMin3DS = 0;

maximum value for fogging plane density DISTANCE_CUE

DistanceCueMax3DS = 1;

minimum value for dimming factor

ViewCameraStrMax3DS = 10;

maximum value for dimming factor VIEW_CAMERA

MatNameStrMax3DS = 16;

maximum string length for filename MAT_NAME

MatShadingMin3DS = 0;

maximum string length for material name MAT_SHADING

MatShadingMax3DS = 3;

minimum shading value

MatACubicFMin3DS = 1;

maximum shading value MAT_ACUBIC_FMIN

MatACubicAMin3DS = 0;

minimum frame skip count

MatACubicAMax3DS = 3;

minimum reflection map aliasing

ACubicFirst3DS = $09;

maximum reflection map aliasing used with TAcubic3DS structure

ACubicFlat3DS = $11;

This item has no description.

PointArrayMin3DS = 3;

POINT_ARRAY

FaceArrayMin3DS = 1;

minimum number of vertices FACE_ARRAY

MshMatGroupMin3DS = 1;

minimum number of faces MshMatGroup3DS

MshMatGroupStrMax3DS = 16;

minimum number of faces per material

ProcNameStrMax3DS = 12;

maximim string length for MshMatGroup PROC_NAME

DLSpotlightMin3DS = 0;

maximum string length for axp process DL_SPOTLIGHT

DLSpotlightMax3DS = 160;

minimum for hotspot and falloff cones

DLLocalShadow2SMin3DS = 10;

maximum for hotspot and falloff cones DL_LOCAL_SHADOW2

DLLocalShadow2SMax3DS = 4096;

minimum shadow map size

DLLocalShadow2FMin3DS = 1;

maximum shadow map size

DLLocalShadow2FMax3DS = 10;

minimum shadow map size

ColorFMin3DS = 0;

maximum shadow map size COLOR_F

ColorFMax3DS = 1;

minimum color value in a channel

IntPercentageMax3DS = 100;

maximum color value in a channel INT_PERCENTAGE

FloatPercentageMax3DS = 1;

Maximum integer percentage FLOAT_PERCENTAGE

MatMapNameStrMax3DS = 12;

Maximum floating point percentage MAT_MAPNAME

NamedObjectStrMax3DS = 10;

Maximum map name string size NAMED_OBJECT

NCameraFOVMin3DS = 0.00025;

Maximum named object string size N_CAMERA

NCameraFOVMax3DS = 160;

Minimum field of view for camera

NCameraFocMin3DS = 10.7813;

Maximum field of view for camera

NCameraFocMax3DS = 10000000;

Minimum lens size for camera

KFHdrStrMax3DS = 12;

Maximum lens size for camera KFHDR

NodeHdrStrMax3DS = 10;

Maximum keyframe header name string size NODE_HDR

InstanceNameStrMax3DS = 10;

Maximum node name string size INSTANCE_NAME

MorphTrackStrMax3DS = 10;

Maximum instance name string size MORPH_TRACK

MorphSmoothMin3DS = 0;

Maximum morph object name string size MORPH_SMOOTH

MorphSmoothMax3DS = 360;

Minimum morph smoothing angle

KFTensionMin3DS = -1;

Maximum morph smoothing angle Keyframe Spline Limits

KFTensionMax3DS = 1;

Minimum key spline tension

KFContinuityMin3DS = -1;

Maximum key spline tension

KFContinuityMax3DS = 1;

Minimum key spline continuity

KFBiasMin3DS = -1;

Maximum key spline continuity

KFBiasMax3DS = 1;

Minimum key spline bias

KFEaseToMin3DS = 0;

Maximum key spline bias

KFEaseToMax3DS = 1;

Minimum key spline ease to

KFEaseFromMin3DS = 0;

Maximum key spline ease to

KFEaseFromMax3DS = 1;

Minimum key spline ease from

TrackHeaderKeysMin3DS = 1;

Maximum key spline ease from Track header Limits

ColTrackTagMin3DS = 0;

Minimum number of keys in a track COL_TRACK_TAG_KEY

ColTrackTagMax3DS = 1;

Minimum color value

FOVTrackTagMin3DS = NCameraFOVMin3DS;

Maximum color value FOV_TRACK_TAG_KEY

FOVTrackTagMax3DS = NCameraFOVMax3DS;

Minimum camera FOV

HotTrackTagMin3DS = 0;

Maximum camera FOV HOT_TRACK_TAG_KEY

HotTrackTagMax3DS = 160;

Minimum hot spot angle

FallTrackTagMin3DS = 0;

Maximum hot spot angle FALL_TRACK_TAG_KEY

FallTrackTagMax3DS = 160;

Minimum fall off angle

KNoID = -1;

Maximum fall off angle

TEX_DECAL = 1;

MAT_TILING

TEX_MIRROR = 1 shl 1;

This item has no description.

TEX_UNUSED1 = 1 shl 2;

This item has no description.

TEX_INVERT = 1 shl 3;

This item has no description.

TEX_NOWRAP = 1 shl 4;

This item has no description.

TEX_SAT = 1 shl 5;

This item has no description.

TEX_ALPHA_SOURCE = 1 shl 6;

summed area table

TEX_TINT = 1 shl 7;

use ALPHA instead of RGB of map

TEX_DONT_USE_ALPHA = 1 shl 8;

tint for color

TEX_RGB_TINT = 1 shl 9;

don't use map alpha

NODE_RENDOB_HIDE = 1 shl 2;

do RGB color transform Values for keyframer flags1

NODE_OFF = 1 shl 3;

This item has no description.

ATKEY1 = 1 shl 4;

This item has no description.

ATKEY2 = 1 shl 5;

This item has no description.

ATKEY3 = 1 shl 6;

This item has no description.

ATKEY4 = 1 shl 7;

This item has no description.

ATKEY5 = 1 shl 8;

This item has no description.

ATKEYFLAGS = ATKEY1 or ATKEY2 or ATKEY3 or ATKEY4 or ATKEY5;

This item has no description.

MARK_NODE = 1 shl 9;

This item has no description.

DISABLE_NODE = 1 shl 10;

This item has no description.

HIDE_NODE = 1 shl 11;

This item has no description.

FAST_NODE = 1 shl 12;

This item has no description.

PRIMARY_NODE = 1 shl 14;

draw node quickdraw style

NODE_CALC_PATH = 1 shl 15;

corresponds to mesh

NODE_HAS_PATH = 1;

Values for keyframer flags2

NODE_AUTO_SMOOTH = 1 shl 1;

This item has no description.

NODE_FROZEN = 1 shl 2;

This item has no description.

NODE_ANI_HIDDEN = 1 shl 3;

This item has no description.

NODE_MOTION_BLUR = 1 shl 4;

This item has no description.

NODE_BLUR_BRANCH = 1 shl 5;

This item has no description.

NODE_MORPH_MTL = 1 shl 6;

This item has no description.

NODE_MORPH_OB = 1 shl 7;

This item has no description.

NULL_CHUNK = $0000;

—————– List of all chunk IDs ————————————-

ChunkType = $0995;

Trick Chunk Flags For ChunkSyntax function

ChunkUnique = $0996;

This item has no description.

NotChunk = $0997;

This item has no description.

Container = $0998;

This item has no description.

IsChunk = $0999;

This item has no description.

DUMMY = $FFFF;

Dummy Chunk that sometimes appears in 3DS files created by prerelease 3D Studio R2

POINT_ARRAY_ENTRY = $F110;

Trick Chunk Types For Open, Write, Close functions

POINT_FLAG_ARRAY_ENTRY = $F111;

This item has no description.

FACE_ARRAY_ENTRY = $F120;

This item has no description.

MSH_MAT_GROUP_ENTRY = $F130;

This item has no description.

TEX_VERTS_ENTRY = $F140;

This item has no description.

SMOOTH_GROUP_ENTRY = $F150;

This item has no description.

POS_TRACK_TAG_KEY = $F020;

This item has no description.

ROT_TRACK_TAG_KEY = $F021;

This item has no description.

SCL_TRACK_TAG_KEY = $F022;

This item has no description.

FOV_TRACK_TAG_KEY = $F023;

This item has no description.

ROLL_TRACK_TAG_KEY = $F024;

This item has no description.

COL_TRACK_TAG_KEY = $F025;

This item has no description.

MORPH_TRACK_TAG_KEY = $F026;

This item has no description.

HOT_TRACK_TAG_KEY = $F027;

This item has no description.

FALL_TRACK_TAG_KEY = $F028;

This item has no description.

M3DMAGIC = $4D4D;

3DS file Chunk IDs

SMAGIC = $2D2D;

This item has no description.

LMAGIC = $2D3D;

This item has no description.

MLIBMAGIC = $3DAA;

This item has no description.

MATMAGIC = $3DFF;

This item has no description.

M3D_VERSION = $0002;

This item has no description.

M3D_KFVERSION = $0005;

This item has no description.

MDATA = $3D3D;

Mesh Chunk Ids

MESH_VERSION = $3D3E;

This item has no description.

COLOR_F = $0010;

This item has no description.

COLOR_24 = $0011;

This item has no description.

LIN_COLOR_24 = $0012;

This item has no description.

LIN_COLOR_F = $0013;

This item has no description.

INT_PERCENTAGE = $0030;

This item has no description.

FLOAT_PERCENTAGE = $0031;

This item has no description.

MASTER_SCALE = $0100;

This item has no description.

BIT_MAP = $1100;

This item has no description.

USE_BIT_MAP = $1101;

This item has no description.

SOLID_BGND = $1200;

This item has no description.

USE_SOLID_BGND = $1201;

This item has no description.

V_GRADIENT = $1300;

This item has no description.

USE_V_GRADIENT = $1301;

This item has no description.

LO_SHADOW_BIAS = $1400;

This item has no description.

HI_SHADOW_BIAS = $1410;

This item has no description.

SHADOW_MAP_SIZE = $1420;

This item has no description.

SHADOW_SAMPLES = $1430;

This item has no description.

SHADOW_RANGE = $1440;

This item has no description.

SHADOW_FILTER = $1450;

This item has no description.

RAY_BIAS = $1460;

This item has no description.

O_CONSTS = $1500;

This item has no description.

AMBIENT_LIGHT = $2100;

This item has no description.

FOG = $2200;

This item has no description.

USE_FOG = $2201;

This item has no description.

FOG_BGND = $2210;

This item has no description.

DISTANCE_CUE = $2300;

This item has no description.

USE_DISTANCE_CUE = $2301;

This item has no description.

LAYER_FOG = $2302;

This item has no description.

USE_LAYER_FOG = $2303;

This item has no description.

DCUE_BGND = $2310;

This item has no description.

DEFAULT_VIEW = $3000;

This item has no description.

VIEW_TOP = $3010;

This item has no description.

VIEW_BOTTOM = $3020;

This item has no description.

VIEW_LEFT = $3030;

This item has no description.

VIEW_RIGHT = $3040;

This item has no description.

VIEW_FRONT = $3050;

This item has no description.

VIEW_BACK = $3060;

This item has no description.

VIEW_USER = $3070;

This item has no description.

VIEW_CAMERA = $3080;

This item has no description.

VIEW_WINDOW = $3090;

This item has no description.

NAMED_OBJECT = $4000;

This item has no description.

OBJ_HIDDEN = $4010;

This item has no description.

OBJ_VIS_LOFTER = $4011;

This item has no description.

OBJ_DOESNT_CAST = $4012;

This item has no description.

OBJ_MATTE = $4013;

This item has no description.

OBJ_FAST = $4014;

This item has no description.

OBJ_PROCEDURAL = $4015;

This item has no description.

OBJ_FROZEN = $4016;

This item has no description.

OBJ_DONT_RCVSHADOW = $4017;

This item has no description.

N_TRI_OBJECT = $4100;

This item has no description.

POINT_ARRAY = $4110;

This item has no description.

POINT_FLAG_ARRAY = $4111;

This item has no description.

FACE_ARRAY = $4120;

This item has no description.

MSH_MAT_GROUP = $4130;

This item has no description.

OLD_MAT_GROUP = $4131;

This item has no description.

TEX_VERTS = $4140;

This item has no description.

SMOOTH_GROUP = $4150;

This item has no description.

MESH_MATRIX = $4160;

This item has no description.

MESH_COLOR = $4165;

This item has no description.

MESH_TEXTURE_INFO = $4170;

This item has no description.

PROC_NAME = $4181;

This item has no description.

PROC_DATA = $4182;

This item has no description.

MSH_BOXMAP = $4190;

This item has no description.

N_D_L_OLD = $4400;

This item has no description.

N_CAM_OLD = $4500;

This item has no description.

N_DIRECT_LIGHT = $4600;

This item has no description.

DL_SPOTLIGHT = $4610;

This item has no description.

DL_OFF = $4620;

This item has no description.

DL_ATTENUATE = $4625;

This item has no description.

DL_RAYSHAD = $4627;

This item has no description.

DL_SHADOWED = $4630;

This item has no description.

DL_LOCAL_SHADOW = $4640;

This item has no description.

DL_LOCAL_SHADOW2 = $4641;

This item has no description.

DL_SEE_CONE = $4650;

This item has no description.

DL_SPOT_RECTANGULAR = $4651;

This item has no description.

DL_SPOT_OVERSHOOT = $4652;

This item has no description.

DL_SPOT_PROJECTOR = $4653;

This item has no description.

DL_EXCLUDE = $4654;

This item has no description.

DL_RANGE = $4655;

This item has no description.

DL_SPOT_ROLL = $4656;

Not used in R3

DL_SPOT_ASPECT = $4657;

This item has no description.

DL_RAY_BIAS = $4658;

This item has no description.

DL_INNER_RANGE = $4659;

This item has no description.

DL_OUTER_RANGE = $465A;

This item has no description.

DL_MULTIPLIER = $465B;

This item has no description.

N_AMBIENT_LIGHT = $4680;

This item has no description.

N_CAMERA = $4700;

This item has no description.

CAM_SEE_CONE = $4710;

This item has no description.

CAM_RANGES = $4720;

This item has no description.

HIERARCHY = $4F00;

This item has no description.

PARENT_OBJECT = $4F10;

This item has no description.

PIVOT_OBJECT = $4F20;

This item has no description.

PIVOT_LIMITS = $4F30;

This item has no description.

PIVOT_ORDER = $4F40;

This item has no description.

XLATE_RANGE = $4F50;

This item has no description.

POLY_2D = $5000;

This item has no description.

SHAPE_OK = $5010;

Flags in shaper AFile that tell whether polys make up an ok shape

SHAPE_NOT_OK = $5011;

This item has no description.

SHAPE_HOOK = $5020;

This item has no description.

PATH_3D = $6000;

This item has no description.

PATH_MATRIX = $6005;

This item has no description.

SHAPE_2D = $6010;

This item has no description.

M_SCALE = $6020;

This item has no description.

M_TWIST = $6030;

This item has no description.

M_TEETER = $6040;

This item has no description.

M_FIT = $6050;

This item has no description.

M_BEVEL = $6060;

This item has no description.

XZ_CURVE = $6070;

This item has no description.

YZ_CURVE = $6080;

This item has no description.

INTERPCT = $6090;

This item has no description.

DEFORM_LIMIT = $60A0;

This item has no description.

USE_CONTOUR = $6100;

Flags for Modeler options

USE_TWEEN = $6110;

This item has no description.

USE_SCALE = $6120;

This item has no description.

USE_TWIST = $6130;

This item has no description.

USE_TEETER = $6140;

This item has no description.

USE_FIT = $6150;

This item has no description.

USE_BEVEL = $6160;

This item has no description.

VIEWPORT_LAYOUT_OLD = $7000;

Viewport description chunks

VIEWPORT_DATA_OLD = $7010;

This item has no description.

VIEWPORT_LAYOUT = $7001;

This item has no description.

VIEWPORT_DATA = $7011;

This item has no description.

VIEWPORT_DATA_3 = $7012;

This item has no description.

VIEWPORT_SIZE = $7020;

This item has no description.

NETWORK_VIEW = $7030;

This item has no description.

XDATA_SECTION = $8000;

External Application Data

XDATA_ENTRY = $8001;

This item has no description.

XDATA_APPNAME = $8002;

This item has no description.

XDATA_STRING = $8003;

This item has no description.

XDATA_FLOAT = $8004;

This item has no description.

XDATA_DOUBLE = $8005;

This item has no description.

XDATA_SHORT = $8006;

This item has no description.

XDATA_LONG = $8007;

This item has no description.

XDATA_VOID = $8008;

This item has no description.

XDATA_GROUP = $8009;

This item has no description.

XDATA_RFU6 = $800A;

This item has no description.

XDATA_RFU5 = $800B;

This item has no description.

XDATA_RFU4 = $800C;

This item has no description.

XDATA_RFU3 = $800D;

This item has no description.

XDATA_RFU2 = $800E;

This item has no description.

XDATA_RFU1 = $800F;

This item has no description.

PARENT_NAME = $80F0;

This item has no description.

MAT_ENTRY = $AFFF;

Material Chunk IDs

MAT_NAME = $A000;

This item has no description.

MAT_AMBIENT = $A010;

This item has no description.

MAT_DIFFUSE = $A020;

This item has no description.

MAT_SPECULAR = $A030;

This item has no description.

MAT_SHININESS = $A040;

This item has no description.

MAT_SHIN2PCT = $A041;

This item has no description.

MAT_SHIN3PCT = $A042;

This item has no description.

MAT_TRANSPARENCY = $A050;

This item has no description.

MAT_XPFALL = $A052;

This item has no description.

MAT_REFBLUR = $A053;

This item has no description.

MAT_SELF_ILLUM = $A080;

This item has no description.

MAT_TWO_SIDE = $A081;

This item has no description.

MAT_DECAL = $A082;

This item has no description.

MAT_ADDITIVE = $A083;

This item has no description.

MAT_SELF_ILPCT = $A084;

This item has no description.

MAT_WIRE = $A085;

This item has no description.

MAT_SUPERSMP = $A086;

This item has no description.

MAT_WIRESIZE = $A087;

This item has no description.

MAT_FACEMAP = $A088;

This item has no description.

MAT_XPFALLIN = $A08A;

This item has no description.

MAT_PHONGSOFT = $A08C;

This item has no description.

MAT_WIREABS = $A08E;

This item has no description.

MAT_SHADING = $A100;

This item has no description.

MAT_TEXMAP = $A200;

This item has no description.

MAT_OPACMAP = $A210;

This item has no description.

MAT_REFLMAP = $A220;

This item has no description.

MAT_BUMPMAP = $A230;

This item has no description.

MAT_SPECMAP = $A204;

This item has no description.

MAT_USE_XPFALL = $A240;

This item has no description.

MAT_USE_REFBLUR = $A250;

This item has no description.

MAT_BUMP_PERCENT = $A252;

This item has no description.

MAT_MAPNAME = $A300;

This item has no description.

MAT_ACUBIC = $A310;

This item has no description.

MAT_SXP_TEXT_DATA = $A320;

This item has no description.

MAT_SXP_TEXT2_DATA = $A321;

This item has no description.

MAT_SXP_OPAC_DATA = $A322;

This item has no description.

MAT_SXP_BUMP_DATA = $A324;

This item has no description.

MAT_SXP_SPEC_DATA = $A325;

This item has no description.

MAT_SXP_SHIN_DATA = $A326;

This item has no description.

MAT_SXP_SELFI_DATA = $A328;

This item has no description.

MAT_SXP_TEXT_MASKDATA = $A32A;

This item has no description.

MAT_SXP_TEXT2_MASKDATA = $A32C;

This item has no description.

MAT_SXP_OPAC_MASKDATA = $A32E;

This item has no description.

MAT_SXP_BUMP_MASKDATA = $A330;

This item has no description.

MAT_SXP_SPEC_MASKDATA = $A332;

This item has no description.

MAT_SXP_SHIN_MASKDATA = $A334;

This item has no description.

MAT_SXP_SELFI_MASKDATA = $A336;

This item has no description.

MAT_SXP_REFL_MASKDATA = $A338;

This item has no description.

MAT_TEX2MAP = $A33A;

This item has no description.

MAT_SHINMAP = $A33C;

This item has no description.

MAT_SELFIMAP = $A33D;

This item has no description.

MAT_TEXMASK = $A33E;

This item has no description.

MAT_TEX2MASK = $A340;

This item has no description.

MAT_OPACMASK = $A342;

This item has no description.

MAT_BUMPMASK = $A344;

This item has no description.

MAT_SHINMASK = $A346;

This item has no description.

MAT_SPECMASK = $A348;

This item has no description.

MAT_SELFIMASK = $A34A;

This item has no description.

MAT_REFLMASK = $A34C;

This item has no description.

MAT_MAP_TILINGOLD = $A350;

This item has no description.

MAT_MAP_TILING = $A351;

This item has no description.

MAT_MAP_TEXBLUR_OLD = $A352;

This item has no description.

MAT_MAP_TEXBLUR = $A353;

This item has no description.

MAT_MAP_USCALE = $A354;

This item has no description.

MAT_MAP_VSCALE = $A356;

This item has no description.

MAT_MAP_UOFFSET = $A358;

This item has no description.

MAT_MAP_VOFFSET = $A35A;

This item has no description.

MAT_MAP_ANG = $A35C;

This item has no description.

MAT_MAP_COL1 = $A360;

This item has no description.

MAT_MAP_COL2 = $A362;

This item has no description.

MAT_MAP_RCOL = $A364;

This item has no description.

MAT_MAP_GCOL = $A366;

This item has no description.

MAT_MAP_BCOL = $A368;

This item has no description.

KFDATA = $B000;

Keyframe Chunk IDs

KFHDR = $B00A;

This item has no description.

AMBIENT_NODE_TAG = $B001;

This item has no description.

OBJECT_NODE_TAG = $B002;

This item has no description.

CAMERA_NODE_TAG = $B003;

This item has no description.

TARGET_NODE_TAG = $B004;

This item has no description.

LIGHT_NODE_TAG = $B005;

This item has no description.

L_TARGET_NODE_TAG = $B006;

This item has no description.

SPOTLIGHT_NODE_TAG = $B007;

This item has no description.

KFSEG = $B008;

This item has no description.

KFCURTIME = $B009;

This item has no description.

NODE_HDR = $B010;

This item has no description.

INSTANCE_NAME = $B011;

This item has no description.

PRESCALE = $B012;

This item has no description.

PIVOT = $B013;

This item has no description.

BOUNDBOX = $B014;

This item has no description.

MORPH_SMOOTH = $B015;

This item has no description.

POS_TRACK_TAG = $B020;

This item has no description.

ROT_TRACK_TAG = $B021;

This item has no description.

SCL_TRACK_TAG = $B022;

This item has no description.

FOV_TRACK_TAG = $B023;

This item has no description.

ROLL_TRACK_TAG = $B024;

This item has no description.

COL_TRACK_TAG = $B025;

This item has no description.

MORPH_TRACK_TAG = $B026;

This item has no description.

HOT_TRACK_TAG = $B027;

This item has no description.

FALL_TRACK_TAG = $B028;

This item has no description.

HIDE_TRACK_TAG = $B029;

This item has no description.

NODE_ID = $B030;

This item has no description.

CMAGIC = $C23D;

This item has no description.

C_MDRAWER = $C010;

This item has no description.

C_TDRAWER = $C020;

This item has no description.

C_SHPDRAWER = $C030;

This item has no description.

C_MODDRAWER = $C040;

This item has no description.

C_RIPDRAWER = $C050;

This item has no description.

C_TXDRAWER = $C060;

This item has no description.

C_PDRAWER = $C062;

This item has no description.

C_MTLDRAWER = $C064;

This item has no description.

C_FLIDRAWER = $C066;

This item has no description.

C_CUBDRAWER = $C067;

This item has no description.

C_MFILE = $C070;

This item has no description.

C_SHPFILE = $C080;

This item has no description.

C_MODFILE = $C090;

This item has no description.

C_RIPFILE = $C0A0;

This item has no description.

C_TXFILE = $C0B0;

This item has no description.

C_PFILE = $C0B2;

This item has no description.

C_MTLFILE = $C0B4;

This item has no description.

C_FLIFILE = $C0B6;

This item has no description.

C_PALFILE = $C0B8;

This item has no description.

C_TX_STRING = $C0C0;

This item has no description.

C_CONSTS = $C0D0;

This item has no description.

C_SNAPS = $C0E0;

This item has no description.

C_GRIDS = $C0F0;

This item has no description.

C_ASNAPS = $C100;

This item has no description.

C_GRID_RANGE = $C110;

This item has no description.

C_RENDTYPE = $C120;

This item has no description.

C_PROGMODE = $C130;

This item has no description.

C_PREVMODE = $C140;

This item has no description.

C_MODWMODE = $C150;

This item has no description.

C_MODMODEL = $C160;

This item has no description.

C_ALL_LINES = $C170;

This item has no description.

C_BACK_TYPE = $C180;

This item has no description.

C_MD_CS = $C190;

This item has no description.

C_MD_CE = $C1A0;

This item has no description.

C_MD_SML = $C1B0;

This item has no description.

C_MD_SMW = $C1C0;

This item has no description.

C_LOFT_WITH_TEXTURE = $C1C3;

This item has no description.

C_LOFT_L_REPEAT = $C1C4;

This item has no description.

C_LOFT_W_REPEAT = $C1C5;

This item has no description.

C_LOFT_UV_NORMALIZE = $C1C6;

This item has no description.

C_WELD_LOFT = $C1C7;

This item has no description.

C_MD_PDET = $C1D0;

This item has no description.

C_MD_SDET = $C1E0;

This item has no description.

C_RGB_RMODE = $C1F0;

This item has no description.

C_RGB_HIDE = $C200;

This item has no description.

C_RGB_MAPSW = $C202;

This item has no description.

C_RGB_TWOSIDE = $C204;

This item has no description.

C_RGB_SHADOW = $C208;

This item has no description.

C_RGB_AA = $C210;

This item has no description.

C_RGB_OVW = $C220;

This item has no description.

C_RGB_OVH = $C230;

This item has no description.

C_RGB_PICTYPE = $C240;

This item has no description.

C_RGB_OUTPUT = $C250;

This item has no description.

C_RGB_TODISK = $C253;

This item has no description.

C_RGB_COMPRESS = $C254;

This item has no description.

C_JPEG_COMPRESSION = $C255;

This item has no description.

C_RGB_DISPDEV = $C256;

This item has no description.

C_RGB_HARDDEV = $C259;

This item has no description.

C_RGB_PATH = $C25A;

This item has no description.

C_BITMAP_DRAWER = $C25B;

This item has no description.

C_RGB_FILE = $C260;

This item has no description.

C_RGB_OVASPECT = $C270;

This item has no description.

C_RGB_ANIMTYPE = $C271;

This item has no description.

C_RENDER_ALL = $C272;

This item has no description.

C_REND_FROM = $C273;

This item has no description.

C_REND_TO = $C274;

This item has no description.

C_REND_NTH = $C275;

This item has no description.

C_PAL_TYPE = $C276;

This item has no description.

C_RND_TURBO = $C277;

This item has no description.

C_RND_MIP = $C278;

This item has no description.

C_BGND_METHOD = $C279;

This item has no description.

C_AUTO_REFLECT = $C27A;

This item has no description.

C_VP_FROM = $C27B;

This item has no description.

C_VP_TO = $C27C;

This item has no description.

C_VP_NTH = $C27D;

This item has no description.

C_REND_TSTEP = $C27E;

This item has no description.

C_VP_TSTEP = $C27F;

This item has no description.

C_SRDIAM = $C280;

This item has no description.

C_SRDEG = $C290;

This item has no description.

C_SRSEG = $C2A0;

This item has no description.

C_SRDIR = $C2B0;

This item has no description.

C_HETOP = $C2C0;

This item has no description.

C_HEBOT = $C2D0;

This item has no description.

C_HEHT = $C2E0;

This item has no description.

C_HETURNS = $C2F0;

This item has no description.

C_HEDEG = $C300;

This item has no description.

C_HESEG = $C310;

This item has no description.

C_HEDIR = $C320;

This item has no description.

C_QUIKSTUFF = $C330;

This item has no description.

C_SEE_LIGHTS = $C340;

This item has no description.

C_SEE_CAMERAS = $C350;

This item has no description.

C_SEE_3D = $C360;

This item has no description.

C_MESHSEL = $C370;

This item has no description.

C_MESHUNSEL = $C380;

This item has no description.

C_POLYSEL = $C390;

This item has no description.

C_POLYUNSEL = $C3A0;

This item has no description.

C_SHPLOCAL = $C3A2;

This item has no description.

C_MSHLOCAL = $C3A4;

This item has no description.

C_NUM_FORMAT = $C3B0;

This item has no description.

C_ARCH_DENOM = $C3C0;

This item has no description.

C_IN_DEVICE = $C3D0;

This item has no description.

C_MSCALE = $C3E0;

This item has no description.

C_COMM_PORT = $C3F0;

This item has no description.

C_TAB_BASES = $C400;

This item has no description.

C_TAB_DIVS = $C410;

This item has no description.

C_MASTER_SCALES = $C420;

This item has no description.

C_SHOW_1STVERT = $C430;

This item has no description.

C_SHAPER_OK = $C440;

This item has no description.

C_LOFTER_OK = $C450;

This item has no description.

C_EDITOR_OK = $C460;

This item has no description.

C_KEYFRAMER_OK = $C470;

This item has no description.

C_PICKSIZE = $C480;

This item has no description.

C_MAPTYPE = $C490;

This item has no description.

C_MAP_DISPLAY = $C4A0;

This item has no description.

C_TILE_XY = $C4B0;

This item has no description.

C_MAP_XYZ = $C4C0;

This item has no description.

C_MAP_SCALE = $C4D0;

This item has no description.

C_MAP_MATRIX_OLD = $C4E0;

This item has no description.

C_MAP_MATRIX = $C4E1;

This item has no description.

C_MAP_WID_HT = $C4F0;

This item has no description.

C_OBNAME = $C500;

This item has no description.

C_CAMNAME = $C510;

This item has no description.

C_LTNAME = $C520;

This item has no description.

C_CUR_MNAME = $C525;

This item has no description.

C_CURMTL_FROM_MESH = $C526;

This item has no description.

C_GET_SHAPE_MAKE_FACES = $C527;

This item has no description.

C_DETAIL = $C530;

This item has no description.

C_VERTMARK = $C540;

This item has no description.

C_MSHAX = $C550;

This item has no description.

C_MSHCP = $C560;

This item has no description.

C_USERAX = $C570;

This item has no description.

C_SHOOK = $C580;

This item has no description.

C_RAX = $C590;

This item has no description.

C_STAPE = $C5A0;

This item has no description.

C_LTAPE = $C5B0;

This item has no description.

C_ETAPE = $C5C0;

This item has no description.

C_KTAPE = $C5C8;

This item has no description.

C_SPHSEGS = $C5D0;

This item has no description.

C_GEOSMOOTH = $C5E0;

This item has no description.

C_HEMISEGS = $C5F0;

This item has no description.

C_PRISMSEGS = $C600;

This item has no description.

C_PRISMSIDES = $C610;

This item has no description.

C_TUBESEGS = $C620;

This item has no description.

C_TUBESIDES = $C630;

This item has no description.

C_TORSEGS = $C640;

This item has no description.

C_TORSIDES = $C650;

This item has no description.

C_CONESIDES = $C660;

This item has no description.

C_CONESEGS = $C661;

This item has no description.

C_NGPARMS = $C670;

This item has no description.

C_PTHLEVEL = $C680;

This item has no description.

C_MSCSYM = $C690;

This item has no description.

C_MFTSYM = $C6A0;

This item has no description.

C_MTTSYM = $C6B0;

This item has no description.

C_SMOOTHING = $C6C0;

This item has no description.

C_MODICOUNT = $C6D0;

This item has no description.

C_FONTSEL = $C6E0;

This item has no description.

C_TESS_TYPE = $C6f0;

This item has no description.

C_TESS_TENSION = $C6f1;

This item has no description.

C_SEG_START = $C700;

This item has no description.

C_SEG_END = $C705;

This item has no description.

C_CURTIME = $C710;

This item has no description.

C_ANIMLENGTH = $C715;

This item has no description.

C_PV_FROM = $C720;

This item has no description.

C_PV_TO = $C725;

This item has no description.

C_PV_DOFNUM = $C730;

This item has no description.

C_PV_RNG = $C735;

This item has no description.

C_PV_NTH = $C740;

This item has no description.

C_PV_TYPE = $C745;

This item has no description.

C_PV_METHOD = $C750;

This item has no description.

C_PV_FPS = $C755;

This item has no description.

C_VTR_FRAMES = $C765;

This item has no description.

C_VTR_HDTL = $C770;

This item has no description.

C_VTR_HD = $C771;

This item has no description.

C_VTR_TL = $C772;

This item has no description.

C_VTR_IN = $C775;

This item has no description.

C_VTR_PK = $C780;

This item has no description.

C_VTR_SH = $C785;

This item has no description.

C_WORK_MTLS = $C790;

Material chunks

C_WORK_MTLS_2 = $C792;

Old-style – now ignored

C_WORK_MTLS_3 = $C793;

Old-style – now ignored

C_WORK_MTLS_4 = $C794;

Old-style – now ignored

C_WORK_MTLS_5 = $CB00;

Old-style – now ignored

C_WORK_MTLS_6 = $CB01;

Old-style – now ignored

C_WORK_MTLS_7 = $CB02;

Old-style – now ignored

C_WORK_MTLS_8 = $CB03;

Old-style – now ignored

C_WORKMTL = $CB04;

Old-style – now ignored

C_SXP_TEXT_DATA = $CB10;

This item has no description.

C_SXP_TEXT2_DATA = $CB20;

This item has no description.

C_SXP_OPAC_DATA = $CB11;

This item has no description.

C_SXP_BUMP_DATA = $CB12;

This item has no description.

C_SXP_SPEC_DATA = $CB24;

This item has no description.

C_SXP_SHIN_DATA = $CB13;

This item has no description.

C_SXP_SELFI_DATA = $CB28;

This item has no description.

C_SXP_TEXT_MASKDATA = $CB30;

This item has no description.

C_SXP_TEXT2_MASKDATA = $CB32;

This item has no description.

C_SXP_OPAC_MASKDATA = $CB34;

This item has no description.

C_SXP_BUMP_MASKDATA = $CB36;

This item has no description.

C_SXP_SPEC_MASKDATA = $CB38;

This item has no description.

C_SXP_SHIN_MASKDATA = $CB3A;

This item has no description.

C_SXP_SELFI_MASKDATA = $C3CB;

This item has no description.

C_SXP_REFL_MASKDATA = $CB3E;

This item has no description.

C_BGTYPE = $C7A1;

This item has no description.

C_MEDTILE = $C7B0;

This item has no description.

C_LO_CONTRAST = $C7D0;

Contrast

C_HI_CONTRAST = $C7D1;

This item has no description.

C_FROZ_DISPLAY = $C7E0;

3d frozen display

C_BOOLWELD = $C7f0;

Booleans

C_BOOLTYPE = $C7f1;

This item has no description.

C_ANG_THRESH = $C900;

This item has no description.

C_SS_THRESH = $C901;

This item has no description.

C_TEXTURE_BLUR_DEFAULT = $C903;

This item has no description.

C_MAPDRAWER = $CA00;

This item has no description.

C_MAPDRAWER1 = $CA01;

This item has no description.

C_MAPDRAWER2 = $CA02;

This item has no description.

C_MAPDRAWER3 = $CA03;

This item has no description.

C_MAPDRAWER4 = $CA04;

This item has no description.

C_MAPDRAWER5 = $CA05;

This item has no description.

C_MAPDRAWER6 = $CA06;

This item has no description.

C_MAPDRAWER7 = $CA07;

This item has no description.

C_MAPDRAWER8 = $CA08;

This item has no description.

C_MAPDRAWER9 = $CA09;

This item has no description.

C_MAPDRAWER_ENTRY = $CA10;

This item has no description.

C_BACKUP_FILE = $CA20;

system options

C_DITHER_256 = $CA21;

This item has no description.

C_SAVE_LAST = $CA22;

This item has no description.

C_USE_ALPHA = $CA23;

This item has no description.

C_TGA_DEPTH = $CA24;

This item has no description.

C_REND_FIELDS = $CA25;

This item has no description.

C_REFLIP = $CA26;

This item has no description.

C_SEL_ITEMTOG = $CA27;

This item has no description.

C_SEL_RESET = $CA28;

This item has no description.

C_STICKY_KEYINF = $CA29;

This item has no description.

C_WELD_THRESHOLD = $CA2A;

This item has no description.

C_ZCLIP_POINT = $CA2B;

This item has no description.

C_ALPHA_SPLIT = $CA2C;

This item has no description.

C_KF_SHOW_BACKFACE = $CA30;

This item has no description.

C_OPTIMIZE_LOFT = $CA40;

This item has no description.

C_TENS_DEFAULT = $CA42;

This item has no description.

C_CONT_DEFAULT = $CA44;

This item has no description.

C_BIAS_DEFAULT = $CA46;

This item has no description.

C_DXFNAME_SRC = $CA50;

This item has no description.

C_AUTO_WELD = $CA60;

This item has no description.

C_AUTO_UNIFY = $CA70;

This item has no description.

C_AUTO_SMOOTH = $CA80;

This item has no description.

C_DXF_SMOOTH_ANG = $CA90;

This item has no description.

C_SMOOTH_ANG = $CAA0;

This item has no description.

C_NET_USE_VPOST = $CC00;

Special network-use chunks

C_NET_USE_GAMMA = $CC10;

This item has no description.

C_NET_FIELD_ORDER = $CC20;

This item has no description.

C_BLUR_FRAMES = $CD00;

This item has no description.

C_BLUR_SAMPLES = $CD10;

This item has no description.

C_BLUR_DUR = $CD20;

This item has no description.

C_HOT_METHOD = $CD30;

This item has no description.

C_HOT_CHECK = $CD40;

This item has no description.

C_PIXEL_SIZE = $CD50;

This item has no description.

C_DISP_GAMMA = $CD60;

This item has no description.

C_FBUF_GAMMA = $CD70;

This item has no description.

C_FILE_OUT_GAMMA = $CD80;

This item has no description.

C_FILE_IN_GAMMA = $CD82;

This item has no description.

C_GAMMA_CORRECT = $CD84;

This item has no description.

C_APPLY_DISP_GAMMA = $CD90;

This item has no description.

C_APPLY_FBUF_GAMMA = $CDA0;

OBSOLETE

C_APPLY_FILE_GAMMA = $CDB0;

OBSOLETE

C_FORCE_WIRE = $CDC0;

OBSOLETE

C_RAY_SHADOWS = $CDD0;

This item has no description.

C_MASTER_AMBIENT = $CDE0;

This item has no description.

C_SUPER_SAMPLE = $CDF0;

This item has no description.

C_OBJECT_MBLUR = $CE00;

This item has no description.

C_MBLUR_DITHER = $CE10;

This item has no description.

C_DITHER_24 = $CE20;

This item has no description.

C_SUPER_BLACK = $CE30;

This item has no description.

C_SAFE_FRAME = $CE40;

This item has no description.

C_VIEW_PRES_RATIO = $CE50;

This item has no description.

C_BGND_PRES_RATIO = $CE60;

This item has no description.

C_NTH_SERIAL_NUM = $CE70;

This item has no description.

VPDATA = $D000;

Video Post

P_QUEUE_ENTRY = $D100;

This item has no description.

P_QUEUE_IMAGE = $D110;

This item has no description.

P_QUEUE_USEIGAMMA = $D114;

This item has no description.

P_QUEUE_PROC = $D120;

This item has no description.

P_QUEUE_SOLID = $D130;

This item has no description.

P_QUEUE_GRADIENT = $D140;

This item has no description.

P_QUEUE_KF = $D150;

This item has no description.

P_QUEUE_MOTBLUR = $D152;

This item has no description.

P_QUEUE_MB_REPEAT = $D153;

This item has no description.

P_QUEUE_NONE = $D160;

This item has no description.

P_QUEUE_RESIZE = $D180;

This item has no description.

P_QUEUE_OFFSET = $D185;

This item has no description.

P_QUEUE_ALIGN = $D190;

This item has no description.

P_CUSTOM_SIZE = $D1a0;

This item has no description.

P_ALPH_NONE = $D210;

This item has no description.

P_ALPH_PSEUDO = $D220;

This item has no description.

P_ALPH_OP_PSEUDO = $D221;

Old Chunk

P_ALPH_BLUR = $D222;

Old Chunk

P_ALPH_PCOL = $D225;

Replaces pseudo

P_ALPH_C0 = $D230;

This item has no description.

P_ALPH_OP_KEY = $D231;

This item has no description.

P_ALPH_KCOL = $D235;

This item has no description.

P_ALPH_OP_NOCONV = $D238;

This item has no description.

P_ALPH_IMAGE = $D240;

This item has no description.

P_ALPH_ALPHA = $D250;

This item has no description.

P_ALPH_QUES = $D260;

This item has no description.

P_ALPH_QUEIMG = $D265;

This item has no description.

P_ALPH_CUTOFF = $D270;

This item has no description.

P_ALPHANEG = $D280;

This item has no description.

P_TRAN_NONE = $D300;

This item has no description.

P_TRAN_IMAGE = $D310;

This item has no description.

P_TRAN_FRAMES = $D312;

This item has no description.

P_TRAN_FADEIN = $D320;

This item has no description.

P_TRAN_FADEOUT = $D330;

This item has no description.

P_TRANNEG = $D340;

This item has no description.

P_RANGES = $D400;

This item has no description.

P_PROC_DATA = $D500;

This item has no description.

NodeTagCount = 6;

This item has no description.

NodeTags: array[1..NodeTagCount] of Word = (TARGET_NODE_TAG, OBJECT_NODE_TAG, CAMERA_NODE_TAG, LIGHT_NODE_TAG, L_TARGET_NODE_TAG, SPOTLIGHT_NODE_TAG );

number of entries in node tag list


GLSysHelp v.2.5: Formats.m3DSTypes

Unit Formats.m3DSTypes

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TPoint3DS |
Record TFColor3DS |
Packed Record TFace3DS |
Record TTexVert3DS |
Record TTrackHeader3DS |
Record TKeyHeader3DS |
Record TKFRotKey3DS |
Record TChunkListEntry3DS |
Record TChunkList3DS |
Record TNodeList |
Record TDatabase3DS |
Record TViewSize3DS |
Record TOrthoView3DS |
Record TUserView3DS |
Record TViewport3DS |
Record TShadowSets3DS |
Record TMeshSet3DS |
Record TFogSettings3DS |
Record TLayerFogSettings3DS |
Record TDCueSettings3DS |
Record TAtmosphere3DS |
Record TVGradientBgnd3DS |
Record TBackground3DS |
Record TACubic3DS |
Record TBitmap3DS |
Record TMapSet3DS |
Record TRMapSet3DS |
Record TMaterial3DS |
Record TMapInfo3DS |
Record TObjMat3DS |
Record TMesh3DS |
Record TSpotShadow3DS |
Record TSpotCone3DS |
Record TSpotProjector3DS |
Record TSpotLight3DS |
Record TLiteAttenuate3DS |
Record TLight3DS |
Record TCamRanges3DS |
Record TCamera3DS |
Record TKFKeyInfo3DS |
Record TKFSegment3DS |
Record TKFSets3DS |
Record TKFCamera3DS |
Record TKFAmbient3DS |
Record TKFMesh3DS |
Record TKFOmni3DS |
Record TKFSpot3DS |
Record TXDataRaw3DS |
Record TColorF |
Record TColor24 |
Record TFog |
Record TLayerFog |
Record TDistanceCue |
Record TViewStandard |
Record TViewUser |
Record TMatAcubic |
Record TIpasData |
Record TPointArray |
Record TPointFlagArray |
Record TFaceArray |
Record TMshMatGroup |
Record TSmoothGroup |
Record TTexVerts |
Record TMeshTextureInfo |
Record TDlSpotlight |
Record TDlLocalShadow2 |
Record TNCamera |
Record TCamRanges |
Record TViewportLayout |
Record TViewportSize |
Record TViewportData |
Record TKFHdr |
Record TKFSeg |
Record TNodeHdr |
Record TBoundBox |
Record TPosTrackTag |
Record TColTrackTag |
Record TRotTrackTag |
Record TScaleTrackTag |
Record TMorphTrackTag |
Record THideTrackTag |
Record TFovTrackTag |
Record TRollTrackTag |
Record THotTrackTag |
Record TFallTrackTag |
Record TXDataEntry |
Record TChunkData |
Record TChunk3DS |

Types

PACubic3DS = ˆTACubic3DS;
PAtmosphere3DS = ˆTAtmosphere3DS;
PBackground3DS = ˆTBackground3DS;
PBitmap3DS = ˆTBitmap3DS;
PBitmapBgnd3DS = ˆTBitmapBgnd3DS;
PBitMapName = PChar3DS;
PBoundBox = ˆTBoundBox;
PCamera3DS = ˆTCamera3DS;
PCamRanges = ˆTCamRanges;
PCamRanges3DS = ˆTCamRanges3DS;
PCardinalArray = ˆTCardinalArray;
PChar3DS = PAnsiChar;
PChunk3DS = ˆTChunk3DS;
PChunkList = ˆTChunkList;
PChunkList3DS = ˆTChunkList3DS;
PChunkListEntry3DS = ˆTChunkListEntry3DS;
PColor24 = ˆTColor24;
PColorF = ˆTColorF;
PColTrackTag = ˆTColTrackTag;
PDatabase3DS = ˆTDatabase3DS;
PDCueSettings3DS = ˆTDCueSettings3DS;
PDistanceCue = ˆTDistanceCue;
PDlExclude = PChar3DS;
PDlInnerRange = ˆTDlInnerRange;
PDlLocalShadow2 = ˆTDlLocalShadow2;
PDlMultiplier = ˆTDlMultiplier;
PDlOuterRange = ˆTDlOuterRange;
PDlRayBias = ˆTDlRayBias;
PDlSpotAspect = ˆTDlSpotAspect;
PDlSpotlight = ˆTDlSpotlight;
PDlSpotProjector = PChar3DS;
PDlSpotRoll = ˆTDlSpotRoll;
PFace3DS = ˆTFace3DS;
PFaceArray = ˆTFaceArray;
PFaceList = ˆTFaceList;
PFallTrackTag = ˆTFallTrackTag;
PFColor3DS = ˆTFColor3DS;
PFColorList = ˆTFColorList;
PFloatPercentage = ˆTFloatPercentage;
PFog = ˆTFog;
PFogSettings3DS = ˆTFogSettings3DS;
PFovTrackTag = ˆTFovTrackTag;
PHideTrackTag = ˆTHideTrackTag;
PHiShadowBias = ˆTHiShadowBias;
PHotTrackTag = ˆTHotTrackTag;
PInstanceName = PChar3DS;
PIntegerArray = ˆTIntegerArray;
PIntPercentage = ˆTIntPercentage;
PIpasData = ˆTIpasData;
PKeyHeader3DS = ˆTKeyHeader3DS;
PKeyHeaderList = ˆTKeyHeaderList;
PKFAmbient3DS = ˆTKFAmbient3DS;
PKFCamera3DS = ˆTKFCamera3DS;
PKFCurtime = ˆTKFCurtime;
PKFHdr = ˆTKFHdr;
PKFId = ˆTKFId;
PKFKeyInfo3DS = ˆTKFKeyInfo3DS;
PKFMesh3DS = ˆTKFMesh3DS;
PKFMorphKey3DS = ˆTKFMorphKey3DS;
PKFMorphKeyList = ˆTKFMorphKeyList;
PKFOmni3DS = ˆTKFOmni3DS;
PKFRotKey3DS = ˆTKFRotKey3DS;
PKFRotKeyList = ˆTKFRotKeyList;
PKFSeg = ˆTKFSeg;
PKFSegment3DS = ˆTKFSegment3DS;
PKFSets3DS = ˆTKFSets3DS;
PKFSpot3DS = ˆTKFSpot3DS;
PLayerFog = ˆTLayerFog;
PLayerFogSettings3DS = ˆTLayerFogSettings3DS;
PLight3DS = ˆTLight3DS;
PLinColor24 = ˆTLinColor24;
PLinColorF = ˆTLinColorF;
PLiteAttenuate3DS = ˆTLiteAttenuate3DS;
PLoShadowBias = ˆTLoShadowBias;
PM3dVersion = ˆTM3dVersion;
PMapInfo3DS = ˆTMapInfo3DS;
PMapSet3DS = ˆTMapSet3DS;
PMasterScale = ˆTMasterScale;
PMatAcubic = ˆTMatAcubic;
PMatBumpPercent = ˆTMatBumpPercent;
PMaterial3DS = ˆTMaterial3DS;
PMatMapAng = ˆTMatMapAng;
PMatMapBCol = ˆTMatMapBCol;
PMatMapCol1 = ˆTMatMapCol1;
PMatMapCol2 = ˆTMatMapCol2;
PMatMapGCol = ˆTMatMapGCol;
PMatMapname = PChar3DS;
PMatMapRCol = ˆTMatMapRCol;
PMatMapTexblur = ˆTMatMapTexblur;
PMatMapTiling = ˆTMatMapTiling;
PMatMapUOffset = ˆTMatMapUOffset;
PMatMapUScale = ˆTMatMapUScale;
PMatMapVOffset = ˆTMatMapVOffset;
PMatMapVScale = ˆTMatMapVScale;
PMatName = PChar3DS;
PMatShading = ˆTMatShading;
PMatWireSize = ˆTMatWireSize;
PMesh3DS = ˆTMesh3DS;
PMeshColor = ˆTMeshColor;
PMeshMatrix = ˆTMeshMatrix;
PMeshSet3DS = ˆTMeshSet3DS;
PMeshTextureInfo = ˆTMeshTextureInfo;
PMeshVersion = ˆTMeshVersion;
PMorphSmooth = ˆTMorphSmooth;
PMorphTrackTag = ˆTMorphTrackTag;
PMshBoxmap = ˆTMshBoxmap;
PMshMatGroup = ˆTMshMatGroup;
PNamedObject = PChar3DS;
PNCamera = ˆTNCamera;
PNDirectLight = ˆTNDirectLight;
PNodeHdr = ˆTNodeHdr;
PNodeList = ˆTNodeList;
PObjMat3DS = ˆTObjMat3DS;
PObjMatList = ˆTObjMatList;
POConsts = ˆTOConsts;
POrthoView3DS = ˆTOrthoView3DS;
PPivot = ˆTPivot;
PPoint3DS = ˆTPoint3DS;
PPointArray = ˆTPointArray;
PPointFlagArray = ˆTPointFlagArray;
PPointList = ˆTPointList;
PPosTrackTag = ˆTPosTrackTag;
PProcName = PChar3DS;
PRayBias = ˆTRayBias;
PRollTrackTag = ˆTRollTrackTag;
PRotTrackTag = ˆTRotTrackTag;
PScaleTrackTag = ˆTScaleTrackTag;
PShadowFilter = ˆTShadowFilter;
PShadowMapSize = ˆTShadowMapSize;
PShadowRange = ˆTShadowRange;
PShadowSamples = ˆTShadowSamples;
PShadowSets3DS = ˆTShadowSets3DS;
PSingleList = ˆTSingleList;
PSmoothGroup = ˆTSmoothGroup;
PSpotCone3DS = ˆTSpotCone3DS;
PSpotLight3DS = ˆTSpotLight3DS;
PSpotProjector3DS = ˆTSpotProjector3DS;
PSpotShadow3DS = ˆTSpotShadow3DS;
PTexVert3DS = ˆTTexVert3DS;
PTexVertList = ˆTTexVertList;
PTexVerts = ˆTTexVerts;
PTrackHeader3DS = ˆTTrackHeader3DS;
PUserView3DS = ˆTUserView3DS;
PVGradient = ˆTVGradient;
PVGradientBgnd3DS = ˆTVGradientBgnd3DS;
PViewCamera = PChar3DS;
PViewport3DS = ˆTViewport3DS;
PViewportData = ˆTViewportData;
PViewportData3 = ˆTViewportData3;
PViewportLayout = ˆTViewportLayout;
PViewportSize = ˆTViewportSize;
PViewSize3DS = ˆTViewSize3DS;
PViewStandard = ˆTViewStandard;
PViewUser = ˆTViewUser;
PWordList = ˆTWordList;
PXDataAppName = PChar3DS;
PXDataDouble = ˆTXDataDouble;
PXDataEntry = ˆTXDataEntry;
PXDataFloat = ˆTXDataFloat;
PXDataLong = ˆTXDataLong;
PXDataRaw3DS = ˆTXDataRaw3DS;
PXDataShort = ˆTXDataShort;
PXDataString = PChar3DS;
PXDataVoid = ˆTXDataVoid;
String3DS = UTF8String;
String64 = string[64];
TAtmosphereType3DS = (...);
TBackgroundType3DS = (...);
TBitmapBgnd3DS = AnsiString;
TCardinalArray = array[0..MaxInt div (2*SizeOf(Cardinal))] of Cardinal;
TChunkList = array[0..MaxInt div (2*SizeOf(TChunkListEntry3DS))] of TChunkListEntry3DS;
TConeStyle3DS = (...);
TDBType3DS = (...);
TDlInnerRange = TDlOuterRange;
TDlMultiplier = Single;
TDlOuterRange = Single;
TDlRayBias = Single;
TDlSpotAspect = Single;
TDlSpotRoll = Single;
TDumpLevel = (...);
TFaceList = array[0..MaxInt div (2*SizeOf(TFace3DS))] of TFace3DS;
TFColorList = array[0..MaxInt div (2*SizeOf(TFColor3DS))] of TFColor3DS;
TFilterType3DS = (...);
TFloatPercentage = Single;
THiShadowBias = TLoShadowBias;
TIntegerArray = array[0..MaxInt div (2*SizeOf(Integer))] of Integer;
TIntPercentage = SmallInt;
TKeyHeaderList = array[0..MaxInt div (2*SizeOf(TKeyHeader3DS))] of TKeyHeader3DS;
TKFCurtime = Integer;
TKFId = SmallInt;
TKFMorphKey3DS = String;
TKFMorphKeyList = array[0..MaxInt div (2*SizeOf(TKFMorphKey3DS))] of TKFMorphKey3DS;
TKFRotKeyList = array[0..MaxInt div (2*SizeOf(TKFRotKey3DS))] of TKFRotKey3DS;
TLayerFogFalloff3DS = (...);
TLinColor24 = TColor24;
TLinColorF = TColorF;
TLoShadowBias = Single;
TM3dVersion = Cardinal;
TMasterScale = Single;
TMatBumpPercent = TIntPercentage;
TMatMapAng = Single;
TMatMapBCol = TMatMapGCol;
TMatMapCol1 = TMatMapBCol;
TMatMapCol2 = TMatMapCol1;
TMatMapGCol = TMatMapRCol;
TMatMapRCol = TLinColor24;
TMatMapTexblur = Single;
TMatMapTiling = Word;
TMatMapUOffset = Single;
TMatMapUScale = Single;
TMatMapVOffset = TMatMapUOffset;
TMatMapVScale = TMatMapUScale;
TMatShading = SmallInt;
TMatWireSize = Single;
TMeshColor = Byte;
TMeshMatrix = array[0..11] of Single;
TMeshVersion = Integer;
TMorphSmooth = Single;
TMshBoxmap = array[0..5] of AnsiString;
TNDirectLight = TPoint3DS;
TObjMatList = array[0..MaxInt div (2*SizeOf(TObjMat3DS))] of TObjMat3DS;
TOConsts = TPoint3DS;
TPivot = TPoint3DS;
TPointList = array[0..MaxInt div (2*SizeOf(TPoint3DS))] of TPoint3DS;
TRayBias = THiShadowBias;
TReleaseLevel = (...);
TShadeType3DS = (...);
TShadowFilter = Single;
TShadowMapSize = SmallInt;
TShadowRange = Integer;
TShadowSamples = SmallInt;
TShadowStyle3DS = (...);
TSingleList = array[0..MaxInt div (2*SizeOf(Single))] of Single;
TSolidBgnd3DS = TFColor3DS;
TTargetType3DS = (...);
TTexVertList = array[0..MaxInt div (2*SizeOf(TTexVert3DS))] of TTexVert3DS;
TTileType3DS = (...);
TTintType3DS = (...);
TVGradient = Single;
TViewportData3 = TViewportData;
TViewType3DS = (...);
TWordList = array[0..MaxInt div (2*SizeOf(Word))] of Word;
TXDataDouble = Double;
TXDataFloat = Single;
TXDataLong = Integer;
TXDataShort = SmallInt;
TXDataVoid = Pointer;

Description

Types

PACubic3DS = ˆTACubic3DS;

used by AddMaterial3DS

PAtmosphere3DS = ˆTAtmosphere3DS;

This item has no description.

PBackground3DS = ˆTBackground3DS;

This item has no description.

PBitmap3DS = ˆTBitmap3DS;

Cubic reflection Map defintion

PBitmapBgnd3DS = ˆTBitmapBgnd3DS;

This item has no description.

PBitMapName = PChar3DS;

This item has no description.

PBoundBox = ˆTBoundBox;

This item has no description.

PCamera3DS = ˆTCamera3DS;

This item has no description.

PCamRanges = ˆTCamRanges;

This item has no description.

PCamRanges3DS = ˆTCamRanges3DS;

Camera atomosphere Ranges

PCardinalArray = ˆTCardinalArray;

This item has no description.

PChar3DS = PAnsiChar;

This item has no description.

PChunk3DS = ˆTChunk3DS;

This item has no description.

PChunkList = ˆTChunkList;

This item has no description.

PChunkList3DS = ˆTChunkList3DS;

This item has no description.

PChunkListEntry3DS = ˆTChunkListEntry3DS;

internal database representation of file information

PColor24 = ˆTColor24;

This item has no description.

PColorF = ˆTColorF;

inner datatypes not followed by a '3DS' to show they are locally used (mostly as a part of another chunk or while collecting specific data)

PColTrackTag = ˆTColTrackTag;

This item has no description.

PDatabase3DS = ˆTDatabase3DS;

This item has no description.

PDCueSettings3DS = ˆTDCueSettings3DS;

This item has no description.

PDistanceCue = ˆTDistanceCue;

This item has no description.

PDlExclude = PChar3DS;

This item has no description.

PDlInnerRange = ˆTDlInnerRange;

This item has no description.

PDlLocalShadow2 = ˆTDlLocalShadow2;

This item has no description.

PDlMultiplier = ˆTDlMultiplier;

This item has no description.

PDlOuterRange = ˆTDlOuterRange;

This item has no description.

PDlRayBias = ˆTDlRayBias;

This item has no description.

PDlSpotAspect = ˆTDlSpotAspect;

This item has no description.

PDlSpotlight = ˆTDlSpotlight;

This item has no description.

PDlSpotProjector = PChar3DS;

This item has no description.

PDlSpotRoll = ˆTDlSpotRoll;

This item has no description.

PFace3DS = ˆTFace3DS;

This item has no description.

PFaceArray = ˆTFaceArray;

This item has no description.

PFaceList = ˆTFaceList;

This item has no description.

PFallTrackTag = ˆTFallTrackTag;

This item has no description.

PFColor3DS = ˆTFColor3DS;

This item has no description.

PFColorList = ˆTFColorList;

This item has no description.

PFloatPercentage = ˆTFloatPercentage;

This item has no description.

PFog = ˆTFog;

This item has no description.

PFogSettings3DS = ˆTFogSettings3DS;

FallOff to the Bottom

PFovTrackTag = ˆTFovTrackTag;

This item has no description.

PHideTrackTag = ˆTHideTrackTag;

This item has no description.

PHiShadowBias = ˆTHiShadowBias;

This item has no description.

PHotTrackTag = ˆTHotTrackTag;

This item has no description.

PInstanceName = PChar3DS;

This item has no description.

PIntegerArray = ˆTIntegerArray;

This item has no description.

PIntPercentage = ˆTIntPercentage;

This item has no description.

PIpasData = ˆTIpasData;

This item has no description.

PKeyHeader3DS = ˆTKeyHeader3DS;

This item has no description.

PKeyHeaderList = ˆTKeyHeaderList;

This item has no description.

PKFAmbient3DS = ˆTKFAmbient3DS;

Ambient Light animation

PKFCamera3DS = ˆTKFCamera3DS;

This item has no description.

PKFCurtime = ˆTKFCurtime;

This item has no description.

PKFHdr = ˆTKFHdr;

This item has no description.

PKFId = ˆTKFId;

This item has no description.

PKFKeyInfo3DS = ˆTKFKeyInfo3DS;

This item has no description.

PKFMesh3DS = ˆTKFMesh3DS;

used by ObjectMotion3DS

PKFMorphKey3DS = ˆTKFMorphKey3DS;

This item has no description.

PKFMorphKeyList = ˆTKFMorphKeyList;

Name of Target Morph object

PKFOmni3DS = ˆTKFOmni3DS;

used by OmnilightMotion3DS

PKFRotKey3DS = ˆTKFRotKey3DS;

This item has no description.

PKFRotKeyList = ˆTKFRotKeyList;

This item has no description.

PKFSeg = ˆTKFSeg;

This item has no description.

PKFSegment3DS = ˆTKFSegment3DS;

This item has no description.

PKFSets3DS = ˆTKFSets3DS;

This item has no description.

PKFSpot3DS = ˆTKFSpot3DS;

This item has no description.

PLayerFog = ˆTLayerFog;

This item has no description.

PLayerFogSettings3DS = ˆTLayerFogSettings3DS;

This item has no description.

PLight3DS = ˆTLight3DS;

omni and spotlight settings

PLinColor24 = ˆTLinColor24;

This item has no description.

PLinColorF = ˆTLinColorF;

This item has no description.

PLiteAttenuate3DS = ˆTLiteAttenuate3DS;

Light Attenuation settings

PLoShadowBias = ˆTLoShadowBias;

This item has no description.

PM3dVersion = ˆTM3dVersion;

This item has no description.

PMapInfo3DS = ˆTMapInfo3DS;

Texture Map icon placement

PMapSet3DS = ˆTMapSet3DS;

Bit Map definition Structure to all Map settings

PMasterScale = ˆTMasterScale;

This item has no description.

PMatAcubic = ˆTMatAcubic;

This item has no description.

PMatBumpPercent = ˆTMatBumpPercent;

This item has no description.

PMaterial3DS = ˆTMaterial3DS;

This item has no description.

PMatMapAng = ˆTMatMapAng;

This item has no description.

PMatMapBCol = ˆTMatMapBCol;

This item has no description.

PMatMapCol1 = ˆTMatMapCol1;

This item has no description.

PMatMapCol2 = ˆTMatMapCol2;

This item has no description.

PMatMapGCol = ˆTMatMapGCol;

This item has no description.

PMatMapname = PChar3DS;

This item has no description.

PMatMapRCol = ˆTMatMapRCol;

This item has no description.

PMatMapTexblur = ˆTMatMapTexblur;

This item has no description.

PMatMapTiling = ˆTMatMapTiling;

This item has no description.

PMatMapUOffset = ˆTMatMapUOffset;

This item has no description.

PMatMapUScale = ˆTMatMapUScale;

This item has no description.

PMatMapVOffset = ˆTMatMapVOffset;

This item has no description.

PMatMapVScale = ˆTMatMapVScale;

This item has no description.

PMatName = PChar3DS;

This item has no description.

PMatShading = ˆTMatShading;

This item has no description.

PMatWireSize = ˆTMatWireSize;

This item has no description.

PMesh3DS = ˆTMesh3DS;

Mesh object definition

PMeshColor = ˆTMeshColor;

This item has no description.

PMeshMatrix = ˆTMeshMatrix;

Mesh definition

PMeshSet3DS = ˆTMeshSet3DS;

This item has no description.

PMeshTextureInfo = ˆTMeshTextureInfo;

This item has no description.

PMeshVersion = ˆTMeshVersion;

This item has no description.

PMorphSmooth = ˆTMorphSmooth;

This item has no description.

PMorphTrackTag = ˆTMorphTrackTag;

This item has no description.

PMshBoxmap = ˆTMshBoxmap;

This item has no description.

PMshMatGroup = ˆTMshMatGroup;

This item has no description.

PNamedObject = PChar3DS;

This item has no description.

PNCamera = ˆTNCamera;

This item has no description.

PNDirectLight = ˆTNDirectLight;

This item has no description.

PNodeHdr = ˆTNodeHdr;

This item has no description.

PNodeList = ˆTNodeList;

3D Studio .MLI file

PObjMat3DS = ˆTObjMat3DS;

Material assignments by face

PObjMatList = ˆTObjMatList;

This item has no description.

POConsts = ˆTOConsts;

This item has no description.

POrthoView3DS = ˆTOrthoView3DS;

This item has no description.

PPivot = ˆTPivot;

This item has no description.

PPoint3DS = ˆTPoint3DS;

This item has no description.

PPointArray = ˆTPointArray;

This item has no description.

PPointFlagArray = ˆTPointFlagArray;

This item has no description.

PPointList = ˆTPointList;

This item has no description.

PPosTrackTag = ˆTPosTrackTag;

This item has no description.

PProcName = PChar3DS;

This item has no description.

PRayBias = ˆTRayBias;

This item has no description.

PRollTrackTag = ˆTRollTrackTag;

This item has no description.

PRotTrackTag = ˆTRotTrackTag;

This item has no description.

PScaleTrackTag = ˆTScaleTrackTag;

This item has no description.

PShadowFilter = ˆTShadowFilter;

This item has no description.

PShadowMapSize = ˆTShadowMapSize;

This item has no description.

PShadowRange = ˆTShadowRange;

This item has no description.

PShadowSamples = ˆTShadowSamples;

This item has no description.

PShadowSets3DS = ˆTShadowSets3DS;

This item has no description.

PSingleList = ˆTSingleList;

This item has no description.

PSmoothGroup = ˆTSmoothGroup;

This item has no description.

PSpotCone3DS = ˆTSpotCone3DS;

Cone visibility settings

PSpotLight3DS = ˆTSpotLight3DS;

spotlight settings

PSpotProjector3DS = ˆTSpotProjector3DS;

spotlight projectio Bitmap

PSpotShadow3DS = ˆTSpotShadow3DS;

Spotlight shadow settings

PTexVert3DS = ˆTTexVert3DS;

This item has no description.

PTexVertList = ˆTTexVertList;

This item has no description.

PTexVerts = ˆTTexVerts;

This item has no description.

PTrackHeader3DS = ˆTTrackHeader3DS;

This item has no description.

PUserView3DS = ˆTUserView3DS;

This item has no description.

PVGradient = ˆTVGradient;

This item has no description.

PVGradientBgnd3DS = ˆTVGradientBgnd3DS;

Color of Solid background

PViewCamera = PChar3DS;

This item has no description.

PViewport3DS = ˆTViewport3DS;

This item has no description.

PViewportData = ˆTViewportData;

This item has no description.

PViewportData3 = ˆTViewportData3;

This item has no description.

PViewportLayout = ˆTViewportLayout;

This item has no description.

PViewportSize = ˆTViewportSize;

This item has no description.

PViewSize3DS = ˆTViewSize3DS;

This item has no description.

PViewStandard = ˆTViewStandard;

This item has no description.

PViewUser = ˆTViewUser;

This item has no description.

PWordList = ˆTWordList;

This item has no description.

PXDataAppName = PChar3DS;

This item has no description.

PXDataDouble = ˆTXDataDouble;

This item has no description.

PXDataEntry = ˆTXDataEntry;

This item has no description.

PXDataFloat = ˆTXDataFloat;

This item has no description.

PXDataLong = ˆTXDataLong;

This item has no description.

PXDataRaw3DS = ˆTXDataRaw3DS;

This item has no description.

PXDataShort = ˆTXDataShort;

This item has no description.

PXDataString = PChar3DS;

This item has no description.

PXDataVoid = ˆTXDataVoid;

This item has no description.

String3DS = UTF8String;

This item has no description.

String64 = string[64];

This item has no description.

TAtmosphereType3DS = (...);

This item has no description.

Values
  • atNoAtmo
  • atUseFog: no active atmospherics
  • atUseLayerFog: Fog atmospheric
  • atUseDistanceCue: layer Fog atmospheric
TBackgroundType3DS = (...);

enumerate list of possible backgrounds used in file

Values
  • btNoBgnd
  • btUseSolidBgnd
  • btUseVGradientBgnd
  • btUseBitmapBgnd
TBitmapBgnd3DS = AnsiString;

This item has no description.

TCardinalArray = array[0..MaxInt div (2*SizeOf(Cardinal))] of Cardinal;

This item has no description.

TChunkList = array[0..MaxInt div (2*SizeOf(TChunkListEntry3DS))] of TChunkListEntry3DS;

This item has no description.

TConeStyle3DS = (...);

Spotlight projection cone shape

Values
  • csCircular
  • csRectangular
TDBType3DS = (...);

Database type settings

Values
  • dbUnknown
  • dbMeshFile: database has not been created yet
  • dbProjectFile: 3D Studio .3DS file
  • dbMaterialFile: 3D Studio .PRJ file
TDlInnerRange = TDlOuterRange;

This item has no description.

TDlMultiplier = Single;

This item has no description.

TDlOuterRange = Single;

This item has no description.

TDlRayBias = Single;

This item has no description.

TDlSpotAspect = Single;

This item has no description.

TDlSpotRoll = Single;

This item has no description.

TDumpLevel = (...);

for TStringList —————- commonly used structures ———————————-

Values
  • dlTerseDump
  • dlMediumDump
  • dlMaximumDump
TFaceList = array[0..MaxInt div (2*SizeOf(TFace3DS))] of TFace3DS;

This item has no description.

TFColorList = array[0..MaxInt div (2*SizeOf(TFColor3DS))] of TFColor3DS;

This item has no description.

TFilterType3DS = (...);

This item has no description.

Values
  • ftPyramidal
  • ftSummedArea
TFloatPercentage = Single;

This item has no description.

THiShadowBias = TLoShadowBias;

This item has no description.

TIntegerArray = array[0..MaxInt div (2*SizeOf(Integer))] of Integer;

This item has no description.

TIntPercentage = SmallInt;

This item has no description.

TKeyHeaderList = array[0..MaxInt div (2*SizeOf(TKeyHeader3DS))] of TKeyHeader3DS;

This item has no description.

TKFCurtime = Integer;

This item has no description.

TKFId = SmallInt;

This item has no description.

TKFMorphKey3DS = String;

Object Morph key

TKFMorphKeyList = array[0..MaxInt div (2*SizeOf(TKFMorphKey3DS))] of TKFMorphKey3DS;

This item has no description.

TKFRotKeyList = array[0..MaxInt div (2*SizeOf(TKFRotKey3DS))] of TKFRotKey3DS;

This item has no description.

TLayerFogFalloff3DS = (...);

distance cue atmospheric

Values
  • lfNoFall
  • lfTopFall: no FallOff
  • lfBottomFall: FallOff to the Top
TLinColor24 = TColor24;

This item has no description.

TLinColorF = TColorF;

This item has no description.

TLoShadowBias = Single;

This item has no description.

TM3dVersion = Cardinal;

This item has no description.

TMasterScale = Single;

This item has no description.

TMatBumpPercent = TIntPercentage;

This item has no description.

TMatMapAng = Single;

This item has no description.

TMatMapBCol = TMatMapGCol;

This item has no description.

TMatMapCol1 = TMatMapBCol;

This item has no description.

TMatMapCol2 = TMatMapCol1;

This item has no description.

TMatMapGCol = TMatMapRCol;

This item has no description.

TMatMapRCol = TLinColor24;

This item has no description.

TMatMapTexblur = Single;

This item has no description.

TMatMapTiling = Word;

This item has no description.

TMatMapUOffset = Single;

This item has no description.

TMatMapUScale = Single;

This item has no description.

TMatMapVOffset = TMatMapUOffset;

This item has no description.

TMatMapVScale = TMatMapUScale;

This item has no description.

TMatShading = SmallInt;

This item has no description.

TMatWireSize = Single;

This item has no description.

TMeshColor = Byte;

This item has no description.

TMeshMatrix = array[0..11] of Single;

This item has no description.

TMeshVersion = Integer;

This item has no description.

TMorphSmooth = Single;

This item has no description.

TMshBoxmap = array[0..5] of AnsiString;

This item has no description.

TNDirectLight = TPoint3DS;

This item has no description.

TObjMatList = array[0..MaxInt div (2*SizeOf(TObjMat3DS))] of TObjMat3DS;

This item has no description.

TOConsts = TPoint3DS;

This item has no description.

TPivot = TPoint3DS;

This item has no description.

TPointList = array[0..MaxInt div (2*SizeOf(TPoint3DS))] of TPoint3DS;

This item has no description.

TRayBias = THiShadowBias;

This item has no description.

TReleaseLevel = (...);

This item has no description.

Values
  • rlRelease1
  • rlRelease2
  • rlRelease3
  • rlReleaseNotKnown
TShadeType3DS = (...);

used for shading field in TMaterial3DS structure

Values
  • stWire
  • stFlat
  • stGouraud
  • stPhong
  • stMetal
TShadowFilter = Single;

This item has no description.

TShadowMapSize = SmallInt;

This item has no description.

TShadowRange = Integer;

This item has no description.

TShadowSamples = SmallInt;

This item has no description.

TShadowStyle3DS = (...);

This item has no description.

Values
  • ssUseShadowMap
  • ssUseRayTraceShadow
TSingleList = array[0..MaxInt div (2*SizeOf(Single))] of Single;

This item has no description.

TSolidBgnd3DS = TFColor3DS;

Name of background Bitmap

TTargetType3DS = (...);

This item has no description.

Values
  • ttLightTarget
  • ttCameraTarget
TTexVertList = array[0..MaxInt div (2*SizeOf(TTexVert3DS))] of TTexVert3DS;

This item has no description.

TTileType3DS = (...);

used for tiling field in TBitmap3DS structure

Values
  • ttTile
  • ttDecal
  • ttBoth
TTintType3DS = (...);

This item has no description.

Values
  • ttRGB
  • ttAlpha
  • ttRGBLumaTint
  • ttAlphaTint
  • ttRGBTint
TVGradient = Single;

This item has no description.

TViewportData3 = TViewportData;

This item has no description.

TViewType3DS = (...);

This item has no description.

Values
  • vtNoView3DS
  • vtTopView3DS
  • vtBottomView3DS
  • vtLeftView3DS
  • vtRightView3DS
  • vtFrontView3DS
  • vtBackView3DS
  • vtUserView3DS
  • vtCameraView3DS
  • vtSpotlightView3DS
TWordList = array[0..MaxInt div (2*SizeOf(Word))] of Word;

This item has no description.

TXDataDouble = Double;

This item has no description.

TXDataFloat = Single;

This item has no description.

TXDataLong = Integer;

This item has no description.

TXDataShort = SmallInt;

This item has no description.

TXDataVoid = Pointer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TPoint3DS

Record TPoint3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TPoint3DS = record

Description

3D point structure

Overview

Fields

Public | X: Single;
Public | Y: Single;
Public | Z: Single;

Description

Fields

Public X: Single;

This item has no description.

Public Y: Single;

This item has no description.

Public Z: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TFColor3DS

Record TFColor3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TFColor3DS = record

Description

RGB Color components

Overview

Fields

Public | R: Single;
Public | G: Single;
Public | B: Single;

Description

Fields

Public R: Single;

This item has no description.

Public G: Single;

This item has no description.

Public B: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Packed Record TFace3DS

Packed Record TFace3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TFace3DS = packed record

Description

Face List element

Overview

Fields

Public | V1: Word
Public | V2: Word
Public | V3: Word
Public | Flag: Word
Public | FaceRec: array[0..3] of Word

Description

Fields

Public V1: Word

This item has no description.

Public V2: Word

This item has no description.

Public V3: Word

This item has no description.

Public Flag: Word

This item has no description.

Public FaceRec: array[0..3] of Word


GLSysHelp v.2.5: Formats.m3DSTypes: Record TTexVert3DS

Record TTexVert3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TTexVert3DS = record

Description

Texture assignment coordinate

Overview

Fields

Public | U: Single;
Public | V: Single;

Description

Fields

Public U: Single;

This item has no description.

Public V: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TTrackHeader3DS

Record TTrackHeader3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TTrackHeader3DS = record

Description

Global track settings

Overview

Fields

Public | Flags: Word;
Public | nu1: Integer;
Public | nu2: Integer;
Public | KeyCount: Integer;

Description

Fields

Public Flags: Word;

This item has no description.

Public nu1: Integer;

This item has no description.

Public nu2: Integer;

This item has no description.

Public KeyCount: Integer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKeyHeader3DS

Record TKeyHeader3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKeyHeader3DS = record

Description

Animation key settings

Overview

Fields

Public | Time: Integer;
Public | RFlags: Word;
Public | Tension: Single;
Public | Continuity: Single;
Public | Bias: Single;
Public | EaseTo: Single;
Public | EaseFrom: Single;

Description

Fields

Public Time: Integer;

This item has no description.

Public RFlags: Word;

Key's frame position

Public Tension: Single;

Spline terms used flag

Public Continuity: Single;

Flagged with $01

Public Bias: Single;

Flagged with $02

Public EaseTo: Single;

Flagged with $04

Public EaseFrom: Single;

Flagged with $08


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFRotKey3DS

Record TKFRotKey3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFRotKey3DS = record

Description

Rotation key

Overview

Fields

Public | Angle: Single;
Public | X: Single;
Public | Y: Single;
Public | Z: Single;

Description

Fields

Public Angle: Single;

This item has no description.

Public X: Single;

Angle of Rotation

Public Y: Single;

Angle of Rotation

Public Z: Single;

Angle of Rotation


GLSysHelp v.2.5: Formats.m3DSTypes: Record TChunkListEntry3DS

Record TChunkListEntry3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TChunkListEntry3DS = record

Description

cross reference between Name and Chunk

Overview

Fields

Public | NameStr: String;
Public | Chunk: PChunk3DS;

Description

Fields

Public NameStr: String;

This item has no description.

Public Chunk: PChunk3DS;

chunk name list


GLSysHelp v.2.5: Formats.m3DSTypes: Record TChunkList3DS

Record TChunkList3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TChunkList3DS = record

Description

list of cross references

Overview

Fields

Public | Count: Integer;
Public | List: PChunkList;

Description

Fields

Public Count: Integer;

This item has no description.

Public List: PChunkList;

number of entries in List


GLSysHelp v.2.5: Formats.m3DSTypes: Record TNodeList

Record TNodeList

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TNodeList = record

Description

This item has no description.

Overview

Fields

Public | ID: SmallInt;
Public | Tag: Word;
Public | Name: String;
Public | InstStr: String;
Public | ParentID: SmallInt;
Public | Next: PNodeList;

Description

Fields

Public ID: SmallInt;

This item has no description.

Public Tag: Word;

This item has no description.

Public Name: String;

This item has no description.

Public InstStr: String;

This item has no description.

Public ParentID: SmallInt;

This item has no description.

Public Next: PNodeList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TDatabase3DS

Record TDatabase3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TDatabase3DS = record

Description

file database

Overview

Fields

Public | TopChunk: PChunk3DS;
Public | ObjListDirty: Boolean;
Public | MatListDirty: Boolean;
Public | NodeListDirty: Boolean;
Public | ObjList: PChunkList3DS;
Public | MatList: PChunkList3DS;
Public | NodeList: PChunkList3DS;

Description

Fields

Public TopChunk: PChunk3DS;

This item has no description.

Public ObjListDirty: Boolean;

Top chunk in the file

Public MatListDirty: Boolean;

If True, than ObjList needs to be recreated

Public NodeListDirty: Boolean;

If True, than ObjList needs to be recreated

Public ObjList: PChunkList3DS;

This item has no description.

Public MatList: PChunkList3DS;

Quick Cross references between names and database chunks

Public NodeList: PChunkList3DS;

Quick Cross references between names and database chunks


GLSysHelp v.2.5: Formats.m3DSTypes: Record TViewSize3DS

Record TViewSize3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TViewSize3DS = record

Description

This item has no description.

Overview

Fields

Public | XPos: Word;
Public | YPos: Word;
Public | Width: Word;
Public | Height: Word;

Description

Fields

Public XPos: Word;

This item has no description.

Public YPos: Word;

This item has no description.

Public Width: Word;

This item has no description.

Public Height: Word;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TOrthoView3DS

Record TOrthoView3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TOrthoView3DS = record

Description

Used to describe Top, Bottom, left, right, front and back views

Overview

Fields

Public | Center: TPoint3DS;
Public | Zoom: Single;

Description

Fields

Public Center: TPoint3DS;

This item has no description.

Public Zoom: Single;

Center of orthogonal View


GLSysHelp v.2.5: Formats.m3DSTypes: Record TUserView3DS

Record TUserView3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TUserView3DS = record

Description

This item has no description.

Overview

Fields

Public | Center: TPoint3DS;
Public | Zoom: Single;
Public | HorAng: Single;
Public | VerAng: Single;

Description

Fields

Public Center: TPoint3DS;

Used to describe User views

Public Zoom: Single;

Center of User View

Public HorAng: Single;

View Zoom factor

Public VerAng: Single;

Horizontal Angle of View


GLSysHelp v.2.5: Formats.m3DSTypes: Record TViewport3DS

Record TViewport3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TViewport3DS = record

Description

Viewport structure details the kind of View in a viewport

Overview

Fields

Public | AType: TViewType3DS;
Public | Size: TViewSize3DS;
Public | Ortho: TOrthoView3DS;
Public | User: TUserView3DS;
Public | CameraStr: String;

Description

Fields

Public AType: TViewType3DS;

This item has no description.

Public Size: TViewSize3DS;

top, bottom, left, right, front, back, user and camera, spot

Public Ortho: TOrthoView3DS;

size of the viewport

Public User: TUserView3DS;

used for top, bottom, left, right, front, and back views

Public CameraStr: String;

Used for User views


GLSysHelp v.2.5: Formats.m3DSTypes: Record TShadowSets3DS

Record TShadowSets3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TShadowSets3DS = record

Description

global Shadow settings

Overview

Fields

Public | AType: TShadowStyle3DS;
Public | Bias: Single;
Public | RayBias: Single;
Public | MapSize: Smallint;
Public | Filter: Single;

Description

Fields

Public AType: TShadowStyle3DS;

This item has no description.

Public Bias: Single;

either UseShadowMaps or UseRayTraceShadows

Public RayBias: Single;

Shadow Bias factor.

Public MapSize: Smallint;

Shadow ray Bias factor, Used in R3

Public Filter: Single;

Shadow Map Size


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMeshSet3DS

Record TMeshSet3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMeshSet3DS = record

Description

This item has no description.

Overview

Fields

Public | MasterScale: Single;
Public | Shadow: TShadowSets3DS;
Public | AmbientLight: TFColor3DS;
Public | OConsts: TPoint3DS;

Description

Fields

Public MasterScale: Single;

This item has no description.

Public Shadow: TShadowSets3DS;

master mesh Scale factor

Public AmbientLight: TFColor3DS;

Global Shadow settings

Public OConsts: TPoint3DS;

Ambient light Color


GLSysHelp v.2.5: Formats.m3DSTypes: Record TFogSettings3DS

Record TFogSettings3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TFogSettings3DS = record

Description

Fog atmosphere parameters

Overview

Fields

Public | NearPlane: Single;
Public | NearDensity: Single;
Public | FarPlane: Single;
Public | FarDensity: Single;
Public | FogColor: TFColor3DS;
Public | FogBgnd: Boolean;

Description

Fields

Public NearPlane: Single;

This item has no description.

Public NearDensity: Single;

near radius of Fog effect

Public FarPlane: Single;

near Fog Density

Public FarDensity: Single;

far radius of Fog effect

Public FogColor: TFColor3DS;

far Fog Density

Public FogBgnd: Boolean;

Color of Fog effect


GLSysHelp v.2.5: Formats.m3DSTypes: Record TLayerFogSettings3DS

Record TLayerFogSettings3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TLayerFogSettings3DS = record

Description

layered Fog atmosphere parameters

Overview

Fields

Public | ZMin: Single;
Public | ZMax: Single;
Public | Density: Single;
Public | FogColor: TFColor3DS;
Public | FallOff: TLayerFogFalloff3DS;
Public | FogBgnd: Boolean;

Description

Fields

Public ZMin: Single;

This item has no description.

Public ZMax: Single;

lower bounds of Fog

Public Density: Single;

upper bounds of Fog

Public FogColor: TFColor3DS;

Fog Density

Public FallOff: TLayerFogFalloff3DS;

Fog Color

Public FogBgnd: Boolean;

FallOff style


GLSysHelp v.2.5: Formats.m3DSTypes: Record TDCueSettings3DS

Record TDCueSettings3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TDCueSettings3DS = record

Description

distance cue atmosphere parameters

Overview

Fields

Public | NearPlane: Single;
Public | NearDim: Single;
Public | FarPlane: Single;
Public | FarDim: Single;
Public | DCueBgnd: Boolean;

Description

Fields

Public NearPlane: Single;

This item has no description.

Public NearDim: Single;

near radius of effect

Public FarPlane: Single;

near dimming factor

Public FarDim: Single;

far radius of effect

Public DCueBgnd: Boolean;

far dimming factor


GLSysHelp v.2.5: Formats.m3DSTypes: Record TAtmosphere3DS

Record TAtmosphere3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TAtmosphere3DS = record

Description

This item has no description.

Overview

Fields

Public | Fog: TFogSettings3DS;
Public | LayerFog: TLayerFogSettings3DS;
Public | DCue: TDCueSettings3DS;
Public | ActiveAtmo: TAtmosphereType3DS;

Description

Fields

Public Fog: TFogSettings3DS;

This item has no description.

Public LayerFog: TLayerFogSettings3DS;

Fog atmosphere settings

Public DCue: TDCueSettings3DS;

layered Fog atmosphere parameters

Public ActiveAtmo: TAtmosphereType3DS;

distance cue atmosphere parameters


GLSysHelp v.2.5: Formats.m3DSTypes: Record TVGradientBgnd3DS

Record TVGradientBgnd3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TVGradientBgnd3DS = record

Description

This item has no description.

Overview

Fields

Public | GradPercent: Single;
Public | Top: TFColor3DS;
Public | Mid: TFColor3DS;
Public | Bottom: TFColor3DS;

Description

Fields

Public GradPercent: Single;

This item has no description.

Public Top: TFColor3DS;

placement of Mid Color band, Ranges from 0-1

Public Mid: TFColor3DS;

color of Top band

Public Bottom: TFColor3DS;

color of Mid background band


GLSysHelp v.2.5: Formats.m3DSTypes: Record TBackground3DS

Record TBackground3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TBackground3DS = record

Description

This item has no description.

Overview

Fields

Public | Bitmap: TBitmapBgnd3DS;
Public | Solid: TSolidBgnd3DS;
Public | VGradient: TVGradientBgnd3DS;
Public | BgndUsed: TBackgroundType3DS;

Description

Fields

Public Bitmap: TBitmapBgnd3DS;

This item has no description.

Public Solid: TSolidBgnd3DS;

This item has no description.

Public VGradient: TVGradientBgnd3DS;

This item has no description.

Public BgndUsed: TBackgroundType3DS;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TACubic3DS

Record TACubic3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TACubic3DS = record

Description

This item has no description.

Overview

Fields

Public | FirstFrame: Boolean;
Public | Flat: Boolean;
Public | Size: Integer;
Public | nthFrame: Integer;

Description

Fields

Public FirstFrame: Boolean;

This item has no description.

Public Flat: Boolean;

True for First Frame Only

Public Size: Integer;

True for Flat Mirror reflection

Public nthFrame: Integer;

Map resolution


GLSysHelp v.2.5: Formats.m3DSTypes: Record TBitmap3DS

Record TBitmap3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TBitmap3DS = record

Description

This item has no description.

Overview

Fields

Public | NameStr: AnsiString;
Public | Percent: Single;
Public | Tiling: TTileType3DS;
Public | IgnoreAlpha: Boolean;
Public | Filter: TFilterType3DS;
Public | Blur: Single;
Public | Mirror: Boolean;
Public | Negative: Boolean;
Public | UScale: Single;
Public | VScale: Single;
Public | UOffset: Single;
Public | VOffset: Single;
Public | Rotation: Single;
Public | Source: TTintType3DS;
Public | Tint1: TFColor3DS;
Public | Tint2: TFColor3DS;
Public | RedTint: TFColor3DS;
Public | GreenTint: TFColor3DS;
Public | BlueTint: TFColor3DS;
Public | DataSize: Integer;
Public | Data: Pointer;

Description

Fields

Public NameStr: AnsiString;

This item has no description.

Public Percent: Single;

Bitmap file name

Public Tiling: TTileType3DS;

Strength percentage

Public IgnoreAlpha: Boolean;

Tile/Decal/Both

Public Filter: TFilterType3DS;

This item has no description.

Public Blur: Single;

Pyramidal/Summed Area

Public Mirror: Boolean;

This item has no description.

Public Negative: Boolean;

This item has no description.

Public UScale: Single;

This item has no description.

Public VScale: Single;

This item has no description.

Public UOffset: Single;

This item has no description.

Public VOffset: Single;

This item has no description.

Public Rotation: Single;

This item has no description.

Public Source: TTintType3DS;

This item has no description.

Public Tint1: TFColor3DS;

RGB/RGB Luma Tint/Alpha Tint/RGB Tint

Public Tint2: TFColor3DS;

This item has no description.

Public RedTint: TFColor3DS;

This item has no description.

Public GreenTint: TFColor3DS;

This item has no description.

Public BlueTint: TFColor3DS;

This item has no description.

Public DataSize: Integer;

This item has no description.

Public Data: Pointer;

Size of procedural Data


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMapSet3DS

Record TMapSet3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMapSet3DS = record

Description

This item has no description.

Overview

Fields

Public | Map: TBitmap3DS;
Public | Mask: TBitmap3DS;

Description

Fields

Public Map: TBitmap3DS;

This item has no description.

Public Mask: TBitmap3DS;

The Map settings


GLSysHelp v.2.5: Formats.m3DSTypes: Record TRMapSet3DS

Record TRMapSet3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TRMapSet3DS = record

Description

This item has no description.

Overview

Fields

Public | Map: TBitmap3DS;
Public | UseAuto: Boolean;
Public | AutoMap: TACubic3DS;
Public | Mask: TBitmap3DS;

Description

Fields

Public Map: TBitmap3DS;

This item has no description.

Public UseAuto: Boolean;

The Map settings

Public AutoMap: TACubic3DS;

True if automatic reflections are being used

Public Mask: TBitmap3DS;

Automatic reflection definitions


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMaterial3DS

Record TMaterial3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMaterial3DS = record

Description

This item has no description.

Overview

Fields

Public | NameStr: AnsiString;
Public | Ambient: TFColor3DS;
Public | Diffuse: TFColor3DS;
Public | Specular: TFColor3DS;
Public | Shininess: Single;
Public | ShinStrength: Single;
Public | Blur: Single;
Public | Transparency: Single;
Public | TransFallOff: Single;
Public | SelfIllumPct: Single;
Public | WireSize: Single;
Public | Shading: TShadeType3DS;
Public | UseBlur: Boolean;
Public | UseFall: Boolean;
Public | TwoSided: Boolean;
Public | SelFillum: Boolean;
Public | Additive: Boolean;
Public | UseWire: Boolean;
Public | UseWireAbs: Boolean;
Public | FaceMap: Boolean;
Public | Soften: Boolean;
Public | Texture: TMapSet3DS;
Public | Texture2: TMapSet3DS;
Public | Opacity: TMapSet3DS;
Public | Bump: TMapSet3DS;
Public | SpecMap: TMapSet3DS;
Public | ShinMap: TMapSet3DS;
Public | IllumMap: TMapSet3DS;
Public | Reflect: TRMapSet3DS;

Description

Fields

Public NameStr: AnsiString;

This item has no description.

Public Ambient: TFColor3DS;

Name

Public Diffuse: TFColor3DS;

Ambient Light Color

Public Specular: TFColor3DS;

Diffuse Light Color

Public Shininess: Single;

Specular Light Color

Public ShinStrength: Single;

Shininess factor

Public Blur: Single;

Shininess strength

Public Transparency: Single;

Blur factor

Public TransFallOff: Single;

Trasparency factor

Public SelfIllumPct: Single;

Falloff factor

Public WireSize: Single;

Self illumination percentage

Public Shading: TShadeType3DS;

Width of wireframe

Public UseBlur: Boolean;

Shading type

Public UseFall: Boolean;

Blurring Flag

Public TwoSided: Boolean;

Transparency FallOff Flag

Public SelFillum: Boolean;

Two sided material Flag

Public Additive: Boolean;

Self illumination Flag

Public UseWire: Boolean;

Additive Transparency Flag

Public UseWireAbs: Boolean;

Use wireframe rendering

Public FaceMap: Boolean;

Wire Size is in units, not pixels.

Public Soften: Boolean;

Face mapping switch

Public Texture: TMapSet3DS;

Soften switch

Public Texture2: TMapSet3DS;

Texture Map settings

Public Opacity: TMapSet3DS;

Second Texture Map settings

Public Bump: TMapSet3DS;

Opacity Map settings

Public SpecMap: TMapSet3DS;

Bump Map settings

Public ShinMap: TMapSet3DS;

Specularity Map settings

Public IllumMap: TMapSet3DS;

Shininess Map settings

Public Reflect: TRMapSet3DS;

Self illumination Map settings


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMapInfo3DS

Record TMapInfo3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMapInfo3DS = record

Description

This item has no description.

Overview

Fields

Public | MapType: Word;
Public | TileX: Single;
Public | TileY: Single;
Public | CenX: Single;
Public | CenY: Single;
Public | CenZ: Single;
Public | Scale: Single;
Public | Matrix: TMeshMatrix;
Public | PW: Single;
Public | PH: Single;
Public | CH: Single;

Description

Fields

Public MapType: Word;

This item has no description.

Public TileX: Single;

icon type

Public TileY: Single;

tiling

Public CenX: Single;

This item has no description.

Public CenY: Single;

position of center

Public CenZ: Single;

This item has no description.

Public Scale: Single;

This item has no description.

Public Matrix: TMeshMatrix;

icon scaling factor

Public PW: Single;

orientation matrix

Public PH: Single;

planar icon width

Public CH: Single;

planar icon height


GLSysHelp v.2.5: Formats.m3DSTypes: Record TObjMat3DS

Record TObjMat3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TObjMat3DS = record

Description

This item has no description.

Overview

Fields

Public | NameStr: AnsiString;
Public | NFaces: Word;
Public | FaceIndex: PWordList;

Description

Fields

Public NameStr: AnsiString;

This item has no description.

Public NFaces: Word;

material name

Public FaceIndex: PWordList;

number of faces using material


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMesh3DS

Record TMesh3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMesh3DS = record

Description

This item has no description.

Overview

Fields

Public | NameStr: AnsiString;
Public | IsHidden: Boolean;
Public | IsvisLofter: Boolean;
Public | IsMatte: Boolean;
Public | IsNoCast: Boolean;
Public | IsFast: Boolean;
Public | IsNorcvShad: boolean;
Public | IsFrozen: Boolean;
Public | NVertices: Word;
Public | VertexArray: PPointList;
Public | NVFlags: Word;
Public | VFlagArray: PWordList;
Public | NTextVerts: Word;
Public | TextArray: PTexVertList;
Public | UseMapInfo: Boolean;
Public | Map: TMapInfo3DS;
Public | LocMatrix: TMeshMatrix;
Public | NFaces: Word;
Public | FaceArray: PFaceList;
Public | SmoothArray: PCardinalArray;
Public | UseBoxMap: Boolean;
Public | BoxMapStr: array[0..5] of String;
Public | MeshColor: Byte;
Public | NMats: Word;
Public | MatArray: PObjMatList;
Public | UseProc: Boolean;
Public | ProcSize: Integer;
Public | ProcNameStr: String;
Public | ProcData: Pointer;

Description

Fields

Public NameStr: AnsiString;

This item has no description.

Public IsHidden: Boolean;

object name

Public IsvisLofter: Boolean;

hidden object flag

Public IsMatte: Boolean;

lofter visibility flag

Public IsNoCast: Boolean;

matte object flag

Public IsFast: Boolean;

doesn't cast shadows flag

Public IsNorcvShad: boolean;

fast display flag

Public IsFrozen: Boolean;

doesn't recieve shadows

Public NVertices: Word;

frozen object flag

Public VertexArray: PPointList;

vertice count

Public NVFlags: Word;

list of vertices

Public VFlagArray: PWordList;

number of vertex flags

Public NTextVerts: Word;

list of vertex flags

Public TextArray: PTexVertList;

number of texture vertices

Public UseMapInfo: Boolean;

list of texture coordinates

Public Map: TMapInfo3DS;

for use of mapping icon information

Public LocMatrix: TMeshMatrix;

mapping icon info

Public NFaces: Word;

object orientation matrix

Public FaceArray: PFaceList;

face count

Public SmoothArray: PCardinalArray;

list of faces

Public UseBoxMap: Boolean;

smoothing group assignment list

Public BoxMapStr: array[0..5] of String;

used to indicate the use of box mapping

Public MeshColor: Byte;

material names used in boxmapping

Public NMats: Word;

UI color assigned to the mesh

Public MatArray: PObjMatList;

assigned materials count

Public UseProc: Boolean;

material assignment list

Public ProcSize: Integer;

use animated stand-in flag

Public ProcNameStr: String;

size of animated stand-in data

Public ProcData: Pointer;

name of animated stand-in procedure


GLSysHelp v.2.5: Formats.m3DSTypes: Record TSpotShadow3DS

Record TSpotShadow3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TSpotShadow3DS = record

Description

This item has no description.

Overview

Fields

Public | Cast: Boolean;
Public | AType: TShadowStyle3DS;
Public | Local: Boolean;
Public | Bias: Single;
Public | Filter: Single;
Public | MapSize: Word;
Public | RayBias: Single;

Description

Fields

Public Cast: Boolean;

This item has no description.

Public AType: TShadowStyle3DS;

True if spotlight casts shadows

Public Local: Boolean;

UseShadow or UseRayTrace

Public Bias: Single;

True if local shadow settings are being used

Public Filter: Single;

shadow bias

Public MapSize: Word;

shadow filter

Public RayBias: Single;

shadow map size


GLSysHelp v.2.5: Formats.m3DSTypes: Record TSpotCone3DS

Record TSpotCone3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TSpotCone3DS = record

Description

This item has no description.

Overview

Fields

Public | AType: TConeStyle3DS;
Public | Show: Boolean;
Public | Overshoot: Boolean;

Description

Fields

Public AType: TConeStyle3DS;

This item has no description.

Public Show: Boolean;

Circular or rectangular light cone

Public Overshoot: Boolean;

True if cone is visible


GLSysHelp v.2.5: Formats.m3DSTypes: Record TSpotProjector3DS

Record TSpotProjector3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TSpotProjector3DS = record

Description

This item has no description.

Overview

Fields

Public | Use: Boolean;
Public | BitmapStr: String;

Description

Fields

Public Use: Boolean;

This item has no description.

Public BitmapStr: String;

True if using projector


GLSysHelp v.2.5: Formats.m3DSTypes: Record TSpotLight3DS

Record TSpotLight3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TSpotLight3DS = record

Description

This item has no description.

Overview

Fields

Public | Target: TPoint3DS;
Public | Hotspot: Single;
Public | FallOff: Single;
Public | Roll: Single;
Public | Aspect: Single;
Public | Shadows: TSpotShadow3DS;
Public | Cone: TSpotCone3DS;
Public | Projector: TSpotProjector3DS;

Description

Fields

Public Target: TPoint3DS;

This item has no description.

Public Hotspot: Single;

Spotlight Target

Public FallOff: Single;

Hotspot Angle

Public Roll: Single;

Hotspot FallOff

Public Aspect: Single;

Roll Angle

Public Shadows: TSpotShadow3DS;

Aspect ratio

Public Cone: TSpotCone3DS;

This item has no description.

Public Projector: TSpotProjector3DS;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TLiteAttenuate3DS

Record TLiteAttenuate3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TLiteAttenuate3DS = record

Description

This item has no description.

Overview

Fields

Public | IsOn: Boolean;
Public | Inner: Single;
Public | Outer: Single;

Description

Fields

Public IsOn: Boolean;

This item has no description.

Public Inner: Single;

True if Light Attenuation is on

Public Outer: Single;

Inner range of Attenuation


GLSysHelp v.2.5: Formats.m3DSTypes: Record TLight3DS

Record TLight3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TLight3DS = record

Description

This item has no description.

Overview

Fields

Public | NameStr: AnsiString;
Public | Pos: TPoint3DS;
Public | Color: TFColor3DS;
Public | Multiplier: Single;
Public | DLOff: Boolean;
Public | Attenuation: TLiteAttenuate3DS;
Public | Exclude: TStringList;
Public | Spot: PSpotLight3DS;

Description

Fields

Public NameStr: AnsiString;

This item has no description.

Public Pos: TPoint3DS;

light name

Public Color: TFColor3DS;

light position

Public Multiplier: Single;

light color

Public DLOff: Boolean;

light intensity multiplier

Public Attenuation: TLiteAttenuate3DS;

True if light is off

Public Exclude: TStringList;

This item has no description.

Public Spot: PSpotLight3DS;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TCamRanges3DS

Record TCamRanges3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TCamRanges3DS = record

Description

This item has no description.

Overview

Fields

Public | CamNear: Single;
Public | CamFar: Single;

Description

Fields

Public CamNear: Single;

This item has no description.

Public CamFar: Single;

Nearest effect radius


GLSysHelp v.2.5: Formats.m3DSTypes: Record TCamera3DS

Record TCamera3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TCamera3DS = record

Description

This item has no description.

Overview

Fields

Public | NameStr: AnsiString;
Public | Position: TPoint3DS;
Public | Target: TPoint3DS;
Public | Roll: Single;
Public | FOV: Single;
Public | ShowCone: Boolean;
Public | Ranges: TCamRanges3DS;

Description

Fields

Public NameStr: AnsiString;

This item has no description.

Public Position: TPoint3DS;

This item has no description.

Public Target: TPoint3DS;

This item has no description.

Public Roll: Single;

This item has no description.

Public FOV: Single;

This item has no description.

Public ShowCone: Boolean;

This item has no description.

Public Ranges: TCamRanges3DS;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFKeyInfo3DS

Record TKFKeyInfo3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFKeyInfo3DS = record

Description

This item has no description.

Overview

Fields

Public | Length: Integer;
Public | CurFrame: Integer;

Description

Fields

Public Length: Integer;

This item has no description.

Public CurFrame: Integer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFSegment3DS

Record TKFSegment3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFSegment3DS = record

Description

This item has no description.

Overview

Fields

Public | Use: Boolean;
Public | SegBegin: Integer;
Public | SegEnd: Integer;

Description

Fields

Public Use: Boolean;

This item has no description.

Public SegBegin: Integer;

This item has no description.

Public SegEnd: Integer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFSets3DS

Record TKFSets3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFSets3DS = record

Description

This item has no description.

Overview

Fields

Public | Anim: TKFKeyInfo3DS;
Public | Seg: TKFSegment3DS;

Description

Fields

Public Anim: TKFKeyInfo3DS;

This item has no description.

Public Seg: TKFSegment3DS;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFCamera3DS

Record TKFCamera3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFCamera3DS = record

Description

This item has no description.

Overview

Fields

Public | NameStr: AnsiString;
Public | ParentStr: AnsiString;
Public | Flags1: Word;
Public | Flags2: Word;
Public | NPKeys: Integer;
Public | NPFlag: Word;
Public | PKeys: PKeyHeaderList;
Public | Pos: PPointList;
Public | NFKeys: Integer;
Public | NFFlag: Word;
Public | FKeys: PKeyHeaderList;
Public | FOV: PSingleList;
Public | NRKeys: Integer;
Public | NRFlag: Word;
Public | RKeys: PKeyHeaderList;
Public | Roll: PSingleList;
Public | TParentStr: String;
Public | NTKeys: Integer;
Public | NTFlag: Word;
Public | TKeys: PKeyHeaderList;
Public | TPos: PPointList;
Public | TFlags1: Word;
Public | TFlags2: Word;

Description

Fields

Public NameStr: AnsiString;

This item has no description.

Public ParentStr: AnsiString;

Name of Camera object

Public Flags1: Word;

Name of Parent object

Public Flags2: Word;

Flags field from node header -fixup later

Public NPKeys: Integer;

Flags2 field from node header -fixup later

Public NPFlag: Word;

Number of Camera Position keys

Public PKeys: PKeyHeaderList;

Loop control Flag for Camera Position keys

Public Pos: PPointList;

Spline values for Camera Position keys

Public NFKeys: Integer;

Camera Position keys

Public NFFlag: Word;

Number of Camera FOV keys

Public FKeys: PKeyHeaderList;

Loop control Flag for Camera FOV keys

Public FOV: PSingleList;

Spline values for Camera FOV keys

Public NRKeys: Integer;

Camera FOV keys

Public NRFlag: Word;

Number of Camera Roll keys

Public RKeys: PKeyHeaderList;

Loop control Flag for Camera Roll keys

Public Roll: PSingleList;

Spline values for Camera Roll keys

Public TParentStr: String;

Camera Roll keys

Public NTKeys: Integer;

Index of Parent object for Target

Public NTFlag: Word;

Number of Target Position keys

Public TKeys: PKeyHeaderList;

Loop control Flag for Target Position keys

Public TPos: PPointList;

Spline values for Target Position keys

Public TFlags1: Word;

Target Position keys

Public TFlags2: Word;

Flags field from Target node header


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFAmbient3DS

Record TKFAmbient3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFAmbient3DS = record

Description

This item has no description.

Overview

Fields

Public | Flags1: Word;
Public | Flags2: Word;
Public | NCKeys: Integer;
Public | NCFlag: Word;
Public | CKeys: PKeyHeaderList;
Public | Color: PFColorList;

Description

Fields

Public Flags1: Word;

This item has no description.

Public Flags2: Word;

Flags field from node header -fixup later

Public NCKeys: Integer;

Flags2 field from node header -fixup later

Public NCFlag: Word;

Number of Color keys

Public CKeys: PKeyHeaderList;

Loop control Flag for Color keys

Public Color: PFColorList;

Spline values for Position keys


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFMesh3DS

Record TKFMesh3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFMesh3DS = record

Description

This item has no description.

Overview

Fields

Public | NameStr: AnsiString;
Public | ParentStr: AnsiString;
Public | Flags1: Word;
Public | Flags2: Word;
Public | Pivot: TPoint3DS;
Public | InstanceStr: AnsiString;
Public | BoundMin: TPoint3DS;
Public | BoundMax: TPoint3DS;
Public | NPKeys: Integer;
Public | NPFlag: Smallint;
Public | PKeys: PKeyHeaderList;
Public | Pos: PPointList;
Public | NRKeys: Integer;
Public | NRFlag: Smallint;
Public | RKeys: PKeyHeaderList;
Public | Rot: PKFRotKeyList;
Public | NSKeys: Integer;
Public | NSFlag: Smallint;
Public | SKeys: PKeyHeaderList;
Public | Scale: PPointList;
Public | NMKeys: Integer;
Public | NMFlag: Smallint;
Public | MKeys: PKeyHeaderList;
Public | Morph: PKFMorphKeyList;
Public | NHKeys: Integer;
Public | NHFlag: Smallint;
Public | HKeys: PKeyHeaderList;
Public | MSAngle: Single;

Description

Fields

Public NameStr: AnsiString;

This item has no description.

Public ParentStr: AnsiString;

Name of mesh

Public Flags1: Word;

Name of Parent object

Public Flags2: Word;

Flags field from node header

Public Pivot: TPoint3DS;

Flags2 field from node header

Public InstanceStr: AnsiString;

Object Pivot point

Public BoundMin: TPoint3DS;

Object Instance Name

Public BoundMax: TPoint3DS;

Minimum bounding box point for dummy objects

Public NPKeys: Integer;

Maximum bounding box point for dummy objects

Public NPFlag: Smallint;

Number of Position keys

Public PKeys: PKeyHeaderList;

Loop control Flag for Position keys

Public Pos: PPointList;

Spline values for Position keys

Public NRKeys: Integer;

Mesh Position keys

Public NRFlag: Smallint;

Number of Rotation keys

Public RKeys: PKeyHeaderList;

Loop control Flag for Rotation keys

Public Rot: PKFRotKeyList;

Spline values for Rotation keys

Public NSKeys: Integer;

Rotation keys

Public NSFlag: Smallint;

Number of scaling keys

Public SKeys: PKeyHeaderList;

Loop control Flag for scaling keys

Public Scale: PPointList;

Spline values for scaling

Public NMKeys: Integer;

Mesh scaling keys

Public NMFlag: Smallint;

Number of Morph keys

Public MKeys: PKeyHeaderList;

Loop control Flag for Morph keys

Public Morph: PKFMorphKeyList;

Spline values for Morph keys

Public NHKeys: Integer;

Morph keys

Public NHFlag: Smallint;

Number of hide keys

Public HKeys: PKeyHeaderList;

Loop control Flag for hide keys

Public MSAngle: Single;

Spline values for hide keys


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFOmni3DS

Record TKFOmni3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFOmni3DS = record

Description

This item has no description.

Overview

Fields

Public | Name: AnsiString;
Public | Parent: AnsiString;
Public | Flags1: Word;
Public | Flags2: Word;
Public | NPKeys: Integer;
Public | NPFlag: Word;
Public | PKeys: PKeyHeaderList;
Public | Pos: PPointList;
Public | NCKeys: Integer;
Public | NCFlag: Word;
Public | CKeys: PKeyHeaderList;
Public | Color: PFColorList;

Description

Fields

Public Name: AnsiString;

This item has no description.

Public Parent: AnsiString;

Name of the Light object node

Public Flags1: Word;

Name of the Parent object

Public Flags2: Word;

Flags field from node header -fixup later

Public NPKeys: Integer;

Flags2 field from node header -fixup later

Public NPFlag: Word;

Number of Position keys

Public PKeys: PKeyHeaderList;

Loop control Flag for Position keys

Public Pos: PPointList;

Spline values for Position keys

Public NCKeys: Integer;

Position keys

Public NCFlag: Word;

Number of Color keys

Public CKeys: PKeyHeaderList;

Loop control Flag for Color keys

Public Color: PFColorList;

Spline values for Position keys


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFSpot3DS

Record TKFSpot3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFSpot3DS = record

Description

This item has no description.

Overview

Fields

Public | Name: AnsiString;
Public | Parent: AnsiString;
Public | Flags1: Word;
Public | Flags2: Word;
Public | NPKeys: Integer;
Public | NPFlag: Word;
Public | PKeys: PKeyHeaderList;
Public | Pos: PPointList;
Public | NCKeys: Integer;
Public | NCFlag: Word;
Public | CKeys: PKeyHeaderList;
Public | Color: PFColorList;
Public | NHKeys: Integer;
Public | NHFlag: Word;
Public | HKeys: PKeyHeaderList;
Public | Hot: PSingleList;
Public | NFKeys: Integer;
Public | NFFlag: Word;
Public | FKeys: PKeyHeaderList;
Public | Fall: PSingleList;
Public | NRKeys: Integer;
Public | NRFlag: Word;
Public | RKeys: PKeyHeaderList;
Public | Roll: PSingleList;
Public | TParent: AnsiString;
Public | NTKeys: Integer;
Public | NTFlag: Word;
Public | TKeys: PKeyHeaderList;
Public | TPos: PPointList;
Public | TFlags1: Word;
Public | TFlags2: Word;

Description

Fields

Public Name: AnsiString;

This item has no description.

Public Parent: AnsiString;

Name of Camera object

Public Flags1: Word;

Parent Name

Public Flags2: Word;

Flags field from node header -fixup later

Public NPKeys: Integer;

Flags2 field from node header -fixup later

Public NPFlag: Word;

Number of Light Position keys

Public PKeys: PKeyHeaderList;

Loop control Flag for Position keys

Public Pos: PPointList;

Spline values for Light Position keys

Public NCKeys: Integer;

Light Position keys

Public NCFlag: Word;

Number of Color keys

Public CKeys: PKeyHeaderList;

Loop control Flag Color keys

Public Color: PFColorList;

Spline values for Color keys

Public NHKeys: Integer;

Color keys

Public NHFlag: Word;

Number of Hotspot Angle keys

Public HKeys: PKeyHeaderList;

Loop control Flag for Hotspot Angle keys

Public Hot: PSingleList;

Spline values for Hotspot Angle keys

Public NFKeys: Integer;

Hotspot Angle keys

Public NFFlag: Word;

Number of FallOff Angle keys

Public FKeys: PKeyHeaderList;

Loop control Flag for FallOff Angle keys

Public Fall: PSingleList;

Spline values for FallOff Angle keys

Public NRKeys: Integer;

FallOff Angle keys

Public NRFlag: Word;

Number of Light Roll keys

Public RKeys: PKeyHeaderList;

Loop control Flag for Light Roll keys

Public Roll: PSingleList;

Spline values for Light Roll keys

Public TParent: AnsiString;

Light Roll keys

Public NTKeys: Integer;

Name of Target's Parent object

Public NTFlag: Word;

Number of Target Position keys

Public TKeys: PKeyHeaderList;

Loop control Flag for Target Position keys

Public TPos: PPointList;

Spline values for Target Position keys

Public TFlags1: Word;

Target Position keys

Public TFlags2: Word;

Flags field from Target node header


GLSysHelp v.2.5: Formats.m3DSTypes: Record TXDataRaw3DS

Record TXDataRaw3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TXDataRaw3DS = record

Description

This item has no description.

Overview

Fields

Public | Size: Integer;
Public | Data: Pointer;

Description

Fields

Public Size: Integer;

This item has no description.

Public Data: Pointer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TColorF

Record TColorF

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TColorF = record

Description

This item has no description.

Overview

Fields

Public | Red: Single;
Public | Green: Single;
Public | Blue: Single;

Description

Fields

Public Red: Single;

This item has no description.

Public Green: Single;

This item has no description.

Public Blue: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TColor24

Record TColor24

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TColor24 = record

Description

This item has no description.

Overview

Fields

Public | Red: Byte;
Public | Green: Byte;
Public | Blue: Byte;

Description

Fields

Public Red: Byte;

This item has no description.

Public Green: Byte;

This item has no description.

Public Blue: Byte;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TFog

Record TFog

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TFog = record

Description

This item has no description.

Overview

Fields

Public | NearPlaneDist: Single;
Public | NearPlaneDensity: Single;
Public | FarPlaneDist: Single;
Public | FarPlaneDensity: Single;

Description

Fields

Public NearPlaneDist: Single;

This item has no description.

Public NearPlaneDensity: Single;

This item has no description.

Public FarPlaneDist: Single;

This item has no description.

Public FarPlaneDensity: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TLayerFog

Record TLayerFog

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TLayerFog = record

Description

This item has no description.

Overview

Fields

Public | ZMin: Single;
Public | ZMax: Single;
Public | Density: Single;
Public | AType: Cardinal;

Description

Fields

Public ZMin: Single;

This item has no description.

Public ZMax: Single;

This item has no description.

Public Density: Single;

This item has no description.

Public AType: Cardinal;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TDistanceCue

Record TDistanceCue

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TDistanceCue = record

Description

This item has no description.

Overview

Fields

Public | NearPlaneDist: Single;
Public | NearPlaneDimming: Single;
Public | FarPlaneDist: Single;
Public | FarPlaneDimming: Single;

Description

Fields

Public NearPlaneDist: Single;

This item has no description.

Public NearPlaneDimming: Single;

This item has no description.

Public FarPlaneDist: Single;

This item has no description.

Public FarPlaneDimming: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TViewStandard

Record TViewStandard

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TViewStandard = record

Description

This item has no description.

Overview

Fields

Public | ViewTargetCoord: TPoint3DS;
Public | ViewWidth: Single;

Description

Fields

Public ViewTargetCoord: TPoint3DS;

This item has no description.

Public ViewWidth: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TViewUser

Record TViewUser

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TViewUser = record

Description

This item has no description.

Overview

Fields

Public | ViewTargetCoord: TPoint3DS;
Public | ViewWidth: Single;
Public | XYViewangle: Single;
Public | YZViewangle: Single;
Public | BankAngle: Single;

Description

Fields

Public ViewTargetCoord: TPoint3DS;

This item has no description.

Public ViewWidth: Single;

This item has no description.

Public XYViewangle: Single;

This item has no description.

Public YZViewangle: Single;

This item has no description.

Public BankAngle: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMatAcubic

Record TMatAcubic

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMatAcubic = record

Description

This item has no description.

Overview

Fields

Public | ShadeLevel: Byte;
Public | Antialias: Byte;
Public | Flags: SmallInt;
Public | MapSize: Cardinal;
Public | FrameInterval: Cardinal;

Description

Fields

Public ShadeLevel: Byte;

This item has no description.

Public Antialias: Byte;

This item has no description.

Public Flags: SmallInt;

This item has no description.

Public MapSize: Cardinal;

This item has no description.

Public FrameInterval: Cardinal;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TIpasData

Record TIpasData

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TIpasData = record

Description

This item has no description.

Overview

Fields

Public | Size: Integer;
Public | Data: Pointer;

Description

Fields

Public Size: Integer;

This item has no description.

Public Data: Pointer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TPointArray

Record TPointArray

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TPointArray = record

Description

This item has no description.

Overview

Fields

Public | Vertices: Word;
Public | PointList: PPointList;

Description

Fields

Public Vertices: Word;

This item has no description.

Public PointList: PPointList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TPointFlagArray

Record TPointFlagArray

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TPointFlagArray = record

Description

This item has no description.

Overview

Fields

Public | Flags: Word;
Public | FlagList: PWordList;

Description

Fields

Public Flags: Word;

This item has no description.

Public FlagList: PWordList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TFaceArray

Record TFaceArray

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TFaceArray = record

Description

This item has no description.

Overview

Fields

Public | Faces: Word;
Public | FaceList: PFaceList;

Description

Fields

Public Faces: Word;

This item has no description.

Public FaceList: PFaceList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMshMatGroup

Record TMshMatGroup

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMshMatGroup = record

Description

This item has no description.

Overview

Fields

Public | MatNameStr: AnsiString;
Public | Faces: Word;
Public | FaceList: PWordList;

Description

Fields

Public MatNameStr: AnsiString;

This item has no description.

Public Faces: Word;

This item has no description.

Public FaceList: PWordList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TSmoothGroup

Record TSmoothGroup

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TSmoothGroup = record

Description

This item has no description.

Overview

Fields

Public | Groups: Word;
Public | GroupList: PCardinalArray;

Description

Fields

Public Groups: Word;

This item has no description.

Public GroupList: PCardinalArray;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TTexVerts

Record TTexVerts

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TTexVerts = record

Description

This item has no description.

Overview

Fields

Public | NumCoords: Word;
Public | TextVertList: PTexVertList;

Description

Fields

Public NumCoords: Word;

This item has no description.

Public TextVertList: PTexVertList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMeshTextureInfo

Record TMeshTextureInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMeshTextureInfo = record

Description

This item has no description.

Overview

Fields

Public | MapType: Word;
Public | XTiling: Single;
Public | YTiling: Single;
Public | IconPos: TPoint3DS;
Public | IconScaling: Single;
Public | XMatrix: TMeshMatrix;
Public | IconWidth: Single;
Public | IconHeight: Single;
Public | CylIconHeight: Single;

Description

Fields

Public MapType: Word;

This item has no description.

Public XTiling: Single;

This item has no description.

Public YTiling: Single;

This item has no description.

Public IconPos: TPoint3DS;

This item has no description.

Public IconScaling: Single;

This item has no description.

Public XMatrix: TMeshMatrix;

This item has no description.

Public IconWidth: Single;

This item has no description.

Public IconHeight: Single;

This item has no description.

Public CylIconHeight: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TDlSpotlight

Record TDlSpotlight

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TDlSpotlight = record

Description

This item has no description.

Overview

Fields

Public | SpotLightTarg: TPoint3DS;
Public | HotspotAngle: Single;
Public | FalloffAngle: Single;

Description

Fields

Public SpotLightTarg: TPoint3DS;

This item has no description.

Public HotspotAngle: Single;

This item has no description.

Public FalloffAngle: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TDlLocalShadow2

Record TDlLocalShadow2

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TDlLocalShadow2 = record

Description

This item has no description.

Overview

Fields

Public | LocalShadowBias: Single;
Public | LocalShadowFilter: Single;
Public | LocalShadowMapSize: SmallInt

Description

Fields

Public LocalShadowBias: Single;

This item has no description.

Public LocalShadowFilter: Single;

This item has no description.

Public LocalShadowMapSize: SmallInt


GLSysHelp v.2.5: Formats.m3DSTypes: Record TNCamera

Record TNCamera

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TNCamera = record

Description

This item has no description.

Overview

Fields

Public | CameraPos: TPoint3DS;
Public | TargetPos: TPoint3DS;
Public | CameraBank: Single;
Public | CameraFocalLength: Single;

Description

Fields

Public CameraPos: TPoint3DS;

This item has no description.

Public TargetPos: TPoint3DS;

This item has no description.

Public CameraBank: Single;

This item has no description.

Public CameraFocalLength: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TCamRanges

Record TCamRanges

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TCamRanges = record

Description

This item has no description.

Overview

Fields

Public | NearPlane: Single;
Public | FarPlane: Single;

Description

Fields

Public NearPlane: Single;

This item has no description.

Public FarPlane: Single;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TViewportLayout

Record TViewportLayout

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TViewportLayout = record

Description

This item has no description.

Overview

Fields

Public | Form: SmallInt;
Public | Top: SmallInt;
Public | Ready: SmallInt;
Public | WState: SmallInt;
Public | SwapWS: SmallInt;
Public | SwapPort: SmallInt;
Public | SwapCur: SmallInt;

Description

Fields

Public Form: SmallInt;

This item has no description.

Public Top: SmallInt;

0 = single window 1 = 2 split verticle 2 = 2 split horizontal 3 = 4 equal squares 4 = 2 squares left & 1 rect right 5 = 1 rect at Top & 2 sqr on bot 6 = 1 rect left & 2 sqr right 7 = 2 sqr Top & 1 rect bot 8 = 3 split vertical 9 = 2 split horiz 10 = 3 sqr left and 1 rect right 11 = 1 rect left & 3 sqr. right Form becomes 0 during swap and its preswapped value is stored in the SwapPort field

Public Ready: SmallInt;

Active window index of 0 to 5

Public WState: SmallInt;

This item has no description.

Public SwapWS: SmallInt;

0 if no swap window, 1 if in swaped "w" state. During a swap, the old 0 window gets stored as the 4 window

Public SwapPort: SmallInt;

This item has no description.

Public SwapCur: SmallInt;

The preswapped value from the Form field


GLSysHelp v.2.5: Formats.m3DSTypes: Record TViewportSize

Record TViewportSize

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TViewportSize = record

Description

This item has no description.

Overview

Fields

Public | XPos: Word;
Public | YPos: Word;
Public | Width: Word;
Public | Height: Word;

Description

Fields

Public XPos: Word;

Values given for 1024x768 resolution

Public YPos: Word;

0

Public Width: Word;

14

Public Height: Word;

895


GLSysHelp v.2.5: Formats.m3DSTypes: Record TViewportData

Record TViewportData

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TViewportData = record

Description

This item has no description.

Overview

Fields

Public | Flags: Word;
Public | AxisLockout: Word;
Public | WinXPos: Word;
Public | WinYPos: Word;
Public | WinWidth: Word;
Public | WinHeight: Word;
Public | View: Word;
Public | ZoomFactor: Single;
Public | Center: TPoint3DS;
Public | HorizAng: Single;
Public | VertAng: Single;
Public | CamNameStr: AnsiString;

Description

Fields

Public Flags: Word;

This item has no description.

Public AxisLockout: Word;

This item has no description.

Public WinXPos: Word;

This item has no description.

Public WinYPos: Word;

This item has no description.

Public WinWidth: Word;

This item has no description.

Public WinHeight: Word;

This item has no description.

Public View: Word;

This item has no description.

Public ZoomFactor: Single;

0 = No View 1 = Top View 2 = Bottom View 3 = Left View 4 = Right View 5 = Front View 6 = Back View 7 = User View 18 = Spotlight View 65535 = Camera View

Public Center: TPoint3DS;

This item has no description.

Public HorizAng: Single;

This item has no description.

Public VertAng: Single;

This item has no description.

Public CamNameStr: AnsiString;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFHdr

Record TKFHdr

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFHdr = record

Description

This item has no description.

Overview

Fields

Public | Revision: SmallInt;
Public | Filename: String;
Public | AnimLength: Integer;

Description

Fields

Public Revision: SmallInt;

This item has no description.

Public Filename: String;

This item has no description.

Public AnimLength: Integer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TKFSeg

Record TKFSeg

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TKFSeg = record

Description

This item has no description.

Overview

Fields

Public | First: Integer;
Public | Last: Integer;

Description

Fields

Public First: Integer;

This item has no description.

Public Last: Integer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TNodeHdr

Record TNodeHdr

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TNodeHdr = record

Description

This item has no description.

Overview

Fields

Public | ObjNameStr: String;
Public | Flags1: Word;
Public | Flags2: Word;
Public | ParentIndex: SmallInt;

Description

Fields

Public ObjNameStr: String;

This item has no description.

Public Flags1: Word;

This item has no description.

Public Flags2: Word;

This item has no description.

Public ParentIndex: SmallInt;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TBoundBox

Record TBoundBox

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TBoundBox = record

Description

This item has no description.

Overview

Fields

Public | Min: TPoint3DS;
Public | Max: TPoint3DS;

Description

Fields

Public Min: TPoint3DS;

This item has no description.

Public Max: TPoint3DS;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TPosTrackTag

Record TPosTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TPosTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | PositionList: PPointList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public PositionList: PPointList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TColTrackTag

Record TColTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TColTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | ColorList: PFColorList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public ColorList: PFColorList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TRotTrackTag

Record TRotTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TRotTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | RotationList: PKFRotKeyList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public RotationList: PKFRotKeyList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TScaleTrackTag

Record TScaleTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TScaleTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | ScaleList: PPointList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public ScaleList: PPointList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TMorphTrackTag

Record TMorphTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TMorphTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | MorphList: PKFMorphKeyList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public MorphList: PKFMorphKeyList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record THideTrackTag

Record THideTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type THideTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TFovTrackTag

Record TFovTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TFovTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | FOVAngleList: PSingleList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public FOVAngleList: PSingleList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TRollTrackTag

Record TRollTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TRollTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | RollAngleList: PSingleList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public RollAngleList: PSingleList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record THotTrackTag

Record THotTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type THotTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | HotspotAngleList: PSingleList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public HotspotAngleList: PSingleList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TFallTrackTag

Record TFallTrackTag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TFallTrackTag = record

Description

This item has no description.

Overview

Fields

Public | TrackHdr: TTrackHeader3DS;
Public | KeyHdrList: PKeyHeaderList;
Public | FalloffAngleList: PSingleList;

Description

Fields

Public TrackHdr: TTrackHeader3DS;

This item has no description.

Public KeyHdrList: PKeyHeaderList;

This item has no description.

Public FalloffAngleList: PSingleList;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TXDataEntry

Record TXDataEntry

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TXDataEntry = record

Description

This item has no description.

Overview

Fields

Public | Size: Integer;
Public | Data: Pointer;

Description

Fields

Public Size: Integer;

This item has no description.

Public Data: Pointer;


GLSysHelp v.2.5: Formats.m3DSTypes: Record TChunkData

Record TChunkData

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TChunkData = record

Description

to avoid zillion type casts, we use this variant record for chunk data, effectively this defines the same pointer differently for different chunk types this is only possible because all types are just pointers

Overview

Fields

Public | ColorF: PColorF
Public | LinColorF: PLinColorF
Public | Color24: PColor24
Public | LinColor24: PLinColor24
Public | IntPercentage: PIntPercentage
Public | FloatPercentage: PFloatPercentage
Public | MatMapname: PMatMapname
Public | M3dVersion: PM3dVersion
Public | MeshVersion: PMeshVersion
Public | MasterScale: PMasterScale
Public | LoShadowBias: PLoShadowBias
Public | ShadowFilter: PShadowFilter
Public | ShadowRange: PShadowRange
Public | HiShadowBias: PHiShadowBias
Public | RayBias: PRayBias
Public | ShadowMapSize: PShadowMapSize
Public | ShadowSamples: PShadowSamples
Public | OConsts: POConsts
Public | BitMapName: PBitMapName
Public | VGradient: PVGradient
Public | Fog: PFog
Public | LayerFog: PLayerFog
Public | DistanceCue: PDistanceCue
Public | ViewStandard: PViewStandard
Public | ViewUser: PViewUser
Public | ViewCamera: PViewCamera
Public | MatName: PMatName
Public | MatShading: PMatShading
Public | MatAcubic: PMatAcubic
Public | IpasData: PIpasData
Public | MatWireSize: PMatWireSize
Public | MatMapTiling: PMatMapTiling
Public | MatMapTexblur: PMatMapTexblur
Public | MatMapUScale: PMatMapUScale
Public | MatMapVScale: PMatMapVScale
Public | MatMapUOffset: PMatMapUOffset
Public | MatMapVOffset: PMatMapVOffset
Public | MatMapAng: PMatMapAng
Public | MatMapCol1: PMatMapCol1
Public | MatMapCol2: PMatMapCol2
Public | MatMapRCol: PMatMapRCol
Public | MatMapGCol: PMatMapGCol
Public | MatMapBCol: PMatMapBCol
Public | MatBumpPercent: PMatBumpPercent
Public | NamedObject: PNamedObject
Public | PointArray: PPointArray
Public | PointFlagArray: PPointFlagArray
Public | FaceArray: PFaceArray
Public | MshMatGroup: PMshMatGroup
Public | MshBoxmap: PMshBoxmap
Public | SmoothGroup: PSmoothGroup
Public | TexVerts: PTexVerts
Public | MeshMatrix: PMeshMatrix
Public | MeshColor: PMeshColor
Public | MeshTextureInfo: PMeshTextureInfo
Public | ProcName: PProcName
Public | NDirectLight: PNDirectLight
Public | DlExclude: PDlExclude
Public | DlInnerRange: PDlInnerRange
Public | DlOuterRange: PDlOuterRange
Public | DlMultiplier: PDlMultiplier
Public | DlSpotlight: PDlSpotlight
Public | DlLocalShadow2: PDlLocalShadow2
Public | DlSpotRoll: PDlSpotRoll
Public | DlSpotAspect: PDlSpotAspect
Public | DlSpotProjector: PDlSpotProjector
Public | DlRayBias: PDlRayBias
Public | NCamera: PNCamera
Public | CamRanges: PCamRanges
Public | ViewportLayout: PViewportLayout
Public | ViewportSize: PViewportSize
Public | ViewportData: PViewportData
Public | XDataEntry: PXDataEntry
Public | XDataAppName: PXDataAppName
Public | XDataString: PXDataString
Public | KFHdr: PKFHdr
Public | KFSeg: PKFSeg
Public | KFCurtime: PKFCurtime
Public | KFId: PKFId
Public | NodeHdr: PNodeHdr
Public | Pivot: PPivot
Public | InstanceName: PInstanceName
Public | MorphSmooth: PMorphSmooth
Public | BoundBox: PBoundBox
Public | PosTrackTag: PPosTrackTag
Public | ColTrackTag: PColTrackTag
Public | RotTrackTag: PRotTrackTag
Public | ScaleTrackTag: PScaleTrackTag
Public | MorphTrackTag: PMorphTrackTag
Public | FovTrackTag: PFovTrackTag
Public | RollTrackTag: PRollTrackTag
Public | HotTrackTag: PHotTrackTag
Public | FallTrackTag: PFallTrackTag
Public | HideTrackTag: PHideTrackTag
Public | Dummy: Pointer

Description

Fields

Public ColorF: PColorF

This item has no description.

Public LinColorF: PLinColorF

This item has no description.

Public Color24: PColor24

This item has no description.

Public LinColor24: PLinColor24

This item has no description.

Public IntPercentage: PIntPercentage

This item has no description.

Public FloatPercentage: PFloatPercentage

This item has no description.

Public MatMapname: PMatMapname

This item has no description.

Public M3dVersion: PM3dVersion

This item has no description.

Public MeshVersion: PMeshVersion

This item has no description.

Public MasterScale: PMasterScale

This item has no description.

Public LoShadowBias: PLoShadowBias

This item has no description.

Public ShadowFilter: PShadowFilter

This item has no description.

Public ShadowRange: PShadowRange

This item has no description.

Public HiShadowBias: PHiShadowBias

This item has no description.

Public RayBias: PRayBias

This item has no description.

Public ShadowMapSize: PShadowMapSize

This item has no description.

Public ShadowSamples: PShadowSamples

This item has no description.

Public OConsts: POConsts

This item has no description.

Public BitMapName: PBitMapName

This item has no description.

Public VGradient: PVGradient

This item has no description.

Public Fog: PFog

This item has no description.

Public LayerFog: PLayerFog

This item has no description.

Public DistanceCue: PDistanceCue

This item has no description.

Public ViewStandard: PViewStandard

This item has no description.

Public ViewUser: PViewUser

This item has no description.

Public ViewCamera: PViewCamera

This item has no description.

Public MatName: PMatName

This item has no description.

Public MatShading: PMatShading

This item has no description.

Public MatAcubic: PMatAcubic

This item has no description.

Public IpasData: PIpasData

This item has no description.

Public MatWireSize: PMatWireSize

This item has no description.

Public MatMapTiling: PMatMapTiling

This item has no description.

Public MatMapTexblur: PMatMapTexblur

This item has no description.

Public MatMapUScale: PMatMapUScale

This item has no description.

Public MatMapVScale: PMatMapVScale

This item has no description.

Public MatMapUOffset: PMatMapUOffset

This item has no description.

Public MatMapVOffset: PMatMapVOffset

This item has no description.

Public MatMapAng: PMatMapAng

This item has no description.

Public MatMapCol1: PMatMapCol1

This item has no description.

Public MatMapCol2: PMatMapCol2

This item has no description.

Public MatMapRCol: PMatMapRCol

This item has no description.

Public MatMapGCol: PMatMapGCol

This item has no description.

Public MatMapBCol: PMatMapBCol

This item has no description.

Public MatBumpPercent: PMatBumpPercent

This item has no description.

Public NamedObject: PNamedObject

This item has no description.

Public PointArray: PPointArray

This item has no description.

Public PointFlagArray: PPointFlagArray

This item has no description.

Public FaceArray: PFaceArray

This item has no description.

Public MshMatGroup: PMshMatGroup

This item has no description.

Public MshBoxmap: PMshBoxmap

This item has no description.

Public SmoothGroup: PSmoothGroup

This item has no description.

Public TexVerts: PTexVerts

This item has no description.

Public MeshMatrix: PMeshMatrix

This item has no description.

Public MeshColor: PMeshColor

This item has no description.

Public MeshTextureInfo: PMeshTextureInfo

This item has no description.

Public ProcName: PProcName

This item has no description.

Public NDirectLight: PNDirectLight

This item has no description.

Public DlExclude: PDlExclude

This item has no description.

Public DlInnerRange: PDlInnerRange

This item has no description.

Public DlOuterRange: PDlOuterRange

This item has no description.

Public DlMultiplier: PDlMultiplier

This item has no description.

Public DlSpotlight: PDlSpotlight

This item has no description.

Public DlLocalShadow2: PDlLocalShadow2

This item has no description.

Public DlSpotRoll: PDlSpotRoll

This item has no description.

Public DlSpotAspect: PDlSpotAspect

This item has no description.

Public DlSpotProjector: PDlSpotProjector

This item has no description.

Public DlRayBias: PDlRayBias

This item has no description.

Public NCamera: PNCamera

This item has no description.

Public CamRanges: PCamRanges

This item has no description.

Public ViewportLayout: PViewportLayout

This item has no description.

Public ViewportSize: PViewportSize

This item has no description.

Public ViewportData: PViewportData

This item has no description.

Public XDataEntry: PXDataEntry

This item has no description.

Public XDataAppName: PXDataAppName

This item has no description.

Public XDataString: PXDataString

This item has no description.

Public KFHdr: PKFHdr

This item has no description.

Public KFSeg: PKFSeg

This item has no description.

Public KFCurtime: PKFCurtime

This item has no description.

Public KFId: PKFId

This item has no description.

Public NodeHdr: PNodeHdr

This item has no description.

Public Pivot: PPivot

This item has no description.

Public InstanceName: PInstanceName

This item has no description.

Public MorphSmooth: PMorphSmooth

This item has no description.

Public BoundBox: PBoundBox

This item has no description.

Public PosTrackTag: PPosTrackTag

This item has no description.

Public ColTrackTag: PColTrackTag

This item has no description.

Public RotTrackTag: PRotTrackTag

This item has no description.

Public ScaleTrackTag: PScaleTrackTag

This item has no description.

Public MorphTrackTag: PMorphTrackTag

This item has no description.

Public FovTrackTag: PFovTrackTag

This item has no description.

Public RollTrackTag: PRollTrackTag

This item has no description.

Public HotTrackTag: PHotTrackTag

This item has no description.

Public FallTrackTag: PFallTrackTag

This item has no description.

Public HideTrackTag: PHideTrackTag

This item has no description.

Public Dummy: Pointer


GLSysHelp v.2.5: Formats.m3DSTypes: Record TChunk3DS

Record TChunk3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.m3DSTypes

Declaration

type TChunk3DS = record

Description

finally the chunk definition

Overview

Fields

Public | Tag: Word;
Public | Size: Cardinal;
Public | Position: Cardinal;
Public | Data: TChunkData;
Public | Sibling: PChunk3DS;
Public | Children: PChunk3DS;

Description

Fields

Public Tag: Word;

This item has no description.

Public Size: Cardinal;

Type of Chunk

Public Position: Cardinal;

Number of bytes used by Chunk

Public Data: TChunkData;

Offset in Source file

Public Sibling: PChunk3DS;

Memory copy of file Data

Public Children: PChunk3DS;

Next Chunk in database


GLSysHelp v.2.5: Formats.m3DSUtils

Unit Formats.m3DSUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Formats.m3DS
  • Formats.m3DSTypes
  • Formats.m3DSConst
  • GLScene.Strings

Overview

Functions and Procedures

function GetAtmosphere(const Source: TFile3DS; var DB: TDatabase3DS): TAtmosphere3DS;
function GetBackground(const Source: TFile3DS; var DB: TDatabase3DS): TBackground3DS;
function GetMeshSet(const Source: TFile3DS; var DB: TDatabase3DS): TMeshSet3DS;
function GetViewport(const Source: TFile3DS; var DB: TDatabase3DS): TViewport3DS;
procedure AddChild(Parent, Child: PChunk3DS);
procedure AddChildOrdered(Parent, Child: PChunk3DS);
function FindChunk(Top: PChunk3DS; Tag: word): PChunk3DS;
function FindNextChunk(Local: PChunk3DS; Tag: word): PChunk3DS;
procedure FreeChunkData(var Chunk: PChunk3DS);
function GetCameraByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TCamera3DS;
function GetCameraCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetChunkValue(Tag: word): integer;
function GetMaterialByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TMaterial3DS;
function GetMaterialCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetMeshByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TMesh3DS;
function GetMeshCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetOmnilightByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TLight3DS;
function GetSpotlightByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TLight3DS;
function GetOmnilightCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetSpotlightCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
procedure InitChunk(var Chunk: PChunk3DS);
procedure ReleaseCamera(Camera: PCamera3DS);
procedure ReleaseChunk(var Chunk: PChunk3DS);
procedure ReleaseChunkList(var List: PChunkList3DS);
procedure ReleaseLight(Light: PLight3DS);
procedure ReleaseMaterial(Mat: PMaterial3DS);
procedure ReleaseMeshObj(Mesh: PMesh3DS);
function GetKFSettings(const Source: TFile3DS; var DB: TDatabase3DS): TKFSets3DS;
procedure ReleaseCameraMotion(Camera: PKFCamera3DS);
procedure GetCameraNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetCameraNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetCameraMotion(const Source: TFile3DS; CamChunk, TargetChunk: PChunk3DS): TKFCamera3DS;
function GetCameraMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TKFCamera3DS;
procedure ReleaseAmbientLightMotion(Light: PKFAmbient3DS);
function GetAmbientLightMotion(const Source: TFile3DS; var DB: TDatabase3DS): TKFAmbient3DS;
procedure InitObjectMotion(var Obj: TKFMesh3DS; NewNPKeys, NewNRKeys, NewNSKeys, NewNMKeys, NewNHKeys: cardinal);
procedure ReleaseObjectMotion(Obj: PKFMesh3DS);
procedure GetObjectNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetObjectNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetObjectMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; const Name: string): TKFMesh3DS;
function GetObjectMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFMesh3DS;
procedure ReleaseOmnilightMotion(Light: PKFOmni3DS);
procedure GetOmnilightNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetOmnilightNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): cardinal;
function GetOmnilightMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; const Name: string): TKFOmni3DS;
function GetOmnilightMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFOmni3DS;
procedure ReleaseSpotlightMotion(Spot: PKFSpot3DS);
procedure GetSpotlightNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetSpotlightNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): cardinal;
function GetSpotlightMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; const Name: string): TKFSpot3DS;
function GetSpotlightMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFSpot3DS;
function GetM3dMagicRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetMeshRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetKfRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetDatabaseRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
procedure ChunkHeaderReport(var Strings: TStrings; Chunk: PChunk3DS; IndentLevel: integer);
function ChunkTagToString(Tag: word): string;
procedure DumpChunk(const Source: TFile3DS; var Strings: TStrings; Chunk: PChunk3DS; IndentLevel: integer; DumpLevel: TDumpLevel);
procedure DumpKeyHeader(Strings: TStrings; const Key: TKeyHeader3DS; IndentLevel: integer);
procedure DeleteChunk(var Chunk: PChunk3DS);
function FindNamedObjectByIndex(Source: TFile3DS; DB: TDatabase3DS; AType: word; Index: integer): PChunk3DS;
procedure ShowError(const ErrorMessage: string);
procedure ShowErrorFormatted(const ErrorMessage: string; const Args: array of const);

Description

Functions and Procedures

function GetAtmosphere(const Source: TFile3DS; var DB: TDatabase3DS): TAtmosphere3DS;

functions to retrieve global settings of a specific 3DS database

function GetBackground(const Source: TFile3DS; var DB: TDatabase3DS): TBackground3DS;

This item has no description.

function GetMeshSet(const Source: TFile3DS; var DB: TDatabase3DS): TMeshSet3DS;

This item has no description.

function GetViewport(const Source: TFile3DS; var DB: TDatabase3DS): TViewport3DS;

This item has no description.

procedure AddChild(Parent, Child: PChunk3DS);

functions to retrieve/modify data related to materials, lights and objects (meshs)

procedure AddChildOrdered(Parent, Child: PChunk3DS);

This item has no description.

function FindChunk(Top: PChunk3DS; Tag: word): PChunk3DS;

This item has no description.

function FindNextChunk(Local: PChunk3DS; Tag: word): PChunk3DS;

This item has no description.

procedure FreeChunkData(var Chunk: PChunk3DS);

This item has no description.

function GetCameraByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TCamera3DS;

This item has no description.

function GetCameraCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;

This item has no description.

function GetChunkValue(Tag: word): integer;

This item has no description.

function GetMaterialByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TMaterial3DS;

This item has no description.

function GetMaterialCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;

This item has no description.

function GetMeshByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TMesh3DS;

This item has no description.

function GetMeshCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;

This item has no description.

function GetOmnilightByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TLight3DS;

This item has no description.

function GetSpotlightByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TLight3DS;

This item has no description.

function GetOmnilightCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;

This item has no description.

function GetSpotlightCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;

This item has no description.

procedure InitChunk(var Chunk: PChunk3DS);

This item has no description.

procedure ReleaseCamera(Camera: PCamera3DS);

This item has no description.

procedure ReleaseChunk(var Chunk: PChunk3DS);

This item has no description.

procedure ReleaseChunkList(var List: PChunkList3DS);

This item has no description.

procedure ReleaseLight(Light: PLight3DS);

This item has no description.

procedure ReleaseMaterial(Mat: PMaterial3DS);

This item has no description.

procedure ReleaseMeshObj(Mesh: PMesh3DS);

This item has no description.

function GetKFSettings(const Source: TFile3DS; var DB: TDatabase3DS): TKFSets3DS;

functions to retrieve/modify keyframer (animation) data

procedure ReleaseCameraMotion(Camera: PKFCamera3DS);

This item has no description.

procedure GetCameraNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);

This item has no description.

function GetCameraNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;

This item has no description.

function GetCameraMotion(const Source: TFile3DS; CamChunk, TargetChunk: PChunk3DS): TKFCamera3DS;

This item has no description.

function GetCameraMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TKFCamera3DS;

This item has no description.

procedure ReleaseAmbientLightMotion(Light: PKFAmbient3DS);

This item has no description.

function GetAmbientLightMotion(const Source: TFile3DS; var DB: TDatabase3DS): TKFAmbient3DS;

This item has no description.

procedure InitObjectMotion(var Obj: TKFMesh3DS; NewNPKeys, NewNRKeys, NewNSKeys, NewNMKeys, NewNHKeys: cardinal);

This item has no description.

procedure ReleaseObjectMotion(Obj: PKFMesh3DS);

This item has no description.

procedure GetObjectNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);

This item has no description.

function GetObjectNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;

This item has no description.

function GetObjectMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; const Name: string): TKFMesh3DS;

This item has no description.

function GetObjectMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFMesh3DS;

This item has no description.

procedure ReleaseOmnilightMotion(Light: PKFOmni3DS);

This item has no description.

procedure GetOmnilightNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);

This item has no description.

function GetOmnilightNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): cardinal;

This item has no description.

function GetOmnilightMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; const Name: string): TKFOmni3DS;

This item has no description.

function GetOmnilightMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFOmni3DS;

This item has no description.

procedure ReleaseSpotlightMotion(Spot: PKFSpot3DS);

This item has no description.

procedure GetSpotlightNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);

This item has no description.

function GetSpotlightNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): cardinal;

This item has no description.

function GetSpotlightMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; const Name: string): TKFSpot3DS;

This item has no description.

function GetSpotlightMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFSpot3DS;

This item has no description.

function GetM3dMagicRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;

version information

function GetMeshRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;

This item has no description.

function GetKfRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;

This item has no description.

function GetDatabaseRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;

This item has no description.

procedure ChunkHeaderReport(var Strings: TStrings; Chunk: PChunk3DS; IndentLevel: integer);

support functions for text output of chunk and database contents

function ChunkTagToString(Tag: word): string;

This item has no description.

procedure DumpChunk(const Source: TFile3DS; var Strings: TStrings; Chunk: PChunk3DS; IndentLevel: integer; DumpLevel: TDumpLevel);

This item has no description.

procedure DumpKeyHeader(Strings: TStrings; const Key: TKeyHeader3DS; IndentLevel: integer);

This item has no description.

procedure DeleteChunk(var Chunk: PChunk3DS);

support functions for chunk handling

function FindNamedObjectByIndex(Source: TFile3DS; DB: TDatabase3DS; AType: word; Index: integer): PChunk3DS;

This item has no description.

procedure ShowError(const ErrorMessage: string);

error message routines

procedure ShowErrorFormatted(const ErrorMessage: string; const Args: array of const);


GLSysHelp v.2.5: Formats.MD2

Unit Formats.MD2

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TMD2VertexIndex |
Record TMD2Triangle |
Record TMD2TriangleVertex |
Record TMD2AliasFrame |
Record TMD2Header |
Class TFileMD2 |

Types

PMD2AliasFrame = ˆTMD2AliasFrame;
PMD2VertexIndex = ˆTMD2VertexIndex;
TGLVertexList = array of array of TVector3f;
TIndexList = array of TMD2VertexIndex;

Constants

MAX_MD2_TRIANGLES = 4096;
MAX_MD2_VERTICES = 2048;
MAX_MD2_FRAMES = 512;
MAX_MD2_SKINS = 32;
MAX_MD2_SKINNAME = 64;

Description

Types

PMD2AliasFrame = ˆTMD2AliasFrame;

This item has no description.

PMD2VertexIndex = ˆTMD2VertexIndex;

This item has no description.

TGLVertexList = array of array of TVector3f;

This item has no description.

TIndexList = array of TMD2VertexIndex;

This item has no description.

Constants

MAX_MD2_TRIANGLES = 4096;

This item has no description.

MAX_MD2_VERTICES = 2048;

This item has no description.

MAX_MD2_FRAMES = 512;

This item has no description.

MAX_MD2_SKINS = 32;

This item has no description.

MAX_MD2_SKINNAME = 64;


GLSysHelp v.2.5: Formats.MD2: Record TMD2VertexIndex

Record TMD2VertexIndex

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD2

Declaration

type TMD2VertexIndex = record

Description

This item has no description.

Overview

Fields

Public | A: integer;
Public | B: integer;
Public | C: integer;
Public | A_S: single;
Public | A_T: single;
Public | B_S: single;
Public | B_T: single;
Public | C_S: single;
Public | C_T: single;

Description

Fields

Public A: integer;

This item has no description.

Public B: integer;

This item has no description.

Public C: integer;

This item has no description.

Public A_S: single;

This item has no description.

Public A_T: single;

This item has no description.

Public B_S: single;

This item has no description.

Public B_T: single;

This item has no description.

Public C_S: single;

This item has no description.

Public C_T: single;


GLSysHelp v.2.5: Formats.MD2: Record TMD2Triangle

Record TMD2Triangle

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD2

Declaration

type TMD2Triangle = record

Description

This item has no description.

Overview

Fields

Public | VertexIndex: TVector3s;
Public | TextureCoordIndex: TVector3s;

Description

Fields

Public VertexIndex: TVector3s;

This item has no description.

Public TextureCoordIndex: TVector3s;


GLSysHelp v.2.5: Formats.MD2: Record TMD2TriangleVertex

Record TMD2TriangleVertex

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD2

Declaration

type TMD2TriangleVertex = record

Description

This item has no description.

Overview

Fields

Public | Vert: array[0..2] of byte;
Public | LightnormalIndex: byte;

Description

Fields

Public Vert: array[0..2] of byte;

This item has no description.

Public LightnormalIndex: byte;


GLSysHelp v.2.5: Formats.MD2: Record TMD2AliasFrame

Record TMD2AliasFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD2

Declaration

type TMD2AliasFrame = record

Description

This item has no description.

Overview

Fields

Public | Scale: TVector3f;
Public | Translate: TVector3f;
Public | Name: array[0..15] of AnsiChar;
Public | Vertices: array[0..0] of TMD2TriangleVertex;

Description

Fields

Public Scale: TVector3f;

This item has no description.

Public Translate: TVector3f;

This item has no description.

Public Name: array[0..15] of AnsiChar;

This item has no description.

Public Vertices: array[0..0] of TMD2TriangleVertex;


GLSysHelp v.2.5: Formats.MD2: Record TMD2Header

Record TMD2Header

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD2

Declaration

type TMD2Header = record

Description

This item has no description.

Overview

Fields

Public | Ident: integer;
Public | Version: integer;
Public | SkinWidth: integer;
Public | SkinHeight: integer;
Public | FrameSize: integer;
Public | Num_Skins: integer;
Public | Num_Vertices: integer;
Public | Num_TextureCoords: integer;
Public | Num_VertexIndices: integer;
Public | Num_GLCommdands: integer;
Public | Num_Frames: integer;
Public | Offset_skins: integer;
Public | Offset_st: integer;
Public | Offset_tris: integer;
Public | Offset_frames: integer;
Public | Offset_glcmds: integer;
Public | Offset_end: integer;

Description

Fields

Public Ident: integer;

This item has no description.

Public Version: integer;

This item has no description.

Public SkinWidth: integer;

This item has no description.

Public SkinHeight: integer;

This item has no description.

Public FrameSize: integer;

This item has no description.

Public Num_Skins: integer;

This item has no description.

Public Num_Vertices: integer;

This item has no description.

Public Num_TextureCoords: integer;

This item has no description.

Public Num_VertexIndices: integer;

This item has no description.

Public Num_GLCommdands: integer;

This item has no description.

Public Num_Frames: integer;

This item has no description.

Public Offset_skins: integer;

This item has no description.

Public Offset_st: integer;

This item has no description.

Public Offset_tris: integer;

This item has no description.

Public Offset_frames: integer;

This item has no description.

Public Offset_glcmds: integer;

This item has no description.

Public Offset_end: integer;


GLSysHelp v.2.5: Formats.MD2: Class TFileMD2

Class TFileMD2

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD2

Declaration

type TFileMD2 = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TFileMD2

Overview

Fields

Private | FiFrames: longint;
Private | FiVertices: longint;
Private | FiTriangles: longint;
Public | fIndexList: TIndexList;
Public | fVertexList: TGLVertexList;
Public | FrameNames: TStrings;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | procedure LoadFromStream(aStream : TStream);
Private | procedure FreeLists;

Properties

Public | property iFrames: longInt read FiFrames;
Public | property IndexList: TIndexList read fIndexList;
Public | property iTriangles: longInt read FiTriangles;
Public | property iVertices: longInt read FiVertices;
Public | property VertexList: TGLVertexList read fVertexList;

Description

Fields

Private FiFrames: longint;

This item has no description.

Private FiVertices: longint;

This item has no description.

Private FiTriangles: longint;

This item has no description.

Public fIndexList: TIndexList;

This item has no description.

Public fVertexList: TGLVertexList;

This item has no description.

Public FrameNames: TStrings;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure LoadFromStream(aStream : TStream);

This item has no description.

Private procedure FreeLists;

This item has no description.

Properties

Public property iFrames: longInt read FiFrames;

This item has no description.

Public property IndexList: TIndexList read fIndexList;

This item has no description.

Public property iTriangles: longInt read FiTriangles;

This item has no description.

Public property iVertices: longInt read FiVertices;

This item has no description.

Public property VertexList: TGLVertexList read fVertexList;


GLSysHelp v.2.5: Formats.MD3

Unit Formats.MD3

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TMD3Tag |
Record TMD3Bone |
Record TMD3Triangle |
Record TMD3Face |
Record TMD3TexCoord |
Record TMD3Skin |
Record TMD3Header |
Record TMD3MeshHeader |
Record TMD3MeshData |
Class TFileMD3 |


GLSysHelp v.2.5: Formats.MD3: Record TMD3Tag

Record TMD3Tag

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3Tag = record

Description

Quake3 MD3 structure types

Overview

Fields

Public | strName: array [0 .. 63] of AnsiChar;
Public | vPosition: TVector3f;
Public | rotation: TMatrix3f;

Description

Fields

Public strName: array [0 .. 63] of AnsiChar;

This item has no description.

Public vPosition: TVector3f;

This item has no description.

Public rotation: TMatrix3f;


GLSysHelp v.2.5: Formats.MD3: Record TMD3Bone

Record TMD3Bone

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3Bone = record

Description

TMD3Frame = record min_bound,max_bounds, local_origin : TVector3f; radius : single; name : array[0..15] of char; end;

Overview

Fields

Public | mins: TVector3f;
Public | maxs: TVector3f;
Public | position: TVector3f;
Public | scale: single;
Public | creator: array [0 .. 15] of AnsiChar;

Description

Fields

Public mins: TVector3f;

This item has no description.

Public maxs: TVector3f;

This item has no description.

Public position: TVector3f;

This item has no description.

Public scale: single;

This item has no description.

Public creator: array [0 .. 15] of AnsiChar;


GLSysHelp v.2.5: Formats.MD3: Record TMD3Triangle

Record TMD3Triangle

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3Triangle = record

Description

This item has no description.

Overview

Fields

Public | vertex: TVector3s;
Public | normal: TVector2b;

Description

Fields

Public vertex: TVector3s;

This item has no description.

Public normal: TVector2b;

value/64 to get real number position


GLSysHelp v.2.5: Formats.MD3: Record TMD3Face

Record TMD3Face

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3Face = record

Description

This item has no description.

Overview

Fields

Public vertexIndices: TVector3i;

Description

Fields

Public vertexIndices: TVector3i;


GLSysHelp v.2.5: Formats.MD3: Record TMD3TexCoord

Record TMD3TexCoord

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3TexCoord = record

Description

This item has no description.

Overview

Fields

Public textureCoord: TVector2f;

Description

Fields

Public textureCoord: TVector2f;


GLSysHelp v.2.5: Formats.MD3: Record TMD3Skin

Record TMD3Skin

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3Skin = record

Description

This item has no description.

Overview

Fields

Public | strName: array [0 .. 63] of AnsiChar;
Public | shaderIndex: Integer;

Description

Fields

Public strName: array [0 .. 63] of AnsiChar;

This item has no description.

Public shaderIndex: Integer;


GLSysHelp v.2.5: Formats.MD3: Record TMD3Header

Record TMD3Header

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3Header = record

Description

This item has no description.

Overview

Fields

Public | fileID: array [0 .. 3] of AnsiChar;
Public | version: Integer;
Public | strFile: array [0 .. 63] of AnsiChar;
Public | flags: Integer;
Public | numFrames: Integer;
Public | numTags: Integer;
Public | numMeshes: Integer;
Public | numMaxSkins: Integer;
Public | headerSize: Integer;
Public | tagStart: Integer;
Public | tagEnd: Integer;
Public | fileSize: Integer;

Description

Fields

Public fileID: array [0 .. 3] of AnsiChar;

This item has no description.

Public version: Integer;

This item has no description.

Public strFile: array [0 .. 63] of AnsiChar;

This item has no description.

Public flags: Integer;

This item has no description.

Public numFrames: Integer;

This item has no description.

Public numTags: Integer;

This item has no description.

Public numMeshes: Integer;

This item has no description.

Public numMaxSkins: Integer;

This item has no description.

Public headerSize: Integer;

This item has no description.

Public tagStart: Integer;

This item has no description.

Public tagEnd: Integer;

This item has no description.

Public fileSize: Integer;


GLSysHelp v.2.5: Formats.MD3: Record TMD3MeshHeader

Record TMD3MeshHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3MeshHeader = record

Description

This item has no description.

Overview

Fields

Public | meshID: array [0 .. 3] of AnsiChar;
Public | strName: array [0 .. 63] of AnsiChar;
Public | flags: Integer;
Public | numMeshFrames: Integer;
Public | numSkins: Integer;
Public | numVertices: Integer;
Public | numTriangles: Integer;
Public | triStart: Integer;
Public | headerSize: Integer;
Public | uvStart: Integer;
Public | vertexStart: Integer;
Public | meshSize: Integer;

Description

Fields

Public meshID: array [0 .. 3] of AnsiChar;

This item has no description.

Public strName: array [0 .. 63] of AnsiChar;

This item has no description.

Public flags: Integer;

This item has no description.

Public numMeshFrames: Integer;

This item has no description.

Public numSkins: Integer;

This item has no description.

Public numVertices: Integer;

This item has no description.

Public numTriangles: Integer;

This item has no description.

Public triStart: Integer;

This item has no description.

Public headerSize: Integer;

This item has no description.

Public uvStart: Integer;

This item has no description.

Public vertexStart: Integer;

This item has no description.

Public meshSize: Integer;


GLSysHelp v.2.5: Formats.MD3: Record TMD3MeshData

Record TMD3MeshData

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TMD3MeshData = record

Description

This item has no description.

Overview

Fields

Public | MeshHeader: TMD3MeshHeader;
Public | Skins: array of TMD3Skin;
Public | Triangles: array of TMD3Face;
Public | TexCoords: array of TMD3TexCoord;
Public | Vertices: array of TMD3Triangle;

Description

Fields

Public MeshHeader: TMD3MeshHeader;

This item has no description.

Public Skins: array of TMD3Skin;

This item has no description.

Public Triangles: array of TMD3Face;

This item has no description.

Public TexCoords: array of TMD3TexCoord;

This item has no description.

Public Vertices: array of TMD3Triangle;


GLSysHelp v.2.5: Formats.MD3: Class TFileMD3

Class TFileMD3

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.MD3

Declaration

type TFileMD3 = class(TObject)

Description

MD3 Main file class

Hierarchy

  • TObject
  • TFileMD3

Overview

Fields

Public | ModelHeader: TMD3Header;
Public | Bones: array of TMD3Bone;
Public | Tags: array of TMD3Tag;
Public | MeshData: array of TMD3MeshData;

Methods

Public procedure LoadFromStream(aStream: TStream);

Description

Fields

Public ModelHeader: TMD3Header;

This item has no description.

Public Bones: array of TMD3Bone;

This item has no description.

Public Tags: array of TMD3Tag;

This item has no description.

Public MeshData: array of TMD3MeshData;

This item has no description.

Methods

Public procedure LoadFromStream(aStream: TStream);


GLSysHelp v.2.5: Formats.OCT

Unit Formats.OCT

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.VectorLists

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TOCTHeader |
Record TOCTVertex |
Record TOCTFace |
Record TOCTTexture |
Record TOCTLightmap |
Record TOCTLight |
Class TOCTFile |

Types

POCTFace = ˆTOCTFace;
POCTLightmap = ˆTOCTLightmap;

Description

Types

POCTFace = ˆTOCTFace;

This item has no description.

POCTLightmap = ˆTOCTLightmap;


GLSysHelp v.2.5: Formats.OCT: Record TOCTHeader

Record TOCTHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.OCT

Declaration

type TOCTHeader = record

Description

This item has no description.

Overview

Fields

Public | numVerts: Integer;
Public | numFaces: Integer;
Public | numTextures: Integer;
Public | numLightmaps: Integer;
Public | numLights: Integer;

Description

Fields

Public numVerts: Integer;

This item has no description.

Public numFaces: Integer;

This item has no description.

Public numTextures: Integer;

This item has no description.

Public numLightmaps: Integer;

This item has no description.

Public numLights: Integer;


GLSysHelp v.2.5: Formats.OCT: Record TOCTVertex

Record TOCTVertex

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.OCT

Declaration

type TOCTVertex = record

Description

This item has no description.

Overview

Fields

Public | tv: TTexPoint;
Public | lv: TTexPoint;
Public | pos: TAffineVector;

Description

Fields

Public tv: TTexPoint;

This item has no description.

Public lv: TTexPoint;

texture coordinates

Public pos: TAffineVector;

lightmap coordinates


GLSysHelp v.2.5: Formats.OCT: Record TOCTFace

Record TOCTFace

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.OCT

Declaration

type TOCTFace = record

Description

This item has no description.

Overview

Fields

Public | start: Integer;
Public | num: Integer;
Public | id: Integer;
Public | lid: Integer;
Public | p: THmgPlane;

Description

Fields

Public start: Integer;

This item has no description.

Public num: Integer;

first face vert in vertex array

Public id: Integer;

number of verts in the face

Public lid: Integer;

texture index into the texture array

Public p: THmgPlane;

lightmap index into the lightmap array


GLSysHelp v.2.5: Formats.OCT: Record TOCTTexture

Record TOCTTexture

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.OCT

Declaration

type TOCTTexture = record

Description

This item has no description.

Overview

Fields

Public | id: Integer;
Public | Name: array [0 .. 63] of AnsiChar;

Description

Fields

Public id: Integer;

This item has no description.

Public Name: array [0 .. 63] of AnsiChar;

texture id


GLSysHelp v.2.5: Formats.OCT: Record TOCTLightmap

Record TOCTLightmap

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.OCT

Declaration

type TOCTLightmap = record

Description

This item has no description.

Overview

Fields

Public | id: Integer;
Public | map: array [0 .. 49151] of Byte;

Description

Fields

Public id: Integer;

This item has no description.

Public map: array [0 .. 49151] of Byte;

lightmaps id


GLSysHelp v.2.5: Formats.OCT: Record TOCTLight

Record TOCTLight

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.OCT

Declaration

type TOCTLight = record

Description

This item has no description.

Overview

Fields

Public | pos: TAffineVector;
Public | color: TAffineVector;
Public | intensity: Integer;

Description

Fields

Public pos: TAffineVector;

This item has no description.

Public color: TAffineVector;

Position

Public intensity: Integer;

Color (RGB)


GLSysHelp v.2.5: Formats.OCT: Class TOCTFile

Class TOCTFile

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.OCT

Declaration

type TOCTFile = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TOCTFile

Overview

Fields

Public | Header: TOCTHeader;
Public | Vertices: array of TOCTVertex;
Public | Faces: array of TOCTFace;
Public | Textures: array of TOCTTexture;
Public | Lightmaps: array of TOCTLightmap;
Public | Lights: array of TOCTLight;
Public | PlayerPos: TAffineVector;

Methods

Public | constructor Create(octStream: TStream); overload;
Public | constructor Create; overload;
Public | procedure AddLight(const lightPos: TAffineVector; const lightColor: TGLVector; lightIntensity: Integer);
Public | procedure AddTriangles(vertexCoords: TGLAffineVectorList; texMapCoords: TGLAffineVectorList; const textureName: String);
Public | procedure SaveToStream(aStream: TStream);

Description

Fields

Public Header: TOCTHeader;

This item has no description.

Public Vertices: array of TOCTVertex;

This item has no description.

Public Faces: array of TOCTFace;

This item has no description.

Public Textures: array of TOCTTexture;

This item has no description.

Public Lightmaps: array of TOCTLightmap;

This item has no description.

Public Lights: array of TOCTLight;

This item has no description.

Public PlayerPos: TAffineVector;

This item has no description.

Methods

Public constructor Create(octStream: TStream); overload;

This item has no description.

Public constructor Create; overload;

This item has no description.

Public procedure AddLight(const lightPos: TAffineVector; const lightColor: TGLVector; lightIntensity: Integer);

This item has no description.

Public procedure AddTriangles(vertexCoords: TGLAffineVectorList; texMapCoords: TGLAffineVectorList; const textureName: String);

This item has no description.

Public procedure SaveToStream(aStream: TStream);

Saves content to stream in OCT format. The Header is automatically prepared before streaming.


GLSysHelp v.2.5: Formats.Q3BSP

Unit Formats.Q3BSP

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TBSPHeader |
Record TBSPLump |
Record TBSPNode |
Record TBSPLeaf |
Record TBSPModel |
Record TBSPVertex |
Record TBSPFace |
Record TBSPTexture |
Record TBSPLightmap |
Record TBSPVisData |
Class TQ3BSP |

Types

PBSPFace = ˆTBSPFace;
PBSPLightmap = ˆTBSPLightmap;
PBSPTexture = ˆTBSPTexture;
PBSPVertex = ˆTBSPVertex;
TBSPBBox = array [0 .. 5] of Integer;

Constants

FACE_POLYGON = 1;
MAX_TEXTURES = 1000;
kEntities = 0;
kTextures = 1;
kPlanes = 2;
kNodes = 3;
kLeafs = 4;
kLeafFaces = 5;
kLeafBrushes = 6;
kModels = 7;
kBrushes = 8;
kBrushSides = 9;
kVertices = 10;
kMeshVerts = 11;
kShaders = 12;
kFaces = 13;
kLightmaps = 14;
kLightVolumes = 15;
kVisData = 16;
kMaxLumps = 17;

Description

Types

PBSPFace = ˆTBSPFace;

This item has no description.

PBSPLightmap = ˆTBSPLightmap;

This item has no description.

PBSPTexture = ˆTBSPTexture;

This item has no description.

PBSPVertex = ˆTBSPVertex;

This item has no description.

TBSPBBox = array [0 .. 5] of Integer;

This item has no description.

Constants

FACE_POLYGON = 1;

This item has no description.

MAX_TEXTURES = 1000;

This item has no description.

kEntities = 0;

This item has no description.

kTextures = 1;

Stores player/object positions, etc...

kPlanes = 2;

Stores texture information

kNodes = 3;

Stores the splitting planes

kLeafs = 4;

Stores the BSP nodes

kLeafFaces = 5;

Stores the leafs of the nodes

kLeafBrushes = 6;

Stores the leaf's indices into the faces

kModels = 7;

Stores the leaf's indices into the brushes

kBrushes = 8;

Stores the info of world models

kBrushSides = 9;

Stores the brushes info (for collision)

kVertices = 10;

Stores the brush surfaces info

kMeshVerts = 11;

Stores the level vertices

kShaders = 12;

Stores the model vertices offsets

kFaces = 13;

Stores the shader files (blending, anims..)

kLightmaps = 14;

Stores the faces for the level

kLightVolumes = 15;

Stores the lightmaps for the level

kVisData = 16;

Stores extra world lighting information

kMaxLumps = 17;

Stores PVS and cluster info (visibility)


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPHeader

Record TBSPHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPHeader = record

Description

This item has no description.

Overview

Fields

Public | StrID: array [0 .. 3] of AnsiChar;
Public | Version: Integer;

Description

Fields

Public StrID: array [0 .. 3] of AnsiChar;

This item has no description.

Public Version: Integer;

This should always be 'IBSP'


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPLump

Record TBSPLump

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPLump = record

Description

This item has no description.

Overview

Fields

Public | Offset: Integer;
Public | Length: Integer;

Description

Fields

Public Offset: Integer;

This item has no description.

Public Length: Integer;

The offset into the file for the start of this lump


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPNode

Record TBSPNode

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPNode = record

Description

This item has no description.

Overview

Fields

Public | Plane: Integer;
Public | Children: array [0 .. 1] of Integer;
Public | BBox: TBSPBBox;

Description

Fields

Public Plane: Integer;

This item has no description.

Public Children: array [0 .. 1] of Integer;

Space partitioning plane

Public BBox: TBSPBBox;

Back and front child nodes


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPLeaf

Record TBSPLeaf

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPLeaf = record

Description

This item has no description.

Overview

Fields

Public | Cluster: Integer;
Public | Area: Integer;
Public | BBox: TBSPBBox;
Public | FirstFace: Integer;
Public | NumFaces: Integer;
Public | FirstBrush: Integer;
Public | NumBrushes: Integer;

Description

Fields

Public Cluster: Integer;

This item has no description.

Public Area: Integer;

Visibility cluster number

Public BBox: TBSPBBox;

Volume of the leaf

Public FirstFace: Integer;

Bounding box of leaf

Public NumFaces: Integer;

Bounding box of leaf

Public FirstBrush: Integer;

Lookup for the face list (indexes are for faces)

Public NumBrushes: Integer;

Lookup for the face list (indexes are for faces)


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPModel

Record TBSPModel

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPModel = record

Description

This item has no description.

Overview

Fields

Public | BBox: TBSPBBox;
Public | FirstFace: Integer;
Public | NumFaces: Integer;
Public | FirstBrush: Integer;
Public | NumBrushes: Integer;

Description

Fields

Public BBox: TBSPBBox;

This item has no description.

Public FirstFace: Integer;

Bounding box of model

Public NumFaces: Integer;

Bounding box of model

Public FirstBrush: Integer;

Lookup for the face list (indexes are for faces)

Public NumBrushes: Integer;

Lookup for the face list (indexes are for faces)


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPVertex

Record TBSPVertex

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPVertex = record

Description

This item has no description.

Overview

Fields

Public | Position: TVector3f;
Public | TextureCoord: TVector2f;
Public | LightmapCoord: TVector2f;
Public | Normal: TVector3f;
Public | Color: array [0 .. 3] of Byte

Description

Fields

Public Position: TVector3f;

This item has no description.

Public TextureCoord: TVector2f;

(x, y, z) position.

Public LightmapCoord: TVector2f;

(u, v) texture coordinate

Public Normal: TVector3f;

(u, v) lightmap coordinate

Public Color: array [0 .. 3] of Byte

(x, y, z) normal vector


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPFace

Record TBSPFace

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPFace = record

Description

This item has no description.

Overview

Fields

Public | textureID: Integer;
Public | effect: Integer;
Public | FaceType: Integer;
Public | startVertIndex: Integer;
Public | numOfVerts: Integer;
Public | meshVertIndex: Integer;
Public | numMeshVerts: Integer;
Public | lightmapID: Integer;
Public | lMapCorner: array [0 .. 1] of Integer;
Public | lMapSize: array [0 .. 1] of Integer;
Public | lMapPos: TVector3f;
Public | lMapVecs: array [0 .. 1] of TVector3f;
Public | vNormal: TVector3f;
Public | Size: array [0 .. 1] of Integer;

Description

Fields

Public textureID: Integer;

This item has no description.

Public effect: Integer;

The index into the texture array

Public FaceType: Integer;

The index for the effects (or -1 = n/a)

Public startVertIndex: Integer;

1=polygon, 2=patch, 3=mesh, 4=billboard

Public numOfVerts: Integer;

The starting index into this face's first vertex

Public meshVertIndex: Integer;

The number of vertices for this face

Public numMeshVerts: Integer;

The index into the first meshvertex

Public lightmapID: Integer;

The number of mesh vertices

Public lMapCorner: array [0 .. 1] of Integer;

The texture index for the lightmap

Public lMapSize: array [0 .. 1] of Integer;

The face's lightmap corner in the image

Public lMapPos: TVector3f;

The size of the lightmap section

Public lMapVecs: array [0 .. 1] of TVector3f;

The 3D origin of lightmap.

Public vNormal: TVector3f;

The 3D space for s and t unit vectors.

Public Size: array [0 .. 1] of Integer;

The face normal.


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPTexture

Record TBSPTexture

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPTexture = record

Description

This item has no description.

Overview

Fields

Public | TextureName: array [0 .. 63] of WideChar;
Public | flags: Integer;
Public | contents: Integer;

Description

Fields

Public TextureName: array [0 .. 63] of WideChar;

This item has no description.

Public flags: Integer;

The name of the texture w/o the extension

Public contents: Integer;

The surface flags (unknown)


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPLightmap

Record TBSPLightmap

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPLightmap = record

Description

This item has no description.

Overview

Fields

Public imageBits: array [0 .. 49151] of Byte;

Description

Fields

Public imageBits: array [0 .. 49151] of Byte;


GLSysHelp v.2.5: Formats.Q3BSP: Record TBSPVisData

Record TBSPVisData

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TBSPVisData = record

Description

This item has no description.

Overview

Fields

Public | numOfClusters: Integer;
Public | bytesPerCluster: Integer;
Public | bitSets: array of Byte;

Description

Fields

Public numOfClusters: Integer;

This item has no description.

Public bytesPerCluster: Integer;

This item has no description.

Public bitSets: array of Byte;


GLSysHelp v.2.5: Formats.Q3BSP: Class TQ3BSP

Class TQ3BSP

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.Q3BSP

Declaration

type TQ3BSP = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TQ3BSP

Overview

Fields

Public | Header: TBSPHeader;
Public | Lumps: array of TBSPLump;
Public | numOfVerts: Integer;
Public | NumOfNodes: Integer;
Public | NumOfPlanes: Integer;
Public | NumOfLeaves: Integer;
Public | NumOfFaces: Integer;
Public | NumOfTextures: Integer;
Public | NumOfLightmaps: Integer;
Public | Vertices: array of TBSPVertex;
Public | Nodes: array of TBSPNode;
Public | Planes: array of TVector4f;
Public | Leaves: array of TBSPLeaf;
Public | Faces: array of TBSPFace;
Public | Textures: array of TBSPTexture;
Public | Lightmaps: array of TBSPLightmap;
Public | VisData: TBSPVisData;

Methods

Public constructor Create(bspStream: TStream);

Description

Fields

Public Header: TBSPHeader;

This item has no description.

Public Lumps: array of TBSPLump;

This item has no description.

Public numOfVerts: Integer;

This item has no description.

Public NumOfNodes: Integer;

This item has no description.

Public NumOfPlanes: Integer;

This item has no description.

Public NumOfLeaves: Integer;

This item has no description.

Public NumOfFaces: Integer;

This item has no description.

Public NumOfTextures: Integer;

This item has no description.

Public NumOfLightmaps: Integer;

This item has no description.

Public Vertices: array of TBSPVertex;

This item has no description.

Public Nodes: array of TBSPNode;

This item has no description.

Public Planes: array of TVector4f;

This item has no description.

Public Leaves: array of TBSPLeaf;

This item has no description.

Public Faces: array of TBSPFace;

This item has no description.

Public Textures: array of TBSPTexture;

This item has no description.

Public Lightmaps: array of TBSPLightmap;

texture names (without extension)

Public VisData: TBSPVisData;

This item has no description.

Methods

Public constructor Create(bspStream: TStream);


GLSysHelp v.2.5: Formats.TGA

Unit Formats.TGA

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.Context
  • GLS.Graphics
  • GLS.ApplicationFileIO
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTGAImage |


GLSysHelp v.2.5: Formats.TGA: Class TGLTGAImage

Class TGLTGAImage

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.TGA

Declaration

type TGLTGAImage = class(TGLBaseImage)

Description

This item has no description. Showing description inherited from TGLDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage
  • TGLTGAImage

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;

This item has no description.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;


GLSysHelp v.2.5: Formats.VFW

Unit Formats.VFW

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.MMSystem
  • Winapi.Messages
  • Winapi.CommDlg
  • Winapi.ActiveX

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TICOPEN |
Packed Record TICINFO |
Packed Record TICCOMPRESS |
Packed Record TICCOMPRESSFRAMES |
Packed Record TICSETSTATUSPROC |
Packed Record TICDECOMPRESS |
Packed Record TICDECOMPRESSEX |
Packed Record TICDRAWBEGIN |
Packed Record TICDRAW |
Packed Record TICDRAWSUGGEST |
Packed Record TICPALETTE |
Packed Record TCOMPVARS |
Packed Record TDRAWDIBTIME |
Packed Record TMainAVIHeader |
Packed Record TAVIStreamHeader |
Packed Record TAVIINDEXENTRY |
Packed Record TAVIPALCHANGE |
Packed Record TAVIStreamInfoW |
Packed Record TAVIStreamInfoA |
Packed Record TAVIFileInfoW |
Packed Record TAVIFileInfoA |
Packed Record TAVICOMPRESSOPTIONS |
Interface IAVIStream |
Interface IAVIStreaming |
Interface IAVIEditStream |
Interface IAVIFile |
Interface IGetFrame |
Record TVIDEOHDR |
Record TCHANNEL_CAPS |
Record TCAPDRIVERCAPS |
Record TCAPSTATUS |
Record TCAPTUREPARMS |
Record TCAPINFOCHUNK |

Functions and Procedures

function VideoForWindowsVersion: DWORD; pascal;
function MKFOURCC(ch0, ch1, ch2, ch3: AnsiChar): FOURCC;
function mmioFOURCC(ch0, ch1, ch2, ch3: AnsiChar): FOURCC;
function aviTWOCC(ch0, ch1: AnsiChar): TWOCC;
function ICInfo(fccType, fccHandler: DWORD; lpicinfo: PICINFO) : BOOL ; stdcall;
function ICInstall(fccType, fccHandler: DWORD; lParam: LPARAM; szDesc: LPSTR; wFlags: UINT) : BOOL ; stdcall;
function ICRemove(fccType, fccHandler: DWORD; wFlags: UINT) : BOOL ; stdcall;
function ICGetInfo(hic: HIC; picinfo: PICINFO; cb: DWORD) : DWORD ; stdcall;
function ICOpen(fccType, fccHandler: DWORD; wMode: UINT) : HIC ; stdcall;
function ICOpenFunction(fccType, fccHandler: DWORD; wMode: UINT; lpfnHandler: TFarProc) : HIC ; stdcall;
function ICClose(hic: HIC) : DWORD; stdcall;
function ICSendMessage(hic: HIC; msg: UINT; dw1, dw2: DWORD) : DWORD ; stdcall;
function ICQueryAbout(hic: HIC): BOOL;
function ICAbout(hic: HIC; hwnd: HWND): DWORD;
function ICQueryConfigure(hic: HIC): BOOL;
function ICConfigure(hic: HIC; hwnd: HWND): DWORD;
function ICGetState(hic: HIC; pv: PVOID; cb: DWORD): DWORD;
function ICSetState(hic: HIC; pv: PVOID; cb: DWORD): DWORD;
function ICGetStateSize(hic: HIC): DWORD;
function ICGetDefaultQuality(hic: HIC): DWORD;
function ICGetDefaultKeyFrameRate(hic: HIC): DWORD;
function ICDrawWindow(hic: HIC; prc: PRECT): DWORD;
function ICCompress( hic : HIC; dwFlags : DWORD; lpbiOutput : PBITMAPINFOHEADER; lpData : PVOID; lpbiInput : PBITMAPINFOHEADER; lpBits : PVOID; lpckid : PDWORD; lpdwFlags : PDWORD; lFrameNum : DWORD; dwFrameSize : DWORD; dwQuality : DWORD; lpbiPrev : PBITMAPINFOHEADER; lpPrev : PVOID ): DWORD; cdecl;
function ICCompressBegin(hic: HIC; lpbiInput: PBITMAPINFOHEADER; lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressQuery(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressGetFormat(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressGetFormatSize(hic: HIC; lpbi: PBITMAPINFOHEADER): DWORD;
function ICCompressGetSize(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressEnd(hic: HIC): DWORD;
function ICDecompress( hic : HIC; dwFlags : DWORD; lpbiFormat : PBITMAPINFOHEADER; lpData : PVOID; lpbi : PBITMAPINFOHEADER; lpBits : PVOID ): DWORD; cdecl;
function ICDecompressBegin(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressQuery(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetFormat(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetFormatSize(hic: HIC; lpbi: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetPalette(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressSetPalette(hic: HIC; lpbiPalette: PBITMAPINFOHEADER): DWORD;
function ICDecompressEnd(hic: HIC): DWORD;
function ICDecompressEx( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExBegin( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExQuery( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExEnd(hic: HIC): DWORD;
function ICDrawBegin( hic : HIC; dwFlags : DWORD; hpal : HPALETTE; hwnd : HWND; hdc : HDC; xDst : int; yDst : int; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; dwRate : DWORD; dwScale : DWORD ): DWORD; cdecl;
function ICDraw( hic : HIC; dwFlags : DWORD; lpFormat : PVOID; lpData : PVOID; cbData : DWORD; lTime : DWORD ): DWORD; cdecl;
function ICDrawSuggestFormat( hic : HIC; lpbiIn : PBITMAPINFOHEADER; lpbiOut : PBITMAPINFOHEADER; dxSrc : int; dySrc : int; dxDst : int; dyDst : int; hicDecomp : HIC ): DWORD; stdcall;
function ICDrawQuery(hic: HIC; lpbiInput: PBITMAPINFOHEADER): DWORD;
function ICDrawChangePalette(hic: HIC; lpbiInput: PBITMAPINFOHEADER): DWORD;
function ICGetBuffersWanted(hic: HIC; lpdwBuffers: PDWORD): DWORD;
function ICDrawEnd(hic: HIC): DWORD;
function ICDrawStart(hic: HIC): DWORD;
function ICDrawStartPlay(hic: HIC; lFrom, lTo: DWORD): DWORD;
function ICDrawStop(hic: HIC): DWORD;
function ICDrawStopPlay(hic: HIC): DWORD;
function ICDrawGetTime(hic: HIC; lplTime: PDWORD): DWORD;
function ICDrawSetTime(hic: HIC; lTime: DWORD): DWORD;
function ICDrawRealize(hic: HIC; hdc: HDC; fBackground: BOOL): DWORD;
function ICDrawFlush(hic: HIC): DWORD;
function ICDrawRenderBuffer(hic: HIC): DWORD;
function ICSetStatusProc( hic : HIC; dwFlags : DWORD; lParam : DWORD; fpfnStatus : TICStatusProc ): DWORD; stdcall;
function ICLocate(fccType, fccHandler: DWORD; lpbiIn, lpbiOut: PBITMAPINFOHEADER; wFlags: WORD): HIC; stdcall;
function ICGetDisplayFormat(hic: HIC; lpbiIn, lpbiOut: PBITMAPINFOHEADER; BitDepth: int; dx, dy: int): HIC; stdcall;
function ICDecompressOpen(fccType, fccHandler: DWORD; lpbiIn, lpbiOut: PBITMAPINFOHEADER): HIC;
function ICDrawOpen(fccType, fccHandler: DWORD; lpbiIn: PBITMAPINFOHEADER): HIC;
function ICImageCompress( hic : HIC; uiFlags : UINT; lpbiIn : PBITMAPINFO; lpBits : PVOID; lpbiOut : PBITMAPINFO; lQuality : LONG; plSize : PDWORD ): THANDLE; stdcall;
function ICImageDecompress( hic : HIC; uiFlags : UINT; lpbiIn : PBITMAPINFO; lpBits : PVOID; lpbiOut : PBITMAPINFO ): THANDLE; stdcall;
function ICCompressorChoose( hwnd : HWND; uiFlags : UINT; pvIn : PVOID; lpData : PVOID; pc : PCOMPVARS; lpszTitle : LPSTR ): BOOL; stdcall;
function ICSeqCompressFrameStart(pc: PCOMPVARS; lpbiIn: PBITMAPINFO): BOOL; stdcall;
procedure ICSeqCompressFrameEnd(pc: PCOMPVARS); stdcall;
function ICSeqCompressFrame( pc : PCOMPVARS; uiFlags : UINT; lpBits : PVOID; pfKey : PBOOL; plSize : PDWORD ): PVOID; stdcall;
procedure ICCompressorFree(pc: PCOMPVARS); stdcall;
function DrawDibOpen: HDRAWDIB; stdcall;
function DrawDibClose(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibGetBuffer(hdd: HDRAWDIB; lpbi: PBITMAPINFOHEADER; dwSize: DWORD; dwFlags: DWORD): PVOID; stdcall;
function DrawDibGetPalette(hdd: HDRAWDIB): HPALETTE; stdcall;
function DrawDibSetPalette(hdd: HDRAWDIB; hpal: HPALETTE): BOOL; stdcall;
function DrawDibChangePalette(hdd: HDRAWDIB; iStart, iLen: int; lppe: PPALETTEENTRY): BOOL; stdcall;
function DrawDibRealize(hdd: HDRAWDIB; hdc: HDC; fBackground: BOOL): UINT; stdcall;
function DrawDibStart(hdd: HDRAWDIB; rate: DWORD): BOOL; stdcall;
function DrawDibStop(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibBegin( hdd : HDRAWDIB; hdc : HDC; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; dxSrc : int; dySrc : int; wFlags : UINT ): BOOL; stdcall;
function DrawDibDraw( hdd : HDRAWDIB; hdc : HDC; xDst : int; yDst : int; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; lpBits : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; wFlags : UINT ): BOOL; stdcall;
function DrawDibUpdate(hdd: HDRAWDIB; hdc: HDC; x, y: int): BOOL;
function DrawDibEnd(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibTime(hdd: HDRAWDIB; lpddtime: PDRAWDIBTIME): BOOL; stdcall;
function DrawDibProfileDisplay(lpbi: PBITMAPINFOHEADER): DWORD; stdcall;
function FromHex(n: BYTE): BYTE;
function StreamFromFOURCC(fcc: DWORD): BYTE;
function TWOCCFromFOURCC(fcc: DWORD): WORD;
function ToHex(n: BYTE): BYTE;
function MAKEAVICKID(tcc: WORD; stream: BYTE): DWORD;
procedure AVIFileInit; stdcall;
procedure AVIFileExit; stdcall;
function AVIFileAddRef(pfile: IAVIFile): ULONG; stdcall;
function AVIFileRelease(pfile: IAVIFile): ULONG; stdcall;
function AVIFileOpenA(var ppfile: IAVIFile; szFile: LPCSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileOpenW(var ppfile: IAVIFile; szFile: LPCWSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileOpen(var ppfile: IAVIFile; szFile: LPCSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileInfoW(pfile: IAVIFile; var pfi: TAVIFILEINFOW; lSize: LONG): HResult; stdcall;
function AVIFileInfoA(pfile: IAVIFile; var pfi: TAVIFILEINFOA; lSize: LONG): HResult; stdcall;
function AVIFileInfo(pfile: IAVIFile; var pfi: TAVIFILEINFO; lSize: LONG): HResult; stdcall;
function AVIFileGetStream(pfile: IAVIFile; var ppavi: IAVISTREAM; fccType: DWORD; lParam: LONG): HResult; stdcall;
function AVIFileCreateStreamW(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFOW): HResult; stdcall;
function AVIFileCreateStreamA(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFOA): HResult; stdcall;
function AVIFileCreateStream(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFO): HResult; stdcall;
function AVIFileWriteData(pfile: IAVIFile; ckid: DWORD; lpData: PVOID; cbData: LONG): HResult; stdcall;
function AVIFileReadData(pfile: IAVIFile; ckid: DWORD; lpData: PVOID; var lpcbData: LONG): HResult; stdcall;
function AVIFileEndRecord(pfile: IAVIFile): HResult; stdcall;
function AVIStreamAddRef(pavi: IAVIStream): ULONG; stdcall;
function AVIStreamRelease(pavi: IAVIStream): ULONG; stdcall;
function AVIStreamInfoW(pavi: IAVIStream; var psi: TAVISTREAMINFOW; lSize: LONG): HResult; stdcall;
function AVIStreamInfoA(pavi: IAVIStream; var psi: TAVISTREAMINFOA; lSize: LONG): HResult; stdcall;
function AVIStreamInfo(pavi: IAVIStream; var psi: TAVISTREAMINFO; lSize: LONG): HResult; stdcall;
function AVIStreamFindSample(pavi: IAVIStream; lPos: LONG; lFlags: LONG): LONG; stdcall;
function AVIStreamReadFormat(pavi: IAVIStream; lPos: LONG; lpFormat: PVOID; lpcbFormat: PLONG): HResult; stdcall;
function AVIStreamSetFormat(pavi: IAVIStream; lPos: LONG; lpFormat: PVOID; cbFormat: LONG): HResult; stdcall;
function AVIStreamReadData(pavi: IAVIStream; fcc: DWORD; lp: PVOID; lpcb: PLONG): HResult; stdcall;
function AVIStreamWriteData(pavi: IAVIStream; fcc: DWORD; lp: PVOID; cb: LONG): HResult; stdcall;
function AVIStreamRead( pavi : IAVISTREAM; lStart : LONG; lSamples : LONG; lpBuffer : PVOID; cbBuffer : LONG; plBytes : PLONG; plSamples : PLONG ): HResult; stdcall;
function AVIStreamWrite( pavi : IAVISTREAM; lStart : LONG; lSamples : LONG; lpBuffer : PVOID; cbBuffer : LONG; dwFlags : DWORD; plSampWritten : PLONG; plBytesWritten : PLONG ): HResult; stdcall;
function AVIStreamStart(pavi: IAVIStream): LONG; stdcall;
function AVIStreamLength(pavi: IAVIStream): LONG; stdcall;
function AVIStreamTimeToSample(pavi: IAVIStream; lTime: LONG): LONG; stdcall;
function AVIStreamSampleToTime(pavi: IAVIStream; lSample: LONG): LONG; stdcall;
function AVIStreamBeginStreaming(pavi: IAVIStream; lStart, lEnd: LONG; lRate: LONG): HResult; stdcall;
function AVIStreamEndStreaming(pavi: IAVIStream): HResult; stdcall;
function AVIStreamGetFrameOpen(pavi: IAVIStream; lpbiWanted: PBitmapInfoHeader): IGetFrame; stdcall;
function AVIStreamGetFrame(pg: IGetFrame; lPos: LONG): PBitmapInfoHeader; stdcall;
function AVIStreamGetFrameClose(pg: IGetFrame): HResult; stdcall;
function AVIStreamOpenFromFileA(var ppavi: IAVISTREAM; szFile: LPCSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamOpenFromFileW(var ppavi: IAVISTREAM; szFile: LPCWSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamOpenFromFile(var ppavi: IAVISTREAM; szFile: LPCSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamCreate(var ppavi: IAVISTREAM; lParam1, lParam2: LONG; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamFindKeyFrame(var pavi: IAVISTREAM; lPos: LONG; lFlags: LONG): DWORD; stdcall;
function AVIStreamClose(pavi: IAVISTREAM): ULONG; stdcall;
function AVIFileClose(pfile: IAVIFILE): ULONG; stdcall;
procedure AVIStreamInit; stdcall;
procedure AVIStreamExit; stdcall;
function AVIStreamSampleToSample(pavi1, pavi2: IAVISTREAM; l: LONG): LONG;
function AVIStreamNextSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamPrevSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNearestSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNextKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamPrevKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNearestKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamIsKeyFrame(pavi: IAVISTREAM; l: LONG): BOOL;
function AVIStreamPrevSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNextSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNearestSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNextKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamPrevKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNearestKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamStartTime(pavi: IAVISTREAM): LONG;
function AVIStreamLengthTime(pavi: IAVISTREAM): LONG;
function AVIStreamEnd(pavi: IAVISTREAM): LONG;
function AVIStreamEndTime(pavi: IAVISTREAM): LONG;
function AVIStreamSampleSize(pavi: IAVISTREAM; lPos: LONG; plSize: PLONG): LONG;
function AVIStreamFormatSize(pavi: IAVISTREAM; lPos: LONG; plSize: PLONG): HResult;
function AVIStreamDataSize(pavi: IAVISTREAM; fcc: DWORD; plSize: PLONG): HResult;
function AVIMakeCompressedStream( var ppsCompressed : IAVISTREAM; ppsSource : IAVISTREAM; lpOptions : PAVICOMPRESSOPTIONS; pclsidHandler : PCLSID ): HResult; stdcall;
function AVISaveVA( szFile : LPCSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveVW( szFile : LPCWSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveV( szFile : LPCSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveOptions( hwnd : HWND; uiFlags : UINT; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): BOOL; stdcall;
function AVISaveOptionsFree(nStreams: int; var plpOptions: PAVICOMPRESSOPTIONS): HResult; stdcall;
function AVIBuildFilterW(lpszFilter: LPWSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIBuildFilterA(lpszFilter: LPSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIBuildFilter(lpszFilter: LPSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIMakeFileFromStreams(var ppfile: IAVIFILE; nStreams: int; var papStreams: IAVISTREAM): HResult; stdcall;
function AVIMakeStreamFromClipboard(cfFormat: UINT; hGlobal: THANDLE; var ppstream: IAVISTREAM): HResult; stdcall;
function AVIPutFileOnClipboard(pf: IAVIFILE): HResult; stdcall;
function AVIGetFromClipboard(var lppf: IAVIFILE): HResult; stdcall;
function AVIClearClipboard: HResult; stdcall;
function CreateEditableStream(var ppsEditable: IAVISTREAM; psSource: IAVISTREAM): HResult; stdcall;
function EditStreamCut(pavi: IAVISTREAM; var plStart, plLength: LONG; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamCopy(pavi: IAVISTREAM; var plStart, plLength: LONG; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamPaste(pavi: IAVISTREAM; var plPos, plLength: LONG; pstream: IAVISTREAM; lStart, lEnd: LONG): HResult; stdcall;
function EditStreamClone(pavi: IAVISTREAM; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamSetNameA(pavi: IAVISTREAM; lpszName: LPCSTR): HResult; stdcall;
function EditStreamSetNameW(pavi: IAVISTREAM; lpszName: LPCWSTR): HResult; stdcall;
function EditStreamSetInfoW(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOW; cbInfo: LONG): HResult; stdcall;
function EditStreamSetInfoA(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOA; cbInfo: LONG): HResult; stdcall;
function EditStreamSetInfo(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOA; cbInfo: LONG): HResult; stdcall;
function EditStreamSetName(pavi: IAVISTREAM; lpszName: LPCSTR): HResult; stdcall;
function MCIWndSM(hWnd: HWND; Msg: UINT; wParam: WPARAM; lParam: LPARAM): DWORD;
function MCIWndCreateA(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCSTR): HWND; cdecl;
function MCIWndCreateW(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCWSTR): HWND; cdecl;
function MCIWndCreate(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCSTR): HWND; cdecl;
function MCIWndRegisterClass: BOOL; cdecl;
function MCIWndCanPlay(hwnd: HWND): BOOL;
function MCIWndCanRecord(hwnd: HWND): BOOL;
function MCIWndCanSave(hwnd: HWND): BOOL;
function MCIWndCanWindow(hwnd: HWND): BOOL;
function MCIWndCanEject(hwnd: HWND): BOOL;
function MCIWndCanConfig(hwnd: HWND): BOOL;
function MCIWndPaletteKick(hwnd: HWND): BOOL;
function MCIWndSave(hwnd: HWND; szFile: LPCSTR): DWORD;
function MCIWndSaveDialog(hwnd: HWND): DWORD;
function MCIWndNew(hwnd: HWND; lp: PVOID): DWORD;
function MCIWndRecord(hwnd: HWND): DWORD;
function MCIWndOpen(hwnd: HWND; sz: LPCSTR; f: BOOL): DWORD;
function MCIWndOpenDialog(hwnd: HWND): DWORD;
function MCIWndClose(hwnd: HWND): DWORD;
function MCIWndPlay(hwnd: HWND): DWORD;
function MCIWndStop(hwnd: HWND): DWORD;
function MCIWndPause(hwnd: HWND): DWORD;
function MCIWndResume(hwnd: HWND): DWORD;
function MCIWndSeek(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndEject(hwnd: HWND): DWORD;
function MCIWndHome(hwnd: HWND): DWORD;
function MCIWndEnd(hwnd: HWND): DWORD;
function MCIWndGetSource(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPutSource(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndGetDest(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPutDest(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPlayReverse(hwnd: HWND): DWORD;
function MCIWndPlayFrom(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndPlayTo(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndPlayFromTo(hwnd: HWND; lStart, lEnd: DWORD): DWORD;
function MCIWndGetDeviceID(hwnd: HWND): UINT;
function MCIWndGetAlias(hwnd: HWND): UINT;
function MCIWndGetMode(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetPosition(hwnd: HWND): DWORD;
function MCIWndGetPositionString(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetStart(hwnd: HWND): DWORD;
function MCIWndGetLength(hwnd: HWND): DWORD;
function MCIWndGetEnd(hwnd: HWND): DWORD;
function MCIWndStep(hwnd: HWND; n: DWORD): DWORD;
procedure MCIWndDestroy(hwnd: HWND);
procedure MCIWndSetZoom(hwnd: HWND; iZoom: UINT);
function MCIWndGetZoom(hwnd: HWND): UINT;
function MCIWndSetVolume(hwnd: HWND; iVol: UINT): DWORD;
function MCIWndGetVolume(hwnd: HWND): DWORD;
function MCIWndSetSpeed(hwnd: HWND; iSpeed: UINT): DWORD;
function MCIWndGetSpeed(hwnd: HWND): DWORD;
function MCIWndSetTimeFormat(hwnd: HWND; lp: LPCSTR): DWORD;
function MCIWndGetTimeFormat(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
procedure MCIWndValidateMedia(hwnd: HWND);
procedure MCIWndSetRepeat(hwnd: HWND; f: BOOL);
function MCIWndGetRepeat(hwnd: HWND): BOOL;
function MCIWndUseFrames(hwnd: HWND): DWORD;
function MCIWndUseTime(hwnd: HWND): DWORD;
procedure MCIWndSetActiveTimer(hwnd: HWND; active: UINT);
procedure MCIWndSetInactiveTimer(hwnd: HWND; inactive: UINT);
procedure MCIWndSetTimers(hwnd: HWND; active, inactive: UINT);
function MCIWndGetActiveTimer(hwnd: HWND): UINT;
function MCIWndGetInactiveTimer(hwnd: HWND): UINT;
function MCIWndRealize(hwnd: HWND; fBkgnd: BOOL): DWORD;
function MCIWndSendString(hwnd: HWND; sz: LPCSTR): DWORD;
function MCIWndReturnString(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetError(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetPalette(hwnd: HWND): HPALETTE;
function MCIWndSetPalette(hwnd: HWND; hpal: HPALETTE): DWORD;
function MCIWndGetFileName(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetDevice(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetStyles(hwnd: HWND): UINT;
function MCIWndChangeStyles(hwnd: HWND; mask: UINT; value: DWORD): DWORD;
function MCIWndOpenInterface(hwnd: HWND; pUnk: PUnknown): DWORD;
function MCIWndSetOwner(hwnd: HWND; hwndP: HWND): DWORD;
function AVICapSM(hwnd: HWND; m: UINT; w: WPARAM; l: LPARAM): DWORD;
function capSetCallbackOnError(hwnd: HWND; fpProc: TCAPERRORCALLBACK): BOOL;
function capSetCallbackOnStatus(hwnd: HWND; fpProc: TCAPSTATUSCALLBACK): BOOL;
function capSetCallbackOnYield(hwnd: HWND; fpProc: TCAPYIELDCALLBACK): BOOL;
function capSetCallbackOnFrame(hwnd: HWND; fpProc: TCAPVIDEOCALLBACK): BOOL;
function capSetCallbackOnVideoStream(hwnd: HWND; fpProc: TCAPVIDEOCALLBACK): BOOL;
function capSetCallbackOnWaveStream(hwnd: HWND; fpProc: TCAPWAVECALLBACK): BOOL;
function capSetCallbackOnCapControl(hwnd: HWND; fpProc: TCAPCONTROLCALLBACK): BOOL;
function capSetUserData(hwnd: HWND; lUser: DWORD): BOOL;
function capGetUserData(hwnd: HWND): DWORD;
function capDriverConnect(hwnd: HWND; i: INT): BOOL;
function capDriverDisconnect(hwnd: HWND): BOOL;
function capDriverGetName(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capDriverGetVersion(hwnd: HWND; szVer: LPSTR; wSize: WORD): BOOL;
function capDriverGetCaps(hwnd: HWND; s: PCAPDRIVERCAPS; wSize: WORD): BOOL;
function capFileSetCaptureFile(hwnd: HWND; szName: LPCSTR): BOOL;
function capFileGetCaptureFile(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capFileAlloc(hwnd: HWND; dwSize: DWORD): BOOL;
function capFileSaveAs(hwnd: HWND; szName: LPCSTR): BOOL;
function capFileSetInfoChunk(hwnd: HWND; lpInfoChunk: PCAPINFOCHUNK): BOOL;
function capFileSaveDIB(hwnd: HWND; szName: LPCSTR): BOOL;
function capEditCopy(hwnd: HWND): BOOL;
function capSetAudioFormat(hwnd: HWND; s: PWAVEFORMATEX; wSize: WORD): BOOL;
function capGetAudioFormat(hwnd: HWND; s: PWAVEFORMATEX; wSize: WORD): DWORD;
function capGetAudioFormatSize(hwnd: HWND): DWORD;
function capDlgVideoFormat(hwnd: HWND): BOOL;
function capDlgVideoSource(hwnd: HWND): BOOL;
function capDlgVideoDisplay(hwnd: HWND): BOOL;
function capDlgVideoCompression(hwnd: HWND): BOOL;
function capGetVideoFormat(hwnd: HWND; s: PVOID; wSize: WORD): DWORD;
function capGetVideoFormatSize(hwnd: HWND): DWORD;
function capSetVideoFormat(hwnd: HWND; s: PVOID; wSize: WORD): BOOL;
function capPreview(hwnd: HWND; f: BOOL): BOOL;
function capPreviewRate(hwnd: HWND; wMS: WORD): BOOL;
function capOverlay(hwnd: HWND; f: BOOL): BOOL;
function capPreviewScale(hwnd: HWND; f: BOOL): BOOL;
function capGetStatus(hwnd: HWND; s: PCAPSTATUS; wSize: WORD): BOOL;
function capSetScrollPos(hwnd: HWND; lpP: PPOINT): BOOL;
function capGrabFrame(hwnd: HWND): BOOL;
function capGrabFrameNoStop(hwnd: HWND): BOOL;
function capCaptureSequence(hwnd: HWND): BOOL;
function capCaptureSequenceNoFile(hwnd: HWND): BOOL;
function capCaptureStop(hwnd: HWND): BOOL;
function capCaptureAbort(hwnd: HWND): BOOL;
function capCaptureSingleFrameOpen(hwnd: HWND): BOOL;
function capCaptureSingleFrameClose(hwnd: HWND): BOOL;
function capCaptureSingleFrame(hwnd: HWND): BOOL;
function capCaptureGetSetup(hwnd: HWND; s: PCAPTUREPARMS; wSize: WORD): BOOL;
function capCaptureSetSetup(hwnd: HWND; s: PCAPTUREPARMS; wSize: WORD): BOOL;
function capSetMCIDeviceName(hwnd: HWND; szName: LPCSTR): BOOL;
function capGetMCIDeviceName(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capPaletteOpen(hwnd: HWND; szName: LPCSTR): BOOL;
function capPaletteSave(hwnd: HWND; szName: LPCSTR): BOOL;
function capPalettePaste(hwnd: HWND): BOOL;
function capPaletteAuto(hwnd: HWND; iFrames, iColors: INT): BOOL;
function capPaletteManual(hwnd: HWND; fGrab: BOOL; iColors: INT): BOOL;
function capCreateCaptureWindowA( lpszWindowName : LPCSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescriptionA( wDriverIndex : UINT; lpszName : LPSTR; cbName : int; lpszVer : LPSTR; cbVer : int ): BOOL; stdcall;
function capCreateCaptureWindowW( lpszWindowName : LPCWSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescriptionW( wDriverIndex : UINT; lpszName : LPWSTR; cbName : int; lpszVer : LPWSTR; cbVer : int ): BOOL; stdcall;
function capCreateCaptureWindow( lpszWindowName : LPCSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescription( wDriverIndex : UINT; lpszName : LPSTR; cbName : int; lpszVer : LPSTR; cbVer : int ): BOOL; stdcall;
function GetOpenFileNamePreviewA(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetSaveFileNamePreviewA(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetOpenFileNamePreviewW(lpofn: POPENFILENAMEW): BOOL; stdcall;
function GetSaveFileNamePreviewW(lpofn: POPENFILENAMEW): BOOL; stdcall;
function GetOpenFileNamePreview(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetSaveFileNamePreview(lpofn: POPENFILENAMEA): BOOL; stdcall;

Types

HDRAWDIB = THandle;
HIC = THandle;
HVIDEO = THandle;
int = integer;
LONG = longint;
PAVICOMPRESSOPTIONS = ˆTAVICOMPRESSOPTIONS;
PAVIFileInfo = ˆTAVIFileInfo;
PAVIFileInfoA = ˆTAVIFileInfoA;
PAVIFileInfoW = ˆTAVIFileInfoW;
PAVIINDEXENTRY = ˆTAVIINDEXENTRY;
PAVIPALCHANGE = ˆTAVIPALCHANGE;
PAVIStreamHeader = ˆTAVIStreamHeader;
PAVIStreamInfo = ˆTAVIStreamInfo;
PAVIStreamInfoA = ˆTAVIStreamInfoA;
PAVIStreamInfoW = ˆTAVIStreamInfoW;
PCAPDRIVERCAPS = ˆTCAPDRIVERCAPS;
PCAPINFOCHUNK = ˆTCAPINFOCHUNK;
PCAPSTATUS = ˆTCAPSTATUS;
PCAPTUREPARMS = ˆTCAPTUREPARMS;
PCHANNEL_CAPS = ˆTCHANNEL_CAPS;
PCOMPVARS = ˆTCOMPVARS;
PDRAWDIBTIME = ˆTDRAWDIBTIME;
PHVIDEO = ˆHVIDEO;
PICCOMPRESS = ˆTICCOMPRESS;
PICCOMPRESSFRAMES = ˆTICCOMPRESSFRAMES;
PICDECOMPRESS = ˆTICDECOMPRESS;
PICDECOMPRESSEX = ˆTICDECOMPRESSEX;
PICDRAW = ˆTICDRAW;
PICDRAWBEGIN = ˆTICDRAWBEGIN;
PICDRAWSUGGEST = ˆTICDRAWSUGGEST;
PICINFO = ˆTICINFO;
PICOPEN = ˆTICOPEN;
PICPALETTE = ˆTICPALETTE;
PICSETSTATUSPROC = ˆTICSETSTATUSPROC;
PLONG = ˆLONG;
PMainAVIHeader = ˆTMainAVIHeader;
PUnknown = ˆIUnknown;
PVIDEOHDR = ˆTVIDEOHDR;
PVOID = pointer;
TAVIFileInfo = TAVIFileInfoA;
TAVISAVECALLBACK = function(i: int): BOOL; pascal;
TAVIStreamInfo = TAVIStreamInfoA;
TCAPCONTROLCALLBACK = function(hWnd: HWND; nState: int): DWORD; stdcall;
TCAPERRORCALLBACK = TCAPERRORCALLBACKA;
TCAPERRORCALLBACKA = function(hWnd: HWND; nID: int; lpsz: LPCSTR): DWORD; stdcall;
TCAPERRORCALLBACKW = function(hWnd: HWND; nID: int; lpsz: LPCWSTR): DWORD; stdcall;
TCAPSTATUSCALLBACK = TCAPSTATUSCALLBACKA;
TCAPSTATUSCALLBACKA = function(hWnd: HWND; nID: int; lpsz: LPCSTR): DWORD; stdcall;
TCAPSTATUSCALLBACKW = function(hWnd: HWND; nID: int; lpsz: LPCWSTR): DWORD; stdcall;
TCAPVIDEOCALLBACK = function(hWnd: HWND; lpVHdr: PVIDEOHDR): DWORD; stdcall;
TCAPWAVECALLBACK = function(hWnd: HWND; lpWHdr: PWAVEHDR): DWORD; stdcall;
TCAPYIELDCALLBACK = function(hWnd: HWND): DWORD; stdcall;
TICCompressProc = function(lInputOutput: LPARAM; lFrame: DWORD; lpBits: PVOID; len: LONG): LONG; stdcall;
TICStatusProc = function(lParam: LPARAM; message: UINT; l: LONG): LONG; stdcall;
TWOCC = word;

Constants

ICVERSION = $0104 ;
BI_1632 = $32333631;
ICTYPE_VIDEO = $63646976;
ICTYPE_AUDIO = $63647561;
ICERR_OK = 0 ;
ICERR_DONTDRAW = 1 ;
ICERR_NEWPALETTE = 2 ;
ICERR_GOTOKEYFRAME = 3 ;
ICERR_STOPDRAWING = 4 ;
ICERR_UNSUPPORTED = -1 ;
ICERR_BADFORMAT = -2 ;
ICERR_MEMORY = -3 ;
ICERR_INTERNAL = -4 ;
ICERR_BADFLAGS = -5 ;
ICERR_BADPARAM = -6 ;
ICERR_BADSIZE = -7 ;
ICERR_BADHANDLE = -8 ;
ICERR_CANTUPDATE = -9 ;
ICERR_ABORT = -10 ;
ICERR_ERROR = -100 ;
ICERR_BADBITDEPTH = -200 ;
ICERR_BADIMAGESIZE = -201 ;
ICERR_CUSTOM = -400 ;
ICMODE_COMPRESS = 1 ;
ICMODE_DECOMPRESS = 2 ;
ICMODE_FASTDECOMPRESS = 3 ;
ICMODE_QUERY = 4 ;
ICMODE_FASTCOMPRESS = 5 ;
ICMODE_DRAW = 8 ;
AVIIF_LIST = $00000001 ;
AVIIF_TWOCC = $00000002 ;
AVIIF_KEYFRAME = $00000010 ;
ICQUALITY_LOW = 0 ;
ICQUALITY_HIGH = 10000 ;
ICQUALITY_DEFAULT = -1 ;
ICM_USER = (DRV_USER+$0000) ;
ICM_RESERVED_LOW = (DRV_USER+$1000) ;
ICM_RESERVED_HIGH = (DRV_USER+$2000) ;
ICM_RESERVED = ICM_RESERVED_LOW ;
ICM_GETSTATE = (ICM_RESERVED+0) ;
ICM_SETSTATE = (ICM_RESERVED+1) ;
ICM_GETINFO = (ICM_RESERVED+2) ;
ICM_CONFIGURE = (ICM_RESERVED+10);
ICM_ABOUT = (ICM_RESERVED+11);
ICM_GETDEFAULTQUALITY = (ICM_RESERVED+30);
ICM_GETQUALITY = (ICM_RESERVED+31);
ICM_SETQUALITY = (ICM_RESERVED+32);
ICM_SET = (ICM_RESERVED+40);
ICM_GET = (ICM_RESERVED+41);
ICM_FRAMERATE = $526D7246;
ICM_KEYFRAMERATE = $5279654B;
ICM_COMPRESS_GET_FORMAT = (ICM_USER+4) ;
ICM_COMPRESS_GET_SIZE = (ICM_USER+5) ;
ICM_COMPRESS_QUERY = (ICM_USER+6) ;
ICM_COMPRESS_BEGIN = (ICM_USER+7) ;
ICM_COMPRESS = (ICM_USER+8) ;
ICM_COMPRESS_END = (ICM_USER+9) ;
ICM_DECOMPRESS_GET_FORMAT = (ICM_USER+10) ;
ICM_DECOMPRESS_QUERY = (ICM_USER+11) ;
ICM_DECOMPRESS_BEGIN = (ICM_USER+12) ;
ICM_DECOMPRESS = (ICM_USER+13) ;
ICM_DECOMPRESS_END = (ICM_USER+14) ;
ICM_DECOMPRESS_SET_PALETTE = (ICM_USER+29) ;
ICM_DECOMPRESS_GET_PALETTE = (ICM_USER+30) ;
ICM_DRAW_QUERY = (ICM_USER+31) ;
ICM_DRAW_BEGIN = (ICM_USER+15) ;
ICM_DRAW_GET_PALETTE = (ICM_USER+16) ;
ICM_DRAW_START = (ICM_USER+18) ;
ICM_DRAW_STOP = (ICM_USER+19) ;
ICM_DRAW_END = (ICM_USER+21) ;
ICM_DRAW_GETTIME = (ICM_USER+32) ;
ICM_DRAW = (ICM_USER+33) ;
ICM_DRAW_WINDOW = (ICM_USER+34) ;
ICM_DRAW_SETTIME = (ICM_USER+35) ;
ICM_DRAW_REALIZE = (ICM_USER+36) ;
ICM_DRAW_FLUSH = (ICM_USER+37) ;
ICM_DRAW_RENDERBUFFER = (ICM_USER+38) ;
ICM_DRAW_START_PLAY = (ICM_USER+39) ;
ICM_DRAW_STOP_PLAY = (ICM_USER+40) ;
ICM_DRAW_SUGGESTFORMAT = (ICM_USER+50) ;
ICM_DRAW_CHANGEPALETTE = (ICM_USER+51) ;
ICM_GETBUFFERSWANTED = (ICM_USER+41) ;
ICM_GETDEFAULTKEYFRAMERATE = (ICM_USER+42) ;
ICM_DECOMPRESSEX_BEGIN = (ICM_USER+60) ;
ICM_DECOMPRESSEX_QUERY = (ICM_USER+61) ;
ICM_DECOMPRESSEX = (ICM_USER+62) ;
ICM_DECOMPRESSEX_END = (ICM_USER+63) ;
ICM_COMPRESS_FRAMES_INFO = (ICM_USER+70) ;
ICM_SET_STATUS_PROC = (ICM_USER+72) ;
VIDCF_QUALITY = $0001 ;
VIDCF_CRUNCH = $0002 ;
VIDCF_TEMPORAL = $0004 ;
VIDCF_COMPRESSFRAMES = $0008 ;
VIDCF_DRAW = $0010 ;
VIDCF_FASTTEMPORALC = $0020 ;
VIDCF_FASTTEMPORALD = $0080 ;
ICCOMPRESS_KEYFRAME = $00000001;
ICCOMPRESSFRAMES_PADDING = $00000001 ;
ICSTATUS_START = 0 ;
ICSTATUS_STATUS = 1 ;
ICSTATUS_END = 2 ;
ICSTATUS_ERROR = 3 ;
ICSTATUS_YIELD = 4 ;
ICDECOMPRESS_HURRYUP = $80000000 ;
ICDECOMPRESS_UPDATE = $40000000 ;
ICDECOMPRESS_PREROLL = $20000000 ;
ICDECOMPRESS_NULLFRAME = $10000000 ;
ICDECOMPRESS_NOTKEYFRAME = $08000000 ;
ICDRAW_QUERY = $00000001 ;
ICDRAW_FULLSCREEN = $00000002 ;
ICDRAW_HDC = $00000004 ;
ICDRAW_ANIMATE = $00000008 ;
ICDRAW_CONTINUE = $00000010 ;
ICDRAW_MEMORYDC = $00000020 ;
ICDRAW_UPDATING = $00000040 ;
ICDRAW_RENDER = $00000080 ;
ICDRAW_BUFFER = $00000100 ;
ICDRAW_HURRYUP = $80000000 ;
ICDRAW_UPDATE = $40000000 ;
ICDRAW_PREROLL = $20000000 ;
ICDRAW_NULLFRAME = $10000000 ;
ICDRAW_NOTKEYFRAME = $08000000 ;
ICINSTALL_UNICODE = $8000 ;
ICINSTALL_FUNCTION = $0001 ;
ICINSTALL_DRIVER = $0002 ;
ICINSTALL_HDRV = $0004 ;
ICINSTALL_DRIVERW = $8002 ;
ICMF_CONFIGURE_QUERY = $00000001 ;
ICMF_ABOUT_QUERY = $00000001 ;
ICMF_COMPVARS_VALID = $00000001;
ICMF_CHOOSE_KEYFRAME = $0001;
ICMF_CHOOSE_DATARATE = $0002;
ICMF_CHOOSE_PREVIEW = $0004;
ICMF_CHOOSE_ALLCOMPRESSORS = $0008;
DDF_UPDATE = $0002;
DDF_SAME_HDC = $0004;
DDF_SAME_DRAW = $0008;
DDF_DONTDRAW = $0010;
DDF_ANIMATE = $0020;
DDF_BUFFER = $0040;
DDF_JUSTDRAWIT = $0080;
DDF_FULLSCREEN = $0100;
DDF_BACKGROUNDPAL = $0200;
DDF_NOTKEYFRAME = $0400;
DDF_HURRYUP = $0800;
DDF_HALFTONE = $1000;
DDF_PREROLL = DDF_DONTDRAW;
DDF_SAME_DIB = DDF_SAME_DRAW;
DDF_SAME_SIZE = DDF_SAME_DRAW;
PD_CAN_DRAW_DIB = $0001;
PD_CAN_STRETCHDIB = $0002;
PD_STRETCHDIB_1_1_OK = $0004;
PD_STRETCHDIB_1_2_OK = $0008;
PD_STRETCHDIB_1_N_OK = $0010;
formtypeAVI = $20495641;
listtypeAVIHEADER = $6C726468;
ckidAVIMAINHDR = $68697661;
listtypeSTREAMHEADER = $6C727473;
ckidSTREAMHEADER = $68727473;
ckidSTREAMFORMAT = $66727473;
ckidSTREAMHANDLERDATA = $64727473;
ckidSTREAMNAME = $6E727473;
listtypeAVIMOVIE = $69766F6D;
listtypeAVIRECORD = $20636572;
ckidAVINEWINDEX = $31786469;
streamtypeVIDEO = $73646976;
streamtypeAUDIO = $73647561;
streamtypeMIDI = $7364696D;
streamtypeTEXT = $73747874;
cktypeDIBbits = $6264;
cktypeDIBcompressed = $6364;
cktypePALchange = $6370;
cktypeWAVEbytes = $6277;
ckidAVIPADDING = $4B4E554A;
AVIF_HASINDEX = $00000010;
AVIF_MUSTUSEINDEX = $00000020;
AVIF_ISINTERLEAVED = $00000100;
AVIF_TRUSTCKTYPE = $00000800;
AVIF_WASCAPTUREFILE = $00010000;
AVIF_COPYRIGHTED = $00020000;
AVI_HEADERSIZE = 2048;
AVISF_DISABLED = $00000001;
AVISF_VIDEO_PALCHANGES = $00010000;
AVIIF_NOTIME = $00000100;
AVIIF_COMPUSE = $0FFF0000;
AVIGETFRAMEF_BESTDISPLAYFMT = 1;
AVISTREAMINFO_DISABLED = $00000001;
AVISTREAMINFO_FORMATCHANGES = $00010000;
AVIFILEINFO_HASINDEX = $00000010;
AVIFILEINFO_MUSTUSEINDEX = $00000020;
AVIFILEINFO_ISINTERLEAVED = $00000100;
AVIFILEINFO_WASCAPTUREFILE = $00010000;
AVIFILEINFO_COPYRIGHTED = $00020000;
AVIFILECAPS_CANREAD = $00000001;
AVIFILECAPS_CANWRITE = $00000002;
AVIFILECAPS_ALLKEYFRAMES = $00000010;
AVIFILECAPS_NOCOMPRESSION = $00000020;
AVICOMPRESSF_INTERLEAVE = $00000001;
AVICOMPRESSF_DATARATE = $00000002;
AVICOMPRESSF_KEYFRAMES = $00000004;
AVICOMPRESSF_VALID = $00000008;
IID_IAVIFile : TGUID = (D1: $00020020; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIStream : TGUID = (D1: $00020021; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIStreaming : TGUID = (D1: $00020022; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IGetFrame : TGUID = (D1: $00020023; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIEditStream: TGUID = (D1: $00020024; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
CLSID_AVISimpleUnMarshal : TGUID = (D1: $00020009; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
CLSID_AVIFile : TGUID = (D1: $00020000; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
AVIFILEHANDLER_CANREAD = $0001;
AVIFILEHANDLER_CANWRITE = $0002;
AVIFILEHANDLER_CANACCEPTNONRGB = $0004;
AVISTREAMREAD_CONVENIENT = -1;
FIND_DIR = $0000000F;
FIND_NEXT = $00000001;
FIND_PREV = $00000004;
FIND_FROM_START = $00000008;
FIND_TYPE = $000000F0;
FIND_KEY = $00000010;
FIND_ANY = $00000020;
FIND_FORMAT = $00000040;
FIND_RET = $0000F000;
FIND_POS = $00000000;
FIND_LENGTH = $00001000;
FIND_OFFSET = $00002000;
FIND_SIZE = $00003000;
FIND_INDEX = $00004000;
SEARCH_NEAREST = FIND_PREV;
SEARCH_BACKWARD = FIND_PREV;
SEARCH_FORWARD = FIND_NEXT;
SEARCH_KEY = FIND_KEY;
SEARCH_ANY = FIND_ANY;
comptypeDIB = $20424944;
AVIERR_OK = 0;
AVIERR_UNSUPPORTED = $80044065;
AVIERR_BADFORMAT = $80044066;
AVIERR_MEMORY = $80044067;
AVIERR_INTERNAL = $80044068;
AVIERR_BADFLAGS = $80044069;
AVIERR_BADPARAM = $8004406A;
AVIERR_BADSIZE = $8004406B;
AVIERR_BADHANDLE = $8004406C;
AVIERR_FILEREAD = $8004406D;
AVIERR_FILEWRITE = $8004406E;
AVIERR_FILEOPEN = $8004406F;
AVIERR_COMPRESSOR = $80044070;
AVIERR_NOCOMPRESSOR = $80044071;
AVIERR_READONLY = $80044072;
AVIERR_NODATA = $80044073;
AVIERR_BUFFERTOOSMALL = $80044074;
AVIERR_CANTCOMPRESS = $80044075;
AVIERR_USERABORT = $800440C6;
AVIERR_ERROR = $800440C7;
MCIWND_WINDOW_CLASS = 'MCIWndClass' ;
MCIWNDOPENF_NEW = $0001;
MCIWNDF_NOAUTOSIZEWINDOW = $0001;
MCIWNDF_NOPLAYBAR = $0002;
MCIWNDF_NOAUTOSIZEMOVIE = $0004;
MCIWNDF_NOMENU = $0008;
MCIWNDF_SHOWNAME = $0010;
MCIWNDF_SHOWPOS = $0020;
MCIWNDF_SHOWMODE = $0040;
MCIWNDF_SHOWALL = $0070;
MCIWNDF_NOTIFYMODE = $0100;
MCIWNDF_NOTIFYPOS = $0200;
MCIWNDF_NOTIFYSIZE = $0400;
MCIWNDF_NOTIFYERROR = $1000;
MCIWNDF_NOTIFYALL = $1F00;
MCIWNDF_NOTIFYANSI = $0080;
MCIWNDF_NOTIFYMEDIAA = $0880;
MCIWNDF_NOTIFYMEDIAW = $0800;
MCIWNDF_NOTIFYMEDIA = MCIWNDF_NOTIFYMEDIAA;
MCIWNDF_RECORD = $2000;
MCIWNDF_NOERRORDLG = $4000;
MCIWNDF_NOOPEN = $8000;
MCIWNDM_GETDEVICEID = WM_USER + 100;
MCIWNDM_GETSTART = WM_USER + 103;
MCIWNDM_GETLENGTH = WM_USER + 104;
MCIWNDM_GETEND = WM_USER + 105;
MCIWNDM_EJECT = WM_USER + 107;
MCIWNDM_SETZOOM = WM_USER + 108;
MCIWNDM_GETZOOM = WM_USER + 109;
MCIWNDM_SETVOLUME = WM_USER + 110;
MCIWNDM_GETVOLUME = WM_USER + 111;
MCIWNDM_SETSPEED = WM_USER + 112;
MCIWNDM_GETSPEED = WM_USER + 113;
MCIWNDM_SETREPEAT = WM_USER + 114;
MCIWNDM_GETREPEAT = WM_USER + 115;
MCIWNDM_REALIZE = WM_USER + 118;
MCIWNDM_VALIDATEMEDIA = WM_USER + 121;
MCIWNDM_PLAYFROM = WM_USER + 122;
MCIWNDM_PLAYTO = WM_USER + 123;
MCIWNDM_GETPALETTE = WM_USER + 126;
MCIWNDM_SETPALETTE = WM_USER + 127;
MCIWNDM_SETTIMERS = WM_USER + 129;
MCIWNDM_SETACTIVETIMER = WM_USER + 130;
MCIWNDM_SETINACTIVETIMER = WM_USER + 131;
MCIWNDM_GETACTIVETIMER = WM_USER + 132;
MCIWNDM_GETINACTIVETIMER = WM_USER + 133;
MCIWNDM_CHANGESTYLES = WM_USER + 135;
MCIWNDM_GETSTYLES = WM_USER + 136;
MCIWNDM_GETALIAS = WM_USER + 137;
MCIWNDM_PLAYREVERSE = WM_USER + 139;
MCIWNDM_GET_SOURCE = WM_USER + 140;
MCIWNDM_PUT_SOURCE = WM_USER + 141;
MCIWNDM_GET_DEST = WM_USER + 142;
MCIWNDM_PUT_DEST = WM_USER + 143;
MCIWNDM_CAN_PLAY = WM_USER + 144;
MCIWNDM_CAN_WINDOW = WM_USER + 145;
MCIWNDM_CAN_RECORD = WM_USER + 146;
MCIWNDM_CAN_SAVE = WM_USER + 147;
MCIWNDM_CAN_EJECT = WM_USER + 148;
MCIWNDM_CAN_CONFIG = WM_USER + 149;
MCIWNDM_PALETTEKICK = WM_USER + 150;
MCIWNDM_OPENINTERFACE = WM_USER + 151;
MCIWNDM_SETOWNER = WM_USER + 152;
MCIWNDM_SENDSTRINGA = WM_USER + 101;
MCIWNDM_GETPOSITIONA = WM_USER + 102;
MCIWNDM_GETMODEA = WM_USER + 106;
MCIWNDM_SETTIMEFORMATA = WM_USER + 119;
MCIWNDM_GETTIMEFORMATA = WM_USER + 120;
MCIWNDM_GETFILENAMEA = WM_USER + 124;
MCIWNDM_GETDEVICEA = WM_USER + 125;
MCIWNDM_GETERRORA = WM_USER + 128;
MCIWNDM_NEWA = WM_USER + 134;
MCIWNDM_RETURNSTRINGA = WM_USER + 138;
MCIWNDM_OPENA = WM_USER + 153;
MCIWNDM_SENDSTRINGW = WM_USER + 201;
MCIWNDM_GETPOSITIONW = WM_USER + 202;
MCIWNDM_GETMODEW = WM_USER + 206;
MCIWNDM_SETTIMEFORMATW = WM_USER + 219;
MCIWNDM_GETTIMEFORMATW = WM_USER + 220;
MCIWNDM_GETFILENAMEW = WM_USER + 224;
MCIWNDM_GETDEVICEW = WM_USER + 225;
MCIWNDM_GETERRORW = WM_USER + 228;
MCIWNDM_NEWW = WM_USER + 234;
MCIWNDM_RETURNSTRINGW = WM_USER + 238;
MCIWNDM_OPENW = WM_USER + 252;
MCIWNDM_SENDSTRING = MCIWNDM_SENDSTRINGA;
MCIWNDM_GETPOSITION = MCIWNDM_GETPOSITIONA;
MCIWNDM_GETMODE = MCIWNDM_GETMODEA;
MCIWNDM_SETTIMEFORMAT = MCIWNDM_SETTIMEFORMATA;
MCIWNDM_GETTIMEFORMAT = MCIWNDM_GETTIMEFORMATA;
MCIWNDM_GETFILENAME = MCIWNDM_GETFILENAMEA;
MCIWNDM_GETDEVICE = MCIWNDM_GETDEVICEA;
MCIWNDM_GETERROR = MCIWNDM_GETERRORA;
MCIWNDM_NEW = MCIWNDM_NEWA;
MCIWNDM_RETURNSTRING = MCIWNDM_RETURNSTRINGA;
MCIWNDM_OPEN = MCIWNDM_OPENA;
MCIWNDM_NOTIFYMODE = WM_USER + 200;
MCIWNDM_NOTIFYPOS = WM_USER + 201;
MCIWNDM_NOTIFYSIZE = WM_USER + 202;
MCIWNDM_NOTIFYMEDIA = WM_USER + 203;
MCIWNDM_NOTIFYERROR = WM_USER + 205;
MCIWND_START = dword(-1) ;
MCIWND_END = dword(-2) ;
DV_ERR_OK = 0;
DV_ERR_BASE = 1;
DV_ERR_NONSPECIFIC = DV_ERR_BASE;
DV_ERR_BADFORMAT = DV_ERR_BASE + 1;
DV_ERR_STILLPLAYING = DV_ERR_BASE + 2;
DV_ERR_UNPREPARED = DV_ERR_BASE + 3;
DV_ERR_SYNC = DV_ERR_BASE + 4;
DV_ERR_TOOMANYCHANNELS = DV_ERR_BASE + 5;
DV_ERR_NOTDETECTED = DV_ERR_BASE + 6;
DV_ERR_BADINSTALL = DV_ERR_BASE + 7;
DV_ERR_CREATEPALETTE = DV_ERR_BASE + 8;
DV_ERR_SIZEFIELD = DV_ERR_BASE + 9;
DV_ERR_PARAM1 = DV_ERR_BASE + 10;
DV_ERR_PARAM2 = DV_ERR_BASE + 11;
DV_ERR_CONFIG1 = DV_ERR_BASE + 12;
DV_ERR_CONFIG2 = DV_ERR_BASE + 13;
DV_ERR_FLAGS = DV_ERR_BASE + 14;
DV_ERR_13 = DV_ERR_BASE + 15;
DV_ERR_NOTSUPPORTED = DV_ERR_BASE + 16;
DV_ERR_NOMEM = DV_ERR_BASE + 17;
DV_ERR_ALLOCATED = DV_ERR_BASE + 18;
DV_ERR_BADDEVICEID = DV_ERR_BASE + 19;
DV_ERR_INVALHANDLE = DV_ERR_BASE + 20;
DV_ERR_BADERRNUM = DV_ERR_BASE + 21;
DV_ERR_NO_BUFFERS = DV_ERR_BASE + 22;
DV_ERR_MEM_CONFLICT = DV_ERR_BASE + 23;
DV_ERR_IO_CONFLICT = DV_ERR_BASE + 24;
DV_ERR_DMA_CONFLICT = DV_ERR_BASE + 25;
DV_ERR_INT_CONFLICT = DV_ERR_BASE + 26;
DV_ERR_PROTECT_ONLY = DV_ERR_BASE + 27;
DV_ERR_LASTERROR = DV_ERR_BASE + 27;
DV_ERR_USER_MSG = DV_ERR_BASE + 1000;
DV_VM_OPEN = MM_DRVM_OPEN;
DV_VM_CLOSE = MM_DRVM_CLOSE;
DV_VM_DATA = MM_DRVM_DATA;
DV_VM_ERROR = MM_DRVM_ERROR;
VHDR_DONE = $00000001;
VHDR_PREPARED = $00000002;
VHDR_INQUEUE = $00000004;
VHDR_KEYFRAME = $00000008;
VCAPS_OVERLAY = $00000001;
VCAPS_SRC_CAN_CLIP = $00000002;
VCAPS_DST_CAN_CLIP = $00000004;
VCAPS_CAN_SCALE = $00000008;
VIDEO_EXTERNALIN = $0001;
VIDEO_EXTERNALOUT = $0002;
VIDEO_IN = $0004;
VIDEO_OUT = $0008;
VIDEO_DLG_QUERY = $0010;
VIDEO_CONFIGURE_QUERY = $8000;
VIDEO_CONFIGURE_SET = $1000;
VIDEO_CONFIGURE_GET = $2000;
VIDEO_CONFIGURE_QUERYSIZE = $0001;
VIDEO_CONFIGURE_CURRENT = $0010;
VIDEO_CONFIGURE_NOMINAL = $0020;
VIDEO_CONFIGURE_MIN = $0040;
VIDEO_CONFIGURE_MAX = $0080;
DVM_USER = $4000;
DVM_CONFIGURE_START = $1000;
DVM_CONFIGURE_END = $1FFF;
DVM_PALETTE = DVM_CONFIGURE_START + 1;
DVM_FORMAT = DVM_CONFIGURE_START + 2;
DVM_PALETTERGB555 = DVM_CONFIGURE_START + 3;
DVM_SRC_RECT = DVM_CONFIGURE_START + 4;
DVM_DST_RECT = DVM_CONFIGURE_START + 5;
WM_CAP_START = WM_USER;
WM_CAP_UNICODE_START = WM_USER + 100;
WM_CAP_GET_CAPSTREAMPTR = WM_CAP_START + 1;
WM_CAP_SET_CALLBACK_ERRORW = WM_CAP_UNICODE_START + 2;
WM_CAP_SET_CALLBACK_STATUSW = WM_CAP_UNICODE_START + 3;
WM_CAP_SET_CALLBACK_ERRORA = WM_CAP_START + 2;
WM_CAP_SET_CALLBACK_STATUSA = WM_CAP_START + 3;
WM_CAP_SET_CALLBACK_ERROR = WM_CAP_SET_CALLBACK_ERRORA;
WM_CAP_SET_CALLBACK_STATUS = WM_CAP_SET_CALLBACK_STATUSA;
WM_CAP_SET_CALLBACK_YIELD = WM_CAP_START + 4;
WM_CAP_SET_CALLBACK_FRAME = WM_CAP_START + 5;
WM_CAP_SET_CALLBACK_VIDEOSTREAM = WM_CAP_START + 6;
WM_CAP_SET_CALLBACK_WAVESTREAM = WM_CAP_START + 7;
WM_CAP_GET_USER_DATA = WM_CAP_START + 8;
WM_CAP_SET_USER_DATA = WM_CAP_START + 9;
WM_CAP_DRIVER_CONNECT = WM_CAP_START + 10;
WM_CAP_DRIVER_DISCONNECT = WM_CAP_START + 11;
WM_CAP_DRIVER_GET_NAMEA = WM_CAP_START + 12;
WM_CAP_DRIVER_GET_VERSIONA = WM_CAP_START + 13;
WM_CAP_DRIVER_GET_NAMEW = WM_CAP_UNICODE_START + 12;
WM_CAP_DRIVER_GET_VERSIONW = WM_CAP_UNICODE_START + 13;
WM_CAP_DRIVER_GET_NAME = WM_CAP_DRIVER_GET_NAMEA;
WM_CAP_DRIVER_GET_VERSION = WM_CAP_DRIVER_GET_VERSIONA;
WM_CAP_DRIVER_GET_CAPS = WM_CAP_START + 14;
WM_CAP_FILE_SET_CAPTURE_FILEA = WM_CAP_START + 20;
WM_CAP_FILE_GET_CAPTURE_FILEA = WM_CAP_START + 21;
WM_CAP_FILE_SAVEASA = WM_CAP_START + 23;
WM_CAP_FILE_SAVEDIBA = WM_CAP_START + 25;
WM_CAP_FILE_SET_CAPTURE_FILEW = WM_CAP_UNICODE_START + 20;
WM_CAP_FILE_GET_CAPTURE_FILEW = WM_CAP_UNICODE_START + 21;
WM_CAP_FILE_SAVEASW = WM_CAP_UNICODE_START + 23;
WM_CAP_FILE_SAVEDIBW = WM_CAP_UNICODE_START + 25;
WM_CAP_FILE_SET_CAPTURE_FILE = WM_CAP_FILE_SET_CAPTURE_FILEA;
WM_CAP_FILE_GET_CAPTURE_FILE = WM_CAP_FILE_GET_CAPTURE_FILEA;
WM_CAP_FILE_SAVEAS = WM_CAP_FILE_SAVEASA;
WM_CAP_FILE_SAVEDIB = WM_CAP_FILE_SAVEDIBA;
WM_CAP_FILE_ALLOCATE = WM_CAP_START + 22;
WM_CAP_FILE_SET_INFOCHUNK = WM_CAP_START + 24;
WM_CAP_EDIT_COPY = WM_CAP_START + 30;
WM_CAP_SET_AUDIOFORMAT = WM_CAP_START + 35;
WM_CAP_GET_AUDIOFORMAT = WM_CAP_START + 36;
WM_CAP_DLG_VIDEOFORMAT = WM_CAP_START + 41;
WM_CAP_DLG_VIDEOSOURCE = WM_CAP_START + 42;
WM_CAP_DLG_VIDEODISPLAY = WM_CAP_START + 43;
WM_CAP_GET_VIDEOFORMAT = WM_CAP_START + 44;
WM_CAP_SET_VIDEOFORMAT = WM_CAP_START + 45;
WM_CAP_DLG_VIDEOCOMPRESSION = WM_CAP_START + 46;
WM_CAP_SET_PREVIEW = WM_CAP_START + 50;
WM_CAP_SET_OVERLAY = WM_CAP_START + 51;
WM_CAP_SET_PREVIEWRATE = WM_CAP_START + 52;
WM_CAP_SET_SCALE = WM_CAP_START + 53;
WM_CAP_GET_STATUS = WM_CAP_START + 54;
WM_CAP_SET_SCROLL = WM_CAP_START + 55;
WM_CAP_GRAB_FRAME = WM_CAP_START + 60;
WM_CAP_GRAB_FRAME_NOSTOP = WM_CAP_START + 61;
WM_CAP_SEQUENCE = WM_CAP_START + 62;
WM_CAP_SEQUENCE_NOFILE = WM_CAP_START + 63;
WM_CAP_SET_SEQUENCE_SETUP = WM_CAP_START + 64;
WM_CAP_GET_SEQUENCE_SETUP = WM_CAP_START + 65;
WM_CAP_SET_MCI_DEVICEA = WM_CAP_START + 66;
WM_CAP_GET_MCI_DEVICEA = WM_CAP_START + 67;
WM_CAP_SET_MCI_DEVICEW = WM_CAP_UNICODE_START + 66;
WM_CAP_GET_MCI_DEVICEW = WM_CAP_UNICODE_START + 67;
WM_CAP_SET_MCI_DEVICE = WM_CAP_SET_MCI_DEVICEA;
WM_CAP_GET_MCI_DEVICE = WM_CAP_GET_MCI_DEVICEA;
WM_CAP_STOP = WM_CAP_START + 68;
WM_CAP_ABORT = WM_CAP_START + 69;
WM_CAP_SINGLE_FRAME_OPEN = WM_CAP_START + 70;
WM_CAP_SINGLE_FRAME_CLOSE = WM_CAP_START + 71;
WM_CAP_SINGLE_FRAME = WM_CAP_START + 72;
WM_CAP_PAL_OPENA = WM_CAP_START + 80;
WM_CAP_PAL_SAVEA = WM_CAP_START + 81;
WM_CAP_PAL_OPENW = WM_CAP_UNICODE_START + 80;
WM_CAP_PAL_SAVEW = WM_CAP_UNICODE_START + 81;
WM_CAP_PAL_OPEN = WM_CAP_PAL_OPENA;
WM_CAP_PAL_SAVE = WM_CAP_PAL_SAVEA;
WM_CAP_PAL_PASTE = WM_CAP_START + 82;
WM_CAP_PAL_AUTOCREATE = WM_CAP_START + 83;
WM_CAP_PAL_MANUALCREATE = WM_CAP_START + 84;
WM_CAP_SET_CALLBACK_CAPCONTROL = WM_CAP_START + 85;
WM_CAP_UNICODE_END = WM_CAP_PAL_SAVEW;
WM_CAP_END = WM_CAP_UNICODE_END;
AVSTREAMMASTER_AUDIO = 0;
AVSTREAMMASTER_NONE = 1;
CONTROLCALLBACK_PREROLL = 1;
CONTROLCALLBACK_CAPTURING = 2;
infotypeDIGITIZATION_TIME = $54494449;
infotypeSMPTE_TIME = $504D5349;
IDS_CAP_BEGIN = 300;
IDS_CAP_END = 301;
IDS_CAP_INFO = 401;
IDS_CAP_OUTOFMEM = 402;
IDS_CAP_FILEEXISTS = 403;
IDS_CAP_ERRORPALOPEN = 404;
IDS_CAP_ERRORPALSAVE = 405;
IDS_CAP_ERRORDIBSAVE = 406;
IDS_CAP_DEFAVIEXT = 407;
IDS_CAP_DEFPALEXT = 408;
IDS_CAP_CANTOPEN = 409;
IDS_CAP_SEQ_MSGSTART = 410;
IDS_CAP_SEQ_MSGSTOP = 411;
IDS_CAP_VIDEDITERR = 412;
IDS_CAP_READONLYFILE = 413;
IDS_CAP_WRITEERROR = 414;
IDS_CAP_NODISKSPACE = 415;
IDS_CAP_SETFILESIZE = 416;
IDS_CAP_SAVEASPERCENT = 417;
IDS_CAP_DRIVER_ERROR = 418;
IDS_CAP_WAVE_OPEN_ERROR = 419;
IDS_CAP_WAVE_ALLOC_ERROR = 420;
IDS_CAP_WAVE_PREPARE_ERROR = 421;
IDS_CAP_WAVE_ADD_ERROR = 422;
IDS_CAP_WAVE_SIZE_ERROR = 423;
IDS_CAP_VIDEO_OPEN_ERROR = 424;
IDS_CAP_VIDEO_ALLOC_ERROR = 425;
IDS_CAP_VIDEO_PREPARE_ERROR = 426;
IDS_CAP_VIDEO_ADD_ERROR = 427;
IDS_CAP_VIDEO_SIZE_ERROR = 428;
IDS_CAP_FILE_OPEN_ERROR = 429;
IDS_CAP_FILE_WRITE_ERROR = 430;
IDS_CAP_RECORDING_ERROR = 431;
IDS_CAP_RECORDING_ERROR2 = 432;
IDS_CAP_AVI_INIT_ERROR = 433;
IDS_CAP_NO_FRAME_CAP_ERROR = 434;
IDS_CAP_NO_PALETTE_WARN = 435;
IDS_CAP_MCI_CONTROL_ERROR = 436;
IDS_CAP_MCI_CANT_STEP_ERROR = 437;
IDS_CAP_NO_AUDIO_CAP_ERROR = 438;
IDS_CAP_AVI_DRAWDIB_ERROR = 439;
IDS_CAP_COMPRESSOR_ERROR = 440;
IDS_CAP_AUDIO_DROP_ERROR = 441;
IDS_CAP_STAT_LIVE_MODE = 500;
IDS_CAP_STAT_OVERLAY_MODE = 501;
IDS_CAP_STAT_CAP_INIT = 502;
IDS_CAP_STAT_CAP_FINI = 503;
IDS_CAP_STAT_PALETTE_BUILD = 504;
IDS_CAP_STAT_OPTPAL_BUILD = 505;
IDS_CAP_STAT_I_FRAMES = 506;
IDS_CAP_STAT_L_FRAMES = 507;
IDS_CAP_STAT_CAP_L_FRAMES = 508;
IDS_CAP_STAT_CAP_AUDIO = 509;
IDS_CAP_STAT_VIDEOCURRENT = 510;
IDS_CAP_STAT_VIDEOAUDIO = 511;
IDS_CAP_STAT_VIDEOONLY = 512;
IDS_CAP_STAT_FRAMESDROPPED = 513;

Description

Functions and Procedures

function VideoForWindowsVersion: DWORD; pascal;

*************************************************************************** * * VideoForWindowsVersion() - returns version of VfW * **************************************************************************

function MKFOURCC(ch0, ch1, ch2, ch3: AnsiChar): FOURCC;

***************************************************************************/ /* */ /* Macros */ /* */ /* should we define this?? */ /* */ /***************************************************************************

function mmioFOURCC(ch0, ch1, ch2, ch3: AnsiChar): FOURCC;

'1632'

function aviTWOCC(ch0, ch1: AnsiChar): TWOCC;

This item has no description.

function ICInfo(fccType, fccHandler: DWORD; lpicinfo: PICINFO) : BOOL ; stdcall;

***********************************************************************

ICM function declarations

***********************************************************************

function ICInstall(fccType, fccHandler: DWORD; lParam: LPARAM; szDesc: LPSTR; wFlags: UINT) : BOOL ; stdcall;

This item has no description.

function ICRemove(fccType, fccHandler: DWORD; wFlags: UINT) : BOOL ; stdcall;

This item has no description.

function ICGetInfo(hic: HIC; picinfo: PICINFO; cb: DWORD) : DWORD ; stdcall;

This item has no description.

function ICOpen(fccType, fccHandler: DWORD; wMode: UINT) : HIC ; stdcall;

This item has no description.

function ICOpenFunction(fccType, fccHandler: DWORD; wMode: UINT; lpfnHandler: TFarProc) : HIC ; stdcall;

This item has no description.

function ICClose(hic: HIC) : DWORD; stdcall;

This item has no description.

function ICSendMessage(hic: HIC; msg: UINT; dw1, dw2: DWORD) : DWORD ; stdcall;

This item has no description.

function ICQueryAbout(hic: HIC): BOOL;

This item has no description.

function ICAbout(hic: HIC; hwnd: HWND): DWORD;

This item has no description.

function ICQueryConfigure(hic: HIC): BOOL;

This item has no description.

function ICConfigure(hic: HIC; hwnd: HWND): DWORD;

This item has no description.

function ICGetState(hic: HIC; pv: PVOID; cb: DWORD): DWORD;

– Get/Set state macros —————————————————–

function ICSetState(hic: HIC; pv: PVOID; cb: DWORD): DWORD;

This item has no description.

function ICGetStateSize(hic: HIC): DWORD;

This item has no description.

function ICGetDefaultQuality(hic: HIC): DWORD;

– Get value macros ———————————————————

function ICGetDefaultKeyFrameRate(hic: HIC): DWORD;

This item has no description.

function ICDrawWindow(hic: HIC; prc: PRECT): DWORD;

– Draw window macro ——————————————————–

function ICCompress( hic : HIC; dwFlags : DWORD; lpbiOutput : PBITMAPINFOHEADER; lpData : PVOID; lpbiInput : PBITMAPINFOHEADER; lpBits : PVOID; lpckid : PDWORD; lpdwFlags : PDWORD; lFrameNum : DWORD; dwFrameSize : DWORD; dwQuality : DWORD; lpbiPrev : PBITMAPINFOHEADER; lpPrev : PVOID ): DWORD; cdecl;

***********************************************************************

compression functions

************************************************************************/ /* * ICCompress() * * compress a single frame *

function ICCompressBegin(hic: HIC; lpbiInput: PBITMAPINFOHEADER; lpbiOutput: PBITMAPINFOHEADER): DWORD;

* ICCompressBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOuput) is supported. *

function ICCompressQuery(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;

* ICCompressQuery() * * determines if compression from a source format (lpbiInput) to a dest * format (lpbiOuput) is supported. *

function ICCompressGetFormat(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;

* ICCompressGetFormat() * * get the output format, (format of compressed data) * if lpbiOutput is NULL return the size in bytes needed for format. *

function ICCompressGetFormatSize(hic: HIC; lpbi: PBITMAPINFOHEADER): DWORD;

This item has no description.

function ICCompressGetSize(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;

* ICCompressSize() * * return the maximal size of a compressed frame *

function ICCompressEnd(hic: HIC): DWORD;

This item has no description.

function ICDecompress( hic : HIC; dwFlags : DWORD; lpbiFormat : PBITMAPINFOHEADER; lpData : PVOID; lpbi : PBITMAPINFOHEADER; lpBits : PVOID ): DWORD; cdecl;

* ICDecompress() * * decompress a single frame *

function ICDecompressBegin(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;

* ICDecompressBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *

function ICDecompressQuery(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;

* ICDecompressQuery() * * determines if compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *

function ICDecompressGetFormat(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;

* ICDecompressGetFormat() * * get the output format, (format of un-compressed data) * if lpbiOutput is NULL return the size in bytes needed for format. *

function ICDecompressGetFormatSize(hic: HIC; lpbi: PBITMAPINFOHEADER): DWORD;

This item has no description.

function ICDecompressGetPalette(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;

* ICDecompressGetPalette() * * get the output palette *

function ICDecompressSetPalette(hic: HIC; lpbiPalette: PBITMAPINFOHEADER): DWORD;

This item has no description.

function ICDecompressEnd(hic: HIC): DWORD;

This item has no description.

function ICDecompressEx( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;

* ICDecompressEx() * * decompress a single frame *

function ICDecompressExBegin( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;

* ICDecompressExBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *

function ICDecompressExQuery( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;

* ICDecompressExQuery() *

function ICDecompressExEnd(hic: HIC): DWORD;

This item has no description.

function ICDrawBegin( hic : HIC; dwFlags : DWORD; hpal : HPALETTE; hwnd : HWND; hdc : HDC; xDst : int; yDst : int; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; dwRate : DWORD; dwScale : DWORD ): DWORD; cdecl;

* ICDrawBegin() * * start decompressing data with format (lpbiInput) directly to the screen * * return zero if the decompressor supports drawing. *

function ICDraw( hic : HIC; dwFlags : DWORD; lpFormat : PVOID; lpData : PVOID; cbData : DWORD; lTime : DWORD ): DWORD; cdecl;

* ICDraw() * * decompress data directly to the screen *

function ICDrawSuggestFormat( hic : HIC; lpbiIn : PBITMAPINFOHEADER; lpbiOut : PBITMAPINFOHEADER; dxSrc : int; dySrc : int; dxDst : int; dyDst : int; hicDecomp : HIC ): DWORD; stdcall;

ICMessage is not supported on Win32, so provide a static inline function to do the same job

function ICDrawQuery(hic: HIC; lpbiInput: PBITMAPINFOHEADER): DWORD;

* ICDrawQuery() * * determines if the compressor is willing to render the specified format. *

function ICDrawChangePalette(hic: HIC; lpbiInput: PBITMAPINFOHEADER): DWORD;

This item has no description.

function ICGetBuffersWanted(hic: HIC; lpdwBuffers: PDWORD): DWORD;

This item has no description.

function ICDrawEnd(hic: HIC): DWORD;

This item has no description.

function ICDrawStart(hic: HIC): DWORD;

This item has no description.

function ICDrawStartPlay(hic: HIC; lFrom, lTo: DWORD): DWORD;

This item has no description.

function ICDrawStop(hic: HIC): DWORD;

This item has no description.

function ICDrawStopPlay(hic: HIC): DWORD;

This item has no description.

function ICDrawGetTime(hic: HIC; lplTime: PDWORD): DWORD;

This item has no description.

function ICDrawSetTime(hic: HIC; lTime: DWORD): DWORD;

This item has no description.

function ICDrawRealize(hic: HIC; hdc: HDC; fBackground: BOOL): DWORD;

This item has no description.

function ICDrawFlush(hic: HIC): DWORD;

This item has no description.

function ICDrawRenderBuffer(hic: HIC): DWORD;

This item has no description.

function ICSetStatusProc( hic : HIC; dwFlags : DWORD; lParam : DWORD; fpfnStatus : TICStatusProc ): DWORD; stdcall;

ICMessage is not supported on NT

function ICLocate(fccType, fccHandler: DWORD; lpbiIn, lpbiOut: PBITMAPINFOHEADER; wFlags: WORD): HIC; stdcall;

***********************************************************************

helper routines for DrawDib and MCIAVI...

***********************************************************************

function ICGetDisplayFormat(hic: HIC; lpbiIn, lpbiOut: PBITMAPINFOHEADER; BitDepth: int; dx, dy: int): HIC; stdcall;

This item has no description.

function ICDecompressOpen(fccType, fccHandler: DWORD; lpbiIn, lpbiOut: PBITMAPINFOHEADER): HIC;

This item has no description.

function ICDrawOpen(fccType, fccHandler: DWORD; lpbiIn: PBITMAPINFOHEADER): HIC;

This item has no description.

function ICImageCompress( hic : HIC; uiFlags : UINT; lpbiIn : PBITMAPINFO; lpBits : PVOID; lpbiOut : PBITMAPINFO; lQuality : LONG; plSize : PDWORD ): THANDLE; stdcall;

*********************************************************************** Higher level functions ***********************************************************************

function ICImageDecompress( hic : HIC; uiFlags : UINT; lpbiIn : PBITMAPINFO; lpBits : PVOID; lpbiOut : PBITMAPINFO ): THANDLE; stdcall;

This item has no description.

function ICCompressorChoose( hwnd : HWND; uiFlags : UINT; pvIn : PVOID; lpData : PVOID; pc : PCOMPVARS; lpszTitle : LPSTR ): BOOL; stdcall;

COMPVARS contains valid data

allows user to choose compressor, quality etc...

function ICSeqCompressFrameStart(pc: PCOMPVARS; lpbiIn: PBITMAPINFO): BOOL; stdcall;

don't only show those that can handle the input format or input data

procedure ICSeqCompressFrameEnd(pc: PCOMPVARS); stdcall;

This item has no description.

function ICSeqCompressFrame( pc : PCOMPVARS; uiFlags : UINT; lpBits : PVOID; pfKey : PBOOL; plSize : PDWORD ): PVOID; stdcall;

This item has no description.

procedure ICCompressorFree(pc: PCOMPVARS); stdcall;

This item has no description.

function DrawDibOpen: HDRAWDIB; stdcall;

– DrawDibOpen() ————————————————————

function DrawDibClose(hdd: HDRAWDIB): BOOL; stdcall;

– DrawDibClose() ———————————————————–

function DrawDibGetBuffer(hdd: HDRAWDIB; lpbi: PBITMAPINFOHEADER; dwSize: DWORD; dwFlags: DWORD): PVOID; stdcall;

– DrawDibGetBuffer() ——————————————————-

function DrawDibGetPalette(hdd: HDRAWDIB): HPALETTE; stdcall;

– DrawDibGetPalette() - get the palette used for drawing DIBs ————–

function DrawDibSetPalette(hdd: HDRAWDIB; hpal: HPALETTE): BOOL; stdcall;

– DrawDibSetPalette() - set the palette used for drawing DIBs ————–

function DrawDibChangePalette(hdd: HDRAWDIB; iStart, iLen: int; lppe: PPALETTEENTRY): BOOL; stdcall;

– DrawDibChangePalette() —————————————————

function DrawDibRealize(hdd: HDRAWDIB; hdc: HDC; fBackground: BOOL): UINT; stdcall;

– DrawDibRealize() - realize the palette in a HDD ————————–

function DrawDibStart(hdd: HDRAWDIB; rate: DWORD): BOOL; stdcall;

– DrawDibStart() - start of streaming playback —————————–

function DrawDibStop(hdd: HDRAWDIB): BOOL; stdcall;

– DrawDibStop() - start of streaming playback ——————————

function DrawDibBegin( hdd : HDRAWDIB; hdc : HDC; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; dxSrc : int; dySrc : int; wFlags : UINT ): BOOL; stdcall;

– DrawDibBegin() - prepare to draw —————————————–

function DrawDibDraw( hdd : HDRAWDIB; hdc : HDC; xDst : int; yDst : int; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; lpBits : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; wFlags : UINT ): BOOL; stdcall;

– DrawDibDraw() - actually draw a DIB to the screen ————————

function DrawDibUpdate(hdd: HDRAWDIB; hdc: HDC; x, y: int): BOOL;

– DrawDibUpdate() - redraw last image (may only be valid with DDF_BUFFER) –

function DrawDibEnd(hdd: HDRAWDIB): BOOL; stdcall;

– DrawDibEnd() ————————————————————-

function DrawDibTime(hdd: HDRAWDIB; lpddtime: PDRAWDIBTIME): BOOL; stdcall;

This item has no description.

function DrawDibProfileDisplay(lpbi: PBITMAPINFOHEADER): DWORD; stdcall;

...

function FromHex(n: BYTE): BYTE;

– Macro to get stream number out of a FOURCC ckid ————————–

function StreamFromFOURCC(fcc: DWORD): BYTE;

This item has no description.

function TWOCCFromFOURCC(fcc: DWORD): WORD;

– Macro to get TWOCC chunk type out of a FOURCC ckid ———————–

function ToHex(n: BYTE): BYTE;

– Macro to make a ckid for a chunk out of a TWOCC and a stream num (0-255) -

function MAKEAVICKID(tcc: WORD; stream: BYTE): DWORD;

This item has no description.

procedure AVIFileInit; stdcall;

– Functions —————————————————————-

procedure AVIFileExit; stdcall;

Call this first!

function AVIFileAddRef(pfile: IAVIFile): ULONG; stdcall;

This item has no description.

function AVIFileRelease(pfile: IAVIFile): ULONG; stdcall;

This item has no description.

function AVIFileOpenA(var ppfile: IAVIFile; szFile: LPCSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;

This item has no description.

function AVIFileOpenW(var ppfile: IAVIFile; szFile: LPCWSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;

This item has no description.

function AVIFileOpen(var ppfile: IAVIFile; szFile: LPCSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;

This item has no description.

function AVIFileInfoW(pfile: IAVIFile; var pfi: TAVIFILEINFOW; lSize: LONG): HResult; stdcall;

This item has no description.

function AVIFileInfoA(pfile: IAVIFile; var pfi: TAVIFILEINFOA; lSize: LONG): HResult; stdcall;

This item has no description.

function AVIFileInfo(pfile: IAVIFile; var pfi: TAVIFILEINFO; lSize: LONG): HResult; stdcall;

This item has no description.

function AVIFileGetStream(pfile: IAVIFile; var ppavi: IAVISTREAM; fccType: DWORD; lParam: LONG): HResult; stdcall;

This item has no description.

function AVIFileCreateStreamW(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFOW): HResult; stdcall;

This item has no description.

function AVIFileCreateStreamA(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFOA): HResult; stdcall;

This item has no description.

function AVIFileCreateStream(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFO): HResult; stdcall;

This item has no description.

function AVIFileWriteData(pfile: IAVIFile; ckid: DWORD; lpData: PVOID; cbData: LONG): HResult; stdcall;

This item has no description.

function AVIFileReadData(pfile: IAVIFile; ckid: DWORD; lpData: PVOID; var lpcbData: LONG): HResult; stdcall;

This item has no description.

function AVIFileEndRecord(pfile: IAVIFile): HResult; stdcall;

This item has no description.

function AVIStreamAddRef(pavi: IAVIStream): ULONG; stdcall;

This item has no description.

function AVIStreamRelease(pavi: IAVIStream): ULONG; stdcall;

This item has no description.

function AVIStreamInfoW(pavi: IAVIStream; var psi: TAVISTREAMINFOW; lSize: LONG): HResult; stdcall;

This item has no description.

function AVIStreamInfoA(pavi: IAVIStream; var psi: TAVISTREAMINFOA; lSize: LONG): HResult; stdcall;

This item has no description.

function AVIStreamInfo(pavi: IAVIStream; var psi: TAVISTREAMINFO; lSize: LONG): HResult; stdcall;

This item has no description.

function AVIStreamFindSample(pavi: IAVIStream; lPos: LONG; lFlags: LONG): LONG; stdcall;

This item has no description.

function AVIStreamReadFormat(pavi: IAVIStream; lPos: LONG; lpFormat: PVOID; lpcbFormat: PLONG): HResult; stdcall;

This item has no description.

function AVIStreamSetFormat(pavi: IAVIStream; lPos: LONG; lpFormat: PVOID; cbFormat: LONG): HResult; stdcall;

This item has no description.

function AVIStreamReadData(pavi: IAVIStream; fcc: DWORD; lp: PVOID; lpcb: PLONG): HResult; stdcall;

This item has no description.

function AVIStreamWriteData(pavi: IAVIStream; fcc: DWORD; lp: PVOID; cb: LONG): HResult; stdcall;

This item has no description.

function AVIStreamRead( pavi : IAVISTREAM; lStart : LONG; lSamples : LONG; lpBuffer : PVOID; cbBuffer : LONG; plBytes : PLONG; plSamples : PLONG ): HResult; stdcall;

This item has no description.

function AVIStreamWrite( pavi : IAVISTREAM; lStart : LONG; lSamples : LONG; lpBuffer : PVOID; cbBuffer : LONG; dwFlags : DWORD; plSampWritten : PLONG; plBytesWritten : PLONG ): HResult; stdcall;

This item has no description.

function AVIStreamStart(pavi: IAVIStream): LONG; stdcall;

Right now, these just use AVIStreamInfo() to get information, then return some of it. Can they be more efficient?

function AVIStreamLength(pavi: IAVIStream): LONG; stdcall;

This item has no description.

function AVIStreamTimeToSample(pavi: IAVIStream; lTime: LONG): LONG; stdcall;

This item has no description.

function AVIStreamSampleToTime(pavi: IAVIStream; lSample: LONG): LONG; stdcall;

This item has no description.

function AVIStreamBeginStreaming(pavi: IAVIStream; lStart, lEnd: LONG; lRate: LONG): HResult; stdcall;

This item has no description.

function AVIStreamEndStreaming(pavi: IAVIStream): HResult; stdcall;

This item has no description.

function AVIStreamGetFrameOpen(pavi: IAVIStream; lpbiWanted: PBitmapInfoHeader): IGetFrame; stdcall;

– Helper functions for using IGetFrame ————————————-

function AVIStreamGetFrame(pg: IGetFrame; lPos: LONG): PBitmapInfoHeader; stdcall;

This item has no description.

function AVIStreamGetFrameClose(pg: IGetFrame): HResult; stdcall;

This item has no description.

function AVIStreamOpenFromFileA(var ppavi: IAVISTREAM; szFile: LPCSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;

– Shortcut function ——————————————————–

function AVIStreamOpenFromFileW(var ppavi: IAVISTREAM; szFile: LPCWSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;

This item has no description.

function AVIStreamOpenFromFile(var ppavi: IAVISTREAM; szFile: LPCSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;

This item has no description.

function AVIStreamCreate(var ppavi: IAVISTREAM; lParam1, lParam2: LONG; pclsidHandler: PCLSID): HResult; stdcall;

– Use to create disembodied streams —————————————-

function AVIStreamFindKeyFrame(var pavi: IAVISTREAM; lPos: LONG; lFlags: LONG): DWORD; stdcall;

– Stuff to support backward compat. —————————————-

function AVIStreamClose(pavi: IAVISTREAM): ULONG; stdcall;

AVIStreamFindSample Non-portable: this is alias for method name FindKeyFrame FindSample

function AVIFileClose(pfile: IAVIFILE): ULONG; stdcall;

AVIStreamRelease

procedure AVIStreamInit; stdcall;

AVIFileRelease

procedure AVIStreamExit; stdcall;

AVIFileInit

function AVIStreamSampleToSample(pavi1, pavi2: IAVISTREAM; l: LONG): LONG;

– Helper macros ————————————————————

function AVIStreamNextSample(pavi: IAVISTREAM; l: LONG): LONG;

This item has no description.

function AVIStreamPrevSample(pavi: IAVISTREAM; l: LONG): LONG;

This item has no description.

function AVIStreamNearestSample(pavi: IAVISTREAM; l: LONG): LONG;

This item has no description.

function AVIStreamNextKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;

This item has no description.

function AVIStreamPrevKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;

This item has no description.

function AVIStreamNearestKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;

This item has no description.

function AVIStreamIsKeyFrame(pavi: IAVISTREAM; l: LONG): BOOL;

This item has no description.

function AVIStreamPrevSampleTime(pavi: IAVISTREAM; t: LONG): LONG;

This item has no description.

function AVIStreamNextSampleTime(pavi: IAVISTREAM; t: LONG): LONG;

This item has no description.

function AVIStreamNearestSampleTime(pavi: IAVISTREAM; t: LONG): LONG;

This item has no description.

function AVIStreamNextKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;

This item has no description.

function AVIStreamPrevKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;

This item has no description.

function AVIStreamNearestKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;

This item has no description.

function AVIStreamStartTime(pavi: IAVISTREAM): LONG;

This item has no description.

function AVIStreamLengthTime(pavi: IAVISTREAM): LONG;

This item has no description.

function AVIStreamEnd(pavi: IAVISTREAM): LONG;

This item has no description.

function AVIStreamEndTime(pavi: IAVISTREAM): LONG;

This item has no description.

function AVIStreamSampleSize(pavi: IAVISTREAM; lPos: LONG; plSize: PLONG): LONG;

This item has no description.

function AVIStreamFormatSize(pavi: IAVISTREAM; lPos: LONG; plSize: PLONG): HResult;

This item has no description.

function AVIStreamDataSize(pavi: IAVISTREAM; fcc: DWORD; plSize: PLONG): HResult;

This item has no description.

function AVIMakeCompressedStream( var ppsCompressed : IAVISTREAM; ppsSource : IAVISTREAM; lpOptions : PAVICOMPRESSOPTIONS; pclsidHandler : PCLSID ): HResult; stdcall;

mmioFOURCC('D', 'I', 'B', ' ')

function AVISaveVA( szFile : LPCSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;

Non-portable: uses variable number of params EXTERN_C HRESULT CDECL AVISaveA (LPCSTR szFile, CLSID FAR *pclsidHandler, AVISAVECALLBACK lpfnCallback, int nStreams, PAVISTREAM pfile, LPAVICOMPRESSOPTIONS lpOptions, ...);

function AVISaveVW( szFile : LPCWSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;

Non-portable: uses variable number of params EXTERN_C HRESULT CDECL AVISaveW (LPCWSTR szFile, CLSID FAR *pclsidHandler, AVISAVECALLBACK lpfnCallback, int nStreams, PAVISTREAM pfile, LPAVICOMPRESSOPTIONS lpOptions, ...);

function AVISaveV( szFile : LPCSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;

#define AVISave AVISaveA

function AVISaveOptions( hwnd : HWND; uiFlags : UINT; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): BOOL; stdcall;

AVISaveVA

function AVISaveOptionsFree(nStreams: int; var plpOptions: PAVICOMPRESSOPTIONS): HResult; stdcall;

This item has no description.

function AVIBuildFilterW(lpszFilter: LPWSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;

Same as the flags for ICCompressorChoose (see compman.h) These determine what the compression options dialog for video streams will look like.

function AVIBuildFilterA(lpszFilter: LPSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;

This item has no description.

function AVIBuildFilter(lpszFilter: LPSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;

This item has no description.

function AVIMakeFileFromStreams(var ppfile: IAVIFILE; nStreams: int; var papStreams: IAVISTREAM): HResult; stdcall;

AVIBuildFilterA

function AVIMakeStreamFromClipboard(cfFormat: UINT; hGlobal: THANDLE; var ppstream: IAVISTREAM): HResult; stdcall;

This item has no description.

function AVIPutFileOnClipboard(pf: IAVIFILE): HResult; stdcall;

– Clipboard routines ——————————————————-

function AVIGetFromClipboard(var lppf: IAVIFILE): HResult; stdcall;

This item has no description.

function AVIClearClipboard: HResult; stdcall;

This item has no description.

function CreateEditableStream(var ppsEditable: IAVISTREAM; psSource: IAVISTREAM): HResult; stdcall;

– Editing routines ———————————————————

function EditStreamCut(pavi: IAVISTREAM; var plStart, plLength: LONG; var ppResult: IAVISTREAM): HResult; stdcall;

This item has no description.

function EditStreamCopy(pavi: IAVISTREAM; var plStart, plLength: LONG; var ppResult: IAVISTREAM): HResult; stdcall;

This item has no description.

function EditStreamPaste(pavi: IAVISTREAM; var plPos, plLength: LONG; pstream: IAVISTREAM; lStart, lEnd: LONG): HResult; stdcall;

This item has no description.

function EditStreamClone(pavi: IAVISTREAM; var ppResult: IAVISTREAM): HResult; stdcall;

This item has no description.

function EditStreamSetNameA(pavi: IAVISTREAM; lpszName: LPCSTR): HResult; stdcall;

This item has no description.

function EditStreamSetNameW(pavi: IAVISTREAM; lpszName: LPCWSTR): HResult; stdcall;

This item has no description.

function EditStreamSetInfoW(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOW; cbInfo: LONG): HResult; stdcall;

This item has no description.

function EditStreamSetInfoA(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOA; cbInfo: LONG): HResult; stdcall;

This item has no description.

function EditStreamSetInfo(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOA; cbInfo: LONG): HResult; stdcall;

This item has no description.

function EditStreamSetName(pavi: IAVISTREAM; lpszName: LPCSTR): HResult; stdcall;

EditStreamSetInfoA

function MCIWndSM(hWnd: HWND; Msg: UINT; wParam: WPARAM; lParam: LPARAM): DWORD;

MCIWnd

MCIWnd window class header file.

the MCIWnd window class is a window class for controling MCI devices MCI devices include, wave files, midi files, AVI Video, cd audio, vcr, video disc, and others..

to learn more about MCI and mci command sets see the "Microsoft Multimedia Programmers's guide" in the Win31 SDK

the easiest use of the MCIWnd class is like so:

hwnd = MCIWndCreate(hwndParent, hInstance, 0, "chimes.wav"); ... MCIWndPlay(hwnd); MCIWndStop(hwnd); MCIWndPause(hwnd); .... MCIWndDestroy(hwnd);

this will create a window with a play/pause, stop and a playbar and start the wave file playing.

mciwnd.h defines macros for all the most common MCI commands, but any string command can be used if needed.

Note: unlike the mciSendString() API, no alias or file name needs to be specifed, since the device to use is implied by the window handle.

MCIWndSendString(hwnd, "setaudio stream to 2");

(C) Copyright Microsoft Corp. 1991-1995. All rights reserved.

WIN32:

MCIWnd supports both ansi and unicode interfaces. For any message that takes or returns a text string, two versions of the message are defined, appended with A or W for Ansi or Wide Char. The message or api itself is defined to be one or other of these depending on whether you have UNICODE defined in your application. Thus for the api MCIWndCreate, there are in fact two apis, MCIWndCreateA and MCIWndCreateW. If you call MCIWndCreate, this will be re-routed to MCIWndCreateA unless UNICODE is defined when building your application. In any one application, you can mix calls to the Ansi and Unicode entrypoints.

If you use SendMessage instead of the macros below such as MCIWndOpen(), you will see that the messages have changed for WIN32, to support Ansi and Unicode entrypoints. In particular, MCI_OPEN has been replaced by MCWNDM_OPENA, or MCIWNDM_OPENW (MCIWNDM_OPEN is defined to be one or other of these).

Also, note that the WIN32 implementation of MCIWnd uses UNICODE so all apis and messages supporting ANSI strings do so by mapping them UNICODE strings and then calling the corresponding UNICODE entrypoint.

function MCIWndCreateA(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCSTR): HWND; cdecl;

This item has no description.

function MCIWndCreateW(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCWSTR): HWND; cdecl;

This item has no description.

function MCIWndCreate(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCSTR): HWND; cdecl;

This item has no description.

function MCIWndRegisterClass: BOOL; cdecl;

MCIWndCreateA

function MCIWndCanPlay(hwnd: HWND): BOOL;

– Can macros —————————————————————

function MCIWndCanRecord(hwnd: HWND): BOOL;

This item has no description.

function MCIWndCanSave(hwnd: HWND): BOOL;

This item has no description.

function MCIWndCanWindow(hwnd: HWND): BOOL;

This item has no description.

function MCIWndCanEject(hwnd: HWND): BOOL;

This item has no description.

function MCIWndCanConfig(hwnd: HWND): BOOL;

This item has no description.

function MCIWndPaletteKick(hwnd: HWND): BOOL;

This item has no description.

function MCIWndSave(hwnd: HWND; szFile: LPCSTR): DWORD;

This item has no description.

function MCIWndSaveDialog(hwnd: HWND): DWORD;

This item has no description.

function MCIWndNew(hwnd: HWND; lp: PVOID): DWORD;

If you dont give a device it will use the current device....

function MCIWndRecord(hwnd: HWND): DWORD;

This item has no description.

function MCIWndOpen(hwnd: HWND; sz: LPCSTR; f: BOOL): DWORD;

This item has no description.

function MCIWndOpenDialog(hwnd: HWND): DWORD;

This item has no description.

function MCIWndClose(hwnd: HWND): DWORD;

This item has no description.

function MCIWndPlay(hwnd: HWND): DWORD;

This item has no description.

function MCIWndStop(hwnd: HWND): DWORD;

This item has no description.

function MCIWndPause(hwnd: HWND): DWORD;

This item has no description.

function MCIWndResume(hwnd: HWND): DWORD;

This item has no description.

function MCIWndSeek(hwnd: HWND; lPos: DWORD): DWORD;

This item has no description.

function MCIWndEject(hwnd: HWND): DWORD;

This item has no description.

function MCIWndHome(hwnd: HWND): DWORD;

This item has no description.

function MCIWndEnd(hwnd: HWND): DWORD;

This item has no description.

function MCIWndGetSource(hwnd: HWND; prc: PRECT): DWORD;

This item has no description.

function MCIWndPutSource(hwnd: HWND; prc: PRECT): DWORD;

This item has no description.

function MCIWndGetDest(hwnd: HWND; prc: PRECT): DWORD;

This item has no description.

function MCIWndPutDest(hwnd: HWND; prc: PRECT): DWORD;

This item has no description.

function MCIWndPlayReverse(hwnd: HWND): DWORD;

This item has no description.

function MCIWndPlayFrom(hwnd: HWND; lPos: DWORD): DWORD;

This item has no description.

function MCIWndPlayTo(hwnd: HWND; lPos: DWORD): DWORD;

This item has no description.

function MCIWndPlayFromTo(hwnd: HWND; lStart, lEnd: DWORD): DWORD;

This item has no description.

function MCIWndGetDeviceID(hwnd: HWND): UINT;

This item has no description.

function MCIWndGetAlias(hwnd: HWND): UINT;

This item has no description.

function MCIWndGetMode(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;

This item has no description.

function MCIWndGetPosition(hwnd: HWND): DWORD;

This item has no description.

function MCIWndGetPositionString(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;

This item has no description.

function MCIWndGetStart(hwnd: HWND): DWORD;

This item has no description.

function MCIWndGetLength(hwnd: HWND): DWORD;

This item has no description.

function MCIWndGetEnd(hwnd: HWND): DWORD;

This item has no description.

function MCIWndStep(hwnd: HWND; n: DWORD): DWORD;

This item has no description.

procedure MCIWndDestroy(hwnd: HWND);

This item has no description.

procedure MCIWndSetZoom(hwnd: HWND; iZoom: UINT);

This item has no description.

function MCIWndGetZoom(hwnd: HWND): UINT;

This item has no description.

function MCIWndSetVolume(hwnd: HWND; iVol: UINT): DWORD;

This item has no description.

function MCIWndGetVolume(hwnd: HWND): DWORD;

This item has no description.

function MCIWndSetSpeed(hwnd: HWND; iSpeed: UINT): DWORD;

This item has no description.

function MCIWndGetSpeed(hwnd: HWND): DWORD;

This item has no description.

function MCIWndSetTimeFormat(hwnd: HWND; lp: LPCSTR): DWORD;

This item has no description.

function MCIWndGetTimeFormat(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;

This item has no description.

procedure MCIWndValidateMedia(hwnd: HWND);

This item has no description.

procedure MCIWndSetRepeat(hwnd: HWND; f: BOOL);

This item has no description.

function MCIWndGetRepeat(hwnd: HWND): BOOL;

This item has no description.

function MCIWndUseFrames(hwnd: HWND): DWORD;

This item has no description.

function MCIWndUseTime(hwnd: HWND): DWORD;

This item has no description.

procedure MCIWndSetActiveTimer(hwnd: HWND; active: UINT);

This item has no description.

procedure MCIWndSetInactiveTimer(hwnd: HWND; inactive: UINT);

This item has no description.

procedure MCIWndSetTimers(hwnd: HWND; active, inactive: UINT);

This item has no description.

function MCIWndGetActiveTimer(hwnd: HWND): UINT;

This item has no description.

function MCIWndGetInactiveTimer(hwnd: HWND): UINT;

This item has no description.

function MCIWndRealize(hwnd: HWND; fBkgnd: BOOL): DWORD;

This item has no description.

function MCIWndSendString(hwnd: HWND; sz: LPCSTR): DWORD;

This item has no description.

function MCIWndReturnString(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;

This item has no description.

function MCIWndGetError(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;

This item has no description.

function MCIWndGetPalette(hwnd: HWND): HPALETTE;

#define MCIWndActivate(hwnd, f) (void)MCIWndSM(hwnd, WM_ACTIVATE, (WPARAM)(BOOL)(f), 0)

function MCIWndSetPalette(hwnd: HWND; hpal: HPALETTE): DWORD;

This item has no description.

function MCIWndGetFileName(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;

This item has no description.

function MCIWndGetDevice(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;

This item has no description.

function MCIWndGetStyles(hwnd: HWND): UINT;

This item has no description.

function MCIWndChangeStyles(hwnd: HWND; mask: UINT; value: DWORD): DWORD;

This item has no description.

function MCIWndOpenInterface(hwnd: HWND; pUnk: PUnknown): DWORD;

This item has no description.

function MCIWndSetOwner(hwnd: HWND; hwndP: HWND): DWORD;

This item has no description.

function AVICapSM(hwnd: HWND; m: UINT; w: WPARAM; l: LPARAM): DWORD;

== AVICAP - Window class for AVI capture ====================================

function capSetCallbackOnError(hwnd: HWND; fpProc: TCAPERRORCALLBACK): BOOL;

message wrapper macros are defined for the default messages only. Apps that wish to mix Ansi and UNICODE message sending will have to reference the _A and _W messages directly

function capSetCallbackOnStatus(hwnd: HWND; fpProc: TCAPSTATUSCALLBACK): BOOL;

This item has no description.

function capSetCallbackOnYield(hwnd: HWND; fpProc: TCAPYIELDCALLBACK): BOOL;

This item has no description.

function capSetCallbackOnFrame(hwnd: HWND; fpProc: TCAPVIDEOCALLBACK): BOOL;

This item has no description.

function capSetCallbackOnVideoStream(hwnd: HWND; fpProc: TCAPVIDEOCALLBACK): BOOL;

This item has no description.

function capSetCallbackOnWaveStream(hwnd: HWND; fpProc: TCAPWAVECALLBACK): BOOL;

This item has no description.

function capSetCallbackOnCapControl(hwnd: HWND; fpProc: TCAPCONTROLCALLBACK): BOOL;

This item has no description.

function capSetUserData(hwnd: HWND; lUser: DWORD): BOOL;

This item has no description.

function capGetUserData(hwnd: HWND): DWORD;

This item has no description.

function capDriverConnect(hwnd: HWND; i: INT): BOOL;

This item has no description.

function capDriverDisconnect(hwnd: HWND): BOOL;

This item has no description.

function capDriverGetName(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;

This item has no description.

function capDriverGetVersion(hwnd: HWND; szVer: LPSTR; wSize: WORD): BOOL;

This item has no description.

function capDriverGetCaps(hwnd: HWND; s: PCAPDRIVERCAPS; wSize: WORD): BOOL;

This item has no description.

function capFileSetCaptureFile(hwnd: HWND; szName: LPCSTR): BOOL;

This item has no description.

function capFileGetCaptureFile(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;

This item has no description.

function capFileAlloc(hwnd: HWND; dwSize: DWORD): BOOL;

This item has no description.

function capFileSaveAs(hwnd: HWND; szName: LPCSTR): BOOL;

This item has no description.

function capFileSetInfoChunk(hwnd: HWND; lpInfoChunk: PCAPINFOCHUNK): BOOL;

This item has no description.

function capFileSaveDIB(hwnd: HWND; szName: LPCSTR): BOOL;

This item has no description.

function capEditCopy(hwnd: HWND): BOOL;

This item has no description.

function capSetAudioFormat(hwnd: HWND; s: PWAVEFORMATEX; wSize: WORD): BOOL;

This item has no description.

function capGetAudioFormat(hwnd: HWND; s: PWAVEFORMATEX; wSize: WORD): DWORD;

This item has no description.

function capGetAudioFormatSize(hwnd: HWND): DWORD;

This item has no description.

function capDlgVideoFormat(hwnd: HWND): BOOL;

This item has no description.

function capDlgVideoSource(hwnd: HWND): BOOL;

This item has no description.

function capDlgVideoDisplay(hwnd: HWND): BOOL;

This item has no description.

function capDlgVideoCompression(hwnd: HWND): BOOL;

This item has no description.

function capGetVideoFormat(hwnd: HWND; s: PVOID; wSize: WORD): DWORD;

This item has no description.

function capGetVideoFormatSize(hwnd: HWND): DWORD;

This item has no description.

function capSetVideoFormat(hwnd: HWND; s: PVOID; wSize: WORD): BOOL;

This item has no description.

function capPreview(hwnd: HWND; f: BOOL): BOOL;

This item has no description.

function capPreviewRate(hwnd: HWND; wMS: WORD): BOOL;

This item has no description.

function capOverlay(hwnd: HWND; f: BOOL): BOOL;

This item has no description.

function capPreviewScale(hwnd: HWND; f: BOOL): BOOL;

This item has no description.

function capGetStatus(hwnd: HWND; s: PCAPSTATUS; wSize: WORD): BOOL;

This item has no description.

function capSetScrollPos(hwnd: HWND; lpP: PPOINT): BOOL;

This item has no description.

function capGrabFrame(hwnd: HWND): BOOL;

This item has no description.

function capGrabFrameNoStop(hwnd: HWND): BOOL;

This item has no description.

function capCaptureSequence(hwnd: HWND): BOOL;

This item has no description.

function capCaptureSequenceNoFile(hwnd: HWND): BOOL;

This item has no description.

function capCaptureStop(hwnd: HWND): BOOL;

This item has no description.

function capCaptureAbort(hwnd: HWND): BOOL;

This item has no description.

function capCaptureSingleFrameOpen(hwnd: HWND): BOOL;

This item has no description.

function capCaptureSingleFrameClose(hwnd: HWND): BOOL;

This item has no description.

function capCaptureSingleFrame(hwnd: HWND): BOOL;

This item has no description.

function capCaptureGetSetup(hwnd: HWND; s: PCAPTUREPARMS; wSize: WORD): BOOL;

This item has no description.

function capCaptureSetSetup(hwnd: HWND; s: PCAPTUREPARMS; wSize: WORD): BOOL;

This item has no description.

function capSetMCIDeviceName(hwnd: HWND; szName: LPCSTR): BOOL;

This item has no description.

function capGetMCIDeviceName(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;

This item has no description.

function capPaletteOpen(hwnd: HWND; szName: LPCSTR): BOOL;

This item has no description.

function capPaletteSave(hwnd: HWND; szName: LPCSTR): BOOL;

This item has no description.

function capPalettePaste(hwnd: HWND): BOOL;

This item has no description.

function capPaletteAuto(hwnd: HWND; iFrames, iColors: INT): BOOL;

This item has no description.

function capPaletteManual(hwnd: HWND; fGrab: BOOL; iColors: INT): BOOL;

This item has no description.

function capCreateCaptureWindowA( lpszWindowName : LPCSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;

– The only exported functions from AVICAP.DLL ——————————

function capGetDriverDescriptionA( wDriverIndex : UINT; lpszName : LPSTR; cbName : int; lpszVer : LPSTR; cbVer : int ): BOOL; stdcall;

This item has no description.

function capCreateCaptureWindowW( lpszWindowName : LPCWSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;

This item has no description.

function capGetDriverDescriptionW( wDriverIndex : UINT; lpszName : LPWSTR; cbName : int; lpszVer : LPWSTR; cbVer : int ): BOOL; stdcall;

This item has no description.

function capCreateCaptureWindow( lpszWindowName : LPCSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;

This item has no description.

function capGetDriverDescription( wDriverIndex : UINT; lpszName : LPSTR; cbName : int; lpszVer : LPSTR; cbVer : int ): BOOL; stdcall;

capCreateCaptureWindowA

function GetOpenFileNamePreviewA(lpofn: POPENFILENAMEA): BOOL; stdcall;

== FilePreview dialog =======================================================

function GetSaveFileNamePreviewA(lpofn: POPENFILENAMEA): BOOL; stdcall;

This item has no description.

function GetOpenFileNamePreviewW(lpofn: POPENFILENAMEW): BOOL; stdcall;

This item has no description.

function GetSaveFileNamePreviewW(lpofn: POPENFILENAMEW): BOOL; stdcall;

This item has no description.

function GetOpenFileNamePreview(lpofn: POPENFILENAMEA): BOOL; stdcall;

This item has no description.

function GetSaveFileNamePreview(lpofn: POPENFILENAMEA): BOOL; stdcall;

GetOpenFileNamePreviewA

Types

HDRAWDIB = THandle;

************************************************************************* * * DRAWDIB - Routines for drawing to the display. * ************************************************************************

HIC = THandle;

This item has no description.

HVIDEO = THandle;

== VIDEO - Video capture driver interface ===================================

int = integer;

This item has no description.

LONG = longint;

This item has no description.

PAVICOMPRESSOPTIONS = ˆTAVICOMPRESSOPTIONS;

Make sure it matches the AutoDoc in avisave.c !!!

PAVIFileInfo = ˆTAVIFileInfo;

This item has no description.

PAVIFileInfoA = ˆTAVIFileInfoA;

This item has no description.

PAVIFileInfoW = ˆTAVIFileInfoW;

– AVIFILEINFO ————————————————————–

PAVIINDEXENTRY = ˆTAVIINDEXENTRY;

these bits are for compressor use

PAVIPALCHANGE = ˆTAVIPALCHANGE;

– Palette change chunk (used in video streams) —————————–

PAVIStreamHeader = ˆTAVIStreamHeader;

This item has no description.

PAVIStreamInfo = ˆTAVIStreamInfo;

This item has no description.

PAVIStreamInfoA = ˆTAVIStreamInfoA;

This item has no description.

PAVIStreamInfoW = ˆTAVIStreamInfoW;

for Unicode/Ansi thunking we need to declare three versions of this!

PCAPDRIVERCAPS = ˆTCAPDRIVERCAPS;

– Structures —————————————————————

PCAPINFOCHUNK = ˆTCAPINFOCHUNK;

No master

PCAPSTATUS = ˆTCAPSTATUS;

This item has no description.

PCAPTUREPARMS = ˆTCAPTUREPARMS;

Default values in parenthesis

PCHANNEL_CAPS = ˆTCHANNEL_CAPS;

– Channel capabilities structure ——————————————-

PCOMPVARS = ˆTCOMPVARS;

Structure used by ICSeqCompressFrame and ICCompressorChoose routines Make sure this matches the autodoc in icm.c!

PDRAWDIBTIME = ˆTDRAWDIBTIME;

– DrawDibTime() - for debugging purposes only ——————————

PHVIDEO = ˆHVIDEO;

This item has no description.

PICCOMPRESS = ˆTICCOMPRESS;

This item has no description.

PICCOMPRESSFRAMES = ˆTICCOMPRESSFRAMES;

This item has no description.

PICDECOMPRESS = ˆTICDECOMPRESS;

this frame is not a key frame

PICDECOMPRESSEX = ˆTICDECOMPRESSEX;

This item has no description.

PICDRAW = ˆTICDRAW;

this frame is not a key frame

PICDRAWBEGIN = ˆTICDRAWBEGIN;

please buffer this data offscreen, we will need to update it

PICDRAWSUGGEST = ˆTICDRAWSUGGEST;

This item has no description.

PICINFO = ˆTICINFO;

*********************************************************************** ***********************************************************************

PICOPEN = ˆTICOPEN;

*********************************************************************** ***********************************************************************

PICPALETTE = ˆTICPALETTE;

*********************************************************************** ***********************************************************************

PICSETSTATUSPROC = ˆTICSETSTATUSPROC;

This item has no description.

PLONG = ˆLONG;

This item has no description.

PMainAVIHeader = ˆTMainAVIHeader;

size of AVI header list

PUnknown = ˆIUnknown;

This item has no description.

PVIDEOHDR = ˆTVIDEOHDR;

– Video data block header ————————————————–

PVOID = pointer;

*************************************************************************** * * types * **************************************************************************

TAVIFileInfo = TAVIFileInfoA;

This item has no description.

TAVISAVECALLBACK = function(i: int): BOOL; pascal;

This item has no description.

TAVIStreamInfo = TAVIStreamInfoA;

This item has no description.

TCAPCONTROLCALLBACK = function(hWnd: HWND; nState: int): DWORD; stdcall;

This item has no description.

TCAPERRORCALLBACK = TCAPERRORCALLBACKA;

This item has no description.

TCAPERRORCALLBACKA = function(hWnd: HWND; nID: int; lpsz: LPCSTR): DWORD; stdcall;

This item has no description.

TCAPERRORCALLBACKW = function(hWnd: HWND; nID: int; lpsz: LPCWSTR): DWORD; stdcall;

This item has no description.

TCAPSTATUSCALLBACK = TCAPSTATUSCALLBACKA;

This item has no description.

TCAPSTATUSCALLBACKA = function(hWnd: HWND; nID: int; lpsz: LPCSTR): DWORD; stdcall;

This item has no description.

TCAPSTATUSCALLBACKW = function(hWnd: HWND; nID: int; lpsz: LPCWSTR): DWORD; stdcall;

This item has no description.

TCAPVIDEOCALLBACK = function(hWnd: HWND; lpVHdr: PVIDEOHDR): DWORD; stdcall;

This item has no description.

TCAPWAVECALLBACK = function(hWnd: HWND; lpWHdr: PWAVEHDR): DWORD; stdcall;

This item has no description.

TCAPYIELDCALLBACK = function(hWnd: HWND): DWORD; stdcall;

– Callback definitions —————————————————–

TICCompressProc = function(lInputOutput: LPARAM; lFrame: DWORD; lpBits: PVOID; len: LONG): LONG; stdcall;

This item has no description.

TICStatusProc = function(lParam: LPARAM; message: UINT; l: LONG): LONG; stdcall;

return nonzero means abort operation in progress

TWOCC = word;

This item has no description.

Constants

ICVERSION = $0104 ;

*************************************************************************** * * COMPMAN - Installable Compression Manager. * ***************************************************************************

BI_1632 = $32333631;

Handle to an Installable Compressor

this code in biCompression means the DIB must be accesed via 48 bit pointers! using *ONLY* the selector given.

ICTYPE_VIDEO = $63646976;

This item has no description.

ICTYPE_AUDIO = $63647561;

vidc

ICERR_OK = 0 ;

audc

ICERR_DONTDRAW = 1 ;

This item has no description.

ICERR_NEWPALETTE = 2 ;

This item has no description.

ICERR_GOTOKEYFRAME = 3 ;

This item has no description.

ICERR_STOPDRAWING = 4 ;

This item has no description.

ICERR_UNSUPPORTED = -1 ;

This item has no description.

ICERR_BADFORMAT = -2 ;

This item has no description.

ICERR_MEMORY = -3 ;

This item has no description.

ICERR_INTERNAL = -4 ;

This item has no description.

ICERR_BADFLAGS = -5 ;

This item has no description.

ICERR_BADPARAM = -6 ;

This item has no description.

ICERR_BADSIZE = -7 ;

This item has no description.

ICERR_BADHANDLE = -8 ;

This item has no description.

ICERR_CANTUPDATE = -9 ;

This item has no description.

ICERR_ABORT = -10 ;

This item has no description.

ICERR_ERROR = -100 ;

This item has no description.

ICERR_BADBITDEPTH = -200 ;

This item has no description.

ICERR_BADIMAGESIZE = -201 ;

This item has no description.

ICERR_CUSTOM = -400 ;

This item has no description.

ICMODE_COMPRESS = 1 ;

– Values for dwFlags of ICOpen() ——————————————-

ICMODE_DECOMPRESS = 2 ;

This item has no description.

ICMODE_FASTDECOMPRESS = 3 ;

This item has no description.

ICMODE_QUERY = 4 ;

This item has no description.

ICMODE_FASTCOMPRESS = 5 ;

This item has no description.

ICMODE_DRAW = 8 ;

This item has no description.

AVIIF_LIST = $00000001 ;

– Flags for AVI file index ————————————————-

AVIIF_TWOCC = $00000002 ;

This item has no description.

AVIIF_KEYFRAME = $00000010 ;

This item has no description.

ICQUALITY_LOW = 0 ;

– quality flags ————————————————————

ICQUALITY_HIGH = 10000 ;

This item has no description.

ICQUALITY_DEFAULT = -1 ;

This item has no description.

ICM_USER = (DRV_USER+$0000) ;

*********************************************************************** ***********************************************************************

ICM_RESERVED_LOW = (DRV_USER+$1000) ;

This item has no description.

ICM_RESERVED_HIGH = (DRV_USER+$2000) ;

This item has no description.

ICM_RESERVED = ICM_RESERVED_LOW ;

This item has no description.

ICM_GETSTATE = (ICM_RESERVED+0) ;

***********************************************************************

messages.

***********************************************************************

ICM_SETSTATE = (ICM_RESERVED+1) ;

Get compressor state

ICM_GETINFO = (ICM_RESERVED+2) ;

Set compressor state

ICM_CONFIGURE = (ICM_RESERVED+10);

Query info about the compressor

ICM_ABOUT = (ICM_RESERVED+11);

show the configure dialog

ICM_GETDEFAULTQUALITY = (ICM_RESERVED+30);

show the about box

ICM_GETQUALITY = (ICM_RESERVED+31);

get the default value for quality

ICM_SETQUALITY = (ICM_RESERVED+32);

get the current value for quality

ICM_SET = (ICM_RESERVED+40);

set the default value for quality

ICM_GET = (ICM_RESERVED+41);

Tell the driver something

ICM_FRAMERATE = $526D7246;

– Constants for ICM_SET: —————————————————

ICM_KEYFRAMERATE = $5279654B;

FrmR

ICM_COMPRESS_GET_FORMAT = (ICM_USER+4) ;

***********************************************************************

ICM specific messages.

***********************************************************************

ICM_COMPRESS_GET_SIZE = (ICM_USER+5) ;

get compress format or size

ICM_COMPRESS_QUERY = (ICM_USER+6) ;

get output size

ICM_COMPRESS_BEGIN = (ICM_USER+7) ;

query support for compress

ICM_COMPRESS = (ICM_USER+8) ;

begin a series of compress calls.

ICM_COMPRESS_END = (ICM_USER+9) ;

compress a frame

ICM_DECOMPRESS_GET_FORMAT = (ICM_USER+10) ;

end of a series of compress calls.

ICM_DECOMPRESS_QUERY = (ICM_USER+11) ;

get decompress format or size

ICM_DECOMPRESS_BEGIN = (ICM_USER+12) ;

query support for dempress

ICM_DECOMPRESS = (ICM_USER+13) ;

start a series of decompress calls

ICM_DECOMPRESS_END = (ICM_USER+14) ;

decompress a frame

ICM_DECOMPRESS_SET_PALETTE = (ICM_USER+29) ;

end a series of decompress calls

ICM_DECOMPRESS_GET_PALETTE = (ICM_USER+30) ;

fill in the DIB color table

ICM_DRAW_QUERY = (ICM_USER+31) ;

fill in the DIB color table

ICM_DRAW_BEGIN = (ICM_USER+15) ;

query support for dempress

ICM_DRAW_GET_PALETTE = (ICM_USER+16) ;

start a series of draw calls

ICM_DRAW_START = (ICM_USER+18) ;

get the palette needed for drawing

ICM_DRAW_STOP = (ICM_USER+19) ;

start decompress clock

ICM_DRAW_END = (ICM_USER+21) ;

stop decompress clock

ICM_DRAW_GETTIME = (ICM_USER+32) ;

end a series of draw calls

ICM_DRAW = (ICM_USER+33) ;

get value of decompress clock

ICM_DRAW_WINDOW = (ICM_USER+34) ;

generalized "render" message

ICM_DRAW_SETTIME = (ICM_USER+35) ;

drawing window has moved or hidden

ICM_DRAW_REALIZE = (ICM_USER+36) ;

set correct value for decompress clock

ICM_DRAW_FLUSH = (ICM_USER+37) ;

realize palette for drawing

ICM_DRAW_RENDERBUFFER = (ICM_USER+38) ;

clear out buffered frames

ICM_DRAW_START_PLAY = (ICM_USER+39) ;

draw undrawn things in queue

ICM_DRAW_STOP_PLAY = (ICM_USER+40) ;

start of a play

ICM_DRAW_SUGGESTFORMAT = (ICM_USER+50) ;

end of a play

ICM_DRAW_CHANGEPALETTE = (ICM_USER+51) ;

Like ICGetDisplayFormat

ICM_GETBUFFERSWANTED = (ICM_USER+41) ;

for animating palette

ICM_GETDEFAULTKEYFRAMERATE = (ICM_USER+42) ;

ask about prebuffering

ICM_DECOMPRESSEX_BEGIN = (ICM_USER+60) ;

get the default value for key frames

ICM_DECOMPRESSEX_QUERY = (ICM_USER+61) ;

start a series of decompress calls

ICM_DECOMPRESSEX = (ICM_USER+62) ;

start a series of decompress calls

ICM_DECOMPRESSEX_END = (ICM_USER+63) ;

decompress a frame

ICM_COMPRESS_FRAMES_INFO = (ICM_USER+70) ;

end a series of decompress calls

ICM_SET_STATUS_PROC = (ICM_USER+72) ;

tell about compress to come

VIDCF_QUALITY = $0001 ;

– Flags for the <dwFlags> field of the <ICINFO> structure. ————

VIDCF_CRUNCH = $0002 ;

supports quality

VIDCF_TEMPORAL = $0004 ;

supports crunching to a frame size

VIDCF_COMPRESSFRAMES = $0008 ;

supports inter-frame compress

VIDCF_DRAW = $0010 ;

wants the compress all frames message

VIDCF_FASTTEMPORALC = $0020 ;

supports drawing

VIDCF_FASTTEMPORALD = $0080 ;

does not need prev frame on compress

ICCOMPRESS_KEYFRAME = $00000001;

*********************************************************************** ***********************************************************************

ICCOMPRESSFRAMES_PADDING = $00000001 ;

*********************************************************************** ***********************************************************************

ICSTATUS_START = 0 ;

– Messages for Status callback ———————————————

ICSTATUS_STATUS = 1 ;

This item has no description.

ICSTATUS_END = 2 ;

l = % done

ICSTATUS_ERROR = 3 ;

This item has no description.

ICSTATUS_YIELD = 4 ;

l = error string (LPSTR)

ICDECOMPRESS_HURRYUP = $80000000 ;

*********************************************************************** ***********************************************************************

ICDECOMPRESS_UPDATE = $40000000 ;

don't draw just buffer (hurry up!)

ICDECOMPRESS_PREROLL = $20000000 ;

don't draw just update screen

ICDECOMPRESS_NULLFRAME = $10000000 ;

this frame is before real start

ICDECOMPRESS_NOTKEYFRAME = $08000000 ;

repeat last frame

ICDRAW_QUERY = $00000001 ;

*********************************************************************** ***********************************************************************

ICDRAW_FULLSCREEN = $00000002 ;

test for support

ICDRAW_HDC = $00000004 ;

draw to full screen

ICDRAW_ANIMATE = $00000008 ;

draw to a HDC/HWND

ICDRAW_CONTINUE = $00000010 ;

expect palette animation

ICDRAW_MEMORYDC = $00000020 ;

draw is a continuation of previous draw

ICDRAW_UPDATING = $00000040 ;

DC is offscreen, by the way

ICDRAW_RENDER = $00000080 ;

We're updating, as opposed to playing

ICDRAW_BUFFER = $00000100 ;

used to render data not draw it

ICDRAW_HURRYUP = $80000000 ;

*********************************************************************** ***********************************************************************

ICDRAW_UPDATE = $40000000 ;

don't draw just buffer (hurry up!)

ICDRAW_PREROLL = $20000000 ;

don't draw just update screen

ICDRAW_NULLFRAME = $10000000 ;

this frame is before real start

ICDRAW_NOTKEYFRAME = $08000000 ;

repeat last frame

ICINSTALL_UNICODE = $8000 ;

– Values for wFlags of ICInstall ——————————————-

ICINSTALL_FUNCTION = $0001 ;

This item has no description.

ICINSTALL_DRIVER = $0002 ;

lParam is a DriverProc (function ptr)

ICINSTALL_HDRV = $0004 ;

lParam is a driver name (string)

ICINSTALL_DRIVERW = $8002 ;

lParam is a HDRVR (driver handle)

ICMF_CONFIGURE_QUERY = $00000001 ;

– Query macros ————————————————————-

ICMF_ABOUT_QUERY = $00000001 ;

This item has no description.

ICMF_COMPVARS_VALID = $00000001;

FLAGS for dwFlags element of COMPVARS structure: set this flag if you initialize COMPVARS before calling ICCompressorChoose

ICMF_CHOOSE_KEYFRAME = $0001;

defines for uiFlags

ICMF_CHOOSE_DATARATE = $0002;

show KeyFrame Every box

ICMF_CHOOSE_PREVIEW = $0004;

show DataRate box

ICMF_CHOOSE_ALLCOMPRESSORS = $0008;

allow expanded preview dialog

DDF_UPDATE = $0002;

********************************************************************

DrawDib Flags

*********************************************************************

DDF_SAME_HDC = $0004;

re-draw the last DIB

DDF_SAME_DRAW = $0008;

HDC same as last call (all setup)

DDF_DONTDRAW = $0010;

draw params are the same

DDF_ANIMATE = $0020;

dont draw frame, just decompress

DDF_BUFFER = $0040;

allow palette animation

DDF_JUSTDRAWIT = $0080;

always buffer image

DDF_FULLSCREEN = $0100;

just draw it with GDI

DDF_BACKGROUNDPAL = $0200;

use DisplayDib

DDF_NOTKEYFRAME = $0400;

Realize palette in background

DDF_HURRYUP = $0800;

this is a partial frame update, hint

DDF_HALFTONE = $1000;

hurry up please!

DDF_PREROLL = DDF_DONTDRAW;

always halftone

DDF_SAME_DIB = DDF_SAME_DRAW;

Builing up a non-keyframe

DDF_SAME_SIZE = DDF_SAME_DRAW;

This item has no description.

PD_CAN_DRAW_DIB = $0001;

– Display profiling ——————————————————–

PD_CAN_STRETCHDIB = $0002;

if you can draw at all

PD_STRETCHDIB_1_1_OK = $0004;

basicly RC_STRETCHDIB

PD_STRETCHDIB_1_2_OK = $0008;

is it fast?

PD_STRETCHDIB_1_N_OK = $0010;

...

formtypeAVI = $20495641;

– form types, list types and chunk types ———————————–

listtypeAVIHEADER = $6C726468;

mmioFOURCC('A', 'V', 'I', ' ')

ckidAVIMAINHDR = $68697661;

mmioFOURCC('h', 'd', 'r', 'l')

listtypeSTREAMHEADER = $6C727473;

mmioFOURCC('a', 'v', 'i', 'h')

ckidSTREAMHEADER = $68727473;

mmioFOURCC('s', 't', 'r', 'l')

ckidSTREAMFORMAT = $66727473;

mmioFOURCC('s', 't', 'r', 'h')

ckidSTREAMHANDLERDATA = $64727473;

mmioFOURCC('s', 't', 'r', 'f')

ckidSTREAMNAME = $6E727473;

mmioFOURCC('s', 't', 'r', 'd')

listtypeAVIMOVIE = $69766F6D;

mmioFOURCC('s', 't', 'r', 'n')

listtypeAVIRECORD = $20636572;

mmioFOURCC('m', 'o', 'v', 'i')

ckidAVINEWINDEX = $31786469;

mmioFOURCC('r', 'e', 'c', ' ')

streamtypeVIDEO = $73646976;

– Stream types for the <fccType> field of the stream header —————-

streamtypeAUDIO = $73647561;

mmioFOURCC('v', 'i', 'd', 's')

streamtypeMIDI = $7364696D;

mmioFOURCC('a', 'u', 'd', 's')

streamtypeTEXT = $73747874;

mmioFOURCC('m', 'i', 'd', 's')

cktypeDIBbits = $6264;

– Basic chunk types ——————————————————–

cktypeDIBcompressed = $6364;

aviTWOCC('d', 'b')

cktypePALchange = $6370;

aviTWOCC('d', 'c')

cktypeWAVEbytes = $6277;

aviTWOCC('p', 'c')

ckidAVIPADDING = $4B4E554A;

– Chunk id to use for extra chunks for padding —————————–

AVIF_HASINDEX = $00000010;

– flags for use in <dwFlags> in AVIFileHdr ———————————

AVIF_MUSTUSEINDEX = $00000020;

Index at end of file?

AVIF_ISINTERLEAVED = $00000100;

This item has no description.

AVIF_TRUSTCKTYPE = $00000800;

This item has no description.

AVIF_WASCAPTUREFILE = $00010000;

Use CKType to find key frames?

AVIF_COPYRIGHTED = $00020000;

This item has no description.

AVI_HEADERSIZE = 2048;

– The AVI File Header LIST chunk should be padded to this size ————-

AVISF_DISABLED = $00000001;

– Stream header ————————————————————

AVISF_VIDEO_PALCHANGES = $00010000;

This item has no description.

AVIIF_NOTIME = $00000100;

– Flags for index ———————————————————-

AVIIF_COMPUSE = $0FFF0000;

this frame doesn't take any time

AVIGETFRAMEF_BESTDISPLAYFMT = 1;

Ansi - Unicode thunking.

Unicode or Ansi-only apps can call the avifile APIs. any Win32 app who wants to use any of the AVI COM interfaces must be UNICODE - the AVISTREAMINFO and AVIFILEINFO structures used in the Info methods of these interfaces are the unicode variants, and no thunking to or from ansi takes place except in the AVIFILE api entrypoints.

For Ansi/Unicode thunking: for each entrypoint or structure that uses chars or strings, two versions are declared in the Win32 version, ApiNameW and ApiNameA. The default name ApiName is #defined to one or other of these depending on whether UNICODE is defined (during compilation of the app that is including this header). The source will contain ApiName and ApiNameA (with ApiName being the Win16 implementation, and also #defined to ApiNameW, and ApiNameA being the thunk entrypoint).

For GetFrame::SetFormat - use the best format for the display

AVISTREAMINFO_DISABLED = $00000001;

This item has no description.

AVISTREAMINFO_FORMATCHANGES = $00010000;

This item has no description.

AVIFILEINFO_HASINDEX = $00000010;

– Flags for dwFlags ——————————————————–

AVIFILEINFO_MUSTUSEINDEX = $00000020;

This item has no description.

AVIFILEINFO_ISINTERLEAVED = $00000100;

This item has no description.

AVIFILEINFO_WASCAPTUREFILE = $00010000;

This item has no description.

AVIFILEINFO_COPYRIGHTED = $00020000;

This item has no description.

AVIFILECAPS_CANREAD = $00000001;

– Flags for dwCaps ———————————————————

AVIFILECAPS_CANWRITE = $00000002;

This item has no description.

AVIFILECAPS_ALLKEYFRAMES = $00000010;

This item has no description.

AVIFILECAPS_NOCOMPRESSION = $00000020;

This item has no description.

AVICOMPRESSF_INTERLEAVE = $00000001;

Defines for the dwFlags field of the AVICOMPRESSOPTIONS struct Each of these flags determines if the appropriate field in the structure (dwInterleaveEvery, dwBytesPerSecond, and dwKeyFrameEvery) is payed attention to. See the autodoc in avisave.c for details.

AVICOMPRESSF_DATARATE = $00000002;

interleave

AVICOMPRESSF_KEYFRAMES = $00000004;

use a data rate

AVICOMPRESSF_VALID = $00000008;

use keyframes

IID_IAVIFile : TGUID = (D1: $00020020; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));

– GUIDs ——————————————————————–

IID_IAVIStream : TGUID = (D1: $00020021; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));

This item has no description.

IID_IAVIStreaming : TGUID = (D1: $00020022; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));

This item has no description.

IID_IGetFrame : TGUID = (D1: $00020023; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));

This item has no description.

IID_IAVIEditStream: TGUID = (D1: $00020024; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));

This item has no description.

CLSID_AVISimpleUnMarshal : TGUID = (D1: $00020009; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));

This item has no description.

CLSID_AVIFile : TGUID = (D1: $00020000; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));

This item has no description.

AVIFILEHANDLER_CANREAD = $0001;

This item has no description.

AVIFILEHANDLER_CANWRITE = $0002;

This item has no description.

AVIFILEHANDLER_CANACCEPTNONRGB = $0004;

This item has no description.

AVISTREAMREAD_CONVENIENT = -1;

This item has no description.

FIND_DIR = $0000000F;

– Flags for AVIStreamFindSample ——————————————–

FIND_NEXT = $00000001;

direction

FIND_PREV = $00000004;

go forward

FIND_FROM_START = $00000008;

go backward

FIND_TYPE = $000000F0;

start at the logical beginning

FIND_KEY = $00000010;

type mask

FIND_ANY = $00000020;

find key frame.

FIND_FORMAT = $00000040;

find any (non-empty) sample

FIND_RET = $0000F000;

find format change

FIND_POS = $00000000;

return mask

FIND_LENGTH = $00001000;

return logical position

FIND_OFFSET = $00002000;

return logical size

FIND_SIZE = $00003000;

return physical position

FIND_INDEX = $00004000;

return physical size

SEARCH_NEAREST = FIND_PREV;

AVIFileExit

SEARCH_BACKWARD = FIND_PREV;

This item has no description.

SEARCH_FORWARD = FIND_NEXT;

This item has no description.

SEARCH_KEY = FIND_KEY;

This item has no description.

SEARCH_ANY = FIND_ANY;

This item has no description.

comptypeDIB = $20424944;

== AVISave routines and structures ==========================================

AVIERR_OK = 0;

– Error handling ———————————————————–

AVIERR_UNSUPPORTED = $80044065;

!!! Questions to be answered: How can you get a string form of these errors? Which of these errors should be replaced by errors in SCODE.H?

AVIERR_BADFORMAT = $80044066;

MAKE_AVIERR(101)

AVIERR_MEMORY = $80044067;

MAKE_AVIERR(102)

AVIERR_INTERNAL = $80044068;

MAKE_AVIERR(103)

AVIERR_BADFLAGS = $80044069;

MAKE_AVIERR(104)

AVIERR_BADPARAM = $8004406A;

MAKE_AVIERR(105)

AVIERR_BADSIZE = $8004406B;

MAKE_AVIERR(106)

AVIERR_BADHANDLE = $8004406C;

MAKE_AVIERR(107)

AVIERR_FILEREAD = $8004406D;

MAKE_AVIERR(108)

AVIERR_FILEWRITE = $8004406E;

MAKE_AVIERR(109)

AVIERR_FILEOPEN = $8004406F;

MAKE_AVIERR(110)

AVIERR_COMPRESSOR = $80044070;

MAKE_AVIERR(111)

AVIERR_NOCOMPRESSOR = $80044071;

MAKE_AVIERR(112)

AVIERR_READONLY = $80044072;

MAKE_AVIERR(113)

AVIERR_NODATA = $80044073;

MAKE_AVIERR(114)

AVIERR_BUFFERTOOSMALL = $80044074;

MAKE_AVIERR(115)

AVIERR_CANTCOMPRESS = $80044075;

MAKE_AVIERR(116)

AVIERR_USERABORT = $800440C6;

MAKE_AVIERR(117)

AVIERR_ERROR = $800440C7;

MAKE_AVIERR(198)

MCIWND_WINDOW_CLASS = 'MCIWndClass' ;

This item has no description.

MCIWNDOPENF_NEW = $0001;

– Flags for the MCIWndOpen command —————————————–

MCIWNDF_NOAUTOSIZEWINDOW = $0001;

– Window styles ————————————————————

MCIWNDF_NOPLAYBAR = $0002;

when movie size changes

MCIWNDF_NOAUTOSIZEMOVIE = $0004;

no toolbar

MCIWNDF_NOMENU = $0008;

when window size changes

MCIWNDF_SHOWNAME = $0010;

no popup menu from RBUTTONDOWN

MCIWNDF_SHOWPOS = $0020;

show name in caption

MCIWNDF_SHOWMODE = $0040;

show position in caption

MCIWNDF_SHOWALL = $0070;

show mode in caption

MCIWNDF_NOTIFYMODE = $0100;

show all

MCIWNDF_NOTIFYPOS = $0200;

tell parent of mode change

MCIWNDF_NOTIFYSIZE = $0400;

tell parent of pos change

MCIWNDF_NOTIFYERROR = $1000;

tell parent of size change

MCIWNDF_NOTIFYALL = $1F00;

tell parent of an error

MCIWNDF_NOTIFYANSI = $0080;

tell all

MCIWNDF_NOTIFYMEDIAA = $0880;

The MEDIA notification includes a text string. To receive notifications in ANSI instead of unicode set the MCIWNDF_NOTIFYANSI style bit. The macro below includes this bit by default unless you define UNICODE in your application.

MCIWNDF_NOTIFYMEDIAW = $0800;

tell parent of media change

MCIWNDF_NOTIFYMEDIA = MCIWNDF_NOTIFYMEDIAA;

tell parent of media change

MCIWNDF_RECORD = $2000;

This item has no description.

MCIWNDF_NOERRORDLG = $4000;

Give a record button

MCIWNDF_NOOPEN = $8000;

Show Error Dlgs for MCI cmds?

MCIWNDM_GETDEVICEID = WM_USER + 100;

all the text-related messages are defined out of order above (they need to be defined before the MCIWndOpen() macros

MCIWNDM_GETSTART = WM_USER + 103;

This item has no description.

MCIWNDM_GETLENGTH = WM_USER + 104;

This item has no description.

MCIWNDM_GETEND = WM_USER + 105;

This item has no description.

MCIWNDM_EJECT = WM_USER + 107;

This item has no description.

MCIWNDM_SETZOOM = WM_USER + 108;

This item has no description.

MCIWNDM_GETZOOM = WM_USER + 109;

This item has no description.

MCIWNDM_SETVOLUME = WM_USER + 110;

This item has no description.

MCIWNDM_GETVOLUME = WM_USER + 111;

This item has no description.

MCIWNDM_SETSPEED = WM_USER + 112;

This item has no description.

MCIWNDM_GETSPEED = WM_USER + 113;

This item has no description.

MCIWNDM_SETREPEAT = WM_USER + 114;

This item has no description.

MCIWNDM_GETREPEAT = WM_USER + 115;

This item has no description.

MCIWNDM_REALIZE = WM_USER + 118;

This item has no description.

MCIWNDM_VALIDATEMEDIA = WM_USER + 121;

This item has no description.

MCIWNDM_PLAYFROM = WM_USER + 122;

This item has no description.

MCIWNDM_PLAYTO = WM_USER + 123;

This item has no description.

MCIWNDM_GETPALETTE = WM_USER + 126;

This item has no description.

MCIWNDM_SETPALETTE = WM_USER + 127;

This item has no description.

MCIWNDM_SETTIMERS = WM_USER + 129;

This item has no description.

MCIWNDM_SETACTIVETIMER = WM_USER + 130;

This item has no description.

MCIWNDM_SETINACTIVETIMER = WM_USER + 131;

This item has no description.

MCIWNDM_GETACTIVETIMER = WM_USER + 132;

This item has no description.

MCIWNDM_GETINACTIVETIMER = WM_USER + 133;

This item has no description.

MCIWNDM_CHANGESTYLES = WM_USER + 135;

This item has no description.

MCIWNDM_GETSTYLES = WM_USER + 136;

This item has no description.

MCIWNDM_GETALIAS = WM_USER + 137;

This item has no description.

MCIWNDM_PLAYREVERSE = WM_USER + 139;

This item has no description.

MCIWNDM_GET_SOURCE = WM_USER + 140;

This item has no description.

MCIWNDM_PUT_SOURCE = WM_USER + 141;

This item has no description.

MCIWNDM_GET_DEST = WM_USER + 142;

This item has no description.

MCIWNDM_PUT_DEST = WM_USER + 143;

This item has no description.

MCIWNDM_CAN_PLAY = WM_USER + 144;

This item has no description.

MCIWNDM_CAN_WINDOW = WM_USER + 145;

This item has no description.

MCIWNDM_CAN_RECORD = WM_USER + 146;

This item has no description.

MCIWNDM_CAN_SAVE = WM_USER + 147;

This item has no description.

MCIWNDM_CAN_EJECT = WM_USER + 148;

This item has no description.

MCIWNDM_CAN_CONFIG = WM_USER + 149;

This item has no description.

MCIWNDM_PALETTEKICK = WM_USER + 150;

This item has no description.

MCIWNDM_OPENINTERFACE = WM_USER + 151;

This item has no description.

MCIWNDM_SETOWNER = WM_USER + 152;

This item has no description.

MCIWNDM_SENDSTRINGA = WM_USER + 101;

– Define both A and W messages ———————————————

MCIWNDM_GETPOSITIONA = WM_USER + 102;

This item has no description.

MCIWNDM_GETMODEA = WM_USER + 106;

This item has no description.

MCIWNDM_SETTIMEFORMATA = WM_USER + 119;

This item has no description.

MCIWNDM_GETTIMEFORMATA = WM_USER + 120;

This item has no description.

MCIWNDM_GETFILENAMEA = WM_USER + 124;

This item has no description.

MCIWNDM_GETDEVICEA = WM_USER + 125;

This item has no description.

MCIWNDM_GETERRORA = WM_USER + 128;

This item has no description.

MCIWNDM_NEWA = WM_USER + 134;

This item has no description.

MCIWNDM_RETURNSTRINGA = WM_USER + 138;

This item has no description.

MCIWNDM_OPENA = WM_USER + 153;

This item has no description.

MCIWNDM_SENDSTRINGW = WM_USER + 201;

This item has no description.

MCIWNDM_GETPOSITIONW = WM_USER + 202;

This item has no description.

MCIWNDM_GETMODEW = WM_USER + 206;

This item has no description.

MCIWNDM_SETTIMEFORMATW = WM_USER + 219;

This item has no description.

MCIWNDM_GETTIMEFORMATW = WM_USER + 220;

This item has no description.

MCIWNDM_GETFILENAMEW = WM_USER + 224;

This item has no description.

MCIWNDM_GETDEVICEW = WM_USER + 225;

This item has no description.

MCIWNDM_GETERRORW = WM_USER + 228;

This item has no description.

MCIWNDM_NEWW = WM_USER + 234;

This item has no description.

MCIWNDM_RETURNSTRINGW = WM_USER + 238;

This item has no description.

MCIWNDM_OPENW = WM_USER + 252;

This item has no description.

MCIWNDM_SENDSTRING = MCIWNDM_SENDSTRINGA;

– Map defaults to A ——————————————————–

MCIWNDM_GETPOSITION = MCIWNDM_GETPOSITIONA;

This item has no description.

MCIWNDM_GETMODE = MCIWNDM_GETMODEA;

This item has no description.

MCIWNDM_SETTIMEFORMAT = MCIWNDM_SETTIMEFORMATA;

This item has no description.

MCIWNDM_GETTIMEFORMAT = MCIWNDM_GETTIMEFORMATA;

This item has no description.

MCIWNDM_GETFILENAME = MCIWNDM_GETFILENAMEA;

This item has no description.

MCIWNDM_GETDEVICE = MCIWNDM_GETDEVICEA;

This item has no description.

MCIWNDM_GETERROR = MCIWNDM_GETERRORA;

This item has no description.

MCIWNDM_NEW = MCIWNDM_NEWA;

This item has no description.

MCIWNDM_RETURNSTRING = MCIWNDM_RETURNSTRINGA;

This item has no description.

MCIWNDM_OPEN = MCIWNDM_OPENA;

This item has no description.

MCIWNDM_NOTIFYMODE = WM_USER + 200;

– Messages MCIWND will send to an app ————————————–

MCIWNDM_NOTIFYPOS = WM_USER + 201;

wp = hwnd, lp = mode

MCIWNDM_NOTIFYSIZE = WM_USER + 202;

wp = hwnd, lp = pos

MCIWNDM_NOTIFYMEDIA = WM_USER + 203;

wp = hwnd

MCIWNDM_NOTIFYERROR = WM_USER + 205;

wp = hwnd, lp = fn

MCIWND_START = dword(-1) ;

– Special seek values for START and END ————————————

MCIWND_END = dword(-2) ;

This item has no description.

DV_ERR_OK = 0;

– Error return values ——————————————————

DV_ERR_BASE = 1;

No error

DV_ERR_NONSPECIFIC = DV_ERR_BASE;

Error Base

DV_ERR_BADFORMAT = DV_ERR_BASE + 1;

This item has no description.

DV_ERR_STILLPLAYING = DV_ERR_BASE + 2;

unsupported video format

DV_ERR_UNPREPARED = DV_ERR_BASE + 3;

still something playing

DV_ERR_SYNC = DV_ERR_BASE + 4;

header not prepared

DV_ERR_TOOMANYCHANNELS = DV_ERR_BASE + 5;

device is synchronous

DV_ERR_NOTDETECTED = DV_ERR_BASE + 6;

number of channels exceeded

DV_ERR_BADINSTALL = DV_ERR_BASE + 7;

HW not detected

DV_ERR_CREATEPALETTE = DV_ERR_BASE + 8;

Can not get Profile

DV_ERR_SIZEFIELD = DV_ERR_BASE + 9;

This item has no description.

DV_ERR_PARAM1 = DV_ERR_BASE + 10;

This item has no description.

DV_ERR_PARAM2 = DV_ERR_BASE + 11;

This item has no description.

DV_ERR_CONFIG1 = DV_ERR_BASE + 12;

This item has no description.

DV_ERR_CONFIG2 = DV_ERR_BASE + 13;

This item has no description.

DV_ERR_FLAGS = DV_ERR_BASE + 14;

This item has no description.

DV_ERR_13 = DV_ERR_BASE + 15;

This item has no description.

DV_ERR_NOTSUPPORTED = DV_ERR_BASE + 16;

This item has no description.

DV_ERR_NOMEM = DV_ERR_BASE + 17;

function not suported

DV_ERR_ALLOCATED = DV_ERR_BASE + 18;

out of memory

DV_ERR_BADDEVICEID = DV_ERR_BASE + 19;

device is allocated

DV_ERR_INVALHANDLE = DV_ERR_BASE + 20;

This item has no description.

DV_ERR_BADERRNUM = DV_ERR_BASE + 21;

This item has no description.

DV_ERR_NO_BUFFERS = DV_ERR_BASE + 22;

This item has no description.

DV_ERR_MEM_CONFLICT = DV_ERR_BASE + 23;

out of buffers

DV_ERR_IO_CONFLICT = DV_ERR_BASE + 24;

Mem conflict detected

DV_ERR_DMA_CONFLICT = DV_ERR_BASE + 25;

I/O conflict detected

DV_ERR_INT_CONFLICT = DV_ERR_BASE + 26;

DMA conflict detected

DV_ERR_PROTECT_ONLY = DV_ERR_BASE + 27;

Interrupt conflict detected

DV_ERR_LASTERROR = DV_ERR_BASE + 27;

Can not run in standard mode

DV_ERR_USER_MSG = DV_ERR_BASE + 1000;

This item has no description.

DV_VM_OPEN = MM_DRVM_OPEN;

Note that the values for all installable driver callback messages are identical, (ie. MM_DRVM_DATA has the same value for capture drivers, installable video codecs, and the audio compression manager).

DV_VM_CLOSE = MM_DRVM_CLOSE;

Obsolete messages

DV_VM_DATA = MM_DRVM_DATA;

This item has no description.

DV_VM_ERROR = MM_DRVM_ERROR;

This item has no description.

VHDR_DONE = $00000001;

– dwFlags field of VIDEOHDR ————————————————

VHDR_PREPARED = $00000002;

Done bit

VHDR_INQUEUE = $00000004;

Set if this header has been prepared

VHDR_KEYFRAME = $00000008;

Reserved for driver

VCAPS_OVERLAY = $00000001;

– dwFlags of CHANNEL_CAPS ————————————————–

VCAPS_SRC_CAN_CLIP = $00000002;

overlay channel

VCAPS_DST_CAN_CLIP = $00000004;

src rect can clip

VCAPS_CAN_SCALE = $00000008;

dst rect can clip

VIDEO_EXTERNALIN = $0001;

– Types of channels to open with the videoOpen function ——————–

VIDEO_EXTERNALOUT = $0002;

This item has no description.

VIDEO_IN = $0004;

This item has no description.

VIDEO_OUT = $0008;

This item has no description.

VIDEO_DLG_QUERY = $0010;

– Is a driver dialog available for this channel —————————-

VIDEO_CONFIGURE_QUERY = $8000;

– videoConfigure (both GET and SET) —————————————-

VIDEO_CONFIGURE_SET = $1000;

– videoConfigure (SET only) ————————————————

VIDEO_CONFIGURE_GET = $2000;

– videoConfigure (GET only) ————————————————

VIDEO_CONFIGURE_QUERYSIZE = $0001;

This item has no description.

VIDEO_CONFIGURE_CURRENT = $0010;

This item has no description.

VIDEO_CONFIGURE_NOMINAL = $0020;

This item has no description.

VIDEO_CONFIGURE_MIN = $0040;

This item has no description.

VIDEO_CONFIGURE_MAX = $0080;

This item has no description.

DVM_USER = $4000;

== Configure messages =======================================================

DVM_CONFIGURE_START = $1000;

This item has no description.

DVM_CONFIGURE_END = $1FFF;

This item has no description.

DVM_PALETTE = DVM_CONFIGURE_START + 1;

This item has no description.

DVM_FORMAT = DVM_CONFIGURE_START + 2;

This item has no description.

DVM_PALETTERGB555 = DVM_CONFIGURE_START + 3;

This item has no description.

DVM_SRC_RECT = DVM_CONFIGURE_START + 4;

This item has no description.

DVM_DST_RECT = DVM_CONFIGURE_START + 5;

This item has no description.

WM_CAP_START = WM_USER;

UNICODE

The Win32 version of AVICAP on NT supports UNICODE applications: for each API or message that takes a char or string parameter, there are two versions, ApiNameA and ApiNameW. The default name ApiName is #defined to one or other depending on whether UNICODE is defined. Apps can call the A and W apis directly, and mix them.

The 32-bit AVICAP on NT uses unicode exclusively internally. ApiNameA() will be implemented as a call to ApiNameW() together with translation of strings. Defines start of the message range

WM_CAP_UNICODE_START = WM_USER + 100;

This item has no description.

WM_CAP_GET_CAPSTREAMPTR = WM_CAP_START + 1;

This item has no description.

WM_CAP_SET_CALLBACK_ERRORW = WM_CAP_UNICODE_START + 2;

This item has no description.

WM_CAP_SET_CALLBACK_STATUSW = WM_CAP_UNICODE_START + 3;

This item has no description.

WM_CAP_SET_CALLBACK_ERRORA = WM_CAP_START + 2;

This item has no description.

WM_CAP_SET_CALLBACK_STATUSA = WM_CAP_START + 3;

This item has no description.

WM_CAP_SET_CALLBACK_ERROR = WM_CAP_SET_CALLBACK_ERRORA;

This item has no description.

WM_CAP_SET_CALLBACK_STATUS = WM_CAP_SET_CALLBACK_STATUSA;

This item has no description.

WM_CAP_SET_CALLBACK_YIELD = WM_CAP_START + 4;

This item has no description.

WM_CAP_SET_CALLBACK_FRAME = WM_CAP_START + 5;

This item has no description.

WM_CAP_SET_CALLBACK_VIDEOSTREAM = WM_CAP_START + 6;

This item has no description.

WM_CAP_SET_CALLBACK_WAVESTREAM = WM_CAP_START + 7;

This item has no description.

WM_CAP_GET_USER_DATA = WM_CAP_START + 8;

This item has no description.

WM_CAP_SET_USER_DATA = WM_CAP_START + 9;

This item has no description.

WM_CAP_DRIVER_CONNECT = WM_CAP_START + 10;

This item has no description.

WM_CAP_DRIVER_DISCONNECT = WM_CAP_START + 11;

This item has no description.

WM_CAP_DRIVER_GET_NAMEA = WM_CAP_START + 12;

This item has no description.

WM_CAP_DRIVER_GET_VERSIONA = WM_CAP_START + 13;

This item has no description.

WM_CAP_DRIVER_GET_NAMEW = WM_CAP_UNICODE_START + 12;

This item has no description.

WM_CAP_DRIVER_GET_VERSIONW = WM_CAP_UNICODE_START + 13;

This item has no description.

WM_CAP_DRIVER_GET_NAME = WM_CAP_DRIVER_GET_NAMEA;

This item has no description.

WM_CAP_DRIVER_GET_VERSION = WM_CAP_DRIVER_GET_VERSIONA;

This item has no description.

WM_CAP_DRIVER_GET_CAPS = WM_CAP_START + 14;

This item has no description.

WM_CAP_FILE_SET_CAPTURE_FILEA = WM_CAP_START + 20;

This item has no description.

WM_CAP_FILE_GET_CAPTURE_FILEA = WM_CAP_START + 21;

This item has no description.

WM_CAP_FILE_SAVEASA = WM_CAP_START + 23;

This item has no description.

WM_CAP_FILE_SAVEDIBA = WM_CAP_START + 25;

This item has no description.

WM_CAP_FILE_SET_CAPTURE_FILEW = WM_CAP_UNICODE_START + 20;

This item has no description.

WM_CAP_FILE_GET_CAPTURE_FILEW = WM_CAP_UNICODE_START + 21;

This item has no description.

WM_CAP_FILE_SAVEASW = WM_CAP_UNICODE_START + 23;

This item has no description.

WM_CAP_FILE_SAVEDIBW = WM_CAP_UNICODE_START + 25;

This item has no description.

WM_CAP_FILE_SET_CAPTURE_FILE = WM_CAP_FILE_SET_CAPTURE_FILEA;

This item has no description.

WM_CAP_FILE_GET_CAPTURE_FILE = WM_CAP_FILE_GET_CAPTURE_FILEA;

This item has no description.

WM_CAP_FILE_SAVEAS = WM_CAP_FILE_SAVEASA;

This item has no description.

WM_CAP_FILE_SAVEDIB = WM_CAP_FILE_SAVEDIBA;

This item has no description.

WM_CAP_FILE_ALLOCATE = WM_CAP_START + 22;

out of order to save on ifdefs

WM_CAP_FILE_SET_INFOCHUNK = WM_CAP_START + 24;

This item has no description.

WM_CAP_EDIT_COPY = WM_CAP_START + 30;

This item has no description.

WM_CAP_SET_AUDIOFORMAT = WM_CAP_START + 35;

This item has no description.

WM_CAP_GET_AUDIOFORMAT = WM_CAP_START + 36;

This item has no description.

WM_CAP_DLG_VIDEOFORMAT = WM_CAP_START + 41;

This item has no description.

WM_CAP_DLG_VIDEOSOURCE = WM_CAP_START + 42;

This item has no description.

WM_CAP_DLG_VIDEODISPLAY = WM_CAP_START + 43;

This item has no description.

WM_CAP_GET_VIDEOFORMAT = WM_CAP_START + 44;

This item has no description.

WM_CAP_SET_VIDEOFORMAT = WM_CAP_START + 45;

This item has no description.

WM_CAP_DLG_VIDEOCOMPRESSION = WM_CAP_START + 46;

This item has no description.

WM_CAP_SET_PREVIEW = WM_CAP_START + 50;

This item has no description.

WM_CAP_SET_OVERLAY = WM_CAP_START + 51;

This item has no description.

WM_CAP_SET_PREVIEWRATE = WM_CAP_START + 52;

This item has no description.

WM_CAP_SET_SCALE = WM_CAP_START + 53;

This item has no description.

WM_CAP_GET_STATUS = WM_CAP_START + 54;

This item has no description.

WM_CAP_SET_SCROLL = WM_CAP_START + 55;

This item has no description.

WM_CAP_GRAB_FRAME = WM_CAP_START + 60;

This item has no description.

WM_CAP_GRAB_FRAME_NOSTOP = WM_CAP_START + 61;

This item has no description.

WM_CAP_SEQUENCE = WM_CAP_START + 62;

This item has no description.

WM_CAP_SEQUENCE_NOFILE = WM_CAP_START + 63;

This item has no description.

WM_CAP_SET_SEQUENCE_SETUP = WM_CAP_START + 64;

This item has no description.

WM_CAP_GET_SEQUENCE_SETUP = WM_CAP_START + 65;

This item has no description.

WM_CAP_SET_MCI_DEVICEA = WM_CAP_START + 66;

This item has no description.

WM_CAP_GET_MCI_DEVICEA = WM_CAP_START + 67;

This item has no description.

WM_CAP_SET_MCI_DEVICEW = WM_CAP_UNICODE_START + 66;

This item has no description.

WM_CAP_GET_MCI_DEVICEW = WM_CAP_UNICODE_START + 67;

This item has no description.

WM_CAP_SET_MCI_DEVICE = WM_CAP_SET_MCI_DEVICEA;

This item has no description.

WM_CAP_GET_MCI_DEVICE = WM_CAP_GET_MCI_DEVICEA;

This item has no description.

WM_CAP_STOP = WM_CAP_START + 68;

This item has no description.

WM_CAP_ABORT = WM_CAP_START + 69;

This item has no description.

WM_CAP_SINGLE_FRAME_OPEN = WM_CAP_START + 70;

This item has no description.

WM_CAP_SINGLE_FRAME_CLOSE = WM_CAP_START + 71;

This item has no description.

WM_CAP_SINGLE_FRAME = WM_CAP_START + 72;

This item has no description.

WM_CAP_PAL_OPENA = WM_CAP_START + 80;

This item has no description.

WM_CAP_PAL_SAVEA = WM_CAP_START + 81;

This item has no description.

WM_CAP_PAL_OPENW = WM_CAP_UNICODE_START + 80;

This item has no description.

WM_CAP_PAL_SAVEW = WM_CAP_UNICODE_START + 81;

This item has no description.

WM_CAP_PAL_OPEN = WM_CAP_PAL_OPENA;

This item has no description.

WM_CAP_PAL_SAVE = WM_CAP_PAL_SAVEA;

This item has no description.

WM_CAP_PAL_PASTE = WM_CAP_START + 82;

This item has no description.

WM_CAP_PAL_AUTOCREATE = WM_CAP_START + 83;

This item has no description.

WM_CAP_PAL_MANUALCREATE = WM_CAP_START + 84;

This item has no description.

WM_CAP_SET_CALLBACK_CAPCONTROL = WM_CAP_START + 85;

Following added post VFW 1.1

WM_CAP_UNICODE_END = WM_CAP_PAL_SAVEW;

Defines end of the message range

WM_CAP_END = WM_CAP_UNICODE_END;

This item has no description.

AVSTREAMMASTER_AUDIO = 0;

Since Audio and Video streams generally use non-synchronized capture clocks, this flag determines whether the audio stream is to be considered the master or controlling clock when writing the AVI file:

AVSTREAMMASTER_AUDIO - Audio is master, video frame duration is forced to match audio duration (VFW 1.0, 1.1 default) AVSTREAMMASTER_NONE - No master, audio and video streams may be of different lengths

AVSTREAMMASTER_NONE = 1;

Audio master (VFW 1.0, 1.1)

CONTROLCALLBACK_PREROLL = 1;

– CapControlCallback states ————————————————

CONTROLCALLBACK_CAPTURING = 2;

Waiting to start capture

infotypeDIGITIZATION_TIME = $54494449;

– New information chunk IDs ————————————————

infotypeSMPTE_TIME = $504D5349;

mmioFOURCC ('I','D','I','T')

IDS_CAP_BEGIN = 300;

– String IDs from status and error callbacks ——————————-

IDS_CAP_END = 301;

"Capture Start"

IDS_CAP_INFO = 401;

"Capture End"

IDS_CAP_OUTOFMEM = 402;

"%s"

IDS_CAP_FILEEXISTS = 403;

"Out of memory"

IDS_CAP_ERRORPALOPEN = 404;

"File '%s' exists – overwrite it?"

IDS_CAP_ERRORPALSAVE = 405;

"Error opening palette '%s'"

IDS_CAP_ERRORDIBSAVE = 406;

"Error saving palette '%s'"

IDS_CAP_DEFAVIEXT = 407;

"Error saving frame '%s'"

IDS_CAP_DEFPALEXT = 408;

"avi"

IDS_CAP_CANTOPEN = 409;

"pal"

IDS_CAP_SEQ_MSGSTART = 410;

"Cannot open '%s'"

IDS_CAP_SEQ_MSGSTOP = 411;

"Select OK to start capture\nof video sequence\nto %s."

IDS_CAP_VIDEDITERR = 412;

"Hit ESCAPE or click to end capture"

IDS_CAP_READONLYFILE = 413;

"An error occurred while trying to run VidEdit."

IDS_CAP_WRITEERROR = 414;

"The file '%s' is a read-only file."

IDS_CAP_NODISKSPACE = 415;

"Unable to write to file '%s'.\nDisk may be full."

IDS_CAP_SETFILESIZE = 416;

"There is no space to create a capture file on the specified device."

IDS_CAP_SAVEASPERCENT = 417;

"Set File Size"

IDS_CAP_DRIVER_ERROR = 418;

"SaveAs: %2ld%% Hit Escape to abort."

IDS_CAP_WAVE_OPEN_ERROR = 419;

Driver specific error message

IDS_CAP_WAVE_ALLOC_ERROR = 420;

"Error: Cannot open the wave input device.\nCheck sample size, frequency, and channels."

IDS_CAP_WAVE_PREPARE_ERROR = 421;

"Error: Out of memory for wave buffers."

IDS_CAP_WAVE_ADD_ERROR = 422;

"Error: Cannot prepare wave buffers."

IDS_CAP_WAVE_SIZE_ERROR = 423;

"Error: Cannot add wave buffers."

IDS_CAP_VIDEO_OPEN_ERROR = 424;

"Error: Bad wave size."

IDS_CAP_VIDEO_ALLOC_ERROR = 425;

"Error: Cannot open the video input device."

IDS_CAP_VIDEO_PREPARE_ERROR = 426;

"Error: Out of memory for video buffers."

IDS_CAP_VIDEO_ADD_ERROR = 427;

"Error: Cannot prepare video buffers."

IDS_CAP_VIDEO_SIZE_ERROR = 428;

"Error: Cannot add video buffers."

IDS_CAP_FILE_OPEN_ERROR = 429;

"Error: Bad video size."

IDS_CAP_FILE_WRITE_ERROR = 430;

"Error: Cannot open capture file."

IDS_CAP_RECORDING_ERROR = 431;

"Error: Cannot write to capture file. Disk may be full."

IDS_CAP_RECORDING_ERROR2 = 432;

"Error: Cannot write to capture file. Data rate too high or disk full."

IDS_CAP_AVI_INIT_ERROR = 433;

"Error while recording"

IDS_CAP_NO_FRAME_CAP_ERROR = 434;

"Error: Unable to initialize for capture."

IDS_CAP_NO_PALETTE_WARN = 435;

"Warning: No frames captured.\nConfirm that vertical sync interrupts\nare configured and enabled."

IDS_CAP_MCI_CONTROL_ERROR = 436;

"Warning: Using default palette."

IDS_CAP_MCI_CANT_STEP_ERROR = 437;

"Error: Unable to access MCI device."

IDS_CAP_NO_AUDIO_CAP_ERROR = 438;

"Error: Unable to step MCI device."

IDS_CAP_AVI_DRAWDIB_ERROR = 439;

"Error: No audio data captured.\nCheck audio card settings."

IDS_CAP_COMPRESSOR_ERROR = 440;

"Error: Unable to draw this data format."

IDS_CAP_AUDIO_DROP_ERROR = 441;

"Error: Unable to initialize compressor."

IDS_CAP_STAT_LIVE_MODE = 500;

– Status string IDs ——————————————————–

IDS_CAP_STAT_OVERLAY_MODE = 501;

"Live window"

IDS_CAP_STAT_CAP_INIT = 502;

"Overlay window"

IDS_CAP_STAT_CAP_FINI = 503;

"Setting up for capture - Please wait"

IDS_CAP_STAT_PALETTE_BUILD = 504;

"Finished capture, now writing frame %ld"

IDS_CAP_STAT_OPTPAL_BUILD = 505;

"Building palette map"

IDS_CAP_STAT_I_FRAMES = 506;

"Computing optimal palette"

IDS_CAP_STAT_L_FRAMES = 507;

"%d frames"

IDS_CAP_STAT_CAP_L_FRAMES = 508;

"%ld frames"

IDS_CAP_STAT_CAP_AUDIO = 509;

"Captured %ld frames"

IDS_CAP_STAT_VIDEOCURRENT = 510;

"Capturing audio"

IDS_CAP_STAT_VIDEOAUDIO = 511;

"Captured %ld frames (%ld dropped) %d.%03d sec."

IDS_CAP_STAT_VIDEOONLY = 512;

"Captured %d.%03d sec. %ld frames (%ld dropped) (%d.%03d fps). %ld audio bytes (%d,%03d sps)"

IDS_CAP_STAT_FRAMESDROPPED = 513;

"Captured %d.%03d sec. %ld frames (%ld dropped) (%d.%03d fps)"


GLSysHelp v.2.5: Formats.VFW: Packed Record TICOPEN

Packed Record TICOPEN

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICOPEN = packed record

Description

This item has no description.

Overview

Fields

Public | dwSize: DWORD ;
Public | fccType: DWORD ;
Public | fccHandler: DWORD ;
Public | dwVersion: DWORD ;
Public | dwFlags: DWORD ;
Public | dwError: DWORD ;
Public | pV1Reserved: PVOID ;
Public | pV2Reserved: PVOID ;
Public | dnDevNode: DWORD ;

Description

Fields

Public dwSize: DWORD ;

This item has no description.

Public fccType: DWORD ;

sizeof(ICOPEN)

Public fccHandler: DWORD ;

'vidc'

Public dwVersion: DWORD ;

This item has no description.

Public dwFlags: DWORD ;

version of compman opening you

Public dwError: DWORD ;

LOWORD is type specific

Public pV1Reserved: PVOID ;

error return.

Public pV2Reserved: PVOID ;

Reserved

Public dnDevNode: DWORD ;

Reserved


GLSysHelp v.2.5: Formats.VFW: Packed Record TICINFO

Packed Record TICINFO

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICINFO = packed record

Description

This item has no description.

Overview

Fields

Public | dwSize: DWORD;
Public | fccType: DWORD;
Public | fccHandler: DWORD;
Public | dwFlags: DWORD;
Public | dwVersion: DWORD;
Public | dwVersionICM: DWORD;
Public | szName: array[0..15] of WChar ;
Public | szDescription: array[0..127] of WChar ;
Public | szDriver: array[0..127] of WChar ;

Description

Fields

Public dwSize: DWORD;

This item has no description.

Public fccType: DWORD;

sizeof(ICINFO)

Public fccHandler: DWORD;

compressor type 'vidc' 'audc'

Public dwFlags: DWORD;

compressor sub-type 'rle ' 'jpeg' 'pcm '

Public dwVersion: DWORD;

flags LOWORD is type specific

Public dwVersionICM: DWORD;

version of the driver

Public szName: array[0..15] of WChar ;

version of the ICM used

under Win32, the driver always returns UNICODE strings.

Public szDescription: array[0..127] of WChar ;

short name

Public szDriver: array[0..127] of WChar ;

DWORD name


GLSysHelp v.2.5: Formats.VFW: Packed Record TICCOMPRESS

Packed Record TICCOMPRESS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICCOMPRESS = packed record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD;
Public | lpbiOutput: PBITMAPINFOHEADER ;
Public | lpOutput: PVOID ;
Public | lpbiInput: PBITMAPINFOHEADER ;
Public | lpInput: PVOID ;
Public | lpckid: PDWORD ;
Public | lpdwFlags: PDWORD;
Public | lFrameNum: LONG ;
Public | dwFrameSize: DWORD ;
Public | dwQuality: DWORD ;
Public | lpbiPrev: PBITMAPINFOHEADER ;
Public | lpPrev: PVOID ;

Description

Fields

Public dwFlags: DWORD;

This item has no description.

Public lpbiOutput: PBITMAPINFOHEADER ;

flags

Public lpOutput: PVOID ;

output format

Public lpbiInput: PBITMAPINFOHEADER ;

output data

Public lpInput: PVOID ;

format of frame to compress

Public lpckid: PDWORD ;

frame data to compress

Public lpdwFlags: PDWORD;

ckid for data in AVI file

Public lFrameNum: LONG ;

flags in the AVI index.

Public dwFrameSize: DWORD ;

frame number of seq.

Public dwQuality: DWORD ;

reqested size in bytes. (if non zero)

Public lpbiPrev: PBITMAPINFOHEADER ;

quality these are new fields

Public lpPrev: PVOID ;

format of previous frame


GLSysHelp v.2.5: Formats.VFW: Packed Record TICCOMPRESSFRAMES

Packed Record TICCOMPRESSFRAMES

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICCOMPRESSFRAMES = packed record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD ;
Public | lpbiOutput: PBITMAPINFOHEADER ;
Public | lOutput: LPARAM ;
Public | lpbiInput: PBITMAPINFOHEADER ;
Public | lInput: LPARAM ;
Public | lStartFrame: LONG ;
Public | lFrameCount: LONG ;
Public | lQuality: LONG ;
Public | lDataRate: LONG ;
Public | lKeyRate: LONG ;
Public | dwRate: DWORD ;
Public | dwScale: DWORD ;
Public | dwOverheadPerFrame: DWORD ;
Public | dwReserved2: DWORD ;
Public | GetData: TICCompressProc;
Public | PutData: TICCompressProc;

Description

Fields

Public dwFlags: DWORD ;

This item has no description.

Public lpbiOutput: PBITMAPINFOHEADER ;

flags

Public lOutput: LPARAM ;

output format

Public lpbiInput: PBITMAPINFOHEADER ;

output identifier

Public lInput: LPARAM ;

format of frame to compress

Public lStartFrame: LONG ;

input identifier

Public lFrameCount: LONG ;

start frame

Public lQuality: LONG ;

# of frames

Public lDataRate: LONG ;

quality

Public lKeyRate: LONG ;

data rate

Public dwRate: DWORD ;

key frame rate

Public dwScale: DWORD ;

frame rate, as always

Public dwOverheadPerFrame: DWORD ;

This item has no description.

Public dwReserved2: DWORD ;

This item has no description.

Public GetData: TICCompressProc;

This item has no description.

Public PutData: TICCompressProc;


GLSysHelp v.2.5: Formats.VFW: Packed Record TICSETSTATUSPROC

Packed Record TICSETSTATUSPROC

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICSETSTATUSPROC = packed record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD ;
Public | lParam: LPARAM ;
Public | Status: TICStatusProc;

Description

Fields

Public dwFlags: DWORD ;

This item has no description.

Public lParam: LPARAM ;

This item has no description.

Public Status: TICStatusProc;


GLSysHelp v.2.5: Formats.VFW: Packed Record TICDECOMPRESS

Packed Record TICDECOMPRESS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICDECOMPRESS = packed record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD ;
Public | lpbiInput: PBITMAPINFOHEADER ;
Public | lpInput: PVOID ;
Public | lpbiOutput: PBITMAPINFOHEADER ;
Public | lpOutput: PVOID ;
Public | ckid: DWORD ;

Description

Fields

Public dwFlags: DWORD ;

This item has no description.

Public lpbiInput: PBITMAPINFOHEADER ;

flags (from AVI index...)

Public lpInput: PVOID ;

BITMAPINFO of compressed data biSizeImage has the chunk size

Public lpbiOutput: PBITMAPINFOHEADER ;

compressed data

Public lpOutput: PVOID ;

DIB to decompress to

Public ckid: DWORD ;


GLSysHelp v.2.5: Formats.VFW: Packed Record TICDECOMPRESSEX

Packed Record TICDECOMPRESSEX

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICDECOMPRESSEX = packed record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD;
Public | lpbiSrc: PBITMAPINFOHEADER;
Public | lpSrc: PVOID;
Public | lpbiDst: PBITMAPINFOHEADER;
Public | lpDst: PVOID;
Public | xDst: int;
Public | yDst: int;
Public | dxDst: int;
Public | dyDst: int;
Public | xSrc: int;
Public | ySrc: int;
Public | dxSrc: int;
Public | dySrc: int;

Description

Fields

Public dwFlags: DWORD;

same as ICM_DECOMPRESS

Public lpbiSrc: PBITMAPINFOHEADER;

This item has no description.

Public lpSrc: PVOID;

BITMAPINFO of compressed data

Public lpbiDst: PBITMAPINFOHEADER;

compressed data

Public lpDst: PVOID;

DIB to decompress to

Public xDst: int;

output data

new for ICM_DECOMPRESSEX

Public yDst: int;

destination rectangle

Public dxDst: int;

This item has no description.

Public dyDst: int;

This item has no description.

Public xSrc: int;

This item has no description.

Public ySrc: int;

source rectangle

Public dxSrc: int;

This item has no description.

Public dySrc: int;


GLSysHelp v.2.5: Formats.VFW: Packed Record TICDRAWBEGIN

Packed Record TICDRAWBEGIN

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICDRAWBEGIN = packed record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD ;
Public | hpal: HPALETTE ;
Public | hwnd: HWND ;
Public | hdc: HDC ;
Public | xDst: int ;
Public | yDst: int ;
Public | dxDst: int ;
Public | dyDst: int ;
Public | lpbi: PBITMAPINFOHEADER ;
Public | xSrc: int ;
Public | ySrc: int ;
Public | dxSrc: int ;
Public | dySrc: int ;
Public | dwRate: DWORD ;
Public | dwScale: DWORD ;

Description

Fields

Public dwFlags: DWORD ;

This item has no description.

Public hpal: HPALETTE ;

flags

Public hwnd: HWND ;

palette to draw with

Public hdc: HDC ;

window to draw to

Public xDst: int ;

HDC to draw to

Public yDst: int ;

destination rectangle

Public dxDst: int ;

This item has no description.

Public dyDst: int ;

This item has no description.

Public lpbi: PBITMAPINFOHEADER ;

This item has no description.

Public xSrc: int ;

format of frame to draw

Public ySrc: int ;

source rectangle

Public dxSrc: int ;

This item has no description.

Public dySrc: int ;

This item has no description.

Public dwRate: DWORD ;

This item has no description.

Public dwScale: DWORD ;

frames/second = (dwRate/dwScale)


GLSysHelp v.2.5: Formats.VFW: Packed Record TICDRAW

Packed Record TICDRAW

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICDRAW = packed record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD ;
Public | lpFormat: PVOID ;
Public | lpData: PVOID ;
Public | cbData: DWORD ;
Public | lTime: LONG ;

Description

Fields

Public dwFlags: DWORD ;

This item has no description.

Public lpFormat: PVOID ;

flags

Public lpData: PVOID ;

format of frame to decompress

Public cbData: DWORD ;

frame data to decompress

Public lTime: LONG ;


GLSysHelp v.2.5: Formats.VFW: Packed Record TICDRAWSUGGEST

Packed Record TICDRAWSUGGEST

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICDRAWSUGGEST = packed record

Description

This item has no description.

Overview

Fields

Public | lpbiIn: PBITMAPINFOHEADER ;
Public | lpbiSuggest: PBITMAPINFOHEADER ;
Public | dxSrc: int ;
Public | dySrc: int ;
Public | dxDst: int ;
Public | dyDst: int ;
Public | hicDecompressor: HIC ;

Description

Fields

Public lpbiIn: PBITMAPINFOHEADER ;

This item has no description.

Public lpbiSuggest: PBITMAPINFOHEADER ;

format to be drawn

Public dxSrc: int ;

location for suggested format (or NULL to get size)

Public dySrc: int ;

source extent or 0

Public dxDst: int ;

This item has no description.

Public dyDst: int ;

dest extent or 0

Public hicDecompressor: HIC ;


GLSysHelp v.2.5: Formats.VFW: Packed Record TICPALETTE

Packed Record TICPALETTE

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TICPALETTE = packed record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD ;
Public | iStart: int ;
Public | iLen: int ;
Public | lppe: PPALETTEENTRY ;

Description

Fields

Public dwFlags: DWORD ;

This item has no description.

Public iStart: int ;

flags (from AVI index...)

Public iLen: int ;

first palette to change

Public lppe: PPALETTEENTRY ;

count of entries to change.


GLSysHelp v.2.5: Formats.VFW: Packed Record TCOMPVARS

Packed Record TCOMPVARS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TCOMPVARS = packed record

Description

This item has no description.

Overview

Fields

Public | cbSize: DWORD;
Public | dwFlags: DWORD;
Public | hic: HIC;
Public | fccType: DWORD;
Public | fccHandler: DWORD;
Public | lpbiIn: PBITMAPINFO;
Public | lpbiOut: PBITMAPINFO;
Public | lpBitsOut: PVOID;
Public | lpBitsPrev: PVOID;
Public | lFrame: LONG;
Public | lKey: LONG;
Public | lDataRate: LONG;
Public | lQ: LONG;
Public | lKeyCount: LONG;
Public | lpState: PVOID;
Public | cbState: LONG;

Description

Fields

Public cbSize: DWORD;

This item has no description.

Public dwFlags: DWORD;

set to sizeof(COMPVARS) before calling ICCompressorChoose

Public hic: HIC;

see below...

Public fccType: DWORD;

HIC of chosen compressor

Public fccHandler: DWORD;

basically ICTYPE_VIDEO

Public lpbiIn: PBITMAPINFO;

handler of chosen compressor or "" or "DIB "

Public lpbiOut: PBITMAPINFO;

input format

Public lpBitsOut: PVOID;

output format - will compress to this

Public lpBitsPrev: PVOID;

This item has no description.

Public lFrame: LONG;

This item has no description.

Public lKey: LONG;

This item has no description.

Public lDataRate: LONG;

key frames how often?

Public lQ: LONG;

desired data rate KB/Sec

Public lKeyCount: LONG;

desired quality

Public lpState: PVOID;

This item has no description.

Public cbState: LONG;

state of compressor


GLSysHelp v.2.5: Formats.VFW: Packed Record TDRAWDIBTIME

Packed Record TDRAWDIBTIME

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TDRAWDIBTIME = packed record

Description

This item has no description.

Overview

Fields

Public | timeCount: LONG;
Public | timeDraw: LONG;
Public | timeDecompress: LONG;
Public | timeDither: LONG;
Public | timeStretch: LONG;
Public | timeBlt: LONG;
Public | timeSetDIBits: LONG;

Description

Fields

Public timeCount: LONG;

This item has no description.

Public timeDraw: LONG;

This item has no description.

Public timeDecompress: LONG;

This item has no description.

Public timeDither: LONG;

This item has no description.

Public timeStretch: LONG;

This item has no description.

Public timeBlt: LONG;

This item has no description.

Public timeSetDIBits: LONG;


GLSysHelp v.2.5: Formats.VFW: Packed Record TMainAVIHeader

Packed Record TMainAVIHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TMainAVIHeader = packed record

Description

This item has no description.

Overview

Fields

Public | dwMicroSecPerFrame: DWORD;
Public | dwMaxBytesPerSec: DWORD;
Public | dwPaddingGranularity: DWORD;
Public | dwFlags: DWORD;
Public | dwTotalFrames: DWORD;
Public | dwInitialFrames: DWORD;
Public | dwStreams: DWORD;
Public | dwSuggestedBufferSize: DWORD;
Public | dwWidth: DWORD;
Public | dwHeight: DWORD;
Public | dwReserved: array[0..3] of DWORD;

Description

Fields

Public dwMicroSecPerFrame: DWORD;

This item has no description.

Public dwMaxBytesPerSec: DWORD;

frame display rate (or 0L)

Public dwPaddingGranularity: DWORD;

max. transfer rate

Public dwFlags: DWORD;

pad to multiples of this size; normally 2K.

Public dwTotalFrames: DWORD;

the ever-present flags

Public dwInitialFrames: DWORD;

# frames in file

Public dwStreams: DWORD;

This item has no description.

Public dwSuggestedBufferSize: DWORD;

This item has no description.

Public dwWidth: DWORD;

This item has no description.

Public dwHeight: DWORD;

This item has no description.

Public dwReserved: array[0..3] of DWORD;


GLSysHelp v.2.5: Formats.VFW: Packed Record TAVIStreamHeader

Packed Record TAVIStreamHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TAVIStreamHeader = packed record

Description

This item has no description.

Overview

Fields

Public | fccType: FOURCC;
Public | fccHandler: FOURCC;
Public | dwFlags: DWORD;
Public | wPriority: WORD;
Public | wLanguage: WORD;
Public | dwInitialFrames: DWORD;
Public | dwScale: DWORD;
Public | dwRate: DWORD;
Public | dwStart: DWORD;
Public | dwLength: DWORD;
Public | dwSuggestedBufferSize: DWORD;
Public | dwQuality: DWORD;
Public | dwSampleSize: DWORD;
Public | rcFrame: TRECT;

Description

Fields

Public fccType: FOURCC;

This item has no description.

Public fccHandler: FOURCC;

This item has no description.

Public dwFlags: DWORD;

This item has no description.

Public wPriority: WORD;

Contains AVITF_* flags

Public wLanguage: WORD;

This item has no description.

Public dwInitialFrames: DWORD;

This item has no description.

Public dwScale: DWORD;

This item has no description.

Public dwRate: DWORD;

This item has no description.

Public dwStart: DWORD;

dwRate / dwScale == samples/second

Public dwLength: DWORD;

This item has no description.

Public dwSuggestedBufferSize: DWORD;

In units above...

Public dwQuality: DWORD;

This item has no description.

Public dwSampleSize: DWORD;

This item has no description.

Public rcFrame: TRECT;


GLSysHelp v.2.5: Formats.VFW: Packed Record TAVIINDEXENTRY

Packed Record TAVIINDEXENTRY

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TAVIINDEXENTRY = packed record

Description

This item has no description.

Overview

Fields

Public | ckid: DWORD;
Public | dwFlags: DWORD;
Public | dwChunkOffset: DWORD;
Public | dwChunkLength: DWORD;

Description

Fields

Public ckid: DWORD;

This item has no description.

Public dwFlags: DWORD;

This item has no description.

Public dwChunkOffset: DWORD;

This item has no description.

Public dwChunkLength: DWORD;

Position of chunk


GLSysHelp v.2.5: Formats.VFW: Packed Record TAVIPALCHANGE

Packed Record TAVIPALCHANGE

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TAVIPALCHANGE = packed record

Description

This item has no description.

Overview

Fields

Public | bFirstEntry: BYTE;
Public | bNumEntries: BYTE;
Public | wFlags: WORD;
Public | peNew: array[0..0] of TPALETTEENTRY;

Description

Fields

Public bFirstEntry: BYTE;

This item has no description.

Public bNumEntries: BYTE;

first entry to change

Public wFlags: WORD;

# entries to change (0 if 256)

Public peNew: array[0..0] of TPALETTEENTRY;

Mostly to preserve alignment...


GLSysHelp v.2.5: Formats.VFW: Packed Record TAVIStreamInfoW

Packed Record TAVIStreamInfoW

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TAVIStreamInfoW = packed record

Description

This item has no description.

Overview

Fields

Public | fccType: DWORD;
Public | fccHandler: DWORD;
Public | dwFlags: DWORD;
Public | dwCaps: DWORD;
Public | wPriority: WORD;
Public | wLanguage: WORD;
Public | dwScale: DWORD;
Public | dwRate: DWORD;
Public | dwStart: DWORD;
Public | dwLength: DWORD;
Public | dwInitialFrames: DWORD;
Public | dwSuggestedBufferSize: DWORD;
Public | dwQuality: DWORD;
Public | dwSampleSize: DWORD;
Public | rcFrame: TRECT;
Public | dwEditCount: DWORD;
Public | dwFormatChangeCount: DWORD;
Public | szName: array[0..63] of WideChar;

Description

Fields

Public fccType: DWORD;

This item has no description.

Public fccHandler: DWORD;

This item has no description.

Public dwFlags: DWORD;

This item has no description.

Public dwCaps: DWORD;

Contains AVITF_* flags

Public wPriority: WORD;

This item has no description.

Public wLanguage: WORD;

This item has no description.

Public dwScale: DWORD;

This item has no description.

Public dwRate: DWORD;

This item has no description.

Public dwStart: DWORD;

dwRate / dwScale == samples/second

Public dwLength: DWORD;

This item has no description.

Public dwInitialFrames: DWORD;

In units above...

Public dwSuggestedBufferSize: DWORD;

This item has no description.

Public dwQuality: DWORD;

This item has no description.

Public dwSampleSize: DWORD;

This item has no description.

Public rcFrame: TRECT;

This item has no description.

Public dwEditCount: DWORD;

This item has no description.

Public dwFormatChangeCount: DWORD;

This item has no description.

Public szName: array[0..63] of WideChar;


GLSysHelp v.2.5: Formats.VFW: Packed Record TAVIStreamInfoA

Packed Record TAVIStreamInfoA

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TAVIStreamInfoA = packed record

Description

This item has no description.

Overview

Fields

Public | fccType: DWORD;
Public | fccHandler: DWORD;
Public | dwFlags: DWORD;
Public | dwCaps: DWORD;
Public | wPriority: WORD;
Public | wLanguage: WORD;
Public | dwScale: DWORD;
Public | dwRate: DWORD;
Public | dwStart: DWORD;
Public | dwLength: DWORD;
Public | dwInitialFrames: DWORD;
Public | dwSuggestedBufferSize: DWORD;
Public | dwQuality: DWORD;
Public | dwSampleSize: DWORD;
Public | rcFrame: TRECT;
Public | dwEditCount: DWORD;
Public | dwFormatChangeCount: DWORD;
Public | szName: array[0..63] of AnsiChar;

Description

Fields

Public fccType: DWORD;

This item has no description.

Public fccHandler: DWORD;

This item has no description.

Public dwFlags: DWORD;

This item has no description.

Public dwCaps: DWORD;

Contains AVITF_* flags

Public wPriority: WORD;

This item has no description.

Public wLanguage: WORD;

This item has no description.

Public dwScale: DWORD;

This item has no description.

Public dwRate: DWORD;

This item has no description.

Public dwStart: DWORD;

dwRate / dwScale == samples/second

Public dwLength: DWORD;

This item has no description.

Public dwInitialFrames: DWORD;

In units above...

Public dwSuggestedBufferSize: DWORD;

This item has no description.

Public dwQuality: DWORD;

This item has no description.

Public dwSampleSize: DWORD;

This item has no description.

Public rcFrame: TRECT;

This item has no description.

Public dwEditCount: DWORD;

This item has no description.

Public dwFormatChangeCount: DWORD;

This item has no description.

Public szName: array[0..63] of AnsiChar;


GLSysHelp v.2.5: Formats.VFW: Packed Record TAVIFileInfoW

Packed Record TAVIFileInfoW

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TAVIFileInfoW = packed record

Description

This item has no description.

Overview

Fields

Public | dwMaxBytesPerSec: DWORD;
Public | dwFlags: DWORD;
Public | dwCaps: DWORD;
Public | dwStreams: DWORD;
Public | dwSuggestedBufferSize: DWORD;
Public | dwWidth: DWORD;
Public | dwHeight: DWORD;
Public | dwScale: DWORD;
Public | dwRate: DWORD;
Public | dwLength: DWORD;
Public | dwEditCount: DWORD;
Public | szFileType: array[0..63] of WideChar;

Description

Fields

Public dwMaxBytesPerSec: DWORD;

This item has no description.

Public dwFlags: DWORD;

max. transfer rate

Public dwCaps: DWORD;

the ever-present flags

Public dwStreams: DWORD;

This item has no description.

Public dwSuggestedBufferSize: DWORD;

This item has no description.

Public dwWidth: DWORD;

This item has no description.

Public dwHeight: DWORD;

This item has no description.

Public dwScale: DWORD;

This item has no description.

Public dwRate: DWORD;

This item has no description.

Public dwLength: DWORD;

dwRate / dwScale == samples/second

Public dwEditCount: DWORD;

This item has no description.

Public szFileType: array[0..63] of WideChar;


GLSysHelp v.2.5: Formats.VFW: Packed Record TAVIFileInfoA

Packed Record TAVIFileInfoA

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TAVIFileInfoA = packed record

Description

This item has no description.

Overview

Fields

Public | dwMaxBytesPerSec: DWORD;
Public | dwFlags: DWORD;
Public | dwCaps: DWORD;
Public | dwStreams: DWORD;
Public | dwSuggestedBufferSize: DWORD;
Public | dwWidth: DWORD;
Public | dwHeight: DWORD;
Public | dwScale: DWORD;
Public | dwRate: DWORD;
Public | dwLength: DWORD;
Public | dwEditCount: DWORD;
Public | szFileType: array[0..63] of AnsiChar;

Description

Fields

Public dwMaxBytesPerSec: DWORD;

This item has no description.

Public dwFlags: DWORD;

max. transfer rate

Public dwCaps: DWORD;

the ever-present flags

Public dwStreams: DWORD;

This item has no description.

Public dwSuggestedBufferSize: DWORD;

This item has no description.

Public dwWidth: DWORD;

This item has no description.

Public dwHeight: DWORD;

This item has no description.

Public dwScale: DWORD;

This item has no description.

Public dwRate: DWORD;

This item has no description.

Public dwLength: DWORD;

dwRate / dwScale == samples/second

Public dwEditCount: DWORD;

This item has no description.

Public szFileType: array[0..63] of AnsiChar;


GLSysHelp v.2.5: Formats.VFW: Packed Record TAVICOMPRESSOPTIONS

Packed Record TAVICOMPRESSOPTIONS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TAVICOMPRESSOPTIONS = packed record

Description

This item has no description.

Overview

Fields

Public | fccType: DWORD;
Public | fccHandler: DWORD;
Public | dwKeyFrameEvery: DWORD;
Public | dwQuality: DWORD;
Public | dwBytesPerSecond: DWORD;
Public | dwFlags: DWORD;
Public | lpFormat: PVOID;
Public | cbFormat: DWORD;
Public | lpParms: PVOID;
Public | cbParms: DWORD;
Public | dwInterleaveEvery: DWORD;

Description

Fields

Public fccType: DWORD;

This item has no description.

Public fccHandler: DWORD;

stream type, for consistency

Public dwKeyFrameEvery: DWORD;

compressor

Public dwQuality: DWORD;

keyframe rate

Public dwBytesPerSecond: DWORD;

compress quality 0-10,000

Public dwFlags: DWORD;

bytes per second

Public lpFormat: PVOID;

flags... see below

Public cbFormat: DWORD;

save format

Public lpParms: PVOID;

This item has no description.

Public cbParms: DWORD;

compressor options

Public dwInterleaveEvery: DWORD;


GLSysHelp v.2.5: Formats.VFW: Interface IAVIStream

Interface IAVIStream

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type IAVIStream = interface(IUnknown)

Description

- - - - - - - - */

/****** AVI Stream Interface ******************************************

Hierarchy

  • IUnknown
  • IAVIStream

Overview

Methods

Public | function Create(lParam1, lParam2: LPARAM): HResult; stdcall;
Public | function Delete(lStart: LONG; lSamples: LONG): HResult; stdcall;
Public | function FindSample(lPos: LONG; lFlags: LONG): LONG; stdcall;
Public | function Info(var psi: TAVIStreamInfoW; lSize: LONG): HResult; stdcall;
Public | function Read(lStart: LONG; lSamples: LONG; lpBuffer: PVOID; cbBuffer: LONG; var plBytes, plSamples: LONG): HResult; stdcall;
Public | function ReadData(fcc: DWORD; lp: PVOID; var lpcb: LONG): HResult; stdcall;
Public | function ReadFormat(lPos: LONG; lpFormat: PVOID; var lpcbFormat: LONG): HResult; stdcall;
Public | function SetFormat(lPos: LONG; lpFormat: PVOID; cbFormat: LONG): HResult; stdcall;
Public | function SetInfo(var lpInfo: TAVIStreamInfoW; cbInfo: LONG): HResult; stdcall;
Public | function Write(lStart: LONG; lSamples: LONG; lpBuffer: PVOID; cbBuffer: LONG; dwFlags: DWORD; var plSampWritten, plBytesWritten: LONG): HResult; stdcall;
Public | function WriteData(fcc: DWORD; lp: PVOID; cb: LONG): HResult; stdcall;

Description

Methods

Public function Create(lParam1, lParam2: LPARAM): HResult; stdcall;

This item has no description.

Public function Delete(lStart: LONG; lSamples: LONG): HResult; stdcall;

This item has no description.

Public function FindSample(lPos: LONG; lFlags: LONG): LONG; stdcall;

This item has no description.

Public function Info(var psi: TAVIStreamInfoW; lSize: LONG): HResult; stdcall;

This item has no description.

Public function Read(lStart: LONG; lSamples: LONG; lpBuffer: PVOID; cbBuffer: LONG; var plBytes, plSamples: LONG): HResult; stdcall;

This item has no description.

Public function ReadData(fcc: DWORD; lp: PVOID; var lpcb: LONG): HResult; stdcall;

This item has no description.

Public function ReadFormat(lPos: LONG; lpFormat: PVOID; var lpcbFormat: LONG): HResult; stdcall;

This item has no description.

Public function SetFormat(lPos: LONG; lpFormat: PVOID; cbFormat: LONG): HResult; stdcall;

This item has no description.

Public function SetInfo(var lpInfo: TAVIStreamInfoW; cbInfo: LONG): HResult; stdcall;

This item has no description.

Public function Write(lStart: LONG; lSamples: LONG; lpBuffer: PVOID; cbBuffer: LONG; dwFlags: DWORD; var plSampWritten, plBytesWritten: LONG): HResult; stdcall;

This item has no description.

Public function WriteData(fcc: DWORD; lp: PVOID; cb: LONG): HResult; stdcall;


GLSysHelp v.2.5: Formats.VFW: Interface IAVIStreaming

Interface IAVIStreaming

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type IAVIStreaming = interface(IUnknown)

Description

This item has no description.

Hierarchy

  • IUnknown
  • IAVIStreaming

Overview

Methods

Public | function _Begin(lStart, lEnd : LONG; lRate : LONG): HResult; stdcall;
Public | function _End: HResult; stdcall;

Description

Methods

Public function _Begin(lStart, lEnd : LONG; lRate : LONG): HResult; stdcall;

This item has no description.

Public function _End: HResult; stdcall;


GLSysHelp v.2.5: Formats.VFW: Interface IAVIEditStream

Interface IAVIEditStream

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type IAVIEditStream = interface(IUnknown)

Description

This item has no description.

Hierarchy

  • IUnknown
  • IAVIEditStream

Overview

Methods

Public | function Clone(var ppResult: IAVIStream): HResult; stdcall;
Public | function Copy(var plStart, plLength: LONG; var ppResult: IAVIStream): HResult; stdcall;
Public | function Cut(var plStart, plLength: LONG; var ppResult: IAVIStream): HResult; stdcall;
Public | function Paste(var plPos: LONG; var plLength: LONG; pstream: IAVIStream; lStart, lEnd: LONG): HResult; stdcall;
Public | function SetInfo(var lpInfo: TAVIStreamInfoW; cbInfo: LONG): HResult; stdcall;

Description

Methods

Public function Clone(var ppResult: IAVIStream): HResult; stdcall;

This item has no description.

Public function Copy(var plStart, plLength: LONG; var ppResult: IAVIStream): HResult; stdcall;

This item has no description.

Public function Cut(var plStart, plLength: LONG; var ppResult: IAVIStream): HResult; stdcall;

This item has no description.

Public function Paste(var plPos: LONG; var plLength: LONG; pstream: IAVIStream; lStart, lEnd: LONG): HResult; stdcall;

This item has no description.

Public function SetInfo(var lpInfo: TAVIStreamInfoW; cbInfo: LONG): HResult; stdcall;


GLSysHelp v.2.5: Formats.VFW: Interface IAVIFile

Interface IAVIFile

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type IAVIFile = interface(IUnknown)

Description

– AVIFile ——————————————————————

Hierarchy

  • IUnknown
  • IAVIFile

Overview

Methods

Public | function CreateStream(var ppStream: IAVISTREAM; var psi: TAVIStreamInfoW): HResult; stdcall;
Public | function DeleteStream(fccType: DWORD; lParam: LONG): HResult; stdcall;
Public | function EndRecord: HResult; stdcall;
Public | function GetStream(var ppStream: IAVISTREAM; fccType: DWORD; lParam: LONG): HResult; stdcall;
Public | function Info(var pfi: TAVIFileInfoW; iSize: LONG): HResult; stdcall;
Public | function ReadData(ckid: DWORD; lpData: PVOID; lpcbData: PLONG): HResult; stdcall;
Public | function WriteData(ckid: DWORD; lpData: PVOID; cbData: LONG): HResult; stdcall;

Description

Methods

Public function CreateStream(var ppStream: IAVISTREAM; var psi: TAVIStreamInfoW): HResult; stdcall;

This item has no description.

Public function DeleteStream(fccType: DWORD; lParam: LONG): HResult; stdcall;

This item has no description.

Public function EndRecord: HResult; stdcall;

This item has no description.

Public function GetStream(var ppStream: IAVISTREAM; fccType: DWORD; lParam: LONG): HResult; stdcall;

This item has no description.

Public function Info(var pfi: TAVIFileInfoW; iSize: LONG): HResult; stdcall;

This item has no description.

Public function ReadData(ckid: DWORD; lpData: PVOID; lpcbData: PLONG): HResult; stdcall;

This item has no description.

Public function WriteData(ckid: DWORD; lpData: PVOID; cbData: LONG): HResult; stdcall;


GLSysHelp v.2.5: Formats.VFW: Interface IGetFrame

Interface IGetFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type IGetFrame = interface(IUnknown)

Description

The functions 'BeginExtraction' and 'EndExtraction' have actually the names 'Begin' and 'End', but we cannot use that identifiers for obvious reasons.

Hierarchy

  • IUnknown
  • IGetFrame

Overview

Methods

Public | function BeginExtraction(lStart, lEnd, lRate: LONG): HResult; stdcall;
Public | function EndExtraction: HResult; stdcall;
Public | function GetFrame(lPos: LONG): PBitmapInfoHeader; stdcall;
Public | function SetFormat(var lpbi: TBitmapInfoHeader; lpBits: Pointer; x, y, dx, dy: Integer): HResult; stdcall;

Description

Methods

Public function BeginExtraction(lStart, lEnd, lRate: LONG): HResult; stdcall;

This item has no description.

Public function EndExtraction: HResult; stdcall;

This item has no description.

Public function GetFrame(lPos: LONG): PBitmapInfoHeader; stdcall;

This item has no description.

Public function SetFormat(var lpbi: TBitmapInfoHeader; lpBits: Pointer; x, y, dx, dy: Integer): HResult; stdcall;


GLSysHelp v.2.5: Formats.VFW: Record TVIDEOHDR

Record TVIDEOHDR

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TVIDEOHDR = record

Description

This item has no description.

Overview

Fields

Public | lpData: PBYTE;
Public | dwBufferLength: DWORD;
Public | dwBytesUsed: DWORD;
Public | dwTimeCaptured: DWORD;
Public | dwUser: DWORD;
Public | dwFlags: DWORD;
Public | dwReserved: array[0..3] of DWORD;

Description

Fields

Public lpData: PBYTE;

This item has no description.

Public dwBufferLength: DWORD;

pointer to locked data buffer

Public dwBytesUsed: DWORD;

Length of data buffer

Public dwTimeCaptured: DWORD;

Bytes actually used

Public dwUser: DWORD;

Milliseconds from start of stream

Public dwFlags: DWORD;

for client's use

Public dwReserved: array[0..3] of DWORD;

assorted flags (see defines)


GLSysHelp v.2.5: Formats.VFW: Record TCHANNEL_CAPS

Record TCHANNEL_CAPS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TCHANNEL_CAPS = record

Description

This item has no description.

Overview

Fields

Public | dwFlags: DWORD;
Public | dwSrcRectXMod: DWORD;
Public | dwSrcRectYMod: DWORD;
Public | dwSrcRectWidthMod: DWORD;
Public | dwSrcRectHeightMod: DWORD;
Public | dwDstRectXMod: DWORD;
Public | dwDstRectYMod: DWORD;
Public | dwDstRectWidthMod: DWORD;
Public | dwDstRectHeightMod: DWORD;

Description

Fields

Public dwFlags: DWORD;

This item has no description.

Public dwSrcRectXMod: DWORD;

Capability flags

Public dwSrcRectYMod: DWORD;

Granularity of src rect in x

Public dwSrcRectWidthMod: DWORD;

Granularity of src rect in y

Public dwSrcRectHeightMod: DWORD;

Granularity of src rect width

Public dwDstRectXMod: DWORD;

Granularity of src rect height

Public dwDstRectYMod: DWORD;

Granularity of dst rect in x

Public dwDstRectWidthMod: DWORD;

Granularity of dst rect in y

Public dwDstRectHeightMod: DWORD;

Granularity of dst rect width


GLSysHelp v.2.5: Formats.VFW: Record TCAPDRIVERCAPS

Record TCAPDRIVERCAPS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TCAPDRIVERCAPS = record

Description

This item has no description.

Overview

Fields

Public | wDeviceIndex: UINT;
Public | fHasOverlay: BOOL;
Public | fHasDlgVideoSource: BOOL;
Public | fHasDlgVideoFormat: BOOL;
Public | fHasDlgVideoDisplay: BOOL;
Public | fCaptureInitialized: BOOL;
Public | fDriverSuppliesPalettes: BOOL;
Public | hVideoIn: THANDLE;
Public | hVideoOut: THANDLE;
Public | hVideoExtIn: THANDLE;
Public | hVideoExtOut: THANDLE;

Description

Fields

Public wDeviceIndex: UINT;

This item has no description.

Public fHasOverlay: BOOL;

Driver index in system.ini

Public fHasDlgVideoSource: BOOL;

Can device overlay?

Public fHasDlgVideoFormat: BOOL;

Has Video source dlg?

Public fHasDlgVideoDisplay: BOOL;

Has Format dlg?

Public fCaptureInitialized: BOOL;

Has External out dlg?

Public fDriverSuppliesPalettes: BOOL;

Driver ready to capture?

Public hVideoIn: THANDLE;

Can driver make palettes? following always NULL on Win32.

Public hVideoOut: THANDLE;

Driver In channel

Public hVideoExtIn: THANDLE;

Driver Out channel

Public hVideoExtOut: THANDLE;

Driver Ext In channel


GLSysHelp v.2.5: Formats.VFW: Record TCAPSTATUS

Record TCAPSTATUS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TCAPSTATUS = record

Description

This item has no description.

Overview

Fields

Public | uiImageWidth: UINT ;
Public | uiImageHeight: UINT ;
Public | fLiveWindow: BOOL ;
Public | fOverlayWindow: BOOL ;
Public | fScale: BOOL ;
Public | ptScroll: TPOINT ;
Public | fUsingDefaultPalette: BOOL ;
Public | fAudioHardware: BOOL ;
Public | fCapFileExists: BOOL ;
Public | dwCurrentVideoFrame: DWORD ;
Public | dwCurrentVideoFramesDropped: DWORD ;
Public | dwCurrentWaveSamples: DWORD ;
Public | dwCurrentTimeElapsedMS: DWORD ;
Public | hPalCurrent: HPALETTE;
Public | fCapturingNow: BOOL ;
Public | dwReturn: DWORD ;
Public | wNumVideoAllocated: UINT ;
Public | wNumAudioAllocated: UINT ;

Description

Fields

Public uiImageWidth: UINT ;

This item has no description.

Public uiImageHeight: UINT ;

Width of the image

Public fLiveWindow: BOOL ;

Height of the image

Public fOverlayWindow: BOOL ;

Now Previewing video?

Public fScale: BOOL ;

Now Overlaying video?

Public ptScroll: TPOINT ;

Scale image to client?

Public fUsingDefaultPalette: BOOL ;

Scroll position

Public fAudioHardware: BOOL ;

Using default driver palette?

Public fCapFileExists: BOOL ;

Audio hardware present?

Public dwCurrentVideoFrame: DWORD ;

Does capture file exist?

Public dwCurrentVideoFramesDropped: DWORD ;

# of video frames cap'td

Public dwCurrentWaveSamples: DWORD ;

# of video frames dropped

Public dwCurrentTimeElapsedMS: DWORD ;

# of wave samples cap'td

Public hPalCurrent: HPALETTE;

Elapsed capture duration

Public fCapturingNow: BOOL ;

Current palette in use

Public dwReturn: DWORD ;

Capture in progress?

Public wNumVideoAllocated: UINT ;

Error value after any operation

Public wNumAudioAllocated: UINT ;

Actual number of video buffers


GLSysHelp v.2.5: Formats.VFW: Record TCAPTUREPARMS

Record TCAPTUREPARMS

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TCAPTUREPARMS = record

Description

This item has no description.

Overview

Fields

Public | dwRequestMicroSecPerFrame: DWORD ;
Public | fMakeUserHitOKToCapture: BOOL ;
Public | wPercentDropForError: UINT ;
Public | fYield: BOOL ;
Public | dwIndexSize: DWORD ;
Public | wChunkGranularity: UINT ;
Public | fUsingDOSMemory: BOOL ;
Public | wNumVideoRequested: UINT ;
Public | fCaptureAudio: BOOL ;
Public | wNumAudioRequested: UINT ;
Public | vKeyAbort: UINT ;
Public | fAbortLeftMouse: BOOL ;
Public | fAbortRightMouse: BOOL ;
Public | fLimitEnabled: BOOL ;
Public | wTimeLimit: UINT ;
Public | fMCIControl: BOOL ;
Public | fStepMCIDevice: BOOL ;
Public | dwMCIStartTime: DWORD ;
Public | dwMCIStopTime: DWORD ;
Public | fStepCaptureAt2x: BOOL ;
Public | wStepCaptureAverageFrames: UINT ;
Public | dwAudioBufferSize: DWORD ;
Public | fDisableWriteCache: BOOL ;
Public | AVStreamMaster: UINT ;

Description

Fields

Public dwRequestMicroSecPerFrame: DWORD ;

This item has no description.

Public fMakeUserHitOKToCapture: BOOL ;

Requested capture rate

Public wPercentDropForError: UINT ;

Show "Hit OK to cap" dlg?

Public fYield: BOOL ;

Give error msg if > (10%)

Public dwIndexSize: DWORD ;

Capture via background task?

Public wChunkGranularity: UINT ;

Max index size in frames (32K)

Public fUsingDOSMemory: BOOL ;

Junk chunk granularity (2K)

Public wNumVideoRequested: UINT ;

Use DOS buffers?

Public fCaptureAudio: BOOL ;

# video buffers, If 0, autocalc

Public wNumAudioRequested: UINT ;

Capture audio?

Public vKeyAbort: UINT ;

# audio buffers, If 0, autocalc

Public fAbortLeftMouse: BOOL ;

Virtual key causing abort

Public fAbortRightMouse: BOOL ;

Abort on left mouse?

Public fLimitEnabled: BOOL ;

Abort on right mouse?

Public wTimeLimit: UINT ;

Use wTimeLimit?

Public fMCIControl: BOOL ;

Seconds to capture

Public fStepMCIDevice: BOOL ;

Use MCI video source?

Public dwMCIStartTime: DWORD ;

Step MCI device?

Public dwMCIStopTime: DWORD ;

Time to start in MS

Public fStepCaptureAt2x: BOOL ;

Time to stop in MS

Public wStepCaptureAverageFrames: UINT ;

Perform spatial averaging 2x

Public dwAudioBufferSize: DWORD ;

Temporal average n Frames

Public fDisableWriteCache: BOOL ;

Size of audio bufs (0 = default)

Public AVStreamMaster: UINT ;

Attempt to disable write cache


GLSysHelp v.2.5: Formats.VFW: Record TCAPINFOCHUNK

Record TCAPINFOCHUNK

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VFW

Declaration

type TCAPINFOCHUNK = record

Description

This item has no description.

Overview

Fields

Public | fccInfoID: FOURCC;
Public | lpData: PVOID;
Public | cbData: DWORD;

Description

Fields

Public fccInfoID: FOURCC;

This item has no description.

Public lpData: PVOID;

Chunk ID, "ICOP" for copyright

Public cbData: DWORD;

pointer to data


GLSysHelp v.2.5: Formats.VRML

Unit Formats.VRML

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The unit is part of the GLScene Engine, http://glscene.org

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.VectorLists
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TVRMLNode |
Class TVRMLSingleArray |
Class TVRMLIntegerArray |
Class TVRMLMaterial |
Class TVRMLUse |
Class TVRMLShapeHints |
Class TVRMLTransform |
Class TVRMLParser |


GLSysHelp v.2.5: Formats.VRML: Class TVRMLNode

Class TVRMLNode

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VRML

Declaration

type TVRMLNode = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TVRMLNode

Overview

Fields

Private | FNodes: TList;
Private | FParent: TVRMLNode;
Private | FName: String;
Private | FDefName: String;

Methods

Public | constructor Create; virtual;
Public | constructor CreateOwned(AParent: TVRMLNode);
Public | destructor Destroy; override;
Public | function Count: Integer;
Private | function GetNode(index: Integer): TVRMLNode;
Public | procedure Add(node: TVRMLNode);
Public | procedure Clear;
Public | procedure Delete(index: Integer);
Public | procedure Remove(node: TVRMLNode);

Properties

Public | property DefName: String read FDefName write FDefName;
Public | property Name: String read FName write FName;
Public | property Nodes[index: Integer]: TVRMLNode read GetNode;
Public | property Parent: TVRMLNode read FParent;

Description

Fields

Private FNodes: TList;

This item has no description.

Private FParent: TVRMLNode;

This item has no description.

Private FName: String;

This item has no description.

Private FDefName: String;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public constructor CreateOwned(AParent: TVRMLNode);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Count: Integer;

This item has no description.

Private function GetNode(index: Integer): TVRMLNode;

This item has no description.

Public procedure Add(node: TVRMLNode);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(index: Integer);

This item has no description.

Public procedure Remove(node: TVRMLNode);

This item has no description.

Properties

Public property DefName: String read FDefName write FDefName;

This item has no description.

Public property Name: String read FName write FName;

This item has no description.

Public property Nodes[index: Integer]: TVRMLNode read GetNode;

This item has no description.

Public property Parent: TVRMLNode read FParent;


GLSysHelp v.2.5: Formats.VRML: Class TVRMLSingleArray

Class TVRMLSingleArray

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VRML

Declaration

type TVRMLSingleArray = class(TVRMLNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLSingleArray

Overview

Fields

Private FValues: TGLSingleList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;

Properties

Public property Values: TGLSingleList read FValues;

Description

Fields

Private FValues: TGLSingleList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Public property Values: TGLSingleList read FValues;


GLSysHelp v.2.5: Formats.VRML: Class TVRMLIntegerArray

Class TVRMLIntegerArray

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VRML

Declaration

type TVRMLIntegerArray = class(TVRMLNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLIntegerArray

Overview

Fields

Private FValues: TGLIntegerList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;

Properties

Public property Values: TGLIntegerList read FValues;

Description

Fields

Private FValues: TGLIntegerList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Public property Values: TGLIntegerList read FValues;


GLSysHelp v.2.5: Formats.VRML: Class TVRMLMaterial

Class TVRMLMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VRML

Declaration

type TVRMLMaterial = class(TVRMLNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLMaterial

Overview

Fields

Private | FDiffuseColor: TVector3f;
Private | FAmbientColor: TVector3f;
Private | FSpecularColor: TVector3f;
Private | FEmissiveColor: TVector3f;
Private | FTransparency: Single;
Private | FShininess: Single;
Private | FHasDiffuse: Boolean;
Private | FHasAmbient: Boolean;
Private | FHasSpecular: Boolean;
Private | FHasEmissive: Boolean;
Private | FHasTransparency: Boolean;
Private | FHasShininess: Boolean;

Methods

Public constructor Create; override;

Properties

Public | property AmbientColor: TVector3f read FAmbientColor write FAmbientColor;
Public | property DiffuseColor: TVector3f read FDiffuseColor write FDiffuseColor;
Public | property EmissiveColor: TVector3f read FEmissiveColor write FEmissiveColor;
Public | property HasAmbient: Boolean read FHasAmbient write FHasAmbient;
Public | property HasDiffuse: Boolean read FHasDiffuse write FHasDiffuse;
Public | property HasEmissive: Boolean read FHasEmissive write FHasEmissive;
Public | property HasShininess: Boolean read FHasShininess write FHasShininess;
Public | property HasSpecular: Boolean read FHasSpecular write FHasSpecular;
Public | property HasTransparency: Boolean read FHasTransparency write FHasTransparency;
Public | property Shininess: Single read FShininess write FShininess;
Public | property SpecularColor: TVector3f read FSpecularColor write FSpecularColor;
Public | property Transparency: Single read FTransparency write FTransparency;

Description

Fields

Private FDiffuseColor: TVector3f;

This item has no description.

Private FAmbientColor: TVector3f;

This item has no description.

Private FSpecularColor: TVector3f;

This item has no description.

Private FEmissiveColor: TVector3f;

This item has no description.

Private FTransparency: Single;

This item has no description.

Private FShininess: Single;

This item has no description.

Private FHasDiffuse: Boolean;

This item has no description.

Private FHasAmbient: Boolean;

This item has no description.

Private FHasSpecular: Boolean;

This item has no description.

Private FHasEmissive: Boolean;

This item has no description.

Private FHasTransparency: Boolean;

This item has no description.

Private FHasShininess: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Properties

Public property AmbientColor: TVector3f read FAmbientColor write FAmbientColor;

This item has no description.

Public property DiffuseColor: TVector3f read FDiffuseColor write FDiffuseColor;

This item has no description.

Public property EmissiveColor: TVector3f read FEmissiveColor write FEmissiveColor;

This item has no description.

Public property HasAmbient: Boolean read FHasAmbient write FHasAmbient;

This item has no description.

Public property HasDiffuse: Boolean read FHasDiffuse write FHasDiffuse;

This item has no description.

Public property HasEmissive: Boolean read FHasEmissive write FHasEmissive;

This item has no description.

Public property HasShininess: Boolean read FHasShininess write FHasShininess;

This item has no description.

Public property HasSpecular: Boolean read FHasSpecular write FHasSpecular;

This item has no description.

Public property HasTransparency: Boolean read FHasTransparency write FHasTransparency;

This item has no description.

Public property Shininess: Single read FShininess write FShininess;

This item has no description.

Public property SpecularColor: TVector3f read FSpecularColor write FSpecularColor;

This item has no description.

Public property Transparency: Single read FTransparency write FTransparency;


GLSysHelp v.2.5: Formats.VRML: Class TVRMLUse

Class TVRMLUse

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VRML

Declaration

type TVRMLUse = class(TVRMLNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLUse

Overview

Fields

Private FValue: String;

Properties

Public property Value: String read FValue write FValue;

Description

Fields

Private FValue: String;

This item has no description.

Properties

Public property Value: String read FValue write FValue;


GLSysHelp v.2.5: Formats.VRML: Class TVRMLShapeHints

Class TVRMLShapeHints

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VRML

Declaration

type TVRMLShapeHints = class(TVRMLNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLShapeHints

Overview

Fields

Private FCreaseAngle: Single;

Properties

Public property CreaseAngle: Single read FCreaseAngle write FCreaseAngle;

Description

Fields

Private FCreaseAngle: Single;

This item has no description.

Properties

Public property CreaseAngle: Single read FCreaseAngle write FCreaseAngle;


GLSysHelp v.2.5: Formats.VRML: Class TVRMLTransform

Class TVRMLTransform

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VRML

Declaration

type TVRMLTransform = class(TVRMLNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLTransform

Overview

Fields

Private | FCenter: TVector3f;
Private | FRotation: TVector4f;
Private | FScaleFactor: TVector3f;

Methods

Public constructor Create; override;

Properties

Public | property Center: TVector3f read FCenter write FCenter;
Public | property Rotation: TVector4f read FRotation write FRotation;
Public | property ScaleFactor: TVector3f read FScaleFactor write FScaleFactor;

Description

Fields

Private FCenter: TVector3f;

This item has no description.

Private FRotation: TVector4f;

This item has no description.

Private FScaleFactor: TVector3f;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Properties

Public property Center: TVector3f read FCenter write FCenter;

This item has no description.

Public property Rotation: TVector4f read FRotation write FRotation;

This item has no description.

Public property ScaleFactor: TVector3f read FScaleFactor write FScaleFactor;


GLSysHelp v.2.5: Formats.VRML: Class TVRMLParser

Class TVRMLParser

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.VRML

Declaration

type TVRMLParser = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TVRMLParser

Overview

Fields

Private | FCursor: Integer;
Private | FTokens: TStringList;
Private | FRootNode: TVRMLNode;
Private | FCurrentNode: TVRMLNode;
Private | FAllowUnknownNodes: Boolean;
Private | FDefines: TList;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure Parse(Text: String);

Properties

Public | property AllowUnknownNodes: Boolean read FAllowUnknownNodes write FAllowUnknownNodes;
Public | property RootNode: TVRMLNode read FRootNode;

Description

Fields

Private FCursor: Integer;

This item has no description.

Private FTokens: TStringList;

This item has no description.

Private FRootNode: TVRMLNode;

This item has no description.

Private FCurrentNode: TVRMLNode;

This item has no description.

Private FAllowUnknownNodes: Boolean;

This item has no description.

Private FDefines: TList;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Parse(Text: String);

This item has no description.

Properties

Public property AllowUnknownNodes: Boolean read FAllowUnknownNodes write FAllowUnknownNodes;

This item has no description.

Public property RootNode: TVRMLNode read FRootNode;


GLSysHelp v.2.5: Formats.X

Unit Formats.X

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.PersistentClasses
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TDXFileHeader |
Class TDXNode |
Class TDXMaterial |
Class TDXMaterialList |
Class TDXFrame |
Class TDXMesh |
Class TDXFile |


GLSysHelp v.2.5: Formats.X: Record TDXFileHeader

Record TDXFileHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.X

Declaration

type TDXFileHeader = record

Description

This item has no description.

Overview

Fields

Public | Magic: array [0 .. 3] of AnsiChar;
Public | Major: array [0 .. 1] of AnsiChar;
Public | Minor: array [0 .. 1] of AnsiChar;
Public | FileType: array [0 .. 3] of AnsiChar;
Public | FloatType: array [0 .. 3] of AnsiChar;

Description

Fields

Public Magic: array [0 .. 3] of AnsiChar;

This item has no description.

Public Major: array [0 .. 1] of AnsiChar;

This item has no description.

Public Minor: array [0 .. 1] of AnsiChar;

This item has no description.

Public FileType: array [0 .. 3] of AnsiChar;

This item has no description.

Public FloatType: array [0 .. 3] of AnsiChar;


GLSysHelp v.2.5: Formats.X: Class TDXNode

Class TDXNode

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.X

Declaration

type TDXNode = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TDXNode

Overview

Fields

Private | FName: String;
Private | FTypeName: String;
Private | FOwner: TDXNode;

Methods

Public | constructor Create; virtual;
Public | constructor CreateOwned(AOwner: TDXNode);
Private | function GetItem(index: Integer): TDXNode;
Public | procedure Clear; override;

Properties

Public | property Items[index: Integer]: TDXNode read GetItem;
Public | property Name: String read FName write FName;
Public | property Owner: TDXNode read FOwner;
Public | property TypeName: String read FTypeName write FTypeName;

Description

Fields

Private FName: String;

This item has no description.

Private FTypeName: String;

This item has no description.

Private FOwner: TDXNode;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public constructor CreateOwned(AOwner: TDXNode);

This item has no description.

Private function GetItem(index: Integer): TDXNode;

This item has no description.

Public procedure Clear; override;

This item has no description.

Properties

Public property Items[index: Integer]: TDXNode read GetItem;

This item has no description.

Public property Name: String read FName write FName;

This item has no description.

Public property Owner: TDXNode read FOwner;

This item has no description.

Public property TypeName: String read FTypeName write FTypeName;


GLSysHelp v.2.5: Formats.X: Class TDXMaterial

Class TDXMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.X

Declaration

type TDXMaterial = class(TGLPersistentObject)

Description

This item has no description.

Hierarchy

  • TGLPersistentObject
  • TDXMaterial

Overview

Fields

Private | FDiffuse: TVector4f;
Private | FSpecPower: Single;
Private | FSpecular: TVector3f;
Private | FEmissive: TVector3f;
Private | FTexture: String;

Methods

Public constructor CreateOwned(AOwner: TDXMaterialList);

Properties

Public | property Diffuse: TVector4f read FDiffuse write FDiffuse;
Public | property Emissive: TVector3f read FEmissive write FEmissive;
Public | property SpecPower: Single read FSpecPower write FSpecPower;
Public | property Specular: TVector3f read FSpecular write FSpecular;
Public | property Texture: String read FTexture write FTexture;

Description

Fields

Private FDiffuse: TVector4f;

This item has no description.

Private FSpecPower: Single;

This item has no description.

Private FSpecular: TVector3f;

This item has no description.

Private FEmissive: TVector3f;

This item has no description.

Private FTexture: String;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TDXMaterialList);

This item has no description.

Properties

Public property Diffuse: TVector4f read FDiffuse write FDiffuse;

This item has no description.

Public property Emissive: TVector3f read FEmissive write FEmissive;

This item has no description.

Public property SpecPower: Single read FSpecPower write FSpecPower;

This item has no description.

Public property Specular: TVector3f read FSpecular write FSpecular;

This item has no description.

Public property Texture: String read FTexture write FTexture;


GLSysHelp v.2.5: Formats.X: Class TDXMaterialList

Class TDXMaterialList

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.X

Declaration

type TDXMaterialList = class(TDXNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TDXNode
  • TDXMaterialList

Overview

Methods

Private function GetMaterial(index: Integer): TDXMaterial;

Properties

Public property Items[index: Integer]: TDXMaterial read GetMaterial;

Description

Methods

Private function GetMaterial(index: Integer): TDXMaterial;

This item has no description.

Properties

Public property Items[index: Integer]: TDXMaterial read GetMaterial;


GLSysHelp v.2.5: Formats.X: Class TDXFrame

Class TDXFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.X

Declaration

type TDXFrame = class(TDXNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TDXNode
  • TDXFrame

Overview

Fields

Private FMatrix: TGLMatrix;

Methods

Public | constructor Create; override;
Public | function GlobalMatrix: TGLMatrix;

Properties

Public property Matrix: TGLMatrix read FMatrix write FMatrix;

Description

Fields

Private FMatrix: TGLMatrix;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public function GlobalMatrix: TGLMatrix;

This item has no description.

Properties

Public property Matrix: TGLMatrix read FMatrix write FMatrix;


GLSysHelp v.2.5: Formats.X: Class TDXMesh

Class TDXMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.X

Declaration

type TDXMesh = class(TDXNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TDXNode
  • TDXMesh

Overview

Fields

Private | FVertices: TGLAffineVectorList;
Private | FNormals: TGLAffineVectorList;
Private | FTexCoords: TGLAffineVectorList;
Private | FVertexIndices: TGLIntegerList;
Private | FNormalIndices: TGLIntegerList;
Private | FMaterialIndices: TGLIntegerList;
Private | FVertCountIndices: TGLIntegerList;
Private | FMaterialList: TDXMaterialList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;

Properties

Public | property MaterialIndices: TGLIntegerList read FMaterialIndices;
Public | property MaterialList: TDXMaterialList read FMaterialList;
Public | property NormalIndices: TGLIntegerList read FNormalIndices;
Public | property Normals: TGLAffineVectorList read FNormals;
Public | property TexCoords: TGLAffineVectorList read FTexCoords;
Public | property VertCountIndices: TGLIntegerList read FVertCountIndices;
Public | property VertexIndices: TGLIntegerList read FVertexIndices;
Public | property Vertices: TGLAffineVectorList read FVertices;

Description

Fields

Private FVertices: TGLAffineVectorList;

This item has no description.

Private FNormals: TGLAffineVectorList;

This item has no description.

Private FTexCoords: TGLAffineVectorList;

This item has no description.

Private FVertexIndices: TGLIntegerList;

This item has no description.

Private FNormalIndices: TGLIntegerList;

This item has no description.

Private FMaterialIndices: TGLIntegerList;

This item has no description.

Private FVertCountIndices: TGLIntegerList;

This item has no description.

Private FMaterialList: TDXMaterialList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Public property MaterialIndices: TGLIntegerList read FMaterialIndices;

This item has no description.

Public property MaterialList: TDXMaterialList read FMaterialList;

This item has no description.

Public property NormalIndices: TGLIntegerList read FNormalIndices;

This item has no description.

Public property Normals: TGLAffineVectorList read FNormals;

This item has no description.

Public property TexCoords: TGLAffineVectorList read FTexCoords;

This item has no description.

Public property VertCountIndices: TGLIntegerList read FVertCountIndices;

This item has no description.

Public property VertexIndices: TGLIntegerList read FVertexIndices;

This item has no description.

Public property Vertices: TGLAffineVectorList read FVertices;


GLSysHelp v.2.5: Formats.X: Class TDXFile

Class TDXFile

Description
Hierarchy
Fields
Methods
Properties

Unit

Formats.X

Declaration

type TDXFile = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TDXFile

Overview

Fields

Private | FRootNode: TDXNode;
Private | FHeader: TDXFileHeader;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure LoadFromStream(Stream: TStream);

Properties

Public | property Header: TDXFileHeader read FHeader;
Public | property RootNode: TDXNode read FRootNode;

Description

Fields

Private FRootNode: TDXNode;

This item has no description.

Private FHeader: TDXFileHeader;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure LoadFromStream(Stream: TStream);

This item has no description.

Properties

Public property Header: TDXFileHeader read FHeader;

procedure SaveToStream(Stream : TStream);

Public property RootNode: TDXNode read FRootNode;


GLSysHelp v.2.5: FRColorEditor

Unit FRColorEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • WinApi.Windows
  • System.Classes
  • System.SysUtils
  • System.Types
  • VCL.Forms
  • VCL.StdCtrls
  • VCL.ComCtrls
  • VCL.ExtCtrls
  • VCL.Dialogs
  • VCL.Controls
  • VCL.Graphics
  • GLScene.VectorGeometry
  • GLS.Color
  • GLS.Texture
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRColorEditor |


GLSysHelp v.2.5: FRColorEditor: Class TRColorEditor

Class TRColorEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

FRColorEditor

Declaration

type TRColorEditor = class(TFrame)

Description

This item has no description.

Hierarchy

  • TFrame
  • TRColorEditor

Overview

Fields

Public | Label1: TLabel;
Public | Label2: TLabel;
Public | Label3: TLabel;
Public | Label4: TLabel;
Public | PAPreview: TPanel;
Public | ColorDialog: TColorDialog;
Public | Panel1: TPanel;
Public | ColorEditorPaintBox: TPaintBox;
Public | RedEdit: TEdit;
Public | GreenEdit: TEdit;
Public | BlueEdit: TEdit;
Public | AlphaEdit: TEdit;
Private | FOnChange: TNotifyEvent;
Private | updating: Boolean;
Private | WorkBitmap: tBitmap;
Private | RedValue: Integer;
Private | GreenValue: integer;
Private | BlueValue: integer;
Private | AlphaVAlue: integer;
Private | DraggingValue: (None,Red,Green,Blue,Alpha);

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetColor: THomogeneousFltVector;
Public | procedure AlphaEditChange(Sender: TObject);
Public | procedure BlueEditChange(Sender: TObject);
Public | procedure ColorEditorPaintBoxMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure ColorEditorPaintBoxMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public | procedure ColorEditorPaintBoxMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure ColorEditorPaintBoxPaint(Sender: TObject);
Public | procedure FrameResize(Sender: TObject);
Public | procedure GreenEditChange(Sender: TObject);
Public | procedure PAPreviewDblClick(Sender: TObject);
Public | procedure RedEditChange(Sender: TObject);
Public | procedure TBEChange(Sender: TObject);
Private | procedure ContentsChanged;
Private | procedure DragColorSliderToPosition(XPos : integer);
Private | procedure DrawContents;
Private | procedure SetColor(const val : THomogeneousFltVector);

Properties

Public | property Color : THomogeneousFltVector read GetColor write SetColor;
Published | property OnChange : TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public PAPreview: TPanel;

This item has no description.

Public ColorDialog: TColorDialog;

This item has no description.

Public Panel1: TPanel;

This item has no description.

Public ColorEditorPaintBox: TPaintBox;

This item has no description.

Public RedEdit: TEdit;

This item has no description.

Public GreenEdit: TEdit;

This item has no description.

Public BlueEdit: TEdit;

This item has no description.

Public AlphaEdit: TEdit;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private updating: Boolean;

This item has no description.

Private WorkBitmap: tBitmap;

This item has no description.

Private RedValue: Integer;

This item has no description.

Private GreenValue: integer;

This item has no description.

Private BlueValue: integer;

This item has no description.

Private AlphaVAlue: integer;

This item has no description.

Private DraggingValue: (None,Red,Green,Blue,Alpha);

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetColor: THomogeneousFltVector;

This item has no description.

Public procedure AlphaEditChange(Sender: TObject);

This item has no description.

Public procedure BlueEditChange(Sender: TObject);

This item has no description.

Public procedure ColorEditorPaintBoxMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure ColorEditorPaintBoxMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure ColorEditorPaintBoxMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure ColorEditorPaintBoxPaint(Sender: TObject);

This item has no description.

Public procedure FrameResize(Sender: TObject);

This item has no description.

Public procedure GreenEditChange(Sender: TObject);

This item has no description.

Public procedure PAPreviewDblClick(Sender: TObject);

This item has no description.

Public procedure RedEditChange(Sender: TObject);

This item has no description.

Public procedure TBEChange(Sender: TObject);

This item has no description.

Private procedure ContentsChanged;

This item has no description.

Private procedure DragColorSliderToPosition(XPos : integer);

This item has no description.

Private procedure DrawContents;

This item has no description.

Private procedure SetColor(const val : THomogeneousFltVector);

This item has no description.

Properties

Public property Color : THomogeneousFltVector read GetColor write SetColor;

This item has no description.

Published property OnChange : TNotifyEvent read FOnChange write FOnChange;


GLSysHelp v.2.5: FRFaceEditor

Unit FRFaceEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • WinApi.Windows
  • System.Classes
  • System.SysUtils
  • System.ImageList
  • VCL.Forms
  • VCL.ComCtrls
  • VCL.StdCtrls
  • VCL.ImgList
  • VCL.Controls
  • VCL.Graphics
  • FRTrackBarEdit
  • FRColorEditor
  • GLS.Texture
  • GLS.Material
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRFaceEditor |


GLSysHelp v.2.5: FRFaceEditor: Class TRFaceEditor

Class TRFaceEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

FRFaceEditor

Declaration

type TRFaceEditor = class(TFrame)

Description

This item has no description.

Hierarchy

  • TFrame
  • TRFaceEditor

Overview

Fields

Public | PageControl: TPageControl;
Public | TSAmbient: TTabSheet;
Public | TSDiffuse: TTabSheet;
Public | TSEmission: TTabSheet;
Public | TSSpecular: TTabSheet;
Public | CEAmbiant: TRColorEditor;
Public | Label1: TLabel;
Public | TBEShininess: TRTrackBarEdit;
Public | ImageList: TImageList;
Public | CEDiffuse: TRColorEditor;
Public | CEEmission: TRColorEditor;
Public | CESpecular: TRColorEditor;
Private | FOnChange: TNotifyEvent;
Private | Updating: Boolean;
Private | FFaceProperties: TGLFaceProperties;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure TBEShininessTrackBarChange(Sender: TObject);
Private | procedure OnColorChange(Sender: TObject);
Private | procedure SetGLFaceProperties(const val: TGLFaceProperties);

Properties

Public | property FaceProperties: TGLFaceProperties read FFaceProperties write SetGLFaceProperties;
Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Public PageControl: TPageControl;

This item has no description.

Public TSAmbient: TTabSheet;

This item has no description.

Public TSDiffuse: TTabSheet;

This item has no description.

Public TSEmission: TTabSheet;

This item has no description.

Public TSSpecular: TTabSheet;

This item has no description.

Public CEAmbiant: TRColorEditor;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public TBEShininess: TRTrackBarEdit;

This item has no description.

Public ImageList: TImageList;

This item has no description.

Public CEDiffuse: TRColorEditor;

This item has no description.

Public CEEmission: TRColorEditor;

This item has no description.

Public CESpecular: TRColorEditor;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private Updating: Boolean;

This item has no description.

Private FFaceProperties: TGLFaceProperties;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure TBEShininessTrackBarChange(Sender: TObject);

This item has no description.

Private procedure OnColorChange(Sender: TObject);

This item has no description.

Private procedure SetGLFaceProperties(const val: TGLFaceProperties);

This item has no description.

Properties

Public property FaceProperties: TGLFaceProperties read FFaceProperties write SetGLFaceProperties;

This item has no description.

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;


GLSysHelp v.2.5: FRMaterialPreview

Unit FRMaterialPreview

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Types
  • System.Classes
  • Vcl.Graphics
  • Vcl.Forms
  • Vcl.StdCtrls
  • Vcl.ComCtrls
  • Vcl.Controls
  • GLS.Scene
  • GLScene.VectorTypes
  • GLS.Objects
  • GLS.Texture
  • GLS.HUDObjects
  • GLS.SceneViewer
  • GLS.GeomObjects
  • GLS.Color
  • GLS.Coordinates
  • GLS.BaseClasses
  • GLS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRMaterialPreview |


GLSysHelp v.2.5: FRMaterialPreview: Class TRMaterialPreview

Class TRMaterialPreview

Description
Hierarchy
Fields
Methods
Properties

Unit

FRMaterialPreview

Declaration

type TRMaterialPreview = class(TFrame)

Description

This item has no description.

Hierarchy

  • TFrame
  • TRMaterialPreview

Overview

Fields

Public | GLScene: TGLScene;
Public | GLSceneViewer: TGLSceneViewer;
Public | CBObject: TComboBox;
Public | Camera: TGLCamera;
Public | Cube: TGLCube;
Public | Sphere: TGLSphere;
Public | LightSource: TGLLightSource;
Public | CBBackground: TComboBox;
Public | BackGroundSprite: TGLHUDSprite;
Public | Teapot: TGLTeapot;
Public | World: TGLDummyCube;
Public | Light: TGLDummyCube;
Public | FireSphere: TGLSphere;
Public | GLMaterialLibrary: TGLMaterialLibrary;
Private | FLibMaterial: TGLAbstractLibMaterial;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetLibMaterial: TGLAbstractLibMaterial;
Private | function GetMaterial: TGLMaterial;
Public | procedure CBBackgroundChange(Sender: TObject);
Public | procedure CBObjectChange(Sender: TObject);
Public | procedure SceneViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Public | procedure SceneViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public | procedure SceneViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);
Private | procedure SetLibMaterial(const Value: TGLAbstractLibMaterial);
Private | procedure SetMaterial(const Value: TGLMaterial);

Properties

Public | property LibMaterial: TGLAbstractLibMaterial read GetLibMaterial write SetLibMaterial;
Public | property Material: TGLMaterial read GetMaterial write SetMaterial;

Description

Fields

Public GLScene: TGLScene;

This item has no description.

Public GLSceneViewer: TGLSceneViewer;

This item has no description.

Public CBObject: TComboBox;

This item has no description.

Public Camera: TGLCamera;

This item has no description.

Public Cube: TGLCube;

This item has no description.

Public Sphere: TGLSphere;

This item has no description.

Public LightSource: TGLLightSource;

This item has no description.

Public CBBackground: TComboBox;

This item has no description.

Public BackGroundSprite: TGLHUDSprite;

This item has no description.

Public Teapot: TGLTeapot;

This item has no description.

Public World: TGLDummyCube;

This item has no description.

Public Light: TGLDummyCube;

This item has no description.

Public FireSphere: TGLSphere;

This item has no description.

Public GLMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FLibMaterial: TGLAbstractLibMaterial;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetLibMaterial: TGLAbstractLibMaterial;

This item has no description.

Private function GetMaterial: TGLMaterial;

This item has no description.

Public procedure CBBackgroundChange(Sender: TObject);

This item has no description.

Public procedure CBObjectChange(Sender: TObject);

This item has no description.

Public procedure SceneViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure SceneViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

This item has no description.

Public procedure SceneViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

This item has no description.

Private procedure SetLibMaterial(const Value: TGLAbstractLibMaterial);

This item has no description.

Private procedure SetMaterial(const Value: TGLMaterial);

This item has no description.

Properties

Public property LibMaterial: TGLAbstractLibMaterial read GetLibMaterial write SetLibMaterial;

This item has no description.

Public property Material: TGLMaterial read GetMaterial write SetMaterial;


GLSysHelp v.2.5: FRTextureEdit

Unit FRTextureEdit

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.TypInfo
  • VCL.Forms
  • VCL.StdCtrls
  • VCL.Buttons
  • VCL.Controls
  • GLS.Graphics
  • GLScene.TextureFormat
  • GLS.Texture
  • GLS.State
  • GLS.TextureImageEditors

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRTextureEdit |


GLSysHelp v.2.5: FRTextureEdit: Class TRTextureEdit

Class TRTextureEdit

Description
Hierarchy
Fields
Methods
Properties

Unit

FRTextureEdit

Declaration

type TRTextureEdit = class(TFrame)

Description

This item has no description.

Hierarchy

  • TFrame
  • TRTextureEdit

Overview

Fields

Public | Label2: TLabel;
Public | SBEditImage: TSpeedButton;
Public | CBMagFilter: TComboBox;
Public | Label3: TLabel;
Public | Label4: TLabel;
Public | CBMinFilter: TComboBox;
Public | CBTextureMode: TComboBox;
Public | Label1: TLabel;
Public | Label5: TLabel;
Public | CBTextureWrap: TComboBox;
Public | CBDisabled: TCheckBox;
Public | CBImageClass: TComboBox;
Public | CBImageAlpha: TComboBox;
Public | Label6: TLabel;
Public | CBFilteringQuality: TComboBox;
Public | Label7: TLabel;
Private | FTexture: TGLTexture;
Private | FOnChange: TNotifyEvent;
Private | Changeing: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CBDisabledClick(Sender: TObject);
Public | procedure CBFilteringQualityChange(Sender: TObject);
Public | procedure CBImageAlphaChange(Sender: TObject);
Public | procedure CBImageClassChange(Sender: TObject);
Public | procedure CBMagFilterChange(Sender: TObject);
Public | procedure CBMinFilterChange(Sender: TObject);
Public | procedure CBTextureModeChange(Sender: TObject);
Public | procedure CBTextureWrapChange(Sender: TObject);
Public | procedure SBEditImageClick(Sender: TObject);

Properties

Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Public | property Texture: TGLTexture read FTexture write SetTexture;

Description

Fields

Public Label2: TLabel;

This item has no description.

Public SBEditImage: TSpeedButton;

This item has no description.

Public CBMagFilter: TComboBox;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public CBMinFilter: TComboBox;

This item has no description.

Public CBTextureMode: TComboBox;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label5: TLabel;

This item has no description.

Public CBTextureWrap: TComboBox;

This item has no description.

Public CBDisabled: TCheckBox;

This item has no description.

Public CBImageClass: TComboBox;

This item has no description.

Public CBImageAlpha: TComboBox;

This item has no description.

Public Label6: TLabel;

This item has no description.

Public CBFilteringQuality: TComboBox;

This item has no description.

Public Label7: TLabel;

This item has no description.

Private FTexture: TGLTexture;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private Changeing: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CBDisabledClick(Sender: TObject);

This item has no description.

Public procedure CBFilteringQualityChange(Sender: TObject);

This item has no description.

Public procedure CBImageAlphaChange(Sender: TObject);

This item has no description.

Public procedure CBImageClassChange(Sender: TObject);

This item has no description.

Public procedure CBMagFilterChange(Sender: TObject);

This item has no description.

Public procedure CBMinFilterChange(Sender: TObject);

This item has no description.

Public procedure CBTextureModeChange(Sender: TObject);

This item has no description.

Public procedure CBTextureWrapChange(Sender: TObject);

This item has no description.

Public procedure SBEditImageClick(Sender: TObject);

This item has no description.

Properties

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;

This item has no description.

Public property Texture: TGLTexture read FTexture write SetTexture;


GLSysHelp v.2.5: FRTrackBarEdit

Unit FRTrackBarEdit

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Frame combining a TrackBar and an Edit.

Uses

  • System.Classes
  • System.SysUtils
  • VCL.Forms
  • VCL.StdCtrls
  • VCL.ComCtrls
  • VCL.Controls

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRTrackBarEdit |


GLSysHelp v.2.5: FRTrackBarEdit: Class TRTrackBarEdit

Class TRTrackBarEdit

Description
Hierarchy
Fields
Methods
Properties

Unit

FRTrackBarEdit

Declaration

type TRTrackBarEdit = class(TFrame)

Description

This item has no description.

Hierarchy

  • TFrame
  • TRTrackBarEdit

Overview

Fields

Public | TrackBar: TTrackBar;
Public | Edit: TEdit;

Methods

Private | function GetValue: Integer;
Private | function GetValueMax: Integer;
Private | function GetValueMin: Integer;
Public | procedure EditChange(Sender: TObject);
Public | procedure TrackBarChange(Sender: TObject);
Private | procedure SetValue(const val : Integer);
Private | procedure SetValueMax(const val : Integer);
Private | procedure SetValueMin(const val : Integer);

Properties

Public | property Value : Integer read GetValue write SetValue;
Public | property ValueMax : Integer read GetValueMax write SetValueMax;
Public | property ValueMin : Integer read GetValueMin write SetValueMin;

Description

Fields

Public TrackBar: TTrackBar;

This item has no description.

Public Edit: TEdit;

This item has no description.

Methods

Private function GetValue: Integer;

This item has no description.

Private function GetValueMax: Integer;

This item has no description.

Private function GetValueMin: Integer;

This item has no description.

Public procedure EditChange(Sender: TObject);

This item has no description.

Public procedure TrackBarChange(Sender: TObject);

This item has no description.

Private procedure SetValue(const val : Integer);

This item has no description.

Private procedure SetValueMax(const val : Integer);

This item has no description.

Private procedure SetValueMin(const val : Integer);

This item has no description.

Properties

Public property Value : Integer read GetValue write SetValue;

This item has no description.

Public property ValueMax : Integer read GetValueMax write SetValueMax;

This item has no description.

Public property ValueMin : Integer read GetValueMin write SetValueMin;


GLSysHelp v.2.5: GLS.AnimatedSprite

Unit GLS.AnimatedSprite

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Material
  • GLS.PersistentClasses
  • GLScene.XCollection
  • GLS.RenderContextInfo
  • GLS.BaseClasses
  • GLS.Context
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSpriteAnimFrame |
Class TGLSpriteAnimFrameList |
Class TGLSpriteAnimMargins |
Class TGLSpriteAnimation |
Class TGLSpriteAnimationList |
Class TGLAnimatedSprite |

Types

TGLSpriteAnimationMode = (...);
TGLSpriteFrameDimensions = (...);

Description

Types

TGLSpriteAnimationMode = (...);

Sets the current animation playback mode: samNone - No playback, the animation does not progress. samPlayOnce - Plays the animation once then switches to samNone. samLoop - Play the animation forward in a continuous loop. samLoopBackward - Same as samLoop but reversed direction. samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached.

Values
  • samNone
  • samPlayOnce
  • samLoop
  • samBounceForward
  • samBounceBackward
  • samLoopBackward
TGLSpriteFrameDimensions = (...);

Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.

Values
  • sfdAuto
  • sfdManual


GLSysHelp v.2.5: GLS.AnimatedSprite: Class TGLSpriteAnimFrame

Class TGLSpriteAnimFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AnimatedSprite

Declaration

type TGLSpriteAnimFrame = class(TXCollectionItem)

Description

Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLSpriteAnimFrame

Overview

Fields

Private | FOffsetX: Integer;
Private | FOffsetY: Integer;
Private | FWidth: Integer;
Private | FHeight: Integer;

Methods

Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Private | procedure DoChanged;

Properties

Published | property Height: Integer read FHeight write SetHeight;
Published | property OffsetX: Integer read FOffsetX write SetOffsetX;
Published | property OffsetY: Integer read FOffsetY write SetOffsetY;
Published | property Width: Integer read FWidth write SetWidth;

Description

Fields

Private FOffsetX: Integer;

This item has no description.

Private FOffsetY: Integer;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Methods

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private procedure DoChanged;

This item has no description.

Properties

Published property Height: Integer read FHeight write SetHeight;

This item has no description.

Published property OffsetX: Integer read FOffsetX write SetOffsetX;

This item has no description.

Published property OffsetY: Integer read FOffsetY write SetOffsetY;

This item has no description.

Published property Width: Integer read FWidth write SetWidth;


GLSysHelp v.2.5: GLS.AnimatedSprite: Class TGLSpriteAnimFrameList

Class TGLSpriteAnimFrameList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AnimatedSprite

Declaration

type TGLSpriteAnimFrameList = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLSpriteAnimFrameList

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.


GLSysHelp v.2.5: GLS.AnimatedSprite: Class TGLSpriteAnimMargins

Class TGLSpriteAnimMargins

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AnimatedSprite

Declaration

type TGLSpriteAnimMargins = class(TPersistent)

Description

Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.

Hierarchy

  • TObject
  • TPersistent
  • TGLSpriteAnimMargins

Overview

Fields

Private | FOwner: TGLSpriteAnimation;
Private | FLeft: Integer;
Private | FTop: Integer;
Private | FRight: Integer;
Private | FBottom: Integer;

Methods

Public constructor Create(Animation: TGLSpriteAnimation);

Properties

Published | property Bottom: Integer read FBottom write SetBottom;
Published | property Left: Integer read FLeft write SetLeft;
Public | property Owner: TGLSpriteAnimation read FOwner;
Published | property Right: Integer read FRight write SetRight;
Published | property Top: Integer read FTop write SetTop;

Description

Fields

Private FOwner: TGLSpriteAnimation;

This item has no description.

Private FLeft: Integer;

This item has no description.

Private FTop: Integer;

This item has no description.

Private FRight: Integer;

This item has no description.

Private FBottom: Integer;

This item has no description.

Methods

Public constructor Create(Animation: TGLSpriteAnimation);

This item has no description.

Properties

Published property Bottom: Integer read FBottom write SetBottom;

This item has no description.

Published property Left: Integer read FLeft write SetLeft;

This item has no description.

Public property Owner: TGLSpriteAnimation read FOwner;

This item has no description.

Published property Right: Integer read FRight write SetRight;

This item has no description.

Published property Top: Integer read FTop write SetTop;


GLSysHelp v.2.5: GLS.AnimatedSprite: Class TGLSpriteAnimation

Class TGLSpriteAnimation

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AnimatedSprite

Declaration

type TGLSpriteAnimation = class(TXCollectionItem, IGLMaterialLibrarySupported)

Description

Animations define how the texture coordinates for each offset are to be determined.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLSpriteAnimation

Overview

Fields

Private | FCurrentFrame: Integer;
Private | FStartFrame: Integer;
Private | FEndFrame: Integer;
Private | FFrameWidth: Integer;
Private | FFrameHeight: Integer;
Private | FInterval: Integer;
Private | FFrames: TGLSpriteAnimFrameList;
Private | FLibMaterialName: TGLLibMaterialName;
Private | FLibMaterialCached: TGLLibMaterial;
Private | FDimensions: TGLSpriteFrameDimensions;
Private | FMargins: TGLSpriteAnimMargins;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Private | procedure DoChanged;

Properties

Published | property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame;
Published | property Dimensions: TGLSpriteFrameDimensions read FDimensions write SetDimensions;
Published | property EndFrame: Integer read FEndFrame write FEndFrame;
Published | property FrameHeight: Integer read FFrameHeight write SetFrameHeight;
Published | property FrameRate: Single read GetFrameRate write SetFrameRate;
Published | property Frames: TGLSpriteAnimFrameList read FFrames;
Published | property FrameWidth: Integer read FFrameWidth write SetFrameWidth;
Published | property Interval: Integer read FInterval write SetInterval;
Public | property LibMaterialCached: TGLLibMaterial read GetLibMaterialCached;
Published | property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property Margins: TGLSpriteAnimMargins read FMargins;
Published | property StartFrame: Integer read FStartFrame write FStartFrame;

Description

Fields

Private FCurrentFrame: Integer;

This item has no description.

Private FStartFrame: Integer;

This item has no description.

Private FEndFrame: Integer;

This item has no description.

Private FFrameWidth: Integer;

This item has no description.

Private FFrameHeight: Integer;

This item has no description.

Private FInterval: Integer;

This item has no description.

Private FFrames: TGLSpriteAnimFrameList;

This item has no description.

Private FLibMaterialName: TGLLibMaterialName;

This item has no description.

Private FLibMaterialCached: TGLLibMaterial;

This item has no description.

Private FDimensions: TGLSpriteFrameDimensions;

This item has no description.

Private FMargins: TGLSpriteAnimMargins;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private procedure DoChanged;

This item has no description.

Properties

Published property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame;

The current showing frame for this animation.

Published property Dimensions: TGLSpriteFrameDimensions read FDimensions write SetDimensions;

Automatic or manual texture coordinate generation.

Published property EndFrame: Integer read FEndFrame write FEndFrame;

Defines the ending frame for auto dimension animations.

Published property FrameHeight: Integer read FFrameHeight write SetFrameHeight;

Height of each frame in an auto dimension animation.

Published property FrameRate: Single read GetFrameRate write SetFrameRate;

The number of frames per second for the animation. Will automatically calculate the Interval value when set. Precision will depend on Interval since Interval has priority.

Published property Frames: TGLSpriteAnimFrameList read FFrames;

Manual dimension animation frames. Stores the offsets and dimensions for each frame in the animation.

Published property FrameWidth: Integer read FFrameWidth write SetFrameWidth;

Width of each frame in an auto dimension animation.

Published property Interval: Integer read FInterval write SetInterval;

The number of milliseconds between each frame in the animation. Will automatically calculate the FrameRate value when set. Will override the TGLAnimatedSprite Interval is greater than zero.

Public property LibMaterialCached: TGLLibMaterial read GetLibMaterialCached;

This item has no description.

Published property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;

The name of the lib material the sprites associated material library for this animation.

Published property Margins: TGLSpriteAnimMargins read FMargins;

Sets cropping margins for auto dimension animations.

Published property StartFrame: Integer read FStartFrame write FStartFrame;

Defines the starting frame for auto dimension animations.


GLSysHelp v.2.5: GLS.AnimatedSprite: Class TGLSpriteAnimationList

Class TGLSpriteAnimationList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AnimatedSprite

Declaration

type TGLSpriteAnimationList = class(TXCollection)

Description

A collection for storing SpriteAnimation objects.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLSpriteAnimationList

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.


GLSysHelp v.2.5: GLS.AnimatedSprite: Class TGLAnimatedSprite

Class TGLAnimatedSprite

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AnimatedSprite

Declaration

type TGLAnimatedSprite = class(TGLBaseSceneObject)

Description

An animated version for using offset texture coordinate animation.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLAnimatedSprite

Overview

Fields

Private | FAnimations: TGLSpriteAnimationList;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FAnimationIndex: Integer;
Private | FInterval: Integer;
Private | FRotation: Integer;
Private | FPixelRatio: Integer;
Private | FMirrorU: Boolean;
Private | FMirrorV: Boolean;
Private | FAnimationMode: TGLSpriteAnimationMode;
Private | FCurrentFrameDelta: Double;
Private | FOnFrameChanged: TNotifyEvent;
Private | FOnEndFrameReached: TNotifyEvent;
Private | FOnStartFrameReached: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure NextFrame;

Properties

Published | property AnimationIndex: Integer read FAnimationIndex write SetAnimationIndex;
Published | property AnimationMode: TGLSpriteAnimationMode read FAnimationMode write SetAnimationMode;
Published | property Animations: TGLSpriteAnimationList read FAnimations;
Published | property FrameRate: Single read GetFrameRate write SetFrameRate;
Published | property Interval: Integer read FInterval write SetInterval;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MirrorU: Boolean read FMirrorU write SetMirrorU;
Published | property MirrorV: Boolean read FMirrorV write SetMirrorV;
Published | property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;
Published | property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;
Published | property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;
Published | property PixelRatio: Integer read FPixelRatio write SetPixelRatio;
Published | property Position;
Published | property Rotation: Integer read FRotation write SetRotation;
Published | property Scale;
Published | property Visible;

Description

Fields

Private FAnimations: TGLSpriteAnimationList;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FAnimationIndex: Integer;

This item has no description.

Private FInterval: Integer;

This item has no description.

Private FRotation: Integer;

This item has no description.

Private FPixelRatio: Integer;

This item has no description.

Private FMirrorU: Boolean;

This item has no description.

Private FMirrorV: Boolean;

This item has no description.

Private FAnimationMode: TGLSpriteAnimationMode;

This item has no description.

Private FCurrentFrameDelta: Double;

This item has no description.

Private FOnFrameChanged: TNotifyEvent;

This item has no description.

Private FOnEndFrameReached: TNotifyEvent;

This item has no description.

Private FOnStartFrameReached: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure NextFrame;

Steps the current animation to the next frame

Properties

Published property AnimationIndex: Integer read FAnimationIndex write SetAnimationIndex;

Index of the sprite animation to be used.

Published property AnimationMode: TGLSpriteAnimationMode read FAnimationMode write SetAnimationMode;

Playback mode for the current animation.

Published property Animations: TGLSpriteAnimationList read FAnimations;

A collection of animations. Stores the settings for animating then sprite.

Published property FrameRate: Single read GetFrameRate write SetFrameRate;

Sets the frames per second for the current animation. Automatically calculates the Interval. Precision will be restricted to the values of Interval since Interval takes priority.

Published property Interval: Integer read FInterval write SetInterval;

Sets the number of milliseconds between each frame. Will recalculate the Framerate when set. Will be overridden by the TGLSpriteAnimation Interval if it is greater than zero.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

The material library that stores the lib materials for the animations.

Published property MirrorU: Boolean read FMirrorU write SetMirrorU;

Mirror the generated texture coords in the U axis.

Published property MirrorV: Boolean read FMirrorV write SetMirrorV;

Mirror the generated texture coords in the V axis.

Published property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;

An event fired when the animation reaches the end frame.

Published property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;

An event fired when the animation changes to it's next frame.

Published property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;

An event fired when the animation reaches the start frame.

Published property PixelRatio: Integer read FPixelRatio write SetPixelRatio;

Used to automatically calculate the width and height of a sprite based on the size of the frame it is showing. For example, if PixelRatio is set to 100 and the current animation frame is 100 pixels wide it will set the width of the sprite to 1. If the frame is 50 pixels width the sprite will be 0.5 wide.

Published property Position;

This item has no description.

Published property Rotation: Integer read FRotation write SetRotation;

Rotates the sprite (in degrees).

Published property Scale;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.ApplicationFileIO

Unit GLS.ApplicationFileIO

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • GLS.BaseClasses
  • GLScene.Strings
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLApplicationFileIO |
Class TGLDataFile |

Functions and Procedures

function ApplicationFileIODefined: Boolean;
function FileStreamExists(const fileName: string): Boolean;
function CreateResourceStream(const ResName: string; ResType: PChar) : TGLResourceStream;
function StrToGLSResType(const AStrRes: string): TGLApplicationResource;

Types

TGLAFIOCreateFileStream = function(const fileName: string; mode: Word): TStream;
TGLAFIOFileStreamEvent = procedure(const fileName: String; mode: Word; var Stream: TStream) of object;
TGLAFIOFileStreamExists = function(const fileName: string): Boolean;
TGLAFIOFileStreamExistsEvent = function(const fileName: string) : Boolean of object;
TGLApplicationResource = (...);
TGLDataFileCapabilities = set of TGLDataFileCapability;
TGLDataFileCapability = (...);
TGLDataFileClass = class of TGLDataFile;
TGLResourceStream = TResourceStream;

Constants

GLS_RC_DDS_Type = RT_RCDATA;
GLS_RC_JPG_Type = RT_RCDATA;
GLS_RC_XML_Type = RT_RCDATA;
GLS_RC_String_Type = RT_RCDATA;

Variables

vAFIOCreateFileStream: TGLAFIOCreateFileStream = nil;
vAFIOFileStreamExists: TGLAFIOFileStreamExists = nil;

Description

Functions and Procedures

function ApplicationFileIODefined: Boolean;

Returns true if an ApplicationFileIO has been defined

function FileStreamExists(const fileName: string): Boolean;

Queries is a file stream corresponding to the fileName exists.

function CreateResourceStream(const ResName: string; ResType: PChar) : TGLResourceStream;

This item has no description.

function StrToGLSResType(const AStrRes: string): TGLApplicationResource;

This item has no description.

Types

TGLAFIOCreateFileStream = function(const fileName: string; mode: Word): TStream;

This item has no description.

TGLAFIOFileStreamEvent = procedure(const fileName: String; mode: Word; var Stream: TStream) of object;

This item has no description.

TGLAFIOFileStreamExists = function(const fileName: string): Boolean;

This item has no description.

TGLAFIOFileStreamExistsEvent = function(const fileName: string) : Boolean of object;

This item has no description.

TGLApplicationResource = (...);

This item has no description.

Values
  • aresNone
  • aresSplash
  • aresTexture
  • aresMaterial
  • aresSampler
  • aresFont
  • aresMesh
TGLDataFileCapabilities = set of TGLDataFileCapability;

This item has no description.

TGLDataFileCapability = (...);

This item has no description.

Values
  • dfcRead
  • dfcWrite
TGLDataFileClass = class of TGLDataFile;

This item has no description.

TGLResourceStream = TResourceStream;

This item has no description.

Constants

GLS_RC_DDS_Type = RT_RCDATA;

This item has no description.

GLS_RC_JPG_Type = RT_RCDATA;

This item has no description.

GLS_RC_XML_Type = RT_RCDATA;

This item has no description.

GLS_RC_String_Type = RT_RCDATA;

This item has no description.

Variables

vAFIOCreateFileStream: TGLAFIOCreateFileStream = nil;

This item has no description.

vAFIOFileStreamExists: TGLAFIOFileStreamExists = nil;


GLSysHelp v.2.5: GLS.ApplicationFileIO: Class TGLApplicationFileIO

Class TGLApplicationFileIO

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ApplicationFileIO

Declaration

type TGLApplicationFileIO = class(TComponent)

Description

Allows specifying a custom behaviour for CreateFileStream. The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable. If multiple ApplicationFileIO components exist in the application, the last one created will be the active one.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLApplicationFileIO

Overview

Fields

Private | FOnFileStream: TGLAFIOFileStreamEvent;
Private | FOnFileStreamExists: TGLAFIOFileStreamExistsEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property OnFileStream: TGLAFIOFileStreamEvent read FOnFileStream write FOnFileStream;
Published | property OnFileStreamExists: TGLAFIOFileStreamExistsEvent read FOnFileStreamExists write FOnFileStreamExists;

Description

Fields

Private FOnFileStream: TGLAFIOFileStreamEvent;

This item has no description.

Private FOnFileStreamExists: TGLAFIOFileStreamExistsEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property OnFileStream: TGLAFIOFileStreamEvent read FOnFileStream write FOnFileStream;

Event that allows you to specify a stream for the file. Destruction of the stream is at the discretion of the code that invoked CreateFileStream. Return nil to let the default mechanism take place (ie. attempt a regular file system access).

Published property OnFileStreamExists: TGLAFIOFileStreamExistsEvent read FOnFileStreamExists write FOnFileStreamExists;

Event that allows you to specify if a stream for the file exists.


GLSysHelp v.2.5: GLS.ApplicationFileIO: Class TGLDataFile

Class TGLDataFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ApplicationFileIO

Declaration

type TGLDataFile = class(TGLUpdateAbleObject)

Description

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile

Overview

Fields

Private FResourceName: string;

Methods

Public | class function Capabilities: TGLDataFileCapabilities; virtual;
Public | function CreateCopy(AOwner: TPersistent): TGLDataFile; virtual;
Public | procedure Initialize; virtual;
Public | procedure LoadFromFile(const fileName: string); virtual;
Public | procedure LoadFromStream(Stream: TStream); virtual;
Public | procedure SaveToFile(const fileName: string); virtual;
Public | procedure SaveToStream(Stream: TStream); virtual;
Private | procedure SetResourceName(const AName: string);

Properties

Public property ResourceName: string read FResourceName write SetResourceName;

Description

Fields

Private FResourceName: string;

This item has no description.

Methods

Public class function Capabilities: TGLDataFileCapabilities; virtual;

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public function CreateCopy(AOwner: TPersistent): TGLDataFile; virtual;

Duplicates Self and returns a copy. Subclasses should override this method to duplicate their data.

Public procedure Initialize; virtual;

This item has no description.

Public procedure LoadFromFile(const fileName: string); virtual;

This item has no description.

Public procedure LoadFromStream(Stream: TStream); virtual;

This item has no description.

Public procedure SaveToFile(const fileName: string); virtual;

This item has no description.

Public procedure SaveToStream(Stream: TStream); virtual;

This item has no description.

Private procedure SetResourceName(const AName: string);

This item has no description.

Properties

Public property ResourceName: string read FResourceName write SetResourceName;

Optionnal resource name. When using LoadFromFile/SaveToFile, the filename is placed in it, when using the Stream variants, the caller may place the resource name in it for parser use.


GLSysHelp v.2.5: GLS.ArchiveManager

Unit GLS.ArchiveManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.ApplicationFileIO
  • GLS.PersistentClasses
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseArchive |
Class TGLArchiveFileFormat |
Class TGLArchiveFileFormatsList |
Class TGLLibArchive |
Class TGLLibArchives |
Class TGLSArchiveManager |
Class EInvalidArchiveFile |

Functions and Procedures

function GetArchiveFileFormats: TGLArchiveFileFormatsList;
procedure RegisterArchiveFormat(const AExtension, ADescription: string; AClass: TGLBaseArchiveClass);
procedure UnregisterArchiveFormat(AClass: TGLBaseArchiveClass);
function GetArchiveManager: TGLSArchiveManager;
function ArcCreateFileStream(const FileName: string; mode: word): TStream;
function ArcFileStreamExists(const FileName: string): boolean;

Types

TCompressionLevel = (...);
TGLBaseArchiveClass = class of TGLBaseArchive;

Description

Functions and Procedures

function GetArchiveFileFormats: TGLArchiveFileFormatsList;

getting a class of accessed archiver

procedure RegisterArchiveFormat(const AExtension, ADescription: string; AClass: TGLBaseArchiveClass);

This item has no description.

procedure UnregisterArchiveFormat(AClass: TGLBaseArchiveClass);

This item has no description.

function GetArchiveManager: TGLSArchiveManager;

Caution!!! Work for one archive manager only

function ArcCreateFileStream(const FileName: string; mode: word): TStream;

GLS.ApplicationFileIO These functions are used to automate loading User enters LoadFromFile and through these functions gets the result

function ArcFileStreamExists(const FileName: string): boolean;

This item has no description.

Types

TCompressionLevel = (...);

This item has no description.

Values
  • clNone
  • clFastest
  • clDefault
  • clMax
  • clLevel1
  • clLevel2
  • clLevel3
  • clLevel4
  • clLevel5
  • clLevel6
  • clLevel7
  • clLevel8
  • clLevel9
TGLBaseArchiveClass = class of TGLBaseArchive;


GLSysHelp v.2.5: GLS.ArchiveManager: Class TGLBaseArchive

Class TGLBaseArchive

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ArchiveManager

Declaration

type TGLBaseArchive = class(TGLDataFile)

Description

BaseArchive class

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseArchive

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function ContentExists(ContentName: string): boolean; virtual; abstract;
Public | function GetContent(ContentName: string): TStream; overload; virtual; abstract;
Public | function GetContent(index: integer): TStream; overload; virtual; abstract;
Public | function GetContent(Stream: TStream; index: integer): TStream; overload; virtual; abstract;
Public | function GetContentSize(ContentName: string): integer; overload; virtual; abstract;
Public | function GetContentSize(index: integer): integer; overload; virtual; abstract;
Public | procedure AddFromFile(FileName, Path: string); virtual; abstract;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); virtual; abstract;
Public | procedure Clear; virtual; abstract;
Public | procedure Extract(index: integer; NewName: string); overload; virtual; abstract;
Public | procedure Extract(ContentName, NewName: string); overload; virtual; abstract;
Public | procedure RemoveContent(index: integer); overload; virtual; abstract;
Public | procedure RemoveContent(ContentName: string); overload; virtual; abstract;

Properties

Public | property CompressionLevel: TCompressionLevel read FCompressionLevel write SetCompressionLevel default clNone;
Public | property ContentList: TStrings read FContentList;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ContentExists(ContentName: string): boolean; virtual; abstract;

This item has no description.

Public function GetContent(ContentName: string): TStream; overload; virtual; abstract;

This item has no description.

Public function GetContent(index: integer): TStream; overload; virtual; abstract;

This item has no description.

Public function GetContent(Stream: TStream; index: integer): TStream; overload; virtual; abstract;

This item has no description.

Public function GetContentSize(ContentName: string): integer; overload; virtual; abstract;

This item has no description.

Public function GetContentSize(index: integer): integer; overload; virtual; abstract;

This item has no description.

Public procedure AddFromFile(FileName, Path: string); virtual; abstract;

This item has no description.

Public procedure AddFromStream(ContentName, Path: string; FS: TStream); virtual; abstract;

This item has no description.

Public procedure Clear; virtual; abstract;

This item has no description.

Public procedure Extract(index: integer; NewName: string); overload; virtual; abstract;

This item has no description.

Public procedure Extract(ContentName, NewName: string); overload; virtual; abstract;

This item has no description.

Public procedure RemoveContent(index: integer); overload; virtual; abstract;

This item has no description.

Public procedure RemoveContent(ContentName: string); overload; virtual; abstract;

This item has no description.

Properties

Public property CompressionLevel: TCompressionLevel read FCompressionLevel write SetCompressionLevel default clNone;

This item has no description.

Public property ContentList: TStrings read FContentList;


GLSysHelp v.2.5: GLS.ArchiveManager: Class TGLArchiveFileFormat

Class TGLArchiveFileFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ArchiveManager

Declaration

type TGLArchiveFileFormat = class(TObject)

Description

The type to record a registered class

Hierarchy

  • TObject
  • TGLArchiveFileFormat

Overview

Fields

Public | BaseArchiveClass: TGLBaseArchiveClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: integer;

Description

Fields

Public BaseArchiveClass: TGLBaseArchiveClass;

This item has no description.

Public Extension: string;

This item has no description.

Public Description: string;

This item has no description.

Public DescResID: integer;


GLSysHelp v.2.5: GLS.ArchiveManager: Class TGLArchiveFileFormatsList

Class TGLArchiveFileFormatsList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ArchiveManager

Declaration

type TGLArchiveFileFormatsList = class(TGLPersistentObjectList)

Description

The list of registered classes

Hierarchy

  • TGLPersistentObjectList
  • TGLArchiveFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(Ext: string): TGLBaseArchiveClass;
Public | function FindFromFileName(const FileName: string): TGLBaseArchiveClass;
Public | procedure Add(const Ext, Desc: string; DescID: integer; AClass: TGLBaseArchiveClass);
Public | procedure Remove(AClass: TGLBaseArchiveClass);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function FindExt(Ext: string): TGLBaseArchiveClass;

This item has no description.

Public function FindFromFileName(const FileName: string): TGLBaseArchiveClass;

This item has no description.

Public procedure Add(const Ext, Desc: string; DescID: integer; AClass: TGLBaseArchiveClass);

This item has no description.

Public procedure Remove(AClass: TGLBaseArchiveClass);


GLSysHelp v.2.5: GLS.ArchiveManager: Class TGLLibArchive

Class TGLLibArchive

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ArchiveManager

Declaration

type TGLLibArchive = class(TCollectionItem)

Description

Using the collection item for simultaneous work with several archives

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLLibArchive

Overview

Fields

Private | vArchive: TGLBaseArchive;
Private | ArcClass: TGLBaseArchiveClass;
Private | FFileName: string;
Private | FName: string;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function ContentExists(aContentName: string): boolean;
Public | function GetContent(aContentName: string): TStream; overload;
Public | function GetContent(aindex: integer): TStream; overload;
Public | function GetContentSize(aindex: integer): integer; overload;
Public | function GetContentSize(aContentName: string): integer; overload;
Private | function GetCompressionLevel: TCompressionLevel;
Private | function GetContentList: TStrings;
Public | procedure AddFromFile(aFileName, aPath: string); overload;
Public | procedure AddFromFile(aFileName: string); overload;
Public | procedure AddFromStream(aContentName: string; aF: TStream); overload;
Public | procedure AddFromStream(aContentName, aPath: string; aF: TStream); overload;
Public | procedure Clear;
Public | procedure CreateArchive(FileName: string; OverwriteExistingFile: boolean = False);
Public | procedure Extract(aindex: integer; aNewName: string); overload;
Public | procedure Extract(aContentName, aNewName: string); overload;
Public | procedure LoadFromFile(aFileName: string); overload;
Public | procedure LoadFromFile(aFileName, aAchiverType: string); overload;
Public | procedure RemoveContent(aContentName: string); overload;
Public | procedure RemoveContent(aindex: integer); overload;
Private | procedure SetCompressionLevel(aValue: TCompressionLevel);
Private | procedure SetName(const val: string);

Properties

Public | property CompressionLevel: TCompressionLevel read GetCompressionLevel write SetCompressionLevel default clDefault;
Public | property ContentList: TStrings read GetContentList;
Public | property FileName: string read FFileName;
Published | property Name: string read FName write SetName;

Description

Fields

Private vArchive: TGLBaseArchive;

This item has no description.

Private ArcClass: TGLBaseArchiveClass;

This item has no description.

Private FFileName: string;

This item has no description.

Private FName: string;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ContentExists(aContentName: string): boolean;

This item has no description.

Public function GetContent(aContentName: string): TStream; overload;

This item has no description.

Public function GetContent(aindex: integer): TStream; overload;

This item has no description.

Public function GetContentSize(aindex: integer): integer; overload;

This item has no description.

Public function GetContentSize(aContentName: string): integer; overload;

This item has no description.

Private function GetCompressionLevel: TCompressionLevel;

This item has no description.

Private function GetContentList: TStrings;

This item has no description.

Public procedure AddFromFile(aFileName, aPath: string); overload;

This item has no description.

Public procedure AddFromFile(aFileName: string); overload;

This item has no description.

Public procedure AddFromStream(aContentName: string; aF: TStream); overload;

This item has no description.

Public procedure AddFromStream(aContentName, aPath: string; aF: TStream); overload;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure CreateArchive(FileName: string; OverwriteExistingFile: boolean = False);

This item has no description.

Public procedure Extract(aindex: integer; aNewName: string); overload;

This item has no description.

Public procedure Extract(aContentName, aNewName: string); overload;

This item has no description.

Public procedure LoadFromFile(aFileName: string); overload;

This item has no description.

Public procedure LoadFromFile(aFileName, aAchiverType: string); overload;

This item has no description.

Public procedure RemoveContent(aContentName: string); overload;

This item has no description.

Public procedure RemoveContent(aindex: integer); overload;

This item has no description.

Private procedure SetCompressionLevel(aValue: TCompressionLevel);

This item has no description.

Private procedure SetName(const val: string);

This item has no description.

Properties

Public property CompressionLevel: TCompressionLevel read GetCompressionLevel write SetCompressionLevel default clDefault;

This item has no description.

Public property ContentList: TStrings read GetContentList;

This item has no description.

Public property FileName: string read FFileName;

This item has no description.

Published property Name: string read FName write SetName;


GLSysHelp v.2.5: GLS.ArchiveManager: Class TGLLibArchives

Class TGLLibArchives

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ArchiveManager

Declaration

type TGLLibArchives = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLLibArchives

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLLibArchive;
Public | function FindItemID(ID: integer): TGLLibArchive;
Public | function GetArchiveByFileName(const AName: string): TGLLibArchive;
Public | function GetFileNameOfArchive(aValue: TGLLibArchive): string;
Public | function GetLibArchiveByName(const AName: string): TGLLibArchive;
Public | function GetNameOfLibArchive(const Archive: TGLLibArchive): string;
Public | function IndexOf(const Item: TGLLibArchive): integer;
Public | function MakeUniqueName(const nameRoot: string): string;
Public | function Owner: TPersistent;

Properties

Public property Items[index: integer]: TGLLibArchive read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLLibArchive;

This item has no description.

Public function FindItemID(ID: integer): TGLLibArchive;

This item has no description.

Public function GetArchiveByFileName(const AName: string): TGLLibArchive;

searching archiver by name

Public function GetFileNameOfArchive(aValue: TGLLibArchive): string;

This item has no description.

Public function GetLibArchiveByName(const AName: string): TGLLibArchive;

This item has no description.

Public function GetNameOfLibArchive(const Archive: TGLLibArchive): string;

This item has no description.

Public function IndexOf(const Item: TGLLibArchive): integer;

This item has no description.

Public function MakeUniqueName(const nameRoot: string): string;

searching needed item

Public function Owner: TPersistent;

This item has no description.

Properties

Public property Items[index: integer]: TGLLibArchive read GetItems write SetItems;


GLSysHelp v.2.5: GLS.ArchiveManager: Class TGLSArchiveManager

Class TGLSArchiveManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ArchiveManager

Declaration

type TGLSArchiveManager = class(TComponent)

Description

ArchiveManager class

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLSArchiveManager

Overview

Fields

Private FArchives: TGLLibArchives;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ContentExists(aContentName: string): boolean;
Public | function GetArchiveByFileName(const AName: string): TGLLibArchive;
Public | function GetContent(aContentName: string): TStream;
Public | function GetFileNameOfArchive(const aArchive: TGLLibArchive): string;
Public | function OpenArchive(aFileName, aAchiverType: string): TGLLibArchive; overload;
Public | function OpenArchive(aFileName: string): TGLLibArchive; overload;
Public | procedure CloseArchive(aArchive: TGLLibArchive);
Private | Procedure SetArchives(aValue: TGLLibArchives);

Properties

Published property Archives: TGLLibArchives read FArchives write SetArchives;

Description

Fields

Private FArchives: TGLLibArchives;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ContentExists(aContentName: string): boolean;

This item has no description.

Public function GetArchiveByFileName(const AName: string): TGLLibArchive;

This item has no description.

Public function GetContent(aContentName: string): TStream;

This item has no description.

Public function GetFileNameOfArchive(const aArchive: TGLLibArchive): string;

This item has no description.

Public function OpenArchive(aFileName, aAchiverType: string): TGLLibArchive; overload;

This item has no description.

Public function OpenArchive(aFileName: string): TGLLibArchive; overload;

This item has no description.

Public procedure CloseArchive(aArchive: TGLLibArchive);

This item has no description.

Private Procedure SetArchives(aValue: TGLLibArchives);

This item has no description.

Properties

Published property Archives: TGLLibArchives read FArchives write SetArchives;


GLSysHelp v.2.5: GLS.ArchiveManager: Class EInvalidArchiveFile

Class EInvalidArchiveFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ArchiveManager

Declaration

type EInvalidArchiveFile = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EInvalidArchiveFile


GLSysHelp v.2.5: GLS.AsyncHDS

Unit GLS.AsyncHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.HeightData

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLAsyncHDS |
Class TGLAsyncHDThread |

Types

TIdleEvent = procedure(Sender:TGLAsyncHDS;TilesUpdated:boolean) of object;
TNewTilePreparedEvent = procedure (Sender : TGLAsyncHDS; HeightData : TGLHeightData) of object;
TUseDirtyTiles = (...);

Description

Types

TIdleEvent = procedure(Sender:TGLAsyncHDS;TilesUpdated:boolean) of object;

This item has no description.

TNewTilePreparedEvent = procedure (Sender : TGLAsyncHDS; HeightData : TGLHeightData) of object;

This item has no description.

TUseDirtyTiles = (...);

Determines if/how dirty tiles are displayed and when they are released. When a tile is maked as dirty, a replacement is queued immediately. However, the replacement cant be used until the HDThread has finished preparing it. Dirty tiles can be deleted as soon as they are no longer used/displayed. Possible states for a TUseDirtyTiles. hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, before allowing the renderer to switch over to the new set of tiles. (This prevents a fading checkerbox effect.)

Values
  • dtNever
  • dtUntilReplaced
  • dtUntilAllReplaced


GLSysHelp v.2.5: GLS.AsyncHDS: Class TGLAsyncHDS

Class TGLAsyncHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AsyncHDS

Declaration

type TGLAsyncHDS = class(TGLHeightDataSourceFilter)

Description

This item has no description. Showing description inherited from TGLHeightDataSourceFilter.

Height Data Source Filter. This component sits between the TGLTerrainRenderer, and a real TGLHeightDataSource. i.e. TGLTerrainRenderer links to this. This links to the real TGLHeightDataSource. Use the 'HeightDataSource' property, to link to a source HDS. The 'OnSourceDataFetched' event then gives you the opportunity to make any changes, or link in a texture to the TGLHeightData object, BEFORE it is cached. It bypasses the cache of the source HDS, by calling the source's StartPreparingData procedure directly. The TGLHeightData objects are then cached by THIS component, AFTER you have made your changes. This eliminates the need to copy and release the TGLHeightData object from the Source HDS's cache, before linking your texture. See the new version of TGLBumpmapHDS for an example. (LIN) To create your own HDSFilters, Derive from this component, and override the PreparingData procedure.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLHeightDataSourceFilter
  • TGLAsyncHDS

Overview

Fields

Private | FOnIdleEvent:TIdleEvent;
Private | FOnNewTilePrepared: TNewTilePreparedEvent;
Private | FUseDirtyTiles:TUseDirtyTiles;
Private | FTilesUpdated:boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ThreadCount:integer;
Public | function TilesUpdated:boolean;
Public | procedure BeforePreparingData(HeightData : TGLHeightData); override;
Public | procedure NewTilePrepared(HeightData:TGLHeightData);
Public | procedure StartPreparingData(HeightData : TGLHeightData); override;
Public | procedure ThreadIsIdle; override;
Public | procedure TilesUpdatedFlagReset;
Public | procedure WaitFor(TimeOut: integer = 2000);

Properties

Published | property Active;
Published | property MaxThreads;
Published | property OnIdle : TIdleEvent read FOnIdleEvent write FOnIdleEvent;
Published | property OnNewTilePrepared : TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property UseDirtyTiles : TUseDirtyTiles read FUseDirtyTiles write FUseDirtyTiles;

Description

Fields

Private FOnIdleEvent:TIdleEvent;

This item has no description.

Private FOnNewTilePrepared: TNewTilePreparedEvent;

This item has no description.

Private FUseDirtyTiles:TUseDirtyTiles;

This item has no description.

Private FTilesUpdated:boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

TilesUpdated:boolean;

Public destructor Destroy; override;

This item has no description.

Public function ThreadCount:integer;

This item has no description.

Public function TilesUpdated:boolean;

This function prevents the user from trying to write directly to this variable. FTilesUpdated if NOT threadsafe and should only be reset with TilesUpdatedFlagReset.

Public procedure BeforePreparingData(HeightData : TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.BeforePreparingData.

This is called BEFORE StartPreparing Data, but always from the main thread.

Public procedure NewTilePrepared(HeightData:TGLHeightData);

This item has no description.

Public procedure StartPreparingData(HeightData : TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Public procedure ThreadIsIdle; override;

This item has no description.

Public procedure TilesUpdatedFlagReset;

Returns true if tiles have been updated since the flag was last reset

Public procedure WaitFor(TimeOut: integer = 2000);

Wait for all running threads to finish. Should only be called after setting Active to false, to prevent new threads from starting.

Properties

Published property Active;

sets the maximum number of simultaineous threads that will prepare tiles.(>1 is rarely needed)

Published property MaxThreads;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxThreads.

Maximum number of background threads. If 0 (zero), multithreading is disabled and StartPreparingData will be called from the mainthread, and all preload requirements (queued TGLHeightData objects) will be loaded in sequence from the main thread. If 1, basic multithreading and queueing gets enabled, ie. StartPreparingData will be called from a thread, but from one thread only (ie. there is no need to implement a TGLHeightDataThread, just make sure StartPreparingData code is thread-safe). Other values (2 and more) are relevant only if you implement a TGLHeightDataThread subclass and fire it in StartPreparingData.

Published property OnIdle : TIdleEvent read FOnIdleEvent write FOnIdleEvent;

sets the TilesUpdatedFlag to false; (is ThreadSafe)

Published property OnNewTilePrepared : TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;

This item has no description.

Published property UseDirtyTiles : TUseDirtyTiles read FUseDirtyTiles write FUseDirtyTiles;


GLSysHelp v.2.5: GLS.AsyncHDS: Class TGLAsyncHDThread

Class TGLAsyncHDThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AsyncHDS

Declaration

type TGLAsyncHDThread = class(TGLHeightDataThread)

Description

This item has no description. Showing description inherited from TGLHeightDataThread.

A thread specialized for processing TGLHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly

Hierarchy

  • TObject
  • TThread
  • TGLHeightDataThread
  • TGLAsyncHDThread

Overview

Fields

Public | Owner: TGLAsyncHDS;
Public | HDS: TGLHeightDataSource;

Methods

Public | Procedure Execute; override;
Public | Procedure Sync;

Description

Fields

Public Owner: TGLAsyncHDS;

This item has no description.

Public HDS: TGLHeightDataSource;

This item has no description.

Methods

Public Procedure Execute; override;

This item has no description.

Public Procedure Sync;


GLSysHelp v.2.5: GLS.AsyncTimer

Unit GLS.AsyncTimer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.SyncObjs
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLAsyncTimer |

Constants

cDEFAULT_TIMER_INTERVAL = 1000;

Description

Constants

cDEFAULT_TIMER_INTERVAL = 1000;


GLSysHelp v.2.5: GLS.AsyncTimer: Class TGLAsyncTimer

Class TGLAsyncTimer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AsyncTimer

Declaration

type TGLAsyncTimer = class(TComponent)

Description

Asynchronous timer component (actual 1 ms resolution, if CPU fast enough). Keep in mind timer resolution is obtained in-between events, but events are not triggered every x ms. For instance if you set the interval to 5 ms, and your Timer event takes 1 ms to complete, Timer events will actually be triggered every 5+1=6 ms (that's why it's "asynchronous"). This component is based on ThreadedTimer by Carlos Barbosa.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLAsyncTimer

Overview

Fields

Private | FEnabled: Boolean;
Private | FOnTimer: TNotifyEvent;
Private | FTimerThread: TThread;
Private | FMutex: TCriticalSection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled default False;
Published | property Interval: Word read GetInterval write SetInterval default cDEFAULT_TIMER_INTERVAL;
Published | property OnTimer: TNotifyEvent read FOnTimer write FOnTimer;
Published | property ThreadPriority: TThreadPriority read GetThreadPriority write SetThreadPriority default tpTimeCritical;

Description

Fields

Private FEnabled: Boolean;

This item has no description.

Private FOnTimer: TNotifyEvent;

This item has no description.

Private FTimerThread: TThread;

This item has no description.

Private FMutex: TCriticalSection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled default False;

This item has no description.

Published property Interval: Word read GetInterval write SetInterval default cDEFAULT_TIMER_INTERVAL;

This item has no description.

Published property OnTimer: TNotifyEvent read FOnTimer write FOnTimer;

This item has no description.

Published property ThreadPriority: TThreadPriority read GetThreadPriority write SetThreadPriority default tpTimeCritical;


GLSysHelp v.2.5: GLS.Atmosphere

Unit GLS.Atmosphere

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.SysUtils
  • System.Classes
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.Objects
  • GLS.Cadencer
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Context
  • GLScene.Strings
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLAtmosphereException |
Class TGLCustomAtmosphere |
Class TGLAtmosphere |

Types

TGLAtmosphereBlendingMode = (...);

Description

Types

TGLAtmosphereBlendingMode = (...);

With atmosphere options: - aabmOneMinusSrcAlpha is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big; - bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).

Values
  • abmOneMinusDstColor
  • abmOneMinusSrcAlpha


GLSysHelp v.2.5: GLS.Atmosphere: Class EGLAtmosphereException

Class EGLAtmosphereException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Atmosphere

Declaration

type EGLAtmosphereException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLAtmosphereException


GLSysHelp v.2.5: GLS.Atmosphere: Class TGLCustomAtmosphere

Class TGLCustomAtmosphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Atmosphere

Declaration

type TGLCustomAtmosphere = class(TGLBaseSceneObject)

Description

This class imitates an atmosphere around a planet

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomAtmosphere

Overview

Fields

Private | cosCache: array of Single;
Private | sinCache: array of Single;
Private | pVertex: PVectorArray;
Private | pColor: PVectorArray;
Private | FSlices: Integer;
Private | FBlendingMode: TGLAtmosphereBlendingMode;
Private | FPlanetRadius: Single;
Private | FAtmosphereRadius: Single;
Private | FOpacity: Single;
Private | FLowAtmColor: TGLColor;
Private | FHighAtmColor: TGLColor;
Private | FSun: TGLBaseSceneObject;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Private | function StoreAtmosphereRadius: Boolean;
Private | function StoreHighAtmColor: Boolean;
Private | function StoreLowAtmColor: Boolean;
Private | function StoreOpacity: Boolean;
Private | function StorePlanetRadius: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure SetOptimalAtmosphere(const ARadius: Single);
Public | procedure SetOptimalAtmosphere2(const ARadius: Single);
Public | procedure TogleBlendingMode;
Private | procedure EnableGLBlendingMode(StateCache: TGLStateCache);
Private | procedure SetAtmosphereRadius(const Value: Single);
Private | procedure SetHighAtmColor(const AValue: TGLColor);
Private | procedure SetLowAtmColor(const AValue: TGLColor);
Private | procedure SetPlanetRadius(const Value: Single);
Private | procedure SetSlices(const Value: Integer);
Private | procedure SetSun(const Value: TGLBaseSceneObject);

Properties

Public | property AtmosphereRadius: Single read FAtmosphereRadius write SetAtmosphereRadius stored StoreAtmosphereRadius;
Public | property BlendingMode: TGLAtmosphereBlendingMode read FBlendingMode write FBlendingMode default abmOneMinusSrcAlpha;
Public | property HighAtmColor: TGLColor read FHighAtmColor write SetHighAtmColor stored StoreHighAtmColor;
Public | property LowAtmColor: TGLColor read FLowAtmColor write SetLowAtmColor stored StoreLowAtmColor;
Public | property Opacity: Single read FOpacity write FOpacity stored StoreOpacity;
Public | property PlanetRadius: Single read FPlanetRadius write SetPlanetRadius stored StorePlanetRadius;
Public | property Slices: Integer read FSlices write SetSlices default 60;
Public | property Sun: TGLBaseSceneObject read FSun write SetSun;

Description

Fields

Private cosCache: array of Single;

Used in DoRenderl

Private sinCache: array of Single;

Used in DoRenderl

Private pVertex: PVectorArray;

This item has no description.

Private pColor: PVectorArray;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FBlendingMode: TGLAtmosphereBlendingMode;

This item has no description.

Private FPlanetRadius: Single;

This item has no description.

Private FAtmosphereRadius: Single;

This item has no description.

Private FOpacity: Single;

This item has no description.

Private FLowAtmColor: TGLColor;

This item has no description.

Private FHighAtmColor: TGLColor;

This item has no description.

Private FSun: TGLBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

Used to determine extents

Private function StoreAtmosphereRadius: Boolean;

This item has no description.

Private function StoreHighAtmColor: Boolean;

This item has no description.

Private function StoreLowAtmColor: Boolean;

This item has no description.

Private function StoreOpacity: Boolean;

This item has no description.

Private function StorePlanetRadius: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

changes between 2 blending modes Standard component stuff

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Main rendering procedure

Public procedure SetOptimalAtmosphere(const ARadius: Single);

This item has no description.

Public procedure SetOptimalAtmosphere2(const ARadius: Single);

absolute

Public procedure TogleBlendingMode;

relative

Private procedure EnableGLBlendingMode(StateCache: TGLStateCache);

This item has no description.

Private procedure SetAtmosphereRadius(const Value: Single);

This item has no description.

Private procedure SetHighAtmColor(const AValue: TGLColor);

This item has no description.

Private procedure SetLowAtmColor(const AValue: TGLColor);

This item has no description.

Private procedure SetPlanetRadius(const Value: Single);

This item has no description.

Private procedure SetSlices(const Value: Integer);

This item has no description.

Private procedure SetSun(const Value: TGLBaseSceneObject);

This item has no description.

Properties

Public property AtmosphereRadius: Single read FAtmosphereRadius write SetAtmosphereRadius stored StoreAtmosphereRadius;

AtmosphereRadius > PlanetRadius!

Public property BlendingMode: TGLAtmosphereBlendingMode read FBlendingMode write FBlendingMode default abmOneMinusSrcAlpha;

This item has no description.

Public property HighAtmColor: TGLColor read FHighAtmColor write SetHighAtmColor stored StoreHighAtmColor;

This item has no description.

Public property LowAtmColor: TGLColor read FLowAtmColor write SetLowAtmColor stored StoreLowAtmColor;

Use value slightly lower than actual radius, for antialiasing effect

Public property Opacity: Single read FOpacity write FOpacity stored StoreOpacity;

This item has no description.

Public property PlanetRadius: Single read FPlanetRadius write SetPlanetRadius stored StorePlanetRadius;

This item has no description.

Public property Slices: Integer read FSlices write SetSlices default 60;

This item has no description.

Public property Sun: TGLBaseSceneObject read FSun write SetSun;


GLSysHelp v.2.5: GLS.Atmosphere: Class TGLAtmosphere

Class TGLAtmosphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Atmosphere

Declaration

type TGLAtmosphere = class(TGLCustomAtmosphere)

Description

This item has no description. Showing description inherited from TGLCustomAtmosphere.

This class imitates an atmosphere around a planet

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomAtmosphere
  • TGLAtmosphere

Overview

Properties

Published | property AtmosphereRadius;
Published | property Behaviours;
Published | property BlendingMode;
Published | property Effects;
Published | property HighAtmColor;
Published | property LowAtmColor;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Opacity;
Published | property PlanetRadius;
Published | property Position;
Published | property ShowAxes;
Published | property Slices;
Published | property Sun;
Published | property Visible;

Description

Properties

Published property AtmosphereRadius;

This item has no description. Showing description inherited from TGLCustomAtmosphere.AtmosphereRadius.

AtmosphereRadius > PlanetRadius!

Published property Behaviours;

This item has no description.

Published property BlendingMode;

This item has no description.

Published property Effects;

This item has no description.

Published property HighAtmColor;

This item has no description.

Published property LowAtmColor;

This item has no description. Showing description inherited from TGLCustomAtmosphere.LowAtmColor.

Use value slightly lower than actual radius, for antialiasing effect

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Opacity;

This item has no description.

Published property PlanetRadius;

This item has no description.

Published property Position;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property Slices;

This item has no description.

Published property Sun;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.AVIRecorder

Unit GLS.AVIRecorder

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • VCL.Controls
  • VCL.Forms
  • VCL.Extctrls
  • VCL.Graphics
  • VCL.Dialogs
  • Formats.VFW
  • GLS.Graphics
  • GLS.Scene
  • GLS.SceneViewer

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLAVIRecorder |

Types

PAVIStream = ˆIAVIStream;
TAVICompressor = (...);
TAVIImageRetrievalMode = (...);
TAVIRecorderPostProcessEvent = procedure(Sender: TObject; frame: TBitmap) of object;
TAVIRecorderState = (...);
TAVISizeRestriction = (...);

Description

Types

PAVIStream = ˆIAVIStream;

This item has no description.

TAVICompressor = (...);

This item has no description.

Values
  • acDefault
  • acShowDialog
  • acDivX
TAVIImageRetrievalMode = (...);

Image retrieval mode for frame capture. Following modes are supported: irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution

Values
  • irmSnapShot
  • irmRenderToBitmap
  • irmBitBlt
TAVIRecorderPostProcessEvent = procedure(Sender: TObject; frame: TBitmap) of object;

This item has no description.

TAVIRecorderState = (...);

This item has no description.

Values
  • rsNone
  • rsRecording
TAVISizeRestriction = (...);

Frame size restriction. Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.

Values
  • srNoRestriction
  • srForceBlock2x2
  • srForceBlock4x4
  • srForceBlock8x8


GLSysHelp v.2.5: GLS.AVIRecorder: Class TGLAVIRecorder

Class TGLAVIRecorder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.AVIRecorder

Declaration

type TGLAVIRecorder = class(TComponent)

Description

Component to make it easy to record GLScene frames into an AVI file.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLAVIRecorder

Overview

Fields

Private | AVIBitmap: TBitmap;
Private | AVIFrameIndex: integer;
Private | AVI_DPI: integer;
Private | asi: TAVIStreamInfo;
Private | pfile: IAVIFile;
Private | Stream: IAVIStream;
Private | Stream_c: IAVIStream;
Private | FBitmapInfo: PBitmapInfoHeader;
Private | FBitmapBits: Pointer;
Private | FBitmapSize: Dword;
Private | FTempName: String;
Private | FAVIFilename: string;
Private | FFPS: byte;
Private | FWidth: integer;
Private | FHeight: integer;
Private | FSizeRestriction: TAVISizeRestriction;
Private | FImageRetrievalMode: TAVIImageRetrievalMode;
Private | RecorderState: TAVIRecorderState;
Private | FOnPostProcessEvent: TAVIRecorderPostProcessEvent;
Private | FBuffer: TGLSceneBuffer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateAVIFile(DPI: integer = 0): boolean;
Public | function Recording: boolean;
Public | procedure AddAVIFrame; overload;
Public | procedure AddAVIFrame(bmp: TBitmap); overload;
Public | procedure CloseAVIFile(UserAbort: boolean = false);
Private | procedure SetGLNonVisualViewer(const Value: TGLNonVisualViewer);
Private | procedure SetGLSceneViewer(const Value: TGLSceneViewer);
Private | procedure SetHeight(const val: integer);
Private | procedure SetSizeRestriction(const val: TAVISizeRestriction);
Private | procedure SetWidth(const val: integer);

Properties

Published | property Compressor: TAVICompressor read FCompressor write FCompressor default acDefault;
Published | property Filename: String read FAVIFilename write FAVIFilename;
Published | property FPS: byte read FFPS write FFPS default 25;
Published | property GLNonVisualViewer: TGLNonVisualViewer read FGLNonVisualViewer write SetGLNonVisualViewer;
Published | property GLSceneViewer: TGLSceneViewer read FGLSceneViewer write SetGLSceneViewer;
Published | property Height: integer read FHeight write SetHeight;
Published | property ImageRetrievalMode: TAVIImageRetrievalMode read FImageRetrievalMode write FImageRetrievalMode default irmBitBlt;
Published | property OnPostProcessEvent: TAVIRecorderPostProcessEvent read FOnPostProcessEvent write FOnPostProcessEvent;
Published | property SizeRestriction: TAVISizeRestriction read FSizeRestriction write SetSizeRestriction default srForceBlock8x8;
Published | property Width: integer read FWidth write SetWidth;

Description

Fields

Private AVIBitmap: TBitmap;

This item has no description.

Private AVIFrameIndex: integer;

This item has no description.

Private AVI_DPI: integer;

This item has no description.

Private asi: TAVIStreamInfo;

This item has no description.

Private pfile: IAVIFile;

This item has no description.

Private Stream: IAVIStream;

This item has no description.

Private Stream_c: IAVIStream;

This item has no description.

Private FBitmapInfo: PBitmapInfoHeader;

AVI stream and stream to be compressed

Private FBitmapBits: Pointer;

This item has no description.

Private FBitmapSize: Dword;

This item has no description.

Private FTempName: String;

This item has no description.

Private FAVIFilename: string;

so that we know the filename to delete case of user abort

Private FFPS: byte;

This item has no description.

Private FWidth: integer;

This item has no description.

Private FHeight: integer;

This item has no description.

Private FSizeRestriction: TAVISizeRestriction;

This item has no description.

Private FImageRetrievalMode: TAVIImageRetrievalMode;

This item has no description.

Private RecorderState: TAVIRecorderState;

This item has no description.

Private FOnPostProcessEvent: TAVIRecorderPostProcessEvent;

This item has no description.

Private FBuffer: TGLSceneBuffer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateAVIFile(DPI: integer = 0): boolean;

This item has no description.

Public function Recording: boolean;

This item has no description.

Public procedure AddAVIFrame; overload;

This item has no description.

Public procedure AddAVIFrame(bmp: TBitmap); overload;

This item has no description.

Public procedure CloseAVIFile(UserAbort: boolean = false);

This item has no description.

Private procedure SetGLNonVisualViewer(const Value: TGLNonVisualViewer);

This item has no description.

Private procedure SetGLSceneViewer(const Value: TGLSceneViewer);

This item has no description.

Private procedure SetHeight(const val: integer);

This item has no description.

Private procedure SetSizeRestriction(const val: TAVISizeRestriction);

This item has no description.

Private procedure SetWidth(const val: integer);

This item has no description.

Properties

Published property Compressor: TAVICompressor read FCompressor write FCompressor default acDefault;

This item has no description.

Published property Filename: String read FAVIFilename write FAVIFilename;

This item has no description.

Published property FPS: byte read FFPS write FFPS default 25;

This item has no description.

Published property GLNonVisualViewer: TGLNonVisualViewer read FGLNonVisualViewer write SetGLNonVisualViewer;

This item has no description.

Published property GLSceneViewer: TGLSceneViewer read FGLSceneViewer write SetGLSceneViewer;

This item has no description.

Published property Height: integer read FHeight write SetHeight;

This item has no description.

Published property ImageRetrievalMode: TAVIImageRetrievalMode read FImageRetrievalMode write FImageRetrievalMode default irmBitBlt;

This item has no description.

Published property OnPostProcessEvent: TAVIRecorderPostProcessEvent read FOnPostProcessEvent write FOnPostProcessEvent;

This item has no description.

Published property SizeRestriction: TAVISizeRestriction read FSizeRestriction write SetSizeRestriction default srForceBlock8x8;

This item has no description.

Published property Width: integer read FWidth write SetWidth;


GLSysHelp v.2.5: GLS.BaseMeshSilhouette

Unit GLS.BaseMeshSilhouette

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.VectorFileObjects
  • GLS.Silhouette

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFaceGroupConnectivity |
Class TGLBaseMeshConnectivity |


GLSysHelp v.2.5: GLS.BaseMeshSilhouette: Class TGLFaceGroupConnectivity

Class TGLFaceGroupConnectivity

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BaseMeshSilhouette

Declaration

type TGLFaceGroupConnectivity = class(TGLConnectivity)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBaseConnectivity
  • TGLConnectivity
  • TGLFaceGroupConnectivity

Overview

Fields

Private | FMeshObject: TGLMeshObject;
Private | FOwnsVertices: boolean;

Methods

Public | constructor Create(APrecomputeFaceNormal: boolean); override;
Public | constructor CreateFromMesh(aMeshObject: TGLMeshObject; APrecomputeFaceNormal: boolean);
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure RebuildEdgeList;
Private | procedure SetMeshObject(const Value: TGLMeshObject);

Properties

Public property MeshObject: TGLMeshObject read FMeshObject write SetMeshObject;

Description

Fields

Private FMeshObject: TGLMeshObject;

This item has no description.

Private FOwnsVertices: boolean;

This item has no description.

Methods

Public constructor Create(APrecomputeFaceNormal: boolean); override;

This item has no description.

Public constructor CreateFromMesh(aMeshObject: TGLMeshObject; APrecomputeFaceNormal: boolean);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Clear; override;

This item has no description. Showing description inherited from TGLConnectivity.Clear.

Clears out all connectivity information.

Public procedure RebuildEdgeList;

Builds the connectivity information.

Private procedure SetMeshObject(const Value: TGLMeshObject);

This item has no description.

Properties

Public property MeshObject: TGLMeshObject read FMeshObject write SetMeshObject;


GLSysHelp v.2.5: GLS.BaseMeshSilhouette: Class TGLBaseMeshConnectivity

Class TGLBaseMeshConnectivity

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BaseMeshSilhouette

Declaration

type TGLBaseMeshConnectivity = class(TGLBaseConnectivity)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBaseConnectivity
  • TGLBaseMeshConnectivity

Overview

Fields

Private | FBaseMesh: TGLBaseMesh;
Private | FFaceGroupConnectivityList: TList;

Methods

Public | constructor Create(APrecomputeFaceNormal: boolean); override;
Public | constructor CreateFromMesh(aBaseMesh: TGLBaseMesh);
Public | destructor Destroy; override;
Private | function GetConnectivityCount: integer;
Private | function GetFaceGroupConnectivity(i: integer): TGLFaceGroupConnectivity;
Public | procedure Clear(SaveFaceGroupConnectivity: boolean);
Public | procedure CreateSilhouette(const silhouetteParameters: TGLSilhouetteParameters; var aSilhouette: TGLSilhouette; AddToSilhouette: boolean);
Public | procedure RebuildEdgeList;
Private | procedure SetBaseMesh(const Value: TGLBaseMesh);

Properties

Public | property BaseMesh: TGLBaseMesh read FBaseMesh write SetBaseMesh;
Public | property ConnectivityCount: integer read GetConnectivityCount;
Public | property FaceGroupConnectivity[i: integer]: TGLFaceGroupConnectivity read GetFaceGroupConnectivity;

Description

Fields

Private FBaseMesh: TGLBaseMesh;

This item has no description.

Private FFaceGroupConnectivityList: TList;

This item has no description.

Methods

Public constructor Create(APrecomputeFaceNormal: boolean); override;

This item has no description.

Public constructor CreateFromMesh(aBaseMesh: TGLBaseMesh);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetConnectivityCount: integer;

This item has no description.

Private function GetFaceGroupConnectivity(i: integer): TGLFaceGroupConnectivity;

This item has no description.

Public procedure Clear(SaveFaceGroupConnectivity: boolean);

This item has no description.

Public procedure CreateSilhouette(const silhouetteParameters: TGLSilhouetteParameters; var aSilhouette: TGLSilhouette; AddToSilhouette: boolean);

This item has no description.

Public procedure RebuildEdgeList;

Builds the connectivity information.

Private procedure SetBaseMesh(const Value: TGLBaseMesh);

This item has no description.

Properties

Public property BaseMesh: TGLBaseMesh read FBaseMesh write SetBaseMesh;

This item has no description.

Public property ConnectivityCount: integer read GetConnectivityCount;

This item has no description.

Public property FaceGroupConnectivity[i: integer]: TGLFaceGroupConnectivity read GetFaceGroupConnectivity;


GLSysHelp v.2.5: GLS.Behaviours

Unit GLS.Behaviours

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLS.Scene
  • GLScene.VectorGeometry
  • GLScene.XCollection
  • GLS.BaseClasses
  • GLS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDamping |
Class TGLBInertia |
Class TGLBAcceleration |

Functions and Procedures

function GetInertia(const AGLSceneObject: TGLBaseSceneObject): TGLBInertia;
function GetOrCreateInertia(behaviours: TGLBehaviours): TGLBInertia; overload;
function GetOrCreateInertia(obj: TGLBaseSceneObject): TGLBInertia; overload;
function GetOrCreateAcceleration(behaviours: TGLBehaviours): TGLBAcceleration; overload;
function GetOrCreateAcceleration(obj: TGLBaseSceneObject): TGLBAcceleration; overload;

Description

Functions and Procedures

function GetInertia(const AGLSceneObject: TGLBaseSceneObject): TGLBInertia;

Returns or creates the TGLBInertia within the given behaviours. This helper function is convenient way to access a TGLBInertia.

function GetOrCreateInertia(behaviours: TGLBehaviours): TGLBInertia; overload;

This item has no description.

function GetOrCreateInertia(obj: TGLBaseSceneObject): TGLBInertia; overload;

This item has no description.

function GetOrCreateAcceleration(behaviours: TGLBehaviours): TGLBAcceleration; overload;

Returns or creates the TGLBAcceleration within the given behaviours. This helper function is convenient way to access a TGLBAcceleration.

function GetOrCreateAcceleration(obj: TGLBaseSceneObject): TGLBAcceleration; overload;


GLSysHelp v.2.5: GLS.Behaviours: Class TGLDamping

Class TGLDamping

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Behaviours

Declaration

type TGLDamping = class(TGLUpdateAbleObject)

Description

Holds parameters for a basic damping model by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass. Formulas: damping = constant + linear * Speed + quadratic * Speedˆ2 accel = damping / Mass That's just basic physics. A note on the components: constant: use it for solid friction (will stop abruptly an object after decreasing its speed. linear: linear friction damping. quadratic: expresses viscosity

Hierarchy

  • TGLUpdateAbleObject
  • TGLDamping

Overview

Fields

Private | FConstant: single;
Private | FLinear: single;
Private | FQuadratic: single;

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AsString(const damping: TGLDamping): String;
Public | function Calculate(speed, deltaTime: Double): Double;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader);
Public | procedure SetDamping(const constant: Single = 0; const linear: Single = 0; const quadratic: Single = 0);
Public | procedure WriteToFiler(writer: TWriter);

Properties

Published | property Constant: Single read FConstant write FConstant;
Published | property Linear: Single read FLinear write FLinear;
Published | property Quadratic: Single read FQuadratic write FQuadratic;

Description

Fields

Private FConstant: single;

This item has no description.

Private FLinear: single;

This item has no description.

Private FQuadratic: single;

This item has no description.

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AsString(const damping: TGLDamping): String;

Returns a "[constant; linear; quadratic]" String

Public function Calculate(speed, deltaTime: Double): Double;

Calculates attenuated speed over deltaTime. integration step is 0.01 sec, and the following formula is applied at each step: constant+linear*speed+quadratic*speedˆ2

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ReadFromFiler(reader: TReader);

This item has no description.

Public procedure SetDamping(const constant: Single = 0; const linear: Single = 0; const quadratic: Single = 0);

Sets all damping parameters in a single call.

Public procedure WriteToFiler(writer: TWriter);

This item has no description.

Properties

Published property Constant: Single read FConstant write FConstant;

This item has no description.

Published property Linear: Single read FLinear write FLinear;

This item has no description.

Published property Quadratic: Single read FQuadratic write FQuadratic;


GLSysHelp v.2.5: GLS.Behaviours: Class TGLBInertia

Class TGLBInertia

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Behaviours

Declaration

type TGLBInertia = class(TGLBehaviour)

Description

Simple translation and rotation Inertia behaviour. Stores translation and rotation speeds, to which you can apply accelerations. Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBInertia

Overview

Fields

Private | FMass: single;
Private | FTranslationSpeed: TGLCoordinates;
Private | FTurnSpeed: single;
Private | FRollSpeed: single;
Private | FPitchSpeed: single;
Private | FTranslationDamping: TGLDamping;
Private | FRotationDamping: TGLDamping;
Private | FDampingEnabled: boolean;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: boolean; override;
Public | procedure ApplyForce(const deltaTime: Double; const Force: TGLVector);
Public | procedure ApplyTorque(const deltaTime: double; const turnTorque, rollTorque, pitchTorque: single);
Public | procedure ApplyTranslationAcceleration(const deltaTime: double; const accel: TGLVector);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure MirrorTranslation;
Public | procedure SurfaceBounce(const surfaceNormal: TGLVector; restitution: single);

Properties

Published | property DampingEnabled: boolean read FDampingEnabled write FDampingEnabled;
Published | property Mass: single read FMass write FMass;
Published | property PitchSpeed: single read FPitchSpeed write FPitchSpeed;
Published | property RollSpeed: single read FRollSpeed write FRollSpeed;
Published | property RotationDamping: TGLDamping read FRotationDamping write SetRotationDamping;
Published | property TranslationDamping: TGLDamping read FTranslationDamping write SetTranslationDamping;
Published | property TranslationSpeed: TGLCoordinates read FTranslationSpeed write SetTranslationSpeed;
Published | property TurnSpeed: single read FTurnSpeed write FTurnSpeed;

Description

Fields

Private FMass: single;

This item has no description.

Private FTranslationSpeed: TGLCoordinates;

This item has no description.

Private FTurnSpeed: single;

This item has no description.

Private FRollSpeed: single;

This item has no description.

Private FPitchSpeed: single;

This item has no description.

Private FTranslationDamping: TGLDamping;

This item has no description.

Private FRotationDamping: TGLDamping;

This item has no description.

Private FDampingEnabled: boolean;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure ApplyForce(const deltaTime: Double; const Force: TGLVector);

Applies a timed force to the inertia. If Mass is null, nothing is done.

Public procedure ApplyTorque(const deltaTime: double; const turnTorque, rollTorque, pitchTorque: single);

Applies a timed torque to the inertia (yuck!). This gets a "yuck!" because it is as false as the rest of the rotation model.

Public procedure ApplyTranslationAcceleration(const deltaTime: double; const accel: TGLVector);

Adds time-proportionned acceleration to the speed.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure MirrorTranslation;

Inverts the translation vector.

Public procedure SurfaceBounce(const surfaceNormal: TGLVector; restitution: single);

Bounce speed as if hitting a surface. restitution is the coefficient of restituted energy (1=no energy loss, 0=no bounce). The normal is NOT assumed to be normalized.

Properties

Published property DampingEnabled: boolean read FDampingEnabled write FDampingEnabled;

Enable/Disable damping (damping has a high cpu-cycle cost). Damping is enabled by default.

Published property Mass: single read FMass write FMass;

This item has no description.

Published property PitchSpeed: single read FPitchSpeed write FPitchSpeed;

This item has no description.

Published property RollSpeed: single read FRollSpeed write FRollSpeed;

This item has no description.

Published property RotationDamping: TGLDamping read FRotationDamping write SetRotationDamping;

Damping applied to rotation speed (yuck!). Well, this one is not "exact", like TranslationDamping, and neither it is "physical" since I'm reusing the mass and... and... well don't show this to your science teacher 8). Anyway that's easier to use than the realworld formulas, calculated faster, and properly used can give a good illusion of reality.

Published property TranslationDamping: TGLDamping read FTranslationDamping write SetTranslationDamping;

Damping applied to translation speed. Note that it is not "exactly" applied, ie. if damping would stop your object after 0.5 time unit, and your progression steps are of 1 time unit, there will be an integration error of 0.5 time unit.

Published property TranslationSpeed: TGLCoordinates read FTranslationSpeed write SetTranslationSpeed;

This item has no description.

Published property TurnSpeed: single read FTurnSpeed write FTurnSpeed;


GLSysHelp v.2.5: GLS.Behaviours: Class TGLBAcceleration

Class TGLBAcceleration

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Behaviours

Declaration

type TGLBAcceleration = class(TGLBehaviour)

Description

Applies a constant acceleration to a TGLBInertia.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBAcceleration

Overview

Fields

Private FAcceleration: TGLCoordinates;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;

Properties

Published property Acceleration: TGLCoordinates read FAcceleration write FAcceleration;

Description

Fields

Private FAcceleration: TGLCoordinates;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Properties

Published property Acceleration: TGLCoordinates read FAcceleration write FAcceleration;


GLSysHelp v.2.5: GLS.BitmapFont

Unit GLS.BitmapFont

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpengL
  • System.Classes
  • System.SysUtils
  • System.Types
  • Vcl.Graphics
  • Vcl.StdCtrls
  • GLScene.OpenGLTokens
  • GLScene.TextureFormat
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.Context
  • GLS.Texture
  • GLS.State
  • GLScene.Utils
  • GLS.Graphics
  • GLS.Color
  • GLS.BaseClasses
  • GLS.RenderContextInfo
  • GLS.PersistentClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBitmapFontRange |
Class TGLBitmapFontRanges |
Record TCharInfo |
Class TGLCustomBitmapFont |
Class TGLBitmapFont |
Class TGLFlatText |

Types

PCharInfo = ˆTCharInfo;
TGLFlatTextOption = (...);
TGLFlatTextOptions = set of TGLFlatTextOption;

Description

Types

PCharInfo = ˆTCharInfo;

This item has no description.

TGLFlatTextOption = (...);

This item has no description.

Values
  • ftoTwoSided
TGLFlatTextOptions = set of TGLFlatTextOption;


GLSysHelp v.2.5: GLS.BitmapFont: Class TGLBitmapFontRange

Class TGLBitmapFontRange

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BitmapFont

Declaration

type TGLBitmapFontRange = class(TCollectionItem)

Description

An individual character range in a bitmap font. A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLBitmapFontRange

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | function GetStartASCII: WideString;
Private | function GetStopASCII: WideString;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;

Properties

Published | property CharCount: Integer read FCharCount;
Published | property StartASCII: WideString read GetStartASCII write SetStartASCII;
Published | property StartGlyphIdx: Integer read FStartGlyphIdx write SetStartGlyphIdx;
Published | property StopASCII: WideString read GetStopASCII write SetStopASCII;
Published | property StopGlyphIdx: Integer read FStopGlyphIdx;

Description

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetStartASCII: WideString;

This item has no description.

Private function GetStopASCII: WideString;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Published property CharCount: Integer read FCharCount;

This item has no description.

Published property StartASCII: WideString read GetStartASCII write SetStartASCII;

This item has no description.

Published property StartGlyphIdx: Integer read FStartGlyphIdx write SetStartGlyphIdx;

This item has no description.

Published property StopASCII: WideString read GetStopASCII write SetStopASCII;

This item has no description.

Published property StopGlyphIdx: Integer read FStopGlyphIdx;


GLSysHelp v.2.5: GLS.BitmapFont: Class TGLBitmapFontRanges

Class TGLBitmapFontRanges

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BitmapFont

Declaration

type TGLBitmapFontRanges = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLBitmapFontRanges

Overview

Fields

Private FCharCount: Integer;

Methods

Public | constructor Create(AOwner: TComponent);
Public | destructor Destroy; override;
Public | function Add(const StartASCII, StopASCII: AnsiChar) : TGLBitmapFontRange; overload;
Public | function Add(const StartASCII, StopASCII: WideChar) : TGLBitmapFontRange; overload;
Public | function Add: TGLBitmapFontRange; overload;
Public | function CharacterToTileIndex(aChar: WideChar): Integer;
Public | function FindItemID(ID: Integer): TGLBitmapFontRange;
Public | function TileIndexToChar(aIndex: Integer): WideChar;
Public | procedure NotifyChange;

Properties

Public | property CharacterCount: Integer read FCharCount;
Public | property Items[index: Integer]: TGLBitmapFontRange read GetItems write SetItems;

Description

Fields

Private FCharCount: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add(const StartASCII, StopASCII: AnsiChar) : TGLBitmapFontRange; overload;

This item has no description.

Public function Add(const StartASCII, StopASCII: WideChar) : TGLBitmapFontRange; overload;

This item has no description.

Public function Add: TGLBitmapFontRange; overload;

This item has no description.

Public function CharacterToTileIndex(aChar: WideChar): Integer;

Converts an ASCII character into a tile index. Return -1 if character cannot be rendered.

Public function FindItemID(ID: Integer): TGLBitmapFontRange;

This item has no description.

Public function TileIndexToChar(aIndex: Integer): WideChar;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Public property CharacterCount: Integer read FCharCount;

Total number of characters in the ranges; cached for performance

Public property Items[index: Integer]: TGLBitmapFontRange read GetItems write SetItems;


GLSysHelp v.2.5: GLS.BitmapFont: Record TCharInfo

Record TCharInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BitmapFont

Declaration

type TCharInfo = record

Description

This item has no description.

Overview

Fields

Public | l: word;
Public | t: word;
Public | w: word;

Description

Fields

Public l: word;

This item has no description.

Public t: word;

This item has no description.

Public w: word;


GLSysHelp v.2.5: GLS.BitmapFont: Class TGLCustomBitmapFont

Class TGLCustomBitmapFont

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BitmapFont

Declaration

type TGLCustomBitmapFont = class(TGLUpdateAbleComponent)

Description

Provides access to individual characters in a BitmapFont. Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column). Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap. Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomBitmapFont

Overview

Fields

Private | FRanges: TGLBitmapFontRanges;
Private | FGlyphs: TPicture;
Private | FCharWidth: Integer;
Private | FCharHeight: Integer;
Private | FGlyphsIntervalX: Integer;
Private | FGlyphsIntervalY: Integer;
Private | FHSpace: Integer;
Private | FVSpace: Integer;
Private | FHSpaceFix: Integer;
Private | FUsers: TList;
Private | FMinFilter: TGLMinFilter;
Private | FMagFilter: TGLMagFilter;
Private | FTextureWidth: Integer;
Private | FTextureHeight: Integer;
Private | FTextRows: Integer;
Private | FTextCols: Integer;
Private | FGlyphsAlpha: TGLTextureImageAlpha;
Private | FTextures: TList;
Private | FTextureModified: boolean;
Private | FLastTexture: TGLTextureHandle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CalcStringWidth(const aText: UnicodeString): Integer; overload; virtual;
Public | function CharacterCount: Integer; virtual;
Public | function CharacterToTileIndex(aChar: WideChar): Integer; virtual;
Public | function GetCharWidth(Ch: WideChar): Integer;
Public | function TextWidth(const Text: UnicodeString): Integer;
Public | function TileIndexToChar(aIndex: Integer): WideChar; virtual;
Public | procedure CheckTexture(var ARci: TGLRenderContextInfo);
Public | procedure RegisterUser(anObject: TGLBaseSceneObject); virtual;
Public | procedure RenderString(var ARci: TGLRenderContextInfo; const aText: UnicodeString; aAlignment: TAlignment; aLayout: TTextLayout; const aColor: TGLColorVector; aPosition: PGLVector = nil; aReverseY: boolean = False); overload; virtual;
Public | procedure TextOut(var rci: TGLRenderContextInfo; X, Y: Single; const Text: UnicodeString; const Color: TGLColorVector); overload;
Public | procedure TextOut(var rci: TGLRenderContextInfo; X, Y: Single; const Text: UnicodeString; const Color: TColor); overload;
Public | procedure UnRegisterUser(anObject: TGLBaseSceneObject); virtual;

Properties

Public | property CharHeight: Integer read FCharHeight write SetCharHeight default 16;
Public | property TextureHeight: Integer read FTextureHeight write FTextureHeight;
Public | property TextureWidth: Integer read FTextureWidth write FTextureWidth;

Description

Fields

Private FRanges: TGLBitmapFontRanges;

This item has no description.

Private FGlyphs: TPicture;

This item has no description.

Private FCharWidth: Integer;

This item has no description.

Private FCharHeight: Integer;

This item has no description.

Private FGlyphsIntervalX: Integer;

This item has no description.

Private FGlyphsIntervalY: Integer;

This item has no description.

Private FHSpace: Integer;

This item has no description.

Private FVSpace: Integer;

This item has no description.

Private FHSpaceFix: Integer;

This item has no description.

Private FUsers: TList;

This item has no description.

Private FMinFilter: TGLMinFilter;

This item has no description.

Private FMagFilter: TGLMagFilter;

This item has no description.

Private FTextureWidth: Integer;

This item has no description.

Private FTextureHeight: Integer;

This item has no description.

Private FTextRows: Integer;

This item has no description.

Private FTextCols: Integer;

This item has no description.

Private FGlyphsAlpha: TGLTextureImageAlpha;

This item has no description.

Private FTextures: TList;

This item has no description.

Private FTextureModified: boolean;

This item has no description.

Private FLastTexture: TGLTextureHandle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalcStringWidth(const aText: UnicodeString): Integer; overload; virtual;

Get the actual pixel width for this string.

Public function CharacterCount: Integer; virtual;

This item has no description.

Public function CharacterToTileIndex(aChar: WideChar): Integer; virtual;

This item has no description.

Public function GetCharWidth(Ch: WideChar): Integer;

Get the actual width for this char.

Public function TextWidth(const Text: UnicodeString): Integer;

This item has no description.

Public function TileIndexToChar(aIndex: Integer): WideChar; virtual;

This item has no description.

Public procedure CheckTexture(var ARci: TGLRenderContextInfo);

make texture if needed

Public procedure RegisterUser(anObject: TGLBaseSceneObject); virtual;

This item has no description.

Public procedure RenderString(var ARci: TGLRenderContextInfo; const aText: UnicodeString; aAlignment: TAlignment; aLayout: TTextLayout; const aColor: TGLColorVector; aPosition: PGLVector = nil; aReverseY: boolean = False); overload; virtual;

Renders the given string at current position or at position given by the optional position variable. The current matrix is blindly used, meaning you can render all kinds of rotated and linear distorted text with this method, OpenGL Enable states are also possibly altered.

Public procedure TextOut(var rci: TGLRenderContextInfo; X, Y: Single; const Text: UnicodeString; const Color: TGLColorVector); overload;

A simpler canvas-style TextOut helper for RenderString. The rendering is reversed along Y by default, to allow direct use with TGLCanvas

Public procedure TextOut(var rci: TGLRenderContextInfo; X, Y: Single; const Text: UnicodeString; const Color: TColor); overload;

This item has no description.

Public procedure UnRegisterUser(anObject: TGLBaseSceneObject); virtual;

This item has no description.

Properties

Public property CharHeight: Integer read FCharHeight write SetCharHeight default 16;

Height of a single character.

Public property TextureHeight: Integer read FTextureHeight write FTextureHeight;

This item has no description.

Public property TextureWidth: Integer read FTextureWidth write FTextureWidth;


GLSysHelp v.2.5: GLS.BitmapFont: Class TGLBitmapFont

Class TGLBitmapFont

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BitmapFont

Declaration

type TGLBitmapFont = class(TGLCustomBitmapFont)

Description

See TGLCustomBitmapFont. This class only publuishes some of the properties.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomBitmapFont
  • TGLBitmapFont

Overview

Properties

Published | property CharHeight;
Published | property CharWidth;
Published | property Glyphs;
Published | property GlyphsAlpha;
Published | property GlyphsIntervalX;
Published | property GlyphsIntervalY;
Published | property HSpace;
Published | property MagFilter;
Published | property MinFilter;
Published | property Ranges;
Published | property VSpace;

Description

Properties

Published property CharHeight;

This item has no description. Showing description inherited from TGLCustomBitmapFont.CharHeight.

Height of a single character.

Published property CharWidth;

This item has no description.

Published property Glyphs;

This item has no description.

Published property GlyphsAlpha;

This item has no description.

Published property GlyphsIntervalX;

This item has no description.

Published property GlyphsIntervalY;

This item has no description.

Published property HSpace;

This item has no description.

Published property MagFilter;

This item has no description.

Published property MinFilter;

This item has no description.

Published property Ranges;

This item has no description.

Published property VSpace;


GLSysHelp v.2.5: GLS.BitmapFont: Class TGLFlatText

Class TGLFlatText

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BitmapFont

Declaration

type TGLFlatText = class(TGLImmaterialSceneObject)

Description

A 2D text displayed and positionned in 3D coordinates. The FlatText uses a character font defined and stored by a TGLBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLFlatText

Overview

Fields

Private | FBitmapFont: TGLCustomBitmapFont;
Private | FText: UnicodeString;
Private | FAlignment: TAlignment;
Private | FLayout: TTextLayout;
Private | FModulateColor: TGLColor;
Private | FOptions: TGLFlatTextOptions;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: boolean); override;

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment;
Published | property BitmapFont: TGLCustomBitmapFont read FBitmapFont write SetBitmapFont;
Published | property Layout: TTextLayout read FLayout write SetLayout;
Published | property ModulateColor: TGLColor read FModulateColor write SetModulateColor;
Published | property Options: TGLFlatTextOptions read FOptions write SetOptions;
Published | property Text: UnicodeString read FText write SetText;

Description

Fields

Private FBitmapFont: TGLCustomBitmapFont;

This item has no description.

Private FText: UnicodeString;

This item has no description.

Private FAlignment: TAlignment;

This item has no description.

Private FLayout: TTextLayout;

This item has no description.

Private FModulateColor: TGLColor;

This item has no description.

Private FOptions: TGLFlatTextOptions;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: boolean); override;

This item has no description.

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment;

Controls the text alignment (horizontal). Possible values : taLeftJustify, taRightJustify, taCenter

Published property BitmapFont: TGLCustomBitmapFont read FBitmapFont write SetBitmapFont;

Refers the bitmap font to use. The referred bitmap font component stores and allows access to individual character bitmaps.

Published property Layout: TTextLayout read FLayout write SetLayout;

Controls the text layout (vertical). Possible values : tlTop, tlCenter, tlBottom

Published property ModulateColor: TGLColor read FModulateColor write SetModulateColor;

Color modulation, can be used for fade in/out too.

Published property Options: TGLFlatTextOptions read FOptions write SetOptions;

Flat text options. ftoTwoSided : when set the text will be visible from its two sides even if faceculling is on (at the scene-level).

Published property Text: UnicodeString read FText write SetText;

Text to render. Be aware that only the characters available in the bitmap font will be rendered. CR LF sequences are allowed.


GLSysHelp v.2.5: GLS.Blur

Unit GLS.Blur

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • VCL.Graphics
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.TextureFormat
  • GLS.BaseClasses
  • GLS.Scene
  • GLS.Objects
  • GLS.BitmapFont
  • GLS.Texture
  • GLS.Material
  • GLS.HudObjects
  • GLS.Color
  • GLS.Graphics
  • GLS.Context
  • GLS.XOpenGL
  • GLS.State
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TRGBPixel |
Class EGLMotionBlurException |
Class TGLBlur |
Class TGLMotionBlur |

Types

TGLAdvancedBlurImagePrepareEvent = procedure(Sender: TObject; BMP32: TGLImage; var DoBlur: boolean) of object;
TGLBlurkind = (...);
TGLBlurPreset = (...);
TRGBPixelBuffer = array of TRGBPixel;

Description

Types

TGLAdvancedBlurImagePrepareEvent = procedure(Sender: TObject; BMP32: TGLImage; var DoBlur: boolean) of object;

This item has no description.

TGLBlurkind = (...);

This item has no description.

Values
  • bNone
  • bSimple
  • bAdvanced
TGLBlurPreset = (...);

This item has no description.

Values
  • pNone
  • pGlossy
  • pBeastView
  • pOceanDepth
  • pDream
  • pOverBlur
  • pAdvancedBlur
TRGBPixelBuffer = array of TRGBPixel;


GLSysHelp v.2.5: GLS.Blur: Record TRGBPixel

Record TRGBPixel

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Blur

Declaration

type TRGBPixel = record

Description

This item has no description.

Overview

Fields

Public | R: TGLubyte;
Public | G: TGLubyte;
Public | B: TGLubyte;

Description

Fields

Public R: TGLubyte;

This item has no description.

Public G: TGLubyte;

This item has no description.

Public B: TGLubyte;


GLSysHelp v.2.5: GLS.Blur: Class EGLMotionBlurException

Class EGLMotionBlurException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Blur

Declaration

type EGLMotionBlurException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLMotionBlurException


GLSysHelp v.2.5: GLS.Blur: Class TGLBlur

Class TGLBlur

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Blur

Declaration

type TGLBlur = class(TGLHUDSprite)

Description

This item has no description. Showing description inherited from TGLHUDSprite.

A rectangular area, NOT perspective projected. (x, y) coordinates map directly to the viewport (in pixels) and refer the center of the area. The coordinate system is that of an equivalent TCanvas, ie. top-left point is the origin (0, 0). The z component is ignored and Z-Buffer is disabled when rendering. Using TGLHUDSprite in 2D only scenes : The most convenient way to use a TGLHUDSprite as a simple 2D sprite with blending capabilities (transparency or additive), is to set the texture mode to tmModulate, in FrontProperties, to use the Emission color to control coloring/intensity, and finally use the Diffuse color's alpha to control transparency (while setting the other RGB components to 0). You can also control aplha-blending by defining a <1 value in the sprite's AlphaChannel field. This provides you with hardware accelerated, alpha-blended blitting. Note : since TGLHUDSprite works in absolute coordinates, TGLProxyObject can't be used to duplicate an hud sprite.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSprite
  • TGLHUDSprite
  • TGLBlur

Overview

Fields

Private | FViewer: TGLMemoryViewer;
Private | OldTime: Double;
Private | FDoingMemView: boolean;
Private | FBlurDeltaTime: Double;
Private | FBlurTop: Single;
Private | FBlurBottom: Single;
Private | FBlurLeft: Single;
Private | FBlurRight: Single;
Private | FRenderHeight: Integer;
Private | FRenderWidth: Integer;
Private | FPreset: TGLBlurPreset;
Private | FTargetObject: TGLbaseSceneObject;
Private | FOnAdvancedBlurImagePrepareEvent: TGLAdvancedBlurImagePrepareEvent;
Private | FBlur: TGLBlurKind;
Private | Pixelbuffer: TRGBPixelBuffer;
Private | FAdvancedBlurPasses: integer;
Private | FOnAfterTargetRender: TNotifyEvent;
Private | FOnBeforeTargetRender: TNotifyEvent;
Private | FAdvancedBlurAmp: single;
Private | FBlurSelf: boolean;
Private | FAdvancedBlurLowClamp: byte;
Private | FAdvancedBlurHiClamp: byte;
Private | FRenderBackgroundColor: TColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function StoreBlurBottom: Boolean;
Private | function StoreBlurDeltaTime: Boolean;
Private | function StoreBlurLeft: Boolean;
Private | function StoreBlurRight: Boolean;
Private | function StoreBlurTop: Boolean;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Private | procedure DoMemView(baseObject: TGLBaseSceneObject);
Private | procedure SetAdvancedBlurAmp(const Value: single);
Private | procedure SetAdvancedBlurHiClamp(const Value: byte);
Private | procedure SetAdvancedBlurLowClamp(const Value: byte);
Private | procedure SetAdvancedBlurPasses(const Value: integer);
Private | procedure SetBlur(const Value: TGLBlurKind);
Private | procedure SetBlurSelf(const Value: boolean);
Private | procedure SetOnAdvancedBlurImagePrepareEvent(const Value: TGLAdvancedBlurImagePrepareEvent);
Private | procedure SetOnAfterTargetRender(const Value: TNotifyEvent);
Private | procedure SetOnBeforeTargetRender(const Value: TNotifyEvent);
Private | procedure SetPreset(const Value: TGLBlurPreset);
Private | procedure SetRenderBackgroundColor(const Value: TColor);
Private | procedure SetRenderHeight(const Value: Integer);
Private | procedure SetRenderWidth(const Value: Integer);
Private | procedure SetTargetObject(const Value: TGLbaseSceneObject);
Private | procedure UpdateImageSettings;

Properties

Published | property AdvancedBlurAmp: single read FAdvancedBlurAmp write SetAdvancedBlurAmp;
Published | property AdvancedBlurHiClamp: byte read FAdvancedBlurHiClamp write SetAdvancedBlurHiClamp;
Published | property AdvancedBlurLowClamp: byte read FAdvancedBlurLowClamp write SetAdvancedBlurLowClamp;
Published | property AdvancedBlurPasses: integer read FAdvancedBlurPasses write SetAdvancedBlurPasses;
Published | property Blur: TGLBlurKind read FBlur write SetBlur;
Published | property BlurBottom: Single read FBlurBottom write FBlurBottom stored StoreBlurBottom;
Published | property BlurDeltaTime: Double read FBlurDeltaTime write FBlurDeltaTime stored StoreBlurDeltaTime;
Published | property BlurLeft: Single read FBlurLeft write FBlurLeft stored StoreBlurLeft;
Published | property BlurRight: Single read FBlurRight write FBlurRight stored StoreBlurRight;
Published | property BlurSelf: boolean read FBlurSelf write SetBlurSelf;
Published | property BlurTop: Single read FBlurTop write FBlurTop stored StoreBlurTop;
Published | property OnAdvancedBlurImagePrepareEvent: TGLAdvancedBlurImagePrepareEvent read FOnAdvancedBlurImagePrepareEvent write SetOnAdvancedBlurImagePrepareEvent;
Published | property OnAfterTargetRender: TNotifyEvent read FOnAfterTargetRender write SetOnAfterTargetRender;
Published | property OnBeforeTargetRender: TNotifyEvent read FOnBeforeTargetRender write SetOnBeforeTargetRender;
Published | property Preset: TGLBlurPreset read FPreset write SetPreset stored false;
Published | property RenderBackgroundColor: TColor read FRenderBackgroundColor write SetRenderBackgroundColor;
Published | property RenderHeight: Integer read FRenderHeight write SetRenderHeight default 256;
Published | property RenderWidth: Integer read FRenderWidth write SetRenderWidth default 256;
Published | property TargetObject: TGLbaseSceneObject read FTargetObject write SetTargetObject;

Description

Fields

Private FViewer: TGLMemoryViewer;

This item has no description.

Private OldTime: Double;

This item has no description.

Private FDoingMemView: boolean;

This item has no description.

Private FBlurDeltaTime: Double;

This item has no description.

Private FBlurTop: Single;

This item has no description.

Private FBlurBottom: Single;

This item has no description.

Private FBlurLeft: Single;

This item has no description.

Private FBlurRight: Single;

This item has no description.

Private FRenderHeight: Integer;

This item has no description.

Private FRenderWidth: Integer;

This item has no description.

Private FPreset: TGLBlurPreset;

This item has no description.

Private FTargetObject: TGLbaseSceneObject;

This item has no description.

Private FOnAdvancedBlurImagePrepareEvent: TGLAdvancedBlurImagePrepareEvent;

This item has no description.

Private FBlur: TGLBlurKind;

This item has no description.

Private Pixelbuffer: TRGBPixelBuffer;

This item has no description.

Private FAdvancedBlurPasses: integer;

This item has no description.

Private FOnAfterTargetRender: TNotifyEvent;

This item has no description.

Private FOnBeforeTargetRender: TNotifyEvent;

This item has no description.

Private FAdvancedBlurAmp: single;

This item has no description.

Private FBlurSelf: boolean;

This item has no description.

Private FAdvancedBlurLowClamp: byte;

This item has no description.

Private FAdvancedBlurHiClamp: byte;

This item has no description.

Private FRenderBackgroundColor: TColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function StoreBlurBottom: Boolean;

This item has no description.

Private function StoreBlurDeltaTime: Boolean;

This item has no description.

Private function StoreBlurLeft: Boolean;

This item has no description.

Private function StoreBlurRight: Boolean;

This item has no description.

Private function StoreBlurTop: Boolean;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Private procedure DoMemView(baseObject: TGLBaseSceneObject);

This item has no description.

Private procedure SetAdvancedBlurAmp(const Value: single);

This item has no description.

Private procedure SetAdvancedBlurHiClamp(const Value: byte);

This item has no description.

Private procedure SetAdvancedBlurLowClamp(const Value: byte);

This item has no description.

Private procedure SetAdvancedBlurPasses(const Value: integer);

This item has no description.

Private procedure SetBlur(const Value: TGLBlurKind);

This item has no description.

Private procedure SetBlurSelf(const Value: boolean);

This item has no description.

Private procedure SetOnAdvancedBlurImagePrepareEvent(const Value: TGLAdvancedBlurImagePrepareEvent);

This item has no description.

Private procedure SetOnAfterTargetRender(const Value: TNotifyEvent);

This item has no description.

Private procedure SetOnBeforeTargetRender(const Value: TNotifyEvent);

This item has no description.

Private procedure SetPreset(const Value: TGLBlurPreset);

This item has no description.

Private procedure SetRenderBackgroundColor(const Value: TColor);

This item has no description.

Private procedure SetRenderHeight(const Value: Integer);

This item has no description.

Private procedure SetRenderWidth(const Value: Integer);

This item has no description.

Private procedure SetTargetObject(const Value: TGLbaseSceneObject);

This item has no description.

Private procedure UpdateImageSettings;

This item has no description.

Properties

Published property AdvancedBlurAmp: single read FAdvancedBlurAmp write SetAdvancedBlurAmp;

This item has no description.

Published property AdvancedBlurHiClamp: byte read FAdvancedBlurHiClamp write SetAdvancedBlurHiClamp;

This item has no description.

Published property AdvancedBlurLowClamp: byte read FAdvancedBlurLowClamp write SetAdvancedBlurLowClamp;

This item has no description.

Published property AdvancedBlurPasses: integer read FAdvancedBlurPasses write SetAdvancedBlurPasses;

This item has no description.

Published property Blur: TGLBlurKind read FBlur write SetBlur;

This item has no description.

Published property BlurBottom: Single read FBlurBottom write FBlurBottom stored StoreBlurBottom;

This item has no description.

Published property BlurDeltaTime: Double read FBlurDeltaTime write FBlurDeltaTime stored StoreBlurDeltaTime;

This item has no description.

Published property BlurLeft: Single read FBlurLeft write FBlurLeft stored StoreBlurLeft;

This item has no description.

Published property BlurRight: Single read FBlurRight write FBlurRight stored StoreBlurRight;

This item has no description.

Published property BlurSelf: boolean read FBlurSelf write SetBlurSelf;

This item has no description.

Published property BlurTop: Single read FBlurTop write FBlurTop stored StoreBlurTop;

This item has no description.

Published property OnAdvancedBlurImagePrepareEvent: TGLAdvancedBlurImagePrepareEvent read FOnAdvancedBlurImagePrepareEvent write SetOnAdvancedBlurImagePrepareEvent;

This item has no description.

Published property OnAfterTargetRender: TNotifyEvent read FOnAfterTargetRender write SetOnAfterTargetRender;

This item has no description.

Published property OnBeforeTargetRender: TNotifyEvent read FOnBeforeTargetRender write SetOnBeforeTargetRender;

This item has no description.

Published property Preset: TGLBlurPreset read FPreset write SetPreset stored false;

This item has no description.

Published property RenderBackgroundColor: TColor read FRenderBackgroundColor write SetRenderBackgroundColor;

This item has no description.

Published property RenderHeight: Integer read FRenderHeight write SetRenderHeight default 256;

This item has no description.

Published property RenderWidth: Integer read FRenderWidth write SetRenderWidth default 256;

This item has no description.

Published property TargetObject: TGLbaseSceneObject read FTargetObject write SetTargetObject;


GLSysHelp v.2.5: GLS.Blur: Class TGLMotionBlur

Class TGLMotionBlur

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Blur

Declaration

type TGLMotionBlur = class(TGLCustomSceneObject, IGLInitializable)

Description

This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders. Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;) I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLMotionBlur

Overview

Fields

Private FIntensity: Single;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | function SupportsRequiredExtensions: Boolean;
Private | function StoreIntensity: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Behaviours;
Published | property Effects;
Published | property Hint;
Published | property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;
Published | property OnProgress;
Published | property Visible;

Description

Fields

Private FIntensity: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public function SupportsRequiredExtensions: Boolean;

This function is only valid AFTER OpenGL has been initialized.

Private function StoreIntensity: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Effects;

This item has no description.

Published property Hint;

This item has no description.

Published property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;

The more the intensity, the more blur you have.

Published property OnProgress;

This item has no description.

Published property Visible;

From TGLBaseSceneObject.


GLSysHelp v.2.5: GLS.BumpmapHDS

Unit GLS.BumpmapHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.SyncObjs
  • System.UITypes
  • Vcl.Graphics
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Coordinates
  • GLS.HeightData
  • GLS.Graphics
  • GLS.Color
  • GLS.VectorLists
  • GLS.Texture
  • GLS.Material
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBumpmapHDS |

Functions and Procedures

procedure CalcObjectSpaceLightVectors(Light : TAffineVector; Vertices: TGLAffineVectorList; Colors: TGLVectorList);
procedure SetupTangentSpace(Vertices, Normals, TexCoords, Tangents, BiNormals : TGLAffineVectorList);
procedure CalcTangentSpaceLightVectors(Light : TAffineVector; Vertices, Normals, Tangents, BiNormals : TGLAffineVectorList; Colors: TGLVectorList);
function CreateObjectSpaceNormalMap(Width, Height : Integer; HiNormals,HiTexCoords : TGLAffineVectorList) : TBitmap;
function CreateTangentSpaceNormalMap(Width, Height : Integer; HiNormals, HiTexCoords, LoNormals, LoTexCoords, Tangents, BiNormals : TGLAffineVectorList) : TBitmap;

Types

TGLNormalMapSpace = (...);
TNewTilePreparedEvent = procedure(Sender: TGLBumpmapHDS; heightData: TGLHeightData; normalMapMaterial: TGLLibMaterial) of object;

Description

Functions and Procedures

procedure CalcObjectSpaceLightVectors(Light : TAffineVector; Vertices: TGLAffineVectorList; Colors: TGLVectorList);

Some useful methods for setting up bump maps.

procedure SetupTangentSpace(Vertices, Normals, TexCoords, Tangents, BiNormals : TGLAffineVectorList);

This item has no description.

procedure CalcTangentSpaceLightVectors(Light : TAffineVector; Vertices, Normals, Tangents, BiNormals : TGLAffineVectorList; Colors: TGLVectorList);

This item has no description.

function CreateObjectSpaceNormalMap(Width, Height : Integer; HiNormals,HiTexCoords : TGLAffineVectorList) : TBitmap;

This item has no description.

function CreateTangentSpaceNormalMap(Width, Height : Integer; HiNormals, HiTexCoords, LoNormals, LoTexCoords, Tangents, BiNormals : TGLAffineVectorList) : TBitmap;

This item has no description.

Types

TGLNormalMapSpace = (...);

This item has no description.

Values
  • nmsObject
  • nmsTangent
TNewTilePreparedEvent = procedure(Sender: TGLBumpmapHDS; heightData: TGLHeightData; normalMapMaterial: TGLLibMaterial) of object;


GLSysHelp v.2.5: GLS.BumpmapHDS: Class TGLBumpmapHDS

Class TGLBumpmapHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.BumpmapHDS

Declaration

type TGLBumpmapHDS = class(TGLHeightDataSourceFilter)

Description

An Height Data Source that generates elevation bumpmaps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLHeightDataSourceFilter
  • TGLBumpmapHDS

Overview

Fields

Private | FBumpmapLibrary: TGLMaterialLibrary;
Private | FOnNewTilePrepared: TNewTilePreparedEvent;
Private | FBumpScale: Single;
Private | FSubSampling: Integer;
Private | FMaxTextures: Integer;
Private | Uno: TCriticalSection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure GenerateNormalMap(heightData: TGLHeightData; normalMap: TGLImage; scale: Single);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreparingData(heightData: TGLHeightData); override;
Public | procedure Release(aHeightData: TGLHeightData); override;
Public | procedure TrimTextureCache(MaxTextureCount: Integer);

Properties

Published | property BumpmapLibrary: TGLMaterialLibrary read FBumpmapLibrary write SetBumpmapLibrary;
Published | property BumpScale: Single read FBumpScale write SetBumpScale stored StoreBumpScale;
Published | property MaxPoolSize;
Published | property MaxTextures: Integer read FMaxTextures write FMaxTextures;
Published | property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property OnSourceDataFetched;
Published | property SubSampling: Integer read FSubSampling write SetSubSampling default 1;

Description

Fields

Private FBumpmapLibrary: TGLMaterialLibrary;

FElevationHDS : TGLHeightDataSource;

Private FOnNewTilePrepared: TNewTilePreparedEvent;

This item has no description.

Private FBumpScale: Single;

This item has no description.

Private FSubSampling: Integer;

This item has no description.

Private FMaxTextures: Integer;

This item has no description.

Private Uno: TCriticalSection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure GenerateNormalMap(heightData: TGLHeightData; normalMap: TGLImage; scale: Single);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure PreparingData(heightData: TGLHeightData); override;

procedure TileTextureCoordinates(heightData : TGLHeightData; TextureScale:TTexPoint; TextureOffset:TTexPoint);

Public procedure Release(aHeightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.Release.

Notification that the data is no longer used by the renderer. Default behaviour is just to change DataState to hdsReady (ie. return the data to the pool)

Public procedure TrimTextureCache(MaxTextureCount: Integer);

This will repeatedly delete the oldest unused texture from the TGLMaterialLibrary, until the texture count drops to MaxTextureCount. DONT use this if you used TGLHeightData.MaterialName to link your terrain textures. Either use with TGLHeightData.LibMaterial, or manually delete unused Normal-Map textures.

Properties

Published property BumpmapLibrary: TGLMaterialLibrary read FBumpmapLibrary write SetBumpmapLibrary;

This item has no description.

Published property BumpScale: Single read FBumpScale write SetBumpScale stored StoreBumpScale;

This item has no description.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property MaxTextures: Integer read FMaxTextures write FMaxTextures;

If MaxTextures>0 then the Bumpmap library is trimmed down to size whenever the texture count is larger than MaxTextures. The oldest, unused texture is trimmed first. However, if you used TGLHeightData.MaterialName, instead of TGLHeightData.LibMaterial, then the TGLHeightData component does not register the texture as being used. So, if you use TGLHeightData.MaterialName then make sure MaxTextures=0. If MaxTextures=0 or if treads(GLS.AsyncHDS) are used, then the texture cache is NOT trimmed automatically. You will have to manually trim the cache from the main thread, by calling 'TrimTextureCache'. (GLS.AsyncHDS.OnIdle is a good place.)

Published property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;

This item has no description.

Published property OnSourceDataFetched;

This item has no description.

Published property SubSampling: Integer read FSubSampling write SetSubSampling default 1;

Specifies the amount of subsampling for the bump texture. This value must be a power of 2, and is used to divide the height tile resolution to determine the bump texture resolution (f.i. a tile size of 128 with a subsampling of 4 will result in textures of a resolution of 32x32. SubSampling won't allow texture resolution to get below 16x16 (minimal bumpmap resolution).


GLSysHelp v.2.5: GLS.Cadencer

Unit GLS.Cadencer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.Classes
  • System.SysUtils
  • System.Types
  • VCL.Forms
  • GLS.Scene
  • GLS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCadencer |
Class TGLCustomCadencedComponent |
Class TGLCadencedComponent |

Types

TGLCadencerMode = (...);
TGLCadencerTimeReference = (...);

Description

Types

TGLCadencerMode = (...);

Determines how the TGLCadencer operates. - cmManual : you must trigger progress manually (in your code) - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.

Values
  • cmManual
  • cmASAP
  • cmApplicationIdle
TGLCadencerTimeReference = (...);

Determines which time reference the TGLCadencer should use. - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems) - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems) - cmExternal : the CurrentTime property is used

Values
  • cmRTC
  • cmPerformanceCounter
  • cmExternal


GLSysHelp v.2.5: GLS.Cadencer: Class TGLCadencer

Class TGLCadencer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Cadencer

Declaration

type TGLCadencer = class(TComponent)

Description

This component allows auto-progression of animation. Basicly dropping this component and linking it to your TGLScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene). The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLCadencer

Overview

Fields

Private | FSubscribedCadenceableComponents: TList;
Private | FScene: TGLScene;
Private | FTimeMultiplier: Double;
Private | lastTime: Double;
Private | downTime: Double;
Private | lastMultiplier: Double;
Private | FEnabled: Boolean;
Private | FSleepLength: Integer;
Private | FMode: TGLCadencerMode;
Private | FTimeReference: TGLCadencerTimeReference;
Private | FCurrentTime: Double;
Private | FOriginTime: Double;
Private | FMaxDeltaTime: Double;
Private | FMinDeltaTime: Double;
Private | FFixedDeltaTime: Double;
Private | FOnProgress: TGLProgressEvent;
Private | FOnTotalProgress: TGLProgressEvent;
Private | FProgressing: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetCurrenttime: Double; inline;
Public | function IsBusy: Boolean;
Public | procedure Progress;
Public | procedure Reset;
Public | procedure Subscribe(aComponent: TGLCadenceAbleComponent);
Public | procedure UnSubscribe(aComponent: TGLCadenceAbleComponent);
Private | procedure SetCurrentTime(const Value: Double);

Properties

Public | property CurrentTime: Double read FCurrentTime write SetCurrentTime;
Published | property Enabled: Boolean read FEnabled write SetEnabled default True;
Published | property FixedDeltaTime: Double read FFixedDeltaTime write FFixedDeltaTime;
Published | property MaxDeltaTime: Double read FMaxDeltaTime write FMaxDeltaTime;
Published | property MinDeltaTime: Double read FMinDeltaTime write FMinDeltaTime;
Published | property Mode: TGLCadencerMode read FMode write SetMode default cmASAP;
Published | property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;
Published | property OnTotalProgress : TGLProgressEvent read FOnTotalProgress write FOnTotalProgress;
Public | property OriginTime: Double read FOriginTime write FOriginTime;
Published | property Scene: TGLScene read FScene write SetScene;
Published | property SleepLength: Integer read FSleepLength write FSleepLength default -1;
Published | property TimeMultiplier: Double read FTimeMultiplier write SetTimeMultiplier stored StoreTimeMultiplier;
Published | property TimeReference: TGLCadencerTimeReference read FTimeReference write SetTimeReference default cmPerformanceCounter;

Description

Fields

Private FSubscribedCadenceableComponents: TList;

This item has no description.

Private FScene: TGLScene;

This item has no description.

Private FTimeMultiplier: Double;

This item has no description.

Private lastTime: Double;

This item has no description.

Private downTime: Double;

This item has no description.

Private lastMultiplier: Double;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FSleepLength: Integer;

This item has no description.

Private FMode: TGLCadencerMode;

This item has no description.

Private FTimeReference: TGLCadencerTimeReference;

This item has no description.

Private FCurrentTime: Double;

This item has no description.

Private FOriginTime: Double;

This item has no description.

Private FMaxDeltaTime: Double;

This item has no description.

Private FMinDeltaTime: Double;

This item has no description.

Private FFixedDeltaTime: Double;

This item has no description.

Private FOnProgress: TGLProgressEvent;

This item has no description.

Private FOnTotalProgress: TGLProgressEvent;

This item has no description.

Private FProgressing: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetCurrenttime: Double; inline;

Adjusts CurrentTime if necessary, then returns its value.

Public function IsBusy: Boolean;

Returns True if a "Progress" is underway. Be aware that as long as IsBusy is True, the Cadencer may be sending messages and progression calls to cadenceable components and scenes.

Public procedure Progress;

Allows to manually trigger a progression. Time stuff is handled automatically. If cadencer is disabled, this functions does nothing.

Public procedure Reset;

Reset the time parameters and returns to zero.

Public procedure Subscribe(aComponent: TGLCadenceAbleComponent);

This item has no description.

Public procedure UnSubscribe(aComponent: TGLCadenceAbleComponent);

This item has no description.

Private procedure SetCurrentTime(const Value: Double);

This item has no description.

Properties

Public property CurrentTime: Double read FCurrentTime write SetCurrentTime;

Current time (manually or automatically set, see TimeReference).

Published property Enabled: Boolean read FEnabled write SetEnabled default True;

Enables/Disables cadencing. Disabling won't cause a jump when restarting, it is working like a play/pause (ie. may modify OriginTime to keep things smooth).

Published property FixedDeltaTime: Double read FFixedDeltaTime write FFixedDeltaTime;

Fixed time-step value for progression events. If superior to zero, progression steps will happen with that fixed delta time. The progression remains time based, so zero to N events may be fired depending on the actual deltaTime (if deltaTime is inferior to FixedDeltaTime, no event will be fired, if it is superior to two times FixedDeltaTime, two events will be fired, etc.). This option allows to use fixed time steps in simulations (while the animation and rendering itself may happen at a lower or higher framerate).

Published property MaxDeltaTime: Double read FMaxDeltaTime write FMaxDeltaTime;

Maximum value for deltaTime in progression events. If null or negative, no max deltaTime is defined, otherwise, whenever an event whose actual deltaTime would be superior to MaxDeltaTime occurs, deltaTime is clamped to this max, and the extra time is hidden by the cadencer (it isn't visible in CurrentTime either). This option allows to limit progression rate in simulations where high values would result in errors/random behaviour.

Published property MinDeltaTime: Double read FMinDeltaTime write FMinDeltaTime;

Minimum value for deltaTime in progression events. If superior to zero, this value specifies the minimum time step between two progression events. This option allows to limit progression rate in simulations where low values would result in errors/random behaviour.

Published property Mode: TGLCadencerMode read FMode write SetMode default cmASAP;

Adjusts how progression events are triggered. See TGLCadencerMode.

Published property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;

Happens AFTER scene was progressed.

Published property OnTotalProgress : TGLProgressEvent read FOnTotalProgress write FOnTotalProgress;

Happens AFTER all iterations with fixed delta time.

Public property OriginTime: Double read FOriginTime write FOriginTime;

Value soustracted to current time to obtain progression time.

Published property Scene: TGLScene read FScene write SetScene;

The TGLScene that will be cadenced (progressed).

Published property SleepLength: Integer read FSleepLength write FSleepLength default -1;

Allows relinquishing time to other threads/processes. A "sleep" is issued BEFORE each progress if SleepLength>=0 (see help for the "sleep" procedure in delphi for details).

Published property TimeMultiplier: Double read FTimeMultiplier write SetTimeMultiplier stored StoreTimeMultiplier;

Multiplier applied to the time reference. Zero isn't an allowed value, and be aware that if negative values are accepted, they may not be supported by other GLScene objects. Changing the TimeMultiplier will alter OriginTime.

Published property TimeReference: TGLCadencerTimeReference read FTimeReference write SetTimeReference default cmPerformanceCounter;

Defines how CurrentTime is updated. See TGLCadencerTimeReference. Dynamically changeing the TimeReference may cause a "jump".


GLSysHelp v.2.5: GLS.Cadencer: Class TGLCustomCadencedComponent

Class TGLCustomCadencedComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Cadencer

Declaration

type TGLCustomCadencedComponent = class(TGLUpdateAbleComponent)

Description

Adds a property to connect/subscribe to a cadencer.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent

Overview

Fields

Private FCadencer: TGLCadencer;

Methods

Public | destructor Destroy; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Description

Fields

Private FCadencer: TGLCadencer;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;


GLSysHelp v.2.5: GLS.Cadencer: Class TGLCadencedComponent

Class TGLCadencedComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Cadencer

Declaration

type TGLCadencedComponent = class(TGLCustomCadencedComponent)

Description

This item has no description. Showing description inherited from TGLCustomCadencedComponent.

Adds a property to connect/subscribe to a cadencer.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent

Overview

Properties

Published property Cadencer;

Description

Properties

Published property Cadencer;


GLSysHelp v.2.5: GLS.CameraController

Unit GLS.CameraController

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • System.Contnrs
  • System.Types
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Coordinates
  • GLS.PersistentClasses
  • GLS.Scene
  • GLS.SmoothNavigator

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLCameraController |
Class TGLCameraJobList |
Class TGLCameraJob |
Class TGLMoveToPosJob |
Class TGLZoomToDistanceJob |
Class TGLOrbitToPosJob |
Class TGLSmoothOrbitToPos |
Class TGLOrbitToPosAdvJob |
Class TGLSmoothOrbitToPosAdvJob |
Class TGLCameraController |

Types

TGLCameraJobEvent = procedure(Sender: TGLCameraJob) of object;

Description

Types

TGLCameraJobEvent = procedure(Sender: TGLCameraJob) of object;


GLSysHelp v.2.5: GLS.CameraController: Class EGLCameraController

Class EGLCameraController

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type EGLCameraController = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLCameraController


GLSysHelp v.2.5: GLS.CameraController: Class TGLCameraJobList

Class TGLCameraJobList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLCameraJobList = class(TObjectList)

Description

This item has no description.

Hierarchy

  • TObject
  • TObjectList
  • TGLCameraJobList

Overview

Fields

Private FController: TGLCameraController;

Methods

Public | constructor Create(AController: TGLCameraController);
Public | function Add(ACameraJob: TGLCameraJob): integer;
Public | function First: TGLCameraJob;
Public | function Last: TGLCameraJob;
Private | function GetCameraJob(const AIndex: integer): TGLCameraJob;
Private | procedure SetCameraJob(const AIndex: integer; const Value: TGLCameraJob);

Properties

Public property Items[const AIndex: integer]: TGLCameraJob read GetCameraJob write SetCameraJob;

Description

Fields

Private FController: TGLCameraController;

This item has no description.

Methods

Public constructor Create(AController: TGLCameraController);

This item has no description.

Public function Add(ACameraJob: TGLCameraJob): integer;

This item has no description.

Public function First: TGLCameraJob;

This item has no description.

Public function Last: TGLCameraJob;

This item has no description.

Private function GetCameraJob(const AIndex: integer): TGLCameraJob;

This item has no description.

Private procedure SetCameraJob(const AIndex: integer; const Value: TGLCameraJob);

This item has no description.

Properties

Public property Items[const AIndex: integer]: TGLCameraJob read GetCameraJob write SetCameraJob;


GLSysHelp v.2.5: GLS.CameraController: Class TGLCameraJob

Class TGLCameraJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLCameraJob = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCameraJob

Overview

Fields

Private FJoblist: TGLCameraJobList;

Methods

Public | constructor Create(const AJoblist: TGLCameraJobList); virtual;
Public | destructor Destroy; override;
Public | procedure Abort;
Public | procedure Init; virtual; abstract;
Public | procedure Step; virtual; abstract;

Properties

Public | property ElapsedTime: Double read FElapsedTime write FElapsedTime;
Public | property ProceedTime: Double read FProceedTime write FProceedTime;
Public | property Running: boolean read FRunning write FRunning;
Public | property StartTime: Double read FStartTime write FStartTime;

Description

Fields

Private FJoblist: TGLCameraJobList;

This item has no description.

Methods

Public constructor Create(const AJoblist: TGLCameraJobList); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Abort;

This item has no description.

Public procedure Init; virtual; abstract;

This item has no description.

Public procedure Step; virtual; abstract;

This item has no description.

Properties

Public property ElapsedTime: Double read FElapsedTime write FElapsedTime;

This item has no description.

Public property ProceedTime: Double read FProceedTime write FProceedTime;

This item has no description.

Public property Running: boolean read FRunning write FRunning;

This item has no description.

Public property StartTime: Double read FStartTime write FStartTime;


GLSysHelp v.2.5: GLS.CameraController: Class TGLMoveToPosJob

Class TGLMoveToPosJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLMoveToPosJob = class(TGLCameraJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLMoveToPosJob

Overview

Fields

Private | FInitialPos: TGLVector;
Private | FFinalPos: TGLVector;
Public | X: Double;
Public | Y: Double;
Public | Z: Double;
Public | Time: Double;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TGLVector read FFinalPos;
Public | property InitialPos: TGLVector read FInitialPos;

Description

Fields

Private FInitialPos: TGLVector;

This item has no description.

Private FFinalPos: TGLVector;

This item has no description.

Public X: Double;

This item has no description.

Public Y: Double;

This item has no description.

Public Z: Double;

This item has no description.

Public Time: Double;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property FinalPos: TGLVector read FFinalPos;

This item has no description.

Public property InitialPos: TGLVector read FInitialPos;

Properties.


GLSysHelp v.2.5: GLS.CameraController: Class TGLZoomToDistanceJob

Class TGLZoomToDistanceJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLZoomToDistanceJob = class(TGLCameraJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLZoomToDistanceJob

Overview

Fields

Private | FInitialPos: TGLVector;
Private | FFinalPos: TGLVector;
Public | Distance: Double;
Public | Time: Double;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TGLVector read FFinalPos;
Public | property InitialPos: TGLVector read FInitialPos;

Description

Fields

Private FInitialPos: TGLVector;

This item has no description.

Private FFinalPos: TGLVector;

This item has no description.

Public Distance: Double;

This item has no description.

Public Time: Double;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property FinalPos: TGLVector read FFinalPos;

This item has no description.

Public property InitialPos: TGLVector read FInitialPos;

Properties.


GLSysHelp v.2.5: GLS.CameraController: Class TGLOrbitToPosJob

Class TGLOrbitToPosJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLOrbitToPosJob = class(TGLCameraJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLOrbitToPosJob

Overview

Fields

Private | FFinalPos: TGLVector;
Private | FRotateSpeed: TVector2f;
Private | FCameraUpVector: TGLVector;
Private | FTargetPosition: TGLVector;
Private | FTime: Double;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property CameraUpVector: TGLVector read FCameraUpVector;
Public | property FinalPos: TGLVector read FFinalPos;
Public | property RotateSpeed: TVector2f read FRotateSpeed;
Public | property TargetPosition: TGLVector read FTargetPosition;
Public | property Time: Double read FTime;

Description

Fields

Private FFinalPos: TGLVector;

This item has no description.

Private FRotateSpeed: TVector2f;

Yep, FFinalPos is stored in relative coordinates.

Private FCameraUpVector: TGLVector;

This item has no description.

Private FTargetPosition: TGLVector;

Absolute Coordinates, can even be not normalized by radius. Procesed in Init, not used anywhere else.

Private FTime: Double;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property CameraUpVector: TGLVector read FCameraUpVector;

This item has no description.

Public property FinalPos: TGLVector read FFinalPos;

This item has no description.

Public property RotateSpeed: TVector2f read FRotateSpeed;

This item has no description.

Public property TargetPosition: TGLVector read FTargetPosition;

This item has no description.

Public property Time: Double read FTime;


GLSysHelp v.2.5: GLS.CameraController: Class TGLSmoothOrbitToPos

Class TGLSmoothOrbitToPos

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLSmoothOrbitToPos = class(TGLOrbitToPosJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLOrbitToPosJob
  • TGLSmoothOrbitToPos

Overview

Fields

Private | FCutoffAngle: Single;
Private | FNeedToRecalculateZoom: boolean;
Private | FShouldBeMatrix: TGLMatrix;
Private | FSmoothNavigator: TGLNavigatorSmoothChangeVector;

Methods

Public | constructor Create(const AJoblist: TGLCameraJobList); override;
Public | procedure Step; override;

Properties

Public | property CutoffAngle: Single read FCutoffAngle write FCutoffAngle;
Public | property NeedToRecalculateZoom: boolean read FNeedToRecalculateZoom write FNeedToRecalculateZoom;

Description

Fields

Private FCutoffAngle: Single;

This item has no description.

Private FNeedToRecalculateZoom: boolean;

This item has no description.

Private FShouldBeMatrix: TGLMatrix;

This item has no description.

Private FSmoothNavigator: TGLNavigatorSmoothChangeVector;

This item has no description.

Methods

Public constructor Create(const AJoblist: TGLCameraJobList); override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property CutoffAngle: Single read FCutoffAngle write FCutoffAngle;

This item has no description.

Public property NeedToRecalculateZoom: boolean read FNeedToRecalculateZoom write FNeedToRecalculateZoom;


GLSysHelp v.2.5: GLS.CameraController: Class TGLOrbitToPosAdvJob

Class TGLOrbitToPosAdvJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLOrbitToPosAdvJob = class(TGLCameraJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLOrbitToPosAdvJob

Overview

Fields

Private | FInitialPos: TGLVector;
Private | FFinalPos: TGLVector;
Private | FInitialUp: TGLVector;
Private | FInitialDir: TGLVector;
Private | FRotAxis: TGLVector;
Private | FAngle: Double;
Public | X: Double;
Public | Y: Double;
Public | Z: Double;
Public | Time: Double;
Public | PreferUpAxis: boolean;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TGLVector read FFinalPos;
Public | property InitialDir: TGLVector read FInitialDir;
Public | property InitialPos: TGLVector read FInitialPos;
Public | property InitialUp: TGLVector read FInitialUp;

Description

Fields

Private FInitialPos: TGLVector;

This item has no description.

Private FFinalPos: TGLVector;

This item has no description.

Private FInitialUp: TGLVector;

This item has no description.

Private FInitialDir: TGLVector;

This item has no description.

Private FRotAxis: TGLVector;

This item has no description.

Private FAngle: Double;

This item has no description.

Public X: Double;

This item has no description.

Public Y: Double;

This item has no description.

Public Z: Double;

This item has no description.

Public Time: Double;

This item has no description.

Public PreferUpAxis: boolean;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property FinalPos: TGLVector read FFinalPos;

This item has no description.

Public property InitialDir: TGLVector read FInitialDir;

This item has no description.

Public property InitialPos: TGLVector read FInitialPos;

Properties.

Public property InitialUp: TGLVector read FInitialUp;


GLSysHelp v.2.5: GLS.CameraController: Class TGLSmoothOrbitToPosAdvJob

Class TGLSmoothOrbitToPosAdvJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLSmoothOrbitToPosAdvJob = class(TGLOrbitToPosAdvJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLOrbitToPosAdvJob
  • TGLSmoothOrbitToPosAdvJob

Overview

Fields

Private | FPreviousPosition: TGLVector;
Private | FSmoothNavigator: TGLNavigatorSmoothChangeVector;
Private | FRestoreUpVector: boolean;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Description

Fields

Private FPreviousPosition: TGLVector;

This item has no description.

Private FSmoothNavigator: TGLNavigatorSmoothChangeVector;

This item has no description.

Private FRestoreUpVector: boolean;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;


GLSysHelp v.2.5: GLS.CameraController: Class TGLCameraController

Class TGLCameraController

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CameraController

Declaration

type TGLCameraController = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLCameraController

Overview

Fields

Private | FCameraJobList: TGLCameraJobList;
Private | FCamera: TGLBaseSceneObject;
Private | FCameraTarget: TGLBaseSceneObject;
Private | FOnJobAdded: TGLCameraJobEvent;
Private | FOnJobFinished: TGLCameraJobEvent;
Private | FOnJobStep: TGLCameraJobEvent;
Private | FsoSafeDist: Double;
Private | FsoTimeToSafePlacement: Double;
Private | FsoTimeToOrbit: Double;
Private | FsoTimeToZoomBackIn: Double;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MoveToPos(X, Y, Z, Time: Double): TGLMoveToPosJob;
Public | function OrbitToPos(X, Y, Z, Time: Double): TGLOrbitToPosJob;
Public | function OrbitToPosAdvanced(X, Y, Z, Time: Double; PreferUpAxis: boolean = True): TGLOrbitToPosAdvJob;
Public | function OrbitToPosAdvancedSmooth(const X, Y, Z, Time: Double; const ASmoothNavigator: TGLNavigatorSmoothChangeVector; const PreferUpAxis: boolean = True): TGLSmoothOrbitToPosAdvJob;
Public | function OrbitToPosSmooth(const ATargetPosition: TGLVector; const ATime: Double; const ASmoothNavigator: TGLNavigatorSmoothChangeVector; const AFNeedToRecalculateZoom: boolean; const ACameraUpVector: PGLVector = nil): TGLSmoothOrbitToPos;
Public | function ZoomToDistance(Distance, Time: Double): TGLZoomToDistanceJob;
Public | procedure SafeOrbitAndZoomToPos(X, Y, Z: Double);
Public | procedure Step(const deltaTime, newTime: Double);
Public | procedure StopMovement;
Private | procedure CheckAssignments(Extended: boolean);
Private | procedure SetCamera(const Value: TGLBaseSceneObject);
Private | procedure SetCameraTarget(const Value: TGLBaseSceneObject);
Private | procedure SetOnJobAdded(const Value: TGLCameraJobEvent);
Private | procedure SetOnJobFinished(const Value: TGLCameraJobEvent);
Private | procedure SetOnJobStep(const Value: TGLCameraJobEvent);

Properties

Published | property Camera: TGLBaseSceneObject read FCamera write SetCamera;
Public | property CameraJobList: TGLCameraJobList read FCameraJobList;
Published | property CameraTarget: TGLBaseSceneObject read FCameraTarget write SetCameraTarget;
Published | property OnJobAdded: TGLCameraJobEvent read FOnJobAdded write SetOnJobAdded;
Published | property OnJobFinished: TGLCameraJobEvent read FOnJobFinished write SetOnJobFinished;
Published | property OnJobStep: TGLCameraJobEvent read FOnJobStep write SetOnJobStep;
Published | property soSafeDistance: Double read FsoSafeDist write FsoSafeDist;
Published | property soTimeToOrbit: Double read FsoTimeToOrbit write FsoTimeToOrbit;
Published | property soTimeToSafePlacement: Double read FsoTimeToSafePlacement write FsoTimeToSafePlacement;
Published | property soTimeToZoomBackIn: Double read FsoTimeToZoomBackIn write FsoTimeToZoomBackIn;

Description

Fields

Private FCameraJobList: TGLCameraJobList;

Objects.

Private FCamera: TGLBaseSceneObject;

This item has no description.

Private FCameraTarget: TGLBaseSceneObject;

This item has no description.

Private FOnJobAdded: TGLCameraJobEvent;

Events.

Private FOnJobFinished: TGLCameraJobEvent;

This item has no description.

Private FOnJobStep: TGLCameraJobEvent;

This item has no description.

Private FsoSafeDist: Double;

fields used by SafeOrbitAndZoomToPos

Private FsoTimeToSafePlacement: Double;

fields used by SafeOrbitAndZoomToPos

Private FsoTimeToOrbit: Double;

fields used by SafeOrbitAndZoomToPos

Private FsoTimeToZoomBackIn: Double;

fields used by SafeOrbitAndZoomToPos

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MoveToPos(X, Y, Z, Time: Double): TGLMoveToPosJob;

linear movement from current pos

Public function OrbitToPos(X, Y, Z, Time: Double): TGLOrbitToPosJob;

orbiting from current pos to the pos where the camera points at the camera.targetObject TROUGH the given point it will not move to the given point(!), use SafeOrbitAndZoomToPos instead there has to be a camera.targetObject assigned!

Public function OrbitToPosAdvanced(X, Y, Z, Time: Double; PreferUpAxis: boolean = True): TGLOrbitToPosAdvJob;

Same function as OrbitToPos but support all camera states PreferUpAxis value is to setup if function use Camera Up based rotation axis instead of Camera direction based rotation axis when destination and camera position are opposite from Camera Target

Public function OrbitToPosAdvancedSmooth(const X, Y, Z, Time: Double; const ASmoothNavigator: TGLNavigatorSmoothChangeVector; const PreferUpAxis: boolean = True): TGLSmoothOrbitToPosAdvJob;

Same as OrbitToPosAdvanced(), but makes use of SmoothNavigator to make sure all camera movements are smooth.

Public function OrbitToPosSmooth(const ATargetPosition: TGLVector; const ATime: Double; const ASmoothNavigator: TGLNavigatorSmoothChangeVector; const AFNeedToRecalculateZoom: boolean; const ACameraUpVector: PGLVector = nil): TGLSmoothOrbitToPos;

Same as OrbitToPos(), but makes use of SmoothNavigator to make sure all camera movements are smooth.

Public function ZoomToDistance(Distance, Time: Double): TGLZoomToDistanceJob;

zooms in/out by moving to the given distance from camera.targetObject there has to be a camera.targetObject assigned!

Public procedure SafeOrbitAndZoomToPos(X, Y, Z: Double);

google earth - like "fly-to" = zoom out to safe distance, orbit, and then zoom in to the given point there has to be a camera.targetObject assigned!

Public procedure Step(const deltaTime, newTime: Double);

Called by the cadencer to animate the camera

Public procedure StopMovement;

It might be a good idea to introduce ability to stop movement and return control to user, here it is

Private procedure CheckAssignments(Extended: boolean);

private methods used to test whether camera and cadencer are assigned Extended = true -> will test also for Camera.TargetObject

Private procedure SetCamera(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetCameraTarget(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetOnJobAdded(const Value: TGLCameraJobEvent);

after AdjustScene the Camera.DepthofView will be modified if you want to zoom back in from GUI you should use something like Camera.DepthOfView:=2*Camera.DistanceToTarget+2*camera.TargetObject.BoundingSphereRadius;

Private procedure SetOnJobFinished(const Value: TGLCameraJobEvent);

This item has no description.

Private procedure SetOnJobStep(const Value: TGLCameraJobEvent);

This item has no description.

Properties

Published property Camera: TGLBaseSceneObject read FCamera write SetCamera;

Assign a Moving object (usually a TGLCamera).

Public property CameraJobList: TGLCameraJobList read FCameraJobList;

This item has no description.

Published property CameraTarget: TGLBaseSceneObject read FCameraTarget write SetCameraTarget;

Assign a target, around which Moving object should rotate(usually TGLCamera.TargetObject).

Published property OnJobAdded: TGLCameraJobEvent read FOnJobAdded write SetOnJobAdded;

this event is triggered when a job is init

Published property OnJobFinished: TGLCameraJobEvent read FOnJobFinished write SetOnJobFinished;

this event is triggered when a job is finished (not canceled)

Published property OnJobStep: TGLCameraJobEvent read FOnJobStep write SetOnJobStep;

this event is triggered when a job is step (like an OnMove)

Published property soSafeDistance: Double read FsoSafeDist write FsoSafeDist;

safe distance to avoid moving the camera trough the camera.targetObject while performing SafeOrbitAndZoomToPos

Published property soTimeToOrbit: Double read FsoTimeToOrbit write FsoTimeToOrbit;

time to orbit while performing SafeOrbitAndZoomToPos

Published property soTimeToSafePlacement: Double read FsoTimeToSafePlacement write FsoTimeToSafePlacement;

time to zoom in/out to the safe position while performing SafeOrbitAndZoomToPos

Published property soTimeToZoomBackIn: Double read FsoTimeToZoomBackIn write FsoTimeToZoomBackIn;

time to zoom in/out to the given final position while performing SafeOrbitAndZoomToPos


GLSysHelp v.2.5: GLS.Canvas

Unit GLS.Canvas

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Types
  • System.Classes
  • System.Math
  • Vcl.Graphics
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Color
  • GLS.Context
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCanvas |

Types

TGLArcDirection = (...);

Description

Types

TGLArcDirection = (...);

This item has no description.

Values
  • adCounterClockWise
  • adClockWise


GLSysHelp v.2.5: GLS.Canvas: Class TGLCanvas

Class TGLCanvas

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Canvas

Declaration

type TGLCanvas = class(TObject)

Description

A simple Canvas-like interface for OpenGL. This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points. This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner. All coordinates are internally maintained with floating point precision. Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).

Hierarchy

  • TObject
  • TGLCanvas

Overview

Fields

Private | FBufferSizeX: Integer;
Private | FBufferSizeY: Integer;
Private | FLastPrimitive: Integer;
Private | FCurrentPos: TAffineVector;
Private | FPenColor: TColor;
Private | FPenWidth: Integer;
Private | FCurrentPenColorVector: TGLVector;
Private | FArcDirection: TGLArcDirection;

Methods

Public | constructor Create(bufferSizeX, bufferSizeY: Integer); overload;
Public | constructor Create(bufferSizeX, bufferSizeY: Integer; const baseTransform: TGLMatrix); overload;
Public | destructor Destroy; override;
Public | procedure Arc(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;
Public | procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;
Public | procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;
Public | procedure ArcTo(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;
Public | procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;
Public | procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;
Public | procedure Ellipse(const x, y: Single; const Radius: Single); overload;
Public | procedure Ellipse(const x, y: Single; const xRadius, yRadius: Single); overload;
Public | procedure Ellipse(const x, y: Integer; const xRadius, yRadius: Single); overload;
Public | procedure EllipseBB(const x1, y1, x2, y2: Single); overload;
Public | procedure EllipseBB(const x1, y1, x2, y2: Integer); overload;
Public | procedure FillEllipse(const x, y: Integer; const xRadius, yRadius: Single); overload;
Public | procedure FillEllipse(const x, y: Single; const Radius: Single); overload;
Public | procedure FillEllipse(const x, y: Single; const xRadius, yRadius: Single); overload;
Public | procedure FillEllipseGradient(const x, y, Radius: Single; const edgeColor: TGLColorVector); overload;
Public | procedure FillEllipseGradient(const x, y: Integer; const xRadius, yRadius: Integer; const edgeColor: TGLColorVector); overload;
Public | procedure FillEllipseGradient(const x, y, xRadius, yRadius: Single; const edgeColor: TGLColorVector); overload;
Public | procedure FillRect(const x1, y1, x2, y2: Single); overload;
Public | procedure FillRect(const x1, y1, x2, y2: Integer); overload;
Public | procedure FillRectGradient(const x1, y1, x2, y2: Integer; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TGLColorVector); overload;
Public | procedure FillRectGradient(const x1, y1, x2, y2: Single; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TGLColorVector); overload;
Public | procedure FrameRect(const x1, y1, x2, y2: Integer); overload;
Public | procedure FrameRect(const x1, y1, x2, y2: Single); overload;
Public | procedure InvertYAxis;
Public | procedure Line(const x1, y1, x2, y2: Integer); overload;
Public | procedure Line(const x1, y1, x2, y2: Single); overload;
Public | procedure LineTo(const x, y: Integer); overload;
Public | procedure LineTo(const x, y: Single); overload;
Public | procedure LineToRel(const x, y: Integer); overload;
Public | procedure LineToRel(const x, y: Single); overload;
Public | procedure MoveTo(const x, y: Single); overload;
Public | procedure MoveTo(const x, y: Integer); overload;
Public | procedure MoveToRel(const x, y: Integer); overload;
Public | procedure MoveToRel(const x, y: Single); overload;
Public | procedure PlotPixel(const x, y: Single); overload;
Public | procedure PlotPixel(const x, y: Integer); overload;
Public | procedure Polygon(const points: array of TPoint);
Public | procedure Polyline(const points: array of TPoint);
Public | procedure RoundRect(const x1, y1, x2, y2, xr, yr: Integer); overload;
Public | procedure RoundRect(const x1, y1, x2, y2, xr, yr: Single); overload;
Public | procedure StopPrimitive;

Properties

Public | property ArcDirection: TGLArcDirection read FArcDirection write FArcDirection;
Public | property CanvasSizeX: Integer read FBufferSizeX;
Public | property CanvasSizeY: Integer read FBufferSizeY;
Public | property PenAlpha : Single read GetPenAlpha write SetPenAlpha;
Public | property PenColor: TColor read FPenColor write SetPenColor;
Public | property PenWidth: Integer read FPenWidth write SetPenWidth;

Description

Fields

Private FBufferSizeX: Integer;

This item has no description.

Private FBufferSizeY: Integer;

This item has no description.

Private FLastPrimitive: Integer;

This item has no description.

Private FCurrentPos: TAffineVector;

This item has no description.

Private FPenColor: TColor;

This item has no description.

Private FPenWidth: Integer;

This item has no description.

Private FCurrentPenColorVector: TGLVector;

This item has no description.

Private FArcDirection: TGLArcDirection;

This item has no description.

Methods

Public constructor Create(bufferSizeX, bufferSizeY: Integer); overload;

This item has no description.

Public constructor Create(bufferSizeX, bufferSizeY: Integer; const baseTransform: TGLMatrix); overload;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Arc(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;

This item has no description.

Public procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;

This item has no description.

Public procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;

Draw an elliptical arc. The points (x1, y1) and (x2, y2) specify the bounding rectangle. An ellipse formed by the specified bounding rectangle defines the curve of the arc. The arc extends in the current drawing direction from the point where it intersects the radial from the center of the bounding rectangle to the (x3, y3) point. The arc ends where it intersects the radial from the center of the bounding rectangle to the (x4, y4) point. If the starting point and ending point are the same, a complete ellipse is drawn. Use the ArcDirection property to get and set the current drawing direction for a device context. The default drawing direction is counterclockwise.

Public procedure ArcTo(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;

This item has no description.

Public procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;

This item has no description.

Public procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;

Same as Arc but update the current position.

Public procedure Ellipse(const x, y: Single; const Radius: Single); overload;

This item has no description.

Public procedure Ellipse(const x, y: Single; const xRadius, yRadius: Single); overload;

This item has no description.

Public procedure Ellipse(const x, y: Integer; const xRadius, yRadius: Single); overload;

Draws and ellipse centered at (x, y) with given radiuses.

Public procedure EllipseBB(const x1, y1, x2, y2: Single); overload;

This item has no description.

Public procedure EllipseBB(const x1, y1, x2, y2: Integer); overload;

Draws an ellipse with (x1,y1)-(x2, y2) bounding rectangle.

Public procedure FillEllipse(const x, y: Integer; const xRadius, yRadius: Single); overload;

Draw a filled ellipse.

Public procedure FillEllipse(const x, y: Single; const Radius: Single); overload;

This item has no description.

Public procedure FillEllipse(const x, y: Single; const xRadius, yRadius: Single); overload;

This item has no description.

Public procedure FillEllipseGradient(const x, y, Radius: Single; const edgeColor: TGLColorVector); overload;

This item has no description.

Public procedure FillEllipseGradient(const x, y: Integer; const xRadius, yRadius: Integer; const edgeColor: TGLColorVector); overload;

This item has no description.

Public procedure FillEllipseGradient(const x, y, xRadius, yRadius: Single; const edgeColor: TGLColorVector); overload;

Draw a filled gradient ellipse. OpenGL will use the last PenColor and PenAlpha as the center color and do gradient to edge of ellipse using the edgeColor parameter.

Public procedure FillRect(const x1, y1, x2, y2: Single); overload;

This item has no description.

Public procedure FillRect(const x1, y1, x2, y2: Integer); overload;

Draw the (x1,y1)-(x2, y2) rectangle (filled with PenColor).

Public procedure FillRectGradient(const x1, y1, x2, y2: Integer; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TGLColorVector); overload;

This item has no description.

Public procedure FillRectGradient(const x1, y1, x2, y2: Single; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TGLColorVector); overload;

Draw the (x1,y1)-(x2, y2) rectangle (filled with given gradient's color).

Public procedure FrameRect(const x1, y1, x2, y2: Integer); overload;

Draw the (x1,y1)-(x2, y2) rectangle's frame (border).

Public procedure FrameRect(const x1, y1, x2, y2: Single); overload;

This item has no description.

Public procedure InvertYAxis;

Inverts the orientation of the Y Axis. If (0, 0) was in the top left corner, it will move to the bottom left corner or vice-versa.

Public procedure Line(const x1, y1, x2, y2: Integer); overload;

Draws a line from (x1, y1) to (x2, y2). The current position is NOT updated.

Public procedure Line(const x1, y1, x2, y2: Single); overload;

This item has no description.

Public procedure LineTo(const x, y: Integer); overload;

Draws a line from current position to given coordinate. Current position is updated.

Public procedure LineTo(const x, y: Single); overload;

This item has no description.

Public procedure LineToRel(const x, y: Integer); overload;

This item has no description.

Public procedure LineToRel(const x, y: Single); overload;

This item has no description.

Public procedure MoveTo(const x, y: Single); overload;

This item has no description.

Public procedure MoveTo(const x, y: Integer); overload;

Updates the current position (absolute coords).

Public procedure MoveToRel(const x, y: Integer); overload;

Updates the current position (relative coords).

Public procedure MoveToRel(const x, y: Single); overload;

This item has no description.

Public procedure PlotPixel(const x, y: Single); overload;

This item has no description.

Public procedure PlotPixel(const x, y: Integer); overload;

Plots a pixel at given coordinate. PenWidth affects pixel size. The current position is NOT updated.

Public procedure Polygon(const points: array of TPoint);

Similar to Polyline but also connects the last point to the first.

Public procedure Polyline(const points: array of TPoint);

Draws the set of lines defined by connecting the points. Similar to invoking MoveTo on the first point, then LineTo on all the following points.

Public procedure RoundRect(const x1, y1, x2, y2, xr, yr: Integer); overload;

This item has no description.

Public procedure RoundRect(const x1, y1, x2, y2, xr, yr: Single); overload;

This item has no description.

Public procedure StopPrimitive;

Stops the current internal primitive. This function is invoked automatically by TGLCanvas when changeing primitives, you should directly call if you want to render your own stuff intertwined with TGLCanvas drawings. In that case, call it before your own OpenGL calls.

Properties

Public property ArcDirection: TGLArcDirection read FArcDirection write FArcDirection;

This item has no description.

Public property CanvasSizeX: Integer read FBufferSizeX;

This item has no description.

Public property CanvasSizeY: Integer read FBufferSizeY;

This item has no description.

Public property PenAlpha : Single read GetPenAlpha write SetPenAlpha;

Current Pen Alpha channel (from 0.0 to 1.0)

Public property PenColor: TColor read FPenColor write SetPenColor;

Current Pen Color.

Public property PenWidth: Integer read FPenWidth write SetPenWidth;

Current Pen Width.


GLSysHelp v.2.5: GLS.CgBombShader

Unit GLS.CgBombShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.Texture
  • GLS.Cadencer
  • GLS.Context
  • GLScene.Strings
  • GLS.Material
  • GLS.RenderContextInfo
  • GLScene.TextureFormat
  • GLS.State
  • Cg.GL
  • GLS.CgShader

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class ECgBombShaderException |
Class TCgCustomBombShader |
Class TCgBombShader |

Types

TGLCgBombShaderTextureSource = (...);

Description

Types

TGLCgBombShaderTextureSource = (...);

This item has no description.

Values
  • stsPrimaryTexture
  • stsSecondadyTexture
  • stsThirdTexture
  • stsUserSelectedTexture


GLSysHelp v.2.5: GLS.CgBombShader: Class ECgBombShaderException

Class ECgBombShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgBombShader

Declaration

type ECgBombShaderException = class(ECgShaderException)

Description

This item has no description. Showing description inherited from ECgShaderException.

Define OutputCompilerWarnings to output Cg compiler warnings to a file. Useful for detecting bugs caused by using uninitialized value, implicit type cast, etc.

Hierarchy

  • TObject
  • Exception
  • EGLShaderException
  • ECgShaderException
  • ECgBombShaderException


GLSysHelp v.2.5: GLS.CgBombShader: Class TCgCustomBombShader

Class TCgCustomBombShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgBombShader

Declaration

type TCgCustomBombShader = class(TCadencableCustomCgShader, IGLMaterialLibrarySupported)

Description

Just a good-looking shader.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TCadencableCustomCgShader
  • TCgCustomBombShader

Overview

Fields

Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FGradientTexture: TGLTexture;
Private | FMainTexture: TGLTexture;
Private | FMainTextureName: TGLLibMaterialName;
Private | FGradientTextureName: TGLLibMaterialName;
Private | FSharpness: Single;
Private | FColorRange: Single;
Private | FSpeed: Single;
Private | FDisplacement: Single;
Private | FAlpha: Single;
Private | FTurbDensity: Single;
Private | FColorSharpness: Single;
Private | FGradientTextureShare: Single;
Private | FMainTextureShare: Single;
Private | FMainTextureSource: TGLCgBombShaderTextureSource;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetGradientTextureName: TGLLibMaterialName;
Private | function GetMainTextureName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function StoreColorRange: Boolean;
Private | function StoreColorSharpness: Boolean;
Private | function StoreDisplacement: Boolean;
Private | function StoreGradientTextureShare: Boolean;
Private | function StoreMainTextureShare: Boolean;
Private | function StoreSharpness: Boolean;
Private | function StoreSpeed: Boolean;
Private | function StoreTurbDensity: Boolean;
Private | procedure SetGradientTexture(const Value: TGLTexture);
Private | procedure SetGradientTextureName(const Value: TGLLibMaterialName);
Private | procedure SetMainTexture(const Value: TGLTexture);
Private | procedure SetMainTextureName(const Value: TGLLibMaterialName);

Properties

Public | property Alpha: Single read FAlpha write FAlpha;
Public | property ColorRange: Single read FColorRange write FColorRange stored StoreColorRange;
Public | property ColorSharpness: Single read FColorSharpness write FColorSharpness stored StoreColorSharpness;
Public | property Displacement: Single read FDisplacement write FDisplacement stored StoreDisplacement;
Public | property GradientTexture: TGLTexture read FGradientTexture write SetGradientTexture;
Public | property GradientTextureName: TGLLibMaterialName read GetGradientTextureName write SetGradientTextureName;
Public | property GradientTextureShare: Single read FGradientTextureShare write FGradientTextureShare stored StoreGradientTextureShare;
Public | property MainTexture: TGLTexture read FMainTexture write SetMainTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;
Public | property MainTextureShare: Single read FMainTextureShare write FMainTextureShare stored StoreMainTextureShare;
Public | property MainTextureSource: TGLCgBombShaderTextureSource read FMainTextureSource write FMainTextureSource;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property Sharpness: Single read FSharpness write FSharpness stored StoreSharpness;
Public | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Public | property TurbDensity: Single read FTurbDensity write FTurbDensity stored StoreTurbDensity;

Description

Fields

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FGradientTexture: TGLTexture;

This item has no description.

Private FMainTexture: TGLTexture;

This item has no description.

Private FMainTextureName: TGLLibMaterialName;

This item has no description.

Private FGradientTextureName: TGLLibMaterialName;

This item has no description.

Private FSharpness: Single;

This item has no description.

Private FColorRange: Single;

This item has no description.

Private FSpeed: Single;

This item has no description.

Private FDisplacement: Single;

This item has no description.

Private FAlpha: Single;

This item has no description.

Private FTurbDensity: Single;

This item has no description.

Private FColorSharpness: Single;

This item has no description.

Private FGradientTextureShare: Single;

This item has no description.

Private FMainTextureShare: Single;

This item has no description.

Private FMainTextureSource: TGLCgBombShaderTextureSource;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetGradientTextureName: TGLLibMaterialName;

This item has no description.

Private function GetMainTextureName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Private function StoreColorRange: Boolean;

This item has no description.

Private function StoreColorSharpness: Boolean;

This item has no description.

Private function StoreDisplacement: Boolean;

This item has no description.

Private function StoreGradientTextureShare: Boolean;

This item has no description.

Private function StoreMainTextureShare: Boolean;

This item has no description.

Private function StoreSharpness: Boolean;

This item has no description.

Private function StoreSpeed: Boolean;

This item has no description.

Private function StoreTurbDensity: Boolean;

This item has no description.

Private procedure SetGradientTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetGradientTextureName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMainTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetMainTextureName(const Value: TGLLibMaterialName);

This item has no description.

Properties

Public property Alpha: Single read FAlpha write FAlpha;

This item has no description.

Public property ColorRange: Single read FColorRange write FColorRange stored StoreColorRange;

This item has no description.

Public property ColorSharpness: Single read FColorSharpness write FColorSharpness stored StoreColorSharpness;

This item has no description.

Public property Displacement: Single read FDisplacement write FDisplacement stored StoreDisplacement;

This item has no description.

Public property GradientTexture: TGLTexture read FGradientTexture write SetGradientTexture;

This item has no description.

Public property GradientTextureName: TGLLibMaterialName read GetGradientTextureName write SetGradientTextureName;

This item has no description.

Public property GradientTextureShare: Single read FGradientTextureShare write FGradientTextureShare stored StoreGradientTextureShare;

This item has no description.

Public property MainTexture: TGLTexture read FMainTexture write SetMainTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;

This item has no description.

Public property MainTextureShare: Single read FMainTextureShare write FMainTextureShare stored StoreMainTextureShare;

This item has no description.

Public property MainTextureSource: TGLCgBombShaderTextureSource read FMainTextureSource write FMainTextureSource;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property Sharpness: Single read FSharpness write FSharpness stored StoreSharpness;

This item has no description.

Public property Speed: Single read FSpeed write FSpeed stored StoreSpeed;

This item has no description.

Public property TurbDensity: Single read FTurbDensity write FTurbDensity stored StoreTurbDensity;


GLSysHelp v.2.5: GLS.CgBombShader: Class TCgBombShader

Class TCgBombShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgBombShader

Declaration

type TCgBombShader = class(TCgCustomBombShader)

Description

This item has no description. Showing description inherited from TCgCustomBombShader.

Just a good-looking shader.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TCadencableCustomCgShader
  • TCgCustomBombShader
  • TCgBombShader

Overview

Properties

Published | property Alpha;
Published | property Cadencer;
Published | property ColorRange;
Published | property ColorSharpness;
Published | property DesignEnable;
Published | property Displacement;
Published | property GradientTextureName;
Published | property GradientTextureShare;
Published | property MainTextureName;
Published | property MainTextureShare;
Published | property MaterialLibrary;
Published | property Sharpness;
Published | property Speed;
Published | property TurbDensity;

Description

Properties

Published property Alpha;

This item has no description.

Published property Cadencer;

This item has no description.

Published property ColorRange;

This item has no description.

Published property ColorSharpness;

This item has no description.

Published property DesignEnable;

This item has no description.

Published property Displacement;

This item has no description.

Published property GradientTextureName;

This item has no description.

Published property GradientTextureShare;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MainTextureShare;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property Sharpness;

This item has no description.

Published property Speed;

This item has no description.

Published property TurbDensity;


GLSysHelp v.2.5: GLS.CgPostTransformationShader

Unit GLS.CgPostTransformationShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.Texture
  • GLS.Cadencer
  • GLS.Context
  • GLS.Scene
  • GLS.RenderContextInfo
  • GLScene.TextureFormat
  • Cg.Import
  • Cg.GL
  • GLS.CgShader
  • GLSL.CustomShader

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCustomCGPostTransformationShader |
Class TGLCGPostTransformationShader |


GLSysHelp v.2.5: GLS.CgPostTransformationShader: Class TGLCustomCGPostTransformationShader

Class TGLCustomCGPostTransformationShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgPostTransformationShader

Declaration

type TGLCustomCGPostTransformationShader = class(TCustomCGShader, IGLPostShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TGLCustomCGPostTransformationShader

Overview

Fields

Private | FTransformationPower: Single;
Private | FTransformationTexture: TGLTexture;

Methods

Public constructor Create(AOwner: TComponent); override;

Properties

Public | property TransformationPower: Single read FTransformationPower write FTransformationPower;
Public | property TransformationTexture: TGLTexture read FTransformationTexture write FTransformationTexture;

Description

Fields

Private FTransformationPower: Single;

This item has no description.

Private FTransformationTexture: TGLTexture;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Properties

Public property TransformationPower: Single read FTransformationPower write FTransformationPower;

This item has no description.

Public property TransformationTexture: TGLTexture read FTransformationTexture write FTransformationTexture;


GLSysHelp v.2.5: GLS.CgPostTransformationShader: Class TGLCGPostTransformationShader

Class TGLCGPostTransformationShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgPostTransformationShader

Declaration

type TGLCGPostTransformationShader = class(TGLCustomCGPostTransformationShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TGLCustomCGPostTransformationShader
  • TGLCGPostTransformationShader

Overview

Properties

Published | property TransformationPower;
Published | property TransformationTexture;

Description

Properties

Published property TransformationPower;

This item has no description.

Published property TransformationTexture;


GLSysHelp v.2.5: GLS.CgRegister

Unit GLS.CgRegister

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • DesignIntf
  • DesignEditors
  • VCLEditors
  • GLS.Material
  • Cg.Import
  • Cg.GL
  • GLS.SceneRegister
  • GLS.CgShader
  • GLS.CgBombShader

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;

using TGLLibMaterialNameProperty


GLSysHelp v.2.5: GLS.CgShader

Unit GLS.CgShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLScene.VectorTypes
  • GLS.Texture
  • GLScene.Strings
  • GLS.Cadencer
  • GLS.Context
  • GLS.BaseClasses
  • GLS.RenderContextInfo
  • GLS.Material
  • GLScene.TextureFormat
  • Cg.Import
  • Cg.GL

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class ECgShaderException |
Class TCgProgram |
Class TCgParameter |
Class TCgVertexProgram |
Class TCgFragmentProgram |
Class TCustomCgShader |
Class TCadencableCustomCgShader |
Class TCgShader |

Functions and Procedures

function IsCgProfileSupported(Profile: TcgProfile): boolean;

Types

TCgApplyEvent = procedure(CgProgram: TCgProgram; Sender: TObject) of object;
TCgFPProfile = (...);
TcgProgramType = (...);
TCgShaderEvent = procedure(CgShader: TCustomCgShader) of object;
TCgUnApplyEvent = procedure(CgProgram: TCgProgram) of object;
TCgVPProfile = (...);
TPrecisionSetting = (...);

Variables

IncludeFilePath: string;

Description

Functions and Procedures

function IsCgProfileSupported(Profile: TcgProfile): boolean;

Misc. global functions

Types

TCgApplyEvent = procedure(CgProgram: TCgProgram; Sender: TObject) of object;

This item has no description.

TCgFPProfile = (...);

Available fragment program profile

Values
  • fpDetectLatest
  • fp20
  • fp30
  • fp40
  • arbfp1
TcgProgramType = (...);

This item has no description.

Values
  • ptVertex
  • ptFragment
TCgShaderEvent = procedure(CgShader: TCustomCgShader) of object;

This item has no description.

TCgUnApplyEvent = procedure(CgProgram: TCgProgram) of object;

This item has no description.

TCgVPProfile = (...);

Available vertex program profile

Values
  • vpDetectLatest
  • vp20
  • vp30
  • vp40
  • arbvp1
TPrecisionSetting = (...);

This item has no description.

Values
  • psFull
  • psFast

Variables

IncludeFilePath: string;

Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.


GLSysHelp v.2.5: GLS.CgShader: Class ECgShaderException

Class ECgShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgShader

Declaration

type ECgShaderException = class(EGLShaderException)

Description

Define OutputCompilerWarnings to output Cg compiler warnings to a file. Useful for detecting bugs caused by using uninitialized value, implicit type cast, etc.

Hierarchy

  • TObject
  • Exception
  • EGLShaderException
  • ECgShaderException


GLSysHelp v.2.5: GLS.CgShader: Class TCgProgram

Class TCgProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgShader

Declaration

type TCgProgram = class(TGLUpdateAbleObject)

Description

Wrapper around a Cg program.

Hierarchy

  • TGLUpdateAbleObject
  • TCgProgram

Overview

Fields

Private | FCgContext: PcgContext;
Private | FCode: TStrings;
Private | FProgramName: String;
Private | FHandle: PCGprogram;
Private | FParams: TList;
Private | FOnApply: TCgApplyEvent;
Private | FOnUnApply: TCgUnApplyEvent;
Private | FOnProgramChanged: TNotifyEvent;
Private | FEnabled: boolean;
Private | FDetectProfile: boolean;
Private | FPrecision: TPrecisionSetting;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function DirectParamByName(const name: String): PCGParameter;
Public | function GetLatestProfile: TcgProfile; virtual; abstract;
Public | function GetProfileStringA: string;
Public | function LongName: string;
Public | function ParamByName(const name: String): TCgParameter;
Public | function ParamCount: Integer;
Private | function GetManualNotification: boolean;
Public | procedure Apply(var rci: TGLRenderContextInfo; Sender: TObject);
Public | procedure Finalize;
Public | procedure Initialize; virtual;
Public | procedure ListCompilation(Output: TStrings);
Public | procedure ListParameters(Output: TStrings);
Public | procedure LoadFromFile(const fileName: String);
Public | procedure SetParam(ParamName: string; const Vector2fVal: TVector2f); overload;
Public | procedure SetParam(ParamName: string; const Vector3fVal: TVector3f); overload;
Public | procedure SetParam(ParamName: string; const Vector4fVal: TVector4f); overload;
Public | procedure SetParam(ParamName: string; SingleVal: Single); overload;
Public | procedure SetStateMatrix(ParamName: string; matrix, Transform: Cardinal);
Public | procedure SetTexture(ParamName: string; TextureID: Cardinal);
Public | procedure UnApply(var rci: TGLRenderContextInfo);
Private | procedure SetManualNotification(const Value: boolean);
Private | procedure SetPrecision(const Value: TPrecisionSetting);

Properties

Published | property Code: TStrings read FCode write SetCode;
Public | property DirectProfile: TcgProfile read FProfile write FProfile;
Published | property Enabled: boolean read FEnabled write FEnabled default True;
Public | property ManualNotification: boolean read GetManualNotification write SetManualNotification default False;
Published | property OnApply: TCgApplyEvent read FOnApply write FOnApply;
Public | property OnProgramChanged: TNotifyEvent read FOnProgramChanged write FOnProgramChanged;
Published | property OnUnApply: TCgUnApplyEvent read FOnUnApply write FOnUnApply;
Public | property Param[index: String]: TCgParameter read GetParam;
Public | property Params: TList read FParams;
Published | property Precision: TPrecisionSetting read FPrecision write SetPrecision default psFull;
Published | property ProgramName: String read FProgramName write SetProgramName;

Description

Fields

Private FCgContext: PcgContext;

This item has no description.

Private FCode: TStrings;

This item has no description.

Private FProgramName: String;

the Cg program itself

Private FHandle: PCGprogram;

This item has no description.

Private FParams: TList;

This item has no description.

Private FOnApply: TCgApplyEvent;

This item has no description.

Private FOnUnApply: TCgUnApplyEvent;

This item has no description.

Private FOnProgramChanged: TNotifyEvent;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FDetectProfile: boolean;

This item has no description.

Private FPrecision: TPrecisionSetting;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DirectParamByName(const name: String): PCGParameter;

Returns a handle to a Cg parameter

Public function GetLatestProfile: TcgProfile; virtual; abstract;

This item has no description.

Public function GetProfileStringA: string;

This item has no description.

Public function LongName: string;

retruns ShaderName.[program type].ProgramName

Public function ParamByName(const name: String): TCgParameter;

ParamByName returns CgParameter; returns nil if not found.

Public function ParamCount: Integer;

This item has no description.

Private function GetManualNotification: boolean;

This item has no description.

Public procedure Apply(var rci: TGLRenderContextInfo; Sender: TObject);

This item has no description.

Public procedure Finalize;

This item has no description.

Public procedure Initialize; virtual;

This item has no description.

Public procedure ListCompilation(Output: TStrings);

This item has no description.

Public procedure ListParameters(Output: TStrings);

This item has no description.

Public procedure LoadFromFile(const fileName: String);

This item has no description.

Public procedure SetParam(ParamName: string; const Vector2fVal: TVector2f); overload;

This item has no description.

Public procedure SetParam(ParamName: string; const Vector3fVal: TVector3f); overload;

This item has no description.

Public procedure SetParam(ParamName: string; const Vector4fVal: TVector4f); overload;

This item has no description.

Public procedure SetParam(ParamName: string; SingleVal: Single); overload;

shorthands for accessing parameters

Public procedure SetStateMatrix(ParamName: string; matrix, Transform: Cardinal);

This item has no description.

Public procedure SetTexture(ParamName: string; TextureID: Cardinal);

This item has no description.

Public procedure UnApply(var rci: TGLRenderContextInfo);

This item has no description.

Private procedure SetManualNotification(const Value: boolean);

This item has no description.

Private procedure SetPrecision(const Value: TPrecisionSetting);

This item has no description.

Properties

Published property Code: TStrings read FCode write SetCode;

This item has no description.

Public property DirectProfile: TcgProfile read FProfile write FProfile;

Direct access to the profile. Set Profile of the sub-classes to any but DetectLatest if you want to specify the profile directly.

Published property Enabled: boolean read FEnabled write FEnabled default True;

This item has no description.

Public property ManualNotification: boolean read GetManualNotification write SetManualNotification default False;

If True, that shader is not reset when TCgProgram' parameters change.

Published property OnApply: TCgApplyEvent read FOnApply write FOnApply;

This item has no description.

Public property OnProgramChanged: TNotifyEvent read FOnProgramChanged write FOnProgramChanged;

Seams, that this event is never called. Probably should be deleted...

Published property OnUnApply: TCgUnApplyEvent read FOnUnApply write FOnUnApply;

This item has no description.

Public property Param[index: String]: TCgParameter read GetParam;

Use Param instead of ParamByName if you want implicit check for the existence of your requested parameter.

Public property Params: TList read FParams;

This item has no description.

Published property Precision: TPrecisionSetting read FPrecision write SetPrecision default psFull;

Precision controls data precision of GPU operation. Possible options are 16-bit (psFast) or 32-bit (psFull). 16-bit operation is generally faster.

Published property ProgramName: String read FProgramName write SetProgramName;


GLSysHelp v.2.5: GLS.CgShader: Class TCgParameter

Class TCgParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgShader

Declaration

type TCgParameter = class(TObject)

Description

Wrapper around a Cg parameter of the main program.

Hierarchy

  • TObject
  • TCgParameter

Overview

Fields

Private | FOwner: TCgProgram;
Private | FName: String;
Private | FHandle: PCGParameter;
Private | FValueType: TCGtype;
Private | FDirection: TCGenum;
Private | FVariability: TCGenum;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function LongName: string;
Public | procedure DisableClientState;
Public | procedure DisableTexture;
Public | procedure EnableClientState;
Public | procedure EnableTexture;
Public | procedure SetAsMatrix(const val: TMatrix4f);
Public | procedure SetAsScalar(const val: Single); overload;
Public | procedure SetAsScalar(const val: boolean); overload;
Public | procedure SetAsStateMatrix(matrix, Transform: Cardinal);
Public | procedure SetAsTexture(TextureID: Cardinal);
Public | procedure SetAsTexture1D(TextureID: Cardinal);
Public | procedure SetAsTexture2D(TextureID: Cardinal);
Public | procedure SetAsTexture3D(TextureID: Cardinal);
Public | procedure SetAsTextureCUBE(TextureID: Cardinal);
Public | procedure SetAsTextureRECT(TextureID: Cardinal);
Public | procedure SetAsVector(const val: TVector4f); overload;
Public | procedure SetAsVector(const val: TVector3f); overload;
Public | procedure SetAsVector(const val: TVector2f); overload;
Public | procedure SetAsVector(const val: array of Single); overload;
Public | procedure SetParameterPointer(Values: TGLVectorList); overload;
Public | procedure SetParameterPointer(Values: TGLAffineVectorList); overload;
Public | procedure SetToTextureOf(LibMaterial: TGLLibMaterial);

Properties

Public | property AsAffineVector: TAffineVector write SetAsVector3f;
Public | property AsVector: TGLVector write SetAsVector4f;
Public | property AsVector2f: TVector2f write SetAsVector2f;
Public | property Direction: TCGenum read FDirection write FDirection;
Public | property Handle: PCGParameter read FHandle write FHandle;
Public | property Name: String read FName;
Public | property Owner: TCgProgram read FOwner;
Public | property ValueType: TCGtype read FValueType;
Public | property Variability: TCGenum read FVariability write FVariability;

Description

Fields

Private FOwner: TCgProgram;

This item has no description.

Private FName: String;

This item has no description.

Private FHandle: PCGParameter;

This item has no description.

Private FValueType: TCGtype;

This item has no description.

Private FDirection: TCGenum;

e.g. CG_FLOAT

Private FVariability: TCGenum;

e.g. CG_INOUT

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LongName: string;

LongName retruns ShaderName.[program type].ProgramName.ParamName.

Public procedure DisableClientState;

This item has no description.

Public procedure DisableTexture;

This item has no description.

Public procedure EnableClientState;

This item has no description.

Public procedure EnableTexture;

This item has no description.

Public procedure SetAsMatrix(const val: TMatrix4f);

This item has no description.

Public procedure SetAsScalar(const val: Single); overload;

Procedures for setting uniform pamareters. Implicitly check for data type.

Public procedure SetAsScalar(const val: boolean); overload;

This item has no description.

Public procedure SetAsStateMatrix(matrix, Transform: Cardinal);

This item has no description.

Public procedure SetAsTexture(TextureID: Cardinal);

SetAsTexture checks for all texture types

Public procedure SetAsTexture1D(TextureID: Cardinal);

SetAsTexture* check for specific type

Public procedure SetAsTexture2D(TextureID: Cardinal);

This item has no description.

Public procedure SetAsTexture3D(TextureID: Cardinal);

This item has no description.

Public procedure SetAsTextureCUBE(TextureID: Cardinal);

This item has no description.

Public procedure SetAsTextureRECT(TextureID: Cardinal);

This item has no description.

Public procedure SetAsVector(const val: TVector4f); overload;

This item has no description.

Public procedure SetAsVector(const val: TVector3f); overload;

This item has no description.

Public procedure SetAsVector(const val: TVector2f); overload;

This item has no description.

Public procedure SetAsVector(const val: array of Single); overload;

This overloaded SetAsVector accepts open array as input. e.g. SetAsVector([0.1, 0.2]). Array length must between 1-4.

Public procedure SetParameterPointer(Values: TGLVectorList); overload;

Procedures for setting varying parameters with an array of values.

Public procedure SetParameterPointer(Values: TGLAffineVectorList); overload;

This item has no description.

Public procedure SetToTextureOf(LibMaterial: TGLLibMaterial);

SetToTextureOf determines texture type on-the-fly.

Properties

Public property AsAffineVector: TAffineVector write SetAsVector3f;

position f.i.

Public property AsVector: TGLVector write SetAsVector4f;

GLScene-friendly properties

Public property AsVector2f: TVector2f write SetAsVector2f;

normal f.i.

Public property Direction: TCGenum read FDirection write FDirection;

This item has no description.

Public property Handle: PCGParameter read FHandle write FHandle;

This item has no description.

Public property Name: String read FName;

This item has no description.

Public property Owner: TCgProgram read FOwner;

This item has no description.

Public property ValueType: TCGtype read FValueType;

This item has no description.

Public property Variability: TCGenum read FVariability write FVariability;


GLSysHelp v.2.5: GLS.CgShader: Class TCgVertexProgram

Class TCgVertexProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgShader

Declaration

type TCgVertexProgram = class(TCgProgram)

Description

This item has no description. Showing description inherited from TCgProgram.

Wrapper around a Cg program.

Hierarchy

  • TGLUpdateAbleObject
  • TCgProgram
  • TCgVertexProgram

Overview

Fields

Private FVPProfile: TCgVPProfile;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function GetLatestProfile: TcgProfile; override;
Private | procedure SetVPProfile(v: TCgVPProfile);

Properties

Published property Profile: TCgVPProfile read FVPProfile write SetVPProfile default vpDetectLatest;

Description

Fields

Private FVPProfile: TCgVPProfile;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public function GetLatestProfile: TcgProfile; override;

This item has no description.

Private procedure SetVPProfile(v: TCgVPProfile);

This item has no description.

Properties

Published property Profile: TCgVPProfile read FVPProfile write SetVPProfile default vpDetectLatest;


GLSysHelp v.2.5: GLS.CgShader: Class TCgFragmentProgram

Class TCgFragmentProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgShader

Declaration

type TCgFragmentProgram = class(TCgProgram)

Description

This item has no description. Showing description inherited from TCgProgram.

Wrapper around a Cg program.

Hierarchy

  • TGLUpdateAbleObject
  • TCgProgram
  • TCgFragmentProgram

Overview

Fields

Private | FFPProfile: TCgFPProfile;
Private | FManageTexture: boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function GetLatestProfile: TcgProfile; override;
Public | procedure Initialize; override;
Private | procedure SetFPProfile(v: TCgFPProfile);
Private | procedure SetManageTexture(const Value: boolean);

Properties

Published | property ManageTexture: boolean read FManageTexture write SetManageTexture default False;
Published | property Profile: TCgFPProfile read FFPProfile write SetFPProfile default fpDetectLatest;

Description

Fields

Private FFPProfile: TCgFPProfile;

This item has no description.

Private FManageTexture: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public function GetLatestProfile: TcgProfile; override;

This item has no description.

Public procedure Initialize; override;

This item has no description.

Private procedure SetFPProfile(v: TCgFPProfile);

This item has no description.

Private procedure SetManageTexture(const Value: boolean);

This item has no description.

Properties

Published property ManageTexture: boolean read FManageTexture write SetManageTexture default False;

Switch for auto enabling of texture parameters (Cg 1.2 feature) With Cg 1.2.1, default is OFF

Published property Profile: TCgFPProfile read FFPProfile write SetFPProfile default fpDetectLatest;


GLSysHelp v.2.5: GLS.CgShader: Class TCustomCgShader

Class TCustomCgShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgShader

Declaration

type TCustomCgShader = class(TGLShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader

Overview

Fields

Private | FVertexProgram: TCgVertexProgram;
Private | FFragmentProgram: TCgFragmentProgram;
Private | FOnInitialize: TCgShaderEvent;
Private | FDesignEnable: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: boolean; override;
Public | procedure LoadShaderPrograms(const VPFilename, FPFilename: string);

Description

Fields

Private FVertexProgram: TCgVertexProgram;

This item has no description.

Private FFragmentProgram: TCgFragmentProgram;

This item has no description.

Private FOnInitialize: TCgShaderEvent;

This item has no description.

Private FDesignEnable: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ShaderSupported: boolean; override;

This item has no description. Showing description inherited from TGLShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public procedure LoadShaderPrograms(const VPFilename, FPFilename: string);


GLSysHelp v.2.5: GLS.CgShader: Class TCadencableCustomCgShader

Class TCadencableCustomCgShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgShader

Declaration

type TCadencableCustomCgShader = class(TCustomCgShader)

Description

Allows to use a Cadencer, which is used for noise generation in many shaders.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TCadencableCustomCgShader

Overview

Fields

Private FCadencer: TGLCadencer;

Methods

Private procedure SetCadencer(const Value: TGLCadencer);

Properties

Public property Cadencer: TGLCadencer read FCadencer write SetCadencer;

Description

Fields

Private FCadencer: TGLCadencer;

This item has no description.

Methods

Private procedure SetCadencer(const Value: TGLCadencer);

This item has no description.

Properties

Public property Cadencer: TGLCadencer read FCadencer write SetCadencer;


GLSysHelp v.2.5: GLS.CgShader: Class TCgShader

Class TCgShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CgShader

Declaration

type TCgShader = class(TCustomCgShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TCgShader

Overview

Properties

Published | property DesignEnable;
Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property OnApplyFP;
Published | property OnApplyVP;
Published | property OnInitialize;
Published | property OnUnApplyFP;
Published | property OnUnApplyVP;
Published | property ShaderStyle;
Published | property VertexProgram;

Description

Properties

Published property DesignEnable;

This item has no description.

Published property FailedInitAction;

This item has no description. Showing description inherited from TGLShader.FailedInitAction.

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Published property FragmentProgram;

This item has no description.

Published property OnApplyFP;

This item has no description.

Published property OnApplyVP;

This item has no description.

Published property OnInitialize;

This item has no description.

Published property OnUnApplyFP;

This item has no description.

Published property OnUnApplyVP;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TGLShader.ShaderStyle.

Shader application style (default is ssLowLevel).

Published property VertexProgram;


GLSysHelp v.2.5: GLS.Collision

Unit GLS.Collision

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.VectorTypes
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLScene.XCollection
  • GLS.VectorLists
  • GLS.VectorFileObjects
  • GLScene.GeometryBB
  • GLScene.Manager

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCollisionManager |
Class TGLBCollision |

Functions and Procedures

function FastCheckPointVsPoint(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckPointVsSphere(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckPointVsEllipsoid(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckPointVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckSphereVsPoint(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckSphereVsSphere(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckSphereVsEllipsoid(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckSphereVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckEllipsoidVsPoint(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckEllipsoidVsSphere(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckEllipsoidVsEllipsoid(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckEllipsoidVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckCubeVsPoint(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckCubeVsSphere(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckCubeVsEllipsoid(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckCubeVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckCubeVsFace(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckFaceVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;
function FastCheckFaceVsFace(obj1, obj2: TGLBaseSceneObject): Boolean;
function IntersectCubes(obj1, obj2: TGLBaseSceneObject): Boolean; overload;
function GetOrCreateCollision(behaviours: TGLBehaviours) : TGLBCollision; overload;
function GetOrCreateCollision(obj: TGLBaseSceneObject): TGLBCollision; overload;

Types

PFastCollisionChecker = ˆTFastCollisionChecker;
TCollisionBoundingMode = (...);
TFastCollisionChecker = function(obj1, obj2: TGLBaseSceneObject): Boolean;
TObjectCollisionEvent = procedure(Sender: TObject; object1, object2: TGLBaseSceneObject) of object;

Description

Functions and Procedures

function FastCheckPointVsPoint(obj1, obj2: TGLBaseSceneObject): Boolean;

Fast Collision detection routines that are heavily specialized and just return a boolean

function FastCheckPointVsSphere(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckPointVsEllipsoid(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckPointVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckSphereVsPoint(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckSphereVsSphere(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckSphereVsEllipsoid(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckSphereVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckEllipsoidVsPoint(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckEllipsoidVsSphere(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckEllipsoidVsEllipsoid(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckEllipsoidVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsPoint(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsSphere(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsEllipsoid(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsFace(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

function FastCheckFaceVsCube(obj1, obj2: TGLBaseSceneObject): Boolean;

experimental

function FastCheckFaceVsFace(obj1, obj2: TGLBaseSceneObject): Boolean;

experimental

function IntersectCubes(obj1, obj2: TGLBaseSceneObject): Boolean; overload;

Returns true when the bounding box cubes does intersect the other. Also true when the one cube does contain the other completely.

function GetOrCreateCollision(behaviours: TGLBehaviours) : TGLBCollision; overload;

Returns or creates the TGLBCollision within the given behaviours. This helper function is convenient way to access a TGLBCollision.

function GetOrCreateCollision(obj: TGLBaseSceneObject): TGLBCollision; overload;

Returns or creates the TGLBCollision within the given object's behaviours. This helper function is convenient way to access a TGLBCollision.

Types

PFastCollisionChecker = ˆTFastCollisionChecker;

This item has no description.

TCollisionBoundingMode = (...);

Defines how fine collision bounding is for a particular object. Possible values are : cbmPoint : the object is punctual and may only collide with volumes cbmSphere : the object is defined by its bounding sphere (radius is the max of axis-aligned dimensions) cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid cbmCube : the object is defined by a bounding axis-aligned "cube" cbmFaces : the object is defined by its faces (needs object-level support, if unavailable, uses cbmCube code)

Values
  • cbmPoint
  • cbmSphere
  • cbmEllipsoid
  • cbmCube
  • cbmFaces
TFastCollisionChecker = function(obj1, obj2: TGLBaseSceneObject): Boolean;

This item has no description.

TObjectCollisionEvent = procedure(Sender: TObject; object1, object2: TGLBaseSceneObject) of object;


GLSysHelp v.2.5: GLS.Collision: Class TGLCollisionManager

Class TGLCollisionManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Collision

Declaration

type TGLCollisionManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLCollisionManager

Overview

Fields

Private | FClients: TList;
Private | FOnCollision: TObjectCollisionEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CheckCollisions;

Properties

Published property OnCollision: TObjectCollisionEvent read FOnCollision write FOnCollision;

Description

Fields

Private FClients: TList;

This item has no description.

Private FOnCollision: TObjectCollisionEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CheckCollisions;

This item has no description.

Properties

Published property OnCollision: TObjectCollisionEvent read FOnCollision write FOnCollision;


GLSysHelp v.2.5: GLS.Collision: Class TGLBCollision

Class TGLBCollision

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Collision

Declaration

type TGLBCollision = class(TGLBehaviour)

Description

Collision detection behaviour. Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms. An object may have multiple TGLBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBCollision

Overview

Fields

Private | FBoundingMode: TCollisionBoundingMode;
Private | FManager: TGLCollisionManager;
Private | FManagerName: String;
Private | FGroupIndex: Integer;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property BoundingMode: TCollisionBoundingMode read FBoundingMode write FBoundingMode;
Published | property GroupIndex: Integer read FGroupIndex write SetGroupIndex;
Published | property Manager: TGLCollisionManager read FManager write SetManager;

Description

Fields

Private FBoundingMode: TCollisionBoundingMode;

This item has no description.

Private FManager: TGLCollisionManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FGroupIndex: Integer;

NOT persistent, temporarily used for persistence

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Properties

Published property BoundingMode: TCollisionBoundingMode read FBoundingMode write FBoundingMode;

This item has no description.

Published property GroupIndex: Integer read FGroupIndex write SetGroupIndex;

This item has no description.

Published property Manager: TGLCollisionManager read FManager write SetManager;

Refers the collision manager.


GLSysHelp v.2.5: GLS.CompositeImage

Unit GLS.CompositeImage

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLS.Context
  • GLScene.OpenGLTokens
  • GLS.Graphics
  • GLS.Texture
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCompositeImage |


GLSysHelp v.2.5: GLS.CompositeImage: Class TGLCompositeImage

Class TGLCompositeImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CompositeImage

Declaration

type TGLCompositeImage = class(TGLTextureImage)

Description

This item has no description. Showing description inherited from TGLTextureImage.

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLCompositeImage

Overview

Fields

Private | FBitmap: TGLBitmap32;
Private | FWidth: integer;
Private | FHeight: integer;
Private | FDepth: integer;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLBitmap32; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure LoadFromStream(const AStream: TStream);
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Published | property Depth: Integer read GetDepth write SetDepth;
Published | property Height: Integer read GetHeight write SetHeight;
Public | property NativeTextureTarget;
Published | property Width: Integer read GetWidth write SetWidth;

Description

Fields

Private FBitmap: TGLBitmap32;

This item has no description.

Private FWidth: integer;

This item has no description.

Private FHeight: integer;

This item has no description.

Private FDepth: integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TGLBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure LoadFromStream(const AStream: TStream);

This item has no description.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when GLScene no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Properties

Published property Depth: Integer read GetDepth write SetDepth;

This item has no description.

Published property Height: Integer read GetHeight write SetHeight;

This item has no description.

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TGLTextureImage.NativeTextureTarget.

Native opengl texture target.

Published property Width: Integer read GetWidth write SetWidth;


GLSysHelp v.2.5: GLS.Console

Unit GLS.Console

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.TypInfo
  • Vcl.Graphics
  • GLScene.VectorTypes
  • GLS.PersistentClasses
  • GLS.Coordinates
  • GLScene.Strings
  • GLS.Scene
  • GLS.Objects
  • GLS.HudObjects
  • GLS.SceneViewer
  • GLS.BitmapFont
  • GLS.Context
  • GLS.ImageUtils
  • GLS.Texture
  • GLScene.Utils
  • GLS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLConsoleException |
Record TGLUserInputCommand |
Class TGLConsoleStringList |
Class TGLConsoleCommand |
Class TGLConsoleCommandList |
Class TGLConsoleControls |
Class TGLCustomConsole |
Class TGLConsole |

Types

TGLConsoleMatchList = set of 0..CONSOLE_MAX_COMMANDS ;
TGLConsoleOption = (...);
TGLConsoleOptions = set of TGLConsoleOption;
TGLlConsoleEvent = procedure(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand) of object;

Constants

CONSOLE_MAX_COMMANDS = 120;

Description

Types

TGLConsoleMatchList = set of 0..CONSOLE_MAX_COMMANDS ;

This item has no description.

TGLConsoleOption = (...);

This item has no description.

Values
  • coAutoCompleteCommandsOnKeyPress
  • coAutoCompleteCommandsOnEnter: commands are auto-completed as user types them
  • coShowConsoleHelpIfUnknownCommand: commands are auto-completed when user presses the "Enter" key
  • coRemoveQuotes: take a wild guess ;)
TGLConsoleOptions = set of TGLConsoleOption;

remove quotes when a command line is parsed

TGLlConsoleEvent = procedure(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand) of object;

Event called when used presses the "Enter"

Constants

CONSOLE_MAX_COMMANDS = 120;


GLSysHelp v.2.5: GLS.Console: Class EGLConsoleException

Class EGLConsoleException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Console

Declaration

type EGLConsoleException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLConsoleException


GLSysHelp v.2.5: GLS.Console: Record TGLUserInputCommand

Record TGLUserInputCommand

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Console

Declaration

type TGLUserInputCommand = record

Description

Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...

Overview

Fields

Public | CommandCount: Integer;
Public | Strings: array of string;
Public | UnknownCommand: Boolean;

Description

Fields

Public CommandCount: Integer;

This item has no description.

Public Strings: array of string;

This item has no description.

Public UnknownCommand: Boolean;


GLSysHelp v.2.5: GLS.Console: Class TGLConsoleStringList

Class TGLConsoleStringList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Console

Declaration

type TGLConsoleStringList = class(TStringList)

Description

A class that checks for duplicates.

Hierarchy

  • TObject
  • TPersistent
  • TStrings
  • TStringList
  • TGLConsoleStringList

Overview

Fields

Private FConsole: TGLCustomConsole;

Methods

Public | constructor Create(const Owner: TGLCustomConsole);
Public | function CommandExists(const Command: string): Boolean;

Description

Fields

Private FConsole: TGLCustomConsole;

This item has no description.

Methods

Public constructor Create(const Owner: TGLCustomConsole);

This item has no description.

Public function CommandExists(const Command: string): Boolean;


GLSysHelp v.2.5: GLS.Console: Class TGLConsoleCommand

Class TGLConsoleCommand

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Console

Declaration

type TGLConsoleCommand = class(TCollectionItem)

Description

A wrapper for a console command.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLConsoleCommand

Overview

Fields

Private | FVisible: Boolean;
Private | FEnabled: Boolean;
Private | FSilentDisabled: Boolean;
Private | FCommandList: TGLConsoleCommandList;
Private | FCommandName: string;
Private | FShortHelp: string;
Private | FLongHelp: TStringList;
Private | FOnCommand: TGLlConsoleEvent;
Private | FOnHelp: TNotifyEvent;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ShowHelp; virtual;
Public | procedure ShowShortHelp; virtual;
Private | procedure SetCommandName(const Value: string);

Properties

Published | property CommandName: string read FCommandName write SetCommandName;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property LongHelp: TStringList read FLongHelp;
Published | property OnCommand: TGLlConsoleEvent read FOnCommand write FOnCommand;
Published | property OnHelp: TNotifyEvent read FOnHelp write FOnHelp;
Published | property ShortHelp: string read FShortHelp write FShortHelp;
Published | property SilentDisabled: Boolean read FSilentDisabled write FSilentDisabled default False;
Published | property Visible: Boolean read FVisible write FVisible default True;

Description

Fields

Private FVisible: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FSilentDisabled: Boolean;

This item has no description.

Private FCommandList: TGLConsoleCommandList;

This item has no description.

Private FCommandName: string;

This item has no description.

Private FShortHelp: string;

This item has no description.

Private FLongHelp: TStringList;

This item has no description.

Private FOnCommand: TGLlConsoleEvent;

This item has no description.

Private FOnHelp: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ShowHelp; virtual;

This item has no description.

Public procedure ShowShortHelp; virtual;

This item has no description.

Private procedure SetCommandName(const Value: string);

This item has no description.

Properties

Published property CommandName: string read FCommandName write SetCommandName;

This item has no description.

Published property Enabled: Boolean read FEnabled write FEnabled default True;

Disabled commands won't execute

Published property LongHelp: TStringList read FLongHelp;

This item has no description.

Published property OnCommand: TGLlConsoleEvent read FOnCommand write FOnCommand;

This item has no description.

Published property OnHelp: TNotifyEvent read FOnHelp write FOnHelp;

This item has no description.

Published property ShortHelp: string read FShortHelp write FShortHelp;

This item has no description.

Published property SilentDisabled: Boolean read FSilentDisabled write FSilentDisabled default False;

If command is disabled and user calls it, no error report will be generated if SilentDisabled is enabled

Published property Visible: Boolean read FVisible write FVisible default True;

Hidden commands won't show when user requests command list or uses auto-complete


GLSysHelp v.2.5: GLS.Console: Class TGLConsoleCommandList

Class TGLConsoleCommandList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Console

Declaration

type TGLConsoleCommandList = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLConsoleCommandList

Overview

Fields

Private FConsole: TGLCustomConsole;

Methods

Public | constructor Create(const AOwner: TGLCustomConsole);
Public | destructor Destroy; override;
Public | function Add: TGLConsoleCommand; overload;
Public | function CommandExists(const Command: string): Boolean;
Public | function GetCommandIndex(const Command: string): Integer;
Public | function LastConsoleCommand: TGLConsoleCommand;
Private | function GetItems(const Index: Integer): TGLConsoleCommand;
Public | procedure SortCommands(const Ascending: Boolean = True);

Properties

Public property Items[const Index: Integer]: TGLConsoleCommand read GetItems;

Description

Fields

Private FConsole: TGLCustomConsole;

This item has no description.

Methods

Public constructor Create(const AOwner: TGLCustomConsole);

Standard stuff

Public destructor Destroy; override;

This item has no description.

Public function Add: TGLConsoleCommand; overload;

This item has no description.

Public function CommandExists(const Command: string): Boolean;

This item has no description.

Public function GetCommandIndex(const Command: string): Integer;

This item has no description.

Public function LastConsoleCommand: TGLConsoleCommand;

General list stuff

Private function GetItems(const Index: Integer): TGLConsoleCommand;

This item has no description.

Public procedure SortCommands(const Ascending: Boolean = True);

This item has no description.

Properties

Public property Items[const Index: Integer]: TGLConsoleCommand read GetItems;


GLSysHelp v.2.5: GLS.Console: Class TGLConsoleControls

Class TGLConsoleControls

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Console

Declaration

type TGLConsoleControls = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLConsoleControls

Overview

Fields

Private | FOwner: TPersistent;
Private | FNavigatePageUp: Byte;
Private | FAutoCompleteCommand: Byte;
Private | FPreviousCommand: Byte;
Private | FNextCommand: Byte;
Private | FNavigateUp: Byte;
Private | FNavigatePageDown: Byte;
Private | FNavigateDown: Byte;
Private | FDblClickDelay: Integer;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property AutoCompleteCommand: Byte read FAutoCompleteCommand write FAutoCompleteCommand default VK_CONTROL;
Published | property DblClickDelay: Integer read FDblClickDelay write FDblClickDelay default 300;
Published | property NavigateDown: Byte read FNavigateDown write FNavigateDown default VK_END;
Published | property NavigatePageDown: Byte read FNavigatePageDown write FNavigatePageDown default VK_NEXT;
Published | property NavigatePageUp: Byte read FNavigatePageUp write FNavigatePageUp default VK_PRIOR;
Published | property NavigateUp: Byte read FNavigateUp write FNavigateUp default VK_HOME;
Published | property NextCommand: Byte read FNextCommand write FNextCommand default VK_DOWN;
Published | property PreviousCommand: Byte read FPreviousCommand write FPreviousCommand default VK_UP;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FNavigatePageUp: Byte;

This item has no description.

Private FAutoCompleteCommand: Byte;

This item has no description.

Private FPreviousCommand: Byte;

This item has no description.

Private FNextCommand: Byte;

This item has no description.

Private FNavigateUp: Byte;

This item has no description.

Private FNavigatePageDown: Byte;

This item has no description.

Private FNavigateDown: Byte;

This item has no description.

Private FDblClickDelay: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property AutoCompleteCommand: Byte read FAutoCompleteCommand write FAutoCompleteCommand default VK_CONTROL;

This item has no description.

Published property DblClickDelay: Integer read FDblClickDelay write FDblClickDelay default 300;

This item has no description.

Published property NavigateDown: Byte read FNavigateDown write FNavigateDown default VK_END;

This item has no description.

Published property NavigatePageDown: Byte read FNavigatePageDown write FNavigatePageDown default VK_NEXT;

This item has no description.

Published property NavigatePageUp: Byte read FNavigatePageUp write FNavigatePageUp default VK_PRIOR;

This item has no description.

Published property NavigateUp: Byte read FNavigateUp write FNavigateUp default VK_HOME;

This item has no description.

Published property NextCommand: Byte read FNextCommand write FNextCommand default VK_DOWN;

This item has no description.

Published property PreviousCommand: Byte read FPreviousCommand write FPreviousCommand default VK_UP;


GLSysHelp v.2.5: GLS.Console: Class TGLCustomConsole

Class TGLCustomConsole

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Console

Declaration

type TGLCustomConsole = class(TGLBaseSceneObject)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomConsole

Overview

Fields

Private | FHudSprite: TGLHudSprite;
Private | FHudText: TGLHudText;
Private | FSceneViewer: TGLSceneViewer;
Private | FInputLine: string;
Private | FStartLine: Integer;
Private | FCurrentCommand: Integer;
Private | FPreviousTickCount: Integer;
Private | FSize: Single;
Private | FColsoleLog: TStringList;
Private | FCommands: TGLConsoleCommandList;
Private | FAdditionalCommands: TGLConsoleStringList;
Private | FTypedCommands: TStringList;
Private | FControls: TGLConsoleControls;
Private | FOnCommandIssued: TGLlConsoleEvent;
Private | FOptions: TGLConsoleOptions;
Private | FHint: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetFont: TGLCustomBitmapFont;
Public | procedure AddLine(const str: string);
Public | procedure ClearTypedCommands;
Public | procedure ExecuteCommand(const Command: string);
Public | procedure ExecuteCommands(const Commands: TStrings);
Public | procedure NavigateDown;
Public | procedure NavigatePageDown;
Public | procedure NavigatePageUp;
Public | procedure NavigateUp;
Public | procedure ProcessKeyDown(const key: word); virtual;
Public | procedure ProcessKeyPress(const c: Char); virtual;
Public | procedure RefreshHudSize; virtual;
Private | procedure SetFont(const Value: TGLCustomBitmapFont);
Private | procedure SetSceneViewer(const Value: TGLSceneViewer);
Private | procedure SetSize(const Value: Single);

Properties

Public | property AdditionalCommands: TGLConsoleStringList read FAdditionalCommands;
Public | property ColsoleLog: TStringList read FColsoleLog;
Public | property Commands: TGLConsoleCommandList read FCommands;
Public | property Controls: TGLConsoleControls read FControls;
Public | property Font: TGLCustomBitmapFont read GetFont write SetFont stored False;
Public | property FontColor: TColor read GetFontColor write SetFontColor stored False;
Public | property Hint: string read FHint write FHint;
Public | property HudSprite: TGLHudSprite read FHudSprite;
Public | property HUDSpriteColor: TColor read GetHUDSpriteColor write SetHUDSpriteColor stored False;
Public | property HudText: TGLHudText read FHudText;
Public | property InputLine: string read FInputLine write FInputLine;
Public | property OnCommandIssued: TGLlConsoleEvent read FOnCommandIssued write FOnCommandIssued;
Public | property Options: TGLConsoleOptions read FOptions write FOptions;
Public | property SceneViewer: TGLSceneViewer read FSceneViewer write SetSceneViewer;
Public | property Size: Single read FSize write SetSize;
Public | property TypedCommands: TStringList read FTypedCommands;
Public | property Visible default False;

Description

Fields

Private FHudSprite: TGLHudSprite;

This item has no description.

Private FHudText: TGLHudText;

This item has no description.

Private FSceneViewer: TGLSceneViewer;

This item has no description.

Private FInputLine: string;

This item has no description.

Private FStartLine: Integer;

This item has no description.

Private FCurrentCommand: Integer;

This item has no description.

Private FPreviousTickCount: Integer;

This item has no description.

Private FSize: Single;

This item has no description.

Private FColsoleLog: TStringList;

This item has no description.

Private FCommands: TGLConsoleCommandList;

This item has no description.

Private FAdditionalCommands: TGLConsoleStringList;

This item has no description.

Private FTypedCommands: TStringList;

This item has no description.

Private FControls: TGLConsoleControls;

This item has no description.

Private FOnCommandIssued: TGLlConsoleEvent;

This item has no description.

Private FOptions: TGLConsoleOptions;

This item has no description.

Private FHint: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetFont: TGLCustomBitmapFont;

This item has no description.

Public procedure AddLine(const str: string);

Adds a line (which is not treated as a command).

Public procedure ClearTypedCommands;

TypedCommands are cleared and current command index is reset.

Public procedure ExecuteCommand(const Command: string);

This item has no description.

Public procedure ExecuteCommands(const Commands: TStrings);

This item has no description.

Public procedure NavigateDown;

This item has no description.

Public procedure NavigatePageDown;

This item has no description.

Public procedure NavigatePageUp;

This item has no description.

Public procedure NavigateUp;

Navigation through code from outside

Public procedure ProcessKeyDown(const key: word); virtual;

This item has no description.

Public procedure ProcessKeyPress(const c: Char); virtual;

Methods: User *must* call these methods in his code.

Public procedure RefreshHudSize; virtual;

Refreshes the size of the hud to reflect changes on the viewer. Should be called whenever the viewer's size changes.

Private procedure SetFont(const Value: TGLCustomBitmapFont);

This item has no description.

Private procedure SetSceneViewer(const Value: TGLSceneViewer);

This item has no description.

Private procedure SetSize(const Value: Single);

This item has no description.

Properties

Public property AdditionalCommands: TGLConsoleStringList read FAdditionalCommands;

Aditional commands can be registered to participate in command auto-completion. They can be interpreted in the global OnCommandIssued event handler.

Public property ColsoleLog: TStringList read FColsoleLog;

List of commands that user typed and console's responces.

Public property Commands: TGLConsoleCommandList read FCommands;

Commands have events that are called when user types a sertauin command

Public property Controls: TGLConsoleControls read FControls;

User controls.

Public property Font: TGLCustomBitmapFont read GetFont write SetFont stored False;

This item has no description.

Public property FontColor: TColor read GetFontColor write SetFontColor stored False;

Changes the console font color.

Public property Hint: string read FHint write FHint;

Standard stuff

Public property HudSprite: TGLHudSprite read FHudSprite;

This item has no description.

Public property HUDSpriteColor: TColor read GetHUDSpriteColor write SetHUDSpriteColor stored False;

This item has no description.

Public property HudText: TGLHudText read FHudText;

This item has no description.

Public property InputLine: string read FInputLine write FInputLine;

Where user enters his commands.

Public property OnCommandIssued: TGLlConsoleEvent read FOnCommandIssued write FOnCommandIssued;

Main event of the console. Happens whenever the enter key is pressed. First the input line is compared to all registered commands, then everything is parsed into a TGLUserInputCommand record and sent to the event. Empty lines are not ignored (i.e. they also trigger events)

Public property Options: TGLConsoleOptions read FOptions write FOptions;

This item has no description.

Public property SceneViewer: TGLSceneViewer read FSceneViewer write SetSceneViewer;

Visual stuff.

Public property Size: Single read FSize write SetSize;

Allows to change consol's height from 0 to 1.

Public property TypedCommands: TStringList read FTypedCommands;

List of commands that user typed.

Public property Visible default False;


GLSysHelp v.2.5: GLS.Console: Class TGLConsole

Class TGLConsole

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Console

Declaration

type TGLConsole = class(TGLCustomConsole)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomConsole
  • TGLConsole

Overview

Properties

Published | property AdditionalCommands;
Published | property ColsoleLog;
Published | property Commands;
Published | property Controls;
Published | property Font;
Published | property FontColor;
Published | property Hint;
Published | property HudSprite;
Published | property HUDSpriteColor;
Published | property HudText;
Published | property InputLine;
Published | property ObjectsSorting;
Published | property OnCommandIssued;
Published | property OnProgress;
Published | property Options;
Published | property SceneViewer;
Published | property Tag;
Published | property TypedCommands;
Published | property Visible;

Description

Properties

Published property AdditionalCommands;

This item has no description. Showing description inherited from TGLCustomConsole.AdditionalCommands.

Aditional commands can be registered to participate in command auto-completion. They can be interpreted in the global OnCommandIssued event handler.

Published property ColsoleLog;

This item has no description. Showing description inherited from TGLCustomConsole.ColsoleLog.

List of commands that user typed and console's responces.

Published property Commands;

This item has no description. Showing description inherited from TGLCustomConsole.Commands.

Commands have events that are called when user types a sertauin command

Published property Controls;

This item has no description. Showing description inherited from TGLCustomConsole.Controls.

User controls.

Published property Font;

This item has no description.

Published property FontColor;

This item has no description. Showing description inherited from TGLCustomConsole.FontColor.

Changes the console font color.

Published property Hint;

This item has no description. Showing description inherited from TGLCustomConsole.Hint.

Standard stuff

Published property HudSprite;

This item has no description.

Published property HUDSpriteColor;

This item has no description.

Published property HudText;

This item has no description.

Published property InputLine;

This item has no description. Showing description inherited from TGLCustomConsole.InputLine.

Where user enters his commands.

Published property ObjectsSorting;

This item has no description.

Published property OnCommandIssued;

This item has no description. Showing description inherited from TGLCustomConsole.OnCommandIssued.

Main event of the console. Happens whenever the enter key is pressed. First the input line is compared to all registered commands, then everything is parsed into a TGLUserInputCommand record and sent to the event. Empty lines are not ignored (i.e. they also trigger events)

Published property OnProgress;

This item has no description.

Published property Options;

This item has no description.

Published property SceneViewer;

This item has no description. Showing description inherited from TGLCustomConsole.SceneViewer.

Visual stuff.

Published property Tag;

This item has no description.

Published property TypedCommands;

This item has no description. Showing description inherited from TGLCustomConsole.TypedCommands.

List of commands that user typed.

Published property Visible;


GLSysHelp v.2.5: GLS.Context

Unit GLS.Context

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.SyncObjs
  • VCL.Forms
  • VCL.Controls
  • VCL.Consts
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLScene.VectorTypes
  • GLScene.TextureFormat
  • GLS.OpenGLAdapter
  • GLScene.PipelineTransform
  • GLS.State
  • GLS.XOpenGL
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TFinishTaskEvent |
Record TServiceContextTask |
Class TGLContext |
Class TGLScreenControlingContext |
Record TGLRCHandle |
Class TGLContextHandle |
Class TGLVirtualHandle |
Class TGLVirtualHandleTransf |
Class TGLListHandle |
Class TGLTextureHandle |
Class TGLSamplerHandle |
Class TGLQueryHandle |
Class TGLOcclusionQueryHandle |
Class TGLBooleanOcclusionQueryHandle |
Class TGLTimerQueryHandle |
Class TGLPrimitiveQueryHandle |
Class TGLBufferObjectHandle |
Class TGLVBOHandle |
Class TGLVBOArrayBufferHandle |
Class TGLVBOElementArrayHandle |
Class TGLPackPBOHandle |
Class TGLUnpackPBOHandle |
Class TGLTransformFeedbackBufferHandle |
Class TGLTextureBufferHandle |
Class TGLUniformBufferHandle |
Class TGLVertexArrayHandle |
Class TGLFramebufferHandle |
Class TGLRenderbufferHandle |
Class TGLARBProgramHandle |
Class TGLARBVertexProgramHandle |
Class TGLARBFragmentProgramHandle |
Class TGLARBGeometryProgramHandle |
Class TGLSLHandle |
Class TGLShaderHandle |
Class TGLVertexShaderHandle |
Class TGLGeometryShaderHandle |
Class TGLFragmentShaderHandle |
Class TGLTessControlShaderHandle |
Class TGLTessEvaluationShaderHandle |
Class TGLProgramHandle |
Record TGLContextNotification |
Class TGLContextManager |
Class EGLContext |
Class EGLShader |
Class EPBuffer |

Functions and Procedures

procedure RegisterGLContextClass(aGLContextClass: TGLContextClass);
function CurrentGLContext: TGLContext; inline;
function SafeCurrentGLContext: TGLContext; inline;
function IsMainThread: Boolean;
function IsServiceContextAvaible: Boolean;
function GetServiceWindow: TForm;

Types

PGLRCHandle = ˆTGLRCHandle;
TGLAntiAliasing = (...);
TGLContextAcceleration = (...);
TGLContextClass = class of TGLContext;
TGLContextLayer = (...);
TGLFramebufferStatus = (...);
TGLRCOption = (...);
TGLRCOptions = set of TGLRCOption;
TGLShaderHandleClass = class of TGLShaderHandle;
TGLVirtualHandleEvent = procedure(Sender: TGLVirtualHandle; var Handle: TGLuint) of object;
TGLVSyncMode = (...);
TOnPrepareHandleData = procedure(aContext: TGLContext) of object;
TTaskProcedure = procedure of object; stdcall;

Constants

MRT_BUFFERS: array [0 .. 3] of TGLuint = (GL_FRONT_LEFT, GL_AUX0, GL_AUX1, GL_AUX2);

Variables

GLContextManager: TGLContextManager;
vIgnoreOpenGLErrors: Boolean = False;
vContextActivationFailureOccurred: Boolean = False;
vCurrentGLContext: TGLContext;
GL: TGLExtensionsAndEntryPoints;
xgl: TGLMultitextureCoordinator;
vMainThread: Boolean;
GLwithoutContext: TGLExtensionsAndEntryPoints;

Description

Functions and Procedures

procedure RegisterGLContextClass(aGLContextClass: TGLContextClass);

Drivers should register themselves via this function.

function CurrentGLContext: TGLContext; inline;

The TGLContext that is the currently active context, if any. Returns nil if no context is active.

function SafeCurrentGLContext: TGLContext; inline;

This item has no description.

function IsMainThread: Boolean;

This item has no description.

function IsServiceContextAvaible: Boolean;

This item has no description.

function GetServiceWindow: TForm;

This item has no description.

Types

PGLRCHandle = ˆTGLRCHandle;

This item has no description.

TGLAntiAliasing = (...);

This item has no description.

Values
  • aaDefault: Multisample Antialiasing
  • aaNone
  • aa2x
  • aa2xHQ
  • aa4x
  • aa4xHQ
  • aa6x
  • aa8x
  • aa16x
  • csa8x: Coverage Sampling Antialiasing
  • csa8xHQ
  • csa16x
  • csa16xHQ
TGLContextAcceleration = (...);

This item has no description.

Values
  • chaUnknown
  • chaHardware
  • chaSoftware
TGLContextClass = class of TGLContext;

This item has no description.

TGLContextLayer = (...);

This item has no description.

Values
  • clUnderlay2
  • clUnderlay1
  • clMainPlane
  • clOverlay1
  • clOverlay2
TGLFramebufferStatus = (...);

This item has no description.

Values
  • fsComplete
  • fsIncompleteAttachment
  • fsIncompleteMissingAttachment
  • fsIncompleteDuplicateAttachment
  • fsIncompleteDimensions
  • fsIncompleteFormats
  • fsIncompleteDrawBuffer
  • fsIncompleteReadBuffer
  • fsUnsupported
  • fsIncompleteMultisample
  • fsStatusError
TGLRCOption = (...);

This item has no description.

Values
  • rcoDoubleBuffered
  • rcoStereo
  • rcoDebug
  • rcoOGL_ES
TGLRCOptions = set of TGLRCOption;

This item has no description.

TGLShaderHandleClass = class of TGLShaderHandle;

This item has no description.

TGLVirtualHandleEvent = procedure(Sender: TGLVirtualHandle; var Handle: TGLuint) of object;

This item has no description.

TGLVSyncMode = (...);

This item has no description.

Values
  • vsmSync
  • vsmNoSync
TOnPrepareHandleData = procedure(aContext: TGLContext) of object;

This item has no description.

TTaskProcedure = procedure of object; stdcall;

This item has no description.

Constants

MRT_BUFFERS: array [0 .. 3] of TGLuint = (GL_FRONT_LEFT, GL_AUX0, GL_AUX1, GL_AUX2);

Buffer ID's for Multiple-Render-Targets (using GL_ATI_draw_buffers)

Variables

GLContextManager: TGLContextManager;

This item has no description.

vIgnoreOpenGLErrors: Boolean = False;

This item has no description.

vContextActivationFailureOccurred: Boolean = False;

This item has no description.

vCurrentGLContext: TGLContext;

This item has no description.

GL: TGLExtensionsAndEntryPoints;

This item has no description.

xgl: TGLMultitextureCoordinator;

This item has no description.

vMainThread: Boolean;

This item has no description.

GLwithoutContext: TGLExtensionsAndEntryPoints;


GLSysHelp v.2.5: GLS.Context: Class TFinishTaskEvent

Class TFinishTaskEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TFinishTaskEvent = class(TEvent)

Description

This item has no description.

Hierarchy

  • TEvent
  • TFinishTaskEvent

Overview

Methods

Public constructor Create; reintroduce;

Description

Methods

Public constructor Create; reintroduce;


GLSysHelp v.2.5: GLS.Context: Record TServiceContextTask

Record TServiceContextTask

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TServiceContextTask = record

Description

This item has no description.

Overview

Fields

Public | Task: TTaskProcedure;
Public | Event: TFinishTaskEvent;

Description

Fields

Public Task: TTaskProcedure;

This item has no description.

Public Event: TFinishTaskEvent;


GLSysHelp v.2.5: GLS.Context: Class TGLContext

Class TGLContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLContext = class(TObject)

Description

Wrapper around an OpenGL rendering context. The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection. This is a virtual abstract a class, and platform-specific subclasses must be used. All rendering context share the same lists

Hierarchy

  • TObject
  • TGLContext

Overview

Fields

Private | FColorBits: Integer;
Private | FAlphaBits: Integer;
Private | FDepthBits: Integer;
Private | FStencilBits: Integer;
Private | FAccumBits: Integer;
Private | FAuxBuffers: Integer;
Private | FAntiAliasing: TGLAntiAliasing;
Private | FOptions: TGLRCOptions;
Private | FOnDestroyContext: TNotifyEvent;
Private | FManager: TGLContextManager;
Private | FActivationCount: Integer;
Private | FOwnedHandlesCount: Integer;
Private | FIsPraparationNeed: Boolean;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function FindCompatibleContext: TGLContext;
Public | function IsValid: Boolean; virtual; abstract;
Public | function RenderOutputDevice: Pointer; virtual; abstract;
Private | function GetActive: Boolean; inline;
Public | procedure Activate;
Public | procedure CreateContext(ADeviceHandle: HDC); overload;
Public | procedure CreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: Integer = 1);
Public | procedure Deactivate;
Public | procedure DestroyAllHandles;
Public | procedure DestroyContext;
Public | procedure PrepareHandlesData;
Public | procedure ShareLists(aContext: TGLContext);
Public | procedure SwapBuffers; virtual; abstract;
Private | procedure SetAcceleration(const val: TGLContextAcceleration); inline;
Private | procedure SetAccumBits(const aAccumBits: Integer); inline;
Private | procedure SetActive(const aActive: Boolean); inline;
Private | procedure SetAlphaBits(const aAlphaBits: Integer); inline;
Private | procedure SetAntiAliasing(const val: TGLAntiAliasing); inline;
Private | procedure SetAuxBuffers(const aAuxBuffers: Integer); inline;
Private | procedure SetColorBits(const aColorBits: Integer); inline;
Private | procedure SetDepthBits(const val: Integer); inline;
Private | procedure SetLayer(const Value: TGLContextLayer); inline;
Private | procedure SetOptions(const aOptions: TGLRCOptions); inline;
Private | procedure SetStencilBits(const aStencilBits: Integer); inline;

Properties

Public | property Acceleration: TGLContextAcceleration read FAcceleration write SetAcceleration;
Public | property AccumBits: Integer read FAccumBits write SetAccumBits;
Public | property Active: Boolean read GetActive write SetActive;
Public | property AlphaBits: Integer read FAlphaBits write SetAlphaBits;
Public | property AntiAliasing: TGLAntiAliasing read FAntiAliasing write SetAntiAliasing;
Public | property AuxBuffers: Integer read FAuxBuffers write SetAuxBuffers;
Public | property ColorBits: Integer read FColorBits write SetColorBits;
Public | property DepthBits: Integer read FDepthBits write SetDepthBits;
Public | property GL: TGLExtensionsAndEntryPoints read Fgl;
Public | property GLStates: TGLStateCache read FGLStates;
Public | property IsPraparationNeed: Boolean read FIsPraparationNeed;
Public | property Layer: TGLContextLayer read FLayer write SetLayer;
Public | property Manager: TGLContextManager read FManager;
Public | property MultitextureCoordinator: TGLMultitextureCoordinator read Fxgl;
Public | property OnDestroyContext: TNotifyEvent read FOnDestroyContext write FOnDestroyContext;
Public | property Options: TGLRCOptions read FOptions write SetOptions;
Public | property PipelineTransformation: TGTransformation read FTransformation;
Public | property StencilBits: Integer read FStencilBits write SetStencilBits;

Description

Fields

Private FColorBits: Integer;

This item has no description.

Private FAlphaBits: Integer;

This item has no description.

Private FDepthBits: Integer;

This item has no description.

Private FStencilBits: Integer;

This item has no description.

Private FAccumBits: Integer;

This item has no description.

Private FAuxBuffers: Integer;

This item has no description.

Private FAntiAliasing: TGLAntiAliasing;

This item has no description.

Private FOptions: TGLRCOptions;

This item has no description.

Private FOnDestroyContext: TNotifyEvent;

This item has no description.

Private FManager: TGLContextManager;

This item has no description.

Private FActivationCount: Integer;

This item has no description.

Private FOwnedHandlesCount: Integer;

This item has no description.

Private FIsPraparationNeed: Boolean;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindCompatibleContext: TGLContext;

Returns the first compatible context that isn't self in the shares

Public function IsValid: Boolean; virtual; abstract;

Returns true if the context is valid. A context is valid from the time it has been successfully created to the time of its destruction.

Public function RenderOutputDevice: Pointer; virtual; abstract;

This item has no description.

Private function GetActive: Boolean; inline;

This item has no description.

Public procedure Activate;

Activates the context. A context can be activated multiple times (and must be deactivated the same number of times), but this function will fail if another context is already active.

Public procedure CreateContext(ADeviceHandle: HDC); overload;

Creates the context. This method must be invoked before the context can be used

Public procedure CreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: Integer = 1);

Creates an in-memory context. The function should fail if no hardware-accelerated memory context can be created (the CreateContext method can handle software OpenGL contexts)

Public procedure Deactivate;

Deactivates the context. Will fail if the context is not active or another context has been activated

Public procedure DestroyAllHandles;

This item has no description.

Public procedure DestroyContext;

Destroy the context. Will fail if no context has been created. The method will first invoke the OnDestroyContext event, then attempts to deactivate the context (if it is active) before destroying it

Public procedure PrepareHandlesData;

Call OnPrepare for all handles

Public procedure ShareLists(aContext: TGLContext);

Setup display list sharing between two rendering contexts. Both contexts must have the same pixel format

Public procedure SwapBuffers; virtual; abstract;

Request to swap front and back buffers if they were defined

Private procedure SetAcceleration(const val: TGLContextAcceleration); inline;

This item has no description.

Private procedure SetAccumBits(const aAccumBits: Integer); inline;

This item has no description.

Private procedure SetActive(const aActive: Boolean); inline;

This item has no description.

Private procedure SetAlphaBits(const aAlphaBits: Integer); inline;

This item has no description.

Private procedure SetAntiAliasing(const val: TGLAntiAliasing); inline;

This item has no description.

Private procedure SetAuxBuffers(const aAuxBuffers: Integer); inline;

This item has no description.

Private procedure SetColorBits(const aColorBits: Integer); inline;

This item has no description.

Private procedure SetDepthBits(const val: Integer); inline;

This item has no description.

Private procedure SetLayer(const Value: TGLContextLayer); inline;

This item has no description.

Private procedure SetOptions(const aOptions: TGLRCOptions); inline;

This item has no description.

Private procedure SetStencilBits(const aStencilBits: Integer); inline;

This item has no description.

Properties

Public property Acceleration: TGLContextAcceleration read FAcceleration write SetAcceleration;

Indicates if the context is hardware-accelerated

Public property AccumBits: Integer read FAccumBits write SetAccumBits;

Accumulation buffer bits for the rendering context

Public property Active: Boolean read GetActive write SetActive;

Allows reading and defining the activity for the context. The methods of this property are just wrappers around calls to Activate and Deactivate

Public property AlphaBits: Integer read FAlphaBits write SetAlphaBits;

Alpha bits for the rendering context

Public property AntiAliasing: TGLAntiAliasing read FAntiAliasing write SetAntiAliasing;

AntiAliasing option. Ignored if not hardware supported, currently based on ARB_multisample

Public property AuxBuffers: Integer read FAuxBuffers write SetAuxBuffers;

Auxiliary buffers bits for the rendering context

Public property ColorBits: Integer read FColorBits write SetColorBits;

Color bits for the rendering context

Public property DepthBits: Integer read FDepthBits write SetDepthBits;

Depth bits for the rendering context

Public property GL: TGLExtensionsAndEntryPoints read Fgl;

Access to OpenGL command and extension

Public property GLStates: TGLStateCache read FGLStates;

An application-side cache of global per-context OpenGL states and parameters

Public property IsPraparationNeed: Boolean read FIsPraparationNeed;

This item has no description.

Public property Layer: TGLContextLayer read FLayer write SetLayer;

Specifies the layer plane that the rendering context is bound to

Public property Manager: TGLContextManager read FManager;

Context manager reference

Public property MultitextureCoordinator: TGLMultitextureCoordinator read Fxgl;

This item has no description.

Public property OnDestroyContext: TNotifyEvent read FOnDestroyContext write FOnDestroyContext;

Triggered whenever the context is destroyed. This events happens *before* the context has been actually destroyed, OpenGL resource cleanup can still occur here

Public property Options: TGLRCOptions read FOptions write SetOptions;

Rendering context options

Public property PipelineTransformation: TGTransformation read FTransformation;

This item has no description.

Public property StencilBits: Integer read FStencilBits write SetStencilBits;

Stencil bits for the rendering context


GLSysHelp v.2.5: GLS.Context: Class TGLScreenControlingContext

Class TGLScreenControlingContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLScreenControlingContext = class(TGLContext)

Description

A TGLContext with screen control property and methods. This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API. TGLSceneViewer won't use them, TGLMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass

Hierarchy

  • TObject
  • TGLContext
  • TGLScreenControlingContext

Overview

Properties

Public | property FullScreen: Boolean read FFullScreen write FFullScreen;
Public | property Height: Integer read FHeight write FHeight;
Public | property Width: Integer read FWidth write FWidth;

Description

Properties

Public property FullScreen: Boolean read FFullScreen write FFullScreen;

This item has no description.

Public property Height: Integer read FHeight write FHeight;

This item has no description.

Public property Width: Integer read FWidth write FWidth;


GLSysHelp v.2.5: GLS.Context: Record TGLRCHandle

Record TGLRCHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLRCHandle = record

Description

This item has no description.

Overview

Fields

Public | FRenderingContext: TGLContext;
Public | FHandle: TGLuint;
Public | FChanged: Boolean;

Description

Fields

Public FRenderingContext: TGLContext;

This item has no description.

Public FHandle: TGLuint;

This item has no description.

Public FChanged: Boolean;


GLSysHelp v.2.5: GLS.Context: Class TGLContextHandle

Class TGLContextHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLContextHandle = class(TObject)

Description

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses

Hierarchy

  • TObject
  • TGLContextHandle

Overview

Fields

Private | FHandles: TList;
Private | FLastHandle: PGLRCHandle;
Private | FOnPrepare: TOnPrepareHandleData;

Methods

Public | constructor Create; virtual;
Public | constructor CreateAndAllocate(failIfAllocationFailed: Boolean = True);
Public | destructor Destroy; override;
Public | function AllocateHandle: TGLuint;
Public | function IsAllocatedForContext(aContext: TGLContext = nil): Boolean;
Public | function IsDataComplitelyUpdated: Boolean;
Public | function IsDataNeedUpdate: Boolean; inline;
Public | function IsShared: Boolean;
Public | class function IsSupported: Boolean; virtual;
Private | function GetContext: TGLContext;
Private | function GetHandle: TGLuint; inline;
Private | function RCItem(AIndex: Integer): PGLRCHandle; inline;
Private | function SearchRC(aContext: TGLContext): PGLRCHandle;
Public | procedure DestroyHandle;
Public | procedure NotifyChangesOfData;
Public | procedure NotifyDataUpdated;
Private | procedure CheckCurrentRC;

Properties

Public | property Handle: TGLuint read GetHandle;
Public | property OnPrapare: TOnPrepareHandleData read FOnPrepare write FOnPrepare;
Public | property RenderingContext: TGLContext read GetContext;

Description

Fields

Private FHandles: TList;

This item has no description.

Private FLastHandle: PGLRCHandle;

This item has no description.

Private FOnPrepare: TOnPrepareHandleData;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public constructor CreateAndAllocate(failIfAllocationFailed: Boolean = True);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AllocateHandle: TGLuint;

This item has no description.

Public function IsAllocatedForContext(aContext: TGLContext = nil): Boolean;

This item has no description.

Public function IsDataComplitelyUpdated: Boolean;

Return True if data updated in all contexts

Public function IsDataNeedUpdate: Boolean; inline;

Return True is data need update in current context

Public function IsShared: Boolean;

This item has no description.

Public class function IsSupported: Boolean; virtual;

Checks if required extensions / OpenGL version are met

Private function GetContext: TGLContext;

This item has no description.

Private function GetHandle: TGLuint; inline;

This item has no description.

Private function RCItem(AIndex: Integer): PGLRCHandle; inline;

This item has no description.

Private function SearchRC(aContext: TGLContext): PGLRCHandle;

This item has no description.

Public procedure DestroyHandle;

This item has no description.

Public procedure NotifyChangesOfData;

Notify the data was changed through all context

Public procedure NotifyDataUpdated;

Notify the data was updated in current context

Private procedure CheckCurrentRC;

This item has no description.

Properties

Public property Handle: TGLuint read GetHandle;

Return OpenGL identifier in current context

Public property OnPrapare: TOnPrepareHandleData read FOnPrepare write FOnPrepare;

This item has no description.

Public property RenderingContext: TGLContext read GetContext;

Return current rendering context if handle is allocated in it or first context where handle is allocated.


GLSysHelp v.2.5: GLS.Context: Class TGLVirtualHandle

Class TGLVirtualHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLVirtualHandle = class(TGLContextHandle)

Description

A context handle with event-based handle allocation and destruction

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLVirtualHandle

Overview

Fields

Private | FOnAllocate: TGLVirtualHandleEvent;
Private | FOnDestroy: TGLVirtualHandleEvent;
Private | FTag: Integer;

Properties

Public | property OnAllocate: TGLVirtualHandleEvent read FOnAllocate write FOnAllocate;
Public | property OnDestroy: TGLVirtualHandleEvent read FOnDestroy write FOnDestroy;
Public | property Tag: Integer read FTag write FTag;

Description

Fields

Private FOnAllocate: TGLVirtualHandleEvent;

This item has no description.

Private FOnDestroy: TGLVirtualHandleEvent;

This item has no description.

Private FTag: Integer;

This item has no description.

Properties

Public property OnAllocate: TGLVirtualHandleEvent read FOnAllocate write FOnAllocate;

This item has no description.

Public property OnDestroy: TGLVirtualHandleEvent read FOnDestroy write FOnDestroy;

This item has no description.

Public property Tag: Integer read FTag write FTag;


GLSysHelp v.2.5: GLS.Context: Class TGLVirtualHandleTransf

Class TGLVirtualHandleTransf

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLVirtualHandleTransf = class(TGLVirtualHandle)

Description

Transferable virtual handle

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLVirtualHandle
  • TGLVirtualHandleTransf


GLSysHelp v.2.5: GLS.Context: Class TGLListHandle

Class TGLListHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLListHandle = class(TGLContextHandle)

Description

Manages a handle to a display list

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLListHandle

Overview

Methods

Public | procedure CallList; inline;
Public | procedure EndList; inline;
Public | procedure NewList(mode: TGLuint); inline;

Description

Methods

Public procedure CallList; inline;

This item has no description.

Public procedure EndList; inline;

This item has no description.

Public procedure NewList(mode: TGLuint); inline;


GLSysHelp v.2.5: GLS.Context: Class TGLTextureHandle

Class TGLTextureHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLTextureHandle = class(TGLContextHandle)

Description

Manages a handle to a texture

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLTextureHandle

Overview

Fields

Private FTarget: TGLTextureTarget;

Methods

Private procedure SetTarget(ATarget: TGLTextureTarget);

Properties

Public property Target: TGLTextureTarget read FTarget write SetTarget;

Description

Fields

Private FTarget: TGLTextureTarget;

This item has no description.

Methods

Private procedure SetTarget(ATarget: TGLTextureTarget);

This item has no description.

Properties

Public property Target: TGLTextureTarget read FTarget write SetTarget;


GLSysHelp v.2.5: GLS.Context: Class TGLSamplerHandle

Class TGLSamplerHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLSamplerHandle = class(TGLContextHandle)

Description

Manages a handle to a sampler

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSamplerHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLQueryHandle

Class TGLQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLQueryHandle = class(TGLContextHandle)

Description

Manages a handle to a query. Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle

Overview

Fields

Private FActive: Boolean;

Methods

Public | function CounterBits: Integer;
Public | function IsResultAvailable: Boolean;
Public | function QueryResultBool: TGLboolean;
Public | function QueryResultInt: TGLint;
Public | function QueryResultInt64: TGLint64EXT;
Public | function QueryResultUInt: TGLUInt;
Public | function QueryResultUInt64: TGLuint64EXT;
Public | procedure BeginQuery;
Public | procedure EndQuery;

Properties

Public | property Active: Boolean read FActive;
Public | property QueryType: TGLQueryType read GetQueryType;
Public | property Target: TGLuint read GetTarget;

Description

Fields

Private FActive: Boolean;

This item has no description.

Methods

Public function CounterBits: Integer;

Number of bits used to store the query result. eg. 32/64 bit

Public function IsResultAvailable: Boolean;

Check if result is available from the query. Result may not be available immediately after ending the query

Public function QueryResultBool: TGLboolean;

This item has no description.

Public function QueryResultInt: TGLint;

Retrieve query result, may cause a stall if the result is not available yet

Public function QueryResultInt64: TGLint64EXT;

This item has no description.

Public function QueryResultUInt: TGLUInt;

This item has no description.

Public function QueryResultUInt64: TGLuint64EXT;

This item has no description.

Public procedure BeginQuery;

This item has no description.

Public procedure EndQuery;

This item has no description.

Properties

Public property Active: Boolean read FActive;

True if within a Begin/EndQuery.

Public property QueryType: TGLQueryType read GetQueryType;

This item has no description.

Public property Target: TGLuint read GetTarget;


GLSysHelp v.2.5: GLS.Context: Class TGLOcclusionQueryHandle

Class TGLOcclusionQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLOcclusionQueryHandle = class(TGLQueryHandle)

Description

Manages a handle to an occlusion query. Requires OpenGL 1.5+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle
  • TGLOcclusionQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function PixelCount: Integer;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public function PixelCount: Integer;

Number of samples (pixels) drawn during the query, some pixels may be drawn to several times in the same query


GLSysHelp v.2.5: GLS.Context: Class TGLBooleanOcclusionQueryHandle

Class TGLBooleanOcclusionQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLBooleanOcclusionQueryHandle = class(TGLQueryHandle)

Description

This item has no description. Showing description inherited from TGLQueryHandle.

Manages a handle to a query. Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle
  • TGLBooleanOcclusionQueryHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLTimerQueryHandle

Class TGLTimerQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLTimerQueryHandle = class(TGLQueryHandle)

Description

Manages a handle to a timer query. Requires GL_EXT_timer_query extension. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle
  • TGLTimerQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function Time: Integer;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public function Time: Integer;

Time, in nanoseconds (1 ns = 10ˆ-9 s) between starting + ending the query. with 32 bit integer can measure up to approximately 4 seconds, use QueryResultUInt64 if you may need longer


GLSysHelp v.2.5: GLS.Context: Class TGLPrimitiveQueryHandle

Class TGLPrimitiveQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLPrimitiveQueryHandle = class(TGLQueryHandle)

Description

Manages a handle to a primitive query. Requires OpenGL 3.0+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle
  • TGLPrimitiveQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function PrimitivesGenerated: Integer;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public function PrimitivesGenerated: Integer;

Number of primitives (eg. Points, Triangles etc.) drawn whilst the query was active


GLSysHelp v.2.5: GLS.Context: Class TGLBufferObjectHandle

Class TGLBufferObjectHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLBufferObjectHandle = class(TGLContextHandle)

Description

Manages a handle to a Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle

Overview

Fields

Private FSize: Integer;

Methods

Public | constructor CreateFromData(p: Pointer; size: Integer; bufferUsage: TGLuint);
Public | class function IsSupported: Boolean; override;
Public | function MapBuffer(access: TGLuint): Pointer;
Public | function MapBufferRange(offset: TGLint; len: TGLsizei; access: TGLbitfield): Pointer;
Public | function UnmapBuffer: Boolean;
Public | procedure Bind; virtual; abstract;
Public | procedure BindBase(index: TGLuint); virtual;
Public | procedure BindBufferData(p: Pointer; size: Integer; bufferUsage: TGLuint);
Public | procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); virtual;
Public | procedure BufferData(p: Pointer; size: Integer; bufferUsage: TGLuint);
Public | procedure BufferSubData(offset, size: Integer; p: Pointer);
Public | procedure Flush(offset: TGLint; len: TGLsizei);
Public | procedure UnBind; virtual; abstract;
Public | procedure UnBindBase(index: TGLuint); virtual;

Properties

Public | property BufferSize: Integer read FSize;
Public | property Target: TGLuint read GetTarget;

Description

Fields

Private FSize: Integer;

This item has no description.

Methods

Public constructor CreateFromData(p: Pointer; size: Integer; bufferUsage: TGLuint);

Creates the buffer object buffer and initializes it.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public function MapBuffer(access: TGLuint): Pointer;

Map buffer content to memory. Values for access are GL_READ_ONLY_ARB, GL_WRITE_ONLY_ARB and GL_READ_WRITE_ARB. Valid only if the buffer has been bound, must be followed by an UnmapBuffer, only one buffer may be mapped at a time.

Public function MapBufferRange(offset: TGLint; len: TGLsizei; access: TGLbitfield): Pointer;

This item has no description.

Public function UnmapBuffer: Boolean;

Unmap buffer content from memory. Must follow a MapBuffer, and happen before the buffer is unbound.

Public procedure Bind; virtual; abstract;

This item has no description.

Public procedure BindBase(index: TGLuint); virtual;

Equivalent to calling BindRange with offset = 0, and size = the size of buffer.

Public procedure BindBufferData(p: Pointer; size: Integer; bufferUsage: TGLuint);

Invokes Bind then BufferData

Public procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); virtual;

Bind a buffer object to an indexed target, used by transform feedback buffer objects and uniform buffer objects. (OpenGL 3.0+)

Public procedure BufferData(p: Pointer; size: Integer; bufferUsage: TGLuint);

Specifies buffer content. Common bufferUsage values are GL_STATIC_DRAW_ARB for data that will change rarely, but be used often, GL_STREAM_DRAW_ARB for data specified once but used only a few times, and GL_DYNAMIC_DRAW_ARB for data that is re-specified very often. Valid only if the buffer has been bound.

Public procedure BufferSubData(offset, size: Integer; p: Pointer);

Updates part of an already existing buffer. offset and size indicate which part of the data in the buffer is to bo modified and p where the data should be taken from.

Public procedure Flush(offset: TGLint; len: TGLsizei);

This item has no description.

Public procedure UnBind; virtual; abstract;

Note that it is not necessary to UnBind before Binding another buffer.

Public procedure UnBindBase(index: TGLuint); virtual;

This item has no description.

Properties

Public property BufferSize: Integer read FSize;

This item has no description.

Public property Target: TGLuint read GetTarget;


GLSysHelp v.2.5: GLS.Context: Class TGLVBOHandle

Class TGLVBOHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLVBOHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to an Vertex Buffer Object, VBO. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLVBOHandle

Overview

Methods

Private function GetVBOTarget: TGLuint;

Properties

Public property VBOTarget: TGLuint read GetVBOTarget;

Description

Methods

Private function GetVBOTarget: TGLuint;

This item has no description.

Properties

Public property VBOTarget: TGLuint read GetVBOTarget;


GLSysHelp v.2.5: GLS.Context: Class TGLVBOArrayBufferHandle

Class TGLVBOArrayBufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLVBOArrayBufferHandle = class(TGLVBOHandle)

Description

Manages a handle to VBO Array Buffer. Typically used to store vertices, normals, texcoords, etc.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLVBOHandle
  • TGLVBOArrayBufferHandle

Overview

Methods

Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GLSysHelp v.2.5: GLS.Context: Class TGLVBOElementArrayHandle

Class TGLVBOElementArrayHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLVBOElementArrayHandle = class(TGLVBOHandle)

Description

Manages a handle to VBO Element Array Buffer. Typically used to store vertex indices.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLVBOHandle
  • TGLVBOElementArrayHandle

Overview

Methods

Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GLSysHelp v.2.5: GLS.Context: Class TGLPackPBOHandle

Class TGLPackPBOHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLPackPBOHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to PBO Pixel Pack Buffer. When bound, commands such as ReadPixels write their data into a buffer object.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLPackPBOHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GLSysHelp v.2.5: GLS.Context: Class TGLUnpackPBOHandle

Class TGLUnpackPBOHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLUnpackPBOHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to PBO Pixel Unpack Buffer. When bound, commands such as DrawPixels read their data from a buffer object

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLUnpackPBOHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GLSysHelp v.2.5: GLS.Context: Class TGLTransformFeedbackBufferHandle

Class TGLTransformFeedbackBufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLTransformFeedbackBufferHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to a Transform Feedback Buffer Object. Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLTransformFeedbackBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure BeginTransformFeedback(primitiveMode: TGLuint);
Public | procedure Bind; override;
Public | procedure BindBase(index: TGLuint); override;
Public | procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); override;
Public | procedure EndTransformFeedback();
Public | procedure UnBind; override;
Public | procedure UnBindBase(index: TGLuint); override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure BeginTransformFeedback(primitiveMode: TGLuint);

This item has no description.

Public procedure Bind; override;

This item has no description.

Public procedure BindBase(index: TGLuint); override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.BindBase.

Equivalent to calling BindRange with offset = 0, and size = the size of buffer.

Public procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.BindRange.

Bind a buffer object to an indexed target, used by transform feedback buffer objects and uniform buffer objects. (OpenGL 3.0+)

Public procedure EndTransformFeedback();

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.

Public procedure UnBindBase(index: TGLuint); override;


GLSysHelp v.2.5: GLS.Context: Class TGLTextureBufferHandle

Class TGLTextureBufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLTextureBufferHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to a Buffer Texture. (TBO)

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLTextureBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GLSysHelp v.2.5: GLS.Context: Class TGLUniformBufferHandle

Class TGLUniformBufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLUniformBufferHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLUniformBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind; override;
Public | procedure BindBase(index: TGLuint); override;
Public | procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); override;
Public | procedure UnBind; override;
Public | procedure UnBindBase(index: TGLuint); override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind; override;

This item has no description.

Public procedure BindBase(index: TGLuint); override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.BindBase.

Equivalent to calling BindRange with offset = 0, and size = the size of buffer.

Public procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.BindRange.

Bind a buffer object to an indexed target, used by transform feedback buffer objects and uniform buffer objects. (OpenGL 3.0+)

Public procedure UnBind; override;

This item has no description. Showing description inherited from TGLBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.

Public procedure UnBindBase(index: TGLuint); override;


GLSysHelp v.2.5: GLS.Context: Class TGLVertexArrayHandle

Class TGLVertexArrayHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLVertexArrayHandle = class(TGLContextHandle)

Description

Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLVertexArrayHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind;
Public | procedure UnBind;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind;

This item has no description.

Public procedure UnBind;


GLSysHelp v.2.5: GLS.Context: Class TGLFramebufferHandle

Class TGLFramebufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLFramebufferHandle = class(TGLContextHandle)

Description

Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLFramebufferHandle

Overview

Methods

Public | function GetAttachmentObjectName(Target: TGLuint; attachment: TGLuint): TGLint;
Public | function GetAttachmentObjectType(Target: TGLuint; attachment: TGLuint): TGLint;
Public | function GetAttachmentParameter(Target: TGLuint; attachment: TGLuint; pname: TGLuint): TGLint;
Public | function GetStatus: TGLFramebufferStatus;
Public | function GetStringStatus(out clarification: string): TGLFramebufferStatus;
Public | class function IsSupported: Boolean; override;
Public | procedure Attach1DTexture(Target: TGLuint; attachment: TGLuint; textarget: TGLuint; texture: TGLuint; level: TGLint);
Public | procedure Attach2DTexture(Target: TGLuint; attachment: TGLuint; textarget: TGLuint; texture: TGLuint; level: TGLint);
Public | procedure Attach3DTexture(Target: TGLuint; attachment: TGLuint; textarget: TGLuint; texture: TGLuint; level: TGLint; Layer: TGLint);
Public | procedure AttachLayer(Target: TGLuint; attachment: TGLuint; texture: TGLuint; level: TGLint; Layer: TGLint);
Public | procedure AttachRenderBuffer(Target: TGLuint; attachment: TGLuint; renderbuffertarget: TGLuint; renderbuffer: TGLuint);
Public | procedure AttachTexture(Target: TGLuint; attachment: TGLuint; texture: TGLuint; level: TGLint);
Public | procedure AttachTextureLayer(Target: TGLuint; attachment: TGLuint; texture: TGLuint; level: TGLint; Layer: TGLint);
Public | procedure Bind;
Public | procedure BindForDrawing;
Public | procedure BindForReading;
Public | procedure Blit(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: TGLuint);
Public | procedure UnBind;
Public | procedure UnBindForDrawing;
Public | procedure UnBindForReading;

Description

Methods

Public function GetAttachmentObjectName(Target: TGLuint; attachment: TGLuint): TGLint;

Returns the name (ID) of the texture or renderbuffer attached to attachment point

Public function GetAttachmentObjectType(Target: TGLuint; attachment: TGLuint): TGLint;

Returns the type of object bound to attachment point: GL_NONE, GL_FRAMEBUFFER_DEFAULT, GL_TEXTURE, or GL_RENDERBUFFER

Public function GetAttachmentParameter(Target: TGLuint; attachment: TGLuint; pname: TGLuint): TGLint;

target = GL_DRAW_FRAMEBUFFER, GL_READ_FRAMEBUFFER, GL_FRAMEBUFFER (equivalent to GL_DRAW_FRAMEBUFFER) If default framebuffer (0) is bound: attachment = GL_FRONT_LEFT, GL_FRONT_RIGHT, GL_BACK_LEFT, or GL_BACK_RIGHT, GL_DEPTH, GL_STENCIL if a framebuffer object is bound: attachment = GL_COLOR_ATTACHMENTi, GL_DEPTH_ATTACHMENT, GL_STENCIL_ATTACHMENT, GL_DEPTH_STENCIL_ATTACHMENT param = GL_FRAMEBUFFER_ATTACHMENT_(OBJECT_TYPE, OBJECT_NAME, RED_SIZE, GREEN_SIZE, BLUE_SIZE, ALPHA_SIZE, DEPTH_SIZE, STENCIL_SIZE, COMPONENT_TYPE, COLOR_ENCODING, TEXTURE_LEVEL, LAYERED, TEXTURE_CUBE_MAP_FACE, TEXTURE_LAYER

Public function GetStatus: TGLFramebufferStatus;

This item has no description.

Public function GetStringStatus(out clarification: string): TGLFramebufferStatus;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Attach1DTexture(Target: TGLuint; attachment: TGLuint; textarget: TGLuint; texture: TGLuint; level: TGLint);

target = GL_DRAW_FRAMEBUFFER, GL_READ_FRAMEBUFFER, GL_FRAMEBUFFER (attach to both READ + DRAW) attachment = COLOR_ATTACHMENTi, DEPTH_ATTACHMENT, STENCIL_ATTACHMENT, DEPTH_STENCIL_ATTACHMENT

Public procedure Attach2DTexture(Target: TGLuint; attachment: TGLuint; textarget: TGLuint; texture: TGLuint; level: TGLint);

This item has no description.

Public procedure Attach3DTexture(Target: TGLuint; attachment: TGLuint; textarget: TGLuint; texture: TGLuint; level: TGLint; Layer: TGLint);

This item has no description.

Public procedure AttachLayer(Target: TGLuint; attachment: TGLuint; texture: TGLuint; level: TGLint; Layer: TGLint);

This item has no description.

Public procedure AttachRenderBuffer(Target: TGLuint; attachment: TGLuint; renderbuffertarget: TGLuint; renderbuffer: TGLuint);

This item has no description.

Public procedure AttachTexture(Target: TGLuint; attachment: TGLuint; texture: TGLuint; level: TGLint);

OpenGL 3.2+ only. If texture is the name of a three-dimensional texture, cube map texture, one-or two-dimensional array texture, or two-dimensional multisample array texture, the texture level attached to the framebuffer attachment point is an array of images, and the framebuffer attachment is considered layered

Public procedure AttachTextureLayer(Target: TGLuint; attachment: TGLuint; texture: TGLuint; level: TGLint; Layer: TGLint);

OpenGL 3.2+ only

Public procedure Bind;

Bind framebuffer for both drawing + reading

Public procedure BindForDrawing;

Bind framebuffer for drawing

Public procedure BindForReading;

Bind framebuffer for reading

Public procedure Blit(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: TGLuint);

copy rect from bound read framebuffer to bound draw framebuffer

Public procedure UnBind;

Note that it is not necessary to unbind before binding another framebuffer.

Public procedure UnBindForDrawing;

This item has no description.

Public procedure UnBindForReading;


GLSysHelp v.2.5: GLS.Context: Class TGLRenderbufferHandle

Class TGLRenderbufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLRenderbufferHandle = class(TGLContextHandle)

Description

Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLRenderbufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind;
Public | procedure SetStorage(internalformat: TGLuint; width, height: TGLsizei);
Public | procedure SetStorageMultisample(internalformat: TGLuint; samples: TGLsizei; width, height: TGLsizei);
Public | procedure UnBind;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind;

This item has no description.

Public procedure SetStorage(internalformat: TGLuint; width, height: TGLsizei);

This item has no description.

Public procedure SetStorageMultisample(internalformat: TGLuint; samples: TGLsizei; width, height: TGLsizei);

This item has no description.

Public procedure UnBind;


GLSysHelp v.2.5: GLS.Context: Class TGLARBProgramHandle

Class TGLARBProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLARBProgramHandle = class(TGLContextHandle)

Description

This item has no description. Showing description inherited from TGLContextHandle.

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLARBProgramHandle

Overview

Fields

Private | FReady: Boolean;
Private | FInfoLog: string;

Methods

Public | procedure Bind;
Public | procedure Disable;
Public | procedure Enable;
Public | procedure LoadARBProgram(const AText: string);

Properties

Public | property InfoLog: string read FInfoLog;
Public | property Ready: Boolean read FReady;

Description

Fields

Private FReady: Boolean;

This item has no description.

Private FInfoLog: string;

This item has no description.

Methods

Public procedure Bind;

This item has no description.

Public procedure Disable;

This item has no description.

Public procedure Enable;

This item has no description.

Public procedure LoadARBProgram(const AText: string);

This item has no description.

Properties

Public property InfoLog: string read FInfoLog;

This item has no description.

Public property Ready: Boolean read FReady;


GLSysHelp v.2.5: GLS.Context: Class TGLARBVertexProgramHandle

Class TGLARBVertexProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLARBVertexProgramHandle = class(TGLARBProgramHandle)

Description

This item has no description. Showing description inherited from TGLContextHandle.

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLARBProgramHandle
  • TGLARBVertexProgramHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLARBFragmentProgramHandle

Class TGLARBFragmentProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLARBFragmentProgramHandle = class(TGLARBProgramHandle)

Description

This item has no description. Showing description inherited from TGLContextHandle.

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLARBProgramHandle
  • TGLARBFragmentProgramHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLARBGeometryProgramHandle

Class TGLARBGeometryProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLARBGeometryProgramHandle = class(TGLARBProgramHandle)

Description

This item has no description. Showing description inherited from TGLContextHandle.

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLARBProgramHandle
  • TGLARBGeometryProgramHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLSLHandle

Class TGLSLHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLSLHandle = class(TGLContextHandle)

Description

Base class for GLSL handles (programs and shaders). Do not use this class directly, use one of its subclasses instead

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle

Overview

Methods

Public | function InfoLog: string;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public function InfoLog: string;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLShaderHandle

Class TGLShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLShaderHandle = class(TGLSLHandle)

Description

Manages a handle to a Shader Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle

Overview

Fields

Private FShaderType: TGLuint;

Methods

Public | function CompileShader: Boolean;
Public | procedure ShaderSource(const source: AnsiString); overload;

Properties

Public property ShaderType: TGLuint read FShaderType;

Description

Fields

Private FShaderType: TGLuint;

This item has no description.

Methods

Public function CompileShader: Boolean;

Returns True if compilation sucessful

Public procedure ShaderSource(const source: AnsiString); overload;

This item has no description.

Properties

Public property ShaderType: TGLuint read FShaderType;


GLSysHelp v.2.5: GLS.Context: Class TGLVertexShaderHandle

Class TGLVertexShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLVertexShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Vertex Shader Object

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLVertexShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLGeometryShaderHandle

Class TGLGeometryShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLGeometryShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Geometry Shader Object

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLGeometryShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLFragmentShaderHandle

Class TGLFragmentShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLFragmentShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Fragment Shader Object

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLFragmentShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLTessControlShaderHandle

Class TGLTessControlShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLTessControlShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Tessellation Control Shader Object

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLTessControlShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLTessEvaluationShaderHandle

Class TGLTessEvaluationShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLTessEvaluationShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Tessellation Evaluation Shader Object

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLTessEvaluationShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TGLContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GLSysHelp v.2.5: GLS.Context: Class TGLProgramHandle

Class TGLProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLProgramHandle = class(TGLSLHandle)

Description

Manages a GLSL Program Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLProgramHandle

Overview

Fields

Private FName: string;

Methods

Public | constructor Create; override;
Public | function GetAttribLocation(const aName: string): Integer;
Public | function GetUniformBlockIndex(const aName: string): Integer;
Public | function GetUniformBufferSize(const aName: string): Integer;
Public | function GetUniformLocation(const aName: string): Integer;
Public | function GetUniformOffset(const aName: string): PGLInt;
Public | function GetVaryingLocation(const aName: string): Integer;
Public | class function IsValid(const ID: TGLuint): Boolean; override;
Public | function LinkProgram: Boolean;
Public | function ValidateProgram: Boolean;
Private | function GetUniform1f(const index: string): Single;
Private | function GetUniform1i(const index: string): Integer;
Private | function GetUniform2f(const index: string): TVector2f;
Private | function GetUniform2i(const index: string): TVector2i;
Private | function GetUniform3f(const index: string): TAffineVector;
Private | function GetUniform3i(const index: string): TVector3i;
Private | function GetUniform4f(const index: string): TGLVector;
Private | function GetUniform4i(const index: string): TVector4i;
Private | function GetUniformMatrix2fv(const index: string): TMatrix2f;
Private | function GetUniformMatrix3fv(const index: string): TMatrix3f;
Private | function GetUniformMatrix4fv(const index: string): TGLMatrix;
Private | function GetUniformTextureHandle(const Index: string; const TextureIndex: Integer; const TextureTarget: TGLTextureTarget) : TGLuint;
Public | procedure AddActiveVarying(const aName: string);
Public | procedure AddShader(ShaderType: TGLShaderHandleClass; const ShaderSource: string; treatWarningsAsErrors: Boolean = False);
Public | procedure AttachObject(shader: TGLShaderHandle);
Public | procedure BindAttribLocation(index: Integer; const aName: string);
Public | procedure BindFragDataLocation(index: Integer; const aName: string);
Public | procedure DetachAllObject;
Public | procedure EndUseProgramObject;
Public | procedure SetUniformf(const index: string; const val: TVector3f); overload;
Public | procedure SetUniformf(const index: string; const val: TVector4f); overload;
Public | procedure SetUniformf(const index: string; const val: TVector2f); overload;
Public | procedure SetUniformf(const index: string; const val: Single); overload;
Public | procedure SetUniformi(const index: string; const val: TVector2i); overload;
Public | procedure SetUniformi(const index: string; const val: Integer); overload;
Public | procedure SetUniformi(const index: string; const val: TVector4i); overload;
Public | procedure SetUniformi(const index: string; const val: TVector3i); overload;
Public | procedure UseProgramObject;
Private | procedure SetUniform1f(const index: string; val: Single);
Private | procedure SetUniform1i(const index: string; val: Integer);
Private | procedure SetUniform2f(const index: string; const val: TVector2f);
Private | procedure SetUniform2i(const index: string; const Value: TVector2i);
Private | procedure SetUniform3f(const index: string; const val: TAffineVector);
Private | procedure SetUniform3i(const index: string; const Value: TVector3i);
Private | procedure SetUniform4f(const index: string; const val: TGLVector);
Private | procedure SetUniform4i(const index: string; const Value: TVector4i);
Private | procedure SetUniformBuffer(const Index: string; Value: TGLUniformBufferHandle);
Private | procedure SetUniformMatrix2fv(const index: string; const val: TMatrix2f);
Private | procedure SetUniformMatrix3fv(const index: string; const val: TMatrix3f);
Private | procedure SetUniformMatrix4fv(const index: string; const val: TGLMatrix);
Private | procedure SetUniformTextureHandle(const Index: string; const TextureIndex: Integer; const TextureTarget: TGLTextureTarget; const Value: TGLuint);

Properties

Public | property Name: string read FName write FName;
Public | property Uniform1f[const index: string]: Single read GetUniform1f write SetUniform1f;
Public | property Uniform1i[const index: string]: Integer read GetUniform1i write SetUniform1i;
Public | property Uniform2f[const index: string]: TVector2f read GetUniform2f write SetUniform2f;
Public | property Uniform2i[const index: string]: TVector2i read GetUniform2i write SetUniform2i;
Public | property Uniform3f[const index: string]: TAffineVector read GetUniform3f write SetUniform3f;
Public | property Uniform3i[const index: string]: TVector3i read GetUniform3i write SetUniform3i;
Public | property Uniform4f[const index: string]: TGLVector read GetUniform4f write SetUniform4f;
Public | property Uniform4i[const index: string]: TVector4i read GetUniform4i write SetUniform4i;
Public | property UniformBuffer[const index: string]: TGLUniformBufferHandle write SetUniformBuffer;
Public | property UniformMatrix2fv[const index: string]: TMatrix2f read GetUniformMatrix2fv write SetUniformMatrix2fv;
Public | property UniformMatrix3fv[const index: string]: TMatrix3f read GetUniformMatrix3fv write SetUniformMatrix3fv;
Public | property UniformMatrix4fv[const index: string]: TGLMatrix read GetUniformMatrix4fv write SetUniformMatrix4fv;
Public | property UniformTextureHandle[const index: string; const TextureIndex: Integer; const TextureTarget: TGLTextureTarget]: TGLuint read GetUniformTextureHandle write SetUniformTextureHandle;

Description

Fields

Private FName: string;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public function GetAttribLocation(const aName: string): Integer;

This item has no description.

Public function GetUniformBlockIndex(const aName: string): Integer;

This item has no description.

Public function GetUniformBufferSize(const aName: string): Integer;

Currently, NVidia-specific.

Public function GetUniformLocation(const aName: string): Integer;

This item has no description.

Public function GetUniformOffset(const aName: string): PGLInt;

This item has no description.

Public function GetVaryingLocation(const aName: string): Integer;

This item has no description.

Public class function IsValid(const ID: TGLuint): Boolean; override;

This item has no description.

Public function LinkProgram: Boolean;

This item has no description.

Public function ValidateProgram: Boolean;

This item has no description.

Private function GetUniform1f(const index: string): Single;

This item has no description.

Private function GetUniform1i(const index: string): Integer;

This item has no description.

Private function GetUniform2f(const index: string): TVector2f;

This item has no description.

Private function GetUniform2i(const index: string): TVector2i;

This item has no description.

Private function GetUniform3f(const index: string): TAffineVector;

This item has no description.

Private function GetUniform3i(const index: string): TVector3i;

This item has no description.

Private function GetUniform4f(const index: string): TGLVector;

This item has no description.

Private function GetUniform4i(const index: string): TVector4i;

This item has no description.

Private function GetUniformMatrix2fv(const index: string): TMatrix2f;

This item has no description.

Private function GetUniformMatrix3fv(const index: string): TMatrix3f;

This item has no description.

Private function GetUniformMatrix4fv(const index: string): TGLMatrix;

This item has no description.

Private function GetUniformTextureHandle(const Index: string; const TextureIndex: Integer; const TextureTarget: TGLTextureTarget) : TGLuint;

This item has no description.

Public procedure AddActiveVarying(const aName: string);

Currently, NVidia-specific.

Public procedure AddShader(ShaderType: TGLShaderHandleClass; const ShaderSource: string; treatWarningsAsErrors: Boolean = False);

Compile and attach a new shader. Raises an EGLShader exception in case of failure.

Public procedure AttachObject(shader: TGLShaderHandle);

This item has no description.

Public procedure BindAttribLocation(index: Integer; const aName: string);

This item has no description.

Public procedure BindFragDataLocation(index: Integer; const aName: string);

This item has no description.

Public procedure DetachAllObject;

This item has no description.

Public procedure EndUseProgramObject;

This item has no description.

Public procedure SetUniformf(const index: string; const val: TVector3f); overload;

This item has no description.

Public procedure SetUniformf(const index: string; const val: TVector4f); overload;

This item has no description.

Public procedure SetUniformf(const index: string; const val: TVector2f); overload;

This item has no description.

Public procedure SetUniformf(const index: string; const val: Single); overload;

This item has no description.

Public procedure SetUniformi(const index: string; const val: TVector2i); overload;

This item has no description.

Public procedure SetUniformi(const index: string; const val: Integer); overload;

This item has no description.

Public procedure SetUniformi(const index: string; const val: TVector4i); overload;

This item has no description.

Public procedure SetUniformi(const index: string; const val: TVector3i); overload;

This item has no description.

Public procedure UseProgramObject;

This item has no description.

Private procedure SetUniform1f(const index: string; val: Single);

This item has no description.

Private procedure SetUniform1i(const index: string; val: Integer);

This item has no description.

Private procedure SetUniform2f(const index: string; const val: TVector2f);

This item has no description.

Private procedure SetUniform2i(const index: string; const Value: TVector2i);

This item has no description.

Private procedure SetUniform3f(const index: string; const val: TAffineVector);

This item has no description.

Private procedure SetUniform3i(const index: string; const Value: TVector3i);

This item has no description.

Private procedure SetUniform4f(const index: string; const val: TGLVector);

This item has no description.

Private procedure SetUniform4i(const index: string; const Value: TVector4i);

This item has no description.

Private procedure SetUniformBuffer(const Index: string; Value: TGLUniformBufferHandle);

This item has no description.

Private procedure SetUniformMatrix2fv(const index: string; const val: TMatrix2f);

This item has no description.

Private procedure SetUniformMatrix3fv(const index: string; const val: TMatrix3f);

This item has no description.

Private procedure SetUniformMatrix4fv(const index: string; const val: TGLMatrix);

This item has no description.

Private procedure SetUniformTextureHandle(const Index: string; const TextureIndex: Integer; const TextureTarget: TGLTextureTarget; const Value: TGLuint);

This item has no description.

Properties

Public property Name: string read FName write FName;

This item has no description.

Public property Uniform1f[const index: string]: Single read GetUniform1f write SetUniform1f;

This item has no description.

Public property Uniform1i[const index: string]: Integer read GetUniform1i write SetUniform1i;

Shader parameters.

Public property Uniform2f[const index: string]: TVector2f read GetUniform2f write SetUniform2f;

This item has no description.

Public property Uniform2i[const index: string]: TVector2i read GetUniform2i write SetUniform2i;

This item has no description.

Public property Uniform3f[const index: string]: TAffineVector read GetUniform3f write SetUniform3f;

This item has no description.

Public property Uniform3i[const index: string]: TVector3i read GetUniform3i write SetUniform3i;

This item has no description.

Public property Uniform4f[const index: string]: TGLVector read GetUniform4f write SetUniform4f;

This item has no description.

Public property Uniform4i[const index: string]: TVector4i read GetUniform4i write SetUniform4i;

This item has no description.

Public property UniformBuffer[const index: string]: TGLUniformBufferHandle write SetUniformBuffer;

This item has no description.

Public property UniformMatrix2fv[const index: string]: TMatrix2f read GetUniformMatrix2fv write SetUniformMatrix2fv;

This item has no description.

Public property UniformMatrix3fv[const index: string]: TMatrix3f read GetUniformMatrix3fv write SetUniformMatrix3fv;

This item has no description.

Public property UniformMatrix4fv[const index: string]: TGLMatrix read GetUniformMatrix4fv write SetUniformMatrix4fv;

This item has no description.

Public property UniformTextureHandle[const index: string; const TextureIndex: Integer; const TextureTarget: TGLTextureTarget]: TGLuint read GetUniformTextureHandle write SetUniformTextureHandle;


GLSysHelp v.2.5: GLS.Context: Record TGLContextNotification

Record TGLContextNotification

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLContextNotification = record

Description

This item has no description.

Overview

Fields

Public | obj: TObject;
Public | Event: TNotifyEvent;

Description

Fields

Public obj: TObject;

This item has no description.

Public Event: TNotifyEvent;


GLSysHelp v.2.5: GLS.Context: Class TGLContextManager

Class TGLContextManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type TGLContextManager = class(TObject)

Description

Stores and manages all the TGLContext objects.

Hierarchy

  • TObject
  • TGLContextManager

Overview

Fields

Private | FList: TThreadList;
Private | FTerminated: Boolean;
Private | FNotifications: array of TGLContextNotification;
Private | FCreatedRCCount: Integer;
Private | FHandles: TList;
Private | FServiceContext: TGLContext;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function ContextCount: Integer;
Public | function CreateContext(AClass: TGLContextClass = nil): TGLContext;
Public | procedure DestroyAllHandles;
Public | procedure LastContextDestroyNotification(anObject: TObject; anEvent: TNotifyEvent);
Public | procedure NotifyPreparationNeed;
Public | procedure RemoveNotification(anObject: TObject);
Public | procedure Terminate;

Description

Fields

Private FList: TThreadList;

This item has no description.

Private FTerminated: Boolean;

This item has no description.

Private FNotifications: array of TGLContextNotification;

This item has no description.

Private FCreatedRCCount: Integer;

This item has no description.

Private FHandles: TList;

This item has no description.

Private FServiceContext: TGLContext;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ContextCount: Integer;

Returns the number of TGLContext object. This is *not* the number of OpenGL rendering contexts!

Public function CreateContext(AClass: TGLContextClass = nil): TGLContext;

Returns an appropriate, ready-to use context. The returned context should be freed by caller.

Public procedure DestroyAllHandles;

Request all contexts to destroy all their handles.

Public procedure LastContextDestroyNotification(anObject: TObject; anEvent: TNotifyEvent);

Registers a new object to notify when the last context is destroyed. When the last rendering context is destroyed, the 'anEvent' will be invoked with 'anObject' as parameter. Note that the registration is kept until the notification is triggered or a RemoveNotification on 'anObject' is issued.

Public procedure NotifyPreparationNeed;

Notify all contexts about necessity of handles preparation.

Public procedure RemoveNotification(anObject: TObject);

Unregisters an object from the notification lists.

Public procedure Terminate;

Marks the context manager for termination


GLSysHelp v.2.5: GLS.Context: Class EGLContext

Class EGLContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type EGLContext = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLContext


GLSysHelp v.2.5: GLS.Context: Class EGLShader

Class EGLShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type EGLShader = class(EGLContext)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLContext
  • EGLShader


GLSysHelp v.2.5: GLS.Context: Class EPBuffer

Class EPBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Context

Declaration

type EPBuffer = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EPBuffer


GLSysHelp v.2.5: GLS.CUDA.APIComps

Unit GLS.CUDA.APIComps

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Types
  • System.Classes
  • System.SysUtils
  • GLS.PersistentClasses
  • GLS.BaseClasses
  • GLS.Context
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.VectorLists
  • GLS.Graphics
  • GLScene.Strings
  • GLScene.Utils
  • GLS.CUDA.Compiler
  • GLS.CUDA.Context
  • CUDA.Import
  • CUDA.RunTime
  • CUDA.Parser
  • CUDA.FourierTransform
  • CUDA.DataAccess

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TChannelTypeAndNum |
Class TCUDAComponent |
Class TCUDAModule |
Class TCUDAGraphicResource |
Class TCUDAMemData |
Class TCUDAUniform |
Class TCUDAConstant |
Class TCUDAFuncParam |
Class TCUDAFunction |
Class TCUDATexture |
Class TGLCUDA |

Functions and Procedures

function GetChannelTypeAndNum(AType: TCUDAType): TChannelTypeAndNum;
procedure RegisterCUDAComponentNameChangeEvent(ANotifyEvent: TNotifyEvent);
procedure DeRegisterCUDAComponentNameChangeEvent;

Types

TCuAddresMode = (...);
TCUDAChange = (...);
TCUDAChanges = set of TCUDAChange;
TCUDAChannelNum = (...);
TCUDAChannelType = (...);
TCUDAComponentClass = class of TCUDAComponent;
TCUDAMapping = (...);
TCUDAMemMapFlag = (...);
TCUDAMemMapFlags = set of TCUDAMemMapFlag;
TCUDAMemType = (...);
TCuFilterMode = (...);
TGLResourceType = (...);

Description

Functions and Procedures

function GetChannelTypeAndNum(AType: TCUDAType): TChannelTypeAndNum;

This item has no description.

procedure RegisterCUDAComponentNameChangeEvent(ANotifyEvent: TNotifyEvent);

This item has no description.

procedure DeRegisterCUDAComponentNameChangeEvent;

This item has no description.

Types

TCuAddresMode = (...);

This item has no description.

Values
  • amWrap
  • amClamp
  • amMirror
TCUDAChange = (...);

This item has no description.

Values
  • cuchDevice
  • cuchContext
  • cuchSize
  • cuchAddresMode
  • cuchFlag
  • cuchFilterMode
  • cuchArray
  • cuchFormat
  • cuchMapping
TCUDAChanges = set of TCUDAChange;

This item has no description.

TCUDAChannelNum = (...);

This item has no description.

Values
  • cnOne
  • cnTwo
  • cnThree
  • cnFour
TCUDAChannelType = (...);

This item has no description.

Values
  • ctUndefined
  • ctUInt8
  • ctUInt16
  • ctUInt32
  • ctInt8
  • ctInt16
  • ctInt32
  • ctHalfFloat
  • ctFloat
  • ctDouble
TCUDAComponentClass = class of TCUDAComponent;

This item has no description.

TCUDAMapping = (...);

This item has no description.

Values
  • grmDefault
  • grmReadOnly
  • grmWriteDiscard
TCUDAMemMapFlag = (...);

This item has no description.

Values
  • mmfPortable
  • mmfFastWrite: Memory is shared between contexts
TCUDAMemMapFlags = set of TCUDAMemMapFlag;

Fast write, slow read

TCUDAMemType = (...);

This item has no description.

Values
  • mtHost
  • mtDevice
  • mtArray
TCuFilterMode = (...);

This item has no description.

Values
  • fmPoint
  • fmLinear
TGLResourceType = (...);

This item has no description.

Values
  • rtTexture
  • rtBuffer


GLSysHelp v.2.5: GLS.CUDA.APIComps: Record TChannelTypeAndNum

Record TChannelTypeAndNum

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TChannelTypeAndNum = record

Description

This item has no description.

Overview

Fields

Public | F: TCUDAChannelType;
Public | C: TCUDAChannelNum;

Description

Fields

Public F: TCUDAChannelType;

This item has no description.

Public C: TCUDAChannelNum;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDAComponent

Class TCUDAComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDAComponent = class(TCUDAHandlesMaster)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent

Overview

Fields

Private | FMaster: TCUDAComponent;
Private | FItems: TGLPersistentObjectList;

Methods

Public | destructor Destroy; override;
Public | function GetItemByName(const name: string): TCUDAComponent;
Public | function GetParentComponent: TComponent; override;
Public | function HasParent: Boolean; override;
Public | function MakeUniqueName(const BaseName: string): string;
Private | function GetItem(const i: Integer): TCUDAComponent;
Private | function GetItemsCount: Integer;
Public | procedure CuNotifyChange(AChange: TCUDAChange); virtual;
Public | procedure SetParentComponent(Value: TComponent); override;
Private | procedure SetMaster(AMaster: TCUDAComponent);

Properties

Public | property Context: TCUDAContext read GetContext;
Public | property IsAllocated: Boolean read GetIsAllocated;
Public | property Items[const i: Integer]: TCUDAComponent read GetItem;
Public | property ItemsCount: Integer read GetItemsCount;
Public | property Master: TCUDAComponent read FMaster write SetMaster;
Public | property Status: TCUresult read FStatus;

Description

Fields

Private FMaster: TCUDAComponent;

This item has no description.

Private FItems: TGLPersistentObjectList;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function GetItemByName(const name: string): TCUDAComponent;

This item has no description.

Public function GetParentComponent: TComponent; override;

This item has no description.

Public function HasParent: Boolean; override;

This item has no description.

Public function MakeUniqueName(const BaseName: string): string;

This item has no description.

Private function GetItem(const i: Integer): TCUDAComponent;

This item has no description.

Private function GetItemsCount: Integer;

This item has no description.

Public procedure CuNotifyChange(AChange: TCUDAChange); virtual;

This item has no description.

Public procedure SetParentComponent(Value: TComponent); override;

This item has no description.

Private procedure SetMaster(AMaster: TCUDAComponent);

This item has no description.

Properties

Public property Context: TCUDAContext read GetContext;

This item has no description.

Public property IsAllocated: Boolean read GetIsAllocated;

Return true if handle is allocated (i.e. component has device object)

Public property Items[const i: Integer]: TCUDAComponent read GetItem;

This item has no description.

Public property ItemsCount: Integer read GetItemsCount;

This item has no description.

Public property Master: TCUDAComponent read FMaster write SetMaster;

This item has no description.

Public property Status: TCUresult read FStatus;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDAModule

Class TCUDAModule

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDAModule = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAModule

Overview

Fields

Private | FHandle: PCUmodule;
Private | FCode: TStringList;
Private | FCodeType: TGLCUDACompilerOutput;
Private | FCompiler: TGLCUDACompiler;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetKernelConstant(const AName: string): TCUDAConstant;
Private | function GetKernelFunction(const AName: string): TCUDAFunction;
Private | function GetKernelTexture(const AName: string): TCUDATexture;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadAndCompile;
Public | procedure LoadFromFile(const AFilename: string);
Public | procedure LoadFromSource;
Public | procedure Unload;
Private | procedure SetCode(const Value: TStringList);
Private | procedure SetCompiler(const Value: TGLCUDACompiler);

Properties

Published | property Code: TStringList read FCode write SetCode;
Public | property CodeType: TGLCUDACompilerOutput read FCodeType;
Published | property Compiler: TGLCUDACompiler read FCompiler write SetCompiler;
Public | property Context: TCUDAContext read GetContext;
Public | property KernelConstant[const AName: string]: TCUDAConstant read GetKernelConstant;
Public | property KernelFunction[const AName: string]: TCUDAFunction read GetKernelFunction;
Public | property KernelTexture[const AName: string]: TCUDATexture read GetKernelTexture;

Description

Fields

Private FHandle: PCUmodule;

This item has no description.

Private FCode: TStringList;

This item has no description.

Private FCodeType: TGLCUDACompilerOutput;

This item has no description.

Private FCompiler: TGLCUDACompiler;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetKernelConstant(const AName: string): TCUDAConstant;

This item has no description.

Private function GetKernelFunction(const AName: string): TCUDAFunction;

This item has no description.

Private function GetKernelTexture(const AName: string): TCUDATexture;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadAndCompile;

This item has no description.

Public procedure LoadFromFile(const AFilename: string);

This item has no description.

Public procedure LoadFromSource;

This item has no description.

Public procedure Unload;

This item has no description.

Private procedure SetCode(const Value: TStringList);

This item has no description.

Private procedure SetCompiler(const Value: TGLCUDACompiler);

This item has no description.

Properties

Published property Code: TStringList read FCode write SetCode;

This item has no description.

Public property CodeType: TGLCUDACompilerOutput read FCodeType;

This item has no description.

Published property Compiler: TGLCUDACompiler read FCompiler write SetCompiler;

This item has no description.

Public property Context: TCUDAContext read GetContext;

This item has no description.

Public property KernelConstant[const AName: string]: TCUDAConstant read GetKernelConstant;

This item has no description.

Public property KernelFunction[const AName: string]: TCUDAFunction read GetKernelFunction;

This item has no description.

Public property KernelTexture[const AName: string]: TCUDATexture read GetKernelTexture;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDAGraphicResource

Class TCUDAGraphicResource

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDAGraphicResource = class(TCUDAComponent)

Description

Abstract class of graphic resources.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource

Overview

Methods

Public | procedure MapResources; virtual; abstract;
Public | procedure UnMapResources; virtual; abstract;

Description

Methods

Public procedure MapResources; virtual; abstract;

This item has no description.

Public procedure UnMapResources; virtual; abstract;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDAMemData

Class TCUDAMemData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDAMemData = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAMemData

Overview

Fields

Private | FData: TCUdeviceptr;
Private | FMappedMemory: TCUdeviceptr;
Private | FHandle: PCUarray;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FDepth: Integer;
Private | FPitch: Cardinal;
Private | FElementSize: Integer;
Private | FDataSize: Integer;
Private | FChannelsType: TCUDAChannelType;
Private | fChannelsNum: TCUDAChannelNum;
Private | FMemoryType: TCUDAMemType;
Private | FTexture: TCUDATexture;
Private | FOpenGLRefArray: Boolean;
Private | FMapping: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Data<EType>(X, Y, Z: Integer): GCUDAHostElementAccess<EType>; overload;
Public | function Data<EType>(X, Y: Integer): GCUDAHostElementAccess<EType>; overload;
Public | function Data<EType>(X: Integer): GCUDAHostElementAccess<EType>; overload;
Private | function GetArrayHandle: PCUarray;
Private | function GetData: TCUdeviceptr;
Public | procedure CopyFrom(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;
Public | procedure CopyFrom(const AGLImage: TGLBitmap32); overload;
Public | procedure CopyFrom(const ASrcMemData: TCUDAMemData); overload;
Public | procedure CopyTo(const ADstMemData: TCUDAMemData); overload;
Public | procedure CopyTo(const AGLImage: TGLImage); overload;
Public | procedure CopyTo(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;
Public | procedure CuNotifyChange(AChange: TCUDAChange); override;
Public | procedure FillMem(const Value);
Public | procedure Map(const AFlags: TCUDAMemMapFlags = []);
Public | procedure SubCopyTo(const ADstMemData: TCUDAMemData; ASrcXYZ, ADstXYZ, ASizes: IntElement.TVector3);
Public | procedure UnMap;
Private | procedure SetChannelNum(const Value: TCUDAChannelNum);
Private | procedure SetChannelType(const Value: TCUDAChannelType);
Private | procedure SetDepth(const Value: Integer);
Private | procedure SetHeight(const Value: Integer);
Private | procedure SetMemoryType(const AType: TCUDAMemType);
Private | procedure SetWidth(const Value: Integer);

Properties

Public | property ArrayHandle: PCUarray read GetArrayHandle;
Published | property ChannelsNum: TCUDAChannelNum read fChannelsNum write SetChannelNum default cnOne;
Published | property ChannelsType: TCUDAChannelType read fChannelsType write SetChannelType default ctInt8;
Public | property DataSize: Integer read FDataSize;
Published | property Depth: Integer read fDepth write SetDepth default 0;
Public | property ElementSize: Integer read FElementSize;
Published | property Height: Integer read fHeight write SetHeight default 0;
Public | property MappedMemoryAddress: TCUdeviceptr read FMappedMemory;
Published | property MemoryType: TCUDAMemType read FMemoryType write SetMemoryType default mtHost;
Public | property Pitch: Cardinal read fPitch;
Public | property RawData: TCUdeviceptr read GetData;
Published | property Width: Integer read fWidth write SetWidth default 256;

Description

Fields

Private FData: TCUdeviceptr;

This item has no description.

Private FMappedMemory: TCUdeviceptr;

This item has no description.

Private FHandle: PCUarray;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FDepth: Integer;

This item has no description.

Private FPitch: Cardinal;

This item has no description.

Private FElementSize: Integer;

This item has no description.

Private FDataSize: Integer;

This item has no description.

Private FChannelsType: TCUDAChannelType;

This item has no description.

Private fChannelsNum: TCUDAChannelNum;

This item has no description.

Private FMemoryType: TCUDAMemType;

This item has no description.

Private FTexture: TCUDATexture;

This item has no description.

Private FOpenGLRefArray: Boolean;

This item has no description.

Private FMapping: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Data<EType>(X, Y, Z: Integer): GCUDAHostElementAccess<EType>; overload;

This item has no description.

Public function Data<EType>(X, Y: Integer): GCUDAHostElementAccess<EType>; overload;

This item has no description.

Public function Data<EType>(X: Integer): GCUDAHostElementAccess<EType>; overload;

This item has no description.

Private function GetArrayHandle: PCUarray;

This item has no description.

Private function GetData: TCUdeviceptr;

This item has no description.

Public procedure CopyFrom(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;

This item has no description.

Public procedure CopyFrom(const AGLImage: TGLBitmap32); overload;

This item has no description.

Public procedure CopyFrom(const ASrcMemData: TCUDAMemData); overload;

This item has no description.

Public procedure CopyTo(const ADstMemData: TCUDAMemData); overload;

This item has no description.

Public procedure CopyTo(const AGLImage: TGLImage); overload;

This item has no description.

Public procedure CopyTo(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;

Copy data to Graphic resource.

Public procedure CuNotifyChange(AChange: TCUDAChange); override;

This item has no description.

Public procedure FillMem(const Value);

Fill device data

Public procedure Map(const AFlags: TCUDAMemMapFlags = []);

Map device and array memory to host or host memory to device. Mapping is necessary for modifying device data. When mapped host memory - it can be accessed in device side via MappedHostAddress.

Public procedure SubCopyTo(const ADstMemData: TCUDAMemData; ASrcXYZ, ADstXYZ, ASizes: IntElement.TVector3);

This item has no description.

Public procedure UnMap;

Done mapping operation.

Private procedure SetChannelNum(const Value: TCUDAChannelNum);

This item has no description.

Private procedure SetChannelType(const Value: TCUDAChannelType);

This item has no description.

Private procedure SetDepth(const Value: Integer);

This item has no description.

Private procedure SetHeight(const Value: Integer);

This item has no description.

Private procedure SetMemoryType(const AType: TCUDAMemType);

This item has no description.

Private procedure SetWidth(const Value: Integer);

This item has no description.

Properties

Public property ArrayHandle: PCUarray read GetArrayHandle;

This item has no description.

Published property ChannelsNum: TCUDAChannelNum read fChannelsNum write SetChannelNum default cnOne;

This item has no description.

Published property ChannelsType: TCUDAChannelType read fChannelsType write SetChannelType default ctInt8;

This item has no description.

Public property DataSize: Integer read FDataSize;

This item has no description.

Published property Depth: Integer read fDepth write SetDepth default 0;

This item has no description.

Public property ElementSize: Integer read FElementSize;

This item has no description.

Published property Height: Integer read fHeight write SetHeight default 0;

This item has no description.

Public property MappedMemoryAddress: TCUdeviceptr read FMappedMemory;

This item has no description.

Published property MemoryType: TCUDAMemType read FMemoryType write SetMemoryType default mtHost;

This item has no description.

Public property Pitch: Cardinal read fPitch;

This item has no description.

Public property RawData: TCUdeviceptr read GetData;

This item has no description.

Published property Width: Integer read fWidth write SetWidth default 256;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDAUniform

Class TCUDAUniform

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDAUniform = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Public property IsValueDefined: Boolean read FDefined write SetDefined;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Public property IsValueDefined: Boolean read FDefined write SetDefined;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDAConstant

Class TCUDAConstant

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDAConstant = class(TCUDAUniform)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform
  • TCUDAConstant

Overview

Properties

Published | property CustomType;
Published | property DataType;
Public | property DeviceAddress: TCUdeviceptr read GetDeviceAddress;
Published | property KernelName;
Published | property Reference;
Published | property Size;

Description

Properties

Published property CustomType;

This item has no description.

Published property DataType;

This item has no description.

Public property DeviceAddress: TCUdeviceptr read GetDeviceAddress;

This item has no description.

Published property KernelName;

This item has no description.

Published property Reference;

This item has no description.

Published property Size;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDAFuncParam

Class TCUDAFuncParam

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDAFuncParam = class(TCUDAUniform)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform
  • TCUDAFuncParam

Overview

Methods

Public constructor Create(AOwner: TComponent); override;

Properties

Published | property CustomType;
Published | property DataType;
Published | property KernelName;
Published | property Reference;
Published | property Size;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Properties

Published property CustomType;

This item has no description.

Published property DataType;

This item has no description.

Published property KernelName;

This item has no description.

Published property Reference;

This item has no description.

Published property Size;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDAFunction

Class TCUDAFunction

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDAFunction = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAFunction

Overview

Fields

Private | FKernelName: string;
Private | FHandle: PCUfunction;
Private | FAutoSync: Boolean;
Private | FBlockShape: TCUDADimensions;
Private | FGrid: TCUDADimensions;
Private | ParamOffset: Integer;
Private | FLaunching: Boolean;
Private | FOnParameterSetup: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetConstMemorySize: Integer;
Private | function GetHandle: PCUfunction;
Private | function GetLocalMemorySize: Integer;
Private | function GetMaxThreadPerBlock: Integer;
Private | function GetNumRegisters: Integer;
Private | function GetParameter(const AName: string): TCUDAFuncParam;
Private | function GetSharedMemorySize: Integer;
Public | procedure Launch(Grided: Boolean = true);
Public | procedure SetParam(Value: TVector3f); overload;
Public | procedure SetParam(Value: TVector2f); overload;
Public | procedure SetParam(Value: TVector4i); overload;
Public | procedure SetParam(Value: TVector4f); overload;
Public | procedure SetParam(Ptr: Pointer); overload;
Public | procedure SetParam(TexRef: TCUDATexture); overload;
Public | procedure SetParam(MemData: TCUDAMemData); overload;
Public | procedure SetParam(Value: TVector3i); overload;
Public | procedure SetParam(Value: Cardinal); overload;
Public | procedure SetParam(Value: Integer); overload;
Public | procedure SetParam(Value: TVector2i); overload;
Public | procedure SetParam(Value: Single); overload;
Private | procedure SetBlockShape(const AShape: TCUDADimensions);
Private | procedure SetGrid(const AGrid: TCUDADimensions);
Private | procedure SetKernelName(const AName: string);
Private | procedure SetSharedMemorySize(Value: Integer);

Properties

Published | property AutoSync: Boolean read FAutoSync write FAutoSync default true;
Published | property BlockShape: TCUDADimensions read FBlockShape write SetBlockShape;
Public | property ConstMemorySize: Integer read GetConstMemorySize;
Published | property Grid: TCUDADimensions read FGrid write SetGrid;
Public | property Handle: PCUfunction read GetHandle;
Published | property KernelName: string read FKernelName write SetKernelName;
Public | property LocalMemorySize: Integer read GetLocalMemorySize;
Public | property MaxThreadPerBlock: Integer read GetMaxThreadPerBlock;
Public | property NumRegisters: Integer read GetNumRegisters;
Published | property OnParameterSetup: TNotifyEvent read FOnParameterSetup write FOnParameterSetup;
Public | property Parameters[const AName: string]: TCUDAFuncParam read GetParameter;
Public | property SharedMemorySize: Integer read GetSharedMemorySize write SetSharedMemorySize;

Description

Fields

Private FKernelName: string;

This item has no description.

Private FHandle: PCUfunction;

This item has no description.

Private FAutoSync: Boolean;

This item has no description.

Private FBlockShape: TCUDADimensions;

This item has no description.

Private FGrid: TCUDADimensions;

This item has no description.

Private ParamOffset: Integer;

This item has no description.

Private FLaunching: Boolean;

This item has no description.

Private FOnParameterSetup: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetConstMemorySize: Integer;

This item has no description.

Private function GetHandle: PCUfunction;

This item has no description.

Private function GetLocalMemorySize: Integer;

This item has no description.

Private function GetMaxThreadPerBlock: Integer;

This item has no description.

Private function GetNumRegisters: Integer;

This item has no description.

Private function GetParameter(const AName: string): TCUDAFuncParam;

This item has no description.

Private function GetSharedMemorySize: Integer;

This item has no description.

Public procedure Launch(Grided: Boolean = true);

This item has no description.

Public procedure SetParam(Value: TVector3f); overload;

This item has no description.

Public procedure SetParam(Value: TVector2f); overload;

This item has no description.

Public procedure SetParam(Value: TVector4i); overload;

This item has no description.

Public procedure SetParam(Value: TVector4f); overload;

This item has no description.

Public procedure SetParam(Ptr: Pointer); overload;

This item has no description.

Public procedure SetParam(TexRef: TCUDATexture); overload;

This item has no description.

Public procedure SetParam(MemData: TCUDAMemData); overload;

This item has no description.

Public procedure SetParam(Value: TVector3i); overload;

This item has no description.

Public procedure SetParam(Value: Cardinal); overload;

This item has no description.

Public procedure SetParam(Value: Integer); overload;

This item has no description.

Public procedure SetParam(Value: TVector2i); overload;

This item has no description.

Public procedure SetParam(Value: Single); overload;

This item has no description.

Private procedure SetBlockShape(const AShape: TCUDADimensions);

This item has no description.

Private procedure SetGrid(const AGrid: TCUDADimensions);

This item has no description.

Private procedure SetKernelName(const AName: string);

This item has no description.

Private procedure SetSharedMemorySize(Value: Integer);

This item has no description.

Properties

Published property AutoSync: Boolean read FAutoSync write FAutoSync default true;

This item has no description.

Published property BlockShape: TCUDADimensions read FBlockShape write SetBlockShape;

This item has no description.

Public property ConstMemorySize: Integer read GetConstMemorySize;

This item has no description.

Published property Grid: TCUDADimensions read FGrid write SetGrid;

This item has no description.

Public property Handle: PCUfunction read GetHandle;

This item has no description.

Published property KernelName: string read FKernelName write SetKernelName;

This item has no description.

Public property LocalMemorySize: Integer read GetLocalMemorySize;

This item has no description.

Public property MaxThreadPerBlock: Integer read GetMaxThreadPerBlock;

This item has no description.

Public property NumRegisters: Integer read GetNumRegisters;

This item has no description.

Published property OnParameterSetup: TNotifyEvent read FOnParameterSetup write FOnParameterSetup;

This item has no description.

Public property Parameters[const AName: string]: TCUDAFuncParam read GetParameter;

This item has no description.

Public property SharedMemorySize: Integer read GetSharedMemorySize write SetSharedMemorySize;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TCUDATexture

Class TCUDATexture

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TCUDATexture = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDATexture

Overview

Fields

Private | FKernelName: string;
Private | FHandle: PCUtexref;
Private | fArray: TCUDAMemData;
Private | fAddressModeS: TCuAddresMode;
Private | fAddressModeT: TCuAddresMode;
Private | fAddressModeR: TCuAddresMode;
Private | fNormalizedCoord: Boolean;
Private | fReadAsInteger: Boolean;
Private | fFilterMode: TCuFilterMode;
Private | fFormat: TCUDAChannelType;
Private | fChannelNum: TCUDAChannelNum;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetHandle: PCUtexref;
Private | procedure SetAddressModeR(const AMode: TCuAddresMode);
Private | procedure SetAddressModeS(const AMode: TCuAddresMode);
Private | procedure SetAddressModeT(const AMode: TCuAddresMode);
Private | procedure SetArray(Value: TCUDAMemData);
Private | procedure SetChannelNum(AValue: TCUDAChannelNum);
Private | procedure SetFilterMode(const mode: TCuFilterMode);
Private | procedure SetFormat(AValue: TCUDAChannelType);
Private | procedure SetKernelName(const AName: string);
Private | procedure SetNormalizedCoord(const flag: Boolean);
Private | procedure SetReadAsInteger(const flag: Boolean);

Properties

Published | property AddressModeR: TCuAddresMode read fAddressModeR write SetAddressModeR default amClamp;
Published | property AddressModeS: TCuAddresMode read fAddressModeS write SetAddressModeS default amClamp;
Published | property AddressModeT: TCuAddresMode read fAddressModeT write SetAddressModeT default amClamp;
Published | property ChannelNum: TCUDAChannelNum read fChannelNum write SetChannelNum;
Published | property FilterMode: TCuFilterMode read fFilterMode write SetFilterMode default fmPoint;
Published | property Format: TCUDAChannelType read fFormat write SetFormat;
Public | property Handle: PCUtexref read GetHandle;
Published | property KernelName: string read FKernelName write SetKernelName;
Published | property MemDataArray: TCUDAMemData read fArray write SetArray;
Published | property NormalizedCoord: Boolean read fNormalizedCoord write SetNormalizedCoord default true;
Published | property ReadAsInteger: Boolean read fReadAsInteger write SetReadAsInteger default false;

Description

Fields

Private FKernelName: string;

This item has no description.

Private FHandle: PCUtexref;

This item has no description.

Private fArray: TCUDAMemData;

This item has no description.

Private fAddressModeS: TCuAddresMode;

This item has no description.

Private fAddressModeT: TCuAddresMode;

This item has no description.

Private fAddressModeR: TCuAddresMode;

This item has no description.

Private fNormalizedCoord: Boolean;

This item has no description.

Private fReadAsInteger: Boolean;

This item has no description.

Private fFilterMode: TCuFilterMode;

This item has no description.

Private fFormat: TCUDAChannelType;

This item has no description.

Private fChannelNum: TCUDAChannelNum;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetHandle: PCUtexref;

This item has no description.

Private procedure SetAddressModeR(const AMode: TCuAddresMode);

This item has no description.

Private procedure SetAddressModeS(const AMode: TCuAddresMode);

This item has no description.

Private procedure SetAddressModeT(const AMode: TCuAddresMode);

This item has no description.

Private procedure SetArray(Value: TCUDAMemData);

This item has no description.

Private procedure SetChannelNum(AValue: TCUDAChannelNum);

This item has no description.

Private procedure SetFilterMode(const mode: TCuFilterMode);

This item has no description.

Private procedure SetFormat(AValue: TCUDAChannelType);

This item has no description.

Private procedure SetKernelName(const AName: string);

This item has no description.

Private procedure SetNormalizedCoord(const flag: Boolean);

This item has no description.

Private procedure SetReadAsInteger(const flag: Boolean);

This item has no description.

Properties

Published property AddressModeR: TCuAddresMode read fAddressModeR write SetAddressModeR default amClamp;

This item has no description.

Published property AddressModeS: TCuAddresMode read fAddressModeS write SetAddressModeS default amClamp;

This item has no description.

Published property AddressModeT: TCuAddresMode read fAddressModeT write SetAddressModeT default amClamp;

This item has no description.

Published property ChannelNum: TCUDAChannelNum read fChannelNum write SetChannelNum;

This item has no description.

Published property FilterMode: TCuFilterMode read fFilterMode write SetFilterMode default fmPoint;

This item has no description.

Published property Format: TCUDAChannelType read fFormat write SetFormat;

This item has no description.

Public property Handle: PCUtexref read GetHandle;

This item has no description.

Published property KernelName: string read FKernelName write SetKernelName;

This item has no description.

Published property MemDataArray: TCUDAMemData read fArray write SetArray;

This item has no description.

Published property NormalizedCoord: Boolean read fNormalizedCoord write SetNormalizedCoord default true;

This item has no description.

Published property ReadAsInteger: Boolean read fReadAsInteger write SetReadAsInteger default false;


GLSysHelp v.2.5: GLS.CUDA.APIComps: Class TGLCUDA

Class TGLCUDA

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.APIComps

Declaration

type TGLCUDA = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TGLCUDA

Overview

Fields

Private | fDevice: TGLCUDADevice;
Private | fContext: TCUDAContext;
Private | FOnOpenGLInteropInit: TOnOpenGLInteropInit;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetModule(const i: Integer): TCUDAModule;
Private | procedure SetDevice(const Value: TGLCUDADevice);
Private | procedure SetOnOpenGLInteropInit(AEvent: TOnOpenGLInteropInit);

Properties

Published | property ComputingDevice: TGLCUDADevice read fDevice write SetDevice;
Public | property Context: TCUDAContext read GetContext;
Public | property Modules[const i: Integer]: TCUDAModule read GetModule;
Published | property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write SetOnOpenGLInteropInit;

Description

Fields

Private fDevice: TGLCUDADevice;

This item has no description.

Private fContext: TCUDAContext;

This item has no description.

Private FOnOpenGLInteropInit: TOnOpenGLInteropInit;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetModule(const i: Integer): TCUDAModule;

This item has no description.

Private procedure SetDevice(const Value: TGLCUDADevice);

This item has no description.

Private procedure SetOnOpenGLInteropInit(AEvent: TOnOpenGLInteropInit);

This item has no description.

Properties

Published property ComputingDevice: TGLCUDADevice read fDevice write SetDevice;

This item has no description.

Public property Context: TCUDAContext read GetContext;

This item has no description.

Public property Modules[const i: Integer]: TCUDAModule read GetModule;

This item has no description.

Published property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write SetOnOpenGLInteropInit;


GLSysHelp v.2.5: GLS.CUDA.Compiler

Unit GLS.CUDA.Compiler

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.ShellAPI
  • Winapi.TlHelp32
  • System.UITypes
  • System.SysUtils
  • System.Classes
  • Vcl.Forms
  • GLS.ApplicationFileIO
  • CUDA.Parser

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCUDACompiler |

Types

TFindCuFileFunc = function(var AModuleName: string): Boolean;
TGLCUDACompilerOutput = (...);
TGLCUDARealArch = (...);
TGLCUDARealArchs = set of TGLCUDARealArch;
TGLCUDAVirtArch = (...);

Variables

vFindCuFileFunc: TFindCuFileFunc;

Description

Types

TFindCuFileFunc = function(var AModuleName: string): Boolean;

This item has no description.

TGLCUDACompilerOutput = (...);

VCL.Dialogs,

Values
  • codeUndefined
  • codePtx
  • codeCubin
  • codeGpu
TGLCUDARealArch = (...);

sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown

Values
  • sm_10
  • sm_11
  • sm_12
  • sm_13
  • sm_20
  • sm_21
TGLCUDARealArchs = set of TGLCUDARealArch;

This item has no description.

TGLCUDAVirtArch = (...);

compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support

Values
  • compute_10
  • compute_11
  • compute_12
  • compute_13
  • compute_20

Variables

vFindCuFileFunc: TFindCuFileFunc;


GLSysHelp v.2.5: GLS.CUDA.Compiler: Class TGLCUDACompiler

Class TGLCUDACompiler

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Compiler

Declaration

type TGLCUDACompiler = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLCUDACompiler

Overview

Fields

Private | FNVCCPath: string;
Private | FCppCompilerPath: string;
Private | FProduct: TStringList;
Private | FProjectModule: string;
Private | FSourceCodeFile: string;
Private | FConsoleContent: string;
Private | FOutputCodeType: TGLCUDACompilerOutput;
Private | FVirtualArch: TGLCUDAVirtArch;
Private | FRealArch: TGLCUDARealArchs;
Private | FMaxRegisterCount: Integer;
Private | FModuleInfo: TCUDAModuleInfo;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Compile: Boolean;
Private | function StoreProjectModule: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetSourceCodeFile(const AFileName: string);
Private | procedure SetCppCompilerPath(const AValue: string);
Private | procedure SetMaxRegisterCount(Value: Integer);
Private | procedure SetNVCCPath(const AValue: string);
Private | procedure SetOutputCodeType(const Value: TGLCUDACompilerOutput);
Private | procedure SetRealArch(AValue: TGLCUDARealArchs);

Properties

Public | property ConsoleContent: string read FConsoleContent;
Published | property CppCompilerPath: string read FCppCompilerPath write SetCppCompilerPath;
Published | property MaxRegisterCount: Integer read FMaxRegisterCount write SetMaxRegisterCount default 32;
Public | property ModuleInfo: TCUDAModuleInfo read FModuleInfo;
Published | property NVCCPath: string read FNVCCPath write SetNVCCPath;
Published | property OutputCodeType: TGLCUDACompilerOutput read FOutputCodeType write setOutputCodeType default codePtx;
Public | property Product: TStringList read FProduct write FProduct;
Published | property ProjectModule: string read FProjectModule write FProjectModule stored StoreProjectModule;
Published | property RealArchitecture: TGLCUDARealArchs read FRealArch write SetRealArch default [sm_13];
Published | property SourceCodeFile: string read FSourceCodeFile;
Published | property VirtualArchitecture: TGLCUDAVirtArch read FVirtualArch write FVirtualArch default compute_13;

Description

Fields

Private FNVCCPath: string;

This item has no description.

Private FCppCompilerPath: string;

This item has no description.

Private FProduct: TStringList;

This item has no description.

Private FProjectModule: string;

This item has no description.

Private FSourceCodeFile: string;

This item has no description.

Private FConsoleContent: string;

This item has no description.

Private FOutputCodeType: TGLCUDACompilerOutput;

This item has no description.

Private FVirtualArch: TGLCUDAVirtArch;

This item has no description.

Private FRealArch: TGLCUDARealArchs;

This item has no description.

Private FMaxRegisterCount: Integer;

This item has no description.

Private FModuleInfo: TCUDAModuleInfo;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Compile: Boolean;

This item has no description.

Private function StoreProjectModule: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure SetSourceCodeFile(const AFileName: string);

This item has no description.

Private procedure SetCppCompilerPath(const AValue: string);

This item has no description.

Private procedure SetMaxRegisterCount(Value: Integer);

This item has no description.

Private procedure SetNVCCPath(const AValue: string);

This item has no description.

Private procedure SetOutputCodeType(const Value: TGLCUDACompilerOutput);

This item has no description.

Private procedure SetRealArch(AValue: TGLCUDARealArchs);

This item has no description.

Properties

Public property ConsoleContent: string read FConsoleContent;

This item has no description.

Published property CppCompilerPath: string read FCppCompilerPath write SetCppCompilerPath;

Microsoft Visual Studio Compiler. Pascal compiler is still not done.

Published property MaxRegisterCount: Integer read FMaxRegisterCount write SetMaxRegisterCount default 32;

Maximum registers that kernel can use.

Public property ModuleInfo: TCUDAModuleInfo read FModuleInfo;

This item has no description.

Published property NVCCPath: string read FNVCCPath write SetNVCCPath;

NVidia CUDA Compiler.

Published property OutputCodeType: TGLCUDACompilerOutput read FOutputCodeType write setOutputCodeType default codePtx;

Output code type for module kernel - Ptx - Parallel Thread Execution - Cubin - CUDA Binary

Public property Product: TStringList read FProduct write FProduct;

Product of compilation.

Published property ProjectModule: string read FProjectModule write FProjectModule stored StoreProjectModule;

Disign-time only property. Make choose of one of the Project module as CUDA kernel source

Published property RealArchitecture: TGLCUDARealArchs read FRealArch write SetRealArch default [sm_13];

In the CUDA naming scheme, GPUs are named sm_xy, where x denotes the GPU generation number, and y the version in that generation.

Published property SourceCodeFile: string read FSourceCodeFile;

Full file name of source code file.

Published property VirtualArchitecture: TGLCUDAVirtArch read FVirtualArch write FVirtualArch default compute_13;

Virtual architecture.


GLSysHelp v.2.5: GLS.CUDA.Context

Unit GLS.CUDA.Context

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.Strings
  • GLS.BaseClasses
  • GLS.Context
  • GLScene.Generics
  • CUDA.Import
  • CUDA.RunTime

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDADimensions |
Class TCUDADevice |
Class TGLCUDADevice |
Class TCUDAHandlesMaster |
Class TCUDAContext |
Class CUDAContextManager |

Types

TCUDAContextList = GList<TCUDAContext>;
TCUDADeviceList = GList<TCUDADevice>;
TCUDAHandleList = GThreadList<TCUDAHandlesMaster>;
TOnOpenGLInteropInit = procedure(out Context: TGLContext) of object;

Description

Types

TCUDAContextList = GList<TCUDAContext>;

This item has no description.

TCUDADeviceList = GList<TCUDADevice>;

This item has no description.

TCUDAHandleList = GThreadList<TCUDAHandlesMaster>;

This item has no description.

TOnOpenGLInteropInit = procedure(out Context: TGLContext) of object;


GLSysHelp v.2.5: GLS.CUDA.Context: Class TCUDADimensions

Class TCUDADimensions

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Context

Declaration

type TCUDADimensions = class(TGLUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TCUDADimensions

Overview

Fields

Private | FXYZ: TDim3;
Private | FMaxXYZ: TDim3;
Private | FReadOnly: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function GetDimComponent(index: Integer): Integer;
Private | function GetMaxDimComponent(index: Integer): Integer;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetDimComponent(index: Integer; Value: Integer);
Private | procedure SetMaxDimComponent(index: Integer; Value: Integer);

Properties

Public | property MaxSizeX: Integer index 0 read GetMaxDimComponent write SetMaxDimComponent;
Public | property MaxSizeY: Integer index 1 read GetMaxDimComponent write SetMaxDimComponent;
Public | property MaxSizeZ: Integer index 2 read GetMaxDimComponent write SetMaxDimComponent;
Public | property ReadOnlyValue: Boolean read FReadOnly write FReadOnly;
Published | property SizeX: Integer index 0 read GetDimComponent write SetDimComponent default 1;
Published | property SizeY: Integer index 1 read GetDimComponent write SetDimComponent default 1;
Published | property SizeZ: Integer index 2 read GetDimComponent write SetDimComponent default 1;

Description

Fields

Private FXYZ: TDim3;

This item has no description.

Private FMaxXYZ: TDim3;

This item has no description.

Private FReadOnly: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function GetDimComponent(index: Integer): Integer;

This item has no description.

Private function GetMaxDimComponent(index: Integer): Integer;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetDimComponent(index: Integer; Value: Integer);

This item has no description.

Private procedure SetMaxDimComponent(index: Integer; Value: Integer);

This item has no description.

Properties

Public property MaxSizeX: Integer index 0 read GetMaxDimComponent write SetMaxDimComponent;

This item has no description.

Public property MaxSizeY: Integer index 1 read GetMaxDimComponent write SetMaxDimComponent;

This item has no description.

Public property MaxSizeZ: Integer index 2 read GetMaxDimComponent write SetMaxDimComponent;

This item has no description.

Public property ReadOnlyValue: Boolean read FReadOnly write FReadOnly;

This item has no description.

Published property SizeX: Integer index 0 read GetDimComponent write SetDimComponent default 1;

This item has no description.

Published property SizeY: Integer index 1 read GetDimComponent write SetDimComponent default 1;

This item has no description.

Published property SizeZ: Integer index 2 read GetDimComponent write SetDimComponent default 1;


GLSysHelp v.2.5: GLS.CUDA.Context: Class TCUDADevice

Class TCUDADevice

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Context

Declaration

type TCUDADevice = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCUDADevice

Overview

Fields

Private | fID: Integer;
Private | fHandle: TCUdevice;
Private | fGFlops: Integer;
Private | fDeviceProperties: TCudaDeviceProp;
Private | FSuitable: Boolean;
Private | FUsed: Boolean;
Private | fMaxThreadsDim: TCUDADimensions;
Private | fMaxGridSize: TCUDADimensions;

Methods

Public | constructor Create; reintroduce;
Public | destructor Destroy; override;
Public | function TotalMemory: Cardinal;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property ClockRate: Integer read fDeviceProperties.ClockRate;
Published | property DeviceOverlap: Integer read fDeviceProperties.DeviceOverlap;
Published | property Major: Integer read fDeviceProperties.Major;
Published | property MaxGridSize: TCUDADimensions read fMaxGridSize;
Published | property MaxThreadsDim: TCUDADimensions read fMaxThreadsDim;
Published | property MaxThreadsPerBlock: Integer read fDeviceProperties.MaxThreadsPerBlock;
Published | property MemPitch: NativeUInt read fDeviceProperties.MemPitch;
Published | property Minor: Integer read fDeviceProperties.Minor;
Published | property MultiProcessorCount: Integer read fDeviceProperties.MultiProcessorCount;
Published | property Name: string read GetName;
Published | property RegsPerBlock: Integer read fDeviceProperties.RegsPerBlock;
Published | property SharedMemPerBlock: NativeUInt read fDeviceProperties.SharedMemPerBlock;
Published | property TextureAlignment: NativeUInt read fDeviceProperties.TextureAlignment;
Published | property TotalConstMem: NativeUInt read fDeviceProperties.TotalConstMem;
Published | property TotalGlobalMem: NativeUInt read fDeviceProperties.TotalGlobalMem;
Published | property WarpSize: Integer read fDeviceProperties.WarpSize;

Description

Fields

Private fID: Integer;

This item has no description.

Private fHandle: TCUdevice;

This item has no description.

Private fGFlops: Integer;

This item has no description.

Private fDeviceProperties: TCudaDeviceProp;

This item has no description.

Private FSuitable: Boolean;

This item has no description.

Private FUsed: Boolean;

This item has no description.

Private fMaxThreadsDim: TCUDADimensions;

This item has no description.

Private fMaxGridSize: TCUDADimensions;

This item has no description.

Methods

Public constructor Create; reintroduce;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TotalMemory: Cardinal;

Returns in bytes the total amount of memory available on the device dev in bytes.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property ClockRate: Integer read fDeviceProperties.ClockRate;

This item has no description.

Published property DeviceOverlap: Integer read fDeviceProperties.DeviceOverlap;

This item has no description.

Published property Major: Integer read fDeviceProperties.Major;

This item has no description.

Published property MaxGridSize: TCUDADimensions read fMaxGridSize;

This item has no description.

Published property MaxThreadsDim: TCUDADimensions read fMaxThreadsDim;

This item has no description.

Published property MaxThreadsPerBlock: Integer read fDeviceProperties.MaxThreadsPerBlock;

This item has no description.

Published property MemPitch: NativeUInt read fDeviceProperties.MemPitch;

This item has no description.

Published property Minor: Integer read fDeviceProperties.Minor;

This item has no description.

Published property MultiProcessorCount: Integer read fDeviceProperties.MultiProcessorCount;

This item has no description.

Published property Name: string read GetName;

This item has no description.

Published property RegsPerBlock: Integer read fDeviceProperties.RegsPerBlock;

This item has no description.

Published property SharedMemPerBlock: NativeUInt read fDeviceProperties.SharedMemPerBlock;

This item has no description.

Published property TextureAlignment: NativeUInt read fDeviceProperties.TextureAlignment;

This item has no description.

Published property TotalConstMem: NativeUInt read fDeviceProperties.TotalConstMem;

This item has no description.

Published property TotalGlobalMem: NativeUInt read fDeviceProperties.TotalGlobalMem;

This item has no description.

Published property WarpSize: Integer read fDeviceProperties.WarpSize;


GLSysHelp v.2.5: GLS.CUDA.Context: Class TGLCUDADevice

Class TGLCUDADevice

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Context

Declaration

type TGLCUDADevice = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLCUDADevice

Overview

Fields

Private FSelectDeviceName: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Suitable: Boolean;
Private | function GetDevice: TCUDADevice;
Private | procedure SetDevice(AValue: TCUDADevice);
Private | procedure SetDeviceName(const AName: string);

Properties

Published | property Device: TCUDADevice read GetDevice write SetDevice;
Published | property SelectDevice: string read FSelectDeviceName write SetDeviceName;

Description

Fields

Private FSelectDeviceName: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Suitable: Boolean;

This item has no description.

Private function GetDevice: TCUDADevice;

This item has no description.

Private procedure SetDevice(AValue: TCUDADevice);

This item has no description.

Private procedure SetDeviceName(const AName: string);

This item has no description.

Properties

Published property Device: TCUDADevice read GetDevice write SetDevice;

This item has no description.

Published property SelectDevice: string read FSelectDeviceName write SetDeviceName;


GLSysHelp v.2.5: GLS.CUDA.Context: Class TCUDAHandlesMaster

Class TCUDAHandlesMaster

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Context

Declaration

type TCUDAHandlesMaster = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster


GLSysHelp v.2.5: GLS.CUDA.Context: Class TCUDAContext

Class TCUDAContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Context

Declaration

type TCUDAContext = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TCUDAContext

Overview

Fields

Private | fHandle: PCUcontext;
Private | FDevice: TCUDADevice;
Private | FOnOpenGLInteropInit: TOnOpenGLInteropInit;
Private | FHandleList: TCUDAHandleList;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; inline;
Public | procedure DestroyAllHandles;
Public | procedure Release;
Public | procedure Requires;
Private | procedure SetDevice(ADevice: TCUDADevice);

Properties

Public | property Device: TCUDADevice read FDevice write SetDevice;
Public | property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write FOnOpenGLInteropInit;

Description

Fields

Private fHandle: PCUcontext;

This item has no description.

Private FDevice: TCUDADevice;

This item has no description.

Private FOnOpenGLInteropInit: TOnOpenGLInteropInit;

This item has no description.

Private FHandleList: TCUDAHandleList;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean; inline;

This item has no description.

Public procedure DestroyAllHandles;

Destroy all handles based of this context

Public procedure Release;

Pops context from current CPU thread

Public procedure Requires;

Pushes context onto CPU thread’s stack of current contexts

Private procedure SetDevice(ADevice: TCUDADevice);

This item has no description.

Properties

Public property Device: TCUDADevice read FDevice write SetDevice;

This item has no description.

Public property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write FOnOpenGLInteropInit;


GLSysHelp v.2.5: GLS.CUDA.Context: Class CUDAContextManager

Class CUDAContextManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Context

Declaration

type CUDAContextManager = class(TObject)

Description

Static class of CUDA contexts manager

Hierarchy

  • TObject
  • CUDAContextManager

Overview

Fields

Private | class var fDeviceList: TCUDADeviceList;
Private | class var fContextList: TCUDAContextList;
Private | class var FContextStacks: array of TCUDAContextList;

Methods

Public | class function ContextCount: Integer;
Public | class function DeviceCount: Integer;
Public | class function GetCurrentThreadContext: TCUDAContext;
Public | class function GetDeviceByName(const AName: string): TCUDADevice;
Public | class function GetMaxGflopsDevice: TCUDADevice;
Public | class function PopContext: TCUDAContext;
Public | class procedure CreateContext(aContext: TCUDAContext);
Public | class procedure CreateContextOf(ADevice: TCUDADevice);
Public | class procedure DestroyContext(aContext: TCUDAContext);
Public | class procedure DestroyContextOf(ADevice: TCUDADevice);
Public | class procedure Done;
Public | class procedure FillUnusedDeviceList(var AList: TStringList);
Public | class procedure Init;
Public | class procedure PushContext(aContext: TCUDAContext);

Properties

Public | property Contexts[i: Integer]: TCUDAContext read GetContext;
Public | property Devices[i: Integer]: TCUDADevice read GetDevice;

Description

Fields

Private class var fDeviceList: TCUDADeviceList;

This item has no description.

Private class var fContextList: TCUDAContextList;

This item has no description.

Private class var FContextStacks: array of TCUDAContextList;

This item has no description.

Methods

Public class function ContextCount: Integer;

Returns the number of TCUDAcontext object

Public class function DeviceCount: Integer;

Returns the number of CUDA compatiable devices

Public class function GetCurrentThreadContext: TCUDAContext;

Return CUDA context of current thread

Public class function GetDeviceByName(const AName: string): TCUDADevice;

Return device by name

Public class function GetMaxGflopsDevice: TCUDADevice;

Returns a device that has a maximum Giga flops

Public class function PopContext: TCUDAContext;

This item has no description.

Public class procedure CreateContext(aContext: TCUDAContext);

This item has no description.

Public class procedure CreateContextOf(ADevice: TCUDADevice);

This item has no description.

Public class procedure DestroyContext(aContext: TCUDAContext);

This item has no description.

Public class procedure DestroyContextOf(ADevice: TCUDADevice);

This item has no description.

Public class procedure Done;

This item has no description.

Public class procedure FillUnusedDeviceList(var AList: TStringList);

Fill unused device list to show its in property

Public class procedure Init;

Management

Public class procedure PushContext(aContext: TCUDAContext);

This item has no description.

Properties

Public property Contexts[i: Integer]: TCUDAContext read GetContext;

Access to contexts list

Public property Devices[i: Integer]: TCUDADevice read GetDevice;

Access to devices list.


GLSysHelp v.2.5: GLS.CUDA.FFTPlan

Unit GLS.CUDA.FFTPlan

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.CUDA.Context
  • GLS.CUDA.APIComps
  • CUDA.Import
  • CUDA.FourierTransform

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDAFFTPlan |

Types

TCUDAFFTdir = (...);
TCUDAFFTransform = (...);

Description

Types

TCUDAFFTdir = (...);

This item has no description.

Values
  • fftdForward
  • fftdInverse
TCUDAFFTransform = (...);

This item has no description.

Values
  • fftRealToComplex
  • fftComplexToReal
  • fftComplexToComplex
  • fftDoubleToDoubleComplex
  • fftDoubleComplexToDouble
  • fftDoubleComplexToDoubleComplex


GLSysHelp v.2.5: GLS.CUDA.FFTPlan: Class TCUDAFFTPlan

Class TCUDAFFTPlan

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.FFTPlan

Declaration

type TCUDAFFTPlan = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAFFTPlan

Overview

Fields

Private | FHandle: TcufftHandle;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FDepth: Integer;
Private | FBatch: Integer;
Private | FSize: Integer;
Private | FPaddedSize: Integer;
Private | FTransform: TCUDAFFTransform;
Private | FStatus: TcufftResult;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Execute(ASrc: TCUDAMemData; ADst: TCUDAMemData; const ADir: TCUDAFFTdir = fftdForward);
Private | procedure SetBatch(Value: Integer);
Private | procedure SetDepth(Value: Integer);
Private | procedure SetHeight(Value: Integer);
Private | procedure SetTransform(Value: TCUDAFFTransform);
Private | procedure SetWidth(Value: Integer);

Properties

Published | property Batch: Integer read FBatch write SetBatch default 1;
Published | property Depth: Integer read FDepth write SetDepth default 0;
Published | property Height: Integer read FHeight write SetHeight default 0;
Published | property Transform: TCUDAFFTransform read FTransform write SetTransform default fftRealToComplex;
Published | property Width: Integer read fWidth write SetWidth default 256;

Description

Fields

Private FHandle: TcufftHandle;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FDepth: Integer;

This item has no description.

Private FBatch: Integer;

This item has no description.

Private FSize: Integer;

This item has no description.

Private FPaddedSize: Integer;

This item has no description.

Private FTransform: TCUDAFFTransform;

This item has no description.

Private FStatus: TcufftResult;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Execute(ASrc: TCUDAMemData; ADst: TCUDAMemData; const ADir: TCUDAFFTdir = fftdForward);

This item has no description.

Private procedure SetBatch(Value: Integer);

This item has no description.

Private procedure SetDepth(Value: Integer);

This item has no description.

Private procedure SetHeight(Value: Integer);

This item has no description.

Private procedure SetTransform(Value: TCUDAFFTransform);

This item has no description.

Private procedure SetWidth(Value: Integer);

This item has no description.

Properties

Published property Batch: Integer read FBatch write SetBatch default 1;

This item has no description.

Published property Depth: Integer read FDepth write SetDepth default 0;

This item has no description.

Published property Height: Integer read FHeight write SetHeight default 0;

This item has no description.

Published property Transform: TCUDAFFTransform read FTransform write SetTransform default fftRealToComplex;

This item has no description.

Published property Width: Integer read fWidth write SetWidth default 256;


GLSysHelp v.2.5: GLS.CUDA.Graphics

Unit GLS.CUDA.Graphics

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLS.CUDA.APIComps
  • CUDA.Import
  • GLS.Context
  • GLS.State
  • GLS.Scene
  • GLS.Graphics
  • GLS.Material
  • GLScene.Strings
  • GLScene.TextureFormat
  • GLS.Texture
  • GLSL.Shader
  • GLSL.ShaderParameter
  • GLS.PersistentClasses
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLVertexAttribute |
Class TGLVertexAttributes |
Class TCUDACustomFeedBackMesh |
Class TCUDAFeedbackMesh |
Class TCUDAImageResource |
Class TCUDAGeometryResource |

Types

TFeedBackMeshLaunching = (...);
TFeedBackMeshPrimitive = (...);
TOnBeforeKernelLaunch = procedure(Sender: TGLVertexAttribute) of object;

Description

Types

TFeedBackMeshLaunching = (...);

This item has no description.

Values
  • fblCommon
  • fblOnePerAtttribute
TFeedBackMeshPrimitive = (...);

This item has no description.

Values
  • fbmpPoint
  • fbmpLine
  • fbmpTriangle
TOnBeforeKernelLaunch = procedure(Sender: TGLVertexAttribute) of object;


GLSysHelp v.2.5: GLS.CUDA.Graphics: Class TGLVertexAttribute

Class TGLVertexAttribute

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Graphics

Declaration

type TGLVertexAttribute = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLVertexAttribute

Overview

Fields

Private | FName: string;
Private | FType: TGLSLDataType;
Private | FFunc: TCUDAFunction;
Private | FLocation: Integer;
Private | FOnBeforeKernelLaunch: TOnBeforeKernelLaunch;

Methods

Public | constructor Create(ACollection: TCollection); override;
Private | function GetLocation: Integer;
Private | function GetOwner: TGLVertexAttributes; reintroduce;
Public | procedure NotifyChange(Sender: TObject);
Private | procedure SetFunc(AFunc: TCUDAFunction);
Private | procedure SetName(const AName: string);
Private | procedure SetType(AType: TGLSLDataType);

Properties

Published | property GLSLType: TGLSLDataType read FType write SetType;
Published | property KernelFunction: TCUDAFunction read FFunc write SetFunc;
Public | property Location: Integer read GetLocation;
Published | property Name: string read FName write SetName;
Published | property OnBeforeKernelLaunch: TOnBeforeKernelLaunch read FOnBeforeKernelLaunch write FOnBeforeKernelLaunch;

Description

Fields

Private FName: string;

This item has no description.

Private FType: TGLSLDataType;

This item has no description.

Private FFunc: TCUDAFunction;

This item has no description.

Private FLocation: Integer;

This item has no description.

Private FOnBeforeKernelLaunch: TOnBeforeKernelLaunch;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Private function GetLocation: Integer;

This item has no description.

Private function GetOwner: TGLVertexAttributes; reintroduce;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Private procedure SetFunc(AFunc: TCUDAFunction);

This item has no description.

Private procedure SetName(const AName: string);

This item has no description.

Private procedure SetType(AType: TGLSLDataType);

This item has no description.

Properties

Published property GLSLType: TGLSLDataType read FType write SetType;

This item has no description.

Published property KernelFunction: TCUDAFunction read FFunc write SetFunc;

This item has no description.

Public property Location: Integer read GetLocation;

This item has no description.

Published property Name: string read FName write SetName;

This item has no description.

Published property OnBeforeKernelLaunch: TOnBeforeKernelLaunch read FOnBeforeKernelLaunch write FOnBeforeKernelLaunch;


GLSysHelp v.2.5: GLS.CUDA.Graphics: Class TGLVertexAttributes

Class TGLVertexAttributes

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Graphics

Declaration

type TGLVertexAttributes = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLVertexAttributes

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLVertexAttribute;
Public | function GetAttributeByName(const AName: string): TGLVertexAttribute;
Public | function MakeUniqueName(const ANameRoot: string): string;
Private | function GetItems(Index: Integer): TGLVertexAttribute;
Public | procedure NotifyChange(Sender: TObject);
Private | procedure SetItems(Index: Integer; const AValue: TGLVertexAttribute);

Properties

Public property Attributes[Index: Integer]: TGLVertexAttribute read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLVertexAttribute;

This item has no description.

Public function GetAttributeByName(const AName: string): TGLVertexAttribute;

This item has no description.

Public function MakeUniqueName(const ANameRoot: string): string;

This item has no description.

Private function GetItems(Index: Integer): TGLVertexAttribute;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Private procedure SetItems(Index: Integer; const AValue: TGLVertexAttribute);

This item has no description.

Properties

Public property Attributes[Index: Integer]: TGLVertexAttribute read GetItems write SetItems;


GLSysHelp v.2.5: GLS.CUDA.Graphics: Class TCUDACustomFeedBackMesh

Class TCUDACustomFeedBackMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Graphics

Declaration

type TCUDACustomFeedBackMesh = class(TGLBaseSceneObject)

Description

====================================================

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TCUDACustomFeedBackMesh

Overview

Fields

Private | FGeometryResource: TCUDAGraphicResource;
Private | FAttributes: TGLVertexAttributes;
Private | FVAO: TGLVertexArrayHandle;
Private | FVBO: TGLVBOArrayBufferHandle;
Private | FEBO: TGLVBOElementArrayHandle;
Private | FPrimitiveType: TFeedBackMeshPrimitive;
Private | FVertexNumber: Integer;
Private | FElementNumber: Integer;
Private | FShader: TGLSLShader;
Private | FCommonFunc: TCUDAFunction;
Private | FLaunching: TFeedBackMeshLaunching;
Private | FBlend: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Private | procedure SetAttributes(AValue: TGLVertexAttributes);
Private | procedure SetCommonFunc(AFunc: TCUDAFunction);
Private | procedure SetElementNumber(AValue: Integer);
Private | procedure SetPrimitiveType(AValue: TFeedBackMeshPrimitive);
Private | procedure SetShader(AShader: TGLSLShader);
Private | procedure SetVertexNumber(AValue: Integer);

Properties

Public | property ArrayBufferHandle: TGLVBOArrayBufferHandle read FVBO;
Public | property ElementArrayHandle: TGLVBOElementArrayHandle read FEBO;

Description

Fields

Private FGeometryResource: TCUDAGraphicResource;

This item has no description.

Private FAttributes: TGLVertexAttributes;

This item has no description.

Private FVAO: TGLVertexArrayHandle;

This item has no description.

Private FVBO: TGLVBOArrayBufferHandle;

This item has no description.

Private FEBO: TGLVBOElementArrayHandle;

This item has no description.

Private FPrimitiveType: TFeedBackMeshPrimitive;

This item has no description.

Private FVertexNumber: Integer;

This item has no description.

Private FElementNumber: Integer;

This item has no description.

Private FShader: TGLSLShader;

This item has no description.

Private FCommonFunc: TCUDAFunction;

This item has no description.

Private FLaunching: TFeedBackMeshLaunching;

This item has no description.

Private FBlend: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Private procedure SetAttributes(AValue: TGLVertexAttributes);

This item has no description.

Private procedure SetCommonFunc(AFunc: TCUDAFunction);

This item has no description.

Private procedure SetElementNumber(AValue: Integer);

This item has no description.

Private procedure SetPrimitiveType(AValue: TFeedBackMeshPrimitive);

This item has no description.

Private procedure SetShader(AShader: TGLSLShader);

This item has no description.

Private procedure SetVertexNumber(AValue: Integer);

This item has no description.

Properties

Public property ArrayBufferHandle: TGLVBOArrayBufferHandle read FVBO;

This item has no description.

Public property ElementArrayHandle: TGLVBOElementArrayHandle read FEBO;


GLSysHelp v.2.5: GLS.CUDA.Graphics: Class TCUDAFeedbackMesh

Class TCUDAFeedbackMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Graphics

Declaration

type TCUDAFeedbackMesh = class(TCUDACustomFeedBackMesh)

Description

This item has no description. Showing description inherited from TCUDACustomFeedBackMesh.

====================================================

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TCUDACustomFeedBackMesh
  • TCUDAFeedbackMesh

Overview

Properties

Published | property Attributes;
Published | property Behaviours;
Published | property Blend;
Published | property CommonKernelFunction;
Published | property Direction;
Published | property Effects;
Published | property ElementNumber;
Published | property Launching;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property PrimitiveType;
Published | property RollAngle;
Published | property Scale;
Published | property Shader;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VertexNumber;
Published | property VisibilityCulling;
Published | property Visible;

Description

Properties

Published property Attributes;

This item has no description.

Published property Behaviours;

This item has no description.

Published property Blend;

This item has no description.

Published property CommonKernelFunction;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property ElementNumber;

This item has no description.

Published property Launching;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnPicked;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Pickable;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property PrimitiveType;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property Shader;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property VertexNumber;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.CUDA.Graphics: Class TCUDAImageResource

Class TCUDAImageResource

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Graphics

Declaration

type TCUDAImageResource = class(TCUDAGraphicResource)

Description

This item has no description. Showing description inherited from TCUDAGraphicResource.

Abstract class of graphic resources.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource
  • TCUDAImageResource

Overview

Fields

Private | fMaterialLibrary: TGLMaterialLibrary;
Private | fTextureName: TGLLibMaterialName;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BindArrayToTexture(var cudaArray: TCUDAMemData; ALeyer, ALevel: LOngWord); override;
Public | procedure MapResources; override;
Public | procedure UnMapResources; override;
Private | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);
Private | procedure SetTextureName(const Value: TGLLibMaterialName);

Properties

Published | property Mapping;
Published | property MaterialLibrary: TGLMaterialLibrary read fMaterialLibrary write SetMaterialLibrary;
Published | property TextureName: TGLLibMaterialName read fTextureName write SetTextureName;

Description

Fields

Private fMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private fTextureName: TGLLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BindArrayToTexture(var cudaArray: TCUDAMemData; ALeyer, ALevel: LOngWord); override;

This item has no description.

Public procedure MapResources; override;

This item has no description.

Public procedure UnMapResources; override;

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

This item has no description.

Private procedure SetTextureName(const Value: TGLLibMaterialName);

This item has no description.

Properties

Published property Mapping;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read fMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property TextureName: TGLLibMaterialName read fTextureName write SetTextureName;


GLSysHelp v.2.5: GLS.CUDA.Graphics: Class TCUDAGeometryResource

Class TCUDAGeometryResource

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.Graphics

Declaration

type TCUDAGeometryResource = class(TCUDAGraphicResource)

Description

This item has no description. Showing description inherited from TCUDAGraphicResource.

Abstract class of graphic resources.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource
  • TCUDAGeometryResource

Overview

Fields

Private FFeedBackMesh: TCUDACustomFeedBackMesh;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetAttribArraySize(AAttr: TGLVertexAttribute): LongWord;
Public | procedure MapResources; override;
Public | procedure UnMapResources; override;
Private | procedure SetFeedBackMesh(const Value: TCUDACustomFeedBackMesh);

Properties

Public | property AttributeDataAddress[const AttribName: string]: Pointer read GetAttributeArrayAddress;
Public | property AttributeDataSize[const AttribName: string]: LongWord read GetAttributeArraySize;
Published | property FeedBackMesh: TCUDACustomFeedBackMesh read FFeedBackMesh write SetFeedBackMesh;
Public | property IndexDataAddress: Pointer read GetElementArrayAddress;
Public | property IndexDataSize: LongWord read GetElementArrayDataSize;
Published | property Mapping;

Description

Fields

Private FFeedBackMesh: TCUDACustomFeedBackMesh;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAttribArraySize(AAttr: TGLVertexAttribute): LongWord;

This item has no description.

Public procedure MapResources; override;

This item has no description.

Public procedure UnMapResources; override;

This item has no description.

Private procedure SetFeedBackMesh(const Value: TCUDACustomFeedBackMesh);

This item has no description.

Properties

Public property AttributeDataAddress[const AttribName: string]: Pointer read GetAttributeArrayAddress;

This item has no description.

Public property AttributeDataSize[const AttribName: string]: LongWord read GetAttributeArraySize;

This item has no description.

Published property FeedBackMesh: TCUDACustomFeedBackMesh read FFeedBackMesh write SetFeedBackMesh;

This item has no description.

Public property IndexDataAddress: Pointer read GetElementArrayAddress;

This item has no description.

Public property IndexDataSize: LongWord read GetElementArrayDataSize;

This item has no description.

Published property Mapping;


GLSysHelp v.2.5: GLS.CUDA.PropEditors

Unit GLS.CUDA.PropEditors

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • ToolsAPI
  • StrEdit
  • DesignEditors
  • DesignIntf
  • GLS.CUDA.APIComps
  • GLS.CUDA.Compiler
  • GLS.CUDA.Context
  • FmCUDAEditor

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCUDAEditor |
Class TGLCUDACompilerEditor |
Class TGLCUDACompilerSourceProperty |
Class TGLCUDADeviceProperty |

Functions and Procedures

function FindCuFile(var AModuleName: string): Boolean;

Description

Functions and Procedures

function FindCuFile(var AModuleName: string): Boolean;


GLSysHelp v.2.5: GLS.CUDA.PropEditors: Class TGLCUDAEditor

Class TGLCUDAEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.PropEditors

Declaration

type TGLCUDAEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TGLCUDAEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GLSysHelp v.2.5: GLS.CUDA.PropEditors: Class TGLCUDACompilerEditor

Class TGLCUDACompilerEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.PropEditors

Declaration

type TGLCUDACompilerEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TGLCUDACompilerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GLSysHelp v.2.5: GLS.CUDA.PropEditors: Class TGLCUDACompilerSourceProperty

Class TGLCUDACompilerSourceProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.PropEditors

Declaration

type TGLCUDACompilerSourceProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLCUDACompilerSourceProperty

Overview

Fields

Private FModuleList: TStringList;

Methods

Public | constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;
Public | destructor Destroy; override;
Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: String); override;
Private | procedure RefreshModuleList;

Description

Fields

Private FModuleList: TStringList;

This item has no description.

Methods

Public constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: String); override;

This item has no description.

Private procedure RefreshModuleList;


GLSysHelp v.2.5: GLS.CUDA.PropEditors: Class TGLCUDADeviceProperty

Class TGLCUDADeviceProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CUDA.PropEditors

Declaration

type TGLCUDADeviceProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLCUDADeviceProperty

Overview

Fields

Private FDeviceList: TStringList;

Methods

Public | constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;
Public | destructor Destroy; override;
Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: String); override;

Description

Fields

Private FDeviceList: TStringList;

This item has no description.

Methods

Public constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: String); override;


GLSysHelp v.2.5: GLS.CUDA.Register

Unit GLS.CUDA.Register

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • DesignIntf
  • DesignEditors
  • ToolsAPI
  • StrEdit
  • GLS.SceneRegister
  • GLS.CUDA.APIComps
  • GLS.CUDA.Compiler
  • GLS.CUDA.Context
  • GLS.CUDA.Graphics
  • GLS.CUDA.FFTPlan
  • GLS.CUDA.PropEditors

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GLSysHelp v.2.5: GLS.CyborgManager

Unit GLS.CyborgManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • GLS.Scene
  • GLS.Objects
  • GLS.SmartObjects
  • GLS.File3DS
  • GLS.FilePly
  • GLS.FileOBJ

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCyborgManager |


GLSysHelp v.2.5: GLS.CyborgManager: Class TGLCyborgManager

Class TGLCyborgManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.CyborgManager

Declaration

type TGLCyborgManager = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCyborgManager

Overview

Fields

Private | FMasterObject: TGLDummyCube;
Private | FModelList: TStringList;
Private | FModelPath: string;

Methods

Public | constructor Create(AMaster: TGLDummyCube; APath: string); virtual;
Public | destructor Destroy; override;
Public | function LoadModel(AFilename: string): TGLCyborg;
Private | procedure SetPathToModel(const Value: String);

Properties

Public | property MasterObject: TGLDummyCube read FMasterObject;
Public | property ModelList: TStringList read FModelList;
Public | property Path: string read FModelPath write SetPathToModel;

Description

Fields

Private FMasterObject: TGLDummyCube;

This item has no description.

Private FModelList: TStringList;

This item has no description.

Private FModelPath: string;

This item has no description.

Methods

Public constructor Create(AMaster: TGLDummyCube; APath: string); virtual;

It will create the list, assign the path to the models and the master object where the new models will be loaded

Public destructor Destroy; override;

It will free all the loaded models

Public function LoadModel(AFilename: string): TGLCyborg;

It will load a new model if it's not in the list and then return the new freeform. If it,s already in the list, it will return the existing freeform

Private procedure SetPathToModel(const Value: String);

Changing the path to the models and refresh the already existing freeforms

Properties

Public property MasterObject: TGLDummyCube read FMasterObject;

This item has no description.

Public property ModelList: TStringList read FModelList;

This item has no description.

Public property Path: string read FModelPath write SetPathToModel;


GLSysHelp v.2.5: GLS.DCE

Unit GLS.DCE

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.BaseClasses
  • GLS.Coordinates
  • GLScene.Manager
  • GLScene.XCollection
  • GLS.VectorLists
  • GLS.Scene
  • GLS.VectorFileObjects
  • GLS.EllipseCollision
  • GLS.TerrainRenderer
  • GLS.ProxyObjects
  • GLS.MultiProxy
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TDCECollision |
Class TGLDCEManager |
Class TGLDCEStatic |
Class TGLDCEDynamic |

Functions and Procedures

procedure ECSetCollisionRange(var MovePack: TECMovePack);
procedure ECResetColliders(var MovePack: TECMovePack);
procedure ECAddFreeForm(var MovePack: TECMovePack; FreeForm: TGLBaseSceneObject; Solid: Boolean; ObjectID: Integer);
procedure ECAddBox(var MovePack: TECMovePack; BoxObj: TGLBaseSceneObject; BoxSize: TAffineVector; Solid: Boolean; ObjectID: Integer);
procedure ECAddTerrain(var MovePack: TECMovePack; TerrainRenderer: TGLTerrainRenderer; Resolution: single; Solid: Boolean; ObjectID: Integer);
procedure ECAddEllipsoid(var MovePack: TECMovePack; ePos, eRadius: TAffineVector; Solid: Boolean; ObjectID: Integer);
function GetOrCreateDCEStatic(behaviours: TGLBehaviours): TGLDCEStatic; overload;
function GetOrCreateDCEStatic(obj: TGLBaseSceneObject): TGLDCEStatic; overload;
function GetOrCreateDCEDynamic(behaviours: TGLBehaviours) : TGLDCEDynamic; overload;
function GetOrCreateDCEDynamic(obj: TGLBaseSceneObject): TGLDCEDynamic; overload;

Types

TDCECollisionEvent = procedure(Sender: TObject; object1, object2: TGLBaseSceneObject; CollisionInfo: TDCECollision) of object;
TDCECollisionSelection = (...);
TDCEObjectCollisionEvent = procedure(Sender: TObject; ObjectCollided: TGLBaseSceneObject; CollisionInfo: TDCECollision) of object;
TDCEShape = (...);
TDCESlideOrBounce = (...);

Constants

DCEBox: array [0 .. 35] of TAffineVector = ((x: 1; y: - 1; z: - 1), (x: 1; y: 1; z: - 1), (x: 1; y: - 1; z: 1), (x: 1; y: 1; z: - 1), (x: 1; y: 1; z: 1), (x: 1; y: - 1; z: 1), (x: 1; y: 1; z: - 1), (x: - 1; y: 1; z: - 1), (x: - 1; y: 1; z: 1), (x: 1; y: 1; z: 1), (x: 1; y: 1; z: - 1), (x: - 1; y: 1; z: 1), (x: - 1; y: 1; z: 1), (x: - 1; y: - 1; z: 1), (x: 1; y: - 1; z: 1), (x: 1; y: 1; z: 1), (x: - 1; y: 1; z: 1), (x: 1; y: - 1; z: 1), (x: - 1; y: - 1; z: 1), (x: - 1; y: 1; z: 1), (x: - 1; y: 1; z: - 1), (x: - 1; y: - 1; z: - 1), (x: - 1; y: - 1; z: 1), (x: - 1; y: 1; z: - 1), (x: 1; y: - 1; z: 1), (x: - 1; y: - 1; z: 1), (x: 1; y: - 1; z: - 1), (x: - 1; y: - 1; z: 1), (x: - 1; y: - 1; z: - 1), (x: 1; y: - 1; z: - 1), (x: 1; y: 1; z: - 1), (x: 1; y: - 1; z: - 1), (x: - 1; y: 1; z: - 1), (x: 1; y: - 1; z: - 1), (x: - 1; y: - 1; z: - 1), (x: - 1; y: 1; z: - 1));

Description

Functions and Procedures

procedure ECSetCollisionRange(var MovePack: TECMovePack);

———————- DCE Misc functions ————————— Calculate and set the collision range

procedure ECResetColliders(var MovePack: TECMovePack);

Set the collider lists to null

procedure ECAddFreeForm(var MovePack: TECMovePack; FreeForm: TGLBaseSceneObject; Solid: Boolean; ObjectID: Integer);

Add freeform's octree data

procedure ECAddBox(var MovePack: TECMovePack; BoxObj: TGLBaseSceneObject; BoxSize: TAffineVector; Solid: Boolean; ObjectID: Integer);

Add a TriMesh box

procedure ECAddTerrain(var MovePack: TECMovePack; TerrainRenderer: TGLTerrainRenderer; Resolution: single; Solid: Boolean; ObjectID: Integer);

Add the terrain as a TriMesh

procedure ECAddEllipsoid(var MovePack: TECMovePack; ePos, eRadius: TAffineVector; Solid: Boolean; ObjectID: Integer);

Add a static ellipsoid

function GetOrCreateDCEStatic(behaviours: TGLBehaviours): TGLDCEStatic; overload;

This item has no description.

function GetOrCreateDCEStatic(obj: TGLBaseSceneObject): TGLDCEStatic; overload;

This item has no description.

function GetOrCreateDCEDynamic(behaviours: TGLBehaviours) : TGLDCEDynamic; overload;

This item has no description.

function GetOrCreateDCEDynamic(obj: TGLBaseSceneObject): TGLDCEDynamic; overload;

This item has no description.

Types

TDCECollisionEvent = procedure(Sender: TObject; object1, object2: TGLBaseSceneObject; CollisionInfo: TDCECollision) of object;

This item has no description.

TDCECollisionSelection = (...);

Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: ccsDCEStandard: Collides bodies if A.layer <= B.layer ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0)

Values
  • ccsDCEStandard
  • ccsCollisionStandard
  • ccsHybrid
TDCEObjectCollisionEvent = procedure(Sender: TObject; ObjectCollided: TGLBaseSceneObject; CollisionInfo: TDCECollision) of object;

This item has no description.

TDCEShape = (...);

Only csEllipsoid can have dynamic behaviour

Values
  • csEllipsoid
  • csBox
  • csFreeform
  • csTerrain
TDCESlideOrBounce = (...);

This item has no description.

Values
  • csbSlide
  • csbBounce

Constants

DCEBox: array [0 .. 35] of TAffineVector = ((x: 1; y: - 1; z: - 1), (x: 1; y: 1; z: - 1), (x: 1; y: - 1; z: 1), (x: 1; y: 1; z: - 1), (x: 1; y: 1; z: 1), (x: 1; y: - 1; z: 1), (x: 1; y: 1; z: - 1), (x: - 1; y: 1; z: - 1), (x: - 1; y: 1; z: 1), (x: 1; y: 1; z: 1), (x: 1; y: 1; z: - 1), (x: - 1; y: 1; z: 1), (x: - 1; y: 1; z: 1), (x: - 1; y: - 1; z: 1), (x: 1; y: - 1; z: 1), (x: 1; y: 1; z: 1), (x: - 1; y: 1; z: 1), (x: 1; y: - 1; z: 1), (x: - 1; y: - 1; z: 1), (x: - 1; y: 1; z: 1), (x: - 1; y: 1; z: - 1), (x: - 1; y: - 1; z: - 1), (x: - 1; y: - 1; z: 1), (x: - 1; y: 1; z: - 1), (x: 1; y: - 1; z: 1), (x: - 1; y: - 1; z: 1), (x: 1; y: - 1; z: - 1), (x: - 1; y: - 1; z: 1), (x: - 1; y: - 1; z: - 1), (x: 1; y: - 1; z: - 1), (x: 1; y: 1; z: - 1), (x: 1; y: - 1; z: - 1), (x: - 1; y: 1; z: - 1), (x: 1; y: - 1; z: - 1), (x: - 1; y: - 1; z: - 1), (x: - 1; y: 1; z: - 1));


GLSysHelp v.2.5: GLS.DCE: Record TDCECollision

Record TDCECollision

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.DCE

Declaration

type TDCECollision = record

Description

This item has no description.

Overview

Fields

Public | Position: TAffineVector;
Public | Normal: TAffineVector;
Public | Bounce: TAffineVector;
Public | Nearest: Boolean;
Public | RootCollision: Boolean;
Public | Distance: single;

Description

Fields

Public Position: TAffineVector;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Public Bounce: TAffineVector;

Surface normal

Public Nearest: Boolean;

Surface reflection

Public RootCollision: Boolean;

This item has no description.

Public Distance: single;


GLSysHelp v.2.5: GLS.DCE: Class TGLDCEManager

Class TGLDCEManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.DCE

Declaration

type TGLDCEManager = class(TComponent)

Description

The Dynamic Collision Engine Manager class

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLDCEManager

Overview

Fields

Private | FStatics: TList;
Private | FDynamics: TList;
Private | FGravity: single;
Private | FWorldDirection: TGLCoordinates;
Private | FWorldScale: single;
Private | FMovimentScale: single;
Private | FStandardiseLayers: TDCECollisionSelection;
Private | FManualStep: Boolean;
Private | FOnCollision: TDCECollisionEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MoveByDistance(var Body: TGLDCEDynamic; deltaS, deltaAbsS: TAffineVector): single;
Private | function GetDynamicCount: Integer;
Private | function GetStaticCount: Integer;
Public | procedure Step(deltaTime: Double);
Private | procedure SetWorldDirection(const Value: TGLCoordinates);
Private | procedure SetWorldScale(const Value: single);

Properties

Public | property DynamicCount: Integer read GetDynamicCount;
Published | property Gravity: single read FGravity write FGravity;
Published | property ManualStep: Boolean read FManualStep write FManualStep;
Published | property MovimentScale: single read FMovimentScale write FMovimentScale;
Published | property OnCollision: TDCECollisionEvent read FOnCollision write FOnCollision;
Published | property StandardiseLayers: TDCECollisionSelection read FStandardiseLayers write FStandardiseLayers;
Public | property StaticCount: Integer read GetStaticCount;
Published | property WorldDirection: TGLCoordinates read FWorldDirection write SetWorldDirection;
Published | property WorldScale: single read FWorldScale write SetWorldScale;

Description

Fields

Private FStatics: TList;

This item has no description.

Private FDynamics: TList;

This item has no description.

Private FGravity: single;

This item has no description.

Private FWorldDirection: TGLCoordinates;

This item has no description.

Private FWorldScale: single;

Used to calculate jumps f.i.

Private FMovimentScale: single;

This item has no description.

Private FStandardiseLayers: TDCECollisionSelection;

This item has no description.

Private FManualStep: Boolean;

This item has no description.

Private FOnCollision: TDCECollisionEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MoveByDistance(var Body: TGLDCEDynamic; deltaS, deltaAbsS: TAffineVector): single;

Moves the body by the distance and returns the average friction

Private function GetDynamicCount: Integer;

This item has no description.

Private function GetStaticCount: Integer;

This item has no description.

Public procedure Step(deltaTime: Double);

This item has no description.

Private procedure SetWorldDirection(const Value: TGLCoordinates);

This item has no description.

Private procedure SetWorldScale(const Value: single);

This item has no description.

Properties

Public property DynamicCount: Integer read GetDynamicCount;

This item has no description.

Published property Gravity: single read FGravity write FGravity;

This item has no description.

Published property ManualStep: Boolean read FManualStep write FManualStep;

This item has no description.

Published property MovimentScale: single read FMovimentScale write FMovimentScale;

This item has no description.

Published property OnCollision: TDCECollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property StandardiseLayers: TDCECollisionSelection read FStandardiseLayers write FStandardiseLayers;

This item has no description.

Public property StaticCount: Integer read GetStaticCount;

This item has no description.

Published property WorldDirection: TGLCoordinates read FWorldDirection write SetWorldDirection;

This item has no description.

Published property WorldScale: single read FWorldScale write SetWorldScale;


GLSysHelp v.2.5: GLS.DCE: Class TGLDCEStatic

Class TGLDCEStatic

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.DCE

Declaration

type TGLDCEStatic = class(TGLBehaviour)

Description

This item has no description. Showing description inherited from TGLBehaviour.

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLDCEStatic

Overview

Fields

Private | FManager: TGLDCEManager;
Private | FManagerName: String;
Private | FActive: Boolean;
Private | FShape: TDCEShape;
Private | FLayer: Integer;
Private | FSolid: Boolean;
Private | FFriction: single;
Private | FBounceFactor: single;
Private | FSize: TGLCoordinates;
Private | FOnCollision: TDCEObjectCollisionEvent;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetBounceFactor(const Value: single);
Private | procedure SetFriction(const Value: single);
Private | procedure SetShape(const Value: TDCEShape);
Private | procedure SetSize(const Value: TGLCoordinates);

Properties

Published | property Active: Boolean read FActive write FActive;
Published | property BounceFactor: single read FBounceFactor write SetBounceFactor;
Published | property Friction: single read FFriction write SetFriction;
Published | property Layer: Integer read FLayer write FLayer;
Published | property Manager: TGLDCEManager read FManager write SetManager;
Public | property OnCollision: TDCEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Shape: TDCEShape read FShape write SetShape;
Published | property Size: TGLCoordinates read FSize write SetSize;
Published | property Solid: Boolean read FSolid write FSolid;

Description

Fields

Private FManager: TGLDCEManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FActive: Boolean;

NOT persistent, temporarily used for persistence

Private FShape: TDCEShape;

This item has no description.

Private FLayer: Integer;

Collides only with lower or equal layers

Private FSolid: Boolean;

Collide and slide if true, otherwise it "walk thru walls"

Private FFriction: single;

This item has no description.

Private FBounceFactor: single;

0 (no friction); 100 (no movement)

Private FSize: TGLCoordinates;

0 (don't bounce); 1 (bounce forever)

Private FOnCollision: TDCEObjectCollisionEvent;

Events

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Private procedure SetBounceFactor(const Value: single);

This item has no description.

Private procedure SetFriction(const Value: single);

This item has no description.

Private procedure SetShape(const Value: TDCEShape);

This item has no description.

Private procedure SetSize(const Value: TGLCoordinates);

This item has no description.

Properties

Published property Active: Boolean read FActive write FActive;

This item has no description.

Published property BounceFactor: single read FBounceFactor write SetBounceFactor;

This item has no description.

Published property Friction: single read FFriction write SetFriction;

This item has no description.

Published property Layer: Integer read FLayer write FLayer;

This item has no description.

Published property Manager: TGLDCEManager read FManager write SetManager;

This item has no description.

Public property OnCollision: TDCEObjectCollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property Shape: TDCEShape read FShape write SetShape;

This item has no description.

Published property Size: TGLCoordinates read FSize write SetSize;

This item has no description.

Published property Solid: Boolean read FSolid write FSolid;


GLSysHelp v.2.5: GLS.DCE: Class TGLDCEDynamic

Class TGLDCEDynamic

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.DCE

Declaration

type TGLDCEDynamic = class(TGLBehaviour)

Description

This item has no description. Showing description inherited from TGLBehaviour.

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLDCEDynamic

Overview

Fields

Private | FManager: TGLDCEManager;
Private | FManagerName: String;
Private | FActive: Boolean;
Private | FUseGravity: Boolean;
Private | FLayer: Integer;
Private | FSolid: Boolean;
Private | FFriction: single;
Private | FBounceFactor: single;
Private | FSize: TGLCoordinates;
Private | FMaxRecursionDepth: byte;
Private | FSlideOrBounce: TDCESlideOrBounce;
Private | FAccel: TAffineVector;
Private | FSpeed: TAffineVector;
Private | FAbsAccel: TAffineVector;
Private | FAbsSpeed: TAffineVector;
Private | FGravSpeed: TAffineVector;
Private | FTotalFriction: single;
Private | FInGround: Boolean;
Private | FGroundNormal: TAffineVector;
Private | FJumpHeight: single;
Private | FJumpForce: single;
Private | FJumpSpeed: single;
Private | FJumping: Boolean;
Private | FOnCollision: TDCEObjectCollisionEvent;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure ApplyAbsAccel(NewAccel: TAffineVector); overload;
Public | procedure ApplyAbsAccel(x, y, z: single); overload;
Public | procedure ApplyAccel(x, y, z: single); overload;
Public | procedure ApplyAccel(NewAccel: TAffineVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoMove(deltaTime: Double);
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure Jump(jHeight, jSpeed: single);
Public | procedure Move(deltaS: TAffineVector; deltaTime: Double);
Public | procedure MoveTo(Position: TAffineVector; Amount: single);
Public | procedure StopAbsAccel;
Public | procedure StopAccel;
Private | procedure SetBounceFactor(const Value: single);
Private | procedure SetFriction(const Value: single);
Private | procedure SetSize(const Value: TGLCoordinates);

Properties

Published | property Active: Boolean read FActive write FActive;
Published | property BounceFactor: single read FBounceFactor write SetBounceFactor;
Published | property Friction: single read FFriction write SetFriction;
Public | property InGround: Boolean read FInGround;
Published | property Layer: Integer read FLayer write FLayer;
Published | property Manager: TGLDCEManager read FManager write SetManager;
Public | property MaxRecursionDepth: byte read FMaxRecursionDepth write FMaxRecursionDepth;
Public | property OnCollision: TDCEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Size: TGLCoordinates read FSize write SetSize;
Published | property SlideOrBounce: TDCESlideOrBounce read FSlideOrBounce write FSlideOrBounce;
Published | property Solid: Boolean read FSolid write FSolid;
Public | property Speed: TAffineVector read FSpeed write FSpeed;
Published | property UseGravity: Boolean read FUseGravity write FUseGravity;

Description

Fields

Private FManager: TGLDCEManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FActive: Boolean;

NOT persistent, temporarily used for persistence

Private FUseGravity: Boolean;

This item has no description.

Private FLayer: Integer;

This item has no description.

Private FSolid: Boolean;

Collides only with lower or equal layers

Private FFriction: single;

Collide and slide if true, otherwise it "walk thru walls"

Private FBounceFactor: single;

0 (no friction); 100 (no movement)

Private FSize: TGLCoordinates;

0 (don't bounce); 1 (bounce forever)

Private FMaxRecursionDepth: byte;

Number of iterations of the collision method

Private FSlideOrBounce: TDCESlideOrBounce;

This item has no description.

Private FAccel: TAffineVector;

gak20041122 Movement

Private FSpeed: TAffineVector;

Current acceleration

Private FAbsAccel: TAffineVector;

Current speed

Private FAbsSpeed: TAffineVector;

Current absolute accel

Private FGravSpeed: TAffineVector;

Current absolute speed

Private FTotalFriction: single;

Current gravity speed

Private FInGround: Boolean;

Current sum of all contatcs friction

Private FGroundNormal: TAffineVector;

This item has no description.

Private FJumpHeight: single;

This item has no description.

Private FJumpForce: single;

This item has no description.

Private FJumpSpeed: single;

This item has no description.

Private FJumping: Boolean;

This item has no description.

Private FOnCollision: TDCEObjectCollisionEvent;

Events

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure ApplyAbsAccel(NewAccel: TAffineVector); overload;

This item has no description.

Public procedure ApplyAbsAccel(x, y, z: single); overload;

This item has no description.

Public procedure ApplyAccel(x, y, z: single); overload;

This item has no description.

Public procedure ApplyAccel(NewAccel: TAffineVector); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoMove(deltaTime: Double);

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure Jump(jHeight, jSpeed: single);

This item has no description.

Public procedure Move(deltaS: TAffineVector; deltaTime: Double);

This item has no description.

Public procedure MoveTo(Position: TAffineVector; Amount: single);

This item has no description.

Public procedure StopAbsAccel;

This item has no description.

Public procedure StopAccel;

This item has no description.

Private procedure SetBounceFactor(const Value: single);

This item has no description.

Private procedure SetFriction(const Value: single);

This item has no description.

Private procedure SetSize(const Value: TGLCoordinates);

This item has no description.

Properties

Published property Active: Boolean read FActive write FActive;

This item has no description.

Published property BounceFactor: single read FBounceFactor write SetBounceFactor;

This item has no description.

Published property Friction: single read FFriction write SetFriction;

This item has no description.

Public property InGround: Boolean read FInGround;

This item has no description.

Published property Layer: Integer read FLayer write FLayer;

This item has no description.

Published property Manager: TGLDCEManager read FManager write SetManager;

This item has no description.

Public property MaxRecursionDepth: byte read FMaxRecursionDepth write FMaxRecursionDepth;

This item has no description.

Public property OnCollision: TDCEObjectCollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property Size: TGLCoordinates read FSize write SetSize;

This item has no description.

Published property SlideOrBounce: TDCESlideOrBounce read FSlideOrBounce write FSlideOrBounce;

This item has no description.

Published property Solid: Boolean read FSolid write FSolid;

This item has no description.

Public property Speed: TAffineVector read FSpeed write FSpeed;

Runtime only

Published property UseGravity: Boolean read FUseGravity write FUseGravity;


GLSysHelp v.2.5: GLS.DynamicTexture

Unit GLS.DynamicTexture

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Types
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.TextureFormat
  • GLScene.Utils
  • GLS.Context
  • GLS.Texture
  • GLS.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDynamicTextureImage |


GLSysHelp v.2.5: GLS.DynamicTexture: Class TGLDynamicTextureImage

Class TGLDynamicTextureImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.DynamicTexture

Declaration

type TGLDynamicTextureImage = class(TGLBlankImage)

Description

Allows for fast updating of the texture at runtime

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLBlankImage
  • TGLDynamicTextureImage

Overview

Fields

Private | FUpdating: integer;
Private | FTexSize: integer;
Private | FBuffer: pointer;
Private | FPBO: TGLBufferObjectHandle;
Private | FData: pointer;
Private | FDirtyRect: TRect;
Private | FUseBGR: boolean;
Private | FUsePBO: boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure SetDirtyRectangle(const Value: TRect);
Private | procedure SetUsePBO(const Value: boolean);

Properties

Public | property Data: pointer read FData;
Public | property DirtyRectangle: TRect read FDirtyRect write SetDirtyRectangle;
Public | property UseBGR: boolean read FUseBGR write FUseBGR;
Public | property UsePBO: boolean read FUsePBO write SetUsePBO;

Description

Fields

Private FUpdating: integer;

This item has no description.

Private FTexSize: integer;

This item has no description.

Private FBuffer: pointer;

This item has no description.

Private FPBO: TGLBufferObjectHandle;

This item has no description.

Private FData: pointer;

This item has no description.

Private FDirtyRect: TRect;

This item has no description.

Private FUseBGR: boolean;

This item has no description.

Private FUsePBO: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public procedure BeginUpdate;

Must be called before using the Data pointer. Rendering context must be active!

Public procedure EndUpdate;

Must be called after data is changed. This will upload the new data

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure SetDirtyRectangle(const Value: TRect);

This item has no description.

Private procedure SetUsePBO(const Value: boolean);

This item has no description.

Properties

Public property Data: pointer read FData;

Pointer to buffer data. Will be nil outside a BeginUpdate / EndUpdate block

Public property DirtyRectangle: TRect read FDirtyRect write SetDirtyRectangle;

Marks the dirty rectangle inside the texture. BeginUpdate sets it to ((0, 0), (Width, Height)), ie the entire texture. Override it if you're only changing a small piece of the texture. Note that the Data pointer is relative to the DirtyRectangle, NOT the entire texture.

Public property UseBGR: boolean read FUseBGR write FUseBGR;

Indicates that the data is stored as BGR(A) instead of RGB(A). The default is BGR(A)

Public property UsePBO: boolean read FUsePBO write SetUsePBO;

Enables or disables use of a PBO. Default is true


GLSysHelp v.2.5: GLS.EllipseCollision

Unit GLS.EllipseCollision

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Octree
  • GLS.VectorLists

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TECPlane |
Record TECObjectInfo |
Record TECTriangle |
Record TECTriMesh |
Record TECFreeForm |
Record TECCollider |
Record TECContact |
Record TECCollisionPacket |
Record TECMovePack |

Functions and Procedures

function VectorDivide(const v, divider: TAffineVector): TAffineVector;
procedure CollideAndSlide(var MP: TECMovePack);
procedure CollideWithWorld(var MP: TECMovePack; pos, vel: TAffineVector; var HasCollided: Boolean);

Types

TECColliderList = array of TECCollider;
TECColliderShape = (...);
TECContactList = array of TECContact;
TECFreeFormList = array of TECFreeForm;
TECTriMeshList = array of TECTriMesh;

Constants

cECCloseDistance: Single = 0.005;

Variables

Debug_Tri: array of TECTriangle;

Description

Functions and Procedures

function VectorDivide(const v, divider: TAffineVector): TAffineVector;

This item has no description.

procedure CollideAndSlide(var MP: TECMovePack);

This item has no description.

procedure CollideWithWorld(var MP: TECMovePack; pos, vel: TAffineVector; var HasCollided: Boolean);

This item has no description.

Types

TECColliderList = array of TECCollider;

This item has no description.

TECColliderShape = (...);

This item has no description.

Values
  • csEllipsoid
  • csPoint
TECContactList = array of TECContact;

This item has no description.

TECFreeFormList = array of TECFreeForm;

This item has no description.

TECTriMeshList = array of TECTriMesh;

This item has no description.

Constants

cECCloseDistance: Single = 0.005;

This item has no description.

Variables

Debug_Tri: array of TECTriangle;

.$DEFINE DEBUG


GLSysHelp v.2.5: GLS.EllipseCollision: Class TECPlane

Class TECPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECPlane = class(TObject)

Description

The Ellipsoid collision class

Hierarchy

  • TObject
  • TECPlane

Overview

Fields

Public | Equation: array [0 .. 3] of Single;
Public | Origin: TAffineVector;
Public | Normal: TAffineVector;

Methods

Public | function isFrontFacingTo(const Direction: TAffineVector): Boolean;
Public | function signedDistanceTo(const Point: TAffineVector): Single;
Public | procedure MakePlane(const nOrigin, nNormal: TAffineVector); overload;
Public | procedure MakePlane(const p1, p2, p3: TAffineVector); overload;

Description

Fields

Public Equation: array [0 .. 3] of Single;

This item has no description.

Public Origin: TAffineVector;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Methods

Public function isFrontFacingTo(const Direction: TAffineVector): Boolean;

This item has no description.

Public function signedDistanceTo(const Point: TAffineVector): Single;

This item has no description.

Public procedure MakePlane(const nOrigin, nNormal: TAffineVector); overload;

This item has no description.

Public procedure MakePlane(const p1, p2, p3: TAffineVector); overload;


GLSysHelp v.2.5: GLS.EllipseCollision: Record TECObjectInfo

Record TECObjectInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECObjectInfo = record

Description

Object collision properties

Overview

Fields

Public | AbsoluteMatrix: TGLMatrix;
Public | Solid: Boolean;
Public | IsDynamic: Boolean;
Public | ObjectID: Integer;

Description

Fields

Public AbsoluteMatrix: TGLMatrix;

This item has no description.

Public Solid: Boolean;

This item has no description.

Public IsDynamic: Boolean;

This item has no description.

Public ObjectID: Integer;


GLSysHelp v.2.5: GLS.EllipseCollision: Record TECTriangle

Record TECTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECTriangle = record

Description

Ellipsoid collision Triangle

Overview

Fields

Public | p1: TAffineVector;
Public | p2: TAffineVector;
Public | p3: TAffineVector;

Description

Fields

Public p1: TAffineVector;

This item has no description.

Public p2: TAffineVector;

This item has no description.

Public p3: TAffineVector;


GLSysHelp v.2.5: GLS.EllipseCollision: Record TECTriMesh

Record TECTriMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECTriMesh = record

Description

Ellipsoid collision Mesh

Overview

Fields

Public | Triangles: array of TECTriangle;
Public | ObjectInfo: TECObjectInfo;

Description

Fields

Public Triangles: array of TECTriangle;

This item has no description.

Public ObjectInfo: TECObjectInfo;


GLSysHelp v.2.5: GLS.EllipseCollision: Record TECFreeForm

Record TECFreeForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECFreeForm = record

Description

Ellipsoid collision FreeForm

Overview

Fields

Public | OctreeNodes: array of PGLOctreeNode;
Public | triangleFiler: ˆTGLAffineVectorList;
Public | InvertedNormals: Boolean;
Public | ObjectInfo: TECObjectInfo;

Description

Fields

Public OctreeNodes: array of PGLOctreeNode;

This item has no description.

Public triangleFiler: ˆTGLAffineVectorList;

This item has no description.

Public InvertedNormals: Boolean;

This item has no description.

Public ObjectInfo: TECObjectInfo;


GLSysHelp v.2.5: GLS.EllipseCollision: Record TECCollider

Record TECCollider

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECCollider = record

Description

This item has no description.

Overview

Fields

Public | Position: TAffineVector;
Public | Radius: TAffineVector;
Public | Shape: TECColliderShape;
Public | ObjectInfo: TECObjectInfo;

Description

Fields

Public Position: TAffineVector;

This item has no description.

Public Radius: TAffineVector;

This item has no description.

Public Shape: TECColliderShape;

This item has no description.

Public ObjectInfo: TECObjectInfo;


GLSysHelp v.2.5: GLS.EllipseCollision: Record TECContact

Record TECContact

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECContact = record

Description

This item has no description.

Overview

Fields

Public | Position: TAffineVector;
Public | SurfaceNormal: TAffineVector;
Public | Distance: Single;
Public | ObjectInfo: TECObjectInfo;

Description

Fields

Public Position: TAffineVector;

Generated by the collision procedure

Public SurfaceNormal: TAffineVector;

This item has no description.

Public Distance: Single;

This item has no description.

Public ObjectInfo: TECObjectInfo;

Collider data


GLSysHelp v.2.5: GLS.EllipseCollision: Record TECCollisionPacket

Record TECCollisionPacket

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECCollisionPacket = record

Description

This item has no description.

Overview

Fields

Public | velocity: TAffineVector;
Public | normalizedVelocity: TAffineVector;
Public | basePoint: TAffineVector;
Public | foundCollision: Boolean;
Public | nearestDistance: Single;
Public | NearestObject: Integer;
Public | intersectionPoint: TAffineVector;
Public | intersectionNormal: TAffineVector;

Description

Fields

Public velocity: TAffineVector;

Information about the move being requested: (in eSpace)

Public normalizedVelocity: TAffineVector;

This item has no description.

Public basePoint: TAffineVector;

This item has no description.

Public foundCollision: Boolean;

Hit information

Public nearestDistance: Single;

This item has no description.

Public NearestObject: Integer;

This item has no description.

Public intersectionPoint: TAffineVector;

This item has no description.

Public intersectionNormal: TAffineVector;


GLSysHelp v.2.5: GLS.EllipseCollision: Record TECMovePack

Record TECMovePack

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EllipseCollision

Declaration

type TECMovePack = record

Description

This item has no description.

Overview

Fields

Public | TriMeshes: TECTriMeshList;
Public | Freeforms: TECFreeFormList;
Public | Colliders: TECColliderList;
Public | Position: TAffineVector;
Public | velocity: TAffineVector;
Public | Gravity: TAffineVector;
Public | Radius: TAffineVector;
Public | ObjectInfo: TECObjectInfo;
Public | CollisionRange: Single;
Public | UnitScale: Double;
Public | MaxRecursionDepth: Byte;
Public | CP: TECCollisionPacket;
Public | collisionRecursionDepth: Byte;
Public | ResultPos: TAffineVector;
Public | NearestObject: Integer;
Public | VelocityCollided: Boolean;
Public | GravityCollided: Boolean;
Public | GroundNormal: TAffineVector;
Public | Contacts: TECContactList

Description

Fields

Public TriMeshes: TECTriMeshList;

List of closest triangles

Public Freeforms: TECFreeFormList;

List of freeform octree nodes

Public Colliders: TECColliderList;

List of other colliders (f.i. ellipsoids)

Public Position: TAffineVector;

Movement params

Public velocity: TAffineVector;

This item has no description.

Public Gravity: TAffineVector;

This item has no description.

Public Radius: TAffineVector;

This item has no description.

Public ObjectInfo: TECObjectInfo;

This item has no description.

Public CollisionRange: Single;

This item has no description.

Public UnitScale: Double;

Stores the range where objects may collide Internal

Public MaxRecursionDepth: Byte;

This item has no description.

Public CP: TECCollisionPacket;

This item has no description.

Public collisionRecursionDepth: Byte;

This item has no description.

Public ResultPos: TAffineVector;

Result

Public NearestObject: Integer;

This item has no description.

Public VelocityCollided: Boolean;

This item has no description.

Public GravityCollided: Boolean;

This item has no description.

Public GroundNormal: TAffineVector;

This item has no description.

Public Contacts: TECContactList


GLSysHelp v.2.5: GLS.EParticleMasksManager

Unit GLS.EParticleMasksManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Types
  • System.SysUtils
  • System.Classes
  • System.Math
  • VCL.Graphics
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.Texture
  • GLS.Material
  • GLS.Scene
  • GLS.ParticleFX
  • GLS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLEParticleMask |
Class TGLEParticleMasks |
Class TGLEParticleMasksManager |

Types

TGLEProjectedParticleMask = (...);

Description

Types

TGLEProjectedParticleMask = (...);

This item has no description.

Values
  • pptXMask
  • pptYMask
  • pptZMask


GLSysHelp v.2.5: GLS.EParticleMasksManager: Class TGLEParticleMask

Class TGLEParticleMask

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EParticleMasksManager

Declaration

type TGLEParticleMask = class(TCollectionItem, IGLMaterialLibrarySupported)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLEParticleMask

Overview

Fields

Private | FName: string;
Private | FScale: TGLCoordinates;
Private | FPosition: TGLCoordinates;
Private | FYMask: TGLLibMaterialName;
Private | FZMask: TGLLibMaterialName;
Private | FXMask: TGLLibMaterialName;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FBackgroundColor: TColor;
Private | FMaskColor: TColor;
Private | FMaxX: Integer;
Private | FMaxY: Integer;
Private | FMaxZ: Integer;
Private | FMinX: Integer;
Private | FMinY: Integer;
Private | FMinZ: Integer;
Private | IXW: Integer;
Private | IXH: Integer;
Private | IYW: Integer;
Private | IYH: Integer;
Private | IZW: Integer;
Private | IZH: Integer;
Private | LX: Integer;
Private | LY: Integer;
Private | LZ: Integer;
Private | MX: Integer;
Private | MY: Integer;
Private | BogusMask: Boolean;
Private | BogusMaskX: Boolean;
Private | BogusMaskY: Boolean;
Private | BogusMaskZ: Boolean;
Private | FRollAngle: Single;
Private | FPitchAngle: Single;
Private | FTurnAngle: Single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Private | function XCan: TBitmap;
Private | function YCan: TBitmap;
Private | function ZCan: TBitmap;
Private | function _AddRef: Integer; stdcall;
Private | function _Release: Integer; stdcall;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GenerateMaskFromProjection(FromMask, ToMask: TGLEProjectedParticleMask; Depth: Integer);
Public | procedure Pitch(Angle: Single);
Public | procedure Roll(Angle: Single);
Public | procedure Turn(Angle: Single);
Public | procedure UpdateExtents;
Private | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);
Private | procedure SetName(const Value: string);
Private | procedure SetXMask(const Value: TGLLibMaterialName);
Private | procedure SetYMask(const Value: TGLLibMaterialName);
Private | procedure SetZMask(const Value: TGLLibMaterialName);

Properties

Published | property BackgroundColor: TColor read FBackgroundColor write FBackgroundColor;
Published | property MaskColor: TColor read FMaskColor write FMaskColor;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Name: string read FName write SetName;
Published | property PitchAngle: Single read FPitchAngle write FPitchAngle;
Published | property Position: TGLCoordinates read FPosition write FPosition;
Published | property RollAngle: Single read FRollAngle write FRollAngle;
Published | property Scale: TGLCoordinates read FScale write FScale;
Published | property TurnAngle: Single read FTurnAngle write FTurnAngle;
Published | property XMask: TGLLibMaterialName read FXMask write SetXMask;
Published | property YMask: TGLLibMaterialName read FYMask write SetYMask;
Published | property ZMask: TGLLibMaterialName read FZMask write SetZMask;

Description

Fields

Private FName: string;

This item has no description.

Private FScale: TGLCoordinates;

This item has no description.

Private FPosition: TGLCoordinates;

This item has no description.

Private FYMask: TGLLibMaterialName;

This item has no description.

Private FZMask: TGLLibMaterialName;

This item has no description.

Private FXMask: TGLLibMaterialName;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FBackgroundColor: TColor;

This item has no description.

Private FMaskColor: TColor;

This item has no description.

Private FMaxX: Integer;

This item has no description.

Private FMaxY: Integer;

This item has no description.

Private FMaxZ: Integer;

This item has no description.

Private FMinX: Integer;

This item has no description.

Private FMinY: Integer;

This item has no description.

Private FMinZ: Integer;

This item has no description.

Private IXW: Integer;

This item has no description.

Private IXH: Integer;

This item has no description.

Private IYW: Integer;

This item has no description.

Private IYH: Integer;

This item has no description.

Private IZW: Integer;

This item has no description.

Private IZH: Integer;

This item has no description.

Private LX: Integer;

This item has no description.

Private LY: Integer;

This item has no description.

Private LZ: Integer;

This item has no description.

Private MX: Integer;

This item has no description.

Private MY: Integer;

This item has no description.

Private BogusMask: Boolean;

This item has no description.

Private BogusMaskX: Boolean;

This item has no description.

Private BogusMaskY: Boolean;

This item has no description.

Private BogusMaskZ: Boolean;

This item has no description.

Private FRollAngle: Single;

we might have a pitch mask

Private FPitchAngle: Single;

This item has no description.

Private FTurnAngle: Single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

implementing IGLMaterialLibrarySupported

Private function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;

implementing IInterface

Private function XCan: TBitmap;

This item has no description.

Private function YCan: TBitmap;

This item has no description.

Private function ZCan: TBitmap;

This item has no description.

Private function _AddRef: Integer; stdcall;

This item has no description.

Private function _Release: Integer; stdcall;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure GenerateMaskFromProjection(FromMask, ToMask: TGLEProjectedParticleMask; Depth: Integer);

this generates a xmask from another mask just to fill gaps, depth is dependant on frommask width and height

Public procedure Pitch(Angle: Single);

This item has no description.

Public procedure Roll(Angle: Single);

This item has no description.

Public procedure Turn(Angle: Single);

This item has no description.

Public procedure UpdateExtents;

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

This item has no description.

Private procedure SetName(const Value: string);

This item has no description.

Private procedure SetXMask(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetYMask(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetZMask(const Value: TGLLibMaterialName);

This item has no description.

Properties

Published property BackgroundColor: TColor read FBackgroundColor write FBackgroundColor;

background color is the color that prevents particles from being positioned there

Published property MaskColor: TColor read FMaskColor write FMaskColor;

maskcolor is where particles are allowed to be positioned

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property Name: string read FName write SetName;

the reference name of the particle mask

Published property PitchAngle: Single read FPitchAngle write FPitchAngle;

This item has no description.

Published property Position: TGLCoordinates read FPosition write FPosition;

This item has no description.

Published property RollAngle: Single read FRollAngle write FRollAngle;

just the average angles for orientation

Published property Scale: TGLCoordinates read FScale write FScale;

scales and positions

Published property TurnAngle: Single read FTurnAngle write FTurnAngle;

This item has no description.

Published property XMask: TGLLibMaterialName read FXMask write SetXMask;

mask images, make sure materiallibrary is assigned

Published property YMask: TGLLibMaterialName read FYMask write SetYMask;

This item has no description.

Published property ZMask: TGLLibMaterialName read FZMask write SetZMask;


GLSysHelp v.2.5: GLS.EParticleMasksManager: Class TGLEParticleMasks

Class TGLEParticleMasks

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EParticleMasksManager

Declaration

type TGLEParticleMasks = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLEParticleMasks

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLEParticleMask;

Properties

Public property Items[Index: Integer]: TGLEParticleMask read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLEParticleMask;

This item has no description.

Properties

Public property Items[Index: Integer]: TGLEParticleMask read GetItems write SetItems;


GLSysHelp v.2.5: GLS.EParticleMasksManager: Class TGLEParticleMasksManager

Class TGLEParticleMasksManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.EParticleMasksManager

Declaration

type TGLEParticleMasksManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLEParticleMasksManager

Overview

Fields

Private FParticleMasks: TGLEParticleMasks;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticlePositionFromMask(MaskName: string): TVector3f;
Public | function ParticleMaskByName(MaskName: string): TGLEParticleMask;
Public | function TargetParticlePositionFromMask(TargetObject: TGLBaseSceneObject; MaskName: string): TVector3f;
Public | procedure SetParticlePositionFromMask(Particle: TGLParticle; MaskName: string);
Public | procedure SetParticlePositionFromMaskTarget(Particle: TGLParticle; MaskName: string; TargetObject: TGLBaseSceneObject);

Properties

Published property ParticleMasks: TGLEParticleMasks read FParticleMasks write FParticleMasks;

Description

Fields

Private FParticleMasks: TGLEParticleMasks;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateParticlePositionFromMask(MaskName: string): TVector3f;

This item has no description.

Public function ParticleMaskByName(MaskName: string): TGLEParticleMask;

This item has no description.

Public function TargetParticlePositionFromMask(TargetObject: TGLBaseSceneObject; MaskName: string): TVector3f;

This item has no description.

Public procedure SetParticlePositionFromMask(Particle: TGLParticle; MaskName: string);

This item has no description.

Public procedure SetParticlePositionFromMaskTarget(Particle: TGLParticle; MaskName: string; TargetObject: TGLBaseSceneObject);

This item has no description.

Properties

Published property ParticleMasks: TGLEParticleMasks read FParticleMasks write FParticleMasks;


GLSysHelp v.2.5: GLS.ExplosionFx

Unit GLS.ExplosionFx

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.Scene
  • GLS.VectorFileObjects
  • GLS.VectorLists
  • GLScene.XCollection
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLS.Context
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBExplosionFX |


GLSysHelp v.2.5: GLS.ExplosionFx: Class TGLBExplosionFX

Class TGLBExplosionFX

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ExplosionFx

Declaration

type TGLBExplosionFX = class(TGLObjectPreEffect)

Description

This item has no description. Showing description inherited from TGLObjectPreEffect.

An object effect that gets rendered before owner object's render. The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect
  • TGLObjectPreEffect
  • TGLBExplosionFX

Overview

Fields

Private | FTriList: TGLAffineVectorList;
Private | FRotList: TGLAffineVectorList;
Private | FDirList: TGLAffineVectorList;
Private | FPosList: TGLAffineVectorList;
Private | FEnabled: boolean;
Private | FFaceCount: integer;
Private | FSpeed: single;
Private | FDirection: TGLCoordinates;
Private | FMaxSteps: integer;
Private | FStep: integer;

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Render(var rci : TGLRenderContextInfo); override;
Public | procedure Reset;
Private | procedure SetDirection(value: TGLCoordinates);
Private | procedure SetDirList(Value: TGLAffineVectorList);
Private | procedure SetEnabled(value: boolean);
Private | procedure SetPosList(Value: TGLAffineVectorList);
Private | procedure SetRotList(Value: TGLAffineVectorList);
Private | procedure SetTriList(Value: TGLAffineVectorList);

Properties

Published | property Direction: TGLCoordinates read FDirection write SetDirection;
Public | property Enabled: boolean read FEnabled write SetEnabled;
Published | property MaxSteps: integer read FMaxSteps write FMaxSteps;
Published | property Speed: single read FSpeed write FSpeed;
Public | property Step: integer read FStep;

Description

Fields

Private FTriList: TGLAffineVectorList;

This item has no description.

Private FRotList: TGLAffineVectorList;

This item has no description.

Private FDirList: TGLAffineVectorList;

This item has no description.

Private FPosList: TGLAffineVectorList;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FFaceCount: integer;

This item has no description.

Private FSpeed: single;

This item has no description.

Private FDirection: TGLCoordinates;

This item has no description.

Private FMaxSteps: integer;

This item has no description.

Private FStep: integer;

This item has no description.

Methods

Public constructor Create(aOwner : TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Render(var rci : TGLRenderContextInfo); override;

This item has no description.

Public procedure Reset;

Resets the behaviour, so the information can be re-cached and the mesh can be exploded again

Private procedure SetDirection(value: TGLCoordinates);

This item has no description.

Private procedure SetDirList(Value: TGLAffineVectorList);

This item has no description.

Private procedure SetEnabled(value: boolean);

This item has no description.

Private procedure SetPosList(Value: TGLAffineVectorList);

This item has no description.

Private procedure SetRotList(Value: TGLAffineVectorList);

This item has no description.

Private procedure SetTriList(Value: TGLAffineVectorList);

This item has no description.

Properties

Published property Direction: TGLCoordinates read FDirection write SetDirection;

This item has no description.

Public property Enabled: boolean read FEnabled write SetEnabled;

This item has no description.

Published property MaxSteps: integer read FMaxSteps write FMaxSteps;

This item has no description.

Published property Speed: single read FSpeed write FSpeed;

This item has no description.

Public property Step: integer read FStep;


GLSysHelp v.2.5: GLS.Extrusion

Unit GLS.Extrusion

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.Context
  • GLS.Objects
  • GLS.Scene
  • GLS.MultiPolygon
  • GLS.Color
  • GLScene.VectorGeometry
  • GLS.RenderContextInfo
  • GLS.Nodes
  • GLS.State
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLRevolutionSolid |
Class TGLExtrusionSolid |
Class TGLPipeNode |
Class TGLPipeNodes |
Class TGLPipe |

Types

TGLExtrusionSolidPart = (...);
TGLExtrusionSolidParts = set of TGLExtrusionSolidPart;
TGLRevolutionSolidPart = (...);
TGLRevolutionSolidParts = set of TGLRevolutionSolidPart;
TPipeNodesColorMode = (...);
TPipeNormalMode = (...);
TPipePart = (...);
TPipeParts = set of TPipePart;
TPipeTexCoordMode = (...);

Description

Types

TGLExtrusionSolidPart = (...);

This item has no description.

Values
  • espOutside
  • espInside
  • espStartPolygon
  • espStopPolygon
TGLExtrusionSolidParts = set of TGLExtrusionSolidPart;

This item has no description.

TGLRevolutionSolidPart = (...);

This item has no description.

Values
  • rspOutside
  • rspInside
  • rspStartPolygon
  • rspStopPolygon
TGLRevolutionSolidParts = set of TGLRevolutionSolidPart;

This item has no description.

TPipeNodesColorMode = (...);

This item has no description.

Values
  • pncmNone
  • pncmEmission
  • pncmAmbient
  • pncmDiffuse
  • pncmAmbientAndDiffuse
TPipeNormalMode = (...);

This item has no description.

Values
  • pnmDefault
  • pnmAdvanced
TPipePart = (...);

This item has no description.

Values
  • ppOutside
  • ppInside
  • ppStartDisk
  • ppStopDisk
TPipeParts = set of TPipePart;

This item has no description.

TPipeTexCoordMode = (...);

This item has no description.

Values
  • ptcmDefault
  • ptcmManual


GLSysHelp v.2.5: GLS.Extrusion: Class TGLRevolutionSolid

Class TGLRevolutionSolid

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Extrusion

Declaration

type TGLRevolutionSolid = class(TGLPolygonBase)

Description

A solid object generated by rotating a curve along the Y axis. The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF). The TGLRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution. If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLRevolutionSolid

Overview

Fields

Private | FSlices: Integer;
Private | FStartAngle: Single;
Private | FStopAngle: Single;
Private | FNormals: TGLNormalSmoothing;
Private | FYOffsetPerTurn: Single;
Private | FTriangleCount: Integer;
Private | FNormalDirection: TGLNormalDirection;
Private | FParts: TGLRevolutionSolidParts;
Private | FAxisAlignedDimensionsCache: TGLVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure StructureChanged; override;

Properties

Published | property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TGLNormalSmoothing read FNormals write SetNormals default nsFlat;
Published | property Parts: TGLRevolutionSolidParts read FParts write SetParts default [rspOutside];
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StopAngle: Single read FStopAngle write SetStopAngle stored StoreStopAngle;
Public | property TriangleCount: Integer read FTriangleCount;
Published | property YOffsetPerTurn: Single read FYOffsetPerTurn write SetYOffsetPerTurn;

Description

Fields

Private FSlices: Integer;

This item has no description.

Private FStartAngle: Single;

This item has no description.

Private FStopAngle: Single;

This item has no description.

Private FNormals: TGLNormalSmoothing;

This item has no description.

Private FYOffsetPerTurn: Single;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FNormalDirection: TGLNormalDirection;

This item has no description.

Private FParts: TGLRevolutionSolidParts;

This item has no description.

Private FAxisAlignedDimensionsCache: TGLVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Normals: TGLNormalSmoothing read FNormals write SetNormals default nsFlat;

This item has no description.

Published property Parts: TGLRevolutionSolidParts read FParts write SetParts default [rspOutside];

Parts of the rotation solid to be generated for rendering. rspInside and rspOutside are generated from the curve and make the inside/outside as long as NormalDirection=ndOutside and the solid is described by the curve that goes from top to bottom. Start/StopPolygon are tesselated from the curve (considered as closed).

Published property Slices: Integer read FSlices write SetSlices default 16;

Number of slices per turn (360deg).

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property StopAngle: Single read FStopAngle write SetStopAngle stored StoreStopAngle;

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.

Published property YOffsetPerTurn: Single read FYOffsetPerTurn write SetYOffsetPerTurn;

Y offset applied to the curve position for each turn. This amount is applied proportionnally, for instance if your curve is a small circle, off from the Y axis, with a YOffset set to 0 (zero), you will get a torus, but with a non null value, you will get a small helicoidal spring. This can be useful for rendering, lots of helicoidal objects from screws, to nails to stairs etc.


GLSysHelp v.2.5: GLS.Extrusion: Class TGLExtrusionSolid

Class TGLExtrusionSolid

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Extrusion

Declaration

type TGLExtrusionSolid = class(TGLMultiPolygonBase)

Description

Extrudes a complex Polygon into Z direction. For contour description see TGLMultiPolygonBase. properties Parts, Height (or should we better cal it Depth, because its in Z?), Stacks, Normals and NormalDirection are equivalent to TGLRevolutionSolid. If Normals=nsSmooth and the angle between two consecutive normals along the contour is less than MinSmoothAngle, smoothing is done, otherweise flat normals are used. This makes it possible to have smooth normals on sharp edged contours.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMultiPolygonBase
  • TGLExtrusionSolid

Overview

Fields

Private | FStacks: Integer;
Private | FNormals: TGLNormalSmoothing;
Private | FTriangleCount: Integer;
Private | FNormalDirection: TGLNormalDirection;
Private | FParts: TGLExtrusionSolidParts;
Private | FHeight: TGLFloat;
Private | FMinSmoothAngle: Single;
Private | FMinSmoothAngleCos: Single;
Private | FAxisAlignedDimensionsCache: TGLVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure StructureChanged; override;
Private | procedure SetHeight(const Value: TGLFloat);
Private | procedure SetMinSmoothAngle(const Value: Single);

Properties

Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property MinSmoothAngle: Single read FMinSmoothAngle write SetMinSmoothAngle;
Published | property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TGLNormalSmoothing read FNormals write SetNormals default nsFlat;
Published | property Parts: TGLExtrusionSolidParts read FParts write SetParts default [espOutside];
Published | property Stacks: Integer read FStacks write SetStacks default 1;
Public | property TriangleCount: Integer read FTriangleCount;

Description

Fields

Private FStacks: Integer;

This item has no description.

Private FNormals: TGLNormalSmoothing;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FNormalDirection: TGLNormalDirection;

This item has no description.

Private FParts: TGLExtrusionSolidParts;

This item has no description.

Private FHeight: TGLFloat;

This item has no description.

Private FMinSmoothAngle: Single;

This item has no description.

Private FMinSmoothAngleCos: Single;

This item has no description.

Private FAxisAlignedDimensionsCache: TGLVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description. Showing description inherited from TGLMultiPolygonBase.Create.

property PNormal:PAffineVector read FPNormal;

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure StructureChanged; override;

This item has no description.

Private procedure SetHeight(const Value: TGLFloat);

This item has no description.

Private procedure SetMinSmoothAngle(const Value: Single);

This item has no description.

Properties

Published property Height: TGLFloat read FHeight write SetHeight;

This item has no description.

Published property MinSmoothAngle: Single read FMinSmoothAngle write SetMinSmoothAngle;

This item has no description.

Published property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Normals: TGLNormalSmoothing read FNormals write SetNormals default nsFlat;

This item has no description.

Published property Parts: TGLExtrusionSolidParts read FParts write SetParts default [espOutside];

This item has no description.

Published property Stacks: Integer read FStacks write SetStacks default 1;

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.


GLSysHelp v.2.5: GLS.Extrusion: Class TGLPipeNode

Class TGLPipeNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Extrusion

Declaration

type TGLPipeNode = class(TGLNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLNode
  • TGLPipeNode

Overview

Fields

Private | FRadiusFactor: Single;
Private | FColor: TGLColor;
Private | FTexCoordT: Single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Color: TGLColor read FColor write SetColor;
Published | property RadiusFactor: Single read FRadiusFactor write SetRadiusFactor stored StoreRadiusFactor;
Published | property TexCoordT: Single read FTexCoordT write FTexCoordT stored StoreTexCoordT;

Description

Fields

Private FRadiusFactor: Single;

This item has no description.

Private FColor: TGLColor;

This item has no description.

Private FTexCoordT: Single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Color: TGLColor read FColor write SetColor;

This item has no description.

Published property RadiusFactor: Single read FRadiusFactor write SetRadiusFactor stored StoreRadiusFactor;

This item has no description.

Published property TexCoordT: Single read FTexCoordT write FTexCoordT stored StoreTexCoordT;


GLSysHelp v.2.5: GLS.Extrusion: Class TGLPipeNodes

Class TGLPipeNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Extrusion

Declaration

type TGLPipeNodes = class(TGLLinesNodes)

Description

This item has no description. Showing description inherited from TGLLinesNodes.

Specialized collection for Nodes in a TGLLines objects. Stores TGLLinesNode items

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLNodes
  • TGLLinesNodes
  • TGLPipeNodes

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLPipeNode;
Public | function FindItemID(ID: Integer): TGLPipeNode;

Properties

Public property Items[index: Integer]: TGLPipeNode read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLPipeNode;

This item has no description.

Public function FindItemID(ID: Integer): TGLPipeNode;

This item has no description.

Properties

Public property Items[index: Integer]: TGLPipeNode read GetItems write SetItems;


GLSysHelp v.2.5: GLS.Extrusion: Class TGLPipe

Class TGLPipe

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Extrusion

Declaration

type TGLPipe = class(TGLPolygonBase)

Description

A solid object generated by extruding a circle along a trajectory. Texture coordinates NOT supported yet.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLPipe

Overview

Fields

Private | FSlices: Integer;
Private | FParts: TPipeParts;
Private | FTriangleCount: Integer;
Private | FRadius: Single;
Private | FNodesColorMode: TPipeNodesColorMode;
Private | FTextCoordMode: TPipeTexCoordMode;
Private | FTextCoordTileS: Single;
Private | FTextCoordTileT: Single;
Private | FNormalMode: TPipeNormalMode;
Private | FNormalSmoothAngle: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property NodesColorMode: TPipeNodesColorMode read FNodesColorMode write SetNodesColorMode default pncmNone;
Published | property NormalMode: TPipeNormalMode read FNormalMode write SetNormalMode default pnmDefault;
Published | property NormalSmoothAngle: Single read FNormalSmoothAngle write SetNormalSmoothAngle;
Published | property Parts: TPipeParts read FParts write SetParts default [ppOutside];
Published | property Radius: Single read FRadius write SetRadius;
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property TexCoordMode: TPipeTexCoordMode read FTextCoordMode write SetTextCoordMode default ptcmDefault;
Published | property TexCoordTileS: Single read FTextCoordTileS write SetTextCoordTileS stored StoreTextCoordTileS;
Published | property TexCoordTileT: Single read FTextCoordTileT write SetTextCoordTileT stored StoreTextCoordTileT;
Public | property TriangleCount: Integer read FTriangleCount;

Description

Fields

Private FSlices: Integer;

This item has no description.

Private FParts: TPipeParts;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FNodesColorMode: TPipeNodesColorMode;

This item has no description.

Private FTextCoordMode: TPipeTexCoordMode;

This item has no description.

Private FTextCoordTileS: Single;

This item has no description.

Private FTextCoordTileT: Single;

This item has no description.

Private FNormalMode: TPipeNormalMode;

This item has no description.

Private FNormalSmoothAngle: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property NodesColorMode: TPipeNodesColorMode read FNodesColorMode write SetNodesColorMode default pncmNone;

This item has no description.

Published property NormalMode: TPipeNormalMode read FNormalMode write SetNormalMode default pnmDefault;

This item has no description.

Published property NormalSmoothAngle: Single read FNormalSmoothAngle write SetNormalSmoothAngle;

This item has no description.

Published property Parts: TPipeParts read FParts write SetParts default [ppOutside];

This item has no description.

Published property Radius: Single read FRadius write SetRadius;

This item has no description.

Published property Slices: Integer read FSlices write SetSlices default 16;

This item has no description.

Published property TexCoordMode: TPipeTexCoordMode read FTextCoordMode write SetTextCoordMode default ptcmDefault;

This item has no description.

Published property TexCoordTileS: Single read FTextCoordTileS write SetTextCoordTileS stored StoreTextCoordTileS;

This item has no description.

Published property TexCoordTileT: Single read FTextCoordTileT write SetTextCoordTileT stored StoreTextCoordTileT;

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.


GLSysHelp v.2.5: GLS.FBORenderer

Unit GLS.FBORenderer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.TextureFormat
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.PersistentClasses
  • GLScene.PipelineTransform
  • GLS.Scene
  • GLS.Texture
  • GLS.Context
  • GLS.Color
  • GLS.Material
  • GLS.RenderContextInfo
  • GLS.State
  • GLS.MultiSampleImage
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLRenderbuffer |
Class TGLDepthRBO |
Class TGLStencilRBO |
Class TGLFrameBuffer |
Class TGLFBORenderer |

Types

TGLEnabledRenderBuffer = (...);
TGLEnabledRenderBuffers = set of TGLEnabledRenderBuffer;
TGLFBOClearOption = (...);
TGLFBOClearOptions = set of TGLFBOClearOption;
TGLFBOTargetVisibility = (...);
TGLStencilPrecision = (...);
TGLTextureArray = array of TGLTexture;
TSetTextureTargetsEvent = procedure(Sender : TObject; var colorTexs : TGLTextureArray) of object;

Constants

MaxColorAttachments = 32;

Description

Types

TGLEnabledRenderBuffer = (...);

———————– GLS.FBORenderer classes ————————–

Values
  • erbDepth
  • erbStencil
TGLEnabledRenderBuffers = set of TGLEnabledRenderBuffer;

This item has no description.

TGLFBOClearOption = (...);

This item has no description.

Values
  • coColorBufferClear
  • coDepthBufferClear
  • coStencilBufferClear
  • coUseBufferBackground
TGLFBOClearOptions = set of TGLFBOClearOption;

This item has no description.

TGLFBOTargetVisibility = (...);

This item has no description.

Values
  • tvDefault
  • tvFBOOnly
TGLStencilPrecision = (...);

This item has no description.

Values
  • spDefault
  • sp1bit
  • sp4bits
  • sp8bits
  • sp16bits
TGLTextureArray = array of TGLTexture;

This item has no description.

TSetTextureTargetsEvent = procedure(Sender : TObject; var colorTexs : TGLTextureArray) of object;

This item has no description.

Constants

MaxColorAttachments = 32;


GLSysHelp v.2.5: GLS.FBORenderer: Class TGLRenderbuffer

Class TGLRenderbuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FBORenderer

Declaration

type TGLRenderbuffer = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLRenderbuffer

Overview

Fields

Private | FRenderbufferHandle: TGLRenderbufferHandle;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FStorageValid: Boolean;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Private | function GetHandle: Cardinal;
Public | procedure Bind;
Public | procedure Unbind;
Private | procedure SetHeight(const Value: Integer);
Private | procedure SetWidth(const Value: Integer);

Properties

Public | property Handle: Cardinal read GetHandle;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Width: Integer read FWidth write SetWidth;

Description

Fields

Private FRenderbufferHandle: TGLRenderbufferHandle;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FStorageValid: Boolean;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetHandle: Cardinal;

This item has no description.

Public procedure Bind;

This item has no description.

Public procedure Unbind;

This item has no description.

Private procedure SetHeight(const Value: Integer);

This item has no description.

Private procedure SetWidth(const Value: Integer);

This item has no description.

Properties

Public property Handle: Cardinal read GetHandle;

Handle to the OpenGL render buffer object. If the handle hasn't already been allocated, it will be allocated by this call (ie. do not use if no OpenGL context is active!)

Public property Height: Integer read FHeight write SetHeight;

This item has no description.

Public property Width: Integer read FWidth write SetWidth;


GLSysHelp v.2.5: GLS.FBORenderer: Class TGLDepthRBO

Class TGLDepthRBO

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FBORenderer

Declaration

type TGLDepthRBO = class(TGLRenderbuffer)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLRenderbuffer
  • TGLDepthRBO

Overview

Fields

Private FDepthPrecision: TGLDepthPrecision;

Methods

Public | constructor Create;
Private | procedure SetDepthPrecision(const Value: TGLDepthPrecision);

Properties

Public property DepthPrecision: TGLDepthPrecision read FDepthPrecision write SetDepthPrecision;

Description

Fields

Private FDepthPrecision: TGLDepthPrecision;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Private procedure SetDepthPrecision(const Value: TGLDepthPrecision);

This item has no description.

Properties

Public property DepthPrecision: TGLDepthPrecision read FDepthPrecision write SetDepthPrecision;


GLSysHelp v.2.5: GLS.FBORenderer: Class TGLStencilRBO

Class TGLStencilRBO

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FBORenderer

Declaration

type TGLStencilRBO = class(TGLRenderbuffer)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLRenderbuffer
  • TGLStencilRBO

Overview

Fields

Private FStencilPrecision: TGLStencilPrecision;

Methods

Public | constructor Create;
Private | procedure SetStencilPrecision(const Value: TGLStencilPrecision);

Properties

Public property StencilPrecision: TGLStencilPrecision read FStencilPrecision write SetStencilPrecision;

Description

Fields

Private FStencilPrecision: TGLStencilPrecision;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Private procedure SetStencilPrecision(const Value: TGLStencilPrecision);

This item has no description.

Properties

Public property StencilPrecision: TGLStencilPrecision read FStencilPrecision write SetStencilPrecision;


GLSysHelp v.2.5: GLS.FBORenderer: Class TGLFrameBuffer

Class TGLFrameBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FBORenderer

Declaration

type TGLFrameBuffer = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLFrameBuffer

Overview

Fields

Private | FFrameBufferHandle: TGLFramebufferHandle;
Private | FTarget: Cardinal;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FLayer: Integer;
Private | FLevel: Integer;
Private | FTextureMipmap: cardinal;
Private | FAttachedTexture: array[0..MaxColorAttachments - 1] of TGLTexture;
Private | FDepthTexture: TGLTexture;
Private | FDRBO: TGLDepthRBO;
Private | FSRBO: TGLStencilRBO;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetStringStatus(out clarification: string): TGLFramebufferStatus;
Private | function GetStatus: TGLFramebufferStatus;
Public | procedure AttachDepthBuffer(DepthBuffer: TGLDepthRBO); overload;
Public | procedure AttachDepthTexture(Texture: TGLTexture); overload;
Public | procedure AttachStencilBuffer(StencilBuffer: TGLStencilRBO); overload;
Public | procedure AttachTexture(n: Cardinal; Texture: TGLTexture); overload;
Public | procedure Bind;
Public | procedure DetachDepthBuffer;
Public | procedure DetachDepthTexture;
Public | procedure DetachStencilBuffer;
Public | procedure DetachTexture(n: Cardinal);
Public | procedure PostRender(const PostGenerateMipmap: Boolean);
Public | procedure PreRender;
Public | procedure Render(var rci: TGLRenderContextInfo; baseObject: TGLBaseSceneObject);
Public | procedure Unbind;
Private | procedure SetHeight(const Value: Integer);
Private | procedure SetLayer(const Value: Integer);
Private | procedure SetLevel(const Value: Integer);
Private | procedure SetWidth(const Value: Integer);

Properties

Public | property Handle: TGLFramebufferHandle read FFrameBufferHandle;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Layer: Integer read FLayer write SetLayer;
Public | property Level: Integer read FLevel write SetLevel;
Public | property Status: TGLFramebufferStatus read GetStatus;
Public | property Width: Integer read FWidth write SetWidth;

Description

Fields

Private FFrameBufferHandle: TGLFramebufferHandle;

This item has no description.

Private FTarget: Cardinal;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FLayer: Integer;

This item has no description.

Private FLevel: Integer;

This item has no description.

Private FTextureMipmap: cardinal;

This item has no description.

Private FAttachedTexture: array[0..MaxColorAttachments - 1] of TGLTexture;

This item has no description.

Private FDepthTexture: TGLTexture;

This item has no description.

Private FDRBO: TGLDepthRBO;

This item has no description.

Private FSRBO: TGLStencilRBO;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetStringStatus(out clarification: string): TGLFramebufferStatus;

This item has no description.

Private function GetStatus: TGLFramebufferStatus;

This item has no description.

Public procedure AttachDepthBuffer(DepthBuffer: TGLDepthRBO); overload;

attaches a depth rbo to the fbo the depth buffer must have the same dimentions as the fbo

Public procedure AttachDepthTexture(Texture: TGLTexture); overload;

attaches a depth texture to the fbo the depth texture must have the same dimentions as the fbo

Public procedure AttachStencilBuffer(StencilBuffer: TGLStencilRBO); overload;

attaches a stencil rbo to the fbo the stencil buffer must have the same dimentions as the fbo

Public procedure AttachTexture(n: Cardinal; Texture: TGLTexture); overload;

This item has no description.

Public procedure Bind;

This item has no description.

Public procedure DetachDepthBuffer;

detaches depth attachment from the fbo

Public procedure DetachDepthTexture;

This item has no description.

Public procedure DetachStencilBuffer;

detaches stencil attachment from the fbo

Public procedure DetachTexture(n: Cardinal);

This item has no description.

Public procedure PostRender(const PostGenerateMipmap: Boolean);

This item has no description.

Public procedure PreRender;

This item has no description.

Public procedure Render(var rci: TGLRenderContextInfo; baseObject: TGLBaseSceneObject);

This item has no description.

Public procedure Unbind;

This item has no description.

Private procedure SetHeight(const Value: Integer);

This item has no description.

Private procedure SetLayer(const Value: Integer);

This item has no description.

Private procedure SetLevel(const Value: Integer);

This item has no description.

Private procedure SetWidth(const Value: Integer);

This item has no description.

Properties

Public property Handle: TGLFramebufferHandle read FFrameBufferHandle;

This item has no description.

Public property Height: Integer read FHeight write SetHeight;

This item has no description.

Public property Layer: Integer read FLayer write SetLayer;

This item has no description.

Public property Level: Integer read FLevel write SetLevel;

This item has no description.

Public property Status: TGLFramebufferStatus read GetStatus;

This item has no description.

Public property Width: Integer read FWidth write SetWidth;


GLSysHelp v.2.5: GLS.FBORenderer: Class TGLFBORenderer

Class TGLFBORenderer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FBORenderer

Declaration

type TGLFBORenderer = class(TGLBaseSceneObject, IGLMaterialLibrarySupported)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLFBORenderer

Overview

Fields

Private | FFbo: TGLFrameBuffer;
Private | FDepthRBO: TGLDepthRBO;
Private | FStencilRBO: TGLStencilRBO;
Private | FColorAttachment: Integer;
Private | FRendering: Boolean;
Private | FHasColor: Boolean;
Private | FHasDepth: Boolean;
Private | FHasStencil: Boolean;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FColorTextureName: TGLLibMaterialName;
Private | FDepthTextureName: TGLLibMaterialName;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FForceTextureDimensions: Boolean;
Private | FStencilPrecision: TGLStencilPrecision;
Private | FRootObject: TGLBaseSceneObject;
Private | FRootVisible: Boolean;
Private | FCamera: TGLCamera;
Private | FEnabledRenderBuffers: TGLEnabledRenderBuffers;
Private | FTargetVisibility: TGLFBOTargetVisibility;
Private | FBeforeRender: TGLDirectRenderEvent;
Private | FPostInitialize: TNotifyEvent;
Private | FAfterRender: TGLDirectRenderEvent;
Private | FPreInitialize: TNotifyEvent;
Private | FBackgroundColor: TGLColor;
Private | FClearOptions: TGLFBOClearOptions;
Private | FAspect: Single;
Private | FSceneScaleFactor: Single;
Private | FUseLibraryAsMultiTarget: Boolean;
Private | FPostGenerateMipmap: Boolean;
Private | FMaxSize: Integer;
Private | FMaxAttachment: Integer;
Private | FStoreCamera: array[0..2] of TGLVector;
Private | FOnSetTextureTargets: TSetTextureTargetsEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetLayer: Integer;
Private | function GetLevel: Integer;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function GetViewport: TRectangle;
Private | function StoreAspect: Boolean;
Private | function StoreSceneScaleFactor: Boolean;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf: Boolean; ARenderChildren: Boolean); override;
Private | procedure SetBackgroundColor(const Value: TGLColor);
Private | procedure SetCamera(const Value: TGLCamera);
Private | procedure SetColorTextureName(const Value: TGLLibMaterialName);
Private | procedure SetDepthTextureName(const Value: TGLLibMaterialName);
Private | procedure SetEnabledRenderBuffers(const Value: TGLEnabledRenderBuffers);
Private | procedure SetForceTextureDimentions(const Value: Boolean);
Private | procedure SetHeight(Value: Integer);
Private | procedure SetLayer(const Value: Integer);
Private | procedure SetLevel(const Value: Integer);
Private | procedure SetMaterialLibrary(const Value: TGLAbstractMaterialLibrary);
Private | procedure SetPostGenerateMipmap(const Value: Boolean);
Private | procedure SetRootObject(const Value: TGLBaseSceneObject);
Private | procedure SetStencilPrecision(const Value: TGLStencilPrecision);
Private | procedure SetTargetVisibility(const Value: TGLFBOTargetVisibility);
Private | procedure SetUseLibraryAsMultiTarget(Value: Boolean);
Private | procedure SetWidth(Value: Integer);

Properties

Published | property Active: Boolean read GetVisible write SetVisible default True;
Published | property AfterRender: TGLDirectRenderEvent read FAfterRender write FAfterRender;
Published | property Aspect: Single read FAspect write FAspect stored StoreAspect;
Published | property BackgroundColor: TGLColor read FBackgroundColor write SetBackgroundColor;
Published | property BeforeRender: TGLDirectRenderEvent read FBeforeRender write FBeforeRender;
Published | property Camera: TGLCamera read FCamera write SetCamera;
Published | property ClearOptions: TGLFBOClearOptions read FClearOptions write FClearOptions;
Published | property ColorTextureName: TGLLibMaterialName read FColorTextureName write SetColorTextureName;
Published | property DepthTextureName: TGLLibMaterialName read FDepthTextureName write SetDepthTextureName;
Published | property EnabledRenderBuffers: TGLEnabledRenderBuffers read FEnabledRenderBuffers write SetEnabledRenderBuffers;
Published | property ForceTextureDimensions: Boolean read FForceTextureDimensions write SetForceTextureDimentions default True;
Published | property Height: Integer read FHeight write SetHeight default 256;
Public | property Layer: Integer read GetLayer write SetLayer;
Public | property Level: Integer read GetLevel write SetLevel;
Published | property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;
Published | property OnSetTextureTargets: TSetTextureTargetsEvent read FOnSetTextureTargets write FOnSetTextureTargets;
Published | property PickableTarget: Boolean read GetPickable write SetPickable default False;
Published | property PostGenerateMipmap: Boolean read FPostGenerateMipmap write SetPostGenerateMipmap default True;
Published | property PostInitialize: TNotifyEvent read FPostInitialize write FPostInitialize;
Published | property PreInitialize: TNotifyEvent read FPreInitialize write FPreInitialize;
Published | property RootObject: TGLBaseSceneObject read FRootObject write SetRootObject;
Published | property SceneScaleFactor: Single read FSceneScaleFactor write FSceneScaleFactor stored StoreSceneScaleFactor;
Published | property StencilPrecision: TGLStencilPrecision read FStencilPrecision write SetStencilPrecision default spDefault;
Published | property TargetVisibility: TGLFBOTargetVisibility read FTargetVisibility write SetTargetVisibility default tvDefault;
Published | property UseLibraryAsMultiTarget: Boolean read FUseLibraryAsMultiTarget write SetUseLibraryAsMultiTarget default False;
Published | property Width: Integer read FWidth write SetWidth default 256;

Description

Fields

Private FFbo: TGLFrameBuffer;

This item has no description.

Private FDepthRBO: TGLDepthRBO;

This item has no description.

Private FStencilRBO: TGLStencilRBO;

This item has no description.

Private FColorAttachment: Integer;

This item has no description.

Private FRendering: Boolean;

This item has no description.

Private FHasColor: Boolean;

This item has no description.

Private FHasDepth: Boolean;

This item has no description.

Private FHasStencil: Boolean;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FColorTextureName: TGLLibMaterialName;

This item has no description.

Private FDepthTextureName: TGLLibMaterialName;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FForceTextureDimensions: Boolean;

This item has no description.

Private FStencilPrecision: TGLStencilPrecision;

This item has no description.

Private FRootObject: TGLBaseSceneObject;

This item has no description.

Private FRootVisible: Boolean;

This item has no description.

Private FCamera: TGLCamera;

This item has no description.

Private FEnabledRenderBuffers: TGLEnabledRenderBuffers;

This item has no description.

Private FTargetVisibility: TGLFBOTargetVisibility;

This item has no description.

Private FBeforeRender: TGLDirectRenderEvent;

This item has no description.

Private FPostInitialize: TNotifyEvent;

This item has no description.

Private FAfterRender: TGLDirectRenderEvent;

This item has no description.

Private FPreInitialize: TNotifyEvent;

This item has no description.

Private FBackgroundColor: TGLColor;

This item has no description.

Private FClearOptions: TGLFBOClearOptions;

This item has no description.

Private FAspect: Single;

This item has no description.

Private FSceneScaleFactor: Single;

This item has no description.

Private FUseLibraryAsMultiTarget: Boolean;

This item has no description.

Private FPostGenerateMipmap: Boolean;

This item has no description.

Private FMaxSize: Integer;

This item has no description.

Private FMaxAttachment: Integer;

This item has no description.

Private FStoreCamera: array[0..2] of TGLVector;

This item has no description.

Private FOnSetTextureTargets: TSetTextureTargetsEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetLayer: Integer;

This item has no description.

Private function GetLevel: Integer;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

implementing IGLMaterialLibrarySupported

Private function GetViewport: TRectangle;

This item has no description.

Private function StoreAspect: Boolean;

This item has no description.

Private function StoreSceneScaleFactor: Boolean;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf: Boolean; ARenderChildren: Boolean); override;

This item has no description.

Private procedure SetBackgroundColor(const Value: TGLColor);

This item has no description.

Private procedure SetCamera(const Value: TGLCamera);

This item has no description.

Private procedure SetColorTextureName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetDepthTextureName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetEnabledRenderBuffers(const Value: TGLEnabledRenderBuffers);

This item has no description.

Private procedure SetForceTextureDimentions(const Value: Boolean);

This item has no description.

Private procedure SetHeight(Value: Integer);

This item has no description.

Private procedure SetLayer(const Value: Integer);

This item has no description.

Private procedure SetLevel(const Value: Integer);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLAbstractMaterialLibrary);

This item has no description.

Private procedure SetPostGenerateMipmap(const Value: Boolean);

This item has no description.

Private procedure SetRootObject(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetStencilPrecision(const Value: TGLStencilPrecision);

This item has no description.

Private procedure SetTargetVisibility(const Value: TGLFBOTargetVisibility);

This item has no description.

Private procedure SetUseLibraryAsMultiTarget(Value: Boolean);

This item has no description.

Private procedure SetWidth(Value: Integer);

This item has no description.

Properties

Published property Active: Boolean read GetVisible write SetVisible default True;

This item has no description.

Published property AfterRender: TGLDirectRenderEvent read FAfterRender write FAfterRender;

called after the rendering to the FBO

Published property Aspect: Single read FAspect write FAspect stored StoreAspect;

This item has no description.

Published property BackgroundColor: TGLColor read FBackgroundColor write SetBackgroundColor;

This item has no description.

Published property BeforeRender: TGLDirectRenderEvent read FBeforeRender write FBeforeRender;

called before rendering to the FBO

Published property Camera: TGLCamera read FCamera write SetCamera;

Camera used for rendering to the FBO if not assigned, use the active view's camera

Published property ClearOptions: TGLFBOClearOptions read FClearOptions write FClearOptions;

This item has no description.

Published property ColorTextureName: TGLLibMaterialName read FColorTextureName write SetColorTextureName;

This item has no description.

Published property DepthTextureName: TGLLibMaterialName read FDepthTextureName write SetDepthTextureName;

This item has no description.

Published property EnabledRenderBuffers: TGLEnabledRenderBuffers read FEnabledRenderBuffers write SetEnabledRenderBuffers;

Enables the use of a render buffer if a texture is not assigned

Published property ForceTextureDimensions: Boolean read FForceTextureDimensions write SetForceTextureDimentions default True;

Force texture dimensions when initializing only works with TGLBlankImage and TGLFloatDataImage, otherwise does nothing

Published property Height: Integer read FHeight write SetHeight default 256;

This item has no description.

Public property Layer: Integer read GetLayer write SetLayer;

Layer (also cube map face) is activated only on the volume textures, texture array and cube map. You can select the layer during the drawing to.

Public property Level: Integer read GetLevel write SetLevel;

Mipmap Level where will be rendering

Published property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property OnSetTextureTargets: TSetTextureTargetsEvent read FOnSetTextureTargets write FOnSetTextureTargets;

Allows multiTargeting to different texture sources instead of all coming from one single MatLib with UseLibraryAsMultiTarget. OnSetTextureTargets overrides the other method of setting target textures via the MaterialLibrary, ColorTextureName and DepthTextureName propertes

Published property PickableTarget: Boolean read GetPickable write SetPickable default False;

This item has no description.

Published property PostGenerateMipmap: Boolean read FPostGenerateMipmap write SetPostGenerateMipmap default True;

Control mipmap generation after rendering texture must have MinFilter with mipmaping

Published property PostInitialize: TNotifyEvent read FPostInitialize write FPostInitialize;

Called after the FBO is initialized, but before any rendering the FBO is bound before calling this event

Published property PreInitialize: TNotifyEvent read FPreInitialize write FPreInitialize;

Called before the FBO is initialized the FBO is bound before calling this event

Published property RootObject: TGLBaseSceneObject read FRootObject write SetRootObject;

Root object used when rendering to the FBO if not assigned, uses itself as root and renders the child objects to the FBO

Published property SceneScaleFactor: Single read FSceneScaleFactor write FSceneScaleFactor stored StoreSceneScaleFactor;

Adjust the scene scale of the camera so that the rendering becomes independent of the width of the fbo renderer 0 = disabled

Published property StencilPrecision: TGLStencilPrecision read FStencilPrecision write SetStencilPrecision default spDefault;

use stencil buffer

Published property TargetVisibility: TGLFBOTargetVisibility read FTargetVisibility write SetTargetVisibility default tvDefault;

Determines if target is rendered to FBO only or rendered normally in FBO only mode, if RootObject is assigned, the RootObject's Visible flag is modified in default mode, if RootObject is not assigned, children are rendered normally after being rendered to the FBO

Published property UseLibraryAsMultiTarget: Boolean read FUseLibraryAsMultiTarget write SetUseLibraryAsMultiTarget default False;

This item has no description.

Published property Width: Integer read FWidth write SetWidth default 256;


GLSysHelp v.2.5: GLS.Feedback

Unit GLS.Feedback

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.PipelineTransform
  • GLS.PersistentClasses
  • GLS.VectorLists
  • GLS.Scene
  • GLS.VectorFileObjects
  • GLS.Texture
  • GLS.RenderContextInfo
  • GLS.Context
  • GLS.State
  • GLS.MeshUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFeedback |

Types

TGLFeedbackMode = (...);

Description

Types

TGLFeedbackMode = (...);

This item has no description.

Values
  • fm2D
  • fm3D
  • fm3DColor
  • fm3DColorTexture
  • fm4DColorTexture


GLSysHelp v.2.5: GLS.Feedback: Class TGLFeedback

Class TGLFeedback

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Feedback

Declaration

type TGLFeedback = class(TGLBaseSceneObject)

Description

An object encapsulating the OpenGL feedback rendering mode.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLFeedback

Overview

Fields

Private | FActive: Boolean;
Private | FBuffer: TGLSingleList;
Private | FMaxBufferSize: Cardinal;
Private | FBuffered: Boolean;
Private | FCorrectionScaling: Single;
Private | FMode: TGLFeedbackMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildMeshFromBuffer( Vertices: TGLAffineVectorList = nil; Normals: TGLAffineVectorList = nil; Colors: TGLVectorList = nil; TexCoords: TGLAffineVectorList = nil; VertexIndices: TGLIntegerList = nil);
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Active: Boolean read FActive write FActive;
Public | property Buffer: TGLSingleList read FBuffer;
Public | property Buffered: Boolean read FBuffered;
Public | property CorrectionScaling: Single read FCorrectionScaling;
Published | property MaxBufferSize: Cardinal read FMaxBufferSize write SetMaxBufferSize;
Published | property Mode: TGLFeedbackMode read FMode write SetMode;
Published | property Visible;

Description

Fields

Private FActive: Boolean;

This item has no description.

Private FBuffer: TGLSingleList;

This item has no description.

Private FMaxBufferSize: Cardinal;

This item has no description.

Private FBuffered: Boolean;

This item has no description.

Private FCorrectionScaling: Single;

This item has no description.

Private FMode: TGLFeedbackMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildMeshFromBuffer( Vertices: TGLAffineVectorList = nil; Normals: TGLAffineVectorList = nil; Colors: TGLVectorList = nil; TexCoords: TGLAffineVectorList = nil; VertexIndices: TGLIntegerList = nil);

Parse the the feedback buffer for polygon data and build a mesh into the assigned lists.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Active: Boolean read FActive write FActive;

Toggles the feedback rendering

Public property Buffer: TGLSingleList read FBuffer;

The feedback buffer

Public property Buffered: Boolean read FBuffered;

True when there is data in the buffer ready for parsing

Public property CorrectionScaling: Single read FCorrectionScaling;

Vertex positions in the buffer needs to be scaled by CorrectionScaling to get correct coordinates.

Published property MaxBufferSize: Cardinal read FMaxBufferSize write SetMaxBufferSize;

Maximum size allocated for the feedback buffer

Published property Mode: TGLFeedbackMode read FMode write SetMode;

The type of data that is collected in the feedback buffer

Published property Visible;


GLSysHelp v.2.5: GLS.File3DPDF

Unit GLS.File3DPDF

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • WinApi.Windows
  • WinApi.ShellAPI
  • System.Classes
  • System.SysUtils
  • System.StrUtils
  • GLScene.VectorTypes
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLIDTFVectorFile |
Class TGLU3DVectorFile |

Variables

IDTFConverterFileName: string;

Description

Variables

IDTFConverterFileName: string;

global variable for accing the IDTF->U3D converter


GLSysHelp v.2.5: GLS.File3DPDF: Class TGLIDTFVectorFile

Class TGLIDTFVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DPDF

Declaration

type TGLIDTFVectorFile = class(TGLVectorFile)

Description

The IDTF vector file (Intermediate Data Text File). Used for converting to IDTF -> U3D -> 3D PDF

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLIDTFVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure SaveToStream(aStream: TStream); override;
Private | procedure BuildNormals(m: TGLMeshObject);

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure SaveToStream(aStream: TStream); override;

This item has no description.

Private procedure BuildNormals(m: TGLMeshObject);


GLSysHelp v.2.5: GLS.File3DPDF: Class TGLU3DVectorFile

Class TGLU3DVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DPDF

Declaration

type TGLU3DVectorFile = class(TGLIDTFVectorFile)

Description

The U3D vector file (using IDTF and U3DConverter).

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLIDTFVectorFile
  • TGLU3DVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.File3DS

Unit GLS.File3DS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.Strings
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.Objects
  • GLS.VectorFileObjects
  • GLS.Texture
  • GLS.ApplicationFileIO
  • GLS.Context
  • GLS.PersistentClasses
  • GLS.File3DSSceneObjects
  • GLS.VectorLists
  • GLS.RenderContextInfo
  • GLS.Material
  • Formats.m3DS
  • Formats.m3DSTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLFile3DS |
Packed Record TGLFile3DSAnimationData |
Class TGLFile3DSAnimationKeys |
Class TGLFile3DSScaleAnimationKeys |
Class TGLFile3DSRotationAnimationKeys |
Class TGLFile3DSPositionAnimationKeys |
Class TGLFile3DSColorAnimationKeys |
Class TTGLFile3DSPositionAnimationKeys |
Class TGLFile3DSSpotLightCutOffAnimationKeys |
Class TGLFile3DSLightHotSpotAnimationKeys |
Class TGLFile3DSRollAnimationKeys |
Class TGLFile3DSAnimationKeyList |
Class TGLFile3DSDummyObject |
Class TGLFile3DSMeshObject |
Class TGLFile3DSOmniLightObject |
Class TGLFile3DSSpotLightObject |
Class TGLFile3DSCameraObject |
Class TGL3DSVectorFile |

Types

TGLFile3DSAnimKeysClassType = (...);

Variables

vGLFile3DS_UseTextureEx: Boolean = False;
vGLFile3DS_EnableAnimation: Boolean = False;
vGLFile3DS_FixDefaultUpAxisY: Boolean = False;
vGLFile3DS_LoadedStaticFrame: Integer = -1;

Description

Types

TGLFile3DSAnimKeysClassType = (...);

Used only for serialization. There probably is a more efficient way to do it.

Values
  • ctScale
  • ctRot
  • ctPos
  • ctCol
  • ctTPos
  • ctFall
  • ctHot
  • ctRoll

Variables

vGLFile3DS_UseTextureEx: Boolean = False;

If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.

vGLFile3DS_EnableAnimation: Boolean = False;

If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TGLFreeForm.AutoCentering does now work correctly. - TGLMeshObject.vertices return values different from TGLMeshObject.ExtractTriangles()

vGLFile3DS_FixDefaultUpAxisY: Boolean = False;

If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vGLFile3DS_EnableAnimation = true)

vGLFile3DS_LoadedStaticFrame: Integer = -1;

If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vGLFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.


GLSysHelp v.2.5: GLS.File3DS: Class EGLFile3DS

Class EGLFile3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type EGLFile3DS = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLFile3DS


GLSysHelp v.2.5: GLS.File3DS: Packed Record TGLFile3DSAnimationData

Packed Record TGLFile3DSAnimationData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSAnimationData = packed record

Description

A record that holds all the information that is used during 3ds animation.

Overview

Fields

Public | ModelMatrix: TGLMatrix;
Public | Color: TGLVector;
Public | TargetPos: TAffineVector;
Public | SpotLightCutOff: Single;
Public | HotSpot: Single;
Public | Roll: Single;

Description

Fields

Public ModelMatrix: TGLMatrix;

This item has no description.

Public Color: TGLVector;

This item has no description.

Public TargetPos: TAffineVector;

Omni Light.

Public SpotLightCutOff: Single;

Spot Light.

Public HotSpot: Single;

This item has no description.

Public Roll: Single;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSAnimationKeys

Class TGLFile3DSAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSAnimationKeys = class(TGLPersistentObject)

Description

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys

Overview

Fields

Private | FNumKeys: Integer;
Private | FKeys: array of TKeyHeader3DS;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); virtual; abstract;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); virtual;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;
Private | procedure InterpolateFrame(var I: Integer; var w: real; const AFrame: real);

Description

Fields

Private FNumKeys: Integer;

This item has no description.

Private FKeys: array of TKeyHeader3DS;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); virtual; abstract;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); virtual;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;

This item has no description.

Private procedure InterpolateFrame(var I: Integer; var w: real; const AFrame: real);


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSScaleAnimationKeys

Class TGLFile3DSScaleAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSScaleAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSScaleAnimationKeys

Overview

Fields

Private FScale: array of TAffineVector;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FScale: array of TAffineVector;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSRotationAnimationKeys

Class TGLFile3DSRotationAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSRotationAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSRotationAnimationKeys

Overview

Fields

Private FRot: array of TKFRotKey3DS;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FRot: array of TKFRotKey3DS;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSPositionAnimationKeys

Class TGLFile3DSPositionAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSPositionAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSPositionAnimationKeys

Overview

Fields

Private FPos: array of TAffineVector;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FPos: array of TAffineVector;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSColorAnimationKeys

Class TGLFile3DSColorAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSColorAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSColorAnimationKeys

Overview

Fields

Private FCol: array of TAffineVector;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FCol: array of TAffineVector;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TTGLFile3DSPositionAnimationKeys

Class TTGLFile3DSPositionAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TTGLFile3DSPositionAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys
  • TTGLFile3DSPositionAnimationKeys

Overview

Fields

Private FTPos: array of TAffineVector;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FTPos: array of TAffineVector;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSSpotLightCutOffAnimationKeys

Class TGLFile3DSSpotLightCutOffAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSSpotLightCutOffAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSSpotLightCutOffAnimationKeys

Overview

Fields

Private FFall: array of Single;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FFall: array of Single;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSLightHotSpotAnimationKeys

Class TGLFile3DSLightHotSpotAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSLightHotSpotAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSLightHotSpotAnimationKeys

Overview

Fields

Private FHot: array of Single;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FHot: array of Single;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSRollAnimationKeys

Class TGLFile3DSRollAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSRollAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSRollAnimationKeys

Overview

Fields

Private FRoll: array of Single;

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FRoll: array of Single;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: Integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSAnimationKeyList

Class TGLFile3DSAnimationKeyList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSAnimationKeyList = class(TGLPersistentObject)

Description

This item has no description.

Hierarchy

  • TGLPersistentObject
  • TGLFile3DSAnimationKeyList

Overview

Fields

Private FAnimKeysList: array of TGLFile3DSAnimationKeys;

Methods

Public | destructor Destroy; override;
Public | procedure AddKeys(const AItem: TGLFile3DSAnimationKeys);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ClearKeys;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FAnimKeysList: array of TGLFile3DSAnimationKeys;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public procedure AddKeys(const AItem: TGLFile3DSAnimationKeys);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ClearKeys;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSDummyObject

Class TGLFile3DSDummyObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSDummyObject = class(TGLMorphableMeshObject)

Description

A 3ds-specific TGLMorphableMeshObject.

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TGLMorphableMeshObject
  • TGLFile3DSDummyObject

Overview

Fields

Private | FAnimList: TGLFile3DSAnimationKeyList;
Private | FAnimData: Pointer;
Private | FRefTranf: TGLFile3DSAnimationData;
Private | FAnimTransf: TGLFile3DSAnimationData;
Private | FParent: TGLFile3DSDummyObject;
Private | FParentName: String64;
Private | FStatic: Boolean;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TGLAffineVectorList = nil; normals: TGLAffineVectorList = nil): TGLAffineVectorList; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GetExtents(out min, max: TAffineVector); override;
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single); override;
Public | procedure LoadAnimation(const AData: Pointer); virtual;
Public | procedure MorphTo(morphTargetIndex: Integer); override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); virtual;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Properties

Public | property AnimList: TGLFile3DSAnimationKeyList read FAnimList;
Public | property Parent: TGLFile3DSDummyObject read FParent write FParent;
Public | property RefrenceTransf: TGLFile3DSAnimationData read FRefTranf write FRefTranf;

Description

Fields

Private FAnimList: TGLFile3DSAnimationKeyList;

This item has no description.

Private FAnimData: Pointer;

This item has no description.

Private FRefTranf: TGLFile3DSAnimationData;

This item has no description.

Private FAnimTransf: TGLFile3DSAnimationData;

This item has no description.

Private FParent: TGLFile3DSDummyObject;

This item has no description.

Private FParentName: String64;

This item has no description.

Private FStatic: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ExtractTriangles(texCoords: TGLAffineVectorList = nil; normals: TGLAffineVectorList = nil): TGLAffineVectorList; override;

This item has no description. Showing description inherited from TGLBaseMeshObject.ExtractTriangles.

Extracts all mesh triangles as a triangles list. The resulting list size is a multiple of 3, each group of 3 vertices making up and independant triangle. The returned list can be used independantly from the mesh object (all data is duplicated) and should be freed by caller. If texCoords is specified, per vertex texture coordinates will be placed there, when available.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure GetExtents(out min, max: TAffineVector); override;

This item has no description. Showing description inherited from TGLMeshObject.GetExtents.

The extents of the object (min and max coordinates)

Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single); override;

This item has no description.

Public procedure LoadAnimation(const AData: Pointer); virtual;

Static tag used in BuildList to not apply animation matrix

Public procedure MorphTo(morphTargetIndex: Integer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure SetFrame(const AFrame: real); virtual;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property AnimList: TGLFile3DSAnimationKeyList read FAnimList;

This item has no description.

Public property Parent: TGLFile3DSDummyObject read FParent write FParent;

This item has no description.

Public property RefrenceTransf: TGLFile3DSAnimationData read FRefTranf write FRefTranf;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSMeshObject

Class TGLFile3DSMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSMeshObject = class(TGLFile3DSDummyObject)

Description

A 3ds-specific mesh object.

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TGLMorphableMeshObject
  • TGLFile3DSDummyObject
  • TGLFile3DSMeshObject

Overview

Methods

Public | procedure BuildList(var ARci: TGLRenderContextInfo); override;
Public | procedure LoadAnimation(const AData: Pointer); override;

Description

Methods

Public procedure BuildList(var ARci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLMeshObject.BuildList.

Similar to regular scene object's BuildList method

Public procedure LoadAnimation(const AData: Pointer); override;

This item has no description. Showing description inherited from TGLFile3DSDummyObject.LoadAnimation.

Static tag used in BuildList to not apply animation matrix


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSOmniLightObject

Class TGLFile3DSOmniLightObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSOmniLightObject = class(TGLFile3DSDummyObject)

Description

A 3ds-specific omni light.

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TGLMorphableMeshObject
  • TGLFile3DSDummyObject
  • TGLFile3DSOmniLightObject

Overview

Fields

Private | FLightSrc: TGLFile3DSLight;
Private | FLightSrcName: String64;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(const AOwner: TGLBaseMesh; const AData: PLight3DS); virtual;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FLightSrc: TGLFile3DSLight;

This item has no description.

Private FLightSrcName: String64;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadAnimation(const AData: Pointer); override;

This item has no description. Showing description inherited from TGLFile3DSDummyObject.LoadAnimation.

Static tag used in BuildList to not apply animation matrix

Public procedure LoadData(const AOwner: TGLBaseMesh; const AData: PLight3DS); virtual;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure SetFrame(const AFrame: real); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSSpotLightObject

Class TGLFile3DSSpotLightObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSSpotLightObject = class(TGLFile3DSOmniLightObject)

Description

A 3ds-specific spot light.

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TGLMorphableMeshObject
  • TGLFile3DSDummyObject
  • TGLFile3DSOmniLightObject
  • TGLFile3DSSpotLightObject

Overview

Methods

Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(const AOwner: TGLBaseMesh; const AData: PLight3DS); override;
Public | procedure SetFrame(const AFrame: real); override;

Description

Methods

Public procedure LoadAnimation(const AData: Pointer); override;

This item has no description. Showing description inherited from TGLFile3DSDummyObject.LoadAnimation.

Static tag used in BuildList to not apply animation matrix

Public procedure LoadData(const AOwner: TGLBaseMesh; const AData: PLight3DS); override;

This item has no description.

Public procedure SetFrame(const AFrame: real); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGLFile3DSCameraObject

Class TGLFile3DSCameraObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGLFile3DSCameraObject = class(TGLFile3DSDummyObject)

Description

A 3ds-specific camera.

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TGLMorphableMeshObject
  • TGLFile3DSDummyObject
  • TGLFile3DSCameraObject

Overview

Fields

Private | FTargetObj: TGLDummyCube;
Private | FCameraSrc: TGLFile3DSCamera;
Private | FCameraSrcName: String64;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(Owner: TGLBaseMesh; AData: PCamera3DS);
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Description

Fields

Private FTargetObj: TGLDummyCube;

This item has no description.

Private FCameraSrc: TGLFile3DSCamera;

This item has no description.

Private FCameraSrcName: String64;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure LoadAnimation(const AData: Pointer); override;

This item has no description. Showing description inherited from TGLFile3DSDummyObject.LoadAnimation.

Static tag used in BuildList to not apply animation matrix

Public procedure LoadData(Owner: TGLBaseMesh; AData: PCamera3DS);

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure SetFrame(const AFrame: real); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;


GLSysHelp v.2.5: GLS.File3DS: Class TGL3DSVectorFile

Class TGL3DSVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DS

Declaration

type TGL3DSVectorFile = class(TGLVectorFile)

Description

The 3DStudio vector file. Uses an upgraded version if a 3DS import library by Mike Lischke. (http://www.lishcke-online.de). A 3DS file may contain material information and require textures when loading.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGL3DSVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.File3DSSceneObjects

Unit GLS.File3DSSceneObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLS.OpenGLAdapter
  • GLScene.OpenGLTokens
  • GLS.PersistentClasses
  • GLS.Coordinates
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.Scene
  • GLS.VectorFileObjects
  • GLS.RenderContextInfo
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFile3DSLight |
Class TGLFile3DSCamera |
Class TGLFile3DSActor |
Class TGLFile3DSFreeForm |

Variables

vGLFile3DSSceneObjects_RenderCameraAndLights: Boolean = False;

Description

Variables

vGLFile3DSSceneObjects_RenderCameraAndLights: Boolean = False;


GLSysHelp v.2.5: GLS.File3DSSceneObjects: Class TGLFile3DSLight

Class TGLFile3DSLight

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DSSceneObjects

Declaration

type TGLFile3DSLight = class(TGLLightSource)

Description

This item has no description. Showing description inherited from TGLLightSource.

Standard light source. The standard GLScene light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle). Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property. Lightsources are managed in a specific object by the TGLScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLLightSource
  • TGLFile3DSLight

Overview

Fields

Private | FTargetPos: TGLCoordinates;
Private | FHotSpot: Single;
Private | FMultipler: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property HotSpot: Single read FHotSpot write FHotSpot;
Published | property Multipler: Single read FMultipler write FMultipler;
Published | property SpotTargetPos: TGLCoordinates read FTargetPos;

Description

Fields

Private FTargetPos: TGLCoordinates;

This item has no description.

Private FHotSpot: Single;

This item has no description.

Private FMultipler: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.CoordinateChanged.

Recalculate an orthonormal system

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property HotSpot: Single read FHotSpot write FHotSpot;

This item has no description.

Published property Multipler: Single read FMultipler write FMultipler;

This item has no description.

Published property SpotTargetPos: TGLCoordinates read FTargetPos;


GLSysHelp v.2.5: GLS.File3DSSceneObjects: Class TGLFile3DSCamera

Class TGLFile3DSCamera

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DSSceneObjects

Declaration

type TGLFile3DSCamera = class(TGLCamera)

Description

This item has no description. Showing description inherited from TGLCamera.

Camera object. This object is commonly referred by TGLSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCamera
  • TGLFile3DSCamera

Overview

Fields

Private | FTargetPos: TGLCoordinates;
Private | FQuadCyl: array[0..1] of PGLUquadric;
Private | FQuadDisk: array[0..1] of PGLUquadric;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property CameraTargetPos: TGLCoordinates read FTargetPos;
Published | property RollAngle;

Description

Fields

Private FTargetPos: TGLCoordinates;

This item has no description.

Private FQuadCyl: array[0..1] of PGLUquadric;

This item has no description.

Private FQuadDisk: array[0..1] of PGLUquadric;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.CoordinateChanged.

Recalculate an orthonormal system

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property CameraTargetPos: TGLCoordinates read FTargetPos;

This item has no description.

Published property RollAngle;


GLSysHelp v.2.5: GLS.File3DSSceneObjects: Class TGLFile3DSActor

Class TGLFile3DSActor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DSSceneObjects

Declaration

type TGLFile3DSActor = class(TGLActor)

Description

This item has no description. Showing description inherited from TGLActor.

Mesh class specialized in animated meshes. The TGLActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TGLAnimationController components).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLActor
  • TGLFile3DSActor

Overview

Methods

Private | procedure ReadMesh(Stream: TStream);
Private | procedure WriteMesh(Stream: TStream);

Description

Methods

Private procedure ReadMesh(Stream: TStream);

This item has no description.

Private procedure WriteMesh(Stream: TStream);


GLSysHelp v.2.5: GLS.File3DSSceneObjects: Class TGLFile3DSFreeForm

Class TGLFile3DSFreeForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.File3DSSceneObjects

Declaration

type TGLFile3DSFreeForm = class(TGLFreeForm)

Description

This item has no description. Showing description inherited from TGLFreeForm.

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLFreeForm
  • TGLFile3DSFreeForm

Overview

Fields

Private | FTransfMat: TGLMatrix;
Private | FScaleMat: TGLMatrix;
Private | ParentMatrix: TGLMatrix;
Private | FS_Rot3DS: TGLCoordinates4;
Private | FRot3DS: TGLCoordinates4;
Private | FScale3DS: TGLCoordinates4;
Public | FRefMat: TGLMatrix;

Methods

Public | constructor Create(AOWner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function BarycenterAbsolutePosition: TGLVector; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Private | procedure ReadMesh(Stream: TStream);
Private | procedure WriteMesh(Stream: TStream);

Properties

Published | property Rot3DS: TGLCoordinates4 read FRot3DS;
Published | property Scale3DS: TGLCoordinates4 read FScale3DS;
Published | property S_Rot3DS: TGLCoordinates4 read FS_Rot3DS;

Description

Fields

Private FTransfMat: TGLMatrix;

This item has no description.

Private FScaleMat: TGLMatrix;

This item has no description.

Private ParentMatrix: TGLMatrix;

This item has no description.

Private FS_Rot3DS: TGLCoordinates4;

This item has no description.

Private FRot3DS: TGLCoordinates4;

This item has no description.

Private FScale3DS: TGLCoordinates4;

This item has no description.

Public FRefMat: TGLMatrix;

This item has no description.

Methods

Public constructor Create(AOWner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function BarycenterAbsolutePosition: TGLVector; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.CoordinateChanged.

Recalculate an orthonormal system

Private procedure ReadMesh(Stream: TStream);

This item has no description.

Private procedure WriteMesh(Stream: TStream);

This item has no description.

Properties

Published property Rot3DS: TGLCoordinates4 read FRot3DS;

This item has no description.

Published property Scale3DS: TGLCoordinates4 read FScale3DS;

This item has no description.

Published property S_Rot3DS: TGLCoordinates4 read FS_Rot3DS;


GLSysHelp v.2.5: GLS.FileASE

Unit GLS.FileASE

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.Texture
  • GLS.Material
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLASEFaceTexure |
Record TGLASEFaceTexureChannels |
Record TGLASESmoothingGroups |
Class TGLASEFace |
Class TGLASEFaceList |
Class TGLASEMeshObject |
Record TGLASEMaterialTextureMap |
Record TGLASEMaterialTextureMaps |
Record TGLASESubMaterial |
Record TGLASESubMaterialList |
Class TGLASEMaterial |
Class TGLASEMaterialList |
Class TGLASEVectorFile |

Functions and Procedures

procedure ASESetPreferredTexture(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);
procedure ASESetPreferredLightmap(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);

Types

TASETextureMap = (...);

Constants

GL_ASE_MAX_TEXURE_CHANNELS = 12;
GL_ASE_MAX_SUBMATERIALS = 5;
GL_ASE_MAX_SMOOTH_GROUPS = 5;
GL_ASE_MAX_TEXTURE_MAPS = 12;

Description

Functions and Procedures

procedure ASESetPreferredTexture(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);

use this functions to select texture and lightmap from ASE file aSubMaterialIndex = -1 - means main material maps Default are: Texture - main material Diffuse map Lightmap - main material Ambient map

procedure ASESetPreferredLightmap(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);

This item has no description.

Types

TASETextureMap = (...);

This item has no description.

Values
  • tmGeneric
  • tmAmbient
  • tmDiffuse
  • tmSpecular
  • tmShine
  • tmShinestrength
  • tmSelfillum
  • tmOpacity
  • tmFiltercolor
  • tmBump
  • tmReflect
  • tmRefract

Constants

GL_ASE_MAX_TEXURE_CHANNELS = 12;

This item has no description.

GL_ASE_MAX_SUBMATERIALS = 5;

maximum texture channels

GL_ASE_MAX_SMOOTH_GROUPS = 5;

maximum material submaterials

GL_ASE_MAX_TEXTURE_MAPS = 12;

maximum smoothing groups


GLSysHelp v.2.5: GLS.FileASE: Record TGLASEFaceTexure

Record TGLASEFaceTexure

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEFaceTexure = record

Description

maximum texture maps face texture channel indices

Overview

Fields

Public | Idx0: Integer;
Public | Idx1: Integer;
Public | Idx2: Integer;

Description

Fields

Public Idx0: Integer;

This item has no description.

Public Idx1: Integer;

This item has no description.

Public Idx2: Integer;


GLSysHelp v.2.5: GLS.FileASE: Record TGLASEFaceTexureChannels

Record TGLASEFaceTexureChannels

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEFaceTexureChannels = record

Description

face texture channels

Overview

Fields

Public | Count: Integer;
Public | ChanelTexture: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TGLASEFaceTexure;

Description

Fields

Public Count: Integer;

This item has no description.

Public ChanelTexture: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TGLASEFaceTexure;


GLSysHelp v.2.5: GLS.FileASE: Record TGLASESmoothingGroups

Record TGLASESmoothingGroups

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASESmoothingGroups = record

Description

This item has no description.

Overview

Fields

Public | Count: Integer;
Public | Groups: array [0..GL_ASE_MAX_SMOOTH_GROUPS] of Integer;

Description

Fields

Public Count: Integer;

This item has no description.

Public Groups: array [0..GL_ASE_MAX_SMOOTH_GROUPS] of Integer;


GLSysHelp v.2.5: GLS.FileASE: Class TGLASEFace

Class TGLASEFace

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEFace = class(TObject)

Description

ASE mesh face

Hierarchy

  • TObject
  • TGLASEFace

Overview

Fields

Private | FV: array [0..2] of Integer;
Private | FNormal: TAffineVector;
Private | FN: array [0..2] of TAffineVector;
Private | FSmoothing: TGLASESmoothingGroups;
Private | FSubMaterialID: Integer;
Private | FTextChannels: TGLASEFaceTexureChannels;

Methods

Public constructor Create;

Properties

Public | property Normal: TAffineVector read FNormal;
Public | property Normal1: TAffineVector read FN[0];
Public | property Normal2: TAffineVector read FN[1];
Public | property Normal3: TAffineVector read FN[2];
Public | property Smoothing: TGLASESmoothingGroups read FSmoothing;
Public | property SubMaterialID: Integer read FSubMaterialID;
Public | property TextChannels: TGLASEFaceTexureChannels read FTextChannels;
Public | property VertIdx1: Integer read FV[0];
Public | property VertIdx2: Integer read FV[1];
Public | property VertIdx3: Integer read FV[2];

Description

Fields

Private FV: array [0..2] of Integer;

This item has no description.

Private FNormal: TAffineVector;

This item has no description.

Private FN: array [0..2] of TAffineVector;

This item has no description.

Private FSmoothing: TGLASESmoothingGroups;

This item has no description.

Private FSubMaterialID: Integer;

This item has no description.

Private FTextChannels: TGLASEFaceTexureChannels;

submaterial ID

Methods

Public constructor Create;

This item has no description.

Properties

Public property Normal: TAffineVector read FNormal;

vertex 2 index

Public property Normal1: TAffineVector read FN[0];

face normal

Public property Normal2: TAffineVector read FN[1];

vertex 0 normal

Public property Normal3: TAffineVector read FN[2];

vertex 1 normal

Public property Smoothing: TGLASESmoothingGroups read FSmoothing;

channels texture coordinates

Public property SubMaterialID: Integer read FSubMaterialID;

smoothing group list

Public property TextChannels: TGLASEFaceTexureChannels read FTextChannels;

vertex 2 normal

Public property VertIdx1: Integer read FV[0];

This item has no description.

Public property VertIdx2: Integer read FV[1];

vertex 0 index

Public property VertIdx3: Integer read FV[2];

vertex 1 index


GLSysHelp v.2.5: GLS.FileASE: Class TGLASEFaceList

Class TGLASEFaceList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEFaceList = class(TObject)

Description

ASE mesh faces list

Hierarchy

  • TObject
  • TGLASEFaceList

Overview

Fields

Private FItems: TList;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Add: TGLASEFace;
Private | function GetCount: Integer;
Private | function GetFace(Index: Integer): TGLASEFace;
Public | procedure Clear;
Public | procedure Delete(aIndex: Integer);

Properties

Public | property Count: Integer read GetCount;
Public | property Face[Index: Integer]: TGLASEFace read GetFace;

Description

Fields

Private FItems: TList;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add: TGLASEFace;

This item has no description.

Private function GetCount: Integer;

This item has no description.

Private function GetFace(Index: Integer): TGLASEFace;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(aIndex: Integer);

This item has no description.

Properties

Public property Count: Integer read GetCount;

This item has no description.

Public property Face[Index: Integer]: TGLASEFace read GetFace;


GLSysHelp v.2.5: GLS.FileASE: Class TGLASEMeshObject

Class TGLASEMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEMeshObject = class(TObject)

Description

ASE geom object, represents single mesh object; contains: vertices, faces, verice indices, faces and vertices normals, channels of texture coordinates and indices, scaling and location info; this object used only to store ASE data temporary to copy supported piece of it into GLScene TGLMeshObject

Hierarchy

  • TObject
  • TGLASEMeshObject

Overview

Fields

Private | FFaces: TGLASEFaceList;
Private | FVertices: TGLAffineVectorList;
Private | FMatrix: TGLMatrix;
Private | FInheritedPosition: TAffineVector;
Private | FInheritedScale: TAffineVector;
Private | FInheritedRotation: TAffineVector;
Private | FRotationAngle: Single;
Private | FRotationAxis: TAffineVector;
Private | FPosition: TGLVector;
Private | FScale: TAffineVector;
Private | FScaleAxisAngle: Single;
Private | FScaleAxis: TAffineVector;
Private | FTexChannels: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TGLAffineVectorList;
Private | FTexChannelsCount: Integer;
Private | FHasNormals: Boolean;
Private | FMaterialID: Integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Private | function AddTexChannel: TGLAffineVectorList;
Private | function GetTextChannel(Channel: Integer): TGLAffineVectorList;

Properties

Public | property Faces: TGLASEFaceList read FFaces;
Public | property HasNormals: Boolean read FHasNormals;
Public | property InheritedPosition: TAffineVector read FInheritedPosition;
Public | property InheritedRotation: TAffineVector read FInheritedRotation;
Public | property InheritedScale: TAffineVector read FInheritedScale;
Public | property MaterialID: Integer read FMaterialID;
Public | property Matrix: TGLMatrix read FMatrix;
Public | property Position: TGLVector read FPosition;
Public | property RotationAngle: Single read FRotationAngle;
Public | property RotationAxis: TAffineVector read FRotationAxis;
Public | property Scale: TAffineVector read FScale;
Public | property ScaleAxis: TAffineVector read FScaleAxis;
Public | property ScaleAxisAngle: Single read FScaleAxisAngle;
Public | property TextChannel[Channel: Integer]: TGLAffineVectorList read GetTextChannel;
Public | property TextChannelsCount: Integer read FTexChannelsCount;
Public | property Vertices: TGLAffineVectorList read FVertices;

Description

Fields

Private FFaces: TGLASEFaceList;

This item has no description.

Private FVertices: TGLAffineVectorList;

This item has no description.

Private FMatrix: TGLMatrix;

This item has no description.

Private FInheritedPosition: TAffineVector;

This item has no description.

Private FInheritedScale: TAffineVector;

This item has no description.

Private FInheritedRotation: TAffineVector;

This item has no description.

Private FRotationAngle: Single;

This item has no description.

Private FRotationAxis: TAffineVector;

This item has no description.

Private FPosition: TGLVector;

This item has no description.

Private FScale: TAffineVector;

This item has no description.

Private FScaleAxisAngle: Single;

This item has no description.

Private FScaleAxis: TAffineVector;

This item has no description.

Private FTexChannels: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TGLAffineVectorList;

This item has no description.

Private FTexChannelsCount: Integer;

This item has no description.

Private FHasNormals: Boolean;

This item has no description.

Private FMaterialID: Integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function AddTexChannel: TGLAffineVectorList;

This item has no description.

Private function GetTextChannel(Channel: Integer): TGLAffineVectorList;

This item has no description.

Properties

Public property Faces: TGLASEFaceList read FFaces;

This item has no description.

Public property HasNormals: Boolean read FHasNormals;

This item has no description.

Public property InheritedPosition: TAffineVector read FInheritedPosition;

This item has no description.

Public property InheritedRotation: TAffineVector read FInheritedRotation;

This item has no description.

Public property InheritedScale: TAffineVector read FInheritedScale;

This item has no description.

Public property MaterialID: Integer read FMaterialID;

This item has no description.

Public property Matrix: TGLMatrix read FMatrix;

This item has no description.

Public property Position: TGLVector read FPosition;

This item has no description.

Public property RotationAngle: Single read FRotationAngle;

This item has no description.

Public property RotationAxis: TAffineVector read FRotationAxis;

This item has no description.

Public property Scale: TAffineVector read FScale;

This item has no description.

Public property ScaleAxis: TAffineVector read FScaleAxis;

This item has no description.

Public property ScaleAxisAngle: Single read FScaleAxisAngle;

This item has no description.

Public property TextChannel[Channel: Integer]: TGLAffineVectorList read GetTextChannel;

This item has no description.

Public property TextChannelsCount: Integer read FTexChannelsCount;

This item has no description.

Public property Vertices: TGLAffineVectorList read FVertices;


GLSysHelp v.2.5: GLS.FileASE: Record TGLASEMaterialTextureMap

Record TGLASEMaterialTextureMap

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEMaterialTextureMap = record

Description

This item has no description.

Overview

Fields

Public | Kind: string;
Public | Name: string;
Public | _Class: string;
Public | No: Integer;
Public | Amount: Single;
Public | Bitmap: string;
Public | UOffset: Single;
Public | VOffset: Single;
Public | UTiling: Single;
Public | VTiling: Single;
Public | Angle: Single;
Public | Blur: Single;
Public | BlurOffset: Single;
Public | NouseAmount: Single;
Public | NoiseSize: Single;
Public | NoiseLevel: Integer;
Public | NoisePhase: Single;

Description

Fields

Public Kind: string;

This item has no description.

Public Name: string;

This item has no description.

Public _Class: string;

This item has no description.

Public No: Integer;

This item has no description.

Public Amount: Single;

This item has no description.

Public Bitmap: string;

This item has no description.

Public UOffset: Single;

This item has no description.

Public VOffset: Single;

This item has no description.

Public UTiling: Single;

This item has no description.

Public VTiling: Single;

This item has no description.

Public Angle: Single;

This item has no description.

Public Blur: Single;

This item has no description.

Public BlurOffset: Single;

This item has no description.

Public NouseAmount: Single;

This item has no description.

Public NoiseSize: Single;

This item has no description.

Public NoiseLevel: Integer;

This item has no description.

Public NoisePhase: Single;


GLSysHelp v.2.5: GLS.FileASE: Record TGLASEMaterialTextureMaps

Record TGLASEMaterialTextureMaps

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEMaterialTextureMaps = record

Description

This item has no description.

Overview

Fields

Public | Map: array [0..GL_ASE_MAX_TEXTURE_MAPS - 1] of TGLASEMaterialTextureMap;
Public | Count: Integer;

Description

Fields

Public Map: array [0..GL_ASE_MAX_TEXTURE_MAPS - 1] of TGLASEMaterialTextureMap;

This item has no description.

Public Count: Integer;


GLSysHelp v.2.5: GLS.FileASE: Record TGLASESubMaterial

Record TGLASESubMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASESubMaterial = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | Ambient: TAffineVector;
Public | Diffuse: TAffineVector;
Public | Specular: TAffineVector;
Public | Shiness: Single;
Public | ShineStrength: Single;
Public | Transparency: Single;
Public | WireSize: Single;
Public | SelfIllumination: Single;
Public | TextureMaps: TGLASEMaterialTextureMaps;

Description

Fields

Public Name: string;

This item has no description.

Public Ambient: TAffineVector;

This item has no description.

Public Diffuse: TAffineVector;

This item has no description.

Public Specular: TAffineVector;

This item has no description.

Public Shiness: Single;

This item has no description.

Public ShineStrength: Single;

This item has no description.

Public Transparency: Single;

This item has no description.

Public WireSize: Single;

This item has no description.

Public SelfIllumination: Single;

This item has no description.

Public TextureMaps: TGLASEMaterialTextureMaps;


GLSysHelp v.2.5: GLS.FileASE: Record TGLASESubMaterialList

Record TGLASESubMaterialList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASESubMaterialList = record

Description

This item has no description.

Overview

Fields

Public | SubMaterial: array [0..GL_ASE_MAX_SUBMATERIALS - 1] of TGLASESubMaterial;
Public | Count: Integer;

Description

Fields

Public SubMaterial: array [0..GL_ASE_MAX_SUBMATERIALS - 1] of TGLASESubMaterial;

This item has no description.

Public Count: Integer;


GLSysHelp v.2.5: GLS.FileASE: Class TGLASEMaterial

Class TGLASEMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEMaterial = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLASEMaterial

Overview

Fields

Private | FWireSize: Single;
Private | FShineStrength: Single;
Private | FShiness: Single;
Private | FTransparency: Single;
Private | FName: string;
Private | FDiffuse: TAffineVector;
Private | FAmbient: TAffineVector;
Private | FSpecular: TAffineVector;
Private | FSubMaterials: TGLASESubMaterialList;
Private | FTextureMaps: TGLASEMaterialTextureMaps;

Methods

Public constructor Create;

Properties

Public | property Ambient: TAffineVector read FAmbient;
Public | property Diffuse: TAffineVector read FDiffuse;
Public | property Name: string read FName;
Public | property Shiness: Single read FShiness;
Public | property ShineStrength: Single read FShineStrength;
Public | property Specular: TAffineVector read FSpecular;
Public | property SubMaterials: TGLASESubMaterialList read FSubMaterials;
Public | property TextureMaps: TGLASEMaterialTextureMaps read FTextureMaps;
Public | property Transparency: Single read FTransparency;
Public | property WireSize: Single read FWireSize;

Description

Fields

Private FWireSize: Single;

This item has no description.

Private FShineStrength: Single;

This item has no description.

Private FShiness: Single;

This item has no description.

Private FTransparency: Single;

This item has no description.

Private FName: string;

This item has no description.

Private FDiffuse: TAffineVector;

This item has no description.

Private FAmbient: TAffineVector;

This item has no description.

Private FSpecular: TAffineVector;

This item has no description.

Private FSubMaterials: TGLASESubMaterialList;

This item has no description.

Private FTextureMaps: TGLASEMaterialTextureMaps;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Properties

Public property Ambient: TAffineVector read FAmbient;

This item has no description.

Public property Diffuse: TAffineVector read FDiffuse;

This item has no description.

Public property Name: string read FName;

This item has no description.

Public property Shiness: Single read FShiness;

This item has no description.

Public property ShineStrength: Single read FShineStrength;

This item has no description.

Public property Specular: TAffineVector read FSpecular;

This item has no description.

Public property SubMaterials: TGLASESubMaterialList read FSubMaterials;

This item has no description.

Public property TextureMaps: TGLASEMaterialTextureMaps read FTextureMaps;

This item has no description.

Public property Transparency: Single read FTransparency;

This item has no description.

Public property WireSize: Single read FWireSize;


GLSysHelp v.2.5: GLS.FileASE: Class TGLASEMaterialList

Class TGLASEMaterialList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEMaterialList = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLASEMaterialList

Overview

Fields

Private FItems: TList;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Add: TGLASEMaterial;
Private | function GetCount: Integer;
Private | function GetMaterial(Index: Integer): TGLASEMaterial;
Public | procedure Clear;
Public | procedure Delete(aIndex: Integer);

Properties

Public | property Count: Integer read GetCount;
Public | property Material[Index: Integer]: TGLASEMaterial read GetMaterial;

Description

Fields

Private FItems: TList;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add: TGLASEMaterial;

This item has no description.

Private function GetCount: Integer;

This item has no description.

Private function GetMaterial(Index: Integer): TGLASEMaterial;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(aIndex: Integer);

This item has no description.

Properties

Public property Count: Integer read GetCount;

This item has no description.

Public property Material[Index: Integer]: TGLASEMaterial read GetMaterial;


GLSysHelp v.2.5: GLS.FileASE: Class TGLASEVectorFile

Class TGLASEVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileASE

Declaration

type TGLASEVectorFile = class(TGLVectorFile)

Description

ASE vector file parser

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLASEVectorFile

Overview

Fields

Private | FStringData: TStringList;
Private | FHeader: string;
Private | FComment: string;
Private | FRECVShadow: Boolean;
Private | FCastShadow: Boolean;
Private | FMotionBlur: Boolean;
Private | FMaterialList: TGLASEMaterialList;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function Capabilities: TGLDataFileCapabilities; override;
Private | function CheckTextureMap(var aLineIndex: Integer; var aMaps: TGLASEMaterialTextureMaps): Boolean;
Private | function CheckUnknownData(var aLineIndex: Integer): Boolean;
Private | function ContainString(const aData, aString: string): Boolean;
Private | function GetDoubleValue(const aData: string): Double;
Private | function GetEndOfFirstValue(const aData: string): Integer;
Private | function GetFirstValue(aData: string): string;
Private | function GetPropCastShadow(const aData: string): Boolean;
Private | function GetPropMBlur(const aData: string): Boolean;
Private | function GetPropRECVShadow(const aData: string): Boolean;
Private | function GetStringValue(const aData: string): string;
Private | function GetTagOnData(const aData: string): Integer;
Private | function GetValue3D(const aData: string): TAffineVector;
Private | function GetValue4D(const aData: string; var Value0: Integer): TAffineVector;
Private | function IsEndOfSection(const aData: string): Boolean;
Private | function IsSectionBegingin(const aData: string): Boolean;
Public | procedure LoadFromStream(aStream: TStream); override;
Private | procedure Parse;
Private | procedure ParseFaceString(const aData: string; var Index, A, B, C, AB, BC, CA, MatID: Integer; var Smooth: TGLASESmoothingGroups);
Private | procedure ParseGeomObject(var aLineIndex: Integer);
Private | procedure ParseMappingChannel(var aLineIndex: Integer; aMesh: TGLASEMeshObject);
Private | procedure ParseMaterial(var aLineIndex: Integer; aMaterial: TGLASEMaterial);
Private | procedure ParseMaterialList(var aLineIndex: Integer);
Private | procedure ParseMeshFaces(var aLineIndex: Integer; aMesh: TGLASEMeshObject; FacesCount: Integer);
Private | procedure ParseMeshGeom(var aLineIndex: Integer; aMesh: TGLASEMeshObject);
Private | procedure ParseMeshNormals(var aLineIndex: Integer; aMesh: TGLASEMeshObject; FacesCount: Integer);
Private | procedure ParseMeshOptions(var aLineIndex: Integer; aMesh: TGLASEMeshObject);
Private | procedure ParseMeshTextureFaces(var aLineIndex: Integer; aMesh: TGLASEMeshObject; TextureFacesCount: Integer);
Private | procedure ParseMeshTextureVertices(var aLineIndex: Integer; aMesh: TGLASEMeshObject; TextureVerticesCount: Integer);
Private | procedure ParseMeshVertices(var aLineIndex: Integer; aMesh: TGLASEMeshObject; VerticesCount: Integer);
Private | procedure ParseScene(var aLineIndex: Integer);
Private | procedure ParseSubMaterial(var aLineIndex: Integer; aMaterial: TGLASEMaterial);
Private | procedure ParseTextureMap(var aLineIndex: Integer; var aMaps: TGLASEMaterialTextureMaps; const aMapKind: string);
Private | procedure SkipSection(var aLineIndex: Integer);

Properties

Public | property CastShadow: Boolean read FCastShadow;
Public | property Comment: string read FComment;
Public | property Header: string read FHeader;
Public | property MotionBlur: Boolean read FMotionBlur;
Public | property RECVShadow: Boolean read FRECVShadow;

Description

Fields

Private FStringData: TStringList;

This item has no description.

Private FHeader: string;

This item has no description.

Private FComment: string;

This item has no description.

Private FRECVShadow: Boolean;

This item has no description.

Private FCastShadow: Boolean;

This item has no description.

Private FMotionBlur: Boolean;

This item has no description.

Private FMaterialList: TGLASEMaterialList;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Private function CheckTextureMap(var aLineIndex: Integer; var aMaps: TGLASEMaterialTextureMaps): Boolean;

This item has no description.

Private function CheckUnknownData(var aLineIndex: Integer): Boolean;

This item has no description.

Private function ContainString(const aData, aString: string): Boolean;

This item has no description.

Private function GetDoubleValue(const aData: string): Double;

This item has no description.

Private function GetEndOfFirstValue(const aData: string): Integer;

This item has no description.

Private function GetFirstValue(aData: string): string;

This item has no description.

Private function GetPropCastShadow(const aData: string): Boolean;

This item has no description.

Private function GetPropMBlur(const aData: string): Boolean;

This item has no description.

Private function GetPropRECVShadow(const aData: string): Boolean;

This item has no description.

Private function GetStringValue(const aData: string): string;

This item has no description.

Private function GetTagOnData(const aData: string): Integer;

This item has no description.

Private function GetValue3D(const aData: string): TAffineVector;

This item has no description.

Private function GetValue4D(const aData: string; var Value0: Integer): TAffineVector;

This item has no description.

Private function IsEndOfSection(const aData: string): Boolean;

This item has no description.

Private function IsSectionBegingin(const aData: string): Boolean;

This item has no description.

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Private procedure Parse;

This item has no description.

Private procedure ParseFaceString(const aData: string; var Index, A, B, C, AB, BC, CA, MatID: Integer; var Smooth: TGLASESmoothingGroups);

This item has no description.

Private procedure ParseGeomObject(var aLineIndex: Integer);

This item has no description.

Private procedure ParseMappingChannel(var aLineIndex: Integer; aMesh: TGLASEMeshObject);

This item has no description.

Private procedure ParseMaterial(var aLineIndex: Integer; aMaterial: TGLASEMaterial);

This item has no description.

Private procedure ParseMaterialList(var aLineIndex: Integer);

This item has no description.

Private procedure ParseMeshFaces(var aLineIndex: Integer; aMesh: TGLASEMeshObject; FacesCount: Integer);

This item has no description.

Private procedure ParseMeshGeom(var aLineIndex: Integer; aMesh: TGLASEMeshObject);

This item has no description.

Private procedure ParseMeshNormals(var aLineIndex: Integer; aMesh: TGLASEMeshObject; FacesCount: Integer);

This item has no description.

Private procedure ParseMeshOptions(var aLineIndex: Integer; aMesh: TGLASEMeshObject);

This item has no description.

Private procedure ParseMeshTextureFaces(var aLineIndex: Integer; aMesh: TGLASEMeshObject; TextureFacesCount: Integer);

This item has no description.

Private procedure ParseMeshTextureVertices(var aLineIndex: Integer; aMesh: TGLASEMeshObject; TextureVerticesCount: Integer);

This item has no description.

Private procedure ParseMeshVertices(var aLineIndex: Integer; aMesh: TGLASEMeshObject; VerticesCount: Integer);

This item has no description.

Private procedure ParseScene(var aLineIndex: Integer);

This item has no description.

Private procedure ParseSubMaterial(var aLineIndex: Integer; aMaterial: TGLASEMaterial);

This item has no description.

Private procedure ParseTextureMap(var aLineIndex: Integer; var aMaps: TGLASEMaterialTextureMaps; const aMapKind: string);

This item has no description.

Private procedure SkipSection(var aLineIndex: Integer);

This item has no description.

Properties

Public property CastShadow: Boolean read FCastShadow;

This item has no description.

Public property Comment: string read FComment;

This item has no description.

Public property Header: string read FHeader;

This item has no description.

Public property MotionBlur: Boolean read FMotionBlur;

This item has no description.

Public property RECVShadow: Boolean read FRECVShadow;


GLSysHelp v.2.5: GLS.FileB3D

Unit GLS.FileB3D

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.TextureFormat
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLS.Texture
  • GLS.Material
  • GLS.VectorLists
  • Formats.B3D

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLB3DVectorFile |


GLSysHelp v.2.5: GLS.FileB3D: Class TGLB3DVectorFile

Class TGLB3DVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileB3D

Declaration

type TGLB3DVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLB3DVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(AStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(AStream: TStream); override;


GLSysHelp v.2.5: GLS.FileBMP

Unit GLS.FileBMP

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.TextureFormat
  • GLS.Context
  • GLS.Graphics
  • GLS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBMPImage |


GLSysHelp v.2.5: GLS.FileBMP: Class TGLBMPImage

Class TGLBMPImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileBMP

Declaration

type TGLBMPImage = class(TGLBaseImage)

Description

This item has no description. Showing description inherited from TGLDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage
  • TGLBMPImage

Overview

Fields

Private | FTopDown: Boolean;
Private | RedMask: LongWord;
Private | GreenMask: LongWord;
Private | BlueMask: LongWord;
Private | RedShift: ShortInt;
Private | GreenShift: ShortInt;
Private | BlueShift: ShortInt;
Private | FLineBuffer: PByteArray;
Private | FReadSize: Integer;
Private | FDeltaX: Integer;
Private | FDeltaY: Integer;

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Private | function CountBits(Value: byte): shortint;
Private | function ExpandColor(Value: longword): TGLPixel32;
Private | function Monochrome(N: Integer): Integer;
Private | function Octochrome(N: Integer): Integer;
Private | function Quadrochrome(N: Integer): Integer;
Private | function ShiftCount(Mask: longword): shortint;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;
Private | procedure ExpandRLE4ScanLine(Row: Integer; Stream: TStream);
Private | procedure ExpandRLE8ScanLine(Row: Integer; Stream: TStream);

Description

Fields

Private FTopDown: Boolean;

This item has no description.

Private RedMask: LongWord;

This item has no description.

Private GreenMask: LongWord;

This item has no description.

Private BlueMask: LongWord;

This item has no description.

Private RedShift: ShortInt;

This item has no description.

Private GreenShift: ShortInt;

This item has no description.

Private BlueShift: ShortInt;

This item has no description.

Private FLineBuffer: PByteArray;

This item has no description.

Private FReadSize: Integer;

This item has no description.

Private FDeltaX: Integer;

This item has no description.

Private FDeltaY: Integer;

This item has no description.

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Private function CountBits(Value: byte): shortint;

This item has no description.

Private function ExpandColor(Value: longword): TGLPixel32;

This item has no description.

Private function Monochrome(N: Integer): Integer;

This item has no description.

Private function Octochrome(N: Integer): Integer;

This item has no description.

Private function Quadrochrome(N: Integer): Integer;

This item has no description.

Private function ShiftCount(Mask: longword): shortint;

This item has no description.

Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;

This item has no description.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;

This item has no description.

Private procedure ExpandRLE4ScanLine(Row: Integer; Stream: TStream);

This item has no description.

Private procedure ExpandRLE8ScanLine(Row: Integer; Stream: TStream);


GLSysHelp v.2.5: GLS.FileDDS

Unit GLS.FileDDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLS.Context
  • GLS.Graphics
  • GLS.Texture
  • GLScene.VectorGeometry
  • GLScene.TextureFormat
  • GLS.CompositeImage
  • GLS.MultiSampleImage
  • GLScene.RGBE
  • GLS.ApplicationFileIO
  • GLS.Material
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDDSImage |

Functions and Procedures

function GetOrCreateLibMaterial(aMaterialLibrary: TGLMaterialLibrary; aMaterialName: string): TGLLibMaterial;
function LibMat(aMatLib: TGLMaterialLibrary; aMatName: string): TGLLibMaterial;
function DDStex(aMatLib: TGLMaterialLibrary; aTexName, aDDSFileName: string; aSecondTexName: string = ''; aDDSLevel: integer = 0): TGLLibMaterial; overload;
function DDStex(aTexture: TGLTexture; aDDSFileName: string; aDDSLevel: integer = 0): TGLTexture; overload;
function DDStex(aTextureEx: TGLTextureExItem; aDDSFileName: string; aDDSLevel: integer = 0): TGLTextureExItem; overload;

Types

TGLDDSDetailLevels = (...);

Variables

vDDSDetailLevel: TGLDDSDetailLevels = ddsHighDet;

Description

Functions and Procedures

function GetOrCreateLibMaterial(aMaterialLibrary: TGLMaterialLibrary; aMaterialName: string): TGLLibMaterial;

get or create material in material library

function LibMat(aMatLib: TGLMaterialLibrary; aMatName: string): TGLLibMaterial;

This item has no description.

function DDStex(aMatLib: TGLMaterialLibrary; aTexName, aDDSFileName: string; aSecondTexName: string = ''; aDDSLevel: integer = 0): TGLLibMaterial; overload;

function DDStex(aMatLib: TGLMaterialLibrary; aTexName, aDDSFileName: string; aSecondTexName: string = ''; aDDSLevel: integer = 0): TGLLibMaterial; overload;

function DDStex(aTexture: TGLTexture; aDDSFileName: string; aDDSLevel: integer = 0): TGLTexture; overload;

This item has no description.

function DDStex(aTextureEx: TGLTextureExItem; aDDSFileName: string; aDDSLevel: integer = 0): TGLTextureExItem; overload;

This item has no description.

Types

TGLDDSDetailLevels = (...);

This item has no description.

Values
  • ddsHighDet
  • ddsMediumDet
  • ddsLowDet

Variables

vDDSDetailLevel: TGLDDSDetailLevels = ddsHighDet;

Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.


GLSysHelp v.2.5: GLS.FileDDS: Class TGLDDSImage

Class TGLDDSImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileDDS

Declaration

type TGLDDSImage = class(TGLBaseImage)

Description

This item has no description. Showing description inherited from TGLDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage
  • TGLDDSImage

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure AssignFromTexture(TextureContext: TGLContext; const TextureHandle: Cardinal; TextureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const IntFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const Filename: string); override;
Public | procedure LoadFromStream(Stream: TStream); override;
Public | procedure SaveToFile(const Filename: string); override;
Public | procedure SaveToStream(Stream: TStream); override;
Private | procedure FlipSurface(ChangeData: PGLubyte; W, H, D: integer);

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(TextureContext: TGLContext; const TextureHandle: Cardinal; TextureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const IntFormat: TGLInternalFormat); reintroduce;

Assigns from any Texture.

Public procedure LoadFromFile(const Filename: string); override;

This item has no description.

Public procedure LoadFromStream(Stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const Filename: string); override;

This item has no description.

Public procedure SaveToStream(Stream: TStream); override;

This item has no description.

Private procedure FlipSurface(ChangeData: PGLubyte; W, H, D: integer);


GLSysHelp v.2.5: GLS.FileDEL

Unit GLS.FileDEL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorTypesExt
  • GLScene.VectorGeometry
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDELVectorFile |


GLSysHelp v.2.5: GLS.FileDEL: Class TGLDELVectorFile

Class TGLDELVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileDEL

Declaration

type TGLDELVectorFile = class(TGLVectorFile)

Description

The DEL vector file (tetrahedra irregular network)

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLDELVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream : TStream); override;


GLSysHelp v.2.5: GLS.FileDXF

Unit GLS.FileDXF

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLS.PersistentClasses
  • GLS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.Scene
  • GLS.Texture
  • GLS.VectorFileObjects
  • GLS.Material
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDXFVectorFile |


GLSysHelp v.2.5: GLS.FileDXF: Class TGLDXFVectorFile

Class TGLDXFVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileDXF

Declaration

type TGLDXFVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLDXFVectorFile

Overview

Fields

Private | FSourceStream: TStream;
Private | FBuffer: String;
Private | FLineNo: Integer;
Private | FEof: Boolean;
Private | FBufPos: Integer;
Private | HasPushedCode: Boolean;
Private | PushedCode: Integer;
Private | FLayers: TStringList;
Private | FBlocks: TStringList;
Private | FLastpercentdone: BYTE;

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Fields

Private FSourceStream: TStream;

This item has no description.

Private FBuffer: String;

Load from this stream

Private FLineNo: Integer;

Buffer and current line

Private FEof: Boolean;

current Line number - for error messages

Private FBufPos: Integer;

Stream done?

Private HasPushedCode: Boolean;

Position in the buffer

Private PushedCode: Integer;

This item has no description.

Private FLayers: TStringList;

This item has no description.

Private FBlocks: TStringList;

This item has no description.

Private FLastpercentdone: BYTE;

This item has no description.

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileGL2

Unit GLS.FileGL2

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.PersistentClasses
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLS.Material
  • GLS.VectorLists
  • Formats.GL2

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMVectorFile |
Class TGLAVectorFile |

Variables

vGhoul2LevelOfDetail: Integer = 0;
vGhoul2MaxBonesPerVertex: Integer = 4;

Description

Variables

vGhoul2LevelOfDetail: Integer = 0;

This item has no description.

vGhoul2MaxBonesPerVertex: Integer = 4;

Highest detail level by default


GLSysHelp v.2.5: GLS.FileGL2: Class TGLMVectorFile

Class TGLMVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileGL2

Declaration

type TGLMVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLMVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileGL2: Class TGLAVectorFile

Class TGLAVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileGL2

Declaration

type TGLAVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLAVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileGLTF

Unit GLS.FileGLTF

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.PersistentClasses
  • GLS.VectorFileObjects
  • GLS.Texture
  • GLS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLS.VectorLists
  • GLScene.VectorGeometry
  • GLS.Material
  • GLScene.Utils
  • PasGLTF

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLglTFVectorFile |

Variables

glTFUseEmbeddedColors: Boolean;

Description

Variables

glTFUseEmbeddedColors: Boolean;


GLSysHelp v.2.5: GLS.FileGLTF: Class TGLglTFVectorFile

Class TGLglTFVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileGLTF

Declaration

type TGLglTFVectorFile = class(TGLVectorFile)

Description

The glTF format is a runtime asset delivery format for GL APIs: WebGL, OpenGL ES OpenGL and Vulkan.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLglTFVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileGRD

Unit GLS.FileGRD

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLS.Graph
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGRDVectorFile |


GLSysHelp v.2.5: GLS.FileGRD: Class TGLGRDVectorFile

Class TGLGRDVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileGRD

Declaration

type TGLGRDVectorFile = class(TGLVectorFile)

Description

The GRD file represents ascii grid formats in 2D/3D. This is a format for storing regular grid values as a matrices of cell centers. The format supports variations and subformats. This importer works for Sutfer, ArcInfo and GMS formats

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLGRDVectorFile

Overview

Fields

Public | GLHeightField: TGLHeightField;
Public | Nodes: array of TSingleArray;
Private | StrVal: String;
Private | StrLine: String;
Private | MaxZ: Single;

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Private | function ExtractWord(N: Integer; const S: string; const WordDelims: TSysCharSet): string;
Private | function WordPosition(const N: Integer; const S: string; const WordDelims: TSysCharSet): Integer;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Fields

Public GLHeightField: TGLHeightField;

This item has no description.

Public Nodes: array of TSingleArray;

This item has no description.

Private StrVal: String;

This item has no description.

Private StrLine: String;

This item has no description.

Private MaxZ: Single;

This item has no description.

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Private function ExtractWord(N: Integer; const S: string; const WordDelims: TSysCharSet): string;

This item has no description.

Private function WordPosition(const N: Integer; const S: string; const WordDelims: TSysCharSet): Integer;

This item has no description.

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileGTS

Unit GLS.FileGTS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGTSVectorFile |


GLSysHelp v.2.5: GLS.FileGTS: Class TGLGTSVectorFile

Class TGLGTSVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileGTS

Declaration

type TGLGTSVectorFile = class(TGLVectorFile)

Description

The GTS vector file (GNU Triangulated Surface library). It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces. Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices). http://gts.sourceforge.net/

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLGTSVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileHDR

Unit GLS.FileHDR

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.TextureFormat
  • GLScene.RGBE
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.ApplicationFileIO
  • GLS.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLHDRImage |


GLSysHelp v.2.5: GLS.FileHDR: Class TGLHDRImage

Class TGLHDRImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileHDR

Declaration

type TGLHDRImage = class(TGLBaseImage)

Description

This item has no description. Showing description inherited from TGLDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage
  • TGLHDRImage

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Private | function GetProgramType: Ansistring;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Private | procedure SetProgramType(aval: Ansistring);

Properties

Public | property Exposure: Single read fExposure;
Public | property Gamma: Single read fGamma;
Public | property ProgramType: Ansistring read GetProgramType write SetProgramType;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Private function GetProgramType: Ansistring;

This item has no description.

Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;

This item has no description.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Private procedure SetProgramType(aval: Ansistring);

This item has no description.

Properties

Public property Exposure: Single read fExposure;

This item has no description.

Public property Gamma: Single read fGamma;

This item has no description.

Public property ProgramType: Ansistring read GetProgramType write SetProgramType;


GLSysHelp v.2.5: GLS.FileJPEG

Unit GLS.FileJPEG

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • Vcl.Graphics
  • Vcl.Imaging.Jpeg
  • GLScene.OpenGLTokens
  • GLS.Context
  • GLS.Graphics
  • GLScene.TextureFormat
  • GLS.ApplicationFileIO
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLJPEGImage |

Functions and Procedures

procedure Jpeg2Bmp(const BmpFileName, JpgFileName: string);

Description

Functions and Procedures

procedure Jpeg2Bmp(const BmpFileName, JpgFileName: string);


GLSysHelp v.2.5: GLS.FileJPEG: Class TGLJPEGImage

Class TGLJPEGImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileJPEG

Declaration

type TGLJPEGImage = class(TGLBaseImage)

Description

This item has no description. Showing description inherited from TGLDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage
  • TGLJPEGImage

Overview

Fields

Private | FAbortLoading: boolean;
Private | FDivScale: longword;
Private | FDither: boolean;
Private | FSmoothing: boolean;
Private | FProgressiveEncoding: boolean;

Methods

Public | constructor Create; override;
Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(AStream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(AStream: TStream); override;
Private | procedure SetSmoothing(const AValue: boolean);

Properties

Public | property Dither: boolean read FDither write FDither;
Public | property DivScale: longword read FDivScale write FDivScale;
Public | property ProgressiveEncoding: boolean read FProgressiveEncoding;
Public | property Smoothing: boolean read FSmoothing write SetSmoothing;

Description

Fields

Private FAbortLoading: boolean;

This item has no description.

Private FDivScale: longword;

This item has no description.

Private FDither: boolean;

This item has no description.

Private FSmoothing: boolean;

This item has no description.

Private FProgressiveEncoding: boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;

Assigns from any Texture.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(AStream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(AStream: TStream); override;

This item has no description.

Private procedure SetSmoothing(const AValue: boolean);

This item has no description.

Properties

Public property Dither: boolean read FDither write FDither;

This item has no description.

Public property DivScale: longword read FDivScale write FDivScale;

This item has no description.

Public property ProgressiveEncoding: boolean read FProgressiveEncoding;

This item has no description.

Public property Smoothing: boolean read FSmoothing write SetSmoothing;


GLSysHelp v.2.5: GLS.FileLMTS

Unit GLS.FileLMTS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Vcl.Graphics
  • GLScene.VectorTypes
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLS.VectorLists
  • GLScene.VectorGeometry
  • GLS.Texture
  • GLS.PersistentClasses
  • GLS.Graphics
  • GLS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TLMTS_Header |
Record TLMTS_TexData |
Record TLMTS_Subset |
Record TLMTS_Vertex |
Record TLMTS |
Record TMaterialInfo |
Class TGLLMTSVectorFile |

Types

PLMTS = ˆTLMTS;
PLMTS_Header = ˆTLMTS_Header;
PLMTS_Subset = ˆTLMTS_Subset;
PLMTS_TexData = ˆTLMTS_TexData;
PLMTS_Vertex = ˆTLMTS_Vertex;

Constants

C_LMTS_ID = $53544D4C;
C_LMTS_VER = 4;
C_LMTS_SUBS = $53425553;
C_LMTS_TEXT = $54584554;
C_LMTS_TRIS = $53495254;
C_LMTS_TEXFNLEN = 255;

Description

Types

PLMTS = ˆTLMTS;

This item has no description.

PLMTS_Header = ˆTLMTS_Header;

max texture filename length

PLMTS_Subset = ˆTLMTS_Subset;

This item has no description.

PLMTS_TexData = ˆTLMTS_TexData;

This item has no description.

PLMTS_Vertex = ˆTLMTS_Vertex;

This item has no description.

Constants

C_LMTS_ID = $53544D4C;

This item has no description.

C_LMTS_VER = 4;

This item has no description.

C_LMTS_SUBS = $53425553;

This item has no description.

C_LMTS_TEXT = $54584554;

This item has no description.

C_LMTS_TRIS = $53495254;

This item has no description.

C_LMTS_TEXFNLEN = 255;


GLSysHelp v.2.5: GLS.FileLMTS: Record TLMTS_Header

Record TLMTS_Header

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileLMTS

Declaration

type TLMTS_Header = record

Description

This item has no description.

Overview

Fields

Public | ID: cardinal;
Public | Ver: cardinal;
Public | headerSize: cardinal;
Public | nTexts: word;
Public | nSubsets: word;
Public | nTris: cardinal;
Public | subSize: word;
Public | vtxSize: word;

Description

Fields

Public ID: cardinal;

packed

Public Ver: cardinal;

This item has no description.

Public headerSize: cardinal;

This item has no description.

Public nTexts: word;

This item has no description.

Public nSubsets: word;

# of textures

Public nTris: cardinal;

This item has no description.

Public subSize: word;

This item has no description.

Public vtxSize: word;


GLSysHelp v.2.5: GLS.FileLMTS: Record TLMTS_TexData

Record TLMTS_TexData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileLMTS

Declaration

type TLMTS_TexData = record

Description

This item has no description.

Overview

Fields

Public | fName: array [0 .. C_LMTS_TEXFNLEN] of AnsiChar;
Public | Flags: Word;

Description

Fields

Public fName: array [0 .. C_LMTS_TEXFNLEN] of AnsiChar;

packed

Public Flags: Word;


GLSysHelp v.2.5: GLS.FileLMTS: Record TLMTS_Subset

Record TLMTS_Subset

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileLMTS

Declaration

type TLMTS_Subset = record

Description

This item has no description.

Overview

Fields

Public | Offset: LongInt;
Public | Count: LongInt;
Public | TextID1: Word;
Public | TextID2: Word;

Description

Fields

Public Offset: LongInt;

packed

Public Count: LongInt;

This item has no description.

Public TextID1: Word;

This item has no description.

Public TextID2: Word;


GLSysHelp v.2.5: GLS.FileLMTS: Record TLMTS_Vertex

Record TLMTS_Vertex

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileLMTS

Declaration

type TLMTS_Vertex = record

Description

This item has no description.

Overview

Fields

Public | x: Single;
Public | y: Single;
Public | z: Single;
Public | u1: Single;
Public | v1: Single;
Public | u2: Single;
Public | v2: Single;

Description

Fields

Public x: Single;

packed

Public y: Single;

packed

Public z: Single;

packed

Public u1: Single;

This item has no description.

Public v1: Single;

This item has no description.

Public u2: Single;

This item has no description.

Public v2: Single;


GLSysHelp v.2.5: GLS.FileLMTS: Record TLMTS

Record TLMTS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileLMTS

Declaration

type TLMTS = record

Description

This item has no description.

Overview

Fields

Public | header: TLMTS_Header;
Public | usrData: pointer;
Public | usrSize: cardinal;
Public | texData: pointer;
Public | subsets: pointer;
Public | tris: pointer;
Public | ok: boolean;

Description

Fields

Public header: TLMTS_Header;

This item has no description.

Public usrData: pointer;

This item has no description.

Public usrSize: cardinal;

This item has no description.

Public texData: pointer;

This item has no description.

Public subsets: pointer;

This item has no description.

Public tris: pointer;

This item has no description.

Public ok: boolean;


GLSysHelp v.2.5: GLS.FileLMTS: Record TMaterialInfo

Record TMaterialInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileLMTS

Declaration

type TMaterialInfo = record

Description

This item has no description.

Overview

Fields

Public | FShininess: TGLShininess;
Public | BShininess: TGLShininess;
Public | FAmbient: TGLVector;
Public | FDiffuse: TGLVector;
Public | FEmission: TGLVector;
Public | FSpecular: TGLVector;
Public | BAmbient: TGLVector;
Public | BDiffuse: TGLVector;
Public | BEmission: TGLVector;
Public | BSpecular: TGLVector;
Public | ImageAlpha: TGLTextureImageAlpha;
Public | magFilter: TGLMagFilter;
Public | minFilter: TGLMinFilter;
Public | TextureMode: TGLTextureMode;
Public | TextureWrap: TGLTextureWrap;
Public | Blendingmode: TGLBlendingMode;
Public | FaceCulling: TGLFaceCulling;
Public | mathash: integer;

Description

Fields

Public FShininess: TGLShininess;

This item has no description.

Public BShininess: TGLShininess;

This item has no description.

Public FAmbient: TGLVector;

This item has no description.

Public FDiffuse: TGLVector;

This item has no description.

Public FEmission: TGLVector;

This item has no description.

Public FSpecular: TGLVector;

This item has no description.

Public BAmbient: TGLVector;

This item has no description.

Public BDiffuse: TGLVector;

This item has no description.

Public BEmission: TGLVector;

This item has no description.

Public BSpecular: TGLVector;

This item has no description.

Public ImageAlpha: TGLTextureImageAlpha;

This item has no description.

Public magFilter: TGLMagFilter;

This item has no description.

Public minFilter: TGLMinFilter;

This item has no description.

Public TextureMode: TGLTextureMode;

This item has no description.

Public TextureWrap: TGLTextureWrap;

This item has no description.

Public Blendingmode: TGLBlendingMode;

This item has no description.

Public FaceCulling: TGLFaceCulling;

This item has no description.

Public mathash: integer;


GLSysHelp v.2.5: GLS.FileLMTS: Class TGLLMTSVectorFile

Class TGLLMTSVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileLMTS

Declaration

type TGLLMTSVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLLMTSVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileLWO

Unit GLS.FileLWO

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLS.VectorFileObjects
  • GLS.VectorLists
  • Formats.LWO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLWOVectorFile |


GLSysHelp v.2.5: GLS.FileLWO: Class TGLLWOVectorFile

Class TGLLWOVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileLWO

Declaration

type TGLLWOVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLLWOVectorFile

Overview

Fields

Private | FLWO: TLWObjectFile;
Private | FPnts: TLWPnts;

Methods

Public | procedure LoadFromStream(aStream: TStream); override;
Private | procedure AddLayr(Layr: TLWLayr; LWO: TLWObjectFile);
Private | procedure AddPnts(Pnts: TLWPnts; Mesh: TGLMeshObject);
Private | procedure AddPols(Pols: TLWPols; Mesh: TGLMeshObject);
Private | procedure AddSurf(Surf: TLWSurf; LWO: TLWObjectFile);
Private | procedure AddVMap(VMap: TLWVMap; Mesh: TGLMeshObject);

Description

Fields

Private FLWO: TLWObjectFile;

This item has no description.

Private FPnts: TLWPnts;

This item has no description.

Methods

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Private procedure AddLayr(Layr: TLWLayr; LWO: TLWObjectFile);

This item has no description.

Private procedure AddPnts(Pnts: TLWPnts; Mesh: TGLMeshObject);

This item has no description.

Private procedure AddPols(Pols: TLWPols; Mesh: TGLMeshObject);

This item has no description.

Private procedure AddSurf(Surf: TLWSurf; LWO: TLWObjectFile);

This item has no description.

Private procedure AddVMap(VMap: TLWVMap; Mesh: TGLMeshObject);


GLSysHelp v.2.5: GLS.FileMD2

Unit GLS.FileMD2

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • Formats.MD2

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMD2VectorFile |


GLSysHelp v.2.5: GLS.FileMD2: Class TGLMD2VectorFile

Class TGLMD2VectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMD2

Declaration

type TGLMD2VectorFile = class(TGLVectorFile)

Description

The MD2 vector file (Quake2 actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TGLActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap). Based on code by Roger Cao.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLMD2VectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileMD3

Unit GLS.FileMD3

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.VectorFileObjects
  • GLS.Material
  • GLS.ApplicationFileIO
  • GLScene.VectorGeometry
  • Formats.MD3
  • GLS.Texture

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMD3VectorFile |


GLSysHelp v.2.5: GLS.FileMD3: Class TGLMD3VectorFile

Class TGLMD3VectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMD3

Declaration

type TGLMD3VectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLMD3VectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream : TStream); override;


GLSysHelp v.2.5: GLS.FileMD5

Unit GLS.FileMD5

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.VectorFileObjects
  • GLS.PersistentClasses
  • GLScene.Utils
  • GLS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMD5VectorFile |

Variables

vMD5TextureExtensions: TStringList;

Description

Variables

vMD5TextureExtensions: TStringList;


GLSysHelp v.2.5: GLS.FileMD5: Class TGLMD5VectorFile

Class TGLMD5VectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMD5

Declaration

type TGLMD5VectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLMD5VectorFile

Overview

Fields

Private | FMD5String: TStringList;
Private | FTempString: TStringList;
Private | FBoneNames: TStringList;
Private | FCurrentPos: Integer;
Private | FBasePose: TGLSkeletonFrame;
Private | FFramePositions: TGLAffineVectorList;
Private | FFrameQuaternions: TGLQuaternionList;
Private | FJointFlags: TGLIntegerList;
Private | FNumFrames: Integer;
Private | FFirstFrame: Integer;
Private | FFrameRate: Integer;
Private | FNumJoints: Integer;

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Private | function ReadLine: String;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Fields

Private FMD5String: TStringList;

This item has no description.

Private FTempString: TStringList;

This item has no description.

Private FBoneNames: TStringList;

This item has no description.

Private FCurrentPos: Integer;

This item has no description.

Private FBasePose: TGLSkeletonFrame;

This item has no description.

Private FFramePositions: TGLAffineVectorList;

This item has no description.

Private FFrameQuaternions: TGLQuaternionList;

This item has no description.

Private FJointFlags: TGLIntegerList;

This item has no description.

Private FNumFrames: Integer;

This item has no description.

Private FFirstFrame: Integer;

This item has no description.

Private FFrameRate: Integer;

This item has no description.

Private FNumJoints: Integer;

This item has no description.

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Private function ReadLine: String;

This item has no description.

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileMDC

Unit GLS.FileMDC

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.VectorFileObjects
  • GLS.Material
  • GLS.ApplicationFileIO
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TMDCFileHeader |
Record TMDCBorderFrame |
Packed Record TMDCTagName |
Packed Record TMDCTagFrame |
Packed Record TMDCTag |
Packed Record TMDCSurfaceHeader |
Packed Record TMDCSkin |
Packed Record TMDCBaseFrame |
Packed Record TMDCCompFrame |
Class TGLMDCVectorFile |

Types

PMDCTagFrame = ˆTMDCTagFrame;
PMDCTagName = ˆTMDCTagName;
TMDCAngle = TMDCPoint;
TMDCBaseVertex = array [0 .. 3] of SmallInt;
TMDCCompVertex = array [0 .. 3] of Byte;
TMDCPoint = array [0 .. 2] of Single;
TMDCTexCoord = array [0 .. 1] of Single;
TMDCTriangle = array [0 .. 2] of Cardinal;

Constants

MDCFILE_IDENTITY = 'IDPC';
MDCFILE_VERSION = 2;
MDC_BASEVERTEX_FACTOR = 0.015625;
MDC_COMPVERTEX_FACTOR = 0.046875;

Description

Types

PMDCTagFrame = ˆTMDCTagFrame;

This item has no description.

PMDCTagName = ˆTMDCTagName;

This item has no description.

TMDCAngle = TMDCPoint;

This item has no description.

TMDCBaseVertex = array [0 .. 3] of SmallInt;

This item has no description.

TMDCCompVertex = array [0 .. 3] of Byte;

This item has no description.

TMDCPoint = array [0 .. 2] of Single;

3/64;

TMDCTexCoord = array [0 .. 1] of Single;

This item has no description.

TMDCTriangle = array [0 .. 2] of Cardinal;

This item has no description.

Constants

MDCFILE_IDENTITY = 'IDPC';

This item has no description.

MDCFILE_VERSION = 2;

This item has no description.

MDC_BASEVERTEX_FACTOR = 0.015625;

This item has no description.

MDC_COMPVERTEX_FACTOR = 0.046875;

1/64;


GLSysHelp v.2.5: GLS.FileMDC: Packed Record TMDCFileHeader

Packed Record TMDCFileHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCFileHeader = packed record

Description

This item has no description.

Overview

Fields

Public | Ident: array [0 .. 3] of AnsiChar;
Public | Version: Cardinal;
Public | Name: array [0 .. 63] of AnsiChar;
Public | Flags: Cardinal;
Public | NumFrames: Cardinal;
Public | NumTags: Cardinal;
Public | NumSurfaces: Cardinal;
Public | NumSkins: Cardinal;
Public | OffsetBorderFrames: Cardinal;
Public | OffsetTagNames: Cardinal;
Public | OffsetTagFrames: Cardinal;
Public | OffsetSurfaces: Cardinal;
Public | OffsetEnd: Cardinal;

Description

Fields

Public Ident: array [0 .. 3] of AnsiChar;

This item has no description.

Public Version: Cardinal;

This item has no description.

Public Name: array [0 .. 63] of AnsiChar;

This item has no description.

Public Flags: Cardinal;

This item has no description.

Public NumFrames: Cardinal;

This item has no description.

Public NumTags: Cardinal;

This item has no description.

Public NumSurfaces: Cardinal;

This item has no description.

Public NumSkins: Cardinal;

This item has no description.

Public OffsetBorderFrames: Cardinal;

This item has no description.

Public OffsetTagNames: Cardinal;

This item has no description.

Public OffsetTagFrames: Cardinal;

This item has no description.

Public OffsetSurfaces: Cardinal;

This item has no description.

Public OffsetEnd: Cardinal;


GLSysHelp v.2.5: GLS.FileMDC: Record TMDCBorderFrame

Record TMDCBorderFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCBorderFrame = record

Description

This item has no description.

Overview

Fields

Public | BBMin: TMDCPoint;
Public | BBMax: TMDCPoint;
Public | LocalOrigin: TMDCPoint;
Public | Radius: Single;
Public | Name: array [0 .. 15] of AnsiChar;

Description

Fields

Public BBMin: TMDCPoint;

This item has no description.

Public BBMax: TMDCPoint;

This item has no description.

Public LocalOrigin: TMDCPoint;

This item has no description.

Public Radius: Single;

This item has no description.

Public Name: array [0 .. 15] of AnsiChar;


GLSysHelp v.2.5: GLS.FileMDC: Packed Record TMDCTagName

Packed Record TMDCTagName

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCTagName = packed record

Description

This item has no description.

Overview

Fields

Public Name: array [0 .. 63] of AnsiChar;

Description

Fields

Public Name: array [0 .. 63] of AnsiChar;


GLSysHelp v.2.5: GLS.FileMDC: Packed Record TMDCTagFrame

Packed Record TMDCTagFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCTagFrame = packed record

Description

This item has no description.

Overview

Fields

Public | TagPosition: array [0 .. 2] of Word;
Public | TagAngle: array [0 .. 2] of Word;

Description

Fields

Public TagPosition: array [0 .. 2] of Word;

This item has no description.

Public TagAngle: array [0 .. 2] of Word;

or ShortInt?


GLSysHelp v.2.5: GLS.FileMDC: Packed Record TMDCTag

Packed Record TMDCTag

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCTag = packed record

Description

This item has no description.

Overview

Fields

Public | TagName: PMDCTagName;
Public | TagFrame: PMDCTagFrame;

Description

Fields

Public TagName: PMDCTagName;

This item has no description.

Public TagFrame: PMDCTagFrame;


GLSysHelp v.2.5: GLS.FileMDC: Packed Record TMDCSurfaceHeader

Packed Record TMDCSurfaceHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCSurfaceHeader = packed record

Description

This item has no description.

Overview

Fields

Public | Ident: array [0 .. 3] of AnsiChar;
Public | Name: array [0 .. 63] of AnsiChar;
Public | Flags: Cardinal;
Public | NumCompFrames: Cardinal;
Public | NumBaseFrames: Cardinal;
Public | NumSkins: Cardinal;
Public | NumVertices: Cardinal;
Public | NumTriangles: Cardinal;
Public | OffsetTriangles: Cardinal;
Public | OffsetSkins: Cardinal;
Public | OffsetTexCoords: Cardinal;
Public | OffsetBaseVerts: Cardinal;
Public | OffsetCompVerts: Cardinal;
Public | OffsetFrameBaseFrames: Cardinal;
Public | OffsetFrameCompFrames: Cardinal;
Public | OffsetEnd: Cardinal;

Description

Fields

Public Ident: array [0 .. 3] of AnsiChar;

This item has no description.

Public Name: array [0 .. 63] of AnsiChar;

This item has no description.

Public Flags: Cardinal;

This item has no description.

Public NumCompFrames: Cardinal;

This item has no description.

Public NumBaseFrames: Cardinal;

This item has no description.

Public NumSkins: Cardinal;

This item has no description.

Public NumVertices: Cardinal;

This item has no description.

Public NumTriangles: Cardinal;

This item has no description.

Public OffsetTriangles: Cardinal;

This item has no description.

Public OffsetSkins: Cardinal;

This item has no description.

Public OffsetTexCoords: Cardinal;

This item has no description.

Public OffsetBaseVerts: Cardinal;

This item has no description.

Public OffsetCompVerts: Cardinal;

This item has no description.

Public OffsetFrameBaseFrames: Cardinal;

This item has no description.

Public OffsetFrameCompFrames: Cardinal;

This item has no description.

Public OffsetEnd: Cardinal;


GLSysHelp v.2.5: GLS.FileMDC: Packed Record TMDCSkin

Packed Record TMDCSkin

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCSkin = packed record

Description

This item has no description.

Overview

Fields

Public | Shader: array [0 .. 63] of AnsiChar;
Public | Flags: Cardinal;

Description

Fields

Public Shader: array [0 .. 63] of AnsiChar;

This item has no description.

Public Flags: Cardinal;


GLSysHelp v.2.5: GLS.FileMDC: Packed Record TMDCBaseFrame

Packed Record TMDCBaseFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCBaseFrame = packed record

Description

This item has no description.

Overview

Fields

Public BaseVertices: array of TMDCBaseVertex;

Description

Fields

Public BaseVertices: array of TMDCBaseVertex;


GLSysHelp v.2.5: GLS.FileMDC: Packed Record TMDCCompFrame

Packed Record TMDCCompFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TMDCCompFrame = packed record

Description

This item has no description.

Overview

Fields

Public CompVertices: array of TMDCCompVertex;

Description

Fields

Public CompVertices: array of TMDCCompVertex;


GLSysHelp v.2.5: GLS.FileMDC: Class TGLMDCVectorFile

Class TGLMDCVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMDC

Declaration

type TGLMDCVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLMDCVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(AStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(AStream: TStream); override;


GLSysHelp v.2.5: GLS.FileMP3

Unit GLS.FileMP3

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLS.ApplicationFileIO
  • GLS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMP3File |


GLSysHelp v.2.5: GLS.FileMP3: Class TGLMP3File

Class TGLMP3File

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMP3

Declaration

type TGLMP3File = class(TGLSoundFile)

Description

Support for MP3 format. *Partial* support only, access to PCMData is NOT supported.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLSoundFile
  • TGLMP3File

Overview

Fields

Private data: array of Byte;

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | function CreateCopy(AOwner: TPersistent) : TGLDataFile; override;
Public | function LengthInBytes: Integer; override;
Public | function PCMData: Pointer; override;
Public | function WAVData: Pointer; override;
Public | function WAVDataSize: Integer; override;
Public | procedure LoadFromStream(Stream: TStream); override;
Public | procedure PlayOnWaveOut; override;
Public | procedure SaveToStream(Stream: TStream); override;

Description

Fields

Private data: array of Byte;

This item has no description.

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public function CreateCopy(AOwner: TPersistent) : TGLDataFile; override;

used to store MP3 bitstream

Public function LengthInBytes: Integer; override;

This item has no description. Showing description inherited from TGLSoundFile.LengthInBytes.

Length of PCM data, in bytes.

Public function PCMData: Pointer; override;

This item has no description. Showing description inherited from TGLSoundFile.PCMData.

Returns a pointer to the sample data viewed as an in-memory PCM buffer.

Public function WAVData: Pointer; override;

This item has no description. Showing description inherited from TGLSoundFile.WAVData.

Returns a pointer to the sample data viewed as an in-memory WAV File.

Public function WAVDataSize: Integer; override;

This item has no description. Showing description inherited from TGLSoundFile.WAVDataSize.

Returns the size (in bytes) of the WAVData.

Public procedure LoadFromStream(Stream: TStream); override;

This item has no description.

Public procedure PlayOnWaveOut; override;

This item has no description.

Public procedure SaveToStream(Stream: TStream); override;


GLSysHelp v.2.5: GLS.FileMS3D

Unit GLS.FileMS3D

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Math
  • System.Classes
  • System.SysUtils
  • GLS.VectorFileObjects
  • GLScene.VectorTypes
  • GLS.Material
  • GLS.Color
  • GLS.Texture
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMS3DGroup |
Record TMS3DHeader |
Record TMS3DVertex |
Record TMS3DTriangle |
Record TMS3DMaterial |
Record TMS3DKeyframeRotation |
Record TMS3DKeyframePosition |
Record TMS3DJointBase |
Record TMS3DJoint |
Record TMS3DComment |
Class TMS3DCommentList |
Record TMS3D_vertex_ex_t |
Class TVertexWeightList |
Class TGLMS3DVectorFile |

Types

pMS3DComment=ˆTMS3DComment;
PMS3DJointArray = ˆTMS3DJointArray;
PMS3DKeyframePositionArray = ˆTMS3DKeyframePositionArray;
PMS3DKeyframeRotationArray = ˆTMS3DKeyframeRotationArray;
PMS3DTriangleArray = ˆTMS3DTriangleArray;
PMS3DVertexArray = ˆTMS3DVertexArray;
pMS3D_vertex_ex_t=ˆTMS3D_vertex_ex_t;
TMS3DJointArray = array[0..MAX_MS3D_JOINTS - 1] of TMS3DJoint;
TMS3DKeyframePositionArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframePosition;
TMS3DKeyframeRotationArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframeRotation;
TMS3DTriangleArray = array[0..MAX_MS3D_TRIANGLES - 1] of TMS3DTriangle;
TMS3DVertexArray = array[0..MAX_MS3D_VERTICES - 1] of TMS3DVertex;

Constants

MAX_MS3D_VERTICES = 8192;
MAX_MS3D_TRIANGLES = 16384;
MAX_MS3D_GROUPS = 128;
MAX_MS3D_MATERIALS = 128;
MAX_MS3D_JOINTS = 128;
MAX_MS3D_KEYFRAMES = 5000;

Description

Types

pMS3DComment=ˆTMS3DComment;

This item has no description.

PMS3DJointArray = ˆTMS3DJointArray;

This item has no description.

PMS3DKeyframePositionArray = ˆTMS3DKeyframePositionArray;

This item has no description.

PMS3DKeyframeRotationArray = ˆTMS3DKeyframeRotationArray;

This item has no description.

PMS3DTriangleArray = ˆTMS3DTriangleArray;

This item has no description.

PMS3DVertexArray = ˆTMS3DVertexArray;

This item has no description.

pMS3D_vertex_ex_t=ˆTMS3D_vertex_ex_t;

This item has no description.

TMS3DJointArray = array[0..MAX_MS3D_JOINTS - 1] of TMS3DJoint;

This item has no description.

TMS3DKeyframePositionArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframePosition;

This item has no description.

TMS3DKeyframeRotationArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframeRotation;

This item has no description.

TMS3DTriangleArray = array[0..MAX_MS3D_TRIANGLES - 1] of TMS3DTriangle;

This item has no description.

TMS3DVertexArray = array[0..MAX_MS3D_VERTICES - 1] of TMS3DVertex;

This item has no description.

Constants

MAX_MS3D_VERTICES = 8192;

This item has no description.

MAX_MS3D_TRIANGLES = 16384;

This item has no description.

MAX_MS3D_GROUPS = 128;

This item has no description.

MAX_MS3D_MATERIALS = 128;

This item has no description.

MAX_MS3D_JOINTS = 128;

This item has no description.

MAX_MS3D_KEYFRAMES = 5000;


GLSysHelp v.2.5: GLS.FileMS3D: Class TMS3DGroup

Class TMS3DGroup

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DGroup = class(TObject)

Description

typedef struct (* byte flags; // SELECTED | HIDDEN char name[32]; // word numtriangles; // word triangleIndices[numtriangles]; // the groups group the triangles char materialIndex; // -1 = no material *) ms3d_group_t;

Hierarchy

  • TObject
  • TMS3DGroup

Overview

Fields

Public | Flags: byte;
Public | Name: array[0..31] of AnsiChar;
Public | NumTriangles: word;
Public | TriangleIndices: TList;
Public | MaterialIndex: Shortint;

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Fields

Public Flags: byte;

This item has no description.

Public Name: array[0..31] of AnsiChar;

This item has no description.

Public NumTriangles: word;

This item has no description.

Public TriangleIndices: TList;

This item has no description.

Public MaterialIndex: Shortint;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DHeader

Record TMS3DHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DHeader = record

Description

typdef struct (* char id[10]; // always "MS3D000000" int version; // 4 *) ms3d_header_t;

Overview

Fields

Public | ID: array[0..9] of AnsiChar;
Public | Version: integer;

Description

Fields

Public ID: array[0..9] of AnsiChar;

This item has no description.

Public Version: integer;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DVertex

Record TMS3DVertex

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DVertex = record

Description

typedef struct (* byte flags; // SELECTED | SELECTED2 | HIDDEN float vertex[3]; // char boneId; // -1 = no bone byte referenceCount; *) ms3d_vertex_t;

Overview

Fields

Public | Flags: byte;
Public | Vertex: TD3DVector;
Public | BoneId: AnsiChar;
Public | ReferenceCount: byte;

Description

Fields

Public Flags: byte;

This item has no description.

Public Vertex: TD3DVector;

This item has no description.

Public BoneId: AnsiChar;

This item has no description.

Public ReferenceCount: byte;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DTriangle

Record TMS3DTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DTriangle = record

Description

typedef struct (* word flags; // SELECTED | SELECTED2 | HIDDEN word vertexIndices[3]; // float vertexNormals[3][3]; // float s[3]; // float t[3]; // byte smoothingGroup; // 1 - 32 byte groupIndex; // *) ms3d_triangle_t;

Overview

Fields

Public | Flags: word;
Public | VertexIndices: array[0..2] of word;
Public | VertexNormals: array[0..2] of TD3DVector;
Public | S: array[0..2] of single;
Public | T: array[0..2] of single;
Public | SmoothingGroup: byte;
Public | GroupIndex: byte;

Description

Fields

Public Flags: word;

This item has no description.

Public VertexIndices: array[0..2] of word;

This item has no description.

Public VertexNormals: array[0..2] of TD3DVector;

This item has no description.

Public S: array[0..2] of single;

This item has no description.

Public T: array[0..2] of single;

This item has no description.

Public SmoothingGroup: byte;

This item has no description.

Public GroupIndex: byte;

1 - 32


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DMaterial

Record TMS3DMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DMaterial = record

Description

typedef struct (* char name[32]; // float ambient[4]; // float diffuse[4]; // float specular[4]; // float emissive[4]; // float shininess; // 0.0f - 128.0f float transparency; // 0.0f - 1.0f char mode; // 0, 1, 2 is unused now char texture[128]; // texture.bmp char alphamap[128]; // alpha.bmp *) ms3d_material_t;

Overview

Fields

Public | Name: array[0..31] of AnsiChar;
Public | Ambient: TGLColorVector;
Public | Diffuse: TGLColorVector;
Public | Specular: TGLColorVector;
Public | Emissive: TGLColorVector;
Public | Shininess: single;
Public | Transparency: single;
Public | Mode: AnsiChar;
Public | Texture: array[0..127] of AnsiChar;
Public | Alphamap: array[0..127] of AnsiChar;

Description

Fields

Public Name: array[0..31] of AnsiChar;

This item has no description.

Public Ambient: TGLColorVector;

This item has no description.

Public Diffuse: TGLColorVector;

This item has no description.

Public Specular: TGLColorVector;

This item has no description.

Public Emissive: TGLColorVector;

This item has no description.

Public Shininess: single;

This item has no description.

Public Transparency: single;

This item has no description.

Public Mode: AnsiChar;

This item has no description.

Public Texture: array[0..127] of AnsiChar;

This item has no description.

Public Alphamap: array[0..127] of AnsiChar;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DKeyframeRotation

Record TMS3DKeyframeRotation

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DKeyframeRotation = record

Description

typedef struct (* float time; // time in seconds float rotation[3]; // x, y, z angles *) ms3d_keyframe_rot_t;

Overview

Fields

Public | Time: single;
Public | Rotation: TD3DVector;

Description

Fields

Public Time: single;

This item has no description.

Public Rotation: TD3DVector;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DKeyframePosition

Record TMS3DKeyframePosition

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DKeyframePosition = record

Description

typedef struct (* float time; // time in seconds float position[3]; // local position *) ms3d_keyframe_pos_t;

Overview

Fields

Public | Time: single;
Public | Position: TD3DVector;

Description

Fields

Public Time: single;

This item has no description.

Public Position: TD3DVector;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DJointBase

Record TMS3DJointBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DJointBase = record

Description

typedef struct (* byte flags; // SELECTED | DIRTY char name[32]; // char parentName[32]; // float rotation[3]; // local reference matrix float position[3];

word numKeyFramesRot; // word numKeyFramesTrans; //

ms3d_keyframe_rot_t keyFramesRot[numKeyFramesRot]; // local animation matrices ms3d_keyframe_pos_t keyFramesTrans[numKeyFramesTrans]; // local animation matrices *) ms3d_joint_t;

Overview

Fields

Public | Flags: byte;
Public | Name: array[0..31] of AnsiChar;
Public | ParentName: array[0..31] of AnsiChar;
Public | Rotation: TD3DVector;
Public | Position: TD3DVector;
Public | NumKeyFramesRot: word;
Public | NumKeyFramesTrans: word;

Description

Fields

Public Flags: byte;

This item has no description.

Public Name: array[0..31] of AnsiChar;

This item has no description.

Public ParentName: array[0..31] of AnsiChar;

This item has no description.

Public Rotation: TD3DVector;

This item has no description.

Public Position: TD3DVector;

This item has no description.

Public NumKeyFramesRot: word;

This item has no description.

Public NumKeyFramesTrans: word;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DJoint

Record TMS3DJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DJoint = record

Description

This item has no description.

Overview

Fields

Public | Base: TMS3DJointBase;
Public | KeyFramesRot: PMS3DKeyframeRotationArray;
Public | KeyFramesTrans: PMS3DKeyframePositionArray;

Description

Fields

Public Base: TMS3DJointBase;

This item has no description.

Public KeyFramesRot: PMS3DKeyframeRotationArray;

This item has no description.

Public KeyFramesTrans: PMS3DKeyframePositionArray;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3DComment

Record TMS3DComment

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DComment = record

Description

This item has no description.

Overview

Fields

Public | index: Integer;
Public | commentLength: integer;
Public | comment: array of AnsiChar;

Description

Fields

Public index: Integer;

This item has no description.

Public commentLength: integer;

This item has no description.

Public comment: array of AnsiChar;


GLSysHelp v.2.5: GLS.FileMS3D: Class TMS3DCommentList

Class TMS3DCommentList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3DCommentList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TMS3DCommentList

Overview

Methods

Public | destructor Destroy; override;
Public | function NewComment: pMS3DComment;

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function NewComment: pMS3DComment;


GLSysHelp v.2.5: GLS.FileMS3D: Record TMS3D_vertex_ex_t

Record TMS3D_vertex_ex_t

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TMS3D_vertex_ex_t = record

Description

This item has no description.

Overview

Fields

Public | boneIds: array[0..2] of byte;
Public | weights: array[0..2] of byte;
Public | extra: cardinal;
Public | unknown: cardinal;

Description

Fields

Public boneIds: array[0..2] of byte;

This item has no description.

Public weights: array[0..2] of byte;

This item has no description.

Public extra: cardinal;

This item has no description.

Public unknown: cardinal;


GLSysHelp v.2.5: GLS.FileMS3D: Class TVertexWeightList

Class TVertexWeightList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TVertexWeightList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TVertexWeightList

Overview

Fields

Private FsubVersion: Integer;

Methods

Public | destructor Destroy; override;
Public | function newWeight: pMS3D_vertex_ex_t;
Private | function GetWeight(idx: Integer): pMS3D_vertex_ex_t;
Public | procedure Clear; override;
Private | procedure SetsubVersion(const Value: Integer);

Properties

Public | property subVersion: Integer read FsubVersion write SetsubVersion;
Public | property Weight[idx: Integer]: pMS3D_vertex_ex_t read GetWeight;

Description

Fields

Private FsubVersion: Integer;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function newWeight: pMS3D_vertex_ex_t;

This item has no description.

Private function GetWeight(idx: Integer): pMS3D_vertex_ex_t;

This item has no description.

Public procedure Clear; override;

This item has no description.

Private procedure SetsubVersion(const Value: Integer);

This item has no description.

Properties

Public property subVersion: Integer read FsubVersion write SetsubVersion;

This item has no description.

Public property Weight[idx: Integer]: pMS3D_vertex_ex_t read GetWeight;


GLSysHelp v.2.5: GLS.FileMS3D: Class TGLMS3DVectorFile

Class TGLMS3DVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileMS3D

Declaration

type TGLMS3DVectorFile = class(TGLVectorFile)

Description

The MilkShape vector file. By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLMS3DVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileNMF

Unit GLS.FileNMF

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorTypes
  • GLS.VectorFileObjects
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TNmHeader |
Record TNmRawTriangle |
Class TFileNMF |
Class TGLNMFVectorFile |

Constants

NMF_HEADER_TAG = 'NMF ';
NMF_TRIANGLE_TAG = 'TRIS';

Description

Constants

NMF_HEADER_TAG = 'NMF ';

This item has no description.

NMF_TRIANGLE_TAG = 'TRIS';


GLSysHelp v.2.5: GLS.FileNMF: Record TNmHeader

Record TNmHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileNMF

Declaration

type TNmHeader = record

Description

This item has no description.

Overview

Fields

Public | hdr: array [0 .. 3] of AnsiChar;
Public | size: cardinal;

Description

Fields

Public hdr: array [0 .. 3] of AnsiChar;

This item has no description.

Public size: cardinal;


GLSysHelp v.2.5: GLS.FileNMF: Record TNmRawTriangle

Record TNmRawTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileNMF

Declaration

type TNmRawTriangle = record

Description

This item has no description.

Overview

Fields

Public | vert: array [0 .. 2] of TAffineVector;
Public | norm: array [0 .. 2] of TAffineVector;
Public | texCoord: array [0 .. 2] of TTexPoint;

Description

Fields

Public vert: array [0 .. 2] of TAffineVector;

This item has no description.

Public norm: array [0 .. 2] of TAffineVector;

This item has no description.

Public texCoord: array [0 .. 2] of TTexPoint;


GLSysHelp v.2.5: GLS.FileNMF: Class TFileNMF

Class TFileNMF

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileNMF

Declaration

type TFileNMF = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TFileNMF

Overview

Fields

Public | FileHeader: TNmHeader;
Public | TrisHeader: TNmHeader;
Public | NumTris: Integer;
Public | RawTriangles: array of TNmRawTriangle;

Methods

Public | procedure LoadFromStream(Stream: TStream);
Public | procedure SaveToStream(Stream: TStream);

Description

Fields

Public FileHeader: TNmHeader;

This item has no description.

Public TrisHeader: TNmHeader;

This item has no description.

Public NumTris: Integer;

This item has no description.

Public RawTriangles: array of TNmRawTriangle;

This item has no description.

Methods

Public procedure LoadFromStream(Stream: TStream);

This item has no description.

Public procedure SaveToStream(Stream: TStream);


GLSysHelp v.2.5: GLS.FileNMF: Class TGLNMFVectorFile

Class TGLNMFVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileNMF

Declaration

type TGLNMFVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLNMFVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileNurbs

Unit GLS.FileNurbs

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLS.VectorFileObjects
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.ApplicationFileIO
  • GLS.ParametricSurfaces
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNurbsVectorFile |


GLSysHelp v.2.5: GLS.FileNurbs: Class TGLNurbsVectorFile

Class TGLNurbsVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileNurbs

Declaration

type TGLNurbsVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLNurbsVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(stream: TStream); override;


GLSysHelp v.2.5: GLS.FileOBJ

Unit GLS.FileOBJ

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLS.ApplicationFileIO
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.VectorFileObjects
  • GLS.VectorLists
  • GLS.Texture
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.Material
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLOBJVectorFile |
Class EGLOBJFileError |
Class TGLMTLFile |

Constants

BufSize = 10240;
LineLen = 100;

Variables

vGLFileOBJ_SplitMesh: boolean = False;

Description

Constants

BufSize = 10240;

Load input data in chunks of BufSize Bytes.

LineLen = 100;

Allocate memory for the current line in chunks of LineLen Bytes.

Variables

vGLFileOBJ_SplitMesh: boolean = False;

If enabled, main mesh will be splitted into multiple mesh from facegroup data.


GLSysHelp v.2.5: GLS.FileOBJ: Class TGLOBJVectorFile

Class TGLOBJVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileOBJ

Declaration

type TGLOBJVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLOBJVectorFile

Overview

Fields

Private | FSourceStream: TStream;
Private | FBuffer: AnsiString;
Private | FLine: string;
Private | FLineNo: Integer;
Private | FEof: Boolean;
Private | FBufPos: Integer;

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Fields

Private FSourceStream: TStream;

This item has no description.

Private FBuffer: AnsiString;

Load from this stream

Private FLine: string;

Buffer

Private FLineNo: Integer;

current line

Private FEof: Boolean;

current Line number - for error messages

Private FBufPos: Integer;

Stream done?

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileOBJ: Class EGLOBJFileError

Class EGLOBJFileError

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileOBJ

Declaration

type EGLOBJFileError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLOBJFileError

Overview

Fields

Private FLineNo: Integer;

Properties

Public property LineNo: Integer read FLineNo;

Description

Fields

Private FLineNo: Integer;

This item has no description.

Properties

Public property LineNo: Integer read FLineNo;


GLSysHelp v.2.5: GLS.FileOBJ: Class TGLMTLFile

Class TGLMTLFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileOBJ

Declaration

type TGLMTLFile = class(TStringList)

Description

A simple class that know how to extract infos from a mtl file. mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more): materials begin with a 'newmtl' command followed by material name *Kd command defines the diffuse color *map_Kd command defines the diffuse texture image *Ka/map_Ka define the ambient color and texmap *Ks/map_Ks define the specular color and texmap *Ke/map_Ke define the self-illumination/lightmap texmap map_Bump specifies the bump map *d specifies transparency (alpha-channel, range [0; 1]) map_d specifies the opcaity texture map Ns defines the specular exponent or shininess or phong specular (?) Ni is the refraction index (greater than 1) *illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting)

Hierarchy

  • TObject
  • TPersistent
  • TStrings
  • TStringList
  • TGLMTLFile

Overview

Methods

Public | function MaterialStringProperty(const materialName, propertyName: string): string;
Public | function MaterialVectorProperty(const materialName, propertyName: string; const defaultValue: TGLVector): TGLVector;
Public | procedure Prepare;

Description

Methods

Public function MaterialStringProperty(const materialName, propertyName: string): string;

This item has no description.

Public function MaterialVectorProperty(const materialName, propertyName: string; const defaultValue: TGLVector): TGLVector;

This item has no description.

Public procedure Prepare;


GLSysHelp v.2.5: GLS.FileOCT

Unit GLS.FileOCT

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Vcl.Graphics
  • GLS.Texture
  • GLS.Material
  • GLS.Graphics
  • GLS.State
  • GLScene.TextureFormat
  • GLS.VectorFileObjects
  • GLScene.VectorGeometry
  • GLS.ApplicationFileIO
  • Formats.OCT

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLOCTGLVectorFile |

Variables

vGLFileOCTLightmapBrightness: single = 1;
vGLFileOCTLightmapGammaCorrection: single = 1;
vGLFileOCTAllocateMaterials: boolean = True;

Description

Variables

vGLFileOCTLightmapBrightness: single = 1;

This item has no description.

vGLFileOCTLightmapGammaCorrection: single = 1;

Scaling factor, 1.0 = unchanged

vGLFileOCTAllocateMaterials: boolean = True;

Scaling factor, 1.0 = unchanged


GLSysHelp v.2.5: GLS.FileOCT: Class TGLOCTGLVectorFile

Class TGLOCTGLVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileOCT

Declaration

type TGLOCTGLVectorFile = class(TGLVectorFile)

Description

The OCT vector file (FSRad output).

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLOCTGLVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FilePGM

Unit GLS.FilePGM

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLS.Context
  • GLS.Graphics
  • GLScene.TextureFormat
  • GLScene.Strings
  • GLS.ApplicationFileIO
  • CUDA.Utility

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPGMImage |


GLSysHelp v.2.5: GLS.FilePGM: Class TGLPGMImage

Class TGLPGMImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FilePGM

Declaration

type TGLPGMImage = class(TGLBaseImage)

Description

This item has no description. Showing description inherited from TGLDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage
  • TGLPGMImage

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;

This item has no description.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;


GLSysHelp v.2.5: GLS.FilePLY

Unit GLS.FilePLY

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPLYVectorFile |


GLSysHelp v.2.5: GLS.FilePLY: Class TGLPLYVectorFile

Class TGLPLYVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FilePLY

Declaration

type TGLPLYVectorFile = class(TGLVectorFile)

Description

The PLY vector file aka Stanford Triangle Format. This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLPLYVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FilePNG

Unit GLS.FilePNG

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • VCL.Imaging.pngimage
  • GLScene.OpenGLTokens
  • GLScene.Strings
  • GLS.Context
  • GLS.Graphics
  • GLS.ApplicationFileIO
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPNGImage |


GLSysHelp v.2.5: GLS.FilePNG: Class TGLPNGImage

Class TGLPNGImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FilePNG

Declaration

type TGLPNGImage = class(TGLBaseImage)

Description

This item has no description. Showing description inherited from TGLDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage
  • TGLPNGImage

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(AStream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(AStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: Cardinal; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;

Assigns from any Texture.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(AStream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(AStream: TStream); override;


GLSysHelp v.2.5: GLS.FileQ3BSP

Unit GLS.FileQ3BSP

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Vcl.Graphics
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.VectorLists
  • Formats.Q3BSP
  • GLS.MeshBSP
  • GLS.Texture
  • GLS.Graphics
  • GLS.State
  • GLScene.Utils
  • GLS.Material
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLQ3BSPVectorFile |

Variables

vQ3BSPLightmapGammaCorrection: Single = 2.5;
vQ3BSPLightmapBrightness: Single = 2;
vGLFileQ3BSPLoadMaterials: boolean = True;

Description

Variables

vQ3BSPLightmapGammaCorrection: Single = 2.5;

Q3 lightmaps are quite dark, we brighten them a lot by default

vQ3BSPLightmapBrightness: Single = 2;

This item has no description.

vGLFileQ3BSPLoadMaterials: boolean = True;

scaling factor, 1.0 = unchanged


GLSysHelp v.2.5: GLS.FileQ3BSP: Class TGLQ3BSPVectorFile

Class TGLQ3BSPVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileQ3BSP

Declaration

type TGLQ3BSPVectorFile = class(TGLVectorFile)

Description

The Q3BSP vector file (Quake III BSP).

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLQ3BSPVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileQ3MD3

Unit GLS.FileQ3MD3

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorFileObjects
  • GLS.VectorLists
  • GLS.Material
  • GLS.PersistentClasses
  • Formats.MD3

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMD3TagList |

Functions and Procedures

procedure LoadQ3Anims(Animations: TGLActorAnimations; const FileName: string; const NamePrefix: string); overload;
procedure LoadQ3Anims(Animations: TGLActorAnimations; Strings: TStrings; const NamePrefix: string); overload;
procedure LoadQ3Skin(const FileName: string; Actor: TGLActor);

Description

Functions and Procedures

procedure LoadQ3Anims(Animations: TGLActorAnimations; const FileName: string; const NamePrefix: string); overload;

These procedures are helpers to load the Quake3 animation file data into an animation list. The NamePrefix parameter is used to determine which class of animation is extracted. eg NamePrefix='TORSO' will load all animations starting with 'TORSO_' like 'TORSO_STAND'

procedure LoadQ3Anims(Animations: TGLActorAnimations; Strings: TStrings; const NamePrefix: string); overload;

This item has no description.

procedure LoadQ3Skin(const FileName: string; Actor: TGLActor);

Quake3 Skin loading procedure. Use this procedure to apply textures to a GLActor. This doens't use the actors original preloaded materials so it may be a good idea to clear the actors material library before running this to keep everything nice and clean.


GLSysHelp v.2.5: GLS.FileQ3MD3: Class TMD3TagList

Class TMD3TagList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileQ3MD3

Declaration

type TMD3TagList = class(TObject)

Description

This class is used to extract the tag transform information stored in the MD3 files. The data is used to offset each part of the model based on the parent parts animation state.

Hierarchy

  • TObject
  • TMD3TagList

Overview

Fields

Private | FTags: array of TMD3Tag;
Private | FNumTags: Integer;
Private | FNumFrames: Integer;

Methods

Public | function GetTransform(const TagName: string; Frame: Integer): TGLMatrix;
Private | function GetTag(index: Integer): TMD3Tag;
Public | procedure LoadFromFile(const FileName: String);
Public | procedure LoadFromStream(AStream: TStream);

Properties

Public | property FrameCount: Integer read FNumFrames;
Public | property TagCount: Integer read FNumTags;
Public | property Tags[index: Integer]: TMD3Tag read GetTag;

Description

Fields

Private FTags: array of TMD3Tag;

This item has no description.

Private FNumTags: Integer;

This item has no description.

Private FNumFrames: Integer;

This item has no description.

Methods

Public function GetTransform(const TagName: string; Frame: Integer): TGLMatrix;

This item has no description.

Private function GetTag(index: Integer): TMD3Tag;

This item has no description.

Public procedure LoadFromFile(const FileName: String);

This item has no description.

Public procedure LoadFromStream(AStream: TStream);

This item has no description.

Properties

Public property FrameCount: Integer read FNumFrames;

This item has no description.

Public property TagCount: Integer read FNumTags;

This item has no description.

Public property Tags[index: Integer]: TMD3Tag read GetTag;


GLSysHelp v.2.5: GLS.FileSMD

Unit GLS.FileSMD

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.VectorFileObjects
  • GLS.VectorLists
  • GLS.Texture
  • GLS.PersistentClasses
  • GLS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Material
  • GLScene.Strings
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMDVectorFile |


GLSysHelp v.2.5: GLS.FileSMD: Class TGLSMDVectorFile

Class TGLSMDVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileSMD

Declaration

type TGLSMDVectorFile = class(TGLVectorFile)

Description

The SMD vector file is Half-life's skeleton format. The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames. This reader curently reads both, but requires that the main file (the one with mesh data) be read first.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLSMDVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileSTL

Unit GLS.FileSTL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.VectorFileObjects
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TSTLHeader |
Packed Record TSTLFace |
Class TGLSTLVectorFile |

Types

TSTLVertex = TAffineVector;

Variables

STLUseEmbeddedColors: Boolean;

Description

Types

TSTLVertex = TAffineVector;

This item has no description.

Variables

STLUseEmbeddedColors: Boolean;


GLSysHelp v.2.5: GLS.FileSTL: Packed Record TSTLHeader

Packed Record TSTLHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileSTL

Declaration

type TSTLHeader = packed record

Description

This item has no description.

Overview

Fields

Public | dummy: array[0..79] of byte;
Public | nbFaces: Longint;

Description

Fields

Public dummy: array[0..79] of byte;

This item has no description.

Public nbFaces: Longint;


GLSysHelp v.2.5: GLS.FileSTL: Packed Record TSTLFace

Packed Record TSTLFace

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileSTL

Declaration

type TSTLFace = packed record

Description

This item has no description.

Overview

Fields

Public | normal: TSTLVertex;
Public | v1: TSTLVertex;
Public | v2: TSTLVertex;
Public | v3: TSTLVertex;
Public | padding: array[0..1] of byte;

Description

Fields

Public normal: TSTLVertex;

This item has no description.

Public v1: TSTLVertex;

facet surface normal

Public v2: TSTLVertex;

vertex 1

Public v3: TSTLVertex;

vertex 2

Public padding: array[0..1] of byte;

vertex 3


GLSysHelp v.2.5: GLS.FileSTL: Class TGLSTLVectorFile

Class TGLSTLVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileSTL

Declaration

type TGLSTLVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLSTLVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileTGA

Unit GLS.FileTGA

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Vcl.Graphics
  • GLS.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TTGAImage |
Class ETGAException |


GLSysHelp v.2.5: GLS.FileTGA: Class TTGAImage

Class TTGAImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileTGA

Declaration

type TTGAImage = class(TBitmap)

Description

TGA image load/save capable class. TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.

Hierarchy

  • TBitmap
  • TTGAImage

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;


GLSysHelp v.2.5: GLS.FileTGA: Class ETGAException

Class ETGAException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileTGA

Declaration

type ETGAException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • ETGAException


GLSysHelp v.2.5: GLS.FileTIN

Unit GLS.FileTIN

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GLScene.VectorTypesExt
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTINVectorFile |


GLSysHelp v.2.5: GLS.FileTIN: Class TGLTINVectorFile

Class TGLTINVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileTIN

Declaration

type TGLTINVectorFile = class(TGLVectorFile)

Description

The TIN vector file (triangle irregular network). It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files). This format is encountered in the DEM/DTED world and used in place of grids.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLTINVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream : TStream); override;


GLSysHelp v.2.5: GLS.FileVfsPAK

Unit GLS.FileVfsPAK

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.Contnrs
  • System.SysUtils
  • GLScene.Strings
  • GLS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TPakHeader |
Record TFileSection |
Class TGLVfsPAK |

Functions and Procedures

function PAKCreateFileStream(const FileName: string; Mode: word): TStream;
function PAKFileStreamExists(const FileName: string): Boolean;

Types

TZCompressedMode = (...);

Constants

SIGN = 'PACK';
SIGN_COMPRESSED = 'PACZ';

Variables

ActiveVfsPAK: TGLVfsPAK;

Description

Functions and Procedures

function PAKCreateFileStream(const FileName: string; Mode: word): TStream;

This item has no description.

function PAKFileStreamExists(const FileName: string): Boolean;

This item has no description.

Types

TZCompressedMode = (...);

Signature for compressed pak.

Values
  • Good
  • Fast
  • Auto
  • None

Constants

SIGN = 'PACK';

This item has no description.

SIGN_COMPRESSED = 'PACZ';

Signature for uncompressed - raw pak.

Variables

ActiveVfsPAK: TGLVfsPAK;


GLSysHelp v.2.5: GLS.FileVfsPAK: Record TPakHeader

Record TPakHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileVfsPAK

Declaration

type TPakHeader = record

Description

This item has no description.

Overview

Fields

Public | Signature: array [0 .. 3] of AnsiChar;
Public | DirOffset: integer;
Public | DirLength: integer;

Description

Fields

Public Signature: array [0 .. 3] of AnsiChar;

This item has no description.

Public DirOffset: integer;

This item has no description.

Public DirLength: integer;


GLSysHelp v.2.5: GLS.FileVfsPAK: Record TFileSection

Record TFileSection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileVfsPAK

Declaration

type TFileSection = record

Description

This item has no description.

Overview

Fields

Public | FileName: array [0 .. 119] of AnsiChar;
Public | FilePos: integer;
Public | FileLength: integer;

Description

Fields

Public FileName: array [0 .. 119] of AnsiChar;

This item has no description.

Public FilePos: integer;

This item has no description.

Public FileLength: integer;


GLSysHelp v.2.5: GLS.FileVfsPAK: Class TGLVfsPAK

Class TGLVfsPAK

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileVfsPAK

Declaration

type TGLVfsPAK = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLVfsPAK

Overview

Fields

Private | FPakFiles: TStringList;
Private | FHeader: TPakHeader;
Private | FHeaderList: array of TPakHeader;
Private | FStream: TFileStream;
Private | FStreamList: TObjectList;
Private | FFiles: TStrings;
Private | FFilesLists: TObjectList;
Private | FFileName: string;
Private | FCompressionLevel: TZCompressedMode;
Private | FCompressed: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); overload; override;
Public | constructor Create(AOwner: TComponent; const CbrMode: TZCompressedMode); reintroduce; overload;
Public | destructor Destroy; override;
Public | function FileExists(const FileName: string): Boolean;
Public | function GetFile(const FileName: string): TStream; overload;
Public | function GetFile(index: integer): TStream; overload;
Public | function GetFileSize(index: integer): integer; overload;
Public | function GetFileSize(const FileName: string): integer; overload;
Private | function GetFileCount: integer;
Private | function GetStreamNumber: integer;
Public | procedure AddEmptyFile(const FileName, Path: string);
Public | procedure AddFromFile(const FileName, Path: string);
Public | procedure AddFromStream(const FileName, Path: string; F: TStream);
Public | procedure ClearPakFiles;
Public | procedure Extract(index: integer; const NewName: string); overload;
Public | procedure Extract(const FileName, NewName: string); overload;
Public | procedure LoadFromFile(const FileName: string; Mode: word);
Public | procedure RemoveFile(const FileName: string); overload;
Public | procedure RemoveFile(index: integer); overload;
Private | procedure MakeFileList;
Private | procedure SetStreamNumber(i: integer);

Properties

Public | property ActivePakNum: integer read GetStreamNumber write SetStreamNumber;
Public | property Compressed: Boolean read FCompressed;
Public | property CompressionLevel: TZCompressedMode read FCompressionLevel;
Public | property FileCount: integer Read GetFileCount;
Public | property Files: TStrings read FFiles;
Public | property PakFileName: string Read FFileName;
Public | property PakFiles: TStringList read FPakFiles;

Description

Fields

Private FPakFiles: TStringList;

This item has no description.

Private FHeader: TPakHeader;

This item has no description.

Private FHeaderList: array of TPakHeader;

This item has no description.

Private FStream: TFileStream;

This item has no description.

Private FStreamList: TObjectList;

This item has no description.

Private FFiles: TStrings;

This item has no description.

Private FFilesLists: TObjectList;

This item has no description.

Private FFileName: string;

This item has no description.

Private FCompressionLevel: TZCompressedMode;

This item has no description.

Private FCompressed: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); overload; override;

This item has no description.

Public constructor Create(AOwner: TComponent; const CbrMode: TZCompressedMode); reintroduce; overload;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FileExists(const FileName: string): Boolean;

This item has no description.

Public function GetFile(const FileName: string): TStream; overload;

This item has no description.

Public function GetFile(index: integer): TStream; overload;

This item has no description.

Public function GetFileSize(index: integer): integer; overload;

This item has no description.

Public function GetFileSize(const FileName: string): integer; overload;

This item has no description.

Private function GetFileCount: integer;

This item has no description.

Private function GetStreamNumber: integer;

This item has no description.

Public procedure AddEmptyFile(const FileName, Path: string);

This item has no description.

Public procedure AddFromFile(const FileName, Path: string);

This item has no description.

Public procedure AddFromStream(const FileName, Path: string; F: TStream);

This item has no description.

Public procedure ClearPakFiles;

This item has no description.

Public procedure Extract(index: integer; const NewName: string); overload;

This item has no description.

Public procedure Extract(const FileName, NewName: string); overload;

This item has no description.

Public procedure LoadFromFile(const FileName: string; Mode: word);

for Mode value search Delphi Help for "File open mode constants"

Public procedure RemoveFile(const FileName: string); overload;

This item has no description.

Public procedure RemoveFile(index: integer); overload;

This item has no description.

Private procedure MakeFileList;

This item has no description.

Private procedure SetStreamNumber(i: integer);

This item has no description.

Properties

Public property ActivePakNum: integer read GetStreamNumber write SetStreamNumber;

This item has no description.

Public property Compressed: Boolean read FCompressed;

This item has no description.

Public property CompressionLevel: TZCompressedMode read FCompressionLevel;

This item has no description.

Public property FileCount: integer Read GetFileCount;

This item has no description.

Public property Files: TStrings read FFiles;

This item has no description.

Public property PakFileName: string Read FFileName;

This item has no description.

Public property PakFiles: TStringList read FPakFiles;


GLSysHelp v.2.5: GLS.FileVOR

Unit GLS.FileVOR

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.VectorFileObjects
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TVORHeader |
Packed Record TVORFace |
Class TGLVORVectorFile |

Types

TVORVertex = TAffineVector;

Variables

VORUseEmbeddedColors: Boolean;

Description

Types

TVORVertex = TAffineVector;

This item has no description.

Variables

VORUseEmbeddedColors: Boolean;


GLSysHelp v.2.5: GLS.FileVOR: Packed Record TVORHeader

Packed Record TVORHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileVOR

Declaration

type TVORHeader = packed record

Description

This item has no description.

Overview

Fields

Public | dummy: array[0..79] of byte;
Public | nbFaces: Longint;

Description

Fields

Public dummy: array[0..79] of byte;

This item has no description.

Public nbFaces: Longint;


GLSysHelp v.2.5: GLS.FileVOR: Packed Record TVORFace

Packed Record TVORFace

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileVOR

Declaration

type TVORFace = packed record

Description

This item has no description.

Overview

Fields

Public | normal: TVORVertex;
Public | v1: TVORVertex;
Public | v2: TVORVertex;
Public | v3: TVORVertex;
Public | padding: array[0..1] of byte;

Description

Fields

Public normal: TVORVertex;

This item has no description.

Public v1: TVORVertex;

facet surface normal

Public v2: TVORVertex;

vertex 1

Public v3: TVORVertex;

vertex 2

Public padding: array[0..1] of byte;

vertex 3


GLSysHelp v.2.5: GLS.FileVOR: Class TGLVORVectorFile

Class TGLVORVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileVOR

Declaration

type TGLVORVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLVORVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileVRML

Unit GLS.FileVRML

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLS.VectorFileObjects
  • GLS.Material
  • GLS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • Formats.VRML
  • GLS.MeshUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLVRMLVectorFile |


GLSysHelp v.2.5: GLS.FileVRML: Class TGLVRMLVectorFile

Class TGLVRMLVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileVRML

Declaration

type TGLVRMLVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLVRMLVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileWAV

Unit GLS.FileWAV

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.MMSystem
  • System.Classes
  • GLS.ApplicationFileIO
  • GLS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWAVFile |


GLSysHelp v.2.5: GLS.FileWAV: Class TGLWAVFile

Class TGLWAVFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileWAV

Declaration

type TGLWAVFile = class(TGLSoundFile)

Description

Support for Windows WAV format.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLSoundFile
  • TGLWAVFile

Overview

Fields

Private | waveFormat: TWaveFormatEx;
Private | pcmOffset: Integer;
Private | FPCMDataLength: Integer;
Private | data: array of Byte;

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | function CreateCopy(AOwner: TPersistent): TGLDataFile; override;
Public | function LengthInBytes: Integer; override;
Public | function PCMData: Pointer; override;
Public | function WAVData: Pointer; override;
Public | function WAVDataSize: Integer; override;
Public | procedure LoadFromStream(Stream: TStream); override;
Public | procedure PlayOnWaveOut; override;
Public | procedure SaveToStream(Stream: TStream); override;

Description

Fields

Private waveFormat: TWaveFormatEx;

This item has no description.

Private pcmOffset: Integer;

This item has no description.

Private FPCMDataLength: Integer;

This item has no description.

Private data: array of Byte;

This item has no description.

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public function CreateCopy(AOwner: TPersistent): TGLDataFile; override;

used to store WAVE bitstream

Public function LengthInBytes: Integer; override;

This item has no description. Showing description inherited from TGLSoundFile.LengthInBytes.

Length of PCM data, in bytes.

Public function PCMData: Pointer; override;

This item has no description. Showing description inherited from TGLSoundFile.PCMData.

Returns a pointer to the sample data viewed as an in-memory PCM buffer.

Public function WAVData: Pointer; override;

This item has no description. Showing description inherited from TGLSoundFile.WAVData.

Returns a pointer to the sample data viewed as an in-memory WAV File.

Public function WAVDataSize: Integer; override;

This item has no description. Showing description inherited from TGLSoundFile.WAVDataSize.

Returns the size (in bytes) of the WAVData.

Public procedure LoadFromStream(Stream: TStream); override;

This item has no description.

Public procedure PlayOnWaveOut; override;

This item has no description.

Public procedure SaveToStream(Stream: TStream); override;


GLSysHelp v.2.5: GLS.FileX

Unit GLS.FileX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLS.VectorLists
  • GLScene.VectorGeometry
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLS.Texture
  • GLS.Material
  • Formats.X

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLXVectorFile |


GLSysHelp v.2.5: GLS.FileX: Class TGLXVectorFile

Class TGLXVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileX

Declaration

type TGLXVectorFile = class(TGLVectorFile)

Description

This item has no description. Showing description inherited from TGLVectorFile.

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLXVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.FileZLIB

Unit GLS.FileZLIB

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.ZLib
  • GLS.ArchiveManager

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TZLibHeader |
Record TFileSection |
Class TZLibArchive |

Constants

SIGN = 'ZLIB';

Description

Constants

SIGN = 'ZLIB';


GLSysHelp v.2.5: GLS.FileZLIB: Record TZLibHeader

Record TZLibHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileZLIB

Declaration

type TZLibHeader = record

Description

Signature for compressed zlib.

Overview

Fields

Public | Signature: array[0..3] of AnsiChar;
Public | DirOffset: integer;
Public | DirLength: integer;

Description

Fields

Public Signature: array[0..3] of AnsiChar;

This item has no description.

Public DirOffset: integer;

This item has no description.

Public DirLength: integer;


GLSysHelp v.2.5: GLS.FileZLIB: Record TFileSection

Record TFileSection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileZLIB

Declaration

type TFileSection = record

Description

This item has no description.

Overview

Fields

Public | FileName: array[0..119] of AnsiChar;
Public | FilePos: integer;
Public | FileLength: integer;
Public | CbrMode: TCompressionLevel;

Description

Fields

Public FileName: array[0..119] of AnsiChar;

This item has no description.

Public FilePos: integer;

This item has no description.

Public FileLength: integer;

This item has no description.

Public CbrMode: TCompressionLevel;


GLSysHelp v.2.5: GLS.FileZLIB: Class TZLibArchive

Class TZLibArchive

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FileZLIB

Declaration

type TZLibArchive = class(TGLBaseArchive)

Description

This item has no description. Showing description inherited from TGLBaseArchive.

BaseArchive class

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseArchive
  • TZLibArchive

Overview

Fields

Private | FHeader: TZLibHeader;
Private | FStream: TFileStream;

Methods

Public | destructor Destroy; override;
Public | function ContentExists(ContentName: string): boolean; override;
Public | function GetContent(aStream: TStream; index: integer): TStream; override;
Public | function GetContent(index: integer): TStream; override;
Public | function GetContent(ContentName: string): TStream; override;
Public | function GetContentSize(index: integer): integer; override;
Public | function GetContentSize(ContentName: string): integer; override;
Private | function GetContentCount: integer;
Public | procedure AddFromFile(FileName, Path: string); override;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); override;
Public | procedure Clear; override;
Public | procedure Extract(ContentName, NewName: string); override;
Public | procedure Extract(index: integer; NewName: string); override;
Public | procedure LoadFromFile(const FileName: string); override;
Public | procedure RemoveContent(ContentName: string); overload; override;
Public | procedure RemoveContent(index: integer); overload; override;
Private | procedure MakeContentList;

Properties

Public property ContentCount: integer Read GetContentCount;

Description

Fields

Private FHeader: TZLibHeader;

This item has no description.

Private FStream: TFileStream;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function ContentExists(ContentName: string): boolean; override;

This item has no description.

Public function GetContent(aStream: TStream; index: integer): TStream; override;

This item has no description.

Public function GetContent(index: integer): TStream; override;

This item has no description.

Public function GetContent(ContentName: string): TStream; override;

This item has no description.

Public function GetContentSize(index: integer): integer; override;

This item has no description.

Public function GetContentSize(ContentName: string): integer; override;

This item has no description.

Private function GetContentCount: integer;

This item has no description.

Public procedure AddFromFile(FileName, Path: string); override;

This item has no description.

Public procedure AddFromStream(ContentName, Path: string; FS: TStream); override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure Extract(ContentName, NewName: string); override;

This item has no description.

Public procedure Extract(index: integer; NewName: string); override;

This item has no description.

Public procedure LoadFromFile(const FileName: string); override;

This item has no description.

Public procedure RemoveContent(ContentName: string); overload; override;

This item has no description.

Public procedure RemoveContent(index: integer); overload; override;

This item has no description.

Private procedure MakeContentList;

This item has no description.

Properties

Public property ContentCount: integer Read GetContentCount;


GLSysHelp v.2.5: GLS.FireFX

Unit GLS.FireFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLScene.PipelineTransform
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.VectorLists
  • GLScene.VectorTypes
  • GLS.Cadencer
  • GLS.Color
  • GLS.BaseClasses
  • GLS.Coordinates
  • GLScene.Manager
  • GLS.RenderContextInfo
  • GLS.State
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLFireParticle |
Class TGLFireFXManager |
Class TGLBFireFX |

Functions and Procedures

function GetOrCreateFireFX(effects: TGLEffects): TGLBFireFX; overload;
function GetOrCreateFireFX(obj: TGLBaseSceneObject): TGLBFireFX; overload;

Types

PGLFireParticle = ˆTGLFireParticle;
PGLFireParticleArray = ˆTGLFireParticleArray;
TGLFireParticleArray = array[0..MAXINT shr 6] of TGLFireParticle;

Description

Functions and Procedures

function GetOrCreateFireFX(effects: TGLEffects): TGLBFireFX; overload;

Returns or creates the TGLBFireFX within the given behaviours. This helper function is convenient way to access a TGLBFireFX.

function GetOrCreateFireFX(obj: TGLBaseSceneObject): TGLBFireFX; overload;

Returns or creates the TGLBFireFX within the given object's behaviours. This helper function is convenient way to access a TGLBFireFX.

Types

PGLFireParticle = ˆTGLFireParticle;

This item has no description.

PGLFireParticleArray = ˆTGLFireParticleArray;

This item has no description.

TGLFireParticleArray = array[0..MAXINT shr 6] of TGLFireParticle;


GLSysHelp v.2.5: GLS.FireFX: Record TGLFireParticle

Record TGLFireParticle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FireFX

Declaration

type TGLFireParticle = record

Description

This item has no description.

Overview

Fields

Public | Position: TGLVector;
Public | Speed: TGLVector;
Public | Alpha: Single;
Public | TimeToLive: Single;
Public | LifeLength: Single;

Description

Fields

Public Position: TGLVector;

This item has no description.

Public Speed: TGLVector;

This item has no description.

Public Alpha: Single;

This item has no description.

Public TimeToLive: Single;

This item has no description.

Public LifeLength: Single;


GLSysHelp v.2.5: GLS.FireFX: Class TGLFireFXManager

Class TGLFireFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FireFX

Declaration

type TGLFireFXManager = class(TGLCadenceAbleComponent)

Description

Fire special effect manager. Defines the looks and behaviour of a particle system that can be made to look fire-like.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLFireFXManager

Overview

Fields

Private | FClients: TList;
Private | FFireParticles: PGLFireParticleArray;
Private | FFireDir: TGLCoordinates;
Private | FInitialDir: TGLCoordinates;
Private | FCadencer: TGLCadencer;
Private | FMaxParticles: Integer;
Private | FParticleLife: Integer;
Private | FParticleSize: Single;
Private | FFireDensity: Single;
Private | FFireEvaporation: Single;
Private | FFireCrown: Single;
Private | FParticleInterval: Single;
Private | IntervalDelta: Single;
Private | NP: Integer;
Private | FInnerColor: TGLColor;
Private | FOuterColor: TGLColor;
Private | FFireBurst: Single;
Private | FFireRadius: Single;
Private | FDisabled: Boolean;
Private | FPaused: Boolean;
Private | FUseInterval: Boolean;
Private | FReference: TGLBaseSceneObject;
Private | FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure FireInit;
Public | procedure IsotropicExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; nbParticles: Integer = -1);
Public | procedure RingExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; const ringVectorX, ringVectorY: TAffineVector; nbParticles: Integer = -1);

Properties

Published | property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Published | property Disabled: Boolean read FDisabled write FDisabled;
Published | property FireBurst: Single read FFireBurst write FFireBurst;
Published | property FireCrown: Single read FFireCrown write FFireCrown;
Published | property FireDensity: Single read FFireDensity write FFireDensity;
Published | property FireDir: TGLCoordinates read FFireDir write SetFireDir;
Published | property FireEvaporation: Single read FFireEvaporation write FFireEvaporation;
Published | property FireRadius: Single read FFireRadius write FFireRadius;
Published | property InitialDir: TGLCoordinates read FInitialDir write SetInitialDir;
Published | property InnerColor: TGLColor read FInnerColor write SetInnerColor;
Published | property MaxParticles: Integer read FMaxParticles write SetMaxParticles default 256;
Published | property NoZWrite: Boolean read FNoZWrite write FNoZWrite default True;
Published | property OuterColor: TGLColor read FOuterColor write SetOuterColor;
Public | property ParticleCount: Integer read NP;
Published | property ParticleInterval: Single read FParticleInterval write FParticleInterval;
Published | property ParticleLife: Integer read FParticleLife write FParticleLife default 3;
Published | property ParticleSize: Single read FParticleSize write FParticleSize stored StoreParticleSize;
Published | property Paused: Boolean read FPaused write FPaused;
Published | property Reference: TGLBaseSceneObject read FReference write SetReference;
Published | property UseInterval: Boolean read FUseInterval write FUseInterval;

Description

Fields

Private FClients: TList;

This item has no description.

Private FFireParticles: PGLFireParticleArray;

This item has no description.

Private FFireDir: TGLCoordinates;

This item has no description.

Private FInitialDir: TGLCoordinates;

This item has no description.

Private FCadencer: TGLCadencer;

This item has no description.

Private FMaxParticles: Integer;

This item has no description.

Private FParticleLife: Integer;

This item has no description.

Private FParticleSize: Single;

This item has no description.

Private FFireDensity: Single;

This item has no description.

Private FFireEvaporation: Single;

This item has no description.

Private FFireCrown: Single;

This item has no description.

Private FParticleInterval: Single;

This item has no description.

Private IntervalDelta: Single;

This item has no description.

Private NP: Integer;

This item has no description.

Private FInnerColor: TGLColor;

This item has no description.

Private FOuterColor: TGLColor;

This item has no description.

Private FFireBurst: Single;

This item has no description.

Private FFireRadius: Single;

This item has no description.

Private FDisabled: Boolean;

This item has no description.

Private FPaused: Boolean;

This item has no description.

Private FUseInterval: Boolean;

This item has no description.

Private FReference: TGLBaseSceneObject;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure FireInit;

Reinitializes the fire.

Public procedure IsotropicExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; nbParticles: Integer = -1);

Spawns a large quantity of particles to simulate an isotropic explosion. This method generates an isotropic explosion, i.e. there is no privilegied direction in the initial vector.

Public procedure RingExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; const ringVectorX, ringVectorY: TAffineVector; nbParticles: Integer = -1);

Spawns a large quantity of particles to simulate a ring explosion. This method generates a ring explosion. The plane of the ring is described by ringVectorX/Y, which should be of unit length (but you may not make them of unit length if you want "elliptic" rings).

Properties

Published property Cadencer: TGLCadencer read FCadencer write SetCadencer;

The cadencer that will "drive" the animation of the system.

Published property Disabled: Boolean read FDisabled write FDisabled;

If true, no new particles are spawn. But current ones continue to live and die.

Published property FireBurst: Single read FFireBurst write FFireBurst;

This item has no description.

Published property FireCrown: Single read FFireCrown write FFireCrown;

Adjust a crown (circular) radius on which particles are spawned. With a value of zero, the particles are spawned in the FireRadius cube around the origin, with a non zero value, they appear in a torus of major radius FireCrown, and minor radius FireRadius*1.73.

Published property FireDensity: Single read FFireDensity write FFireDensity;

default clrWhite;

Published property FireDir: TGLCoordinates read FFireDir write SetFireDir;

Adjusts the acceleration direction (abs coordinates).

Published property FireEvaporation: Single read FFireEvaporation write FFireEvaporation;

This item has no description.

Published property FireRadius: Single read FFireRadius write FFireRadius;

Adjusts the random birth radius for particles (actually a birth cube).

Published property InitialDir: TGLCoordinates read FInitialDir write SetInitialDir;

Adjusts the initial direction (abs coordinates).

Published property InnerColor: TGLColor read FInnerColor write SetInnerColor;

Inner color of a particle.

Published property MaxParticles: Integer read FMaxParticles write SetMaxParticles default 256;

Maximum number of simultaneous particles in the system.

Published property NoZWrite: Boolean read FNoZWrite write FNoZWrite default True;

Particle's render won't write to Z-Buffer

Published property OuterColor: TGLColor read FOuterColor write SetOuterColor;

Outer color of a particle.

Public property ParticleCount: Integer read NP;

Current Nb of particles.

Published property ParticleInterval: Single read FParticleInterval write FParticleInterval;

Interval between particles births (in sec). The interval may not be honoured if MawParticles is reached.

Published property ParticleLife: Integer read FParticleLife write FParticleLife default 3;

Life length of particle.

Published property ParticleSize: Single read FParticleSize write FParticleSize stored StoreParticleSize;

Size of the particle, in absolute units.

Published property Paused: Boolean read FPaused write FPaused;

When paused, the fire animation is freezed.

Published property Reference: TGLBaseSceneObject read FReference write SetReference;

Specifies an optional object whose position to use as reference. This property allows switching between static/shared fires (for fireplaces or static torches) and dynamic fire trails. The absolute position of the reference object is 'central' spawning point for new particles, usually, the object will be the one and only one on which the effect is applied.

Published property UseInterval: Boolean read FUseInterval write FUseInterval;

Enable/disable use of ParticleInterval. If true ParticleInterval is used, if False, the system will attempt to maintain a particle count of MaxParticles, by spawning new particles to replace the dead ones ASAP.


GLSysHelp v.2.5: GLS.FireFX: Class TGLBFireFX

Class TGLBFireFX

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FireFX

Declaration

type TGLBFireFX = class(TGLObjectPostEffect)

Description

Fire special effect. This effect works as a client of TFireFXManager

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect
  • TGLObjectPostEffect
  • TGLBFireFX

Overview

Fields

Private | FManager: TGLFireFXManager;
Private | FManagerName: string;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Published property Manager: TGLFireFXManager read FManager write SetManager;

Description

Fields

Private FManager: TGLFireFXManager;

This item has no description.

Private FManagerName: string;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure Render(var rci: TGLRenderContextInfo); override;

Old - procedure Render(sceneBuffer: TGLSceneBuffer; var rci: TGLRenderContextInfo); override;

Properties

Published property Manager: TGLFireFXManager read FManager write SetManager;

Refers the collision manager.


GLSysHelp v.2.5: GLS.FPSMovement

Unit GLS.FPSMovement

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.Classes
  • System.Types
  • System.SysUtils
  • Vcl.Graphics
  • GLScene.OpenGLTokens
  • GLS.Coordinates
  • GLScene.VectorTypes
  • GLS.Context
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.VectorFileObjects
  • GLS.VectorLists
  • GLScene.XCollection
  • GLS.GeomObjects
  • GLS.Navigator
  • GLS.RenderContextInfo
  • GLS.BaseClasses
  • GLScene.Manager
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLContactPoint |
Class TGLCollisionState |
Class TGLCollisionStates |
Class TGLMapCollectionItem |
Class TGLMapCollection |
Class TGLFPSMovementManager |
Class TGLBFPSMovement |

Functions and Procedures

function GetFPSMovement(behaviours: TGLBehaviours): TGLBFPSMovement; overload;
function GetFPSMovement(obj: TGLBaseSceneObject): TGLBFPSMovement; overload;
function GetOrCreateFPSMovement(behaviours: TGLBehaviours): TGLBFPSMovement; overload;
function GetOrCreateFPSMovement(obj: TGLBaseSceneObject): TGLBFPSMovement; overload;

Types

TGLMapCollectionItemClass = class of TGLMapCollectionItem;

Description

Functions and Procedures

function GetFPSMovement(behaviours: TGLBehaviours): TGLBFPSMovement; overload;

This item has no description.

function GetFPSMovement(obj: TGLBaseSceneObject): TGLBFPSMovement; overload;

This item has no description.

function GetOrCreateFPSMovement(behaviours: TGLBehaviours): TGLBFPSMovement; overload;

This item has no description.

function GetOrCreateFPSMovement(obj: TGLBaseSceneObject): TGLBFPSMovement; overload;

This item has no description.

Types

TGLMapCollectionItemClass = class of TGLMapCollectionItem;


GLSysHelp v.2.5: GLS.FPSMovement: Record TGLContactPoint

Record TGLContactPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FPSMovement

Declaration

type TGLContactPoint = record

Description

This item has no description.

Overview

Fields

Public | intPoint: TGLVector;
Public | intNormal: TGLVector;

Description

Fields

Public intPoint: TGLVector;

This item has no description.

Public intNormal: TGLVector;


GLSysHelp v.2.5: GLS.FPSMovement: Class TGLCollisionState

Class TGLCollisionState

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FPSMovement

Declaration

type TGLCollisionState = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLCollisionState

Overview

Fields

Public | Position: TGLVector;
Public | Contact: TGLContactPoint;
Public | Time: Int64;

Description

Fields

Public Position: TGLVector;

This item has no description.

Public Contact: TGLContactPoint;

This item has no description.

Public Time: Int64;


GLSysHelp v.2.5: GLS.FPSMovement: Class TGLCollisionStates

Class TGLCollisionStates

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FPSMovement

Declaration

type TGLCollisionStates = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLCollisionStates


GLSysHelp v.2.5: GLS.FPSMovement: Class TGLMapCollectionItem

Class TGLMapCollectionItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FPSMovement

Declaration

type TGLMapCollectionItem = class(TXCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLMapCollectionItem

Overview

Fields

Private | FMap: TGLFreeForm;
Private | FMapName: string;
Private | FCollisionGroup: integer;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | class function FriendlyName: String; override;
Private | procedure setMap(value: TGLFreeForm);

Properties

Published | property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;
Published | property Map: TGLFreeForm read FMap write setMap;

Description

Fields

Private FMap: TGLFreeForm;

This item has no description.

Private FMapName: string;

This item has no description.

Private FCollisionGroup: integer;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private procedure setMap(value: TGLFreeForm);

This item has no description.

Properties

Published property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;

Indicates the collision group of this map. A Collision Group is a set of logical maps and movers that can collide between themselves (i.e. a Behaviour with group 1 can only collide with maps that are also on group 1).

Published property Map: TGLFreeForm read FMap write setMap;


GLSysHelp v.2.5: GLS.FPSMovement: Class TGLMapCollection

Class TGLMapCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FPSMovement

Declaration

type TGLMapCollection = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLMapCollection

Overview

Methods

Public | function addMap(Map: TGLFreeForm; CollisionGroup: integer = 0) : TGLMapCollectionItem;
Public | function findMap(mapFreeForm: TGLFreeForm): TGLMapCollectionItem;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public function addMap(Map: TGLFreeForm; CollisionGroup: integer = 0) : TGLMapCollectionItem;

This item has no description.

Public function findMap(mapFreeForm: TGLFreeForm): TGLMapCollectionItem;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.


GLSysHelp v.2.5: GLS.FPSMovement: Class TGLFPSMovementManager

Class TGLFPSMovementManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FPSMovement

Declaration

type TGLFPSMovementManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLFPSMovementManager

Overview

Fields

Private | FNavigator: TGLNavigator;
Private | FDisplayTime: integer;
Private | FMovementScale: single;
Private | FMaps: TGLMapCollection;
Private | FScene: TGLScene;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function SphereSweepAndSlide(freeform: TGLFreeForm; behaviour: TGLBFPSMovement; SphereStart: TGLVector; var Velocity, newPosition: TGLVector; sphereRadius: single): boolean; overload;
Public | procedure SphereSweepAndSlide(behaviour: TGLBFPSMovement; SphereStart: TGLVector; var Velocity, newPosition: TGLVector; sphereRadius: single); overload;
Private | procedure DrawArrows(intPoint, intNormal, Ray: TGLVector; Arrow1, Arrow2: TGLArrowLine);
Private | procedure SetNavigator(value: TGLNavigator);
Private | procedure setScene(value: TGLScene);

Properties

Published | property DisplayTime: integer read FDisplayTime write FDisplayTime;
Published | property Maps: TGLMapCollection read FMaps write FMaps;
Published | property MovementScale: single read FMovementScale write FMovementScale;
Published | property Navigator: TGLNavigator read FNavigator write SetNavigator;
Published | property Scene: TGLScene read FScene write setScene;

Description

Fields

Private FNavigator: TGLNavigator;

This item has no description.

Private FDisplayTime: integer;

This item has no description.

Private FMovementScale: single;

This item has no description.

Private FMaps: TGLMapCollection;

This item has no description.

Private FScene: TGLScene;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function SphereSweepAndSlide(freeform: TGLFreeForm; behaviour: TGLBFPSMovement; SphereStart: TGLVector; var Velocity, newPosition: TGLVector; sphereRadius: single): boolean; overload;

Basic idea is to OctreeSphereSweepIntersect to plane, update position then change velocity to slide along the plane. Camera can collide with multiple planes (e.g. floor + multiple walls + ceiling) limit iterations to 4 or 5 for now, may need to be higher for more complex maps or fast motion

Public procedure SphereSweepAndSlide(behaviour: TGLBFPSMovement; SphereStart: TGLVector; var Velocity, newPosition: TGLVector; sphereRadius: single); overload;

This item has no description.

Private procedure DrawArrows(intPoint, intNormal, Ray: TGLVector; Arrow1, Arrow2: TGLArrowLine);

This item has no description.

Private procedure SetNavigator(value: TGLNavigator);

This item has no description.

Private procedure setScene(value: TGLScene);

This item has no description.

Properties

Published property DisplayTime: integer read FDisplayTime write FDisplayTime;

Display Time for the arrow lines.

Published property Maps: TGLMapCollection read FMaps write FMaps;

This item has no description.

Published property MovementScale: single read FMovementScale write FMovementScale;

This item has no description.

Published property Navigator: TGLNavigator read FNavigator write SetNavigator;

This item has no description.

Published property Scene: TGLScene read FScene write setScene;


GLSysHelp v.2.5: GLS.FPSMovement: Class TGLBFPSMovement

Class TGLBFPSMovement

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FPSMovement

Declaration

type TGLBFPSMovement = class(TGLBehaviour)

Description

This item has no description. Showing description inherited from TGLBehaviour.

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBFPSMovement

Overview

Fields

Private | FManager: TGLFPSMovementManager;
Private | CollisionStates: TGLCollisionStates;
Private | ArrowLine1: TGLArrowLine;
Private | ArrowLine2: TGLArrowLine;
Private | ArrowLine3: TGLArrowLine;
Private | ArrowLine4: TGLArrowLine;
Private | ArrowLine5: TGLArrowLine;
Private | ArrowLine6: TGLArrowLine;
Private | dirGl: TGLDirectOpenGL;
Private | tickCount: Int64;
Private | oldPosition: TGLVector;
Private | FGravityEnabled: boolean;
Private | FSphereRadius: single;
Private | FShowArrows: boolean;
Private | FCollisionGroup: integer;
Private | FManagerName: string;
Public | Velocity: TGLVector;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure MoveForward(Distance: single);
Public | procedure StrafeHorizontal(Distance: single);
Public | procedure StrafeVertical(Distance: single);
Public | procedure Straighten;
Public | procedure TurnHorizontal(Angle: single);
Public | procedure TurnVertical(Angle: single);
Private | procedure RenderArrowLines(Sender: TObject; var rci: TGLRenderContextInfo);
Private | procedure setShowArrows(value: boolean);

Properties

Published | property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;
Published | property GravityEnabled: boolean read FGravityEnabled write FGravityEnabled;
Published | property Manager: TGLFPSMovementManager read FManager write FManager;
Published | property ShowArrows: boolean read FShowArrows write setShowArrows;
Published | property sphereRadius: single read FSphereRadius write FSphereRadius;

Description

Fields

Private FManager: TGLFPSMovementManager;

This item has no description.

Private CollisionStates: TGLCollisionStates;

This item has no description.

Private ArrowLine1: TGLArrowLine;

This item has no description.

Private ArrowLine2: TGLArrowLine;

This item has no description.

Private ArrowLine3: TGLArrowLine;

This item has no description.

Private ArrowLine4: TGLArrowLine;

This item has no description.

Private ArrowLine5: TGLArrowLine;

This item has no description.

Private ArrowLine6: TGLArrowLine;

This item has no description.

Private dirGl: TGLDirectOpenGL;

This item has no description.

Private tickCount: Int64;

This item has no description.

Private oldPosition: TGLVector;

This item has no description.

Private FGravityEnabled: boolean;

This item has no description.

Private FSphereRadius: single;

This item has no description.

Private FShowArrows: boolean;

This item has no description.

Private FCollisionGroup: integer;

This item has no description.

Private FManagerName: string;

This item has no description.

Public Velocity: TGLVector;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure MoveForward(Distance: single);

This item has no description.

Public procedure StrafeHorizontal(Distance: single);

This item has no description.

Public procedure StrafeVertical(Distance: single);

This item has no description.

Public procedure Straighten;

This item has no description.

Public procedure TurnHorizontal(Angle: single);

This item has no description.

Public procedure TurnVertical(Angle: single);

This item has no description.

Private procedure RenderArrowLines(Sender: TObject; var rci: TGLRenderContextInfo);

This item has no description.

Private procedure setShowArrows(value: boolean);

This item has no description.

Properties

Published property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;

Indicates the collision group of this behaviour. A Collision Group is a set of logical maps and movers that can collide between themselves (i.e. a Behaviour with group 1 can only collide with maps that are also on group 1)

Published property GravityEnabled: boolean read FGravityEnabled write FGravityEnabled;

This item has no description.

Published property Manager: TGLFPSMovementManager read FManager write FManager;

This item has no description.

Published property ShowArrows: boolean read FShowArrows write setShowArrows;

Show Arrows and trailing for debuging.

Published property sphereRadius: single read FSphereRadius write FSphereRadius;

Radius to execute the testing with. A value < 0 indicates to use the boundingSphereRadius of the object.


GLSysHelp v.2.5: GLS.FullScreenViewer

Unit GLS.FullScreenViewer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.Classes
  • System.SysUtils
  • VCL.Forms
  • VCL.Controls
  • VCL.Menus
  • GLScene.OpenGLTokens
  • GLScene.Utils
  • GLS.Context
  • GLS.ImageUtils
  • GLS.Scene
  • GLS.SceneViewer

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFullScreenViewer |

Functions and Procedures

procedure Register;

Types

TGLScreenDepth = (...);

Description

Functions and Procedures

procedure Register;

This item has no description.

Types

TGLScreenDepth = (...);

This item has no description.

Values
  • sd8bits
  • sd16bits
  • sd24bits
  • sd32bits


GLSysHelp v.2.5: GLS.FullScreenViewer: Class TGLFullScreenViewer

Class TGLFullScreenViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.FullScreenViewer

Declaration

type TGLFullScreenViewer = class(TGLNonVisualViewer)

Description

A FullScreen viewer. This non visual viewer will, when activated, use the full screen as rendering surface. It will also switch/restore videomode depending on the required width/height. This is performed by creating an underlying TForm and using its surface for rendering OpenGL, "decent" ICDs will automatically use PageFlipping instead of BlockTransfer (slower buffer flipping mode used for windowed OpenGL). Note: if you terminate the application either via a kill or in the IDE, the original resolution isn't restored.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLNonVisualViewer
  • TGLFullScreenViewer

Overview

Fields

Private | FFormIsOwned: Boolean;
Private | FForm: TForm;
Private | FOwnDC: HWND;
Private | FScreenDepth: TGLScreenDepth;
Private | FActive: Boolean;
Private | FSwitchedResolution: Boolean;
Private | FManualRendering: Boolean;
Private | FUpdateCount: Integer;
Private | FOnMouseDown: TMouseEvent;
Private | FOnMouseUp: TMouseEvent;
Private | FOnMouseMove: TMouseMoveEvent;
Private | FOnMouseWheel: TMouseWheelEvent;
Private | FOnMouseWheelDown: TMouseWheelUpDownEvent;
Private | FOnMouseWheelUp: TMouseWheelUpDownEvent;
Private | FOnClick: TNotifyEvent;
Private | FOnDblClick: TNotifyEvent;
Private | FOnKeyDown: TKeyEvent;
Private | FOnKeyUp: TKeyEvent;
Private | FOnKeyPress: TKeyPressEvent;
Private | FOnClose: TCloseEvent;
Private | FOnCloseQuery: TCloseQueryEvent;
Private | FStayOnTop: Boolean;
Private | FVSync: TGLVSyncMode;
Private | FRefreshRate: Integer;
Private | FCursor: TCursor;
Private | FPopupMenu: TPopupMenu;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FramesPerSecond: Single;
Public | function FramesPerSecondText(decimals: Integer = 1): String;
Public | function LastFrameTime: Single;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure ReActivate;
Public | procedure Render(baseObject: TGLBaseSceneObject = nil); override;
Public | procedure ResetPerformanceMonitor;
Public | procedure UseCurrentResolution;
Private | procedure SetActive(const val: Boolean);
Private | procedure SetCursor(const val: TCursor);
Private | procedure SetForm(aVal: TForm);
Private | procedure SetManualRendering(const val: Boolean);
Private | procedure SetOnClick(const val: TNotifyEvent);
Private | procedure SetOnClose(const val: TCloseEvent);
Private | procedure SetOnCloseQuery(const val: TCloseQueryEvent);
Private | procedure SetOnDblClick(const val: TNotifyEvent);
Private | procedure SetOnKeyDown(const val: TKeyEvent);
Private | procedure SetOnKeyPress(const val: TKeyPressEvent);
Private | procedure SetOnKeyUp(const val: TKeyEvent);
Private | procedure SetOnMouseDown(const val: TMouseEvent);
Private | procedure SetOnMouseMove(const val: TMouseMoveEvent);
Private | procedure SetOnMouseUp(const val: TMouseEvent);
Private | procedure SetOnMouseWheel(const val: TMouseWheelEvent);
Private | procedure SetOnMouseWheelDown(const val: TMouseWheelUpDownEvent);
Private | procedure SetOnMouseWheelUp(const val: TMouseWheelUpDownEvent);
Private | procedure SetPopupMenu(const val: TPopupMenu);
Private | procedure SetScreenDepth(const val: TGLScreenDepth);
Private | procedure SetStayOnTop(const val: Boolean);

Properties

Public | property Active: Boolean read FActive write SetActive;
Published | property Cursor: TCursor read FCursor write SetCursor default crDefault;
Published | property Form: TForm read FForm write SetForm;
Public | property Handle: HWND read GetHandle;
Published | property ManualRendering: Boolean read FManualRendering write SetManualRendering;
Published | property OnClick: TNotifyEvent read FOnClick write SetOnClick;
Published | property OnClose: TCloseEvent read FOnClose write SetOnClose;
Published | property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write SetOnCloseQuery;
Published | property OnDblClick: TNotifyEvent read FOnDblClick write SetOnDblClick;
Published | property OnKeyDown: TKeyEvent read FOnKeyDown write SetOnKeyDown;
Published | property OnKeyPress: TKeyPressEvent read FOnKeyPress write SetOnKeyPress;
Published | property OnKeyUp: TKeyEvent read FOnKeyUp write SetOnKeyUp;
Published | property OnMouseDown: TMouseEvent read FOnMouseDown write SetOnMouseDown;
Published | property OnMouseMove: TMouseMoveEvent read FOnMouseMove write SetOnMouseMove;
Published | property OnMouseUp: TMouseEvent read FOnMouseUp write SetOnMouseUp;
Published | property OnMouseWheel: TMouseWheelEvent read FOnMouseWheel write SetOnMouseWheel;
Published | property OnMouseWheelDown: TMouseWheelUpDownEvent read FOnMouseWheelDown write SetOnMouseWheelDown;
Published | property OnMouseWheelUp: TMouseWheelUpDownEvent read FOnMouseWheelUp write SetOnMouseWheelUp;
Published | property PopupMenu: TPopupMenu read FPopupMenu write SetPopupMenu;
Published | property RefreshRate: Integer read FRefreshRate write FRefreshRate;
Public | property RenderDC: HWND read FOwnDC;
Published | property ScreenDepth: TGLScreenDepth read FScreenDepth write SetScreenDepth default sd32bits;
Published | property StayOnTop: Boolean read FStayOnTop write SetStayOnTop default False;
Published | property VSync: TGLVSyncMode read FVSync write FVSync default vsmSync;

Description

Fields

Private FFormIsOwned: Boolean;

This item has no description.

Private FForm: TForm;

This item has no description.

Private FOwnDC: HWND;

This item has no description.

Private FScreenDepth: TGLScreenDepth;

This item has no description.

Private FActive: Boolean;

This item has no description.

Private FSwitchedResolution: Boolean;

This item has no description.

Private FManualRendering: Boolean;

This item has no description.

Private FUpdateCount: Integer;

This item has no description.

Private FOnMouseDown: TMouseEvent;

This item has no description.

Private FOnMouseUp: TMouseEvent;

This item has no description.

Private FOnMouseMove: TMouseMoveEvent;

This item has no description.

Private FOnMouseWheel: TMouseWheelEvent;

This item has no description.

Private FOnMouseWheelDown: TMouseWheelUpDownEvent;

This item has no description.

Private FOnMouseWheelUp: TMouseWheelUpDownEvent;

This item has no description.

Private FOnClick: TNotifyEvent;

This item has no description.

Private FOnDblClick: TNotifyEvent;

This item has no description.

Private FOnKeyDown: TKeyEvent;

This item has no description.

Private FOnKeyUp: TKeyEvent;

This item has no description.

Private FOnKeyPress: TKeyPressEvent;

This item has no description.

Private FOnClose: TCloseEvent;

This item has no description.

Private FOnCloseQuery: TCloseQueryEvent;

This item has no description.

Private FStayOnTop: Boolean;

This item has no description.

Private FVSync: TGLVSyncMode;

This item has no description.

Private FRefreshRate: Integer;

This item has no description.

Private FCursor: TCursor;

This item has no description.

Private FPopupMenu: TPopupMenu;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FramesPerSecond: Single;

This item has no description.

Public function FramesPerSecondText(decimals: Integer = 1): String;

This item has no description.

Public function LastFrameTime: Single;

This item has no description.

Public procedure BeginUpdate;

This item has no description.

Public procedure EndUpdate;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure ReActivate;

This item has no description.

Public procedure Render(baseObject: TGLBaseSceneObject = nil); override;

This item has no description.

Public procedure ResetPerformanceMonitor;

This item has no description.

Public procedure UseCurrentResolution;

Adjusts property so that current resolution will be used. Call this method if you want to make sure video mode isn't switched.

Private procedure SetActive(const val: Boolean);

This item has no description.

Private procedure SetCursor(const val: TCursor);

This item has no description.

Private procedure SetForm(aVal: TForm);

This item has no description.

Private procedure SetManualRendering(const val: Boolean);

This item has no description.

Private procedure SetOnClick(const val: TNotifyEvent);

This item has no description.

Private procedure SetOnClose(const val: TCloseEvent);

This item has no description.

Private procedure SetOnCloseQuery(const val: TCloseQueryEvent);

This item has no description.

Private procedure SetOnDblClick(const val: TNotifyEvent);

This item has no description.

Private procedure SetOnKeyDown(const val: TKeyEvent);

This item has no description.

Private procedure SetOnKeyPress(const val: TKeyPressEvent);

This item has no description.

Private procedure SetOnKeyUp(const val: TKeyEvent);

This item has no description.

Private procedure SetOnMouseDown(const val: TMouseEvent);

This item has no description.

Private procedure SetOnMouseMove(const val: TMouseMoveEvent);

This item has no description.

Private procedure SetOnMouseUp(const val: TMouseEvent);

This item has no description.

Private procedure SetOnMouseWheel(const val: TMouseWheelEvent);

This item has no description.

Private procedure SetOnMouseWheelDown(const val: TMouseWheelUpDownEvent);

This item has no description.

Private procedure SetOnMouseWheelUp(const val: TMouseWheelUpDownEvent);

This item has no description.

Private procedure SetPopupMenu(const val: TPopupMenu);

This item has no description.

Private procedure SetScreenDepth(const val: TGLScreenDepth);

This item has no description.

Private procedure SetStayOnTop(const val: Boolean);

This item has no description.

Properties

Public property Active: Boolean read FActive write SetActive;

Activates/deactivates full screen mode.

Published property Cursor: TCursor read FCursor write SetCursor default crDefault;

This item has no description.

Published property Form: TForm read FForm write SetForm;

This item has no description.

Public property Handle: HWND read GetHandle;

Read access to the underlying form handle. Returns 0 (zero) if the viewer is not active or has not yet instantiated its form.

Published property ManualRendering: Boolean read FManualRendering write SetManualRendering;

This item has no description.

Published property OnClick: TNotifyEvent read FOnClick write SetOnClick;

This item has no description.

Published property OnClose: TCloseEvent read FOnClose write SetOnClose;

This item has no description.

Published property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write SetOnCloseQuery;

This item has no description.

Published property OnDblClick: TNotifyEvent read FOnDblClick write SetOnDblClick;

This item has no description.

Published property OnKeyDown: TKeyEvent read FOnKeyDown write SetOnKeyDown;

This item has no description.

Published property OnKeyPress: TKeyPressEvent read FOnKeyPress write SetOnKeyPress;

This item has no description.

Published property OnKeyUp: TKeyEvent read FOnKeyUp write SetOnKeyUp;

This item has no description.

Published property OnMouseDown: TMouseEvent read FOnMouseDown write SetOnMouseDown;

This item has no description.

Published property OnMouseMove: TMouseMoveEvent read FOnMouseMove write SetOnMouseMove;

This item has no description.

Published property OnMouseUp: TMouseEvent read FOnMouseUp write SetOnMouseUp;

This item has no description.

Published property OnMouseWheel: TMouseWheelEvent read FOnMouseWheel write SetOnMouseWheel;

This item has no description.

Published property OnMouseWheelDown: TMouseWheelUpDownEvent read FOnMouseWheelDown write SetOnMouseWheelDown;

This item has no description.

Published property OnMouseWheelUp: TMouseWheelUpDownEvent read FOnMouseWheelUp write SetOnMouseWheelUp;

This item has no description.

Published property PopupMenu: TPopupMenu read FPopupMenu write SetPopupMenu;

This item has no description.

Published property RefreshRate: Integer read FRefreshRate write FRefreshRate;

Screen refresh rate. Use zero for system default. This property allows you to work around the winxp bug that limits uses a refresh rate of 60hz when changeing resolution. it is however suggested to give the user the opportunity to adjust it instead of having a fixed value (expecially beyond 75hz or for resolutions beyond 1024x768). the value will be automatically clamped to the highest value *reported* compatible with the monitor.

Public property RenderDC: HWND read FOwnDC;

This item has no description.

Published property ScreenDepth: TGLScreenDepth read FScreenDepth write SetScreenDepth default sd32bits;

It is not used in UNIX. Requested ScreenDepth.

Published property StayOnTop: Boolean read FStayOnTop write SetStayOnTop default False;

Specifies if the underlying form is "fsStayOnTop". The benefit of StayOnTop is that it hides the windows bar and other background windows. The "fsStayOnTop" is automatically switched off/on when the underlying form loses/gains focus. It is recommended not to use StayOnTop while running in the IDE or during the debugging phase.

Published property VSync: TGLVSyncMode read FVSync write FVSync default vsmSync;

Specifies if the refresh should be synchronized with the VSync signal. If the underlying OpenGL ICD does not support the WGL_EXT_swap_control extension, this property is ignored.


GLSysHelp v.2.5: GLS.GameMenu

Unit GLS.GameMenu

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLS.Coordinates
  • GLS.Scene
  • GLS.Material
  • GLS.BitmapFont
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.Canvas
  • GLS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGameMenu |

Types

TGLGameMenuScale = (...);

Description

Types

TGLGameMenuScale = (...);

This item has no description.

Values
  • gmsNormal
  • gms1024x768


GLSysHelp v.2.5: GLS.GameMenu: Class TGLGameMenu

Class TGLGameMenu

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GameMenu

Declaration

type TGLGameMenu = class(TGLSceneObject, IGLMaterialLibrarySupported)

Description

Classic game menu interface made of several lines.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLGameMenu

Overview

Fields

Private | FItems: TStrings;
Private | FSelected: Integer;
Private | FFont: TGLCustomBitmapFont;
Private | FMarginVert: Integer;
Private | FMarginHorz: Integer;
Private | FSpacing: Integer;
Private | FMenuScale: TGLGameMenuScale;
Private | FBackColor: TGLColor;
Private | FInactiveColor: TGLColor;
Private | FActiveColor: TGLColor;
Private | FDisabledColor: TGLColor;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FTitleMaterialName: TGLLibMaterialName;
Private | FTitleWidth: Integer;
Private | FTitleHeight: Integer;
Private | FOnSelectedChanged: TNotifyEvent;
Private | FBoxTop: Integer;
Private | FBoxBottom: Integer;
Private | FBoxLeft: Integer;
Private | FBoxRight: Integer;
Private | FMenuTop: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure MouseMenuSelect(const X, Y: Integer);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure SelectNext;
Public | procedure SelectPrev;

Properties

Published | property ActiveColor: TGLColor read FActiveColor write SetActiveColor;
Published | property BackColor: TGLColor read FBackColor write SetBackColor;
Published | property Behaviours;
Published | property BoxBottom: Integer read FBoxBottom;
Published | property BoxLeft: Integer read FBoxLeft;
Published | property BoxRight: Integer read FBoxRight;
Published | property BoxTop: Integer read FBoxTop;
Published | property DisabledColor: TGLColor read FDisabledColor write SetDisabledColor;
Published | property Effects;
Public | property Enabled[AIndex: Integer]: Boolean read GetEnabled write SetEnabled;
Published | property Font: TGLCustomBitmapFont read FFont write SetFont;
Published | property InactiveColor: TGLColor read FInactiveColor write SetInactiveColor;
Published | property Items: TStrings read FItems write SetItems;
Published | property MarginHorz: Integer read FMarginHorz write SetMarginHorz default 16;
Published | property MarginVert: Integer read FMarginVert write SetMarginVert default 16;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MenuScale: TGLGameMenuScale read FMenuScale write SetMenuScale default gmsNormal;
Published | property MenuTop: Integer read FMenuTop;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property OnSelectedChanged: TNotifyEvent read FOnSelectedChanged write FOnSelectedChanged;
Published | property Position;
Published | property Selected: Integer read FSelected write SetSelected default -1;
Public | property SelectedText: string read GetSelectedText;
Published | property Spacing: Integer read FSpacing write SetSpacing default 16;
Published | property TitleHeight: Integer read FTitleHeight write SetTitleHeight default 0;
Published | property TitleMaterialName: string read FTitleMaterialName write SetTitleMaterialName;
Published | property TitleWidth: Integer read FTitleWidth write SetTitleWidth default 0;
Published | property VisibilityCulling;
Published | property Visible;

Description

Fields

Private FItems: TStrings;

This item has no description.

Private FSelected: Integer;

This item has no description.

Private FFont: TGLCustomBitmapFont;

This item has no description.

Private FMarginVert: Integer;

This item has no description.

Private FMarginHorz: Integer;

This item has no description.

Private FSpacing: Integer;

This item has no description.

Private FMenuScale: TGLGameMenuScale;

This item has no description.

Private FBackColor: TGLColor;

This item has no description.

Private FInactiveColor: TGLColor;

This item has no description.

Private FActiveColor: TGLColor;

This item has no description.

Private FDisabledColor: TGLColor;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FTitleMaterialName: TGLLibMaterialName;

This item has no description.

Private FTitleWidth: Integer;

This item has no description.

Private FTitleHeight: Integer;

This item has no description.

Private FOnSelectedChanged: TNotifyEvent;

This item has no description.

Private FBoxTop: Integer;

This item has no description.

Private FBoxBottom: Integer;

This item has no description.

Private FBoxLeft: Integer;

This item has no description.

Private FBoxRight: Integer;

This item has no description.

Private FMenuTop: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

implementing IGLMaterialLibrarySupported

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure MouseMenuSelect(const X, Y: Integer);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure SelectNext;

This item has no description.

Public procedure SelectPrev;

This item has no description.

Properties

Published property ActiveColor: TGLColor read FActiveColor write SetActiveColor;

This item has no description.

Published property BackColor: TGLColor read FBackColor write SetBackColor;

This item has no description.

Published property Behaviours;

This item has no description.

Published property BoxBottom: Integer read FBoxBottom;

This item has no description.

Published property BoxLeft: Integer read FBoxLeft;

This item has no description.

Published property BoxRight: Integer read FBoxRight;

This item has no description.

Published property BoxTop: Integer read FBoxTop;

these are the extents of the menu

Published property DisabledColor: TGLColor read FDisabledColor write SetDisabledColor;

This item has no description.

Published property Effects;

This item has no description.

Public property Enabled[AIndex: Integer]: Boolean read GetEnabled write SetEnabled;

This item has no description.

Published property Font: TGLCustomBitmapFont read FFont write SetFont;

This item has no description.

Published property InactiveColor: TGLColor read FInactiveColor write SetInactiveColor;

This item has no description.

Published property Items: TStrings read FItems write SetItems;

This item has no description.

Published property MarginHorz: Integer read FMarginHorz write SetMarginHorz default 16;

This item has no description.

Published property MarginVert: Integer read FMarginVert write SetMarginVert default 16;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property MenuScale: TGLGameMenuScale read FMenuScale write SetMenuScale default gmsNormal;

This item has no description.

Published property MenuTop: Integer read FMenuTop;

this is the top of the first menu item

Published property ObjectsSorting;

publish other stuff from TGLBaseSceneObject

Published property OnProgress;

This item has no description.

Published property OnSelectedChanged: TNotifyEvent read FOnSelectedChanged write FOnSelectedChanged;

This item has no description.

Published property Position;

This item has no description.

Published property Selected: Integer read FSelected write SetSelected default -1;

This item has no description.

Public property SelectedText: string read GetSelectedText;

This item has no description.

Published property Spacing: Integer read FSpacing write SetSpacing default 16;

This item has no description.

Published property TitleHeight: Integer read FTitleHeight write SetTitleHeight default 0;

This item has no description.

Published property TitleMaterialName: string read FTitleMaterialName write SetTitleMaterialName;

This item has no description.

Published property TitleWidth: Integer read FTitleWidth write SetTitleWidth default 0;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.GeomObjects

Unit GLS.GeomObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Math
  • System.Classes
  • GLS.OpenGLAdapter
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.PipelineTransform
  • GLScene.Polynomials
  • GLS.Scene
  • GLS.State
  • GLS.PersistentClasses
  • GLS.VectorLists
  • GLS.Silhouette
  • GLScene.GeometryBB
  • GLS.VectorFileObjects
  • GLS.Material
  • GLS.Texture
  • GLS.Context
  • GLS.Objects
  • GLS.Mesh
  • GLS.RenderContextInfo
  • GLS.XOpenGL

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTetrahedron |
Class TGLOctahedron |
Class TGLHexahedron |
Class TGLDodecahedron |
Class TGLIcosahedron |
Class TGLDisk |
Class TGLCylinderBase |
Class TGLCone |
Class TGLCylinder |
Class TGLCapsule |
Class TGLAnnulus |
Class TGLTorus |
Class TGLArrowLine |
Class TGLArrowArc |
Class TGLPolygon |
Class TGLFrustrum |
Class TGLTeapot |

Types

TGLAnnulusPart = (...);
TGLAnnulusParts = set of TGLAnnulusPart;
TGLArrowArcPart = (...);
TGLArrowArcParts = set of TGLArrowArcPart;
TGLArrowHeadStyle = (...);
TGLArrowLinePart = (...);
TGLArrowLineParts = set of TGLArrowLinePart;
TGLConePart = (...);
TGLConeParts = set of TGLConePart;
TGLCylinderAlignment = (...);
TGLCylinderPart = (...);
TGLCylinderParts = set of TGLCylinderPart;
TGLFrustrumPart = (...);
TGLFrustrumParts = set of TGLFrustrumPart;
TGLPolygonPart = (...);
TGLPolygonParts = set of TGLPolygonPart;
TGLTorusPart = (...);
TGLTorusParts = set of TGLTorusPart;

Constants

cAllFrustrumParts = [fpTop, fpBottom, fpFront, fpBack, fpLeft, fpRight];

Description

Types

TGLAnnulusPart = (...);

This item has no description.

Values
  • anInnerSides
  • anOuterSides
  • anBottom
  • anTop
TGLAnnulusParts = set of TGLAnnulusPart;

This item has no description.

TGLArrowArcPart = (...);

This item has no description.

Values
  • aaArc
  • aaTopArrow
  • aaBottomArrow
TGLArrowArcParts = set of TGLArrowArcPart;

This item has no description.

TGLArrowHeadStyle = (...);

This item has no description.

Values
  • ahssStacked
  • ahssCentered
  • ahssIncluded
TGLArrowLinePart = (...);

This item has no description.

Values
  • alLine
  • alTopArrow
  • alBottomArrow
TGLArrowLineParts = set of TGLArrowLinePart;

This item has no description.

TGLConePart = (...);

This item has no description.

Values
  • coSides
  • coBottom
TGLConeParts = set of TGLConePart;

This item has no description.

TGLCylinderAlignment = (...);

This item has no description.

Values
  • caCenter
  • caTop
  • caBottom
TGLCylinderPart = (...);

This item has no description.

Values
  • cySides
  • cyBottom
  • cyTop
TGLCylinderParts = set of TGLCylinderPart;

This item has no description.

TGLFrustrumPart = (...);

This item has no description.

Values
  • fpTop
  • fpBottom
  • fpFront
  • fpBack
  • fpLeft
  • fpRight
TGLFrustrumParts = set of TGLFrustrumPart;

This item has no description.

TGLPolygonPart = (...);

This item has no description.

Values
  • ppTop
  • ppBottom
TGLPolygonParts = set of TGLPolygonPart;

This item has no description.

TGLTorusPart = (...);

This item has no description.

Values
  • toSides
  • toStartDisk
  • toStopDisk
TGLTorusParts = set of TGLTorusPart;

This item has no description.

Constants

cAllFrustrumParts = [fpTop, fpBottom, fpFront, fpBack, fpLeft, fpRight];


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLTetrahedron

Class TGLTetrahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLTetrahedron = class(TGLBaseMesh)

Description

This objects has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLTetrahedron

Overview

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLOctahedron

Class TGLOctahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLOctahedron = class(TGLBaseMesh)

Description

This item has no description. Showing description inherited from TGLBaseMesh.

Base class for mesh objects.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLOctahedron

Overview

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLHexahedron

Class TGLHexahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLHexahedron = class(TGLBaseMesh)

Description

This item has no description. Showing description inherited from TGLBaseMesh.

Base class for mesh objects.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLHexahedron

Overview

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLDodecahedron

Class TGLDodecahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLDodecahedron = class(TGLBaseMesh)

Description

This item has no description. Showing description inherited from TGLBaseMesh.

Base class for mesh objects.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLDodecahedron

Overview

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLIcosahedron

Class TGLIcosahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLIcosahedron = class(TGLBaseMesh)

Description

This item has no description. Showing description inherited from TGLBaseMesh.

Base class for mesh objects.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLIcosahedron

Overview

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLDisk

Class TGLDisk

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLDisk = class(TGLQuadricObject)

Description

A Disk object that may not be complete, it can have a hole (controlled by the InnerRadius property) and can only be a slice (controlled by the StartAngle and SweepAngle properties).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLDisk

Overview

Fields

Private | FStartAngle: Single;
Private | FSweepAngle: Single;
Private | FOuterRadius: Single;
Private | FInnerRadius: Single;
Private | FSlices: Integer;
Private | FLoops: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Private | procedure SetInnerRadius(const aValue: Single);
Private | procedure SetLoops(aValue: Integer);
Private | procedure SetOuterRadius(const aValue: Single);
Private | procedure SetSlices(aValue: Integer);
Private | procedure SetStartAngle(const aValue: Single);
Private | procedure SetSweepAngle(const aValue: Single);

Properties

Published | property InnerRadius: Single read FInnerRadius write SetInnerRadius;
Published | property Loops: Integer read FLoops write SetLoops default 2;
Published | property OuterRadius: Single read FOuterRadius write SetOuterRadius;
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property SweepAngle: Single read FSweepAngle write SetSweepAngle;

Description

Fields

Private FStartAngle: Single;

This item has no description.

Private FSweepAngle: Single;

This item has no description.

Private FOuterRadius: Single;

This item has no description.

Private FInnerRadius: Single;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FLoops: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetInnerRadius(const aValue: Single);

This item has no description.

Private procedure SetLoops(aValue: Integer);

This item has no description.

Private procedure SetOuterRadius(const aValue: Single);

This item has no description.

Private procedure SetSlices(aValue: Integer);

This item has no description.

Private procedure SetStartAngle(const aValue: Single);

This item has no description.

Private procedure SetSweepAngle(const aValue: Single);

This item has no description.

Properties

Published property InnerRadius: Single read FInnerRadius write SetInnerRadius;

Allows defining a "hole" in the disk

Published property Loops: Integer read FLoops write SetLoops default 2;

Number of radial mesh subdivisions

Published property OuterRadius: Single read FOuterRadius write SetOuterRadius;

Outer radius for the disk. If you leave InnerRadius at 0, this is the disk radius

Published property Slices: Integer read FSlices write SetSlices default 16;

Number of mesh slices. For instance, if Slices=6, your disk will look like an hexagon

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property SweepAngle: Single read FSweepAngle write SetSweepAngle;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLCylinderBase

Class TGLCylinderBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLCylinderBase = class(TGLQuadricObject)

Description

Base class to cylinder-like objects that introduces the basic cylinder description properties. Be aware teh default slices and stacks make up for a high-poly cylinder, unless you're after high-quality lighting it is recommended to reduce the Stacks property to 1.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase

Overview

Fields

Private | FBottomRadius: Single;
Private | FSlices: Integer;
Private | FStacks: Integer;
Private | FLoops: Integer;
Private | FHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property BottomRadius: Single read FBottomRadius write SetBottomRadius;
Published | property Height: Single read FHeight write SetHeight;
Published | property Loops: Integer read FLoops write SetLoops default 1;
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property Stacks: Integer read FStacks write SetStacks default 4;

Description

Fields

Private FBottomRadius: Single;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FStacks: Integer;

This item has no description.

Private FLoops: Integer;

This item has no description.

Private FHeight: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property BottomRadius: Single read FBottomRadius write SetBottomRadius;

This item has no description.

Published property Height: Single read FHeight write SetHeight;

This item has no description.

Published property Loops: Integer read FLoops write SetLoops default 1;

Number of concentric rings for top/bottom disk(s).

Published property Slices: Integer read FSlices write SetSlices default 16;

This item has no description.

Published property Stacks: Integer read FStacks write SetStacks default 4;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLCone

Class TGLCone

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLCone = class(TGLCylinderBase)

Description

A cone object

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLCone

Overview

Fields

Private FParts: TGLConeParts;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published property Parts: TGLConeParts read FParts write SetParts default [coSides, coBottom];

Description

Fields

Private FParts: TGLConeParts;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Parts: TGLConeParts read FParts write SetParts default [coSides, coBottom];


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLCylinder

Class TGLCylinder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLCylinder = class(TGLCylinderBase)

Description

Cylinder object, can also be used to make truncated cones

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLCylinder

Overview

Fields

Private | FParts: TGLCylinderParts;
Private | FTopRadius: Single;
Private | FAlignment: TGLCylinderAlignment;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | procedure Align(const startObj, endObj: TGLBaseSceneObject); overload;
Public | procedure Align(const startPoint, endPoint: TAffineVector); overload;
Public | procedure Align(const startPoint, endPoint: TGLVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property Alignment: TGLCylinderAlignment read FAlignment write SetAlignment default caCenter;
Published | property Parts: TGLCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];
Published | property TopRadius: Single read FTopRadius write SetTopRadius;

Description

Fields

Private FParts: TGLCylinderParts;

This item has no description.

Private FTopRadius: Single;

This item has no description.

Private FAlignment: TGLCylinderAlignment;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Align(const startObj, endObj: TGLBaseSceneObject); overload;

This item has no description.

Public procedure Align(const startPoint, endPoint: TAffineVector); overload;

This item has no description.

Public procedure Align(const startPoint, endPoint: TGLVector); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Alignment: TGLCylinderAlignment read FAlignment write SetAlignment default caCenter;

This item has no description.

Published property Parts: TGLCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];

This item has no description.

Published property TopRadius: Single read FTopRadius write SetTopRadius;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLCapsule

Class TGLCapsule

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLCapsule = class(TGLSceneObject)

Description

Capsule object, can also be used to make truncated cones

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLCapsule

Overview

Fields

Private | FParts: TGLCylinderParts;
Private | FRadius: Single;
Private | FSlices: Integer;
Private | FStacks: Integer;
Private | FHeight: Single;
Private | FAlignment: TGLCylinderAlignment;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | procedure Align(const startObj, endObj: TGLBaseSceneObject); overload;
Public | procedure Align(const startPoint, endPoint: TAffineVector); overload;
Public | procedure Align(const startPoint, endPoint: TGLVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property Alignment: TGLCylinderAlignment read FAlignment write SetAlignment default caCenter;
Published | property Height: Single read FHeight write SetHeight;
Published | property Parts: TGLCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];
Published | property Radius: Single read FRadius write SetRadius;
Published | property Slices: Integer read FSlices write SetSlices;
Published | property Stacks: Integer read FStacks write SetStacks;

Description

Fields

Private FParts: TGLCylinderParts;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FStacks: Integer;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FAlignment: TGLCylinderAlignment;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Align(const startObj, endObj: TGLBaseSceneObject); overload;

This item has no description.

Public procedure Align(const startPoint, endPoint: TAffineVector); overload;

This item has no description.

Public procedure Align(const startPoint, endPoint: TGLVector); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Alignment: TGLCylinderAlignment read FAlignment write SetAlignment default caCenter;

This item has no description.

Published property Height: Single read FHeight write SetHeight;

This item has no description.

Published property Parts: TGLCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];

This item has no description.

Published property Radius: Single read FRadius write SetRadius;

This item has no description.

Published property Slices: Integer read FSlices write SetSlices;

This item has no description.

Published property Stacks: Integer read FStacks write SetStacks;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLAnnulus

Class TGLAnnulus

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLAnnulus = class(TGLCylinderBase)

Description

An annulus is a cylinder that can be made hollow (pipe-like)

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLAnnulus

Overview

Fields

Private | FParts: TGLAnnulusParts;
Private | FBottomInnerRadius: Single;
Private | FTopInnerRadius: Single;
Private | FTopRadius: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property BottomInnerRadius: Single read FBottomInnerRadius write SetBottomInnerRadius;
Published | property Parts: TGLAnnulusParts read FParts write SetParts default [anInnerSides, anOuterSides, anBottom, anTop];
Published | property TopInnerRadius: Single read FTopInnerRadius write SetTopInnerRadius;
Published | property TopRadius: Single read FTopRadius write SetTopRadius;

Description

Fields

Private FParts: TGLAnnulusParts;

This item has no description.

Private FBottomInnerRadius: Single;

This item has no description.

Private FTopInnerRadius: Single;

This item has no description.

Private FTopRadius: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property BottomInnerRadius: Single read FBottomInnerRadius write SetBottomInnerRadius;

This item has no description.

Published property Parts: TGLAnnulusParts read FParts write SetParts default [anInnerSides, anOuterSides, anBottom, anTop];

This item has no description.

Published property TopInnerRadius: Single read FTopInnerRadius write SetTopInnerRadius;

This item has no description.

Published property TopRadius: Single read FTopRadius write SetTopRadius;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLTorus

Class TGLTorus

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLTorus = class(TGLSceneObject)

Description

A Torus object

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTorus

Overview

Fields

Private | FParts: TGLTorusParts;
Private | FRings: Cardinal;
Private | FSides: Cardinal;
Private | FStartAngle: Single;
Private | FStopAngle: Single;
Private | FMinorRadius: Single;
Private | FMajorRadius: Single;
Private | FMesh: array of array of TGLVertexRec;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property MajorRadius: Single read FMajorRadius write SetMajorRadius;
Published | property MinorRadius: Single read FMinorRadius write SetMinorRadius;
Published | property Parts: TGLTorusParts read FParts write SetParts default [toSides];
Published | property Rings: Cardinal read FRings write SetRings default 25;
Published | property Sides: Cardinal read FSides write SetSides default 15;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StopAngle: Single read FStopAngle write SetStopAngle;

Description

Fields

Private FParts: TGLTorusParts;

This item has no description.

Private FRings: Cardinal;

This item has no description.

Private FSides: Cardinal;

This item has no description.

Private FStartAngle: Single;

This item has no description.

Private FStopAngle: Single;

This item has no description.

Private FMinorRadius: Single;

This item has no description.

Private FMajorRadius: Single;

This item has no description.

Private FMesh: array of array of TGLVertexRec;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property MajorRadius: Single read FMajorRadius write SetMajorRadius;

This item has no description.

Published property MinorRadius: Single read FMinorRadius write SetMinorRadius;

This item has no description.

Published property Parts: TGLTorusParts read FParts write SetParts default [toSides];

This item has no description.

Published property Rings: Cardinal read FRings write SetRings default 25;

This item has no description.

Published property Sides: Cardinal read FSides write SetSides default 15;

This item has no description.

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property StopAngle: Single read FStopAngle write SetStopAngle;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLArrowLine

Class TGLArrowLine

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLArrowLine = class(TGLCylinderBase)

Description

Draws an arrowhead (cylinder + cone). The arrow head is a cone that shares the attributes of the cylinder (ie stacks/slices, materials etc). Seems to work ok. This is useful for displaying a vector based field (eg velocity) or other arrows that might be required. By default the bottom arrow is off

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLArrowLine

Overview

Fields

Private | FParts: TGLArrowLineParts;
Private | FTopRadius: Single;
Private | fTopArrowHeadHeight: Single;
Private | fTopArrowHeadRadius: Single;
Private | fBottomArrowHeadHeight: Single;
Private | fBottomArrowHeadRadius: Single;
Private | FHeadStackingStyle: TGLArrowHeadStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property BottomArrowHeadHeight: Single read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;
Published | property BottomArrowHeadRadius: Single read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;
Published | property HeadStackingStyle: TGLArrowHeadStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;
Published | property Parts: TGLArrowLineParts read FParts write SetParts default [alLine, alTopArrow];
Published | property TopArrowHeadHeight: Single read fTopArrowHeadHeight write SetTopArrowHeadHeight;
Published | property TopArrowHeadRadius: Single read fTopArrowHeadRadius write SetTopArrowHeadRadius;
Published | property TopRadius: Single read FTopRadius write SetTopRadius;

Description

Fields

Private FParts: TGLArrowLineParts;

This item has no description.

Private FTopRadius: Single;

This item has no description.

Private fTopArrowHeadHeight: Single;

This item has no description.

Private fTopArrowHeadRadius: Single;

This item has no description.

Private fBottomArrowHeadHeight: Single;

This item has no description.

Private fBottomArrowHeadRadius: Single;

This item has no description.

Private FHeadStackingStyle: TGLArrowHeadStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property BottomArrowHeadHeight: Single read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;

This item has no description.

Published property BottomArrowHeadRadius: Single read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;

This item has no description.

Published property HeadStackingStyle: TGLArrowHeadStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;

This item has no description.

Published property Parts: TGLArrowLineParts read FParts write SetParts default [alLine, alTopArrow];

This item has no description.

Published property TopArrowHeadHeight: Single read fTopArrowHeadHeight write SetTopArrowHeadHeight;

This item has no description.

Published property TopArrowHeadRadius: Single read fTopArrowHeadRadius write SetTopArrowHeadRadius;

This item has no description.

Published property TopRadius: Single read FTopRadius write SetTopRadius;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLArrowArc

Class TGLArrowArc

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLArrowArc = class(TGLCylinderBase)

Description

Draws an arrowhead (Sliced Torus + cone). The arrow head is a cone that shares the attributes of the Torus (ie stacks/slices, materials etc). This is useful for displaying a movement (eg twist) or other arc arrows that might be required. By default the bottom arrow is off

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLArrowArc

Overview

Fields

Private | fArcRadius: Single;
Private | FStartAngle: Single;
Private | FStopAngle: Single;
Private | FParts: TGLArrowArcParts;
Private | FTopRadius: Single;
Private | fTopArrowHeadHeight: Single;
Private | fTopArrowHeadRadius: Single;
Private | fBottomArrowHeadHeight: Single;
Private | fBottomArrowHeadRadius: Single;
Private | FHeadStackingStyle: TGLArrowHeadStyle;
Private | FMesh: array of array of TGLVertexRec;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property ArcRadius: Single read fArcRadius write SetArcRadius;
Published | property BottomArrowHeadHeight: Single read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;
Published | property BottomArrowHeadRadius: Single read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;
Published | property HeadStackingStyle: TGLArrowHeadStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;
Published | property Parts: TGLArrowArcParts read FParts write SetParts default [aaArc, aaTopArrow];
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StopAngle: Single read FStopAngle write SetStopAngle;
Published | property TopArrowHeadHeight: Single read fTopArrowHeadHeight write SetTopArrowHeadHeight;
Published | property TopArrowHeadRadius: Single read fTopArrowHeadRadius write SetTopArrowHeadRadius;
Published | property TopRadius: Single read FTopRadius write SetTopRadius;

Description

Fields

Private fArcRadius: Single;

This item has no description.

Private FStartAngle: Single;

This item has no description.

Private FStopAngle: Single;

This item has no description.

Private FParts: TGLArrowArcParts;

This item has no description.

Private FTopRadius: Single;

This item has no description.

Private fTopArrowHeadHeight: Single;

This item has no description.

Private fTopArrowHeadRadius: Single;

This item has no description.

Private fBottomArrowHeadHeight: Single;

This item has no description.

Private fBottomArrowHeadRadius: Single;

This item has no description.

Private FHeadStackingStyle: TGLArrowHeadStyle;

This item has no description.

Private FMesh: array of array of TGLVertexRec;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property ArcRadius: Single read fArcRadius write SetArcRadius;

This item has no description.

Published property BottomArrowHeadHeight: Single read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;

This item has no description.

Published property BottomArrowHeadRadius: Single read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;

This item has no description.

Published property HeadStackingStyle: TGLArrowHeadStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;

This item has no description.

Published property Parts: TGLArrowArcParts read FParts write SetParts default [aaArc, aaTopArrow];

This item has no description.

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property StopAngle: Single read FStopAngle write SetStopAngle;

This item has no description.

Published property TopArrowHeadHeight: Single read fTopArrowHeadHeight write SetTopArrowHeadHeight;

This item has no description.

Published property TopArrowHeadRadius: Single read fTopArrowHeadRadius write SetTopArrowHeadRadius;

This item has no description.

Published property TopRadius: Single read FTopRadius write SetTopRadius;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLPolygon

Class TGLPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLPolygon = class(TGLPolygonBase)

Description

A basic polygon object. The contour is described by the Nodes and SplineMode properties, it should be planar and is automatically tessellated. Texture coordinates are deduced from X and Y coordinates only. This object allows only for polygons described by a single contour, if you need "complex polygons" with holes, patches and cutouts, see GLS.MultiPolygon.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLPolygon

Overview

Fields

Private FParts: TGLPolygonParts;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published property Parts: TGLPolygonParts read FParts write SetParts default [ppTop, ppBottom];

Description

Fields

Private FParts: TGLPolygonParts;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Parts: TGLPolygonParts read FParts write SetParts default [ppTop, ppBottom];

Parts of polygon. The 'top' of the polygon is the position were the curve describing the polygon spin counter-clockwise (i.e. right handed convention).


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLFrustrum

Class TGLFrustrum

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLFrustrum = class(TGLSceneObject)

Description

A frustrum is a pyramid with the top chopped off. The height of the imaginary pyramid is ApexHeight, the height of the frustrum is Height. If ApexHeight and Height are the same, the frustrum degenerates into a pyramid. Height cannot be greater than ApexHeight.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLFrustrum

Overview

Fields

Private | FApexHeight: Single;
Private | FBaseDepth: Single;
Private | FBaseWidth: Single;
Private | FHeight: Single;
Private | FParts: TGLFrustrumParts;
Private | FNormalDirection: TGLNormalDirection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedBoundingBoxUnscaled: TAABB;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function TopDepth: Single;
Public | function TopWidth: Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Private | procedure SetApexHeight(const aValue: Single);
Private | procedure SetBaseDepth(const aValue: Single);
Private | procedure SetBaseWidth(const aValue: Single);
Private | procedure SetHeight(const aValue: Single);
Private | procedure SetNormalDirection(aValue: TGLNormalDirection);
Private | procedure SetParts(aValue: TGLFrustrumParts);

Properties

Published | property ApexHeight: Single read FApexHeight write SetApexHeight stored False;
Published | property BaseDepth: Single read FBaseDepth write SetBaseDepth stored False;
Published | property BaseWidth: Single read FBaseWidth write SetBaseWidth stored False;
Published | property Height: Single read FHeight write SetHeight stored False;
Published | property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Parts: TGLFrustrumParts read FParts write SetParts default cAllFrustrumParts;

Description

Fields

Private FApexHeight: Single;

This item has no description.

Private FBaseDepth: Single;

This item has no description.

Private FBaseWidth: Single;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FParts: TGLFrustrumParts;

This item has no description.

Private FNormalDirection: TGLNormalDirection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedBoundingBoxUnscaled: TAABB;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function TopDepth: Single;

This item has no description.

Public function TopWidth: Single;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetApexHeight(const aValue: Single);

This item has no description.

Private procedure SetBaseDepth(const aValue: Single);

This item has no description.

Private procedure SetBaseWidth(const aValue: Single);

This item has no description.

Private procedure SetHeight(const aValue: Single);

This item has no description.

Private procedure SetNormalDirection(aValue: TGLNormalDirection);

This item has no description.

Private procedure SetParts(aValue: TGLFrustrumParts);

This item has no description.

Properties

Published property ApexHeight: Single read FApexHeight write SetApexHeight stored False;

This item has no description.

Published property BaseDepth: Single read FBaseDepth write SetBaseDepth stored False;

This item has no description.

Published property BaseWidth: Single read FBaseWidth write SetBaseWidth stored False;

This item has no description.

Published property Height: Single read FHeight write SetHeight stored False;

This item has no description.

Published property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Parts: TGLFrustrumParts read FParts write SetParts default cAllFrustrumParts;


GLSysHelp v.2.5: GLS.GeomObjects: Class TGLTeapot

Class TGLTeapot

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GeomObjects

Declaration

type TGLTeapot = class(TGLSceneObject)

Description

The classic teapot. The only use of this object is as placeholder for testing...

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTeapot

Overview

Fields

Private FGrid: Cardinal;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Description

Fields

Private FGrid: Cardinal;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;


GLSysHelp v.2.5: GLS.Gizmo

Unit GLS.Gizmo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Vcl.StdCtrls
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLS.Scene
  • GLS.PersistentClasses
  • GLS.Color
  • GLS.Objects
  • GLS.Material
  • GLS.GeomObjects
  • GLS.BitmapFont
  • GLS.SceneViewer
  • GLS.VectorFileObjects
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLS.State
  • GLS.Selection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGizmoUndoItem |
Class TGLGizmoUndoCollection |
Class TGLGizmoRayCastHitData |
Class TGLGizmoPickCube |
Class TGLGizmoPickTorus |
Class TGLGizmo |

Types

TGLGizmoAcceptEvent = procedure(Sender: TObject; var Obj: TGLBaseSceneObject; var Accept: Boolean; var Dimensions: TGLVector) of object;
TGLGizmoAxis = (...);
TGLGizmoElement = (...);
TGLGizmoElements = set of TGLGizmoElement;
TGLGizmoOperation = (...);
TGLGizmoPickMode = (...);
TGLGizmoUpdateEvent = procedure(Sender: TObject; Obj: TGLBaseSceneObject; Axis: TGLGizmoAxis; Operation: TGLGizmoOperation; var Vector: TGLVector) of object;
TGLGizmoVisibleInfoLabel = (...);
TGLGizmoVisibleInfoLabels = set of TGLGizmoVisibleInfoLabel;

Description

Types

TGLGizmoAcceptEvent = procedure(Sender: TObject; var Obj: TGLBaseSceneObject; var Accept: Boolean; var Dimensions: TGLVector) of object;

This item has no description.

TGLGizmoAxis = (...);

This item has no description.

Values
  • gaNone
  • gaX
  • gaY
  • gaZ
  • gaXY
  • gaXZ
  • gaYZ
TGLGizmoElement = (...);

This item has no description.

Values
  • geMove
  • geRotate
  • geScale
  • geAxisLabel
  • geObjectInfos
  • geBoundingBox
TGLGizmoElements = set of TGLGizmoElement;

This item has no description.

TGLGizmoOperation = (...);

This item has no description.

Values
  • gopMove
  • gopRotate
  • gopScale
  • gopNone
  • gpMoveGizmo
  • gpRotateGizmo
TGLGizmoPickMode = (...);

This item has no description.

Values
  • pmGetPickedObjects
  • pmRayCast
TGLGizmoUpdateEvent = procedure(Sender: TObject; Obj: TGLBaseSceneObject; Axis: TGLGizmoAxis; Operation: TGLGizmoOperation; var Vector: TGLVector) of object;

This item has no description.

TGLGizmoVisibleInfoLabel = (...);

This item has no description.

Values
  • vliName
  • vliOperation
  • vliCoords
TGLGizmoVisibleInfoLabels = set of TGLGizmoVisibleInfoLabel;


GLSysHelp v.2.5: GLS.Gizmo: Class TGLGizmoUndoItem

Class TGLGizmoUndoItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gizmo

Declaration

type TGLGizmoUndoItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLGizmoUndoItem

Overview

Fields

Private | FOldLibMaterialName: string;
Private | FOldAutoScaling: TGLCoordinates;
Private | FEffectedObject: TGLCustomSceneObject;
Private | FOldMatr: TGLMatrix;
Private | FOldMatrix: TGLMatrix;

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;
Public | procedure AssignFromObject(const AObject: TGLCustomSceneObject);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Private | procedure SetEffectedObject(const Value: TGLCustomSceneObject);
Private | procedure SetOldAutoScaling(const Value: TGLCoordinates);
Private | procedure SetOldMatrix(const Value: TGLMatrix);

Properties

Published | property EffectedObject: TGLCustomSceneObject read FEffectedObject write SetEffectedObject;
Published | property OldAutoScaling: TGLCoordinates read FOldAutoScaling write SetOldAutoScaling;
Published | property OldLibMaterialName: string read FOldLibMaterialName write FOldLibMaterialName;
Public | property OldMatrix: TGLMatrix read FOldMatrix write SetOldMatrix;

Description

Fields

Private FOldLibMaterialName: string;

This item has no description.

Private FOldAutoScaling: TGLCoordinates;

This item has no description.

Private FEffectedObject: TGLCustomSceneObject;

This item has no description.

Private FOldMatr: TGLMatrix;

This item has no description.

Private FOldMatrix: TGLMatrix;

This item has no description.

Methods

Public constructor Create(AOwner: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AssignFromObject(const AObject: TGLCustomSceneObject);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;

This item has no description.

Private procedure SetEffectedObject(const Value: TGLCustomSceneObject);

This item has no description.

Private procedure SetOldAutoScaling(const Value: TGLCoordinates);

This item has no description.

Private procedure SetOldMatrix(const Value: TGLMatrix);

This item has no description.

Properties

Published property EffectedObject: TGLCustomSceneObject read FEffectedObject write SetEffectedObject;

This item has no description.

Published property OldAutoScaling: TGLCoordinates read FOldAutoScaling write SetOldAutoScaling;

This item has no description.

Published property OldLibMaterialName: string read FOldLibMaterialName write FOldLibMaterialName;

This item has no description.

Public property OldMatrix: TGLMatrix read FOldMatrix write SetOldMatrix;

TODO: create a special type for Matrix.


GLSysHelp v.2.5: GLS.Gizmo: Class TGLGizmoUndoCollection

Class TGLGizmoUndoCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gizmo

Declaration

type TGLGizmoUndoCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLGizmoUndoCollection

Overview

Methods

Public | function Add: TGLGizmoUndoItem;
Private | function GetItems(const Index: Integer): TGLGizmoUndoItem;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveByObject(const AObject: TGLCustomSceneObject);
Private | procedure SetItems(const Index: Integer; const Value: TGLGizmoUndoItem);

Properties

Public property Items[const Index: Integer]: TGLGizmoUndoItem read GetItems write SetItems;

Description

Methods

Public function Add: TGLGizmoUndoItem;

This item has no description.

Private function GetItems(const Index: Integer): TGLGizmoUndoItem;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation);

This item has no description.

Public procedure RemoveByObject(const AObject: TGLCustomSceneObject);

This item has no description.

Private procedure SetItems(const Index: Integer; const Value: TGLGizmoUndoItem);

This item has no description.

Properties

Public property Items[const Index: Integer]: TGLGizmoUndoItem read GetItems write SetItems;


GLSysHelp v.2.5: GLS.Gizmo: Class TGLGizmoRayCastHitData

Class TGLGizmoRayCastHitData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gizmo

Declaration

type TGLGizmoRayCastHitData = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLGizmoRayCastHitData

Overview

Fields

Public | Obj: TGLBaseSceneObject;
Public | Point: TGLVector;

Description

Fields

Public Obj: TGLBaseSceneObject;

This item has no description.

Public Point: TGLVector;


GLSysHelp v.2.5: GLS.Gizmo: Class TGLGizmoPickCube

Class TGLGizmoPickCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gizmo

Declaration

type TGLGizmoPickCube = class(TGLCube)

Description

This item has no description. Showing description inherited from TGLCube.

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TGLFreeForm and a material library. Ref: https://mathworld.wolfram.com/Cube.html

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLCube
  • TGLGizmoPickCube


GLSysHelp v.2.5: GLS.Gizmo: Class TGLGizmoPickTorus

Class TGLGizmoPickTorus

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gizmo

Declaration

type TGLGizmoPickTorus = class(TGLTorus)

Description

This item has no description. Showing description inherited from TGLTorus.

A Torus object

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTorus
  • TGLGizmoPickTorus


GLSysHelp v.2.5: GLS.Gizmo: Class TGLGizmo

Class TGLGizmo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gizmo

Declaration

type TGLGizmo = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLGizmo

Overview

Fields

Private | _GZObaseGizmo: TGLBaseSceneObject;
Private | _GZOBoundingcube: TGLCube;
Private | _GZOrootHelpers: TGLBaseSceneObject;
Private | _GZOrootLines: TGLBaseSceneObject;
Private | _GZOrootTorus: TGLBaseSceneObject;
Private | _GZOrootCubes: TGLBaseSceneObject;
Private | _GZORootAxisLabel: TGLBaseSceneObject;
Private | _GZORootVisibleInfoLabels: TGLBaseSceneObject;
Private | _GZOlineX: TGLLines;
Private | _GZOlineY: TGLLines;
Private | _GZOlineZ: TGLLines;
Private | _GZOplaneXY: TGLLines;
Private | _GZOplaneXZ: TGLLines;
Private | _GZOplaneYZ: TGLLines;
Private | _GZOTorusX: TGLGizmoPickTorus;
Private | _GZOTorusY: TGLGizmoPickTorus;
Private | _GZOTorusZ: TGLGizmoPickTorus;
Private | _GZOCubeX: TGLGizmoPickCube;
Private | _GZOCubeY: TGLGizmoPickCube;
Private | _GZOCubeZ: TGLGizmoPickCube;
Private | _GZOAxisLabelX: TGLFlatText;
Private | _GZOAxisLabelY: TGLFlatText;
Private | _GZOAxisLabelZ: TGLFlatText;
Private | _GZOVisibleInfoLabels: TGLFlatText;
Private | FRootGizmo: TGLBaseSceneObject;
Private | FSelectedObj: TGLBaseSceneObject;
Private | FOperation: TGLGizmoOperation;
Private | FSelAxis: TGLGizmoAxis;
Private | FBoundingBoxColor: TGLColor;
Private | FSelectedColor: TGLColor;
Private | FVisibleInfoLabelsColor: TGLColor;
Private | FBoundingBoxColorChanged: Boolean;
Private | FVisibleInfoLabelsColorChanged: Boolean;
Private | FForceOperation: Boolean;
Private | FForceAxis: Boolean;
Private | FForceUniformScale: Boolean;
Private | FAutoZoom: Boolean;
Private | FExcludeObjects: Boolean;
Private | FNoZWrite: Boolean;
Private | FEnabled: Boolean;
Private | FAutoZoomFactor: Single;
Private | FZoomFactor: Single;
Private | FMoveCoef: Single;
Private | FRotationCoef: Single;
Private | FViewer: TGLSceneViewer;
Private | FGizmoElements: TGLGizmoElements;
Private | FVisibleVisibleInfoLabels: TGLGizmoVisibleInfoLabels;
Private | FExcludeObjectsList: TStrings;
Private | Moving: Boolean;
Private | Mx: Integer;
Private | My: Integer;
Private | Rx: Integer;
Private | Ry: Integer;
Private | dglEnable: TGLDirectOpenGL;
Private | dglDisable: TGLDirectOpenGL;
Private | dgtEnable: TGLDirectOpenGL;
Private | dgtDisable: TGLDirectOpenGL;
Private | dgcEnable: TGLDirectOpenGL;
Private | dgcDisable: TGLDirectOpenGL;
Private | dglaEnable: TGLDirectOpenGL;
Private | dglaDisable: TGLDirectOpenGL;
Private | dgliEnable: TGLDirectOpenGL;
Private | dgliDisable: TGLDirectOpenGL;
Private | LastMousePos: TGLVector;
Private | ObjDimensions: TGLVector;
Private | FOnBeforeSelect: TGLGizmoAcceptEvent;
Private | FOnBeforeUpdate: TGLGizmoUpdateEvent;
Private | FOnSelectionLost: TNotifyEvent;
Private | FScaleCoef: Single;
Private | FGizmoThickness: Single;
Private | FPickMode: TGLGizmoPickMode;
Private | FInternalRaycastHitData: TList;
Private | FUndoHistory: TGLGizmoUndoCollection;
Private | FLabelFont: TGLCustomBitmapFont;
Public | PickableObjectsWithRayCast: TList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetPickedObjectPoint(const Obj: TGLBaseSceneObject): TGLVector;
Private | function CheckObjectInExcludeList(const Obj: TGLBaseSceneObject): Boolean;
Private | function InternalGetPickedObjects(const X1, Y1, X2, Y2: Integer; const GuessCount: Integer = 8): TGLPickList;
Private | function MouseWorldPos(const X, Y: Integer): TGLVector;
Public | procedure Loaded; override;
Public | procedure LooseSelection; virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure SetVisible(const AValue: Boolean);
Public | procedure UndoAdd(const AObject: TGLCustomSceneObject);
Public | procedure UpdateGizmo(const NewDimensions: TGLVector); overload;
Public | procedure UpdateGizmo; overload;
Public | procedure ViewerMouseDown(const X, Y: Integer);
Public | procedure ViewerMouseMove(const X, Y: Integer);
Public | procedure ViewerMouseUp(const X, Y: Integer);
Private | procedure ClearInternalRaycastHitData;
Private | procedure DirectGlDisable(Sender: TObject; var Rci: TGLRenderContextInfo);
Private | procedure DirectGlEnable(Sender: TObject; var Rci: TGLRenderContextInfo);
Private | procedure SetBoundingBoxColor(const AValue: TGLColor);
Private | procedure SetExcludeObjectsList(const AValue: TStrings);
Private | procedure SetGizmoElements(const AValue: TGLGizmoElements);
Private | procedure SetGLGizmoThickness(const Value: Single);
Private | procedure SeTGLGizmoVisibleInfoLabels(const AValue: TGLGizmoVisibleInfoLabels);
Private | procedure SetLabelFont(const Value: TGLCustomBitmapFont);
Private | procedure SetRootGizmo(const AValue: TGLBaseSceneObject);
Private | procedure SetSelectedColor(const AValue: TGLColor);
Private | procedure SetSelectedObj(const Value: TGLBaseSceneObject);
Private | procedure SetViewer(const Value: TGLSceneViewer);
Private | procedure SetVisibleInfoLabelsColor(const AValue: TGLColor);
Private | procedure UpdateVisibleInfoLabels;

Properties

Published | property AutoZoom: Boolean read FAutoZoom write FAutoZoom;
Published | property AutoZoomFactor: Single read FAutoZoomFactor write FAutoZoomFactor;
Published | property BoundingBoxColor: TGLColor read FBoundingBoxColor write SetBoundingBoxColor;
Published | property Enabled: Boolean read FEnabled write FEnabled default False;
Published | property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;
Published | property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;
Published | property ForceAxis: Boolean read FForceAxis write FForceAxis;
Published | property ForceOperation: Boolean read FForceOperation write FForceoperation;
Published | property ForceUniformScale: Boolean read FForceUniformScale write FForceUniformScale;
Published | property GizmoElements: TGLGizmoElements read FGizmoElements write SetGizmoElements;
Published | property GizmoThickness: Single read FGizmoThickness write SeTGLGizmoThickness;
Published | property LabelFont: TGLCustomBitmapFont read FLabelFont write SetLabelFont default nil;
Published | property MoveCoef: Single read FMoveCoef write FMoveCoef;
Published | property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Published | property OnBeforeSelect: TGLGizmoAcceptEvent read FOnBeforeSelect write FOnBeforeSelect;
Published | property OnBeforeUpdate: TGLGizmoUpdateEvent read FOnBeforeUpdate write FOnBeforeUpdate;
Published | property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;
Published | property Operation: TGLGizmoOperation read FOperation write FOperation;
Published | property PickMode: TGLGizmoPickMode read FPickMode write FPickMode default PmGetPickedObjects;
Public | property RootGizmo: TGLBaseSceneObject read FRootGizmo write SetRootGizmo;
Published | property RotationCoef: Single read FRotationCoef write FRotationCoef;
Published | property ScaleCoef: Single read FScaleCoef write FScaleCoef;
Published | property SelAxis: TGLGizmoAxis read FSelAxis write FSelAxis;
Published | property SelectedColor: TGLColor read FSelectedColor write SetSelectedColor;
Published | property SelectedObj: TGLBaseSceneObject read FSelectedObj write SetSelectedObj;
Published | property Viewer: TGLSceneViewer read FViewer write SetViewer;
Published | property VisibleInfoLabels: TGLGizmoVisibleInfoLabels read FVisibleVisibleInfoLabels write SeTGLGizmoVisibleInfoLabels;
Published | property VisibleInfoLabelsColor: TGLColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;
Published | property ZoomFactor: Single read FZoomFactor write FZoomFactor;

Description

Fields

Private _GZObaseGizmo: TGLBaseSceneObject;

This item has no description.

Private _GZOBoundingcube: TGLCube;

This item has no description.

Private _GZOrootHelpers: TGLBaseSceneObject;

This item has no description.

Private _GZOrootLines: TGLBaseSceneObject;

This item has no description.

Private _GZOrootTorus: TGLBaseSceneObject;

This item has no description.

Private _GZOrootCubes: TGLBaseSceneObject;

This item has no description.

Private _GZORootAxisLabel: TGLBaseSceneObject;

This item has no description.

Private _GZORootVisibleInfoLabels: TGLBaseSceneObject;

This item has no description.

Private _GZOlineX: TGLLines;

This item has no description.

Private _GZOlineY: TGLLines;

This item has no description.

Private _GZOlineZ: TGLLines;

This item has no description.

Private _GZOplaneXY: TGLLines;

This item has no description.

Private _GZOplaneXZ: TGLLines;

This item has no description.

Private _GZOplaneYZ: TGLLines;

This item has no description.

Private _GZOTorusX: TGLGizmoPickTorus;

For Move

Private _GZOTorusY: TGLGizmoPickTorus;

For Move

Private _GZOTorusZ: TGLGizmoPickTorus;

For Move

Private _GZOCubeX: TGLGizmoPickCube;

For Rotate

Private _GZOCubeY: TGLGizmoPickCube;

For Rotate

Private _GZOCubeZ: TGLGizmoPickCube;

For Rotate

Private _GZOAxisLabelX: TGLFlatText;

For Scale

Private _GZOAxisLabelY: TGLFlatText;

For Scale

Private _GZOAxisLabelZ: TGLFlatText;

For Scale

Private _GZOVisibleInfoLabels: TGLFlatText;

This item has no description.

Private FRootGizmo: TGLBaseSceneObject;

This item has no description.

Private FSelectedObj: TGLBaseSceneObject;

This item has no description.

Private FOperation: TGLGizmoOperation;

FLastOperation,

Private FSelAxis: TGLGizmoAxis;

This item has no description.

Private FBoundingBoxColor: TGLColor;

This item has no description.

Private FSelectedColor: TGLColor;

This item has no description.

Private FVisibleInfoLabelsColor: TGLColor;

This item has no description.

Private FBoundingBoxColorChanged: Boolean;

This item has no description.

Private FVisibleInfoLabelsColorChanged: Boolean;

This item has no description.

Private FForceOperation: Boolean;

This item has no description.

Private FForceAxis: Boolean;

This item has no description.

Private FForceUniformScale: Boolean;

This item has no description.

Private FAutoZoom: Boolean;

This item has no description.

Private FExcludeObjects: Boolean;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FAutoZoomFactor: Single;

This item has no description.

Private FZoomFactor: Single;

This item has no description.

Private FMoveCoef: Single;

This item has no description.

Private FRotationCoef: Single;

This item has no description.

Private FViewer: TGLSceneViewer;

This item has no description.

Private FGizmoElements: TGLGizmoElements;

This item has no description.

Private FVisibleVisibleInfoLabels: TGLGizmoVisibleInfoLabels;

This item has no description.

Private FExcludeObjectsList: TStrings;

This item has no description.

Private Moving: Boolean;

This item has no description.

Private Mx: Integer;

This item has no description.

Private My: Integer;

This item has no description.

Private Rx: Integer;

This item has no description.

Private Ry: Integer;

This item has no description.

Private dglEnable: TGLDirectOpenGL;

This item has no description.

Private dglDisable: TGLDirectOpenGL;

This item has no description.

Private dgtEnable: TGLDirectOpenGL;

This item has no description.

Private dgtDisable: TGLDirectOpenGL;

This item has no description.

Private dgcEnable: TGLDirectOpenGL;

This item has no description.

Private dgcDisable: TGLDirectOpenGL;

This item has no description.

Private dglaEnable: TGLDirectOpenGL;

This item has no description.

Private dglaDisable: TGLDirectOpenGL;

This item has no description.

Private dgliEnable: TGLDirectOpenGL;

This item has no description.

Private dgliDisable: TGLDirectOpenGL;

This item has no description.

Private LastMousePos: TGLVector;

This item has no description.

Private ObjDimensions: TGLVector;

This item has no description.

Private FOnBeforeSelect: TGLGizmoAcceptEvent;

This item has no description.

Private FOnBeforeUpdate: TGLGizmoUpdateEvent;

This item has no description.

Private FOnSelectionLost: TNotifyEvent;

This item has no description.

Private FScaleCoef: Single;

This item has no description.

Private FGizmoThickness: Single;

This item has no description.

Private FPickMode: TGLGizmoPickMode;

This item has no description.

Private FInternalRaycastHitData: TList;

This item has no description.

Private FUndoHistory: TGLGizmoUndoCollection;

This item has no description.

Private FLabelFont: TGLCustomBitmapFont;

This item has no description.

Public PickableObjectsWithRayCast: TList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetPickedObjectPoint(const Obj: TGLBaseSceneObject): TGLVector;

This item has no description.

Private function CheckObjectInExcludeList(const Obj: TGLBaseSceneObject): Boolean;

This item has no description.

Private function InternalGetPickedObjects(const X1, Y1, X2, Y2: Integer; const GuessCount: Integer = 8): TGLPickList;

This item has no description.

Private function MouseWorldPos(const X, Y: Integer): TGLVector;

This item has no description.

Public procedure Loaded; override;

This item has no description.

Public procedure LooseSelection; virtual;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure SetVisible(const AValue: Boolean);

This item has no description.

Public procedure UndoAdd(const AObject: TGLCustomSceneObject);

This item has no description.

Public procedure UpdateGizmo(const NewDimensions: TGLVector); overload;

This item has no description.

Public procedure UpdateGizmo; overload;

This item has no description.

Public procedure ViewerMouseDown(const X, Y: Integer);

This item has no description.

Public procedure ViewerMouseMove(const X, Y: Integer);

This item has no description.

Public procedure ViewerMouseUp(const X, Y: Integer);

This item has no description.

Private procedure ClearInternalRaycastHitData;

This item has no description.

Private procedure DirectGlDisable(Sender: TObject; var Rci: TGLRenderContextInfo);

This item has no description.

Private procedure DirectGlEnable(Sender: TObject; var Rci: TGLRenderContextInfo);

This item has no description.

Private procedure SetBoundingBoxColor(const AValue: TGLColor);

This item has no description.

Private procedure SetExcludeObjectsList(const AValue: TStrings);

This item has no description.

Private procedure SetGizmoElements(const AValue: TGLGizmoElements);

This item has no description.

Private procedure SetGLGizmoThickness(const Value: Single);

This item has no description.

Private procedure SeTGLGizmoVisibleInfoLabels(const AValue: TGLGizmoVisibleInfoLabels);

This item has no description.

Private procedure SetLabelFont(const Value: TGLCustomBitmapFont);

This item has no description.

Private procedure SetRootGizmo(const AValue: TGLBaseSceneObject);

This item has no description.

Private procedure SetSelectedColor(const AValue: TGLColor);

This item has no description.

Private procedure SetSelectedObj(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetViewer(const Value: TGLSceneViewer);

This item has no description.

Private procedure SetVisibleInfoLabelsColor(const AValue: TGLColor);

This item has no description.

Private procedure UpdateVisibleInfoLabels;

This item has no description.

Properties

Published property AutoZoom: Boolean read FAutoZoom write FAutoZoom;

This item has no description.

Published property AutoZoomFactor: Single read FAutoZoomFactor write FAutoZoomFactor;

This item has no description.

Published property BoundingBoxColor: TGLColor read FBoundingBoxColor write SetBoundingBoxColor;

This item has no description.

Published property Enabled: Boolean read FEnabled write FEnabled default False;

Indicates whether the gizmo is enabled or not. WARNING: When loading/editing (possibly whenever a structureChanged call is made) a model, sometimes the gizmo will trigger a bug if the mouse is inside the glscene Viewer. To prevent that, remember to disable the gizmo before loading, then process windows messages (i.e. application.processMessage) and then enable the gizmo again. Warning Enable is ReadOnly property if you set to False, Gizmo is not Hidden use Visible instead if you want to Hide, if you want to Hide but keep enabled see the VisibleGizmo property

Published property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;

This item has no description.

Published property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;

This item has no description.

Published property ForceAxis: Boolean read FForceAxis write FForceAxis;

This item has no description.

Published property ForceOperation: Boolean read FForceOperation write FForceoperation;

This item has no description.

Published property ForceUniformScale: Boolean read FForceUniformScale write FForceUniformScale;

This item has no description.

Published property GizmoElements: TGLGizmoElements read FGizmoElements write SetGizmoElements;

This item has no description.

Published property GizmoThickness: Single read FGizmoThickness write SeTGLGizmoThickness;

This item has no description.

Published property LabelFont: TGLCustomBitmapFont read FLabelFont write SetLabelFont default nil;

This item has no description.

Published property MoveCoef: Single read FMoveCoef write FMoveCoef;

This item has no description.

Published property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

This item has no description.

Published property OnBeforeSelect: TGLGizmoAcceptEvent read FOnBeforeSelect write FOnBeforeSelect;

This item has no description.

Published property OnBeforeUpdate: TGLGizmoUpdateEvent read FOnBeforeUpdate write FOnBeforeUpdate;

Called before an Update is applied. The "vector" parameter is the difference that will be applied to the object, according to the axis and operation selected.

Published property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;

This item has no description.

Published property Operation: TGLGizmoOperation read FOperation write FOperation;

This item has no description.

Published property PickMode: TGLGizmoPickMode read FPickMode write FPickMode default PmGetPickedObjects;

This item has no description.

Public property RootGizmo: TGLBaseSceneObject read FRootGizmo write SetRootGizmo;

This item has no description.

Published property RotationCoef: Single read FRotationCoef write FRotationCoef;

This item has no description.

Published property ScaleCoef: Single read FScaleCoef write FScaleCoef;

This item has no description.

Published property SelAxis: TGLGizmoAxis read FSelAxis write FSelAxis;

This item has no description.

Published property SelectedColor: TGLColor read FSelectedColor write SetSelectedColor;

This item has no description.

Published property SelectedObj: TGLBaseSceneObject read FSelectedObj write SetSelectedObj;

This item has no description.

Published property Viewer: TGLSceneViewer read FViewer write SetViewer;

——————————————————————–

Published property VisibleInfoLabels: TGLGizmoVisibleInfoLabels read FVisibleVisibleInfoLabels write SeTGLGizmoVisibleInfoLabels;

This item has no description.

Published property VisibleInfoLabelsColor: TGLColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;

This item has no description.

Published property ZoomFactor: Single read FZoomFactor write FZoomFactor;


GLSysHelp v.2.5: GLS.GizmoEx

Unit GLS.GizmoEx

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.Types
  • Vcl.StdCtrls
  • GLS.Scene
  • GLS.Color
  • GLS.Objects
  • GLScene.VectorGeometry
  • GLS.Material
  • GLScene.Strings
  • GLS.GeomObjects
  • GLS.BitmapFont
  • GLS.SceneViewer
  • GLS.VectorFileObjects
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLScene.GeometryBB
  • GLScene.VectorTypes
  • GLS.Canvas
  • GLS.PersistentClasses
  • GLS.Screen
  • GLS.State
  • GLS.Selection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGizmoExObjectItem |
Class TGLGizmoExObjectCollection |
Class TGLGizmoExActionHistoryItem |
Class TGLGizmoExActionHistoryCollection |
Class TGLGizmoExUIFrustrum |
Class TGLGizmoExUISphere |
Class TGLGizmoExUIDisk |
Class TGLGizmoExUITorus |
Class TGLGizmoExUIPolygon |
Class TGLGizmoExUIArrowLine |
Class TGLGizmoExUILines |
Class TGLGizmoExUIFlatText |
Class TGLGizmoEx |

Types

TGLGizmoExAcceptEvent = procedure(Sender: TObject; var objs: TGLPickList) of object;
TGLGizmoExAxis = (...);
TGLGizmoExAxisSelected = procedure(Sender: TObject; var Axis: TGLGizmoExAxis) of object;
TGLGizmoExOperation = (...);
TGLGizmoExOperationMode = (...);
TGLGizmoExPickMode = (...);
TGLGizmoExReferenceCoordinateSystem = (...);
TGLGizmoExSelectionRegion = (...);
TGLGizmoExSelRec = array of TPoint;
TGLGizmoExVisibleInfoLabel = (...);
TGLGizmoExVisibleInfoLabels = set of TGLGizmoExVisibleInfoLabel;
TInfoLabelCoordType = (...);

Description

Types

TGLGizmoExAcceptEvent = procedure(Sender: TObject; var objs: TGLPickList) of object;

This item has no description.

TGLGizmoExAxis = (...);

This item has no description.

Values
  • gaNone
  • gaX
  • gaY
  • gaZ
  • gaXY
  • gaXZ
  • gaYZ
  • gaXYZ
TGLGizmoExAxisSelected = procedure(Sender: TObject; var Axis: TGLGizmoExAxis) of object;

This item has no description.

TGLGizmoExOperation = (...);

This item has no description.

Values
  • gopMove
  • gopRotate
  • gopScale
  • gopNone
TGLGizmoExOperationMode = (...);

This item has no description.

Values
  • gomNone
  • gomSelect
  • gomMove
  • gomRotate
  • gomScale
TGLGizmoExPickMode = (...);

This item has no description.

Values
  • pmGetPickedObjects
  • pmRayCast
TGLGizmoExReferenceCoordinateSystem = (...);

This item has no description.

Values
  • rcsView
  • rcsLocal
TGLGizmoExSelectionRegion = (...);

This item has no description.

Values
  • gsrRectangular
  • gsrCircular
  • gsrFence
  • gsrLasso
TGLGizmoExSelRec = array of TPoint;

This item has no description.

TGLGizmoExVisibleInfoLabel = (...);

This item has no description.

Values
  • vliName
  • vliOperation
  • vliCoords
TGLGizmoExVisibleInfoLabels = set of TGLGizmoExVisibleInfoLabel;

This item has no description.

TInfoLabelCoordType = (...);

This item has no description.

Values
  • ilcChanging
  • ilcChangeRate


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExObjectItem

Class TGLGizmoExObjectItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExObjectItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLGizmoExObjectItem

Overview

Fields

Private | FOldAutoScaling: TGLVector;
Private | FEffectedObject: TGLBaseSceneObject;
Private | FParentOldObject: TGLBaseSceneObject;
Private | FIndexOldObject: Integer;
Private | FNameOldObject: string;
Private | FReturnObject: Boolean;
Private | FOldMatrix: TGLMatrix;
Private | FGizmoTmpRoot: TGLBaseSceneObject;

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;
Public | procedure AssignFromObject(const AObject: TGLBaseSceneObject; AssignAndRemoveObj: Boolean = False);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Private | procedure SetEffectedObject(const Value: TGLBaseSceneObject);
Private | procedure SetOldMatrix(const Value: TGLMatrix);

Properties

Published | property EffectedObject: TGLBaseSceneobject read FEffectedObject write SetEffectedObject;
Public | property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;
Public | property OldMatrix: TGLMatrix read FOldMatrix write SetOldMatrix;

Description

Fields

Private FOldAutoScaling: TGLVector;

This item has no description.

Private FEffectedObject: TGLBaseSceneObject;

This item has no description.

Private FParentOldObject: TGLBaseSceneObject;

This item has no description.

Private FIndexOldObject: Integer;

This item has no description.

Private FNameOldObject: string;

This item has no description.

Private FReturnObject: Boolean;

This item has no description.

Private FOldMatrix: TGLMatrix;

This item has no description.

Private FGizmoTmpRoot: TGLBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AssignFromObject(const AObject: TGLBaseSceneObject; AssignAndRemoveObj: Boolean = False);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;

This item has no description.

Private procedure SetEffectedObject(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetOldMatrix(const Value: TGLMatrix);

This item has no description.

Properties

Published property EffectedObject: TGLBaseSceneobject read FEffectedObject write SetEffectedObject;

This item has no description.

Public property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;

This item has no description.

Public property OldMatrix: TGLMatrix read FOldMatrix write SetOldMatrix;

TODO: create a special type for Matrix.


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExObjectCollection

Class TGLGizmoExObjectCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExObjectCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLGizmoExObjectCollection

Overview

Methods

Public | function Add: TGLGizmoExObjectItem;
Private | function GetItems(const Index: Integer): TGLGizmoExObjectItem;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveByObject(const AObject: TGLCustomSceneObject);
Private | procedure SetItems(const Index: Integer; const Value: TGLGizmoExObjectItem);

Properties

Public property Items[const Index: Integer]: TGLGizmoExObjectItem read GetItems write SetItems;

Description

Methods

Public function Add: TGLGizmoExObjectItem;

This item has no description.

Private function GetItems(const Index: Integer): TGLGizmoExObjectItem;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation);

This item has no description.

Public procedure RemoveByObject(const AObject: TGLCustomSceneObject);

This item has no description.

Private procedure SetItems(const Index: Integer; const Value: TGLGizmoExObjectItem);

This item has no description.

Properties

Public property Items[const Index: Integer]: TGLGizmoExObjectItem read GetItems write SetItems;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExActionHistoryItem

Class TGLGizmoExActionHistoryItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExActionHistoryItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLGizmoExActionHistoryItem

Overview

Fields

Private | FObject: TObject;
Private | FGizmoObjectCollection: TGLGizmoExObjectCollection;

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;
Private | procedure SetGizmoObjectCollection(aValue: TGLGizmoExObjectCollection);
Private | procedure SetObject(aValue: TObject);

Properties

Public | property BaseObject: TObject read FObject write SetObject;
Public | property GizmoObjectCollection: TGLGizmoExObjectCollection read FGizmoObjectCollection write SetGizmoObjectCollection;

Description

Fields

Private FObject: TObject;

This item has no description.

Private FGizmoObjectCollection: TGLGizmoExObjectCollection;

This item has no description.

Methods

Public constructor Create(AOwner: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetGizmoObjectCollection(aValue: TGLGizmoExObjectCollection);

This item has no description.

Private procedure SetObject(aValue: TObject);

This item has no description.

Properties

Public property BaseObject: TObject read FObject write SetObject;

This item has no description.

Public property GizmoObjectCollection: TGLGizmoExObjectCollection read FGizmoObjectCollection write SetGizmoObjectCollection;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExActionHistoryCollection

Class TGLGizmoExActionHistoryCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExActionHistoryCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLGizmoExActionHistoryCollection

Overview

Fields

Private | FItemIndex: Integer;
Private | FItemsMaxCount: Integer;
Private | FGizmoTmpRoot: TGLBaseSceneObject;

Methods

Public | constructor Create(AOwner: TPersistent; ItemClass: TCollectionItemClass);
Public | function Redo: TGLGizmoExActionHistoryItem;
Public | function Undo: TGLGizmoExActionHistoryItem;
Private | function Add: TGLGizmoExActionHistoryItem;
Private | function GetItems(const Index: Integer): TGLGizmoExActionHistoryItem;
Public | procedure AddObject(obj: TObject);
Public | procedure AddObjects(objs: TGLPickList);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveObjects(objs: TGLPickList);
Private | procedure SetItems(const Index: Integer; const Value: TGLGizmoExActionHistoryItem);

Properties

Public | property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;
Public | property ItemIndex: Integer read FItemIndex write FItemIndex;
Public | property Items[const Index: Integer]: TGLGizmoExActionHistoryItem read GetItems write SetItems;
Public | property MaxCount: Integer read FItemsMaxCount write FItemsMaxCount;

Description

Fields

Private FItemIndex: Integer;

This item has no description.

Private FItemsMaxCount: Integer;

This item has no description.

Private FGizmoTmpRoot: TGLBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent; ItemClass: TCollectionItemClass);

This item has no description.

Public function Redo: TGLGizmoExActionHistoryItem;

This item has no description.

Public function Undo: TGLGizmoExActionHistoryItem;

This item has no description.

Private function Add: TGLGizmoExActionHistoryItem;

This item has no description.

Private function GetItems(const Index: Integer): TGLGizmoExActionHistoryItem;

This item has no description.

Public procedure AddObject(obj: TObject);

This item has no description.

Public procedure AddObjects(objs: TGLPickList);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation);

This item has no description.

Public procedure RemoveObjects(objs: TGLPickList);

This item has no description.

Private procedure SetItems(const Index: Integer; const Value: TGLGizmoExActionHistoryItem);

This item has no description.

Properties

Public property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;

This item has no description.

Public property ItemIndex: Integer read FItemIndex write FItemIndex;

This item has no description.

Public property Items[const Index: Integer]: TGLGizmoExActionHistoryItem read GetItems write SetItems;

This item has no description.

Public property MaxCount: Integer read FItemsMaxCount write FItemsMaxCount;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExUIFrustrum

Class TGLGizmoExUIFrustrum

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExUIFrustrum = class(TGLFrustrum)

Description

Gizmo objects

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLFrustrum
  • TGLGizmoExUIFrustrum

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExUISphere

Class TGLGizmoExUISphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExUISphere = class(TGLSphere)

Description

This item has no description. Showing description inherited from TGLSphere.

A sphere object. The sphere can have to and bottom caps, as well as being just a slice of sphere. Ref: https://mathworld.wolfram.com/Sphere.html Ref: https://mathworld.wolfram.com/GeodesicDome.html

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLSphere
  • TGLGizmoExUISphere

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExUIDisk

Class TGLGizmoExUIDisk

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExUIDisk = class(TGLDisk)

Description

This item has no description. Showing description inherited from TGLDisk.

A Disk object that may not be complete, it can have a hole (controlled by the InnerRadius property) and can only be a slice (controlled by the StartAngle and SweepAngle properties).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLDisk
  • TGLGizmoExUIDisk

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExUITorus

Class TGLGizmoExUITorus

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExUITorus = class(TGLTorus)

Description

This item has no description. Showing description inherited from TGLTorus.

A Torus object

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTorus
  • TGLGizmoExUITorus

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExUIPolygon

Class TGLGizmoExUIPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExUIPolygon = class(TGLPolygon)

Description

This item has no description. Showing description inherited from TGLPolygon.

A basic polygon object. The contour is described by the Nodes and SplineMode properties, it should be planar and is automatically tessellated. Texture coordinates are deduced from X and Y coordinates only. This object allows only for polygons described by a single contour, if you need "complex polygons" with holes, patches and cutouts, see GLS.MultiPolygon.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLPolygon
  • TGLGizmoExUIPolygon

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExUIArrowLine

Class TGLGizmoExUIArrowLine

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExUIArrowLine = class(TGLArrowLine)

Description

This item has no description. Showing description inherited from TGLArrowLine.

Draws an arrowhead (cylinder + cone). The arrow head is a cone that shares the attributes of the cylinder (ie stacks/slices, materials etc). Seems to work ok. This is useful for displaying a vector based field (eg velocity) or other arrows that might be required. By default the bottom arrow is off

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLArrowLine
  • TGLGizmoExUIArrowLine

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExUILines

Class TGLGizmoExUILines

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExUILines = class(TGLLines)

Description

This item has no description. Showing description inherited from TGLLines.

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLNodedLines
  • TGLLines
  • TGLGizmoExUILines

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoExUIFlatText

Class TGLGizmoExUIFlatText

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoExUIFlatText = class(TGLFlatText)

Description

This item has no description. Showing description inherited from TGLFlatText.

A 2D text displayed and positionned in 3D coordinates. The FlatText uses a character font defined and stored by a TGLBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLFlatText
  • TGLGizmoExUIFlatText

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GLSysHelp v.2.5: GLS.GizmoEx: Class TGLGizmoEx

Class TGLGizmoEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.GizmoEx

Declaration

type TGLGizmoEx = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLGizmoEx

Overview

Fields

Private | FUIBaseGizmo: TGLBaseSceneObject;
Private | FUIRootHelpers: TGLBaseSceneObject;
Private | FUIRootSelect: TGLBaseSceneObject;
Private | FUIRootMovement: TGLBaseSceneObject;
Private | FUIRootRotate: TGLBaseSceneObject;
Private | FUIRootRotateAxisLabel: TGLBaseSceneObject;
Private | FUIRootScale: TGLBaseSceneObject;
Private | FUIRootAxisLabel: TGLBaseSceneObject;
Private | FUIRootVisibleInfoLabels: TGLBaseSceneObject;
Private | FInterfaceRender: TGLDirectOpenGL;
Private | FInternalRender: TGLDirectOpenGL;
Private | FUISelectLineX: TGLGizmoExUILines;
Private | FUISelectLineY: TGLGizmoExUILines;
Private | FUISelectLineZ: TGLGizmoExUILines;
Private | FUIICMovementLineX: TGLGizmoExUIFrustrum;
Private | FUIICMovementLineY: TGLGizmoExUIFrustrum;
Private | FUIICMovementLineZ: TGLGizmoExUIFrustrum;
Private | FUIICMovementLineXY: TGLGizmoExUIFrustrum;
Private | FUIICMovementLineXZ: TGLGizmoExUIFrustrum;
Private | FUIICMovementLineYZ: TGLGizmoExUIFrustrum;
Private | FUIMovementArrowX: TGLGizmoExUIArrowLine;
Private | FUIMovementArrowY: TGLGizmoExUIArrowLine;
Private | FUIMovementArrowZ: TGLGizmoExUIArrowLine;
Private | FUIMovementLineX: TGLGizmoExUILines;
Private | FUIMovementLineY: TGLGizmoExUILines;
Private | FUIMovementLineZ: TGLGizmoExUILines;
Private | FUIMovementLineXY: TGLGizmoExUILines;
Private | FUIMovementLineXZ: TGLGizmoExUILines;
Private | FUIMovementLineYZ: TGLGizmoExUILines;
Private | FUIMovementPlaneXY: TGLGizmoExUIPolyGon;
Private | FUIMovementPlaneXZ: TGLGizmoExUIPolyGon;
Private | FUIMovementPlaneYZ: TGLGizmoExUIPolyGon;
Private | FUIRotateLineX: TGLGizmoExUILines;
Private | FUIRotateLineY: TGLGizmoExUILines;
Private | FUIRotateLineZ: TGLGizmoExUILines;
Private | FUIRotateLineXY: TGLGizmoExUILines;
Private | FUIRotateLineXZ: TGLGizmoExUILines;
Private | FUIICRotateTorusX: TGLGizmoExUITorus;
Private | FUIICRotateTorusY: TGLGizmoExUITorus;
Private | FUIICRotateTorusZ: TGLGizmoExUITorus;
Private | FUIICRotateTorusXZ: TGLGizmoExUITorus;
Private | FUIRotateDiskXY: TGLGizmoExUIDisk;
Private | FUIRotateDiskX: TGLGizmoExUIDisk;
Private | FUIRotateDiskX2: TGLGizmoExUIDisk;
Private | FUIRotateDiskY: TGLGizmoExUIDisk;
Private | FUIRotateDiskY2: TGLGizmoExUIDisk;
Private | FUIRotateDiskZ: TGLGizmoExUIDisk;
Private | FUIRotateDiskZ2: TGLGizmoExUIDisk;
Private | FUIRotateLineArrowX: TGLGizmoExUILines;
Private | FUIRotateLineArrowY: TGLGizmoExUILines;
Private | FUIRotateLineArrowZ: TGLGizmoExUILines;
Private | FUIICRotateSphereXY: TGLGizmoExUISphere;
Private | FUIRotateAxisLabelX: TGLGizmoExUIFlatText;
Private | FUIRotateAxisLabelY: TGLGizmoExUIFlatText;
Private | FUIRotateAxisLabelZ: TGLGizmoExUIFlatText;
Private | FUIScaleArrowX: TGLGizmoExUISphere;
Private | FUIScaleArrowY: TGLGizmoExUISphere;
Private | FUIScaleArrowZ: TGLGizmoExUISphere;
Private | FUIScaleLineX: TGLGizmoExUILines;
Private | FUIScaleLineY: TGLGizmoExUILines;
Private | FUIScaleLineZ: TGLGizmoExUILines;
Private | FUIScaleLineXY: TGLGizmoExUILines;
Private | FUIScaleLineYZ: TGLGizmoExUILines;
Private | FUIScaleLineXZ: TGLGizmoExUILines;
Private | FUIICScaleLineX: TGLGizmoExUIFrustrum;
Private | FUIICScaleLineY: TGLGizmoExUIFrustrum;
Private | FUIICScaleLineZ: TGLGizmoExUIFrustrum;
Private | FUIICScaleLineXY: TGLGizmoExUIFrustrum;
Private | FUIICScaleLineXZ: TGLGizmoExUIFrustrum;
Private | FUIICScaleLineYZ: TGLGizmoExUIFrustrum;
Private | FUIICScaleLineXYZ: TGLGizmoExUIFrustrum;
Private | FUIScalePlaneXY: TGLGizmoExUIPolyGon;
Private | FUIScalePlaneXZ: TGLGizmoExUIPolyGon;
Private | FUIScalePlaneYZ: TGLGizmoExUIPolyGon;
Private | FUIScalePlaneXYZ: TGLGizmoExUIPolyGon;
Private | FUIAxisLabelX: TGLGizmoExUIFlatText;
Private | FUIAxisLabelY: TGLGizmoExUIFlatText;
Private | FUIAxisLabelZ: TGLGizmoExUIFlatText;
Private | FUIVisibleInfoLabels: TGLGizmoExUIFlatText;
Private | FRootGizmo: TGLBaseSceneObject;
Private | FRootObjects: TGLBaseSceneObject;
Private | FGizmoTmpRoot: TGLBaseSceneObject;
Private | FSelectedObj: TGLBaseSceneObject;
Private | FOperation: TGLGizmoExOperation;
Private | FOperationMode: TGLGizmoExOperationMode;
Private | FSelAxis: TGLGizmoExAxis;
Private | fInfoLabelCoordType: TInfoLabelCoordType;
Private | FReferenceCoordSystem: TGLGizmoExReferenceCoordinateSystem;
Private | FBoundingBoxColor: TGLColor;
Private | FSelectedColor: TGLColor;
Private | FVisibleInfoLabelsColor: TGLColor;
Private | FSelectionRegionColor: TGLColor;
Private | FVisibleInfoLabelsColorChanged: Boolean;
Private | FAutoZoom: Boolean;
Private | FExcludeObjects: Boolean;
Private | FExcludeClassname: Boolean;
Private | FNoZWrite: Boolean;
Private | FEnabled: Boolean;
Private | FAutoZoomFactor: Single;
Private | FZoomFactor: Single;
Private | FMoveCoef: Single;
Private | FRotationCoef: Single;
Private | FViewer: TGLSceneViewer;
Private | FVisibleVisibleInfoLabels: TGLGizmoExVisibleInfoLabels;
Private | FExcludeObjectsList: TStrings;
Private | FExcludeClassNameList: TStrings;
Private | FSelectionRegion: TGLGizmoExSelectionRegion;
Private | FEnableMultiSelection: Boolean;
Private | FShowMultiSelecting: Boolean;
Private | FSelectionRec: TGLGizmoExSelRec;
Private | FCanAddObjToSelectionList: Boolean;
Private | FCanRemoveObjFromSelectionList: Boolean;
Private | FSelectedObjects: TGLPickList;
Private | FAntiAliasedLines: Boolean;
Private | FShowAxisLabel: Boolean;
Private | FShowObjectInfos: Boolean;
Private | FShowBoundingBox: Boolean;
Private | FCanChangeWithChildren: Boolean;
Private | moving: Boolean;
Private | mx: Integer;
Private | my: Integer;
Private | fCursorPos: TPoint;
Private | fLastCursorPos: TPoint;
Private | fChangeRate: TAffineVector;
Private | FEnableLoopCursorMoving: Boolean;
Private | lastMousePos: TGLVector;
Private | FOnUpdate: TNotifyEvent;
Private | FOnSelect: TGLGizmoExAcceptEvent;
Private | FOnOperationChange: TNotifyEvent;
Private | FOnOperationModeChange: TNotifyEvent;
Private | FOnSelectionLost: TNotifyEvent;
Private | FOnAxisSelected: TGLGizmoExAxisSelected;
Private | FScaleCoef: Single;
Private | FGizmoThickness: Single;
Private | FPickMode: TGLGizmoExPickMode;
Private | FEnableHistory: Boolean;
Private | FHistory: TGLGizmoExActionHistoryCollection;
Private | FHistoryStepsCount: Integer;
Private | FLabelFont: TGLCustomBitmapFont;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Redo: TGLGizmoExActionHistoryItem;
Public | function Undo: TGLGizmoExActionHistoryItem;
Private | function CheckClassNameInExcludeList(const Obj: TGLBaseSceneObject): Boolean;
Private | function CheckObjectInExcludeList(const Obj: TGLBaseSceneObject): Boolean;
Private | function GetPickList: TGLPickList;
Private | function GetSelectedObj: TGLBaseSceneObject;
Private | function GetVisible: Boolean;
Private | function InternalGetPickedObjects(const x1, y1, x2, y2: Integer; const guessCount: Integer = 8): TGLPickList;
Private | function MouseWorldPos(const X, Y: Integer): TGLVector;
Public | procedure Loaded; override;
Public | procedure LooseCursorSelection;
Public | procedure LooseSelection; virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RemoveSelectedObjects;
Public | procedure UndoAdd(const AObject: TObject);
Public | procedure UpdateGizmo; overload;
Public | procedure ViewerMouseDown(const X, Y: Integer);
Public | procedure ViewerMouseMove(const X, Y: Integer);
Public | procedure ViewerMouseUp(const X, Y: Integer);
Private | procedure ActivatingElements(PickList: TGLPickList);
Private | procedure AddObjToSelectionList(Obj: TGLBaseSceneObject);
Private | procedure AssignPickList(aList: TGLPickList; RemoveObj: Boolean = False);
Private | procedure ClearSelection;
Private | procedure InterfaceRender(Sender: TObject; var rci: TGLRenderContextInfo);
Private | procedure InternalRender(Sender: TObject; var rci: TGLRenderContextInfo);
Private | procedure MultiSelMouseDown(X, Y: Integer);
Private | procedure MultiSelMouseMove(X, Y: Integer);
Private | procedure MultiSelMouseUp(X, Y: Integer);
Private | procedure RemoveObjFromSelectionList(Obj: TGLBaseSceneObject);
Private | procedure SetAALines(aValue: Boolean);
Private | procedure SetAngleDisk(aAngle: Single);
Private | procedure SetAutoZoomFactor(const AValue: Single);
Private | procedure SetBoundingBoxColor(const AValue: TGLColor);
Private | procedure SetCanChangeWithChildren(AValue: Boolean);
Private | procedure SetEnableLoopCursorMoving(const AValue: Boolean);
Private | procedure SetEnableMultiSelection(const AValue: Boolean);
Private | procedure SetExcludeClassNameList(const AValue: TStrings);
Private | procedure SetExcludeObjectsList(const AValue: TStrings);
Private | procedure SetGizmoTmpRoot(const AValue: TGLBaseSceneObject);
Private | procedure SetGLGizmoExThickness(const Value: Single);
Private | procedure SeTGLGizmoExVisibleInfoLabels(const AValue: TGLGizmoExVisibleInfoLabels);
Private | procedure SetHistoryStepsCount(aValue: Integer);
Private | procedure SetInfoLabelCoordType(aValue: TInfoLabelCoordType);
Private | procedure SetLabelFont(const Value: TGLCustomBitmapFont);
Private | procedure SetNoZWrite(const Value: Boolean);
Private | procedure SetOperation(const Value: TGLGizmoExOperation);
Private | procedure SetOperationMode(const Value: TGLGizmoExOperationMode);
Private | procedure SetPickList(aValue: TGLPickList);
Private | procedure SetPickMode(APickMode: TGLGizmoExPickMode);
Private | procedure SetReferenceCoordSystem(aValue: TGLGizmoExReferenceCoordinateSystem);
Private | procedure SetRootGizmo(const AValue: TGLBaseSceneObject);
Private | procedure SetRootObjects(const AValue: TGLBaseSceneObject);
Private | procedure SetSelAxis(aValue: TGLGizmoExAxis);
Private | procedure SetSelectedColor(const AValue: TGLColor);
Private | procedure SetSelectedObj(const Value: TGLBaseSceneObject);
Private | procedure SetSelectionRegion(const AValue: TGLGizmoExSelectionRegion);
Private | procedure SetSelectionRegionColor(const AValue: TGLColor);
Private | procedure SetShowAxisLabel(const AValue: Boolean);
Private | procedure SetShowBoundingBox(const AValue: Boolean);
Private | procedure SetShowObjectInfos(const AValue: Boolean);
Private | procedure SetViewer(const Value: TGLSceneViewer);
Private | procedure SetVisible(const AValue: Boolean);
Private | procedure SetVisibleInfoLabelsColor(const AValue: TGLColor);
Private | procedure SetZoomFactor(const AValue: Single);
Private | procedure UpdateVisibleInfoLabels;

Properties

Published | property AntiAliasedLines: Boolean read FAntiAliasedLines write SetAALines default True;
Published | property AutoZoom: Boolean read FAutoZoom write FAutoZoom default True;
Published | property AutoZoomFactor: Single read FAutoZoomFactor write SetAutoZoomFactor;
Published | property BoundingBoxColor: TGLColor read FBoundingBoxColor write SetBoundingBoxColor;
Public | property CanAddObjToSelectionList: Boolean read FCanAddObjToSelectionList write FCanAddObjToSelectionList;
Published | property CanChangeWithChildren: Boolean read FCanChangeWithChildren write SetCanChangeWithChildren;
Public | property CanRemoveObjFromSelectionList: Boolean read FCanRemoveObjFromSelectionList write FCanRemoveObjFromSelectionList;
Public | property CursorSelectingRegion: Boolean read FShowMultiSelecting;
Published | property EnableActionHistory: Boolean read FEnableHistory write FEnableHistory default True;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property EnableLoopCursorMoving: Boolean read FEnableLoopCursorMoving write SetEnableLoopCursorMoving default True;
Published | property EnableMultiSelection: Boolean read FEnableMultiSelection write SetEnableMultiSelection default True;
Published | property ExcludeClassname: Boolean read FExcludeClassname write FExcludeClassname;
Published | property ExcludeClassnameList: TStrings read FExcludeClassnameList write SetExcludeClassnameList;
Published | property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;
Published | property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;
Published | property GizmoThickness: Single read FGizmoThickness write SeTGLGizmoExThickness;
Public | property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write SetGizmoTmpRoot;
Published | property HistoryStepsCount: Integer read FHistoryStepsCount write SetHistoryStepsCount;
Published | property InfoLabelCoordType: TInfoLabelCoordType read fInfoLabelCoordType write SetInfoLabelCoordType default ilcChangeRate;
Published | property LabelFont: TGLCustomBitmapFont read FLabelFont write SetLabelFont default nil;
Published | property MoveCoef: Single read FMoveCoef write FMoveCoef;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite default True;
Published | property OnAxisSelected: TGLGizmoExAxisSelected read FOnAxisSelected write FOnAxisSelected;
Published | property OnOperationChange: TNotifyEvent read FOnOperationChange write FOnOperationChange;
Published | property OnOperationModeChange: TNotifyEvent read FOnOperationModeChange write FOnOperationModeChange;
Published | property OnSelect: TGLGizmoExAcceptEvent read FOnSelect write FOnSelect;
Published | property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;
Published | property OnUpdate: TNotifyEvent read FOnUpdate write FOnUpdate;
Private | property Operation: TGLGizmoExOperation read FOperation write SetOperation;
Published | property OperationMode: TGLGizmoExOperationMode read FOperationMode write SetOperationMode default gomSelect;
Published | property PickMode: TGLGizmoExPickMode read FPickMode write SetPickMode default pmGetPickedObjects;
Published | property ReferenceCoordSystem: TGLGizmoExReferenceCoordinateSystem read FReferenceCoordSystem write SetReferenceCoordSystem default rcsView;
Public | property RootGizmo: TGLBaseSceneObject read FRootGizmo write SetRootGizmo;
Public | property RootObjects: TGLBaseSceneObject read FRootObjects write SetRootObjects;
Published | property RotationCoef: Single read FRotationCoef write FRotationCoef;
Published | property ScaleCoef: Single read FScaleCoef write FScaleCoef;
Private | property SelAxis: TGLGizmoExAxis read FSelAxis write SetSelAxis;
Published | property SelectedColor: TGLColor read FSelectedColor write SetSelectedColor;
Published | property SelectedObj: TGLBaseSceneObject read GetSelectedObj write SetSelectedObj;
Published | property SelectedObjects: TGLPickList read GetPickList write SetPickList;
Published | property SelectionRegion: TGLGizmoExSelectionRegion read FSelectionRegion write SetSelectionRegion default gsrRectangular;
Published | property SelectionRegionColor: TGLColor read FSelectionRegionColor write SetSelectionRegionColor;
Published | property ShowAxisLabel: Boolean read FShowAxisLabel write SetShowAxisLabel default True;
Published | property ShowBoundingBox: Boolean read FShowBoundingBox write SetShowBoundingBox default True;
Published | property ShowObjectInfos: Boolean read FShowObjectInfos write SetShowObjectInfos default True;
Published | property Viewer: TGLSceneViewer read FViewer write SetViewer;
Published | property Visible: Boolean read GetVisible write SetVisible;
Published | property VisibleInfoLabels: TGLGizmoExVisibleInfoLabels read FVisibleVisibleInfoLabels write SeTGLGizmoExVisibleInfoLabels;
Published | property VisibleInfoLabelsColor: TGLColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;
Published | property ZoomFactor: Single read FZoomFactor write SetZoomFactor;

Description

Fields

Private FUIBaseGizmo: TGLBaseSceneObject;

This item has no description.

Private FUIRootHelpers: TGLBaseSceneObject;

This item has no description.

Private FUIRootSelect: TGLBaseSceneObject;

This item has no description.

Private FUIRootMovement: TGLBaseSceneObject;

for None

Private FUIRootRotate: TGLBaseSceneObject;

for Move

Private FUIRootRotateAxisLabel: TGLBaseSceneObject;

for Rotate

Private FUIRootScale: TGLBaseSceneObject;

This item has no description.

Private FUIRootAxisLabel: TGLBaseSceneObject;

for Scale

Private FUIRootVisibleInfoLabels: TGLBaseSceneObject;

This item has no description.

Private FInterfaceRender: TGLDirectOpenGL;

This item has no description.

Private FInternalRender: TGLDirectOpenGL;

This item has no description.

Private FUISelectLineX: TGLGizmoExUILines;

This item has no description.

Private FUISelectLineY: TGLGizmoExUILines;

This item has no description.

Private FUISelectLineZ: TGLGizmoExUILines;

This item has no description.

Private FUIICMovementLineX: TGLGizmoExUIFrustrum;

For None (Select) IC- Invisible Control For Move

Private FUIICMovementLineY: TGLGizmoExUIFrustrum;

For None (Select) IC- Invisible Control For Move

Private FUIICMovementLineZ: TGLGizmoExUIFrustrum;

For None (Select) IC- Invisible Control For Move

Private FUIICMovementLineXY: TGLGizmoExUIFrustrum;

For None (Select) IC- Invisible Control For Move

Private FUIICMovementLineXZ: TGLGizmoExUIFrustrum;

For None (Select) IC- Invisible Control For Move

Private FUIICMovementLineYZ: TGLGizmoExUIFrustrum;

For None (Select) IC- Invisible Control For Move

Private FUIMovementArrowX: TGLGizmoExUIArrowLine;

This item has no description.

Private FUIMovementArrowY: TGLGizmoExUIArrowLine;

This item has no description.

Private FUIMovementArrowZ: TGLGizmoExUIArrowLine;

This item has no description.

Private FUIMovementLineX: TGLGizmoExUILines;

For Move

Private FUIMovementLineY: TGLGizmoExUILines;

For Move

Private FUIMovementLineZ: TGLGizmoExUILines;

For Move

Private FUIMovementLineXY: TGLGizmoExUILines;

For Move

Private FUIMovementLineXZ: TGLGizmoExUILines;

For Move

Private FUIMovementLineYZ: TGLGizmoExUILines;

For Move

Private FUIMovementPlaneXY: TGLGizmoExUIPolyGon;

For Move

Private FUIMovementPlaneXZ: TGLGizmoExUIPolyGon;

For Move

Private FUIMovementPlaneYZ: TGLGizmoExUIPolyGon;

For Move

Private FUIRotateLineX: TGLGizmoExUILines;

For Move ForRotate

Private FUIRotateLineY: TGLGizmoExUILines;

For Move ForRotate

Private FUIRotateLineZ: TGLGizmoExUILines;

For Move ForRotate

Private FUIRotateLineXY: TGLGizmoExUILines;

For Move ForRotate

Private FUIRotateLineXZ: TGLGizmoExUILines;

For Move ForRotate

Private FUIICRotateTorusX: TGLGizmoExUITorus;

This item has no description.

Private FUIICRotateTorusY: TGLGizmoExUITorus;

This item has no description.

Private FUIICRotateTorusZ: TGLGizmoExUITorus;

This item has no description.

Private FUIICRotateTorusXZ: TGLGizmoExUITorus;

This item has no description.

Private FUIRotateDiskXY: TGLGizmoExUIDisk;

For Rotate

Private FUIRotateDiskX: TGLGizmoExUIDisk;

For Rotate

Private FUIRotateDiskX2: TGLGizmoExUIDisk;

For Rotate

Private FUIRotateDiskY: TGLGizmoExUIDisk;

For Rotate

Private FUIRotateDiskY2: TGLGizmoExUIDisk;

For Rotate

Private FUIRotateDiskZ: TGLGizmoExUIDisk;

For Rotate

Private FUIRotateDiskZ2: TGLGizmoExUIDisk;

For Rotate

Private FUIRotateLineArrowX: TGLGizmoExUILines;

This item has no description.

Private FUIRotateLineArrowY: TGLGizmoExUILines;

This item has no description.

Private FUIRotateLineArrowZ: TGLGizmoExUILines;

This item has no description.

Private FUIICRotateSphereXY: TGLGizmoExUISphere;

This item has no description.

Private FUIRotateAxisLabelX: TGLGizmoExUIFlatText;

This item has no description.

Private FUIRotateAxisLabelY: TGLGizmoExUIFlatText;

This item has no description.

Private FUIRotateAxisLabelZ: TGLGizmoExUIFlatText;

This item has no description.

Private FUIScaleArrowX: TGLGizmoExUISphere;

ForScale

Private FUIScaleArrowY: TGLGizmoExUISphere;

ForScale

Private FUIScaleArrowZ: TGLGizmoExUISphere;

ForScale

Private FUIScaleLineX: TGLGizmoExUILines;

For Scale

Private FUIScaleLineY: TGLGizmoExUILines;

For Scale

Private FUIScaleLineZ: TGLGizmoExUILines;

For Scale

Private FUIScaleLineXY: TGLGizmoExUILines;

For Scale

Private FUIScaleLineYZ: TGLGizmoExUILines;

For Scale

Private FUIScaleLineXZ: TGLGizmoExUILines;

For Scale

Private FUIICScaleLineX: TGLGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineY: TGLGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineZ: TGLGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineXY: TGLGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineXZ: TGLGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineYZ: TGLGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineXYZ: TGLGizmoExUIFrustrum;

This item has no description.

Private FUIScalePlaneXY: TGLGizmoExUIPolyGon;

This item has no description.

Private FUIScalePlaneXZ: TGLGizmoExUIPolyGon;

This item has no description.

Private FUIScalePlaneYZ: TGLGizmoExUIPolyGon;

This item has no description.

Private FUIScalePlaneXYZ: TGLGizmoExUIPolyGon;

This item has no description.

Private FUIAxisLabelX: TGLGizmoExUIFlatText;

For Move

Private FUIAxisLabelY: TGLGizmoExUIFlatText;

For Move

Private FUIAxisLabelZ: TGLGizmoExUIFlatText;

For Move

Private FUIVisibleInfoLabels: TGLGizmoExUIFlatText;

This item has no description.

Private FRootGizmo: TGLBaseSceneObject;

This item has no description.

Private FRootObjects: TGLBaseSceneObject;

This item has no description.

Private FGizmoTmpRoot: TGLBaseSceneObject;

This item has no description.

Private FSelectedObj: TGLBaseSceneObject;

This item has no description.

Private FOperation: TGLGizmoExOperation;

This item has no description.

Private FOperationMode: TGLGizmoExOperationMode;

This item has no description.

Private FSelAxis: TGLGizmoExAxis;

This item has no description.

Private fInfoLabelCoordType: TInfoLabelCoordType;

This item has no description.

Private FReferenceCoordSystem: TGLGizmoExReferenceCoordinateSystem;

This item has no description.

Private FBoundingBoxColor: TGLColor;

This item has no description.

Private FSelectedColor: TGLColor;

This item has no description.

Private FVisibleInfoLabelsColor: TGLColor;

This item has no description.

Private FSelectionRegionColor: TGLColor;

This item has no description.

Private FVisibleInfoLabelsColorChanged: Boolean;

This item has no description.

Private FAutoZoom: Boolean;

This item has no description.

Private FExcludeObjects: Boolean;

This item has no description.

Private FExcludeClassname: Boolean;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FAutoZoomFactor: Single;

This item has no description.

Private FZoomFactor: Single;

This item has no description.

Private FMoveCoef: Single;

This item has no description.

Private FRotationCoef: Single;

This item has no description.

Private FViewer: TGLSceneViewer;

This item has no description.

Private FVisibleVisibleInfoLabels: TGLGizmoExVisibleInfoLabels;

This item has no description.

Private FExcludeObjectsList: TStrings;

This item has no description.

Private FExcludeClassNameList: TStrings;

This item has no description.

Private FSelectionRegion: TGLGizmoExSelectionRegion;

This item has no description.

Private FEnableMultiSelection: Boolean;

This item has no description.

Private FShowMultiSelecting: Boolean;

This item has no description.

Private FSelectionRec: TGLGizmoExSelRec;

This item has no description.

Private FCanAddObjToSelectionList: Boolean;

This item has no description.

Private FCanRemoveObjFromSelectionList: Boolean;

This item has no description.

Private FSelectedObjects: TGLPickList;

This item has no description.

Private FAntiAliasedLines: Boolean;

This item has no description.

Private FShowAxisLabel: Boolean;

This item has no description.

Private FShowObjectInfos: Boolean;

This item has no description.

Private FShowBoundingBox: Boolean;

This item has no description.

Private FCanChangeWithChildren: Boolean;

This item has no description.

Private moving: Boolean;

This item has no description.

Private mx: Integer;

This item has no description.

Private my: Integer;

This item has no description.

Private fCursorPos: TPoint;

This item has no description.

Private fLastCursorPos: TPoint;

This item has no description.

Private fChangeRate: TAffineVector;

This item has no description.

Private FEnableLoopCursorMoving: Boolean;

total rotate angle

Private lastMousePos: TGLVector;

This item has no description.

Private FOnUpdate: TNotifyEvent;

This item has no description.

Private FOnSelect: TGLGizmoExAcceptEvent;

This item has no description.

Private FOnOperationChange: TNotifyEvent;

This item has no description.

Private FOnOperationModeChange: TNotifyEvent;

This item has no description.

Private FOnSelectionLost: TNotifyEvent;

This item has no description.

Private FOnAxisSelected: TGLGizmoExAxisSelected;

This item has no description.

Private FScaleCoef: Single;

This item has no description.

Private FGizmoThickness: Single;

This item has no description.

Private FPickMode: TGLGizmoExPickMode;

This item has no description.

Private FEnableHistory: Boolean;

This item has no description.

Private FHistory: TGLGizmoExActionHistoryCollection;

This item has no description.

Private FHistoryStepsCount: Integer;

This item has no description.

Private FLabelFont: TGLCustomBitmapFont;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Redo: TGLGizmoExActionHistoryItem;

This item has no description.

Public function Undo: TGLGizmoExActionHistoryItem;

This item has no description.

Private function CheckClassNameInExcludeList(const Obj: TGLBaseSceneObject): Boolean;

This item has no description.

Private function CheckObjectInExcludeList(const Obj: TGLBaseSceneObject): Boolean;

This item has no description.

Private function GetPickList: TGLPickList;

This item has no description.

Private function GetSelectedObj: TGLBaseSceneObject;

This item has no description.

Private function GetVisible: Boolean;

This item has no description.

Private function InternalGetPickedObjects(const x1, y1, x2, y2: Integer; const guessCount: Integer = 8): TGLPickList;

This item has no description.

Private function MouseWorldPos(const X, Y: Integer): TGLVector;

This item has no description.

Public procedure Loaded; override;

This item has no description.

Public procedure LooseCursorSelection;

This item has no description.

Public procedure LooseSelection; virtual;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure RemoveSelectedObjects;

This item has no description.

Public procedure UndoAdd(const AObject: TObject);

This item has no description.

Public procedure UpdateGizmo; overload;

This item has no description.

Public procedure ViewerMouseDown(const X, Y: Integer);

This item has no description.

Public procedure ViewerMouseMove(const X, Y: Integer);

This item has no description.

Public procedure ViewerMouseUp(const X, Y: Integer);

This item has no description.

Private procedure ActivatingElements(PickList: TGLPickList);

This item has no description.

Private procedure AddObjToSelectionList(Obj: TGLBaseSceneObject);

This item has no description.

Private procedure AssignPickList(aList: TGLPickList; RemoveObj: Boolean = False);

This item has no description.

Private procedure ClearSelection;

This item has no description.

Private procedure InterfaceRender(Sender: TObject; var rci: TGLRenderContextInfo);

This item has no description.

Private procedure InternalRender(Sender: TObject; var rci: TGLRenderContextInfo);

This item has no description.

Private procedure MultiSelMouseDown(X, Y: Integer);

This item has no description.

Private procedure MultiSelMouseMove(X, Y: Integer);

This item has no description.

Private procedure MultiSelMouseUp(X, Y: Integer);

This item has no description.

Private procedure RemoveObjFromSelectionList(Obj: TGLBaseSceneObject);

This item has no description.

Private procedure SetAALines(aValue: Boolean);

This item has no description.

Private procedure SetAngleDisk(aAngle: Single);

This item has no description.

Private procedure SetAutoZoomFactor(const AValue: Single);

This item has no description.

Private procedure SetBoundingBoxColor(const AValue: TGLColor);

This item has no description.

Private procedure SetCanChangeWithChildren(AValue: Boolean);

This item has no description.

Private procedure SetEnableLoopCursorMoving(const AValue: Boolean);

This item has no description.

Private procedure SetEnableMultiSelection(const AValue: Boolean);

This item has no description.

Private procedure SetExcludeClassNameList(const AValue: TStrings);

This item has no description.

Private procedure SetExcludeObjectsList(const AValue: TStrings);

This item has no description.

Private procedure SetGizmoTmpRoot(const AValue: TGLBaseSceneObject);

This item has no description.

Private procedure SetGLGizmoExThickness(const Value: Single);

This item has no description.

Private procedure SeTGLGizmoExVisibleInfoLabels(const AValue: TGLGizmoExVisibleInfoLabels);

This item has no description.

Private procedure SetHistoryStepsCount(aValue: Integer);

This item has no description.

Private procedure SetInfoLabelCoordType(aValue: TInfoLabelCoordType);

This item has no description.

Private procedure SetLabelFont(const Value: TGLCustomBitmapFont);

This item has no description.

Private procedure SetNoZWrite(const Value: Boolean);

This item has no description.

Private procedure SetOperation(const Value: TGLGizmoExOperation);

This item has no description.

Private procedure SetOperationMode(const Value: TGLGizmoExOperationMode);

This item has no description.

Private procedure SetPickList(aValue: TGLPickList);

This item has no description.

Private procedure SetPickMode(APickMode: TGLGizmoExPickMode);

This item has no description.

Private procedure SetReferenceCoordSystem(aValue: TGLGizmoExReferenceCoordinateSystem);

This item has no description.

Private procedure SetRootGizmo(const AValue: TGLBaseSceneObject);

This item has no description.

Private procedure SetRootObjects(const AValue: TGLBaseSceneObject);

This item has no description.

Private procedure SetSelAxis(aValue: TGLGizmoExAxis);

This item has no description.

Private procedure SetSelectedColor(const AValue: TGLColor);

This item has no description.

Private procedure SetSelectedObj(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetSelectionRegion(const AValue: TGLGizmoExSelectionRegion);

This item has no description.

Private procedure SetSelectionRegionColor(const AValue: TGLColor);

This item has no description.

Private procedure SetShowAxisLabel(const AValue: Boolean);

This item has no description.

Private procedure SetShowBoundingBox(const AValue: Boolean);

This item has no description.

Private procedure SetShowObjectInfos(const AValue: Boolean);

This item has no description.

Private procedure SetViewer(const Value: TGLSceneViewer);

This item has no description.

Private procedure SetVisible(const AValue: Boolean);

This item has no description.

Private procedure SetVisibleInfoLabelsColor(const AValue: TGLColor);

This item has no description.

Private procedure SetZoomFactor(const AValue: Single);

This item has no description.

Private procedure UpdateVisibleInfoLabels;

This item has no description.

Properties

Published property AntiAliasedLines: Boolean read FAntiAliasedLines write SetAALines default True;

This item has no description.

Published property AutoZoom: Boolean read FAutoZoom write FAutoZoom default True;

This item has no description.

Published property AutoZoomFactor: Single read FAutoZoomFactor write SetAutoZoomFactor;

This item has no description.

Published property BoundingBoxColor: TGLColor read FBoundingBoxColor write SetBoundingBoxColor;

This item has no description.

Public property CanAddObjToSelectionList: Boolean read FCanAddObjToSelectionList write FCanAddObjToSelectionList;

This item has no description.

Published property CanChangeWithChildren: Boolean read FCanChangeWithChildren write SetCanChangeWithChildren;

This item has no description.

Public property CanRemoveObjFromSelectionList: Boolean read FCanRemoveObjFromSelectionList write FCanRemoveObjFromSelectionList;

This item has no description.

Public property CursorSelectingRegion: Boolean read FShowMultiSelecting;

This item has no description.

Published property EnableActionHistory: Boolean read FEnableHistory write FEnableHistory default True;

This item has no description.

Published property Enabled: Boolean read FEnabled write FEnabled default True;

Use the property OperationMode=gomNone to unactivate gizmo and make it invisible

Published property EnableLoopCursorMoving: Boolean read FEnableLoopCursorMoving write SetEnableLoopCursorMoving default True;

This item has no description.

Published property EnableMultiSelection: Boolean read FEnableMultiSelection write SetEnableMultiSelection default True;

This item has no description.

Published property ExcludeClassname: Boolean read FExcludeClassname write FExcludeClassname;

This item has no description.

Published property ExcludeClassnameList: TStrings read FExcludeClassnameList write SetExcludeClassnameList;

This item has no description.

Published property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;

This item has no description.

Published property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;

This item has no description.

Published property GizmoThickness: Single read FGizmoThickness write SeTGLGizmoExThickness;

This item has no description.

Public property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write SetGizmoTmpRoot;

This item has no description.

Published property HistoryStepsCount: Integer read FHistoryStepsCount write SetHistoryStepsCount;

This item has no description.

Published property InfoLabelCoordType: TInfoLabelCoordType read fInfoLabelCoordType write SetInfoLabelCoordType default ilcChangeRate;

This item has no description.

Published property LabelFont: TGLCustomBitmapFont read FLabelFont write SetLabelFont default nil;

This item has no description.

Published property MoveCoef: Single read FMoveCoef write FMoveCoef;

This item has no description.

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite default True;

This item has no description.

Published property OnAxisSelected: TGLGizmoExAxisSelected read FOnAxisSelected write FOnAxisSelected;

This item has no description.

Published property OnOperationChange: TNotifyEvent read FOnOperationChange write FOnOperationChange;

This item has no description.

Published property OnOperationModeChange: TNotifyEvent read FOnOperationModeChange write FOnOperationModeChange;

This item has no description.

Published property OnSelect: TGLGizmoExAcceptEvent read FOnSelect write FOnSelect;

This item has no description.

Published property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;

This item has no description.

Published property OnUpdate: TNotifyEvent read FOnUpdate write FOnUpdate;

This item has no description.

Private property Operation: TGLGizmoExOperation read FOperation write SetOperation;

This item has no description.

Published property OperationMode: TGLGizmoExOperationMode read FOperationMode write SetOperationMode default gomSelect;

This item has no description.

Published property PickMode: TGLGizmoExPickMode read FPickMode write SetPickMode default pmGetPickedObjects;

This item has no description.

Published property ReferenceCoordSystem: TGLGizmoExReferenceCoordinateSystem read FReferenceCoordSystem write SetReferenceCoordSystem default rcsView;

This item has no description.

Public property RootGizmo: TGLBaseSceneObject read FRootGizmo write SetRootGizmo;

This item has no description.

Public property RootObjects: TGLBaseSceneObject read FRootObjects write SetRootObjects;

This item has no description.

Published property RotationCoef: Single read FRotationCoef write FRotationCoef;

This item has no description.

Published property ScaleCoef: Single read FScaleCoef write FScaleCoef;

This item has no description.

Private property SelAxis: TGLGizmoExAxis read FSelAxis write SetSelAxis;

This item has no description.

Published property SelectedColor: TGLColor read FSelectedColor write SetSelectedColor;

This item has no description.

Published property SelectedObj: TGLBaseSceneObject read GetSelectedObj write SetSelectedObj;

This item has no description.

Published property SelectedObjects: TGLPickList read GetPickList write SetPickList;

This item has no description.

Published property SelectionRegion: TGLGizmoExSelectionRegion read FSelectionRegion write SetSelectionRegion default gsrRectangular;

This item has no description.

Published property SelectionRegionColor: TGLColor read FSelectionRegionColor write SetSelectionRegionColor;

This item has no description.

Published property ShowAxisLabel: Boolean read FShowAxisLabel write SetShowAxisLabel default True;

This item has no description.

Published property ShowBoundingBox: Boolean read FShowBoundingBox write SetShowBoundingBox default True;

This item has no description.

Published property ShowObjectInfos: Boolean read FShowObjectInfos write SetShowObjectInfos default True;

This item has no description.

Published property Viewer: TGLSceneViewer read FViewer write SetViewer;

——————————————————————–

Published property Visible: Boolean read GetVisible write SetVisible;

This item has no description.

Published property VisibleInfoLabels: TGLGizmoExVisibleInfoLabels read FVisibleVisibleInfoLabels write SeTGLGizmoExVisibleInfoLabels;

This item has no description.

Published property VisibleInfoLabelsColor: TGLColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;

This item has no description.

Published property ZoomFactor: Single read FZoomFactor write SetZoomFactor;


GLSysHelp v.2.5: GLS.Graph

Unit GLS.Graph

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.BaseClasses
  • GLS.Scene
  • GLS.Context
  • GLS.XOpenGL
  • GLS.Material
  • GLS.Objects
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSamplingScale |
Class TGLHeightField |
Class TGLXYZGrid |

Types

TGLHeightFieldColorMode = (...);
TGLHeightFieldGetHeight2Event = procedure(Sender: TObject; const x, y: Single; var z: Single; var Color: TGLColorVector; var TexPoint: TTexPoint) of object;
TGLHeightFieldGetHeightEvent = procedure(const x, y: Single; var z: Single; var Color: TGLColorVector; var TexPoint: TTexPoint) of object;
TGLHeightFieldOption = (...);
TGLHeightFieldOptions = set of TGLHeightFieldOption;
TGLXYZGridLinesStyle = (...);
TGLXYZGridPart = (...);
TGLXYZGridParts = set of TGLXYZGridPart;

Description

Types

TGLHeightFieldColorMode = (...);

This item has no description.

Values
  • hfcmNone
  • hfcmEmission
  • hfcmAmbient
  • hfcmDiffuse
  • hfcmAmbientAndDiffuse
TGLHeightFieldGetHeight2Event = procedure(Sender: TObject; const x, y: Single; var z: Single; var Color: TGLColorVector; var TexPoint: TTexPoint) of object;

This item has no description.

TGLHeightFieldGetHeightEvent = procedure(const x, y: Single; var z: Single; var Color: TGLColorVector; var TexPoint: TTexPoint) of object;

This item has no description.

TGLHeightFieldOption = (...);

This item has no description.

Values
  • hfoTextureCoordinates
  • hfoTwoSided
TGLHeightFieldOptions = set of TGLHeightFieldOption;

This item has no description.

TGLXYZGridLinesStyle = (...);

Rendering Style for grid lines. - glsLine : a single line is used for each grid line (from Min to Max), this provides the fastest rendering - glsSegments : line segments are used between each node of the grid, this enhances perspective and quality, at the expense of computing power.

Values
  • glsLine
  • glsSegments
TGLXYZGridPart = (...);

This item has no description.

Values
  • gpX
  • gpY
  • gpZ
TGLXYZGridParts = set of TGLXYZGridPart;


GLSysHelp v.2.5: GLS.Graph: Class TGLSamplingScale

Class TGLSamplingScale

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graph

Declaration

type TGLSamplingScale = class(TGLUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLSamplingScale

Overview

Fields

Private | FMin: Single;
Private | FMax: Single;
Private | FOrigin: Single;
Private | FStep: Single;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean;
Public | function MaxStepCount: Integer;
Public | function StepBase: Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetBaseStepMaxToVars(var Base, Step, Max: Single; SamplingEnabled: Boolean = True);

Properties

Published | property Max: Single read FMax write SetMax;
Published | property Min: Single read FMin write SetMin;
Published | property Origin: Single read FOrigin write SetOrigin;
Published | property Step: Single read FStep write SetStep;

Description

Fields

Private FMin: Single;

This item has no description.

Private FMax: Single;

This item has no description.

Private FOrigin: Single;

This item has no description.

Private FStep: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean;

This item has no description.

Public function MaxStepCount: Integer;

Maximum number of steps that can occur between Min and Max.

Public function StepBase: Single;

Returns the Base value for Step browsing. ie. the lowest value (superior to Min) that verifies Frac((Origin-StepBase)/Step)=0.0, this value may be superior to Max.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure SetBaseStepMaxToVars(var Base, Step, Max: Single; SamplingEnabled: Boolean = True);

This item has no description.

Properties

Published property Max: Single read FMax write SetMax;

This item has no description.

Published property Min: Single read FMin write SetMin;

This item has no description.

Published property Origin: Single read FOrigin write SetOrigin;

This item has no description.

Published property Step: Single read FStep write SetStep;


GLSysHelp v.2.5: GLS.Graph: Class TGLHeightField

Class TGLHeightField

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graph

Declaration

type TGLHeightField = class(TGLSceneObject)

Description

Renders a sampled height-field. HeightFields are used to materialize z=f(x, y) surfaces, you can use it to render anything from math formulas to statistics. Most important properties of an height field are its sampling scales (X & Y) that determine the extents and the resolution of the base grid. The component will then invoke it OnGetHeight event to retrieve Z values for all of the grid points (values are retrieved only once for each point). Each point may have an additionnal color and texture coordinate.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLHeightField

Overview

Fields

Private | FOnGetHeight: TGLHeightFieldGetHeightEvent;
Private | FOnGetHeight2: TGLHeightFieldGetHeight2Event;
Private | FXSamplingScale: TGLSamplingScale;
Private | FYSamplingScale: TGLSamplingScale;
Private | FOptions: TGLHeightFieldOptions;
Private | FTriangleCount: Integer;
Private | FColorMode: TGLHeightFieldColorMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property ColorMode: TGLHeightFieldColorMode read FColorMode write SetColorMode default hfcmNone;
Published | property OnGetHeight: TGLHeightFieldGetHeightEvent read FOnGetHeight write SetOnGetHeight;
Published | property OnGetHeight2: TGLHeightFieldGetHeight2Event read FOnGetHeight2 write SetOnGetHeight2;
Published | property Options: TGLHeightFieldOptions read FOptions write SetOptions default [hfoTwoSided];
Public | property TriangleCount: Integer read FTriangleCount;
Published | property XSamplingScale: TGLSamplingScale read FXSamplingScale write SetXSamplingScale;
Published | property YSamplingScale: TGLSamplingScale read FYSamplingScale write SetYSamplingScale;

Description

Fields

Private FOnGetHeight: TGLHeightFieldGetHeightEvent;

This item has no description.

Private FOnGetHeight2: TGLHeightFieldGetHeight2Event;

This item has no description.

Private FXSamplingScale: TGLSamplingScale;

This item has no description.

Private FYSamplingScale: TGLSamplingScale;

This item has no description.

Private FOptions: TGLHeightFieldOptions;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FColorMode: TGLHeightFieldColorMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property ColorMode: TGLHeightFieldColorMode read FColorMode write SetColorMode default hfcmNone;

Define if and how per vertex color is used.

Published property OnGetHeight: TGLHeightFieldGetHeightEvent read FOnGetHeight write SetOnGetHeight;

Primary event to return heights.

Published property OnGetHeight2: TGLHeightFieldGetHeight2Event read FOnGetHeight2 write SetOnGetHeight2;

Alternate this event to return heights. This events passes an extra "Sender" parameter, it will be invoked only if OnGetHeight isn't defined.

Published property Options: TGLHeightFieldOptions read FOptions write SetOptions default [hfoTwoSided];

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

This item has no description.

Published property XSamplingScale: TGLSamplingScale read FXSamplingScale write SetXSamplingScale;

This item has no description.

Published property YSamplingScale: TGLSamplingScale read FYSamplingScale write SetYSamplingScale;


GLSysHelp v.2.5: GLS.Graph: Class TGLXYZGrid

Class TGLXYZGrid

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graph

Declaration

type TGLXYZGrid = class(TGLLineBase)

Description

An XYZ Grid object. Renders an XYZ grid using lines

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLXYZGrid

Overview

Fields

Private | FXSamplingScale: TGLSamplingScale;
Private | FYSamplingScale: TGLSamplingScale;
Private | FZSamplingScale: TGLSamplingScale;
Private | FParts: TGLXYZGridParts;
Private | FLinesStyle: TGLXYZGridLinesStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property LinesSmoothing: Boolean write SetLinesSmoothing stored False;
Published | property LinesStyle: TGLXYZGridLinesStyle read FLinesStyle write SetLinesStyle default glsSegments;
Published | property Parts: TGLXYZGridParts read FParts write SetParts default [gpX, gpY];
Published | property XSamplingScale: TGLSamplingScale read FXSamplingScale write SetXSamplingScale;
Published | property YSamplingScale: TGLSamplingScale read FYSamplingScale write SetYSamplingScale;
Published | property ZSamplingScale: TGLSamplingScale read FZSamplingScale write SetZSamplingScale;

Description

Fields

Private FXSamplingScale: TGLSamplingScale;

This item has no description.

Private FYSamplingScale: TGLSamplingScale;

This item has no description.

Private FZSamplingScale: TGLSamplingScale;

This item has no description.

Private FParts: TGLXYZGridParts;

This item has no description.

Private FLinesStyle: TGLXYZGridLinesStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property LinesSmoothing: Boolean write SetLinesSmoothing stored False;

Adjusts lines smoothing (or antialiasing). Obsolete, now maps to Antialiased property

Published property LinesStyle: TGLXYZGridLinesStyle read FLinesStyle write SetLinesStyle default glsSegments;

This item has no description.

Published property Parts: TGLXYZGridParts read FParts write SetParts default [gpX, gpY];

This item has no description.

Published property XSamplingScale: TGLSamplingScale read FXSamplingScale write SetXSamplingScale;

This item has no description.

Published property YSamplingScale: TGLSamplingScale read FYSamplingScale write SetYSamplingScale;

This item has no description.

Published property ZSamplingScale: TGLSamplingScale read FZSamplingScale write SetZSamplingScale;


GLSysHelp v.2.5: GLS.Graphics

Unit GLS.Graphics

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.SyncObjs
  • System.Math
  • VCL.Graphics
  • VCL.Imaging.Pngimage
  • VCL.Consts
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.TextureFormat
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLS.State
  • GLS.ApplicationFileIO
  • GLS.PersistentClasses
  • GLS.Context
  • GLS.ImageUtils
  • GLS.Color
  • GLScene.Utils
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TGLPixel24 |
Packed Record TGLPixel32 |
Record TGLImageLevelDesc |
Class TGLBaseImage |
Class TGLImage |
Class TGLRasterFileFormat |
Class TGLRasterFileFormatsList |
Class EInvalidRasterFile |

Functions and Procedures

procedure Div2(var Value: Integer);
procedure BGR24ToRGB24(src, dest: Pointer; pixelCount: Integer);
procedure BGR24ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure RGB24ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure BGRA32ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure GammaCorrectRGBArray(base: Pointer; pixelCount: Integer; gamma: Single);
procedure BrightenRGBArray(base: Pointer; pixelCount: Integer; factor: Single);
function GetRasterFileFormats: TGLRasterFileFormatsList;
function RasterFileFormatExtensionByIndex(index: Integer): string;
procedure RegisterRasterFormat(const AExtension, ADescription: string; AClass: TGLBaseImageClass);
procedure UnregisterRasterFormat(AClass: TGLBaseImageClass);
function GetImageLodNumber(w, h, d: Integer; IsVolume: Boolean): Integer;
function GraphicClassForExtension(const anExtension: string): TGraphicClass;
procedure HackTPictureRegisteredFormats(destList: TStrings);

Types

PGLPixel24 = ˆTGLPixel24;
PGLPixel32 = ˆTGLPixel32;
PGLPixel32Array = ˆTGLPixel32Array;
TGLBaseImageClass = class of TGLBaseImage;
TGLBitmap32 = TGLImage;
TGLImageLODRange = 0..15;
TGLImagePiramid = array[TGLImageLODRange] of TGLImageLevelDesc;
TGLLODStreamingState = (...);
TGLPixel32Array = array[0..MaxInt shr 3] of TGLPixel32;

Variables

vVerticalFlipDDS: Boolean = True;

Description

Functions and Procedures

procedure Div2(var Value: Integer);

This item has no description.

procedure BGR24ToRGB24(src, dest: Pointer; pixelCount: Integer);

This item has no description.

procedure BGR24ToRGBA32(src, dest: Pointer; pixelCount: Integer);

This item has no description.

procedure RGB24ToRGBA32(src, dest: Pointer; pixelCount: Integer);

This item has no description.

procedure BGRA32ToRGBA32(src, dest: Pointer; pixelCount: Integer);

This item has no description.

procedure GammaCorrectRGBArray(base: Pointer; pixelCount: Integer; gamma: Single);

This item has no description.

procedure BrightenRGBArray(base: Pointer; pixelCount: Integer; factor: Single);

This item has no description.

function GetRasterFileFormats: TGLRasterFileFormatsList;

Read access to the list of registered vector file formats

function RasterFileFormatExtensionByIndex(index: Integer): string;

Returns an extension by its index in the internal image files dialogs filter. Use InternalImageFileFormatsFilter to obtain the filter.

procedure RegisterRasterFormat(const AExtension, ADescription: string; AClass: TGLBaseImageClass);

This item has no description.

procedure UnregisterRasterFormat(AClass: TGLBaseImageClass);

This item has no description.

function GetImageLodNumber(w, h, d: Integer; IsVolume: Boolean): Integer;

Return an optimal number of texture pyramid

function GraphicClassForExtension(const anExtension: string): TGraphicClass;

Returns the TGraphicClass associated to the extension, if any. Accepts anExtension with or without the '.'

procedure HackTPictureRegisteredFormats(destList: TStrings);

Adds to the passed TStrings the list of registered formats. Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').

Types

PGLPixel24 = ˆTGLPixel24;

This item has no description.

PGLPixel32 = ˆTGLPixel32;

This item has no description.

PGLPixel32Array = ˆTGLPixel32Array;

This item has no description.

TGLBaseImageClass = class of TGLBaseImage;

This item has no description.

TGLBitmap32 = TGLImage;

This item has no description.

TGLImageLODRange = 0..15;

This item has no description.

TGLImagePiramid = array[TGLImageLODRange] of TGLImageLevelDesc;

This item has no description.

TGLLODStreamingState = (...);

This item has no description.

Values
  • ssKeeping
  • ssLoading
  • ssLoaded
  • ssTransfered
TGLPixel32Array = array[0..MaxInt shr 3] of TGLPixel32;

This item has no description.

Variables

vVerticalFlipDDS: Boolean = True;


GLSysHelp v.2.5: GLS.Graphics: Packed Record TGLPixel24

Packed Record TGLPixel24

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graphics

Declaration

type TGLPixel24 = packed record

Description

This item has no description.

Overview

Fields

Public | r: Byte;
Public | g: Byte;
Public | b: Byte;

Description

Fields

Public r: Byte;

This item has no description.

Public g: Byte;

This item has no description.

Public b: Byte;


GLSysHelp v.2.5: GLS.Graphics: Packed Record TGLPixel32

Packed Record TGLPixel32

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graphics

Declaration

type TGLPixel32 = packed record

Description

This item has no description.

Overview

Fields

Public | r: Byte;
Public | g: Byte;
Public | b: Byte;
Public | a: Byte;

Description

Fields

Public r: Byte;

This item has no description.

Public g: Byte;

This item has no description.

Public b: Byte;

This item has no description.

Public a: Byte;


GLSysHelp v.2.5: GLS.Graphics: Record TGLImageLevelDesc

Record TGLImageLevelDesc

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graphics

Declaration

type TGLImageLevelDesc = record

Description

This item has no description.

Overview

Fields

Public | Width: Integer;
Public | Height: Integer;
Public | Depth: Integer;
Public | PBO: TGLUnpackPBOHandle;
Public | MapAddress: Pointer;
Public | Offset: LongWord;
Public | StreamOffset: LongWord;
Public | Size: LongWord;
Public | State: TGLLODStreamingState;

Description

Fields

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Public Depth: Integer;

This item has no description.

Public PBO: TGLUnpackPBOHandle;

This item has no description.

Public MapAddress: Pointer;

This item has no description.

Public Offset: LongWord;

This item has no description.

Public StreamOffset: LongWord;

This item has no description.

Public Size: LongWord;

This item has no description.

Public State: TGLLODStreamingState;


GLSysHelp v.2.5: GLS.Graphics: Class TGLBaseImage

Class TGLBaseImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graphics

Declaration

type TGLBaseImage = class(TGLDataFile)

Description

This item has no description. Showing description inherited from TGLDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage

Overview

Fields

Private | FSourceStream: TStream;
Private | FStreamLevel: TGLImageLODRange;
Private | FFinishEvent: TFinishTaskEvent;

Methods

Public | constructor Create; reintroduce; virtual;
Public | destructor Destroy; override;
Public | function AssignFromTexture( AHandle: TGLTextureHandle; const CastToFormat: Boolean; const intFormat: TGLInternalFormat = tfRGBA8; const colorFormat: Cardinal = 0; const dataType: Cardinal = 0): Boolean; virtual;
Public | function ConvertCrossToCubeMap: Boolean;
Public | function ConvertToVolume(const col, row: Integer; const MakeArray: Boolean): Boolean;
Public | function DataSize: Cardinal;
Public | function GetTextureTarget: TGLTextureTarget;
Public | function IsCompressed: Boolean;
Public | function IsEmpty: Boolean;
Public | function IsVolume: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GenerateMipmap(AFilter: TImageFilterFunction); virtual;
Public | procedure Narrow;
Public | procedure RegisterAsOpenGLTexture( AHandle: TGLTextureHandle; aMipmapGen: Boolean; aTexFormat: Cardinal; out texWidth: integer; out texHeight: integer; out texDepth: integer); virtual;
Public | procedure SetErrorImage;
Public | procedure UnMipmap; virtual;
Public | procedure UpdateLevelsInfo;

Properties

Public | property ColorFormat: Cardinal read fColorFormat;
Public | property CubeMap: Boolean read fCubeMap;
Public | property Data: PGLPixel32Array read GetData;
Public | property DataType: Cardinal read fDataType;
Public | property ElementSize: Integer read fElementSize;
Public | property InternalFormat: TGLInternalFormat read FInternalFormat;
Public | property LevelCount: TGLImageLODRange read fLevelCount;
Public | property LevelDepth[ALOD: TGLImageLODRange]: Integer read GetLevelDepth;
Public | property LevelHeight[ALOD: TGLImageLODRange]: Integer read GetLevelHeight;
Public | property LevelOffset[ALOD: TGLImageLODRange]: Integer read GetLevelOffset;
Public | property LevelPixelBuffer[ALOD: TGLImageLODRange]: TGLUnpackPBOHandle read GetLevelPBO;
Public | property LevelSizeInByte[ALOD: TGLImageLODRange]: Integer read GetLevelSizeInByte;
Public | property LevelStreamingState[ALOD: TGLImageLODRange]: TGLLODStreamingState read GetLevelStreamingState write SetLevelStreamingState;
Public | property LevelWidth[ALOD: TGLImageLODRange]: Integer read GetLevelWidth;
Public | property TextureArray: Boolean read fTextureArray;

Description

Fields

Private FSourceStream: TStream;

This item has no description.

Private FStreamLevel: TGLImageLODRange;

This item has no description.

Private FFinishEvent: TFinishTaskEvent;

This item has no description.

Methods

Public constructor Create; reintroduce; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AssignFromTexture( AHandle: TGLTextureHandle; const CastToFormat: Boolean; const intFormat: TGLInternalFormat = tfRGBA8; const colorFormat: Cardinal = 0; const dataType: Cardinal = 0): Boolean; virtual;

Assigns from any Texture.

Public function ConvertCrossToCubeMap: Boolean;

Convert vertical cross format of non compressed, non mipmaped image to six face of cube map

Public function ConvertToVolume(const col, row: Integer; const MakeArray: Boolean): Boolean;

Convert flat image to volume by dividing it into slice.

Public function DataSize: Cardinal;

Return size in byte of all image

Public function GetTextureTarget: TGLTextureTarget;

This item has no description.

Public function IsCompressed: Boolean;

This item has no description.

Public function IsEmpty: Boolean;

True if the bitmap is empty (ie. width or height is zero).

Public function IsVolume: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure GenerateMipmap(AFilter: TImageFilterFunction); virtual;

Generate LOD pyramid

Public procedure Narrow;

Narrow image data to simple RGBA8 ubyte

Public procedure RegisterAsOpenGLTexture( AHandle: TGLTextureHandle; aMipmapGen: Boolean; aTexFormat: Cardinal; out texWidth: integer; out texHeight: integer; out texDepth: integer); virtual;

Registers the bitmap's content as an OpenGL texture map.

Public procedure SetErrorImage;

Set image of error.

Public procedure UnMipmap; virtual;

Leave top level and remove other

Public procedure UpdateLevelsInfo;

Recalculate levels information based on first level.

Properties

Public property ColorFormat: Cardinal read fColorFormat;

This item has no description.

Public property CubeMap: Boolean read fCubeMap;

This item has no description.

Public property Data: PGLPixel32Array read GetData;

Direct Access to image data

Public property DataType: Cardinal read fDataType;

This item has no description.

Public property ElementSize: Integer read fElementSize;

This item has no description.

Public property InternalFormat: TGLInternalFormat read FInternalFormat;

This item has no description.

Public property LevelCount: TGLImageLODRange read fLevelCount;

Number of levels.

Public property LevelDepth[ALOD: TGLImageLODRange]: Integer read GetLevelDepth;

This item has no description.

Public property LevelHeight[ALOD: TGLImageLODRange]: Integer read GetLevelHeight;

This item has no description.

Public property LevelOffset[ALOD: TGLImageLODRange]: Integer read GetLevelOffset;

LOD offset in byte

Public property LevelPixelBuffer[ALOD: TGLImageLODRange]: TGLUnpackPBOHandle read GetLevelPBO;

This item has no description.

Public property LevelSizeInByte[ALOD: TGLImageLODRange]: Integer read GetLevelSizeInByte;

LOD size in byte

Public property LevelStreamingState[ALOD: TGLImageLODRange]: TGLLODStreamingState read GetLevelStreamingState write SetLevelStreamingState;

This item has no description.

Public property LevelWidth[ALOD: TGLImageLODRange]: Integer read GetLevelWidth;

This item has no description.

Public property TextureArray: Boolean read fTextureArray;


GLSysHelp v.2.5: GLS.Graphics: Class TGLImage

Class TGLImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graphics

Declaration

type TGLImage = class(TGLBaseImage)

Description

Contains and manipulates a 32 bits (24+8) bitmap. This is the base class for preparing and manipulating textures in GLS.Scene, this function does not rely on a windows handle and should be used for in-memory manipulations only. 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL. The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseImage
  • TGLImage

Overview

Fields

Private | FVerticalReverseOnAssignFromBitmap: Boolean;
Private | FBlank: Boolean;
Private | fOldColorFormat: Cardinal;
Private | fOldDataType: Cardinal;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Create32BitsBitmap: TBitmap;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure AssignFromBitmap24WithoutRGBSwap(aBitmap: TBitmap);
Public | procedure AssignFromTexture2D(textureHandle: TGLTextureHandle); overload;
Public | procedure AssignFromTexture2D(textureHandle: Cardinal); overload;
Public | procedure AssignToBitmap(aBitmap: TBitmap);
Public | procedure BrightnessCorrection(const factor: Single);
Public | procedure DownSampleByFactor2;
Public | procedure DrawPixels(const x, y: Single);
Public | procedure GammaCorrection(const gamma: Single);
Public | procedure GenerateMipmap(AFilter: TImageFilterFunction); override;
Public | procedure GrayScaleToNormalMap(const scale: Single; wrapX: Boolean = True; wrapY: Boolean = True);
Public | procedure InvertAlpha;
Public | procedure NormalizeNormalMap;
Public | procedure ReadPixels(const area: TRect);
Public | procedure SetAlphaFromIntensity;
Public | procedure SetAlphaToFloatValue(const aValue: Single);
Public | procedure SetAlphaToValue(const aValue: Byte);
Public | procedure SetAlphaTransparentForColor(const aColor: TGLPixel32); overload;
Public | procedure SetAlphaTransparentForColor(const aColor: TColor); overload;
Public | procedure SetAlphaTransparentForColor(const aColor: TGLPixel24); overload;
Public | procedure SetColorFormatDataType(const AColorFormat, ADataType: Cardinal);
Public | procedure SqrtAlpha;
Public | procedure UnMipmap; override;
Private | procedure DataConvertTask;

Properties

Public | property Blank: boolean read FBlank write SetBlank;
Public | property ColorFormat: Cardinal read fColorFormat;
Public | property CubeMap: Boolean read fCubeMap write SetCubeMap;
Public | property DataType: Cardinal read fDataType;
Public | property Depth: Integer read GetDepth write SetDepth;
Public | property ElementSize: Integer read fElementSize;
Public | property Height: Integer read GetHeight write SetHeight;
Public | property InternalFormat: TGLInternalFormat read FInternalFormat write FInternalFormat;
Public | property ScanLine[index: Integer]: PGLPixel32Array read GetScanLine;
Public | property TextureArray: Boolean read fTextureArray write SetArray;
Public | property VerticalReverseOnAssignFromBitmap: Boolean read FVerticalReverseOnAssignFromBitmap write FVerticalReverseOnAssignFromBitmap;
Public | property Width: Integer read GetWidth write SetWidth;

Description

Fields

Private FVerticalReverseOnAssignFromBitmap: Boolean;

This item has no description.

Private FBlank: Boolean;

This item has no description.

Private fOldColorFormat: Cardinal;

This item has no description.

Private fOldDataType: Cardinal;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Create32BitsBitmap: TBitmap;

Create a 32 bits TBitmap from self content.

Public procedure Assign(Source: TPersistent); override;

Accepts TGLImage and TGraphic subclasses.

Public procedure AssignFromBitmap24WithoutRGBSwap(aBitmap: TBitmap);

Assigns from a 24 bits bitmap without swapping RGB. This is faster than a regular assignment, but R and B channels will be reversed (from what you would view in a TImage). Suitable if you do your own drawing and reverse RGB on the drawing side. If you're after speed, don't forget to set the bitmap's dimensions to a power of two!

Public procedure AssignFromTexture2D(textureHandle: TGLTextureHandle); overload;

Assigns from a Texture handle. If the handle is invalid, the bitmap32 will be empty.

Public procedure AssignFromTexture2D(textureHandle: Cardinal); overload;

Assigns from a 2D Texture. The context which holds the texture must be active and the texture handle valid.

Public procedure AssignToBitmap(aBitmap: TBitmap);

Converts a TImage back into a TBitmap

Public procedure BrightnessCorrection(const factor: Single);

Apply a brightness (scaled saturating) correction to the RGB components.

Public procedure DownSampleByFactor2;

Downsample the bitmap by a factor of 2 in both dimensions. If one of the dimensions is 1 or less, does nothing.

Public procedure DrawPixels(const x, y: Single);

Draws the whole bitmap at given position in the current OpenGL context. This function must be called with a rendering context active. Blending and Alpha channel functions are not altered by this function and must be adjusted separately.

Public procedure GammaCorrection(const gamma: Single);

Apply a gamma correction to the RGB components.

Public procedure GenerateMipmap(AFilter: TImageFilterFunction); override;

Generate level of detail.

Public procedure GrayScaleToNormalMap(const scale: Single; wrapX: Boolean = True; wrapY: Boolean = True);

Converts a grayscale 'elevation' bitmap to normal map. Actually, only the Green component in the original bitmap is used.

Public procedure InvertAlpha;

Inverts the AlphaChannel component. What was transparent becomes opaque and vice-versa.

Public procedure NormalizeNormalMap;

Assumes the bitmap content is a normal map and normalizes all pixels.

Public procedure ReadPixels(const area: TRect);

Reads the given area from the current active OpenGL rendering context. The best spot for reading pixels is within a SceneViewer's PostRender event : the scene has been fully rendered and the OpenGL context is still active.

Public procedure SetAlphaFromIntensity;

Set Alpha channel values to the pixel intensity. The intensity is calculated as the mean of RGB components.

Public procedure SetAlphaToFloatValue(const aValue: Single);

Set Alpha channel values to given float [0..1] value.

Public procedure SetAlphaToValue(const aValue: Byte);

Set Alpha channel values to given byte value.

Public procedure SetAlphaTransparentForColor(const aColor: TGLPixel32); overload;

This item has no description.

Public procedure SetAlphaTransparentForColor(const aColor: TColor); overload;

Set Alpha channel to 0 for pixels of given color, 255 for others). This makes pixels of given color totally transparent while the others are completely opaque.

Public procedure SetAlphaTransparentForColor(const aColor: TGLPixel24); overload;

This item has no description.

Public procedure SetColorFormatDataType(const AColorFormat, ADataType: Cardinal);

Recast image OpenGL data type and color format.

Public procedure SqrtAlpha;

AlphaChannel components are replaced by their sqrt.

Public procedure UnMipmap; override;

Clear all levels except first.

Private procedure DataConvertTask;

This item has no description.

Properties

Public property Blank: boolean read FBlank write SetBlank;

Set Blank to true if you actually don't need to allocate data in main menory. Useful for textures that are generated by the GPU on the fly.

Public property ColorFormat: Cardinal read fColorFormat;

OpenGL color format

Public property CubeMap: Boolean read fCubeMap write SetCubeMap;

This item has no description.

Public property DataType: Cardinal read fDataType;

OpenGL data type

Public property Depth: Integer read GetDepth write SetDepth;

Depth of the bitmap.

Public property ElementSize: Integer read fElementSize;

Size in bytes of pixel or block

Public property Height: Integer read GetHeight write SetHeight;

Height of the bitmap.

Public property InternalFormat: TGLInternalFormat read FInternalFormat write FInternalFormat;

Recommended texture internal format

Public property ScanLine[index: Integer]: PGLPixel32Array read GetScanLine;

Access to a specific Bitmap ScanLine. index should be in the [0; Height[ range. Warning : this function is NOT protected against invalid indexes, and invoking it is invalid if the bitmap is Empty.

Public property TextureArray: Boolean read fTextureArray write SetArray;

This item has no description.

Public property VerticalReverseOnAssignFromBitmap: Boolean read FVerticalReverseOnAssignFromBitmap write FVerticalReverseOnAssignFromBitmap;

This item has no description.

Public property Width: Integer read GetWidth write SetWidth;

Width of the bitmap.


GLSysHelp v.2.5: GLS.Graphics: Class TGLRasterFileFormat

Class TGLRasterFileFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graphics

Declaration

type TGLRasterFileFormat = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLRasterFileFormat

Overview

Fields

Public | BaseImageClass: TGLBaseImageClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: Integer;

Description

Fields

Public BaseImageClass: TGLBaseImageClass;

This item has no description.

Public Extension: string;

This item has no description.

Public Description: string;

This item has no description.

Public DescResID: Integer;


GLSysHelp v.2.5: GLS.Graphics: Class TGLRasterFileFormatsList

Class TGLRasterFileFormatsList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graphics

Declaration

type TGLRasterFileFormatsList = class(TGLPersistentObjectList)

Description

Stores registered raster file formats.

Hierarchy

  • TGLPersistentObjectList
  • TGLRasterFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(ext: string): TGLBaseImageClass;
Public | function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;
Public | function FindFromFileName(const fileName: string): TGLBaseImageClass;
Public | function FindFromStream(const AStream: TStream): TGLBaseImageClass;
Public | procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TGLBaseImageClass);
Public | procedure BuildFilterStrings(imageFileClass: TGLBaseImageClass; var descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);
Public | procedure Remove(AClass: TGLBaseImageClass);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function FindExt(ext: string): TGLBaseImageClass;

This item has no description.

Public function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;

This item has no description.

Public function FindFromFileName(const fileName: string): TGLBaseImageClass;

This item has no description.

Public function FindFromStream(const AStream: TStream): TGLBaseImageClass;

This item has no description.

Public procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TGLBaseImageClass);

This item has no description.

Public procedure BuildFilterStrings(imageFileClass: TGLBaseImageClass; var descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);

This item has no description.

Public procedure Remove(AClass: TGLBaseImageClass);


GLSysHelp v.2.5: GLS.Graphics: Class EInvalidRasterFile

Class EInvalidRasterFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Graphics

Declaration

type EInvalidRasterFile = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EInvalidRasterFile


GLSysHelp v.2.5: GLS.Gui

Unit GLS.Gui

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.BitmapFont
  • GLS.Material
  • GLS.Context
  • GLS.PersistentClasses
  • GLS.Coordinates
  • GLS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseGuiObject |
Record TGUIRect |
Class TGLGuiElement |
Class TGLGuiElementList |
Class TGLGuiComponent |
Class TGLGuiComponentList |
Class TGLGuiLayout |

Functions and Procedures

function IsInRect(const R: TGUIRect; X, Y: Single): Boolean; inline;

Types

TGLGuiComponentName = string;
TGLGuiElementName = string;
TGUIAlignments = (...);
TGUIDrawResult = array [TGUIAlignments] of TGUIRect;

Constants

GuiNullRect: TGUIRect = (X1: 0.0; Y1: 0.0; X2: 0.0; Y2: 0.0; XTiles: 0.0; YTiles: 0.0);

Description

Functions and Procedures

function IsInRect(const R: TGUIRect; X, Y: Single): Boolean; inline;

This item has no description.

Types

TGLGuiComponentName = string;

This item has no description.

TGLGuiElementName = string;

This item has no description.

TGUIAlignments = (...);

This item has no description.

Values
  • GLAlTopLeft
  • GLAlTop
  • GLAlTopRight
  • GLAlLeft
  • GLAlCenter
  • GLAlRight
  • GLAlBottomLeft
  • GLAlBottom
  • GLAlBottomRight
  • GLAlBorder
TGUIDrawResult = array [TGUIAlignments] of TGUIRect;

This item has no description.

Constants

GuiNullRect: TGUIRect = (X1: 0.0; Y1: 0.0; X2: 0.0; Y2: 0.0; XTiles: 0.0; YTiles: 0.0);


GLSysHelp v.2.5: GLS.Gui: Class TGLBaseGuiObject

Class TGLBaseGuiObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gui

Declaration

type TGLBaseGuiObject = class(TGLBaseSceneObject)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject

Overview

Fields

Private | FRecursiveVisible: Boolean;
Private | FWidth: Single;
Private | FHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure AddChild(AChild: TGLBaseSceneObject); override;
Public | procedure Insert(aIndex: Integer; AChild: TGLBaseSceneObject); override;

Properties

Public | property Height: Single read FHeight write SetHeight;
Public | property Left: TGLFloat read GetLeft write SetLeft;
Public | property RecursiveVisible: Boolean read FRecursiveVisible;
Public | property Top: TGLFloat read GetTop write SetTop;
Public | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FRecursiveVisible: Boolean;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FHeight: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure AddChild(AChild: TGLBaseSceneObject); override;

This item has no description.

Public procedure Insert(aIndex: Integer; AChild: TGLBaseSceneObject); override;

This item has no description.

Properties

Public property Height: Single read FHeight write SetHeight;

GuiComponent Height in 3D world units.

Public property Left: TGLFloat read GetLeft write SetLeft;

GuiComponent Left in 3D world units.

Public property RecursiveVisible: Boolean read FRecursiveVisible;

This item has no description.

Public property Top: TGLFloat read GetTop write SetTop;

GuiComponent Top in 3D world units.

Public property Width: Single read FWidth write SetWidth;

GuiComponent Width in 3D world units.


GLSysHelp v.2.5: GLS.Gui: Record TGUIRect

Record TGUIRect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gui

Declaration

type TGUIRect = record

Description

This item has no description.

Overview

Fields

Public | X1: TGLFloat;
Public | Y1: TGLFloat;
Public | X2: TGLFloat;
Public | Y2: TGLFloat;
Public | XTiles: TGLFloat;
Public | YTiles: TGLFloat;

Description

Fields

Public X1: TGLFloat;

This item has no description.

Public Y1: TGLFloat;

This item has no description.

Public X2: TGLFloat;

This item has no description.

Public Y2: TGLFloat;

This item has no description.

Public XTiles: TGLFloat;

This item has no description.

Public YTiles: TGLFloat;


GLSysHelp v.2.5: GLS.Gui: Class TGLGuiElement

Class TGLGuiElement

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gui

Declaration

type TGLGuiElement = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLGuiElement

Overview

Fields

Private | FTopLeft: TGLCoordinates2;
Private | FBottomRight: TGLCoordinates2;
Private | FScale: TGLCoordinates2;
Private | FAlign: TGUIAlignments;
Private | FName: TGLGuiElementName;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure AssignTo(Dest: TPersistent); override;

Properties

Published | property Align: TGUIAlignments read FAlign write FAlign;
Published | property BottomRight: TGLCoordinates2 read FBottomRight write FBottomRight;
Published | property Name: TGLGuiElementName read FName write SetName;
Published | property Scale: TGLCoordinates2 read FScale write FScale;
Published | property TopLeft: TGLCoordinates2 read FTopLeft write FTopLeft;

Description

Fields

Private FTopLeft: TGLCoordinates2;

This item has no description.

Private FBottomRight: TGLCoordinates2;

This item has no description.

Private FScale: TGLCoordinates2;

This item has no description.

Private FAlign: TGUIAlignments;

This item has no description.

Private FName: TGLGuiElementName;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AssignTo(Dest: TPersistent); override;

This item has no description.

Properties

Published property Align: TGUIAlignments read FAlign write FAlign;

This item has no description.

Published property BottomRight: TGLCoordinates2 read FBottomRight write FBottomRight;

This item has no description.

Published property Name: TGLGuiElementName read FName write SetName;

This item has no description.

Published property Scale: TGLCoordinates2 read FScale write FScale;

This item has no description.

Published property TopLeft: TGLCoordinates2 read FTopLeft write FTopLeft;


GLSysHelp v.2.5: GLS.Gui: Class TGLGuiElementList

Class TGLGuiElementList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gui

Declaration

type TGLGuiElementList = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLGuiElementList

Overview

Fields

Private FGuiComponent: TGLGuiComponent;

Methods

Public | constructor Create(AOwner: TGLGuiComponent);
Public | function GetOwner: TPersistent; override;
Public | function IndexOf(const Item: TGLGuiElement): Integer;
Public | procedure AssignTo(Dest: TPersistent); override;

Properties

Public property Items[index: Integer]: TGLGuiElement read GetItems write SetItems;

Description

Fields

Private FGuiComponent: TGLGuiComponent;

This item has no description.

Methods

Public constructor Create(AOwner: TGLGuiComponent);

This item has no description.

Public function GetOwner: TPersistent; override;

This item has no description.

Public function IndexOf(const Item: TGLGuiElement): Integer;

This item has no description.

Public procedure AssignTo(Dest: TPersistent); override;

This item has no description.

Properties

Public property Items[index: Integer]: TGLGuiElement read GetItems write SetItems;


GLSysHelp v.2.5: GLS.Gui: Class TGLGuiComponent

Class TGLGuiComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gui

Declaration

type TGLGuiComponent = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLGuiComponent

Overview

Fields

Private | FElements: TGLGuiElementList;
Private | FName: TGLGuiComponentName;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function GetOwnerList: TGLGuiComponentList;
Public | procedure AssignTo(Dest: TPersistent); override;
Public | procedure RenderToArea(X1, Y1, X2, Y2: TGLFloat; var Res: TGUIDrawResult; Refresh: Boolean = True; Scale: TGLFloat = 1);

Properties

Published | property Elements: TGLGuiElementList read FElements write FElements;
Published | property Name: TGLGuiComponentName read FName write SetName;
Public | property Owner: TGLGuiComponentList read GetOwnerList;

Description

Fields

Private FElements: TGLGuiElementList;

This item has no description.

Private FName: TGLGuiComponentName;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetOwnerList: TGLGuiComponentList;

This item has no description.

Public procedure AssignTo(Dest: TPersistent); override;

This item has no description.

Public procedure RenderToArea(X1, Y1, X2, Y2: TGLFloat; var Res: TGUIDrawResult; Refresh: Boolean = True; Scale: TGLFloat = 1);

This item has no description.

Properties

Published property Elements: TGLGuiElementList read FElements write FElements;

This item has no description.

Published property Name: TGLGuiComponentName read FName write SetName;

This item has no description.

Public property Owner: TGLGuiComponentList read GetOwnerList;


GLSysHelp v.2.5: GLS.Gui: Class TGLGuiComponentList

Class TGLGuiComponentList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gui

Declaration

type TGLGuiComponentList = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLGuiComponentList

Overview

Fields

Private FLayout: TGLGuiLayout;

Methods

Public | constructor Create(AOwner: TGLGuiLayout);
Public | function FindItem(name: TGLGuiComponentName): TGLGuiComponent;
Public | function GetOwner: TPersistent; override;

Properties

Public property Items[index: Integer]: TGLGuiComponent read GetItems write SetItems;

Description

Fields

Private FLayout: TGLGuiLayout;

This item has no description.

Methods

Public constructor Create(AOwner: TGLGuiLayout);

This item has no description.

Public function FindItem(name: TGLGuiComponentName): TGLGuiComponent;

This item has no description.

Public function GetOwner: TPersistent; override;

This item has no description.

Properties

Public property Items[index: Integer]: TGLGuiComponent read GetItems write SetItems;


GLSysHelp v.2.5: GLS.Gui: Class TGLGuiLayout

Class TGLGuiLayout

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Gui

Declaration

type TGLGuiLayout = class(TGLUpdateAbleComponent)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLGuiLayout

Overview

Fields

Private | FBitmapFont: TGLCustomBitmapFont;
Private | FMaterial: TGLMaterial;
Private | FGuiComponents: TGLGuiComponentList;
Private | FFileName: string;
Private | FGuiComponentList: TList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure AddGuiComponent(Component: TGLUpdateAbleComponent);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure LoadFromFile(FN: string);
Public | procedure LoadFromStream(Stream: TStream);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure RemoveGuiComponent(Component: TGLUpdateAbleComponent);
Public | procedure SaveToFile(FN: string);
Public | procedure SaveToStream(Stream: TStream);

Properties

Published | property BitmapFont: TGLCustomBitmapFont read FBitmapFont write FBitmapFont;
Published | property FileName: string read FFileName write SetFileName;
Published | property GuiComponents: TGLGuiComponentList read FGuiComponents write FGuiComponents;
Published | property Material: TGLMaterial read FMaterial write FMaterial;

Description

Fields

Private FBitmapFont: TGLCustomBitmapFont;

This item has no description.

Private FMaterial: TGLMaterial;

This item has no description.

Private FGuiComponents: TGLGuiComponentList;

This item has no description.

Private FFileName: string;

This item has no description.

Private FGuiComponentList: TList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddGuiComponent(Component: TGLUpdateAbleComponent);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure LoadFromFile(FN: string);

This item has no description.

Public procedure LoadFromStream(Stream: TStream);

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure RemoveGuiComponent(Component: TGLUpdateAbleComponent);

This item has no description.

Public procedure SaveToFile(FN: string);

This item has no description.

Public procedure SaveToStream(Stream: TStream);

This item has no description.

Properties

Published property BitmapFont: TGLCustomBitmapFont read FBitmapFont write FBitmapFont;

This item has no description.

Published property FileName: string read FFileName write SetFileName;

This item has no description.

Published property GuiComponents: TGLGuiComponentList read FGuiComponents write FGuiComponents;

This item has no description.

Published property Material: TGLMaterial read FMaterial write FMaterial;


GLSysHelp v.2.5: GLS.HeightData

Unit GLS.HeightData

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.Types
  • Vcl.Graphics
  • GLScene.VectorGeometry
  • GLS.ApplicationFileIO
  • GLScene.Utils
  • GLS.Material
  • GLS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLHeightDataSource |
Record TGLHeightDataUser |
Class TGLHeightData |
Class TGLHeightDataThread |
Class TGLBitmapHDS |
Class TGLCustomHDS |
Class TGLTerrainBaseHDS |
Class TGLHeightDataSourceFilter |

Types

PByteRaster = ˆTByteRaster;
PSingleRaster = ˆTSingleRaster;
PSmallIntArray = ˆTSmallintArray;
PSmallIntRaster = ˆTSmallIntRaster;
TByteArray = array [0 .. MaxInt div (2 * SizeOf(Byte))] of Byte;
TByteRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PByteArray;
TGLHeightDataClass = class of TGLHeightData;
TGLHeightDataState = (...);
TGLHeightDataType = (...);
THDTextureCoordinatesMode = (...);
TMarkDirtyEvent = procedure(const Area: TRect) of object;
TOnHeightDataDirtyEvent = procedure(sender: TGLHeightData) of object;
TSingleRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PSingleArray;
TSmallintArray = array [0 .. MaxInt div (2 * SizeOf(SmallInt))] of SmallInt;
TSmallIntRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PSmallIntArray;
TSourceDataFetchedEvent = procedure(sender: TGLHeightDataSourceFilter; HeightData: TGLHeightData) of object;
TStartPreparingDataEvent = procedure(HeightData: TGLHeightData) of object;

Description

Types

PByteRaster = ˆTByteRaster;

This item has no description.

PSingleRaster = ˆTSingleRaster;

This item has no description.

PSmallIntArray = ˆTSmallintArray;

This item has no description.

PSmallIntRaster = ˆTSmallIntRaster;

This item has no description.

TByteArray = array [0 .. MaxInt div (2 * SizeOf(Byte))] of Byte;

to CreateMonochromeBitmap

TByteRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PByteArray;

This item has no description.

TGLHeightDataClass = class of TGLHeightData;

This item has no description.

TGLHeightDataState = (...);

Possible states for a TGLHeightData. hdsQueued : the data has been queued for loading hdsPreparing : the data is currently loading or being prepared for use hdsReady : the data is fully loaded and ready for use hdsNone : the height data does not exist for this tile

Values
  • hdsQueued
  • hdsPreparing
  • hdsReady
  • hdsNone
TGLHeightDataType = (...);

Determines the type of data stored in a TGLHeightData. There are 3 data types (8 bits unsigned, signed 16 bits and 32 bits). Conversions: (128*(ByteValue-128)) = SmallIntValue = Round(SingleValue). The 'hdtDefault' type is used for request only, and specifies that the default type for the source should be used.

Values
  • hdtByte
  • hdtSmallInt
  • hdtSingle
  • hdtDefault
THDTextureCoordinatesMode = (...);

This item has no description.

Values
  • tcmWorld
  • tcmLocal
TMarkDirtyEvent = procedure(const Area: TRect) of object;

This item has no description.

TOnHeightDataDirtyEvent = procedure(sender: TGLHeightData) of object;

This item has no description.

TSingleRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PSingleArray;

This item has no description.

TSmallintArray = array [0 .. MaxInt div (2 * SizeOf(SmallInt))] of SmallInt;

This item has no description.

TSmallIntRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PSmallIntArray;

This item has no description.

TSourceDataFetchedEvent = procedure(sender: TGLHeightDataSourceFilter; HeightData: TGLHeightData) of object;

This item has no description.

TStartPreparingDataEvent = procedure(HeightData: TGLHeightData) of object;


GLSysHelp v.2.5: GLS.HeightData: Class TGLHeightDataSource

Class TGLHeightDataSource

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightData

Declaration

type TGLHeightDataSource = class(TComponent)

Description

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TGLHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TGLHeightData with its "Release" method) Pre-loading : specify a list of TGLHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource

Overview

Fields

Private | FData: TThreadList;
Private | FDataHash: array [0 .. 255] of TList;
Private | FThread: TThread;
Private | FMaxThreads: Integer;
Private | FMaxPoolSize: Integer;
Private | FHeightDataClass: TGLHeightDataClass;
Private | FDefaultHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetData(XLeft, YTop, size: Integer; DataType: TGLHeightDataType) : TGLHeightData; virtual;
Public | function Height: Integer; virtual; abstract;
Public | function InterpolatedHeight(x, y: Single; TileSize: Integer) : Single; virtual;
Public | function PreLoad(XLeft, YTop, size: Integer; DataType: TGLHeightDataType) : TGLHeightData; virtual;
Public | function Width: Integer; virtual; abstract;
Public | procedure AfterPreparingData(HeightData: TGLHeightData); virtual;
Public | procedure BeforePreparingData(HeightData: TGLHeightData); virtual;
Public | procedure CleanUp;
Public | procedure Clear;
Public | procedure MarkDirty(const Area: TRect); overload; virtual;
Public | procedure MarkDirty(XLeft, YTop, xRight, yBottom: Integer); overload;
Public | procedure MarkDirty; overload;
Public | procedure PreloadReplacement(aHeightData: TGLHeightData);
Public | procedure Release(aHeightData: TGLHeightData); virtual;
Public | procedure StartPreparingData(HeightData: TGLHeightData); virtual;
Public | procedure TextureCoordinates(HeightData: TGLHeightData; Stretch: boolean = false);
Public | procedure ThreadIsIdle; virtual;

Properties

Public | property Data: TThreadList read FData;
Public | property DefaultHeight: Single read FDefaultHeight write FDefaultHeight;
Public | property MaxPoolSize: Integer read FMaxPoolSize write FMaxPoolSize;
Public | property MaxThreads: Integer read FMaxThreads write SetMaxThreads;

Description

Fields

Private FData: TThreadList;

This item has no description.

Private FDataHash: array [0 .. 255] of TList;

stores all TGLHeightData, whatever their state/type

Private FThread: TThread;

X/Y hash references for HeightDatas

Private FMaxThreads: Integer;

queue manager

Private FMaxPoolSize: Integer;

This item has no description.

Private FHeightDataClass: TGLHeightDataClass;

This item has no description.

Private FDefaultHeight: Single;

FReleaseLatency : TDateTime; //Not used anymore???

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetData(XLeft, YTop, size: Integer; DataType: TGLHeightDataType) : TGLHeightData; virtual;

Base TGLHeightData requester method. Returns (by rebuilding it or from the cache) a TGLHeightData corresponding to the given area. Size must be a power of two. Subclasses may choose to publish it or just publish datasource- specific requester method using specific parameters.

Public function Height: Integer; virtual; abstract;

This item has no description.

Public function InterpolatedHeight(x, y: Single; TileSize: Integer) : Single; virtual;

Interpolates height for the given point.

Public function PreLoad(XLeft, YTop, size: Integer; DataType: TGLHeightDataType) : TGLHeightData; virtual;

Preloading request. See GetData for details.

Public function Width: Integer; virtual; abstract;

This item has no description.

Public procedure AfterPreparingData(HeightData: TGLHeightData); virtual;

This is called After "StartPreparingData", but always from the main thread

Public procedure BeforePreparingData(HeightData: TGLHeightData); virtual;

This is called BEFORE StartPreparing Data, but always from the main thread.

Public procedure CleanUp;

Removes less used TDataHeight objects from the pool. Only removes objects whose state is hdsReady and UseCounter is zero, starting from the end of the list until total data size gets below MaxPoolSize (or nothing can be removed).

Public procedure Clear;

Empties the Data list, terminating thread if necessary. If some TGLHeightData are hdsInUse, triggers an exception and does nothing.

Public procedure MarkDirty(const Area: TRect); overload; virtual;

Marks the given area as "dirty" (ie source data changed). All loaded and in-cache tiles overlapping the area are flushed.

Public procedure MarkDirty(XLeft, YTop, xRight, yBottom: Integer); overload;

This item has no description.

Public procedure MarkDirty; overload;

This item has no description.

Public procedure PreloadReplacement(aHeightData: TGLHeightData);

Replacing dirty tiles.

Public procedure Release(aHeightData: TGLHeightData); virtual;

Notification that the data is no longer used by the renderer. Default behaviour is just to change DataState to hdsReady (ie. return the data to the pool)

Public procedure StartPreparingData(HeightData: TGLHeightData); virtual;

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Public procedure TextureCoordinates(HeightData: TGLHeightData; Stretch: boolean = false);

This item has no description.

Public procedure ThreadIsIdle; virtual;

This item has no description.

Properties

Public property Data: TThreadList read FData;

Access to currently pooled TGLHeightData objects, and Thread locking

Public property DefaultHeight: Single read FDefaultHeight write FDefaultHeight;

Height to return for undefined tiles.

Public property MaxPoolSize: Integer read FMaxPoolSize write FMaxPoolSize;

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Public property MaxThreads: Integer read FMaxThreads write SetMaxThreads;

Maximum number of background threads. If 0 (zero), multithreading is disabled and StartPreparingData will be called from the mainthread, and all preload requirements (queued TGLHeightData objects) will be loaded in sequence from the main thread. If 1, basic multithreading and queueing gets enabled, ie. StartPreparingData will be called from a thread, but from one thread only (ie. there is no need to implement a TGLHeightDataThread, just make sure StartPreparingData code is thread-safe). Other values (2 and more) are relevant only if you implement a TGLHeightDataThread subclass and fire it in StartPreparingData.


GLSysHelp v.2.5: GLS.HeightData: Record TGLHeightDataUser

Record TGLHeightDataUser

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightData

Declaration

type TGLHeightDataUser = record

Description

This item has no description.

Overview

Fields

Public | user: TObject;
Public | event: TOnHeightDataDirtyEvent;

Description

Fields

Public user: TObject;

This item has no description.

Public event: TOnHeightDataDirtyEvent;


GLSysHelp v.2.5: GLS.HeightData: Class TGLHeightData

Class TGLHeightData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightData

Declaration

type TGLHeightData = class(TGLUpdateAbleObject)

Description

TGLHeightData = class (TObject)

Hierarchy

  • TGLUpdateAbleObject
  • TGLHeightData

Overview

Fields

Private | FUsers: array of TGLHeightDataUser;
Private | FOwner: TGLHeightDataSource;
Private | FDataState: TGLHeightDataState;
Private | FSize: Integer;
Private | FXLeft: Integer;
Private | FYTop: Integer;
Private | FUseCounter: Integer;
Private | FDataType: TGLHeightDataType;
Private | FDataSize: Integer;
Private | FByteData: PByteArray;
Private | FByteRaster: PByteRaster;
Private | FSmallIntData: PSmallIntArray;
Private | FSmallIntRaster: PSmallIntRaster;
Private | FSingleData: PSingleArray;
Private | FSingleRaster: PSingleRaster;
Private | FTextureCoordinatesMode: THDTextureCoordinatesMode;
Private | FTCOffset: TTexPoint;
Private | FTCScale: TTexPoint;
Private | FMaterialName: String;
Private | FLibMaterial: TGLLibMaterial;
Private | FObjectTag: TObject;
Private | FTag: Integer;
Private | FTag2: Integer;
Private | FOnDestroy: TNotifyEvent;
Private | FDirty: boolean;
Private | FHeightMin: Single;
Private | FHeightMax: Single;
Public | OldVersion: TGLHeightData;
Public | NewVersion: TGLHeightData;
Public | DontUse: boolean;

Methods

Public | constructor Create(AOwner: TGLHeightDataSource; aXLeft, aYTop, aSize: Integer; aDataType: TGLHeightDataType); reintroduce; virtual;
Public | destructor Destroy; override;
Public | function ByteHeight(x, y: Integer): Byte;
Public | function Height(x, y: Integer): Single;
Public | function InterpolatedHeight(x, y: Single): Single;
Public | function Normal(x, y: Integer; const scale: TAffineVector): TAffineVector;
Public | function NormalAtNode(x, y: Integer; const scale: TAffineVector): TAffineVector;
Public | function OverlapsArea(const Area: TRect): boolean;
Public | function SingleHeight(x, y: Integer): Single;
Public | function SmallIntHeight(x, y: Integer): SmallInt;
Public | procedure Allocate(const Val: TGLHeightDataType); virtual;
Public | procedure MarkDirty;
Public | procedure RegisterUse;
Public | procedure Release;
Private | procedure BuildByteRaster;
Private | procedure BuildSingleRaster;
Private | procedure BuildSmallIntRaster;
Private | procedure ConvertByteToSingle;
Private | procedure ConvertByteToSmallInt;
Private | procedure ConvertSingleToByte;
Private | procedure ConvertSingleToSmallInt;
Private | procedure ConvertSmallIntToByte;
Private | procedure ConvertSmallIntToSingle;

Properties

Public | property ByteData: PByteArray read FByteData;
Public | property ByteRaster: PByteRaster read FByteRaster;
Public | property DataSize: Integer read FDataSize;
Public | property DataState: TGLHeightDataState read FDataState write FDataState;
Public | property DataType: TGLHeightDataType read FDataType write SetDataType;
Public | property Dirty: boolean read FDirty write FDirty;
Public | property HeightMax: Single read GetHeightMax write FHeightMax;
Public | property HeightMin: Single read GetHeightMin write FHeightMin;
Public | property LibMaterial: TGLLibMaterial read FLibMaterial write SetLibMaterial;
Public | property MaterialName: String read FMaterialName write SetMaterialName;
Public | property ObjectTag: TObject read FObjectTag write FObjectTag;
Public | property OnDestroy: TNotifyEvent read FOnDestroy write FOnDestroy;
Public | property Owner: TGLHeightDataSource read FOwner;
Public | property SingleData: PSingleArray read FSingleData;
Public | property SingleRaster: PSingleRaster read FSingleRaster;
Public | property Size: Integer read FSize;
Public | property SmallIntData: PSmallIntArray read FSmallIntData;
Public | property SmallIntRaster: PSmallIntRaster read FSmallIntRaster;
Public | property Tag: Integer read FTag write FTag;
Public | property Tag2: Integer read FTag2 write FTag2;
Public | property TextureCoordinatesMode: THDTextureCoordinatesMode read FTextureCoordinatesMode write FTextureCoordinatesMode;
Public | property TextureCoordinatesOffset: TTexPoint read FTCOffset write FTCOffset;
Public | property TextureCoordinatesScale: TTexPoint read FTCScale write FTCScale;
Public | property Thread: TGLHeightDataThread read FThread write FThread;
Public | property UseCounter: Integer read FUseCounter;
Public | property XLeft: Integer read FXLeft;
Public | property YTop: Integer read FYTop;

Description

Fields

Private FUsers: array of TGLHeightDataUser;

This item has no description.

Private FOwner: TGLHeightDataSource;

This item has no description.

Private FDataState: TGLHeightDataState;

This item has no description.

Private FSize: Integer;

This item has no description.

Private FXLeft: Integer;

This item has no description.

Private FYTop: Integer;

This item has no description.

Private FUseCounter: Integer;

This item has no description.

Private FDataType: TGLHeightDataType;

This item has no description.

Private FDataSize: Integer;

This item has no description.

Private FByteData: PByteArray;

This item has no description.

Private FByteRaster: PByteRaster;

This item has no description.

Private FSmallIntData: PSmallIntArray;

This item has no description.

Private FSmallIntRaster: PSmallIntRaster;

This item has no description.

Private FSingleData: PSingleArray;

This item has no description.

Private FSingleRaster: PSingleRaster;

This item has no description.

Private FTextureCoordinatesMode: THDTextureCoordinatesMode;

This item has no description.

Private FTCOffset: TTexPoint;

This item has no description.

Private FTCScale: TTexPoint;

This item has no description.

Private FMaterialName: String;

This item has no description.

Private FLibMaterial: TGLLibMaterial;

Unsafe. Use FLibMaterial instead

Private FObjectTag: TObject;

This item has no description.

Private FTag: Integer;

This item has no description.

Private FTag2: Integer;

This item has no description.

Private FOnDestroy: TNotifyEvent;

This item has no description.

Private FDirty: boolean;

This item has no description.

Private FHeightMin: Single;

This item has no description.

Private FHeightMax: Single;

This item has no description.

Public OldVersion: TGLHeightData;

This item has no description.

Public NewVersion: TGLHeightData;

previous version of this tile

Public DontUse: boolean;

the replacement tile

Methods

Public constructor Create(AOwner: TGLHeightDataSource; aXLeft, aYTop, aSize: Integer; aDataType: TGLHeightDataType); reintroduce; virtual;

Tells TerrainRenderer which version to use constructor Create(AOwner : TComponent); override;

Public destructor Destroy; override;

This item has no description.

Public function ByteHeight(x, y: Integer): Byte;

Height of point x, y as a Byte.

Public function Height(x, y: Integer): Single;

Returns the height as a single, whatever the DataType (slow).

Public function InterpolatedHeight(x, y: Single): Single;

Interopolated height of point x, y as a Single.

Public function Normal(x, y: Integer; const scale: TAffineVector): TAffineVector;

Calculates and returns the normal for vertex point x, y. Sub classes may provide normal cacheing, the default implementation being rather blunt.

Public function NormalAtNode(x, y: Integer; const scale: TAffineVector): TAffineVector;

Calculates and returns the normal for cell x, y.(between vertexes)

Public function OverlapsArea(const Area: TRect): boolean;

Returns True if the data tile overlaps the area.

Public function SingleHeight(x, y: Integer): Single;

Height of point x, y as a Single.

Public function SmallIntHeight(x, y: Integer): SmallInt;

Height of point x, y as a SmallInt.

Public procedure Allocate(const Val: TGLHeightDataType); virtual;

Allocate memory and prepare lookup tables for current datatype. Fails if already allocated. Made Dynamic to allow descendants

Public procedure MarkDirty;

Marks the tile as dirty. The immediate effect is currently the destruction of the tile.

Public procedure RegisterUse;

Increments UseCounter. User objects should implement a method that will be notified when the data becomes dirty, when invoked they should release the heightdata immediately after performing their own cleanups.

Public procedure Release;

Decrements UseCounter. When the counter reaches zero, notifies the Owner TGLHeightDataSource that the data is no longer used. The renderer should call Release when it no longer needs a THeighData, and never free/destroy the object directly.

Private procedure BuildByteRaster;

This item has no description.

Private procedure BuildSingleRaster;

This item has no description.

Private procedure BuildSmallIntRaster;

This item has no description.

Private procedure ConvertByteToSingle;

This item has no description.

Private procedure ConvertByteToSmallInt;

This item has no description.

Private procedure ConvertSingleToByte;

This item has no description.

Private procedure ConvertSingleToSmallInt;

This item has no description.

Private procedure ConvertSmallIntToByte;

This item has no description.

Private procedure ConvertSmallIntToSingle;

This item has no description.

Properties

Public property ByteData: PByteArray read FByteData;

Access to data as a byte array (n = y*Size+x). If TGLHeightData is not of type hdtByte, this value is nil.

Public property ByteRaster: PByteRaster read FByteRaster;

Access to data as a byte raster (y, x). If TGLHeightData is not of type hdtByte, this value is nil.

Public property DataSize: Integer read FDataSize;

Memory Size of the raw data in bytes.

Public property DataState: TGLHeightDataState read FDataState write FDataState;

Current state of the data.

Public property DataType: TGLHeightDataType read FDataType write SetDataType;

Type of the data. Assigning a new datatype will result in the data being converted.

Public property Dirty: boolean read FDirty write FDirty;

True if the data is dirty (ie. no longer up-to-date).

Public property HeightMax: Single read GetHeightMax write FHeightMax;

Maximum height in the tile. DataSources may assign a value to prevent automatic computation if they have a faster/already computed value.

Public property HeightMin: Single read GetHeightMin write FHeightMin;

Minimum height in the tile. DataSources may assign a value to prevent automatic computation if they have a faster/already computed value.

Public property LibMaterial: TGLLibMaterial read FLibMaterial write SetLibMaterial;

property LibMaterial : Links directly to the tile's TGLLibMaterial. Unlike 'MaterialName', this property also registers the tile as a user of the texture. This prevents TGLLibMaterials.DeleteUnusedTextures from deleting the used texture by mistake and causing Access Violations. Use this instead of the old MaterialName property, to prevent AV's.

Public property MaterialName: String read FMaterialName write SetMaterialName;

Name of material for the tile (if terrain uses multiple materials). property MaterialName : String read FMaterialName write FMaterialName; (WARNING: Unsafe when deleting textures! If possible, rather use LibMaterial.)

Public property ObjectTag: TObject read FObjectTag write FObjectTag;

Reserved for renderer use.

Public property OnDestroy: TNotifyEvent read FOnDestroy write FOnDestroy;

Fired when the object is destroyed.

Public property Owner: TGLHeightDataSource read FOwner;

The component who created and maintains this data.

Public property SingleData: PSingleArray read FSingleData;

Access to data as a Single array (n = y*Size+x). If TGLHeightData is not of type hdtSingle, this value is nil.

Public property SingleRaster: PSingleRaster read FSingleRaster;

Access to data as a Single raster (y, x). If TGLHeightData is not of type hdtSingle, this value is nil.

Public property Size: Integer read FSize;

Size of the data square, in data units.

Public property SmallIntData: PSmallIntArray read FSmallIntData;

Access to data as a SmallInt array (n = y*Size+x). If TGLHeightData is not of type hdtSmallInt, this value is nil.

Public property SmallIntRaster: PSmallIntRaster read FSmallIntRaster;

Access to data as a SmallInt raster (y, x). If TGLHeightData is not of type hdtSmallInt, this value is nil.

Public property Tag: Integer read FTag write FTag;

Reserved for renderer use.

Public property Tag2: Integer read FTag2 write FTag2;

Reserved for renderer use.

Public property TextureCoordinatesMode: THDTextureCoordinatesMode read FTextureCoordinatesMode write FTextureCoordinatesMode;

Texture coordinates generation mode. Default is tcmWorld coordinates.

Public property TextureCoordinatesOffset: TTexPoint read FTCOffset write FTCOffset;

This item has no description.

Public property TextureCoordinatesScale: TTexPoint read FTCScale write FTCScale;

This item has no description.

Public property Thread: TGLHeightDataThread read FThread write FThread;

Used by perlin HDS.

Public property UseCounter: Integer read FUseCounter;

Counter for use registration. A TGLHeightData is not returned to the pool until this counter reaches a value of zero.

Public property XLeft: Integer read FXLeft;

World X coordinate of top left point.

Public property YTop: Integer read FYTop;

World Y coordinate of top left point.


GLSysHelp v.2.5: GLS.HeightData: Class TGLHeightDataThread

Class TGLHeightDataThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightData

Declaration

type TGLHeightDataThread = class(TThread)

Description

A thread specialized for processing TGLHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly

Hierarchy

  • TObject
  • TThread
  • TGLHeightDataThread

Overview

Methods

Public destructor Destroy; override;

Properties

Public property HeightData: TGLHeightData read FHeightData write FHeightData;

Description

Methods

Public destructor Destroy; override;

This item has no description.

Properties

Public property HeightData: TGLHeightData read FHeightData write FHeightData;

The Height Data the thread is to prepare.


GLSysHelp v.2.5: GLS.HeightData: Class TGLBitmapHDS

Class TGLBitmapHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightData

Declaration

type TGLBitmapHDS = class(TGLHeightDataSource)

Description

Bitmap-based Height Data Source. The image is automatically wrapped if requested data is out of picture Size, or if requested data is larger than the picture. The internal format is an 8 bit bitmap whose dimensions are a power of two, if the original image does not comply, it is StretchDraw'ed on a monochrome (gray) bitmap.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLBitmapHDS

Overview

Fields

Private | FScanLineCache: array of PByteArray;
Private | FBitmap: TBitmap;
Private | FPicture: TPicture;
Private | FInfiniteWrap: boolean;
Private | FInverted: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height: Integer; override;
Public | function Width: Integer; override;
Public | procedure MarkDirty(const Area: TRect); override;
Public | procedure StartPreparingData(HeightData: TGLHeightData); override;

Properties

Published | property InfiniteWrap: boolean read FInfiniteWrap write SetInfiniteWrap default True;
Published | property Inverted: boolean read FInverted write SetInverted default True;
Published | property MaxPoolSize;
Published | property Picture: TPicture read FPicture write SetPicture;

Description

Fields

Private FScanLineCache: array of PByteArray;

This item has no description.

Private FBitmap: TBitmap;

This item has no description.

Private FPicture: TPicture;

This item has no description.

Private FInfiniteWrap: boolean;

This item has no description.

Private FInverted: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Height: Integer; override;

This item has no description.

Public function Width: Integer; override;

This item has no description.

Public procedure MarkDirty(const Area: TRect); override;

This item has no description. Showing description inherited from TGLHeightDataSource.MarkDirty.

Marks the given area as "dirty" (ie source data changed). All loaded and in-cache tiles overlapping the area are flushed.

Public procedure StartPreparingData(HeightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property InfiniteWrap: boolean read FInfiniteWrap write SetInfiniteWrap default True;

If true the height field is wrapped indefinetely.

Published property Inverted: boolean read FInverted write SetInverted default True;

If true, the rendered terrain is a mirror image of the input data.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property Picture: TPicture read FPicture write SetPicture;

The picture serving as Height field data reference. The picture is (if not already) internally converted to a 8 bit bitmap (grayscale). For better performance and to save memory, feed it this format!


GLSysHelp v.2.5: GLS.HeightData: Class TGLCustomHDS

Class TGLCustomHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightData

Declaration

type TGLCustomHDS = class(TGLHeightDataSource)

Description

An Height Data Source for custom use. Provides event handlers for the various requests to be implemented application-side (for application-specific needs).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLCustomHDS

Overview

Fields

Private | FOnStartPreparingData: TStartPreparingDataEvent;
Private | FOnMarkDirty: TMarkDirtyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure MarkDirty(const Area: TRect); override;
Public | procedure StartPreparingData(HeightData: TGLHeightData); override;

Properties

Published | property MaxPoolSize;
Published | property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;
Published | property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;

Description

Fields

Private FOnStartPreparingData: TStartPreparingDataEvent;

This item has no description.

Private FOnMarkDirty: TMarkDirtyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure MarkDirty(const Area: TRect); override;

This item has no description. Showing description inherited from TGLHeightDataSource.MarkDirty.

Marks the given area as "dirty" (ie source data changed). All loaded and in-cache tiles overlapping the area are flushed.

Public procedure StartPreparingData(HeightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property MaxPoolSize;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;

This item has no description.

Published property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;


GLSysHelp v.2.5: GLS.HeightData: Class TGLTerrainBaseHDS

Class TGLTerrainBaseHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightData

Declaration

type TGLTerrainBaseHDS = class(TGLHeightDataSource)

Description

TerrainBase-based Height Data Source. This component takes its data from the TerrainBase Gobal Terrain Model. Though it can be used directly, the resolution of the TerrainBase dataset isn't high enough for accurate short-range representation and the data should rather be used as basis for further (fractal) refinement. TerrainBase is freely available from the National Geophysical Data Center and World Data Center web site (http://ngdc.noaa.com). (this component expects to find "tbase.bin" in the current directory).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLTerrainBaseHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure StartPreparingData(HeightData: TGLHeightData); override;

Properties

Published property MaxPoolSize;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure StartPreparingData(HeightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property MaxPoolSize;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.


GLSysHelp v.2.5: GLS.HeightData: Class TGLHeightDataSourceFilter

Class TGLHeightDataSourceFilter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightData

Declaration

type TGLHeightDataSourceFilter = class(TGLHeightDataSource)

Description

Height Data Source Filter. This component sits between the TGLTerrainRenderer, and a real TGLHeightDataSource. i.e. TGLTerrainRenderer links to this. This links to the real TGLHeightDataSource. Use the 'HeightDataSource' property, to link to a source HDS. The 'OnSourceDataFetched' event then gives you the opportunity to make any changes, or link in a texture to the TGLHeightData object, BEFORE it is cached. It bypasses the cache of the source HDS, by calling the source's StartPreparingData procedure directly. The TGLHeightData objects are then cached by THIS component, AFTER you have made your changes. This eliminates the need to copy and release the TGLHeightData object from the Source HDS's cache, before linking your texture. See the new version of TGLBumpmapHDS for an example. (LIN) To create your own HDSFilters, Derive from this component, and override the PreparingData procedure.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLHeightDataSourceFilter

Overview

Fields

Private | FHDS: TGLHeightDataSource;
Private | FOnSourceDataFetched: TSourceDataFetchedEvent;
Private | FActive: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height: Integer; override;
Public | function Width: Integer; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure Release(aHeightData: TGLHeightData); override;
Public | procedure StartPreparingData(HeightData: TGLHeightData); override;

Properties

Published | property Active: boolean read FActive write FActive;
Published | property HeightDataSource: TGLHeightDataSource read FHDS write SetHDS;
Published | property MaxPoolSize;
Public | property OnSourceDataFetched: TSourceDataFetchedEvent read FOnSourceDataFetched write FOnSourceDataFetched;

Description

Fields

Private FHDS: TGLHeightDataSource;

This item has no description.

Private FOnSourceDataFetched: TSourceDataFetchedEvent;

This item has no description.

Private FActive: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Height: Integer; override;

This item has no description.

Public function Width: Integer; override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure Release(aHeightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.Release.

Notification that the data is no longer used by the renderer. Default behaviour is just to change DataState to hdsReady (ie. return the data to the pool)

Public procedure StartPreparingData(HeightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property Active: boolean read FActive write FActive;

This item has no description.

Published property HeightDataSource: TGLHeightDataSource read FHDS write SetHDS;

This item has no description.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Public property OnSourceDataFetched: TSourceDataFetchedEvent read FOnSourceDataFetched write FOnSourceDataFetched;


GLSysHelp v.2.5: GLS.HeightTileFileHDS

Unit GLS.HeightTileFileHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.HeightData

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TGLHeightTileInfo |
Packed Record TGLHeightTile |
Packed Record THTFHeader |
Class TGLHeightTileFile |
Class TGLHeightTileFileHDS |

Types

PGLHeightTile = ˆTGLHeightTile;
PGLHeightTileInfo = ˆTGLHeightTileInfo;
PIntegerArray = ˆTIntegerArray;
PPHeightTileInfo = ˆPGLHeightTileInfo;
PShortIntArray = ˆTShortIntArray;
PSmallIntArray = ˆTSmallIntArray;
TIntegerArray = array [0 .. MaxInt shr 3] of Integer;
TShortIntArray = array [0 .. MaxInt shr 2] of ShortInt;
TSmallIntArray = array [0 .. MaxInt shr 2] of SmallInt;

Constants

cHTFHashTableSize = 1023;
cHTFQuadTableSize = 31;

Description

Types

PGLHeightTile = ˆTGLHeightTile;

This item has no description.

PGLHeightTileInfo = ˆTGLHeightTileInfo;

This item has no description.

PIntegerArray = ˆTIntegerArray;

This item has no description.

PPHeightTileInfo = ˆPGLHeightTileInfo;

This item has no description.

PShortIntArray = ˆTShortIntArray;

This item has no description.

PSmallIntArray = ˆTSmallIntArray;

This item has no description.

TIntegerArray = array [0 .. MaxInt shr 3] of Integer;

Access to large tiled height data files. Performance vs Raw file accesses (for perfect tile match): Cached data: "Smooth" terrain 1:2 to 1:10 Random terrain 1:1

Non-cached data: "Smooth" terrain 1:100 to 1:1000 Random terrain 1:100

TShortIntArray = array [0 .. MaxInt shr 2] of ShortInt;

This item has no description.

TSmallIntArray = array [0 .. MaxInt shr 2] of SmallInt;

This item has no description.

Constants

cHTFHashTableSize = 1023;

This item has no description.

cHTFQuadTableSize = 31;


GLSysHelp v.2.5: GLS.HeightTileFileHDS: Packed Record TGLHeightTileInfo

Packed Record TGLHeightTileInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightTileFileHDS

Declaration

type TGLHeightTileInfo = packed record

Description

This item has no description.

Overview

Fields

Public | left: Integer;
Public | top: Integer;
Public | width: Integer;
Public | height: Integer;
Public | min: SmallInt;
Public | max: SmallInt;
Public | average: SmallInt;
Public | fileOffset: Int64;

Description

Fields

Public left: Integer;

This item has no description.

Public top: Integer;

This item has no description.

Public width: Integer;

This item has no description.

Public height: Integer;

This item has no description.

Public min: SmallInt;

This item has no description.

Public max: SmallInt;

This item has no description.

Public average: SmallInt;

This item has no description.

Public fileOffset: Int64;


GLSysHelp v.2.5: GLS.HeightTileFileHDS: Packed Record TGLHeightTile

Packed Record TGLHeightTile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightTileFileHDS

Declaration

type TGLHeightTile = packed record

Description

This item has no description.

Overview

Fields

Public | info: TGLHeightTileInfo;
Public | data: array of SmallInt;

Description

Fields

Public info: TGLHeightTileInfo;

This item has no description.

Public data: array of SmallInt;


GLSysHelp v.2.5: GLS.HeightTileFileHDS: Packed Record THTFHeader

Packed Record THTFHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightTileFileHDS

Declaration

type THTFHeader = packed record

Description

This item has no description.

Overview

Fields

Public | FileVersion: array [0 .. 5] of AnsiChar;
Public | TileIndexOffset: Int64;
Public | SizeX: Integer;
Public | SizeY: Integer;
Public | TileSize: Integer;
Public | DefaultZ: SmallInt;

Description

Fields

Public FileVersion: array [0 .. 5] of AnsiChar;

This item has no description.

Public TileIndexOffset: Int64;

This item has no description.

Public SizeX: Integer;

This item has no description.

Public SizeY: Integer;

This item has no description.

Public TileSize: Integer;

This item has no description.

Public DefaultZ: SmallInt;


GLSysHelp v.2.5: GLS.HeightTileFileHDS: Class TGLHeightTileFile

Class TGLHeightTileFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightTileFileHDS

Declaration

type TGLHeightTileFile = class(TObject)

Description

Interfaces a Tiled file

Hierarchy

  • TObject
  • TGLHeightTileFile

Overview

Fields

Private | FFile: TStream;
Private | FHeader: THTFHeader;
Private | FTileIndex: packed of TGLHeightTileInfo;
Private | FTileMark: array of Cardinal;
Private | FLastMark: Cardinal;
Private | FHashTable: array [0 .. cHTFHashTableSize] of array of Integer;
Private | FQuadTable: array [0 .. cHTFQuadTableSize, 0 .. cHTFQuadTableSize] of array of Integer;
Private | FCreating: Boolean;
Private | FHeightTile: TGLHeightTile;
Private | FInBuf: array of ShortInt;

Methods

Public | constructor Create(const fileName: String);
Public | constructor CreateNew(const fileName: String; aSizeX, aSizeY, aTileSize: Integer);
Public | destructor Destroy; override;
Public | function GetTile(aLeft, aTop: Integer; pTileInfo: PPHeightTileInfo = nil): PGLHeightTile;
Public | function GetTileIndex(aLeft, aTop: Integer): Integer;
Public | function IndexOfTile(aTile: PGLHeightTileInfo): Integer;
Public | function TileCompressedSize(tileIndex: Integer): Integer;
Public | function TileCount: Integer;
Public | function XYHeight(anX, anY: Integer): SmallInt;
Public | function XYTileInfo(anX, anY: Integer): PGLHeightTileInfo;
Public | procedure CompressTile(aLeft, aTop, aWidth, aHeight: Integer; aData: PSmallIntArray);
Public | procedure ExtractRow(x, y, len: Integer; dest: PSmallIntArray);
Public | procedure TilesInRect(aLeft, aTop, aRight, aBottom: Integer; destList: TList);

Properties

Public | property DefaultZ: SmallInt read FHeader.DefaultZ write FHeader.DefaultZ;
Public | property SizeX: Integer read FHeader.SizeX;
Public | property SizeY: Integer read FHeader.SizeY;
Public | property Tiles[index: Integer]: PGLHeightTileInfo read GetTiles;
Public | property TileSize: Integer read FHeader.TileSize;

Description

Fields

Private FFile: TStream;

This item has no description.

Private FHeader: THTFHeader;

This item has no description.

Private FTileIndex: packed of TGLHeightTileInfo;

This item has no description.

Private FTileMark: array of Cardinal;

This item has no description.

Private FLastMark: Cardinal;

This item has no description.

Private FHashTable: array [0 .. cHTFHashTableSize] of array of Integer;

This item has no description.

Private FQuadTable: array [0 .. cHTFQuadTableSize, 0 .. cHTFQuadTableSize] of array of Integer;

This item has no description.

Private FCreating: Boolean;

This item has no description.

Private FHeightTile: TGLHeightTile;

This item has no description.

Private FInBuf: array of ShortInt;

This item has no description.

Methods

Public constructor Create(const fileName: String);

This item has no description.

Public constructor CreateNew(const fileName: String; aSizeX, aSizeY, aTileSize: Integer);

Creates a new HTF file. Read and data access methods are not available when creating.

Public destructor Destroy; override;

This item has no description.

Public function GetTile(aLeft, aTop: Integer; pTileInfo: PPHeightTileInfo = nil): PGLHeightTile;

Returns tile of corresponding left/top.

Public function GetTileIndex(aLeft, aTop: Integer): Integer;

Returns tile index for corresponding left/top.

Public function IndexOfTile(aTile: PGLHeightTileInfo): Integer;

This item has no description.

Public function TileCompressedSize(tileIndex: Integer): Integer;

This item has no description.

Public function TileCount: Integer;

This item has no description.

Public function XYHeight(anX, anY: Integer): SmallInt;

Returns the height at given coordinates. This is definetely NOT the fastest way to access HTF data and should only be used as utility function.

Public function XYTileInfo(anX, anY: Integer): PGLHeightTileInfo;

Returns the tile that contains x and y.

Public procedure CompressTile(aLeft, aTop, aWidth, aHeight: Integer; aData: PSmallIntArray);

Stores and compresses give tile data. aLeft and top MUST be a multiple of TileSize, aWidth and aHeight MUST be lower or equal to TileSize.

Public procedure ExtractRow(x, y, len: Integer; dest: PSmallIntArray);

Extract a single row from the HTF file. This is NOT the fastest way to access HTF data. All of the row must be contained in the world, otherwise result is undefined.

Public procedure TilesInRect(aLeft, aTop, aRight, aBottom: Integer; destList: TList);

Clears the list then add all tiles that overlap the rectangular area.

Properties

Public property DefaultZ: SmallInt read FHeader.DefaultZ write FHeader.DefaultZ;

This item has no description.

Public property SizeX: Integer read FHeader.SizeX;

This item has no description.

Public property SizeY: Integer read FHeader.SizeY;

This item has no description.

Public property Tiles[index: Integer]: PGLHeightTileInfo read GetTiles;

This item has no description.

Public property TileSize: Integer read FHeader.TileSize;

Maximum width and height for a tile. Actual tiles may not be square, can assume random layouts, and may overlap.


GLSysHelp v.2.5: GLS.HeightTileFileHDS: Class TGLHeightTileFileHDS

Class TGLHeightTileFileHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HeightTileFileHDS

Declaration

type TGLHeightTileFileHDS = class(TGLHeightDataSource)

Description

—————- TGLHeightTileFileHDS class ———————– An Height Data Source for the HTF format.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLHeightTileFileHDS

Overview

Fields

Private | FInfiniteWrap: Boolean;
Private | FInverted: Boolean;
Private | FHTFFileName: String;
Private | FHTF: TGLHeightTileFile;
Private | FMinElevation: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height: Integer; override;
Public | function OpenHTF: TGLHeightTileFile;
Public | function Width: Integer; override;
Public | procedure StartPreparingData(HeightData: TGLHeightData); override;

Properties

Published | property DefaultHeight;
Published | property HTFFileName: String read FHTFFileName write SetHTFFileName;
Published | property InfiniteWrap: Boolean read FInfiniteWrap write SetInfiniteWrap default True;
Published | property Inverted: Boolean read FInverted write SetInverted default True;
Published | property MaxPoolSize;
Published | property MinElevation: Integer read FMinElevation write SetMinElevation default -32768;

Description

Fields

Private FInfiniteWrap: Boolean;

This item has no description.

Private FInverted: Boolean;

This item has no description.

Private FHTFFileName: String;

This item has no description.

Private FHTF: TGLHeightTileFile;

This item has no description.

Private FMinElevation: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Height: Integer; override;

This item has no description.

Public function OpenHTF: TGLHeightTileFile;

This item has no description.

Public function Width: Integer; override;

This item has no description.

Public procedure StartPreparingData(HeightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property DefaultHeight;

This item has no description. Showing description inherited from TGLHeightDataSource.DefaultHeight.

Height to return for undefined tiles.

Published property HTFFileName: String read FHTFFileName write SetHTFFileName;

FileName of the HTF file. Note that it is accessed via the services of GLS.ApplicationFileIO, so this may not necessarily be a regular file on a disk...

Published property InfiniteWrap: Boolean read FInfiniteWrap write SetInfiniteWrap default True;

If true the height field is wrapped indefinetely.

Published property Inverted: Boolean read FInverted write SetInverted default True;

If true the height data is inverted.(Top to bottom)

Published property MaxPoolSize;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property MinElevation: Integer read FMinElevation write SetMinElevation default -32768;

Minimum elevation of the tiles that are considered to exist. This property can typically be used to hide underwater tiles.


GLSysHelp v.2.5: GLS.HUDObjects

Unit GLS.HUDObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • Vcl.StdCtrls
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLScene.VectorTypes
  • GLS.Coordinates
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.Objects
  • GLS.BitmapFont
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.Material
  • GLS.Texture

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLHUDSprite |
Class TGLHUDText |
Class TGLAbsoluteHUDText |
Class TGLResolutionIndependantHUDText |


GLSysHelp v.2.5: GLS.HUDObjects: Class TGLHUDSprite

Class TGLHUDSprite

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HUDObjects

Declaration

type TGLHUDSprite = class(TGLSprite)

Description

A rectangular area, NOT perspective projected. (x, y) coordinates map directly to the viewport (in pixels) and refer the center of the area. The coordinate system is that of an equivalent TCanvas, ie. top-left point is the origin (0, 0). The z component is ignored and Z-Buffer is disabled when rendering. Using TGLHUDSprite in 2D only scenes : The most convenient way to use a TGLHUDSprite as a simple 2D sprite with blending capabilities (transparency or additive), is to set the texture mode to tmModulate, in FrontProperties, to use the Emission color to control coloring/intensity, and finally use the Diffuse color's alpha to control transparency (while setting the other RGB components to 0). You can also control aplha-blending by defining a <1 value in the sprite's AlphaChannel field. This provides you with hardware accelerated, alpha-blended blitting. Note : since TGLHUDSprite works in absolute coordinates, TGLProxyObject can't be used to duplicate an hud sprite.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSprite
  • TGLHUDSprite

Overview

Fields

Private | FXTiles: Integer;
Private | FYTiles: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function StoreHeight: Boolean;
Private | function StoreWidth: Boolean;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property Height stored StoreHeight;
Published | property Width stored StoreWidth;
Published | property XTiles: Integer read FXTiles write SetXTiles default 1;
Published | property YTiles: Integer read FYTiles write SetYTiles default 1;

Description

Fields

Private FXTiles: Integer;

This item has no description.

Private FYTiles: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function StoreHeight: Boolean;

This item has no description.

Private function StoreWidth: Boolean;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property Height stored StoreHeight;

This item has no description. Showing description inherited from TGLSprite.Height.

Sprite Height in 3D world units.

Published property Width stored StoreWidth;

Redeclare them with new default values.

Published property XTiles: Integer read FXTiles write SetXTiles default 1;

This item has no description.

Published property YTiles: Integer read FYTiles write SetYTiles default 1;


GLSysHelp v.2.5: GLS.HUDObjects: Class TGLHUDText

Class TGLHUDText

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HUDObjects

Declaration

type TGLHUDText = class(TGLImmaterialSceneObject)

Description

A 2D text displayed and positionned in 2D coordinates. The HUDText uses a character font defined and stored by a TGLBitmapFont component. The text can be scaled and rotated (2D), the layout and alignment can also be controled.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLHUDText

Overview

Fields

Private | FBitmapFont: TGLCustomBitmapFont;
Private | FText: UnicodeString;
Private | FRotation: Single;
Private | FAlignment: TAlignment;
Private | FLayout: TTextLayout;
Private | FModulateColor: TGLColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment default taLeftJustify;
Published | property BitmapFont: TGLCustomBitmapFont read FBitmapFont write SetBitmapFont;
Published | property Layout: TTextLayout read FLayout write SetLayout default tlTop;
Published | property ModulateColor: TGLColor read FModulateColor write SetModulateColor;
Published | property Rotation: Single read FRotation write SetRotation;
Published | property Text: UnicodeString read FText write SetText;

Description

Fields

Private FBitmapFont: TGLCustomBitmapFont;

This item has no description.

Private FText: UnicodeString;

This item has no description.

Private FRotation: Single;

This item has no description.

Private FAlignment: TAlignment;

This item has no description.

Private FLayout: TTextLayout;

This item has no description.

Private FModulateColor: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment default taLeftJustify;

Controls the text alignment (horizontal). Possible values : taLeftJustify, taRightJustify, taCenter

Published property BitmapFont: TGLCustomBitmapFont read FBitmapFont write SetBitmapFont;

Refers the bitmap font to use. The referred bitmap font component stores and allows access to individual character bitmaps.

Published property Layout: TTextLayout read FLayout write SetLayout default tlTop;

Controls the text layout (vertical). Possible values : tlTop, tlCenter, tlBottom

Published property ModulateColor: TGLColor read FModulateColor write SetModulateColor;

Color modulation, can be used for fade in/out too.

Published property Rotation: Single read FRotation write SetRotation;

Rotation angle in degrees (2d).

Published property Text: UnicodeString read FText write SetText;

Text to render. Be aware that only the characters available in the bitmap font will be rendered. CR LF sequences are allowed.


GLSysHelp v.2.5: GLS.HUDObjects: Class TGLAbsoluteHUDText

Class TGLAbsoluteHUDText

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HUDObjects

Declaration

type TGLAbsoluteHUDText = class(TGLHUDText)

Description

Position (X, Y and X) is in absolute coordinates. This component converts them to screen coordinates and renderes text there.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLHUDText
  • TGLAbsoluteHUDText

Overview

Methods

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;


GLSysHelp v.2.5: GLS.HUDObjects: Class TGLResolutionIndependantHUDText

Class TGLResolutionIndependantHUDText

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.HUDObjects

Declaration

type TGLResolutionIndependantHUDText = class(TGLHUDText)

Description

Position (X and Y) is expected in a [0..1] range (from Screen size) This component converts this position to the actual screen position and renders the text there. This way a HUD text always appears to be in the the same place, regardless of the currect screen resolution. Note: this still does not solve the font scaling problem.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLHUDText
  • TGLResolutionIndependantHUDText

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;


GLSysHelp v.2.5: GLS.ImageUtils

Unit GLS.ImageUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • System.UITypes
  • System.Classes
  • System.Math
  • Vcl.Forms
  • Vcl.Dialogs
  • Vcl.ExtDlgs
  • Vcl.Graphics
  • GLScene.OpenGLTokens
  • GLScene.Strings
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TIntermediateFormat |
Class EGLImageUtils |

Functions and Procedures

function ImageBoxFilter(Value: Single): Single;
function ImageTriangleFilter(Value: Single): Single;
function ImageHermiteFilter(Value: Single): Single;
function ImageBellFilter(Value: Single): Single;
function ImageSplineFilter(Value: Single): Single;
function ImageLanczos3Filter(Value: Single): Single;
function ImageMitchellFilter(Value: Single): Single;
procedure ImageAlphaFromIntensity(var AColor: TIntermediateFormat);
procedure ImageAlphaSuperBlackTransparent(var AColor: TIntermediateFormat);
procedure ImageAlphaLuminance(var AColor: TIntermediateFormat);
procedure ImageAlphaLuminanceSqrt(var AColor: TIntermediateFormat);
procedure ImageAlphaOpaque(var AColor: TIntermediateFormat);
procedure ImageAlphaTopLeftPointColorTransparent(var AColor: TIntermediateFormat);
procedure ImageAlphaInverseLuminance(var AColor: TIntermediateFormat);
procedure ImageAlphaInverseLuminanceSqrt(var AColor: TIntermediateFormat);
procedure ImageAlphaBottomRightPointColorTransparent(var AColor: TIntermediateFormat);
procedure ConvertImage(const ASrc: Pointer; const ADst: Pointer; ASrcColorFormat, ADstColorFormat: Cardinal; ASrcDataType, ADstDataType: Cardinal; AWidth, AHeight: Integer);
procedure RescaleImage(const ASrc: Pointer; const ADst: Pointer; AColorFormat: Cardinal; ADataType: Cardinal; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight, ADstWidth, ADstHeight: Integer);
procedure Build2DMipmap(const ASrc: Pointer; const ADst: TPointerArray; AColorFormat: Cardinal; ADataType: Cardinal; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight: Integer);
procedure AlphaGammaBrightCorrection(const ASrc: Pointer; AColorFormat: Cardinal; ADataType: Cardinal; ASrcWidth, ASrcHeight: Integer; anAlphaProc: TImageAlphaProc; ABrightness: Single; AGamma: Single);
function StringToColorAdvancedSafe(const Str: string; const Default: TColor): TColor;
function TryStringToColorAdvanced(const Str: string; var OutColor: TColor): Boolean;
function StringToColorAdvanced(const Str: string): TColor;
function GetDeviceLogicalPixelsX(device: HDC): Integer;
function GetCurrentColorDepth: Integer;
function PixelFormatToColorBits(aPixelFormat: TPixelFormat): Integer;
function GLOKMessageBox(const Text, Caption: string): Integer;
procedure GLLoadBitmapFromInstance(Instance: LongInt; ABitmap: TBitmap; const AName: string);
procedure InformationDlg(const msg: string);
function QuestionDlg(const msg: string): Boolean;
function InputDlg(const aCaption, aPrompt, aDefault: string): string;
function SavePictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;
function OpenPictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;

Types

PIntermediateFormatArray = ˆTIntermediateFormatArray;
PRGBA32F = ˆTIntermediateFormat;
T48BitBlock = array [0 .. 3, 0 .. 3] of SmallInt;
TImageAlphaProc = procedure(var AColor: TIntermediateFormat);
TImageFilterFunction = function(Value: Single): Single;
TIntermediateFormatArray = array [0 .. MaxInt div (2 * SizeOf(TIntermediateFormat))] of TIntermediateFormat;
TPointerArray = array of Pointer;
TU48BitBlock = array [0 .. 3, 0 .. 3] of Byte;

Variables

vImageScaleFilterWidth: Integer = 5;

Description

Functions and Procedures

function ImageBoxFilter(Value: Single): Single;

This item has no description.

function ImageTriangleFilter(Value: Single): Single;

This item has no description.

function ImageHermiteFilter(Value: Single): Single;

This item has no description.

function ImageBellFilter(Value: Single): Single;

This item has no description.

function ImageSplineFilter(Value: Single): Single;

This item has no description.

function ImageLanczos3Filter(Value: Single): Single;

This item has no description.

function ImageMitchellFilter(Value: Single): Single;

This item has no description.

procedure ImageAlphaFromIntensity(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaSuperBlackTransparent(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaLuminance(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaLuminanceSqrt(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaOpaque(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaTopLeftPointColorTransparent(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaInverseLuminance(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaInverseLuminanceSqrt(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaBottomRightPointColorTransparent(var AColor: TIntermediateFormat);

This item has no description.

procedure ConvertImage(const ASrc: Pointer; const ADst: Pointer; ASrcColorFormat, ADstColorFormat: Cardinal; ASrcDataType, ADstDataType: Cardinal; AWidth, AHeight: Integer);

This item has no description.

procedure RescaleImage(const ASrc: Pointer; const ADst: Pointer; AColorFormat: Cardinal; ADataType: Cardinal; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight, ADstWidth, ADstHeight: Integer);

This item has no description.

procedure Build2DMipmap(const ASrc: Pointer; const ADst: TPointerArray; AColorFormat: Cardinal; ADataType: Cardinal; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight: Integer);

This item has no description.

procedure AlphaGammaBrightCorrection(const ASrc: Pointer; AColorFormat: Cardinal; ADataType: Cardinal; ASrcWidth, ASrcHeight: Integer; anAlphaProc: TImageAlphaProc; ABrightness: Single; AGamma: Single);

This item has no description.

function StringToColorAdvancedSafe(const Str: string; const Default: TColor): TColor;

Converts a string into color

function TryStringToColorAdvanced(const Str: string; var OutColor: TColor): Boolean;

Converts a string into color

function StringToColorAdvanced(const Str: string): TColor;

Converts a string into color

function GetDeviceLogicalPixelsX(device: HDC): Integer;

Number of pixels per logical inch along the screen width for the device. Under Win32 awaits a HDC and returns its LOGPIXELSX.

function GetCurrentColorDepth: Integer;

Number of bits per pixel for the current desktop resolution.

function PixelFormatToColorBits(aPixelFormat: TPixelFormat): Integer;

Returns the number of color bits associated to the given pixel format.

function GLOKMessageBox(const Text, Caption: string): Integer;

Returns the number of CPU cycles since startup. Use the similarly named CPU instruction.

procedure GLLoadBitmapFromInstance(Instance: LongInt; ABitmap: TBitmap; const AName: string);

This item has no description.

procedure InformationDlg(const msg: string);

Pops up a simple dialog with msg and an Ok button.

function QuestionDlg(const msg: string): Boolean;

Pops up a simple question dialog with msg and yes/no buttons. Returns True if answer was "yes".

function InputDlg(const aCaption, aPrompt, aDefault: string): string;

Posp a simple dialog with a string input.

function SavePictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;

Pops up a simple save picture dialog.

function OpenPictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;

Pops up a simple open picture dialog.

Types

PIntermediateFormatArray = ˆTIntermediateFormatArray;

This item has no description.

PRGBA32F = ˆTIntermediateFormat;

This item has no description.

T48BitBlock = array [0 .. 3, 0 .. 3] of SmallInt;

This item has no description.

TImageAlphaProc = procedure(var AColor: TIntermediateFormat);

This item has no description.

TImageFilterFunction = function(Value: Single): Single;

This item has no description.

TIntermediateFormatArray = array [0 .. MaxInt div (2 * SizeOf(TIntermediateFormat))] of TIntermediateFormat;

This item has no description.

TPointerArray = array of Pointer;

This item has no description.

TU48BitBlock = array [0 .. 3, 0 .. 3] of Byte;

This item has no description.

Variables

vImageScaleFilterWidth: Integer = 5;


GLSysHelp v.2.5: GLS.ImageUtils: Record TIntermediateFormat

Record TIntermediateFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ImageUtils

Declaration

type TIntermediateFormat = record

Description

Relative sample radius for filtering

Overview

Fields

Public | R: Single;
Public | G: Single;
Public | B: Single;
Public | A: Single;

Description

Fields

Public R: Single;

This item has no description.

Public G: Single;

This item has no description.

Public B: Single;

This item has no description.

Public A: Single;


GLSysHelp v.2.5: GLS.ImageUtils: Class EGLImageUtils

Class EGLImageUtils

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ImageUtils

Declaration

type EGLImageUtils = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLImageUtils


GLSysHelp v.2.5: GLS.Imposter

Unit GLS.Imposter

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Types
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.Context
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.PersistentClasses
  • GLScene.PipelineTransform
  • GLS.Graphics
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.Coordinates
  • GLS.BaseClasses
  • GLS.State
  • GLScene.TextureFormat
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TImposter |
Class TGLImposterBuilder |
Class TGLStaticImposterBuilderCorona |
Record TCoronaTangentLookup |
Class TGLStaticImposterBuilderCoronas |
Class TStaticImposter |
Class TGLStaticImposterBuilder |
Class TGLDynamicImposterBuilder |
Class TGLImposter |

Types

TImposterLoadedEvent = procedure (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter) of object;
TImposterOption = (...);
TImposterOptions = set of TImposterOption;
TImposterReference = (...);
TLoadingImposterEvent = function (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter) : TGLBitmap32 of object;
TSIBLigthing = (...);

Constants

cDefaultImposterOptions = [impoBlended, impoAlphaTest];

Description

Types

TImposterLoadedEvent = procedure (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter) of object;

Used CPPB procedure instead of Delphi function TLoadingImposterEvent = procedure (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter; var result : TGLBitmap32) of object;

TImposterOption = (...);

Imposter rendering options. Following options are supported: impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing

Values
  • impoBlended
  • impoAlphaTest
  • impoNearestFiltering
  • impoPerspectiveCorrection
TImposterOptions = set of TImposterOption;

This item has no description.

TImposterReference = (...);

This item has no description.

Values
  • irCenter
  • irTop
  • irBottom
TLoadingImposterEvent = function (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter) : TGLBitmap32 of object;

Imposter loading events

TSIBLigthing = (...);

This item has no description.

Values
  • siblNoLighting
  • siblStaticLighting
  • siblLocalLighting

Constants

cDefaultImposterOptions = [impoBlended, impoAlphaTest];


GLSysHelp v.2.5: GLS.Imposter: Class TImposter

Class TImposter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TImposter = class(TObject)

Description

Base class for imposters manipulation and handling. Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.

Note: Remeber to enable Destination Alpha on your viewer.

Hierarchy

  • TObject
  • TImposter

Overview

Fields

Private | FRequestCount: Integer;
Private | FBuilder: TGLImposterBuilder;
Private | FTexture: TGLTextureHandle;
Private | FImpostoredObject: TGLBaseSceneObject;
Private | FAspectRatio: Single;
Private | FModulated: Boolean;

Methods

Public | constructor Create(aBuilder: TGLImposterBuilder); virtual;
Public | destructor Destroy; override;
Public | procedure BeginRender(var rci: TGLRenderContextInfo); virtual;
Public | procedure EndRender(var rci: TGLRenderContextInfo); virtual;
Public | procedure Render(var rci: TGLRenderContextInfo; const objPos, localCameraPos: TGLVector; size: Single); virtual;
Public | procedure RenderOnce(var rci: TGLRenderContextInfo; const objPos, localCameraPos: TGLVector; size: Single);

Properties

Public | property AspectRatio: Single read FAspectRatio write FAspectRatio;
Public | property Builder: TGLImposterBuilder read FBuilder;
Public | property ImpostoredObject: TGLBaseSceneObject read FImpostoredObject write FImpostoredObject;
Public | property Modulated: Boolean read FModulated write FModulated;
Public | property Texture: TGLTextureHandle read FTexture;

Description

Fields

Private FRequestCount: Integer;

This item has no description.

Private FBuilder: TGLImposterBuilder;

This item has no description.

Private FTexture: TGLTextureHandle;

This item has no description.

Private FImpostoredObject: TGLBaseSceneObject;

This item has no description.

Private FAspectRatio: Single;

This item has no description.

Private FModulated: Boolean;

This item has no description.

Methods

Public constructor Create(aBuilder: TGLImposterBuilder); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BeginRender(var rci: TGLRenderContextInfo); virtual;

This item has no description.

Public procedure EndRender(var rci: TGLRenderContextInfo); virtual;

This item has no description.

Public procedure Render(var rci: TGLRenderContextInfo; const objPos, localCameraPos: TGLVector; size: Single); virtual;

This item has no description.

Public procedure RenderOnce(var rci: TGLRenderContextInfo; const objPos, localCameraPos: TGLVector; size: Single);

This item has no description.

Properties

Public property AspectRatio: Single read FAspectRatio write FAspectRatio;

This item has no description.

Public property Builder: TGLImposterBuilder read FBuilder;

This item has no description.

Public property ImpostoredObject: TGLBaseSceneObject read FImpostoredObject write FImpostoredObject;

This item has no description.

Public property Modulated: Boolean read FModulated write FModulated;

This item has no description.

Public property Texture: TGLTextureHandle read FTexture;


GLSysHelp v.2.5: GLS.Imposter: Class TGLImposterBuilder

Class TGLImposterBuilder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TGLImposterBuilder = class(TGLUpdateAbleComponent)

Description

Abstract ImposterBuilder class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLImposterBuilder

Overview

Fields

Private | FBackColor: TGLColor;
Private | FBuildOffset: TGLCoordinates;
Private | FImposterRegister: TGLPersistentObjectList;
Private | FRenderPoint: TGLRenderPoint;
Private | FImposterOptions: TImposterOptions;
Private | FAlphaTreshold: Single;
Private | FImposterReference: TImposterReference;
Private | FOnLoadingImposter: TLoadingImposterEvent;
Private | FOnImposterLoaded: TImposterLoadedEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ImposterFor(impostoredObject: TGLBaseSceneObject): TImposter;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure RequestImposterFor(impostoredObject: TGLBaseSceneObject);
Public | procedure UnRequestImposterFor(impostoredObject: TGLBaseSceneObject);

Properties

Published | property AlphaTreshold: Single read FAlphaTreshold write FAlphaTreshold;
Published | property BackColor: TGLColor read FBackColor write SetBackColor;
Published | property BuildOffset: TGLCoordinates read FBuildOffset write SetBuildOffset;
Published | property ImposterOptions: TImposterOptions read FImposterOptions write FImposterOptions default cDefaultImposterOptions;
Published | property ImposterReference: TImposterReference read FImposterReference write SetImposterReference default irCenter;
Published | property OnImposterLoaded: TImposterLoadedEvent read FOnImposterLoaded write FOnImposterLoaded;
Published | property OnLoadingImposter: TLoadingImposterEvent read FOnLoadingImposter write FOnLoadingImposter;
Published | property RenderPoint: TGLRenderPoint read FRenderPoint write SetRenderPoint;

Description

Fields

Private FBackColor: TGLColor;

This item has no description.

Private FBuildOffset: TGLCoordinates;

This item has no description.

Private FImposterRegister: TGLPersistentObjectList;

This item has no description.

Private FRenderPoint: TGLRenderPoint;

This item has no description.

Private FImposterOptions: TImposterOptions;

This item has no description.

Private FAlphaTreshold: Single;

This item has no description.

Private FImposterReference: TImposterReference;

This item has no description.

Private FOnLoadingImposter: TLoadingImposterEvent;

This item has no description.

Private FOnImposterLoaded: TImposterLoadedEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ImposterFor(impostoredObject: TGLBaseSceneObject): TImposter;

Returns a valid imposter for the specified object. Imposter must have been requested first, and the builder given an opportunity to prepare it before it can be available.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure RequestImposterFor(impostoredObject: TGLBaseSceneObject);

Request an imposter to be prepared for the specified object.

Public procedure UnRequestImposterFor(impostoredObject: TGLBaseSceneObject);

Tells the imposter for the specified object is no longer needed.

Properties

Published property AlphaTreshold: Single read FAlphaTreshold write FAlphaTreshold;

Alpha testing teshold.

Published property BackColor: TGLColor read FBackColor write SetBackColor;

Background color for impostor rendering. Typically, you'll want to leave the alpha channel to zero, and pick as RGB as color that matches the impostor'ed objects edge colors most.

Published property BuildOffset: TGLCoordinates read FBuildOffset write SetBuildOffset;

Offset applied to the impostor'ed object during imposter construction. Can be used to manually tune the centering of objects.

Published property ImposterOptions: TImposterOptions read FImposterOptions write FImposterOptions default cDefaultImposterOptions;

Imposter rendering options.

Published property ImposterReference: TImposterReference read FImposterReference write SetImposterReference default irCenter;

Determines how the imposter are handled. This is the reference point for imposters, impostor'ed objects that are centered should use irCenter, those whose bottom is the origin should use irBottom, etc.

Published property OnImposterLoaded: TImposterLoadedEvent read FOnImposterLoaded write FOnImposterLoaded;

Event fired after preparing/loading an imposter. This events gives an opportunity to save the imposter after it has been loaded or prepared.

Published property OnLoadingImposter: TLoadingImposterEvent read FOnLoadingImposter write FOnLoadingImposter;

Event fired before preparing/loading an imposter. If an already prepared version of the importer is available, place it in the TGLBitmap32 the event shall return (the bitmap will be freed by the imposter builder). If a bitmap is specified, it will be used in place of what automatic generation could have generated.

Published property RenderPoint: TGLRenderPoint read FRenderPoint write SetRenderPoint;

Specifies the render point at which the impostor texture(s) can be prepared. For best result, the render point should happen in viewer that has a destination alpha (otherwise, impostors will be opaque).


GLSysHelp v.2.5: GLS.Imposter: Class TGLStaticImposterBuilderCorona

Class TGLStaticImposterBuilderCorona

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TGLStaticImposterBuilderCorona = class(TCollectionItem)

Description

Describes a set of orientation in a corona fashion.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLStaticImposterBuilderCorona

Overview

Fields

Private | FSamples: Integer;
Private | FElevation: Single;
Private | FSampleBaseIndex: Integer;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Elevation: Single read FElevation write SetElevation;
Published | property Samples: Integer read FSamples write SetSamples default 8;

Description

Fields

Private FSamples: Integer;

This item has no description.

Private FElevation: Single;

This item has no description.

Private FSampleBaseIndex: Integer;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Elevation: Single read FElevation write SetElevation;

This item has no description.

Published property Samples: Integer read FSamples write SetSamples default 8;


GLSysHelp v.2.5: GLS.Imposter: Record TCoronaTangentLookup

Record TCoronaTangentLookup

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TCoronaTangentLookup = record

Description

This item has no description.

Overview

Fields

Public | minTan: Single;
Public | maxTan: Single;
Public | corona: TGLStaticImposterBuilderCorona;

Description

Fields

Public minTan: Single;

This item has no description.

Public maxTan: Single;

This item has no description.

Public corona: TGLStaticImposterBuilderCorona;


GLSysHelp v.2.5: GLS.Imposter: Class TGLStaticImposterBuilderCoronas

Class TGLStaticImposterBuilderCoronas

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TGLStaticImposterBuilderCoronas = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLStaticImposterBuilderCoronas

Overview

Fields

Private FCoronaTangentLookup: array of TCoronaTangentLookup;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add(const elevation: Single; samples: Integer): TGLStaticImposterBuilderCorona; overload;
Public | function Add: TGLStaticImposterBuilderCorona; overload;
Public | function SampleCount: Integer;
Public | procedure EndUpdate; override;
Public | procedure NotifyChange; virtual;

Properties

Public property Items[AIndex: Integer]: TGLStaticImposterBuilderCorona read GetItems write SetItems;

Description

Fields

Private FCoronaTangentLookup: array of TCoronaTangentLookup;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function Add(const elevation: Single; samples: Integer): TGLStaticImposterBuilderCorona; overload;

This item has no description.

Public function Add: TGLStaticImposterBuilderCorona; overload;

This item has no description.

Public function SampleCount: Integer;

This item has no description.

Public procedure EndUpdate; override;

This item has no description.

Public procedure NotifyChange; virtual;

This item has no description.

Properties

Public property Items[AIndex: Integer]: TGLStaticImposterBuilderCorona read GetItems write SetItems;


GLSysHelp v.2.5: GLS.Imposter: Class TStaticImposter

Class TStaticImposter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TStaticImposter = class(TImposter)

Description

Imposter class whose texture contains several views from different angles.

Hierarchy

  • TObject
  • TImposter
  • TStaticImposter

Overview

Methods

Public procedure Render(var rci: TGLRenderContextInfo; const objPos, localCameraPos: TGLVector; size: Single); override;

Description

Methods

Public procedure Render(var rci: TGLRenderContextInfo; const objPos, localCameraPos: TGLVector; size: Single); override;


GLSysHelp v.2.5: GLS.Imposter: Class TGLStaticImposterBuilder

Class TGLStaticImposterBuilder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TGLStaticImposterBuilder = class(TGLImposterBuilder)

Description

Builds imposters whose texture is a catalog of prerendered views.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLImposterBuilder
  • TGLStaticImposterBuilder

Overview

Fields

Private | FCoronas: TGLStaticImposterBuilderCoronas;
Private | FSampleSize: Integer;
Private | FTextureSize: TPoint;
Private | FSamplesPerAxis: TPoint;
Private | FInvSamplesPerAxis: TVector2f;
Private | FSamplingRatioBias: Single;
Private | FInvSamplingRatioBias: Single;
Private | FLighting: TSIBLigthing;
Private | FSamplesAlphaScale: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function TextureFillRatio: Single;
Public | procedure Render(var rci: TGLRenderContextInfo; impostoredObject: TGLBaseSceneObject; destImposter: TImposter);

Properties

Published | property Coronas: TGLStaticImposterBuilderCoronas read FCoronas write SetCoronas;
Published | property Lighting: TSIBLigthing read FLighting write FLighting default siblStaticLighting;
Published | property SamplesAlphaScale: Single read FSamplesAlphaScale write SetSamplesAlphaScale stored StoreSamplesAlphaScale;
Published | property SampleSize: Integer read FSampleSize write SetSampleSize default 32;
Public | property SamplesPerAxis: TPoint read FSamplesPerAxis;
Published | property SamplingRatioBias: Single read FSamplingRatioBias write SetSamplingRatioBias stored StoreSamplingRatioBias;
Public | property TextureSize: TPoint read FTextureSize;
Published | property TextureSizeInfo: string read GetTextureSizeInfo write SetTextureSizeInfo stored False;

Description

Fields

Private FCoronas: TGLStaticImposterBuilderCoronas;

This item has no description.

Private FSampleSize: Integer;

This item has no description.

Private FTextureSize: TPoint;

This item has no description.

Private FSamplesPerAxis: TPoint;

This item has no description.

Private FInvSamplesPerAxis: TVector2f;

This item has no description.

Private FSamplingRatioBias: Single;

This item has no description.

Private FInvSamplingRatioBias: Single;

This item has no description.

Private FLighting: TSIBLigthing;

This item has no description.

Private FSamplesAlphaScale: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TextureFillRatio: Single;

Ratio (0..1) of the texture that will be used by samples. If this value is below 1, you're wasting texture space and may as well increase the number of samples.

Public procedure Render(var rci: TGLRenderContextInfo; impostoredObject: TGLBaseSceneObject; destImposter: TImposter);

Render imposter texture. Buffer and object must be compatible, RC must have been activated.

Properties

Published property Coronas: TGLStaticImposterBuilderCoronas read FCoronas write SetCoronas;

Description of the samples looking orientations.

Published property Lighting: TSIBLigthing read FLighting write FLighting default siblStaticLighting;

Lighting mode to apply during samples construction.

Published property SamplesAlphaScale: Single read FSamplesAlphaScale write SetSamplesAlphaScale stored StoreSamplesAlphaScale;

Scale factor apply to the sample alpha channel. Main use is to saturate the samples alpha channel, and make fully opaque what would have been partially transparent, while leaving fully transparent what was fully transparent.

Published property SampleSize: Integer read FSampleSize write SetSampleSize default 32;

Size of the imposter samples (square).

Public property SamplesPerAxis: TPoint read FSamplesPerAxis;

This item has no description.

Published property SamplingRatioBias: Single read FSamplingRatioBias write SetSamplingRatioBias stored StoreSamplingRatioBias;

Size ratio applied to the impostor'ed objects during sampling. Values greater than one can be used to "fill" the samples more by scaling up the object. This is especially useful when the impostor'ed object doesn't fill its bounding sphere, and/or if the outer details are not relevant for impostoring.

Public property TextureSize: TPoint read FTextureSize;

Meaningful only after imposter texture has been prepared.

Published property TextureSizeInfo: string read GetTextureSizeInfo write SetTextureSizeInfo stored False;

Dummy property that returns the size of the imposter texture. This property is essentially here as a helper at design time, to give you the requirements your coronas and samplesize parameters imply.


GLSysHelp v.2.5: GLS.Imposter: Class TGLDynamicImposterBuilder

Class TGLDynamicImposterBuilder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TGLDynamicImposterBuilder = class(TGLImposterBuilder)

Description

This item has no description. Showing description inherited from TGLImposterBuilder.

Abstract ImposterBuilder class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLImposterBuilder
  • TGLDynamicImposterBuilder

Overview

Fields

Private | FMinTexSize: Integer;
Private | FMaxTexSize: Integer;
Private | FMinDistance: Single;
Private | FTolerance: Single;
Private | FUseMatrixError: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property MaxTexSize: Integer read FMaxTexSize write FMaxTexSize;
Published | property MinDistance: Single read FMinDistance write SetMinDistance;
Published | property MinTexSize: Integer read FMinTexSize write FMinTexSize;
Published | property Tolerance: Single read FTolerance write FTolerance;
Published | property UseMatrixError: Boolean read FUseMatrixError write FUseMatrixError;

Description

Fields

Private FMinTexSize: Integer;

This item has no description.

Private FMaxTexSize: Integer;

This item has no description.

Private FMinDistance: Single;

This item has no description.

Private FTolerance: Single;

This item has no description.

Private FUseMatrixError: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property MaxTexSize: Integer read FMaxTexSize write FMaxTexSize;

This item has no description.

Published property MinDistance: Single read FMinDistance write SetMinDistance;

This item has no description.

Published property MinTexSize: Integer read FMinTexSize write FMinTexSize;

procedure DoRender(var rci : TGLRenderContextInfo; renderSelf, renderChildren : Boolean); override;

Published property Tolerance: Single read FTolerance write FTolerance;

This item has no description.

Published property UseMatrixError: Boolean read FUseMatrixError write FUseMatrixError;


GLSysHelp v.2.5: GLS.Imposter: Class TGLImposter

Class TGLImposter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Imposter

Declaration

type TGLImposter = class(TGLImmaterialSceneObject)

Description

This item has no description. Showing description inherited from TGLImmaterialSceneObject.

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLImposter

Overview

Fields

Private | FBuilder: TGLImposterBuilder;
Private | FImpostoredObject: TGLBaseSceneObject;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property Builder: TGLImposterBuilder read FBuilder write SetBuilder;
Published | property ImpostoredObject: TGLBaseSceneObject read FImpostoredObject write SetImpostoredObject;

Description

Fields

Private FBuilder: TGLImposterBuilder;

This item has no description.

Private FImpostoredObject: TGLBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Properties

Published property Builder: TGLImposterBuilder read FBuilder write SetBuilder;

This item has no description.

Published property ImpostoredObject: TGLBaseSceneObject read FImpostoredObject write SetImpostoredObject;


GLSysHelp v.2.5: GLS.InitOpenGL

Unit GLS.InitOpenGL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • Vcl.Forms
  • System.SysUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLOpenGL |
Class TGLShader |
Class TGLShaderV |
Class TGLShaderG |
Class TGLShaderF |
Class TGLProgram |
Class TGLBuffer |
Class TGLBufferV |
Class TGLBufferI |
Class TGLBufferU |
Class TGLArray |

Variables

GLOpenGL: TGLOpenGL;

Description

Variables

GLOpenGL: TGLOpenGL;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLOpenGL

Class TGLOpenGL

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLOpenGL = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLOpenGL

Overview

Fields

Private | CustomForm: TCustomForm;
Private | _WND: HWND;
Private | _DC: HDC;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | class function DefaultPFD: TPixelFormatDescriptor;
Public | procedure ApplyPixelFormat(const DC_: HDC);
Public | procedure BeginGL;
Public | procedure EndGL;
Public | procedure InitOpenGL;

Properties

Public | property PFD: TPixelFormatDescriptor read _PFD write SetPFD;
Public | property PFI: Integer read _PFI write SetPFI;
Public | property RC: HGLRC read _RC;

Description

Fields

Private CustomForm: TCustomForm;

This item has no description.

Private _WND: HWND;

This item has no description.

Private _DC: HDC;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function DefaultPFD: TPixelFormatDescriptor;

This item has no description.

Public procedure ApplyPixelFormat(const DC_: HDC);

This item has no description.

Public procedure BeginGL;

This item has no description.

Public procedure EndGL;

This item has no description.

Public procedure InitOpenGL;

This item has no description.

Properties

Public property PFD: TPixelFormatDescriptor read _PFD write SetPFD;

This item has no description.

Public property PFI: Integer read _PFI write SetPFI;

This item has no description.

Public property RC: HGLRC read _RC;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLShader

Class TGLShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLShader = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLShader

Overview

Methods

Public | constructor Create(const Kind_: Cardinal);
Public | destructor Destroy; override;
Public | procedure SetSource(const Source_: String);

Properties

Public property ID: Cardinal read _ID;

Description

Methods

Public constructor Create(const Kind_: Cardinal);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure SetSource(const Source_: String);

This item has no description.

Properties

Public property ID: Cardinal read _ID;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLShaderV

Class TGLShaderV

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLShaderV = class(TGLShader)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLShader
  • TGLShaderV

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLShaderG

Class TGLShaderG

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLShaderG = class(TGLShader)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLShader
  • TGLShaderG

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLShaderF

Class TGLShaderF

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLShaderF = class(TGLShader)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLShader
  • TGLShaderF

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLProgram

Class TGLProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLProgram = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLProgram

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure Attach(const Shader_: TGLShader);
Public | procedure Detach(const Shader_: TGLShader);
Public | procedure Link;
Public | procedure Use;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Attach(const Shader_: TGLShader);

This item has no description.

Public procedure Detach(const Shader_: TGLShader);

This item has no description.

Public procedure Link;

This item has no description.

Public procedure Use;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLBuffer

Class TGLBuffer

Description
Hierarchy
Nested Types
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLBuffer<_TYPE_:record> = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBuffer

Overview

Nested Types

Public _PValue_ = ˆ_TYPE_;

Methods

Public | constructor Create(const Kind_: Cardinal);
Public | destructor Destroy; override;
Public | procedure Bind;
Public | procedure Map;
Public | procedure Unbind;
Public | procedure Unmap;

Properties

Public | property Count: Integer read _Count write SetCount;
Public | property ID: Cardinal read _ID;

Description

Nested Types

Public _PValue_ = ˆ_TYPE_;

This item has no description.

Methods

Public constructor Create(const Kind_: Cardinal);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Bind;

This item has no description.

Public procedure Map;

This item has no description.

Public procedure Unbind;

This item has no description.

Public procedure Unmap;

This item has no description.

Properties

Public property Count: Integer read _Count write SetCount;

This item has no description.

Public property ID: Cardinal read _ID;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLBufferV

Class TGLBufferV

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLBufferV<_TYPE_:record> = class(TGLBuffer<_TYPE_>)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBuffer
  • TGLBufferV

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLBufferI

Class TGLBufferI

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLBufferI<_TYPE_:record> = class(TGLBuffer<_TYPE_>)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBuffer
  • TGLBufferI

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLBufferU

Class TGLBufferU

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLBufferU<_TYPE_:record> = class(TGLBuffer<_TYPE_>)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBuffer
  • TGLBufferU

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.InitOpenGL: Class TGLArray

Class TGLArray

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.InitOpenGL

Declaration

type TGLArray = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLArray

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure BeginBind;
Public | procedure EndBind;

Properties

Public property ID: Cardinal read _ID;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BeginBind;

This item has no description.

Public procedure EndBind;

This item has no description.

Properties

Public property ID: Cardinal read _ID;


GLSysHelp v.2.5: GLS.Isolines

Unit GLS.Isolines

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • System.Generics.Collections
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.VectorTypesExt
  • GLScene.Spline
  • GLS.VectorLists
  • GLS.Coordinates
  • GLS.Objects
  • GLS.MultiPolygon
  • GLS.Color
  • GLS.SpaceText
  • GLS.VectorFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLIsoline |
Class TGLIsolines |

Functions and Procedures

procedure Initialize_Contouring(var DataGrid: TMatrixArr; NXpoints, NYpoints: integer; CurrentIsoline: Single);
procedure Release_Memory_Isoline;
function GetNextIsoline(var Isoline: TGLIsoline): Boolean;
procedure TriangleElevationSegments(const p1, p2, p3: TAffineVector; ElevationDelta: Single; Segments: TGLAffineVectorList);

Types

PGLIsoline = ˆTGLIsoline;
PVertex2DArr = ˆTVertex2DArr;
TByteMatrixArr = array of array of Byte;
TByteVectorArr = array of Byte;
TCastArray = array [0 .. 2, 0 .. 2, 0 .. 2] of Integer;
TGLIsolineState = (...);
TMatrixArr = array of array of Single;
TVectorArr = array of Single;
TVectorL4D = array [0 .. 4] of Single;
TVectorL4I = array [0 .. 4] of Integer;
TVertex2DArr = array [0 .. 32767] of TPoint2DRec;

Description

Functions and Procedures

procedure Initialize_Contouring(var DataGrid: TMatrixArr; NXpoints, NYpoints: integer; CurrentIsoline: Single);

This item has no description.

procedure Release_Memory_Isoline;

This item has no description.

function GetNextIsoline(var Isoline: TGLIsoline): Boolean;

This item has no description.

procedure TriangleElevationSegments(const p1, p2, p3: TAffineVector; ElevationDelta: Single; Segments: TGLAffineVectorList);

Defines contouring segments inside a triangle using elevations

Types

PGLIsoline = ˆTGLIsoline;

This item has no description.

PVertex2DArr = ˆTVertex2DArr;

This item has no description.

TByteMatrixArr = array of array of Byte;

This item has no description.

TByteVectorArr = array of Byte;

This item has no description.

TCastArray = array [0 .. 2, 0 .. 2, 0 .. 2] of Integer;

This item has no description.

TGLIsolineState = (...);

This item has no description.

Values
  • ilsEmpty
  • ilsCalculating
  • ilsReady
TMatrixArr = array of array of Single;

This item has no description.

TVectorArr = array of Single;

This item has no description.

TVectorL4D = array [0 .. 4] of Single;

This item has no description.

TVectorL4I = array [0 .. 4] of Integer;

This item has no description.

TVertex2DArr = array [0 .. 32767] of TPoint2DRec;


GLSysHelp v.2.5: GLS.Isolines: Class TGLIsoline

Class TGLIsoline

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Isolines

Declaration

type TGLIsoline = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLIsoline

Overview

Fields

Public | NP: Integer;
Public | Line: PVertex2DArr;

Methods

Public | constructor Create(LineSize: integer); virtual;
Public | destructor Destroy; override;

Description

Fields

Public NP: Integer;

This item has no description.

Public Line: PVertex2DArr;

This item has no description.

Methods

Public constructor Create(LineSize: integer); virtual;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.Isolines: Class TGLIsolines

Class TGLIsolines

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Isolines

Declaration

type TGLIsolines = class(TGLLines)

Description

This item has no description. Showing description inherited from TGLLines.

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLNodedLines
  • TGLLines
  • TGLIsolines

Overview

Fields

Public | IsoVertex: TAffineVector;
Public | GLSpaceTextSF: array of TGLSpaceText;
Private | CoordRange: Integer;
Private | LineList: TList;
Private | IsolineState: TGLIsolineState;

Methods

Public | constructor Create(AOwner: TComponent); virtual;
Public | destructor Destroy; override;
Public | procedure Conrec(PlaneSFindex:Integer; PlaneSF: TGLFreeForm; Data: TMatrixArr; ilb, iub, jlb, jub: Integer; X: TVectorArr; Y: TVectorArr; NC: Integer; HgtL: TVectorArr; Z_Kfix: Single; res3Dmax, res3Dmin: Single);
Public | procedure FreeList;
Public | procedure MakeIsolines(var Depths: TMatrixArr; bmSize: Integer; StartDepth, EndDepth: Single; Interval: Integer);

Description

Fields

Public IsoVertex: TAffineVector;

This item has no description.

Public GLSpaceTextSF: array of TGLSpaceText;

This item has no description.

Private CoordRange: Integer;

This item has no description.

Private LineList: TList;

This item has no description.

Private IsolineState: TGLIsolineState;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Conrec(PlaneSFindex:Integer; PlaneSF: TGLFreeForm; Data: TMatrixArr; ilb, iub, jlb, jub: Integer; X: TVectorArr; Y: TVectorArr; NC: Integer; HgtL: TVectorArr; Z_Kfix: Single; res3Dmax, res3Dmin: Single);

CONREC is a contouring routine for rectangular spaced data or regular 2D grids It takes each rectangle of adjacent data points and splits it into 4 triangles after choosing the height at the centre of the rectangle. For each of the triangles the line segment resulting from the intersection with each contour plane. A routine is then called with the starting and stopping coordinates of the line segment that make up a contour curve and then output these isolines. See details in http://paulbourke.net/papers/conrec/

The input parameters are as follows : PlaneSFindex - PlaneSF - Data - Scalar field in 2D grid ilb - lower bound in west - east direction iub - upper bound in west - east direction jlb - lower bound in north - south direction jub upper bound in north - south direction X - coord. vector for west - east Y - coord. vector for north - south NC - number of cut levels HgtL - values of cut levels Z_Kfix - res3Dmin -

Public procedure FreeList;

This item has no description.

Public procedure MakeIsolines(var Depths: TMatrixArr; bmSize: Integer; StartDepth, EndDepth: Single; Interval: Integer);


GLSysHelp v.2.5: GLS.Isosurface

Unit GLS.Isosurface

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.Mesh
  • GLS.VectorFileObjects
  • GLScene.VectorTypes
  • GLScene.VectorTypesExt

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMarchingCube |
Class TGLIsoSurfaceExtractor |

Functions and Procedures

function SFSphere(X, Y, Z: Extended): TScalarValue;
function SFMinkowski(X, Y, Z: Extended): TScalarValue;
function SFKleinBottle(X, Y, Z: Extended): TScalarValue;
function SFChmutov1(X, Y, Z: Extended): TScalarValue;
function SFChmutov2(X, Y, Z: Extended): TScalarValue;
function SFToroidal(X, Y, Z: Extended): TScalarValue;
function SFDoubleTorus(X, Y, Z: Extended): TScalarValue;

Constants

ALLOC_SIZE = 65536;

Description

Functions and Procedures

function SFSphere(X, Y, Z: Extended): TScalarValue;

Sphere surface

function SFMinkowski(X, Y, Z: Extended): TScalarValue;

Minkowski space (http://mathworld.wolfram.com)

function SFKleinBottle(X, Y, Z: Extended): TScalarValue;

Klein Bottle (http://mathworld.wolfram.com)

function SFChmutov1(X, Y, Z: Extended): TScalarValue;

Chmutov-surface-1 (http://mathworld.wolfram.com)

function SFChmutov2(X, Y, Z: Extended): TScalarValue;

Chmutov-surface-2 (http://mathworld.wolfram.com)

function SFToroidal(X, Y, Z: Extended): TScalarValue;

Toroidal surface (phantasy!)

function SFDoubleTorus(X, Y, Z: Extended): TScalarValue;

Double torus Surface (phantasy!)

Constants

ALLOC_SIZE = 65536;


GLSysHelp v.2.5: GLS.Isosurface: Class TGLMarchingCube

Class TGLMarchingCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Isosurface

Declaration

type TGLMarchingCube = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLMarchingCube

Overview

Fields

Private | FIsoValue: TScalarValue;
Private | PVertsX: PIntegerArray;
Private | PVertsY: PIntegerArray;
Private | PVertsZ: PIntegerArray;
Private | _Nverts: Integer;
Private | _Ntrigs: Integer;
Private | _Sverts: Integer;
Private | _Strigs: Integer;
Private | PVertices: PVertArray;
Private | PTriangles: PTriangleRecArray;
Private | _i: Longword;
Private | _j: Longword;
Private | _k: Longword;
Private | _Cube: array [0 .. 7] of TVoxelRec;
Private | _lut_entry: Byte;
Public | ScalarField: TScalarField;

Methods

Public | constructor Create(SizeX, SizeY, SizeZ: Integer; AIsoValue: TScalarValue = 0.0; xMin: Single = -0.5; xMax: Single = 0.5; yMin: Single = -0.5; yMax: Single = 0.5; zMin: Single = -0.5; zMax: Single = 0.5); overload; virtual;
Public | constructor Create; overload; virtual;
Public | destructor Destroy; override;
Public | function Internal(AValue: TScalarValue): Boolean; virtual;
Public | procedure CalcMeshObject(AMeshObject: TGLMeshObject; Alpha: Single = 1);
Public | procedure CalcVertices(Vertices: TGLVertexList; Alpha: Single = 1);
Public | procedure FillVoxelData(AIsoValue: TScalarValue; AScalarField: TScalarFieldInt); overload; virtual;
Public | procedure FillVoxelData(AIsoValue: TScalarValue; AScalarField: TScalarField = nil); overload; virtual;
Public | procedure FillVoxelData; overload; virtual;
Public | procedure ReDim(ASizeX, ASizeY, ASizeZ: Integer; xMin, xMax, yMin, yMax, zMin, zMax: Single); virtual;
Public | procedure Run(IsoValue: TScalarValue); overload;
Public | procedure Run; overload;
Private | procedure Clean_all(keepFacets: Boolean = False);
Private | procedure Clean_space;
Private | procedure Clean_temps;
Private | procedure Init_all;
Private | procedure Init_space;
Private | procedure Init_temps;
Private | procedure Test_vertex_addiction;

Properties

Public property IsoValue: TScalarValue read FIsoValue write FIsoValue;

Description

Fields

Private FIsoValue: TScalarValue;

This item has no description.

Private PVertsX: PIntegerArray;

sliceSize:Longword;

Private PVertsY: PIntegerArray;

This item has no description.

Private PVertsZ: PIntegerArray;

This item has no description.

Private _Nverts: Integer;

This item has no description.

Private _Ntrigs: Integer;

This item has no description.

Private _Sverts: Integer;

This item has no description.

Private _Strigs: Integer;

This item has no description.

Private PVertices: PVertArray;

This item has no description.

Private PTriangles: PTriangleRecArray;

This item has no description.

Private _i: Longword;

This item has no description.

Private _j: Longword;

This item has no description.

Private _k: Longword;

This item has no description.

Private _Cube: array [0 .. 7] of TVoxelRec;

This item has no description.

Private _lut_entry: Byte;

This item has no description.

Public ScalarField: TScalarField;

This item has no description.

Methods

Public constructor Create(SizeX, SizeY, SizeZ: Integer; AIsoValue: TScalarValue = 0.0; xMin: Single = -0.5; xMax: Single = 0.5; yMin: Single = -0.5; yMax: Single = 0.5; zMin: Single = -0.5; zMax: Single = 0.5); overload; virtual;

This item has no description.

Public constructor Create; overload; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Internal(AValue: TScalarValue): Boolean; virtual;

This item has no description.

Public procedure CalcMeshObject(AMeshObject: TGLMeshObject; Alpha: Single = 1);

This item has no description.

Public procedure CalcVertices(Vertices: TGLVertexList; Alpha: Single = 1);

This item has no description.

Public procedure FillVoxelData(AIsoValue: TScalarValue; AScalarField: TScalarFieldInt); overload; virtual;

This item has no description.

Public procedure FillVoxelData(AIsoValue: TScalarValue; AScalarField: TScalarField = nil); overload; virtual;

This item has no description.

Public procedure FillVoxelData; overload; virtual;

This item has no description.

Public procedure ReDim(ASizeX, ASizeY, ASizeZ: Integer; xMin, xMax, yMin, yMax, zMin, zMax: Single); virtual;

This item has no description.

Public procedure Run(IsoValue: TScalarValue); overload;

This item has no description.

Public procedure Run; overload;

This item has no description.

Private procedure Clean_all(keepFacets: Boolean = False);

This item has no description.

Private procedure Clean_space;

This item has no description.

Private procedure Clean_temps;

This item has no description.

Private procedure Init_all;

This item has no description.

Private procedure Init_space;

This item has no description.

Private procedure Init_temps;

_case:Byte; _config:Byte; _subconfig:Byte;

Private procedure Test_vertex_addiction;

This item has no description.

Properties

Public property IsoValue: TScalarValue read FIsoValue write FIsoValue;


GLSysHelp v.2.5: GLS.Isosurface: Class TGLIsoSurfaceExtractor

Class TGLIsoSurfaceExtractor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Isosurface

Declaration

type TGLIsoSurfaceExtractor = class(TObject)

Description

3D isosurface extractor class. This class allows to calculate and exctract isosurfaces from scalar field voxel models using a given isovalue

Hierarchy

  • TObject
  • TGLIsoSurfaceExtractor

Overview

Fields

Private | Data: TArray3DExt;
Private | Dimensions: array ['x' .. 'z'] of Integer;

Methods

Public | constructor Create(); overload;
Public | constructor Create(Xdim, Ydim, Zdim: Integer; var AData: TArray3DExt); overload;
Public | destructor Destroy(); override;
Private | function BuildIndex(var ADatavals: array of Single; Isovalue: Single): word;
Private | function Interpolate(const V0, V1: TAffineVector; var Val0, Val1, Isovalue: Single; isPolished: boolean): TVertex;
Public | procedure AssignData(Xdim, Ydim, Zdim: Integer; var AData: TArray3DExt);
Public | procedure MarchingCubes(Isovalue: Single; out Vertices: TVertexArray; out Triangles: TIntegerArray; isPolished: boolean);
Public | procedure MarchingTetrahedra(Isovalue: Single; out Vertices: TVertexArray; out Triangles: TIntegerArray; isPolished: boolean);

Description

Fields

Private Data: TArray3DExt;

This item has no description.

Private Dimensions: array ['x' .. 'z'] of Integer;

This item has no description.

Methods

Public constructor Create(); overload;

This item has no description.

Public constructor Create(Xdim, Ydim, Zdim: Integer; var AData: TArray3DExt); overload;

This item has no description.

Public destructor Destroy(); override;

This item has no description.

Private function BuildIndex(var ADatavals: array of Single; Isovalue: Single): word;

Build Index depending on whether the edges are outside or inside the surface

Private function Interpolate(const V0, V1: TAffineVector; var Val0, Val1, Isovalue: Single; isPolished: boolean): TVertex;

This item has no description.

Public procedure AssignData(Xdim, Ydim, Zdim: Integer; var AData: TArray3DExt);

This item has no description.

Public procedure MarchingCubes(Isovalue: Single; out Vertices: TVertexArray; out Triangles: TIntegerArray; isPolished: boolean);

Launch Marching Cubes

Public procedure MarchingTetrahedra(Isovalue: Single; out Vertices: TVertexArray; out Triangles: TIntegerArray; isPolished: boolean);

Launch Marching Tetrahedra


GLSysHelp v.2.5: GLS.Joystick

Unit GLS.Joystick

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • Winapi.MMSystem
  • System.SysUtils
  • System.Classes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLJoystick |

Types

TJoyAxis = (...);
TJoyPos = (...);
TJoystickButton = (...);
TJoystickButtons = set of TJoystickButton;
TJoystickDesignMode = (...);
TJoystickEvent = procedure(Sender: TObject; JoyID: TJoystickID; Buttons: TJoystickButtons; XDeflection, YDeflection: Integer) of Object;
TJoystickID = (...);

Description

Types

TJoyAxis = (...);

This item has no description.

Values
  • jaX
  • jaY
  • jaZ
  • jaR
  • jaU
  • jaV
TJoyPos = (...);

This item has no description.

Values
  • jpMin
  • jpCenter
  • jpMax
TJoystickButton = (...);

This item has no description.

Values
  • jbButton1
  • jbButton2
  • jbButton3
  • jbButton4
TJoystickButtons = set of TJoystickButton;

This item has no description.

TJoystickDesignMode = (...);

This item has no description.

Values
  • jdmInactive
  • jdmActive
TJoystickEvent = procedure(Sender: TObject; JoyID: TJoystickID; Buttons: TJoystickButtons; XDeflection, YDeflection: Integer) of Object;

This item has no description.

TJoystickID = (...);

This item has no description.

Values
  • jidNoJoystick
  • jidJoystick1
  • jidJoystick2


GLSysHelp v.2.5: GLS.Joystick: Class TGLJoystick

Class TGLJoystick

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Joystick

Declaration

type TGLJoystick = class(TComponent)

Description

A component interfacing the Joystick via the (regular) windows API.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLJoystick

Overview

Fields

Private | FWindowHandle: HWND;
Private | FNumButtons: Integer;
Private | FLastX: Integer;
Private | FLastY: Integer;
Private | FLastZ: Integer;
Private | FThreshold: Cardinal;
Private | FInterval: Cardinal;
Private | FCapture: Boolean;
Private | FNoCaptureErrors: Boolean;
Private | FJoystickID: TJoystickID;
Private | FMinMaxInfo: array [TJoyAxis, TJoyPos] of Integer;
Private | FXPosInfo: array [0 .. 4] of Integer;
Private | FYPosInfo: array [0 .. 4] of Integer;
Private | FOnJoystickButtonChange: TJoystickEvent;
Private | FOnJoystickMove: TJoystickEvent;
Private | FXPosition: Integer;
Private | FYPosition: Integer;
Private | FJoyButtons: TJoystickButtons;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetCapture(AValue: Boolean);
Private | procedure SetInterval(AValue: Cardinal);
Private | procedure SetJoystickID(AValue: TJoystickID);
Private | procedure SetThreshold(AValue: Cardinal);

Properties

Published | property Capture: Boolean read FCapture write SetCapture default False;
Published | property Interval: Cardinal read FInterval write SetInterval default 100;
Public | property JoyButtons: TJoystickButtons read FJoyButtons;
Published | property JoystickID: TJoystickID read FJoystickID write SetJoystickID default jidNoJoystick;
Published | property NoCaptureErrors: Boolean read FNoCaptureErrors write FNoCaptureErrors default True;
Published | property OnJoystickButtonChange: TJoystickEvent read FOnJoystickButtonChange write FOnJoystickButtonChange;
Published | property OnJoystickMove: TJoystickEvent read FOnJoystickMove write FOnJoystickMove;
Published | property Threshold: Cardinal read FThreshold write SetThreshold default 1000;
Public | property XPosition: Integer read FXPosition;
Public | property YPosition: Integer read FYPosition;

Description

Fields

Private FWindowHandle: HWND;

This item has no description.

Private FNumButtons: Integer;

This item has no description.

Private FLastX: Integer;

This item has no description.

Private FLastY: Integer;

This item has no description.

Private FLastZ: Integer;

This item has no description.

Private FThreshold: Cardinal;

This item has no description.

Private FInterval: Cardinal;

This item has no description.

Private FCapture: Boolean;

This item has no description.

Private FNoCaptureErrors: Boolean;

This item has no description.

Private FJoystickID: TJoystickID;

This item has no description.

Private FMinMaxInfo: array [TJoyAxis, TJoyPos] of Integer;

This item has no description.

Private FXPosInfo: array [0 .. 4] of Integer;

This item has no description.

Private FYPosInfo: array [0 .. 4] of Integer;

This item has no description.

Private FOnJoystickButtonChange: TJoystickEvent;

This item has no description.

Private FOnJoystickMove: TJoystickEvent;

This item has no description.

Private FXPosition: Integer;

This item has no description.

Private FYPosition: Integer;

This item has no description.

Private FJoyButtons: TJoystickButtons;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetCapture(AValue: Boolean);

This item has no description.

Private procedure SetInterval(AValue: Cardinal);

This item has no description.

Private procedure SetJoystickID(AValue: TJoystickID);

This item has no description.

Private procedure SetThreshold(AValue: Cardinal);

This item has no description.

Properties

Published property Capture: Boolean read FCapture write SetCapture default False;

When set to True, the component attempts to capture the joystick. If capture is successfull, retrieving joystick status is possible, if not, an error message is triggered.

Published property Interval: Cardinal read FInterval write SetInterval default 100;

Polling frequency (milliseconds)

Public property JoyButtons: TJoystickButtons read FJoyButtons;

This item has no description.

Published property JoystickID: TJoystickID read FJoystickID write SetJoystickID default jidNoJoystick;

This item has no description.

Published property NoCaptureErrors: Boolean read FNoCaptureErrors write FNoCaptureErrors default True;

If true joystick capture errors do not result in exceptions.

Published property OnJoystickButtonChange: TJoystickEvent read FOnJoystickButtonChange write FOnJoystickButtonChange;

This item has no description.

Published property OnJoystickMove: TJoystickEvent read FOnJoystickMove write FOnJoystickMove;

This item has no description.

Published property Threshold: Cardinal read FThreshold write SetThreshold default 1000;

This item has no description.

Public property XPosition: Integer read FXPosition;

This item has no description.

Public property YPosition: Integer read FYPosition;


GLSysHelp v.2.5: GLS.LensFlare

Unit GLS.LensFlare

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.BaseClasses
  • GLScene.VectorTypes
  • GLS.Scene
  • GLScene.PipelineTransform
  • GLS.Objects
  • GLS.Context
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.State
  • GLScene.Utils
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFlareGradient |
Class TGLLensFlare |

Types

TGLFlareElement = (...);
TGLFlareElements = set of TGLFlareElement;

Constants

cDefaultFlareElements = [feGlow, feRing, feStreaks, feRays, feSecondaries];

Description

Types

TGLFlareElement = (...);

This item has no description.

Values
  • feGlow
  • feRing
  • feStreaks
  • feRays
  • feSecondaries
TGLFlareElements = set of TGLFlareElement;

This item has no description.

Constants

cDefaultFlareElements = [feGlow, feRing, feStreaks, feRays, feSecondaries];


GLSysHelp v.2.5: GLS.LensFlare: Class TGLFlareGradient

Class TGLFlareGradient

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.LensFlare

Declaration

type TGLFlareGradient = class(TGLUpdateAbleObject)

Description

The actual gradients between two colors are, of course, calculated by OpenGL. The start and end colors of a gradient are stored to represent the color of lens flare elements.

Hierarchy

  • TGLUpdateAbleObject
  • TGLFlareGradient

Overview

Fields

Private | FFromColor: TGLColor;
Private | FToColor: TGLColor;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | constructor CreateInitialized(AOwner: TPersistent; const fromColor, toColor: TGLColorVector);
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property FromColor: TGLColor read FFromColor write SetFromColor;
Published | property ToColor: TGLColor read FToColor write SetToColor;

Description

Fields

Private FFromColor: TGLColor;

This item has no description.

Private FToColor: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public constructor CreateInitialized(AOwner: TPersistent; const fromColor, toColor: TGLColorVector);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property FromColor: TGLColor read FFromColor write SetFromColor;

This item has no description.

Published property ToColor: TGLColor read FToColor write SetToColor;


GLSysHelp v.2.5: GLS.LensFlare: Class TGLLensFlare

Class TGLLensFlare

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.LensFlare

Declaration

type TGLLensFlare = class(TGLBaseSceneObject)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLLensFlare

Overview

Fields

Private | FSize: Integer;
Private | FDeltaTime: Single;
Private | FCurrSize: Single;
Private | FSeed: Integer;
Private | FSqueeze: Single;
Private | FNumStreaks: Integer;
Private | FStreakWidth: Single;
Private | FStreakAngle: Single;
Private | FNumSecs: Integer;
Private | FResolution: Integer;
Private | FAutoZTest: Boolean;
Private | FElements: TGLFlareElements;
Private | FSin20Res: array of Single;
Private | FCos20Res: array of Single;
Private | FSinRes: array of Single;
Private | FCosRes: array of Single;
Private | FTexRays: TGLTextureHandle;
Private | FFlareIsNotOccluded: Boolean;
Private | FOcclusionQuery: TGLOcclusionQueryHandle;
Private | FGlowGradient: TGLFlareGradient;
Private | FRingGradient: TGLFlareGradient;
Private | FStreaksGradient: TGLFlareGradient;
Private | FRaysGradient: TGLFlareGradient;
Private | FSecondariesGradient: TGLFlareGradient;
Private | FDynamic: Boolean;
Private | FPreRenderPoint: TGLRenderPoint;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreRender(activeBuffer: TGLSceneBuffer);

Properties

Published | property AutoZTest: Boolean read FAutoZTest write SetAutoZTest default True;
Published | property Behaviours;
Published | property Dynamic: Boolean read FDynamic write FDynamic default True;
Published | property Effects;
Published | property Elements: TGLFlareElements read FElements write SetElements default cDefaultFlareElements;
Public | property FlareInstantaneousSize: Single read FCurrSize write FCurrSize;
Published | property FlareIsNotOccluded: Boolean read FFlareIsNotOccluded write FFlareIsNotOccluded;
Published | property GlowGradient: TGLFlareGradient read FGlowGradient write SetGlowGradient;
Published | property NumSecs: Integer read FNumSecs write SetNumSecs default 8;
Published | property NumStreaks: Integer read FNumStreaks write SetNumStreaks default 4;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Position;
Published | property PreRenderPoint: TGLRenderPoint read FPreRenderPoint write SetPreRenderPoint;
Published | property RaysGradient: TGLFlareGradient read FRaysGradient;
Published | property Resolution: Integer read FResolution write SetResolution default 64;
Published | property RingGradient: TGLFlareGradient read FRingGradient;
Published | property SecondariesGradient: TGLFlareGradient read FSecondariesGradient;
Published | property Seed: Integer read FSeed write SetSeed;
Published | property Size: Integer read FSize write SetSize default 50;
Published | property Squeeze: Single read FSqueeze write SetSqueeze stored StoreSqueeze;
Published | property StreakAngle: Single read FStreakAngle write SetStreakAngle;
Published | property StreaksGradient: TGLFlareGradient read FStreaksGradient;
Published | property StreakWidth: Single read FStreakWidth write SetStreakWidth stored StoreStreakWidth;
Published | property Visible;

Description

Fields

Private FSize: Integer;

This item has no description.

Private FDeltaTime: Single;

This item has no description.

Private FCurrSize: Single;

This item has no description.

Private FSeed: Integer;

This item has no description.

Private FSqueeze: Single;

This item has no description.

Private FNumStreaks: Integer;

This item has no description.

Private FStreakWidth: Single;

This item has no description.

Private FStreakAngle: Single;

This item has no description.

Private FNumSecs: Integer;

This item has no description.

Private FResolution: Integer;

This item has no description.

Private FAutoZTest: Boolean;

This item has no description.

Private FElements: TGLFlareElements;

This item has no description.

Private FSin20Res: array of Single;

This item has no description.

Private FCos20Res: array of Single;

This item has no description.

Private FSinRes: array of Single;

This item has no description.

Private FCosRes: array of Single;

This item has no description.

Private FTexRays: TGLTextureHandle;

This item has no description.

Private FFlareIsNotOccluded: Boolean;

This item has no description.

Private FOcclusionQuery: TGLOcclusionQueryHandle;

This item has no description.

Private FGlowGradient: TGLFlareGradient;

This item has no description.

Private FRingGradient: TGLFlareGradient;

This item has no description.

Private FStreaksGradient: TGLFlareGradient;

This item has no description.

Private FRaysGradient: TGLFlareGradient;

This item has no description.

Private FSecondariesGradient: TGLFlareGradient;

This item has no description.

Private FDynamic: Boolean;

This item has no description.

Private FPreRenderPoint: TGLRenderPoint;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure PreRender(activeBuffer: TGLSceneBuffer);

Prepares pre-rendered texture to speed up actual rendering. Will use the currently active context as scratch space, and will automatically do nothing if things have already been prepared, thus you can invoke it systematically in a Viewer.BeforeRender event f.i.

Properties

Published property AutoZTest: Boolean read FAutoZTest write SetAutoZTest default True;

Automatically computes FlareIsNotOccluded depending on ZBuffer test. Not that the automated test may use test result from the previous frame into the next (to avoid a rendering stall).

Published property Behaviours;

This item has no description.

Published property Dynamic: Boolean read FDynamic write FDynamic default True;

Is the flare size adjusted dynamically? If true, the flare size will be grown and reduced over a few frames when it switches between occluded and non-occluded states. This requires animation to be active, but results in a smoother appearance. When false, flare will either be at full size or hidden. The flare is always considered non-dynamic at design-time.

Published property Effects;

This item has no description.

Published property Elements: TGLFlareElements read FElements write SetElements default cDefaultFlareElements;

Which elements should be rendered?

Public property FlareInstantaneousSize: Single read FCurrSize write FCurrSize;

Access to the Flare's current size. Flares decay or grow back over several frames, depending on their occlusion status, and this property allows to track or manually alter this instantaneous size.

Published property FlareIsNotOccluded: Boolean read FFlareIsNotOccluded write FFlareIsNotOccluded;

Is the LensFlare not occluded?. If false the flare will fade away, if true, it will fade in and stay. This value is automatically updated if AutoZTest is set.

Published property GlowGradient: TGLFlareGradient read FGlowGradient write SetGlowGradient;

This item has no description.

Published property NumSecs: Integer read FNumSecs write SetNumSecs default 8;

Number of secondary flares.

Published property NumStreaks: Integer read FNumStreaks write SetNumStreaks default 4;

Number of streaks.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Position;

This item has no description.

Published property PreRenderPoint: TGLRenderPoint read FPreRenderPoint write SetPreRenderPoint;

PreRender point for pre-rendered flare textures. See PreRender method for more details.

Published property RaysGradient: TGLFlareGradient read FRaysGradient;

This item has no description.

Published property Resolution: Integer read FResolution write SetResolution default 64;

Number of segments used when rendering circles.

Published property RingGradient: TGLFlareGradient read FRingGradient;

This item has no description.

Published property SecondariesGradient: TGLFlareGradient read FSecondariesGradient;

This item has no description.

Published property Seed: Integer read FSeed write SetSeed;

Random seed

Published property Size: Integer read FSize write SetSize default 50;

MaxRadius of the flare.

Published property Squeeze: Single read FSqueeze write SetSqueeze stored StoreSqueeze;

To create elliptic flares.

Published property StreakAngle: Single read FStreakAngle write SetStreakAngle;

Angle of the streaks (in degrees)

Published property StreaksGradient: TGLFlareGradient read FStreaksGradient;

This item has no description.

Published property StreakWidth: Single read FStreakWidth write SetStreakWidth stored StoreStreakWidth;

Width of the streaks.

Published property Visible;


GLSysHelp v.2.5: GLS.LinePFX

Unit GLS.LinePFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.ParticleFX
  • GLS.Texture
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.Context
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLineParticle |
Class TGLLinePFXManager |


GLSysHelp v.2.5: GLS.LinePFX: Class TGLLineParticle

Class TGLLineParticle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.LinePFX

Declaration

type TGLLineParticle = class(TGLParticle)

Description

Linear particle.

Hierarchy

  • TGLPersistentObject
  • TGLParticle
  • TGLLineParticle

Overview

Fields

Private | FDirection: TAffineVector;
Private | FLength: Single;

Methods

Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Direction: TAffineVector read FDirection write FDirection;
Public | property Length: Single read FLength write FLength;

Description

Fields

Private FDirection: TAffineVector;

This item has no description.

Private FLength: Single;

This item has no description.

Methods

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Direction: TAffineVector read FDirection write FDirection;

Direction of the line.

Public property Length: Single read FLength write FLength;

Length of the line


GLSysHelp v.2.5: GLS.LinePFX: Class TGLLinePFXManager

Class TGLLinePFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.LinePFX

Declaration

type TGLLinePFXManager = class(TGLLifeColoredPFXManager)

Description

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLLinePFXManager

Overview

Fields

Private | Fvx: TAffineVector;
Private | Fvy: TAffineVector;
Private | FNvx: TAffineVector;
Private | FNvy: TAffineVector;
Private | FDefaultLength: Single;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle: TGLParticle; override;
Public | class function ParticlesClass: TGLParticleClass; override;

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property DefaultLength: Single read FDefaultLength write FDefaultLength stored StoreDefaultLength;
Published | property LifeColors;
Published | property ParticleSize;

Description

Fields

Private Fvx: TAffineVector;

This item has no description.

Private Fvy: TAffineVector;

This item has no description.

Private FNvx: TAffineVector;

NOT persistent

Private FNvy: TAffineVector;

NOT persistent

Private FDefaultLength: Single;

NOT persistent

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateParticle: TGLParticle; override;

This item has no description. Showing description inherited from TGLParticleFXManager.CreateParticle.

Creates a new particle controled by the manager.

Public class function ParticlesClass: TGLParticleClass; override;

This item has no description. Showing description inherited from TGLParticleFXManager.ParticlesClass.

Class of particles created by this manager. }

Properties

Published property ColorInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property DefaultLength: Single read FDefaultLength write FDefaultLength stored StoreDefaultLength;

This item has no description.

Published property LifeColors;

This item has no description.

Published property ParticleSize;


GLSysHelp v.2.5: GLS.Material

Unit GLS.Material

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • Vcl.Graphics
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.TextureFormat
  • GLScene.Strings
  • GLS.RenderContextInfo
  • GLS.BaseClasses
  • GLS.Context
  • GLS.Texture
  • GLS.Color
  • GLS.Coordinates
  • GLS.PersistentClasses
  • GLS.State
  • GLS.XOpenGL
  • GLS.ApplicationFileIO
  • GLS.Graphics
  • GLS.ImageUtils
  • GLScene.Utils
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IGLMaterialLibrarySupported |
Class TGLShader |
Class TGLFaceProperties |
Class TGLDepthProperties |
Class TGLBlendingParameters |
Class TGLMaterial |
Class TGLAbstractLibMaterial |
Class TGLLibMaterial |
Class TGLAbstractLibMaterials |
Class TGLLibMaterials |
Class TGLAbstractMaterialLibrary |
Class TGLMaterialLibrary |

Types

TGlAlphaFunc = TGLComparisonFunction;
TGLBlendingMode = (...);
TGLFaceCulling = (...);
TGLLibMaterialName = string;
TGLMaterialOption = (...);
TGLMaterialOptions = set of TGLMaterialOption;
TGLShaderClass = class of TGLShader;
TGLShaderFailedInitAction = (...);
TGLShaderStyle = (...);
TGLShininess = 0..128;

Description

Types

TGlAlphaFunc = TGLComparisonFunction;

This item has no description.

TGLBlendingMode = (...);

Simplified blending options. bmOpaque : disable blending bmTransparency : uses standard alpha blending bmAdditive : activates additive blending (with saturation) bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise) bmAlphaTest100 : uses opaque blending, with alpha-testing at 100% bmModulate : uses modulation blending bmCustom : uses TGLBlendingParameters options

Values
  • bmOpaque
  • bmTransparency
  • bmAdditive
  • bmAlphaTest50
  • bmAlphaTest100
  • bmModulate
  • bmCustom
TGLFaceCulling = (...);

This item has no description.

Values
  • fcBufferDefault
  • fcCull
  • fcNoCull
TGLLibMaterialName = string;

This item has no description.

TGLMaterialOption = (...);

Control special rendering options for a material. moIgnoreFog : fog is deactivated when the material is rendered

Values
  • moIgnoreFog
  • moNoLighting
TGLMaterialOptions = set of TGLMaterialOption;

This item has no description.

TGLShaderClass = class of TGLShader;

This item has no description.

TGLShaderFailedInitAction = (...);

Defines what to do if for some reason shader failed to initialize. fiaSilentdisable: just disable it fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage fiaReRaiseException: Re-raises the exception fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;)

Values
  • fiaSilentDisable
  • fiaRaiseStandardException
  • fiaRaiseHandledException
  • fiaReRaiseException
TGLShaderStyle = (...);

Define GLShader style application relatively to a material. ssHighLevel: shader is applied before material application, and unapplied after material unapplication ssLowLevel: shader is applied after material application, and unapplied before material unapplication ssReplace: shader is applied in place of the material (and material is completely ignored)

Values
  • ssHighLevel
  • ssLowLevel
  • ssReplace
TGLShininess = 0..128;


GLSysHelp v.2.5: GLS.Material: Interface IGLMaterialLibrarySupported

Interface IGLMaterialLibrarySupported

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type IGLMaterialLibrarySupported = interface(IInterface)

Description

an interface for proper TGLLibMaterialNameProperty support

Hierarchy

  • IInterface
  • IGLMaterialLibrarySupported

Overview

Methods

Public function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Description

Methods

Public function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Attributes
GUID['{8E442AF9-D212-4A5E-8A88-92F798BABFD1}']


GLSysHelp v.2.5: GLS.Material: Class TGLShader

Class TGLShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLShader = class(TGLUpdateAbleComponent)

Description

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader

Overview

Fields

Private | FEnabled: Boolean;
Private | FLibMatUsers: TList;
Private | FVirtualHandle: TGLVirtualHandle;
Private | FShaderStyle: TGLShaderStyle;
Private | FUpdateCount: Integer;
Private | FShaderActive: Boolean;
Private | FFailedInitAction: TGLShaderFailedInitAction;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; virtual;
Public | function UnApply(var rci: TGLRenderContextInfo): Boolean;
Public | procedure Apply(var rci: TGLRenderContextInfo; Sender: TObject);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled default True;
Public | property FailedInitAction: TGLShaderFailedInitAction read FFailedInitAction write FFailedInitAction default fiaRaiseStandardException;
Public | property ShaderStyle: TGLShaderStyle read FShaderStyle write FShaderStyle default ssLowLevel;

Description

Fields

Private FEnabled: Boolean;

This item has no description.

Private FLibMatUsers: TList;

This item has no description.

Private FVirtualHandle: TGLVirtualHandle;

This item has no description.

Private FShaderStyle: TGLShaderStyle;

This item has no description.

Private FUpdateCount: Integer;

This item has no description.

Private FShaderActive: Boolean;

This item has no description.

Private FFailedInitAction: TGLShaderFailedInitAction;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ShaderSupported: Boolean; virtual;

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public function UnApply(var rci: TGLRenderContextInfo): Boolean;

UnApply shader. When returning True, the caller is expected to perform a multipass rendering by re-rendering then invoking UnApply again, until a "False" is returned.

Public procedure Apply(var rci: TGLRenderContextInfo; Sender: TObject);

Apply shader to OpenGL state machine.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BeginUpdate;

This item has no description.

Public procedure EndUpdate;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

Subclasses should invoke this function when shader properties are altered. This procedure can also be used to reset/recompile the shader.

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled default True;

Turns on/off shader application. Note that this only turns on/off the shader application, if the ShaderStyle is ssReplace, the material won't be applied even if the shader is disabled.

Public property FailedInitAction: TGLShaderFailedInitAction read FFailedInitAction write FFailedInitAction default fiaRaiseStandardException;

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Public property ShaderStyle: TGLShaderStyle read FShaderStyle write FShaderStyle default ssLowLevel;

Shader application style (default is ssLowLevel).


GLSysHelp v.2.5: GLS.Material: Class TGLFaceProperties

Class TGLFaceProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLFaceProperties = class(TGLUpdateAbleObject)

Description

Stores basic face lighting properties. The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools. You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).

Hierarchy

  • TGLUpdateAbleObject
  • TGLFaceProperties

Overview

Fields

Private | FAmbient: TGLColor;
Private | FDiffuse: TGLColor;
Private | FSpecular: TGLColor;
Private | FEmission: TGLColor;
Private | FShininess: TGLShininess;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var rci: TGLRenderContextInfo; aFace: TGLCullFaceMode); inline;
Public | procedure ApplyNoLighting(var rci: TGLRenderContextInfo; aFace: TGLCullFaceMode); inline;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Ambient: TGLColor read FAmbient write SetAmbient;
Published | property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Published | property Emission: TGLColor read FEmission write SetEmission;
Published | property Shininess: TGLShininess read FShininess write SetShininess default 0;
Published | property Specular: TGLColor read FSpecular write SetSpecular;

Description

Fields

Private FAmbient: TGLColor;

This item has no description.

Private FDiffuse: TGLColor;

This item has no description.

Private FSpecular: TGLColor;

This item has no description.

Private FEmission: TGLColor;

This item has no description.

Private FShininess: TGLShininess;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply(var rci: TGLRenderContextInfo; aFace: TGLCullFaceMode); inline;

This item has no description.

Public procedure ApplyNoLighting(var rci: TGLRenderContextInfo; aFace: TGLCullFaceMode); inline;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Ambient: TGLColor read FAmbient write SetAmbient;

This item has no description.

Published property Diffuse: TGLColor read FDiffuse write SetDiffuse;

This item has no description.

Published property Emission: TGLColor read FEmission write SetEmission;

This item has no description.

Published property Shininess: TGLShininess read FShininess write SetShininess default 0;

This item has no description.

Published property Specular: TGLColor read FSpecular write SetSpecular;


GLSysHelp v.2.5: GLS.Material: Class TGLDepthProperties

Class TGLDepthProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLDepthProperties = class(TGLUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDepthProperties

Overview

Fields

Private | FDepthTest: boolean;
Private | FDepthWrite: boolean;
Private | FZNear: Single;
Private | FZFar: Single;
Private | FCompareFunc: TGLDepthfunction;
Private | FDepthClamp: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | procedure Apply(var rci: TGLRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property DepthClamp: Boolean read FDepthClamp write SetDepthClamp default False;
Published | property DepthCompareFunction: TGLDepthFunction read FCompareFunc write SetCompareFunc default cfLequal;
Published | property DepthTest: boolean read FDepthTest write SetDepthTest default True;
Published | property DepthWrite: boolean read FDepthWrite write SetDepthWrite default True;
Published | property ZFar: Single read FZFar write SetZFar stored StoreZFar;
Published | property ZNear: Single read FZNear write SetZNear stored StoreZNear;

Description

Fields

Private FDepthTest: boolean;

This item has no description.

Private FDepthWrite: boolean;

This item has no description.

Private FZNear: Single;

This item has no description.

Private FZFar: Single;

This item has no description.

Private FCompareFunc: TGLDepthfunction;

This item has no description.

Private FDepthClamp: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public procedure Apply(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property DepthClamp: Boolean read FDepthClamp write SetDepthClamp default False;

Enable clipping depth to the near and far planes

Published property DepthCompareFunction: TGLDepthFunction read FCompareFunc write SetCompareFunc default cfLequal;

Specifies the function used to compare each incoming pixel depth value with the depth value present in the depth buffer.

Published property DepthTest: boolean read FDepthTest write SetDepthTest default True;

DepthTest enabling. When DepthTest is enabled, objects closer to the camera will hide farther ones (via use of Z-Buffering). When DepthTest is disabled, the latest objects drawn/rendered overlap all previous objects, whatever their distance to the camera. Even when DepthTest is enabled, objects may chose to ignore depth testing through the osIgnoreDepthBuffer of their ObjectStyle property.

Published property DepthWrite: boolean read FDepthWrite write SetDepthWrite default True;

If True, object will not write to Z-Buffer.

Published property ZFar: Single read FZFar write SetZFar stored StoreZFar;

Specifies the mapping of the far clipping plane to window coordinates. The initial value is 1.

Published property ZNear: Single read FZNear write SetZNear stored StoreZNear;

Specifies the mapping of the near clipping plane to window coordinates. The initial value is 0.


GLSysHelp v.2.5: GLS.Material: Class TGLBlendingParameters

Class TGLBlendingParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLBlendingParameters = class(TGLUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLBlendingParameters

Overview

Fields

Private | FUseAlphaFunc: Boolean;
Private | FUseBlendFunc: Boolean;
Private | FSeparateBlendFunc: Boolean;
Private | FAlphaFuncType: TGlAlphaFunc;
Private | FAlphaFuncRef: Single;
Private | FBlendFuncSFactor: TGLBlendFunction;
Private | FBlendFuncDFactor: TGLBlendFunction;
Private | FAlphaBlendFuncSFactor: TGLBlendFunction;
Private | FAlphaBlendFuncDFactor: TGLBlendFunction;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function StoreAlphaFuncRef: Boolean;
Public | procedure Apply(var rci: TGLRenderContextInfo); inline;
Private | procedure SetAlphaBlendFuncDFactor(const Value: TGLBlendFunction);
Private | procedure SetAlphaBlendFuncSFactor(const Value: TGLBlendFunction);
Private | procedure SetAlphaFuncRef(const Value: Single);
Private | procedure SetAlphaFuncType(const Value: TGlAlphaFunc);
Private | procedure SetBlendFuncDFactor(const Value: TGLBlendFunction);
Private | procedure SetBlendFuncSFactor(const Value: TGLBlendFunction);
Private | procedure SetSeparateBlendFunc(const Value: Boolean);
Private | procedure SetUseAlphaFunc(const Value: Boolean);
Private | procedure SetUseBlendFunc(const Value: Boolean);

Properties

Published | property AlphaBlendFuncDFactor: TGLBlendFunction read FAlphaBlendFuncDFactor write SetAlphaBlendFuncDFactor default bfOneMinusSrcAlpha;
Published | property AlphaBlendFuncSFactor: TGLBlendFunction read FAlphaBlendFuncSFactor write SetAlphaBlendFuncSFactor default bfSrcAlpha;
Published | property AlphaFuncRef: Single read FAlphaFuncRef write SetAlphaFuncRef stored StoreAlphaFuncRef;
Published | property AlphaFunctType: TGlAlphaFunc read FAlphaFuncType write SetAlphaFuncType default cfGreater;
Published | property BlendFuncDFactor: TGLBlendFunction read FBlendFuncDFactor write SetBlendFuncDFactor default bfOneMinusSrcAlpha;
Published | property BlendFuncSFactor: TGLBlendFunction read FBlendFuncSFactor write SetBlendFuncSFactor default bfSrcAlpha;
Published | property SeparateBlendFunc: Boolean read FSeparateBlendFunc write SetSeparateBlendFunc default False;
Published | property UseAlphaFunc: Boolean read FUseAlphaFunc write SetUseAlphaFunc default False;
Published | property UseBlendFunc: Boolean read FUseBlendFunc write SetUseBlendFunc default True;

Description

Fields

Private FUseAlphaFunc: Boolean;

This item has no description.

Private FUseBlendFunc: Boolean;

This item has no description.

Private FSeparateBlendFunc: Boolean;

This item has no description.

Private FAlphaFuncType: TGlAlphaFunc;

This item has no description.

Private FAlphaFuncRef: Single;

This item has no description.

Private FBlendFuncSFactor: TGLBlendFunction;

This item has no description.

Private FBlendFuncDFactor: TGLBlendFunction;

This item has no description.

Private FAlphaBlendFuncSFactor: TGLBlendFunction;

This item has no description.

Private FAlphaBlendFuncDFactor: TGLBlendFunction;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function StoreAlphaFuncRef: Boolean;

This item has no description.

Public procedure Apply(var rci: TGLRenderContextInfo); inline;

This item has no description.

Private procedure SetAlphaBlendFuncDFactor(const Value: TGLBlendFunction);

This item has no description.

Private procedure SetAlphaBlendFuncSFactor(const Value: TGLBlendFunction);

This item has no description.

Private procedure SetAlphaFuncRef(const Value: Single);

This item has no description.

Private procedure SetAlphaFuncType(const Value: TGlAlphaFunc);

This item has no description.

Private procedure SetBlendFuncDFactor(const Value: TGLBlendFunction);

This item has no description.

Private procedure SetBlendFuncSFactor(const Value: TGLBlendFunction);

This item has no description.

Private procedure SetSeparateBlendFunc(const Value: Boolean);

This item has no description.

Private procedure SetUseAlphaFunc(const Value: Boolean);

This item has no description.

Private procedure SetUseBlendFunc(const Value: Boolean);

This item has no description.

Properties

Published property AlphaBlendFuncDFactor: TGLBlendFunction read FAlphaBlendFuncDFactor write SetAlphaBlendFuncDFactor default bfOneMinusSrcAlpha;

This item has no description.

Published property AlphaBlendFuncSFactor: TGLBlendFunction read FAlphaBlendFuncSFactor write SetAlphaBlendFuncSFactor default bfSrcAlpha;

This item has no description.

Published property AlphaFuncRef: Single read FAlphaFuncRef write SetAlphaFuncRef stored StoreAlphaFuncRef;

This item has no description.

Published property AlphaFunctType: TGlAlphaFunc read FAlphaFuncType write SetAlphaFuncType default cfGreater;

This item has no description.

Published property BlendFuncDFactor: TGLBlendFunction read FBlendFuncDFactor write SetBlendFuncDFactor default bfOneMinusSrcAlpha;

This item has no description.

Published property BlendFuncSFactor: TGLBlendFunction read FBlendFuncSFactor write SetBlendFuncSFactor default bfSrcAlpha;

This item has no description.

Published property SeparateBlendFunc: Boolean read FSeparateBlendFunc write SetSeparateBlendFunc default False;

This item has no description.

Published property UseAlphaFunc: Boolean read FUseAlphaFunc write SetUseAlphaFunc default False;

This item has no description.

Published property UseBlendFunc: Boolean read FUseBlendFunc write SetUseBlendFunc default True;


GLSysHelp v.2.5: GLS.Material: Class TGLMaterial

Class TGLMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLMaterial = class(TGLUpdateAbleObject, IGLMaterialLibrarySupported, IGLTextureNotifyAble)

Description

Describes a rendering material. A material is basically a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping. An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TGLLibMaterial (taken for a material library). The TGLLibMaterial has more advanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps.

Hierarchy

  • TGLUpdateAbleObject
  • TGLMaterial

Overview

Fields

Private | FFrontProperties: TGLFaceProperties;
Private | FBackProperties: TGLFaceProperties;
Private | FDepthProperties: TGLDepthProperties;
Private | FBlendingMode: TGLBlendingMode;
Private | FBlendingParams: TGLBlendingParameters;
Private | FTexture: TGLTexture;
Private | FTextureEx: TGLTextureEx;
Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FLibMaterialName: TGLLibMaterialName;
Private | FMaterialOptions: TGLMaterialOptions;
Private | FFaceCulling: TGLFaceCulling;
Private | FPolygonMode: TGLPolygonMode;
Private | currentLibMaterial: TGLAbstractLibMaterial;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; inline;
Public | function GetActualPrimaryMaterial: TGLMaterial;
Public | function GetActualPrimaryTexture: TGLTexture;
Public | function GetLibMaterial: TGLLibMaterial;
Public | function HasSecondaryTexture: Boolean;
Public | function MaterialIsLinkedToLib: Boolean; inline;
Public | function UnApply(var rci: TGLRenderContextInfo): Boolean; inline;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | procedure Apply(var rci: TGLRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DestroyHandles;
Public | procedure Loaded;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyTexMapChange(Sender: TObject);
Public | procedure PrepareBuildList; inline;
Public | procedure QuickAssignMaterial(const MaterialLibrary: TGLMaterialLibrary; const Material: TGLLibMaterial);

Properties

Published | property BackProperties: TGLFaceProperties read GetBackProperties write SetBackProperties stored StoreMaterialProps;
Published | property BlendingMode: TGLBlendingMode read FBlendingMode write SetBlendingMode stored StoreMaterialProps default bmOpaque;
Published | property BlendingParams: TGLBlendingParameters read FBlendingParams write SetBlendingParams;
Published | property DepthProperties: TGLDepthProperties read FDepthProperties write SetDepthProperties stored StoreMaterialProps;
Published | property FaceCulling: TGLFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;
Published | property FrontProperties: TGLFaceProperties read FFrontProperties write SetFrontProperties stored StoreMaterialProps;
Published | property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property MaterialLibrary: TGLAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MaterialOptions: TGLMaterialOptions read FMaterialOptions write SetMaterialOptions default [];
Published | property PolygonMode: TGLPolygonMode read FPolygonMode write SetPolygonMode default pmFill;
Published | property Texture: TGLTexture read GetTexture write SetTexture stored StoreMaterialProps;
Published | property TextureEx: TGLTextureEx read GetTextureEx write SetTextureEx stored StoreTextureEx;

Description

Fields

Private FFrontProperties: TGLFaceProperties;

This item has no description.

Private FBackProperties: TGLFaceProperties;

This item has no description.

Private FDepthProperties: TGLDepthProperties;

This item has no description.

Private FBlendingMode: TGLBlendingMode;

This item has no description.

Private FBlendingParams: TGLBlendingParameters;

This item has no description.

Private FTexture: TGLTexture;

This item has no description.

Private FTextureEx: TGLTextureEx;

This item has no description.

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FLibMaterialName: TGLLibMaterialName;

This item has no description.

Private FMaterialOptions: TGLMaterialOptions;

This item has no description.

Private FFaceCulling: TGLFaceCulling;

This item has no description.

Private FPolygonMode: TGLPolygonMode;

This item has no description.

Private currentLibMaterial: TGLAbstractLibMaterial;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Blended: Boolean; inline;

Returns True if the material is blended. Will return the libmaterial's blending if it is linked to a material library.

Public function GetActualPrimaryMaterial: TGLMaterial;

Gets the primary Material either from material library or the texture property

Public function GetActualPrimaryTexture: TGLTexture;

Gets the primary texture either from material library or the texture property

Public function GetLibMaterial: TGLLibMaterial;

Return the LibMaterial (see LibMaterialName)

Public function HasSecondaryTexture: Boolean;

True if the material has a secondary texture

Public function MaterialIsLinkedToLib: Boolean; inline;

True if the material comes from the library instead of the texture property

Public function UnApply(var rci: TGLRenderContextInfo): Boolean; inline;

Restore non-standard material states that were altered; A return value of True is a multipass request.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Public procedure Apply(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DestroyHandles;

This item has no description.

Public procedure Loaded;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure NotifyTexMapChange(Sender: TObject);

This item has no description.

Public procedure PrepareBuildList; inline;

This item has no description.

Public procedure QuickAssignMaterial(const MaterialLibrary: TGLMaterialLibrary; const Material: TGLLibMaterial);

This item has no description.

Properties

Published property BackProperties: TGLFaceProperties read GetBackProperties write SetBackProperties stored StoreMaterialProps;

This item has no description.

Published property BlendingMode: TGLBlendingMode read FBlendingMode write SetBlendingMode stored StoreMaterialProps default bmOpaque;

This item has no description.

Published property BlendingParams: TGLBlendingParameters read FBlendingParams write SetBlendingParams;

This item has no description.

Published property DepthProperties: TGLDepthProperties read FDepthProperties write SetDepthProperties stored StoreMaterialProps;

This item has no description.

Published property FaceCulling: TGLFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;

This item has no description.

Published property FrontProperties: TGLFaceProperties read FFrontProperties write SetFrontProperties stored StoreMaterialProps;

This item has no description.

Published property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;

This item has no description.

Published property MaterialLibrary: TGLAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property MaterialOptions: TGLMaterialOptions read FMaterialOptions write SetMaterialOptions default [];

This item has no description.

Published property PolygonMode: TGLPolygonMode read FPolygonMode write SetPolygonMode default pmFill;

This item has no description.

Published property Texture: TGLTexture read GetTexture write SetTexture stored StoreMaterialProps;

This item has no description.

Published property TextureEx: TGLTextureEx read GetTextureEx write SetTextureEx stored StoreTextureEx;


GLSysHelp v.2.5: GLS.Material: Class TGLAbstractLibMaterial

Class TGLAbstractLibMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLAbstractLibMaterial = class(TCollectionItem, IGLMaterialLibrarySupported, IGLNotifyAble)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLAbstractLibMaterial

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; virtual;
Public | function IsUsed: boolean;
Public | function UnApply(var ARci: TGLRenderContextInfo): Boolean; virtual;
Public | procedure Apply(var ARci: TGLRenderContextInfo); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); virtual;
Public | procedure NotifyUsers;
Public | procedure RegisterUser(libMaterial: TGLLibMaterial); overload;
Public | procedure RegisterUser(comp: TGLUpdateAbleComponent); overload;
Public | procedure RegisterUser(obj: TGLUpdateAbleObject); overload;
Public | procedure UnregisterUser(libMaterial: TGLLibMaterial); overload;
Public | procedure UnregisterUser(obj: TGLUpdateAbleObject); overload;
Public | procedure UnregisterUser(comp: TGLUpdateAbleComponent); overload;

Properties

Public | property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary;
Published | property Name: TGLLibMaterialName read FName write SetName;
Public | property NameHashKey: Integer read FNameHashKey;
Published | property Tag: Integer read FTag write FTag;

Description

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Blended: Boolean; virtual;

This item has no description.

Public function IsUsed: boolean;

Returns true if the texture has registed users

Public function UnApply(var ARci: TGLRenderContextInfo): Boolean; virtual;

Restore non-standard material states that were altered

Public procedure Apply(var ARci: TGLRenderContextInfo); virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); virtual;

This item has no description.

Public procedure NotifyUsers;

This item has no description.

Public procedure RegisterUser(libMaterial: TGLLibMaterial); overload;

This item has no description.

Public procedure RegisterUser(comp: TGLUpdateAbleComponent); overload;

This item has no description.

Public procedure RegisterUser(obj: TGLUpdateAbleObject); overload;

This item has no description.

Public procedure UnregisterUser(libMaterial: TGLLibMaterial); overload;

This item has no description.

Public procedure UnregisterUser(obj: TGLUpdateAbleObject); overload;

This item has no description.

Public procedure UnregisterUser(comp: TGLUpdateAbleComponent); overload;

This item has no description.

Properties

Public property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary;

This item has no description.

Published property Name: TGLLibMaterialName read FName write SetName;

This item has no description.

Public property NameHashKey: Integer read FNameHashKey;

This item has no description.

Published property Tag: Integer read FTag write FTag;


GLSysHelp v.2.5: GLS.Material: Class TGLLibMaterial

Class TGLLibMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLLibMaterial = class(TGLAbstractLibMaterial, IGLTextureNotifyAble)

Description

Material in a material library. Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLAbstractLibMaterial
  • TGLLibMaterial

Overview

Fields

Private | FMaterial: TGLMaterial;
Private | FTextureOffset: TGLCoordinates;
Private | FTextureScale: TGLCoordinates;
Private | FTextureRotate: Single;
Private | FTextureMatrixIsIdentity: Boolean;
Private | FTextureOverride: Boolean;
Private | FTextureMatrix: TGLMatrix;
Private | FTexture2Name: TGLLibMaterialName;
Private | FShader: TGLShader;
Private | libMatTexture2: TGLLibMaterial;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; override;
Public | function UnApply(var ARci: TGLRenderContextInfo): Boolean; override;
Public | procedure Apply(var ARci: TGLRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyTexMapChange(Sender: TObject);
Public | procedure NotifyUsersOfTexMapChange;
Public | procedure PrepareBuildList;

Properties

Published | property Material: TGLMaterial read FMaterial write SetMaterial;
Published | property Shader: TGLShader read FShader write SetShader;
Published | property Texture2Name: TGLLibMaterialName read FTexture2Name write SetTexture2Name;
Public | property TextureMatrix: TGLMatrix read FTextureMatrix write SetTextureMatrix;
Public | property TextureMatrixIsIdentity: boolean read FTextureMatrixIsIdentity;
Published | property TextureOffset: TGLCoordinates read FTextureOffset write SetTextureOffset;
Published | property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;
Published | property TextureScale: TGLCoordinates read FTextureScale write SetTextureScale;

Description

Fields

Private FMaterial: TGLMaterial;

This item has no description.

Private FTextureOffset: TGLCoordinates;

This item has no description.

Private FTextureScale: TGLCoordinates;

This item has no description.

Private FTextureRotate: Single;

This item has no description.

Private FTextureMatrixIsIdentity: Boolean;

This item has no description.

Private FTextureOverride: Boolean;

This item has no description.

Private FTextureMatrix: TGLMatrix;

This item has no description.

Private FTexture2Name: TGLLibMaterialName;

This item has no description.

Private FShader: TGLShader;

This item has no description.

Private libMatTexture2: TGLLibMaterial;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Blended: Boolean; override;

This item has no description.

Public function UnApply(var ARci: TGLRenderContextInfo): Boolean; override;

Restore non-standard material states that were altered

Public procedure Apply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyTexMapChange(Sender: TObject);

This item has no description.

Public procedure NotifyUsersOfTexMapChange;

This item has no description.

Public procedure PrepareBuildList;

This item has no description.

Properties

Published property Material: TGLMaterial read FMaterial write SetMaterial;

This item has no description.

Published property Shader: TGLShader read FShader write SetShader;

Optionnal shader for the material.

Published property Texture2Name: TGLLibMaterialName read FTexture2Name write SetTexture2Name;

Reference to the second texture. The referred LibMaterial *must* be in the same material library. Second textures are supported only through ARB multitexturing (ignored if not supported).

Public property TextureMatrix: TGLMatrix read FTextureMatrix write SetTextureMatrix;

This item has no description.

Public property TextureMatrixIsIdentity: boolean read FTextureMatrixIsIdentity;

This item has no description.

Published property TextureOffset: TGLCoordinates read FTextureOffset write SetTextureOffset;

Texture offset in texture coordinates. The offset is applied after scaling

Published property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;

This item has no description.

Published property TextureScale: TGLCoordinates read FTextureScale write SetTextureScale;

Texture coordinates scaling. Scaling is applied <i>before</i> applying the offset, and is applied to the texture coordinates, meaning that a scale factor of (2, 2, 2) will make your texture look twice smaller


GLSysHelp v.2.5: GLS.Material: Class TGLAbstractLibMaterials

Class TGLAbstractLibMaterials

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLAbstractLibMaterials = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLAbstractLibMaterials

Overview

Methods

Public function MakeUniqueName(const nameRoot: TGLLibMaterialName): TGLLibMaterialName;

Description

Methods

Public function MakeUniqueName(const nameRoot: TGLLibMaterialName): TGLLibMaterialName;


GLSysHelp v.2.5: GLS.Material: Class TGLLibMaterials

Class TGLLibMaterials

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLLibMaterials = class(TGLAbstractLibMaterials)

Description

A collection of materials, mainly used in material libraries.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLAbstractLibMaterials
  • TGLLibMaterials

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLLibMaterial;
Public | function FindItemID(ID: Integer): TGLLibMaterial;
Public | function GetLibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterial;
Public | function GetMaterialIndex(const Material: TGLMaterial): Integer;
Public | function GetNameOfLibMaterial(const Material: TGLLibMaterial): TGLLibMaterialName;
Public | function GetNameOfTexture(const Texture: TGLTexture): TGLLibMaterialName;
Public | function GetTextureIndex(const Texture: TGLTexture): Integer;
Public | function IndexOf(const Item: TGLLibMaterial): Integer;
Public | function Owner: TPersistent;
Public | procedure DeleteUnusedMaterials;
Public | procedure PrepareBuildList;

Properties

Public property Items[index: Integer]: TGLLibMaterial read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLLibMaterial;

This item has no description.

Public function FindItemID(ID: Integer): TGLLibMaterial;

This item has no description.

Public function GetLibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterial;

This item has no description.

Public function GetMaterialIndex(const Material: TGLMaterial): Integer;

Returns index of this Material if it exists.

Public function GetNameOfLibMaterial(const Material: TGLLibMaterial): TGLLibMaterialName;

Returns name of this Material if it exists.

Public function GetNameOfTexture(const Texture: TGLTexture): TGLLibMaterialName;

Returns name of this Texture if it exists.

Public function GetTextureIndex(const Texture: TGLTexture): Integer;

Returns index of this Texture if it exists.

Public function IndexOf(const Item: TGLLibMaterial): Integer;

This item has no description.

Public function Owner: TPersistent;

This item has no description.

Public procedure DeleteUnusedMaterials;

Deletes all the unused materials in the collection. A material is considered unused if no other material or updateable object references it. WARNING: For this to work, objects that use the textuere, have to REGISTER to the texture.

Public procedure PrepareBuildList;

This item has no description.

Properties

Public property Items[index: Integer]: TGLLibMaterial read GetItems write SetItems;


GLSysHelp v.2.5: GLS.Material: Class TGLAbstractMaterialLibrary

Class TGLAbstractMaterialLibrary

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLAbstractMaterialLibrary = class(TGLCadenceAbleComponent)

Description

This item has no description.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLAbstractMaterialLibrary

Overview

Methods

Public | function ApplyMaterial(const AName: string; var ARci: TGLRenderContextInfo): Boolean;
Public | function UnApplyMaterial(var ARci: TGLRenderContextInfo): Boolean;
Public | procedure SetNamesToTStrings(AStrings: TStrings);

Description

Methods

Public function ApplyMaterial(const AName: string; var ARci: TGLRenderContextInfo): Boolean;

Applies the material of given name. Returns False if the material could not be found. ake sure this call is balanced with a corresponding UnApplyMaterial (or an assertion will be triggered in the destructor). If a material is already applied, and has not yet been unapplied, an assertion will be triggered.

Public function UnApplyMaterial(var ARci: TGLRenderContextInfo): Boolean;

Un-applies the last applied material. Use this function in conjunction with ApplyMaterial. If no material was applied, an assertion will be triggered.

Public procedure SetNamesToTStrings(AStrings: TStrings);


GLSysHelp v.2.5: GLS.Material: Class TGLMaterialLibrary

Class TGLMaterialLibrary

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Material

Declaration

type TGLMaterialLibrary = class(TGLAbstractMaterialLibrary)

Description

Stores a set of materials, to be used and shared by scene objects. Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time. Materials in a material library also feature advanced control properties like texture coordinates transforms.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLAbstractMaterialLibrary
  • TGLMaterialLibrary

Overview

Fields

Private | FDoNotClearMaterialsOnLoad: Boolean;
Private | FOnTextureNeeded: TGLTextureNeededEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddTextureMaterial(const materialName: string; graphic: TGraphic): TGLLibMaterial; overload;
Public | function AddTextureMaterial(const materialName, fileName: string; persistent: Boolean = True): TGLLibMaterial; overload;
Public | function GetNameOfLibMaterial(const LibMat: TGLLibMaterial): TGLLibMaterialName;
Public | function GetNameOfTexture(const Texture: TGLTexture): TGLLibMaterialName;
Public | function LibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterial;
Public | function TextureByName(const LibMatName: TGLLibMaterialName): TGLTexture;
Public | procedure AddMaterialsFromFile(const fileName: string);
Public | procedure AddMaterialsFromStream(aStream: TStream);
Public | procedure DestroyHandles;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure LoadFromStream(aStream: TStream); virtual;
Public | procedure ReadFromFiler(reader: TGLVirtualReader);
Public | procedure SaveToFile(const fileName: string);
Public | procedure SaveToStream(aStream: TStream); virtual;
Public | procedure WriteToFiler(writer: TGLVirtualWriter);

Properties

Published | property Materials: TGLLibMaterials read GetMaterials write SetMaterials stored StoreMaterials;
Published | property OnTextureNeeded: TGLTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Published | property TexturePaths;

Description

Fields

Private FDoNotClearMaterialsOnLoad: Boolean;

This item has no description.

Private FOnTextureNeeded: TGLTextureNeededEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddTextureMaterial(const materialName: string; graphic: TGraphic): TGLLibMaterial; overload;

Add a "standard" texture material. TGLGraphic based variant.

Public function AddTextureMaterial(const materialName, fileName: string; persistent: Boolean = True): TGLLibMaterial; overload;

Add a "standard" texture material. "standard" means linear texturing mode with mipmaps and texture modulation mode with default-strength color components. If persistent is True, the image will be loaded persistently in memory (via a TGLPersistentImage), if false, it will be unloaded after upload to OpenGL (via TGLPicFileImage).

Public function GetNameOfLibMaterial(const LibMat: TGLLibMaterial): TGLLibMaterialName;

Returns name of Material if any exists.

Public function GetNameOfTexture(const Texture: TGLTexture): TGLLibMaterialName;

Returns name of texture if any exists.

Public function LibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterial;

Returns libMaterial of given name if any exists.

Public function TextureByName(const LibMatName: TGLLibMaterialName): TGLTexture;

Returns Texture of given material's name if any exists.

Public procedure AddMaterialsFromFile(const fileName: string);

This item has no description.

Public procedure AddMaterialsFromStream(aStream: TStream);

This item has no description.

Public procedure DestroyHandles;

This item has no description.

Public procedure LoadFromFile(const fileName: string);

This item has no description.

Public procedure LoadFromStream(aStream: TStream); virtual;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader);

This item has no description.

Public procedure SaveToFile(const fileName: string);

Save library content to a file. Recommended extension : .GLML Currently saves only texture, ambient, diffuse, emission and specular colors.

Public procedure SaveToStream(aStream: TStream); virtual;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter);

This item has no description.

Properties

Published property Materials: TGLLibMaterials read GetMaterials write SetMaterials stored StoreMaterials;

The materials collection.

Published property OnTextureNeeded: TGLTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;

This event is fired whenever a texture needs to be loaded from disk. The event is triggered before even attempting to load the texture, and before TexturePaths is used.

Published property TexturePaths;

Paths to lookup when attempting to load a texture. You can specify multiple paths when loading a texture, the separator being the semi-colon ';' character. Directories are looked up from first to last, the first file name match is used. The current directory is always implicit and checked last. Note that you can also use the OnTextureNeeded event to provide a filename.


GLSysHelp v.2.5: GLS.MaterialEx

Unit GLS.MaterialEx

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Math
  • Vcl.Graphics
  • GLScene.OpenGLTokens
  • GLS.RenderContextInfo
  • GLScene.PipelineTransform
  • GLS.BaseClasses
  • GLS.Context
  • GLScene.VectorTypes
  • GLS.Material
  • GLS.Texture
  • GLS.Color
  • GLS.Coordinates
  • GLScene.VectorGeometry
  • GLS.Graphics
  • GLS.PersistentClasses
  • GLS.State
  • GLScene.TextureFormat
  • GLScene.XCollection
  • GLS.TextureCombiners
  • GLSL.ShaderParameter
  • GLS.ApplicationFileIO
  • GLScene.Strings
  • GLS.ImageUtils
  • GLScene.Utils
  • GLS.XOpenGL
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseMaterialCollectionItem |
Class TGLLibMaterialProperty |
Class TGLTextureSampler |
Class TGLAbstractTexture |
Class TGLTextureImageEx |
Class TGLFrameBufferAttachment |
Class TGLTextureSwizzling |
Class TGLTextureProperties |
Class TGLFixedFunctionProperties |
Class TGLTextureCombiner |
Class TGLASMVertexProgram |
Class TGLMultitexturingProperties |
Class TGLShaderEx |
Class TGLAbstractShaderUniform |
Class TGLShaderUniform |
Class TGLShaderUniformDSA |
Class TGLShaderUniformTexture |
Class TGLBaseShaderModel |
Class TGLShaderModel3 |
Class TGLShaderModel4 |
Class TGLShaderModel5 |
Class TGLLibMaterialEx |
Class TGLLibMaterialsEx |
Class TGLMatLibComponents |
Class TGLMaterialLibraryEx |

Functions and Procedures

procedure RegisterGLMaterialExNameChangeEvent(AEvent: TNotifyEvent);
procedure DeRegisterGLMaterialExNameChangeEvent(AEvent: TNotifyEvent);

Types

CGLAbstractShaderUniform = class of TGLAbstractShaderUniform;
CGLBaseMaterialCollectionItem = class of TGLBaseMaterialCollectionItem;
TGLMaterialComponentName = string;
TGLShaderType = (...);
TLightDir2TexEnvColor = (...);
TMipmapGenerationMode = (...);
TOnAsmProgSetting = procedure(Sender: TGLASMVertexProgram; var ARci: TGLRenderContextInfo) of object;
TOnUniformInitialize = procedure(Sender: TGLBaseShaderModel) of object;
TOnUniformSetting = procedure(Sender: TGLBaseShaderModel; var ARci: TGLRenderContextInfo) of object;

Description

Functions and Procedures

procedure RegisterGLMaterialExNameChangeEvent(AEvent: TNotifyEvent);

This item has no description.

procedure DeRegisterGLMaterialExNameChangeEvent(AEvent: TNotifyEvent);

This item has no description.

Types

CGLAbstractShaderUniform = class of TGLAbstractShaderUniform;

This item has no description.

CGLBaseMaterialCollectionItem = class of TGLBaseMaterialCollectionItem;

This item has no description.

TGLMaterialComponentName = string;

This item has no description.

TGLShaderType = (...);

This item has no description.

Values
  • shtVertex
  • shtControl
  • shtEvaluation
  • shtGeometry
  • shtFragment
TLightDir2TexEnvColor = (...);

This item has no description.

Values
  • l2eNone
  • l2eEnvColor0
  • l2eEnvColor1
  • l2eEnvColor2
  • l2eEnvColor3
TMipmapGenerationMode = (...);

This item has no description.

Values
  • mgmNoMip
  • mgmLeaveExisting
  • mgmOnFly
  • mgmBoxFilter
  • mgmTriangleFilter
  • mgmHermiteFilter
  • mgmBellFilter
  • mgmSplineFilter
  • mgmLanczos3Filter
  • mgmMitchellFilter
TOnAsmProgSetting = procedure(Sender: TGLASMVertexProgram; var ARci: TGLRenderContextInfo) of object;

This item has no description.

TOnUniformInitialize = procedure(Sender: TGLBaseShaderModel) of object;

This item has no description.

TOnUniformSetting = procedure(Sender: TGLBaseShaderModel; var ARci: TGLRenderContextInfo) of object;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLBaseMaterialCollectionItem

Class TGLBaseMaterialCollectionItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLBaseMaterialCollectionItem = class(TXCollectionItem, IGLMaterialLibrarySupported)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem

Overview

Fields

Private | FNameHashKey: Integer;
Private | FUserList: TGLPersistentObjectList;
Private | FDefferedInit: Boolean;
Private | FNotifying: Boolean;
Private | FIsValid: Boolean;

Methods

Public | destructor Destroy; override;
Public | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | function GetUserCount: Integer;
Private | function GetMaterialLibraryEx: TGLMaterialLibraryEx;
Private | function GetUserList: TGLPersistentObjectList;
Public | procedure RegisterUser(AUser: TGLUpdateAbleObject);
Public | procedure UnregisterUser(AUser: TGLUpdateAbleObject);

Properties

Published | property DefferedInit: Boolean read FDefferedInit write FDefferedInit default False;
Public | property IsValid: Boolean read FIsValid;
Public | property MaterialLibrary: TGLMaterialLibraryEx read GetMaterialLibraryEx;
Published | property Name: TGLMaterialComponentName read GetName write SetName;

Description

Fields

Private FNameHashKey: Integer;

This item has no description.

Private FUserList: TGLPersistentObjectList;

This item has no description.

Private FDefferedInit: Boolean;

This item has no description.

Private FNotifying: Boolean;

This item has no description.

Private FIsValid: Boolean;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Public function GetUserCount: Integer;

This item has no description.

Private function GetMaterialLibraryEx: TGLMaterialLibraryEx;

This item has no description.

Private function GetUserList: TGLPersistentObjectList;

This item has no description.

Public procedure RegisterUser(AUser: TGLUpdateAbleObject);

This item has no description.

Public procedure UnregisterUser(AUser: TGLUpdateAbleObject);

This item has no description.

Properties

Published property DefferedInit: Boolean read FDefferedInit write FDefferedInit default False;

Run-time flag, indicate that resource should initialize in case of failure material's level.

Public property IsValid: Boolean read FIsValid;

This item has no description.

Public property MaterialLibrary: TGLMaterialLibraryEx read GetMaterialLibraryEx;

This item has no description.

Published property Name: TGLMaterialComponentName read GetName write SetName;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLLibMaterialProperty

Class TGLLibMaterialProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLLibMaterialProperty = class(TGLUpdateAbleObject, IGLMaterialLibrarySupported)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLibMaterialProperty

Overview

Methods

Public | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled;
Public | property MaterialLibrary: TGLMaterialLibraryEx read GetMaterialLibraryEx;

Description

Methods

Public function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled;

This item has no description.

Public property MaterialLibrary: TGLMaterialLibraryEx read GetMaterialLibraryEx;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLTextureSampler

Class TGLTextureSampler

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLTextureSampler = class(TGLBaseMaterialCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLTextureSampler

Overview

Fields

Private | FHandle: TGLSamplerHandle;
Private | FMinFilter: TGLMinFilter;
Private | FMagFilter: TGLMagFilter;
Private | FFilteringQuality: TGLTextureFilteringQuality;
Private | FLODBias: Integer;
Private | FLODBiasFract: Single;
Private | FWrap: array[0..2] of TGLSeparateTextureWrap;
Private | FBorderColor: TGLColor;
Private | FCompareMode: TGLTextureCompareMode;
Private | FCompareFunc: TGLDepthFunction;
Private | FDecodeSRGB: Boolean;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Private | function GetWrap(Index: Integer): TGLSeparateTextureWrap;
Public | procedure Apply(var ARci: TGLRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TGLRenderContextInfo);
Private | procedure SetBorderColor(const AValue: TGLColor);
Private | procedure SetCompareFunc(AValue: TGLDepthFunction);
Private | procedure SetCompareMode(AValue: TGLTextureCompareMode);
Private | procedure SetDecodeSRGB(AValue: Boolean);
Private | procedure SetFilteringQuality(AValue: TGLTextureFilteringQuality);
Private | procedure SetLODBias(AValue: Integer);
Private | procedure SetMagFilter(AValue: TGLMagFilter);
Private | procedure SetMinFilter(AValue: TGLMinFilter);
Private | procedure SetWrap(Index: Integer; AValue: TGLSeparateTextureWrap);

Properties

Published | property BorderColor: TGLColor read FBorderColor write SetBorderColor;
Published | property CompareFunc: TGLDepthFunction read FCompareFunc write SetCompareFunc default cfLEqual;
Published | property CompareMode: TGLTextureCompareMode read FCompareMode write SetCompareMode default tcmNone;
Published | property FilteringQuality: TGLTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfAnisotropic;
Public | property Handle: TGLSamplerHandle read FHandle;
Published | property LodBias: Integer read FLODBias write SetLODBias default 0;
Published | property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;
Published | property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;
Published | property sRGB_Encode: Boolean read FDecodeSRGB write SetDecodeSRGB default True;
Published | property WrapX: TGLSeparateTextureWrap index 0 read GetWrap write SetWrap default twRepeat;
Published | property WrapY: TGLSeparateTextureWrap index 1 read GetWrap write SetWrap default twRepeat;
Published | property WrapZ: TGLSeparateTextureWrap index 2 read GetWrap write SetWrap default twRepeat;

Description

Fields

Private FHandle: TGLSamplerHandle;

This item has no description.

Private FMinFilter: TGLMinFilter;

This item has no description.

Private FMagFilter: TGLMagFilter;

This item has no description.

Private FFilteringQuality: TGLTextureFilteringQuality;

This item has no description.

Private FLODBias: Integer;

This item has no description.

Private FLODBiasFract: Single;

This item has no description.

Private FWrap: array[0..2] of TGLSeparateTextureWrap;

This item has no description.

Private FBorderColor: TGLColor;

This item has no description.

Private FCompareMode: TGLTextureCompareMode;

This item has no description.

Private FCompareFunc: TGLDepthFunction;

This item has no description.

Private FDecodeSRGB: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private function GetWrap(Index: Integer): TGLSeparateTextureWrap;

This item has no description.

Public procedure Apply(var ARci: TGLRenderContextInfo);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoOnPrepare(Sender: TGLContext); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure UnApply(var ARci: TGLRenderContextInfo);

This item has no description.

Private procedure SetBorderColor(const AValue: TGLColor);

This item has no description.

Private procedure SetCompareFunc(AValue: TGLDepthFunction);

This item has no description.

Private procedure SetCompareMode(AValue: TGLTextureCompareMode);

This item has no description.

Private procedure SetDecodeSRGB(AValue: Boolean);

This item has no description.

Private procedure SetFilteringQuality(AValue: TGLTextureFilteringQuality);

This item has no description.

Private procedure SetLODBias(AValue: Integer);

This item has no description.

Private procedure SetMagFilter(AValue: TGLMagFilter);

This item has no description.

Private procedure SetMinFilter(AValue: TGLMinFilter);

This item has no description.

Private procedure SetWrap(Index: Integer; AValue: TGLSeparateTextureWrap);

This item has no description.

Properties

Published property BorderColor: TGLColor read FBorderColor write SetBorderColor;

Texture border color.

Published property CompareFunc: TGLDepthFunction read FCompareFunc write SetCompareFunc default cfLEqual;

This item has no description.

Published property CompareMode: TGLTextureCompareMode read FCompareMode write SetCompareMode default tcmNone;

Compare mode and function for depth texture

Published property FilteringQuality: TGLTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfAnisotropic;

This item has no description.

Public property Handle: TGLSamplerHandle read FHandle;

This item has no description.

Published property LodBias: Integer read FLODBias write SetLODBias default 0;

Texture LOD bias.

Published property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;

Texture magnification filter.

Published property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;

Texture minification filter.

Published property sRGB_Encode: Boolean read FDecodeSRGB write SetDecodeSRGB default True;

Force retrieving the undecoded sRGB data from the texture and manipulate that directly.

Published property WrapX: TGLSeparateTextureWrap index 0 read GetWrap write SetWrap default twRepeat;

Address mode for the texture.

Published property WrapY: TGLSeparateTextureWrap index 1 read GetWrap write SetWrap default twRepeat;

This item has no description.

Published property WrapZ: TGLSeparateTextureWrap index 2 read GetWrap write SetWrap default twRepeat;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLAbstractTexture

Class TGLAbstractTexture

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLAbstractTexture = class(TGLBaseMaterialCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLAbstractTexture

Overview

Properties

Public | property Handle: TGLTextureHandle read FHandle;
Published | property Shape: TGLTextureTarget read GetTextureTarget;

Description

Properties

Public property Handle: TGLTextureHandle read FHandle;

This item has no description.

Published property Shape: TGLTextureTarget read GetTextureTarget;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLTextureImageEx

Class TGLTextureImageEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLTextureImageEx = class(TGLAbstractTexture)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLAbstractTexture
  • TGLTextureImageEx

Overview

Fields

Private | FCompression: TGLTextureCompression;
Private | FImage: TGLBaseImage;
Private | FImageAlpha: TGLTextureImageAlpha;
Private | FImageBrightness: Single;
Private | FImageGamma: Single;
Private | FHeightToNormalScale: Single;
Private | FSourceFile: string;
Private | FApplyCounter: Integer;
Private | FInternallyStored: Boolean;
Private | FMipGenMode: TMipmapGenerationMode;
Private | FUseStreaming: Boolean;
Private | FBaseLevel: Integer;
Private | FMaxLevel: Integer;
Private | FLastTime: Double;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Private | function StoreBrightness: Boolean;
Private | function StoreGamma: Boolean;
Private | function StoreNormalMapScale: Boolean;
Public | procedure Apply(var ARci: TGLRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TGLRenderContextInfo); override;
Private | procedure CalcLODRange(out AFirstLOD, ALastLOD: Integer);
Private | procedure FullTransfer;
Private | procedure PrepareImage;
Private | procedure SetCompression(const AValue: TGLTextureCompression);
Private | procedure SetImageAlpha(const AValue: TGLTextureImageAlpha);
Private | procedure SetImageBrightness(const AValue: Single);
Private | procedure SetImageGamma(const AValue: Single);
Private | procedure SetInternalFormat(const AValue: TGLInternalFormat);
Private | procedure SetInternallyStored(const AValue: Boolean);
Private | procedure SetMipGenMode(const AValue: TMipmapGenerationMode);
Private | procedure SetNormalMapScale(const AValue: Single);
Private | procedure SetSourceFile(AValue: string);
Private | procedure SetUseStreaming(const AValue: Boolean);
Private | procedure StreamTransfer;

Properties

Published | property Compression: TGLTextureCompression read FCompression write SetCompression default tcDefault;
Published | property HeightToNormalScale: Single read FHeightToNormalScale write SetNormalMapScale stored StoreNormalMapScale;
Published | property ImageAlpha: TGLTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;
Published | property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;
Published | property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;
Published | property InternalDepth: Integer read FDepth;
Published | property InternalFormat: TGLInternalFormat read FInternalFormat write SetInternalFormat default tfRGBA8;
Published | property InternalHeight: Integer read FHeight;
Published | property InternallyStored: Boolean read FInternallyStored write SetInternallyStored default False;
Published | property InternalWidth: Integer read FWidth;
Published | property MipGenMode: TMipmapGenerationMode read FMipGenMode write SetMipGenMode default mgmOnFly;
Published | property SourceFile: string read FSourceFile write SetSourceFile;
Published | property UseStreaming: Boolean read FUseStreaming write SetUseStreaming default False;

Description

Fields

Private FCompression: TGLTextureCompression;

This item has no description.

Private FImage: TGLBaseImage;

This item has no description.

Private FImageAlpha: TGLTextureImageAlpha;

This item has no description.

Private FImageBrightness: Single;

This item has no description.

Private FImageGamma: Single;

This item has no description.

Private FHeightToNormalScale: Single;

This item has no description.

Private FSourceFile: string;

This item has no description.

Private FApplyCounter: Integer;

This item has no description.

Private FInternallyStored: Boolean;

This item has no description.

Private FMipGenMode: TMipmapGenerationMode;

This item has no description.

Private FUseStreaming: Boolean;

This item has no description.

Private FBaseLevel: Integer;

This item has no description.

Private FMaxLevel: Integer;

This item has no description.

Private FLastTime: Double;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private function StoreBrightness: Boolean;

This item has no description.

Private function StoreGamma: Boolean;

This item has no description.

Private function StoreNormalMapScale: Boolean;

This item has no description.

Public procedure Apply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoOnPrepare(Sender: TGLContext); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure UnApply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Private procedure CalcLODRange(out AFirstLOD, ALastLOD: Integer);

This item has no description.

Private procedure FullTransfer;

This item has no description.

Private procedure PrepareImage;

This item has no description.

Private procedure SetCompression(const AValue: TGLTextureCompression);

This item has no description.

Private procedure SetImageAlpha(const AValue: TGLTextureImageAlpha);

This item has no description.

Private procedure SetImageBrightness(const AValue: Single);

This item has no description.

Private procedure SetImageGamma(const AValue: Single);

This item has no description.

Private procedure SetInternalFormat(const AValue: TGLInternalFormat);

This item has no description.

Private procedure SetInternallyStored(const AValue: Boolean);

This item has no description.

Private procedure SetMipGenMode(const AValue: TMipmapGenerationMode);

This item has no description.

Private procedure SetNormalMapScale(const AValue: Single);

This item has no description.

Private procedure SetSourceFile(AValue: string);

This item has no description.

Private procedure SetUseStreaming(const AValue: Boolean);

This item has no description.

Private procedure StreamTransfer;

This item has no description.

Properties

Published property Compression: TGLTextureCompression read FCompression write SetCompression default tcDefault;

Texture compression control. If True the compressed TextureFormat variant (the OpenGL ICD must support GL_ARB_texture_compression, or this option is ignored).

Published property HeightToNormalScale: Single read FHeightToNormalScale write SetNormalMapScale stored StoreNormalMapScale;

Normal Map scaling. Force normal map generation from height map and controls the intensity of the bumps.

Published property ImageAlpha: TGLTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;

Automatic Image Alpha setting. Allows to control how and if the image's Alpha channel (transparency) is computed.

Published property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;

Texture brightness correction. This correction is applied upon loading a TGLTextureImage, it's a simple saturating scaling applied to the RGB components of the 32 bits image, before it is passed to OpenGL, and before gamma correction (if any).

Published property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;

Texture gamma correction. The gamma correction is applied upon loading a TGLTextureImage, applied to the RGB components of the 32 bits image, before it is passed to OpenGL, after brightness correction (if any).

Published property InternalDepth: Integer read FDepth;

This item has no description.

Published property InternalFormat: TGLInternalFormat read FInternalFormat write SetInternalFormat default tfRGBA8;

This item has no description.

Published property InternalHeight: Integer read FHeight;

This item has no description.

Published property InternallyStored: Boolean read FInternallyStored write SetInternallyStored default False;

Force to store image levels in separate files in ready to transfer format

Published property InternalWidth: Integer read FWidth;

Factual texture properties

Published property MipGenMode: TMipmapGenerationMode read FMipGenMode write SetMipGenMode default mgmOnFly;

Mipmap generation mode.

Published property SourceFile: string read FSourceFile write SetSourceFile;

Source file path and name.

Published property UseStreaming: Boolean read FUseStreaming write SetUseStreaming default False;

Enable streaming loading.


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLFrameBufferAttachment

Class TGLFrameBufferAttachment

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLFrameBufferAttachment = class(TGLAbstractTexture)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLAbstractTexture
  • TGLFrameBufferAttachment

Overview

Fields

Private | FRenderBufferHandle: TGLRenderbufferHandle;
Private | FLayered: Boolean;
Private | FCubeMap: Boolean;
Private | FSamples: Integer;
Private | FOnlyWrite: Boolean;
Private | FFixedSamplesLocation: Boolean;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure Apply(var ARci: TGLRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TGLRenderContextInfo); override;
Private | procedure SetCubeMap(AValue: Boolean);
Private | procedure SetDepth(AValue: Integer);
Private | procedure SetFixedSamplesLocation(AValue: Boolean);
Private | procedure SetHeight(AValue: Integer);
Private | procedure SetInternalFormat(const AValue: TGLInternalFormat);
Private | procedure SetLayered(AValue: Boolean);
Private | procedure SetOnlyWrite(AValue: Boolean);
Private | procedure SetSamples(AValue: Integer);
Private | procedure SetWidth(AValue: Integer);

Properties

Published | property CubeMap: Boolean read FCubeMap write SetCubeMap default False;
Published | property FixedSamplesLocation: Boolean read FFixedSamplesLocation write SetFixedSamplesLocation default False;
Published | property InternalDepth: Integer read FDepth write SetDepth default 0;
Published | property InternalFormat: TGLInternalFormat read FInternalFormat write SetInternalFormat default tfRGBA8;
Published | property InternalHeight: Integer read FHeight write SetHeight default 256;
Published | property InternalWidth: Integer read FWidth write SetWidth default 256;
Published | property Layered: Boolean read FLayered write SetLayered default False;
Published | property OnlyWrite: Boolean read FOnlyWrite write SetOnlyWrite default False;
Published | property Samples: Integer read FSamples write SetSamples default -1;

Description

Fields

Private FRenderBufferHandle: TGLRenderbufferHandle;

This item has no description.

Private FLayered: Boolean;

This item has no description.

Private FCubeMap: Boolean;

This item has no description.

Private FSamples: Integer;

This item has no description.

Private FOnlyWrite: Boolean;

This item has no description.

Private FFixedSamplesLocation: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Apply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoOnPrepare(Sender: TGLContext); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure UnApply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Private procedure SetCubeMap(AValue: Boolean);

This item has no description.

Private procedure SetDepth(AValue: Integer);

This item has no description.

Private procedure SetFixedSamplesLocation(AValue: Boolean);

This item has no description.

Private procedure SetHeight(AValue: Integer);

This item has no description.

Private procedure SetInternalFormat(const AValue: TGLInternalFormat);

This item has no description.

Private procedure SetLayered(AValue: Boolean);

This item has no description.

Private procedure SetOnlyWrite(AValue: Boolean);

This item has no description.

Private procedure SetSamples(AValue: Integer);

This item has no description.

Private procedure SetWidth(AValue: Integer);

This item has no description.

Properties

Published property CubeMap: Boolean read FCubeMap write SetCubeMap default False;

Force target be cube map.

Published property FixedSamplesLocation: Boolean read FFixedSamplesLocation write SetFixedSamplesLocation default False;

FixedSamplesLocation flag makes image will use identical sample locations and the same number of samples for all texels in the image, and the sample locations will not depend on the internalformat or size of the image.

Published property InternalDepth: Integer read FDepth write SetDepth default 0;

This item has no description.

Published property InternalFormat: TGLInternalFormat read FInternalFormat write SetInternalFormat default tfRGBA8;

This item has no description.

Published property InternalHeight: Integer read FHeight write SetHeight default 256;

This item has no description.

Published property InternalWidth: Integer read FWidth write SetWidth default 256;

This item has no description.

Published property Layered: Boolean read FLayered write SetLayered default False;

Force targe be texture array.

Published property OnlyWrite: Boolean read FOnlyWrite write SetOnlyWrite default False;

This flag makes use render buffer as target which makes it impossible to read it as texture, but improves efficiency.

Published property Samples: Integer read FSamples write SetSamples default -1;

Number of samples. Positive value makes texture be multisample.


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLTextureSwizzling

Class TGLTextureSwizzling

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLTextureSwizzling = class(TGLUpdateAbleObject)

Description

Swizzle the components of a texture fetches in shader or fixed-function pipeline.

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureSwizzling

Overview

Fields

Private FSwizzles: TglSwizzleVector;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function GetSwizzle(AIndex: Integer): TGLTextureSwizzle;
Private | function StoreSwizzle(AIndex: Integer): Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(AReader: TReader);
Public | procedure WriteToFiler(AWriter: TWriter);
Private | procedure SetSwizzle(AIndex: Integer; AValue: TGLTextureSwizzle);

Properties

Published | property AlphaFrom: TGLTextureSwizzle index 3 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published | property BlueFrom: TGLTextureSwizzle index 2 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published | property GreenFrom: TGLTextureSwizzle index 1 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published | property RedFrom: TGLTextureSwizzle index 0 read GetSwizzle write SetSwizzle stored StoreSwizzle;

Description

Fields

Private FSwizzles: TglSwizzleVector;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function GetSwizzle(AIndex: Integer): TGLTextureSwizzle;

This item has no description.

Private function StoreSwizzle(AIndex: Integer): Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ReadFromFiler(AReader: TReader);

This item has no description.

Public procedure WriteToFiler(AWriter: TWriter);

This item has no description.

Private procedure SetSwizzle(AIndex: Integer; AValue: TGLTextureSwizzle);

This item has no description.

Properties

Published property AlphaFrom: TGLTextureSwizzle index 3 read GetSwizzle write SetSwizzle stored StoreSwizzle;

This item has no description.

Published property BlueFrom: TGLTextureSwizzle index 2 read GetSwizzle write SetSwizzle stored StoreSwizzle;

This item has no description.

Published property GreenFrom: TGLTextureSwizzle index 1 read GetSwizzle write SetSwizzle stored StoreSwizzle;

This item has no description.

Published property RedFrom: TGLTextureSwizzle index 0 read GetSwizzle write SetSwizzle stored StoreSwizzle;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLTextureProperties

Class TGLTextureProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLTextureProperties = class(TGLLibMaterialProperty)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLTextureProperties

Overview

Fields

Private | FLibTextureName: TGLMaterialComponentName;
Private | FLibSamplerName: TGLMaterialComponentName;
Private | FLibTexture: TGLAbstractTexture;
Private | FLibSampler: TGLTextureSampler;
Private | FTextureOffset: TGLCoordinates;
Private | FTextureScale: TGLCoordinates;
Private | FTextureRotate: Single;
Private | FTextureMatrixIsIdentity: Boolean;
Private | FTextureOverride: Boolean;
Private | FTextureMatrix: TGLMatrix;
Private | FMappingMode: TGLTextureMappingMode;
Private | FEnvColor: TGLColor;
Private | FMapSCoordinates: TGLCoordinates4;
Private | FMapTCoordinates: TGLCoordinates4;
Private | FMapRCoordinates: TGLCoordinates4;
Private | FMapQCoordinates: TGLCoordinates4;
Private | FSwizzling: TGLTextureSwizzling;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean;
Private | function GetLibSamplerName: TGLMaterialComponentName;
Private | function GetLibTextureName: TGLMaterialComponentName;
Private | function GetMappingQCoordinates: TGLCoordinates4;
Private | function GetMappingRCoordinates: TGLCoordinates4;
Private | function GetMappingSCoordinates: TGLCoordinates4;
Private | function GetMappingTCoordinates: TGLCoordinates4;
Private | function GetTextureOffset: TGLCoordinates;
Private | function GetTextureScale: TGLCoordinates;
Private | function StoreMappingQCoordinates: Boolean;
Private | function StoreMappingRCoordinates: Boolean;
Private | function StoreMappingSCoordinates: Boolean;
Private | function StoreMappingTCoordinates: Boolean;
Private | function StoreSwizzling: Boolean;
Private | function StoreTextureOffset: Boolean;
Private | function StoreTextureRotate: Boolean;
Private | function StoreTextureScale: Boolean;
Public | procedure Apply(var ARci: TGLRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Notification(Sender: TObject; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TGLRenderContextInfo);
Private | procedure ApplyMappingMode;
Private | procedure CalculateTextureMatrix;
Private | procedure SetEnvColor(const AValue: TGLColor);
Private | procedure SetLibSamplerName(const AValue: TGLMaterialComponentName);
Private | procedure SetLibTextureName(const AValue: TGLMaterialComponentName);
Private | procedure SetMappingMode(const AValue: TGLTextureMappingMode);
Private | procedure SetMappingQCoordinates(const AValue: TGLCoordinates4);
Private | procedure SetMappingRCoordinates(const AValue: TGLCoordinates4);
Private | procedure SetMappingSCoordinates(const AValue: TGLCoordinates4);
Private | procedure SetMappingTCoordinates(const AValue: TGLCoordinates4);
Private | procedure SetSwizzling(const AValue: TGLTextureSwizzling);
Private | procedure SetTextureMatrix(const AValue: TGLMatrix);
Private | procedure SetTextureOffset(const AValue: TGLCoordinates);
Private | procedure SetTextureRotate(AValue: Single);
Private | procedure SetTextureScale(const AValue: TGLCoordinates);
Private | procedure UnApplyMappingMode;

Properties

Published | property EnvColor: TGLColor read FEnvColor write SetEnvColor;
Published | property LibSamplerName: TGLMaterialComponentName read GetLibSamplerName write SetLibSamplerName;
Published | property LibTextureName: TGLMaterialComponentName read GetLibTextureName write SetLibTextureName;
Published | property MappingMode: TGLTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;
Published | property MappingQCoordinates: TGLCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;
Published | property MappingRCoordinates: TGLCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;
Published | property MappingSCoordinates: TGLCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;
Published | property MappingTCoordinates: TGLCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;
Published | property Swizzling: TGLTextureSwizzling read FSwizzling write SetSwizzling stored StoreSwizzling;
Public | property TextureMatrix: TGLMatrix read FTextureMatrix write SetTextureMatrix;
Published | property TextureOffset: TGLCoordinates read GetTextureOffset write SetTextureOffset stored StoreTextureOffset;
Published | property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;
Published | property TextureScale: TGLCoordinates read GetTextureScale write SetTextureScale stored StoreTextureScale;

Description

Fields

Private FLibTextureName: TGLMaterialComponentName;

This item has no description.

Private FLibSamplerName: TGLMaterialComponentName;

This item has no description.

Private FLibTexture: TGLAbstractTexture;

This item has no description.

Private FLibSampler: TGLTextureSampler;

This item has no description.

Private FTextureOffset: TGLCoordinates;

This item has no description.

Private FTextureScale: TGLCoordinates;

This item has no description.

Private FTextureRotate: Single;

This item has no description.

Private FTextureMatrixIsIdentity: Boolean;

This item has no description.

Private FTextureOverride: Boolean;

This item has no description.

Private FTextureMatrix: TGLMatrix;

This item has no description.

Private FMappingMode: TGLTextureMappingMode;

This item has no description.

Private FEnvColor: TGLColor;

This item has no description.

Private FMapSCoordinates: TGLCoordinates4;

This item has no description.

Private FMapTCoordinates: TGLCoordinates4;

This item has no description.

Private FMapRCoordinates: TGLCoordinates4;

This item has no description.

Private FMapQCoordinates: TGLCoordinates4;

This item has no description.

Private FSwizzling: TGLTextureSwizzling;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean;

This item has no description.

Private function GetLibSamplerName: TGLMaterialComponentName;

This item has no description.

Private function GetLibTextureName: TGLMaterialComponentName;

This item has no description.

Private function GetMappingQCoordinates: TGLCoordinates4;

This item has no description.

Private function GetMappingRCoordinates: TGLCoordinates4;

This item has no description.

Private function GetMappingSCoordinates: TGLCoordinates4;

This item has no description.

Private function GetMappingTCoordinates: TGLCoordinates4;

This item has no description.

Private function GetTextureOffset: TGLCoordinates;

This item has no description.

Private function GetTextureScale: TGLCoordinates;

This item has no description.

Private function StoreMappingQCoordinates: Boolean;

This item has no description.

Private function StoreMappingRCoordinates: Boolean;

This item has no description.

Private function StoreMappingSCoordinates: Boolean;

This item has no description.

Private function StoreMappingTCoordinates: Boolean;

This item has no description.

Private function StoreSwizzling: Boolean;

This item has no description.

Private function StoreTextureOffset: Boolean;

This item has no description.

Private function StoreTextureRotate: Boolean;

This item has no description.

Private function StoreTextureScale: Boolean;

This item has no description.

Public procedure Apply(var ARci: TGLRenderContextInfo);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Notification(Sender: TObject; Operation: TOperation); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure UnApply(var ARci: TGLRenderContextInfo);

This item has no description.

Private procedure ApplyMappingMode;

This item has no description.

Private procedure CalculateTextureMatrix;

This item has no description.

Private procedure SetEnvColor(const AValue: TGLColor);

This item has no description.

Private procedure SetLibSamplerName(const AValue: TGLMaterialComponentName);

This item has no description.

Private procedure SetLibTextureName(const AValue: TGLMaterialComponentName);

This item has no description.

Private procedure SetMappingMode(const AValue: TGLTextureMappingMode);

This item has no description.

Private procedure SetMappingQCoordinates(const AValue: TGLCoordinates4);

This item has no description.

Private procedure SetMappingRCoordinates(const AValue: TGLCoordinates4);

This item has no description.

Private procedure SetMappingSCoordinates(const AValue: TGLCoordinates4);

This item has no description.

Private procedure SetMappingTCoordinates(const AValue: TGLCoordinates4);

This item has no description.

Private procedure SetSwizzling(const AValue: TGLTextureSwizzling);

This item has no description.

Private procedure SetTextureMatrix(const AValue: TGLMatrix);

This item has no description.

Private procedure SetTextureOffset(const AValue: TGLCoordinates);

This item has no description.

Private procedure SetTextureRotate(AValue: Single);

This item has no description.

Private procedure SetTextureScale(const AValue: TGLCoordinates);

This item has no description.

Private procedure UnApplyMappingMode;

This item has no description.

Properties

Published property EnvColor: TGLColor read FEnvColor write SetEnvColor;

Texture Environment color.

Published property LibSamplerName: TGLMaterialComponentName read GetLibSamplerName write SetLibSamplerName;

This item has no description.

Published property LibTextureName: TGLMaterialComponentName read GetLibTextureName write SetLibTextureName;

This item has no description.

Published property MappingMode: TGLTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;

Texture coordinates mapping mode. This property controls automatic texture coordinates generation.

Published property MappingQCoordinates: TGLCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;

This item has no description.

Published property MappingRCoordinates: TGLCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;

This item has no description.

Published property MappingSCoordinates: TGLCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;

Texture mapping coordinates mode for S, T, R and Q axis. This property stores the coordinates for automatic texture coordinates generation.

Published property MappingTCoordinates: TGLCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;

This item has no description.

Published property Swizzling: TGLTextureSwizzling read FSwizzling write SetSwizzling stored StoreSwizzling;

Texture color fetching parameters.

Public property TextureMatrix: TGLMatrix read FTextureMatrix write SetTextureMatrix;

This item has no description.

Published property TextureOffset: TGLCoordinates read GetTextureOffset write SetTextureOffset stored StoreTextureOffset;

This item has no description.

Published property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;

Texture coordinates rotating. Rotating is applied after applying offset and scale, and rotate ST direction around R axis.

Published property TextureScale: TGLCoordinates read GetTextureScale write SetTextureScale stored StoreTextureScale;

Texture coordinates scaling. Scaling is applied before applying the offset, and is applied to the texture coordinates, meaning that a scale factor of (2, 2, 2) will make your texture look twice smaller.


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLFixedFunctionProperties

Class TGLFixedFunctionProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLFixedFunctionProperties = class(TGLLibMaterialProperty)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLFixedFunctionProperties

Overview

Fields

Private | FFrontProperties: TGLFaceProperties;
Private | FBackProperties: TGLFaceProperties;
Private | FDepthProperties: TGLDepthProperties;
Private | FBlendingMode: TGLBlendingMode;
Private | FBlendingParams: TGLBlendingParameters;
Private | FTexProp: TGLTextureProperties;
Private | FMaterialOptions: TGLMaterialOptions;
Private | FFaceCulling: TGLFaceCulling;
Private | FPolygonMode: TGLPolygonMode;
Private | FTextureMode: TGLTextureMode;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean;
Private | function GetBackProperties: TGLFaceProperties;
Public | procedure Apply(var ARci: TGLRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure UnApply(var ARci: TGLRenderContextInfo);
Private | procedure SetBackProperties(AValues: TGLFaceProperties);
Private | procedure SetBlendingMode(const AValue: TGLBlendingMode);
Private | procedure SetBlendingParams(const AValue: TGLBlendingParameters);
Private | procedure SetDepthProperties(AValues: TGLDepthProperties);
Private | procedure SetFaceCulling(const AValue: TGLFaceCulling);
Private | procedure SetFrontProperties(AValues: TGLFaceProperties);
Private | procedure SetMaterialOptions(const AValue: TGLMaterialOptions);
Private | procedure SetPolygonMode(AValue: TGLPolygonMode);
Private | procedure SetTexProp(AValue: TGLTextureProperties);
Private | procedure SetTextureMode(AValue: TGLTextureMode);

Properties

Published | property BackProperties: TGLFaceProperties read GetBackProperties write SetBackProperties;
Published | property BlendingMode: TGLBlendingMode read FBlendingMode write SetBlendingMode default bmOpaque;
Published | property BlendingParams: TGLBlendingParameters read FBlendingParams write SetBlendingParams;
Published | property DepthProperties: TGLDepthProperties read FDepthProperties write SetDepthProperties;
Published | property FaceCulling: TGLFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;
Published | property FrontProperties: TGLFaceProperties read FFrontProperties write SetFrontProperties;
Published | property MaterialOptions: TGLMaterialOptions read FMaterialOptions write SetMaterialOptions default [];
Published | property NextPass;
Published | property PolygonMode: TGLPolygonMode read FPolygonMode write SetPolygonMode default pmFill;
Published | property Texture: TGLTextureProperties read FTexProp write SetTexProp;
Published | property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Description

Fields

Private FFrontProperties: TGLFaceProperties;

This item has no description.

Private FBackProperties: TGLFaceProperties;

This item has no description.

Private FDepthProperties: TGLDepthProperties;

This item has no description.

Private FBlendingMode: TGLBlendingMode;

This item has no description.

Private FBlendingParams: TGLBlendingParameters;

This item has no description.

Private FTexProp: TGLTextureProperties;

This item has no description.

Private FMaterialOptions: TGLMaterialOptions;

This item has no description.

Private FFaceCulling: TGLFaceCulling;

This item has no description.

Private FPolygonMode: TGLPolygonMode;

This item has no description.

Private FTextureMode: TGLTextureMode;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Blended: Boolean;

Returns True if the material is blended.

Private function GetBackProperties: TGLFaceProperties;

This item has no description.

Public procedure Apply(var ARci: TGLRenderContextInfo);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure UnApply(var ARci: TGLRenderContextInfo);

This item has no description.

Private procedure SetBackProperties(AValues: TGLFaceProperties);

This item has no description.

Private procedure SetBlendingMode(const AValue: TGLBlendingMode);

This item has no description.

Private procedure SetBlendingParams(const AValue: TGLBlendingParameters);

This item has no description.

Private procedure SetDepthProperties(AValues: TGLDepthProperties);

This item has no description.

Private procedure SetFaceCulling(const AValue: TGLFaceCulling);

This item has no description.

Private procedure SetFrontProperties(AValues: TGLFaceProperties);

This item has no description.

Private procedure SetMaterialOptions(const AValue: TGLMaterialOptions);

This item has no description.

Private procedure SetPolygonMode(AValue: TGLPolygonMode);

This item has no description.

Private procedure SetTexProp(AValue: TGLTextureProperties);

This item has no description.

Private procedure SetTextureMode(AValue: TGLTextureMode);

This item has no description.

Properties

Published property BackProperties: TGLFaceProperties read GetBackProperties write SetBackProperties;

This item has no description.

Published property BlendingMode: TGLBlendingMode read FBlendingMode write SetBlendingMode default bmOpaque;

This item has no description.

Published property BlendingParams: TGLBlendingParameters read FBlendingParams write SetBlendingParams;

This item has no description.

Published property DepthProperties: TGLDepthProperties read FDepthProperties write SetDepthProperties;

This item has no description.

Published property FaceCulling: TGLFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;

This item has no description.

Published property FrontProperties: TGLFaceProperties read FFrontProperties write SetFrontProperties;

This item has no description.

Published property MaterialOptions: TGLMaterialOptions read FMaterialOptions write SetMaterialOptions default [];

This item has no description.

Published property NextPass;

Next pass of FFP.

Published property PolygonMode: TGLPolygonMode read FPolygonMode write SetPolygonMode default pmFill;

This item has no description.

Published property Texture: TGLTextureProperties read FTexProp write SetTexProp;

This item has no description.

Published property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Texture application mode.


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLTextureCombiner

Class TGLTextureCombiner

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLTextureCombiner = class(TGLBaseMaterialCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLTextureCombiner

Overview

Fields

Private | FHandle: TGLVirtualHandle;
Private | FScript: TStringList;
Private | FCommandCache: TCombinerCache;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure DoAllocate(Sender: TGLVirtualHandle; var handle: Cardinal);
Private | procedure DoDeallocate(Sender: TGLVirtualHandle; var handle: Cardinal);
Private | procedure SetScript(AValue: TStringList);

Properties

Published property Script: TStringList read FScript write SetScript;

Description

Fields

Private FHandle: TGLVirtualHandle;

This item has no description.

Private FScript: TStringList;

This item has no description.

Private FCommandCache: TCombinerCache;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoOnPrepare(Sender: TGLContext); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure DoAllocate(Sender: TGLVirtualHandle; var handle: Cardinal);

This item has no description.

Private procedure DoDeallocate(Sender: TGLVirtualHandle; var handle: Cardinal);

This item has no description.

Private procedure SetScript(AValue: TStringList);

This item has no description.

Properties

Published property Script: TStringList read FScript write SetScript;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLASMVertexProgram

Class TGLASMVertexProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLASMVertexProgram = class(TGLBaseMaterialCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLASMVertexProgram

Overview

Fields

Private | FHandle: TGLARBVertexProgramHandle;
Private | FSource: TStringList;
Private | FSourceFile: string;
Private | FInfoLog: string;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Private | function GetHandle: TGLARBVertexProgramHandle;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure SetSource(AValue: TStringList);
Private | procedure SetSourceFile(AValue: string);

Properties

Public | property Handle: TGLARBVertexProgramHandle read GetHandle;
Published | property InfoLog: string read FInfoLog;
Published | property Source: TStringList read FSource write SetSource;
Published | property SourceFile: string read FSourceFile write SetSourceFile;

Description

Fields

Private FHandle: TGLARBVertexProgramHandle;

This item has no description.

Private FSource: TStringList;

This item has no description.

Private FSourceFile: string;

This item has no description.

Private FInfoLog: string;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private function GetHandle: TGLARBVertexProgramHandle;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoOnPrepare(Sender: TGLContext); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure SetSource(AValue: TStringList);

This item has no description.

Private procedure SetSourceFile(AValue: string);

This item has no description.

Properties

Public property Handle: TGLARBVertexProgramHandle read GetHandle;

This item has no description.

Published property InfoLog: string read FInfoLog;

This item has no description.

Published property Source: TStringList read FSource write SetSource;

This item has no description.

Published property SourceFile: string read FSourceFile write SetSourceFile;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLMultitexturingProperties

Class TGLMultitexturingProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLMultitexturingProperties = class(TGLLibMaterialProperty)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLMultitexturingProperties

Overview

Fields

Private | FLibCombiner: TGLTextureCombiner;
Private | FLibAsmProg: TGLASMVertexProgram;
Private | FLibCombinerName: TGLMaterialComponentName;
Private | FLibAsmProgName: TGLMaterialComponentName;
Private | FTexProps: array[0..3] of TGLTextureProperties;
Private | FTextureMode: TGLTextureMode;
Private | FLightDir: TLightDir2TexEnvColor;
Private | FLightSourceIndex: Integer;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean;
Private | function GetLibAsmProgName: string;
Private | function GetLibCombinerName: string;
Private | function GetTexProps(AIndex: Integer): TGLTextureProperties;
Public | procedure Apply(var ARci: TGLRenderContextInfo);
Public | procedure Notification(Sender: TObject; Operation: TOperation); override;
Public | procedure UnApply(var ARci: TGLRenderContextInfo);
Private | procedure SetLibAsmProgName(const AValue: string);
Private | procedure SetLibCombinerName(const AValue: string);
Private | procedure SetLightSourceIndex(AValue: Integer);
Private | procedure SetTexProps(AIndex: Integer; AValue: TGLTextureProperties);
Private | procedure SetTextureMode(AValue: TGLTextureMode);

Properties

Published | property LibAsmProgName: string read GetLibAsmProgName write SetLibAsmProgName;
Published | property LibCombinerName: string read GetLibCombinerName write SetLibCombinerName;
Published | property LightDirTo: TLightDir2TexEnvColor read FLightDir write FLightDir default l2eNone;
Published | property LightSourceIndex: Integer read FLightSourceIndex write SetLightSourceIndex default 0;
Published | property NextPass;
Published | property Texture0: TGLTextureProperties index 0 read GetTexProps write SetTexProps;
Published | property Texture1: TGLTextureProperties index 1 read GetTexProps write SetTexProps;
Published | property Texture2: TGLTextureProperties index 2 read GetTexProps write SetTexProps;
Published | property Texture3: TGLTextureProperties index 3 read GetTexProps write SetTexProps;
Published | property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Description

Fields

Private FLibCombiner: TGLTextureCombiner;

This item has no description.

Private FLibAsmProg: TGLASMVertexProgram;

This item has no description.

Private FLibCombinerName: TGLMaterialComponentName;

This item has no description.

Private FLibAsmProgName: TGLMaterialComponentName;

This item has no description.

Private FTexProps: array[0..3] of TGLTextureProperties;

This item has no description.

Private FTextureMode: TGLTextureMode;

This item has no description.

Private FLightDir: TLightDir2TexEnvColor;

This item has no description.

Private FLightSourceIndex: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean;

This item has no description.

Private function GetLibAsmProgName: string;

This item has no description.

Private function GetLibCombinerName: string;

This item has no description.

Private function GetTexProps(AIndex: Integer): TGLTextureProperties;

This item has no description.

Public procedure Apply(var ARci: TGLRenderContextInfo);

This item has no description.

Public procedure Notification(Sender: TObject; Operation: TOperation); override;

This item has no description.

Public procedure UnApply(var ARci: TGLRenderContextInfo);

This item has no description.

Private procedure SetLibAsmProgName(const AValue: string);

This item has no description.

Private procedure SetLibCombinerName(const AValue: string);

This item has no description.

Private procedure SetLightSourceIndex(AValue: Integer);

This item has no description.

Private procedure SetTexProps(AIndex: Integer; AValue: TGLTextureProperties);

This item has no description.

Private procedure SetTextureMode(AValue: TGLTextureMode);

This item has no description.

Properties

Published property LibAsmProgName: string read GetLibAsmProgName write SetLibAsmProgName;

This item has no description.

Published property LibCombinerName: string read GetLibCombinerName write SetLibCombinerName;

This item has no description.

Published property LightDirTo: TLightDir2TexEnvColor read FLightDir write FLightDir default l2eNone;

Pass light source direction to enviroment color of choosen texture. Vector in model space.

Published property LightSourceIndex: Integer read FLightSourceIndex write SetLightSourceIndex default 0;

Specify index of light source for LightDirTo.

Published property NextPass;

Next pass of combiner.

Published property Texture0: TGLTextureProperties index 0 read GetTexProps write SetTexProps;

This item has no description.

Published property Texture1: TGLTextureProperties index 1 read GetTexProps write SetTexProps;

This item has no description.

Published property Texture2: TGLTextureProperties index 2 read GetTexProps write SetTexProps;

This item has no description.

Published property Texture3: TGLTextureProperties index 3 read GetTexProps write SetTexProps;

This item has no description.

Published property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Texture application mode.


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLShaderEx

Class TGLShaderEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLShaderEx = class(TGLBaseMaterialCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLShaderEx

Overview

Fields

Private | FHandle: array[TGLShaderType] of TGLShaderHandle;
Private | FSource: TStringList;
Private | FSourceFile: string;
Private | FShaderType: TGLShaderType;
Private | FInfoLog: string;
Private | FGeometryInput: TGLgsInTypes;
Private | FGeometryOutput: TGLgsOutTypes;
Private | FGeometryVerticesOut: Integer;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Private | function GetHandle: TGLShaderHandle;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure SetGeometryInput(AValue: TGLgsInTypes);
Private | procedure SetGeometryOutput(AValue: TGLgsOutTypes);
Private | procedure SetGeometryVerticesOut(AValue: Integer);
Private | procedure SetShaderType(AValue: TGLShaderType);
Private | procedure SetSource(AValue: TStringList);
Private | procedure SetSourceFile(AValue: string);

Properties

Published | property GeometryInput: TGLgsInTypes read FGeometryInput write SetGeometryInput default gsInPoints;
Published | property GeometryOutput: TGLgsOutTypes read FGeometryOutput write SetGeometryOutput default gsOutPoints;
Published | property GeometryVerticesOut: Integer read FGeometryVerticesOut write SetGeometryVerticesOut default 1;
Public | property Handle: TGLShaderHandle read GetHandle;
Published | property InfoLog: string read FInfoLog;
Published | property ShaderType: TGLShaderType read FShaderType write SetShaderType default shtVertex;
Published | property Source: TStringList read FSource write SetSource;
Published | property SourceFile: string read FSourceFile write SetSourceFile;

Description

Fields

Private FHandle: array[TGLShaderType] of TGLShaderHandle;

This item has no description.

Private FSource: TStringList;

This item has no description.

Private FSourceFile: string;

This item has no description.

Private FShaderType: TGLShaderType;

This item has no description.

Private FInfoLog: string;

This item has no description.

Private FGeometryInput: TGLgsInTypes;

This item has no description.

Private FGeometryOutput: TGLgsOutTypes;

This item has no description.

Private FGeometryVerticesOut: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private function GetHandle: TGLShaderHandle;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoOnPrepare(Sender: TGLContext); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure SetGeometryInput(AValue: TGLgsInTypes);

This item has no description.

Private procedure SetGeometryOutput(AValue: TGLgsOutTypes);

This item has no description.

Private procedure SetGeometryVerticesOut(AValue: Integer);

This item has no description.

Private procedure SetShaderType(AValue: TGLShaderType);

This item has no description.

Private procedure SetSource(AValue: TStringList);

This item has no description.

Private procedure SetSourceFile(AValue: string);

This item has no description.

Properties

Published property GeometryInput: TGLgsInTypes read FGeometryInput write SetGeometryInput default gsInPoints;

This item has no description.

Published property GeometryOutput: TGLgsOutTypes read FGeometryOutput write SetGeometryOutput default gsOutPoints;

This item has no description.

Published property GeometryVerticesOut: Integer read FGeometryVerticesOut write SetGeometryVerticesOut default 1;

This item has no description.

Public property Handle: TGLShaderHandle read GetHandle;

This item has no description.

Published property InfoLog: string read FInfoLog;

This item has no description.

Published property ShaderType: TGLShaderType read FShaderType write SetShaderType default shtVertex;

This item has no description.

Published property Source: TStringList read FSource write SetSource;

This item has no description.

Published property SourceFile: string read FSourceFile write SetSourceFile;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLAbstractShaderUniform

Class TGLAbstractShaderUniform

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLAbstractShaderUniform = class(TGLUpdateAbleObject, IShaderParameter)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLAbstractShaderUniform


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLShaderUniform

Class TGLShaderUniform

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLShaderUniform = class(TGLAbstractShaderUniform, IShaderParameter)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLAbstractShaderUniform
  • TGLShaderUniform

Overview

Methods

Public | procedure Apply(var ARci: TGLRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetFloatArray(const Values: PGLFloat; Count: Integer); override;
Public | procedure SetIntArray(const Values: PGLInt; Count: Integer); override;
Public | procedure SetUIntArray(const Values: PGLUInt; Count: Integer); override;

Properties

Public | property GLSLType: TGLSLDataType read GetGLSLType;
Public | property Location: Integer read FLocation;
Public | property Name: string read GetName;

Description

Methods

Public procedure Apply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure SetFloatArray(const Values: PGLFloat; Count: Integer); override;

This item has no description.

Public procedure SetIntArray(const Values: PGLInt; Count: Integer); override;

This item has no description.

Public procedure SetUIntArray(const Values: PGLUInt; Count: Integer); override;

This item has no description.

Properties

Public property GLSLType: TGLSLDataType read GetGLSLType;

This item has no description.

Public property Location: Integer read FLocation;

This item has no description.

Public property Name: string read GetName;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLShaderUniformDSA

Class TGLShaderUniformDSA

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLShaderUniformDSA = class(TGLShaderUniform)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLAbstractShaderUniform
  • TGLShaderUniform
  • TGLShaderUniformDSA

Overview

Methods

Public | procedure SetFloatArray(const Values: PGLFloat; Count: Integer); override;
Public | procedure SetIntArray(const Values: PGLInt; Count: Integer); override;
Public | procedure SetUIntArray(const Values: PGLUInt; Count: Integer); override;

Description

Methods

Public procedure SetFloatArray(const Values: PGLFloat; Count: Integer); override;

This item has no description.

Public procedure SetIntArray(const Values: PGLInt; Count: Integer); override;

This item has no description.

Public procedure SetUIntArray(const Values: PGLUInt; Count: Integer); override;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLShaderUniformTexture

Class TGLShaderUniformTexture

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLShaderUniformTexture = class(TGLShaderUniform)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLAbstractShaderUniform
  • TGLShaderUniform
  • TGLShaderUniformTexture

Overview

Fields

Private | FLibTexture: TGLAbstractTexture;
Private | FLibSampler: TGLTextureSampler;
Private | FTarget: TGLTextureTarget;
Private | FSwizzling: TglSwizzleVector;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var ARci: TGLRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Notification(Sender: TObject; Operation: TOperation); override;

Properties

Public | property GLSLSampler: TGLSLSamplerType read GetGLSLSamplerType;
Public | property LibSamplerName: TGLMaterialComponentName read GetSamplerName write SetSamplerName;
Public | property LibTextureName: TGLMaterialComponentName read GetTextureName write SetTextureName;
Public | property Swizzling: TglSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;

Description

Fields

Private FLibTexture: TGLAbstractTexture;

This item has no description.

Private FLibSampler: TGLTextureSampler;

This item has no description.

Private FTarget: TGLTextureTarget;

This item has no description.

Private FSwizzling: TglSwizzleVector;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Notification(Sender: TObject; Operation: TOperation); override;

This item has no description.

Properties

Public property GLSLSampler: TGLSLSamplerType read GetGLSLSamplerType;

This item has no description.

Public property LibSamplerName: TGLMaterialComponentName read GetSamplerName write SetSamplerName;

This item has no description.

Public property LibTextureName: TGLMaterialComponentName read GetTextureName write SetTextureName;

This item has no description.

Public property Swizzling: TglSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLBaseShaderModel

Class TGLBaseShaderModel

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLBaseShaderModel = class(TGLLibMaterialProperty)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLBaseShaderModel

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var ARci: TGLRenderContextInfo); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext);
Public | procedure GetUniformNames(Proc: TGetStrProc);
Public | procedure Notification(Sender: TObject; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TGLRenderContextInfo); virtual;

Properties

Published | property AutoFillOfUniforms: Boolean read FAutoFill write FAutoFill stored False;
Public | property Handle: TGLProgramHandle read FHandle;
Published | property InfoLog: string read FInfoLog;
Public | property IsValid: Boolean read FIsValid;
Published | property NextPass;
Public | property Uniforms[const AName: string]: IShaderParameter read GetUniform;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply(var ARci: TGLRenderContextInfo); virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoOnPrepare(Sender: TGLContext);

This item has no description.

Public procedure GetUniformNames(Proc: TGetStrProc);

This item has no description.

Public procedure Notification(Sender: TObject; Operation: TOperation); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure UnApply(var ARci: TGLRenderContextInfo); virtual;

This item has no description.

Properties

Published property AutoFillOfUniforms: Boolean read FAutoFill write FAutoFill stored False;

Turn on autofill of uniforms

Public property Handle: TGLProgramHandle read FHandle;

This item has no description.

Published property InfoLog: string read FInfoLog;

Compilation info log for design time

Public property IsValid: Boolean read FIsValid;

This item has no description.

Published property NextPass;

This item has no description.

Public property Uniforms[const AName: string]: IShaderParameter read GetUniform;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLShaderModel3

Class TGLShaderModel3

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLShaderModel3 = class(TGLBaseShaderModel)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLBaseShaderModel
  • TGLShaderModel3

Overview

Methods

Public class function IsSupported: Boolean; override;

Properties

Published | property LibFragmentShaderName;
Published | property LibVertexShaderName;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description.

Properties

Published property LibFragmentShaderName;

This item has no description.

Published property LibVertexShaderName;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLShaderModel4

Class TGLShaderModel4

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLShaderModel4 = class(TGLBaseShaderModel)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLBaseShaderModel
  • TGLShaderModel4

Overview

Methods

Public class function IsSupported: Boolean; override;

Properties

Published | property LibFragmentShaderName;
Published | property LibGeometryShaderName;
Published | property LibVertexShaderName;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description.

Properties

Published property LibFragmentShaderName;

This item has no description.

Published property LibGeometryShaderName;

This item has no description.

Published property LibVertexShaderName;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLShaderModel5

Class TGLShaderModel5

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLShaderModel5 = class(TGLBaseShaderModel)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLBaseShaderModel
  • TGLShaderModel5

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Apply(var ARci: TGLRenderContextInfo); override;
Public | procedure UnApply(var ARci: TGLRenderContextInfo); override;

Properties

Published | property LibFragmentShaderName;
Published | property LibGeometryShaderName;
Published | property LibTessControlShaderName;
Published | property LibTessEvalShaderName;
Published | property LibVertexShaderName;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description.

Public procedure Apply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Public procedure UnApply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Properties

Published property LibFragmentShaderName;

This item has no description.

Published property LibGeometryShaderName;

This item has no description.

Published property LibTessControlShaderName;

This item has no description.

Published property LibTessEvalShaderName;

This item has no description.

Published property LibVertexShaderName;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLLibMaterialEx

Class TGLLibMaterialEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLLibMaterialEx = class(TGLAbstractLibMaterial)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLAbstractLibMaterial
  • TGLLibMaterialEx

Overview

Fields

Private | FHandle: TGLVirtualHandle;
Private | FApplicableLevel: TGLMaterialLevel;
Private | FSelectedLevel: TGLMaterialLevel;
Private | FFixedFunc: TGLFixedFunctionProperties;
Private | FMultitexturing: TGLMultitexturingProperties;
Private | FSM3: TGLShaderModel3;
Private | FSM4: TGLShaderModel4;
Private | FSM5: TGLShaderModel5;
Private | FOnAsmProgSetting: TOnAsmProgSetting;
Private | FOnSM3UniformInit: TOnUniformInitialize;
Private | FOnSM3UniformSetting: TOnUniformSetting;
Private | FOnSM4UniformInit: TOnUniformInitialize;
Private | FOnSM4UniformSetting: TOnUniformSetting;
Private | FOnSM5UniformInit: TOnUniformInitialize;
Private | FOnSM5UniformSetting: TOnUniformSetting;
Private | FNextPass: TGLLibMaterialEx;
Private | FStoreAmalgamating: Boolean;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; override;
Public | function UnApply(var ARci: TGLRenderContextInfo): Boolean; override;
Public | procedure Apply(var ARci: TGLRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure DoAllocate(Sender: TGLVirtualHandle; var handle: Cardinal);
Private | procedure DoDeallocate(Sender: TGLVirtualHandle; var handle: Cardinal);
Private | procedure SetFixedFunc(AValue: TGLFixedFunctionProperties);
Private | procedure SetLevel(AValue: TGLMaterialLevel);
Private | procedure SetMultitexturing(AValue: TGLMultitexturingProperties);
Private | procedure SetSM3(AValue: TGLShaderModel3);
Private | procedure SetSM4(AValue: TGLShaderModel4);
Private | procedure SetSM5(AValue: TGLShaderModel5);

Properties

Published | property ApplicableLevel: TGLMaterialLevel read FApplicableLevel write SetLevel default mlAuto;
Published | property FixedFunction: TGLFixedFunctionProperties read FFixedFunc write SetFixedFunc;
Published | property Multitexturing: TGLMultitexturingProperties read FMultitexturing write SetMultitexturing;
Published | property OnAsmProgSetting: TOnAsmProgSetting read FOnAsmProgSetting write FOnAsmProgSetting;
Published | property OnSM3UniformInitialize: TOnUniformInitialize read FOnSM3UniformInit write FOnSM3UniformInit;
Published | property OnSM3UniformSetting: TOnUniformSetting read FOnSM3UniformSetting write FOnSM3UniformSetting;
Published | property OnSM4UniformInitialize: TOnUniformInitialize read FOnSM4UniformInit write FOnSM4UniformInit;
Published | property OnSM4UniformSetting: TOnUniformSetting read FOnSM4UniformSetting write FOnSM4UniformSetting;
Published | property OnSM5UniformInitialize: TOnUniformInitialize read FOnSM5UniformInit write FOnSM5UniformInit;
Published | property OnSM5UniformSetting: TOnUniformSetting read FOnSM5UniformSetting write FOnSM5UniformSetting;
Published | property SelectedLevel: TGLMaterialLevel read FSelectedLevel;
Published | property ShaderModel3: TGLShaderModel3 read FSM3 write SetSM3;
Published | property ShaderModel4: TGLShaderModel4 read FSM4 write SetSM4;
Published | property ShaderModel5: TGLShaderModel5 read FSM5 write SetSM5;

Description

Fields

Private FHandle: TGLVirtualHandle;

This item has no description.

Private FApplicableLevel: TGLMaterialLevel;

This item has no description.

Private FSelectedLevel: TGLMaterialLevel;

This item has no description.

Private FFixedFunc: TGLFixedFunctionProperties;

This item has no description.

Private FMultitexturing: TGLMultitexturingProperties;

This item has no description.

Private FSM3: TGLShaderModel3;

This item has no description.

Private FSM4: TGLShaderModel4;

This item has no description.

Private FSM5: TGLShaderModel5;

This item has no description.

Private FOnAsmProgSetting: TOnAsmProgSetting;

This item has no description.

Private FOnSM3UniformInit: TOnUniformInitialize;

This item has no description.

Private FOnSM3UniformSetting: TOnUniformSetting;

This item has no description.

Private FOnSM4UniformInit: TOnUniformInitialize;

This item has no description.

Private FOnSM4UniformSetting: TOnUniformSetting;

This item has no description.

Private FOnSM5UniformInit: TOnUniformInitialize;

This item has no description.

Private FOnSM5UniformSetting: TOnUniformSetting;

This item has no description.

Private FNextPass: TGLLibMaterialEx;

This item has no description.

Private FStoreAmalgamating: Boolean;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Blended: Boolean; override;

This item has no description.

Public function UnApply(var ARci: TGLRenderContextInfo): Boolean; override;

This item has no description. Showing description inherited from TGLAbstractLibMaterial.UnApply.

Restore non-standard material states that were altered

Public procedure Apply(var ARci: TGLRenderContextInfo); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure DoAllocate(Sender: TGLVirtualHandle; var handle: Cardinal);

This item has no description.

Private procedure DoDeallocate(Sender: TGLVirtualHandle; var handle: Cardinal);

This item has no description.

Private procedure SetFixedFunc(AValue: TGLFixedFunctionProperties);

This item has no description.

Private procedure SetLevel(AValue: TGLMaterialLevel);

This item has no description.

Private procedure SetMultitexturing(AValue: TGLMultitexturingProperties);

This item has no description.

Private procedure SetSM3(AValue: TGLShaderModel3);

This item has no description.

Private procedure SetSM4(AValue: TGLShaderModel4);

This item has no description.

Private procedure SetSM5(AValue: TGLShaderModel5);

This item has no description.

Properties

Published property ApplicableLevel: TGLMaterialLevel read FApplicableLevel write SetLevel default mlAuto;

This item has no description.

Published property FixedFunction: TGLFixedFunctionProperties read FFixedFunc write SetFixedFunc;

This item has no description.

Published property Multitexturing: TGLMultitexturingProperties read FMultitexturing write SetMultitexturing;

This item has no description.

Published property OnAsmProgSetting: TOnAsmProgSetting read FOnAsmProgSetting write FOnAsmProgSetting;

Asm vertex program event

Published property OnSM3UniformInitialize: TOnUniformInitialize read FOnSM3UniformInit write FOnSM3UniformInit;

Shader model 3 event

Published property OnSM3UniformSetting: TOnUniformSetting read FOnSM3UniformSetting write FOnSM3UniformSetting;

This item has no description.

Published property OnSM4UniformInitialize: TOnUniformInitialize read FOnSM4UniformInit write FOnSM4UniformInit;

Shader model 4 event

Published property OnSM4UniformSetting: TOnUniformSetting read FOnSM4UniformSetting write FOnSM4UniformSetting;

This item has no description.

Published property OnSM5UniformInitialize: TOnUniformInitialize read FOnSM5UniformInit write FOnSM5UniformInit;

Shader model 5 event

Published property OnSM5UniformSetting: TOnUniformSetting read FOnSM5UniformSetting write FOnSM5UniformSetting;

This item has no description.

Published property SelectedLevel: TGLMaterialLevel read FSelectedLevel;

This item has no description.

Published property ShaderModel3: TGLShaderModel3 read FSM3 write SetSM3;

This item has no description.

Published property ShaderModel4: TGLShaderModel4 read FSM4 write SetSM4;

This item has no description.

Published property ShaderModel5: TGLShaderModel5 read FSM5 write SetSM5;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLLibMaterialsEx

Class TGLLibMaterialsEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLLibMaterialsEx = class(TGLAbstractLibMaterials)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLAbstractLibMaterials
  • TGLLibMaterialsEx

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLLibMaterialEx;
Public | function FindItemID(ID: Integer): TGLLibMaterialEx;
Public | function GetLibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterialEx;
Public | function IndexOf(const Item: TGLLibMaterialEx): Integer;
Public | function MaterialLibrary: TGLMaterialLibraryEx;

Properties

Public property Items[index: Integer]: TGLLibMaterialEx read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLLibMaterialEx;

This item has no description.

Public function FindItemID(ID: Integer): TGLLibMaterialEx;

This item has no description.

Public function GetLibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterialEx;

This item has no description.

Public function IndexOf(const Item: TGLLibMaterialEx): Integer;

This item has no description.

Public function MaterialLibrary: TGLMaterialLibraryEx;

This item has no description.

Properties

Public property Items[index: Integer]: TGLLibMaterialEx read GetItems write SetItems;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLMatLibComponents

Class TGLMatLibComponents

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLMatLibComponents = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLMatLibComponents

Overview

Methods

Public | function GetAsmProgByName(const AName: TGLMaterialComponentName): TGLASMVertexProgram;
Public | function GetAttachmentByName(const AName: TGLMaterialComponentName): TGLFrameBufferAttachment;
Public | function GetCombinerByName(const AName: TGLMaterialComponentName): TGLTextureCombiner;
Public | function GetItemByName(const AName: TGLMaterialComponentName): TGLBaseMaterialCollectionItem;
Public | function GetNamePath: string; override;
Public | function GetSamplerByName(const AName: TGLMaterialComponentName): TGLTextureSampler;
Public | function GetShaderByName(const AName: TGLMaterialComponentName): TGLShaderEx;
Public | function GetTextureByName(const AName: TGLMaterialComponentName): TGLAbstractTexture;
Public | class function ItemsClass: TXCollectionItemClass; override;
Public | function MakeUniqueName(const AName: TGLMaterialComponentName): TGLMaterialComponentName;

Properties

Public property Items[index: Integer]: TGLBaseMaterialCollectionItem read GetItems;

Description

Methods

Public function GetAsmProgByName(const AName: TGLMaterialComponentName): TGLASMVertexProgram;

This item has no description.

Public function GetAttachmentByName(const AName: TGLMaterialComponentName): TGLFrameBufferAttachment;

This item has no description.

Public function GetCombinerByName(const AName: TGLMaterialComponentName): TGLTextureCombiner;

This item has no description.

Public function GetItemByName(const AName: TGLMaterialComponentName): TGLBaseMaterialCollectionItem;

This item has no description.

Public function GetNamePath: string; override;

This item has no description.

Public function GetSamplerByName(const AName: TGLMaterialComponentName): TGLTextureSampler;

This item has no description.

Public function GetShaderByName(const AName: TGLMaterialComponentName): TGLShaderEx;

This item has no description.

Public function GetTextureByName(const AName: TGLMaterialComponentName): TGLAbstractTexture;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public function MakeUniqueName(const AName: TGLMaterialComponentName): TGLMaterialComponentName;

This item has no description.

Properties

Public property Items[index: Integer]: TGLBaseMaterialCollectionItem read GetItems;


GLSysHelp v.2.5: GLS.MaterialEx: Class TGLMaterialLibraryEx

Class TGLMaterialLibraryEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialEx

Declaration

type TGLMaterialLibraryEx = class(TGLAbstractMaterialLibrary)

Description

This item has no description.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLAbstractMaterialLibrary
  • TGLMaterialLibraryEx

Overview

Fields

Private FComponents: TGLMatLibComponents;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddAsmProg(const AName: TGLMaterialComponentName): TGLASMVertexProgram;
Public | function AddAttachment(const AName: TGLMaterialComponentName): TGLFrameBufferAttachment;
Public | function AddCombiner(const AName: TGLMaterialComponentName): TGLTextureCombiner;
Public | function AddSampler(const AName: TGLMaterialComponentName): TGLTextureSampler;
Public | function AddShader(const AName: TGLMaterialComponentName): TGLShaderEx;
Public | function AddTexture(const AName: TGLMaterialComponentName): TGLTextureImageEx;
Public | procedure GetNames(Proc: TGetStrProc; AClass: CGLBaseMaterialCollectionItem); overload;
Public | procedure SetLevelForAll(const ALevel: TGLMaterialLevel);

Properties

Published | property Components: TGLMatLibComponents read FComponents write SetComponents;
Published | property Materials: TGLLibMaterialsEx read GetMaterials write SetMaterials stored StoreMaterials;
Published | property TexturePaths;

Description

Fields

Private FComponents: TGLMatLibComponents;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddAsmProg(const AName: TGLMaterialComponentName): TGLASMVertexProgram;

This item has no description.

Public function AddAttachment(const AName: TGLMaterialComponentName): TGLFrameBufferAttachment;

This item has no description.

Public function AddCombiner(const AName: TGLMaterialComponentName): TGLTextureCombiner;

This item has no description.

Public function AddSampler(const AName: TGLMaterialComponentName): TGLTextureSampler;

This item has no description.

Public function AddShader(const AName: TGLMaterialComponentName): TGLShaderEx;

This item has no description.

Public function AddTexture(const AName: TGLMaterialComponentName): TGLTextureImageEx;

This item has no description.

Public procedure GetNames(Proc: TGetStrProc; AClass: CGLBaseMaterialCollectionItem); overload;

This item has no description.

Public procedure SetLevelForAll(const ALevel: TGLMaterialLevel);

This item has no description.

Properties

Published property Components: TGLMatLibComponents read FComponents write SetComponents;

This item has no description.

Published property Materials: TGLLibMaterialsEx read GetMaterials write SetMaterials stored StoreMaterials;

The materials collection.

Published property TexturePaths;


GLSysHelp v.2.5: GLS.MaterialMultiProxy

Unit GLS.MaterialMultiProxy

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLS.Scene
  • GLScene.VectorGeometry
  • GLS.Texture
  • GLS.Material
  • GLS.Silhouette
  • GLScene.Strings
  • GLS.PersistentClasses
  • GLS.RenderContextInfo
  • GLS.BaseClasses
  • GLS.Context
  • GLScene.VectorTypes
  • GLScene.PipelineTransform

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMaterialMultiProxyMaster |
Class TGLMaterialMultiProxyMasters |
Class TGLMaterialMultiProxy |


GLSysHelp v.2.5: GLS.MaterialMultiProxy: Class TGLMaterialMultiProxyMaster

Class TGLMaterialMultiProxyMaster

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialMultiProxy

Declaration

type TGLMaterialMultiProxyMaster = class(TGLInterfacedCollectionItem, IGLMaterialLibrarySupported)

Description

MasterObject description for a MultiProxy object.

Hierarchy

  • TGLInterfacedCollectionItem
  • TGLMaterialMultiProxyMaster

Overview

Fields

Private | FMasterObject: TGLBaseSceneObject;
Private | FMasterLibMaterial: TGLLibMaterial;
Private | FTempLibMaterialName: TGLLibMaterialName;
Private | FDistanceMin2: Single;
Private | FDistanceMax2: Single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerObject: TGLMaterialMultiProxy;
Private | function GetMasterLibMaterialName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;
Private | procedure SetMasterLibMaterialName(const Value: TGLLibMaterialName);

Properties

Published | property DistanceMax: Single read GetDistanceMax write SetDistanceMax;
Published | property DistanceMin: Single read GetDistanceMin write SetDistanceMin;
Public | property MasterLibMaterial: TGLLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;
Published | property MasterLibMaterialName: TGLLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;
Published | property MasterObject: TGLBaseSceneObject read FMasterObject write SetMasterObject;

Description

Fields

Private FMasterObject: TGLBaseSceneObject;

This item has no description.

Private FMasterLibMaterial: TGLLibMaterial;

This item has no description.

Private FTempLibMaterialName: TGLLibMaterialName;

This item has no description.

Private FDistanceMin2: Single;

This item has no description.

Private FDistanceMax2: Single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OwnerObject: TGLMaterialMultiProxy;

This item has no description.

Private function GetMasterLibMaterialName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Private procedure SetMasterLibMaterialName(const Value: TGLLibMaterialName);

This item has no description.

Properties

Published property DistanceMax: Single read GetDistanceMax write SetDistanceMax;

Maximum visibility Distance (exclusive).

Published property DistanceMin: Single read GetDistanceMin write SetDistanceMin;

Minimum visibility Distance (inclusive).

Public property MasterLibMaterial: TGLLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;

Specifies the Material, that current master object will use. Provides a faster way to access FMasterLibMaterial, compared to MasterLibMaterialName

Published property MasterLibMaterialName: TGLLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;

Specifies the Material, that current master object will use.

Published property MasterObject: TGLBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.


GLSysHelp v.2.5: GLS.MaterialMultiProxy: Class TGLMaterialMultiProxyMasters

Class TGLMaterialMultiProxyMasters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialMultiProxy

Declaration

type TGLMaterialMultiProxyMasters = class(TOwnedCollection)

Description

Collection of TGLMaterialMultiProxyMaster.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLMaterialMultiProxyMasters

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add(Master: TGLBaseSceneObject; MasterLibMaterial: TGLLibMaterial; DistanceMin, DistanceMax: Single): TGLMaterialMultiProxyMaster; overload;
Public | function Add(Master: TGLBaseSceneObject; DistanceMin, DistanceMax: Single): TGLMaterialMultiProxyMaster; overload;
Public | function Add: TGLMaterialMultiProxyMaster; overload;
Public | procedure EndUpdate; override;
Public | procedure NotifyChange;

Properties

Public property Items[index: Integer]: TGLMaterialMultiProxyMaster read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function Add(Master: TGLBaseSceneObject; MasterLibMaterial: TGLLibMaterial; DistanceMin, DistanceMax: Single): TGLMaterialMultiProxyMaster; overload;

This item has no description.

Public function Add(Master: TGLBaseSceneObject; DistanceMin, DistanceMax: Single): TGLMaterialMultiProxyMaster; overload;

This item has no description.

Public function Add: TGLMaterialMultiProxyMaster; overload;

This item has no description.

Public procedure EndUpdate; override;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Public property Items[index: Integer]: TGLMaterialMultiProxyMaster read GetItems write SetItems;


GLSysHelp v.2.5: GLS.MaterialMultiProxy: Class TGLMaterialMultiProxy

Class TGLMaterialMultiProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialMultiProxy

Declaration

type TGLMaterialMultiProxy = class(TGLBaseSceneObject)

Description

Multiple Proxy object. This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLMaterialMultiProxy

Overview

Fields

Private | FMasterObjects: TGLMaterialMultiProxyMasters;
Private | FRendering: Boolean;
Private | FMaterialLibrary: TGLMaterialLibrary;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Private | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property MasterObjects: TGLMaterialMultiProxyMasters read FMasterObjects write SetMasterObjects;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Fields

Private FMasterObjects: TGLMaterialMultiProxyMasters;

This item has no description.

Private FRendering: Boolean;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

internal use (loop protection)

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property MasterObjects: TGLMaterialMultiProxyMasters read FMasterObjects write SetMasterObjects;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.MaterialScript

Unit GLS.MaterialScript

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • VCL.StdCtrls
  • GLScene.VectorTypes
  • GLS.Texture
  • GLScene.TextureFormat
  • GLS.Graphics
  • GLScene.Utils
  • GLS.Color
  • GLS.Coordinates
  • GLS.Material
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShaderItem |
Class TGLShaderItems |
Class TGLMaterialLibraryItem |
Class TGLMaterialLibraryItems |
Class TGLMaterialScripter |


GLSysHelp v.2.5: GLS.MaterialScript: Class TGLShaderItem

Class TGLShaderItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialScript

Declaration

type TGLShaderItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLShaderItem

Overview

Fields

Private | FShader: TGLShader;
Private | FName: string;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetName(const Value: string);
Private | procedure SetShader(const Value: TGLShader);

Properties

Published | property Name: string read FName write SetName;
Published | property Shader: TGLShader read FShader write SetShader;

Description

Fields

Private FShader: TGLShader;

This item has no description.

Private FName: string;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetName(const Value: string);

This item has no description.

Private procedure SetShader(const Value: TGLShader);

This item has no description.

Properties

Published property Name: string read FName write SetName;

This item has no description.

Published property Shader: TGLShader read FShader write SetShader;


GLSysHelp v.2.5: GLS.MaterialScript: Class TGLShaderItems

Class TGLShaderItems

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialScript

Declaration

type TGLShaderItems = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLShaderItems

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Private | function GetItems(Index: Integer): TGLShaderItem;
Private | procedure SetItems(Index: Integer; const Val: TGLShaderItem);

Properties

Public property Items[Index: Integer]: TGLShaderItem read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Private function GetItems(Index: Integer): TGLShaderItem;

This item has no description.

Private procedure SetItems(Index: Integer; const Val: TGLShaderItem);

This item has no description.

Properties

Public property Items[Index: Integer]: TGLShaderItem read GetItems write SetItems;


GLSysHelp v.2.5: GLS.MaterialScript: Class TGLMaterialLibraryItem

Class TGLMaterialLibraryItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialScript

Declaration

type TGLMaterialLibraryItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLMaterialLibraryItem

Overview

Fields

Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FName: string;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);
Private | procedure SetName(const Value: string);

Properties

Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Name: string read FName write SetName;

Description

Fields

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FName: string;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

This item has no description.

Private procedure SetName(const Value: string);

This item has no description.

Properties

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property Name: string read FName write SetName;


GLSysHelp v.2.5: GLS.MaterialScript: Class TGLMaterialLibraryItems

Class TGLMaterialLibraryItems

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialScript

Declaration

type TGLMaterialLibraryItems = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLMaterialLibraryItems

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Private | function GetItems(Index: Integer): TGLMaterialLibraryItem;
Private | procedure SetItems(Index: Integer; const Val: TGLMaterialLibraryItem);

Properties

Public property Items[Index: Integer]: TGLMaterialLibraryItem read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Private function GetItems(Index: Integer): TGLMaterialLibraryItem;

This item has no description.

Private procedure SetItems(Index: Integer; const Val: TGLMaterialLibraryItem);

This item has no description.

Properties

Public property Items[Index: Integer]: TGLMaterialLibraryItem read GetItems write SetItems;


GLSysHelp v.2.5: GLS.MaterialScript: Class TGLMaterialScripter

Class TGLMaterialScripter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MaterialScript

Declaration

type TGLMaterialScripter = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLMaterialScripter

Overview

Fields

Private | FShaderItems: TGLShaderItems;
Private | FMaterialLibraryItems: TGLMaterialLibraryItems;
Private | FAppend: Boolean;
Private | FOverwrite: Boolean;
Private | FScript: TStrings;
Private | FMemo: TMemo;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | Count: Longint;
Private | Infini: Longint;
Private | Done: Boolean;
Private | NewMat: TGLLibMaterial;
Private | TmpCoords: TGLCoordinates;
Private | TmpColor: TGLColor;
Private | TmpCoords4: TGLCoordinates4;
Private | TmpStr: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function CheckRepeatDone: Boolean;
Private | function ClassExists(arguement: string): Boolean;
Private | function DeleteSpaces(Value: string): string;
Private | function ExtractValue: string;
Private | function SubstrExists(substr: string): Boolean;
Private | function ValueExists(Value: string): Boolean;
Public | procedure CompileScript;
Private | procedure CheckError;
Private | procedure ExtractColors;
Private | procedure ExtractCoords3;
Private | procedure ExtractCoords4;
Private | procedure SetAppend(const Value: Boolean);
Private | procedure SeTGLMaterialLibraryItems(const Value: TGLMaterialLibraryItems);
Private | procedure SeTGLShaderItems(const Value: TGLShaderItems);
Private | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);
Private | procedure SetMemo(const Value: TMemo);
Private | procedure SetOverwrite(const Value: Boolean);
Private | procedure SetScript(const Value: TStrings);
Private | procedure XBackAmbient;
Private | procedure XBackDiffuse;
Private | procedure XBackEmission;
Private | procedure XBackProperties;
Private | procedure XBackShininess;
Private | procedure XBackSpecular;
Private | procedure XBlankImage;
Private | procedure XBlendingMode;
Private | procedure XCompression;
Private | procedure XEnvColor;
Private | procedure XFacingCulling;
Private | procedure XFilteringQuality;
Private | procedure XFrontAmbient;
Private | procedure XFrontDiffuse;
Private | procedure XFrontEmission;
Private | procedure XFrontProperties;
Private | procedure XFrontShininess;
Private | procedure XFrontSpecular;
Private | procedure XImageAlpha;
Private | procedure XImageBrightness;
Private | procedure XImageClass;
Private | procedure XImageGamma;
Private | procedure XLibMaterialName;
Private | procedure XMagFilter;
Private | procedure XMappingMode;
Private | procedure XMappingSCoordinates;
Private | procedure XMappingTCoordinates;
Private | procedure XMaterial;
Private | procedure XMaterialLibrary;
Private | procedure XMaterialOptions;
Private | procedure XMinFilter;
Private | procedure XName;
Private | procedure XNormalMapScale;
Private | procedure XPersistantImage;
Private | procedure XPictureFileName;
Private | procedure XPictureNX;
Private | procedure XPictureNY;
Private | procedure XPictureNZ;
Private | procedure XPicturePX;
Private | procedure XPicturePY;
Private | procedure XPicturePZ;
Private | procedure XPolygonMode;
Private | procedure XShader;
Private | procedure XTexture;
Private | procedure XTexture2Name;
Private | procedure XTextureFormat;
Private | procedure XTextureMode;
Private | procedure XTextureOffset;
Private | procedure XTextureScale;
Private | procedure XTextureWrap;
Private | procedure ZMaterial;

Properties

Published | property AppendToMaterialLibrary: Boolean read FAppend write SetAppend;
Public | property DebugMemo: TMemo read FMemo write SetMemo;
Published | property MaterialLibraries: TGLMaterialLibraryItems read FMaterialLibraryItems write SeTGLMaterialLibraryItems;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property OverwriteToMaterialLibrary: Boolean read FOverwrite write SetOverwrite;
Published | property Script: TStrings read FScript write SetScript;
Published | property Shaders: TGLShaderItems read FShaderItems write SeTGLShaderItems;

Description

Fields

Private FShaderItems: TGLShaderItems;

This item has no description.

Private FMaterialLibraryItems: TGLMaterialLibraryItems;

This item has no description.

Private FAppend: Boolean;

This item has no description.

Private FOverwrite: Boolean;

This item has no description.

Private FScript: TStrings;

This item has no description.

Private FMemo: TMemo;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private Count: Longint;

This item has no description.

Private Infini: Longint;

This item has no description.

Private Done: Boolean;

This item has no description.

Private NewMat: TGLLibMaterial;

This item has no description.

Private TmpCoords: TGLCoordinates;

This item has no description.

Private TmpColor: TGLColor;

This item has no description.

Private TmpCoords4: TGLCoordinates4;

This item has no description.

Private TmpStr: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function CheckRepeatDone: Boolean;

This item has no description.

Private function ClassExists(arguement: string): Boolean;

This item has no description.

Private function DeleteSpaces(Value: string): string;

This item has no description.

Private function ExtractValue: string;

extraction functions

Private function SubstrExists(substr: string): Boolean;

This item has no description.

Private function ValueExists(Value: string): Boolean;

This item has no description.

Public procedure CompileScript;

This item has no description.

Private procedure CheckError;

error checking

Private procedure ExtractColors;

This item has no description.

Private procedure ExtractCoords3;

This item has no description.

Private procedure ExtractCoords4;

This item has no description.

Private procedure SetAppend(const Value: Boolean);

This item has no description.

Private procedure SeTGLMaterialLibraryItems(const Value: TGLMaterialLibraryItems);

This item has no description.

Private procedure SeTGLShaderItems(const Value: TGLShaderItems);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

This item has no description.

Private procedure SetMemo(const Value: TMemo);

This item has no description.

Private procedure SetOverwrite(const Value: Boolean);

This item has no description.

Private procedure SetScript(const Value: TStrings);

This item has no description.

Private procedure XBackAmbient;

This item has no description.

Private procedure XBackDiffuse;

This item has no description.

Private procedure XBackEmission;

This item has no description.

Private procedure XBackProperties;

This item has no description.

Private procedure XBackShininess;

This item has no description.

Private procedure XBackSpecular;

This item has no description.

Private procedure XBlankImage;

This item has no description.

Private procedure XBlendingMode;

This item has no description.

Private procedure XCompression;

This item has no description.

Private procedure XEnvColor;

This item has no description.

Private procedure XFacingCulling;

This item has no description.

Private procedure XFilteringQuality;

This item has no description.

Private procedure XFrontAmbient;

This item has no description.

Private procedure XFrontDiffuse;

This item has no description.

Private procedure XFrontEmission;

This item has no description.

Private procedure XFrontProperties;

This item has no description.

Private procedure XFrontShininess;

This item has no description.

Private procedure XFrontSpecular;

This item has no description.

Private procedure XImageAlpha;

This item has no description.

Private procedure XImageBrightness;

This item has no description.

Private procedure XImageClass;

This item has no description.

Private procedure XImageGamma;

This item has no description.

Private procedure XLibMaterialName;

This item has no description.

Private procedure XMagFilter;

This item has no description.

Private procedure XMappingMode;

This item has no description.

Private procedure XMappingSCoordinates;

This item has no description.

Private procedure XMappingTCoordinates;

This item has no description.

Private procedure XMaterial;

internally called scripts for value extraction

Private procedure XMaterialLibrary;

This item has no description.

Private procedure XMaterialOptions;

This item has no description.

Private procedure XMinFilter;

This item has no description.

Private procedure XName;

This item has no description.

Private procedure XNormalMapScale;

This item has no description.

Private procedure XPersistantImage;

This item has no description.

Private procedure XPictureFileName;

This item has no description.

Private procedure XPictureNX;

This item has no description.

Private procedure XPictureNY;

This item has no description.

Private procedure XPictureNZ;

This item has no description.

Private procedure XPicturePX;

This item has no description.

Private procedure XPicturePY;

This item has no description.

Private procedure XPicturePZ;

This item has no description.

Private procedure XPolygonMode;

This item has no description.

Private procedure XShader;

This item has no description.

Private procedure XTexture;

This item has no description.

Private procedure XTexture2Name;

This item has no description.

Private procedure XTextureFormat;

This item has no description.

Private procedure XTextureMode;

This item has no description.

Private procedure XTextureOffset;

This item has no description.

Private procedure XTextureScale;

This item has no description.

Private procedure XTextureWrap;

This item has no description.

Private procedure ZMaterial;

these are our viable scripts

Properties

Published property AppendToMaterialLibrary: Boolean read FAppend write SetAppend;

This item has no description.

Public property DebugMemo: TMemo read FMemo write SetMemo;

This item has no description.

Published property MaterialLibraries: TGLMaterialLibraryItems read FMaterialLibraryItems write SeTGLMaterialLibraryItems;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property OverwriteToMaterialLibrary: Boolean read FOverwrite write SetOverwrite;

This item has no description.

Published property Script: TStrings read FScript write SetScript;

This item has no description.

Published property Shaders: TGLShaderItems read FShaderItems write SeTGLShaderItems;


GLSysHelp v.2.5: GLS.Memo

Unit GLS.Memo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • WinApi.Windows
  • WinApi.Messages
  • System.SysUtils
  • System.Classes
  • System.UITypes
  • VCL.Graphics
  • VCL.Controls
  • VCL.Forms
  • VCL.Dialogs
  • VCL.ClipBrd
  • VCL.StdCtrls
  • VCL.ExtCtrls

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TCellSize |
Record TCellPos |
Record TFullPos |
Class TLineProp |
Class TCharStyle |
Class TStyleList |
Class TGLAbstractMemoObject |
Class TGLSMemoAbstractScrollableObject |
Class TGLSMemoScrollBar |
Class TGLSMemoStrings |
Class TGLSMemoGutter |
Class TGLSMemoUndo |
Class TGLSMemoInsCharUndo |
Class TGLSMemoDelCharUndo |
Class TGLSMEmoDelLineUndo |
Class TGLSMemoSelUndo |
Class TGLSMemoDeleteBufUndo |
Class TGLSMemoPasteUndo |
Class TGLSMemoUndoList |
Class TGLSCustomMemo |
Class TGLSMemo |
Class TGLSMemoStringList |
Class TGLSSynHiMemo |

Functions and Procedures

procedure Border(Canvas: TCanvas; const rct: TRect; BorderType: TBorderType);

Types

TBorderType = (...);
TCommand = Integer;
TDelimiters = TSysCharSet;
TGetLineAttrsEvent = procedure(Sender: TObject; LineNo: integer; var Attrs: string) of object;
TGutterClickEvent = procedure(Sender: TObject; LineNo: integer) of object;
TGutterDrawEvent = procedure(Sender: TObject; ACanvas: TCanvas; LineNo: integer; rct: TRect) of object;
TsbState = (...);
TScrollMode = (...);
TTokenType = (...);
TUndoChangeEvent = procedure(Sender: TObject; CanUndo, CanRedo: Boolean) of object;

Description

Functions and Procedures

procedure Border(Canvas: TCanvas; const rct: TRect; BorderType: TBorderType);

This item has no description.

Types

TBorderType = (...);

This item has no description.

Values
  • btRaised
  • btLowered
  • btFlatRaised
  • btFlatLowered
TCommand = Integer;

This item has no description.

TDelimiters = TSysCharSet;

This item has no description.

TGetLineAttrsEvent = procedure(Sender: TObject; LineNo: integer; var Attrs: string) of object;

This item has no description.

TGutterClickEvent = procedure(Sender: TObject; LineNo: integer) of object;

————————————————————–

TGutterDrawEvent = procedure(Sender: TObject; ACanvas: TCanvas; LineNo: integer; rct: TRect) of object;

This item has no description.

TsbState = (...);

This item has no description.

Values
  • sbsWait
  • sbsBack
  • sbsForward
  • sbsPageBack
  • sbsPageForward
  • sbsDragging
TScrollMode = (...);

This item has no description.

Values
  • smAuto
  • smStrict
TTokenType = (...);

This item has no description.

Values
  • ttWord
  • ttBracket
  • ttSpecial
  • ttDelimiter
  • ttSpace
  • ttEOL
  • ttInteger
  • ttFloat
  • ttComment
  • ttOther
  • ttWrongNumber
TUndoChangeEvent = procedure(Sender: TObject; CanUndo, CanRedo: Boolean) of object;


GLSysHelp v.2.5: GLS.Memo: Record TCellSize

Record TCellSize

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TCellSize = record

Description

This item has no description.

Overview

Fields

Public | W: integer;
Public | H: integer;

Description

Fields

Public W: integer;

This item has no description.

Public H: integer;


GLSysHelp v.2.5: GLS.Memo: Record TCellPos

Record TCellPos

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TCellPos = record

Description

This item has no description.

Overview

Fields

Public | X: integer;
Public | Y: integer;

Description

Fields

Public X: integer;

This item has no description.

Public Y: integer;


GLSysHelp v.2.5: GLS.Memo: Record TFullPos

Record TFullPos

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TFullPos = record

Description

This item has no description.

Overview

Fields

Public | LineNo: integer;
Public | Pos: integer;

Description

Fields

Public LineNo: integer;

This item has no description.

Public Pos: integer;


GLSysHelp v.2.5: GLS.Memo: Class TLineProp

Class TLineProp

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TLineProp = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TLineProp

Overview

Fields

Public | FObject: TObject;
Public | FStyleNo: integer;
Public | FInComment: Boolean;
Public | FInBrackets: integer;
Public | FValidAttrs: Boolean;
Public | FCharAttrs: string;

Description

Fields

Public FObject: TObject;

This item has no description.

Public FStyleNo: integer;

This item has no description.

Public FInComment: Boolean;

This item has no description.

Public FInBrackets: integer;

This item has no description.

Public FValidAttrs: Boolean;

This item has no description.

Public FCharAttrs: string;


GLSysHelp v.2.5: GLS.Memo: Class TCharStyle

Class TCharStyle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TCharStyle = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCharStyle

Overview

Fields

Private | FTextColor: TColor;
Private | FBkColor: TColor;
Private | FStyle: TFontStyles;

Properties

Published | property BkColor: TColor read FBkColor write FBkColor;
Published | property Style: TFontStyles read FStyle write FStyle;
Published | property TextColor: TColor read FTextColor write FTextColor;

Description

Fields

Private FTextColor: TColor;

This item has no description.

Private FBkColor: TColor;

This item has no description.

Private FStyle: TFontStyles;

This item has no description.

Properties

Published property BkColor: TColor read FBkColor write FBkColor;

This item has no description.

Published property Style: TFontStyles read FStyle write FStyle;

This item has no description.

Published property TextColor: TColor read FTextColor write FTextColor;


GLSysHelp v.2.5: GLS.Memo: Class TStyleList

Class TStyleList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TStyleList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TStyleList

Overview

Methods

Public | destructor Destroy; override;
Public | function Add(ATextColor, ABkCOlor: TColor; AStyle: TFontStyles): Integer;
Private | function GetBkColor(Index: Integer): TColor;
Private | function GetStyle(Index: Integer): TFontStyles;
Private | function GetTextColor(Index: Integer): TColor;
Public | procedure Change(Index: integer; ATextColor, ABkColor: TColor; AStyle: TFontStyles);
Public | procedure Clear; override;
Public | procedure Delete(Index: Integer);
Private | procedure CheckRange(Index: integer);
Private | procedure SetBkColor(Index: Integer; Value: TColor);
Private | procedure SetStyle(Index: Integer; Value: TFontStyles);
Private | procedure SetTextColor(Index: Integer; Value: TColor);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function Add(ATextColor, ABkCOlor: TColor; AStyle: TFontStyles): Integer;

This item has no description.

Private function GetBkColor(Index: Integer): TColor;

This item has no description.

Private function GetStyle(Index: Integer): TFontStyles;

This item has no description.

Private function GetTextColor(Index: Integer): TColor;

This item has no description.

Public procedure Change(Index: integer; ATextColor, ABkColor: TColor; AStyle: TFontStyles);

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure Delete(Index: Integer);

This item has no description.

Private procedure CheckRange(Index: integer);

This item has no description.

Private procedure SetBkColor(Index: Integer; Value: TColor);

This item has no description.

Private procedure SetStyle(Index: Integer; Value: TFontStyles);

This item has no description.

Private procedure SetTextColor(Index: Integer; Value: TColor);


GLSysHelp v.2.5: GLS.Memo: Class TGLAbstractMemoObject

Class TGLAbstractMemoObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLAbstractMemoObject = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLAbstractMemoObject

Overview

Methods

Public | function MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;
Public | function MouseMove(Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;
Public | function MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;

Description

Methods

Public function MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;

This item has no description.

Public function MouseMove(Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;

This item has no description.

Public function MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoAbstractScrollableObject

Class TGLSMemoAbstractScrollableObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoAbstractScrollableObject = class(TCustomControl)

Description

This item has no description.

Hierarchy

  • TCustomControl
  • TGLSMemoAbstractScrollableObject


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoScrollBar

Class TGLSMemoScrollBar

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoScrollBar = class(TGLAbstractMemoObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLAbstractMemoObject
  • TGLSMemoScrollBar

Overview

Fields

Private | FKind: TScrollBarKind;
Private | FParent: TGLSMemoAbstractScrollableObject;
Private | FLeft: integer;
Private | FTop: integer;
Private | FWidth: integer;
Private | FHeight: integer;
Private | FTotal: integer;
Private | FMaxPosition: integer;
Private | FPosition: integer;
Private | FButtonLength: integer;
Private | FState: TsbState;
Private | FXOffset: integer;
Private | FYOffset: integer;

Methods

Public | constructor Create(AParent: TGLSMemoAbstractScrollableObject; AKind: TScrollBarKind);
Public | function MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseMove(Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MoveThumbTo(X, Y: Integer): integer;
Private | function GetBackRect: TRect;
Private | function GetForwardRect: TRect;
Private | function GetMiddleRect: TRect;
Private | function GetPgBackRect: TRect;
Private | function GetPgForwardRect: TRect;
Private | function GetRect: TRect;
Private | function GetThumbRect: TRect;
Public | procedure PaintTo(ACanvas: TCanvas);
Private | procedure SetParams(Index: integer; Value: integer);
Private | procedure SetState(Value: TsbState);

Properties

Public | property BackRect: TRect read GetBackRect;
Public | property ForwardRect: TRect read GetForwardRect;
Public | property FullRect: TRect read GetRect;
Public | property Height: integer index 3 read FHeight write SetParams;
Public | property Kind: TScrollBarKind read FKind write FKind;
Public | property Left: integer index 0 read FLeft write SetParams;
Public | property MaxPosition: integer index 5 read FMaxPosition write SetParams;
Public | property MiddleRect: TRect read GetMiddleRect;
Public | property PageBackRect: TRect read GetPgBackRect;
Public | property PageForwardRect: TRect read GetPgForwardRect;
Public | property Parent: TGLSMemoAbstractScrollableObject read FParent;
Public | property Position: integer index 6 read FPosition write SetParams;
Public | property State: TsbState read FState write SetState;
Public | property ThumbRect: TRect read GetThumbRect;
Public | property Top: integer index 1 read FTop write SetParams;
Public | property Total: integer index 4 read FTotal write SetParams;
Public | property Width: integer index 2 read FWidth write SetParams;

Description

Fields

Private FKind: TScrollBarKind;

This item has no description.

Private FParent: TGLSMemoAbstractScrollableObject;

This item has no description.

Private FLeft: integer;

This item has no description.

Private FTop: integer;

This item has no description.

Private FWidth: integer;

This item has no description.

Private FHeight: integer;

This item has no description.

Private FTotal: integer;

This item has no description.

Private FMaxPosition: integer;

This item has no description.

Private FPosition: integer;

This item has no description.

Private FButtonLength: integer;

This item has no description.

Private FState: TsbState;

This item has no description.

Private FXOffset: integer;

This item has no description.

Private FYOffset: integer;

This item has no description.

Methods

Public constructor Create(AParent: TGLSMemoAbstractScrollableObject; AKind: TScrollBarKind);

This item has no description.

Public function MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public function MouseMove(Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public function MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public function MoveThumbTo(X, Y: Integer): integer;

This item has no description.

Private function GetBackRect: TRect;

This item has no description.

Private function GetForwardRect: TRect;

This item has no description.

Private function GetMiddleRect: TRect;

This item has no description.

Private function GetPgBackRect: TRect;

This item has no description.

Private function GetPgForwardRect: TRect;

This item has no description.

Private function GetRect: TRect;

This item has no description.

Private function GetThumbRect: TRect;

This item has no description.

Public procedure PaintTo(ACanvas: TCanvas);

This item has no description.

Private procedure SetParams(Index: integer; Value: integer);

This item has no description.

Private procedure SetState(Value: TsbState);

This item has no description.

Properties

Public property BackRect: TRect read GetBackRect;

This item has no description.

Public property ForwardRect: TRect read GetForwardRect;

This item has no description.

Public property FullRect: TRect read GetRect;

This item has no description.

Public property Height: integer index 3 read FHeight write SetParams;

This item has no description.

Public property Kind: TScrollBarKind read FKind write FKind;

This item has no description.

Public property Left: integer index 0 read FLeft write SetParams;

This item has no description.

Public property MaxPosition: integer index 5 read FMaxPosition write SetParams;

This item has no description.

Public property MiddleRect: TRect read GetMiddleRect;

This item has no description.

Public property PageBackRect: TRect read GetPgBackRect;

This item has no description.

Public property PageForwardRect: TRect read GetPgForwardRect;

This item has no description.

Public property Parent: TGLSMemoAbstractScrollableObject read FParent;

This item has no description.

Public property Position: integer index 6 read FPosition write SetParams;

This item has no description.

Public property State: TsbState read FState write SetState;

This item has no description.

Public property ThumbRect: TRect read GetThumbRect;

This item has no description.

Public property Top: integer index 1 read FTop write SetParams;

This item has no description.

Public property Total: integer index 4 read FTotal write SetParams;

This item has no description.

Public property Width: integer index 2 read FWidth write SetParams;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoStrings

Class TGLSMemoStrings

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoStrings = class(TStringList)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TStrings
  • TStringList
  • TGLSMemoStrings

Overview

Fields

Private | FMemo: TGLSCustomMemo;
Private | FLockCount: integer;
Private | FDeleting: Boolean;

Methods

Public | destructor Destroy; override;
Public | function Add(const S: string): Integer; override;
Public | function AddObject(const S: string; AObject: TObject): Integer; override;
Public | function DoAdd(const S: string): Integer;
Private | function GetCharAttrs(Index: Integer): string;
Private | function GetInBrackets(Index: Integer): integer;
Private | function GetInComment(Index: Integer): Boolean;
Private | function GetLineProp(Index: integer): TLineProp;
Private | function GetLineStyle(Index: integer): integer;
Private | function GetValidAttrs(Index: Integer): Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear; override;
Public | procedure Delete(Index: Integer); override;
Public | procedure DoInsert(Index: Integer; const S: string);
Public | procedure Insert(Index: Integer; const S: string); override;
Public | procedure InsertObject(Index: Integer; const S: string; AObject: TObject); override;
Public | procedure LoadFromFile(const FileName: string); override;
Private | procedure CheckRange(Index: integer);
Private | procedure SetCharAttrs(Index: Integer; const Value: string);
Private | procedure SetInBrackets(Index: Integer; Value: integer);
Private | procedure SetInComment(Index: Integer; Value: Boolean);
Private | procedure SetLineStyle(Index: integer; Value: integer);
Private | procedure SetValidAttrs(Index: Integer; Value: Boolean);

Description

Fields

Private FMemo: TGLSCustomMemo;

This item has no description.

Private FLockCount: integer;

This item has no description.

Private FDeleting: Boolean;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function Add(const S: string): Integer; override;

This item has no description.

Public function AddObject(const S: string; AObject: TObject): Integer; override;

This item has no description.

Public function DoAdd(const S: string): Integer;

This item has no description.

Private function GetCharAttrs(Index: Integer): string;

This item has no description.

Private function GetInBrackets(Index: Integer): integer;

This item has no description.

Private function GetInComment(Index: Integer): Boolean;

This item has no description.

Private function GetLineProp(Index: integer): TLineProp;

This item has no description.

Private function GetLineStyle(Index: integer): integer;

This item has no description.

Private function GetValidAttrs(Index: Integer): Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure Delete(Index: Integer); override;

This item has no description.

Public procedure DoInsert(Index: Integer; const S: string);

This item has no description.

Public procedure Insert(Index: Integer; const S: string); override;

This item has no description.

Public procedure InsertObject(Index: Integer; const S: string; AObject: TObject); override;

This item has no description.

Public procedure LoadFromFile(const FileName: string); override;

This item has no description.

Private procedure CheckRange(Index: integer);

This item has no description.

Private procedure SetCharAttrs(Index: Integer; const Value: string);

This item has no description.

Private procedure SetInBrackets(Index: Integer; Value: integer);

This item has no description.

Private procedure SetInComment(Index: Integer; Value: Boolean);

This item has no description.

Private procedure SetLineStyle(Index: integer; Value: integer);

This item has no description.

Private procedure SetValidAttrs(Index: Integer; Value: Boolean);


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoGutter

Class TGLSMemoGutter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoGutter = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLSMemoGutter

Overview

Fields

Private | FMemo: TGLSCustomMemo;
Private | FLeft: integer;
Private | FTop: integer;
Private | FWidth: integer;
Private | FHeight: integer;
Private | FColor: TColor;

Methods

Private | function GetRect: TRect;
Private | procedure SetParams(Index: integer; Value: integer);

Properties

Public | property FullRect: TRect read GetRect;
Public | property Height: integer index 3 read FHeight write SetParams;
Public | property Left: integer index 0 read FLeft write SetParams;
Public | property Top: integer index 1 read FTop write SetParams;
Public | property Width: integer index 2 read FWidth write SetParams;

Description

Fields

Private FMemo: TGLSCustomMemo;

This item has no description.

Private FLeft: integer;

This item has no description.

Private FTop: integer;

This item has no description.

Private FWidth: integer;

This item has no description.

Private FHeight: integer;

This item has no description.

Private FColor: TColor;

This item has no description.

Methods

Private function GetRect: TRect;

This item has no description.

Private procedure SetParams(Index: integer; Value: integer);

This item has no description.

Properties

Public property FullRect: TRect read GetRect;

This item has no description.

Public property Height: integer index 3 read FHeight write SetParams;

This item has no description.

Public property Left: integer index 0 read FLeft write SetParams;

This item has no description.

Public property Top: integer index 1 read FTop write SetParams;

This item has no description.

Public property Width: integer index 2 read FWidth write SetParams;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoUndo

Class TGLSMemoUndo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoUndo = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLSMemoUndo

Overview

Fields

Private | FMemo: TGLSCustomMemo;
Private | FUndoCurX0: integer;
Private | FUndoCurY0: integer;
Private | FUndoCurX: integer;
Private | FUndoCurY: integer;
Private | FUndoText: string;

Methods

Public | constructor Create(ACurX0, ACurY0, ACurX, ACurY: integer; const AText: string);
Public | function Append(NewUndo: TGLSMemoUndo): Boolean; virtual;
Public | procedure PerformRedo; virtual; abstract;
Public | procedure PerformUndo; virtual; abstract;
Public | procedure Redo;
Public | procedure Undo;

Properties

Public | property UndoCurX: integer read FUndoCurX write FUndoCurX;
Public | property UndoCurX0: integer read FUndoCurX0 write FUndoCurX0;
Public | property UndoCurY: integer read FUndoCurY write FUndoCurY;
Public | property UndoCurY0: integer read FUndoCurY0 write FUndoCurY0;

Description

Fields

Private FMemo: TGLSCustomMemo;

This item has no description.

Private FUndoCurX0: integer;

This item has no description.

Private FUndoCurY0: integer;

This item has no description.

Private FUndoCurX: integer;

This item has no description.

Private FUndoCurY: integer;

This item has no description.

Private FUndoText: string;

This item has no description.

Methods

Public constructor Create(ACurX0, ACurY0, ACurX, ACurY: integer; const AText: string);

This item has no description.

Public function Append(NewUndo: TGLSMemoUndo): Boolean; virtual;

This item has no description.

Public procedure PerformRedo; virtual; abstract;

This item has no description.

Public procedure PerformUndo; virtual; abstract;

This item has no description.

Public procedure Redo;

This item has no description.

Public procedure Undo;

This item has no description.

Properties

Public property UndoCurX: integer read FUndoCurX write FUndoCurX;

This item has no description.

Public property UndoCurX0: integer read FUndoCurX0 write FUndoCurX0;

This item has no description.

Public property UndoCurY: integer read FUndoCurY write FUndoCurY;

This item has no description.

Public property UndoCurY0: integer read FUndoCurY0 write FUndoCurY0;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoInsCharUndo

Class TGLSMemoInsCharUndo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoInsCharUndo = class(TGLSMemoUndo)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoInsCharUndo

Overview

Methods

Public | function Append(NewUndo: TGLSMemoUndo): Boolean; override;
Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Description

Methods

Public function Append(NewUndo: TGLSMemoUndo): Boolean; override;

This item has no description.

Public procedure PerformRedo; override;

This item has no description.

Public procedure PerformUndo; override;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoDelCharUndo

Class TGLSMemoDelCharUndo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoDelCharUndo = class(TGLSMemoUndo)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoDelCharUndo

Overview

Fields

Private FIsBackspace: Boolean;

Methods

Public | function Append(NewUndo: TGLSMemoUndo): Boolean; override;
Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Properties

Public property IsBackspace: Boolean read FIsBackspace write FIsBackspace;

Description

Fields

Private FIsBackspace: Boolean;

This item has no description.

Methods

Public function Append(NewUndo: TGLSMemoUndo): Boolean; override;

This item has no description.

Public procedure PerformRedo; override;

This item has no description.

Public procedure PerformUndo; override;

This item has no description.

Properties

Public property IsBackspace: Boolean read FIsBackspace write FIsBackspace;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMEmoDelLineUndo

Class TGLSMEmoDelLineUndo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMEmoDelLineUndo = class(TGLSMemoUndo)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMEmoDelLineUndo

Overview

Fields

Private FIndex: integer;

Methods

Public | constructor Create(AIndex, ACurX0, ACurY0, ACurX, ACurY: integer; const AText: string);
Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Description

Fields

Private FIndex: integer;

This item has no description.

Methods

Public constructor Create(AIndex, ACurX0, ACurY0, ACurX, ACurY: integer; const AText: string);

This item has no description.

Public procedure PerformRedo; override;

This item has no description.

Public procedure PerformUndo; override;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoSelUndo

Class TGLSMemoSelUndo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoSelUndo = class(TGLSMemoUndo)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoSelUndo

Overview

Fields

Private | FUndoSelStartX: integer;
Private | FUndoSelStartY: integer;
Private | FUndoSelEndX: integer;
Private | FUndoSelEndY: integer;

Properties

Public | property UndoSelEndX: integer read FUndoSelEndX write FUndoSelEndX;
Public | property UndoSelEndY: integer read FUndoSelEndY write FUndoSelEndY;
Public | property UndoSelStartX: integer read FUndoSelStartX write FUndoSelStartX;
Public | property UndoSelStartY: integer read FUndoSelStartY write FUndoSelStartY;

Description

Fields

Private FUndoSelStartX: integer;

This item has no description.

Private FUndoSelStartY: integer;

This item has no description.

Private FUndoSelEndX: integer;

This item has no description.

Private FUndoSelEndY: integer;

This item has no description.

Properties

Public property UndoSelEndX: integer read FUndoSelEndX write FUndoSelEndX;

This item has no description.

Public property UndoSelEndY: integer read FUndoSelEndY write FUndoSelEndY;

This item has no description.

Public property UndoSelStartX: integer read FUndoSelStartX write FUndoSelStartX;

This item has no description.

Public property UndoSelStartY: integer read FUndoSelStartY write FUndoSelStartY;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoDeleteBufUndo

Class TGLSMemoDeleteBufUndo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoDeleteBufUndo = class(TGLSMemoSelUndo)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoSelUndo
  • TGLSMemoDeleteBufUndo

Overview

Methods

Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Description

Methods

Public procedure PerformRedo; override;

This item has no description.

Public procedure PerformUndo; override;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoPasteUndo

Class TGLSMemoPasteUndo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoPasteUndo = class(TGLSMemoUndo)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoPasteUndo

Overview

Methods

Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Description

Methods

Public procedure PerformRedo; override;

This item has no description.

Public procedure PerformUndo; override;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoUndoList

Class TGLSMemoUndoList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoUndoList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLSMemoUndoList

Overview

Fields

Private | FPos: integer;
Private | FMemo: TGLSCustomMemo;
Private | FIsPerforming: Boolean;
Private | FLimit: integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Add(Item: Pointer): Integer;
Public | procedure Clear; override;
Public | procedure Delete(Index: Integer);
Public | procedure Redo;
Public | procedure Undo;

Properties

Public | property IsPerforming: Boolean read FIsPerforming write FIsPerforming;
Public | property Items[Index: Integer]: TGLSMemoUndo read Get;
Public | property Limit: integer read FLimit write SetLimit;
Public | property Memo: TGLSCustomMemo read FMemo write FMemo;
Public | property Pos: integer read FPos write FPos;

Description

Fields

Private FPos: integer;

This item has no description.

Private FMemo: TGLSCustomMemo;

This item has no description.

Private FIsPerforming: Boolean;

This item has no description.

Private FLimit: integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add(Item: Pointer): Integer;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure Delete(Index: Integer);

This item has no description.

Public procedure Redo;

This item has no description.

Public procedure Undo;

This item has no description.

Properties

Public property IsPerforming: Boolean read FIsPerforming write FIsPerforming;

This item has no description.

Public property Items[Index: Integer]: TGLSMemoUndo read Get;

This item has no description.

Public property Limit: integer read FLimit write SetLimit;

This item has no description.

Public property Memo: TGLSCustomMemo read FMemo write FMemo;

This item has no description.

Public property Pos: integer read FPos write FPos;


GLSysHelp v.2.5: GLS.Memo: Class TGLSCustomMemo

Class TGLSCustomMemo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSCustomMemo = class(TGLSMemoAbstractScrollableObject)

Description

This item has no description.

Hierarchy

  • TCustomControl
  • TGLSMemoAbstractScrollableObject
  • TGLSCustomMemo

Overview

Fields

Private | FAutoIndent: Boolean;
Private | FMargin: integer;
Private | FHiddenCaret: Boolean;
Private | FCaretVisible: Boolean;
Private | FCellSize: TCellSize;
Private | FCurX: integer;
Private | FCurY: integer;
Private | FLeftCol: integer;
Private | FTopLine: integer;
Private | FTabSize: integer;
Private | FFont: TFont;
Private | FBkColor: TColor;
Private | FSelColor: TColor;
Private | FSelBkColor: TColor;
Private | FReadOnly: Boolean;
Private | FDelErase: Boolean;
Private | FLines: TStrings;
Private | FSelStartX: integer;
Private | FSelStartY: integer;
Private | FSelEndX: integer;
Private | FSelEndY: integer;
Private | FPrevSelX: integer;
Private | FPrevSelY: integer;
Private | FScrollBars: System.UITypes.TScrollStyle;
Private | FScrollBarWidth: integer;
Private | FGutter: TGLSMemoGutter;
Private | FGutterWidth: integer;
Private | sbVert: TGLSMemoScrollBar;
Private | sbHorz: TGLSMemoScrollBar;
Private | FStyles: TStyleList;
Private | FLineBitmap: TBitmap;
Private | FSelCharPos: TFullPos;
Private | FSelCharStyle: integer;
Private | FLeftButtonDown: Boolean;
Private | FScrollMode: TScrollMode;
Private | FUndoList: TGLSMemoUndoList;
Private | FFirstUndoList: TGLSMemoUndoList;
Private | FUndoLimit: integer;
Private | FLastMouseUpX: integer;
Private | FLastMouseUpY: integer;
Private | FAfterDoubleClick: Boolean;
Private | FOnMoveCursor: TNotifyEvent;
Private | FOnChange: TNotifyEvent;
Private | FOnAttrChange: TNotifyEvent;
Private | FOnStatusChange: TNotifyEvent;
Private | FOnSelectionChange: TNotifyEvent;
Private | FOnGutterDraw: TGutterDrawEvent;
Private | FOnGutterClick: TGutterClickEvent;
Private | FOnGetLineAttrs: TGetLineAttrsEvent;
Private | FOnUndoChange: TUndoChangeEvent;
Private | FHideCursor: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CanRedo: Boolean;
Public | function CanUndo: Boolean;
Public | function CellFromPos(X, Y: integer): TCellPos;
Public | function CellRect(ACol, ARow: integer): TRect;
Public | function CharFromPos(X, Y: integer): TFullPos;
Public | function CharStyleNo(LineNo, Pos: integer): integer;
Public | function ColRect(ACol: integer): TRect;
Public | function FindText(Text: string; Options: TFindOptions; Select: Boolean): Boolean;
Public | function LineRect(ARow: integer): TRect;
Public | function SelectLine(LineNo, StyleNo: Integer): integer;
Private | function GetCharAttrs(Index: integer): string;
Private | function GetGutterColor: TColor;
Private | function GetInBrackets(Index: Integer): integer;
Private | function GetInComment(Index: integer): Boolean;
Private | function GetLineStyle(Index: integer): integer;
Private | function GetSelEnd: TPoint;
Private | function GetSelLength: integer;
Private | function GetSelStart: TPoint;
Private | function GetSelText: string;
Private | function GetValidAttrs(Index: integer): Boolean;
Private | function GetVisible(Index: integer): integer;
Private | function IsLineVisible(LineNo: integer): Boolean;
Private | function MaxLength: integer;
Public | procedure Clear;
Public | procedure ClearSelection;
Public | procedure CopyToClipBoard;
Public | procedure CutToClipBoard;
Public | procedure InsertTemplate(AText: string);
Public | procedure PasteFromClipBoard;
Public | procedure Redo;
Public | procedure SelectAll;
Public | procedure SelectChar(LineNo, Pos, StyleNo: Integer);
Public | procedure SelectLines(StartLine, EndLine: Integer);
Public | procedure SetCursor(ACurX, ACurY: Integer);
Public | procedure Undo;
Public | procedure UnSelectChar;
Private | procedure DoCommand(cmd: TCommand; const AShift: TShiftState);
Private | procedure DrawLine(LineNo: integer);
Private | procedure ExpandSelection;
Private | procedure FreshLineBitmap;
Private | procedure MakeVisible;
Private | procedure MoveCursor(dX, dY: integer; Shift: TShiftState);
Private | procedure MovePage(dP: integer; Shift: TShiftState);
Private | procedure ResizeEditor;
Private | procedure ResizeGutter;
Private | procedure ResizeScrollBars;
Private | procedure SetCharAttrs(Index: integer; const Value: string);
Private | procedure SetColor(Index: integer; Value: TColor);
Private | procedure SetCurX(Value: integer);
Private | procedure SetCurY(Value: integer);
Private | procedure SetFont(Value: TFont);
Private | procedure SetGutterColor(Value: TColor);
Private | procedure SetGutterWidth(Value: integer);
Private | procedure SetHiddenCaret(Value: Boolean);
Private | procedure SetInBrackets(Index: Integer; Value: integer);
Private | procedure SetInComment(Index: integer; Value: Boolean);
Private | procedure SetLines(ALines: TStrings);
Private | procedure SetLineStyle(Index: integer; Value: integer);
Private | procedure SetScrollBars(Value: System.UITypes.TScrollStyle);
Private | procedure SetSelText(const AValue: string);
Private | procedure SetUndoLimit(Value: integer);
Private | procedure SetValidAttrs(Index: integer; Value: Boolean);
Private | procedure ShowCaret(State: Boolean);
Private | procedure WMEraseBkgnd(var Msg: TWmEraseBkgnd); message WM_ERASEBKGND;
Private | procedure WMGetDlgCode(var Msg: TWMGetDlgCode); message WM_GETDLGCODE;
Private | procedure WMKillFocus(var Msg: TWMSetFocus); message WM_KILLFOCUS;
Private | procedure WMMouseWheel(var Message: TMessage); message WM_MOUSEWHEEL;
Private | procedure WMSetCursor(var Msg: TWMSetCursor); message WM_SETCURSOR;
Private | procedure WMSetFocus(var Msg: TWMSetFocus); message WM_SETFOCUS;
Private | procedure WMSize(var Msg: TWMSize); message WM_SIZE;

Properties

Public | property CurX: integer read FCurX write SetCurX;
Public | property CurY: integer read FCurY write SetCurY;
Public | property DelErase: Boolean read FDelErase write FDelErase;
Public | property LineStyle[Index: integer]: integer read GetLineStyle write SetLineStyle;
Public | property Selection: string read GetSelText write SetSelText;
Public | property SelEnd: TPoint read GetSelEnd;
Public | property SelLength: integer read GetSelLength;
Public | property SelStart: TPoint read GetSelStart;
Public | property Styles: TStyleList read FStyles;
Public | property UndoList: TGLSMemoUndoList read FUndoList write FUndoList;

Description

Fields

Private FAutoIndent: Boolean;

This item has no description.

Private FMargin: integer;

This item has no description.

Private FHiddenCaret: Boolean;

This item has no description.

Private FCaretVisible: Boolean;

This item has no description.

Private FCellSize: TCellSize;

This item has no description.

Private FCurX: integer;

This item has no description.

Private FCurY: integer;

This item has no description.

Private FLeftCol: integer;

This item has no description.

Private FTopLine: integer;

This item has no description.

Private FTabSize: integer;

This item has no description.

Private FFont: TFont;

This item has no description.

Private FBkColor: TColor;

This item has no description.

Private FSelColor: TColor;

This item has no description.

Private FSelBkColor: TColor;

This item has no description.

Private FReadOnly: Boolean;

This item has no description.

Private FDelErase: Boolean;

This item has no description.

Private FLines: TStrings;

This item has no description.

Private FSelStartX: integer;

This item has no description.

Private FSelStartY: integer;

This item has no description.

Private FSelEndX: integer;

This item has no description.

Private FSelEndY: integer;

This item has no description.

Private FPrevSelX: integer;

This item has no description.

Private FPrevSelY: integer;

This item has no description.

Private FScrollBars: System.UITypes.TScrollStyle;

This item has no description.

Private FScrollBarWidth: integer;

This item has no description.

Private FGutter: TGLSMemoGutter;

This item has no description.

Private FGutterWidth: integer;

This item has no description.

Private sbVert: TGLSMemoScrollBar;

This item has no description.

Private sbHorz: TGLSMemoScrollBar;

This item has no description.

Private FStyles: TStyleList;

This item has no description.

Private FLineBitmap: TBitmap;

This item has no description.

Private FSelCharPos: TFullPos;

This item has no description.

Private FSelCharStyle: integer;

This item has no description.

Private FLeftButtonDown: Boolean;

This item has no description.

Private FScrollMode: TScrollMode;

This item has no description.

Private FUndoList: TGLSMemoUndoList;

This item has no description.

Private FFirstUndoList: TGLSMemoUndoList;

This item has no description.

Private FUndoLimit: integer;

This item has no description.

Private FLastMouseUpX: integer;

This item has no description.

Private FLastMouseUpY: integer;

This item has no description.

Private FAfterDoubleClick: Boolean;

This item has no description.

Private FOnMoveCursor: TNotifyEvent;

events

Private FOnChange: TNotifyEvent;

This item has no description.

Private FOnAttrChange: TNotifyEvent;

This item has no description.

Private FOnStatusChange: TNotifyEvent;

This item has no description.

Private FOnSelectionChange: TNotifyEvent;

This item has no description.

Private FOnGutterDraw: TGutterDrawEvent;

This item has no description.

Private FOnGutterClick: TGutterClickEvent;

This item has no description.

Private FOnGetLineAttrs: TGetLineAttrsEvent;

This item has no description.

Private FOnUndoChange: TUndoChangeEvent;

This item has no description.

Private FHideCursor: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CanRedo: Boolean;

This item has no description.

Public function CanUndo: Boolean;

This item has no description.

Public function CellFromPos(X, Y: integer): TCellPos;

This item has no description.

Public function CellRect(ACol, ARow: integer): TRect;

This item has no description.

Public function CharFromPos(X, Y: integer): TFullPos;

This item has no description.

Public function CharStyleNo(LineNo, Pos: integer): integer;

This item has no description.

Public function ColRect(ACol: integer): TRect;

This item has no description.

Public function FindText(Text: string; Options: TFindOptions; Select: Boolean): Boolean;

This item has no description.

Public function LineRect(ARow: integer): TRect;

This item has no description.

Public function SelectLine(LineNo, StyleNo: Integer): integer;

This item has no description.

Private function GetCharAttrs(Index: integer): string;

This item has no description.

Private function GetGutterColor: TColor;

This item has no description.

Private function GetInBrackets(Index: Integer): integer;

This item has no description.

Private function GetInComment(Index: integer): Boolean;

This item has no description.

Private function GetLineStyle(Index: integer): integer;

This item has no description.

Private function GetSelEnd: TPoint;

This item has no description.

Private function GetSelLength: integer;

This item has no description.

Private function GetSelStart: TPoint;

This item has no description.

Private function GetSelText: string;

This item has no description.

Private function GetValidAttrs(Index: integer): Boolean;

This item has no description.

Private function GetVisible(Index: integer): integer;

This item has no description.

Private function IsLineVisible(LineNo: integer): Boolean;

This item has no description.

Private function MaxLength: integer;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure ClearSelection;

This item has no description.

Public procedure CopyToClipBoard;

This item has no description.

Public procedure CutToClipBoard;

This item has no description.

Public procedure InsertTemplate(AText: string);

This item has no description.

Public procedure PasteFromClipBoard;

This item has no description.

Public procedure Redo;

This item has no description.

Public procedure SelectAll;

This item has no description.

Public procedure SelectChar(LineNo, Pos, StyleNo: Integer);

This item has no description.

Public procedure SelectLines(StartLine, EndLine: Integer);

This item has no description.

Public procedure SetCursor(ACurX, ACurY: Integer);

This item has no description.

Public procedure Undo;

This item has no description.

Public procedure UnSelectChar;

This item has no description.

Private procedure DoCommand(cmd: TCommand; const AShift: TShiftState);

This item has no description.

Private procedure DrawLine(LineNo: integer);

This item has no description.

Private procedure ExpandSelection;

This item has no description.

Private procedure FreshLineBitmap;

This item has no description.

Private procedure MakeVisible;

This item has no description.

Private procedure MoveCursor(dX, dY: integer; Shift: TShiftState);

This item has no description.

Private procedure MovePage(dP: integer; Shift: TShiftState);

This item has no description.

Private procedure ResizeEditor;

This item has no description.

Private procedure ResizeGutter;

This item has no description.

Private procedure ResizeScrollBars;

This item has no description.

Private procedure SetCharAttrs(Index: integer; const Value: string);

This item has no description.

Private procedure SetColor(Index: integer; Value: TColor);

This item has no description.

Private procedure SetCurX(Value: integer);

This item has no description.

Private procedure SetCurY(Value: integer);

This item has no description.

Private procedure SetFont(Value: TFont);

This item has no description.

Private procedure SetGutterColor(Value: TColor);

This item has no description.

Private procedure SetGutterWidth(Value: integer);

This item has no description.

Private procedure SetHiddenCaret(Value: Boolean);

This item has no description.

Private procedure SetInBrackets(Index: Integer; Value: integer);

This item has no description.

Private procedure SetInComment(Index: integer; Value: Boolean);

This item has no description.

Private procedure SetLines(ALines: TStrings);

This item has no description.

Private procedure SetLineStyle(Index: integer; Value: integer);

This item has no description.

Private procedure SetScrollBars(Value: System.UITypes.TScrollStyle);

This item has no description.

Private procedure SetSelText(const AValue: string);

This item has no description.

Private procedure SetUndoLimit(Value: integer);

This item has no description.

Private procedure SetValidAttrs(Index: integer; Value: Boolean);

This item has no description.

Private procedure ShowCaret(State: Boolean);

This item has no description.

Private procedure WMEraseBkgnd(var Msg: TWmEraseBkgnd); message WM_ERASEBKGND;

This item has no description.

Private procedure WMGetDlgCode(var Msg: TWMGetDlgCode); message WM_GETDLGCODE;

This item has no description.

Private procedure WMKillFocus(var Msg: TWMSetFocus); message WM_KILLFOCUS;

This item has no description.

Private procedure WMMouseWheel(var Message: TMessage); message WM_MOUSEWHEEL;

This item has no description.

Private procedure WMSetCursor(var Msg: TWMSetCursor); message WM_SETCURSOR;

This item has no description.

Private procedure WMSetFocus(var Msg: TWMSetFocus); message WM_SETFOCUS;

This item has no description.

Private procedure WMSize(var Msg: TWMSize); message WM_SIZE;

This item has no description.

Properties

Public property CurX: integer read FCurX write SetCurX;

This item has no description.

Public property CurY: integer read FCurY write SetCurY;

This item has no description.

Public property DelErase: Boolean read FDelErase write FDelErase;

This item has no description.

Public property LineStyle[Index: integer]: integer read GetLineStyle write SetLineStyle;

This item has no description.

Public property Selection: string read GetSelText write SetSelText;

This item has no description.

Public property SelEnd: TPoint read GetSelEnd;

This item has no description.

Public property SelLength: integer read GetSelLength;

This item has no description.

Public property SelStart: TPoint read GetSelStart;

This item has no description.

Public property Styles: TStyleList read FStyles;

This item has no description.

Public property UndoList: TGLSMemoUndoList read FUndoList write FUndoList;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemo

Class TGLSMemo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemo = class(TGLSCustomMemo)

Description

This item has no description.

Hierarchy

  • TCustomControl
  • TGLSMemoAbstractScrollableObject
  • TGLSCustomMemo
  • TGLSMemo

Overview

Properties

Published | property Align;
Published | property AutoIndent;
Published | property BkColor;
Published | property DelErase;
Published | property Enabled;
Published | property Font;
Published | property GutterColor;
Published | property GutterWidth;
Published | property HiddenCaret;
Published | property Lines;
Published | property OnAttrChange;
Published | property OnChange;
Published | property OnClick;
Published | property OnDblClick;
Published | property OnDragDrop;
Published | property OnDragOver;
Published | property OnEndDrag;
Published | property OnEnter;
Published | property OnExit;
Published | property OnGetLineAttrs;
Published | property OnGutterClick;
Published | property OnGutterDraw;
Published | property OnKeyDown;
Published | property OnKeyPress;
Published | property OnKeyUp;
Published | property OnMouseDown;
Published | property OnMouseMove;
Published | property OnMouseUp;
Published | property OnMoveCursor;
Published | property OnSelectionChange;
Published | property OnStartDrag;
Published | property OnStatusChange;
Published | property OnUndoChange;
Published | property PopupMenu;
Published | property ReadOnly;
Published | property ScrollBars;
Published | property ScrollMode;
Published | property SelBkColor;
Published | property SelColor;
Published | property Selection;
Published | property ShowHint;
Published | property TabOrder;
Published | property TabSize;
Published | property TabStop;
Published | property UndoLimit;
Published | property Visible;

Description

Properties

Published property Align;

TCustomControl

Published property AutoIndent;

TGLSCustomMemo

Published property BkColor;

This item has no description.

Published property DelErase;

This item has no description.

Published property Enabled;

This item has no description.

Published property Font;

This item has no description.

Published property GutterColor;

This item has no description.

Published property GutterWidth;

This item has no description.

Published property HiddenCaret;

This item has no description.

Published property Lines;

This item has no description.

Published property OnAttrChange;

This item has no description.

Published property OnChange;

This item has no description.

Published property OnClick;

Inherited events

Published property OnDblClick;

This item has no description.

Published property OnDragDrop;

This item has no description.

Published property OnDragOver;

This item has no description.

Published property OnEndDrag;

This item has no description.

Published property OnEnter;

This item has no description.

Published property OnExit;

This item has no description.

Published property OnGetLineAttrs;

This item has no description.

Published property OnGutterClick;

This item has no description.

Published property OnGutterDraw;

Events

Published property OnKeyDown;

This item has no description.

Published property OnKeyPress;

This item has no description.

Published property OnKeyUp;

This item has no description.

Published property OnMouseDown;

This item has no description.

Published property OnMouseMove;

This item has no description.

Published property OnMouseUp;

This item has no description.

Published property OnMoveCursor;

This item has no description.

Published property OnSelectionChange;

This item has no description.

Published property OnStartDrag;

This item has no description.

Published property OnStatusChange;

This item has no description.

Published property OnUndoChange;

This item has no description.

Published property PopupMenu;

TControl

Published property ReadOnly;

This item has no description.

Published property ScrollBars;

This item has no description.

Published property ScrollMode;

This item has no description.

Published property SelBkColor;

This item has no description.

Published property SelColor;

This item has no description.

Published property Selection;

This item has no description.

Published property ShowHint;

This item has no description.

Published property TabOrder;

This item has no description.

Published property TabSize;

This item has no description.

Published property TabStop;

This item has no description.

Published property UndoLimit;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.Memo: Class TGLSMemoStringList

Class TGLSMemoStringList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSMemoStringList = class(TStringList)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TStrings
  • TStringList
  • TGLSMemoStringList

Overview

Methods

Private | procedure ReadStrings(Reader: TReader);
Private | procedure WriteStrings(Writer: TWriter);

Description

Methods

Private procedure ReadStrings(Reader: TReader);

This item has no description.

Private procedure WriteStrings(Writer: TWriter);


GLSysHelp v.2.5: GLS.Memo: Class TGLSSynHiMemo

Class TGLSSynHiMemo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Memo

Declaration

type TGLSSynHiMemo = class(TGLSCustomMemo)

Description

————————————————————– SYNTAX MEMO - declaration ————————————————————–

Hierarchy

  • TCustomControl
  • TGLSMemoAbstractScrollableObject
  • TGLSCustomMemo
  • TGLSSynHiMemo

Overview

Fields

Private | FIsPainting: Boolean;
Private | FInComment: Boolean;
Private | FWordList: TGLSMemoStringList;
Private | FSpecialList: TGLSMemoStringList;
Private | FBracketList: TGLSMemoStringList;
Private | FDelimiters: TDelimiters;
Private | FInBrackets: integer;
Private | FLineComment: string;
Private | FMultiCommentLeft: string;
Private | FMultiCommentRight: string;
Private | FDelimiterStyle: TCharStyle;
Private | FCommentStyle: TCharStyle;
Private | FNumberStyle: TCharStyle;
Private | FDelimiterStyleNo: integer;
Private | FCommentStyleNo: integer;
Private | FNumberStyleNo: integer;
Private | FCaseSensitive: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetToken(const S: string; var From: integer; out TokenType: TTokenType; out StyleNo: integer): string;
Public | procedure AddBrackets(StyleNo: integer; const ArrS: array of string);
Public | procedure AddSpecial(StyleNo: integer; const ArrS: array of string);
Public | procedure AddWord(StyleNo: integer; const ArrS: array of string);
Private | procedure FindLineAttrs(Sender: TObject; LineNo: integer; var Attrs: string);
Private | procedure SetBracketList(Value: TGLSMemoStringList);
Private | procedure SetCaseSensitive(Value: Boolean);
Private | procedure SetSpecialList(Value: TGLSMemoStringList);
Private | procedure SetStyle(Index: integer; Value: TCharStyle);
Private | procedure SetWordList(Value: TGLSMemoStringList);

Properties

Published | property Align;
Published | property AutoIndent;
Published | property BkColor;
Published | property BracketList: TGLSMemoStringList read FBracketList write SetBracketList;
Published | property CaseSensitive: Boolean read FCaseSensitive write SetCaseSensitive;
Published | property CommentStyle: TCharStyle index 1 read FCommentStyle write SetStyle;
Published | property DelErase;
Public | property Delimiters: TDelimiters read FDelimiters write FDelimiters;
Published | property DelimiterStyle: TCharStyle index 0 read FDelimiterStyle write SetStyle;
Published | property Enabled;
Published | property Font;
Published | property GutterColor;
Published | property GutterWidth;
Published | property HiddenCaret;
Published | property LineComment: string read FLineComment write FLineComment;
Published | property Lines;
Published | property MultiCommentLeft: string read FMultiCommentLeft write FMultiCommentLeft;
Published | property MultiCommentRight: string read FMultiCommentRight write FMultiCommentRight;
Published | property NumberStyle: TCharStyle index 2 read FNumberStyle write SetStyle;
Published | property OnChange;
Published | property OnClick;
Published | property OnDblClick;
Published | property OnDragDrop;
Published | property OnDragOver;
Published | property OnEndDrag;
Published | property OnEnter;
Published | property OnExit;
Published | property OnGutterClick;
Published | property OnGutterDraw;
Published | property OnKeyDown;
Published | property OnKeyPress;
Published | property OnKeyUp;
Published | property OnMouseDown;
Published | property OnMouseMove;
Published | property OnMouseUp;
Published | property OnMoveCursor;
Published | property OnSelectionChange;
Published | property OnStartDrag;
Published | property OnStatusChange;
Published | property OnUndoChange;
Published | property PopupMenu;
Published | property ReadOnly;
Published | property ScrollBars;
Published | property ScrollMode;
Published | property SelBkColor;
Published | property SelColor;
Published | property ShowHint;
Published | property SpecialList: TGLSMemoStringList read FSpecialList write SetSpecialList;
Published | property TabOrder;
Published | property TabSize;
Published | property TabStop;
Published | property UndoLimit;
Published | property Visible;
Published | property WordList: TGLSMemoStringList read FWordList write SetWordList;

Description

Fields

Private FIsPainting: Boolean;

This item has no description.

Private FInComment: Boolean;

This item has no description.

Private FWordList: TGLSMemoStringList;

This item has no description.

Private FSpecialList: TGLSMemoStringList;

This item has no description.

Private FBracketList: TGLSMemoStringList;

This item has no description.

Private FDelimiters: TDelimiters;

This item has no description.

Private FInBrackets: integer;

This item has no description.

Private FLineComment: string;

This item has no description.

Private FMultiCommentLeft: string;

This item has no description.

Private FMultiCommentRight: string;

This item has no description.

Private FDelimiterStyle: TCharStyle;

This item has no description.

Private FCommentStyle: TCharStyle;

This item has no description.

Private FNumberStyle: TCharStyle;

This item has no description.

Private FDelimiterStyleNo: integer;

This item has no description.

Private FCommentStyleNo: integer;

This item has no description.

Private FNumberStyleNo: integer;

This item has no description.

Private FCaseSensitive: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetToken(const S: string; var From: integer; out TokenType: TTokenType; out StyleNo: integer): string;

This item has no description.

Public procedure AddBrackets(StyleNo: integer; const ArrS: array of string);

This item has no description.

Public procedure AddSpecial(StyleNo: integer; const ArrS: array of string);

This item has no description.

Public procedure AddWord(StyleNo: integer; const ArrS: array of string);

This item has no description.

Private procedure FindLineAttrs(Sender: TObject; LineNo: integer; var Attrs: string);

This item has no description.

Private procedure SetBracketList(Value: TGLSMemoStringList);

This item has no description.

Private procedure SetCaseSensitive(Value: Boolean);

This item has no description.

Private procedure SetSpecialList(Value: TGLSMemoStringList);

This item has no description.

Private procedure SetStyle(Index: integer; Value: TCharStyle);

This item has no description.

Private procedure SetWordList(Value: TGLSMemoStringList);

This item has no description.

Properties

Published property Align;

TCustomControl

Published property AutoIndent;

TGLSCustomMemo

Published property BkColor;

This item has no description.

Published property BracketList: TGLSMemoStringList read FBracketList write SetBracketList;

This item has no description.

Published property CaseSensitive: Boolean read FCaseSensitive write SetCaseSensitive;

This item has no description.

Published property CommentStyle: TCharStyle index 1 read FCommentStyle write SetStyle;

This item has no description.

Published property DelErase;

This item has no description.

Public property Delimiters: TDelimiters read FDelimiters write FDelimiters;

This item has no description.

Published property DelimiterStyle: TCharStyle index 0 read FDelimiterStyle write SetStyle;

This item has no description.

Published property Enabled;

This item has no description.

Published property Font;

This item has no description.

Published property GutterColor;

This item has no description.

Published property GutterWidth;

This item has no description.

Published property HiddenCaret;

This item has no description.

Published property LineComment: string read FLineComment write FLineComment;

TGLSSyntaxMemo

Published property Lines;

This item has no description.

Published property MultiCommentLeft: string read FMultiCommentLeft write FMultiCommentLeft;

This item has no description.

Published property MultiCommentRight: string read FMultiCommentRight write FMultiCommentRight;

This item has no description.

Published property NumberStyle: TCharStyle index 2 read FNumberStyle write SetStyle;

This item has no description.

Published property OnChange;

This item has no description.

Published property OnClick;

Inherited events

Published property OnDblClick;

This item has no description.

Published property OnDragDrop;

This item has no description.

Published property OnDragOver;

This item has no description.

Published property OnEndDrag;

This item has no description.

Published property OnEnter;

This item has no description.

Published property OnExit;

This item has no description.

Published property OnGutterClick;

Events

Published property OnGutterDraw;

This item has no description.

Published property OnKeyDown;

This item has no description.

Published property OnKeyPress;

This item has no description.

Published property OnKeyUp;

This item has no description.

Published property OnMouseDown;

This item has no description.

Published property OnMouseMove;

This item has no description.

Published property OnMouseUp;

This item has no description.

Published property OnMoveCursor;

This item has no description.

Published property OnSelectionChange;

This item has no description.

Published property OnStartDrag;

This item has no description.

Published property OnStatusChange;

This item has no description.

Published property OnUndoChange;

This item has no description.

Published property PopupMenu;

TControl

Published property ReadOnly;

This item has no description.

Published property ScrollBars;

This item has no description.

Published property ScrollMode;

This item has no description.

Published property SelBkColor;

This item has no description.

Published property SelColor;

This item has no description.

Published property ShowHint;

This item has no description.

Published property SpecialList: TGLSMemoStringList read FSpecialList write SetSpecialList;

This item has no description.

Published property TabOrder;

This item has no description.

Published property TabSize;

This item has no description.

Published property TabStop;

This item has no description.

Published property UndoLimit;

This item has no description.

Published property Visible;

This item has no description.

Published property WordList: TGLSMemoStringList read FWordList write SetWordList;


GLSysHelp v.2.5: GLS.Mesh

Unit GLS.Mesh

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.Strings
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.XOpenGL
  • GLS.Context
  • GLS.Scene
  • GLS.State
  • GLS.Color
  • GLS.BaseClasses
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TGLVertexData |
Class TGLVertexList |
Class TGLMesh |

Types

PGLVertexData = ˆTGLVertexData;
PGLVertexDataArray = ˆTGLVertexDataArray;
TGLMeshMode = (...);
TGLVertexDataArray = array[0..(MAXINT shr 6)] of TGLVertexData;
TGLVertexMode = (...);

Constants

cMeshModeToGLEnum: array[Low(TGLMeshMode)..High(TGLMeshMode) ] of Cardinal = (GL_TRIANGLE_STRIP, GL_TRIANGLE_FAN, GL_TRIANGLES, GL_QUAD_STRIP, GL_QUADS, GL_POLYGON);
cVertexModeToGLEnum: array[Low(TGLVertexMode)..High(TGLVertexMode) ] of Cardinal = (GL_V3F, GL_N3F_V3F, GL_C4F_N3F_V3F, GL_T2F_C4F_N3F_V3F, GL_T2F_N3F_V3F, GL_T2F_V3F);

Description

Types

PGLVertexData = ˆTGLVertexData;

This item has no description.

PGLVertexDataArray = ˆTGLVertexDataArray;

This item has no description.

TGLMeshMode = (...);

This item has no description.

Values
  • mmTriangleStrip
  • mmTriangleFan
  • mmTriangles
  • mmQuadStrip
  • mmQuads
  • mmPolygon
TGLVertexDataArray = array[0..(MAXINT shr 6)] of TGLVertexData;

This item has no description.

TGLVertexMode = (...);

This item has no description.

Values
  • vmV
  • vmVN
  • vmVNC
  • vmVNCT
  • vmVNT
  • vmVT

Constants

cMeshModeToGLEnum: array[Low(TGLMeshMode)..High(TGLMeshMode) ] of Cardinal = (GL_TRIANGLE_STRIP, GL_TRIANGLE_FAN, GL_TRIANGLES, GL_QUAD_STRIP, GL_QUADS, GL_POLYGON);

This item has no description.

cVertexModeToGLEnum: array[Low(TGLVertexMode)..High(TGLVertexMode) ] of Cardinal = (GL_V3F, GL_N3F_V3F, GL_C4F_N3F_V3F, GL_T2F_C4F_N3F_V3F, GL_T2F_N3F_V3F, GL_T2F_V3F);


GLSysHelp v.2.5: GLS.Mesh: Packed Record TGLVertexData

Packed Record TGLVertexData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Mesh

Declaration

type TGLVertexData = packed record

Description

This item has no description.

Overview

Fields

Public | textCoord: TTexPoint;
Public | color: TGLVector;
Public | normal: TAffineVector;
Public | coord: TVertex;

Description

Fields

Public textCoord: TTexPoint;

This item has no description.

Public color: TGLVector;

This item has no description.

Public normal: TAffineVector;

This item has no description.

Public coord: TVertex;


GLSysHelp v.2.5: GLS.Mesh: Class TGLVertexList

Class TGLVertexList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Mesh

Declaration

type TGLVertexList = class(TGLUpdateAbleObject)

Description

Stores an interlaced vertex list for direct use in OpenGL. Locking (hardware passthrough) is supported, see "Locked" property for details.

Hierarchy

  • TGLUpdateAbleObject
  • TGLVertexList

Overview

Fields

Private | FValues: PGLVertexDataArray;
Private | FCount: Integer;
Private | FCapacity: Integer;
Private | FGrowth: Integer;
Private | FLockedOldValues: PGLVertexDataArray;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function CreateInterpolatedCoords(list2: TGLVertexList; lerpFactor: Single): TGLVertexList;
Public | function SumVertexCoords: TAffineVector;
Public | procedure AddVertex(const vertex: TVertex; const normal: TAffineVector; const color: TGLColorVector); overload;
Public | procedure AddVertex(const vertex: TVertex; const normal: TAffineVector); overload;
Public | procedure AddVertex(const vertexData: TGLVertexData); overload;
Public | procedure AddVertex(const aVertex: TVertex; const aNormal: TAffineVector; const aColor: TGLColorVector; const aTexPoint: TTexPoint); overload;
Public | procedure AddVertex3(const vd1, vd2, vd3: TGLVertexData); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure DefineOpenGLArrays;
Public | procedure DuplicateVertex(index: Integer);
Public | procedure EnterLockSection;
Public | procedure GetExtents(var min, max: TAffineVector);
Public | procedure LeaveLockSection;
Public | procedure NormalizeNormals;
Public | procedure Translate(const v: TAffineVector);

Properties

Public | property Capacity: Integer read FCapacity write SetCapacity;
Public | property Count: Integer read FCount;
Public | property FirstColor: PGLFloat read GetFirstColor;
Public | property FirstEntry: PGLFloat read GetFirstEntry;
Public | property FirstNormal: PGLFloat read GetFirstNormal;
Public | property FirstTexPoint: PGLFloat read GetFirstTexPoint;
Public | property FirstVertex: PGLFloat read GetFirstVertex;
Public | property Growth: Integer read FGrowth write SetGrowth;
Public | property Locked: Boolean read GetLocked write SetLocked;
Public | property VertexColor[index: Integer]: TVector4f read GetVertexColor write SetVertexColor;
Public | property VertexCoord[index: Integer]: TAffineVector read GetVertexCoord write SetVertexCoord;
Public | property VertexNormal[index: Integer]: TAffineVector read GetVertexNormal write SetVertexNormal;
Public | property VertexTexCoord[index: Integer]: TTexPoint read GetVertexTexCoord write SetVertexTexCoord;
Public | property Vertices[index: Integer]: TGLVertexData read GetVertices write SetVertices;

Description

Fields

Private FValues: PGLVertexDataArray;

This item has no description.

Private FCount: Integer;

This item has no description.

Private FCapacity: Integer;

This item has no description.

Private FGrowth: Integer;

This item has no description.

Private FLockedOldValues: PGLVertexDataArray;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateInterpolatedCoords(list2: TGLVertexList; lerpFactor: Single): TGLVertexList;

This item has no description.

Public function SumVertexCoords: TAffineVector;

Calculates the sum of all vertex coords

Public procedure AddVertex(const vertex: TVertex; const normal: TAffineVector; const color: TGLColorVector); overload;

Adds a vertex to the list, no texturing version.

Public procedure AddVertex(const vertex: TVertex; const normal: TAffineVector); overload;

Adds a vertex to the list, no texturing, not color version.

Public procedure AddVertex(const vertexData: TGLVertexData); overload;

Adds a vertex to the list, fastest method.

Public procedure AddVertex(const aVertex: TVertex; const aNormal: TAffineVector; const aColor: TGLColorVector; const aTexPoint: TTexPoint); overload;

Adds a vertex to the list. Use the NullVector, NullHmgVector or NullTexPoint constants for params you don't want to set.

Public procedure AddVertex3(const vd1, vd2, vd3: TGLVertexData); overload;

Adds a vertex to the list, fastest method for adding a triangle.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure DefineOpenGLArrays;

This item has no description.

Public procedure DuplicateVertex(index: Integer);

Duplicates the vertex of given index and adds it at the end of the list.

Public procedure EnterLockSection;

This item has no description.

Public procedure GetExtents(var min, max: TAffineVector);

Calculates the extents of the vertice coords.

Public procedure LeaveLockSection;

This item has no description.

Public procedure NormalizeNormals;

Normalizes all normals.

Public procedure Translate(const v: TAffineVector);

Translate all coords by given vector

Properties

Public property Capacity: Integer read FCapacity write SetCapacity;

Capacity of the list (nb of vertex). Use this to allocate memory quickly before calling AddVertex.

Public property Count: Integer read FCount;

This item has no description.

Public property FirstColor: PGLFloat read GetFirstColor;

This item has no description.

Public property FirstEntry: PGLFloat read GetFirstEntry;

This item has no description.

Public property FirstNormal: PGLFloat read GetFirstNormal;

This item has no description.

Public property FirstTexPoint: PGLFloat read GetFirstTexPoint;

This item has no description.

Public property FirstVertex: PGLFloat read GetFirstVertex;

This item has no description.

Public property Growth: Integer read FGrowth write SetGrowth;

Vertex capacity that will be added each time the list needs to grow. default value is 256 (chunks of approx 13 kb).

Public property Locked: Boolean read GetLocked write SetLocked;

Locking state of the vertex list. You can "Lock" a list to increase rendering performance on some OpenGL implementations (NVidia's). A Locked list size shouldn't be changed and calculations should be avoided. Performance can only be gained from a lock for osDirectDraw object, ie. meshes that are updated for each frame (the default build list mode is faster on static meshes). Be aware that the "Locked" state enforcement is not very strict to avoid performance hits, and GLScene may not always notify you that you're doing things you shouldn't on a locked list!

Public property VertexColor[index: Integer]: TVector4f read GetVertexColor write SetVertexColor;

This item has no description.

Public property VertexCoord[index: Integer]: TAffineVector read GetVertexCoord write SetVertexCoord;

This item has no description.

Public property VertexNormal[index: Integer]: TAffineVector read GetVertexNormal write SetVertexNormal;

This item has no description.

Public property VertexTexCoord[index: Integer]: TTexPoint read GetVertexTexCoord write SetVertexTexCoord;

This item has no description.

Public property Vertices[index: Integer]: TGLVertexData read GetVertices write SetVertices;


GLSysHelp v.2.5: GLS.Mesh: Class TGLMesh

Class TGLMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Mesh

Declaration

type TGLMesh = class(TGLSceneObject)

Description

Basic mesh object. Each mesh holds a set of vertices and a Mode value defines how they make up the mesh (triangles, strips...)

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMesh

Overview

Fields

Private | FVertices: TGLVertexList;
Private | FMode: TGLMeshMode;
Private | FVertexMode: TGLVertexMode;
Private | FAxisAlignedDimensionsCache: TGLVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Area: Single;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function Length: Single;
Public | function Volume: Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure CalcNormals(Frontface: TGLFaceWinding);
Public | procedure StructureChanged; override;

Properties

Published | property Mode: TGLMeshMode read FMode write SetMode;
Published | property VertexMode: TGLVertexMode read FVertexMode write SetVertexMode default vmVNCT;
Public | property Vertices: TGLVertexList read FVertices write SetVertices;

Description

Fields

Private FVertices: TGLVertexList;

This item has no description.

Private FMode: TGLMeshMode;

This item has no description.

Private FVertexMode: TGLVertexMode;

This item has no description.

Private FAxisAlignedDimensionsCache: TGLVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Area: Single;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function Length: Single;

This item has no description.

Public function Volume: Single;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure CalcNormals(Frontface: TGLFaceWinding);

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Mode: TGLMeshMode read FMode write SetMode;

This item has no description.

Published property VertexMode: TGLVertexMode read FVertexMode write SetVertexMode default vmVNCT;

This item has no description.

Public property Vertices: TGLVertexList read FVertices write SetVertices;


GLSysHelp v.2.5: GLS.MeshBSP

Unit GLS.MeshBSP

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLS.VectorFileObjects
  • GLS.Material
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.Color
  • GLS.RenderContextInfo
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TBSPCullingSphere |
Record TBSPRenderContextInfo |
Class TBSPClusterVisibility |
Class TBSPMeshObject |
Class TFGBSPNode |

Types

TBSPRenderSort = (...);

Description

Types

TBSPRenderSort = (...);

This item has no description.

Values
  • rsNone
  • rsBackToFront
  • rsFrontToBack


GLSysHelp v.2.5: GLS.MeshBSP: Record TBSPCullingSphere

Record TBSPCullingSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshBSP

Declaration

type TBSPCullingSphere = record

Description

This item has no description.

Overview

Fields

Public | position: TGLVector;
Public | radius: Single;

Description

Fields

Public position: TGLVector;

This item has no description.

Public radius: Single;


GLSysHelp v.2.5: GLS.MeshBSP: Record TBSPRenderContextInfo

Record TBSPRenderContextInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshBSP

Declaration

type TBSPRenderContextInfo = record

Description

This item has no description.

Overview

Fields

Public | cameraLocal: TGLVector;
Public | rci: PGLRenderContextInfo;
Public | faceGroups: TList;
Public | cullingSpheres: array of TBSPCullingSphere;

Description

Fields

Public cameraLocal: TGLVector;

Local coordinates of the camera (can be a vector or point)

Public rci: PGLRenderContextInfo;

This item has no description.

Public faceGroups: TList;

This item has no description.

Public cullingSpheres: array of TBSPCullingSphere;


GLSysHelp v.2.5: GLS.MeshBSP: Class TBSPClusterVisibility

Class TBSPClusterVisibility

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshBSP

Declaration

type TBSPClusterVisibility = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TBSPClusterVisibility

Overview

Fields

Private | FData: PByteArray;
Private | FSize: Integer;
Private | FBytesPerCluster: Integer;
Private | FCount: Integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure SetData(Source: PByte; NumClusters: Integer);

Properties

Public | property Count: Integer read FCount write SetCount;
Public | property Visibility[src,dst: Integer]: Boolean read GetVisibility write SetVisibility;

Description

Fields

Private FData: PByteArray;

This item has no description.

Private FSize: Integer;

This item has no description.

Private FBytesPerCluster: Integer;

This item has no description.

Private FCount: Integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure SetData(Source: PByte; NumClusters: Integer);

This item has no description.

Properties

Public property Count: Integer read FCount write SetCount;

This item has no description.

Public property Visibility[src,dst: Integer]: Boolean read GetVisibility write SetVisibility;


GLSysHelp v.2.5: GLS.MeshBSP: Class TBSPMeshObject

Class TBSPMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshBSP

Declaration

type TBSPMeshObject = class(TGLMeshObject)

Description

A BSP mesh object. Stores the geometry information, BSP rendering options and offers some basic BSP utility methods. Geometry information is indexed in the facegroups, the 1st facegroup (of index 0) being the root node of the BSP tree.

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TBSPMeshObject

Overview

Fields

Private | FRenderSort: TBSPRenderSort;
Private | FClusterVisibility: TBSPClusterVisibility;
Private | FUseClusterVisibility: Boolean;

Methods

Public | constructor CreateOwned(AOwner: TGLMeshObjectList);
Public | destructor Destroy; override;
Public | function AverageDepth: Single;
Public | function FindNodeByPoint(const aPoint: TGLVector): TFGBSPNode;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure CleanupUnusedNodes;

Properties

Public | property ClusterVisibility: TBSPClusterVisibility read FClusterVisibility;
Public | property RenderSort: TBSPRenderSort read FRenderSort write FRenderSort;
Public | property UseClusterVisibility: Boolean read FUseClusterVisibility write FUseClusterVisibility;

Description

Fields

Private FRenderSort: TBSPRenderSort;

This item has no description.

Private FClusterVisibility: TBSPClusterVisibility;

This item has no description.

Private FUseClusterVisibility: Boolean;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TGLMeshObjectList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AverageDepth: Single;

Returns the average BSP tree depth of end nodes. Sums up the depth each end node (starting at 1 for root node), divides by the number of end nodes. This is a simple estimator of tree balancing (structurally speaking, not polygon-wise).

Public function FindNodeByPoint(const aPoint: TGLVector): TFGBSPNode;

Traverses the tree to the given point and returns the node index.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLMeshObject.BuildList.

Similar to regular scene object's BuildList method

Public procedure CleanupUnusedNodes;

Drops all unused nodes from the facegroups list. An unused node is a node that renders nothing and whose children render nothing. Indices are remapped in the process.

Properties

Public property ClusterVisibility: TBSPClusterVisibility read FClusterVisibility;

Cluster visibility. A property for defining node cluster-cluster visibility potential.

Public property RenderSort: TBSPRenderSort read FRenderSort write FRenderSort;

Rendering sort mode. This sort mode can currently *not* blend with the sort by materials flag, default mode is rsBackToFront. Note that in rsNone mode, the hierarchical nature of the tree is still honoured (positive subnode, self, then negative subnode).

Public property UseClusterVisibility: Boolean read FUseClusterVisibility write FUseClusterVisibility;

Use cluster visibility. Toggles the use of the visibility set for culling clusters of nodes when rendering.


GLSysHelp v.2.5: GLS.MeshBSP: Class TFGBSPNode

Class TFGBSPNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshBSP

Declaration

type TFGBSPNode = class(TFGVertexIndexList)

Description

A node in the BSP tree. The description does not explicitly differentiates nodes and leafs, nodes are referred by their index.

Hierarchy

  • TGLPersistentObject
  • TGLFaceGroup
  • TFGVertexIndexList
  • TFGBSPNode

Overview

Fields

Private | FSplitPlane: THmgPlane;
Private | FPositiveSubNodeIndex: Integer;
Private | FNegativeSubNodeIndex: Integer;
Private | FCluster: Integer;

Methods

Public | constructor CreateOwned(AOwner: TGLFaceGroups); override;
Public | destructor Destroy; override;
Public | function FindSplitPlane(triangleSplitCost: Single = 1; triangleImbalanceCost: Single = 0.5): THmgPlane;
Public | procedure CollectBackToFront(var bsprci: TBSPRenderContextInfo);
Public | procedure CollectFrontToBack(var bsprci: TBSPRenderContextInfo);
Public | procedure CollectNoSort(var bsprci: TBSPRenderContextInfo);
Public | procedure EvaluateSplitPlane(const splitPlane: THmgPlane; var nbTriangleSplit: Integer; var nbPositiveTriangles: Integer; var nbNegativeTriangles: Integer);
Public | procedure FixTJunctions(const tJunctionsCandidates: TGLIntegerList);
Public | procedure IsCulled(const bsprci: TBSPRenderContextInfo; var positive, negative: Boolean);
Public | procedure PerformSplit(const splitPlane: THmgPlane; const maxTrianglesPerLeaf: Integer = MaxInt);

Properties

Public | property Cluster: Integer read FCluster write FCluster;
Public | property NegativeSubNodeIndex: Integer read FNegativeSubNodeIndex write FNegativeSubNodeIndex;
Public | property PositiveSubNodeIndex: Integer read FPositiveSubNodeIndex write FPositiveSubNodeIndex;
Public | property splitPlane: THmgPlane read FSplitPlane write FSplitPlane;

Description

Fields

Private FSplitPlane: THmgPlane;

This item has no description.

Private FPositiveSubNodeIndex: Integer;

This item has no description.

Private FNegativeSubNodeIndex: Integer;

This item has no description.

Private FCluster: Integer;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TGLFaceGroups); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindSplitPlane(triangleSplitCost: Single = 1; triangleImbalanceCost: Single = 0.5): THmgPlane;

Try to find a 'decent' split plane for the node. Use this function to build a BSP tree, on leafy nodes. The split plane is chosen among the polygon planes, the coefficient are used to determine what a 'good' split plane is by assigning a cost to splitted triangles (cut by the split plane) and tree imbalance.

Public procedure CollectBackToFront(var bsprci: TBSPRenderContextInfo);

This item has no description.

Public procedure CollectFrontToBack(var bsprci: TBSPRenderContextInfo);

This item has no description.

Public procedure CollectNoSort(var bsprci: TBSPRenderContextInfo);

This item has no description.

Public procedure EvaluateSplitPlane(const splitPlane: THmgPlane; var nbTriangleSplit: Integer; var nbPositiveTriangles: Integer; var nbNegativeTriangles: Integer);

Evaluates a split plane. Used by FindSplitPlane. For splitted triangles, the extra spawned triangles required are accounted for in the nbXxxTriangles values.

Public procedure FixTJunctions(const tJunctionsCandidates: TGLIntegerList);

Goes through all triangle edges, looking for tjunctions. The candidates are indices of points to lookup a tjunction vertices.

Public procedure IsCulled(const bsprci: TBSPRenderContextInfo; var positive, negative: Boolean);

This item has no description.

Public procedure PerformSplit(const splitPlane: THmgPlane; const maxTrianglesPerLeaf: Integer = MaxInt);

Splits a leafy node along the specified plane. Will trigger an exception if the node already has subnodes. Currently also changes the mode from strips/fan to list.

Properties

Public property Cluster: Integer read FCluster write FCluster;

The index of the cluster that this node belongs to. Used for visibility determination.

Public property NegativeSubNodeIndex: Integer read FNegativeSubNodeIndex write FNegativeSubNodeIndex;

Index of the negative sub-node index in the list. Zero if empty.

Public property PositiveSubNodeIndex: Integer read FPositiveSubNodeIndex write FPositiveSubNodeIndex;

Index of the positive sub-node index in the list. Zero if empty.

Public property splitPlane: THmgPlane read FSplitPlane write FSplitPlane;

BSP node split plane. Divides space between positive and negative half-space, positive half-space being the one were the evaluation of an homogeneous vector against the plane is positive.


GLSysHelp v.2.5: GLS.MeshBuilder

Unit GLS.MeshBuilder

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.PersistentClasses
  • GLS.Scene
  • GLS.VectorFileObjects
  • GLS.MeshUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLHexahedronProperties |
Record TGLSphereProperties |
Record TGLCylinderProperties |

Functions and Procedures

procedure BuildMeshCube(Mesh : TGLMeshObject; const Position, Scale : TAffineVector);
procedure BuildMeshCylinder(Mesh : TGLMeshObject; const Position, Scale : TAffineVector; Slices : Integer);
procedure BuildMeshCylinderAdv(Mesh: TGLMeshObject; const Position, Scale: TAffineVector; TopRadius, BottomRadius, Height: single; Slices: Integer);
procedure BuildMeshHemiSphere(Mesh: TGLMeshObject; const Position, Scale: TAffineVector);
procedure BuildMeshHemiCylinder(Mesh: TGLMeshObject; const Position, Scale: TAffineVector; Slices: Integer);
procedure MakeMeshHexahedron(MeshObject: TGLMeshObject);
procedure MakeMeshTetrahedron(MeshObject: TGLMeshObject);
procedure MakeMeshSphere(MeshObject: TGLMeshObject);
procedure OptimizeMesh(aList: TGLMeshObjectList; options: TGLMeshOptimizerOptions); overload;
procedure OptimizeMesh(aList: TGLMeshObjectList); overload;
procedure OptimizeMesh(aMeshObject: TGLMeshObject; options: TGLMeshOptimizerOptions); overload;
procedure OptimizeMesh(aMeshObject: TGLMeshObject); overload;
procedure FacesSmooth(aMeshObj: TGLMeshObject; aWeldDistance: Single = 0.0000001; aThreshold: Single = 35.0; InvertNormals: boolean = false);

Types

TGLMeshOptimizerOption = (...);
TGLMeshOptimizerOptions = set of TGLMeshOptimizerOption;

Constants

cMeshHexahedron: array [0 .. 5] of TGLHexahedronProperties = (( VertexCoords: ((X: - 1; Y: - 1; Z: 1), (X: 1; Y: - 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: - 1; Y: 1; Z: 1)); TextureCoords: ((X: 0; Y: 0), (X: 1; Y: 0), (X: 1; Y: 1), (X: 0; Y: 1)); PartIndices: (0, 1, 2, 2, 3, 0); Material: 'Front';), ( VertexCoords: ((X: - 1; Y: - 1; Z: - 1), (X: - 1; Y: 1; Z: - 1), (X: 1; Y: 1; Z: - 1), (X: 1; Y: - 1; Z: - 1)); TextureCoords: ((X: 1; Y: 0), (X: 1; Y: 1), (X: 0; Y: 1), (X: 0; Y: 0)); PartIndices: (4, 5, 6, 6, 7, 4); Material: 'Back';), ( VertexCoords: ((X: - 1; Y: 1; Z: - 1), (X: - 1; Y: 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: 1; Z: - 1)); TextureCoords: ((X: 0; Y: 1), (X: 0; Y: 0), (X: 1; Y: 0), (X: 1; Y: 1)); PartIndices: (8, 9, 10, 10, 11, 8); Material: 'Top';), ( VertexCoords: ((X: - 1; Y: - 1; Z: - 1), (X: 1; Y: - 1; Z: - 1), (X: 1; Y: - 1; Z: 1), (X: - 1; Y: - 1; Z: 1)); TextureCoords: ((X: 1; Y: 1), (X: 0; Y: 1), (X: 0; Y: 0), (X: 1; Y: 0)); PartIndices: (12, 13, 14, 14, 15, 12); Material: 'Bottom';), ( VertexCoords: ((X: 1; Y: - 1; Z: - 1), (X: 1; Y: 1; Z: - 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: - 1; Z: 1)); TextureCoords: ((X: 1; Y: 0), (X: 1; Y: 1), (X: 0; Y: 1), (X: 0; Y: 0)); PartIndices: (16, 17, 18, 18, 19, 16); Material: 'Right';), ( VertexCoords: ((X: - 1; Y: - 1; Z: - 1), (X: - 1; Y: - 1; Z: 1), (X: - 1; Y: 1; Z: 1), (X: - 1; Y: 1; Z: - 1)); TextureCoords: ((X: 0; Y: 0), (X: 1; Y: 0), (X: 1; Y: 1), (X: 0; Y: 1)); PartIndices: (20, 21, 22, 22, 23, 20); Material: 'Left';));
cMeshSphere: array [0 .. 1] of TGLSphereProperties = (( VertexCoords: ((X: - 1; Y: 1; Z: - 1), (X: - 1; Y: 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: 1; Z: - 1), (X: 0; Y: 1; Z: 0)); TextureCoords: ((X: 0; Y: 1), (X: 0; Y: 0), (X: 1; Y: 0), (X: 1; Y: 1), (X: 1; Y: 1)); PartIndices: (0, 1); Material: 'Top';), ( VertexCoords: ((X: - 1; Y: - 1; Z: - 1), (X: 1; Y: - 1; Z: - 1), (X: 1; Y: - 1; Z: 1), (X: - 1; Y: - 1; Z: 1), (X: - 1; Y: - 1; Z: 1)); TextureCoords: ((X: 1; Y: 1), (X: 0; Y: 1), (X: 0; Y: 0), (X: 1; Y: 0), (X: 0; Y: 0)); PartIndices: (1, 2); Material: 'Bottom';));

Variables

vDefaultMeshOptimizerOptions: TGLMeshOptimizerOptions = [mooStandardize, mooVertexCache, mooSortByMaterials, mooMergeObjects];

Description

Functions and Procedures

procedure BuildMeshCube(Mesh : TGLMeshObject; const Position, Scale : TAffineVector);

—————- Build Meshes ——————-

procedure BuildMeshCylinder(Mesh : TGLMeshObject; const Position, Scale : TAffineVector; Slices : Integer);

This item has no description.

procedure BuildMeshCylinderAdv(Mesh: TGLMeshObject; const Position, Scale: TAffineVector; TopRadius, BottomRadius, Height: single; Slices: Integer);

This item has no description.

procedure BuildMeshHemiSphere(Mesh: TGLMeshObject; const Position, Scale: TAffineVector);

Not implemented

procedure BuildMeshHemiCylinder(Mesh: TGLMeshObject; const Position, Scale: TAffineVector; Slices: Integer);

This item has no description.

procedure MakeMeshHexahedron(MeshObject: TGLMeshObject);

—————- Make Meshes ——————-

procedure MakeMeshTetrahedron(MeshObject: TGLMeshObject);

Not implemented

procedure MakeMeshSphere(MeshObject: TGLMeshObject);

This item has no description.

procedure OptimizeMesh(aList: TGLMeshObjectList; options: TGLMeshOptimizerOptions); overload;

Optimize Mesh (list, default options)

procedure OptimizeMesh(aList: TGLMeshObjectList); overload;

This item has no description.

procedure OptimizeMesh(aMeshObject: TGLMeshObject; options: TGLMeshOptimizerOptions); overload;

OptimizeMesh (object, with options)

procedure OptimizeMesh(aMeshObject: TGLMeshObject); overload;

OptimizeMesh (object, default options)

procedure FacesSmooth(aMeshObj: TGLMeshObject; aWeldDistance: Single = 0.0000001; aThreshold: Single = 35.0; InvertNormals: boolean = false);

This item has no description.

Types

TGLMeshOptimizerOption = (...);

This item has no description.

Values
  • mooStandardize
  • mooVertexCache
  • mooSortByMaterials
  • mooMergeObjects
TGLMeshOptimizerOptions = set of TGLMeshOptimizerOption;

This item has no description.

Constants

cMeshHexahedron: array [0 .. 5] of TGLHexahedronProperties = (( VertexCoords: ((X: - 1; Y: - 1; Z: 1), (X: 1; Y: - 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: - 1; Y: 1; Z: 1)); TextureCoords: ((X: 0; Y: 0), (X: 1; Y: 0), (X: 1; Y: 1), (X: 0; Y: 1)); PartIndices: (0, 1, 2, 2, 3, 0); Material: 'Front';), ( VertexCoords: ((X: - 1; Y: - 1; Z: - 1), (X: - 1; Y: 1; Z: - 1), (X: 1; Y: 1; Z: - 1), (X: 1; Y: - 1; Z: - 1)); TextureCoords: ((X: 1; Y: 0), (X: 1; Y: 1), (X: 0; Y: 1), (X: 0; Y: 0)); PartIndices: (4, 5, 6, 6, 7, 4); Material: 'Back';), ( VertexCoords: ((X: - 1; Y: 1; Z: - 1), (X: - 1; Y: 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: 1; Z: - 1)); TextureCoords: ((X: 0; Y: 1), (X: 0; Y: 0), (X: 1; Y: 0), (X: 1; Y: 1)); PartIndices: (8, 9, 10, 10, 11, 8); Material: 'Top';), ( VertexCoords: ((X: - 1; Y: - 1; Z: - 1), (X: 1; Y: - 1; Z: - 1), (X: 1; Y: - 1; Z: 1), (X: - 1; Y: - 1; Z: 1)); TextureCoords: ((X: 1; Y: 1), (X: 0; Y: 1), (X: 0; Y: 0), (X: 1; Y: 0)); PartIndices: (12, 13, 14, 14, 15, 12); Material: 'Bottom';), ( VertexCoords: ((X: 1; Y: - 1; Z: - 1), (X: 1; Y: 1; Z: - 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: - 1; Z: 1)); TextureCoords: ((X: 1; Y: 0), (X: 1; Y: 1), (X: 0; Y: 1), (X: 0; Y: 0)); PartIndices: (16, 17, 18, 18, 19, 16); Material: 'Right';), ( VertexCoords: ((X: - 1; Y: - 1; Z: - 1), (X: - 1; Y: - 1; Z: 1), (X: - 1; Y: 1; Z: 1), (X: - 1; Y: 1; Z: - 1)); TextureCoords: ((X: 0; Y: 0), (X: 1; Y: 0), (X: 1; Y: 1), (X: 0; Y: 1)); PartIndices: (20, 21, 22, 22, 23, 20); Material: 'Left';));

Hexahedron arrays for 6 parts

cMeshSphere: array [0 .. 1] of TGLSphereProperties = (( VertexCoords: ((X: - 1; Y: 1; Z: - 1), (X: - 1; Y: 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: 1; Z: - 1), (X: 0; Y: 1; Z: 0)); TextureCoords: ((X: 0; Y: 1), (X: 0; Y: 0), (X: 1; Y: 0), (X: 1; Y: 1), (X: 1; Y: 1)); PartIndices: (0, 1); Material: 'Top';), ( VertexCoords: ((X: - 1; Y: - 1; Z: - 1), (X: 1; Y: - 1; Z: - 1), (X: 1; Y: - 1; Z: 1), (X: - 1; Y: - 1; Z: 1), (X: - 1; Y: - 1; Z: 1)); TextureCoords: ((X: 1; Y: 1), (X: 0; Y: 1), (X: 0; Y: 0), (X: 1; Y: 0), (X: 0; Y: 0)); PartIndices: (1, 2); Material: 'Bottom';));

Front Quad Back Quad Top Quad Bottom Quad Right Quad Left Quad Sphere arrays for parts with 2 hemispheres

Variables

vDefaultMeshOptimizerOptions: TGLMeshOptimizerOptions = [mooStandardize, mooVertexCache, mooSortByMaterials, mooMergeObjects];


GLSysHelp v.2.5: GLS.MeshBuilder: Record TGLHexahedronProperties

Record TGLHexahedronProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshBuilder

Declaration

type TGLHexahedronProperties = record

Description

Properties of a hexahedron with 6 quad parts

Overview

Fields

Public | Normal3f: TVector3f;
Public | VertexCoords: array [0 .. 3] of TVector3f;
Public | TextureCoords: array [0 .. 3] of TVector2f;
Public | PartIndices: array [0 .. 5] of Integer;
Public | Material: string;

Description

Fields

Public Normal3f: TVector3f;

This item has no description.

Public VertexCoords: array [0 .. 3] of TVector3f;

This item has no description.

Public TextureCoords: array [0 .. 3] of TVector2f;

This item has no description.

Public PartIndices: array [0 .. 5] of Integer;

This item has no description.

Public Material: string;


GLSysHelp v.2.5: GLS.MeshBuilder: Record TGLSphereProperties

Record TGLSphereProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshBuilder

Declaration

type TGLSphereProperties = record

Description

Properties of a sphere with two hemispheres using 5 points to make each hemisphere part

Overview

Fields

Public | Normal3f: TVector3f;
Public | VertexCoords: array [0 .. 4] of TVector3f;
Public | TextureCoords: array [0 .. 4] of TVector2f;
Public | PartIndices: array [0 .. 1] of Integer;
Public | Material: string;

Description

Fields

Public Normal3f: TVector3f;

This item has no description.

Public VertexCoords: array [0 .. 4] of TVector3f;

This item has no description.

Public TextureCoords: array [0 .. 4] of TVector2f;

This item has no description.

Public PartIndices: array [0 .. 1] of Integer;

This item has no description.

Public Material: string;


GLSysHelp v.2.5: GLS.MeshBuilder: Record TGLCylinderProperties

Record TGLCylinderProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshBuilder

Declaration

type TGLCylinderProperties = record

Description

Properties of a cylinder with 8 parts for 2 hemicylinders using 6 points to make each part for hemidisk caps and side surfaces

Overview

Fields

Public | Normal3f: TVector3f;
Public | VertexCoords: array [0 .. 5] of TVector3f;
Public | TextureCoords: array [0 .. 5] of TVector2f;
Public | PartIndices: array [0 .. 7] of Integer;
Public | Material: string;

Description

Fields

Public Normal3f: TVector3f;

This item has no description.

Public VertexCoords: array [0 .. 5] of TVector3f;

This item has no description.

Public TextureCoords: array [0 .. 5] of TVector2f;

This item has no description.

Public PartIndices: array [0 .. 7] of Integer;

This item has no description.

Public Material: string;


GLSysHelp v.2.5: GLS.MeshCSG

Unit GLS.MeshCSG

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • GLS.Scene
  • GLScene.VectorTypes
  • GLS.VectorFileObjects
  • GLScene.VectorGeometry
  • GLS.MeshBSP
  • GLS.VectorLists

Overview

Functions and Procedures

procedure CSG_Operation(obj1, obj2: TGLMeshObject; Operation: TCSGOperation; Res: TGLMeshObject; const MaterialName1, MaterialName2: string);

Types

TCSGOperation = (...);

Description

Functions and Procedures

procedure CSG_Operation(obj1, obj2: TGLMeshObject; Operation: TCSGOperation; Res: TGLMeshObject; const MaterialName1, MaterialName2: string);

This item has no description.

Types

TCSGOperation = (...);

This item has no description.

Values
  • CSG_Union
  • CSG_Subtraction
  • CSG_Intersection


GLSysHelp v.2.5: GLS.MeshLines

Unit GLS.MeshLines

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Spline
  • GLS.VectorLists
  • GLS.Scene
  • GLS.Objects
  • GLS.Texture
  • GLS.Coordinates
  • GLS.Context
  • GLS.Material
  • GLS.Color
  • GLS.State
  • GLS.Nodes
  • GLS.VectorFileObjects
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLineNode |
Class TGLLineNodes |
Class TGLLineItem |
Class TGLLineCollection |
Class TGLLightmapBounds |
Class TGLMeshLines |

Types

TGLLineOperation = (...);

Description

Types

TGLLineOperation = (...);

This item has no description.

Values
  • loSelectLine
  • loNewLine
  • loInsertNode
  • loMoveNode


GLSysHelp v.2.5: GLS.MeshLines: Class TGLLineNode

Class TGLLineNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshLines

Declaration

type TGLLineNode = class(TGLNode)

Description

Specialized Node for use in a TGLLines objects. Adds a Width property

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLNode
  • TGLLineNode

Overview

Fields

Private FData: Pointer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public property Data: Pointer read FData write FData;

Description

Fields

Private FData: Pointer;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Public property Data: Pointer read FData write FData;


GLSysHelp v.2.5: GLS.MeshLines: Class TGLLineNodes

Class TGLLineNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshLines

Declaration

type TGLLineNodes = class(TGLNodes)

Description

Specialized collection for Nodes in TGLMeshLines objects. Stores TGLLineNode items.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLNodes
  • TGLLineNodes

Overview

Methods

Public | constructor Create(AOwner: TComponent); overload;
Public | destructor Destroy; override;
Public | function IndexOf(LineNode: TGLLineNode): Integer;
Public | procedure NotifyChange; override;

Description

Methods

Public constructor Create(AOwner: TComponent); overload;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IndexOf(LineNode: TGLLineNode): Integer;

This item has no description.

Public procedure NotifyChange; override;


GLSysHelp v.2.5: GLS.MeshLines: Class TGLLineItem

Class TGLLineItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshLines

Declaration

type TGLLineItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLLineItem

Overview

Fields

Private | FName: String;
Private | FBreakAngle: Single;
Private | FDivision: Integer;
Private | FNodes: TGLLineNodes;
Private | FSplineMode: TGLLineSplineMode;
Private | FTextureLength: Single;
Private | FWidth: Single;
Private | FTextureCorrection: Boolean;
Private | FHide: Boolean;
Private | FData: Pointer;

Methods

Published | constructor Create(Collection: TCollection); override;
Published | destructor Destroy; override;
Private | procedure SetBreakAngle(const Value: Single);
Private | procedure SetDivision(const Value: Integer);
Private | procedure SetHide(const Value: Boolean);
Private | procedure SetNodes(const Value: TGLLineNodes);
Private | procedure SetSplineMode(const Value: TGLLineSplineMode);
Private | procedure SetTextureCorrection(const Value: Boolean);
Private | procedure SetTextureLength(const Value: Single);
Private | procedure SetWidth(const Value: Single);

Properties

Published | property BreakAngle: Single read FBreakAngle write SetBreakAngle;
Public | property Data: Pointer read FData write FData;
Published | property Division: Integer read FDivision write SetDivision;
Published | property Hide: Boolean read FHide write SetHide;
Published | property Name: String read FName write FName;
Published | property Nodes: TGLLineNodes read FNodes write SetNodes;
Published | property SplineMode: TGLLineSplineMode read FSplineMode write SetSplineMode;
Published | property TextureCorrection: Boolean read FTextureCorrection write SetTextureCorrection;
Published | property TextureLength: Single read FTextureLength write SetTextureLength;
Published | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FName: String;

This item has no description.

Private FBreakAngle: Single;

This item has no description.

Private FDivision: Integer;

This item has no description.

Private FNodes: TGLLineNodes;

This item has no description.

Private FSplineMode: TGLLineSplineMode;

This item has no description.

Private FTextureLength: Single;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FTextureCorrection: Boolean;

This item has no description.

Private FHide: Boolean;

This item has no description.

Private FData: Pointer;

This item has no description.

Methods

Published constructor Create(Collection: TCollection); override;

This item has no description.

Published destructor Destroy; override;

This item has no description.

Private procedure SetBreakAngle(const Value: Single);

This item has no description.

Private procedure SetDivision(const Value: Integer);

This item has no description.

Private procedure SetHide(const Value: Boolean);

This item has no description.

Private procedure SetNodes(const Value: TGLLineNodes);

This item has no description.

Private procedure SetSplineMode(const Value: TGLLineSplineMode);

This item has no description.

Private procedure SetTextureCorrection(const Value: Boolean);

This item has no description.

Private procedure SetTextureLength(const Value: Single);

This item has no description.

Private procedure SetWidth(const Value: Single);

This item has no description.

Properties

Published property BreakAngle: Single read FBreakAngle write SetBreakAngle;

This item has no description.

Public property Data: Pointer read FData write FData;

This item has no description.

Published property Division: Integer read FDivision write SetDivision;

This item has no description.

Published property Hide: Boolean read FHide write SetHide;

This item has no description.

Published property Name: String read FName write FName;

This item has no description.

Published property Nodes: TGLLineNodes read FNodes write SetNodes;

This item has no description.

Published property SplineMode: TGLLineSplineMode read FSplineMode write SetSplineMode;

This item has no description.

Published property TextureCorrection: Boolean read FTextureCorrection write SetTextureCorrection;

This item has no description.

Published property TextureLength: Single read FTextureLength write SetTextureLength;

This item has no description.

Published property Width: Single read FWidth write SetWidth;


GLSysHelp v.2.5: GLS.MeshLines: Class TGLLineCollection

Class TGLLineCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshLines

Declaration

type TGLLineCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLLineCollection

Overview

Methods

Public | function Add: TGLLineItem; overload;
Public | function Add(Name: String): TGLLineItem; overload;
Private | function GetItems(Index: Integer): TGLLineItem;
Private | procedure SetItems(Index: Integer; const Val: TGLLineItem);

Properties

Public property Items[Index: Integer]: TGLLineItem read GetItems write SetItems;

Description

Methods

Public function Add: TGLLineItem; overload;

This item has no description.

Public function Add(Name: String): TGLLineItem; overload;

This item has no description.

Private function GetItems(Index: Integer): TGLLineItem;

This item has no description.

Private procedure SetItems(Index: Integer; const Val: TGLLineItem);

This item has no description.

Properties

Public property Items[Index: Integer]: TGLLineItem read GetItems write SetItems;


GLSysHelp v.2.5: GLS.MeshLines: Class TGLLightmapBounds

Class TGLLightmapBounds

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshLines

Declaration

type TGLLightmapBounds = class(TGLCustomCoordinates)

Description

This item has no description.

Hierarchy

  • TGLCustomCoordinates
  • TGLLightmapBounds

Overview

Methods

Private | function GetBottom: TGLFloat;
Private | function GetHeight: TGLFloat;
Private | function GetLeft: TGLFloat;
Private | function GetRight: TGLFloat;
Private | function GetTop: TGLFloat;
Private | function GetWidth: TGLFloat;
Private | procedure SetBottom(const Value: TGLFloat);
Private | procedure SetLeft(const Value: TGLFloat);
Private | procedure SetRight(const Value: TGLFloat);
Private | procedure SetTop(const Value: TGLFloat);

Properties

Published | property Bottom: TGLFloat read GetBottom write SetBottom stored False;
Published | property Height: TGLFloat read GetHeight;
Published | property Left: TGLFloat read GetLeft write SetLeft stored False;
Published | property Right: TGLFloat read GetRight write SetRight stored False;
Published | property Top: TGLFloat read GetTop write SetTop stored False;
Published | property Width: TGLFloat read GetWidth;

Description

Methods

Private function GetBottom: TGLFloat;

This item has no description.

Private function GetHeight: TGLFloat;

This item has no description.

Private function GetLeft: TGLFloat;

This item has no description.

Private function GetRight: TGLFloat;

This item has no description.

Private function GetTop: TGLFloat;

This item has no description.

Private function GetWidth: TGLFloat;

This item has no description.

Private procedure SetBottom(const Value: TGLFloat);

This item has no description.

Private procedure SetLeft(const Value: TGLFloat);

This item has no description.

Private procedure SetRight(const Value: TGLFloat);

This item has no description.

Private procedure SetTop(const Value: TGLFloat);

This item has no description.

Properties

Published property Bottom: TGLFloat read GetBottom write SetBottom stored False;

This item has no description.

Published property Height: TGLFloat read GetHeight;

This item has no description.

Published property Left: TGLFloat read GetLeft write SetLeft stored False;

This item has no description.

Published property Right: TGLFloat read GetRight write SetRight stored False;

This item has no description.

Published property Top: TGLFloat read GetTop write SetTop stored False;

This item has no description.

Published property Width: TGLFloat read GetWidth;


GLSysHelp v.2.5: GLS.MeshLines: Class TGLMeshLines

Class TGLMeshLines

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MeshLines

Declaration

type TGLMeshLines = class(TGLFreeForm)

Description

This item has no description. Showing description inherited from TGLFreeForm.

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLFreeForm
  • TGLMeshLines

Overview

Fields

Private | FLines: TGLLineCollection;
Private | FMesh: TGLMeshObject;
Private | FLightmapBounds: TGLLightmapBounds;
Private | FLightmapIndex: Integer;
Private | FLightmapMaterialName: String;
Private | FFaceGroup: TFGVertexIndexList;
Private | FIndex: Integer;
Private | FNoZWrite: Boolean;
Private | FShowNodes: Boolean;
Private | FUpdating: Integer;
Private | FSelectedLineItem: TGLLineItem;
Private | FSelectedNode: TGLLineNode;
Private | FNode1: TGLLineNode;
Private | FNode2: TGLLineNode;

Methods

Published | constructor Create(AOwner: TComponent); override;
Published | destructor Destroy; override;
Public | function SelectLineItem(LineItem: TGLLineItem): TGLLineItem; overload;
Public | function SelectLineItem(const X, Z: Single; Tolerance: Single = 1) : TGLLineItem; overload;
Public | function SelectLineItem(LineNode: TGLLineNode): TGLLineItem; overload;
Private | function GetUpdating: Boolean;
Private | function PointNearLine(const LineItem: TGLLineItem; const X, Z: Single; Tolerance: Single = 1): Boolean;
Private | function PointNearSegment(const StartNode, EndNode: TGLLineNode; const X, Z: Single; LineWidth: Single; Tolerance: Single = 1): Boolean;
Private | function SelectNode(LineItem: TGLLineItem; X, Z: Single): TGLLineNode;
Public | procedure BeginUpdate;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure Clear;
Public | procedure DeselectLineItem;
Public | procedure DeselectLineNode;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure EndUpdate;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure AddIndex;
Private | procedure AddStitchMarker(idx: TGLIntegerList);
Private | procedure AddVertices(const Up, Inner, Outer: TAffineVector; S: Single; Correction: Single; UseDegenerate: Boolean; LineItem: TGLLineItem);
Private | procedure BuildGeometry;
Private | procedure BuildLineItem(LineItem: TGLLineItem);
Private | procedure DoChanged;
Private | procedure DrawCircle(Radius: Single);
Private | procedure DrawNode(var rci: TGLRenderContextInfo; Node: TGLLineNode; LineWidth: Single);
Private | procedure SetLightmapBounds(const Value: TGLLightmapBounds);
Private | procedure SetLightmapIndex(const Value: Integer);
Private | procedure SetLightmapMaterialName(const Value: String);
Private | procedure SetNoZWrite(const Value: Boolean);
Private | procedure SetShowNodes(const Value: Boolean);
Private | procedure StitchStrips(idx: TGLIntegerList);

Properties

Published | property LightmapBounds: TGLLightmapBounds read FLightmapBounds write SetLightmapBounds;
Published | property LightmapIndex: Integer read FLightmapIndex write SetLightmapIndex;
Published | property LightmapMaterialName: String read FLightmapMaterialName write SetLightmapMaterialName;
Published | property Lines: TGLLineCollection read FLines;
Published | property Material;
Public | property Node1: TGLLineNode read FNode1;
Public | property Node2: TGLLineNode read FNode2;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Public | property SelectedLineItem: TGLLineItem read FSelectedLineItem;
Public | property SelectedNode: TGLLineNode read FSelectedNode;
Published | property ShowNodes: Boolean read FShowNodes write SetShowNodes;
Published | property Updating: Boolean Read GetUpdating;

Description

Fields

Private FLines: TGLLineCollection;

This item has no description.

Private FMesh: TGLMeshObject;

This item has no description.

Private FLightmapBounds: TGLLightmapBounds;

This item has no description.

Private FLightmapIndex: Integer;

This item has no description.

Private FLightmapMaterialName: String;

This item has no description.

Private FFaceGroup: TFGVertexIndexList;

This item has no description.

Private FIndex: Integer;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Private FShowNodes: Boolean;

This item has no description.

Private FUpdating: Integer;

This item has no description.

Private FSelectedLineItem: TGLLineItem;

This item has no description.

Private FSelectedNode: TGLLineNode;

This item has no description.

Private FNode1: TGLLineNode;

This item has no description.

Private FNode2: TGLLineNode;

This item has no description.

Methods

Published constructor Create(AOwner: TComponent); override;

This item has no description.

Published destructor Destroy; override;

This item has no description.

Public function SelectLineItem(LineItem: TGLLineItem): TGLLineItem; overload;

This item has no description.

Public function SelectLineItem(const X, Z: Single; Tolerance: Single = 1) : TGLLineItem; overload;

This item has no description.

Public function SelectLineItem(LineNode: TGLLineNode): TGLLineItem; overload;

This item has no description.

Private function GetUpdating: Boolean;

This item has no description.

Private function PointNearLine(const LineItem: TGLLineItem; const X, Z: Single; Tolerance: Single = 1): Boolean;

This item has no description.

Private function PointNearSegment(const StartNode, EndNode: TGLLineNode; const X, Z: Single; LineWidth: Single; Tolerance: Single = 1): Boolean;

This item has no description.

Private function SelectNode(LineItem: TGLLineItem; X, Z: Single): TGLLineNode;

This item has no description.

Public procedure BeginUpdate;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure Clear;

This item has no description.

Public procedure DeselectLineItem;

This item has no description.

Public procedure DeselectLineNode;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure EndUpdate;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure AddIndex;

This item has no description.

Private procedure AddStitchMarker(idx: TGLIntegerList);

This item has no description.

Private procedure AddVertices(const Up, Inner, Outer: TAffineVector; S: Single; Correction: Single; UseDegenerate: Boolean; LineItem: TGLLineItem);

This item has no description.

Private procedure BuildGeometry;

This item has no description.

Private procedure BuildLineItem(LineItem: TGLLineItem);

This item has no description.

Private procedure DoChanged;

This item has no description.

Private procedure DrawCircle(Radius: Single);

This item has no description.

Private procedure DrawNode(var rci: TGLRenderContextInfo; Node: TGLLineNode; LineWidth: Single);

This item has no description.

Private procedure SetLightmapBounds(const Value: TGLLightmapBounds);

This item has no description.

Private procedure SetLightmapIndex(const Value: Integer);

This item has no description.

Private procedure SetLightmapMaterialName(const Value: String);

This item has no description.

Private procedure SetNoZWrite(const Value: Boolean);

This item has no description.

Private procedure SetShowNodes(const Value: Boolean);

This item has no description.

Private procedure StitchStrips(idx: TGLIntegerList);

This item has no description.

Properties

Published property LightmapBounds: TGLLightmapBounds read FLightmapBounds write SetLightmapBounds;

This item has no description.

Published property LightmapIndex: Integer read FLightmapIndex write SetLightmapIndex;

This item has no description.

Published property LightmapMaterialName: String read FLightmapMaterialName write SetLightmapMaterialName;

This item has no description.

Published property Lines: TGLLineCollection read FLines;

This item has no description.

Published property Material;

This item has no description.

Public property Node1: TGLLineNode read FNode1;

This item has no description.

Public property Node2: TGLLineNode read FNode2;

This item has no description.

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;

This item has no description.

Public property SelectedLineItem: TGLLineItem read FSelectedLineItem;

This item has no description.

Public property SelectedNode: TGLLineNode read FSelectedNode;

This item has no description.

Published property ShowNodes: Boolean read FShowNodes write SetShowNodes;

This item has no description.

Published property Updating: Boolean Read GetUpdating;


GLSysHelp v.2.5: GLS.MeshUtils

Unit GLS.MeshUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLS.PersistentClasses
  • GLS.VectorLists
  • GLScene.VectorGeometry
  • GLScene.VectorTypes

Overview

Functions and Procedures

procedure ConvertStripToList(const strip: TGLAffineVectorList; list: TGLAffineVectorList); overload;
procedure ConvertStripToList(const strip: TGLIntegerList; list: TGLIntegerList); overload;
procedure ConvertStripToList(const strip: TGLAffineVectorList; const indices: TGLIntegerList; list: TGLAffineVectorList); overload;
function ConvertStripToList(const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TGLLongWordList; overload;
function ConvertFansToList(const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TGLLongWordList;
procedure ConvertIndexedListToList(const data: TGLAffineVectorList; const indices: TGLIntegerList; list: TGLAffineVectorList);
function BuildVectorCountOptimizedIndices(const vertices: TGLAffineVectorList; const normals: TGLAffineVectorList = nil; const texCoords: TGLAffineVectorList = nil): TGLIntegerList;
procedure RemapReferences(reference: TGLAffineVectorList; const indices: TGLIntegerList); overload;
procedure RemapReferences(reference: TGLIntegerList; const indices: TGLIntegerList); overload;
procedure RemapAndCleanupReferences(reference: TGLAffineVectorList; indices: TGLIntegerList);
function RemapIndicesToIndicesMap(remapIndices: TGLIntegerList): TGLIntegerList;
procedure RemapTrianglesIndices(indices, indicesMap: TGLIntegerList);
procedure remapIndices(indices, indicesMap: TGLIntegerList);
procedure UnifyTrianglesWinding(indices: TGLIntegerList);
procedure InvertTrianglesWinding(indices: TGLIntegerList);
function BuildNormals(reference: TGLAffineVectorList; indices: TGLIntegerList) : TGLAffineVectorList;
function BuildNonOrientedEdgesList(triangleIndices: TGLIntegerList; triangleEdges: TGLIntegerList = nil; edgesTriangles: TGLIntegerList = nil) : TGLIntegerList;
procedure WeldVertices(vertices: TGLAffineVectorList; indicesMap: TGLIntegerList; weldRadius: Single);
function StripifyMesh(indices: TGLIntegerList; maxVertexIndex: Integer; agglomerateLoneTriangles: Boolean = False): TGLPersistentObjectList;
procedure IncreaseCoherency(indices: TGLIntegerList; cacheSize: Integer);
procedure SubdivideTriangles(smoothFactor: Single; vertices: TGLAffineVectorList; triangleIndices: TGLIntegerList; normals: TGLAffineVectorList = nil; onSubdivideEdge: TSubdivideEdgeEvent = nil);
function MakeTriangleAdjacencyList(const AindicesList: PLongWordArray; Count: LongWord; const AVerticesList: PAffineVectorArray): TGLLongWordList;

Types

TSubdivideEdgeEvent = procedure(const idxA, idxB, newIdx: Integer); register;

Variables

vImprovedFixingOpenTriangleEdge: Boolean = False;
vEdgeInfoReserveSize: LongWord = 64;

Description

Functions and Procedures

procedure ConvertStripToList(const strip: TGLAffineVectorList; list: TGLAffineVectorList); overload;

Converts a triangle strips into a triangle list. Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.

procedure ConvertStripToList(const strip: TGLIntegerList; list: TGLIntegerList); overload;

This item has no description.

procedure ConvertStripToList(const strip: TGLAffineVectorList; const indices: TGLIntegerList; list: TGLAffineVectorList); overload;

This item has no description.

function ConvertStripToList(const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TGLLongWordList; overload;

This item has no description.

function ConvertFansToList(const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TGLLongWordList;

This item has no description.

procedure ConvertIndexedListToList(const data: TGLAffineVectorList; const indices: TGLIntegerList; list: TGLAffineVectorList);

Expands an indexed structure into a non-indexed structure.

function BuildVectorCountOptimizedIndices(const vertices: TGLAffineVectorList; const normals: TGLAffineVectorList = nil; const texCoords: TGLAffineVectorList = nil): TGLIntegerList;

Builds a vector-count optimized indices list. The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used). The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.

procedure RemapReferences(reference: TGLAffineVectorList; const indices: TGLIntegerList); overload;

Alters a reference array and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.

procedure RemapReferences(reference: TGLIntegerList; const indices: TGLIntegerList); overload;

This item has no description.

procedure RemapAndCleanupReferences(reference: TGLAffineVectorList; indices: TGLIntegerList);

Alters a reference/indice pair and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.

function RemapIndicesToIndicesMap(remapIndices: TGLIntegerList): TGLIntegerList;

Creates an indices map from a remap list. The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear? In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices. Any simpler documentation of this function welcome ;)

procedure RemapTrianglesIndices(indices, indicesMap: TGLIntegerList);

Remaps a list of triangles vertex indices and remove degenerate triangles. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

procedure remapIndices(indices, indicesMap: TGLIntegerList);

Remaps a list of indices. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

procedure UnifyTrianglesWinding(indices: TGLIntegerList);

Attempts to unify triangle winding. Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)

procedure InvertTrianglesWinding(indices: TGLIntegerList);

Inverts the triangles winding (vertex order).

function BuildNormals(reference: TGLAffineVectorList; indices: TGLIntegerList) : TGLAffineVectorList;

Builds normals for a triangles list. Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles. Returned list must be freed by caller.

function BuildNonOrientedEdgesList(triangleIndices: TGLIntegerList; triangleEdges: TGLIntegerList = nil; edgesTriangles: TGLIntegerList = nil) : TGLIntegerList;

Builds a list of non-oriented (non duplicated) edges list. Each edge is represented by the two integers of its vertices, sorted in ascending order. If not nil then - triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation; - edgesTriangles is filled with the indices of the first index of the triangle in triangleIndices that have this edge. A maximum of two triangles can be referred by this list, and its final size will be that of the Result (ie. non oriented edges list)

procedure WeldVertices(vertices: TGLAffineVectorList; indicesMap: TGLIntegerList; weldRadius: Single);

Welds all vertices separated by a distance inferior to weldRadius. Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter). The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex]. The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex. This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)

function StripifyMesh(indices: TGLIntegerList; maxVertexIndex: Integer; agglomerateLoneTriangles: Boolean = False): TGLPersistentObjectList;

Attempts to create as few as possible triangle strips to cover the mesh. The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality). The function returns a list of TGLIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller. If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.

procedure IncreaseCoherency(indices: TGLIntegerList; cacheSize: Integer);

Increases indices coherency wrt vertex caches. The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips). This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).

procedure SubdivideTriangles(smoothFactor: Single; vertices: TGLAffineVectorList; triangleIndices: TGLIntegerList; normals: TGLAffineVectorList = nil; onSubdivideEdge: TSubdivideEdgeEvent = nil);

Subdivides mesh triangles. Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes. The procedure is not intended for real-time use.

function MakeTriangleAdjacencyList(const AindicesList: PLongWordArray; Count: LongWord; const AVerticesList: PAffineVectorArray): TGLLongWordList;

Create list of indices of triangles with adjacency from triangle list

Types

TSubdivideEdgeEvent = procedure(const idxA, idxB, newIdx: Integer); register;

This item has no description.

Variables

vImprovedFixingOpenTriangleEdge: Boolean = False;

This item has no description.

vEdgeInfoReserveSize: LongWord = 64;


GLSysHelp v.2.5: GLS.Mirror

Unit GLS.Mirror

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GLScene.OpenGLTokens
  • GLS.OpenGLAdapter
  • GLS.Scene
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.Material
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.State
  • GLScene.VectorTypes
  • GLS.PersistentClasses
  • GLScene.PipelineTransform
  • GLScene.XCollection
  • GLS.Texture

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMirror |

Types

TGLMirrorOption = (...);
TGLMirrorOptions = set of TGLMirrorOption;
TMirrorShapes = (...);

Constants

cDefaultMirrorOptions = [moUseStencil];

Description

Types

TGLMirrorOption = (...);

This item has no description.

Values
  • moUseStencil
  • moOpaque
  • moMirrorPlaneClip
  • moClearZBuffer
TGLMirrorOptions = set of TGLMirrorOption;

This item has no description.

TMirrorShapes = (...);

This item has no description.

Values
  • msRect
  • msDisk

Constants

cDefaultMirrorOptions = [moUseStencil];


GLSysHelp v.2.5: GLS.Mirror: Class TGLMirror

Class TGLMirror

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Mirror

Declaration

type TGLMirror = class(TGLSceneObject)

Description

A simple plane mirror. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered). It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMirror

Overview

Fields

Private | FRendering: Boolean;
Private | FMirrorObject: TGLBaseSceneObject;
Private | FWidth: Single;
Private | FHeight: Single;
Private | FMirrorOptions: TGLMirrorOptions;
Private | FOnBeginRenderingMirrors: TNotifyEvent;
Private | FOnEndRenderingMirrors: TNotifyEvent;
Private | FShape: TMirrorShapes;
Private | FRadius: Single;
Private | FSlices: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var ARci: TGLRenderContextInfo); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Height: Single read FHeight write SetHeight;
Published | property MirrorObject: TGLBaseSceneObject read FMirrorObject write SetMirrorObject;
Published | property MirrorOptions: TGLMirrorOptions read FMirrorOptions write SetMirrorOptions default cDefaultMirrorOptions;
Published | property OnBeginRenderingMirrors: TNotifyEvent read FOnBeginRenderingMirrors write FOnBeginRenderingMirrors;
Published | property OnEndRenderingMirrors: TNotifyEvent read FOnEndRenderingMirrors write FOnEndRenderingMirrors;
Published | property Radius: Single read FRadius write SetRadius;
Published | property Shape: TMirrorShapes read FShape write SetShape default msRect;
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FRendering: Boolean;

This item has no description.

Private FMirrorObject: TGLBaseSceneObject;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FMirrorOptions: TGLMirrorOptions;

This item has no description.

Private FOnBeginRenderingMirrors: TNotifyEvent;

This item has no description.

Private FOnEndRenderingMirrors: TNotifyEvent;

This item has no description.

Private FShape: TMirrorShapes;

This item has no description.

Private FRadius: Single;

ORL

Private FSlices: Integer;

ORL

Methods

Public constructor Create(AOwner: TComponent); override;

ORL

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var ARci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Height: Single read FHeight write SetHeight;

This item has no description.

Published property MirrorObject: TGLBaseSceneObject read FMirrorObject write SetMirrorObject;

Selects the object to mirror. If nil, the whole scene is mirrored

Published property MirrorOptions: TGLMirrorOptions read FMirrorOptions write SetMirrorOptions default cDefaultMirrorOptions;

Controls rendering options. moUseStencil: mirror area is stenciled, prevents reflected objects to be visible on the sides of the mirror (stencil buffer must be active in the viewer) moOpaque: mirror is opaque (ie. painted with background color) moMirrorPlaneClip: a ClipPlane is defined to prevent reflections from popping out of the mirror (for objects behind or halfway through) moClearZBuffer: mirror area's ZBuffer is cleared so that background objects don't interfere with reflected objects (reflected objects must be rendered AFTER the mirror in the hierarchy). Works only along with stenciling.

Published property OnBeginRenderingMirrors: TNotifyEvent read FOnBeginRenderingMirrors write FOnBeginRenderingMirrors;

Fired before the object's mirror images are rendered.

Published property OnEndRenderingMirrors: TNotifyEvent read FOnEndRenderingMirrors write FOnEndRenderingMirrors;

Fired after the object's mirror images are rendered.

Published property Radius: Single read FRadius write SetRadius;

This item has no description.

Published property Shape: TMirrorShapes read FShape write SetShape default msRect;

ORL

Published property Slices: Integer read FSlices write SetSlices default 16;

ORL

Published property Width: Single read FWidth write SetWidth;


GLSysHelp v.2.5: GLS.Movement

Unit GLS.Movement

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.OpenGLTokens
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.XCollection
  • GLScene.Spline
  • GLS.BaseClasses
  • GLS.Scene
  • GLS.Objects
  • GLScene.Strings
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPathNode |
Class TGLPathNodes |
Class TGLMovementPath |
Class TGLMovementPaths |
Class TGLMovement |

Functions and Procedures

function GetMovement(const behaviours: TGLBehaviours): TGLMovement; overload;
function GetMovement(const obj: TGLBaseSceneObject): TGLMovement; overload;
function GetOrCreateMovement(const behaviours: TGLBehaviours): TGLMovement; overload;
function GetOrCreateMovement(const obj: TGLBaseSceneObject): TGLMovement; overload;
procedure StartAllMovements(const Scene: TGLScene; const StartCamerasMove, StartObjectsMove: Boolean);
procedure StopAllMovements(const Scene: TGLScene; const StopCamerasMove, StopObjectsMove: Boolean);

Types

TGLMovementRotationMode = (...);
TPathTravelStartEvent = procedure (Sender: TObject; Path: TGLMovementPath) of object;
TPathTravelStopEvent = procedure (Sender: TObject; Path: TGLMovementPath; var Looped: boolean) of object;

Description

Functions and Procedures

function GetMovement(const behaviours: TGLBehaviours): TGLMovement; overload;

This item has no description.

function GetMovement(const obj: TGLBaseSceneObject): TGLMovement; overload;

This item has no description.

function GetOrCreateMovement(const behaviours: TGLBehaviours): TGLMovement; overload;

This item has no description.

function GetOrCreateMovement(const obj: TGLBaseSceneObject): TGLMovement; overload;

This item has no description.

procedure StartAllMovements(const Scene: TGLScene; const StartCamerasMove, StartObjectsMove: Boolean);

This item has no description.

procedure StopAllMovements(const Scene: TGLScene; const StopCamerasMove, StopObjectsMove: Boolean);

This item has no description.

Types

TGLMovementRotationMode = (...);

This item has no description.

Values
  • rmTurnPitchRoll
  • rmUpDirection
TPathTravelStartEvent = procedure (Sender: TObject; Path: TGLMovementPath) of object;

Event for path related event

TPathTravelStopEvent = procedure (Sender: TObject; Path: TGLMovementPath; var Looped: boolean) of object;


GLSysHelp v.2.5: GLS.Movement: Class TGLPathNode

Class TGLPathNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Movement

Declaration

type TGLPathNode = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLPathNode

Overview

Fields

Private | FPosition: TGLVector;
Private | FScale: TGLVector;
Private | FRotation: TGLVector;
Private | FDirection: TGLVector;
Private | FUp: TGLVector;
Private | FSpeed: single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function EqualNode(const aNode: TGLPathNode): boolean;
Public | function PositionAsAddress: PGLFloat;
Public | function RotationAsAddress: PGLFloat;
Public | function ScaleAsAddress: PGLFloat;
Private | function GetDirectionCoordinate(const Index: Integer): TGLFloat; inline;
Private | function GetPositionCoordinate(const Index: Integer): TGLFloat;
Private | function GetRotationCoordinate(const Index: Integer): TGLFloat; inline;
Private | function GetScaleCoordinate(const Index: Integer): TGLFloat; inline;
Private | function GetUpCoordinate(const Index: Integer): TGLFloat; inline;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure InitializeByObject(const Obj: TGLBaseSceneObject);
Private | procedure SetDirectionCoordinate(const Index: integer; const AValue: TGLFloat);
Private | procedure SetPositionAsVector(const Value: TGLVector);
Private | procedure SetPositionCoordinate(const Index: integer; const AValue: TGLFloat);
Private | procedure SetRotationAsVector(const Value: TGLVector);
Private | procedure SetRotationCoordinate(const Index: integer; const AValue: TGLFloat);
Private | procedure SetScaleAsVector(const Value: TGLVector);
Private | procedure SetScaleCoordinate(const Index: integer; const AValue: TGLFloat);
Private | procedure SetSpeed(const Value: single);
Private | procedure SetUpCoordinate(const Index: integer; const AValue: TGLFloat);

Properties

Public | property DirectionAsVector: TGLVector read FDirection write FDirection;
Published | property DirectionX: TGLFloat index 0 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property DirectionY: TGLFloat index 1 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property DirectionZ: TGLFloat index 2 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property PitchAngle: TGLFloat index 0 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property PositionAsVector: TGLVector Read FPosition Write SetPositionAsVector;
Published | property RollAngle: TGLFloat index 2 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property RotationAsVector: TGLVector Read FRotation Write SetRotationAsVector;
Public | property ScaleAsVector: TGLVector Read FScale Write SetScaleAsVector;
Published | property ScaleX: TGLFloat index 0 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property ScaleY: TGLFloat index 1 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property ScaleZ: TGLFloat index 2 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property Speed: single Read FSpeed Write SetSpeed;
Published | property TurnAngle: TGLFloat index 1 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property UpAsVector: TGLVector read FUp write FUp;
Published | property UpX: TGLFloat index 0 Read GetUpCoordinate Write SetUpCoordinate;
Published | property UpY: TGLFloat index 1 Read GetUpCoordinate Write SetUpCoordinate;
Published | property UpZ: TGLFloat index 2 Read GetUpCoordinate Write SetUpCoordinate;
Published | property X: TGLFloat index 0 Read GetPositionCoordinate Write SetPositionCoordinate;
Published | property Y: TGLFloat index 1 Read GetPositionCoordinate Write SetPositionCoordinate;
Published | property Z: TGLFloat index 2 Read GetPositionCoordinate Write SetPositionCoordinate;

Description

Fields

Private FPosition: TGLVector;

This item has no description.

Private FScale: TGLVector;

This item has no description.

Private FRotation: TGLVector;

This item has no description.

Private FDirection: TGLVector;

This item has no description.

Private FUp: TGLVector;

This item has no description.

Private FSpeed: single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function EqualNode(const aNode: TGLPathNode): boolean;

Warning: does not take speed into account.

Public function PositionAsAddress: PGLFloat;

This item has no description.

Public function RotationAsAddress: PGLFloat;

This item has no description.

Public function ScaleAsAddress: PGLFloat;

This item has no description.

Private function GetDirectionCoordinate(const Index: Integer): TGLFloat; inline;

This item has no description.

Private function GetPositionCoordinate(const Index: Integer): TGLFloat;

This item has no description.

Private function GetRotationCoordinate(const Index: Integer): TGLFloat; inline;

This item has no description.

Private function GetScaleCoordinate(const Index: Integer): TGLFloat; inline;

This item has no description.

Private function GetUpCoordinate(const Index: Integer): TGLFloat; inline;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure InitializeByObject(const Obj: TGLBaseSceneObject);

This item has no description.

Private procedure SetDirectionCoordinate(const Index: integer; const AValue: TGLFloat);

This item has no description.

Private procedure SetPositionAsVector(const Value: TGLVector);

This item has no description.

Private procedure SetPositionCoordinate(const Index: integer; const AValue: TGLFloat);

This item has no description.

Private procedure SetRotationAsVector(const Value: TGLVector);

This item has no description.

Private procedure SetRotationCoordinate(const Index: integer; const AValue: TGLFloat);

This item has no description.

Private procedure SetScaleAsVector(const Value: TGLVector);

This item has no description.

Private procedure SetScaleCoordinate(const Index: integer; const AValue: TGLFloat);

This item has no description.

Private procedure SetSpeed(const Value: single);

This item has no description.

Private procedure SetUpCoordinate(const Index: integer; const AValue: TGLFloat);

This item has no description.

Properties

Public property DirectionAsVector: TGLVector read FDirection write FDirection;

This item has no description.

Published property DirectionX: TGLFloat index 0 Read GetDirectionCoordinate Write SetDirectionCoordinate;

This item has no description.

Published property DirectionY: TGLFloat index 1 Read GetDirectionCoordinate Write SetDirectionCoordinate;

This item has no description.

Published property DirectionZ: TGLFloat index 2 Read GetDirectionCoordinate Write SetDirectionCoordinate;

This item has no description.

Published property PitchAngle: TGLFloat index 0 Read GetRotationCoordinate Write SetRotationCoordinate;

Rotation.X means PitchAngle; Rotation.Y means TurnAngle; Rotation.Z means RollAngle;

Public property PositionAsVector: TGLVector Read FPosition Write SetPositionAsVector;

This item has no description.

Published property RollAngle: TGLFloat index 2 Read GetRotationCoordinate Write SetRotationCoordinate;

This item has no description.

Public property RotationAsVector: TGLVector Read FRotation Write SetRotationAsVector;

Rotation.X means PitchAngle, Rotation.Y means TurnAngle, Rotation.Z means RollAngle.

Public property ScaleAsVector: TGLVector Read FScale Write SetScaleAsVector;

This item has no description.

Published property ScaleX: TGLFloat index 0 Read GetScaleCoordinate Write SetScaleCoordinate;

This item has no description.

Published property ScaleY: TGLFloat index 1 Read GetScaleCoordinate Write SetScaleCoordinate;

This item has no description.

Published property ScaleZ: TGLFloat index 2 Read GetScaleCoordinate Write SetScaleCoordinate;

This item has no description.

Published property Speed: single Read FSpeed Write SetSpeed;

This item has no description.

Published property TurnAngle: TGLFloat index 1 Read GetRotationCoordinate Write SetRotationCoordinate;

This item has no description.

Public property UpAsVector: TGLVector read FUp write FUp;

This item has no description.

Published property UpX: TGLFloat index 0 Read GetUpCoordinate Write SetUpCoordinate;

This item has no description.

Published property UpY: TGLFloat index 1 Read GetUpCoordinate Write SetUpCoordinate;

This item has no description.

Published property UpZ: TGLFloat index 2 Read GetUpCoordinate Write SetUpCoordinate;

This item has no description.

Published property X: TGLFloat index 0 Read GetPositionCoordinate Write SetPositionCoordinate;

This item has no description.

Published property Y: TGLFloat index 1 Read GetPositionCoordinate Write SetPositionCoordinate;

This item has no description.

Published property Z: TGLFloat index 2 Read GetPositionCoordinate Write SetPositionCoordinate;


GLSysHelp v.2.5: GLS.Movement: Class TGLPathNodes

Class TGLPathNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Movement

Declaration

type TGLPathNodes = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLPathNodes

Overview

Methods

Public | constructor Create(aOwner: TGLMovementPath);
Public | function Add: TGLPathNode;
Public | function FindItemID(const ID: integer): TGLPathNode;
Public | function GetOwnerMovementPath: TGLMovementPath;
Public | procedure NotifyChange; virtual;

Properties

Public property Items[const index: integer]: TGLPathNode Read GetItems Write SetItems;

Description

Methods

Public constructor Create(aOwner: TGLMovementPath);

This item has no description.

Public function Add: TGLPathNode;

This item has no description.

Public function FindItemID(const ID: integer): TGLPathNode;

This item has no description.

Public function GetOwnerMovementPath: TGLMovementPath;

This item has no description.

Public procedure NotifyChange; virtual;

This item has no description.

Properties

Public property Items[const index: integer]: TGLPathNode Read GetItems Write SetItems;


GLSysHelp v.2.5: GLS.Movement: Class TGLMovementPath

Class TGLMovementPath

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Movement

Declaration

type TGLMovementPath = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLMovementPath

Overview

Fields

Private | FPathLine: TGLLines;
Private | FShowPath: Boolean;
Private | FPathSplineMode: TGLLineSplineMode;
Private | FNodes: TGLPathNodes;
Private | FStartTimeApplied: Boolean;
Private | FStartTime: double;
Private | FInitialTime: Double;
Private | FEstimateTime: double;
Private | FCurrentNode: TGLPathNode;
Private | FInTravel: boolean;
Private | FLooped: boolean;
Private | FName: string;
Private | FRotationMode: TGLMovementRotationMode;
Private | MotionSplineControl: TCubicSpline;
Private | RotationSplineControl: TCubicSpline;
Private | ScaleSplineControl: TCubicSpline;
Private | DirectionSplineControl: TCubicSpline;
Private | UpSplineControl: TCubicSpline;
Private | FOnTravelStart: TNotifyEvent;
Private | FOnTravelStop: TNotifyEvent;
Private | FCurrentNodeIndex: integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function AddNode: TGLPathNode; overload;
Public | function AddNode(const Node: TGLPathNode): TGLPathNode; overload;
Public | function AddNodeFromObject(const Obj: TGLBaseSceneObject): TGLPathNode;
Public | function DeleteNode(const Node: TGLPathNode): TGLPathNode; overload;
Public | function DeleteNode(const Index: integer): TGLPathNode; overload;
Public | function GetMovement: TGLMovement;
Public | function InsertNode(const Index: integer): TGLPathNode; overload;
Public | function InsertNode(const Node: TGLPathNode; const Index: integer): TGLPathNode; overload;
Public | function InsertNodeFromObject(const Obj: TGLBaseSceneObject; const Index: integer): TGLPathNode;
Public | function NextNode: integer;
Public | function NodeDistance(const Node1, Node2: TGLPathNode): double;
Public | function PrevNode: integer;
Private | function GetNodeCount: integer;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalculateState(const CurrentTime: double);
Public | procedure ClearNodes;
Public | procedure TravelPath(const Start: boolean); overload;
Public | procedure TravelPath(const Start: boolean; const aStartTime: double); overload;
Public | procedure UpdatePathLine;
Private | procedure SetCurrentNodeIndex(const Value: integer);
Private | procedure SetPathSplineMode(const Value: TGLLineSplineMode);
Private | procedure SetShowPath(const Value: Boolean);
Private | procedure SetStartTime(const Value: double);

Properties

Public | property CurrentNode: TGLPathNode Read FCurrentNode;
Public | property CurrentNodeIndex: integer Read FCurrentNodeIndex Write SetCurrentNodeIndex;
Published | property EstimateTime: double Read FEstimateTime;
Public | property InTravel: boolean Read FInTravel;
Published | property Looped: boolean Read FLooped Write FLooped;
Published | property Name: string Read FName Write FName;
Public | property NodeCount: integer Read GetNodeCount;
Published | property Nodes: TGLPathNodes Read FNodes;
Public | property OnTravelStart: TNotifyEvent Read FOnTravelStart Write FOnTravelStart;
Public | property OnTravelStop: TNotifyEvent Read FOnTravelStop Write FOnTravelStop;
Published | property PathSplineMode: TGLLineSplineMode read FPathSplineMode write SetPathSplineMode default lsmLines;
Published | property RotationMode: TGLMovementRotationMode read FRotationMode write FRotationMode default rmTurnPitchRoll;
Published | property ShowPath: Boolean read FShowPath write SetShowPath;
Published | property StartTime: double Read FStartTime Write SetStartTime;

Description

Fields

Private FPathLine: TGLLines;

This item has no description.

Private FShowPath: Boolean;

This item has no description.

Private FPathSplineMode: TGLLineSplineMode;

This item has no description.

Private FNodes: TGLPathNodes;

This item has no description.

Private FStartTimeApplied: Boolean;

All the time saved in ms

Private FStartTime: double;

This item has no description.

Private FInitialTime: Double;

This item has no description.

Private FEstimateTime: double;

This item has no description.

Private FCurrentNode: TGLPathNode;

This item has no description.

Private FInTravel: boolean;

This item has no description.

Private FLooped: boolean;

This item has no description.

Private FName: string;

This item has no description.

Private FRotationMode: TGLMovementRotationMode;

This item has no description.

Private MotionSplineControl: TCubicSpline;

This item has no description.

Private RotationSplineControl: TCubicSpline;

This item has no description.

Private ScaleSplineControl: TCubicSpline;

This item has no description.

Private DirectionSplineControl: TCubicSpline;

This item has no description.

Private UpSplineControl: TCubicSpline;

This item has no description.

Private FOnTravelStart: TNotifyEvent;

This item has no description.

Private FOnTravelStop: TNotifyEvent;

This item has no description.

Private FCurrentNodeIndex: integer;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddNode: TGLPathNode; overload;

This item has no description.

Public function AddNode(const Node: TGLPathNode): TGLPathNode; overload;

This item has no description.

Public function AddNodeFromObject(const Obj: TGLBaseSceneObject): TGLPathNode;

This item has no description.

Public function DeleteNode(const Node: TGLPathNode): TGLPathNode; overload;

This item has no description.

Public function DeleteNode(const Index: integer): TGLPathNode; overload;

This item has no description.

Public function GetMovement: TGLMovement;

This item has no description.

Public function InsertNode(const Index: integer): TGLPathNode; overload;

This item has no description.

Public function InsertNode(const Node: TGLPathNode; const Index: integer): TGLPathNode; overload;

This item has no description.

Public function InsertNodeFromObject(const Obj: TGLBaseSceneObject; const Index: integer): TGLPathNode;

This item has no description.

Public function NextNode: integer;

This item has no description.

Public function NodeDistance(const Node1, Node2: TGLPathNode): double;

This item has no description.

Public function PrevNode: integer;

This item has no description.

Private function GetNodeCount: integer;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure CalculateState(const CurrentTime: double);

This item has no description.

Public procedure ClearNodes;

This item has no description.

Public procedure TravelPath(const Start: boolean); overload;

This item has no description.

Public procedure TravelPath(const Start: boolean; const aStartTime: double); overload;

This item has no description.

Public procedure UpdatePathLine;

This item has no description.

Private procedure SetCurrentNodeIndex(const Value: integer);

This item has no description.

Private procedure SetPathSplineMode(const Value: TGLLineSplineMode);

This item has no description.

Private procedure SetShowPath(const Value: Boolean);

This item has no description.

Private procedure SetStartTime(const Value: double);

This item has no description.

Properties

Public property CurrentNode: TGLPathNode Read FCurrentNode;

This item has no description.

Public property CurrentNodeIndex: integer Read FCurrentNodeIndex Write SetCurrentNodeIndex;

This item has no description.

Published property EstimateTime: double Read FEstimateTime;

This item has no description.

Public property InTravel: boolean Read FInTravel;

This item has no description.

Published property Looped: boolean Read FLooped Write FLooped;

This item has no description.

Published property Name: string Read FName Write FName;

This item has no description.

Public property NodeCount: integer Read GetNodeCount;

This item has no description.

Published property Nodes: TGLPathNodes Read FNodes;

This item has no description.

Public property OnTravelStart: TNotifyEvent Read FOnTravelStart Write FOnTravelStart;

This item has no description.

Public property OnTravelStop: TNotifyEvent Read FOnTravelStop Write FOnTravelStop;

This item has no description.

Published property PathSplineMode: TGLLineSplineMode read FPathSplineMode write SetPathSplineMode default lsmLines;

This property is currently ignored.

Published property RotationMode: TGLMovementRotationMode read FRotationMode write FRotationMode default rmTurnPitchRoll;

This item has no description.

Published property ShowPath: Boolean read FShowPath write SetShowPath;

This item has no description.

Published property StartTime: double Read FStartTime Write SetStartTime;


GLSysHelp v.2.5: GLS.Movement: Class TGLMovementPaths

Class TGLMovementPaths

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Movement

Declaration

type TGLMovementPaths = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLMovementPaths

Overview

Methods

Public | constructor Create(aOwner: TGLMovement);
Public | function Add: TGLMovementPath;
Public | function FindItemID(const ID: integer): TGLMovementPath;
Public | procedure NotifyChange; virtual;

Properties

Public property Items[const index: integer]: TGLMovementPath Read GetItems Write SetItems;

Description

Methods

Public constructor Create(aOwner: TGLMovement);

This item has no description.

Public function Add: TGLMovementPath;

This item has no description.

Public function FindItemID(const ID: integer): TGLMovementPath;

This item has no description.

Public procedure NotifyChange; virtual;

This item has no description.

Properties

Public property Items[const index: integer]: TGLMovementPath Read GetItems Write SetItems;


GLSysHelp v.2.5: GLS.Movement: Class TGLMovement

Class TGLMovement

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Movement

Declaration

type TGLMovement = class(TGLBehaviour)

Description

This item has no description. Showing description inherited from TGLBehaviour.

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLMovement

Overview

Fields

Private | FPaths: TGLMovementPaths;
Private | FAutoStartNextPath: boolean;
Private | FActivePathIndex: integer;
Private | FOnAllPathTravelledOver: TNotifyEvent;
Private | FOnPathTravelStart: TPathTravelStartEvent;
Private | FOnPathTravelStop: TPathTravelStopEvent;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AddPath(aObject: TGLBaseSceneObject): TGLMovementPath; overload;
Public | function AddPath: TGLMovementPath; overload;
Public | function AddPath(Path: TGLMovementPath): TGLMovementPath; overload;
Public | function DeletePath: TGLMovementPath; overload;
Public | function DeletePath(Index: integer): TGLMovementPath; overload;
Public | function DeletePath(Path: TGLMovementPath): TGLMovementPath; overload;
Public | function FirstPath: integer;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function LastPath: integer;
Public | function NextPath: integer;
Public | function PrevPath: integer;
Public | class function UniqueItem: boolean; override;
Private | function GetActivePath: TGLMovementPath;
Private | function GetPathCount: integer;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ClearPaths;
Public | procedure DoProgress(const progressTime : TGLProgressTimes); override;
Public | procedure StartPathTravel;
Public | procedure StopPathTravel;
Private | procedure SetActivePath(Value: TGLMovementPath);
Private | procedure SetActivePathIndex(Value: integer);

Properties

Published | property ActivePath: TGLMovementPath Read GetActivePath Write SetActivePath;
Published | property ActivePathIndex: integer Read FActivePathIndex Write SetActivePathIndex;
Published | property AutoStartNextPath: boolean Read FAutoStartNextPath Write FAutoStartNextPath;
Public | property OnAllPathTravelledOver: TNotifyEvent Read FOnAllPathTravelledOver Write FOnAllPathTravelledOver;
Public | property OnPathTravelStart: TPathTravelStartEvent Read FOnPathTravelStart Write FOnPathTravelStart;
Public | property OnPathTravelStop: TPathTravelStopEvent Read FOnPathTravelStop Write FOnPathTravelStop;
Public | property PathCount: integer Read GetPathCount;
Published | property Paths: TGLMovementPaths Read FPaths;

Description

Fields

Private FPaths: TGLMovementPaths;

This item has no description.

Private FAutoStartNextPath: boolean;

This item has no description.

Private FActivePathIndex: integer;

This item has no description.

Private FOnAllPathTravelledOver: TNotifyEvent;

This item has no description.

Private FOnPathTravelStart: TPathTravelStartEvent;

This item has no description.

Private FOnPathTravelStop: TPathTravelStopEvent;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddPath(aObject: TGLBaseSceneObject): TGLMovementPath; overload;

add an path with one node, and the node is based on aObject

Public function AddPath: TGLMovementPath; overload;

add an empty path;

Public function AddPath(Path: TGLMovementPath): TGLMovementPath; overload;

add one path to the new one

Public function DeletePath: TGLMovementPath; overload;

This item has no description.

Public function DeletePath(Index: integer): TGLMovementPath; overload;

This item has no description.

Public function DeletePath(Path: TGLMovementPath): TGLMovementPath; overload;

Result is current path

Public function FirstPath: integer;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function LastPath: integer;

This item has no description.

Public function NextPath: integer;

This item has no description.

Public function PrevPath: integer;

This item has no description.

Public class function UniqueItem: boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Private function GetActivePath: TGLMovementPath;

This item has no description.

Private function GetPathCount: integer;

function GetMovementPath(Index: integer): TGLMovementPath; procedure SetMovementPath(Index: integer; AValue: TGLMovementPath);

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ClearPaths;

This item has no description.

Public procedure DoProgress(const progressTime : TGLProgressTimes); override;

This item has no description.

Public procedure StartPathTravel;

This item has no description.

Public procedure StopPathTravel;

This item has no description.

Private procedure SetActivePath(Value: TGLMovementPath);

This item has no description.

Private procedure SetActivePathIndex(Value: integer);

This item has no description.

Properties

Published property ActivePath: TGLMovementPath Read GetActivePath Write SetActivePath;

This item has no description.

Published property ActivePathIndex: integer Read FActivePathIndex Write SetActivePathIndex;

This item has no description.

Published property AutoStartNextPath: boolean Read FAutoStartNextPath Write FAutoStartNextPath;

This item has no description.

Public property OnAllPathTravelledOver: TNotifyEvent Read FOnAllPathTravelledOver Write FOnAllPathTravelledOver;

why do these property can't be saved in IDE ?

Public property OnPathTravelStart: TPathTravelStartEvent Read FOnPathTravelStart Write FOnPathTravelStart;

This item has no description.

Public property OnPathTravelStop: TPathTravelStopEvent Read FOnPathTravelStop Write FOnPathTravelStop;

This item has no description.

Public property PathCount: integer Read GetPathCount;

property Paths[index: Integer]: TGLMovementPath read GetMovementPath write SetMovementPath;

Published property Paths: TGLMovementPaths Read FPaths;


GLSysHelp v.2.5: GLS.MultiPolygon

Unit GLS.MultiPolygon

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.OpenGLAdapter
  • GLScene.Spline
  • GLS.XOpenGL
  • GLS.Context
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.PersistentClasses
  • GLS.Scene
  • GLS.Objects
  • GLS.GeomObjects
  • GLS.Nodes
  • GLS.BaseClasses
  • GLS.Coordinates
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLContourNodes |
Class TGLContour |
Class TGLContours |
Class TGLPolygonList |
Class TGLMultiPolygonBase |
Class TGLMultiPolygon |
Class TGLVectorPool |

Types

TGLContourClass = class of TGLContour;

Description

Types

TGLContourClass = class of TGLContour;


GLSysHelp v.2.5: GLS.MultiPolygon: Class TGLContourNodes

Class TGLContourNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiPolygon

Declaration

type TGLContourNodes = class(TGLNodes)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLNodes
  • TGLContourNodes

Overview

Methods

Public procedure NotifyChange; override;

Description

Methods

Public procedure NotifyChange; override;


GLSysHelp v.2.5: GLS.MultiPolygon: Class TGLContour

Class TGLContour

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiPolygon

Declaration

type TGLContour = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLContour

Overview

Fields

Private | FNodes: TGLContourNodes;
Private | FDivision: Integer;
Private | FSplineMode: TGLLineSplineMode;
Private | FDescription: string;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetDescription(const Value: string);
Private | procedure SetDivision(Value: Integer);
Private | procedure SetNodes(const Value: TGLContourNodes);
Private | procedure SetSplineMode(const Value: TGLLineSplineMode);

Properties

Published | property Description: string read FDescription write SetDescription;
Published | property Division: Integer read FDivision write SetDivision default 10;
Published | property Nodes: TGLContourNodes read FNodes write SetNodes;
Published | property SplineMode: TGLLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Fields

Private FNodes: TGLContourNodes;

This item has no description.

Private FDivision: Integer;

This item has no description.

Private FSplineMode: TGLLineSplineMode;

This item has no description.

Private FDescription: string;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetDescription(const Value: string);

This item has no description.

Private procedure SetDivision(Value: Integer);

This item has no description.

Private procedure SetNodes(const Value: TGLContourNodes);

This item has no description.

Private procedure SetSplineMode(const Value: TGLLineSplineMode);

This item has no description.

Properties

Published property Description: string read FDescription write SetDescription;

This item has no description.

Published property Division: Integer read FDivision write SetDivision default 10;

Number of divisions for each segment in spline modes. Minimum 1 (disabled), ignored in lsmLines mode.

Published property Nodes: TGLContourNodes read FNodes write SetNodes;

The nodes list

Published property SplineMode: TGLLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Default spline drawing mode. This mode is used only for the curve, not for the rotation path.


GLSysHelp v.2.5: GLS.MultiPolygon: Class TGLContours

Class TGLContours

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiPolygon

Declaration

type TGLContours = class(TGNotifyCollection)

Description

This item has no description.

Hierarchy

  • TGNotifyCollection
  • TGLContours

Overview

Methods

Public | constructor Create(AOwner: TComponent); overload;
Public | function Add: TGLContour; inline;
Public | function FindItemID(ID: Integer): TGLContour; inline;
Private | function GetItems(index: Integer): TGLContour;
Public | procedure GetExtents(var min, max: TAffineVector);
Private | procedure SetItems(index: Integer; const Value: TGLContour);

Properties

Public property Items[index: Integer]: TGLContour read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent); overload;

This item has no description.

Public function Add: TGLContour; inline;

This item has no description.

Public function FindItemID(ID: Integer): TGLContour; inline;

This item has no description.

Private function GetItems(index: Integer): TGLContour;

This item has no description.

Public procedure GetExtents(var min, max: TAffineVector);

This item has no description.

Private procedure SetItems(index: Integer; const Value: TGLContour);

This item has no description.

Properties

Public property Items[index: Integer]: TGLContour read GetItems write SetItems;


GLSysHelp v.2.5: GLS.MultiPolygon: Class TGLPolygonList

Class TGLPolygonList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiPolygon

Declaration

type TGLPolygonList = class(TGLPersistentObjectList)

Description

This item has no description.

Hierarchy

  • TGLPersistentObjectList
  • TGLPolygonList

Overview

Fields

Private FAktList: TGLAffineVectorList;

Methods

Private | function GetList(I: Integer): TGLAffineVectorList;
Public | procedure Add;

Properties

Public | property AktList: TGLAffineVectorList read FAktList;
Public | property List[I: Integer]: TGLAffineVectorList read GetList;

Description

Fields

Private FAktList: TGLAffineVectorList;

This item has no description.

Methods

Private function GetList(I: Integer): TGLAffineVectorList;

This item has no description.

Public procedure Add;

This item has no description.

Properties

Public property AktList: TGLAffineVectorList read FAktList;

This item has no description.

Public property List[I: Integer]: TGLAffineVectorList read GetList;


GLSysHelp v.2.5: GLS.MultiPolygon: Class TGLMultiPolygonBase

Class TGLMultiPolygonBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiPolygon

Declaration

type TGLMultiPolygonBase = class(TGLSceneObject)

Description

Multipolygon is defined with multiple contours. The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator). The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one. Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended. TGLMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of GLS.VectorLists.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMultiPolygonBase

Overview

Fields

Private | FContours: TGLContours;
Private | FOutline: TGLPolygonList;
Private | FContoursNormal: TAffineVector;
Private | FAxisAlignedDimensionsCache: TGLVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Private | function GetOutline: TGLPolygonList;
Private | function GetPath(i: Integer): TGLContourNodes;
Public | procedure AddNode(const i: Integer; const X, Y, Z: TGLfloat); overload;
Public | procedure AddNode(const i: Integer; const coords: TGLCoordinates); overload;
Public | procedure AddNode(const i: Integer; const value: TAffineVector); overload;
Public | procedure AddNode(const i: Integer; const value: TGLVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure StructureChanged; override;
Private | procedure SetContours(const Value: TGLContours);
Private | procedure SetContoursNormal(const Value: TAffineVector);
Private | procedure SetPath(i: Integer; const value: TGLContourNodes);

Properties

Published | property Contours: TGLContours read FContours write SetContours;
Public | property ContoursNormal: TAffineVector read FContoursNormal write SetContoursNormal;
Public | property Outline: TGLPolygonList read GetOutline;
Public | property Path[i: Integer]: TGLContourNodes read GetPath write SetPath;

Description

Fields

Private FContours: TGLContours;

This item has no description.

Private FOutline: TGLPolygonList;

This item has no description.

Private FContoursNormal: TAffineVector;

This item has no description.

Private FAxisAlignedDimensionsCache: TGLVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

property PNormal:PAffineVector read FPNormal;

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Private function GetOutline: TGLPolygonList;

This item has no description.

Private function GetPath(i: Integer): TGLContourNodes;

This item has no description.

Public procedure AddNode(const i: Integer; const X, Y, Z: TGLfloat); overload;

This item has no description.

Public procedure AddNode(const i: Integer; const coords: TGLCoordinates); overload;

This item has no description.

Public procedure AddNode(const i: Integer; const value: TAffineVector); overload;

This item has no description.

Public procedure AddNode(const i: Integer; const value: TGLVector); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Private procedure SetContours(const Value: TGLContours);

This item has no description.

Private procedure SetContoursNormal(const Value: TAffineVector);

This item has no description.

Private procedure SetPath(i: Integer; const value: TGLContourNodes);

This item has no description.

Properties

Published property Contours: TGLContours read FContours write SetContours;

This item has no description.

Public property ContoursNormal: TAffineVector read FContoursNormal write SetContoursNormal;

This item has no description.

Public property Outline: TGLPolygonList read GetOutline;

This item has no description.

Public property Path[i: Integer]: TGLContourNodes read GetPath write SetPath;


GLSysHelp v.2.5: GLS.MultiPolygon: Class TGLMultiPolygon

Class TGLMultiPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiPolygon

Declaration

type TGLMultiPolygon = class(TGLMultiPolygonBase)

Description

A polygon that can have holes and multiple contours. Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMultiPolygonBase
  • TGLMultiPolygon

Overview

Fields

Private FParts: TGLPolygonParts;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published property Parts: TGLPolygonParts read FParts write SetParts default [ppTop, ppBottom];

Description

Fields

Private FParts: TGLPolygonParts;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description. Showing description inherited from TGLMultiPolygonBase.Create.

property PNormal:PAffineVector read FPNormal;

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Parts: TGLPolygonParts read FParts write SetParts default [ppTop, ppBottom];


GLSysHelp v.2.5: GLS.MultiPolygon: Class TGLVectorPool

Class TGLVectorPool

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiPolygon

Declaration

type TGLVectorPool = class(TList)

Description

Page oriented pointer array, with persistent pointer target memory. In TGLVectorList a pointer to a vector will not be valid any more after a call to SetCapacity, which might be done implicitely during Add. The TGLVectorPool keeps memory in its original position during its whole lifetime.

Hierarchy

  • TObject
  • TList
  • TGLVectorPool

Overview

Fields

Private | FEntrySize: Integer;
Private | FPageSize: Integer;
Private | FArrSize: Integer;
Private | FUsedEntries: Integer;
Private | FAktArray: GLScene.VectorGeometry.PByteArray;

Methods

Public | constructor Create(APageSize, AEntrySize: Integer);
Public | destructor Destroy; override;
Public | procedure GetNewVector(var P: Pointer);
Private | procedure CreatePage;

Description

Fields

Private FEntrySize: Integer;

This item has no description.

Private FPageSize: Integer;

size of each entry

Private FArrSize: Integer;

number of entries per page

Private FUsedEntries: Integer;

size of one page

Private FAktArray: GLScene.VectorGeometry.PByteArray;

used entries in actual page

Methods

Public constructor Create(APageSize, AEntrySize: Integer);

creates new page

Public destructor Destroy; override;

This item has no description.

Public procedure GetNewVector(var P: Pointer);

retrieve pointer to new entry. will create new page if needed

Private procedure CreatePage;

pointer to actual page


GLSysHelp v.2.5: GLS.MultiProxy

Unit GLS.MultiProxy

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.Scene
  • GLS.Silhouette
  • GLS.RenderContextInfo
  • GLS.BaseClasses
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMultiProxyMaster |
Class TGLMultiProxyMasters |
Class TGLMultiProxy |


GLSysHelp v.2.5: GLS.MultiProxy: Class TGLMultiProxyMaster

Class TGLMultiProxyMaster

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiProxy

Declaration

type TGLMultiProxyMaster = class(TCollectionItem)

Description

MasterObject description for a MultiProxy object

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLMultiProxyMaster

Overview

Fields

Private | FMasterObject: TGLBaseSceneObject;
Private | FDistanceMin: Single;
Private | FDistanceMin2: Single;
Private | FDistanceMax: Single;
Private | FDistanceMax2: Single;
Private | FVisible: Boolean;

Methods

Public | constructor Create(Collection : TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerObject: TGLMultiProxy;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;

Properties

Published | property DistanceMax : Single read FDistanceMax write SetDistanceMax;
Published | property DistanceMin : Single read FDistanceMin write SetDistanceMin;
Published | property MasterObject : TGLBaseSceneObject read FMasterObject write SetMasterObject;
Published | property Visible : Boolean read FVisible write SetVisible default True;

Description

Fields

Private FMasterObject: TGLBaseSceneObject;

This item has no description.

Private FDistanceMin: Single;

This item has no description.

Private FDistanceMin2: Single;

This item has no description.

Private FDistanceMax: Single;

This item has no description.

Private FDistanceMax2: Single;

This item has no description.

Private FVisible: Boolean;

This item has no description.

Methods

Public constructor Create(Collection : TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OwnerObject: TGLMultiProxy;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Published property DistanceMax : Single read FDistanceMax write SetDistanceMax;

Maximum visibility distance (exclusive).

Published property DistanceMin : Single read FDistanceMin write SetDistanceMin;

Minimum visibility distance (inclusive).

Published property MasterObject : TGLBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.

Published property Visible : Boolean read FVisible write SetVisible default True;

Determines if the master object can be visible (proxy'ed). Note: the master object's distance also has to be within DistanceMin and DistanceMax.


GLSysHelp v.2.5: GLS.MultiProxy: Class TGLMultiProxyMasters

Class TGLMultiProxyMasters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiProxy

Declaration

type TGLMultiProxyMasters = class(TOwnedCollection)

Description

Collection of TGLMultiProxyMaster.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLMultiProxyMasters

Overview

Methods

Public | constructor Create(AOwner : TPersistent);
Public | function Add(master : TGLBaseSceneObject; distanceMin, distanceMax : Single) : TGLMultiProxyMaster; overload;
Public | function Add: TGLMultiProxyMaster; overload;
Public | procedure EndUpdate; override;
Public | procedure Notification(AComponent: TComponent);
Public | procedure NotifyChange;

Properties

Public property Items[index: Integer]: TGLMultiProxyMaster read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner : TPersistent);

This item has no description.

Public function Add(master : TGLBaseSceneObject; distanceMin, distanceMax : Single) : TGLMultiProxyMaster; overload;

This item has no description.

Public function Add: TGLMultiProxyMaster; overload;

This item has no description.

Public procedure EndUpdate; override;

This item has no description.

Public procedure Notification(AComponent: TComponent);

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Public property Items[index: Integer]: TGLMultiProxyMaster read GetItems write SetItems;


GLSysHelp v.2.5: GLS.MultiProxy: Class TGLMultiProxy

Class TGLMultiProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiProxy

Declaration

type TGLMultiProxy = class(TGLSceneObject)

Description

Multiple Proxy object. This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMultiProxy

Overview

Fields

Private | FMasterObjects: TGLMultiProxyMasters;
Private | FRendering: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters) : TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector : TGLVector; intersectPoint : PGLVector = nil; intersectNormal : PGLVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci : TGLRenderContextInfo; renderSelf, renderChildren : Boolean); override;

Properties

Published | property Behaviours;
Published | property Direction;
Published | property MasterObjects : TGLMultiProxyMasters read FMasterObjects write SetMasterObjects;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Fields

Private FMasterObjects: TGLMultiProxyMasters;

This item has no description.

Private FRendering: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters) : TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector : TGLVector; intersectPoint : PGLVector = nil; intersectNormal : PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci : TGLRenderContextInfo; renderSelf, renderChildren : Boolean); override;

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property MasterObjects : TGLMultiProxyMasters read FMasterObjects write SetMasterObjects;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.MultiSampleImage

Unit GLS.MultiSampleImage

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.TextureFormat
  • GLS.Context
  • GLS.Texture
  • GLS.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMultisampleImage |


GLSysHelp v.2.5: GLS.MultiSampleImage: Class TGLMultisampleImage

Class TGLMultisampleImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.MultiSampleImage

Declaration

type TGLMultisampleImage = class(TGLTextureImage)

Description

This item has no description. Showing description inherited from TGLTextureImage.

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLMultisampleImage

Overview

Fields

Private | FBitmap: TGLBitmap32;
Private | FSamplesCount: Integer;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FDepth: Integer;
Private | FFixedSamplesLocation: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLBitmap32; override;
Public | class function IsSelfLoading: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure LoadTexture(AInternalFormat: TGLInternalFormat); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Private | procedure SetDepth(val: Integer);
Private | procedure SetFixedSamplesLocation(val: Boolean);
Private | procedure SetHeight(val: Integer);
Private | procedure SetSamplesCount(val: Integer);
Private | procedure SetWidth(val: Integer);

Properties

Published | property Depth: Integer read GetDepth write SetDepth default 0;
Published | property FixedSamplesLocation: Boolean read FFixedSamplesLocation write SetFixedSamplesLocation;
Published | property Height: Integer read GetHeight write SetHeight default 256;
Public | property NativeTextureTarget;
Published | property SamplesCount: Integer read FSamplesCount write SetSamplesCount default 0;
Published | property Width: Integer read GetWidth write SetWidth default 256;

Description

Fields

Private FBitmap: TGLBitmap32;

This item has no description.

Private FSamplesCount: Integer;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FDepth: Integer;

This item has no description.

Private FFixedSamplesLocation: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TGLBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public class function IsSelfLoading: Boolean; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure LoadTexture(AInternalFormat: TGLInternalFormat); override;

This item has no description.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when GLScene no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Private procedure SetDepth(val: Integer);

This item has no description.

Private procedure SetFixedSamplesLocation(val: Boolean);

This item has no description.

Private procedure SetHeight(val: Integer);

This item has no description.

Private procedure SetSamplesCount(val: Integer);

This item has no description.

Private procedure SetWidth(val: Integer);

This item has no description.

Properties

Published property Depth: Integer read GetDepth write SetDepth default 0;

This item has no description.

Published property FixedSamplesLocation: Boolean read FFixedSamplesLocation write SetFixedSamplesLocation;

This item has no description.

Published property Height: Integer read GetHeight write SetHeight default 256;

Width of the blank image (for memory allocation).

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TGLTextureImage.NativeTextureTarget.

Native opengl texture target.

Published property SamplesCount: Integer read FSamplesCount write SetSamplesCount default 0;

This item has no description.

Published property Width: Integer read GetWidth write SetWidth default 256;

Width of the blank image (for memory allocation).


GLSysHelp v.2.5: GLS.Navigator

Unit GLS.Navigator

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Types
  • System.Classes
  • System.SysUtils
  • System.Math
  • Vcl.Controls
  • Vcl.Graphics
  • Vcl.Forms
  • GLS.Scene
  • GLS.SceneViewer
  • GLS.Objects
  • GLS.GeomObjects
  • GLS.Context
  • GLS.BaseClasses
  • GLS.PersistentClasses
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Keyboard
  • GLS.HudObjects
  • GLS.Coordinates
  • GLS.Screen
  • GLS.Material
  • GLS.Texture
  • GLScene.TextureFormat
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNavigator |
Class TGLUserInterface |
Class TGLNaviCube |

Variables

sW2: integer;
sH2: integer;

Description

Variables

sW2: integer;

This item has no description.

sH2: integer;


GLSysHelp v.2.5: GLS.Navigator: Class TGLNavigator

Class TGLNavigator

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Navigator

Declaration

type TGLNavigator = class(TComponent)

Description

TGLNavigator is the component for moving a TGLBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor. The four calls to get you started is TurnHorisontal : it turns left and right. TurnVertical : it turns up and down. MoveForward : moves back and forth. FlyForward : moves back and forth in the movingobject's direction The three properties to get you started is MovingObject : The Object that you are moving. UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't more like Descent. AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane...(no tilt and flying) InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLNavigator

Overview

Fields

Private | FObject: TGLBaseSceneObject;
Private | FVirtualRight: TGLVector;
Private | FVirtualUp: TGLCoordinates;
Private | FUseVirtualUp: boolean;
Private | FAutoUpdateObject: boolean;
Private | FMaxAngle: single;
Private | FMinAngle: single;
Private | FCurrentVAngle: single;
Private | FCurrentHAngle: single;
Private | FAngleLock: boolean;
Private | FMoveUpWhenMovingForward: boolean;
Private | FInvertHorizontalSteeringWhenUpsideDown: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure FlyForward(Distance: single);
Public | procedure LoadState(Stream: TStream);
Public | procedure MoveForward(Distance: single);
Public | procedure SaveState(Stream: TStream);
Public | procedure StrafeHorizontal(Distance: single);
Public | procedure StrafeVertical(Distance: single);
Public | procedure Straighten;
Public | procedure TurnHorizontal(Angle: single);
Public | procedure TurnVertical(Angle: single);

Properties

Published | property AngleLock: boolean read FAngleLock write FAngleLock default False;
Published | property AutoUpdateObject: boolean read FAutoUpdateObject write FAutoUpdateObject default False;
Public | property CurrentHAngle: single read FCurrentHAngle;
Public | property CurrentVAngle: single read FCurrentVAngle;
Published | property InvertHorizontalSteeringWhenUpsideDown: boolean read FInvertHorizontalSteeringWhenUpsideDown write FInvertHorizontalSteeringWhenUpsideDown default False;
Published | property MaxAngle: single read FMaxAngle write FMaxAngle;
Published | property MinAngle: single read FMinAngle write FMinAngle;
Published | property MoveUpWhenMovingForward: boolean read FMoveUpWhenMovingForward write FMoveUpWhenMovingForward default False;
Published | property MovingObject: TGLBaseSceneObject read FObject write SetObject;
Published | property UseVirtualUp: boolean read FUseVirtualUp write SetUseVirtualUp default False;
Published | property VirtualUp: TGLCoordinates read FVirtualUp write SetVirtualUp;

Description

Fields

Private FObject: TGLBaseSceneObject;

This item has no description.

Private FVirtualRight: TGLVector;

This item has no description.

Private FVirtualUp: TGLCoordinates;

This item has no description.

Private FUseVirtualUp: boolean;

This item has no description.

Private FAutoUpdateObject: boolean;

This item has no description.

Private FMaxAngle: single;

This item has no description.

Private FMinAngle: single;

This item has no description.

Private FCurrentVAngle: single;

This item has no description.

Private FCurrentHAngle: single;

This item has no description.

Private FAngleLock: boolean;

This item has no description.

Private FMoveUpWhenMovingForward: boolean;

This item has no description.

Private FInvertHorizontalSteeringWhenUpsideDown: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure FlyForward(Distance: single);

This item has no description.

Public procedure LoadState(Stream: TStream);

This item has no description.

Public procedure MoveForward(Distance: single);

This item has no description.

Public procedure SaveState(Stream: TStream);

This item has no description.

Public procedure StrafeHorizontal(Distance: single);

This item has no description.

Public procedure StrafeVertical(Distance: single);

This item has no description.

Public procedure Straighten;

This item has no description.

Public procedure TurnHorizontal(Angle: single);

This item has no description.

Public procedure TurnVertical(Angle: single);

This item has no description.

Properties

Published property AngleLock: boolean read FAngleLock write FAngleLock default False;

This item has no description.

Published property AutoUpdateObject: boolean read FAutoUpdateObject write FAutoUpdateObject default False;

This item has no description.

Public property CurrentHAngle: single read FCurrentHAngle;

This item has no description.

Public property CurrentVAngle: single read FCurrentVAngle;

This item has no description.

Published property InvertHorizontalSteeringWhenUpsideDown: boolean read FInvertHorizontalSteeringWhenUpsideDown write FInvertHorizontalSteeringWhenUpsideDown default False;

This item has no description.

Published property MaxAngle: single read FMaxAngle write FMaxAngle;

This item has no description.

Published property MinAngle: single read FMinAngle write FMinAngle;

This item has no description.

Published property MoveUpWhenMovingForward: boolean read FMoveUpWhenMovingForward write FMoveUpWhenMovingForward default False;

This item has no description.

Published property MovingObject: TGLBaseSceneObject read FObject write SetObject;

This item has no description.

Published property UseVirtualUp: boolean read FUseVirtualUp write SetUseVirtualUp default False;

This item has no description.

Published property VirtualUp: TGLCoordinates read FVirtualUp write SetVirtualUp;


GLSysHelp v.2.5: GLS.Navigator: Class TGLUserInterface

Class TGLUserInterface

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Navigator

Declaration

type TGLUserInterface = class(TComponent)

Description

TGLUserInterface is the component which reads the user input and transform it into action. The four calls to get you started is MouseLookActivate : set us up the bomb. MouseLookDeActivate : defuses it. Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. MouseSpeed : Also known as mouse sensitivity. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLUserInterface

Overview

Fields

Private | FPrevPoint: TPoint;
Private | midScreenX: integer;
Private | midScreenY: integer;
Private | FMouseActive: boolean;
Private | FMouseSpeed: single;
Private | FGLNavigator: TGLNavigator;
Private | FGLVertNavigator: TGLNavigator;
Private | FInvertMouse: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function IsMouseLookOn: boolean;
Public | function MouseLook: boolean;
Public | procedure MouseLookActivate;
Public | procedure MouseLookActiveToggle;
Public | procedure MouseLookDeactivate;
Public | procedure MouseUpdate;
Public | procedure TurnHorizontal(Angle: Double);
Public | procedure TurnVertical(Angle: Double);
Private | procedure MouseInitialize;
Private | procedure SetMouseLookActive(const val: boolean);
Private | procedure setNavigator(val: TGLNavigator);
Private | procedure setVertNavigator(val: TGLNavigator);

Properties

Published | property GLNavigator: TGLNavigator read FGLNavigator write setNavigator;
Published | property GLVertNavigator: TGLNavigator read FGLVertNavigator write setVertNavigator;
Published | property InvertMouse: boolean read FInvertMouse write FInvertMouse default False;
Public | property MouseLookActive: boolean read FMouseActive write SetMouseLookActive;
Published | property MouseSpeed: single read FMouseSpeed write FMouseSpeed;

Description

Fields

Private FPrevPoint: TPoint;

This item has no description.

Private midScreenX: integer;

This item has no description.

Private midScreenY: integer;

This item has no description.

Private FMouseActive: boolean;

This item has no description.

Private FMouseSpeed: single;

This item has no description.

Private FGLNavigator: TGLNavigator;

This item has no description.

Private FGLVertNavigator: TGLNavigator;

This item has no description.

Private FInvertMouse: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsMouseLookOn: boolean;

This item has no description.

Public function MouseLook: boolean;

This item has no description.

Public procedure MouseLookActivate;

This item has no description.

Public procedure MouseLookActiveToggle;

This item has no description.

Public procedure MouseLookDeactivate;

This item has no description.

Public procedure MouseUpdate;

This item has no description.

Public procedure TurnHorizontal(Angle: Double);

This item has no description.

Public procedure TurnVertical(Angle: Double);

This item has no description.

Private procedure MouseInitialize;

This item has no description.

Private procedure SetMouseLookActive(const val: boolean);

This item has no description.

Private procedure setNavigator(val: TGLNavigator);

This item has no description.

Private procedure setVertNavigator(val: TGLNavigator);

This item has no description.

Properties

Published property GLNavigator: TGLNavigator read FGLNavigator write setNavigator;

This item has no description.

Published property GLVertNavigator: TGLNavigator read FGLVertNavigator write setVertNavigator;

This item has no description.

Published property InvertMouse: boolean read FInvertMouse write FInvertMouse default False;

This item has no description.

Public property MouseLookActive: boolean read FMouseActive write SetMouseLookActive;

This item has no description.

Published property MouseSpeed: single read FMouseSpeed write FMouseSpeed;


GLSysHelp v.2.5: GLS.Navigator: Class TGLNaviCube

Class TGLNaviCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Navigator

Declaration

type TGLNaviCube = class(TGLBaseSceneObject)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLNaviCube

Overview

Fields

Private | FDelta: single;
Private | FFps: single;
Private | FTimer: single;
Private | FInactiveTime: single;
Private | FCube: TGLDummyCube;
Private | FSel: integer;
Private | FSelPos: TGLVector;
Private | FCam: TGLCamera;
Private | FNaviCam: TGLCamera;
Private | FHud: TGLHUDSprite;
Private | FMem: TGLMemoryViewer;
Private | FViewer: TGLSceneViewer;
Private | FReady: boolean;
Private | FMouse: boolean;
Private | FMouseRotation: boolean;
Private | FMousePos: TPoint;
Private | FPosAnimationStart: TGLVector;
Private | FPosAnimationEnd: TGLVector;

Methods

Public | constructor CreateAsChild(aParentOwner: TGLBaseSceneObject); reintroduce;
Public | procedure DoProgress(const pt: TGLProgressTimes); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: boolean); override;

Properties

Public | property ActiveMouse: boolean read FMouse write FMouse;
Public | property Camera: TGLCamera read FCam write FCam;
Public | property FPS: single read FFps write FFps;
Public | property InactiveTime: single read FInactiveTime write FInactiveTime;
Public | property SceneViewer: TGLSceneViewer read FViewer write FViewer;

Description

Fields

Private FDelta: single;

This item has no description.

Private FFps: single;

This item has no description.

Private FTimer: single;

This item has no description.

Private FInactiveTime: single;

This item has no description.

Private FCube: TGLDummyCube;

This item has no description.

Private FSel: integer;

This item has no description.

Private FSelPos: TGLVector;

This item has no description.

Private FCam: TGLCamera;

This item has no description.

Private FNaviCam: TGLCamera;

This item has no description.

Private FHud: TGLHUDSprite;

This item has no description.

Private FMem: TGLMemoryViewer;

This item has no description.

Private FViewer: TGLSceneViewer;

This item has no description.

Private FReady: boolean;

This item has no description.

Private FMouse: boolean;

This item has no description.

Private FMouseRotation: boolean;

This item has no description.

Private FMousePos: TPoint;

This item has no description.

Private FPosAnimationStart: TGLVector;

This item has no description.

Private FPosAnimationEnd: TGLVector;

This item has no description.

Methods

Public constructor CreateAsChild(aParentOwner: TGLBaseSceneObject); reintroduce;

This item has no description.

Public procedure DoProgress(const pt: TGLProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: boolean); override;

This item has no description.

Properties

Public property ActiveMouse: boolean read FMouse write FMouse;

This item has no description.

Public property Camera: TGLCamera read FCam write FCam;

This item has no description.

Public property FPS: single read FFps write FFps;

This item has no description.

Public property InactiveTime: single read FInactiveTime write FInactiveTime;

This item has no description.

Public property SceneViewer: TGLSceneViewer read FViewer write FViewer;


GLSysHelp v.2.5: GLS.NGDManager

Unit GLS.NGDManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • System.Types
  • NGD.Import
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLScene.XCollection
  • GLScene.GeometryBB
  • GLS.BaseClasses
  • GLS.PersistentClasses
  • GLS.Scene
  • GLScene.Manager
  • GLS.Coordinates
  • GLS.Objects
  • GLS.GeomObjects
  • GLS.VectorFileObjects
  • GLS.Color

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLNGDHeightField |
Class TGLNGDBehaviourList |
Class TGLNGDDebugOption |
Class TGLNGDManager |
Class TGLNGDBehaviour |
Class TGLNGDDynamic |
Class TGLNGDStatic |
Class TGLNGDSurfaceItem |
Class TGLNGDSurfacePair |
Class TGLNGDJointPivot |
Class TGLNGDJointPin |
Class TGLNGDJointPin2 |
Class TGLNGDJointBallAndSocket |
Class TGLNGDJointHinge |
Class TGLNGDJointSlider |
Class TGLNGDJointKinematicController |
Class TGLNGDJoint |

Functions and Procedures

function GetNGDStatic(Obj: TGLBaseSceneObject): TGLNGDStatic;
function GetOrCreateNGDStatic(Obj: TGLBaseSceneObject): TGLNGDStatic;
function GetNGDDynamic(Obj: TGLBaseSceneObject): TGLNGDDynamic;
function GetOrCreateNGDDynamic(Obj: TGLBaseSceneObject): TGLNGDDynamic;
function GetBodyFromGLSceneObject(Obj: TGLBaseSceneObject): PNewtonBody;

Types

TAABBOverlapEvent = function(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer): Boolean of object;
TApplyForceAndTorqueEvent = procedure(const cbody: PNewtonBody; timestep: dFloat; threadIndex: Integer) of object;
TCollisionIteratorEvent = procedure(const userData: Pointer; vertexCount: Integer; const cfaceArray: PdFloat; faceId: Integer) of object;
TContactProcessEvent = procedure(const ccontact: PNewtonJoint; timestep: dFloat; threadIndex: Integer) of object;
TDeSerializeEvent = procedure(serializeHandle: Pointer; buffer: Pointer; size: Cardinal) of object;
TGLNGDCollisions = (...);
TGLNGDFrictionModels = (...);
TGLNGDJoints = (...);
TGLNGDManagerDebug = (...);
TGLNGDManagerDebugs = set of TGLNGDManagerDebug;
TGLNGDPickedActions = (...);
TGLNGDSolverModels = (...);
TSerializeEvent = procedure(serializeHandle: Pointer; const cbuffer: Pointer; size: Cardinal) of object;
TSetTransformEvent = procedure(const cbody: PNewtonBody; const cmatrix: PdFloat; threadIndex: Integer) of object;

Description

Functions and Procedures

function GetNGDStatic(Obj: TGLBaseSceneObject): TGLNGDStatic;

Global function

function GetOrCreateNGDStatic(Obj: TGLBaseSceneObject): TGLNGDStatic;

This item has no description.

function GetNGDDynamic(Obj: TGLBaseSceneObject): TGLNGDDynamic;

This item has no description.

function GetOrCreateNGDDynamic(Obj: TGLBaseSceneObject): TGLNGDDynamic;

This item has no description.

function GetBodyFromGLSceneObject(Obj: TGLBaseSceneObject): PNewtonBody;

This item has no description.

Types

TAABBOverlapEvent = function(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer): Boolean of object;

This item has no description.

TApplyForceAndTorqueEvent = procedure(const cbody: PNewtonBody; timestep: dFloat; threadIndex: Integer) of object;

This item has no description.

TCollisionIteratorEvent = procedure(const userData: Pointer; vertexCount: Integer; const cfaceArray: PdFloat; faceId: Integer) of object;

Events for Newton Callback

TContactProcessEvent = procedure(const ccontact: PNewtonJoint; timestep: dFloat; threadIndex: Integer) of object;

This item has no description.

TDeSerializeEvent = procedure(serializeHandle: Pointer; buffer: Pointer; size: Cardinal) of object;

This item has no description.

TGLNGDCollisions = (...);

This item has no description.

Values
  • nc_Primitive = 0
  • nc_Convex
  • nc_BBox
  • nc_BSphere
  • nc_Tree
  • nc_Mesh
  • nc_Null
  • nc_HeightField
  • nc_NGDFile
TGLNGDFrictionModels = (...);

This item has no description.

Values
  • fmExact = 0
  • fmAdaptive
TGLNGDJoints = (...);

This item has no description.

Values
  • nj_BallAndSocket
  • nj_Hinge
  • nj_Slider
  • nj_Corkscrew
  • nj_Universal
  • nj_CustomBallAndSocket
  • nj_CustomHinge
  • nj_CustomSlider
  • nj_UpVector
  • nj_KinematicController
TGLNGDManagerDebug = (...);

This item has no description.

Values
  • mdShowGeometry
  • mdShowAABB
  • mdShowCenterOfMass
  • mdShowContact
  • mdShowJoint
  • mdShowForce
  • mdShowAppliedForce
  • mdShowAppliedVelocity
TGLNGDManagerDebugs = set of TGLNGDManagerDebug;

This item has no description.

TGLNGDPickedActions = (...);

This item has no description.

Values
  • paAttach = 0
  • paMove
  • paDetach
TGLNGDSolverModels = (...);

This item has no description.

Values
  • smExact = 0
  • smLinear1
  • smLinear2
  • smLinear3
  • smLinear4
  • smLinear5
  • smLinear6
  • smLinear7
  • smLinear8
  • smLinear9
TSerializeEvent = procedure(serializeHandle: Pointer; const cbuffer: Pointer; size: Cardinal) of object;

This item has no description.

TSetTransformEvent = procedure(const cbody: PNewtonBody; const cmatrix: PdFloat; threadIndex: Integer) of object;


GLSysHelp v.2.5: GLS.NGDManager: Record TGLNGDHeightField

Record TGLNGDHeightField

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDHeightField = record

Description

TComponent TList TWriter TReader TPersistent Samevalue isZero to compare single NGD.Joints, // old joints Physics.NewtonImport, // new version 4.0 PGLVector TGLVector TGLMatrix PGLMatrix NullHmgVector... TGLAffineVectorList for Tree TXCollection file function For show debug cube cone freeform...

Overview

Fields

Public | heightArray: array of Word;
Public | width: Integer;
Public | depth: Integer;
Public | gridDiagonals: Boolean;
Public | widthDepthScale: Single;
Public | heightScale: Single;

Description

Fields

Public heightArray: array of Word;

This item has no description.

Public width: Integer;

This item has no description.

Public depth: Integer;

This item has no description.

Public gridDiagonals: Boolean;

This item has no description.

Public widthDepthScale: Single;

This item has no description.

Public heightScale: Single;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDBehaviourList

Class TGLNGDBehaviourList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDBehaviourList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLNGDBehaviourList

Overview

Properties

Public property ItemsBehav[index: Integer]: TGLNGDBehaviour read GetBehav write PutBehav;

Description

Properties

Public property ItemsBehav[index: Integer]: TGLNGDBehaviour read GetBehav write PutBehav;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDDebugOption

Class TGLNGDDebugOption

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDDebugOption = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLNGDDebugOption

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | destructor Destroy; override;

Properties

Published | property AABBColor: TGLColor read FAABBColor write FAABBColor;
Published | property AABBColorSleep: TGLColor read FAABBColorSleep write FAABBColorSleep;
Published | property AppliedForceColor: TGLColor read FAppliedForceColor write FAppliedForceColor;
Published | property AppliedVelocityColor: TGLColor read FAppliedVelocityColor write FAppliedVelocityColor;
Published | property CenterOfMassColor: TGLColor read FCenterOfMassColor write FCenterOfMassColor;
Published | property ContactColor: TGLColor read FContactColor write FContactColor;
Published | property CustomColor: TGLColor read FCustomColor write FCustomColor;
Published | property DotAxisSize: Single read FDotAxisSize write SetDotAxisSize stored StoredDotAxis;
Published | property ForceColor: TGLColor read FForceColor write FForceColor;
Published | property GeomColorDyn: TGLColor read FGeomColorDyn write FGeomColorDyn;
Published | property GeomColorStat: TGLColor read FGeomColorStat write FGeomColorStat;
Published | property JointAxisColor: TGLColor read FJointAxisColor write FJointAxisColor;
Published | property JointPivotColor: TGLColor read FJointPivotColor write FJointPivotColor;
Published | property NGDManagerDebugs: TGLNGDManagerDebugs read FManagerDebugs write SetManagerDebugs default [];

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property AABBColor: TGLColor read FAABBColor write FAABBColor;

This item has no description.

Published property AABBColorSleep: TGLColor read FAABBColorSleep write FAABBColorSleep;

This item has no description.

Published property AppliedForceColor: TGLColor read FAppliedForceColor write FAppliedForceColor;

This item has no description.

Published property AppliedVelocityColor: TGLColor read FAppliedVelocityColor write FAppliedVelocityColor;

This item has no description.

Published property CenterOfMassColor: TGLColor read FCenterOfMassColor write FCenterOfMassColor;

This item has no description.

Published property ContactColor: TGLColor read FContactColor write FContactColor;

This item has no description.

Published property CustomColor: TGLColor read FCustomColor write FCustomColor;

This item has no description.

Published property DotAxisSize: Single read FDotAxisSize write SetDotAxisSize stored StoredDotAxis;

This item has no description.

Published property ForceColor: TGLColor read FForceColor write FForceColor;

This item has no description.

Published property GeomColorDyn: TGLColor read FGeomColorDyn write FGeomColorDyn;

This item has no description.

Published property GeomColorStat: TGLColor read FGeomColorStat write FGeomColorStat;

This item has no description.

Published property JointAxisColor: TGLColor read FJointAxisColor write FJointAxisColor;

This item has no description.

Published property JointPivotColor: TGLColor read FJointPivotColor write FJointPivotColor;

This item has no description.

Published property NGDManagerDebugs: TGLNGDManagerDebugs read FManagerDebugs write SetManagerDebugs default [];


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDManager

Class TGLNGDManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLNGDManager

Overview

Fields

Private | FNewtonWorld: PNewtonWorld;
Private | FNGDBehaviours: TGLNGDBehaviourList;
Private | FCurrentColor: TGLColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Step(deltatime: Single);

Properties

Published | property DebugOption: TGLNGDDebugOption read FNewtonDebugOption write FNewtonDebugOption;
Published | property DllVersion: Integer read FDllVersion;
Published | property FrictionModel: TGLNGDFrictionModels read FFrictionModel write SetFrictionModel default fmExact;
Published | property Gravity: TGLCoordinates read FGravity write FGravity;
Published | property Line: TGLLines read FGLLines write SetGLLines;
Published | property MinimumFrameRate: Integer read FMinimumFrameRate write SetMinimumFrameRate default 60;
Published | property NewtonBodyCount: Integer read GetBodyCount;
Published | property NewtonConstraintCount: Integer read GetConstraintCount;
Published | property NewtonJoint: TOwnedCollection read FNewtonJointGroup write FNewtonJointGroup;
Published | property NewtonSurfaceItem: TCollection read FNewtonSurfaceItem write FNewtonSurfaceItem;
Published | property NewtonSurfacePair: TOwnedCollection read FNewtonSurfacePair write FNewtonSurfacePair;
Published | property SolverModel: TGLNGDSolverModels read FSolverModel write SetSolverModel default smExact;
Published | property ThreadCount: Integer read FThreadCount write SetThreadCount default 1;
Published | property Visible: Boolean read FVisible write SetVisible default True;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;
Published | property WorldSizeMax: TGLCoordinates read FWorldSizeMax write FWorldSizeMax;
Published | property WorldSizeMin: TGLCoordinates read FWorldSizeMin write FWorldSizeMin;

Description

Fields

Private FNewtonWorld: PNewtonWorld;

This item has no description.

Private FNGDBehaviours: TGLNGDBehaviourList;

This item has no description.

Private FCurrentColor: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

Debug view

Public destructor Destroy; override;

This item has no description.

Public procedure Step(deltatime: Single);

This item has no description.

Properties

Published property DebugOption: TGLNGDDebugOption read FNewtonDebugOption write FNewtonDebugOption;

This item has no description.

Published property DllVersion: Integer read FDllVersion;

This item has no description.

Published property FrictionModel: TGLNGDFrictionModels read FFrictionModel write SetFrictionModel default fmExact;

This item has no description.

Published property Gravity: TGLCoordinates read FGravity write FGravity;

This item has no description.

Published property Line: TGLLines read FGLLines write SetGLLines;

This item has no description.

Published property MinimumFrameRate: Integer read FMinimumFrameRate write SetMinimumFrameRate default 60;

This item has no description.

Published property NewtonBodyCount: Integer read GetBodyCount;

This item has no description.

Published property NewtonConstraintCount: Integer read GetConstraintCount;

This item has no description.

Published property NewtonJoint: TOwnedCollection read FNewtonJointGroup write FNewtonJointGroup;

This item has no description.

Published property NewtonSurfaceItem: TCollection read FNewtonSurfaceItem write FNewtonSurfaceItem;

This item has no description.

Published property NewtonSurfacePair: TOwnedCollection read FNewtonSurfacePair write FNewtonSurfacePair;

This item has no description.

Published property SolverModel: TGLNGDSolverModels read FSolverModel write SetSolverModel default smExact;

This item has no description.

Published property ThreadCount: Integer read FThreadCount write SetThreadCount default 1;

This item has no description.

Published property Visible: Boolean read FVisible write SetVisible default True;

This item has no description.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

This item has no description.

Published property WorldSizeMax: TGLCoordinates read FWorldSizeMax write FWorldSizeMax;

This item has no description.

Published property WorldSizeMin: TGLCoordinates read FWorldSizeMin write FWorldSizeMin;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDBehaviour

Class TGLNGDBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDBehaviour = class(TGLBehaviour)

Description

Basis structures for Behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLNGDBehaviour

Overview

Fields

Private | FManager: TGLNGDManager;
Private | FManagerName: string;
Private | FInitialized: Boolean;
Private | FNewtonBody: PNewtonBody;
Private | FCollision: PNewtonCollision;
Private | FNewtonBodyMatrix: TGLMatrix;
Private | FContinuousCollisionMode: Boolean;
Private | FNewtonCollisions: TGLNGDCollisions;
Private | FCollisionIteratorEvent: TCollisionIteratorEvent;
Private | FOwnerBaseSceneObject: TGLBaseSceneObject;
Private | FTreeCollisionOptimize: Boolean;
Private | FConvexCollisionTolerance: Single;
Private | FFileCollision: string;
Private | FSurfaceItem: TGLNGDSurfaceItem;
Private | FHeightFieldOptions: TGLNGDHeightField;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure DeSerialize(filename: string);
Public | procedure Reinitialize;
Public | procedure Serialize(filename: string);

Properties

Published | property ContinuousCollisionMode: Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;
Published | property ConvexCollisionTolerance: Single read FConvexCollisionTolerance write FConvexCollisionTolerance stored StoredTolerance;
Published | property FileCollision: string read FFileCollision write FFileCollision;
Public | property HeightFieldOptions: TGLNGDHeightField read FHeightFieldOptions write SetHeightFieldOptions;
Public | property Initialized: Boolean read FInitialized;
Published | property Manager: TGLNGDManager read FManager write SetManager;
Public | property NewtonBodyAABB: TAABB read GetNewtonBodyAABB;
Public | property NewtonBodyMatrix: TGLMatrix read GetNewtonBodyMatrix write SetNewtonBodyMatrix;
Published | property NGDNewtonCollisions: TGLNGDCollisions read FNewtonCollisions write SetNewtonCollisions default nc_Primitive;
Published | property NGDSurfaceItem: TGLNGDSurfaceItem read FSurfaceItem write SetNewtonSurfaceItem;
Published | property TreeCollisionOptimize: Boolean read FTreeCollisionOptimize write FTreeCollisionOptimize default True;

Description

Fields

Private FManager: TGLNGDManager;

This item has no description.

Private FManagerName: string;

This item has no description.

Private FInitialized: Boolean;

This item has no description.

Private FNewtonBody: PNewtonBody;

This item has no description.

Private FCollision: PNewtonCollision;

This item has no description.

Private FNewtonBodyMatrix: TGLMatrix;

This item has no description.

Private FContinuousCollisionMode: Boolean;

Position and Orientation

Private FNewtonCollisions: TGLNGDCollisions;

Default=False

Private FCollisionIteratorEvent: TCollisionIteratorEvent;

This item has no description.

Private FOwnerBaseSceneObject: TGLBaseSceneObject;

This item has no description.

Private FTreeCollisionOptimize: Boolean;

FNullCollisionMass: Single; // Default=0

Private FConvexCollisionTolerance: Single;

Default=True

Private FFileCollision: string;

Default=0.01 1%

Private FSurfaceItem: TGLNGDSurfaceItem;

This item has no description.

Private FHeightFieldOptions: TGLNGDHeightField;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure DeSerialize(filename: string);

This item has no description.

Public procedure Reinitialize;

This item has no description.

Public procedure Serialize(filename: string);

This item has no description.

Properties

Published property ContinuousCollisionMode: Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;

This item has no description.

Published property ConvexCollisionTolerance: Single read FConvexCollisionTolerance write FConvexCollisionTolerance stored StoredTolerance;

This item has no description.

Published property FileCollision: string read FFileCollision write FFileCollision;

This item has no description.

Public property HeightFieldOptions: TGLNGDHeightField read FHeightFieldOptions write SetHeightFieldOptions;

This item has no description.

Public property Initialized: Boolean read FInitialized;

This item has no description.

Published property Manager: TGLNGDManager read FManager write SetManager;

This item has no description.

Public property NewtonBodyAABB: TAABB read GetNewtonBodyAABB;

This item has no description.

Public property NewtonBodyMatrix: TGLMatrix read GetNewtonBodyMatrix write SetNewtonBodyMatrix;

This item has no description.

Published property NGDNewtonCollisions: TGLNGDCollisions read FNewtonCollisions write SetNewtonCollisions default nc_Primitive;

This item has no description.

Published property NGDSurfaceItem: TGLNGDSurfaceItem read FSurfaceItem write SetNewtonSurfaceItem;

This item has no description.

Published property TreeCollisionOptimize: Boolean read FTreeCollisionOptimize write FTreeCollisionOptimize default True;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDDynamic

Class TGLNGDDynamic

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDDynamic = class(TGLNGDBehaviour)

Description

This item has no description. Showing description inherited from TGLNGDBehaviour.

Basis structures for Behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLNGDBehaviour
  • TGLNGDDynamic

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | function GetOmega: TGLVector;
Public | function GetVelocity: TGLVector;
Public | procedure AddImpulse(const veloc, pointposit: TGLVector);
Public | procedure SetOmega(const Omega: TGLVector);
Public | procedure SetVelocity(const Velocity: TGLVector);

Properties

Published | property AngularDamping: TGLCoordinates read FAngularDamping write FAngularDamping;
Published | property AppliedForce: TGLCoordinates read FAppliedForce;
Published | property AppliedOmega: TGLCoordinates read FAppliedOmega;
Published | property AppliedTorque: TGLCoordinates read FAppliedTorque;
Published | property AppliedVelocity: TGLCoordinates read FAppliedVelocity;
Published | property AutoSleep: Boolean read FAutoSleep write SetAutoSleep default True;
Published | property CenterOfMass: TGLCoordinates read FCenterOfMass write FCenterOfMass;
Public | property CustomForceAndTorqueEvent: TApplyForceAndTorqueEvent read FCustomForceAndTorqueEvent write FCustomForceAndTorqueEvent;
Published | property Density: Single read FDensity write SetDensity stored StoredDensity;
Published | property Force: TGLCoordinates read FForce write FForce;
Published | property LinearDamping: Single read FLinearDamping write SetLinearDamping stored StoredLinearDamping;
Published | property Mass: Single read FMass;
Published | property NullCollisionVolume: Single read FNullCollisionVolume write FNullCollisionVolume stored StoredNullCollisionVolume;
Public | property Omega: TGLVector read GetOmega write SetOmega;
Published | property Torque: TGLCoordinates read FTorque write FTorque;
Published | property UseGravity: Boolean read FUseGravity write FUseGravity default True;
Public | property Velocity: TGLVector read GetVelocity write SetVelocity;
Published | property Volume: Single read FVolume;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function GetOmega: TGLVector;

This item has no description.

Public function GetVelocity: TGLVector;

This item has no description.

Public procedure AddImpulse(const veloc, pointposit: TGLVector);

This item has no description.

Public procedure SetOmega(const Omega: TGLVector);

This item has no description.

Public procedure SetVelocity(const Velocity: TGLVector);

This item has no description.

Properties

Published property AngularDamping: TGLCoordinates read FAngularDamping write FAngularDamping;

This item has no description.

Published property AppliedForce: TGLCoordinates read FAppliedForce;

This item has no description.

Published property AppliedOmega: TGLCoordinates read FAppliedOmega;

Read Only

Published property AppliedTorque: TGLCoordinates read FAppliedTorque;

This item has no description.

Published property AppliedVelocity: TGLCoordinates read FAppliedVelocity;

This item has no description.

Published property AutoSleep: Boolean read FAutoSleep write SetAutoSleep default True;

This item has no description.

Published property CenterOfMass: TGLCoordinates read FCenterOfMass write FCenterOfMass;

This item has no description.

Public property CustomForceAndTorqueEvent: TApplyForceAndTorqueEvent read FCustomForceAndTorqueEvent write FCustomForceAndTorqueEvent;

This item has no description.

Published property Density: Single read FDensity write SetDensity stored StoredDensity;

This item has no description.

Published property Force: TGLCoordinates read FForce write FForce;

This item has no description.

Published property LinearDamping: Single read FLinearDamping write SetLinearDamping stored StoredLinearDamping;

This item has no description.

Published property Mass: Single read FMass;

This item has no description.

Published property NullCollisionVolume: Single read FNullCollisionVolume write FNullCollisionVolume stored StoredNullCollisionVolume;

This item has no description.

Public property Omega: TGLVector read GetOmega write SetOmega;

This item has no description.

Published property Torque: TGLCoordinates read FTorque write FTorque;

This item has no description.

Published property UseGravity: Boolean read FUseGravity write FUseGravity default True;

This item has no description.

Public property Velocity: TGLVector read GetVelocity write SetVelocity;

This item has no description.

Published property Volume: Single read FVolume;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDStatic

Class TGLNGDStatic

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDStatic = class(TGLNGDBehaviour)

Description

This item has no description. Showing description inherited from TGLNGDBehaviour.

Basis structures for Behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLNGDBehaviour
  • TGLNGDStatic

Overview

Methods

Public class function FriendlyName: string; override;

Description

Methods

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDSurfaceItem

Class TGLNGDSurfaceItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDSurfaceItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLNGDSurfaceItem

Overview

Fields

Private FDisplayName: string;

Properties

Published | property DisplayName;
Published | property ID;

Description

Fields

Private FDisplayName: string;

This item has no description.

Properties

Published property DisplayName;

This item has no description.

Published property ID;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDSurfacePair

Class TGLNGDSurfacePair

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDSurfacePair = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLNGDSurfacePair

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Private | class function NewtonAABBOverlap(const material: PNewtonMaterial; const body0: PNewtonBody; const body1: PNewtonBody; threadIndex: Integer): Integer; static; cdecl;
Private | function OnNewtonAABBOverlapEvent(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer): Boolean;
Public | procedure SetMaterialItems(const item1, item2: TGLNGDSurfaceItem);
Private | class procedure NewtonContactsProcess(const contact: PNewtonJoint; timestep: dFloat; threadIndex: Integer); static; cdecl;
Private | procedure OnNewtonContactsProcessEvent(const ccontact: PNewtonJoint; timestep: dFloat; threadIndex: Integer);

Properties

Published | property AABBOverlapEvent: TAABBOverlapEvent read FAABBOverlapEvent write FAABBOverlapEvent;
Published | property Collidable: Boolean read FCollidable write SetCollidable default True;
Published | property ContactProcessEvent: TContactProcessEvent read FContactProcessEvent write FContactProcessEvent;
Published | property ContinuousCollisionMode: Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;
Published | property Elasticity: Single read FElasticity write SetElasticity stored StoredElasticity;
Published | property KineticFriction: Single read FKineticFriction write SetKineticFriction stored StoredKineticFriction;
Public | property NGDSurfaceItem1: TGLNGDSurfaceItem read FSurfaceItem1;
Public | property NGDSurfaceItem2: TGLNGDSurfaceItem read FSurfaceItem2;
Published | property Softness: Single read FSoftness write SetSoftness stored StoredSoftness;
Published | property StaticFriction: Single read FStaticFriction write SetStaticFriction stored StoredStaticFriction;
Published | property Thickness: Boolean read FThickness write SetThickness default False;

Description

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Private class function NewtonAABBOverlap(const material: PNewtonMaterial; const body0: PNewtonBody; const body1: PNewtonBody; threadIndex: Integer): Integer; static; cdecl;

Callback

Private function OnNewtonAABBOverlapEvent(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer): Boolean;

Event

Public procedure SetMaterialItems(const item1, item2: TGLNGDSurfaceItem);

This item has no description.

Private class procedure NewtonContactsProcess(const contact: PNewtonJoint; timestep: dFloat; threadIndex: Integer); static; cdecl;

This item has no description.

Private procedure OnNewtonContactsProcessEvent(const ccontact: PNewtonJoint; timestep: dFloat; threadIndex: Integer);

This item has no description.

Properties

Published property AABBOverlapEvent: TAABBOverlapEvent read FAABBOverlapEvent write FAABBOverlapEvent;

This item has no description.

Published property Collidable: Boolean read FCollidable write SetCollidable default True;

This item has no description.

Published property ContactProcessEvent: TContactProcessEvent read FContactProcessEvent write FContactProcessEvent;

This item has no description.

Published property ContinuousCollisionMode: Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;

This item has no description.

Published property Elasticity: Single read FElasticity write SetElasticity stored StoredElasticity;

This item has no description.

Published property KineticFriction: Single read FKineticFriction write SetKineticFriction stored StoredKineticFriction;

This item has no description.

Public property NGDSurfaceItem1: TGLNGDSurfaceItem read FSurfaceItem1;

This item has no description.

Public property NGDSurfaceItem2: TGLNGDSurfaceItem read FSurfaceItem2;

This item has no description.

Published property Softness: Single read FSoftness write SetSoftness stored StoredSoftness;

This item has no description.

Published property StaticFriction: Single read FStaticFriction write SetStaticFriction stored StoredStaticFriction;

This item has no description.

Published property Thickness: Boolean read FThickness write SetThickness default False;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDJointPivot

Class TGLNGDJointPivot

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDJointPivot = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLNGDJointPivot

Overview

Fields

Private | FManager: TGLNGDManager;
Private | FPivotPoint: TGLCoordinates;
Private | FOuter: TGLNGDJoint;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); virtual;
Public | destructor Destroy; override;

Properties

Published property PivotPoint: TGLCoordinates read FPivotPoint write FPivotPoint;

Description

Fields

Private FManager: TGLNGDManager;

This item has no description.

Private FPivotPoint: TGLCoordinates;

This item has no description.

Private FOuter: TGLNGDJoint;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property PivotPoint: TGLCoordinates read FPivotPoint write FPivotPoint;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDJointPin

Class TGLNGDJointPin

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDJointPin = class(TGLNGDJointPivot)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLNGDJointPivot
  • TGLNGDJointPin

Overview

Fields

Private FPinDirection: TGLCoordinates;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;
Public | destructor Destroy; override;

Properties

Published property PinDirection: TGLCoordinates read FPinDirection write FPinDirection;

Description

Fields

Private FPinDirection: TGLCoordinates;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property PinDirection: TGLCoordinates read FPinDirection write FPinDirection;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDJointPin2

Class TGLNGDJointPin2

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDJointPin2 = class(TGLNGDJointPin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLNGDJointPivot
  • TGLNGDJointPin
  • TGLNGDJointPin2

Overview

Fields

Private FPinDirection2: TGLCoordinates;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;
Public | destructor Destroy; override;

Properties

Published property PinDirection2: TGLCoordinates read FPinDirection2 write FPinDirection2;

Description

Fields

Private FPinDirection2: TGLCoordinates;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property PinDirection2: TGLCoordinates read FPinDirection2 write FPinDirection2;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDJointBallAndSocket

Class TGLNGDJointBallAndSocket

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDJointBallAndSocket = class(TGLNGDJointPivot)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLNGDJointPivot
  • TGLNGDJointBallAndSocket

Overview

Fields

Private | FConeAngle: Single;
Private | FMinTwistAngle: Single;
Private | FMaxTwistAngle: Single;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;
Private | function StoredConeAngle: Boolean;
Private | function StoredMaxTwistAngle: Boolean;
Private | function StoredMinTwistAngle: Boolean;
Private | procedure SetConeAngle(const Value: Single);
Private | procedure SetMaxTwistAngle(const Value: Single);
Private | procedure SetMinTwistAngle(const Value: Single);

Properties

Published | property ConeAngle: Single read FConeAngle write SetConeAngle stored StoredConeAngle;
Published | property MaxTwistAngle: Single read FMaxTwistAngle write SetMaxTwistAngle stored StoredMaxTwistAngle;
Published | property MinTwistAngle: Single read FMinTwistAngle write SetMinTwistAngle stored StoredMinTwistAngle;

Description

Fields

Private FConeAngle: Single;

This item has no description.

Private FMinTwistAngle: Single;

90

Private FMaxTwistAngle: Single;

-90

Methods

Public constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;

This item has no description.

Private function StoredConeAngle: Boolean;

This item has no description.

Private function StoredMaxTwistAngle: Boolean;

This item has no description.

Private function StoredMinTwistAngle: Boolean;

This item has no description.

Private procedure SetConeAngle(const Value: Single);

90

Private procedure SetMaxTwistAngle(const Value: Single);

This item has no description.

Private procedure SetMinTwistAngle(const Value: Single);

This item has no description.

Properties

Published property ConeAngle: Single read FConeAngle write SetConeAngle stored StoredConeAngle;

This item has no description.

Published property MaxTwistAngle: Single read FMaxTwistAngle write SetMaxTwistAngle stored StoredMaxTwistAngle;

This item has no description.

Published property MinTwistAngle: Single read FMinTwistAngle write SetMinTwistAngle stored StoredMinTwistAngle;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDJointHinge

Class TGLNGDJointHinge

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDJointHinge = class(TGLNGDJointPin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLNGDJointPivot
  • TGLNGDJointPin
  • TGLNGDJointHinge

Overview

Fields

Private | FMinAngle: Single;
Private | FMaxAngle: Single;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;
Private | function StoredMaxAngle: Boolean;
Private | function StoredMinAngle: Boolean;
Private | procedure SetMaxAngle(const Value: Single);
Private | procedure SetMinAngle(const Value: Single);

Properties

Published | property MaxAngle: Single read FMaxAngle write SetMaxAngle stored StoredMaxAngle;
Published | property MinAngle: Single read FMinAngle write SetMinAngle stored StoredMinAngle;

Description

Fields

Private FMinAngle: Single;

This item has no description.

Private FMaxAngle: Single;

-90

Methods

Public constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;

This item has no description.

Private function StoredMaxAngle: Boolean;

This item has no description.

Private function StoredMinAngle: Boolean;

This item has no description.

Private procedure SetMaxAngle(const Value: Single);

90

Private procedure SetMinAngle(const Value: Single);

This item has no description.

Properties

Published property MaxAngle: Single read FMaxAngle write SetMaxAngle stored StoredMaxAngle;

This item has no description.

Published property MinAngle: Single read FMinAngle write SetMinAngle stored StoredMinAngle;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDJointSlider

Class TGLNGDJointSlider

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDJointSlider = class(TGLNGDJointPin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLNGDJointPivot
  • TGLNGDJointPin
  • TGLNGDJointSlider

Overview

Fields

Private | FMinDistance: Single;
Private | FMaxDistance: Single;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;
Private | function StoredMaxDistance: Boolean;
Private | function StoredMinDistance: Boolean;
Private | procedure SetMaxDistance(const Value: Single);
Private | procedure SetMinDistance(const Value: Single);

Properties

Published | property MaxDistance: Single read FMaxDistance write SetMaxDistance stored StoredMaxDistance;
Published | property MinDistance: Single read FMinDistance write SetMinDistance stored StoredMinDistance;

Description

Fields

Private FMinDistance: Single;

This item has no description.

Private FMaxDistance: Single;

-10

Methods

Public constructor Create(AOwner: TComponent; aOuter: TGLNGDJoint); override;

This item has no description.

Private function StoredMaxDistance: Boolean;

This item has no description.

Private function StoredMinDistance: Boolean;

This item has no description.

Private procedure SetMaxDistance(const Value: Single);

10

Private procedure SetMinDistance(const Value: Single);

This item has no description.

Properties

Published property MaxDistance: Single read FMaxDistance write SetMaxDistance stored StoredMaxDistance;

This item has no description.

Published property MinDistance: Single read FMinDistance write SetMinDistance stored StoredMinDistance;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDJointKinematicController

Class TGLNGDJointKinematicController

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDJointKinematicController = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLNGDJointKinematicController

Overview

Fields

Private | FPickModeLinear: Boolean;
Private | FLinearFriction: Single;
Private | FAngularFriction: Single;

Methods

Public | constructor Create();
Private | function StoredAngularFriction: Boolean;
Private | function StoredLinearFriction: Boolean;

Properties

Published | property AngularFriction: Single read FAngularFriction write FAngularFriction stored StoredAngularFriction;
Published | property LinearFriction: Single read FLinearFriction write FLinearFriction stored StoredLinearFriction;
Published | property PickModeLinear: Boolean read FPickModeLinear write FPickModeLinear default False;

Description

Fields

Private FPickModeLinear: Boolean;

This item has no description.

Private FLinearFriction: Single;

False

Private FAngularFriction: Single;

750

Methods

Public constructor Create();

This item has no description.

Private function StoredAngularFriction: Boolean;

250

Private function StoredLinearFriction: Boolean;

This item has no description.

Properties

Published property AngularFriction: Single read FAngularFriction write FAngularFriction stored StoredAngularFriction;

This item has no description.

Published property LinearFriction: Single read FLinearFriction write FLinearFriction stored StoredLinearFriction;

This item has no description.

Published property PickModeLinear: Boolean read FPickModeLinear write FPickModeLinear default False;


GLSysHelp v.2.5: GLS.NGDManager: Class TGLNGDJoint

Class TGLNGDJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDManager

Declaration

type TGLNGDJoint = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLNGDJoint

Overview

Fields

Private | FManager: TGLNGDManager;
Private | FParentObject: TGLBaseSceneObject;
Private | FJointType: TGLNGDJoints;
Private | FStiffness: Single;
Private | FChildObject: TGLBaseSceneObject;
Private | FCollisionState: Boolean;
Private | FNewtonJoint: PNewtonJoint;
Private | FNewtonUserJoint: Pointer;
Private | FUPVectorDirection: TGLCoordinates;
Private | FBallAndSocketOptions: TGLNGDJointPivot;
Private | FHingeOptions: TGLNGDJointPin;
Private | FSliderOptions: TGLNGDJointPin;
Private | FCorkscrewOptions: TGLNGDJointPin;
Private | FUniversalOptions: TGLNGDJointPin2;
Private | FCustomBallAndSocketOptions: TGLNGDJointBallAndSocket;
Private | FCustomHingeOptions: TGLNGDJointHinge;
Private | FCustomSliderOptions: TGLNGDJointSlider;
Private | FKinematicOptions: TGLNGDJointKinematicController;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | function StoredStiffness: Boolean;
Public | procedure KinematicControllerPick(pickpoint: TGLVector; PickedActions: TGLNGDPickedActions);
Private | procedure DestroyNewtonData;
Private | procedure Render;
Private | procedure SetChildObject(const Value: TGLBaseSceneObject);
Private | procedure SetCollisionState(const Value: Boolean);
Private | procedure SetJointType(const Value: TGLNGDJoints);
Private | procedure SetParentObject(const Value: TGLBaseSceneObject);
Private | procedure SetStiffness(const Value: Single);

Properties

Published | property BallAndSocketOptions: TGLNGDJointPivot read FBallAndSocketOptions write FBallAndSocketOptions;
Published | property ChildObject: TGLBaseSceneObject read FChildObject write SetChildObject;
Published | property CollisionState: Boolean read FCollisionState write SetCollisionState default False;
Published | property CorkscrewOptions: TGLNGDJointPin read FCorkscrewOptions write FCorkscrewOptions;
Published | property CustomBallAndSocketOptions: TGLNGDJointBallAndSocket read FCustomBallAndSocketOptions write FCustomBallAndSocketOptions;
Published | property CustomHingeOptions: TGLNGDJointHinge read FCustomHingeOptions write FCustomHingeOptions;
Published | property CustomSliderOptions: TGLNGDJointSlider read FCustomSliderOptions write FCustomSliderOptions;
Published | property HingeOptions: TGLNGDJointPin read FHingeOptions write FHingeOptions;
Published | property JointType: TGLNGDJoints read FJointType write SetJointType;
Published | property KinematicControllerOptions: TGLNGDJointKinematicController read FKinematicOptions write FKinematicOptions;
Published | property ParentObject: TGLBaseSceneObject read FParentObject write SetParentObject;
Published | property SliderOptions: TGLNGDJointPin read FSliderOptions write FSliderOptions;
Published | property Stiffness: Single read FStiffness write SetStiffness stored StoredStiffness;
Published | property UniversalOptions: TGLNGDJointPin2 read FUniversalOptions write FUniversalOptions;
Published | property UPVectorDirection: TGLCoordinates read FUPVectorDirection write FUPVectorDirection;

Description

Fields

Private FManager: TGLNGDManager;

Global

Private FParentObject: TGLBaseSceneObject;

This item has no description.

Private FJointType: TGLNGDJoints;

This item has no description.

Private FStiffness: Single;

This item has no description.

Private FChildObject: TGLBaseSceneObject;

0.9 With Two object Every joint except nj_UpVector and nj_KinematicController

Private FCollisionState: Boolean;

This item has no description.

Private FNewtonJoint: PNewtonJoint;

False With classic joint nj_BallAndSocket, nj_Hinge, nj_Slider, nj_Corkscrew nj_Universal, nj_UpVector

Private FNewtonUserJoint: Pointer;

With CustomJoint nj_CustomBallAndSocket, nj_CustomHinge, nj_CustomSlider nj_KinematicController

Private FUPVectorDirection: TGLCoordinates;

nj_UpVector

Private FBallAndSocketOptions: TGLNGDJointPivot;

This item has no description.

Private FHingeOptions: TGLNGDJointPin;

This item has no description.

Private FSliderOptions: TGLNGDJointPin;

This item has no description.

Private FCorkscrewOptions: TGLNGDJointPin;

This item has no description.

Private FUniversalOptions: TGLNGDJointPin2;

This item has no description.

Private FCustomBallAndSocketOptions: TGLNGDJointBallAndSocket;

This item has no description.

Private FCustomHingeOptions: TGLNGDJointHinge;

This item has no description.

Private FCustomSliderOptions: TGLNGDJointSlider;

This item has no description.

Private FKinematicOptions: TGLNGDJointKinematicController;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function StoredStiffness: Boolean;

This item has no description.

Public procedure KinematicControllerPick(pickpoint: TGLVector; PickedActions: TGLNGDPickedActions);

This item has no description.

Private procedure DestroyNewtonData;

This item has no description.

Private procedure Render;

This item has no description.

Private procedure SetChildObject(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetCollisionState(const Value: Boolean);

This item has no description.

Private procedure SetJointType(const Value: TGLNGDJoints);

This item has no description.

Private procedure SetParentObject(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetStiffness(const Value: Single);

This item has no description.

Properties

Published property BallAndSocketOptions: TGLNGDJointPivot read FBallAndSocketOptions write FBallAndSocketOptions;

This item has no description.

Published property ChildObject: TGLBaseSceneObject read FChildObject write SetChildObject;

This item has no description.

Published property CollisionState: Boolean read FCollisionState write SetCollisionState default False;

This item has no description.

Published property CorkscrewOptions: TGLNGDJointPin read FCorkscrewOptions write FCorkscrewOptions;

This item has no description.

Published property CustomBallAndSocketOptions: TGLNGDJointBallAndSocket read FCustomBallAndSocketOptions write FCustomBallAndSocketOptions;

This item has no description.

Published property CustomHingeOptions: TGLNGDJointHinge read FCustomHingeOptions write FCustomHingeOptions;

This item has no description.

Published property CustomSliderOptions: TGLNGDJointSlider read FCustomSliderOptions write FCustomSliderOptions;

This item has no description.

Published property HingeOptions: TGLNGDJointPin read FHingeOptions write FHingeOptions;

This item has no description.

Published property JointType: TGLNGDJoints read FJointType write SetJointType;

This item has no description.

Published property KinematicControllerOptions: TGLNGDJointKinematicController read FKinematicOptions write FKinematicOptions;

This item has no description.

Published property ParentObject: TGLBaseSceneObject read FParentObject write SetParentObject;

This item has no description.

Published property SliderOptions: TGLNGDJointPin read FSliderOptions write FSliderOptions;

This item has no description.

Published property Stiffness: Single read FStiffness write SetStiffness stored StoredStiffness;

This item has no description.

Published property UniversalOptions: TGLNGDJointPin2 read FUniversalOptions write FUniversalOptions;

This item has no description.

Published property UPVectorDirection: TGLCoordinates read FUPVectorDirection write FUPVectorDirection;


GLSysHelp v.2.5: GLS.NGDRagdoll

Unit GLS.NGDRagdoll

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.VectorFileObjects
  • NGD.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TNewtonRagdoll |

Functions and Procedures

function GetBoneParent(Actor: TGLActor; bone: integer): integer;

Description

Functions and Procedures

function GetBoneParent(Actor: TGLActor; bone: integer): integer;


GLSysHelp v.2.5: GLS.NGDRagdoll: Class TNewtonRagdoll

Class TNewtonRagdoll

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.NGDRagdoll

Declaration

type TNewtonRagdoll = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TNewtonRagdoll

Overview

Fields

Private | FERP: single;
Private | FSlideLimit: single;
Private | FAngleLimit: single;
Private | FEnabled: boolean;
Private | newtonworld: PNewtonWorld;
Public | Actor: TGLActor;
Public | Bodies: TList;
Public | Joints: array of PNewtonJoint;
Public | Norm_matrices: array of TGLMatrix;
Public | Envelopes: array of record kind: byte; Mat: TGLMatrix; Pt: TVector3f; W, D, H, Mass: single; end;

Methods

Public | constructor Create(model: TGLActor; world: PNewtonWorld; min_env_size: single = 0.8; slide_limit: single = 0.5; erp_: single = 0.8; angle_limit: single = 15; full: boolean = true);
Public | destructor Destroy; override;
Public | function TranslatePos(n: integer; add: boolean): TGLVector;
Public | procedure Conform;
Public | procedure LoadFromFile(filename: string);
Public | procedure SaveToFile(filename: string);
Private | procedure Clean;
Private | procedure SetAngleLimit(value: single);
Private | procedure SetEnabled(value: boolean);
Private | procedure SetERP(value: single);
Private | procedure SetSlideLimit(value: single);

Properties

Public | property AngleLimit: single read FAngleLimit write SetAngleLimit;
Public | property Enabled: boolean read FEnabled write SetEnabled;
Public | property ERP: single read FERP write SetERP;
Public | property SlideLimit: single read FSlideLimit write SetSlideLimit;

Description

Fields

Private FERP: single;

This item has no description.

Private FSlideLimit: single;

This item has no description.

Private FAngleLimit: single;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private newtonworld: PNewtonWorld;

This item has no description.

Public Actor: TGLActor;

This item has no description.

Public Bodies: TList;

This item has no description.

Public Joints: array of PNewtonJoint;

This item has no description.

Public Norm_matrices: array of TGLMatrix;

This item has no description.

Public Envelopes: array of record kind: byte; Mat: TGLMatrix; Pt: TVector3f; W, D, H, Mass: single; end;

This item has no description.

Methods

Public constructor Create(model: TGLActor; world: PNewtonWorld; min_env_size: single = 0.8; slide_limit: single = 0.5; erp_: single = 0.8; angle_limit: single = 15; full: boolean = true);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TranslatePos(n: integer; add: boolean): TGLVector;

This item has no description.

Public procedure Conform;

This item has no description.

Public procedure LoadFromFile(filename: string);

This item has no description.

Public procedure SaveToFile(filename: string);

This item has no description.

Private procedure Clean;

This item has no description.

Private procedure SetAngleLimit(value: single);

This item has no description.

Private procedure SetEnabled(value: boolean);

This item has no description.

Private procedure SetERP(value: single);

This item has no description.

Private procedure SetSlideLimit(value: single);

This item has no description.

Properties

Public property AngleLimit: single read FAngleLimit write SetAngleLimit;

This item has no description.

Public property Enabled: boolean read FEnabled write SetEnabled;

This item has no description.

Public property ERP: single read FERP write SetERP;

This item has no description.

Public property SlideLimit: single read FSlideLimit write SetSlideLimit;


GLSysHelp v.2.5: GLS.Nodes

Unit GLS.Nodes

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.OpenGLAdapter
  • GLS.Context
  • GLS.BaseClasses
  • GLScene.Spline
  • GLS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNode |
Class TGLNodes |

Types

TGLNodesClass = class of TGLNodes;

Description

Types

TGLNodesClass = class of TGLNodes;


GLSysHelp v.2.5: GLS.Nodes: Class TGLNode

Class TGLNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Nodes

Declaration

type TGLNode = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLNode

Overview

Fields

Private | FCoords: TGLVector;
Private | FTagObject: TObject;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function AsAddress: PGLFloat;
Private | function GetAsAffineVector: TAffineVector;
Private | function GetCoordinate(const Index: Integer): TGLFloat;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetAsAffineVector(const Value: TAffineVector);
Private | procedure SetAsVector(const Value: TGLVector);
Private | procedure SetCoordinate(AIndex: Integer; AValue: TGLFloat);

Properties

Public | property AsAffineVector: TAffineVector read GetAsAffineVector write SetAsAffineVector;
Public | property AsVector: TGLVector read FCoords write SetAsVector;
Public | property TagObject: TObject read FTagObject write FTagObject;
Public | property W: TGLFloat index 3 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property X: TGLFloat index 0 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property Y: TGLFloat index 1 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property Z: TGLFloat index 2 read GetCoordinate write SetCoordinate stored StoreCoordinate;

Description

Fields

Private FCoords: TGLVector;

This item has no description.

Private FTagObject: TObject;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AsAddress: PGLFloat;

This item has no description.

Private function GetAsAffineVector: TAffineVector;

This item has no description.

Private function GetCoordinate(const Index: Integer): TGLFloat;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetAsAffineVector(const Value: TAffineVector);

This item has no description.

Private procedure SetAsVector(const Value: TGLVector);

This item has no description.

Private procedure SetCoordinate(AIndex: Integer; AValue: TGLFloat);

This item has no description.

Properties

Public property AsAffineVector: TAffineVector read GetAsAffineVector write SetAsAffineVector;

The coordinates viewed as an affine vector. Assigning a value to this property will trigger notification events, if you don't want so, use DirectVector instead. The W component is automatically adjustes depending on style.

Public property AsVector: TGLVector read FCoords write SetAsVector;

The coordinates viewed as a vector. Assigning a value to this property will trigger notification events, if you don't want so, use DirectVector instead.

Public property TagObject: TObject read FTagObject write FTagObject;

This item has no description.

Public property W: TGLFloat index 3 read GetCoordinate write SetCoordinate stored StoreCoordinate;

This item has no description.

Published property X: TGLFloat index 0 read GetCoordinate write SetCoordinate stored StoreCoordinate;

This item has no description.

Published property Y: TGLFloat index 1 read GetCoordinate write SetCoordinate stored StoreCoordinate;

This item has no description.

Published property Z: TGLFloat index 2 read GetCoordinate write SetCoordinate stored StoreCoordinate;


GLSysHelp v.2.5: GLS.Nodes: Class TGLNodes

Class TGLNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Nodes

Declaration

type TGLNodes = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLNodes

Overview

Methods

Public | constructor Create(AOwner: TPersistent; AItemClass: TCollectionItemClass = nil);
Public | function Add: TGLNode;
Public | function Barycenter: TAffineVector;
Public | function CreateCopy(AOwner: TPersistent): TGLNodes;
Public | function CreateNewCubicSpline: TCubicSpline;
Public | function FindItemID(ID: Integer): TGLNode;
Public | function First: TGLNode;
Public | function Last: TGLNode;
Public | function Normal: TAffineVector;
Public | function Vector(I: Integer): TAffineVector;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure AddNode(const Coords: TGLCustomCoordinates); overload;
Public | procedure AddNode(const X, Y, Z: TGLfloat); overload;
Public | procedure AddNode(const Value: TGLVector); overload;
Public | procedure AddXYArc(XRadius, YRadius: Single; StartAngle, StopAngle: Single; NbSegments: Integer; const Center: TAffineVector);
Public | procedure EndUpdate; override;
Public | procedure GetExtents(var Min, Max: TAffineVector);
Public | procedure NotifyChange; virtual;
Public | procedure RenderTesselatedPolygon(ATextured: Boolean; ANormal: PAffineVector = nil; ASplineDivisions: Integer = 1; AInvertNormals: Boolean = False);
Public | procedure RotateAroundX(Angle: Single);
Public | procedure RotateAroundY(Angle: Single);
Public | procedure RotateAroundZ(Angle: Single);
Public | procedure Scale(const Fv: TAffineVector); overload;
Public | procedure Scale(F: Single); overload;
Public | procedure Translate(const Tv: TAffineVector);

Properties

Public property Items[index: Integer]: TGLNode read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent; AItemClass: TCollectionItemClass = nil);

This item has no description.

Public function Add: TGLNode;

This item has no description.

Public function Barycenter: TAffineVector;

Calculates and returns the barycenter of the nodes

Public function CreateCopy(AOwner: TPersistent): TGLNodes;

This item has no description.

Public function CreateNewCubicSpline: TCubicSpline;

This item has no description.

Public function FindItemID(ID: Integer): TGLNode;

This item has no description.

Public function First: TGLNode;

This item has no description.

Public function Last: TGLNode;

This item has no description.

Public function Normal: TAffineVector;

Computes normal based on the 1st three nodes. Returns NullVector if there are less than 3 nodes.

Public function Vector(I: Integer): TAffineVector;

Returns normalized vector Nodes[i+1]-Nodes[i]

Public procedure AddNode(const Value: TAffineVector); overload;

This item has no description.

Public procedure AddNode(const Coords: TGLCustomCoordinates); overload;

AddNode (TGLCustomCoordinates)

Public procedure AddNode(const X, Y, Z: TGLfloat); overload;

This item has no description.

Public procedure AddNode(const Value: TGLVector); overload;

This item has no description.

Public procedure AddXYArc(XRadius, YRadius: Single; StartAngle, StopAngle: Single; NbSegments: Integer; const Center: TAffineVector);

This item has no description.

Public procedure EndUpdate; override;

This item has no description.

Public procedure GetExtents(var Min, Max: TAffineVector);

Calculates the extents of the nodes (min-max for all coordinates). The returned values are also the two corners of the axis-aligned bounding box.

Public procedure NotifyChange; virtual;

This item has no description.

Public procedure RenderTesselatedPolygon(ATextured: Boolean; ANormal: PAffineVector = nil; ASplineDivisions: Integer = 1; AInvertNormals: Boolean = False);

This item has no description.

Public procedure RotateAroundX(Angle: Single);

Rotate nodes around Y axis by the given angle (degrees)

Public procedure RotateAroundY(Angle: Single);

Rotate nodes around Y axis by the given angle (degrees)

Public procedure RotateAroundZ(Angle: Single);

Rotate nodes around Y axis by the given angle (degrees)

Public procedure Scale(const Fv: TAffineVector); overload;

Scale all node coordinates

Public procedure Scale(F: Single); overload;

Scale all node coordinates

Public procedure Translate(const Tv: TAffineVector);

Translate all nodes

Properties

Public property Items[index: Integer]: TGLNode read GetItems write SetItems;


GLSysHelp v.2.5: GLS.ObjectManager

Unit GLS.ObjectManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • VCL.Graphics
  • VCL.Controls
  • VCL.Menus
  • GLS.Scene
  • GLS.ImageUtils
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLSceneObjectEntry |
Class TGLObjectManager |

Types

PSceneObjectEntry = ˆTGLSceneObjectEntry;

Description

Types

PSceneObjectEntry = ˆTGLSceneObjectEntry;


GLSysHelp v.2.5: GLS.ObjectManager: Record TGLSceneObjectEntry

Record TGLSceneObjectEntry

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ObjectManager

Declaration

type TGLSceneObjectEntry = record

Description

holds a relation between an scene object class, its global identification, its location in the object stock and its icon reference

Overview

Fields

Public | ObjectClass: TGLSceneObjectClass;
Public | Name: string;
Public | Category: string;
Public | Index: Integer;
Public | ImageIndex: Integer;

Description

Fields

Public ObjectClass: TGLSceneObjectClass;

This item has no description.

Public Name: string;

This item has no description.

Public Category: string;

type name of the object

Public Index: Integer;

category of object

Public ImageIndex: Integer;

index into "FSceneObjectList"


GLSysHelp v.2.5: GLS.ObjectManager: Class TGLObjectManager

Class TGLObjectManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ObjectManager

Declaration

type TGLObjectManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLObjectManager

Overview

Fields

Private | FSceneObjectList: TList;
Private | FObjectIcons: TImageList;
Private | FOverlayIndex: Integer;
Private | FSceneRootIndex: Integer;
Private | FCameraRootIndex: Integer;
Private | FLightsourceRootIndex: Integer;
Private | FObjectRootIndex: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetCategory(ASceneObject: TGLSceneObjectClass): string;
Public | function GetClassFromIndex(Index: Integer): TGLSceneObjectClass;
Public | function GetImageIndex(ASceneObject: TGLSceneObjectClass): Integer;
Public | procedure CreateDefaultObjectIcons(ResourceModule: Cardinal);
Public | procedure GetRegisteredSceneObjects(ObjectList: TStringList);
Public | procedure PopulateMenuWithRegisteredSceneObjects(AMenuItem: TMenuItem; aClickEvent: TNotifyEvent);
Public | procedure RegisterSceneObject(ASceneObject: TGLSceneObjectClass; const aName, aCategory: string; ResourceModule: Cardinal; ResourceName: string = ''); overload;
Public | procedure RegisterSceneObject(ASceneObject: TGLSceneObjectClass; const aName, aCategory: string; aBitmap: TBitmap); overload;
Public | procedure RegisterSceneObject(ASceneObject: TGLSceneObjectClass; const aName, aCategory: string); overload;
Public | procedure UnRegisterSceneObject(ASceneObject: TGLSceneObjectClass);

Properties

Public | property CameraRootIndex: Integer read FCameraRootIndex;
Public | property LightsourceRootIndex: Integer read FLightsourceRootIndex;
Public | property ObjectIcons: TImageList read FObjectIcons;
Public | property ObjectRootIndex: Integer read FObjectRootIndex;
Public | property SceneRootIndex: Integer read FSceneRootIndex;

Description

Fields

Private FSceneObjectList: TList;

This item has no description.

Private FObjectIcons: TImageList;

This item has no description.

Private FOverlayIndex: Integer;

a list of icons for scene objects

Private FSceneRootIndex: Integer;

indices into the object icon list

Private FCameraRootIndex: Integer;

indices into the object icon list

Private FLightsourceRootIndex: Integer;

indices into the object icon list

Private FObjectRootIndex: Integer;

indices into the object icon list

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetCategory(ASceneObject: TGLSceneObjectClass): string;

This item has no description.

Public function GetClassFromIndex(Index: Integer): TGLSceneObjectClass;

This item has no description.

Public function GetImageIndex(ASceneObject: TGLSceneObjectClass): Integer;

This item has no description.

Public procedure CreateDefaultObjectIcons(ResourceModule: Cardinal);

This item has no description.

Public procedure GetRegisteredSceneObjects(ObjectList: TStringList);

This item has no description.

Public procedure PopulateMenuWithRegisteredSceneObjects(AMenuItem: TMenuItem; aClickEvent: TNotifyEvent);

This item has no description.

Public procedure RegisterSceneObject(ASceneObject: TGLSceneObjectClass; const aName, aCategory: string; ResourceModule: Cardinal; ResourceName: string = ''); overload;

This item has no description.

Public procedure RegisterSceneObject(ASceneObject: TGLSceneObjectClass; const aName, aCategory: string; aBitmap: TBitmap); overload;

This item has no description.

Public procedure RegisterSceneObject(ASceneObject: TGLSceneObjectClass; const aName, aCategory: string); overload;

Registers a stock object and adds it to the stock object list

Public procedure UnRegisterSceneObject(ASceneObject: TGLSceneObjectClass);

Unregisters a stock object and removes it from the stock object list

Properties

Public property CameraRootIndex: Integer read FCameraRootIndex;

This item has no description.

Public property LightsourceRootIndex: Integer read FLightsourceRootIndex;

This item has no description.

Public property ObjectIcons: TImageList read FObjectIcons;

This item has no description.

Public property ObjectRootIndex: Integer read FObjectRootIndex;

This item has no description.

Public property SceneRootIndex: Integer read FSceneRootIndex;


GLSysHelp v.2.5: GLS.Objects

Unit GLS.Objects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Types
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLS.OpenGLAdapter
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.PersistentClasses
  • GLS.BaseClasses
  • GLS.Coordinates
  • GLScene.Spline
  • GLS.VectorLists
  • GLScene.PipelineTransform
  • GLS.Scene
  • GLS.Context
  • GLS.Silhouette
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.Nodes
  • GLS.XOpenGL
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLVertexRec |
Class TGLDummyCube |
Class TGLPlane |
Class TGLSprite |
Class TGLPointParameters |
Class TGLPoints |
Class TGLLinesNode |
Class TGLLinesNodes |
Class TGLLineBase |
Class TGLNodedLines |
Class TGLLines |
Class TGLCube |
Class TGLQuadricObject |
Class TGLSphere |
Class TGLPolygonBase |
Class TGLSuperellipsoid |

Functions and Procedures

procedure CubeWireframeBuildList(var rci: TGLRenderContextInfo; Size: TGLFloat; Stipple: Boolean; const Color: TGLColorVector);

Types

PGLVertexRec = ˆTGLVertexRec;
TGLAngleLimit180 = -90 .. 90;
TGLAngleLimit360 = 0 .. 360;
TGLCapType = (...);
TGLCubePart = (...);
TGLCubeParts = set of TGLCubePart;
TGLLineNodesAspect = (...);
TGLLinesOption = (...);
TGLLinesOptions = set of TGLLinesOption;
TGLLineSplineMode = (...);
TGLNormalSmoothing = (...);
TGLPlaneStyle = (...);
TGLPlaneStyles = set of TGLPlaneStyle;
TGLPointStyle = (...);
TGLVisibilityDeterminationEvent = function(Sender: TObject; var rci: TGLRenderContextInfo): Boolean of object;

Constants

cDefaultPointSize: Single = 1.0;
TangentAttributeName: PAnsiChar = 'Tangent';
BinormalAttributeName: PAnsiChar = 'Binormal';

Description

Functions and Procedures

procedure CubeWireframeBuildList(var rci: TGLRenderContextInfo; Size: TGLFloat; Stipple: Boolean; const Color: TGLColorVector);

Issues for a unit-size cube stippled wireframe

Types

PGLVertexRec = ˆTGLVertexRec;

This item has no description.

TGLAngleLimit180 = -90 .. 90;

This item has no description.

TGLAngleLimit360 = 0 .. 360;

This item has no description.

TGLCapType = (...);

This item has no description.

Values
  • ctNone
  • ctCenter
  • ctFlat
TGLCubePart = (...);

This item has no description.

Values
  • cpTop
  • cpBottom
  • cpFront
  • cpBack
  • cpLeft
  • cpRight
TGLCubeParts = set of TGLCubePart;

This item has no description.

TGLLineNodesAspect = (...);

Possible aspects for the nodes of a TLine.

Values
  • lnaInvisible
  • lnaAxes
  • lnaCube
TGLLinesOption = (...);

This item has no description.

Values
  • loUseNodeColorForLines
  • loColorLogicXor
TGLLinesOptions = set of TGLLinesOption;

This item has no description.

TGLLineSplineMode = (...);

Available spline modes for a TLine.

Values
  • lsmLines
  • lsmCubicSpline
  • lsmBezierSpline
  • lsmNURBSCurve
  • lsmSegments
  • lsmLoop
TGLNormalSmoothing = (...);

Determines how and if normals are smoothed. - nsFlat : facetted look - nsSmooth : smooth look - nsNone : unlighted rendering, usefull for decla texturing

Values
  • nsFlat
  • nsSmooth
  • nsNone
TGLPlaneStyle = (...);

This item has no description.

Values
  • psSingleQuad
  • psTileTexture
TGLPlaneStyles = set of TGLPlaneStyle;

This item has no description.

TGLPointStyle = (...);

This item has no description.

Values
  • psSquare
  • psRound
  • psSmooth
  • psSmoothAdditive
  • psSquareAdditive
TGLVisibilityDeterminationEvent = function(Sender: TObject; var rci: TGLRenderContextInfo): Boolean of object;

This item has no description.

Constants

cDefaultPointSize: Single = 1.0;

This item has no description.

TangentAttributeName: PAnsiChar = 'Tangent';

This item has no description.

BinormalAttributeName: PAnsiChar = 'Binormal';


GLSysHelp v.2.5: GLS.Objects: Record TGLVertexRec

Record TGLVertexRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLVertexRec = record

Description

This item has no description.

Overview

Fields

Public | Position: TVector3f;
Public | Normal: TVector3f;
Public | Binormal: TVector3f;
Public | Tangent: TVector3f;
Public | TexCoord: TVector2f;

Description

Fields

Public Position: TVector3f;

This item has no description.

Public Normal: TVector3f;

This item has no description.

Public Binormal: TVector3f;

This item has no description.

Public Tangent: TVector3f;

This item has no description.

Public TexCoord: TVector2f;


GLSysHelp v.2.5: GLS.Objects: Class TGLDummyCube

Class TGLDummyCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLDummyCube = class(TGLCameraInvariantObject)

Description

A simple cube, invisible at run-time. This is a usually non-visible object -except at design-time- used for building hierarchies or groups, when some kind of joint or movement mechanism needs be described, you can use DummyCubes. DummyCube's barycenter is its children's barycenter. The DummyCube can optionnally amalgamate all its children into a single display list (see Amalgamate property).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject
  • TGLDummyCube

Overview

Fields

Private | FCubeSize: TGLFloat;
Private | FEdgeColor: TGLColor;
Private | FVisibleAtRunTime: Boolean;
Private | FAmalgamate: Boolean;
Private | FGroupList: TGLListHandle;
Private | FOnVisibilityDetermination: TGLVisibilityDeterminationEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function BarycenterAbsolutePosition: TGLVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure StructureChanged; override;

Properties

Published | property Amalgamate: Boolean read FAmalgamate write SetAmalgamate default False;
Published | property CamInvarianceMode default cimNone;
Published | property CubeSize: TGLFloat read FCubeSize write SetCubeSize;
Published | property EdgeColor: TGLColor read FEdgeColor write SetEdgeColor;
Published | property OnVisibilityDetermination: TGLVisibilityDeterminationEvent read FOnVisibilityDetermination write FOnVisibilityDetermination;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

Description

Fields

Private FCubeSize: TGLFloat;

This item has no description.

Private FEdgeColor: TGLColor;

This item has no description.

Private FVisibleAtRunTime: Boolean;

This item has no description.

Private FAmalgamate: Boolean;

This item has no description.

Private FGroupList: TGLListHandle;

This item has no description.

Private FOnVisibilityDetermination: TGLVisibilityDeterminationEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function BarycenterAbsolutePosition: TGLVector; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Amalgamate: Boolean read FAmalgamate write SetAmalgamate default False;

Amalgamate the dummy's children in a single OpenGL entity. This activates a special rendering mode, which will compile the rendering of all of the dummycube's children objects into a single display list. This may provide a significant speed up in some situations, however, this means that changes to the children will be ignored until you call StructureChanged on the dummy cube. Some objects, that have their own display list management, may not be compatible with this behaviour. This will also prevents sorting and culling to operate as usual. In short, this features is best used for static, non-transparent geometry, or when the point of view won't change over a large number of frames.

Published property CamInvarianceMode default cimNone;

Camera Invariance Options. These options allow to "deactivate" sensitivity to camera, f.i. by centering the object on the camera or ignoring camera orientation.

Published property CubeSize: TGLFloat read FCubeSize write SetCubeSize;

This item has no description.

Published property EdgeColor: TGLColor read FEdgeColor write SetEdgeColor;

This item has no description.

Published property OnVisibilityDetermination: TGLVisibilityDeterminationEvent read FOnVisibilityDetermination write FOnVisibilityDetermination;

Event for custom visibility determination. Event handler should return True if the dummycube and its children are to be considered visible for the current render.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

If true the dummycube's edges will be visible at runtime. The default behaviour of the dummycube is to be visible at design-time only, and invisible at runtime.


GLSysHelp v.2.5: GLS.Objects: Class TGLPlane

Class TGLPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLPlane = class(TGLSceneObject)

Description

A simple plane object. Note that a plane is always made of a single quad (two triangles) and the tiling is only applied to texture coordinates.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPlane

Overview

Fields

Private | FXOffset: TGLFloat;
Private | FYOffset: TGLFloat;
Private | FXScope: TGLFloat;
Private | FYScope: TGLFloat;
Private | FWidth: TGLFloat;
Private | FHeight: TGLFloat;
Private | FXTiles: Cardinal;
Private | FYTiles: Cardinal;
Private | FStyle: TGLPlaneStyles;
Private | FMesh: array of array of TGLVertexRec;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public | function PointDistance(const aPoint: TGLVector): Single;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | function ScreenRect(aBuffer: TGLSceneBuffer): TRect;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property Style: TGLPlaneStyles read FStyle write SetStyle default [psSingleQuad, psTileTexture];
Published | property Width: TGLFloat read FWidth write SetWidth;
Published | property XOffset: TGLFloat read FXOffset write SetXOffset;
Published | property XScope: TGLFloat read FXScope write SetXScope stored StoreXScope;
Published | property XTiles: Cardinal read FXTiles write SetXTiles default 1;
Published | property YOffset: TGLFloat read FYOffset write SetYOffset;
Published | property YScope: TGLFloat read FYScope write SetYScope stored StoreYScope;
Published | property YTiles: Cardinal read FYTiles write SetYTiles default 1;

Description

Fields

Private FXOffset: TGLFloat;

This item has no description.

Private FYOffset: TGLFloat;

This item has no description.

Private FXScope: TGLFloat;

This item has no description.

Private FYScope: TGLFloat;

This item has no description.

Private FWidth: TGLFloat;

This item has no description.

Private FHeight: TGLFloat;

This item has no description.

Private FXTiles: Cardinal;

This item has no description.

Private FYTiles: Cardinal;

This item has no description.

Private FStyle: TGLPlaneStyles;

This item has no description.

Private FMesh: array of array of TGLVertexRec;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function PointDistance(const aPoint: TGLVector): Single;

Computes the signed distance to the point. Point coordinates are expected in absolute coordinates.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public function ScreenRect(aBuffer: TGLSceneBuffer): TRect;

Computes the screen coordinates of the smallest rectangle encompassing the plane. Returned extents are NOT limited to any physical screen extents.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Height: TGLFloat read FHeight write SetHeight;

This item has no description.

Published property Style: TGLPlaneStyles read FStyle write SetStyle default [psSingleQuad, psTileTexture];

This item has no description.

Published property Width: TGLFloat read FWidth write SetWidth;

This item has no description.

Published property XOffset: TGLFloat read FXOffset write SetXOffset;

This item has no description.

Published property XScope: TGLFloat read FXScope write SetXScope stored StoreXScope;

This item has no description.

Published property XTiles: Cardinal read FXTiles write SetXTiles default 1;

This item has no description.

Published property YOffset: TGLFloat read FYOffset write SetYOffset;

This item has no description.

Published property YScope: TGLFloat read FYScope write SetYScope stored StoreYScope;

This item has no description.

Published property YTiles: Cardinal read FYTiles write SetYTiles default 1;


GLSysHelp v.2.5: GLS.Objects: Class TGLSprite

Class TGLSprite

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLSprite = class(TGLSceneObject)

Description

A rectangular area, perspective projected, but always facing the camera. A TGLSprite is perspective projected and as such is scaled with distance, if you want a 2D sprite that does not get scaled, see TGLHUDSprite.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSprite

Overview

Fields

Private | FWidth: TGLFloat;
Private | FHeight: TGLFloat;
Private | FRotation: TGLFloat;
Private | FAlphaChannel: Single;
Private | FMirrorU: Boolean;
Private | FMirrorV: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure SetSize(const Width, Height: TGLFloat);
Public | procedure SetSquareSize(const Size: TGLFloat);

Properties

Published | property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;
Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property MirrorU: Boolean read FMirrorU write SetMirrorU default False;
Published | property MirrorV: Boolean read FMirrorV write SetMirrorV default False;
Published | property Rotation: TGLFloat read FRotation write SetRotation;
Published | property Width: TGLFloat read FWidth write SetWidth;

Description

Fields

Private FWidth: TGLFloat;

This item has no description.

Private FHeight: TGLFloat;

This item has no description.

Private FRotation: TGLFloat;

This item has no description.

Private FAlphaChannel: Single;

This item has no description.

Private FMirrorU: Boolean;

This item has no description.

Private FMirrorV: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure SetSize(const Width, Height: TGLFloat);

This item has no description.

Public procedure SetSquareSize(const Size: TGLFloat);

Set width and height to "size"

Properties

Published property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;

If different from 1, this value will replace that of Diffuse.Alpha

Published property Height: TGLFloat read FHeight write SetHeight;

Sprite Height in 3D world units.

Published property MirrorU: Boolean read FMirrorU write SetMirrorU default False;

Reverses the texture coordinates in the U and V direction to mirror the texture.

Published property MirrorV: Boolean read FMirrorV write SetMirrorV default False;

This item has no description.

Published property Rotation: TGLFloat read FRotation write SetRotation;

This the ON-SCREEN rotation of the sprite. Rotatation=0 is handled faster.

Published property Width: TGLFloat read FWidth write SetWidth;

Sprite Width in 3D world units.


GLSysHelp v.2.5: GLS.Objects: Class TGLPointParameters

Class TGLPointParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLPointParameters = class(TGLUpdateAbleObject)

Description

Point parameters as in ARB_point_parameters. Make sure to read the ARB_point_parameters spec if you want to understand what each parameter does.

Hierarchy

  • TGLUpdateAbleObject
  • TGLPointParameters

Overview

Fields

Private | FEnabled: Boolean;
Private | FMinSize: Single;
Private | FMaxSize: Single;
Private | FFadeTresholdSize: Single;
Private | FDistanceAttenuation: TGLCoordinates;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure UnApply;

Properties

Published | property DistanceAttenuation: TGLCoordinates read FDistanceAttenuation write SetDistanceAttenuation;
Published | property Enabled: Boolean read FEnabled write SetEnabled default False;
Published | property FadeTresholdSize: Single read FFadeTresholdSize write SetFadeTresholdSize stored False;
Published | property MaxSize: Single read FMaxSize write SetMaxSize stored False;
Published | property MinSize: Single read FMinSize write SetMinSize stored False;

Description

Fields

Private FEnabled: Boolean;

This item has no description.

Private FMinSize: Single;

This item has no description.

Private FMaxSize: Single;

This item has no description.

Private FFadeTresholdSize: Single;

This item has no description.

Private FDistanceAttenuation: TGLCoordinates;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure UnApply;

This item has no description.

Properties

Published property DistanceAttenuation: TGLCoordinates read FDistanceAttenuation write SetDistanceAttenuation;

Components XYZ are for constant, linear and quadratic attenuation.

Published property Enabled: Boolean read FEnabled write SetEnabled default False;

This item has no description.

Published property FadeTresholdSize: Single read FFadeTresholdSize write SetFadeTresholdSize stored False;

This item has no description.

Published property MaxSize: Single read FMaxSize write SetMaxSize stored False;

This item has no description.

Published property MinSize: Single read FMinSize write SetMinSize stored False;


GLSysHelp v.2.5: GLS.Objects: Class TGLPoints

Class TGLPoints

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLPoints = class(TGLImmaterialSceneObject)

Description

Renders a set of non-transparent colored points. The points positions and their color are defined through the Positions and Colors properties

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLPoints

Overview

Fields

Private | FPositions: TGLAffineVectorList;
Private | FColors: TGLVectorList;
Private | FSize: Single;
Private | FStyle: TGLPointStyle;
Private | FPointParameters: TGLPointParameters;
Private | FStatic: Boolean;
Private | FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Public | property Colors: TGLVectorList read FColors write SetColors;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Published | property PointParameters: TGLPointParameters read FPointParameters write SetPointParameters;
Public | property Positions: TGLAffineVectorList read FPositions write SetPositions;
Published | property Size: Single read FSize write SetSize stored StoreSize;
Published | property Static: Boolean read FStatic write SetStatic;
Published | property Style: TGLPointStyle read FStyle write SetStyle default psSquare;

Description

Fields

Private FPositions: TGLAffineVectorList;

This item has no description.

Private FColors: TGLVectorList;

This item has no description.

Private FSize: Single;

This item has no description.

Private FStyle: TGLPointStyle;

This item has no description.

Private FPointParameters: TGLPointParameters;

This item has no description.

Private FStatic: Boolean;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property Colors: TGLVectorList read FColors write SetColors;

Defines the points colors: if empty, point color will be opaque white if contains a single color, all points will use that color if contains N colors, the first N points (at max) will be rendered using the corresponding colors

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;

If true points do not write their Z to the depth buffer.

Published property PointParameters: TGLPointParameters read FPointParameters write SetPointParameters;

Point parameters as of ARB_point_parameters. Allows to vary the size and transparency of points depending on their distance to the observer.

Public property Positions: TGLAffineVectorList read FPositions write SetPositions;

Points positions. If empty, a single point is assumed at (0, 0, 0)

Published property Size: Single read FSize write SetSize stored StoreSize;

Point size, all points have a fixed size.

Published property Static: Boolean read FStatic write SetStatic;

Tells the component if point coordinates are static. If static, changes to the positions should be notified via an explicit StructureChanged call, or may not refresh. Static sets of points may render faster than dynamic ones.

Published property Style: TGLPointStyle read FStyle write SetStyle default psSquare;

Points style.


GLSysHelp v.2.5: GLS.Objects: Class TGLLinesNode

Class TGLLinesNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLLinesNode = class(TGLNode)

Description

Specialized Node for use in a TGLLines objects. Adds a Color property (TGLColor) }

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLNode
  • TGLLinesNode

Overview

Fields

Private FColor: TGLColor;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property Color: TGLColor read FColor write SetColor stored StoreColor;

Description

Fields

Private FColor: TGLColor;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Color: TGLColor read FColor write SetColor stored StoreColor;

The node color. Can also defined the line color (interpolated between nodes) if loUseNodeColorForLines is set (in TGLLines).


GLSysHelp v.2.5: GLS.Objects: Class TGLLinesNodes

Class TGLLinesNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLLinesNodes = class(TGLNodes)

Description

Specialized collection for Nodes in a TGLLines objects. Stores TGLLinesNode items

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLNodes
  • TGLLinesNodes

Overview

Methods

Public | constructor Create(AOwner: TComponent); overload;
Public | procedure NotifyChange; override;

Description

Methods

Public constructor Create(AOwner: TComponent); overload;

This item has no description.

Public procedure NotifyChange; override;


GLSysHelp v.2.5: GLS.Objects: Class TGLLineBase

Class TGLLineBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLLineBase = class(TGLImmaterialSceneObject)

Description

Base class for line objects. Introduces line style properties (width, color...)

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase

Overview

Fields

Private | FLineColor: TGLColor;
Private | FLinePattern: TGLushort;
Private | FLineWidth: Single;
Private | FAntiAliased: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property AntiAliased: Boolean read FAntiAliased write SetAntiAliased default False;
Published | property LineColor: TGLColor read FLineColor write SetLineColor;
Published | property LinePattern: TGLushort read FLinePattern write SetLinePattern default $FFFF;
Published | property LineWidth: Single read FLineWidth write SetLineWidth stored StoreLineWidth;
Published | property Visible;

Description

Fields

Private FLineColor: TGLColor;

This item has no description.

Private FLinePattern: TGLushort;

This item has no description.

Private FLineWidth: Single;

This item has no description.

Private FAntiAliased: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property AntiAliased: Boolean read FAntiAliased write SetAntiAliased default False;

Indicates if OpenGL should smooth line edges. Smoothed lines looks better but are poorly implemented in most OpenGL drivers and take *lots* of rendering time

Published property LineColor: TGLColor read FLineColor write SetLineColor;

Default color of the lines.

Published property LinePattern: TGLushort read FLinePattern write SetLinePattern default $FFFF;

Bitwise line pattern. For instance $FFFF (65535) is a white line (stipple disabled), $0000 is a black line, $CCCC is the stipple used in axes and dummycube, etc.

Published property LineWidth: Single read FLineWidth write SetLineWidth stored StoreLineWidth;

Default width of the lines.

Published property Visible;


GLSysHelp v.2.5: GLS.Objects: Class TGLNodedLines

Class TGLNodedLines

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLNodedLines = class(TGLLineBase)

Description

Class that defines lines via a series of nodes. Base class, does not render anything

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLNodedLines

Overview

Fields

Private | FNodes: TGLLinesNodes;
Private | FNodesAspect: TGLLineNodesAspect;
Private | FNodeColor: TGLColor;
Private | FNodeSize: Single;
Private | FOldNodeColor: TGLColorVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure AddNode(const Value: TGLVector); overload;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure AddNode(const X, Y, Z: TGLFloat); overload;
Public | procedure AddNode(const coords: TGLCoordinates); overload;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property NodeColor: TGLColor read FNodeColor write SetNodeColor;
Published | property Nodes: TGLLinesNodes read FNodes write SetNodes;
Published | property NodesAspect: TGLLineNodesAspect read FNodesAspect write SetNodesAspect default lnaAxes;
Published | property NodeSize: Single read FNodeSize write SetNodeSize stored StoreNodeSize;

Description

Fields

Private FNodes: TGLLinesNodes;

This item has no description.

Private FNodesAspect: TGLLineNodesAspect;

This item has no description.

Private FNodeColor: TGLColor;

This item has no description.

Private FNodeSize: Single;

This item has no description.

Private FOldNodeColor: TGLColorVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure AddNode(const Value: TGLVector); overload;

This item has no description.

Public procedure AddNode(const Value: TAffineVector); overload;

This item has no description.

Public procedure AddNode(const X, Y, Z: TGLFloat); overload;

This item has no description.

Public procedure AddNode(const coords: TGLCoordinates); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property NodeColor: TGLColor read FNodeColor write SetNodeColor;

Default color for nodes. lnaInvisible and lnaAxes ignore this setting

Published property Nodes: TGLLinesNodes read FNodes write SetNodes;

The nodes list.

Published property NodesAspect: TGLLineNodesAspect read FNodesAspect write SetNodesAspect default lnaAxes;

Default aspect of line nodes. May help you materialize nodes, segments and control points.

Published property NodeSize: Single read FNodeSize write SetNodeSize stored StoreNodeSize;

Size for the various node aspects.


GLSysHelp v.2.5: GLS.Objects: Class TGLLines

Class TGLLines

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLLines = class(TGLNodedLines)

Description

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLNodedLines
  • TGLLines

Overview

Fields

Private | FDivision: Integer;
Private | FSplineMode: TGLLineSplineMode;
Private | FOptions: TGLLinesOptions;
Private | FNURBSOrder: Integer;
Private | FNURBSTolerance: Single;
Private | FNURBSKnots: TGLSingleList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property Division: Integer read FDivision write SetDivision default 10;
Public | property NURBSKnots: TGLSingleList read FNURBSKnots;
Public | property NURBSOrder: Integer read FNURBSOrder write SetNURBSOrder;
Public | property NURBSTolerance: Single read FNURBSTolerance write SetNURBSTolerance;
Published | property Options: TGLLinesOptions read FOptions write SetOptions;
Published | property SplineMode: TGLLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Fields

Private FDivision: Integer;

This item has no description.

Private FSplineMode: TGLLineSplineMode;

This item has no description.

Private FOptions: TGLLinesOptions;

This item has no description.

Private FNURBSOrder: Integer;

This item has no description.

Private FNURBSTolerance: Single;

This item has no description.

Private FNURBSKnots: TGLSingleList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Division: Integer read FDivision write SetDivision default 10;

Number of divisions for each segment in spline modes. Minimum 1 (disabled), ignored in lsmLines mode.

Public property NURBSKnots: TGLSingleList read FNURBSKnots;

This item has no description.

Public property NURBSOrder: Integer read FNURBSOrder write SetNURBSOrder;

This item has no description.

Public property NURBSTolerance: Single read FNURBSTolerance write SetNURBSTolerance;

This item has no description.

Published property Options: TGLLinesOptions read FOptions write SetOptions;

Rendering options for the line. loUseNodeColorForLines: if set lines will be drawn using node colors (and color interpolation between nodes), if not, LineColor will be used (single color). loColorLogicXor: enable logic operation for color of XOR type.

Published property SplineMode: TGLLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Default spline drawing mode.


GLSysHelp v.2.5: GLS.Objects: Class TGLCube

Class TGLCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLCube = class(TGLSceneObject)

Description

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TGLFreeForm and a material library. Ref: https://mathworld.wolfram.com/Cube.html

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLCube

Overview

Fields

Private | FCubeSize: TAffineVector;
Private | FParts: TGLCubeParts;
Private | FNormalDirection: TGLNormalDirection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Private | function GetCubeWHD(const Index: Integer): TGLFloat; inline;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Private | procedure SetCubeWHD(Index: Integer; aValue: TGLFloat); inline;
Private | procedure SetNormalDirection(aValue: TGLNormalDirection); inline;
Private | procedure SetParts(aValue: TGLCubeParts); inline;

Properties

Published | property CubeDepth: TGLFloat index 2 read GetCubeWHD write SetCubeWHD stored False;
Published | property CubeHeight: TGLFloat index 1 read GetCubeWHD write SetCubeWHD stored False;
Published | property CubeWidth: TGLFloat index 0 read GetCubeWHD write SetCubeWHD stored False;
Published | property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Parts: TGLCubeParts read FParts write SetParts default [cpTop, cpBottom, cpFront, cpBack, cpLeft, cpRight];

Description

Fields

Private FCubeSize: TAffineVector;

This item has no description.

Private FParts: TGLCubeParts;

This item has no description.

Private FNormalDirection: TGLNormalDirection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Private function GetCubeWHD(const Index: Integer): TGLFloat; inline;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetCubeWHD(Index: Integer; aValue: TGLFloat); inline;

This item has no description.

Private procedure SetNormalDirection(aValue: TGLNormalDirection); inline;

This item has no description.

Private procedure SetParts(aValue: TGLCubeParts); inline;

This item has no description.

Properties

Published property CubeDepth: TGLFloat index 2 read GetCubeWHD write SetCubeWHD stored False;

This item has no description.

Published property CubeHeight: TGLFloat index 1 read GetCubeWHD write SetCubeWHD stored False;

This item has no description.

Published property CubeWidth: TGLFloat index 0 read GetCubeWHD write SetCubeWHD stored False;

This item has no description.

Published property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Parts: TGLCubeParts read FParts write SetParts default [cpTop, cpBottom, cpFront, cpBack, cpLeft, cpRight];


GLSysHelp v.2.5: GLS.Objects: Class TGLQuadricObject

Class TGLQuadricObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLQuadricObject = class(TGLSceneObject)

Description

Base class for quadric objects. Introduces some basic Quadric interaction functions (the actual quadric math is part of the GLU library).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject

Overview

Fields

Private | FNormals: TGLNormalSmoothing;
Private | FNormalDirection: TGLNormalDirection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TGLNormalSmoothing read FNormals write SetNormals default nsSmooth;

Description

Fields

Private FNormals: TGLNormalSmoothing;

This item has no description.

Private FNormalDirection: TGLNormalDirection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property NormalDirection: TGLNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Normals: TGLNormalSmoothing read FNormals write SetNormals default nsSmooth;


GLSysHelp v.2.5: GLS.Objects: Class TGLSphere

Class TGLSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLSphere = class(TGLQuadricObject)

Description

A sphere object. The sphere can have to and bottom caps, as well as being just a slice of sphere. Ref: https://mathworld.wolfram.com/Sphere.html Ref: https://mathworld.wolfram.com/GeodesicDome.html

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLSphere

Overview

Fields

Private | FRadius: TGLFloat;
Private | FSlices: TGLInt;
Private | FStacks: TGLInt;
Private | FTop: TGLAngleLimit180;
Private | FBottom: TGLAngleLimit180;
Private | FStart: TGLAngleLimit360;
Private | FStop: TGLAngleLimit360;
Private | FTopCap: TGLCapType;
Private | FBottomCap: TGLCapType;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Private | procedure SetBottom(aValue: TGLAngleLimit180);
Private | procedure SetBottomCap(aValue: TGLCapType);
Private | procedure SetRadius(const aValue: TGLFloat);
Private | procedure SetSlices(aValue: TGLInt);
Private | procedure SetStacks(aValue: TGLInt);
Private | procedure SetStart(aValue: TGLAngleLimit360);
Private | procedure SetStop(aValue: TGLAngleLimit360);
Private | procedure SetTop(aValue: TGLAngleLimit180);
Private | procedure SetTopCap(aValue: TGLCapType);

Properties

Published | property Bottom: TGLAngleLimit180 read FBottom write SetBottom default -90;
Published | property BottomCap: TGLCapType read FBottomCap write SetBottomCap default ctNone;
Published | property Radius: TGLFloat read FRadius write SetRadius;
Published | property Slices: TGLInt read FSlices write SetSlices default 16;
Published | property Stacks: TGLInt read FStacks write SetStacks default 16;
Published | property Start: TGLAngleLimit360 read FStart write SetStart default 0;
Published | property Stop: TGLAngleLimit360 read FStop write SetStop default 360;
Published | property Top: TGLAngleLimit180 read FTop write SetTop default 90;
Published | property TopCap: TGLCapType read FTopCap write SetTopCap default ctNone;

Description

Fields

Private FRadius: TGLFloat;

This item has no description.

Private FSlices: TGLInt;

This item has no description.

Private FStacks: TGLInt;

This item has no description.

Private FTop: TGLAngleLimit180;

This item has no description.

Private FBottom: TGLAngleLimit180;

This item has no description.

Private FStart: TGLAngleLimit360;

This item has no description.

Private FStop: TGLAngleLimit360;

This item has no description.

Private FTopCap: TGLCapType;

This item has no description.

Private FBottomCap: TGLCapType;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetBottom(aValue: TGLAngleLimit180);

This item has no description.

Private procedure SetBottomCap(aValue: TGLCapType);

This item has no description.

Private procedure SetRadius(const aValue: TGLFloat);

This item has no description.

Private procedure SetSlices(aValue: TGLInt);

This item has no description.

Private procedure SetStacks(aValue: TGLInt);

This item has no description.

Private procedure SetStart(aValue: TGLAngleLimit360);

This item has no description.

Private procedure SetStop(aValue: TGLAngleLimit360);

This item has no description.

Private procedure SetTop(aValue: TGLAngleLimit180);

This item has no description.

Private procedure SetTopCap(aValue: TGLCapType);

This item has no description.

Properties

Published property Bottom: TGLAngleLimit180 read FBottom write SetBottom default -90;

This item has no description.

Published property BottomCap: TGLCapType read FBottomCap write SetBottomCap default ctNone;

This item has no description.

Published property Radius: TGLFloat read FRadius write SetRadius;

This item has no description.

Published property Slices: TGLInt read FSlices write SetSlices default 16;

This item has no description.

Published property Stacks: TGLInt read FStacks write SetStacks default 16;

This item has no description.

Published property Start: TGLAngleLimit360 read FStart write SetStart default 0;

This item has no description.

Published property Stop: TGLAngleLimit360 read FStop write SetStop default 360;

This item has no description.

Published property Top: TGLAngleLimit180 read FTop write SetTop default 90;

This item has no description.

Published property TopCap: TGLCapType read FTopCap write SetTopCap default ctNone;


GLSysHelp v.2.5: GLS.Objects: Class TGLPolygonBase

Class TGLPolygonBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLPolygonBase = class(TGLSceneObject)

Description

Base class for objects based on a polygon

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase

Overview

Fields

Private | FDivision: Integer;
Private | FSplineMode: TGLLineSplineMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure AddNode(const X, Y, Z: TGLFloat); overload;
Public | procedure AddNode(const Value: TGLVector); overload;
Public | procedure AddNode(const coords: TGLCoordinates); overload;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Division: Integer read FDivision write SetDivision default 10;
Published | property Nodes: TGLNodes read FNodes write SetNodes;
Published | property SplineMode: TGLLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Fields

Private FDivision: Integer;

This item has no description.

Private FSplineMode: TGLLineSplineMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddNode(const X, Y, Z: TGLFloat); overload;

This item has no description.

Public procedure AddNode(const Value: TGLVector); overload;

This item has no description.

Public procedure AddNode(const coords: TGLCoordinates); overload;

This item has no description.

Public procedure AddNode(const Value: TAffineVector); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property Division: Integer read FDivision write SetDivision default 10;

Number of divisions for each segment in spline modes. Minimum 1 (disabled), ignored in lsmLines mode.

Published property Nodes: TGLNodes read FNodes write SetNodes;

The nodes list.

Published property SplineMode: TGLLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Default spline drawing mode. This mode is used only for the curve, not for the rotation path.


GLSysHelp v.2.5: GLS.Objects: Class TGLSuperellipsoid

Class TGLSuperellipsoid

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Objects

Declaration

type TGLSuperellipsoid = class(TGLQuadricObject)

Description

A Superellipsoid object. The Superellipsoid can have top and bottom caps, as well as being just a slice of Superellipsoid. Ref: https://mathworld.wolfram.com/Superellipse.html

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLSuperellipsoid

Overview

Fields

Private | FRadius: TGLFloat;
Private | FVCurve: TGLFloat;
Private | FHCurve: TGLFloat;
Private | FSlices: TGLInt;
Private | FStacks: TGLInt;
Private | FTop: TGLAngleLimit180;
Private | FBottom: TGLAngleLimit180;
Private | FStart: TGLAngleLimit360;
Private | FStop: TGLAngleLimit360;
Private | FTopCap: TGLCapType;
Private | FBottomCap: TGLCapType;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Private | procedure SetBottom(aValue: TGLAngleLimit180);
Private | procedure SetBottomCap(aValue: TGLCapType);
Private | procedure SetHCurve(const aValue: TGLFloat);
Private | procedure SetRadius(const aValue: TGLFloat);
Private | procedure SetSlices(aValue: TGLInt);
Private | procedure SetStacks(aValue: TGLInt);
Private | procedure SetStart(aValue: TGLAngleLimit360);
Private | procedure SetStop(aValue: TGLAngleLimit360);
Private | procedure SetTop(aValue: TGLAngleLimit180);
Private | procedure SetTopCap(aValue: TGLCapType);
Private | procedure SetVCurve(const aValue: TGLFloat);

Properties

Published | property Bottom: TGLAngleLimit180 read FBottom write SetBottom default -90;
Published | property BottomCap: TGLCapType read FBottomCap write SetBottomCap default ctNone;
Published | property HCurve: TGLFloat read FHCurve write SetHCurve;
Published | property Radius: TGLFloat read FRadius write SetRadius;
Published | property Slices: TGLInt read FSlices write SetSlices default 16;
Published | property Stacks: TGLInt read FStacks write SetStacks default 16;
Published | property Start: TGLAngleLimit360 read FStart write SetStart default 0;
Published | property Stop: TGLAngleLimit360 read FStop write SetStop default 360;
Published | property Top: TGLAngleLimit180 read FTop write SetTop default 90;
Published | property TopCap: TGLCapType read FTopCap write SetTopCap default ctNone;
Published | property VCurve: TGLFloat read FVCurve write SetVCurve;

Description

Fields

Private FRadius: TGLFloat;

This item has no description.

Private FVCurve: TGLFloat;

This item has no description.

Private FHCurve: TGLFloat;

This item has no description.

Private FSlices: TGLInt;

This item has no description.

Private FStacks: TGLInt;

This item has no description.

Private FTop: TGLAngleLimit180;

This item has no description.

Private FBottom: TGLAngleLimit180;

This item has no description.

Private FStart: TGLAngleLimit360;

This item has no description.

Private FStop: TGLAngleLimit360;

This item has no description.

Private FTopCap: TGLCapType;

This item has no description.

Private FBottomCap: TGLCapType;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil) : Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetBottom(aValue: TGLAngleLimit180);

This item has no description.

Private procedure SetBottomCap(aValue: TGLCapType);

This item has no description.

Private procedure SetHCurve(const aValue: TGLFloat);

This item has no description.

Private procedure SetRadius(const aValue: TGLFloat);

This item has no description.

Private procedure SetSlices(aValue: TGLInt);

This item has no description.

Private procedure SetStacks(aValue: TGLInt);

This item has no description.

Private procedure SetStart(aValue: TGLAngleLimit360);

This item has no description.

Private procedure SetStop(aValue: TGLAngleLimit360);

This item has no description.

Private procedure SetTop(aValue: TGLAngleLimit180);

This item has no description.

Private procedure SetTopCap(aValue: TGLCapType);

This item has no description.

Private procedure SetVCurve(const aValue: TGLFloat);

This item has no description.

Properties

Published property Bottom: TGLAngleLimit180 read FBottom write SetBottom default -90;

This item has no description.

Published property BottomCap: TGLCapType read FBottomCap write SetBottomCap default ctNone;

This item has no description.

Published property HCurve: TGLFloat read FHCurve write SetHCurve;

This item has no description.

Published property Radius: TGLFloat read FRadius write SetRadius;

This item has no description.

Published property Slices: TGLInt read FSlices write SetSlices default 16;

This item has no description.

Published property Stacks: TGLInt read FStacks write SetStacks default 16;

This item has no description.

Published property Start: TGLAngleLimit360 read FStart write SetStart default 0;

This item has no description.

Published property Stop: TGLAngleLimit360 read FStop write SetStop default 360;

This item has no description.

Published property Top: TGLAngleLimit180 read FTop write SetTop default 90;

This item has no description.

Published property TopCap: TGLCapType read FTopCap write SetTopCap default ctNone;

This item has no description.

Published property VCurve: TGLFloat read FVCurve write SetVCurve;


GLSysHelp v.2.5: GLS.Octree

Unit GLS.Octree

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Math
  • System.Classes
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLScene.GeometryBB
  • GLS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TOctreeTriangleInfo |
Record TGLOctreeNode |
Class TGLOctree |

Types

PGLOctreeNode = ˆTGLOctreeNode;
POctreeTriangleInfo = ˆTOctreeTriangleInfo;
TProcAffineAffineAffine = procedure(V1, V2, V3: TAffineFLTVector) of object;
TProcInt = procedure(I: Integer) of object;

Description

Types

PGLOctreeNode = ˆTGLOctreeNode;

This item has no description.

POctreeTriangleInfo = ˆTOctreeTriangleInfo;

Stores information about an intersected triangle

TProcAffineAffineAffine = procedure(V1, V2, V3: TAffineFLTVector) of object;

This item has no description.

TProcInt = procedure(I: Integer) of object;


GLSysHelp v.2.5: GLS.Octree: Record TOctreeTriangleInfo

Record TOctreeTriangleInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Octree

Declaration

type TOctreeTriangleInfo = record

Description

This item has no description.

Overview

Fields

Public | Index: Integer;
Public | Vertex: array [0 .. 2] of TAffineVector;

Description

Fields

Public Index: Integer;

This item has no description.

Public Vertex: array [0 .. 2] of TAffineVector;


GLSysHelp v.2.5: GLS.Octree: Record TGLOctreeNode

Record TGLOctreeNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Octree

Declaration

type TGLOctreeNode = record

Description

This item has no description.

Overview

Fields

Public | MinExtent: TAffineFLTVector;
Public | MaxExtent: TAffineFLTVector;
Public | ListHandle: TGLListHandle;
Public | WillDraw: Boolean;
Public | TriArray: array of Integer;
Public | ChildArray: array [0 .. 7] of PGLOctreeNode;

Description

Fields

Public MinExtent: TAffineFLTVector;

This item has no description.

Public MaxExtent: TAffineFLTVector;

This item has no description.

Public ListHandle: TGLListHandle;

TextureHandle:TGLTextureHandle;

Public WillDraw: Boolean;

This item has no description.

Public TriArray: array of Integer;

temporary change Are duplicates possible?

Public ChildArray: array [0 .. 7] of PGLOctreeNode;

array of triangle references


GLSysHelp v.2.5: GLS.Octree: Class TGLOctree

Class TGLOctree

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Octree

Declaration

type TGLOctree = class(TObject)

Description

Manages an Octree containing references to triangles.

Hierarchy

  • TObject
  • TGLOctree

Overview

Fields

Public | WorldMinExtent: TAffineFLTVector;
Public | WorldMaxExtent: TAffineFLTVector;
Public | RootNode: PGLOctreeNode;
Public | MaxOlevel: Integer;
Public | NodeCount: Integer;
Public | TriCountMesh: Integer;
Public | TriCountOctree: Integer;
Public | MeshCount: Integer;
Public | ResultArray: array of PGLOctreeNode;
Public | TriangleFiler: TGLAffineVectorList;

Methods

Public | destructor Destroy; override;
Public | function AABBIntersect(const AABB: TAABB; const M1to2, M2to1: TGLMatrix; Triangles: TGLAffineVectorList = nil): Boolean;
Public | function GetTrianglesFromNodesIntersectingAABB(const ObjAABB: TAABB) : TGLAffineVectorList;
Public | function GetTrianglesFromNodesIntersectingCube(const ObjAABB: TAABB; const ObjToSelf, SelfToObj: TGLMatrix): TGLAffineVectorList;
Public | function RayCastIntersect(const RayStart, RayVector: TGLVector; IntersectPoint: PGLVector = nil; IntersectNormal: PGLVector = nil; TriangleInfo: POctreeTriangleInfo = nil): Boolean;
Public | function SphereSweepIntersect(const RayStart, RayVector: TGLVector; const Velocity, Radius: Single; IntersectPoint: PGLVector = nil; IntersectNormal: PGLVector = nil): Boolean;
Public | function TriangleIntersect(const V1, V2, V3: TAffineVector): Boolean;
Public | procedure DisposeTree;
Public | procedure InitializeTree(const AWorldMinExtent, AWorldMaxExtent : TAffineVector; const ATriangles: TGLAffineVectorList; const ATreeDepth: Integer);
Public | procedure WalkSphereToLeaf(Onode: PGLOctreeNode; const P: TGLVector; Radius: Single);

Description

Fields

Public WorldMinExtent: TAffineFLTVector;

This item has no description.

Public WorldMaxExtent: TAffineFLTVector;

This item has no description.

Public RootNode: PGLOctreeNode;

This item has no description.

Public MaxOlevel: Integer;

always points to root node

Public NodeCount: Integer;

max depth level of TGLOctreeNode

Public TriCountMesh: Integer;

number of nodes (ex: 8 for level 1, 72 for level 2 etc).

Public TriCountOctree: Integer;

total number of triangles in the mesh

Public MeshCount: Integer;

total number of triangles cut into the octree

Public ResultArray: array of PGLOctreeNode;

number of meshes currently cut into the Octree

Public TriangleFiler: TGLAffineVectorList;

holds the result nodes of various calls

Methods

Public destructor Destroy; override;

This item has no description.

Public function AABBIntersect(const AABB: TAABB; const M1to2, M2to1: TGLMatrix; Triangles: TGLAffineVectorList = nil): Boolean;

Checks if an AABB intersects a face on the octree

Public function GetTrianglesFromNodesIntersectingAABB(const ObjAABB: TAABB) : TGLAffineVectorList;

Returns all triangles in the AABB.

Public function GetTrianglesFromNodesIntersectingCube(const ObjAABB: TAABB; const ObjToSelf, SelfToObj: TGLMatrix): TGLAffineVectorList;

Returns all triangles in an arbitrarily placed cube

Public function RayCastIntersect(const RayStart, RayVector: TGLVector; IntersectPoint: PGLVector = nil; IntersectNormal: PGLVector = nil; TriangleInfo: POctreeTriangleInfo = nil): Boolean;

This item has no description.

Public function SphereSweepIntersect(const RayStart, RayVector: TGLVector; const Velocity, Radius: Single; IntersectPoint: PGLVector = nil; IntersectNormal: PGLVector = nil): Boolean;

This item has no description.

Public function TriangleIntersect(const V1, V2, V3: TAffineVector): Boolean;

This item has no description.

Public procedure DisposeTree;

This item has no description.

Public procedure InitializeTree(const AWorldMinExtent, AWorldMaxExtent : TAffineVector; const ATriangles: TGLAffineVectorList; const ATreeDepth: Integer);

Initializes the tree from the triangle list. All triangles must be contained in the world extent to be properly taken into account.

Public procedure WalkSphereToLeaf(Onode: PGLOctreeNode; const P: TGLVector; Radius: Single);


GLSysHelp v.2.5: GLS.ODEManager

Unit GLS.ODEManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • System.Types
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLS.VectorLists
  • GLScene.VectorGeometry
  • GLScene.PipelineTransform
  • GLS.PersistentClasses
  • GLScene.Manager
  • GLScene.XCollection
  • GLS.Scene
  • GLS.Context
  • GLS.Texture
  • GLS.Objects
  • GLS.Color
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLS.State
  • GLS.TerrainRenderer
  • GLS.Graph
  • ODE.Import
  • GLS.ODEUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLODEManager |
Class TGLODECollisionSurface |
Class TGLODEBehaviour |
Class TGLODEDynamic |
Class TGLODEStatic |
Class TGLODEElements |
Class TGLODEElementBase |
Class TGLODEElementBox |
Class TGLODEElementSphere |
Class TGLODEElementCapsule |
Class TGLODEElementCylinder |
Class TGLODEElementTriMesh |
Class TGLODEElementPlane |
Class TGLODEJoints |
Class TGLODEJointList |
Class TGLODEJointBase |
Class TGLODEJointParams |
Class TGLODEJointHinge |
Class TGLODEJointBall |
Class TGLODEJointSlider |
Class TGLODEJointFixed |
Class TGLODEJointHinge2 |
Class TGLODEJointUniversal |
Class TGLODEContactPoint |
Class TGLODECustomCollider |
Class TGLODEHeightField |

Functions and Procedures

procedure nearCallBack(Data: Pointer; o1, o2: PdxGeom); cdecl;
function GetBodyFromObject(anObject: TObject): PdxBody;
function GetBodyFromGLSceneObject(anObject: TGLBaseSceneObject): PdxBody;
function GetSurfaceFromObject(anObject: TObject): TGLODECollisionSurface;
procedure RegisterGLSceneObject(anObject: TGLBaseSceneObject);
procedure UnregisterGLSceneObject(anObject: TGLBaseSceneObject);
function GetGLSceneObject(anObjectName: String): TGLBaseSceneObject;
function GetOdeStatic(obj: TGLBaseSceneObject): TGLODEStatic;
function GetOrCreateOdeStatic(obj: TGLBaseSceneObject): TGLODEStatic;
function GetOdeDynamic(obj: TGLBaseSceneObject): TGLODEDynamic;
function GetOrCreateOdeDynamic(obj: TGLBaseSceneObject): TGLODEDynamic;
function GetODEHeightField(obj: TGLBaseSceneObject): TGLODEHeightField;
function GetOrCreateODEHeightField(obj: TGLBaseSceneObject): TGLODEHeightField;

Types

TGLODECollisionEvent = procedure (Sender : TObject; Object1, Object2 : TObject; var Contact:TdContact; var HandleCollision:Boolean) of object;
TGLODECollisionSurfaceMode = (...);
TGLODECustomCollisionEvent = procedure (Geom1, Geom2 : PdxGeom) of object;
TGLODEElementClass = class of TGLODEElementBase;
TGLODEGetParamCallback = function(Param: Integer; var Value: TdReal): Boolean of object;
TGLODEJointOption = (...);
TGLODEJointOptions = set of TGLODEJointOption;
TGLODEObjectCollisionEvent = procedure (Sender : TObject; Object2 : TObject; var Contact:TdContact; var HandleCollision:Boolean) of object;
TGLODESetParamCallback = function(Param: Integer; const Value: TdReal): Boolean of object;
TGLODESolverMethod = (...);
TGLODESurfaceModes = set of TGLODECollisionSurfaceMode;

Variables

vODEObjectRegister: TList;
vCustomColliderClass: TdGeomClass;
vCustomColliderClassNum: Integer;

Description

Functions and Procedures

procedure nearCallBack(Data: Pointer; o1, o2: PdxGeom); cdecl;

ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer

function GetBodyFromObject(anObject: TObject): PdxBody;

Helper functions for extracting data from objects with different inheritance.

function GetBodyFromGLSceneObject(anObject: TGLBaseSceneObject): PdxBody;

This item has no description.

function GetSurfaceFromObject(anObject: TObject): TGLODECollisionSurface;

This item has no description.

procedure RegisterGLSceneObject(anObject: TGLBaseSceneObject);

GLODEObject register methods (used for joint object persistence)

procedure UnregisterGLSceneObject(anObject: TGLBaseSceneObject);

This item has no description.

function GetGLSceneObject(anObjectName: String): TGLBaseSceneObject;

This item has no description.

function GetOdeStatic(obj: TGLBaseSceneObject): TGLODEStatic;

Get and GetOrCreate functions for ode behaviours

function GetOrCreateOdeStatic(obj: TGLBaseSceneObject): TGLODEStatic;

This item has no description.

function GetOdeDynamic(obj: TGLBaseSceneObject): TGLODEDynamic;

This item has no description.

function GetOrCreateOdeDynamic(obj: TGLBaseSceneObject): TGLODEDynamic;

This item has no description.

function GetODEHeightField(obj: TGLBaseSceneObject): TGLODEHeightField;

Get and GetOrCreate functions for ODE HeightField

function GetOrCreateODEHeightField(obj: TGLBaseSceneObject): TGLODEHeightField;

This item has no description.

Types

TGLODECollisionEvent = procedure (Sender : TObject; Object1, Object2 : TObject; var Contact:TdContact; var HandleCollision:Boolean) of object;

This item has no description.

TGLODECollisionSurfaceMode = (...);

This item has no description.

Values
  • csmMu2
  • csmFDir1
  • csmBounce
  • csmSoftERP
  • csmSoftCFM
  • csmMotion1
  • csmMotion2
  • csmSlip1
  • csmSlip2
TGLODECustomCollisionEvent = procedure (Geom1, Geom2 : PdxGeom) of object;

This item has no description.

TGLODEElementClass = class of TGLODEElementBase;

This item has no description.

TGLODEGetParamCallback = function(Param: Integer; var Value: TdReal): Boolean of object;

This item has no description.

TGLODEJointOption = (...);

This item has no description.

Values
  • joBothObjectsMustBeAssigned
TGLODEJointOptions = set of TGLODEJointOption;

This item has no description.

TGLODEObjectCollisionEvent = procedure (Sender : TObject; Object2 : TObject; var Contact:TdContact; var HandleCollision:Boolean) of object;

This item has no description.

TGLODESetParamCallback = function(Param: Integer; const Value: TdReal): Boolean of object;

This item has no description.

TGLODESolverMethod = (...);

This item has no description.

Values
  • osmDefault
  • osmStepFast
  • osmQuickStep
TGLODESurfaceModes = set of TGLODECollisionSurfaceMode;

This item has no description.

Variables

vODEObjectRegister: TList;

This item has no description.

vCustomColliderClass: TdGeomClass;

This item has no description.

vCustomColliderClassNum: Integer;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEManager

Class TGLODEManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEManager = class(TComponent)

Description

The visual component to manage behaviours of ODE objects

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLODEManager

Overview

Fields

Private | FWorld: PdxWorld;
Private | FSpace: PdxSpace;
Private | FContactGroup: TdJointGroupID;
Private | FGravity: TGLCoordinates;
Private | FOnCollision: TGLODECollisionEvent;
Private | FOnCustomCollision: TGLODECustomCollisionEvent;
Private | FNumContactJoints: Integer;
Private | FMaxContacts: Integer;
Private | FODEBehaviours: TGLPersistentObjectList;
Private | FRFContactList: TList;
Private | FIterations: Integer;
Private | FSolver: TGLODESolverMethod;
Private | FContacts: array of TdContact;
Private | FContactGeoms: array of TdContactGeom;
Private | FRenderPoint: TGLRenderPoint;
Private | FVisible: Boolean;
Private | FVisibleAtRunTime: Boolean;
Private | FGeomColorDynD: TGLColor;
Private | FGeomColorDynE: TGLColor;
Private | FGeomColorStat: TGLColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure Step(deltaTime: double);

Properties

Public | property ContactGroup: TdJointGroupID read FContactGroup;
Published | property GeomColorDynD: TGLColor read FGeomColorDynD write SetGeomColorDynD;
Published | property GeomColorDynE: TGLColor read FGeomColorDynE write SetGeomColorDynE;
Published | property GeomColorStat: TGLColor read FGeomColorStat write SetGeomColorStat;
Published | property Gravity: TGLCoordinates read FGravity write SetGravity;
Published | property Iterations: Integer read FIterations write SetIterations;
Published | property MaxContacts: Integer read FMaxContacts write SetMaxContacts;
Public | property NumContactJoints: Integer read FNumContactJoints;
Published | property OnCollision: TGLODECollisionEvent read FOnCollision write FOnCollision;
Published | property OnCustomCollision: TGLODECustomCollisionEvent read FOnCustomCollision write FOnCustomCollision;
Published | property RenderPoint: TGLRenderPoint read FRenderPoint write SetRenderPoint;
Published | property Solver: TGLODESolverMethod read FSolver write FSolver;
Public | property Space: PdxSpace read FSpace;
Published | property Visible: Boolean read FVisible write SetVisible;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime;
Public | property World: PdxWorld read FWorld;

Description

Fields

Private FWorld: PdxWorld;

This item has no description.

Private FSpace: PdxSpace;

This item has no description.

Private FContactGroup: TdJointGroupID;

This item has no description.

Private FGravity: TGLCoordinates;

This item has no description.

Private FOnCollision: TGLODECollisionEvent;

This item has no description.

Private FOnCustomCollision: TGLODECustomCollisionEvent;

This item has no description.

Private FNumContactJoints: Integer;

This item has no description.

Private FMaxContacts: Integer;

This item has no description.

Private FODEBehaviours: TGLPersistentObjectList;

This item has no description.

Private FRFContactList: TList;

This item has no description.

Private FIterations: Integer;

This item has no description.

Private FSolver: TGLODESolverMethod;

This item has no description.

Private FContacts: array of TdContact;

This item has no description.

Private FContactGeoms: array of TdContactGeom;

This item has no description.

Private FRenderPoint: TGLRenderPoint;

This item has no description.

Private FVisible: Boolean;

This item has no description.

Private FVisibleAtRunTime: Boolean;

This item has no description.

Private FGeomColorDynD: TGLColor;

This item has no description.

Private FGeomColorDynE: TGLColor;

This item has no description.

Private FGeomColorStat: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure Step(deltaTime: double);

This item has no description.

Properties

Public property ContactGroup: TdJointGroupID read FContactGroup;

This item has no description.

Published property GeomColorDynD: TGLColor read FGeomColorDynD write SetGeomColorDynD;

This item has no description.

Published property GeomColorDynE: TGLColor read FGeomColorDynE write SetGeomColorDynE;

This item has no description.

Published property GeomColorStat: TGLColor read FGeomColorStat write SetGeomColorStat;

This item has no description.

Published property Gravity: TGLCoordinates read FGravity write SetGravity;

This item has no description.

Published property Iterations: Integer read FIterations write SetIterations;

This item has no description.

Published property MaxContacts: Integer read FMaxContacts write SetMaxContacts;

This item has no description.

Public property NumContactJoints: Integer read FNumContactJoints;

This item has no description.

Published property OnCollision: TGLODECollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property OnCustomCollision: TGLODECustomCollisionEvent read FOnCustomCollision write FOnCustomCollision;

This item has no description.

Published property RenderPoint: TGLRenderPoint read FRenderPoint write SetRenderPoint;

This item has no description.

Published property Solver: TGLODESolverMethod read FSolver write FSolver;

This item has no description.

Public property Space: PdxSpace read FSpace;

This item has no description.

Published property Visible: Boolean read FVisible write SetVisible;

This item has no description.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime;

This item has no description.

Public property World: PdxWorld read FWorld;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODECollisionSurface

Class TGLODECollisionSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODECollisionSurface = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLODECollisionSurface

Overview

Fields

Private | FOwner: TPersistent;
Private | FSurfaceParams: TdSurfaceParameters;
Private | FRFCoeff: Single;
Private | FRFEnabled: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function GetOwner: TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Bounce: TdReal read GetBounce write SetBounce;
Published | property Bounce_Vel: TdReal read GetBounce_Vel write SetBounce_Vel;
Published | property Motion1: TdReal read GetMotion1 write SetMotion1;
Published | property Motion2: TdReal read GetMotion2 write SetMotion2;
Published | property Mu: TdReal read GetMu write SetMu;
Published | property Mu2: TdReal read GetMu2 write SetMu2;
Published | property RollingFrictionCoeff: Single read FRFCoeff write FRFCoeff;
Published | property RollingFrictionEnabled: Boolean read FRFEnabled write FRFEnabled;
Published | property Slip1: TdReal read GetSlip1 write SetSlip1;
Published | property Slip2: TdReal read GetSlip2 write SetSlip2;
Published | property SoftCFM: TdReal read GetSoftCFM write SetSoftCFM;
Published | property SoftERP: TdReal read GetSoftERP write SetSoftERP;
Published | property SurfaceMode: TGLODESurfaceModes read GetSurfaceMode write SetSurfaceMode;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FSurfaceParams: TdSurfaceParameters;

This item has no description.

Private FRFCoeff: Single;

This item has no description.

Private FRFEnabled: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function GetOwner: TPersistent; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Bounce: TdReal read GetBounce write SetBounce;

This item has no description.

Published property Bounce_Vel: TdReal read GetBounce_Vel write SetBounce_Vel;

This item has no description.

Published property Motion1: TdReal read GetMotion1 write SetMotion1;

This item has no description.

Published property Motion2: TdReal read GetMotion2 write SetMotion2;

This item has no description.

Published property Mu: TdReal read GetMu write SetMu;

This item has no description.

Published property Mu2: TdReal read GetMu2 write SetMu2;

This item has no description.

Published property RollingFrictionCoeff: Single read FRFCoeff write FRFCoeff;

This item has no description.

Published property RollingFrictionEnabled: Boolean read FRFEnabled write FRFEnabled;

This item has no description.

Published property Slip1: TdReal read GetSlip1 write SetSlip1;

This item has no description.

Published property Slip2: TdReal read GetSlip2 write SetSlip2;

This item has no description.

Published property SoftCFM: TdReal read GetSoftCFM write SetSoftCFM;

This item has no description.

Published property SoftERP: TdReal read GetSoftERP write SetSoftERP;

This item has no description.

Published property SurfaceMode: TGLODESurfaceModes read GetSurfaceMode write SetSurfaceMode;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEBehaviour

Class TGLODEBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEBehaviour = class(TGLBehaviour)

Description

Basis structures for behaviour style implementations

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour

Overview

Fields

Private | FManager: TGLODEManager;
Private | FManagerName: String;
Private | FSurface: TGLODECollisionSurface;
Private | FOnCollision: TGLODEObjectCollisionEvent;
Private | FInitialized: Boolean;
Private | FOwnerBaseSceneObject: TGLBaseSceneObject;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure Reinitialize;
Public | procedure Render(var rci: TGLRenderContextInfo); virtual;

Properties

Public | property AbsoluteMatrix: TGLMatrix read GetAbsoluteMatrix;
Public | property Initialized: Boolean read FInitialized;
Published | property Manager: TGLODEManager read FManager write SetManager;
Published | property OnCollision: TGLODEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Surface: TGLODECollisionSurface read FSurface write SetSurface;

Description

Fields

Private FManager: TGLODEManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FSurface: TGLODECollisionSurface;

This item has no description.

Private FOnCollision: TGLODEObjectCollisionEvent;

This item has no description.

Private FInitialized: Boolean;

This item has no description.

Private FOwnerBaseSceneObject: TGLBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure Reinitialize;

This item has no description.

Public procedure Render(var rci: TGLRenderContextInfo); virtual;

This item has no description.

Properties

Public property AbsoluteMatrix: TGLMatrix read GetAbsoluteMatrix;

This item has no description.

Public property Initialized: Boolean read FInitialized;

This item has no description.

Published property Manager: TGLODEManager read FManager write SetManager;

This item has no description.

Published property OnCollision: TGLODEObjectCollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property Surface: TGLODECollisionSurface read FSurface write SetSurface;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEDynamic

Class TGLODEDynamic

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEDynamic = class(TGLODEBehaviour)

Description

This item has no description. Showing description inherited from TGLODEBehaviour.

Basis structures for behaviour style implementations

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour
  • TGLODEDynamic

Overview

Fields

Private | FBody: PdxBody;
Private | FMass: TdMass;
Private | FElements: TGLODEElements;
Private | FEnabled: Boolean;
Private | FJointRegister: TList;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AddNewElement(AChild: TGLODEElementClass): TGLODEElementBase; dynamic;
Public | function CalculateMass: TdMass;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure AddForce(Force: TAffineVector);
Public | procedure AddForceAtPos(Force, Pos: TAffineVector);
Public | procedure AddForceAtRelPos(Force, Pos: TAffineVector);
Public | procedure AddRelForce(Force: TAffineVector);
Public | procedure AddRelForceAtPos(Force, Pos: TAffineVector);
Public | procedure AddRelForceAtRelPos(Force, Pos: TAffineVector);
Public | procedure AddRelTorque(Torque: TAffineVector);
Public | procedure AddTorque(Torque: TAffineVector);
Public | procedure AlignObject;
Public | procedure CalibrateCenterOfMass;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Public | property Body: PdxBody read FBody;
Published | property Elements: TGLODEElements read FElements;
Published | property Enabled: Boolean read GetEnabled write SetEnabled;
Public | property Mass: TdMass read GetMass write SetMass;

Description

Fields

Private FBody: PdxBody;

This item has no description.

Private FMass: TdMass;

This item has no description.

Private FElements: TGLODEElements;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FJointRegister: TList;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddNewElement(AChild: TGLODEElementClass): TGLODEElementBase; dynamic;

This item has no description.

Public function CalculateMass: TdMass;

This item has no description.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure AddForce(Force: TAffineVector);

This item has no description.

Public procedure AddForceAtPos(Force, Pos: TAffineVector);

This item has no description.

Public procedure AddForceAtRelPos(Force, Pos: TAffineVector);

This item has no description.

Public procedure AddRelForce(Force: TAffineVector);

This item has no description.

Public procedure AddRelForceAtPos(Force, Pos: TAffineVector);

This item has no description.

Public procedure AddRelForceAtRelPos(Force, Pos: TAffineVector);

This item has no description.

Public procedure AddRelTorque(Torque: TAffineVector);

This item has no description.

Public procedure AddTorque(Torque: TAffineVector);

This item has no description.

Public procedure AlignObject;

This item has no description.

Public procedure CalibrateCenterOfMass;

This item has no description.

Public procedure Render(var rci: TGLRenderContextInfo); override;

This item has no description.

Properties

Public property Body: PdxBody read FBody;

This item has no description.

Published property Elements: TGLODEElements read FElements;

This item has no description.

Published property Enabled: Boolean read GetEnabled write SetEnabled;

This item has no description.

Public property Mass: TdMass read GetMass write SetMass;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEStatic

Class TGLODEStatic

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEStatic = class(TGLODEBehaviour)

Description

This item has no description. Showing description inherited from TGLODEBehaviour.

Basis structures for behaviour style implementations

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour
  • TGLODEStatic

Overview

Fields

Private FElements: TGLODEElements;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AddNewElement(AChild: TGLODEElementClass): TGLODEElementBase; dynamic;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Published property Elements: TGLODEElements read FElements;

Description

Fields

Private FElements: TGLODEElements;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddNewElement(AChild: TGLODEElementClass): TGLODEElementBase; dynamic;

This item has no description.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Render(var rci: TGLRenderContextInfo); override;

This item has no description.

Properties

Published property Elements: TGLODEElements read FElements;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEElements

Class TGLODEElements

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEElements = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLODEElements

Overview

Methods

Public | destructor Destroy; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Private | function GetElement(index: Integer): TGLODEElementBase;
Public | procedure Finalize;
Public | procedure Initialize;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure Render(var rci: TGLRenderContextInfo);

Properties

Public property Element[index: Integer]: TGLODEElementBase read GetElement;

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Private function GetElement(index: Integer): TGLODEElementBase;

This item has no description.

Public procedure Finalize;

This item has no description.

Public procedure Initialize;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure Render(var rci: TGLRenderContextInfo);

This item has no description.

Properties

Public property Element[index: Integer]: TGLODEElementBase read GetElement;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEElementBase

Class TGLODEElementBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEElementBase = class(TXCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEElementBase

Overview

Fields

Private | FMass: TdMass;
Private | FDensity: TdReal;
Private | FGeomTransform: PdxGeom;
Private | FGeomElement: PdxGeom;
Private | FPosition: TGLCoordinates;
Private | FDirection: TGLCoordinates;
Private | FUp: TGLCoordinates;
Private | FLocalMatrix: TGLMatrix;
Private | FRealignODE: Boolean;
Private | FInitialized: Boolean;
Private | FDynamic: Boolean;
Private | FIsCalculating: Boolean;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AbsoluteMatrix: TGLMatrix;
Public | function AbsolutePosition: TAffineVector;
Public | procedure Render(var rci: TGLRenderContextInfo); virtual;

Properties

Published | property Density: TdReal read FDensity write SetDensity;
Published | property Direction: TGLCoordinates read FDirection write SetDirection;
Public | property Geom: PdxGeom read FGeomElement;
Public | property GeomTransform: PdxGeom read FGeomTransform;
Public | property Initialized: Boolean read FInitialized;
Public | property Matrix: TGLMatrix read GetMatrix write SetMatrix;
Published | property Position: TGLCoordinates read FPosition write SetPosition;
Published | property Up: TGLCoordinates read FUp write SetUp;

Description

Fields

Private FMass: TdMass;

This item has no description.

Private FDensity: TdReal;

This item has no description.

Private FGeomTransform: PdxGeom;

This item has no description.

Private FGeomElement: PdxGeom;

This item has no description.

Private FPosition: TGLCoordinates;

This item has no description.

Private FDirection: TGLCoordinates;

This item has no description.

Private FUp: TGLCoordinates;

This item has no description.

Private FLocalMatrix: TGLMatrix;

This item has no description.

Private FRealignODE: Boolean;

This item has no description.

Private FInitialized: Boolean;

This item has no description.

Private FDynamic: Boolean;

This item has no description.

Private FIsCalculating: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AbsoluteMatrix: TGLMatrix;

This item has no description.

Public function AbsolutePosition: TAffineVector;

This item has no description.

Public procedure Render(var rci: TGLRenderContextInfo); virtual;

This item has no description.

Properties

Published property Density: TdReal read FDensity write SetDensity;

This item has no description.

Published property Direction: TGLCoordinates read FDirection write SetDirection;

This item has no description.

Public property Geom: PdxGeom read FGeomElement;

This item has no description.

Public property GeomTransform: PdxGeom read FGeomTransform;

This item has no description.

Public property Initialized: Boolean read FInitialized;

This item has no description.

Public property Matrix: TGLMatrix read GetMatrix write SetMatrix;

This item has no description.

Published property Position: TGLCoordinates read FPosition write SetPosition;

This item has no description.

Published property Up: TGLCoordinates read FUp write SetUp;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEElementBox

Class TGLODEElementBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEElementBox = class(TGLODEElementBase)

Description

ODE box implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEElementBase
  • TGLODEElementBox

Overview

Fields

Private | FBoxWidth: TdReal;
Private | FBoxHeight: TdReal;
Private | FBoxDepth: TdReal;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Published | property BoxDepth: TdReal read GetBoxDepth write SetBoxDepth;
Published | property BoxHeight: TdReal read GetBoxHeight write SetBoxHeight;
Published | property BoxWidth: TdReal read GetBoxWidth write SetBoxWidth;

Description

Fields

Private FBoxWidth: TdReal;

This item has no description.

Private FBoxHeight: TdReal;

This item has no description.

Private FBoxDepth: TdReal;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Render(var rci: TGLRenderContextInfo); override;

This item has no description.

Properties

Published property BoxDepth: TdReal read GetBoxDepth write SetBoxDepth;

This item has no description.

Published property BoxHeight: TdReal read GetBoxHeight write SetBoxHeight;

This item has no description.

Published property BoxWidth: TdReal read GetBoxWidth write SetBoxWidth;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEElementSphere

Class TGLODEElementSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEElementSphere = class(TGLODEElementBase)

Description

ODE sphere implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEElementBase
  • TGLODEElementSphere

Overview

Fields

Private FRadius: TdReal;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Published property Radius: TdReal read GetRadius write SetRadius;

Description

Fields

Private FRadius: TdReal;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Render(var rci: TGLRenderContextInfo); override;

This item has no description.

Properties

Published property Radius: TdReal read GetRadius write SetRadius;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEElementCapsule

Class TGLODEElementCapsule

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEElementCapsule = class(TGLODEElementBase)

Description

ODE capped cylinder implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEElementBase
  • TGLODEElementCapsule

Overview

Fields

Private | FRadius: TdReal;
Private | FLength: TdReal;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Published | property Length: TdReal read GetLength write SetLength;
Published | property Radius: TdReal read GetRadius write SetRadius;

Description

Fields

Private FRadius: TdReal;

This item has no description.

Private FLength: TdReal;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Render(var rci: TGLRenderContextInfo); override;

This item has no description.

Properties

Published property Length: TdReal read GetLength write SetLength;

This item has no description.

Published property Radius: TdReal read GetRadius write SetRadius;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEElementCylinder

Class TGLODEElementCylinder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEElementCylinder = class(TGLODEElementBase)

Description

ODE cylinder implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEElementBase
  • TGLODEElementCylinder

Overview

Fields

Private | FRadius: TdReal;
Private | FLength: TdReal;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Published | property Length: TdReal read GetLength write SetLength;
Published | property Radius: TdReal read GetRadius write SetRadius;

Description

Fields

Private FRadius: TdReal;

This item has no description.

Private FLength: TdReal;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Render(var rci: TGLRenderContextInfo); override;

This item has no description.

Properties

Published property Length: TdReal read GetLength write SetLength;

This item has no description.

Published property Radius: TdReal read GetRadius write SetRadius;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEElementTriMesh

Class TGLODEElementTriMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEElementTriMesh = class(TGLODEElementBase)

Description

ODE tri-mesh implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEElementBase
  • TGLODEElementTriMesh

Overview

Fields

Private | FTriMeshData: PdxTriMeshData;
Private | FVertices: TGLAffineVectorList;
Private | FIndices: TGLIntegerList;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure RefreshTriMeshData;

Properties

Public | property Indices: TGLIntegerList read FIndices write SetIndices;
Public | property Vertices: TGLAffineVectorList read FVertices write SetVertices;

Description

Fields

Private FTriMeshData: PdxTriMeshData;

This item has no description.

Private FVertices: TGLAffineVectorList;

This item has no description.

Private FIndices: TGLIntegerList;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure RefreshTriMeshData;

This item has no description.

Properties

Public property Indices: TGLIntegerList read FIndices write SetIndices;

This item has no description.

Public property Vertices: TGLAffineVectorList read FVertices write SetVertices;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEElementPlane

Class TGLODEElementPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEElementPlane = class(TGLODEElementBase)

Description

ODE plane implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEElementBase
  • TGLODEElementPlane

Overview

Methods

Public | class function CanAddTo(collection: TXCollection): Boolean; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;

Description

Methods

Public class function CanAddTo(collection: TXCollection): Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.CanAddTo.

Allows the XCollectionItem class to determine if it should be allowed to be added to the given collection.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJoints

Class TGLODEJoints

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJoints = class(TXCollection)

Description

An XCollection decendant for ODE Joints

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLODEJoints

Overview

Methods

Public | class function ItemsClass: TXCollectionItemClass; override;
Public | procedure Finalize;
Public | procedure Initialize;

Properties

Public property Joint[index: Integer]: TGLODEJointBase read GetJoint;

Description

Methods

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure Finalize;

This item has no description.

Public procedure Initialize;

This item has no description.

Properties

Public property Joint[index: Integer]: TGLODEJointBase read GetJoint;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointList

Class TGLODEJointList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointList = class(TComponent)

Description

Component front-end for storing ODE Joints

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLODEJointList

Overview

Fields

Private FJoints: TGLODEJoints;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property Joints: TGLODEJoints read FJoints;

Description

Fields

Private FJoints: TGLODEJoints;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Joints: TGLODEJoints read FJoints;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointBase

Class TGLODEJointBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointBase = class(TXCollectionItem)

Description

Base structures for ODE Joints

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEJointBase

Overview

Fields

Private | FJointID: TdJointID;
Private | FObject1: TGLBaseSceneObject;
Private | FObject2: TGLBaseSceneObject;
Private | FManager: TGLODEManager;
Private | FObject1Name: String;
Private | FObject2Name: String;
Private | FManagerName: String;
Private | FInitialized: Boolean;
Private | FEnabled: Boolean;
Private | FJointOptions: TGLODEJointOptions;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function IsAttached: Boolean;
Public | procedure DoLoaded;
Public | procedure Finalize; virtual;
Public | procedure Initialize; virtual;
Public | procedure StructureChanged; virtual;

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled;
Public | property Initialized: Boolean read FInitialized;
Public | property JointID: TdJointID read FJointID;
Published | property Manager: TGLODEManager read FManager write SetManager;
Published | property Object1: TGLBaseSceneObject read FObject1 write SetObject1;
Published | property Object2: TGLBaseSceneObject read FObject2 write SetObject2;

Description

Fields

Private FJointID: TdJointID;

This item has no description.

Private FObject1: TGLBaseSceneObject;

This item has no description.

Private FObject2: TGLBaseSceneObject;

This item has no description.

Private FManager: TGLODEManager;

This item has no description.

Private FObject1Name: String;

This item has no description.

Private FObject2Name: String;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FInitialized: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FJointOptions: TGLODEJointOptions;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsAttached: Boolean;

This item has no description.

Public procedure DoLoaded;

This item has no description.

Public procedure Finalize; virtual;

This item has no description.

Public procedure Initialize; virtual;

This item has no description.

Public procedure StructureChanged; virtual;

This item has no description.

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled;

This item has no description.

Public property Initialized: Boolean read FInitialized;

This item has no description.

Public property JointID: TdJointID read FJointID;

This item has no description.

Published property Manager: TGLODEManager read FManager write SetManager;

This item has no description.

Published property Object1: TGLBaseSceneObject read FObject1 write SetObject1;

This item has no description.

Published property Object2: TGLBaseSceneObject read FObject2 write SetObject2;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointParams

Class TGLODEJointParams

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointParams = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLODEJointParams

Overview

Fields

Private | FOwner: TPersistent;
Private | FSetCallback: TGLODESetParamCallback;
Private | FGetCallback: TGLODEGetParamCallback;
Private | FLoStop: TdReal;
Private | FHiStop: TdReal;
Private | FVel: TdReal;
Private | FFMax: TdReal;
Private | FFudgeFactor: TdReal;
Private | FBounce: TdReal;
Private | FCFM: TdReal;
Private | FStopERP: TdReal;
Private | FStopCFM: TdReal;
Private | FSuspensionERP: TdReal;
Private | FSuspensionCFM: TdReal;
Private | FFlagLoStop: Boolean;
Private | FFlagHiStop: Boolean;
Private | FFlagVel: Boolean;
Private | FFlagFMax: Boolean;
Private | FFlagFudgeFactor: Boolean;
Private | FFlagBounce: Boolean;
Private | FFlagCFM: Boolean;
Private | FFlagStopERP: Boolean;
Private | FFlagStopCFM: Boolean;
Private | FFlagSuspensionERP: Boolean;
Private | FFlagSuspensionCFM: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function GetOwner: TPersistent; override;
Public | procedure ApplyFlagged;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Bounce: TdReal read GetBounce write SetBounce;
Published | property CFM: TdReal read GetCFM write SetCFM;
Published | property FMax: TdReal read GetFMax write SetFMax;
Published | property FudgeFactor: TdReal read GetFudgeFactor write SetFudgeFactor;
Public | property GetCallback: TGLODEGetParamCallback read FGetCallback write FGetCallback;
Published | property HiStop: TdReal read GetHiStop write SetHiStop;
Published | property LoStop: TdReal read GetLoStop write SetLoStop;
Public | property SetCallback: TGLODESetParamCallback read FSetCallback write FSetCallback;
Published | property StopCFM: TdReal read GetStopCFM write SetStopCFM;
Published | property StopERP: TdReal read GetStopERP write SetStopERP;
Published | property SuspensionCFM: TdReal read GetSuspensionCFM write SetSuspensionCFM;
Published | property SuspensionERP: TdReal read GetSuspensionERP write SetSuspensionERP;
Published | property Vel: TdReal read GetVel write SetVel;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FSetCallback: TGLODESetParamCallback;

This item has no description.

Private FGetCallback: TGLODEGetParamCallback;

This item has no description.

Private FLoStop: TdReal;

This item has no description.

Private FHiStop: TdReal;

This item has no description.

Private FVel: TdReal;

This item has no description.

Private FFMax: TdReal;

This item has no description.

Private FFudgeFactor: TdReal;

This item has no description.

Private FBounce: TdReal;

This item has no description.

Private FCFM: TdReal;

This item has no description.

Private FStopERP: TdReal;

This item has no description.

Private FStopCFM: TdReal;

This item has no description.

Private FSuspensionERP: TdReal;

This item has no description.

Private FSuspensionCFM: TdReal;

This item has no description.

Private FFlagLoStop: Boolean;

This item has no description.

Private FFlagHiStop: Boolean;

This item has no description.

Private FFlagVel: Boolean;

This item has no description.

Private FFlagFMax: Boolean;

This item has no description.

Private FFlagFudgeFactor: Boolean;

This item has no description.

Private FFlagBounce: Boolean;

This item has no description.

Private FFlagCFM: Boolean;

This item has no description.

Private FFlagStopERP: Boolean;

This item has no description.

Private FFlagStopCFM: Boolean;

This item has no description.

Private FFlagSuspensionERP: Boolean;

This item has no description.

Private FFlagSuspensionCFM: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function GetOwner: TPersistent; override;

This item has no description.

Public procedure ApplyFlagged;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Bounce: TdReal read GetBounce write SetBounce;

This item has no description.

Published property CFM: TdReal read GetCFM write SetCFM;

This item has no description.

Published property FMax: TdReal read GetFMax write SetFMax;

This item has no description.

Published property FudgeFactor: TdReal read GetFudgeFactor write SetFudgeFactor;

This item has no description.

Public property GetCallback: TGLODEGetParamCallback read FGetCallback write FGetCallback;

This item has no description.

Published property HiStop: TdReal read GetHiStop write SetHiStop;

This item has no description.

Published property LoStop: TdReal read GetLoStop write SetLoStop;

This item has no description.

Public property SetCallback: TGLODESetParamCallback read FSetCallback write FSetCallback;

This item has no description.

Published property StopCFM: TdReal read GetStopCFM write SetStopCFM;

This item has no description.

Published property StopERP: TdReal read GetStopERP write SetStopERP;

This item has no description.

Published property SuspensionCFM: TdReal read GetSuspensionCFM write SetSuspensionCFM;

This item has no description.

Published property SuspensionERP: TdReal read GetSuspensionERP write SetSuspensionERP;

This item has no description.

Published property Vel: TdReal read GetVel write SetVel;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointHinge

Class TGLODEJointHinge

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointHinge = class(TGLODEJointBase)

Description

ODE hinge joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEJointBase
  • TGLODEJointHinge

Overview

Fields

Private | FAnchor: TGLCoordinates;
Private | FAxis: TGLCoordinates;
Private | FAxisParams: TGLODEJointParams;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published | property Anchor: TGLCoordinates read FAnchor write SetAnchor;
Published | property Axis: TGLCoordinates read FAxis write SetAxis;
Published | property AxisParams: TGLODEJointParams read FAxisParams write SetAxisParams;

Description

Fields

Private FAnchor: TGLCoordinates;

This item has no description.

Private FAxis: TGLCoordinates;

This item has no description.

Private FAxisParams: TGLODEJointParams;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Anchor: TGLCoordinates read FAnchor write SetAnchor;

This item has no description.

Published property Axis: TGLCoordinates read FAxis write SetAxis;

This item has no description.

Published property AxisParams: TGLODEJointParams read FAxisParams write SetAxisParams;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointBall

Class TGLODEJointBall

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointBall = class(TGLODEJointBase)

Description

ODE ball joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEJointBase
  • TGLODEJointBall

Overview

Fields

Private FAnchor: TGLCoordinates;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published property Anchor: TGLCoordinates read FAnchor write SetAnchor;

Description

Fields

Private FAnchor: TGLCoordinates;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Anchor: TGLCoordinates read FAnchor write SetAnchor;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointSlider

Class TGLODEJointSlider

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointSlider = class(TGLODEJointBase)

Description

ODE slider joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEJointBase
  • TGLODEJointSlider

Overview

Fields

Private | FAxis: TGLCoordinates;
Private | FAxisParams: TGLODEJointParams;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published | property Axis: TGLCoordinates read FAxis write SetAxis;
Published | property AxisParams: TGLODEJointParams read FAxisParams write SetAxisParams;

Description

Fields

Private FAxis: TGLCoordinates;

This item has no description.

Private FAxisParams: TGLODEJointParams;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Axis: TGLCoordinates read FAxis write SetAxis;

This item has no description.

Published property AxisParams: TGLODEJointParams read FAxisParams write SetAxisParams;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointFixed

Class TGLODEJointFixed

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointFixed = class(TGLODEJointBase)

Description

ODE fixed joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEJointBase
  • TGLODEJointFixed

Overview

Methods

Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;

Description

Methods

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointHinge2

Class TGLODEJointHinge2

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointHinge2 = class(TGLODEJointBase)

Description

ODE hinge2 joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEJointBase
  • TGLODEJointHinge2

Overview

Fields

Private | FAnchor: TGLCoordinates;
Private | FAxis1: TGLCoordinates;
Private | FAxis2: TGLCoordinates;
Private | FAxis1Params: TGLODEJointParams;
Private | FAxis2Params: TGLODEJointParams;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published | property Anchor: TGLCoordinates read FAnchor write SetAnchor;
Published | property Axis1: TGLCoordinates read FAxis1 write SetAxis1;
Published | property Axis1Params: TGLODEJointParams read FAxis1Params write SetAxis1Params;
Published | property Axis2: TGLCoordinates read FAxis2 write SetAxis2;
Published | property Axis2Params: TGLODEJointParams read FAxis2Params write SetAxis2Params;

Description

Fields

Private FAnchor: TGLCoordinates;

This item has no description.

Private FAxis1: TGLCoordinates;

This item has no description.

Private FAxis2: TGLCoordinates;

This item has no description.

Private FAxis1Params: TGLODEJointParams;

This item has no description.

Private FAxis2Params: TGLODEJointParams;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Anchor: TGLCoordinates read FAnchor write SetAnchor;

This item has no description.

Published property Axis1: TGLCoordinates read FAxis1 write SetAxis1;

This item has no description.

Published property Axis1Params: TGLODEJointParams read FAxis1Params write SetAxis1Params;

This item has no description.

Published property Axis2: TGLCoordinates read FAxis2 write SetAxis2;

This item has no description.

Published property Axis2Params: TGLODEJointParams read FAxis2Params write SetAxis2Params;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEJointUniversal

Class TGLODEJointUniversal

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEJointUniversal = class(TGLODEJointBase)

Description

ODE universal joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLODEJointBase
  • TGLODEJointUniversal

Overview

Fields

Private | FAnchor: TGLCoordinates;
Private | FAxis1: TGLCoordinates;
Private | FAxis2: TGLCoordinates;
Private | FAxis1Params: TGLODEJointParams;
Private | FAxis2Params: TGLODEJointParams;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published | property Anchor: TGLCoordinates read FAnchor write SetAnchor;
Published | property Axis1: TGLCoordinates read FAxis1 write SetAxis1;
Published | property Axis1Params: TGLODEJointParams read FAxis1Params write SetAxis1Params;
Published | property Axis2: TGLCoordinates read FAxis2 write SetAxis2;
Published | property Axis2Params: TGLODEJointParams read FAxis2Params write SetAxis2Params;

Description

Fields

Private FAnchor: TGLCoordinates;

This item has no description.

Private FAxis1: TGLCoordinates;

This item has no description.

Private FAxis2: TGLCoordinates;

This item has no description.

Private FAxis1Params: TGLODEJointParams;

This item has no description.

Private FAxis2Params: TGLODEJointParams;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Anchor: TGLCoordinates read FAnchor write SetAnchor;

This item has no description.

Published property Axis1: TGLCoordinates read FAxis1 write SetAxis1;

This item has no description.

Published property Axis1Params: TGLODEJointParams read FAxis1Params write SetAxis1Params;

This item has no description.

Published property Axis2: TGLCoordinates read FAxis2 write SetAxis2;

This item has no description.

Published property Axis2Params: TGLODEJointParams read FAxis2Params write SetAxis2Params;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEContactPoint

Class TGLODEContactPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEContactPoint = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLODEContactPoint

Overview

Fields

Public | Position: TAffineVector;
Public | Normal: TAffineVector;
Public | Depth: Single;

Description

Fields

Public Position: TAffineVector;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Public Depth: Single;


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODECustomCollider

Class TGLODECustomCollider

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODECustomCollider = class(TGLODEBehaviour)

Description

The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms. Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour
  • TGLODECustomCollider

Overview

Fields

Private | FGeom: PdxGeom;
Private | FContactList: TList;
Private | FContactCache: TList;
Private | FTransform: TGLMatrix;
Private | FContactResolution: Single;
Private | FRenderContacts: Boolean;
Private | FContactRenderPoints: TGLAffineVectorList;
Private | FPointSize: Single;
Private | FContactColor: TGLColor;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Published | property ContactColor: TGLColor read FContactColor write SetContactColor;
Published | property ContactResolution: Single read FContactResolution write SetContactResolution;
Public | property Geom: PdxGeom read FGeom;
Published | property PointSize: Single read FPointSize write SetPointSize;
Published | property RenderContacts: Boolean read FRenderContacts write SetRenderContacts;

Description

Fields

Private FGeom: PdxGeom;

This item has no description.

Private FContactList: TList;

This item has no description.

Private FContactCache: TList;

This item has no description.

Private FTransform: TGLMatrix;

This item has no description.

Private FContactResolution: Single;

This item has no description.

Private FRenderContacts: Boolean;

This item has no description.

Private FContactRenderPoints: TGLAffineVectorList;

This item has no description.

Private FPointSize: Single;

This item has no description.

Private FContactColor: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Render(var rci: TGLRenderContextInfo); override;

This item has no description.

Properties

Published property ContactColor: TGLColor read FContactColor write SetContactColor;

Contact point rendering color.

Published property ContactResolution: Single read FContactResolution write SetContactResolution;

Defines the resolution of the contact points created for the colliding Geom. The number of contact points generated change base don the size of the object and the ContactResolution. Lower values generate higher resolution contact boundaries, and thus smoother but slower collisions.

Public property Geom: PdxGeom read FGeom;

This item has no description.

Published property PointSize: Single read FPointSize write SetPointSize;

Contact point rendering size (in pixels).

Published property RenderContacts: Boolean read FRenderContacts write SetRenderContacts;

Toggle contact point rendering on and off. (Rendered through the assigned Manager.RenderPoint.


GLSysHelp v.2.5: GLS.ODEManager: Class TGLODEHeightField

Class TGLODEHeightField

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODEManager

Declaration

type TGLODEHeightField = class(TGLODECustomCollider)

Description

Add this behaviour to a TGLHeightField or TGLTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour
  • TGLODECustomCollider
  • TGLODEHeightField

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function CanAddTo(collection: TXCollection): Boolean; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: Boolean; override;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function CanAddTo(collection: TXCollection): Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.CanAddTo.

Allows the XCollectionItem class to determine if it should be allowed to be added to the given collection.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.


GLSysHelp v.2.5: GLS.ODERagdoll

Unit GLS.ODERagdoll

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Ragdoll
  • GLS.Scene
  • GLS.Objects
  • GLS.Texture
  • GLS.VectorFileObjects
  • ODE.Import
  • GLS.ODEUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLODERagdollCube |
Class TGLODERagdollWorld |
Class TGLODERagdollDummyJoint |
Class TGLODERagdollHingeJoint |
Class TGLODERagdollUniversalJoint |
Class TGLODERagdollBone |
Class TGLODERagdoll |

Constants

cMaxContacts = 4;

Variables

vODERagdoll_cDensity: Single;
vODERagdoll_cMass: Single;

Description

Constants

cMaxContacts = 4;

This item has no description.

Variables

vODERagdoll_cDensity: Single;

This item has no description.

vODERagdoll_cMass: Single;


GLSysHelp v.2.5: GLS.ODERagdoll: Class TGLODERagdollCube

Class TGLODERagdollCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODERagdoll

Declaration

type TGLODERagdollCube = class(TGLCube)

Description

This item has no description. Showing description inherited from TGLCube.

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TGLFreeForm and a material library. Ref: https://mathworld.wolfram.com/Cube.html

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLCube
  • TGLODERagdollCube

Overview

Fields

Public | Bone: TGLODERagdollBone;
Public | Ragdoll: TGLODERagdoll;

Description

Fields

Public Bone: TGLODERagdollBone;

This item has no description.

Public Ragdoll: TGLODERagdoll;

Useful in Oncollision Event


GLSysHelp v.2.5: GLS.ODERagdoll: Class TGLODERagdollWorld

Class TGLODERagdollWorld

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODERagdoll

Declaration

type TGLODERagdollWorld = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLODERagdollWorld

Overview

Fields

Private | FSpace: PdxSpace;
Private | FWorld: PdxWorld;
Private | FContactGroup: TdJointGroupID;
Private | FRagdoll: TGLODERagdoll;
Private | isWorldCreated: Boolean;

Methods

Public | constructor Create;
Public | constructor CreateFrom(World: PdxWorld; Space: PdxSpace; ContactGroup: TdJointGroupID);
Public | destructor Destroy; override;
Public | procedure WorldUpdate;

Properties

Public | property ContactGroup: TdJointGroupID read FContactGroup;
Public | property Ragdoll: TGLODERagdoll read FRagdoll;
Public | property Space: PdxSpace read FSpace;
Public | property World: PdxWorld read FWorld;

Description

Fields

Private FSpace: PdxSpace;

This item has no description.

Private FWorld: PdxWorld;

This item has no description.

Private FContactGroup: TdJointGroupID;

This item has no description.

Private FRagdoll: TGLODERagdoll;

This item has no description.

Private isWorldCreated: Boolean;

This item has no description.

Methods

Public constructor Create;

NEW1

Public constructor CreateFrom(World: PdxWorld; Space: PdxSpace; ContactGroup: TdJointGroupID);

Create the world from any existing ODE world

Public destructor Destroy; override;

This item has no description.

Public procedure WorldUpdate;

This item has no description.

Properties

Public property ContactGroup: TdJointGroupID read FContactGroup;

This item has no description.

Public property Ragdoll: TGLODERagdoll read FRagdoll;

This item has no description.

Public property Space: PdxSpace read FSpace;

This item has no description.

Public property World: PdxWorld read FWorld;


GLSysHelp v.2.5: GLS.ODERagdoll: Class TGLODERagdollDummyJoint

Class TGLODERagdollDummyJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODERagdoll

Declaration

type TGLODERagdollDummyJoint = class(TGLRagdolJoint)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLRagdolJoint
  • TGLODERagdollDummyJoint


GLSysHelp v.2.5: GLS.ODERagdoll: Class TGLODERagdollHingeJoint

Class TGLODERagdollHingeJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODERagdoll

Declaration

type TGLODERagdollHingeJoint = class(TGLRagdolJoint)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLRagdolJoint
  • TGLODERagdollHingeJoint

Overview

Fields

Private | FParamHiStop: Single;
Private | FParamLoStop: Single;
Private | FAxis: TAffineVector;

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single);

Properties

Public | property Axis: TAffineVector read FAxis;
Public | property ParamHiStop: Single read FParamHiStop write FParamHiStop;
Public | property ParamLoStop: Single read FParamLoStop write FParamLoStop;

Description

Fields

Private FParamHiStop: Single;

This item has no description.

Private FParamLoStop: Single;

This item has no description.

Private FAxis: TAffineVector;

This item has no description.

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single);

This item has no description.

Properties

Public property Axis: TAffineVector read FAxis;

This item has no description.

Public property ParamHiStop: Single read FParamHiStop write FParamHiStop;

This item has no description.

Public property ParamLoStop: Single read FParamLoStop write FParamLoStop;


GLSysHelp v.2.5: GLS.ODERagdoll: Class TGLODERagdollUniversalJoint

Class TGLODERagdollUniversalJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODERagdoll

Declaration

type TGLODERagdollUniversalJoint = class(TGLODERagdollHingeJoint)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLRagdolJoint
  • TGLODERagdollHingeJoint
  • TGLODERagdollUniversalJoint

Overview

Fields

Private | FParamHiStop2: Single;
Private | FParamLoStop2: Single;
Private | FAxis2: TAffineVector;

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single; Axis2: TAffineVector; ParamLoStop2: Single; ParamHiStop2: Single);

Properties

Public | property Axis2: TAffineVector read FAxis2;
Public | property ParamHiStop2: Single read FParamHiStop2 write FParamHiStop2;
Public | property ParamLoStop2: Single read FParamLoStop2 write FParamLoStop2;

Description

Fields

Private FParamHiStop2: Single;

This item has no description.

Private FParamLoStop2: Single;

This item has no description.

Private FAxis2: TAffineVector;

This item has no description.

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single; Axis2: TAffineVector; ParamLoStop2: Single; ParamHiStop2: Single);

This item has no description.

Properties

Public property Axis2: TAffineVector read FAxis2;

This item has no description.

Public property ParamHiStop2: Single read FParamHiStop2 write FParamHiStop2;

This item has no description.

Public property ParamLoStop2: Single read FParamLoStop2 write FParamLoStop2;


GLSysHelp v.2.5: GLS.ODERagdoll: Class TGLODERagdollBone

Class TGLODERagdollBone

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODERagdoll

Declaration

type TGLODERagdollBone = class(TGLRagdolBone)

Description

This item has no description.

Hierarchy

  • TGLPersistentObjectList
  • TGLRagdolBoneList
  • TGLRagdolBone
  • TGLODERagdollBone

Overview

Fields

Private | FOwner: TGLODERagdollBone;
Private | FRagdoll: TGLODERagdoll;
Private | FBody: PdxBody;
Private | FGeom: PdxGeom;
Private | FJointId: TdJointID;

Methods

Public | constructor Create(Ragdoll: TGLODERagdoll);
Public | constructor CreateOwned(aOwner: TGLODERagdollBone);
Private | procedure AlignBodyToMatrix(Mat: TGLMatrix);

Properties

Public | property Body: PdxBody read FBody;
Public | property Geom: PdxGeom read FGeom;

Description

Fields

Private FOwner: TGLODERagdollBone;

This item has no description.

Private FRagdoll: TGLODERagdoll;

This item has no description.

Private FBody: PdxBody;

This item has no description.

Private FGeom: PdxGeom;

This item has no description.

Private FJointId: TdJointID;

This item has no description.

Methods

Public constructor Create(Ragdoll: TGLODERagdoll);

This item has no description.

Public constructor CreateOwned(aOwner: TGLODERagdollBone);

This item has no description.

Private procedure AlignBodyToMatrix(Mat: TGLMatrix);

This item has no description.

Properties

Public property Body: PdxBody read FBody;

This item has no description.

Public property Geom: PdxGeom read FGeom;


GLSysHelp v.2.5: GLS.ODERagdoll: Class TGLODERagdoll

Class TGLODERagdoll

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODERagdoll

Declaration

type TGLODERagdoll = class(TGLRagdoll)

Description

This item has no description.

Hierarchy

  • TGLPersistentObject
  • TGLRagdoll
  • TGLODERagdoll

Overview

Fields

Private | FODEWorld: TGLODERagdollWorld;
Private | FGLSceneRoot: TGLBaseSceneObject;
Private | FShowBoundingBoxes: Boolean;
Private | FEnabled: Boolean;

Methods

Public constructor Create(aOwner: TGLBaseMesh);

Properties

Public | property Enabled: Boolean read FEnabled write FEnabled;
Public | property GLSceneRoot: TGLBaseSceneObject read FGLSceneRoot write FGLSceneRoot;
Public | property ODEWorld: TGLODERagdollWorld read FODEWorld write FODEWorld;
Public | property ShowBoundingBoxes: Boolean read FShowBoundingBoxes write FShowBoundingBoxes;

Description

Fields

Private FODEWorld: TGLODERagdollWorld;

This item has no description.

Private FGLSceneRoot: TGLBaseSceneObject;

This item has no description.

Private FShowBoundingBoxes: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Methods

Public constructor Create(aOwner: TGLBaseMesh);

This item has no description.

Properties

Public property Enabled: Boolean read FEnabled write FEnabled;

This item has no description.

Public property GLSceneRoot: TGLBaseSceneObject read FGLSceneRoot write FGLSceneRoot;

This item has no description.

Public property ODEWorld: TGLODERagdollWorld read FODEWorld write FODEWorld;

This item has no description.

Public property ShowBoundingBoxes: Boolean read FShowBoundingBoxes write FShowBoundingBoxes;


GLSysHelp v.2.5: GLS.ODESkeletonColliders

Unit GLS.ODESkeletonColliders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorTypes
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.VectorFileObjects
  • ODE.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSCODEBase |
Class TSCODESphere |
Class TSCODECCylinder |
Class TSCODEBox |

Functions and Procedures

procedure AddSCODEGeomsToODESpace(colliders: TGLSkeletonColliderList; Space: PdxSpace);

Description

Functions and Procedures

procedure AddSCODEGeomsToODESpace(colliders: TGLSkeletonColliderList; Space: PdxSpace);

After loading call this function to add all the geoms in a skeleton collider list to a given ODE space


GLSysHelp v.2.5: GLS.ODESkeletonColliders: Class TSCODEBase

Class TSCODEBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODESkeletonColliders

Declaration

type TSCODEBase = class(TGLSkeletonCollider)

Description

Base ODE skeleton collider class

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonCollider
  • TSCODEBase

Overview

Fields

Private FGeom: PdxGeom;

Methods

Public | procedure AddToSpace(Space: PdxSpace); virtual;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public property Geom: PdxGeom read FGeom;

Description

Fields

Private FGeom: PdxGeom;

This item has no description.

Methods

Public procedure AddToSpace(Space: PdxSpace); virtual;

This item has no description.

Public procedure AlignCollider; override;

This item has no description. Showing description inherited from TGLSkeletonCollider.AlignCollider.

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Geom: PdxGeom read FGeom;

The geoms are created through the AddToSpace procedure


GLSysHelp v.2.5: GLS.ODESkeletonColliders: Class TSCODESphere

Class TSCODESphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODESkeletonColliders

Declaration

type TSCODESphere = class(TSCODEBase)

Description

Sphere shaped ODE geom in a skeleton collider

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonCollider
  • TSCODEBase
  • TSCODESphere

Overview

Fields

Private FRadius: TdReal;

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space: PdxSpace); override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public property Radius: TdReal read FRadius write SetRadius;

Description

Fields

Private FRadius: TdReal;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToSpace(Space: PdxSpace); override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Radius: TdReal read FRadius write SetRadius;


GLSysHelp v.2.5: GLS.ODESkeletonColliders: Class TSCODECCylinder

Class TSCODECCylinder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODESkeletonColliders

Declaration

type TSCODECCylinder = class(TSCODEBase)

Description

Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonCollider
  • TSCODEBase
  • TSCODECCylinder

Overview

Fields

Private | FRadius: Single;
Private | FLength: Single;

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space: PdxSpace); override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Length: Single read FLength write SetLength;
Public | property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FRadius: Single;

This item has no description.

Private FLength: Single;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToSpace(Space: PdxSpace); override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Length: Single read FLength write SetLength;

This item has no description.

Public property Radius: Single read FRadius write SetRadius;


GLSysHelp v.2.5: GLS.ODESkeletonColliders: Class TSCODEBox

Class TSCODEBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ODESkeletonColliders

Declaration

type TSCODEBox = class(TSCODEBase)

Description

Box shaped ODE geom in a skeleton collider

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonCollider
  • TSCODEBase
  • TSCODEBox

Overview

Fields

Private | FBoxWidth: TdReal;
Private | FBoxHeight: TdReal;
Private | FBoxDepth: TdReal;

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space: PdxSpace); override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property BoxDepth: TdReal read FBoxDepth write SetBoxDepth;
Public | property BoxHeight: TdReal read FBoxHeight write SetBoxHeight;
Public | property BoxWidth: TdReal read FBoxWidth write SetBoxWidth;

Description

Fields

Private FBoxWidth: TdReal;

This item has no description.

Private FBoxHeight: TdReal;

This item has no description.

Private FBoxDepth: TdReal;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToSpace(Space: PdxSpace); override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property BoxDepth: TdReal read FBoxDepth write SetBoxDepth;

This item has no description.

Public property BoxHeight: TdReal read FBoxHeight write SetBoxHeight;

This item has no description.

Public property BoxWidth: TdReal read FBoxWidth write SetBoxWidth;


GLSysHelp v.2.5: GLS.ODEUtils

Unit GLS.ODEUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.SysUtils
  • System.Classes
  • ODE.Import
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.Context
  • GLS.PersistentClasses
  • GLS.VectorLists
  • GLS.Coordinates
  • GLS.Objects
  • GLS.VerletClothify
  • GLS.VectorFileObjects

Overview

Functions and Procedures

procedure DrawBox(Sides: TdVector3);
procedure setTransform(pos: TdVector3; R: TdMatrix3);
procedure dsDrawBox(pos: PdVector3; R: PdMatrix3; Sides: TdVector3); overload;
procedure dsDrawBox(pos: TdVector3; R: TdMatrix3; Sides: TdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TGLMatrix; R: TdMatrix3; pos: TdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TGLMatrix; R: PdMatrix3; pos: PdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TGLMatrix; R: TdMatrix3_As3x4; pos: TdVector3); overload;
function GLSceneMatrixToODER(m: TGLMatrix): TdMatrix3;
function ConvertdVector3ToVector3f(R: TdVector3): TVector3f; overload;
function ConvertdVector3ToVector3f(R: PdVector3): TVector3f; overload;
function ConvertdVector3ToVector4f(R: TdVector3): TVector4f; overload;
function ConvertdVector3ToVector4f(R: PdVector3): TVector4f; overload;
function ConvertdVector3ToAffineVector(R: PdVector3): TAffineVector; overload;
function ConvertdVector3ToAffineVector(R: TdVector3): TAffineVector; overload;
function GetBodyPositionAsAffineVector(Body: PdxBody): TAffineVector;
function ConvertVector3fTodVector3(R: TVector3f): TdVector3;
function ConvertVector3fToPdVector3(R: TVector3f): PdVector3;
function ConvertVector4fTodVector3(R: TVector4f): TdVector3;
function ConvertVector4fToPdVector3(R: TVector4f): PdVector3;
function dVector3Length(R: TdVector3): single; overload;
function dVector3Length(R: PdVector3): single; overload;
function dBodyToBodyDistance(Body1, Body2: PdxBody): TdReal;
procedure CopyPosFromGeomToGL(Geom: PdxGeom; GLBaseSceneObject: TGLBaseSceneObject);
procedure PositionSceneObject(GLBaseSceneObject: TGLBaseSceneObject; Geom: PdxGeom);
procedure PositionSceneObjectForGeom(Geom: PdxGeom);
procedure CopyCubeSizeFromBox(Cube: TGLCube; Geom: PdxGeom);
procedure CopyBodyFromCube(Body: PdxBody; var Geom: PdxGeom; Cube: TGLCube; Space: PdxSpace);
function CreateGeomFromCube(Cube: TGLCube; Space: PdxSpace): PdxGeom;
function CreateBodyFromCube(var Geom: PdxGeom; Cube: TGLCube; World: PdxWorld; Space: PdxSpace): PdxBody;
function CreateTriMeshFromBaseMesh(GLBaseMesh: TGLBaseMesh; Space: PdxSpace; var Vertices: PdVector3Array; var Indices: PdIntegerArray): PdxGeom;
function GLMatrixFromGeom(Geom: PdxGeom): TGLMatrix;
function GLDirectionFromGeom(Geom: PdxGeom): TGLVector;
function CreateODEPlaneFromGLPlane(Plane: TGLPlane; Space: PdxSpace): PdxGeom;
procedure RenderGeomList(GeomList: TGeomList);
function RandomColorVector: TGLVector;

Description

Functions and Procedures

procedure DrawBox(Sides: TdVector3);

This item has no description.

procedure setTransform(pos: TdVector3; R: TdMatrix3);

This item has no description.

procedure dsDrawBox(pos: PdVector3; R: PdMatrix3; Sides: TdVector3); overload;

This item has no description.

procedure dsDrawBox(pos: TdVector3; R: TdMatrix3; Sides: TdVector3); overload;

This item has no description.

procedure ODERToGLSceneMatrix(var m: TGLMatrix; R: TdMatrix3; pos: TdVector3); overload;

This item has no description.

procedure ODERToGLSceneMatrix(var m: TGLMatrix; R: PdMatrix3; pos: PdVector3); overload;

This item has no description.

procedure ODERToGLSceneMatrix(var m: TGLMatrix; R: TdMatrix3_As3x4; pos: TdVector3); overload;

This item has no description.

function GLSceneMatrixToODER(m: TGLMatrix): TdMatrix3;

This item has no description.

function ConvertdVector3ToVector3f(R: TdVector3): TVector3f; overload;

Converting between ODE and GLScene formats

function ConvertdVector3ToVector3f(R: PdVector3): TVector3f; overload;

This item has no description.

function ConvertdVector3ToVector4f(R: TdVector3): TVector4f; overload;

This item has no description.

function ConvertdVector3ToVector4f(R: PdVector3): TVector4f; overload;

This item has no description.

function ConvertdVector3ToAffineVector(R: PdVector3): TAffineVector; overload;

This item has no description.

function ConvertdVector3ToAffineVector(R: TdVector3): TAffineVector; overload;

This item has no description.

function GetBodyPositionAsAffineVector(Body: PdxBody): TAffineVector;

This item has no description.

function ConvertVector3fTodVector3(R: TVector3f): TdVector3;

Converting between GLScene and ODE formats

function ConvertVector3fToPdVector3(R: TVector3f): PdVector3;

This item has no description.

function ConvertVector4fTodVector3(R: TVector4f): TdVector3;

This item has no description.

function ConvertVector4fToPdVector3(R: TVector4f): PdVector3;

This item has no description.

function dVector3Length(R: TdVector3): single; overload;

This item has no description.

function dVector3Length(R: PdVector3): single; overload;

This item has no description.

function dBodyToBodyDistance(Body1, Body2: PdxBody): TdReal;

This item has no description.

procedure CopyPosFromGeomToGL(Geom: PdxGeom; GLBaseSceneObject: TGLBaseSceneObject);

This item has no description.

procedure PositionSceneObject(GLBaseSceneObject: TGLBaseSceneObject; Geom: PdxGeom);

This item has no description.

procedure PositionSceneObjectForGeom(Geom: PdxGeom);

This item has no description.

procedure CopyCubeSizeFromBox(Cube: TGLCube; Geom: PdxGeom);

This item has no description.

procedure CopyBodyFromCube(Body: PdxBody; var Geom: PdxGeom; Cube: TGLCube; Space: PdxSpace);

This item has no description.

function CreateGeomFromCube(Cube: TGLCube; Space: PdxSpace): PdxGeom;

This item has no description.

function CreateBodyFromCube(var Geom: PdxGeom; Cube: TGLCube; World: PdxWorld; Space: PdxSpace): PdxBody;

This item has no description.

function CreateTriMeshFromBaseMesh(GLBaseMesh: TGLBaseMesh; Space: PdxSpace; var Vertices: PdVector3Array; var Indices: PdIntegerArray): PdxGeom;

This method requires you to manually deallocate vertices and indices when you're done with the trimesh

function GLMatrixFromGeom(Geom: PdxGeom): TGLMatrix;

This item has no description.

function GLDirectionFromGeom(Geom: PdxGeom): TGLVector;

This item has no description.

function CreateODEPlaneFromGLPlane(Plane: TGLPlane; Space: PdxSpace): PdxGeom;

This item has no description.

procedure RenderGeomList(GeomList: TGeomList);

This item has no description.

function RandomColorVector: TGLVector;


GLSysHelp v.2.5: GLS.OpenGLAdapter

Unit GLS.OpenGLAdapter

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.Strings
  • GLScene.Logger
  • GLScene.VectorGeometry
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EOpenGLError |
Class TGLExtensionsAndEntryPoints |

Functions and Procedures

function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: cardinal): BOOL; stdcall; external opengl32;
function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;
function wglCreateLayerContext(p1: HDC; p2: integer): HGLRC; stdcall; external opengl32;
function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;
function wglGetCurrentContext: HGLRC; stdcall; external opengl32;
function wglGetCurrentDC: HDC; stdcall; external opengl32;
function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;
function wglRealizeLayerPalette(p1: HDC; p2: integer; p3: BOOL): BOOL; stdcall; external opengl32;
function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;
function wglSwapLayerBuffers(p1: HDC; p2: cardinal): BOOL; stdcall; external opengl32;
function gluErrorString(errCode: Cardinal): PAnsiChar; stdcall; external glu32;
function gluGetString(Name: Cardinal): PAnsiChar; stdcall; external glu32;
procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;
procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;
procedure gluPickMatrix(X, y, Width, Height: TGLdouble; const Viewport: TVector4i); stdcall; external glu32;
procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;
function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;
function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;
function gluScaleImage(format: Cardinal; widthin, heightin: TGLint; typein: Cardinal; datain: Pointer; widthout, heightout: TGLint; typeout: Cardinal; dataout: Pointer): TGLint; stdcall; external glu32;
function gluBuild1DMipmaps(target: Cardinal; Components, Width: TGLint; format, atype: Cardinal; Data: Pointer): TGLint; stdcall; external glu32;
function gluBuild2DMipmaps(target: Cardinal; Components, Width, Height: TGLint; format, atype: Cardinal; Data: Pointer): TGLint; stdcall; external glu32;
function gluNewQuadric: PGLUquadric; stdcall; external glu32;
procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;
procedure gluQuadricNormals(quadObject: PGLUquadric; normals: Cardinal); stdcall; external glu32;
procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;
procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: Cardinal); stdcall; external glu32;
procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: Cardinal); stdcall; external glu32;
procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, Height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;
procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;
procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluQuadricCallback(quadObject: PGLUquadric; which: Cardinal; fn: TGLUQuadricErrorProc); stdcall; external glu32;
function gluNewTess: PGLUtesselator; stdcall; external glu32;
procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;
procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; Data: Pointer); stdcall; external glu32;
procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessProperty(tess: PGLUtesselator; which: Cardinal; Value: TGLdouble); stdcall; external glu32;
procedure gluTessNormal(tess: PGLUtesselator; X, y, z: TGLdouble); stdcall; external glu32;
procedure gluTessCallback(tess: PGLUtesselator; which: Cardinal; fn: Pointer); stdcall; external glu32;
procedure gluGetTessProperty(tess: PGLUtesselator; which: Cardinal; Value: PGLdouble); stdcall; external glu32;
function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;
procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluPwlCurve(nobj: PGLUnurbs; Count: TGLint; points: PGLfloat; stride: TGLint; atype: Cardinal); stdcall; external glu32;
procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: Cardinal); stdcall; external glu32;
procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: Cardinal); stdcall; external glu32;
procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const Viewport: TVector4i); stdcall; external glu32;
procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; Value: TGLfloat); stdcall; external glu32;
procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; Value: PGLfloat); stdcall; external glu32;
procedure gluNurbsCallback(nobj: PGLUnurbs; which: Cardinal; fn: TGLUNurbsErrorProc); stdcall; external glu32;
procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluNextContour(tess: PGLUtesselator; atype: Cardinal); stdcall; external glu32;
procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
function GetProcAddressGLLib(ProcName: PAnsiChar): Pointer;
function GetProcAddressGLS(ProcName: PAnsiChar): Pointer;
procedure CloseOpenGL;
function InitOpenGL: boolean;
function InitOpenGLFromLibrary(const GLName, GLUName: string): boolean;
function IsOpenGLInitialized: boolean;
procedure UnloadOpenGL;
function LoadOpenGL: boolean;
function LoadOpenGLFromLibrary(GLName, GLUName: string): boolean;
function IsOpenGLLoaded: boolean;
function IsMesaGL: boolean;
procedure TrimAndSplitVersionString(buffer: string; var max, min: integer);
function IsVersionMet(MajorVersion, MinorVersion, actualMajorVersion, actualMinorVersion: integer): boolean;

Constants

opengl32 = 'OpenGL32.dll';
glu32 = 'GLU32.dll';

Description

Functions and Procedures

function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: cardinal): BOOL; stdcall; external opengl32;

TGLExtensionsAndEntryPoints —————————— Windows OpenGL (WGL) support functions {$IFDEF SUPPORT_WGL} function wglGetProcAddress(ProcName: PAnsiChar): Pointer; stdcall; external opengl32;

function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;

This item has no description.

function wglCreateLayerContext(p1: HDC; p2: integer): HGLRC; stdcall; external opengl32;

This item has no description.

function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;

This item has no description.

function wglGetCurrentContext: HGLRC; stdcall; external opengl32;

function wglDescribeLayerPlane(p1: HDC; p2, p3: integer; p4: cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;

function wglGetCurrentDC: HDC; stdcall; external opengl32;

This item has no description.

function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;

function wglRealizeLayerPalette(p1: HDC; p2: integer; p3: BOOL): BOOL; stdcall; external opengl32;

This item has no description.

function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;

function wglSwapLayerBuffers(p1: HDC; p2: cardinal): BOOL; stdcall; external opengl32;

This item has no description.

function gluErrorString(errCode: Cardinal): PAnsiChar; stdcall; external glu32;

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32; function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 Name 'wglUseFontBitmapsA'; function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 Name 'wglUseFontOutlinesA';

function gluGetString(Name: Cardinal): PAnsiChar; stdcall; external glu32;

This item has no description.

procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPickMatrix(X, y, Width, Height: TGLdouble; const Viewport: TVector4i); stdcall; external glu32;

This item has no description.

procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;

This item has no description.

function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;

This item has no description.

function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;

This item has no description.

function gluScaleImage(format: Cardinal; widthin, heightin: TGLint; typein: Cardinal; datain: Pointer; widthout, heightout: TGLint; typeout: Cardinal; dataout: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluBuild1DMipmaps(target: Cardinal; Components, Width: TGLint; format, atype: Cardinal; Data: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluBuild2DMipmaps(target: Cardinal; Components, Width, Height: TGLint; format, atype: Cardinal; Data: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluNewQuadric: PGLUquadric; stdcall; external glu32;

This item has no description.

procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;

This item has no description.

procedure gluQuadricNormals(quadObject: PGLUquadric; normals: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;

This item has no description.

procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, Height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

This item has no description.

procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;

This item has no description.

procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

This item has no description.

procedure gluQuadricCallback(quadObject: PGLUquadric; which: Cardinal; fn: TGLUQuadricErrorProc); stdcall; external glu32;

This item has no description.

function gluNewTess: PGLUtesselator; stdcall; external glu32;

This item has no description.

procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;

This item has no description.

procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; Data: Pointer); stdcall; external glu32;

This item has no description.

procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessProperty(tess: PGLUtesselator; which: Cardinal; Value: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluTessNormal(tess: PGLUtesselator; X, y, z: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluTessCallback(tess: PGLUtesselator; which: Cardinal; fn: Pointer); stdcall; external glu32;

This item has no description.

procedure gluGetTessProperty(tess: PGLUtesselator; which: Cardinal; Value: PGLdouble); stdcall; external glu32;

This item has no description.

function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;

This item has no description.

procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluPwlCurve(nobj: PGLUnurbs; Count: TGLint; points: PGLfloat; stride: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const Viewport: TVector4i); stdcall; external glu32;

This item has no description.

procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; Value: TGLfloat); stdcall; external glu32;

This item has no description.

procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; Value: PGLfloat); stdcall; external glu32;

This item has no description.

procedure gluNurbsCallback(nobj: PGLUnurbs; which: Cardinal; fn: TGLUNurbsErrorProc); stdcall; external glu32;

This item has no description.

procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluNextContour(tess: PGLUtesselator; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

function GetProcAddressGLLib(ProcName: PAnsiChar): Pointer;

This item has no description.

function GetProcAddressGLS(ProcName: PAnsiChar): Pointer;

This item has no description.

procedure CloseOpenGL;

This item has no description.

function InitOpenGL: boolean;

This item has no description.

function InitOpenGLFromLibrary(const GLName, GLUName: string): boolean;

This item has no description.

function IsOpenGLInitialized: boolean;

This item has no description.

procedure UnloadOpenGL;

compatibility routines

function LoadOpenGL: boolean;

This item has no description.

function LoadOpenGLFromLibrary(GLName, GLUName: string): boolean;

This item has no description.

function IsOpenGLLoaded: boolean;

This item has no description.

function IsMesaGL: boolean;

This item has no description.

procedure TrimAndSplitVersionString(buffer: string; var max, min: integer);

This item has no description.

function IsVersionMet(MajorVersion, MinorVersion, actualMajorVersion, actualMinorVersion: integer): boolean;

This item has no description.

Constants

opengl32 = 'OpenGL32.dll';

This item has no description.

glu32 = 'GLU32.dll';


GLSysHelp v.2.5: GLS.OpenGLAdapter: Class EOpenGLError

Class EOpenGLError

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.OpenGLAdapter

Declaration

type EOpenGLError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EOpenGLError


GLSysHelp v.2.5: GLS.OpenGLAdapter: Class TGLExtensionsAndEntryPoints

Class TGLExtensionsAndEntryPoints

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.OpenGLAdapter

Declaration

type TGLExtensionsAndEntryPoints = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLExtensionsAndEntryPoints

Overview

Fields

Private | FBuffer: string;
Private | FInitialized: boolean;
Private | FDebug: boolean;
Private | FDebugIds: Cardinal;
Public | VERSION_1_0: boolean;
Public | VERSION_1_1: boolean;
Public | VERSION_1_2: boolean;
Public | VERSION_1_3: boolean;
Public | VERSION_1_4: boolean;
Public | VERSION_1_5: boolean;
Public | VERSION_2_0: boolean;
Public | VERSION_2_1: boolean;
Public | VERSION_3_0: boolean;
Public | VERSION_3_1: boolean;
Public | VERSION_3_2: boolean;
Public | VERSION_3_3: boolean;
Public | VERSION_4_0: boolean;
Public | VERSION_4_1: boolean;
Public | VERSION_4_2: boolean;
Public | ARB_blend_func_extended: boolean;
Public | ARB_color_buffer_float: boolean;
Public | ARB_compatibility: boolean;
Public | ARB_copy_buffer: boolean;
Public | ARB_depth_buffer_float: boolean;
Public | ARB_depth_clamp: boolean;
Public | ARB_depth_texture: boolean;
Public | ARB_draw_buffers: boolean;
Public | ARB_draw_buffers_blend: boolean;
Public | ARB_draw_elements_base_vertex: boolean;
Public | ARB_draw_indirect: boolean;
Public | ARB_draw_instanced: boolean;
Public | ARB_explicit_attrib_location: boolean;
Public | ARB_fragment_coord_conventions: boolean;
Public | ARB_fragment_program: boolean;
Public | ARB_fragment_program_shadow: boolean;
Public | ARB_fragment_shader: boolean;
Public | ARB_framebuffer_object: boolean;
Public | ARB_framebuffer_sRGB: boolean;
Public | ARB_geometry_shader4: boolean;
Public | ARB_gpu_shader_fp64: boolean;
Public | ARB_gpu_shader5: boolean;
Public | ARB_half_float_pixel: boolean;
Public | ARB_half_float_vertex: boolean;
Public | ARB_imaging: boolean;
Public | ARB_instanced_arrays: boolean;
Public | ARB_map_buffer_range: boolean;
Public | ARB_matrix_palette: boolean;
Public | ARB_multisample: boolean;
Public | ARB_multitexture: boolean;
Public | ARB_occlusion_query: boolean;
Public | ARB_occlusion_query2: boolean;
Public | ARB_pixel_buffer_object: boolean;
Public | ARB_point_parameters: boolean;
Public | ARB_point_sprite: boolean;
Public | ARB_provoking_vertex: boolean;
Public | ARB_sample_shading: boolean;
Public | ARB_sampler_objects: boolean;
Public | ARB_seamless_cube_map: boolean;
Public | ARB_shader_bit_encoding: boolean;
Public | ARB_shader_subroutine: boolean;
Public | ARB_shader_texture_lod: boolean;
Public | ARB_shading_language_100: boolean;
Public | ARB_shadow: boolean;
Public | ARB_shadow_ambient: boolean;
Public | ARB_shader_objects: boolean;
Public | ARB_sync: boolean;
Public | ARB_tessellation_shader: boolean;
Public | ARB_texture_border_clamp: boolean;
Public | ARB_texture_buffer_object: boolean;
Public | ARB_texture_buffer_object_rgb32: boolean;
Public | ARB_texture_compression: boolean;
Public | ARB_texture_compression_rgtc: boolean;
Public | ARB_texture_cube_map: boolean;
Public | ARB_texture_cube_map_array: boolean;
Public | ARB_texture_env_add: boolean;
Public | ARB_texture_env_combine: boolean;
Public | ARB_texture_env_crossbar: boolean;
Public | ARB_texture_env_dot3: boolean;
Public | ARB_texture_float: boolean;
Public | ARB_texture_gather: boolean;
Public | ARB_texture_mirrored_repeat: boolean;
Public | ARB_texture_multisample: boolean;
Public | ARB_texture_non_power_of_two: boolean;
Public | ARB_texture_query_lod: boolean;
Public | ARB_texture_rectangle: boolean;
Public | ARB_texture_rg: boolean;
Public | ARB_texture_rgb10_a2ui: boolean;
Public | ARB_texture_swizzle: boolean;
Public | ARB_timer_query: boolean;
Public | ARB_transform_feedback2: boolean;
Public | ARB_transform_feedback3: boolean;
Public | ARB_transpose_matrix: boolean;
Public | ARB_uniform_buffer_object: boolean;
Public | ARB_vertex_array_bgra: boolean;
Public | ARB_vertex_array_object: boolean;
Public | ARB_vertex_blend: boolean;
Public | ARB_vertex_buffer_object: boolean;
Public | ARB_vertex_program: boolean;
Public | ARB_vertex_shader: boolean;
Public | ARB_vertex_type_2_10_10_10_rev: boolean;
Public | ARB_window_pos: boolean;
Public | ARB_texture_compression_bptc: boolean;
Public | ARB_get_program_binary: boolean;
Public | ARB_separate_shader_objects: boolean;
Public | ARB_shader_stencil_export: boolean;
Public | KHR_debug: boolean;
Public | ARB_clear_buffer_object: boolean;
Public | ARB_compute_shader: boolean;
Public | ARB_copy_image: boolean;
Public | ARB_debug_group: boolean;
Public | ARB_debug_label: boolean;
Public | ARB_debug_output2: boolean;
Public | ARB_ES3_compatibility: boolean;
Public | ARB_explicit_uniform_location: boolean;
Public | ARB_fragment_layer_viewport: boolean;
Public | ARB_framebuffer_no_attachments: boolean;
Public | ARB_internalformat_query2: boolean;
Public | ARB_invalidate_subdata: boolean;
Public | ARB_multi_draw_indirect: boolean;
Public | ARB_program_interface_query: boolean;
Public | ARB_shader_image_size: boolean;
Public | ARB_shader_storage_buffer_object: boolean;
Public | ARB_stencil_texturing: boolean;
Public | ARB_texture_buffer_range: boolean;
Public | ARB_texture_query_levels: boolean;
Public | ARB_texture_storage_multisample: boolean;
Public | ARB_texture_view: boolean;
Public | ARB_vertex_attrib_binding: boolean;
Public | ARB_robustness_isolation: boolean;
Public | ARB_cl_event: boolean;
Public | _3DFX_multisample: boolean;
Public | _3DFX_tbuffer: boolean;
Public | _3DFX_texture_compression_FXT1: boolean;
Public | ATI_draw_buffers: boolean;
Public | ATI_texture_compression_3dc: boolean;
Public | ATI_texture_float: boolean;
Public | ATI_texture_mirror_once: boolean;
Public | S3_s3tc: boolean;
Public | EXT_abgr: boolean;
Public | EXT_bgra: boolean;
Public | EXT_bindable_uniform: boolean;
Public | EXT_blend_color: boolean;
Public | EXT_blend_equation_separate: boolean;
Public | EXT_blend_func_separate: boolean;
Public | EXT_blend_logic_op: boolean;
Public | EXT_blend_minmax: boolean;
Public | EXT_blend_subtract: boolean;
Public | EXT_Cg_shader: boolean;
Public | EXT_clip_volume_hint: boolean;
Public | EXT_compiled_vertex_array: boolean;
Public | EXT_copy_texture: boolean;
Public | EXT_depth_bounds_test: boolean;
Public | EXT_draw_buffers2: boolean;
Public | EXT_draw_instanced: boolean;
Public | EXT_draw_range_elements: boolean;
Public | EXT_fog_coord: boolean;
Public | EXT_framebuffer_blit: boolean;
Public | EXT_framebuffer_multisample: boolean;
Public | EXT_framebuffer_object: boolean;
Public | EXT_framebuffer_sRGB: boolean;
Public | EXT_geometry_shader4: boolean;
Public | EXT_gpu_program_parameters: boolean;
Public | EXT_gpu_shader4: boolean;
Public | EXT_multi_draw_arrays: boolean;
Public | EXT_multisample: boolean;
Public | EXT_packed_depth_stencil: boolean;
Public | EXT_packed_float: boolean;
Public | EXT_packed_pixels: boolean;
Public | EXT_paletted_texture: boolean;
Public | EXT_pixel_buffer_object: boolean;
Public | EXT_polygon_offset: boolean;
Public | EXT_rescale_normal: boolean;
Public | EXT_secondary_color: boolean;
Public | EXT_separate_specular_color: boolean;
Public | EXT_shadow_funcs: boolean;
Public | EXT_shared_texture_palette: boolean;
Public | EXT_stencil_clear_tag: boolean;
Public | EXT_stencil_two_side: boolean;
Public | EXT_stencil_wrap: boolean;
Public | EXT_texture3D: boolean;
Public | EXT_texture_array: boolean;
Public | EXT_texture_buffer_object: boolean;
Public | EXT_texture_compression_latc: boolean;
Public | EXT_texture_compression_rgtc: boolean;
Public | EXT_texture_compression_s3tc: boolean;
Public | EXT_texture_cube_map: boolean;
Public | EXT_texture_edge_clamp: boolean;
Public | EXT_texture_env_add: boolean;
Public | EXT_texture_env_combine: boolean;
Public | EXT_texture_env_dot3: boolean;
Public | EXT_texture_filter_anisotropic: boolean;
Public | EXT_texture_integer: boolean;
Public | EXT_texture_lod: boolean;
Public | EXT_texture_lod_bias: boolean;
Public | EXT_texture_mirror_clamp: boolean;
Public | EXT_texture_object: boolean;
Public | EXT_texture_rectangle: boolean;
Public | EXT_texture_sRGB: boolean;
Public | EXT_texture_shared_exponent: boolean;
Public | EXT_timer_query: boolean;
Public | EXT_transform_feedback: boolean;
Public | EXT_vertex_array: boolean;
Public | EXT_texture_sRGB_decode: boolean;
Public | EXT_direct_state_access: boolean;
Public | EXT_texture_swizzle: boolean;
Public | HP_occlusion_test: boolean;
Public | IBM_rasterpos_clip: boolean;
Public | KTX_buffer_region: boolean;
Public | MESA_resize_buffers: boolean;
Public | NV_blend_square: boolean;
Public | NV_conditional_render: boolean;
Public | NV_copy_image: boolean;
Public | NV_depth_buffer_float: boolean;
Public | NV_fence: boolean;
Public | NV_float_buffer: boolean;
Public | NV_fog_distance: boolean;
Public | NV_geometry_program4: boolean;
Public | NV_light_max_exponent: boolean;
Public | NV_multisample_filter_hint: boolean;
Public | NV_occlusion_query: boolean;
Public | NV_point_sprite: boolean;
Public | NV_primitive_restart: boolean;
Public | NV_register_combiners: boolean;
Public | NV_shader_buffer_load: boolean;
Public | NV_texgen_reflection: boolean;
Public | NV_texture_compression_vtc: boolean;
Public | NV_texture_env_combine4: boolean;
Public | NV_texture_rectangle: boolean;
Public | NV_texture_shader: boolean;
Public | NV_texture_shader2: boolean;
Public | NV_texture_shader3: boolean;
Public | NV_transform_feedback: boolean;
Public | NV_vertex_array_range: boolean;
Public | NV_vertex_array_range2: boolean;
Public | NV_vertex_buffer_unified_memory: boolean;
Public | NV_vertex_program: boolean;
Public | SGI_color_matrix: boolean;
Public | SGIS_generate_mipmap: boolean;
Public | SGIS_multisample: boolean;
Public | SGIS_texture_border_clamp: boolean;
Public | SGIS_texture_color_mask: boolean;
Public | SGIS_texture_edge_clamp: boolean;
Public | SGIS_texture_lod: boolean;
Public | SGIX_depth_texture: boolean;
Public | SGIX_shadow: boolean;
Public | SGIX_shadow_ambient: boolean;
Public | AMD_vertex_shader_tessellator: boolean;
Public | WIN_swap_hint: boolean;
Public | ATI_meminfo: boolean;
Public | NVX_gpu_memory_info: boolean;
Public | NV_vdpau_interop: boolean;
Public | NV_path_rendering: boolean;
Public | GREMEDY_frame_terminator: boolean;
Public | GREMEDY_string_marker: boolean;
Public | AMDX_debug_output: boolean;
Public | ARB_debug_output: boolean;
Public | BindTexture: procedure(target: Cardinal; texture: Cardinal); stdcall;
Public | BlendFunc: procedure(sfactor: Cardinal; dfactor: Cardinal); stdcall;
Public | Clear: procedure(mask: TGLbitfield); stdcall;
Public | ClearColor: procedure(red, green, blue, alpha: Single); stdcall;
Public | ClearDepth: procedure(depth: TGLclampd); stdcall;
Public | ClearStencil: procedure(s: TGLint); stdcall;
Public | ColorMask: procedure(red, green, blue, alpha: TGLboolean); stdcall;
Public | CopyTexImage1D: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; X, y: TGLint; Width: TGLsizei; border: TGLint); stdcall;
Public | CopyTexImage2D: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; X, y: TGLint; Width, Height: TGLsizei; border: TGLint); stdcall;
Public | CopyTexSubImage1D: procedure(target: Cardinal; level, xoffset, X, y: TGLint; Width: TGLsizei); stdcall;
Public | CopyTexSubImage2D: procedure(target: Cardinal; level, xoffset, yoffset, X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | CullFace: procedure(mode: Cardinal); stdcall;
Public | DeleteTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;
Public | DepthFunc: procedure(func: Cardinal); stdcall;
Public | DepthMask: procedure(flag: TGLboolean); stdcall;
Public | DepthRange: procedure(zNear, zFar: TGLclampd); stdcall;
Public | Disable: procedure(cap: Cardinal); stdcall;
Public | DrawArrays: procedure(mode: Cardinal; First: TGLint; Count: TGLsizei); stdcall;
Public | DrawBuffer: procedure(mode: Cardinal); stdcall;
Public | DrawElements: procedure(mode: Cardinal; Count: TGLsizei; atype: Cardinal; indices: Pointer); stdcall;
Public | Enable: procedure(cap: Cardinal); stdcall;
Public | Finish: procedure(); stdcall;
Public | Flush: procedure(); stdcall;
Public | FrontFace: procedure(mode: Cardinal); stdcall;
Public | GenTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;
Public | GetBooleanv: procedure(pname: Cardinal; params: PGLboolean); stdcall;
Public | GetDoublev: procedure(pname: Cardinal; params: PGLdouble); stdcall;
Public | GetError: function: Cardinal; stdcall;
Public | GetFloatv: procedure(pname: Cardinal; params: PGLfloat); stdcall;
Public | GetIntegerv: procedure(pname: Cardinal; params: PGLint); stdcall;
Public | GetPointerv: procedure(pname: Cardinal; var params); stdcall;
Public | GetString: function(Name: Cardinal): PAnsiChar; stdcall;
Public | GetTexImage: procedure(target: Cardinal; level: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | GetTexLevelParameterfv: procedure(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;
Public | GetTexLevelParameteriv: procedure(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall;
Public | GetTexParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetTexParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;
Public | Hint: procedure(target, mode: Cardinal); stdcall;
Public | IsEnabled: function(cap: Cardinal): TGLboolean; stdcall;
Public | IsTexture: function(texture: Cardinal): TGLboolean; stdcall;
Public | LineWidth: procedure(Width: TGLfloat); stdcall;
Public | LogicOp: procedure(opcode: Cardinal); stdcall;
Public | PixelStoref: procedure(pname: Cardinal; param: TGLfloat); stdcall;
Public | PixelStorei: procedure(pname: Cardinal; param: TGLint); stdcall;
Public | PointSize: procedure(size: TGLfloat); stdcall;
Public | PolygonMode: procedure(face, mode: Cardinal); stdcall;
Public | PolygonOffset: procedure(factor, units: TGLfloat); stdcall;
Public | ReadBuffer: procedure(mode: Cardinal); stdcall;
Public | ReadPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | Scissor: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | StencilFunc: procedure(func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;
Public | StencilMask: procedure(mask: Cardinal); stdcall;
Public | StencilOp: procedure(fail, zfail, zpass: Cardinal); stdcall;
Public | TexImage1D: procedure(target: Cardinal; level, internalFormat: TGLint; Width: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | TexImage2D: procedure(target: Cardinal; level, internalFormat: TGLint; Width, Height: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | TexParameterf: procedure(target, pname: Cardinal; param: TGLfloat); stdcall;
Public | TexParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
Public | TexParameteri: procedure(target, pname: Cardinal; param: TGLint); stdcall;
Public | TexParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;
Public | TexSubImage1D: procedure(target: Cardinal; level, xoffset: TGLint; Width: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | TexSubImage2D: procedure(target: Cardinal; level, xoffset, yoffset: TGLint; Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | Viewport: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | Accum: procedure(op: Cardinal; Value: TGLfloat); stdcall;
Public | AlphaFunc: procedure(func: Cardinal; ref: Single); stdcall;
Public | AreTexturesResident: function(n: TGLsizei; textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall;
Public | ArrayElement: procedure(i: TGLint); stdcall;
Public | Begin_: procedure(mode: Cardinal); stdcall;
Public | Bitmap: procedure(Width: TGLsizei; Height: TGLsizei; xorig, yorig: TGLfloat; xmove: TGLfloat; ymove: TGLfloat; Bitmap: Pointer); stdcall;
Public | CallList: procedure(list: Cardinal); stdcall;
Public | CallLists: procedure(n: TGLsizei; atype: Cardinal; lists: Pointer); stdcall;
Public | ClearAccum: procedure(red, green, blue, alpha: TGLfloat); stdcall;
Public | ClearIndex: procedure(c: TGLfloat); stdcall;
Public | ClipPlane: procedure(plane: Cardinal; equation: PGLdouble); stdcall;
Public | Color3b: procedure(red, green, blue: TGLbyte); stdcall;
Public | Color3bv: procedure(v: PGLbyte); stdcall;
Public | Color3d: procedure(red, green, blue: TGLdouble); stdcall;
Public | Color3dv: procedure(v: PGLdouble); stdcall;
Public | Color3f: procedure(red, green, blue: TGLfloat); stdcall;
Public | Color3fv: procedure(v: PGLfloat); stdcall;
Public | Color3i: procedure(red, green, blue: TGLint); stdcall;
Public | Color3iv: procedure(v: PGLint); stdcall;
Public | Color3s: procedure(red, green, blue: TGLshort); stdcall;
Public | Color3sv: procedure(v: PGLshort); stdcall;
Public | Color3ub: procedure(red, green, blue: TGLubyte); stdcall;
Public | Color3ubv: procedure(v: PGLubyte); stdcall;
Public | Color3ui: procedure(red, green, blue: Cardinal); stdcall;
Public | Color3uiv: procedure(v: PGLuint); stdcall;
Public | Color3us: procedure(red, green, blue: TGLushort); stdcall;
Public | Color3usv: procedure(v: PGLushort); stdcall;
Public | Color4b: procedure(red, green, blue, alpha: TGLbyte); stdcall;
Public | Color4bv: procedure(v: PGLbyte); stdcall;
Public | Color4d: procedure(red, green, blue, alpha: TGLdouble); stdcall;
Public | Color4dv: procedure(v: PGLdouble); stdcall;
Public | Color4f: procedure(red, green, blue, alpha: TGLfloat); stdcall;
Public | Color4fv: procedure(v: PGLfloat); stdcall;
Public | Color4i: procedure(red, green, blue, alpha: TGLint); stdcall;
Public | Color4iv: procedure(v: PGLint); stdcall;
Public | Color4s: procedure(red, green, blue, alpha: TGLshort); stdcall;
Public | Color4sv: procedure(v: TGLshort); stdcall;
Public | Color4ub: procedure(red, green, blue, alpha: TGLubyte); stdcall;
Public | Color4ubv: procedure(v: PGLubyte); stdcall;
Public | Color4ui: procedure(red, green, blue, alpha: Cardinal); stdcall;
Public | Color4uiv: procedure(v: PGLuint); stdcall;
Public | Color4us: procedure(red, green, blue, alpha: TGLushort); stdcall;
Public | Color4usv: procedure(v: PGLushort); stdcall;
Public | ColorMaterial: procedure(face: Cardinal; mode: Cardinal); stdcall;
Public | ColorPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | CopyPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; atype: Cardinal); stdcall;
Public | DeleteLists: procedure(list: Cardinal; range: TGLsizei); stdcall;
Public | DisableClientState: procedure(aarray: Cardinal); stdcall;
Public | DrawPixels: procedure(Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | EdgeFlag: procedure(flag: TGLboolean); stdcall;
Public | EdgeFlagPointer: procedure(stride: TGLsizei; Data: Pointer); stdcall;
Public | EdgeFlagv: procedure(flag: PGLboolean); stdcall;
Public | EnableClientState: procedure(aarray: Cardinal); stdcall;
Public | End_: procedure(); stdcall;
Public | EndList: procedure(); stdcall;
Public | EvalCoord1d: procedure(u: TGLdouble); stdcall;
Public | EvalCoord1dv: procedure(u: PGLdouble); stdcall;
Public | EvalCoord1f: procedure(u: TGLfloat); stdcall;
Public | EvalCoord1fv: procedure(u: PGLfloat); stdcall;
Public | EvalCoord2d: procedure(u: TGLdouble; v: TGLdouble); stdcall;
Public | EvalCoord2dv: procedure(u: PGLdouble); stdcall;
Public | EvalCoord2f: procedure(u, v: TGLfloat); stdcall;
Public | EvalCoord2fv: procedure(u: PGLfloat); stdcall;
Public | EvalMesh1: procedure(mode: Cardinal; i1, i2: TGLint); stdcall;
Public | EvalMesh2: procedure(mode: Cardinal; i1, i2, j1, j2: TGLint); stdcall;
Public | EvalPoint1: procedure(i: TGLint); stdcall;
Public | EvalPoint2: procedure(i, j: TGLint); stdcall;
Public | FeedbackBuffer: procedure(size: TGLsizei; atype: Cardinal; buffer: PGLfloat); stdcall;
Public | Fogf: procedure(pname: Cardinal; param: TGLfloat); stdcall;
Public | Fogfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;
Public | Fogi: procedure(pname: Cardinal; param: TGLint); stdcall;
Public | Fogiv: procedure(pname: Cardinal; params: PGLint); stdcall;
Public | Frustum: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;
Public | GenLists: function(range: TGLsizei): Cardinal; stdcall;
Public | GetClipPlane: procedure(plane: Cardinal; equation: PGLdouble); stdcall;
Public | GetLightfv: procedure(light, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetLightiv: procedure(light, pname: Cardinal; params: PGLint); stdcall;
Public | GetMapdv: procedure(target, query: Cardinal; v: PGLdouble); stdcall;
Public | GetMapfv: procedure(target, query: Cardinal; v: PGLfloat); stdcall;
Public | GetMapiv: procedure(target, query: Cardinal; v: PGLint); stdcall;
Public | GetMaterialfv: procedure(face, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetMaterialiv: procedure(face, pname: Cardinal; params: PGLint); stdcall;
Public | GetPixelMapfv: procedure(map: Cardinal; values: PGLfloat); stdcall;
Public | GetPixelMapuiv: procedure(map: Cardinal; values: PGLuint); stdcall;
Public | GetPixelMapusv: procedure(map: Cardinal; values: PGLushort); stdcall;
Public | GetPolygonStipple: procedure(mask: PGLubyte); stdcall;
Public | GetTexEnvfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetTexEnviv: procedure(target, pname: Cardinal; params: PGLint); stdcall;
Public | GetTexGendv: procedure(coord, pname: Cardinal; params: PGLdouble); stdcall;
Public | GetTexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetTexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;
Public | IndexMask: procedure(mask: Cardinal); stdcall;
Public | IndexPointer: procedure(atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | Indexd: procedure(c: TGLdouble); stdcall;
Public | Indexdv: procedure(c: PGLdouble); stdcall;
Public | Indexf: procedure(c: TGLfloat); stdcall;
Public | Indexfv: procedure(c: PGLfloat); stdcall;
Public | Indexi: procedure(c: TGLint); stdcall;
Public | Indexiv: procedure(c: PGLint); stdcall;
Public | Indexs: procedure(c: TGLshort); stdcall;
Public | Indexsv: procedure(c: PGLshort); stdcall;
Public | Indexub: procedure(c: TGLubyte); stdcall;
Public | Indexubv: procedure(c: PGLubyte); stdcall;
Public | InitNames: procedure(); stdcall;
Public | InterleavedArrays: procedure(format: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | IsList: function(list: Cardinal): TGLboolean; stdcall;
Public | LightModelf: procedure(pname: Cardinal; param: TGLfloat); stdcall;
Public | LightModelfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;
Public | LightModeli: procedure(pname: Cardinal; param: TGLint); stdcall;
Public | LightModeliv: procedure(pname: Cardinal; params: PGLint); stdcall;
Public | Lightf: procedure(light, pname: Cardinal; param: TGLfloat); stdcall;
Public | Lightfv: procedure(light, pname: Cardinal; params: PGLfloat); stdcall;
Public | Lighti: procedure(light, pname: Cardinal; param: TGLint); stdcall;
Public | Lightiv: procedure(light, pname: Cardinal; params: PGLint); stdcall;
Public | LineStipple: procedure(factor: TGLint; pattern: TGLushort); stdcall;
Public | ListBase: procedure(base: Cardinal); stdcall;
Public | LoadIdentity: procedure(); stdcall;
Public | LoadMatrixd: procedure(m: PGLdouble); stdcall;
Public | LoadMatrixf: procedure(m: PGLfloat); stdcall;
Public | LoadName: procedure(Name: Cardinal); stdcall;
Public | Map1d: procedure(target: Cardinal; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall;
Public | Map1f: procedure(target: Cardinal; u1, u2: TGLfloat; stride, order: TGLint; points: PGLfloat); stdcall;
Public | Map2d: procedure(target: Cardinal; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall;
Public | Map2f: procedure(target: Cardinal; u1, u2: TGLfloat; ustride, uorder: TGLint; v1, v2: TGLfloat; vstride, vorder: TGLint; points: PGLfloat); stdcall;
Public | MapGrid1d: procedure(un: TGLint; u1, u2: TGLdouble); stdcall;
Public | MapGrid1f: procedure(un: TGLint; u1, u2: TGLfloat); stdcall;
Public | MapGrid2d: procedure(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall;
Public | MapGrid2f: procedure(un: TGLint; u1, u2: TGLfloat; vn: TGLint; v1, v2: TGLfloat); stdcall;
Public | Materialf: procedure(face, pname: Cardinal; param: TGLfloat); stdcall;
Public | Materialfv: procedure(face, pname: Cardinal; params: PGLfloat); stdcall;
Public | Materiali: procedure(face, pname: Cardinal; param: TGLint); stdcall;
Public | Materialiv: procedure(face, pname: Cardinal; params: PGLint); stdcall;
Public | MatrixMode: procedure(mode: Cardinal); stdcall;
Public | MultMatrixd: procedure(m: PGLdouble); stdcall;
Public | MultMatrixf: procedure(m: PGLfloat); stdcall;
Public | NewList: procedure(list: Cardinal; mode: Cardinal); stdcall;
Public | Normal3b: procedure(nx, ny, nz: TGLbyte); stdcall;
Public | Normal3bv: procedure(v: PGLbyte); stdcall;
Public | Normal3d: procedure(nx, ny, nz: TGLdouble); stdcall;
Public | Normal3dv: procedure(v: PGLdouble); stdcall;
Public | Normal3f: procedure(nx, ny, nz: TGLfloat); stdcall;
Public | Normal3fv: procedure(v: PGLfloat); stdcall;
Public | Normal3i: procedure(nx, ny, nz: TGLint); stdcall;
Public | Normal3iv: procedure(v: PGLint); stdcall;
Public | Normal3s: procedure(nx, ny, nz: TGLshort); stdcall;
Public | Normal3sv: procedure(v: PGLshort); stdcall;
Public | NormalPointer: procedure(atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | Ortho: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;
Public | PassThrough: procedure(token: TGLfloat); stdcall;
Public | PixelMapfv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLfloat); stdcall;
Public | PixelMapuiv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLuint); stdcall;
Public | PixelMapusv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLushort); stdcall;
Public | PixelTransferf: procedure(pname: Cardinal; param: TGLfloat); stdcall;
Public | PixelTransferi: procedure(pname: Cardinal; param: TGLint); stdcall;
Public | PixelZoom: procedure(xfactor, yfactor: TGLfloat); stdcall;
Public | PolygonStipple: procedure(mask: PGLubyte); stdcall;
Public | PopAttrib: procedure(); stdcall;
Public | PopClientAttrib: procedure(); stdcall;
Public | PopMatrix: procedure(); stdcall;
Public | PopName: procedure(); stdcall;
Public | PrioritizeTextures: procedure(n: TGLsizei; textures: PGLuint; priorities: PSingle); stdcall;
Public | PushAttrib: procedure(mask: TGLbitfield); stdcall;
Public | PushClientAttrib: procedure(mask: TGLbitfield); stdcall;
Public | PushMatrix: procedure(); stdcall;
Public | PushName: procedure(Name: Cardinal); stdcall;
Public | RasterPos2d: procedure(X, y: TGLdouble); stdcall;
Public | RasterPos2dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos2f: procedure(X, y: TGLfloat); stdcall;
Public | RasterPos2fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos2i: procedure(X, y: TGLint); stdcall;
Public | RasterPos2iv: procedure(v: PGLint); stdcall;
Public | RasterPos2s: procedure(X, y: PGLshort); stdcall;
Public | RasterPos2sv: procedure(v: PGLshort); stdcall;
Public | RasterPos3d: procedure(X, y, z: TGLdouble); stdcall;
Public | RasterPos3dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos3f: procedure(X, y, z: TGLfloat); stdcall;
Public | RasterPos3fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos3i: procedure(X, y, z: TGLint); stdcall;
Public | RasterPos3iv: procedure(v: PGLint); stdcall;
Public | RasterPos3s: procedure(X, y, z: TGLshort); stdcall;
Public | RasterPos3sv: procedure(v: PGLshort); stdcall;
Public | RasterPos4d: procedure(X, y, z, w: TGLdouble); stdcall;
Public | RasterPos4dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos4f: procedure(X, y, z, w: TGLfloat); stdcall;
Public | RasterPos4fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos4i: procedure(X, y, z, w: TGLint); stdcall;
Public | RasterPos4iv: procedure(v: PGLint); stdcall;
Public | RasterPos4s: procedure(X, y, z, w: TGLshort); stdcall;
Public | RasterPos4sv: procedure(v: PGLshort); stdcall;
Public | Rectd: procedure(x1, y1, x2, y2: TGLdouble); stdcall;
Public | Rectdv: procedure(v1, v2: PGLdouble); stdcall;
Public | Rectf: procedure(x1, y1, x2, y2: TGLfloat); stdcall;
Public | Rectfv: procedure(v1, v2: PGLfloat); stdcall;
Public | Recti: procedure(x1, y1, x2, y2: TGLint); stdcall;
Public | Rectiv: procedure(v1, v2: PGLint); stdcall;
Public | Rects: procedure(x1, y1, x2, y2: TGLshort); stdcall;
Public | Rectsv: procedure(v1, v2: PGLshort); stdcall;
Public | RenderMode: function(mode: Cardinal): TGLint; stdcall;
Public | Rotated: procedure(ane, X, y, z: TGLdouble); stdcall;
Public | Rotatef: procedure(ane, X, y, z: TGLfloat); stdcall;
Public | Scaled: procedure(X, y, z: TGLdouble); stdcall;
Public | Scalef: procedure(X, y, z: TGLfloat); stdcall;
Public | SelectBuffer: procedure(size: TGLsizei; buffer: PGLuint); stdcall;
Public | ShadeModel: procedure(mode: Cardinal); stdcall;
Public | TexCoord1d: procedure(s: TGLdouble); stdcall;
Public | TexCoord1dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord1f: procedure(s: TGLfloat); stdcall;
Public | TexCoord1fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord1i: procedure(s: TGLint); stdcall;
Public | TexCoord1iv: procedure(v: PGLint); stdcall;
Public | TexCoord1s: procedure(s: TGLshort); stdcall;
Public | TexCoord1sv: procedure(v: PGLshort); stdcall;
Public | TexCoord2d: procedure(s, t: TGLdouble); stdcall;
Public | TexCoord2dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord2f: procedure(s, t: TGLfloat); stdcall;
Public | TexCoord2fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord2i: procedure(s, t: TGLint); stdcall;
Public | TexCoord2iv: procedure(v: PGLint); stdcall;
Public | TexCoord2s: procedure(s, t: TGLshort); stdcall;
Public | TexCoord2sv: procedure(v: PGLshort); stdcall;
Public | TexCoord3d: procedure(s, t, r: TGLdouble); stdcall;
Public | TexCoord3dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;
Public | TexCoord3fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord3i: procedure(s, t, r: TGLint); stdcall;
Public | TexCoord3iv: procedure(v: PGLint); stdcall;
Public | TexCoord3s: procedure(s, t, r: TGLshort); stdcall;
Public | TexCoord3sv: procedure(v: PGLshort); stdcall;
Public | TexCoord4d: procedure(s, t, r, q: TGLdouble); stdcall;
Public | TexCoord4dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;
Public | TexCoord4fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord4i: procedure(s, t, r, q: TGLint); stdcall;
Public | TexCoord4iv: procedure(v: PGLint); stdcall;
Public | TexCoord4s: procedure(s, t, r, q: TGLshort); stdcall;
Public | TexCoord4sv: procedure(v: PGLshort); stdcall;
Public | TexCoordPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | TexEnvf: procedure(target, pname: Cardinal; param: TGLfloat); stdcall;
Public | TexEnvfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
Public | TexEnvi: procedure(target, pname: Cardinal; param: TGLint); stdcall;
Public | TexEnviv: procedure(target, pname: Cardinal; params: PGLint); stdcall;
Public | TexGend: procedure(coord, pname: Cardinal; param: TGLdouble); stdcall;
Public | TexGendv: procedure(coord, pname: Cardinal; params: PGLdouble); stdcall;
Public | TexGenf: procedure(coord, pname: Cardinal; param: TGLfloat); stdcall;
Public | TexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;
Public | TexGeni: procedure(coord, pname: Cardinal; param: TGLint); stdcall;
Public | TexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;
Public | Translated: procedure(X, y, z: TGLdouble); stdcall;
Public | Translatef: procedure(X, y, z: TGLfloat); stdcall;
Public | Vertex2d: procedure(X, y: TGLdouble); stdcall;
Public | Vertex2dv: procedure(v: PGLdouble); stdcall;
Public | Vertex2f: procedure(X, y: TGLfloat); stdcall;
Public | Vertex2fv: procedure(v: PGLfloat); stdcall;
Public | Vertex2i: procedure(X, y: TGLint); stdcall;
Public | Vertex2iv: procedure(v: PGLint); stdcall;
Public | Vertex2s: procedure(X, y: TGLshort); stdcall;
Public | Vertex2sv: procedure(v: PGLshort); stdcall;
Public | Vertex3d: procedure(X, y, z: TGLdouble); stdcall;
Public | Vertex3dv: procedure(v: PGLdouble); stdcall;
Public | Vertex3f: procedure(X, y, z: TGLfloat); stdcall;
Public | Vertex3fv: procedure(v: PGLfloat); stdcall;
Public | Vertex3i: procedure(X, y, z: TGLint); stdcall;
Public | Vertex3iv: procedure(v: PGLint); stdcall;
Public | Vertex3s: procedure(X, y, z: TGLshort); stdcall;
Public | Vertex3sv: procedure(v: PGLshort); stdcall;
Public | Vertex4d: procedure(X, y, z, w: TGLdouble); stdcall;
Public | Vertex4dv: procedure(v: PGLdouble); stdcall;
Public | Vertex4f: procedure(X, y, z, w: TGLfloat); stdcall;
Public | Vertex4fv: procedure(v: PGLfloat); stdcall;
Public | Vertex4i: procedure(X, y, z, w: TGLint); stdcall;
Public | Vertex4iv: procedure(v: PGLint); stdcall;
Public | Vertex4s: procedure(X, y, z, w: TGLshort); stdcall;
Public | Vertex4sv: procedure(v: PGLshort); stdcall;
Public | VertexPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | BlendColor: PFNGLBLENDCOLORPROC;
Public | BlendEquation: PFNGLBLENDEQUATIONPROC;
Public | DrawRangeElements: PFNGLDRAWRANGEELEMENTSPROC;
Public | TexImage3D: PFNGLTEXIMAGE3DPROC;
Public | TexSubImage3D: PFNGLTEXSUBIMAGE3DPROC;
Public | CopyTexSubImage3D: PFNGLCOPYTEXSUBIMAGE3DPROC;
Public | BlendFuncSeparate: PFNGLBLENDFUNCSEPARATEPROC;
Public | MultiDrawArrays: PFNGLMULTIDRAWARRAYSPROC;
Public | MultiDrawElements: PFNGLMULTIDRAWELEMENTSPROC;
Public | PointParameterf: PFNGLPOINTPARAMETERFPROC;
Public | PointParameterfv: PFNGLPOINTPARAMETERFVPROC;
Public | PointParameteri: PFNGLPOINTPARAMETERIPROC;
Public | PointParameteriv: PFNGLPOINTPARAMETERIVPROC;
Public | BlendEquationSeparate: PFNGLBLENDEQUATIONSEPARATEPROC;
Public | DrawBuffers: PFNGLDRAWBUFFERSPROC;
Public | StencilOpSeparate: PFNGLSTENCILOPSEPARATEPROC;
Public | StencilFuncSeparate: PFNGLSTENCILFUNCSEPARATEPROC;
Public | StencilMaskSeparate: PFNGLSTENCILMASKSEPARATEPROC;
Public | LockArrays: PFNGLLOCKARRAYSEXTPROC;
Public | UnlockArrays: PFNGLUNLOCKARRAYSEXTPROC;
Public | BindBuffer: PFNGLBINDBUFFERPROC;
Public | DeleteBuffers: PFNGLDELETEBUFFERSPROC;
Public | GenBuffers: PFNGLGENBUFFERSPROC;
Public | IsBuffer: PFNGLISBUFFERPROC;
Public | BufferData: PFNGLBUFFERDATAPROC;
Public | BufferSubData: PFNGLBUFFERSUBDATAPROC;
Public | GetBufferSubData: PFNGLGETBUFFERSUBDATAPROC;
Public | MapBuffer: PFNGLMAPBUFFERPROC;
Public | UnmapBuffer: PFNGLUNMAPBUFFERPROC;
Public | GetBufferParameteriv: PFNGLGETBUFFERPARAMETERIVPROC;
Public | GetBufferPointerv: PFNGLGETBUFFERPOINTERVPROC;
Public | MapBufferRange: PFNGLMAPBUFFERRANGEPROC;
Public | FlushMappedBufferRange: PFNGLFLUSHMAPPEDBUFFERRANGEPROC;
Public | BindBufferRange: PFNGLBINDBUFFERRANGEPROC;
Public | BindBufferOffset: PFNGLBINDBUFFEROFFSETEXTPROC;
Public | BindBufferBase: PFNGLBINDBUFFERBASEPROC;
Public | TransformFeedbackAttribs: PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC;
Public | TransformFeedbackVaryingsNV: PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC;
Public | TransformFeedbackVaryings: PFNGLTRANSFORMFEEDBACKVARYINGSPROC;
Public | GetTransformFeedbackVarying: PFNGLGETTRANSFORMFEEDBACKVARYINGPROC;
Public | BeginTransformFeedback: PFNGLBEGINTRANSFORMFEEDBACKPROC;
Public | EndTransformFeedback: PFNGLENDTRANSFORMFEEDBACKPROC;
Public | TexBuffer: PFNGLTEXBUFFERPROC;
Public | ClearBufferiv: PFNGLCLEARBUFFERIVPROC;
Public | ClearBufferuiv: PFNGLCLEARBUFFERUIVPROC;
Public | ClearBufferfv: PFNGLCLEARBUFFERFVPROC;
Public | ClearBufferfi: PFNGLCLEARBUFFERFIPROC;
Public | GetStringi: PFNGLGETSTRINGIPROC;
Public | BindVertexArray: PFNGLBINDVERTEXARRAYPROC;
Public | DeleteVertexArrays: PFNGLDELETEVERTEXARRAYSPROC;
Public | GenVertexArrays: PFNGLGENVERTEXARRAYSPROC;
Public | IsVertexArray: PFNGLISVERTEXARRAYPROC;
Public | FlushVertexArrayRangeNV: PFNGLFLUSHVERTEXARRAYRANGENVPROC;
Public | VertexArrayRangeNV: PFNGLVERTEXARRAYRANGENVPROC;
Public | GetUniformIndices: PFNGLGETUNIFORMINDICESPROC;
Public | GetActiveUniformsiv: PFNGLGETACTIVEUNIFORMSIVPROC;
Public | GetActiveUniformName: PFNGLGETACTIVEUNIFORMNAMEPROC;
Public | GetUniformBlockIndex: PFNGLGETUNIFORMBLOCKINDEXPROC;
Public | GetActiveUniformBlockiv: PFNGLGETACTIVEUNIFORMBLOCKIVPROC;
Public | GetActiveUniformBlockName: PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC;
Public | UniformBlockBinding: PFNGLUNIFORMBLOCKBINDINGPROC;
Public | CopyBufferSubData: PFNGLCOPYBUFFERSUBDATAPROC;
Public | UniformBuffer: PFNGLUNIFORMBUFFEREXTPROC;
Public | GetUniformBufferSize: PFNGLGETUNIFORMBUFFERSIZEEXTPROC;
Public | GetUniformOffset: PFNGLGETUNIFORMOFFSETEXTPROC;
Public | PrimitiveRestartIndex: PFNGLPRIMITIVERESTARTINDEXPROC;
Public | DrawElementsBaseVertex: PFNGLDRAWELEMENTSBASEVERTEXPROC;
Public | DrawRangeElementsBaseVertex: PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC;
Public | DrawElementsInstancedBaseVertex: PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC;
Public | MultiDrawElementsBaseVertex: PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC;
Public | DrawArraysInstanced: PFNGLDRAWARRAYSINSTANCEDPROC;
Public | DrawElementsInstanced: PFNGLDRAWELEMENTSINSTANCEDPROC;
Public | VertexAttrib1d: PFNGLVERTEXATTRIB1DPROC;
Public | VertexAttrib1dv: PFNGLVERTEXATTRIB1DVPROC;
Public | VertexAttrib1f: PFNGLVERTEXATTRIB1FPROC;
Public | VertexAttrib1fv: PFNGLVERTEXATTRIB1FVPROC;
Public | VertexAttrib1s: PFNGLVERTEXATTRIB1SPROC;
Public | VertexAttrib1sv: PFNGLVERTEXATTRIB1SVPROC;
Public | VertexAttrib2d: PFNGLVERTEXATTRIB2DPROC;
Public | VertexAttrib2dv: PFNGLVERTEXATTRIB2DVPROC;
Public | VertexAttrib2f: PFNGLVERTEXATTRIB2FPROC;
Public | VertexAttrib2fv: PFNGLVERTEXATTRIB2FVPROC;
Public | VertexAttrib2s: PFNGLVERTEXATTRIB2SPROC;
Public | VertexAttrib2sv: PFNGLVERTEXATTRIB2SVPROC;
Public | VertexAttrib3d: PFNGLVERTEXATTRIB3DPROC;
Public | VertexAttrib3dv: PFNGLVERTEXATTRIB3DVPROC;
Public | VertexAttrib3f: PFNGLVERTEXATTRIB3FPROC;
Public | VertexAttrib3fv: PFNGLVERTEXATTRIB3FVPROC;
Public | VertexAttrib3s: PFNGLVERTEXATTRIB3SPROC;
Public | VertexAttrib3sv: PFNGLVERTEXATTRIB3SVPROC;
Public | VertexAttrib4Nbv: PFNGLVERTEXATTRIB4NBVPROC;
Public | VertexAttrib4Niv: PFNGLVERTEXATTRIB4NIVPROC;
Public | VertexAttrib4Nsv: PFNGLVERTEXATTRIB4NSVPROC;
Public | VertexAttrib4Nub: PFNGLVERTEXATTRIB4NUBPROC;
Public | VertexAttrib4Nubv: PFNGLVERTEXATTRIB4NUBVPROC;
Public | VertexAttrib4Nuiv: PFNGLVERTEXATTRIB4NUIVPROC;
Public | VertexAttrib4Nusv: PFNGLVERTEXATTRIB4NUSVPROC;
Public | VertexAttrib4bv: PFNGLVERTEXATTRIB4BVPROC;
Public | VertexAttrib4d: PFNGLVERTEXATTRIB4DPROC;
Public | VertexAttrib4dv: PFNGLVERTEXATTRIB4DVPROC;
Public | VertexAttrib4f: PFNGLVERTEXATTRIB4FPROC;
Public | VertexAttrib4fv: PFNGLVERTEXATTRIB4FVPROC;
Public | VertexAttrib4iv: PFNGLVERTEXATTRIB4IVPROC;
Public | VertexAttrib4s: PFNGLVERTEXATTRIB4SPROC;
Public | VertexAttrib4sv: PFNGLVERTEXATTRIB4SVPROC;
Public | VertexAttrib4ubv: PFNGLVERTEXATTRIB4UBVPROC;
Public | VertexAttrib4uiv: PFNGLVERTEXATTRIB4UIVPROC;
Public | VertexAttrib4usv: PFNGLVERTEXATTRIB4USVPROC;
Public | VertexAttribPointer: PFNGLVERTEXATTRIBPOINTERPROC;
Public | VertexAttribI1i: PFNGLVERTEXATTRIBI1IPROC;
Public | VertexAttribI2i: PFNGLVERTEXATTRIBI2IPROC;
Public | VertexAttribI3i: PFNGLVERTEXATTRIBI3IPROC;
Public | VertexAttribI4i: PFNGLVERTEXATTRIBI4IPROC;
Public | VertexAttribI1ui: PFNGLVERTEXATTRIBI1UIPROC;
Public | VertexAttribI2ui: PFNGLVERTEXATTRIBI2UIPROC;
Public | VertexAttribI3ui: PFNGLVERTEXATTRIBI3UIPROC;
Public | VertexAttribI4ui: PFNGLVERTEXATTRIBI4UIPROC;
Public | VertexAttribI1iv: PFNGLVERTEXATTRIBI1IVPROC;
Public | VertexAttribI2iv: PFNGLVERTEXATTRIBI2IVPROC;
Public | VertexAttribI3iv: PFNGLVERTEXATTRIBI3IVPROC;
Public | VertexAttribI4iv: PFNGLVERTEXATTRIBI4IVPROC;
Public | VertexAttribI1uiv: PFNGLVERTEXATTRIBI1UIVPROC;
Public | VertexAttribI2uiv: PFNGLVERTEXATTRIBI2UIVPROC;
Public | VertexAttribI3uiv: PFNGLVERTEXATTRIBI3UIVPROC;
Public | VertexAttribI4uiv: PFNGLVERTEXATTRIBI4UIVPROC;
Public | VertexAttribI4bv: PFNGLVERTEXATTRIBI4BVPROC;
Public | VertexAttribI4sv: PFNGLVERTEXATTRIBI4SVPROC;
Public | VertexAttribI4ubv: PFNGLVERTEXATTRIBI4UBVPROC;
Public | VertexAttribI4usv: PFNGLVERTEXATTRIBI4USVPROC;
Public | VertexAttribIPointer: PFNGLVERTEXATTRIBIPOINTERPROC;
Public | GetVertexAttribIiv: PFNGLGETVERTEXATTRIBIIVPROC;
Public | GetVertexAttribIuiv: PFNGLGETVERTEXATTRIBIUIVPROC;
Public | Uniform1ui: PFNGLUNIFORM1UIPROC;
Public | Uniform2ui: PFNGLUNIFORM2UIPROC;
Public | Uniform3ui: PFNGLUNIFORM3UIPROC;
Public | Uniform4ui: PFNGLUNIFORM4UIPROC;
Public | Uniform1uiv: PFNGLUNIFORM1UIVPROC;
Public | Uniform2uiv: PFNGLUNIFORM2UIVPROC;
Public | Uniform3uiv: PFNGLUNIFORM3UIVPROC;
Public | Uniform4uiv: PFNGLUNIFORM4UIVPROC;
Public | GetUniformuiv: PFNGLGETUNIFORMUIVPROC;
Public | BindFragDataLocation: PFNGLBINDFRAGDATALOCATIONPROC;
Public | GetFragDataLocation: PFNGLGETFRAGDATALOCATIONPROC;
Public | ClampColor: PFNGLCLAMPCOLORPROC;
Public | ColorMaski: PFNGLCOLORMASKIPROC;
Public | GetBooleani_v: PFNGLGETBOOLEANI_VPROC;
Public | GetIntegeri_v: PFNGLGETINTEGERI_VPROC;
Public | Enablei: PFNGLENABLEIPROC;
Public | Disablei: PFNGLDISABLEIPROC;
Public | IsEnabledi: PFNGLISENABLEDIPROC;
Public | EnableVertexAttribArray: PFNGLENABLEVERTEXATTRIBARRAYPROC;
Public | DisableVertexAttribArray: PFNGLDISABLEVERTEXATTRIBARRAYPROC;
Public | VertexAttribDivisor: PFNGLVERTEXATTRIBDIVISORPROC;
Public | ClearColorIi: PFNGLCLEARCOLORIIEXTPROC;
Public | ClearColorIui: PFNGLCLEARCOLORIUIEXTPROC;
Public | TexParameterIiv: PFNGLTEXPARAMETERIIVPROC;
Public | TexParameterIuiv: PFNGLTEXPARAMETERIUIVPROC;
Public | GetTexParameterIiv: PFNGLGETTEXPARAMETERIIVPROC;
Public | GetTexParameterIuiv: PFNGLGETTEXPARAMETERIUIVPROC;
Public | PatchParameteri: PFNGLPATCHPARAMETERIPROC;
Public | PatchParameterfv: PFNGLPATCHPARAMETERFVPROC;
Public | BufferAddressRangeNV: PFNGLBUFFERADDRESSRANGENVPROC;
Public | VertexFormatNV: PFNGLVERTEXFORMATNVPROC;
Public | NormalFormatNV: PFNGLNORMALFORMATNVPROC;
Public | ColorFormatNV: PFNGLCOLORFORMATNVPROC;
Public | IndexFormatNV: PFNGLINDEXFORMATNVPROC;
Public | TexCoordFormatNV: PFNGLTEXCOORDFORMATNVPROC;
Public | EdgeFlagFormatNV: PFNGLEDGEFLAGFORMATNVPROC;
Public | SecondaryColorFormatNV: PFNGLSECONDARYCOLORFORMATNVPROC;
Public | FogCoordFormatNV: PFNGLFOGCOORDFORMATNVPROC;
Public | VertexAttribFormatNV: PFNGLVERTEXATTRIBFORMATNVPROC;
Public | VertexAttribIFormatNV: PFNGLVERTEXATTRIBIFORMATNVPROC;
Public | GetIntegerui64i_vNV: PFNGLGETINTEGERUI64I_VNVPROC;
Public | GetBufferParameterui64vNV: PGNGLGETBUFFERPARAMETERUI64VNV;
Public | MakeBufferResidentNV: PFNGLMAKEBUFFERRESIDENTNVPROC;
Public | MakeBufferNonResidentNV: PFNGLMAKEBUFFERNONRESIDENTNVPROC;
Public | IsBufferResidentNV: PFNGLISBUFFERRESIDENTNVPROC;
Public | MakeNamedBufferResidentNV: PFNGLMAKENAMEDBUFFERRESIDENTNVPROC;
Public | MakeNamedBufferNonResidentNV: PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC;
Public | IsNamedBufferResidentNV: PFNGLISNAMEDBUFFERRESIDENTNVPROC;
Public | GetNamedBufferParameterui64vNV: PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC;
Public | GetIntegerui64vNV: PFNGLGETINTEGERUI64VNVPROC;
Public | Uniformui64NV: PFNGLUNIFORMUI64NVPROC;
Public | Uniformui64vNV: PFNGLUNIFORMUI64VNVPROC;
Public | GetUniformui64vNV: PFNGLGETUNIFORMUI64VNVPROC;
Public | ProgramUniformui64NV: PFNGLPROGRAMUNIFORMUI64NVPROC;
Public | ProgramUniformui64vNV: PFNGLPROGRAMUNIFORMUI64VNVPROC;
Public | ClearBufferData: PFNGLClearBufferData;
Public | ClearBufferSubData: PFNGLClearBufferSubData;
Public | ClearNamedBufferData: PFNGLClearNamedBufferData;
Public | ClearNamedBufferSubData: PFNGLClearNamedBufferSubData;
Public | InvalidateTexSubImage: PFNGLInvalidateTexSubImage;
Public | InvalidateTexImage: PFNGLInvalidateTexImage;
Public | InvalidateBufferSubData: PFNGLInvalidateBufferSubData;
Public | InvalidateBufferData: PFNGLInvalidateBufferData;
Public | InvalidateFramebuffer: PFNGLInvalidateFramebuffer;
Public | InvalidateSubFramebuffer: PFNGLInvalidateSubFramebuffer;
Public | MultiDrawArraysIndirect: PFNGLMultiDrawArraysIndirect;
Public | MultiDrawElementsIndirect: PFNGLMultiDrawElementsIndirect;
Public | BindVertexBuffer: PFNGLBindVertexBuffer;
Public | VertexAttribFormat: PFNGLVertexAttribFormat;
Public | VertexAttribIFormat: PFNGLVertexAttribIFormat;
Public | VertexAttribLFormat: PFNGLVertexAttribLFormat;
Public | VertexAttribBinding: PFNGLVertexAttribBinding;
Public | VertexBindingDivisor: PFNGLVertexBindingDivisor;
Public | VertexArrayBindVertexBuffer: PFNGLVertexArrayBindVertexBuffer;
Public | VertexArrayVertexAttribFormat: PFNGLVertexArrayVertexAttribFormat;
Public | VertexArrayVertexAttribIFormat: PFNGLVertexArrayVertexAttribIFormat;
Public | VertexArrayVertexAttribLFormat: PFNGLVertexArrayVertexAttribLFormat;
Public | VertexArrayVertexAttribBinding: PFNGLVertexArrayVertexAttribBinding;
Public | VertexArrayVertexBindingDivisor: PFNGLVertexArrayVertexBindingDivisor;
Public | DeleteObject: PFNGLDELETEOBJECTARBPROC;
Public | GetHandle: PFNGLGETHANDLEARBPROC;
Public | DetachShader: PFNGLDETACHSHADERPROC;
Public | CreateShader: PFNGLCREATESHADERPROC;
Public | DeleteShader: PFNGLDELETESHADERPROC;
Public | ShaderSource: PFNGLSHADERSOURCEPROC;
Public | CompileShader: PFNGLCOMPILESHADERPROC;
Public | CreateProgram: PFNGLCREATEPROGRAMPROC;
Public | DeleteProgram: PFNGLDELETEPROGRAMPROC;
Public | AttachShader: PFNGLATTACHSHADERPROC;
Public | LinkProgram: PFNGLLINKPROGRAMPROC;
Public | UseProgram: PFNGLUSEPROGRAMPROC;
Public | ValidateProgram: PFNGLVALIDATEPROGRAMPROC;
Public | Uniform1f: PFNGLUNIFORM1FPROC;
Public | Uniform2f: PFNGLUNIFORM2FPROC;
Public | Uniform3f: PFNGLUNIFORM3FPROC;
Public | Uniform4f: PFNGLUNIFORM4FPROC;
Public | Uniform1i: PFNGLUNIFORM1IPROC;
Public | Uniform2i: PFNGLUNIFORM2IPROC;
Public | Uniform3i: PFNGLUNIFORM3IPROC;
Public | Uniform4i: PFNGLUNIFORM4IPROC;
Public | Uniform1fv: PFNGLUNIFORM1FVPROC;
Public | Uniform2fv: PFNGLUNIFORM2FVPROC;
Public | Uniform3fv: PFNGLUNIFORM3FVPROC;
Public | Uniform4fv: PFNGLUNIFORM4FVPROC;
Public | Uniform1iv: PFNGLUNIFORM1IVPROC;
Public | Uniform2iv: PFNGLUNIFORM2IVPROC;
Public | Uniform3iv: PFNGLUNIFORM3IVPROC;
Public | Uniform4iv: PFNGLUNIFORM4IVPROC;
Public | UniformMatrix2fv: PFNGLUNIFORMMATRIX2FVPROC;
Public | UniformMatrix3fv: PFNGLUNIFORMMATRIX3FVPROC;
Public | UniformMatrix4fv: PFNGLUNIFORMMATRIX4FVPROC;
Public | GetObjectParameterfv: PFNGLGETOBJECTPARAMETERFVARBPROC;
Public | GetObjectParameteriv: PFNGLGETOBJECTPARAMETERIVARBPROC;
Public | GetInfoLog: PFNGLGETINFOLOGARBPROC;
Public | GetAttachedObjects: PFNGLGETATTACHEDOBJECTSARBPROC;
Public | GetActiveAttrib: PFNGLGETACTIVEATTRIBPROC;
Public | GetActiveUniform: PFNGLGETACTIVEUNIFORMPROC;
Public | GetAttachedShaders: PFNGLGETATTACHEDSHADERSPROC;
Public | GetAttribLocation: PFNGLGETATTRIBLOCATIONPROC;
Public | GetProgramiv: PFNGLGETPROGRAMIVPROC;
Public | GetProgramInfoLog: PFNGLGETPROGRAMINFOLOGPROC;
Public | GetShaderiv: PFNGLGETSHADERIVPROC;
Public | GetShaderInfoLog: PFNGLGETSHADERINFOLOGPROC;
Public | GetShaderSource: PFNGLGETSHADERSOURCEPROC;
Public | GetUniformLocation: PFNGLGETUNIFORMLOCATIONPROC;
Public | GetUniformfv: PFNGLGETUNIFORMFVPROC;
Public | GetUniformiv: PFNGLGETUNIFORMIVPROC;
Public | GetVertexAttribdv: PFNGLGETVERTEXATTRIBDVPROC;
Public | GetVertexAttribfv: PFNGLGETVERTEXATTRIBFVPROC;
Public | GetVertexAttribiv: PFNGLGETVERTEXATTRIBIVPROC;
Public | GetVertexAttribPointerv: PFNGLGETVERTEXATTRIBPOINTERVPROC;
Public | IsProgram: PFNGLISPROGRAMPROC;
Public | IsShader: PFNGLISSHADERPROC;
Public | BindAttribLocation: PFNGLBINDATTRIBLOCATIONPROC;
Public | BindFragDataLocationIndexed: PFNGLBINDFRAGDATALOCATIONINDEXEDPROC;
Public | GetFragDataIndex: PFNGLGETFRAGDATAINDEXPROC;
Public | GetVaryingLocation: PFNGLGETVARYINGLOCATIONNVPROC;
Public | GetActiveVarying: PFNGLGETACTIVEVARYINGNVPROC;
Public | ActiveVarying: PFNGLACTIVEVARYINGNVPROC;
Public | GetProgramBinary: PFNGLGETPROGRAMBINARYPROC;
Public | ProgramBinary: PFNGLPROGRAMBINARYPROC;
Public | UseProgramStages: PFNGLUSEPROGRAMSTAGESPROC;
Public | ActiveShaderProgram: PFNGLACTIVESHADERPROGRAMPROC;
Public | CreateShaderProgramv: PFNGLCREATESHADERPROGRAMVPROC;
Public | BindProgramPipeline: PFNGLBINDPROGRAMPIPELINEPROC;
Public | DeleteProgramPipelines: PFNGLDELETEPROGRAMPIPELINESPROC;
Public | GenProgramPipelines: PFNGLGENPROGRAMPIPELINESPROC;
Public | IsProgramPipeline: PFNGLISPROGRAMPIPELINEPROC;
Public | GetProgramPipelineiv: PFNGLGETPROGRAMPIPELINEIVPROC;
Public | ProgramUniform1i: PFNGLPROGRAMUNIFORM1IPROC;
Public | ProgramUniform1iv: PFNGLPROGRAMUNIFORM1IVPROC;
Public | ProgramUniform1f: PFNGLPROGRAMUNIFORM1FPROC;
Public | ProgramUniform1fv: PFNGLPROGRAMUNIFORM1FVPROC;
Public | ProgramUniform1d: PFNGLPROGRAMUNIFORM1DPROC;
Public | ProgramUniform1dv: PFNGLPROGRAMUNIFORM1DVPROC;
Public | ProgramUniform1ui: PFNGLPROGRAMUNIFORM1UIPROC;
Public | ProgramUniform1uiv: PFNGLPROGRAMUNIFORM1UIVPROC;
Public | ProgramUniform2i: PFNGLPROGRAMUNIFORM2IPROC;
Public | ProgramUniform2iv: PFNGLPROGRAMUNIFORM2IVPROC;
Public | ProgramUniform2f: PFNGLPROGRAMUNIFORM2FPROC;
Public | ProgramUniform2fv: PFNGLPROGRAMUNIFORM2FVPROC;
Public | ProgramUniform2d: PFNGLPROGRAMUNIFORM2DPROC;
Public | ProgramUniform2dv: PFNGLPROGRAMUNIFORM2DVPROC;
Public | ProgramUniform2ui: PFNGLPROGRAMUNIFORM2UIPROC;
Public | ProgramUniform2uiv: PFNGLPROGRAMUNIFORM2UIVPROC;
Public | ProgramUniform3i: PFNGLPROGRAMUNIFORM3IPROC;
Public | ProgramUniform3iv: PFNGLPROGRAMUNIFORM3IVPROC;
Public | ProgramUniform3f: PFNGLPROGRAMUNIFORM3FPROC;
Public | ProgramUniform3fv: PFNGLPROGRAMUNIFORM3FVPROC;
Public | ProgramUniform3d: PFNGLPROGRAMUNIFORM3DPROC;
Public | ProgramUniform3dv: PFNGLPROGRAMUNIFORM3DVPROC;
Public | ProgramUniform3ui: PFNGLPROGRAMUNIFORM3UIPROC;
Public | ProgramUniform3uiv: PFNGLPROGRAMUNIFORM3UIVPROC;
Public | ProgramUniform4i: PFNGLPROGRAMUNIFORM4IPROC;
Public | ProgramUniform4iv: PFNGLPROGRAMUNIFORM4IVPROC;
Public | ProgramUniform4f: PFNGLPROGRAMUNIFORM4FPROC;
Public | ProgramUniform4fv: PFNGLPROGRAMUNIFORM4FVPROC;
Public | ProgramUniform4d: PFNGLPROGRAMUNIFORM4DPROC;
Public | ProgramUniform4dv: PFNGLPROGRAMUNIFORM4DVPROC;
Public | ProgramUniform4ui: PFNGLPROGRAMUNIFORM4UIPROC;
Public | ProgramUniform4uiv: PFNGLPROGRAMUNIFORM4UIVPROC;
Public | ProgramUniformMatrix2fv: PFNGLPROGRAMUNIFORMMATRIX2FVPROC;
Public | ProgramUniformMatrix3fv: PFNGLPROGRAMUNIFORMMATRIX3FVPROC;
Public | ProgramUniformMatrix4fv: PFNGLPROGRAMUNIFORMMATRIX4FVPROC;
Public | ProgramUniformMatrix2dv: PFNGLPROGRAMUNIFORMMATRIX2DVPROC;
Public | ProgramUniformMatrix3dv: PFNGLPROGRAMUNIFORMMATRIX3DVPROC;
Public | ProgramUniformMatrix4dv: PFNGLPROGRAMUNIFORMMATRIX4DVPROC;
Public | ProgramUniformMatrix2x3fv: PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC;
Public | ProgramUniformMatrix3x2fv: PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC;
Public | ProgramUniformMatrix2x4fv: PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC;
Public | ProgramUniformMatrix4x2fv: PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC;
Public | ProgramUniformMatrix3x4fv: PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC;
Public | ProgramUniformMatrix4x3fv: PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC;
Public | ProgramUniformMatrix2x3dv: PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC;
Public | ProgramUniformMatrix3x2dv: PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC;
Public | ProgramUniformMatrix2x4dv: PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC;
Public | ProgramUniformMatrix4x2dv: PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC;
Public | ProgramUniformMatrix3x4dv: PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC;
Public | ProgramUniformMatrix4x3dv: PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC;
Public | ValidateProgramPipeline: PFNGLVALIDATEPROGRAMPIPELINEPROC;
Public | GetProgramPipelineInfoLog: PFNGLGETPROGRAMPIPELINEINFOLOGPROC;
Public | DispatchCompute: PFNGLDispatchCompute;
Public | DispatchComputeIndirect: PFNGLDispatchComputeIndirect;
Public | ShaderStorageBlockBinding: PFNGLShaderStorageBlockBinding;
Public | IsRenderbuffer: PFNGLISRENDERBUFFERPROC;
Public | BindRenderbuffer: PFNGLBINDRENDERBUFFERPROC;
Public | DeleteRenderbuffers: PFNGLDELETERENDERBUFFERSPROC;
Public | GenRenderbuffers: PFNGLGENRENDERBUFFERSPROC;
Public | RenderbufferStorage: PFNGLRENDERBUFFERSTORAGEPROC;
Public | RenderbufferStorageMultisample: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC;
Public | GetRenderbufferParameteriv: PFNGLGETRENDERBUFFERPARAMETERIVPROC;
Public | IsFramebuffer: PFNGLISFRAMEBUFFERPROC;
Public | BindFramebuffer: PFNGLBINDFRAMEBUFFERPROC;
Public | DeleteFramebuffers: PFNGLDELETEFRAMEBUFFERSPROC;
Public | GenFramebuffers: PFNGLGENFRAMEBUFFERSPROC;
Public | CheckFramebufferStatus: PFNGLCHECKFRAMEBUFFERSTATUSPROC;
Public | FramebufferTexture: PFNGLFRAMEBUFFERTEXTUREPROC;
Public | FramebufferTexture1D: PFNGLFRAMEBUFFERTEXTURE1DPROC;
Public | FramebufferTexture2D: PFNGLFRAMEBUFFERTEXTURE2DPROC;
Public | FramebufferTexture3D: PFNGLFRAMEBUFFERTEXTURE3DPROC;
Public | FramebufferTextureLayer: PFNGLFRAMEBUFFERTEXTURELAYERPROC;
Public | FramebufferTextureFace: PFNGLFRAMEBUFFERTEXTUREFACEARBPROC;
Public | FramebufferRenderbuffer: PFNGLFRAMEBUFFERRENDERBUFFERPROC;
Public | GetFramebufferAttachmentParameteriv: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC;
Public | BlitFramebuffer: PFNGLBLITFRAMEBUFFERPROC;
Public | GenerateMipmap: PFNGLGENERATEMIPMAPPROC;
Public | FramebufferParameteri: PFNGLFramebufferParameteri;
Public | NamedFramebufferParameteri: PFNGLNamedFramebufferParameteri;
Public | GetNamedFramebufferParameteriv: PFNGLGetNamedFramebufferParameteriv;
Public | GenQueries: PFNGLGENQUERIESPROC;
Public | DeleteQueries: PFNGLDELETEQUERIESPROC;
Public | IsQuery: PFNGLISQUERYPROC;
Public | BeginQuery: PFNGLBEGINQUERYPROC;
Public | EndQuery: PFNGLENDQUERYPROC;
Public | GetQueryiv: PFNGLGETQUERYIVPROC;
Public | GetQueryObjectiv: PFNGLGETQUERYOBJECTIVPROC;
Public | GetQueryObjectuiv: PFNGLGETQUERYOBJECTUIVPROC;
Public | QueryCounter: PFNGLQUERYCOUNTERPROC;
Public | GetQueryObjecti64v: PFNGLGETQUERYOBJECTI64VPROC;
Public | GetQueryObjectui64v: PFNGLGETQUERYOBJECTUI64VPROC;
Public | GetInternalformati64v: PFNGLGetInternalformati64v;
Public | GetProgramInterfaceiv: PFNGLGetProgramInterfaceiv;
Public | GetProgramResourceIndex: PFNGLGetProgramResourceIndex;
Public | GetProgramResourceName: PFNGLGetProgramResourceName;
Public | GetProgramResourceiv: PFNGLGetProgramResourceiv;
Public | GetProgramResourceLocation: PFNGLGetProgramResourceLocation;
Public | GetProgramResourceLocationIndex: PFNGLGetProgramResourceLocationIndex;
Public | ActiveTexture: PFNGLACTIVETEXTUREPROC;
Public | SampleCoverage: PFNGLSAMPLECOVERAGEPROC;
Public | CompressedTexImage3D: PFNGLCOMPRESSEDTEXIMAGE3DPROC;
Public | CompressedTexImage2D: PFNGLCOMPRESSEDTEXIMAGE2DPROC;
Public | CompressedTexImage1D: PFNGLCOMPRESSEDTEXIMAGE1DPROC;
Public | CompressedTexSubImage3D: PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC;
Public | CompressedTexSubImage2D: PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC;
Public | CompressedTexSubImage1D: PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC;
Public | GetCompressedTexImage: PFNGLGETCOMPRESSEDTEXIMAGEPROC;
Public | ClientActiveTexture: PFNGLCLIENTACTIVETEXTUREPROC;
Public | MultiTexCoord1d: PFNGLMULTITEXCOORD1DPROC;
Public | MultiTexCoord1dV: PFNGLMULTITEXCOORD1DVPROC;
Public | MultiTexCoord1f: PFNGLMULTITEXCOORD1FPROC;
Public | MultiTexCoord1fv: PFNGLMULTITEXCOORD1FVPROC;
Public | MultiTexCoord1i: PFNGLMULTITEXCOORD1IPROC;
Public | MultiTexCoord1iv: PFNGLMULTITEXCOORD1IVPROC;
Public | MultiTexCoord1s: PFNGLMULTITEXCOORD1SPROC;
Public | MultiTexCoord1sv: PFNGLMULTITEXCOORD1SVPROC;
Public | MultiTexCoord2d: PFNGLMULTITEXCOORD2DPROC;
Public | MultiTexCoord2dv: PFNGLMULTITEXCOORD2DVPROC;
Public | MultiTexCoord2f: PFNGLMULTITEXCOORD2FPROC;
Public | MultiTexCoord2fv: PFNGLMULTITEXCOORD2FVPROC;
Public | MultiTexCoord2i: PFNGLMULTITEXCOORD2IPROC;
Public | MultiTexCoord2iv: PFNGLMULTITEXCOORD2IVPROC;
Public | MultiTexCoord2s: PFNGLMULTITEXCOORD2SPROC;
Public | MultiTexCoord2sv: PFNGLMULTITEXCOORD2SVPROC;
Public | MultiTexCoord3d: PFNGLMULTITEXCOORD3DPROC;
Public | MultiTexCoord3dv: PFNGLMULTITEXCOORD3DVPROC;
Public | MultiTexCoord3f: PFNGLMULTITEXCOORD3FPROC;
Public | MultiTexCoord3fv: PFNGLMULTITEXCOORD3FVPROC;
Public | MultiTexCoord3i: PFNGLMULTITEXCOORD3IPROC;
Public | MultiTexCoord3iv: PFNGLMULTITEXCOORD3IVPROC;
Public | MultiTexCoord3s: PFNGLMULTITEXCOORD3SPROC;
Public | MultiTexCoord3sv: PFNGLMULTITEXCOORD3SVPROC;
Public | MultiTexCoord4d: PFNGLMULTITEXCOORD4DPROC;
Public | MultiTexCoord4dv: PFNGLMULTITEXCOORD4DVPROC;
Public | MultiTexCoord4f: PFNGLMULTITEXCOORD4FPROC;
Public | MultiTexCoord4fv: PFNGLMULTITEXCOORD4FVPROC;
Public | MultiTexCoord4i: PFNGLMULTITEXCOORD4IPROC;
Public | MultiTexCoord4iv: PFNGLMULTITEXCOORD4IVPROC;
Public | MultiTexCoord4s: PFNGLMULTITEXCOORD4SPROC;
Public | MultiTexCoord4sv: PFNGLMULTITEXCOORD4SVPROC;
Public | GetInteger64i_v: PFNGLGETINTEGER64I_VPROC;
Public | GetBufferParameteri64v: PFNGLGETBUFFERPARAMETERI64VPROC;
Public | ProgramParameteri: PFNGLPROGRAMPARAMETERIPROC;
Public | ProgramString: PFNGLPROGRAMSTRINGARBPROC;
Public | BindProgram: PFNGLBINDPROGRAMARBPROC;
Public | DeletePrograms: PFNGLDELETEPROGRAMSARBPROC;
Public | GenPrograms: PFNGLGENPROGRAMSARBPROC;
Public | ProgramEnvParameter4d: PFNGLPROGRAMENVPARAMETER4DARBPROC;
Public | ProgramEnvParameter4dv: PFNGLPROGRAMENVPARAMETER4DVARBPROC;
Public | ProgramEnvParameter4f: PFNGLPROGRAMENVPARAMETER4FARBPROC;
Public | ProgramEnvParameter4fv: PFNGLPROGRAMENVPARAMETER4FVARBPROC;
Public | ProgramLocalParameter4d: PFNGLPROGRAMLOCALPARAMETER4DARBPROC;
Public | ProgramLocalParameter4dv: PFNGLPROGRAMLOCALPARAMETER4DVARBPROC;
Public | ProgramLocalParameter4f: PFNGLPROGRAMLOCALPARAMETER4FARBPROC;
Public | ProgramLocalParameter4fv: PFNGLPROGRAMLOCALPARAMETER4FVARBPROC;
Public | GetProgramEnvParameterdv: PFNGLGETPROGRAMENVPARAMETERDVARBPROC;
Public | GetProgramEnvParameterfv: PFNGLGETPROGRAMENVPARAMETERFVARBPROC;
Public | GetProgramLocalParameterdv: PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC;
Public | GetProgramLocalParameterfv: PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC;
Public | TexImage2DMultisample: PFNGLTEXIMAGE2DMULTISAMPLEPROC;
Public | TexImage3DMultisample: PFNGLTEXIMAGE3DMULTISAMPLEPROC;
Public | GetMultisamplefv: PFNGLGETMULTISAMPLEFVPROC;
Public | SampleMaski: PFNGLSAMPLEMASKIPROC;
Public | ProvokingVertex: PFNGLPROVOKINGVERTEXPROC;
Public | FenceSync: PFNGLFENCESYNCPROC;
Public | IsSync: PFNGLISSYNCPROC;
Public | DeleteSync: PFNGLDELETESYNCPROC;
Public | ClientWaitSync: PFNGLCLIENTWAITSYNCPROC;
Public | WaitSync: PFNGLWAITSYNCPROC;
Public | GetInteger64v: PFNGLGETINTEGER64VPROC;
Public | GetSynciv: PFNGLGETSYNCIVPROC;
Public | BlendEquationi: PFNGLBLENDEQUATIONIPROC;
Public | BlendEquationSeparatei: PFNGLBLENDEQUATIONSEPARATEIPROC;
Public | BlendFunci: PFNGLBLENDFUNCIPROC;
Public | BlendFuncSeparatei: PFNGLBLENDFUNCSEPARATEIPROC;
Public | MinSampleShading: PFNGLMINSAMPLESHADINGPROC;
Public | GenSamplers: PFNGLGENSAMPLERSPROC;
Public | DeleteSamplers: PFNGLDELETESAMPLERSPROC;
Public | IsSampler: PFNGLISSAMPLERPROC;
Public | BindSampler: PFNGLBINDSAMPLERPROC;
Public | SamplerParameteri: PFNGLSAMPLERPARAMETERIPROC;
Public | SamplerParameteriv: PFNGLSAMPLERPARAMETERIVPROC;
Public | SamplerParameterf: PFNGLSAMPLERPARAMETERFPROC;
Public | SamplerParameterfv: PFNGLSAMPLERPARAMETERFVPROC;
Public | SamplerParameterIiv: PFNGLSAMPLERPARAMETERIIVPROC;
Public | SamplerParameterIuiv: PFNGLSAMPLERPARAMETERIUIVPROC;
Public | GetSamplerParameteriv: PFNGLGETSAMPLERPARAMETERIVPROC;
Public | GetSamplerParameterIiv: PFNGLGETSAMPLERPARAMETERIIVPROC;
Public | GetSamplerParameterfv: PFNGLGETSAMPLERPARAMETERFVPROC;
Public | GetSamplerParameterIfv: PFNGLGETSAMPLERPARAMETERIFVPROC;
Public | CopyImageSubData: PFNGLCopyImageSubData;
Public | TexBufferRange: PFNGLTexBufferRange;
Public | TextureBufferRange: PFNGLTextureBufferRange;
Public | TexStorage2DMultisample: PFNGLTexStorage2DMultisample;
Public | TexStorage3DMultisample: PFNGLTexStorage3DMultisample;
Public | TextureStorage2DMultisample: PFNGLTextureStorage2DMultisample;
Public | TextureStorage3DMultisample: PFNGLTextureStorage3DMultisample;
Public | BufferStorage: PFNGLBufferStorage;
Public | ClearTexImage: PFNGLClearTexImage;
Public | ClearTexSubImage: PFNGLClearTexSubImage;
Public | BindBuffersBase: PFNGLBindBuffersBase;
Public | BindBuffersRange: PFNGLBindBuffersRange;
Public | BindTextures: PFNGLBindTextures;
Public | BindSamplers: PFNGLBindSamplers;
Public | BindImageTextures: PFNGLBindImageTextures;
Public | BindVertexBuffers: PFNGLBindVertexBuffers;
Public | TextureView: PFNGLTextureView;
Public | ClientAttribDefault: PFNGLCLIENTATTRIBDEFAULTEXTPROC;
Public | PushClientAttribDefault: PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC;
Public | MatrixLoadf: PFNGLMATRIXLOADFEXTPROC;
Public | MatrixLoadd: PFNGLMATRIXLOADDEXTPROC;
Public | MatrixMultf: PFNGLMATRIXMULTFEXTPROC;
Public | MatrixMultd: PFNGLMATRIXMULTDEXTPROC;
Public | MatrixLoadIdentity: PFNGLMATRIXLOADIDENTITYEXTPROC;
Public | MatrixRotatef: PFNGLMATRIXROTATEFEXTPROC;
Public | MatrixRotated: PFNGLMATRIXROTATEDEXTPROC;
Public | MatrixScalef: PFNGLMATRIXSCALEFEXTPROC;
Public | MatrixScaled: PFNGLMATRIXSCALEDEXTPROC;
Public | MatrixTranslatef: PFNGLMATRIXTRANSLATEFEXTPROC;
Public | MatrixTranslated: PFNGLMATRIXTRANSLATEDEXTPROC;
Public | MatrixFrustum: PFNGLMATRIXFRUSTUMEXTPROC;
Public | MatrixOrtho: PFNGLMATRIXORTHOEXTPROC;
Public | MatrixPop: PFNGLMATRIXPOPEXTPROC;
Public | MatrixPush: PFNGLMATRIXPUSHEXTPROC;
Public | MatrixLoadTransposef: PFNGLMATRIXLOADTRANSPOSEFEXTPROC;
Public | MatrixLoadTransposed: PFNGLMATRIXLOADTRANSPOSEDEXTPROC;
Public | MatrixMultTransposef: PFNGLMATRIXMULTTRANSPOSEFEXTPROC;
Public | MatrixMultTransposed: PFNGLMATRIXMULTTRANSPOSEDEXTPROC;
Public | TextureParameterfv: PFNGLTEXTUREPARAMETERFVEXTPROC;
Public | TextureParameteri: PFNGLTEXTUREPARAMETERIEXTPROC;
Public | TextureParameteriv: PFNGLTEXTUREPARAMETERIVEXTPROC;
Public | TextureImage1D: PFNGLTEXTUREIMAGE1DEXTPROC;
Public | TextureImage2D: PFNGLTEXTUREIMAGE2DEXTPROC;
Public | TextureSubImage1D: PFNGLTEXTURESUBIMAGE1DEXTPROC;
Public | TextureSubImage2D: PFNGLTEXTURESUBIMAGE2DEXTPROC;
Public | CopyTextureImage1D: PFNGLCOPYTEXTUREIMAGE1DEXTPROC;
Public | CopyTextureImage2D: PFNGLCOPYTEXTUREIMAGE2DEXTPROC;
Public | CopyTextureSubImage1D: PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC;
Public | CopyTextureSubImage2D: PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC;
Public | GetTextureImage: PFNGLGETTEXTUREIMAGEEXTPROC;
Public | GetTextureParameterfv: PFNGLGETTEXTUREPARAMETERFVEXTPROC;
Public | GetTextureParameteriv: PFNGLGETTEXTUREPARAMETERIVEXTPROC;
Public | GetTextureLevelParameterfv: PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC;
Public | GetTextureLevelParameteriv: PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC;
Public | TextureImage3D: PFNGLTEXTUREIMAGE3DEXTPROC;
Public | TextureSubImage3D: PFNGLTEXTURESUBIMAGE3DEXTPROC;
Public | CopyTextureSubImage3D: PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC;
Public | MultiTexParameterf: PFNGLMULTITEXPARAMETERFEXTPROC;
Public | MultiTexParameterfv: PFNGLMULTITEXPARAMETERFVEXTPROC;
Public | MultiTexParameteri: PFNGLMULTITEXPARAMETERIEXTPROC;
Public | MultiTexParameteriv: PFNGLMULTITEXPARAMETERIVEXTPROC;
Public | MultiTexImage1D: PFNGLMULTITEXIMAGE1DEXTPROC;
Public | MultiTexImage2D: PFNGLMULTITEXIMAGE2DEXTPROC;
Public | MultiTexSubImage1D: PFNGLMULTITEXSUBIMAGE1DEXTPROC;
Public | MultiTexSubImage2D: PFNGLMULTITEXSUBIMAGE2DEXTPROC;
Public | CopyMultiTexImage1D: PFNGLCOPYMULTITEXIMAGE1DEXTPROC;
Public | CopyMultiTexImage2D: PFNGLCOPYMULTITEXIMAGE2DEXTPROC;
Public | CopyMultiTexSubImage1D: PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC;
Public | CopyMultiTexSubImage2D: PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC;
Public | GetMultiTexImage: PFNGLGETMULTITEXIMAGEEXTPROC;
Public | GetMultiTexParameterfv: PFNGLGETMULTITEXPARAMETERFVEXTPROC;
Public | GetMultiTexParameteriv: PFNGLGETMULTITEXPARAMETERIVEXTPROC;
Public | GetMultiTexLevelParameterfv: PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC;
Public | GetMultiTexLevelParameteriv: PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC;
Public | MultiTexImage3D: PFNGLMULTITEXIMAGE3DEXTPROC;
Public | MultiTexSubImage3D: PFNGLMULTITEXSUBIMAGE3DEXTPROC;
Public | CopyMultiTexSubImage3D: PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC;
Public | BindMultiTexture: PFNGLBINDMULTITEXTUREEXTPROC;
Public | EnableClientStateIndexed: PFNGLENABLECLIENTSTATEINDEXEDEXTPROC;
Public | DisableClientStateIndexed: PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC;
Public | MultiTexCoordPointer: PFNGLMULTITEXCOORDPOINTEREXTPROC;
Public | MultiTexEnvf: PFNGLMULTITEXENVFEXTPROC;
Public | MultiTexEnvfv: PFNGLMULTITEXENVFVEXTPROC;
Public | MultiTexEnvi: PFNGLMULTITEXENVIEXTPROC;
Public | MultiTexEnviv: PFNGLMULTITEXENVIVEXTPROC;
Public | MultiTexGend: PFNGLMULTITEXGENDEXTPROC;
Public | MultiTexGendv: PFNGLMULTITEXGENDVEXTPROC;
Public | MultiTexGenf: PFNGLMULTITEXGENFEXTPROC;
Public | MultiTexGenfv: PFNGLMULTITEXGENFVEXTPROC;
Public | MultiTexGeni: PFNGLMULTITEXGENIEXTPROC;
Public | MultiTexGeniv: PFNGLMULTITEXGENIVEXTPROC;
Public | GetMultiTexEnvfv: PFNGLGETMULTITEXENVFVEXTPROC;
Public | GetMultiTexEnviv: PFNGLGETMULTITEXENVIVEXTPROC;
Public | GetMultiTexGendv: PFNGLGETMULTITEXGENDVEXTPROC;
Public | GetMultiTexGenfv: PFNGLGETMULTITEXGENFVEXTPROC;
Public | GetMultiTexGeniv: PFNGLGETMULTITEXGENIVEXTPROC;
Public | GetFloatIndexedv: PFNGLGETFLOATINDEXEDVEXTPROC;
Public | GetDoubleIndexedv: PFNGLGETDOUBLEINDEXEDVEXTPROC;
Public | GetPointerIndexedv: PFNGLGETPOINTERINDEXEDVEXTPROC;
Public | CompressedTextureImage3D: PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC;
Public | CompressedTextureImage2D: PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC;
Public | CompressedTextureImage1D: PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC;
Public | CompressedTextureSubImage3D: PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC;
Public | CompressedTextureSubImage2D: PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC;
Public | CompressedTextureSubImage1D: PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC;
Public | GetCompressedTextureImage: PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC;
Public | CompressedMultiTexImage3D: PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC;
Public | CompressedMultiTexImage2D: PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC;
Public | CompressedMultiTexImage1D: PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC;
Public | CompressedMultiTexSubImage3D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC;
Public | CompressedMultiTexSubImage2D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC;
Public | CompressedMultiTexSubImage1D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC;
Public | GetCompressedMultiTexImage: PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC;
Public | NamedProgramString: PFNGLNAMEDPROGRAMSTRINGEXTPROC;
Public | NamedProgramLocalParameter4d: PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC;
Public | NamedProgramLocalParameter4dv: PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC;
Public | NamedProgramLocalParameter4f: PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC;
Public | NamedProgramLocalParameter4fv: PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC;
Public | GetNamedProgramLocalParameterdv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC;
Public | GetNamedProgramLocalParameterfv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC;
Public | GetNamedProgramiv: PFNGLGETNAMEDPROGRAMIVEXTPROC;
Public | GetNamedProgramString: PFNGLGETNAMEDPROGRAMSTRINGEXTPROC;
Public | NamedProgramLocalParameters4fv: PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC;
Public | NamedProgramLocalParameterI4i: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC;
Public | NamedProgramLocalParameterI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC;
Public | NamedProgramLocalParametersI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC;
Public | NamedProgramLocalParameterI4ui: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC;
Public | NamedProgramLocalParameterI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC;
Public | NamedProgramLocalParametersI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC;
Public | GetNamedProgramLocalParameterIiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC;
Public | GetNamedProgramLocalParameterIuiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC;
Public | TextureParameterIiv: PFNGLTEXTUREPARAMETERIIVEXTPROC;
Public | TextureParameterIuiv: PFNGLTEXTUREPARAMETERIUIVEXTPROC;
Public | GetTextureParameterIiv: PFNGLGETTEXTUREPARAMETERIIVEXTPROC;
Public | GetTextureParameterIuiv: PFNGLGETTEXTUREPARAMETERIUIVEXTPROC;
Public | MultiTexParameterIiv: PFNGLMULTITEXPARAMETERIIVEXTPROC;
Public | MultiTexParameterIuiv: PFNGLMULTITEXPARAMETERIUIVEXTPROC;
Public | GetMultiTexParameterIiv: PFNGLGETMULTITEXPARAMETERIIVEXTPROC;
Public | GetMultiTexParameterIuiv: PFNGLGETMULTITEXPARAMETERIUIVEXTPROC;
Public | NamedBufferData: PFNGLNAMEDBUFFERDATAEXTPROC;
Public | NamedBufferSubData: PFNGLNAMEDBUFFERSUBDATAEXTPROC;
Public | MapNamedBuffer: PFNGLMAPNAMEDBUFFEREXTPROC;
Public | UnmapNamedBuffer: PFNGLUNMAPNAMEDBUFFEREXTPROC;
Public | MapNamedBufferRange: PFNGLMAPNAMEDBUFFERRANGEEXTPROC;
Public | FlushMappedNamedBufferRange: PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC;
Public | NamedCopyBufferSubData: PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC;
Public | GetNamedBufferParameteriv: PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC;
Public | GetNamedBufferPointerv: PFNGLGETNAMEDBUFFERPOINTERVEXTPROC;
Public | GetNamedBufferSubData: PFNGLGETNAMEDBUFFERSUBDATAEXTPROC;
Public | TextureBuffer: PFNGLTEXTUREBUFFEREXTPROC;
Public | MultiTexBuffer: PFNGLMULTITEXBUFFEREXTPROC;
Public | NamedRenderbufferStorage: PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC;
Public | GetNamedRenderbufferParameteriv: PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC;
Public | CheckNamedFramebufferStatus: PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC;
Public | NamedFramebufferTexture1D: PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC;
Public | NamedFramebufferTexture2D: PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC;
Public | NamedFramebufferTexture3D: PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC;
Public | NamedFramebufferRenderbuffer: PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC;
Public | GetNamedFramebufferAttachmentParameteriv: PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC;
Public | GenerateTextureMipmap: PFNGLGENERATETEXTUREMIPMAPEXTPROC;
Public | GenerateMultiTexMipmap: PFNGLGENERATEMULTITEXMIPMAPEXTPROC;
Public | FramebufferDrawBuffer: PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC;
Public | FramebufferDrawBuffers: PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC;
Public | FramebufferReadBuffer: PFNGLFRAMEBUFFERREADBUFFEREXTPROC;
Public | GetFramebufferParameteriv: PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC;
Public | NamedRenderbufferStorageMultisample: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC;
Public | NamedRenderbufferStorageMultisampleCoverage: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC;
Public | NamedFramebufferTexture: PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC;
Public | NamedFramebufferTextureLayer: PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC;
Public | NamedFramebufferTextureFace: PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC;
Public | TextureRenderbuffer: PFNGLTEXTURERENDERBUFFEREXTPROC;
Public | MultiTexRenderbuffer: PFNGLMULTITEXRENDERBUFFEREXTPROC;
Public | FrameTerminatorGREMEDY: PFNGLFRAMETERMINATORGREMEDYPROC;
Public | StringMarkerGREMEDY: PFNGLSTRINGMARKERGREMEDYPROC;
Public | DebugMessageEnableAMDX: procedure(category: Cardinal; severity: Cardinal; Count: TGLsizei; var ids: Cardinal; Enabled: boolean);
Public | PushDebugGroup: PFNGLPushDebugGroup;
Public | PopDebugGroup: PFNGLPopDebugGroup;
Public | ObjectLabel: PFNGLObjectLabel;
Public | GetObjectLabel: PFNGLGetObjectLabel;
Public | ObjectPtrLabel: PFNGLObjectPtrLabel;
Public | GetObjectPtrLabel: PFNGLGetObjectPtrLabel;
Public | DebugMessageCallbackAMDX: procedure(callback: TDebugProcAMD; userParam: Pointer); stdcall;
Public | DebugMessageControl: procedure(type_: Cardinal; Source: Cardinal; severity: Cardinal; Count: TGLsizei; var ids: Cardinal; Enabled: boolean); stdcall;
Public | DebugMessageInsert: procedure(Source: Cardinal; severity: Cardinal; id: Cardinal; length: TGLsizei; const buf: PAnsiChar); stdcall;
Public | DebugMessageCallback: procedure(callback: TDebugProc; userParam: Pointer); stdcall;
Public | GetDebugMessageLog: function(Count: Cardinal; bufSize: TGLsizei; var severity: Cardinal; var severities: Cardinal; var ids: Cardinal; var lengths: TGLsizei; messageLog: PAnsiChar): Cardinal; stdcall;
Public | CreateSyncFromCLevent: PFNGLCreateSyncFromCLevent;
Public | VDPAUInitNV: procedure(const vdpDevice: Pointer; const getProcAddress: Pointer); stdcall;
Public | VDPAUFiniNV: procedure(); stdcall;
Public | VDPAURegisterVideoSurfaceNV: function(const vdpSurface: Pointer; target: Cardinal; numTextureNames: TGLsizei; const textureNames: PGLuint) : TGLvdpauSurfaceNV; stdcall;
Public | VDPAURegisterOutputSurfaceNV: function(const vdpSurface: Pointer; target: Cardinal; numTextureNames: TGLsizei; const textureNames: PGLuint) : TGLvdpauSurfaceNV; stdcall;
Public | VDPAUIsSurfaceNV: procedure(surface: TGLvdpauSurfaceNV); stdcall;
Public | VDPAUUnregisterSurfaceNV: procedure(surface: TGLvdpauSurfaceNV); stdcall;
Public | VDPAUGetSurfaceivNV: procedure(surface: TGLvdpauSurfaceNV; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;
Public | VDPAUSurfaceAccessNV: procedure(surface: TGLvdpauSurfaceNV; access: Cardinal); stdcall;
Public | VDPAUMapSurfacesNV: procedure(numSurfaces: TGLsizei; const surfaces: PGLvdpauSurfaceNV); stdcall;
Public | VDPAUUnmapSurfacesNV: procedure(numSurface: TGLsizei; const surfaces: PGLvdpauSurfaceNV); stdcall;
Public | GenPathsNV: PFNGLGENPATHSNVPROC;
Public | DeletePathsNV: PFNGLDELETEPATHSNVPROC;
Public | IsPathNV: PFNGLISPATHNVPROC;
Public | PathCommandsNV: PFNGLPATHCOMMANDSNVPROC;
Public | PathCoordsNV: PFNGLPATHCOORDSNVPROC;
Public | PathSubCommandsNV: PFNGLPATHSUBCOMMANDSNVPROC;
Public | PathSubCoordsNV: PFNGLPATHSUBCOORDSNVPROC;
Public | PathStringNV: PFNGLPATHSTRINGNVPROC;
Public | PathGlyphsNV: PFNGLPATHGLYPHSNVPROC;
Public | PathGlyphRangeNV: PFNGLPATHGLYPHRANGENVPROC;
Public | WeightPathsNV: PFNGLWEIGHTPATHSNVPROC;
Public | CopyPathNV: PFNGLCOPYPATHNVPROC;
Public | InterpolatePathsNV: PFNGLINTERPOLATEPATHSNVPROC;
Public | PathParameterivNV: PFNGLPATHPARAMETERIVNVPROC;
Public | PathParameteriNV: PFNGLPATHPARAMETERINVPROC;
Public | PathParameterfvNV: PFNGLPATHPARAMETERFVNVPROC;
Public | PathParameterfNV: PFNGLPATHPARAMETERFNVPROC;
Public | PathDashArrayNV: PFNGLPATHDASHARRAYNVPROC;
Public | PathStencilFuncNV: PFNGLPATHSTENCILFUNCNVPROC;
Public | StencilFillPathNV: PFNGLSTENCILFILLPATHNVPROC;
Public | StencilStrokePathNV: PFNGLSTENCILSTROKEPATHNVPROC;
Public | StencilFillPathInstancedNV: PFNGLSTENCILFILLPATHINSTANCEDNVPROC;
Public | StencilStrokePathInstancedNV: PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC;
Public | PathColorGenNV: PFNGLPATHCOLORGENNVPROC;
Public | PathTexGenNV: PFNGLPATHTEXGENNVPROC;
Public | PathFogGenNV: PFNGLPATHFOGGENNVPROC;
Public | CoverFillPathNV: PFNGLCOVERFILLPATHNVPROC;
Public | CoverStrokePathNV: PFNGLCOVERSTROKEPATHNVPROC;
Public | CoverFillPathInstancedNV: PFNGLCOVERFILLPATHINSTANCEDNVPROC;
Public | CoverStrokePathInstancedNV: PFNGLCOVERSTROKEPATHINSTANCEDNVPROC;
Public | GetPathParameterivNV: PFNGLGETPATHPARAMETERIVNVPROC;
Public | GetPathParameterfvNV: PFNGLGETPATHPARAMETERFVNVPROC;
Public | GetPathCommandsNV: PFNGLGETPATHCOMMANDSNVPROC;
Public | GetPathCoordsNV: PFNGLGETPATHCOORDSNVPROC;
Public | GetPathDashArrayNV: PFNGLGETPATHDASHARRAYNVPROC;
Public | GetPathMetricsNV: PFNGLGETPATHMETRICSNVPROC;
Public | GetPathMetricRangeNV: PFNGLGETPATHMETRICRANGENVPROC;
Public | GetPathSpacingNV: PFNGLGETPATHSPACINGNVPROC;
Public | GetPathColorGenivNV: PFNGLGETPATHCOLORGENIVNVPROC;
Public | GetPathColorGenfvNV: PFNGLGETPATHCOLORGENFVNVPROC;
Public | GetPathTexGenivNV: PFNGLGETPATHTEXGENIVNVPROC;
Public | GetPathTexGenfvNV: PFNGLGETPATHTEXGENFVNVPROC;
Public | IsPointInFillPathNV: PFNGLISPOINTINFILLPATHNVPROC;
Public | IsPointInStrokePathNV: PFNGLISPOINTINSTROKEPATHNVPROC;
Public | GetPathLengthNV: PFNGLGETPATHLENGTHNVPROC;
Public | PointAlongPathNV: PFNGLPOINTALONGPATHNVPROC;
Public | PathStencilDepthOffsetNV: PFNGLPATHSTENCILDEPTHOFFSETNVPROC;
Public | PathCoverDepthFuncNV: PFNGLPATHCOVERDEPTHFUNCNVPROC;
Public | W_ARB_buffer_region: boolean;
Public | W_ARB_create_context: boolean;
Public | W_ARB_create_context_profile: boolean;
Public | W_ARB_extensions_string: boolean;
Public | W_ARB_framebuffer_sRGB: boolean;
Public | W_ARB_make_current_read: boolean;
Public | W_ARB_multisample: boolean;
Public | W_ARB_pbuffer: boolean;
Public | W_ARB_pixel_format: boolean;
Public | W_ARB_pixel_format_float: boolean;
Public | W_ARB_render_texture: boolean;
Public | W_ATI_pixel_format_float: boolean;
Public | W_EXT_framebuffer_sRGB: boolean;
Public | W_EXT_pixel_format_packed_float: boolean;
Public | W_EXT_swap_control: boolean;
Public | W_NV_gpu_affinity: boolean;
Public | W_EXT_create_context_es2_profile: boolean;
Public | W_NV_DX_interop: boolean;
Public | W_NV_DX_interop2: boolean;
Public | WCreateBufferRegionARB: PFNWGLCREATEBUFFERREGIONARBPROC;
Public | WDeleteBufferRegionARB: PFNWGLDELETEBUFFERREGIONARBPROC;
Public | WSaveBufferRegionARB: PFNWGLSAVEBUFFERREGIONARBPROC;
Public | WRestoreBufferRegionARB: PFNWGLRESTOREBUFFERREGIONARBPROC;
Public | WGetExtensionsStringARB: PFNWGLGETEXTENSIONSSTRINGARBPROC;
Public | WGetPixelFormatAttribivARB: PFNWGLGETPIXELFORMATATTRIBIVARBPROC;
Public | WGetPixelFormatAttribfvARB: PFNWGLGETPIXELFORMATATTRIBFVARBPROC;
Public | WChoosePixelFormatARB: PFNWGLCHOOSEPIXELFORMATARBPROC;
Public | WMakeContextCurrentARB: PFNWGLMAKECONTEXTCURRENTARBPROC;
Public | WGetCurrentReadDCARB: PFNWGLGETCURRENTREADDCARBPROC;
Public | WCreatePbufferARB: PFNWGLCREATEPBUFFERARBPROC;
Public | WGetPbufferDCARB: PFNWGLGETPBUFFERDCARBPROC;
Public | WReleasePbufferDCARB: PFNWGLRELEASEPBUFFERDCARBPROC;
Public | WDestroyPbufferARB: PFNWGLDESTROYPBUFFERARBPROC;
Public | WQueryPbufferARB: PFNWGLQUERYPBUFFERARBPROC;
Public | WBindTexImageARB: PFNWGLBINDTEXIMAGEARBPROC;
Public | WReleaseTexImageARB: PFNWGLRELEASETEXIMAGEARBPROC;
Public | WSetPbufferAttribARB: PFNWGLSETPBUFFERATTRIBARBPROC;
Public | WCreateContextAttribsARB: PFNWGLCREATECONTEXTATTRIBSARBPROC;
Public | WEnumGpusNV: PFNWGLENUMGPUSNVPROC;
Public | WEnumGpuDevicesNV: PFNWGLENUMGPUDEVICESNVPROC;
Public | WCreateAffinityDCNV: PFNWGLCREATEAFFINITYDCNVPROC;
Public | WEnumGpusFromAffinityDCNV: PFNWGLENUMGPUSFROMAFFINITYDCNVPROC;
Public | WDeleteDCNV: PFNWGLDELETEDCNVPROC;
Public | WDXSetResourceShareHandleNV: PFNWGLDXSETRESOURCESHAREHANDLEPROC;
Public | WDXOpenDeviceNV: PFNWGLDXOPENDEVICEPROC;
Public | WDXCloseDeviceNV: PFNWGLDXCLOSEDEVICEPROC;
Public | WDXRegisterObjectNV: PFNWGLDXREGISTEROBJECTPROC;
Public | WDXUnregisterObjectNV: PFNWGLDXUNREGISTEROBJECTPROC;
Public | WDXObjectAccessNV: PFNWGLDXOBJECTACCESSPROC;
Public | WDXLockObjectsNV: PFNWGLDXLOCKOBJECTSPROC;
Public | WDXUnlockObjectsNV: PFNWGLDXUNLOCKOBJECTSNVPROC;
Public | WSwapIntervalEXT: PFNWGLSWAPINTERVALEXTPROC;
Public | WGetSwapIntervalEXT: PFNWGLGETSWAPINTERVALEXTPROC;
Public | WAllocateMemoryNV: PFNWGLALLOCATEMEMORYNVPROC;
Public | WFreeMemoryNV: PFNWGLFREEMEMORYNVPROC;
Public | UNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;
Public | UNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;
Public | UDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

Methods

Public | constructor Create;
Private | function CheckExtension(const Extension: string): boolean;
Private | function GetAddress(const ProcName: string): Pointer;
Private | function GetAddressAlt(const ProcName1, ProcName2: string): Pointer;
Private | function GetAddressNoSuffixes(const ProcName: string): Pointer;
Private | function GetCapAddress: Pointer;
Public | procedure CheckError;
Public | procedure ClearError;
Public | procedure Close;
Public | procedure Initialize(ATemporary: boolean = False);
Private | procedure ReadWGLExtensions;
Private | procedure ReadWGLImplementationProperties;

Properties

Public | property DebugMode: boolean read FDebug write FDebug;
Public | property IsInitialized: boolean read FInitialized;

Description

Fields

Private FBuffer: string;

This item has no description.

Private FInitialized: boolean;

This item has no description.

Private FDebug: boolean;

This item has no description.

Private FDebugIds: Cardinal;

This item has no description.

Public VERSION_1_0: boolean;

This item has no description.

Public VERSION_1_1: boolean;

This item has no description.

Public VERSION_1_2: boolean;

This item has no description.

Public VERSION_1_3: boolean;

This item has no description.

Public VERSION_1_4: boolean;

This item has no description.

Public VERSION_1_5: boolean;

This item has no description.

Public VERSION_2_0: boolean;

This item has no description.

Public VERSION_2_1: boolean;

This item has no description.

Public VERSION_3_0: boolean;

This item has no description.

Public VERSION_3_1: boolean;

This item has no description.

Public VERSION_3_2: boolean;

This item has no description.

Public VERSION_3_3: boolean;

This item has no description.

Public VERSION_4_0: boolean;

This item has no description.

Public VERSION_4_1: boolean;

This item has no description.

Public VERSION_4_2: boolean;

This item has no description.

Public ARB_blend_func_extended: boolean;

This item has no description.

Public ARB_color_buffer_float: boolean;

This item has no description.

Public ARB_compatibility: boolean;

This item has no description.

Public ARB_copy_buffer: boolean;

This item has no description.

Public ARB_depth_buffer_float: boolean;

This item has no description.

Public ARB_depth_clamp: boolean;

This item has no description.

Public ARB_depth_texture: boolean;

This item has no description.

Public ARB_draw_buffers: boolean;

This item has no description.

Public ARB_draw_buffers_blend: boolean;

This item has no description.

Public ARB_draw_elements_base_vertex: boolean;

This item has no description.

Public ARB_draw_indirect: boolean;

This item has no description.

Public ARB_draw_instanced: boolean;

This item has no description.

Public ARB_explicit_attrib_location: boolean;

This item has no description.

Public ARB_fragment_coord_conventions: boolean;

This item has no description.

Public ARB_fragment_program: boolean;

This item has no description.

Public ARB_fragment_program_shadow: boolean;

This item has no description.

Public ARB_fragment_shader: boolean;

This item has no description.

Public ARB_framebuffer_object: boolean;

This item has no description.

Public ARB_framebuffer_sRGB: boolean;

This item has no description.

Public ARB_geometry_shader4: boolean;

This item has no description.

Public ARB_gpu_shader_fp64: boolean;

This item has no description.

Public ARB_gpu_shader5: boolean;

This item has no description.

Public ARB_half_float_pixel: boolean;

This item has no description.

Public ARB_half_float_vertex: boolean;

This item has no description.

Public ARB_imaging: boolean;

This item has no description.

Public ARB_instanced_arrays: boolean;

This item has no description.

Public ARB_map_buffer_range: boolean;

This item has no description.

Public ARB_matrix_palette: boolean;

This item has no description.

Public ARB_multisample: boolean;

This item has no description.

Public ARB_multitexture: boolean;

This item has no description.

Public ARB_occlusion_query: boolean;

This item has no description.

Public ARB_occlusion_query2: boolean;

This item has no description.

Public ARB_pixel_buffer_object: boolean;

This item has no description.

Public ARB_point_parameters: boolean;

This item has no description.

Public ARB_point_sprite: boolean;

This item has no description.

Public ARB_provoking_vertex: boolean;

This item has no description.

Public ARB_sample_shading: boolean;

This item has no description.

Public ARB_sampler_objects: boolean;

This item has no description.

Public ARB_seamless_cube_map: boolean;

This item has no description.

Public ARB_shader_bit_encoding: boolean;

This item has no description.

Public ARB_shader_subroutine: boolean;

This item has no description.

Public ARB_shader_texture_lod: boolean;

This item has no description.

Public ARB_shading_language_100: boolean;

This item has no description.

Public ARB_shadow: boolean;

This item has no description.

Public ARB_shadow_ambient: boolean;

This item has no description.

Public ARB_shader_objects: boolean;

This item has no description.

Public ARB_sync: boolean;

This item has no description.

Public ARB_tessellation_shader: boolean;

This item has no description.

Public ARB_texture_border_clamp: boolean;

This item has no description.

Public ARB_texture_buffer_object: boolean;

This item has no description.

Public ARB_texture_buffer_object_rgb32: boolean;

This item has no description.

Public ARB_texture_compression: boolean;

This item has no description.

Public ARB_texture_compression_rgtc: boolean;

This item has no description.

Public ARB_texture_cube_map: boolean;

This item has no description.

Public ARB_texture_cube_map_array: boolean;

This item has no description.

Public ARB_texture_env_add: boolean;

This item has no description.

Public ARB_texture_env_combine: boolean;

This item has no description.

Public ARB_texture_env_crossbar: boolean;

This item has no description.

Public ARB_texture_env_dot3: boolean;

This item has no description.

Public ARB_texture_float: boolean;

This item has no description.

Public ARB_texture_gather: boolean;

This item has no description.

Public ARB_texture_mirrored_repeat: boolean;

This item has no description.

Public ARB_texture_multisample: boolean;

This item has no description.

Public ARB_texture_non_power_of_two: boolean;

This item has no description.

Public ARB_texture_query_lod: boolean;

This item has no description.

Public ARB_texture_rectangle: boolean;

This item has no description.

Public ARB_texture_rg: boolean;

This item has no description.

Public ARB_texture_rgb10_a2ui: boolean;

This item has no description.

Public ARB_texture_swizzle: boolean;

This item has no description.

Public ARB_timer_query: boolean;

This item has no description.

Public ARB_transform_feedback2: boolean;

This item has no description.

Public ARB_transform_feedback3: boolean;

This item has no description.

Public ARB_transpose_matrix: boolean;

This item has no description.

Public ARB_uniform_buffer_object: boolean;

This item has no description.

Public ARB_vertex_array_bgra: boolean;

This item has no description.

Public ARB_vertex_array_object: boolean;

This item has no description.

Public ARB_vertex_blend: boolean;

This item has no description.

Public ARB_vertex_buffer_object: boolean;

This item has no description.

Public ARB_vertex_program: boolean;

This item has no description.

Public ARB_vertex_shader: boolean;

This item has no description.

Public ARB_vertex_type_2_10_10_10_rev: boolean;

This item has no description.

Public ARB_window_pos: boolean;

This item has no description.

Public ARB_texture_compression_bptc: boolean;

This item has no description.

Public ARB_get_program_binary: boolean;

This item has no description.

Public ARB_separate_shader_objects: boolean;

This item has no description.

Public ARB_shader_stencil_export: boolean;

This item has no description.

Public KHR_debug: boolean;

This item has no description.

Public ARB_clear_buffer_object: boolean;

This item has no description.

Public ARB_compute_shader: boolean;

This item has no description.

Public ARB_copy_image: boolean;

This item has no description.

Public ARB_debug_group: boolean;

This item has no description.

Public ARB_debug_label: boolean;

This item has no description.

Public ARB_debug_output2: boolean;

This item has no description.

Public ARB_ES3_compatibility: boolean;

This item has no description.

Public ARB_explicit_uniform_location: boolean;

This item has no description.

Public ARB_fragment_layer_viewport: boolean;

This item has no description.

Public ARB_framebuffer_no_attachments: boolean;

This item has no description.

Public ARB_internalformat_query2: boolean;

This item has no description.

Public ARB_invalidate_subdata: boolean;

This item has no description.

Public ARB_multi_draw_indirect: boolean;

This item has no description.

Public ARB_program_interface_query: boolean;

This item has no description.

Public ARB_shader_image_size: boolean;

This item has no description.

Public ARB_shader_storage_buffer_object: boolean;

This item has no description.

Public ARB_stencil_texturing: boolean;

This item has no description.

Public ARB_texture_buffer_range: boolean;

This item has no description.

Public ARB_texture_query_levels: boolean;

This item has no description.

Public ARB_texture_storage_multisample: boolean;

This item has no description.

Public ARB_texture_view: boolean;

This item has no description.

Public ARB_vertex_attrib_binding: boolean;

This item has no description.

Public ARB_robustness_isolation: boolean;

This item has no description.

Public ARB_cl_event: boolean;

This item has no description.

Public _3DFX_multisample: boolean;

This item has no description.

Public _3DFX_tbuffer: boolean;

This item has no description.

Public _3DFX_texture_compression_FXT1: boolean;

This item has no description.

Public ATI_draw_buffers: boolean;

This item has no description.

Public ATI_texture_compression_3dc: boolean;

This item has no description.

Public ATI_texture_float: boolean;

This item has no description.

Public ATI_texture_mirror_once: boolean;

This item has no description.

Public S3_s3tc: boolean;

This item has no description.

Public EXT_abgr: boolean;

This item has no description.

Public EXT_bgra: boolean;

This item has no description.

Public EXT_bindable_uniform: boolean;

This item has no description.

Public EXT_blend_color: boolean;

This item has no description.

Public EXT_blend_equation_separate: boolean;

This item has no description.

Public EXT_blend_func_separate: boolean;

This item has no description.

Public EXT_blend_logic_op: boolean;

This item has no description.

Public EXT_blend_minmax: boolean;

This item has no description.

Public EXT_blend_subtract: boolean;

This item has no description.

Public EXT_Cg_shader: boolean;

This item has no description.

Public EXT_clip_volume_hint: boolean;

This item has no description.

Public EXT_compiled_vertex_array: boolean;

This item has no description.

Public EXT_copy_texture: boolean;

This item has no description.

Public EXT_depth_bounds_test: boolean;

This item has no description.

Public EXT_draw_buffers2: boolean;

This item has no description.

Public EXT_draw_instanced: boolean;

This item has no description.

Public EXT_draw_range_elements: boolean;

This item has no description.

Public EXT_fog_coord: boolean;

This item has no description.

Public EXT_framebuffer_blit: boolean;

This item has no description.

Public EXT_framebuffer_multisample: boolean;

This item has no description.

Public EXT_framebuffer_object: boolean;

This item has no description.

Public EXT_framebuffer_sRGB: boolean;

This item has no description.

Public EXT_geometry_shader4: boolean;

This item has no description.

Public EXT_gpu_program_parameters: boolean;

This item has no description.

Public EXT_gpu_shader4: boolean;

This item has no description.

Public EXT_multi_draw_arrays: boolean;

This item has no description.

Public EXT_multisample: boolean;

This item has no description.

Public EXT_packed_depth_stencil: boolean;

This item has no description.

Public EXT_packed_float: boolean;

This item has no description.

Public EXT_packed_pixels: boolean;

This item has no description.

Public EXT_paletted_texture: boolean;

This item has no description.

Public EXT_pixel_buffer_object: boolean;

This item has no description.

Public EXT_polygon_offset: boolean;

This item has no description.

Public EXT_rescale_normal: boolean;

This item has no description.

Public EXT_secondary_color: boolean;

This item has no description.

Public EXT_separate_specular_color: boolean;

This item has no description.

Public EXT_shadow_funcs: boolean;

This item has no description.

Public EXT_shared_texture_palette: boolean;

This item has no description.

Public EXT_stencil_clear_tag: boolean;

This item has no description.

Public EXT_stencil_two_side: boolean;

This item has no description.

Public EXT_stencil_wrap: boolean;

This item has no description.

Public EXT_texture3D: boolean;

This item has no description.

Public EXT_texture_array: boolean;

This item has no description.

Public EXT_texture_buffer_object: boolean;

This item has no description.

Public EXT_texture_compression_latc: boolean;

This item has no description.

Public EXT_texture_compression_rgtc: boolean;

This item has no description.

Public EXT_texture_compression_s3tc: boolean;

This item has no description.

Public EXT_texture_cube_map: boolean;

This item has no description.

Public EXT_texture_edge_clamp: boolean;

This item has no description.

Public EXT_texture_env_add: boolean;

This item has no description.

Public EXT_texture_env_combine: boolean;

This item has no description.

Public EXT_texture_env_dot3: boolean;

This item has no description.

Public EXT_texture_filter_anisotropic: boolean;

This item has no description.

Public EXT_texture_integer: boolean;

This item has no description.

Public EXT_texture_lod: boolean;

This item has no description.

Public EXT_texture_lod_bias: boolean;

This item has no description.

Public EXT_texture_mirror_clamp: boolean;

This item has no description.

Public EXT_texture_object: boolean;

This item has no description.

Public EXT_texture_rectangle: boolean;

This item has no description.

Public EXT_texture_sRGB: boolean;

This item has no description.

Public EXT_texture_shared_exponent: boolean;

This item has no description.

Public EXT_timer_query: boolean;

This item has no description.

Public EXT_transform_feedback: boolean;

This item has no description.

Public EXT_vertex_array: boolean;

This item has no description.

Public EXT_texture_sRGB_decode: boolean;

This item has no description.

Public EXT_direct_state_access: boolean;

This item has no description.

Public EXT_texture_swizzle: boolean;

This item has no description.

Public HP_occlusion_test: boolean;

This item has no description.

Public IBM_rasterpos_clip: boolean;

This item has no description.

Public KTX_buffer_region: boolean;

This item has no description.

Public MESA_resize_buffers: boolean;

This item has no description.

Public NV_blend_square: boolean;

This item has no description.

Public NV_conditional_render: boolean;

This item has no description.

Public NV_copy_image: boolean;

This item has no description.

Public NV_depth_buffer_float: boolean;

This item has no description.

Public NV_fence: boolean;

This item has no description.

Public NV_float_buffer: boolean;

This item has no description.

Public NV_fog_distance: boolean;

This item has no description.

Public NV_geometry_program4: boolean;

This item has no description.

Public NV_light_max_exponent: boolean;

This item has no description.

Public NV_multisample_filter_hint: boolean;

This item has no description.

Public NV_occlusion_query: boolean;

This item has no description.

Public NV_point_sprite: boolean;

This item has no description.

Public NV_primitive_restart: boolean;

This item has no description.

Public NV_register_combiners: boolean;

This item has no description.

Public NV_shader_buffer_load: boolean;

This item has no description.

Public NV_texgen_reflection: boolean;

This item has no description.

Public NV_texture_compression_vtc: boolean;

This item has no description.

Public NV_texture_env_combine4: boolean;

This item has no description.

Public NV_texture_rectangle: boolean;

This item has no description.

Public NV_texture_shader: boolean;

This item has no description.

Public NV_texture_shader2: boolean;

This item has no description.

Public NV_texture_shader3: boolean;

This item has no description.

Public NV_transform_feedback: boolean;

This item has no description.

Public NV_vertex_array_range: boolean;

This item has no description.

Public NV_vertex_array_range2: boolean;

This item has no description.

Public NV_vertex_buffer_unified_memory: boolean;

This item has no description.

Public NV_vertex_program: boolean;

This item has no description.

Public SGI_color_matrix: boolean;

This item has no description.

Public SGIS_generate_mipmap: boolean;

This item has no description.

Public SGIS_multisample: boolean;

This item has no description.

Public SGIS_texture_border_clamp: boolean;

This item has no description.

Public SGIS_texture_color_mask: boolean;

This item has no description.

Public SGIS_texture_edge_clamp: boolean;

This item has no description.

Public SGIS_texture_lod: boolean;

This item has no description.

Public SGIX_depth_texture: boolean;

This item has no description.

Public SGIX_shadow: boolean;

This item has no description.

Public SGIX_shadow_ambient: boolean;

This item has no description.

Public AMD_vertex_shader_tessellator: boolean;

This item has no description.

Public WIN_swap_hint: boolean;

This item has no description.

Public ATI_meminfo: boolean;

This item has no description.

Public NVX_gpu_memory_info: boolean;

This item has no description.

Public NV_vdpau_interop: boolean;

This item has no description.

Public NV_path_rendering: boolean;

This item has no description.

Public GREMEDY_frame_terminator: boolean;

This item has no description.

Public GREMEDY_string_marker: boolean;

This item has no description.

Public AMDX_debug_output: boolean;

This item has no description.

Public ARB_debug_output: boolean;

This item has no description.

Public BindTexture: procedure(target: Cardinal; texture: Cardinal); stdcall;

OpenGL 1.1 core functions and procedures

Public BlendFunc: procedure(sfactor: Cardinal; dfactor: Cardinal); stdcall;

This item has no description.

Public Clear: procedure(mask: TGLbitfield); stdcall;

This item has no description.

Public ClearColor: procedure(red, green, blue, alpha: Single); stdcall;

This item has no description.

Public ClearDepth: procedure(depth: TGLclampd); stdcall;

This item has no description.

Public ClearStencil: procedure(s: TGLint); stdcall;

This item has no description.

Public ColorMask: procedure(red, green, blue, alpha: TGLboolean); stdcall;

This item has no description.

Public CopyTexImage1D: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; X, y: TGLint; Width: TGLsizei; border: TGLint); stdcall;

This item has no description.

Public CopyTexImage2D: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; X, y: TGLint; Width, Height: TGLsizei; border: TGLint); stdcall;

This item has no description.

Public CopyTexSubImage1D: procedure(target: Cardinal; level, xoffset, X, y: TGLint; Width: TGLsizei); stdcall;

This item has no description.

Public CopyTexSubImage2D: procedure(target: Cardinal; level, xoffset, yoffset, X, y: TGLint; Width, Height: TGLsizei); stdcall;

This item has no description.

Public CullFace: procedure(mode: Cardinal); stdcall;

This item has no description.

Public DeleteTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;

This item has no description.

Public DepthFunc: procedure(func: Cardinal); stdcall;

This item has no description.

Public DepthMask: procedure(flag: TGLboolean); stdcall;

This item has no description.

Public DepthRange: procedure(zNear, zFar: TGLclampd); stdcall;

This item has no description.

Public Disable: procedure(cap: Cardinal); stdcall;

This item has no description.

Public DrawArrays: procedure(mode: Cardinal; First: TGLint; Count: TGLsizei); stdcall;

This item has no description.

Public DrawBuffer: procedure(mode: Cardinal); stdcall;

This item has no description.

Public DrawElements: procedure(mode: Cardinal; Count: TGLsizei; atype: Cardinal; indices: Pointer); stdcall;

This item has no description.

Public Enable: procedure(cap: Cardinal); stdcall;

This item has no description.

Public Finish: procedure(); stdcall;

This item has no description.

Public Flush: procedure(); stdcall;

This item has no description.

Public FrontFace: procedure(mode: Cardinal); stdcall;

This item has no description.

Public GenTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;

This item has no description.

Public GetBooleanv: procedure(pname: Cardinal; params: PGLboolean); stdcall;

This item has no description.

Public GetDoublev: procedure(pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

Public GetError: function: Cardinal; stdcall;

This item has no description.

Public GetFloatv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetIntegerv: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetPointerv: procedure(pname: Cardinal; var params); stdcall;

This item has no description.

Public GetString: function(Name: Cardinal): PAnsiChar; stdcall;

This item has no description.

Public GetTexImage: procedure(target: Cardinal; level: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public GetTexLevelParameterfv: procedure(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetTexLevelParameteriv: procedure(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetTexParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetTexParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public Hint: procedure(target, mode: Cardinal); stdcall;

This item has no description.

Public IsEnabled: function(cap: Cardinal): TGLboolean; stdcall;

This item has no description.

Public IsTexture: function(texture: Cardinal): TGLboolean; stdcall;

This item has no description.

Public LineWidth: procedure(Width: TGLfloat); stdcall;

This item has no description.

Public LogicOp: procedure(opcode: Cardinal); stdcall;

This item has no description.

Public PixelStoref: procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public PixelStorei: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public PointSize: procedure(size: TGLfloat); stdcall;

This item has no description.

Public PolygonMode: procedure(face, mode: Cardinal); stdcall;

This item has no description.

Public PolygonOffset: procedure(factor, units: TGLfloat); stdcall;

This item has no description.

Public ReadBuffer: procedure(mode: Cardinal); stdcall;

This item has no description.

Public ReadPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public Scissor: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;

This item has no description.

Public StencilFunc: procedure(func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;

This item has no description.

Public StencilMask: procedure(mask: Cardinal); stdcall;

This item has no description.

Public StencilOp: procedure(fail, zfail, zpass: Cardinal); stdcall;

This item has no description.

Public TexImage1D: procedure(target: Cardinal; level, internalFormat: TGLint; Width: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public TexImage2D: procedure(target: Cardinal; level, internalFormat: TGLint; Width, Height: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public TexParameterf: procedure(target, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public TexParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public TexParameteri: procedure(target, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public TexParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public TexSubImage1D: procedure(target: Cardinal; level, xoffset: TGLint; Width: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public TexSubImage2D: procedure(target: Cardinal; level, xoffset, yoffset: TGLint; Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public Viewport: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;

This item has no description.

Public Accum: procedure(op: Cardinal; Value: TGLfloat); stdcall;

—————————— OpenGL 1.1 deprecated

Public AlphaFunc: procedure(func: Cardinal; ref: Single); stdcall;

This item has no description.

Public AreTexturesResident: function(n: TGLsizei; textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall;

This item has no description.

Public ArrayElement: procedure(i: TGLint); stdcall;

This item has no description.

Public Begin_: procedure(mode: Cardinal); stdcall;

This item has no description.

Public Bitmap: procedure(Width: TGLsizei; Height: TGLsizei; xorig, yorig: TGLfloat; xmove: TGLfloat; ymove: TGLfloat; Bitmap: Pointer); stdcall;

This item has no description.

Public CallList: procedure(list: Cardinal); stdcall;

This item has no description.

Public CallLists: procedure(n: TGLsizei; atype: Cardinal; lists: Pointer); stdcall;

This item has no description.

Public ClearAccum: procedure(red, green, blue, alpha: TGLfloat); stdcall;

This item has no description.

Public ClearIndex: procedure(c: TGLfloat); stdcall;

This item has no description.

Public ClipPlane: procedure(plane: Cardinal; equation: PGLdouble); stdcall;

This item has no description.

Public Color3b: procedure(red, green, blue: TGLbyte); stdcall;

This item has no description.

Public Color3bv: procedure(v: PGLbyte); stdcall;

This item has no description.

Public Color3d: procedure(red, green, blue: TGLdouble); stdcall;

This item has no description.

Public Color3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Color3f: procedure(red, green, blue: TGLfloat); stdcall;

This item has no description.

Public Color3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Color3i: procedure(red, green, blue: TGLint); stdcall;

This item has no description.

Public Color3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Color3s: procedure(red, green, blue: TGLshort); stdcall;

This item has no description.

Public Color3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public Color3ub: procedure(red, green, blue: TGLubyte); stdcall;

This item has no description.

Public Color3ubv: procedure(v: PGLubyte); stdcall;

This item has no description.

Public Color3ui: procedure(red, green, blue: Cardinal); stdcall;

This item has no description.

Public Color3uiv: procedure(v: PGLuint); stdcall;

This item has no description.

Public Color3us: procedure(red, green, blue: TGLushort); stdcall;

This item has no description.

Public Color3usv: procedure(v: PGLushort); stdcall;

This item has no description.

Public Color4b: procedure(red, green, blue, alpha: TGLbyte); stdcall;

This item has no description.

Public Color4bv: procedure(v: PGLbyte); stdcall;

This item has no description.

Public Color4d: procedure(red, green, blue, alpha: TGLdouble); stdcall;

This item has no description.

Public Color4dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Color4f: procedure(red, green, blue, alpha: TGLfloat); stdcall;

This item has no description.

Public Color4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Color4i: procedure(red, green, blue, alpha: TGLint); stdcall;

This item has no description.

Public Color4iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Color4s: procedure(red, green, blue, alpha: TGLshort); stdcall;

This item has no description.

Public Color4sv: procedure(v: TGLshort); stdcall;

This item has no description.

Public Color4ub: procedure(red, green, blue, alpha: TGLubyte); stdcall;

This item has no description.

Public Color4ubv: procedure(v: PGLubyte); stdcall;

This item has no description.

Public Color4ui: procedure(red, green, blue, alpha: Cardinal); stdcall;

This item has no description.

Public Color4uiv: procedure(v: PGLuint); stdcall;

This item has no description.

Public Color4us: procedure(red, green, blue, alpha: TGLushort); stdcall;

This item has no description.

Public Color4usv: procedure(v: PGLushort); stdcall;

This item has no description.

Public ColorMaterial: procedure(face: Cardinal; mode: Cardinal); stdcall;

This item has no description.

Public ColorPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public CopyPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; atype: Cardinal); stdcall;

This item has no description.

Public DeleteLists: procedure(list: Cardinal; range: TGLsizei); stdcall;

This item has no description.

Public DisableClientState: procedure(aarray: Cardinal); stdcall;

This item has no description.

Public DrawPixels: procedure(Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public EdgeFlag: procedure(flag: TGLboolean); stdcall;

This item has no description.

Public EdgeFlagPointer: procedure(stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public EdgeFlagv: procedure(flag: PGLboolean); stdcall;

This item has no description.

Public EnableClientState: procedure(aarray: Cardinal); stdcall;

This item has no description.

Public End_: procedure(); stdcall;

This item has no description.

Public EndList: procedure(); stdcall;

This item has no description.

Public EvalCoord1d: procedure(u: TGLdouble); stdcall;

This item has no description.

Public EvalCoord1dv: procedure(u: PGLdouble); stdcall;

This item has no description.

Public EvalCoord1f: procedure(u: TGLfloat); stdcall;

This item has no description.

Public EvalCoord1fv: procedure(u: PGLfloat); stdcall;

This item has no description.

Public EvalCoord2d: procedure(u: TGLdouble; v: TGLdouble); stdcall;

This item has no description.

Public EvalCoord2dv: procedure(u: PGLdouble); stdcall;

This item has no description.

Public EvalCoord2f: procedure(u, v: TGLfloat); stdcall;

This item has no description.

Public EvalCoord2fv: procedure(u: PGLfloat); stdcall;

This item has no description.

Public EvalMesh1: procedure(mode: Cardinal; i1, i2: TGLint); stdcall;

This item has no description.

Public EvalMesh2: procedure(mode: Cardinal; i1, i2, j1, j2: TGLint); stdcall;

This item has no description.

Public EvalPoint1: procedure(i: TGLint); stdcall;

This item has no description.

Public EvalPoint2: procedure(i, j: TGLint); stdcall;

This item has no description.

Public FeedbackBuffer: procedure(size: TGLsizei; atype: Cardinal; buffer: PGLfloat); stdcall;

This item has no description.

Public Fogf: procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public Fogfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public Fogi: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public Fogiv: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public Frustum: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;

This item has no description.

Public GenLists: function(range: TGLsizei): Cardinal; stdcall;

This item has no description.

Public GetClipPlane: procedure(plane: Cardinal; equation: PGLdouble); stdcall;

This item has no description.

Public GetLightfv: procedure(light, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetLightiv: procedure(light, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetMapdv: procedure(target, query: Cardinal; v: PGLdouble); stdcall;

This item has no description.

Public GetMapfv: procedure(target, query: Cardinal; v: PGLfloat); stdcall;

This item has no description.

Public GetMapiv: procedure(target, query: Cardinal; v: PGLint); stdcall;

This item has no description.

Public GetMaterialfv: procedure(face, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetMaterialiv: procedure(face, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetPixelMapfv: procedure(map: Cardinal; values: PGLfloat); stdcall;

This item has no description.

Public GetPixelMapuiv: procedure(map: Cardinal; values: PGLuint); stdcall;

This item has no description.

Public GetPixelMapusv: procedure(map: Cardinal; values: PGLushort); stdcall;

This item has no description.

Public GetPolygonStipple: procedure(mask: PGLubyte); stdcall;

This item has no description.

Public GetTexEnvfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetTexEnviv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetTexGendv: procedure(coord, pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

Public GetTexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetTexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public IndexMask: procedure(mask: Cardinal); stdcall;

This item has no description.

Public IndexPointer: procedure(atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public Indexd: procedure(c: TGLdouble); stdcall;

This item has no description.

Public Indexdv: procedure(c: PGLdouble); stdcall;

This item has no description.

Public Indexf: procedure(c: TGLfloat); stdcall;

This item has no description.

Public Indexfv: procedure(c: PGLfloat); stdcall;

This item has no description.

Public Indexi: procedure(c: TGLint); stdcall;

This item has no description.

Public Indexiv: procedure(c: PGLint); stdcall;

This item has no description.

Public Indexs: procedure(c: TGLshort); stdcall;

This item has no description.

Public Indexsv: procedure(c: PGLshort); stdcall;

This item has no description.

Public Indexub: procedure(c: TGLubyte); stdcall;

This item has no description.

Public Indexubv: procedure(c: PGLubyte); stdcall;

This item has no description.

Public InitNames: procedure(); stdcall;

This item has no description.

Public InterleavedArrays: procedure(format: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public IsList: function(list: Cardinal): TGLboolean; stdcall;

This item has no description.

Public LightModelf: procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public LightModelfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public LightModeli: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public LightModeliv: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public Lightf: procedure(light, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public Lightfv: procedure(light, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public Lighti: procedure(light, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public Lightiv: procedure(light, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public LineStipple: procedure(factor: TGLint; pattern: TGLushort); stdcall;

This item has no description.

Public ListBase: procedure(base: Cardinal); stdcall;

This item has no description.

Public LoadIdentity: procedure(); stdcall;

This item has no description.

Public LoadMatrixd: procedure(m: PGLdouble); stdcall;

This item has no description.

Public LoadMatrixf: procedure(m: PGLfloat); stdcall;

This item has no description.

Public LoadName: procedure(Name: Cardinal); stdcall;

This item has no description.

Public Map1d: procedure(target: Cardinal; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall;

This item has no description.

Public Map1f: procedure(target: Cardinal; u1, u2: TGLfloat; stride, order: TGLint; points: PGLfloat); stdcall;

This item has no description.

Public Map2d: procedure(target: Cardinal; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall;

This item has no description.

Public Map2f: procedure(target: Cardinal; u1, u2: TGLfloat; ustride, uorder: TGLint; v1, v2: TGLfloat; vstride, vorder: TGLint; points: PGLfloat); stdcall;

This item has no description.

Public MapGrid1d: procedure(un: TGLint; u1, u2: TGLdouble); stdcall;

This item has no description.

Public MapGrid1f: procedure(un: TGLint; u1, u2: TGLfloat); stdcall;

This item has no description.

Public MapGrid2d: procedure(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall;

This item has no description.

Public MapGrid2f: procedure(un: TGLint; u1, u2: TGLfloat; vn: TGLint; v1, v2: TGLfloat); stdcall;

This item has no description.

Public Materialf: procedure(face, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public Materialfv: procedure(face, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public Materiali: procedure(face, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public Materialiv: procedure(face, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public MatrixMode: procedure(mode: Cardinal); stdcall;

This item has no description.

Public MultMatrixd: procedure(m: PGLdouble); stdcall;

This item has no description.

Public MultMatrixf: procedure(m: PGLfloat); stdcall;

This item has no description.

Public NewList: procedure(list: Cardinal; mode: Cardinal); stdcall;

This item has no description.

Public Normal3b: procedure(nx, ny, nz: TGLbyte); stdcall;

This item has no description.

Public Normal3bv: procedure(v: PGLbyte); stdcall;

This item has no description.

Public Normal3d: procedure(nx, ny, nz: TGLdouble); stdcall;

This item has no description.

Public Normal3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Normal3f: procedure(nx, ny, nz: TGLfloat); stdcall;

This item has no description.

Public Normal3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Normal3i: procedure(nx, ny, nz: TGLint); stdcall;

This item has no description.

Public Normal3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Normal3s: procedure(nx, ny, nz: TGLshort); stdcall;

This item has no description.

Public Normal3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public NormalPointer: procedure(atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public Ortho: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;

This item has no description.

Public PassThrough: procedure(token: TGLfloat); stdcall;

This item has no description.

Public PixelMapfv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLfloat); stdcall;

This item has no description.

Public PixelMapuiv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLuint); stdcall;

This item has no description.

Public PixelMapusv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLushort); stdcall;

This item has no description.

Public PixelTransferf: procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public PixelTransferi: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public PixelZoom: procedure(xfactor, yfactor: TGLfloat); stdcall;

This item has no description.

Public PolygonStipple: procedure(mask: PGLubyte); stdcall;

This item has no description.

Public PopAttrib: procedure(); stdcall;

This item has no description.

Public PopClientAttrib: procedure(); stdcall;

This item has no description.

Public PopMatrix: procedure(); stdcall;

This item has no description.

Public PopName: procedure(); stdcall;

This item has no description.

Public PrioritizeTextures: procedure(n: TGLsizei; textures: PGLuint; priorities: PSingle); stdcall;

This item has no description.

Public PushAttrib: procedure(mask: TGLbitfield); stdcall;

This item has no description.

Public PushClientAttrib: procedure(mask: TGLbitfield); stdcall;

This item has no description.

Public PushMatrix: procedure(); stdcall;

This item has no description.

Public PushName: procedure(Name: Cardinal); stdcall;

This item has no description.

Public RasterPos2d: procedure(X, y: TGLdouble); stdcall;

This item has no description.

Public RasterPos2dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public RasterPos2f: procedure(X, y: TGLfloat); stdcall;

This item has no description.

Public RasterPos2fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public RasterPos2i: procedure(X, y: TGLint); stdcall;

This item has no description.

Public RasterPos2iv: procedure(v: PGLint); stdcall;

This item has no description.

Public RasterPos2s: procedure(X, y: PGLshort); stdcall;

This item has no description.

Public RasterPos2sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public RasterPos3d: procedure(X, y, z: TGLdouble); stdcall;

This item has no description.

Public RasterPos3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public RasterPos3f: procedure(X, y, z: TGLfloat); stdcall;

This item has no description.

Public RasterPos3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public RasterPos3i: procedure(X, y, z: TGLint); stdcall;

This item has no description.

Public RasterPos3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public RasterPos3s: procedure(X, y, z: TGLshort); stdcall;

This item has no description.

Public RasterPos3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public RasterPos4d: procedure(X, y, z, w: TGLdouble); stdcall;

This item has no description.

Public RasterPos4dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public RasterPos4f: procedure(X, y, z, w: TGLfloat); stdcall;

This item has no description.

Public RasterPos4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public RasterPos4i: procedure(X, y, z, w: TGLint); stdcall;

This item has no description.

Public RasterPos4iv: procedure(v: PGLint); stdcall;

This item has no description.

Public RasterPos4s: procedure(X, y, z, w: TGLshort); stdcall;

This item has no description.

Public RasterPos4sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public Rectd: procedure(x1, y1, x2, y2: TGLdouble); stdcall;

This item has no description.

Public Rectdv: procedure(v1, v2: PGLdouble); stdcall;

This item has no description.

Public Rectf: procedure(x1, y1, x2, y2: TGLfloat); stdcall;

This item has no description.

Public Rectfv: procedure(v1, v2: PGLfloat); stdcall;

This item has no description.

Public Recti: procedure(x1, y1, x2, y2: TGLint); stdcall;

This item has no description.

Public Rectiv: procedure(v1, v2: PGLint); stdcall;

This item has no description.

Public Rects: procedure(x1, y1, x2, y2: TGLshort); stdcall;

This item has no description.

Public Rectsv: procedure(v1, v2: PGLshort); stdcall;

This item has no description.

Public RenderMode: function(mode: Cardinal): TGLint; stdcall;

This item has no description.

Public Rotated: procedure(ane, X, y, z: TGLdouble); stdcall;

This item has no description.

Public Rotatef: procedure(ane, X, y, z: TGLfloat); stdcall;

This item has no description.

Public Scaled: procedure(X, y, z: TGLdouble); stdcall;

This item has no description.

Public Scalef: procedure(X, y, z: TGLfloat); stdcall;

This item has no description.

Public SelectBuffer: procedure(size: TGLsizei; buffer: PGLuint); stdcall;

This item has no description.

Public ShadeModel: procedure(mode: Cardinal); stdcall;

This item has no description.

Public TexCoord1d: procedure(s: TGLdouble); stdcall;

This item has no description.

Public TexCoord1dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public TexCoord1f: procedure(s: TGLfloat); stdcall;

This item has no description.

Public TexCoord1fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord1i: procedure(s: TGLint); stdcall;

This item has no description.

Public TexCoord1iv: procedure(v: PGLint); stdcall;

This item has no description.

Public TexCoord1s: procedure(s: TGLshort); stdcall;

This item has no description.

Public TexCoord1sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public TexCoord2d: procedure(s, t: TGLdouble); stdcall;

This item has no description.

Public TexCoord2dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public TexCoord2f: procedure(s, t: TGLfloat); stdcall;

This item has no description.

Public TexCoord2fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord2i: procedure(s, t: TGLint); stdcall;

This item has no description.

Public TexCoord2iv: procedure(v: PGLint); stdcall;

This item has no description.

Public TexCoord2s: procedure(s, t: TGLshort); stdcall;

This item has no description.

Public TexCoord2sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public TexCoord3d: procedure(s, t, r: TGLdouble); stdcall;

This item has no description.

Public TexCoord3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;

This item has no description.

Public TexCoord3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord3i: procedure(s, t, r: TGLint); stdcall;

This item has no description.

Public TexCoord3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public TexCoord3s: procedure(s, t, r: TGLshort); stdcall;

This item has no description.

Public TexCoord3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public TexCoord4d: procedure(s, t, r, q: TGLdouble); stdcall;

This item has no description.

Public TexCoord4dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;

This item has no description.

Public TexCoord4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord4i: procedure(s, t, r, q: TGLint); stdcall;

This item has no description.

Public TexCoord4iv: procedure(v: PGLint); stdcall;

This item has no description.

Public TexCoord4s: procedure(s, t, r, q: TGLshort); stdcall;

This item has no description.

Public TexCoord4sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public TexCoordPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public TexEnvf: procedure(target, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public TexEnvfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public TexEnvi: procedure(target, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public TexEnviv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public TexGend: procedure(coord, pname: Cardinal; param: TGLdouble); stdcall;

This item has no description.

Public TexGendv: procedure(coord, pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

Public TexGenf: procedure(coord, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public TexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public TexGeni: procedure(coord, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public TexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public Translated: procedure(X, y, z: TGLdouble); stdcall;

This item has no description.

Public Translatef: procedure(X, y, z: TGLfloat); stdcall;

This item has no description.

Public Vertex2d: procedure(X, y: TGLdouble); stdcall;

This item has no description.

Public Vertex2dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Vertex2f: procedure(X, y: TGLfloat); stdcall;

This item has no description.

Public Vertex2fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Vertex2i: procedure(X, y: TGLint); stdcall;

This item has no description.

Public Vertex2iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Vertex2s: procedure(X, y: TGLshort); stdcall;

This item has no description.

Public Vertex2sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public Vertex3d: procedure(X, y, z: TGLdouble); stdcall;

This item has no description.

Public Vertex3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Vertex3f: procedure(X, y, z: TGLfloat); stdcall;

This item has no description.

Public Vertex3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Vertex3i: procedure(X, y, z: TGLint); stdcall;

This item has no description.

Public Vertex3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Vertex3s: procedure(X, y, z: TGLshort); stdcall;

This item has no description.

Public Vertex3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public Vertex4d: procedure(X, y, z, w: TGLdouble); stdcall;

This item has no description.

Public Vertex4dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Vertex4f: procedure(X, y, z, w: TGLfloat); stdcall;

This item has no description.

Public Vertex4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Vertex4i: procedure(X, y, z, w: TGLint); stdcall;

This item has no description.

Public Vertex4iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Vertex4s: procedure(X, y, z, w: TGLshort); stdcall;

This item has no description.

Public Vertex4sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public VertexPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public BlendColor: PFNGLBLENDCOLORPROC;

***************************************************************** ——— New core function/procedure definitions in OpenGL 1.2'} *****************************************************************

Public BlendEquation: PFNGLBLENDEQUATIONPROC;

This item has no description.

Public DrawRangeElements: PFNGLDRAWRANGEELEMENTSPROC;

This item has no description.

Public TexImage3D: PFNGLTEXIMAGE3DPROC;

This item has no description.

Public TexSubImage3D: PFNGLTEXSUBIMAGE3DPROC;

This item has no description.

Public CopyTexSubImage3D: PFNGLCOPYTEXSUBIMAGE3DPROC;

This item has no description.

Public BlendFuncSeparate: PFNGLBLENDFUNCSEPARATEPROC;

——– New core function/procedure definitions in OpenGL 1.4'}

Public MultiDrawArrays: PFNGLMULTIDRAWARRAYSPROC;

This item has no description.

Public MultiDrawElements: PFNGLMULTIDRAWELEMENTSPROC;

This item has no description.

Public PointParameterf: PFNGLPOINTPARAMETERFPROC;

This item has no description.

Public PointParameterfv: PFNGLPOINTPARAMETERFVPROC;

This item has no description.

Public PointParameteri: PFNGLPOINTPARAMETERIPROC;

This item has no description.

Public PointParameteriv: PFNGLPOINTPARAMETERIVPROC;

This item has no description.

Public BlendEquationSeparate: PFNGLBLENDEQUATIONSEPARATEPROC;

————- New core function/procedure definitions in OpenGL 2.0'}

Public DrawBuffers: PFNGLDRAWBUFFERSPROC;

This item has no description.

Public StencilOpSeparate: PFNGLSTENCILOPSEPARATEPROC;

This item has no description.

Public StencilFuncSeparate: PFNGLSTENCILFUNCSEPARATEPROC;

This item has no description.

Public StencilMaskSeparate: PFNGLSTENCILMASKSEPARATEPROC;

This item has no description.

Public LockArrays: PFNGLLOCKARRAYSEXTPROC;

—————- Buffer objects

Public UnlockArrays: PFNGLUNLOCKARRAYSEXTPROC;

EXT only

Public BindBuffer: PFNGLBINDBUFFERPROC;

EXT only

Public DeleteBuffers: PFNGLDELETEBUFFERSPROC;

This item has no description.

Public GenBuffers: PFNGLGENBUFFERSPROC;

This item has no description.

Public IsBuffer: PFNGLISBUFFERPROC;

This item has no description.

Public BufferData: PFNGLBUFFERDATAPROC;

This item has no description.

Public BufferSubData: PFNGLBUFFERSUBDATAPROC;

This item has no description.

Public GetBufferSubData: PFNGLGETBUFFERSUBDATAPROC;

This item has no description.

Public MapBuffer: PFNGLMAPBUFFERPROC;

This item has no description.

Public UnmapBuffer: PFNGLUNMAPBUFFERPROC;

This item has no description.

Public GetBufferParameteriv: PFNGLGETBUFFERPARAMETERIVPROC;

This item has no description.

Public GetBufferPointerv: PFNGLGETBUFFERPOINTERVPROC;

This item has no description.

Public MapBufferRange: PFNGLMAPBUFFERRANGEPROC;

This item has no description.

Public FlushMappedBufferRange: PFNGLFLUSHMAPPEDBUFFERRANGEPROC;

This item has no description.

Public BindBufferRange: PFNGLBINDBUFFERRANGEPROC;

This item has no description.

Public BindBufferOffset: PFNGLBINDBUFFEROFFSETEXTPROC;

This item has no description.

Public BindBufferBase: PFNGLBINDBUFFERBASEPROC;

EXT + NV only

Public TransformFeedbackAttribs: PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC;

This item has no description.

Public TransformFeedbackVaryingsNV: PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC;

NV only

Public TransformFeedbackVaryings: PFNGLTRANSFORMFEEDBACKVARYINGSPROC;

NV only

Public GetTransformFeedbackVarying: PFNGLGETTRANSFORMFEEDBACKVARYINGPROC;

This item has no description.

Public BeginTransformFeedback: PFNGLBEGINTRANSFORMFEEDBACKPROC;

This item has no description.

Public EndTransformFeedback: PFNGLENDTRANSFORMFEEDBACKPROC;

This item has no description.

Public TexBuffer: PFNGLTEXBUFFERPROC;

This item has no description.

Public ClearBufferiv: PFNGLCLEARBUFFERIVPROC;

This item has no description.

Public ClearBufferuiv: PFNGLCLEARBUFFERUIVPROC;

This item has no description.

Public ClearBufferfv: PFNGLCLEARBUFFERFVPROC;

This item has no description.

Public ClearBufferfi: PFNGLCLEARBUFFERFIPROC;

This item has no description.

Public GetStringi: PFNGLGETSTRINGIPROC;

This item has no description.

Public BindVertexArray: PFNGLBINDVERTEXARRAYPROC;

This item has no description.

Public DeleteVertexArrays: PFNGLDELETEVERTEXARRAYSPROC;

This item has no description.

Public GenVertexArrays: PFNGLGENVERTEXARRAYSPROC;

This item has no description.

Public IsVertexArray: PFNGLISVERTEXARRAYPROC;

This item has no description.

Public FlushVertexArrayRangeNV: PFNGLFLUSHVERTEXARRAYRANGENVPROC;

This item has no description.

Public VertexArrayRangeNV: PFNGLVERTEXARRAYRANGENVPROC;

This item has no description.

Public GetUniformIndices: PFNGLGETUNIFORMINDICESPROC;

This item has no description.

Public GetActiveUniformsiv: PFNGLGETACTIVEUNIFORMSIVPROC;

This item has no description.

Public GetActiveUniformName: PFNGLGETACTIVEUNIFORMNAMEPROC;

This item has no description.

Public GetUniformBlockIndex: PFNGLGETUNIFORMBLOCKINDEXPROC;

This item has no description.

Public GetActiveUniformBlockiv: PFNGLGETACTIVEUNIFORMBLOCKIVPROC;

This item has no description.

Public GetActiveUniformBlockName: PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC;

This item has no description.

Public UniformBlockBinding: PFNGLUNIFORMBLOCKBINDINGPROC;

This item has no description.

Public CopyBufferSubData: PFNGLCOPYBUFFERSUBDATAPROC;

This item has no description.

Public UniformBuffer: PFNGLUNIFORMBUFFEREXTPROC;

This item has no description.

Public GetUniformBufferSize: PFNGLGETUNIFORMBUFFERSIZEEXTPROC;

This item has no description.

Public GetUniformOffset: PFNGLGETUNIFORMOFFSETEXTPROC;

EXT only

Public PrimitiveRestartIndex: PFNGLPRIMITIVERESTARTINDEXPROC;

EXT only

Public DrawElementsBaseVertex: PFNGLDRAWELEMENTSBASEVERTEXPROC;

This item has no description.

Public DrawRangeElementsBaseVertex: PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC;

This item has no description.

Public DrawElementsInstancedBaseVertex: PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC;

This item has no description.

Public MultiDrawElementsBaseVertex: PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC;

This item has no description.

Public DrawArraysInstanced: PFNGLDRAWARRAYSINSTANCEDPROC;

This item has no description.

Public DrawElementsInstanced: PFNGLDRAWELEMENTSINSTANCEDPROC;

This item has no description.

Public VertexAttrib1d: PFNGLVERTEXATTRIB1DPROC;

This item has no description.

Public VertexAttrib1dv: PFNGLVERTEXATTRIB1DVPROC;

This item has no description.

Public VertexAttrib1f: PFNGLVERTEXATTRIB1FPROC;

This item has no description.

Public VertexAttrib1fv: PFNGLVERTEXATTRIB1FVPROC;

This item has no description.

Public VertexAttrib1s: PFNGLVERTEXATTRIB1SPROC;

This item has no description.

Public VertexAttrib1sv: PFNGLVERTEXATTRIB1SVPROC;

This item has no description.

Public VertexAttrib2d: PFNGLVERTEXATTRIB2DPROC;

This item has no description.

Public VertexAttrib2dv: PFNGLVERTEXATTRIB2DVPROC;

This item has no description.

Public VertexAttrib2f: PFNGLVERTEXATTRIB2FPROC;

This item has no description.

Public VertexAttrib2fv: PFNGLVERTEXATTRIB2FVPROC;

This item has no description.

Public VertexAttrib2s: PFNGLVERTEXATTRIB2SPROC;

This item has no description.

Public VertexAttrib2sv: PFNGLVERTEXATTRIB2SVPROC;

This item has no description.

Public VertexAttrib3d: PFNGLVERTEXATTRIB3DPROC;

This item has no description.

Public VertexAttrib3dv: PFNGLVERTEXATTRIB3DVPROC;

This item has no description.

Public VertexAttrib3f: PFNGLVERTEXATTRIB3FPROC;

This item has no description.

Public VertexAttrib3fv: PFNGLVERTEXATTRIB3FVPROC;

This item has no description.

Public VertexAttrib3s: PFNGLVERTEXATTRIB3SPROC;

This item has no description.

Public VertexAttrib3sv: PFNGLVERTEXATTRIB3SVPROC;

This item has no description.

Public VertexAttrib4Nbv: PFNGLVERTEXATTRIB4NBVPROC;

This item has no description.

Public VertexAttrib4Niv: PFNGLVERTEXATTRIB4NIVPROC;

This item has no description.

Public VertexAttrib4Nsv: PFNGLVERTEXATTRIB4NSVPROC;

This item has no description.

Public VertexAttrib4Nub: PFNGLVERTEXATTRIB4NUBPROC;

This item has no description.

Public VertexAttrib4Nubv: PFNGLVERTEXATTRIB4NUBVPROC;

This item has no description.

Public VertexAttrib4Nuiv: PFNGLVERTEXATTRIB4NUIVPROC;

This item has no description.

Public VertexAttrib4Nusv: PFNGLVERTEXATTRIB4NUSVPROC;

This item has no description.

Public VertexAttrib4bv: PFNGLVERTEXATTRIB4BVPROC;

This item has no description.

Public VertexAttrib4d: PFNGLVERTEXATTRIB4DPROC;

This item has no description.

Public VertexAttrib4dv: PFNGLVERTEXATTRIB4DVPROC;

This item has no description.

Public VertexAttrib4f: PFNGLVERTEXATTRIB4FPROC;

This item has no description.

Public VertexAttrib4fv: PFNGLVERTEXATTRIB4FVPROC;

This item has no description.

Public VertexAttrib4iv: PFNGLVERTEXATTRIB4IVPROC;

This item has no description.

Public VertexAttrib4s: PFNGLVERTEXATTRIB4SPROC;

This item has no description.

Public VertexAttrib4sv: PFNGLVERTEXATTRIB4SVPROC;

This item has no description.

Public VertexAttrib4ubv: PFNGLVERTEXATTRIB4UBVPROC;

This item has no description.

Public VertexAttrib4uiv: PFNGLVERTEXATTRIB4UIVPROC;

This item has no description.

Public VertexAttrib4usv: PFNGLVERTEXATTRIB4USVPROC;

This item has no description.

Public VertexAttribPointer: PFNGLVERTEXATTRIBPOINTERPROC;

This item has no description.

Public VertexAttribI1i: PFNGLVERTEXATTRIBI1IPROC;

This item has no description.

Public VertexAttribI2i: PFNGLVERTEXATTRIBI2IPROC;

This item has no description.

Public VertexAttribI3i: PFNGLVERTEXATTRIBI3IPROC;

This item has no description.

Public VertexAttribI4i: PFNGLVERTEXATTRIBI4IPROC;

This item has no description.

Public VertexAttribI1ui: PFNGLVERTEXATTRIBI1UIPROC;

This item has no description.

Public VertexAttribI2ui: PFNGLVERTEXATTRIBI2UIPROC;

This item has no description.

Public VertexAttribI3ui: PFNGLVERTEXATTRIBI3UIPROC;

This item has no description.

Public VertexAttribI4ui: PFNGLVERTEXATTRIBI4UIPROC;

This item has no description.

Public VertexAttribI1iv: PFNGLVERTEXATTRIBI1IVPROC;

This item has no description.

Public VertexAttribI2iv: PFNGLVERTEXATTRIBI2IVPROC;

This item has no description.

Public VertexAttribI3iv: PFNGLVERTEXATTRIBI3IVPROC;

This item has no description.

Public VertexAttribI4iv: PFNGLVERTEXATTRIBI4IVPROC;

This item has no description.

Public VertexAttribI1uiv: PFNGLVERTEXATTRIBI1UIVPROC;

This item has no description.

Public VertexAttribI2uiv: PFNGLVERTEXATTRIBI2UIVPROC;

This item has no description.

Public VertexAttribI3uiv: PFNGLVERTEXATTRIBI3UIVPROC;

This item has no description.

Public VertexAttribI4uiv: PFNGLVERTEXATTRIBI4UIVPROC;

This item has no description.

Public VertexAttribI4bv: PFNGLVERTEXATTRIBI4BVPROC;

This item has no description.

Public VertexAttribI4sv: PFNGLVERTEXATTRIBI4SVPROC;

This item has no description.

Public VertexAttribI4ubv: PFNGLVERTEXATTRIBI4UBVPROC;

This item has no description.

Public VertexAttribI4usv: PFNGLVERTEXATTRIBI4USVPROC;

This item has no description.

Public VertexAttribIPointer: PFNGLVERTEXATTRIBIPOINTERPROC;

This item has no description.

Public GetVertexAttribIiv: PFNGLGETVERTEXATTRIBIIVPROC;

This item has no description.

Public GetVertexAttribIuiv: PFNGLGETVERTEXATTRIBIUIVPROC;

This item has no description.

Public Uniform1ui: PFNGLUNIFORM1UIPROC;

This item has no description.

Public Uniform2ui: PFNGLUNIFORM2UIPROC;

This item has no description.

Public Uniform3ui: PFNGLUNIFORM3UIPROC;

This item has no description.

Public Uniform4ui: PFNGLUNIFORM4UIPROC;

This item has no description.

Public Uniform1uiv: PFNGLUNIFORM1UIVPROC;

This item has no description.

Public Uniform2uiv: PFNGLUNIFORM2UIVPROC;

This item has no description.

Public Uniform3uiv: PFNGLUNIFORM3UIVPROC;

This item has no description.

Public Uniform4uiv: PFNGLUNIFORM4UIVPROC;

This item has no description.

Public GetUniformuiv: PFNGLGETUNIFORMUIVPROC;

This item has no description.

Public BindFragDataLocation: PFNGLBINDFRAGDATALOCATIONPROC;

This item has no description.

Public GetFragDataLocation: PFNGLGETFRAGDATALOCATIONPROC;

This item has no description.

Public ClampColor: PFNGLCLAMPCOLORPROC;

This item has no description.

Public ColorMaski: PFNGLCOLORMASKIPROC;

This item has no description.

Public GetBooleani_v: PFNGLGETBOOLEANI_VPROC;

This item has no description.

Public GetIntegeri_v: PFNGLGETINTEGERI_VPROC;

This item has no description.

Public Enablei: PFNGLENABLEIPROC;

This item has no description.

Public Disablei: PFNGLDISABLEIPROC;

This item has no description.

Public IsEnabledi: PFNGLISENABLEDIPROC;

This item has no description.

Public EnableVertexAttribArray: PFNGLENABLEVERTEXATTRIBARRAYPROC;

This item has no description.

Public DisableVertexAttribArray: PFNGLDISABLEVERTEXATTRIBARRAYPROC;

This item has no description.

Public VertexAttribDivisor: PFNGLVERTEXATTRIBDIVISORPROC;

This item has no description.

Public ClearColorIi: PFNGLCLEARCOLORIIEXTPROC;

This item has no description.

Public ClearColorIui: PFNGLCLEARCOLORIUIEXTPROC;

EXT only

Public TexParameterIiv: PFNGLTEXPARAMETERIIVPROC;

EXT only

Public TexParameterIuiv: PFNGLTEXPARAMETERIUIVPROC;

This item has no description.

Public GetTexParameterIiv: PFNGLGETTEXPARAMETERIIVPROC;

This item has no description.

Public GetTexParameterIuiv: PFNGLGETTEXPARAMETERIUIVPROC;

This item has no description.

Public PatchParameteri: PFNGLPATCHPARAMETERIPROC;

This item has no description.

Public PatchParameterfv: PFNGLPATCHPARAMETERFVPROC;

This item has no description.

Public BufferAddressRangeNV: PFNGLBUFFERADDRESSRANGENVPROC;

This item has no description.

Public VertexFormatNV: PFNGLVERTEXFORMATNVPROC;

This item has no description.

Public NormalFormatNV: PFNGLNORMALFORMATNVPROC;

This item has no description.

Public ColorFormatNV: PFNGLCOLORFORMATNVPROC;

This item has no description.

Public IndexFormatNV: PFNGLINDEXFORMATNVPROC;

This item has no description.

Public TexCoordFormatNV: PFNGLTEXCOORDFORMATNVPROC;

This item has no description.

Public EdgeFlagFormatNV: PFNGLEDGEFLAGFORMATNVPROC;

This item has no description.

Public SecondaryColorFormatNV: PFNGLSECONDARYCOLORFORMATNVPROC;

This item has no description.

Public FogCoordFormatNV: PFNGLFOGCOORDFORMATNVPROC;

This item has no description.

Public VertexAttribFormatNV: PFNGLVERTEXATTRIBFORMATNVPROC;

This item has no description.

Public VertexAttribIFormatNV: PFNGLVERTEXATTRIBIFORMATNVPROC;

This item has no description.

Public GetIntegerui64i_vNV: PFNGLGETINTEGERUI64I_VNVPROC;

This item has no description.

Public GetBufferParameterui64vNV: PGNGLGETBUFFERPARAMETERUI64VNV;

This item has no description.

Public MakeBufferResidentNV: PFNGLMAKEBUFFERRESIDENTNVPROC;

This item has no description.

Public MakeBufferNonResidentNV: PFNGLMAKEBUFFERNONRESIDENTNVPROC;

This item has no description.

Public IsBufferResidentNV: PFNGLISBUFFERRESIDENTNVPROC;

This item has no description.

Public MakeNamedBufferResidentNV: PFNGLMAKENAMEDBUFFERRESIDENTNVPROC;

This item has no description.

Public MakeNamedBufferNonResidentNV: PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC;

This item has no description.

Public IsNamedBufferResidentNV: PFNGLISNAMEDBUFFERRESIDENTNVPROC;

This item has no description.

Public GetNamedBufferParameterui64vNV: PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC;

This item has no description.

Public GetIntegerui64vNV: PFNGLGETINTEGERUI64VNVPROC;

This item has no description.

Public Uniformui64NV: PFNGLUNIFORMUI64NVPROC;

This item has no description.

Public Uniformui64vNV: PFNGLUNIFORMUI64VNVPROC;

This item has no description.

Public GetUniformui64vNV: PFNGLGETUNIFORMUI64VNVPROC;

This item has no description.

Public ProgramUniformui64NV: PFNGLPROGRAMUNIFORMUI64NVPROC;

This item has no description.

Public ProgramUniformui64vNV: PFNGLPROGRAMUNIFORMUI64VNVPROC;

This item has no description.

Public ClearBufferData: PFNGLClearBufferData;

This item has no description.

Public ClearBufferSubData: PFNGLClearBufferSubData;

This item has no description.

Public ClearNamedBufferData: PFNGLClearNamedBufferData;

This item has no description.

Public ClearNamedBufferSubData: PFNGLClearNamedBufferSubData;

This item has no description.

Public InvalidateTexSubImage: PFNGLInvalidateTexSubImage;

This item has no description.

Public InvalidateTexImage: PFNGLInvalidateTexImage;

This item has no description.

Public InvalidateBufferSubData: PFNGLInvalidateBufferSubData;

This item has no description.

Public InvalidateBufferData: PFNGLInvalidateBufferData;

This item has no description.

Public InvalidateFramebuffer: PFNGLInvalidateFramebuffer;

This item has no description.

Public InvalidateSubFramebuffer: PFNGLInvalidateSubFramebuffer;

This item has no description.

Public MultiDrawArraysIndirect: PFNGLMultiDrawArraysIndirect;

This item has no description.

Public MultiDrawElementsIndirect: PFNGLMultiDrawElementsIndirect;

This item has no description.

Public BindVertexBuffer: PFNGLBindVertexBuffer;

This item has no description.

Public VertexAttribFormat: PFNGLVertexAttribFormat;

This item has no description.

Public VertexAttribIFormat: PFNGLVertexAttribIFormat;

This item has no description.

Public VertexAttribLFormat: PFNGLVertexAttribLFormat;

This item has no description.

Public VertexAttribBinding: PFNGLVertexAttribBinding;

This item has no description.

Public VertexBindingDivisor: PFNGLVertexBindingDivisor;

This item has no description.

Public VertexArrayBindVertexBuffer: PFNGLVertexArrayBindVertexBuffer;

This item has no description.

Public VertexArrayVertexAttribFormat: PFNGLVertexArrayVertexAttribFormat;

This item has no description.

Public VertexArrayVertexAttribIFormat: PFNGLVertexArrayVertexAttribIFormat;

This item has no description.

Public VertexArrayVertexAttribLFormat: PFNGLVertexArrayVertexAttribLFormat;

This item has no description.

Public VertexArrayVertexAttribBinding: PFNGLVertexArrayVertexAttribBinding;

This item has no description.

Public VertexArrayVertexBindingDivisor: PFNGLVertexArrayVertexBindingDivisor;

This item has no description.

Public DeleteObject: PFNGLDELETEOBJECTARBPROC;

—————————— Shader object

Public GetHandle: PFNGLGETHANDLEARBPROC;

ARB only

Public DetachShader: PFNGLDETACHSHADERPROC;

ARB only

Public CreateShader: PFNGLCREATESHADERPROC;

This item has no description.

Public DeleteShader: PFNGLDELETESHADERPROC;

This item has no description.

Public ShaderSource: PFNGLSHADERSOURCEPROC;

This item has no description.

Public CompileShader: PFNGLCOMPILESHADERPROC;

This item has no description.

Public CreateProgram: PFNGLCREATEPROGRAMPROC;

This item has no description.

Public DeleteProgram: PFNGLDELETEPROGRAMPROC;

This item has no description.

Public AttachShader: PFNGLATTACHSHADERPROC;

This item has no description.

Public LinkProgram: PFNGLLINKPROGRAMPROC;

This item has no description.

Public UseProgram: PFNGLUSEPROGRAMPROC;

This item has no description.

Public ValidateProgram: PFNGLVALIDATEPROGRAMPROC;

This item has no description.

Public Uniform1f: PFNGLUNIFORM1FPROC;

This item has no description.

Public Uniform2f: PFNGLUNIFORM2FPROC;

This item has no description.

Public Uniform3f: PFNGLUNIFORM3FPROC;

This item has no description.

Public Uniform4f: PFNGLUNIFORM4FPROC;

This item has no description.

Public Uniform1i: PFNGLUNIFORM1IPROC;

This item has no description.

Public Uniform2i: PFNGLUNIFORM2IPROC;

This item has no description.

Public Uniform3i: PFNGLUNIFORM3IPROC;

This item has no description.

Public Uniform4i: PFNGLUNIFORM4IPROC;

This item has no description.

Public Uniform1fv: PFNGLUNIFORM1FVPROC;

This item has no description.

Public Uniform2fv: PFNGLUNIFORM2FVPROC;

This item has no description.

Public Uniform3fv: PFNGLUNIFORM3FVPROC;

This item has no description.

Public Uniform4fv: PFNGLUNIFORM4FVPROC;

This item has no description.

Public Uniform1iv: PFNGLUNIFORM1IVPROC;

This item has no description.

Public Uniform2iv: PFNGLUNIFORM2IVPROC;

This item has no description.

Public Uniform3iv: PFNGLUNIFORM3IVPROC;

This item has no description.

Public Uniform4iv: PFNGLUNIFORM4IVPROC;

This item has no description.

Public UniformMatrix2fv: PFNGLUNIFORMMATRIX2FVPROC;

This item has no description.

Public UniformMatrix3fv: PFNGLUNIFORMMATRIX3FVPROC;

This item has no description.

Public UniformMatrix4fv: PFNGLUNIFORMMATRIX4FVPROC;

This item has no description.

Public GetObjectParameterfv: PFNGLGETOBJECTPARAMETERFVARBPROC;

This item has no description.

Public GetObjectParameteriv: PFNGLGETOBJECTPARAMETERIVARBPROC;

ARB only

Public GetInfoLog: PFNGLGETINFOLOGARBPROC;

ARB only

Public GetAttachedObjects: PFNGLGETATTACHEDOBJECTSARBPROC;

ARB only

Public GetActiveAttrib: PFNGLGETACTIVEATTRIBPROC;

ARB only

Public GetActiveUniform: PFNGLGETACTIVEUNIFORMPROC;

This item has no description.

Public GetAttachedShaders: PFNGLGETATTACHEDSHADERSPROC;

This item has no description.

Public GetAttribLocation: PFNGLGETATTRIBLOCATIONPROC;

This item has no description.

Public GetProgramiv: PFNGLGETPROGRAMIVPROC;

This item has no description.

Public GetProgramInfoLog: PFNGLGETPROGRAMINFOLOGPROC;

This item has no description.

Public GetShaderiv: PFNGLGETSHADERIVPROC;

This item has no description.

Public GetShaderInfoLog: PFNGLGETSHADERINFOLOGPROC;

This item has no description.

Public GetShaderSource: PFNGLGETSHADERSOURCEPROC;

This item has no description.

Public GetUniformLocation: PFNGLGETUNIFORMLOCATIONPROC;

This item has no description.

Public GetUniformfv: PFNGLGETUNIFORMFVPROC;

This item has no description.

Public GetUniformiv: PFNGLGETUNIFORMIVPROC;

This item has no description.

Public GetVertexAttribdv: PFNGLGETVERTEXATTRIBDVPROC;

This item has no description.

Public GetVertexAttribfv: PFNGLGETVERTEXATTRIBFVPROC;

This item has no description.

Public GetVertexAttribiv: PFNGLGETVERTEXATTRIBIVPROC;

This item has no description.

Public GetVertexAttribPointerv: PFNGLGETVERTEXATTRIBPOINTERVPROC;

This item has no description.

Public IsProgram: PFNGLISPROGRAMPROC;

This item has no description.

Public IsShader: PFNGLISSHADERPROC;

This item has no description.

Public BindAttribLocation: PFNGLBINDATTRIBLOCATIONPROC;

This item has no description.

Public BindFragDataLocationIndexed: PFNGLBINDFRAGDATALOCATIONINDEXEDPROC;

This item has no description.

Public GetFragDataIndex: PFNGLGETFRAGDATAINDEXPROC;

This item has no description.

Public GetVaryingLocation: PFNGLGETVARYINGLOCATIONNVPROC;

This item has no description.

Public GetActiveVarying: PFNGLGETACTIVEVARYINGNVPROC;

NV only

Public ActiveVarying: PFNGLACTIVEVARYINGNVPROC;

NV only

Public GetProgramBinary: PFNGLGETPROGRAMBINARYPROC;

NV only

Public ProgramBinary: PFNGLPROGRAMBINARYPROC;

This item has no description.

Public UseProgramStages: PFNGLUSEPROGRAMSTAGESPROC;

This item has no description.

Public ActiveShaderProgram: PFNGLACTIVESHADERPROGRAMPROC;

This item has no description.

Public CreateShaderProgramv: PFNGLCREATESHADERPROGRAMVPROC;

This item has no description.

Public BindProgramPipeline: PFNGLBINDPROGRAMPIPELINEPROC;

This item has no description.

Public DeleteProgramPipelines: PFNGLDELETEPROGRAMPIPELINESPROC;

This item has no description.

Public GenProgramPipelines: PFNGLGENPROGRAMPIPELINESPROC;

This item has no description.

Public IsProgramPipeline: PFNGLISPROGRAMPIPELINEPROC;

This item has no description.

Public GetProgramPipelineiv: PFNGLGETPROGRAMPIPELINEIVPROC;

This item has no description.

Public ProgramUniform1i: PFNGLPROGRAMUNIFORM1IPROC;

This item has no description.

Public ProgramUniform1iv: PFNGLPROGRAMUNIFORM1IVPROC;

This item has no description.

Public ProgramUniform1f: PFNGLPROGRAMUNIFORM1FPROC;

This item has no description.

Public ProgramUniform1fv: PFNGLPROGRAMUNIFORM1FVPROC;

This item has no description.

Public ProgramUniform1d: PFNGLPROGRAMUNIFORM1DPROC;

This item has no description.

Public ProgramUniform1dv: PFNGLPROGRAMUNIFORM1DVPROC;

This item has no description.

Public ProgramUniform1ui: PFNGLPROGRAMUNIFORM1UIPROC;

This item has no description.

Public ProgramUniform1uiv: PFNGLPROGRAMUNIFORM1UIVPROC;

This item has no description.

Public ProgramUniform2i: PFNGLPROGRAMUNIFORM2IPROC;

This item has no description.

Public ProgramUniform2iv: PFNGLPROGRAMUNIFORM2IVPROC;

This item has no description.

Public ProgramUniform2f: PFNGLPROGRAMUNIFORM2FPROC;

This item has no description.

Public ProgramUniform2fv: PFNGLPROGRAMUNIFORM2FVPROC;

This item has no description.

Public ProgramUniform2d: PFNGLPROGRAMUNIFORM2DPROC;

This item has no description.

Public ProgramUniform2dv: PFNGLPROGRAMUNIFORM2DVPROC;

This item has no description.

Public ProgramUniform2ui: PFNGLPROGRAMUNIFORM2UIPROC;

This item has no description.

Public ProgramUniform2uiv: PFNGLPROGRAMUNIFORM2UIVPROC;

This item has no description.

Public ProgramUniform3i: PFNGLPROGRAMUNIFORM3IPROC;

This item has no description.

Public ProgramUniform3iv: PFNGLPROGRAMUNIFORM3IVPROC;

This item has no description.

Public ProgramUniform3f: PFNGLPROGRAMUNIFORM3FPROC;

This item has no description.

Public ProgramUniform3fv: PFNGLPROGRAMUNIFORM3FVPROC;

This item has no description.

Public ProgramUniform3d: PFNGLPROGRAMUNIFORM3DPROC;

This item has no description.

Public ProgramUniform3dv: PFNGLPROGRAMUNIFORM3DVPROC;

This item has no description.

Public ProgramUniform3ui: PFNGLPROGRAMUNIFORM3UIPROC;

This item has no description.

Public ProgramUniform3uiv: PFNGLPROGRAMUNIFORM3UIVPROC;

This item has no description.

Public ProgramUniform4i: PFNGLPROGRAMUNIFORM4IPROC;

This item has no description.

Public ProgramUniform4iv: PFNGLPROGRAMUNIFORM4IVPROC;

This item has no description.

Public ProgramUniform4f: PFNGLPROGRAMUNIFORM4FPROC;

This item has no description.

Public ProgramUniform4fv: PFNGLPROGRAMUNIFORM4FVPROC;

This item has no description.

Public ProgramUniform4d: PFNGLPROGRAMUNIFORM4DPROC;

This item has no description.

Public ProgramUniform4dv: PFNGLPROGRAMUNIFORM4DVPROC;

This item has no description.

Public ProgramUniform4ui: PFNGLPROGRAMUNIFORM4UIPROC;

This item has no description.

Public ProgramUniform4uiv: PFNGLPROGRAMUNIFORM4UIVPROC;

This item has no description.

Public ProgramUniformMatrix2fv: PFNGLPROGRAMUNIFORMMATRIX2FVPROC;

This item has no description.

Public ProgramUniformMatrix3fv: PFNGLPROGRAMUNIFORMMATRIX3FVPROC;

This item has no description.

Public ProgramUniformMatrix4fv: PFNGLPROGRAMUNIFORMMATRIX4FVPROC;

This item has no description.

Public ProgramUniformMatrix2dv: PFNGLPROGRAMUNIFORMMATRIX2DVPROC;

This item has no description.

Public ProgramUniformMatrix3dv: PFNGLPROGRAMUNIFORMMATRIX3DVPROC;

This item has no description.

Public ProgramUniformMatrix4dv: PFNGLPROGRAMUNIFORMMATRIX4DVPROC;

This item has no description.

Public ProgramUniformMatrix2x3fv: PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC;

This item has no description.

Public ProgramUniformMatrix3x2fv: PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC;

This item has no description.

Public ProgramUniformMatrix2x4fv: PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC;

This item has no description.

Public ProgramUniformMatrix4x2fv: PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC;

This item has no description.

Public ProgramUniformMatrix3x4fv: PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC;

This item has no description.

Public ProgramUniformMatrix4x3fv: PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC;

This item has no description.

Public ProgramUniformMatrix2x3dv: PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC;

This item has no description.

Public ProgramUniformMatrix3x2dv: PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC;

This item has no description.

Public ProgramUniformMatrix2x4dv: PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC;

This item has no description.

Public ProgramUniformMatrix4x2dv: PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC;

This item has no description.

Public ProgramUniformMatrix3x4dv: PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC;

This item has no description.

Public ProgramUniformMatrix4x3dv: PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC;

This item has no description.

Public ValidateProgramPipeline: PFNGLVALIDATEPROGRAMPIPELINEPROC;

This item has no description.

Public GetProgramPipelineInfoLog: PFNGLGETPROGRAMPIPELINEINFOLOGPROC;

This item has no description.

Public DispatchCompute: PFNGLDispatchCompute;

This item has no description.

Public DispatchComputeIndirect: PFNGLDispatchComputeIndirect;

This item has no description.

Public ShaderStorageBlockBinding: PFNGLShaderStorageBlockBinding;

This item has no description.

Public IsRenderbuffer: PFNGLISRENDERBUFFERPROC;

————- Framebuffer object

Public BindRenderbuffer: PFNGLBINDRENDERBUFFERPROC;

This item has no description.

Public DeleteRenderbuffers: PFNGLDELETERENDERBUFFERSPROC;

This item has no description.

Public GenRenderbuffers: PFNGLGENRENDERBUFFERSPROC;

This item has no description.

Public RenderbufferStorage: PFNGLRENDERBUFFERSTORAGEPROC;

This item has no description.

Public RenderbufferStorageMultisample: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC;

This item has no description.

Public GetRenderbufferParameteriv: PFNGLGETRENDERBUFFERPARAMETERIVPROC;

This item has no description.

Public IsFramebuffer: PFNGLISFRAMEBUFFERPROC;

This item has no description.

Public BindFramebuffer: PFNGLBINDFRAMEBUFFERPROC;

This item has no description.

Public DeleteFramebuffers: PFNGLDELETEFRAMEBUFFERSPROC;

This item has no description.

Public GenFramebuffers: PFNGLGENFRAMEBUFFERSPROC;

This item has no description.

Public CheckFramebufferStatus: PFNGLCHECKFRAMEBUFFERSTATUSPROC;

This item has no description.

Public FramebufferTexture: PFNGLFRAMEBUFFERTEXTUREPROC;

This item has no description.

Public FramebufferTexture1D: PFNGLFRAMEBUFFERTEXTURE1DPROC;

This item has no description.

Public FramebufferTexture2D: PFNGLFRAMEBUFFERTEXTURE2DPROC;

This item has no description.

Public FramebufferTexture3D: PFNGLFRAMEBUFFERTEXTURE3DPROC;

This item has no description.

Public FramebufferTextureLayer: PFNGLFRAMEBUFFERTEXTURELAYERPROC;

This item has no description.

Public FramebufferTextureFace: PFNGLFRAMEBUFFERTEXTUREFACEARBPROC;

This item has no description.

Public FramebufferRenderbuffer: PFNGLFRAMEBUFFERRENDERBUFFERPROC;

ARB only

Public GetFramebufferAttachmentParameteriv: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC;

This item has no description.

Public BlitFramebuffer: PFNGLBLITFRAMEBUFFERPROC;

This item has no description.

Public GenerateMipmap: PFNGLGENERATEMIPMAPPROC;

This item has no description.

Public FramebufferParameteri: PFNGLFramebufferParameteri;

This item has no description.

Public NamedFramebufferParameteri: PFNGLNamedFramebufferParameteri;

This item has no description.

Public GetNamedFramebufferParameteriv: PFNGLGetNamedFramebufferParameteriv;

This item has no description.

Public GenQueries: PFNGLGENQUERIESPROC;

—————————— Queries object

Public DeleteQueries: PFNGLDELETEQUERIESPROC;

This item has no description.

Public IsQuery: PFNGLISQUERYPROC;

This item has no description.

Public BeginQuery: PFNGLBEGINQUERYPROC;

This item has no description.

Public EndQuery: PFNGLENDQUERYPROC;

This item has no description.

Public GetQueryiv: PFNGLGETQUERYIVPROC;

This item has no description.

Public GetQueryObjectiv: PFNGLGETQUERYOBJECTIVPROC;

This item has no description.

Public GetQueryObjectuiv: PFNGLGETQUERYOBJECTUIVPROC;

This item has no description.

Public QueryCounter: PFNGLQUERYCOUNTERPROC;

This item has no description.

Public GetQueryObjecti64v: PFNGLGETQUERYOBJECTI64VPROC;

This item has no description.

Public GetQueryObjectui64v: PFNGLGETQUERYOBJECTUI64VPROC;

This item has no description.

Public GetInternalformati64v: PFNGLGetInternalformati64v;

This item has no description.

Public GetProgramInterfaceiv: PFNGLGetProgramInterfaceiv;

This item has no description.

Public GetProgramResourceIndex: PFNGLGetProgramResourceIndex;

This item has no description.

Public GetProgramResourceName: PFNGLGetProgramResourceName;

This item has no description.

Public GetProgramResourceiv: PFNGLGetProgramResourceiv;

This item has no description.

Public GetProgramResourceLocation: PFNGLGetProgramResourceLocation;

This item has no description.

Public GetProgramResourceLocationIndex: PFNGLGetProgramResourceLocationIndex;

This item has no description.

Public ActiveTexture: PFNGLACTIVETEXTUREPROC;

—————————— Texture & Sampler object promoted to core v1.3 from GL_ARB_multitexture (#1)

Public SampleCoverage: PFNGLSAMPLECOVERAGEPROC;

This item has no description.

Public CompressedTexImage3D: PFNGLCOMPRESSEDTEXIMAGE3DPROC;

promoted to core v1.3 from GL_ARB_texture_compression (#12)

Public CompressedTexImage2D: PFNGLCOMPRESSEDTEXIMAGE2DPROC;

This item has no description.

Public CompressedTexImage1D: PFNGLCOMPRESSEDTEXIMAGE1DPROC;

This item has no description.

Public CompressedTexSubImage3D: PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC;

This item has no description.

Public CompressedTexSubImage2D: PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC;

This item has no description.

Public CompressedTexSubImage1D: PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC;

This item has no description.

Public GetCompressedTexImage: PFNGLGETCOMPRESSEDTEXIMAGEPROC;

This item has no description.

Public ClientActiveTexture: PFNGLCLIENTACTIVETEXTUREPROC;

This item has no description.

Public MultiTexCoord1d: PFNGLMULTITEXCOORD1DPROC;

This item has no description.

Public MultiTexCoord1dV: PFNGLMULTITEXCOORD1DVPROC;

This item has no description.

Public MultiTexCoord1f: PFNGLMULTITEXCOORD1FPROC;

This item has no description.

Public MultiTexCoord1fv: PFNGLMULTITEXCOORD1FVPROC;

This item has no description.

Public MultiTexCoord1i: PFNGLMULTITEXCOORD1IPROC;

This item has no description.

Public MultiTexCoord1iv: PFNGLMULTITEXCOORD1IVPROC;

This item has no description.

Public MultiTexCoord1s: PFNGLMULTITEXCOORD1SPROC;

This item has no description.

Public MultiTexCoord1sv: PFNGLMULTITEXCOORD1SVPROC;

This item has no description.

Public MultiTexCoord2d: PFNGLMULTITEXCOORD2DPROC;

This item has no description.

Public MultiTexCoord2dv: PFNGLMULTITEXCOORD2DVPROC;

This item has no description.

Public MultiTexCoord2f: PFNGLMULTITEXCOORD2FPROC;

This item has no description.

Public MultiTexCoord2fv: PFNGLMULTITEXCOORD2FVPROC;

This item has no description.

Public MultiTexCoord2i: PFNGLMULTITEXCOORD2IPROC;

This item has no description.

Public MultiTexCoord2iv: PFNGLMULTITEXCOORD2IVPROC;

This item has no description.

Public MultiTexCoord2s: PFNGLMULTITEXCOORD2SPROC;

This item has no description.

Public MultiTexCoord2sv: PFNGLMULTITEXCOORD2SVPROC;

This item has no description.

Public MultiTexCoord3d: PFNGLMULTITEXCOORD3DPROC;

This item has no description.

Public MultiTexCoord3dv: PFNGLMULTITEXCOORD3DVPROC;

This item has no description.

Public MultiTexCoord3f: PFNGLMULTITEXCOORD3FPROC;

This item has no description.

Public MultiTexCoord3fv: PFNGLMULTITEXCOORD3FVPROC;

This item has no description.

Public MultiTexCoord3i: PFNGLMULTITEXCOORD3IPROC;

This item has no description.

Public MultiTexCoord3iv: PFNGLMULTITEXCOORD3IVPROC;

This item has no description.

Public MultiTexCoord3s: PFNGLMULTITEXCOORD3SPROC;

This item has no description.

Public MultiTexCoord3sv: PFNGLMULTITEXCOORD3SVPROC;

This item has no description.

Public MultiTexCoord4d: PFNGLMULTITEXCOORD4DPROC;

This item has no description.

Public MultiTexCoord4dv: PFNGLMULTITEXCOORD4DVPROC;

This item has no description.

Public MultiTexCoord4f: PFNGLMULTITEXCOORD4FPROC;

This item has no description.

Public MultiTexCoord4fv: PFNGLMULTITEXCOORD4FVPROC;

This item has no description.

Public MultiTexCoord4i: PFNGLMULTITEXCOORD4IPROC;

This item has no description.

Public MultiTexCoord4iv: PFNGLMULTITEXCOORD4IVPROC;

This item has no description.

Public MultiTexCoord4s: PFNGLMULTITEXCOORD4SPROC;

This item has no description.

Public MultiTexCoord4sv: PFNGLMULTITEXCOORD4SVPROC;

This item has no description.

Public GetInteger64i_v: PFNGLGETINTEGER64I_VPROC;

This item has no description.

Public GetBufferParameteri64v: PFNGLGETBUFFERPARAMETERI64VPROC;

This item has no description.

Public ProgramParameteri: PFNGLPROGRAMPARAMETERIPROC;

This item has no description.

Public ProgramString: PFNGLPROGRAMSTRINGARBPROC;

This item has no description.

Public BindProgram: PFNGLBINDPROGRAMARBPROC;

ARB only

Public DeletePrograms: PFNGLDELETEPROGRAMSARBPROC;

ARB + NV only

Public GenPrograms: PFNGLGENPROGRAMSARBPROC;

ARB + NV only

Public ProgramEnvParameter4d: PFNGLPROGRAMENVPARAMETER4DARBPROC;

ARB + NV only

Public ProgramEnvParameter4dv: PFNGLPROGRAMENVPARAMETER4DVARBPROC;

ARB only

Public ProgramEnvParameter4f: PFNGLPROGRAMENVPARAMETER4FARBPROC;

ARB only

Public ProgramEnvParameter4fv: PFNGLPROGRAMENVPARAMETER4FVARBPROC;

ARB only

Public ProgramLocalParameter4d: PFNGLPROGRAMLOCALPARAMETER4DARBPROC;

ARB only

Public ProgramLocalParameter4dv: PFNGLPROGRAMLOCALPARAMETER4DVARBPROC;

ARB only

Public ProgramLocalParameter4f: PFNGLPROGRAMLOCALPARAMETER4FARBPROC;

ARB only

Public ProgramLocalParameter4fv: PFNGLPROGRAMLOCALPARAMETER4FVARBPROC;

ARB only

Public GetProgramEnvParameterdv: PFNGLGETPROGRAMENVPARAMETERDVARBPROC;

ARB only

Public GetProgramEnvParameterfv: PFNGLGETPROGRAMENVPARAMETERFVARBPROC;

ARB only

Public GetProgramLocalParameterdv: PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC;

ARB only

Public GetProgramLocalParameterfv: PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC;

ARB only

Public TexImage2DMultisample: PFNGLTEXIMAGE2DMULTISAMPLEPROC;

ARB only

Public TexImage3DMultisample: PFNGLTEXIMAGE3DMULTISAMPLEPROC;

This item has no description.

Public GetMultisamplefv: PFNGLGETMULTISAMPLEFVPROC;

This item has no description.

Public SampleMaski: PFNGLSAMPLEMASKIPROC;

This item has no description.

Public ProvokingVertex: PFNGLPROVOKINGVERTEXPROC;

This item has no description.

Public FenceSync: PFNGLFENCESYNCPROC;

This item has no description.

Public IsSync: PFNGLISSYNCPROC;

This item has no description.

Public DeleteSync: PFNGLDELETESYNCPROC;

This item has no description.

Public ClientWaitSync: PFNGLCLIENTWAITSYNCPROC;

This item has no description.

Public WaitSync: PFNGLWAITSYNCPROC;

This item has no description.

Public GetInteger64v: PFNGLGETINTEGER64VPROC;

This item has no description.

Public GetSynciv: PFNGLGETSYNCIVPROC;

This item has no description.

Public BlendEquationi: PFNGLBLENDEQUATIONIPROC;

This item has no description.

Public BlendEquationSeparatei: PFNGLBLENDEQUATIONSEPARATEIPROC;

This item has no description.

Public BlendFunci: PFNGLBLENDFUNCIPROC;

This item has no description.

Public BlendFuncSeparatei: PFNGLBLENDFUNCSEPARATEIPROC;

This item has no description.

Public MinSampleShading: PFNGLMINSAMPLESHADINGPROC;

This item has no description.

Public GenSamplers: PFNGLGENSAMPLERSPROC;

This item has no description.

Public DeleteSamplers: PFNGLDELETESAMPLERSPROC;

This item has no description.

Public IsSampler: PFNGLISSAMPLERPROC;

This item has no description.

Public BindSampler: PFNGLBINDSAMPLERPROC;

This item has no description.

Public SamplerParameteri: PFNGLSAMPLERPARAMETERIPROC;

This item has no description.

Public SamplerParameteriv: PFNGLSAMPLERPARAMETERIVPROC;

This item has no description.

Public SamplerParameterf: PFNGLSAMPLERPARAMETERFPROC;

This item has no description.

Public SamplerParameterfv: PFNGLSAMPLERPARAMETERFVPROC;

This item has no description.

Public SamplerParameterIiv: PFNGLSAMPLERPARAMETERIIVPROC;

This item has no description.

Public SamplerParameterIuiv: PFNGLSAMPLERPARAMETERIUIVPROC;

This item has no description.

Public GetSamplerParameteriv: PFNGLGETSAMPLERPARAMETERIVPROC;

This item has no description.

Public GetSamplerParameterIiv: PFNGLGETSAMPLERPARAMETERIIVPROC;

This item has no description.

Public GetSamplerParameterfv: PFNGLGETSAMPLERPARAMETERFVPROC;

This item has no description.

Public GetSamplerParameterIfv: PFNGLGETSAMPLERPARAMETERIFVPROC;

This item has no description.

Public CopyImageSubData: PFNGLCopyImageSubData;

This item has no description.

Public TexBufferRange: PFNGLTexBufferRange;

This item has no description.

Public TextureBufferRange: PFNGLTextureBufferRange;

This item has no description.

Public TexStorage2DMultisample: PFNGLTexStorage2DMultisample;

This item has no description.

Public TexStorage3DMultisample: PFNGLTexStorage3DMultisample;

This item has no description.

Public TextureStorage2DMultisample: PFNGLTextureStorage2DMultisample;

This item has no description.

Public TextureStorage3DMultisample: PFNGLTextureStorage3DMultisample;

This item has no description.

Public BufferStorage: PFNGLBufferStorage;

This item has no description.

Public ClearTexImage: PFNGLClearTexImage;

This item has no description.

Public ClearTexSubImage: PFNGLClearTexSubImage;

This item has no description.

Public BindBuffersBase: PFNGLBindBuffersBase;

This item has no description.

Public BindBuffersRange: PFNGLBindBuffersRange;

This item has no description.

Public BindTextures: PFNGLBindTextures;

This item has no description.

Public BindSamplers: PFNGLBindSamplers;

This item has no description.

Public BindImageTextures: PFNGLBindImageTextures;

This item has no description.

Public BindVertexBuffers: PFNGLBindVertexBuffers;

This item has no description.

Public TextureView: PFNGLTextureView;

This item has no description.

Public ClientAttribDefault: PFNGLCLIENTATTRIBDEFAULTEXTPROC;

—————————— Direct access

Public PushClientAttribDefault: PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC;

This item has no description.

Public MatrixLoadf: PFNGLMATRIXLOADFEXTPROC;

This item has no description.

Public MatrixLoadd: PFNGLMATRIXLOADDEXTPROC;

This item has no description.

Public MatrixMultf: PFNGLMATRIXMULTFEXTPROC;

This item has no description.

Public MatrixMultd: PFNGLMATRIXMULTDEXTPROC;

This item has no description.

Public MatrixLoadIdentity: PFNGLMATRIXLOADIDENTITYEXTPROC;

This item has no description.

Public MatrixRotatef: PFNGLMATRIXROTATEFEXTPROC;

This item has no description.

Public MatrixRotated: PFNGLMATRIXROTATEDEXTPROC;

This item has no description.

Public MatrixScalef: PFNGLMATRIXSCALEFEXTPROC;

This item has no description.

Public MatrixScaled: PFNGLMATRIXSCALEDEXTPROC;

This item has no description.

Public MatrixTranslatef: PFNGLMATRIXTRANSLATEFEXTPROC;

This item has no description.

Public MatrixTranslated: PFNGLMATRIXTRANSLATEDEXTPROC;

This item has no description.

Public MatrixFrustum: PFNGLMATRIXFRUSTUMEXTPROC;

This item has no description.

Public MatrixOrtho: PFNGLMATRIXORTHOEXTPROC;

This item has no description.

Public MatrixPop: PFNGLMATRIXPOPEXTPROC;

This item has no description.

Public MatrixPush: PFNGLMATRIXPUSHEXTPROC;

This item has no description.

Public MatrixLoadTransposef: PFNGLMATRIXLOADTRANSPOSEFEXTPROC;

This item has no description.

Public MatrixLoadTransposed: PFNGLMATRIXLOADTRANSPOSEDEXTPROC;

This item has no description.

Public MatrixMultTransposef: PFNGLMATRIXMULTTRANSPOSEFEXTPROC;

This item has no description.

Public MatrixMultTransposed: PFNGLMATRIXMULTTRANSPOSEDEXTPROC;

This item has no description.

Public TextureParameterfv: PFNGLTEXTUREPARAMETERFVEXTPROC;

This item has no description.

Public TextureParameteri: PFNGLTEXTUREPARAMETERIEXTPROC;

This item has no description.

Public TextureParameteriv: PFNGLTEXTUREPARAMETERIVEXTPROC;

This item has no description.

Public TextureImage1D: PFNGLTEXTUREIMAGE1DEXTPROC;

This item has no description.

Public TextureImage2D: PFNGLTEXTUREIMAGE2DEXTPROC;

This item has no description.

Public TextureSubImage1D: PFNGLTEXTURESUBIMAGE1DEXTPROC;

This item has no description.

Public TextureSubImage2D: PFNGLTEXTURESUBIMAGE2DEXTPROC;

This item has no description.

Public CopyTextureImage1D: PFNGLCOPYTEXTUREIMAGE1DEXTPROC;

This item has no description.

Public CopyTextureImage2D: PFNGLCOPYTEXTUREIMAGE2DEXTPROC;

This item has no description.

Public CopyTextureSubImage1D: PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC;

This item has no description.

Public CopyTextureSubImage2D: PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC;

This item has no description.

Public GetTextureImage: PFNGLGETTEXTUREIMAGEEXTPROC;

This item has no description.

Public GetTextureParameterfv: PFNGLGETTEXTUREPARAMETERFVEXTPROC;

This item has no description.

Public GetTextureParameteriv: PFNGLGETTEXTUREPARAMETERIVEXTPROC;

This item has no description.

Public GetTextureLevelParameterfv: PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC;

This item has no description.

Public GetTextureLevelParameteriv: PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC;

This item has no description.

Public TextureImage3D: PFNGLTEXTUREIMAGE3DEXTPROC;

This item has no description.

Public TextureSubImage3D: PFNGLTEXTURESUBIMAGE3DEXTPROC;

This item has no description.

Public CopyTextureSubImage3D: PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC;

This item has no description.

Public MultiTexParameterf: PFNGLMULTITEXPARAMETERFEXTPROC;

This item has no description.

Public MultiTexParameterfv: PFNGLMULTITEXPARAMETERFVEXTPROC;

This item has no description.

Public MultiTexParameteri: PFNGLMULTITEXPARAMETERIEXTPROC;

This item has no description.

Public MultiTexParameteriv: PFNGLMULTITEXPARAMETERIVEXTPROC;

This item has no description.

Public MultiTexImage1D: PFNGLMULTITEXIMAGE1DEXTPROC;

This item has no description.

Public MultiTexImage2D: PFNGLMULTITEXIMAGE2DEXTPROC;

This item has no description.

Public MultiTexSubImage1D: PFNGLMULTITEXSUBIMAGE1DEXTPROC;

This item has no description.

Public MultiTexSubImage2D: PFNGLMULTITEXSUBIMAGE2DEXTPROC;

This item has no description.

Public CopyMultiTexImage1D: PFNGLCOPYMULTITEXIMAGE1DEXTPROC;

This item has no description.

Public CopyMultiTexImage2D: PFNGLCOPYMULTITEXIMAGE2DEXTPROC;

This item has no description.

Public CopyMultiTexSubImage1D: PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC;

This item has no description.

Public CopyMultiTexSubImage2D: PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC;

This item has no description.

Public GetMultiTexImage: PFNGLGETMULTITEXIMAGEEXTPROC;

This item has no description.

Public GetMultiTexParameterfv: PFNGLGETMULTITEXPARAMETERFVEXTPROC;

This item has no description.

Public GetMultiTexParameteriv: PFNGLGETMULTITEXPARAMETERIVEXTPROC;

This item has no description.

Public GetMultiTexLevelParameterfv: PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC;

This item has no description.

Public GetMultiTexLevelParameteriv: PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC;

This item has no description.

Public MultiTexImage3D: PFNGLMULTITEXIMAGE3DEXTPROC;

This item has no description.

Public MultiTexSubImage3D: PFNGLMULTITEXSUBIMAGE3DEXTPROC;

This item has no description.

Public CopyMultiTexSubImage3D: PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC;

This item has no description.

Public BindMultiTexture: PFNGLBINDMULTITEXTUREEXTPROC;

This item has no description.

Public EnableClientStateIndexed: PFNGLENABLECLIENTSTATEINDEXEDEXTPROC;

This item has no description.

Public DisableClientStateIndexed: PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC;

This item has no description.

Public MultiTexCoordPointer: PFNGLMULTITEXCOORDPOINTEREXTPROC;

This item has no description.

Public MultiTexEnvf: PFNGLMULTITEXENVFEXTPROC;

This item has no description.

Public MultiTexEnvfv: PFNGLMULTITEXENVFVEXTPROC;

This item has no description.

Public MultiTexEnvi: PFNGLMULTITEXENVIEXTPROC;

This item has no description.

Public MultiTexEnviv: PFNGLMULTITEXENVIVEXTPROC;

This item has no description.

Public MultiTexGend: PFNGLMULTITEXGENDEXTPROC;

This item has no description.

Public MultiTexGendv: PFNGLMULTITEXGENDVEXTPROC;

This item has no description.

Public MultiTexGenf: PFNGLMULTITEXGENFEXTPROC;

This item has no description.

Public MultiTexGenfv: PFNGLMULTITEXGENFVEXTPROC;

This item has no description.

Public MultiTexGeni: PFNGLMULTITEXGENIEXTPROC;

This item has no description.

Public MultiTexGeniv: PFNGLMULTITEXGENIVEXTPROC;

This item has no description.

Public GetMultiTexEnvfv: PFNGLGETMULTITEXENVFVEXTPROC;

This item has no description.

Public GetMultiTexEnviv: PFNGLGETMULTITEXENVIVEXTPROC;

This item has no description.

Public GetMultiTexGendv: PFNGLGETMULTITEXGENDVEXTPROC;

This item has no description.

Public GetMultiTexGenfv: PFNGLGETMULTITEXGENFVEXTPROC;

This item has no description.

Public GetMultiTexGeniv: PFNGLGETMULTITEXGENIVEXTPROC;

This item has no description.

Public GetFloatIndexedv: PFNGLGETFLOATINDEXEDVEXTPROC;

This item has no description.

Public GetDoubleIndexedv: PFNGLGETDOUBLEINDEXEDVEXTPROC;

This item has no description.

Public GetPointerIndexedv: PFNGLGETPOINTERINDEXEDVEXTPROC;

This item has no description.

Public CompressedTextureImage3D: PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC;

This item has no description.

Public CompressedTextureImage2D: PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC;

This item has no description.

Public CompressedTextureImage1D: PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC;

This item has no description.

Public CompressedTextureSubImage3D: PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC;

This item has no description.

Public CompressedTextureSubImage2D: PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC;

This item has no description.

Public CompressedTextureSubImage1D: PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC;

This item has no description.

Public GetCompressedTextureImage: PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC;

This item has no description.

Public CompressedMultiTexImage3D: PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC;

This item has no description.

Public CompressedMultiTexImage2D: PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC;

This item has no description.

Public CompressedMultiTexImage1D: PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC;

This item has no description.

Public CompressedMultiTexSubImage3D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC;

This item has no description.

Public CompressedMultiTexSubImage2D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC;

This item has no description.

Public CompressedMultiTexSubImage1D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC;

This item has no description.

Public GetCompressedMultiTexImage: PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC;

This item has no description.

Public NamedProgramString: PFNGLNAMEDPROGRAMSTRINGEXTPROC;

This item has no description.

Public NamedProgramLocalParameter4d: PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC;

This item has no description.

Public NamedProgramLocalParameter4dv: PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC;

This item has no description.

Public NamedProgramLocalParameter4f: PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC;

This item has no description.

Public NamedProgramLocalParameter4fv: PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC;

This item has no description.

Public GetNamedProgramLocalParameterdv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC;

This item has no description.

Public GetNamedProgramLocalParameterfv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC;

This item has no description.

Public GetNamedProgramiv: PFNGLGETNAMEDPROGRAMIVEXTPROC;

This item has no description.

Public GetNamedProgramString: PFNGLGETNAMEDPROGRAMSTRINGEXTPROC;

This item has no description.

Public NamedProgramLocalParameters4fv: PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC;

This item has no description.

Public NamedProgramLocalParameterI4i: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC;

This item has no description.

Public NamedProgramLocalParameterI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC;

This item has no description.

Public NamedProgramLocalParametersI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC;

This item has no description.

Public NamedProgramLocalParameterI4ui: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC;

This item has no description.

Public NamedProgramLocalParameterI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC;

This item has no description.

Public NamedProgramLocalParametersI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC;

This item has no description.

Public GetNamedProgramLocalParameterIiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC;

This item has no description.

Public GetNamedProgramLocalParameterIuiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC;

This item has no description.

Public TextureParameterIiv: PFNGLTEXTUREPARAMETERIIVEXTPROC;

This item has no description.

Public TextureParameterIuiv: PFNGLTEXTUREPARAMETERIUIVEXTPROC;

This item has no description.

Public GetTextureParameterIiv: PFNGLGETTEXTUREPARAMETERIIVEXTPROC;

This item has no description.

Public GetTextureParameterIuiv: PFNGLGETTEXTUREPARAMETERIUIVEXTPROC;

This item has no description.

Public MultiTexParameterIiv: PFNGLMULTITEXPARAMETERIIVEXTPROC;

This item has no description.

Public MultiTexParameterIuiv: PFNGLMULTITEXPARAMETERIUIVEXTPROC;

This item has no description.

Public GetMultiTexParameterIiv: PFNGLGETMULTITEXPARAMETERIIVEXTPROC;

This item has no description.

Public GetMultiTexParameterIuiv: PFNGLGETMULTITEXPARAMETERIUIVEXTPROC;

This item has no description.

Public NamedBufferData: PFNGLNAMEDBUFFERDATAEXTPROC;

This item has no description.

Public NamedBufferSubData: PFNGLNAMEDBUFFERSUBDATAEXTPROC;

This item has no description.

Public MapNamedBuffer: PFNGLMAPNAMEDBUFFEREXTPROC;

This item has no description.

Public UnmapNamedBuffer: PFNGLUNMAPNAMEDBUFFEREXTPROC;

This item has no description.

Public MapNamedBufferRange: PFNGLMAPNAMEDBUFFERRANGEEXTPROC;

This item has no description.

Public FlushMappedNamedBufferRange: PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC;

This item has no description.

Public NamedCopyBufferSubData: PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC;

This item has no description.

Public GetNamedBufferParameteriv: PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC;

This item has no description.

Public GetNamedBufferPointerv: PFNGLGETNAMEDBUFFERPOINTERVEXTPROC;

This item has no description.

Public GetNamedBufferSubData: PFNGLGETNAMEDBUFFERSUBDATAEXTPROC;

This item has no description.

Public TextureBuffer: PFNGLTEXTUREBUFFEREXTPROC;

This item has no description.

Public MultiTexBuffer: PFNGLMULTITEXBUFFEREXTPROC;

This item has no description.

Public NamedRenderbufferStorage: PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC;

This item has no description.

Public GetNamedRenderbufferParameteriv: PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC;

This item has no description.

Public CheckNamedFramebufferStatus: PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC;

This item has no description.

Public NamedFramebufferTexture1D: PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC;

This item has no description.

Public NamedFramebufferTexture2D: PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC;

This item has no description.

Public NamedFramebufferTexture3D: PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC;

This item has no description.

Public NamedFramebufferRenderbuffer: PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC;

This item has no description.

Public GetNamedFramebufferAttachmentParameteriv: PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC;

This item has no description.

Public GenerateTextureMipmap: PFNGLGENERATETEXTUREMIPMAPEXTPROC;

This item has no description.

Public GenerateMultiTexMipmap: PFNGLGENERATEMULTITEXMIPMAPEXTPROC;

This item has no description.

Public FramebufferDrawBuffer: PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC;

This item has no description.

Public FramebufferDrawBuffers: PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC;

This item has no description.

Public FramebufferReadBuffer: PFNGLFRAMEBUFFERREADBUFFEREXTPROC;

This item has no description.

Public GetFramebufferParameteriv: PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC;

This item has no description.

Public NamedRenderbufferStorageMultisample: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC;

This item has no description.

Public NamedRenderbufferStorageMultisampleCoverage: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC;

This item has no description.

Public NamedFramebufferTexture: PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC;

This item has no description.

Public NamedFramebufferTextureLayer: PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC;

This item has no description.

Public NamedFramebufferTextureFace: PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC;

This item has no description.

Public TextureRenderbuffer: PFNGLTEXTURERENDERBUFFEREXTPROC;

This item has no description.

Public MultiTexRenderbuffer: PFNGLMULTITEXRENDERBUFFEREXTPROC;

This item has no description.

Public FrameTerminatorGREMEDY: PFNGLFRAMETERMINATORGREMEDYPROC;

—————————— Debugging Special Gremedy debugger extension

Public StringMarkerGREMEDY: PFNGLSTRINGMARKERGREMEDYPROC;

This item has no description.

Public DebugMessageEnableAMDX: procedure(category: Cardinal; severity: Cardinal; Count: TGLsizei; var ids: Cardinal; Enabled: boolean);

This item has no description.

Public PushDebugGroup: PFNGLPushDebugGroup;

This item has no description.

Public PopDebugGroup: PFNGLPopDebugGroup;

This item has no description.

Public ObjectLabel: PFNGLObjectLabel;

This item has no description.

Public GetObjectLabel: PFNGLGetObjectLabel;

This item has no description.

Public ObjectPtrLabel: PFNGLObjectPtrLabel;

This item has no description.

Public GetObjectPtrLabel: PFNGLGetObjectPtrLabel;

This item has no description.

Public DebugMessageCallbackAMDX: procedure(callback: TDebugProcAMD; userParam: Pointer); stdcall;

This item has no description.

Public DebugMessageControl: procedure(type_: Cardinal; Source: Cardinal; severity: Cardinal; Count: TGLsizei; var ids: Cardinal; Enabled: boolean); stdcall;

This item has no description.

Public DebugMessageInsert: procedure(Source: Cardinal; severity: Cardinal; id: Cardinal; length: TGLsizei; const buf: PAnsiChar); stdcall;

This item has no description.

Public DebugMessageCallback: procedure(callback: TDebugProc; userParam: Pointer); stdcall;

This item has no description.

Public GetDebugMessageLog: function(Count: Cardinal; bufSize: TGLsizei; var severity: Cardinal; var severities: Cardinal; var ids: Cardinal; var lengths: TGLsizei; messageLog: PAnsiChar): Cardinal; stdcall;

This item has no description.

Public CreateSyncFromCLevent: PFNGLCreateSyncFromCLevent;

—————————— Interrop

Public VDPAUInitNV: procedure(const vdpDevice: Pointer; const getProcAddress: Pointer); stdcall;

This item has no description.

Public VDPAUFiniNV: procedure(); stdcall;

This item has no description.

Public VDPAURegisterVideoSurfaceNV: function(const vdpSurface: Pointer; target: Cardinal; numTextureNames: TGLsizei; const textureNames: PGLuint) : TGLvdpauSurfaceNV; stdcall;

This item has no description.

Public VDPAURegisterOutputSurfaceNV: function(const vdpSurface: Pointer; target: Cardinal; numTextureNames: TGLsizei; const textureNames: PGLuint) : TGLvdpauSurfaceNV; stdcall;

This item has no description.

Public VDPAUIsSurfaceNV: procedure(surface: TGLvdpauSurfaceNV); stdcall;

This item has no description.

Public VDPAUUnregisterSurfaceNV: procedure(surface: TGLvdpauSurfaceNV); stdcall;

This item has no description.

Public VDPAUGetSurfaceivNV: procedure(surface: TGLvdpauSurfaceNV; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

This item has no description.

Public VDPAUSurfaceAccessNV: procedure(surface: TGLvdpauSurfaceNV; access: Cardinal); stdcall;

This item has no description.

Public VDPAUMapSurfacesNV: procedure(numSurfaces: TGLsizei; const surfaces: PGLvdpauSurfaceNV); stdcall;

This item has no description.

Public VDPAUUnmapSurfacesNV: procedure(numSurface: TGLsizei; const surfaces: PGLvdpauSurfaceNV); stdcall;

This item has no description.

Public GenPathsNV: PFNGLGENPATHSNVPROC;

—————————— Path rendering

Public DeletePathsNV: PFNGLDELETEPATHSNVPROC;

This item has no description.

Public IsPathNV: PFNGLISPATHNVPROC;

This item has no description.

Public PathCommandsNV: PFNGLPATHCOMMANDSNVPROC;

This item has no description.

Public PathCoordsNV: PFNGLPATHCOORDSNVPROC;

This item has no description.

Public PathSubCommandsNV: PFNGLPATHSUBCOMMANDSNVPROC;

This item has no description.

Public PathSubCoordsNV: PFNGLPATHSUBCOORDSNVPROC;

This item has no description.

Public PathStringNV: PFNGLPATHSTRINGNVPROC;

This item has no description.

Public PathGlyphsNV: PFNGLPATHGLYPHSNVPROC;

This item has no description.

Public PathGlyphRangeNV: PFNGLPATHGLYPHRANGENVPROC;

This item has no description.

Public WeightPathsNV: PFNGLWEIGHTPATHSNVPROC;

This item has no description.

Public CopyPathNV: PFNGLCOPYPATHNVPROC;

This item has no description.

Public InterpolatePathsNV: PFNGLINTERPOLATEPATHSNVPROC;

This item has no description.

Public PathParameterivNV: PFNGLPATHPARAMETERIVNVPROC;

This item has no description.

Public PathParameteriNV: PFNGLPATHPARAMETERINVPROC;

This item has no description.

Public PathParameterfvNV: PFNGLPATHPARAMETERFVNVPROC;

This item has no description.

Public PathParameterfNV: PFNGLPATHPARAMETERFNVPROC;

This item has no description.

Public PathDashArrayNV: PFNGLPATHDASHARRAYNVPROC;

This item has no description.

Public PathStencilFuncNV: PFNGLPATHSTENCILFUNCNVPROC;

This item has no description.

Public StencilFillPathNV: PFNGLSTENCILFILLPATHNVPROC;

This item has no description.

Public StencilStrokePathNV: PFNGLSTENCILSTROKEPATHNVPROC;

This item has no description.

Public StencilFillPathInstancedNV: PFNGLSTENCILFILLPATHINSTANCEDNVPROC;

This item has no description.

Public StencilStrokePathInstancedNV: PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC;

This item has no description.

Public PathColorGenNV: PFNGLPATHCOLORGENNVPROC;

This item has no description.

Public PathTexGenNV: PFNGLPATHTEXGENNVPROC;

This item has no description.

Public PathFogGenNV: PFNGLPATHFOGGENNVPROC;

This item has no description.

Public CoverFillPathNV: PFNGLCOVERFILLPATHNVPROC;

This item has no description.

Public CoverStrokePathNV: PFNGLCOVERSTROKEPATHNVPROC;

This item has no description.

Public CoverFillPathInstancedNV: PFNGLCOVERFILLPATHINSTANCEDNVPROC;

This item has no description.

Public CoverStrokePathInstancedNV: PFNGLCOVERSTROKEPATHINSTANCEDNVPROC;

This item has no description.

Public GetPathParameterivNV: PFNGLGETPATHPARAMETERIVNVPROC;

This item has no description.

Public GetPathParameterfvNV: PFNGLGETPATHPARAMETERFVNVPROC;

This item has no description.

Public GetPathCommandsNV: PFNGLGETPATHCOMMANDSNVPROC;

This item has no description.

Public GetPathCoordsNV: PFNGLGETPATHCOORDSNVPROC;

This item has no description.

Public GetPathDashArrayNV: PFNGLGETPATHDASHARRAYNVPROC;

This item has no description.

Public GetPathMetricsNV: PFNGLGETPATHMETRICSNVPROC;

This item has no description.

Public GetPathMetricRangeNV: PFNGLGETPATHMETRICRANGENVPROC;

This item has no description.

Public GetPathSpacingNV: PFNGLGETPATHSPACINGNVPROC;

This item has no description.

Public GetPathColorGenivNV: PFNGLGETPATHCOLORGENIVNVPROC;

This item has no description.

Public GetPathColorGenfvNV: PFNGLGETPATHCOLORGENFVNVPROC;

This item has no description.

Public GetPathTexGenivNV: PFNGLGETPATHTEXGENIVNVPROC;

This item has no description.

Public GetPathTexGenfvNV: PFNGLGETPATHTEXGENFVNVPROC;

This item has no description.

Public IsPointInFillPathNV: PFNGLISPOINTINFILLPATHNVPROC;

This item has no description.

Public IsPointInStrokePathNV: PFNGLISPOINTINSTROKEPATHNVPROC;

This item has no description.

Public GetPathLengthNV: PFNGLGETPATHLENGTHNVPROC;

This item has no description.

Public PointAlongPathNV: PFNGLPOINTALONGPATHNVPROC;

This item has no description.

Public PathStencilDepthOffsetNV: PFNGLPATHSTENCILDEPTHOFFSETNVPROC;

This item has no description.

Public PathCoverDepthFuncNV: PFNGLPATHCOVERDEPTHFUNCNVPROC;

This item has no description.

Public W_ARB_buffer_region: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_create_context: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_create_context_profile: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_extensions_string: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_framebuffer_sRGB: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_make_current_read: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_multisample: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_pbuffer: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_pixel_format: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_pixel_format_float: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_render_texture: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ATI_pixel_format_float: boolean;

Vendor/EXT WGL extension checks

Public W_EXT_framebuffer_sRGB: boolean;

Vendor/EXT WGL extension checks

Public W_EXT_pixel_format_packed_float: boolean;

Vendor/EXT WGL extension checks

Public W_EXT_swap_control: boolean;

Vendor/EXT WGL extension checks

Public W_NV_gpu_affinity: boolean;

Vendor/EXT WGL extension checks

Public W_EXT_create_context_es2_profile: boolean;

Vendor/EXT WGL extension checks

Public W_NV_DX_interop: boolean;

Vendor/EXT WGL extension checks

Public W_NV_DX_interop2: boolean;

Vendor/EXT WGL extension checks

Public WCreateBufferRegionARB: PFNWGLCREATEBUFFERREGIONARBPROC;

WGL_buffer_region (ARB #4)

Public WDeleteBufferRegionARB: PFNWGLDELETEBUFFERREGIONARBPROC;

This item has no description.

Public WSaveBufferRegionARB: PFNWGLSAVEBUFFERREGIONARBPROC;

This item has no description.

Public WRestoreBufferRegionARB: PFNWGLRESTOREBUFFERREGIONARBPROC;

This item has no description.

Public WGetExtensionsStringARB: PFNWGLGETEXTENSIONSSTRINGARBPROC;

WGL_ARB_extensions_string (ARB #8)

Public WGetPixelFormatAttribivARB: PFNWGLGETPIXELFORMATATTRIBIVARBPROC;

WGL_ARB_pixel_format (ARB #9)

Public WGetPixelFormatAttribfvARB: PFNWGLGETPIXELFORMATATTRIBFVARBPROC;

This item has no description.

Public WChoosePixelFormatARB: PFNWGLCHOOSEPIXELFORMATARBPROC;

This item has no description.

Public WMakeContextCurrentARB: PFNWGLMAKECONTEXTCURRENTARBPROC;

WGL_make_current_read (ARB #10)

Public WGetCurrentReadDCARB: PFNWGLGETCURRENTREADDCARBPROC;

This item has no description.

Public WCreatePbufferARB: PFNWGLCREATEPBUFFERARBPROC;

WGL_ARB_pbuffer (ARB #11)

Public WGetPbufferDCARB: PFNWGLGETPBUFFERDCARBPROC;

This item has no description.

Public WReleasePbufferDCARB: PFNWGLRELEASEPBUFFERDCARBPROC;

This item has no description.

Public WDestroyPbufferARB: PFNWGLDESTROYPBUFFERARBPROC;

This item has no description.

Public WQueryPbufferARB: PFNWGLQUERYPBUFFERARBPROC;

This item has no description.

Public WBindTexImageARB: PFNWGLBINDTEXIMAGEARBPROC;

WGL_ARB_render_texture (ARB #20)

Public WReleaseTexImageARB: PFNWGLRELEASETEXIMAGEARBPROC;

This item has no description.

Public WSetPbufferAttribARB: PFNWGLSETPBUFFERATTRIBARBPROC;

This item has no description.

Public WCreateContextAttribsARB: PFNWGLCREATECONTEXTATTRIBSARBPROC;

WGL_ARB_create_context (ARB #55)

Public WEnumGpusNV: PFNWGLENUMGPUSNVPROC;

WGL_NV_gpu_affinity

Public WEnumGpuDevicesNV: PFNWGLENUMGPUDEVICESNVPROC;

This item has no description.

Public WCreateAffinityDCNV: PFNWGLCREATEAFFINITYDCNVPROC;

This item has no description.

Public WEnumGpusFromAffinityDCNV: PFNWGLENUMGPUSFROMAFFINITYDCNVPROC;

This item has no description.

Public WDeleteDCNV: PFNWGLDELETEDCNVPROC;

This item has no description.

Public WDXSetResourceShareHandleNV: PFNWGLDXSETRESOURCESHAREHANDLEPROC;

WGL_NV_DX_interop (EXT #407)

Public WDXOpenDeviceNV: PFNWGLDXOPENDEVICEPROC;

This item has no description.

Public WDXCloseDeviceNV: PFNWGLDXCLOSEDEVICEPROC;

This item has no description.

Public WDXRegisterObjectNV: PFNWGLDXREGISTEROBJECTPROC;

This item has no description.

Public WDXUnregisterObjectNV: PFNWGLDXUNREGISTEROBJECTPROC;

This item has no description.

Public WDXObjectAccessNV: PFNWGLDXOBJECTACCESSPROC;

This item has no description.

Public WDXLockObjectsNV: PFNWGLDXLOCKOBJECTSPROC;

This item has no description.

Public WDXUnlockObjectsNV: PFNWGLDXUNLOCKOBJECTSNVPROC;

This item has no description.

Public WSwapIntervalEXT: PFNWGLSWAPINTERVALEXTPROC;

########################################################### function and procedure definitions for Vendor/EXT WGL extensions ########################################################### WGL_EXT_swap_control (EXT #172)

Public WGetSwapIntervalEXT: PFNWGLGETSWAPINTERVALEXTPROC;

This item has no description.

Public WAllocateMemoryNV: PFNWGLALLOCATEMEMORYNVPROC;

GL_NV_vertex_array_range (EXT #190)

Public WFreeMemoryNV: PFNWGLFREEMEMORYNVPROC;

This item has no description.

Public UNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

—————————— EGL function/procedure —————————— locate functions/procedures for OpenGL Utility (GLU) extensions'} {$ENDIF} ########################################################### locate functions and procedures for GLU extensions ###########################################################

Public UNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;

This item has no description.

Public UDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Private function CheckExtension(const Extension: string): boolean;

This item has no description.

Private function GetAddress(const ProcName: string): Pointer;

This item has no description.

Private function GetAddressAlt(const ProcName1, ProcName2: string): Pointer;

This item has no description.

Private function GetAddressNoSuffixes(const ProcName: string): Pointer;

This item has no description.

Private function GetCapAddress: Pointer;

This item has no description.

Public procedure CheckError;

This item has no description.

Public procedure ClearError;

This item has no description.

Public procedure Close;

This item has no description.

Public procedure Initialize(ATemporary: boolean = False);

This item has no description.

Private procedure ReadWGLExtensions;

This item has no description.

Private procedure ReadWGLImplementationProperties;

This item has no description.

Properties

Public property DebugMode: boolean read FDebug write FDebug;

This item has no description.

Public property IsInitialized: boolean read FInitialized;


GLSysHelp v.2.5: GLS.PAKArchive

Unit GLS.PAKArchive

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.ArchiveManager

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TPakHeader |
Record TFileSection |
Class TPAKArchive |

Constants

SIGN = 'PACK';

Description

Constants

SIGN = 'PACK';


GLSysHelp v.2.5: GLS.PAKArchive: Record TPakHeader

Record TPakHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PAKArchive

Declaration

type TPakHeader = record

Description

This item has no description.

Overview

Fields

Public | Signature: array [0 .. 3] of AnsiChar;
Public | DirOffset: integer;
Public | DirLength: integer;

Description

Fields

Public Signature: array [0 .. 3] of AnsiChar;

This item has no description.

Public DirOffset: integer;

This item has no description.

Public DirLength: integer;


GLSysHelp v.2.5: GLS.PAKArchive: Record TFileSection

Record TFileSection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PAKArchive

Declaration

type TFileSection = record

Description

This item has no description.

Overview

Fields

Public | FileName: array [0 .. 119] of AnsiChar;
Public | FilePos: integer;
Public | FileLength: integer;

Description

Fields

Public FileName: array [0 .. 119] of AnsiChar;

This item has no description.

Public FilePos: integer;

This item has no description.

Public FileLength: integer;


GLSysHelp v.2.5: GLS.PAKArchive: Class TPAKArchive

Class TPAKArchive

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PAKArchive

Declaration

type TPAKArchive = class(TGLBaseArchive)

Description

This item has no description. Showing description inherited from TGLBaseArchive.

BaseArchive class

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLBaseArchive
  • TPAKArchive

Overview

Fields

Private | FHeader: TPakHeader;
Private | FStream: TFileStream;

Methods

Public | function ContentExists(ContentName: string): boolean; override;
Public | function GetContent(Stream: TStream; index: integer): TStream; override;
Public | function GetContent(ContentName: string): TStream; override;
Public | function GetContent(index: integer): TStream; override;
Public | function GetContentSize(index: integer): integer; override;
Public | function GetContentSize(ContentName: string): integer; override;
Private | function GetContentCount: integer;
Public | procedure AddFromFile(FileName, Path: string); override;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); override;
Public | procedure Clear; override;
Public | procedure Extract(ContentName, NewName: string); override;
Public | procedure Extract(index: integer; NewName: string); override;
Public | procedure LoadFromFile(const FileName: string); override;
Public | procedure RemoveContent(ContentName: string); override;
Public | procedure RemoveContent(index: integer); override;
Private | procedure MakeContentList;

Properties

Public property ContentCount: integer Read GetContentCount;

Description

Fields

Private FHeader: TPakHeader;

This item has no description.

Private FStream: TFileStream;

This item has no description.

Methods

Public function ContentExists(ContentName: string): boolean; override;

This item has no description.

Public function GetContent(Stream: TStream; index: integer): TStream; override;

This item has no description.

Public function GetContent(ContentName: string): TStream; override;

This item has no description.

Public function GetContent(index: integer): TStream; override;

This item has no description.

Public function GetContentSize(index: integer): integer; override;

This item has no description.

Public function GetContentSize(ContentName: string): integer; override;

This item has no description.

Private function GetContentCount: integer;

This item has no description.

Public procedure AddFromFile(FileName, Path: string); override;

This item has no description.

Public procedure AddFromStream(ContentName, Path: string; FS: TStream); override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure Extract(ContentName, NewName: string); override;

This item has no description.

Public procedure Extract(index: integer; NewName: string); override;

This item has no description.

Public procedure LoadFromFile(const FileName: string); override;

This item has no description.

Public procedure RemoveContent(ContentName: string); override;

This item has no description.

Public procedure RemoveContent(index: integer); override;

This item has no description.

Private procedure MakeContentList;

This item has no description.

Properties

Public property ContentCount: integer Read GetContentCount;


GLSysHelp v.2.5: GLS.ParametricSurfaces

Unit GLS.ParametricSurfaces

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • GLS.OpenGLAdapter
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLS.CurvesAndSurfaces
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.PersistentClasses
  • GLS.VectorFileObjects
  • GLS.Texture
  • GLS.State
  • GLS.Context
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMOParametricSurface |
Class TFGBezierSurface |

Types

TParametricSurfaceBasis = (...);
TParametricSurfaceRenderer = (...);

Description

Types

TParametricSurfaceBasis = (...);

psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.

Values
  • psbBezier
  • psbBSpline
TParametricSurfaceRenderer = (...);

psrGLScene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenGL uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.

Values
  • psrGLScene
  • psrOpenGL


GLSysHelp v.2.5: GLS.ParametricSurfaces: Class TMOParametricSurface

Class TMOParametricSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParametricSurfaces

Declaration

type TMOParametricSurface = class(TGLMeshObject)

Description

This item has no description. Showing description inherited from TGLMeshObject.

Base mesh class. Introduces base methods and properties for mesh objects. Subclasses are named "TGLMOxxx".

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TMOParametricSurface

Overview

Fields

Private | FControlPoints: TGLAffineVectorList;
Private | FWeightedControlPoints: TGLAffineVectorList;
Private | FKnotsU: TGLSingleList;
Private | FKnotsV: TGLSingleList;
Private | FWeights: TGLSingleList;
Private | FOrderU: Integer;
Private | FOrderV: Integer;
Private | FCountU: Integer;
Private | FCountV: Integer;
Private | FResolution: Integer;
Private | FAutoKnots: Boolean;
Private | FContinuity: TBSplineContinuity;
Private | FRenderer: TParametricSurfaceRenderer;
Private | FBasis: TParametricSurfaceBasis;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure Clear; override;
Public | procedure GenerateMesh;
Public | procedure Prepare; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;
Private | procedure SetBasis(Value: TParametricSurfaceBasis);
Private | procedure SetControlPoints(Value: TGLAffineVectorList);
Private | procedure SetKnotsU(Value: TGLSingleList);
Private | procedure SetKnotsV(Value: TGLSingleList);
Private | procedure SetRenderer(Value: TParametricSurfaceRenderer);
Private | procedure SetWeights(Value: TGLSingleList);

Properties

Public | property AutoKnots: Boolean read FAutoKnots write FAutoKnots;
Public | property Basis: TParametricSurfaceBasis read FBasis write SetBasis;
Public | property Continuity: TBSplineContinuity read FContinuity write FContinuity;
Public | property ControlPoints: TGLAffineVectorList read FControlPoints write SetControlPoints;
Public | property CountU: Integer read FCountU write FCountU;
Public | property CountV: Integer read FCountV write FCountV;
Public | property KnotsU: TGLSingleList read FKnotsU write SetKnotsU;
Public | property KnotsV: TGLSingleList read FKnotsV write SetKnotsV;
Public | property OrderU: Integer read FOrderU write FOrderU;
Public | property OrderV: Integer read FOrderV write FOrderV;
Public | property Renderer: TParametricSurfaceRenderer read FRenderer write SetRenderer;
Public | property Resolution: Integer read FResolution write FResolution;
Public | property Weights: TGLSingleList read FWeights write SetWeights;

Description

Fields

Private FControlPoints: TGLAffineVectorList;

This item has no description.

Private FWeightedControlPoints: TGLAffineVectorList;

This item has no description.

Private FKnotsU: TGLSingleList;

This item has no description.

Private FKnotsV: TGLSingleList;

This item has no description.

Private FWeights: TGLSingleList;

This item has no description.

Private FOrderU: Integer;

This item has no description.

Private FOrderV: Integer;

This item has no description.

Private FCountU: Integer;

This item has no description.

Private FCountV: Integer;

This item has no description.

Private FResolution: Integer;

This item has no description.

Private FAutoKnots: Boolean;

This item has no description.

Private FContinuity: TBSplineContinuity;

This item has no description.

Private FRenderer: TParametricSurfaceRenderer;

This item has no description.

Private FBasis: TParametricSurfaceBasis;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLMeshObject.BuildList.

Similar to regular scene object's BuildList method

Public procedure Clear; override;

This item has no description. Showing description inherited from TGLBaseMeshObject.Clear.

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure GenerateMesh;

Generates a mesh approximation of the surface defined by the properties below. This is used to construct the mesh when using Renderer = psrGLScene. If you want to render using OpenGL calls but would like to obtain the mesh data also use this call to generate the mesh data. Fills in Vertices, Normals, etc.

Public procedure Prepare; override;

This item has no description. Showing description inherited from TGLMeshObject.Prepare.

Precalculate whatever is needed for rendering, called once

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Private procedure SetBasis(Value: TParametricSurfaceBasis);

This item has no description.

Private procedure SetControlPoints(Value: TGLAffineVectorList);

This item has no description.

Private procedure SetKnotsU(Value: TGLSingleList);

This item has no description.

Private procedure SetKnotsV(Value: TGLSingleList);

This item has no description.

Private procedure SetRenderer(Value: TParametricSurfaceRenderer);

This item has no description.

Private procedure SetWeights(Value: TGLSingleList);

This item has no description.

Properties

Public property AutoKnots: Boolean read FAutoKnots write FAutoKnots;

Automatically generate the knot vectors based on the Continuity. Only applies to BSpline surfaces.

Public property Basis: TParametricSurfaceBasis read FBasis write SetBasis;

Basis determines the style of curve, psbBezier or psbBSpline

Public property Continuity: TBSplineContinuity read FContinuity write FContinuity;

This item has no description.

Public property ControlPoints: TGLAffineVectorList read FControlPoints write SetControlPoints;

Control points define the parametric surface.

Public property CountU: Integer read FCountU write FCountU;

CountU and CountV describe the number of control points in the U and V direciton. Basically a control point width and height in (u,v) space.

Public property CountV: Integer read FCountV write FCountV;

This item has no description.

Public property KnotsU: TGLSingleList read FKnotsU write SetKnotsU;

KnotsU and KnotsV are the knot vectors in the U and V direction. Knots define the continuity of curves and how control points influence the parametric values to build the surface.

Public property KnotsV: TGLSingleList read FKnotsV write SetKnotsV;

This item has no description.

Public property OrderU: Integer read FOrderU write FOrderU;

OrderU and OrderV defines the curve order in the U and V direction

Public property OrderV: Integer read FOrderV write FOrderV;

This item has no description.

Public property Renderer: TParametricSurfaceRenderer read FRenderer write SetRenderer;

Determines whether to use OpenGL calls (psrOpenGL) or the GLScene mesh objects (psrGLScene) to render the surface.

Public property Resolution: Integer read FResolution write FResolution;

Defines how fine the resultant mesh will be. Higher values create finer meshes. Resolution = 50 would produce a 50x50 mesh. The GLU Nurbs rendering uses resolution as the U_STEP and V_STEP using the sampling method GLU_DOMAIN_DISTANCE, so the resolution works a little differently there.

Public property Weights: TGLSingleList read FWeights write SetWeights;

Weights define how much a control point effects the surface.


GLSysHelp v.2.5: GLS.ParametricSurfaces: Class TFGBezierSurface

Class TFGBezierSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParametricSurfaces

Declaration

type TFGBezierSurface = class(TGLFaceGroup)

Description

A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.

Hierarchy

  • TGLPersistentObject
  • TGLFaceGroup
  • TFGBezierSurface

Overview

Fields

Private | FCountU: Integer;
Private | FCountV: Integer;
Private | FControlPointIndices: TGLIntegerList;
Private | FTexCoordIndices: TGLIntegerList;
Private | FResolution: Integer;
Private | FMinU: Single;
Private | FMaxU: Single;
Private | FMinV: Single;
Private | FMaxV: Single;
Private | FTempControlPoints: TGLAffineVectorList;
Private | FTempTexCoords: TGLAffineVectorList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure Prepare; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property ControlPointIndices: TGLIntegerList read FControlPointIndices write SetControlPointIndices;
Public | property CountU: Integer read FCountU write FCountU;
Public | property CountV: Integer read FCountV write FCountV;
Public | property MaxU: Single read FMaxU write FMaxU;
Public | property MaxV: Single read FMaxV write FMaxV;
Public | property MinU: Single read FMinU write FMinU;
Public | property MinV: Single read FMinV write FMinV;
Public | property Resolution: Integer read FResolution write FResolution;
Public | property TexCoordIndices: TGLIntegerList read FTexCoordIndices write SetTexCoordIndices;

Description

Fields

Private FCountU: Integer;

This item has no description.

Private FCountV: Integer;

This item has no description.

Private FControlPointIndices: TGLIntegerList;

This item has no description.

Private FTexCoordIndices: TGLIntegerList;

This item has no description.

Private FResolution: Integer;

This item has no description.

Private FMinU: Single;

This item has no description.

Private FMaxU: Single;

This item has no description.

Private FMinV: Single;

This item has no description.

Private FMaxV: Single;

This item has no description.

Private FTempControlPoints: TGLAffineVectorList;

This item has no description.

Private FTempTexCoords: TGLAffineVectorList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description.

Public procedure Prepare; override;

This item has no description. Showing description inherited from TGLFaceGroup.Prepare.

Precalculate whatever is needed for rendering, called once

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property ControlPointIndices: TGLIntegerList read FControlPointIndices write SetControlPointIndices;

This item has no description.

Public property CountU: Integer read FCountU write FCountU;

This item has no description.

Public property CountV: Integer read FCountV write FCountV;

This item has no description.

Public property MaxU: Single read FMaxU write FMaxU;

This item has no description.

Public property MaxV: Single read FMaxV write FMaxV;

This item has no description.

Public property MinU: Single read FMinU write FMinU;

This item has no description.

Public property MinV: Single read FMinV write FMinV;

This item has no description.

Public property Resolution: Integer read FResolution write FResolution;

This item has no description.

Public property TexCoordIndices: TGLIntegerList read FTexCoordIndices write SetTexCoordIndices;


GLSysHelp v.2.5: GLS.ParticleFX

Unit GLS.ParticleFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLScene.Utils
  • GLScene.PipelineTransform
  • GLS.State
  • GLScene.VectorTypes
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.XCollection
  • GLS.Material
  • GLS.Cadencer
  • GLS.VectorLists
  • GLS.Graphics
  • GLS.Context
  • GLS.Color
  • GLS.BaseClasses
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLScene.Manager
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLParticle |
Class TGLParticleList |
Class TGLParticleFXManager |
Class TGLParticleFXEffect |
Packed Record TParticleReference |
Record TPFXRegion |
Class TGLParticleFXRenderer |
Class TGLSourcePFXEffect |
Class TGLDynamicPFXManager |
Class TPFXLifeColor |
Class TPFXLifeColors |
Class TGLLifeColoredPFXManager |
Class TGLCustomPFXManager |
Class TGLPolygonPFXManager |
Class TGLBaseSpritePFXManager |
Class TGLCustomSpritePFXManager |
Class TGLPointLightPFXManager |

Functions and Procedures

function GetOrCreateSourcePFX(obj: TGLBaseSceneObject; const name: string = ''): TGLSourcePFXEffect;

Types

PFXPointerList = ˆTFXPointerList;
PGLParticleArray = ˆTGLParticleArray;
PParticleReference = ˆTParticleReference;
PParticleReferenceArray = ˆTParticleReferenceArray;
PPFXRegion = ˆTPFXRegion;
TFXPointerList = array[0..MaxInt shr 8-1] of Pointer;
TGLParticleArray = array[0..MaxInt shr 4] of TGLParticle;
TGLParticleClass = class of TGLParticle;
TGLSourcePFXDispersionMode = (...);
TGLSourcePFXPositionMode = (...);
TGLSourcePFXVelocityMode = (...);
TParticleReferenceArray = packed array[0..MaxInt shr 8-1] of TParticleReference;
TPFXCreateParticleEvent = procedure(Sender: TObject; aParticle: TGLParticle) of object;
TPFXDirectRenderEvent = procedure(Sender: TObject; aParticle: TGLParticle; var rci: TGLRenderContextInfo) of object;
TPFXGetParticleCountEvent = function(Sender: TObject): Integer of object;
TPFXParticleProgress = procedure(Sender: TObject; const progressTime: TGLProgressTimes; aParticle: TGLParticle; var killParticle: Boolean) of object;
TPFXPrepareTextureImageEvent = procedure(Sender: TObject; destBmp32: TGLBitmap32; var texFormat: Integer) of object;
TPFXProgressEvent = procedure(Sender: TObject; const progressTime: TGLProgressTimes; var defaultProgress: Boolean) of object;
TPFXSortAccuracy = (...);
TSpriteColorMode = (...);
TSpritesPerTexture = (...);

Constants

cPFXNbRegions = 128;
cPFXGranularity = 128;

Description

Functions and Procedures

function GetOrCreateSourcePFX(obj: TGLBaseSceneObject; const name: string = ''): TGLSourcePFXEffect;

Returns or creates the TGLBInertia within the given object's behaviours.

Types

PFXPointerList = ˆTFXPointerList;

This item has no description.

PGLParticleArray = ˆTGLParticleArray;

This item has no description.

PParticleReference = ˆTParticleReference;

This item has no description.

PParticleReferenceArray = ˆTParticleReferenceArray;

This item has no description.

PPFXRegion = ˆTPFXRegion;

This item has no description.

TFXPointerList = array[0..MaxInt shr 8-1] of Pointer;

This item has no description.

TGLParticleArray = array[0..MaxInt shr 4] of TGLParticle;

This item has no description.

TGLParticleClass = class of TGLParticle;

This item has no description.

TGLSourcePFXDispersionMode = (...);

This item has no description.

Values
  • sdmFast
  • sdmIsotropic
  • sdmGaussian
TGLSourcePFXPositionMode = (...);

This item has no description.

Values
  • spmAbsoluteOffset
  • spmRelative
TGLSourcePFXVelocityMode = (...);

This item has no description.

Values
  • svmAbsolute
  • svmRelative
TParticleReferenceArray = packed array[0..MaxInt shr 8-1] of TParticleReference;

This item has no description.

TPFXCreateParticleEvent = procedure(Sender: TObject; aParticle: TGLParticle) of object;

This item has no description.

TPFXDirectRenderEvent = procedure(Sender: TObject; aParticle: TGLParticle; var rci: TGLRenderContextInfo) of object;

This item has no description.

TPFXGetParticleCountEvent = function(Sender: TObject): Integer of object;

This item has no description.

TPFXParticleProgress = procedure(Sender: TObject; const progressTime: TGLProgressTimes; aParticle: TGLParticle; var killParticle: Boolean) of object;

This item has no description.

TPFXPrepareTextureImageEvent = procedure(Sender: TObject; destBmp32: TGLBitmap32; var texFormat: Integer) of object;

This item has no description.

TPFXProgressEvent = procedure(Sender: TObject; const progressTime: TGLProgressTimes; var defaultProgress: Boolean) of object;

This item has no description.

TPFXSortAccuracy = (...);

This item has no description.

Values
  • saLow
  • saOneTenth
  • saOneThird
  • saOneHalf
  • saHigh
TSpriteColorMode = (...);

Sprite color modes. scmFade: vertex coloring is used to fade inner-outer scmInner: vertex coloring uses inner color only scmOuter: vertex coloring uses outer color only scmNone: vertex coloring is NOT used (colors are ignored)

Values
  • scmFade
  • scmInner
  • scmOuter
  • scmNone
TSpritesPerTexture = (...);

Sprites per sprite texture for the SpritePFX.

Values
  • sptOne
  • sptFour

Constants

cPFXNbRegions = 128;

This item has no description.

cPFXGranularity = 128;

number of distance regions


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLParticle

Class TGLParticle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLParticle = class(TGLPersistentObject)

Description

Base class for particles. The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).

Hierarchy

  • TGLPersistentObject
  • TGLParticle

Overview

Fields

Private | FID: Integer;
Private | FTag: Integer;
Private | FManager: TGLParticleFXManager;
Private | FPosition: TAffineVector;
Private | FVelocity: TAffineVector;
Private | FRotation: Single;
Private | FCreationTime: Double;
Private | FEffectScale: Single;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Private | function GetPosition(const Index: Integer): Single;
Private | function GetVelocity(const Index: Integer): Single;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;
Private | procedure WritePosition(const Index: Integer; const aValue: Single);
Private | procedure WriteVelocity(const Index: Integer; const aValue: Single);

Properties

Public | property CreationTime: Double read FCreationTime write FCreationTime;
Public | property ID: Integer read FID;
Public | property Manager: TGLParticleFXManager read FManager write FManager;
Public | property Position: TAffineVector read FPosition write FPosition;
Public | property PosX : Single index 0 read GetPosition write WritePosition;
Public | property PosY : Single index 1 read GetPosition write WritePosition;
Public | property PosZ : Single index 2 read GetPosition write WritePosition;
Public | property Tag: Integer read FTag write FTag;
Public | property Velocity: TAffineVector read FVelocity write FVelocity;
Public | property VelX : Single index 0 read GetVelocity write WriteVelocity;
Public | property VelY : Single index 1 read GetVelocity write WriteVelocity;
Public | property VelZ : Single index 2 read GetVelocity write WriteVelocity;

Description

Fields

Private FID: Integer;

This item has no description.

Private FTag: Integer;

This item has no description.

Private FManager: TGLParticleFXManager;

This item has no description.

Private FPosition: TAffineVector;

NOT persistent

Private FVelocity: TAffineVector;

This item has no description.

Private FRotation: Single;

This item has no description.

Private FCreationTime: Double;

This item has no description.

Private FEffectScale: Single;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetPosition(const Index: Integer): Single;

This item has no description.

Private function GetVelocity(const Index: Integer): Single;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Private procedure WritePosition(const Index: Integer; const aValue: Single);

This item has no description.

Private procedure WriteVelocity(const Index: Integer; const aValue: Single);

This item has no description.

Properties

Public property CreationTime: Double read FCreationTime write FCreationTime;

Time at which particle was created

Public property ID: Integer read FID;

Particle's ID, given at birth. ID is a value unique per manager.

Public property Manager: TGLParticleFXManager read FManager write FManager;

This item has no description.

Public property Position: TAffineVector read FPosition write FPosition;

Particle's absolute position. Note that this property is read-accessed directly at rendering time in the innards of the depth-sorting code.

Public property PosX : Single index 0 read GetPosition write WritePosition;

This item has no description.

Public property PosY : Single index 1 read GetPosition write WritePosition;

This item has no description.

Public property PosZ : Single index 2 read GetPosition write WritePosition;

This item has no description.

Public property Tag: Integer read FTag write FTag;

This item has no description.

Public property Velocity: TAffineVector read FVelocity write FVelocity;

Particle's velocity. This velocity is indicative and is NOT automatically applied to the position during progression events by this class (subclasses may implement that).

Public property VelX : Single index 0 read GetVelocity write WriteVelocity;

This item has no description.

Public property VelY : Single index 1 read GetVelocity write WriteVelocity;

This item has no description.

Public property VelZ : Single index 2 read GetVelocity write WriteVelocity;


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLParticleList

Class TGLParticleList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLParticleList = class(TGLPersistentObject)

Description

List of particles. This list is managed with particles and performance in mind, make sure to check methods doc.

Hierarchy

  • TGLPersistentObject
  • TGLParticleList

Overview

Fields

Private | FOwner: TGLParticleFXManager;
Private | FItemList: TGLPersistentObjectList;
Private | FDirectList: PGLParticleArray;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function AddItem(aItem: TGLParticle): Integer;
Public | function IndexOfItem(aItem: TGLParticle): Integer;
Public | function ItemCount: Integer;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure RemoveAndFreeItem(aItem: TGLParticle);
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Items[index: Integer]: TGLParticle read GetItems write SetItems;
Public | property List: PGLParticleArray read FDirectList;
Public | property Owner: TGLParticleFXManager read FOwner write FOwner;

Description

Fields

Private FOwner: TGLParticleFXManager;

This item has no description.

Private FItemList: TGLPersistentObjectList;

NOT persistent

Private FDirectList: PGLParticleArray;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddItem(aItem: TGLParticle): Integer;

Adds a particle to the list. Particle owneship is defined blindly, if the particle was previously in another list, it won't be automatically removed from that list.

Public function IndexOfItem(aItem: TGLParticle): Integer;

This item has no description.

Public function ItemCount: Integer;

This item has no description.

Public procedure Pack;

Packs the list by removing all "nil" items. Note: this functions is orders of magnitude faster than the TList version.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure RemoveAndFreeItem(aItem: TGLParticle);

Removes and frees a particular item for the list. If the item is not part of the list, nothing is done. If found in the list, the item's "slot" is set to nil and item is freed (after setting its ownership to nil). The nils can be removed with a call to Pack.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Items[index: Integer]: TGLParticle read GetItems write SetItems;

This item has no description.

Public property List: PGLParticleArray read FDirectList;

This item has no description.

Public property Owner: TGLParticleFXManager read FOwner write FOwner;

Refers owner manager


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLParticleFXManager

Class TGLParticleFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLParticleFXManager = class(TGLCadencedComponent)

Description

Base class for particle FX managers. Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer. Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager

Overview

Fields

Private | FBlendingMode: TGLBlendingMode;
Private | FRenderer: TGLParticleFXRenderer;
Private | FParticles: TGLParticleList;
Private | FNextID: Integer;
Private | FOnCreateParticle: TPFXCreateParticleEvent;
Private | FAutoFreeWhenEmpty: Boolean;
Private | FUsers: TList;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle: TGLParticle; virtual;
Public | function ParticleCount: Integer; virtual;
Public | class function ParticlesClass: TGLParticleClass; virtual;
Public | procedure CreateParticles(nbParticles: Integer);
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Public | property AutoFreeWhenEmpty: Boolean read FAutoFreeWhenEmpty write FAutoFreeWhenEmpty;
Published | property Cadencer;
Published | property OnCreateParticle: TPFXCreateParticleEvent read FOnCreateParticle write FOnCreateParticle;
Public | property Particles: TGLParticleList read FParticles write SetParticles;
Published | property Renderer: TGLParticleFXRenderer read FRenderer write SetRenderer;

Description

Fields

Private FBlendingMode: TGLBlendingMode;

This item has no description.

Private FRenderer: TGLParticleFXRenderer;

This item has no description.

Private FParticles: TGLParticleList;

This item has no description.

Private FNextID: Integer;

This item has no description.

Private FOnCreateParticle: TPFXCreateParticleEvent;

This item has no description.

Private FAutoFreeWhenEmpty: Boolean;

This item has no description.

Private FUsers: TList;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateParticle: TGLParticle; virtual;

Creates a new particle controled by the manager.

Public function ParticleCount: Integer; virtual;

Return the number of particles. Note that subclasses may decide to return a particle count inferior to Particles.ItemCount, and the value returned by this method will be the one honoured at render time.

Public class function ParticlesClass: TGLParticleClass; virtual;

Class of particles created by this manager. }

Public procedure CreateParticles(nbParticles: Integer);

Create several particles at once.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Public property AutoFreeWhenEmpty: Boolean read FAutoFreeWhenEmpty write FAutoFreeWhenEmpty;

If True the manager will free itself when its particle count reaches zero. Check happens in the progression event, use with caution and only if you know what you're doing!

Published property Cadencer;

This item has no description.

Published property OnCreateParticle: TPFXCreateParticleEvent read FOnCreateParticle write FOnCreateParticle;

Event triggered after standard particle creation and initialization.

Public property Particles: TGLParticleList read FParticles write SetParticles;

A TGLParticleList property.

Published property Renderer: TGLParticleFXRenderer read FRenderer write SetRenderer;

References the renderer. The renderer takes care of ordering the particles of the manager (and other managers linked to it) and rendering them all depth-sorted.


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLParticleFXEffect

Class TGLParticleFXEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLParticleFXEffect = class(TGLObjectPostEffect)

Description

Base class for linking scene objects to a particle FX manager.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect
  • TGLObjectPostEffect
  • TGLParticleFXEffect

Overview

Fields

Private | FManager: TGLParticleFXManager;
Private | FManagerName: string;
Private | FEffectScale: single;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Private | procedure SetEffectScale(const Value: single);

Properties

Published | property EffectScale: single read FEffectScale write SetEffectScale;
Published | property Manager: TGLParticleFXManager read FManager write SetManager;

Description

Fields

Private FManager: TGLParticleFXManager;

This item has no description.

Private FManagerName: string;

This item has no description.

Private FEffectScale: single;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetEffectScale(const Value: single);

This item has no description.

Properties

Published property EffectScale: single read FEffectScale write SetEffectScale;

This item has no description.

Published property Manager: TGLParticleFXManager read FManager write SetManager;

Reference to the Particle FX manager


GLSysHelp v.2.5: GLS.ParticleFX: Packed Record TParticleReference

Packed Record TParticleReference

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TParticleReference = packed record

Description

PFX region rendering structures

Overview

Fields

Public | particle: TGLParticle;
Public | distance: Integer;

Description

Fields

Public particle: TGLParticle;

This item has no description.

Public distance: Integer;


GLSysHelp v.2.5: GLS.ParticleFX: Record TPFXRegion

Record TPFXRegion

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TPFXRegion = record

Description

This item has no description.

Overview

Fields

Public | count: Integer;
Public | capacity: Integer;
Public | particleRef: PParticleReferenceArray;
Public | particleOrder: PFXPointerList;

Description

Fields

Public count: Integer;

This item has no description.

Public capacity: Integer;

This item has no description.

Public particleRef: PParticleReferenceArray;

This item has no description.

Public particleOrder: PFXPointerList;


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLParticleFXRenderer

Class TGLParticleFXRenderer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLParticleFXRenderer = class(TGLBaseSceneObject)

Description

Rendering interface for scene-wide particle FX. A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately. This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLParticleFXRenderer

Overview

Fields

Private | FManagerList: TList;
Private | FLastSortTime: Double;
Private | FLastParticleCount: Integer;
Private | FZWrite: Boolean;
Private | FZTest: Boolean;
Private | FZCull: Boolean;
Private | FZSortAccuracy: TPFXSortAccuracy;
Private | FZMaxDistance: Single;
Private | FBlendingMode: TGLBlendingMode;
Private | FRegions: array[0..cPFXNbRegions - 1] of TPFXRegion;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property BlendingMode: TGLBlendingMode read FBlendingMode write FBlendingMode default bmAdditive;
Public | property LastParticleCount: Integer read FLastParticleCount;
Public | property LastSortTime: Double read FLastSortTime;
Published | property Visible;
Published | property ZCull: Boolean read FZCull write FZCull default True;
Published | property ZMaxDistance: Single read FZMaxDistance write FZMaxDistance stored StoreZMaxDistance;
Published | property ZSortAccuracy: TPFXSortAccuracy read FZSortAccuracy write FZSortAccuracy default saHigh;
Published | property ZTest: Boolean read FZTest write FZTest default True;
Published | property ZWrite: Boolean read FZWrite write FZWrite default False;

Description

Fields

Private FManagerList: TList;

This item has no description.

Private FLastSortTime: Double;

This item has no description.

Private FLastParticleCount: Integer;

This item has no description.

Private FZWrite: Boolean;

This item has no description.

Private FZTest: Boolean;

This item has no description.

Private FZCull: Boolean;

This item has no description.

Private FZSortAccuracy: TPFXSortAccuracy;

This item has no description.

Private FZMaxDistance: Single;

This item has no description.

Private FBlendingMode: TGLBlendingMode;

This item has no description.

Private FRegions: array[0..cPFXNbRegions - 1] of TPFXRegion;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

Quick Explanation of what is below: The purpose is to depth-sort a large number (thousandths) of particles and render them back to front. The rendering part is not particularly complex, it just invokes the various PFX managers involved and request particle renderings. The sort uses a first-pass region partition (the depth range is split into regions, and particles are assigned directly to the region they belong to), then each region is sorted with a QuickSort. The QuickSort itself is the regular classic variant, but the comparison is made on singles as if they were integers, this is allowed by the IEEE format in a very efficient manner if all values are superior to 1, which is ensured by the distance calculation and a fixed offset of 1

Properties

Published property BlendingMode: TGLBlendingMode read FBlendingMode write FBlendingMode default bmAdditive;

Default blending mode for particles. "Additive" blending is the usual mode (increases brightness and saturates), "transparency" may be used for smoke or systems that opacify view, "opaque" is more rarely used. Note: specific PFX managers may override/ignore this setting.

Public property LastParticleCount: Integer read FLastParticleCount;

Amount of particles during the last render.

Public property LastSortTime: Double read FLastSortTime;

Time (in msec) spent sorting the particles for last render.

Published property Visible;

This item has no description.

Published property ZCull: Boolean read FZCull write FZCull default True;

If true the renderer will cull particles that are behind the camera.

Published property ZMaxDistance: Single read FZMaxDistance write FZMaxDistance stored StoreZMaxDistance;

Maximum distance for rendering PFX particles. If zero, camera's DepthOfView is used.

Published property ZSortAccuracy: TPFXSortAccuracy read FZSortAccuracy write FZSortAccuracy default saHigh;

If true particles will be accurately sorted back to front. When false, only a rough ordering is used, which can result in visual glitches but may be faster.

Published property ZTest: Boolean read FZTest write FZTest default True;

Specifies if particles should write to test ZBuffer.

Published property ZWrite: Boolean read FZWrite write FZWrite default False;

Specifies if particles should write to ZBuffer. If the PFXRenderer is the last object to be rendered in the scene, it is not necessary to write to the ZBuffer since the particles are depth-sorted. Writing to the ZBuffer has a performance penalty.


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLSourcePFXEffect

Class TGLSourcePFXEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLSourcePFXEffect = class(TGLParticleFXEffect)

Description

Simple Particles Source.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect
  • TGLObjectPostEffect
  • TGLParticleFXEffect
  • TGLSourcePFXEffect

Overview

Fields

Private | FInitialVelocity: TGLCoordinates;
Private | FInitialPosition: TGLCoordinates;
Private | FPositionDispersionRange: TGLCoordinates;
Private | FVelocityDispersion: Single;
Private | FPositionDispersion: Single;
Private | FParticleInterval: Single;
Private | FVelocityMode: TGLSourcePFXVelocityMode;
Private | FPositionMode: TGLSourcePFXPositionMode;
Private | FDispersionMode: TGLSourcePFXDispersionMode;
Private | FEnabled: Boolean;
Private | FDisabledIfOwnerInvisible: Boolean;
Private | FTimeRemainder: Double;
Private | FRotationDispersion: Single;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | procedure Burst(time: Double; nb: Integer);
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure RingExplosion(time: Double; minInitialSpeed, maxInitialSpeed: Single; nbParticles: Integer);

Properties

Published | property DisabledIfOwnerInvisible: boolean read FDisabledIfOwnerInvisible write FDisabledIfOwnerInvisible;
Published | property DispersionMode: TGLSourcePFXDispersionMode read FDispersionMode write FDispersionMode default sdmFast;
Published | property Enabled: boolean read FEnabled write FEnabled;
Published | property InitialPosition: TGLCoordinates read FInitialPosition write SetInitialPosition;
Published | property InitialVelocity: TGLCoordinates read FInitialVelocity write SetInitialVelocity;
Published | property ParticleInterval: Single read FParticleInterval write SetParticleInterval;
Published | property PositionDispersion: Single read FPositionDispersion write FPositionDispersion;
Published | property PositionDispersionRange: TGLCoordinates read FPositionDispersionRange write SetPositionDispersionRange;
Published | property PositionMode: TGLSourcePFXPositionMode read FPositionMode write FPositionMode default spmAbsoluteOffset;
Published | property RotationDispersion: Single read FRotationDispersion write FRotationDispersion;
Published | property VelocityDispersion: Single read FVelocityDispersion write FVelocityDispersion;
Published | property VelocityMode: TGLSourcePFXVelocityMode read FVelocityMode write FVelocityMode default svmAbsolute;

Description

Fields

Private FInitialVelocity: TGLCoordinates;

This item has no description.

Private FInitialPosition: TGLCoordinates;

This item has no description.

Private FPositionDispersionRange: TGLCoordinates;

This item has no description.

Private FVelocityDispersion: Single;

This item has no description.

Private FPositionDispersion: Single;

This item has no description.

Private FParticleInterval: Single;

This item has no description.

Private FVelocityMode: TGLSourcePFXVelocityMode;

This item has no description.

Private FPositionMode: TGLSourcePFXPositionMode;

This item has no description.

Private FDispersionMode: TGLSourcePFXDispersionMode;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FDisabledIfOwnerInvisible: Boolean;

This item has no description.

Private FTimeRemainder: Double;

This item has no description.

Private FRotationDispersion: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Burst(time: Double; nb: Integer);

Instantaneously creates nb particles

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure RingExplosion(time: Double; minInitialSpeed, maxInitialSpeed: Single; nbParticles: Integer);

This item has no description.

Properties

Published property DisabledIfOwnerInvisible: boolean read FDisabledIfOwnerInvisible write FDisabledIfOwnerInvisible;

This item has no description.

Published property DispersionMode: TGLSourcePFXDispersionMode read FDispersionMode write FDispersionMode default sdmFast;

This item has no description.

Published property Enabled: boolean read FEnabled write FEnabled;

This item has no description.

Published property InitialPosition: TGLCoordinates read FInitialPosition write SetInitialPosition;

This item has no description.

Published property InitialVelocity: TGLCoordinates read FInitialVelocity write SetInitialVelocity;

This item has no description.

Published property ParticleInterval: Single read FParticleInterval write SetParticleInterval;

This item has no description.

Published property PositionDispersion: Single read FPositionDispersion write FPositionDispersion;

This item has no description.

Published property PositionDispersionRange: TGLCoordinates read FPositionDispersionRange write SetPositionDispersionRange;

This item has no description.

Published property PositionMode: TGLSourcePFXPositionMode read FPositionMode write FPositionMode default spmAbsoluteOffset;

This item has no description.

Published property RotationDispersion: Single read FRotationDispersion write FRotationDispersion;

This item has no description.

Published property VelocityDispersion: Single read FVelocityDispersion write FVelocityDispersion;

This item has no description.

Published property VelocityMode: TGLSourcePFXVelocityMode read FVelocityMode write FVelocityMode default svmAbsolute;


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLDynamicPFXManager

Class TGLDynamicPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLDynamicPFXManager = class(TGLParticleFXManager)

Description

An abstract PFX manager for simple dynamic particles. Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager

Overview

Fields

Private | FAcceleration: TGLCoordinates;
Private | FFriction: Single;
Private | FCurrentTime: Double;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;

Properties

Published | property Acceleration: TGLCoordinates read FAcceleration write SetAcceleration;
Published | property Friction: Single read FFriction write FFriction;

Description

Fields

Private FAcceleration: TGLCoordinates;

This item has no description.

Private FFriction: Single;

This item has no description.

Private FCurrentTime: Double;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Properties

Published property Acceleration: TGLCoordinates read FAcceleration write SetAcceleration;

Oriented acceleration applied to the particles.

Published property Friction: Single read FFriction write FFriction;

Friction applied to the particles. Friction is applied as a speed scaling factor over 1 second, ie. a friction of 0.5 will half speed over 1 second, a friction of 3 will triple speed over 1 second, and a friction of 1 (default value) will have no effect.


GLSysHelp v.2.5: GLS.ParticleFX: Class TPFXLifeColor

Class TPFXLifeColor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TPFXLifeColor = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TPFXLifeColor

Overview

Fields

Private | FColorInner: TGLColor;
Private | FColorOuter: TGLColor;
Private | FLifeTime: Single;
Private | FInvLifeTime: Single;
Private | FIntervalRatio: Single;
Private | FSizeScale: Single;
Private | FDoScale: Boolean;
Private | FDoRotate: boolean;
Private | FRotateAngle: Single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property ColorInner: TGLColor read FColorInner write SetColorInner;
Published | property ColorOuter: TGLColor read FColorOuter write SetColorOuter;
Public | property InvIntervalRatio: Single read FIntervalRatio;
Public | property InvLifeTime: Single read FInvLifeTime;
Published | property LifeTime: Single read FLifeTime write SetLifeTime;
Published | property RotateAngle: Single read FRotateAngle write SetRotateAngle;
Published | property SizeScale: Single read FSizeScale write SetSizeScale;

Description

Fields

Private FColorInner: TGLColor;

This item has no description.

Private FColorOuter: TGLColor;

This item has no description.

Private FLifeTime: Single;

This item has no description.

Private FInvLifeTime: Single;

This item has no description.

Private FIntervalRatio: Single;

This item has no description.

Private FSizeScale: Single;

This item has no description.

Private FDoScale: Boolean;

This item has no description.

Private FDoRotate: boolean;

This item has no description.

Private FRotateAngle: Single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

indirectly persistent

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property ColorInner: TGLColor read FColorInner write SetColorInner;

This item has no description.

Published property ColorOuter: TGLColor read FColorOuter write SetColorOuter;

This item has no description.

Public property InvIntervalRatio: Single read FIntervalRatio;

Stores 1/(LifeTime[Next]-LifeTime[Self])

Public property InvLifeTime: Single read FInvLifeTime;

Stores 1/LifeTime

Published property LifeTime: Single read FLifeTime write SetLifeTime;

This item has no description.

Published property RotateAngle: Single read FRotateAngle write SetRotateAngle;

This item has no description.

Published property SizeScale: Single read FSizeScale write SetSizeScale;


GLSysHelp v.2.5: GLS.ParticleFX: Class TPFXLifeColors

Class TPFXLifeColors

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TPFXLifeColors = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TPFXLifeColors

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add: TPFXLifeColor;
Public | function FindItemID(ID: Integer): TPFXLifeColor;
Public | function MaxLifeTime: Double;
Public | function RotationsDefined: Boolean;
Public | function ScalingDefined: Boolean;
Public | procedure PrepareIntervalRatios;

Properties

Public property Items[index: Integer]: TPFXLifeColor read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function Add: TPFXLifeColor;

This item has no description.

Public function FindItemID(ID: Integer): TPFXLifeColor;

This item has no description.

Public function MaxLifeTime: Double;

This item has no description.

Public function RotationsDefined: Boolean;

This item has no description.

Public function ScalingDefined: Boolean;

This item has no description.

Public procedure PrepareIntervalRatios;

This item has no description.

Properties

Public property Items[index: Integer]: TPFXLifeColor read GetItems write SetItems;


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLLifeColoredPFXManager

Class TGLLifeColoredPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLLifeColoredPFXManager = class(TGLDynamicPFXManager)

Description

Base PFX manager for particles with life colors. Particles have a core and edge color, for subclassing.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager

Overview

Fields

Private | FLifeColors: TPFXLifeColors;
Private | FLifeColorsLookup: TList;
Private | FLifeRotations: Boolean;
Private | FLifeScaling: Boolean;
Private | FColorInner: TGLColor;
Private | FColorOuter: TGLColor;
Private | FParticleSize: Single;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property BlendingMode default bmAdditive;
Public | property ColorInner: TGLColor read FColorInner write SetColorInner;
Public | property ColorOuter: TGLColor read FColorOuter write SetColorOuter;
Public | property LifeColors: TPFXLifeColors read FLifeColors write SetLifeColors;
Public | property ParticleSize: Single read FParticleSize write FParticleSize;

Description

Fields

Private FLifeColors: TPFXLifeColors;

This item has no description.

Private FLifeColorsLookup: TList;

This item has no description.

Private FLifeRotations: Boolean;

This item has no description.

Private FLifeScaling: Boolean;

This item has no description.

Private FColorInner: TGLColor;

This item has no description.

Private FColorOuter: TGLColor;

This item has no description.

Private FParticleSize: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property BlendingMode default bmAdditive;

This item has no description.

Public property ColorInner: TGLColor read FColorInner write SetColorInner;

This item has no description.

Public property ColorOuter: TGLColor read FColorOuter write SetColorOuter;

This item has no description.

Public property LifeColors: TPFXLifeColors read FLifeColors write SetLifeColors;

This item has no description.

Public property ParticleSize: Single read FParticleSize write FParticleSize;


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLCustomPFXManager

Class TGLCustomPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLCustomPFXManager = class(TGLLifeColoredPFXManager)

Description

A particles FX manager offering events for customization/experimentation. This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager. If the events aren't handled, nothing will be rendered.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLCustomPFXManager

Overview

Fields

Private | FOnInitializeRendering: TGLDirectRenderEvent;
Private | FOnBeginParticles: TGLDirectRenderEvent;
Private | FOnRenderParticle: TPFXDirectRenderEvent;
Private | FOnEndParticles: TGLDirectRenderEvent;
Private | FOnFinalizeRendering: TGLDirectRenderEvent;
Private | FOnProgress: TPFXProgressEvent;
Private | FOnParticleProgress: TPFXParticleProgress;
Private | FOnGetParticleCountEvent: TPFXGetParticleCountEvent;

Methods

Public | function ParticleCount: Integer; override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property OnBeginParticles: TGLDirectRenderEvent read FOnBeginParticles write FOnBeginParticles;
Published | property OnEndParticles: TGLDirectRenderEvent read FOnEndParticles write FOnEndParticles;
Published | property OnFinalizeRendering: TGLDirectRenderEvent read FOnFinalizeRendering write FOnFinalizeRendering;
Published | property OnGetParticleCountEvent: TPFXGetParticleCountEvent read FOnGetParticleCountEvent write FOnGetParticleCountEvent;
Published | property OnInitializeRendering: TGLDirectRenderEvent read FOnInitializeRendering write FOnInitializeRendering;
Published | property OnParticleProgress: TPFXParticleProgress read FOnParticleProgress write FOnParticleProgress;
Published | property OnProgress: TPFXProgressEvent read FOnProgress write FOnProgress;
Published | property OnRenderParticle: TPFXDirectRenderEvent read FOnRenderParticle write FOnRenderParticle;
Published | property ParticleSize;

Description

Fields

Private FOnInitializeRendering: TGLDirectRenderEvent;

This item has no description.

Private FOnBeginParticles: TGLDirectRenderEvent;

This item has no description.

Private FOnRenderParticle: TPFXDirectRenderEvent;

This item has no description.

Private FOnEndParticles: TGLDirectRenderEvent;

This item has no description.

Private FOnFinalizeRendering: TGLDirectRenderEvent;

This item has no description.

Private FOnProgress: TPFXProgressEvent;

This item has no description.

Private FOnParticleProgress: TPFXParticleProgress;

This item has no description.

Private FOnGetParticleCountEvent: TPFXGetParticleCountEvent;

This item has no description.

Methods

Public function ParticleCount: Integer; override;

This item has no description. Showing description inherited from TGLParticleFXManager.ParticleCount.

Return the number of particles. Note that subclasses may decide to return a particle count inferior to Particles.ItemCount, and the value returned by this method will be the one honoured at render time.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Properties

Published property ColorInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property LifeColors;

This item has no description.

Published property OnBeginParticles: TGLDirectRenderEvent read FOnBeginParticles write FOnBeginParticles;

This item has no description.

Published property OnEndParticles: TGLDirectRenderEvent read FOnEndParticles write FOnEndParticles;

This item has no description.

Published property OnFinalizeRendering: TGLDirectRenderEvent read FOnFinalizeRendering write FOnFinalizeRendering;

This item has no description.

Published property OnGetParticleCountEvent: TPFXGetParticleCountEvent read FOnGetParticleCountEvent write FOnGetParticleCountEvent;

This item has no description.

Published property OnInitializeRendering: TGLDirectRenderEvent read FOnInitializeRendering write FOnInitializeRendering;

This item has no description.

Published property OnParticleProgress: TPFXParticleProgress read FOnParticleProgress write FOnParticleProgress;

This item has no description.

Published property OnProgress: TPFXProgressEvent read FOnProgress write FOnProgress;

This item has no description.

Published property OnRenderParticle: TPFXDirectRenderEvent read FOnRenderParticle write FOnRenderParticle;

This item has no description.

Published property ParticleSize;


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLPolygonPFXManager

Class TGLPolygonPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLPolygonPFXManager = class(TGLLifeColoredPFXManager)

Description

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLPolygonPFXManager

Overview

Fields

Private | FNbSides: Integer;
Private | Fvx: TAffineVector;
Private | Fvy: TAffineVector;
Private | FVertices: TGLAffineVectorList;
Private | FVertBuf: TGLAffineVectorList;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property NbSides: Integer read FNbSides write SetNbSides default 6;
Published | property ParticleSize;

Description

Fields

Private FNbSides: Integer;

This item has no description.

Private Fvx: TAffineVector;

This item has no description.

Private Fvy: TAffineVector;

This item has no description.

Private FVertices: TGLAffineVectorList;

NOT persistent

Private FVertBuf: TGLAffineVectorList;

NOT persistent

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property ColorInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property LifeColors;

This item has no description.

Published property NbSides: Integer read FNbSides write SetNbSides default 6;

This item has no description.

Published property ParticleSize;


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLBaseSpritePFXManager

Class TGLBaseSpritePFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLBaseSpritePFXManager = class(TGLLifeColoredPFXManager)

Description

Base class for sprite-based particles FX managers. The particles are made of optionally centered single-textured quads.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLBaseSpritePFXManager

Overview

Fields

Private | FTexHandle: TGLTextureHandle;
Private | Fvx: TAffineVector;
Private | Fvy: TAffineVector;
Private | Fvz: TAffineVector;
Private | FVertices: TGLAffineVectorList;
Private | FVertBuf: TGLAffineVectorList;
Private | FAspectRatio: Single;
Private | FRotation: Single;
Private | FShareSprites: TGLBaseSpritePFXManager;
Private | FSpritesPerTexture: TSpritesPerTexture;
Private | FColorMode: TSpriteColorMode;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property AspectRatio: Single read FAspectRatio write SetAspectRatio stored StoreAspectRatio;
Public | property ColorMode: TSpriteColorMode read FColorMode write SetColorMode;
Published | property Rotation: Single read FRotation write SetRotation;
Published | property ShareSprites: TGLBaseSpritePFXManager read FShareSprites write FShareSprites;

Description

Fields

Private FTexHandle: TGLTextureHandle;

This item has no description.

Private Fvx: TAffineVector;

This item has no description.

Private Fvy: TAffineVector;

This item has no description.

Private Fvz: TAffineVector;

This item has no description.

Private FVertices: TGLAffineVectorList;

NOT persistent

Private FVertBuf: TGLAffineVectorList;

NOT persistent

Private FAspectRatio: Single;

NOT persistent

Private FRotation: Single;

This item has no description.

Private FShareSprites: TGLBaseSpritePFXManager;

This item has no description.

Private FSpritesPerTexture: TSpritesPerTexture;

This item has no description.

Private FColorMode: TSpriteColorMode;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property AspectRatio: Single read FAspectRatio write SetAspectRatio stored StoreAspectRatio;

Ratio between width and height. An AspectRatio of 1 (default) will result in square sprite particles, values higher than one will result in horizontally stretched sprites, values below one will stretch vertically (assuming no rotation is applied).

Public property ColorMode: TSpriteColorMode read FColorMode write SetColorMode;

This item has no description.

Published property Rotation: Single read FRotation write SetRotation;

Particle sprites rotation (in degrees). All particles of the PFX manager share this rotation.

Published property ShareSprites: TGLBaseSpritePFXManager read FShareSprites write FShareSprites;

If specified the manager will reuse the other manager's sprites. Sharing sprites between PFX managers can help at the rendering stage if particles of the managers are mixed by helping reduce the number of texture switches. Note that only the texture is shared, not the colors, sizes or other dynamic parameters.


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLCustomSpritePFXManager

Class TGLCustomSpritePFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLCustomSpritePFXManager = class(TGLBaseSpritePFXManager)

Description

A sprite-based particles FX managers using user-specified code to prepare the texture

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLBaseSpritePFXManager
  • TGLCustomSpritePFXManager

Overview

Fields

Private FOnPrepareTextureImage: TPFXPrepareTextureImageEvent;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property OnPrepareTextureImage: TPFXPrepareTextureImageEvent read FOnPrepareTextureImage write FOnPrepareTextureImage;
Published | property ParticleSize;
Published | property SpritesPerTexture default sptOne;

Description

Fields

Private FOnPrepareTextureImage: TPFXPrepareTextureImageEvent;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property ColorInner;

This item has no description.

Published property ColorMode default scmInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property LifeColors;

This item has no description.

Published property OnPrepareTextureImage: TPFXPrepareTextureImageEvent read FOnPrepareTextureImage write FOnPrepareTextureImage;

Place your texture rendering code in this event.

Published property ParticleSize;

This item has no description.

Published property SpritesPerTexture default sptOne;


GLSysHelp v.2.5: GLS.ParticleFX: Class TGLPointLightPFXManager

Class TGLPointLightPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ParticleFX

Declaration

type TGLPointLightPFXManager = class(TGLBaseSpritePFXManager)

Description

A sprite-based particles FX managers using point light maps. The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property. This PFX manager renders particles similar to what you can get with TGLPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLBaseSpritePFXManager
  • TGLPointLightPFXManager

Overview

Fields

Private FTexMapSize: Integer;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property ParticleSize;
Published | property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 5;

Description

Fields

Private FTexMapSize: Integer;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property ColorInner;

This item has no description.

Published property ColorMode default scmInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property LifeColors;

This item has no description.

Published property ParticleSize;

This item has no description.

Published property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 5;

Underlying texture map size, as a power of two. Min value is 3 (size=8), max value is 9 (size=512).


GLSysHelp v.2.5: GLS.Particles

Unit GLS.Particles

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLS.Scene
  • GLScene.XCollection
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.OpenGLTokens
  • GLS.Context
  • GLS.Color
  • GLS.BaseClasses
  • GLS.RenderContextInfo
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLParticles |

Types

TGLParticleEvent = procedure(Sender: TObject; particle: TGLBaseSceneObject) of object;

Description

Types

TGLParticleEvent = procedure(Sender: TObject; particle: TGLBaseSceneObject) of object;


GLSysHelp v.2.5: GLS.Particles: Class TGLParticles

Class TGLParticles

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Particles

Declaration

type TGLParticles = class(TGLImmaterialSceneObject)

Description

Manager object of a particle system. Particles in a TGLParticles system are described as normal scene objects, however their children are to be : "particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. "live particle" : the other objects (index>0), this ones are rendered and receive progression events. TGLParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and GLScene objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle. All direct access to a TGLParticles children should be avoided. For high-performance particle systems of basic particles, you should look into GLParticleFX instead, TGLParticles being rather focused on complex particles.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLParticles

Overview

Fields

Private | FCubeSize: TGLFloat;
Private | FEdgeColor: TGLColor;
Private | FVisibleAtRunTime: Boolean;
Private | particlePool: TList;
Private | FParticlePoolSize: Integer;
Private | FOnCreateParticle: TGLParticleEvent;
Private | FOnActivateParticle: TGLParticleEvent;
Private | FOnKillParticle: TGLParticleEvent;
Private | FOnDestroyParticle: TGLParticleEvent;
Private | FOnBeforeRenderParticles: TGLDirectRenderEvent;
Private | FOnAfterRenderParticles: TGLDirectRenderEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle: TGLBaseSceneObject;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var ARci: TGLRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure KillParticle(aParticle: TGLBaseSceneObject);
Public | procedure KillParticles;

Properties

Published | property CubeSize: TGLFloat read FCubeSize write SetCubeSize;
Published | property EdgeColor: TGLColor read FEdgeColor write SetEdgeColor;
Published | property OnActivateParticle: TGLParticleEvent read FOnActivateParticle write FOnActivateParticle;
Published | property OnAfterRenderParticles: TGLDirectRenderEvent read FOnAfterRenderParticles write FOnAfterRenderParticles;
Published | property OnBeforeRenderParticles: TGLDirectRenderEvent read FOnBeforeRenderParticles write FOnBeforeRenderParticles;
Published | property OnCreateParticle: TGLParticleEvent read FOnCreateParticle write FOnCreateParticle;
Published | property OnDestroyParticle: TGLParticleEvent read FOnDestroyParticle write FOnDestroyParticle;
Published | property OnKillParticle: TGLParticleEvent read FOnKillParticle write FOnKillParticle;
Published | property ParticlePoolSize: Integer read FParticlePoolSize write SetParticlePoolSize default 0;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

Description

Fields

Private FCubeSize: TGLFloat;

This item has no description.

Private FEdgeColor: TGLColor;

This item has no description.

Private FVisibleAtRunTime: Boolean;

This item has no description.

Private particlePool: TList;

This item has no description.

Private FParticlePoolSize: Integer;

This item has no description.

Private FOnCreateParticle: TGLParticleEvent;

This item has no description.

Private FOnActivateParticle: TGLParticleEvent;

This item has no description.

Private FOnKillParticle: TGLParticleEvent;

This item has no description.

Private FOnDestroyParticle: TGLParticleEvent;

This item has no description.

Private FOnBeforeRenderParticles: TGLDirectRenderEvent;

This item has no description.

Private FOnAfterRenderParticles: TGLDirectRenderEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateParticle: TGLBaseSceneObject;

Request creation of a new particle. Particle will be either created or retrieved from the particlePool.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var ARci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure KillParticle(aParticle: TGLBaseSceneObject);

Kill given particle. If particlePool is not full, particle will be sent to the pool, if not, it will be freed.

Public procedure KillParticles;

Kill all particles.

Properties

Published property CubeSize: TGLFloat read FCubeSize write SetCubeSize;

This item has no description.

Published property EdgeColor: TGLColor read FEdgeColor write SetEdgeColor;

This item has no description.

Published property OnActivateParticle: TGLParticleEvent read FOnActivateParticle write FOnActivateParticle;

Fired when a particle will get in the "live" list. The particle has just been "Assigned" with the template, may happen after a creation or a pick from the particle pool.

Published property OnAfterRenderParticles: TGLDirectRenderEvent read FOnAfterRenderParticles write FOnAfterRenderParticles;

Fired after rendering the last of the particles.

Published property OnBeforeRenderParticles: TGLDirectRenderEvent read FOnBeforeRenderParticles write FOnBeforeRenderParticles;

Fired before rendering the first of the particles.

Published property OnCreateParticle: TGLParticleEvent read FOnCreateParticle write FOnCreateParticle;

Fired a particle has been created as a template duplicate. When the event is triggered, the particle has yet been added to the scene.

Published property OnDestroyParticle: TGLParticleEvent read FOnDestroyParticle write FOnDestroyParticle;

Triggered just before destroying a particle. The particle can be in the pool (ie. not parented)

Published property OnKillParticle: TGLParticleEvent read FOnKillParticle write FOnKillParticle;

Triggered when a particle is killed. When the event is fired, the particle is still parented, after this event, the particle will either go to the pool or be destroyed if the pool is full.

Published property ParticlePoolSize: Integer read FParticlePoolSize write SetParticlePoolSize default 0;

Size of the particle pool (for storing killed particles). Default size is zero, meaning the particlePool is disabled.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;


GLSysHelp v.2.5: GLS.Perlin

Unit GLS.Perlin

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • Vcl.Graphics
  • GLScene.VectorGeometry
  • GLS.HeightData

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBasePerlinOctav |
Class TGLBasePerlin |
Class TGL1DPerlin |
Class TGL2DPerlinOctav |
Class TGL2DPerlin |
Class TGLPerlinHDS |
Class TGLPerlinHDSThread |

Functions and Procedures

function Linear_Interpolate(const a, b, x: Double): Double;
function Cubic_Interpolate(v0, v1, v2, v3, x: Double): Double;
function Cosine_Interpolate(const a, b, x: Double): Double;
function Perlin_Random1(x: Integer): Double;
function Perlin_Random2(Const x, Y: Integer): Double;
procedure Perlin_Random1DStrip(x, Width, Step: Integer; Amp: Double; Res: T1DPerlinArray);
procedure Cubic_Interpolate_Strip(B1, B2, B3, B4, Res: T1DPerlinArray; Width: Integer);
procedure Smooth_Interpolate_Strip(B1, B2, B3, Res: T1DPerlinArray; Width: Integer);
function ExponateCrap(root, exponant: Integer): Integer;

Types

T1DPerlinArray = array of Double;
T2DPerlinArray = array of T1DPerlinArray;
TGLPerlinInterpolation = (...);
TGLPerlinOctav = class of TGLBasePerlinOctav;

Description

Functions and Procedures

function Linear_Interpolate(const a, b, x: Double): Double;

Useless for final output! Usefull for after interpolation, as its FAST!

function Cubic_Interpolate(v0, v1, v2, v3, x: Double): Double;

does a cubic interpolation

function Cosine_Interpolate(const a, b, x: Double): Double;

does a cosine interpolation

function Perlin_Random1(x: Integer): Double;

just a random controlled by X

function Perlin_Random2(Const x, Y: Integer): Double;

just a random controlled by X,Y

procedure Perlin_Random1DStrip(x, Width, Step: Integer; Amp: Double; Res: T1DPerlinArray);

generates a random strip

procedure Cubic_Interpolate_Strip(B1, B2, B3, B4, Res: T1DPerlinArray; Width: Integer);

cubic interpolate 4 strips into one...

procedure Smooth_Interpolate_Strip(B1, B2, B3, Res: T1DPerlinArray; Width: Integer);

smooth interpolate 3 strips into one...

function ExponateCrap(root, exponant: Integer): Integer;

The function returning some integer based on the rootˆexponant concept, result is crap and is only for "random" usage... eg perlin.

Types

T1DPerlinArray = array of Double;

This item has no description.

T2DPerlinArray = array of T1DPerlinArray;

This item has no description.

TGLPerlinInterpolation = (...);

This item has no description.

Values
  • pi_none
  • pi_simple
  • pi_linear
  • pi_Smoothed
  • pi_Cosine
  • pi_cubic
TGLPerlinOctav = class of TGLBasePerlinOctav;


GLSysHelp v.2.5: GLS.Perlin: Class TGLBasePerlinOctav

Class TGLBasePerlinOctav

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Perlin

Declaration

type TGLBasePerlinOctav = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBasePerlinOctav

Overview

Fields

Private | FAmplitude: Double;
Private | FScale: Double;
Private | FInterpolation: TGLPerlinInterpolation;
Private | FSmoothing: TGLPerlinInterpolation;

Methods

Public Procedure Generate; virtual; abstract;

Properties

Public | property Amplitude: Double read FAmplitude write FAmplitude;
Public | property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Public | property Scale: Double read FScale write FScale;
Public | property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;

Description

Fields

Private FAmplitude: Double;

This item has no description.

Private FScale: Double;

This item has no description.

Private FInterpolation: TGLPerlinInterpolation;

This item has no description.

Private FSmoothing: TGLPerlinInterpolation;

This item has no description.

Methods

Public Procedure Generate; virtual; abstract;

This item has no description.

Properties

Public property Amplitude: Double read FAmplitude write FAmplitude;

This item has no description.

Public property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;

This item has no description.

Public property Scale: Double read FScale write FScale;

This item has no description.

Public property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;


GLSysHelp v.2.5: GLS.Perlin: Class TGLBasePerlin

Class TGLBasePerlin

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Perlin

Declaration

type TGLBasePerlin = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLBasePerlin

Overview

Fields

Private | FPersistence: Double;
Private | FNumber_Of_Octaves: Integer;
Private | FOctaves: TList;
Private | FOctavClass: TGLPerlinOctav;
Private | FInterpolation: TGLPerlinInterpolation;
Private | FSmoothing: TGLPerlinInterpolation;

Methods

Public | Constructor Create(AOwner: TComponent); override;
Public | Procedure Generate; virtual; abstract;

Properties

Published | property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Published | property Number_Of_Octaves: Integer read FNumber_Of_Octaves write Set_Number_Of_Octaves;
Public | property Octaves[index: Integer]: TGLBasePerlinOctav read GetOctave;
Published | property Persistence: Double read FPersistence write SetPersistence;
Published | property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;

Description

Fields

Private FPersistence: Double;

This item has no description.

Private FNumber_Of_Octaves: Integer;

This item has no description.

Private FOctaves: TList;

This item has no description.

Private FOctavClass: TGLPerlinOctav;

This item has no description.

Private FInterpolation: TGLPerlinInterpolation;

This item has no description.

Private FSmoothing: TGLPerlinInterpolation;

This item has no description.

Methods

Public Constructor Create(AOwner: TComponent); override;

This item has no description.

Public Procedure Generate; virtual; abstract;

This item has no description.

Properties

Published property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;

This item has no description.

Published property Number_Of_Octaves: Integer read FNumber_Of_Octaves write Set_Number_Of_Octaves;

This item has no description.

Public property Octaves[index: Integer]: TGLBasePerlinOctav read GetOctave;

This item has no description.

Published property Persistence: Double read FPersistence write SetPersistence;

This item has no description.

Published property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;


GLSysHelp v.2.5: GLS.Perlin: Class TGL1DPerlin

Class TGL1DPerlin

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Perlin

Declaration

type TGL1DPerlin = class(TGLBasePerlin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLBasePerlin
  • TGL1DPerlin

Overview

Methods

Public Function GetPerlinValue_1D(x: Double): Double;

Description

Methods

Public Function GetPerlinValue_1D(x: Double): Double;


GLSysHelp v.2.5: GLS.Perlin: Class TGL2DPerlinOctav

Class TGL2DPerlinOctav

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Perlin

Declaration

type TGL2DPerlinOctav = class(TGLBasePerlinOctav)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBasePerlinOctav
  • TGL2DPerlinOctav

Overview

Fields

Public | Data: T2DPerlinArray;
Public | Width: Integer;
Public | Height: Integer;
Public | XStart: Integer;
Public | YStart: Integer;
Public | XStep: Integer;
Public | YStep: Integer;
Public | YRate: Integer;

Methods

Public | Function GetCosine(x, y: Double): Double;
Public | Function GetCubic(x, y: Double): Double;
Public | Function GetData(x, y: Integer): Double;
Public | Function GetDataSmoothed(x, y: Integer): Double;
Public | Function GetPerling(x, y: Double): Double;
Public | Procedure Generate; override;
Public | Procedure Generate_CubicInterpolate;
Public | Procedure Generate_NonInterpolated;
Public | Procedure Generate_SmoothInterpolate;

Description

Fields

Public Data: T2DPerlinArray;

This item has no description.

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Public XStart: Integer;

This item has no description.

Public YStart: Integer;

This item has no description.

Public XStep: Integer;

This item has no description.

Public YStep: Integer;

This item has no description.

Public YRate: Integer;

This item has no description.

Methods

Public Function GetCosine(x, y: Double): Double;

This item has no description.

Public Function GetCubic(x, y: Double): Double;

This item has no description.

Public Function GetData(x, y: Integer): Double;

This item has no description.

Public Function GetDataSmoothed(x, y: Integer): Double;

This item has no description.

Public Function GetPerling(x, y: Double): Double;

This item has no description.

Public Procedure Generate; override;

This item has no description.

Public Procedure Generate_CubicInterpolate;

This item has no description.

Public Procedure Generate_NonInterpolated;

This item has no description.

Public Procedure Generate_SmoothInterpolate;


GLSysHelp v.2.5: GLS.Perlin: Class TGL2DPerlin

Class TGL2DPerlin

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Perlin

Declaration

type TGL2DPerlin = class(TGLBasePerlin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLBasePerlin
  • TGL2DPerlin

Overview

Fields

Public | Width: Integer;
Public | Height: Integer;
Public | XStart: Integer;
Public | YStart: Integer;
Public | XStep: Integer;
Public | YStep: Integer;
Public | MaxValue: Double;
Public | MinValue: Double;

Methods

Public | Constructor Create(AOwner: TComponent); override;
Public | Function GetPerlinValue_2D(x, y: Double): Double;
Public | Procedure Generate; override;
Public | Procedure MakeBitmap(Param: TBitmap);
Public | Procedure SetHeightData(heightData: TGLHeightData);

Description

Fields

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Public XStart: Integer;

This item has no description.

Public YStart: Integer;

This item has no description.

Public XStep: Integer;

This item has no description.

Public YStep: Integer;

This item has no description.

Public MaxValue: Double;

This item has no description.

Public MinValue: Double;

This item has no description.

Methods

Public Constructor Create(AOwner: TComponent); override;

This item has no description.

Public Function GetPerlinValue_2D(x, y: Double): Double;

This item has no description.

Public Procedure Generate; override;

This item has no description.

Public Procedure MakeBitmap(Param: TBitmap);

This item has no description.

Public Procedure SetHeightData(heightData: TGLHeightData);


GLSysHelp v.2.5: GLS.Perlin: Class TGLPerlinHDS

Class TGLPerlinHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Perlin

Declaration

type TGLPerlinHDS = class(TGLHeightDataSource)

Description

This item has no description. Showing description inherited from TGLHeightDataSource.

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TGLHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TGLHeightData with its "Release" method) Pre-loading : specify a list of TGLHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLPerlinHDS

Overview

Fields

Private | FInterpolation: TGLPerlinInterpolation;
Private | FSmoothing: TGLPerlinInterpolation;
Private | FPersistence: Double;
Private | FNumber_Of_Octaves: Integer;
Private | FLines: TStrings;
Private | FLinesChanged: Boolean;
Private | FXStart: Integer;
Private | FYStart: Integer;
Public | MaxValue: Double;
Public | MinValue: Double;
Public | Stall: Boolean;

Methods

Public | Constructor Create(AOwner: TComponent); override;
Public | procedure StartPreparingData(heightData: TGLHeightData); override;
Public | procedure WaitFor;

Properties

Published | property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Public | property Lines: TStrings read FLines;
Public | property LinesChanged: Boolean read FLinesChanged write FLinesChanged;
Published | property MaxPoolSize;
Published | property Number_Of_Octaves: Integer read FNumber_Of_Octaves write FNumber_Of_Octaves;
Published | property Persistence: Double read FPersistence write FPersistence;
Published | property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;
Published | property XStart: Integer read FXStart write FXStart;
Published | property YStart: Integer read FYStart write FYStart;

Description

Fields

Private FInterpolation: TGLPerlinInterpolation;

This item has no description.

Private FSmoothing: TGLPerlinInterpolation;

This item has no description.

Private FPersistence: Double;

This item has no description.

Private FNumber_Of_Octaves: Integer;

This item has no description.

Private FLines: TStrings;

This item has no description.

Private FLinesChanged: Boolean;

This item has no description.

Private FXStart: Integer;

This item has no description.

Private FYStart: Integer;

This item has no description.

Public MaxValue: Double;

This item has no description.

Public MinValue: Double;

This item has no description.

Public Stall: Boolean;

This item has no description.

Methods

Public Constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure StartPreparingData(heightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Public procedure WaitFor;

This item has no description.

Properties

Published property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;

This item has no description.

Public property Lines: TStrings read FLines;

This item has no description.

Public property LinesChanged: Boolean read FLinesChanged write FLinesChanged;

This item has no description.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property Number_Of_Octaves: Integer read FNumber_Of_Octaves write FNumber_Of_Octaves;

This item has no description.

Published property Persistence: Double read FPersistence write FPersistence;

This item has no description.

Published property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;

This item has no description.

Published property XStart: Integer read FXStart write FXStart;

This item has no description.

Published property YStart: Integer read FYStart write FYStart;


GLSysHelp v.2.5: GLS.Perlin: Class TGLPerlinHDSThread

Class TGLPerlinHDSThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Perlin

Declaration

type TGLPerlinHDSThread = class(TGLHeightDataThread)

Description

This item has no description. Showing description inherited from TGLHeightDataThread.

A thread specialized for processing TGLHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly

Hierarchy

  • TObject
  • TThread
  • TGLHeightDataThread
  • TGLPerlinHDSThread

Overview

Fields

Public | Perlin: TGL2DPerlin;
Public | PerlinSource: TGLPerlinHDS;

Methods

Public | Procedure Execute; override;
Public | Procedure OpdateOutSide;

Description

Fields

Public Perlin: TGL2DPerlin;

This item has no description.

Public PerlinSource: TGLPerlinHDS;

This item has no description.

Methods

Public Procedure Execute; override;

This item has no description.

Public Procedure OpdateOutSide;


GLSysHelp v.2.5: GLS.PerlinPFX

Unit GLS.PerlinPFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.ParticleFX
  • GLS.Graphics
  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPerlinPFXManager |
Class TGLPerlin3DNoise |

Constants

cPERLIN_TABLE_SIZE = 256;

Description

Constants

cPERLIN_TABLE_SIZE = 256;


GLSysHelp v.2.5: GLS.PerlinPFX: Class TGLPerlinPFXManager

Class TGLPerlinPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PerlinPFX

Declaration

type TGLPerlinPFXManager = class(TGLBaseSpritePFXManager)

Description

A sprite-based particles FX manager using perlin-based sprites. This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles. The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLBaseSpritePFXManager
  • TGLPerlinPFXManager

Overview

Fields

Private | FTexMapSize: Integer;
Private | FNoiseSeed: Integer;
Private | FNoiseScale: Integer;
Private | FNoiseAmplitude: Integer;
Private | FSmoothness: Single;
Private | FBrightness: Single;
Private | FGamma: Single;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property Brightness: Single read FBrightness write SetBrightness;
Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property Gamma: Single read FGamma write SetGamma;
Published | property LifeColors;
Published | property NoiseAmplitude: Integer read FNoiseAmplitude write SetNoiseAmplitude default 50;
Published | property NoiseScale: Integer read FNoiseScale write SetNoiseScale default 100;
Published | property NoiseSeed: Integer read FNoiseSeed write SetNoiseSeed default 0;
Published | property ParticleSize;
Published | property Smoothness: Single read FSmoothness write SetSmoothness;
Published | property SpritesPerTexture default sptFour;
Published | property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 6;

Description

Fields

Private FTexMapSize: Integer;

This item has no description.

Private FNoiseSeed: Integer;

This item has no description.

Private FNoiseScale: Integer;

This item has no description.

Private FNoiseAmplitude: Integer;

This item has no description.

Private FSmoothness: Single;

This item has no description.

Private FBrightness: Single;

This item has no description.

Private FGamma: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Brightness: Single read FBrightness write SetBrightness;

Brightness factor applied to the perlin texture intensity. Brightness acts as a scaling, non-saturating factor. Examples: Brightness = 1 : intensities in the [0; 1] range Brightness = 2 : intensities in the [0.5; 1] range Brightness = 0.5 : intensities in the [0; 0.5] range Brightness is applied to the final texture (and thus affects the distance based intensity).

Published property ColorInner;

This item has no description.

Published property ColorMode default scmInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property Gamma: Single read FGamma write SetGamma;

This item has no description.

Published property LifeColors;

This item has no description.

Published property NoiseAmplitude: Integer read FNoiseAmplitude write SetNoiseAmplitude default 50;

Amplitude applied to the perlin noise (intensity). This value represent the percentage of the sprite luminance affected by the perlin texture.

Published property NoiseScale: Integer read FNoiseScale write SetNoiseScale default 100;

Scale applied to the perlin noise (stretching).

Published property NoiseSeed: Integer read FNoiseSeed write SetNoiseSeed default 0;

Random seed to use for the perlin noise.

Published property ParticleSize;

This item has no description.

Published property Smoothness: Single read FSmoothness write SetSmoothness;

Smoothness of the distance-based intensity. This value is the exponent applied to the intensity in the texture, basically with a value of 1 (default) the intensity decreases linearly, with higher values, it will remain 'constant' in the center then fade-off more abruptly, and with values below 1, there will be a sharp spike in the center.

Published property SpritesPerTexture default sptFour;

This item has no description.

Published property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 6;

Underlying texture map size, as a power of two. Min value is 3 (size=8), max value is 9 (size=512).


GLSysHelp v.2.5: GLS.PerlinPFX: Class TGLPerlin3DNoise

Class TGLPerlin3DNoise

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PerlinPFX

Declaration

type TGLPerlin3DNoise = class(TObject)

Description

Generates Perlin Noise in the [-1; 1] range. 2D noise requests are taken in the Z=0 slice

Hierarchy

  • TObject
  • TGLPerlin3DNoise

Overview

Methods

Public | constructor Create(randomSeed: Integer);
Public | function Noise(const v: TAffineVector): Single; overload;
Public | function Noise(const v: TGLVector): Single; overload;
Public | function Noise(const x, y, z: Single): Single; overload;
Public | function Noise(const x, y: Single): Single; overload;
Public | procedure Initialize(randomSeed: Integer);

Description

Methods

Public constructor Create(randomSeed: Integer);

This item has no description.

Public function Noise(const v: TAffineVector): Single; overload;

This item has no description.

Public function Noise(const v: TGLVector): Single; overload;

This item has no description.

Public function Noise(const x, y, z: Single): Single; overload;

This item has no description.

Public function Noise(const x, y: Single): Single; overload;

This item has no description.

Public procedure Initialize(randomSeed: Integer);


GLSysHelp v.2.5: GLS.PhysFields

Unit GLS.PhysFields

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorGeometry
  • GLScene.XCollection
  • GLS.Coordinates
  • GLS.Scene
  • GLS.Behaviours
  • GLS.PhysInertias
  • GLS.PhysManager

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLUniformGravityEmitter |
Class TGLRadialGravityEmitter |
Class TGLDampingFieldEmitter |

Constants

GravitationalConstant = 6.6726E-11;

Description

Constants

GravitationalConstant = 6.6726E-11;


GLSysHelp v.2.5: GLS.PhysFields: Class TGLUniformGravityEmitter

Class TGLUniformGravityEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysFields

Declaration

type TGLUniformGravityEmitter = class(TGLBaseForceFieldEmitter)

Description

GLS.RigidBodyInertia

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBaseForceFieldEmitter
  • TGLUniformGravityEmitter

Overview

Fields

Private fGravity: TGLCoordinates;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForceField(Body: TGLBaseSceneObject) : TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Gravity: TGLCoordinates read fGravity write SetGravity;

Description

Fields

Private fGravity: TGLCoordinates;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TGLBaseForceFieldEmitter.Destroy.

abstract;

Public function CalculateForceField(Body: TGLBaseSceneObject) : TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Gravity: TGLCoordinates read fGravity write SetGravity;


GLSysHelp v.2.5: GLS.PhysFields: Class TGLRadialGravityEmitter

Class TGLRadialGravityEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysFields

Declaration

type TGLRadialGravityEmitter = class(TGLBaseForceFieldEmitter)

Description

This item has no description. Showing description inherited from TGLBaseForceFieldEmitter.

A base for different types of force-field behaviours

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBaseForceFieldEmitter
  • TGLRadialGravityEmitter

Overview

Fields

Private | fMass: Real;
Private | fMassOverG: Real;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForceField(Body: TGLBaseSceneObject) : TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Mass: Real read fMass write fMass;

Description

Fields

Private fMass: Real;

This item has no description.

Private fMassOverG: Real;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TGLBaseForceFieldEmitter.Destroy.

abstract;

Public function CalculateForceField(Body: TGLBaseSceneObject) : TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Mass: Real read fMass write fMass;


GLSysHelp v.2.5: GLS.PhysFields: Class TGLDampingFieldEmitter

Class TGLDampingFieldEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysFields

Declaration

type TGLDampingFieldEmitter = class(TGLBaseForceFieldEmitter)

Description

This item has no description. Showing description inherited from TGLBaseForceFieldEmitter.

A base for different types of force-field behaviours

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBaseForceFieldEmitter
  • TGLDampingFieldEmitter

Overview

Fields

Private fDamping: TGLDamping;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForceField(Body: TGLBaseSceneObject) : TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Damping: TGLDamping read fDamping write SetDamping;

Description

Fields

Private fDamping: TGLDamping;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TGLBaseForceFieldEmitter.Destroy.

abstract;

Public function CalculateForceField(Body: TGLBaseSceneObject) : TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Damping: TGLDamping read fDamping write SetDamping;


GLSysHelp v.2.5: GLS.PhysForces

Unit GLS.PhysForces

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorTypes
  • GLScene.XCollection
  • GLS.Scene
  • GLScene.VectorGeometry
  • GLS.Behaviours
  • GLS.Coordinates
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLForce |
Class TGLHookesSpring |
Class TGLHookesString |

Types

TGLForceType = (...);
TOnCustomForce = procedure() of object;

Description

Types

TGLForceType = (...);

This item has no description.

Values
  • ftHookes
  • ftGravitation
  • ftCustom
TOnCustomForce = procedure() of object;


GLSysHelp v.2.5: GLS.PhysForces: Class TGLForce

Class TGLForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysForces

Declaration

type TGLForce = class(TXCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLForce

Overview

Fields

Private | fObject1: TGLBaseSceneObject;
Private | fObject2: TGLBaseSceneObject;
Private | fposition1: TGLCoordinates;
Private | fposition2: TGLCoordinates;
Private | object1Name: String;
Private | object2Name: String;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForce(): TAffineVector; virtual;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure SetObject1(const val: TGLBaseSceneObject);
Public | procedure SetObject2(const val: TGLBaseSceneObject);
Public | procedure SetPosition1(const val: TGLCoordinates);
Public | procedure SetPosition2(const val: TGLCoordinates);
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Object1: TGLBaseSceneObject read fObject1 write SetObject1;
Published | property Object2: TGLBaseSceneObject read fObject2 write SetObject2;
Published | property Position1: TGLCoordinates read fposition1 write SetPosition1;
Published | property Position2: TGLCoordinates read fposition2 write SetPosition2;

Description

Fields

Private fObject1: TGLBaseSceneObject;

This item has no description.

Private fObject2: TGLBaseSceneObject;

This item has no description.

Private fposition1: TGLCoordinates;

This item has no description.

Private fposition2: TGLCoordinates;

This item has no description.

Private object1Name: String;

This item has no description.

Private object2Name: String;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalculateForce(): TAffineVector; virtual;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ReadFromFiler(reader: TReader); override;

Override this function to read subclass data.

Public procedure SetObject1(const val: TGLBaseSceneObject);

This item has no description.

Public procedure SetObject2(const val: TGLBaseSceneObject);

This item has no description.

Public procedure SetPosition1(const val: TGLCoordinates);

This item has no description.

Public procedure SetPosition2(const val: TGLCoordinates);

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

Override this function to write subclass data.

Properties

Published property Object1: TGLBaseSceneObject read fObject1 write SetObject1;

This item has no description.

Published property Object2: TGLBaseSceneObject read fObject2 write SetObject2;

This item has no description.

Published property Position1: TGLCoordinates read fposition1 write SetPosition1;

This item has no description.

Published property Position2: TGLCoordinates read fposition2 write SetPosition2;


GLSysHelp v.2.5: GLS.PhysForces: Class TGLHookesSpring

Class TGLHookesSpring

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysForces

Declaration

type TGLHookesSpring = class(TGLForce)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLForce
  • TGLHookesSpring

Overview

Fields

Private | fNaturalLength: Real;
Private | fElasticity: Real;
Private | fLength: Real;
Private | fExtension: Real;
Private | fDamping: TGLDamping;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForce(): TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure SetDamping(const val: TGLDamping);
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Damping: TGLDamping read fDamping write SetDamping;
Published | property Elasticity: Real read fElasticity write fElasticity;
Published | property NaturalLength: Real read fNaturalLength write fNaturalLength;

Description

Fields

Private fNaturalLength: Real;

This item has no description.

Private fElasticity: Real;

This item has no description.

Private fLength: Real;

This item has no description.

Private fExtension: Real;

This item has no description.

Private fDamping: TGLDamping;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalculateForce(): TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description. Showing description inherited from TGLForce.ReadFromFiler.

Override this function to read subclass data.

Public procedure SetDamping(const val: TGLDamping);

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description. Showing description inherited from TGLForce.WriteToFiler.

Override this function to write subclass data.

Properties

Published property Damping: TGLDamping read fDamping write SetDamping;

This item has no description.

Published property Elasticity: Real read fElasticity write fElasticity;

This item has no description.

Published property NaturalLength: Real read fNaturalLength write fNaturalLength;


GLSysHelp v.2.5: GLS.PhysForces: Class TGLHookesString

Class TGLHookesString

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysForces

Declaration

type TGLHookesString = class(TGLHookesSpring)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLForce
  • TGLHookesSpring
  • TGLHookesString

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForce(): TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;

procedure WriteToFiler(writer : TWriter); override; procedure ReadFromFiler(reader : TReader); override;

Public destructor Destroy; override;

This item has no description.

Public function CalculateForce(): TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.


GLSysHelp v.2.5: GLS.Physics.Register

Unit GLS.Physics.Register

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLS.ODEManager
  • GLS.NGDManager
  • GLS.PhysManager

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GLSysHelp v.2.5: GLS.PhysInertias

Unit GLS.PhysInertias

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • GLS.PersistentClasses
  • GLScene.XCollection
  • GLS.BaseClasses
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.PhysManager
  • GLS.Coordinates
  • GLScene.Strings
  • GLS.Scene
  • GLS.Behaviours

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLParticleInertia |
Class TGLInertiaTensor |
Class TGLRigidBodyInertia |

Functions and Procedures

function GetOrCreateParticleInertia(behaviours: TGLBehaviours): TGLParticleInertia; overload;
function GetOrCreateParticleInertia(obj: TGLBaseSceneObject): TGLParticleInertia; overload;
function GetOrCreateRigidBodyInertia(behaviours: TGLBehaviours): TGLRigidBodyInertia; overload;
function GetOrCreateRigidBodyInertia(obj: TGLBaseSceneObject): TGLRigidBodyInertia; overload;

Constants

DebugMode = false;

Description

Functions and Procedures

function GetOrCreateParticleInertia(behaviours: TGLBehaviours): TGLParticleInertia; overload;

Returns or creates the TGLParticleInertia within the given behaviours. This helper function is convenient way to access a TGLParticleInertia.

function GetOrCreateParticleInertia(obj: TGLBaseSceneObject): TGLParticleInertia; overload;

Returns or creates the TGLParticleInertia within the given object's behaviours. This helper function is convenient way to access a TGLParticleInertia.

function GetOrCreateRigidBodyInertia(behaviours: TGLBehaviours): TGLRigidBodyInertia; overload;

Returns or creates the TGLRigidBodyInertia within the given behaviours. This helper function is convenient way to access a TGLRigidBodyInertia.

function GetOrCreateRigidBodyInertia(obj: TGLBaseSceneObject): TGLRigidBodyInertia; overload;

Returns or creates the TGLRigidBodyInertia within the given object's behaviours. This helper function is convenient way to access a TGLRigidBodyInertia.

Constants

DebugMode = false;


GLSysHelp v.2.5: GLS.PhysInertias: Class TGLParticleInertia

Class TGLParticleInertia

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysInertias

Declaration

type TGLParticleInertia = class(TGLBaseInertia)

Description

This item has no description. Showing description inherited from TGLBaseInertia.

purpose of TGLBaseInertia is to allow for inertias that may be constrained to 1 or 2 dimensions Shouldn't be used directly, instead use TGLParticleInertia (for a 3D particle) TGLRigidBodyInertia (for a 3D rigid-body) or define a new sub-class e.g. TGL1DParticleInertia, this will allow for faster speed

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBaseInertia
  • TGLParticleInertia

Overview

Fields

Private | FMass: Single;
Private | FTranslationSpeed: TGLCoordinates;
Private | FTranslationDamping: TGLDamping;
Public | fForce: TAffineVector;
Public | LinearPosition: TAffineVector;
Public | LinearMomentum: TAffineVector;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateKE(): Real; override;
Public | function CalculatePE(): Real; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure ApplyDamping(damping: TGLDamping); virtual;
Public | procedure ApplyForce(x, y, z: Real); overload; virtual;
Public | procedure ApplyForce(Force: TAffineVector); overload; virtual;
Public | procedure ApplyForce(pos, Force: TAffineVector); overload; virtual;
Public | procedure ApplyImpulse(j: Single; normal: TAffineVector); overload; virtual;
Public | procedure ApplyImpulse(j, x, y, z: Real); overload; virtual;
Public | procedure ApplyLocalForce(pos, Force: TAffineVector); virtual;
Public | procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalcAuxiliary(); override;
Public | procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); override;
Public | procedure CalculateForceFieldForce(ForceFieldEmitter : TGLBaseForceFieldEmitter); override;
Public | procedure MirrorTranslation;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure RemoveForces(); override;
Public | procedure SetForce(x, y, z: Real); virtual;
Public | procedure SetUpStartingState(); override;
Public | procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); override;
Public | procedure SurfaceBounce(const surfaceNormal: TGLVector; restitution: Single);
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Mass: Single read FMass write FMass;
Published | property TranslationDamping: TGLDamping read FTranslationDamping write SetTranslationDamping;
Published | property TranslationSpeed: TGLCoordinates read FTranslationSpeed write SetTranslationSpeed;

Description

Fields

Private FMass: Single;

modified from TGLBInertia

Private FTranslationSpeed: TGLCoordinates;

This item has no description.

Private FTranslationDamping: TGLDamping;

This item has no description.

Public fForce: TAffineVector;

This item has no description.

Public LinearPosition: TAffineVector;

This item has no description.

Public LinearMomentum: TAffineVector;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TGLBaseInertia.Destroy.

abstract;

Public function CalculateKE(): Real; override;

This item has no description.

Public function CalculatePE(): Real; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure ApplyDamping(damping: TGLDamping); virtual;

This item has no description.

Public procedure ApplyForce(x, y, z: Real); overload; virtual;

This item has no description.

Public procedure ApplyForce(Force: TAffineVector); overload; virtual;

This item has no description.

Public procedure ApplyForce(pos, Force: TAffineVector); overload; virtual;

This item has no description.

Public procedure ApplyImpulse(j: Single; normal: TAffineVector); overload; virtual;

This item has no description.

Public procedure ApplyImpulse(j, x, y, z: Real); overload; virtual;

This item has no description.

Public procedure ApplyLocalForce(pos, Force: TAffineVector); virtual;

This item has no description.

Public procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure CalcAuxiliary(); override;

This item has no description.

Public procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); override;

This item has no description.

Public procedure CalculateForceFieldForce(ForceFieldEmitter : TGLBaseForceFieldEmitter); override;

This item has no description.

Public procedure MirrorTranslation;

Inverts the translation vector

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure RemoveForces(); override;

This item has no description.

Public procedure SetForce(x, y, z: Real); virtual;

This item has no description.

Public procedure SetUpStartingState(); override;

This item has no description.

Public procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); override;

This item has no description. Showing description inherited from TGLBaseInertia.StateToArray.

don't re-declare this in sub-classes just initialise it in constructor

Public procedure SurfaceBounce(const surfaceNormal: TGLVector; restitution: Single);

Bounce speed as if hitting a surface. restitution is the coefficient of restituted energy (1=no energy loss, 0=no bounce). The normal is NOT assumed to be normalized.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Mass: Single read FMass write FMass;

This item has no description.

Published property TranslationDamping: TGLDamping read FTranslationDamping write SetTranslationDamping;

Damping applied to translation speed.<br> Note that it is not "exactly" applied, ie. if damping would stop your object after 0.5 time unit, and your progression steps are of 1 time unit, there will be an integration error of 0.5 time unit.

Published property TranslationSpeed: TGLCoordinates read FTranslationSpeed write SetTranslationSpeed;


GLSysHelp v.2.5: GLS.PhysInertias: Class TGLInertiaTensor

Class TGLInertiaTensor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysInertias

Declaration

type TGLInertiaTensor = class(TGLUpdateAbleObject)

Description

Stores Inertia Tensor for TGLRigidBodyInertia model

Hierarchy

  • TGLUpdateAbleObject
  • TGLInertiaTensor

Overview

Fields

Private | fm11: Single;
Private | fm12: Single;
Private | fm13: Single;
Private | fm21: Single;
Private | fm22: Single;
Private | fm23: Single;
Private | fm31: Single;
Private | fm32: Single;
Private | fm33: Single;

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader);
Public | procedure WriteToFiler(writer: TWriter);

Properties

Published | property m11: Single read fm11 write fm11;
Published | property m12: Single read fm12 write fm12;
Published | property m13: Single read fm13 write fm13;
Published | property m21: Single read fm21 write fm21;
Published | property m22: Single read fm22 write fm22;
Published | property m23: Single read fm23 write fm23;
Published | property m31: Single read fm31 write fm31;
Published | property m32: Single read fm32 write fm32;
Published | property m33: Single read fm33 write fm33;

Description

Fields

Private fm11: Single;

This item has no description.

Private fm12: Single;

This item has no description.

Private fm13: Single;

This item has no description.

Private fm21: Single;

This item has no description.

Private fm22: Single;

This item has no description.

Private fm23: Single;

This item has no description.

Private fm31: Single;

This item has no description.

Private fm32: Single;

This item has no description.

Private fm33: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ReadFromFiler(reader: TReader);

This item has no description.

Public procedure WriteToFiler(writer: TWriter);

This item has no description.

Properties

Published property m11: Single read fm11 write fm11;

This item has no description.

Published property m12: Single read fm12 write fm12;

This item has no description.

Published property m13: Single read fm13 write fm13;

This item has no description.

Published property m21: Single read fm21 write fm21;

This item has no description.

Published property m22: Single read fm22 write fm22;

This item has no description.

Published property m23: Single read fm23 write fm23;

This item has no description.

Published property m31: Single read fm31 write fm31;

This item has no description.

Published property m32: Single read fm32 write fm32;

This item has no description.

Published property m33: Single read fm33 write fm33;


GLSysHelp v.2.5: GLS.PhysInertias: Class TGLRigidBodyInertia

Class TGLRigidBodyInertia

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysInertias

Declaration

type TGLRigidBodyInertia = class(TGLParticleInertia)

Description

A more complex model than TGLBInertia for Inertia

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBaseInertia
  • TGLParticleInertia
  • TGLRigidBodyInertia

Overview

Fields

Private | fDensity: Real;
Private | fBodyInertiaTensor: TAffineMAtrix;
Private | fBodyInverseInertiaTensor: TAffineMAtrix;
Private | fInertiaTensor: TGLInertiaTensor;
Private | InverseInertiaTensor: TAffineMAtrix;
Private | fRotationSpeed: TGLCoordinates;
Private | FRotationDamping: TGLDamping;
Public | AngularOrientation: TQuaternion;
Public | R: TMatrix3f;
Public | AngularMomentum: TAffineVector;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalcAngularOrientationDot(): TQuaternion;
Public | function CalcAngularVelocityDot(): TAffineVector;
Public | function CalculateKE(): Real; override;
Public | function CalculatePE(): Real; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | function QuaternionToString(Quat: TQuaternion): String;
Public | class function UniqueItem: Boolean; override;
Public | procedure ApplyDamping(damping: TGLDamping); override;
Public | procedure ApplyForce(pos, Force: TAffineVector); override;
Public | procedure ApplyImpulse(j: Single; position, normal: TAffineVector); overload;
Public | procedure ApplyImpulse(j, xpos, ypos, zpos, x, y, z: Real); overload;
Public | procedure ApplyLocalForce(pos, Force: TVector3f); override;
Public | procedure ApplyLocalImpulse(xpos, ypos, zpos, x, y, z: Real);
Public | procedure ApplyTorque(x, y, z: Real);
Public | procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalcAuxiliary(); override;
Public | procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure RemoveForces(); override;
Public | procedure SetInertiaTensor(newVal: TGLInertiaTensor);
Public | procedure SetRotationDamping(const val: TGLDamping);
Public | procedure SetRotationSpeed(const val: TGLCoordinates);
Public | procedure SetTorque(x, y, z: Real);
Public | procedure SetUpStartingState(); override;
Public | procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); override;
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Density: Real read fDensity write fDensity;
Published | property InertiaTensor: TGLInertiaTensor read fInertiaTensor write SetInertiaTensor;
Published | property RotationDamping: TGLDamping read FRotationDamping write SetRotationDamping;
Published | property RotationSpeed: TGLCoordinates read fRotationSpeed write SetRotationSpeed;

Description

Fields

Private fDensity: Real;

This item has no description.

Private fBodyInertiaTensor: TAffineMAtrix;

This item has no description.

Private fBodyInverseInertiaTensor: TAffineMAtrix;

This item has no description.

Private fInertiaTensor: TGLInertiaTensor;

This item has no description.

Private InverseInertiaTensor: TAffineMAtrix;

This item has no description.

Private fRotationSpeed: TGLCoordinates;

LinearVelocity:TAffineVector;

Private FRotationDamping: TGLDamping;

AngularVelocity:TAffineVector; //rotation about axis, magnitude=speed damping properties

Public AngularOrientation: TQuaternion;

This item has no description.

Public R: TMatrix3f;

As Quat will help improve accuracy

Public AngularMomentum: TAffineVector;

corresponds to AngularOrientation

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TGLBaseInertia.Destroy.

abstract;

Public function CalcAngularOrientationDot(): TQuaternion;

function CalcLinearPositionDot():TAffineVector; function CalcLinearMomentumDot():TAffineVector;

Public function CalcAngularVelocityDot(): TAffineVector;

This item has no description.

Public function CalculateKE(): Real; override;

This item has no description.

Public function CalculatePE(): Real; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function QuaternionToString(Quat: TQuaternion): String;

function Star(Vector:TAffineVector):TGLMatrix;

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure ApplyDamping(damping: TGLDamping); override;

This item has no description.

Public procedure ApplyForce(pos, Force: TAffineVector); override;

This item has no description.

Public procedure ApplyImpulse(j: Single; position, normal: TAffineVector); overload;

This item has no description.

Public procedure ApplyImpulse(j, xpos, ypos, zpos, x, y, z: Real); overload;

This item has no description.

Public procedure ApplyLocalForce(pos, Force: TVector3f); override;

This item has no description.

Public procedure ApplyLocalImpulse(xpos, ypos, zpos, x, y, z: Real);

This item has no description.

Public procedure ApplyTorque(x, y, z: Real);

This item has no description.

Public procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure CalcAuxiliary(); override;

This item has no description.

Public procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); override;

This item has no description.

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure RemoveForces(); override;

This item has no description.

Public procedure SetInertiaTensor(newVal: TGLInertiaTensor);

This item has no description.

Public procedure SetRotationDamping(const val: TGLDamping);

This item has no description.

Public procedure SetRotationSpeed(const val: TGLCoordinates);

This item has no description.

Public procedure SetTorque(x, y, z: Real);

This item has no description.

Public procedure SetUpStartingState(); override;

This item has no description.

Public procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); override;

This item has no description. Showing description inherited from TGLBaseInertia.StateToArray.

don't re-declare this in sub-classes just initialise it in constructor

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Density: Real read fDensity write fDensity;

This item has no description.

Published property InertiaTensor: TGLInertiaTensor read fInertiaTensor write SetInertiaTensor;

This item has no description.

Published property RotationDamping: TGLDamping read FRotationDamping write SetRotationDamping;

This item has no description.

Published property RotationSpeed: TGLCoordinates read fRotationSpeed write SetRotationSpeed;


GLSysHelp v.2.5: GLS.PhysJoints

Unit GLS.PhysJoints

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLS.Scene
  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseJoint |
Class TGLBaseLink |
Class TGLJoint |
Class TGLLink |
Class TGLType1Link |
Class TGLType2Link |
Class TGLType3Link |
Class TGLType4Link |
Class TGLType5Link |
Class TGLType6Link |
Class TGLType7Link |
Class TGLType8Link |
Class TGLPrismaticJoint |
Class TGLRevoluteJoint |
Class TGLBallAndSocketJoint |


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLBaseJoint

Class TGLBaseJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLBaseJoint = class(TObject)

Description

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLBaseLink

Class TGLBaseLink

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLBaseLink = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBaseLink


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLJoint

Class TGLJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLJoint = class(TGLBaseJoint)

Description

This item has no description. Showing description inherited from TGLBaseJoint.

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint
  • TGLJoint

Overview

Fields

Public | Link1: TGLBaseLink;
Public | Link2: TGLBaseLink;

Description

Fields

Public Link1: TGLBaseLink;

This item has no description.

Public Link2: TGLBaseLink;

if Link1 is nil, assumed to be base


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLLink

Class TGLLink

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLLink = class(TGLBaseLink)

Description

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink

Overview

Fields

Public | fLinkLength: Real;
Public | fTwistAngle: Real;
Public | fLinkAngle: Real;
Public | fLinkDistance: Real;
Public | A: TGLMatrix;

Methods

Public constructor Create(LinkLength, TwistAngle, LinkAngle, LinkDistance: Real);

Description

Fields

Public fLinkLength: Real;

Link Parameters

Public fTwistAngle: Real;

Length of common normal which is orthogonal to both joint axes Z[n-1] and Z[n] (a.k.a. L)

Public fLinkAngle: Real;

Twist angle between joint axes, if joint frames were coincident (a.k.a. Theta?)

Public fLinkDistance: Real;

Angle between common normals X[n-1] and X[n] (a.k.a. Alpha?)

Public A: TGLMatrix;

// // A-Matrix // [ Cos(Theta) -Sin(Theta)*Cos(Alpha) Sin(Theta)*Sin(Alpha) L*Cos(Theta) ] // [ Sin(Theta) Cos(Theta)*cos(Alpha) -Cos(Theta)*Sin(Alpha) L*Sin(Theta) ] // [ 0 Sin(Alpha) Cos(Alpha) d ] // [ 0 0 0 1 ] //

Methods

Public constructor Create(LinkLength, TwistAngle, LinkAngle, LinkDistance: Real);


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLType1Link

Class TGLType1Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLType1Link = class(TGLLink)

Description

// Type 1 Two-Link Manipulator // // _ ________ // / \ \ // / \/________/ // / / // / / // / / // / / // / / // \_/ //

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType1Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

// A-Matrix // [ C1 -S1 0 L1C1 ] // [ S1 C1 0 L1S1 ] // [ 0 0 1 0 ] // [ 0 0 0 1 ] //


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLType2Link

Class TGLType2Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLType2Link = class(TGLLink)

Description

// Type 2 Two-Link Manipulator // ___ // / \___________________ // | + |___________________| // \ / // | | // | | // | | // | | // | | // | | // __|_|__ // |___.___| //

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType2Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

variable


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLType3Link

Class TGLType3Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLType3Link = class(TGLLink)

Description

// Type 3 Two-Link Manipulator // _______ // _________| |__ // <-|_________| |__|-> // |__ __| // | | // | | // | | // | | // | | // _|_|_ // |__.__|

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType3Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

// A-Matrix // [ 1 0 0 0 ] // [ 0 1 0 0 ] // [ 0 0 1 d2 ] // [ 0 0 0 1 ] //


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLType4Link

Class TGLType4Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLType4Link = class(TGLLink)

Description

This item has no description. Showing description inherited from TGLLink.

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType4Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

variable


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLType5Link

Class TGLType5Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLType5Link = class(TGLLink)

Description

// Type 5 Two-Link Manipulator // // _ // ________|_|__ // <-|_____________|-> // | | // | | // | | // | | // | | // __| |__ // |__| |__| // |_| // | // V //

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType5Link

Overview

Fields

Public Length: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Methods

Public constructor Create(Length, Angle: Real);

variable


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLType6Link

Class TGLType6Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLType6Link = class(TGLLink)

Description

This item has no description. Showing description inherited from TGLLink.

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType6Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

variable


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLType7Link

Class TGLType7Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLType7Link = class(TGLLink)

Description

This item has no description. Showing description inherited from TGLLink.

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType7Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

variable


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLType8Link

Class TGLType8Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLType8Link = class(TGLLink)

Description

This item has no description. Showing description inherited from TGLLink.

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType8Link

Overview

Fields

Public Length: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Methods

Public constructor Create(Length, Angle: Real);

variable


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLPrismaticJoint

Class TGLPrismaticJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLPrismaticJoint = class(TGLJoint)

Description

This item has no description. Showing description inherited from TGLBaseJoint.

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint
  • TGLJoint
  • TGLPrismaticJoint


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLRevoluteJoint

Class TGLRevoluteJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLRevoluteJoint = class(TGLJoint)

Description

This item has no description. Showing description inherited from TGLBaseJoint.

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint
  • TGLJoint
  • TGLRevoluteJoint


GLSysHelp v.2.5: GLS.PhysJoints: Class TGLBallAndSocketJoint

Class TGLBallAndSocketJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysJoints

Declaration

type TGLBallAndSocketJoint = class(TGLJoint)

Description

This item has no description. Showing description inherited from TGLBaseJoint.

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint
  • TGLJoint
  • TGLBallAndSocketJoint


GLSysHelp v.2.5: GLS.PhysManager

Unit GLS.PhysManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.PhysForces
  • GLS.Behaviours

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TDESolver |
Class TDESolverExplicit |
Class TDESolverEuler |
Class TDESolverRungeKutta4 |
Class TDESolverImplicit |
Class TDESolverVerlet |
Class TGLBaseInertia |
Class TGLBaseForceFieldEmitter |
Class TGLPhysManager |
Class TGLForces |

Types

TDESolverType = (...);
TStateArray = Array of Real;

Description

Types

TDESolverType = (...);

only ssEuler is usable at the moment

Values
  • ssEuler
  • ssRungeKutta4
  • ssVerlet
TStateArray = Array of Real;

TDESolver = procedure((*RigidBody:TGLRigidBody;*)DeltaTime:Real) of object;


GLSysHelp v.2.5: GLS.PhysManager: Class TDESolver

Class TDESolver

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TDESolver = class(TObject)

Description

need to have state array(s) seperate from inertias to allow for implicit & explicit methods

Hierarchy

  • TObject
  • TDESolver

Overview

Fields

Public | StateSize: Integer;
Public | StateArray: TStateArray;
Public | Owner: TGLPhysManager;

Methods

Public | constructor Create(aOwner: TGLPhysManager);
Public | destructor Destroy; override;
Public | function StateToArray(): TStateArray; virtual;
Public | procedure ArrayToState(StateArray: TStateArray); virtual;
Public | procedure Solve(DeltaTime: Real); virtual; abstract;

Description

Fields

Public StateSize: Integer;

This item has no description.

Public StateArray: TStateArray;

This item has no description.

Public Owner: TGLPhysManager;

This item has no description.

Methods

Public constructor Create(aOwner: TGLPhysManager);

This item has no description.

Public destructor Destroy; override;

override; //abstract;

Public function StateToArray(): TStateArray; virtual;

This item has no description.

Public procedure ArrayToState(StateArray: TStateArray); virtual;

This item has no description.

Public procedure Solve(DeltaTime: Real); virtual; abstract;


GLSysHelp v.2.5: GLS.PhysManager: Class TDESolverExplicit

Class TDESolverExplicit

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TDESolverExplicit = class(TDESolver)

Description

explicit e.g. Euler, Mid-point, Runge-Kutta integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverExplicit

Overview

Fields

Public StateArrayDot: TStateArray;

Methods

Public function CalcStateDot(): TStateArray; virtual;

Description

Fields

Public StateArrayDot: TStateArray;

This item has no description.

Methods

Public function CalcStateDot(): TStateArray; virtual;

Velocity stored


GLSysHelp v.2.5: GLS.PhysManager: Class TDESolverEuler

Class TDESolverEuler

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TDESolverEuler = class(TDESolverExplicit)

Description

This item has no description. Showing description inherited from TDESolverExplicit.

explicit e.g. Euler, Mid-point, Runge-Kutta integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverExplicit
  • TDESolverEuler

Overview

Methods

Public procedure Solve(DeltaTime: Real); override;

Description

Methods

Public procedure Solve(DeltaTime: Real); override;


GLSysHelp v.2.5: GLS.PhysManager: Class TDESolverRungeKutta4

Class TDESolverRungeKutta4

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TDESolverRungeKutta4 = class(TDESolverExplicit)

Description

This item has no description. Showing description inherited from TDESolverExplicit.

explicit e.g. Euler, Mid-point, Runge-Kutta integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverExplicit
  • TDESolverRungeKutta4

Overview

Methods

Public procedure Solve(DeltaTime: Real); override;

Description

Methods

Public procedure Solve(DeltaTime: Real); override;


GLSysHelp v.2.5: GLS.PhysManager: Class TDESolverImplicit

Class TDESolverImplicit

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TDESolverImplicit = class(TDESolver)

Description

implicit e.g. Verlet Integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverImplicit

Overview

Fields

Public LastStateArray: TStateArray;

Description

Fields

Public LastStateArray: TStateArray;


GLSysHelp v.2.5: GLS.PhysManager: Class TDESolverVerlet

Class TDESolverVerlet

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TDESolverVerlet = class(TDESolverImplicit)

Description

This item has no description. Showing description inherited from TDESolverImplicit.

implicit e.g. Verlet Integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverImplicit
  • TDESolverVerlet


GLSysHelp v.2.5: GLS.PhysManager: Class TGLBaseInertia

Class TGLBaseInertia

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TGLBaseInertia = class(TGLBehaviour)

Description

purpose of TGLBaseInertia is to allow for inertias that may be constrained to 1 or 2 dimensions Shouldn't be used directly, instead use TGLParticleInertia (for a 3D particle) TGLRigidBodyInertia (for a 3D rigid-body) or define a new sub-class e.g. TGL1DParticleInertia, this will allow for faster speed

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBaseInertia

Overview

Fields

Private | FDampingEnabled: Boolean;
Private | FManager: TGLPhysManager;
Private | FManagerName: String;
Public | StateSize: Integer;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateKE(): Real; virtual;
Public | function CalculatePE(): Real; virtual;
Public | procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalcAuxiliary(); virtual;
Public | procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); virtual;
Public | procedure CalculateForceFieldForce(ForceFieldEmitter : TGLBaseForceFieldEmitter); virtual;
Public | procedure RemoveForces(); virtual;
Public | procedure SetManager(const val: TGLPhysManager);
Public | procedure SetUpStartingState(); virtual;
Public | procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); virtual;

Properties

Published | property DampingEnabled: Boolean read FDampingEnabled write FDampingEnabled;
Published | property Manager: TGLPhysManager read FManager write SetManager;

Description

Fields

Private FDampingEnabled: Boolean;

This item has no description.

Private FManager: TGLPhysManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Public StateSize: Integer;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

abstract;

Public function CalculateKE(): Real; virtual;

This item has no description.

Public function CalculatePE(): Real; virtual;

This item has no description.

Public procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure CalcAuxiliary(); virtual;

This item has no description.

Public procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); virtual;

This item has no description.

Public procedure CalculateForceFieldForce(ForceFieldEmitter : TGLBaseForceFieldEmitter); virtual;

This item has no description.

Public procedure RemoveForces(); virtual;

This item has no description.

Public procedure SetManager(const val: TGLPhysManager);

This item has no description.

Public procedure SetUpStartingState(); virtual;

This item has no description.

Public procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); virtual;

don't re-declare this in sub-classes just initialise it in constructor

Properties

Published property DampingEnabled: Boolean read FDampingEnabled write FDampingEnabled;

This item has no description.

Published property Manager: TGLPhysManager read FManager write SetManager;


GLSysHelp v.2.5: GLS.PhysManager: Class TGLBaseForceFieldEmitter

Class TGLBaseForceFieldEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TGLBaseForceFieldEmitter = class(TGLBehaviour)

Description

A base for different types of force-field behaviours

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBaseForceFieldEmitter

Overview

Fields

Private | FManager: TGLPhysManager;
Private | FManagerName: String;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForceField(Body: TGLBaseSceneObject): TAffineVector; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetManager(const val: TGLPhysManager);

Properties

Published property Manager: TGLPhysManager read FManager write SetManager;

Description

Fields

Private FManager: TGLPhysManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

abstract;

Public function CalculateForceField(Body: TGLBaseSceneObject): TAffineVector; virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure SetManager(const val: TGLPhysManager);

This item has no description.

Properties

Published property Manager: TGLPhysManager read FManager write SetManager;


GLSysHelp v.2.5: GLS.PhysManager: Class TGLPhysManager

Class TGLPhysManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TGLPhysManager = class(TComponent)

Description

The Simple Physics Interaction (SPI) manager can only deal with objects from one scene More than one physics manager can be assigned to a scene

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLPhysManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CalculateKE(): Real;
Public | function CalculatePE(): Real;
Public | function FindForceFieldEmitterByName(Name: String): TGLBaseSceneObject;
Public | function FindObjectByName(Name: String): TGLBaseSceneObject;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalculateNextState(DeltaTime: Real);
Public | procedure DeRegisterAllForceFieldEmitters;
Public | procedure DeRegisterAllInertias;
Public | procedure DeRegisterForceFieldEmitter(aForceField: TGLBaseForceFieldEmitter);
Public | procedure DeRegisterInertia(aInertia: TGLBaseInertia);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RegisterForceFieldEmitter(aForceField: TGLBaseForceFieldEmitter);
Public | procedure RegisterInertia(aInertia: TGLBaseInertia);
Public | procedure SetDESolver(SolverType: TDESolverType);

Properties

Public | property ForceFieldEmitters: TList read fForceFieldEmitters write SetForceFieldEmitters;
Published | property Forces: TGLForces read GetForces write SetForces;
Public | property Inertias: TList read fInertias write SetInertias;
Published | property Scene: TGLScene read fScene write SetScene;
Published | property Solver: TDESolverType read fDESolverType write SetDESolver;

Description

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalculateKE(): Real;

This item has no description.

Public function CalculatePE(): Real;

This item has no description.

Public function FindForceFieldEmitterByName(Name: String): TGLBaseSceneObject;

This item has no description.

Public function FindObjectByName(Name: String): TGLBaseSceneObject;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure CalculateNextState(DeltaTime: Real);

This item has no description.

Public procedure DeRegisterAllForceFieldEmitters;

This item has no description.

Public procedure DeRegisterAllInertias;

This item has no description.

Public procedure DeRegisterForceFieldEmitter(aForceField: TGLBaseForceFieldEmitter);

This item has no description.

Public procedure DeRegisterInertia(aInertia: TGLBaseInertia);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure RegisterForceFieldEmitter(aForceField: TGLBaseForceFieldEmitter);

This item has no description.

Public procedure RegisterInertia(aInertia: TGLBaseInertia);

This item has no description.

Public procedure SetDESolver(SolverType: TDESolverType);

This item has no description.

Properties

Public property ForceFieldEmitters: TList read fForceFieldEmitters write SetForceFieldEmitters;

stored False;

Published property Forces: TGLForces read GetForces write SetForces;

stored False;

Public property Inertias: TList read fInertias write SetInertias;

This item has no description.

Published property Scene: TGLScene read fScene write SetScene;

This item has no description.

Published property Solver: TDESolverType read fDESolverType write SetDESolver;

stored False;


GLSysHelp v.2.5: GLS.PhysManager: Class TGLForces

Class TGLForces

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.PhysManager

Declaration

type TGLForces = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLForces

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | class function ItemsClass: TXCollectionItemClass; override;

Properties

Public property Force[index: Integer]: TGLForce read GetForce;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public class function ItemsClass: TXCollectionItemClass; override;

destructor Destroy;override;

Properties

Public property Force[index: Integer]: TGLForce read GetForce;


GLSysHelp v.2.5: GLS.PolygonTesselation

Unit GLS.PolygonTesselation

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.SysUtils
  • GLS.OpenGLAdapter
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLS.VectorLists
  • GLScene.VectorGeometry
  • GLS.VectorFileObjects
  • GLS.PersistentClasses

Overview

Functions and Procedures

procedure DoTesselate(Vertexes: TGLAffineVectorList; Mesh: TGLBaseMesh; normal: PAffineVector = nil; invertNormals: Boolean = False);

Description

Functions and Procedures

procedure DoTesselate(Vertexes: TGLAffineVectorList; Mesh: TGLBaseMesh; normal: PAffineVector = nil; invertNormals: Boolean = False);

Tesselates the polygon outlined by the Vertexes. And adds them to the first facegroup of the Mesh.


GLSysHelp v.2.5: GLS.Polyhedra

Unit GLS.Polyhedra

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.Math
  • VCL.Consts
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorTypesExt
  • GLScene.TextureFormat
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.BaseClasses
  • GLS.Objects
  • GLS.GeomObjects
  • GLS.Portal
  • GLS.VectorLists
  • GLS.PersistentClasses
  • GLS.Silhouette
  • GLScene.Strings
  • GLS.Texture
  • GLS.Material
  • GLS.Mesh
  • GLScene.Logger
  • GLS.Octree
  • GLScene.GeometryBB
  • GLS.ApplicationFileIO
  • GLS.Context
  • GLS.Color

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPolyTet |


GLSysHelp v.2.5: GLS.Polyhedra: Class TGLPolyTet

Class TGLPolyTet

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Polyhedra

Declaration

type TGLPolyTet = class(TGLPolygon)

Description

A PolyTet object that handles polygyns for tetrahedron

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLPolygon
  • TGLPolyTet

Overview

Methods

Public | constructor CreateOwned(AOwner: TGLPolygon);
Public | destructor Destroy; override;

Description

Methods

Public constructor CreateOwned(AOwner: TGLPolygon);

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.Portal

Unit GLS.Portal

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.PersistentClasses
  • GLScene.VectorTypes
  • GLS.VectorFileObjects
  • GLS.Scene
  • GLS.Material
  • GLScene.VectorGeometry
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPortalMeshObjectList |
Class TGLSectorMeshObject |
Class TFGPolygon |
Class TFGPortalPolygon |
Class TGLPortal |


GLSysHelp v.2.5: GLS.Portal: Class TGLPortalMeshObjectList

Class TGLPortalMeshObjectList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Portal

Declaration

type TGLPortalMeshObjectList = class(TGLMeshObjectList)

Description

A mesh object list that handles portal rendering. The items are treated as being sectors.

Hierarchy

  • TGLPersistentObjectList
  • TGLMeshObjectList
  • TGLPortalMeshObjectList

Overview

Methods

Public | constructor CreateOwned(AOwner: TGLBaseMesh);
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;

Description

Methods

Public constructor CreateOwned(AOwner: TGLBaseMesh);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLMeshObjectList.BuildList.

Similar to regular scene object's BuildList method


GLSysHelp v.2.5: GLS.Portal: Class TGLSectorMeshObject

Class TGLSectorMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Portal

Declaration

type TGLSectorMeshObject = class(TGLMorphableMeshObject)

Description

A portal renderer sector.

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TGLMorphableMeshObject
  • TGLSectorMeshObject

Overview

Fields

Private FRenderDone: Boolean;

Methods

Public | constructor CreateOwned(AOwner: TGLMeshObjectList);
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure Prepare; override;

Properties

Public property RenderDone: Boolean read FRenderDone write FRenderDone;

Description

Fields

Private FRenderDone: Boolean;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TGLMeshObjectList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLMeshObject.BuildList.

Similar to regular scene object's BuildList method

Public procedure Prepare; override;

This item has no description. Showing description inherited from TGLMeshObject.Prepare.

Precalculate whatever is needed for rendering, called once

Properties

Public property RenderDone: Boolean read FRenderDone write FRenderDone;


GLSysHelp v.2.5: GLS.Portal: Class TFGPolygon

Class TFGPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Portal

Declaration

type TFGPolygon = class(TFGVertexNormalTexIndexList)

Description

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

Hierarchy

  • TGLPersistentObject
  • TGLFaceGroup
  • TFGVertexIndexList
  • TFGVertexNormalTexIndexList
  • TFGPolygon

Overview

Methods

Public | constructor CreateOwned(AOwner: TGLFaceGroups); override;
Public | destructor Destroy; override;
Public | procedure Prepare; override;

Description

Methods

Public constructor CreateOwned(AOwner: TGLFaceGroups); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Prepare; override;

This item has no description. Showing description inherited from TGLFaceGroup.Prepare.

Precalculate whatever is needed for rendering, called once


GLSysHelp v.2.5: GLS.Portal: Class TFGPortalPolygon

Class TFGPortalPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Portal

Declaration

type TFGPortalPolygon = class(TFGPolygon)

Description

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

Hierarchy

  • TGLPersistentObject
  • TGLFaceGroup
  • TFGVertexIndexList
  • TFGVertexNormalTexIndexList
  • TFGPolygon
  • TFGPortalPolygon

Overview

Fields

Private | FDestinationSectorIndex: Integer;
Private | FCenter: TAffineVector;
Private | FNormal: TAffineVector;
Private | FRadius: Single;

Methods

Public | constructor CreateOwned(AOwner: TGLFaceGroups); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure Prepare; override;

Properties

Public property DestinationSectorIndex: Integer read FDestinationSectorIndex write FDestinationSectorIndex;

Description

Fields

Private FDestinationSectorIndex: Integer;

This item has no description.

Private FCenter: TAffineVector;

This item has no description.

Private FNormal: TAffineVector;

This item has no description.

Private FRadius: Single;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TGLFaceGroups); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description.

Public procedure Prepare; override;

This item has no description. Showing description inherited from TGLFaceGroup.Prepare.

Precalculate whatever is needed for rendering, called once

Properties

Public property DestinationSectorIndex: Integer read FDestinationSectorIndex write FDestinationSectorIndex;


GLSysHelp v.2.5: GLS.Portal: Class TGLPortal

Class TGLPortal

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Portal

Declaration

type TGLPortal = class(TGLBaseMesh)

Description

Portal Renderer class.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLPortal

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property MaterialLibrary;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property MaterialLibrary;

This item has no description. Showing description inherited from TGLBaseMesh.MaterialLibrary.

Material library where mesh materials will be stored/retrieved. If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.


GLSysHelp v.2.5: GLS.ProcTextures

Unit GLS.ProcTextures

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLS.Texture
  • GLS.Graphics
  • GLScene.TextureFormat
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLProcTextureNoise |

Constants

GRADIENT_TABLE_SIZE = 256;
DAMP_SHIFT = 20;

Description

Constants

GRADIENT_TABLE_SIZE = 256;

This item has no description.

DAMP_SHIFT = 20;


GLSysHelp v.2.5: GLS.ProcTextures: Class TGLProcTextureNoise

Class TGLProcTextureNoise

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProcTextures

Declaration

type TGLProcTextureNoise = class(TGLTextureImage)

Description

This item has no description. Showing description inherited from TGLTextureImage.

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLProcTextureNoise

Overview

Fields

Private | FNoiseMap: TGLBitmap32;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FMinCut: Byte;
Private | FNoiseSharpness: Single;
Private | FNoiseAnimate: Single;
Private | FSeamless: Boolean;
Private | FNoiseRandSeed: Longint;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLBitmap32; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure NoiseAnimate(speed: Single);
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Public | procedure SetPermFromData(const inPERM: array of Byte);
Public | procedure SetPermToDefault;

Properties

Published | property Depth: Integer read GetDepth;
Published | property Height: Integer read GetHeight write SetHeight default 128;
Published | property MinCut: Byte read FMinCut write SetMinCut;
Published | property NoiseRandSeed: Longint read FNoiseRandSeed write SetNoiseRandSeed;
Published | property NoiseSharpness: Single read FNoiseSharpness write SetNoiseSharpness;
Published | property Seamless: Boolean read FSeamless write SetSeamless;
Published | property Width: Integer read GetWidth write SetWidth default 128;

Description

Fields

Private FNoiseMap: TGLBitmap32;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FMinCut: Byte;

This item has no description.

Private FNoiseSharpness: Single;

This item has no description.

Private FNoiseAnimate: Single;

This item has no description.

Private FSeamless: Boolean;

This item has no description.

Private FNoiseRandSeed: Longint;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TGLBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure NoiseAnimate(speed: Single);

This item has no description.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when GLScene no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Public procedure SetPermFromData(const inPERM: array of Byte);

This item has no description.

Public procedure SetPermToDefault;

This item has no description.

Properties

Published property Depth: Integer read GetDepth;

This item has no description.

Published property Height: Integer read GetHeight write SetHeight default 128;

This item has no description.

Published property MinCut: Byte read FMinCut write SetMinCut;

This item has no description.

Published property NoiseRandSeed: Longint read FNoiseRandSeed write SetNoiseRandSeed;

This item has no description.

Published property NoiseSharpness: Single read FNoiseSharpness write SetNoiseSharpness;

This item has no description.

Published property Seamless: Boolean read FSeamless write SetSeamless;

This item has no description.

Published property Width: Integer read GetWidth write SetWidth default 128;


GLSysHelp v.2.5: GLS.ProjectedTextures

Unit GLS.ProjectedTextures

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.PersistentClasses
  • GLScene.VectorTypes
  • GLS.Texture
  • GLScene.VectorGeometry
  • GLS.RenderContextInfo
  • GLS.State
  • GLS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextureEmitter |
Class TGLTextureEmitterItem |
Class TGLTextureEmitters |
Class TGLProjectedTextures |

Types

TGLProjectedTexturesStyle = (...);

Description

Types

TGLProjectedTexturesStyle = (...);

Possible styles of texture projection. Possible values: ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures).

Values
  • ptsOriginal
  • ptsInverse


GLSysHelp v.2.5: GLS.ProjectedTextures: Class TGLTextureEmitter

Class TGLTextureEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProjectedTextures

Declaration

type TGLTextureEmitter = class(TGLSceneObject)

Description

A projected texture emmiter. It's material property will be used as the projected texture. Can be places anywhere in the scene.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTextureEmitter

Overview

Fields

Private | FFOVy: single;
Private | FAspect: single;

Methods

Public constructor Create(AOwner: TComponent); override;

Properties

Published | property Aspect: single read FAspect write FAspect;
Published | property FOVy: single read FFOVy write FFOVy;

Description

Fields

Private FFOVy: single;

This item has no description.

Private FAspect: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Properties

Published property Aspect: single read FAspect write FAspect;

x/y ratio. For no distortion, this should be set to texture.width/texture.height.

Published property FOVy: single read FFOVy write FFOVy;

Indicates the field-of-view of the projection frustum.


GLSysHelp v.2.5: GLS.ProjectedTextures: Class TGLTextureEmitterItem

Class TGLTextureEmitterItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProjectedTextures

Declaration

type TGLTextureEmitterItem = class(TCollectionItem)

Description

Specifies an item on the TGLTextureEmitters collection.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLTextureEmitterItem

Overview

Fields

Private FEmitter: TGLTextureEmitter;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property Emitter: TGLTextureEmitter read FEmitter write SetEmitter;

Description

Fields

Private FEmitter: TGLTextureEmitter;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Emitter: TGLTextureEmitter read FEmitter write SetEmitter;


GLSysHelp v.2.5: GLS.ProjectedTextures: Class TGLTextureEmitters

Class TGLTextureEmitters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProjectedTextures

Declaration

type TGLTextureEmitters = class(TCollection)

Description

Collection of TGLTextureEmitter.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLTextureEmitters

Overview

Fields

Private FOwner: TGLProjectedTextures;

Methods

Public procedure AddEmitter(texEmitter: TGLTextureEmitter);

Properties

Public property Items[index: Integer]: TGLTextureEmitterItem read GetItems;

Description

Fields

Private FOwner: TGLProjectedTextures;

This item has no description.

Methods

Public procedure AddEmitter(texEmitter: TGLTextureEmitter);

This item has no description.

Properties

Public property Items[index: Integer]: TGLTextureEmitterItem read GetItems;


GLSysHelp v.2.5: GLS.ProjectedTextures: Class TGLProjectedTextures

Class TGLProjectedTextures

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProjectedTextures

Declaration

type TGLProjectedTextures = class(TGLImmaterialSceneObject)

Description

Projected Textures Manager. Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLProjectedTextures

Overview

Fields

Private | FEmitters: TGLTextureEmitters;
Private | FStyle: TGLProjectedTexturesStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Emitters: TGLTextureEmitters read FEmitters write FEmitters;
Published | property Style: TGLProjectedTexturesStyle read FStyle write FStyle;

Description

Fields

Private FEmitters: TGLTextureEmitters;

This item has no description.

Private FStyle: TGLProjectedTexturesStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Emitters: TGLTextureEmitters read FEmitters write FEmitters;

List of texture emitters.

Published property Style: TGLProjectedTexturesStyle read FStyle write FStyle;

Indicates the style of the projected textures.


GLSysHelp v.2.5: GLS.ProxyObjects

Unit GLS.ProxyObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLScene.XCollection
  • GLScene.PipelineTransform
  • GLScene.VectorGeometry
  • GLS.Texture
  • GLS.VectorFileObjects
  • GLScene.Strings
  • GLS.RenderContextInfo
  • GLS.BaseClasses
  • GLS.Material
  • GLS.Context
  • GLS.PersistentClasses
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLProxyException |
Class TGLColorProxy |
Class TGLMaterialProxy |
Class TGLFreeFormProxy |
Class TBoneMatrixObj |
Class TGLActorProxy |

Types

TGLActorProxyAnimationMode = (...);

Description

Types

TGLActorProxyAnimationMode = (...);

pamLoop mode was too difficalt to implement, so it was discarded ...for now. pamPlayOnce only works if Actor.AnimationMode <> aamNone.

Values
  • pamInherited
  • pamNone
  • pamPlayOnce


GLSysHelp v.2.5: GLS.ProxyObjects: Class EGLProxyException

Class EGLProxyException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProxyObjects

Declaration

type EGLProxyException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLProxyException


GLSysHelp v.2.5: GLS.ProxyObjects: Class TGLColorProxy

Class TGLColorProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProxyObjects

Declaration

type TGLColorProxy = class(TGLProxyObject)

Description

A proxy object with its own color. This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject
  • TGLColorProxy

Overview

Fields

Private FFrontColor: TGLFaceProperties;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMasterMaterialObject: TGLCustomSceneObject;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Private | procedure SetFrontColor(AValue: TGLFaceProperties);
Private | procedure SetMasterMaterialObject(const Value: TGLCustomSceneObject);

Properties

Published | property FrontColor: TGLFaceProperties read FFrontColor write SetFrontColor;
Published | property MasterObject: TGLCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;

Description

Fields

Private FFrontColor: TGLFaceProperties;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMasterMaterialObject: TGLCustomSceneObject;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Private procedure SetFrontColor(AValue: TGLFaceProperties);

This item has no description.

Private procedure SetMasterMaterialObject(const Value: TGLCustomSceneObject);

This item has no description.

Properties

Published property FrontColor: TGLFaceProperties read FFrontColor write SetFrontColor;

This item has no description.

Published property MasterObject: TGLCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;

Redeclare as TGLCustomSceneObject.


GLSysHelp v.2.5: GLS.ProxyObjects: Class TGLMaterialProxy

Class TGLMaterialProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProxyObjects

Declaration

type TGLMaterialProxy = class(TGLProxyObject, IGLMaterialLibrarySupported)

Description

A proxy object with its own material. This proxy object can take a mesh from one master and a materia from a material library.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject
  • TGLMaterialProxy

Overview

Fields

Private | FTempLibMaterialName: string;
Private | FMasterLibMaterial: TGLLibMaterial;
Private | FMaterialLibrary: TGLMaterialLibrary;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMasterLibMaterialName: TGLLibMaterialName;
Private | function GetMasterMaterialObject: TGLCustomSceneObject;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Private | procedure SetMasterLibMaterialName(const Value: TGLLibMaterialName);
Private | procedure SetMasterMaterialObject(const Value: TGLCustomSceneObject);
Private | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

Properties

Public | property MasterLibMaterial: TGLLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;
Published | property MasterLibMaterialName: TGLLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;
Published | property MasterObject: TGLCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Fields

Private FTempLibMaterialName: string;

This item has no description.

Private FMasterLibMaterial: TGLLibMaterial;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMasterLibMaterialName: TGLLibMaterialName;

This item has no description.

Private function GetMasterMaterialObject: TGLCustomSceneObject;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Private procedure SetMasterLibMaterialName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMasterMaterialObject(const Value: TGLCustomSceneObject);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

This item has no description.

Properties

Public property MasterLibMaterial: TGLLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;

Specifies the Material, that current master object will use. Provides a faster way to access FMasterLibMaterial, compared to MasterLibMaterialName

Published property MasterLibMaterialName: TGLLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;

Specifies the Material, that current master object will use.

Published property MasterObject: TGLCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;

Redeclare as TGLCustomSceneObject.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;


GLSysHelp v.2.5: GLS.ProxyObjects: Class TGLFreeFormProxy

Class TGLFreeFormProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProxyObjects

Declaration

type TGLFreeFormProxy = class(TGLProxyObject)

Description

A proxy object specialized for FreeForms.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject
  • TGLFreeFormProxy

Overview

Methods

Public | function OctreeRayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean;
Public | function OctreeSphereSweepIntersect(const rayStart, rayVector: TGLVector; const velocity, radius, modelscale: Single; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean;
Private | function GetMasterFreeFormObject: TGLFreeForm;
Private | procedure SetMasterFreeFormObject(const Value: TGLFreeForm);

Properties

Published property MasterObject: TGLFreeForm read GetMasterFreeFormObject write SetMasterFreeFormObject;

Description

Methods

Public function OctreeRayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean;

If the MasterObject is a FreeForm, you can raycast against the Octree, which is alot faster. You must build the octree before using.

Public function OctreeSphereSweepIntersect(const rayStart, rayVector: TGLVector; const velocity, radius, modelscale: Single; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean;

WARNING: This function is not yet 100% reliable with scale+rotation.

Private function GetMasterFreeFormObject: TGLFreeForm;

This item has no description.

Private procedure SetMasterFreeFormObject(const Value: TGLFreeForm);

This item has no description.

Properties

Published property MasterObject: TGLFreeForm read GetMasterFreeFormObject write SetMasterFreeFormObject;

Redeclare as TGLFreeForm.


GLSysHelp v.2.5: GLS.ProxyObjects: Class TBoneMatrixObj

Class TBoneMatrixObj

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProxyObjects

Declaration

type TBoneMatrixObj = class(TObject)

Description

An object containing the bone matrix for TGLActorProxy.

Hierarchy

  • TObject
  • TBoneMatrixObj

Overview

Fields

Public | Matrix: TGLMatrix;
Public | BoneName: string;
Public | BoneIndex: integer;

Description

Fields

Public Matrix: TGLMatrix;

This item has no description.

Public BoneName: string;

This item has no description.

Public BoneIndex: integer;


GLSysHelp v.2.5: GLS.ProxyObjects: Class TGLActorProxy

Class TGLActorProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ProxyObjects

Declaration

type TGLActorProxy = class(TGLProxyObject, IGLMaterialLibrarySupported)

Description

A proxy object specialized for Actors.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject
  • TGLActorProxy

Overview

Fields

Private | FCurrentFrame: Integer;
Private | FStartFrame: Integer;
Private | FEndFrame: Integer;
Private | FLastFrame: Integer;
Private | FCurrentFrameDelta: Single;
Private | FCurrentTime: TGLProgressTimes;
Private | FAnimation: TGLActorAnimationName;
Private | FTempLibMaterialName: string;
Private | FMasterLibMaterial: TGLLibMaterial;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FBonesMatrices: TStringList;
Private | FStoreBonesMatrix: boolean;
Private | FStoredBoneNames: TStrings;
Private | FOnBeforeRender: TGLProgressEvent;
Private | FAnimationMode: TGLActorProxyAnimationMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function BoneMatrix(BoneName: string): TGLMatrix; overload;
Public | function BoneMatrix(BoneIndex: integer): TGLMatrix; overload;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;
Public | function RayCastIntersectEx(RefActor: TGLActor; const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; overload;
Private | function GetLibMaterialName: TGLLibMaterialName;
Private | function GetMasterActorObject: TGLActor;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | procedure BoneMatricesClear;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Private | procedure SetAnimation(const Value: TGLActorAnimationName);
Private | procedure SetLibMaterialName(const Value: TGLLibMaterialName);
Private | procedure SetMasterActorObject(const Value: TGLActor);
Private | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);
Private | procedure SetOnBeforeRender(const Value: TGLProgressEvent);
Private | procedure SetStoreBonesMatrix(const Value: boolean);
Private | procedure SetStoredBoneNames(const Value: TStrings);

Properties

Published | property Animation: TGLActorAnimationName read FAnimation write SetAnimation;
Published | property AnimationMode: TGLActorProxyAnimationMode read FAnimationMode write FAnimationMode default pamInherited;
Public | property CurrentFrame: Integer read FCurrentFrame;
Public | property CurrentFrameDelta: Single read FCurrentFrameDelta;
Public | property CurrentTime: TGLProgressTimes read FCurrentTime;
Public | property EndFrame: Integer read FEndFrame;
Published | property LibMaterialName: TGLLibMaterialName read GetLibMaterialName write SetLibMaterialName;
Published | property MasterObject: TGLActor read GetMasterActorObject write SetMasterActorObject;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property OnBeforeRender: TGLProgressEvent read FOnBeforeRender write SetOnBeforeRender;
Published | property ProxyOptions default [pooEffects, pooObjects];
Public | property StartFrame: Integer read FStartFrame;
Published | property StoreBonesMatrix: boolean read FStoreBonesMatrix write SetStoreBonesMatrix;
Published | property StoredBoneNames: TStrings read FStoredBoneNames write SetStoredBoneNames;

Description

Fields

Private FCurrentFrame: Integer;

This item has no description.

Private FStartFrame: Integer;

This item has no description.

Private FEndFrame: Integer;

This item has no description.

Private FLastFrame: Integer;

This item has no description.

Private FCurrentFrameDelta: Single;

This item has no description.

Private FCurrentTime: TGLProgressTimes;

This item has no description.

Private FAnimation: TGLActorAnimationName;

This item has no description.

Private FTempLibMaterialName: string;

This item has no description.

Private FMasterLibMaterial: TGLLibMaterial;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FBonesMatrices: TStringList;

This item has no description.

Private FStoreBonesMatrix: boolean;

This item has no description.

Private FStoredBoneNames: TStrings;

This item has no description.

Private FOnBeforeRender: TGLProgressEvent;

This item has no description.

Private FAnimationMode: TGLActorProxyAnimationMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

stores matrices of bones of the current frame rendered

Public destructor Destroy; override;

This item has no description.

Public function BoneMatrix(BoneName: string): TGLMatrix; overload;

This item has no description.

Public function BoneMatrix(BoneIndex: integer): TGLMatrix; overload;

Gets the Bones Matrix in the current animation frame. (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;

A standard version of the RayCastIntersect function.

Public function RayCastIntersectEx(RefActor: TGLActor; const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; overload;

Raycasts on self, but actually on the "RefActor" Actor. Note that the "RefActor" parameter does not necessarily have to be the same Actor refernced by the MasterObject property: This allows to pass a low-low-low-poly Actor to raycast in the "RefActor" parameter, while using a high-poly Actor in the "MasterObject" property, of course we assume that the two Masterobject Actors have same animations.

Private function GetLibMaterialName: TGLLibMaterialName;

This item has no description.

Private function GetMasterActorObject: TGLActor;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Public procedure BoneMatricesClear;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Private procedure SetAnimation(const Value: TGLActorAnimationName);

This item has no description.

Private procedure SetLibMaterialName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMasterActorObject(const Value: TGLActor);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

This item has no description.

Private procedure SetOnBeforeRender(const Value: TGLProgressEvent);

This item has no description.

Private procedure SetStoreBonesMatrix(const Value: boolean);

This item has no description.

Private procedure SetStoredBoneNames(const Value: TStrings);

This item has no description.

Properties

Published property Animation: TGLActorAnimationName read FAnimation write SetAnimation;

This item has no description.

Published property AnimationMode: TGLActorProxyAnimationMode read FAnimationMode write FAnimationMode default pamInherited;

This item has no description.

Public property CurrentFrame: Integer read FCurrentFrame;

This item has no description.

Public property CurrentFrameDelta: Single read FCurrentFrameDelta;

This item has no description.

Public property CurrentTime: TGLProgressTimes read FCurrentTime;

This item has no description.

Public property EndFrame: Integer read FEndFrame;

This item has no description.

Published property LibMaterialName: TGLLibMaterialName read GetLibMaterialName write SetLibMaterialName;

Specifies the Material, that current proxy will use.

Published property MasterObject: TGLActor read GetMasterActorObject write SetMasterActorObject;

Redeclare as TGLActor.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Specifies the MaterialLibrary, that current proxy will use.

Published property OnBeforeRender: TGLProgressEvent read FOnBeforeRender write SetOnBeforeRender;

Event allowing to apply extra transformations (f.ex: bone rotations) to the referenced Actor on order to have the proxy render these changes.

Published property ProxyOptions default [pooEffects, pooObjects];

Redeclare without pooTransformation (Don't know why it causes the object to be oriented incorrecly.)

Public property StartFrame: Integer read FStartFrame;

This item has no description.

Published property StoreBonesMatrix: boolean read FStoreBonesMatrix write SetStoreBonesMatrix;

Specifies if it will store the Bones Matrices, accessible via the BoneMatrix function (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)

Published property StoredBoneNames: TStrings read FStoredBoneNames write SetStoredBoneNames;

Specifies the names of the bones we want the matrices to be stored. If empty, all bones will be stored (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)


GLSysHelp v.2.5: GLS.Pythons.Script

Unit GLS.Pythons.Script

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GLS.ScriptBase
  • GLScene.Manager
  • Python.Engine

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPythonEngine |
Class TGLScriptPython |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GLSysHelp v.2.5: GLS.Pythons.Script: Class TGLPythonEngine

Class TGLPythonEngine

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Pythons.Script

Declaration

type TGLPythonEngine = class(TPythonEngine)

Description

This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TGLScriptPython) retain it's assigned compiler from design to run -time.

Hierarchy

  • TPythonEngine
  • TGLPythonEngine

Overview

Methods

Public | constructor Create(AOnwer: TComponent); override;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create(AOnwer: TComponent); override;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLS.Pythons.Script: Class TGLScriptPython

Class TGLScriptPython

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Pythons.Script

Declaration

type TGLScriptPython = class(TGLScriptBase)

Description

Implements Python scripting functionality through the abstracted GLS.ScriptBase

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLScriptBase
  • TGLScriptPython

Overview

Fields

Private | FEngine: TGLPythonEngine;
Private | FEngineName: String;
Private | FCompiled: Boolean;
Private | FStarted: Boolean;

Methods

Public | destructor Destroy; override;
Public | function Call(aName: String; aParams: array of Variant): Variant; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Compile; override;
Public | procedure Execute; override;
Public | procedure Invalidate; override;
Public | procedure Start; override;
Public | procedure Stop; override;

Properties

Published property Engine: TGLPythonEngine read FEngine write SetEngine;

Description

Fields

Private FEngine: TGLPythonEngine;

This item has no description.

Private FEngineName: String;

This item has no description.

Private FCompiled: Boolean;

This item has no description.

Private FStarted: Boolean;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function Call(aName: String; aParams: array of Variant): Variant; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure Compile; override;

This item has no description.

Public procedure Execute; override;

This item has no description.

Public procedure Invalidate; override;

This item has no description.

Public procedure Start; override;

This item has no description.

Public procedure Stop; override;

This item has no description.

Properties

Published property Engine: TGLPythonEngine read FEngine write SetEngine;


GLSysHelp v.2.5: GLS.Ragdoll

Unit GLS.Ragdoll

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLS.Scene
  • GLS.PersistentClasses
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorFileObjects
  • GLS.VectorLists
  • GLS.Objects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLRagdolJoint |
Class TGLRagdolBoneList |
Class TGLRagdolBone |
Class TGLRagdoll |


GLSysHelp v.2.5: GLS.Ragdoll: Class TGLRagdolJoint

Class TGLRagdolJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Ragdoll

Declaration

type TGLRagdolJoint = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLRagdolJoint


GLSysHelp v.2.5: GLS.Ragdoll: Class TGLRagdolBoneList

Class TGLRagdolBoneList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Ragdoll

Declaration

type TGLRagdolBoneList = class(TGLPersistentObjectList)

Description

This item has no description.

Hierarchy

  • TGLPersistentObjectList
  • TGLRagdolBoneList

Overview

Fields

Private FRagdoll: TGLRagdoll;

Methods

Public | constructor Create(Ragdoll: TGLRagdoll); reintroduce;
Public | destructor Destroy; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Items[Index: Integer]: TGLRagdolBone read GetRagdollBone;
Public | property Ragdoll: TGLRagdoll read FRagdoll;

Description

Fields

Private FRagdoll: TGLRagdoll;

This item has no description.

Methods

Public constructor Create(Ragdoll: TGLRagdoll); reintroduce;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Items[Index: Integer]: TGLRagdolBone read GetRagdollBone;

This item has no description.

Public property Ragdoll: TGLRagdoll read FRagdoll;


GLSysHelp v.2.5: GLS.Ragdoll: Class TGLRagdolBone

Class TGLRagdolBone

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Ragdoll

Declaration

type TGLRagdolBone = class(TGLRagdolBoneList)

Description

This item has no description.

Hierarchy

  • TGLPersistentObjectList
  • TGLRagdolBoneList
  • TGLRagdolBone

Overview

Fields

Private | FOwner: TGLRagdolBoneList;
Private | FName: String;
Private | FBoneID: Integer;
Private | FBoundMax: TAffineVector;
Private | FBoundMin: TAffineVector;
Private | FBoundBoneDelta: TAffineVector;
Private | FOrigin: TAffineVector;
Private | FSize: TAffineVector;
Private | FBoneMatrix: TGLMatrix;
Private | FJoint: TGLRagdolJoint;
Private | FOriginalMatrix: TGLMatrix;
Private | FReferenceMatrix: TGLMatrix;
Private | FAnchor: TAffineVector;

Methods

Public | constructor Create(Ragdoll: TGLRagdoll);
Public | constructor CreateOwned(aOwner: TGLRagdolBoneList);
Public | destructor Destroy; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;
Private | procedure AlignChild;
Private | procedure AlignToSkeleton;
Private | procedure CreateBoundingBox;
Private | procedure CreateBoundsChild;
Private | procedure SetAnchor(const Anchor: TAffineVector);
Private | procedure StartChild;
Private | procedure StopChild;
Private | procedure UpdateChild;

Properties

Public | property Anchor: TAffineVector read FAnchor;
Public | property BoneID: Integer read FBoneID write FBoneID;
Public | property BoneMatrix: TGLMatrix read FBoneMatrix;
Public | property Items[Index: Integer]: TGLRagdolBone read GetRagdollBone;
Public | property Joint: TGLRagdolJoint read FJoint write FJoint;
Public | property Name: String read FName write FName;
Public | property Origin: TAffineVector read FOrigin;
Public | property Owner: TGLRagdolBoneList read FOwner;
Public | property ReferenceMatrix: TGLMatrix read FReferenceMatrix;
Public | property Size: TAffineVector read FSize;

Description

Fields

Private FOwner: TGLRagdolBoneList;

This item has no description.

Private FName: String;

This item has no description.

Private FBoneID: Integer;

This item has no description.

Private FBoundMax: TAffineVector;

Refering to TGLActor Bone

Private FBoundMin: TAffineVector;

This item has no description.

Private FBoundBoneDelta: TAffineVector;

This item has no description.

Private FOrigin: TAffineVector;

Stores the diference from the bone.GlobalMatrix to the center of the bone's bounding box

Private FSize: TAffineVector;

This item has no description.

Private FBoneMatrix: TGLMatrix;

This item has no description.

Private FJoint: TGLRagdolJoint;

This item has no description.

Private FOriginalMatrix: TGLMatrix;

This item has no description.

Private FReferenceMatrix: TGLMatrix;

Stores the Bone.GlobalMatrix before the ragdoll start

Private FAnchor: TAffineVector;

Stores the first bone matrix to be used as reference

Methods

Public constructor Create(Ragdoll: TGLRagdoll);

This item has no description.

Public constructor CreateOwned(aOwner: TGLRagdolBoneList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Private procedure AlignChild;

This item has no description.

Private procedure AlignToSkeleton;

This item has no description.

Private procedure CreateBoundingBox;

The position of the joint

Private procedure CreateBoundsChild;

This item has no description.

Private procedure SetAnchor(const Anchor: TAffineVector);

This item has no description.

Private procedure StartChild;

This item has no description.

Private procedure StopChild;

This item has no description.

Private procedure UpdateChild;

This item has no description.

Properties

Public property Anchor: TAffineVector read FAnchor;

This item has no description.

Public property BoneID: Integer read FBoneID write FBoneID;

This item has no description.

Public property BoneMatrix: TGLMatrix read FBoneMatrix;

This item has no description.

Public property Items[Index: Integer]: TGLRagdolBone read GetRagdollBone;

This item has no description.

Public property Joint: TGLRagdolJoint read FJoint write FJoint;

This item has no description.

Public property Name: String read FName write FName;

This item has no description.

Public property Origin: TAffineVector read FOrigin;

This item has no description.

Public property Owner: TGLRagdolBoneList read FOwner;

This item has no description.

Public property ReferenceMatrix: TGLMatrix read FReferenceMatrix;

This item has no description.

Public property Size: TAffineVector read FSize;


GLSysHelp v.2.5: GLS.Ragdoll: Class TGLRagdoll

Class TGLRagdoll

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Ragdoll

Declaration

type TGLRagdoll = class(TGLPersistentObject)

Description

This item has no description.

Hierarchy

  • TGLPersistentObject
  • TGLRagdoll

Overview

Fields

Private | FOwner: TGLBaseMesh;
Private | FRootBone: TGLRagdolBone;
Private | FEnabled: Boolean;
Private | FBuilt: Boolean;

Methods

Public | constructor Create(aOwner: TGLBaseMesh); reintroduce;
Public | destructor Destroy; override;
Public | procedure BuildRagdoll;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure SetRootBone(RootBone: TGLRagdolBone);
Public | procedure Start;
Public | procedure Stop;
Public | procedure Update;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Enabled: Boolean read FEnabled;
Public | property Owner: TGLBaseMesh read FOwner;
Public | property RootBone: TGLRagdolBone read FRootBone;

Description

Fields

Private FOwner: TGLBaseMesh;

This item has no description.

Private FRootBone: TGLRagdolBone;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FBuilt: Boolean;

This item has no description.

Methods

Public constructor Create(aOwner: TGLBaseMesh); reintroduce;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildRagdoll;

Create the bounding box and setup the ragdoll do be started later

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure SetRootBone(RootBone: TGLRagdolBone);

Must be set before build the ragdoll

Public procedure Start;

This item has no description.

Public procedure Stop;

This item has no description.

Public procedure Update;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Enabled: Boolean read FEnabled;

This item has no description.

Public property Owner: TGLBaseMesh read FOwner;

This item has no description.

Public property RootBone: TGLRagdolBone read FRootBone;


GLSysHelp v.2.5: GLS.RandomHDS

Unit GLS.RandomHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.Classes
  • System.Math
  • System.SysUtils
  • System.UITypes
  • System.Contnrs
  • Vcl.Graphics
  • Vcl.Imaging.jpeg
  • Vcl.Forms
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.HeightData
  • GLS.TerrainRenderer
  • GLS.Texture
  • GLS.Color
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLS.Material
  • GLS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TSeaErosion |
Record TRainErosion |
Record TLifeErosion |
Record TFractionErosion |
Record TLandTileInfo |
Record TSteps |
Class TGLBaseRandomHDS |
Class TGLCustomRandomHDS |
Class TGLFractalHDS |
Record TRelativeCoordinate |
Class TGLTiledRndLandscape |
Class TGLFractalArchipelago |

Functions and Procedures

function LoadJPGtexture(const JpgName: string): tBitmap;
function NoisyColor(const Color: tColor; const Noise: single = 0.05): TGLColorVector;
function TextureGreen(const x, y: integer): TGLColorVector;
function TextureBlue(const x, y: integer): TGLColorVector;
function TextureSand(const x, y: integer): TGLColorVector;
function TextureBrownSoil(const x, y: integer): TGLColorVector;
function TextureDarkGreen(const x, y: integer): TGLColorVector;
function TextureDarkGray(const x, y: integer): TGLColorVector;
function TextureWhite(const x, y: integer): TGLColorVector;
procedure FractalMiddlePointHDS(const aDepth, aSeed, aAmplitude: integer; const aRoughness: single; aCyclic: boolean; var z: TMapOfSingle; var MinZ, MaxZ: single);
procedure InitializeRandomGenerator(const Seed: integer);
procedure PrimerNull(var z: TMapOfSingle);
procedure PrimerIsland(LowZ, HighZ: single; var z: TMapOfSingle);

Types

TGLLandTile = TGLCustomRandomHDS;
TIntegerClamp = procedure(var x, y: integer) of object;
TIsDefaultTile = function(X, Z: integer): boolean of object;
TMapOfSingle = array of array of single;
TMapOfVector = array of array of TGLVector;
TOnCreateLandTile = procedure(x, z, Seed: integer; var aLandscape: TGLLandTile) of object;
TOnDrawTexture = function(const Sender: TGLBaseRandomHDS; x, y: integer; z: double; Normal: TGLVector): TGLColorVector of object;
TSingleClamp = procedure(var x, y: single) of object;

Constants

VerticalScalingFactor = 128;

Description

Functions and Procedures

function LoadJPGtexture(const JpgName: string): tBitmap;

Texture functions

function NoisyColor(const Color: tColor; const Noise: single = 0.05): TGLColorVector;

This item has no description.

function TextureGreen(const x, y: integer): TGLColorVector;

This item has no description.

function TextureBlue(const x, y: integer): TGLColorVector;

This item has no description.

function TextureSand(const x, y: integer): TGLColorVector;

This item has no description.

function TextureBrownSoil(const x, y: integer): TGLColorVector;

This item has no description.

function TextureDarkGreen(const x, y: integer): TGLColorVector;

This item has no description.

function TextureDarkGray(const x, y: integer): TGLColorVector;

This item has no description.

function TextureWhite(const x, y: integer): TGLColorVector;

This item has no description.

procedure FractalMiddlePointHDS(const aDepth, aSeed, aAmplitude: integer; const aRoughness: single; aCyclic: boolean; var z: TMapOfSingle; var MinZ, MaxZ: single);

Fractal algorithm based on the middle-point displacement method. It is built in a way that it can be juxtaposed seamlessly to itself (cyclic boundaries)

procedure InitializeRandomGenerator(const Seed: integer);

This item has no description.

procedure PrimerNull(var z: TMapOfSingle);

Landscape primers

procedure PrimerIsland(LowZ, HighZ: single; var z: TMapOfSingle);

This item has no description.

Types

TGLLandTile = TGLCustomRandomHDS;

TMapOfLandscapes: array of array of TGLBaseRandomHDS;

TIntegerClamp = procedure(var x, y: integer) of object;

This item has no description.

TIsDefaultTile = function(X, Z: integer): boolean of object;

This item has no description.

TMapOfSingle = array of array of single;

This item has no description.

TMapOfVector = array of array of TGLVector;

This item has no description.

TOnCreateLandTile = procedure(x, z, Seed: integer; var aLandscape: TGLLandTile) of object;

This item has no description.

TOnDrawTexture = function(const Sender: TGLBaseRandomHDS; x, y: integer; z: double; Normal: TGLVector): TGLColorVector of object;

Function type to use for topography-based texture

TSingleClamp = procedure(var x, y: single) of object;

This item has no description.

Constants

VerticalScalingFactor = 128;


GLSysHelp v.2.5: GLS.RandomHDS: Record TSeaErosion

Record TSeaErosion

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TSeaErosion = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | BeachHeight: single;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public BeachHeight: single;


GLSysHelp v.2.5: GLS.RandomHDS: Record TRainErosion

Record TRainErosion

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TRainErosion = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | ErosionRate: single;
Public | DepositRate: single;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public ErosionRate: single;

This item has no description.

Public DepositRate: single;


GLSysHelp v.2.5: GLS.RandomHDS: Record TLifeErosion

Record TLifeErosion

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TLifeErosion = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | Robustness: single;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public Robustness: single;


GLSysHelp v.2.5: GLS.RandomHDS: Record TFractionErosion

Record TFractionErosion

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TFractionErosion = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | Slope: single;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public Slope: single;


GLSysHelp v.2.5: GLS.RandomHDS: Record TLandTileInfo

Record TLandTileInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TLandTileInfo = record

Description

This item has no description.

Overview

Fields

Public | x: integer;
Public | z: integer;
Public | State: TGLHeightDataState;

Description

Fields

Public x: integer;

This item has no description.

Public z: integer;

This item has no description.

Public State: TGLHeightDataState;

Coordinates of the landtile. Used to generate the seed


GLSysHelp v.2.5: GLS.RandomHDS: Record TSteps

Record TSteps

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TSteps = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | Count: integer;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public Count: integer;


GLSysHelp v.2.5: GLS.RandomHDS: Class TGLBaseRandomHDS

Class TGLBaseRandomHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TGLBaseRandomHDS = class(TGLHeightDataSource)

Description

This class introduces all the basic properties of random landscape. No method implemented though. It is used as a descendant for - TGLCustomRandomLandscape: one tile landscape (cyclic or not) - TGLTiledRndLandscape: "infinite" landscapes (grids of TGLCustomRandomLandscape)

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLBaseRandomHDS

Overview

Fields

Private | FSteps: TSteps;
Private | FLandCover: boolean;
Public | FErosionByRain: TRainErosion;
Public | FErosionBySea: TSeaErosion;
Public | FErosionByLife: TLifeErosion;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetLandCover(const Value: boolean);
Private | procedure SetOnDrawTexture(const Value: TOnDrawTexture);
Private | procedure SetSteps(const Value: TSteps);

Properties

Published | property AmbientLight: single read FAmbientLight write SetAmbientLight;
Published | property Cyclic: boolean read FCyclic write SetCyclic;
Published | property ErosionByFraction: TFractionErosion read FErosionByFraction write SetErosionByFraction;
Published | property ErosionByLife: TLifeErosion read FErosionByLife write SetErosionByLife;
Published | property ErosionByRain: TRainErosion read FErosionByRain write SetErosionByRain;
Published | property ErosionBySea: TSeaErosion read FErosionBySea write SetErosionBySea;
Published | property LandCover: boolean read FLandCover write SetLandCover;
Public | property LightColor: TGLColorVector read FLightColor write SetLightColor;
Public | property LightDirection: TGLVector read FLightDirection write SetLightDirection;
Published | property Lighting: boolean read FLighting write SetLighting;
Published | property LightSmoothing: boolean read FLightSmoothing write SetLightSmoothing;
Published | property MaterialName: string read FMaterialName write SetMaterialName;
Public | property OnDrawTexture: TOnDrawTexture read FOnDrawTexture write SetOnDrawTexture;
Published | property PrimerLandscape: boolean read FPrimerLandscape write SetPrimerLandscape;
Published | property Sea: boolean read FSea write SetSea;
Published | property SeaLevel: single read GetSeaLevel write SetSeaLevel;
Published | property SeaTransparency: single read GetSeaTransparency write SetSeaTransparency;
Published | property Seed: integer read FSeed write SetSeed;
Published | property Shadows: boolean read FShadows write SetShadows;
Published | property Steps: TSteps read FSteps write SetSteps;
Published | property TerrainRenderer: TGLTerrainRenderer read FTerrainRenderer write SetTerrainRenderer;
Published | property TextureScale: integer read FTextureScale write SetTextureScale;

Description

Fields

Private FSteps: TSteps;

This item has no description.

Private FLandCover: boolean;

This item has no description.

Public FErosionByRain: TRainErosion;

This item has no description.

Public FErosionBySea: TSeaErosion;

This item has no description.

Public FErosionByLife: TLifeErosion;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetLandCover(const Value: boolean);

This item has no description.

Private procedure SetOnDrawTexture(const Value: TOnDrawTexture);

This item has no description.

Private procedure SetSteps(const Value: TSteps);

This item has no description.

Properties

Published property AmbientLight: single read FAmbientLight write SetAmbientLight;

This item has no description.

Published property Cyclic: boolean read FCyclic write SetCyclic;

If true, the landscape can be tiled to itself seamlessly. If false, the landscape is an isolated square.

Published property ErosionByFraction: TFractionErosion read FErosionByFraction write SetErosionByFraction;

Erosion parameters. See associated record types

Published property ErosionByLife: TLifeErosion read FErosionByLife write SetErosionByLife;

This item has no description.

Published property ErosionByRain: TRainErosion read FErosionByRain write SetErosionByRain;

This item has no description.

Published property ErosionBySea: TSeaErosion read FErosionBySea write SetErosionBySea;

This item has no description.

Published property LandCover: boolean read FLandCover write SetLandCover;

This item has no description.

Public property LightColor: TGLColorVector read FLightColor write SetLightColor;

Usually white, but you can generate e.g.sunset ambiance by setting it to red

Public property LightDirection: TGLVector read FLightDirection write SetLightDirection;

Light is parallel (sun light)

Published property Lighting: boolean read FLighting write SetLighting;

Enable or disable all lighting effects

Published property LightSmoothing: boolean read FLightSmoothing write SetLightSmoothing;

True by default. You can gain a little speed by disabling it.

Published property MaterialName: string read FMaterialName write SetMaterialName;

Not used

Public property OnDrawTexture: TOnDrawTexture read FOnDrawTexture write SetOnDrawTexture;

This function must be supplied by the user. Here he/she can define which colour to use depending on coordinates, elevation and normal. This provides a great flexibility. If no function is supplied (OnDrawTexture=nil), a default texture function is used (very basic, just blue and green).

Published property PrimerLandscape: boolean read FPrimerLandscape write SetPrimerLandscape;

If true, the height-field will not be emptied and generation will take the existing heights to shape the new landscape

Published property Sea: boolean read FSea write SetSea;

Enable the sea surface truncation

Published property SeaLevel: single read GetSeaLevel write SetSeaLevel;

Sea level

Published property SeaTransparency: single read GetSeaTransparency write SetSeaTransparency;

Depth at which the sea bottom becomes invisible. See DoSea for more information

Published property Seed: integer read FSeed write SetSeed;

Seed used by the random generator. Each seed generate a different reproductible landscape.

Published property Shadows: boolean read FShadows write SetShadows;

Enable shadow casting. May take some time for large Depth.

Published property Steps: TSteps read FSteps write SetSteps;

This item has no description.

Published property TerrainRenderer: TGLTerrainRenderer read FTerrainRenderer write SetTerrainRenderer;

TerrainRenderer used to render the HDS.

Published property TextureScale: integer read FTextureScale write SetTextureScale;

Defines how many texture pixels are drawn per height-field cell. The larger this number the better the quality of the resulting image, but it takes a more time to compute. Good results are got between 1 and 5.


GLSysHelp v.2.5: GLS.RandomHDS: Class TGLCustomRandomHDS

Class TGLCustomRandomHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TGLCustomRandomHDS = class(TGLBaseRandomHDS)

Description

Base structure for all random landscape objects. It can't be used directly since its BuildHeightField procedure is abstract. Use one of its descendants instead.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLBaseRandomHDS
  • TGLCustomRandomHDS

Overview

Fields

Private | FSlave: boolean;
Private | FMaxHeight: single;
Private | FMinHeight: single;
Private | FRangeHeight: single;
Private | FTask: string;
Private | FSingleConstrain: TSingleClamp;
Private | FIntegerConstrain: TIntegerClamp;
Private | FKeepNormals: boolean;
Public | FHeight: TMapOfSingle;
Public | FLightMap: TMapOfSingle;
Public | FNormal: TMapOfVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function BoundaryX: integer;
Public | function BoundaryZ: integer;
Public | function Interpolate(x, y: single): single;
Public | function Normal(const Position: TGLVector): TGLVector;
Public | function PointInMap(const x, y: integer): boolean; overload;
Public | function PointInMap(const x, y: single): boolean; overload;
Public | function Scale: TGLCoordinates;
Public | function StandardisedHeight(const x, y: integer): single;
Public | function XMoveBoundary: single;
Public | function ZMoveBoundary: single;
Private | function GetHeight(x, y: integer): single;
Public | procedure BuildHeightField; overload; virtual; abstract;
Public | procedure BuildLandscape;
Public | procedure BuildLightMap(const aLightDirection: TGLVector); overload;
Public | procedure BuildLightMap; overload;
Public | procedure BuildNormals;
Public | procedure BuildTexture;
Public | procedure ClearHeightField;
Public | procedure ClearLightMap;
Public | procedure ConstrainCoordinates(var x, y: single); overload;
Public | procedure ConstrainCoordinates(var x, y: integer); overload;
Public | procedure DoCyclicBoundaries;
Public | procedure DoErosionByFraction;
Public | procedure DoErosionByLife;
Public | procedure DoErosionByRain;
Public | procedure DoErosionBySea;
Public | procedure DoSea;
Public | procedure DoSteps;
Public | procedure StartPreparingData(heightData: TGLHeightData); override;
Private | procedure SetHeight(x, y: integer; const Value: single);
Private | procedure SetKeepNormals(const Value: boolean);

Properties

Published | property Cyclic: boolean read FCyclic write SetCyclic;
Public | property Heights[x,y: integer]: single read GetHeight write SetHeight;
Public | property KeepNormals: boolean read FKeepNormals write SetKeepNormals;
Public | property LandTileInfo: TLandTileInfo read GetLandTileInfo write SetLandTileInfo;
Public | property MaxHeight: single read FMaxHeight;
Public | property MinHeight: single read FMinHeight;
Public | property RangeHeight: single read FRangeHeight;
Public | property Size: integer read FSize;
Public | property Task: string read FTask;
Public | property TaskProgress: integer read FTaskProgress;

Description

Fields

Private FSlave: boolean;

This item has no description.

Private FMaxHeight: single;

This item has no description.

Private FMinHeight: single;

This item has no description.

Private FRangeHeight: single;

This item has no description.

Private FTask: string;

This item has no description.

Private FSingleConstrain: TSingleClamp;

This item has no description.

Private FIntegerConstrain: TIntegerClamp;

This item has no description.

Private FKeepNormals: boolean;

This item has no description.

Public FHeight: TMapOfSingle;

This item has no description.

Public FLightMap: TMapOfSingle;

This item has no description.

Public FNormal: TMapOfVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BoundaryX: integer;

Upper bounds of the tile

Public function BoundaryZ: integer;

This item has no description.

Public function Interpolate(x, y: single): single;

A specific implementation of THeightDataSource.InterpolatedHeight

Public function Normal(const Position: TGLVector): TGLVector;

Vector normal to the terrain at the position

Public function PointInMap(const x, y: integer): boolean; overload;

This item has no description.

Public function PointInMap(const x, y: single): boolean; overload;

Range checking

Public function Scale: TGLCoordinates;

Scale of the Terrain Renderer. They are set so as giving a identical vertical/horitontal ratio with any size. Therefore, Scale.X=Scale.Y=1 and only Scale.Z varies. If you want to increase the landscape scale, the best way would be to place the Terrain Renderer in a DummyCube and rescale it.

Public function StandardisedHeight(const x, y: integer): single;

A height rescaled between 0 and 1000 for

Public function XMoveBoundary: single;

Use these boundaries with non-cyclic landscapes to constrain camera movements.

Public function ZMoveBoundary: single;

This item has no description.

Private function GetHeight(x, y: integer): single;

This item has no description.

Public procedure BuildHeightField; overload; virtual; abstract;

Generate the heightfield array, based on the topographical properties

Public procedure BuildLandscape;

Provide an automated way to build a landscape. However, a greater control can be achieved by calling the various procedures manually (they are public methods) as one gets a sligthly different result depending on the sequence of erosion and sea steps.

Public procedure BuildLightMap(const aLightDirection: TGLVector); overload;

This item has no description.

Public procedure BuildLightMap; overload;

- Compute the light effects - Compute the casted shadows - Perform a basic smoothing if TextureScale>1

Public procedure BuildNormals;

Normals are needed for lighting and slope-based textures

Public procedure BuildTexture;

For every pixel of the texture, computes slope and interpolated height and sends these information to a user-supplied function (OnDrawTexture), whose result is a TGLColorVector. If no OnDrawTexture is supplied, a basic default texture will be used.

Public procedure ClearHeightField;

Fill the heightfield with "Empty" values (-999)

Public procedure ClearLightMap;

Fill the light map with 1

Public procedure ConstrainCoordinates(var x, y: single); overload;

Constrain x,y to be in the boundaries of the height field array. This is done in two way depending on the kind of landscape: Cyclic landscapes: mod Non-cyclic landscape: clamp

Public procedure ConstrainCoordinates(var x, y: integer); overload;

This item has no description.

Public procedure DoCyclicBoundaries;

Enforces an identical height on the opposing edges of the landscape

Public procedure DoErosionByFraction;

Not yet implemented

Public procedure DoErosionByLife;

Just a smoothing. Should be done last as it improves the look of other erosion effects. Too much biological erosion can ruin erase their results though. Some tweaking may be needed

Public procedure DoErosionByRain;

Create sharp valleys and canyons. If DepositRate>0, it will also fill the low pools, producing flat "lakes" and "ponds". Drop some rain on every cell of the landscape and let it run downward, taking soil on its way. When it arrives into a pool, let it deposit all that has been eroded

Public procedure DoErosionBySea;

Create a beach and a cliff around the islands

Public procedure DoSea;

Cut all elevations lower than sea level. If Transparency>0, the sea surface will not be flat, but a slight elevation change (unperceptible in 3D view) allow to fake transparency in the OnDrawTexture.

Public procedure DoSteps;

Discretise the heigthfield in a chosen number of steps

Public procedure StartPreparingData(heightData: TGLHeightData); override;

tTerrainRender event handler

Private procedure SetHeight(x, y: integer; const Value: single);

This item has no description.

Private procedure SetKeepNormals(const Value: boolean);

This item has no description.

Properties

Published property Cyclic: boolean read FCyclic write SetCyclic;

This item has no description.

Public property Heights[x,y: integer]: single read GetHeight write SetHeight;

x and y are range-checked and constrained into the array. This slows down computation. If you don't need to range-check (this is mainly useful in cyclic landscapes when you need a seamless joint), call fHeigth instead (this is a protected field, therefore only accessible from TGLFractalHDS descendents.

Public property KeepNormals: boolean read FKeepNormals write SetKeepNormals;

Keep the array of normals for future use

Public property LandTileInfo: TLandTileInfo read GetLandTileInfo write SetLandTileInfo;

Property used by TGLTiledRndLandscape to know where the landtile is located and other parameters. See tLandTileInfo

Public property MaxHeight: single read FMaxHeight;

Store the minimum and maximum elevations

Public property MinHeight: single read FMinHeight;

This item has no description.

Public property RangeHeight: single read FRangeHeight;

Max height - min height

Public property Size: integer read FSize;

Size of the square height array. With the middle-point algorithm, it is always Size = 2ˆN+1. In a cyclic landscape, the last row and columns are identical to the first.

Public property Task: string read FTask;

When long computations are running, this property contains the operation beeing processed.

Public property TaskProgress: integer read FTaskProgress;

A value between 0 and 100 indicating the percentage of completion


GLSysHelp v.2.5: GLS.RandomHDS: Class TGLFractalHDS

Class TGLFractalHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TGLFractalHDS = class(TGLCustomRandomHDS)

Description

Random landscape based on the middle-point displacement algorithm

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLBaseRandomHDS
  • TGLCustomRandomHDS
  • TGLFractalHDS

Overview

Fields

Private | FAmplitude: integer;
Private | FDepth: integer;
Private | FRoughness: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildHeightField; overload; override;
Public | procedure BuildHeightField(const aDepth, aSeed, aAmplitude: integer); overload;
Private | procedure SetAmplitude(const Value: integer);
Private | procedure SetDepth(const Value: integer);
Private | procedure SetRoughness(const Value: single);

Properties

Published | property Amplitude: integer read fAmplitude write SetAmplitude;
Published | property Depth: integer read fDepth write SetDepth;
Published | property Roughness: single read fRoughness write SetRoughness;

Description

Fields

Private FAmplitude: integer;

This item has no description.

Private FDepth: integer;

This item has no description.

Private FRoughness: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildHeightField; overload; override;

This item has no description. Showing description inherited from TGLCustomRandomHDS.BuildHeightField.

Generate the heightfield array, based on the topographical properties

Public procedure BuildHeightField(const aDepth, aSeed, aAmplitude: integer); overload;

This item has no description.

Private procedure SetAmplitude(const Value: integer);

This item has no description.

Private procedure SetDepth(const Value: integer);

This item has no description.

Private procedure SetRoughness(const Value: single);

This item has no description.

Properties

Published property Amplitude: integer read fAmplitude write SetAmplitude;

Proportional to the difference between highest and lowest altitude.

Published property Depth: integer read fDepth write SetDepth;

Number of levels in the fractal process. Depth defines the size of the landscape: Size = 2ˆDepth+1 . Good results are got with Depth>=6. Above 10 the landscape takes a lot of time to be generated.

Published property Roughness: single read fRoughness write SetRoughness;

The lower this parameter, the smoother the landscape. Takes value between 0 and 1


GLSysHelp v.2.5: GLS.RandomHDS: Record TRelativeCoordinate

Record TRelativeCoordinate

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TRelativeCoordinate = record

Description

This item has no description.

Overview

Fields

Public | DX: integer
Public | DZ: integer

Description

Fields

Public DX: integer

This item has no description.

Public DZ: integer


GLSysHelp v.2.5: GLS.RandomHDS: Class TGLTiledRndLandscape

Class TGLTiledRndLandscape

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TGLTiledRndLandscape = class(TGLBaseRandomHDS)

Description

This item has no description. Showing description inherited from TGLBaseRandomHDS.

This class introduces all the basic properties of random landscape. No method implemented though. It is used as a descendant for - TGLCustomRandomLandscape: one tile landscape (cyclic or not) - TGLTiledRndLandscape: "infinite" landscapes (grids of TGLCustomRandomLandscape)

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLBaseRandomHDS
  • TGLTiledRndLandscape

Overview

Fields

Private | FLandTileComputing: boolean;
Private | FExtentX: integer;
Private | FExtentZ: integer;
Private | FExtentXhalf: integer;
Private | FExtentZhalf: integer;
Private | fLandTileSize: integer;
Private | FSingleConstrain: TSingleClamp;
Private | FIntegerConstrain: TIntegerClamp;
Private | FTerrainRenderer: TGLTerrainRenderer;
Private | FCamera: TGLCamera;
Private | fOnCreateLandTile: TOnCreateLandTile;
Private | fOnCreateDefaultTile: TStartPreparingDataEvent;
Private | FIsDefaultTile: TIsDefaultTile;
Private | FSeed: integer;
Private | fBaseSeed: integer;
Private | fComputedLandTile: TGLLandTile;
Private | FLandTileCapacity: integer;
Private | FGenerationRadius: integer;
Private | FLandTileDensity: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function LandtileCount: integer;
Public | function TileDistance(const x1, z1, x2, z2: integer): single;
Public | function TileDistanceSquared(const x1, z1, x2, z2: integer): integer;
Public | function XMoveBoundary: single;
Public | function ZMoveBoundary: single;
Private | function fDefaultIsDefaultTile(x, z: integer): boolean;
Private | function GetTask: string;
Private | function GetTaskProgress: integer;
Public | procedure ApplyLighting(var aLandTile: TGLLandTile);
Public | procedure ApplyTexture(var aLandTile: TGLLandTile);
Public | procedure ApplyTopography(var aLandTile: TGLLandTile);
Public | procedure CameraPosition(var TileX, TileZ: integer);
Public | procedure CleanUp;
Public | procedure ConstrainCoordinates(var x, z: single); overload;
Public | procedure ConstrainCoordinates(var x, z: integer); overload;
Public | procedure FindLandTile(const x, z: single; var TileX, TileZ: integer);
Public | procedure Initialize(const aX, aZ: single); virtual;
Public | procedure StartPreparingData(heightData: TGLHeightData); override;
Public | procedure Update;
Private | procedure fDefaultOnCreateDefaultTile(heightData: TGLHeightData);
Private | procedure SetCamera(const Value: TGLCamera);
Private | procedure SetExtentX(const Value: integer);
Private | procedure SetExtentZ(const Value: integer);
Private | procedure SetGenerationRadius(const Value: integer);
Private | procedure SetIsDefaultTile(const Value: TIsDefaultTile);
Private | procedure SetLandTileCapacity(const Value: integer);
Private | procedure SetLandTileDensity(const Value: single);
Private | procedure SetOnCreateDefaultTile(const Value: TStartPreparingDataEvent);
Private | procedure SetOnCreateLandTile(const Value: TOnCreateLandTile);
Private | procedure SetSeed(const Value: integer);

Properties

Published | property Camera: TGLCamera read FCamera write SetCamera;
Published | property Cyclic: boolean read FCyclic write SetCyclic;
Published | property ExtentX: integer read FExtentX write SetExtentX;
Published | property ExtentZ: integer read FExtentZ write SetExtentZ;
Published | property GenerationRadius: integer read FGenerationRadius write SetGenerationRadius;
Public | property IsDefaultTile: TIsDefaultTile read FIsDefaultTile write SetIsDefaultTile;
Published | property LandTileCapacity: integer read FLandTileCapacity write SetLandTileCapacity;
Published | property LandTileDensity: single read FLandTileDensity write SetLandTileDensity;
Public | property LandTileSize: integer read fLandTileSize;
Public | property MapUpdating: boolean read fMapUpdating;
Public | property OnCreateLandTile: TOnCreateLandTile read fOnCreateLandTile write SetOnCreateLandTile;
Published | property Seed: integer read FSeed write SetSeed;
Public | property Task: string read GetTask;
Public | property TaskProgress: integer read GetTaskProgress;
Published | property TerrainRenderer: TGLTerrainRenderer read FTerrainRenderer write SetTerrainRenderer;

Description

Fields

Private FLandTileComputing: boolean;

This item has no description.

Private FExtentX: integer;

Is a landtile being computed?

Private FExtentZ: integer;

This item has no description.

Private FExtentXhalf: integer;

This item has no description.

Private FExtentZhalf: integer;

This item has no description.

Private fLandTileSize: integer;

This item has no description.

Private FSingleConstrain: TSingleClamp;

This item has no description.

Private FIntegerConstrain: TIntegerClamp;

This item has no description.

Private FTerrainRenderer: TGLTerrainRenderer;

This item has no description.

Private FCamera: TGLCamera;

This item has no description.

Private fOnCreateLandTile: TOnCreateLandTile;

This item has no description.

Private fOnCreateDefaultTile: TStartPreparingDataEvent;

This item has no description.

Private FIsDefaultTile: TIsDefaultTile;

This item has no description.

Private FSeed: integer;

This item has no description.

Private fBaseSeed: integer;

This item has no description.

Private fComputedLandTile: TGLLandTile;

This item has no description.

Private FLandTileCapacity: integer;

This item has no description.

Private FGenerationRadius: integer;

This item has no description.

Private FLandTileDensity: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LandtileCount: integer;

Number of landtile in memory

Public function TileDistance(const x1, z1, x2, z2: integer): single;

Distance between two landtiles

Public function TileDistanceSquared(const x1, z1, x2, z2: integer): integer;

Square of distance between two landtiles. Use this function to compare two distances.

Public function XMoveBoundary: single;

Use these boundaries with non-cyclic landscapes to constrain camera movements.

Public function ZMoveBoundary: single;

This item has no description.

Private function fDefaultIsDefaultTile(x, z: integer): boolean;

This item has no description.

Private function GetTask: string;

This item has no description.

Private function GetTaskProgress: integer;

This item has no description.

Public procedure ApplyLighting(var aLandTile: TGLLandTile);

This item has no description.

Public procedure ApplyTexture(var aLandTile: TGLLandTile);

This item has no description.

Public procedure ApplyTopography(var aLandTile: TGLLandTile);

This item has no description.

Public procedure CameraPosition(var TileX, TileZ: integer);

This item has no description.

Public procedure CleanUp;

This item has no description.

Public procedure ConstrainCoordinates(var x, z: single); overload;

Constrain x,y to be in the boundaries of the height field array. This is done in two way depending on the kind of landscape: Cyclic landscapes: mod Non-cyclic landscape: clamp

Public procedure ConstrainCoordinates(var x, z: integer); overload;

This item has no description.

Public procedure FindLandTile(const x, z: single; var TileX, TileZ: integer);

Compute the landtile containing (x,z)

Public procedure Initialize(const aX, aZ: single); virtual;

Build the first landtile and position the camera. Must be called first.

Public procedure StartPreparingData(heightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Public procedure Update;

This procedure check which landtiles must be generated or destroyed as a function of camera position. This is let to the descendent classes.

Private procedure fDefaultOnCreateDefaultTile(heightData: TGLHeightData);

This item has no description.

Private procedure SetCamera(const Value: TGLCamera);

This item has no description.

Private procedure SetExtentX(const Value: integer);

This item has no description.

Private procedure SetExtentZ(const Value: integer);

This item has no description.

Private procedure SetGenerationRadius(const Value: integer);

This item has no description.

Private procedure SetIsDefaultTile(const Value: TIsDefaultTile);

This item has no description.

Private procedure SetLandTileCapacity(const Value: integer);

This item has no description.

Private procedure SetLandTileDensity(const Value: single);

This item has no description.

Private procedure SetOnCreateDefaultTile(const Value: TStartPreparingDataEvent);

This item has no description.

Private procedure SetOnCreateLandTile(const Value: TOnCreateLandTile);

This item has no description.

Private procedure SetSeed(const Value: integer);

This item has no description.

Properties

Published property Camera: TGLCamera read FCamera write SetCamera;

This item has no description.

Published property Cyclic: boolean read FCyclic write SetCyclic;

This item has no description.

Published property ExtentX: integer read FExtentX write SetExtentX;

Dimensions of the "infinite" landscape. Can be set very high. These parameters have neither memory nor speed consequence. They are mainly used to compute a unique seed for each landtile

Published property ExtentZ: integer read FExtentZ write SetExtentZ;

This item has no description.

Published property GenerationRadius: integer read FGenerationRadius write SetGenerationRadius;

Distance at which a new landtile begin to be built. Increasing this value allows for a higher camera speed but it will also increase the memory requirements.

Public property IsDefaultTile: TIsDefaultTile read FIsDefaultTile write SetIsDefaultTile;

User-supplied function determining if this landtile will be built by the OnCreateDefaultTile or if a landscape will be generated.

Published property LandTileCapacity: integer read FLandTileCapacity write SetLandTileCapacity;

Number of landtile to keep in memory. Should not be modified.

Published property LandTileDensity: single read FLandTileDensity write SetLandTileDensity;

Probability that a given landtile is non-default

Public property LandTileSize: integer read fLandTileSize;

Size of a landtile. Must be a power of two

Public property MapUpdating: boolean read fMapUpdating;

This item has no description.

Public property OnCreateLandTile: TOnCreateLandTile read fOnCreateLandTile write SetOnCreateLandTile;

User-specified event handler containing the particular code for tile generation

Published property Seed: integer read FSeed write SetSeed;

Base seed for the entire archipelago

Public property Task: string read GetTask;

When long computations are running, this property contains the operation beeing processed.

Public property TaskProgress: integer read GetTaskProgress;

A value between 0 and 100 indicating the percentage of completion

Published property TerrainRenderer: TGLTerrainRenderer read FTerrainRenderer write SetTerrainRenderer;

Terrain renderer linked to the HDS. Must be set just after creation.


GLSysHelp v.2.5: GLS.RandomHDS: Class TGLFractalArchipelago

Class TGLFractalArchipelago

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RandomHDS

Declaration

type TGLFractalArchipelago = class(TGLTiledRndLandscape)

Description

This item has no description. Showing description inherited from TGLBaseRandomHDS.

This class introduces all the basic properties of random landscape. No method implemented though. It is used as a descendant for - TGLCustomRandomLandscape: one tile landscape (cyclic or not) - TGLTiledRndLandscape: "infinite" landscapes (grids of TGLCustomRandomLandscape)

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLBaseRandomHDS
  • TGLTiledRndLandscape
  • TGLFractalArchipelago

Overview

Fields

Private | FDepth: integer;
Private | FRoughnessMax: single;
Private | FRoughnessMin: single;
Private | FAmplitudeMin: integer;
Private | FAmplitudeMax: integer;
Private | FSeaDynamic: boolean;
Private | FSeaMaterialName: string;
Private | FWaveAmplitude: single;
Private | FWaveSpeed: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetIslandDensity: single;
Public | procedure ComputeLandTile(const aX, aZ: integer; var NewLandTile: TGLLandTile); override;
Private | procedure FPostRenderSeaDynamic(var rci: TGLRenderContextInfo; var HeightDatas: TList);
Private | procedure FPostRenderSeaStatic(var rci: TGLRenderContextInfo; var HeightDatas: TList);
Private | procedure SetAmplitudeMax(const Value: integer);
Private | procedure SetAmplitudeMin(const Value: integer);
Private | procedure SetDepth(const Value: integer);
Private | procedure SetIslandDensity(const Value: single);
Private | procedure SetRoughnessMax(const Value: single);
Private | procedure SetRoughnessMin(const Value: single);
Private | procedure SetSeaDynamic(const Value: boolean);
Private | procedure SetSeaMaterialName(const Value: string);
Private | procedure SetWaveAmplitude(const Value: single);
Private | procedure SetWaveSpeed(const Value: single);

Properties

Published | property AmplitudeMax: integer read FAmplitudeMax write SetAmplitudeMax;
Published | property AmplitudeMin: integer read FAmplitudeMin write SetAmplitudeMin;
Published | property Depth: integer read fDepth write SetDepth;
Published | property IslandDensity: single read GetIslandDensity write SetIslandDensity;
Published | property RoughnessMax: single read FRoughnessMax write SetRoughnessMax;
Published | property RoughnessMin: single read FRoughnessMin write SetRoughnessMin;
Published | property SeaDynamic: boolean read FSeaDynamic write SetSeaDynamic;
Published | property SeaMaterialName: string read FSeaMaterialName write SetSeaMaterialName;
Published | property WaveAmplitude: single read FWaveAmplitude write SetWaveAmplitude;
Published | property WaveSpeed: single read FWaveSpeed write SetWaveSpeed;

Description

Fields

Private FDepth: integer;

This item has no description.

Private FRoughnessMax: single;

This item has no description.

Private FRoughnessMin: single;

This item has no description.

Private FAmplitudeMin: integer;

This item has no description.

Private FAmplitudeMax: integer;

This item has no description.

Private FSeaDynamic: boolean;

This item has no description.

Private FSeaMaterialName: string;

This item has no description.

Private FWaveAmplitude: single;

This item has no description.

Private FWaveSpeed: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetIslandDensity: single;

This item has no description.

Public procedure ComputeLandTile(const aX, aZ: integer; var NewLandTile: TGLLandTile); override;

This item has no description.

Private procedure FPostRenderSeaDynamic(var rci: TGLRenderContextInfo; var HeightDatas: TList);

Sea with waves. Borrowed from GLS Archipelago advanced demo

Private procedure FPostRenderSeaStatic(var rci: TGLRenderContextInfo; var HeightDatas: TList);

PostRender event handler drawing a static water plane between islands Code borrowed from Eric's Archipelago GLScene advanced demo

Private procedure SetAmplitudeMax(const Value: integer);

This item has no description.

Private procedure SetAmplitudeMin(const Value: integer);

This item has no description.

Private procedure SetDepth(const Value: integer);

This item has no description.

Private procedure SetIslandDensity(const Value: single);

This item has no description.

Private procedure SetRoughnessMax(const Value: single);

This item has no description.

Private procedure SetRoughnessMin(const Value: single);

This item has no description.

Private procedure SetSeaDynamic(const Value: boolean);

This item has no description.

Private procedure SetSeaMaterialName(const Value: string);

This item has no description.

Private procedure SetWaveAmplitude(const Value: single);

This item has no description.

Private procedure SetWaveSpeed(const Value: single);

This item has no description.

Properties

Published property AmplitudeMax: integer read FAmplitudeMax write SetAmplitudeMax;

Ranges for the amplitude parameter in the fractal algorithm

Published property AmplitudeMin: integer read FAmplitudeMin write SetAmplitudeMin;

This item has no description.

Published property Depth: integer read fDepth write SetDepth;

Depth of the fractal algorithm

Published property IslandDensity: single read GetIslandDensity write SetIslandDensity;

A wrapper for LandtileDensity. This is the probabilty for a landtile to contain an island.

Published property RoughnessMax: single read FRoughnessMax write SetRoughnessMax;

Ranges for the roughness parameter in the fractal algorithm

Published property RoughnessMin: single read FRoughnessMin write SetRoughnessMin;

This item has no description.

Published property SeaDynamic: boolean read FSeaDynamic write SetSeaDynamic;

If true, the sea will show dynamic waves. Slow.

Published property SeaMaterialName: string read FSeaMaterialName write SetSeaMaterialName;

Reference to a material in the TerrainRenderer's material library. This material will be used to drape the water plane.

Published property WaveAmplitude: single read FWaveAmplitude write SetWaveAmplitude;

Size of the waves

Published property WaveSpeed: single read FWaveSpeed write SetWaveSpeed;


GLSysHelp v.2.5: GLS.RenderContextInfo

Unit GLS.RenderContextInfo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLS.PersistentClasses
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.State
  • GLScene.PipelineTransform
  • GLS.Color

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLSize |
Record TGLRenderContextClippingInfo |
Record TGLRenderContextInfo |

Types

PGLRenderContextInfo = ˆTGLRenderContextInfo;
TGLDrawState = (...);
TGLObjectsSorting = (...);
TGLVisibilityCulling = (...);

Description

Types

PGLRenderContextInfo = ˆTGLRenderContextInfo;

This item has no description.

TGLDrawState = (...);

This item has no description.

Values
  • dsRendering
  • dsPicking
  • dsPrinting
TGLObjectsSorting = (...);

Determines if objects are sorted, and how. Sorting is done level by level (and not for all entities), values are : osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst osNone : do not sort objects. osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. osRenderNearestFirst : render objects whose Position is the nearest to the camera first.

Values
  • osInherited
  • osNone
  • osRenderFarthestFirst
  • osRenderBlendedLast
  • osRenderNearestFirst
TGLVisibilityCulling = (...);

Determines the visibility culling mode. Culling is done level by level, allowed values are: vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone vcNone : no visibility culling is performed vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).

Values
  • vcInherited
  • vcNone
  • vcObjectBased
  • vcHierarchical


GLSysHelp v.2.5: GLS.RenderContextInfo: Record TGLSize

Record TGLSize

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RenderContextInfo

Declaration

type TGLSize = record

Description

This item has no description.

Overview

Fields

Public | cx: Longint;
Public | cy: Longint;

Description

Fields

Public cx: Longint;

This item has no description.

Public cy: Longint;


GLSysHelp v.2.5: GLS.RenderContextInfo: Record TGLRenderContextClippingInfo

Record TGLRenderContextClippingInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RenderContextInfo

Declaration

type TGLRenderContextClippingInfo = record

Description

This item has no description.

Overview

Fields

Public | Origin: TGLVector;
Public | ClippingDirection: TGLVector;
Public | ViewPortRadius: Single;
Public | NearClippingDistance: Single;
Public | FarClippingDistance: Single;
Public | Frustum: TFrustum;

Description

Fields

Public Origin: TGLVector;

This item has no description.

Public ClippingDirection: TGLVector;

This item has no description.

Public ViewPortRadius: Single;

This item has no description.

Public NearClippingDistance: Single;

viewport bounding radius per distance unit

Public FarClippingDistance: Single;

This item has no description.

Public Frustum: TFrustum;


GLSysHelp v.2.5: GLS.RenderContextInfo: Record TGLRenderContextInfo

Record TGLRenderContextInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.RenderContextInfo

Declaration

type TGLRenderContextInfo = record

Description

Stores contextual info useful during rendering methods.

Overview

Fields

Public | Scene: TObject;
Public | Buffer: TObject;
Public | CameraPosition: TGLVector;
Public | CameraDirection: TGLVector;
Public | CameraUp: TGLVector;
Public | ViewPortSize: TGLSize;
Public | RenderDPI: Integer;
Public | MaterialLibrary: TObject;
Public | LightMapLibrary: TObject;
Public | FogDisabledCounter: Integer;
Public | DrawState: TGLDrawState;
Public | ObjectsSorting: TGLObjectsSorting;
Public | VisibilityCulling: TGLVisibilityCulling;
Public | GLStates: TGLStateCache;
Public | PipelineTransformation: TGTransformation;
Public | Rcci: TGLRenderContextClippingInfo;
Public | SceneAmbientColor: TGLColorVector;
Public | BufferFaceCull: Boolean;
Public | BufferLighting: Boolean;
Public | BufferFog: Boolean;
Public | BufferDepthTest: Boolean;
Public | ProxySubObject: Boolean;
Public | IgnoreMaterials: Boolean;
Public | IgnoreBlendingRequests: Boolean;
Public | IgnoreDepthRequests: Boolean;
Public | Amalgamating: Boolean;
Public | Lights: TGLPersistentObjectList;
Public | AfterRenderEffects: TGLPersistentObjectList;
Public | CurrentMaterialLevel: TGLMaterialLevel;
Public | PrimitiveMask: TGLMeshPrimitives;
Public | OrderCounter: Integer;

Description

Fields

Public Scene: TObject;

This item has no description.

Public Buffer: TObject;

usually TGLScene

Public CameraPosition: TGLVector;

usually TGLSceneBuffer

Public CameraDirection: TGLVector;

This item has no description.

Public CameraUp: TGLVector;

This item has no description.

Public ViewPortSize: TGLSize;

This item has no description.

Public RenderDPI: Integer;

This item has no description.

Public MaterialLibrary: TObject;

This item has no description.

Public LightMapLibrary: TObject;

usually TGLMaterialLibrary;

Public FogDisabledCounter: Integer;

usually TGLMaterialLibrary;

Public DrawState: TGLDrawState;

This item has no description.

Public ObjectsSorting: TGLObjectsSorting;

This item has no description.

Public VisibilityCulling: TGLVisibilityCulling;

This item has no description.

Public GLStates: TGLStateCache;

This item has no description.

Public PipelineTransformation: TGTransformation;

This item has no description.

Public Rcci: TGLRenderContextClippingInfo;

This item has no description.

Public SceneAmbientColor: TGLColorVector;

This item has no description.

Public BufferFaceCull: Boolean;

This item has no description.

Public BufferLighting: Boolean;

This item has no description.

Public BufferFog: Boolean;

This item has no description.

Public BufferDepthTest: Boolean;

This item has no description.

Public ProxySubObject: Boolean;

This item has no description.

Public IgnoreMaterials: Boolean;

This item has no description.

Public IgnoreBlendingRequests: Boolean;

This item has no description.

Public IgnoreDepthRequests: Boolean;

This item has no description.

Public Amalgamating: Boolean;

This item has no description.

Public Lights: TGLPersistentObjectList;

This item has no description.

Public AfterRenderEffects: TGLPersistentObjectList;

This item has no description.

Public CurrentMaterialLevel: TGLMaterialLevel;

This item has no description.

Public PrimitiveMask: TGLMeshPrimitives;

This item has no description.

Public OrderCounter: Integer;


GLSysHelp v.2.5: GLS.ROAMPatch

Unit GLS.ROAMPatch

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.XOpenGL
  • GLScene.VectorGeometry
  • GLS.HeightData
  • GLS.VectorLists
  • GLS.Context
  • GLScene.VectorTypes
  • GLS.Isolines
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLROAMException |
Packed Record TROAMTriangleNode |
Packed Record TROAMRenderPoint |
Class TGLROAMPatch |

Functions and Procedures

procedure SetROAMTrianglesCapacity(nb: Integer);
function GetROAMTrianglesCapacity: Integer;
procedure DrawContours(Vertices: TGLAffineVectorList; VertexIndices: TGLIntegerList; ContourInterval: Integer; ContourWidth: Integer; DecVal: Integer);

Types

PROAMTriangleNode = ˆTROAMTriangleNode;

Description

Functions and Procedures

procedure SetROAMTrianglesCapacity(nb: Integer);

Specifies the maximum number of ROAM triangles that may be allocated.

function GetROAMTrianglesCapacity: Integer;

This item has no description.

procedure DrawContours(Vertices: TGLAffineVectorList; VertexIndices: TGLIntegerList; ContourInterval: Integer; ContourWidth: Integer; DecVal: Integer);

Draw contours on rendering terrain patches

Types

PROAMTriangleNode = ˆTROAMTriangleNode;


GLSysHelp v.2.5: GLS.ROAMPatch: Class EGLROAMException

Class EGLROAMException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ROAMPatch

Declaration

type EGLROAMException = class(Exception)

Description

Exception use by splitter for SafeTesselation

Hierarchy

  • TObject
  • Exception
  • EGLROAMException


GLSysHelp v.2.5: GLS.ROAMPatch: Packed Record TROAMTriangleNode

Packed Record TROAMTriangleNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ROAMPatch

Declaration

type TROAMTriangleNode = packed record

Description

This item has no description.

Overview

Fields

Public | Base: PROAMTriangleNode;
Public | Left: PROAMTriangleNode;
Public | Right: PROAMTriangleNode;
Public | LeftChild: PROAMTriangleNode;
Public | RightChild: PROAMTriangleNode;

Description

Fields

Public Base: PROAMTriangleNode;

This item has no description.

Public Left: PROAMTriangleNode;

This item has no description.

Public Right: PROAMTriangleNode;

This item has no description.

Public LeftChild: PROAMTriangleNode;

This item has no description.

Public RightChild: PROAMTriangleNode;


GLSysHelp v.2.5: GLS.ROAMPatch: Packed Record TROAMRenderPoint

Packed Record TROAMRenderPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ROAMPatch

Declaration

type TROAMRenderPoint = packed record

Description

This item has no description.

Overview

Fields

Public | X: Integer;
Public | Y: Integer;
Public | Idx: Integer;

Description

Fields

Public X: Integer;

This item has no description.

Public Y: Integer;

This item has no description.

Public Idx: Integer;


GLSysHelp v.2.5: GLS.ROAMPatch: Class TGLROAMPatch

Class TGLROAMPatch

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ROAMPatch

Declaration

type TGLROAMPatch = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLROAMPatch

Overview

Fields

Private | FID: Integer;
Private | FHeightData: TGLHeightData;
Private | FHeightRaster: PSmallIntRaster;
Private | FTLNode: PROAMTriangleNode;
Private | FBRNode: PROAMTriangleNode;
Private | FTLVariance: array of cardinal;
Private | FBRVariance: array of cardinal;
Private | FPatchSize: Integer;
Private | FTriangleCount: Integer;
Private | FListHandle: TGLListHandle;
Private | FTag: Integer;
Private | FObserverPosition: TAffineVector;
Private | FNorth: TGLROAMPatch;
Private | FSouth: TGLROAMPatch;
Private | FWest: TGLROAMPatch;
Private | FEast: TGLROAMPatch;
Private | FHighRes: Boolean;
Private | FMaxDepth: Integer;
Private | FVertexScale: TAffineVector;
Private | FVertexOffset: TAffineVector;
Private | FTextureScale: TAffineVector;
Private | FTextureOffset: TAffineVector;
Private | FMaxTLVarianceDepth: Integer;
Private | FMaxBRVarianceDepth: Integer;
Private | FOcclusionQuery: TGLOcclusionQueryHandle;
Private | FOcclusionSkip: Integer;
Private | FOcclusionCounter: Integer;
Private | FLastOcclusionTestPassed: Boolean;
Private | FContourInterval: Integer;
Private | FContourWidth: Integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function SafeTesselate: Boolean;
Public | function Tesselate: Boolean;
Public | procedure ComputeVariance(Variance: Integer);
Public | procedure ConnectToTheNorth(NorthPatch: TGLROAMPatch);
Public | procedure ConnectToTheWest(WestPatch: TGLROAMPatch);
Public | class procedure FlushAccum(Vertices: TGLAffineVectorList; VertexIndices: TGLIntegerList; TexCoords: TGLTexPointList);
Public | procedure RenderAccum(Vertices: TGLAffineVectorList; VertexIndices: TGLIntegerList; TexCoords: TGLTexPointList; AutoFlushVertexCount: Integer);
Public | procedure RenderHighRes(Vertices: TGLAffineVectorList; VertexIndices: TGLIntegerList; TexCoords: TGLTexPointList; ForceROAM: Boolean);
Public | procedure ResetTessellation;

Properties

Public | property ContourInterval: Integer read FContourInterval write FContourInterval default 0;
Public | property ContourWidth: Integer read FContourWidth write FContourWidth default 1;
Public | property HeightData: TGLHeightData read FHeightData write SetHeightData;
Public | property HighRes: Boolean read FHighRes write FHighRes;
Public | property ID: Integer read FID;
Public | property LastOcclusionTestPassed: Boolean read FLastOcclusionTestPassed;
Public | property ObserverPosition: TAffineVector read FObserverPosition write FObserverPosition;
Public | property OcclusionCounter: Integer read FOcclusionCounter write FOcclusionCounter;
Public | property OcclusionSkip: Integer read FOcclusionSkip write SetOcclusionSkip;
Public | property Tag: Integer read FTag write FTag;
Public | property TextureOffset: TAffineVector read FTextureOffset write FTextureOffset;
Public | property TextureScale: TAffineVector read FTextureScale write FTextureScale;
Public | property TriangleCount: Integer read FTriangleCount;
Public | property VertexOffset: TAffineVector read FVertexOffset write FVertexOffset;
Public | property VertexScale: TAffineVector read FVertexScale write FVertexScale;

Description

Fields

Private FID: Integer;

This item has no description.

Private FHeightData: TGLHeightData;

This item has no description.

Private FHeightRaster: PSmallIntRaster;

Referred, not owned

Private FTLNode: PROAMTriangleNode;

This item has no description.

Private FBRNode: PROAMTriangleNode;

This item has no description.

Private FTLVariance: array of cardinal;

This item has no description.

Private FBRVariance: array of cardinal;

This item has no description.

Private FPatchSize: Integer;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FListHandle: TGLListHandle;

This item has no description.

Private FTag: Integer;

This item has no description.

Private FObserverPosition: TAffineVector;

This item has no description.

Private FNorth: TGLROAMPatch;

This item has no description.

Private FSouth: TGLROAMPatch;

This item has no description.

Private FWest: TGLROAMPatch;

This item has no description.

Private FEast: TGLROAMPatch;

This item has no description.

Private FHighRes: Boolean;

neighbours

Private FMaxDepth: Integer;

This item has no description.

Private FVertexScale: TAffineVector;

This item has no description.

Private FVertexOffset: TAffineVector;

This item has no description.

Private FTextureScale: TAffineVector;

This item has no description.

Private FTextureOffset: TAffineVector;

This item has no description.

Private FMaxTLVarianceDepth: Integer;

This item has no description.

Private FMaxBRVarianceDepth: Integer;

This item has no description.

Private FOcclusionQuery: TGLOcclusionQueryHandle;

This item has no description.

Private FOcclusionSkip: Integer;

This item has no description.

Private FOcclusionCounter: Integer;

This item has no description.

Private FLastOcclusionTestPassed: Boolean;

This item has no description.

Private FContourInterval: Integer;

This item has no description.

Private FContourWidth: Integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function SafeTesselate: Boolean;

AV free version of Tesselate. When IncreaseTrianglesCapacity is called, all PROAMTriangleNode values in higher function became invalid due to the memory shifting. Recursivity is the main problem, that's why SafeTesselate is calling Tesselate in a try..except .

Public function Tesselate: Boolean;

Returns false if MaxCLODTriangles limit is reached

Public procedure ComputeVariance(Variance: Integer);

This item has no description.

Public procedure ConnectToTheNorth(NorthPatch: TGLROAMPatch);

This item has no description.

Public procedure ConnectToTheWest(WestPatch: TGLROAMPatch);

This item has no description.

Public class procedure FlushAccum(Vertices: TGLAffineVectorList; VertexIndices: TGLIntegerList; TexCoords: TGLTexPointList);

Render all vertices accumulated in the arrays and set their count back to zero.

Public procedure RenderAccum(Vertices: TGLAffineVectorList; VertexIndices: TGLIntegerList; TexCoords: TGLTexPointList; AutoFlushVertexCount: Integer);

Render the patch by accumulating triangles. The lists are assumed to have enough capacity to allow AddNC calls (additions without capacity check). Once at least autoFlushVertexCount vertices have been accumulated, perform a FlushAccum

Public procedure RenderHighRes(Vertices: TGLAffineVectorList; VertexIndices: TGLIntegerList; TexCoords: TGLTexPointList; ForceROAM: Boolean);

Render the patch in high-resolution. The lists are assumed to have enough capacity to allow AddNC calls (additions without capacity check). High-resolution renders use display lists, and are assumed to be made together.

Public procedure ResetTessellation;

This item has no description.

Properties

Public property ContourInterval: Integer read FContourInterval write FContourInterval default 0;

Distance between contours - zero (default) for no contours

Public property ContourWidth: Integer read FContourWidth write FContourWidth default 1;

Width of contours

Public property HeightData: TGLHeightData read FHeightData write SetHeightData;

This item has no description.

Public property HighRes: Boolean read FHighRes write FHighRes;

This item has no description.

Public property ID: Integer read FID;

This item has no description.

Public property LastOcclusionTestPassed: Boolean read FLastOcclusionTestPassed;

Result for the last occlusion test. Note that this value is updated upon rendering the tile in non-high-res mode only.

Public property ObserverPosition: TAffineVector read FObserverPosition write FObserverPosition;

This item has no description.

Public property OcclusionCounter: Integer read FOcclusionCounter write FOcclusionCounter;

Number of frames remaining to next occlusion test.

Public property OcclusionSkip: Integer read FOcclusionSkip write SetOcclusionSkip;

Number of frames to skip after an occlusion test returned zero pixels.

Public property Tag: Integer read FTag write FTag;

This item has no description.

Public property TextureOffset: TAffineVector read FTextureOffset write FTextureOffset;

This item has no description.

Public property TextureScale: TAffineVector read FTextureScale write FTextureScale;

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

This item has no description.

Public property VertexOffset: TAffineVector read FVertexOffset write FVertexOffset;

This item has no description.

Public property VertexScale: TAffineVector read FVertexScale write FVertexScale;


GLSysHelp v.2.5: GLS.Scene

Unit GLS.Scene

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • System.Math
  • Vcl.Graphics
  • Vcl.Controls
  • GLScene.OpenGLTokens
  • GLS.XOpenGL
  • GLScene.XCollection
  • GLScene.Strings
  • GLS.Context
  • GLScene.VectorGeometry
  • GLS.Silhouette
  • GLS.PersistentClasses
  • GLScene.PipelineTransform
  • GLS.State
  • GLS.Graphics
  • GLScene.GeometryBB
  • GLS.VectorLists
  • GLS.Texture
  • GLS.Color
  • GLS.BaseClasses
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLS.Material
  • GLScene.TextureFormat
  • GLS.Selection
  • GLScene.VectorTypes
  • GLS.ApplicationFileIO
  • GLScene.Utils
  • GLS.ImageUtils
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IGLInitializable |
Class TGLInitializableObjectList |
Class TGLBaseSceneObject |
Class TGLBaseBehaviour |
Class TGLBehaviour |
Class TGLBehaviours |
Class TGLEffect |
Class TGLObjectPreEffect |
Class TGLObjectPostEffect |
Class TGLObjectAfterEffect |
Class TGLEffects |
Class TGLCustomSceneObject |
Class TGLSceneRootObject |
Class TGLImmaterialSceneObject |
Class TGLCameraInvariantObject |
Class TGLSceneObject |
Class TGLDirectOpenGL |
Class TGLRenderPoint |
Class TGLProxyObject |
Class TGLLightSource |
Class TGLCamera |
Class TGLScene |
Class TGLFogEnvironment |
Class TGLSceneBuffer |
Class TGLNonVisualViewer |
Class TGLMemoryViewer |

Functions and Procedures

procedure RegisterGLBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterGLBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);
procedure RegisterGLBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterGLBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);
procedure AxesBuildList(var rci: TGLRenderContextInfo; pattern: Word; AxisLen: Single);
procedure RegisterInfoForm(infoForm: TInvokeInfoForm);
procedure InvokeInfoForm(aSceneBuffer: TGLSceneBuffer; Modal: boolean);
function GetCurrentRenderingObject: TGLBaseSceneObject;

Types

TFogDistance = (...);
TFogMode = (...);
TGLBehaviourClass = class of TGLBehaviour;
TGLCameraInvarianceMode = (...);
TGLCameraKeepFOVMode = (...);
TGLCameraStyle = (...);
TGLColorDepth = (...);
TGLContextOption = (...);
TGLContextOptions = set of TGLContextOption;
TGLDepthPrecision = (...);
TGLDirectRenderEvent = procedure(Sender: TObject; var rci: TGLRenderContextInfo) of object;
TGLEffectClass = class of TGLEffect;
TGLLightStyle = (...);
TGLLimitType = (...);
TGLNormalDirection = (...);
TGLObjectBBChange = (...);
TGLObjectBBChanges = set of TGLObjectBBChange;
TGLObjectChange = (...);
TGLObjectChanges = set of TGLObjectChange;
TGLObjectStyle = (...);
TGLObjectStyles = set of TGLObjectStyle;
TGLProxyObjectClass = class of TGLProxyObject;
TGLProxyObjectOption = (...);
TGLProxyObjectOptions = set of TGLProxyObjectOption;
TGLSceneObjectClass = class of TGLBaseSceneObject;
TGLSceneOperation = (...);
TGLSceneViewerMode = (...);
TGLShadeModel = (...);
TInvokeInfoForm = procedure(aSceneBuffer: TGLSceneBuffer; Modal: boolean);
TOnCustomPerspective = procedure(const viewport: TRectangle; width, height: Integer; DPI: Integer; var viewPortRadius: Single) of object;

Constants

cDefaultProxyOptions = [pooEffects, pooObjects, pooTransformation];
GLSCENE_REVISION = '$Revision: 2024$';
GLSCENE_VERSION = 'v2.5 %s';

Variables

vCounterFrequency: Int64;
vCurrentRenderingObject: TGLBaseSceneObject;

Description

Functions and Procedures

procedure RegisterGLBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);

Register an event handler triggered by any TGLBaseSceneObject Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by GLSceneEdit in the IDE.

procedure DeRegisterGLBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);

Deregister an event handler triggered by any TGLBaseSceneObject Name change. See RegisterGLBaseSceneObjectNameChangeEvent.

procedure RegisterGLBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);

Register an event handler triggered by any TGLBehaviour Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.

procedure DeRegisterGLBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);

Deregister an event handler triggered by any TGLBaseSceneObject Name change. See RegisterGLBaseSceneObjectNameChangeEvent.

procedure AxesBuildList(var rci: TGLRenderContextInfo; pattern: Word; AxisLen: Single);

Issues OpenGL calls for drawing X, Y, Z axes in a standard style.

procedure RegisterInfoForm(infoForm: TInvokeInfoForm);

Registers the procedure call used to invoke the info form.

procedure InvokeInfoForm(aSceneBuffer: TGLSceneBuffer; Modal: boolean);

This item has no description.

function GetCurrentRenderingObject: TGLBaseSceneObject;

This item has no description.

Types

TFogDistance = (...);

Fog distance calculation mode. fdDefault: let OpenGL use its default formula fdEyeRadial: uses radial "true" distance (best quality) fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.

Values
  • fdDefault
  • fdEyeRadial
  • fdEyePlane
TFogMode = (...);

This item has no description.

Values
  • fmLinear
  • fmExp
  • fmExp2
TGLBehaviourClass = class of TGLBehaviour;

This item has no description.

TGLCameraInvarianceMode = (...);

This item has no description.

Values
  • cimNone
  • cimPosition
  • cimOrientation
TGLCameraKeepFOVMode = (...);

This item has no description.

Values
  • ckmHorizontalFOV
  • ckmVerticalFOV
TGLCameraStyle = (...);

This item has no description.

Values
  • csPerspective
  • csOrthogonal
  • csOrtho2D
  • csCustom
  • csInfinitePerspective
  • csPerspectiveKeepFOV
TGLColorDepth = (...);

This item has no description.

Values
  • cdDefault
  • cd8bits
  • cd16bits
  • cd24bits
  • cdFloat64bits
  • cdFloat128bits
TGLContextOption = (...);

Options for the rendering context. roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering. roRenderToWindows: ignored (legacy). roTwoSideLighting: enables two-side lighting model. roStereo: enables stereo support in the driver (need to test with a stereo device...) roDestinationAlpha: request an Alpha channel for the rendered output roNoColorBuffer: don't request a color buffer (color depth setting ignored) roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling. roForwardContext: force OpenGL forward context

Values
  • roSoftwareMode
  • roDoubleBuffer
  • roStencilBuffer
  • roRenderToWindow
  • roTwoSideLighting
  • roStereo
  • roDestinationAlpha
  • roNoColorBuffer
  • roNoColorBufferClear
  • roNoSwapBuffers
  • roNoDepthBufferClear
  • roDebugContext
  • roForwardContext
  • roOpenGL_ES2_Context
TGLContextOptions = set of TGLContextOption;

This item has no description.

TGLDepthPrecision = (...);

This item has no description.

Values
  • dpDefault
  • dp16bits
  • dp24bits
  • dp32bits
TGLDirectRenderEvent = procedure(Sender: TObject; var rci: TGLRenderContextInfo) of object;

Event for user-specific rendering in a TGLDirectOpenGL object.

TGLEffectClass = class of TGLEffect;

This item has no description.

TGLLightStyle = (...);

Defines the various styles for lightsources. lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering)

Values
  • lsSpot
  • lsOmni
  • lsParallel
  • lsParallelSpot
TGLLimitType = (...);

IDs for limit determination

Values
  • limClipPlanes
  • limEvalOrder
  • limLights
  • limListNesting
  • limModelViewStack
  • limNameStack
  • limPixelMapTable
  • limProjectionStack
  • limTextureSize
  • limTextureStack
  • limViewportDims
  • limAccumAlphaBits
  • limAccumBlueBits
  • limAccumGreenBits
  • limAccumRedBits
  • limAlphaBits
  • limAuxBuffers
  • limBlueBits
  • limGreenBits
  • limRedBits
  • limIndexBits
  • limStereo
  • limDoubleBuffer
  • limSubpixelBits
  • limDepthBits
  • limStencilBits
  • limNbTextureUnits
TGLNormalDirection = (...);

This item has no description.

Values
  • ndInside
  • ndOutside
TGLObjectBBChange = (...);

This item has no description.

Values
  • oBBcChild
  • oBBcStructure
TGLObjectBBChanges = set of TGLObjectBBChange;

This item has no description.

TGLObjectChange = (...);

Used to describe the changes in an object, which have to be reflected in the scene

Values
  • ocTransformation
  • ocAbsoluteMatrix
  • ocInvAbsoluteMatrix
  • ocStructure
TGLObjectChanges = set of TGLObjectChange;

This item has no description.

TGLObjectStyle = (...);

Possible styles/options for a GLScene object. Allowed styles are: osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered

Values
  • osDirectDraw
  • osIgnoreDepthBuffer
  • osNoVisibilityCulling
TGLObjectStyles = set of TGLObjectStyle;

This item has no description.

TGLProxyObjectClass = class of TGLProxyObject;

This item has no description.

TGLProxyObjectOption = (...);

Defines which features are taken from the master object.

Values
  • pooEffects
  • pooObjects
  • pooTransformation
TGLProxyObjectOptions = set of TGLProxyObjectOption;

This item has no description.

TGLSceneObjectClass = class of TGLBaseSceneObject;

This item has no description.

TGLSceneOperation = (...);

Flags for design notification

Values
  • soAdd
  • soRemove
  • soMove
  • soRename
  • soSelect
  • soBeginUpdate
  • soEndUpdate
TGLSceneViewerMode = (...);

This item has no description.

Values
  • svmDisabled
  • svmDefault
  • svmNavigation
  • svmGizmo
TGLShadeModel = (...);

This item has no description.

Values
  • smDefault
  • smSmooth
  • smFlat
TInvokeInfoForm = procedure(aSceneBuffer: TGLSceneBuffer; Modal: boolean);

This item has no description.

TOnCustomPerspective = procedure(const viewport: TRectangle; width, height: Integer; DPI: Integer; var viewPortRadius: Single) of object;

This item has no description.

Constants

cDefaultProxyOptions = [pooEffects, pooObjects, pooTransformation];

This item has no description.

GLSCENE_REVISION = '$Revision: 2024$';

This item has no description.

GLSCENE_VERSION = 'v2.5 %s';

This item has no description.

Variables

vCounterFrequency: Int64;

This item has no description.

vCurrentRenderingObject: TGLBaseSceneObject;


GLSysHelp v.2.5: GLS.Scene: Interface IGLInitializable

Interface IGLInitializable

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type IGLInitializable = interface(IInterface)

Description

Interface to objects that need initialization

Attributes
GUID['{EA40AE8E-79B3-42F5-ADF1-7A901B665E12}']

Hierarchy

  • IInterface
  • IGLInitializable

Overview

Methods

Public procedure InitializeObject(ASender: TObject; const ARci: TGLRenderContextInfo);

Description

Methods

Public procedure InitializeObject(ASender: TObject; const ARci: TGLRenderContextInfo);


GLSysHelp v.2.5: GLS.Scene: Class TGLInitializableObjectList

Class TGLInitializableObjectList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLInitializableObjectList = class(TList)

Description

Just a list of objects that support IGLInitializable.

Hierarchy

  • TObject
  • TList
  • TGLInitializableObjectList

Overview

Methods

Public | function Add(const Item: IGLInitializable): Integer;
Private | function GetItems(const Index: Integer): IGLInitializable;
Private | procedure PutItems(const Index: Integer; const Value: IGLInitializable);

Properties

Public property Items[const Index: Integer]: IGLInitializable read GetItems write PutItems;

Description

Methods

Public function Add(const Item: IGLInitializable): Integer;

This item has no description.

Private function GetItems(const Index: Integer): IGLInitializable;

This item has no description.

Private procedure PutItems(const Index: Integer; const Value: IGLInitializable);

This item has no description.

Properties

Public property Items[const Index: Integer]: IGLInitializable read GetItems write PutItems;


GLSysHelp v.2.5: GLS.Scene: Class TGLBaseSceneObject

Class TGLBaseSceneObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLBaseSceneObject = class(TGLCoordinatesUpdateAbleComponent)

Description

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject

Overview

Fields

Private | FAbsoluteMatrix: TGLMatrix;
Private | FInvAbsoluteMatrix: TGLMatrix;
Private | FLocalMatrix: TGLMatrix;
Private | FObjectStyle: TGLObjectStyles;
Private | FListHandle: TGLListHandle;
Private | FPosition: TGLCoordinates;
Private | FDirection: TGLCoordinates;
Private | FUp: TGLCoordinates;
Private | FScaling: TGLCoordinates;
Private | FChanges: TGLObjectChanges;
Private | FParent: TGLBaseSceneObject;
Private | FScene: TGLScene;
Private | FBBChanges: TGLObjectBBChanges;
Private | FBoundingBoxPersonalUnscaled: THmgBoundingBox;
Private | FBoundingBoxOfChildren: THmgBoundingBox;
Private | FBoundingBoxIncludingChildren: THmgBoundingBox;
Private | FChildren: TGLPersistentObjectList;
Private | FVisible: Boolean;
Private | FUpdateCount: Integer;
Private | FShowAxes: Boolean;
Private | FRotation: TGLCoordinates;
Private | FIsCalculating: Boolean;
Private | FObjectsSorting: TGLObjectsSorting;
Private | FVisibilityCulling: TGLVisibilityCulling;
Private | FOnProgress: TGLProgressEvent;
Private | FOnAddedToParent: TNotifyEvent;
Private | FBehaviours: TGLBehaviours;
Private | FEffects: TGLEffects;
Private | FPickable: Boolean;
Private | FOnPicked: TNotifyEvent;
Private | FTagObject: TObject;
Private | FTagFloat: Single;
Private | objList: TGLPersistentObjectList;
Private | distList: TGLSingleList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | constructor CreateAsChild(aParentOwner: TGLBaseSceneObject);
Public | destructor Destroy; override;
Public | function AbsoluteLeft: TGLVector;
Public | function AbsoluteMatrixAsAddress: PGLMatrix;
Public | function AbsolutePositionAsAddress: PGLVector;
Public | function AbsoluteRight: TGLVector;
Public | function AbsoluteToLocal(const v: TGLVector): TGLVector; overload;
Public | function AbsoluteToLocal(const v: TAffineVector): TAffineVector; overload;
Public | function AbsoluteXVector: TGLVector;
Public | function AbsoluteYVector: TGLVector;
Public | function AbsoluteZVector: TGLVector;
Public | function AddNewBehaviour(aBehaviour: TGLBehaviourClass): TGLBehaviour;
Public | function AddNewChild(aChild: TGLSceneObjectClass): TGLBaseSceneObject; virtual;
Public | function AddNewChildFirst(aChild: TGLSceneObjectClass): TGLBaseSceneObject; virtual;
Public | function AddNewEffect(aEffect: TGLEffectClass): TGLEffect;
Public | function AffineLeftVector: TAffineVector; inline;
Public | function AffineRight: TAffineVector; inline;
Public | function AxisAlignedBoundingBox(const AIncludeChilden: Boolean = True): TAABB;
Public | function AxisAlignedBoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): TAABB;
Public | function AxisAlignedBoundingBoxAbsoluteEx: TAABB;
Public | function AxisAlignedBoundingBoxEx: TAABB;
Public | function AxisAlignedBoundingBoxUnscaled(const AIncludeChilden: Boolean = True): TAABB;
Public | function AxisAlignedDimensions: TGLVector; virtual;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; virtual;
Public | function BarycenterAbsolutePosition: TGLVector; virtual;
Public | function BarycenterSqrDistanceTo(const pt: TGLVector): Single;
Public | function BoundingBox(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingBoxIncludingChildrenEx: THmgBoundingBox;
Public | function BoundingBoxOfChildrenEx: THmgBoundingBox;
Public | function BoundingBoxPersonalUnscaledEx: THmgBoundingBox;
Public | function BoundingBoxUnscaled(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingSphereRadius: Single; inline;
Public | function BoundingSphereRadiusUnscaled: Single; inline;
Public | function DistanceTo(const pt: TGLVector): Single; overload;
Public | function DistanceTo(const pt: TAffineVector): Single; overload;
Public | function DistanceTo(anObject: TGLBaseSceneObject): Single; overload;
Public | function FindChild(const aName: string; ownChildrenOnly: Boolean): TGLBaseSceneObject;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; virtual;
Public | function GetHandle(var rci: TGLRenderContextInfo): Cardinal;
Public | function GetOrCreateBehaviour(aBehaviour: TGLBehaviourClass): TGLBehaviour;
Public | function GetOrCreateEffect(aEffect: TGLEffectClass): TGLEffect;
Public | function GetParentComponent: TComponent; override;
Public | function HasParent: Boolean; override; final;
Public | function HasSubChildren: Boolean;
Public | function IndexOfChild(aChild: TGLBaseSceneObject): Integer;
Public | function InvAbsoluteMatrix: TGLMatrix; inline;
Public | function InvAbsoluteMatrixAsAddress: PGLMatrix;
Public | function IsUpdating: Boolean; inline;
Public | function LeftVector: TGLVector; inline;
Public | function ListHandleAllocated: Boolean; inline;
Public | function LocalToAbsolute(const v: TAffineVector): TAffineVector; overload;
Public | function LocalToAbsolute(const v: TGLVector): TGLVector; overload;
Public | function PointInObject(const point: TGLVector): Boolean; virtual;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; virtual;
Public | function Right: TGLVector; inline;
Public | function SqrDistanceTo(const pt: TGLVector): Single; overload;
Public | function SqrDistanceTo(const pt: TAffineVector): Single; overload;
Public | function SqrDistanceTo(anObject: TGLBaseSceneObject): Single; overload;
Private | function Get(Index: Integer): TGLBaseSceneObject; inline;
Private | function GetAbsoluteAffineScale: TAffineVector;
Private | function GetAbsoluteMatrix: TGLMatrix; inline;
Private | function GetAbsoluteScale: TGLVector;
Private | function GetBehaviours: TGLBehaviours;
Private | function GetCount: Integer; inline;
Private | function GetDirectAbsoluteMatrix: PGLMatrix;
Private | function GetEffects: TGLEffects;
Private | function GetIndex: Integer; inline;
Private | function GetLocalMatrix: PGLMatrix; inline;
Private | function GetMatrix: PGLMatrix; inline;
Private | function GetPitchAngle: Single; inline;
Private | function GetRollAngle: Single; inline;
Private | function GetTurnAngle: Single; inline;
Public | procedure AddChild(aChild: TGLBaseSceneObject); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate; inline;
Public | procedure BuildList(var rci: TGLRenderContextInfo); virtual;
Public | procedure ClearStructureChanged; inline;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public | procedure DeleteChildren; virtual;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); virtual;
Public | procedure EndUpdate; inline;
Public | procedure ExchangeChildren(anIndex1, anIndex2: Integer);
Public | procedure ExchangeChildrenSafe(anIndex1, anIndex2: Integer);
Public | procedure ForceLocalMatrix(const aMatrix: TGLMatrix); inline;
Public | procedure Insert(aIndex: Integer; aChild: TGLBaseSceneObject); virtual;
Public | procedure Lift(ADistance: Single);
Public | procedure Move(ADistance: Single);
Public | procedure MoveChildDown(anIndex: Integer);
Public | procedure MoveChildFirst(anIndex: Integer);
Public | procedure MoveChildLast(anIndex: Integer);
Public | procedure MoveChildUp(anIndex: Integer);
Public | procedure MoveDown;
Public | procedure MoveFirst;
Public | procedure MoveLast;
Public | procedure MoveObjectAllAround(anObject: TGLBaseSceneObject; pitchDelta, turnDelta: Single);
Public | procedure MoveObjectAround(anObject: TGLBaseSceneObject; pitchDelta, turnDelta: Single);
Public | procedure MoveTo(newParent: TGLBaseSceneObject); virtual;
Public | procedure MoveUp;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure Pitch(angle: Single);
Public | procedure PointTo(const ATargetObject: TGLBaseSceneObject; const AUpVector: TGLVector); overload;
Public | procedure PointTo(const AAbsolutePosition, AUpVector: TGLVector); overload;
Public | procedure Remove(aChild: TGLBaseSceneObject; keepChildren: Boolean); virtual;
Public | procedure Render(var ARci: TGLRenderContextInfo);
Public | procedure RenderChildren(firstChildIndex, lastChildIndex: Integer; var rci: TGLRenderContextInfo);
Public | procedure ResetAndPitchTurnRoll(const degX, degY, degZ: Single);
Public | procedure ResetRotations;
Public | procedure Roll(angle: Single);
Public | procedure RotateAbsolute(const rx, ry, rz: Single); overload;
Public | procedure RotateAbsolute(const axis: TAffineVector; angle: Single); overload;
Public | procedure SetMatrix(const aValue: TGLMatrix); inline;
Public | procedure Slide(ADistance: Single);
Public | procedure StructureChanged; virtual;
Public | procedure TransformationChanged; inline;
Public | procedure Translate(tx, ty, tz: Single);
Public | procedure Turn(angle: Single);
Private | procedure SetAbsoluteAffineScale(const Value: TAffineVector);
Private | procedure SetAbsoluteMatrix(const Value: TGLMatrix);
Private | procedure SetAbsoluteScale(const Value: TGLVector);
Private | procedure SetBBChanges(const Value: TGLObjectBBChanges);
Private | procedure SetBehaviours(const val: TGLBehaviours);
Private | procedure SetDirection(AVector: TGLCoordinates);
Private | procedure SetEffects(const val: TGLEffects);
Private | procedure SetIndex(aValue: Integer);
Private | procedure SetObjectsSorting(const val: TGLObjectsSorting);
Private | procedure SetParent(const val: TGLBaseSceneObject); inline;
Private | procedure SetPitchAngle(AValue: Single);
Private | procedure SetPosition(APosition: TGLCoordinates);
Private | procedure SetRollAngle(AValue: Single);
Private | procedure SetRotation(aRotation: TGLCoordinates);
Private | procedure SetScaling(AValue: TGLCoordinates);
Private | procedure SetShowAxes(AValue: Boolean);
Private | procedure SetTurnAngle(AValue: Single);
Private | procedure SetUp(AVector: TGLCoordinates);
Private | procedure SetVisibilityCulling(const val: TGLVisibilityCulling);

Properties

Public | property AbsoluteAffineDirection: TAffineVector read GetAbsoluteAffineDirection write SetAbsoluteAffineDirection;
Public | property AbsoluteAffinePosition: TAffineVector read GetAbsoluteAffinePosition write SetAbsoluteAffinePosition;
Public | property AbsoluteAffineScale: TAffineVector read GetAbsoluteAffineScale write SetAbsoluteAffineScale;
Public | property AbsoluteAffineUp: TAffineVector read GetAbsoluteAffineUp write SetAbsoluteAffineUp;
Public | property AbsoluteDirection: TGLVector read GetAbsoluteDirection write SetAbsoluteDirection;
Public | property AbsoluteMatrix: TGLMatrix read GetAbsoluteMatrix write SetAbsoluteMatrix;
Public | property AbsolutePosition: TGLVector read GetAbsolutePosition write SetAbsolutePosition;
Public | property AbsoluteScale: TGLVector read GetAbsoluteScale write SetAbsoluteScale;
Public | property AbsoluteUp: TGLVector read GetAbsoluteUp write SetAbsoluteUp;
Public | property BBChanges: TGLObjectBBChanges read fBBChanges write SetBBChanges;
Public | property Behaviours: TGLBehaviours read GetBehaviours write SetBehaviours stored False;
Public | property Changes: TGLObjectChanges read FChanges;
Public | property Children[Index: Integer]: TGLBaseSceneObject read Get;
Public | property Count: Integer read GetCount;
Public | property DirectAbsoluteMatrix: PGLMatrix read GetDirectAbsoluteMatrix;
Public | property Direction: TGLCoordinates read FDirection write SetDirection;
Public | property Effects: TGLEffects read GetEffects write SetEffects stored False;
Public | property Index: Integer read GetIndex write SetIndex;
Public | property LocalMatrix: PGLMatrix read GetLocalMatrix;
Public | property Matrix: PGLMatrix read GetMatrix;
Public | property ObjectsSorting: TGLObjectsSorting read FObjectsSorting write SetObjectsSorting default osInherited;
Public | property ObjectStyle: TGLObjectStyles read FObjectStyle write FObjectStyle;
Public | property OnAddedToParent: TNotifyEvent read FOnAddedToParent write FOnAddedToParent;
Public | property OnPicked: TNotifyEvent read FOnPicked write FOnPicked;
Public | property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;
Public | property Parent: TGLBaseSceneObject read FParent write SetParent;
Public | property Pickable: Boolean read FPickable write SetPickable default True;
Public | property PitchAngle: Single read GetPitchAngle write SetPitchAngle;
Public | property Position: TGLCoordinates read FPosition write SetPosition;
Public | property RollAngle: Single read GetRollAngle write SetRollAngle;
Public | property Rotation: TGLCoordinates read FRotation write SetRotation;
Public | property Scale: TGLCoordinates read FScaling write SetScaling;
Public | property Scene: TGLScene read FScene;
Public | property ShowAxes: Boolean read FShowAxes write SetShowAxes default False;
Published | property TagFloat: Single read FTagFloat write FTagFloat;
Public | property TagObject: TObject read FTagObject write FTagObject;
Public | property TurnAngle: Single read GetTurnAngle write SetTurnAngle;
Public | property Up: TGLCoordinates read FUp write SetUp;
Public | property VisibilityCulling: TGLVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcInherited;
Public | property Visible: Boolean read FVisible write SetVisible default True;

Description

Fields

Private FAbsoluteMatrix: TGLMatrix;

This item has no description.

Private FInvAbsoluteMatrix: TGLMatrix;

This item has no description.

Private FLocalMatrix: TGLMatrix;

This item has no description.

Private FObjectStyle: TGLObjectStyles;

This item has no description.

Private FListHandle: TGLListHandle;

This item has no description.

Private FPosition: TGLCoordinates;

created on 1st use

Private FDirection: TGLCoordinates;

This item has no description.

Private FUp: TGLCoordinates;

This item has no description.

Private FScaling: TGLCoordinates;

This item has no description.

Private FChanges: TGLObjectChanges;

This item has no description.

Private FParent: TGLBaseSceneObject;

This item has no description.

Private FScene: TGLScene;

This item has no description.

Private FBBChanges: TGLObjectBBChanges;

This item has no description.

Private FBoundingBoxPersonalUnscaled: THmgBoundingBox;

This item has no description.

Private FBoundingBoxOfChildren: THmgBoundingBox;

This item has no description.

Private FBoundingBoxIncludingChildren: THmgBoundingBox;

This item has no description.

Private FChildren: TGLPersistentObjectList;

This item has no description.

Private FVisible: Boolean;

created on 1st use

Private FUpdateCount: Integer;

This item has no description.

Private FShowAxes: Boolean;

This item has no description.

Private FRotation: TGLCoordinates;

This item has no description.

Private FIsCalculating: Boolean;

current rotation angles

Private FObjectsSorting: TGLObjectsSorting;

This item has no description.

Private FVisibilityCulling: TGLVisibilityCulling;

This item has no description.

Private FOnProgress: TGLProgressEvent;

This item has no description.

Private FOnAddedToParent: TNotifyEvent;

This item has no description.

Private FBehaviours: TGLBehaviours;

This item has no description.

Private FEffects: TGLEffects;

This item has no description.

Private FPickable: Boolean;

This item has no description.

Private FOnPicked: TNotifyEvent;

This item has no description.

Private FTagObject: TObject;

This item has no description.

Private FTagFloat: Single;

This item has no description.

Private objList: TGLPersistentObjectList;

This item has no description.

Private distList: TGLSingleList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public constructor CreateAsChild(aParentOwner: TGLBaseSceneObject);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AbsoluteLeft: TGLVector;

Calculate the left vector in absolute coordinates.

Public function AbsoluteMatrixAsAddress: PGLMatrix;

See AbsoluteMatrix.

Public function AbsolutePositionAsAddress: PGLVector;

This item has no description.

Public function AbsoluteRight: TGLVector;

Calculate the right vector in absolute coordinates.

Public function AbsoluteToLocal(const v: TGLVector): TGLVector; overload;

Converts a vector/point from absolute coordinates to local coordinates.

Public function AbsoluteToLocal(const v: TAffineVector): TAffineVector; overload;

Converts a vector from absolute coordinates to local coordinates.

Public function AbsoluteXVector: TGLVector;

Returns the Absolute X Vector expressed in local coordinates.

Public function AbsoluteYVector: TGLVector;

Returns the Absolute Y Vector expressed in local coordinates.

Public function AbsoluteZVector: TGLVector;

Returns the Absolute Z Vector expressed in local coordinates.

Public function AddNewBehaviour(aBehaviour: TGLBehaviourClass): TGLBehaviour;

This item has no description.

Public function AddNewChild(aChild: TGLSceneObjectClass): TGLBaseSceneObject; virtual;

Creates a new scene object and add it to this object as new child

Public function AddNewChildFirst(aChild: TGLSceneObjectClass): TGLBaseSceneObject; virtual;

Creates a new scene object and add it to this object as first child

Public function AddNewEffect(aEffect: TGLEffectClass): TGLEffect;

This item has no description.

Public function AffineLeftVector: TAffineVector; inline;

Returns the Left vector (based on Up and Direction)

Public function AffineRight: TAffineVector; inline;

Returns the Right vector (based on Up and Direction)

Public function AxisAlignedBoundingBox(const AIncludeChilden: Boolean = True): TAABB;

Calculates and return the AABB for the object. The AABB is currently calculated from the BB. There is no caching scheme for them.

Public function AxisAlignedBoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): TAABB;

This item has no description.

Public function AxisAlignedBoundingBoxAbsoluteEx: TAABB;

This item has no description.

Public function AxisAlignedBoundingBoxEx: TAABB;

Advanced AABB functions that use a caching scheme. Also they include children and use BaryCenter.

Public function AxisAlignedBoundingBoxUnscaled(const AIncludeChilden: Boolean = True): TAABB;

This item has no description.

Public function AxisAlignedDimensions: TGLVector; virtual;

Shall returns the object's axis aligned extensions. The dimensions are measured from object center and are expressed with scale accounted for, in the object's coordinates (not in absolute ones). Default value is half the object's Scale.

Public function AxisAlignedDimensionsUnscaled: TGLVector; virtual;

This item has no description.

Public function BarycenterAbsolutePosition: TGLVector; virtual;

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function BarycenterSqrDistanceTo(const pt: TGLVector): Single;

Calculates the object's barycenter distance to a point.

Public function BoundingBox(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;

Calculates and return the Bounding Box for the object. The BB is calculated each time this method is invoked, based on the AxisAlignedDimensions of the object and that of its children. There is no caching scheme for them.

Public function BoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;

This item has no description.

Public function BoundingBoxIncludingChildrenEx: THmgBoundingBox;

This item has no description.

Public function BoundingBoxOfChildrenEx: THmgBoundingBox;

This item has no description.

Public function BoundingBoxPersonalUnscaledEx: THmgBoundingBox;

Advanced BB functions that use a caching scheme. Also they include children and use BaryCenter.

Public function BoundingBoxUnscaled(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;

This item has no description.

Public function BoundingSphereRadius: Single; inline;

Max distance of corners of the BoundingBox.

Public function BoundingSphereRadiusUnscaled: Single; inline;

This item has no description.

Public function DistanceTo(const pt: TGLVector): Single; overload;

This item has no description.

Public function DistanceTo(const pt: TAffineVector): Single; overload;

This item has no description.

Public function DistanceTo(anObject: TGLBaseSceneObject): Single; overload;

Computes the object's distance to a point/object. Only objects AbsolutePositions are considered.

Public function FindChild(const aName: string; ownChildrenOnly: Boolean): TGLBaseSceneObject;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; virtual;

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function GetHandle(var rci: TGLRenderContextInfo): Cardinal;

Returns the handle to the object's build list. Use with caution! Some objects don't support buildlists!

Public function GetOrCreateBehaviour(aBehaviour: TGLBehaviourClass): TGLBehaviour;

This item has no description.

Public function GetOrCreateEffect(aEffect: TGLEffectClass): TGLEffect;

This item has no description.

Public function GetParentComponent: TComponent; override;

This item has no description.

Public function HasParent: Boolean; override; final;

This item has no description.

Public function HasSubChildren: Boolean;

This item has no description.

Public function IndexOfChild(aChild: TGLBaseSceneObject): Integer;

This item has no description.

Public function InvAbsoluteMatrix: TGLMatrix; inline;

Calculates the object's absolute inverse matrix. Multiplying an absolute coordinate with this matrix gives a local coordinate. The current implem uses transposition(AbsoluteMatrix), which is true unless you're using some scaling...

Public function InvAbsoluteMatrixAsAddress: PGLMatrix;

See InvAbsoluteMatrix.

Public function IsUpdating: Boolean; inline;

This item has no description.

Public function LeftVector: TGLVector; inline;

Returns the Left vector (based on Up and Direction)

Public function ListHandleAllocated: Boolean; inline;

This item has no description.

Public function LocalToAbsolute(const v: TAffineVector): TAffineVector; overload;

Converts a vector from local coordinates to absolute coordinates.

Public function LocalToAbsolute(const v: TGLVector): TGLVector; overload;

Converts a vector/point from local coordinates to absolute coordinates.

Public function PointInObject(const point: TGLVector): Boolean; virtual;

Indicates if a point is within an object. Given coordinate is an absolute coordinate. Linear or surfacic objects shall always return False. Default value is based on AxisAlignedDimension and a cube bounding.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; virtual;

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public function Right: TGLVector; inline;

Returns the Right vector (based on Up and Direction)

Public function SqrDistanceTo(const pt: TGLVector): Single; overload;

This item has no description.

Public function SqrDistanceTo(const pt: TAffineVector): Single; overload;

This item has no description.

Public function SqrDistanceTo(anObject: TGLBaseSceneObject): Single; overload;

Calculates the object's square distance to a point/object. pt is assumed to be in absolute coordinates, AbsolutePosition is considered as being the object position.

Private function Get(Index: Integer): TGLBaseSceneObject; inline;

If somebody could look at DefineProperties, ReadBehaviours, ReadEffects and verify code is safe to use then it could be uncommented

Private function GetAbsoluteAffineScale: TAffineVector;

This item has no description.

Private function GetAbsoluteMatrix: TGLMatrix; inline;

This item has no description.

Private function GetAbsoluteScale: TGLVector;

This item has no description.

Private function GetBehaviours: TGLBehaviours;

This item has no description.

Private function GetCount: Integer; inline;

This item has no description.

Private function GetDirectAbsoluteMatrix: PGLMatrix;

This item has no description.

Private function GetEffects: TGLEffects;

This item has no description.

Private function GetIndex: Integer; inline;

This item has no description.

Private function GetLocalMatrix: PGLMatrix; inline;

This item has no description.

Private function GetMatrix: PGLMatrix; inline;

This item has no description.

Private function GetPitchAngle: Single; inline;

This item has no description.

Private function GetRollAngle: Single; inline;

This item has no description.

Private function GetTurnAngle: Single; inline;

This item has no description.

Public procedure AddChild(aChild: TGLBaseSceneObject); virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BeginUpdate; inline;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); virtual;

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure ClearStructureChanged; inline;

This item has no description.

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;

Recalculate an orthonormal system

Public procedure DeleteChildren; virtual;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); virtual;

This item has no description.

Public procedure EndUpdate; inline;

This item has no description.

Public procedure ExchangeChildren(anIndex1, anIndex2: Integer);

The "regular" version of this procedure does not perform any checks and calls FChildren.Exchange directly. User should/can perform range checks manualy.

Public procedure ExchangeChildrenSafe(anIndex1, anIndex2: Integer);

The "safe" version of this procedure checks if indexes are inside the list. If not, no exception if raised.

Public procedure ForceLocalMatrix(const aMatrix: TGLMatrix); inline;

Forces the local matrix to the specified value. AbsoluteMatrix, InverseMatrix, etc. will honour that change, but may become invalid if the specified matrix isn't orthonormal (can be used for specific rendering or projection effects). The local matrix will be reset by the next TransformationChanged, position or attitude change.

Public procedure Insert(aIndex: Integer; aChild: TGLBaseSceneObject); virtual;

This item has no description.

Public procedure Lift(ADistance: Single);

Moves the object along the Up vector (move up/down)

Public procedure Move(ADistance: Single);

Moves the object along the direction vector

Public procedure MoveChildDown(anIndex: Integer);

This item has no description.

Public procedure MoveChildFirst(anIndex: Integer);

This item has no description.

Public procedure MoveChildLast(anIndex: Integer);

This item has no description.

Public procedure MoveChildUp(anIndex: Integer);

These procedures are safe.

Public procedure MoveDown;

This item has no description.

Public procedure MoveFirst;

This item has no description.

Public procedure MoveLast;

This item has no description.

Public procedure MoveObjectAllAround(anObject: TGLBaseSceneObject; pitchDelta, turnDelta: Single);

This item has no description.

Public procedure MoveObjectAround(anObject: TGLBaseSceneObject; pitchDelta, turnDelta: Single);

This item has no description.

Public procedure MoveTo(newParent: TGLBaseSceneObject); virtual;

This item has no description.

Public procedure MoveUp;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure Pitch(angle: Single);

This item has no description.

Public procedure PointTo(const ATargetObject: TGLBaseSceneObject; const AUpVector: TGLVector); overload;

Orients the object toward a target object

Public procedure PointTo(const AAbsolutePosition, AUpVector: TGLVector); overload;

Orients the object toward a target absolute position

Public procedure Remove(aChild: TGLBaseSceneObject; keepChildren: Boolean); virtual;

Takes a scene object out of the child list, but doesn't destroy it. If 'KeepChildren' is true its children will be kept as new children in this scene object.

Public procedure Render(var ARci: TGLRenderContextInfo);

This item has no description.

Public procedure RenderChildren(firstChildIndex, lastChildIndex: Integer; var rci: TGLRenderContextInfo);

This item has no description.

Public procedure ResetAndPitchTurnRoll(const degX, degY, degZ: Single);

Reset rotations and applies them back in the specified order.

Public procedure ResetRotations;

Sets all rotations to zero and restores default Direction/Up. Using this function then applying roll/pitch/turn in the order that suits you, you can give an "absolute" meaning to rotation angles (they are still applied locally though). Scale and Position are not affected.

Public procedure Roll(angle: Single);

This item has no description.

Public procedure RotateAbsolute(const rx, ry, rz: Single); overload;

Applies rotations around absolute X, Y and Z axis.

Public procedure RotateAbsolute(const axis: TAffineVector; angle: Single); overload;

Applies rotations around the absolute given vector (angle in degrees).

Public procedure SetMatrix(const aValue: TGLMatrix); inline;

The local transformation (relative to parent). If you're *sure* the local matrix is up-to-date, you may use LocalMatrix for quicker access.

Public procedure Slide(ADistance: Single);

Moves camera along the right vector (move left and right)

Public procedure StructureChanged; virtual;

This item has no description.

Public procedure TransformationChanged; inline;

This item has no description.

Public procedure Translate(tx, ty, tz: Single);

Translates the object

Public procedure Turn(angle: Single);

This item has no description.

Private procedure SetAbsoluteAffineScale(const Value: TAffineVector);

This item has no description.

Private procedure SetAbsoluteMatrix(const Value: TGLMatrix);

This item has no description.

Private procedure SetAbsoluteScale(const Value: TGLVector);

This item has no description.

Private procedure SetBBChanges(const Value: TGLObjectBBChanges);

This item has no description.

Private procedure SetBehaviours(const val: TGLBehaviours);

This item has no description.

Private procedure SetDirection(AVector: TGLCoordinates);

This item has no description.

Private procedure SetEffects(const val: TGLEffects);

This item has no description.

Private procedure SetIndex(aValue: Integer);

This item has no description.

Private procedure SetObjectsSorting(const val: TGLObjectsSorting);

This item has no description.

Private procedure SetParent(const val: TGLBaseSceneObject); inline;

This item has no description.

Private procedure SetPitchAngle(AValue: Single);

This item has no description.

Private procedure SetPosition(APosition: TGLCoordinates);

This item has no description.

Private procedure SetRollAngle(AValue: Single);

This item has no description.

Private procedure SetRotation(aRotation: TGLCoordinates);

This item has no description.

Private procedure SetScaling(AValue: TGLCoordinates);

This item has no description.

Private procedure SetShowAxes(AValue: Boolean);

This item has no description.

Private procedure SetTurnAngle(AValue: Single);

This item has no description.

Private procedure SetUp(AVector: TGLCoordinates);

This item has no description.

Private procedure SetVisibilityCulling(const val: TGLVisibilityCulling);

This item has no description.

Properties

Public property AbsoluteAffineDirection: TAffineVector read GetAbsoluteAffineDirection write SetAbsoluteAffineDirection;

This item has no description.

Public property AbsoluteAffinePosition: TAffineVector read GetAbsoluteAffinePosition write SetAbsoluteAffinePosition;

This item has no description.

Public property AbsoluteAffineScale: TAffineVector read GetAbsoluteAffineScale write SetAbsoluteAffineScale;

This item has no description.

Public property AbsoluteAffineUp: TAffineVector read GetAbsoluteAffineUp write SetAbsoluteAffineUp;

This item has no description.

Public property AbsoluteDirection: TGLVector read GetAbsoluteDirection write SetAbsoluteDirection;

Direction vector in absolute coordinates.

Public property AbsoluteMatrix: TGLMatrix read GetAbsoluteMatrix write SetAbsoluteMatrix;

The object's absolute matrix by composing all local matrices. Multiplying a local coordinate with this matrix gives an absolute coordinate.

Public property AbsolutePosition: TGLVector read GetAbsolutePosition write SetAbsolutePosition;

Computes and allows to set the object's absolute coordinates.

Public property AbsoluteScale: TGLVector read GetAbsoluteScale write SetAbsoluteScale;

Scale vector in absolute coordinates. Warning: SetAbsoluteScale() does not work correctly at the moment.

Public property AbsoluteUp: TGLVector read GetAbsoluteUp write SetAbsoluteUp;

Up vector in absolute coordinates.

Public property BBChanges: TGLObjectBBChanges read fBBChanges write SetBBChanges;

This item has no description.

Public property Behaviours: TGLBehaviours read GetBehaviours write SetBehaviours stored False;

This item has no description.

Public property Changes: TGLObjectChanges read FChanges;

This item has no description.

Public property Children[Index: Integer]: TGLBaseSceneObject read Get;

This item has no description.

Public property Count: Integer read GetCount;

This item has no description.

Public property DirectAbsoluteMatrix: PGLMatrix read GetDirectAbsoluteMatrix;

Holds the absolute transformation matrix. If you're not *sure* the absolute matrix is up-to-date, use the AbsoluteMatrix property, this one may be nil...

Public property Direction: TGLCoordinates read FDirection write SetDirection;

This item has no description.

Public property Effects: TGLEffects read GetEffects write SetEffects stored False;

This item has no description.

Public property Index: Integer read GetIndex write SetIndex;

This item has no description.

Public property LocalMatrix: PGLMatrix read GetLocalMatrix;

Holds the local transformation (relative to parent). If you're not *sure* the local matrix is up-to-date, use Matrix property.

Public property Matrix: PGLMatrix read GetMatrix;

This item has no description.

Public property ObjectsSorting: TGLObjectsSorting read FObjectsSorting write SetObjectsSorting default osInherited;

This item has no description.

Public property ObjectStyle: TGLObjectStyles read FObjectStyle write FObjectStyle;

Controls and adjusts internal optimizations based on object's style. Advanced user only.

Public property OnAddedToParent: TNotifyEvent read FOnAddedToParent write FOnAddedToParent;

This item has no description.

Public property OnPicked: TNotifyEvent read FOnPicked write FOnPicked;

This item has no description.

Public property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;

This item has no description.

Public property Parent: TGLBaseSceneObject read FParent write SetParent;

This item has no description.

Public property Pickable: Boolean read FPickable write SetPickable default True;

This item has no description.

Public property PitchAngle: Single read GetPitchAngle write SetPitchAngle;

This item has no description.

Public property Position: TGLCoordinates read FPosition write SetPosition;

This item has no description.

Public property RollAngle: Single read GetRollAngle write SetRollAngle;

This item has no description.

Public property Rotation: TGLCoordinates read FRotation write SetRotation;

This item has no description.

Public property Scale: TGLCoordinates read FScaling write SetScaling;

This item has no description.

Public property Scene: TGLScene read FScene;

This item has no description.

Public property ShowAxes: Boolean read FShowAxes write SetShowAxes default False;

This item has no description.

Published property TagFloat: Single read FTagFloat write FTagFloat;

This item has no description.

Public property TagObject: TObject read FTagObject write FTagObject;

This item has no description.

Public property TurnAngle: Single read GetTurnAngle write SetTurnAngle;

This item has no description.

Public property Up: TGLCoordinates read FUp write SetUp;

This item has no description.

Public property VisibilityCulling: TGLVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcInherited;

This item has no description.

Public property Visible: Boolean read FVisible write SetVisible default True;


GLSysHelp v.2.5: GLS.Scene: Class TGLBaseBehaviour

Class TGLBaseBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLBaseBehaviour = class(TXCollectionItem)

Description

Base class for implementing behaviours in TGLScene. Behaviours are regrouped in a collection attached to a TGLBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...). Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses : stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.)

Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object). NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); virtual;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); virtual;


GLSysHelp v.2.5: GLS.Scene: Class TGLBehaviour

Class TGLBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLBehaviour = class(TGLBaseBehaviour)

Description

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour


GLSysHelp v.2.5: GLS.Scene: Class TGLBehaviours

Class TGLBehaviours

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLBehaviours = class(TXCollection)

Description

Holds a list of TGLBehaviour objects. This object expects itself to be owned by a TGLBaseSceneObject. As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TGLBehaviour subclasses.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLBehaviours

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | function GetNamePath: string; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Public | procedure DoProgress(const progressTimes: TGLProgressTimes); inline;

Properties

Public property Behaviour[index: Integer]: TGLBehaviour read GetBehaviour;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public function GetNamePath: string; override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure DoProgress(const progressTimes: TGLProgressTimes); inline;

This item has no description.

Properties

Public property Behaviour[index: Integer]: TGLBehaviour read GetBehaviour;


GLSysHelp v.2.5: GLS.Scene: Class TGLEffect

Class TGLEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLEffect = class(TGLBaseBehaviour)

Description

A rendering effect that can be applied to SceneObjects. ObjectEffect is a subclass of behaviour that gets a chance to Render an object-related special effect. TGLEffect should not be used as base class for custom effects, instead you should use the following base classes : TGLObjectPreEffect is rendered before owner object render TGLObjectPostEffect is rendered after the owner object render TGLObjectAfterEffect is rendered at the end of the scene rendering NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect

Overview

Methods

Public procedure Render(var rci: TGLRenderContextInfo); virtual;

Description

Methods

Public procedure Render(var rci: TGLRenderContextInfo); virtual;


GLSysHelp v.2.5: GLS.Scene: Class TGLObjectPreEffect

Class TGLObjectPreEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLObjectPreEffect = class(TGLEffect)

Description

An object effect that gets rendered before owner object's render. The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect
  • TGLObjectPreEffect


GLSysHelp v.2.5: GLS.Scene: Class TGLObjectPostEffect

Class TGLObjectPostEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLObjectPostEffect = class(TGLEffect)

Description

An object effect that gets rendered after owner object's render. The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect
  • TGLObjectPostEffect


GLSysHelp v.2.5: GLS.Scene: Class TGLObjectAfterEffect

Class TGLObjectAfterEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLObjectAfterEffect = class(TGLEffect)

Description

An object effect that gets rendered at scene's end. No particular OpenGL matrices or material should be assumed.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect
  • TGLObjectAfterEffect


GLSysHelp v.2.5: GLS.Scene: Class TGLEffects

Class TGLEffects

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLEffects = class(TXCollection)

Description

Holds a list of object effects. This object expects itself to be owned by a TGLBaseSceneObject.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLEffects

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | function GetNamePath: string; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes);
Public | procedure RenderPostEffects(var rci: TGLRenderContextInfo); inline;
Public | procedure RenderPreEffects(var rci: TGLRenderContextInfo); inline;

Properties

Public property ObjectEffect[index: Integer]: TGLEffect read GetEffect;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public function GetNamePath: string; override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure DoProgress(const progressTime: TGLProgressTimes);

This item has no description.

Public procedure RenderPostEffects(var rci: TGLRenderContextInfo); inline;

Also take care of registering after effects with the GLSceneViewer.

Public procedure RenderPreEffects(var rci: TGLRenderContextInfo); inline;

This item has no description.

Properties

Public property ObjectEffect[index: Integer]: TGLEffect read GetEffect;


GLSysHelp v.2.5: GLS.Scene: Class TGLCustomSceneObject

Class TGLCustomSceneObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLCustomSceneObject = class(TGLBaseSceneObject)

Description

Extended base scene object class with a material property. The material allows defining a color and texture for the object, see TGLMaterial

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject

Overview

Fields

Private | FMaterial: TGLMaterial;
Private | FHint: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Public | property Hint: string read FHint write FHint;
Public | property Material: TGLMaterial read FMaterial write SetGLMaterial;

Description

Fields

Private FMaterial: TGLMaterial;

This item has no description.

Private FHint: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Public property Hint: string read FHint write FHint;

This item has no description.

Public property Material: TGLMaterial read FMaterial write SetGLMaterial;


GLSysHelp v.2.5: GLS.Scene: Class TGLSceneRootObject

Class TGLSceneRootObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLSceneRootObject = class(TGLBaseSceneObject)

Description

This class shall be used only as a hierarchy root. It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations. Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLSceneRootObject

Overview

Methods

Public constructor Create(AOwner: TComponent); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;


GLSysHelp v.2.5: GLS.Scene: Class TGLImmaterialSceneObject

Class TGLImmaterialSceneObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLImmaterialSceneObject = class(TGLCustomSceneObject)

Description

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject

Overview

Methods

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property Hint;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VisibilityCulling;
Published | property Visible;

Description

Methods

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property Hint;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnPicked;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Pickable;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.Scene: Class TGLCameraInvariantObject

Class TGLCameraInvariantObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLCameraInvariantObject = class(TGLImmaterialSceneObject)

Description

Base class for camera invariant objects. Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject

Overview

Fields

Private FCamInvarianceMode: TGLCameraInvarianceMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Description

Fields

Private FCamInvarianceMode: TGLCameraInvarianceMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;


GLSysHelp v.2.5: GLS.Scene: Class TGLSceneObject

Class TGLSceneObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLSceneObject = class(TGLCustomSceneObject)

Description

Base class for standard scene objects. Publishes the Material property.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject

Overview

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property Hint;
Published | property Material;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VisibilityCulling;
Published | property Visible;

Description

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property Hint;

This item has no description.

Published property Material;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnPicked;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Pickable;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.Scene: Class TGLDirectOpenGL

Class TGLDirectOpenGL

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLDirectOpenGL = class(TGLImmaterialSceneObject)

Description

Provides a way to issue direct OpenGL calls during the rendering. You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLDirectOpenGL

Overview

Fields

Private | FUseBuildList: Boolean;
Private | FOnRender: TGLDirectRenderEvent;
Private | FBlend: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property Blend: Boolean read FBlend write SetBlend;
Published | property OnRender: TGLDirectRenderEvent read FOnRender write FOnRender;
Published | property UseBuildList: Boolean read FUseBuildList write SetUseBuildList;

Description

Fields

Private FUseBuildList: Boolean;

This item has no description.

Private FOnRender: TGLDirectRenderEvent;

This item has no description.

Private FBlend: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Blend: Boolean read FBlend write SetBlend;

Defines if the object uses blending. This property will allow direct opengl objects to be flagged as blended for object sorting purposes.

Published property OnRender: TGLDirectRenderEvent read FOnRender write FOnRender;

Place your specific OpenGL code here. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.

Published property UseBuildList: Boolean read FUseBuildList write SetUseBuildList;

Specifies if a build list be made. If True, GLScene will generate a build list (side cache), ie. OnRender will only be invoked once for the first render, or after a StructureChanged call. This is suitable for "static" geometry and will usually speed up rendering of things that don't change. If false, OnRender will be invoked for each render. This is suitable for dynamic geometry (things that change often or constantly).


GLSysHelp v.2.5: GLS.Scene: Class TGLRenderPoint

Class TGLRenderPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLRenderPoint = class(TGLImmaterialSceneObject)

Description

Scene object that allows other objects to issue rendering at some point. This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase. Callbacks must be explicitly unregistered.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLRenderPoint

Overview

Fields

Private | FCallBacks: array of TGLDirectRenderEvent;
Private | FFreeCallBacks: array of TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure Clear;
Public | procedure RegisterCallBack(renderEvent: TGLDirectRenderEvent; renderPointFreed: TNotifyEvent);
Public | procedure UnRegisterCallBack(renderEvent: TGLDirectRenderEvent);

Description

Fields

Private FCallBacks: array of TGLDirectRenderEvent;

This item has no description.

Private FFreeCallBacks: array of TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure Clear;

This item has no description.

Public procedure RegisterCallBack(renderEvent: TGLDirectRenderEvent; renderPointFreed: TNotifyEvent);

This item has no description.

Public procedure UnRegisterCallBack(renderEvent: TGLDirectRenderEvent);


GLSysHelp v.2.5: GLS.Scene: Class TGLProxyObject

Class TGLProxyObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLProxyObject = class(TGLBaseSceneObject)

Description

A full proxy object. This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own. Use it for duplicates of an object.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject

Overview

Fields

Private | FMasterObject: TGLBaseSceneObject;
Private | FProxyOptions: TGLProxyObjectOptions;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensions: TGLVector; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function BarycenterAbsolutePosition: TGLVector; override;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Behaviours;
Published | property Direction;
Published | property MasterObject: TGLBaseSceneObject read FMasterObject write SetMasterObject;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property ProxyOptions: TGLProxyObjectOptions read FProxyOptions write SetProxyOptions default cDefaultProxyOptions;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Fields

Private FMasterObject: TGLBaseSceneObject;

This item has no description.

Private FProxyOptions: TGLProxyObjectOptions;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensions: TGLVector; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.AxisAlignedDimensions.

Shall returns the object's axis aligned extensions. The dimensions are measured from object center and are expressed with scale accounted for, in the object's coordinates (not in absolute ones). Default value is half the object's Scale.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function BarycenterAbsolutePosition: TGLVector; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property MasterObject: TGLBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.

Published property ObjectsSorting;

This item has no description.

Published property OnPicked;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Pickable;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property ProxyOptions: TGLProxyObjectOptions read FProxyOptions write SetProxyOptions default cDefaultProxyOptions;

Specifies how and what is proxy'ed.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLS.Scene: Class TGLLightSource

Class TGLLightSource

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLLightSource = class(TGLBaseSceneObject)

Description

Standard light source. The standard GLScene light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle). Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property. Lightsources are managed in a specific object by the TGLScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLLightSource

Overview

Fields

Private | FLightID: Cardinal;
Private | FSpotDirection: TGLCoordinates;
Private | FSpotExponent: Single;
Private | FSpotCutOff: Single;
Private | FConstAttenuation: Single;
Private | FLinearAttenuation: Single;
Private | FQuadraticAttenuation: Single;
Private | FShining: Boolean;
Private | FAmbient: TGLColor;
Private | FDiffuse: TGLColor;
Private | FSpecular: TGLColor;
Private | FLightStyle: TGLLightStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Attenuated: Boolean;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Ambient: TGLColor read FAmbient write SetAmbient;
Published | property ConstAttenuation: Single read FConstAttenuation write SetConstAttenuation;
Published | property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Public | property LightID: Cardinal read FLightID;
Published | property LightStyle: TGLLightStyle read FLightStyle write SetLightStyle default lsSpot;
Published | property LinearAttenuation: Single read FLinearAttenuation write SetLinearAttenuation;
Published | property OnProgress;
Published | property Position;
Published | property QuadraticAttenuation: Single read FQuadraticAttenuation write SetQuadraticAttenuation;
Published | property Shining: Boolean read FShining write SetShining default True;
Published | property Specular: TGLColor read FSpecular write SetSpecular;
Published | property SpotCutOff: Single read FSpotCutOff write SetSpotCutOff;
Published | property SpotDirection: TGLCoordinates read FSpotDirection write SetSpotDirection;
Published | property SpotExponent: Single read FSpotExponent write SetSpotExponent;

Description

Fields

Private FLightID: Cardinal;

This item has no description.

Private FSpotDirection: TGLCoordinates;

This item has no description.

Private FSpotExponent: Single;

This item has no description.

Private FSpotCutOff: Single;

This item has no description.

Private FConstAttenuation: Single;

This item has no description.

Private FLinearAttenuation: Single;

This item has no description.

Private FQuadraticAttenuation: Single;

This item has no description.

Private FShining: Boolean;

This item has no description.

Private FAmbient: TGLColor;

This item has no description.

Private FDiffuse: TGLColor;

This item has no description.

Private FSpecular: TGLColor;

This item has no description.

Private FLightStyle: TGLLightStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Attenuated: Boolean;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;

light sources have different handle types than normal scene objects

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.CoordinateChanged.

Recalculate an orthonormal system

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Ambient: TGLColor read FAmbient write SetAmbient;

This item has no description.

Published property ConstAttenuation: Single read FConstAttenuation write SetConstAttenuation;

This item has no description.

Published property Diffuse: TGLColor read FDiffuse write SetDiffuse;

This item has no description.

Public property LightID: Cardinal read FLightID;

This item has no description.

Published property LightStyle: TGLLightStyle read FLightStyle write SetLightStyle default lsSpot;

This item has no description.

Published property LinearAttenuation: Single read FLinearAttenuation write SetLinearAttenuation;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Position;

This item has no description.

Published property QuadraticAttenuation: Single read FQuadraticAttenuation write SetQuadraticAttenuation;

This item has no description.

Published property Shining: Boolean read FShining write SetShining default True;

This item has no description.

Published property Specular: TGLColor read FSpecular write SetSpecular;

This item has no description.

Published property SpotCutOff: Single read FSpotCutOff write SetSpotCutOff;

This item has no description.

Published property SpotDirection: TGLCoordinates read FSpotDirection write SetSpotDirection;

This item has no description.

Published property SpotExponent: Single read FSpotExponent write SetSpotExponent;


GLSysHelp v.2.5: GLS.Scene: Class TGLCamera

Class TGLCamera

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLCamera = class(TGLBaseSceneObject)

Description

Camera object. This object is commonly referred by TGLSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCamera

Overview

Fields

Private | FFocalLength: Single;
Private | FDepthOfView: Single;
Private | FNearPlane: Single;
Private | FNearPlaneBias: Single;
Private | FViewPortRadius: Single;
Private | FTargetObject: TGLBaseSceneObject;
Private | FLastDirection: TGLVector;
Private | FCameraStyle: TGLCameraStyle;
Private | FKeepFOVMode: TGLCameraKeepFOVMode;
Private | FSceneScale: Single;
Private | FDeferredApply: TNotifyEvent;
Private | FOnCustomPerspective: TOnCustomPerspective;
Private | FDesign: Boolean;
Private | FFOVY: Double;
Private | FFOVX: Double;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AbsoluteEyeSpaceVector(forwardDistance, rightDistance, upDistance: Single): TGLVector;
Public | function AbsoluteRightVectorToTarget: TGLVector;
Public | function AbsoluteUpVectorToTarget: TGLVector;
Public | function AbsoluteVectorToTarget: TGLVector;
Public | function DistanceToTarget: Single;
Public | function GetFieldOfView(const AViewportDimension: single): single;
Public | function PointInFront(const point: TGLVector): boolean; overload;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;
Public | function ScreenDeltaToVector(deltaX, deltaY: Integer; ratio: Single; const planeNormal: TGLVector): TGLVector;
Public | function ScreenDeltaToVectorXY(deltaX, deltaY: Integer; ratio: Single): TGLVector;
Public | function ScreenDeltaToVectorXZ(deltaX, deltaY: Integer; ratio: Single): TGLVector;
Public | function ScreenDeltaToVectorYZ(deltaX, deltaY: Integer; ratio: Single): TGLVector;
Public | procedure AdjustDistanceToTarget(distanceRatio: Single);
Public | procedure Apply;
Public | procedure ApplyPerspective(const AViewport: TRectangle; AWidth, AHeight: Integer; ADPI: Integer);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure AutoLeveling(Factor: Single);
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure MoveAllAroundTarget(pitchDelta, turnDelta :Single);
Public | procedure MoveAroundTarget(pitchDelta, turnDelta: Single);
Public | procedure MoveInEyeSpace(forwardDistance, rightDistance, upDistance: Single);
Public | procedure MoveTargetInEyeSpace(forwardDistance, rightDistance, upDistance: Single);
Public | procedure Reset(aSceneBuffer: TGLSceneBuffer);
Public | procedure RotateObject(obj: TGLBaseSceneObject; pitchDelta, turnDelta: Single; rollDelta: Single = 0);
Public | procedure RotateTarget(pitchDelta, turnDelta: Single; rollDelta: Single = 0);
Public | procedure SetFieldOfView(const AFieldOfView, AViewportDimension: single);
Public | procedure ZoomAll(aSceneBuffer: TGLSceneBuffer);

Properties

Published | property CameraStyle: TGLCameraStyle read FCameraStyle write SetCameraStyle default csPerspective;
Published | property DepthOfView: Single read FDepthOfView write SetDepthOfView;
Published | property Direction;
Published | property FocalLength: Single read FFocalLength write SetFocalLength;
Published | property KeepFOVMode: TGLCameraKeepFOVMode read FKeepFOVMode write SetKeepFOVMode default ckmHorizontalFOV;
Public | property NearPlane: Single read FNearPlane;
Published | property NearPlaneBias: Single read FNearPlaneBias write SetNearPlaneBias stored StoreNearPlaneBias;
Published | property OnCustomPerspective: TOnCustomPerspective read FOnCustomPerspective write FOnCustomPerspective;
Published | property OnProgress;
Published | property Position;
Published | property SceneScale: Single read FSceneScale write SetSceneScale stored StoreSceneScale;
Published | property TargetObject: TGLBaseSceneObject read FTargetObject write SetTargetObject;
Published | property Up;

Description

Fields

Private FFocalLength: Single;

This item has no description.

Private FDepthOfView: Single;

This item has no description.

Private FNearPlane: Single;

This item has no description.

Private FNearPlaneBias: Single;

nearest distance to the camera

Private FViewPortRadius: Single;

scaling bias applied to near plane

Private FTargetObject: TGLBaseSceneObject;

viewport bounding radius per distance unit

Private FLastDirection: TGLVector;

This item has no description.

Private FCameraStyle: TGLCameraStyle;

Not persistent

Private FKeepFOVMode: TGLCameraKeepFOVMode;

This item has no description.

Private FSceneScale: Single;

This item has no description.

Private FDeferredApply: TNotifyEvent;

This item has no description.

Private FOnCustomPerspective: TOnCustomPerspective;

This item has no description.

Private FDesign: Boolean;

This item has no description.

Private FFOVY: Double;

This item has no description.

Private FFOVX: Double;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AbsoluteEyeSpaceVector(forwardDistance, rightDistance, upDistance: Single): TGLVector;

Computes the absolute vector corresponding to the eye-space translations.

Public function AbsoluteRightVectorToTarget: TGLVector;

Computes the absolute normalized right vector to the camera target. If no target is defined, AbsoluteRight is returned.

Public function AbsoluteUpVectorToTarget: TGLVector;

Computes the absolute normalized up vector to the camera target. If no target is defined, AbsoluteUpt is returned.

Public function AbsoluteVectorToTarget: TGLVector;

Computes the absolute normalized vector to the camera target. If no target is defined, AbsoluteDirection is returned.

Public function DistanceToTarget: Single;

Returns the distance from camera to target. If TargetObject is nil, returns 1.

Public function GetFieldOfView(const AViewportDimension: single): single;

Calculates the field of view in degrees, given a viewport dimension (width or height). F.i. you may wish to use the minimum of the two.

Public function PointInFront(const point: TGLVector): boolean; overload;

Returns true if a point is in front of the camera.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public function ScreenDeltaToVector(deltaX, deltaY: Integer; ratio: Single; const planeNormal: TGLVector): TGLVector;

Calculate an absolute translation vector from a screen vector. Ratio is applied to both screen delta, planeNormal should be the translation plane's normal.

Public function ScreenDeltaToVectorXY(deltaX, deltaY: Integer; ratio: Single): TGLVector;

Same as ScreenDeltaToVector but optimized for XY plane.

Public function ScreenDeltaToVectorXZ(deltaX, deltaY: Integer; ratio: Single): TGLVector;

Same as ScreenDeltaToVector but optimized for XZ plane.

Public function ScreenDeltaToVectorYZ(deltaX, deltaY: Integer; ratio: Single): TGLVector;

Same as ScreenDeltaToVector but optimized for YZ plane.

Public procedure AdjustDistanceToTarget(distanceRatio: Single);

Adjusts distance from camera to target by applying a ratio. If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Only the camera's position is changed.

Public procedure Apply;

Apply camera transformation

Public procedure ApplyPerspective(const AViewport: TRectangle; AWidth, AHeight: Integer; ADPI: Integer);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure AutoLeveling(Factor: Single);

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure MoveAllAroundTarget(pitchDelta, turnDelta :Single);

Change camera's position to make it move all around its target. If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Camera's Up and Direction properties are changed. Angle deltas are in degrees.

Public procedure MoveAroundTarget(pitchDelta, turnDelta: Single);

Change camera's position to make it move around its target. If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Camera's Up and Direction properties are unchanged. Angle deltas are in degrees, camera parent's coordinates should be identity. Tip : make the camera a child of a "target" dummycube and make it a target the dummycube. Now, to pan across the scene, just move the dummycube, to change viewing angle, use this method.

Public procedure MoveInEyeSpace(forwardDistance, rightDistance, upDistance: Single);

Moves the camera in eye space coordinates.

Public procedure MoveTargetInEyeSpace(forwardDistance, rightDistance, upDistance: Single);

Moves the target in eye space coordinates.

Public procedure Reset(aSceneBuffer: TGLSceneBuffer);

This item has no description.

Public procedure RotateObject(obj: TGLBaseSceneObject; pitchDelta, turnDelta: Single; rollDelta: Single = 0);

This item has no description.

Public procedure RotateTarget(pitchDelta, turnDelta: Single; rollDelta: Single = 0);

This item has no description.

Public procedure SetFieldOfView(const AFieldOfView, AViewportDimension: single);

Sets the FocalLength in degrees, given a field of view and a viewport dimension (width or height).

Public procedure ZoomAll(aSceneBuffer: TGLSceneBuffer);

Position the camera so that the whole scene can be seen

Properties

Published property CameraStyle: TGLCameraStyle read FCameraStyle write SetCameraStyle default csPerspective;

Adjust the camera style. Three styles are available : csPerspective, the default value for perspective projection csOrthogonal, for orthogonal (or isometric) projection. csOrtho2D, setups orthogonal 2D projection in which 1 unit (in x or y) represents 1 pixel. csInfinitePerspective, for perspective view without depth limit. csKeepCamAnglePerspective, for perspective view with keeping aspect on view resize. csCustom, setup is deferred to the OnCustomPerspective event.

Published property DepthOfView: Single read FDepthOfView write SetDepthOfView;

Depth of field/view. Adjusts the maximum distance, beyond which objects will be clipped (ie. not visisble). You must adjust this value if you are experiencing disappearing objects (increase the value) of Z-Buffer crawling (decrease the value). Z-Buffer crawling happens when depth of view is too large and the Z-Buffer precision cannot account for all that depth accurately : objects farther overlap closer objects and vice-versa. Note that this value is ignored in cSOrtho2D mode.

Published property Direction;

This item has no description.

Published property FocalLength: Single read FFocalLength write SetFocalLength;

Focal Length of the camera. Adjusting this value allows for lens zooming effects (use SceneScale for linear zooming). This property affects near/far planes clipping.

Published property KeepFOVMode: TGLCameraKeepFOVMode read FKeepFOVMode write SetKeepFOVMode default ckmHorizontalFOV;

Keep camera angle mode. When CameraStyle is csKeepCamAnglePerspective, select which camera angle you want to keep. kaHeight, for Keep Height oriented camera angle kaWidth, for Keep Width oriented camera angle

Public property NearPlane: Single read FNearPlane;

Nearest clipping plane for the frustum. This value depends on the FocalLength and DepthOfView fields and is calculated to minimize Z-Buffer crawling as suggested by the OpenGL documentation.

Published property NearPlaneBias: Single read FNearPlaneBias write SetNearPlaneBias stored StoreNearPlaneBias;

Scaling bias applied to near-plane calculation. Values inferior to one will move the nearplane nearer, and also reduce medium/long range Z-Buffer precision, values superior to one will move the nearplane farther, and also improve medium/long range Z-Buffer precision.

Published property OnCustomPerspective: TOnCustomPerspective read FOnCustomPerspective write FOnCustomPerspective;

Custom perspective event. This event allows you to specify your custom perpective, either with a glFrustrum, a glOrtho or whatever method suits you. You must compute viewPortRadius for culling to work. This event is only called if CameraStyle is csCustom.

Published property OnProgress;

This item has no description.

Published property Position;

This item has no description.

Published property SceneScale: Single read FSceneScale write SetSceneScale stored StoreSceneScale;

Scene scaling for camera point. This is a linear 2D scaling of the camera's output, allows for linear zooming (use FocalLength for lens zooming).

Published property TargetObject: TGLBaseSceneObject read FTargetObject write SetTargetObject;

If set, camera will point to this object. When camera is pointing an object, the Direction vector is ignored and the Up vector is used as an absolute vector to the up.

Published property Up;


GLSysHelp v.2.5: GLS.Scene: Class TGLScene

Class TGLScene

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLScene = class(TGLUpdateAbleComponent)

Description

Scene component class. The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TGLBaseSceneObject. It will usually contain one or more TGLCamera object, which can be referred by a Viewer component for rendering purposes. The scene's objects can be accessed directly from code (as regular components), but those are edited with a specific editor (double-click on the TGLScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TGLBaseSceneObject.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLScene

Overview

Fields

Private | FUpdateCount: Integer;
Private | FObjects: TGLSceneRootObject;
Private | FBaseContext: TGLContext;
Private | FLights: TGLPersistentObjectList;
Private | FBuffers: TGLPersistentObjectList;
Private | FCurrentGLCamera: TGLCamera;
Private | FCurrentBuffer: TGLSceneBuffer;
Private | FObjectsSorting: TGLObjectsSorting;
Private | FVisibilityCulling: TGLVisibilityCulling;
Private | FOnBeforeProgress: TGLProgressEvent;
Private | FOnProgress: TGLProgressEvent;
Private | FCurrentDeltaTime: Double;
Private | FInitializableObjects: TGLInitializableObjectList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FindSceneObject(const AName: string): TGLBaseSceneObject;
Public | function IsUpdating: Boolean;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): TGLBaseSceneObject;
Public | procedure AddBuffer(aBuffer: TGLSceneBuffer);
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure LoadFromStream(aStream: TStream);
Public | procedure LoadFromTextFile(const fileName: string);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure Progress(const deltaTime, newTime: Double);
Public | procedure RemoveBuffer(aBuffer: TGLSceneBuffer);
Public | procedure SaveToFile(const fileName: string);
Public | procedure SaveToStream(aStream: TStream);
Public | procedure SaveToTextFile(const fileName: string);
Public | procedure SetupLights(maxLights: Integer);
Public | procedure ShutdownAllLights;

Properties

Public | property CurrentBuffer: TGLSceneBuffer read FCurrentBuffer;
Public | property CurrentDeltaTime: Double read FCurrentDeltaTime;
Public | property CurrentGLCamera: TGLCamera read FCurrentGLCamera;
Public | property InitializableObjects: TGLInitializableObjectList read FInitializableObjects;
Public | property Lights: TGLPersistentObjectList read FLights;
Public | property Objects: TGLSceneRootObject read FObjects;
Published | property ObjectsSorting: TGLObjectsSorting read FObjectsSorting write SetObjectsSorting default osRenderBlendedLast;
Published | property OnBeforeProgress: TGLProgressEvent read FOnBeforeProgress write FOnBeforeProgress;
Published | property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;
Published | property VisibilityCulling: TGLVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcNone;

Description

Fields

Private FUpdateCount: Integer;

This item has no description.

Private FObjects: TGLSceneRootObject;

This item has no description.

Private FBaseContext: TGLContext;

This item has no description.

Private FLights: TGLPersistentObjectList;

reference, not owned!

Private FBuffers: TGLPersistentObjectList;

reference, not owned!

Private FCurrentGLCamera: TGLCamera;

This item has no description.

Private FCurrentBuffer: TGLSceneBuffer;

This item has no description.

Private FObjectsSorting: TGLObjectsSorting;

This item has no description.

Private FVisibilityCulling: TGLVisibilityCulling;

This item has no description.

Private FOnBeforeProgress: TGLProgressEvent;

This item has no description.

Private FOnProgress: TGLProgressEvent;

This item has no description.

Private FCurrentDeltaTime: Double;

This item has no description.

Private FInitializableObjects: TGLInitializableObjectList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindSceneObject(const AName: string): TGLBaseSceneObject;

This item has no description.

Public function IsUpdating: Boolean;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): TGLBaseSceneObject;

Calculates, finds and returns the first object intercepted by the ray. Returns nil if no intersection was found. This function will be accurate only for objects that overrided their RayCastIntersect method with accurate code, otherwise, bounding sphere intersections will be returned.

Public procedure AddBuffer(aBuffer: TGLSceneBuffer);

This item has no description.

Public procedure BeginUpdate;

This item has no description.

Public procedure EndUpdate;

This item has no description.

Public procedure LoadFromFile(const fileName: string);

Load the scene from a file. Existing objects/lights/cameras are freed, then the file is loaded. Delphi's IDE is not handling this behaviour properly yet, ie. if you load a scene in the IDE, objects will be properly loaded, but no declare will be placed in the code.

Public procedure LoadFromStream(aStream: TStream);

This item has no description.

Public procedure LoadFromTextFile(const fileName: string);

Load the scene from a text files. See LoadFromFile for details.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure Progress(const deltaTime, newTime: Double);

This item has no description.

Public procedure RemoveBuffer(aBuffer: TGLSceneBuffer);

This item has no description.

Public procedure SaveToFile(const fileName: string);

Saves the scene to a file (recommended extension : .GLSM)

Public procedure SaveToStream(aStream: TStream);

This item has no description.

Public procedure SaveToTextFile(const fileName: string);

Saves the scene to a text file

Public procedure SetupLights(maxLights: Integer);

This item has no description.

Public procedure ShutdownAllLights;

This item has no description.

Properties

Public property CurrentBuffer: TGLSceneBuffer read FCurrentBuffer;

This item has no description.

Public property CurrentDeltaTime: Double read FCurrentDeltaTime;

This item has no description.

Public property CurrentGLCamera: TGLCamera read FCurrentGLCamera;

This item has no description.

Public property InitializableObjects: TGLInitializableObjectList read FInitializableObjects;

List of objects that request to be initialized when rendering context is active. They are removed automaticly from this list once initialized.

Public property Lights: TGLPersistentObjectList read FLights;

This item has no description.

Public property Objects: TGLSceneRootObject read FObjects;

This item has no description.

Published property ObjectsSorting: TGLObjectsSorting read FObjectsSorting write SetObjectsSorting default osRenderBlendedLast;

Defines default ObjectSorting option for scene objects.

Published property OnBeforeProgress: TGLProgressEvent read FOnBeforeProgress write FOnBeforeProgress;

This item has no description.

Published property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;

This item has no description.

Published property VisibilityCulling: TGLVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcNone;

Defines default VisibilityCulling option for scene objects.


GLSysHelp v.2.5: GLS.Scene: Class TGLFogEnvironment

Class TGLFogEnvironment

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLFogEnvironment = class(TGLUpdateAbleObject)

Description

Parameters for fog environment in a scene. The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.

Hierarchy

  • TGLUpdateAbleObject
  • TGLFogEnvironment

Overview

Fields

Private | FSceneBuffer: TGLSceneBuffer;
Private | FFogColor: TGLColor;
Private | FFogStart: Single;
Private | FFogEnd: Single;
Private | FFogMode: TFogMode;
Private | FFogDistance: TFogDistance;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsAtDefaultValues: Boolean;
Public | procedure ApplyFog;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property FogColor: TGLColor read FFogColor write SetFogColor;
Published | property FogDistance: TFogDistance read FFogDistance write SetFogDistance default fdDefault;
Published | property FogEnd: Single read FFogEnd write SetFogEnd;
Published | property FogMode: TFogMode read FFogMode write SetFogMode default fmLinear;
Published | property FogStart: Single read FFogStart write SetFogStart;

Description

Fields

Private FSceneBuffer: TGLSceneBuffer;

This item has no description.

Private FFogColor: TGLColor;

This item has no description.

Private FFogStart: Single;

alpha value means the fog density

Private FFogEnd: Single;

alpha value means the fog density

Private FFogMode: TFogMode;

This item has no description.

Private FFogDistance: TFogDistance;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsAtDefaultValues: Boolean;

This item has no description.

Public procedure ApplyFog;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property FogColor: TGLColor read FFogColor write SetFogColor;

Color of the fog when it is at 100% intensity.

Published property FogDistance: TFogDistance read FFogDistance write SetFogDistance default fdDefault;

Adjusts the formula used for calculating fog distances. This option is honoured if and only if the OpenGL ICD supports the GL_NV_fog_distance extension, otherwise, it is ignored. fdDefault: let OpenGL use its default formula fdEyeRadial: uses radial "true" distance (best quality) fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster)

Published property FogEnd: Single read FFogEnd write SetFogEnd;

Maximum distance for fog, what is farther is at 100% fog intensity.

Published property FogMode: TFogMode read FFogMode write SetFogMode default fmLinear;

The formula used for converting distance to fog intensity.

Published property FogStart: Single read FFogStart write SetFogStart;

Minimum distance for fog, what is closer is not affected.


GLSysHelp v.2.5: GLS.Scene: Class TGLSceneBuffer

Class TGLSceneBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLSceneBuffer = class(TGLUpdateAbleObject)

Description

Encapsulates a frame/rendering buffer.

Hierarchy

  • TGLUpdateAbleObject
  • TGLSceneBuffer

Overview

Fields

Private | FRendering: Boolean;
Private | FRenderingContext: TGLContext;
Private | FAfterRenderEffects: TGLPersistentObjectList;
Private | FViewMatrixStack: array of TGLMatrix;
Private | FProjectionMatrixStack: array of TGLMatrix;
Private | FBaseProjectionMatrix: TGLMatrix;
Private | FCameraAbsolutePosition: TGLVector;
Private | FViewPort: TRectangle;
Private | FSelector: TGLBaseSelectTechnique;
Private | FFaceCulling: Boolean;
Private | FFogEnable: Boolean;
Private | FLighting: Boolean;
Private | FDepthTest: Boolean;
Private | FBackgroundColor: TColor;
Private | FBackgroundAlpha: Single;
Private | FAmbientColor: TGLColor;
Private | FAntiAliasing: TGLAntiAliasing;
Private | FDepthPrecision: TGLDepthPrecision;
Private | FColorDepth: TGLColorDepth;
Private | FContextOptions: TGLContextOptions;
Private | FShadeModel: TGLShadeModel;
Private | FRenderDPI: Integer;
Private | FFogEnvironment: TGLFogEnvironment;
Private | FAccumBufferBits: Integer;
Private | FLayer: TGLContextLayer;
Private | FCamera: TGLCamera;
Private | FFreezeBuffer: Pointer;
Private | FFreezed: Boolean;
Private | FFreezedViewPort: TRectangle;
Private | FFrameCount: Longint;
Private | FFramesPerSecond: Single;
Private | FFirstPerfCounter: Int64;
Private | FLastFrameTime: Single;
Private | FOnChange: TNotifyEvent;
Private | FOnStructuralChange: TNotifyEvent;
Private | FOnPrepareGLContext: TNotifyEvent;
Private | FBeforeRender: TNotifyEvent;
Private | FViewerBeforeRender: TNotifyEvent;
Private | FPostRender: TNotifyEvent;
Private | FAfterRender: TNotifyEvent;
Private | FInitiateRendering: TGLDirectRenderEvent;
Private | FWrapUpRendering: TGLDirectRenderEvent;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function Acceleration: TGLContextAcceleration; inline;
Public | function CreateSnapShot: TGLImage;
Public | function CreateSnapShotBitmap: TBitmap;
Public | function GetPickedObject(x, y: Integer): TGLBaseSceneObject;
Public | function GetPickedObjects(const rect: TRect; objectCountGuess: Integer = 64): TGLPickList;
Public | function GetPixelColor(x, y: Integer): TColor;
Public | function GetPixelDepth(x, y: Integer): Single;
Public | function Height: Integer;
Public | function ModelMatrix: TGLMatrix; deprecated;
Public | function OrthoScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;
Public | function PixelDepthToDistance(aDepth: Single): Single;
Public | function PixelRayToWorld(x, y: Integer): TAffineVector;
Public | function PixelToDistance(x, y: integer): Single;
Public | function ProjectionMatrix: TGLMatrix; deprecated;
Public | function RCInstantiated: Boolean;
Public | function ScreenToVector(const aPoint: TGLVector): TGLVector; overload;
Public | function ScreenToVector(const x, y: Integer): TGLVector; overload;
Public | function ScreenToVector(const aPoint: TAffineVector): TAffineVector; overload;
Public | function ScreenToWorld(const aPoint: TAffineVector): TAffineVector; overload;
Public | function ScreenToWorld(const aPoint: TGLVector): TGLVector; overload;
Public | function ScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;
Public | function ScreenVectorIntersectWithPlane( const aScreenPoint: TGLVector; const planePoint, planeNormal: TGLVector; var intersectPoint: TGLVector): Boolean;
Public | function ScreenVectorIntersectWithPlaneXY( const aScreenPoint: TGLVector; const z: Single; var intersectPoint: TGLVector): Boolean;
Public | function ScreenVectorIntersectWithPlaneXZ( const aScreenPoint: TGLVector; const y: Single; var intersectPoint: TGLVector): Boolean;
Public | function ScreenVectorIntersectWithPlaneYZ( const aScreenPoint: TGLVector; const x: Single; var intersectPoint: TGLVector): Boolean;
Public | function VectorToScreen(const VectToCam: TAffineVector): TAffineVector;
Public | function ViewMatrix: TGLMatrix; deprecated;
Public | function Width: Integer;
Public | function WorldToScreen(const aPoint: TGLVector): TGLVector; overload;
Public | function WorldToScreen(const aPoint: TAffineVector): TAffineVector; overload;
Public | procedure ClearBuffers; inline;
Public | procedure CopyToTexture(aTexture: TGLTexture; xSrc, ySrc, AWidth, AHeight: Integer; xDest, yDest: Integer; glCubeFace: Cardinal = 0); overload;
Public | procedure CopyToTexture(aTexture: TGLTexture); overload;
Public | procedure CreateRC(AWindowHandle: HWND; memoryContext: Boolean; BufferCount: integer = 1); overload;
Public | procedure DestroyRC;
Public | procedure Freeze;
Public | procedure Melt;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyMouseMove(Shift: TShiftState; X, Y: Integer);
Public | procedure PickObjects(const rect: TRect; pickList: TGLPickList; objectCountGuess: Integer);
Public | procedure PopProjectionMatrix; deprecated;
Public | procedure PopViewMatrix; deprecated;
Public | procedure PushProjectionMatrix(const newMatrix: TGLMatrix); deprecated;
Public | procedure PushViewMatrix(const newMatrix: TGLMatrix); deprecated;
Public | procedure Render(baseObject: TGLBaseSceneObject); overload;
Public | procedure Render; overload; inline;
Public | procedure RenderScene(aScene: TGLScene; const viewPortSizeX, viewPortSizeY: Integer; drawState: TGLDrawState; baseObject: TGLBaseSceneObject);
Public | procedure RenderToBitmap(ABitmap: TBitmap; DPI: Integer = 0);
Public | procedure RenderToFile(const AFile: string; bmpWidth, bmpHeight: Integer); overload;
Public | procedure RenderToFile(const AFile: string; DPI: Integer = 0); overload;
Public | procedure ResetPerformanceMonitor;
Public | procedure Resize(newLeft, newTop, newWidth, newHeight: Integer);
Public | procedure SaveAsFloatToFile(const aFilename: string);
Public | procedure SetViewPort(X, Y, W, H: Integer);
Public | procedure ShowInfo(Modal: boolean = false);
Public | procedure WorldToScreen(points: PGLVector; nbPoints: Integer); overload;
Private | procedure SetLayer(const Value: TGLContextLayer);

Properties

Published | property AccumBufferBits: Integer read FAccumBufferBits write SetAccumBufferBits default 0;
Published | property AfterRender: TNotifyEvent read FAfterRender write FAfterRender stored False;
Published | property AmbientColor: TGLColor read FAmbientColor write SetAmbientColor;
Published | property AntiAliasing: TGLAntiAliasing read FAntiAliasing write SetAntiAliasing default aaDefault;
Public | property BackgroundAlpha: Single read FBackgroundAlpha write SetBackgroundAlpha;
Published | property BackgroundColor: TColor read FBackgroundColor write SetBackgroundColor default clBtnFace;
Public | property BaseProjectionMatrix: TGLMatrix read FBaseProjectionMatrix;
Published | property BeforeRender: TNotifyEvent read FBeforeRender write FBeforeRender stored False;
Public | property Camera: TGLCamera read FCamera write SetCamera;
Published | property ColorDepth: TGLColorDepth read FColorDepth write SetColorDepth default cdDefault;
Published | property ContextOptions: TGLContextOptions read FContextOptions write SetContextOptions default [roDoubleBuffer, roRenderToWindow, roDebugContext];
Published | property DepthPrecision: TGLDepthPrecision read FDepthPrecision write SetDepthPrecision default dpDefault;
Published | property DepthTest: Boolean read FDepthTest write SetDepthTest default True;
Published | property FaceCulling: Boolean read FFaceCulling write SetFaceCulling default True;
Published | property FogEnable: Boolean read FFogEnable write SetFogEnable default False;
Published | property FogEnvironment: TGLFogEnvironment read FFogEnvironment write SetGLFogEnvironment stored StoreFog;
Public | property FramesPerSecond: Single read FFramesPerSecond;
Public | property Freezed: Boolean read FFreezed;
Published | property InitiateRendering: TGLDirectRenderEvent read FInitiateRendering write FInitiateRendering stored False;
Public | property LastFrameTime: Single read FLastFrameTime;
Public | property Layer: TGLContextLayer read FLayer write SetLayer default clMainPlane;
Published | property Lighting: Boolean read FLighting write SetLighting default True;
Public | property LimitOf[Which: TGLLimitType]: Integer read GetLimit;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange stored False;
Published | property OnStructuralChange: TNotifyEvent read FOnStructuralChange write FOnStructuralChange stored False;
Published | property PostRender: TNotifyEvent read FPostRender write FPostRender stored False;
Public | property Rendering: Boolean read FRendering;
Public | property RenderingContext: TGLContext read FRenderingContext;
Published | property ShadeModel: TGLShadeModel read FShadeModel write SetShadeModel default smDefault;
Public | property ViewerBeforeRender: TNotifyEvent read FViewerBeforeRender write FViewerBeforeRender stored False;
Public | property ViewPort: TRectangle read FViewPort;
Published | property WrapUpRendering: TGLDirectRenderEvent read FWrapUpRendering write FWrapUpRendering stored False;

Description

Fields

Private FRendering: Boolean;

Internal state

Private FRenderingContext: TGLContext;

This item has no description.

Private FAfterRenderEffects: TGLPersistentObjectList;

This item has no description.

Private FViewMatrixStack: array of TGLMatrix;

This item has no description.

Private FProjectionMatrixStack: array of TGLMatrix;

This item has no description.

Private FBaseProjectionMatrix: TGLMatrix;

This item has no description.

Private FCameraAbsolutePosition: TGLVector;

This item has no description.

Private FViewPort: TRectangle;

This item has no description.

Private FSelector: TGLBaseSelectTechnique;

This item has no description.

Private FFaceCulling: Boolean;

Options & User Properties

Private FFogEnable: Boolean;

Options & User Properties

Private FLighting: Boolean;

Options & User Properties

Private FDepthTest: Boolean;

This item has no description.

Private FBackgroundColor: TColor;

This item has no description.

Private FBackgroundAlpha: Single;

This item has no description.

Private FAmbientColor: TGLColor;

This item has no description.

Private FAntiAliasing: TGLAntiAliasing;

This item has no description.

Private FDepthPrecision: TGLDepthPrecision;

This item has no description.

Private FColorDepth: TGLColorDepth;

This item has no description.

Private FContextOptions: TGLContextOptions;

This item has no description.

Private FShadeModel: TGLShadeModel;

This item has no description.

Private FRenderDPI: Integer;

This item has no description.

Private FFogEnvironment: TGLFogEnvironment;

This item has no description.

Private FAccumBufferBits: Integer;

This item has no description.

Private FLayer: TGLContextLayer;

This item has no description.

Private FCamera: TGLCamera;

Cameras

Private FFreezeBuffer: Pointer;

Freezing

Private FFreezed: Boolean;

This item has no description.

Private FFreezedViewPort: TRectangle;

This item has no description.

Private FFrameCount: Longint;

Monitoring

Private FFramesPerSecond: Single;

This item has no description.

Private FFirstPerfCounter: Int64;

This item has no description.

Private FLastFrameTime: Single;

This item has no description.

Private FOnChange: TNotifyEvent;

Events

Private FOnStructuralChange: TNotifyEvent;

This item has no description.

Private FOnPrepareGLContext: TNotifyEvent;

This item has no description.

Private FBeforeRender: TNotifyEvent;

This item has no description.

Private FViewerBeforeRender: TNotifyEvent;

This item has no description.

Private FPostRender: TNotifyEvent;

This item has no description.

Private FAfterRender: TNotifyEvent;

This item has no description.

Private FInitiateRendering: TGLDirectRenderEvent;

This item has no description.

Private FWrapUpRendering: TGLDirectRenderEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Acceleration: TGLContextAcceleration; inline;

Indicates hardware acceleration support

Public function CreateSnapShot: TGLImage;

Creates a TGLBitmap32 that is a snapshot of current OpenGL content. When possible, use this function instead of RenderToBitmap, it won't request a redraw and will be significantly faster. The returned TGLBitmap32 should be freed by calling code.

Public function CreateSnapShotBitmap: TBitmap;

Creates a bitmap that is a snapshot of current OpenGL content.

Public function GetPickedObject(x, y: Integer): TGLBaseSceneObject;

Returns the nearest object at x, y coordinates or nil if there is none

Public function GetPickedObjects(const rect: TRect; objectCountGuess: Integer = 64): TGLPickList;

Returns a PickList with objects in Rect area. Returned list should be freed by caller. Objects are sorted by depth (nearest objects first).

Public function GetPixelColor(x, y: Integer): TColor;

Returns the color of the pixel at x, y in the frame buffer

Public function GetPixelDepth(x, y: Integer): Single;

Returns the raw depth (Z buffer) of the pixel at x, y in the frame buffer. This value does not map to the actual eye-object distance, but to a depth buffer value in the [0; 1] range.

Public function Height: Integer;

This item has no description.

Public function ModelMatrix: TGLMatrix; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public function OrthoScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;

Converts a screen pixel coordinate into 3D coordinates for orthogonal projection. This function accepts standard canvas coordinates, with (0,0) being the top left corner, and returns, when the camera is in orthogonal mode, the corresponding 3D world point that is in the camera's plane.

Public function PixelDepthToDistance(aDepth: Single): Single;

Converts a raw depth (Z buffer value) to frustrum distance. This calculation is only accurate for the pixel at the centre of the viewer, because it does not take into account that the corners of the frustrum are further from the eye than its centre.

Public function PixelRayToWorld(x, y: Integer): TAffineVector;

Calculates a 3D coordinate from screen position and ZBuffer. This function returns a world absolute coordinate from a 2D point in the viewer, the depth being extracted from the ZBuffer data (DepthTesting and ZBuffer must be enabled for this function to work). Note that ZBuffer precision is not linear and can be quite low on some boards (either from compression or resolution approximations).

Public function PixelToDistance(x, y: integer): Single;

Converts a raw depth (Z buffer value) to world distance. It also compensates for the fact that the corners of the frustrum are further from the eye, than its centre.

Public function ProjectionMatrix: TGLMatrix; deprecated;

Warning: this symbol is deprecated.

Returns the projection matrix in use or used for the last rendering.

Public function RCInstantiated: Boolean;

This item has no description.

Public function ScreenToVector(const aPoint: TGLVector): TGLVector; overload;

This item has no description.

Public function ScreenToVector(const x, y: Integer): TGLVector; overload;

This item has no description.

Public function ScreenToVector(const aPoint: TAffineVector): TAffineVector; overload;

Calculates the 3D vector corresponding to a 2D screen coordinate. The vector originates from the camera's absolute position and is expressed in absolute coordinates. Note that screen coord (0,0) is the lower left corner.

Public function ScreenToWorld(const aPoint: TAffineVector): TAffineVector; overload;

Converts a screen coordinate into world (3D) coordinates. This methods wraps a call to gluUnProject. Note that screen coord (0,0) is the lower left corner.

Public function ScreenToWorld(const aPoint: TGLVector): TGLVector; overload;

This item has no description.

Public function ScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;

Converts a screen pixel coordinate into 3D world coordinates. This function accepts standard canvas coordinates, with (0,0) being the top left corner.

Public function ScreenVectorIntersectWithPlane( const aScreenPoint: TGLVector; const planePoint, planeNormal: TGLVector; var intersectPoint: TGLVector): Boolean;

Calculates intersection between a plane and screen vector. If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneXY( const aScreenPoint: TGLVector; const z: Single; var intersectPoint: TGLVector): Boolean;

Calculates intersection between plane XY and screen vector. If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneXZ( const aScreenPoint: TGLVector; const y: Single; var intersectPoint: TGLVector): Boolean;

Calculates intersection between plane XZ and screen vector. If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneYZ( const aScreenPoint: TGLVector; const x: Single; var intersectPoint: TGLVector): Boolean;

Calculates intersection between plane YZ and screen vector. If an intersection is found, returns True and places result in intersectPoint.

Public function VectorToScreen(const VectToCam: TAffineVector): TAffineVector;

Calculates the 2D screen coordinate of a vector from the camera's absolute position and is expressed in absolute coordinates. Note that screen coord (0,0) is the lower left corner.

Public function ViewMatrix: TGLMatrix; deprecated;

Warning: this symbol is deprecated.

Returns the view matrix in use or used for the last rendering.

Public function Width: Integer;

This item has no description.

Public function WorldToScreen(const aPoint: TGLVector): TGLVector; overload;

This item has no description.

Public function WorldToScreen(const aPoint: TAffineVector): TAffineVector; overload;

Converts an absolute world coordinate into screen coordinate. This methods wraps a call to gluProject. Note that screen coord (0,0) is the lower left corner.

Public procedure ClearBuffers; inline;

This item has no description.

Public procedure CopyToTexture(aTexture: TGLTexture; xSrc, ySrc, AWidth, AHeight: Integer; xDest, yDest: Integer; glCubeFace: Cardinal = 0); overload;

This item has no description.

Public procedure CopyToTexture(aTexture: TGLTexture); overload;

This item has no description.

Public procedure CreateRC(AWindowHandle: HWND; memoryContext: Boolean; BufferCount: integer = 1); overload;

This item has no description.

Public procedure DestroyRC;

This item has no description.

Public procedure Freeze;

Freezes rendering leaving the last rendered scene on the buffer. This is usefull in windowed applications for temporarily stoping rendering (when moving the window, for example).

Public procedure Melt;

Restarts rendering after it was freezed.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure NotifyMouseMove(Shift: TShiftState; X, Y: Integer);

Design time notification

Public procedure PickObjects(const rect: TRect; pickList: TGLPickList; objectCountGuess: Integer);

Fills the PickList with objects in Rect area

Public procedure PopProjectionMatrix; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure PopViewMatrix; deprecated;

Warning: this symbol is deprecated.

Restore a View matrix previously pushed.

Public procedure PushProjectionMatrix(const newMatrix: TGLMatrix); deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure PushViewMatrix(const newMatrix: TGLMatrix); deprecated;

Warning: this symbol is deprecated.

Back up current View matrix and replace it with newMatrix. This method has no effect on the OpenGL matrix, only on the Buffer's matrix, and is intended for special effects rendering.

Public procedure Render(baseObject: TGLBaseSceneObject); overload;

Renders the scene on the viewer. You do not need to call this method, unless you explicitly want a render at a specific time. If you just want the control to get refreshed, use Invalidate instead.

Public procedure Render; overload; inline;

This item has no description.

Public procedure RenderScene(aScene: TGLScene; const viewPortSizeX, viewPortSizeY: Integer; drawState: TGLDrawState; baseObject: TGLBaseSceneObject);

This item has no description.

Public procedure RenderToBitmap(ABitmap: TBitmap; DPI: Integer = 0);

Render the scene to a bitmap at given DPI. DPI = "dots per inch". The "magic" DPI of the screen is 96 under Windows.

Public procedure RenderToFile(const AFile: string; bmpWidth, bmpHeight: Integer); overload;

Renders to bitmap of given size, then saves it to a file. DPI is adjusted to make the bitmap similar to the viewer.

Public procedure RenderToFile(const AFile: string; DPI: Integer = 0); overload;

Render the scene to a bitmap at given DPI and saves it to a file. DPI = "dots per inch". The "magic" DPI of the screen is 96 under Windows.

Public procedure ResetPerformanceMonitor;

Resets the perfomance monitor and begin a new statistics set. See FramesPerSecond.

Public procedure Resize(newLeft, newTop, newWidth, newHeight: Integer);

This item has no description.

Public procedure SaveAsFloatToFile(const aFilename: string);

Save as raw float data to a file

Public procedure SetViewPort(X, Y, W, H: Integer);

This item has no description.

Public procedure ShowInfo(Modal: boolean = false);

Displays a window with info on current OpenGL ICD and context.

Public procedure WorldToScreen(points: PGLVector; nbPoints: Integer); overload;

Converts a set of point absolute world coordinates into screen coordinates.

Private procedure SetLayer(const Value: TGLContextLayer);

This item has no description.

Properties

Published property AccumBufferBits: Integer read FAccumBufferBits write SetAccumBufferBits default 0;

Number of precision bits for the accumulation buffer.

Published property AfterRender: TNotifyEvent read FAfterRender write FAfterRender stored False;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property AmbientColor: TGLColor read FAmbientColor write SetAmbientColor;

Scene ambient color vector. This ambient color is defined independantly from all lightsources, which can have their own ambient components.

Published property AntiAliasing: TGLAntiAliasing read FAntiAliasing write SetAntiAliasing default aaDefault;

AntiAliasing option. Ignored if not hardware supported, currently based on ARB_multisample.

Public property BackgroundAlpha: Single read FBackgroundAlpha write SetBackgroundAlpha;

Adjusts background alpha channel.

Published property BackgroundColor: TColor read FBackgroundColor write SetBackgroundColor default clBtnFace;

Color used for filling the background prior to any rendering.

Public property BaseProjectionMatrix: TGLMatrix read FBaseProjectionMatrix;

Returns the base projection matrix in use or used for the last rendering. The "base" projection is (as of now) either identity or the pick matrix, ie. it is the matrix on which the perspective or orthogonal matrix gets applied.

Published property BeforeRender: TNotifyEvent read FBeforeRender write FBeforeRender stored False;

Triggered before the scene's objects get rendered. You may use this event to execute your own OpenGL rendering (usually background stuff).

Public property Camera: TGLCamera read FCamera write SetCamera;

The camera from which the scene is rendered. A camera is an object you can add and define in a TGLScene component.

Published property ColorDepth: TGLColorDepth read FColorDepth write SetColorDepth default cdDefault;

Color buffer depth. Default depth buffer is highest available (below and including 24 bits)

Published property ContextOptions: TGLContextOptions read FContextOptions write SetContextOptions default [roDoubleBuffer, roRenderToWindow, roDebugContext];

Context options allows to setup specifics of the rendering context. Not all contexts support all options.

Published property DepthPrecision: TGLDepthPrecision read FDepthPrecision write SetDepthPrecision default dpDefault;

Depth buffer precision. Default is highest available (below and including 24 bits)

Published property DepthTest: Boolean read FDepthTest write SetDepthTest default True;

DepthTest enabling. When DepthTest is enabled, objects closer to the camera will hide farther ones (via use of Z-Buffering). When DepthTest is disabled, the latest objects drawn/rendered overlap all previous objects, whatever their distance to the camera. Even when DepthTest is enabled, objects may chose to ignore depth testing through the osIgnoreDepthBuffer of their ObjectStyle property.

Published property FaceCulling: Boolean read FFaceCulling write SetFaceCulling default True;

Enable or disable face culling in the renderer. Face culling is used in hidden faces removal algorithms : each face is given a normal or 'outside' direction. When face culling is enabled, only faces whose normal points towards the observer are rendered.

Published property FogEnable: Boolean read FFogEnable write SetFogEnable default False;

Toggle to enable or disable the fog settings.

Published property FogEnvironment: TGLFogEnvironment read FFogEnvironment write SetGLFogEnvironment stored StoreFog;

Fog environment options. See TGLFogEnvironment.

Public property FramesPerSecond: Single read FFramesPerSecond;

Current FramesPerSecond rendering speed. You must keep the renderer busy to get accurate figures from this property. This is an average value, to reset the counter, call ResetPerfomanceMonitor.

Public property Freezed: Boolean read FFreezed;

Indicates if the Viewer is "frozen".

Published property InitiateRendering: TGLDirectRenderEvent read FInitiateRendering write FInitiateRendering stored False;

Triggered after BeforeRender, before rendering objects. This one is fired after the rci has been initialized and can be used to alter it or perform early renderings that require an rci, the Sender is the buffer.

Public property LastFrameTime: Single read FLastFrameTime;

Time (in second) spent to issue rendering order for the last frame. Be aware that since execution by the hardware isn't synchronous, this value may not be an accurate measurement of the time it took to render the last frame, it's a measurement of only the time it took to issue rendering orders.

Public property Layer: TGLContextLayer read FLayer write SetLayer default clMainPlane;

Specifies the layer plane that the rendering context is bound to.

Published property Lighting: Boolean read FLighting write SetLighting default True;

Toggle to enable or disable lighting calculations. When lighting is enabled, objects will be lit according to lightsources, when lighting is disabled, objects are rendered in their own colors, without any shading. Lighting does NOT generate shadows.

Public property LimitOf[Which: TGLLimitType]: Integer read GetLimit;

Retrieve one of the OpenGL limits for the current viewer. Limits include max texture size, OpenGL stack depth, etc.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange stored False;

Indicates a change in the scene or buffer options. A simple re-render is enough to take into account the changes.

Published property OnStructuralChange: TNotifyEvent read FOnStructuralChange write FOnStructuralChange stored False;

Indicates a structural change in the scene or buffer options. A reconstruction of the RC is necessary to take into account the changes (this may lead to a driver switch or lengthy operations).

Published property PostRender: TNotifyEvent read FPostRender write FPostRender stored False;

Triggered just after all the scene's objects have been rendered. The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering (usually for HUD, 2D overlays or after effects).

Public property Rendering: Boolean read FRendering;

Currently Rendering?

Public property RenderingContext: TGLContext read FRenderingContext;

Current rendering context. The context is a wrapper around platform-specific contexts (see TGLContext) and takes care of context activation and handle management.

Published property ShadeModel: TGLShadeModel read FShadeModel write SetShadeModel default smDefault;

Shade model. Default is "Smooth".

Public property ViewerBeforeRender: TNotifyEvent read FViewerBeforeRender write FViewerBeforeRender stored False;

Event reserved for viewer-specific uses.

Public property ViewPort: TRectangle read FViewPort;

ViewPort for current/last render

Published property WrapUpRendering: TGLDirectRenderEvent read FWrapUpRendering write FWrapUpRendering stored False;

Triggered after rendering all scene objects, before PostRender. This is the last point after which the rci becomes unavailable, the Sender is the buffer.


GLSysHelp v.2.5: GLS.Scene: Class TGLNonVisualViewer

Class TGLNonVisualViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLNonVisualViewer = class(TComponent)

Description

Base class for non-visual viewer. Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLNonVisualViewer

Overview

Fields

Private | FBuffer: TGLSceneBuffer;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FCubeMapRotIdx: Integer;
Private | FCubeMapZNear: Single;
Private | FCubeMapZFar: Single;
Private | FCubeMapTranslation: TAffineVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CopyToTexture(aTexture: TGLTexture); overload; virtual;
Public | procedure CopyToTexture(aTexture: TGLTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer); overload;
Public | procedure CopyToTextureMRT(aTexture: TGLTexture; BufferIndex: integer); overload; virtual;
Public | procedure CopyToTextureMRT(aTexture: TGLTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer; BufferIndex: integer); overload;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure Render(baseObject: TGLBaseSceneObject = nil); virtual; abstract;
Public | procedure RenderCubeMapTextures(cubeMapTexture: TGLTexture; zNear: Single = 0; zFar: Single = 0);

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TGLCamera read GetCamera write SetCamera;
Published | property Height: Integer read FHeight write SetHeight default 256;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Published | property Width: Integer read FWidth write SetWidth default 256;

Description

Fields

Private FBuffer: TGLSceneBuffer;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FCubeMapRotIdx: Integer;

This item has no description.

Private FCubeMapZNear: Single;

This item has no description.

Private FCubeMapZFar: Single;

This item has no description.

Private FCubeMapTranslation: TAffineVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CopyToTexture(aTexture: TGLTexture); overload; virtual;

This item has no description.

Public procedure CopyToTexture(aTexture: TGLTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer); overload;

This item has no description.

Public procedure CopyToTextureMRT(aTexture: TGLTexture; BufferIndex: integer); overload; virtual;

CopyToTexture for Multiple-Render-Target

Public procedure CopyToTextureMRT(aTexture: TGLTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer; BufferIndex: integer); overload;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure Render(baseObject: TGLBaseSceneObject = nil); virtual; abstract;

This item has no description.

Public procedure RenderCubeMapTextures(cubeMapTexture: TGLTexture; zNear: Single = 0; zFar: Single = 0);

Renders the 6 texture maps from a scene. The viewer is used to render the 6 images, one for each face of the cube, from the absolute position of the camera. This does NOT alter the content of the Pictures in the image, and will only change or define the content of textures as registered by OpenGL.

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered. You may use this event to execute your own OpenGL rendering.

Published property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;

Access to buffer properties.

Published property Camera: TGLCamera read GetCamera write SetCamera;

Camera from which the scene is rendered.

Published property Height: Integer read FHeight write SetHeight default 256;

This item has no description.

Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;

Triggered just after all the scene's objects have been rendered. The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.

Published property Width: Integer read FWidth write SetWidth default 256;


GLSysHelp v.2.5: GLS.Scene: Class TGLMemoryViewer

Class TGLMemoryViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Scene

Declaration

type TGLMemoryViewer = class(TGLNonVisualViewer)

Description

Component to render a scene to memory only. This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLNonVisualViewer
  • TGLMemoryViewer

Overview

Fields

Private FBufferCount: integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InstantiateRenderingContext;
Public | procedure Render(baseObject: TGLBaseSceneObject = nil); override;
Private | procedure SetBufferCount(const Value: integer);

Properties

Published property BufferCount: integer read FBufferCount write SetBufferCount default 1;

Description

Fields

Private FBufferCount: integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure InstantiateRenderingContext;

This item has no description.

Public procedure Render(baseObject: TGLBaseSceneObject = nil); override;

This item has no description.

Private procedure SetBufferCount(const Value: integer);

This item has no description.

Properties

Published property BufferCount: integer read FBufferCount write SetBufferCount default 1;

Set BufferCount > 1 for multiple render targets. Users should check if the corresponding extension (GL_ATI_draw_buffers) is supported. Current hardware limit is BufferCount = 4.


GLSysHelp v.2.5: GLS.SceneForm

Unit GLS.SceneForm

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.Classes
  • VCL.Controls
  • VCL.Forms
  • GLS.Scene
  • GLS.Context
  • GLS.Screen
  • GLS.SceneViewer

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFullScreenVideoMode |
Class TGLSceneForm |

Types

TGLFullScreenResolution = (...);

Constants

lcl_major = 0;
lcl_minor = 0;
lcl_release = 0;

Description

Types

TGLFullScreenResolution = (...);

Defines how GLSceneForm will handle fullscreen request fcWindowMaximize: Use current resolution (just maximize form and hide OS bars) fcNearestResolution: Change to nearest valid resolution from current window size fcManualResolution: Use FFullScreenVideoMode settings

Values
  • fcUseCurrent
  • fcNearestResolution
  • fcManualResolution

Constants

lcl_major = 0;

This item has no description.

lcl_minor = 0;

This item has no description.

lcl_release = 0;


GLSysHelp v.2.5: GLS.SceneForm: Class TGLFullScreenVideoMode

Class TGLFullScreenVideoMode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneForm

Declaration

type TGLFullScreenVideoMode = class(TPersistent)

Description

Screen mode settings

Hierarchy

  • TObject
  • TPersistent
  • TGLFullScreenVideoMode

Overview

Fields

Private | FOwner: TGLSceneForm;
Private | FEnabled: Boolean;
Private | FAltTabSupportEnable: Boolean;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FColorDepth: Integer;
Private | FFrequency: Integer;
Private | FResolutionMode: TGLFullScreenResolution;

Methods

Public | constructor Create(AOwner: TGLSceneForm);
Private | procedure SetAltTabSupportEnable(aValue: Boolean);
Private | procedure SetEnabled(aValue: Boolean);

Properties

Published | property AltTabSupportEnable: Boolean read FAltTabSupportEnable write SetAltTabSupportEnable default False;
Published | property ColorDepth: Integer read FColorDepth write FColorDepth;
Published | property Enabled: Boolean read FEnabled write SetEnabled default False;
Published | property Frequency: Integer read FFrequency write FFrequency;
Published | property Height: Integer read FHeight write FHeight;
Published | property ResolutionMode: TGLFullScreenResolution read FResolutionMode write FResolutionMode default fcUseCurrent;
Published | property Width: Integer read FWidth write FWidth;

Description

Fields

Private FOwner: TGLSceneForm;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FAltTabSupportEnable: Boolean;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FColorDepth: Integer;

This item has no description.

Private FFrequency: Integer;

This item has no description.

Private FResolutionMode: TGLFullScreenResolution;

This item has no description.

Methods

Public constructor Create(AOwner: TGLSceneForm);

This item has no description.

Private procedure SetAltTabSupportEnable(aValue: Boolean);

This item has no description.

Private procedure SetEnabled(aValue: Boolean);

This item has no description.

Properties

Published property AltTabSupportEnable: Boolean read FAltTabSupportEnable write SetAltTabSupportEnable default False;

This item has no description.

Published property ColorDepth: Integer read FColorDepth write FColorDepth;

This item has no description.

Published property Enabled: Boolean read FEnabled write SetEnabled default False;

This item has no description.

Published property Frequency: Integer read FFrequency write FFrequency;

This item has no description.

Published property Height: Integer read FHeight write FHeight;

This item has no description.

Published property ResolutionMode: TGLFullScreenResolution read FResolutionMode write FResolutionMode default fcUseCurrent;

This item has no description.

Published property Width: Integer read FWidth write FWidth;


GLSysHelp v.2.5: GLS.SceneForm: Class TGLSceneForm

Class TGLSceneForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneForm

Declaration

type TGLSceneForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGLSceneForm

Overview

Fields

Private | FBuffer: TGLSceneBuffer;
Private | FVSync: TGLVSyncMode;
Private | FOwnDC: HDC;
Private | FFullScreenVideoMode: TGLFullScreenVideoMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetAfterRender: TNotifyEvent;
Private | function GetBeforeRender: TNotifyEvent;
Private | function GetCamera: TGLCamera;
Private | function GetFieldOfView: single;
Private | function GetIsRenderingContextAvailable: Boolean;
Private | function GetPostRender: TNotifyEvent;
Public | procedure DestroyWnd; override;
Private | procedure LastFocus(var Mess: TMessage); message WM_ACTIVATE;
Private | procedure SetAfterRender(const val: TNotifyEvent);
Private | procedure SetBeforeRender(const val: TNotifyEvent);
Private | procedure SetBuffer(const val: TGLSceneBuffer);
Private | procedure SetCamera(const val: TGLCamera);
Private | procedure SetFieldOfView(const Value: single);
Private | procedure SetFullScreenVideoMode(AValue: TGLFullScreenVideoMode);
Private | procedure SetPostRender(const val: TNotifyEvent);
Private | procedure ShutdownFS;
Private | procedure StartupFS;
Private | procedure WMDestroy(var Message: TWMDestroy); message WM_DESTROY;
Private | procedure WMEraseBkgnd(var Message: TWMEraseBkgnd); message WM_ERASEBKGND;
Private | procedure WMPaint(var Message: TWMPaint); message WM_PAINT;
Private | procedure WMSize(var Message: TWMSize); message WM_SIZE;

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TGLCamera read GetCamera write SetCamera;
Published | property FieldOfView: single read GetFieldOfView write SetFieldOfView;
Published | property FullScreenVideoMode: TGLFullScreenVideoMode read FFullScreenVideoMode write SetFullScreenVideoMode;
Public | property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Public | property RenderDC: HDC read FOwnDC;
Published | property VSync: TGLVSyncMode read FVSync write FVSync default vsmNoSync;

Description

Fields

Private FBuffer: TGLSceneBuffer;

This item has no description.

Private FVSync: TGLVSyncMode;

This item has no description.

Private FOwnDC: HDC;

This item has no description.

Private FFullScreenVideoMode: TGLFullScreenVideoMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAfterRender: TNotifyEvent;

This item has no description.

Private function GetBeforeRender: TNotifyEvent;

This item has no description.

Private function GetCamera: TGLCamera;

This item has no description.

Private function GetFieldOfView: single;

This item has no description.

Private function GetIsRenderingContextAvailable: Boolean;

This item has no description.

Private function GetPostRender: TNotifyEvent;

This item has no description.

Public procedure DestroyWnd; override;

This item has no description.

Private procedure LastFocus(var Mess: TMessage); message WM_ACTIVATE;

This item has no description.

Private procedure SetAfterRender(const val: TNotifyEvent);

This item has no description.

Private procedure SetBeforeRender(const val: TNotifyEvent);

This item has no description.

Private procedure SetBuffer(const val: TGLSceneBuffer);

This item has no description.

Private procedure SetCamera(const val: TGLCamera);

This item has no description.

Private procedure SetFieldOfView(const Value: single);

This item has no description.

Private procedure SetFullScreenVideoMode(AValue: TGLFullScreenVideoMode);

This item has no description.

Private procedure SetPostRender(const val: TNotifyEvent);

This item has no description.

Private procedure ShutdownFS;

This item has no description.

Private procedure StartupFS;

This item has no description.

Private procedure WMDestroy(var Message: TWMDestroy); message WM_DESTROY;

This item has no description.

Private procedure WMEraseBkgnd(var Message: TWMEraseBkgnd); message WM_ERASEBKGND;

This item has no description.

Private procedure WMPaint(var Message: TWMPaint); message WM_PAINT;

This item has no description.

Private procedure WMSize(var Message: TWMSize); message WM_SIZE;

This item has no description.

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered. You may use this event to execute your own OpenGL rendering.

Published property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;

Access to buffer properties.

Published property Camera: TGLCamera read GetCamera write SetCamera;

Camera from which the scene is rendered.

Published property FieldOfView: single read GetFieldOfView write SetFieldOfView;

Returns or sets the field of view for the viewer, in degrees. This value depends on the camera and the width and height of the scene. The value isn't persisted, if the width/height or camera.focallength is changed, FieldOfView is changed also.

Published property FullScreenVideoMode: TGLFullScreenVideoMode read FFullScreenVideoMode write SetFullScreenVideoMode;

This item has no description.

Public property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;

This item has no description.

Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;

Triggered just after all the scene's objects have been rendered. The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.

Public property RenderDC: HDC read FOwnDC;

This item has no description.

Published property VSync: TGLVSyncMode read FVSync write FVSync default vsmNoSync;

Specifies if the refresh should be synchronized with the VSync signal. If the underlying OpenGL ICD does not support the WGL_EXT_swap_control extension, this property is ignored.


GLSysHelp v.2.5: GLS.SceneRegister

Unit GLS.SceneRegister

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • WinApi.Windows
  • System.Classes
  • System.SysUtils
  • System.TypInfo
  • VCL.Forms
  • VCL.Dialogs
  • VCL.Controls
  • VCL.StdCtrls
  • VCL.Graphics
  • ToolsAPI
  • DesignIntf
  • DesignEditors
  • VCLEditors
  • GLS.Context
  • GLS.Scene
  • GLS.Color
  • GLS.ImageUtils
  • GLS.ObjectManager
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLibMaterialNameProperty |
Class TGLSceneViewerEditor |
Class TGLSceneEditor |
Class TGLResolutionProperty |
Class TGLTextureProperty |
Class TGLTextureImageProperty |
Class TGLImageClassProperty |
Class TGLColorProperty |
Class TGLSoundFileProperty |
Class TGLSoundNameProperty |
Class TGLCoordinatesProperty |
Class TGLMaterialProperty |
Class TGLGUILayoutEditor |
Class TGLReuseableDefaultEditor |
Class TGLMaterialLibraryEditor |
Class TGLAnimationNameProperty |
Class TGLSoundLibrarySelectionEditor |
Class TGLBaseSceneObjectSelectionEditor |
Class TGLSArchiveManagerEditor |
Class TGLMaterialComponentNameProperty |
Class TGLLibTextureNameProperty |
Class TGLLibSamplerNameProperty |
Class TGLLibCombinerNameProperty |
Class TGLLibShaderNameProperty |
Class TGLLibAttachmentNameProperty |
Class TGLLibAsmProgNameProperty |
Class TPictureFileProperty |
Class TShaderFileProperty |
Class TAsmProgFileProperty |
Class TUniformAutoSetProperty |
Class TGLShaderEditorProperty |

Functions and Procedures

procedure Register;
function ObjectManager: TGLObjectManager;

Description

Functions and Procedures

procedure Register;

Register Components

function ObjectManager: TGLObjectManager;

Auto-create for object manager


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLLibMaterialNameProperty

Class TGLLibMaterialNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLLibMaterialNameProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLLibMaterialNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLSceneViewerEditor

Class TGLSceneViewerEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLSceneViewerEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TGLSceneViewerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLSceneEditor

Class TGLSceneEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLSceneEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TGLSceneEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLResolutionProperty

Class TGLResolutionProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLResolutionProperty = class(TPropertyEditor)

Description

This item has no description.

Hierarchy

  • TPropertyEditor
  • TGLResolutionProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public function GetValue: string; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: string); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLTextureProperty

Class TGLTextureProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLTextureProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TGLTextureProperty

Overview

Methods

Public function GetAttributes: TPropertyAttributes; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLTextureImageProperty

Class TGLTextureImageProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLTextureImageProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TGLTextureImageProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLImageClassProperty

Class TGLImageClassProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLImageClassProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TGLImageClassProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public function GetValue: string; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: string); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLColorProperty

Class TGLColorProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLColorProperty = class(TClassProperty, ICustomPropertyDrawing, ICustomPropertyListDrawing)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TGLColorProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure Edit; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure ListDrawValue(const Value: string; ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);
Public | procedure ListMeasureHeight(const Value: string; ACanvas: TCanvas; var AHeight: Integer);
Public | procedure ListMeasureWidth(const Value: string; ACanvas: TCanvas; var AWidth: Integer);
Public | procedure PropDrawName(ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);
Public | procedure PropDrawValue(ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);
Public | procedure SetValue(const Value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public function GetValue: string; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure ListDrawValue(const Value: string; ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);

This item has no description.

Public procedure ListMeasureHeight(const Value: string; ACanvas: TCanvas; var AHeight: Integer);

ICustomPropertyListDrawing stuff

Public procedure ListMeasureWidth(const Value: string; ACanvas: TCanvas; var AWidth: Integer);

This item has no description.

Public procedure PropDrawName(ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);

CustomPropertyDrawing

Public procedure PropDrawValue(ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);

This item has no description.

Public procedure SetValue(const Value: string); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLSoundFileProperty

Class TGLSoundFileProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLSoundFileProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TGLSoundFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public function GetValue: string; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLSoundNameProperty

Class TGLSoundNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLSoundNameProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLSoundNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLCoordinatesProperty

Class TGLCoordinatesProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLCoordinatesProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TGLCoordinatesProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLMaterialProperty

Class TGLMaterialProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLMaterialProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TGLMaterialProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLGUILayoutEditor

Class TGLGUILayoutEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLGUILayoutEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TGLGUILayoutEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLReuseableDefaultEditor

Class TGLReuseableDefaultEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLReuseableDefaultEditor = class(TComponentEditor, IDefaultEditor)

Description

Editor copied from DsgnIntf. Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TGLSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! and he did that again in D7! Grrr...

Hierarchy

  • TComponentEditor
  • TGLReuseableDefaultEditor

Overview

Methods

Public procedure Edit; override;

Description

Methods

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLMaterialLibraryEditor

Class TGLMaterialLibraryEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLMaterialLibraryEditor = class(TGLReuseableDefaultEditor, IDefaultEditor)

Description

Editor for material library.

Hierarchy

  • TComponentEditor
  • TGLReuseableDefaultEditor
  • TGLMaterialLibraryEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLAnimationNameProperty

Class TGLAnimationNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLAnimationNameProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLAnimationNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLSoundLibrarySelectionEditor

Class TGLSoundLibrarySelectionEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLSoundLibrarySelectionEditor = class(TSelectionEditor)

Description

Selection editor for TGLSoundLibrary Allows units to be added to the uses clause automatically when sound files are loaded into a TGLSoundLibrary at design-time.

Hierarchy

  • TSelectionEditor
  • TGLSoundLibrarySelectionEditor

Overview

Methods

Public procedure RequiresUnits(Proc: TGetStrProc); override;

Description

Methods

Public procedure RequiresUnits(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLBaseSceneObjectSelectionEditor

Class TGLBaseSceneObjectSelectionEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLBaseSceneObjectSelectionEditor = class(TSelectionEditor)

Description

Selection editor for TGLBaseSceneObject. Allows units to be added to the uses clause automatically when behaviours/effects are added to a TGLBaseSceneObject at design-time.

Hierarchy

  • TSelectionEditor
  • TGLBaseSceneObjectSelectionEditor

Overview

Methods

Public procedure RequiresUnits(Proc: TGetStrProc); override;

Description

Methods

Public procedure RequiresUnits(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLSArchiveManagerEditor

Class TGLSArchiveManagerEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLSArchiveManagerEditor = class(TGLReuseableDefaultEditor, IDefaultEditor)

Description

Editor for Archive Manager

Hierarchy

  • TComponentEditor
  • TGLReuseableDefaultEditor
  • TGLSArchiveManagerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLMaterialComponentNameProperty

Class TGLMaterialComponentNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLMaterialComponentNameProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLLibTextureNameProperty

Class TGLLibTextureNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLLibTextureNameProperty = class(TGLMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibTextureNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLLibSamplerNameProperty

Class TGLLibSamplerNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLLibSamplerNameProperty = class(TGLMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibSamplerNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLLibCombinerNameProperty

Class TGLLibCombinerNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLLibCombinerNameProperty = class(TGLMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibCombinerNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLLibShaderNameProperty

Class TGLLibShaderNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLLibShaderNameProperty = class(TGLMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibShaderNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLLibAttachmentNameProperty

Class TGLLibAttachmentNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLLibAttachmentNameProperty = class(TGLMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibAttachmentNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLLibAsmProgNameProperty

Class TGLLibAsmProgNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLLibAsmProgNameProperty = class(TGLMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibAsmProgNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TPictureFileProperty

Class TPictureFileProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TPictureFileProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TPictureFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TShaderFileProperty

Class TShaderFileProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TShaderFileProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TShaderFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TAsmProgFileProperty

Class TAsmProgFileProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TAsmProgFileProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TAsmProgFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneRegister: Class TUniformAutoSetProperty

Class TUniformAutoSetProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TUniformAutoSetProperty = class(TPropertyEditor)

Description

This item has no description.

Hierarchy

  • TPropertyEditor
  • TUniformAutoSetProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;
Private | procedure PassUniform(const S: string);

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Private procedure PassUniform(const S: string);


GLSysHelp v.2.5: GLS.SceneRegister: Class TGLShaderEditorProperty

Class TGLShaderEditorProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneRegister

Declaration

type TGLShaderEditorProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TGLShaderEditorProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.SceneViewer

Unit GLS.SceneViewer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • WinApi.Windows
  • WinApi.Messages
  • System.Classes
  • System.SysUtils
  • System.Types
  • VCL.Graphics
  • VCL.Forms
  • VCL.Controls
  • GLS.Scene
  • GLS.WindowsContext
  • GLS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSceneViewer |

Functions and Procedures

procedure SetupVSync(const AVSyncMode : TGLVSyncMode);

Types

TTouchEvent = procedure(X, Y, TouchWidth, TouchHeight : integer; TouchID : Cardinal; TouchCount : integer; FromPen : boolean) of object;

Description

Functions and Procedures

procedure SetupVSync(const AVSyncMode : TGLVSyncMode);

This item has no description.

Types

TTouchEvent = procedure(X, Y, TouchWidth, TouchHeight : integer; TouchID : Cardinal; TouchCount : integer; FromPen : boolean) of object;


GLSysHelp v.2.5: GLS.SceneViewer: Class TGLSceneViewer

Class TGLSceneViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SceneViewer

Declaration

type TGLSceneViewer = class(TWinControl)

Description

Component where the GLScene objects get rendered. This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap. It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form). This viewer also allows to define rendering options such as fog, face culling, depth testing, etc. and can take care of framerate calculation.

Hierarchy

  • TWinControl
  • TGLSceneViewer

Overview

Fields

Private | FBuffer: TGLSceneBuffer;
Private | FVSync: TGLVSyncMode;
Private | FOwnDC: HDC;
Private | FOnMouseEnter: TNotifyEvent;
Private | FOnMouseLeave: TNotifyEvent;
Private | FMouseInControl: Boolean;
Private | FLastScreenPos: TPoint;
Private | FPenAsTouch: boolean;
Private | FOnTouchMove: TTouchEvent;
Private | FOnTouchUp: TTouchEvent;
Private | FOnTouchDown: TTouchEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateSnapShotBitmap: TBitmap;
Public | function FramesPerSecond: Single;
Public | function FramesPerSecondText(decimals: Integer = 1): string;
Public | function LastFrameTime: Single;
Private | function GetFieldOfView: single;
Private | function GetIsRenderingContextAvailable: Boolean;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RecreateWnd;
Public | procedure RegisterTouch;
Public | procedure ResetPerformanceMonitor;
Public | procedure UnregisterTouch;
Private | procedure CMMouseEnter(var msg: TMessage); message CM_MOUSEENTER;
Private | procedure CMMouseLeave(var msg: TMessage); message CM_MOUSELEAVE;
Private | procedure SetFieldOfView(const Value: single);
Private | procedure WMDestroy(var Message: TWMDestroy); message WM_DESTROY;
Private | procedure WMEraseBkgnd(var Message: TWMEraseBkgnd); message WM_ERASEBKGND;
Private | procedure WMGetDglCode(var Message: TMessage); message WM_GETDLGCODE;
Private | procedure WMPaint(var Message: TWMPaint); message WM_PAINT;
Private | procedure WMSize(var Message: TWMSize); message WM_SIZE;
Private | procedure WMTouch(var Message: TMessage); message WM_TOUCH;

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property Align;
Published | property Anchors;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TGLCamera read GetCamera write SetCamera;
Published | property DragCursor;
Published | property DragMode;
Published | property Enabled;
Published | property FieldOfView: single read GetFieldOfView write SetFieldOfView;
Published | property HelpContext;
Published | property Hint;
Public | property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;
Public | property MouseInControl: Boolean read FMouseInControl;
Published | property OnClick;
Published | property OnContextPopup;
Published | property OnDblClick;
Published | property OnDragDrop;
Published | property OnDragOver;
Published | property OnEndDrag;
Published | property OnEnter;
Published | property OnExit;
Published | property OnGesture;
Published | property OnKeyDown;
Published | property OnKeyUp;
Published | property OnMouseDown;
Published | property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published | property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published | property OnMouseMove;
Published | property OnMouseUp;
Published | property OnMouseWheel;
Published | property OnMouseWheelDown;
Published | property OnMouseWheelUp;
Published | property OnStartDrag;
Published | property OnTouchDown: TTouchEvent read FOnTouchDown write FOnTouchDown;
Published | property OnTouchMove: TTouchEvent read FOnTouchMove write FOnTouchMove;
Published | property OnTouchUp: TTouchEvent read FOnTouchUp write FOnTouchUp;
Published | property PenAsTouch: boolean read FPenAsTouch write FPenAsTouch;
Published | property PopupMenu;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Public | property RenderDC: HDC read FOwnDC;
Published | property TabOrder;
Published | property TabStop;
Published | property Touch;
Published | property Visible;
Published | property VSync: TGLVSyncMode read FVSync write FVSync default vsmNoSync;

Description

Fields

Private FBuffer: TGLSceneBuffer;

This item has no description.

Private FVSync: TGLVSyncMode;

This item has no description.

Private FOwnDC: HDC;

This item has no description.

Private FOnMouseEnter: TNotifyEvent;

This item has no description.

Private FOnMouseLeave: TNotifyEvent;

This item has no description.

Private FMouseInControl: Boolean;

This item has no description.

Private FLastScreenPos: TPoint;

This item has no description.

Private FPenAsTouch: boolean;

This item has no description.

Private FOnTouchMove: TTouchEvent;

This item has no description.

Private FOnTouchUp: TTouchEvent;

This item has no description.

Private FOnTouchDown: TTouchEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateSnapShotBitmap: TBitmap;

This item has no description.

Public function FramesPerSecond: Single;

This item has no description.

Public function FramesPerSecondText(decimals: Integer = 1): string;

This item has no description.

Public function LastFrameTime: Single;

This item has no description.

Private function GetFieldOfView: single;

This item has no description.

Private function GetIsRenderingContextAvailable: Boolean;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure RecreateWnd;

Makes TWinControl's RecreateWnd public. This procedure allows to work around limitations in some OpenGL drivers (like MS Software OpenGL) that are not able to share lists between RCs that already have display lists.

Public procedure RegisterTouch;

This item has no description.

Public procedure ResetPerformanceMonitor;

This item has no description.

Public procedure UnregisterTouch;

This item has no description.

Private procedure CMMouseEnter(var msg: TMessage); message CM_MOUSEENTER;

This item has no description.

Private procedure CMMouseLeave(var msg: TMessage); message CM_MOUSELEAVE;

This item has no description.

Private procedure SetFieldOfView(const Value: single);

This item has no description.

Private procedure WMDestroy(var Message: TWMDestroy); message WM_DESTROY;

This item has no description.

Private procedure WMEraseBkgnd(var Message: TWMEraseBkgnd); message WM_ERASEBKGND;

This item has no description.

Private procedure WMGetDglCode(var Message: TMessage); message WM_GETDLGCODE;

This item has no description.

Private procedure WMPaint(var Message: TWMPaint); message WM_PAINT;

This item has no description.

Private procedure WMSize(var Message: TWMSize); message WM_SIZE;

This item has no description.

Private procedure WMTouch(var Message: TMessage); message WM_TOUCH;

This item has no description.

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property Align;

This item has no description.

Published property Anchors;

This item has no description.

Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered. You may use this event to execute your own OpenGL rendering.

Published property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;

Access to buffer properties.

Published property Camera: TGLCamera read GetCamera write SetCamera;

Camera from which the scene is rendered.

Published property DragCursor;

This item has no description.

Published property DragMode;

This item has no description.

Published property Enabled;

This item has no description.

Published property FieldOfView: single read GetFieldOfView write SetFieldOfView;

Returns or sets the field of view for the viewer, in degrees. This value depends on the camera and the width and height of the scene. The value isn't persisted, if the width/height or camera.focallength is changed, FieldOfView is changed also.

Published property HelpContext;

This item has no description.

Published property Hint;

This item has no description.

Public property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;

This item has no description.

Public property MouseInControl: Boolean read FMouseInControl;

This item has no description.

Published property OnClick;

This item has no description.

Published property OnContextPopup;

This item has no description.

Published property OnDblClick;

This item has no description.

Published property OnDragDrop;

This item has no description.

Published property OnDragOver;

This item has no description.

Published property OnEndDrag;

This item has no description.

Published property OnEnter;

This item has no description.

Published property OnExit;

This item has no description.

Published property OnGesture;

This item has no description.

Published property OnKeyDown;

This item has no description.

Published property OnKeyUp;

This item has no description.

Published property OnMouseDown;

This item has no description.

Published property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;

This item has no description.

Published property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;

This item has no description.

Published property OnMouseMove;

This item has no description.

Published property OnMouseUp;

This item has no description.

Published property OnMouseWheel;

This item has no description.

Published property OnMouseWheelDown;

This item has no description.

Published property OnMouseWheelUp;

This item has no description.

Published property OnStartDrag;

This item has no description.

Published property OnTouchDown: TTouchEvent read FOnTouchDown write FOnTouchDown;

This item has no description.

Published property OnTouchMove: TTouchEvent read FOnTouchMove write FOnTouchMove;

This item has no description.

Published property OnTouchUp: TTouchEvent read FOnTouchUp write FOnTouchUp;

This item has no description.

Published property PenAsTouch: boolean read FPenAsTouch write FPenAsTouch;

Since Windows 10 Fall Creators Update in 2017, pen also triggers touch input. You can set PenAsTouch = false to filter out such input.

Published property PopupMenu;

This item has no description.

Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;

Triggered just after all the scene's objects have been rendered. The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.

Public property RenderDC: HDC read FOwnDC;

This item has no description.

Published property TabOrder;

This item has no description.

Published property TabStop;

This item has no description.

Published property Touch;

This item has no description.

Published property Visible;

This item has no description.

Published property VSync: TGLVSyncMode read FVSync write FVSync default vsmNoSync;

Specifies if the refresh should be synchronized with the VSync signal. If the underlying OpenGL ICD does not support the WGL_EXT_swap_control extension, this property is ignored.


GLSysHelp v.2.5: GLS.Screen

Unit GLS.Screen

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • VCL.Forms
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDisplayOptions |
Packed Record TGLVideoMode |

Functions and Procedures

function GetIndexFromResolution(XRes, YRes, BPP: Integer): TResolution;
procedure ReadVideoModes;
function SetFullscreenMode(modeIndex: TResolution; displayFrequency: Integer = 0): Boolean;
procedure ReadScreenImage(Dest: HDC; DestLeft, DestTop: Integer; const SrcRect: TRectangle);
procedure RestoreDefaultMode;
procedure GLShowCursor(AShow: Boolean);
procedure GLSetCursorPos(AScreenX, AScreenY: Integer);
procedure GLGetCursorPos(var point: TPoint);
function GLGetScreenWidth: Integer;
function GLGetScreenHeight: Integer;

Types

PGLVideoMode = ˆTGLVideoMode;
TGLWindowAttribute = (...);
TGLWindowAttributes = set of TGLWindowAttribute;
TGLWindowFitting = (...);
TResolution = 0 .. MaxVideoModes;

Constants

MaxVideoModes = 200;
lcl_release = 0;

Variables

vNumberVideoModes: Integer = 0;
vCurrentVideoMode: Integer = 0;
vVideoModes: array of TGLVideoMode;

Description

Functions and Procedures

function GetIndexFromResolution(XRes, YRes, BPP: Integer): TResolution;

This item has no description.

procedure ReadVideoModes;

This item has no description.

function SetFullscreenMode(modeIndex: TResolution; displayFrequency: Integer = 0): Boolean;

Changes to the video mode given by 'Index'

procedure ReadScreenImage(Dest: HDC; DestLeft, DestTop: Integer; const SrcRect: TRectangle);

This item has no description.

procedure RestoreDefaultMode;

This item has no description.

procedure GLShowCursor(AShow: Boolean);

This item has no description.

procedure GLSetCursorPos(AScreenX, AScreenY: Integer);

This item has no description.

procedure GLGetCursorPos(var point: TPoint);

This item has no description.

function GLGetScreenWidth: Integer;

This item has no description.

function GLGetScreenHeight: Integer;

This item has no description.

Types

PGLVideoMode = ˆTGLVideoMode;

This item has no description.

TGLWindowAttribute = (...);

window attributes

Values
  • woDesktop
  • woStayOnTop
  • woTransparent
TGLWindowAttributes = set of TGLWindowAttribute;

This item has no description.

TGLWindowFitting = (...);

window-to-screen fitting

Values
  • wfDefault
  • wfFitWindowToScreen
  • wfFitScreenToWindow
TResolution = 0 .. MaxVideoModes;

This item has no description.

Constants

MaxVideoModes = 200;

This item has no description.

lcl_release = 0;

This item has no description.

Variables

vNumberVideoModes: Integer = 0;

This item has no description.

vCurrentVideoMode: Integer = 0;

This item has no description.

vVideoModes: array of TGLVideoMode;


GLSysHelp v.2.5: GLS.Screen: Class TGLDisplayOptions

Class TGLDisplayOptions

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Screen

Declaration

type TGLDisplayOptions = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLDisplayOptions

Overview

Fields

Private | FFullScreen: Boolean;
Private | FScreenResolution: TResolution;
Private | FWindowAttributes: TGLWindowAttributes;
Private | FWindowFitting: TGLWindowFitting;

Methods

Public procedure Assign(Source: TPersistent); override;

Properties

Published | property FullScreen: Boolean read FFullScreen write FFullScreen default False;
Published | property ScreenResolution: TResolution read FScreenResolution write FScreenResolution default 0;
Published | property WindowAttributes: TGLWindowAttributes read FWindowAttributes write FWindowAttributes default [];
Published | property WindowFitting: TGLWindowFitting read FWindowFitting write FWindowFitting default wfDefault;

Description

Fields

Private FFullScreen: Boolean;

This item has no description.

Private FScreenResolution: TResolution;

This item has no description.

Private FWindowAttributes: TGLWindowAttributes;

This item has no description.

Private FWindowFitting: TGLWindowFitting;

This item has no description.

Methods

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property FullScreen: Boolean read FFullScreen write FFullScreen default False;

This item has no description.

Published property ScreenResolution: TResolution read FScreenResolution write FScreenResolution default 0;

This item has no description.

Published property WindowAttributes: TGLWindowAttributes read FWindowAttributes write FWindowAttributes default [];

This item has no description.

Published property WindowFitting: TGLWindowFitting read FWindowFitting write FWindowFitting default wfDefault;


GLSysHelp v.2.5: GLS.Screen: Packed Record TGLVideoMode

Packed Record TGLVideoMode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Screen

Declaration

type TGLVideoMode = packed record

Description

This item has no description.

Overview

Fields

Public | Width: Word;
Public | Height: Word;
Public | ColorDepth: Byte;
Public | MaxFrequency: Byte;
Public | Description: String;

Description

Fields

Public Width: Word;

This item has no description.

Public Height: Word;

This item has no description.

Public ColorDepth: Byte;

This item has no description.

Public MaxFrequency: Byte;

This item has no description.

Public Description: String;


GLSysHelp v.2.5: GLS.ScreenSaver

Unit GLS.ScreenSaver

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.Classes
  • System.SysUtils
  • System.Win.Registry
  • VCL.Dialogs
  • VCL.Controls
  • VCL.Forms
  • VCL.Extctrls

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLScreenSaver |

Functions and Procedures

procedure SetScreenSaverPassword;

Types

TScreenSaverOption = (...);
TScreenSaverOptions = set of TScreenSaverOption;
TScreenSaverPreviewEvent = procedure(Sender: TObject; previewHwnd: HWND) of object;

Constants

cDefaultScreenSaverOptions = [ssoAutoAdjustFormProperties, ssoAutoHookKeyboardEvents, ssoEnhancedMouseMoveDetection];

Description

Functions and Procedures

procedure SetScreenSaverPassword;

Invokes the standard Windows dialog to set the password. May be invoked from your Properties/Configuration dialog.

Types

TScreenSaverOption = (...);

Options d'automatisation du screen-saver. ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer)

Values
  • ssoAutoAdjustFormProperties
  • ssoAutoHookKeyboardEvents
  • ssoAutoHookMouseEvents
  • ssoEnhancedMouseMoveDetection
TScreenSaverOptions = set of TScreenSaverOption;

This item has no description.

TScreenSaverPreviewEvent = procedure(Sender: TObject; previewHwnd: HWND) of object;

This event is fired when screen saver should start in preview mode. The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).

Constants

cDefaultScreenSaverOptions = [ssoAutoAdjustFormProperties, ssoAutoHookKeyboardEvents, ssoEnhancedMouseMoveDetection];


GLSysHelp v.2.5: GLS.ScreenSaver: Class TGLScreenSaver

Class TGLScreenSaver

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ScreenSaver

Declaration

type TGLScreenSaver = class(TComponent)

Description

Drop this component on your main form to make it a screensaver. You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab). How this component works : At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) At run-time, once its props are loaded, this component will parse the command line and trigger relevant events Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible) There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLScreenSaver

Overview

Fields

Private | mouseEventsToIgnore: Integer;
Private | FHonourWindowsPassword: Boolean;
Private | FOptions: TScreenSaverOptions;
Private | FOnPropertiesRequested: TNotifyEvent;
Private | FOnExecute: TNotifyEvent;
Private | FOnPreview: TScreenSaverPreviewEvent;
Private | FOnCloseQuery: TCloseQueryEvent;
Private | FAboutString: String;
Private | FInPreviewMode: Boolean;
Private | mouseTimer: TTimer;
Private | lastMousePosition: TPoint;
Private | FMutex: THandle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CloseSaver: Boolean;
Public | procedure SetPassword;

Properties

Published | property AboutString: String read FAboutString write FAboutString;
Published | property HonourWindowsPassword: Boolean read FHonourWindowsPassword write FHonourWindowsPassword default True;
Public | property InPreviewMode: Boolean read FInPreviewMode;
Published | property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write FOnCloseQuery;
Published | property OnExecute: TNotifyEvent read FOnExecute write FOnExecute;
Published | property OnPreview: TScreenSaverPreviewEvent read FOnPreview write FOnPreview;
Published | property OnPropertiesRequested: TNotifyEvent read FOnPropertiesRequested write FOnPropertiesRequested;
Published | property Options: TScreenSaverOptions read FOptions write FOptions default cDefaultScreenSaverOptions;

Description

Fields

Private mouseEventsToIgnore: Integer;

This item has no description.

Private FHonourWindowsPassword: Boolean;

This item has no description.

Private FOptions: TScreenSaverOptions;

This item has no description.

Private FOnPropertiesRequested: TNotifyEvent;

This item has no description.

Private FOnExecute: TNotifyEvent;

This item has no description.

Private FOnPreview: TScreenSaverPreviewEvent;

This item has no description.

Private FOnCloseQuery: TCloseQueryEvent;

This item has no description.

Private FAboutString: String;

This item has no description.

Private FInPreviewMode: Boolean;

This item has no description.

Private mouseTimer: TTimer;

This item has no description.

Private lastMousePosition: TPoint;

alocated only if necessary

Private FMutex: THandle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CloseSaver: Boolean;

Properly handles request to close the main window. Returns True if the Close request wasn't canceled (by event or password fail) and will actually happen. Use this if you implemented specific screen-saver exiting in your main form. It first triggers the OnCloseQuery, where the close request can be canceled, if this passed, the password is checked if there is any, then sends a WM_CLOSE to the saver windows.

Public procedure SetPassword;

Invokes the standard Windows dialog to set the password. May be invoked from your Properties/Configuration dialog.

Properties

Published property AboutString: String read FAboutString write FAboutString;

This string is displayed if OnPropertiesRequested is not used. You may use it as a quick "AboutBox".

Published property HonourWindowsPassword: Boolean read FHonourWindowsPassword write FHonourWindowsPassword default True;

If True, windows screen-saver password is checked before closing. You may be wanting to set this prop to false if you're using your own password scheme or do not want any password to be set.

Public property InPreviewMode: Boolean read FInPreviewMode;

True if the screen-save is in preview mode. Valid only when the TScreenSaver has completed loading.

Published property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write FOnCloseQuery;

Fired when screen-saver execution should close. It is invoked before querying for password (if there is a password).

Published property OnExecute: TNotifyEvent read FOnExecute write FOnExecute;

Fired when the saver should start executing, after form props are adjusted.

Published property OnPreview: TScreenSaverPreviewEvent read FOnPreview write FOnPreview;

Fired when preview is requested, after form props are adjusted.

Published property OnPropertiesRequested: TNotifyEvent read FOnPropertiesRequested write FOnPropertiesRequested;

Display the properties dialog when this event is triggered. This event may be called before Delphi's form auto-creation is complete, and should not rely on auto-created dialogs/forms but create what needs be.

Published property Options: TScreenSaverOptions read FOptions write FOptions default cDefaultScreenSaverOptions;


GLSysHelp v.2.5: GLS.ScriptBase

Unit GLS.ScriptBase

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.XCollection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLScriptBase |
Class TGLScripts |
Class TGLScriptLibrary |

Types

TGLScriptState = (...);

Description

Types

TGLScriptState = (...);

This item has no description.

Values
  • ssUncompiled
  • ssCompileErrors: The script has yet to be compiled.
  • ssCompiled: Errors occurred while compiling.
  • ssRunningErrors: The script has been compiled and ready to be executed/started.
  • ssRunning: Errors occured while the script was running.


GLSysHelp v.2.5: GLS.ScriptBase: Class TGLScriptBase

Class TGLScriptBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ScriptBase

Declaration

type TGLScriptBase = class(TXCollectionItem)

Description

The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLScriptBase

Overview

Fields

Private | FText: TStringList;
Private | FDescription: String;
Private | FErrors: TStringList;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function Call(aName: String; aParams: array of Variant): Variant; virtual; abstract;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Compile; virtual; abstract;
Public | procedure Execute; virtual; abstract;
Public | procedure Invalidate; virtual; abstract;
Public | procedure Start; virtual; abstract;
Public | procedure Stop; virtual; abstract;

Properties

Published | property Description: String read FDescription write FDescription;
Public | property Errors: TStringList read FErrors;
Public | property State: TGLScriptState read GetState;
Published | property Text: TStringList read FText write SetText;

Description

Fields

Private FText: TStringList;

This item has no description.

Private FDescription: String;

This item has no description.

Private FErrors: TStringList;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Call(aName: String; aParams: array of Variant): Variant; virtual; abstract;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure Compile; virtual; abstract;

This item has no description.

Public procedure Execute; virtual; abstract;

This item has no description.

Public procedure Invalidate; virtual; abstract;

This item has no description.

Public procedure Start; virtual; abstract;

This item has no description.

Public procedure Stop; virtual; abstract;

This item has no description.

Properties

Published property Description: String read FDescription write FDescription;

This item has no description.

Public property Errors: TStringList read FErrors;

This item has no description.

Public property State: TGLScriptState read GetState;

This item has no description.

Published property Text: TStringList read FText write SetText;


GLSysHelp v.2.5: GLS.ScriptBase: Class TGLScripts

Class TGLScripts

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ScriptBase

Declaration

type TGLScripts = class(TXCollection)

Description

XCollection descendant for storing and handling scripts.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLScripts

Overview

Methods

Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public property Items[index: Integer]: TGLScriptBase read GetItems;

Description

Methods

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Public property Items[index: Integer]: TGLScriptBase read GetItems;


GLSysHelp v.2.5: GLS.ScriptBase: Class TGLScriptLibrary

Class TGLScriptLibrary

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ScriptBase

Declaration

type TGLScriptLibrary = class(TComponent)

Description

Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLScriptLibrary

Overview

Fields

Private FScripts: TGLScripts;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property Scripts: TGLScripts read FScripts;

Description

Fields

Private FScripts: TGLScripts;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Scripts: TGLScripts read FScripts;


GLSysHelp v.2.5: GLS.SDL.Context

Unit GLS.SDL.Context

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • GLS.OpenGLAdapter
  • GLS.XOpenGL
  • GLS.Context
  • GLS.Scene
  • SDL.Import
  • GLS.SDL.Window

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSDLViewer |
Class TSDLContext |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GLSysHelp v.2.5: GLS.SDL.Context: Class TSDLViewer

Class TSDLViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SDL.Context

Declaration

type TSDLViewer = class(TGLNonVisualViewer)

Description

A viewer using SDL. Beware: only one at a time, no other viewers allowed! Will also close the application when the window is closed!

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLNonVisualViewer
  • TSDLViewer

Overview

Fields

Private | FCaption: string;
Private | FOnSDLEvent: TSDLEvent;
Private | FOnEventPollDone: TNotifyEvent;
Private | FOnResize: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Active: Boolean;
Public | procedure Render(baseObject: TGLBaseSceneObject = nil); override;

Properties

Published | property Caption: string read FCaption write SetCaption;
Published | property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;
Published | property OnResize: TNotifyEvent read FOnResize write FOnResize;
Published | property OnSDLEvent: TSDLEvent read FOnSDLEvent write FOnSDLEvent;

Description

Fields

Private FCaption: string;

This item has no description.

Private FOnSDLEvent: TSDLEvent;

This item has no description.

Private FOnEventPollDone: TNotifyEvent;

This item has no description.

Private FOnResize: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Active: Boolean;

This item has no description.

Public procedure Render(baseObject: TGLBaseSceneObject = nil); override;

This item has no description.

Properties

Published property Caption: string read FCaption write SetCaption;

This item has no description.

Published property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;

Fired whenever an event polling completes with no events left to poll.

Published property OnResize: TNotifyEvent read FOnResize write FOnResize;

This item has no description.

Published property OnSDLEvent: TSDLEvent read FOnSDLEvent write FOnSDLEvent;

Fired whenever an SDL Event is polled. SDL_QUITEV and SDL_VIDEORESIZE are not passed to this event handler, they are passed via OnClose and OnResize respectively.


GLSysHelp v.2.5: GLS.SDL.Context: Class TSDLContext

Class TSDLContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SDL.Context

Declaration

type TSDLContext = class(TGLScreenControlingContext)

Description

A context driver for OpenGL via SDL (libsdl.org). Due to limitations of SDL: you may have only one SDL window opened at any time (you cannot have memory viewers) closing the SDL window will terminate the application

Hierarchy

  • TObject
  • TGLContext
  • TGLScreenControlingContext
  • TSDLContext

Overview

Fields

Private | FSDLWin: TSDLWindow;
Private | FSimulatedValidity: Boolean;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; override;
Public | function RenderOutputDevice: Pointer; override;
Public | procedure SwapBuffers; override;

Properties

Public property SDLWindow: TSDLWindow read FSDLWin;

Description

Fields

Private FSDLWin: TSDLWindow;

This item has no description.

Private FSimulatedValidity: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean; override;

This item has no description. Showing description inherited from TGLContext.IsValid.

Returns true if the context is valid. A context is valid from the time it has been successfully created to the time of its destruction.

Public function RenderOutputDevice: Pointer; override;

This item has no description.

Public procedure SwapBuffers; override;

This item has no description. Showing description inherited from TGLContext.SwapBuffers.

Request to swap front and back buffers if they were defined

Properties

Public property SDLWindow: TSDLWindow read FSDLWin;


GLSysHelp v.2.5: GLS.SDL.Window

Unit GLS.SDL.Window

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.SyncObjs
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLS.OpenGLAdapter
  • GLScene.VectorTypes
  • GLS.State
  • GLS.Context
  • SDL.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSDLWindow |
Class ESDLError |

Functions and Procedures

function _putenv(const variable: PAnsiChar): Integer; cdecl;
function SDL_putenv(const variable: PAnsiChar): Integer;
function getenv(const name: PAnsiChar): PAnsiChar; cdecl;
function SDL_getenv(const name: PAnsiChar): PAnsiChar;
procedure Register;

Types

TSDLEvent = procedure(sender: TObject; const event: TSDL_Event) of object;
TSDLWindowOption = (...);
TSDLWindowOptions = set of TSDLWindowOption;
TSDLWindowPixelDepth = (...);

Constants

cDefaultSDLWindowOptions = [voDoubleBuffer, voHardwareAccel, voOpenGL, voResizable];

Description

Functions and Procedures

function _putenv(const variable: PAnsiChar): Integer; cdecl;

—————————————————————————– Get Environment Routines ——————————————————————————

function SDL_putenv(const variable: PAnsiChar): Integer;

function SDL_putenv(const variable: PAnsiChar): integer; cdecl; external LibName;

function getenv(const name: PAnsiChar): PAnsiChar; cdecl;

function putenv(const variable: PAnsiChar): integer;

function SDL_getenv(const name: PAnsiChar): PAnsiChar;

function SDL_getenv(const name: PAnsiChar): PAnsiChar; cdecl; external LibName;

procedure Register;

function getenv(const name: PAnsiChar): PAnsiChar;

Types

TSDLEvent = procedure(sender: TObject; const event: TSDL_Event) of object;

This item has no description.

TSDLWindowOption = (...);

Specifies optional settings for the SDL window. Those options are a simplified subset of the SDL options: voDoubleBuffer: create a double-buffered window voOpenGL: requires OpenGL capability for the window voResizable: window should be resizable voFullScreen: requires a full screen "window" (screen resolution may be changed) voStencilBuffer: requires a stencil buffer (8bits, use along voOpenGL)

Values
  • voDoubleBuffer
  • voHardwareAccel
  • voOpenGL
  • voResizable
  • voFullScreen
  • voStencilBuffer
TSDLWindowOptions = set of TSDLWindowOption;

This item has no description.

TSDLWindowPixelDepth = (...);

Pixel Depth options. vpd16bits: 16bpp graphics (565) (and 16 bits depth buffer for OpenGL) vpd24bits: 24bpp graphics (565) (and 24 bits depth buffer for OpenGL)

Values
  • vpd16bits
  • vpd24bits

Constants

cDefaultSDLWindowOptions = [voDoubleBuffer, voHardwareAccel, voOpenGL, voResizable];


GLSysHelp v.2.5: GLS.SDL.Window: Class TSDLWindow

Class TSDLWindow

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SDL.Window

Declaration

type TSDLWindow = class(TComponent)

Description

A basic SDL-based window (non-visual component). Only a limited subset of SDL's features are available, and this window is heavily oriented toward using it for OpenGL rendering. Be aware SDL is currently limited to a single window at any time... so you may have multiple components, but only one can be used

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TSDLWindow

Overview

Fields

Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FPixelDepth: TSDLWindowPixelDepth;
Private | FOptions: TSDLWindowOptions;
Private | FActive: Boolean;
Private | FOnOpen: TNotifyEvent;
Private | FOnClose: TNotifyEvent;
Private | FOnResize: TNotifyEvent;
Private | FOnSDLEvent: TSDLEvent;
Private | FOnEventPollDone: TNotifyEvent;
Private | FCaption: String;
Private | FThreadSleepLength: Integer;
Private | FThreadPriority: TThreadPriority;
Private | FThreadedEventPolling: Boolean;
Private | FThread: TThread;
Private | FSDLSurface: PSDL_Surface;
Private | FWindowHandle: Longword;
Private | FSDLWindow: PSDL_Window;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Close;
Public | procedure Open;
Public | procedure PollEvents;
Public | procedure SwapBuffers;
Public | procedure UpdateWindow;

Properties

Public | property Active: Boolean read FActive write SetActive;
Published | property Caption: String read FCaption write SetCaption;
Published | property Height: Integer read FHeight write SetHeight default 480;
Published | property OnClose: TNotifyEvent read FOnClose write FOnClose;
Published | property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;
Published | property OnOpen: TNotifyEvent read FOnOpen write FOnOpen;
Published | property OnResize: TNotifyEvent read FOnResize write FOnResize;
Published | property OnSDLEvent: TSDLEvent read FOnSDLEvent write FOnSDLEvent;
Published | property Options: TSDLWindowOptions read FOptions write SetOptions default cDefaultSDLWindowOptions;
Published | property PixelDepth: TSDLWindowPixelDepth read FPixelDepth write SetPixelDepth default vpd24bits;
Public | property SDLSurface: PSDL_Surface read FSDLSurface;
Public | property SDLWindow: PSDL_Window read FSDLWindow;
Published | property ThreadedEventPolling: Boolean read FThreadedEventPolling write SetThreadedEventPolling default True;
Published | property ThreadPriority: TThreadPriority read FThreadPriority write SetThreadPriority default tpLower;
Published | property ThreadSleepLength: Integer read FThreadSleepLength write SetThreadSleepLength default 1;
Published | property Width: Integer read FWidth write SetWidth default 640;
Public | property WindowHandle: Cardinal read FWindowHandle write FWindowHandle;

Description

Fields

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FPixelDepth: TSDLWindowPixelDepth;

This item has no description.

Private FOptions: TSDLWindowOptions;

This item has no description.

Private FActive: Boolean;

This item has no description.

Private FOnOpen: TNotifyEvent;

This item has no description.

Private FOnClose: TNotifyEvent;

This item has no description.

Private FOnResize: TNotifyEvent;

This item has no description.

Private FOnSDLEvent: TSDLEvent;

This item has no description.

Private FOnEventPollDone: TNotifyEvent;

This item has no description.

Private FCaption: String;

This item has no description.

Private FThreadSleepLength: Integer;

This item has no description.

Private FThreadPriority: TThreadPriority;

This item has no description.

Private FThreadedEventPolling: Boolean;

This item has no description.

Private FThread: TThread;

This item has no description.

Private FSDLSurface: PSDL_Surface;

This item has no description.

Private FWindowHandle: Longword;

This item has no description.

Private FSDLWindow: PSDL_Window;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Close;

Closes an already opened SDL Window. NOTE: will also kill the app due to an SDL limitation...

Public procedure Open;

Initializes and Opens an SDL window

Public procedure PollEvents;

Polls SDL events. SDL events can be either polled "manually", through a call to this method, or automatically via ThreadEventPolling

Public procedure SwapBuffers;

Swap front and back buffer

Public procedure UpdateWindow;

Applies changes (size, pixeldepth...) to the opened window

Properties

Public property Active: Boolean read FActive write SetActive;

Is the SDL window active (opened)? Adjusting this value as the same effect as invoking Open/Close

Published property Caption: String read FCaption write SetCaption;

Caption of the SDL window

Published property Height: Integer read FHeight write SetHeight default 480;

Height of the SDL window. To apply changes to an active window, call UpdateWindow

Published property OnClose: TNotifyEvent read FOnClose write FOnClose;

Fired whenever closing the window. The SDL surface is still defined and usable when the event happens

Published property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;

Fired whenever an event polling completes with no events left to poll

Published property OnOpen: TNotifyEvent read FOnOpen write FOnOpen;

Fired whenever Open succeeds. The SDL surface is defined and usable when the event happens

Published property OnResize: TNotifyEvent read FOnResize write FOnResize;

Fired whenever the window is resized. Note: glViewPort call is handled automatically for OpenGL windows

Published property OnSDLEvent: TSDLEvent read FOnSDLEvent write FOnSDLEvent;

Fired whenever an SDL Event is polled. SDL_QUITEV and SDL_VIDEORESIZE are not passed to this event handler, they are passed via OnClose and OnResize respectively

Published property Options: TSDLWindowOptions read FOptions write SetOptions default cDefaultSDLWindowOptions;

Options for the SDL window. To apply changes to an active window, call UpdateWindow

Published property PixelDepth: TSDLWindowPixelDepth read FPixelDepth write SetPixelDepth default vpd24bits;

PixelDepth of the SDL window. To apply changes to an active window, call UpdateWindow

Public property SDLSurface: PSDL_Surface read FSDLSurface;

Presents the SDL surface of the window. If Active is False, this value is undefined

Public property SDLWindow: PSDL_Window read FSDLWindow;

Presents the SDL window. If Active is False, this value is undefined

Published property ThreadedEventPolling: Boolean read FThreadedEventPolling write SetThreadedEventPolling default True;

Controls automatic threaded event polling

Published property ThreadPriority: TThreadPriority read FThreadPriority write SetThreadPriority default tpLower;

Priority of the event polling thread

Published property ThreadSleepLength: Integer read FThreadSleepLength write SetThreadSleepLength default 1;

Sleep length between pollings in the polling thread

Published property Width: Integer read FWidth write SetWidth default 640;

Width of the SDL window. To apply changes to an active window, call UpdateWindow

Public property WindowHandle: Cardinal read FWindowHandle write FWindowHandle;

Experimental: ask SDL to reuse and existing WindowHandle


GLSysHelp v.2.5: GLS.SDL.Window: Class ESDLError

Class ESDLError

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SDL.Window

Declaration

type ESDLError = class(Exception)

Description

Generic SDL or SDLWindow exception

Hierarchy

  • TObject
  • Exception
  • ESDLError


GLSysHelp v.2.5: GLS.Selection

Unit GLS.Selection

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.SysUtils
  • System.Classes
  • GLScene.OpenGLTokens
  • GLS.Context
  • GLS.VectorLists
  • GLScene.VectorGeometry
  • GLS.BaseClasses
  • GLS.PersistentClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPickRecord |
Class TGLPickList |
Class TGLBaseSelectTechnique |
Class TGLSelectRenderModeTechnique |

Functions and Procedures

function GetBestSelectorClass: TGLBaseSelectTechniqueClass; inline;

Types

TGLBaseSelectTechniqueClass = class of TGLBaseSelectTechnique;
TPickSortType = (...);
TPickSubObjects = array of LongInt;

Constants

MAX_OBJECT_STACK_DEPTH = 512;

Description

Functions and Procedures

function GetBestSelectorClass: TGLBaseSelectTechniqueClass; inline;

This item has no description.

Types

TGLBaseSelectTechniqueClass = class of TGLBaseSelectTechnique;

This item has no description.

TPickSortType = (...);

This item has no description.

Values
  • psDefault
  • psName
  • psMinDepth
  • psMaxDepth
TPickSubObjects = array of LongInt;

This item has no description.

Constants

MAX_OBJECT_STACK_DEPTH = 512;


GLSysHelp v.2.5: GLS.Selection: Class TPickRecord

Class TPickRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Selection

Declaration

type TPickRecord = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TPickRecord

Overview

Fields

Public | AObject: TGLUpdateAbleComponent;
Public | SubObjects: TPickSubObjects;
Public | ZMin: Single;
Public | ZMax: Single;

Description

Fields

Public AObject: TGLUpdateAbleComponent;

This item has no description.

Public SubObjects: TPickSubObjects;

This item has no description.

Public ZMin: Single;

This item has no description.

Public ZMax: Single;


GLSysHelp v.2.5: GLS.Selection: Class TGLPickList

Class TGLPickList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Selection

Declaration

type TGLPickList = class(TGLPersistentObjectList)

Description

List class for object picking. This list is used to store the results of a PickObjects call.

Hierarchy

  • TGLPersistentObjectList
  • TGLPickList

Overview

Methods

Public | constructor Create(aSortType: TPickSortType); reintroduce;
Public | function FindObject(AObject: TObject): Integer;
Private | function GetFar(aValue: Integer): Single;
Private | function GetHit(aValue: Integer): TObject;
Private | function GetNear(aValue: Integer): Single;
Private | function GetSubObjects(aValue: Integer): TPickSubObjects;
Public | procedure AddHit(obj: TObject; const subObj: TPickSubObjects; zMin, zMax: Single);
Public | procedure Clear; override;

Properties

Public | property FarDistance[Index: Integer]: Single read GetFar;
Public | property Hit[Index: Integer]: TObject read GetHit;
Public | property NearDistance[Index: Integer]: Single read GetNear;
Public | property SubObjects[Index: Integer]: TPickSubObjects read GetSubObjects;

Description

Methods

Public constructor Create(aSortType: TPickSortType); reintroduce;

This item has no description.

Public function FindObject(AObject: TObject): Integer;

This item has no description.

Private function GetFar(aValue: Integer): Single;

This item has no description.

Private function GetHit(aValue: Integer): TObject;

This item has no description.

Private function GetNear(aValue: Integer): Single;

This item has no description.

Private function GetSubObjects(aValue: Integer): TPickSubObjects;

This item has no description.

Public procedure AddHit(obj: TObject; const subObj: TPickSubObjects; zMin, zMax: Single);

This item has no description.

Public procedure Clear; override;

This item has no description.

Properties

Public property FarDistance[Index: Integer]: Single read GetFar;

This item has no description.

Public property Hit[Index: Integer]: TObject read GetHit;

This item has no description.

Public property NearDistance[Index: Integer]: Single read GetNear;

This item has no description.

Public property SubObjects[Index: Integer]: TPickSubObjects read GetSubObjects;


GLSysHelp v.2.5: GLS.Selection: Class TGLBaseSelectTechnique

Class TGLBaseSelectTechnique

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Selection

Declaration

type TGLBaseSelectTechnique = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBaseSelectTechnique

Overview

Methods

Public | class function IsSupported: Boolean; virtual; abstract;
Public | function Stop: Boolean; virtual; abstract;
Public | procedure FillPickingList(var AList: TGLPickList); virtual; abstract;
Public | procedure LoadObject(AName: TObject); virtual; abstract;
Public | procedure PopObject(); virtual; abstract;
Public | procedure PushObject(AName: TObject); virtual; abstract;
Public | procedure Start; virtual; abstract;

Properties

Public | property CurrentObject: TObject read GetObject write SetObject;
Public | property Hits: Integer read GetHits write SetHits;
Public | property ObjectCountGuess: Integer read FObjectCountGuess write SetObjectCountGuess;

Description

Methods

Public class function IsSupported: Boolean; virtual; abstract;

This item has no description.

Public function Stop: Boolean; virtual; abstract;

This item has no description.

Public procedure FillPickingList(var AList: TGLPickList); virtual; abstract;

This item has no description.

Public procedure LoadObject(AName: TObject); virtual; abstract;

This item has no description.

Public procedure PopObject(); virtual; abstract;

This item has no description.

Public procedure PushObject(AName: TObject); virtual; abstract;

This item has no description.

Public procedure Start; virtual; abstract;

This item has no description.

Properties

Public property CurrentObject: TObject read GetObject write SetObject;

This item has no description.

Public property Hits: Integer read GetHits write SetHits;

This item has no description.

Public property ObjectCountGuess: Integer read FObjectCountGuess write SetObjectCountGuess;


GLSysHelp v.2.5: GLS.Selection: Class TGLSelectRenderModeTechnique

Class TGLSelectRenderModeTechnique

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Selection

Declaration

type TGLSelectRenderModeTechnique = class(TGLBaseSelectTechnique)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBaseSelectTechnique
  • TGLSelectRenderModeTechnique

Overview

Fields

Private FBuffer: array of Cardinal;

Methods

Public | class function IsSupported: Boolean; override;
Public | function Stop: Boolean; override;
Public | procedure FillPickingList(var AList: TGLPickList); override;
Public | procedure Start; override;

Properties

Public | property CurrentObject;
Public | property Hits;
Public | property ObjectCountGuess;

Description

Fields

Private FBuffer: array of Cardinal;

This item has no description.

Methods

Public class function IsSupported: Boolean; override;

This item has no description.

Public function Stop: Boolean; override;

This item has no description.

Public procedure FillPickingList(var AList: TGLPickList); override;

This item has no description.

Public procedure Start; override;

This item has no description.

Properties

Public property CurrentObject;

This item has no description.

Public property Hits;

This item has no description.

Public property ObjectCountGuess;


GLSysHelp v.2.5: GLS.ShadowHDS

Unit GLS.ShadowHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.VectorLists
  • GLS.HeightData
  • GLS.Graphics
  • GLScene.VectorGeometry
  • GLS.Texture
  • GLScene.VectorTypes
  • GLS.Coordinates
  • GLS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShadowHDS |

Types

TNewTilePreparedEvent = procedure(Sender: TGLShadowHDS; heightData: TGLHeightData; ShadowMapMaterial: TGLLibMaterial) of object;
TThreadBmp32 = procedure(Sender: TGLShadowHDS; heightData: TGLHeightData; bmp32: TGLBitmap32) of object;

Description

Types

TNewTilePreparedEvent = procedure(Sender: TGLShadowHDS; heightData: TGLHeightData; ShadowMapMaterial: TGLLibMaterial) of object;

This item has no description.

TThreadBmp32 = procedure(Sender: TGLShadowHDS; heightData: TGLHeightData; bmp32: TGLBitmap32) of object;


GLSysHelp v.2.5: GLS.ShadowHDS: Class TGLShadowHDS

Class TGLShadowHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ShadowHDS

Declaration

type TGLShadowHDS = class(TGLHeightDataSourceFilter)

Description

An Height Data Source that generates terrain shadow maps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLHeightDataSourceFilter
  • TGLShadowHDS

Overview

Fields

Private | FTileSize: integer;
Private | FShadowmapLibrary: TGLMaterialLibrary;
Private | FLightVector: TGLCoordinates;
Private | FScale: TGLCoordinates;
Private | FScaleVec: TVector3f;
Private | FOnNewTilePrepared: TNewTilePreparedEvent;
Private | FOnThreadBmp32: TThreadBmp32;
Private | FMaxTextures: integer;
Private | Step: TVector3f;
Private | FScanDistance: integer;
Private | FSoftRange: cardinal;
Private | FDiffuse: single;
Private | FAmbient: single;
Private | OwnerHDS: TGLHeightDataSource;
Public | SkipGenerate: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function RayCastShadowHeight(HD: TGLHeightData; localX, localY: single): single; overload;
Public | function Shade(heightData: TGLHeightData; x, y: integer; ShadowHeight, TerrainHeight: single): byte;
Public | procedure AfterPreparingData(heightData: TGLHeightData); override;
Public | procedure BeforePreparingData(heightData: TGLHeightData); override;
Public | procedure GenerateShadowMap(heightData: TGLHeightData; ShadowMap: TGLBitmap32; scale: single);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreparingData(heightData: TGLHeightData); override;
Public | procedure RayCastLine(heightData: TGLHeightData; Lx, Ly: single; ShadowMap: TGLBitmap32);
Public | procedure TrimTextureCache(MaxTextureCount: integer = 0);

Properties

Published | property Ambient: single read FAmbient write SetAmbient;
Published | property Diffuse: single read FDiffuse write SetDiffuse;
Published | property LightVector: TGLCoordinates read FLightVector write SetLightVector;
Published | property MaxTextures: integer read FMaxTextures write FMaxTextures;
Published | property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property OnSourceDataFetched;
Published | property OnThreadBmp32: TThreadBmp32 read FOnThreadBmp32 write FOnThreadBmp32;
Published | property scale: TGLCoordinates read FScale write FScale;
Published | property ScanDistance: integer read FScanDistance write FScanDistance;
Published | property ShadowmapLibrary: TGLMaterialLibrary read FShadowmapLibrary write SetShadowmapLibrary;
Published | property SoftRange: cardinal read FSoftRange write SetSoftRange;

Description

Fields

Private FTileSize: integer;

This item has no description.

Private FShadowmapLibrary: TGLMaterialLibrary;

This item has no description.

Private FLightVector: TGLCoordinates;

This item has no description.

Private FScale: TGLCoordinates;

This item has no description.

Private FScaleVec: TVector3f;

This item has no description.

Private FOnNewTilePrepared: TNewTilePreparedEvent;

This item has no description.

Private FOnThreadBmp32: TThreadBmp32;

This item has no description.

Private FMaxTextures: integer;

FSubSampling : Integer;

Private Step: TVector3f;

This item has no description.

Private FScanDistance: integer;

This item has no description.

Private FSoftRange: cardinal;

This item has no description.

Private FDiffuse: single;

This item has no description.

Private FAmbient: single;

This item has no description.

Private OwnerHDS: TGLHeightDataSource;

This item has no description.

Public SkipGenerate: boolean;

When true, only a blank ShadowMap is generated (FAST), but OnThreadBmp32 is still called in a subthread.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function RayCastShadowHeight(HD: TGLHeightData; localX, localY: single): single; overload;

This traces a ray from a point on the terrain surface, back to the Lightsource, while testing for any intersections with the terrain. It returns the height of the shadow. There is no shadow if the shadow height is equal to terrain height. This is slow, but only needs to be done for pixels along the tile edge, facing the light.

Public function Shade(heightData: TGLHeightData; x, y: integer; ShadowHeight, TerrainHeight: single): byte;

Calculate the pixel brightness, using Direct Diffuse light and Ambient light. DirectLight = 1 if in direct sunlight (no shadows) 0 if in shadow. (Use "SoftRange" for soft shadow edges i.e. 1>Directlight>0 ) AmbientLight = Relative to Angle between surface Normal and sky (Directly up) ie. Vertical walls are darker because they see less sky. DiffuseLight = Relative to Angle between surface Normal, and Sun vector.

Public procedure AfterPreparingData(heightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.AfterPreparingData.

This is called After "StartPreparingData", but always from the main thread

Public procedure BeforePreparingData(heightData: TGLHeightData); override;

Prepare a blank texture for this tile's lightmap, from the main thread

Public procedure GenerateShadowMap(heightData: TGLHeightData; ShadowMap: TGLBitmap32; scale: single);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure PreparingData(heightData: TGLHeightData); override;

Calculate the lightmap from the HD thread, using the attached blank texture

Public procedure RayCastLine(heightData: TGLHeightData; Lx, Ly: single; ShadowMap: TGLBitmap32);

This item has no description.

Public procedure TrimTextureCache(MaxTextureCount: integer = 0);

This will repeatedly delete the oldest unused texture from the TGLMaterialLibrary, until the texture count drops to MaxTextureCount. DONT use this if you used TGLHeightData.MaterialName to link your terrain textures. Either use with TGLHeightData.LibMaterial, or manually delete unused LightMap textures.

Properties

Published property Ambient: single read FAmbient write SetAmbient;

This item has no description.

Published property Diffuse: single read FDiffuse write SetDiffuse;

Shadow height above sufrace for max diffuse light

Published property LightVector: TGLCoordinates read FLightVector write SetLightVector;

This item has no description.

Published property MaxTextures: integer read FMaxTextures write FMaxTextures;

This item has no description.

Published property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;

WARNING: This runs in a subthread

Published property OnSourceDataFetched;

This item has no description.

Published property OnThreadBmp32: TThreadBmp32 read FOnThreadBmp32 write FOnThreadBmp32;

This item has no description.

Published property scale: TGLCoordinates read FScale write FScale;

This item has no description.

Published property ScanDistance: integer read FScanDistance write FScanDistance;

This item has no description.

Published property ShadowmapLibrary: TGLMaterialLibrary read FShadowmapLibrary write SetShadowmapLibrary;

This item has no description.

Published property SoftRange: cardinal read FSoftRange write SetSoftRange;


GLSysHelp v.2.5: GLS.ShadowPlane

Unit GLS.ShadowPlane

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.Types
  • GLScene.OpenGLTokens
  • GLS.PersistentClasses
  • GLScene.PipelineTransform
  • GLScene.VectorTypes
  • GLS.Scene
  • GLScene.VectorGeometry
  • GLS.Objects
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.State
  • GLScene.TextureFormat
  • GLS.Context
  • GLS.Material
  • GLS.Texture
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShadowPlane |

Types

TShadowPlaneOption = (...);
TShadowPlaneOptions = set of TShadowPlaneOption;

Constants

cDefaultShadowPlaneOptions = [spoUseStencil, spoScissor];

Description

Types

TShadowPlaneOption = (...);

This item has no description.

Values
  • spoUseStencil
  • spoScissor
  • spoTransparent
  • spoIgnoreZ
TShadowPlaneOptions = set of TShadowPlaneOption;

This item has no description.

Constants

cDefaultShadowPlaneOptions = [spoUseStencil, spoScissor];


GLSysHelp v.2.5: GLS.ShadowPlane: Class TGLShadowPlane

Class TGLShadowPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ShadowPlane

Declaration

type TGLShadowPlane = class(TGLPlane)

Description

A simple shadow plane. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered). If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently. You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPlane
  • TGLShadowPlane

Overview

Fields

Private | FRendering: Boolean;
Private | FShadowingObject: TGLBaseSceneObject;
Private | FShadowedLight: TGLLightSource;
Private | FShadowColor: TGLColor;
Private | FShadowOptions: TShadowPlaneOptions;
Private | FOnBeginRenderingShadows: TNotifyEvent;
Private | FOnEndRenderingShadows: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property OnBeginRenderingShadows: TNotifyEvent read FOnBeginRenderingShadows write FOnBeginRenderingShadows;
Published | property OnEndRenderingShadows: TNotifyEvent read FOnEndRenderingShadows write FOnEndRenderingShadows;
Published | property ShadowColor: TGLColor read FShadowColor write SetShadowColor;
Published | property ShadowedLight: TGLLightSource read FShadowedLight write SetShadowedLight;
Published | property ShadowingObject: TGLBaseSceneObject read FShadowingObject write SetShadowingObject;
Published | property ShadowOptions: TShadowPlaneOptions read FShadowOptions write SetShadowOptions default cDefaultShadowPlaneOptions;

Description

Fields

Private FRendering: Boolean;

This item has no description.

Private FShadowingObject: TGLBaseSceneObject;

This item has no description.

Private FShadowedLight: TGLLightSource;

This item has no description.

Private FShadowColor: TGLColor;

This item has no description.

Private FShadowOptions: TShadowPlaneOptions;

This item has no description.

Private FOnBeginRenderingShadows: TNotifyEvent;

This item has no description.

Private FOnEndRenderingShadows: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property OnBeginRenderingShadows: TNotifyEvent read FOnBeginRenderingShadows write FOnBeginRenderingShadows;

Fired before the shadows are rendered

Published property OnEndRenderingShadows: TNotifyEvent read FOnEndRenderingShadows write FOnEndRenderingShadows;

Fired after the shadows are rendered

Published property ShadowColor: TGLColor read FShadowColor write SetShadowColor;

The shadow's color. This color is transparently blended to make shadowed area darker

Published property ShadowedLight: TGLLightSource read FShadowedLight write SetShadowedLight;

The light which casts shadows. It must be enabled otherwise shadows won't be cast

Published property ShadowingObject: TGLBaseSceneObject read FShadowingObject write SetShadowingObject;

Selects the object to mirror.If nil, the whole scene is mirrored.

Published property ShadowOptions: TShadowPlaneOptions read FShadowOptions write SetShadowOptions default cDefaultShadowPlaneOptions;

Controls rendering options: spoUseStencil: plane area is stenciled, prevents shadowing objects to be visible on the sides of the mirror (stencil buffer must be active in the viewer too). It also allows shadows to be partial (blended). spoScissor: plane area is 'scissored', this should improve rendering speed by limiting rendering operations and fill rate, may have adverse effects on old hardware in rare cases spoTransparent: does not render the plane's material, may help improve performance if you're fillrate limited, are using the stencil, and your hardware has optimized stencil-only writes


GLSysHelp v.2.5: GLS.ShadowVolume

Unit GLS.ShadowVolume

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.Silhouette
  • GLS.PersistentClasses
  • GLS.Coordinates
  • GLScene.PipelineTransform
  • GLScene.GeometryBB
  • GLS.Color
  • GLS.Selection
  • GLS.RenderContextInfo
  • GLS.VectorLists
  • GLS.State
  • GLScene.VectorTypes
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShadowVolumeCaster |
Class TGLShadowVolumeOccluder |
Class TGLShadowVolumeLight |
Class TGLShadowVolumeCasters |
Class TGLShadowVolume |

Types

TGLShadowCastingMode = (...);
TGLShadowVolumeCapping = (...);
TGLShadowVolumeMode = (...);
TGLShadowVolumeOption = (...);
TGLShadowVolumeOptions = set of TGLShadowVolumeOption;

Description

Types

TGLShadowCastingMode = (...);

Determines when a caster should actually produce a shadow; scmAlways : Caster always produces a shadow, ignoring visibility scmVisible : Caster casts shadow if the object has visible=true scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true scmParentVisible : Caster produces shadow if parent has visible=true scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting)

Values
  • scmAlways
  • scmVisible
  • scmRecursivelyVisible
  • scmParentVisible
  • scmParentRecursivelyVisible
TGLShadowVolumeCapping = (...);

Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option. Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera.

svcDefault : Default behaviour svcAlways : Always generates caps svcNever : Never generates caps

Values
  • svcDefault
  • svcAlways
  • svcNever
TGLShadowVolumeMode = (...);

Shadow rendering modes. svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) svmOff : no shadowing will take place

Values
  • svmAccurate
  • svmDarkening
  • svmOff
TGLShadowVolumeOption = (...);

Shadow volume rendering options/optimizations. svoShowVolumes : make the shadow volumes visible svoDesignVisible : the shadow are visible at design-time svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface

Values
  • svoShowVolumes
  • svoCacheSilhouettes
  • svoScissorClips
  • svoWorldScissorClip
  • svoDesignVisible
TGLShadowVolumeOptions = set of TGLShadowVolumeOption;


GLSysHelp v.2.5: GLS.ShadowVolume: Class TGLShadowVolumeCaster

Class TGLShadowVolumeCaster

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ShadowVolume

Declaration

type TGLShadowVolumeCaster = class(TCollectionItem)

Description

Specifies an individual shadow caster. Can be a light or an opaque object.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLShadowVolumeCaster

Overview

Fields

Private | FCaster: TGLBaseSceneObject;
Private | FEffectiveRadius: Single;
Private | FCapping: TGLShadowVolumeCapping;
Private | FCastingMode: TGLShadowCastingMode;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Capping: TGLShadowVolumeCapping read FCapping write FCapping default svcDefault;
Public | property Caster: TGLBaseSceneObject read FCaster write SetCaster;
Published | property CastingMode: TGLShadowCastingMode read FCastingMode write FCastingMode default scmRecursivelyVisible;
Published | property EffectiveRadius: Single read FEffectiveRadius write FEffectiveRadius;
Public | property GLShadowVolume: TGLShadowVolume read GetGLShadowVolume;

Description

Fields

Private FCaster: TGLBaseSceneObject;

This item has no description.

Private FEffectiveRadius: Single;

This item has no description.

Private FCapping: TGLShadowVolumeCapping;

This item has no description.

Private FCastingMode: TGLShadowCastingMode;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Capping: TGLShadowVolumeCapping read FCapping write FCapping default svcDefault;

Specifies if the shadow volume should be capped. Capping helps solve shadowing artefacts, at the cost of performance.

Public property Caster: TGLBaseSceneObject read FCaster write SetCaster;

Shadow casting object. Can be an opaque object or a lightsource.

Published property CastingMode: TGLShadowCastingMode read FCastingMode write FCastingMode default scmRecursivelyVisible;

Determines when an object should cast a shadow or not. Typically, objects should only cast shadows when recursively visible. But if you're using dummy shadow casters which are less complex than their parent objects, you should use scmParentRecursivelyVisible.

Published property EffectiveRadius: Single read FEffectiveRadius write FEffectiveRadius;

Radius beyond which the caster can be ignored. Zero (default value) means the caster can never be ignored.

Public property GLShadowVolume: TGLShadowVolume read GetGLShadowVolume;


GLSysHelp v.2.5: GLS.ShadowVolume: Class TGLShadowVolumeOccluder

Class TGLShadowVolumeOccluder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ShadowVolume

Declaration

type TGLShadowVolumeOccluder = class(TGLShadowVolumeCaster)

Description

Specifies an individual shadow casting occluder.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLShadowVolumeCaster
  • TGLShadowVolumeOccluder

Overview

Properties

Published property Caster;

Description

Properties

Published property Caster;

This item has no description. Showing description inherited from TGLShadowVolumeCaster.Caster.

Shadow casting object. Can be an opaque object or a lightsource.


GLSysHelp v.2.5: GLS.ShadowVolume: Class TGLShadowVolumeLight

Class TGLShadowVolumeLight

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ShadowVolume

Declaration

type TGLShadowVolumeLight = class(TGLShadowVolumeCaster)

Description

Specifies an individual shadow casting light.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLShadowVolumeCaster
  • TGLShadowVolumeLight

Overview

Fields

Private FSilhouettes: TGLPersistentObjectList;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure FlushSilhouetteCache;

Properties

Published property LightSource: TGLLightSource read GetLightSource write SetLightSource;

Description

Fields

Private FSilhouettes: TGLPersistentObjectList;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure FlushSilhouetteCache;

This item has no description.

Properties

Published property LightSource: TGLLightSource read GetLightSource write SetLightSource;

Shadow casting lightsource.


GLSysHelp v.2.5: GLS.ShadowVolume: Class TGLShadowVolumeCasters

Class TGLShadowVolumeCasters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ShadowVolume

Declaration

type TGLShadowVolumeCasters = class(TOwnedCollection)

Description

Collection of TGLShadowVolumeCaster.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLShadowVolumeCasters

Overview

Methods

Public | function AddCaster(obj: TGLBaseSceneObject; effectiveRadius: Single = 0; CastingMode: TGLShadowCastingMode = scmRecursivelyVisible): TGLShadowVolumeCaster;
Public | function IndexOfCaster(obj: TGLBaseSceneObject): Integer;
Public | procedure RemoveCaster(obj: TGLBaseSceneObject);

Properties

Public property Items[index: Integer]: TGLShadowVolumeCaster read GetItems;

Description

Methods

Public function AddCaster(obj: TGLBaseSceneObject; effectiveRadius: Single = 0; CastingMode: TGLShadowCastingMode = scmRecursivelyVisible): TGLShadowVolumeCaster;

This item has no description.

Public function IndexOfCaster(obj: TGLBaseSceneObject): Integer;

This item has no description.

Public procedure RemoveCaster(obj: TGLBaseSceneObject);

This item has no description.

Properties

Public property Items[index: Integer]: TGLShadowVolumeCaster read GetItems;


GLSysHelp v.2.5: GLS.ShadowVolume: Class TGLShadowVolume

Class TGLShadowVolume

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ShadowVolume

Declaration

type TGLShadowVolume = class(TGLImmaterialSceneObject)

Description

Simple shadow volumes. Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection. Shadow volumes require that the buffer allows stencil buffers, GLSceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly. Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLShadowVolume

Overview

Fields

Private | FActive: Boolean;
Private | FRendering: Boolean;
Private | FLights: TGLShadowVolumeCasters;
Private | FOccluders: TGLShadowVolumeCasters;
Private | FCapping: TGLShadowVolumeCapping;
Private | FOptions: TGLShadowVolumeOptions;
Private | FMode: TGLShadowVolumeMode;
Private | FDarkeningColor: TGLColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure FlushSilhouetteCache;

Properties

Published | property Active: Boolean read FActive write SetActive default True;
Published | property Capping: TGLShadowVolumeCapping read FCapping write FCapping default svcAlways;
Published | property DarkeningColor: TGLColor read FDarkeningColor write SetDarkeningColor;
Published | property Lights: TGLShadowVolumeCasters read FLights write SetLights;
Published | property Mode: TGLShadowVolumeMode read FMode write SetMode default svmAccurate;
Published | property Occluders: TGLShadowVolumeCasters read FOccluders write SetOccluders;
Published | property Options: TGLShadowVolumeOptions read FOptions write SetOptions default [svoCacheSilhouettes, svoScissorClips];

Description

Fields

Private FActive: Boolean;

This item has no description.

Private FRendering: Boolean;

This item has no description.

Private FLights: TGLShadowVolumeCasters;

This item has no description.

Private FOccluders: TGLShadowVolumeCasters;

This item has no description.

Private FCapping: TGLShadowVolumeCapping;

This item has no description.

Private FOptions: TGLShadowVolumeOptions;

This item has no description.

Private FMode: TGLShadowVolumeMode;

This item has no description.

Private FDarkeningColor: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure FlushSilhouetteCache;

This item has no description.

Properties

Published property Active: Boolean read FActive write SetActive default True;

Determines if shadow volume rendering is active. When set to false, children will be rendered without any shadowing or multipass lighting.

Published property Capping: TGLShadowVolumeCapping read FCapping write FCapping default svcAlways;

Specifies if the shadow volume should be capped. Capping helps solve shadowing artefacts, at the cost of performance.

Published property DarkeningColor: TGLColor read FDarkeningColor write SetDarkeningColor;

Darkening color used in svmDarkening mode.

Published property Lights: TGLShadowVolumeCasters read FLights write SetLights;

Lights that cast shadow volumes.

Published property Mode: TGLShadowVolumeMode read FMode write SetMode default svmAccurate;

Shadow rendering mode.

Published property Occluders: TGLShadowVolumeCasters read FOccluders write SetOccluders;

Occluders that cast shadow volumes.

Published property Options: TGLShadowVolumeOptions read FOptions write SetOptions default [svoCacheSilhouettes, svoScissorClips];

Shadow volume rendering options.


GLSysHelp v.2.5: GLS.Silhouette

Unit GLS.Silhouette

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TGLSilhouetteParameters |
Class TGLSilhouette |
Class TGLBaseConnectivity |
Class TGLConnectivity |

Types

TGSilhouetteStyle = (...);

Description

Types

TGSilhouetteStyle = (...);

This item has no description.

Values
  • ssOmni
  • ssParallel


GLSysHelp v.2.5: GLS.Silhouette: Packed Record TGLSilhouetteParameters

Packed Record TGLSilhouetteParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Silhouette

Declaration

type TGLSilhouetteParameters = packed record

Description

Silouhette generation parameters. SeenFrom and LightDirection are expected in local coordinates.

Overview

Fields

Public | SeenFrom: TAffineVector;
Public | LightDirection: TAffineVector;
Public | Style: TGSilhouetteStyle;
Public | CappingRequired: Boolean;

Description

Fields

Public SeenFrom: TAffineVector;

This item has no description.

Public LightDirection: TAffineVector;

This item has no description.

Public Style: TGSilhouetteStyle;

This item has no description.

Public CappingRequired: Boolean;


GLSysHelp v.2.5: GLS.Silhouette: Class TGLSilhouette

Class TGLSilhouette

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Silhouette

Declaration

type TGLSilhouette = class(TObject)

Description

Base class storing a volume silhouette. Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system. This is the base class, you can use the TGLSilhouette subclass if you need some helper methods for generating the indexed sets.

Hierarchy

  • TObject
  • TGLSilhouette

Overview

Fields

Private | FVertices: TGLVectorList;
Private | FIndices: TGLIntegerList;
Private | FCapIndices: TGLIntegerList;
Private | FParameters: TGLSilhouetteParameters;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | procedure AddCapToSilhouette(const v0, v1, v2: TAffineVector; tightButSlow: Boolean); inline;
Public | procedure AddEdgeToSilhouette(const v0, v1: TAffineVector; tightButSlow: Boolean); inline;
Public | procedure AddIndexedCapToSilhouette(const Vi0, Vi1, vi2: integer); inline;
Public | procedure AddIndexedEdgeToSilhouette(const Vi0, Vi1: integer); inline;
Public | procedure Clear; inline;
Public | procedure ExtrudeVerticesToInfinity(const origin: TAffineVector);
Public | procedure Flush; virtual;

Properties

Public | property CapIndices: TGLIntegerList read FCapIndices write SetCapIndices;
Public | property Indices: TGLIntegerList read FIndices write SetIndices;
Public | property Parameters: TGLSilhouetteParameters read FParameters write FParameters;
Public | property Vertices: TGLVectorList read FVertices write SetVertices;

Description

Fields

Private FVertices: TGLVectorList;

This item has no description.

Private FIndices: TGLIntegerList;

This item has no description.

Private FCapIndices: TGLIntegerList;

This item has no description.

Private FParameters: TGLSilhouetteParameters;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddCapToSilhouette(const v0, v1, v2: TAffineVector; tightButSlow: Boolean); inline;

Adds a capping triangle to the silhouette. If TightButSlow is true, no vertices will be doubled in the silhouette list. This should only be used when creating re-usable silhouettes, because it's much slower.

Public procedure AddEdgeToSilhouette(const v0, v1: TAffineVector; tightButSlow: Boolean); inline;

Adds an edge (two vertices) to the silhouette. If TightButSlow is true, no vertices will be doubled in the silhouette list. This should only be used when creating re-usable silhouettes, because it's much slower.

Public procedure AddIndexedCapToSilhouette(const Vi0, Vi1, vi2: integer); inline;

This item has no description.

Public procedure AddIndexedEdgeToSilhouette(const Vi0, Vi1: integer); inline;

This item has no description.

Public procedure Clear; inline;

This item has no description.

Public procedure ExtrudeVerticesToInfinity(const origin: TAffineVector);

This item has no description.

Public procedure Flush; virtual;

This item has no description.

Properties

Public property CapIndices: TGLIntegerList read FCapIndices write SetCapIndices;

This item has no description.

Public property Indices: TGLIntegerList read FIndices write SetIndices;

This item has no description.

Public property Parameters: TGLSilhouetteParameters read FParameters write FParameters;

This item has no description.

Public property Vertices: TGLVectorList read FVertices write SetVertices;


GLSysHelp v.2.5: GLS.Silhouette: Class TGLBaseConnectivity

Class TGLBaseConnectivity

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Silhouette

Declaration

type TGLBaseConnectivity = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBaseConnectivity

Overview

Methods

Public | constructor Create(APrecomputeFaceNormal: Boolean); virtual;
Public | procedure CreateSilhouette(const ASilhouetteParameters: TGLSilhouetteParameters; var ASilhouette: TGLSilhouette; AddToSilhouette: Boolean); virtual;

Properties

Public | property EdgeCount: integer read GetEdgeCount;
Public | property FaceCount: integer read GetFaceCount;
Public | property PrecomputeFaceNormal: Boolean read FPrecomputeFaceNormal;

Description

Methods

Public constructor Create(APrecomputeFaceNormal: Boolean); virtual;

This item has no description.

Public procedure CreateSilhouette(const ASilhouetteParameters: TGLSilhouetteParameters; var ASilhouette: TGLSilhouette; AddToSilhouette: Boolean); virtual;

This item has no description.

Properties

Public property EdgeCount: integer read GetEdgeCount;

This item has no description.

Public property FaceCount: integer read GetFaceCount;

This item has no description.

Public property PrecomputeFaceNormal: Boolean read FPrecomputeFaceNormal;


GLSysHelp v.2.5: GLS.Silhouette: Class TGLConnectivity

Class TGLConnectivity

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Silhouette

Declaration

type TGLConnectivity = class(TGLBaseConnectivity)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBaseConnectivity
  • TGLConnectivity

Overview

Methods

Public | constructor Create(APrecomputeFaceNormal: Boolean); override;
Public | destructor Destroy; override;
Public | function AddFace(const vertex0, vertex1, vertex2: TAffineVector): integer; inline;
Public | function AddIndexedEdge(vertexIndex0, vertexIndex1: integer; FaceID: integer): integer;
Public | function AddIndexedFace(Vi0, Vi1, vi2: integer): integer;
Public | function AddQuad(const vertex0, vertex1, vertex2, vertex3: TAffineVector): integer; inline;
Public | procedure Clear; virtual;
Public | procedure CreateSilhouette(const silhouetteParameters: TGLSilhouetteParameters; var ASilhouette: TGLSilhouette; AddToSilhouette: Boolean);

Properties

Public | property EdgeCount: integer read GetEdgeCount;
Public | property FaceCount: integer read GetFaceCount;

Description

Methods

Public constructor Create(APrecomputeFaceNormal: Boolean); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddFace(const vertex0, vertex1, vertex2: TAffineVector): integer; inline;

This item has no description.

Public function AddIndexedEdge(vertexIndex0, vertexIndex1: integer; FaceID: integer): integer;

This item has no description.

Public function AddIndexedFace(Vi0, Vi1, vi2: integer): integer;

This item has no description.

Public function AddQuad(const vertex0, vertex1, vertex2, vertex3: TAffineVector): integer; inline;

This item has no description.

Public procedure Clear; virtual;

Clears out all connectivity information.

Public procedure CreateSilhouette(const silhouetteParameters: TGLSilhouetteParameters; var ASilhouette: TGLSilhouette; AddToSilhouette: Boolean);

This item has no description.

Properties

Public property EdgeCount: integer read GetEdgeCount;

This item has no description.

Public property FaceCount: integer read GetFaceCount;


GLSysHelp v.2.5: GLS.SimpleNavigation

Unit GLS.SimpleNavigation

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Types
  • System.Classes
  • System.SysUtils
  • System.TypInfo
  • System.Math
  • VCL.Forms
  • VCL.Controls
  • VCL.ExtCtrls
  • GLS.SceneForm
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.SceneViewer
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSimpleNavigationKeyCombination |
Class TGLSimpleNavigationKeyCombinations |
Class TGLSimpleNavigation |

Types

TGLSimpleNavigationAction = (...);
TGLSimpleNavigationCustomActionEvent = procedure(Sender: TGLSimpleNavigationKeyCombination; Shift: TShiftState; X, Y: Integer) of object;
TGLSimpleNavigationOption = (...);
TGLSimpleNavigationOptions = set of TGLSimpleNavigationOption;

Description

Types

TGLSimpleNavigationAction = (...);

This item has no description.

Values
  • snaNone
  • snaMoveAroundTarget
  • snaZoom
  • snaRotateTarget
  • snaCustom
TGLSimpleNavigationCustomActionEvent = procedure(Sender: TGLSimpleNavigationKeyCombination; Shift: TShiftState; X, Y: Integer) of object;

This item has no description.

TGLSimpleNavigationOption = (...);

This item has no description.

Values
  • snoInvertMoveAroundX
  • snoInvertMoveAroundY
  • snoInvertZoom: MoveAroundTarget.
  • snoInvertMouseWheel
  • snoInvertRotateX: Zoom.
  • snoInvertRotateY
  • snoMouseWheelHandled: RotateTarget.
  • snoShowFPS: MouseWheel.
TGLSimpleNavigationOptions = set of TGLSimpleNavigationOption;

Show FPS


GLSysHelp v.2.5: GLS.SimpleNavigation: Class TGLSimpleNavigationKeyCombination

Class TGLSimpleNavigationKeyCombination

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SimpleNavigation

Declaration

type TGLSimpleNavigationKeyCombination = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLSimpleNavigationKeyCombination

Overview

Fields

Private | FExitOnMatch: Boolean;
Private | FAction: TGLSimpleNavigationAction;
Private | FOnCustomAction: TGLSimpleNavigationCustomActionEvent;
Private | FShiftState: TShiftState;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Action: TGLSimpleNavigationAction read FAction write FAction default snaNone;
Published | property ExitOnMatch: Boolean read FExitOnMatch write FExitOnMatch default True;
Published | property OnCustomAction: TGLSimpleNavigationCustomActionEvent read FOnCustomAction write FOnCustomAction;
Published | property ShiftState: TShiftState read FShiftState write FShiftState default [];

Description

Fields

Private FExitOnMatch: Boolean;

This item has no description.

Private FAction: TGLSimpleNavigationAction;

This item has no description.

Private FOnCustomAction: TGLSimpleNavigationCustomActionEvent;

This item has no description.

Private FShiftState: TShiftState;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Action: TGLSimpleNavigationAction read FAction write FAction default snaNone;

This item has no description.

Published property ExitOnMatch: Boolean read FExitOnMatch write FExitOnMatch default True;

This item has no description.

Published property OnCustomAction: TGLSimpleNavigationCustomActionEvent read FOnCustomAction write FOnCustomAction;

This item has no description.

Published property ShiftState: TShiftState read FShiftState write FShiftState default [];


GLSysHelp v.2.5: GLS.SimpleNavigation: Class TGLSimpleNavigationKeyCombinations

Class TGLSimpleNavigationKeyCombinations

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SimpleNavigation

Declaration

type TGLSimpleNavigationKeyCombinations = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLSimpleNavigationKeyCombinations

Overview

Methods

Public | function Add: TGLSimpleNavigationKeyCombination; overload;
Public | function Add(const AShiftState: TShiftState; const AAction: TGLSimpleNavigationAction; const AExitOnMatch: Boolean = True): TGLSimpleNavigationKeyCombination; overload;
Private | function GetItems(Index: Integer): TGLSimpleNavigationKeyCombination;
Private | procedure SetItems(Index: Integer; const Value: TGLSimpleNavigationKeyCombination);

Properties

Public property Items[Index: Integer]: TGLSimpleNavigationKeyCombination read GetItems write SetItems;

Description

Methods

Public function Add: TGLSimpleNavigationKeyCombination; overload;

This item has no description.

Public function Add(const AShiftState: TShiftState; const AAction: TGLSimpleNavigationAction; const AExitOnMatch: Boolean = True): TGLSimpleNavigationKeyCombination; overload;

This item has no description.

Private function GetItems(Index: Integer): TGLSimpleNavigationKeyCombination;

This item has no description.

Private procedure SetItems(Index: Integer; const Value: TGLSimpleNavigationKeyCombination);

This item has no description.

Properties

Public property Items[Index: Integer]: TGLSimpleNavigationKeyCombination read GetItems write SetItems;


GLSysHelp v.2.5: GLS.SimpleNavigation: Class TGLSimpleNavigation

Class TGLSimpleNavigation

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SimpleNavigation

Declaration

type TGLSimpleNavigation = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLSimpleNavigation

Overview

Fields

Private | FTimer: TTimer;
Private | FForm: TCustomForm;
Private | FGLSceneViewer: TGLSceneViewer;
Private | FOldX: Integer;
Private | FOldY: Integer;
Private | FFormCaption: string;
Private | FMoveAroundTargetSpeed: Single;
Private | FZoomSpeed: Single;
Private | FOptions: TGLSimpleNavigationOptions;
Private | FKeyCombinations: TGLSimpleNavigationKeyCombinations;
Private | FRotateTargetSpeed: Single;
Private | FOnMouseMove: TMouseMoveEvent;
Private | FSceneForm: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function StoreFormCaption: Boolean;
Private | function StoreMoveAroundTargetSpeed: Boolean;
Private | function StoreRotateTargetSpeed: Boolean;
Private | function StoreZoomSpeed: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetForm(const Value: TCustomForm);
Private | procedure SetGLSceneViewer(const Value: TGLSceneViewer);
Private | procedure SetKeyCombinations(const Value: TGLSimpleNavigationKeyCombinations);
Private | procedure SetOptions(const Value: TGLSimpleNavigationOptions);
Private | procedure ShowFPS(Sender: TObject);
Private | procedure ViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Private | procedure ViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

Properties

Published | property Form: TCustomForm read FForm write SetForm;
Published | property FormCaption: string read FFormCaption write FFormCaption stored StoreFormCaption;
Published | property GLSceneViewer: TGLSceneViewer read FGLSceneViewer write SetGLSceneViewer;
Published | property KeyCombinations: TGLSimpleNavigationKeyCombinations read FKeyCombinations write SetKeyCombinations;
Published | property MoveAroundTargetSpeed: Single read FMoveAroundTargetSpeed write FMoveAroundTargetSpeed stored StoreMoveAroundTargetSpeed;
Published | property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;
Published | property Options: TGLSimpleNavigationOptions read FOptions write SetOptions default [snoMouseWheelHandled, snoShowFPS];
Published | property RotateTargetSpeed: Single read FRotateTargetSpeed write FRotateTargetSpeed stored StoreRotateTargetSpeed;
Published | property ZoomSpeed: Single read FZoomSpeed write FZoomSpeed stored StoreZoomSpeed;

Description

Fields

Private FTimer: TTimer;

This item has no description.

Private FForm: TCustomForm;

This item has no description.

Private FGLSceneViewer: TGLSceneViewer;

This item has no description.

Private FOldX: Integer;

This item has no description.

Private FOldY: Integer;

This item has no description.

Private FFormCaption: string;

This item has no description.

Private FMoveAroundTargetSpeed: Single;

This item has no description.

Private FZoomSpeed: Single;

This item has no description.

Private FOptions: TGLSimpleNavigationOptions;

This item has no description.

Private FKeyCombinations: TGLSimpleNavigationKeyCombinations;

This item has no description.

Private FRotateTargetSpeed: Single;

This item has no description.

Private FOnMouseMove: TMouseMoveEvent;

This item has no description.

Private FSceneForm: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function StoreFormCaption: Boolean;

This item has no description.

Private function StoreMoveAroundTargetSpeed: Boolean;

This item has no description.

Private function StoreRotateTargetSpeed: Boolean;

This item has no description.

Private function StoreZoomSpeed: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetForm(const Value: TCustomForm);

This item has no description.

Private procedure SetGLSceneViewer(const Value: TGLSceneViewer);

This item has no description.

Private procedure SetKeyCombinations(const Value: TGLSimpleNavigationKeyCombinations);

This item has no description.

Private procedure SetOptions(const Value: TGLSimpleNavigationOptions);

This item has no description.

Private procedure ShowFPS(Sender: TObject);

This item has no description.

Private procedure ViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

This item has no description.

Private procedure ViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

This item has no description.

Properties

Published property Form: TCustomForm read FForm write SetForm;

This item has no description.

Published property FormCaption: string read FFormCaption write FFormCaption stored StoreFormCaption;

This item has no description.

Published property GLSceneViewer: TGLSceneViewer read FGLSceneViewer write SetGLSceneViewer;

This item has no description.

Published property KeyCombinations: TGLSimpleNavigationKeyCombinations read FKeyCombinations write SetKeyCombinations;

This item has no description.

Published property MoveAroundTargetSpeed: Single read FMoveAroundTargetSpeed write FMoveAroundTargetSpeed stored StoreMoveAroundTargetSpeed;

This item has no description.

Published property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;

This item has no description.

Published property Options: TGLSimpleNavigationOptions read FOptions write SetOptions default [snoMouseWheelHandled, snoShowFPS];

This item has no description.

Published property RotateTargetSpeed: Single read FRotateTargetSpeed write FRotateTargetSpeed stored StoreRotateTargetSpeed;

This item has no description.

Published property ZoomSpeed: Single read FZoomSpeed write FZoomSpeed stored StoreZoomSpeed;


GLSysHelp v.2.5: GLS.SkyDome

Unit GLS.SkyDome

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • System.Math
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.Graphics
  • GLS.Color
  • GLS.Material
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TGLStarRecord |
Class TGLSkyBox |
Class TGLSkyDomeBand |
Class TGLSkyDomeBands |
Class TGLSkyDomeStar |
Class TGLSkyDomeStars |
Class TGLSkyDome |
Class TGLEarthSkyDome |
Record TGLStarSysData |
Record TGLStarData |
Record TGLPlanetData |
Record TGLMoonRingData |
Record TGLAsteroidData |
Record TGLOrbitalElements |
Record TOrbitalElementsData |

Functions and Procedures

function GMTDateTimeToJulianDay(const dt: TDateTime): Double;
function ComputeOrbitalElements(const oeData: TOrbitalElementsData; const d: Double): TGLOrbitalElements;
function ComputePlanetPosition(const orbitalElements: TGLOrbitalElements) : TAffineVector; overload;
function ComputePlanetPosition(const orbitalElementsData: TOrbitalElementsData; const d: Double): TAffineVector; overload;
function StarRecordPositionZUp(const starRecord: TGLStarRecord): TAffineVector;
function StarRecordPositionYUp(const starRecord: TGLStarRecord): TAffineVector;
function LonLatToPos(Lon, Lat: Single): TAffineVector;
function StarRecordColor(const starRecord: TGLStarRecord; bias: Single): TVector4f;

Types

PGLStarRecord = ˆTGLStarRecord;
TGLEarthSkydomeOption = (...);
TGLEarthSkydomeOptions = set of TGLEarthSkydomeOption;
TGLSkyBoxStyle = (...);
TGLSkyDomeOption = (...);
TGLSkyDomeOptions = set of TGLSkyDomeOption;

Constants

cSunOrbitalElements: TOrbitalElementsData = (NConst: 0.0; NVar: 0.0; iConst: 0.0; iVar: 0.0; wConst: 282.9404; wVar: 4.70935E-5; aConst: 1.000000; aVar: 0.0; eConst: 0.016709; eVar: - 1.151E-9; MConst: 356.0470; MVar: 0.9856002585);
cMoonOrbitalElements: TOrbitalElementsData = (NConst: 125.1228; NVar: - 0.0529538083; iConst: 5.1454; iVar: 0.0; wConst: 318.0634; wVar: 0.1643573223; aConst: 60.2666; aVar: 0.0; eConst: 0.054900; eVar: 0.0; MConst: 115.3654; MVar: 13.0649929509);
cMercuryOrbitalElements: TOrbitalElementsData = (NConst: 48.3313; NVar: 3.24587E-5; iConst: 7.0047; iVar: 5.00E-8; wConst: 29.1241; wVar: 1.01444E-5; aConst: 0.387098; aVar: 0.0; eConst: 0.205635; eVar: 5.59E-10; MConst: 168.6562; MVar: 4.0923344368);
cVenusOrbitalElements: TOrbitalElementsData = (NConst: 76.6799; NVar: 2.46590E-5; iConst: 3.3946; iVar: 2.75E-8; wConst: 54.8910; wVar: 1.38374E-5; aConst: 0.723330; aVar: 0.0; eConst: 0.006773; eVar: - 1.302E-9; MConst: 48.0052; MVar: 1.6021302244);
cMarsOrbitalElements: TOrbitalElementsData = (NConst: 49.5574; NVar: 2.11081E-5; iConst: 1.8497; iVar: - 1.78E-8; wConst: 286.5016; wVar: 2.92961E-5; aConst: 1.523688; aVar: 0.0; eConst: 0.093405; eVar: 2.516E-9; MConst: 18.6021; MVar: 0.5240207766);
cJupiterOrbitalElements: TOrbitalElementsData = (NConst: 100.4542; NVar: 2.76854E-5; iConst: 1.3030; iVar: - 1.557E-7; wConst: 273.8777; wVar: 1.64505E-5; aConst: 5.20256; aVar: 0.0; eConst: 0.048498; eVar: 4.469E-9; MConst: 19.8950; MVar: 0.0830853001);
cSaturnOrbitalElements: TOrbitalElementsData = (NConst: 113.6634; NVar: 2.38980E-5; iConst: 2.4886; iVar: - 1.081E-7; wConst: 339.3939; wVar: 2.97661E-5; aConst: 9.55475; aVar: 0.0; eConst: 0.055546; eVar: - 9.499E-9; MConst: 316.9670; MVar: 0.0334442282);
cUranusOrbitalElements: TOrbitalElementsData = (NConst: 74.0005; NVar: 1.3978E-5; iConst: 0.7733; iVar: 1.9E-8; wConst: 96.6612; wVar: 3.0565E-5; aConst: 19.18171; aVar: - 1.55E-8; eConst: 0.047318; eVar: 7.45E-9; MConst: 142.5905; MVar: 0.011725806);
cNeptuneOrbitalElements: TOrbitalElementsData = (NConst: 131.7806; NVar: 3.0173E-5; iConst: 1.7700; iVar: - 2.55E-7; wConst: 272.8461; wVar: - 6.027E-6; aConst: 30.05826; aVar: 3.313E-8; eConst: 0.008606; eVar: 2.15E-9; MConst: 260.2471; MVar: 0.005995147);
cPlutoOrbitalElements: TOrbitalElementsData = (NConst: 162.7806; NVar: 3.0173E-5; iConst: 1.7700; iVar: - 2.55E-7; wConst: 272.8461; wVar: - 6.027E-6; aConst: 30.05826; aVar: 3.313E-8; eConst: 0.008606; EVar: 2.15E-9; MConst: 260.2471; MVar: 0.005995147);
cAUToKilometers = 149.6E6;
cEarthRadius = 6371;

Description

Functions and Procedures

function GMTDateTimeToJulianDay(const dt: TDateTime): Double;

average earth radius in kilometers Converts a TDateTime (GMT+0) into the Julian day used for computations.

function ComputeOrbitalElements(const oeData: TOrbitalElementsData; const d: Double): TGLOrbitalElements;

Compute orbital elements for given Julian day.

function ComputePlanetPosition(const orbitalElements: TGLOrbitalElements) : TAffineVector; overload;

Compute the planet position for given Julian day (in AU).

function ComputePlanetPosition(const orbitalElementsData: TOrbitalElementsData; const d: Double): TAffineVector; overload;

This item has no description.

function StarRecordPositionZUp(const starRecord: TGLStarRecord): TAffineVector;

Computes position on the unit sphere of a star record (Z=up)

function StarRecordPositionYUp(const starRecord: TGLStarRecord): TAffineVector;

Computes position on the unit sphere of a star record (Y=up)

function LonLatToPos(Lon, Lat: Single): TAffineVector;

Computes position on the unit sphere of a star using Longitude and Latitude

function StarRecordColor(const starRecord: TGLStarRecord; bias: Single): TVector4f;

Computes star color from BV index (RGB) and magnitude (alpha)

Types

PGLStarRecord = ˆTGLStarRecord;

This item has no description.

TGLEarthSkydomeOption = (...);

This item has no description.

Values
  • esoFadeStarsWithSun
  • esoRotateOnTwelveHours
  • esoDepthTest
TGLEarthSkydomeOptions = set of TGLEarthSkydomeOption;

This item has no description.

TGLSkyBoxStyle = (...);

————————- SkyBox class ————————-

Values
  • sbsFull
  • sbsTopHalf
  • sbsBottomHalf
  • sbTopTwoThirds
  • sbsTopHalfClamped
TGLSkyDomeOption = (...);

This item has no description.

Values
  • sdoTwinkle
TGLSkyDomeOptions = set of TGLSkyDomeOption;

This item has no description.

Constants

cSunOrbitalElements: TOrbitalElementsData = (NConst: 0.0; NVar: 0.0; iConst: 0.0; iVar: 0.0; wConst: 282.9404; wVar: 4.70935E-5; aConst: 1.000000; aVar: 0.0; eConst: 0.016709; eVar: - 1.151E-9; MConst: 356.0470; MVar: 0.9856002585);

geocentric sun elements

cMoonOrbitalElements: TOrbitalElementsData = (NConst: 125.1228; NVar: - 0.0529538083; iConst: 5.1454; iVar: 0.0; wConst: 318.0634; wVar: 0.1643573223; aConst: 60.2666; aVar: 0.0; eConst: 0.054900; eVar: 0.0; MConst: 115.3654; MVar: 13.0649929509);

(AU) geocentric moon elements

cMercuryOrbitalElements: TOrbitalElementsData = (NConst: 48.3313; NVar: 3.24587E-5; iConst: 7.0047; iVar: 5.00E-8; wConst: 29.1241; wVar: 1.01444E-5; aConst: 0.387098; aVar: 0.0; eConst: 0.205635; eVar: 5.59E-10; MConst: 168.6562; MVar: 4.0923344368);

(Earth radii) heliocentric mercury elements

cVenusOrbitalElements: TOrbitalElementsData = (NConst: 76.6799; NVar: 2.46590E-5; iConst: 3.3946; iVar: 2.75E-8; wConst: 54.8910; wVar: 1.38374E-5; aConst: 0.723330; aVar: 0.0; eConst: 0.006773; eVar: - 1.302E-9; MConst: 48.0052; MVar: 1.6021302244);

(AU) heliocentric venus elements

cMarsOrbitalElements: TOrbitalElementsData = (NConst: 49.5574; NVar: 2.11081E-5; iConst: 1.8497; iVar: - 1.78E-8; wConst: 286.5016; wVar: 2.92961E-5; aConst: 1.523688; aVar: 0.0; eConst: 0.093405; eVar: 2.516E-9; MConst: 18.6021; MVar: 0.5240207766);

(AU) heliocentric mars elements

cJupiterOrbitalElements: TOrbitalElementsData = (NConst: 100.4542; NVar: 2.76854E-5; iConst: 1.3030; iVar: - 1.557E-7; wConst: 273.8777; wVar: 1.64505E-5; aConst: 5.20256; aVar: 0.0; eConst: 0.048498; eVar: 4.469E-9; MConst: 19.8950; MVar: 0.0830853001);

(AU) heliocentric jupiter elements

cSaturnOrbitalElements: TOrbitalElementsData = (NConst: 113.6634; NVar: 2.38980E-5; iConst: 2.4886; iVar: - 1.081E-7; wConst: 339.3939; wVar: 2.97661E-5; aConst: 9.55475; aVar: 0.0; eConst: 0.055546; eVar: - 9.499E-9; MConst: 316.9670; MVar: 0.0334442282);

(AU) heliocentric saturn elements

cUranusOrbitalElements: TOrbitalElementsData = (NConst: 74.0005; NVar: 1.3978E-5; iConst: 0.7733; iVar: 1.9E-8; wConst: 96.6612; wVar: 3.0565E-5; aConst: 19.18171; aVar: - 1.55E-8; eConst: 0.047318; eVar: 7.45E-9; MConst: 142.5905; MVar: 0.011725806);

(AU) heliocentric uranus elements

cNeptuneOrbitalElements: TOrbitalElementsData = (NConst: 131.7806; NVar: 3.0173E-5; iConst: 1.7700; iVar: - 2.55E-7; wConst: 272.8461; wVar: - 6.027E-6; aConst: 30.05826; aVar: 3.313E-8; eConst: 0.008606; eVar: 2.15E-9; MConst: 260.2471; MVar: 0.005995147);

(AU) heliocentric neptune elements

cPlutoOrbitalElements: TOrbitalElementsData = (NConst: 162.7806; NVar: 3.0173E-5; iConst: 1.7700; iVar: - 2.55E-7; wConst: 272.8461; wVar: - 6.027E-6; aConst: 30.05826; aVar: 3.313E-8; eConst: 0.008606; EVar: 2.15E-9; MConst: 260.2471; MVar: 0.005995147);

(AU) heliocentric pluto elements

cAUToKilometers = 149.6E6;

(AU)

cEarthRadius = 6371;

astronomical units to kilometers


GLSysHelp v.2.5: GLS.SkyDome: Packed Record TGLStarRecord

Packed Record TGLStarRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLStarRecord = packed record

Description

This item has no description.

Overview

Fields

Public | RA: Word;
Public | DEC: SmallInt;
Public | BVColorIndex: Byte;
Public | VMagnitude: Byte;

Description

Fields

Public RA: Word;

This item has no description.

Public DEC: SmallInt;

Right Ascension, x100 builtin factor, degrees

Public BVColorIndex: Byte;

Declination, x100 builtin factor, degrees

Public VMagnitude: Byte;

ColorIndex, x100 builtin factor


GLSysHelp v.2.5: GLS.SkyDome: Class TGLSkyBox

Class TGLSkyBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLSkyBox = class(TGLCameraInvariantObject, IGLMaterialLibrarySupported)

Description

This item has no description. Showing description inherited from TGLCameraInvariantObject.

Base class for camera invariant objects. Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject
  • TGLSkyBox

Overview

Fields

Private | FMatNameTop: string;
Private | FMatNameRight: string;
Private | FMatNameFront: string;
Private | FMatNameLeft: string;
Private | FMatNameBack: string;
Private | FMatNameBottom: string;
Private | FMatNameClouds: string;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FCloudsPlaneOffset: Single;
Private | FCloudsPlaneSize: Single;
Private | FStyle: TGLSkyBoxStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | procedure BuildList(var ARci: TGLRenderContextInfo); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property CloudsPlaneOffset: Single read FCloudsPlaneOffset write SetCloudsPlaneOffset;
Published | property CloudsPlaneSize: Single read FCloudsPlaneSize write SetCloudsPlaneSize;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MatNameBack: TGLLibMaterialName read FMatNameBack write SetMatNameBack;
Published | property MatNameBottom: TGLLibMaterialName read FMatNameBottom write SetMatNameBottom;
Published | property MatNameClouds: TGLLibMaterialName read FMatNameClouds write SetMatNameClouds;
Published | property MatNameFront: TGLLibMaterialName read FMatNameFront write SetMatNameFront;
Published | property MatNameLeft: TGLLibMaterialName read FMatNameLeft write SetMatNameLeft;
Published | property MatNameRight: TGLLibMaterialName read FMatNameRight write SetMatNameRight;
Published | property MatNameTop: TGLLibMaterialName read FMatNameTop write SetMatNameTop;
Published | property Style: TGLSkyBoxStyle read FStyle write FStyle default sbsFull;

Description

Fields

Private FMatNameTop: string;

This item has no description.

Private FMatNameRight: string;

This item has no description.

Private FMatNameFront: string;

This item has no description.

Private FMatNameLeft: string;

This item has no description.

Private FMatNameBack: string;

This item has no description.

Private FMatNameBottom: string;

This item has no description.

Private FMatNameClouds: string;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FCloudsPlaneOffset: Single;

This item has no description.

Private FCloudsPlaneSize: Single;

This item has no description.

Private FStyle: TGLSkyBoxStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

implementing IGLMaterialLibrarySupported

Public procedure BuildList(var ARci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Properties

Published property CloudsPlaneOffset: Single read FCloudsPlaneOffset write SetCloudsPlaneOffset;

This item has no description.

Published property CloudsPlaneSize: Single read FCloudsPlaneSize write SetCloudsPlaneSize;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property MatNameBack: TGLLibMaterialName read FMatNameBack write SetMatNameBack;

This item has no description.

Published property MatNameBottom: TGLLibMaterialName read FMatNameBottom write SetMatNameBottom;

This item has no description.

Published property MatNameClouds: TGLLibMaterialName read FMatNameClouds write SetMatNameClouds;

This item has no description.

Published property MatNameFront: TGLLibMaterialName read FMatNameFront write SetMatNameFront;

This item has no description.

Published property MatNameLeft: TGLLibMaterialName read FMatNameLeft write SetMatNameLeft;

This item has no description.

Published property MatNameRight: TGLLibMaterialName read FMatNameRight write SetMatNameRight;

This item has no description.

Published property MatNameTop: TGLLibMaterialName read FMatNameTop write SetMatNameTop;

This item has no description.

Published property Style: TGLSkyBoxStyle read FStyle write FStyle default sbsFull;


GLSysHelp v.2.5: GLS.SkyDome: Class TGLSkyDomeBand

Class TGLSkyDomeBand

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLSkyDomeBand = class(TCollectionItem)

Description

——————— SkyDome classes —————————–

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLSkyDomeBand

Overview

Fields

Private | FStartAngle: Single;
Private | FStopAngle: Single;
Private | FStartColor: TGLColor;
Private | FStopColor: TGLColor;
Private | FSlices: Integer;
Private | FStacks: Integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo);

Properties

Published | property Slices: Integer read FSlices write SetSlices default 12;
Published | property Stacks: Integer read FStacks write SetStacks default 1;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StartColor: TGLColor read FStartColor write SetStartColor;
Published | property StopAngle: Single read FStopAngle write SetStopAngle;
Published | property StopColor: TGLColor read FStopColor write SetStopColor;

Description

Fields

Private FStartAngle: Single;

This item has no description.

Private FStopAngle: Single;

This item has no description.

Private FStartColor: TGLColor;

This item has no description.

Private FStopColor: TGLColor;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FStacks: Integer;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo);

This item has no description.

Properties

Published property Slices: Integer read FSlices write SetSlices default 12;

This item has no description.

Published property Stacks: Integer read FStacks write SetStacks default 1;

This item has no description.

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property StartColor: TGLColor read FStartColor write SetStartColor;

This item has no description.

Published property StopAngle: Single read FStopAngle write SetStopAngle;

This item has no description.

Published property StopColor: TGLColor read FStopColor write SetStopColor;


GLSysHelp v.2.5: GLS.SkyDome: Class TGLSkyDomeBands

Class TGLSkyDomeBands

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLSkyDomeBands = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLSkyDomeBands

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLSkyDomeBand;
Public | function FindItemID(ID: Integer): TGLSkyDomeBand;
Public | procedure BuildList(var rci: TGLRenderContextInfo);
Public | procedure NotifyChange;

Properties

Public property Items[index: Integer]: TGLSkyDomeBand read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLSkyDomeBand;

This item has no description.

Public function FindItemID(ID: Integer): TGLSkyDomeBand;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Public property Items[index: Integer]: TGLSkyDomeBand read GetItems write SetItems;


GLSysHelp v.2.5: GLS.SkyDome: Class TGLSkyDomeStar

Class TGLSkyDomeStar

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLSkyDomeStar = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLSkyDomeStar

Overview

Fields

Private | FRA: Single;
Private | FDec: Single;
Private | FMagnitude: Single;
Private | FColor: TColor;
Private | FCacheCoord: TAffineVector;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Color: TColor read FColor write FColor;
Published | property DEC: Single read FDec write FDec;
Published | property Magnitude: Single read FMagnitude write FMagnitude;
Published | property RA: Single read FRA write FRA;

Description

Fields

Private FRA: Single;

This item has no description.

Private FDec: Single;

This item has no description.

Private FMagnitude: Single;

This item has no description.

Private FColor: TColor;

This item has no description.

Private FCacheCoord: TAffineVector;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Color: TColor read FColor write FColor;

Color of the star.

Published property DEC: Single read FDec write FDec;

Declination, in degrees.

Published property Magnitude: Single read FMagnitude write FMagnitude;

Absolute magnitude.

Published property RA: Single read FRA write FRA;

Right Ascension, in degrees.


GLSysHelp v.2.5: GLS.SkyDome: Class TGLSkyDomeStars

Class TGLSkyDomeStars

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLSkyDomeStars = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLSkyDomeStars

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLSkyDomeStar;
Public | function FindItemID(ID: Integer): TGLSkyDomeStar;
Public | procedure AddRandomStars(const nb: Integer; const color: TColor; const LimitToTopDome: Boolean = False); overload;
Public | procedure AddRandomStars(const nb: Integer; const ColorMin, ColorMax:TVector3b; const Magnitude_min, Magnitude_max: Single; const LimitToTopDome: Boolean = False); overload;
Public | procedure BuildList(var rci: TGLRenderContextInfo; twinkle: Boolean);
Public | procedure LoadStarsFile(const starsFileName: string);

Properties

Public property Items[index: Integer]: TGLSkyDomeStar read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLSkyDomeStar;

This item has no description.

Public function FindItemID(ID: Integer): TGLSkyDomeStar;

This item has no description.

Public procedure AddRandomStars(const nb: Integer; const color: TColor; const LimitToTopDome: Boolean = False); overload;

Adds nb random stars of the given color. Stars are homogenously scattered on the complete sphere, not only the band defined or visible dome.

Public procedure AddRandomStars(const nb: Integer; const ColorMin, ColorMax:TVector3b; const Magnitude_min, Magnitude_max: Single; const LimitToTopDome: Boolean = False); overload;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo; twinkle: Boolean);

This item has no description.

Public procedure LoadStarsFile(const starsFileName: string);

Load a 'stars' file, which is made of TGLStarRecord. Not that '.stars' files should already be sorted by magnitude and color.

Properties

Public property Items[index: Integer]: TGLSkyDomeStar read GetItems write SetItems;


GLSysHelp v.2.5: GLS.SkyDome: Class TGLSkyDome

Class TGLSkyDome

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLSkyDome = class(TGLCameraInvariantObject)

Description

Renders a sky dome always centered on the camera. If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system. The skydome is described by "bands", each "band" is a horizontal cut of a sphere, and you can have as many bands as you wish

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject
  • TGLSkyDome

Overview

Fields

Private | FOptions: TGLSkyDomeOptions;
Private | FBands: TGLSkyDomeBands;
Private | FStars: TGLSkyDomeStars;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property Bands: TGLSkyDomeBands read FBands write SetBands;
Published | property Options: TGLSkyDomeOptions read FOptions write SetOptions default [];
Published | property Stars: TGLSkyDomeStars read FStars write SetStars;

Description

Fields

Private FOptions: TGLSkyDomeOptions;

This item has no description.

Private FBands: TGLSkyDomeBands;

This item has no description.

Private FStars: TGLSkyDomeStars;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Bands: TGLSkyDomeBands read FBands write SetBands;

This item has no description.

Published property Options: TGLSkyDomeOptions read FOptions write SetOptions default [];

This item has no description.

Published property Stars: TGLSkyDomeStars read FStars write SetStars;


GLSysHelp v.2.5: GLS.SkyDome: Class TGLEarthSkyDome

Class TGLEarthSkyDome

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLEarthSkyDome = class(TGLSkyDome)

Description

Render a skydome like what can be seen on earth. Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render exoplanet atmospheres too. The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TGLEarthSkyDome.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject
  • TGLSkyDome
  • TGLEarthSkyDome

Overview

Fields

Private | FSunElevation: Single;
Private | FTurbidity: Single;
Private | FCurSunColor: TGLColorVector;
Private | FCurSkyColor: TGLColorVector;
Private | FCurHazeColor: TGLColorVector;
Private | FCurHazeTurbid: Single;
Private | FCurSunSkyTurbid: Single;
Private | FSunZenithColor: TGLColor;
Private | FSunDawnColor: TGLColor;
Private | FHazeColor: TGLColor;
Private | FSkyColor: TGLColor;
Private | FNightColor: TGLColor;
Private | FDeepColor: TGLColor;
Private | FSlices: Integer;
Private | FStacks: Integer;
Private | FExtendedOptions: TGLEarthSkydomeOptions;
Private | FMorning: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure SetSunAtTime(HH, MM: Single);

Properties

Published | property DeepColor: TGLColor read FDeepColor write SetDeepColor;
Published | property ExtendedOptions: TGLEarthSkydomeOptions read FExtendedOptions write FExtendedOptions;
Published | property HazeColor: TGLColor read FHazeColor write SetHazeColor;
Published | property NightColor: TGLColor read FNightColor write SetNightColor;
Published | property SkyColor: TGLColor read FSkyColor write SetSkyColor;
Published | property Slices: Integer read FSlices write SetSlices default 24;
Published | property Stacks: Integer read FStacks write SetStacks default 48;
Published | property SunDawnColor: TGLColor read FSunDawnColor write SetSunDawnColor;
Published | property SunElevation: Single read FSunElevation write SetSunElevation;
Published | property SunZenithColor: TGLColor read FSunZenithColor write SetSunZenithColor;
Published | property Turbidity: Single read FTurbidity write SetTurbidity;

Description

Fields

Private FSunElevation: Single;

This item has no description.

Private FTurbidity: Single;

This item has no description.

Private FCurSunColor: TGLColorVector;

This item has no description.

Private FCurSkyColor: TGLColorVector;

This item has no description.

Private FCurHazeColor: TGLColorVector;

This item has no description.

Private FCurHazeTurbid: Single;

This item has no description.

Private FCurSunSkyTurbid: Single;

This item has no description.

Private FSunZenithColor: TGLColor;

This item has no description.

Private FSunDawnColor: TGLColor;

This item has no description.

Private FHazeColor: TGLColor;

This item has no description.

Private FSkyColor: TGLColor;

This item has no description.

Private FNightColor: TGLColor;

This item has no description.

Private FDeepColor: TGLColor;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FStacks: Integer;

This item has no description.

Private FExtendedOptions: TGLEarthSkydomeOptions;

This item has no description.

Private FMorning: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure SetSunAtTime(HH, MM: Single);

This item has no description.

Properties

Published property DeepColor: TGLColor read FDeepColor write SetDeepColor;

This item has no description.

Published property ExtendedOptions: TGLEarthSkydomeOptions read FExtendedOptions write FExtendedOptions;

This item has no description.

Published property HazeColor: TGLColor read FHazeColor write SetHazeColor;

This item has no description.

Published property NightColor: TGLColor read FNightColor write SetNightColor;

This item has no description.

Published property SkyColor: TGLColor read FSkyColor write SetSkyColor;

This item has no description.

Published property Slices: Integer read FSlices write SetSlices default 24;

This item has no description.

Published property Stacks: Integer read FStacks write SetStacks default 48;

This item has no description.

Published property SunDawnColor: TGLColor read FSunDawnColor write SetSunDawnColor;

This item has no description.

Published property SunElevation: Single read FSunElevation write SetSunElevation;

Elevation of the sun, measured in degrees

Published property SunZenithColor: TGLColor read FSunZenithColor write SetSunZenithColor;

This item has no description.

Published property Turbidity: Single read FTurbidity write SetTurbidity;

Expresses the purity of air. Value range is from 1 (pure atmosphere) to 120 (very nebulous)


GLSysHelp v.2.5: GLS.SkyDome: Record TGLStarSysData

Record TGLStarSysData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLStarSysData = record

Description

This item has no description.

Overview

Fields

Public | NbStar: byte;
Public | NbPlanet: byte;
Public | NbAsteroid: byte;
Public | NbComet: byte;
Public | NbDebris: byte;

Description

Fields

Public NbStar: byte;

This item has no description.

Public NbPlanet: byte;

Only 1 allowed so far

Public NbAsteroid: byte;

This item has no description.

Public NbComet: byte;

This item has no description.

Public NbDebris: byte;


GLSysHelp v.2.5: GLS.SkyDome: Record TGLStarData

Record TGLStarData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLStarData = record

Description

This item has no description.

Overview

Fields

Public | StarName: String[255];
Public | Radius: Double;
Public | ObjectRotation: Double;
Public | AxisTilt: Double;
Public | nbS3ds: byte;
Public | DocIndex: byte;
Public | StarSysScale: Double;
Public | StarDistanceScale: Double;

Description

Fields

Public StarName: String[255];

ONLY .jpg; Expected: .bmp .tif .tga .png ignored

Public Radius: Double;

This item has no description.

Public ObjectRotation: Double;

This item has no description.

Public AxisTilt: Double;

This item has no description.

Public nbS3ds: byte;

This item has no description.

Public DocIndex: byte;

This item has no description.

Public StarSysScale: Double;

This item has no description.

Public StarDistanceScale: Double;


GLSysHelp v.2.5: GLS.SkyDome: Record TGLPlanetData

Record TGLPlanetData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLPlanetData = record

Description

This item has no description.

Overview

Fields

Public | Name: String[255];
Public | Radius: Double;
Public | ObjectRotation: Double;
Public | AxisTilt: Double;
Public | nbRings: byte;
Public | nbMoons: byte;
Public | nbS3ds: byte;
Public | DocIndex: byte;
Public | Albedo: Double;
Public | OrbitRotation: Double;
Public | aDistance: Double;
Public | aDistanceVar: Double;
Public | Inclination: Double;
Public | InclinationVar: Double;
Public | Eccentricity: Double;
Public | EVar: Double;
Public | EMax: Double;
Public | nLongitude: Double;
Public | nLongitudeVar: Double;
Public | wPerihelion: Double;
Public | wPerihelionVar: Double;
Public | mAnomaly: Double;
Public | mAnomalyVar: Double;
Public | Mass: Double;
Public | Density: Double;
Public | Atmosphere: byte;
Public | VelocityType: byte;
Public | Velocity: Double;
Public | VelocityDir: Double;

Description

Fields

Public Name: String[255];

Planet.jpg .. Planet_bump.jpg

Public Radius: Double;

This item has no description.

Public ObjectRotation: Double;

This item has no description.

Public AxisTilt: Double;

This item has no description.

Public nbRings: byte;

This item has no description.

Public nbMoons: byte;

This item has no description.

Public nbS3ds: byte;

This item has no description.

Public DocIndex: byte;

This item has no description.

Public Albedo: Double;

This item has no description.

Public OrbitRotation: Double;

This item has no description.

Public aDistance: Double;

This item has no description.

Public aDistanceVar: Double;

This item has no description.

Public Inclination: Double;

aConstEdit aVarEdit

Public InclinationVar: Double;

aConstEdit aVarEdit

Public Eccentricity: Double;

iConstEdit iVarEdit

Public EVar: Double;

iConstEdit iVarEdit

Public EMax: Double;

iConstEdit iVarEdit

Public nLongitude: Double;

eConstEdit eVarEdit EMaxEdit

Public nLongitudeVar: Double;

eConstEdit eVarEdit EMaxEdit

Public wPerihelion: Double;

NConstEdit NVarEdit

Public wPerihelionVar: Double;

NConstEdit NVarEdit

Public mAnomaly: Double;

wConstEdit wVarEdit

Public mAnomalyVar: Double;

wConstEdit wVarEdit

Public Mass: Double;

MConstEdit MVarEdit

Public Density: Double;

MConstEdit MVarEdit

Public Atmosphere: byte;

This item has no description.

Public VelocityType: byte;

This item has no description.

Public Velocity: Double;

Which way does the wind blow Given a direction 0 to 100 or 1 to 100 is that 100 or 101

Public VelocityDir: Double;

Which way does the wind blow Given a direction 0 to 100 or 1 to 100 is that 100 or 101


GLSysHelp v.2.5: GLS.SkyDome: Record TGLMoonRingData

Record TGLMoonRingData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLMoonRingData = record

Description

3ds files and DebrisAsteroid too

Overview

Fields

Public | Name: String[255];
Public | Radius: Double;
Public | ObjectRotation: Double;
Public | AxisTilt: Double;
Public | S3dsTex: Boolean;
Public | DocIndex: byte;
Public | Mass: Double;
Public | Density: Double;
Public | RCDType: Integer;
Public | RCDCount: Integer;
Public | RCDXYSize: Double;
Public | RCDZSize: Double;
Public | RCDPosition: Double;
Public | Albedo: Double;
Public | OrbitRotation: Double;
Public | aDistance: Double;
Public | aDistanceVar: Double;
Public | Inclination: Double;
Public | InclinationVar: Double;
Public | Eccentricity: Double;
Public | EVar: Double;
Public | EMax: Double;
Public | nLongitude: Double;
Public | nLongitudeVar: Double;
Public | wPerihelion: Double;
Public | wPerihelionVar: Double;
Public | mAnomaly: Double;
Public | mAnomalyVar: Double;
Public | Atmosphere: byte;
Public | VelocityType: byte;
Public | Velocity: Double;
Public | VelocityDir: Double;

Description

Fields

Public Name: String[255];

This item has no description.

Public Radius: Double;

This item has no description.

Public ObjectRotation: Double;

This item has no description.

Public AxisTilt: Double;

This item has no description.

Public S3dsTex: Boolean;

This item has no description.

Public DocIndex: byte;

This item has no description.

Public Mass: Double;

This item has no description.

Public Density: Double;

This item has no description.

Public RCDType: Integer;

This item has no description.

Public RCDCount: Integer;

This item has no description.

Public RCDXYSize: Double;

This item has no description.

Public RCDZSize: Double;

This item has no description.

Public RCDPosition: Double;

This item has no description.

Public Albedo: Double;

This item has no description.

Public OrbitRotation: Double;

This item has no description.

Public aDistance: Double;

This item has no description.

Public aDistanceVar: Double;

This item has no description.

Public Inclination: Double;

This item has no description.

Public InclinationVar: Double;

This item has no description.

Public Eccentricity: Double;

This item has no description.

Public EVar: Double;

This item has no description.

Public EMax: Double;

This item has no description.

Public nLongitude: Double;

This item has no description.

Public nLongitudeVar: Double;

This item has no description.

Public wPerihelion: Double;

This item has no description.

Public wPerihelionVar: Double;

This item has no description.

Public mAnomaly: Double;

This item has no description.

Public mAnomalyVar: Double;

This item has no description.

Public Atmosphere: byte;

This item has no description.

Public VelocityType: byte;

This item has no description.

Public Velocity: Double;

This item has no description.

Public VelocityDir: Double;


GLSysHelp v.2.5: GLS.SkyDome: Record TGLAsteroidData

Record TGLAsteroidData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLAsteroidData = record

Description

Asteroid Comet spheres..NOT DebrisAsteroid

Overview

Fields

Public | Name: String[255];
Public | Radius: Double;
Public | ObjectRotation: Double;
Public | AxisTilt: Double;
Public | nbS3ds: byte;
Public | DocIndex: byte;
Public | RCDType: Integer;
Public | RCDCount: Integer;
Public | RCDXYSize: Double;
Public | RCDZSize: Double;
Public | RCDPosition: Double;
Public | Albedo: Double;
Public | OrbitRotation: Double;
Public | aDistance: Double;
Public | aDistanceVar: Double;
Public | Inclination: Double;
Public | InclinationVar: Double;
Public | Eccentricity: Double;
Public | EVar: Double;
Public | EMax: Double;
Public | nLongitude: Double;
Public | nLongitudeVar: Double;
Public | wPerihelion: Double;
Public | wPerihelionVar: Double;
Public | mAnomaly: Double;
Public | mAnomalyVar: Double;
Public | Mass: Double;
Public | Density: Double;
Public | Atmosphere: byte;
Public | VelocityType: byte;
Public | Velocity: Double;
Public | VelocityDir: Double;

Description

Fields

Public Name: String[255];

This item has no description.

Public Radius: Double;

This item has no description.

Public ObjectRotation: Double;

This item has no description.

Public AxisTilt: Double;

This item has no description.

Public nbS3ds: byte;

This item has no description.

Public DocIndex: byte;

This item has no description.

Public RCDType: Integer;

This item has no description.

Public RCDCount: Integer;

This item has no description.

Public RCDXYSize: Double;

This item has no description.

Public RCDZSize: Double;

This item has no description.

Public RCDPosition: Double;

This item has no description.

Public Albedo: Double;

This item has no description.

Public OrbitRotation: Double;

This item has no description.

Public aDistance: Double;

This item has no description.

Public aDistanceVar: Double;

This item has no description.

Public Inclination: Double;

This item has no description.

Public InclinationVar: Double;

This item has no description.

Public Eccentricity: Double;

This item has no description.

Public EVar: Double;

This item has no description.

Public EMax: Double;

This item has no description.

Public nLongitude: Double;

This item has no description.

Public nLongitudeVar: Double;

This item has no description.

Public wPerihelion: Double;

This item has no description.

Public wPerihelionVar: Double;

This item has no description.

Public mAnomaly: Double;

This item has no description.

Public mAnomalyVar: Double;

This item has no description.

Public Mass: Double;

This item has no description.

Public Density: Double;

This item has no description.

Public Atmosphere: byte;

This item has no description.

Public VelocityType: byte;

This item has no description.

Public Velocity: Double;

This item has no description.

Public VelocityDir: Double;


GLSysHelp v.2.5: GLS.SkyDome: Record TGLOrbitalElements

Record TGLOrbitalElements

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TGLOrbitalElements = record

Description

For recomputation of TOrbitalElementsData

Overview

Fields

Public | N: Double;
Public | i: Double;
Public | w: Double;
Public | a: Double;
Public | e: Double;
Public | M: Double;

Description

Fields

Public N: Double;

This item has no description.

Public i: Double;

longitude of the ascending node

Public w: Double;

inclination to the ecliptic (plane of the Earth's orbit)

Public a: Double;

argument of perihelion

Public e: Double;

semi-major axis, or mean distance from Sun

Public M: Double;

eccentricity (0=circle, 0-1=ellipse, 1=parabola)


GLSysHelp v.2.5: GLS.SkyDome: Record TOrbitalElementsData

Record TOrbitalElementsData

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SkyDome

Declaration

type TOrbitalElementsData = record

Description

This item has no description.

Overview

Fields

Public | NConst: Double;
Public | NVar: Double;
Public | iConst: Double;
Public | iVar: Double;
Public | wConst: Double;
Public | wVar: Double;
Public | aConst: Double;
Public | aVar: Double;
Public | eConst: Double;
Public | eVar: Double;
Public | MConst: Double;
Public | MVar: Double;

Description

Fields

Public NConst: Double;

This item has no description.

Public NVar: Double;

This item has no description.

Public iConst: Double;

longitude of the ascending node

Public iVar: Double;

longitude of the ascending node

Public wConst: Double;

inclination to the ecliptic (plane of the Earth's orbit)

Public wVar: Double;

inclination to the ecliptic (plane of the Earth's orbit)

Public aConst: Double;

argument of perihelion

Public aVar: Double;

argument of perihelion

Public eConst: Double;

semi-major axis, or mean distance from Sun

Public eVar: Double;

semi-major axis, or mean distance from Sun

Public MConst: Double;

eccentricity (0=circle, 0-1=ellipse, 1=parabola)

Public MVar: Double;

eccentricity (0=circle, 0-1=ellipse, 1=parabola)


GLSysHelp v.2.5: GLS.SmartObjects

Unit GLS.SmartObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.Math
  • VCL.Consts
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.VectorTypesExt
  • GLScene.Strings
  • GLScene.PipelineTransform
  • GLS.Scene
  • GLS.VectorLists
  • GLS.PersistentClasses
  • GLS.Silhouette
  • GLS.Texture
  • GLS.Material
  • GLS.Mesh
  • GLS.Octree
  • GLScene.GeometryBB
  • GLS.Objects
  • GLS.GeomObjects
  • GLS.ApplicationFileIO
  • GLS.Context
  • GLS.Color
  • GLS.Selection
  • GLS.RenderContextInfo
  • GLS.Coordinates
  • GLS.BaseClasses
  • GLS.VectorFileObjects
  • GLS.SoundManager
  • GLS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCyborgThinks |
Class TGLCyborgThinksList |
Class TGLCyborg |
Class TGLSwartSwarm |

Types

TGLCyborgOption = (...);
TGLCyborgOptions = set of TGLCyborgOption;
TGLCyborgReference = (...);
TGLCyborgSenceOrgans = (...);
TGLCyborgThinkMode = (...);
TGLSmartSwarmMode = (...);

Constants

cDefaultCyborgOptions = [coCollide];

Variables

vGLSmartObjectsAllocate: Boolean = True;
vGLSmartObjectsEnableByDefault: Boolean = True;

Description

Types

TGLCyborgOption = (...);

This item has no description.

Values
  • coCollide
  • coContact
  • coJoin
TGLCyborgOptions = set of TGLCyborgOption;

This item has no description.

TGLCyborgReference = (...);

This item has no description.

Values
  • crNone
  • crWeak
  • crStrong
TGLCyborgSenceOrgans = (...);

This item has no description.

Values
  • csoVision
  • csoHearing
  • csoSmell
  • csoTouch
  • taste
TGLCyborgThinkMode = (...);

This item has no description.

Values
  • ctmSelf
  • ctmSleep
  • ctmOutside
  • ctmZombie
  • ctmDeath
TGLSmartSwarmMode = (...);

This item has no description.

Values
  • isNone
  • isRandom
  • isTetra
  • isGrid

Constants

cDefaultCyborgOptions = [coCollide];

This item has no description.

Variables

vGLSmartObjectsAllocate: Boolean = True;

This item has no description.

vGLSmartObjectsEnableByDefault: Boolean = True;


GLSysHelp v.2.5: GLS.SmartObjects: Class TGLCyborgThinks

Class TGLCyborgThinks

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmartObjects

Declaration

type TGLCyborgThinks = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLCyborgThinks


GLSysHelp v.2.5: GLS.SmartObjects: Class TGLCyborgThinksList

Class TGLCyborgThinksList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmartObjects

Declaration

type TGLCyborgThinksList = class(TGLPersistentObjectList)

Description

A list of thinking periods for TGLCyborgThinkMode

Hierarchy

  • TGLPersistentObjectList
  • TGLCyborgThinksList


GLSysHelp v.2.5: GLS.SmartObjects: Class TGLCyborg

Class TGLCyborg

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmartObjects

Declaration

type TGLCyborg = class(TGLActor)

Description

The Cyborg class specialized as a smart actor with AI. The TGLCyborg provides a quick interface to animated actors based on morph or skeleton frames, it is capable of performing frame interpolation and thinking blending (via TGLThinkingController components).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLActor
  • TGLCyborg

Overview

Fields

Private | FBirthTime: TDateTime;
Private | FDeathTime: TDateTime;
Private | FReference: TGLCyborgReference;
Private | FThinkMode: TGLCyborgThinkMode;
Private | FControlers: TList;
Private | FInterval: Integer;
Private | FOptions: TGLCyborgOptions;
Private | FThinkings: TGLCyborgThinks;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CurrentThinking: string;
Public | function IsThinking: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure LoadFromStream(const Filename: string; aStream: TStream); override;
Public | procedure SwitchToThinking(anThinking: TGLCyborgThinks; smooth: Boolean = False);

Properties

Published | property Interval: Integer read FInterval write FInterval;
Published | property Options: TGLCyborgOptions read FOptions write SetOptions default cDefaultCyborgOptions;
Published | property SmartReference: TGLCyborgReference read FReference write FReference default crNone;
Published | property ThinkingMode: TGLCyborgThinkMode read FThinkMode write FThinkMode default ctmSelf;

Description

Fields

Private FBirthTime: TDateTime;

This item has no description.

Private FDeathTime: TDateTime;

This item has no description.

Private FReference: TGLCyborgReference;

This item has no description.

Private FThinkMode: TGLCyborgThinkMode;

This item has no description.

Private FControlers: TList;

This item has no description.

Private FInterval: Integer;

This item has no description.

Private FOptions: TGLCyborgOptions;

This item has no description.

Private FThinkings: TGLCyborgThinks;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CurrentThinking: string;

This item has no description.

Public function IsThinking: Boolean;

Indicates whether the cyborg is currently thinking

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure LoadFromStream(const Filename: string; aStream: TStream); override;

This item has no description. Showing description inherited from TGLBaseMesh.LoadFromStream.

Loads a vector file from a stream. See LoadFromFile. The filename attribute is required to identify the type data you're streaming (3DS, OBJ, etc.)

Public procedure SwitchToThinking(anThinking: TGLCyborgThinks; smooth: Boolean = False);

This item has no description.

Properties

Published property Interval: Integer read FInterval write FInterval;

Interval between thinking frames, in milliseconds.

Published property Options: TGLCyborgOptions read FOptions write SetOptions default cDefaultCyborgOptions;

Cyborg and thinking miscellanious options.

Published property SmartReference: TGLCyborgReference read FReference write FReference default crNone;

Reference Frame Animation mode. Allows specifying if the model is primarily morph or skeleton based

Published property ThinkingMode: TGLCyborgThinkMode read FThinkMode write FThinkMode default ctmSelf;

See TGLCyborgThinkMode.


GLSysHelp v.2.5: GLS.SmartObjects: Class TGLSwartSwarm

Class TGLSwartSwarm

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmartObjects

Declaration

type TGLSwartSwarm = class(TGLPoints)

Description

Synchronize self thinking with an other thinkers in the swarm Copies Ai/Current/End values,ThinkingMode and GridInterpolation. procedure Synchronize(IntelSwarm: TGLIntelSwarm);

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLPoints
  • TGLSwartSwarm

Overview

Fields

Private | FBirthTime: TDateTime;
Private | FDeathTime: TDateTime;
Private | FReference: TGLCyborgReference;
Private | FThinkMode: TGLSmartSwarmMode;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property ThinkingMode: TGLSmartSwarmMode read FThinkMode;

Description

Fields

Private FBirthTime: TDateTime;

This item has no description.

Private FDeathTime: TDateTime;

This item has no description.

Private FReference: TGLCyborgReference;

This item has no description.

Private FThinkMode: TGLSmartSwarmMode;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property ThinkingMode: TGLSmartSwarmMode read FThinkMode;


GLSysHelp v.2.5: GLS.SmoothNavigator

Unit GLS.SmoothNavigator

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Types
  • System.Classes
  • GLS.Scene
  • GLS.PersistentClasses
  • GLScene.VectorTypes
  • GLS.Navigator
  • GLScene.VectorGeometry
  • GLS.Coordinates
  • GLS.Screen
  • GLScene.XCollection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNavigatorAbstractParameters |
Class TGLNavigatorSmoothChangeItem |
Class TGLNavigatorSmoothChangeSingle |
Class TGLNavigatorSmoothChangeVector |
Class TGLNavigatorSmoothChangeItems |
Class TGLNavigatorAdjustDistanceParameters |
Class TGLNavigatorAdjustDistanceParametersEx |
Class TGLNavigatorInertiaParameters |
Class TGLNavigatorGeneralParameters |
Class TGLNavigatorMoveAroundParameters |
Class TGLSmoothNavigator |
Class TGLSmoothUserInterface |

Types

TGLNavigatorSmoothChangeItemClass = class of TGLNavigatorSmoothChangeItem;
TGLNavigatorSmoothChangeSingleGetEvent = function(const ASender: TGLNavigatorSmoothChangeSingle): Single of object;
TGLNavigatorSmoothChangeSingleSetEvent = procedure(const ASender: TGLNavigatorSmoothChangeSingle; const AValue: Single) of object;
TGLNavigatorSmoothChangeVectorGetEvent = function(const ASender: TGLNavigatorSmoothChangeVector): TGLVector of object;
TGLNavigatorSmoothChangeVectorSetEvent = procedure(const ASender: TGLNavigatorSmoothChangeVector; const AValue: TGLVector) of object;

Description

Types

TGLNavigatorSmoothChangeItemClass = class of TGLNavigatorSmoothChangeItem;

This item has no description.

TGLNavigatorSmoothChangeSingleGetEvent = function(const ASender: TGLNavigatorSmoothChangeSingle): Single of object;

This item has no description.

TGLNavigatorSmoothChangeSingleSetEvent = procedure(const ASender: TGLNavigatorSmoothChangeSingle; const AValue: Single) of object;

This item has no description.

TGLNavigatorSmoothChangeVectorGetEvent = function(const ASender: TGLNavigatorSmoothChangeVector): TGLVector of object;

This item has no description.

TGLNavigatorSmoothChangeVectorSetEvent = procedure(const ASender: TGLNavigatorSmoothChangeVector; const AValue: TGLVector) of object;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorAbstractParameters

Class TGLNavigatorAbstractParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorAbstractParameters = class(TPersistent)

Description

Includes a basic set of parameters that control the smoothness of movement.

Hierarchy

  • TObject
  • TPersistent
  • TGLNavigatorAbstractParameters

Overview

Fields

Private | FOwner: TPersistent;
Private | FInertia: Single;
Private | FSpeed: Single;
Private | FCutoff: Single;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Private | function StoreCutoff: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property Cutoff: Single read FCutoff write FCutoff stored StoreCutoff;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FInertia: Single;

This item has no description.

Private FSpeed: Single;

This item has no description.

Private FCutoff: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Private function StoreCutoff: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

This item has no description.

Properties

Published property Cutoff: Single read FCutoff write FCutoff stored StoreCutoff;

This item has no description.

Published property Inertia: Single read FInertia write FInertia stored StoreInertia;

This item has no description.

Published property Speed: Single read FSpeed write FSpeed stored StoreSpeed;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorSmoothChangeItem

Class TGLNavigatorSmoothChangeItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorSmoothChangeItem = class(TXCollectionItem)

Description

Includes a basic set of parameters that control the smoothness of movement.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLNavigatorSmoothChangeItem

Overview

Fields

Private | FInertia: Single;
Private | FSpeed: Single;
Private | FEnabled: Boolean;
Private | FSpeedLimit: Single;
Private | FCutoff: Double;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | function Proceed(ADeltaTime: Double): Boolean; virtual; abstract;
Private | function StoreCutoff: Boolean;
Private | function StoreInertia: Boolean;
Private | function StoreSpeed: Boolean;
Private | function StoreSpeedLimit: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); virtual; abstract;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Published | property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;

Description

Fields

Private FInertia: Single;

This item has no description.

Private FSpeed: Single;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FSpeedLimit: Single;

This item has no description.

Private FCutoff: Double;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public function Proceed(ADeltaTime: Double): Boolean; virtual; abstract;

Returns False if there was no change.

Private function StoreCutoff: Boolean;

This item has no description.

Private function StoreInertia: Boolean;

This item has no description.

Private function StoreSpeed: Boolean;

This item has no description.

Private function StoreSpeedLimit: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ResetTargetValue(); virtual; abstract;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

This item has no description.

Properties

Published property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;

This item has no description.

Published property Enabled: Boolean read FEnabled write FEnabled default True;

This item has no description.

Published property Inertia: Single read FInertia write FInertia stored StoreInertia;

This item has no description.

Published property Speed: Single read FSpeed write FSpeed stored StoreSpeed;

This item has no description.

Published property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorSmoothChangeSingle

Class TGLNavigatorSmoothChangeSingle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorSmoothChangeSingle = class(TGLNavigatorSmoothChangeItem)

Description

Smoothly change any Single value, so it will become TargetValue in the end.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLNavigatorSmoothChangeItem
  • TGLNavigatorSmoothChangeSingle

Overview

Fields

Private | FTargetValue: Single;
Private | FOnGetCurrentValue: TGLNavigatorSmoothChangeSingleGetEvent;
Private | FOnSetCurrentValue: TGLNavigatorSmoothChangeSingleSetEvent;

Methods

Public | class function FriendlyName: string; override;
Public | function Proceed(ADeltaTime: Double): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); override;

Properties

Published | property OnGetCurrentValue: TGLNavigatorSmoothChangeSingleGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;
Published | property OnSetCurrentValue: TGLNavigatorSmoothChangeSingleSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;
Published | property TargetValue: Single read FTargetValue write FTargetValue;

Description

Fields

Private FTargetValue: Single;

This item has no description.

Private FOnGetCurrentValue: TGLNavigatorSmoothChangeSingleGetEvent;

This item has no description.

Private FOnSetCurrentValue: TGLNavigatorSmoothChangeSingleSetEvent;

This item has no description.

Methods

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function Proceed(ADeltaTime: Double): Boolean; override;

This item has no description. Showing description inherited from TGLNavigatorSmoothChangeItem.Proceed.

Returns False if there was no change.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ResetTargetValue(); override;

This item has no description.

Properties

Published property OnGetCurrentValue: TGLNavigatorSmoothChangeSingleGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;

This item has no description.

Published property OnSetCurrentValue: TGLNavigatorSmoothChangeSingleSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;

This item has no description.

Published property TargetValue: Single read FTargetValue write FTargetValue;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorSmoothChangeVector

Class TGLNavigatorSmoothChangeVector

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorSmoothChangeVector = class(TGLNavigatorSmoothChangeItem)

Description

Smoothly change any Vector4f value, so it will become TargetValue in the end.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLNavigatorSmoothChangeItem
  • TGLNavigatorSmoothChangeVector

Overview

Fields

Private | FTargetValue: TGLCoordinates;
Private | FOnGetCurrentValue: TGLNavigatorSmoothChangeVectorGetEvent;
Private | FOnSetCurrentValue: TGLNavigatorSmoothChangeVectorSetEvent;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | function Proceed(ADeltaTime: Double): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); override;
Private | procedure SetTargetValue(const Value: TGLCoordinates);

Properties

Published | property OnGetCurrentValue: TGLNavigatorSmoothChangeVectorGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;
Published | property OnSetCurrentValue: TGLNavigatorSmoothChangeVectorSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;
Published | property TargetValue: TGLCoordinates read FTargetValue write SetTargetValue;

Description

Fields

Private FTargetValue: TGLCoordinates;

This item has no description.

Private FOnGetCurrentValue: TGLNavigatorSmoothChangeVectorGetEvent;

This item has no description.

Private FOnSetCurrentValue: TGLNavigatorSmoothChangeVectorSetEvent;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function Proceed(ADeltaTime: Double): Boolean; override;

This item has no description. Showing description inherited from TGLNavigatorSmoothChangeItem.Proceed.

Returns False if there was no change.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ResetTargetValue(); override;

This item has no description.

Private procedure SetTargetValue(const Value: TGLCoordinates);

This item has no description.

Properties

Published property OnGetCurrentValue: TGLNavigatorSmoothChangeVectorGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;

This item has no description.

Published property OnSetCurrentValue: TGLNavigatorSmoothChangeVectorSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;

This item has no description.

Published property TargetValue: TGLCoordinates read FTargetValue write SetTargetValue;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorSmoothChangeItems

Class TGLNavigatorSmoothChangeItems

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorSmoothChangeItems = class(TXCollection)

Description

XCollection of TGLNavigatorSmoothChangeItem.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TGLNavigatorSmoothChangeItems

Overview

Methods

Public | function Add(AClass : TGLNavigatorSmoothChangeItemClass): TGLNavigatorSmoothChangeItem;
Public | function CanAdd(AClass: TXCollectionItemClass): Boolean; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Private | function GetItems(const Index : Integer): TGLNavigatorSmoothChangeItem;
Private | procedure SetItems(const Index : Integer; const Value: TGLNavigatorSmoothChangeItem);

Properties

Public property Items[const Index: Integer]: TGLNavigatorSmoothChangeItem read GetItems write SetItems;

Description

Methods

Public function Add(AClass : TGLNavigatorSmoothChangeItemClass): TGLNavigatorSmoothChangeItem;

This item has no description.

Public function CanAdd(AClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Private function GetItems(const Index : Integer): TGLNavigatorSmoothChangeItem;

This item has no description.

Private procedure SetItems(const Index : Integer; const Value: TGLNavigatorSmoothChangeItem);

This item has no description.

Properties

Public property Items[const Index: Integer]: TGLNavigatorSmoothChangeItem read GetItems write SetItems;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorAdjustDistanceParameters

Class TGLNavigatorAdjustDistanceParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorAdjustDistanceParameters = class(TGLNavigatorAbstractParameters)

Description

The wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work

Hierarchy

  • TObject
  • TPersistent
  • TGLNavigatorAbstractParameters
  • TGLNavigatorAdjustDistanceParameters

Overview

Fields

Private | FOldDistanceRatio: Single;
Private | FImpulseSpeed: Single;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function StoreImpulseSpeed: Boolean;
Public | procedure AddImpulse(const Impulse: Single); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); override;

Properties

Published property ImpulseSpeed: Single read FImpulseSpeed write FImpulseSpeed stored StoreImpulseSpeed;

Description

Fields

Private FOldDistanceRatio: Single;

This item has no description.

Private FImpulseSpeed: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function StoreImpulseSpeed: Boolean;

This item has no description.

Public procedure AddImpulse(const Impulse: Single); virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ScaleParameters(const Value: Single); override;

This item has no description.

Properties

Published property ImpulseSpeed: Single read FImpulseSpeed write FImpulseSpeed stored StoreImpulseSpeed;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorAdjustDistanceParametersEx

Class TGLNavigatorAdjustDistanceParametersEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorAdjustDistanceParametersEx = class(TGLNavigatorAbstractParameters)

Description

The wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.

Hierarchy

  • TObject
  • TPersistent
  • TGLNavigatorAbstractParameters
  • TGLNavigatorAdjustDistanceParametersEx

Overview

Fields

Private | FSpeedLimit: Single;
Private | FTargetDistance: Single;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function StoreSpeedLimit: Boolean;
Private | function StoreTargetDistance: Boolean;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;
Published | property TargetDistance: Single read FTargetDistance write FTargetDistance stored StoreTargetDistance;

Description

Fields

Private FSpeedLimit: Single;

This item has no description.

Private FTargetDistance: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function StoreSpeedLimit: Boolean;

This item has no description.

Private function StoreTargetDistance: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;

This item has no description.

Published property TargetDistance: Single read FTargetDistance write FTargetDistance stored StoreTargetDistance;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorInertiaParameters

Class TGLNavigatorInertiaParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorInertiaParameters = class(TPersistent)

Description

The wrapper for all parameters that affect the smoothness of movement

Hierarchy

  • TObject
  • TPersistent
  • TGLNavigatorInertiaParameters

Overview

Fields

Private | FOwner: TPersistent;
Private | OldTurnHorizontalAngle: Single;
Private | OldTurnVerticalAngle: Single;
Private | OldMoveForwardDistance: Single;
Private | OldStrafeHorizontalDistance: Single;
Private | OldStrafeVerticalDistance: Single;
Private | FTurnInertia: Single;
Private | FTurnSpeed: Single;
Private | FTurnMaxAngle: Single;
Private | FMovementAcceleration: Single;
Private | FMovementInertia: Single;
Private | FMovementSpeed: Single;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Private | function StoreMovementAcceleration: Boolean;
Private | function StoreMovementInertia: Boolean;
Private | function StoreMovementSpeed: Boolean;
Private | function StoreTurnInertia: Boolean;
Private | function StoreTurnMaxAngle: Boolean;
Private | function StoreTurnSpeed: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property MovementAcceleration: Single read FMovementAcceleration write FMovementAcceleration stored StoreMovementAcceleration;
Published | property MovementInertia: Single read FMovementInertia write FMovementInertia stored StoreMovementInertia;
Published | property MovementSpeed: Single read FMovementSpeed write FMovementSpeed stored StoreMovementSpeed;
Published | property TurnInertia: Single read FTurnInertia write FTurnInertia stored StoreTurnInertia;
Published | property TurnMaxAngle: Single read FTurnMaxAngle write FTurnMaxAngle stored StoreTurnMaxAngle;
Published | property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private OldTurnHorizontalAngle: Single;

This item has no description.

Private OldTurnVerticalAngle: Single;

This item has no description.

Private OldMoveForwardDistance: Single;

This item has no description.

Private OldStrafeHorizontalDistance: Single;

This item has no description.

Private OldStrafeVerticalDistance: Single;

This item has no description.

Private FTurnInertia: Single;

This item has no description.

Private FTurnSpeed: Single;

This item has no description.

Private FTurnMaxAngle: Single;

This item has no description.

Private FMovementAcceleration: Single;

This item has no description.

Private FMovementInertia: Single;

This item has no description.

Private FMovementSpeed: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Private function StoreMovementAcceleration: Boolean;

This item has no description.

Private function StoreMovementInertia: Boolean;

This item has no description.

Private function StoreMovementSpeed: Boolean;

This item has no description.

Private function StoreTurnInertia: Boolean;

This item has no description.

Private function StoreTurnMaxAngle: Boolean;

This item has no description.

Private function StoreTurnSpeed: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

This item has no description.

Properties

Published property MovementAcceleration: Single read FMovementAcceleration write FMovementAcceleration stored StoreMovementAcceleration;

This item has no description.

Published property MovementInertia: Single read FMovementInertia write FMovementInertia stored StoreMovementInertia;

This item has no description.

Published property MovementSpeed: Single read FMovementSpeed write FMovementSpeed stored StoreMovementSpeed;

This item has no description.

Published property TurnInertia: Single read FTurnInertia write FTurnInertia stored StoreTurnInertia;

This item has no description.

Published property TurnMaxAngle: Single read FTurnMaxAngle write FTurnMaxAngle stored StoreTurnMaxAngle;

This item has no description.

Published property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorGeneralParameters

Class TGLNavigatorGeneralParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorGeneralParameters = class(TPersistent)

Description

The wrapper for all general inertia parameters. These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.

Hierarchy

  • TObject
  • TPersistent
  • TGLNavigatorGeneralParameters

Overview

Fields

Private | FOwner: TPersistent;
Private | FAutoScaleMin: Single;
Private | FAutoScaleMax: Single;
Private | FAutoScaleMult: Single;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Private | function StoreAutoScaleMax: Boolean;
Private | function StoreAutoScaleMin: Boolean;
Private | function StoreAutoScaleMult: Boolean;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property AutoScaleMax: Single read FAutoScaleMax write FAutoScaleMax stored StoreAutoScaleMax;
Published | property AutoScaleMin: Single read FAutoScaleMin write FAutoScaleMin stored StoreAutoScaleMin;
Published | property AutoScaleMult: Single read FAutoScaleMult write FAutoScaleMult stored StoreAutoScaleMult;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FAutoScaleMin: Single;

This item has no description.

Private FAutoScaleMax: Single;

This item has no description.

Private FAutoScaleMult: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Private function StoreAutoScaleMax: Boolean;

This item has no description.

Private function StoreAutoScaleMin: Boolean;

This item has no description.

Private function StoreAutoScaleMult: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property AutoScaleMax: Single read FAutoScaleMax write FAutoScaleMax stored StoreAutoScaleMax;

This item has no description.

Published property AutoScaleMin: Single read FAutoScaleMin write FAutoScaleMin stored StoreAutoScaleMin;

This item has no description.

Published property AutoScaleMult: Single read FAutoScaleMult write FAutoScaleMult stored StoreAutoScaleMult;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLNavigatorMoveAroundParameters

Class TGLNavigatorMoveAroundParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLNavigatorMoveAroundParameters = class(TPersistent)

Description

The wrapper for all parameters that effect how the TGLBaseSceneObject.MoveObjectAround() procedure works

Hierarchy

  • TObject
  • TPersistent
  • TGLNavigatorMoveAroundParameters

Overview

Fields

Private | FOwner: TPersistent;
Private | FTargetObject: TGLBaseSceneObject;
Private | FOldPitchInertiaAngle: Single;
Private | FOldTurnInertiaAngle: Single;
Private | FPitchSpeed: Single;
Private | FTurnSpeed: Single;
Private | FInertia: Single;
Private | FMaxAngle: Single;
Private | FCutoff: Double;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Private | function StoreCutoff: Boolean;
Private | function StoreInertia: Boolean;
Private | function StoreMaxAngle: Boolean;
Private | function StorePitchSpeed: Boolean;
Private | function StoreTurnSpeed: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;
Private | procedure SetTargetObject(const Value: TGLBaseSceneObject);

Properties

Published | property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property MaxAngle: Single read FMaxAngle write FMaxAngle stored StoreMaxAngle;
Published | property PitchSpeed: Single read FPitchSpeed write FPitchSpeed stored StorePitchSpeed;
Published | property TargetObject: TGLBaseSceneObject read FTargetObject write SetTargetObject;
Published | property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FTargetObject: TGLBaseSceneObject;

This item has no description.

Private FOldPitchInertiaAngle: Single;

This item has no description.

Private FOldTurnInertiaAngle: Single;

This item has no description.

Private FPitchSpeed: Single;

This item has no description.

Private FTurnSpeed: Single;

This item has no description.

Private FInertia: Single;

This item has no description.

Private FMaxAngle: Single;

This item has no description.

Private FCutoff: Double;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Private function StoreCutoff: Boolean;

This item has no description.

Private function StoreInertia: Boolean;

This item has no description.

Private function StoreMaxAngle: Boolean;

This item has no description.

Private function StorePitchSpeed: Boolean;

This item has no description.

Private function StoreTurnSpeed: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

This item has no description.

Private procedure SetTargetObject(const Value: TGLBaseSceneObject);

This item has no description.

Properties

Published property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;

This item has no description.

Published property Inertia: Single read FInertia write FInertia stored StoreInertia;

This item has no description.

Published property MaxAngle: Single read FMaxAngle write FMaxAngle stored StoreMaxAngle;

This item has no description.

Published property PitchSpeed: Single read FPitchSpeed write FPitchSpeed stored StorePitchSpeed;

This item has no description.

Published property TargetObject: TGLBaseSceneObject read FTargetObject write SetTargetObject;

This item has no description.

Published property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLSmoothNavigator

Class TGLSmoothNavigator

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLSmoothNavigator = class(TGLNavigator)

Description

The component for moving a TGLBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor. It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLNavigator
  • TGLSmoothNavigator

Overview

Fields

Private | FMaxExpectedDeltaTime: Double;
Private | FInertiaParams: TGLNavigatorInertiaParameters;
Private | FGeneralParams: TGLNavigatorGeneralParameters;
Private | FMoveAroundParams: TGLNavigatorMoveAroundParameters;
Private | FAdjustDistanceParams: TGLNavigatorAdjustDistanceParameters;
Private | FAdjustDistanceParamsEx: TGLNavigatorAdjustDistanceParametersEx;
Private | FCustomAnimatedItems: TGLNavigatorSmoothChangeItems;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AdjustDistanceToPoint(const APoint: TGLVector; const DistanceRatio : Single; ADeltaTime: Double): Boolean;
Public | function AdjustDistanceToPointEx(const APoint: TGLVector; ADeltaTime: Double): Boolean;
Public | function AdjustDistanceToTarget(const DistanceRatio : Single; const ADeltaTime: Double): Boolean;
Public | function AdjustDistanceToTargetEx(const ADeltaTime: Double): Boolean;
Public | function MoveAroundTarget(const PitchDelta, TurnDelta : Single; const ADeltaTime: Double): Boolean;
Public | function MoveObjectAround(const AObject: TGLBaseSceneObject; PitchDelta, TurnDelta : Single; ADeltaTime: Double): Boolean;
Private | function StoreMaxExpectedDeltaTime: Boolean;
Public | procedure AnimateCustomItems(const ADeltaTime: Double); virtual;
Public | procedure AutoScaleParameters(const FPS: Single); virtual;
Public | procedure AutoScaleParametersUp(const FPS: Single); virtual;
Public | procedure FlyForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure MoveForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure ScaleParameters(const Value: Single); virtual;
Public | procedure SetObject(Value: TGLBaseSceneObject); override;
Public | procedure StrafeHorizontal(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure StrafeVertical(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure TurnHorizontal(Angle: Single; ADeltaTime: Double); virtual;
Public | procedure TurnVertical(Angle: Single; ADeltaTime: Double); virtual;
Private | procedure SetAdjustDistanceParams(const Value: TGLNavigatorAdjustDistanceParameters);
Private | procedure SetAdjustDistanceParamsEx( const Value: TGLNavigatorAdjustDistanceParametersEx);
Private | procedure SetCustomAnimatedItems( const Value: TGLNavigatorSmoothChangeItems);
Private | procedure SetGeneralParams(const Value: TGLNavigatorGeneralParameters);
Private | procedure SetInertiaParams(const Value: TGLNavigatorInertiaParameters);
Private | procedure SetMoveAroundParams(const Value: TGLNavigatorMoveAroundParameters);

Properties

Published | property AdjustDistanceParams: TGLNavigatorAdjustDistanceParameters read FAdjustDistanceParams write SetAdjustDistanceParams;
Published | property AdjustDistanceParamsEx: TGLNavigatorAdjustDistanceParametersEx read FAdjustDistanceParamsEx write SetAdjustDistanceParamsEx;
Published | property CustomAnimatedItems: TGLNavigatorSmoothChangeItems read FCustomAnimatedItems write SetCustomAnimatedItems;
Published | property GeneralParams: TGLNavigatorGeneralParameters read FGeneralParams write SetGeneralParams;
Published | property InertiaParams: TGLNavigatorInertiaParameters read FInertiaParams write SetInertiaParams;
Published | property MaxExpectedDeltaTime: Double read FMaxExpectedDeltaTime write FMaxExpectedDeltaTime stored StoreMaxExpectedDeltaTime;
Published | property MoveAroundParams: TGLNavigatorMoveAroundParameters read FMoveAroundParams write SetMoveAroundParams;

Description

Fields

Private FMaxExpectedDeltaTime: Double;

This item has no description.

Private FInertiaParams: TGLNavigatorInertiaParameters;

This item has no description.

Private FGeneralParams: TGLNavigatorGeneralParameters;

This item has no description.

Private FMoveAroundParams: TGLNavigatorMoveAroundParameters;

This item has no description.

Private FAdjustDistanceParams: TGLNavigatorAdjustDistanceParameters;

This item has no description.

Private FAdjustDistanceParamsEx: TGLNavigatorAdjustDistanceParametersEx;

This item has no description.

Private FCustomAnimatedItems: TGLNavigatorSmoothChangeItems;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

Constructors-destructors.

Public destructor Destroy; override;

This item has no description.

Public function AdjustDistanceToPoint(const APoint: TGLVector; const DistanceRatio : Single; ADeltaTime: Double): Boolean;

Uses AdjustDistanceParams.

Public function AdjustDistanceToPointEx(const APoint: TGLVector; ADeltaTime: Double): Boolean;

Uses AdjustDistanceParamsEx.

Public function AdjustDistanceToTarget(const DistanceRatio : Single; const ADeltaTime: Double): Boolean;

This item has no description.

Public function AdjustDistanceToTargetEx(const ADeltaTime: Double): Boolean;

This item has no description.

Public function MoveAroundTarget(const PitchDelta, TurnDelta : Single; const ADeltaTime: Double): Boolean;

Uses MoveAroundParams. Returns True, if object was actually moved.

Public function MoveObjectAround(const AObject: TGLBaseSceneObject; PitchDelta, TurnDelta : Single; ADeltaTime: Double): Boolean;

This item has no description.

Private function StoreMaxExpectedDeltaTime: Boolean;

This item has no description.

Public procedure AnimateCustomItems(const ADeltaTime: Double); virtual;

Uses CustomAnimatedItems.

Public procedure AutoScaleParameters(const FPS: Single); virtual;

This item has no description.

Public procedure AutoScaleParametersUp(const FPS: Single); virtual;

This item has no description.

Public procedure FlyForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;

This item has no description.

Public procedure MoveForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

Uses GeneralParams. In ScaleParameters, Value should be around 1.

Public procedure SetObject(Value: TGLBaseSceneObject); override;

From TGLNavigator. Probably, should not be public.

Public procedure StrafeHorizontal(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;

This item has no description.

Public procedure StrafeVertical(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;

This item has no description.

Public procedure TurnHorizontal(Angle: Single; ADeltaTime: Double); virtual;

Uses InertiaParams.

Public procedure TurnVertical(Angle: Single; ADeltaTime: Double); virtual;

This item has no description.

Private procedure SetAdjustDistanceParams(const Value: TGLNavigatorAdjustDistanceParameters);

This item has no description.

Private procedure SetAdjustDistanceParamsEx( const Value: TGLNavigatorAdjustDistanceParametersEx);

This item has no description.

Private procedure SetCustomAnimatedItems( const Value: TGLNavigatorSmoothChangeItems);

This item has no description.

Private procedure SetGeneralParams(const Value: TGLNavigatorGeneralParameters);

This item has no description.

Private procedure SetInertiaParams(const Value: TGLNavigatorInertiaParameters);

This item has no description.

Private procedure SetMoveAroundParams(const Value: TGLNavigatorMoveAroundParameters);

This item has no description.

Properties

Published property AdjustDistanceParams: TGLNavigatorAdjustDistanceParameters read FAdjustDistanceParams write SetAdjustDistanceParams;

This item has no description.

Published property AdjustDistanceParamsEx: TGLNavigatorAdjustDistanceParametersEx read FAdjustDistanceParamsEx write SetAdjustDistanceParamsEx;

This item has no description.

Published property CustomAnimatedItems: TGLNavigatorSmoothChangeItems read FCustomAnimatedItems write SetCustomAnimatedItems;

This item has no description.

Published property GeneralParams: TGLNavigatorGeneralParameters read FGeneralParams write SetGeneralParams;

This item has no description.

Published property InertiaParams: TGLNavigatorInertiaParameters read FInertiaParams write SetInertiaParams;

This item has no description.

Published property MaxExpectedDeltaTime: Double read FMaxExpectedDeltaTime write FMaxExpectedDeltaTime stored StoreMaxExpectedDeltaTime;

This item has no description.

Published property MoveAroundParams: TGLNavigatorMoveAroundParameters read FMoveAroundParams write SetMoveAroundParams;


GLSysHelp v.2.5: GLS.SmoothNavigator: Class TGLSmoothUserInterface

Class TGLSmoothUserInterface

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SmoothNavigator

Declaration

type TGLSmoothUserInterface = class(TComponent)

Description

The component which reads the userinput and transform it into action. Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLSmoothUserInterface

Overview

Fields

Private | FAutoUpdateMouse: Boolean;
Private | FMouseLookActive: Boolean;
Private | FSmoothNavigator: TGLSmoothNavigator;
Private | FSmoothVertNavigator: TGLSmoothNavigator;
Private | FInvertMouse: Boolean;
Private | FOriginalMousePos: TGLCoordinates2;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MouseLook(const ADeltaTime: Double): Boolean; overload;
Public | function MouseLook(const NewXY: TPoint; const ADeltaTime: Double): Boolean; overload;
Public | function MouseLook(const NewX, NewY: Integer; const ADeltaTime: Double): Boolean; overload;
Public | procedure MouseLookActiveToggle; virtual;
Public | procedure TurnHorizontal(const Angle : Single; const ADeltaTime: Double); virtual;
Public | procedure TurnVertical(const Angle : Single; const ADeltaTime: Double); virtual;
Private | procedure SetMouseLookActive(const Value: Boolean); virtual;
Private | procedure SetOriginalMousePos(const Value: TGLCoordinates2); virtual;
Private | procedure SetSmoothNavigator(const Value: TGLSmoothNavigator); virtual;
Private | procedure SetSmoothVertNavigator(const Value: TGLSmoothNavigator); virtual;

Properties

Published | property AutoUpdateMouse: Boolean read FAutoUpdateMouse write FAutoUpdateMouse default True;
Published | property InvertMouse: Boolean read FInvertMouse write FInvertMouse default False;
Published | property MouseLookActive: Boolean read FMouseLookActive write SetMouseLookActive default False;
Published | property OriginalMousePos: TGLCoordinates2 read FOriginalMousePos write SetOriginalMousePos;
Published | property SmoothNavigator: TGLSmoothNavigator read FSmoothNavigator write SetSmoothNavigator;
Published | property SmoothVertNavigator: TGLSmoothNavigator read FSmoothVertNavigator write SetSmoothVertNavigator;

Description

Fields

Private FAutoUpdateMouse: Boolean;

This item has no description.

Private FMouseLookActive: Boolean;

This item has no description.

Private FSmoothNavigator: TGLSmoothNavigator;

This item has no description.

Private FSmoothVertNavigator: TGLSmoothNavigator;

This item has no description.

Private FInvertMouse: Boolean;

This item has no description.

Private FOriginalMousePos: TGLCoordinates2;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MouseLook(const ADeltaTime: Double): Boolean; overload;

This item has no description.

Public function MouseLook(const NewXY: TPoint; const ADeltaTime: Double): Boolean; overload;

This item has no description.

Public function MouseLook(const NewX, NewY: Integer; const ADeltaTime: Double): Boolean; overload;

This item has no description.

Public procedure MouseLookActiveToggle; virtual;

This item has no description.

Public procedure TurnHorizontal(const Angle : Single; const ADeltaTime: Double); virtual;

This item has no description.

Public procedure TurnVertical(const Angle : Single; const ADeltaTime: Double); virtual;

This item has no description.

Private procedure SetMouseLookActive(const Value: Boolean); virtual;

This item has no description.

Private procedure SetOriginalMousePos(const Value: TGLCoordinates2); virtual;

This item has no description.

Private procedure SetSmoothNavigator(const Value: TGLSmoothNavigator); virtual;

This item has no description.

Private procedure SetSmoothVertNavigator(const Value: TGLSmoothNavigator); virtual;

This item has no description.

Properties

Published property AutoUpdateMouse: Boolean read FAutoUpdateMouse write FAutoUpdateMouse default True;

This item has no description.

Published property InvertMouse: Boolean read FInvertMouse write FInvertMouse default False;

This item has no description.

Published property MouseLookActive: Boolean read FMouseLookActive write SetMouseLookActive default False;

This item has no description.

Published property OriginalMousePos: TGLCoordinates2 read FOriginalMousePos write SetOriginalMousePos;

This item has no description.

Published property SmoothNavigator: TGLSmoothNavigator read FSmoothNavigator write SetSmoothNavigator;

This item has no description.

Published property SmoothVertNavigator: TGLSmoothNavigator read FSmoothVertNavigator write SetSmoothVertNavigator;


GLSysHelp v.2.5: GLS.SoundFileObjects

Unit GLS.SoundFileObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.MMSystem
  • System.Classes
  • System.SysUtils
  • VCL.Consts
  • GLS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSoundSampling |
Class TGLSoundFile |
Record TGLSoundFileFormat |
Class TGLSoundFileFormatsList |

Functions and Procedures

function GetGLSoundFileFormats: TGLSoundFileFormatsList;
procedure RegisterSoundFileFormat(const AExtension, ADescription: String; AClass: TGLSoundFileClass);
procedure UnregisterSoundFileClass(AClass: TGLSoundFileClass);

Types

PSoundFileFormat = ˆTGLSoundFileFormat;
TGLSoundFileClass = class of TGLSoundFile;

Description

Functions and Procedures

function GetGLSoundFileFormats: TGLSoundFileFormatsList;

This item has no description.

procedure RegisterSoundFileFormat(const AExtension, ADescription: String; AClass: TGLSoundFileClass);

This item has no description.

procedure UnregisterSoundFileClass(AClass: TGLSoundFileClass);

This item has no description.

Types

PSoundFileFormat = ˆTGLSoundFileFormat;

This item has no description.

TGLSoundFileClass = class of TGLSoundFile;


GLSysHelp v.2.5: GLS.SoundFileObjects: Class TGLSoundSampling

Class TGLSoundSampling

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundFileObjects

Declaration

type TGLSoundSampling = class(TPersistent)

Description

Defines a sound sampling quality.

Hierarchy

  • TObject
  • TPersistent
  • TGLSoundSampling

Overview

Fields

Private | FOwner: TPersistent;
Private | FFrequency: Integer;
Private | FNbChannels: Integer;
Private | FBitsPerSample: Integer;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | destructor Destroy; override;
Public | function BytesPerSample: Integer;
Public | function BytesPerSec: Integer;
Public | function WaveFormat: TWaveFormatEx;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property BitsPerSample: Integer read FBitsPerSample write FBitsPerSample default 8;
Published | property Frequency: Integer read FFrequency write FFrequency default 22050;
Published | property NbChannels: Integer read FNbChannels write FNbChannels default 1;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FFrequency: Integer;

This item has no description.

Private FNbChannels: Integer;

This item has no description.

Private FBitsPerSample: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BytesPerSample: Integer;

This item has no description.

Public function BytesPerSec: Integer;

This item has no description.

Public function WaveFormat: TWaveFormatEx;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property BitsPerSample: Integer read FBitsPerSample write FBitsPerSample default 8;

Nb of bits per sample. Common values are 8 and 16 bits.

Published property Frequency: Integer read FFrequency write FFrequency default 22050;

Sampling frequency in Hz (= samples per sec)

Published property NbChannels: Integer read FNbChannels write FNbChannels default 1;

Nb of sampling channels. 1 = mono, 2 = stereo, etc.


GLSysHelp v.2.5: GLS.SoundFileObjects: Class TGLSoundFile

Class TGLSoundFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundFileObjects

Declaration

type TGLSoundFile = class(TGLDataFile)

Description

Abstract base class for different Sound file formats. The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TGLSoundFile is very similar to TGraphic (see Delphi Help). Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLSoundFile

Overview

Fields

Private FSampling: TGLSoundSampling;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function LengthInBytes: Integer; virtual; abstract;
Public | function LengthInSamples: Integer;
Public | function LengthInSec: Single;
Public | function PCMData: Pointer; virtual; abstract;
Public | function WAVData: Pointer; virtual; abstract;
Public | function WAVDataSize: Integer; virtual; abstract;
Public | procedure PlayOnWaveOut; virtual;

Properties

Public property Sampling: TGLSoundSampling read FSampling write SetSampling;

Description

Fields

Private FSampling: TGLSoundSampling;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LengthInBytes: Integer; virtual; abstract;

Length of PCM data, in bytes.

Public function LengthInSamples: Integer;

Nb of intensity samples in the sample.

Public function LengthInSec: Single;

Length of play of the sample at nominal speed in seconds.

Public function PCMData: Pointer; virtual; abstract;

Returns a pointer to the sample data viewed as an in-memory PCM buffer.

Public function WAVData: Pointer; virtual; abstract;

Returns a pointer to the sample data viewed as an in-memory WAV File.

Public function WAVDataSize: Integer; virtual; abstract;

Returns the size (in bytes) of the WAVData.

Public procedure PlayOnWaveOut; virtual;

This item has no description.

Properties

Public property Sampling: TGLSoundSampling read FSampling write SetSampling;


GLSysHelp v.2.5: GLS.SoundFileObjects: Record TGLSoundFileFormat

Record TGLSoundFileFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundFileObjects

Declaration

type TGLSoundFileFormat = record

Description

This item has no description.

Overview

Fields

Public | SoundFileClass: TGLSoundFileClass;
Public | Extension: String;
Public | Description: String;
Public | DescResID: Integer;

Description

Fields

Public SoundFileClass: TGLSoundFileClass;

This item has no description.

Public Extension: String;

This item has no description.

Public Description: String;

This item has no description.

Public DescResID: Integer;


GLSysHelp v.2.5: GLS.SoundFileObjects: Class TGLSoundFileFormatsList

Class TGLSoundFileFormatsList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundFileObjects

Declaration

type TGLSoundFileFormatsList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLSoundFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(Ext: string): TGLSoundFileClass;
Public | procedure Add(const Ext, Desc: String; DescID: Integer; AClass: TGLSoundFileClass);
Public | procedure BuildFilterStrings(SoundFileClass: TGLSoundFileClass; out Descriptions, Filters: string);
Public | procedure Remove(AClass: TGLSoundFileClass);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function FindExt(Ext: string): TGLSoundFileClass;

This item has no description.

Public procedure Add(const Ext, Desc: String; DescID: Integer; AClass: TGLSoundFileClass);

This item has no description.

Public procedure BuildFilterStrings(SoundFileClass: TGLSoundFileClass; out Descriptions, Filters: string);

This item has no description.

Public procedure Remove(AClass: TGLSoundFileClass);


GLSysHelp v.2.5: GLS.SoundManager

Unit GLS.SoundManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.VectorTypes
  • GLS.SoundFileObjects
  • GLS.Scene
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GLS.Cadencer
  • GLS.BaseClasses
  • GLS.FileMP3
  • GLS.FileWAV
  • GLS.ImageUtils
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSoundSample |
Class TGLSoundSamples |
Class TGLSoundLibrary |
Class TGLBaseSoundSource |
Class TGLSoundSource |
Class TGLSoundSources |
Class TGLSoundManager |
Class TGLBSoundEmitter |

Functions and Procedures

function ActiveSoundManager: TGLSoundManager;
function GetSoundLibraryByName(const aName: string): TGLSoundLibrary;
function GetOrCreateSoundEmitter(behaviours: TGLBehaviours): TGLBSoundEmitter; overload;
function GetOrCreateSoundEmitter(obj: TGLBaseSceneObject): TGLBSoundEmitter; overload;

Types

TGLSoundEnvironment = (...);
TGLSoundSourceChange = (...);
TGLSoundSourceChanges = set of TGLSoundSourceChange;

Variables

vVerboseGLSMErrors: Boolean = True;

Description

Functions and Procedures

function ActiveSoundManager: TGLSoundManager;

This item has no description.

function GetSoundLibraryByName(const aName: string): TGLSoundLibrary;

This item has no description.

function GetOrCreateSoundEmitter(behaviours: TGLBehaviours): TGLBSoundEmitter; overload;

This item has no description.

function GetOrCreateSoundEmitter(obj: TGLBaseSceneObject): TGLBSoundEmitter; overload;

This item has no description.

Types

TGLSoundEnvironment = (...);

EAX standard sound environments.

Values
  • seDefault
  • sePaddedCell
  • seRoom
  • seBathroom
  • seLivingRoom
  • seStoneroom
  • seAuditorium
  • seConcertHall
  • seCave
  • seArena
  • seHangar
  • seCarpetedHallway
  • seHallway
  • seStoneCorridor
  • seAlley
  • seForest
  • seCity
  • seMountains
  • seQuarry
  • sePlain
  • seParkingLot
  • seSewerPipe
  • seUnderWater
  • seDrugged
  • seDizzy
  • sePsychotic
TGLSoundSourceChange = (...);

This item has no description.

Values
  • sscTransformation
  • sscSample
  • sscStatus
TGLSoundSourceChanges = set of TGLSoundSourceChange;

This item has no description.

Variables

vVerboseGLSMErrors: Boolean = True;

If this variable is true, errors in GLSM may be displayed to the user


GLSysHelp v.2.5: GLS.SoundManager: Class TGLSoundSample

Class TGLSoundSample

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundManager

Declaration

type TGLSoundSample = class(TCollectionItem)

Description

Platform Specific

.NET Stores a single PCM coded sound sample.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLSoundSample

Overview

Fields

Private | FName: string;
Private | FData: TGLSoundFile;
Private | FTag: Integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function LengthInBytes: Integer;
Public | function LengthInSamples: Integer;
Public | function LengthInSec: Single;
Public | function Sampling: TGLSoundSampling;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure PlayOnWaveOut;

Properties

Published | property Data: TGLSoundFile read FData write SetData stored False;
Public | property ManagerTag: Integer read FTag write FTag;
Published | property Name: string read FName write FName;

Description

Fields

Private FName: string;

This item has no description.

Private FData: TGLSoundFile;

This item has no description.

Private FTag: Integer;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LengthInBytes: Integer;

This item has no description.

Public function LengthInSamples: Integer;

This item has no description.

Public function LengthInSec: Single;

This item has no description.

Public function Sampling: TGLSoundSampling;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string);

This item has no description.

Public procedure PlayOnWaveOut;

This item has no description.

Properties

Published property Data: TGLSoundFile read FData write SetData stored False;

This item has no description.

Public property ManagerTag: Integer read FTag write FTag;

This Tag is reserved for sound manager use only

Published property Name: string read FName write FName;


GLSysHelp v.2.5: GLS.SoundManager: Class TGLSoundSamples

Class TGLSoundSamples

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundManager

Declaration

type TGLSoundSamples = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLSoundSamples

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLSoundSample;
Public | function AddFile(const fileName: string; const sampleName: string = ''): TGLSoundSample;
Public | function FindItemID(ID: Integer): TGLSoundSample;
Public | function GetByName(const aName: string): TGLSoundSample;

Properties

Public property Items[index: Integer]: TGLSoundSample read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TGLSoundSample;

This item has no description.

Public function AddFile(const fileName: string; const sampleName: string = ''): TGLSoundSample;

This item has no description.

Public function FindItemID(ID: Integer): TGLSoundSample;

This item has no description.

Public function GetByName(const aName: string): TGLSoundSample;

This item has no description.

Properties

Public property Items[index: Integer]: TGLSoundSample read GetItems write SetItems;


GLSysHelp v.2.5: GLS.SoundManager: Class TGLSoundLibrary

Class TGLSoundLibrary

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundManager

Declaration

type TGLSoundLibrary = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLSoundLibrary

Overview

Fields

Private FSamples: TGLSoundSamples;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property Samples: TGLSoundSamples read FSamples write SetSamples;

Description

Fields

Private FSamples: TGLSoundSamples;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Samples: TGLSoundSamples read FSamples write SetSamples;


GLSysHelp v.2.5: GLS.SoundManager: Class TGLBaseSoundSource

Class TGLBaseSoundSource

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundManager

Declaration

type TGLBaseSoundSource = class(TCollectionItem)

Description

Base class for origin of sound playback.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLBaseSoundSource

Overview

Fields

Private | FBehaviourToNotify: TGLBSoundEmitter;
Private | FPriority: Integer;
Private | FOrigin: TGLBaseSceneObject;
Private | FVolume: Single;
Private | FMinDistance: Single;
Private | FMaxDistance: Single;
Private | FInsideConeAngle: Single;
Private | FOutsideConeAngle: Single;
Private | FConeOutsideVolume: Single;
Private | FSoundLibraryName: string;
Private | FSoundLibrary: TGLSoundLibrary;
Private | FSoundName: string;
Private | FMute: Boolean;
Private | FPause: Boolean;
Private | FChanges: TGLSoundSourceChanges;
Private | FNbLoops: Integer;
Private | FTag: Cardinal;
Private | FFrequency: Integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function Sample: TGLSoundSample;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public | property Changes: TGLSoundSourceChanges read FChanges;
Published | property ConeOutsideVolume: Single read FConeOutsideVolume write SetConeOutsideVolume;
Published | property Frequency: Integer read FFrequency write SetFrequency default -1;
Published | property InsideConeAngle: Single read FInsideConeAngle write SetInsideConeAngle;
Public | property ManagerTag: Cardinal read FTag write FTag;
Published | property MaxDistance: Single read FMaxDistance write SetMaxDistance;
Published | property MinDistance: Single read FMinDistance write SetMinDistance;
Published | property Mute: Boolean read FMute write SetMute default False;
Published | property NbLoops: Integer read FNbLoops write SetNbLoops default 1;
Public | property Origin: TGLBaseSceneObject read FOrigin write SetOrigin;
Published | property OutsideConeAngle: Single read FOutsideConeAngle write SetOutsideConeAngle;
Published | property Pause: Boolean read FPause write SetPause default False;
Published | property Priority: Integer read FPriority write SetPriority default 0;
Published | property SoundLibrary: TGLSoundLibrary read GetSoundLibrary write SetSoundLibrary;
Published | property SoundName: string read FSoundName write SetSoundName;
Published | property Volume: Single read FVolume write SetVolume;

Description

Fields

Private FBehaviourToNotify: TGLBSoundEmitter;

This item has no description.

Private FPriority: Integer;

private only, NOT persistent, not assigned

Private FOrigin: TGLBaseSceneObject;

This item has no description.

Private FVolume: Single;

NOT persistent

Private FMinDistance: Single;

This item has no description.

Private FMaxDistance: Single;

This item has no description.

Private FInsideConeAngle: Single;

This item has no description.

Private FOutsideConeAngle: Single;

This item has no description.

Private FConeOutsideVolume: Single;

This item has no description.

Private FSoundLibraryName: string;

This item has no description.

Private FSoundLibrary: TGLSoundLibrary;

used for persistence

Private FSoundName: string;

persistence via name

Private FMute: Boolean;

This item has no description.

Private FPause: Boolean;

This item has no description.

Private FChanges: TGLSoundSourceChanges;

This item has no description.

Private FNbLoops: Integer;

NOT persistent, not assigned

Private FTag: Cardinal;

This item has no description.

Private FFrequency: Integer;

NOT persistent, not assigned

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Sample: TGLSoundSample;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Public property Changes: TGLSoundSourceChanges read FChanges;

This item has no description.

Published property ConeOutsideVolume: Single read FConeOutsideVolume write SetConeOutsideVolume;

Cone outside volume, [0.0; 1.0] range. See DirectX SDK for details.

Published property Frequency: Integer read FFrequency write SetFrequency default -1;

Sample custom playback frequency. Values null or negative are interpreted as 'default frequency'.

Published property InsideConeAngle: Single read FInsideConeAngle write SetInsideConeAngle;

Inside cone angle, [0°; 360°]. Sound volume is maximal within this cone. See DirectX SDK for details.

Public property ManagerTag: Cardinal read FTag write FTag;

This Tag is reserved for sound manager use only

Published property MaxDistance: Single read FMaxDistance write SetMaxDistance;

Max distance, if source is further away, it will not be heard. 100.0 by default

Published property MinDistance: Single read FMinDistance write SetMinDistance;

Min distance before spatial attenuation occurs. 1.0 by default

Published property Mute: Boolean read FMute write SetMute default False;

This item has no description.

Published property NbLoops: Integer read FNbLoops write SetNbLoops default 1;

Nb of playing loops.

Public property Origin: TGLBaseSceneObject read FOrigin write SetOrigin;

Origin object for the sound sources. Absolute object position/orientation are taken into account, the object's TGLBInertia is considered if any. If origin is nil, the source is assumed to be static at the origin. Note : since TCollectionItem do not support the "Notification" scheme, it is up to the Origin object to take care of updating this property prior to release/destruction.

Published property OutsideConeAngle: Single read FOutsideConeAngle write SetOutsideConeAngle;

Outside cone angle, [0°; 360°]. Between inside and outside cone, sound volume decreases between max and cone outside volume. See DirectX SDK for details.

Published property Pause: Boolean read FPause write SetPause default False;

This item has no description.

Published property Priority: Integer read FPriority write SetPriority default 0;

Sound source priority, the higher the better. When maximum number of sound sources is reached, only the sources with the highest priority will continue to play, however, even non-playing sources should be tracked by the manager, thus allowing an "unlimited" amount of sources from the application point of view.

Published property SoundLibrary: TGLSoundLibrary read GetSoundLibrary write SetSoundLibrary;

This item has no description.

Published property SoundName: string read FSoundName write SetSoundName;

This item has no description.

Published property Volume: Single read FVolume write SetVolume;

Volume of the source, [0.0; 1.0] range


GLSysHelp v.2.5: GLS.SoundManager: Class TGLSoundSource

Class TGLSoundSource

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundManager

Declaration

type TGLSoundSource = class(TGLBaseSoundSource)

Description

Origin of sound playback. Just publishes the 'Origin' property. Note that the "orientation" is the the source's Direction, ie. the "Z" vector.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLBaseSoundSource
  • TGLSoundSource

Overview

Methods

Public destructor Destroy; override;

Properties

Published property Origin;

Description

Methods

Public destructor Destroy; override;

This item has no description.

Properties

Published property Origin;

This item has no description. Showing description inherited from TGLBaseSoundSource.Origin.

Origin object for the sound sources. Absolute object position/orientation are taken into account, the object's TGLBInertia is considered if any. If origin is nil, the source is assumed to be static at the origin. Note : since TCollectionItem do not support the "Notification" scheme, it is up to the Origin object to take care of updating this property prior to release/destruction.


GLSysHelp v.2.5: GLS.SoundManager: Class TGLSoundSources

Class TGLSoundSources

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundManager

Declaration

type TGLSoundSources = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLSoundSources

Overview

Methods

Public constructor Create(AOwner: TComponent);

Properties

Public property Items[index: Integer]: TGLSoundSource read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Properties

Public property Items[index: Integer]: TGLSoundSource read GetItems write SetItems;


GLSysHelp v.2.5: GLS.SoundManager: Class TGLSoundManager

Class TGLSoundManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundManager

Declaration

type TGLSoundManager = class(TGLCadenceAbleComponent)

Description

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLSoundManager

Overview

Fields

Private | FActive: Boolean;
Private | FMute: Boolean;
Private | FPause: Boolean;
Private | FMasterVolume: Single;
Private | FListener: TGLBaseSceneObject;
Private | FLastListenerPosition: TGLVector;
Private | FSources: TGLSoundSources;
Private | FMaxChannels: Integer;
Private | FOutputFrequency: Integer;
Private | FUpdateFrequency: Single;
Private | FDistanceFactor: Single;
Private | FRollOffFactor: Single;
Private | FDopplerFactor: Single;
Private | FSoundEnvironment: TGLSoundEnvironment;
Private | FLastUpdateTime: Single;
Private | FLastDeltaTime: Single;
Private | FCadencer: TGLCadencer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CPUUsagePercent: Single; virtual;
Public | function EAXSupported: Boolean; virtual;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure StopAllSources;
Public | procedure UpdateSources; virtual;
Private | procedure ReadDoppler(reader: TReader);
Private | procedure SetActive(const val: Boolean);
Private | procedure SetMute(const val: Boolean);
Private | procedure SetPause(const val: Boolean);
Private | procedure WriteDoppler(writer: TWriter);

Properties

Published | property Active: Boolean read FActive write SetActive default False;
Published | property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Published | property DistanceFactor: Single read FDistanceFactor write SetDistanceFactor stored StoreDistanceFactor;
Published | property DopplerFactor: Single read FDopplerFactor write SetDopplerFactor stored False;
Published | property Environment: TGLSoundEnvironment read FSoundEnvironment write SetSoundEnvironment default seDefault;
Published | property Listener: TGLBaseSceneObject read FListener write SetListener;
Published | property MasterVolume: Single read FMasterVolume write SetMasterVolume;
Published | property MaxChannels: Integer read FMaxChannels write SetMaxChannels default 8;
Published | property Mute: Boolean read FMute write SetMute default False;
Published | property OutputFrequency: Integer read FOutputFrequency write SetOutputFrequency default 44100;
Published | property Pause: Boolean read FPause write SetPause default False;
Published | property RollOffFactor: Single read FRollOffFactor write SetRollOffFactor stored StoreRollOffFactor;
Published | property Sources: TGLSoundSources read FSources write SetSources;
Published | property UpdateFrequency: Single read FUpdateFrequency write SetUpdateFrequency stored StoreUpdateFrequency;

Description

Fields

Private FActive: Boolean;

This item has no description.

Private FMute: Boolean;

This item has no description.

Private FPause: Boolean;

This item has no description.

Private FMasterVolume: Single;

This item has no description.

Private FListener: TGLBaseSceneObject;

This item has no description.

Private FLastListenerPosition: TGLVector;

This item has no description.

Private FSources: TGLSoundSources;

This item has no description.

Private FMaxChannels: Integer;

This item has no description.

Private FOutputFrequency: Integer;

This item has no description.

Private FUpdateFrequency: Single;

This item has no description.

Private FDistanceFactor: Single;

This item has no description.

Private FRollOffFactor: Single;

This item has no description.

Private FDopplerFactor: Single;

This item has no description.

Private FSoundEnvironment: TGLSoundEnvironment;

This item has no description.

Private FLastUpdateTime: Single;

This item has no description.

Private FLastDeltaTime: Single;

This item has no description.

Private FCadencer: TGLCadencer;

last time UpdateSources was fired, not persistent

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CPUUsagePercent: Single; virtual;

Sound manager API reported CPU Usage. Returns -1 when unsupported.

Public function EAXSupported: Boolean; virtual;

True if EAX is supported.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

Progress notification for time synchronization. This method will call UpdateSources depending on the last time it was performed and the value of the UpdateFrequency property.

Public procedure StopAllSources;

Stop and free all sources.

Public procedure UpdateSources; virtual;

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.

Private procedure ReadDoppler(reader: TReader);

This item has no description.

Private procedure SetActive(const val: Boolean);

This item has no description.

Private procedure SetMute(const val: Boolean);

This item has no description.

Private procedure SetPause(const val: Boolean);

This item has no description.

Private procedure WriteDoppler(writer: TWriter);

This item has no description.

Properties

Published property Active: Boolean read FActive write SetActive default False;

Activation/deactivation of the low-level sound API

Published property Cadencer: TGLCadencer read FCadencer write SetCadencer;

Cadencer for time-based control.

Published property DistanceFactor: Single read FDistanceFactor write SetDistanceFactor stored StoreDistanceFactor;

Engine relative distance factor, compared to 1.0 meters. Equates to 'how many units per meter' your engine has.

Published property DopplerFactor: Single read FDopplerFactor write SetDopplerFactor stored False;

Engine relative Doppler factor, compared to 1.0 meters. Equates to 'how many units per meter' your engine has.

Published property Environment: TGLSoundEnvironment read FSoundEnvironment write SetSoundEnvironment default seDefault;

Sound environment (requires EAX compatible soundboard).

Published property Listener: TGLBaseSceneObject read FListener write SetListener;

Scene object that materializes the listener. The sceneobject's AbsolutePosition and orientation are used to define the listener coordinates, velocity is automatically calculated (if you're using DoProgress or connected the manager to a cadencer). If this property is nil, the listener is assumed to be static at the NullPoint coordinate, facing Z axis, with up being Y (ie. the default GLScene orientation).

Published property MasterVolume: Single read FMasterVolume write SetMasterVolume;

Master Volume adjustement in the [0.0; 1.0] range. Driver should take care of properly clamping the master volume.

Published property MaxChannels: Integer read FMaxChannels write SetMaxChannels default 8;

Maximum number of sound output channels. While some drivers will just ignore this value, others cannot dynamically adjust the maximum number of channels (you need to de-activate and re-activate the manager for this property to be taken into account).

Published property Mute: Boolean read FMute write SetMute default False;

Request to mute all sounds. All sound requests should be handled as if sound is unmuted though, however drivers should try to take a CPU advantage of mute over MasterVolume=0

Published property OutputFrequency: Integer read FOutputFrequency write SetOutputFrequency default 44100;

Sound output mixing frequency. Commonly used values ar 11025, 22050 and 44100. Note that most driver cannot dynamically adjust the output frequency (you need to de-ativate and re-activate the manager for this property to be taken into account).

Published property Pause: Boolean read FPause write SetPause default False;

Request to pause all sound, sound output should be muted too. When unpausing, all sound should resume at the point they were paused.

Published property RollOffFactor: Single read FRollOffFactor write SetRollOffFactor stored StoreRollOffFactor;

Sets the global attenuation rolloff factor. Normally volume for a sample will scale at 1 / distance. This gives a logarithmic attenuation of volume as the source gets further away (or closer). Setting this value makes the sound drop off faster or slower. The higher the value, the faster volume will fall off.

Published property Sources: TGLSoundSources read FSources write SetSources;

Currently active and playing sound sources.

Published property UpdateFrequency: Single read FUpdateFrequency write SetUpdateFrequency stored StoreUpdateFrequency;

Update frequency for time-based control (DoProgress). Default value is 10 Hz (frequency is clamped in the 1Hz-60Hz range).


GLSysHelp v.2.5: GLS.SoundManager: Class TGLBSoundEmitter

Class TGLBSoundEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SoundManager

Declaration

type TGLBSoundEmitter = class(TGLBehaviour)

Description

A sound emitter behaviour, plug it on any object to make it noisy. This behaviour is just an interface to a TGLSoundSource, for editing convenience.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBSoundEmitter

Overview

Fields

Private | FPlaying: Boolean;
Private | FSource: TGLBaseSoundSource;
Private | FPlayingSource: TGLSoundSource;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;

Properties

Published | property Playing: Boolean read GetPlaying write SetPlaying default False;
Public | property PlayingSource: TGLSoundSource read FPlayingSource;
Published | property Source: TGLBaseSoundSource read FSource write SetSource;

Description

Fields

Private FPlaying: Boolean;

This item has no description.

Private FSource: TGLBaseSoundSource;

used at design-time ONLY

Private FPlayingSource: TGLSoundSource;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Properties

Published property Playing: Boolean read GetPlaying write SetPlaying default False;

This item has no description.

Public property PlayingSource: TGLSoundSource read FPlayingSource;

This item has no description.

Published property Source: TGLBaseSoundSource read FSource write SetSource;


GLSysHelp v.2.5: GLS.Sounds.BASS

Unit GLS.Sounds.BASS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Vcl.Forms
  • GLS.Scene
  • GLS.SoundManager
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • BASS.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMBASS |

Types

TBASS3DAlgorithm = (...);

Description

Types

TBASS3DAlgorithm = (...);

This item has no description.

Values
  • algDefault
  • algOff
  • algFull
  • algLight


GLSysHelp v.2.5: GLS.Sounds.BASS: Class TGLSMBASS

Class TGLSMBASS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Sounds.BASS

Declaration

type TGLSMBASS = class(TGLSoundManager)

Description

This item has no description. Showing description inherited from TGLSoundManager.

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLSoundManager
  • TGLSMBASS

Overview

Fields

Private | FActivated: Boolean;
Private | FAlgorithm3D: TBASS3DAlgorithm;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CPUUsagePercent: Single; override;
Public | function EAXSupported: Boolean; override;
Public | procedure UpdateSources; override;

Properties

Published property Algorithm3D: TBASS3DAlgorithm read FAlgorithm3D write FAlgorithm3D default algDefault;

Description

Fields

Private FActivated: Boolean;

This item has no description.

Private FAlgorithm3D: TBASS3DAlgorithm;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CPUUsagePercent: Single; override;

This item has no description. Showing description inherited from TGLSoundManager.CPUUsagePercent.

Sound manager API reported CPU Usage. Returns -1 when unsupported.

Public function EAXSupported: Boolean; override;

This item has no description. Showing description inherited from TGLSoundManager.EAXSupported.

True if EAX is supported.

Public procedure UpdateSources; override;

This item has no description. Showing description inherited from TGLSoundManager.UpdateSources.

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.

Properties

Published property Algorithm3D: TBASS3DAlgorithm read FAlgorithm3D write FAlgorithm3D default algDefault;


GLSysHelp v.2.5: GLS.Sounds.FMOD

Unit GLS.Sounds.FMOD

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.SoundManager
  • GLS.Scene
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • FMOD.Import
  • FMOD.Types
  • FMOD.Presets

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMFMOD |


GLSysHelp v.2.5: GLS.Sounds.FMOD: Class TGLSMFMOD

Class TGLSMFMOD

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Sounds.FMOD

Declaration

type TGLSMFMOD = class(TGLSoundManager)

Description

This item has no description. Showing description inherited from TGLSoundManager.

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLSoundManager
  • TGLSMFMOD

Overview

Fields

Private | FActivated: Boolean;
Private | FEAXCapable: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CPUUsagePercent: Single; override;
Public | function EAXSupported: Boolean; override;
Public | procedure UpdateSources; override;

Properties

Published property MaxChannels default 32;

Description

Fields

Private FActivated: Boolean;

This item has no description.

Private FEAXCapable: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CPUUsagePercent: Single; override;

This item has no description. Showing description inherited from TGLSoundManager.CPUUsagePercent.

Sound manager API reported CPU Usage. Returns -1 when unsupported.

Public function EAXSupported: Boolean; override;

This item has no description. Showing description inherited from TGLSoundManager.EAXSupported.

True if EAX is supported.

Public procedure UpdateSources; override;

This item has no description. Showing description inherited from TGLSoundManager.UpdateSources.

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.

Properties

Published property MaxChannels default 32;

This item has no description. Showing description inherited from TGLSoundManager.MaxChannels.

Maximum number of sound output channels. While some drivers will just ignore this value, others cannot dynamically adjust the maximum number of channels (you need to de-activate and re-activate the manager for this property to be taken into account).


GLSysHelp v.2.5: GLS.Sounds.OpenAL

Unit GLS.Sounds.OpenAL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Vcl.Forms
  • Vcl.Dialogs
  • GLScene.VectorTypes
  • GLS.Scene
  • GLScene.VectorGeometry
  • GLS.Coordinates
  • GLS.SoundManager
  • GLS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMOpenAL |

Types

EOpenALError = Exception;

Description

Types

EOpenALError = Exception;


GLSysHelp v.2.5: GLS.Sounds.OpenAL: Class TGLSMOpenAL

Class TGLSMOpenAL

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Sounds.OpenAL

Declaration

type TGLSMOpenAL = class(TGLSoundManager)

Description

This item has no description. Showing description inherited from TGLSoundManager.

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLSoundManager
  • TGLSMOpenAL

Overview

Fields

Private FActivated: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function EAXSupported: Boolean; override;
Public | procedure UpdateSources; override;

Description

Fields

Private FActivated: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function EAXSupported: Boolean; override;

This item has no description. Showing description inherited from TGLSoundManager.EAXSupported.

True if EAX is supported.

Public procedure UpdateSources; override;

This item has no description. Showing description inherited from TGLSoundManager.UpdateSources.

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.


GLSysHelp v.2.5: GLS.Sounds.Register

Unit GLS.Sounds.Register

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLS.Sounds.BASS
  • GLS.Sounds.FMOD
  • GLS.Sounds.OpenAL
  • GLS.Sounds.WaveOut

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GLSysHelp v.2.5: GLS.Sounds.WaveOut

Unit GLS.Sounds.WaveOut

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.MMSystem
  • System.Classes
  • System.SysUtils
  • GLS.SoundManager
  • GLS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMWaveOut |

Functions and Procedures

procedure PlayOnWaveOut(pcmData: Pointer; lengthInBytes: Integer; sampling: TGLSoundSampling); overload;
function PlayOnWaveOut(pcmData: Pointer; lengthInBytes: Integer; waveFormat: TWaveFormatEx): HWaveOut; overload;

Description

Functions and Procedures

procedure PlayOnWaveOut(pcmData: Pointer; lengthInBytes: Integer; sampling: TGLSoundSampling); overload;

This item has no description.

function PlayOnWaveOut(pcmData: Pointer; lengthInBytes: Integer; waveFormat: TWaveFormatEx): HWaveOut; overload;


GLSysHelp v.2.5: GLS.Sounds.WaveOut: Class TGLSMWaveOut

Class TGLSMWaveOut

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Sounds.WaveOut

Declaration

type TGLSMWaveOut = class(TGLSoundManager)

Description

Basic sound manager based on WinMM waveOut function. This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality. Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).

Hierarchy

  • TGLCadenceAbleComponent
  • TGLSoundManager
  • TGLSMWaveOut

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure UpdateSources; override;

Properties

Published property MaxChannels default 4;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure UpdateSources; override;

This item has no description. Showing description inherited from TGLSoundManager.UpdateSources.

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.

Properties

Published property MaxChannels default 4;

This item has no description. Showing description inherited from TGLSoundManager.MaxChannels.

Maximum number of sound output channels. While some drivers will just ignore this value, others cannot dynamically adjust the maximum number of channels (you need to de-activate and re-activate the manager for this property to be taken into account).


GLSysHelp v.2.5: GLS.SpacePartition

Unit GLS.SpacePartition

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.Coordinates
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.GeometryBB
  • GLS.Context
  • GLS.RenderContextInfo
  • GLS.SceneViewer
  • GLS.PersistentClasses
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGLConeSP |
Record TGLExtendedFrustum |
Class TGLSpacePartitionLeaf |
Class TGLSpacePartitionLeafList |
Class TGLSpacePartitionLeafS |
Class TGLBaseSpacePartition |
Class TGLLeavedSpacePartition |
Class TGLSectorNode |
Class TGLSectoredSpacePartition |
Class TSPOctreeNode |
Class TGLOctreeSpacePartition |
Class TSPQuadtreeNode |
Class TGLQuadtreeSpacePartition |
Class TGLSceneObj |

Functions and Procedures

procedure RenderSpatialPartitioning(var rci: TGLRenderContextInfo; const Space: TGLSectoredSpacePartition);
function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const vWidth, vHeight: integer; AGLCamera: TGLCamera): TGLExtendedFrustum; overload;
function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const AGLSceneViewer: TGLSceneViewer): TGLExtendedFrustum; overload;
procedure RenderAABB(var rci: TGLRenderContextInfo; const AABB: TAABB; w, r, g, b: single); overload;
procedure RenderAABB(var rci: TGLRenderContextInfo; const AABB: TAABB); overload;
function ConeContainsBSphere(const Cone: TGLConeSP; const BSphere: TBSphere): TSpaceContains;
function ExtendedFrustumIntersectsBSphere(const AExtendedFrustum: TGLExtendedFrustum; const ABSphere: TBSphere): Boolean;
function ExtendedFrustumMake(const AFrustum: TFrustum; const ANearDist, AFarDist, AFieldOfViewRadians: Single; const ACameraPosition, ALookVector: TAffineVector ): TGLExtendedFrustum;

Types

TGLCullingMode = (...);
TGLGrowMethod = (...);
TGLSectorNodeArray = array [0 .. 7] of TGLSectorNode;

Constants

COctree_LEAF_TRHESHOLD = 30;
COctree_MAX_TREE_DEPTH = 8;
COctree_GROW_GRAVY = 0.1;

Description

Functions and Procedures

procedure RenderSpatialPartitioning(var rci: TGLRenderContextInfo; const Space: TGLSectoredSpacePartition);

Render a spacial partitioning descending from TGLSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation

function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const vWidth, vHeight: integer; AGLCamera: TGLCamera): TGLExtendedFrustum; overload;

Create an extended frustum from a GLSceneViewer - this makes the unit specific to the windows platform!

function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const AGLSceneViewer: TGLSceneViewer): TGLExtendedFrustum; overload;

This item has no description.

procedure RenderAABB(var rci: TGLRenderContextInfo; const AABB: TAABB; w, r, g, b: single); overload;

Renders an AABB as a line

procedure RenderAABB(var rci: TGLRenderContextInfo; const AABB: TAABB); overload;

This item has no description.

function ConeContainsBSphere(const Cone: TGLConeSP; const BSphere: TBSphere): TSpaceContains;

Determines to which extent one Cone contains an BSphere

function ExtendedFrustumIntersectsBSphere(const AExtendedFrustum: TGLExtendedFrustum; const ABSphere: TBSphere): Boolean;

Determines if a extended frustum intersects an BSphere

function ExtendedFrustumMake(const AFrustum: TFrustum; const ANearDist, AFarDist, AFieldOfViewRadians: Single; const ACameraPosition, ALookVector: TAffineVector ): TGLExtendedFrustum;

Create an extended frustum from a number of values

Types

TGLCullingMode = (...);

This item has no description.

Values
  • CmFineCulling
  • CmGrossCulling
TGLGrowMethod = (...);

This item has no description.

Values
  • gmNever
  • gmBestFit
  • gmIncreaseToFitAll
TGLSectorNodeArray = array [0 .. 7] of TGLSectorNode;

This item has no description.

Constants

COctree_LEAF_TRHESHOLD = 30;

This item has no description.

COctree_MAX_TREE_DEPTH = 8;

This item has no description.

COctree_GROW_GRAVY = 0.1;


GLSysHelp v.2.5: GLS.SpacePartition: Record TGLConeSP

Record TGLConeSP

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLConeSP = record

Description

Describes a cone, and is used for cone collision

Overview

Fields

Public | Base: TAffineVector;
Public | Axis: TAffineVector;
Public | Angle: Single;
Public | Length: Single;

Description

Fields

Public Base: TAffineVector;

The base of the cone

Public Axis: TAffineVector;

The axis of the cone

Public Angle: Single;

Angle of the cone

Public Length: Single;

Length of the cone


GLSysHelp v.2.5: GLS.SpacePartition: Record TGLExtendedFrustum

Record TGLExtendedFrustum

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLExtendedFrustum = record

Description

Extended frustum, used for fast intersection testing

Overview

Fields

Public | Frustum: TFrustum;
Public | BSphere: TBSphere;

Description

Fields

Public Frustum: TFrustum;

This item has no description.

Public BSphere: TBSphere;


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLSpacePartitionLeaf

Class TGLSpacePartitionLeaf

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLSpacePartitionLeaf = class(TGLPersistentObject)

Description

Used to store the actual objects in the SpacePartition

Hierarchy

  • TGLPersistentObject
  • TGLSpacePartitionLeaf

Overview

Fields

Private | FSpacePartition: TGLBaseSpacePartition;
Public | FPartitionTag: Pointer;
Public | FCachedAABB: TAABB;
Public | FCachedBSphere: TBSphere;

Methods

Public | constructor CreateOwned(SpacePartition: TGLBaseSpacePartition);
Public | destructor Destroy; override;
Public | procedure Changed; virtual;
Public | procedure UpdateCachedAABBAndBSphere; virtual;
Private | procedure SetSpacePartition(const Value: TGLBaseSpacePartition);

Properties

Public | property PartitionTag: Pointer read FPartitionTag;
Public | property SpacePartition: TGLBaseSpacePartition read FSpacePartition write SetSpacePartition;

Description

Fields

Private FSpacePartition: TGLBaseSpacePartition;

This item has no description.

Public FPartitionTag: Pointer;

This can be used by the space partitioner as it sees fit

Public FCachedAABB: TAABB;

Leaves cache their AABBs so they can be accessed when needed by the space partitioner

Public FCachedBSphere: TBSphere;

Leaves cache their BoundingSpheres so they can easily be accessed when needed by the space partitioner

Methods

Public constructor CreateOwned(SpacePartition: TGLBaseSpacePartition);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Changed; virtual;

Whenever the size or location of the leaf changes, the space partitioner should be notified through a call to Changed. In the basic version, all it does is update the cached AABB and BSphere. You do not need to override this method

Public procedure UpdateCachedAABBAndBSphere; virtual;

AABBs and BSpheres are cached for leafs, and this function should be overriden to update the cache from the structure that the leaf stores. This is the only function you MUST override to use space partitions.

Private procedure SetSpacePartition(const Value: TGLBaseSpacePartition);

This item has no description.

Properties

Public property PartitionTag: Pointer read FPartitionTag;

This tag can be used by the space partition to store vital information in the leaf

Public property SpacePartition: TGLBaseSpacePartition read FSpacePartition write SetSpacePartition;

The TGLBaseSpacePartition that owns this leaf


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLSpacePartitionLeafList

Class TGLSpacePartitionLeafList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLSpacePartitionLeafList = class(TGLPersistentObjectList)

Description

List for storing space partition leaves

Hierarchy

  • TGLPersistentObjectList
  • TGLSpacePartitionLeafList

Overview

Methods

Public | constructor Create; override;
Private | function GetItems(I: Integer): TGLSpacePartitionLeaf;
Private | procedure SetItems(I: Integer; const Value: TGLSpacePartitionLeaf);

Properties

Public property Items[I: Integer]: TGLSpacePartitionLeaf read GetItems write SetItems;

Description

Methods

Public constructor Create; override;

This item has no description.

Private function GetItems(I: Integer): TGLSpacePartitionLeaf;

This item has no description.

Private procedure SetItems(I: Integer; const Value: TGLSpacePartitionLeaf);

This item has no description.

Properties

Public property Items[I: Integer]: TGLSpacePartitionLeaf read GetItems write SetItems;


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLSpacePartitionLeafS

Class TGLSpacePartitionLeafS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLSpacePartitionLeafS = class(TGLSpacePartitionLeaf)

Description

The Space Partition updating for a bounding sphere

Hierarchy

  • TGLPersistentObject
  • TGLSpacePartitionLeaf
  • TGLSpacePartitionLeafS

Overview

Fields

Public | GLBaseSceneObject: TGLBaseSceneObject;
Public | Direction: TAffineVector;

Methods

Public | constructor CreateGLOwned(SpacePartition: TGLBaseSpacePartition; aGLBaseSceneObject: TGLBaseSceneObject);
Public | procedure UpdateCachedAABBAndBSphere; override;

Description

Fields

Public GLBaseSceneObject: TGLBaseSceneObject;

This item has no description.

Public Direction: TAffineVector;

This item has no description.

Methods

Public constructor CreateGLOwned(SpacePartition: TGLBaseSpacePartition; aGLBaseSceneObject: TGLBaseSceneObject);

This item has no description.

Public procedure UpdateCachedAABBAndBSphere; override;

This item has no description. Showing description inherited from TGLSpacePartitionLeaf.UpdateCachedAABBAndBSphere.

AABBs and BSpheres are cached for leafs, and this function should be overriden to update the cache from the structure that the leaf stores. This is the only function you MUST override to use space partitions.


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLBaseSpacePartition

Class TGLBaseSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLBaseSpacePartition = class(TGLPersistentObject)

Description

Basic space partition, does not implement any actual space partitioning

Hierarchy

  • TGLPersistentObject
  • TGLBaseSpacePartition

Overview

Fields

Private FCullingMode: TGLCullingMode;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function QueryAABB(const AAABB: TAABB): Integer; virtual;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; virtual;
Public | function QueryFrustum(const Frustum: TFrustum): Integer; virtual;
Public | function QueryFrustumEx(const ExtendedFrustum: TGLExtendedFrustum): Integer; virtual;
Public | function QueryLeaf(const ALeaf: TGLSpacePartitionLeaf): Integer; virtual;
Public | function QueryPlane(const Location, Normal: TAffineVector): Integer; virtual;
Private | function QueryCone(const ACone: TGLConeSP): Integer; virtual;
Public | procedure AddLeaf(ALeaf: TGLSpacePartitionLeaf); virtual;
Public | procedure Clear; virtual;
Public | procedure LeafChanged(ALeaf: TGLSpacePartitionLeaf); virtual;
Public | procedure ProcessUpdated; virtual;
Public | procedure RemoveLeaf(ALeaf: TGLSpacePartitionLeaf); virtual;

Properties

Public | property CullingMode: TGLCullingMode read FCullingMode write FCullingMode;
Public | property QueryInterObjectTests: Integer read FQueryInterObjectTests;
Public | property QueryResult: TGLSpacePartitionLeafList read FQueryResult;

Description

Fields

Private FCullingMode: TGLCullingMode;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function QueryAABB(const AAABB: TAABB): Integer; virtual;

Query space for Leaves that intersect the axis aligned bounding box, result is returned through QueryResult

Public function QueryBSphere(const ABSphere: TBSphere): Integer; virtual;

Query space for Leaves that intersect the bounding sphere, result is returned through QueryResult

Public function QueryFrustum(const Frustum: TFrustum): Integer; virtual;

Query space for Leaves that intersect a Frustum. Result is returned through QueryResult

Public function QueryFrustumEx(const ExtendedFrustum: TGLExtendedFrustum): Integer; virtual;

Query space for Leaves that intersect an extended frustum. Result is returned through QueryResult. Extended frustum is slightly faster than the regular frustum because it uses a bounding sphere for the frustum

Public function QueryLeaf(const ALeaf: TGLSpacePartitionLeaf): Integer; virtual;

Query space for Leaves that intersect the bounding sphere or box of a leaf. Result is returned through QueryResult

Public function QueryPlane(const Location, Normal: TAffineVector): Integer; virtual;

Query space for Leaves that intersect a plane. Result is returned through QueryResult

Private function QueryCone(const ACone: TGLConeSP): Integer; virtual;

Query space for Leaves that intersect a cone, result is returned through QueryResult

Public procedure AddLeaf(ALeaf: TGLSpacePartitionLeaf); virtual;

** Update space partition Add a leaf

Public procedure Clear; virtual;

Clear all internal storage Leaves

Public procedure LeafChanged(ALeaf: TGLSpacePartitionLeaf); virtual;

Called by leaf when it has changed

Public procedure ProcessUpdated; virtual;

Some space partitioners delay processing changes until all changes have been made. ProcessUpdated should be called when all changes have been performed

Public procedure RemoveLeaf(ALeaf: TGLSpacePartitionLeaf); virtual;

Remove a leaf

Properties

Public property CullingMode: TGLCullingMode read FCullingMode write FCullingMode;

Determines if the spatial structure should do very simple preliminary culling (gross culling) or a more detailed form of culling (fine culling)

Public property QueryInterObjectTests: Integer read FQueryInterObjectTests;

Once a query has been run, this number tells of how many inter object tests that were run. This value must be set by all that override the queries

Public property QueryResult: TGLSpacePartitionLeafList read FQueryResult;

The results from the last query


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLLeavedSpacePartition

Class TGLLeavedSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLLeavedSpacePartition = class(TGLBaseSpacePartition)

Description

Implements a list of all leaves added to the space partition, _not_ a good solution, but it can be used as a benchmark against more complex methods

Hierarchy

  • TGLPersistentObject
  • TGLBaseSpacePartition
  • TGLLeavedSpacePartition

Overview

Fields

Private FLeaves: TGLSpacePartitionLeafList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function QueryAABB(const AAABB: TAABB): Integer; override;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; override;
Public | function QueryPlane(const FLocation, FNormal: TAffineVector): Integer; override;
Private | function QueryCone(const ACone: TGLConeSP): Integer; override;
Public | procedure AddLeaf(ALeaf: TGLSpacePartitionLeaf); override;
Public | procedure Clear; override;
Public | procedure RemoveLeaf(ALeaf: TGLSpacePartitionLeaf); override;

Properties

Published property Leaves: TGLSpacePartitionLeafList read FLeaves;

Description

Fields

Private FLeaves: TGLSpacePartitionLeafList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function QueryAABB(const AAABB: TAABB): Integer; override;

Query space for Leaves that intersect the axis aligned bounding box, result is returned through QueryResult. This override scans _all_ leaves in the list, so it's far from optimal

Public function QueryBSphere(const ABSphere: TBSphere): Integer; override;

Query space for Leaves that intersect the bounding sphere, result is returned through QueryResult. This override scans _all_ leaves in the list, so it's far from optimal

Public function QueryPlane(const FLocation, FNormal: TAffineVector): Integer; override;

Query space for Leaves that intersect a plane. Result is returned through QueryResult

Private function QueryCone(const ACone: TGLConeSP): Integer; override;

Query space for Leaves that intersect a cone, result is returned through QueryResult

Public procedure AddLeaf(ALeaf: TGLSpacePartitionLeaf); override;

** Update space partition Add a leaf

Public procedure Clear; override;

Clear all internal storage Leaves

Public procedure RemoveLeaf(ALeaf: TGLSpacePartitionLeaf); override;

Remove a leaf

Properties

Published property Leaves: TGLSpacePartitionLeafList read FLeaves;


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLSectorNode

Class TGLSectorNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLSectorNode = class(TObject)

Description

Implements a SectorNode node. Each node can have 0 or 8 children, each child being a portion of the size of the parent. For quadtrees, that's 1/4, for octrees, it's 1/8

Hierarchy

  • TObject
  • TGLSectorNode

Overview

Fields

Private | FLeaves: TGLSpacePartitionLeafList;
Private | FAABB: TAABB;
Private | FSectoredSpacePartition: TGLSectoredSpacePartition;
Private | FRecursiveLeafCount: Integer;
Private | FParent: TGLSectorNode;
Private | FNodeDepth: Integer;
Private | FChildCount: Integer;
Private | FChildren: TGLSectorNodeArray;
Private | FBSphere: TBSphere;

Methods

Public | constructor Create(ASectoredSpacePartition: TGLSectoredSpacePartition; AParent: TGLSectorNode);
Public | destructor Destroy; override;
Public | function AABBContainsSector(const AABB: TAABB): TSpaceContains; virtual;
Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; virtual;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; virtual;
Public | function AddLeaf(ALeaf: TGLSpacePartitionLeaf): TGLSectorNode;
Public | function BSphereContainsSector(const BSphere: TBSphere): TSpaceContains; virtual;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; virtual;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; virtual;
Public | function ContainsAABB(const AAABB: TAABB): TSpaceContains; virtual;
Public | function ContainsBSphere(const ABSphere: TBSphere): TSpaceContains; virtual;
Public | function GetChildForAABB(const AABB: TAABB): TGLSectorNode; virtual;
Public | function GetNodeCount: Integer;
Public | function RemoveLeaf(ALeaf: TGLSpacePartitionLeaf; OwnerByThis: Boolean): Boolean;
Private | function GetCenter: TAffineVector;
Private | function GetNoChildren: Boolean;
Public | procedure AddAllLeavesRecursive(const QueryResult: TGLSpacePartitionLeafList);
Public | procedure Clear;
Public | procedure CollapseNode;
Public | procedure CreateChildren; virtual;
Public | procedure ExpandNode;
Public | procedure QueryAABB(const AAABB: TAABB; const QueryResult: TGLSpacePartitionLeafList);
Public | procedure QueryBSphere(const ABSphere: TBSphere; const QueryResult: TGLSpacePartitionLeafList);
Public | procedure QueryFrustum(const Frustum: TFrustum; const QueryResult: TGLSpacePartitionLeafList);
Public | procedure QueryFrustumEx(const ExtendedFrustum: TGLExtendedFrustum; const QueryResult: TGLSpacePartitionLeafList);
Public | procedure QueryPlane(const Location, Normal: TAffineVector; const QueryResult: TGLSpacePartitionLeafList);
Private | procedure SetAABB(const Value: TAABB);

Properties

Public | property AABB: TAABB read FAABB write SetAABB;
Public | property BSphere: TBSphere read FBSphere;
Public | property Center: TAffineVector read GetCenter;
Public | property ChildCount: Integer read FChildCount;
Public | property Children: TGLSectorNodeArray read FChildren;
Public | property Leaves: TGLSpacePartitionLeafList read FLeaves;
Public | property NoChildren: Boolean read GetNoChildren;
Public | property NodeDepth: Integer read FNodeDepth;
Public | property Parent: TGLSectorNode read FParent;
Public | property RecursiveLeafCount: Integer read FRecursiveLeafCount;
Public | property SectoredSpacePartition: TGLSectoredSpacePartition read FSectoredSpacePartition;

Description

Fields

Private FLeaves: TGLSpacePartitionLeafList;

This item has no description.

Private FAABB: TAABB;

This item has no description.

Private FSectoredSpacePartition: TGLSectoredSpacePartition;

This item has no description.

Private FRecursiveLeafCount: Integer;

This item has no description.

Private FParent: TGLSectorNode;

This item has no description.

Private FNodeDepth: Integer;

This item has no description.

Private FChildCount: Integer;

This item has no description.

Private FChildren: TGLSectorNodeArray;

This item has no description.

Private FBSphere: TBSphere;

This item has no description.

Methods

Public constructor Create(ASectoredSpacePartition: TGLSectoredSpacePartition; AParent: TGLSectorNode);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AABBContainsSector(const AABB: TAABB): TSpaceContains; virtual;

Checks if a AABB partially or completely contains this sector

Public function AABBFitsInNode(const AAABB: TAABB): Boolean; virtual;

Checks if an AABB fits completely inside this node

Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; virtual;

Checks if an AABB intersects this node

Public function AddLeaf(ALeaf: TGLSpacePartitionLeaf): TGLSectorNode;

Adds leaf to this node - or one of it's children. If the node has enough leaves and has no children, children will be created and all leaves will be spread among the children

Public function BSphereContainsSector(const BSphere: TBSphere): TSpaceContains; virtual;

Checks if a BSphere partially or completely contains this sector

Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; virtual;

Checks if a BSphere fits completely inside this node

Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; virtual;

Checks if a BSphere intersects this node

Public function ContainsAABB(const AAABB: TAABB): TSpaceContains; virtual;

Checks if this node partially or completely contains an AABB

Public function ContainsBSphere(const ABSphere: TBSphere): TSpaceContains; virtual;

Checks if this node partially or completely contains a BSphere

Public function GetChildForAABB(const AABB: TAABB): TGLSectorNode; virtual;

Computes which child the AABB should go in. Returns nil if no such child exists

Public function GetNodeCount: Integer;

Returns the number of nodes in the Octree

Public function RemoveLeaf(ALeaf: TGLSpacePartitionLeaf; OwnerByThis: Boolean): Boolean;

Remove leaf will remove a leaf from this node. If it is determined that this node has too few leaves after the delete, it may be collapsed. Returns true if the node was actually collapsed

Private function GetCenter: TAffineVector;

This item has no description.

Private function GetNoChildren: Boolean;

This item has no description.

Public procedure AddAllLeavesRecursive(const QueryResult: TGLSpacePartitionLeafList);

Adds all leaves to query result without testing if they intersect, and then do the same for all children. This is used when QueryAABB or QueryBSphere determines that a node fits completely in the searched space

Public procedure Clear;

Clear deletes all children and empties the leaves. It doesn't destroy the leaves, as they belong to the SpacePartition

Public procedure CollapseNode;

Delete all children for this node, adding their leaves to this node

Public procedure CreateChildren; virtual;

Create the number of children this node type needs

Public procedure ExpandNode;

Add children to this node and spread the leaves among it's children

Public procedure QueryAABB(const AAABB: TAABB; const QueryResult: TGLSpacePartitionLeafList);

Query the node and its children for leaves that match the AABB

Public procedure QueryBSphere(const ABSphere: TBSphere; const QueryResult: TGLSpacePartitionLeafList);

Query the node and its children for leaves that match the BSphere

Public procedure QueryFrustum(const Frustum: TFrustum; const QueryResult: TGLSpacePartitionLeafList);

Query the node and its children for leaves that match the Frustum

Public procedure QueryFrustumEx(const ExtendedFrustum: TGLExtendedFrustum; const QueryResult: TGLSpacePartitionLeafList);

Query the node and its children for leaves that match the extended frustum

Public procedure QueryPlane(const Location, Normal: TAffineVector; const QueryResult: TGLSpacePartitionLeafList);

Query the node and its children for leaves that match the plane

Private procedure SetAABB(const Value: TAABB);

This item has no description.

Properties

Public property AABB: TAABB read FAABB write SetAABB;

The Axis Aligned Bounding Box for this node. All leaves MUST fit inside this box

Public property BSphere: TBSphere read FBSphere;

BSphere for this node

Public property Center: TAffineVector read GetCenter;

Center of the AABB for this node

Public property ChildCount: Integer read FChildCount;

The number of child sectors that have been created

Public property Children: TGLSectorNodeArray read FChildren;

A list of the children for this node, only ChildCount children are none nil

Public property Leaves: TGLSpacePartitionLeafList read FLeaves;

The leaves that are stored in this node

Public property NoChildren: Boolean read GetNoChildren;

NoChildren is true if the node has no children

Public property NodeDepth: Integer read FNodeDepth;

The tree depth at which this node is located. For the root, this value is 0, for the roots children, it is 1 and so on

Public property Parent: TGLSectorNode read FParent;

The parent node of this node. If parent is nil, that means that this node is the root node

Public property RecursiveLeafCount: Integer read FRecursiveLeafCount;

The number of leaves stored in this node and all it's children

Public property SectoredSpacePartition: TGLSectoredSpacePartition read FSectoredSpacePartition;

The Structure that owns this node


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLSectoredSpacePartition

Class TGLSectoredSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLSectoredSpacePartition = class(TGLLeavedSpacePartition)

Description

Implements sectored space partitioning, sectored space partitions include Octrees, Quadtrees and BSP-trees

Hierarchy

  • TGLPersistentObject
  • TGLBaseSpacePartition
  • TGLLeavedSpacePartition
  • TGLSectoredSpacePartition

Overview

Fields

Private | FRootNode: TGLSectorNode;
Private | FLeafThreshold: Integer;
Private | FMaxTreeDepth: Integer;
Private | FGrowGravy: Single;
Private | FGrowMethod: TGLGrowMethod;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function CreateNewNode(AParent: TGLSectorNode): TGLSectorNode; virtual;
Public | function GetAABB: TAABB;
Public | function GetNodeCount: Integer;
Public | function QueryAABB(const AAABB: TAABB): Integer; override;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; override;
Public | function QueryFrustum(const Frustum: TFrustum): Integer; override;
Public | function QueryFrustumEx(const ExtendedFrustum: TGLExtendedFrustum): Integer; override;
Public | function QueryLeaf(const ALeaf: TGLSpacePartitionLeaf): Integer; override;
Public | function QueryPlane(const Location, Normal: TAffineVector): Integer; override;
Public | procedure AddLeaf(ALeaf: TGLSpacePartitionLeaf); override;
Public | procedure Clear; override;
Public | procedure LeafChanged(ALeaf: TGLSpacePartitionLeaf); override;
Public | procedure RebuildTree(const NewAABB: TAABB);
Public | procedure RemoveLeaf(ALeaf: TGLSpacePartitionLeaf); override;
Public | procedure UpdateStructureSize(Gravy: Single);
Private | procedure SetLeafThreshold(const Value: Integer);
Private | procedure SetMaxTreeDepth(const Value: Integer);

Properties

Published | property GrowGravy: Single read FGrowGravy write FGrowGravy;
Published | property GrowMethod: TGLGrowMethod read FGrowMethod write FGrowMethod;
Published | property LeafThreshold: Integer read FLeafThreshold write SetLeafThreshold;
Published | property MaxTreeDepth: Integer read FMaxTreeDepth write SetMaxTreeDepth;
Public | property QueryNodeTests: Integer read FQueryNodeTests;
Published | property RootNode: TGLSectorNode read FRootNode;

Description

Fields

Private FRootNode: TGLSectorNode;

This item has no description.

Private FLeafThreshold: Integer;

This item has no description.

Private FMaxTreeDepth: Integer;

This item has no description.

Private FGrowGravy: Single;

This item has no description.

Private FGrowMethod: TGLGrowMethod;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateNewNode(AParent: TGLSectorNode): TGLSectorNode; virtual;

CreateNewNode creates a new node of the TGLSectorNode subclass that this structure requires

Public function GetAABB: TAABB;

Returns the _total_ AABB in structure

Public function GetNodeCount: Integer;

Returns the number of nodes in the structure

Public function QueryAABB(const AAABB: TAABB): Integer; override;

Query space for Leaves that intersect the axis aligned bounding box, result is returned through QueryResult. This method simply defers to the QueryAABB method of the root node

Public function QueryBSphere(const ABSphere: TBSphere): Integer; override;

Query space for Leaves that intersect the bounding sphere, result is returned through QueryResult. This method simply defers to the QueryBSphere method of the root node

Public function QueryFrustum(const Frustum: TFrustum): Integer; override;

Query space for Leaves that intersect a Frustum. Result is returned through QueryResult

Public function QueryFrustumEx(const ExtendedFrustum: TGLExtendedFrustum): Integer; override;

Query space for Leaves that intersect an extended frustum. Result is returned through QueryResult

Public function QueryLeaf(const ALeaf: TGLSpacePartitionLeaf): Integer; override;

Query space for Leaves that intersect the bounding sphere or box of a leaf. Result is returned through QueryResult

Public function QueryPlane(const Location, Normal: TAffineVector): Integer; override;

Query space for Leaves that intersect a plane. Result is returned through QueryResult

Public procedure AddLeaf(ALeaf: TGLSpacePartitionLeaf); override;

Add a leaf to the structure. If the leaf doesn't fit in the structure, the structure is either grown or an exception is raised. If GrowMethod is set to gmBestFit or gmIncreaseToFitAll, the octree will be grown

Public procedure Clear; override;

This item has no description. Showing description inherited from TGLLeavedSpacePartition.Clear.

Clear all internal storage Leaves

Public procedure LeafChanged(ALeaf: TGLSpacePartitionLeaf); override;

Called by leaf when it has changed, the leaf will be moved to an apropriate node

Public procedure RebuildTree(const NewAABB: TAABB);

Rebuild tree will change the tree to the newAABB size, and completely rebuild it

Public procedure RemoveLeaf(ALeaf: TGLSpacePartitionLeaf); override;

Remove a leaf from the structure

Public procedure UpdateStructureSize(Gravy: Single);

UpdateOctreeSize will grow and / or shrink the structure to fit the current leaves +-gravy

Private procedure SetLeafThreshold(const Value: Integer);

This item has no description.

Private procedure SetMaxTreeDepth(const Value: Integer);

This item has no description.

Properties

Published property GrowGravy: Single read FGrowGravy write FGrowGravy;

When the structure is recreated because it's no longer large enough to fit all leafs, it will become large enough to safely fit all leafs, plus GrowGravy. This is to prevent too many grows

Published property GrowMethod: TGLGrowMethod read FGrowMethod write FGrowMethod;

Determines if the structure should grow with new leaves, or if an exception should be raised

Published property LeafThreshold: Integer read FLeafThreshold write SetLeafThreshold;

Determines when a node should be split up to form children

Published property MaxTreeDepth: Integer read FMaxTreeDepth write SetMaxTreeDepth;

Determines how deep a tree should be allowed to grow

Public property QueryNodeTests: Integer read FQueryNodeTests;

After a query has been run, this value will contain the number of nodes that were checked during the query

Published property RootNode: TGLSectorNode read FRootNode;

Root TGLSectorNode that all others stem from


GLSysHelp v.2.5: GLS.SpacePartition: Class TSPOctreeNode

Class TSPOctreeNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TSPOctreeNode = class(TGLSectorNode)

Description

** OCTTREE Implements sector node that handles octrees

Hierarchy

  • TObject
  • TGLSectorNode
  • TSPOctreeNode

Overview

Methods

Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; override;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;
Public | procedure CreateChildren; override;

Description

Methods

Public function AABBFitsInNode(const AAABB: TAABB): Boolean; override;

Checks if an AABB fits completely inside this node

Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;

Checks if an AABB intersects this node

Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;

Checks if a BSphere fits completely inside this node

Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;

Checks if a BSphere intersects this node

Public procedure CreateChildren; override;

Create 8 TSPOctreeNode children


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLOctreeSpacePartition

Class TGLOctreeSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLOctreeSpacePartition = class(TGLSectoredSpacePartition)

Description

Implements octrees

Hierarchy

  • TGLPersistentObject
  • TGLBaseSpacePartition
  • TGLLeavedSpacePartition
  • TGLSectoredSpacePartition
  • TGLOctreeSpacePartition

Overview

Methods

Public | function CreateNewNode(AParent: TGLSectorNode): TGLSectorNode; override;
Public | procedure SetSize(const Min, Max: TAffineVector);

Description

Methods

Public function CreateNewNode(AParent: TGLSectorNode): TGLSectorNode; override;

CreateNewNode creates a new TSPOctreeNode

Public procedure SetSize(const Min, Max: TAffineVector);

Set size updates the size of the Octree


GLSysHelp v.2.5: GLS.SpacePartition: Class TSPQuadtreeNode

Class TSPQuadtreeNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TSPQuadtreeNode = class(TSPOctreeNode)

Description

** QUADTREE Implements sector node that handles quadtrees

Hierarchy

  • TObject
  • TGLSectorNode
  • TSPOctreeNode
  • TSPQuadtreeNode

Overview

Methods

Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; override;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;
Public | function GetChildForAABB(const AABB: TAABB): TGLSectorNode; override;
Public | procedure CreateChildren; override;

Description

Methods

Public function AABBFitsInNode(const AAABB: TAABB): Boolean; override;

Checks if an AABB fits completely inside this node

Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;

Checks if an AABB intersects this node

Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;

Checks if a BSphere fits completely inside this node

Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;

Checks if a BSphere intersects this node

Public function GetChildForAABB(const AABB: TAABB): TGLSectorNode; override;

Computes which child the AABB should go in. Returns nil if no such child exists

Public procedure CreateChildren; override;

Create 4 TSPQuadtreeNode children


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLQuadtreeSpacePartition

Class TGLQuadtreeSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLQuadtreeSpacePartition = class(TGLSectoredSpacePartition)

Description

Implements quadtrees. Quadtrees are hardcoded to completely ignore the Y axis, only using X and Z to determine positioning. This means that they're well suited for 2d-ish situations (landscapes with trees for instance) but not for fully 3d situations (space fighting)

Hierarchy

  • TGLPersistentObject
  • TGLBaseSpacePartition
  • TGLLeavedSpacePartition
  • TGLSectoredSpacePartition
  • TGLQuadtreeSpacePartition

Overview

Methods

Public | function CreateNewNode(AParent: TGLSectorNode): TGLSectorNode; override;
Public | procedure SetSize(const Min, Max: TAffineVector);

Description

Methods

Public function CreateNewNode(AParent: TGLSectorNode): TGLSectorNode; override;

CreateNewNode creates a new TSPOctreeNode

Public procedure SetSize(const Min, Max: TAffineVector);

Set size updates the size of the Octree


GLSysHelp v.2.5: GLS.SpacePartition: Class TGLSceneObj

Class TGLSceneObj

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpacePartition

Declaration

type TGLSceneObj = class(TGLSpacePartitionLeaf)

Description

Object for holding glscene objects in a spatial partitioning

Hierarchy

  • TGLPersistentObject
  • TGLSpacePartitionLeaf
  • TGLSceneObj

Overview

Fields

Public Obj: TGLBaseSceneObject;

Methods

Public | constructor CreateObj(Owner: TGLSectoredSpacePartition; aObj: TGLBaseSceneObject);
Public | destructor Destroy; override;
Public | procedure UpdateCachedAABBAndBSphere; override;

Description

Fields

Public Obj: TGLBaseSceneObject;

This item has no description.

Methods

Public constructor CreateObj(Owner: TGLSectoredSpacePartition; aObj: TGLBaseSceneObject);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure UpdateCachedAABBAndBSphere; override;

This item has no description. Showing description inherited from TGLSpacePartitionLeaf.UpdateCachedAABBAndBSphere.

AABBs and BSpheres are cached for leafs, and this function should be overriden to update the cache from the structure that the leaf stores. This is the only function you MUST override to use space partitions.


GLSysHelp v.2.5: GLS.SpaceText

Unit GLS.SpaceText

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • WinApi.Windows
  • WinApi.Messages
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • System.Types
  • VCL.Dialogs
  • VCL.Graphics
  • VCL.Controls
  • GLScene.VectorTypes
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.Texture
  • GLS.Context
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLS.RenderContextInfo
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextAdjust |
Record TFontEntry |
Class TGLSpaceText |
Class TFontManager |

Functions and Procedures

function FontManager: TFontManager;
procedure ReleaseFontManager;

Types

PFontEntry = ˆTFontEntry;
TGLSpaceTextCharRange = (...);
TGLTextHorzAdjust = (...);
TGLTextVertAdjust = (...);

Variables

vFontManagerMsgID: Cardinal;

Description

Functions and Procedures

function FontManager: TFontManager;

This item has no description.

procedure ReleaseFontManager;

This item has no description.

Types

PFontEntry = ˆTFontEntry;

holds an entry in the font manager list (used in TGLSpaceText)

TGLSpaceTextCharRange = (...);

This item has no description.

Values
  • stcrDefault
  • stcrAlphaNum
  • stcrNumbers
  • stcrWide
TGLTextHorzAdjust = (...);

Note: haAligned, haCentrically, haFitIn have not been implemented!

Values
  • haLeft
  • haCenter
  • haRight
  • haAligned
  • haCentrically
  • haFitIn
TGLTextVertAdjust = (...);

This item has no description.

Values
  • vaTop
  • vaCenter
  • vaBottom
  • vaBaseLine

Variables

vFontManagerMsgID: Cardinal;


GLSysHelp v.2.5: GLS.SpaceText: Class TGLTextAdjust

Class TGLTextAdjust

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpaceText

Declaration

type TGLTextAdjust = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLTextAdjust

Overview

Fields

Private | FHorz: TGLTextHorzAdjust;
Private | FVert: TGLTextVertAdjust;
Private | FOnChange: TNotifyEvent;

Methods

Public | constructor Create;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetHorz(const Value: TGLTextHorzAdjust);
Private | procedure SetVert(const Value: TGLTextVertAdjust);

Properties

Published | property Horz: TGLTextHorzAdjust read FHorz write SetHorz default haLeft;
Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property Vert: TGLTextVertAdjust read FVert write SetVert default vaBaseLine;

Description

Fields

Private FHorz: TGLTextHorzAdjust;

This item has no description.

Private FVert: TGLTextVertAdjust;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetHorz(const Value: TGLTextHorzAdjust);

This item has no description.

Private procedure SetVert(const Value: TGLTextVertAdjust);

This item has no description.

Properties

Published property Horz: TGLTextHorzAdjust read FHorz write SetHorz default haLeft;

This item has no description.

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;

This item has no description.

Published property Vert: TGLTextVertAdjust read FVert write SetVert default vaBaseLine;


GLSysHelp v.2.5: GLS.SpaceText: Record TFontEntry

Record TFontEntry

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpaceText

Declaration

type TFontEntry = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | FVirtualHandle: TGLVirtualHandleTransf;
Public | Styles: TFontStyles;
Public | Extrusion: Single;
Public | RefCount: Integer;
Public | allowedDeviation: Single;
Public | firstChar: Integer;
Public | lastChar: Integer;
Public | glyphMetrics: array of TGlyphMetricsFloat;
Public | FClients: TList;

Description

Fields

Public Name: string;

This item has no description.

Public FVirtualHandle: TGLVirtualHandleTransf;

This item has no description.

Public Styles: TFontStyles;

This item has no description.

Public Extrusion: Single;

This item has no description.

Public RefCount: Integer;

This item has no description.

Public allowedDeviation: Single;

This item has no description.

Public firstChar: Integer;

This item has no description.

Public lastChar: Integer;

This item has no description.

Public glyphMetrics: array of TGlyphMetricsFloat;

This item has no description.

Public FClients: TList;


GLSysHelp v.2.5: GLS.SpaceText: Class TGLSpaceText

Class TGLSpaceText

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpaceText

Declaration

type TGLSpaceText = class(TGLSceneObject)

Description

Renders a text in 3D.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSpaceText

Overview

Fields

Private | FFont: TFont;
Private | FExtrusion: Single;
Private | FAllowedDeviation: Single;
Private | FCharacterRange: TGLSpaceTextCharRange;
Private | FAdjust: TGLTextAdjust;
Private | FAspectRatio: Single;
Private | FOblique: Single;
Private | FTextHeight: Single;
Private | FLines: TStringList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function BarycenterAbsolutePosition: TGLVector; override;
Public | function TextMaxHeight(const str: WideString = ''): Single;
Public | function TextMaxUnder(const str: WideString = ''): Single;
Public | function TextWidth(const str: WideString = ''): Single;
Private | function GetText: WideString;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DefaultHandler(var Message); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure NotifyChange(sender: TObject); override;
Public | procedure NotifyFontChanged;
Public | procedure TextMetrics(const str: WideString; out width, maxHeight, maxUnder: Single);
Private | procedure SetAdjust(const Value: TGLTextAdjust);
Private | procedure SetAllowedDeviation(const val: Single);
Private | procedure SetAspectRatio(const Value: Single);
Private | procedure SetCharacterRange(const val: TGLSpaceTextCharRange);
Private | procedure SetExtrusion(AValue: Single);
Private | procedure SetFont(AFont: TFont);
Private | procedure SetLines(const Value: TStringList);
Private | procedure SetOblique(const Value: Single);
Private | procedure SetText(const AText: WideString);
Private | procedure SetTextHeight(const Value: Single);

Properties

Published | property Adjust: TGLTextAdjust read FAdjust write SetAdjust;
Published | property allowedDeviation: Single read FAllowedDeviation write SetAllowedDeviation;
Published | property AspectRatio: Single read FAspectRatio write SetAspectRatio;
Published | property CharacterRange: TGLSpaceTextCharRange read FCharacterRange write SetCharacterRange default stcrDefault;
Published | property Extrusion: Single read FExtrusion write SetExtrusion;
Published | property Font: TFont read FFont write SetFont;
Published | property Lines: TStringList read FLines write SetLines;
Published | property Oblique: Single read FOblique write SetOblique;
Published | property Text: WideString read GetText write SetText stored False;
Published | property TextHeight: Single read FTextHeight write SetTextHeight;

Description

Fields

Private FFont: TFont;

This item has no description.

Private FExtrusion: Single;

This item has no description.

Private FAllowedDeviation: Single;

This item has no description.

Private FCharacterRange: TGLSpaceTextCharRange;

This item has no description.

Private FAdjust: TGLTextAdjust;

This item has no description.

Private FAspectRatio: Single;

This item has no description.

Private FOblique: Single;

This item has no description.

Private FTextHeight: Single;

This item has no description.

Private FLines: TStringList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function BarycenterAbsolutePosition: TGLVector; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function TextMaxHeight(const str: WideString = ''): Single;

This item has no description.

Public function TextMaxUnder(const str: WideString = ''): Single;

This item has no description.

Public function TextWidth(const str: WideString = ''): Single;

This item has no description.

Private function GetText: WideString;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DefaultHandler(var Message); override;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure NotifyChange(sender: TObject); override;

This item has no description.

Public procedure NotifyFontChanged;

This item has no description.

Public procedure TextMetrics(const str: WideString; out width, maxHeight, maxUnder: Single);

Note: this fuction is valid only after text has been rendered the first time. Before that it returns zeros.

Private procedure SetAdjust(const Value: TGLTextAdjust);

This item has no description.

Private procedure SetAllowedDeviation(const val: Single);

This item has no description.

Private procedure SetAspectRatio(const Value: Single);

This item has no description.

Private procedure SetCharacterRange(const val: TGLSpaceTextCharRange);

This item has no description.

Private procedure SetExtrusion(AValue: Single);

This item has no description.

Private procedure SetFont(AFont: TFont);

This item has no description.

Private procedure SetLines(const Value: TStringList);

This item has no description.

Private procedure SetOblique(const Value: Single);

This item has no description.

Private procedure SetText(const AText: WideString);

This item has no description.

Private procedure SetTextHeight(const Value: Single);

This item has no description.

Properties

Published property Adjust: TGLTextAdjust read FAdjust write SetAdjust;

This item has no description.

Published property allowedDeviation: Single read FAllowedDeviation write SetAllowedDeviation;

Quality related, see Win32 help for wglUseFontOutlines

Published property AspectRatio: Single read FAspectRatio write SetAspectRatio;

This item has no description.

Published property CharacterRange: TGLSpaceTextCharRange read FCharacterRange write SetCharacterRange default stcrDefault;

Character range to convert. Converting less characters saves time and memory...

Published property Extrusion: Single read FExtrusion write SetExtrusion;

Adjusts the 3D font extrusion. If Extrusion=0, the characters will be flat (2D), values >0 will give them a third dimension.

Published property Font: TFont read FFont write SetFont;

This item has no description.

Published property Lines: TStringList read FLines write SetLines;

This item has no description.

Published property Oblique: Single read FOblique write SetOblique;

This item has no description.

Published property Text: WideString read GetText write SetText stored False;

This item has no description.

Published property TextHeight: Single read FTextHeight write SetTextHeight;


GLSysHelp v.2.5: GLS.SpaceText: Class TFontManager

Class TFontManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.SpaceText

Declaration

type TFontManager = class(TList)

Description

Manages a list of fonts for which display lists were created.

Hierarchy

  • TObject
  • TList
  • TFontManager

Overview

Fields

Private FCurrentBase: Integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function FindFont(AName: string; FStyles: TFontStyles; FExtrusion: Single; FAllowedDeviation: Single; FFirstChar, FLastChar: Integer): PFontEntry;
Public | function GetFontBase(AName: string; FStyles: TFontStyles; FExtrusion: Single; allowedDeviation: Single; firstChar, lastChar: Integer; client: TObject): PFontEntry;
Public | procedure Release(entry: PFontEntry; client: TObject);

Description

Fields

Private FCurrentBase: Integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindFont(AName: string; FStyles: TFontStyles; FExtrusion: Single; FAllowedDeviation: Single; FFirstChar, FLastChar: Integer): PFontEntry;

This item has no description.

Public function GetFontBase(AName: string; FStyles: TFontStyles; FExtrusion: Single; allowedDeviation: Single; firstChar, lastChar: Integer; client: TObject): PFontEntry;

This item has no description.

Public procedure Release(entry: PFontEntry; client: TObject);


GLSysHelp v.2.5: GLS.State

Unit GLS.State

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.TextureFormat
  • GLScene.Utils
  • GLS.Color

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TGLLightSourceState |
Packed Record TGLShaderLightSourceState |
Record TUBOStates |
Class TGLStateCache |
Record TStateRecord |

Types

TGLBlendEquation = (...);
TGLBlendFunction = (...);
TGLBufferBindingTarget = (...);
TGLColorComponent = (...);
TGLColorMask = set of TGLColorComponent;
TGLComparisonFunction = (...);
TGLCullFaceMode = (...);
TGLDepthFunction = TGLComparisonFunction;
TGLDstBlendFunction = bfZero..bfOneMinusConstantAlpha;
TGLFaceWinding = (...);
TGLHintType = (...);
TGLLogicOp = (...);
TGLMaterialLevel = (...);
TGLMeshPrimitive = (...);
TGLMeshPrimitives = set of TGLMeshPrimitive;
TGLOnLightsChanged = procedure(Sender: TObject);
TGLPolygonMode = (...);
TGLQueryType = (...);
TGLState = (...);
TGLStates = set of TGLState;
TGLStateType = (...);
TGLStateTypes = set of TGLStateType;
TGLStencilFunction = TGLComparisonFunction;
TGLStencilOp = (...);

Constants

GLS_VERTEX_ATTR_NUM = 16;
cAllAttribBits = [low(TGLStateType) .. High(TGLStateType)];
cAllMeshPrimitive = [ mpTRIANGLES, mpTRIANGLE_STRIP, mpTRIANGLE_FAN, mpPOINTS, mpLINES, mpLINE_LOOP, mpLINE_STRIP, mpLINES_ADJACENCY, mpLINE_STRIP_ADJACENCY, mpTRIANGLES_ADJACENCY, mpTRIANGLE_STRIP_ADJACENCY, mpPATCHES];
cAllColorComponents = [ccRed, ccGreen, ccBlue, ccAlpha];
MAX_HARDWARE_LIGHT = 16;
MAX_SHADER_LIGHT = 8;
MAX_HARDWARE_TEXTURE_UNIT = 48;
MAX_HARDWARE_UNIFORM_BUFFER_BINDING = 75;
cGLStateTypeToGLEnum: array [TGLStateType] of Cardinal = ( GL_CURRENT_BIT, GL_POINT_BIT, GL_LINE_BIT, GL_POLYGON_BIT, GL_POLYGON_STIPPLE_BIT, GL_PIXEL_MODE_BIT, GL_LIGHTING_BIT, GL_FOG_BIT, GL_DEPTH_BUFFER_BIT, GL_ACCUM_BUFFER_BIT, GL_STENCIL_BUFFER_BIT, GL_VIEWPORT_BIT, GL_TRANSFORM_BIT, GL_ENABLE_BIT, GL_COLOR_BUFFER_BIT, GL_HINT_BIT, GL_EVAL_BIT, GL_LIST_BIT, GL_TEXTURE_BIT, GL_SCISSOR_BIT, GL_MULTISAMPLE_BIT);
cGLStateToGLEnum: array[TGLState] of TStateRecord = ((GLConst: GL_ALPHA_TEST; GLDeprecated: True), (GLConst: GL_AUTO_NORMAL; GLDeprecated: True), (GLConst: GL_BLEND; GLDeprecated: False), (GLConst: GL_COLOR_MATERIAL; GLDeprecated: True), (GLConst: GL_CULL_FACE; GLDeprecated: False), (GLConst: GL_DEPTH_TEST; GLDeprecated: False), (GLConst: GL_DITHER; GLDeprecated: False), (GLConst: GL_FOG; GLDeprecated: True), (GLConst: GL_LIGHTING; GLDeprecated: True), (GLConst: GL_LINE_SMOOTH; GLDeprecated: True), (GLConst: GL_LINE_STIPPLE; GLDeprecated: True), (GLConst: GL_INDEX_LOGIC_OP; GLDeprecated: True), (GLConst: GL_COLOR_LOGIC_OP; GLDeprecated: False), (GLConst: GL_NORMALIZE; GLDeprecated: True), (GLConst: GL_POINT_SMOOTH; GLDeprecated: True), (GLConst: GL_POINT_SPRITE; GLDeprecated: True), (GLConst: GL_POLYGON_SMOOTH; GLDeprecated: True), (GLConst: GL_POLYGON_STIPPLE; GLDeprecated: True), (GLConst: GL_SCISSOR_TEST; GLDeprecated: False), (GLConst: GL_STENCIL_TEST; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_POINT; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_LINE; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_FILL; GLDeprecated: False), (GLConst: GL_DEPTH_CLAMP; GLDeprecated: False) );
cGLTexTypeToGLEnum: array[TGLTextureTarget] of Cardinal = (0, GL_TEXTURE_1D, GL_TEXTURE_2D, GL_TEXTURE_3D, GL_TEXTURE_1D_ARRAY, GL_TEXTURE_2D_ARRAY, GL_TEXTURE_RECTANGLE, GL_TEXTURE_BUFFER, GL_TEXTURE_CUBE_MAP, GL_TEXTURE_2D_MULTISAMPLE, GL_TEXTURE_2D_MULTISAMPLE_ARRAY, GL_TEXTURE_CUBE_MAP_ARRAY);
cGLQueryTypeToGLEnum: array[TGLQueryType] of Cardinal = (GL_SAMPLES_PASSED, GL_PRIMITIVES_GENERATED, GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN, GL_TIME_ELAPSED, GL_ANY_SAMPLES_PASSED);
cGLStencilOpToGLEnum: array[TGLStencilOp] of Cardinal = (GL_KEEP, GL_ZERO, GL_REPLACE, GL_INCR, GL_DECR, GL_INVERT, GL_INCR_WRAP, GL_DECR_WRAP);
cGLLogicOpToGLEnum: array[TGLLogicOp] of Cardinal = (GL_CLEAR, GL_AND, GL_AND_REVERSE, GL_COPY, GL_AND_INVERTED, GL_NOOP, GL_XOR, GL_OR, GL_NOR, GL_EQUIV, GL_INVERT, GL_OR_REVERSE, GL_COPY_INVERTED, GL_OR_INVERTED, GL_NAND, GL_SET);
cGLComparisonFunctionToGLEnum: array[TGLComparisonFunction] of Cardinal = (GL_NEVER, GL_ALWAYS, GL_LESS, GL_LEQUAL, GL_EQUAL, GL_GREATER, GL_NOTEQUAL, GL_GEQUAL);
cGLBlendFunctionToGLEnum: array[TGLBlendFunction] of Cardinal = (GL_ZERO, GL_ONE, GL_SRC_COLOR, GL_ONE_MINUS_SRC_COLOR, GL_DST_COLOR, GL_ONE_MINUS_DST_COLOR, GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA, GL_DST_ALPHA, GL_ONE_MINUS_DST_ALPHA, GL_CONSTANT_COLOR, GL_ONE_MINUS_CONSTANT_COLOR, GL_CONSTANT_ALPHA, GL_ONE_MINUS_CONSTANT_ALPHA, GL_SRC_ALPHA_SATURATE );
cGLBlendEquationToGLEnum: array[TGLBlendEquation] of Cardinal = (GL_FUNC_ADD, GL_FUNC_SUBTRACT, GL_FUNC_REVERSE_SUBTRACT, GL_MIN, GL_MAX);
cGLFaceWindingToGLEnum: array[TGLFaceWinding] of Cardinal = (GL_CCW, GL_CW);
cGLPolygonModeToGLEnum: array[TGLPolygonMode] of Cardinal = (GL_FILL, GL_LINE, GL_POINT);
cGLCullFaceModeToGLEnum: array[TGLCullFaceMode] of Cardinal = (GL_FRONT, GL_BACK, GL_FRONT_AND_BACK);
cGLHintToGLEnum: array[TGLHintType] of Cardinal = (GL_DONT_CARE, GL_FASTEST, GL_NICEST);
cGLBufferBindingTarget: array[TGLBufferBindingTarget] of Cardinal = (GL_UNIFORM_BUFFER, GL_TRANSFORM_FEEDBACK_BUFFER);

Description

Types

TGLBlendEquation = (...);

This item has no description.

Values
  • beAdd
  • beSubtract
  • beReverseSubtract
  • beMin
  • beMax
TGLBlendFunction = (...);

This item has no description.

Values
  • bfZero
  • bfOne
  • bfSrcColor
  • bfOneMinusSrcColor
  • bfDstColor
  • bfOneMinusDstColor
  • bfSrcAlpha
  • bfOneMinusSrcAlpha
  • bfDstAlpha
  • bfOneMinusDstAlpha
  • bfConstantColor
  • bfOneMinusConstantColor
  • bfConstantAlpha
  • bfOneMinusConstantAlpha
  • bfSrcAlphaSat
TGLBufferBindingTarget = (...);

This item has no description.

Values
  • bbtUniform
  • bbtTransformFeedBack
TGLColorComponent = (...);

TSingleCullFaceMode = cmFront..cmBack;

Values
  • ccRed
  • ccGreen
  • ccBlue
  • ccAlpha
TGLColorMask = set of TGLColorComponent;

This item has no description.

TGLComparisonFunction = (...);

This item has no description.

Values
  • cfNever
  • cfAlways
  • cfLess
  • cfLEqual
  • cfEqual
  • cfGreater
  • cfNotEqual
  • cfGEqual
TGLCullFaceMode = (...);

This item has no description.

Values
  • cmFront
  • cmBack
  • cmFrontAndBack
TGLDepthFunction = TGLComparisonFunction;

This item has no description.

TGLDstBlendFunction = bfZero..bfOneMinusConstantAlpha;

This item has no description.

TGLFaceWinding = (...);

Describe what kind of winding has a front face

Values
  • fwCounterClockWise
  • fwClockWise
TGLHintType = (...);

This item has no description.

Values
  • hintDontCare
  • hintFastest
  • hintNicest
TGLLogicOp = (...);

This item has no description.

Values
  • loClear
  • loAnd
  • loAndReverse
  • loCopy
  • loAndInverted
  • loNoOp
  • loXOr
  • loOr
  • loNor
  • loEquiv
  • loInvert
  • loOrReverse
  • loCopyInverted
  • loOrInverted
  • loNAnd
  • loSet
TGLMaterialLevel = (...);

This item has no description.

Values
  • mlAuto
  • mlFixedFunction
  • mlMultitexturing
  • mlSM3
  • mlSM4
  • mlSM5
TGLMeshPrimitive = (...);

This item has no description.

Values
  • mpNOPRIMITIVE
  • mpTRIANGLES
  • mpTRIANGLE_STRIP
  • mpTRIANGLE_FAN
  • mpPOINTS
  • mpLINES
  • mpLINE_LOOP
  • mpLINE_STRIP
  • mpLINES_ADJACENCY
  • mpLINE_STRIP_ADJACENCY
  • mpTRIANGLES_ADJACENCY
  • mpTRIANGLE_STRIP_ADJACENCY
  • mpPATCHES
TGLMeshPrimitives = set of TGLMeshPrimitive;

This item has no description.

TGLOnLightsChanged = procedure(Sender: TObject);

This item has no description.

TGLPolygonMode = (...);

This item has no description.

Values
  • pmFill
  • pmLines
  • pmPoints
TGLQueryType = (...);

This item has no description.

Values
  • qrySamplesPassed
  • qryPrimitivesGenerated
  • qryTransformFeedbackPrimitivesWritten
  • qryTimeElapsed
  • qryAnySamplesPassed
TGLState = (...);

Reflects all relevant (binary) states of OpenGL subsystem

Values
  • stAlphaTest
  • stAutoNormal
  • stBlend
  • stColorMaterial
  • stCullFace
  • stDepthTest
  • stDither
  • stFog
  • stLighting
  • stLineSmooth
  • stLineStipple
  • stIndexLogicOp
  • stColorLogicOp
  • stNormalize
  • stPointSmooth
  • stPointSprite
  • stPolygonSmooth
  • stPolygonStipple
  • stScissorTest
  • stStencilTest
  • stPolygonOffsetPoint
  • stPolygonOffsetLine
  • stPolygonOffsetFill
  • stDepthClamp
TGLStates = set of TGLState;

This item has no description.

TGLStateType = (...);

This item has no description.

Values
  • sttCurrent
  • sttPoint
  • sttLine
  • sttPolygon
  • sttPolygonStipple
  • sttPixelMode
  • sttLighting
  • sttFog
  • sttDepthBuffer
  • sttAccumBuffer
  • sttStencilBuffer
  • sttViewport
  • sttTransform
  • sttEnable
  • sttColorBuffer
  • sttHint
  • sttEval
  • sttList
  • sttTexture
  • sttScissor
  • sttMultisample
TGLStateTypes = set of TGLStateType;

This item has no description.

TGLStencilFunction = TGLComparisonFunction;

This item has no description.

TGLStencilOp = (...);

This item has no description.

Values
  • soKeep
  • soZero
  • soReplace
  • soIncr
  • soDecr
  • soInvert
  • soIncrWrap
  • soDecrWrap

Constants

GLS_VERTEX_ATTR_NUM = 16;

This item has no description.

cAllAttribBits = [low(TGLStateType) .. High(TGLStateType)];

This item has no description.

cAllMeshPrimitive = [ mpTRIANGLES, mpTRIANGLE_STRIP, mpTRIANGLE_FAN, mpPOINTS, mpLINES, mpLINE_LOOP, mpLINE_STRIP, mpLINES_ADJACENCY, mpLINE_STRIP_ADJACENCY, mpTRIANGLES_ADJACENCY, mpTRIANGLE_STRIP_ADJACENCY, mpPATCHES];

This item has no description.

cAllColorComponents = [ccRed, ccGreen, ccBlue, ccAlpha];

This item has no description.

MAX_HARDWARE_LIGHT = 16;

This item has no description.

MAX_SHADER_LIGHT = 8;

This item has no description.

MAX_HARDWARE_TEXTURE_UNIT = 48;

This item has no description.

MAX_HARDWARE_UNIFORM_BUFFER_BINDING = 75;

This item has no description.

cGLStateTypeToGLEnum: array [TGLStateType] of Cardinal = ( GL_CURRENT_BIT, GL_POINT_BIT, GL_LINE_BIT, GL_POLYGON_BIT, GL_POLYGON_STIPPLE_BIT, GL_PIXEL_MODE_BIT, GL_LIGHTING_BIT, GL_FOG_BIT, GL_DEPTH_BUFFER_BIT, GL_ACCUM_BUFFER_BIT, GL_STENCIL_BUFFER_BIT, GL_VIEWPORT_BIT, GL_TRANSFORM_BIT, GL_ENABLE_BIT, GL_COLOR_BUFFER_BIT, GL_HINT_BIT, GL_EVAL_BIT, GL_LIST_BIT, GL_TEXTURE_BIT, GL_SCISSOR_BIT, GL_MULTISAMPLE_BIT);

This item has no description.

cGLStateToGLEnum: array[TGLState] of TStateRecord = ((GLConst: GL_ALPHA_TEST; GLDeprecated: True), (GLConst: GL_AUTO_NORMAL; GLDeprecated: True), (GLConst: GL_BLEND; GLDeprecated: False), (GLConst: GL_COLOR_MATERIAL; GLDeprecated: True), (GLConst: GL_CULL_FACE; GLDeprecated: False), (GLConst: GL_DEPTH_TEST; GLDeprecated: False), (GLConst: GL_DITHER; GLDeprecated: False), (GLConst: GL_FOG; GLDeprecated: True), (GLConst: GL_LIGHTING; GLDeprecated: True), (GLConst: GL_LINE_SMOOTH; GLDeprecated: True), (GLConst: GL_LINE_STIPPLE; GLDeprecated: True), (GLConst: GL_INDEX_LOGIC_OP; GLDeprecated: True), (GLConst: GL_COLOR_LOGIC_OP; GLDeprecated: False), (GLConst: GL_NORMALIZE; GLDeprecated: True), (GLConst: GL_POINT_SMOOTH; GLDeprecated: True), (GLConst: GL_POINT_SPRITE; GLDeprecated: True), (GLConst: GL_POLYGON_SMOOTH; GLDeprecated: True), (GLConst: GL_POLYGON_STIPPLE; GLDeprecated: True), (GLConst: GL_SCISSOR_TEST; GLDeprecated: False), (GLConst: GL_STENCIL_TEST; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_POINT; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_LINE; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_FILL; GLDeprecated: False), (GLConst: GL_DEPTH_CLAMP; GLDeprecated: False) );

This item has no description.

cGLTexTypeToGLEnum: array[TGLTextureTarget] of Cardinal = (0, GL_TEXTURE_1D, GL_TEXTURE_2D, GL_TEXTURE_3D, GL_TEXTURE_1D_ARRAY, GL_TEXTURE_2D_ARRAY, GL_TEXTURE_RECTANGLE, GL_TEXTURE_BUFFER, GL_TEXTURE_CUBE_MAP, GL_TEXTURE_2D_MULTISAMPLE, GL_TEXTURE_2D_MULTISAMPLE_ARRAY, GL_TEXTURE_CUBE_MAP_ARRAY);

This item has no description.

cGLQueryTypeToGLEnum: array[TGLQueryType] of Cardinal = (GL_SAMPLES_PASSED, GL_PRIMITIVES_GENERATED, GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN, GL_TIME_ELAPSED, GL_ANY_SAMPLES_PASSED);

This item has no description.

cGLStencilOpToGLEnum: array[TGLStencilOp] of Cardinal = (GL_KEEP, GL_ZERO, GL_REPLACE, GL_INCR, GL_DECR, GL_INVERT, GL_INCR_WRAP, GL_DECR_WRAP);

This item has no description.

cGLLogicOpToGLEnum: array[TGLLogicOp] of Cardinal = (GL_CLEAR, GL_AND, GL_AND_REVERSE, GL_COPY, GL_AND_INVERTED, GL_NOOP, GL_XOR, GL_OR, GL_NOR, GL_EQUIV, GL_INVERT, GL_OR_REVERSE, GL_COPY_INVERTED, GL_OR_INVERTED, GL_NAND, GL_SET);

This item has no description.

cGLComparisonFunctionToGLEnum: array[TGLComparisonFunction] of Cardinal = (GL_NEVER, GL_ALWAYS, GL_LESS, GL_LEQUAL, GL_EQUAL, GL_GREATER, GL_NOTEQUAL, GL_GEQUAL);

This item has no description.

cGLBlendFunctionToGLEnum: array[TGLBlendFunction] of Cardinal = (GL_ZERO, GL_ONE, GL_SRC_COLOR, GL_ONE_MINUS_SRC_COLOR, GL_DST_COLOR, GL_ONE_MINUS_DST_COLOR, GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA, GL_DST_ALPHA, GL_ONE_MINUS_DST_ALPHA, GL_CONSTANT_COLOR, GL_ONE_MINUS_CONSTANT_COLOR, GL_CONSTANT_ALPHA, GL_ONE_MINUS_CONSTANT_ALPHA, GL_SRC_ALPHA_SATURATE );

This item has no description.

cGLBlendEquationToGLEnum: array[TGLBlendEquation] of Cardinal = (GL_FUNC_ADD, GL_FUNC_SUBTRACT, GL_FUNC_REVERSE_SUBTRACT, GL_MIN, GL_MAX);

valid for src only

cGLFaceWindingToGLEnum: array[TGLFaceWinding] of Cardinal = (GL_CCW, GL_CW);

This item has no description.

cGLPolygonModeToGLEnum: array[TGLPolygonMode] of Cardinal = (GL_FILL, GL_LINE, GL_POINT);

This item has no description.

cGLCullFaceModeToGLEnum: array[TGLCullFaceMode] of Cardinal = (GL_FRONT, GL_BACK, GL_FRONT_AND_BACK);

This item has no description.

cGLHintToGLEnum: array[TGLHintType] of Cardinal = (GL_DONT_CARE, GL_FASTEST, GL_NICEST);

This item has no description.

cGLBufferBindingTarget: array[TGLBufferBindingTarget] of Cardinal = (GL_UNIFORM_BUFFER, GL_TRANSFORM_FEEDBACK_BUFFER);


GLSysHelp v.2.5: GLS.State: Packed Record TGLLightSourceState

Packed Record TGLLightSourceState

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.State

Declaration

type TGLLightSourceState = packed record

Description

This item has no description.

Overview

Fields

Public | Position: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;
Public | Ambient: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;
Public | Diffuse: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;
Public | Specular: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;
Public | SpotDirection: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;
Public | SpotCosCutoffExponent: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;
Public | Attenuation: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;

Description

Fields

Public Position: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;

This item has no description.

Public Ambient: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;

This item has no description.

Public Diffuse: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;

This item has no description.

Public Specular: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;

This item has no description.

Public SpotDirection: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;

This item has no description.

Public SpotCosCutoffExponent: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;

This item has no description.

Public Attenuation: array [0 .. MAX_HARDWARE_LIGHT - 1] of TGLVector;


GLSysHelp v.2.5: GLS.State: Packed Record TGLShaderLightSourceState

Packed Record TGLShaderLightSourceState

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.State

Declaration

type TGLShaderLightSourceState = packed record

Description

This item has no description.

Overview

Fields

Public | Position: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;
Public | Ambient: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;
Public | Diffuse: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;
Public | Specular: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;
Public | SpotDirection: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;
Public | SpotCosCutoffExponent: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;
Public | Attenuation: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;

Description

Fields

Public Position: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;

This item has no description.

Public Ambient: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;

This item has no description.

Public Diffuse: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;

This item has no description.

Public Specular: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;

This item has no description.

Public SpotDirection: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;

This item has no description.

Public SpotCosCutoffExponent: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;

This item has no description.

Public Attenuation: array [0 .. MAX_SHADER_LIGHT - 1] of TGLVector;


GLSysHelp v.2.5: GLS.State: Record TUBOStates

Record TUBOStates

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.State

Declaration

type TUBOStates = record

Description

This item has no description.

Overview

Fields

Public | FUniformBufferBinding: Cardinal;
Public | FOffset: TGLintptr;
Public | FSize: TGLsizeiptr;

Description

Fields

Public FUniformBufferBinding: Cardinal;

This item has no description.

Public FOffset: TGLintptr;

This item has no description.

Public FSize: TGLsizeiptr;


GLSysHelp v.2.5: GLS.State: Class TGLStateCache

Class TGLStateCache

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.State

Declaration

type TGLStateCache = class(TObject)

Description

Manages an application-side cache of OpenGL states and parameters. Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context

Hierarchy

  • TObject
  • TGLStateCache

Overview

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function GetLightIndicesAsAddress: PGLInt;
Public | function GetLightStateAsAddress: Pointer;
Public | procedure BeginQuery(const target: TGLQueryType; const Value: Cardinal); inline;
Public | procedure CallList(list: Cardinal); inline;
Public | procedure Disable(const aState: TGLState);
Public | procedure Enable(const aState: TGLState);
Public | procedure EndList; inline;
Public | procedure EndQuery(const target: TGLQueryType); inline;
Public | procedure InvertFrontFace; inline;
Public | procedure NewList(list: Cardinal; mode: Cardinal); inline;
Public | procedure PerformDisable(const aState: TGLState); inline;
Public | procedure PerformEnable(const aState: TGLState); inline;
Public | procedure PopAttrib(); inline;
Public | procedure PushAttrib(const stateTypes: TGLStateTypes); inline;
Public | procedure ResetAll; deprecated; inline;
Public | procedure ResetAllTextureMatrix; inline;
Public | procedure ResetGLCurrentTexture; deprecated;
Public | procedure ResetGLFrontFace; deprecated;
Public | procedure ResetGLMaterialColors; deprecated; inline;
Public | procedure ResetGLPolygonMode; deprecated; inline;
Public | procedure ResetGLTexture(const TextureUnit: Integer); deprecated; inline;
Public | procedure ResetTextureMatrix; inline;
Public | procedure SetBlendEquation(const mode: TGLBlendEquation); inline;
Public | procedure SetBlendEquationSeparate(const modeRGB, modeAlpha: TGLBlendEquation); inline;
Public | procedure SetBlendFunc(const Src: TGLBlendFunction; const Dst: TGLDstBlendFunction); inline;
Public | procedure SetBlendFuncSeparate(const SrcRGB: TGLBlendFunction; const DstRGB: TGLDstBlendFunction; const SrcAlpha: TGLBlendFunction; const DstAlpha: TGLDstBlendFunction); inline;
Public | procedure SetBufferIndexedBinding(const Value: Cardinal; ATarget: TGLBufferBindingTarget; AIndex: Cardinal; AOffset: TGLintptr; ARangeSize: TGLsizeiptr); overload; inline;
Public | procedure SetBufferIndexedBinding(const Value: Cardinal; ATarget: TGLBufferBindingTarget; AIndex: Cardinal; ABufferSize: TGLsizeiptr); overload; inline;
Public | procedure SetColorMask(mask: TGLColorMask); inline;
Public | procedure SetColorWriting(flag: Boolean); inline;
Public | procedure SetDepthRange(const ZNear, ZFar: TGLclampd); inline;
Public | procedure SetFrameBuffer(const Value: Cardinal); inline;
Public | procedure SetGLAlphaFunction(func: TGLComparisonFunction; ref: Single); inline;
Public | procedure SetGLFrontFaceCW; deprecated; inline;
Public | procedure SetGLMaterialAlphaChannel(const aFace: Cardinal; const alpha: TGLfloat);
Public | procedure SetGLMaterialColors(const aFace: TGLCullFaceMode; const emission, Ambient, Diffuse, Specular: TGLVector; const shininess: Integer);
Public | procedure SetGLMaterialDiffuseColor(const aFace: Cardinal; const Diffuse: TGLVector);
Public | procedure SetGLState(const aState: TGLState); deprecated; inline;
Public | procedure SetPolygonOffset(const factor, units: TGLfloat);
Public | procedure SetSampleCoverage(const Value: TGLfloat; invert: TGLboolean);
Public | procedure SetStencilFunc(const func: TGLStencilFunction; const ref: TGLint; const mask: Cardinal); inline;
Public | procedure SetStencilFuncSeparate(const face: TGLCullFaceMode; const func: TGLStencilFunction; const ref: TGLint; const mask: Cardinal); inline;
Public | procedure SetStencilOp(const fail, zfail, zpass: TGLStencilOp); inline;
Public | procedure SetStencilOpSeparate(const face: TGLCullFaceMode; const sfail, dpfail, dppass: TGLStencilOp); inline;
Public | procedure SetTextureMatrix(const matrix: TGLMatrix); inline;
Public | procedure UnSetGLState(const aState: TGLState); deprecated; inline;

Properties

Public | property ActiveTexture: TGLint read FActiveTexture write SetActiveTexture;
Public | property ActiveTextureEnabled[target: TGLTextureTarget]: Boolean read GetActiveTextureEnabled write SetActiveTextureEnabled;
Public | property ArrayBufferBinding: Cardinal read GetArrayBufferBinding write SetArrayBufferBinding;
Public | property BlendColor: TGLVector read FBlendColor write SetBlendColor;
Public | property BlendDstAlpha: TGLDstBlendFunction read FBlendDstAlpha;
Public | property BlendDstRGB: TGLDstBlendFunction read FBlendDstRGB;
Public | property BlendEquationAlpha: TGLBlendEquation read FBlendEquationAlpha;
Public | property BlendEquationRGB: TGLBlendEquation read FBlendEquationRGB;
Public | property BlendSrcAlpha: TGLBlendFunction read FBlendSrcAlpha;
Public | property BlendSrcRGB: TGLBlendFunction read FBlendSrcRGB;
Public | property ClampReadColor: Cardinal read FClampReadColor write SetClampReadColor;
Public | property ColorClearValue: TGLVector read FColorClearValue write SetColorClearValue;
Public | property ColorWriteMask[Index: Integer]: TGLColorMask read GetColorWriteMask write SetColorWriteMask;
Public | property CopyReadBufferBinding: Cardinal read FCopyReadBufferBinding write SetCopyReadBufferBinding;
Public | property CopyWriteBufferBinding: Cardinal read FCopyWriteBufferBinding write SetCopyWriteBufferBinding;
Public | property CullFaceMode: TGLCullFaceMode read FCullFaceMode write SetCullFaceMode;
Public | property CurrentProgram: Cardinal read FCurrentProgram write SetCurrentProgram;
Public | property CurrentQuery[Index: TGLQueryType]: Cardinal read GetCurrentQuery;
Public | property CurrentVertexAttrib[Index: Integer]: TGLVector read GetCurrentVertexAttrib write SetCurrentVertexAttrib;
Public | property DepthClearValue: TGLfloat read FDepthClearValue write SetDepthClearValue;
Public | property DepthFunc: TGLDepthFunction read FDepthFunc write SetDepthFunc;
Public | property DepthRangeFar: TGLclampd read GetDepthRangeFar write SetDepthRangeFar;
Public | property DepthRangeNear: TGLclampd read GetDepthRangeNear write SetDepthRangeNear;
Public | property DepthWriteMask: TGLboolean read FDepthWriteMask write SetDepthWriteMask;
Public | property DrawFrameBuffer: Cardinal read FDrawFrameBuffer write SetDrawFrameBuffer;
Public | property ElementBufferBinding: Cardinal read GetElementBufferBinding write SetElementBufferBinding;
Public | property EnableBlend[Index: Integer]: TGLboolean read GetEnableBlend write SetEnableBlend;
Public | property EnableClipDistance[Index: Cardinal]: TGLboolean read GetEnableClipDistance write SetEnableClipDistance;
Public | property EnableColorLogicOp: TGLboolean read FEnableColorLogicOp write SetEnableColorLogicOp;
Public | property EnableCullFace: TGLboolean read FEnableCullFace write SetEnableCullFace;
Public | property EnableDepthClamp: TGLboolean read FEnableDepthClamp write SetEnableDepthClamp;
Public | property EnableDepthTest: TGLboolean read FEnableDepthTest write SetEnableDepthTest;
Public | property EnableDither: TGLboolean read FEnableDither write SetEnableDither;
Public | property EnableFramebufferSRGB: TGLboolean read FEnableFramebufferSRGB write SetEnableFramebufferSRGB;
Public | property EnableLineSmooth: TGLboolean read FEnableLineSmooth write SetEnableLineSmooth;
Public | property EnableMultisample: TGLboolean read FEnableMultisample write SetEnableMultisample;
Public | property EnablePolygonOffsetFill: TGLboolean read FEnablePolygonOffsetFill write SetEnablePolygonOffsetFill;
Public | property EnablePolygonOffsetLine: TGLboolean read FEnablePolygonOffsetLine write SetEnablePolygonOffsetLine;
Public | property EnablePolygonOffsetPoint: TGLboolean read FEnablePolygonOffsetPoint write SetEnablePolygonOffsetPoint;
Public | property EnablePolygonSmooth: TGLboolean read FEnablePolygonSmooth write SetEnablePolygonSmooth;
Public | property EnablePrimitiveRestart: TGLboolean read GetEnablePrimitiveRestart write SetEnablePrimitiveRestart;
Public | property EnableProgramPointSize: TGLboolean read FEnableProgramPointSize write SetEnableProgramPointSize;
Public | property EnableSampleAlphaToCoverage: TGLboolean read FEnableSampleAlphaToCoverage write SetEnableSampleAlphaToCoverage;
Public | property EnableSampleAlphaToOne: TGLboolean read FEnableSampleAlphaToOne write SetEnableSampleAlphaToOne;
Public | property EnableSampleCoverage: TGLboolean read FEnableSampleCoverage write SetEnableSampleCoverage;
Public | property EnableSampleMask: TGLboolean read FEnableSampleMask write SetEnableSampleMask;
Public | property EnableScissorTest: TGLboolean read FEnableScissorTest write SetEnableScissorTest;
Public | property EnableStencilTest: TGLboolean read FEnableStencilTest write SetEnableStencilTest;
Public | property EnableTextureCubeMapSeamless: TGLboolean read FEnableTextureCubeMapSeamless write SetEnableTextureCubeMapSeamless;
Public | property FixedFunctionPipeLight: Boolean read FFFPLight write SetFFPLight;
Public | property FragmentShaderDerivitiveHint: TGLHintType read FFragmentShaderDerivitiveHint write SetFragmentShaderDerivitiveHint;
Public | property FrontFace: TGLFaceWinding read FFrontFace write SetFrontFace;
Public | property InsideList: Boolean read FInsideList;
Public | property LightAmbient[Index: Integer]: TGLVector read GetLightAmbient write SetLightAmbient;
Public | property LightConstantAtten[Index: Integer]: Single read GetConstantAtten write SetConstantAtten;
Public | property LightDiffuse[Index: Integer]: TGLVector read GetLightDiffuse write SetLightDiffuse;
Public | property LightEnabling[Index: Integer]: Boolean read GetLightEnabling write SetLightEnabling;
Public | property LightLinearAtten[Index: Integer]: Single read GetLinearAtten write SetLinearAtten;
Public | property LightNumber: Integer read FLightNumber;
Public | property LightPosition[Index: Integer]: TGLVector read GetLightPosition write SetLightPosition;
Public | property LightQuadraticAtten[Index: Integer]: Single read GetQuadAtten write SetQuadAtten;
Public | property LightSpecular[Index: Integer]: TGLVector read GetLightSpecular write SetLightSpecular;
Public | property LightSpotCutoff[Index: Integer]: Single read GetSpotCutoff write SetSpotCutoff;
Public | property LightSpotDirection[Index: Integer]: TAffineVector read GetLightSpotDirection write SetLightSpotDirection;
Public | property LightSpotExponent[Index: Integer]: Single read GetSpotExponent write SetSpotExponent;
Public | property LineSmoothHint: TGLHintType read FLineSmoothHint write SetLineSmoothHint;
Public | property LineStippleFactor: TGLint read FLineStippleFactor write SetLineStippleFactor;
Public | property LineStipplePattern: TGLushort read FLineStipplePattern write SetLineStipplePattern;
Public | property LineWidth: TGLfloat read FLineWidth write SetLineWidth;
Public | property LogicOpMode: TGLLogicOp read FLogicOpMode write SetLogicOpMode;
Public | property MaterialAmbient[const aFace: TGLCullFaceMode]: TGLVector read GetMaterialAmbient;
Public | property MaterialDiffuse[const aFace: TGLCullFaceMode]: TGLVector read GetMaterialDiffuse;
Public | property MaterialEmission[const aFace: TGLCullFaceMode]: TGLVector read GetMaterialEmission;
Public | property MaterialShininess[const aFace: TGLCullFaceMode]: Integer read GetMaterialShininess;
Public | property MaterialSpecular[const aFace: TGLCullFaceMode]: TGLVector read GetMaterialSpecular;
Public | property Max3DTextureSize: Cardinal read GetMax3DTextureSize;
Public | property MaxArrayTextureSize: Cardinal read GetMaxArrayTextureSize;
Public | property MaxCubeTextureSize: Cardinal read GetMaxCubeTextureSize;
Public | property MaxLights: Integer read GetMaxLights;
Public | property MaxSamples: Cardinal read GetMaxSamples;
Public | property MaxTextureAnisotropy: Cardinal read GetMaxTextureAnisotropy;
Public | property MaxTextureImageUnits: Cardinal read GetMaxTextureImageUnits;
Public | property MaxTextureSize: Cardinal read GetMaxTextureSize;
Public | property MaxTextureUnits: Cardinal read GetMaxTextureUnits;
Public | property MultisampleFilterHint: TGLHintType read FMultisampleFilterHint write SetMultisampleFilterHint;
Public | property OnLightsChanged: TGLOnLightsChanged read FOnLightsChanged write FOnLightsChanged;
Public | property PackAlignment: Cardinal read FPackAlignment write SetPackAlignment;
Public | property PackImageHeight: Cardinal read FPackImageHeight write SetPackImageHeight;
Public | property PackLSBFirst: TGLboolean read FPackLSBFirst write SetPackLSBFirst;
Public | property PackRowLength: Cardinal read FPackRowLength write SetPackRowLength;
Public | property PackSkipImages: Cardinal read FPackSkipImages write SetPackSkipImages;
Public | property PackSkipPixels: Cardinal read FPackSkipPixels write SetPackSkipPixels;
Public | property PackSkipRows: Cardinal read FPackSkipRows write SetPackSkipRows;
Public | property PackSwapBytes: TGLboolean read FPackSwapBytes write SetPackSwapBytes;
Public | property PixelPackBufferBinding: Cardinal read FPixelPackBufferBinding write SetPixelPackBufferBinding;
Public | property PixelUnpackBufferBinding: Cardinal read FPixelUnpackBufferBinding write SetPixelUnpackBufferBinding;
Public | property PointFadeThresholdSize: TGLfloat read FPointFadeThresholdSize write SetPointFadeThresholdSize;
Public | property PointSize: TGLfloat read FPointSize write SetPointSize;
Public | property PointSpriteCoordOrigin: Cardinal read FPointSpriteCoordOrigin write SetPointSpriteCoordOrigin;
Public | property PolygonMode: TGLPolygonMode read FPolygonMode write SetPolygonMode;
Public | property PolygonOffsetFactor: TGLfloat read FPolygonOffsetFactor write SetPolygonOffsetFactor;
Public | property PolygonOffsetUnits: TGLfloat read FPolygonOffsetUnits write SetPolygonOffsetUnits;
Public | property PolygonSmoothHint: TGLHintType read FPolygonSmoothHint write SetPolygonSmoothHint;
Public | property PrimitiveRestartIndex: Cardinal read GetPrimitiveRestartIndex write SetPrimitiveRestartIndex;
Public | property ProvokingVertex: Cardinal read FProvokingVertex write SetProvokingVertex;
Public | property ReadFrameBuffer: Cardinal read FReadFrameBuffer write SetReadFrameBuffer;
Public | property RenderBuffer: Cardinal read FRenderBuffer write SetRenderBuffer;
Public | property SampleCoverageInvert: TGLboolean read FSampleCoverageInvert write SetSampleCoverageInvert;
Public | property SampleCoverageValue: TGLfloat read FSampleCoverageValue write SetSampleCoverageValue;
Public | property SampleMaskValue[Index: Integer]: TGLbitfield read GetSampleMaskValue write SetSampleMaskValue;
Public | property SamplerBinding[Index: Cardinal]: Cardinal read GetSamplerBinding write SetSamplerBinding;
Public | property ScissorBox: TVector4i read FScissorBox write SetScissorBox;
Public | property States: TGLStates read FStates;
Public | property StencilBackFail: TGLStencilOp read FStencilBackFail;
Public | property StencilBackFunc: TGLStencilFunction read FStencilBackFunc;
Public | property StencilBackPassDepthFail: TGLStencilOp read FStencilBackPassDepthFail;
Public | property StencilBackPassDepthPass: TGLStencilOp read FStencilBackPassDepthPass;
Public | property StencilBackRef: Cardinal read FStencilBackRef;
Public | property StencilBackValueMask: Cardinal read FStencilBackValueMask;
Public | property StencilBackWriteMask: Cardinal read FStencilBackWriteMask write SetStencilBackWriteMask;
Public | property StencilClearValue: Cardinal read FStencilClearValue write SetStencilClearValue;
Public | property StencilFail: TGLStencilOp read FStencilFail;
Public | property StencilFunc: TGLStencilFunction read FStencilFunc;
Public | property StencilPassDepthFail: TGLStencilOp read FStencilPassDepthFail;
Public | property StencilPassDepthPass: TGLStencilOp read FStencilPassDepthPass;
Public | property StencilRef: TGLint read FStencilRef;
Public | property StencilValueMask: Cardinal read FStencilValueMask;
Public | property StencilWriteMask: Cardinal read FStencilWriteMask write SetStencilWriteMask;
Public | property TextureBinding[Index: Integer; target: TGLTextureTarget]: Cardinal read GetTextureBinding write SetTextureBinding;
Public | property TextureBindingTime[Index: Integer; target: TGLTextureTarget]: Double read GetTextureBindingTime;
Public | property TextureBufferBinding: Cardinal read FTextureBufferBinding write SetTextureBufferBinding;
Public | property TextureCompressionHint: TGLHintType read FTextureCompressionHint write SetTextureCompressionHint;
Public | property TransformFeedbackBufferBinding: Cardinal read FTransformFeedbackBufferBinding write SetTransformFeedbackBufferBinding;
Public | property UniformBufferBinding: Cardinal read FUniformBufferBinding write SetUniformBufferBinding;
Public | property UnpackAlignment: Cardinal read FUnpackAlignment write SetUnpackAlignment;
Public | property UnpackImageHeight: Cardinal read FUnpackImageHeight write SetUnpackImageHeight;
Public | property UnpackLSBFirst: TGLboolean read FUnpackLSBFirst write SetUnpackLSBFirst;
Public | property UnpackRowLength: Cardinal read FUnpackRowLength write SetUnpackRowLength;
Public | property UnpackSkipImages: Cardinal read FUnpackSkipImages write SetUnpackSkipImages;
Public | property UnpackSkipPixels: Cardinal read FUnpackSkipPixels write SetUnpackSkipPixels;
Public | property UnpackSkipRows: Cardinal read FUnpackSkipRows write SetUnpackSkipRows;
Public | property UnpackSwapBytes: TGLboolean read FUnpackSwapBytes write SetUnpackSwapBytes;
Public | property VertexArrayBinding: Cardinal read FVertexArrayBinding write SetVertexArrayBinding;
Public | property ViewPort: TVector4i read FViewPort write SetViewPort;

Description

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetLightIndicesAsAddress: PGLInt;

This item has no description.

Public function GetLightStateAsAddress: Pointer;

This item has no description.

Public procedure BeginQuery(const target: TGLQueryType; const Value: Cardinal); inline;

Begins a query of "Target" type. "Value" must be a valid query object

Public procedure CallList(list: Cardinal); inline;

Call display list

Public procedure Disable(const aState: TGLState);

This item has no description.

Public procedure Enable(const aState: TGLState);

This item has no description.

Public procedure EndList; inline;

End display list

Public procedure EndQuery(const target: TGLQueryType); inline;

Ends current query of type "Target"

Public procedure InvertFrontFace; inline;

Inverts front face winding (CCW/CW)

Public procedure NewList(list: Cardinal; mode: Cardinal); inline;

Begin new display list

Public procedure PerformDisable(const aState: TGLState); inline;

This item has no description.

Public procedure PerformEnable(const aState: TGLState); inline;

This item has no description.

Public procedure PopAttrib(); inline;

This item has no description.

Public procedure PushAttrib(const stateTypes: TGLStateTypes); inline;

This item has no description.

Public procedure ResetAll; deprecated; inline;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetAllTextureMatrix; inline;

This item has no description.

Public procedure ResetGLCurrentTexture; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetGLFrontFace; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetGLMaterialColors; deprecated; inline;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetGLPolygonMode; deprecated; inline;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetGLTexture(const TextureUnit: Integer); deprecated; inline;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetTextureMatrix; inline;

This item has no description.

Public procedure SetBlendEquation(const mode: TGLBlendEquation); inline;

write SetBlendEquationAlpha; Sets the blend equation for RGB + alpha to the same value.

Public procedure SetBlendEquationSeparate(const modeRGB, modeAlpha: TGLBlendEquation); inline;

Sets the blend equations for RGB + alpha separately.

Public procedure SetBlendFunc(const Src: TGLBlendFunction; const Dst: TGLDstBlendFunction); inline;

Sets the weighting factors to be used by the blending equation, for both color + alpha

Public procedure SetBlendFuncSeparate(const SrcRGB: TGLBlendFunction; const DstRGB: TGLDstBlendFunction; const SrcAlpha: TGLBlendFunction; const DstAlpha: TGLDstBlendFunction); inline;

Sets the weighting factors to be used by the blending equation, with separate values used for color + alpha components.

Public procedure SetBufferIndexedBinding(const Value: Cardinal; ATarget: TGLBufferBindingTarget; AIndex: Cardinal; AOffset: TGLintptr; ARangeSize: TGLsizeiptr); overload; inline;

This item has no description.

Public procedure SetBufferIndexedBinding(const Value: Cardinal; ATarget: TGLBufferBindingTarget; AIndex: Cardinal; ABufferSize: TGLsizeiptr); overload; inline;

This item has no description.

Public procedure SetColorMask(mask: TGLColorMask); inline;

Set the color write mask for all draw buffers.

Public procedure SetColorWriting(flag: Boolean); inline;

note: needs to change to per draw-buffer

Public procedure SetDepthRange(const ZNear, ZFar: TGLclampd); inline;

Modifies the near + far clipping planes

Public procedure SetFrameBuffer(const Value: Cardinal); inline;

set both draw + read framebuffer.

Public procedure SetGLAlphaFunction(func: TGLComparisonFunction; ref: Single); inline;

Blending states

Public procedure SetGLFrontFaceCW; deprecated; inline;

Warning: this symbol is deprecated.

This item has no description.

Public procedure SetGLMaterialAlphaChannel(const aFace: Cardinal; const alpha: TGLfloat);

Adjusts material alpha channel for a face

Public procedure SetGLMaterialColors(const aFace: TGLCullFaceMode; const emission, Ambient, Diffuse, Specular: TGLVector; const shininess: Integer);

Adjusts material colors for a face

Public procedure SetGLMaterialDiffuseColor(const aFace: Cardinal; const Diffuse: TGLVector);

Adjusts material diffuse color for a face

Public procedure SetGLState(const aState: TGLState); deprecated; inline;

Warning: this symbol is deprecated.

This item has no description.

Public procedure SetPolygonOffset(const factor, units: TGLfloat);

Set polygon offset

Public procedure SetSampleCoverage(const Value: TGLfloat; invert: TGLboolean);

Set sample coverage

Public procedure SetStencilFunc(const func: TGLStencilFunction; const ref: TGLint; const mask: Cardinal); inline;

Used to set stencil Function, Reference + Mask values, for both front + back facing primitives.

Public procedure SetStencilFuncSeparate(const face: TGLCullFaceMode; const func: TGLStencilFunction; const ref: TGLint; const mask: Cardinal); inline;

Used to set stencil Function, Reference + Mask values for either the front or back facing primitives (or both, which is the same as calling SetStencilFunc).

Public procedure SetStencilOp(const fail, zfail, zpass: TGLStencilOp); inline;

Used to set the StencilFail, StencilPassDepthFail + StencilPassDepthPass in one go.

Public procedure SetStencilOpSeparate(const face: TGLCullFaceMode; const sfail, dpfail, dppass: TGLStencilOp); inline;

Used to set the StencilFail, StencilPassDepthFail + StencilPassDepthPass in one go, for either front or back facing primitives.

Public procedure SetTextureMatrix(const matrix: TGLMatrix); inline;

Defines the OpenGL texture matrix. Assumed texture mode is GL_MODELVIEW.

Public procedure UnSetGLState(const aState: TGLState); deprecated; inline;

Warning: this symbol is deprecated.

This item has no description.

Properties

Public property ActiveTexture: TGLint read FActiveTexture write SetActiveTexture;

The active texture unit. Valid values are 0 .. Max texture units.

Public property ActiveTextureEnabled[target: TGLTextureTarget]: Boolean read GetActiveTextureEnabled write SetActiveTextureEnabled;

This item has no description.

Public property ArrayBufferBinding: Cardinal read GetArrayBufferBinding write SetArrayBufferBinding;

The currently bound vertex buffer object (VAO)

Public property BlendColor: TGLVector read FBlendColor write SetBlendColor;

A constant blend color, that can be used in the blend equation.

Public property BlendDstAlpha: TGLDstBlendFunction read FBlendDstAlpha;

The weighting factor used in blending equation, for destination alpha.

Public property BlendDstRGB: TGLDstBlendFunction read FBlendDstRGB;

The weighting factor used in blending equation, for destination RGB.

Public property BlendEquationAlpha: TGLBlendEquation read FBlendEquationAlpha;

The blending equation. Determines how the incoming source fragment's alpha values are combined with the destination alpha values.

Public property BlendEquationRGB: TGLBlendEquation read FBlendEquationRGB;

The blending equation. Determines how the incoming source fragment's RGB are combined with the destination RGB.

Public property BlendSrcAlpha: TGLBlendFunction read FBlendSrcAlpha;

The weighting factor used in blending equation, for source alpha.

Public property BlendSrcRGB: TGLBlendFunction read FBlendSrcRGB;

The weighting factor used in blending equation, for source RGB.

Public property ClampReadColor: Cardinal read FClampReadColor write SetClampReadColor;

Coloring state Controls read color clamping

Public property ColorClearValue: TGLVector read FColorClearValue write SetColorClearValue;

The color clear value.

Public property ColorWriteMask[Index: Integer]: TGLColorMask read GetColorWriteMask write SetColorWriteMask;

The color write mask, for each draw buffer.

Public property CopyReadBufferBinding: Cardinal read FCopyReadBufferBinding write SetCopyReadBufferBinding;

The buffer currently bound to the copy read buffer binding point, this is an extra binding point provided so that you don't need to overwrite other binding points to copy between buffers.

Public property CopyWriteBufferBinding: Cardinal read FCopyWriteBufferBinding write SetCopyWriteBufferBinding;

The buffer currently bound to the copy write buffer binding point, this is an extra binding point provided so that you don't need to overwrite other binding points to copy between buffers.

Public property CullFaceMode: TGLCullFaceMode read FCullFaceMode write SetCullFaceMode;

Selects which faces to cull: front, back or front+back

Public property CurrentProgram: Cardinal read FCurrentProgram write SetCurrentProgram;

Currently bound program

Public property CurrentQuery[Index: TGLQueryType]: Cardinal read GetCurrentQuery;

Current queries. Misc

Public property CurrentVertexAttrib[Index: Integer]: TGLVector read GetCurrentVertexAttrib write SetCurrentVertexAttrib;

Default values to be used when a vertex array is not used for that attribute

Public property DepthClearValue: TGLfloat read FDepthClearValue write SetDepthClearValue;

The depth clear value.

Public property DepthFunc: TGLDepthFunction read FDepthFunc write SetDepthFunc;

The depth function. Used to determine whether to keep a fragment or discard it, depending on the current value stored in the depth buffer.

Public property DepthRangeFar: TGLclampd read GetDepthRangeFar write SetDepthRangeFar;

The far clipping plane distance

Public property DepthRangeNear: TGLclampd read GetDepthRangeNear write SetDepthRangeNear;

The near clipping plane distance

Public property DepthWriteMask: TGLboolean read FDepthWriteMask write SetDepthWriteMask;

The depth write mask.

Public property DrawFrameBuffer: Cardinal read FDrawFrameBuffer write SetDrawFrameBuffer;

Framebuffer to be used for draw operations, 0 = default framebuffer.

Public property ElementBufferBinding: Cardinal read GetElementBufferBinding write SetElementBufferBinding;

The currently bound element buffer object (EBO)

Public property EnableBlend[Index: Integer]: TGLboolean read GetEnableBlend write SetEnableBlend;

Enables/disables blending for each draw buffer.

Public property EnableClipDistance[Index: Cardinal]: TGLboolean read GetEnableClipDistance write SetEnableClipDistance;

Enables/Disables each of the clip distances, used in shaders

Public property EnableColorLogicOp: TGLboolean read FEnableColorLogicOp write SetEnableColorLogicOp;

Enables/disables color logic op.

Public property EnableCullFace: TGLboolean read FEnableCullFace write SetEnableCullFace;

Enable/Disable face culling

Public property EnableDepthClamp: TGLboolean read FEnableDepthClamp write SetEnableDepthClamp;

Enables/Disables depth clamping

Public property EnableDepthTest: TGLboolean read FEnableDepthTest write SetEnableDepthTest;

Enables/disables depth testing.

Public property EnableDither: TGLboolean read FEnableDither write SetEnableDither;

Enables/disables dithering.

Public property EnableFramebufferSRGB: TGLboolean read FEnableFramebufferSRGB write SetEnableFramebufferSRGB;

Enables/disables framebuffer SRGB.

Public property EnableLineSmooth: TGLboolean read FEnableLineSmooth write SetEnableLineSmooth;

Enable/Disable line smoothing

Public property EnableMultisample: TGLboolean read FEnableMultisample write SetEnableMultisample;

Multisample state Enable/Disable multisampling

Public property EnablePolygonOffsetFill: TGLboolean read FEnablePolygonOffsetFill write SetEnablePolygonOffsetFill;

Enable/Disable polygon offset for polygons in fill mode

Public property EnablePolygonOffsetLine: TGLboolean read FEnablePolygonOffsetLine write SetEnablePolygonOffsetLine;

Enable/Disable polygon offset for polygons in line mode

Public property EnablePolygonOffsetPoint: TGLboolean read FEnablePolygonOffsetPoint write SetEnablePolygonOffsetPoint;

Enable/Disable polygon offset for polygons in point mode

Public property EnablePolygonSmooth: TGLboolean read FEnablePolygonSmooth write SetEnablePolygonSmooth;

Enables/Disables polygon smoothing.

Public property EnablePrimitiveRestart: TGLboolean read GetEnablePrimitiveRestart write SetEnablePrimitiveRestart;

Determines whether primitive restart is turned on or off

Public property EnableProgramPointSize: TGLboolean read FEnableProgramPointSize write SetEnableProgramPointSize;

Enables/disables program point size

Public property EnableSampleAlphaToCoverage: TGLboolean read FEnableSampleAlphaToCoverage write SetEnableSampleAlphaToCoverage;

Enable/Disable sample alpha to coverage

Public property EnableSampleAlphaToOne: TGLboolean read FEnableSampleAlphaToOne write SetEnableSampleAlphaToOne;

Enable/Disable sample alpha to one

Public property EnableSampleCoverage: TGLboolean read FEnableSampleCoverage write SetEnableSampleCoverage;

Enable/Disable sample coverage

Public property EnableSampleMask: TGLboolean read FEnableSampleMask write SetEnableSampleMask;

Enable/Disable sample mask

Public property EnableScissorTest: TGLboolean read FEnableScissorTest write SetEnableScissorTest;

Enables/Disables scissor test.

Public property EnableStencilTest: TGLboolean read FEnableStencilTest write SetEnableStencilTest;

Enables/Disables stencil test.

Public property EnableTextureCubeMapSeamless: TGLboolean read FEnableTextureCubeMapSeamless write SetEnableTextureCubeMapSeamless;

Enables/Disables seamless texture cube maps

Public property FixedFunctionPipeLight: Boolean read FFFPLight write SetFFPLight;

Lighting states

Public property FragmentShaderDerivitiveHint: TGLHintType read FFragmentShaderDerivitiveHint write SetFragmentShaderDerivitiveHint;

Fragment shader derivitive hint

Public property FrontFace: TGLFaceWinding read FFrontFace write SetFrontFace;

The winding direction that indicates a front facing primitive

Public property InsideList: Boolean read FInsideList;

Indicates the current presence within the list

Public property LightAmbient[Index: Integer]: TGLVector read GetLightAmbient write SetLightAmbient;

This item has no description.

Public property LightConstantAtten[Index: Integer]: Single read GetConstantAtten write SetConstantAtten;

This item has no description.

Public property LightDiffuse[Index: Integer]: TGLVector read GetLightDiffuse write SetLightDiffuse;

This item has no description.

Public property LightEnabling[Index: Integer]: Boolean read GetLightEnabling write SetLightEnabling;

This item has no description.

Public property LightLinearAtten[Index: Integer]: Single read GetLinearAtten write SetLinearAtten;

This item has no description.

Public property LightNumber: Integer read FLightNumber;

This item has no description.

Public property LightPosition[Index: Integer]: TGLVector read GetLightPosition write SetLightPosition;

This item has no description.

Public property LightQuadraticAtten[Index: Integer]: Single read GetQuadAtten write SetQuadAtten;

This item has no description.

Public property LightSpecular[Index: Integer]: TGLVector read GetLightSpecular write SetLightSpecular;

This item has no description.

Public property LightSpotCutoff[Index: Integer]: Single read GetSpotCutoff write SetSpotCutoff;

This item has no description.

Public property LightSpotDirection[Index: Integer]: TAffineVector read GetLightSpotDirection write SetLightSpotDirection;

This item has no description.

Public property LightSpotExponent[Index: Integer]: Single read GetSpotExponent write SetSpotExponent;

This item has no description.

Public property LineSmoothHint: TGLHintType read FLineSmoothHint write SetLineSmoothHint;

Line smooth hint

Public property LineStippleFactor: TGLint read FLineStippleFactor write SetLineStippleFactor;

The line stipple

Public property LineStipplePattern: TGLushort read FLineStipplePattern write SetLineStipplePattern;

The line stipple

Public property LineWidth: TGLfloat read FLineWidth write SetLineWidth;

The line width

Public property LogicOpMode: TGLLogicOp read FLogicOpMode write SetLogicOpMode;

Logic op mode.

Public property MaterialAmbient[const aFace: TGLCullFaceMode]: TGLVector read GetMaterialAmbient;

This item has no description.

Public property MaterialDiffuse[const aFace: TGLCullFaceMode]: TGLVector read GetMaterialDiffuse;

This item has no description.

Public property MaterialEmission[const aFace: TGLCullFaceMode]: TGLVector read GetMaterialEmission;

This item has no description.

Public property MaterialShininess[const aFace: TGLCullFaceMode]: Integer read GetMaterialShininess;

This item has no description.

Public property MaterialSpecular[const aFace: TGLCullFaceMode]: TGLVector read GetMaterialSpecular;

This item has no description.

Public property Max3DTextureSize: Cardinal read GetMax3DTextureSize;

This item has no description.

Public property MaxArrayTextureSize: Cardinal read GetMaxArrayTextureSize;

This item has no description.

Public property MaxCubeTextureSize: Cardinal read GetMaxCubeTextureSize;

This item has no description.

Public property MaxLights: Integer read GetMaxLights;

This item has no description.

Public property MaxSamples: Cardinal read GetMaxSamples;

This item has no description.

Public property MaxTextureAnisotropy: Cardinal read GetMaxTextureAnisotropy;

This item has no description.

Public property MaxTextureImageUnits: Cardinal read GetMaxTextureImageUnits;

This item has no description.

Public property MaxTextureSize: Cardinal read GetMaxTextureSize;

This item has no description.

Public property MaxTextureUnits: Cardinal read GetMaxTextureUnits;

This item has no description.

Public property MultisampleFilterHint: TGLHintType read FMultisampleFilterHint write SetMultisampleFilterHint;

This item has no description.

Public property OnLightsChanged: TGLOnLightsChanged read FOnLightsChanged write FOnLightsChanged;

This item has no description.

Public property PackAlignment: Cardinal read FPackAlignment write SetPackAlignment;

Pack alignment

Public property PackImageHeight: Cardinal read FPackImageHeight write SetPackImageHeight;

Pack image height

Public property PackLSBFirst: TGLboolean read FPackLSBFirst write SetPackLSBFirst;

Whether packed data is required with LSB (least significant bit) first

Public property PackRowLength: Cardinal read FPackRowLength write SetPackRowLength;

Pack row length

Public property PackSkipImages: Cardinal read FPackSkipImages write SetPackSkipImages;

Pack skip images

Public property PackSkipPixels: Cardinal read FPackSkipPixels write SetPackSkipPixels;

Pack skip pixels

Public property PackSkipRows: Cardinal read FPackSkipRows write SetPackSkipRows;

Pack skip rows

Public property PackSwapBytes: TGLboolean read FPackSwapBytes write SetPackSwapBytes;

Controls whether byte swapping occurs during pixel packing

Public property PixelPackBufferBinding: Cardinal read FPixelPackBufferBinding write SetPixelPackBufferBinding;

Buffer bound for pixel packing (eg. ReadPixels)

Public property PixelUnpackBufferBinding: Cardinal read FPixelUnpackBufferBinding write SetPixelUnpackBufferBinding;

Buffer bound for pixel unpacking (eg. Tex*Image)

Public property PointFadeThresholdSize: TGLfloat read FPointFadeThresholdSize write SetPointFadeThresholdSize;

If multisampling is enabled, this can control when points are faded out

Public property PointSize: TGLfloat read FPointSize write SetPointSize;

The default point size, used when EnableProgramPointSize = false

Public property PointSpriteCoordOrigin: Cardinal read FPointSpriteCoordOrigin write SetPointSpriteCoordOrigin;

The texture coordinate origin of point sprites

Public property PolygonMode: TGLPolygonMode read FPolygonMode write SetPolygonMode;

Whether polygons appear filled, lines or points

Public property PolygonOffsetFactor: TGLfloat read FPolygonOffsetFactor write SetPolygonOffsetFactor;

Scales the maximum depth of the polygon

Public property PolygonOffsetUnits: TGLfloat read FPolygonOffsetUnits write SetPolygonOffsetUnits;

Scales an implementation-dependent constant that relates to the usable resolution of the depth buffer

Public property PolygonSmoothHint: TGLHintType read FPolygonSmoothHint write SetPolygonSmoothHint;

Polygon smooth hint

Public property PrimitiveRestartIndex: Cardinal read GetPrimitiveRestartIndex write SetPrimitiveRestartIndex;

The index Value that causes a primitive restart

Public property ProvokingVertex: Cardinal read FProvokingVertex write SetProvokingVertex;

The provoking vertex used in flat shading. All the vertices of each primitive will the same value determined by this property.

Public property ReadFrameBuffer: Cardinal read FReadFrameBuffer write SetReadFrameBuffer;

Framebuffer to be used for read operations, 0 = default framebuffer.

Public property RenderBuffer: Cardinal read FRenderBuffer write SetRenderBuffer;

property FrameBuffer: Cardinal read FDrawFrameBuffer write SetFrameBuffer; Renderbuffer currently bound render buffer.

Public property SampleCoverageInvert: TGLboolean read FSampleCoverageInvert write SetSampleCoverageInvert;

Inverts sample coverage Value

Public property SampleCoverageValue: TGLfloat read FSampleCoverageValue write SetSampleCoverageValue;

Sample coverage Value

Public property SampleMaskValue[Index: Integer]: TGLbitfield read GetSampleMaskValue write SetSampleMaskValue;

Sample mask values

Public property SamplerBinding[Index: Cardinal]: Cardinal read GetSamplerBinding write SetSamplerBinding;

This item has no description.

Public property ScissorBox: TVector4i read FScissorBox write SetScissorBox;

The bounding box used in scissor test.

Public property States: TGLStates read FStates;

read only properties

Public property StencilBackFail: TGLStencilOp read FStencilBackFail;

The operation to perform when stencil test fails on back facing primitives.

Public property StencilBackFunc: TGLStencilFunction read FStencilBackFunc;

The stencil back function. Determines the comparison function to be used when comparing the reference + stored stencil values on back facing primitives.

Public property StencilBackPassDepthFail: TGLStencilOp read FStencilBackPassDepthFail;

The operation to perform when stencil test passes + depth test fails on back facing primitives.

Public property StencilBackPassDepthPass: TGLStencilOp read FStencilBackPassDepthPass;

The operation to perform when stencil test passes + depth test passes on back facing primitives.

Public property StencilBackRef: Cardinal read FStencilBackRef;

The stencil back reference value. Clamped to 0..255 with an 8 bit stencil.

Public property StencilBackValueMask: Cardinal read FStencilBackValueMask;

The stencil back value mask. Masks both the reference + stored stencil values.

Public property StencilBackWriteMask: Cardinal read FStencilBackWriteMask write SetStencilBackWriteMask;

The stencil back write mask.

Public property StencilClearValue: Cardinal read FStencilClearValue write SetStencilClearValue;

The stencil clear value.

Public property StencilFail: TGLStencilOp read FStencilFail;

write SetStencilRef; The operation to perform when stencil test fails.

Public property StencilFunc: TGLStencilFunction read FStencilFunc;

The stencil function. Determines the comparison function to be used when comparing the reference + stored stencil values.

Public property StencilPassDepthFail: TGLStencilOp read FStencilPassDepthFail;

write SetStencilFail; The operation to perform when stencil test passes + depth test fails.

Public property StencilPassDepthPass: TGLStencilOp read FStencilPassDepthPass;

The operation to perform when stencil test passes + depth test passes.

Public property StencilRef: TGLint read FStencilRef;

The stencil reference value. Clamped to 0..255 with an 8 bit stencil.

Public property StencilValueMask: Cardinal read FStencilValueMask;

The stencil value mask. Masks both the reference + stored stencil values

Public property StencilWriteMask: Cardinal read FStencilWriteMask write SetStencilWriteMask;

The stencil write mask.

Public property TextureBinding[Index: Integer; target: TGLTextureTarget]: Cardinal read GetTextureBinding write SetTextureBinding;

Textures Textures bound to each texture unit + binding point.

Public property TextureBindingTime[Index: Integer; target: TGLTextureTarget]: Double read GetTextureBindingTime;

This item has no description.

Public property TextureBufferBinding: Cardinal read FTextureBufferBinding write SetTextureBufferBinding;

The currently bound texture buffer object (TBO)

Public property TextureCompressionHint: TGLHintType read FTextureCompressionHint write SetTextureCompressionHint;

Texture compression hint

Public property TransformFeedbackBufferBinding: Cardinal read FTransformFeedbackBufferBinding write SetTransformFeedbackBufferBinding;

Currently bound transform feedbac buffer

Public property UniformBufferBinding: Cardinal read FUniformBufferBinding write SetUniformBufferBinding;

Currently bound uniform buffer

Public property UnpackAlignment: Cardinal read FUnpackAlignment write SetUnpackAlignment;

Unpack alignment

Public property UnpackImageHeight: Cardinal read FUnpackImageHeight write SetUnpackImageHeight;

Unpack image height

Public property UnpackLSBFirst: TGLboolean read FUnpackLSBFirst write SetUnpackLSBFirst;

Whether unpacked data is required with LSB (least significant bit) first.

Public property UnpackRowLength: Cardinal read FUnpackRowLength write SetUnpackRowLength;

Unpack row length

Public property UnpackSkipImages: Cardinal read FUnpackSkipImages write SetUnpackSkipImages;

Unpack skip images

Public property UnpackSkipPixels: Cardinal read FUnpackSkipPixels write SetUnpackSkipPixels;

Unpack skip pixels

Public property UnpackSkipRows: Cardinal read FUnpackSkipRows write SetUnpackSkipRows;

Unpack skip rows

Public property UnpackSwapBytes: TGLboolean read FUnpackSwapBytes write SetUnpackSwapBytes;

Controls whether byte swapping occurs during pixel unpacking.

Public property VertexArrayBinding: Cardinal read FVertexArrayBinding write SetVertexArrayBinding;

The currently bound array buffer (calling glVertexAttribPointer locks this buffer to the currently bound VBO).

Public property ViewPort: TVector4i read FViewPort write SetViewPort;

Transformation state


GLSysHelp v.2.5: GLS.State: Record TStateRecord

Record TStateRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.State

Declaration

type TStateRecord = record

Description

This item has no description.

Overview

Fields

Public | GLConst: Cardinal;
Public | GLDeprecated: Boolean;

Description

Fields

Public GLConst: Cardinal;

This item has no description.

Public GLDeprecated: Boolean;


GLSysHelp v.2.5: GLS.TerrainRenderer

Unit GLS.TerrainRenderer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.Coordinates
  • GLS.HeightData
  • GLS.Material
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.ROAMPatch
  • GLS.VectorLists
  • GLS.RenderContextInfo
  • GLS.XOpenGL
  • GLScene.Utils
  • GLScene.VectorTypes
  • GLS.Texture

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTerrainRenderer |

Types

TGetTerrainBoundsEvent = procedure(var l, t, r, b: Single) of object;
TGLHeightDataPostRenderEvent = procedure(var rci: TGLRenderContextInfo; var HeightDatas: TList) of object;
TMaxCLODTrianglesReachedEvent = procedure(var rci: TGLRenderContextInfo) of object;
TPatchPostRenderEvent = procedure(var rci: TGLRenderContextInfo; const patches: TList) of object;
TTerrainHighResStyle = (...);
TTerrainOcclusionTesselate = (...);
TTileManagementFlag = (...);
TTileManagementFlags = set of TTileManagementFlag;

Constants

cTilesHashSize = 255;

Description

Types

TGetTerrainBoundsEvent = procedure(var l, t, r, b: Single) of object;

This item has no description.

TGLHeightDataPostRenderEvent = procedure(var rci: TGLRenderContextInfo; var HeightDatas: TList) of object;

This item has no description.

TMaxCLODTrianglesReachedEvent = procedure(var rci: TGLRenderContextInfo) of object;

This item has no description.

TPatchPostRenderEvent = procedure(var rci: TGLRenderContextInfo; const patches: TList) of object;

This item has no description.

TTerrainHighResStyle = (...);

This item has no description.

Values
  • hrsFullGeometry
  • hrsTesselated
TTerrainOcclusionTesselate = (...);

This item has no description.

Values
  • totTesselateAlways
  • totTesselateIfVisible
TTileManagementFlag = (...);

This item has no description.

Values
  • tmClearUsedFlags
  • tmMarkUsedTiles
  • tmReleaseUnusedTiles
  • tmAllocateNewTiles
  • tmWaitForPreparing
TTileManagementFlags = set of TTileManagementFlag;

This item has no description.

Constants

cTilesHashSize = 255;


GLSysHelp v.2.5: GLS.TerrainRenderer: Class TGLTerrainRenderer

Class TGLTerrainRenderer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TerrainRenderer

Declaration

type TGLTerrainRenderer = class(TGLSceneObject)

Description

Basic terrain renderer. This renderer uses no sophisticated meshing, it just builds and maintains a set of terrain tiles, performs basic visibility culling and renders its stuff. You can use it has a base class/sample for more specialized terrain renderers. The Terrain heightdata is retrieved directly from a TGLHeightDataSource, and expressed as z=f(x, y) data.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTerrainRenderer

Overview

Fields

Private | FHeightDataSource: TGLHeightDataSource;
Private | FTileSize: Integer;
Private | FQualityDistance: Single;
Private | FinvTileSize: Single;
Private | FLastTriangleCount: Integer;
Private | FTilesPerTexture: Single;
Private | FMaxCLODTriangles: Integer;
Private | FCLODPrecision: Integer;
Private | FBufferVertices: TGLAffineVectorList;
Private | FBufferTexPoints: TGLTexPointList;
Private | FBufferVertexIndices: TGLIntegerList;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FOnGetTerrainBounds: TGetTerrainBoundsEvent;
Private | FOnPatchPostRender: TPatchPostRenderEvent;
Private | FOnHeightDataPostRender: TGLHeightDataPostRenderEvent;
Private | FOnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent;
Private | FQualityStyle: TTerrainHighResStyle;
Private | FOcclusionFrameSkip: Integer;
Private | FOcclusionTesselate: TTerrainOcclusionTesselate;
Private | FContourInterval: Integer;
Private | FContourWidth: Integer;
Public | TileManagement: TTileManagementFlags;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function HashedTileCount: Integer;
Public | function InterpolatedHeight(const p: TGLVector): Single; overload;
Public | function InterpolatedHeight(const p: TAffineVector): Single; overload;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;

Properties

Published | property CLODPrecision: Integer read FCLODPrecision write SetCLODPrecision default 100;
Published | property ContourInterval: Integer read FContourInterval write FContourInterval default 0;
Published | property ContourWidth: Integer read FContourWidth write FContourWidth default 1;
Published | property HeightDataSource: TGLHeightDataSource read FHeightDataSource write SetHeightDataSource;
Public | property LastTriangleCount: Integer read FLastTriangleCount;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MaxCLODTriangles: Integer read FMaxCLODTriangles write FMaxCLODTriangles default 65536;
Published | property OcclusionFrameSkip: Integer read FOcclusionFrameSkip write SetOcclusionFrameSkip default 0;
Published | property OcclusionTesselate: TTerrainOcclusionTesselate read FOcclusionTesselate write FOcclusionTesselate default totTesselateIfVisible;
Published | property OnGetTerrainBounds: TGetTerrainBoundsEvent read FOnGetTerrainBounds write FOnGetTerrainBounds;
Published | property OnHeightDataPostRender: TGLHeightDataPostRenderEvent read FOnHeightDataPostRender write FOnHeightDataPostRender;
Published | property OnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent read FOnMaxCLODTrianglesReached write FOnMaxCLODTrianglesReached;
Published | property OnPatchPostRender: TPatchPostRenderEvent read FOnPatchPostRender write FOnPatchPostRender;
Published | property QualityDistance: Single read FQualityDistance write FQualityDistance;
Published | property QualityStyle: TTerrainHighResStyle read FQualityStyle write SetQualityStyle default hrsFullGeometry;
Published | property TileSize: Integer read FTileSize write SetTileSize default 16;
Published | property TilesPerTexture: Single read FTilesPerTexture write SetTilesPerTexture;

Description

Fields

Private FHeightDataSource: TGLHeightDataSource;

This item has no description.

Private FTileSize: Integer;

This item has no description.

Private FQualityDistance: Single;

This item has no description.

Private FinvTileSize: Single;

This item has no description.

Private FLastTriangleCount: Integer;

This item has no description.

Private FTilesPerTexture: Single;

This item has no description.

Private FMaxCLODTriangles: Integer;

This item has no description.

Private FCLODPrecision: Integer;

This item has no description.

Private FBufferVertices: TGLAffineVectorList;

This item has no description.

Private FBufferTexPoints: TGLTexPointList;

This item has no description.

Private FBufferVertexIndices: TGLIntegerList;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FOnGetTerrainBounds: TGetTerrainBoundsEvent;

This item has no description.

Private FOnPatchPostRender: TPatchPostRenderEvent;

This item has no description.

Private FOnHeightDataPostRender: TGLHeightDataPostRenderEvent;

This item has no description.

Private FOnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent;

This item has no description.

Private FQualityStyle: TTerrainHighResStyle;

This item has no description.

Private FOcclusionFrameSkip: Integer;

This item has no description.

Private FOcclusionTesselate: TTerrainOcclusionTesselate;

This item has no description.

Private FContourInterval: Integer;

This item has no description.

Private FContourWidth: Integer;

This item has no description.

Public TileManagement: TTileManagementFlags;

TileManagement flags can be used to turn off various Tile cache management features. This helps to prevent unnecessary tile cache flushes, when rendering from multiple cameras

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function HashedTileCount: Integer;

This item has no description.

Public function InterpolatedHeight(const p: TGLVector): Single; overload;

Interpolates height for the given point. Expects a point expressed in absolute coordinates.

Public function InterpolatedHeight(const p: TAffineVector): Single; overload;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property CLODPrecision: Integer read FCLODPrecision write SetCLODPrecision default 100;

Precision of CLOD tiles. The lower the value, the higher the precision and triangle count. Large values will result in coarse terrain. high-resolution tiles (closer than QualityDistance) ignore this setting.

Published property ContourInterval: Integer read FContourInterval write FContourInterval default 0;

Distance between contours - zero (default) for no contours PGS

Published property ContourWidth: Integer read FContourWidth write FContourWidth default 1;

Width of Isolines

Published property HeightDataSource: TGLHeightDataSource read FHeightDataSource write SetHeightDataSource;

Specifies the HeightData provider component.

Public property LastTriangleCount: Integer read FLastTriangleCount;

Triangle count for the last render

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Link to the material library holding terrain materials. If unspecified, and for all terrain tiles with unspecified material, the terrain renderer's material is used.

Published property MaxCLODTriangles: Integer read FMaxCLODTriangles write FMaxCLODTriangles default 65536;

Maximum number of CLOD triangles per scene. Triangles in high-resolution tiles (closer than QualityDistance) do not count toward this limit.

Published property OcclusionFrameSkip: Integer read FOcclusionFrameSkip write SetOcclusionFrameSkip default 0;

Numbers of frames to skip for a tile when occlusion testing found it invisible. Occlusion testing can help reduce CPU, T&L and fillrate requirements when tiles are occluded, either by the terrain itself (tiles behind a mountain or a cliff) or by geometry that was rendered before the terrain (large buildings). If there is little occlusion in your scene (such as in top down or high-altitude view), turning occlusion on may have a slightly negative effect on framerate. It works by turning off rendering of tiles for the specified number of frames if it has been found invisible, after FrameSkip number of frames have been skipped, it will be rendered again, and a new occlusion testing made. This makes occlusion-testing a frame-to-frame coherency optimization, and as such, shouldn't be used for static rendering (ie. leave value to its default of zero). This optimization requires the hardware to support GL_NV_occlusion_query

Published property OcclusionTesselate: TTerrainOcclusionTesselate read FOcclusionTesselate write FOcclusionTesselate default totTesselateIfVisible;

Determines if and how occlusion testing affects tesselation. Turning off tesselation of tiles determined invisible can improve performance, however, it may result in glitches since the tesselation of an invisible tile can have a slight effect on the tesselation of its adjacent tiles (by forcing higher resolution at the border for instance). This negative effect can be lessened by increasing the QualityDistance, so that glitches will appear farther away (this will mean increasing your triangle count though, so you'll trade CPU power against T&L power).

Published property OnGetTerrainBounds: TGetTerrainBoundsEvent read FOnGetTerrainBounds write FOnGetTerrainBounds;

Allows to specify terrain bounds. Default rendering bounds will reach depth of view in all direction, with this event you can chose to specify a smaller rendered terrain area

Published property OnHeightDataPostRender: TGLHeightDataPostRenderEvent read FOnHeightDataPostRender write FOnHeightDataPostRender;

Invoked for each heightData not culled out by the terrain renderer. The list holds TGLHeightData objects and allows per-patch post-processings, like waters, trees... It is invoked *after* OnPatchPostRender.

Published property OnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent read FOnMaxCLODTrianglesReached write FOnMaxCLODTrianglesReached;

Invoked whenever the MaxCLODTriangles limit was reached during last rendering. This forced the terrain renderer to resize the buffer, which affects performance. If this event is fired frequently, one should increase MaxCLODTriangles.

Published property OnPatchPostRender: TPatchPostRenderEvent read FOnPatchPostRender write FOnPatchPostRender;

Invoked for each rendered patch after terrain render has completed. The list holds TGLROAMPatch objects and allows per-patch post-processings, like waters, trees... It is invoked *before* OnHeightDataPostRender.

Published property QualityDistance: Single read FQualityDistance write FQualityDistance;

Quality distance hint. This parameter gives an hint to the terrain renderer at which distance the terrain quality can be degraded to favor speed. The distance is expressed in absolute coordinates units. All tiles closer than this distance are rendered according to QualityStyle and with a static resolution.

Published property QualityStyle: TTerrainHighResStyle read FQualityStyle write SetQualityStyle default hrsFullGeometry;

Determines how high-res tiles (closer than QualityDistance) are rendered. hrsFullGeometry (default value) means that the high-res tiles are rendered with full-geometry, and no LOD of any kind, while hrsTesselated means the tiles will be tesselated once, with the best output for the CLODPrecision, and the result of that tesselation will be reused in further frames without any adpative tesselation.

Published property TileSize: Integer read FTileSize write SetTileSize default 16;

Size of the terrain tiles. Must be a power of two.

Published property TilesPerTexture: Single read FTilesPerTexture write SetTilesPerTexture;

Number of tiles required for a full texture map.


GLSysHelp v.2.5: GLS.TexLensFlare

Unit GLS.TexLensFlare

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GLS.Scene
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLS.Objects
  • GLS.Texture
  • GLScene.OpenGLTokens
  • GLS.Context
  • GLS.RenderContextInfo
  • GLS.BaseClasses
  • GLS.State
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextureLensFlare |


GLSysHelp v.2.5: GLS.TexLensFlare: Class TGLTextureLensFlare

Class TGLTextureLensFlare

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TexLensFlare

Declaration

type TGLTextureLensFlare = class(TGLBaseSceneObject)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLTextureLensFlare

Overview

Fields

Private | FSize: integer;
Private | FCurrSize: Single;
Private | FNumSecs: integer;
Private | FAutoZTest: boolean;
Private | FDeltaTime: Double;
Private | FImgSecondaries: TGLTexture;
Private | FImgRays: TGLTexture;
Private | FImgRing: TGLTexture;
Private | FImgGlow: TGLTexture;
Private | FSeed: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Private | procedure SetImgGlow(const Value: TGLTexture);
Private | procedure SetImgRays(const Value: TGLTexture);
Private | procedure SetImgRing(const Value: TGLTexture);
Private | procedure SetImgSecondaries(const Value: TGLTexture);
Private | procedure SetSeed(const Value: Integer);

Properties

Published | property AutoZTest: boolean read FAutoZTest write SetAutoZTest default True;
Published | property Behaviours;
Published | property Effects;
Published | property ImgGlow: TGLTexture read FImgGlow write SetImgGlow;
Published | property ImgRays: TGLTexture read FImgRays write SetImgRays;
Published | property ImgRing: TGLTexture read FImgRing write SetImgRing;
Published | property ImgSecondaries: TGLTexture read FImgSecondaries write SetImgSecondaries;
Published | property NumSecs: integer read FNumSecs write SetNumSecs default 8;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Position;
Published | property Seed: Integer read FSeed write SetSeed;
Published | property Size: integer read FSize write SetSize default 50;
Published | property Visible;

Description

Fields

Private FSize: integer;

This item has no description.

Private FCurrSize: Single;

This item has no description.

Private FNumSecs: integer;

This item has no description.

Private FAutoZTest: boolean;

This item has no description.

Private FDeltaTime: Double;

used for internal calculation

Private FImgSecondaries: TGLTexture;

This item has no description.

Private FImgRays: TGLTexture;

This item has no description.

Private FImgRing: TGLTexture;

This item has no description.

Private FImgGlow: TGLTexture;

This item has no description.

Private FSeed: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Private procedure SetImgGlow(const Value: TGLTexture);

This item has no description.

Private procedure SetImgRays(const Value: TGLTexture);

This item has no description.

Private procedure SetImgRing(const Value: TGLTexture);

This item has no description.

Private procedure SetImgSecondaries(const Value: TGLTexture);

This item has no description.

Private procedure SetSeed(const Value: Integer);

This item has no description.

Properties

Published property AutoZTest: boolean read FAutoZTest write SetAutoZTest default True;

Number of segments used when rendering circles. property Resolution: integer read FResolution write SetResolution default 64;

Published property Behaviours;

This item has no description.

Published property Effects;

This item has no description.

Published property ImgGlow: TGLTexture read FImgGlow write SetImgGlow;

The Textures

Published property ImgRays: TGLTexture read FImgRays write SetImgRays;

This item has no description.

Published property ImgRing: TGLTexture read FImgRing write SetImgRing;

This item has no description.

Published property ImgSecondaries: TGLTexture read FImgSecondaries write SetImgSecondaries;

This item has no description.

Published property NumSecs: integer read FNumSecs write SetNumSecs default 8;

Number of secondary flares.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Position;

This item has no description.

Published property Seed: Integer read FSeed write SetSeed;

Random seed

Published property Size: integer read FSize write SetSize default 50;

MaxRadius of the flare.

Published property Visible;


GLSysHelp v.2.5: GLS.Texture

Unit GLS.Texture

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • Vcl.Graphics
  • Vcl.Imaging.jpeg
  • Vcl.Imaging.pngimage
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.BaseClasses
  • GLS.Graphics
  • GLS.Context
  • GLS.State
  • GLS.Color
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLS.PersistentClasses
  • GLScene.PipelineTransform
  • GLS.ImageUtils
  • GLScene.TextureFormat
  • GLS.ApplicationFileIO
  • GLScene.Utils
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IGLTextureNotifyAble |
Class TGLTextureImage |
Class TGLBlankImage |
Class TGLPictureImage |
Class TGLPersistentImage |
Class TGLPicFileImage |
Class TGLCubeMapImage |
Class TGLTexture |
Class TGLTextureExItem |
Class TGLTextureEx |
Class ETexture |
Class EGLShaderException |

Functions and Procedures

procedure RegisterGLTextureImageClass(textureImageClass: TGLTextureImageClass);
function FindGLTextureImageClass(const className: string): TGLTextureImageClass;
function FindGLTextureImageClassByFriendlyName(const friendlyName: string): TGLTextureImageClass;
procedure SetGLTextureImageClassesToStrings(aStrings: TStrings);
function GetGLTextureImageClassesAsStrings: TStrings;
procedure RegisterTGraphicClassFileExtension(const extension: string; const aClass: TGraphicClass);
function CreateGraphicFromFile(const fileName: string): TGraphic;

Types

TGLCubeMapTarget = Integer;
TGLDepthCompareFunc = TGLDepthFunction;
TGLDepthTextureMode = (...);
TGLMagFilter = (...);
TGLMinFilter = (...);
TGLTextureChange = (...);
TGLTextureChanges = set of TGLTextureChange;
TGLTextureCompression = TGLInternalCompression;
TGLTextureFormat = (...);
TGLTextureImageAlpha = (...);
TGLTextureImageClass = class of TGLTextureImage;
TGLTextureMappingMode = (...);
TGLTextureMode = (...);
TGLTextureNeededEvent = procedure(Sender: TObject; var textureFileName: string) of object;
TGLTextureWrap = (...);

Constants

cDefaultNormalMapScale = 0.125;
CmtPX = 0;
CmtNX = 1;
CmtPY = 2;
CmtNY = 3;
CmtPZ = 4;
CmtNZ = 5;

Description

Functions and Procedures

procedure RegisterGLTextureImageClass(textureImageClass: TGLTextureImageClass);

Register a TGLTextureImageClass (used for persistence and IDE purposes)

function FindGLTextureImageClass(const className: string): TGLTextureImageClass;

Finds a registerer TGLTextureImageClass using its classname

function FindGLTextureImageClassByFriendlyName(const friendlyName: string): TGLTextureImageClass;

Finds a registerer TGLTextureImageClass using its FriendlyName

procedure SetGLTextureImageClassesToStrings(aStrings: TStrings);

Defines a TStrings with the list of registered TGLTextureImageClass.

function GetGLTextureImageClassesAsStrings: TStrings;

Creates a TStrings with the list of registered TGLTextureImageClass. To be freed by caller.

procedure RegisterTGraphicClassFileExtension(const extension: string; const aClass: TGraphicClass);

This item has no description.

function CreateGraphicFromFile(const fileName: string): TGraphic;

This item has no description.

Types

TGLCubeMapTarget = Integer;

This item has no description.

TGLDepthCompareFunc = TGLDepthFunction;

Specifies the depth comparison function.

TGLDepthTextureMode = (...);

Specifies how depth values should be treated during filtering and texture application

Values
  • dtmLuminance
  • dtmIntensity
  • dtmAlpha
TGLMagFilter = (...);

This item has no description.

Values
  • maNearest
  • maLinear
TGLMinFilter = (...);

This item has no description.

Values
  • miNearest
  • miLinear
  • miNearestMipmapNearest
  • miLinearMipmapNearest
  • miNearestMipmapLinear
  • miLinearMipmapLinear
TGLTextureChange = (...);

This item has no description.

Values
  • tcImage
  • tcParams
TGLTextureChanges = set of TGLTextureChange;

This item has no description.

TGLTextureCompression = TGLInternalCompression;

This item has no description.

TGLTextureFormat = (...);

Texture format for OpenGL (rendering) use. Internally, GLScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:

Values
  • tfDefault
  • tfRGB
  • tfRGBA: = tfRGB8
  • tfRGB16: = tfRGBA8
  • tfRGBA16: = tfRGB5
  • tfAlpha: = tfRGBA4
  • tfLuminance: = tfALPHA8
  • tfLuminanceAlpha: = tfLUMINANCE8
  • tfIntensity: = tfLUMINANCE8_ALPHA8
  • tfNormalMap: = tfINTENSITY8
  • tfRGBAFloat16: = tfRGB8
  • tfRGBAFloat32: = tfRGBA_FLOAT16_ATI
  • tfExtended: = tfRGBA_FLOAT32_ATI
TGLTextureImageAlpha = (...);

Defines how and if Alpha channel is defined for a texture image. tiaDefault : uses the alpha channel in the image if any tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) tiaOpaque : alpha channel is uniformously set to 1.0 tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque.

Values
  • tiaDefault
  • tiaAlphaFromIntensity
  • tiaSuperBlackTransparent
  • tiaLuminance
  • tiaLuminanceSqrt
  • tiaOpaque
  • tiaTopLeftPointColorTransparent
  • tiaInverseLuminance
  • tiaInverseLuminanceSqrt
  • tiaBottomRightPointColorTransparent
TGLTextureImageClass = class of TGLTextureImage;

This item has no description.

TGLTextureMappingMode = (...);

This item has no description.

Values
  • tmmUser
  • tmmObjectLinear
  • tmmEyeLinear
  • tmmSphere
  • tmmCubeMapReflection
  • tmmCubeMapNormal
  • tmmCubeMapLight0
  • tmmCubeMapCamera
TGLTextureMode = (...);

This item has no description.

Values
  • tmDecal
  • tmModulate
  • tmBlend
  • tmReplace
  • tmAdd
TGLTextureNeededEvent = procedure(Sender: TObject; var textureFileName: string) of object;

This item has no description.

TGLTextureWrap = (...);

This item has no description.

Values
  • twBoth
  • twNone
  • twVertical
  • twHorizontal
  • twSeparate

Constants

cDefaultNormalMapScale = 0.125;

This item has no description.

CmtPX = 0;

This item has no description.

CmtNX = 1;

This item has no description.

CmtPY = 2;

This item has no description.

CmtNY = 3;

This item has no description.

CmtPZ = 4;

This item has no description.

CmtNZ = 5;


GLSysHelp v.2.5: GLS.Texture: Interface IGLTextureNotifyAble

Interface IGLTextureNotifyAble

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type IGLTextureNotifyAble = interface(IGLNotifyAble)

Description

This item has no description.

Hierarchy

  • IGLNotifyAble
  • IGLTextureNotifyAble

Overview

Methods

Public procedure NotifyTexMapChange(Sender: TObject);

Description

Methods

Public procedure NotifyTexMapChange(Sender: TObject);

This item has no description.

Attributes
GUID['{0D9DC0B0-ECE4-4513-A8A1-5AE7022C9426}']


GLSysHelp v.2.5: GLS.Texture: Class TGLTextureImage

Class TGLTextureImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLTextureImage = class(TGLUpdateAbleObject)

Description

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AsBitmap: TBitmap;
Public | class function FriendlyDescription: string; virtual;
Public | class function FriendlyName: string; virtual;
Public | function GetBitmap32: TGLImage; virtual;
Private | function GetResourceName: string;
Public | procedure AssignToBitmap(aBitmap: TBitmap);
Public | procedure Invalidate; virtual;
Public | procedure LoadFromFile(const fileName: string); virtual;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure ReleaseBitmap32; virtual;
Public | procedure SaveToFile(const fileName: string); virtual;

Properties

Public | property Depth: Integer read GetDepth;
Public | property Height: Integer read GetHeight;
Public | property NativeTextureTarget: TGLTextureTarget read GetTextureTarget;
Public | property OwnerTexture: TGLTexture read FOwnerTexture write FOwnerTexture;
Public | property ResourceName: string read GetResourceName;
Public | property Width: Integer read GetWidth;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AsBitmap: TBitmap;

AsBitmap : Returns the TextureImage as a TBitmap

Public class function FriendlyDescription: string; virtual;

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; virtual;

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TGLImage; virtual;

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Private function GetResourceName: string;

This item has no description.

Public procedure AssignToBitmap(aBitmap: TBitmap);

This item has no description.

Public procedure Invalidate; virtual;

Request reload/refresh of data upon next use.

Public procedure LoadFromFile(const fileName: string); virtual;

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure ReleaseBitmap32; virtual;

Request for unloading bitmapData, to free some memory. This one is invoked when GLScene no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); virtual;

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Properties

Public property Depth: Integer read GetDepth;

This item has no description.

Public property Height: Integer read GetHeight;

This item has no description.

Public property NativeTextureTarget: TGLTextureTarget read GetTextureTarget;

Native opengl texture target.

Public property OwnerTexture: TGLTexture read FOwnerTexture write FOwnerTexture;

This item has no description.

Public property ResourceName: string read GetResourceName;

This item has no description.

Public property Width: Integer read GetWidth;


GLSysHelp v.2.5: GLS.Texture: Class TGLBlankImage

Class TGLBlankImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLBlankImage = class(TGLTextureImage)

Description

A texture image with no specified content, only a size. This texture image type is of use if the context of your texture is calculated at run-time (with a TGLMemoryViewer for instance).

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLBlankImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLImage; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Private | procedure SetArray(const val: Boolean);
Private | procedure SetCubeMap(const val: Boolean);
Private | procedure SetDepth(val: Integer);
Private | procedure SetHeight(val: Integer);
Private | procedure SetWidth(val: Integer);

Properties

Published | property ColorFormat: Cardinal read fColorFormat write fColorFormat;
Published | property CubeMap: Boolean read fCubeMap write SetCubeMap default false;
Published | property Depth: Integer read GetDepth write SetDepth default 0;
Published | property Height: Integer read GetHeight write SetHeight default 256;
Published | property TextureArray: Boolean read fArray write SetArray default false;
Published | property Width: Integer read GetWidth write SetWidth default 256;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TGLImage; override;

This item has no description. Showing description inherited from TGLTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when GLScene no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Private procedure SetArray(const val: Boolean);

This item has no description.

Private procedure SetCubeMap(const val: Boolean);

This item has no description.

Private procedure SetDepth(val: Integer);

This item has no description.

Private procedure SetHeight(val: Integer);

This item has no description.

Private procedure SetWidth(val: Integer);

This item has no description.

Properties

Published property ColorFormat: Cardinal read fColorFormat write fColorFormat;

This item has no description.

Published property CubeMap: Boolean read fCubeMap write SetCubeMap default false;

This item has no description.

Published property Depth: Integer read GetDepth write SetDepth default 0;

This item has no description.

Published property Height: Integer read GetHeight write SetHeight default 256;

This item has no description.

Published property TextureArray: Boolean read fArray write SetArray default false;

This item has no description.

Published property Width: Integer read GetWidth write SetWidth default 256;

Width, heigth and depth of the blank image (for memory allocation).


GLSysHelp v.2.5: GLS.Texture: Class TGLPictureImage

Class TGLPictureImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLPictureImage = class(TGLTextureImage)

Description

Base class for image data classes internally based on a TPicture.

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLPictureImage

Overview

Fields

Private | FBitmap: TGLImage;
Private | FGLPicture: TPicture;
Private | FUpdateCounter: Integer;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function GetBitmap32: TGLImage; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure ReleaseBitmap32; override;

Properties

Public property Picture: TPicture read GetPicture write SetPicture;

Description

Fields

Private FBitmap: TGLImage;

This item has no description.

Private FGLPicture: TPicture;

This item has no description.

Private FUpdateCounter: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetBitmap32: TGLImage; override;

This item has no description. Showing description inherited from TGLTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BeginUpdate;

Use this function if you are going to modify the Picture directly. Each invokation MUST be balanced by a call to EndUpdate.

Public procedure EndUpdate;

Ends a direct picture modification session. Follows a BeginUpdate.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when GLScene no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Properties

Public property Picture: TPicture read GetPicture write SetPicture;

Holds the image content.


GLSysHelp v.2.5: GLS.Texture: Class TGLPersistentImage

Class TGLPersistentImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLPersistentImage = class(TGLPictureImage)

Description

Stores any image compatible with Delphi's TPicture mechanism. The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour of TImage. Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLPictureImage
  • TGLPersistentImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Public | property NativeTextureTarget;
Published | property Picture;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Properties

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TGLTextureImage.NativeTextureTarget.

Native opengl texture target.

Published property Picture;

This item has no description. Showing description inherited from TGLPictureImage.Picture.

Holds the image content.


GLSysHelp v.2.5: GLS.Texture: Class TGLPicFileImage

Class TGLPicFileImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLPicFileImage = class(TGLPictureImage)

Description

Uses a picture whose data is found in a file (only filename is stored). The image is unloaded after upload to OpenGL.

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLPictureImage
  • TGLPicFileImage

Overview

Fields

Private | FPictureFileName: string;
Private | FAlreadyWarnedAboutMissingFile: Boolean;
Private | FWidth: Integer;
Private | FHeight: Integer;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLImage; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Invalidate; override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Public | property NativeTextureTarget;
Published | property PictureFileName: string read FPictureFileName write SetPictureFileName;

Description

Fields

Private FPictureFileName: string;

This item has no description.

Private FAlreadyWarnedAboutMissingFile: Boolean;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TGLImage; override;

This item has no description. Showing description inherited from TGLTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Invalidate; override;

This item has no description. Showing description inherited from TGLTextureImage.Invalidate.

Request reload/refresh of data upon next use.

Public procedure LoadFromFile(const fileName: string); override;

Load picture file name or use fileName as picture filename. The autodetection is based on the filelength and presence of zeros.

Public procedure SaveToFile(const fileName: string); override;

Only picture file name is saved

Properties

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TGLTextureImage.NativeTextureTarget.

Native opengl texture target.

Published property PictureFileName: string read FPictureFileName write SetPictureFileName;

Filename of the picture to use.


GLSysHelp v.2.5: GLS.Texture: Class TGLCubeMapImage

Class TGLCubeMapImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLCubeMapImage = class(TGLTextureImage)

Description

A texture image used for specifying and stroing a cube map. Not unlike TGLPictureImage, but storing 6 of them instead of just one. Saving & loading as a whole currently not supported.

Hierarchy

  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLCubeMapImage

Overview

Fields

Private | FImage: TGLImage;
Private | FUpdateCounter: Integer;
Private | FPicture: array[cmtPX..cmtNZ] of TPicture;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLImage; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Public | property NativeTextureTarget;
Public | property Picture[index: TGLCubeMapTarget]: TPicture read GetPicture write SetPicture;
Published | property PictureNX: TPicture index cmtNX read GetPicture write SetPicture;
Published | property PictureNY: TPicture index cmtNY read GetPicture write SetPicture;
Published | property PictureNZ: TPicture index cmtNZ read GetPicture write SetPicture;
Published | property PicturePX: TPicture index cmtPX read GetPicture write SetPicture;
Published | property PicturePY: TPicture index cmtPY read GetPicture write SetPicture;
Published | property PicturePZ: TPicture index cmtPZ read GetPicture write SetPicture;

Description

Fields

Private FImage: TGLImage;

This item has no description.

Private FUpdateCounter: Integer;

This item has no description.

Private FPicture: array[cmtPX..cmtNZ] of TPicture;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TGLTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TGLImage; override;

This item has no description. Showing description inherited from TGLTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BeginUpdate;

Use this function if you are going to modify the Picture directly. Each invokation MUST be balanced by a call to EndUpdate.

Public procedure EndUpdate;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TGLTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when GLScene no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TGLTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Properties

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TGLTextureImage.NativeTextureTarget.

Native opengl texture target.

Public property Picture[index: TGLCubeMapTarget]: TPicture read GetPicture write SetPicture;

Indexed access to the cube map's sub pictures.

Published property PictureNX: TPicture index cmtNX read GetPicture write SetPicture;

This item has no description.

Published property PictureNY: TPicture index cmtNY read GetPicture write SetPicture;

This item has no description.

Published property PictureNZ: TPicture index cmtNZ read GetPicture write SetPicture;

This item has no description.

Published property PicturePX: TPicture index cmtPX read GetPicture write SetPicture;

This item has no description.

Published property PicturePY: TPicture index cmtPY read GetPicture write SetPicture;

This item has no description.

Published property PicturePZ: TPicture index cmtPZ read GetPicture write SetPicture;


GLSysHelp v.2.5: GLS.Texture: Class TGLTexture

Class TGLTexture

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLTexture = class(TGLUpdateAbleObject)

Description

Defines basic texturing properties. You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default). A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TGLTextureImageAlpha).

Hierarchy

  • TGLUpdateAbleObject
  • TGLTexture

Overview

Fields

Private | FTextureHandle: TGLTextureHandle;
Private | FSamplerHandle: TGLVirtualHandle;
Private | FTextureFormat: TGLInternalFormat;
Private | FTextureMode: TGLTextureMode;
Private | FTextureWrap: TGLTextureWrap;
Private | FMinFilter: TGLMinFilter;
Private | FMagFilter: TGLMagFilter;
Private | FDisabled: Boolean;
Private | FImage: TGLTextureImage;
Private | FImageAlpha: TGLTextureImageAlpha;
Private | FImageBrightness: Single;
Private | FImageGamma: Single;
Private | FMappingMode: TGLTextureMappingMode;
Private | FMapSCoordinates: TGLCoordinates4;
Private | FMapTCoordinates: TGLCoordinates4;
Private | FMapRCoordinates: TGLCoordinates4;
Private | FMapQCoordinates: TGLCoordinates4;
Private | FOnTextureNeeded: TGLTextureNeededEvent;
Private | FCompression: TGLTextureCompression;
Private | FRequiredMemorySize: Integer;
Private | FFilteringQuality: TGLTextureFilteringQuality;
Private | FTexWidth: Integer;
Private | FTexHeight: Integer;
Private | FTexDepth: Integer;
Private | FEnvColor: TGLColor;
Private | FBorderColor: TGLColor;
Private | FNormalMapScale: Single;
Private | FTextureWrapS: TGLSeparateTextureWrap;
Private | FTextureWrapT: TGLSeparateTextureWrap;
Private | FTextureWrapR: TGLSeparateTextureWrap;
Private | fTextureCompareMode: TGLTextureCompareMode;
Private | fTextureCompareFunc: TGLDepthCompareFunc;
Private | fDepthTextureMode: TGLDepthTextureMode;
Private | FKeepImageAfterTransfer: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AllocateHandle: Cardinal;
Public | function GetImageClassName: string;
Public | function IsFloatType: Boolean;
Public | function IsHandleAllocated: Boolean;
Public | function OpenGLTextureFormat: Integer;
Public | function TextureImageRequiredMemory: Integer;
Public | procedure Apply(var rci: TGLRenderContextInfo);
Public | procedure ApplyAsTexture2(var rci: TGLRenderContextInfo; textureMatrix: PGLMatrix = nil);
Public | procedure ApplyAsTextureN(n: Integer; var rci: TGLRenderContextInfo; textureMatrix: PGLMatrix = nil);
Public | procedure ApplyMappingMode;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DestroyHandles;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyImageChange;
Public | procedure NotifyParamsChange;
Public | procedure PrepareBuildList;
Public | procedure SetImageClassName(const val: string);
Public | procedure UnApply(var rci: TGLRenderContextInfo);
Public | procedure UnApplyAsTexture2(var rci: TGLRenderContextInfo; reloadIdentityTextureMatrix: boolean);
Public | procedure UnApplyAsTextureN(n: Integer; var rci: TGLRenderContextInfo; reloadIdentityTextureMatrix: boolean);
Public | procedure UnApplyMappingMode;

Properties

Published | property BorderColor: TGLColor read FBorderColor write SetBorderColor;
Published | property Compression: TGLTextureCompression read FCompression write SetCompression default tcDefault;
Published | property DepthTextureMode: TGLDepthTextureMode read fDepthTextureMode write SetDepthTextureMode default dtmLuminance;
Published | property Disabled: Boolean read FDisabled write SetDisabled default True;
Public | property Enabled: Boolean read GetEnabled write SetEnabled;
Published | property EnvColor: TGLColor read FEnvColor write SetEnvColor;
Published | property FilteringQuality: TGLTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfIsotropic;
Public | property Handle: Cardinal read GetHandle;
Published | property Image: TGLTextureImage read FImage write SetImage;
Published | property ImageAlpha: TGLTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;
Published | property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;
Published | property ImageClassName: string read GetImageClassName write SetImageClassName stored StoreImageClassName;
Published | property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;
Published | property KeepImageAfterTransfer: Boolean read FKeepImageAfterTransfer write FKeepImageAfterTransfer default False;
Published | property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;
Published | property MappingMode: TGLTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;
Published | property MappingQCoordinates: TGLCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;
Published | property MappingRCoordinates: TGLCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;
Published | property MappingSCoordinates: TGLCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;
Published | property MappingTCoordinates: TGLCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;
Published | property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;
Published | property NormalMapScale: Single read FNormalMapScale write SetNormalMapScale stored StoreNormalMapScale;
Public | property OnTextureNeeded: TGLTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Public | property TexDepth: Integer read FTexDepth;
Public | property TexHeight: Integer read FTexHeight;
Published | property TextureCompareFunc: TGLDepthCompareFunc read fTextureCompareFunc write SetTextureCompareFunc default cfLequal;
Published | property TextureCompareMode: TGLTextureCompareMode read fTextureCompareMode write SetTextureCompareMode default tcmNone;
Published | property TextureFormat: TGLTextureFormat read GetTextureFormat write SetTextureFormat default tfDefault;
Published | property TextureFormatEx: TGLInternalFormat read FTextureFormat write SetTextureFormatEx stored StoreTextureFormatEx;
Public | property TextureHandle: TGLTextureHandle read FTextureHandle;
Published | property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;
Published | property TextureWrap: TGLTextureWrap read FTextureWrap write SetTextureWrap default twBoth;
Published | property TextureWrapR: TGLSeparateTextureWrap read FTextureWrapR write SetTextureWrapR default twRepeat;
Published | property TextureWrapS: TGLSeparateTextureWrap read FTextureWrapS write SetTextureWrapS default twRepeat;
Published | property TextureWrapT: TGLSeparateTextureWrap read FTextureWrapT write SetTextureWrapT default twRepeat;
Public | property TexWidth: Integer read FTexWidth;

Description

Fields

Private FTextureHandle: TGLTextureHandle;

This item has no description.

Private FSamplerHandle: TGLVirtualHandle;

This item has no description.

Private FTextureFormat: TGLInternalFormat;

This item has no description.

Private FTextureMode: TGLTextureMode;

This item has no description.

Private FTextureWrap: TGLTextureWrap;

This item has no description.

Private FMinFilter: TGLMinFilter;

This item has no description.

Private FMagFilter: TGLMagFilter;

This item has no description.

Private FDisabled: Boolean;

This item has no description.

Private FImage: TGLTextureImage;

This item has no description.

Private FImageAlpha: TGLTextureImageAlpha;

This item has no description.

Private FImageBrightness: Single;

This item has no description.

Private FImageGamma: Single;

This item has no description.

Private FMappingMode: TGLTextureMappingMode;

This item has no description.

Private FMapSCoordinates: TGLCoordinates4;

This item has no description.

Private FMapTCoordinates: TGLCoordinates4;

This item has no description.

Private FMapRCoordinates: TGLCoordinates4;

This item has no description.

Private FMapQCoordinates: TGLCoordinates4;

This item has no description.

Private FOnTextureNeeded: TGLTextureNeededEvent;

This item has no description.

Private FCompression: TGLTextureCompression;

This item has no description.

Private FRequiredMemorySize: Integer;

This item has no description.

Private FFilteringQuality: TGLTextureFilteringQuality;

This item has no description.

Private FTexWidth: Integer;

This item has no description.

Private FTexHeight: Integer;

This item has no description.

Private FTexDepth: Integer;

This item has no description.

Private FEnvColor: TGLColor;

This item has no description.

Private FBorderColor: TGLColor;

This item has no description.

Private FNormalMapScale: Single;

This item has no description.

Private FTextureWrapS: TGLSeparateTextureWrap;

This item has no description.

Private FTextureWrapT: TGLSeparateTextureWrap;

This item has no description.

Private FTextureWrapR: TGLSeparateTextureWrap;

This item has no description.

Private fTextureCompareMode: TGLTextureCompareMode;

This item has no description.

Private fTextureCompareFunc: TGLDepthCompareFunc;

This item has no description.

Private fDepthTextureMode: TGLDepthTextureMode;

This item has no description.

Private FKeepImageAfterTransfer: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AllocateHandle: Cardinal;

Allocates the texture handle if not already allocated. The texture is binded and parameters are setup, but no image data is initialized by this call - for expert use only

Public function GetImageClassName: string;

This item has no description.

Public function IsFloatType: Boolean;

Returns if of float data type

Public function IsHandleAllocated: Boolean;

This item has no description.

Public function OpenGLTextureFormat: Integer;

Returns OpenGL texture format corresponding to current options.

Public function TextureImageRequiredMemory: Integer;

Returns the OpenGL memory used by the texture. The compressed size is returned if, and only if texture compression if active and possible, and the texture has been allocated (Handle is defined), otherwise the estimated size (from TextureFormat specification) is returned

Public procedure Apply(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure ApplyAsTexture2(var rci: TGLRenderContextInfo; textureMatrix: PGLMatrix = nil);

Applies to TEXTURE1

Public procedure ApplyAsTextureN(n: Integer; var rci: TGLRenderContextInfo; textureMatrix: PGLMatrix = nil);

N=1 for TEXTURE0, N=2 for TEXTURE1, etc.

Public procedure ApplyMappingMode;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DestroyHandles;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure NotifyImageChange;

This item has no description.

Public procedure NotifyParamsChange;

This item has no description.

Public procedure PrepareBuildList;

This item has no description.

Public procedure SetImageClassName(const val: string);

This item has no description.

Public procedure UnApply(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure UnApplyAsTexture2(var rci: TGLRenderContextInfo; reloadIdentityTextureMatrix: boolean);

This item has no description.

Public procedure UnApplyAsTextureN(n: Integer; var rci: TGLRenderContextInfo; reloadIdentityTextureMatrix: boolean);

This item has no description.

Public procedure UnApplyMappingMode;

This item has no description.

Properties

Published property BorderColor: TGLColor read FBorderColor write SetBorderColor;

Texture Border color

Published property Compression: TGLTextureCompression read FCompression write SetCompression default tcDefault;

Texture compression control. If True the compressed TextureFormat variant (the OpenGL ICD must support GL_ARB_texture_compression, or this option is ignored).

Published property DepthTextureMode: TGLDepthTextureMode read fDepthTextureMode write SetDepthTextureMode default dtmLuminance;

This item has no description.

Published property Disabled: Boolean read FDisabled write SetDisabled default True;

If true, the texture is disabled (not used)

Public property Enabled: Boolean read GetEnabled write SetEnabled;

Is the texture enabled?. Always equals to 'not Disabled'.

Published property EnvColor: TGLColor read FEnvColor write SetEnvColor;

Texture Environment color

Published property FilteringQuality: TGLTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfIsotropic;

Specifies texture filtering quality. You can choose between bilinear and trilinear filetring (anisotropic). The OpenGL ICD must support GL_EXT_texture_filter_anisotropic or this property is ignored

Public property Handle: Cardinal read GetHandle;

Handle to the OpenGL texture object. If the handle hasn't already been allocated, it will be allocated by this call (ie. do not use if no OpenGL context is active!)

Published property Image: TGLTextureImage read FImage write SetImage;

Image data for the texture

Published property ImageAlpha: TGLTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;

Automatic Image Alpha setting. Allows to control how and if the image's Alpha channel (transparency) is computed

Published property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;

Texture brightness correction. This correction is applied upon loading a TGLTextureImage, it's a simple saturating scaling applied to the RGB components of the 32 bits image, before it is passed to OpenGL, and before gamma correction (if any)

Published property ImageClassName: string read GetImageClassName write SetImageClassName stored StoreImageClassName;

Image ClassName for enabling True polymorphism. This is ugly, but since the default streaming mechanism does a really bad job at storing polymorphic owned-object properties, and neither TFiler nor TPicture allow proper use of the built-in streaming, that's the only way to allow a user-extensible mechanism

Published property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;

Texture gamma correction. The gamma correction is applied upon loading a TGLTextureImage, applied to the RGB components of the 32 bits image, before it is passed to OpenGL, after brightness correction (if any).

Published property KeepImageAfterTransfer: Boolean read FKeepImageAfterTransfer write FKeepImageAfterTransfer default False;

Disable image release after transfering it to VGA

Published property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;

Texture magnification filter.

Published property MappingMode: TGLTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;

Texture coordinates mapping mode. This property controls automatic texture coordinates generation

Published property MappingQCoordinates: TGLCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;

This item has no description.

Published property MappingRCoordinates: TGLCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;

This item has no description.

Published property MappingSCoordinates: TGLCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;

Texture mapping coordinates mode for S, T, R and Q axis. This property stores the coordinates for automatic texture coordinates generation

Published property MappingTCoordinates: TGLCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;

This item has no description.

Published property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;

Texture minification filter.

Published property NormalMapScale: Single read FNormalMapScale write SetNormalMapScale stored StoreNormalMapScale;

Normal Map scaling. Only applies when TextureFormat is tfNormalMap, this property defines the scaling that is applied during normal map generation (ie. controls the intensity of the bumps)

Public property OnTextureNeeded: TGLTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;

This item has no description.

Public property TexDepth: Integer read FTexDepth;

This item has no description.

Public property TexHeight: Integer read FTexHeight;

This item has no description.

Published property TextureCompareFunc: TGLDepthCompareFunc read fTextureCompareFunc write SetTextureCompareFunc default cfLequal;

This item has no description.

Published property TextureCompareMode: TGLTextureCompareMode read fTextureCompareMode write SetTextureCompareMode default tcmNone;

This item has no description.

Published property TextureFormat: TGLTextureFormat read GetTextureFormat write SetTextureFormat default tfDefault;

Texture format for use by the renderer. See TGLTextureFormat for details

Published property TextureFormatEx: TGLInternalFormat read FTextureFormat write SetTextureFormatEx stored StoreTextureFormatEx;

This item has no description.

Public property TextureHandle: TGLTextureHandle read FTextureHandle;

This item has no description.

Published property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Texture application mode.

Published property TextureWrap: TGLTextureWrap read FTextureWrap write SetTextureWrap default twBoth;

Wrapping mode for the texture.

Published property TextureWrapR: TGLSeparateTextureWrap read FTextureWrapR write SetTextureWrapR default twRepeat;

This item has no description.

Published property TextureWrapS: TGLSeparateTextureWrap read FTextureWrapS write SetTextureWrapS default twRepeat;

Wrapping mode for the texture when TextureWrap=twSeparate.

Published property TextureWrapT: TGLSeparateTextureWrap read FTextureWrapT write SetTextureWrapT default twRepeat;

This item has no description.

Public property TexWidth: Integer read FTexWidth;

Actual width, height and depth used for last texture specification binding


GLSysHelp v.2.5: GLS.Texture: Class TGLTextureExItem

Class TGLTextureExItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLTextureExItem = class(TCollectionItem, IGLTextureNotifyAble)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLTextureExItem

Overview

Fields

Private | FTexture: TGLTexture;
Private | FTextureIndex: Integer;
Private | FTextureOffset: TGLCoordinates;
Private | FTextureScale: TGLCoordinates;
Private | FTextureMatrixIsIdentity: Boolean;
Private | FTextureMatrix: TGLMatrix;
Private | FApplied: Boolean;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Private | function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Private | function _AddRef: Integer; stdcall;
Private | function _Release: Integer; stdcall;
Public | procedure Apply(var rci: TGLRenderContextInfo); inline;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure UnApply(var rci: TGLRenderContextInfo); inline;

Properties

Published | property Texture: TGLTexture read FTexture write SetTexture;
Published | property TextureIndex: Integer read FTextureIndex write SetTextureIndex;
Published | property TextureOffset: TGLCoordinates read FTextureOffset write SetTextureOffset;
Published | property TextureScale: TGLCoordinates read FTextureScale write SetTextureScale;

Description

Fields

Private FTexture: TGLTexture;

This item has no description.

Private FTextureIndex: Integer;

This item has no description.

Private FTextureOffset: TGLCoordinates;

This item has no description.

Private FTextureScale: TGLCoordinates;

This item has no description.

Private FTextureMatrixIsIdentity: Boolean;

This item has no description.

Private FTextureMatrix: TGLMatrix;

This item has no description.

Private FApplied: Boolean;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;

Implementing IInterface

Private function _AddRef: Integer; stdcall;

This item has no description.

Private function _Release: Integer; stdcall;

This item has no description.

Public procedure Apply(var rci: TGLRenderContextInfo); inline;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure UnApply(var rci: TGLRenderContextInfo); inline;

This item has no description.

Properties

Published property Texture: TGLTexture read FTexture write SetTexture;

This item has no description.

Published property TextureIndex: Integer read FTextureIndex write SetTextureIndex;

This item has no description.

Published property TextureOffset: TGLCoordinates read FTextureOffset write SetTextureOffset;

This item has no description.

Published property TextureScale: TGLCoordinates read FTextureScale write SetTextureScale;


GLSysHelp v.2.5: GLS.Texture: Class TGLTextureEx

Class TGLTextureEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type TGLTextureEx = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLTextureEx

Overview

Fields

Private FOwner: TGLUpdateAbleObject;

Methods

Public | constructor Create(AOwner: TGLUpdateAbleObject);
Public | function Add: TGLTextureExItem;
Public | function IsTextureEnabled(Index: Integer): Boolean; inline;
Public | procedure Apply(var rci: TGLRenderContextInfo);
Public | procedure Loaded;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure UnApply(var rci: TGLRenderContextInfo);

Properties

Public property Items[index: Integer]: TGLTextureExItem read GetItems write SetItems;

Description

Fields

Private FOwner: TGLUpdateAbleObject;

This item has no description.

Methods

Public constructor Create(AOwner: TGLUpdateAbleObject);

This item has no description.

Public function Add: TGLTextureExItem;

This item has no description.

Public function IsTextureEnabled(Index: Integer): Boolean; inline;

This item has no description.

Public procedure Apply(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure Loaded;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure UnApply(var rci: TGLRenderContextInfo);

This item has no description.

Properties

Public property Items[index: Integer]: TGLTextureExItem read GetItems write SetItems;


GLSysHelp v.2.5: GLS.Texture: Class ETexture

Class ETexture

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type ETexture = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • ETexture


GLSysHelp v.2.5: GLS.Texture: Class EGLShaderException

Class EGLShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Texture

Declaration

type EGLShaderException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLShaderException


GLSysHelp v.2.5: GLS.TextureCombiners

Unit GLS.TextureCombiners

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • System.Classes
  • GLScene.OpenGLTokens
  • GLS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TCombinerCommand |
Class ETextureCombinerError |

Functions and Procedures

function GetTextureCombiners(const tcCode: TStringList): TCombinerCache;

Types

TCombinerCache = array of TCombinerCommand;

Description

Functions and Procedures

function GetTextureCombiners(const tcCode: TStringList): TCombinerCache;

Parses a TC text description and setups combiners accordingly. *experimental* Knowledge of texture combiners is a requirement Syntax: pascal-like, one instruction per line, use '//' for comment.

Examples: Tex1:=Tex0; // replace texture 1 with texture 0 Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1

Accepted tokens: Tex0, Tex1, etc. : texture unit PrimaryColor, Col : the primary color ConstantColor, EnvCol : texture environment constant color

Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.

Types

TCombinerCache = array of TCombinerCommand;


GLSysHelp v.2.5: GLS.TextureCombiners: Record TCombinerCommand

Record TCombinerCommand

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TextureCombiners

Declaration

type TCombinerCommand = record

Description

This item has no description.

Overview

Fields

Public | ActiveUnit: Integer;
Public | Arg1: Integer;
Public | Arg2: Integer;

Description

Fields

Public ActiveUnit: Integer;

This item has no description.

Public Arg1: Integer;

This item has no description.

Public Arg2: Integer;


GLSysHelp v.2.5: GLS.TextureCombiners: Class ETextureCombinerError

Class ETextureCombinerError

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TextureCombiners

Declaration

type ETextureCombinerError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • ETextureCombinerError


GLSysHelp v.2.5: GLS.TexturedHDS

Unit GLS.TexturedHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Types
  • System.Classes
  • GLScene.VectorTypes
  • GLS.Coordinates
  • GLS.HeightData
  • GLS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTexturedHDS |


GLSysHelp v.2.5: GLS.TexturedHDS: Class TGLTexturedHDS

Class TGLTexturedHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TexturedHDS

Declaration

type TGLTexturedHDS = class(TGLHeightDataSource)

Description

This item has no description. Showing description inherited from TGLHeightDataSource.

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TGLHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TGLHeightData with its "Release" method) Pre-loading : specify a list of TGLHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLHeightDataSource
  • TGLTexturedHDS

Overview

Fields

Private | FOnStartPreparingData: TStartPreparingDataEvent;
Private | FOnMarkDirty: TMarkDirtyEvent;
Private | FHeightDataSource: TGLHeightDataSource;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FWholeTilesOnly: Boolean;
Private | FTileSize: integer;
Private | FTilesPerTexture: integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure MarkDirty(const area: TRect); override;
Public | procedure StartPreparingData(heightData: TGLHeightData); override;

Properties

Published | property HeightDataSource: TGLHeightDataSource read FHeightDataSource write SetHeightDataSource;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write FMaterialLibrary;
Published | property MaxPoolSize;
Published | property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;
Published | property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;
Published | property TileSize: integer read FTileSize write FTileSize;
Published | property TilesPerTexture: integer read FTilesPerTexture write FTilesPerTexture;
Published | property WholeTilesOnly: Boolean read FWholeTilesOnly write FWholeTilesOnly;

Description

Fields

Private FOnStartPreparingData: TStartPreparingDataEvent;

This item has no description.

Private FOnMarkDirty: TMarkDirtyEvent;

This item has no description.

Private FHeightDataSource: TGLHeightDataSource;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FWholeTilesOnly: Boolean;

This item has no description.

Private FTileSize: integer;

This item has no description.

Private FTilesPerTexture: integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure MarkDirty(const area: TRect); override;

This item has no description. Showing description inherited from TGLHeightDataSource.MarkDirty.

Marks the given area as "dirty" (ie source data changed). All loaded and in-cache tiles overlapping the area are flushed.

Public procedure StartPreparingData(heightData: TGLHeightData); override;

This item has no description. Showing description inherited from TGLHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property HeightDataSource: TGLHeightDataSource read FHeightDataSource write SetHeightDataSource;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write FMaterialLibrary;

This item has no description.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TGLHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;

This item has no description.

Published property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;

This item has no description.

Published property TileSize: integer read FTileSize write FTileSize;

This should match TileSize in TGLTerrainRenderer

Published property TilesPerTexture: integer read FTilesPerTexture write FTilesPerTexture;

This should match TilesPerTexture in TGLTerrainRenderer

Published property WholeTilesOnly: Boolean read FWholeTilesOnly write FWholeTilesOnly;


GLSysHelp v.2.5: GLS.TextureImageEditors

Unit GLS.TextureImageEditors

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.ImageUtils
  • GLS.Texture
  • GLS.ProcTextures

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextureImageEditor |
Class TGLBlankTIE |
Class TGLPersistentTIE |
Class TGLPicFileTIE |
Class TGLProcTextureNoiseTIE |

Functions and Procedures

function EditGLTextureImage(aTexImage: TGLTextureImage): Boolean;
procedure RegisterGLTextureImageEditor(aTexImageClass: TGLTextureImageClass; texImageEditor: TGLTextureImageEditorClass);
procedure UnRegisterGLTextureImageEditor(texImageEditor: TGLTextureImageEditorClass);

Types

TGLTextureImageEditorClass = class of TGLTextureImageEditor;

Description

Functions and Procedures

function EditGLTextureImage(aTexImage: TGLTextureImage): Boolean;

Invokes the editor for the given TGLTextureImage

procedure RegisterGLTextureImageEditor(aTexImageClass: TGLTextureImageClass; texImageEditor: TGLTextureImageEditorClass);

This item has no description.

procedure UnRegisterGLTextureImageEditor(texImageEditor: TGLTextureImageEditorClass);

This item has no description.

Types

TGLTextureImageEditorClass = class of TGLTextureImageEditor;


GLSysHelp v.2.5: GLS.TextureImageEditors: Class TGLTextureImageEditor

Class TGLTextureImageEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TextureImageEditors

Declaration

type TGLTextureImageEditor = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTextureImageEditor

Overview

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; virtual;

Description

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; virtual;

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GLSysHelp v.2.5: GLS.TextureImageEditors: Class TGLBlankTIE

Class TGLBlankTIE

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TextureImageEditors

Declaration

type TGLBlankTIE = class(TGLTextureImageEditor)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTextureImageEditor
  • TGLBlankTIE

Overview

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; override;

Description

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; override;

This item has no description. Showing description inherited from TGLTextureImageEditor.Edit.

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GLSysHelp v.2.5: GLS.TextureImageEditors: Class TGLPersistentTIE

Class TGLPersistentTIE

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TextureImageEditors

Declaration

type TGLPersistentTIE = class(TGLTextureImageEditor)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTextureImageEditor
  • TGLPersistentTIE

Overview

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; override;

Description

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; override;

This item has no description. Showing description inherited from TGLTextureImageEditor.Edit.

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GLSysHelp v.2.5: GLS.TextureImageEditors: Class TGLPicFileTIE

Class TGLPicFileTIE

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TextureImageEditors

Declaration

type TGLPicFileTIE = class(TGLTextureImageEditor)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTextureImageEditor
  • TGLPicFileTIE

Overview

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; override;

Description

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; override;

This item has no description. Showing description inherited from TGLTextureImageEditor.Edit.

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GLSysHelp v.2.5: GLS.TextureImageEditors: Class TGLProcTextureNoiseTIE

Class TGLProcTextureNoiseTIE

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TextureImageEditors

Declaration

type TGLProcTextureNoiseTIE = class(TGLTextureImageEditor)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTextureImageEditor
  • TGLProcTextureNoiseTIE

Overview

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; override;

Description

Methods

Public class function Edit(aTexImage: TGLTextureImage): Boolean; override;

This item has no description. Showing description inherited from TGLTextureImageEditor.Edit.

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GLSysHelp v.2.5: GLS.ThorFX

Unit GLS.ThorFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.VectorLists
  • GLScene.VectorTypes
  • GLS.Cadencer
  • GLS.Color
  • GLS.BaseClasses
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLScene.PipelineTransform
  • GLScene.Manager
  • GLS.State
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TThorpoint |
Class TGLThorFXManager |
Class TGLBThorFX |

Functions and Procedures

function GetOrCreateThorFX(obj: TGLBaseSceneObject; const name: String = ''): TGLBThorFX;

Types

PThorpoint = ˆTThorpoint;
PThorpointArray = ˆTThorpointArray;
TCalcPointEvent = procedure(Sender: TObject; PointNo: integer; var x: single; var y: single; var z: single) of object;
TThorpointArray = array [0 .. MAXINT shr 6] of TThorpoint;

Description

Functions and Procedures

function GetOrCreateThorFX(obj: TGLBaseSceneObject; const name: String = ''): TGLBThorFX;

Returns or creates the TGLBThorFX within the given object's effects.

Types

PThorpoint = ˆTThorpoint;

This item has no description.

PThorpointArray = ˆTThorpointArray;

This item has no description.

TCalcPointEvent = procedure(Sender: TObject; PointNo: integer; var x: single; var y: single; var z: single) of object;

This item has no description.

TThorpointArray = array [0 .. MAXINT shr 6] of TThorpoint;


GLSysHelp v.2.5: GLS.ThorFX: Record TThorpoint

Record TThorpoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ThorFX

Declaration

type TThorpoint = record

Description

This item has no description.

Overview

Fields

Public | Position: TGLVector;
Public | Size: single;

Description

Fields

Public Position: TGLVector;

This item has no description.

Public Size: single;

Position


GLSysHelp v.2.5: GLS.ThorFX: Class TGLThorFXManager

Class TGLThorFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ThorFX

Declaration

type TGLThorFXManager = class(TGLCadenceAbleComponent)

Description

Thor special effect manager.

Hierarchy

  • TGLCadenceAbleComponent
  • TGLThorFXManager

Overview

Fields

Private | FClients: TList;
Private | FThorpoints: PThorpointArray;
Private | FTarget: TGLCoordinates;
Private | FCadencer: TGLCadencer;
Private | FMaxpoints: integer;
Private | FGlowSize: single;
Private | FVibrate: single;
Private | FWildness: single;
Private | NP: integer;
Private | FInnerColor: TGLColor;
Private | FOuterColor: TGLColor;
Private | FCoreColor: TGLColor;
Private | FDisabled: boolean;
Private | FCore: boolean;
Private | FGlow: boolean;
Private | FOnCalcPoint: TCalcPointEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;

Properties

Published | property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Published | property Core: boolean read FCore write FCore;
Published | property CoreColor: TGLColor read FCoreColor write SetCoreColor;
Published | property Disabled: boolean read FDisabled write FDisabled;
Published | property Glow: boolean read FGlow write FGlow;
Published | property GlowSize: single read FGlowSize write FGlowSize stored StoreGlowSize;
Published | property InnerColor: TGLColor read FInnerColor write SetInnerColor;
Published | property Maxpoints: integer read FMaxpoints write SetMaxpoints default 256;
Published | property OnCalcPoint: TCalcPointEvent read FOnCalcPoint write FOnCalcPoint;
Published | property OuterColor: TGLColor read FOuterColor write SetOuterColor;
Published | property Target: TGLCoordinates read FTarget write SetTarget;
Published | property Vibrate: single read FVibrate write FVibrate stored StoreVibrate;
Published | property Wildness: single read FWildness write FWildness;

Description

Fields

Private FClients: TList;

This item has no description.

Private FThorpoints: PThorpointArray;

This item has no description.

Private FTarget: TGLCoordinates;

This item has no description.

Private FCadencer: TGLCadencer;

This item has no description.

Private FMaxpoints: integer;

This item has no description.

Private FGlowSize: single;

This item has no description.

Private FVibrate: single;

This item has no description.

Private FWildness: single;

This item has no description.

Private NP: integer;

This item has no description.

Private FInnerColor: TGLColor;

This item has no description.

Private FOuterColor: TGLColor;

This item has no description.

Private FCoreColor: TGLColor;

This item has no description.

Private FDisabled: boolean;

This item has no description.

Private FCore: boolean;

This item has no description.

Private FGlow: boolean;

This item has no description.

Private FOnCalcPoint: TCalcPointEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Properties

Published property Cadencer: TGLCadencer read FCadencer write SetCadencer;

This item has no description.

Published property Core: boolean read FCore write FCore;

This item has no description.

Published property CoreColor: TGLColor read FCoreColor write SetCoreColor;

default clrWhite;

Published property Disabled: boolean read FDisabled write FDisabled;

default clrWhite;

Published property Glow: boolean read FGlow write FGlow;

This item has no description.

Published property GlowSize: single read FGlowSize write FGlowSize stored StoreGlowSize;

This item has no description.

Published property InnerColor: TGLColor read FInnerColor write SetInnerColor;

This item has no description.

Published property Maxpoints: integer read FMaxpoints write SetMaxpoints default 256;

This item has no description.

Published property OnCalcPoint: TCalcPointEvent read FOnCalcPoint write FOnCalcPoint;

This item has no description.

Published property OuterColor: TGLColor read FOuterColor write SetOuterColor;

This item has no description.

Published property Target: TGLCoordinates read FTarget write SetTarget;

This item has no description.

Published property Vibrate: single read FVibrate write FVibrate stored StoreVibrate;

This item has no description.

Published property Wildness: single read FWildness write FWildness;


GLSysHelp v.2.5: GLS.ThorFX: Class TGLBThorFX

Class TGLBThorFX

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.ThorFX

Declaration

type TGLBThorFX = class(TGLObjectPostEffect)

Description

Thor special effect

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLEffect
  • TGLObjectPostEffect
  • TGLBThorFX

Overview

Fields

Private | FManager: TGLThorFXManager;
Private | FManagerName: String;
Private | FTarget: TGLCoordinates;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Render(var rci: TGLRenderContextInfo); override;

Properties

Published property Manager: TGLThorFXManager read FManager write SetManager;

Description

Fields

Private FManager: TGLThorFXManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FTarget: TGLCoordinates;

NOT persistent, temporarily used for persistence

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure Render(var rci: TGLRenderContextInfo); override;

This item has no description.

Properties

Published property Manager: TGLThorFXManager read FManager write SetManager;

Refers the collision manager.


GLSysHelp v.2.5: GLS.TilePlane

Unit GLS.TilePlane

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.State
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.Material
  • GLS.Objects
  • GLS.PersistentClasses
  • GLS.VectorLists
  • GLS.RenderContextInfo
  • GLS.XOpenGL

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTiledAreaRow |
Class TGLTiledArea |
Class TGLTilePlane |


GLSysHelp v.2.5: GLS.TilePlane: Class TGLTiledAreaRow

Class TGLTiledAreaRow

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TilePlane

Declaration

type TGLTiledAreaRow = class(TGLPersistentObject)

Description

Stores row information for a tiled area.

Hierarchy

  • TGLPersistentObject
  • TGLTiledAreaRow

Overview

Fields

Private | FColMin: Integer;
Private | FColMax: Integer;
Private | FData: TGLIntegerList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Empty: Boolean;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure RemapTiles(remapList: TGLIntegerList);
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Cell[col: Integer]: Integer read GetCell write SetCell;
Public | property ColMax: Integer read FColMax write SetColMax;
Public | property ColMin: Integer read FColMin write SetColMin;
Public | property Data: TGLIntegerList read FData;

Description

Fields

Private FColMin: Integer;

This item has no description.

Private FColMax: Integer;

This item has no description.

Private FData: TGLIntegerList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Empty: Boolean;

This item has no description.

Public procedure Pack;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure RemapTiles(remapList: TGLIntegerList);

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Cell[col: Integer]: Integer read GetCell write SetCell;

This item has no description.

Public property ColMax: Integer read FColMax write SetColMax;

This item has no description.

Public property ColMin: Integer read FColMin write SetColMin;

This item has no description.

Public property Data: TGLIntegerList read FData;


GLSysHelp v.2.5: GLS.TilePlane: Class TGLTiledArea

Class TGLTiledArea

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TilePlane

Declaration

type TGLTiledArea = class(TGLPersistentObject)

Description

Stores tile information in a tiled area. Each tile stores an integer value with zero the default value, assumed as "empty".

Hierarchy

  • TGLPersistentObject
  • TGLTiledArea

Overview

Fields

Private | FRowMin: Integer;
Private | FRowMax: Integer;
Private | FRows: TGLPersistentObjectList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Empty: Boolean;
Public | procedure Clear;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure RemapTiles(remapList: TGLIntegerList);
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property row[index: Integer]: TGLTiledAreaRow read GetRow;
Public | property RowMax: Integer read FRowMax write SetRowMax;
Public | property RowMin: Integer read FRowMin write SetRowMin;
Public | property Tile[col,row: Integer]: Integer read GetTile write SetTile;

Description

Fields

Private FRowMin: Integer;

This item has no description.

Private FRowMax: Integer;

This item has no description.

Private FRows: TGLPersistentObjectList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Empty: Boolean;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Pack;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure RemapTiles(remapList: TGLIntegerList);

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property row[index: Integer]: TGLTiledAreaRow read GetRow;

This item has no description.

Public property RowMax: Integer read FRowMax write SetRowMax;

This item has no description.

Public property RowMin: Integer read FRowMin write SetRowMin;

This item has no description.

Public property Tile[col,row: Integer]: Integer read GetTile write SetTile;


GLSysHelp v.2.5: GLS.TilePlane: Class TGLTilePlane

Class TGLTilePlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TilePlane

Declaration

type TGLTilePlane = class(TGLImmaterialSceneObject)

Description

A tiled textured plane. This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering. Its bounding dimensions are determined by its painted tile.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLTilePlane

Overview

Fields

Private | FNoZWrite: Boolean;
Private | FTiles: TGLTiledArea;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FSortByMaterials: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Public | property SortByMaterials: Boolean read FSortByMaterials write SetSortByMaterials;
Public | property Tiles: TGLTiledArea read FTiles write SetTiles;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Private FTiles: TGLTiledArea;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FSortByMaterials: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Material library where tiles materials will be stored/retrieved. The lower 16 bits of the tile integer value is understood as being the index of the tile's material in the library (material of index zero is thus unused).

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;

If True the tiles are rendered without writing to the ZBuffer.

Public property SortByMaterials: Boolean read FSortByMaterials write SetSortByMaterials;

Controls the sorting of tiles by material. This property should ideally be left always at its default, True, except for debugging and performance measurement, which is why it's only public and not published.

Public property Tiles: TGLTiledArea read FTiles write SetTiles;

Access to the TiledArea data


GLSysHelp v.2.5: GLS.TimeEventsMgr

Unit GLS.TimeEventsMgr

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.Cadencer
  • GLS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTimeEventsMGR |
Class TTimeEvents |
Class TTimeEvent |

Types

TTimeEventProc = procedure(event: TTimeEvent) of object;
TTimeEventType = (...);

Description

Types

TTimeEventProc = procedure(event: TTimeEvent) of object;

This item has no description.

TTimeEventType = (...);

This item has no description.

Values
  • etOneShot
  • etContinuous
  • etPeriodic


GLSysHelp v.2.5: GLS.TimeEventsMgr: Class TGLTimeEventsMGR

Class TGLTimeEventsMGR

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TimeEventsMgr

Declaration

type TGLTimeEventsMGR = class(TGLUpdateAbleComponent)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLTimeEventsMGR

Overview

Fields

Private | FCadencer: TGLCadencer;
Private | FEnabled: boolean;
Private | FFreeEventOnEnd: boolean;
Private | FEvents: TTimeEvents;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure Reset();

Properties

Published | property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Published | property Enabled: boolean read FEnabled write FEnabled default True;
Published | property Events: TTimeEvents read FEvents write SetEvents;
Published | property FreeEventOnEnd: boolean read FFreeEventOnEnd write FFreeEventOnEnd default False;

Description

Fields

Private FCadencer: TGLCadencer;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FFreeEventOnEnd: boolean;

This item has no description.

Private FEvents: TTimeEvents;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure Reset();

This item has no description.

Properties

Published property Cadencer: TGLCadencer read FCadencer write SetCadencer;

This item has no description.

Published property Enabled: boolean read FEnabled write FEnabled default True;

This item has no description.

Published property Events: TTimeEvents read FEvents write SetEvents;

This item has no description.

Published property FreeEventOnEnd: boolean read FFreeEventOnEnd write FFreeEventOnEnd default False;


GLSysHelp v.2.5: GLS.TimeEventsMgr: Class TTimeEvents

Class TTimeEvents

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TimeEventsMgr

Declaration

type TTimeEvents = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TTimeEvents

Overview

Methods

Public | constructor Create(aOwner: TComponent);
Public | function Add: TTimeEvent;
Public | function EventByName(const name: String): TTimeEvent;
Public | function FindItemID(ID: Integer): TTimeEvent;

Properties

Public property Items[index: Integer]: TTimeEvent read GetItems write SetItems;

Description

Methods

Public constructor Create(aOwner: TComponent);

This item has no description.

Public function Add: TTimeEvent;

This item has no description.

Public function EventByName(const name: String): TTimeEvent;

This item has no description.

Public function FindItemID(ID: Integer): TTimeEvent;

This item has no description.

Properties

Public property Items[index: Integer]: TTimeEvent read GetItems write SetItems;


GLSysHelp v.2.5: GLS.TimeEventsMgr: Class TTimeEvent

Class TTimeEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.TimeEventsMgr

Declaration

type TTimeEvent = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TTimeEvent

Overview

Fields

Private | FName: String;
Private | FStartTime: Double;
Private | FEndTime: Double;
Private | FElapsedTime: Double;
Private | FPeriod: Double;
Private | FEventType: TTimeEventType;
Private | FOnEvent: TTimeEventProc;
Private | FEnabled: boolean;
Private | FTickCount: Cardinal;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | procedure SetEnabled(const Value: boolean);

Properties

Public | property ElapsedTime: Double read FElapsedTime;
Published | property Enabled: boolean read FEnabled write SetEnabled default True;
Published | property EndTime: Double read FEndTime write FEndTime;
Published | property EventType: TTimeEventType read FEventType write FEventType default etOneShot;
Published | property Name: String read FName write SetName;
Published | property OnEvent: TTimeEventProc read FOnEvent write FOnEvent;
Published | property Period: Double read FPeriod write FPeriod;
Published | property StartTime: Double read FStartTime write FStartTime;
Public | property TickCount: Cardinal read FTickCount;

Description

Fields

Private FName: String;

This item has no description.

Private FStartTime: Double;

This item has no description.

Private FEndTime: Double;

This item has no description.

Private FElapsedTime: Double;

This item has no description.

Private FPeriod: Double;

This item has no description.

Private FEventType: TTimeEventType;

This item has no description.

Private FOnEvent: TTimeEventProc;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FTickCount: Cardinal;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetEnabled(const Value: boolean);

This item has no description.

Properties

Public property ElapsedTime: Double read FElapsedTime;

Elapsed time since the event was activated

Published property Enabled: boolean read FEnabled write SetEnabled default True;

This item has no description.

Published property EndTime: Double read FEndTime write FEndTime;

This item has no description.

Published property EventType: TTimeEventType read FEventType write FEventType default etOneShot;

This item has no description.

Published property Name: String read FName write SetName;

This item has no description.

Published property OnEvent: TTimeEventProc read FOnEvent write FOnEvent;

This item has no description.

Published property Period: Double read FPeriod write FPeriod;

This item has no description.

Published property StartTime: Double read FStartTime write FStartTime;

This item has no description.

Public property TickCount: Cardinal read FTickCount;

Number of times the event was triggered since activation


GLSysHelp v.2.5: GLS.Trail

Unit GLS.Trail

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLS.Scene
  • GLScene.VectorTypes
  • GLS.MeshUtils
  • GLScene.VectorGeometry
  • GLS.VectorFileObjects
  • GLS.Mesh
  • GLS.Objects
  • GLS.Material
  • GLScene.Strings
  • GLS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTrail |

Types

TMarkStyle = (...);

Constants

cMaxVerts = 2000;

Description

Types

TMarkStyle = (...);

This item has no description.

Values
  • msUp
  • msDirection
  • msFaceCamera
  • msRight

Constants

cMaxVerts = 2000;


GLSysHelp v.2.5: GLS.Trail: Class TGLTrail

Class TGLTrail

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Trail

Declaration

type TGLTrail = class(TGlMesh)

Description

This item has no description. Showing description inherited from TGLMesh.

Basic mesh object. Each mesh holds a set of vertices and a Mode value defines how they make up the mesh (triangles, strips...)

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMesh
  • TGLTrail

Overview

Fields

Private | fVertLimit: integer;
Private | fTimeLimit: single;
Private | fMinDistance: single;
Private | fAlpha: single;
Private | fAlphaFade: Boolean;
Private | fUVScale: Single;
Private | fVerts: array[1..cMaxVerts] of TVector3f;
Private | fUVs: array[1..cMaxVerts] of TTexpoint;
Private | fTimeStamps: array[1..cMaxVerts] of Double;
Private | fVertStart: integer;
Private | fVertEnd: integer;
Private | fVertCount: integer;
Private | fLastV0Pos: TVector3f;
Private | fLastPos: TVector3f;
Private | fLastDir: TVector3f;
Private | fLastUp: TVector3f;
Private | FLastUVs: single;
Private | fLastP1: TVector3f;
Private | fLastP2: TVector3f;
Private | FTrailObject: TGLBaseSceneObject;
Private | FMarkStyle: TMarkStyle;
Private | FMarkWidth: single;
Private | FEnabled: boolean;
Private | FAntiZFightOffset: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateMark(const p1,p2: TVector3f;CurrentTime : Double):boolean; overload;
Private | function StoreAntiZFightOffset: Boolean;
Public | procedure ClearMarks;
Public | procedure CreateMark(obj: TGlBaseSceneObject; width: single;CurrentTime : Double); overload;
Public | procedure CreateMark(const APos,ADir,AUp: TVector3f; AWidth: single;ACurrentTime : Double); overload;
Public | procedure DoProgress(const progressTime : TGLProgressTimes); override;
Private | procedure SetAlpha(const Value: single);
Private | procedure SetAlphaFade(const Value: Boolean);
Private | procedure SetEnabled(const Value: boolean);
Private | procedure SetMarkStyle(const Value: TMarkStyle);
Private | procedure SetMarkWidth(const Value: single);
Private | procedure SetMinDistance(const Value: single);
Private | procedure SetTimeLimit(const Value: single);
Private | procedure SetTrailObject(const Value: TGLBaseSceneObject);
Private | procedure SetUVScale(const Value: single);
Private | procedure SetVertLimit(const Value: integer);

Properties

Published | property Alpha: single read FAlpha write SetAlpha;
Published | property AlphaFade: Boolean read FAlphaFade write SetAlphaFade default True;
Published | property AntiZFightOffset: Single read FAntiZFightOffset write FAntiZFightOffset stored StoreAntiZFightOffset;
Published | property Enabled : boolean read FEnabled write SetEnabled default True;
Published | property MarkStyle : TMarkStyle read FMarkStyle write SetMarkStyle default msFaceCamera;
Published | property MarkWidth : single read FMarkWidth write SetMarkWidth;
Published | property MinDistance: single read FMinDistance write SetMinDistance;
Published | property TimeLimit: single read FTimeLimit write SetTimeLimit;
Published | property TrailObject : TGLBaseSceneObject read FTrailObject write SetTrailObject default nil;
Published | property UVScale: single read FUVScale write SetUVScale;
Published | property VertLimit: integer read FVertLimit write SetVertLimit default 150;

Description

Fields

Private fVertLimit: integer;

This item has no description.

Private fTimeLimit: single;

This item has no description.

Private fMinDistance: single;

This item has no description.

Private fAlpha: single;

This item has no description.

Private fAlphaFade: Boolean;

This item has no description.

Private fUVScale: Single;

This item has no description.

Private fVerts: array[1..cMaxVerts] of TVector3f;

This item has no description.

Private fUVs: array[1..cMaxVerts] of TTexpoint;

This item has no description.

Private fTimeStamps: array[1..cMaxVerts] of Double;

This item has no description.

Private fVertStart: integer;

This item has no description.

Private fVertEnd: integer;

This item has no description.

Private fVertCount: integer;

This item has no description.

Private fLastV0Pos: TVector3f;

This item has no description.

Private fLastPos: TVector3f;

This item has no description.

Private fLastDir: TVector3f;

This item has no description.

Private fLastUp: TVector3f;

This item has no description.

Private FLastUVs: single;

This item has no description.

Private fLastP1: TVector3f;

used for UV scaling

Private fLastP2: TVector3f;

used for UV scaling

Private FTrailObject: TGLBaseSceneObject;

This item has no description.

Private FMarkStyle: TMarkStyle;

This item has no description.

Private FMarkWidth: single;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FAntiZFightOffset: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateMark(const p1,p2: TVector3f;CurrentTime : Double):boolean; overload;

This item has no description.

Private function StoreAntiZFightOffset: Boolean;

This item has no description.

Public procedure ClearMarks;

This item has no description.

Public procedure CreateMark(obj: TGlBaseSceneObject; width: single;CurrentTime : Double); overload;

This item has no description.

Public procedure CreateMark(const APos,ADir,AUp: TVector3f; AWidth: single;ACurrentTime : Double); overload;

This item has no description.

Public procedure DoProgress(const progressTime : TGLProgressTimes); override;

EnableUVmapping: boolean; // generate UV's or not

Private procedure SetAlpha(const Value: single);

This item has no description.

Private procedure SetAlphaFade(const Value: Boolean);

This item has no description.

Private procedure SetEnabled(const Value: boolean);

This item has no description.

Private procedure SetMarkStyle(const Value: TMarkStyle);

This item has no description.

Private procedure SetMarkWidth(const Value: single);

This item has no description.

Private procedure SetMinDistance(const Value: single);

This item has no description.

Private procedure SetTimeLimit(const Value: single);

This item has no description.

Private procedure SetTrailObject(const Value: TGLBaseSceneObject);

This item has no description.

Private procedure SetUVScale(const Value: single);

This item has no description.

Private procedure SetVertLimit(const Value: integer);

This item has no description.

Properties

Published property Alpha: single read FAlpha write SetAlpha;

This item has no description.

Published property AlphaFade: Boolean read FAlphaFade write SetAlphaFade default True;

This item has no description.

Published property AntiZFightOffset: Single read FAntiZFightOffset write FAntiZFightOffset stored StoreAntiZFightOffset;

Add a tiny bit of offset to help prevent z-fighting.. Need a better solution here as this will get out of whack on really long trails and is dependant on scene scale.

Published property Enabled : boolean read FEnabled write SetEnabled default True;

This item has no description.

Published property MarkStyle : TMarkStyle read FMarkStyle write SetMarkStyle default msFaceCamera;

This item has no description.

Published property MarkWidth : single read FMarkWidth write SetMarkWidth;

This item has no description.

Published property MinDistance: single read FMinDistance write SetMinDistance;

Don't create mark unless moved at least this distance.

Published property TimeLimit: single read FTimeLimit write SetTimeLimit;

This item has no description.

Published property TrailObject : TGLBaseSceneObject read FTrailObject write SetTrailObject default nil;

This item has no description.

Published property UVScale: single read FUVScale write SetUVScale;

This item has no description.

Published property VertLimit: integer read FVertLimit write SetVertLimit default 150;


GLSysHelp v.2.5: GLS.Tree

Unit GLS.Tree

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.State
  • GLS.Material
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.VectorFileObjects
  • GLS.ApplicationFileIO
  • GLS.RenderContextInfo
  • GLS.PersistentClasses
  • GLS.XOpenGL
  • GLS.Context
  • GLScene.VectorTypes
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTreeLeaves |
Class TGLTreeBranch |
Class TGLTreeBranches |
Class TGLTreeBranchNoise |
Class TGLTree |


GLSysHelp v.2.5: GLS.Tree: Class TGLTreeLeaves

Class TGLTreeLeaves

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Tree

Declaration

type TGLTreeLeaves = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTreeLeaves

Overview

Fields

Private | FOwner: TGLTree;
Private | FCount: Integer;
Private | FVertices: TGLAffineVectorList;
Private | FNormals: TGLAffineVectorList;
Private | FTexCoords: TGLAffineVectorList;

Methods

Public | constructor Create(AOwner: TGLTree);
Public | destructor Destroy; override;
Public | procedure AddNew(matrix: TGLMatrix);
Public | procedure BuildList(var rci: TGLRenderContextInfo);
Public | procedure Clear;

Properties

Public | property Count: Integer read FCount;
Public | property Normals: TGLAffineVectorList read FNormals;
Public | property Owner: TGLTree read FOwner;
Public | property TexCoords: TGLAffineVectorList read FTexCoords;
Public | property Vertices: TGLAffineVectorList read FVertices;

Description

Fields

Private FOwner: TGLTree;

This item has no description.

Private FCount: Integer;

This item has no description.

Private FVertices: TGLAffineVectorList;

This item has no description.

Private FNormals: TGLAffineVectorList;

This item has no description.

Private FTexCoords: TGLAffineVectorList;

This item has no description.

Methods

Public constructor Create(AOwner: TGLTree);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddNew(matrix: TGLMatrix);

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure Clear;

This item has no description.

Properties

Public property Count: Integer read FCount;

This item has no description.

Public property Normals: TGLAffineVectorList read FNormals;

This item has no description.

Public property Owner: TGLTree read FOwner;

This item has no description.

Public property TexCoords: TGLAffineVectorList read FTexCoords;

This item has no description.

Public property Vertices: TGLAffineVectorList read FVertices;


GLSysHelp v.2.5: GLS.Tree: Class TGLTreeBranch

Class TGLTreeBranch

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Tree

Declaration

type TGLTreeBranch = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTreeBranch

Overview

Fields

Private | FOwner: TGLTreeBranches;
Private | FLeft: TGLTreeBranch;
Private | FCenter: TGLTreeBranch;
Private | FRight: TGLTreeBranch;
Private | FParent: TGLTreeBranch;
Private | FBranchID: Integer;
Private | FParentID: Integer;
Private | FMatrix: TGLMatrix;
Private | FLower: TGLIntegerList;
Private | FUpper: TGLIntegerList;
Private | FCentralLeader: Boolean;

Methods

Public | constructor Create(AOwner: TGLTreeBranches; AParent: TGLTreeBranch);
Public | destructor Destroy; override;
Private | procedure BuildBranch(branchNoise: TGLTreeBranchNoise; const matrix: TGLMatrix; TexCoordY, Twist: Single; Level: Integer);

Properties

Public | property Center: TGLTreeBranch read FCenter;
Public | property Left: TGLTreeBranch read FLeft;
Public | property Lower: TGLIntegerList read FLower;
Public | property matrix: TGLMatrix read FMatrix;
Public | property Owner: TGLTreeBranches read FOwner;
Public | property Parent: TGLTreeBranch read FParent;
Public | property Right: TGLTreeBranch read FRight;
Public | property Upper: TGLIntegerList read FUpper;

Description

Fields

Private FOwner: TGLTreeBranches;

This item has no description.

Private FLeft: TGLTreeBranch;

This item has no description.

Private FCenter: TGLTreeBranch;

This item has no description.

Private FRight: TGLTreeBranch;

This item has no description.

Private FParent: TGLTreeBranch;

This item has no description.

Private FBranchID: Integer;

This item has no description.

Private FParentID: Integer;

This item has no description.

Private FMatrix: TGLMatrix;

This item has no description.

Private FLower: TGLIntegerList;

This item has no description.

Private FUpper: TGLIntegerList;

This item has no description.

Private FCentralLeader: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TGLTreeBranches; AParent: TGLTreeBranch);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure BuildBranch(branchNoise: TGLTreeBranchNoise; const matrix: TGLMatrix; TexCoordY, Twist: Single; Level: Integer);

This item has no description.

Properties

Public property Center: TGLTreeBranch read FCenter;

This item has no description.

Public property Left: TGLTreeBranch read FLeft;

This item has no description.

Public property Lower: TGLIntegerList read FLower;

This item has no description.

Public property matrix: TGLMatrix read FMatrix;

This item has no description.

Public property Owner: TGLTreeBranches read FOwner;

This item has no description.

Public property Parent: TGLTreeBranch read FParent;

This item has no description.

Public property Right: TGLTreeBranch read FRight;

This item has no description.

Public property Upper: TGLIntegerList read FUpper;


GLSysHelp v.2.5: GLS.Tree: Class TGLTreeBranches

Class TGLTreeBranches

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Tree

Declaration

type TGLTreeBranches = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTreeBranches

Overview

Fields

Private | FOwner: TGLTree;
Private | FSinList: TGLSingleList;
Private | FCosList: TGLSingleList;
Private | FVertices: TGLAffineVectorList;
Private | FNormals: TGLAffineVectorList;
Private | FTexCoords: TGLAffineVectorList;
Private | FIndices: TGLIntegerList;
Private | FRoot: TGLTreeBranch;
Private | FCount: Integer;
Private | FBranchCache: TList;
Private | FBranchIndices: TGLIntegerList;

Methods

Public | constructor Create(AOwner: TGLTree);
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo);
Public | procedure Clear;
Private | procedure BuildBranches;

Properties

Public | property CosList: TGLSingleList read FCosList;
Public | property Count: Integer read FCount;
Public | property Normals: TGLAffineVectorList read FNormals;
Public | property Owner: TGLTree read FOwner;
Public | property SinList: TGLSingleList read FSinList;
Public | property TexCoords: TGLAffineVectorList read FTexCoords;
Public | property Vertices: TGLAffineVectorList read FVertices;

Description

Fields

Private FOwner: TGLTree;

This item has no description.

Private FSinList: TGLSingleList;

This item has no description.

Private FCosList: TGLSingleList;

This item has no description.

Private FVertices: TGLAffineVectorList;

This item has no description.

Private FNormals: TGLAffineVectorList;

This item has no description.

Private FTexCoords: TGLAffineVectorList;

This item has no description.

Private FIndices: TGLIntegerList;

This item has no description.

Private FRoot: TGLTreeBranch;

This item has no description.

Private FCount: Integer;

This item has no description.

Private FBranchCache: TList;

This item has no description.

Private FBranchIndices: TGLIntegerList;

This item has no description.

Methods

Public constructor Create(AOwner: TGLTree);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure Clear;

This item has no description.

Private procedure BuildBranches;

This item has no description.

Properties

Public property CosList: TGLSingleList read FCosList;

This item has no description.

Public property Count: Integer read FCount;

This item has no description.

Public property Normals: TGLAffineVectorList read FNormals;

This item has no description.

Public property Owner: TGLTree read FOwner;

This item has no description.

Public property SinList: TGLSingleList read FSinList;

This item has no description.

Public property TexCoords: TGLAffineVectorList read FTexCoords;

This item has no description.

Public property Vertices: TGLAffineVectorList read FVertices;


GLSysHelp v.2.5: GLS.Tree: Class TGLTreeBranchNoise

Class TGLTreeBranchNoise

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Tree

Declaration

type TGLTreeBranchNoise = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLTreeBranchNoise

Overview

Fields

Private | FBranchNoise: Single;
Private | FLeft: TGLTreeBranchNoise;
Private | FRight: TGLTreeBranchNoise;
Private | FCenter: TGLTreeBranchNoise;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Private | function GetCenter: TGLTreeBranchNoise;
Private | function GetLeft: TGLTreeBranchNoise;
Private | function GetRight: TGLTreeBranchNoise;

Properties

Public | property branchNoise: Single read FBranchNoise;
Public | property Center: TGLTreeBranchNoise read GetCenter;
Public | property Left: TGLTreeBranchNoise read GetLeft;
Public | property Right: TGLTreeBranchNoise read GetRight;

Description

Fields

Private FBranchNoise: Single;

This item has no description.

Private FLeft: TGLTreeBranchNoise;

This item has no description.

Private FRight: TGLTreeBranchNoise;

This item has no description.

Private FCenter: TGLTreeBranchNoise;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetCenter: TGLTreeBranchNoise;

This item has no description.

Private function GetLeft: TGLTreeBranchNoise;

This item has no description.

Private function GetRight: TGLTreeBranchNoise;

This item has no description.

Properties

Public property branchNoise: Single read FBranchNoise;

This item has no description.

Public property Center: TGLTreeBranchNoise read GetCenter;

This item has no description.

Public property Left: TGLTreeBranchNoise read GetLeft;

This item has no description.

Public property Right: TGLTreeBranchNoise read GetRight;


GLSysHelp v.2.5: GLS.Tree: Class TGLTree

Class TGLTree

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Tree

Declaration

type TGLTree = class(TGLImmaterialSceneObject)

Description

This item has no description. Showing description inherited from TGLImmaterialSceneObject.

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLTree

Overview

Fields

Private | FDepth: Integer;
Private | FBranchFacets: Integer;
Private | FLeafSize: Single;
Private | FBranchSize: Single;
Private | FBranchNoise: Single;
Private | FBranchAngleBias: Single;
Private | FBranchAngle: Single;
Private | FBranchTwist: Single;
Private | FBranchRadius: Single;
Private | FLeafThreshold: Single;
Private | FCentralLeaderBias: Single;
Private | FCentralLeader: Boolean;
Private | FSeed: Integer;
Private | FAutoCenter: Boolean;
Private | FAutoRebuild: Boolean;
Private | FCenterBranchConstant: Single;
Private | FLeaves: TGLTreeLeaves;
Private | FBranches: TGLTreeBranches;
Private | FNoise: TGLTreeBranchNoise;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FLeafMaterialName: TGLLibMaterialName;
Private | FLeafBackMaterialName: TGLLibMaterialName;
Private | FBranchMaterialName: TGLLibMaterialName;
Private | FRebuildTree: Boolean;
Private | FAxisAlignedDimensionsCache: TGLVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure BuildMesh(GLBaseMesh: TGLBaseMesh);
Public | procedure Clear;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure ForceTotalRebuild;
Public | procedure GetExtents(var min, max: TAffineVector);
Public | procedure LoadFromFile(const aFileName: String);
Public | procedure LoadFromStream(aStream: TStream);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RebuildTree;
Public | procedure SaveToFile(const aFileName: String);
Public | procedure SaveToStream(aStream: TStream);
Public | procedure StructureChanged; override;

Properties

Published | property AutoCenter: Boolean read FAutoCenter write SetAutoCenter;
Published | property AutoRebuild: Boolean read FAutoRebuild write SetAutoRebuild;
Published | property BranchAngle: Single read FBranchAngle write SetBranchAngle;
Published | property BranchAngleBias: Single read FBranchAngleBias write SetBranchAngleBias;
Public | property Branches: TGLTreeBranches read FBranches;
Published | property BranchFacets: Integer read FBranchFacets write SetBranchFacets;
Published | property BranchMaterialName: TGLLibMaterialName read FBranchMaterialName write SetBranchMaterialName;
Published | property BranchNoise: Single read FBranchNoise write SetBranchNoise;
Published | property BranchRadius: Single read FBranchRadius write SetBranchRadius;
Published | property BranchSize: Single read FBranchSize write SetBranchSize;
Published | property BranchTwist: Single read FBranchTwist write SetBranchTwist;
Published | property CenterBranchConstant: Single read FCenterBranchConstant write SetCenterBranchConstant;
Published | property CentralLeader: Boolean read FCentralLeader write SetCentralLeader;
Published | property CentralLeaderBias: Single read FCentralLeaderBias write SetCentralLeaderBias;
Published | property Depth: Integer read FDepth write SetDepth;
Published | property LeafBackMaterialName: TGLLibMaterialName read FLeafBackMaterialName write SetLeafBackMaterialName;
Published | property LeafMaterialName: TGLLibMaterialName read FLeafMaterialName write SetLeafMaterialName;
Published | property LeafSize: Single read FLeafSize write SetLeafSize;
Published | property LeafThreshold: Single read FLeafThreshold write SetLeafThreshold;
Public | property Leaves: TGLTreeLeaves read FLeaves;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property Noise: TGLTreeBranchNoise read FNoise;
Published | property Seed: Integer read FSeed write SetSeed;

Description

Fields

Private FDepth: Integer;

This item has no description.

Private FBranchFacets: Integer;

This item has no description.

Private FLeafSize: Single;

This item has no description.

Private FBranchSize: Single;

This item has no description.

Private FBranchNoise: Single;

This item has no description.

Private FBranchAngleBias: Single;

This item has no description.

Private FBranchAngle: Single;

This item has no description.

Private FBranchTwist: Single;

This item has no description.

Private FBranchRadius: Single;

This item has no description.

Private FLeafThreshold: Single;

This item has no description.

Private FCentralLeaderBias: Single;

This item has no description.

Private FCentralLeader: Boolean;

This item has no description.

Private FSeed: Integer;

This item has no description.

Private FAutoCenter: Boolean;

This item has no description.

Private FAutoRebuild: Boolean;

This item has no description.

Private FCenterBranchConstant: Single;

This item has no description.

Private FLeaves: TGLTreeLeaves;

This item has no description.

Private FBranches: TGLTreeBranches;

This item has no description.

Private FNoise: TGLTreeBranchNoise;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FLeafMaterialName: TGLLibMaterialName;

This item has no description.

Private FLeafBackMaterialName: TGLLibMaterialName;

This item has no description.

Private FBranchMaterialName: TGLLibMaterialName;

This item has no description.

Private FRebuildTree: Boolean;

This item has no description.

Private FAxisAlignedDimensionsCache: TGLVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure BuildMesh(GLBaseMesh: TGLBaseMesh);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure ForceTotalRebuild;

This item has no description.

Public procedure GetExtents(var min, max: TAffineVector);

This item has no description.

Public procedure LoadFromFile(const aFileName: String);

This item has no description.

Public procedure LoadFromStream(aStream: TStream);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure RebuildTree;

This item has no description.

Public procedure SaveToFile(const aFileName: String);

This item has no description.

Public procedure SaveToStream(aStream: TStream);

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property AutoCenter: Boolean read FAutoCenter write SetAutoCenter;

Automatically center the tree's vertices after building them.

Published property AutoRebuild: Boolean read FAutoRebuild write SetAutoRebuild;

Automatically rebuild the tree after changing the settings

Published property BranchAngle: Single read FBranchAngle write SetBranchAngle;

Effects the balance of the tree.

Published property BranchAngleBias: Single read FBranchAngleBias write SetBranchAngleBias;

Effects the habit of the tree. Values from 0 to 1 refer to Upright to Spreading respectively.

Public property Branches: TGLTreeBranches read FBranches;

This item has no description.

Published property BranchFacets: Integer read FBranchFacets write SetBranchFacets;

The number of facets for each branch in the tree.

Published property BranchMaterialName: TGLLibMaterialName read FBranchMaterialName write SetBranchMaterialName;

This item has no description.

Published property BranchNoise: Single read FBranchNoise write SetBranchNoise;

Overall branch noise influence. Relates to the 'fullness' of the tree.

Published property BranchRadius: Single read FBranchRadius write SetBranchRadius;

Effects the thickness of the branches.

Published property BranchSize: Single read FBranchSize write SetBranchSize;

Branch length modifier.

Published property BranchTwist: Single read FBranchTwist write SetBranchTwist;

Effects the rotation of each sub branch in recursion.

Published property CenterBranchConstant: Single read FCenterBranchConstant write SetCenterBranchConstant;

Central branch can be thinner(lower values)/thicker(->1) depending on this constant. The effect also depends on the BranchAngle variable.

Published property CentralLeader: Boolean read FCentralLeader write SetCentralLeader;

Does this tree have a central leader?

Published property CentralLeaderBias: Single read FCentralLeaderBias write SetCentralLeaderBias;

Determines how BranchAngle effects the central leader (CentralLeader must = True).

Published property Depth: Integer read FDepth write SetDepth;

The depth of tree branch recursion.

Published property LeafBackMaterialName: TGLLibMaterialName read FLeafBackMaterialName write SetLeafBackMaterialName;

This item has no description.

Published property LeafMaterialName: TGLLibMaterialName read FLeafMaterialName write SetLeafMaterialName;

This item has no description.

Published property LeafSize: Single read FLeafSize write SetLeafSize;

Leaf size modifier. Leaf size is also influenced by branch recursion scale.

Published property LeafThreshold: Single read FLeafThreshold write SetLeafThreshold;

Determines how thin a branch can get before a leaf is substituted.

Public property Leaves: TGLTreeLeaves read FLeaves;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property Noise: TGLTreeBranchNoise read FNoise;

This item has no description.

Published property Seed: Integer read FSeed write SetSeed;


GLSysHelp v.2.5: GLS.VectorFileObjects

Unit GLS.VectorFileObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.Math
  • VCL.Consts
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorTypesExt
  • GLScene.TextureFormat
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLS.PersistentClasses
  • GLS.Coordinates
  • GLS.BaseClasses
  • GLScene.GeometryBB
  • GLScene.Utils
  • GLS.Scene
  • GLS.Silhouette
  • GLScene.Strings
  • GLS.Texture
  • GLS.Material
  • GLS.Mesh
  • GLS.Octree
  • GLS.ApplicationFileIO
  • GLS.Context
  • GLS.Color
  • GLScene.PipelineTransform
  • GLS.Selection
  • GLS.XOpenGL
  • GLS.MeshUtils
  • GLS.State
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseMeshObject |
Class TGLSkeletonFrame |
Class TGLSkeletonFrameList |
Class TGLSkeletonBoneList |
Class TGLSkeletonRootBoneList |
Class TGLSkeletonBone |
Class TGLSkeletonCollider |
Class TGLSkeletonColliderList |
Record TGLBlendedLerpInfo |
Class TGLSkeleton |
Class TGLMeshObject |
Class TGLMeshObjectList |
Class TGLMeshMorphTarget |
Class TGLMeshMorphTargetList |
Class TGLMorphableMeshObject |
Packed Record TGLVertexBoneWeight |
Class TGLSkeletonMeshObject |
Class TGLFaceGroup |
Class TFGVertexIndexList |
Class TFGVertexNormalTexIndexList |
Class TFGIndexTexCoordList |
Class TGLFaceGroups |
Class TGLVectorFile |
Class TGLSMVectorFile |
Class TGLBaseMesh |
Class TGLFreeForm |
Class TGLActorAnimation |
Class TGLActorAnimations |
Class TGLBaseAnimationControler |
Class TGLAnimationControler |
Class TGLActor |
Class TGLVectorFileFormat |
Class TGLVectorFileFormatsList |
Class EInvalidVectorFile |

Functions and Procedures

function GetVectorFileFormats: TGLVectorFileFormatsList;
function VectorFileFormatsFilter: string;
function VectorFileFormatsSaveFilter: string;
function VectorFileFormatExtensionByIndex(Index: Integer): string;
procedure RegisterVectorFileFormat(const aExtension, aDescription: string; AClass: TGLVectorFileClass);
procedure UnregisterVectorFileClass(AClass: TGLVectorFileClass);

Types

PGLVertexBoneWeightArray = ˆTGLVertexBoneWeightArray;
PGLVerticesBoneWeights = ˆTGLVerticesBoneWeights;
TGLActorAnimationMode = (...);
TGLActorAnimationName = string;
TGLActorAnimationReference = (...);
TGLActorFrameInterpolation = (...);
TGLActorOption = (...);
TGLActorOptions = set of TGLActorOption;
TGLFaceGroupMeshMode = (...);
TGLMeshAutoCentering = (...);
TGLMeshAutoCenterings = set of TGLMeshAutoCentering;
TGLMeshNormalsOrientation = (...);
TGLMeshObjectListClass = class of TGLMeshObjectList;
TGLMeshObjectMode = (...);
TGLMeshObjectRenderingOption = (...);
TGLMeshObjectRenderingOptions = set of TGLMeshObjectRenderingOption;
TGLSkeletonFrameTransform = (...);
TGLVBOBuffer = (...);
TGLVBOBuffers = set of TGLVBOBuffer;
TGLVectorFileClass = class of TGLVectorFile;
TGLVertexBoneWeightArray = array [0 .. MaxInt div (2 * SizeOf(TGLVertexBoneWeight))] of TGLVertexBoneWeight;
TGLVertexBoneWeightDynArray = array of TGLVertexBoneWeight;
TGLVerticesBoneWeights = array [0 .. MaxInt div (2 * SizeOf(PGLVertexBoneWeightArray))] of PGLVertexBoneWeightArray;

Constants

cDefaultActorOptions = [aoSkeletonNormalizeNormals];

Variables

vGLVectorFileObjectsAllocateMaterials: Boolean = True;
vGLVectorFileObjectsEnableVBOByDefault: Boolean = True;

Description

Functions and Procedures

function GetVectorFileFormats: TGLVectorFileFormatsList;

Read access to the list of registered vector file formats

function VectorFileFormatsFilter: string;

A file extension filter suitable for dialog's 'Filter' property

function VectorFileFormatsSaveFilter: string;

A file extension filter suitable for a savedialog's 'Filter' property

function VectorFileFormatExtensionByIndex(Index: Integer): string;

Returns an extension by its index in the vector files dialogs filter. Use VectorFileFormatsFilter to obtain the filter.

procedure RegisterVectorFileFormat(const aExtension, aDescription: string; AClass: TGLVectorFileClass);

This item has no description.

procedure UnregisterVectorFileClass(AClass: TGLVectorFileClass);

This item has no description.

Types

PGLVertexBoneWeightArray = ˆTGLVertexBoneWeightArray;

This item has no description.

PGLVerticesBoneWeights = ˆTGLVerticesBoneWeights;

This item has no description.

TGLActorAnimationMode = (...);

Defines how an actor plays between its StartFrame and EndFrame. aamNone : no animation is performed aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward aamExternal : Allows for external animation control

Values
  • aamNone
  • aamPlayOnce
  • aamLoop
  • aamBounceForward
  • aamBounceBackward
  • aamLoopBackward
  • aamExternal
TGLActorAnimationName = string;

This item has no description.

TGLActorAnimationReference = (...);

This item has no description.

Values
  • aarMorph
  • aarSkeleton
  • aarNone
TGLActorFrameInterpolation = (...);

Actor frame-interpolation mode. - afpNone : no interpolation, display CurrentFrame only - afpLinear : perform linear interpolation between current and next frame

Values
  • afpNone
  • afpLinear
TGLActorOption = (...);

Miscellanious actor options. aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance.

Values
  • aoSkeletonNormalizeNormals
TGLActorOptions = set of TGLActorOption;

This item has no description.

TGLFaceGroupMeshMode = (...);

Known descriptions for face group mesh modes. - fgmmTriangles : issue all vertices with GL_TRIANGLES. - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP. - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle. - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN. - fgmmQuads : issue all vertices with GL_QUADS.

Values
  • fgmmTriangles
  • fgmmTriangleStrip
  • fgmmFlatTriangles
  • fgmmTriangleFan
  • fgmmQuads
TGLMeshAutoCentering = (...);

This item has no description.

Values
  • macCenterX
  • macCenterY
  • macCenterZ
  • macUseBarycenter
  • macRestorePosition
TGLMeshAutoCenterings = set of TGLMeshAutoCentering;

This item has no description.

TGLMeshNormalsOrientation = (...);

Determines how normals orientation is defined in a mesh. - mnoDefault : uses default orientation - mnoInvert : inverse of default orientation - mnoAutoSolid : autocalculate to make the mesh globally solid - mnoAutoHollow : autocalculate to make the mesh globally hollow

Values
  • mnoDefault
  • mnoInvert
TGLMeshObjectListClass = class of TGLMeshObjectList;

This item has no description.

TGLMeshObjectMode = (...);

This item has no description.

Values
  • momTriangles
  • momTriangleStrip
  • momFaceGroups
TGLMeshObjectRenderingOption = (...);

Rendering options per TGLMeshObject.moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list

Values
  • moroGroupByMaterial
TGLMeshObjectRenderingOptions = set of TGLMeshObjectRenderingOption;

This item has no description.

TGLSkeletonFrameTransform = (...);

This item has no description.

Values
  • sftRotation
  • sftQuaternion
TGLVBOBuffer = (...);

This item has no description.

Values
  • vbVertices
  • vbNormals
  • vbColors
  • vbTexCoords
  • vbLightMapTexCoords
  • vbTexCoordsEx
TGLVBOBuffers = set of TGLVBOBuffer;

This item has no description.

TGLVectorFileClass = class of TGLVectorFile;

This item has no description.

TGLVertexBoneWeightArray = array [0 .. MaxInt div (2 * SizeOf(TGLVertexBoneWeight))] of TGLVertexBoneWeight;

This item has no description.

TGLVertexBoneWeightDynArray = array of TGLVertexBoneWeight;

This item has no description.

TGLVerticesBoneWeights = array [0 .. MaxInt div (2 * SizeOf(PGLVertexBoneWeightArray))] of PGLVertexBoneWeightArray;

This item has no description.

Constants

cDefaultActorOptions = [aoSkeletonNormalizeNormals];

This item has no description.

Variables

vGLVectorFileObjectsAllocateMaterials: Boolean = True;

This item has no description.

vGLVectorFileObjectsEnableVBOByDefault: Boolean = True;

Flag to avoid loading materials (useful for IDE Extentions or scene editors)


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLBaseMeshObject

Class TGLBaseMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLBaseMeshObject = class(TGLPersistentObject)

Description

A base class for mesh objects. The class introduces a set of vertices and normals for the object but does no rendering of its own

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject

Overview

Fields

Private | FName: string;
Private | FVertices: TGLAffineVectorList;
Private | FNormals: TGLAffineVectorList;
Private | FVisible: Boolean;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TGLAffineVectorList = nil; Normals: TGLAffineVectorList = nil): TGLAffineVectorList; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildNormals(vertexIndices: TGLIntegerList; mode: TGLMeshObjectMode; NormalIndices: TGLIntegerList = nil);
Public | procedure Clear; virtual;
Public | procedure GenericOrderedBuildNormals(mode: TGLMeshObjectMode);
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector); virtual;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Name: string read FName write FName;
Public | property Normals: TGLAffineVectorList read FNormals write SetNormals;
Public | property Vertices: TGLAffineVectorList read FVertices write SetVertices;
Public | property Visible: Boolean read FVisible write FVisible;

Description

Fields

Private FName: string;

This item has no description.

Private FVertices: TGLAffineVectorList;

This item has no description.

Private FNormals: TGLAffineVectorList;

This item has no description.

Private FVisible: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ExtractTriangles(texCoords: TGLAffineVectorList = nil; Normals: TGLAffineVectorList = nil): TGLAffineVectorList; virtual;

Extracts all mesh triangles as a triangles list. The resulting list size is a multiple of 3, each group of 3 vertices making up and independant triangle. The returned list can be used independantly from the mesh object (all data is duplicated) and should be freed by caller. If texCoords is specified, per vertex texture coordinates will be placed there, when available.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildNormals(vertexIndices: TGLIntegerList; mode: TGLMeshObjectMode; NormalIndices: TGLIntegerList = nil);

Builds (smoothed) normals for the vertex list. If normalIndices is nil, the method assumes a bijection between vertices and normals sets, and when performed, Normals and Vertices list will have the same number of items (whatever previously was in the Normals list is ignored/removed). If normalIndices is defined, normals will be added to the list and their indices will be added to normalIndices. Already defined normals and indices are preserved. The only valid modes are currently momTriangles and momTriangleStrip (ie. momFaceGroups not supported).

Public procedure Clear; virtual;

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure GenericOrderedBuildNormals(mode: TGLMeshObjectMode);

Builds normals faster without index calculations for the stripe mode

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure Translate(const delta: TAffineVector); virtual;

Translates all the vertices by the given delta.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Name: string read FName write FName;

This item has no description.

Public property Normals: TGLAffineVectorList read FNormals write SetNormals;

This item has no description.

Public property Vertices: TGLAffineVectorList read FVertices write SetVertices;

This item has no description.

Public property Visible: Boolean read FVisible write FVisible;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeletonFrame

Class TGLSkeletonFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeletonFrame = class(TGLPersistentObject)

Description

Stores position and rotation for skeleton joints. If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty)

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonFrame

Overview

Fields

Private | FOwner: TGLSkeletonFrameList;
Private | FName: string;
Private | FPosition: TGLAffineVectorList;
Private | FRotation: TGLAffineVectorList;
Private | FQuaternion: TGLQuaternionList;
Private | FLocalMatrixList: PMatrixArray;
Private | FTransformMode: TGLSkeletonFrameTransform;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TGLSkeletonFrameList);
Public | destructor Destroy; override;
Public | function LocalMatrixList: PMatrixArray;
Public | procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True);
Public | procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True);
Public | procedure FlushLocalMatrixList;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Name: string read FName write FName;
Public | property Owner: TGLSkeletonFrameList read FOwner;
Public | property Position: TGLAffineVectorList read FPosition write SetPosition;
Public | property Quaternion: TGLQuaternionList read FQuaternion write SetQuaternion;
Public | property Rotation: TGLAffineVectorList read FRotation write SetRotation;
Public | property TransformMode: TGLSkeletonFrameTransform read FTransformMode write FTransformMode;

Description

Fields

Private FOwner: TGLSkeletonFrameList;

This item has no description.

Private FName: string;

This item has no description.

Private FPosition: TGLAffineVectorList;

This item has no description.

Private FRotation: TGLAffineVectorList;

This item has no description.

Private FQuaternion: TGLQuaternionList;

This item has no description.

Private FLocalMatrixList: PMatrixArray;

This item has no description.

Private FTransformMode: TGLSkeletonFrameTransform;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TGLSkeletonFrameList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LocalMatrixList: PMatrixArray;

Calculate or retrieves an array of local bone matrices. This array is calculated on the first call after creation, and the first call following a FlushLocalMatrixList. Subsequent calls return the same arrays.

Public procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True);

As the name states; Convert Quaternions to Rotations or vice-versa.

Public procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True);

This item has no description.

Public procedure FlushLocalMatrixList;

Flushes (frees) then LocalMatrixList data. Call this function to allow a recalculation of local matrices.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Name: string read FName write FName;

This item has no description.

Public property Owner: TGLSkeletonFrameList read FOwner;

This item has no description.

Public property Position: TGLAffineVectorList read FPosition write SetPosition;

Position values for the joints.

Public property Quaternion: TGLQuaternionList read FQuaternion write SetQuaternion;

Quaternions are an alternative to Euler rotations to build the global matrices for the skeleton bones.

Public property Rotation: TGLAffineVectorList read FRotation write SetRotation;

Rotation values for the joints.

Public property TransformMode: TGLSkeletonFrameTransform read FTransformMode write FTransformMode;

TransformMode indicates whether to use Rotation or Quaternion to build the local transform matrices.


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeletonFrameList

Class TGLSkeletonFrameList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeletonFrameList = class(TGLPersistentObjectList)

Description

A list of TGLSkeletonFrame objects

Hierarchy

  • TGLPersistentObjectList
  • TGLSkeletonFrameList

Overview

Fields

Private FOwner: TPersistent;

Methods

Public | constructor CreateOwned(aOwner: TPersistent);
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True; SetTransformMode: Boolean = True);
Public | procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True; SetTransformMode: Boolean = True);
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;

Properties

Public | property Items[Index: Integer]: TGLSkeletonFrame read GetSkeletonFrame;
Public | property Owner: TPersistent read FOwner;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TPersistent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True; SetTransformMode: Boolean = True);

As the name states; Convert Quaternions to Rotations or vice-versa.

Public procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True; SetTransformMode: Boolean = True);

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Properties

Public property Items[Index: Integer]: TGLSkeletonFrame read GetSkeletonFrame;

This item has no description.

Public property Owner: TPersistent read FOwner;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeletonBoneList

Class TGLSkeletonBoneList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeletonBoneList = class(TGLPersistentObjectList)

Description

A list of skeleton bones

Hierarchy

  • TGLPersistentObjectList
  • TGLSkeletonBoneList

Overview

Fields

Private FSkeleton: TGLSkeleton;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TGLSkeleton);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TGLSkeletonBone; virtual;
Public | function BoneByName(const aName: string): TGLSkeletonBone; virtual;
Public | function BoneCount: Integer;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); virtual; abstract;
Public | procedure PrepareGlobalMatrices; virtual;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Items[Index: Integer]: TGLSkeletonBone read GetSkeletonBone;
Public | property Skeleton: TGLSkeleton read FSkeleton;

Description

Fields

Private FSkeleton: TGLSkeleton;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TGLSkeleton);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BoneByID(anID: Integer): TGLSkeletonBone; virtual;

Returns a bone by its BoneID, nil if not found.

Public function BoneByName(const aName: string): TGLSkeletonBone; virtual;

Returns a bone by its Name, nil if not found.

Public function BoneCount: Integer;

Number of bones (including all children and self).

Public procedure BuildList(var mrci: TGLRenderContextInfo); virtual; abstract;

Render skeleton wireframe

Public procedure PrepareGlobalMatrices; virtual;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Items[Index: Integer]: TGLSkeletonBone read GetSkeletonBone;

This item has no description.

Public property Skeleton: TGLSkeleton read FSkeleton;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeletonRootBoneList

Class TGLSkeletonRootBoneList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeletonRootBoneList = class(TGLSkeletonBoneList)

Description

This list store skeleton root bones exclusively

Hierarchy

  • TGLPersistentObjectList
  • TGLSkeletonBoneList
  • TGLSkeletonRootBoneList

Overview

Methods

Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public property GlobalMatrix: TGLMatrix read FGlobalMatrix write FGlobalMatrix;

Description

Methods

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

Render skeleton wireframe

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property GlobalMatrix: TGLMatrix read FGlobalMatrix write FGlobalMatrix;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeletonBone

Class TGLSkeletonBone

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeletonBone = class(TGLSkeletonBoneList)

Description

A skeleton bone or node and its children. This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TGLSkeletonFrame, but the calculated bone matrices are stored here.

Hierarchy

  • TGLPersistentObjectList
  • TGLSkeletonBoneList
  • TGLSkeletonBone

Overview

Fields

Private | FOwner: TGLSkeletonBoneList;
Private | FBoneID: Integer;
Private | FName: string;
Private | FColor: Cardinal;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TGLSkeletonBoneList);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TGLSkeletonBone; override;
Public | function BoneByName(const aName: string): TGLSkeletonBone; override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure Clean; override;
Public | procedure PrepareGlobalMatrices; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure SetGlobalMatrix(const Matrix: TGLMatrix);
Public | procedure SetGlobalMatrixForRagDoll(const RagDollMatrix: TGLMatrix);
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property BoneID: Integer read FBoneID write FBoneID;
Public | property Color: Cardinal read FColor write SetColor;
Public | property GlobalMatrix: TGLMatrix read FGlobalMatrix;
Public | property Items[Index: Integer]: TGLSkeletonBone read GetSkeletonBone;
Public | property Name: string read FName write FName;
Public | property Owner: TGLSkeletonBoneList read FOwner;

Description

Fields

Private FOwner: TGLSkeletonBoneList;

This item has no description.

Private FBoneID: Integer;

indirectly persistent

Private FName: string;

This item has no description.

Private FColor: Cardinal;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TGLSkeletonBoneList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BoneByID(anID: Integer): TGLSkeletonBone; override;

Returns a bone by its BoneID, nil if not found.

Public function BoneByName(const aName: string): TGLSkeletonBone; override;

This item has no description. Showing description inherited from TGLSkeletonBoneList.BoneByName.

Returns a bone by its Name, nil if not found.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

Render skeleton wireframe

Public procedure Clean; override;

Free all sub bones and reset BoneID and Name.

Public procedure PrepareGlobalMatrices; override;

Calculates the global matrix for the bone and its sub-bone. Call this function directly only the RootBone.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure SetGlobalMatrix(const Matrix: TGLMatrix);

Set the bone's matrix. Becareful using this.

Public procedure SetGlobalMatrixForRagDoll(const RagDollMatrix: TGLMatrix);

Ragdoll Set the bone's GlobalMatrix. Used for Ragdoll.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property BoneID: Integer read FBoneID write FBoneID;

This item has no description.

Public property Color: Cardinal read FColor write SetColor;

This item has no description.

Public property GlobalMatrix: TGLMatrix read FGlobalMatrix;

Global Matrix for the bone in the current frame. Global matrices must be prepared by invoking PrepareGlobalMatrices on the root bone.

Public property Items[Index: Integer]: TGLSkeletonBone read GetSkeletonBone;

This item has no description.

Public property Name: string read FName write FName;

This item has no description.

Public property Owner: TGLSkeletonBoneList read FOwner;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeletonCollider

Class TGLSkeletonCollider

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeletonCollider = class(TGLPersistentObject)

Description

A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonCollider

Overview

Fields

Private | FOwner: TGLSkeletonColliderList;
Private | FBone: TGLSkeletonBone;
Private | FBoneID: Integer;
Private | FLocalMatrix: TGLMatrix;
Private | FGlobalMatrix: TGLMatrix;
Private | FAutoUpdate: Boolean;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(AOwner: TGLSkeletonColliderList);
Public | procedure AlignCollider; virtual;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property AutoUpdate: Boolean read FAutoUpdate write FAutoUpdate;
Public | property Bone: TGLSkeletonBone read FBone write SetBone;
Public | property GlobalMatrix: TGLMatrix read FGlobalMatrix;
Public | property LocalMatrix: TGLMatrix read FLocalMatrix write SetLocalMatrix;
Public | property Owner: TGLSkeletonColliderList read FOwner;

Description

Fields

Private FOwner: TGLSkeletonColliderList;

This item has no description.

Private FBone: TGLSkeletonBone;

This item has no description.

Private FBoneID: Integer;

This item has no description.

Private FLocalMatrix: TGLMatrix;

This item has no description.

Private FGlobalMatrix: TGLMatrix;

This item has no description.

Private FAutoUpdate: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(AOwner: TGLSkeletonColliderList);

This item has no description.

Public procedure AlignCollider; virtual;

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property AutoUpdate: Boolean read FAutoUpdate write FAutoUpdate;

This item has no description.

Public property Bone: TGLSkeletonBone read FBone write SetBone;

The bone that this collider associates with.

Public property GlobalMatrix: TGLMatrix read FGlobalMatrix;

Global offset and orientation of the collider. This gets set in the AlignCollider method.

Public property LocalMatrix: TGLMatrix read FLocalMatrix write SetLocalMatrix;

Offset and orientation of the collider in the associated bone's space.

Public property Owner: TGLSkeletonColliderList read FOwner;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeletonColliderList

Class TGLSkeletonColliderList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeletonColliderList = class(TGLPersistentObjectList)

Description

List class for storing TGLSkeletonCollider objects

Hierarchy

  • TGLPersistentObjectList
  • TGLSkeletonColliderList

Overview

Fields

Private FOwner: TPersistent;

Methods

Public | constructor CreateOwned(AOwner: TPersistent);
Public | destructor Destroy; override;
Public | procedure AlignColliders;
Public | procedure Clear; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;

Properties

Public | property Items[Index: Integer]: TGLSkeletonCollider read GetSkeletonCollider;
Public | property Owner: TPersistent read FOwner;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TPersistent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AlignColliders;

Calls AlignCollider for each collider in the list.

Public procedure Clear; override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Properties

Public property Items[Index: Integer]: TGLSkeletonCollider read GetSkeletonCollider;

This item has no description.

Public property Owner: TPersistent read FOwner;


GLSysHelp v.2.5: GLS.VectorFileObjects: Record TGLBlendedLerpInfo

Record TGLBlendedLerpInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLBlendedLerpInfo = record

Description

Small structure to store a weighted lerp for use in blending

Overview

Fields

Public | FrameIndex1: Integer;
Public | frameIndex2: Integer;
Public | LerpFactor: Single;
Public | Weight: Single;
Public | ExternalPositions: TGLAffineVectorList;
Public | ExternalRotations: TGLAffineVectorList;
Public | ExternalQuaternions: TGLQuaternionList;

Description

Fields

Public FrameIndex1: Integer;

This item has no description.

Public frameIndex2: Integer;

This item has no description.

Public LerpFactor: Single;

This item has no description.

Public Weight: Single;

This item has no description.

Public ExternalPositions: TGLAffineVectorList;

This item has no description.

Public ExternalRotations: TGLAffineVectorList;

This item has no description.

Public ExternalQuaternions: TGLQuaternionList;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeleton

Class TGLSkeleton

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeleton = class(TGLPersistentObject)

Description

Main skeleton object. This class stores the bones hierarchy and animation frames. It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.

Hierarchy

  • TGLPersistentObject
  • TGLSkeleton

Overview

Fields

Private | FOwner: TGLBaseMesh;
Private | FRootBones: TGLSkeletonRootBoneList;
Private | FFrames: TGLSkeletonFrameList;
Private | FCurrentFrame: TGLSkeletonFrame;
Private | FBonesByIDCache: TList;
Private | FColliders: TGLSkeletonColliderList;
Private | FRagDollEnabled: Boolean;
Private | FMorphInvisibleParts: Boolean;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TGLBaseMesh);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TGLSkeletonBone;
Public | function BoneByName(const aName: string): TGLSkeletonBone;
Public | function BoneCount: Integer;
Public | procedure BlendedLerps(const lerpInfos: array of TGLBlendedLerpInfo);
Public | procedure Clear;
Public | procedure FlushBoneByIDCache;
Public | procedure Lerp(frameIndex1, frameIndex2: Integer; lerpFactor: Single);
Public | procedure MakeSkeletalRotationDelta(startFrame, endFrame: Integer);
Public | procedure MakeSkeletalTranslationStatic(startFrame, endFrame: Integer);
Public | procedure MorphMesh(normalize: Boolean);
Public | procedure MorphTo(frameIndex: Integer); overload;
Public | procedure MorphTo(frame: TGLSkeletonFrame); overload;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure StartRagdoll;
Public | procedure StopRagdoll;
Public | procedure Synchronize(reference: TGLSkeleton);
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property Colliders: TGLSkeletonColliderList read FColliders write SetColliders;
Public | property CurrentFrame: TGLSkeletonFrame read GetCurrentFrame write SetCurrentFrame;
Public | property Frames: TGLSkeletonFrameList read FFrames write SetFrames;
Public | property MorphInvisibleParts: Boolean read FMorphInvisibleParts write FMorphInvisibleParts;
Public | property Owner: TGLBaseMesh read FOwner;
Public | property RootBones: TGLSkeletonRootBoneList read FRootBones write SetRootBones;

Description

Fields

Private FOwner: TGLBaseMesh;

This item has no description.

Private FRootBones: TGLSkeletonRootBoneList;

This item has no description.

Private FFrames: TGLSkeletonFrameList;

This item has no description.

Private FCurrentFrame: TGLSkeletonFrame;

This item has no description.

Private FBonesByIDCache: TList;

not persistent

Private FColliders: TGLSkeletonColliderList;

This item has no description.

Private FRagDollEnabled: Boolean;

This item has no description.

Private FMorphInvisibleParts: Boolean;

ragdoll

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TGLBaseMesh);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BoneByID(anID: Integer): TGLSkeletonBone;

This item has no description.

Public function BoneByName(const aName: string): TGLSkeletonBone;

This item has no description.

Public function BoneCount: Integer;

This item has no description.

Public procedure BlendedLerps(const lerpInfos: array of TGLBlendedLerpInfo);

This item has no description.

Public procedure Clear;

Release bones and frames info.

Public procedure FlushBoneByIDCache;

This item has no description.

Public procedure Lerp(frameIndex1, frameIndex2: Integer; lerpFactor: Single);

This item has no description.

Public procedure MakeSkeletalRotationDelta(startFrame, endFrame: Integer);

Removes the absolute rotation component of the skeletal frames. Some formats will store frames with absolute rotation information, if this correct if the animation is the "main" animation. This function removes that absolute information, making the animation frames suitable for blending purposes.

Public procedure MakeSkeletalTranslationStatic(startFrame, endFrame: Integer);

Linearly removes the translation component between skeletal frames. This function will compute the translation of the first bone (index 0) and linearly subtract this translation in all frames between startFrame and endFrame. Its purpose is essentially to remove the 'slide' that exists in some animation formats (f.i. SMD).

Public procedure MorphMesh(normalize: Boolean);

Applies current frame to morph all mesh objects.

Public procedure MorphTo(frameIndex: Integer); overload;

This item has no description.

Public procedure MorphTo(frame: TGLSkeletonFrame); overload;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure StartRagdoll;

Backup and prepare the BoneMatrixInvertedMeshes to use with ragdolls

Public procedure StopRagdoll;

Restore the BoneMatrixInvertedMeshes to stop the ragdoll

Public procedure Synchronize(reference: TGLSkeleton);

Copy bone rotations from reference skeleton.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Colliders: TGLSkeletonColliderList read FColliders write SetColliders;

This item has no description.

Public property CurrentFrame: TGLSkeletonFrame read GetCurrentFrame write SetCurrentFrame;

This item has no description.

Public property Frames: TGLSkeletonFrameList read FFrames write SetFrames;

This item has no description.

Public property MorphInvisibleParts: Boolean read FMorphInvisibleParts write FMorphInvisibleParts;

Turning this option off (by default) allows to increase FPS, but may break backwards-compatibility, because some may choose to attach other objects to invisible parts.

Public property Owner: TGLBaseMesh read FOwner;

This item has no description.

Public property RootBones: TGLSkeletonRootBoneList read FRootBones write SetRootBones;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLMeshObject

Class TGLMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLMeshObject = class(TGLBaseMeshObject)

Description

Base mesh class. Introduces base methods and properties for mesh objects. Subclasses are named "TGLMOxxx".

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject

Overview

Fields

Private | FOwner: TGLMeshObjectList;
Private | FExtentCacheRevision: Cardinal;
Private | FTexCoords: TGLAffineVectorList;
Private | FLightMapTexCoords: TGLAffineVectorList;
Private | FColors: TGLVectorList;
Private | FFaceGroups: TGLFaceGroups;
Private | FMode: TGLMeshObjectMode;
Private | FRenderingOptions: TGLMeshObjectRenderingOptions;
Private | FArraysDeclared: Boolean;
Private | FLightMapArrayEnabled: Boolean;
Private | FLastLightMapIndex: Integer;
Private | FTexCoordsEx: TList;
Private | FBinormalsTexCoordIndex: Integer;
Private | FTangentsTexCoordIndex: Integer;
Private | FLastXOpenGLTexMapping: Cardinal;
Private | FUseVBO: Boolean;
Private | FVerticesVBO: TGLVBOHandle;
Private | FNormalsVBO: TGLVBOHandle;
Private | FColorsVBO: TGLVBOHandle;
Private | FTexCoordsVBO: array of TGLVBOHandle;
Private | FLightmapTexCoordsVBO: TGLVBOHandle;
Private | FValidBuffers: TGLVBOBuffers;
Private | FExtentCache: TAABB;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(AOwner: TGLMeshObjectList);
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TGLAffineVectorList = nil; Normals: TGLAffineVectorList = nil): TGLAffineVectorList; override;
Public | function GetBarycenter: TGLVector;
Public | function PointInObject(const aPoint: TAffineVector): Boolean; virtual;
Public | function TriangleCount: Integer; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); virtual;
Public | procedure BuildTangentSpace(buildBinormals: Boolean = True; buildTangents: Boolean = True);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure GetExtents(out aabb: TAABB); overload; virtual;
Public | procedure GetExtents(out min, max: TAffineVector); overload; virtual;
Public | procedure GetTriangleData(tri: Integer; list: TGLVectorList; var v0, v1, v2: TGLVector); overload;
Public | procedure GetTriangleData(tri: Integer; list: TGLAffineVectorList; var v0, v1, v2: TAffineVector); overload;
Public | procedure Prepare; virtual;
Public | procedure PrepareBuildList(var mrci: TGLRenderContextInfo); virtual;
Public | procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure SetTriangleData(tri: Integer; list: TGLAffineVectorList; const v0, v1, v2: TAffineVector); overload;
Public | procedure SetTriangleData(tri: Integer; list: TGLVectorList; const v0, v1, v2: TGLVector); overload;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;
Private | procedure SetUseVBO(const Value: Boolean);
Private | procedure SetValidBuffers(Value: TGLVBOBuffers);

Properties

Public | property Binormals: TGLVectorList read GetBinormals write SetBinormals;
Public | property BinormalsTexCoordIndex: Integer read FBinormalsTexCoordIndex write SetBinormalsTexCoordIndex;
Public | property Colors: TGLVectorList read FColors write SetColors;
Public | property FaceGroups: TGLFaceGroups read FFaceGroups;
Public | property LightMapTexCoords: TGLAffineVectorList read FLightMapTexCoords write SetLightmapTexCoords;
Public | property Mode: TGLMeshObjectMode read FMode write FMode;
Public | property Owner: TGLMeshObjectList read FOwner;
Public | property RenderingOptions: TGLMeshObjectRenderingOptions read FRenderingOptions write FRenderingOptions;
Public | property Tangents: TGLVectorList read GetTangents write SetTangents;
Public | property TangentsTexCoordIndex: Integer read FTangentsTexCoordIndex write SetTangentsTexCoordIndex;
Public | property TexCoords: TGLAffineVectorList read FTexCoords write SetTexCoords;
Public | property TexCoordsEx[index: Integer]: TGLVectorList read GetTexCoordsEx write SetTexCoordsEx;
Public | property UseVBO: Boolean read FUseVBO write SetUseVBO;

Description

Fields

Private FOwner: TGLMeshObjectList;

This item has no description.

Private FExtentCacheRevision: Cardinal;

This item has no description.

Private FTexCoords: TGLAffineVectorList;

This item has no description.

Private FLightMapTexCoords: TGLAffineVectorList;

provision for 3D textures

Private FColors: TGLVectorList;

reserved for 2D surface needs

Private FFaceGroups: TGLFaceGroups;

This item has no description.

Private FMode: TGLMeshObjectMode;

This item has no description.

Private FRenderingOptions: TGLMeshObjectRenderingOptions;

This item has no description.

Private FArraysDeclared: Boolean;

This item has no description.

Private FLightMapArrayEnabled: Boolean;

not persistent

Private FLastLightMapIndex: Integer;

not persistent

Private FTexCoordsEx: TList;

not persistent

Private FBinormalsTexCoordIndex: Integer;

This item has no description.

Private FTangentsTexCoordIndex: Integer;

This item has no description.

Private FLastXOpenGLTexMapping: Cardinal;

This item has no description.

Private FUseVBO: Boolean;

This item has no description.

Private FVerticesVBO: TGLVBOHandle;

This item has no description.

Private FNormalsVBO: TGLVBOHandle;

This item has no description.

Private FColorsVBO: TGLVBOHandle;

This item has no description.

Private FTexCoordsVBO: array of TGLVBOHandle;

This item has no description.

Private FLightmapTexCoordsVBO: TGLVBOHandle;

This item has no description.

Private FValidBuffers: TGLVBOBuffers;

This item has no description.

Private FExtentCache: TAABB;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(AOwner: TGLMeshObjectList);

Creates, assigns Owner and adds to list.

Public destructor Destroy; override;

This item has no description.

Public function ExtractTriangles(texCoords: TGLAffineVectorList = nil; Normals: TGLAffineVectorList = nil): TGLAffineVectorList; override;

This item has no description. Showing description inherited from TGLBaseMeshObject.ExtractTriangles.

Extracts all mesh triangles as a triangles list. The resulting list size is a multiple of 3, each group of 3 vertices making up and independant triangle. The returned list can be used independantly from the mesh object (all data is duplicated) and should be freed by caller. If texCoords is specified, per vertex texture coordinates will be placed there, when available.

Public function GetBarycenter: TGLVector;

Barycenter from vertices data

Public function PointInObject(const aPoint: TAffineVector): Boolean; virtual;

This item has no description.

Public function TriangleCount: Integer; virtual;

Returns number of triangles in the mesh object.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var mrci: TGLRenderContextInfo); virtual;

Similar to regular scene object's BuildList method

Public procedure BuildTangentSpace(buildBinormals: Boolean = True; buildTangents: Boolean = True);

Build the tangent space from the mesh object's vertex, normal and texcoord data, filling the binormals and tangents where specified.

Public procedure Clear; override;

This item has no description. Showing description inherited from TGLBaseMeshObject.Clear.

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure DropMaterialLibraryCache;

This item has no description.

Public procedure GetExtents(out aabb: TAABB); overload; virtual;

This item has no description.

Public procedure GetExtents(out min, max: TAffineVector); overload; virtual;

The extents of the object (min and max coordinates)

Public procedure GetTriangleData(tri: Integer; list: TGLVectorList; var v0, v1, v2: TGLVector); overload;

This item has no description.

Public procedure GetTriangleData(tri: Integer; list: TGLAffineVectorList; var v0, v1, v2: TAffineVector); overload;

Returns the triangle data for a given triangle

Public procedure Prepare; virtual;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareBuildList(var mrci: TGLRenderContextInfo); virtual;

Prepare the texture and materials before rendering. Invoked once, before building the list and NOT while building the list.

Public procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure SetTriangleData(tri: Integer; list: TGLAffineVectorList; const v0, v1, v2: TAffineVector); overload;

Sets the triangle data of a given triangle

Public procedure SetTriangleData(tri: Integer; list: TGLVectorList; const v0, v1, v2: TGLVector); overload;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Private procedure SetUseVBO(const Value: Boolean);

This item has no description.

Private procedure SetValidBuffers(Value: TGLVBOBuffers);

This item has no description.

Properties

Public property Binormals: TGLVectorList read GetBinormals write SetBinormals;

A TexCoordsEx list wrapper for binormals usage, returns TexCoordsEx[BinormalsTexCoordIndex].

Public property BinormalsTexCoordIndex: Integer read FBinormalsTexCoordIndex write SetBinormalsTexCoordIndex;

Specify the texcoord extension index for binormals (default = 2)

Public property Colors: TGLVectorList read FColors write SetColors;

This item has no description.

Public property FaceGroups: TGLFaceGroups read FFaceGroups;

This item has no description.

Public property LightMapTexCoords: TGLAffineVectorList read FLightMapTexCoords write SetLightmapTexCoords;

This item has no description.

Public property Mode: TGLMeshObjectMode read FMode write FMode;

This item has no description.

Public property Owner: TGLMeshObjectList read FOwner;

This item has no description.

Public property RenderingOptions: TGLMeshObjectRenderingOptions read FRenderingOptions write FRenderingOptions;

This item has no description.

Public property Tangents: TGLVectorList read GetTangents write SetTangents;

A TexCoordsEx list wrapper for tangents usage, returns TexCoordsEx[BinormalsTexCoordIndex].

Public property TangentsTexCoordIndex: Integer read FTangentsTexCoordIndex write SetTangentsTexCoordIndex;

Specify the texcoord extension index for tangents (default = 3)

Public property TexCoords: TGLAffineVectorList read FTexCoords write SetTexCoords;

This item has no description.

Public property TexCoordsEx[index: Integer]: TGLVectorList read GetTexCoordsEx write SetTexCoordsEx;

The TexCoords Extension is a list of vector lists that are used to extend the vertex data applied during rendering. The lists are applied to the GL_TEXTURE0_ARB + index texture environment. This means that if TexCoordsEx 0 or 1 have data it will override the TexCoords or LightMapTexCoords repectively. Lists are created on demand, meaning that if you request TexCoordsEx[4] it will create the list up to and including 4. The extensions are only applied to the texture environment if they contain data.

Public property UseVBO: Boolean read FUseVBO write SetUseVBO;

If set, rendering will use VBO's instead of vertex arrays.


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLMeshObjectList

Class TGLMeshObjectList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLMeshObjectList = class(TGLPersistentObjectList)

Description

A list of TGLMeshObject objects.

Hierarchy

  • TGLPersistentObjectList
  • TGLMeshObjectList

Overview

Fields

Private FOwner: TGLBaseMesh;

Methods

Public | constructor CreateOwned(aOwner: TGLBaseMesh);
Public | destructor Destroy; override;
Public | function Area: Single;
Public | function ExtractTriangles(texCoords: TGLAffineVectorList = nil; normals: TGLAffineVectorList = nil): TGLAffineVectorList;
Public | function FindMeshByName(const MeshName: string): TGLMeshObject;
Public | function MorphTargetCount: Integer;
Public | function TriangleCount: Integer;
Public | function Volume: Single;
Private | function GetUseVBO: Boolean;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); virtual;
Public | procedure BuildTangentSpace(buildBinormals: Boolean = True; buildTangents: Boolean = True);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure GetExtents(out min, max: TAffineVector);
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single);
Public | procedure MorphTo(morphTargetIndex: Integer);
Public | procedure Prepare; virtual;
Public | procedure PrepareBuildList(var mrci: TGLRenderContextInfo); virtual;
Public | procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector);
Private | procedure SetUseVBO(const Value: Boolean);

Properties

Public | property Items[Index: Integer]: TGLMeshObject read GetMeshObject;
Public | property Owner: TGLBaseMesh read FOwner;
Public | property UseVBO: Boolean read GetUseVBO write SetUseVBO;

Description

Fields

Private FOwner: TGLBaseMesh;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TGLBaseMesh);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Area: Single;

Returns the total Area of meshes in the list.

Public function ExtractTriangles(texCoords: TGLAffineVectorList = nil; normals: TGLAffineVectorList = nil): TGLAffineVectorList;

This item has no description.

Public function FindMeshByName(const MeshName: string): TGLMeshObject;

This item has no description.

Public function MorphTargetCount: Integer;

This item has no description.

Public function TriangleCount: Integer;

Returns number of triangles in the meshes of the list.

Public function Volume: Single;

Returns the total volume of meshes in the list.

Private function GetUseVBO: Boolean;

Returns True if all its MeshObjects use VBOs.

Public procedure BuildList(var mrci: TGLRenderContextInfo); virtual;

Similar to regular scene object's BuildList method

Public procedure BuildTangentSpace(buildBinormals: Boolean = True; buildTangents: Boolean = True);

Build the tangent space from the mesh object's vertex, normal and texcoord data, filling the binormals and tangents where specified.

Public procedure Clear; override;

This item has no description.

Public procedure DropMaterialLibraryCache;

This item has no description.

Public procedure GetExtents(out min, max: TAffineVector);

This item has no description.

Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single);

This item has no description.

Public procedure MorphTo(morphTargetIndex: Integer);

This item has no description.

Public procedure Prepare; virtual;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareBuildList(var mrci: TGLRenderContextInfo); virtual;

Prepare the texture and materials before rendering. Invoked once, before building the list and NOT while building the list.

Public procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure Translate(const delta: TAffineVector);

This item has no description.

Private procedure SetUseVBO(const Value: Boolean);

This item has no description.

Properties

Public property Items[Index: Integer]: TGLMeshObject read GetMeshObject;

This item has no description.

Public property Owner: TGLBaseMesh read FOwner;

This item has no description.

Public property UseVBO: Boolean read GetUseVBO write SetUseVBO;

If set, rendering will use VBO's instead of vertex arrays. Resturns True if all its MeshObjects use VBOs.


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLMeshMorphTarget

Class TGLMeshMorphTarget

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLMeshMorphTarget = class(TGLBaseMeshObject)

Description

A morph target, stores alternate lists of vertices and normals.

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshMorphTarget

Overview

Fields

Private FOwner: TGLMeshMorphTargetList;

Methods

Public | constructor CreateOwned(aOwner: TGLMeshMorphTargetList);
Public | destructor Destroy; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public property Owner: TGLMeshMorphTargetList read FOwner;

Description

Fields

Private FOwner: TGLMeshMorphTargetList;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TGLMeshMorphTargetList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Owner: TGLMeshMorphTargetList read FOwner;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLMeshMorphTargetList

Class TGLMeshMorphTargetList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLMeshMorphTargetList = class(TGLPersistentObjectList)

Description

A list of TGLMeshMorphTarget objects.

Hierarchy

  • TGLPersistentObjectList
  • TGLMeshMorphTargetList

Overview

Fields

Private FOwner: TPersistent;

Methods

Public | constructor CreateOwned(AOwner: TPersistent);
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector);

Properties

Public | property Items[Index: Integer]: TGLMeshMorphTarget read GeTGLMeshMorphTarget;
Public | property Owner: TPersistent read FOwner;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TPersistent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure Translate(const delta: TAffineVector);

This item has no description.

Properties

Public property Items[Index: Integer]: TGLMeshMorphTarget read GeTGLMeshMorphTarget;

This item has no description.

Public property Owner: TPersistent read FOwner;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLMorphableMeshObject

Class TGLMorphableMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLMorphableMeshObject = class(TGLMeshObject)

Description

Mesh object with support for morph targets. The morph targets allow to change vertices and normals according to pre-existing "morph targets".

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TGLMorphableMeshObject

Overview

Fields

Private FMorphTargets: TGLMeshMorphTargetList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single); virtual;
Public | procedure MorphTo(morphTargetIndex: Integer); virtual;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public property MorphTargets: TGLMeshMorphTargetList read FMorphTargets;

Description

Fields

Private FMorphTargets: TGLMeshMorphTargetList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Clear; override;

This item has no description. Showing description inherited from TGLBaseMeshObject.Clear.

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single); virtual;

This item has no description.

Public procedure MorphTo(morphTargetIndex: Integer); virtual;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure Translate(const delta: TAffineVector); override;

This item has no description. Showing description inherited from TGLBaseMeshObject.Translate.

Translates all the vertices by the given delta.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property MorphTargets: TGLMeshMorphTargetList read FMorphTargets;


GLSysHelp v.2.5: GLS.VectorFileObjects: Packed Record TGLVertexBoneWeight

Packed Record TGLVertexBoneWeight

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLVertexBoneWeight = packed record

Description

This item has no description.

Overview

Fields

Public | BoneID: Integer;
Public | weight: Single;

Description

Fields

Public BoneID: Integer;

This item has no description.

Public weight: Single;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSkeletonMeshObject

Class TGLSkeletonMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSkeletonMeshObject = class(TGLMorphableMeshObject)

Description

A mesh object with vertice bone attachments. The class adds per vertex bone weights to the standard morphable mesh. The TGLVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method. When BonesPerVertex is 1, the weight is ignored (set to 1.0).

Hierarchy

  • TGLPersistentObject
  • TGLBaseMeshObject
  • TGLMeshObject
  • TGLMorphableMeshObject
  • TGLSkeletonMeshObject

Overview

Fields

Private | FVerticesBonesWeights: PGLVerticesBoneWeights;
Private | FVerticeBoneWeightCount: Integer;
Private | FVerticeBoneWeightCapacity: Integer;
Private | FBonesPerVertex: Integer;
Private | FLastVerticeBoneWeightCount: Integer;
Private | FLastBonesPerVertex: Integer;
Private | FBoneMatrixInvertedMeshes: TList;
Private | FBackupInvertedMeshes: TList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function FindOrAdd(const boneIDs: TGLVertexBoneWeightDynArray; const vertex, normal: TAffineVector): Integer; overload;
Public | function FindOrAdd(BoneID: Integer; const vertex, normal: TAffineVector): Integer; overload;
Public | procedure AddWeightedBone(aBoneID: Integer; aWeight: Single);
Public | procedure AddWeightedBones(const boneIDs: TGLVertexBoneWeightDynArray);
Public | procedure ApplyCurrentSkeletonFrame(normalize: Boolean);
Public | procedure Clear; override;
Public | procedure PrepareBoneMatrixInvertedMeshes;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;
Private | procedure BackupBoneMatrixInvertedMeshes;
Private | procedure RestoreBoneMatrixInvertedMeshes;

Properties

Public | property BonesPerVertex: Integer read FBonesPerVertex write SetBonesPerVertex;
Public | property VerticeBoneWeightCapacity: Integer read FVerticeBoneWeightCapacity write SetVerticeBoneWeightCapacity;
Public | property VerticeBoneWeightCount: Integer read FVerticeBoneWeightCount write SetVerticeBoneWeightCount;
Public | property VerticesBonesWeights: PGLVerticesBoneWeights read FVerticesBonesWeights;

Description

Fields

Private FVerticesBonesWeights: PGLVerticesBoneWeights;

This item has no description.

Private FVerticeBoneWeightCount: Integer;

This item has no description.

Private FVerticeBoneWeightCapacity: Integer;

This item has no description.

Private FBonesPerVertex: Integer;

This item has no description.

Private FLastVerticeBoneWeightCount: Integer;

This item has no description.

Private FLastBonesPerVertex: Integer;

This item has no description.

Private FBoneMatrixInvertedMeshes: TList;

not persistent

Private FBackupInvertedMeshes: TList;

not persistent

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindOrAdd(const boneIDs: TGLVertexBoneWeightDynArray; const vertex, normal: TAffineVector): Integer; overload;

This item has no description.

Public function FindOrAdd(BoneID: Integer; const vertex, normal: TAffineVector): Integer; overload;

This item has no description.

Public procedure AddWeightedBone(aBoneID: Integer; aWeight: Single);

This item has no description.

Public procedure AddWeightedBones(const boneIDs: TGLVertexBoneWeightDynArray);

This item has no description.

Public procedure ApplyCurrentSkeletonFrame(normalize: Boolean);

This item has no description.

Public procedure Clear; override;

This item has no description. Showing description inherited from TGLBaseMeshObject.Clear.

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure PrepareBoneMatrixInvertedMeshes;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Private procedure BackupBoneMatrixInvertedMeshes;

ragdoll

Private procedure RestoreBoneMatrixInvertedMeshes;

ragdoll

Properties

Public property BonesPerVertex: Integer read FBonesPerVertex write SetBonesPerVertex;

This item has no description.

Public property VerticeBoneWeightCapacity: Integer read FVerticeBoneWeightCapacity write SetVerticeBoneWeightCapacity;

This item has no description.

Public property VerticeBoneWeightCount: Integer read FVerticeBoneWeightCount write SetVerticeBoneWeightCount;

This item has no description.

Public property VerticesBonesWeights: PGLVerticesBoneWeights read FVerticesBonesWeights;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLFaceGroup

Class TGLFaceGroup

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLFaceGroup = class(TGLPersistentObject)

Description

Describes a face group of a TGLMeshObject. Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object". Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.

Hierarchy

  • TGLPersistentObject
  • TGLFaceGroup

Overview

Fields

Private | FOwner: TGLFaceGroups;
Private | FMaterialName: string;
Private | FMaterialCache: TGLLibMaterial;
Private | FLightMapIndex: Integer;
Private | FRenderGroupID: Integer;

Methods

Public | constructor CreateOwned(aOwner: TGLFaceGroups); virtual;
Public | destructor Destroy; override;
Public | function TriangleCount: Integer; virtual; abstract;
Public | procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil); virtual;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); virtual; abstract;
Public | procedure DropMaterialLibraryCache;
Public | procedure Prepare; virtual;
Public | procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure Reverse; virtual;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property LightMapIndex: Integer read FLightMapIndex write FLightMapIndex;
Public | property MaterialCache: TGLLibMaterial read FMaterialCache;
Public | property MaterialName: string read FMaterialName write FMaterialName;
Public | property Owner: TGLFaceGroups read FOwner write FOwner;

Description

Fields

Private FOwner: TGLFaceGroups;

This item has no description.

Private FMaterialName: string;

This item has no description.

Private FMaterialCache: TGLLibMaterial;

This item has no description.

Private FLightMapIndex: Integer;

This item has no description.

Private FRenderGroupID: Integer;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TGLFaceGroups); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TriangleCount: Integer; virtual; abstract;

Returns number of triangles in the facegroup.

Public procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil); virtual;

Add to the list the triangles corresponding to the facegroup. This function is used by TGLMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TGLRenderContextInfo); virtual; abstract;

This item has no description.

Public procedure DropMaterialLibraryCache;

This item has no description.

Public procedure Prepare; virtual;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure Reverse; virtual;

Reverses the rendering order of faces. Default implementation does nothing

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property LightMapIndex: Integer read FLightMapIndex write FLightMapIndex;

Index of lightmap in the lightmap library.

Public property MaterialCache: TGLLibMaterial read FMaterialCache;

This item has no description.

Public property MaterialName: string read FMaterialName write FMaterialName;

This item has no description.

Public property Owner: TGLFaceGroups read FOwner write FOwner;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TFGVertexIndexList

Class TFGVertexIndexList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TFGVertexIndexList = class(TGLFaceGroup)

Description

A face group based on an indexlist. The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.

Hierarchy

  • TGLPersistentObject
  • TGLFaceGroup
  • TFGVertexIndexList

Overview

Fields

Private | FVertexIndices: TGLIntegerList;
Private | FIndexVBO: TGLVBOElementArrayHandle;
Private | FMode: TGLFaceGroupMeshMode;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function GetNormal: TAffineVector;
Public | function TriangleCount: Integer; override;
Public | procedure Add(idx: Integer); inline;
Public | procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure ConvertToList;
Public | procedure GetExtents(var min, max: TAffineVector);
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure Reverse; override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;
Private | procedure InvalidateVBO;
Private | procedure SetupVBO;

Properties

Public | property Mode: TGLFaceGroupMeshMode read FMode write FMode;
Public | property VertexIndices: TGLIntegerList read FVertexIndices write SetVertexIndices;

Description

Fields

Private FVertexIndices: TGLIntegerList;

This item has no description.

Private FIndexVBO: TGLVBOElementArrayHandle;

This item has no description.

Private FMode: TGLFaceGroupMeshMode;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetNormal: TAffineVector;

Return the normal from the 1st three points in the facegroup

Public function TriangleCount: Integer; override;

This item has no description. Showing description inherited from TGLFaceGroup.TriangleCount.

Returns number of triangles in the facegroup.

Public procedure Add(idx: Integer); inline;

This item has no description.

Public procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil); override;

This item has no description. Showing description inherited from TGLFaceGroup.AddToTriangles.

Add to the list the triangles corresponding to the facegroup. This function is used by TGLMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description.

Public procedure ConvertToList;

If mode is strip or fan, convert the indices to triangle list indices.

Public procedure GetExtents(var min, max: TAffineVector);

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure Reverse; override;

This item has no description. Showing description inherited from TGLFaceGroup.Reverse.

Reverses the rendering order of faces. Default implementation does nothing

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Private procedure InvalidateVBO;

This item has no description.

Private procedure SetupVBO;

This item has no description.

Properties

Public property Mode: TGLFaceGroupMeshMode read FMode write FMode;

This item has no description.

Public property VertexIndices: TGLIntegerList read FVertexIndices write SetVertexIndices;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TFGVertexNormalTexIndexList

Class TFGVertexNormalTexIndexList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TFGVertexNormalTexIndexList = class(TFGVertexIndexList)

Description

Adds normals and texcoords indices. Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.

Hierarchy

  • TGLPersistentObject
  • TGLFaceGroup
  • TFGVertexIndexList
  • TFGVertexNormalTexIndexList

Overview

Fields

Private | FNormalIndices: TGLIntegerList;
Private | FTexCoordIndices: TGLIntegerList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Add(vertexIdx, normalIdx, texCoordIdx: Integer);
Public | procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public | property NormalIndices: TGLIntegerList read FNormalIndices write SetNormalIndices;
Public | property TexCoordIndices: TGLIntegerList read FTexCoordIndices write SetTexCoordIndices;

Description

Fields

Private FNormalIndices: TGLIntegerList;

This item has no description.

Private FTexCoordIndices: TGLIntegerList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Add(vertexIdx, normalIdx, texCoordIdx: Integer);

This item has no description.

Public procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil); override;

This item has no description. Showing description inherited from TGLFaceGroup.AddToTriangles.

Add to the list the triangles corresponding to the facegroup. This function is used by TGLMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property NormalIndices: TGLIntegerList read FNormalIndices write SetNormalIndices;

This item has no description.

Public property TexCoordIndices: TGLIntegerList read FTexCoordIndices write SetTexCoordIndices;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TFGIndexTexCoordList

Class TFGIndexTexCoordList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TFGIndexTexCoordList = class(TFGVertexIndexList)

Description

Adds per index texture coordinates to its ancestor. Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.

Hierarchy

  • TGLPersistentObject
  • TGLFaceGroup
  • TFGVertexIndexList
  • TFGIndexTexCoordList

Overview

Fields

Private FTexCoords: TGLAffineVectorList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Add(idx: Integer; const texCoord: TAffineVector); overload;
Public | procedure Add(idx: Integer; const s, t: Single); overload;
Public | procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TGLRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(writer: TGLVirtualWriter); override;

Properties

Public property TexCoords: TGLAffineVectorList read FTexCoords write SetTexCoords;

Description

Fields

Private FTexCoords: TGLAffineVectorList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Add(idx: Integer; const texCoord: TAffineVector); overload;

This item has no description.

Public procedure Add(idx: Integer; const s, t: Single); overload;

This item has no description.

Public procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil); override;

This item has no description. Showing description inherited from TGLFaceGroup.AddToTriangles.

Add to the list the triangles corresponding to the facegroup. This function is used by TGLMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TGLRenderContextInfo); override;

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property TexCoords: TGLAffineVectorList read FTexCoords write SetTexCoords;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLFaceGroups

Class TGLFaceGroups

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLFaceGroups = class(TGLPersistentObjectList)

Description

A list of TGLFaceGroup objects.

Hierarchy

  • TGLPersistentObjectList
  • TGLFaceGroups

Overview

Fields

Private FOwner: TGLMeshObject;

Methods

Public | constructor CreateOwned(aOwner: TGLMeshObject);
Public | destructor Destroy; override;
Public | function MaterialLibrary: TGLMaterialLibrary;
Public | procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public | procedure ReadFromFiler(reader: TGLVirtualReader); override;
Public | procedure SortByMaterial;

Properties

Public | property Items[Index: Integer]: TGLFaceGroup read GetFaceGroup;
Public | property Owner: TGLMeshObject read FOwner;

Description

Fields

Private FOwner: TGLMeshObject;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TGLMeshObject);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MaterialLibrary: TGLMaterialLibrary;

Material Library of the owner TGLBaseMesh.

Public procedure AddToTriangles(aList: TGLAffineVectorList; aTexCoords: TGLAffineVectorList = nil; aNormals: TGLAffineVectorList = nil);

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure DropMaterialLibraryCache;

This item has no description.

Public procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);

This item has no description.

Public procedure ReadFromFiler(reader: TGLVirtualReader); override;

This item has no description.

Public procedure SortByMaterial;

Sort faces by material. Those without material first in list, followed by opaque materials, then transparent materials.

Properties

Public property Items[Index: Integer]: TGLFaceGroup read GetFaceGroup;

This item has no description.

Public property Owner: TGLMeshObject read FOwner;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLVectorFile

Class TGLVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLVectorFile = class(TGLDataFile)

Description

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile

Overview

Fields

Private FNormalsOrientation: TGLMeshNormalsOrientation;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function Owner: TGLBaseMesh;

Properties

Public property NormalsOrientation: TGLMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation;

Description

Fields

Private FNormalsOrientation: TGLMeshNormalsOrientation;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public function Owner: TGLBaseMesh;

This item has no description.

Properties

Public property NormalsOrientation: TGLMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLSMVectorFile

Class TGLSMVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLSMVectorFile = class(TGLVectorFile)

Description

GLSM (GLScene Mesh) vector file. This corresponds to the 'native' GLScene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GLScene features.

Hierarchy

  • TGLUpdateAbleObject
  • TGLDataFile
  • TGLVectorFile
  • TGLSMVectorFile

Overview

Methods

Public | class function Capabilities: TGLDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TGLDataFileCapabilities; override;

This item has no description. Showing description inherited from TGLDataFile.Capabilities.

Describes what the TGLDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLBaseMesh

Class TGLBaseMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLBaseMesh = class(TGLSceneObject)

Description

Base class for mesh objects.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh

Overview

Fields

Private | FNormalsOrientation: TGLMeshNormalsOrientation;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FLightmapLibrary: TGLMaterialLibrary;
Private | FAxisAlignedDimensionsCache: TGLVector;
Private | FBaryCenterOffsetChanged: Boolean;
Private | FBaryCenterOffset: TGLVector;
Private | FUseMeshMaterials: Boolean;
Private | FOverlaySkeleton: Boolean;
Private | FIgnoreMissingTextures: Boolean;
Private | FAutoCentering: TGLMeshAutoCenterings;
Private | FAutoScaling: TGLCoordinates;
Private | FMaterialLibraryCachesPrepared: Boolean;
Private | FConnectivity: TObject;
Private | FLastLoadedFilename: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | function BarycenterAbsolutePosition: TGLVector; override;
Public | function BarycenterOffset: TGLVector;
Public | function BarycenterPosition: TGLVector;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public | function GetBarycenter: TAffineVector;
Public | function LastLoadedFilename: string;
Public | function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;
Public | procedure AddDataFromFile(const filename: string); virtual;
Public | procedure AddDataFromStream(const filename: string; aStream: TStream); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure BuildSilhouetteConnectivityData;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure GetExtents(out min, max: TAffineVector);
Public | procedure LoadFromFile(const filename: string); virtual;
Public | procedure LoadFromStream(const filename: string; aStream: TStream); virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PerformAutoCentering; virtual;
Public | procedure PerformAutoScaling; virtual;
Public | procedure SaveToFile(const filename: string); virtual;
Public | procedure SaveToStream(const filename: string; aStream: TStream); virtual;
Public | procedure StructureChanged; override;
Public | procedure StructureChangedNoPrepare;

Properties

Public | property AutoCentering: TGLMeshAutoCenterings read FAutoCentering write FAutoCentering default [];
Public | property AutoScaling: TGLCoordinates read FAutoScaling write FAutoScaling;
Public | property IgnoreMissingTextures: Boolean read FIgnoreMissingTextures write FIgnoreMissingTextures default False;
Public | property LightmapLibrary: TGLMaterialLibrary read FLightmapLibrary write SetLightmapLibrary;
Public | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property MeshObjects: TGLMeshObjectList read FMeshObjects;
Public | property NormalsOrientation: TGLMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation default mnoDefault;
Public | property OverlaySkeleton: Boolean read FOverlaySkeleton write SetOverlaySkeleton default False;
Public | property Skeleton: TGLSkeleton read FSkeleton;
Public | property UseMeshMaterials: Boolean read FUseMeshMaterials write SetUseMeshMaterials default True;

Description

Fields

Private FNormalsOrientation: TGLMeshNormalsOrientation;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FLightmapLibrary: TGLMaterialLibrary;

This item has no description.

Private FAxisAlignedDimensionsCache: TGLVector;

This item has no description.

Private FBaryCenterOffsetChanged: Boolean;

This item has no description.

Private FBaryCenterOffset: TGLVector;

This item has no description.

Private FUseMeshMaterials: Boolean;

This item has no description.

Private FOverlaySkeleton: Boolean;

This item has no description.

Private FIgnoreMissingTextures: Boolean;

This item has no description.

Private FAutoCentering: TGLMeshAutoCenterings;

This item has no description.

Private FAutoScaling: TGLCoordinates;

This item has no description.

Private FMaterialLibraryCachesPrepared: Boolean;

This item has no description.

Private FConnectivity: TObject;

This item has no description.

Private FLastLoadedFilename: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public function BarycenterAbsolutePosition: TGLVector; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function BarycenterOffset: TGLVector;

This item has no description.

Public function BarycenterPosition: TGLVector;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;

This item has no description. Showing description inherited from TGLBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function GetBarycenter: TAffineVector;

Computes the barycenter of the mesh.

Public function LastLoadedFilename: string;

Returns the filename of the last loaded file, or a blank string if not file was loaded (or if the mesh was dinamically built). This does not take into account the data added to the mesh (through AddDataFromFile) or saved files.

Public function RayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; override;

BEWARE! Utterly inefficient implementation!

Public procedure AddDataFromFile(const filename: string); virtual;

Loads additionnal data from a file. Additionnal data could be more animation frames or morph target. The VectorFile importer must be able to handle addition of data flawlessly.

Public procedure AddDataFromStream(const filename: string; aStream: TStream); virtual;

Loads additionnal data from stream. See AddDataFromFile.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure BuildSilhouetteConnectivityData;

This method allows fast shadow volumes for GLActors. If your actor/mesh doesn't change, you don't need to call this. It basically caches the connectivity data.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure GetExtents(out min, max: TAffineVector);

Computes the extents of the mesh.

Public procedure LoadFromFile(const filename: string); virtual;

Loads a vector file. A vector files (for instance a ".3DS") stores the definition of a mesh as well as materials property. Loading a file replaces the current one (if any).

Public procedure LoadFromStream(const filename: string; aStream: TStream); virtual;

Loads a vector file from a stream. See LoadFromFile. The filename attribute is required to identify the type data you're streaming (3DS, OBJ, etc.)

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure PerformAutoCentering; virtual;

Invoked after a mesh has been loaded. Should auto-center according to the AutoCentering property.

Public procedure PerformAutoScaling; virtual;

Invoked after a mesh has been loaded. Should auto-scale the vertices of the meshobjects to AutoScaling the property.

Public procedure SaveToFile(const filename: string); virtual;

Saves to a vector file. Note that only some of the vector files formats can be written to by GLScene.

Public procedure SaveToStream(const filename: string; aStream: TStream); virtual;

Saves to a vector file in a stream. Note that only some of the vector files formats can be written to by GLScene.

Public procedure StructureChanged; override;

This item has no description.

Public procedure StructureChangedNoPrepare;

Notifies that geometry data changed, but no re-preparation is needed. Using this method will usually be faster, but may result in incorrect rendering, reduced performance and/or invalid bounding box data (ie. invalid collision detection). Use with caution.

Properties

Public property AutoCentering: TGLMeshAutoCenterings read FAutoCentering write FAutoCentering default [];

Determines if a mesh should be centered and how. AutoCentering is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TMeshObjects).

Public property AutoScaling: TGLCoordinates read FAutoScaling write FAutoScaling;

Scales vertices to a AutoScaling. AutoScaling is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TMeshObjects).

Public property IgnoreMissingTextures: Boolean read FIgnoreMissingTextures write FIgnoreMissingTextures default False;

If True, exceptions about missing textures will be ignored. Implementation is up to the file loader class (ie. this property may be ignored by some loaders)

Public property LightmapLibrary: TGLMaterialLibrary read FLightmapLibrary write SetLightmapLibrary;

LightMap library where lightmaps will be stored/retrieved. If this property is not defined, lightmaps won't be used. Lightmaps currently *always* use the second texture unit (unit 1), and may interfere with multi-texture materials.

Public property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Material library where mesh materials will be stored/retrieved. If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.

Public property MeshObjects: TGLMeshObjectList read FMeshObjects;

This item has no description.

Public property NormalsOrientation: TGLMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation default mnoDefault;

Normals orientation for owned mesh.

Public property OverlaySkeleton: Boolean read FOverlaySkeleton write SetOverlaySkeleton default False;

Request rendering of skeleton bones over the mesh.

Public property Skeleton: TGLSkeleton read FSkeleton;

This item has no description.

Public property UseMeshMaterials: Boolean read FUseMeshMaterials write SetUseMeshMaterials default True;

Defines wether materials declared in the vector file mesh are used. You must also define the MaterialLibrary property.


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLFreeForm

Class TGLFreeForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLFreeForm = class(TGLBaseMesh)

Description

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLFreeForm

Overview

Fields

Private FOctree: TGLOctree;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function OctreeAABBIntersect(const AABB: TAABB; objMatrix, invObjMatrix: TGLMatrix; triangles: TGLAffineVectorList = nil): Boolean;
Public | function OctreePointInMesh(const Point: TGLVector): Boolean;
Public | function OctreeRayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean;
Public | function OctreeSphereSweepIntersect(const rayStart, rayVector: TGLVector; const velocity, radius: Single; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean;
Public | function OctreeTriangleIntersect(const v1, v2, v3: TAffineVector): Boolean;
Public | procedure BuildOctree(TreeDepth: Integer = 3);

Properties

Published | property AutoCentering;
Published | property AutoScaling;
Published | property LightmapLibrary;
Published | property MaterialLibrary;
Published | property NormalsOrientation;
Public | property Octree: TGLOctree read FOctree;
Published | property UseMeshMaterials;

Description

Fields

Private FOctree: TGLOctree;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OctreeAABBIntersect(const AABB: TAABB; objMatrix, invObjMatrix: TGLMatrix; triangles: TGLAffineVectorList = nil): Boolean;

This item has no description.

Public function OctreePointInMesh(const Point: TGLVector): Boolean;

Returns true if Point is inside the free form - this will only work properly on closed meshes. Requires that Octree has been prepared.

Public function OctreeRayCastIntersect(const rayStart, rayVector: TGLVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean;

This item has no description.

Public function OctreeSphereSweepIntersect(const rayStart, rayVector: TGLVector; const velocity, radius: Single; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean;

This item has no description.

Public function OctreeTriangleIntersect(const v1, v2, v3: TAffineVector): Boolean;

This item has no description.

Public procedure BuildOctree(TreeDepth: Integer = 3);

This item has no description.

Properties

Published property AutoCentering;

This item has no description. Showing description inherited from TGLBaseMesh.AutoCentering.

Determines if a mesh should be centered and how. AutoCentering is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TMeshObjects).

Published property AutoScaling;

This item has no description. Showing description inherited from TGLBaseMesh.AutoScaling.

Scales vertices to a AutoScaling. AutoScaling is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TMeshObjects).

Published property LightmapLibrary;

This item has no description. Showing description inherited from TGLBaseMesh.LightmapLibrary.

LightMap library where lightmaps will be stored/retrieved. If this property is not defined, lightmaps won't be used. Lightmaps currently *always* use the second texture unit (unit 1), and may interfere with multi-texture materials.

Published property MaterialLibrary;

This item has no description. Showing description inherited from TGLBaseMesh.MaterialLibrary.

Material library where mesh materials will be stored/retrieved. If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.

Published property NormalsOrientation;

This item has no description. Showing description inherited from TGLBaseMesh.NormalsOrientation.

Normals orientation for owned mesh.

Public property Octree: TGLOctree read FOctree;

TODO: function OctreeSphereIntersect Octree support *experimental*. Use only if you understand what you're doing!

Published property UseMeshMaterials;

This item has no description. Showing description inherited from TGLBaseMesh.UseMeshMaterials.

Defines wether materials declared in the vector file mesh are used. You must also define the MaterialLibrary property.


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLActorAnimation

Class TGLActorAnimation

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLActorAnimation = class(TCollectionItem)

Description

An actor animation sequence. An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property). An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TGLAnimationControler.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLActorAnimation

Overview

Fields

Private | FName: string;
Private | FStartFrame: Integer;
Private | FEndFrame: Integer;
Private | FReference: TGLActorAnimationReference;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerActor: TGLActor;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure MakeSkeletalRotationDelta;
Public | procedure MakeSkeletalTranslationStatic;

Properties

Public | property AsString: string read GetAsString write SetAsString;
Published | property EndFrame: Integer read FEndFrame write SetEndFrame;
Published | property Name: string read FName write FName;
Published | property Reference: TGLActorAnimationReference read FReference write SetReference default aarMorph;
Published | property StartFrame: Integer read FStartFrame write SetStartFrame;

Description

Fields

Private FName: string;

This item has no description.

Private FStartFrame: Integer;

This item has no description.

Private FEndFrame: Integer;

This item has no description.

Private FReference: TGLActorAnimationReference;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OwnerActor: TGLActor;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure MakeSkeletalRotationDelta;

Removes the absolute rotation component of the skeletal frames. Some formats will store frames with absolute rotation information, if this correct if the animation is the "main" animation. This function removes that absolute information, making the animation frames suitable for blending purposes.

Public procedure MakeSkeletalTranslationStatic;

Linearly removes the translation component between skeletal frames. This function will compute the translation of the first bone (index 0) and linearly subtract this translation in all frames between startFrame and endFrame. Its purpose is essentially to remove the 'slide' that exists in some animation formats (f.i. SMD).

Properties

Public property AsString: string read GetAsString write SetAsString;

This item has no description.

Published property EndFrame: Integer read FEndFrame write SetEndFrame;

Index of the final frame of the animation.

Published property Name: string read FName write FName;

This item has no description.

Published property Reference: TGLActorAnimationReference read FReference write SetReference default aarMorph;

Indicates if this is a skeletal or a morph-based animation.

Published property StartFrame: Integer read FStartFrame write SetStartFrame;

Index of the initial frame of the animation.


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLActorAnimations

Class TGLActorAnimations

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLActorAnimations = class(TCollection)

Description

Collection of actor animations sequences.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLActorAnimations

Overview

Fields

Private FOwner: TGLActor;

Methods

Public | constructor Create(AOwner: TGLActor);
Public | function Add: TGLActorAnimation;
Public | function FindFrame(aFrame: Integer; aReference: TGLActorAnimationReference): TGLActorAnimation;
Public | function FindItemID(ID: Integer): TGLActorAnimation;
Public | function FindName(const aName: string): TGLActorAnimation;
Public | function Last: TGLActorAnimation;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure LoadFromStream(aStream: TStream);
Public | procedure SaveToFile(const fileName: string);
Public | procedure SaveToStream(aStream: TStream);
Public | procedure SetToStrings(aStrings: TStrings);

Properties

Public property Items[index: Integer]: TGLActorAnimation read GetItems write SetItems;

Description

Fields

Private FOwner: TGLActor;

This item has no description.

Methods

Public constructor Create(AOwner: TGLActor);

This item has no description.

Public function Add: TGLActorAnimation;

This item has no description.

Public function FindFrame(aFrame: Integer; aReference: TGLActorAnimationReference): TGLActorAnimation;

This item has no description.

Public function FindItemID(ID: Integer): TGLActorAnimation;

This item has no description.

Public function FindName(const aName: string): TGLActorAnimation;

This item has no description.

Public function Last: TGLActorAnimation;

This item has no description.

Public procedure LoadFromFile(const fileName: string);

This item has no description.

Public procedure LoadFromStream(aStream: TStream);

This item has no description.

Public procedure SaveToFile(const fileName: string);

This item has no description.

Public procedure SaveToStream(aStream: TStream);

This item has no description.

Public procedure SetToStrings(aStrings: TStrings);

This item has no description.

Properties

Public property Items[index: Integer]: TGLActorAnimation read GetItems write SetItems;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLBaseAnimationControler

Class TGLBaseAnimationControler

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLBaseAnimationControler = class(TComponent)

Description

Base class for skeletal animation control.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLBaseAnimationControler

Overview

Fields

Private | FEnabled: Boolean;
Private | FActor: TGLActor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property Actor: TGLActor read FActor write SetActor;
Published | property Enabled: Boolean read FEnabled write SetEnabled default True;

Description

Fields

Private FEnabled: Boolean;

This item has no description.

Private FActor: TGLActor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Actor: TGLActor read FActor write SetActor;

This item has no description.

Published property Enabled: Boolean read FEnabled write SetEnabled default True;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLAnimationControler

Class TGLAnimationControler

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLAnimationControler = class(TGLBaseAnimationControler)

Description

Controls the blending of an additionnal skeletal animation into an actor. The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TGLActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLBaseAnimationControler
  • TGLAnimationControler

Overview

Fields

Private | FAnimationName: TGLActorAnimationName;
Private | FRatio: Single;

Properties

Published | property AnimationName: string read FAnimationName write SetAnimationName;
Published | property Ratio: Single read FRatio write SetRatio;

Description

Fields

Private FAnimationName: TGLActorAnimationName;

This item has no description.

Private FRatio: Single;

This item has no description.

Properties

Published property AnimationName: string read FAnimationName write SetAnimationName;

This item has no description.

Published property Ratio: Single read FRatio write SetRatio;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLActor

Class TGLActor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLActor = class(TGLBaseMesh)

Description

Mesh class specialized in animated meshes. The TGLActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TGLAnimationController components).

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLActor

Overview

Fields

Private | FStartFrame: Integer;
Private | FEndFrame: Integer;
Private | FReference: TGLActorAnimationReference;
Private | FCurrentFrame: Integer;
Private | FCurrentFrameDelta: Single;
Private | FFrameInterpolation: TGLActorFrameInterpolation;
Private | FInterval: Integer;
Private | FAnimationMode: TGLActorAnimationMode;
Private | FOnFrameChanged: TNotifyEvent;
Private | FOnEndFrameReached: TNotifyEvent;
Private | FOnStartFrameReached: TNotifyEvent;
Private | FAnimations: TGLActorAnimations;
Private | FTargetSmoothAnimation: TGLActorAnimation;
Private | FControlers: TList;
Private | FOptions: TGLActorOptions;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CurrentAnimation: string;
Public | function FrameCount: Integer;
Public | function isSwitchingAnimation: Boolean;
Public | function NextFrameIndex: Integer;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure LoadFromStream(const filename: string; aStream: TStream); override;
Public | procedure NextFrame(nbSteps: Integer = 1);
Public | procedure PrevFrame(nbSteps: Integer = 1);
Public | procedure SetCurrentFrameDirect(const Value: Integer);
Public | procedure SwitchToAnimation(const AnimationName: string; smooth: Boolean = False); overload;
Public | procedure SwitchToAnimation(anAnimation: TGLActorAnimation; smooth: Boolean = False); overload;
Public | procedure SwitchToAnimation(animationIndex: Integer; smooth: Boolean = False); overload;
Public | procedure Synchronize(referenceActor: TGLActor);

Properties

Published | property AnimationMode: TGLActorAnimationMode read FAnimationMode write FAnimationMode default aamNone;
Published | property Animations: TGLActorAnimations read FAnimations write SetAnimations stored StoreAnimations;
Published | property AutoCentering;
Published | property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame default 0;
Published | property CurrentFrameDelta: Single read FCurrentFrameDelta write FCurrentFrameDelta;
Published | property EndFrame: Integer read FEndFrame write SetEndFrame default 0;
Published | property FrameInterpolation: TGLActorFrameInterpolation read FFrameInterpolation write FFrameInterpolation default afpLinear;
Published | property Interval: Integer read FInterval write FInterval;
Published | property LightmapLibrary;
Published | property MaterialLibrary;
Published | property NormalsOrientation;
Published | property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;
Published | property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;
Published | property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;
Published | property Options: TGLActorOptions read FOptions write SetOptions default cDefaultActorOptions;
Published | property OverlaySkeleton;
Published | property Reference: TGLActorAnimationReference read FReference write FReference default aarMorph;
Published | property StartFrame: Integer read FStartFrame write SetStartFrame default 0;
Published | property UseMeshMaterials;

Description

Fields

Private FStartFrame: Integer;

This item has no description.

Private FEndFrame: Integer;

This item has no description.

Private FReference: TGLActorAnimationReference;

This item has no description.

Private FCurrentFrame: Integer;

This item has no description.

Private FCurrentFrameDelta: Single;

This item has no description.

Private FFrameInterpolation: TGLActorFrameInterpolation;

This item has no description.

Private FInterval: Integer;

This item has no description.

Private FAnimationMode: TGLActorAnimationMode;

This item has no description.

Private FOnFrameChanged: TNotifyEvent;

This item has no description.

Private FOnEndFrameReached: TNotifyEvent;

This item has no description.

Private FOnStartFrameReached: TNotifyEvent;

This item has no description.

Private FAnimations: TGLActorAnimations;

This item has no description.

Private FTargetSmoothAnimation: TGLActorAnimation;

This item has no description.

Private FControlers: TList;

This item has no description.

Private FOptions: TGLActorOptions;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CurrentAnimation: string;

This item has no description.

Public function FrameCount: Integer;

This item has no description.

Public function isSwitchingAnimation: Boolean;

Indicates whether the actor is currently swithing animations (with smooth interpolation)

Public function NextFrameIndex: Integer;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure LoadFromStream(const filename: string; aStream: TStream); override;

This item has no description. Showing description inherited from TGLBaseMesh.LoadFromStream.

Loads a vector file from a stream. See LoadFromFile. The filename attribute is required to identify the type data you're streaming (3DS, OBJ, etc.)

Public procedure NextFrame(nbSteps: Integer = 1);

This item has no description.

Public procedure PrevFrame(nbSteps: Integer = 1);

This item has no description.

Public procedure SetCurrentFrameDirect(const Value: Integer);

Provides a direct access to FCurrentFrame without any checks. Used in TGLActorProxy

Public procedure SwitchToAnimation(const AnimationName: string; smooth: Boolean = False); overload;

This item has no description.

Public procedure SwitchToAnimation(anAnimation: TGLActorAnimation; smooth: Boolean = False); overload;

This item has no description.

Public procedure SwitchToAnimation(animationIndex: Integer; smooth: Boolean = False); overload;

This item has no description.

Public procedure Synchronize(referenceActor: TGLActor);

Synchronize self animation with an other actor. Copies Start/Current/End Frame values, CurrentFrameDelta, AnimationMode and FrameInterpolation.

Properties

Published property AnimationMode: TGLActorAnimationMode read FAnimationMode write FAnimationMode default aamNone;

See TGLActorAnimationMode.

Published property Animations: TGLActorAnimations read FAnimations write SetAnimations stored StoreAnimations;

Collection of animations sequences.

Published property AutoCentering;

This item has no description. Showing description inherited from TGLBaseMesh.AutoCentering.

Determines if a mesh should be centered and how. AutoCentering is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TMeshObjects).

Published property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame default 0;

Current animation frame.

Published property CurrentFrameDelta: Single read FCurrentFrameDelta write FCurrentFrameDelta;

Value in the [0; 1] range expressing the delta to the next frame.

Published property EndFrame: Integer read FEndFrame write SetEndFrame default 0;

This item has no description.

Published property FrameInterpolation: TGLActorFrameInterpolation read FFrameInterpolation write FFrameInterpolation default afpLinear;

Frame interpolation mode (afpNone/afpLinear).

Published property Interval: Integer read FInterval write FInterval;

Interval between frames, in milliseconds.

Published property LightmapLibrary;

This item has no description. Showing description inherited from TGLBaseMesh.LightmapLibrary.

LightMap library where lightmaps will be stored/retrieved. If this property is not defined, lightmaps won't be used. Lightmaps currently *always* use the second texture unit (unit 1), and may interfere with multi-texture materials.

Published property MaterialLibrary;

This item has no description. Showing description inherited from TGLBaseMesh.MaterialLibrary.

Material library where mesh materials will be stored/retrieved. If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.

Published property NormalsOrientation;

This item has no description. Showing description inherited from TGLBaseMesh.NormalsOrientation.

Normals orientation for owned mesh.

Published property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;

Triggered after EndFrame has been reached by progression or "nextframe"

Published property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;

Triggered after each CurrentFrame change.

Published property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;

Triggered after StartFrame has been reached by progression or "nextframe"

Published property Options: TGLActorOptions read FOptions write SetOptions default cDefaultActorOptions;

Actor and animation miscellanious options.

Published property OverlaySkeleton;

This item has no description. Showing description inherited from TGLBaseMesh.OverlaySkeleton.

Request rendering of skeleton bones over the mesh.

Published property Reference: TGLActorAnimationReference read FReference write FReference default aarMorph;

Reference Frame Animation mode. Allows specifying if the model is primarily morph or skeleton based

Published property StartFrame: Integer read FStartFrame write SetStartFrame default 0;

This item has no description.

Published property UseMeshMaterials;

This item has no description. Showing description inherited from TGLBaseMesh.UseMeshMaterials.

Defines wether materials declared in the vector file mesh are used. You must also define the MaterialLibrary property.


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLVectorFileFormat

Class TGLVectorFileFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLVectorFileFormat = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVectorFileFormat

Overview

Fields

Public | VectorFileClass: TGLVectorFileClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: Integer;

Description

Fields

Public VectorFileClass: TGLVectorFileClass;

This item has no description.

Public Extension: string;

This item has no description.

Public Description: string;

This item has no description.

Public DescResID: Integer;


GLSysHelp v.2.5: GLS.VectorFileObjects: Class TGLVectorFileFormatsList

Class TGLVectorFileFormatsList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type TGLVectorFileFormatsList = class(TGLPersistentObjectList)

Description

Stores registered vector file formats

Hierarchy

  • TGLPersistentObjectList
  • TGLVectorFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(Ext: string): TGLVectorFileClass;
Public | function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;
Public | function FindFromFileName(const filename: string): TGLVectorFileClass;
Public | procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TGLVectorFileClass);
Public | procedure BuildFilterStrings(vectorFileClass: TGLVectorFileClass; out descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);
Public | procedure Remove(AClass: TGLVectorFileClass);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function FindExt(Ext: string): TGLVectorFileClass;

This item has no description.

Public function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;

This item has no description.

Public function FindFromFileName(const filename: string): TGLVectorFileClass;

This item has no description.

Public procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TGLVectorFileClass);

This item has no description.

Public procedure BuildFilterStrings(vectorFileClass: TGLVectorFileClass; out descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);

This item has no description.

Public procedure Remove(AClass: TGLVectorFileClass);


GLSysHelp v.2.5: GLS.VectorFileObjects: Class EInvalidVectorFile

Class EInvalidVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VectorFileObjects

Declaration

type EInvalidVectorFile = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EInvalidVectorFile


GLSysHelp v.2.5: GLS.VerletClothify

Unit GLS.VerletClothify

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.VectorFileObjects
  • GLS.VerletTypes
  • GLScene.VectorTypes
  • GLS.VectorLists
  • GLScene.VectorGeometry
  • GLS.Texture
  • GLS.RenderContextInfo
  • GLS.State
  • GLS.PersistentClasses
  • GLS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFace |
Class TGLFaceList |
Class TGLFaceExtractor |
Class TGLEdge |
Class TGLEdgeList |
Class TGLEdgeDetector |
Class TGLMeshObjectVerletNode |


GLSysHelp v.2.5: GLS.VerletClothify: Class TGLFace

Class TGLFace

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletClothify

Declaration

type TGLFace = class(TObject)

Description

Class that represents a face. This structure is not used for rendering, but for extracting info from meshes

Hierarchy

  • TObject
  • TGLFace

Overview

Fields

Public | Vertices: array [0 .. 2] of integer;
Public | Normal: TAffineVector;
Public | MeshObject: TGLMeshObject;
Public | Active: boolean;

Methods

Public | constructor Create(aMeshObject: TGLMeshObject);
Public | procedure UpdateNormal;

Description

Fields

Public Vertices: array [0 .. 2] of integer;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Public MeshObject: TGLMeshObject;

This item has no description.

Public Active: boolean;

This item has no description.

Methods

Public constructor Create(aMeshObject: TGLMeshObject);

This item has no description.

Public procedure UpdateNormal;


GLSysHelp v.2.5: GLS.VerletClothify: Class TGLFaceList

Class TGLFaceList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletClothify

Declaration

type TGLFaceList = class(TList)

Description

List of faces

Hierarchy

  • TObject
  • TList
  • TGLFaceList

Overview

Methods

Private | function GetItems(i: integer): TGLFace;
Private | procedure SetItems(i: integer; const Value: TGLFace);

Properties

Public property Items[i: integer]: TGLFace read GetItems write SetItems;

Description

Methods

Private function GetItems(i: integer): TGLFace;

This item has no description.

Private procedure SetItems(i: integer; const Value: TGLFace);

This item has no description.

Properties

Public property Items[i: integer]: TGLFace read GetItems write SetItems;


GLSysHelp v.2.5: GLS.VerletClothify: Class TGLFaceExtractor

Class TGLFaceExtractor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletClothify

Declaration

type TGLFaceExtractor = class(TObject)

Description

Class that extracts faces from a GLBaseMesh

Hierarchy

  • TObject
  • TGLFaceExtractor

Overview

Fields

Private | FFaceList: TGLFaceList;
Private | FGLBaseMesh: TGLBaseMesh;
Private | FNodeList: TGLVerletNodeList;
Private | FWeldDistance: single;
Private | FEdgeDoublesSkipped: integer;

Methods

Public | constructor Create(const aGLBaseMesh: TGLBaseMesh); virtual;
Public | destructor Destroy; override;
Public | function AddFace(const Vi0, Vi1, Vi2: integer; const MeshObject: TGLMeshObject): TGLFace; virtual;
Public | procedure Clear; virtual;
Public | procedure ExtractFacesFromVertexIndexList(const FaceGroup : TFGVertexIndexList; const MeshObject: TGLMeshObject);
Public | procedure ProcessMesh; virtual;
Private | procedure SetWeldDistance(const Value: single);

Properties

Public | property EdgeDoublesSkipped: integer read FEdgeDoublesSkipped;
Public | property FaceList: TGLFaceList read FFaceList;
Public | property GLBaseMesh: TGLBaseMesh read FGLBaseMesh;
Public | property NodeList: TGLVerletNodeList read FNodeList;
Public | property WeldDistance: single read FWeldDistance write SetWeldDistance;

Description

Fields

Private FFaceList: TGLFaceList;

This item has no description.

Private FGLBaseMesh: TGLBaseMesh;

This item has no description.

Private FNodeList: TGLVerletNodeList;

This item has no description.

Private FWeldDistance: single;

This item has no description.

Private FEdgeDoublesSkipped: integer;

This item has no description.

Methods

Public constructor Create(const aGLBaseMesh: TGLBaseMesh); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddFace(const Vi0, Vi1, Vi2: integer; const MeshObject: TGLMeshObject): TGLFace; virtual;

This item has no description.

Public procedure Clear; virtual;

This item has no description.

Public procedure ExtractFacesFromVertexIndexList(const FaceGroup : TFGVertexIndexList; const MeshObject: TGLMeshObject);

This item has no description.

Public procedure ProcessMesh; virtual;

This item has no description.

Private procedure SetWeldDistance(const Value: single);

This item has no description.

Properties

Public property EdgeDoublesSkipped: integer read FEdgeDoublesSkipped;

This item has no description.

Public property FaceList: TGLFaceList read FFaceList;

This item has no description.

Public property GLBaseMesh: TGLBaseMesh read FGLBaseMesh;

This item has no description.

Public property NodeList: TGLVerletNodeList read FNodeList;

This item has no description.

Public property WeldDistance: single read FWeldDistance write SetWeldDistance;


GLSysHelp v.2.5: GLS.VerletClothify: Class TGLEdge

Class TGLEdge

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletClothify

Declaration

type TGLEdge = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLEdge

Overview

Fields

Private | FSolid: boolean;
Private | FLength: single;
Private | FMeshObject: TGLMeshObject;
Private | FOwner: TGLEdgeDetector;
Public | Vertices: array [0 .. 1] of integer;
Public | Faces: array [0 .. 1] of TGLFace;

Methods

Public | constructor Create(const AOwner: TGLEdgeDetector; AVi0, AVi1: integer; AFace0, AFace1: TGLFace; aMeshObject: TGLMeshObject; ASolid: boolean);
Public | procedure Contract;
Public | procedure UpdateEdgeLength;

Properties

Public | property Length: single read FLength write FLength;
Public | property MeshObject: TGLMeshObject read FMeshObject write FMeshObject;
Public | property Owner: TGLEdgeDetector read FOwner;
Public | property Solid: boolean read FSolid write FSolid;

Description

Fields

Private FSolid: boolean;

This item has no description.

Private FLength: single;

This item has no description.

Private FMeshObject: TGLMeshObject;

This item has no description.

Private FOwner: TGLEdgeDetector;

This item has no description.

Public Vertices: array [0 .. 1] of integer;

This item has no description.

Public Faces: array [0 .. 1] of TGLFace;

This item has no description.

Methods

Public constructor Create(const AOwner: TGLEdgeDetector; AVi0, AVi1: integer; AFace0, AFace1: TGLFace; aMeshObject: TGLMeshObject; ASolid: boolean);

This item has no description.

Public procedure Contract;

This item has no description.

Public procedure UpdateEdgeLength;

This item has no description.

Properties

Public property Length: single read FLength write FLength;

This item has no description.

Public property MeshObject: TGLMeshObject read FMeshObject write FMeshObject;

This item has no description.

Public property Owner: TGLEdgeDetector read FOwner;

This item has no description.

Public property Solid: boolean read FSolid write FSolid;


GLSysHelp v.2.5: GLS.VerletClothify: Class TGLEdgeList

Class TGLEdgeList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletClothify

Declaration

type TGLEdgeList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLEdgeList

Overview

Methods

Public | function InsertSorted(AEdge: TGLEdge): integer;
Private | function GetItems(i: integer): TGLEdge;
Public | procedure SortByLength;
Private | procedure SetItems(i: integer; const Value: TGLEdge);

Properties

Public property Items[i: integer]: TGLEdge read GetItems write SetItems;

Description

Methods

Public function InsertSorted(AEdge: TGLEdge): integer;

This item has no description.

Private function GetItems(i: integer): TGLEdge;

This item has no description.

Public procedure SortByLength;

This item has no description.

Private procedure SetItems(i: integer; const Value: TGLEdge);

This item has no description.

Properties

Public property Items[i: integer]: TGLEdge read GetItems write SetItems;


GLSysHelp v.2.5: GLS.VerletClothify: Class TGLEdgeDetector

Class TGLEdgeDetector

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletClothify

Declaration

type TGLEdgeDetector = class(TGLFaceExtractor)

Description

This item has no description. Showing description inherited from TGLFaceExtractor.

Class that extracts faces from a GLBaseMesh

Hierarchy

  • TObject
  • TGLFaceExtractor
  • TGLEdgeDetector

Overview

Fields

Private | FEdgeList: TGLEdgeList;
Private | FCurrentNodeOffset: integer;
Private | FNodesAdded: boolean;

Methods

Public | constructor Create(const aGLBaseMesh: TGLBaseMesh); override;
Public | destructor Destroy; override;
Public | function AddEdge(const Vi0, Vi1: integer; const Face: TGLFace; const aMeshObject: TGLMeshObject): TGLEdge;
Public | function AddFace(const Vi0, Vi1, Vi2: integer; const MeshObject: TGLMeshObject): TGLFace; override;
Public | function AddNode(const VerletWorld: TGLVerletWorld; const MeshObject: TGLMeshObject; const VertexIndex: integer) : TGLVerletNode; virtual;
Public | procedure AddEdgesAsSolidEdges(const VerletWorld: TGLVerletWorld);
Public | procedure AddEdgesAsSprings(const VerletWorld: TGLVerletWorld; const Strength, Damping, Slack: single);
Public | procedure AddEdgesAsSticks(const VerletWorld: TGLVerletWorld; const Slack: single);
Public | procedure AddNodes(const VerletWorld: TGLVerletWorld);
Public | procedure AddOuterEdgesAsSolidEdges(const VerletWorld: TGLVerletWorld);
Public | procedure Clear; override;
Public | procedure ProcessMesh; override;
Public | procedure RenderEdges(var rci: TGLRenderContextInfo);
Public | procedure ReplaceVertexIndex(const ViRemove, ViReplaceWith: integer);
Private | procedure BuildOpposingEdges;

Properties

Public | property CurrentNodeOffset: integer read FCurrentNodeOffset;
Public | property EdgeList: TGLEdgeList read FEdgeList;
Public | property NodesAdded: boolean read FNodesAdded;

Description

Fields

Private FEdgeList: TGLEdgeList;

This item has no description.

Private FCurrentNodeOffset: integer;

This item has no description.

Private FNodesAdded: boolean;

This item has no description.

Methods

Public constructor Create(const aGLBaseMesh: TGLBaseMesh); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddEdge(const Vi0, Vi1: integer; const Face: TGLFace; const aMeshObject: TGLMeshObject): TGLEdge;

This item has no description.

Public function AddFace(const Vi0, Vi1, Vi2: integer; const MeshObject: TGLMeshObject): TGLFace; override;

This item has no description.

Public function AddNode(const VerletWorld: TGLVerletWorld; const MeshObject: TGLMeshObject; const VertexIndex: integer) : TGLVerletNode; virtual;

This item has no description.

Public procedure AddEdgesAsSolidEdges(const VerletWorld: TGLVerletWorld);

This item has no description.

Public procedure AddEdgesAsSprings(const VerletWorld: TGLVerletWorld; const Strength, Damping, Slack: single);

This item has no description.

Public procedure AddEdgesAsSticks(const VerletWorld: TGLVerletWorld; const Slack: single);

This item has no description.

Public procedure AddNodes(const VerletWorld: TGLVerletWorld);

This item has no description.

Public procedure AddOuterEdgesAsSolidEdges(const VerletWorld: TGLVerletWorld);

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure ProcessMesh; override;

This item has no description.

Public procedure RenderEdges(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure ReplaceVertexIndex(const ViRemove, ViReplaceWith: integer);

This item has no description.

Private procedure BuildOpposingEdges;

This item has no description.

Properties

Public property CurrentNodeOffset: integer read FCurrentNodeOffset;

This item has no description.

Public property EdgeList: TGLEdgeList read FEdgeList;

This item has no description.

Public property NodesAdded: boolean read FNodesAdded;


GLSysHelp v.2.5: GLS.VerletClothify: Class TGLMeshObjectVerletNode

Class TGLMeshObjectVerletNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletClothify

Declaration

type TGLMeshObjectVerletNode = class(TGLVerletNode)

Description

This item has no description. Showing description inherited from TGLVerletNode.

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.

Hierarchy

  • TGLPersistentObject
  • TGLSpacePartitionLeaf
  • TGLBaseVerletNode
  • TGLVerletNode
  • TGLMeshObjectVerletNode

Overview

Fields

Private | MeshObject: TGLMeshObject;
Private | VertexIndices: TGLIntegerList;

Methods

Public | constructor CreateOwned(const AOwner: TGLVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure AfterProgress; override;

Description

Fields

Private MeshObject: TGLMeshObject;

This item has no description.

Private VertexIndices: TGLIntegerList;

This item has no description.

Methods

Public constructor CreateOwned(const AOwner: TGLVerletWorld); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AfterProgress; override;


GLSysHelp v.2.5: GLS.VerletTypes

Unit GLS.VerletTypes

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.VectorTypes
  • GLS.PersistentClasses
  • GLS.BaseClasses
  • GLS.Coordinates
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLScene.GeometryBB
  • GLS.Objects
  • GLS.Scene
  • GLS.SpacePartition
  • GLS.VectorFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseVerletNode |
Class TGLVerletNodeList |
Class TGLVerletConstraint |
Class TGLVerletDualConstraint |
Class TGLVerletGroupConstraint |
Class TGLVerletEdge |
Class TGLVerletEdgeList |
Class TGLVerletGlobalConstraint |
Class TGLVerletGlobalFrictionConstraint |
Class TGLVerletGlobalFrictionConstraintSP |
Class TGLVerletGlobalFrictionConstraintSphere |
Class TGLVerletGlobalFrictionConstraintBox |
Class TGLVerletConstraintList |
Class TGLVerletForce |
Class TGLVerletDualForce |
Class TGLVerletGroupForce |
Class TGLVerletGlobalForce |
Class TGLVerletForceList |
Class TGLVerletWorld |
Class TGLVerletGravity |
Class TGLVerletAirResistance |
Class TGLVerletSpring |
Class TGLVerletFloor |
Class TGLVerletHeightField |
Class TGLVerletStick |
Class TGLVerletRigidBody |
Class TGLVerletSlider |
Class TGLVerletFrictionSphere |
Class TGLVerletFrictionCylinder |
Class TGLVerletFrictionCube |
Class TGLVerletFrictionCapsule |
Class TGLVerletNode |
Class TGLVerletHair |
Class TGLVerletSkeletonCollider |
Class TGLVerletSphere |
Class TGLVerletCapsule |

Functions and Procedures

procedure AddVerletConstriantsToVerletWorld(Colliders: TGLSkeletonColliderList; World: TGLVerletWorld);
function CreateVerletPlaneFromGLPlane(Plane: TGLPlane; VerletWorld: TGLVerletWorld; Offset: Single): TGLVerletFloor;

Types

TCollisionConstraintTypes = (...);
TCollisionConstraintTypesSet = set of TCollisionConstraintTypes;
TGLStiffnessSetVH = set of TGLStiffnessVH;
TGLStiffnessVH = (...);
TGLVerletHeightFieldOnNeedHeight = function(hfConstraint: TGLVerletHeightField; node: TGLBaseVerletNode): Single of object;
TGLVerletNodeClass = class of TGLBaseVerletNode;
TUpdateSpacePartion = (...);

Constants

G_DRAG = 0.0001;
cDEFAULT_CONSTRAINT_FRICTION = 0.6;

Description

Functions and Procedures

procedure AddVerletConstriantsToVerletWorld(Colliders: TGLSkeletonColliderList; World: TGLVerletWorld);

After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.

function CreateVerletPlaneFromGLPlane(Plane: TGLPlane; VerletWorld: TGLVerletWorld; Offset: Single): TGLVerletFloor;

This item has no description.

Types

TCollisionConstraintTypes = (...);

This item has no description.

Values
  • cctEdge
  • cctNode
TCollisionConstraintTypesSet = set of TCollisionConstraintTypes;

This item has no description.

TGLStiffnessSetVH = set of TGLStiffnessVH;

This item has no description.

TGLStiffnessVH = (...);

This item has no description.

Values
  • vhsFull
  • vhsSkip1Node
  • vhsSkip2Node
  • vhsSkip3Node
  • vhsSkip4Node
  • vhsSkip5Node
  • vhsSkip6Node
  • vhsSkip7Node
  • vhsSkip8Node
  • vhsSkip9Node
TGLVerletHeightFieldOnNeedHeight = function(hfConstraint: TGLVerletHeightField; node: TGLBaseVerletNode): Single of object;

This item has no description.

TGLVerletNodeClass = class of TGLBaseVerletNode;

This item has no description.

TUpdateSpacePartion = (...);

This item has no description.

Values
  • uspEveryIteration
  • uspEveryFrame
  • uspNever

Constants

G_DRAG = 0.0001;

This item has no description.

cDEFAULT_CONSTRAINT_FRICTION = 0.6;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLBaseVerletNode

Class TGLBaseVerletNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLBaseVerletNode = class(TGLSpacePartitionLeaf)

Description

Basic Verlet Node

Hierarchy

  • TGLPersistentObject
  • TGLSpacePartitionLeaf
  • TGLBaseVerletNode

Overview

Fields

Private | FForce: TAffineVector;
Private | FOwner: TGLVerletWorld;
Private | FWeight: Single;
Private | FInvWeight: Single;
Private | FRadius: Single;
Private | FNailedDown: Boolean;
Private | FFriction: Single;
Private | FChangedOnStep: Integer;

Methods

Public | constructor CreateOwned(const aOwner: TGLVerletWorld); virtual;
Public | destructor Destroy; override;
Public | function DistanceToNode(const node: TGLBaseVerletNode): Single;
Public | function GetMovement: TAffineVector;
Private | function GetSpeed: TAffineVector;
Public | procedure ApplyFriction(const friction, penetrationDepth: Single; const surfaceNormal: TAffineVector);
Public | procedure Initialize; dynamic;
Public | procedure OldApplyFriction(const friction, penetrationDepth: Single);
Public | procedure UpdateCachedAABBAndBSphere; override;
Public | procedure Verlet(const vpt: TGLProgressTimes); virtual;

Properties

Public | property ChangedOnStep: Integer read FChangedOnStep;
Public | property Force: TAffineVector read FForce write FForce;
Public | property friction: Single read FFriction write FFriction;
Public | property InvWeight: Single read FInvWeight;
Public | property Location: TAffineVector read FLocation write SetLocation;
Public | property NailedDown: Boolean read FNailedDown write FNailedDown;
Public | property OldLocation: TAffineVector read FOldLocation write FOldLocation;
Public | property Owner: TGLVerletWorld read FOwner;
Public | property Radius: Single read FRadius write FRadius;
Public | property Speed: TAffineVector read GetSpeed;
Public | property Weight: Single read FWeight write SetWeight;

Description

Fields

Private FForce: TAffineVector;

This item has no description.

Private FOwner: TGLVerletWorld;

This item has no description.

Private FWeight: Single;

This item has no description.

Private FInvWeight: Single;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FNailedDown: Boolean;

This item has no description.

Private FFriction: Single;

This item has no description.

Private FChangedOnStep: Integer;

This item has no description.

Methods

Public constructor CreateOwned(const aOwner: TGLVerletWorld); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DistanceToNode(const node: TGLBaseVerletNode): Single;

Calculates the distance to another node

Public function GetMovement: TAffineVector;

Calculates the movement of the node

Private function GetSpeed: TAffineVector;

This item has no description.

Public procedure ApplyFriction(const friction, penetrationDepth: Single; const surfaceNormal: TAffineVector);

Applies friction

Public procedure Initialize; dynamic;

Initlializes the node. For the base class, it just makes sure that FOldPosition = FPosition, so that speed is zero

Public procedure OldApplyFriction(const friction, penetrationDepth: Single);

Simple and less accurate method for friction

Public procedure UpdateCachedAABBAndBSphere; override;

The TGLBaseVerletNode inherits from TSpacePartitionLeaf, and it needs to know how to publish itself. The owner (a TGLVerletWorld) has a spatial partitioning object

Public procedure Verlet(const vpt: TGLProgressTimes); virtual;

Perform Verlet integration

Properties

Public property ChangedOnStep: Integer read FChangedOnStep;

What phyisics step was this node last changed? Used to keep track of when the spatial partitioning needs to be updated

Public property Force: TAffineVector read FForce write FForce;

A sum of all forces that has been applied to this verlet node during a step

Public property friction: Single read FFriction write FFriction;

Each node has a friction that effects how it reacts during contacts.

Public property InvWeight: Single read FInvWeight;

InvWeight is 1/Weight, and is kept up to date automatically

Public property Location: TAffineVector read FLocation write SetLocation;

The location of the verlet

Public property NailedDown: Boolean read FNailedDown write FNailedDown;

If the node is nailed down, it can't be moved by either force, constraint or verlet integration - but you can still move it by hand

Public property OldLocation: TAffineVector read FOldLocation write FOldLocation;

The old location of the verlet. This is used for verlet integration

Public property Owner: TGLVerletWorld read FOwner;

The VerletWorld that owns this verlet

Public property Radius: Single read FRadius write FRadius;

The radius of the verlet node - this has been more or less deprecated

Public property Speed: TAffineVector read GetSpeed;

Returns the speed of the verlet node. Speed = Movement / deltatime

Public property Weight: Single read FWeight write SetWeight;

The weight of a node determines how much it's affected by a force


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletNodeList

Class TGLVerletNodeList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletNodeList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLVerletNodeList

Overview

Methods

Private | function GetItems(i: Integer): TGLBaseVerletNode;
Private | procedure SetItems(i: Integer; const Value: TGLBaseVerletNode);

Properties

Public property Items[i: Integer]: TGLBaseVerletNode read GetItems write SetItems;

Description

Methods

Private function GetItems(i: Integer): TGLBaseVerletNode;

This item has no description.

Private procedure SetItems(i: Integer; const Value: TGLBaseVerletNode);

This item has no description.

Properties

Public property Items[i: Integer]: TGLBaseVerletNode read GetItems write SetItems;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletConstraint

Class TGLVerletConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletConstraint = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletConstraint

Overview

Fields

Private | FOwner: TGLVerletWorld;
Private | FEnabled: Boolean;
Private | FTag: Integer;

Methods

Public | constructor Create(const aOwner: TGLVerletWorld); virtual;
Public | destructor Destroy; override;
Public | procedure BeforeIterations; virtual;
Public | procedure RemoveNode(const aNode: TGLBaseVerletNode); virtual; abstract;
Public | procedure SatisfyConstraint(const iteration, maxIterations: Integer); virtual; abstract;

Properties

Public | property Enabled: Boolean read FEnabled write FEnabled;
Public | property Owner: TGLVerletWorld read FOwner;
Public | property Tag: Integer read FTag write FTag;

Description

Fields

Private FOwner: TGLVerletWorld;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FTag: Integer;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BeforeIterations; virtual;

Method that's fired before the physics iterations are performed

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); virtual; abstract;

Notifies removal of a node

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); virtual; abstract;

Updates the position of one or several nodes to make sure that they don't violate the constraint

Properties

Public property Enabled: Boolean read FEnabled write FEnabled;

Determines if the constraint should be enforced or not

Public property Owner: TGLVerletWorld read FOwner;

Onwer of the constraint

Public property Tag: Integer read FTag write FTag;

Tag field reserved for the user.


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletDualConstraint

Class TGLVerletDualConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletDualConstraint = class(TGLVerletConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletDualConstraint

Overview

Fields

Private | FNodeA: TGLBaseVerletNode;
Private | FNodeB: TGLBaseVerletNode;

Methods

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

Properties

Public | property NodeA: TGLBaseVerletNode read FNodeA write FNodeA;
Public | property NodeB: TGLBaseVerletNode read FNodeB write FNodeB;

Description

Fields

Private FNodeA: TGLBaseVerletNode;

This item has no description.

Private FNodeB: TGLBaseVerletNode;

This item has no description.

Methods

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

This item has no description. Showing description inherited from TGLVerletConstraint.RemoveNode.

Notifies removal of a node

Properties

Public property NodeA: TGLBaseVerletNode read FNodeA write FNodeA;

Reference to NodeA.

Public property NodeB: TGLBaseVerletNode read FNodeB write FNodeB;

Reference to NodeB.


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGroupConstraint

Class TGLVerletGroupConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGroupConstraint = class(TGLVerletConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGroupConstraint

Overview

Fields

Private FNodes: TGLVerletNodeList;

Methods

Public | constructor Create(const aOwner: TGLVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

Properties

Public property Nodes: TGLVerletNodeList read FNodes;

Description

Fields

Private FNodes: TGLVerletNodeList;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

This item has no description. Showing description inherited from TGLVerletConstraint.RemoveNode.

Notifies removal of a node

Properties

Public property Nodes: TGLVerletNodeList read FNodes;

The list of nodes that this constraint will effect


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletEdge

Class TGLVerletEdge

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletEdge = class(TGLSpacePartitionLeaf)

Description

Verlet edges simulate rigid collission edges

Hierarchy

  • TGLPersistentObject
  • TGLSpacePartitionLeaf
  • TGLVerletEdge

Overview

Fields

Private | FNodeA: TGLBaseVerletNode;
Private | FNodeB: TGLBaseVerletNode;

Methods

Public | constructor CreateEdgeOwned(const aNodeA, aNodeB: TGLBaseVerletNode);
Public | procedure UpdateCachedAABBAndBSphere; override;

Properties

Public | property NodeA: TGLBaseVerletNode read FNodeA write FNodeA;
Public | property NodeB: TGLBaseVerletNode read FNodeB write FNodeB;

Description

Fields

Private FNodeA: TGLBaseVerletNode;

This item has no description.

Private FNodeB: TGLBaseVerletNode;

This item has no description.

Methods

Public constructor CreateEdgeOwned(const aNodeA, aNodeB: TGLBaseVerletNode);

This item has no description.

Public procedure UpdateCachedAABBAndBSphere; override;

The TGLVerletEdge inherits from TSpacePartitionLeaf, and it needs to know how to publish itself. The owner ( a TGLVerletWorld ) has a spatial partitioning object

Properties

Public property NodeA: TGLBaseVerletNode read FNodeA write FNodeA;

One of the nodes in the edge

Public property NodeB: TGLBaseVerletNode read FNodeB write FNodeB;

One of the nodes in the edge


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletEdgeList

Class TGLVerletEdgeList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletEdgeList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLVerletEdgeList

Overview

Methods

Private | function GetItems(i: Integer): TGLVerletEdge;
Private | procedure SetItems(i: Integer; const Value: TGLVerletEdge);

Properties

Public property Items[i: Integer]: TGLVerletEdge read GetItems write SetItems;

Description

Methods

Private function GetItems(i: Integer): TGLVerletEdge;

This item has no description.

Private procedure SetItems(i: Integer; const Value: TGLVerletEdge);

This item has no description.

Properties

Public property Items[i: Integer]: TGLVerletEdge read GetItems write SetItems;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGlobalConstraint

Class TGLVerletGlobalConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGlobalConstraint = class(TGLVerletConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint

Overview

Fields

Private | FKickbackForce: TAffineVector;
Private | FKickbackTorque: TAffineVector;
Private | FLocation: TAffineVector;

Methods

Public | constructor Create(const aOwner: TGLVerletWorld); override;
Public | destructor Destroy; override;
Public | function TranslateKickbackTorque(const TorqueCenter: TAffineVector) : TAffineVector;
Public | procedure AddKickbackForceAt(const Pos: TAffineVector; const Force: TAffineVector);
Public | procedure BeforeIterations; override;
Public | procedure RemoveNode(const aNode: TGLBaseVerletNode); override;
Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Public | procedure SatisfyConstraintForEdge(const aEdge: TGLVerletEdge; const iteration, maxIterations: Integer); virtual;
Public | procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); virtual; abstract;
Private | procedure SetLocation(const Value: TAffineVector); virtual;

Properties

Public | property KickbackForce: TAffineVector read FKickbackForce write FKickbackForce;
Public | property KickbackTorque: TAffineVector read FKickbackTorque write FKickbackTorque;
Public | property Location: TAffineVector read FLocation write SetLocation;

Description

Fields

Private FKickbackForce: TAffineVector;

This item has no description.

Private FKickbackTorque: TAffineVector;

This item has no description.

Private FLocation: TAffineVector;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TranslateKickbackTorque(const TorqueCenter: TAffineVector) : TAffineVector;

This item has no description.

Public procedure AddKickbackForceAt(const Pos: TAffineVector; const Force: TAffineVector);

This item has no description.

Public procedure BeforeIterations; override;

This item has no description. Showing description inherited from TGLVerletConstraint.BeforeIterations.

Method that's fired before the physics iterations are performed

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

This item has no description. Showing description inherited from TGLVerletConstraint.RemoveNode.

Notifies removal of a node

Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;

This item has no description. Showing description inherited from TGLVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint

Public procedure SatisfyConstraintForEdge(const aEdge: TGLVerletEdge; const iteration, maxIterations: Integer); virtual;

This item has no description.

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); virtual; abstract;

This item has no description.

Private procedure SetLocation(const Value: TAffineVector); virtual;

This item has no description.

Properties

Public property KickbackForce: TAffineVector read FKickbackForce write FKickbackForce;

The force that this collider has experienced while correcting the verlet possitions. This force can be applied to ODE bodies, for instance

Public property KickbackTorque: TAffineVector read FKickbackTorque write FKickbackTorque;

The torque that this collider has experienced while correcting the verlet possitions, in reference to the center of the collider. The torque force can be applied to ODE bodies, but it must first be translated. A torque can be trasnalted by EM(b) = EM(a) + EF x VectorSubtract(b, a). Simply adding the torque to the body will NOT work correctly. See TranslateKickbackTorque

Public property Location: TAffineVector read FLocation write SetLocation;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGlobalFrictionConstraint

Class TGLVerletGlobalFrictionConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGlobalFrictionConstraint = class(TGLVerletGlobalConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint

Overview

Fields

Private FFrictionRatio: Single;

Methods

Public constructor Create(const aOwner: TGLVerletWorld); override;

Properties

Public property FrictionRatio: Single read FFrictionRatio write FFrictionRatio;

Description

Fields

Private FFrictionRatio: Single;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); override;

This item has no description.

Properties

Public property FrictionRatio: Single read FFrictionRatio write FFrictionRatio;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGlobalFrictionConstraintSP

Class TGLVerletGlobalFrictionConstraintSP

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGlobalFrictionConstraintSP = class(TGLVerletGlobalFrictionConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletGlobalFrictionConstraintSP

Overview

Methods

Public | procedure PerformSpaceQuery; virtual; abstract;
Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;

Description

Methods

Public procedure PerformSpaceQuery; virtual; abstract;

This item has no description.

Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;

This item has no description. Showing description inherited from TGLVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGlobalFrictionConstraintSphere

Class TGLVerletGlobalFrictionConstraintSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGlobalFrictionConstraintSphere = class(TGLVerletGlobalFrictionConstraintSP)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletGlobalFrictionConstraintSP
  • TGLVerletGlobalFrictionConstraintSphere

Overview

Fields

Private FCachedBSphere: TBSphere;

Methods

Public | function GetBSphere: TBSphere; virtual; abstract;
Public | procedure PerformSpaceQuery; override;
Public | procedure UpdateCachedBSphere;
Private | procedure SetLocation(const Value: TAffineVector); override;

Properties

Public property CachedBSphere: TBSphere read FCachedBSphere;

Description

Fields

Private FCachedBSphere: TBSphere;

This item has no description.

Methods

Public function GetBSphere: TBSphere; virtual; abstract;

This item has no description.

Public procedure PerformSpaceQuery; override;

This item has no description.

Public procedure UpdateCachedBSphere;

This item has no description.

Private procedure SetLocation(const Value: TAffineVector); override;

This item has no description.

Properties

Public property CachedBSphere: TBSphere read FCachedBSphere;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGlobalFrictionConstraintBox

Class TGLVerletGlobalFrictionConstraintBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGlobalFrictionConstraintBox = class(TGLVerletGlobalFrictionConstraintSP)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletGlobalFrictionConstraintSP
  • TGLVerletGlobalFrictionConstraintBox

Overview

Fields

Private FCachedAABB: TAABB;

Methods

Public | function GetAABB: TAABB; virtual; abstract;
Public | procedure PerformSpaceQuery; override;
Public | procedure UpdateCachedAABB;
Private | procedure SetLocation(const Value: TAffineVector); override;

Properties

Public property CachedAABB: TAABB read FCachedAABB;

Description

Fields

Private FCachedAABB: TAABB;

This item has no description.

Methods

Public function GetAABB: TAABB; virtual; abstract;

This item has no description.

Public procedure PerformSpaceQuery; override;

This item has no description.

Public procedure UpdateCachedAABB;

This item has no description.

Private procedure SetLocation(const Value: TAffineVector); override;

This item has no description.

Properties

Public property CachedAABB: TAABB read FCachedAABB;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletConstraintList

Class TGLVerletConstraintList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletConstraintList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLVerletConstraintList

Overview

Methods

Private | function GetItems(i: Integer): TGLVerletConstraint;
Private | procedure SetItems(i: Integer; const Value: TGLVerletConstraint);

Properties

Public property Items[i: Integer]: TGLVerletConstraint read GetItems write SetItems;

Description

Methods

Private function GetItems(i: Integer): TGLVerletConstraint;

This item has no description.

Private procedure SetItems(i: Integer; const Value: TGLVerletConstraint);

This item has no description.

Properties

Public property Items[i: Integer]: TGLVerletConstraint read GetItems write SetItems;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletForce

Class TGLVerletForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletForce = class(TObject)

Description

Generic verlet force.

Hierarchy

  • TObject
  • TGLVerletForce

Overview

Fields

Private FOwner: TGLVerletWorld;

Methods

Public | constructor Create(const aOwner: TGLVerletWorld); virtual;
Public | destructor Destroy; override;
Public | procedure AddForce(const vpt: TGLProgressTimes); virtual; abstract;
Public | procedure RemoveNode(const aNode: TGLBaseVerletNode); virtual; abstract;

Properties

Public property Owner: TGLVerletWorld read FOwner;

Description

Fields

Private FOwner: TGLVerletWorld;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddForce(const vpt: TGLProgressTimes); virtual; abstract;

Implementation should add force to force resultant for all relevant nodes

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); virtual; abstract;

Notifies removal of a node

Properties

Public property Owner: TGLVerletWorld read FOwner;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletDualForce

Class TGLVerletDualForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletDualForce = class(TGLVerletForce)

Description

A verlet force that applies to two specified nodes.

Hierarchy

  • TObject
  • TGLVerletForce
  • TGLVerletDualForce

Overview

Fields

Private | FNodeA: TGLBaseVerletNode;
Private | FNodeB: TGLBaseVerletNode;

Methods

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

Properties

Public | property NodeA: TGLBaseVerletNode read FNodeA write FNodeA;
Public | property NodeB: TGLBaseVerletNode read FNodeB write FNodeB;

Description

Fields

Private FNodeA: TGLBaseVerletNode;

This item has no description.

Private FNodeB: TGLBaseVerletNode;

This item has no description.

Methods

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

This item has no description. Showing description inherited from TGLVerletForce.RemoveNode.

Notifies removal of a node

Properties

Public property NodeA: TGLBaseVerletNode read FNodeA write FNodeA;

Reference to NodeA.

Public property NodeB: TGLBaseVerletNode read FNodeB write FNodeB;

Reference to NodeB.


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGroupForce

Class TGLVerletGroupForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGroupForce = class(TGLVerletForce)

Description

A verlet force that applies to a specified group of nodes.

Hierarchy

  • TObject
  • TGLVerletForce
  • TGLVerletGroupForce

Overview

Fields

Private FNodes: TGLVerletNodeList;

Methods

Public | constructor Create(const aOwner: TGLVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

Properties

Public property Nodes: TGLVerletNodeList read FNodes;

Description

Fields

Private FNodes: TGLVerletNodeList;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

This item has no description. Showing description inherited from TGLVerletForce.RemoveNode.

Notifies removal of a node

Properties

Public property Nodes: TGLVerletNodeList read FNodes;

Nodes of the force group, referred, NOT owned.


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGlobalForce

Class TGLVerletGlobalForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGlobalForce = class(TGLVerletForce)

Description

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TGLVerletForce
  • TGLVerletGlobalForce

Overview

Methods

Public | procedure AddForce(const vpt: TGLProgressTimes); override;
Public | procedure AddForceToNode(const aNode: TGLBaseVerletNode); virtual; abstract;
Public | procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

Description

Methods

Public procedure AddForce(const vpt: TGLProgressTimes); override;

This item has no description. Showing description inherited from TGLVerletForce.AddForce.

Implementation should add force to force resultant for all relevant nodes

Public procedure AddForceToNode(const aNode: TGLBaseVerletNode); virtual; abstract;

This item has no description.

Public procedure RemoveNode(const aNode: TGLBaseVerletNode); override;

This item has no description. Showing description inherited from TGLVerletForce.RemoveNode.

Notifies removal of a node


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletForceList

Class TGLVerletForceList

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletForceList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGLVerletForceList

Overview

Methods

Private | function GetItems(i: Integer): TGLVerletForce;
Private | procedure SetItems(i: Integer; const Value: TGLVerletForce);

Properties

Public property Items[i: Integer]: TGLVerletForce read GetItems write SetItems;

Description

Methods

Private function GetItems(i: Integer): TGLVerletForce;

This item has no description.

Private procedure SetItems(i: Integer; const Value: TGLVerletForce);

This item has no description.

Properties

Public property Items[i: Integer]: TGLVerletForce read GetItems write SetItems;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletWorld

Class TGLVerletWorld

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletWorld = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLVerletWorld

Overview

Fields

Private | FIterations: Integer;
Private | FNodes: TGLVerletNodeList;
Private | FConstraints: TGLVerletConstraintList;
Private | FForces: TGLVerletForceList;
Private | FMaxDeltaTime: Single;
Private | FSimTime: Single;
Private | FDrag: Single;
Private | FCurrentDeltaTime: Single;
Private | FInvCurrentDeltaTime: Single;
Private | FSolidEdges: TGLVerletEdgeList;
Private | FSpacePartition: TGLBaseSpacePartition;
Private | FCurrentStepCount: Integer;
Private | FUpdateSpacePartion: TUpdateSpacePartion;
Private | FCollisionConstraintTypes: TCollisionConstraintTypesSet;
Private | FConstraintsWithBeforeIterations: TGLVerletConstraintList;
Private | FVerletNodeClass: TGLVerletNodeClass;
Private | FInertia: Boolean;
Private | FInertaPauseSteps: Integer;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function AddConstraint(const aConstraint: TGLVerletConstraint): Integer;
Public | function AddForce(const aForce: TGLVerletForce): Integer;
Public | function AddNode(const aNode: TGLBaseVerletNode): Integer;
Public | function CreateOwnedNode(const Location: TAffineVector; const aRadius: Single = 0; const aWeight: Single = 1): TGLBaseVerletNode;
Public | function CreateSlider(const aNodeA, aNodeB: TGLBaseVerletNode; const aSlideDirection: TAffineVector): TGLVerletSlider;
Public | function CreateSpring(const aNodeA, aNodeB: TGLBaseVerletNode; const aStrength, aDamping: Single; const aSlack: Single = 0): TGLVerletSpring;
Public | function CreateStick(const aNodeA, aNodeB: TGLBaseVerletNode; const Slack: Single = 0): TGLVerletStick;
Public | function FirstNode: TGLBaseVerletNode;
Public | function LastNode: TGLBaseVerletNode;
Public | function Progress(const deltaTime, newTime: Double): Integer; virtual;
Public | procedure AddSolidEdge(const aNodeA, aNodeB: TGLBaseVerletNode);
Public | procedure CreateOctree(const OctreeMin, OctreeMax: TAffineVector; const LeafThreshold, MaxTreeDepth: Integer);
Public | procedure Initialize; virtual;
Public | procedure PauseInertia(const IterationSteps: Integer);
Public | procedure RemoveConstraint(const aConstraint: TGLVerletConstraint);
Public | procedure RemoveForce(const aForce: TGLVerletForce);
Public | procedure RemoveNode(const aNode: TGLBaseVerletNode);

Properties

Public | property CollisionConstraintTypes: TCollisionConstraintTypesSet read FCollisionConstraintTypes write FCollisionConstraintTypes;
Public | property Constraints: TGLVerletConstraintList read FConstraints;
Public | property ConstraintsWithBeforeIterations: TGLVerletConstraintList read FConstraintsWithBeforeIterations;
Public | property CurrentDeltaTime: Single read FCurrentDeltaTime;
Public | property CurrentStepCount: Integer read FCurrentStepCount;
Public | property Drag: Single read FDrag write FDrag;
Public | property Inertia: Boolean read FInertia write FInertia;
Public | property Iterations: Integer read FIterations write FIterations;
Public | property MaxDeltaTime: Single read FMaxDeltaTime write FMaxDeltaTime;
Public | property Nodes: TGLVerletNodeList read FNodes;
Public | property SimTime: Single read FSimTime write FSimTime;
Public | property SolidEdges: TGLVerletEdgeList read FSolidEdges write FSolidEdges;
Public | property SpacePartition: TGLBaseSpacePartition read FSpacePartition;
Public | property UpdateSpacePartion: TUpdateSpacePartion read FUpdateSpacePartion write FUpdateSpacePartion;
Public | property VerletNodeClass: TGLVerletNodeClass read FVerletNodeClass write FVerletNodeClass;

Description

Fields

Private FIterations: Integer;

This item has no description.

Private FNodes: TGLVerletNodeList;

This item has no description.

Private FConstraints: TGLVerletConstraintList;

This item has no description.

Private FForces: TGLVerletForceList;

This item has no description.

Private FMaxDeltaTime: Single;

This item has no description.

Private FSimTime: Single;

This item has no description.

Private FDrag: Single;

This item has no description.

Private FCurrentDeltaTime: Single;

This item has no description.

Private FInvCurrentDeltaTime: Single;

This item has no description.

Private FSolidEdges: TGLVerletEdgeList;

This item has no description.

Private FSpacePartition: TGLBaseSpacePartition;

This item has no description.

Private FCurrentStepCount: Integer;

This item has no description.

Private FUpdateSpacePartion: TUpdateSpacePartion;

This item has no description.

Private FCollisionConstraintTypes: TCollisionConstraintTypesSet;

This item has no description.

Private FConstraintsWithBeforeIterations: TGLVerletConstraintList;

This item has no description.

Private FVerletNodeClass: TGLVerletNodeClass;

This item has no description.

Private FInertia: Boolean;

This item has no description.

Private FInertaPauseSteps: Integer;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddConstraint(const aConstraint: TGLVerletConstraint): Integer;

This item has no description.

Public function AddForce(const aForce: TGLVerletForce): Integer;

This item has no description.

Public function AddNode(const aNode: TGLBaseVerletNode): Integer;

This item has no description.

Public function CreateOwnedNode(const Location: TAffineVector; const aRadius: Single = 0; const aWeight: Single = 1): TGLBaseVerletNode;

This item has no description.

Public function CreateSlider(const aNodeA, aNodeB: TGLBaseVerletNode; const aSlideDirection: TAffineVector): TGLVerletSlider;

This item has no description.

Public function CreateSpring(const aNodeA, aNodeB: TGLBaseVerletNode; const aStrength, aDamping: Single; const aSlack: Single = 0): TGLVerletSpring;

This item has no description.

Public function CreateStick(const aNodeA, aNodeB: TGLBaseVerletNode; const Slack: Single = 0): TGLVerletStick;

This item has no description.

Public function FirstNode: TGLBaseVerletNode;

This item has no description.

Public function LastNode: TGLBaseVerletNode;

This item has no description.

Public function Progress(const deltaTime, newTime: Double): Integer; virtual;

This item has no description.

Public procedure AddSolidEdge(const aNodeA, aNodeB: TGLBaseVerletNode);

This item has no description.

Public procedure CreateOctree(const OctreeMin, OctreeMax: TAffineVector; const LeafThreshold, MaxTreeDepth: Integer);

This item has no description.

Public procedure Initialize; virtual;

This item has no description.

Public procedure PauseInertia(const IterationSteps: Integer);

This item has no description.

Public procedure RemoveConstraint(const aConstraint: TGLVerletConstraint);

This item has no description.

Public procedure RemoveForce(const aForce: TGLVerletForce);

This item has no description.

Public procedure RemoveNode(const aNode: TGLBaseVerletNode);

This item has no description.

Properties

Public property CollisionConstraintTypes: TCollisionConstraintTypesSet read FCollisionConstraintTypes write FCollisionConstraintTypes;

This item has no description.

Public property Constraints: TGLVerletConstraintList read FConstraints;

This item has no description.

Public property ConstraintsWithBeforeIterations: TGLVerletConstraintList read FConstraintsWithBeforeIterations;

This item has no description.

Public property CurrentDeltaTime: Single read FCurrentDeltaTime;

This item has no description.

Public property CurrentStepCount: Integer read FCurrentStepCount;

This item has no description.

Public property Drag: Single read FDrag write FDrag;

This item has no description.

Public property Inertia: Boolean read FInertia write FInertia;

This item has no description.

Public property Iterations: Integer read FIterations write FIterations;

This item has no description.

Public property MaxDeltaTime: Single read FMaxDeltaTime write FMaxDeltaTime;

This item has no description.

Public property Nodes: TGLVerletNodeList read FNodes;

This item has no description.

Public property SimTime: Single read FSimTime write FSimTime;

This item has no description.

Public property SolidEdges: TGLVerletEdgeList read FSolidEdges write FSolidEdges;

This item has no description.

Public property SpacePartition: TGLBaseSpacePartition read FSpacePartition;

This item has no description.

Public property UpdateSpacePartion: TUpdateSpacePartion read FUpdateSpacePartion write FUpdateSpacePartion;

This item has no description.

Public property VerletNodeClass: TGLVerletNodeClass read FVerletNodeClass write FVerletNodeClass;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletGravity

Class TGLVerletGravity

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletGravity = class(TGLVerletGlobalForce)

Description

This item has no description. Showing description inherited from TGLVerletGlobalForce.

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TGLVerletForce
  • TGLVerletGlobalForce
  • TGLVerletGravity

Overview

Fields

Private FGravity: TAffineVector;

Methods

Public | constructor Create(const aOwner: TGLVerletWorld); override;
Public | procedure AddForceToNode(const aNode: TGLBaseVerletNode); override;

Properties

Public property Gravity: TAffineVector read FGravity write FGravity;

Description

Fields

Private FGravity: TAffineVector;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); override;

This item has no description.

Public procedure AddForceToNode(const aNode: TGLBaseVerletNode); override;

This item has no description.

Properties

Public property Gravity: TAffineVector read FGravity write FGravity;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletAirResistance

Class TGLVerletAirResistance

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletAirResistance = class(TGLVerletGlobalForce)

Description

This item has no description. Showing description inherited from TGLVerletGlobalForce.

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TGLVerletForce
  • TGLVerletGlobalForce
  • TGLVerletAirResistance

Overview

Fields

Private | FDragCoeff: Single;
Private | FWindDirection: TAffineVector;
Private | FWindMagnitude: Single;
Private | FWindChaos: Single;

Methods

Public | constructor Create(const aOwner: TGLVerletWorld); override;
Public | procedure AddForceToNode(const aNode: TGLBaseVerletNode); override;
Private | procedure SetWindDirection(const Value: TAffineVector);

Properties

Public | property DragCoeff: Single read FDragCoeff write FDragCoeff;
Public | property WindChaos: Single read FWindChaos write FWindChaos;
Public | property WindDirection: TAffineVector read FWindDirection write SetWindDirection;
Public | property WindMagnitude: Single read FWindMagnitude write FWindMagnitude;

Description

Fields

Private FDragCoeff: Single;

This item has no description.

Private FWindDirection: TAffineVector;

This item has no description.

Private FWindMagnitude: Single;

This item has no description.

Private FWindChaos: Single;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); override;

This item has no description.

Public procedure AddForceToNode(const aNode: TGLBaseVerletNode); override;

This item has no description.

Private procedure SetWindDirection(const Value: TAffineVector);

This item has no description.

Properties

Public property DragCoeff: Single read FDragCoeff write FDragCoeff;

This item has no description.

Public property WindChaos: Single read FWindChaos write FWindChaos;

Measures how chaotic the wind is, as a fraction of the wind magnitude

Public property WindDirection: TAffineVector read FWindDirection write SetWindDirection;

This item has no description.

Public property WindMagnitude: Single read FWindMagnitude write FWindMagnitude;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletSpring

Class TGLVerletSpring

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletSpring = class(TGLVerletDualForce)

Description

This item has no description. Showing description inherited from TGLVerletDualForce.

A verlet force that applies to two specified nodes.

Hierarchy

  • TObject
  • TGLVerletForce
  • TGLVerletDualForce
  • TGLVerletSpring

Overview

Fields

Private | FRestLength: Single;
Private | FStrength: Single;
Private | FDamping: Single;
Private | FSlack: Single;
Private | FForceFactor: Single;

Methods

Public | procedure AddForce(const vpt: TGLProgressTimes); override;
Public | procedure SetRestLengthToCurrent;

Properties

Public | property Damping: Single read FDamping write FDamping;
Public | property Slack: Single read FSlack write SetSlack;
Public | property Strength: Single read FStrength write FStrength;

Description

Fields

Private FRestLength: Single;

This item has no description.

Private FStrength: Single;

This item has no description.

Private FDamping: Single;

This item has no description.

Private FSlack: Single;

This item has no description.

Private FForceFactor: Single;

This item has no description.

Methods

Public procedure AddForce(const vpt: TGLProgressTimes); override;

This item has no description. Showing description inherited from TGLVerletForce.AddForce.

Implementation should add force to force resultant for all relevant nodes

Public procedure SetRestLengthToCurrent;

Must be invoked after adjust node locations or strength

Properties

Public property Damping: Single read FDamping write FDamping;

This item has no description.

Public property Slack: Single read FSlack write SetSlack;

This item has no description.

Public property Strength: Single read FStrength write FStrength;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletFloor

Class TGLVerletFloor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletFloor = class(TGLVerletGlobalFrictionConstraintSP)

Description

Floor Collision Constraint

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletGlobalFrictionConstraintSP
  • TGLVerletFloor

Overview

Fields

Private | FBounceRatio: Single;
Private | FFloorLevel: Single;
Private | FNormal: TAffineVector;

Methods

Public | constructor Create(const aOwner: TGLVerletWorld); override;
Public | procedure PerformSpaceQuery; override;
Public | procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public | property BounceRatio: Single read FBounceRatio write FBounceRatio;
Public | property FloorLevel: Single read FFloorLevel write FFloorLevel;
Public | property Normal: TAffineVector read FNormal write SetNormal;

Description

Fields

Private FBounceRatio: Single;

This item has no description.

Private FFloorLevel: Single;

This item has no description.

Private FNormal: TAffineVector;

This item has no description.

Methods

Public constructor Create(const aOwner: TGLVerletWorld); override;

This item has no description.

Public procedure PerformSpaceQuery; override;

This item has no description.

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property BounceRatio: Single read FBounceRatio write FBounceRatio;

This item has no description.

Public property FloorLevel: Single read FFloorLevel write FFloorLevel;

This item has no description.

Public property Normal: TAffineVector read FNormal write SetNormal;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletHeightField

Class TGLVerletHeightField

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletHeightField = class(TGLVerletFloor)

Description

HeightField collision constraint (punctual!)

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletGlobalFrictionConstraintSP
  • TGLVerletFloor
  • TGLVerletHeightField

Overview

Fields

Private FOnNeedHeight: TGLVerletHeightFieldOnNeedHeight;

Methods

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public property OnNeedHeight: TGLVerletHeightFieldOnNeedHeight read FOnNeedHeight write FOnNeedHeight;

Description

Fields

Private FOnNeedHeight: TGLVerletHeightFieldOnNeedHeight;

This item has no description.

Methods

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property OnNeedHeight: TGLVerletHeightFieldOnNeedHeight read FOnNeedHeight write FOnNeedHeight;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletStick

Class TGLVerletStick

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletStick = class(TGLVerletDualConstraint)

Description

Stick Verlet Collision Constraint. Imposes a fixed distance between two nodes

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletDualConstraint
  • TGLVerletStick

Overview

Fields

Private | FSlack: Single;
Private | FRestLength: Single;

Methods

Public | procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;
Public | procedure SetRestLengthToCurrent;

Properties

Public | property RestLength: Single read FRestLength write FRestLength;
Public | property Slack: Single read FSlack write FSlack;

Description

Fields

Private FSlack: Single;

This item has no description.

Private FRestLength: Single;

This item has no description.

Methods

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

This item has no description. Showing description inherited from TGLVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint

Public procedure SetRestLengthToCurrent;

This item has no description.

Properties

Public property RestLength: Single read FRestLength write FRestLength;

This item has no description.

Public property Slack: Single read FSlack write FSlack;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletRigidBody

Class TGLVerletRigidBody

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletRigidBody = class(TGLVerletGroupConstraint)

Description

Rigid body verlet Collision constraint. Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. EXPERIMENTAL, STILL DOES NOT WORK!

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGroupConstraint
  • TGLVerletRigidBody

Overview

Fields

Private | FNodeParams: array of TAffineVector;
Private | FNodeCoords: array of TAffineVector;
Private | FNatMatrix: TAffineMatrix;
Private | FInvNatMatrix: TAffineMatrix;

Methods

Public | procedure ComputeRigidityParameters;
Public | procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

Description

Fields

Private FNodeParams: array of TAffineVector;

This item has no description.

Private FNodeCoords: array of TAffineVector;

This item has no description.

Private FNatMatrix: TAffineMatrix;

This item has no description.

Private FInvNatMatrix: TAffineMatrix;

This item has no description.

Methods

Public procedure ComputeRigidityParameters;

This item has no description.

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

This item has no description. Showing description inherited from TGLVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletSlider

Class TGLVerletSlider

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletSlider = class(TGLVerletDualConstraint)

Description

Slider constraint. Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletDualConstraint
  • TGLVerletSlider

Overview

Fields

Private | FSlideDirection: TAffineVector;
Private | FConstrained: Boolean;

Methods

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

Properties

Public | property Constrained: Boolean read FConstrained write FConstrained;
Public | property SlideDirection: TAffineVector read FSlideDirection write SetSlideDirection;

Description

Fields

Private FSlideDirection: TAffineVector;

This item has no description.

Private FConstrained: Boolean;

This item has no description.

Methods

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

This item has no description. Showing description inherited from TGLVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint

Properties

Public property Constrained: Boolean read FConstrained write FConstrained;

Constrain NodeB to the halfplane defined by NodeA and SlideDirection.

Public property SlideDirection: TAffineVector read FSlideDirection write SetSlideDirection;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletFrictionSphere

Class TGLVerletFrictionSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletFrictionSphere = class(TGLVerletGlobalFrictionConstraintSphere)

Description

Sphere Сollision Friction Constraint

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletGlobalFrictionConstraintSP
  • TGLVerletGlobalFrictionConstraintSphere
  • TGLVerletFrictionSphere

Overview

Fields

Private FRadius: Single;

Methods

Public | function GetBSphere: TBSphere; override;
Public | procedure SatisfyConstraintForEdge(const aEdge: TGLVerletEdge; const iteration, maxIterations: Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public property Radius: Single read FRadius write FRadius;

Description

Fields

Private FRadius: Single;

This item has no description.

Methods

Public function GetBSphere: TBSphere; override;

This item has no description.

Public procedure SatisfyConstraintForEdge(const aEdge: TGLVerletEdge; const iteration, maxIterations: Integer); override;

This item has no description.

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property Radius: Single read FRadius write FRadius;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletFrictionCylinder

Class TGLVerletFrictionCylinder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletFrictionCylinder = class(TGLVerletGlobalFrictionConstraint)

Description

Cylinder collision Friction Constraint. The cylinder is considered infinite by this constraint.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletFrictionCylinder

Overview

Fields

Private | FAxis: TAffineVector;
Private | FRadius: Single;
Private | FRadius2: Single;

Methods

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public | property Axis: TAffineVector read FAxis write FAxis;
Public | property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FAxis: TAffineVector;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FRadius2: Single;

This item has no description.

Methods

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property Axis: TAffineVector read FAxis write FAxis;

Cylinder axis vector. Must be normalized.

Public property Radius: Single read FRadius write SetRadius;

Cylinder radius.


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletFrictionCube

Class TGLVerletFrictionCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletFrictionCube = class(TGLVerletGlobalFrictionConstraintBox)

Description

Cube Сollision Friction Constraint.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletGlobalFrictionConstraintSP
  • TGLVerletGlobalFrictionConstraintBox
  • TGLVerletFrictionCube

Overview

Fields

Private | FHalfSides: TAffineVector;
Private | FSides: TAffineVector;
Private | FDirection: TAffineVector;

Methods

Public | function GetAABB: TAABB; override;
Public | procedure SatisfyConstraintForEdge(const aEdge: TGLVerletEdge; const iteration, maxIterations: Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;
Private | procedure SetSides(const Value: TAffineVector);

Properties

Public | property Direction: TAffineVector read FDirection write FDirection;
Public | property Sides: TAffineVector read FSides write SetSides;

Description

Fields

Private FHalfSides: TAffineVector;

This item has no description.

Private FSides: TAffineVector;

This item has no description.

Private FDirection: TAffineVector;

This item has no description.

Methods

Public function GetAABB: TAABB; override;

This item has no description.

Public procedure SatisfyConstraintForEdge(const aEdge: TGLVerletEdge; const iteration, maxIterations: Integer); override;

Broken and very slow!

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Private procedure SetSides(const Value: TAffineVector);

This item has no description.

Properties

Public property Direction: TAffineVector read FDirection write FDirection;

This item has no description.

Public property Sides: TAffineVector read FSides write SetSides;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletFrictionCapsule

Class TGLVerletFrictionCapsule

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletFrictionCapsule = class(TGLVerletGlobalFrictionConstraintSphere)

Description

Capsule collision Friction Constraint.

Hierarchy

  • TObject
  • TGLVerletConstraint
  • TGLVerletGlobalConstraint
  • TGLVerletGlobalFrictionConstraint
  • TGLVerletGlobalFrictionConstraintSP
  • TGLVerletGlobalFrictionConstraintSphere
  • TGLVerletFrictionCapsule

Overview

Fields

Private | FAxis: TAffineVector;
Private | FRadius: Single;
Private | FRadius2: Single;
Private | FLength: Single;
Private | FLengthDiv2: Single;

Methods

Public | function GetBSphere: TBSphere; override;
Public | procedure SatisfyConstraintForEdge(const aEdge: TGLVerletEdge; const iteration, maxIterations: Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public | property Axis: TAffineVector read FAxis write SetAxis;
Public | property Length: Single read FLength write SetLength;
Public | property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FAxis: TAffineVector;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FRadius2: Single;

This item has no description.

Private FLength: Single;

This item has no description.

Private FLengthDiv2: Single;

This item has no description.

Methods

Public function GetBSphere: TBSphere; override;

This item has no description.

Public procedure SatisfyConstraintForEdge(const aEdge: TGLVerletEdge; const iteration, maxIterations: Integer); override;

This item has no description.

Public procedure SatisfyConstraintForNode(const aNode: TGLBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property Axis: TAffineVector read FAxis write SetAxis;

property Base : TAffineVector read FBase write FBase;

Public property Length: Single read FLength write SetLength;

This item has no description.

Public property Radius: Single read FRadius write SetRadius;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletNode

Class TGLVerletNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletNode = class(TGLBaseVerletNode)

Description

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.

Hierarchy

  • TGLPersistentObject
  • TGLSpacePartitionLeaf
  • TGLBaseVerletNode
  • TGLVerletNode

Overview

Fields

Private | FRelativePosition: TAffineVector;
Private | FGLBaseSceneObject: TGLBaseSceneObject;

Methods

Public | procedure Verlet(const vpt: TGLProgressTimes); override;
Private | procedure SetGLBaseSceneObject(const Value: TGLBaseSceneObject);

Properties

Public | property GLBaseSceneObject: TGLBaseSceneObject read FGLBaseSceneObject write SetGLBaseSceneObject;
Public | property RelativePosition: TAffineVector read FRelativePosition write FRelativePosition;

Description

Fields

Private FRelativePosition: TAffineVector;

This item has no description.

Private FGLBaseSceneObject: TGLBaseSceneObject;

This item has no description.

Methods

Public procedure Verlet(const vpt: TGLProgressTimes); override;

This item has no description. Showing description inherited from TGLBaseVerletNode.Verlet.

Perform Verlet integration

Private procedure SetGLBaseSceneObject(const Value: TGLBaseSceneObject);

This item has no description.

Properties

Public property GLBaseSceneObject: TGLBaseSceneObject read FGLBaseSceneObject write SetGLBaseSceneObject;

This item has no description.

Public property RelativePosition: TAffineVector read FRelativePosition write FRelativePosition;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletHair

Class TGLVerletHair

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletHair = class(TObject)

Description

Verlet Hair class

Hierarchy

  • TObject
  • TGLVerletHair

Overview

Fields

Private | FNodeList: TGLVerletNodeList;
Private | FLinkCount: integer;
Private | FRootDepth: single;
Private | FVerletWorld: TGLVerletWorld;
Private | FHairLength: single;
Private | FData: pointer;
Private | FStiffness: TGLStiffnessSetVH;
Private | FStiffnessList: TList;

Methods

Public | constructor Create(const AVerletWorld: TGLVerletWorld; const ARootDepth, AHairLength: single; ALinkCount: integer; const AAnchorPosition, AHairDirection: TAffineVector; const AStiffness: TGLStiffnessSetVH);
Public | destructor Destroy; override;
Private | function GetAnchor: TGLBaseVerletNode;
Private | function GetLinkLength: single;
Private | function GetRoot: TGLBaseVerletNode;
Public | procedure BuildHair(const AAnchorPosition, AHairDirection: TAffineVector);
Public | procedure BuildStiffness;
Public | procedure Clear;
Public | procedure ClearStiffness;
Private | procedure AddStickStiffness(const ANodeSkip: integer);
Private | procedure SetStiffness(const Value: TGLStiffnessSetVH);

Properties

Public | property Anchor: TGLBaseVerletNode read GetAnchor;
Public | property Data: pointer read FData write FData;
Public | property HairLength: single read FHairLength;
Public | property LinkCount: integer read FLinkCount;
Public | property LinkLength: single read GetLinkLength;
Public | property NodeList: TGLVerletNodeList read FNodeList;
Public | property Root: TGLBaseVerletNode read GetRoot;
Public | property RootDepth: single read FRootDepth;
Public | property Stiffness: TGLStiffnessSetVH read FStiffness write SetStiffness;
Public | property VerletWorld: TGLVerletWorld read FVerletWorld;

Description

Fields

Private FNodeList: TGLVerletNodeList;

This item has no description.

Private FLinkCount: integer;

This item has no description.

Private FRootDepth: single;

This item has no description.

Private FVerletWorld: TGLVerletWorld;

This item has no description.

Private FHairLength: single;

This item has no description.

Private FData: pointer;

This item has no description.

Private FStiffness: TGLStiffnessSetVH;

This item has no description.

Private FStiffnessList: TList;

This item has no description.

Methods

Public constructor Create(const AVerletWorld: TGLVerletWorld; const ARootDepth, AHairLength: single; ALinkCount: integer; const AAnchorPosition, AHairDirection: TAffineVector; const AStiffness: TGLStiffnessSetVH);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAnchor: TGLBaseVerletNode;

This item has no description.

Private function GetLinkLength: single;

This item has no description.

Private function GetRoot: TGLBaseVerletNode;

This item has no description.

Public procedure BuildHair(const AAnchorPosition, AHairDirection: TAffineVector);

This item has no description.

Public procedure BuildStiffness;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure ClearStiffness;

This item has no description.

Private procedure AddStickStiffness(const ANodeSkip: integer);

This item has no description.

Private procedure SetStiffness(const Value: TGLStiffnessSetVH);

This item has no description.

Properties

Public property Anchor: TGLBaseVerletNode read GetAnchor;

Anchor should be nailed down to give the hair stability

Public property Data: pointer read FData write FData;

This item has no description.

Public property HairLength: single read FHairLength;

This item has no description.

Public property LinkCount: integer read FLinkCount;

This item has no description.

Public property LinkLength: single read GetLinkLength;

This item has no description.

Public property NodeList: TGLVerletNodeList read FNodeList;

This item has no description.

Public property Root: TGLBaseVerletNode read GetRoot;

Root should be nailed down to give the hair stability

Public property RootDepth: single read FRootDepth;

This item has no description.

Public property Stiffness: TGLStiffnessSetVH read FStiffness write SetStiffness;

This item has no description.

Public property VerletWorld: TGLVerletWorld read FVerletWorld;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletSkeletonCollider

Class TGLVerletSkeletonCollider

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletSkeletonCollider = class(TGLSkeletonCollider)

Description

Base Verlet Skeleton Collider class.

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonCollider
  • TGLVerletSkeletonCollider

Overview

Fields

Private FVerletConstraint: TGLVerletConstraint;

Methods

Public | procedure AddToVerletWorld(VerletWorld: TGLVerletWorld); virtual;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Properties

Public property VerletConstraint: TGLVerletConstraint read FVerletConstraint;

Description

Fields

Private FVerletConstraint: TGLVerletConstraint;

This item has no description.

Methods

Public procedure AddToVerletWorld(VerletWorld: TGLVerletWorld); virtual;

This item has no description.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property VerletConstraint: TGLVerletConstraint read FVerletConstraint;

The verlet constraint is created through the AddToVerletWorld procedure


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletSphere

Class TGLVerletSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletSphere = class(TGLVerletSkeletonCollider)

Description

Sphere shaped verlet constraint in a skeleton collider

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonCollider
  • TGLVerletSkeletonCollider
  • TGLVerletSphere

Overview

Fields

Private FRadius: Single;

Methods

Public | constructor Create; override;
Public | procedure AddToVerletWorld(VerletWorld: TGLVerletWorld); override;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Properties

Public property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FRadius: Single;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToVerletWorld(VerletWorld: TGLVerletWorld); override;

This item has no description.

Public procedure AlignCollider; override;

This item has no description. Showing description inherited from TGLSkeletonCollider.AlignCollider.

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Radius: Single read FRadius write SetRadius;


GLSysHelp v.2.5: GLS.VerletTypes: Class TGLVerletCapsule

Class TGLVerletCapsule

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.VerletTypes

Declaration

type TGLVerletCapsule = class(TGLVerletSkeletonCollider)

Description

Capsule shaped verlet constraint in a skeleton collider

Hierarchy

  • TGLPersistentObject
  • TGLSkeletonCollider
  • TGLVerletSkeletonCollider
  • TGLVerletCapsule

Overview

Fields

Private | FRadius: Single;
Private | FLength: Single;

Methods

Public | constructor Create; override;
Public | procedure AddToVerletWorld(VerletWorld: TGLVerletWorld); override;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(Reader: TGLVirtualReader); override;
Public | procedure WriteToFiler(Writer: TGLVirtualWriter); override;

Properties

Public | property Length: Single read FLength write SetLength;
Public | property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FRadius: Single;

This item has no description.

Private FLength: Single;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToVerletWorld(VerletWorld: TGLVerletWorld); override;

This item has no description.

Public procedure AlignCollider; override;

This item has no description. Showing description inherited from TGLSkeletonCollider.AlignCollider.

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(Reader: TGLVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TGLVirtualWriter); override;

This item has no description.

Properties

Public property Length: Single read FLength write SetLength;

This item has no description.

Public property Radius: Single read FRadius write SetRadius;


GLSysHelp v.2.5: GLS.WaterPlane

Unit GLS.WaterPlane

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • Vcl.Graphics
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLS.Scene
  • GLS.VectorLists
  • GLS.PersistentClasses
  • GLS.BaseClasses
  • GLS.Context
  • GLS.RenderContextInfo
  • GLScene.VectorTypes
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWaterPlane |

Types

TGLWaterPlaneOption = (...);
TGLWaterPlaneOptions = set of TGLWaterPlaneOption;

Constants

cDefaultWaterPlaneOptions = [wpoTextured];

Description

Types

TGLWaterPlaneOption = (...);

This item has no description.

Values
  • wpoTextured
TGLWaterPlaneOptions = set of TGLWaterPlaneOption;

This item has no description.

Constants

cDefaultWaterPlaneOptions = [wpoTextured];


GLSysHelp v.2.5: GLS.WaterPlane: Class TGLWaterPlane

Class TGLWaterPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.WaterPlane

Declaration

type TGLWaterPlane = class(TGLSceneObject)

Description

This item has no description. Showing description inherited from TGLSceneObject.

Base class for standard scene objects. Publishes the Material property.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLWaterPlane

Overview

Fields

Private | FLocks: packed of ByteBool;
Private | FPositions: packed of Single;
Private | FVelocity: packed of Single;
Private | FPlaneQuadIndices: TGLPersistentObjectList;
Private | FPlaneQuadTexCoords: TGLTexPointList;
Private | FPlaneQuadVertices: TGLAffineVectorList;
Private | FPlaneQuadNormals: TGLAffineVectorList;
Private | FActive: Boolean;
Private | FRainTimeInterval: Integer;
Private | FRainForce: Single;
Private | FViscosity: Single;
Private | FElastic: Single;
Private | FResolution: Integer;
Private | FSimulationFrequency: Single;
Private | FTimeToNextUpdate: Single;
Private | FTimeToNextRainDrop: Single;
Private | FMaximumCatchupIterations: Integer;
Private | FLastIterationStepTime: Single;
Private | FMask: TPicture;
Private | FOptions: TGLWaterPlaneOptions;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TGLVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TGLRenderContextInfo); override;
Public | procedure CreateRippleAtGridPos(X, Y: Integer);
Public | procedure CreateRippleAtWorldPos(const pos: TGLVector); overload;
Public | procedure CreateRippleAtWorldPos(const X, Y, z: Single); overload;
Public | procedure CreateRippleRandom;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure Reset;

Properties

Published | property Active: Boolean read FActive write FActive default True;
Published | property Elastic: Single read FElastic write SetElastic;
Public | property LastIterationStepTime: Single read FLastIterationStepTime;
Published | property Mask: TPicture read FMask write SetMask;
Published | property MaximumCatchupIterations: Integer read FMaximumCatchupIterations write FMaximumCatchupIterations default 1;
Published | property Options: TGLWaterPlaneOptions read FOptions write SetOptions default cDefaultWaterPlaneOptions;
Published | property RainForce: Single read FRainForce write SetRainForce;
Published | property RainTimeInterval: Integer read FRainTimeInterval write SetRainTimeInterval default 500;
Published | property Resolution: Integer read FResolution write SetResolution default 64;
Published | property SimulationFrequency: Single read FSimulationFrequency write SetSimulationFrequency;
Published | property Viscosity: Single read FViscosity write SetViscosity;

Description

Fields

Private FLocks: packed of ByteBool;

This item has no description.

Private FPositions: packed of Single;

This item has no description.

Private FVelocity: packed of Single;

This item has no description.

Private FPlaneQuadIndices: TGLPersistentObjectList;

This item has no description.

Private FPlaneQuadTexCoords: TGLTexPointList;

This item has no description.

Private FPlaneQuadVertices: TGLAffineVectorList;

This item has no description.

Private FPlaneQuadNormals: TGLAffineVectorList;

This item has no description.

Private FActive: Boolean;

This item has no description.

Private FRainTimeInterval: Integer;

This item has no description.

Private FRainForce: Single;

This item has no description.

Private FViscosity: Single;

This item has no description.

Private FElastic: Single;

This item has no description.

Private FResolution: Integer;

This item has no description.

Private FSimulationFrequency: Single;

This item has no description.

Private FTimeToNextUpdate: Single;

This item has no description.

Private FTimeToNextRainDrop: Single;

This item has no description.

Private FMaximumCatchupIterations: Integer;

This item has no description.

Private FLastIterationStepTime: Single;

This item has no description.

Private FMask: TPicture;

This item has no description.

Private FOptions: TGLWaterPlaneOptions;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TGLVector; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TGLRenderContextInfo); override;

This item has no description. Showing description inherited from TGLBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure CreateRippleAtGridPos(X, Y: Integer);

This item has no description.

Public procedure CreateRippleAtWorldPos(const pos: TGLVector); overload;

This item has no description.

Public procedure CreateRippleAtWorldPos(const X, Y, z: Single); overload;

This item has no description.

Public procedure CreateRippleRandom;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure Reset;

This item has no description.

Properties

Published property Active: Boolean read FActive write FActive default True;

This item has no description.

Published property Elastic: Single read FElastic write SetElastic;

This item has no description.

Public property LastIterationStepTime: Single read FLastIterationStepTime;

CPU time (in seconds) taken by the last iteration step.

Published property Mask: TPicture read FMask write SetMask;

A picture whose pixels determine what part of the waterplane is active. Pixels with a green/gray component beyond 128 are active, the others are not (in short, white = active, black = inactive). The picture will automatically be stretched to match the resolution.

Published property MaximumCatchupIterations: Integer read FMaximumCatchupIterations write FMaximumCatchupIterations default 1;

Maximum number of simulation iterations during catchups. Catchups happen when for a reason or another, the DoProgress doesn't happen as fast SimulationFrequency.

Published property Options: TGLWaterPlaneOptions read FOptions write SetOptions default cDefaultWaterPlaneOptions;

This item has no description.

Published property RainForce: Single read FRainForce write SetRainForce;

This item has no description.

Published property RainTimeInterval: Integer read FRainTimeInterval write SetRainTimeInterval default 500;

Delay between raindrops in milliseconds (0 = no rain)

Published property Resolution: Integer read FResolution write SetResolution default 64;

This item has no description.

Published property SimulationFrequency: Single read FSimulationFrequency write SetSimulationFrequency;

Maximum frequency (in Hz) at which simulation iterations happen.

Published property Viscosity: Single read FViscosity write SetViscosity;


GLSysHelp v.2.5: GLS.Windows

Unit GLS.Windows

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.Math
  • Vcl.StdCtrls
  • Vcl.Controls
  • Vcl.Graphics
  • GLScene.OpenGLTokens
  • GLS.PersistentClasses
  • GLScene.Strings
  • GLS.Coordinates
  • GLScene.VectorTypes
  • GLS.Objects
  • GLS.State
  • GLScene.Utils
  • GLS.Scene
  • GLS.HudObjects
  • GLS.Material
  • GLS.Context
  • GLS.BitmapFont
  • GLS.WindowsFont
  • GLScene.VectorGeometry
  • GLS.Gui
  • GLS.Color
  • GLS.ImageUtils
  • GLS.Texture
  • GLS.RenderContextInfo
  • GLS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseComponent |
Class TGLBaseControl |
Class TGLBaseFontControl |
Class TGLBaseTextControl |
Class TGLFocusControl |
Class TGLCustomControl |
Class TGLPopupMenu |
Class TGLForm |
Class TGLPanel |
Class TGLCheckBox |
Class TGLButton |
Class TGLEdit |
Class TGLLabel |
Class TGLAdvancedLabel |
Class TGLScrollbar |
Class TGLStringGrid |

Functions and Procedures

function UnpressGroup(CurrentObject: TGLBaseSceneObject; AGroupID: Integer): Boolean;

Types

TGLAcceptMouseQuery = procedure(Sender: TGLBaseControl; Shift: TShiftState; Action: TGLMouseAction; Button: TMouseButton; X, Y: Integer; var Accept: boolean) of object;
TGLCustomRenderEvent = procedure(Sender: TGLCustomControl; Bitmap: TBitmap) of object;
TGLFormCanClose = procedure(Sender: TGLForm; var CanClose: TGLFormCloseOptions) of object;
TGLFormCanRequest = procedure(Sender: TGLForm; var Can: Boolean) of object;
TGLFormCloseOptions = (...);
TGLFormMove = procedure(Sender: TGLForm; var Left, Top: Single) of object;
TGLFormNotify = procedure(Sender: TGLForm) of object;
TGLMouseAction = (...);
TGLPopupMenuClick = procedure(Sender: TGLPopupMenu; index: Integer; const MenuItemText: string) of object;

Description

Functions and Procedures

function UnpressGroup(CurrentObject: TGLBaseSceneObject; AGroupID: Integer): Boolean;

This item has no description.

Types

TGLAcceptMouseQuery = procedure(Sender: TGLBaseControl; Shift: TShiftState; Action: TGLMouseAction; Button: TMouseButton; X, Y: Integer; var Accept: boolean) of object;

This item has no description.

TGLCustomRenderEvent = procedure(Sender: TGLCustomControl; Bitmap: TBitmap) of object;

This item has no description.

TGLFormCanClose = procedure(Sender: TGLForm; var CanClose: TGLFormCloseOptions) of object;

This item has no description.

TGLFormCanRequest = procedure(Sender: TGLForm; var Can: Boolean) of object;

This item has no description.

TGLFormCloseOptions = (...);

This item has no description.

Values
  • co_Hide
  • co_Ignore
  • co_Destroy
TGLFormMove = procedure(Sender: TGLForm; var Left, Top: Single) of object;

This item has no description.

TGLFormNotify = procedure(Sender: TGLForm) of object;

This item has no description.

TGLMouseAction = (...);

This item has no description.

Values
  • ma_mouseup
  • ma_mousedown
  • ma_mousemove
TGLPopupMenuClick = procedure(Sender: TGLPopupMenu; index: Integer; const MenuItemText: string) of object;


GLSysHelp v.2.5: GLS.Windows: Class TGLBaseComponent

Class TGLBaseComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLBaseComponent = class(TGLBaseGuiObject)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent

Overview

Fields

Private | FGUIRedraw: Boolean;
Private | FGuiLayout: TGLGuiLayout;
Private | FGuiLayoutName: TGLGuiComponentName;
Private | FGuiComponent: TGLGuiComponent;
Private | FReBuildGui: Boolean;
Private | FRedrawAtOnce: Boolean;
Private | MoveX: TGLFloat;
Private | MoveY: TGLFloat;
Private | FRenderStatus: TGUIDrawResult;
Private | FAlphaChannel: Single;
Private | FRotation: TGLFloat;
Private | FNoZWrite: Boolean;
Private | BlockRendering: Boolean;
Private | RenderingCount: Integer;
Private | BlockedCount: Integer;
Private | GuiDestroying: Boolean;
Private | FDoChangesOnProgress: Boolean;
Private | FAutosize: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BlockRender;
Public | procedure DoChanges; virtual;
Public | procedure DoProgress(const progressTime: TGLProgressTimes); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); virtual;
Public | procedure MoveGUI(XRel, YRel: Single);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure PlaceGUI(XPos, YPos: Single);
Public | procedure UnBlockRender;
Private | procedure SetAutosize(const Value: Boolean);
Private | procedure SetDoChangesOnProgress(const Value: Boolean);
Private | procedure SetGUIRedraw(value: Boolean);

Properties

Published | property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;
Published | property Autosize: Boolean read FAutosize write SetAutosize;
Published | property DoChangesOnProgress: Boolean read FDoChangesOnProgress write SetDoChangesOnProgress;
Published | property GuiLayout: TGLGuiLayout read FGuiLayout write SetGuiLayout;
Published | property GuiLayoutName: TGLGuiComponentName read FGuiLayoutName write SetGuiLayoutName;
Public | property GUIRedraw: Boolean read FGUIRedraw write SetGUIRedraw;
Published | property Height;
Published | property Left;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Published | property Position;
Public | property ReBuildGui: Boolean read FReBuildGui write FReBuildGui;
Published | property RedrawAtOnce: Boolean read FRedrawAtOnce write FRedrawAtOnce;
Published | property Rotation: TGLFloat read FRotation write SetRotation;
Published | property Top;
Published | property Visible;
Published | property Width;

Description

Fields

Private FGUIRedraw: Boolean;

This item has no description.

Private FGuiLayout: TGLGuiLayout;

This item has no description.

Private FGuiLayoutName: TGLGuiComponentName;

This item has no description.

Private FGuiComponent: TGLGuiComponent;

This item has no description.

Private FReBuildGui: Boolean;

This item has no description.

Private FRedrawAtOnce: Boolean;

This item has no description.

Private MoveX: TGLFloat;

This item has no description.

Private MoveY: TGLFloat;

This item has no description.

Private FRenderStatus: TGUIDrawResult;

This item has no description.

Private FAlphaChannel: Single;

This item has no description.

Private FRotation: TGLFloat;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Private BlockRendering: Boolean;

This item has no description.

Private RenderingCount: Integer;

This item has no description.

Private BlockedCount: Integer;

This item has no description.

Private GuiDestroying: Boolean;

This item has no description.

Private FDoChangesOnProgress: Boolean;

This item has no description.

Private FAutosize: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BlockRender;

This item has no description.

Public procedure DoChanges; virtual;

This item has no description.

Public procedure DoProgress(const progressTime: TGLProgressTimes); override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); virtual;

This item has no description.

Public procedure MoveGUI(XRel, YRel: Single);

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure PlaceGUI(XPos, YPos: Single);

This item has no description.

Public procedure UnBlockRender;

This item has no description.

Private procedure SetAutosize(const Value: Boolean);

This item has no description.

Private procedure SetDoChangesOnProgress(const Value: Boolean);

This item has no description.

Private procedure SetGUIRedraw(value: Boolean);

This item has no description.

Properties

Published property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;

If different from 1, this value will replace that of Diffuse.Alpha

Published property Autosize: Boolean read FAutosize write SetAutosize;

This item has no description.

Published property DoChangesOnProgress: Boolean read FDoChangesOnProgress write SetDoChangesOnProgress;

This item has no description.

Published property GuiLayout: TGLGuiLayout read FGuiLayout write SetGuiLayout;

This item has no description.

Published property GuiLayoutName: TGLGuiComponentName read FGuiLayoutName write SetGuiLayoutName;

This item has no description.

Public property GUIRedraw: Boolean read FGUIRedraw write SetGUIRedraw;

This item has no description.

Published property Height;

This item has no description. Showing description inherited from TGLBaseGuiObject.Height.

GuiComponent Height in 3D world units.

Published property Left;

This item has no description. Showing description inherited from TGLBaseGuiObject.Left.

GuiComponent Left in 3D world units.

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;

If True, GuiComponent will not write to Z-Buffer. GuiComponent will be maskable by ZBuffer test STILL.

Published property Position;

This item has no description.

Public property ReBuildGui: Boolean read FReBuildGui write FReBuildGui;

This item has no description.

Published property RedrawAtOnce: Boolean read FRedrawAtOnce write FRedrawAtOnce;

This item has no description.

Published property Rotation: TGLFloat read FRotation write SetRotation;

This the ON-SCREEN rotation of the GuiComponent. Rotatation=0 is handled faster.

Published property Top;

This item has no description. Showing description inherited from TGLBaseGuiObject.Top.

GuiComponent Top in 3D world units.

Published property Visible;

This item has no description.

Published property Width;

This item has no description. Showing description inherited from TGLBaseGuiObject.Width.

GuiComponent Width in 3D world units.


GLSysHelp v.2.5: GLS.Windows: Class TGLBaseControl

Class TGLBaseControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLBaseControl = class(TGLBaseComponent)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl

Overview

Fields

Private | FOnMouseDown: TMouseEvent;
Private | FOnMouseMove: TMouseMoveEvent;
Private | FOnMouseUp: TMouseEvent;
Private | FKeepMouseEvents: Boolean;
Private | FActiveControl: TGLBaseControl;
Private | FFocusedControl: TGLFocusControl;
Private | FOnAcceptMouseQuery: TGLAcceptMouseQuery;
Private | FOnMouseLeave: TNotifyEvent;
Private | FOnMouseEnter: TNotifyEvent;
Private | FEnteredControl: TGLBaseControl;

Methods

Public | function MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public | function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public | procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;
Public | procedure KeyPress(Sender: TObject; var Key: Char); virtual;
Public | procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;

Properties

Public | property ActiveControl: TGLBaseControl read FActiveControl write SetActiveControl;
Published | property FocusedControl: TGLFocusControl read FFocusedControl write SetFocusedControl;
Public | property KeepMouseEvents: Boolean read FKeepMouseEvents write FKeepMouseEvents default false;
Published | property OnAcceptMouseQuery: TGLAcceptMouseQuery read FOnAcceptMouseQuery write FOnAcceptMouseQuery;
Published | property OnMouseDown: TMouseEvent read FOnMouseDown write FOnMouseDown;
Published | property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published | property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published | property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;
Published | property OnMouseUp: TMouseEvent read FOnMouseUp write FOnMouseUp;

Description

Fields

Private FOnMouseDown: TMouseEvent;

This item has no description.

Private FOnMouseMove: TMouseMoveEvent;

This item has no description.

Private FOnMouseUp: TMouseEvent;

This item has no description.

Private FKeepMouseEvents: Boolean;

This item has no description.

Private FActiveControl: TGLBaseControl;

This item has no description.

Private FFocusedControl: TGLFocusControl;

This item has no description.

Private FOnAcceptMouseQuery: TGLAcceptMouseQuery;

This item has no description.

Private FOnMouseLeave: TNotifyEvent;

This item has no description.

Private FOnMouseEnter: TNotifyEvent;

This item has no description.

Private FEnteredControl: TGLBaseControl;

This item has no description.

Methods

Public function MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;

This item has no description.

Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; virtual;

This item has no description.

Public function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;

This item has no description.

Public procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;

This item has no description.

Public procedure KeyPress(Sender: TObject; var Key: Char); virtual;

This item has no description.

Public procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;

This item has no description.

Properties

Public property ActiveControl: TGLBaseControl read FActiveControl write SetActiveControl;

This item has no description.

Published property FocusedControl: TGLFocusControl read FFocusedControl write SetFocusedControl;

This item has no description.

Public property KeepMouseEvents: Boolean read FKeepMouseEvents write FKeepMouseEvents default false;

This item has no description.

Published property OnAcceptMouseQuery: TGLAcceptMouseQuery read FOnAcceptMouseQuery write FOnAcceptMouseQuery;

This item has no description.

Published property OnMouseDown: TMouseEvent read FOnMouseDown write FOnMouseDown;

This item has no description.

Published property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;

This item has no description.

Published property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;

This item has no description.

Published property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;

This item has no description.

Published property OnMouseUp: TMouseEvent read FOnMouseUp write FOnMouseUp;


GLSysHelp v.2.5: GLS.Windows: Class TGLBaseFontControl

Class TGLBaseFontControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLBaseFontControl = class(TGLBaseControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl

Overview

Fields

Private | FBitmapFont: TGLCustomBitmapFont;
Private | FDefaultColor: TGLColorVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property BitmapFont: TGLCustomBitmapFont read GetBitmapFont write SetBitmapFont;
Published | property DefaultColor: TColor read GetDefaultColor write SetDefaultColor;

Description

Fields

Private FBitmapFont: TGLCustomBitmapFont;

This item has no description.

Private FDefaultColor: TGLColorVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Properties

Published property BitmapFont: TGLCustomBitmapFont read GetBitmapFont write SetBitmapFont;

This item has no description.

Published property DefaultColor: TColor read GetDefaultColor write SetDefaultColor;


GLSysHelp v.2.5: GLS.Windows: Class TGLBaseTextControl

Class TGLBaseTextControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLBaseTextControl = class(TGLBaseFontControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl

Overview

Fields

Private FCaption: UnicodeString;

Properties

Published property Caption: UnicodeString read FCaption write SetCaption;

Description

Fields

Private FCaption: UnicodeString;

This item has no description.

Properties

Published property Caption: UnicodeString read FCaption write SetCaption;


GLSysHelp v.2.5: GLS.Windows: Class TGLFocusControl

Class TGLFocusControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLFocusControl = class(TGLBaseTextControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl

Overview

Fields

Private | FRootControl: TGLBaseControl;
Private | FFocused: Boolean;
Private | FOnKeyDown: TKeyEvent;
Private | FOnKeyUp: TKeyEvent;
Private | FOnKeyPress: TKeyPressEvent;
Private | FShiftState: TShiftState;
Private | FFocusedColor: TGLColorVector;

Methods

Public | destructor Destroy; override;
Public | procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); override;
Public | procedure KeyPress(Sender: TObject; var Key: Char); override;
Public | procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); override;
Public | procedure MoveTo(newParent: TGLBaseSceneObject); override;
Public | procedure NextControl;
Public | procedure NotifyHide; override;
Public | procedure PrevControl;
Public | procedure ReGetRootControl;
Public | procedure SetFocus;

Properties

Published | property Focused: Boolean read FFocused write SetFocused;
Published | property FocusedColor: TColor read GetFocusedColor write SetFocusedColor;
Published | property OnKeyDown: TKeyEvent read FOnKeyDown write FOnKeyDown;
Published | property OnKeyPress: TKeyPressEvent read FOnKeyPress write FOnKeyPress;
Published | property OnKeyUp: TKeyEvent read FOnKeyUp write FOnKeyUp;
Published | property RootControl: TGLBaseControl read GetRootControl;

Description

Fields

Private FRootControl: TGLBaseControl;

This item has no description.

Private FFocused: Boolean;

This item has no description.

Private FOnKeyDown: TKeyEvent;

This item has no description.

Private FOnKeyUp: TKeyEvent;

This item has no description.

Private FOnKeyPress: TKeyPressEvent;

This item has no description.

Private FShiftState: TShiftState;

This item has no description.

Private FFocusedColor: TGLColorVector;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); override;

This item has no description.

Public procedure KeyPress(Sender: TObject; var Key: Char); override;

This item has no description.

Public procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); override;

This item has no description.

Public procedure MoveTo(newParent: TGLBaseSceneObject); override;

This item has no description.

Public procedure NextControl;

This item has no description.

Public procedure NotifyHide; override;

This item has no description.

Public procedure PrevControl;

This item has no description.

Public procedure ReGetRootControl;

This item has no description.

Public procedure SetFocus;

This item has no description.

Properties

Published property Focused: Boolean read FFocused write SetFocused;

This item has no description.

Published property FocusedColor: TColor read GetFocusedColor write SetFocusedColor;

This item has no description.

Published property OnKeyDown: TKeyEvent read FOnKeyDown write FOnKeyDown;

This item has no description.

Published property OnKeyPress: TKeyPressEvent read FOnKeyPress write FOnKeyPress;

This item has no description.

Published property OnKeyUp: TKeyEvent read FOnKeyUp write FOnKeyUp;

This item has no description.

Published property RootControl: TGLBaseControl read GetRootControl;


GLSysHelp v.2.5: GLS.Windows: Class TGLCustomControl

Class TGLCustomControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLCustomControl = class(TGLFocusControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLCustomControl

Overview

Fields

Private | FCustomData: Pointer;
Private | FCustomObject: TObject;
Private | FOnRender: TGLCustomRenderEvent;
Private | FMaterial: TGLMaterial;
Private | FBitmap: TBitmap;
Private | FInternalBitmap: TBitmap;
Private | FBitmapChanged: Boolean;
Private | FXTexCoord: Single;
Private | FYTexCoord: Single;
Private | FInvalidRenderCount: Integer;
Private | FMaxInvalidRenderCount: Integer;
Private | FCentered: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure SetMaterial(AMaterial: TGLMaterial);
Private | procedure SetCentered(const Value: Boolean);

Properties

Published | property Bitmap: TBitmap read FBitmap write SetBitmap;
Published | property Centered: Boolean read FCentered write SetCentered;
Public | property CustomData: Pointer read FCustomData write FCustomData;
Public | property CustomObject: TObject read FCustomObject write FCustomObject;
Published | property Material: TGLMaterial read FMaterial write SetMaterial;
Published | property MaxInvalidRenderCount: Integer read FMaxInvalidRenderCount write FMaxInvalidRenderCount;
Published | property OnRender: TGLCustomRenderEvent read FOnRender write FOnRender;

Description

Fields

Private FCustomData: Pointer;

This item has no description.

Private FCustomObject: TObject;

This item has no description.

Private FOnRender: TGLCustomRenderEvent;

This item has no description.

Private FMaterial: TGLMaterial;

This item has no description.

Private FBitmap: TBitmap;

This item has no description.

Private FInternalBitmap: TBitmap;

This item has no description.

Private FBitmapChanged: Boolean;

This item has no description.

Private FXTexCoord: Single;

This item has no description.

Private FYTexCoord: Single;

This item has no description.

Private FInvalidRenderCount: Integer;

This item has no description.

Private FMaxInvalidRenderCount: Integer;

This item has no description.

Private FCentered: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure SetMaterial(AMaterial: TGLMaterial);

This item has no description.

Private procedure SetCentered(const Value: Boolean);

This item has no description.

Properties

Published property Bitmap: TBitmap read FBitmap write SetBitmap;

This item has no description.

Published property Centered: Boolean read FCentered write SetCentered;

This item has no description.

Public property CustomData: Pointer read FCustomData write FCustomData;

This item has no description.

Public property CustomObject: TObject read FCustomObject write FCustomObject;

This item has no description.

Published property Material: TGLMaterial read FMaterial write SetMaterial;

This item has no description.

Published property MaxInvalidRenderCount: Integer read FMaxInvalidRenderCount write FMaxInvalidRenderCount;

This item has no description.

Published property OnRender: TGLCustomRenderEvent read FOnRender write FOnRender;


GLSysHelp v.2.5: GLS.Windows: Class TGLPopupMenu

Class TGLPopupMenu

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLPopupMenu = class(TGLFocusControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLPopupMenu

Overview

Fields

Private | FOnClick: TGLPopupMenuClick;
Private | FMenuItems: TStrings;
Private | FSelIndex: Integer;
Private | FMarginSize: Single;
Private | NewHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure PopUp(Px, Py: Integer);

Properties

Published | property MarginSize: Single read FMarginSize write SetMarginSize;
Published | property MenuItems: TStrings read FMenuItems write SetMenuItems;
Published | property OnClick: TGLPopupMenuClick read FOnClick write FOnClick;
Published | property SelIndex: Integer read FSelIndex write SetSelIndex;

Description

Fields

Private FOnClick: TGLPopupMenuClick;

This item has no description.

Private FMenuItems: TStrings;

This item has no description.

Private FSelIndex: Integer;

This item has no description.

Private FMarginSize: Single;

This item has no description.

Private NewHeight: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure PopUp(Px, Py: Integer);

This item has no description.

Properties

Published property MarginSize: Single read FMarginSize write SetMarginSize;

This item has no description.

Published property MenuItems: TStrings read FMenuItems write SetMenuItems;

This item has no description.

Published property OnClick: TGLPopupMenuClick read FOnClick write FOnClick;

This item has no description.

Published property SelIndex: Integer read FSelIndex write SetSelIndex;


GLSysHelp v.2.5: GLS.Windows: Class TGLForm

Class TGLForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLForm = class(TGLBaseTextControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLForm

Overview

Fields

Private | FOnCanMove: TGLFormCanRequest;
Private | FOnCanResize: TGLFormCanRequest;
Private | FOnCanClose: TGLFormCanClose;
Private | FOnShow: TGLFormNotify;
Private | FOnHide: TGLFormNotify;
Private | FOnMoving: TGLFormMove;
Private | Moving: Boolean;
Private | OldX: Integer;
Private | OldY: Integer;
Private | FTitleColor: TGLColorVector;
Private | FTitleOffset: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | procedure Close;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure NotifyHide; override;
Public | procedure NotifyShow; override;

Properties

Published | property OnCanClose: TGLFormCanClose read FOnCanClose write FOnCanClose;
Published | property OnCanMove: TGLFormCanRequest read FOnCanMove write FOnCanMove;
Published | property OnCanResize: TGLFormCanRequest read FOnCanResize write FOnCanResize;
Published | property OnHide: TGLFormNotify read FOnHide write FOnHide;
Published | property OnMoving: TGLFormMove read FOnMoving write FOnMoving;
Published | property OnShow: TGLFormNotify read FOnShow write FOnShow;
Published | property TitleColor: TColor read GetTitleColor write SetTitleColor;
Published | property TitleOffset: Single read FTitleOffset write FTitleOffset;

Description

Fields

Private FOnCanMove: TGLFormCanRequest;

This item has no description.

Private FOnCanResize: TGLFormCanRequest;

This item has no description.

Private FOnCanClose: TGLFormCanClose;

This item has no description.

Private FOnShow: TGLFormNotify;

This item has no description.

Private FOnHide: TGLFormNotify;

This item has no description.

Private FOnMoving: TGLFormMove;

This item has no description.

Private Moving: Boolean;

This item has no description.

Private OldX: Integer;

This item has no description.

Private OldY: Integer;

This item has no description.

Private FTitleColor: TGLColorVector;

This item has no description.

Private FTitleOffset: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public procedure Close;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure NotifyHide; override;

This item has no description.

Public procedure NotifyShow; override;

This item has no description.

Properties

Published property OnCanClose: TGLFormCanClose read FOnCanClose write FOnCanClose;

This item has no description.

Published property OnCanMove: TGLFormCanRequest read FOnCanMove write FOnCanMove;

This item has no description.

Published property OnCanResize: TGLFormCanRequest read FOnCanResize write FOnCanResize;

This item has no description.

Published property OnHide: TGLFormNotify read FOnHide write FOnHide;

This item has no description.

Published property OnMoving: TGLFormMove read FOnMoving write FOnMoving;

This item has no description.

Published property OnShow: TGLFormNotify read FOnShow write FOnShow;

This item has no description.

Published property TitleColor: TColor read GetTitleColor write SetTitleColor;

This item has no description.

Published property TitleOffset: Single read FTitleOffset write FTitleOffset;


GLSysHelp v.2.5: GLS.Windows: Class TGLPanel

Class TGLPanel

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLPanel = class(TGLBaseControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLPanel


GLSysHelp v.2.5: GLS.Windows: Class TGLCheckBox

Class TGLCheckBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLCheckBox = class(TGLBaseControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLCheckBox

Overview

Fields

Private | FChecked: Boolean;
Private | FOnChange: TNotifyEvent;
Private | FGuiLayoutNameChecked: TGLGuiComponentName;
Private | FGuiCheckedComponent: TGLGuiComponent;
Private | FGroup: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Checked: Boolean read FChecked write SetChecked;
Published | property Group: Integer read FGroup write SetGroup;
Published | property GuiLayoutNameChecked: TGLGuiComponentName read FGuiLayoutNameChecked write SetGuiLayoutNameChecked;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Private FChecked: Boolean;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private FGuiLayoutNameChecked: TGLGuiComponentName;

This item has no description.

Private FGuiCheckedComponent: TGLGuiComponent;

This item has no description.

Private FGroup: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property Checked: Boolean read FChecked write SetChecked;

This item has no description.

Published property Group: Integer read FGroup write SetGroup;

This item has no description.

Published property GuiLayoutNameChecked: TGLGuiComponentName read FGuiLayoutNameChecked write SetGuiLayoutNameChecked;

This item has no description.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange;


GLSysHelp v.2.5: GLS.Windows: Class TGLButton

Class TGLButton

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLButton = class(TGLFocusControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLButton

Overview

Fields

Private | FPressed: Boolean;
Private | FOnButtonClick: TNotifyEvent;
Private | FGuiLayoutNamePressed: TGLGuiComponentName;
Private | FGuiPressedComponent: TGLGuiComponent;
Private | FBitBtn: TGLMaterial;
Private | FGroup: Integer;
Private | FLogicWidth: Single;
Private | FLogicHeight: Single;
Private | FXOffSet: Single;
Private | FYOffSet: Single;
Private | FAllowUp: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property AllowUp: Boolean read FAllowUp write FAllowUp;
Published | property BitBtn: TGLMaterial read FBitBtn write SetBitBtn;
Published | property Group: Integer read FGroup write SetGroup;
Published | property GuiLayoutNamePressed: TGLGuiComponentName read FGuiLayoutNamePressed write SetGuiLayoutNamePressed;
Published | property LogicHeight: Single read FLogicHeight write SetLogicHeight;
Published | property LogicWidth: Single read FLogicWidth write SetLogicWidth;
Published | property OnButtonClick: TNotifyEvent read FOnButtonClick write FOnButtonClick;
Published | property Pressed: Boolean read FPressed write SetPressed;
Published | property XOffset: Single read FXOffset write SetXOffset;
Published | property YOffset: Single read FYOffset write SetYOffset;

Description

Fields

Private FPressed: Boolean;

This item has no description.

Private FOnButtonClick: TNotifyEvent;

This item has no description.

Private FGuiLayoutNamePressed: TGLGuiComponentName;

This item has no description.

Private FGuiPressedComponent: TGLGuiComponent;

This item has no description.

Private FBitBtn: TGLMaterial;

This item has no description.

Private FGroup: Integer;

This item has no description.

Private FLogicWidth: Single;

This item has no description.

Private FLogicHeight: Single;

This item has no description.

Private FXOffSet: Single;

This item has no description.

Private FYOffSet: Single;

This item has no description.

Private FAllowUp: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property AllowUp: Boolean read FAllowUp write FAllowUp;

This item has no description.

Published property BitBtn: TGLMaterial read FBitBtn write SetBitBtn;

This item has no description.

Published property Group: Integer read FGroup write SetGroup;

This item has no description.

Published property GuiLayoutNamePressed: TGLGuiComponentName read FGuiLayoutNamePressed write SetGuiLayoutNamePressed;

This item has no description.

Published property LogicHeight: Single read FLogicHeight write SetLogicHeight;

This item has no description.

Published property LogicWidth: Single read FLogicWidth write SetLogicWidth;

This item has no description.

Published property OnButtonClick: TNotifyEvent read FOnButtonClick write FOnButtonClick;

This item has no description.

Published property Pressed: Boolean read FPressed write SetPressed;

This item has no description.

Published property XOffset: Single read FXOffset write SetXOffset;

This item has no description.

Published property YOffset: Single read FYOffset write SetYOffset;


GLSysHelp v.2.5: GLS.Windows: Class TGLEdit

Class TGLEdit

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLEdit = class(TGLFocusControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLEdit

Overview

Fields

Private | FOnChange: TNotifyEvent;
Private | FSelStart: Integer;
Private | FReadOnly: Boolean;
Private | FEditChar: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property EditChar: string read FEditChar write SetEditChar;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property ReadOnly: Boolean read FReadOnly write FReadOnly default False;
Published | property SelStart: Integer read FSelStart write SetSelStart;

Description

Fields

Private FOnChange: TNotifyEvent;

This item has no description.

Private FSelStart: Integer;

This item has no description.

Private FReadOnly: Boolean;

This item has no description.

Private FEditChar: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property EditChar: string read FEditChar write SetEditChar;

This item has no description.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange;

This item has no description.

Published property ReadOnly: Boolean read FReadOnly write FReadOnly default False;

This item has no description.

Published property SelStart: Integer read FSelStart write SetSelStart;


GLSysHelp v.2.5: GLS.Windows: Class TGLLabel

Class TGLLabel

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLLabel = class(TGLBaseTextControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLLabel

Overview

Fields

Private | FAlignment: TAlignment;
Private | FTextLayout: TTextLayout;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Private | procedure SetAlignment(const Value: TAlignment);
Private | procedure SetTextLayout(const Value: TTextLayout);

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment;
Published | property TextLayout: TTextLayout read FTextLayout write SetTextLayout;

Description

Fields

Private FAlignment: TAlignment;

This item has no description.

Private FTextLayout: TTextLayout;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Private procedure SetAlignment(const Value: TAlignment);

This item has no description.

Private procedure SetTextLayout(const Value: TTextLayout);

This item has no description.

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment;

This item has no description.

Published property TextLayout: TTextLayout read FTextLayout write SetTextLayout;


GLSysHelp v.2.5: GLS.Windows: Class TGLAdvancedLabel

Class TGLAdvancedLabel

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLAdvancedLabel = class(TGLFocusControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLAdvancedLabel

Overview

Methods

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;


GLSysHelp v.2.5: GLS.Windows: Class TGLScrollbar

Class TGLScrollbar

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLScrollbar = class(TGLFocusControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLScrollbar

Overview

Fields

Private | FMin: Single;
Private | FMax: Single;
Private | FStep: Single;
Private | FPos: Single;
Private | FPageSize: Single;
Private | FOnChange: TNotifyEvent;
Private | FGuiLayoutKnobName: TGLGuiComponentName;
Private | FGuiKnobComponent: TGLGuiComponent;
Private | FKnobRenderStatus: TGUIDrawResult;
Private | FScrollOffs: Single;
Private | FScrolling: Boolean;
Private | FHorizontal: Boolean;
Private | FLocked: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure PageDown;
Public | procedure PageUp;
Public | procedure StepDown;
Public | procedure StepUp;

Properties

Published | property GuiLayoutKnobName: TGLGuiComponentName read FGuiLayoutKnobName write SetGuiLayoutKnobName;
Published | property Horizontal: Boolean read FHorizontal write SetHorizontal;
Published | property Locked: Boolean read FLocked write FLocked default False;
Published | property Max: Single read FMax write SetMax;
Published | property Min: Single read FMin write SetMin;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property PageSize: Single read FPageSize write SetPageSize;
Published | property Pos: Single read FPos write SetPos;
Published | property Step: Single read FStep write FStep;

Description

Fields

Private FMin: Single;

This item has no description.

Private FMax: Single;

This item has no description.

Private FStep: Single;

This item has no description.

Private FPos: Single;

This item has no description.

Private FPageSize: Single;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private FGuiLayoutKnobName: TGLGuiComponentName;

This item has no description.

Private FGuiKnobComponent: TGLGuiComponent;

This item has no description.

Private FKnobRenderStatus: TGUIDrawResult;

This item has no description.

Private FScrollOffs: Single;

This item has no description.

Private FScrolling: Boolean;

This item has no description.

Private FHorizontal: Boolean;

This item has no description.

Private FLocked: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure PageDown;

This item has no description.

Public procedure PageUp;

This item has no description.

Public procedure StepDown;

This item has no description.

Public procedure StepUp;

This item has no description.

Properties

Published property GuiLayoutKnobName: TGLGuiComponentName read FGuiLayoutKnobName write SetGuiLayoutKnobName;

This item has no description.

Published property Horizontal: Boolean read FHorizontal write SetHorizontal;

This item has no description.

Published property Locked: Boolean read FLocked write FLocked default False;

This item has no description.

Published property Max: Single read FMax write SetMax;

This item has no description.

Published property Min: Single read FMin write SetMin;

This item has no description.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange;

This item has no description.

Published property PageSize: Single read FPageSize write SetPageSize;

This item has no description.

Published property Pos: Single read FPos write SetPos;

This item has no description.

Published property Step: Single read FStep write FStep;


GLSysHelp v.2.5: GLS.Windows: Class TGLStringGrid

Class TGLStringGrid

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.Windows

Declaration

type TGLStringGrid = class(TGLFocusControl)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLStringGrid

Overview

Fields

Private | FSelCol: Integer;
Private | FSelRow: Integer;
Private | FRowSelect: Boolean;
Private | FColSelect: Boolean;
Private | FColumns: TStrings;
Private | FRows: TList;
Private | FHeaderColor: TGLColorVector;
Private | FMarginSize: Integer;
Private | FColumnSize: Integer;
Private | FRowHeight: Integer;
Private | FScrollbar: TGLScrollbar;
Private | FDrawHeader: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Add(const Data: string): Integer; overload;
Public | function Add(const Data: array of string): Integer; overload;
Public | procedure Clear;
Public | procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure OnStringListChange(Sender: TObject);
Public | procedure SetText(Data: string);

Properties

Published | property ColSelect: Boolean read FColSelect write SetColSelect;
Published | property Columns: TStrings read FColumns write SetColumns;
Published | property ColumnSize: Integer read FColumnSize write SetColumnSize;
Published | property DrawHeader: Boolean read FDrawHeader write SetDrawHeader;
Published | property HeaderColor: TColor read GetHeaderColor write SetHeaderColor;
Published | property MarginSize: Integer read FMarginSize write SetMarginSize;
Public | property Row[index: Integer]: TStringList read GetRow write SetRow;
Published | property RowCount: Integer read GetRowCount write SetRowCount;
Published | property RowHeight: Integer read FRowHeight write SetRowHeight;
Published | property RowSelect: Boolean read FRowSelect write SetRowSelect;
Published | property Scrollbar: TGLScrollbar read FScrollbar write SetScrollbar;
Published | property SelCol: Integer read FSelCol write SetSelCol;
Published | property SelRow: Integer read FSelRow write SetSelRow;

Description

Fields

Private FSelCol: Integer;

This item has no description.

Private FSelRow: Integer;

This item has no description.

Private FRowSelect: Boolean;

This item has no description.

Private FColSelect: Boolean;

This item has no description.

Private FColumns: TStrings;

This item has no description.

Private FRows: TList;

This item has no description.

Private FHeaderColor: TGLColorVector;

This item has no description.

Private FMarginSize: Integer;

This item has no description.

Private FColumnSize: Integer;

This item has no description.

Private FRowHeight: Integer;

This item has no description.

Private FScrollbar: TGLScrollbar;

This item has no description.

Private FDrawHeader: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add(const Data: string): Integer; overload;

This item has no description.

Public function Add(const Data: array of string): Integer; overload;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure InternalRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure OnStringListChange(Sender: TObject);

This item has no description.

Public procedure SetText(Data: string);

This item has no description.

Properties

Published property ColSelect: Boolean read FColSelect write SetColSelect;

This item has no description.

Published property Columns: TStrings read FColumns write SetColumns;

This item has no description.

Published property ColumnSize: Integer read FColumnSize write SetColumnSize;

This item has no description.

Published property DrawHeader: Boolean read FDrawHeader write SetDrawHeader;

This item has no description.

Published property HeaderColor: TColor read GetHeaderColor write SetHeaderColor;

This item has no description.

Published property MarginSize: Integer read FMarginSize write SetMarginSize;

This item has no description.

Public property Row[index: Integer]: TStringList read GetRow write SetRow;

This item has no description.

Published property RowCount: Integer read GetRowCount write SetRowCount;

This item has no description.

Published property RowHeight: Integer read FRowHeight write SetRowHeight;

This item has no description.

Published property RowSelect: Boolean read FRowSelect write SetRowSelect;

This item has no description.

Published property Scrollbar: TGLScrollbar read FScrollbar write SetScrollbar;

This item has no description.

Published property SelCol: Integer read FSelCol write SetSelCol;

This item has no description.

Published property SelRow: Integer read FSelRow write SetSelRow;


GLSysHelp v.2.5: GLS.WindowsContext

Unit GLS.WindowsContext

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • Winapi.Messages
  • System.SysUtils
  • System.Classes
  • Vcl.Forms
  • GLScene.VectorTypes
  • GLScene.OpenGLTokens
  • GLS.OpenGLAdapter
  • GLScene.PipelineTransform
  • GLS.Context
  • GLS.State
  • GLScene.Logger
  • GLScene.Strings
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWindowsContext |

Functions and Procedures

function CreateTempWnd: NativeUInt;

Variables

vUseWindowTrackingHook: Boolean = True;

Description

Functions and Procedures

function CreateTempWnd: NativeUInt;

This item has no description.

Variables

vUseWindowTrackingHook: Boolean = True;

This boolean controls a hook-based tracking of top-level forms destruction, with the purpose of being able to properly release OpenGL contexts before they are (improperly) released by some drivers upon top-level form destruction


GLSysHelp v.2.5: GLS.WindowsContext: Class TGLWindowsContext

Class TGLWindowsContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.WindowsContext

Declaration

type TGLWindowsContext = class(TGLContext)

Description

A context driver for standard Windows OpenGL (via MS OpenGL).

Hierarchy

  • TObject
  • TGLContext
  • TGLWindowsContext

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; override;
Public | function RenderOutputDevice: Pointer; override;
Public | procedure SwapBuffers; override;

Properties

Public | property DC: NativeUInt read FDC;
Public | property RC: NativeUInt read FRC;

Description

Methods

Public constructor Create; override;

DoGetHandles must be implemented in child classes, and return the display+window

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean; override;

This item has no description. Showing description inherited from TGLContext.IsValid.

Returns true if the context is valid. A context is valid from the time it has been successfully created to the time of its destruction.

Public function RenderOutputDevice: Pointer; override;

This item has no description.

Public procedure SwapBuffers; override;

This item has no description. Showing description inherited from TGLContext.SwapBuffers.

Request to swap front and back buffers if they were defined

Properties

Public property DC: NativeUInt read FDC;

This item has no description.

Public property RC: NativeUInt read FRC;


GLSysHelp v.2.5: GLS.WindowsFont

Unit GLS.WindowsFont

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.Classes
  • System.Math
  • System.SysUtils
  • System.Types
  • System.UITypes
  • VCL.Graphics
  • GLS.Scene
  • GLS.Texture
  • GLS.BitmapFont
  • GLS.RenderContextInfo
  • GLS.VectorLists
  • GLScene.Utils
  • GLScene.VectorGeometry
  • GLScene.OpenGLTokens
  • GLS.ApplicationFileIO
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWindowsBitmapFont |


GLSysHelp v.2.5: GLS.WindowsFont: Class TGLWindowsBitmapFont

Class TGLWindowsBitmapFont

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.WindowsFont

Declaration

type TGLWindowsBitmapFont = class(TGLCustomBitmapFont)

Description

A bitmap font automatically built from a TFont. It works like a TGLBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders in GLScene as close to that font as posible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations. Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLCustomBitmapFont
  • TGLWindowsBitmapFont

Overview

Fields

Private FFont: TFont;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FontTextureHeight: Integer;
Public | function FontTextureWidth: Integer;
Public | procedure EnsureChars(const AStart, AEnd: widechar);
Public | procedure EnsureString(const s : String); overload;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure SetList(const AList : TGLIntegerList);

Properties

Published | property Font: TFont read FFont write SetFont;
Public | property Glyphs;
Published | property HSpace;
Published | property MagFilter;
Published | property MinFilter;
Published | property Ranges stored StoreRanges;
Published | property VSpace;

Description

Fields

Private FFont: TFont;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FontTextureHeight: Integer;

This item has no description.

Public function FontTextureWidth: Integer;

This item has no description.

Public procedure EnsureChars(const AStart, AEnd: widechar);

This item has no description.

Public procedure EnsureString(const s : String); overload;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure SetList(const AList : TGLIntegerList);

This item has no description.

Properties

Published property Font: TFont read FFont write SetFont;

The font used to prepare the texture. Note: the font color is ignored.

Public property Glyphs;

This item has no description.

Published property HSpace;

This item has no description.

Published property MagFilter;

This item has no description.

Published property MinFilter;

This item has no description.

Published property Ranges stored StoreRanges;

This item has no description.

Published property VSpace;


GLSysHelp v.2.5: GLS.XCollectionRegister

Unit GLS.XCollectionRegister

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.XCollection
  • DesignEditors
  • DesignIntf

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TXCollectionProperty |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GLSysHelp v.2.5: GLS.XCollectionRegister: Class TXCollectionProperty

Class TXCollectionProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.XCollectionRegister

Declaration

type TXCollectionProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TClassProperty
  • TXCollectionProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GLSysHelp v.2.5: GLS.XOpenGL

Unit GLS.XOpenGL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGLext
  • GLScene.VectorTypes
  • GLScene.OpenGLTokens
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMultitextureCoordinator |

Types

TMapTexCoordMode = (...);

Description

Types

TMapTexCoordMode = (...);

This item has no description.

Values
  • mtcmUndefined
  • mtcmNull
  • mtcmMain
  • mtcmDual
  • mtcmSecond
  • mtcmArbitrary


GLSysHelp v.2.5: GLS.XOpenGL: Class TGLMultitextureCoordinator

Class TGLMultitextureCoordinator

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.XOpenGL

Declaration

type TGLMultitextureCoordinator = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLMultitextureCoordinator

Overview

Fields

Private | FMapTexCoordMode: TMapTexCoordMode;
Private | FSecondTextureUnitForbidden: Boolean;
Private | FUpdCount: Integer;
Private | FUpdNewMode: TMapTexCoordMode;
Private | FStateStack: array of TMapTexCoordMode;
Private | FComplexMapping: array of Cardinal;
Private | FComplexMappingN: Integer;
Public | TexCoord2f: procedure(s, t: TGLfloat); stdcall;
Public | TexCoord2fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;
Public | TexCoord3fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;
Public | TexCoord4fv: procedure(v: PGLfloat); stdcall;
Public | TexGenf: procedure(coord, pname: Cardinal; param: TGLfloat); stdcall;
Public | TexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;
Public | TexGeni: procedure(coord, pname: Cardinal; param: TGLint); stdcall;
Public | TexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;
Public | TexCoordPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall;
Public | EnableClientState: procedure(aarray: Cardinal); stdcall;
Public | DisableClientState: procedure(aarray: Cardinal); stdcall;
Public | Enable: procedure(cap: Cardinal); stdcall;
Public | Disable: procedure(cap: Cardinal); stdcall;

Methods

Public | constructor Create;
Public | function GetBitWiseMapping: Cardinal;
Public | procedure AllowSecondTextureUnit;
Public | procedure BeginUpdate; inline;
Public | procedure EndUpdate; inline;
Public | procedure ForbidSecondTextureUnit;
Public | procedure MapTexCoordToArbitrary(const bitWiseUnits: Cardinal); overload;
Public | procedure MapTexCoordToArbitrary(const units: array of Cardinal); overload;
Public | procedure MapTexCoordToArbitraryAdd(const bitWiseUnits: Cardinal);
Public | procedure MapTexCoordToDual;
Public | procedure MapTexCoordToMain;
Public | procedure MapTexCoordToNull;
Public | procedure MapTexCoordToSecond;
Public | procedure PopState;
Public | procedure PushState;

Properties

Public | property MapTexCoordMode: TMapTexCoordMode read FMapTexCoordMode write FMapTexCoordMode;
Public | property SecondTextureUnitForbidden: Boolean read FSecondTextureUnitForbidden;

Description

Fields

Private FMapTexCoordMode: TMapTexCoordMode;

This item has no description.

Private FSecondTextureUnitForbidden: Boolean;

This item has no description.

Private FUpdCount: Integer;

This item has no description.

Private FUpdNewMode: TMapTexCoordMode;

This item has no description.

Private FStateStack: array of TMapTexCoordMode;

This item has no description.

Private FComplexMapping: array of Cardinal;

This item has no description.

Private FComplexMappingN: Integer;

This item has no description.

Public TexCoord2f: procedure(s, t: TGLfloat); stdcall;

Explicit texture coordinates specification

Public TexCoord2fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;

This item has no description.

Public TexCoord3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;

This item has no description.

Public TexCoord4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexGenf: procedure(coord, pname: Cardinal; param: TGLfloat); stdcall;

TexGen texture coordinates specification

Public TexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public TexGeni: procedure(coord, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public TexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public TexCoordPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall;

Vertex Arrays texture coordinates specification

Public EnableClientState: procedure(aarray: Cardinal); stdcall;

This item has no description.

Public DisableClientState: procedure(aarray: Cardinal); stdcall;

This item has no description.

Public Enable: procedure(cap: Cardinal); stdcall;

Misc

Public Disable: procedure(cap: Cardinal); stdcall;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public function GetBitWiseMapping: Cardinal;

Returns the complex mapping in bitwise form.

Public procedure AllowSecondTextureUnit;

Allow XOpenGL to use the second texture unit again.

Public procedure BeginUpdate; inline;

Defers Map calls execution until EndUpdate is met. Calls to Begin/EndUpdate may be nested.

Public procedure EndUpdate; inline;

Applies Map calls if there were any since BeginUpdate was invoked. Calls to Begin/EndUpdate may be nested.

Public procedure ForbidSecondTextureUnit;

Whenever called, 2nd texture units changes will be forbidden to . Use this function when you're using the 2nd texture unit for your own purposes and don't want XOpenGL to alter it.

Public procedure MapTexCoordToArbitrary(const bitWiseUnits: Cardinal); overload;

This item has no description.

Public procedure MapTexCoordToArbitrary(const units: array of Cardinal); overload;

TexCoord functions will define the specified texture units coordinates.

Public procedure MapTexCoordToArbitraryAdd(const bitWiseUnits: Cardinal);

This item has no description.

Public procedure MapTexCoordToDual;

TexCoord functions will define the two first texture units coordinates.

Public procedure MapTexCoordToMain;

TexCoord functions will define the main texture coordinates.

Public procedure MapTexCoordToNull;

TexCoord functions will be ignored.

Public procedure MapTexCoordToSecond;

TexCoord functions will define the second texture unit coordinates.

Public procedure PopState;

Restores XOpenGL State from the stack.

Public procedure PushState;

Saves XOpenGL State on the stack.

Properties

Public property MapTexCoordMode: TMapTexCoordMode read FMapTexCoordMode write FMapTexCoordMode;

This item has no description.

Public property SecondTextureUnitForbidden: Boolean read FSecondTextureUnitForbidden;


GLSysHelp v.2.5: GLS.zBuffer

Unit GLS.zBuffer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLScene.TextureFormat
  • GLScene.VectorTypes
  • GLS.XOpenGL
  • GLS.Scene
  • GLS.Graphics
  • GLS.Objects
  • GLS.Context
  • GLS.SceneViewer
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.State
  • GLS.Coordinates
  • GLS.PersistentClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EZBufferException |
Class TGLzBuffer |
Class TGLZShadows |

Types

PAArray = ˆTAArray;
PZArray = ˆTZArray;
TAArray = array[0..MaxInt shr 3] of Byte;
TAArrayIdx = array of PAArray;
TOptimise = (...);
TZArray = array[0..MaxInt shr 3] of Single;
TZArrayIdx = array of PZArray;

Description

Types

PAArray = ˆTAArray;

This item has no description.

PZArray = ˆTZArray;

This item has no description.

TAArray = array[0..MaxInt shr 3] of Byte;

This item has no description.

TAArrayIdx = array of PAArray;

This item has no description.

TOptimise = (...);

This item has no description.

Values
  • opNone
  • op4in1
  • op9in1
  • op16in1
TZArray = array[0..MaxInt shr 3] of Single;

This item has no description.

TZArrayIdx = array of PZArray;


GLSysHelp v.2.5: GLS.zBuffer: Class EZBufferException

Class EZBufferException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.zBuffer

Declaration

type EZBufferException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EZBufferException


GLSysHelp v.2.5: GLS.zBuffer: Class TGLzBuffer

Class TGLzBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.zBuffer

Declaration

type TGLzBuffer = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TGLzBuffer

Overview

Fields

Private | FData: PZArray;
Private | FDataIdx: TZArrayIdx;
Private | FDataInvIdx: TZArrayIdx;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FDataSize: Integer;
Private | Ang1: single;
Private | Ang2: single;
Private | Scal: single;
Private | C1: single;
Private | S1: single;
Private | C2: single;
Private | S2: single;
Private | Vw: single;
Private | Vh: single;
Private | Lt: TAffineVector;
Private | Rt: TAffineVector;
Private | Lb: TAffineVector;
Private | Rb: TAffineVector;
Private | UpVec: TAffineVector;
Private | RiVec: TAffineVector;
Private | LtW: TAffineVector;
Private | RtW: TAffineVector;
Private | LbW: TAffineVector;
Private | RbW: TAffineVector;
Private | UpVecW: TAffineVector;
Private | RiVecW: TAffineVector;
Private | OrthInvDov: single;
Private | OrthAddX: single;
Private | OrthMulX: single;
Private | OrthAddY: single;
Private | OrthMulY: single;
Private | Dov: single;
Private | Np: single;
Private | Fp: single;
Private | NpFp: single;
Private | OneMinNp_Fp: single;
Private | InvOneMinNp_Fp: single;
Private | Cam: TGLCamera;
Public | SceneViewer: TGLSceneViewer;
Public | MemoryViewer: TGLMemoryViewer;
Public | Buffer: TGLSceneBuffer;
Public | Normal: TAffineVector;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function FastScreenToVector(x, y: Integer): TAffineVector;
Public | function FastVectorToScreen(const vec: TAffineVector): TAffineVector;
Public | function GetDepthBuffer(CalcVectors: Boolean; ContextIsActive: boolean): PZArray;
Public | function GetPixelzDepth(x, y: integer): Single;
Public | function OrthWorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean;
Public | function PixelToDistance(x, y: integer): Single;
Public | function PixelToDistance_OLD(x, y: integer): Single;
Public | function PixelToWorld(const x, y: Integer): TAffineVector;
Public | function WorldToPixel(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean;
Public | function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean; overload;
Public | function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean; overload;
Public | procedure LinkToViewer(viewer: TGLMemoryViewer); overload;
Public | procedure LinkToViewer(viewer: TGLSceneViewer); overload;
Public | procedure Refresh;
Private | procedure DoCalcVectors;

Properties

Public | property Data: PZArray read FData;
Public | property DataIdx: TZArrayIdx read FDataIdx;
Public | property DataInvIdx: TZArrayIdx read FDataIdx;
Public | property DataSize: Integer read FDataSize;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Width: Integer read FWidth write SetWidth;

Description

Fields

Private FData: PZArray;

This item has no description.

Private FDataIdx: TZArrayIdx;

This item has no description.

Private FDataInvIdx: TZArrayIdx;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FDataSize: Integer;

This item has no description.

Private Ang1: single;

VectorToScreen variables;

Private Ang2: single;

VectorToScreen variables;

Private Scal: single;

VectorToScreen variables;

Private C1: single;

VectorToScreen variables;

Private S1: single;

VectorToScreen variables;

Private C2: single;

VectorToScreen variables;

Private S2: single;

VectorToScreen variables;

Private Vw: single;

VectorToScreen variables;

Private Vh: single;

VectorToScreen variables;

Private Lt: TAffineVector;

ScreenToVector corner vectors;

Private Rt: TAffineVector;

ScreenToVector corner vectors;

Private Lb: TAffineVector;

ScreenToVector corner vectors;

Private Rb: TAffineVector;

ScreenToVector corner vectors;

Private UpVec: TAffineVector;

This item has no description.

Private RiVec: TAffineVector;

This item has no description.

Private LtW: TAffineVector;

ScreenToVector corner vectors;(Warped)

Private RtW: TAffineVector;

ScreenToVector corner vectors;(Warped)

Private LbW: TAffineVector;

ScreenToVector corner vectors;(Warped)

Private RbW: TAffineVector;

ScreenToVector corner vectors;(Warped)

Private UpVecW: TAffineVector;

This item has no description.

Private RiVecW: TAffineVector;

This item has no description.

Private OrthInvDov: single;

This item has no description.

Private OrthAddX: single;

This item has no description.

Private OrthMulX: single;

This item has no description.

Private OrthAddY: single;

This item has no description.

Private OrthMulY: single;

This item has no description.

Private Dov: single;

Calc Variables;

Private Np: single;

Calc Variables;

Private Fp: single;

Calc Variables;

Private NpFp: single;

Calc Variables;

Private OneMinNp_Fp: single;

Calc Variables;

Private InvOneMinNp_Fp: single;

Calc Variables;

Private Cam: TGLCamera;

This item has no description.

Public SceneViewer: TGLSceneViewer;

This item has no description.

Public MemoryViewer: TGLMemoryViewer;

This item has no description.

Public Buffer: TGLSceneBuffer;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Methods

Public constructor Create;

Absolute direction of camera

Public destructor Destroy; override;

This item has no description.

Public function FastScreenToVector(x, y: Integer): TAffineVector;

This item has no description.

Public function FastVectorToScreen(const vec: TAffineVector): TAffineVector;

This item has no description.

Public function GetDepthBuffer(CalcVectors: Boolean; ContextIsActive: boolean): PZArray;

This item has no description.

Public function GetPixelzDepth(x, y: integer): Single;

This item has no description.

Public function OrthWorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean;

This item has no description.

Public function PixelToDistance(x, y: integer): Single;

This item has no description.

Public function PixelToDistance_OLD(x, y: integer): Single;

This item has no description.

Public function PixelToWorld(const x, y: Integer): TAffineVector;

This item has no description.

Public function WorldToPixel(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean;

This item has no description.

Public function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean; overload;

This item has no description.

Public function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean; overload;

This item has no description.

Public procedure LinkToViewer(viewer: TGLMemoryViewer); overload;

This item has no description.

Public procedure LinkToViewer(viewer: TGLSceneViewer); overload;

This item has no description.

Public procedure Refresh;

This item has no description.

Private procedure DoCalcVectors;

This item has no description.

Properties

Public property Data: PZArray read FData;

This item has no description.

Public property DataIdx: TZArrayIdx read FDataIdx;

This item has no description.

Public property DataInvIdx: TZArrayIdx read FDataIdx;

This item has no description.

Public property DataSize: Integer read FDataSize;

This item has no description.

Public property Height: Integer read FHeight write SetHeight;

This item has no description.

Public property Width: Integer read FWidth write SetWidth;


GLSysHelp v.2.5: GLS.zBuffer: Class TGLZShadows

Class TGLZShadows

Description
Hierarchy
Fields
Methods
Properties

Unit

GLS.zBuffer

Declaration

type TGLZShadows = class(TGLBaseSceneObject)

Description

This item has no description. Showing description inherited from TGLBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLZShadows

Overview

Fields

Private | FViewer: TGLSceneViewer;
Private | FCaster: TGLMemoryViewer;
Private | FDepthFade: Boolean;
Private | FFrustShadow: Boolean;
Private | FSkyShadow: Boolean;
Private | FOptimise: TOptimise;
Private | FData: PAArray;
Private | FDataIdx: TAArrayIdx;
Private | FDataInvIdx: TAArrayIdx;
Private | FDataSize: Integer;
Private | FWidth: integer;
Private | FHeight: integer;
Private | FXRes: integer;
Private | FYRes: integer;
Private | Fsoft: boolean;
Private | FTolerance: single;
Private | FColor: TGLColor;
Private | SCol: TGLPixel32;
Private | FTexturePrepared: Boolean;
Private | FTexHandle: TGLTextureHandle;
Public | ViewerZBuf: TGLzBuffer;
Public | CasterZBuf: TGLzBuffer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Published | function CastShadow: boolean;
Public | procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Caster: TGLMemoryViewer read GetCaster write SetCaster;
Published | property Color: TGLColor read FColor write FColor;
Published | property DepthFade: Boolean read FDepthFade write FDepthFade;
Published | property FrustShadow: Boolean read FFrustShadow write FFrustShadow;
Published | property Height: integer read FHeight write SetHeight;
Published | property ObjectsSorting;
Published | property Optimise: TOptimise read FOptimise write FOptimise;
Published | property SkyShadow: Boolean read FSkyShadow write FSkyShadow;
Published | property Soft: Boolean read Fsoft write SetSoft;
Published | property Tolerance: single read FTolerance write FTolerance;
Published | property Viewer: TGLSceneViewer read GetViewer write SetViewer;
Published | property Visible;
Published | property Width: integer read FWidth write SetWidth;

Description

Fields

Private FViewer: TGLSceneViewer;

This item has no description.

Private FCaster: TGLMemoryViewer;

This item has no description.

Private FDepthFade: Boolean;

This item has no description.

Private FFrustShadow: Boolean;

This item has no description.

Private FSkyShadow: Boolean;

This item has no description.

Private FOptimise: TOptimise;

This item has no description.

Private FData: PAArray;

This item has no description.

Private FDataIdx: TAArrayIdx;

This item has no description.

Private FDataInvIdx: TAArrayIdx;

This item has no description.

Private FDataSize: Integer;

This item has no description.

Private FWidth: integer;

This item has no description.

Private FHeight: integer;

This item has no description.

Private FXRes: integer;

This item has no description.

Private FYRes: integer;

This item has no description.

Private Fsoft: boolean;

This item has no description.

Private FTolerance: single;

This item has no description.

Private FColor: TGLColor;

This item has no description.

Private SCol: TGLPixel32;

This item has no description.

Private FTexturePrepared: Boolean;

stepX, stepY :single;

Private FTexHandle: TGLTextureHandle;

This item has no description.

Public ViewerZBuf: TGLzBuffer;

This item has no description.

Public CasterZBuf: TGLzBuffer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Published function CastShadow: boolean;

This item has no description.

Public procedure DoRender(var ARci: TGLRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Caster: TGLMemoryViewer read GetCaster write SetCaster;

This item has no description.

Published property Color: TGLColor read FColor write FColor;

This item has no description.

Published property DepthFade: Boolean read FDepthFade write FDepthFade;

This item has no description.

Published property FrustShadow: Boolean read FFrustShadow write FFrustShadow;

This item has no description.

Published property Height: integer read FHeight write SetHeight;

This item has no description.

Published property ObjectsSorting;

property Material;

Published property Optimise: TOptimise read FOptimise write FOptimise;

This item has no description.

Published property SkyShadow: Boolean read FSkyShadow write FSkyShadow;

This item has no description.

Published property Soft: Boolean read Fsoft write SetSoft;

property Xres :integer read FXRes write SetXRes;// default 64; property Yres :integer read FYRes write SetYRes;// default 64;

Published property Tolerance: single read FTolerance write FTolerance;

This item has no description.

Published property Viewer: TGLSceneViewer read GetViewer write SetViewer;

This item has no description.

Published property Visible;

This item has no description.

Published property Width: integer read FWidth write SetWidth;


GLSysHelp v.2.5: GLScene.AnimationUtils

Unit GLScene.AnimationUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Functions and Procedures

function Tweener(Current, Target: TAffineVector; Time, Duration: Single; EaseType: TEaseType): TAffineVector; overload;
function Tweener(Current, Target: TGLVector; Time, Duration: Single; EaseType: TEaseType): TGLVector; overload;
function Tweener(Current, Target: TVector2f; Time, Duration: Single; EaseType: TEaseType): TVector2f; overload;
function Tweener(Current, Target: Single; Time, Duration: Single; EaseType: TEaseType): Single; overload;

Types

TEaseType = (...);

Description

Functions and Procedures

function Tweener(Current, Target: TAffineVector; Time, Duration: Single; EaseType: TEaseType): TAffineVector; overload;

This item has no description.

function Tweener(Current, Target: TGLVector; Time, Duration: Single; EaseType: TEaseType): TGLVector; overload;

This item has no description.

function Tweener(Current, Target: TVector2f; Time, Duration: Single; EaseType: TEaseType): TVector2f; overload;

This item has no description.

function Tweener(Current, Target: Single; Time, Duration: Single; EaseType: TEaseType): Single; overload;

This item has no description.

Types

TEaseType = (...);

This item has no description.

Values
  • etLinear
  • etQuadIn
  • etQuadOut
  • etQuadInOut
  • etQuadOutIn
  • etCubicIn
  • etCubicOut
  • etCubicInOut
  • etCubicOutIn
  • etQuintIn
  • etQuintOut
  • etQuintInOut
  • etQuintOutIn
  • etSineIn
  • etSineOut
  • etSineInOut
  • etSineOutIn
  • etCircIn
  • etCircOut
  • etCircInOut
  • etCircOutIn
  • etExpoIn
  • etExpoOut
  • etExpoInOut
  • etExpoOutIn
  • etElasticIn
  • etElasticOut
  • etElasticInOut
  • etElasticOutIn
  • etBackIn
  • etBackOut
  • etBackInOut
  • etBackOutIn
  • etBounceIn
  • etBounceOut
  • etBounceInOut
  • etBounceOutIn


GLSysHelp v.2.5: GLScene.GeometryBB

Unit GLScene.GeometryBB

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record THmgBoundingBox |
Record TAABB |
Record TBSphere |
Record TGClipRect |

Functions and Procedures

function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2: THmgBoundingBox): Boolean; overload;
function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2: PHmgBoundingBox): Boolean; overload;
function AddBB(var C1: THmgBoundingBox; const C2: THmgBoundingBox): THmgBoundingBox;
procedure AddAABB(var Aabb: TAABB; const Aabb1: TAABB);
procedure SetBB(var C: THmgBoundingBox; const V: TGLVector);
procedure SetAABB(var Bb: TAABB; const V: TGLVector); inline;
procedure BBTransform(var C: THmgBoundingBox; const M: TGLMatrix);
procedure AABBTransform(var Bb: TAABB; const M: TGLMatrix);
procedure AABBScale(var Bb: TAABB; const V: TAffineVector);
function BBMinX(const C: THmgBoundingBox): Single;
function BBMaxX(const C: THmgBoundingBox): Single;
function BBMinY(const C: THmgBoundingBox): Single;
function BBMaxY(const C: THmgBoundingBox): Single;
function BBMinZ(const C: THmgBoundingBox): Single;
function BBMaxZ(const C: THmgBoundingBox): Single;
procedure AABBInclude(var Bb: TAABB; const P: TAffineVector);
procedure AABBFromSweep(var SweepAABB: TAABB; const Start, Dest: TGLVector; const Radius: Single);
function AABBIntersection(const Aabb1, Aabb2: TAABB): TAABB;
function BBToAABB(const ABB: THmgBoundingBox): TAABB;
function AABBToBB(const AnAABB: TAABB): THmgBoundingBox; overload;
function AABBToBB(const AnAABB: TAABB; const M: TGLMatrix): THmgBoundingBox; overload;
procedure OffsetAABB(var Aabb: TAABB; const Delta: TAffineVector); overload;
procedure OffsetAABB(var Aabb: TAABB; const Delta: TGLVector); overload;
procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TAffineVector); overload;
procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TGLVector); overload;
procedure OffsetBBPoint(var Bb: THmgBoundingBox; const Delta: TGLVector); overload;
function IntersectAABBs(const Aabb1, Aabb2: TAABB; const M1To2, M2To1: TGLMatrix): Boolean; overload;
function IntersectAABBsAbsoluteXY(const Aabb1, Aabb2: TAABB): Boolean;
function IntersectAABBsAbsoluteXZ(const Aabb1, Aabb2: TAABB): Boolean;
function IntersectAABBsAbsolute(const Aabb1, Aabb2: TAABB): Boolean;
function AABBFitsInAABBAbsolute(const Aabb1, Aabb2: TAABB): Boolean;
function PointInAABB(const P: TAffineVector; const Aabb: TAABB): Boolean; overload;
function PointInAABB(const P: TGLVector; const Aabb: TAABB): Boolean; overload;
function PlaneIntersectAABB(const Normal: TAffineVector; D: Single; const Aabb: TAABB): Boolean;
function PlaneAABBIntersection(const plane : THmgPlane; const AABB : TAABB) : TGLAffineVectorList;
function TriangleIntersectAABB(const Aabb: TAABB; const V1, V2, V3: TAffineVector): Boolean;
procedure ExtractAABBCorners(const AABB: TAABB; var AABBCorners: TAABBCorners);
procedure AABBToBSphere(const AABB: TAABB; var BSphere: TBSphere);
procedure BSphereToAABB(const BSphere: TBSphere; var AABB: TAABB); overload;
function BSphereToAABB(const Center: TAffineVector; Radius: Single): TAABB; overload;
function BSphereToAABB(const Center: TGLVector; Radius: Single): TAABB; overload;
function AABBContainsAABB(const MainAABB, TestAABB: TAABB): TSpaceContains;
function BSphereContainsAABB(const MainBSphere: TBSphere; const TestAABB: TAABB): TSpaceContains;
function BSphereContainsBSphere(const MainBSphere, TestBSphere: TBSphere): TSpaceContains;
function AABBContainsBSphere(const MainAABB: TAABB; const TestBSphere: TBSphere): TSpaceContains;
function PlaneContainsBSphere(const Location, Normal: TAffineVector; const TestBSphere: TBSphere): TSpaceContains;
function FrustumContainsBSphere(const Frustum: TFrustum; const TestBSphere: TBSphere): TSpaceContains;
function FrustumContainsAABB(const Frustum: TFrustum; const TestAABB: TAABB): TSpaceContains;
function ClipToAABB(const V: TAffineVector; const AABB: TAABB): TAffineVector;
function BSphereIntersectsBSphere(const MainBSphere, TestBSphere: TBSphere): Boolean;
procedure IncludeInClipRect(var ClipRect: TGClipRect; X, Y: Single);
function AABBToClipRect(const Aabb: TAABB; const ModelViewProjection: TGLMatrix; ViewportSizeX, ViewportSizeY: Integer): TGClipRect;
function RayCastAABBIntersect(const RayOrigin, RayDirection: TGLVector; const Aabb: TAABB; out TNear, TFar: Single): Boolean; overload;
function RayCastAABBIntersect(const RayOrigin, RayDirection: TGLVector; const Aabb: TAABB; IntersectPoint: PGLVector = nil): Boolean; overload;

Types

PAABB = ˆTAABB;
PHmgBoundingBox = ˆTHmgBoundingBox;
TAABBCorners = array [0 .. 7] of TAffineVector;
TDirPlan = array [0 .. 5] of Integer;
TPlanBB = array [0 .. 5] of TPlanIndices;
TPlanIndices = array [0 .. 3] of Integer;
TSpaceContains = (...);

Constants

NullBoundingBox: THmgBoundingBox = (BBox:((X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1)));
CBBFront: TPlanIndices = (0, 1, 2, 3);
CBBBack: TPlanIndices = (4, 5, 6, 7);
CBBLeft: TPlanIndices = (0, 4, 7, 3);
CBBRight: TPlanIndices = (1, 5, 6, 2);
CBBTop: TPlanIndices = (0, 1, 5, 4);
CBBBottom: TPlanIndices = (2, 3, 7, 6);
CBBPlans: TPlanBB = ((0, 1, 2, 3), (4, 5, 6, 7), (0, 4, 7, 3), (1, 5, 6, 2), (0, 1, 5, 4), (2, 3, 7, 6));
CDirPlan: TDirPlan = (0, 0, 1, 1, 2, 2);

Description

Functions and Procedures

function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2: THmgBoundingBox): Boolean; overload;

—————————————————————————— Bounding Box functions ——————————————————————————

function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2: PHmgBoundingBox): Boolean; overload;

This item has no description.

function AddBB(var C1: THmgBoundingBox; const C2: THmgBoundingBox): THmgBoundingBox;

Adds a BB into another BB. The original BB (c1) is extended if necessary to contain c2.

procedure AddAABB(var Aabb: TAABB; const Aabb1: TAABB);

This item has no description.

procedure SetBB(var C: THmgBoundingBox; const V: TGLVector);

This item has no description.

procedure SetAABB(var Bb: TAABB; const V: TGLVector); inline;

This item has no description.

procedure BBTransform(var C: THmgBoundingBox; const M: TGLMatrix);

This item has no description.

procedure AABBTransform(var Bb: TAABB; const M: TGLMatrix);

This item has no description.

procedure AABBScale(var Bb: TAABB; const V: TAffineVector);

This item has no description.

function BBMinX(const C: THmgBoundingBox): Single;

This item has no description.

function BBMaxX(const C: THmgBoundingBox): Single;

This item has no description.

function BBMinY(const C: THmgBoundingBox): Single;

This item has no description.

function BBMaxY(const C: THmgBoundingBox): Single;

This item has no description.

function BBMinZ(const C: THmgBoundingBox): Single;

This item has no description.

function BBMaxZ(const C: THmgBoundingBox): Single;

This item has no description.

procedure AABBInclude(var Bb: TAABB; const P: TAffineVector);

Resize the AABB if necessary to include p.

procedure AABBFromSweep(var SweepAABB: TAABB; const Start, Dest: TGLVector; const Radius: Single);

Make an AABB that is formed by sweeping a sphere (or AABB) from Start to Dest

function AABBIntersection(const Aabb1, Aabb2: TAABB): TAABB;

Returns the intersection AABB of two AABBs. If the AABBs don't intersect, will return a degenerated AABB (plane, line or point).

function BBToAABB(const ABB: THmgBoundingBox): TAABB;

Extract AABB information from a BB.

function AABBToBB(const AnAABB: TAABB): THmgBoundingBox; overload;

Converts an AABB to its canonical BB.

function AABBToBB(const AnAABB: TAABB; const M: TGLMatrix): THmgBoundingBox; overload;

Transforms an AABB to a BB.

procedure OffsetAABB(var Aabb: TAABB; const Delta: TAffineVector); overload;

Adds delta to min and max of the AABB.

procedure OffsetAABB(var Aabb: TAABB; const Delta: TGLVector); overload;

This item has no description.

procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TAffineVector); overload;

Adds delta to min and max of the BB.

procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TGLVector); overload;

This item has no description.

procedure OffsetBBPoint(var Bb: THmgBoundingBox; const Delta: TGLVector); overload;

The same as above but uses AddPoint() instead of AddVector().

function IntersectAABBs(const Aabb1, Aabb2: TAABB; const M1To2, M2To1: TGLMatrix): Boolean; overload;

Determines if two AxisAlignedBoundingBoxes intersect. The matrices are the ones that convert one point to the other's AABB system

function IntersectAABBsAbsoluteXY(const Aabb1, Aabb2: TAABB): Boolean;

Checks whether two Bounding boxes aligned with the world axes collide in the XY plane.

function IntersectAABBsAbsoluteXZ(const Aabb1, Aabb2: TAABB): Boolean;

Checks whether two Bounding boxes aligned with the world axes collide in the XZ plane.

function IntersectAABBsAbsolute(const Aabb1, Aabb2: TAABB): Boolean;

Checks whether two Bounding boxes aligned with the world axes collide.

function AABBFitsInAABBAbsolute(const Aabb1, Aabb2: TAABB): Boolean;

Checks whether one Bounding box aligned with the world axes fits within another Bounding box

function PointInAABB(const P: TAffineVector; const Aabb: TAABB): Boolean; overload;

Checks if a point "p" is inside an AABB

function PointInAABB(const P: TGLVector; const Aabb: TAABB): Boolean; overload;

This item has no description.

function PlaneIntersectAABB(const Normal: TAffineVector; D: Single; const Aabb: TAABB): Boolean;

Checks if a plane (given by the normal+d) intersects the AABB

function PlaneAABBIntersection(const plane : THmgPlane; const AABB : TAABB) : TGLAffineVectorList;

Compute the intersection between a plane and the AABB

function TriangleIntersectAABB(const Aabb: TAABB; const V1, V2, V3: TAffineVector): Boolean;

Original source code by Tomas Akenine-Mцller Based on the paper "Fast 3D Triangle-Box Overlap Testing" http://www.cs.lth.se/home/Tomas_Akenine_Moller/pubs/tribox.pdf http://jgt.akpeters.com/papers/AkenineMoller01/ (code) Use separating axis theorem to test overlap between triangle and box need to test for overlap in these directions: 1) the (x,y,z)-directions (actually, since we use the AABB of the triangle we do not even need to test these) 2) normal of the triangle 3) crossproduct(edge from tri, {x,y,z}-directin) this gives 3x3=9 more tests Checks if a triangle (given by vertices v1, v2 and v3) intersects an AABB

procedure ExtractAABBCorners(const AABB: TAABB; var AABBCorners: TAABBCorners);

Extract the corners from an AABB

procedure AABBToBSphere(const AABB: TAABB; var BSphere: TBSphere);

Convert an AABB to a BSphere

procedure BSphereToAABB(const BSphere: TBSphere; var AABB: TAABB); overload;

Convert a BSphere to an AABB

function BSphereToAABB(const Center: TAffineVector; Radius: Single): TAABB; overload;

This item has no description.

function BSphereToAABB(const Center: TGLVector; Radius: Single): TAABB; overload;

This item has no description.

function AABBContainsAABB(const MainAABB, TestAABB: TAABB): TSpaceContains;

Determines to which extent one AABB contains another AABB

function BSphereContainsAABB(const MainBSphere: TBSphere; const TestAABB: TAABB): TSpaceContains;

Determines to which extent a BSphere contains an AABB

function BSphereContainsBSphere(const MainBSphere, TestBSphere: TBSphere): TSpaceContains;

Determines to which extent one BSphere contains another BSphere

function AABBContainsBSphere(const MainAABB: TAABB; const TestBSphere: TBSphere): TSpaceContains;

Determines to which extent an AABB contains a BSpher

function PlaneContainsBSphere(const Location, Normal: TAffineVector; const TestBSphere: TBSphere): TSpaceContains;

Determines to which extent a plane contains a BSphere

function FrustumContainsBSphere(const Frustum: TFrustum; const TestBSphere: TBSphere): TSpaceContains;

Determines to which extent a frustum contains a BSphere

function FrustumContainsAABB(const Frustum: TFrustum; const TestAABB: TAABB): TSpaceContains;

Determines to which extent a frustum contains an AABB

function ClipToAABB(const V: TAffineVector; const AABB: TAABB): TAffineVector;

Clips a position to an AABB

function BSphereIntersectsBSphere(const MainBSphere, TestBSphere: TBSphere): Boolean;

Determines if one BSphere intersects another BSphere

procedure IncludeInClipRect(var ClipRect: TGClipRect; X, Y: Single);

Extend the clip rect to include given coordinate.

function AABBToClipRect(const Aabb: TAABB; const ModelViewProjection: TGLMatrix; ViewportSizeX, ViewportSizeY: Integer): TGClipRect;

Projects an AABB and determines the extent of its projection as a clip rect.

function RayCastAABBIntersect(const RayOrigin, RayDirection: TGLVector; const Aabb: TAABB; out TNear, TFar: Single): Boolean; overload;

Finds the intersection between a ray and an axis aligned bounding box.

function RayCastAABBIntersect(const RayOrigin, RayDirection: TGLVector; const Aabb: TAABB; IntersectPoint: PGLVector = nil): Boolean; overload;

This item has no description.

Types

PAABB = ˆTAABB;

This item has no description.

PHmgBoundingBox = ˆTHmgBoundingBox;

Structure for storing Bounding Boxes

TAABBCorners = array [0 .. 7] of TAffineVector;

Structure for storing the corners of an AABB, used with ExtractAABBCorners

TDirPlan = array [0 .. 5] of Integer;

This item has no description.

TPlanBB = array [0 .. 5] of TPlanIndices;

This item has no description.

TPlanIndices = array [0 .. 3] of Integer;

This item has no description.

TSpaceContains = (...);

Result type for space intersection tests, like AABBContainsAABB or BSphereContainsAABB

Values
  • ScNoOverlap
  • ScContainsFully
  • ScContainsPartially

Constants

NullBoundingBox: THmgBoundingBox = (BBox:((X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1)));

This item has no description.

CBBFront: TPlanIndices = (0, 1, 2, 3);

This item has no description.

CBBBack: TPlanIndices = (4, 5, 6, 7);

This item has no description.

CBBLeft: TPlanIndices = (0, 4, 7, 3);

This item has no description.

CBBRight: TPlanIndices = (1, 5, 6, 2);

This item has no description.

CBBTop: TPlanIndices = (0, 1, 5, 4);

This item has no description.

CBBBottom: TPlanIndices = (2, 3, 7, 6);

This item has no description.

CBBPlans: TPlanBB = ((0, 1, 2, 3), (4, 5, 6, 7), (0, 4, 7, 3), (1, 5, 6, 2), (0, 1, 5, 4), (2, 3, 7, 6));

This item has no description.

CDirPlan: TDirPlan = (0, 0, 1, 1, 2, 2);


GLSysHelp v.2.5: GLScene.GeometryBB: Record THmgBoundingBox

Record THmgBoundingBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.GeometryBB

Declaration

type THmgBoundingBox = record

Description

This item has no description.

Overview

Fields

Public BBox: array [0 .. 7] of TGLVector;

Description

Fields

Public BBox: array [0 .. 7] of TGLVector;


GLSysHelp v.2.5: GLScene.GeometryBB: Record TAABB

Record TAABB

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.GeometryBB

Declaration

type TAABB = record

Description

Structure for storing Axis Aligned Bounding Boxes

Overview

Fields

Public | Min: TAffineVector;
Public | Max: TAffineVector;

Description

Fields

Public Min: TAffineVector;

This item has no description.

Public Max: TAffineVector;


GLSysHelp v.2.5: GLScene.GeometryBB: Record TBSphere

Record TBSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.GeometryBB

Declaration

type TBSphere = record

Description

Structure for storing BoundingSpheres. Similar to TAABB

Overview

Fields

Public | Center: TAffineVector;
Public | Radius: Single;

Description

Fields

Public Center: TAffineVector;

Center of Bounding Sphere

Public Radius: Single;

Radius of Bounding Sphere


GLSysHelp v.2.5: GLScene.GeometryBB: Record TGClipRect

Record TGClipRect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.GeometryBB

Declaration

type TGClipRect = record

Description

This item has no description.

Overview

Fields

Public | Left: Single;
Public | Top: Single;
Public | Right: Single;
Public | Bottom: Single;

Description

Fields

Public Left: Single;

This item has no description.

Public Top: Single;

This item has no description.

Public Right: Single;

This item has no description.

Public Bottom: Single;


GLSysHelp v.2.5: GLScene.Keyboard

Unit GLScene.Keyboard

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.SysUtils

Overview

Functions and Procedures

function IsKeyDown(c: Char): Boolean; overload;
function IsKeyDown(vk: TVirtualKeyCode): Boolean; overload;
function KeyPressed(minVkCode: TVirtualKeyCode = 0): TVirtualKeyCode;
function VirtualKeyCodeToKeyName(vk: TVirtualKeyCode): String;
function KeyNameToVirtualKeyCode(const keyName: String): TVirtualKeyCode;
function CharToVirtualKeyCode(c: Char): TVirtualKeyCode;
procedure KeyboardNotifyWheelMoved(wheelDelta: Integer);

Types

TVirtualKeyCode = Integer;

Constants

VK_MOUSEWHEELUP = VK_F23;
VK_MOUSEWHEELDOWN = VK_F24;

Variables

vLastWheelDelta: Integer;

Description

Functions and Procedures

function IsKeyDown(c: Char): Boolean; overload;

Check if the key corresponding to the given Char is down. The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad. The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).

function IsKeyDown(vk: TVirtualKeyCode): Boolean; overload;

Check if the given virtual key is down. This function is just a wrapper for GetAsyncKeyState.

function KeyPressed(minVkCode: TVirtualKeyCode = 0): TVirtualKeyCode;

Returns the first pressed key whose virtual key code is >= to minVkCode. If no key is pressed, the return value is -1, this function does NOT wait for user input. If you don't care about multiple key presses, just don't use the parameter.

function VirtualKeyCodeToKeyName(vk: TVirtualKeyCode): String;

Converts a virtual key code to its name. The name is expressed using the locale windows options.

function KeyNameToVirtualKeyCode(const keyName: String): TVirtualKeyCode;

Converts a key name to its virtual key code. The comparison is **NOT** case-sensitive, if no match is found, returns -1. The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.

function CharToVirtualKeyCode(c: Char): TVirtualKeyCode;

Returns the virtual keycode corresponding to the given char. The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.

procedure KeyboardNotifyWheelMoved(wheelDelta: Integer);

Use this procedure to notify a wheel movement and have it resurfaced as key stroke. Honoured by IsKeyDown and KeyPressed

Types

TVirtualKeyCode = Integer;

This item has no description.

Constants

VK_MOUSEWHEELUP = VK_F23;

pseudo wheel keys (we squat F23/F24), see KeyboardNotifyWheelMoved

VK_MOUSEWHEELDOWN = VK_F24;

This item has no description.

Variables

vLastWheelDelta: Integer;


GLSysHelp v.2.5: GLScene.Logger

Unit GLScene.Logger

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • Winapi.ShellApi
  • System.StrUtils
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • System.SyncObjs

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TLogBufferFlushThread |
Class TLogCheckSizeThread |
Class TLogSession |
Class TGLSLogger |

Functions and Procedures

function UserLog: TLogSession;
function ReadLine(var TextFile: Text): string;
function GLSLogger(): TLogSession;
procedure UseCustomGLSLogger(const ALogger: TLogSession);
function ConstArrayToString(const Elements: array of const): String;

Types

CLogSession = class of TLogSession;
TIDELogProc = procedure(const AMsg: string);
TLogBufferingMode = (...);
TLogLevel = (...);
TLogLevels = set of TLogLevel;
TLogMessageLimitAction = (...);
TLogTimeFormat = (...);

Constants

llMax: TLogLevels = [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
llMedium: TLogLevels = [lkNotice, lkWarning, lkError, lkFatalError];
llMin: TLogLevels = [lkError, lkFatalError];

Variables

llMessageLimit: array [TLogLevel] of Integer = ( MaxInt, MaxInt, MaxInt, 500, 100, 10 );
lkPrefix: array [TLogLevel] of string = ( ' (D) ', ' (i) ', ' (M) ', ' (W) ', ' (Er) ', ' (!!) ' );
vIDELogProc: TIDELogProc;

Description

Functions and Procedures

function UserLog: TLogSession;

Return logger wich created by TGLSLogger component

function ReadLine(var TextFile: Text): string;

This item has no description.

function GLSLogger(): TLogSession;

Inner logger. Converted to a function, because in case of a DLL and main app using this module, log is written to the same file on initialization and finalization, which is not what one might want. This also allows to create a GLSLogger with custom parameters for user's application, for example a different log path (Often the EXE application directory is read-only).

procedure UseCustomGLSLogger(const ALogger: TLogSession);

This item has no description.

function ConstArrayToString(const Elements: array of const): String;

This item has no description.

Types

CLogSession = class of TLogSession;

Class reference to log session class

TIDELogProc = procedure(const AMsg: string);

This item has no description.

TLogBufferingMode = (...);

How log is buffered.

Values
  • lbmWriteEmidiatly
  • lbmWritePeriodically
  • lbmWriteInTheEnd
TLogLevel = (...);

Levels of importance of log messages

Values
  • lkDebug
  • lkInfo
  • lkNotice
  • lkWarning
  • lkError
  • lkFatalError
TLogLevels = set of TLogLevel;

Log level setting type

TLogMessageLimitAction = (...);

What to do when number of messages exceeds message limit.

Values
  • mlaContinue
  • mlaStopLogging
  • mlaHalt
TLogTimeFormat = (...);

Log date and time setting type

Values
  • lfNone: doesn't output any time information
  • lfDate: include date in the log
  • lfTime: include time in the log
  • lfTimeExact: include time in the log, including milliseconds
  • lfDateTime: include date and time in the log
  • lfElapsed: include time elapsed since startup in the log

Constants

llMax: TLogLevels = [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];

This item has no description.

llMedium: TLogLevels = [lkNotice, lkWarning, lkError, lkFatalError];

This item has no description.

llMin: TLogLevels = [lkError, lkFatalError];

This item has no description.

Variables

llMessageLimit: array [TLogLevel] of Integer = ( MaxInt, MaxInt, MaxInt, 500, 100, 10 );

This item has no description.

lkPrefix: array [TLogLevel] of string = ( ' (D) ', ' (i) ', ' (M) ', ' (W) ', ' (Er) ', ' (!!) ' );

This item has no description.

vIDELogProc: TIDELogProc;


GLSysHelp v.2.5: GLScene.Logger: Class TLogBufferFlushThread

Class TLogBufferFlushThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Logger

Declaration

type TLogBufferFlushThread = class(TThread)

Description

Thread that periodically flushes the buffer to disk.

Hierarchy

  • TObject
  • TThread
  • TLogBufferFlushThread

Overview

Fields

Private FParent: TLogSession;

Methods

Public constructor Create(const AParent: TLogSession);

Description

Fields

Private FParent: TLogSession;

This item has no description.

Methods

Public constructor Create(const AParent: TLogSession);


GLSysHelp v.2.5: GLScene.Logger: Class TLogCheckSizeThread

Class TLogCheckSizeThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Logger

Declaration

type TLogCheckSizeThread = class(TThread)

Description

Thread that checks file size and splits the file if nessesary.

Hierarchy

  • TObject
  • TThread
  • TLogCheckSizeThread

Overview

Fields

Private FParent: TLogSession;

Methods

Public constructor Create(const AParent: TLogSession);

Description

Fields

Private FParent: TLogSession;

This item has no description.

Methods

Public constructor Create(const AParent: TLogSession);


GLSysHelp v.2.5: GLScene.Logger: Class TLogSession

Class TLogSession

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Logger

Declaration

type TLogSession = class(TPersistent)

Description

Abstract Logger class

Hierarchy

  • TObject
  • TPersistent
  • TLogSession

Overview

Fields

Private | FBuffer: TStringList;
Private | FBuffered: Boolean;
Private | FBufferProcessingThread: TLogBufferFlushThread;
Private | FCheckLogSizeThread: TLogCheckSizeThread;
Private | FFlushBufferPeriod: Integer;
Private | FLogFile: Text;
Private | FDestroying: Boolean;
Private | FOriginalLogFileName: string;
Private | FCurrentLogFileName: string;
Private | FUsedLogFileNames: TStringList;
Private | FLogLevels: TLogLevels;
Private | FEnabled: Boolean;
Private | FBufferCriticalSection: TCriticalSection;
Private | FFileAccessCriticalSection: TCriticalSection;
Private | FModeTitles: array [TLogLevel] of string;
Private | FLogKindCount: array [TLogLevel] of Integer;
Private | FLogThreadId: Boolean;
Private | FMessageLimitAction: TLogMessageLimitAction;
Private | FTimeFormat: TLogTimeFormat;
Private | FStartedMs: Cardinal;
Private | FLogFileMaxSize: Integer;
Private | FCheckFileSizePeriod: Integer;
Private | FDisplayLogOnExitIfItContains: TLogLevels;
Private | FWriteInternalMessages: Boolean;
Private | FDisplayErrorDialogs: Boolean;

Methods

Public | constructor Init(const AFileName: string; const ATimeFormat: TLogTimeFormat; const ALevels: TLogLevels; const ALogThreadId: Boolean = True; const ABuffered: Boolean = False; const AMaxSize: Integer = 0; const ABackUpOldLogs: Boolean = False; const AClearOldLogs: Boolean = True; const AWriteInternalMessages: Boolean = True); virtual;
Private | constructor OnlyCreate;
Public | destructor Destroy; override;
Public | procedure DisplayLog();
Public | procedure FlushBuffer();
Public | procedure Log(const Desc: string; const Level: TLogLevel = lkInfo);
Public | procedure LogAdv(const args: array of const; const ALevel: TLogLevel = lkError);
Public | procedure LogDebug(const Desc: string);
Public | procedure LogDebugFmt(const Desc: string; const args: array of const);
Public | procedure LogEmtryLine();
Public | procedure LogError(const Desc: string);
Public | procedure LogErrorFmt(const Desc: string; const args: array of const);
Public | procedure LogException(const E: Exception; const aFunctionName: string; const args: array of const; const ALevel: TLogLevel = lkError);
Public | procedure LogFatalError(const Desc: string);
Public | procedure LogFatalErrorFmt(const Desc: string; const args: array of const);
Public | procedure LogInfo(const Desc: string);
Public | procedure LogInfoFmt(const Desc: string; const args: array of const);
Public | procedure LogNotice(const Desc: string);
Public | procedure LogNoticeFmt(const Desc: string; const args: array of const);
Public | procedure LogWarning(const Desc: string);
Public | procedure LogWarningFmt(const Desc: string; const args: array of const);
Private | procedure ChangeBufferedState();
Private | procedure SetBuffered(const Value: Boolean);
Private | procedure SetEnabled(const Value: Boolean);
Private | procedure SetLogFileMaxSize(const Value: Integer);
Private | procedure SetMode(const NewMode: TLogLevels);

Properties

Public | property Buffered: Boolean read FBuffered write SetBuffered default False;
Public | property CheckFileSizePeriod: Integer read FCheckFileSizePeriod write FCheckFileSizePeriod default 4000;
Public | property DisplayErrorDialogs: Boolean read FDisplayErrorDialogs write FDisplayErrorDialogs default True;
Public | property DisplayLogOnExitIfItContains: TLogLevels read FDisplayLogOnExitIfItContains write FDisplayLogOnExitIfItContains default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
Public | property Enabled: Boolean read FEnabled write SetEnabled default True;
Public | property FlushBufferPeriod: Integer read FFlushBufferPeriod write FFlushBufferPeriod default 5000;
Public | property LogFileMaxSize: Integer read FLogFileMaxSize write SetLogFileMaxSize default 0;
Public | property LogLevels: TLogLevels read FLogLevels write SetMode default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
Public | property LogThreadId: Boolean read FLogThreadId write FLogThreadId default True;
Public | property MessageLimitAction: TLogMessageLimitAction read FMessageLimitAction write FMessageLimitAction default mlaHalt;
Public | property WriteInternalMessages: Boolean read FWriteInternalMessages write FWriteInternalMessages default True;

Description

Fields

Private FBuffer: TStringList;

This item has no description.

Private FBuffered: Boolean;

This item has no description.

Private FBufferProcessingThread: TLogBufferFlushThread;

This item has no description.

Private FCheckLogSizeThread: TLogCheckSizeThread;

This item has no description.

Private FFlushBufferPeriod: Integer;

This item has no description.

Private FLogFile: Text;

This item has no description.

Private FDestroying: Boolean;

TextFile.

Private FOriginalLogFileName: string;

This item has no description.

Private FCurrentLogFileName: string;

Original name

Private FUsedLogFileNames: TStringList;

Current log file, if original exceeded certain size limit.

Private FLogLevels: TLogLevels;

List of all created log files.

Private FEnabled: Boolean;

This item has no description.

Private FBufferCriticalSection: TCriticalSection;

This item has no description.

Private FFileAccessCriticalSection: TCriticalSection;

This item has no description.

Private FModeTitles: array [TLogLevel] of string;

This item has no description.

Private FLogKindCount: array [TLogLevel] of Integer;

This item has no description.

Private FLogThreadId: Boolean;

This item has no description.

Private FMessageLimitAction: TLogMessageLimitAction;

This item has no description.

Private FTimeFormat: TLogTimeFormat;

Determines which date or time to include in the log

Private FStartedMs: Cardinal;

Startup timestamp in milliseconds

Private FLogFileMaxSize: Integer;

This item has no description.

Private FCheckFileSizePeriod: Integer;

This item has no description.

Private FDisplayLogOnExitIfItContains: TLogLevels;

This item has no description.

Private FWriteInternalMessages: Boolean;

This item has no description.

Private FDisplayErrorDialogs: Boolean;

This item has no description.

Methods

Public constructor Init(const AFileName: string; const ATimeFormat: TLogTimeFormat; const ALevels: TLogLevels; const ALogThreadId: Boolean = True; const ABuffered: Boolean = False; const AMaxSize: Integer = 0; const ABackUpOldLogs: Boolean = False; const AClearOldLogs: Boolean = True; const AWriteInternalMessages: Boolean = True); virtual;

Initializes a log session with the specified log file name, time and level settings

Private constructor OnlyCreate;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DisplayLog();

Mics procedures.

Public procedure FlushBuffer();

This item has no description.

Public procedure Log(const Desc: string; const Level: TLogLevel = lkInfo);

General Logging procedures

Public procedure LogAdv(const args: array of const; const ALevel: TLogLevel = lkError);

This item has no description.

Public procedure LogDebug(const Desc: string);

Logs a string Desc if Level matches current USE_LOGGING level (see LogLevels)

Public procedure LogDebugFmt(const Desc: string; const args: array of const);

Logs a formatted string assembled from a format string and an array of arguments.

Public procedure LogEmtryLine();

This item has no description.

Public procedure LogError(const Desc: string);

This item has no description.

Public procedure LogErrorFmt(const Desc: string; const args: array of const);

This item has no description.

Public procedure LogException(const E: Exception; const aFunctionName: string; const args: array of const; const ALevel: TLogLevel = lkError);

This item has no description.

Public procedure LogFatalError(const Desc: string);

This item has no description.

Public procedure LogFatalErrorFmt(const Desc: string; const args: array of const);

This item has no description.

Public procedure LogInfo(const Desc: string);

This item has no description.

Public procedure LogInfoFmt(const Desc: string; const args: array of const);

This item has no description.

Public procedure LogNotice(const Desc: string);

This item has no description.

Public procedure LogNoticeFmt(const Desc: string; const args: array of const);

This item has no description.

Public procedure LogWarning(const Desc: string);

This item has no description.

Public procedure LogWarningFmt(const Desc: string; const args: array of const);

This item has no description.

Private procedure ChangeBufferedState();

This item has no description.

Private procedure SetBuffered(const Value: Boolean);

This item has no description.

Private procedure SetEnabled(const Value: Boolean);

This item has no description.

Private procedure SetLogFileMaxSize(const Value: Integer);

This item has no description.

Private procedure SetMode(const NewMode: TLogLevels);

This item has no description.

Properties

Public property Buffered: Boolean read FBuffered write SetBuffered default False;

This item has no description.

Public property CheckFileSizePeriod: Integer read FCheckFileSizePeriod write FCheckFileSizePeriod default 4000;

In bytes, limited to 2Gb.

Public property DisplayErrorDialogs: Boolean read FDisplayErrorDialogs write FDisplayErrorDialogs default True;

This item has no description.

Public property DisplayLogOnExitIfItContains: TLogLevels read FDisplayLogOnExitIfItContains write FDisplayLogOnExitIfItContains default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];

To always display log, put all log types. To never display log, leave this empty.

Public property Enabled: Boolean read FEnabled write SetEnabled default True;

This item has no description.

Public property FlushBufferPeriod: Integer read FFlushBufferPeriod write FFlushBufferPeriod default 5000;

This item has no description.

Public property LogFileMaxSize: Integer read FLogFileMaxSize write SetLogFileMaxSize default 0;

If LogFileMaxSize is not 0, then: 1) At start, all logs with the same extention will be deleted. 2) All logs wil be periodically cheked for FileSize. New log file will be created when this size exceeds limit.

Public property LogLevels: TLogLevels read FLogLevels write SetMode default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];

If log is buffered, calling this will flush the buffer. Set of levels which to include in the log

Public property LogThreadId: Boolean read FLogThreadId write FLogThreadId default True;

In ms.

Public property MessageLimitAction: TLogMessageLimitAction read FMessageLimitAction write FMessageLimitAction default mlaHalt;

This item has no description.

Public property WriteInternalMessages: Boolean read FWriteInternalMessages write FWriteInternalMessages default True;


GLSysHelp v.2.5: GLScene.Logger: Class TGLSLogger

Class TGLSLogger

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Logger

Declaration

type TGLSLogger = class(TComponent)

Description

Abstract class for control logging.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLSLogger

Overview

Fields

Private | FReplaceAssertion: Boolean;
Private | FTimeFormat: TLogTimeFormat;
Private | FLogLevels: TLogLevels;
Private | FLog: TLogSession;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetLog: TLogSession;
Public | procedure DoPrimary;
Private | procedure SetReplaceAssertion(Value: Boolean);

Properties

Public | property Log: TLogSession read GetLog;
Published | property LogLevels: TLogLevels read FLogLevels write FLogLevels default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
Published | property ReplaceAssertion: Boolean read FReplaceAssertion write SetReplaceAssertion default False;
Published | property TimeFormat: TLogTimeFormat read FTimeFormat write FTimeFormat default lfElapsed;

Description

Fields

Private FReplaceAssertion: Boolean;

This item has no description.

Private FTimeFormat: TLogTimeFormat;

This item has no description.

Private FLogLevels: TLogLevels;

This item has no description.

Private FLog: TLogSession;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetLog: TLogSession;

This item has no description.

Public procedure DoPrimary;

Set component primary and then UserLog return it's log

Private procedure SetReplaceAssertion(Value: Boolean);

This item has no description.

Properties

Public property Log: TLogSession read GetLog;

This item has no description.

Published property LogLevels: TLogLevels read FLogLevels write FLogLevels default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];

This item has no description.

Published property ReplaceAssertion: Boolean read FReplaceAssertion write SetReplaceAssertion default False;

This item has no description.

Published property TimeFormat: TLogTimeFormat read FTimeFormat write FTimeFormat default lfElapsed;

Only design time sets. Define Log initial properties


GLSysHelp v.2.5: GLScene.Manager

Unit GLScene.Manager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.Types

Overview

Functions and Procedures

procedure RegisterManager(aManager: TComponent);
procedure DeRegisterManager(aManager: TComponent);
function FindManager(classType: TComponentClass; const managerName: String) : TComponent;

Description

Functions and Procedures

procedure RegisterManager(aManager: TComponent);

This item has no description.

procedure DeRegisterManager(aManager: TComponent);

This item has no description.

function FindManager(classType: TComponentClass; const managerName: String) : TComponent;


GLSysHelp v.2.5: GLScene.OpenGL4

Unit GLScene.OpenGL4

Description

Uses

Classes, Interfaces, Objects and Records

Functions and Procedures

Types

Constants

Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

System.SysUtils

System.Math

Winapi.Windows

GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name

Description

Packed Record _WGLSWAP

Record TGPUDEVICE

Record TGLUNurbs

Record TGLUQuadric

Record TGLUTesselator

Class EOpenGLError

Functions and Procedures

procedure glAccum(op: TGLuint; value: Single); stdcall; external opengl32;

procedure glAlphaFunc(func: Cardinal; ref: TGLclampf); stdcall; external opengl32;

function glAreTexturesResident(n: TGLsizei; Textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall; external opengl32;

procedure glArrayElement(i: TGLint); stdcall; external opengl32;

procedure glBegin(mode: Cardinal); stdcall; external opengl32;

procedure glBindTexture(target: Cardinal; texture: TGLuint); stdcall; external opengl32;

procedure glBitmap(width: TGLsizei; height: TGLsizei; xorig, yorig: Single; xmove: Single; ymove: Single; bitmap: Pointer); stdcall; external opengl32;

procedure glBlendFunc(sfactor: Cardinal; dfactor: Cardinal); stdcall; external opengl32;

procedure glCallList(list: TGLuint); stdcall; external opengl32;

procedure glCallLists(n: TGLsizei; atype: Cardinal; lists: Pointer); stdcall; external opengl32;

procedure glClear(mask: TGLbitfield); stdcall; external opengl32;

procedure glClearAccum(red, green, blue, alpha: Single); stdcall; external opengl32;

procedure glClearColor(red, green, blue, alpha: TGLclampf); stdcall; external opengl32;

procedure glClearDepth(depth: TGLclampd); stdcall; external opengl32;

procedure glClearIndex(c: Single); stdcall; external opengl32;

procedure glClearStencil(s: TGLint ); stdcall; external opengl32;

procedure glClipPlane(plane: Cardinal; equation: PGLdouble); stdcall; external opengl32;

procedure glColor3b(red, green, blue: TGLbyte); stdcall; external opengl32;

procedure glColor3bv(v: PGLbyte); stdcall; external opengl32;

procedure glColor3d(red, green, blue: TGLdouble); stdcall; external opengl32;

procedure glColor3dv(v: PGLdouble); stdcall; external opengl32;

procedure glColor3f(red, green, blue: Single); stdcall; external opengl32;

procedure glColor3fv(v: PGLfloat); stdcall; external opengl32;

procedure glColor3i(red, green, blue: TGLint); stdcall; external opengl32;

procedure glColor3iv(v: PGLint); stdcall; external opengl32;

procedure glColor3s(red, green, blue: TGLshort); stdcall; external opengl32;

procedure glColor3sv(v: PGLshort); stdcall; external opengl32;

procedure glColor3ub(red, green, blue: TGLubyte); stdcall; external opengl32;

procedure glColor3ubv(v: PGLubyte); stdcall; external opengl32;

procedure glColor3ui(red, green, blue: TGLuint); stdcall; external opengl32;

procedure glColor3uiv(v: PGLuint); stdcall; external opengl32;

procedure glColor3us(red, green, blue: TGLushort); stdcall; external opengl32;

procedure glColor3usv(v: PGLushort); stdcall; external opengl32;

procedure glColor4b(red, green, blue, alpha: TGLbyte); stdcall; external opengl32;

procedure glColor4bv(v: PGLbyte); stdcall; external opengl32;

procedure glColor4d(red, green, blue, alpha: TGLdouble ); stdcall; external opengl32;

procedure glColor4dv(v: PGLdouble); stdcall; external opengl32;

procedure glColor4f(red, green, blue, alpha: Single); stdcall; external opengl32;

procedure glColor4fv(v: PGLfloat); stdcall; external opengl32;

procedure glColor4i(red, green, blue, alpha: TGLint); stdcall; external opengl32;

procedure glColor4iv(v: PGLint); stdcall; external opengl32;

procedure glColor4s(red, green, blue, alpha: TGLshort); stdcall; external opengl32;

procedure glColor4sv(v: TGLshort); stdcall; external opengl32;

procedure glColor4ub(red, green, blue, alpha: TGLubyte); stdcall; external opengl32;

procedure glColor4ubv(v: PGLubyte); stdcall; external opengl32;

procedure glColor4ui(red, green, blue, alpha: TGLuint); stdcall; external opengl32;

procedure glColor4uiv(v: PGLuint); stdcall; external opengl32;

procedure glColor4us(red, green, blue, alpha: TGLushort); stdcall; external opengl32;

procedure glColor4usv(v: PGLushort); stdcall; external opengl32;

procedure glColorMask(red, green, blue, alpha: TGLboolean); stdcall; external opengl32;

procedure glColorMaterial(face: Cardinal; mode: Cardinal); stdcall; external opengl32;

procedure glColorPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glCopyPixels(x, y: TGLint; width, height: TGLsizei; atype: Cardinal); stdcall; external opengl32;

procedure glCopyTexImage1D(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall; external opengl32;

procedure glCopyTexImage2D(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall; external opengl32;

procedure glCopyTexSubImage1D(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall; external opengl32;

procedure glCopyTexSubImage2D(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

procedure glCullFace(mode: Cardinal); stdcall; external opengl32;

procedure glDeleteLists(list: TGLuint; range: TGLsizei); stdcall; external opengl32;

procedure glDeleteTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;

procedure glDepthFunc(func: Cardinal); stdcall; external opengl32;

procedure glDepthMask(flag: TGLboolean); stdcall; external opengl32;

procedure glDepthRange(zNear, zFar: TGLclampd); stdcall; external opengl32;

procedure glDisable(cap: Cardinal); stdcall; external opengl32;

procedure glDisableClientState(aarray: Cardinal); stdcall; external opengl32;

procedure glDrawArrays(mode: Cardinal; first: TGLint; count: TGLsizei); stdcall; external opengl32;

procedure glDrawBuffer(mode: Cardinal); stdcall; external opengl32;

procedure glDrawElements(mode: Cardinal; count: TGLsizei; atype: Cardinal; indices: Pointer); stdcall; external opengl32;

procedure glDrawPixels(width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glEdgeFlag(flag: TGLboolean); stdcall; external opengl32;

procedure glEdgeFlagPointer(stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glEdgeFlagv(flag: PGLboolean); stdcall; external opengl32;

procedure glEnable(cap: Cardinal); stdcall; external opengl32;

procedure glEnableClientState(aarray: Cardinal); stdcall; external opengl32;

procedure glEnd; stdcall; external opengl32;

procedure glEndList; stdcall; external opengl32;

procedure glEvalCoord1d(u: TGLdouble); stdcall; external opengl32;

procedure glEvalCoord1dv(u: PGLdouble); stdcall; external opengl32;

procedure glEvalCoord1f(u: Single); stdcall; external opengl32;

procedure glEvalCoord1fv(u: PGLfloat); stdcall; external opengl32;

procedure glEvalCoord2d(u: TGLdouble; v: TGLdouble); stdcall; external opengl32;

procedure glEvalCoord2dv(u: PGLdouble); stdcall; external opengl32;

procedure glEvalCoord2f(u, v: Single); stdcall; external opengl32;

procedure glEvalCoord2fv(u: PGLfloat); stdcall; external opengl32;

procedure glEvalMesh1(mode: Cardinal; i1, i2: TGLint); stdcall; external opengl32;

procedure glEvalMesh2(mode: Cardinal; i1, i2, j1, j2: TGLint); stdcall; external opengl32;

procedure glEvalPoint1(i: TGLint); stdcall; external opengl32;

procedure glEvalPoint2(i, j: TGLint); stdcall; external opengl32;

procedure glFeedbackBuffer(size: TGLsizei; atype: Cardinal; buffer: PGLfloat); stdcall; external opengl32;

procedure glFinish; stdcall; external opengl32;

procedure glFlush; stdcall; external opengl32;

procedure glFogf(pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glFogfv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glFogi(pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glFogiv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glFrontFace(mode: Cardinal); stdcall; external opengl32;

procedure glFrustum(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;

function glGenLists(range: TGLsizei): TGLuint; stdcall; external opengl32;

procedure glGenTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;

procedure glGetBooleanv(pname: Cardinal; params: PGLboolean); stdcall; external opengl32;

procedure glGetClipPlane(plane: Cardinal; equation: PGLdouble); stdcall; external opengl32;

procedure glGetDoublev(pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

function glGetError: TGLuint; stdcall; external opengl32;

procedure glGetFloatv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetIntegerv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetLightfv(light, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetLightiv(light, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetMapdv(target, query: Cardinal; v: PGLdouble); stdcall; external opengl32;

procedure glGetMapfv(target, query: Cardinal; v: PGLfloat); stdcall; external opengl32;

procedure glGetMapiv(target, query: Cardinal; v: PGLint); stdcall; external opengl32;

procedure glGetMaterialfv(face, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetMaterialiv(face, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetPixelMapfv(map: Cardinal; values: PGLfloat); stdcall; external opengl32;

procedure glGetPixelMapuiv(map: Cardinal; values: PGLuint); stdcall; external opengl32;

procedure glGetPixelMapusv(map: Cardinal; values: PGLushort); stdcall; external opengl32;

procedure glGetPointerv(pname: Cardinal; var params); stdcall; external opengl32;

procedure glGetPolygonStipple(mask: PGLubyte); stdcall; external opengl32;

function glGetString(name: Cardinal): PChar; stdcall; external opengl32;

procedure glGetTexEnvfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetTexEnviv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetTexGendv(coord, pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

procedure glGetTexGenfv(coord, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetTexGeniv(coord, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetTexImage(target: Cardinal; level: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glGetTexLevelParameterfv(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetTexLevelParameteriv(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetTexParameterfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetTexParameteriv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glHint(target, mode: Cardinal); stdcall; external opengl32;

procedure glIndexMask(mask: TGLuint); stdcall; external opengl32;

procedure glIndexPointer(atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glIndexd(c: TGLdouble); stdcall; external opengl32;

procedure glIndexdv(c: PGLdouble); stdcall; external opengl32;

procedure glIndexf(c: Single); stdcall; external opengl32;

procedure glIndexfv(c: PGLfloat); stdcall; external opengl32;

procedure glIndexi(c: TGLint); stdcall; external opengl32;

procedure glIndexiv(c: PGLint); stdcall; external opengl32;

procedure glIndexs(c: TGLshort); stdcall; external opengl32;

procedure glIndexsv(c: PGLshort); stdcall; external opengl32;

procedure glIndexub(c: TGLubyte); stdcall; external opengl32;

procedure glIndexubv(c: PGLubyte); stdcall; external opengl32;

procedure glInitNames; stdcall; external opengl32;

procedure glInterleavedArrays(format: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

function glIsEnabled(cap: Cardinal): TGLboolean; stdcall; external opengl32;

function glIsList(list: TGLuint): TGLboolean; stdcall; external opengl32;

function glIsTexture(texture: TGLuint): TGLboolean; stdcall; external opengl32;

procedure glLightModelf(pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glLightModelfv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glLightModeli(pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glLightModeliv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glLightf(light, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glLightfv(light, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glLighti(light, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glLightiv(light, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glLineStipple(factor: TGLint; pattern: TGLushort); stdcall; external opengl32;

procedure glLineWidth(width: Single); stdcall; external opengl32;

procedure glListBase(base: TGLuint); stdcall; external opengl32;

procedure glLoadIdentity; stdcall; external opengl32;

procedure glLoadMatrixd(m: PGLdouble); stdcall; external opengl32;

procedure glLoadMatrixf(m: PGLfloat); stdcall; external opengl32;

procedure glLoadName(name: TGLuint); stdcall; external opengl32;

procedure glLogicOp(opcode: Cardinal); stdcall; external opengl32;

procedure glMap1d(target: Cardinal; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall; external opengl32;

procedure glMap1f(target: Cardinal; u1, u2: Single; stride, order: TGLint; points: PGLfloat); stdcall; external opengl32;

procedure glMap2d(target: Cardinal; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall; external opengl32;

procedure glMap2f(target: Cardinal; u1, u2: Single; ustride, uorder: TGLint; v1, v2: Single; vstride, vorder: TGLint; points: PGLfloat); stdcall; external opengl32;

procedure glMapGrid1d(un: TGLint; u1, u2: TGLdouble); stdcall; external opengl32;

procedure glMapGrid1f(un: TGLint; u1, u2: Single); stdcall; external opengl32;

procedure glMapGrid2d(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall; external opengl32;

procedure glMapGrid2f(un: TGLint; u1, u2: Single; vn: TGLint; v1, v2: Single); stdcall; external opengl32;

procedure glMaterialf(face, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glMaterialfv(face, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glMateriali(face, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glMaterialiv(face, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glMatrixMode(mode: Cardinal); stdcall; external opengl32;

procedure glMultMatrixd(m: PGLdouble); stdcall; external opengl32;

procedure glMultMatrixf(m: PGLfloat); stdcall; external opengl32;

procedure glNewList(list: TGLuint; mode: Cardinal); stdcall; external opengl32;

procedure glNormal3b(nx, ny, nz: TGLbyte); stdcall; external opengl32;

procedure glNormal3bv(v: PGLbyte); stdcall; external opengl32;

procedure glNormal3d(nx, ny, nz: TGLdouble); stdcall; external opengl32;

procedure glNormal3dv(v: PGLdouble); stdcall; external opengl32;

procedure glNormal3f(nx, ny, nz: Single); stdcall; external opengl32;

procedure glNormal3fv(v: PGLfloat); stdcall; external opengl32;

procedure glNormal3i(nx, ny, nz: TGLint); stdcall; external opengl32;

procedure glNormal3iv(v: PGLint); stdcall; external opengl32;

procedure glNormal3s(nx, ny, nz: TGLshort); stdcall; external opengl32;

procedure glNormal3sv(v: PGLshort); stdcall; external opengl32;

procedure glNormalPointer(atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glOrtho(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;

procedure glPassThrough(token: Single); stdcall; external opengl32;

procedure glPixelMapfv(map: Cardinal; mapsize: TGLsizei; values: PGLfloat); stdcall; external opengl32;

procedure glPixelMapuiv(map: Cardinal; mapsize: TGLsizei; values: PGLuint); stdcall; external opengl32;

procedure glPixelMapusv(map: Cardinal; mapsize: TGLsizei; values: PGLushort); stdcall; external opengl32;

procedure glPixelStoref(pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glPixelStorei(pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glPixelTransferf(pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glPixelTransferi(pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glPixelZoom(xfactor, yfactor: Single); stdcall; external opengl32;

procedure glPointSize(size: Single); stdcall; external opengl32;

procedure glPolygonMode(face, mode: Cardinal); stdcall; external opengl32;

procedure glPolygonOffset(factor, units: Single); stdcall; external opengl32;

procedure glPolygonStipple(mask: PGLubyte); stdcall; external opengl32;

procedure glPopAttrib; stdcall; external opengl32;

procedure glPopClientAttrib; stdcall; external opengl32;

procedure glPopMatrix; stdcall; external opengl32;

procedure glPopName; stdcall; external opengl32;

procedure glPrioritizeTextures(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall; external opengl32;

procedure glPushAttrib(mask: TGLbitfield); stdcall; external opengl32;

procedure glPushClientAttrib(mask: TGLbitfield); stdcall; external opengl32;

procedure glPushMatrix; stdcall; external opengl32;

procedure glPushName(name: TGLuint); stdcall; external opengl32;

procedure glRasterPos2d(x, y: TGLdouble); stdcall; external opengl32;

procedure glRasterPos2dv(v: PGLdouble); stdcall; external opengl32;

procedure glRasterPos2f(x, y: Single); stdcall; external opengl32;

procedure glRasterPos2fv(v: PGLfloat); stdcall; external opengl32;

procedure glRasterPos2i(x, y: TGLint); stdcall; external opengl32;

procedure glRasterPos2iv(v: PGLint); stdcall; external opengl32;

procedure glRasterPos2s(x, y: PGLshort); stdcall; external opengl32;

procedure glRasterPos2sv(v: PGLshort); stdcall; external opengl32;

procedure glRasterPos3d(x, y, z: TGLdouble); stdcall; external opengl32;

procedure glRasterPos3dv(v: PGLdouble); stdcall; external opengl32;

procedure glRasterPos3f(x, y, z: Single); stdcall; external opengl32;

procedure glRasterPos3fv(v: PGLfloat); stdcall; external opengl32;

procedure glRasterPos3i(x, y, z: TGLint); stdcall; external opengl32;

procedure glRasterPos3iv(v: PGLint); stdcall; external opengl32;

procedure glRasterPos3s(x, y, z: TGLshort); stdcall; external opengl32;

procedure glRasterPos3sv(v: PGLshort); stdcall; external opengl32;

procedure glRasterPos4d(x, y, z, w: TGLdouble); stdcall; external opengl32;

procedure glRasterPos4dv(v: PGLdouble); stdcall; external opengl32;

procedure glRasterPos4f(x, y, z, w: Single); stdcall; external opengl32;

procedure glRasterPos4fv(v: PGLfloat); stdcall; external opengl32;

procedure glRasterPos4i(x, y, z, w: TGLint); stdcall; external opengl32;

procedure glRasterPos4iv(v: PGLint); stdcall; external opengl32;

procedure glRasterPos4s(x, y, z, w: TGLshort); stdcall; external opengl32;

procedure glRasterPos4sv(v: PGLshort); stdcall; external opengl32;

procedure glReadBuffer(mode: Cardinal); stdcall; external opengl32;

procedure glReadPixels(x, y: TGLint; width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glRectd(x1, y1, x2, y2: TGLdouble); stdcall; external opengl32;

procedure glRectdv(v1, v2: PGLdouble); stdcall; external opengl32;

procedure glRectf(x1, y1, x2, y2: Single); stdcall; external opengl32;

procedure glRectfv(v1, v2: PGLfloat); stdcall; external opengl32;

procedure glRecti(x1, y1, x2, y2: TGLint); stdcall; external opengl32;

procedure glRectiv(v1, v2: PGLint); stdcall; external opengl32;

procedure glRects(x1, y1, x2, y2: TGLshort); stdcall; external opengl32;

procedure glRectsv(v1, v2: PGLshort); stdcall; external opengl32;

function glRenderMode(mode: Cardinal): TGLint; stdcall; external opengl32;

procedure glRotated(angle, x, y, z: TGLdouble); stdcall; external opengl32;

procedure glRotatef(angle, x, y, z: Single); stdcall; external opengl32;

procedure glScaled(x, y, z: TGLdouble); stdcall; external opengl32;

procedure glScalef(x, y, z: Single); stdcall; external opengl32;

procedure glScissor(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

procedure glSelectBuffer(size: TGLsizei; buffer: PGLuint); stdcall; external opengl32;

procedure glShadeModel(mode: Cardinal); stdcall; external opengl32;

procedure glStencilFunc(func: Cardinal; ref: TGLint; mask: TGLuint); stdcall; external opengl32;

procedure glStencilMask(mask: TGLuint); stdcall; external opengl32;

procedure glStencilOp(fail, zfail, zpass: Cardinal); stdcall; external opengl32;

procedure glTexCoord1d(s: TGLdouble); stdcall; external opengl32;

procedure glTexCoord1dv(v: PGLdouble); stdcall; external opengl32;

procedure glTexCoord1f(s: Single); stdcall; external opengl32;

procedure glTexCoord1fv(v: PGLfloat); stdcall; external opengl32;

procedure glTexCoord1i(s: TGLint); stdcall; external opengl32;

procedure glTexCoord1iv(v: PGLint); stdcall; external opengl32;

procedure glTexCoord1s(s: TGLshort); stdcall; external opengl32;

procedure glTexCoord1sv(v: PGLshort); stdcall; external opengl32;

procedure glTexCoord2d(s, t: TGLdouble); stdcall; external opengl32;

procedure glTexCoord2dv(v: PGLdouble); stdcall; external opengl32;

procedure glTexCoord2f(s, t: Single); stdcall; external opengl32;

procedure glTexCoord2fv(v: PGLfloat); stdcall; external opengl32;

procedure glTexCoord2i(s, t: TGLint); stdcall; external opengl32;

procedure glTexCoord2iv(v: PGLint); stdcall; external opengl32;

procedure glTexCoord2s(s, t: TGLshort); stdcall; external opengl32;

procedure glTexCoord2sv(v: PGLshort); stdcall; external opengl32;

procedure glTexCoord3d(s, t, r: TGLdouble); stdcall; external opengl32;

procedure glTexCoord3dv(v: PGLdouble); stdcall; external opengl32;

procedure glTexCoord3f(s, t, r: Single); stdcall; external opengl32;

procedure glTexCoord3fv(v: PGLfloat); stdcall; external opengl32;

procedure glTexCoord3i(s, t, r: TGLint); stdcall; external opengl32;

procedure glTexCoord3iv(v: PGLint); stdcall; external opengl32;

procedure glTexCoord3s(s, t, r: TGLshort); stdcall; external opengl32;

procedure glTexCoord3sv(v: PGLshort); stdcall; external opengl32;

procedure glTexCoord4d(s, t, r, q: TGLdouble); stdcall; external opengl32;

procedure glTexCoord4dv(v: PGLdouble); stdcall; external opengl32;

procedure glTexCoord4f(s, t, r, q: Single); stdcall; external opengl32;

procedure glTexCoord4fv(v: PGLfloat); stdcall; external opengl32;

procedure glTexCoord4i(s, t, r, q: TGLint); stdcall; external opengl32;

procedure glTexCoord4iv(v: PGLint); stdcall; external opengl32;

procedure glTexCoord4s(s, t, r, q: TGLshort); stdcall; external opengl32;

procedure glTexCoord4sv(v: PGLshort); stdcall; external opengl32;

procedure glTexCoordPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glTexEnvf(target, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glTexEnvfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glTexEnvi(target, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glTexEnviv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glTexGend(coord, pname: Cardinal; param: TGLdouble); stdcall; external opengl32;

procedure glTexGendv(coord, pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

procedure glTexGenf(coord, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glTexGenfv(coord, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glTexGeni(coord, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glTexGeniv(coord, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glTexImage1D(target: Cardinal; level, internalformat: TGLint; width: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glTexImage2D(target: Cardinal; level, internalformat: TGLint; width, height: TGLsizei; border: TGLint; format, atype: Cardinal; Pixels:Pointer); stdcall; external opengl32;

procedure glTexParameterf(target, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glTexParameterfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glTexParameteri(target, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glTexParameteriv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glTexSubImage1D(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glTexSubImage2D(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glTranslated(x, y, z: TGLdouble); stdcall; external opengl32;

procedure glTranslatef(x, y, z: Single); stdcall; external opengl32;

procedure glVertex2d(x, y: TGLdouble); stdcall; external opengl32;

procedure glVertex2dv(v: PGLdouble); stdcall; external opengl32;

procedure glVertex2f(x, y: Single); stdcall; external opengl32;

procedure glVertex2fv(v: PGLfloat); stdcall; external opengl32;

procedure glVertex2i(x, y: TGLint); stdcall; external opengl32;

procedure glVertex2iv(v: PGLint); stdcall; external opengl32;

procedure glVertex2s(x, y: TGLshort); stdcall; external opengl32;

procedure glVertex2sv(v: PGLshort); stdcall; external opengl32;

procedure glVertex3d(x, y, z: TGLdouble); stdcall; external opengl32;

procedure glVertex3dv(v: PGLdouble); stdcall; external opengl32;

procedure glVertex3f(x, y, z: Single); stdcall; external opengl32;

procedure glVertex3fv(v: PGLfloat); stdcall; external opengl32;

procedure glVertex3i(x, y, z: TGLint); stdcall; external opengl32;

procedure glVertex3iv(v: PGLint); stdcall; external opengl32;

procedure glVertex3s(x, y, z: TGLshort); stdcall; external opengl32;

procedure glVertex3sv(v: PGLshort); stdcall; external opengl32;

procedure glVertex4d(x, y, z, w: TGLdouble); stdcall; external opengl32;

procedure glVertex4dv(v: PGLdouble); stdcall; external opengl32;

procedure glVertex4f(x, y, z, w: Single); stdcall; external opengl32;

procedure glVertex4fv(v: PGLfloat); stdcall; external opengl32;

procedure glVertex4i(x, y, z, w: TGLint); stdcall; external opengl32;

procedure glVertex4iv(v: PGLint); stdcall; external opengl32;

procedure glVertex4s(x, y, z, w: TGLshort); stdcall; external opengl32;

procedure glVertex4sv(v: PGLshort); stdcall; external opengl32;

procedure glVertexPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glViewport(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

function gluErrorString(errCode: Cardinal): PGLChar; stdcall; external glu32;

function gluGetString(name: Cardinal): PGLChar; stdcall; external glu32;

procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;

procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;

function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;

function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;

function gluScaleImage(format: Cardinal; widthin, heightin: TGLint; typein: Cardinal; datain: Pointer; widthout, heightout: TGLint; typeout: Cardinal; dataout: Pointer): TGLint; stdcall; external glu32;

function gluBuild1DMipmaps(target: Cardinal; components, width: TGLint; format, atype: Cardinal; data: Pointer): TGLint; stdcall; external glu32;

function gluBuild2DMipmaps(target: Cardinal; components, width, height: TGLint; format, atype: Cardinal; data: Pointer): TGLint; stdcall; external glu32;

function gluNewQuadric: PGLUquadric; stdcall; external glu32;

function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;

function gluNewTess: PGLUtesselator; stdcall; external glu32;

procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;

procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;

procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;

procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; value: PGLfloat); stdcall; external glu32;

procedure gluGetTessProperty(tess: PGLUtesselator; which: Cardinal; value: PGLdouble); stdcall; external glu32;

procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const viewport: TVector4i); stdcall; external glu32;

procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;

procedure gluNextContour(tess: PGLUtesselator; atype: Cardinal); stdcall; external glu32;

procedure gluNurbsCallback(nobj: PGLUnurbs; which: Cardinal; fn: TGLUNurbsErrorProc); stdcall; external glu32;

procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: Cardinal); stdcall; external glu32;

procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; value: Single); stdcall; external glu32;

procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: Cardinal); stdcall; external glu32;

procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;

procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;

procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;

procedure gluPickMatrix(x, y, width, height: TGLdouble; const viewport: TVector4i); stdcall; external glu32;

procedure gluPwlCurve(nobj: PGLUnurbs; count: TGLint; points: PGLfloat; stride: TGLint; atype: Cardinal); stdcall; external glu32;

procedure gluQuadricCallback(quadObject: PGLUquadric; which: Cardinal; fn: TGLUQuadricErrorProc); stdcall; external glu32;

procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: Cardinal); stdcall; external glu32;

procedure gluQuadricNormals(quadObject: PGLUquadric; normals: Cardinal); stdcall; external glu32;

procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: Cardinal); stdcall; external glu32;

procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;

procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;

procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;

procedure gluTessCallback(tess: PGLUtesselator; which: Cardinal; fn: Pointer); stdcall; external glu32;

procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;

procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

procedure gluTessNormal(tess: PGLUtesselator; x, y, z: TGLdouble); stdcall; external glu32;

procedure gluTessProperty(tess: PGLUtesselator; which: Cardinal; value: TGLdouble); stdcall; external glu32;

procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; data: Pointer); stdcall; external glu32;

function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: Cardinal): BOOL; stdcall; external opengl32;

function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;

function wglCreateLayerContext(p1: HDC; p2: Integer): HGLRC; stdcall; external opengl32;

function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;

function wglDescribeLayerPlane(p1: HDC; p2, p3: Integer; p4: Cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;

function wglGetCurrentContext: HGLRC; stdcall; external opengl32;

function wglGetCurrentDC: HDC; stdcall; external opengl32;

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;

function wglGetProcAddress(ProcName: PGLChar): Pointer; stdcall; external opengl32;

function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;

function wglRealizeLayerPalette(p1: HDC; p2: Integer; p3: BOOL): BOOL; stdcall; external opengl32;

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;

function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;

function wglSwapLayerBuffers(p1: HDC; p2: Cardinal): BOOL; stdcall; external opengl32;

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32;

function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;

function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;

function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;

function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;

function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 name 'wglUseFontBitmapsA';

function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 name 'wglUseFontOutlinesA';

function GLGetProcAddress(ProcName: PGLChar): Pointer;

procedure ReadExtensions;

procedure ReadImplementationProperties;

procedure ReadWGLExtensions;

procedure ReadWGLImplementationProperties;

procedure CloseOpenGL;

function InitOpenGL: Boolean;

function InitOpenGLFromLibrary(const GLName, GLUName : String) : Boolean;

function IsOpenGLInitialized: Boolean;

procedure UnloadOpenGL;

function LoadOpenGL: Boolean;

function LoadOpenGLFromLibrary(const GLName, GLUName: String): Boolean;

function IsOpenGLLoaded: Boolean;

function IsMesaGL: Boolean;

procedure TrimAndSplitVersionString(Buffer: String; out Max, Min: Integer);

function IsVersionMet(MajorVersion,MinorVersion, actualMajorVersion, actualMinorVersion:Integer): boolean;

function IsOpenGLVersionMet(MajorVersion,MinorVersion: Integer): boolean;

procedure CheckOpenGLError;

procedure ClearGLError;

procedure RaiseOpenGLError(const msg : String);

Types

GLbitfield = UINT;

GLboolean = BYTEBOOL;

GLbyte = ShortInt;

GLclampd = Double;

GLclampf = Single;

GLdouble = Double;

GLenum = Cardinal;

GLfloat = Single;

GLhandleARB = Cardinal;

GLint = Integer;

GLint64 = Int64;

GLint64EXT = Int64;

GLshort = SmallInt;

GLsizei = Integer;

GLubyte = Byte;

GLuint = UINT;

GLuint64 = UInt64;

GLuint64EXT = UInt64;

GLushort = Word;

HGPUNV = THandle;

HPBUFFERARB = Integer;

HVIDEOINPUTDEVICENV = THandle;

PGLbitfield = ˆTGLbitfield;

PGLboolean = ˆTGLboolean;

PGLbyte = ˆTGLbyte;

PGLChar = PAnsiChar;

PGLclampd = ˆTGLclampd;

PGLclampf = ˆTGLclampf;

PGLdouble = System.PDouble;

PGLenum = ˆCardinal;

PGLfloat = System.PSingle;

PGLhandleARB = ˆGLhandleARB;

PGLint = ˆInteger;

PGLint64 = ˆTGLint64;

PGLint64EXT = ˆTGLint64EXT;

PGLintptr = ˆTGLintptr;

PGLPCharArray = ˆPGLChar;

PGLPointer = ˆPointer;

PGLshort = ˆTGLshort;

PGLsizei = ˆTGLsizei;

PGLubyte = System.PByte;

PGLuint = ˆTGLuint;

PGLuint64 = ˆTGLuint64;

PGLuint64EXT = ˆTGLuint64EXT;

PGLUNurbs = ˆTGLUNurbs;

PGLUNurbsObj = PGLUNurbs;

PGLUQuadric = ˆTGLUQuadric;

PGLUQuadricObj = PGLUQuadric;

PGLushort = System.PWord;

PGLUTesselator = ˆTGLUTesselator;

PGLUTesselatorObj = PGLUTesselator;

PGLUTriangulatorObj = PGLUTesselator;

PGLvoid = Pointer;

PGPUDEVICE = ˆTGPUDEVICE;

PHGPUNV = ˆHGPUNV;

PHVIDEOINPUTDEVICENV = ˆHVIDEOINPUTDEVICENV;

PWGLSwap = ˆTWGLSwap;

TGLbitfield = UINT;

TGLboolean = BYTEBOOL;

TGLbyte = ShortInt;

TGLclampd = Double;

TGLclampf = Single;

TGLdouble = Double;

TGLEnum = Cardinal;

TGLfloat = Single;

TGLint = Integer;

TGLint64 = Int64;

TGLint64EXT = Int64;

TGLintptr = NativeInt;

TGLshort = SmallInt;

TGLsizei = Integer;

TGLsizeiptr = NativeInt;

TGLString = AnsiString;

TGLsync = NativeInt;

TGLubyte = Byte;

TGLuint = UINT;

TGLuint64 = UInt64;

TGLuint64EXT = UInt64;

TGLUNurbsErrorProc = procedure(errorCode: Cardinal); stdcall;

TGLUNurbsObj = TGLUNurbs;

TGLUQuadricErrorProc = procedure(errorCode: Cardinal); stdcall;

TGLUQuadricObj = TGLUQuadric;

TGLushort = Word;

TGLUTessBeginDataProc = procedure(AType: Cardinal; UserData: Pointer); stdcall;

TGLUTessBeginProc = procedure(AType: Cardinal); stdcall;

TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;

TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;

TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;

TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;

TGLUTesselatorObj = TGLUTesselator;

TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;

TGLUTessEndProc = procedure; stdcall;

TGLUTessErrorDataProc = procedure(ErrNo: Cardinal; UserData: Pointer); stdcall;

TGLUTessErrorProc = procedure(ErrNo: Cardinal); stdcall;

TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;

TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;

TGLUTriangulatorObj = TGLUTesselator;

TRCOptions = set of ( opDoubleBuffered, opGDI, opStereo );

TVector4p = array[0..3] of Pointer;

TWGLSwap = _WGLSWAP;

WGLSWAP = _WGLSWAP;

Constants

opengl32 = 'OpenGL32.dll';

glu32 = 'GLU32.dll';

libEGL = 'libEGL.dll';

libGLES2 = 'libGLESv2.dll';

GL_DEPTH_BUFFER_BIT = $00000100;

GL_STENCIL_BUFFER_BIT = $00000400;

GL_COLOR_BUFFER_BIT = $00004000;

GL_TRUE = 1;

GL_FALSE = 0;

GL_POINTS = $0000;

GL_LINES = $0001;

GL_LINE_LOOP = $0002;

GL_LINE_STRIP = $0003;

GL_TRIANGLES = $0004;

GL_TRIANGLE_STRIP = $0005;

GL_TRIANGLE_FAN = $0006;

GL_NEVER = $0200;

GL_LESS = $0201;

GL_EQUAL = $0202;

GL_LEQUAL = $0203;

GL_GREATER = $0204;

GL_NOTEQUAL = $0205;

GL_GEQUAL = $0206;

GL_ALWAYS = $0207;

GL_ZERO = 0;

GL_ONE = 1;

GL_SRC_COLOR = $0300;

GL_ONE_MINUS_SRC_COLOR = $0301;

GL_SRC_ALPHA = $0302;

GL_ONE_MINUS_SRC_ALPHA = $0303;

GL_DST_ALPHA = $0304;

GL_ONE_MINUS_DST_ALPHA = $0305;

GL_DST_COLOR = $0306;

GL_ONE_MINUS_DST_COLOR = $0307;

GL_SRC_ALPHA_SATURATE = $0308;

GL_NONE = 0;

GL_FRONT_LEFT = $0400;

GL_FRONT_RIGHT = $0401;

GL_BACK_LEFT = $0402;

GL_BACK_RIGHT = $0403;

GL_FRONT = $0404;

GL_BACK = $0405;

GL_LEFT = $0406;

GL_RIGHT = $0407;

GL_FRONT_AND_BACK = $0408;

GL_NO_ERROR = 0;

GL_INVALID_ENUM = $0500;

GL_INVALID_VALUE = $0501;

GL_INVALID_OPERATION = $0502;

GL_OUT_OF_MEMORY = $0505;

GL_CW = $0900;

GL_CCW = $0901;

GL_POINT_SIZE = $0B11;

GL_POINT_SIZE_RANGE = $0B12;

GL_POINT_SIZE_GRANULARITY = $0B13;

GL_LINE_SMOOTH = $0B20;

GL_LINE_WIDTH = $0B21;

GL_LINE_WIDTH_RANGE = $0B22;

GL_LINE_WIDTH_GRANULARITY = $0B23;

GL_POLYGON_SMOOTH = $0B41;

GL_CULL_FACE = $0B44;

GL_CULL_FACE_MODE = $0B45;

GL_FRONT_FACE = $0B46;

GL_DEPTH_RANGE = $0B70;

GL_DEPTH_TEST = $0B71;

GL_DEPTH_WRITEMASK = $0B72;

GL_DEPTH_CLEAR_VALUE = $0B73;

GL_DEPTH_FUNC = $0B74;

GL_STENCIL_TEST = $0B90;

GL_STENCIL_CLEAR_VALUE = $0B91;

GL_STENCIL_FUNC = $0B92;

GL_STENCIL_VALUE_MASK = $0B93;

GL_STENCIL_FAIL = $0B94;

GL_STENCIL_PASS_DEPTH_FAIL = $0B95;

GL_STENCIL_PASS_DEPTH_PASS = $0B96;

GL_STENCIL_REF = $0B97;

GL_STENCIL_WRITEMASK = $0B98;

GL_VIEWPORT = $0BA2;

GL_DITHER = $0BD0;

GL_BLEND_DST = $0BE0;

GL_BLEND_SRC = $0BE1;

GL_BLEND = $0BE2;

GL_LOGIC_OP_MODE = $0BF0;

GL_COLOR_LOGIC_OP = $0BF2;

GL_DRAW_BUFFER = $0C01;

GL_READ_BUFFER = $0C02;

GL_SCISSOR_BOX = $0C10;

GL_SCISSOR_TEST = $0C11;

GL_COLOR_CLEAR_VALUE = $0C22;

GL_COLOR_WRITEMASK = $0C23;

GL_DOUBLEBUFFER = $0C32;

GL_STEREO = $0C33;

GL_LINE_SMOOTH_HINT = $0C52;

GL_POLYGON_SMOOTH_HINT = $0C53;

GL_UNPACK_SWAP_BYTES = $0CF0;

GL_UNPACK_LSB_FIRST = $0CF1;

GL_UNPACK_ROW_LENGTH = $0CF2;

GL_UNPACK_SKIP_ROWS = $0CF3;

GL_UNPACK_SKIP_PIXELS = $0CF4;

GL_UNPACK_ALIGNMENT = $0CF5;

GL_PACK_SWAP_BYTES = $0D00;

GL_PACK_LSB_FIRST = $0D01;

GL_PACK_ROW_LENGTH = $0D02;

GL_PACK_SKIP_ROWS = $0D03;

GL_PACK_SKIP_PIXELS = $0D04;

GL_PACK_ALIGNMENT = $0D05;

GL_MAX_TEXTURE_SIZE = $0D33;

GL_MAX_VIEWPORT_DIMS = $0D3A;

GL_SUBPIXEL_BITS = $0D50;

GL_TEXTURE_1D = $0DE0;

GL_TEXTURE_2D = $0DE1;

GL_POLYGON_OFFSET_UNITS = $2A00;

GL_POLYGON_OFFSET_POINT = $2A01;

GL_POLYGON_OFFSET_LINE = $2A02;

GL_POLYGON_OFFSET_FILL = $8037;

GL_POLYGON_OFFSET_FACTOR = $8038;

GL_TEXTURE_BINDING_1D = $8068;

GL_TEXTURE_BINDING_2D = $8069;

GL_TEXTURE_WIDTH = $1000;

GL_TEXTURE_HEIGHT = $1001;

GL_TEXTURE_INTERNAL_FORMAT = $1003;

GL_TEXTURE_BORDER_COLOR = $1004;

GL_TEXTURE_BORDER = $1005;

GL_TEXTURE_RED_SIZE = $805C;

GL_TEXTURE_GREEN_SIZE = $805D;

GL_TEXTURE_BLUE_SIZE = $805E;

GL_TEXTURE_ALPHA_SIZE = $805F;

GL_DONT_CARE = $1100;

GL_FASTEST = $1101;

GL_NICEST = $1102;

GL_BYTE = $1400;

GL_UNSIGNED_BYTE = $1401;

GL_SHORT = $1402;

GL_UNSIGNED_SHORT = $1403;

GL_INT = $1404;

GL_UNSIGNED_INT = $1405;

GL_FLOAT = $1406;

GL_DOUBLE = $140A;

GL_CLEAR = $1500;

GL_AND = $1501;

GL_AND_REVERSE = $1502;

GL_COPY = $1503;

GL_AND_INVERTED = $1504;

GL_NOOP = $1505;

GL_XOR = $1506;

GL_OR = $1507;

GL_NOR = $1508;

GL_EQUIV = $1509;

GL_INVERT = $150A;

GL_OR_REVERSE = $150B;

GL_COPY_INVERTED = $150C;

GL_OR_INVERTED = $150D;

GL_NAND = $150E;

GL_SET = $150F;

GL_TEXTURE = $1702;

GL_COLOR = $1800;

GL_DEPTH = $1801;

GL_STENCIL = $1802;

GL_STENCIL_INDEX = $1901;

GL_DEPTH_COMPONENT = $1902;

GL_RED = $1903;

GL_GREEN = $1904;

GL_BLUE = $1905;

GL_ALPHA = $1906;

GL_RGB = $1907;

GL_RGBA = $1908;

GL_POINT = $1B00;

GL_LINE = $1B01;

GL_FILL = $1B02;

GL_KEEP = $1E00;

GL_REPLACE = $1E01;

GL_INCR = $1E02;

GL_DECR = $1E03;

GL_VENDOR = $1F00;

GL_RENDERER = $1F01;

GL_VERSION = $1F02;

GL_EXTENSIONS = $1F03;

GL_NEAREST = $2600;

GL_LINEAR = $2601;

GL_NEAREST_MIPMAP_NEAREST = $2700;

GL_LINEAR_MIPMAP_NEAREST = $2701;

GL_NEAREST_MIPMAP_LINEAR = $2702;

GL_LINEAR_MIPMAP_LINEAR = $2703;

GL_TEXTURE_MAG_FILTER = $2800;

GL_TEXTURE_MIN_FILTER = $2801;

GL_TEXTURE_WRAP_S = $2802;

GL_TEXTURE_WRAP_T = $2803;

GL_PROXY_TEXTURE_1D = $8063;

GL_PROXY_TEXTURE_2D = $8064;

GL_REPEAT = $2901;

GL_R3_G3_B2 = $2A10;

GL_RGB4 = $804F;

GL_RGB5 = $8050;

GL_RGB8 = $8051;

GL_RGB10 = $8052;

GL_RGB12 = $8053;

GL_RGB16 = $8054;

GL_RGBA2 = $8055;

GL_RGBA4 = $8056;

GL_RGB5_A1 = $8057;

GL_RGBA8 = $8058;

GL_RGB10_A2 = $8059;

GL_RGBA12 = $805A;

GL_RGBA16 = $805B;

GL_ACCUM = $0100;

GL_LOAD = $0101;

GL_RETURN = $0102;

GL_MULT = $0103;

GL_ADD = $0104;

GL_CURRENT_BIT = $00000001;

GL_POINT_BIT = $00000002;

GL_LINE_BIT = $00000004;

GL_POLYGON_BIT = $00000008;

GL_POLYGON_STIPPLE_BIT = $00000010;

GL_PIXEL_MODE_BIT = $00000020;

GL_LIGHTING_BIT = $00000040;

GL_FOG_BIT = $00000080;

GL_ACCUM_BUFFER_BIT = $00000200;

GL_VIEWPORT_BIT = $00000800;

GL_TRANSFORM_BIT = $00001000;

GL_ENABLE_BIT = $00002000;

GL_HINT_BIT = $00008000;

GL_EVAL_BIT = $00010000;

GL_LIST_BIT = $00020000;

GL_TEXTURE_BIT = $00040000;

GL_SCISSOR_BIT = $00080000;

GL_ALL_ATTRIB_BITS = $000FFFFF;

GL_QUADS = $0007;

GL_QUAD_STRIP = $0008;

GL_POLYGON = $0009;

GL_CLIP_PLANE0 = $3000;

GL_CLIP_PLANE1 = $3001;

GL_CLIP_PLANE2 = $3002;

GL_CLIP_PLANE3 = $3003;

GL_CLIP_PLANE4 = $3004;

GL_CLIP_PLANE5 = $3005;

GL_2_BYTES = $1407;

GL_3_BYTES = $1408;

GL_4_BYTES = $1409;

GL_AUX0 = $0409;

GL_AUX1 = $040A;

GL_AUX2 = $040B;

GL_AUX3 = $040C;

GL_STACK_OVERFLOW = $0503;

GL_STACK_UNDERFLOW = $0504;

GL_2D = $0600;

GL_3D = $0601;

GL_3D_COLOR = $0602;

GL_3D_COLOR_TEXTURE = $0603;

GL_4D_COLOR_TEXTURE = $0604;

GL_PASS_THROUGH_TOKEN = $0700;

GL_POINT_TOKEN = $0701;

GL_LINE_TOKEN = $0702;

GL_POLYGON_TOKEN = $0703;

GL_BITMAP_TOKEN = $0704;

GL_DRAW_PIXEL_TOKEN = $0705;

GL_COPY_PIXEL_TOKEN = $0706;

GL_LINE_RESET_TOKEN = $0707;

GL_EXP = $0800;

GL_EXP2 = $0801;

GL_COEFF = $0A00;

GL_ORDER = $0A01;

GL_DOMAIN = $0A02;

GL_CURRENT_COLOR = $0B00;

GL_CURRENT_INDEX = $0B01;

GL_CURRENT_NORMAL = $0B02;

GL_CURRENT_TEXTURE_COORDS = $0B03;

GL_CURRENT_RASTER_COLOR = $0B04;

GL_CURRENT_RASTER_INDEX = $0B05;

GL_CURRENT_RASTER_TEXTURE_COORDS = $0B06;

GL_CURRENT_RASTER_POSITION = $0B07;

GL_CURRENT_RASTER_POSITION_VALID = $0B08;

GL_CURRENT_RASTER_DISTANCE = $0B09;

GL_POINT_SMOOTH = $0B10;

GL_LINE_STIPPLE = $0B24;

GL_LINE_STIPPLE_PATTERN = $0B25;

GL_LINE_STIPPLE_REPEAT = $0B26;

GL_LIST_MODE = $0B30;

GL_MAX_LIST_NESTING = $0B31;

GL_LIST_BASE = $0B32;

GL_LIST_INDEX = $0B33;

GL_POLYGON_MODE = $0B40;

GL_POLYGON_STIPPLE = $0B42;

GL_EDGE_FLAG = $0B43;

GL_LIGHTING = $0B50;

GL_LIGHT_MODEL_LOCAL_VIEWER = $0B51;

GL_LIGHT_MODEL_TWO_SIDE = $0B52;

GL_LIGHT_MODEL_AMBIENT = $0B53;

GL_SHADE_MODEL = $0B54;

GL_COLOR_MATERIAL_FACE = $0B55;

GL_COLOR_MATERIAL_PARAMETER = $0B56;

GL_COLOR_MATERIAL = $0B57;

GL_FOG = $0B60;

GL_FOG_INDEX = $0B61;

GL_FOG_DENSITY = $0B62;

GL_FOG_START = $0B63;

GL_FOG_END = $0B64;

GL_FOG_MODE = $0B65;

GL_FOG_COLOR = $0B66;

GL_ACCUM_CLEAR_VALUE = $0B80;

GL_MATRIX_MODE = $0BA0;

GL_NORMALIZE = $0BA1;

GL_MODELVIEW_STACK_DEPTH = $0BA3;

GL_PROJECTION_STACK_DEPTH = $0BA4;

GL_TEXTURE_STACK_DEPTH = $0BA5;

GL_MODELVIEW_MATRIX = $0BA6;

GL_PROJECTION_MATRIX = $0BA7;

GL_TEXTURE_MATRIX = $0BA8;

GL_ATTRIB_STACK_DEPTH = $0BB0;

GL_CLIENT_ATTRIB_STACK_DEPTH = $0BB1;

GL_ALPHA_TEST = $0BC0;

GL_ALPHA_TEST_FUNC = $0BC1;

GL_ALPHA_TEST_REF = $0BC2;

GL_INDEX_LOGIC_OP = $0BF1;

GL_AUX_BUFFERS = $0C00;

GL_INDEX_CLEAR_VALUE = $0C20;

GL_INDEX_WRITEMASK = $0C21;

GL_INDEX_MODE = $0C30;

GL_RGBA_MODE = $0C31;

GL_RENDER_MODE = $0C40;

GL_PERSPECTIVE_CORRECTION_HINT = $0C50;

GL_POINT_SMOOTH_HINT = $0C51;

GL_FOG_HINT = $0C54;

GL_TEXTURE_GEN_S = $0C60;

GL_TEXTURE_GEN_T = $0C61;

GL_TEXTURE_GEN_R = $0C62;

GL_TEXTURE_GEN_Q = $0C63;

GL_PIXEL_MAP_I_TO_I = $0C70;

GL_PIXEL_MAP_S_TO_S = $0C71;

GL_PIXEL_MAP_I_TO_R = $0C72;

GL_PIXEL_MAP_I_TO_G = $0C73;

GL_PIXEL_MAP_I_TO_B = $0C74;

GL_PIXEL_MAP_I_TO_A = $0C75;

GL_PIXEL_MAP_R_TO_R = $0C76;

GL_PIXEL_MAP_G_TO_G = $0C77;

GL_PIXEL_MAP_B_TO_B = $0C78;

GL_PIXEL_MAP_A_TO_A = $0C79;

GL_PIXEL_MAP_I_TO_I_SIZE = $0CB0;

GL_PIXEL_MAP_S_TO_S_SIZE = $0CB1;

GL_PIXEL_MAP_I_TO_R_SIZE = $0CB2;

GL_PIXEL_MAP_I_TO_G_SIZE = $0CB3;

GL_PIXEL_MAP_I_TO_B_SIZE = $0CB4;

GL_PIXEL_MAP_I_TO_A_SIZE = $0CB5;

GL_PIXEL_MAP_R_TO_R_SIZE = $0CB6;

GL_PIXEL_MAP_G_TO_G_SIZE = $0CB7;

GL_PIXEL_MAP_B_TO_B_SIZE = $0CB8;

GL_PIXEL_MAP_A_TO_A_SIZE = $0CB9;

GL_MAP_COLOR = $0D10;

GL_MAP_STENCIL = $0D11;

GL_INDEX_SHIFT = $0D12;

GL_INDEX_OFFSET = $0D13;

GL_RED_SCALE = $0D14;

GL_RED_BIAS = $0D15;

GL_ZOOM_X = $0D16;

GL_ZOOM_Y = $0D17;

GL_GREEN_SCALE = $0D18;

GL_GREEN_BIAS = $0D19;

GL_BLUE_SCALE = $0D1A;

GL_BLUE_BIAS = $0D1B;

GL_ALPHA_SCALE = $0D1C;

GL_ALPHA_BIAS = $0D1D;

GL_DEPTH_SCALE = $0D1E;

GL_DEPTH_BIAS = $0D1F;

GL_MAX_EVAL_ORDER = $0D30;

GL_MAX_LIGHTS = $0D31;

GL_MAX_CLIP_PLANES = $0D32;

GL_MAX_PIXEL_MAP_TABLE = $0D34;

GL_MAX_ATTRIB_STACK_DEPTH = $0D35;

GL_MAX_MODELVIEW_STACK_DEPTH = $0D36;

GL_MAX_NAME_STACK_DEPTH = $0D37;

GL_MAX_PROJECTION_STACK_DEPTH = $0D38;

GL_MAX_TEXTURE_STACK_DEPTH = $0D39;

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH = $0D3B;

GL_INDEX_BITS = $0D51;

GL_RED_BITS = $0D52;

GL_GREEN_BITS = $0D53;

GL_BLUE_BITS = $0D54;

GL_ALPHA_BITS = $0D55;

GL_DEPTH_BITS = $0D56;

GL_STENCIL_BITS = $0D57;

GL_ACCUM_RED_BITS = $0D58;

GL_ACCUM_GREEN_BITS = $0D59;

GL_ACCUM_BLUE_BITS = $0D5A;

GL_ACCUM_ALPHA_BITS = $0D5B;

GL_NAME_STACK_DEPTH = $0D70;

GL_AUTO_NORMAL = $0D80;

GL_MAP1_COLOR_4 = $0D90;

GL_MAP1_INDEX = $0D91;

GL_MAP1_NORMAL = $0D92;

GL_MAP1_TEXTURE_COORD_1 = $0D93;

GL_MAP1_TEXTURE_COORD_2 = $0D94;

GL_MAP1_TEXTURE_COORD_3 = $0D95;

GL_MAP1_TEXTURE_COORD_4 = $0D96;

GL_MAP1_VERTEX_3 = $0D97;

GL_MAP1_VERTEX_4 = $0D98;

GL_MAP2_COLOR_4 = $0DB0;

GL_MAP2_INDEX = $0DB1;

GL_MAP2_NORMAL = $0DB2;

GL_MAP2_TEXTURE_COORD_1 = $0DB3;

GL_MAP2_TEXTURE_COORD_2 = $0DB4;

GL_MAP2_TEXTURE_COORD_3 = $0DB5;

GL_MAP2_TEXTURE_COORD_4 = $0DB6;

GL_MAP2_VERTEX_3 = $0DB7;

GL_MAP2_VERTEX_4 = $0DB8;

GL_MAP1_GRID_DOMAIN = $0DD0;

GL_MAP1_GRID_SEGMENTS = $0DD1;

GL_MAP2_GRID_DOMAIN = $0DD2;

GL_MAP2_GRID_SEGMENTS = $0DD3;

GL_FEEDBACK_BUFFER_POINTER = $0DF0;

GL_FEEDBACK_BUFFER_SIZE = $0DF1;

GL_FEEDBACK_BUFFER_TYPE = $0DF2;

GL_SELECTION_BUFFER_POINTER = $0DF3;

GL_SELECTION_BUFFER_SIZE = $0DF4;

GL_LIGHT0 = $4000;

GL_LIGHT1 = $4001;

GL_LIGHT2 = $4002;

GL_LIGHT3 = $4003;

GL_LIGHT4 = $4004;

GL_LIGHT5 = $4005;

GL_LIGHT6 = $4006;

GL_LIGHT7 = $4007;

GL_AMBIENT = $1200;

GL_DIFFUSE = $1201;

GL_SPECULAR = $1202;

GL_POSITION = $1203;

GL_SPOT_DIRECTION = $1204;

GL_SPOT_EXPONENT = $1205;

GL_SPOT_CUTOFF = $1206;

GL_CONSTANT_ATTENUATION = $1207;

GL_LINEAR_ATTENUATION = $1208;

GL_QUADRATIC_ATTENUATION = $1209;

GL_COMPILE = $1300;

GL_COMPILE_AND_EXECUTE = $1301;

GL_EMISSION = $1600;

GL_SHININESS = $1601;

GL_AMBIENT_AND_DIFFUSE = $1602;

GL_COLOR_INDEXES = $1603;

GL_MODELVIEW = $1700;

GL_PROJECTION = $1701;

GL_COLOR_INDEX = $1900;

GL_LUMINANCE = $1909;

GL_LUMINANCE_ALPHA = $190A;

GL_BITMAP = $1A00;

GL_RENDER = $1C00;

GL_FEEDBACK = $1C01;

GL_SELECT = $1C02;

GL_FLAT = $1D00;

GL_SMOOTH = $1D01;

GL_S = $2000;

GL_T = $2001;

GL_R = $2002;

GL_Q = $2003;

GL_MODULATE = $2100;

GL_DECAL = $2101;

GL_TEXTURE_ENV_MODE = $2200;

GL_TEXTURE_ENV_COLOR = $2201;

GL_TEXTURE_ENV = $2300;

GL_EYE_LINEAR = $2400;

GL_OBJECT_LINEAR = $2401;

GL_SPHERE_MAP = $2402;

GL_TEXTURE_GEN_MODE = $2500;

GL_OBJECT_PLANE = $2501;

GL_EYE_PLANE = $2502;

GL_CLAMP = $2900;

GL_CLIENT_PIXEL_STORE_BIT = $00000001;

GL_CLIENT_VERTEX_ARRAY_BIT = $00000002;

GL_CLIENT_ALL_ATTRIB_BITS = $FFFFFFFF;

GL_ALPHA4 = $803B;

GL_ALPHA8 = $803C;

GL_ALPHA12 = $803D;

GL_ALPHA16 = $803E;

GL_LUMINANCE4 = $803F;

GL_LUMINANCE8 = $8040;

GL_LUMINANCE12 = $8041;

GL_LUMINANCE16 = $8042;

GL_LUMINANCE4_ALPHA4 = $8043;

GL_LUMINANCE6_ALPHA2 = $8044;

GL_LUMINANCE8_ALPHA8 = $8045;

GL_LUMINANCE12_ALPHA4 = $8046;

GL_LUMINANCE12_ALPHA12 = $8047;

GL_LUMINANCE16_ALPHA16 = $8048;

GL_INTENSITY = $8049;

GL_INTENSITY4 = $804A;

GL_INTENSITY8 = $804B;

GL_INTENSITY12 = $804C;

GL_INTENSITY16 = $804D;

GL_TEXTURE_LUMINANCE_SIZE = $8060;

GL_TEXTURE_INTENSITY_SIZE = $8061;

GL_TEXTURE_PRIORITY = $8066;

GL_TEXTURE_RESIDENT = $8067;

GL_VERTEX_ARRAY = $8074;

GL_NORMAL_ARRAY = $8075;

GL_COLOR_ARRAY = $8076;

GL_INDEX_ARRAY = $8077;

GL_TEXTURE_COORD_ARRAY = $8078;

GL_EDGE_FLAG_ARRAY = $8079;

GL_VERTEX_ARRAY_SIZE = $807A;

GL_VERTEX_ARRAY_TYPE = $807B;

GL_VERTEX_ARRAY_STRIDE = $807C;

GL_NORMAL_ARRAY_TYPE = $807E;

GL_NORMAL_ARRAY_STRIDE = $807F;

GL_COLOR_ARRAY_SIZE = $8081;

GL_COLOR_ARRAY_TYPE = $8082;

GL_COLOR_ARRAY_STRIDE = $8083;

GL_INDEX_ARRAY_TYPE = $8085;

GL_INDEX_ARRAY_STRIDE = $8086;

GL_TEXTURE_COORD_ARRAY_SIZE = $8088;

GL_TEXTURE_COORD_ARRAY_TYPE = $8089;

GL_TEXTURE_COORD_ARRAY_STRIDE = $808A;

GL_EDGE_FLAG_ARRAY_STRIDE = $808C;

GL_VERTEX_ARRAY_POINTER = $808E;

GL_NORMAL_ARRAY_POINTER = $808F;

GL_COLOR_ARRAY_POINTER = $8090;

GL_INDEX_ARRAY_POINTER = $8091;

GL_TEXTURE_COORD_ARRAY_POINTER = $8092;

GL_EDGE_FLAG_ARRAY_POINTER = $8093;

GL_V2F = $2A20;

GL_V3F = $2A21;

GL_C4UB_V2F = $2A22;

GL_C4UB_V3F = $2A23;

GL_C3F_V3F = $2A24;

GL_N3F_V3F = $2A25;

GL_C4F_N3F_V3F = $2A26;

GL_T2F_V3F = $2A27;

GL_T4F_V4F = $2A28;

GL_T2F_C4UB_V3F = $2A29;

GL_T2F_C3F_V3F = $2A2A;

GL_T2F_N3F_V3F = $2A2B;

GL_T2F_C4F_N3F_V3F = $2A2C;

GL_T4F_C4F_N3F_V4F = $2A2D;

GL_COLOR_TABLE_FORMAT_EXT = $80D8;

GL_COLOR_TABLE_WIDTH_EXT = $80D9;

GL_COLOR_TABLE_RED_SIZE_EXT = $80DA;

GL_COLOR_TABLE_GREEN_SIZE_EXT = $80DB;

GL_COLOR_TABLE_BLUE_SIZE_EXT = $80DC;

GL_COLOR_TABLE_ALPHA_SIZE_EXT = $80DD;

GL_COLOR_TABLE_LUMINANCE_SIZE_EXT = $80DE;

GL_COLOR_TABLE_INTENSITY_SIZE_EXT = $80DF;

GL_LOGIC_OP = GL_INDEX_LOGIC_OP;

GL_TEXTURE_COMPONENTS = GL_TEXTURE_INTERNAL_FORMAT;

GL_UNSIGNED_BYTE_3_3_2 = $8032;

GL_UNSIGNED_SHORT_4_4_4_4 = $8033;

GL_UNSIGNED_SHORT_5_5_5_1 = $8034;

GL_UNSIGNED_INT_8_8_8_8 = $8035;

GL_UNSIGNED_INT_10_10_10_2 = $8036;

GL_TEXTURE_BINDING_3D = $806A;

GL_PACK_SKIP_IMAGES = $806B;

GL_PACK_IMAGE_HEIGHT = $806C;

GL_UNPACK_SKIP_IMAGES = $806D;

GL_UNPACK_IMAGE_HEIGHT = $806E;

GL_TEXTURE_3D = $806F;

GL_PROXY_TEXTURE_3D = $8070;

GL_TEXTURE_DEPTH = $8071;

GL_TEXTURE_WRAP_R = $8072;

GL_MAX_3D_TEXTURE_SIZE = $8073;

GL_UNSIGNED_BYTE_2_3_3_REV = $8362;

GL_UNSIGNED_SHORT_5_6_5 = $8363;

GL_UNSIGNED_SHORT_5_6_5_REV = $8364;

GL_UNSIGNED_SHORT_4_4_4_4_REV = $8365;

GL_UNSIGNED_SHORT_1_5_5_5_REV = $8366;

GL_UNSIGNED_INT_8_8_8_8_REV = $8367;

GL_UNSIGNED_INT_2_10_10_10_REV = $8368;

GL_BGR = $80E0;

GL_BGRA = $80E1;

GL_MAX_ELEMENTS_VERTICES = $80E8;

GL_MAX_ELEMENTS_INDICES = $80E9;

GL_CLAMP_TO_EDGE = $812F;

GL_TEXTURE_MIN_LOD = $813A;

GL_TEXTURE_MAX_LOD = $813B;

GL_TEXTURE_BASE_LEVEL = $813C;

GL_TEXTURE_MAX_LEVEL = $813D;

GL_SMOOTH_POINT_SIZE_RANGE = $0B12;

GL_SMOOTH_POINT_SIZE_GRANULARITY = $0B13;

GL_SMOOTH_LINE_WIDTH_RANGE = $0B22;

GL_SMOOTH_LINE_WIDTH_GRANULARITY = $0B23;

GL_ALIASED_LINE_WIDTH_RANGE = $846E;

GL_RESCALE_NORMAL = $803A;

GL_LIGHT_MODEL_COLOR_CONTROL = $81F8;

GL_SINGLE_COLOR = $81F9;

GL_SEPARATE_SPECULAR_COLOR = $81FA;

GL_ALIASED_POINT_SIZE_RANGE = $846D;

GL_TEXTURE0 = $84C0;

GL_TEXTURE1 = $84C1;

GL_TEXTURE2 = $84C2;

GL_TEXTURE3 = $84C3;

GL_TEXTURE4 = $84C4;

GL_TEXTURE5 = $84C5;

GL_TEXTURE6 = $84C6;

GL_TEXTURE7 = $84C7;

GL_TEXTURE8 = $84C8;

GL_TEXTURE9 = $84C9;

GL_TEXTURE10 = $84CA;

GL_TEXTURE11 = $84CB;

GL_TEXTURE12 = $84CC;

GL_TEXTURE13 = $84CD;

GL_TEXTURE14 = $84CE;

GL_TEXTURE15 = $84CF;

GL_TEXTURE16 = $84D0;

GL_TEXTURE17 = $84D1;

GL_TEXTURE18 = $84D2;

GL_TEXTURE19 = $84D3;

GL_TEXTURE20 = $84D4;

GL_TEXTURE21 = $84D5;

GL_TEXTURE22 = $84D6;

GL_TEXTURE23 = $84D7;

GL_TEXTURE24 = $84D8;

GL_TEXTURE25 = $84D9;

GL_TEXTURE26 = $84DA;

GL_TEXTURE27 = $84DB;

GL_TEXTURE28 = $84DC;

GL_TEXTURE29 = $84DD;

GL_TEXTURE30 = $84DE;

GL_TEXTURE31 = $84DF;

GL_ACTIVE_TEXTURE = $84E0;

GL_MULTISAMPLE = $809D;

GL_SAMPLE_ALPHA_TO_COVERAGE = $809E;

GL_SAMPLE_ALPHA_TO_ONE = $809F;

GL_SAMPLE_COVERAGE = $80A0;

GL_SAMPLE_BUFFERS = $80A8;

GL_SAMPLES = $80A9;

GL_SAMPLE_COVERAGE_VALUE = $80AA;

GL_SAMPLE_COVERAGE_INVERT = $80AB;

GL_TEXTURE_CUBE_MAP = $8513;

GL_TEXTURE_BINDING_CUBE_MAP = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z = $851A;

GL_PROXY_TEXTURE_CUBE_MAP = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE = $851C;

GL_COMPRESSED_RGB = $84ED;

GL_COMPRESSED_RGBA = $84EE;

GL_TEXTURE_COMPRESSION_HINT = $84EF;

GL_TEXTURE_COMPRESSED_IMAGE_SIZE = $86A0;

GL_TEXTURE_COMPRESSED = $86A1;

GL_NUM_COMPRESSED_TEXTURE_FORMATS = $86A2;

GL_COMPRESSED_TEXTURE_FORMATS = $86A3;

GL_CLAMP_TO_BORDER = $812D;

GL_CLIENT_ACTIVE_TEXTURE = $84E1;

GL_MAX_TEXTURE_UNITS = $84E2;

GL_TRANSPOSE_MODELVIEW_MATRIX = $84E3;

GL_TRANSPOSE_PROJECTION_MATRIX = $84E4;

GL_TRANSPOSE_TEXTURE_MATRIX = $84E5;

GL_TRANSPOSE_COLOR_MATRIX = $84E6;

GL_MULTISAMPLE_BIT = $20000000;

GL_NORMAL_MAP = $8511;

GL_REFLECTION_MAP = $8512;

GL_COMPRESSED_ALPHA = $84E9;

GL_COMPRESSED_LUMINANCE = $84EA;

GL_COMPRESSED_LUMINANCE_ALPHA = $84EB;

GL_COMPRESSED_INTENSITY = $84EC;

GL_COMBINE = $8570;

GL_COMBINE_RGB = $8571;

GL_COMBINE_ALPHA = $8572;

GL_SOURCE0_RGB = $8580;

GL_SOURCE1_RGB = $8581;

GL_SOURCE2_RGB = $8582;

GL_SOURCE0_ALPHA = $8588;

GL_SOURCE1_ALPHA = $8589;

GL_SOURCE2_ALPHA = $858A;

GL_OPERAND0_RGB = $8590;

GL_OPERAND1_RGB = $8591;

GL_OPERAND2_RGB = $8592;

GL_OPERAND0_ALPHA = $8598;

GL_OPERAND1_ALPHA = $8599;

GL_OPERAND2_ALPHA = $859A;

GL_RGB_SCALE = $8573;

GL_ADD_SIGNED = $8574;

GL_INTERPOLATE = $8575;

GL_SUBTRACT = $84E7;

GL_CONSTANT = $8576;

GL_PRIMARY_COLOR = $8577;

GL_PREVIOUS = $8578;

GL_DOT3_RGB = $86AE;

GL_DOT3_RGBA = $86AF;

GL_BLEND_DST_RGB = $80C8;

GL_BLEND_SRC_RGB = $80C9;

GL_BLEND_DST_ALPHA = $80CA;

GL_BLEND_SRC_ALPHA = $80CB;

GL_POINT_FADE_THRESHOLD_SIZE = $8128;

GL_DEPTH_COMPONENT16 = $81A5;

GL_DEPTH_COMPONENT24 = $81A6;

GL_DEPTH_COMPONENT32 = $81A7;

GL_MIRRORED_REPEAT = $8370;

GL_MAX_TEXTURE_LOD_BIAS = $84FD;

GL_TEXTURE_LOD_BIAS = $8501;

GL_INCR_WRAP = $8507;

GL_DECR_WRAP = $8508;

GL_TEXTURE_DEPTH_SIZE = $884A;

GL_TEXTURE_COMPARE_MODE = $884C;

GL_TEXTURE_COMPARE_FUNC = $884D;

GL_POINT_SIZE_MIN = $8126;

GL_POINT_SIZE_MAX = $8127;

GL_POINT_DISTANCE_ATTENUATION = $8129;

GL_GENERATE_MIPMAP = $8191;

GL_GENERATE_MIPMAP_HINT = $8192;

GL_FOG_COORDINATE_SOURCE = $8450;

GL_FOG_COORDINATE = $8451;

GL_FRAGMENT_DEPTH = $8452;

GL_CURRENT_FOG_COORDINATE = $8453;

GL_FOG_COORDINATE_ARRAY_TYPE = $8454;

GL_FOG_COORDINATE_ARRAY_STRIDE = $8455;

GL_FOG_COORDINATE_ARRAY_POINTER = $8456;

GL_FOG_COORDINATE_ARRAY = $8457;

GL_COLOR_SUM = $8458;

GL_CURRENT_SECONDARY_COLOR = $8459;

GL_SECONDARY_COLOR_ARRAY_SIZE = $845A;

GL_SECONDARY_COLOR_ARRAY_TYPE = $845B;

GL_SECONDARY_COLOR_ARRAY_STRIDE = $845C;

GL_SECONDARY_COLOR_ARRAY_POINTER = $845D;

GL_SECONDARY_COLOR_ARRAY = $845E;

GL_TEXTURE_FILTER_CONTROL = $8500;

GL_DEPTH_TEXTURE_MODE = $884B;

GL_COMPARE_R_TO_TEXTURE = $884E;

GL_BUFFER_SIZE = $8764;

GL_BUFFER_USAGE = $8765;

GL_QUERY_COUNTER_BITS = $8864;

GL_CURRENT_QUERY = $8865;

GL_QUERY_RESULT = $8866;

GL_QUERY_RESULT_AVAILABLE = $8867;

GL_ARRAY_BUFFER = $8892;

GL_ELEMENT_ARRAY_BUFFER = $8893;

GL_ARRAY_BUFFER_BINDING = $8894;

GL_ELEMENT_ARRAY_BUFFER_BINDING = $8895;

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING = $889F;

GL_READ_ONLY = $88B8;

GL_WRITE_ONLY = $88B9;

GL_READ_WRITE = $88BA;

GL_BUFFER_ACCESS = $88BB;

GL_BUFFER_MAPPED = $88BC;

GL_BUFFER_MAP_POINTER = $88BD;

GL_STREAM_DRAW = $88E0;

GL_STREAM_READ = $88E1;

GL_STREAM_COPY = $88E2;

GL_STATIC_DRAW = $88E4;

GL_STATIC_READ = $88E5;

GL_STATIC_COPY = $88E6;

GL_DYNAMIC_DRAW = $88E8;

GL_DYNAMIC_READ = $88E9;

GL_DYNAMIC_COPY = $88EA;

GL_SAMPLES_PASSED = $8914;

GL_VERTEX_ARRAY_BUFFER_BINDING = $8896;

GL_NORMAL_ARRAY_BUFFER_BINDING = $8897;

GL_COLOR_ARRAY_BUFFER_BINDING = $8898;

GL_INDEX_ARRAY_BUFFER_BINDING = $8899;

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING = $889A;

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING = $889B;

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING = $889C;

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING = $889D;

GL_WEIGHT_ARRAY_BUFFER_BINDING = $889E;

GL_FOG_COORD_SRC = $8450;

GL_FOG_COORD = $8451;

GL_CURRENT_FOG_COORD = $8453;

GL_FOG_COORD_ARRAY_TYPE = $8454;

GL_FOG_COORD_ARRAY_STRIDE = $8455;

GL_FOG_COORD_ARRAY_POINTER = $8456;

GL_FOG_COORD_ARRAY = $8457;

GL_FOG_COORD_ARRAY_BUFFER_BINDING = $889D;

GL_SRC0_RGB = $8580;

GL_SRC1_RGB = $8581;

GL_SRC2_RGB = $8582;

GL_SRC0_ALPHA = $8588;

GL_SRC1_ALPHA = $8589;

GL_SRC2_ALPHA = $858A;

GL_BLEND_EQUATION_RGB = $8009;

GL_VERTEX_ATTRIB_ARRAY_ENABLED = $8622;

GL_VERTEX_ATTRIB_ARRAY_SIZE = $8623;

GL_VERTEX_ATTRIB_ARRAY_STRIDE = $8624;

GL_VERTEX_ATTRIB_ARRAY_TYPE = $8625;

GL_CURRENT_VERTEX_ATTRIB = $8626;

GL_VERTEX_PROGRAM_POINT_SIZE = $8642;

GL_VERTEX_ATTRIB_ARRAY_POINTER = $8645;

GL_STENCIL_BACK_FUNC = $8800;

GL_STENCIL_BACK_FAIL = $8801;

GL_STENCIL_BACK_PASS_DEPTH_FAIL = $8802;

GL_STENCIL_BACK_PASS_DEPTH_PASS = $8803;

GL_MAX_DRAW_BUFFERS = $8824;

GL_DRAW_BUFFER0 = $8825;

GL_DRAW_BUFFER1 = $8826;

GL_DRAW_BUFFER2 = $8827;

GL_DRAW_BUFFER3 = $8828;

GL_DRAW_BUFFER4 = $8829;

GL_DRAW_BUFFER5 = $882A;

GL_DRAW_BUFFER6 = $882B;

GL_DRAW_BUFFER7 = $882C;

GL_DRAW_BUFFER8 = $882D;

GL_DRAW_BUFFER9 = $882E;

GL_DRAW_BUFFER10 = $882F;

GL_DRAW_BUFFER11 = $8830;

GL_DRAW_BUFFER12 = $8831;

GL_DRAW_BUFFER13 = $8832;

GL_DRAW_BUFFER14 = $8833;

GL_DRAW_BUFFER15 = $8834;

GL_BLEND_EQUATION_ALPHA = $883D;

GL_MAX_VERTEX_ATTRIBS = $8869;

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED = $886A;

GL_MAX_TEXTURE_IMAGE_UNITS = $8872;

GL_FRAGMENT_SHADER = $8B30;

GL_VERTEX_SHADER = $8B31;

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS = $8B49;

GL_MAX_VERTEX_UNIFORM_COMPONENTS = $8B4A;

GL_MAX_VARYING_FLOATS = $8B4B;

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = $8B4C;

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS = $8B4D;

GL_SHADER_TYPE = $8B4F;

GL_FLOAT_VEC2 = $8B50;

GL_FLOAT_VEC3 = $8B51;

GL_FLOAT_VEC4 = $8B52;

GL_INT_VEC2 = $8B53;

GL_INT_VEC3 = $8B54;

GL_INT_VEC4 = $8B55;

GL_BOOL = $8B56;

GL_BOOL_VEC2 = $8B57;

GL_BOOL_VEC3 = $8B58;

GL_BOOL_VEC4 = $8B59;

GL_FLOAT_MAT2 = $8B5A;

GL_FLOAT_MAT3 = $8B5B;

GL_FLOAT_MAT4 = $8B5C;

GL_SAMPLER_1D = $8B5D;

GL_SAMPLER_2D = $8B5E;

GL_SAMPLER_3D = $8B5F;

GL_SAMPLER_CUBE = $8B60;

GL_SAMPLER_1D_SHADOW = $8B61;

GL_SAMPLER_2D_SHADOW = $8B62;

GL_DELETE_STATUS = $8B80;

GL_COMPILE_STATUS = $8B81;

GL_LINK_STATUS = $8B82;

GL_VALIDATE_STATUS = $8B83;

GL_INFO_LOG_LENGTH = $8B84;

GL_ATTACHED_SHADERS = $8B85;

GL_ACTIVE_UNIFORMS = $8B86;

GL_ACTIVE_UNIFORM_MAX_LENGTH = $8B87;

GL_SHADER_SOURCE_LENGTH = $8B88;

GL_ACTIVE_ATTRIBUTES = $8B89;

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH = $8B8A;

GL_FRAGMENT_SHADER_DERIVATIVE_HINT = $8B8B;

GL_SHADING_LANGUAGE_VERSION = $8B8C;

GL_CURRENT_PROGRAM = $8B8D;

GL_POINT_SPRITE_COORD_ORIGIN = $8CA0;

GL_LOWER_LEFT = $8CA1;

GL_UPPER_LEFT = $8CA2;

GL_STENCIL_BACK_REF = $8CA3;

GL_STENCIL_BACK_VALUE_MASK = $8CA4;

GL_STENCIL_BACK_WRITEMASK = $8CA5;

GL_VERTEX_PROGRAM_TWO_SIDE = $8643;

GL_POINT_SPRITE = $8861;

GL_COORD_REPLACE = $8862;

GL_MAX_TEXTURE_COORDS = $8871;

GL_PIXEL_PACK_BUFFER = $88EB;

GL_PIXEL_UNPACK_BUFFER = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING = $88EF;

GL_FLOAT_MAT2x3 = $8B65;

GL_FLOAT_MAT2x4 = $8B66;

GL_FLOAT_MAT3x2 = $8B67;

GL_FLOAT_MAT3x4 = $8B68;

GL_FLOAT_MAT4x2 = $8B69;

GL_FLOAT_MAT4x3 = $8B6A;

GL_SRGB = $8C40;

GL_SRGB8 = $8C41;

GL_SRGB_ALPHA = $8C42;

GL_SRGB8_ALPHA8 = $8C43;

GL_COMPRESSED_SRGB = $8C48;

GL_COMPRESSED_SRGB_ALPHA = $8C49;

GL_CURRENT_RASTER_SECONDARY_COLOR = $845F;

GL_SLUMINANCE_ALPHA = $8C44;

GL_SLUMINANCE8_ALPHA8 = $8C45;

GL_SLUMINANCE = $8C46;

GL_SLUMINANCE8 = $8C47;

GL_COMPRESSED_SLUMINANCE = $8C4A;

GL_COMPRESSED_SLUMINANCE_ALPHA = $8C4B;

GL_COMPARE_REF_TO_TEXTURE = $884E;

GL_CLIP_DISTANCE0 = $3000;

GL_CLIP_DISTANCE1 = $3001;

GL_CLIP_DISTANCE2 = $3002;

GL_CLIP_DISTANCE3 = $3003;

GL_CLIP_DISTANCE4 = $3004;

GL_CLIP_DISTANCE5 = $3005;

GL_CLIP_DISTANCE6 = $3006;

GL_CLIP_DISTANCE7 = $3007;

GL_MAX_CLIP_DISTANCES = $0D32;

GL_MAJOR_VERSION = $821B;

GL_MINOR_VERSION = $821C;

GL_NUM_EXTENSIONS = $821D;

GL_CONTEXT_FLAGS = $821E;

GL_DEPTH_BUFFER = $8223;

GL_STENCIL_BUFFER = $8224;

GL_COMPRESSED_RED = $8225;

GL_COMPRESSED_RG = $8226;

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT = $0001;

GL_RGBA32F = $8814;

GL_RGB32F = $8815;

GL_RGBA16F = $881A;

GL_RGB16F = $881B;

GL_VERTEX_ATTRIB_ARRAY_INTEGER = $88FD;

GL_MAX_ARRAY_TEXTURE_LAYERS = $88FF;

GL_MIN_PROGRAM_TEXEL_OFFSET = $8904;

GL_MAX_PROGRAM_TEXEL_OFFSET = $8905;

GL_CLAMP_READ_COLOR = $891C;

GL_FIXED_ONLY = $891D;

GL_MAX_VARYING_COMPONENTS = $8B4B;

GL_TEXTURE_1D_ARRAY = $8C18;

GL_PROXY_TEXTURE_1D_ARRAY = $8C19;

GL_TEXTURE_2D_ARRAY = $8C1A;

GL_PROXY_TEXTURE_2D_ARRAY = $8C1B;

GL_TEXTURE_BINDING_1D_ARRAY = $8C1C;

GL_TEXTURE_BINDING_2D_ARRAY = $8C1D;

GL_R11F_G11F_B10F = $8C3A;

GL_UNSIGNED_INT_10F_11F_11F_REV = $8C3B;

GL_RGB9_E5 = $8C3D;

GL_UNSIGNED_INT_5_9_9_9_REV = $8C3E;

GL_TEXTURE_SHARED_SIZE = $8C3F;

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH = $8C76;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE = $8C7F;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS = $8C80;

GL_TRANSFORM_FEEDBACK_VARYINGS = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_START = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE = $8C85;

GL_PRIMITIVES_GENERATED = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN = $8C88;

GL_RASTERIZER_DISCARD = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS = $8C8B;

GL_INTERLEAVED_ATTRIBS = $8C8C;

GL_SEPARATE_ATTRIBS = $8C8D;

GL_TRANSFORM_FEEDBACK_BUFFER = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING = $8C8F;

GL_RGBA32UI = $8D70;

GL_RGB32UI = $8D71;

GL_RGBA16UI = $8D76;

GL_RGB16UI = $8D77;

GL_RGBA8UI = $8D7C;

GL_RGB8UI = $8D7D;

GL_RGBA32I = $8D82;

GL_RGB32I = $8D83;

GL_RGBA16I = $8D88;

GL_RGB16I = $8D89;

GL_RGBA8I = $8D8E;

GL_RGB8I = $8D8F;

GL_RED_INTEGER = $8D94;

GL_GREEN_INTEGER = $8D95;

GL_BLUE_INTEGER = $8D96;

GL_RGB_INTEGER = $8D98;

GL_RGBA_INTEGER = $8D99;

GL_BGR_INTEGER = $8D9A;

GL_BGRA_INTEGER = $8D9B;

GL_SAMPLER_1D_ARRAY = $8DC0;

GL_SAMPLER_2D_ARRAY = $8DC1;

GL_SAMPLER_1D_ARRAY_SHADOW = $8DC3;

GL_SAMPLER_2D_ARRAY_SHADOW = $8DC4;

GL_SAMPLER_CUBE_SHADOW = $8DC5;

GL_UNSIGNED_INT_VEC2 = $8DC6;

GL_UNSIGNED_INT_VEC3 = $8DC7;

GL_UNSIGNED_INT_VEC4 = $8DC8;

GL_INT_SAMPLER_1D = $8DC9;

GL_INT_SAMPLER_2D = $8DCA;

GL_INT_SAMPLER_3D = $8DCB;

GL_INT_SAMPLER_CUBE = $8DCC;

GL_INT_SAMPLER_1D_ARRAY = $8DCE;

GL_INT_SAMPLER_2D_ARRAY = $8DCF;

GL_UNSIGNED_INT_SAMPLER_1D = $8DD1;

GL_UNSIGNED_INT_SAMPLER_2D = $8DD2;

GL_UNSIGNED_INT_SAMPLER_3D = $8DD3;

GL_UNSIGNED_INT_SAMPLER_CUBE = $8DD4;

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY = $8DD6;

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY = $8DD7;

GL_QUERY_WAIT = $8E13;

GL_QUERY_NO_WAIT = $8E14;

GL_QUERY_BY_REGION_WAIT = $8E15;

GL_QUERY_BY_REGION_NO_WAIT = $8E16;

GL_BUFFER_ACCESS_FLAGS = $911F;

GL_BUFFER_MAP_LENGTH = $9120;

GL_BUFFER_MAP_OFFSET = $9121;

GL_CLAMP_VERTEX_COLOR = $891A;

GL_CLAMP_FRAGMENT_COLOR = $891B;

GL_ALPHA_INTEGER = $8D97;

GL_SAMPLER_2D_RECT = $8B63;

GL_SAMPLER_2D_RECT_SHADOW = $8B64;

GL_SAMPLER_BUFFER = $8DC2;

GL_INT_SAMPLER_2D_RECT = $8DCD;

GL_INT_SAMPLER_BUFFER = $8DD0;

GL_UNSIGNED_INT_SAMPLER_2D_RECT = $8DD5;

GL_UNSIGNED_INT_SAMPLER_BUFFER = $8DD8;

GL_TEXTURE_BUFFER = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE = $8C2B;

GL_TEXTURE_BINDING_BUFFER = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING = $8C2D;

GL_TEXTURE_BUFFER_FORMAT = $8C2E;

GL_TEXTURE_RECTANGLE = $84F5;

GL_TEXTURE_BINDING_RECTANGLE = $84F6;

GL_PROXY_TEXTURE_RECTANGLE = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE = $84F8;

GL_RED_SNORM = $8F90;

GL_RG_SNORM = $8F91;

GL_RGB_SNORM = $8F92;

GL_RGBA_SNORM = $8F93;

GL_R8_SNORM = $8F94;

GL_RG8_SNORM = $8F95;

GL_RGB8_SNORM = $8F96;

GL_RGBA8_SNORM = $8F97;

GL_R16_SNORM = $8F98;

GL_RG16_SNORM = $8F99;

GL_RGB16_SNORM = $8F9A;

GL_RGBA16_SNORM = $8F9B;

GL_SIGNED_NORMALIZED = $8F9C;

GL_PRIMITIVE_RESTART = $8F9D;

GL_PRIMITIVE_RESTART_INDEX = $8F9E;

GL_CONTEXT_CORE_PROFILE_BIT = $00000001;

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT = $00000002;

GL_LINES_ADJACENCY = $000A;

GL_LINE_STRIP_ADJACENCY = $000B;

GL_TRIANGLES_ADJACENCY = $000C;

GL_TRIANGLE_STRIP_ADJACENCY = $000D;

GL_PROGRAM_POINT_SIZE = $8642;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS = $8C29;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED = $8DA7;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS = $8DA8;

GL_GEOMETRY_SHADER = $8DD9;

GL_GEOMETRY_VERTICES_OUT = $8916;

GL_GEOMETRY_INPUT_TYPE = $8917;

GL_GEOMETRY_OUTPUT_TYPE = $8918;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS = $8DE1;

GL_MAX_VERTEX_OUTPUT_COMPONENTS = $9122;

GL_MAX_GEOMETRY_INPUT_COMPONENTS = $9123;

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS = $9124;

GL_MAX_FRAGMENT_INPUT_COMPONENTS = $9125;

GL_CONTEXT_PROFILE_MASK = $9126;

GL_VERTEX_ATTRIB_ARRAY_DIVISOR = $88FE;

GL_SAMPLE_SHADING = $8C36;

GL_MIN_SAMPLE_SHADING_VALUE = $8C37;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5F;

GL_TEXTURE_CUBE_MAP_ARRAY = $9009;

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY = $900A;

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY = $900B;

GL_SAMPLER_CUBE_MAP_ARRAY = $900C;

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW = $900D;

GL_INT_SAMPLER_CUBE_MAP_ARRAY = $900E;

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY = $900F;

GL_NUM_SHADING_LANGUAGE_VERSIONS = $82E9;

GL_VERTEX_ATTRIB_ARRAY_LONG = $874E;

GL_MULTISAMPLE_3DFX = $86B2;

GL_SAMPLE_BUFFERS_3DFX = $86B3;

GL_SAMPLES_3DFX = $86B4;

GL_MULTISAMPLE_BIT_3DFX = $20000000;

GL_COMPRESSED_RGB_FXT1_3DFX = $86B0;

GL_COMPRESSED_RGBA_FXT1_3DFX = $86B1;

GL_UNPACK_CLIENT_STORAGE_APPLE = $85B2;

GL_ELEMENT_ARRAY_APPLE = $8A0C;

GL_ELEMENT_ARRAY_TYPE_APPLE = $8A0D;

GL_ELEMENT_ARRAY_POINTER_APPLE = $8A0E;

GL_DRAW_PIXELS_APPLE = $8A0A;

GL_FENCE_APPLE = $8A0B;

GL_LIGHT_MODEL_SPECULAR_VECTOR_APPLE = $85B0;

GL_TRANSFORM_HINT_APPLE = $85B1;

GL_VERTEX_ARRAY_BINDING_APPLE = $85B5;

GL_VERTEX_ARRAY_RANGE_APPLE = $851D;

GL_VERTEX_ARRAY_RANGE_LENGTH_APPLE = $851E;

GL_VERTEX_ARRAY_STORAGE_HINT_APPLE = $851F;

GL_VERTEX_ARRAY_RANGE_POINTER_APPLE = $8521;

GL_STORAGE_CLIENT_APPLE = $85B4;

GL_STORAGE_CACHED_APPLE = $85BE;

GL_STORAGE_SHARED_APPLE = $85BF;

GL_YCBCR_422_APPLE = $85B9;

GL_UNSIGNED_SHORT_8_8_APPLE = $85BA;

GL_UNSIGNED_SHORT_8_8_REV_APPLE = $85BB;

GL_RGB_RAW_422_APPLE = $8A51;

GL_TEXTURE_RANGE_LENGTH_APPLE = $85B7;

GL_TEXTURE_RANGE_POINTER_APPLE = $85B8;

GL_TEXTURE_STORAGE_HINT_APPLE = $85BC;

GL_STORAGE_PRIVATE_APPLE = $85BD;

GL_HALF_APPLE = $140B;

GL_RGBA_FLOAT32_APPLE = $8814;

GL_RGB_FLOAT32_APPLE = $8815;

GL_ALPHA_FLOAT32_APPLE = $8816;

GL_INTENSITY_FLOAT32_APPLE = $8817;

GL_LUMINANCE_FLOAT32_APPLE = $8818;

GL_LUMINANCE_ALPHA_FLOAT32_APPLE = $8819;

GL_RGBA_FLOAT16_APPLE = $881A;

GL_RGB_FLOAT16_APPLE = $881B;

GL_ALPHA_FLOAT16_APPLE = $881C;

GL_INTENSITY_FLOAT16_APPLE = $881D;

GL_LUMINANCE_FLOAT16_APPLE = $881E;

GL_LUMINANCE_ALPHA_FLOAT16_APPLE = $881F;

GL_COLOR_FLOAT_APPLE = $8A0F;

GL_VERTEX_ATTRIB_MAP1_APPLE = $8A00;

GL_VERTEX_ATTRIB_MAP2_APPLE = $8A01;

GL_VERTEX_ATTRIB_MAP1_SIZE_APPLE = $8A02;

GL_VERTEX_ATTRIB_MAP1_COEFF_APPLE = $8A03;

GL_VERTEX_ATTRIB_MAP1_ORDER_APPLE = $8A04;

GL_VERTEX_ATTRIB_MAP1_DOMAIN_APPLE = $8A05;

GL_VERTEX_ATTRIB_MAP2_SIZE_APPLE = $8A06;

GL_VERTEX_ATTRIB_MAP2_COEFF_APPLE = $8A07;

GL_VERTEX_ATTRIB_MAP2_ORDER_APPLE = $8A08;

GL_VERTEX_ATTRIB_MAP2_DOMAIN_APPLE = $8A09;

GL_AUX_DEPTH_STENCIL_APPLE = $8A14;

GL_BUFFER_OBJECT_APPLE = $85B3;

GL_RELEASED_APPLE = $8A19;

GL_VOLATILE_APPLE = $8A1A;

GL_RETAINED_APPLE = $8A1B;

GL_UNDEFINED_APPLE = $8A1C;

GL_PURGEABLE_APPLE = $8A1D;

GL_PACK_ROW_BYTES_APPLE = $8A15;

GL_UNPACK_ROW_BYTES_APPLE = $8A16;

GL_DEPTH_COMPONENT16_ARB = $81A5;

GL_DEPTH_COMPONENT24_ARB = $81A6;

GL_DEPTH_COMPONENT32_ARB = $81A7;

GL_TEXTURE_DEPTH_SIZE_ARB = $884A;

GL_DEPTH_TEXTURE_MODE_ARB = $884B;

GL_FRAGMENT_PROGRAM_ARB = $8804;

GL_PROGRAM_ALU_INSTRUCTIONS_ARB = $8805;

GL_PROGRAM_TEX_INSTRUCTIONS_ARB = $8806;

GL_PROGRAM_TEX_INDIRECTIONS_ARB = $8807;

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $8808;

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $8809;

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $880A;

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB = $880B;

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB = $880C;

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB = $880D;

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $880E;

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $880F;

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $8810;

GL_MAX_TEXTURE_COORDS_ARB = $8871;

GL_MAX_TEXTURE_IMAGE_UNITS_ARB = $8872;

GL_CONSTANT_COLOR_ARB = $8001;

GL_ONE_MINUS_CONSTANT_COLOR = $8002;

GL_CONSTANT_ALPHA = $8003;

GL_ONE_MINUS_CONSTANT_ALPHA = $8004;

GL_BLEND_COLOR = $8005;

GL_FUNC_ADD = $8006;

GL_MIN = $8007;

GL_MAX = $8008;

GL_BLEND_EQUATION = $8009;

GL_FUNC_SUBTRACT = $800A;

GL_FUNC_REVERSE_SUBTRACT = $800B;

GL_CONVOLUTION_1D = $8010;

GL_CONVOLUTION_2D = $8011;

GL_SEPARABLE_2D = $8012;

GL_CONVOLUTION_BORDER_MODE = $8013;

GL_CONVOLUTION_FILTER_SCALE = $8014;

GL_CONVOLUTION_FILTER_BIAS = $8015;

GL_REDUCE = $8016;

GL_CONVOLUTION_FORMAT = $8017;

GL_CONVOLUTION_WIDTH = $8018;

GL_CONVOLUTION_HEIGHT = $8019;

GL_MAX_CONVOLUTION_WIDTH = $801A;

GL_MAX_CONVOLUTION_HEIGHT = $801B;

GL_POST_CONVOLUTION_RED_SCALE = $801C;

GL_POST_CONVOLUTION_GREEN_SCALE = $801D;

GL_POST_CONVOLUTION_BLUE_SCALE = $801E;

GL_POST_CONVOLUTION_ALPHA_SCALE = $801F;

GL_POST_CONVOLUTION_RED_BIAS = $8020;

GL_POST_CONVOLUTION_GREEN_BIAS = $8021;

GL_POST_CONVOLUTION_BLUE_BIAS = $8022;

GL_POST_CONVOLUTION_ALPHA_BIAS = $8023;

GL_HISTOGRAM = $8024;

GL_PROXY_HISTOGRAM = $8025;

GL_HISTOGRAM_WIDTH = $8026;

GL_HISTOGRAM_FORMAT = $8027;

GL_HISTOGRAM_RED_SIZE = $8028;

GL_HISTOGRAM_GREEN_SIZE = $8029;

GL_HISTOGRAM_BLUE_SIZE = $802A;

GL_HISTOGRAM_ALPHA_SIZE = $802B;

GL_HISTOGRAM_LUMINANCE_SIZE = $802C;

GL_HISTOGRAM_SINK = $802D;

GL_MINMAX = $802E;

GL_MINMAX_FORMAT = $802F;

GL_MINMAX_SINK = $8030;

GL_TABLE_TOO_LARGE = $8031;

GL_COLOR_MATRIX = $80B1;

GL_COLOR_MATRIX_STACK_DEPTH = $80B2;

GL_MAX_COLOR_MATRIX_STACK_DEPTH = $80B3;

GL_POST_COLOR_MATRIX_RED_SCALE = $80B4;

GL_POST_COLOR_MATRIX_GREEN_SCALE = $80B5;

GL_POST_COLOR_MATRIX_BLUE_SCALE = $80B6;

GL_POST_COLOR_MATRIX_ALPHA_SCALE = $80B7;

GL_POST_COLOR_MATRIX_RED_BIAS = $80B8;

GL_POST_COLOR_MATRIX_GREEN_BIAS = $80B9;

GL_POST_COLOR_MATRIX_BLUE_BIAS = $80BA;

GL_POST_COLOR_MATRIX_ALPHA_BIAS = $80BB;

GL_COLOR_TABLE = $80D0;

GL_POST_CONVOLUTION_COLOR_TABLE = $80D1;

GL_POST_COLOR_MATRIX_COLOR_TABLE = $80D2;

GL_PROXY_COLOR_TABLE = $80D3;

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE = $80D4;

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE = $80D5;

GL_COLOR_TABLE_SCALE = $80D6;

GL_COLOR_TABLE_BIAS = $80D7;

GL_COLOR_TABLE_FORMAT = $80D8;

GL_COLOR_TABLE_WIDTH = $80D9;

GL_COLOR_TABLE_RED_SIZE = $80DA;

GL_COLOR_TABLE_GREEN_SIZE = $80DB;

GL_COLOR_TABLE_BLUE_SIZE = $80DC;

GL_COLOR_TABLE_ALPHA_SIZE = $80DD;

GL_COLOR_TABLE_LUMINANCE_SIZE = $80DE;

GL_COLOR_TABLE_INTENSITY_SIZE = $80DF;

GL_CONSTANT_BORDER = $8151;

GL_REPLICATE_BORDER = $8153;

GL_CONVOLUTION_BORDER_COLOR = $8154;

GL_MATRIX_PALETTE_ARB = $8840;

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB = $8841;

GL_MAX_PALETTE_MATRICES_ARB = $8842;

GL_CURRENT_PALETTE_MATRIX_ARB = $8843;

GL_MATRIX_INDEX_ARRAY_ARB = $8844;

GL_CURRENT_MATRIX_INDEX_ARB = $8845;

GL_MATRIX_INDEX_ARRAY_SIZE_ARB = $8846;

GL_MATRIX_INDEX_ARRAY_TYPE_ARB = $8847;

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB = $8848;

GL_MATRIX_INDEX_ARRAY_POINTER_ARB = $8849;

GL_MULTISAMPLE_ARB = $809D;

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB = $809E;

GL_SAMPLE_ALPHA_TO_ONE_ARB = $809F;

GL_SAMPLE_COVERAGE_ARB = $80A0;

GL_SAMPLE_BUFFERS_ARB = $80A8;

GL_SAMPLES_ARB = $80A9;

GL_SAMPLE_COVERAGE_VALUE_ARB = $80AA;

GL_SAMPLE_COVERAGE_INVERT_ARB = $80AB;

GL_MULTISAMPLE_BIT_ARB = $20000000;

GL_TEXTURE0_ARB = $84C0;

GL_TEXTURE1_ARB = $84C1;

GL_TEXTURE2_ARB = $84C2;

GL_TEXTURE3_ARB = $84C3;

GL_TEXTURE4_ARB = $84C4;

GL_TEXTURE5_ARB = $84C5;

GL_TEXTURE6_ARB = $84C6;

GL_TEXTURE7_ARB = $84C7;

GL_TEXTURE8_ARB = $84C8;

GL_TEXTURE9_ARB = $84C9;

GL_TEXTURE10_ARB = $84CA;

GL_TEXTURE11_ARB = $84CB;

GL_TEXTURE12_ARB = $84CC;

GL_TEXTURE13_ARB = $84CD;

GL_TEXTURE14_ARB = $84CE;

GL_TEXTURE15_ARB = $84CF;

GL_TEXTURE16_ARB = $84D0;

GL_TEXTURE17_ARB = $84D1;

GL_TEXTURE18_ARB = $84D2;

GL_TEXTURE19_ARB = $84D3;

GL_TEXTURE20_ARB = $84D4;

GL_TEXTURE21_ARB = $84D5;

GL_TEXTURE22_ARB = $84D6;

GL_TEXTURE23_ARB = $84D7;

GL_TEXTURE24_ARB = $84D8;

GL_TEXTURE25_ARB = $84D9;

GL_TEXTURE26_ARB = $84DA;

GL_TEXTURE27_ARB = $84DB;

GL_TEXTURE28_ARB = $84DC;

GL_TEXTURE29_ARB = $84DD;

GL_TEXTURE30_ARB = $84DE;

GL_TEXTURE31_ARB = $84DF;

GL_ACTIVE_TEXTURE_ARB = $84E0;

GL_CLIENT_ACTIVE_TEXTURE_ARB = $84E1;

GL_MAX_TEXTURE_UNITS_ARB = $84E2;

GL_POINT_SIZE_MIN_ARB = $8126;

GL_POINT_SIZE_MAX_ARB = $8127;

GL_POINT_FADE_THRESHOLD_SIZE_ARB = $8128;

GL_POINT_DISTANCE_ATTENUATION_ARB = $8129;

GL_TEXTURE_COMPARE_MODE_ARB = $884C;

GL_TEXTURE_COMPARE_FUNC_ARB = $884D;

GL_COMPARE_R_TO_TEXTURE_ARB = $884E;

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB = $80BF;

GL_SPARSE_STORAGE_BIT_ARB = $0400;

GL_SPARSE_BUFFER_PAGE_SIZE_ARB = $82F8;

GL_CLAMP_TO_BORDER_ARB = $812D;

GL_COMPRESSED_ALPHA_ARB = $84E9;

GL_COMPRESSED_LUMINANCE_ARB = $84EA;

GL_COMPRESSED_LUMINANCE_ALPHA_ARB = $84EB;

GL_COMPRESSED_INTENSITY_ARB = $84EC;

GL_COMPRESSED_RGB_ARB = $84ED;

GL_COMPRESSED_RGBA_ARB = $84EE;

GL_TEXTURE_COMPRESSION_HINT_ARB = $84EF;

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB = $86A0;

GL_TEXTURE_COMPRESSED_ARB = $86A1;

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB = $86A2;

GL_COMPRESSED_TEXTURE_FORMATS_ARB = $86A3;

GL_NORMAL_MAP_ARB = $8511;

GL_REFLECTION_MAP_ARB = $8512;

GL_TEXTURE_CUBE_MAP_ARB = $8513;

GL_TEXTURE_BINDING_CUBE_MAP_ARB = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $851A;

GL_PROXY_TEXTURE_CUBE_MAP_ARB = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = $851C;

GL_COMBINE_ARB = $8570;

GL_COMBINE_RGB_ARB = $8571;

GL_COMBINE_ALPHA_ARB = $8572;

GL_SOURCE0_RGB_ARB = $8580;

GL_SOURCE1_RGB_ARB = $8581;

GL_SOURCE2_RGB_ARB = $8582;

GL_SOURCE0_ALPHA_ARB = $8588;

GL_SOURCE1_ALPHA_ARB = $8589;

GL_SOURCE2_ALPHA_ARB = $858A;

GL_OPERAND0_RGB_ARB = $8590;

GL_OPERAND1_RGB_ARB = $8591;

GL_OPERAND2_RGB_ARB = $8592;

GL_OPERAND0_ALPHA_ARB = $8598;

GL_OPERAND1_ALPHA_ARB = $8599;

GL_OPERAND2_ALPHA_ARB = $859A;

GL_RGB_SCALE_ARB = $8573;

GL_ADD_SIGNED_ARB = $8574;

GL_INTERPOLATE_ARB = $8575;

GL_SUBTRACT_ARB = $84E7;

GL_CONSTANT_ARB = $8576;

GL_PRIMARY_COLOR_ARB = $8577;

GL_PREVIOUS_ARB = $8578;

GL_DOT3_RGB_ARB = $86AE;

GL_DOT3_RGBA_ARB = $86AF;

GL_TEXTURE_REDUCTION_MODE_ARB = $9366;

GL_WEIGHTED_AVERAGE_ARB = $9367;

GL_MIRRORED_REPEAT_ARB = $8370;

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB = $84E3;

GL_TRANSPOSE_PROJECTION_MATRIX_ARB = $84E4;

GL_TRANSPOSE_TEXTURE_MATRIX_ARB = $84E5;

GL_TRANSPOSE_COLOR_MATRIX_ARB = $84E6;

GL_MAX_VERTEX_UNITS_ARB = $86A4;

GL_ACTIVE_VERTEX_UNITS_ARB = $86A5;

GL_WEIGHT_SUM_UNITY_ARB = $86A6;

GL_VERTEX_BLEND_ARB = $86A7;

GL_CURRENT_WEIGHT_ARB = $86A8;

GL_WEIGHT_ARRAY_TYPE_ARB = $86A9;

GL_WEIGHT_ARRAY_STRIDE_ARB = $86AA;

GL_WEIGHT_ARRAY_SIZE_ARB = $86AB;

GL_WEIGHT_ARRAY_POINTER_ARB = $86AC;

GL_WEIGHT_ARRAY_ARB = $86AD;

GL_MODELVIEW0_ARB = $1700;

GL_MODELVIEW1_ARB = $850A;

GL_MODELVIEW2_ARB = $8722;

GL_MODELVIEW3_ARB = $8723;

GL_MODELVIEW4_ARB = $8724;

GL_MODELVIEW5_ARB = $8725;

GL_MODELVIEW6_ARB = $8726;

GL_MODELVIEW7_ARB = $8727;

GL_MODELVIEW8_ARB = $8728;

GL_MODELVIEW9_ARB = $8729;

GL_MODELVIEW10_ARB = $872A;

GL_MODELVIEW11_ARB = $872B;

GL_MODELVIEW12_ARB = $872C;

GL_MODELVIEW13_ARB = $872D;

GL_MODELVIEW14_ARB = $872E;

GL_MODELVIEW15_ARB = $872F;

GL_MODELVIEW16_ARB = $8730;

GL_MODELVIEW17_ARB = $8731;

GL_MODELVIEW18_ARB = $8732;

GL_MODELVIEW19_ARB = $8733;

GL_MODELVIEW20_ARB = $8734;

GL_MODELVIEW21_ARB = $8735;

GL_MODELVIEW22_ARB = $8736;

GL_MODELVIEW23_ARB = $8737;

GL_MODELVIEW24_ARB = $8738;

GL_MODELVIEW25_ARB = $8739;

GL_MODELVIEW26_ARB = $873A;

GL_MODELVIEW27_ARB = $873B;

GL_MODELVIEW28_ARB = $873C;

GL_MODELVIEW29_ARB = $873D;

GL_MODELVIEW30_ARB = $873E;

GL_MODELVIEW31_ARB = $873F;

GL_BUFFER_SIZE_ARB = $8764;

GL_BUFFER_USAGE_ARB = $8765;

GL_ARRAY_BUFFER_ARB = $8892;

GL_ELEMENT_ARRAY_BUFFER_ARB = $8893;

GL_ARRAY_BUFFER_BINDING_ARB = $8894;

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB = $8895;

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB = $8896;

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB = $8897;

GL_COLOR_ARRAY_BUFFER_BINDING_ARB = $8898;

GL_INDEX_ARRAY_BUFFER_BINDING_ARB = $8899;

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB = $889A;

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB = $889B;

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB = $889C;

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB = $889D;

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB = $889E;

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB = $889F;

GL_READ_ONLY_ARB = $88B8;

GL_WRITE_ONLY_ARB = $88B9;

GL_READ_WRITE_ARB = $88BA;

GL_BUFFER_ACCESS_ARB = $88BB;

GL_BUFFER_MAPPED_ARB = $88BC;

GL_BUFFER_MAP_POINTER_ARB = $88BD;

GL_STREAM_DRAW_ARB = $88E0;

GL_STREAM_READ_ARB = $88E1;

GL_STREAM_COPY_ARB = $88E2;

GL_STATIC_DRAW_ARB = $88E4;

GL_STATIC_READ_ARB = $88E5;

GL_STATIC_COPY_ARB = $88E6;

GL_DYNAMIC_DRAW_ARB = $88E8;

GL_DYNAMIC_READ_ARB = $88E9;

GL_DYNAMIC_COPY_ARB = $88EA;

GL_COLOR_SUM_ARB = $8458;

GL_VERTEX_PROGRAM_ARB = $8620;

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB = $8622;

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB = $8623;

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB = $8624;

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB = $8625;

GL_CURRENT_VERTEX_ATTRIB_ARB = $8626;

GL_PROGRAM_LENGTH_ARB = $8627;

GL_PROGRAM_STRING_ARB = $8628;

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB = $862E;

GL_MAX_PROGRAM_MATRICES_ARB = $862F;

GL_CURRENT_MATRIX_STACK_DEPTH_ARB = $8640;

GL_CURRENT_MATRIX_ARB = $8641;

GL_VERTEX_PROGRAM_POINT_SIZE_ARB = $8642;

GL_VERTEX_PROGRAM_TWO_SIDE_ARB = $8643;

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB = $8645;

GL_PROGRAM_ERROR_POSITION_ARB = $864B;

GL_PROGRAM_BINDING_ARB = $8677;

GL_MAX_VERTEX_ATTRIBS_ARB = $8869;

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB = $886A;

GL_PROGRAM_ERROR_STRING_ARB = $8874;

GL_PROGRAM_FORMAT_ASCII_ARB = $8875;

GL_PROGRAM_FORMAT_ARB = $8876;

GL_PROGRAM_INSTRUCTIONS_ARB = $88A0;

GL_MAX_PROGRAM_INSTRUCTIONS_ARB = $88A1;

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A2;

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A3;

GL_PROGRAM_TEMPORARIES_ARB = $88A4;

GL_MAX_PROGRAM_TEMPORARIES_ARB = $88A5;

GL_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A6;

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A7;

GL_PROGRAM_PARAMETERS_ARB = $88A8;

GL_MAX_PROGRAM_PARAMETERS_ARB = $88A9;

GL_PROGRAM_NATIVE_PARAMETERS_ARB = $88AA;

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB = $88AB;

GL_PROGRAM_ATTRIBS_ARB = $88AC;

GL_MAX_PROGRAM_ATTRIBS_ARB = $88AD;

GL_PROGRAM_NATIVE_ATTRIBS_ARB = $88AE;

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB = $88AF;

GL_PROGRAM_ADDRESS_REGISTERS_ARB = $88B0;

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB = $88B1;

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B2;

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B3;

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB = $88B4;

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB = $88B5;

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB = $88B6;

GL_TRANSPOSE_CURRENT_MATRIX_ARB = $88B7;

GL_MATRIX0_ARB = $88C0;

GL_MATRIX1_ARB = $88C1;

GL_MATRIX2_ARB = $88C2;

GL_MATRIX3_ARB = $88C3;

GL_MATRIX4_ARB = $88C4;

GL_MATRIX5_ARB = $88C5;

GL_MATRIX6_ARB = $88C6;

GL_MATRIX7_ARB = $88C7;

GL_MATRIX8_ARB = $88C8;

GL_MATRIX9_ARB = $88C9;

GL_MATRIX10_ARB = $88CA;

GL_MATRIX11_ARB = $88CB;

GL_MATRIX12_ARB = $88CC;

GL_MATRIX13_ARB = $88CD;

GL_MATRIX14_ARB = $88CE;

GL_MATRIX15_ARB = $88CF;

GL_MATRIX16_ARB = $88D0;

GL_MATRIX17_ARB = $88D1;

GL_MATRIX18_ARB = $88D2;

GL_MATRIX19_ARB = $88D3;

GL_MATRIX20_ARB = $88D4;

GL_MATRIX21_ARB = $88D5;

GL_MATRIX22_ARB = $88D6;

GL_MATRIX23_ARB = $88D7;

GL_MATRIX24_ARB = $88D8;

GL_MATRIX25_ARB = $88D9;

GL_MATRIX26_ARB = $88DA;

GL_MATRIX27_ARB = $88DB;

GL_MATRIX28_ARB = $88DC;

GL_MATRIX29_ARB = $88DD;

GL_MATRIX30_ARB = $88DE;

GL_MATRIX31_ARB = $88DF;

GL_MAX_DRAW_BUFFERS_ARB = $8824;

GL_DRAW_BUFFER0_ARB = $8825;

GL_DRAW_BUFFER1_ARB = $8826;

GL_DRAW_BUFFER2_ARB = $8827;

GL_DRAW_BUFFER3_ARB = $8828;

GL_DRAW_BUFFER4_ARB = $8829;

GL_DRAW_BUFFER5_ARB = $882A;

GL_DRAW_BUFFER6_ARB = $882B;

GL_DRAW_BUFFER7_ARB = $882C;

GL_DRAW_BUFFER8_ARB = $882D;

GL_DRAW_BUFFER9_ARB = $882E;

GL_DRAW_BUFFER10_ARB = $882F;

GL_DRAW_BUFFER11_ARB = $8830;

GL_DRAW_BUFFER12_ARB = $8831;

GL_DRAW_BUFFER13_ARB = $8832;

GL_DRAW_BUFFER14_ARB = $8833;

GL_DRAW_BUFFER15_ARB = $8834;

GL_TEXTURE_RECTANGLE_ARB = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_ARB = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_ARB = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB = $84F8;

GL_RGBA_FLOAT_MODE_ARB = $8820;

GL_CLAMP_VERTEX_COLOR_ARB = $891A;

GL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

GL_CLAMP_READ_COLOR_ARB = $891C;

GL_FIXED_ONLY_ARB = $891D;

WGL_TYPE_RGBA_FLOAT_ARB = $21A0;

GLX_RGBA_FLOAT_TYPE = $20B9;

GLX_RGBA_FLOAT_BIT = $00000004;

GL_MAX_COMPUTE_VARIABLE_GROUP_INVOCATIONS_ARB = $9344;

GL_MAX_COMPUTE_FIXED_GROUP_INVOCATIONS_ARB = $90EB;

GL_MAX_COMPUTE_VARIABLE_GROUP_SIZE_ARB = $9345;

GL_MAX_COMPUTE_FIXED_GROUP_SIZE_ARB = $91BF;

GL_HALF_FLOAT_ARB = $140B;

GL_TEXTURE_RED_TYPE_ARB = $8C10;

GL_TEXTURE_GREEN_TYPE_ARB = $8C11;

GL_TEXTURE_BLUE_TYPE_ARB = $8C12;

GL_TEXTURE_ALPHA_TYPE_ARB = $8C13;

GL_TEXTURE_LUMINANCE_TYPE_ARB = $8C14;

GL_TEXTURE_INTENSITY_TYPE_ARB = $8C15;

GL_TEXTURE_DEPTH_TYPE_ARB = $8C16;

GL_UNSIGNED_NORMALIZED_ARB = $8C17;

GL_RGBA32F_ARB = $8814;

GL_RGB32F_ARB = $8815;

GL_ALPHA32F_ARB = $8816;

GL_INTENSITY32F_ARB = $8817;

GL_LUMINANCE32F_ARB = $8818;

GL_LUMINANCE_ALPHA32F_ARB = $8819;

GL_RGBA16F_ARB = $881A;

GL_RGB16F_ARB = $881B;

GL_ALPHA16F_ARB = $881C;

GL_INTENSITY16F_ARB = $881D;

GL_LUMINANCE16F_ARB = $881E;

GL_LUMINANCE_ALPHA16F_ARB = $881F;

GL_PIXEL_PACK_BUFFER_ARB = $88EB;

GL_PIXEL_UNPACK_BUFFER_ARB = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING_ARB = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB = $88EF;

GL_DEPTH_COMPONENT32F = $8CAC;

GL_DEPTH32F_STENCIL8 = $8CAD;

GL_FLOAT_32_UNSIGNED_INT_24_8_REV = $8DAD;

GL_INVALID_FRAMEBUFFER_OPERATION = $0506;

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING = $8210;

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE = $8211;

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE = $8212;

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE = $8213;

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE = $8214;

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE = $8215;

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE = $8216;

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE = $8217;

GL_FRAMEBUFFER_DEFAULT = $8218;

GL_FRAMEBUFFER_UNDEFINED = $8219;

GL_DEPTH_STENCIL_ATTACHMENT = $821A;

GL_MAX_RENDERBUFFER_SIZE = $84E8;

GL_DEPTH_STENCIL = $84F9;

GL_UNSIGNED_INT_24_8 = $84FA;

GL_DEPTH24_STENCIL8 = $88F0;

GL_TEXTURE_STENCIL_SIZE = $88F1;

GL_TEXTURE_RED_TYPE = $8C10;

GL_TEXTURE_GREEN_TYPE = $8C11;

GL_TEXTURE_BLUE_TYPE = $8C12;

GL_TEXTURE_ALPHA_TYPE = $8C13;

GL_TEXTURE_DEPTH_TYPE = $8C16;

GL_UNSIGNED_NORMALIZED = $8C17;

GL_FRAMEBUFFER_BINDING = $8CA6;

GL_DRAW_FRAMEBUFFER_BINDING = GL_FRAMEBUFFER_BINDING;

GL_RENDERBUFFER_BINDING = $8CA7;

GL_READ_FRAMEBUFFER = $8CA8;

GL_DRAW_FRAMEBUFFER = $8CA9;

GL_READ_FRAMEBUFFER_BINDING = $8CAA;

GL_RENDERBUFFER_SAMPLES = $8CAB;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE = $8CD0;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME = $8CD1;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL = $8CD2;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE = $8CD3;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER = $8CD4;

GL_FRAMEBUFFER_COMPLETE = $8CD5;

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT = $8CD6;

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT = $8CD7;

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER = $8CDB;

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER = $8CDC;

GL_FRAMEBUFFER_UNSUPPORTED = $8CDD;

GL_MAX_COLOR_ATTACHMENTS = $8CDF;

GL_COLOR_ATTACHMENT0 = $8CE0;

GL_COLOR_ATTACHMENT1 = $8CE1;

GL_COLOR_ATTACHMENT2 = $8CE2;

GL_COLOR_ATTACHMENT3 = $8CE3;

GL_COLOR_ATTACHMENT4 = $8CE4;

GL_COLOR_ATTACHMENT5 = $8CE5;

GL_COLOR_ATTACHMENT6 = $8CE6;

GL_COLOR_ATTACHMENT7 = $8CE7;

GL_COLOR_ATTACHMENT8 = $8CE8;

GL_COLOR_ATTACHMENT9 = $8CE9;

GL_COLOR_ATTACHMENT10 = $8CEA;

GL_COLOR_ATTACHMENT11 = $8CEB;

GL_COLOR_ATTACHMENT12 = $8CEC;

GL_COLOR_ATTACHMENT13 = $8CED;

GL_COLOR_ATTACHMENT14 = $8CEE;

GL_COLOR_ATTACHMENT15 = $8CEF;

GL_DEPTH_ATTACHMENT = $8D00;

GL_STENCIL_ATTACHMENT = $8D20;

GL_FRAMEBUFFER = $8D40;

GL_RENDERBUFFER = $8D41;

GL_RENDERBUFFER_WIDTH = $8D42;

GL_RENDERBUFFER_HEIGHT = $8D43;

GL_RENDERBUFFER_INTERNAL_FORMAT = $8D44;

GL_STENCIL_INDEX1 = $8D46;

GL_STENCIL_INDEX4 = $8D47;

GL_STENCIL_INDEX8 = $8D48;

GL_STENCIL_INDEX16 = $8D49;

GL_RENDERBUFFER_RED_SIZE = $8D50;

GL_RENDERBUFFER_GREEN_SIZE = $8D51;

GL_RENDERBUFFER_BLUE_SIZE = $8D52;

GL_RENDERBUFFER_ALPHA_SIZE = $8D53;

GL_RENDERBUFFER_DEPTH_SIZE = $8D54;

GL_RENDERBUFFER_STENCIL_SIZE = $8D55;

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE = $8D56;

GL_MAX_SAMPLES = $8D57;

GL_INDEX = $8222;

GL_TEXTURE_LUMINANCE_TYPE = $8C14;

GL_TEXTURE_INTENSITY_TYPE = $8C15;

GL_FRAMEBUFFER_SRGB = $8DB9;

GL_LINES_ADJACENCY_ARB = $000A;

GL_LINE_STRIP_ADJACENCY_ARB = $000B;

GL_TRIANGLES_ADJACENCY_ARB = $000C;

GL_TRIANGLE_STRIP_ADJACENCY_ARB = $000D;

GL_PROGRAM_POINT_SIZE_ARB = $8642;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB = $8C29;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB = $8DA7;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB = $8DA8;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB = $8DA9;

GL_GEOMETRY_SHADER_ARB = $8DD9;

GL_GEOMETRY_VERTICES_OUT_ARB = $8DDA;

GL_GEOMETRY_INPUT_TYPE_ARB = $8DDB;

GL_GEOMETRY_OUTPUT_TYPE_ARB = $8DDC;

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB = $8DDD;

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB = $8DDE;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB = $8DE1;

GL_SHADER_BINARY_FORMAT_SPIR_V_ARB = $9551;

GL_SPIR_V_BINARY_ARB = $9552;

GL_HALF_FLOAT = $140B;

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB = $88FE;

GL_MAP_READ_BIT = $0001;

GL_MAP_WRITE_BIT = $0002;

GL_MAP_INVALIDATE_RANGE_BIT = $0004;

GL_MAP_INVALIDATE_BUFFER_BIT = $0008;

GL_MAP_FLUSH_EXPLICIT_BIT = $0010;

GL_MAP_UNSYNCHRONIZED_BIT = $0020;

GL_TEXTURE_BUFFER_ARB = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE_ARB = $8C2B;

GL_TEXTURE_BINDING_BUFFER_ARB = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB = $8C2D;

GL_TEXTURE_BUFFER_FORMAT_ARB = $8C2E;

GL_COMPRESSED_RED_RGTC1 = $8DBB;

GL_COMPRESSED_SIGNED_RED_RGTC1 = $8DBC;

GL_COMPRESSED_RG_RGTC2 = $8DBD;

GL_COMPRESSED_SIGNED_RG_RGTC2 = $8DBE;

GL_RG = $8227;

GL_RG_INTEGER = $8228;

GL_R8 = $8229;

GL_R16 = $822A;

GL_RG8 = $822B;

GL_RG16 = $822C;

GL_R16F = $822D;

GL_R32F = $822E;

GL_RG16F = $822F;

GL_RG32F = $8230;

GL_R8I = $8231;

GL_R8UI = $8232;

GL_R16I = $8233;

GL_R16UI = $8234;

GL_R32I = $8235;

GL_R32UI = $8236;

GL_RG8I = $8237;

GL_RG8UI = $8238;

GL_RG16I = $8239;

GL_RG16UI = $823A;

GL_RG32I = $823B;

GL_RG32UI = $823C;

GL_VERTEX_ARRAY_BINDING = $85B5;

GL_UNIFORM_BUFFER = $8A11;

GL_UNIFORM_BUFFER_BINDING = $8A28;

GL_UNIFORM_BUFFER_START = $8A29;

GL_UNIFORM_BUFFER_SIZE = $8A2A;

GL_MAX_VERTEX_UNIFORM_BLOCKS = $8A2B;

GL_MAX_GEOMETRY_UNIFORM_BLOCKS = $8A2C;

GL_MAX_FRAGMENT_UNIFORM_BLOCKS = $8A2D;

GL_MAX_COMBINED_UNIFORM_BLOCKS = $8A2E;

GL_MAX_UNIFORM_BUFFER_BINDINGS = $8A2F;

GL_MAX_UNIFORM_BLOCK_SIZE = $8A30;

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS = $8A31;

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS = $8A32;

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS = $8A33;

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT = $8A34;

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH = $8A35;

GL_ACTIVE_UNIFORM_BLOCKS = $8A36;

GL_UNIFORM_TYPE = $8A37;

GL_UNIFORM_SIZE = $8A38;

GL_UNIFORM_NAME_LENGTH = $8A39;

GL_UNIFORM_BLOCK_INDEX = $8A3A;

GL_UNIFORM_OFFSET = $8A3B;

GL_UNIFORM_ARRAY_STRIDE = $8A3C;

GL_UNIFORM_MATRIX_STRIDE = $8A3D;

GL_UNIFORM_IS_ROW_MAJOR = $8A3E;

GL_UNIFORM_BLOCK_BINDING = $8A3F;

GL_UNIFORM_BLOCK_DATA_SIZE = $8A40;

GL_UNIFORM_BLOCK_NAME_LENGTH = $8A41;

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS = $8A42;

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES = $8A43;

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER = $8A44;

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER = $8A45;

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER = $8A46;

GL_INVALID_INDEX = $FFFFFFFF;

GL_COPY_READ_BUFFER_BINDING = $8F36;

GL_COPY_READ_BUFFER = GL_COPY_READ_BUFFER_BINDING;

GL_COPY_WRITE_BUFFER_BINDING = $8F37;

GL_COPY_WRITE_BUFFER = GL_COPY_WRITE_BUFFER_BINDING;

GL_DEPTH_CLAMP = $864F;

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION = $8E4C;

GL_FIRST_VERTEX_CONVENTION = $8E4D;

GL_LAST_VERTEX_CONVENTION = $8E4E;

GL_PROVOKING_VERTEX = $8E4F;

GL_TEXTURE_CUBE_MAP_SEAMLESS = $884F;

GL_MAX_SERVER_WAIT_TIMEOUT = $9111;

GL_OBJECT_TYPE = $9112;

GL_SYNC_CONDITION = $9113;

GL_SYNC_STATUS = $9114;

GL_SYNC_FLAGS = $9115;

GL_SYNC_FENCE = $9116;

GL_SYNC_GPU_COMMANDS_COMPLETE = $9117;

GL_UNSIGNALED = $9118;

GL_SIGNALED = $9119;

GL_ALREADY_SIGNALED = $911A;

GL_TIMEOUT_EXPIRED = $911B;

GL_CONDITION_SATISFIED = $911C;

GL_WAIT_FAILED = $911D;

GL_SYNC_FLUSH_COMMANDS_BIT = $00000001;

GL_TIMEOUT_IGNORED = $FFFFFFFFFFFFFFFF;

GL_SAMPLE_POSITION = $8E50;

GL_SAMPLE_MASK = $8E51;

GL_SAMPLE_MASK_VALUE = $8E52;

GL_MAX_SAMPLE_MASK_WORDS = $8E59;

GL_TEXTURE_2D_MULTISAMPLE = $9100;

GL_PROXY_TEXTURE_2D_MULTISAMPLE = $9101;

GL_TEXTURE_2D_MULTISAMPLE_ARRAY = $9102;

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY = $9103;

GL_TEXTURE_BINDING_2D_MULTISAMPLE = $9104;

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY = $9105;

GL_TEXTURE_SAMPLES = $9106;

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS = $9107;

GL_SAMPLER_2D_MULTISAMPLE = $9108;

GL_INT_SAMPLER_2D_MULTISAMPLE = $9109;

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE = $910A;

GL_SAMPLER_2D_MULTISAMPLE_ARRAY = $910B;

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910C;

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910D;

GL_MAX_COLOR_TEXTURE_SAMPLES = $910E;

GL_MAX_DEPTH_TEXTURE_SAMPLES = $910F;

GL_MAX_INTEGER_SAMPLES = $9110;

GL_SAMPLE_SHADING_ARB = $8C36;

GL_MIN_SAMPLE_SHADING_VALUE_ARB = $8C37;

GL_SAMPLE_LOCATION_SUBPIXEL_BITS_ARB = $933D;

GL_SAMPLE_LOCATION_PIXEL_GRID_WIDTH_ARB = $933E;

GL_SAMPLE_LOCATION_PIXEL_GRID_HEIGHT_ARB = $933F;

GL_PROGRAMMABLE_SAMPLE_LOCATION_TABLE_SIZE_ARB = $9340;

GL_SAMPLE_LOCATION_ARB = $8E50;

GL_PROGRAMMABLE_SAMPLE_LOCATION_ARB = $9341;

GL_FRAMEBUFFER_PROGRAMMABLE_SAMPLE_LOCATIONS_ARB = $9342;

GL_FRAMEBUFFER_SAMPLE_LOCATION_PIXEL_GRID_ARB = $9343;

GL_TEXTURE_CUBE_MAP_ARRAY_ARB = $9009;

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB = $900A;

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB = $900B;

GL_SAMPLER_CUBE_MAP_ARRAY_ARB = $900C;

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB = $900D;

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900E;

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900F;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5F;

GL_SHADER_INCLUDE_ARB = $8DAE;

GL_NAMED_STRING_LENGTH_ARB = $8DE9;

GL_NAMED_STRING_TYPE_ARB = $8DEA;

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB = $8E8C;

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB = $8E8D;

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB = $8E8E;

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB = $8E8F;

GL_SRC1_COLOR = $88F9;

GL_ONE_MINUS_SRC1_COLOR = $88FA;

GL_ONE_MINUS_SRC1_ALPHA = $88FB;

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS = $88FC;

GL_ANY_SAMPLES_PASSED = $8C2F;

GL_MAX_SHADER_COMPILER_THREADS_ARB = $91B0;

GL_COMPLETION_STATUS_ARB = $91B1;

GL_SAMPLER_BINDING = $8919;

GL_RGB10_A2UI = $906F;

GL_TEXTURE_SWIZZLE_R = $8E42;

GL_TEXTURE_SWIZZLE_G = $8E43;

GL_TEXTURE_SWIZZLE_B = $8E44;

GL_TEXTURE_SWIZZLE_A = $8E45;

GL_TEXTURE_SWIZZLE_RGBA = $8E46;

GL_TEXTURE_SPARSE_ARB = $91A6;

GL_VIRTUAL_PAGE_SIZE_INDEX_ARB = $91A7;

GL_NUM_VIRTUAL_PAGE_SIZES_ARB = $91A8;

GL_SPARSE_TEXTURE_FULL_ARRAY_CUBE_MIPMAPS_ARB = $91A9;

GL_NUM_SPARSE_LEVELS_ARB = $91AA;

GL_VIRTUAL_PAGE_SIZE_X_ARB = $9195;

GL_VIRTUAL_PAGE_SIZE_Y_ARB = $9196;

GL_VIRTUAL_PAGE_SIZE_Z_ARB = $9197;

GL_MAX_SPARSE_TEXTURE_SIZE_ARB = $9198;

GL_MAX_SPARSE_3D_TEXTURE_SIZE_ARB = $9199;

GL_MAX_SPARSE_ARRAY_TEXTURE_LAYERS_ARB = $919A;

GL_MIN_SPARSE_LEVEL_ARB = $919B;

GL_TIME_ELAPSED = $88BF;

GL_TIMESTAMP = $8E28;

GL_INT_2_10_10_10_REV = $8D9F;

GL_DRAW_INDIRECT_BUFFER = $8F3F;

GL_DRAW_INDIRECT_BUFFER_BINDING = $8F43;

GL_GEOMETRY_SHADER_INVOCATIONS = $887F;

GL_MAX_GEOMETRY_SHADER_INVOCATIONS = $8E5A;

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET = $8E5B;

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET = $8E5C;

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS = $8E5D;

GL_DOUBLE_VEC2 = $8FFC;

GL_DOUBLE_VEC3 = $8FFD;

GL_DOUBLE_VEC4 = $8FFE;

GL_DOUBLE_MAT2 = $8F46;

GL_DOUBLE_MAT3 = $8F47;

GL_DOUBLE_MAT4 = $8F48;

GL_DOUBLE_MAT2x3 = $8F49;

GL_DOUBLE_MAT2x4 = $8F4A;

GL_DOUBLE_MAT3x2 = $8F4B;

GL_DOUBLE_MAT3x4 = $8F4C;

GL_DOUBLE_MAT4x2 = $8F4D;

GL_DOUBLE_MAT4x3 = $8F4E;

GL_INT64_ARB = $140E;

GL_INT64_VEC2_ARB = $8FE9;

GL_INT64_VEC3_ARB = $8FEA;

GL_INT64_VEC4_ARB = $8FEB;

GL_UNSIGNED_INT64_VEC2_ARB = $8FF5;

GL_UNSIGNED_INT64_VEC3_ARB = $8FF6;

GL_UNSIGNED_INT64_VEC4_ARB = $8FF7;

GL_ACTIVE_SUBROUTINES = $8DE5;

GL_ACTIVE_SUBROUTINE_UNIFORMS = $8DE6;

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS = $8E47;

GL_ACTIVE_SUBROUTINE_MAX_LENGTH = $8E48;

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH = $8E49;

GL_MAX_SUBROUTINES = $8DE7;

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS = $8DE8;

GL_NUM_COMPATIBLE_SUBROUTINES = $8E4A;

GL_COMPATIBLE_SUBROUTINES = $8E4B;

GL_PATCHES = $000E;

GL_PATCH_VERTICES = $8E72;

GL_PATCH_DEFAULT_INNER_LEVEL = $8E73;

GL_PATCH_DEFAULT_OUTER_LEVEL = $8E74;

GL_TESS_CONTROL_OUTPUT_VERTICES = $8E75;

GL_TESS_GEN_MODE = $8E76;

GL_TESS_GEN_SPACING = $8E77;

GL_TESS_GEN_VERTEX_ORDER = $8E78;

GL_TESS_GEN_POINT_MODE = $8E79;

GL_ISOLINES = $8E7A;

GL_FRACTIONAL_ODD = $8E7B;

GL_FRACTIONAL_EVEN = $8E7C;

GL_MAX_PATCH_VERTICES = $8E7D;

GL_MAX_TESS_GEN_LEVEL = $8E7E;

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS = $8E7F;

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E80;

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS = $8E81;

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS = $8E82;

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS = $8E83;

GL_MAX_TESS_PATCH_COMPONENTS = $8E84;

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS = $8E85;

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS = $8E86;

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS = $8E89;

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS = $8E8A;

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS = $886C;

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS = $886D;

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS = $8E1E;

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E1F;

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER = $84F0;

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER = $84F1;

GL_TESS_EVALUATION_SHADER = $8E87;

GL_TESS_CONTROL_SHADER = $8E88;

GL_TRANSFORM_FEEDBACK = $8E22;

GL_TRANSFORM_FEEDBACK_PAUSED = $8E23;

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED = GL_TRANSFORM_FEEDBACK_PAUSED;

GL_TRANSFORM_FEEDBACK_ACTIVE = $8E24;

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE = GL_TRANSFORM_FEEDBACK_ACTIVE;

GL_TRANSFORM_FEEDBACK_BINDING = $8E25;

GL_TRANSFORM_FEEDBACK_OVERFLOW_ARB = $82EC;

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW_ARB = $82ED;

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS = $8E70;

GL_MAX_VERTEX_STREAMS = $8E71;

GL_FIXED = $140C;

GL_IMPLEMENTATION_COLOR_READ_TYPE = $8B9A;

GL_IMPLEMENTATION_COLOR_READ_FORMAT = $8B9B;

GL_LOW_FLOAT = $8DF0;

GL_MEDIUM_FLOAT = $8DF1;

GL_HIGH_FLOAT = $8DF2;

GL_LOW_INT = $8DF3;

GL_MEDIUM_INT = $8DF4;

GL_HIGH_INT = $8DF5;

GL_SHADER_COMPILER = $8DFA;

GL_NUM_SHADER_BINARY_FORMATS = $8DF9;

GL_MAX_VERTEX_UNIFORM_VECTORS = $8DFB;

GL_MAX_VARYING_VECTORS = $8DFC;

GL_MAX_FRAGMENT_UNIFORM_VECTORS = $8DFD;

GL_RGB565 = $8D62;

GL_PRIMITIVE_BOUNDING_BOX_ARB = $092BE;

GL_MULTISAMPLE_LINE_WIDTH_RANGE_ARB = $09381;

GL_MULTISAMPLE_LINE_WIDTH_GRANULARITY_ARB = $09382;

GL_PROGRAM_BINARY_RETRIEVABLE_HINT = $8257;

GL_PROGRAM_BINARY_LENGTH = $8741;

GL_NUM_PROGRAM_BINARY_FORMATS = $87FE;

GL_PROGRAM_BINARY_FORMATS = $87FF;

GL_VERTEX_SHADER_BIT = $00000001;

GL_FRAGMENT_SHADER_BIT = $00000002;

GL_GEOMETRY_SHADER_BIT = $00000004;

GL_TESS_CONTROL_SHADER_BIT = $00000008;

GL_TESS_EVALUATION_SHADER_BIT = $00000010;

GL_ALL_SHADER_BITS = $FFFFFFFF;

GL_PROGRAM_SEPARABLE = $8258;

GL_ACTIVE_PROGRAM = $8259;

GL_PROGRAM_PIPELINE_BINDING = $825A;

GL_MAX_VIEWPORTS = $825B;

GL_VIEWPORT_SUBPIXEL_BITS = $825C;

GL_VIEWPORT_BOUNDS_RANGE = $825D;

GL_LAYER_PROVOKING_VERTEX = $825E;

GL_VIEWPORT_INDEX_PROVOKING_VERTEX = $825F;

GL_UNDEFINED_VERTEX = $8260;

GL_SYNC_CL_EVENT_ARB = $8240;

GL_SYNC_CL_EVENT_COMPLETE_ARB = $8241;

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB = $8242;

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB = $8243;

GL_DEBUG_CALLBACK_FUNCTION_ARB = $8244;

GL_DEBUG_CALLBACK_USER_PARAM_ARB = $8245;

GL_DEBUG_SOURCE_API_ARB = $8246;

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB = $8247;

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB = $8248;

GL_DEBUG_SOURCE_THIRD_PARTY_ARB = $8249;

GL_DEBUG_SOURCE_APPLICATION_ARB = $824A;

GL_DEBUG_SOURCE_OTHER_ARB = $824B;

GL_DEBUG_TYPE_ERROR_ARB = $824C;

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB = $824D;

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB = $824E;

GL_DEBUG_TYPE_PORTABILITY_ARB = $824F;

GL_DEBUG_TYPE_PERFORMANCE_ARB = $8250;

GL_DEBUG_TYPE_OTHER_ARB = $8251;

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB = $9143;

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB = $9144;

GL_DEBUG_LOGGED_MESSAGES_ARB = $9145;

GL_DEBUG_SEVERITY_HIGH_ARB = $9146;

GL_DEBUG_SEVERITY_MEDIUM_ARB = $9147;

GL_DEBUG_SEVERITY_LOW_ARB = $9148;

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB = $00000004;

GL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

GL_GUILTY_CONTEXT_RESET_ARB = $8253;

GL_INNOCENT_CONTEXT_RESET_ARB = $8254;

GL_UNKNOWN_CONTEXT_RESET_ARB = $8255;

GL_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

GL_NO_RESET_NOTIFICATION_ARB = $8261;

GL_UNPACK_COMPRESSED_BLOCK_WIDTH = $09127;

GL_UNPACK_COMPRESSED_BLOCK_HEIGHT = $09128;

GL_UNPACK_COMPRESSED_BLOCK_DEPTH = $09129;

GL_UNPACK_COMPRESSED_BLOCK_SIZE = $0912A;

GL_PACK_COMPRESSED_BLOCK_WIDTH = $0912B;

GL_PACK_COMPRESSED_BLOCK_HEIGHT = $0912C;

GL_PACK_COMPRESSED_BLOCK_DEPTH = $0912D;

GL_PACK_COMPRESSED_BLOCK_SIZE = $0912E;

GL_NUM_SAMPLE_COUNTS = $09380;

GL_MIN_MAP_BUFFER_ALIGNMENT = $090BC;

GL_ATOMIC_COUNTER_BUFFER = $92C0;

GL_ATOMIC_COUNTER_BUFFER_BINDING = $92C1;

GL_ATOMIC_COUNTER_BUFFER_START = $92C2;

GL_ATOMIC_COUNTER_BUFFER_SIZE = $92C3;

GL_ATOMIC_COUNTER_BUFFER_DATA_SIZE = $92C4;

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTERS = $92C5;

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTER_INDICES = $92C6;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_VERTEX_SHADER = $92C7;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_CONTROL_SHADER = $92C8;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_EVALUATION_SHADER = $92C9;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_GEOMETRY_SHADER = $92CA;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_FRAGMENT_SHADER = $92CB;

GL_MAX_VERTEX_ATOMIC_COUNTER_BUFFERS = $92CC;

GL_MAX_TESS_CONTROL_ATOMIC_COUNTER_BUFFERS = $92CD;

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTER_BUFFERS = $92CE;

GL_MAX_GEOMETRY_ATOMIC_COUNTER_BUFFERS = $92CF;

GL_MAX_FRAGMENT_ATOMIC_COUNTER_BUFFERS = $92D0;

GL_MAX_COMBINED_ATOMIC_COUNTER_BUFFERS = $92D1;

GL_MAX_VERTEX_ATOMIC_COUNTERS = $92D2;

GL_MAX_TESS_CONTROL_ATOMIC_COUNTERS = $92D3;

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTERS = $92D4;

GL_MAX_GEOMETRY_ATOMIC_COUNTERS = $92D5;

GL_MAX_FRAGMENT_ATOMIC_COUNTERS = $92D6;

GL_MAX_COMBINED_ATOMIC_COUNTERS = $92D7;

GL_MAX_ATOMIC_COUNTER_BUFFER_SIZE = $92D8;

GL_MAX_ATOMIC_COUNTER_BUFFER_BINDINGS = $92DC;

GL_ACTIVE_ATOMIC_COUNTER_BUFFERS = $92D9;

GL_UNIFORM_ATOMIC_COUNTER_BUFFER_INDEX = $92DA;

GL_UNSIGNED_INT_ATOMIC_COUNTER = $92DB;

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT = $00000001;

GL_ELEMENT_ARRAY_BARRIER_BIT = $00000002;

GL_UNIFORM_BARRIER_BIT = $00000004;

GL_TEXTURE_FETCH_BARRIER_BIT = $00000008;

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT = $00000020;

GL_COMMAND_BARRIER_BIT = $00000040;

GL_PIXEL_BUFFER_BARRIER_BIT = $00000080;

GL_TEXTURE_UPDATE_BARRIER_BIT = $00000100;

GL_BUFFER_UPDATE_BARRIER_BIT = $00000200;

GL_FRAMEBUFFER_BARRIER_BIT = $00000400;

GL_TRANSFORM_FEEDBACK_BARRIER_BIT = $00000800;

GL_ATOMIC_COUNTER_BARRIER_BIT = $00001000;

GL_ALL_BARRIER_BITS = $FFFFFFFF;

GL_MAX_IMAGE_UNITS = $8F38;

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS = $8F39;

GL_IMAGE_BINDING_NAME = $8F3A;

GL_IMAGE_BINDING_LEVEL = $8F3B;

GL_IMAGE_BINDING_LAYERED = $8F3C;

GL_IMAGE_BINDING_LAYER = $8F3D;

GL_IMAGE_BINDING_ACCESS = $8F3E;

GL_IMAGE_1D = $904C;

GL_IMAGE_2D = $904D;

GL_IMAGE_3D = $904E;

GL_IMAGE_2D_RECT = $904F;

GL_IMAGE_CUBE = $9050;

GL_IMAGE_BUFFER = $9051;

GL_IMAGE_1D_ARRAY = $9052;

GL_IMAGE_2D_ARRAY = $9053;

GL_IMAGE_CUBE_MAP_ARRAY = $9054;

GL_IMAGE_2D_MULTISAMPLE = $9055;

GL_IMAGE_2D_MULTISAMPLE_ARRAY = $9056;

GL_INT_IMAGE_1D = $9057;

GL_INT_IMAGE_2D = $9058;

GL_INT_IMAGE_3D = $9059;

GL_INT_IMAGE_2D_RECT = $905A;

GL_INT_IMAGE_CUBE = $905B;

GL_INT_IMAGE_BUFFER = $905C;

GL_INT_IMAGE_1D_ARRAY = $905D;

GL_INT_IMAGE_2D_ARRAY = $905E;

GL_INT_IMAGE_CUBE_MAP_ARRAY = $905F;

GL_INT_IMAGE_2D_MULTISAMPLE = $9060;

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY = $9061;

GL_UNSIGNED_INT_IMAGE_1D = $9062;

GL_UNSIGNED_INT_IMAGE_2D = $9063;

GL_UNSIGNED_INT_IMAGE_3D = $9064;

GL_UNSIGNED_INT_IMAGE_2D_RECT = $9065;

GL_UNSIGNED_INT_IMAGE_CUBE = $9066;

GL_UNSIGNED_INT_IMAGE_BUFFER = $9067;

GL_UNSIGNED_INT_IMAGE_1D_ARRAY = $9068;

GL_UNSIGNED_INT_IMAGE_2D_ARRAY = $9069;

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY = $906A;

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE = $906B;

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY = $906C;

GL_MAX_IMAGE_SAMPLES = $906D;

GL_IMAGE_BINDING_FORMAT = $906E;

GL_IMAGE_FORMAT_COMPATIBILITY_TYPE = $90C7;

GL_IMAGE_FORMAT_COMPATIBILITY_BY_SIZE = $90C8;

GL_IMAGE_FORMAT_COMPATIBILITY_BY_CLASS = $90C9;

GL_MAX_VERTEX_IMAGE_UNIFORMS = $90CA;

GL_MAX_TESS_CONTROL_IMAGE_UNIFORMS = $90CB;

GL_MAX_TESS_EVALUATION_IMAGE_UNIFORMS = $90CC;

GL_MAX_GEOMETRY_IMAGE_UNIFORMS = $90CD;

GL_MAX_FRAGMENT_IMAGE_UNIFORMS = $90CE;

GL_MAX_COMBINED_IMAGE_UNIFORMS = $90CF;

GL_TEXTURE_IMMUTABLE_FORMAT = $912F;

GL_COMPRESSED_RGBA_ASTC_4x4_KHR = $93B0;

GL_COMPRESSED_RGBA_ASTC_5x4_KHR = $93B1;

GL_COMPRESSED_RGBA_ASTC_5x5_KHR = $93B2;

GL_COMPRESSED_RGBA_ASTC_6x5_KHR = $93B3;

GL_COMPRESSED_RGBA_ASTC_6x6_KHR = $93B4;

GL_COMPRESSED_RGBA_ASTC_8x5_KHR = $93B5;

GL_COMPRESSED_RGBA_ASTC_8x6_KHR = $93B6;

GL_COMPRESSED_RGBA_ASTC_8x8_KHR = $93B7;

GL_COMPRESSED_RGBA_ASTC_105_KHR = $93B8;

GL_COMPRESSED_RGBA_ASTC_106_KHR = $93B9;

GL_COMPRESSED_RGBA_ASTC_108_KHR = $93BA;

GL_COMPRESSED_RGBA_ASTC_110_KHR = $93BB;

GL_COMPRESSED_RGBA_ASTC_12x10_KHR = $93BC;

GL_COMPRESSED_RGBA_ASTC_12x12_KHR = $93BD;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_4x4_KHR = $93D0;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x4_KHR = $93D1;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x5_KHR = $93D2;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x5_KHR = $93D3;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x6_KHR = $93D4;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x5_KHR = $93D5;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x6_KHR = $93D6;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x8_KHR = $93D7;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x5_KHR = $93D8;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x6_KHR = $93D9;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x8_KHR = $93DA;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x10_KHR = $93DB;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x10_KHR = $93DC;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x12_KHR = $93DD;

GL_DEBUG_OUTPUT_SYNCHRONOUS = $8242;

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH = $8243;

GL_DEBUG_CALLBACK_FUNCTION = $8244;

GL_DEBUG_CALLBACK_USER_PARAM = $8245;

GL_DEBUG_SOURCE_API = $8246;

GL_DEBUG_SOURCE_WINDOW_SYSTEM = $8247;

GL_DEBUG_SOURCE_SHADER_COMPILER = $8248;

GL_DEBUG_SOURCE_THIRD_PARTY = $8249;

GL_DEBUG_SOURCE_APPLICATION = $824A;

GL_DEBUG_SOURCE_OTHER = $824B;

GL_DEBUG_TYPE_ERROR = $824C;

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR = $824D;

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR = $824E;

GL_DEBUG_TYPE_PORTABILITY = $824F;

GL_DEBUG_TYPE_PERFORMANCE = $8250;

GL_DEBUG_TYPE_OTHER = $8251;

GL_DEBUG_TYPE_MARKER = $8268;

GL_DEBUG_TYPE_PUSH_GROUP = $8269;

GL_DEBUG_TYPE_POP_GROUP = $826A;

GL_DEBUG_SEVERITY_NOTIFICATION = $826B;

GL_MAX_DEBUG_GROUP_STACK_DEPTH = $826C;

GL_DEBUG_GROUP_STACK_DEPTH = $826D;

GL_BUFFER = $82E0;

GL_SHADER = $82E1;

GL_PROGRAM = $82E2;

GL_QUERY = $82E3;

GL_PROGRAM_PIPELINE = $82E4;

GL_SAMPLER = $82E6;

GL_DISPLAY_LIST = $82E7;

GL_MAX_LABEL_LENGTH = $82E8;

GL_MAX_DEBUG_MESSAGE_LENGTH = $9143;

GL_MAX_DEBUG_LOGGED_MESSAGES = $9144;

GL_DEBUG_LOGGED_MESSAGES = $9145;

GL_DEBUG_SEVERITY_HIGH = $9146;

GL_DEBUG_SEVERITY_MEDIUM = $9147;

GL_DEBUG_SEVERITY_LOW = $9148;

GL_DEBUG_OUTPUT = $92E0;

GL_CONTEXT_FLAG_DEBUG_BIT = $00000002;

GL_COMPUTE_SHADER = $91B9;

GL_MAX_COMPUTE_UNIFORM_BLOCKS = $91BB;

GL_MAX_COMPUTE_TEXTURE_IMAGE_UNITS = $91BC;

GL_MAX_COMPUTE_IMAGE_UNIFORMS = $91BD;

GL_MAX_COMPUTE_SHARED_MEMORY_SIZE = $8262;

GL_MAX_COMPUTE_UNIFORM_COMPONENTS = $8263;

GL_MAX_COMPUTE_ATOMIC_COUNTER_BUFFERS = $8264;

GL_MAX_COMPUTE_ATOMIC_COUNTERS = $8265;

GL_MAX_COMBINED_COMPUTE_UNIFORM_COMPONENTS = $8266;

GL_MAX_COMPUTE_LOCAL_INVOCATIONS = $90EB;

GL_MAX_COMPUTE_WORK_GROUP_COUNT = $91BE;

GL_MAX_COMPUTE_WORK_GROUP_SIZE = $91BF;

GL_COMPUTE_LOCAL_WORK_SIZE = $8267;

GL_UNIFORM_BLOCK_REFERENCED_BY_COMPUTE_SHADER = $90EC;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_COMPUTE_SHADER = $90ED;

GL_DISPATCH_INDIRECT_BUFFER = $90EE;

GL_DISPATCH_INDIRECT_BUFFER_BINDING = $90EF;

GL_COMPUTE_SHADER_BIT = $00000020;

GL_COMPRESSED_RGB8_ETC2 = $9274;

GL_COMPRESSED_SRGB8_ETC2 = $9275;

GL_COMPRESSED_RGB8_PUNCHTHROUGH_ALPHA1_ETC2 = $9276;

GL_COMPRESSED_SRGB8_PUNCHTHROUGH_ALPHA1_ETC2 = $9277;

GL_COMPRESSED_RGBA8_ETC2_EAC = $9278;

GL_COMPRESSED_SRGB8_ALPHA8_ETC2_EAC = $9279;

GL_COMPRESSED_R11_EAC = $9270;

GL_COMPRESSED_SIGNED_R11_EAC = $9271;

GL_COMPRESSED_RG11_EAC = $9272;

GL_COMPRESSED_SIGNED_RG11_EAC = $9273;

GL_PRIMITIVE_RESTART_FIXED_INDEX = $8D69;

GL_ANY_SAMPLES_PASSED_CONSERVATIVE = $8D6A;

GL_MAX_ELEMENT_INDEX = $8D6B;

GL_MAX_UNIFORM_LOCATIONS = $826E;

GL_FRAMEBUFFER_DEFAULT_WIDTH = $9310;

GL_FRAMEBUFFER_DEFAULT_HEIGHT = $9311;

GL_FRAMEBUFFER_DEFAULT_LAYERS = $9312;

GL_FRAMEBUFFER_DEFAULT_SAMPLES = $9313;

GL_FRAMEBUFFER_DEFAULT_FIXED_SAMPLE_LOCATIONS = $9314;

GL_MAX_FRAMEBUFFER_WIDTH = $9315;

GL_MAX_FRAMEBUFFER_HEIGHT = $9316;

GL_MAX_FRAMEBUFFER_LAYERS = $9317;

GL_MAX_FRAMEBUFFER_SAMPLES = $9318;

GL_INTERNALFORMAT_SUPPORTED = $826F;

GL_INTERNALFORMAT_PREFERRED = $8270;

GL_INTERNALFORMAT_RED_SIZE = $8271;

GL_INTERNALFORMAT_GREEN_SIZE = $8272;

GL_INTERNALFORMAT_BLUE_SIZE = $8273;

GL_INTERNALFORMAT_ALPHA_SIZE = $8274;

GL_INTERNALFORMAT_DEPTH_SIZE = $8275;

GL_INTERNALFORMAT_STENCIL_SIZE = $8276;

GL_INTERNALFORMAT_SHARED_SIZE = $8277;

GL_INTERNALFORMAT_RED_TYPE = $8278;

GL_INTERNALFORMAT_GREEN_TYPE = $8279;

GL_INTERNALFORMAT_BLUE_TYPE = $827A;

GL_INTERNALFORMAT_ALPHA_TYPE = $827B;

GL_INTERNALFORMAT_DEPTH_TYPE = $827C;

GL_INTERNALFORMAT_STENCIL_TYPE = $827D;

GL_MAX_WIDTH = $827E;

GL_MAX_HEIGHT = $827F;

GL_MAX_DEPTH = $8280;

GL_MAX_LAYERS = $8281;

GL_MAX_COMBINED_DIMENSIONS = $8282;

GL_COLOR_COMPONENTS = $8283;

GL_DEPTH_COMPONENTS = $8284;

GL_STENCIL_COMPONENTS = $8285;

GL_COLOR_RENDERABLE = $8286;

GL_DEPTH_RENDERABLE = $8287;

GL_STENCIL_RENDERABLE = $8288;

GL_FRAMEBUFFER_RENDERABLE = $8289;

GL_FRAMEBUFFER_RENDERABLE_LAYERED = $828A;

GL_FRAMEBUFFER_BLEND = $828B;

GL_READ_PIXELS = $828C;

GL_READ_PIXELS_FORMAT = $828D;

GL_READ_PIXELS_TYPE = $828E;

GL_TEXTURE_IMAGE_FORMAT = $828F;

GL_TEXTURE_IMAGE_TYPE = $8290;

GL_GET_TEXTURE_IMAGE_FORMAT = $8291;

GL_GET_TEXTURE_IMAGE_TYPE = $8292;

GL_MIPMAP = $8293;

GL_MANUAL_GENERATE_MIPMAP = $8294;

GL_AUTO_GENERATE_MIPMAP = $8295;

GL_COLOR_ENCODING = $8296;

GL_SRGB_READ = $8297;

GL_SRGB_WRITE = $8298;

GL_SRGB_DECODE_ARB = $8299;

GL_FILTER = $829A;

GL_VERTEX_TEXTURE = $829B;

GL_TESS_CONTROL_TEXTURE = $829C;

GL_TESS_EVALUATION_TEXTURE = $829D;

GL_GEOMETRY_TEXTURE = $829E;

GL_FRAGMENT_TEXTURE = $829F;

GL_COMPUTE_TEXTURE = $82A0;

GL_TEXTURE_SHADOW = $82A1;

GL_TEXTURE_GATHER = $82A2;

GL_TEXTURE_GATHER_SHADOW = $82A3;

GL_SHADER_IMAGE_LOAD = $82A4;

GL_SHADER_IMAGE_STORE = $82A5;

GL_SHADER_IMAGE_ATOMIC = $82A6;

GL_IMAGE_TEXEL_SIZE = $82A7;

GL_IMAGE_COMPATIBILITY_CLASS = $82A8;

GL_IMAGE_PIXEL_FORMAT = $82A9;

GL_IMAGE_PIXEL_TYPE = $82AA;

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_TEST = $82AC;

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_TEST = $82AD;

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_WRITE = $82AE;

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_WRITE = $82AF;

GL_TEXTURE_COMPRESSED_BLOCK_WIDTH = $82B1;

GL_TEXTURE_COMPRESSED_BLOCK_HEIGHT = $82B2;

GL_TEXTURE_COMPRESSED_BLOCK_SIZE = $82B3;

GL_CLEAR_BUFFER = $82B4;

GL_TEXTURE_VIEW = $82B5;

GL_VIEW_COMPATIBILITY_CLASS = $82B6;

GL_FULL_SUPPORT = $82B7;

GL_CAVEAT_SUPPORT = $82B8;

GL_IMAGE_CLASS_4_X_32 = $82B9;

GL_IMAGE_CLASS_2_X_32 = $82BA;

GL_IMAGE_CLASS_1_X_32 = $82BB;

GL_IMAGE_CLASS_4_X_16 = $82BC;

GL_IMAGE_CLASS_2_X_16 = $82BD;

GL_IMAGE_CLASS_1_X_16 = $82BE;

GL_IMAGE_CLASS_4_X_8 = $82BF;

GL_IMAGE_CLASS_2_X_8 = $82C0;

GL_IMAGE_CLASS_1_X_8 = $82C1;

GL_IMAGE_CLASS_11_11_10 = $82C2;

GL_IMAGE_CLASS_10_10_10_2 = $82C3;

GL_VIEW_CLASS_128_BITS = $82C4;

GL_VIEW_CLASS_96_BITS = $82C5;

GL_VIEW_CLASS_64_BITS = $82C6;

GL_VIEW_CLASS_48_BITS = $82C7;

GL_VIEW_CLASS_32_BITS = $82C8;

GL_VIEW_CLASS_24_BITS = $82C9;

GL_VIEW_CLASS_16_BITS = $82CA;

GL_VIEW_CLASS_8_BITS = $82CB;

GL_VIEW_CLASS_S3TC_DXT1_RGB = $82CC;

GL_VIEW_CLASS_S3TC_DXT1_RGBA = $82CD;

GL_VIEW_CLASS_S3TC_DXT3_RGBA = $82CE;

GL_VIEW_CLASS_S3TC_DXT5_RGBA = $82CF;

GL_VIEW_CLASS_RGTC1_RED = $82D0;

GL_VIEW_CLASS_RGTC2_RG = $82D1;

GL_VIEW_CLASS_BPTC_UNORM = $82D2;

GL_VIEW_CLASS_BPTC_FLOAT = $82D3;

GL_UNIFORM = $92E1;

GL_UNIFORM_BLOCK = $92E2;

GL_PROGRAM_INPUT = $92E3;

GL_PROGRAM_OUTPUT = $92E4;

GL_BUFFER_VARIABLE = $92E5;

GL_SHADER_STORAGE_BLOCK = $92E6;

GL_VERTEX_SUBROUTINE = $92E8;

GL_TESS_CONTROL_SUBROUTINE = $92E9;

GL_TESS_EVALUATION_SUBROUTINE = $92EA;

GL_GEOMETRY_SUBROUTINE = $92EB;

GL_FRAGMENT_SUBROUTINE = $92EC;

GL_COMPUTE_SUBROUTINE = $92ED;

GL_VERTEX_SUBROUTINE_UNIFORM = $92EE;

GL_TESS_CONTROL_SUBROUTINE_UNIFORM = $92EF;

GL_TESS_EVALUATION_SUBROUTINE_UNIFORM = $92F0;

GL_GEOMETRY_SUBROUTINE_UNIFORM = $92F1;

GL_FRAGMENT_SUBROUTINE_UNIFORM = $92F2;

GL_COMPUTE_SUBROUTINE_UNIFORM = $92F3;

GL_TRANSFORM_FEEDBACK_VARYING = $92F4;

GL_ACTIVE_RESOURCES = $92F5;

GL_MAX_NAME_LENGTH = $92F6;

GL_MAX_NUM_ACTIVE_VARIABLES = $92F7;

GL_MAX_NUM_COMPATIBLE_SUBROUTINES = $92F8;

GL_NAME_LENGTH = $92F9;

GL_TYPE = $92FA;

GL_ARRAY_SIZE = $92FB;

GL_OFFSET = $92FC;

GL_BLOCK_INDEX = $92FD;

GL_ARRAY_STRIDE = $92FE;

GL_MATRIX_STRIDE = $92FF;

GL_IS_ROW_MAJOR = $9300;

GL_ATOMIC_COUNTER_BUFFER_INDEX = $9301;

GL_BUFFER_BINDING = $9302;

GL_BUFFER_DATA_SIZE = $9303;

GL_NUM_ACTIVE_VARIABLES = $9304;

GL_ACTIVE_VARIABLES = $9305;

GL_REFERENCED_BY_VERTEX_SHADER = $9306;

GL_REFERENCED_BY_TESS_CONTROL_SHADER = $9307;

GL_REFERENCED_BY_TESS_EVALUATION_SHADER = $9308;

GL_REFERENCED_BY_GEOMETRY_SHADER = $9309;

GL_REFERENCED_BY_FRAGMENT_SHADER = $930A;

GL_REFERENCED_BY_COMPUTE_SHADER = $930B;

GL_TOP_LEVEL_ARRAY_SIZE = $930C;

GL_TOP_LEVEL_ARRAY_STRIDE = $930D;

GL_LOCATION = $930E;

GL_LOCATION_INDEX = $930F;

GL_IS_PER_PATCH = $92E7;

GL_SHADER_STORAGE_BUFFER = $90D2;

GL_SHADER_STORAGE_BUFFER_BINDING = $90D3;

GL_SHADER_STORAGE_BUFFER_START = $90D4;

GL_SHADER_STORAGE_BUFFER_SIZE = $90D5;

GL_MAX_VERTEX_SHADER_STORAGE_BLOCKS = $90D6;

GL_MAX_GEOMETRY_SHADER_STORAGE_BLOCKS = $90D7;

GL_MAX_TESS_CONTROL_SHADER_STORAGE_BLOCKS = $90D8;

GL_MAX_TESS_EVALUATION_SHADER_STORAGE_BLOCKS = $90D9;

GL_MAX_FRAGMENT_SHADER_STORAGE_BLOCKS = $90DA;

GL_MAX_COMPUTE_SHADER_STORAGE_BLOCKS = $90DB;

GL_MAX_COMBINED_SHADER_STORAGE_BLOCKS = $90DC;

GL_MAX_SHADER_STORAGE_BUFFER_BINDINGS = $90DD;

GL_MAX_SHADER_STORAGE_BLOCK_SIZE = $90DE;

GL_SHADER_STORAGE_BUFFER_OFFSET_ALIGNMENT = $90DF;

GL_SHADER_STORAGE_BARRIER_BIT = $2000;

GL_MAX_COMBINED_SHADER_OUTPUT_RESOURCES = GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS;

GL_DEPTH_STENCIL_TEXTURE_MODE = $90EA;

GL_TEXTURE_BUFFER_OFFSET = $919D;

GL_TEXTURE_BUFFER_SIZE = $919E;

GL_TEXTURE_BUFFER_OFFSET_ALIGNMENT = $919F;

GL_TEXTURE_VIEW_MIN_LEVEL = $82DB;

GL_TEXTURE_VIEW_NUM_LEVELS = $82DC;

GL_TEXTURE_VIEW_MIN_LAYER = $82DD;

GL_TEXTURE_VIEW_NUM_LAYERS = $82DE;

GL_TEXTURE_IMMUTABLE_LEVELS = $82DF;

GL_VERTEX_ATTRIB_BINDING = $82D4;

GL_VERTEX_ATTRIB_RELATIVE_OFFSET = $82D5;

GL_VERTEX_BINDING_DIVISOR = $82D6;

GL_VERTEX_BINDING_OFFSET = $82D7;

GL_VERTEX_BINDING_STRIDE = $82D8;

GL_MAX_VERTEX_ATTRIB_RELATIVE_OFFSET = $82D9;

GL_MAX_VERTEX_ATTRIB_BINDINGS = $82DA;

GL_MAX_VERTEX_ATTRIB_STRIDE = $82E5;

GL_PRIMITIVE_RESTART_FOR_PATCHES_SUPPORTED = $8221;

GL_TEXTURE_BUFFER_BINDING = $8C2A;

GL_MAP_PERSISTENT_BIT = $0040;

GL_MAP_COHERENT_BIT = $0080;

GL_DYNAMIC_STORAGE_BIT = $0100;

GL_CLIENT_STORAGE_BIT = $0200;

GL_CLIENT_MAPPED_BUFFER_BARRIER_BIT = $00004000;

GL_BUFFER_IMMUTABLE_STORAGE = $821F;

GL_BUFFER_STORAGE_FLAGS = $8220;

GL_CLEAR_TEXTURE = $9365;

GL_LOCATION_COMPONENT = $934A;

GL_TRANSFORM_FEEDBACK_BUFFER_INDEX = $934B;

GL_TRANSFORM_FEEDBACK_BUFFER_STRIDE = $934C;

GL_QUERY_BUFFER = $9192;

GL_QUERY_BUFFER_BARRIER_BIT = $00008000;

GL_QUERY_BUFFER_BINDING = $9193;

GL_QUERY_RESULT_NO_WAIT = $9194;

GL_MIRROR_CLAMP_TO_EDGE = $8743;

GL_CONTEXT_LOST = $0507;

GL_NEGATIVE_ONE_TO_ONE = $935E;

GL_ZERO_TO_ONE = $935F;

GL_CLIP_ORIGIN = $935C;

GL_CLIP_DEPTH_MODE = $935D;

GL_QUERY_WAIT_INVERTED = $8E17;

GL_QUERY_NO_WAIT_INVERTED = $8E18;

GL_QUERY_BY_REGION_WAIT_INVERTED = $8E19;

GL_QUERY_BY_REGION_NO_WAIT_INVERTED = $8E1A;

GL_MAX_CULL_DISTANCES = $82F9;

GL_MAX_COMBINED_CLIP_AND_CULL_DISTANCES = $82FA;

GL_TEXTURE_TARGET = $1006;

GL_QUERY_TARGET = $82EA;

GL_TEXTURE_BINDING = $82EB;

GL_GUILTY_CONTEXT_RESET = $8253;

GL_INNOCENT_CONTEXT_RESET = $8254;

GL_UNKNOWN_CONTEXT_RESET = $8255;

GL_RESET_NOTIFICATION_STRATEGY = $8256;

GL_LOSE_CONTEXT_ON_RESET = $8252;

GL_NO_RESET_NOTIFICATION = $8261;

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT = $00000004;

GL_CONTEXT_RELEASE_BEHAVIOR = $82FB;

GL_CONTEXT_RELEASE_BEHAVIOR_FLUSH = $82FC;

GL_SHADER_BINARY_FORMAT_SPIR_V = $9551;

GL_SPIR_V_BINARY = $9552;

GL_PARAMETER_BUFFER = $80EE;

GL_PARAMETER_BUFFER_BINDING = $80EF;

GL_CONTEXT_FLAG_NO_ERROR_BIT = $00000008;

GL_VERTICES_SUBMITTED = $82EE;

GL_PRIMITIVES_SUBMITTED = $82EF;

GL_VERTEX_SHADER_INVOCATIONS = $82F0;

GL_TESS_CONTROL_SHADER_PATCHES = $82F1;

GL_TESS_EVALUATION_SHADER_INVOCATIONS = $82F2;

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED = $82F3;

GL_FRAGMENT_SHADER_INVOCATIONS = $82F4;

GL_COMPUTE_SHADER_INVOCATIONS = $82F5;

GL_CLIPPING_INPUT_PRIMITIVES = $82F6;

GL_CLIPPING_OUTPUT_PRIMITIVES = $82F7;

GL_POLYGON_OFFSET_CLAMP = $8E1B;

GL_SPIR_V_EXTENSIONS = $9553;

GL_NUM_SPIR_V_EXTENSIONS = $9554;

GL_TEXTURE_MAX_ANISOTROPY = $84FE;

GL_MAX_TEXTURE_MAX_ANISOTROPY = $84FF;

GL_TRANSFORM_FEEDBACK_OVERFLOW = $82EC;

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW = $82ED;

GL_MAX_DRAW_BUFFERS_ATI = $8824;

GL_DRAW_BUFFER0_ATI = $8825;

GL_DRAW_BUFFER1_ATI = $8826;

GL_DRAW_BUFFER2_ATI = $8827;

GL_DRAW_BUFFER3_ATI = $8828;

GL_DRAW_BUFFER4_ATI = $8829;

GL_DRAW_BUFFER5_ATI = $882A;

GL_DRAW_BUFFER6_ATI = $882B;

GL_DRAW_BUFFER7_ATI = $882C;

GL_DRAW_BUFFER8_ATI = $882D;

GL_DRAW_BUFFER9_ATI = $882E;

GL_DRAW_BUFFER10_ATI = $882F;

GL_DRAW_BUFFER11_ATI = $8830;

GL_DRAW_BUFFER12_ATI = $8831;

GL_DRAW_BUFFER13_ATI = $8832;

GL_DRAW_BUFFER14_ATI = $8833;

GL_DRAW_BUFFER15_ATI = $8834;

GL_ELEMENT_ARRAY_ATI = $8768;

GL_ELEMENT_ARRAY_TYPE_ATI = $8769;

GL_ELEMENT_ARRAY_POINTER_ATI = $876A;

GL_BUMP_ROT_MATRIX_ATI = $8775;

GL_BUMP_ROT_MATRIX_SIZE_ATI = $8776;

GL_BUMP_NUM_TEX_UNITS_ATI = $8777;

GL_BUMP_TEX_UNITS_ATI = $8778;

GL_DUDV_ATI = $8779;

GL_DU8DV8_ATI = $877A;

GL_BUMP_ENVMAP_ATI = $877B;

GL_BUMP_TARGET_ATI = $877C;

GL_FRAGMENT_SHADER_ATI = $8920;

GL_REG_0_ATI = $8921;

GL_REG_1_ATI = $8922;

GL_REG_2_ATI = $8923;

GL_REG_3_ATI = $8924;

GL_REG_4_ATI = $8925;

GL_REG_5_ATI = $8926;

GL_REG_6_ATI = $8927;

GL_REG_7_ATI = $8928;

GL_REG_8_ATI = $8929;

GL_REG_9_ATI = $892A;

GL_REG_10_ATI = $892B;

GL_REG_11_ATI = $892C;

GL_REG_12_ATI = $892D;

GL_REG_13_ATI = $892E;

GL_REG_14_ATI = $892F;

GL_REG_15_ATI = $8930;

GL_REG_16_ATI = $8931;

GL_REG_17_ATI = $8932;

GL_REG_18_ATI = $8933;

GL_REG_19_ATI = $8934;

GL_REG_20_ATI = $8935;

GL_REG_21_ATI = $8936;

GL_REG_22_ATI = $8937;

GL_REG_23_ATI = $8938;

GL_REG_24_ATI = $8939;

GL_REG_25_ATI = $893A;

GL_REG_26_ATI = $893B;

GL_REG_27_ATI = $893C;

GL_REG_28_ATI = $893D;

GL_REG_29_ATI = $893E;

GL_REG_30_ATI = $893F;

GL_REG_31_ATI = $8940;

GL_CON_0_ATI = $8941;

GL_CON_1_ATI = $8942;

GL_CON_2_ATI = $8943;

GL_CON_3_ATI = $8944;

GL_CON_4_ATI = $8945;

GL_CON_5_ATI = $8946;

GL_CON_6_ATI = $8947;

GL_CON_7_ATI = $8948;

GL_CON_8_ATI = $8949;

GL_CON_9_ATI = $894A;

GL_CON_10_ATI = $894B;

GL_CON_11_ATI = $894C;

GL_CON_12_ATI = $894D;

GL_CON_13_ATI = $894E;

GL_CON_14_ATI = $894F;

GL_CON_15_ATI = $8950;

GL_CON_16_ATI = $8951;

GL_CON_17_ATI = $8952;

GL_CON_18_ATI = $8953;

GL_CON_19_ATI = $8954;

GL_CON_20_ATI = $8955;

GL_CON_21_ATI = $8956;

GL_CON_22_ATI = $8957;

GL_CON_23_ATI = $8958;

GL_CON_24_ATI = $8959;

GL_CON_25_ATI = $895A;

GL_CON_26_ATI = $895B;

GL_CON_27_ATI = $895C;

GL_CON_28_ATI = $895D;

GL_CON_29_ATI = $895E;

GL_CON_30_ATI = $895F;

GL_CON_31_ATI = $8960;

GL_MOV_ATI = $8961;

GL_ADD_ATI = $8963;

GL_MUL_ATI = $8964;

GL_SUB_ATI = $8965;

GL_DOT3_ATI = $8966;

GL_DOT4_ATI = $8967;

GL_MAD_ATI = $8968;

GL_LERP_ATI = $8969;

GL_CND_ATI = $896A;

GL_CND0_ATI = $896B;

GL_DOT2_ADD_ATI = $896C;

GL_SECONDARY_INTERPOLATOR_ATI = $896D;

GL_NUM_FRAGMENT_REGISTERS_ATI = $896E;

GL_NUM_FRAGMENT_CONSTANTS_ATI = $896F;

GL_NUM_PASSES_ATI = $8970;

GL_NUM_INSTRUCTIONS_PER_PASS_ATI = $8971;

GL_NUM_INSTRUCTIONS_TOTAL_ATI = $8972;

GL_NUM_INPUT_INTERPOLATOR_COMPONENTS_ATI = $8973;

GL_NUM_LOOPBACK_COMPONENTS_ATI = $8974;

GL_COLOR_ALPHA_PAIRING_ATI = $8975;

GL_SWIZZLE_STR_ATI = $8976;

GL_SWIZZLE_STQ_ATI = $8977;

GL_SWIZZLE_STR_DR_ATI = $8978;

GL_SWIZZLE_STQ_DQ_ATI = $8979;

GL_SWIZZLE_STRQ_ATI = $897A;

GL_SWIZZLE_STRQ_DQ_ATI = $897B;

GL_RED_BIT_ATI = $00000001;

GL_GREEN_BIT_ATI = $00000002;

GL_BLUE_BIT_ATI = $00000004;

GL_2X_BIT_ATI = $00000001;

GL_4X_BIT_ATI = $00000002;

GL_8X_BIT_ATI = $00000004;

GL_HALF_BIT_ATI = $00000008;

GL_QUARTER_BIT_ATI = $00000010;

GL_EIGHTH_BIT_ATI = $00000020;

GL_SATURATE_BIT_ATI = $00000040;

GL_COMP_BIT_ATI = $00000002;

GL_NEGATE_BIT_ATI = $00000004;

GL_BIAS_BIT_ATI = $00000008;

GL_PN_TRIANGLES_ATI = $87F0;

GL_MAX_PN_TRIANGLES_TESSELATION_LEVEL_ATI = $87F1;

GL_PN_TRIANGLES_POINT_MODE_ATI = $87F2;

GL_PN_TRIANGLES_NORMAL_MODE_ATI = $87F3;

GL_PN_TRIANGLES_TESSELATION_LEVEL_ATI = $87F4;

GL_PN_TRIANGLES_POINT_MODE_LINEAR_ATI = $87F5;

GL_PN_TRIANGLES_POINT_MODE_CUBIC_ATI = $87F6;

GL_PN_TRIANGLES_NORMAL_MODE_LINEAR_ATI = $87F7;

GL_PN_TRIANGLES_NORMAL_MODE_QUADRATIC_ATI = $87F8;

GL_STENCIL_BACK_FUNC_ATI = $8800;

GL_STENCIL_BACK_FAIL_ATI = $8801;

GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI = $8802;

GL_STENCIL_BACK_PASS_DEPTH_PASS_ATI = $8803;

GL_TEXT_FRAGMENT_SHADER_ATI = $8200;

GL_MODULATE_ADD_ATI = $8744;

GL_MODULATE_SIGNED_ADD_ATI = $8745;

GL_MODULATE_SUBTRACT_ATI = $8746;

GL_RGBA_FLOAT32_ATI = $8814;

GL_RGB_FLOAT32_ATI = $8815;

GL_ALPHA_FLOAT32_ATI = $8816;

GL_INTENSITY_FLOAT32_ATI = $8817;

GL_LUMINANCE_FLOAT32_ATI = $8818;

GL_LUMINANCE_ALPHA_FLOAT32_ATI = $8819;

GL_RGBA_FLOAT16_ATI = $881A;

GL_RGB_FLOAT16_ATI = $881B;

GL_ALPHA_FLOAT16_ATI = $881C;

GL_INTENSITY_FLOAT16_ATI = $881D;

GL_LUMINANCE_FLOAT16_ATI = $881E;

GL_LUMINANCE_ALPHA_FLOAT16_ATI = $881F;

GL_MIRROR_CLAMP_ATI = $8742;

GL_MIRROR_CLAMP_TO_EDGE_ATI = $8743;

GL_STATIC_ATI = $8760;

GL_DYNAMIC_ATI = $8761;

GL_PRESERVE_ATI = $8762;

GL_DISCARD_ATI = $8763;

GL_OBJECT_BUFFER_SIZE_ATI = $8764;

GL_OBJECT_BUFFER_USAGE_ATI = $8765;

GL_ARRAY_OBJECT_BUFFER_ATI = $8766;

GL_ARRAY_OBJECT_OFFSET_ATI = $8767;

GL_MAX_VERTEX_STREAMS_ATI = $876B;

GL_VERTEX_STREAM0_ATI = $876C;

GL_VERTEX_STREAM1_ATI = $876D;

GL_VERTEX_STREAM2_ATI = $876E;

GL_VERTEX_STREAM3_ATI = $876F;

GL_VERTEX_STREAM4_ATI = $8770;

GL_VERTEX_STREAM5_ATI = $8771;

GL_VERTEX_STREAM6_ATI = $8772;

GL_VERTEX_STREAM7_ATI = $8773;

GL_VERTEX_SOURCE_ATI = $8774;

GL_VBO_FREE_MEMORY_ATI = $87FB;

GL_TEXTURE_FREE_MEMORY_ATI = $87FC;

GL_RENDERBUFFER_FREE_MEMORY_ATI = $87FD;

GL_COUNTER_TYPE_AMD = $8BC0;

GL_COUNTER_RANGE_AMD = $8BC1;

GL_UNSIGNED_INT64_AMD = $8BC2;

GL_PERCENTAGE_AMD = $8BC3;

GL_PERFMON_RESULT_AVAILABLE_AMD = $8BC4;

GL_PERFMON_RESULT_SIZE_AMD = $8BC5;

GL_PERFMON_RESULT_AMD = $8BC6;

GL_SAMPLER_BUFFER_AMD = $9001;

GL_INT_SAMPLER_BUFFER_AMD = $9002;

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD = $9003;

GL_TESSELLATION_MODE_AMD = $9004;

GL_TESSELLATION_FACTOR_AMD = $9005;

GL_DISCRETE_AMD = $9006;

GL_CONTINUOUS_AMD = $9007;

GL_DATA_BUFFER_AMD = $9151;

GL_PERFORMANCE_MONITOR_AMD = $9152;

GL_QUERY_OBJECT_AMD = $9153;

GL_VERTEX_ARRAY_OBJECT_AMD = $9154;

GL_SAMPLER_OBJECT_AMD = $9155;

GL_MAX_DEBUG_LOGGED_MESSAGES_AMD = $9144;

GL_DEBUG_LOGGED_MESSAGES_AMD = $9145;

GL_DEBUG_SEVERITY_HIGH_AMD = $9146;

GL_DEBUG_SEVERITY_MEDIUM_AMD = $9147;

GL_DEBUG_SEVERITY_LOW_AMD = $9148;

GL_DEBUG_CATEGORY_API_ERROR_AMD = $9149;

GL_DEBUG_CATEGORY_WINDOW_SYSTEM_AMD = $914A;

GL_DEBUG_CATEGORY_DEPRECATION_AMD = $914B;

GL_DEBUG_CATEGORY_UNDEFINED_BEHAVIOR_AMD = $914C;

GL_DEBUG_CATEGORY_PERFORMANCE_AMD = $914D;

GL_DEBUG_CATEGORY_SHADER_COMPILER_AMD = $914E;

GL_DEBUG_CATEGORY_APPLICATION_AMD = $914F;

GL_DEBUG_CATEGORY_OTHER_AMD = $9150;

GL_DEPTH_CLAMP_NEAR_AMD = $901E;

GL_DEPTH_CLAMP_FAR_AMD = $901F;

GL_422_EXT = $80CC;

GL_422_REV_EXT = $80CD;

GL_422_AVERAGE_EXT = $80CE;

GL_422_REV_AVERAGE_EXT = $80CF;

GL_ABGR_EXT = $8000;

GL_BGR_EXT = $80E0;

GL_BGRA_EXT = $80E1;

GL_CONSTANT_COLOR_EXT = $8001;

GL_ONE_MINUS_CONSTANT_COLOR_EXT = $8002;

GL_CONSTANT_ALPHA_EXT = $8003;

GL_ONE_MINUS_CONSTANT_ALPHA_EXT = $8004;

GL_BLEND_COLOR_EXT = $8005;

GL_BLEND_DST_RGB_EXT = $80C8;

GL_BLEND_SRC_RGB_EXT = $80C9;

GL_BLEND_DST_ALPHA_EXT = $80CA;

GL_BLEND_SRC_ALPHA_EXT = $80CB;

GL_FUNC_ADD_EXT = $8006;

GL_MIN_EXT = $8007;

GL_MAX_EXT = $8008;

GL_BLEND_EQUATION_EXT = $8009;

GL_FUNC_SUBTRACT_EXT = $800A;

GL_FUNC_REVERSE_SUBTRACT_EXT = $800B;

GL_CLIP_VOLUME_CLIPPING_HINT_EXT = $80F0;

GL_CMYK_EXT = $800C;

GL_CMYKA_EXT = $800D;

GL_PACK_CMYK_HINT_EXT = $800E;

GL_UNPACK_CMYK_HINT_EXT = $800F;

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT = $81A8;

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT = $81A9;

GL_CONVOLUTION_1D_EXT = $8010;

GL_CONVOLUTION_2D_EXT = $8011;

GL_SEPARABLE_2D_EXT = $8012;

GL_CONVOLUTION_BORDER_MODE_EXT = $8013;

GL_CONVOLUTION_FILTER_SCALE_EXT = $8014;

GL_CONVOLUTION_FILTER_BIAS_EXT = $8015;

GL_REDUCE_EXT = $8016;

GL_CONVOLUTION_FORMAT_EXT = $8017;

GL_CONVOLUTION_WIDTH_EXT = $8018;

GL_CONVOLUTION_HEIGHT_EXT = $8019;

GL_MAX_CONVOLUTION_WIDTH_EXT = $801A;

GL_MAX_CONVOLUTION_HEIGHT_EXT = $801B;

GL_POST_CONVOLUTION_RED_SCALE_EXT = $801C;

GL_POST_CONVOLUTION_GREEN_SCALE_EXT = $801D;

GL_POST_CONVOLUTION_BLUE_SCALE_EXT = $801E;

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT = $801F;

GL_POST_CONVOLUTION_RED_BIAS_EXT = $8020;

GL_POST_CONVOLUTION_GREEN_BIAS_EXT = $8021;

GL_POST_CONVOLUTION_BLUE_BIAS_EXT = $8022;

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT = $8023;

GL_TANGENT_ARRAY_EXT = $8439;

GL_BINORMAL_ARRAY_EXT = $843A;

GL_CURRENT_TANGENT_EXT = $843B;

GL_CURRENT_BINORMAL_EXT = $843C;

GL_TANGENT_ARRAY_TYPE_EXT = $843E;

GL_TANGENT_ARRAY_STRIDE_EXT = $843F;

GL_BINORMAL_ARRAY_TYPE_EXT = $8440;

GL_BINORMAL_ARRAY_STRIDE_EXT = $8441;

GL_TANGENT_ARRAY_POINTER_EXT = $8442;

GL_BINORMAL_ARRAY_POINTER_EXT = $8443;

GL_MAP1_TANGENT_EXT = $8444;

GL_MAP2_TANGENT_EXT = $8445;

GL_MAP1_BINORMAL_EXT = $8446;

GL_MAP2_BINORMAL_EXT = $8447;

GL_CULL_VERTEX_EXT = $81AA;

GL_CULL_VERTEX_EYE_POSITION_EXT = $81AB;

GL_CULL_VERTEX_OBJECT_POSITION_EXT = $81AC;

GL_MAX_ELEMENTS_VERTICES_EXT = $80E8;

GL_MAX_ELEMENTS_INDICES_EXT = $80E9;

GL_FOG_COORDINATE_SOURCE_EXT = $8450;

GL_FOG_COORDINATE_EXT = $8451;

GL_FRAGMENT_DEPTH_EXT = $8452;

GL_CURRENT_FOG_COORDINATE_EXT = $8453;

GL_FOG_COORDINATE_ARRAY_TYPE_EXT = $8454;

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT = $8455;

GL_FOG_COORDINATE_ARRAY_POINTER_EXT = $8456;

GL_FOG_COORDINATE_ARRAY_EXT = $8457;

GL_FRAMEBUFFER_EXT = $8D40;

GL_RENDERBUFFER_EXT = $8D41;

GL_STENCIL_INDEX_EXT = $8D45;

GL_STENCIL_INDEX1_EXT = $8D46;

GL_STENCIL_INDEX4_EXT = $8D47;

GL_STENCIL_INDEX8_EXT = $8D48;

GL_STENCIL_INDEX16_EXT = $8D49;

GL_RENDERBUFFER_WIDTH_EXT = $8D42;

GL_RENDERBUFFER_HEIGHT_EXT = $8D43;

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT = $8D44;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT = $8CD0;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT = $8CD1;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT = $8CD2;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT = $8CD3;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT = $8CD4;

GL_COLOR_ATTACHMENT0_EXT = $8CE0;

GL_COLOR_ATTACHMENT1_EXT = $8CE1;

GL_COLOR_ATTACHMENT2_EXT = $8CE2;

GL_COLOR_ATTACHMENT3_EXT = $8CE3;

GL_COLOR_ATTACHMENT4_EXT = $8CE4;

GL_COLOR_ATTACHMENT5_EXT = $8CE5;

GL_COLOR_ATTACHMENT6_EXT = $8CE6;

GL_COLOR_ATTACHMENT7_EXT = $8CE7;

GL_COLOR_ATTACHMENT8_EXT = $8CE8;

GL_COLOR_ATTACHMENT9_EXT = $8CE9;

GL_COLOR_ATTACHMENT10_EXT = $8CEA;

GL_COLOR_ATTACHMENT11_EXT = $8CEB;

GL_COLOR_ATTACHMENT12_EXT = $8CEC;

GL_COLOR_ATTACHMENT13_EXT = $8CED;

GL_COLOR_ATTACHMENT14_EXT = $8CEE;

GL_COLOR_ATTACHMENT15_EXT = $8CEF;

GL_DEPTH_ATTACHMENT_EXT = $8D00;

GL_STENCIL_ATTACHMENT_EXT = $8D20;

GL_FRAMEBUFFER_COMPLETE_EXT = $8CD5;

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT = $8CD6;

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT = $8CD7;

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT = $8CD9;

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT = $8CDA;

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT = $8CDB;

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT = $8CDC;

GL_FRAMEBUFFER_UNSUPPORTED_EXT = $8CDD;

GL_FRAMEBUFFER_STATUS_ERROR_EXT = $8CDE;

GL_FRAMEBUFFER_BINDING_EXT = $8CA6;

GL_RENDERBUFFER_BINDING_EXT = $8CA7;

GL_MAX_COLOR_ATTACHMENTS_EXT = $8CDF;

GL_MAX_RENDERBUFFER_SIZE_EXT = $84E8;

GL_INVALID_FRAMEBUFFER_OPERATION_EXT = $0506;

GL_HISTOGRAM_EXT = $8024;

GL_PROXY_HISTOGRAM_EXT = $8025;

GL_HISTOGRAM_WIDTH_EXT = $8026;

GL_HISTOGRAM_FORMAT_EXT = $8027;

GL_HISTOGRAM_RED_SIZE_EXT = $8028;

GL_HISTOGRAM_GREEN_SIZE_EXT = $8029;

GL_HISTOGRAM_BLUE_SIZE_EXT = $802A;

GL_HISTOGRAM_ALPHA_SIZE_EXT = $802B;

GL_HISTOGRAM_LUMINANCE_SIZE_EXT = $802C;

GL_HISTOGRAM_SINK_EXT = $802D;

GL_MINMAX_EXT = $802E;

GL_MINMAX_FORMAT_EXT = $802F;

GL_MINMAX_SINK_EXT = $8030;

GL_TABLE_TOO_LARGE_EXT = $8031;

GL_IUI_V2F_EXT = $81AD;

GL_IUI_V3F_EXT = $81AE;

GL_IUI_N3F_V2F_EXT = $81AF;

GL_IUI_N3F_V3F_EXT = $81B0;

GL_T2F_IUI_V2F_EXT = $81B1;

GL_T2F_IUI_V3F_EXT = $81B2;

GL_T2F_IUI_N3F_V2F_EXT = $81B3;

GL_T2F_IUI_N3F_V3F_EXT = $81B4;

GL_INDEX_TEST_EXT = $81B5;

GL_INDEX_TEST_FUNC_EXT = $81B6;

GL_INDEX_TEST_REF_EXT = $81B7;

GL_INDEX_MATERIAL_EXT = $81B8;

GL_INDEX_MATERIAL_PARAMETER_EXT = $81B9;

GL_INDEX_MATERIAL_FACE_EXT = $81BA;

GL_FRAGMENT_MATERIAL_EXT = $8349;

GL_FRAGMENT_NORMAL_EXT = $834A;

GL_FRAGMENT_COLOR_EXT = $834C;

GL_ATTENUATION_EXT = $834D;

GL_SHADOW_ATTENUATION_EXT = $834E;

GL_TEXTURE_APPLICATION_MODE_EXT = $834F;

GL_TEXTURE_LIGHT_EXT = $8350;

GL_TEXTURE_MATERIAL_FACE_EXT = $8351;

GL_TEXTURE_MATERIAL_PARAMETER_EXT = $8352;

GL_MULTISAMPLE_EXT = $809D;

GL_SAMPLE_ALPHA_TO_MASK_EXT = $809E;

GL_SAMPLE_ALPHA_TO_ONE_EXT = $809F;

GL_SAMPLE_MASK_EXT = $80A0;

GL_1PASS_EXT = $80A1;

GL_2PASS_0_EXT = $80A2;

GL_2PASS_1_EXT = $80A3;

GL_4PASS_0_EXT = $80A4;

GL_4PASS_1_EXT = $80A5;

GL_4PASS_2_EXT = $80A6;

GL_4PASS_3_EXT = $80A7;

GL_SAMPLE_BUFFERS_EXT = $80A8;

GL_SAMPLES_EXT = $80A9;

GL_SAMPLE_MASK_VALUE_EXT = $80AA;

GL_SAMPLE_MASK_INVERT_EXT = $80AB;

GL_SAMPLE_PATTERN_EXT = $80AC;

GL_MULTISAMPLE_BIT_EXT = $20000000;

GL_UNSIGNED_BYTE_3_3_2_EXT = $8032;

GL_UNSIGNED_SHORT_4_4_4_4_EXT = $8033;

GL_UNSIGNED_SHORT_5_5_5_1_EXT = $8034;

GL_UNSIGNED_INT_8_8_8_8_EXT = $8035;

GL_UNSIGNED_INT_10_10_10_2_EXT = $8036;

GL_COLOR_INDEX1_EXT = $80E2;

GL_COLOR_INDEX2_EXT = $80E3;

GL_COLOR_INDEX4_EXT = $80E4;

GL_COLOR_INDEX8_EXT = $80E5;

GL_COLOR_INDEX12_EXT = $80E6;

GL_COLOR_INDEX16_EXT = $80E7;

GL_TEXTURE_INDEX_SIZE_EXT = $80ED;

GL_PIXEL_TRANSFORM_2D_EXT = $8330;

GL_PIXEL_MAG_FILTER_EXT = $8331;

GL_PIXEL_MIN_FILTER_EXT = $8332;

GL_PIXEL_CUBIC_WEIGHT_EXT = $8333;

GL_CUBIC_EXT = $8334;

GL_AVERAGE_EXT = $8335;

GL_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT = $8336;

GL_MAX_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT = $8337;

GL_PIXEL_TRANSFORM_2D_MATRIX_EXT = $8338;

GL_POINT_SIZE_MIN_EXT = $8126;

GL_POINT_SIZE_MAX_EXT = $8127;

GL_POINT_FADE_THRESHOLD_SIZE_EXT = $8128;

GL_DISTANCE_ATTENUATION_EXT = $8129;

GL_POLYGON_OFFSET_EXT = $8037;

GL_POLYGON_OFFSET_FACTOR_EXT = $8038;

GL_POLYGON_OFFSET_BIAS_EXT = $8039;

GL_RESCALE_NORMAL_EXT = $803A;

GL_COLOR_SUM_EXT = $8458;

GL_CURRENT_SECONDARY_COLOR_EXT = $8459;

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT = $845A;

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT = $845B;

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT = $845C;

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT = $845D;

GL_SECONDARY_COLOR_ARRAY_EXT = $845E;

GL_LIGHT_MODEL_COLOR_CONTROL_EXT = $81F8;

GL_SINGLE_COLOR_EXT = $81F9;

GL_SEPARATE_SPECULAR_COLOR_EXT = $81FA;

GL_SHARED_TEXTURE_PALETTE_EXT = $81FB;

GL_STENCIL_TEST_TWO_SIDE_EXT = $8910;

GL_ACTIVE_STENCIL_FACE_EXT = $8911;

GL_INCR_WRAP_EXT = $8507;

GL_DECR_WRAP_EXT = $8508;

GL_ALPHA4_EXT = $803B;

GL_ALPHA8_EXT = $803C;

GL_ALPHA12_EXT = $803D;

GL_ALPHA16_EXT = $803E;

GL_LUMINANCE4_EXT = $803F;

GL_LUMINANCE8_EXT = $8040;

GL_LUMINANCE12_EXT = $8041;

GL_LUMINANCE16_EXT = $8042;

GL_LUMINANCE4_ALPHA4_EXT = $8043;

GL_LUMINANCE6_ALPHA2_EXT = $8044;

GL_LUMINANCE8_ALPHA8_EXT = $8045;

GL_LUMINANCE12_ALPHA4_EXT = $8046;

GL_LUMINANCE12_ALPHA12_EXT = $8047;

GL_LUMINANCE16_ALPHA16_EXT = $8048;

GL_INTENSITY_EXT = $8049;

GL_INTENSITY4_EXT = $804A;

GL_INTENSITY8_EXT = $804B;

GL_INTENSITY12_EXT = $804C;

GL_INTENSITY16_EXT = $804D;

GL_RGB2_EXT = $804E;

GL_RGB4_EXT = $804F;

GL_RGB5_EXT = $8050;

GL_RGB8_EXT = $8051;

GL_RGB10_EXT = $8052;

GL_RGB12_EXT = $8053;

GL_RGB16_EXT = $8054;

GL_RGBA2_EXT = $8055;

GL_RGBA4_EXT = $8056;

GL_RGB5_A1_EXT = $8057;

GL_RGBA8_EXT = $8058;

GL_RGB10_A2_EXT = $8059;

GL_RGBA12_EXT = $805A;

GL_RGBA16_EXT = $805B;

GL_TEXTURE_RED_SIZE_EXT = $805C;

GL_TEXTURE_GREEN_SIZE_EXT = $805D;

GL_TEXTURE_BLUE_SIZE_EXT = $805E;

GL_TEXTURE_ALPHA_SIZE_EXT = $805F;

GL_TEXTURE_LUMINANCE_SIZE_EXT = $8060;

GL_TEXTURE_INTENSITY_SIZE_EXT = $8061;

GL_REPLACE_EXT = $8062;

GL_PROXY_TEXTURE_1D_EXT = $8063;

GL_PROXY_TEXTURE_2D_EXT = $8064;

GL_TEXTURE_TOO_LARGE_EXT = $8065;

GL_PACK_SKIP_IMAGES_EXT = $806B;

GL_PACK_IMAGE_HEIGHT_EXT = $806C;

GL_UNPACK_SKIP_IMAGES_EXT = $806D;

GL_UNPACK_IMAGE_HEIGHT_EXT = $806E;

GL_TEXTURE_3D_EXT = $806F;

GL_PROXY_TEXTURE_3D_EXT = $8070;

GL_TEXTURE_DEPTH_EXT = $8071;

GL_TEXTURE_WRAP_R_EXT = $8072;

GL_MAX_3D_TEXTURE_SIZE_EXT = $8073;

GL_COMPRESSED_RGB_S3TC_DXT1_EXT = $83F0;

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT = $83F1;

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT = $83F2;

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT = $83F3;

GL_NORMAL_MAP_EXT = $8511;

GL_REFLECTION_MAP_EXT = $8512;

GL_TEXTURE_CUBE_MAP_EXT = $8513;

GL_TEXTURE_BINDING_CUBE_MAP_EXT = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT = $851A;

GL_PROXY_TEXTURE_CUBE_MAP_EXT = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT = $851C;

GL_CLAMP_TO_EDGE_EXT = $812F;

GL_COMBINE_EXT = $8570;

GL_COMBINE_RGB_EXT = $8571;

GL_COMBINE_ALPHA_EXT = $8572;

GL_RGB_SCALE_EXT = $8573;

GL_ADD_SIGNED_EXT = $8574;

GL_INTERPOLATE_EXT = $8575;

GL_CONSTANT_EXT = $8576;

GL_PRIMARY_COLOR_EXT = $8577;

GL_PREVIOUS_EXT = $8578;

GL_SOURCE0_RGB_EXT = $8580;

GL_SOURCE1_RGB_EXT = $8581;

GL_SOURCE2_RGB_EXT = $8582;

GL_SOURCE0_ALPHA_EXT = $8588;

GL_SOURCE1_ALPHA_EXT = $8589;

GL_SOURCE2_ALPHA_EXT = $858A;

GL_OPERAND0_RGB_EXT = $8590;

GL_OPERAND1_RGB_EXT = $8591;

GL_OPERAND2_RGB_EXT = $8592;

GL_OPERAND0_ALPHA_EXT = $8598;

GL_OPERAND1_ALPHA_EXT = $8599;

GL_OPERAND2_ALPHA_EXT = $859A;

GL_DOT3_RGB_EXT = $8740;

GL_DOT3_RGBA_EXT = $8741;

GL_TEXTURE_MAX_ANISOTROPY_EXT = $84FE;

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT = $84FF;

GL_MAX_TEXTURE_LOD_BIAS_EXT = $84FD;

GL_TEXTURE_FILTER_CONTROL_EXT = $8500;

GL_TEXTURE_LOD_BIAS_EXT = $8501;

GL_TEXTURE_PRIORITY_EXT = $8066;

GL_TEXTURE_RESIDENT_EXT = $8067;

GL_TEXTURE_1D_BINDING_EXT = $8068;

GL_TEXTURE_2D_BINDING_EXT = $8069;

GL_TEXTURE_3D_BINDING_EXT = $806A;

GL_PERTURB_EXT = $85AE;

GL_TEXTURE_NORMAL_EXT = $85AF;

GL_TEXTURE_RECTANGLE_EXT = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_EXT = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_EXT = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT = $84F8;

GL_VERTEX_ARRAY_EXT = $8074;

GL_NORMAL_ARRAY_EXT = $8075;

GL_COLOR_ARRAY_EXT = $8076;

GL_INDEX_ARRAY_EXT = $8077;

GL_TEXTURE_COORD_ARRAY_EXT = $8078;

GL_EDGE_FLAG_ARRAY_EXT = $8079;

GL_VERTEX_ARRAY_SIZE_EXT = $807A;

GL_VERTEX_ARRAY_TYPE_EXT = $807B;

GL_VERTEX_ARRAY_STRIDE_EXT = $807C;

GL_VERTEX_ARRAY_COUNT_EXT = $807D;

GL_NORMAL_ARRAY_TYPE_EXT = $807E;

GL_NORMAL_ARRAY_STRIDE_EXT = $807F;

GL_NORMAL_ARRAY_COUNT_EXT = $8080;

GL_COLOR_ARRAY_SIZE_EXT = $8081;

GL_COLOR_ARRAY_TYPE_EXT = $8082;

GL_COLOR_ARRAY_STRIDE_EXT = $8083;

GL_COLOR_ARRAY_COUNT_EXT = $8084;

GL_INDEX_ARRAY_TYPE_EXT = $8085;

GL_INDEX_ARRAY_STRIDE_EXT = $8086;

GL_INDEX_ARRAY_COUNT_EXT = $8087;

GL_TEXTURE_COORD_ARRAY_SIZE_EXT = $8088;

GL_TEXTURE_COORD_ARRAY_TYPE_EXT = $8089;

GL_TEXTURE_COORD_ARRAY_STRIDE_EXT = $808A;

GL_TEXTURE_COORD_ARRAY_COUNT_EXT = $808B;

GL_EDGE_FLAG_ARRAY_STRIDE_EXT = $808C;

GL_EDGE_FLAG_ARRAY_COUNT_EXT = $808D;

GL_VERTEX_ARRAY_POINTER_EXT = $808E;

GL_NORMAL_ARRAY_POINTER_EXT = $808F;

GL_COLOR_ARRAY_POINTER_EXT = $8090;

GL_INDEX_ARRAY_POINTER_EXT = $8091;

GL_TEXTURE_COORD_ARRAY_POINTER_EXT = $8092;

GL_EDGE_FLAG_ARRAY_POINTER_EXT = $8093;

GL_VERTEX_SHADER_EXT = $8780;

GL_VERTEX_SHADER_BINDING_EXT = $8781;

GL_OP_INDEX_EXT = $8782;

GL_OP_NEGATE_EXT = $8783;

GL_OP_DOT3_EXT = $8784;

GL_OP_DOT4_EXT = $8785;

GL_OP_MUL_EXT = $8786;

GL_OP_ADD_EXT = $8787;

GL_OP_MADD_EXT = $8788;

GL_OP_FRAC_EXT = $8789;

GL_OP_MAX_EXT = $878A;

GL_OP_MIN_EXT = $878B;

GL_OP_SET_GE_EXT = $878C;

GL_OP_SET_LT_EXT = $878D;

GL_OP_CLAMP_EXT = $878E;

GL_OP_FLOOR_EXT = $878F;

GL_OP_ROUND_EXT = $8790;

GL_OP_EXP_BASE_2_EXT = $8791;

GL_OP_LOG_BASE_2_EXT = $8792;

GL_OP_POWER_EXT = $8793;

GL_OP_RECIP_EXT = $8794;

GL_OP_RECIP_SQRT_EXT = $8795;

GL_OP_SUB_EXT = $8796;

GL_OP_CROSS_PRODUCT_EXT = $8797;

GL_OP_MULTIPLY_MATRIX_EXT = $8798;

GL_OP_MOV_EXT = $8799;

GL_OUTPUT_VERTEX_EXT = $879A;

GL_OUTPUT_COLOR0_EXT = $879B;

GL_OUTPUT_COLOR1_EXT = $879C;

GL_OUTPUT_TEXTURE_COORD0_EXT = $879D;

GL_OUTPUT_TEXTURE_COORD1_EXT = $879E;

GL_OUTPUT_TEXTURE_COORD2_EXT = $879F;

GL_OUTPUT_TEXTURE_COORD3_EXT = $87A0;

GL_OUTPUT_TEXTURE_COORD4_EXT = $87A1;

GL_OUTPUT_TEXTURE_COORD5_EXT = $87A2;

GL_OUTPUT_TEXTURE_COORD6_EXT = $87A3;

GL_OUTPUT_TEXTURE_COORD7_EXT = $87A4;

GL_OUTPUT_TEXTURE_COORD8_EXT = $87A5;

GL_OUTPUT_TEXTURE_COORD9_EXT = $87A6;

GL_OUTPUT_TEXTURE_COORD10_EXT = $87A7;

GL_OUTPUT_TEXTURE_COORD11_EXT = $87A8;

GL_OUTPUT_TEXTURE_COORD12_EXT = $87A9;

GL_OUTPUT_TEXTURE_COORD13_EXT = $87AA;

GL_OUTPUT_TEXTURE_COORD14_EXT = $87AB;

GL_OUTPUT_TEXTURE_COORD15_EXT = $87AC;

GL_OUTPUT_TEXTURE_COORD16_EXT = $87AD;

GL_OUTPUT_TEXTURE_COORD17_EXT = $87AE;

GL_OUTPUT_TEXTURE_COORD18_EXT = $87AF;

GL_OUTPUT_TEXTURE_COORD19_EXT = $87B0;

GL_OUTPUT_TEXTURE_COORD20_EXT = $87B1;

GL_OUTPUT_TEXTURE_COORD21_EXT = $87B2;

GL_OUTPUT_TEXTURE_COORD22_EXT = $87B3;

GL_OUTPUT_TEXTURE_COORD23_EXT = $87B4;

GL_OUTPUT_TEXTURE_COORD24_EXT = $87B5;

GL_OUTPUT_TEXTURE_COORD25_EXT = $87B6;

GL_OUTPUT_TEXTURE_COORD26_EXT = $87B7;

GL_OUTPUT_TEXTURE_COORD27_EXT = $87B8;

GL_OUTPUT_TEXTURE_COORD28_EXT = $87B9;

GL_OUTPUT_TEXTURE_COORD29_EXT = $87BA;

GL_OUTPUT_TEXTURE_COORD30_EXT = $87BB;

GL_OUTPUT_TEXTURE_COORD31_EXT = $87BC;

GL_OUTPUT_FOG_EXT = $87BD;

GL_SCALAR_EXT = $87BE;

GL_VECTOR_EXT = $87BF;

GL_MATRIX_EXT = $87C0;

GL_VARIANT_EXT = $87C1;

GL_INVARIANT_EXT = $87C2;

GL_LOCAL_CONSTANT_EXT = $87C3;

GL_LOCAL_EXT = $87C4;

GL_MAX_VERTEX_SHADER_INSTRUCTIONS_EXT = $87C5;

GL_MAX_VERTEX_SHADER_VARIANTS_EXT = $87C6;

GL_MAX_VERTEX_SHADER_INVARIANTS_EXT = $87C7;

GL_MAX_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87C8;

GL_MAX_VERTEX_SHADER_LOCALS_EXT = $87C9;

GL_MAX_OPTIMIZED_VERTEX_SHADER_INSTRUCTIONS_EXT = $87CA;

GL_MAX_OPTIMIZED_VERTEX_SHADER_VARIANTS_EXT = $87CB;

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87CC;

GL_MAX_OPTIMIZED_VERTEX_SHADER_INVARIANTS_EXT = $87CD;

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCALS_EXT = $87CE;

GL_VERTEX_SHADER_INSTRUCTIONS_EXT = $87CF;

GL_VERTEX_SHADER_VARIANTS_EXT = $87D0;

GL_VERTEX_SHADER_INVARIANTS_EXT = $87D1;

GL_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87D2;

GL_VERTEX_SHADER_LOCALS_EXT = $87D3;

GL_VERTEX_SHADER_OPTIMIZED_EXT = $87D4;

GL_X_EXT = $87D5;

GL_Y_EXT = $87D6;

GL_Z_EXT = $87D7;

GL_W_EXT = $87D8;

GL_NEGATIVE_X_EXT = $87D9;

GL_NEGATIVE_Y_EXT = $87DA;

GL_NEGATIVE_Z_EXT = $87DB;

GL_NEGATIVE_W_EXT = $87DC;

GL_ZERO_EXT = $87DD;

GL_ONE_EXT = $87DE;

GL_NEGATIVE_ONE_EXT = $87DF;

GL_NORMALIZED_RANGE_EXT = $87E0;

GL_FULL_RANGE_EXT = $87E1;

GL_CURRENT_VERTEX_EXT = $87E2;

GL_MVP_MATRIX_EXT = $87E3;

GL_VARIANT_VALUE_EXT = $87E4;

GL_VARIANT_DATATYPE_EXT = $87E5;

GL_VARIANT_ARRAY_STRIDE_EXT = $87E6;

GL_VARIANT_ARRAY_TYPE_EXT = $87E7;

GL_VARIANT_ARRAY_EXT = $87E8;

GL_VARIANT_ARRAY_POINTER_EXT = $87E9;

GL_INVARIANT_VALUE_EXT = $87EA;

GL_INVARIANT_DATATYPE_EXT = $87EB;

GL_LOCAL_CONSTANT_VALUE_EXT = $87EC;

GL_LOCAL_CONSTANT_DATATYPE_EXT = $87ED;

GL_MODELVIEW0_STACK_DEPTH_EXT = $0BA3;

GL_MODELVIEW1_STACK_DEPTH_EXT = $8502;

GL_MODELVIEW0_MATRIX_EXT = $0BA6;

GL_MODELVIEW1_MATRIX_EXT = $8506;

GL_VERTEX_WEIGHTING_EXT = $8509;

GL_MODELVIEW0_EXT = $1700;

GL_MODELVIEW1_EXT = $850A;

GL_CURRENT_VERTEX_WEIGHT_EXT = $850B;

GL_VERTEX_WEIGHT_ARRAY_EXT = $850C;

GL_VERTEX_WEIGHT_ARRAY_SIZE_EXT = $850D;

GL_VERTEX_WEIGHT_ARRAY_TYPE_EXT = $850E;

GL_VERTEX_WEIGHT_ARRAY_STRIDE_EXT = $850F;

GL_VERTEX_WEIGHT_ARRAY_POINTER_EXT = $8510;

GL_DEPTH_BOUNDS_TEST_EXT = $8890;

GL_DEPTH_BOUNDS_EXT = $8891;

GL_MIRROR_CLAMP_EXT = $8742;

GL_MIRROR_CLAMP_TO_EDGE_EXT = $8743;

GL_MIRROR_CLAMP_TO_BORDER_EXT = $8912;

GL_BLEND_EQUATION_RGB_EXT = $8009;

GL_BLEND_EQUATION_ALPHA_EXT = $883D;

GL_PIXEL_PACK_BUFFER_EXT = $88EB;

GL_PIXEL_UNPACK_BUFFER_EXT = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING_EXT = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT = $88EF;

GL_STENCIL_TAG_BITS_EXT = $88F2;

GL_STENCIL_CLEAR_TAG_VALUE_EXT = $88F3;

GL_DEPTH_STENCIL_EXT = $84F9;

GL_UNSIGNED_INT_24_8_EXT = $84FA;

GL_DEPTH24_STENCIL8_EXT = $88F0;

GL_TEXTURE_STENCIL_SIZE_EXT = $88F1;

GL_SRGB_EXT = $8C40;

GL_SRGB8_EXT = $8C41;

GL_SRGB_ALPHA_EXT = $8C42;

GL_SRGB8_ALPHA8_EXT = $8C43;

GL_SLUMINANCE_ALPHA_EXT = $8C44;

GL_SLUMINANCE8_ALPHA8_EXT = $8C45;

GL_SLUMINANCE_EXT = $8C46;

GL_SLUMINANCE8_EXT = $8C47;

GL_COMPRESSED_SRGB_EXT = $8C48;

GL_COMPRESSED_SRGB_ALPHA_EXT = $8C49;

GL_COMPRESSED_SLUMINANCE_EXT = $8C4A;

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT = $8C4B;

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT = $8C4C;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT = $8C4D;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT = $8C4E;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT = $8C4F;

GL_READ_FRAMEBUFFER_EXT = $8CA8;

GL_DRAW_FRAMEBUFFER_EXT = $8CA9;

GL_READ_FRAMEBUFFER_BINDING_EXT = GL_FRAMEBUFFER_BINDING_EXT;

GL_DRAW_FRAMEBUFFER_BINDING_EXT = $8CAA;

GL_RENDERBUFFER_SAMPLES_EXT = $8CAB;

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT = $8D56;

GL_MAX_SAMPLES_EXT = $8D57;

GL_TIME_ELAPSED_EXT = $88BF;

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT = $8DE2;

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT = $8DE3;

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT = $8DE4;

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT = $8DED;

GL_UNIFORM_BUFFER_EXT = $8DEE;

GL_UNIFORM_BUFFER_BINDING_EXT = $8DEF;

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2;

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20A9;

GL_FRAMEBUFFER_SRGB_EXT = $8DB9;

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $8DBA;

GL_GEOMETRY_SHADER_EXT = $8DD9;

GL_GEOMETRY_VERTICES_OUT_EXT = $8DDA;

GL_GEOMETRY_INPUT_TYPE_EXT = $8DDB;

GL_GEOMETRY_OUTPUT_TYPE_EXT = $8DDC;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT = $8C29;

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT = $8DDD;

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT = $8DDE;

GL_MAX_VARYING_COMPONENTS_EXT = $8B4B;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT = $8DE1;

GL_LINES_ADJACENCY_EXT = $A;

GL_LINE_STRIP_ADJACENCY_EXT = $B;

GL_TRIANGLES_ADJACENCY_EXT = $C;

GL_TRIANGLE_STRIP_ADJACENCY_EXT = $D;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT = $8DA8;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT = $8DA9;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT = $8DA7;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT = $8CD4;

GL_PROGRAM_POINT_SIZE_EXT = $8642;

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT = $88FD;

GL_SAMPLER_1D_ARRAY_EXT = $8DC0;

GL_SAMPLER_2D_ARRAY_EXT = $8DC1;

GL_SAMPLER_BUFFER_EXT = $8DC2;

GL_SAMPLER_1D_ARRAY_SHADOW_EXT = $8DC3;

GL_SAMPLER_2D_ARRAY_SHADOW_EXT = $8DC4;

GL_SAMPLER_CUBE_SHADOW_EXT = $8DC5;

GL_UNSIGNED_INT_VEC2_EXT = $8DC6;

GL_UNSIGNED_INT_VEC3_EXT = $8DC7;

GL_UNSIGNED_INT_VEC4_EXT = $8DC8;

GL_INT_SAMPLER_1D_EXT = $8DC9;

GL_INT_SAMPLER_2D_EXT = $8DCA;

GL_INT_SAMPLER_3D_EXT = $8DCB;

GL_INT_SAMPLER_CUBE_EXT = $8DCC;

GL_INT_SAMPLER_2D_RECT_EXT = $8DCD;

GL_INT_SAMPLER_1D_ARRAY_EXT = $8DCE;

GL_INT_SAMPLER_2D_ARRAY_EXT = $8DCF;

GL_INT_SAMPLER_BUFFER_EXT = $8DD0;

GL_UNSIGNED_INT_SAMPLER_1D_EXT = $8DD1;

GL_UNSIGNED_INT_SAMPLER_2D_EXT = $8DD2;

GL_UNSIGNED_INT_SAMPLER_3D_EXT = $8DD3;

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT = $8DD4;

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT = $8DD5;

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT = $8DD6;

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT = $8DD7;

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT = $8DD8;

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT = $8904;

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT = $8905;

GL_R11F_G11F_B10F_EXT = $8C3A;

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT = $8C3B;

RGBA_SIGNED_COMPONENTS_EXT = $8C3C;

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1;

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008;

GL_TEXTURE_1D_ARRAY_EXT = $8C18;

GL_TEXTURE_2D_ARRAY_EXT = $8C1A;

GL_PROXY_TEXTURE_2D_ARRAY_EXT = $8C1B;

GL_PROXY_TEXTURE_1D_ARRAY_EXT = $8C19;

GL_TEXTURE_BINDING_1D_ARRAY_EXT = $8C1C;

GL_TEXTURE_BINDING_2D_ARRAY_EXT = $8C1D;

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT = $88FF;

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT = $884E;

GL_TEXTURE_BUFFER_EXT = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE_EXT = $8C2B;

GL_TEXTURE_BINDING_BUFFER_EXT = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT = $8C2D;

GL_TEXTURE_BUFFER_FORMAT_EXT = $8C2E;

GL_COMPRESSED_LUMINANCE_LATC1_EXT = $8C70;

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT = $8C71;

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT = $8C72;

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT = $8C73;

GL_COMPRESSED_RED_RGTC1_EXT = $8DBB;

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT = $8DBC;

GL_COMPRESSED_RED_GREEN_RGTC2_EXT = $8DBD;

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT = $8DBE;

GL_RGBA_INTEGER_MODE_EXT = $8D9E;

GL_RGBA32UI_EXT = $8D70;

GL_RGB32UI_EXT = $8D71;

GL_ALPHA32UI_EXT = $8D72;

GL_INTENSITY32UI_EXT = $8D73;

GL_LUMINANCE32UI_EXT = $8D74;

GL_LUMINANCE_ALPHA32UI_EXT = $8D75;

GL_RGBA16UI_EXT = $8D76;

GL_RGB16UI_EXT = $8D77;

GL_ALPHA16UI_EXT = $8D78;

GL_INTENSITY16UI_EXT = $8D79;

GL_LUMINANCE16UI_EXT = $8D7A;

GL_LUMINANCE_ALPHA16UI_EXT = $8D7B;

GL_RGBA8UI_EXT = $8D7C;

GL_RGB8UI_EXT = $8D7D;

GL_ALPHA8UI_EXT = $8D7E;

GL_INTENSITY8UI_EXT = $8D7F;

GL_LUMINANCE8UI_EXT = $8D80;

GL_LUMINANCE_ALPHA8UI_EXT = $8D81;

GL_RGBA32I_EXT = $8D82;

GL_RGB32I_EXT = $8D83;

GL_ALPHA32I_EXT = $8D84;

GL_INTENSITY32I_EXT = $8D85;

GL_LUMINANCE32I_EXT = $8D86;

GL_LUMINANCE_ALPHA32I_EXT = $8D87;

GL_RGBA16I_EXT = $8D88;

GL_RGB16I_EXT = $8D89;

GL_ALPHA16I_EXT = $8D8A;

GL_INTENSITY16I_EXT = $8D8B;

GL_LUMINANCE16I_EXT = $8D8C;

GL_LUMINANCE_ALPHA16I_EXT = $8D8D;

GL_RGBA8I_EXT = $8D8E;

GL_RGB8I_EXT = $8D8F;

GL_ALPHA8I_EXT = $8D90;

GL_INTENSITY8I_EXT = $8D91;

GL_LUMINANCE8I_EXT = $8D92;

GL_LUMINANCE_ALPHA8I_EXT = $8D93;

GL_RED_INTEGER_EXT = $8D94;

GL_GREEN_INTEGER_EXT = $8D95;

GL_BLUE_INTEGER_EXT = $8D96;

GL_ALPHA_INTEGER_EXT = $8D97;

GL_RGB_INTEGER_EXT = $8D98;

GL_RGBA_INTEGER_EXT = $8D99;

GL_BGR_INTEGER_EXT = $8D9A;

GL_BGRA_INTEGER_EXT = $8D9B;

GL_LUMINANCE_INTEGER_EXT = $8D9C;

GL_LUMINANCE_ALPHA_INTEGER_EXT = $8D9D;

GL_RGB9_E5_EXT = $8C3D;

GL_UNSIGNED_INT_5_9_9_9_REV_EXT = $8C3E;

GL_TEXTURE_SHARED_SIZE_EXT = $8C3F;

GL_TRANSFORM_FEEDBACK_BUFFER_EXT = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT = $8C85;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT = $8C8F;

GL_INTERLEAVED_ATTRIBS_EXT = $8C8C;

GL_SEPARATE_ATTRIBS_EXT = $8C8D;

GL_PRIMITIVES_GENERATED_EXT = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT = $8C88;

GL_RASTERIZER_DISCARD_EXT = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT = $8C8B;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT = $8C80;

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT = $8C7F;

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT = $8C76;

GL_PROGRAM_MATRIX_EXT = $8E2D;

GL_TRANSPOSE_PROGRAM_MATRIX_EXT = $8E2E;

GL_PROGRAM_MATRIX_STACK_DEPTH_EXT = $8E2F;

GL_TEXTURE_SWIZZLE_R_EXT = $8E42;

GL_TEXTURE_SWIZZLE_G_EXT = $8E43;

GL_TEXTURE_SWIZZLE_B_EXT = $8E44;

GL_TEXTURE_SWIZZLE_A_EXT = $8E45;

GL_TEXTURE_SWIZZLE_RGBA_EXT = $8E46;

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION_EXT = $8E4C;

GL_FIRST_VERTEX_CONVENTION_EXT = $8E4D;

GL_LAST_VERTEX_CONVENTION_EXT = $8E4E;

GL_PROVOKING_VERTEX_EXT = $8E4F;

GL_ALPHA_SNORM = $9010;

GL_LUMINANCE_SNORM = $9011;

GL_LUMINANCE_ALPHA_SNORM = $9012;

GL_INTENSITY_SNORM = $9013;

GL_ALPHA8_SNORM = $9014;

GL_LUMINANCE8_SNORM = $9015;

GL_LUMINANCE8_ALPHA8_SNORM = $9016;

GL_INTENSITY8_SNORM = $9017;

GL_ALPHA16_SNORM = $9018;

GL_LUMINANCE16_SNORM = $9019;

GL_LUMINANCE16_ALPHA16_SNORM = $901A;

GL_INTENSITY16_SNORM = $901B;

GL_ACTIVE_PROGRAM_EXT = $8B8D;

GL_MAX_IMAGE_UNITS_EXT = $8F38;

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS_EXT = $8F39;

GL_IMAGE_BINDING_NAME_EXT = $8F3A;

GL_IMAGE_BINDING_LEVEL_EXT = $8F3B;

GL_IMAGE_BINDING_LAYERED_EXT = $8F3C;

GL_IMAGE_BINDING_LAYER_EXT = $8F3D;

GL_IMAGE_BINDING_ACCESS_EXT = $8F3E;

GL_IMAGE_1D_EXT = $904C;

GL_IMAGE_2D_EXT = $904D;

GL_IMAGE_3D_EXT = $904E;

GL_IMAGE_2D_RECT_EXT = $904F;

GL_IMAGE_CUBE_EXT = $9050;

GL_IMAGE_BUFFER_EXT = $9051;

GL_IMAGE_1D_ARRAY_EXT = $9052;

GL_IMAGE_2D_ARRAY_EXT = $9053;

GL_IMAGE_CUBE_MAP_ARRAY_EXT = $9054;

GL_IMAGE_2D_MULTISAMPLE_EXT = $9055;

GL_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $9056;

GL_INT_IMAGE_1D_EXT = $9057;

GL_INT_IMAGE_2D_EXT = $9058;

GL_INT_IMAGE_3D_EXT = $9059;

GL_INT_IMAGE_2D_RECT_EXT = $905A;

GL_INT_IMAGE_CUBE_EXT = $905B;

GL_INT_IMAGE_BUFFER_EXT = $905C;

GL_INT_IMAGE_1D_ARRAY_EXT = $905D;

GL_INT_IMAGE_2D_ARRAY_EXT = $905E;

GL_INT_IMAGE_CUBE_MAP_ARRAY_EXT = $905F;

GL_INT_IMAGE_2D_MULTISAMPLE_EXT = $9060;

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $9061;

GL_UNSIGNED_INT_IMAGE_1D_EXT = $9062;

GL_UNSIGNED_INT_IMAGE_2D_EXT = $9063;

GL_UNSIGNED_INT_IMAGE_3D_EXT = $9064;

GL_UNSIGNED_INT_IMAGE_2D_RECT_EXT = $9065;

GL_UNSIGNED_INT_IMAGE_CUBE_EXT = $9066;

GL_UNSIGNED_INT_IMAGE_BUFFER_EXT = $9067;

GL_UNSIGNED_INT_IMAGE_1D_ARRAY_EXT = $9068;

GL_UNSIGNED_INT_IMAGE_2D_ARRAY_EXT = $9069;

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY_EXT = $906A;

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_EXT = $906B;

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $906C;

GL_MAX_IMAGE_SAMPLES_EXT = $906D;

GL_IMAGE_BINDING_FORMAT_EXT = $906E;

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT_EXT = $00000001;

GL_ELEMENT_ARRAY_BARRIER_BIT_EXT = $00000002;

GL_UNIFORM_BARRIER_BIT_EXT = $00000004;

GL_TEXTURE_FETCH_BARRIER_BIT_EXT = $00000008;

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT_EXT = $00000020;

GL_COMMAND_BARRIER_BIT_EXT = $00000040;

GL_PIXEL_BUFFER_BARRIER_BIT_EXT = $00000080;

GL_TEXTURE_UPDATE_BARRIER_BIT_EXT = $00000100;

GL_BUFFER_UPDATE_BARRIER_BIT_EXT = $00000200;

GL_FRAMEBUFFER_BARRIER_BIT_EXT = $00000400;

GL_TRANSFORM_FEEDBACK_BARRIER_BIT_EXT = $00000800;

GL_ATOMIC_COUNTER_BARRIER_BIT_EXT = $00001000;

GL_ALL_BARRIER_BITS_EXT = $FFFFFFFF;

GL_DOUBLE_VEC2_EXT = $8FFC;

GL_DOUBLE_VEC3_EXT = $8FFD;

GL_DOUBLE_VEC4_EXT = $8FFE;

GL_DOUBLE_MAT2_EXT = $8F46;

GL_DOUBLE_MAT3_EXT = $8F47;

GL_DOUBLE_MAT4_EXT = $8F48;

GL_DOUBLE_MAT2x3_EXT = $8F49;

GL_DOUBLE_MAT2x4_EXT = $8F4A;

GL_DOUBLE_MAT3x2_EXT = $8F4B;

GL_DOUBLE_MAT3x4_EXT = $8F4C;

GL_DOUBLE_MAT4x2_EXT = $8F4D;

GL_DOUBLE_MAT4x3_EXT = $8F4E;

GL_TEXTURE_SRGB_DECODE_EXT = $8A48;

GL_DECODE_EXT = $8A49;

GL_SKIP_DECODE_EXT = $8A4A;

GL_TEXTURE_COVERAGE_SAMPLES_NV = $9045;

GL_TEXTURE_COLOR_SAMPLES_NV = $9046;

GL_FACTOR_MIN_AMD = $901C;

GL_FACTOR_MAX_AMD = $901D;

GL_SUBSAMPLE_DISTANCE_AMD = $883F;

GL_SYNC_X11_FENCE_EXT = $90E1;

GL_SCALED_RESOLVE_FASTEST_EXT = $90BA;

GL_SCALED_RESOLVE_NICEST_EXT = $90BB;

GL_PATH_FORMAT_SVG_NV = $9070;

GL_PATH_FORMAT_PS_NV = $9071;

GL_STANDARD_FONT_NAME_NV = $9072;

GL_SYSTEM_FONT_NAME_NV = $9073;

GL_FILE_NAME_NV = $9074;

GL_PATH_STROKE_WIDTH_NV = $9075;

GL_PATH_END_CAPS_NV = $9076;

GL_PATH_INITIAL_END_CAP_NV = $9077;

GL_PATH_TERMINAL_END_CAP_NV = $9078;

GL_PATH_JOIN_STYLE_NV = $9079;

GL_PATH_MITER_LIMIT_NV = $907A;

GL_PATH_DASH_CAPS_NV = $907B;

GL_PATH_INITIAL_DASH_CAP_NV = $907C;

GL_PATH_TERMINAL_DASH_CAP_NV = $907D;

GL_PATH_DASH_OFFSET_NV = $907E;

GL_PATH_CLIENT_LENGTH_NV = $907F;

GL_PATH_FILL_MODE_NV = $9080;

GL_PATH_FILL_MASK_NV = $9081;

GL_PATH_FILL_COVER_MODE_NV = $9082;

GL_PATH_STROKE_COVER_MODE_NV = $9083;

GL_PATH_STROKE_MASK_NV = $9084;

GL_PATH_SAMPLE_QUALITY_NV = $9085;

GL_PATH_STROKE_BOUND_NV = $9086;

GL_PATH_STROKE_OVERSAMPLE_COUNT_NV= $9087;

GL_COUNT_UP_NV = $9088;

GL_COUNT_DOWN_NV = $9089;

GL_PATH_OBJECT_BOUNDING_BOX_NV = $908A;

GL_CONVEX_HULL_NV = $908B;

GL_MULTI_HULLS_NV = $908C;

GL_BOUNDING_BOX_NV = $908D;

GL_TRANSLATE_X_NV = $908E;

GL_TRANSLATE_Y_NV = $908F;

GL_TRANSLATE_2D_NV = $9090;

GL_TRANSLATE_3D_NV = $9091;

GL_AFFINE_2D_NV = $9092;

GL_PROJECTIVE_2D_NV = $9093;

GL_AFFINE_3D_NV = $9094;

GL_PROJECTIVE_3D_NV = $9095;

GL_TRANSPOSE_AFFINE_2D_NV = $9096;

GL_TRANSPOSE_PROJECTIVE_2D_NV = $9097;

GL_TRANSPOSE_AFFINE_3D_NV = $9098;

GL_TRANSPOSE_PROJECTIVE_3D_NV = $9099;

GL_UTF8_NV = $909A;

GL_UTF16_NV = $909B;

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV= $909C;

GL_PATH_COMMAND_COUNT_NV = $909D;

GL_PATH_COORD_COUNT_NV = $909E;

GL_PATH_DASH_ARRAY_COUNT_NV = $909F;

GL_PATH_COMPUTED_LENGTH_NV = $90A0;

GL_PATH_FILL_BOUNDING_BOX_NV = $90A1;

GL_PATH_STROKE_BOUNDING_BOX_NV = $90A2;

GL_SQUARE_NV = $90A3;

GL_ROUND_NV = $90A4;

GL_TRIANGULAR_NV = $90A5;

GL_BEVEL_NV = $90A6;

GL_MITER_REVERT_NV = $90A7;

GL_MITER_TRUNCATE_NV = $90A8;

GL_SKIP_MISSING_GLYPH_NV = $90A9;

GL_USE_MISSING_GLYPH_NV = $90AA;

GL_PATH_ERROR_POSITION_NV = $90AB;

GL_PATH_FOG_GEN_MODE_NV = $90AC;

GL_ACCUM_ADJACENT_PAIRS_NV = $90AD;

GL_ADJACENT_PAIRS_NV = $90AE;

GL_FIRST_TO_REST_NV = $90AF;

GL_PATH_GEN_MODE_NV = $90B0;

GL_PATH_GEN_COEFF_NV = $90B1;

GL_PATH_GEN_COLOR_FORMAT_NV = $90B2;

GL_PATH_GEN_COMPONENTS_NV = $90B3;

GL_PATH_STENCIL_FUNC_NV = $90B7;

GL_PATH_STENCIL_REF_NV = $90B8;

GL_PATH_STENCIL_VALUE_MASK_NV = $90B9;

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV= $90BD;

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV= $90BE;

GL_PATH_COVER_DEPTH_FUNC_NV = $90BF;

GL_PATH_DASH_OFFSET_RESET_NV = $90B4;

GL_MOVE_TO_RESETS_NV = $90B5;

GL_MOVE_TO_CONTINUES_NV = $90B6;

GL_CLOSE_PATH_NV = $00;

GL_MOVE_TO_NV = $02;

GL_RELATIVE_MOVE_TO_NV = $03;

GL_LINE_TO_NV = $04;

GL_RELATIVE_LINE_TO_NV = $05;

GL_HORIZONTAL_LINE_TO_NV = $06;

GL_RELATIVE_HORIZONTAL_LINE_TO_NV= $07;

GL_VERTICAL_LINE_TO_NV = $08;

GL_RELATIVE_VERTICAL_LINE_TO_NV = $09;

GL_QUADRATIC_CURVE_TO_NV = $0A;

GL_RELATIVE_QUADRATIC_CURVE_TO_NV= $0B;

GL_CUBIC_CURVE_TO_NV = $0C;

GL_RELATIVE_CUBIC_CURVE_TO_NV = $0D;

GL_SMOOTH_QUADRATIC_CURVE_TO_NV = $0E;

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV= $0F;

GL_SMOOTH_CUBIC_CURVE_TO_NV = $10;

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV= $11;

GL_SMALL_CCW_ARC_TO_NV = $12;

GL_RELATIVE_SMALL_CCW_ARC_TO_NV = $13;

GL_SMALL_CW_ARC_TO_NV = $14;

GL_RELATIVE_SMALL_CW_ARC_TO_NV = $15;

GL_LARGE_CCW_ARC_TO_NV = $16;

GL_RELATIVE_LARGE_CCW_ARC_TO_NV = $17;

GL_LARGE_CW_ARC_TO_NV = $18;

GL_RELATIVE_LARGE_CW_ARC_TO_NV = $19;

GL_RESTART_PATH_NV = $F0;

GL_DUP_FIRST_CUBIC_CURVE_TO_NV = $F2;

GL_DUP_LAST_CUBIC_CURVE_TO_NV = $F4;

GL_RECT_NV = $F6;

GL_CIRCULAR_CCW_ARC_TO_NV = $F8;

GL_CIRCULAR_CW_ARC_TO_NV = $FA;

GL_CIRCULAR_TANGENT_ARC_TO_NV = $FC;

GL_ARC_TO_NV = $FE;

GL_RELATIVE_ARC_TO_NV = $FF;

GL_BOLD_BIT_NV = $01;

GL_ITALIC_BIT_NV = $02;

GL_GLYPH_WIDTH_BIT_NV = $01;

GL_GLYPH_HEIGHT_BIT_NV = $02;

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV= $04;

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV= $08;

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV= $10;

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV= $20;

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV= $40;

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV= $80;

GL_GLYPH_HAS_KERNING_NV = $100;

GL_FONT_X_MIN_BOUNDS_NV = $00010000;

GL_FONT_Y_MIN_BOUNDS_NV = $00020000;

GL_FONT_X_MAX_BOUNDS_NV = $00040000;

GL_FONT_Y_MAX_BOUNDS_NV = $00080000;

GL_FONT_UNITS_PER_EM_NV = $00100000;

GL_FONT_ASCENDER_NV = $00200000;

GL_FONT_DESCENDER_NV = $00400000;

GL_FONT_HEIGHT_NV = $00800000;

GL_FONT_MAX_ADVANCE_WIDTH_NV = $01000000;

GL_FONT_MAX_ADVANCE_HEIGHT_NV = $02000000;

GL_FONT_UNDERLINE_POSITION_NV = $04000000;

GL_FONT_UNDERLINE_THICKNESS_NV = $08000000;

GL_FONT_HAS_KERNING_NV = $10000000;

GL_EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD= $9160;

GL_SET_AMD = $874A;

GL_REPLACE_VALUE_AMD = $874B;

GL_STENCIL_OP_VALUE_AMD = $874C;

GL_STENCIL_BACK_OP_VALUE_AMD = $874D;

GL_QUERY_BUFFER_AMD = $9192;

GL_QUERY_BUFFER_BINDING_AMD = $9193;

GL_QUERY_RESULT_NO_WAIT_AMD = $9194;

GL_TEXTURE_DEFORMATION_BIT_SGIX = $00000001;

GL_GEOMETRY_DEFORMATION_BIT_SGIX = $00000002;

GL_IGNORE_BORDER_HP = $8150;

GL_CONSTANT_BORDER_HP = $8151;

GL_REPLICATE_BORDER_HP = $8153;

GL_CONVOLUTION_BORDER_COLOR_HP = $8154;

GL_IMAGE_SCALE_X_HP = $8155;

GL_IMAGE_SCALE_Y_HP = $8156;

GL_IMAGE_TRANSLATE_X_HP = $8157;

GL_IMAGE_TRANSLATE_Y_HP = $8158;

GL_IMAGE_ROTATE_ANGLE_HP = $8159;

GL_IMAGE_ROTATE_ORIGIN_X_HP = $815A;

GL_IMAGE_ROTATE_ORIGIN_Y_HP = $815B;

GL_IMAGE_MAG_FILTER_HP = $815C;

GL_IMAGE_MIN_FILTER_HP = $815D;

GL_IMAGE_CUBIC_WEIGHT_HP = $815E;

GL_CUBIC_HP = $815F;

GL_AVERAGE_HP = $8160;

GL_IMAGE_TRANSFORM_2D_HP = $8161;

GL_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP = $8162;

GL_PROXY_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP = $8163;

GL_OCCLUSION_TEST_HP = $8165;

GL_OCCLUSION_TEST_RESULT_HP = $8166;

GL_TEXTURE_LIGHTING_MODE_HP = $8167;

GL_TEXTURE_POST_SPECULAR_HP = $8168;

GL_TEXTURE_PRE_SPECULAR_HP = $8169;

GL_CULL_VERTEX_IBM = 103050;

GL_RASTER_POSITION_UNCLIPPED_IBM = $19262;

GL_MIRRORED_REPEAT_IBM = $8370;

GL_VERTEX_ARRAY_LIST_IBM = 103070;

GL_NORMAL_ARRAY_LIST_IBM = 103071;

GL_COLOR_ARRAY_LIST_IBM = 103072;

GL_INDEX_ARRAY_LIST_IBM = 103073;

GL_TEXTURE_COORD_ARRAY_LIST_IBM = 103074;

GL_EDGE_FLAG_ARRAY_LIST_IBM = 103075;

GL_FOG_COORDINATE_ARRAY_LIST_IBM = 103076;

GL_SECONDARY_COLOR_ARRAY_LIST_IBM = 103077;

GL_VERTEX_ARRAY_LIST_STRIDE_IBM = 103080;

GL_NORMAL_ARRAY_LIST_STRIDE_IBM = 103081;

GL_COLOR_ARRAY_LIST_STRIDE_IBM = 103082;

GL_INDEX_ARRAY_LIST_STRIDE_IBM = 103083;

GL_TEXTURE_COORD_ARRAY_LIST_STRIDE_IBM = 103084;

GL_EDGE_FLAG_ARRAY_LIST_STRIDE_IBM = 103085;

GL_FOG_COORDINATE_ARRAY_LIST_STRIDE_IBM = 103086;

GL_SECONDARY_COLOR_ARRAY_LIST_STRIDE_IBM = 103087;

GL_RED_MIN_CLAMP_INGR = $8560;

GL_GREEN_MIN_CLAMP_INGR = $8561;

GL_BLUE_MIN_CLAMP_INGR = $8562;

GL_ALPHA_MIN_CLAMP_INGR = $8563;

GL_RED_MAX_CLAMP_INGR = $8564;

GL_GREEN_MAX_CLAMP_INGR = $8565;

GL_BLUE_MAX_CLAMP_INGR = $8566;

GL_ALPHA_MAX_CLAMP_INGR = $8567;

GL_INTERLACE_READ_INGR = $8568;

GL_PARALLEL_ARRAYS_INTEL = $83F4;

GL_VERTEX_ARRAY_PARALLEL_POINTERS_INTEL = $83F5;

GL_NORMAL_ARRAY_PARALLEL_POINTERS_INTEL = $83F6;

GL_COLOR_ARRAY_PARALLEL_POINTERS_INTEL = $83F7;

GL_TEXTURE_COORD_ARRAY_PARALLEL_POINTERS_INTEL = $83F8;

GL_DEPTH_STENCIL_TO_RGBA_NV = $886E;

GL_DEPTH_STENCIL_TO_BGRA_NV = $886F;

GL_DEPTH_CLAMP_NV = $864F;

GL_EVAL_2D_NV = $86C0;

GL_EVAL_TRIANGULAR_2D_NV = $86C1;

GL_MAP_TESSELLATION_NV = $86C2;

GL_MAP_ATTRIB_U_ORDER_NV = $86C3;

GL_MAP_ATTRIB_V_ORDER_NV = $86C4;

GL_EVAL_FRACTIONAL_TESSELLATION_NV = $86C5;

GL_EVAL_VERTEX_ATTRIB0_NV = $86C6;

GL_EVAL_VERTEX_ATTRIB1_NV = $86C7;

GL_EVAL_VERTEX_ATTRIB2_NV = $86C8;

GL_EVAL_VERTEX_ATTRIB3_NV = $86C9;

GL_EVAL_VERTEX_ATTRIB4_NV = $86CA;

GL_EVAL_VERTEX_ATTRIB5_NV = $86CB;

GL_EVAL_VERTEX_ATTRIB6_NV = $86CC;

GL_EVAL_VERTEX_ATTRIB7_NV = $86CD;

GL_EVAL_VERTEX_ATTRIB8_NV = $86CE;

GL_EVAL_VERTEX_ATTRIB9_NV = $86CF;

GL_EVAL_VERTEX_ATTRIB10_NV = $86D0;

GL_EVAL_VERTEX_ATTRIB11_NV = $86D1;

GL_EVAL_VERTEX_ATTRIB12_NV = $86D2;

GL_EVAL_VERTEX_ATTRIB13_NV = $86D3;

GL_EVAL_VERTEX_ATTRIB14_NV = $86D4;

GL_EVAL_VERTEX_ATTRIB15_NV = $86D5;

GL_MAX_MAP_TESSELLATION_NV = $86D6;

GL_MAX_RATIONAL_EVAL_ORDER_NV = $86D7;

GL_ALL_COMPLETED_NV = $84F2;

GL_FENCE_STATUS_NV = $84F3;

GL_FENCE_CONDITION_NV = $84F4;

GL_FLOAT_R_NV = $8880;

GL_FLOAT_RG_NV = $8881;

GL_FLOAT_RGB_NV = $8882;

GL_FLOAT_RGBA_NV = $8883;

GL_FLOAT_R16_NV = $8884;

GL_FLOAT_R32_NV = $8885;

GL_FLOAT_RG16_NV = $8886;

GL_FLOAT_RG32_NV = $8887;

GL_FLOAT_RGB16_NV = $8888;

GL_FLOAT_RGB32_NV = $8889;

GL_FLOAT_RGBA16_NV = $888A;

GL_FLOAT_RGBA32_NV = $888B;

GL_TEXTURE_FLOAT_COMPONENTS_NV = $888C;

GL_FLOAT_CLEAR_COLOR_VALUE_NV = $888D;

GL_FLOAT_RGBA_MODE_NV = $888E;

GL_FOG_DISTANCE_MODE_NV = $855A;

GL_EYE_RADIAL_NV = $855B;

GL_EYE_PLANE_ABSOLUTE_NV = $855C;

GL_MAX_FRAGMENT_PROGRAM_LOCAL_PARAMETERS_NV = $8868;

GL_FRAGMENT_PROGRAM_NV = $8870;

GL_MAX_TEXTURE_COORDS_NV = $8871;

GL_MAX_TEXTURE_IMAGE_UNITS_NV = $8872;

GL_FRAGMENT_PROGRAM_BINDING_NV = $8873;

GL_PROGRAM_ERROR_STRING_NV = $8874;

GL_HALF_FLOAT_NV = $140B;

GL_MAX_SHININESS_NV = $8504;

GL_MAX_SPOT_EXPONENT_NV = $8505;

GL_MULTISAMPLE_FILTER_HINT_NV = $8534;

GL_PIXEL_COUNTER_BITS_NV = $8864;

GL_CURRENT_OCCLUSION_QUERY_ID_NV = $8865;

GL_PIXEL_COUNT_NV = $8866;

GL_PIXEL_COUNT_AVAILABLE_NV = $8867;

GL_DEPTH_STENCIL_NV = $84F9;

GL_UNSIGNED_INT_24_8_NV = $84FA;

GL_WRITE_PIXEL_DATA_RANGE_NV = $8878;

GL_READ_PIXEL_DATA_RANGE_NV = $8879;

GL_WRITE_PIXEL_DATA_RANGE_LENGTH_NV = $887A;

GL_READ_PIXEL_DATA_RANGE_LENGTH_NV = $887B;

GL_WRITE_PIXEL_DATA_RANGE_POINTER_NV = $887C;

GL_READ_PIXEL_DATA_RANGE_POINTER_NV = $887D;

GL_POINT_SPRITE_NV = $8861;

GL_COORD_REPLACE_NV = $8862;

GL_POINT_SPRITE_R_MODE_NV = $8863;

GL_PRIMITIVE_RESTART_NV = $8558;

GL_PRIMITIVE_RESTART_INDEX_NV = $8559;

GL_REGISTER_COMBINERS_NV = $8522;

GL_VARIABLE_A_NV = $8523;

GL_VARIABLE_B_NV = $8524;

GL_VARIABLE_C_NV = $8525;

GL_VARIABLE_D_NV = $8526;

GL_VARIABLE_E_NV = $8527;

GL_VARIABLE_F_NV = $8528;

GL_VARIABLE_G_NV = $8529;

GL_CONSTANT_COLOR0_NV = $852A;

GL_CONSTANT_COLOR1_NV = $852B;

GL_PRIMARY_COLOR_NV = $852C;

GL_SECONDARY_COLOR_NV = $852D;

GL_SPARE0_NV = $852E;

GL_SPARE1_NV = $852F;

GL_DISCARD_NV = $8530;

GL_E_TIMES_F_NV = $8531;

GL_SPARE0_PLUS_SECONDARY_COLOR_NV = $8532;

GL_UNSIGNED_IDENTITY_NV = $8536;

GL_UNSIGNED_INVERT_NV = $8537;

GL_EXPAND_NORMAL_NV = $8538;

GL_EXPAND_NEGATE_NV = $8539;

GL_HALF_BIAS_NORMAL_NV = $853A;

GL_HALF_BIAS_NEGATE_NV = $853B;

GL_SIGNED_IDENTITY_NV = $853C;

GL_SIGNED_NEGATE_NV = $853D;

GL_SCALE_BY_TWO_NV = $853E;

GL_SCALE_BY_FOUR_NV = $853F;

GL_SCALE_BY_ONE_HALF_NV = $8540;

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV = $8541;

GL_COMBINER_INPUT_NV = $8542;

GL_COMBINER_MAPPING_NV = $8543;

GL_COMBINER_COMPONENT_USAGE_NV = $8544;

GL_COMBINER_AB_DOT_PRODUCT_NV = $8545;

GL_COMBINER_CD_DOT_PRODUCT_NV = $8546;

GL_COMBINER_MUX_SUM_NV = $8547;

GL_COMBINER_SCALE_NV = $8548;

GL_COMBINER_BIAS_NV = $8549;

GL_COMBINER_AB_OUTPUT_NV = $854A;

GL_COMBINER_CD_OUTPUT_NV = $854B;

GL_COMBINER_SUM_OUTPUT_NV = $854C;

GL_MAX_GENERAL_COMBINERS_NV = $854D;

GL_NUM_GENERAL_COMBINERS_NV = $854E;

GL_COLOR_SUM_CLAMP_NV = $854F;

GL_COMBINER0_NV = $8550;

GL_COMBINER1_NV = $8551;

GL_COMBINER2_NV = $8552;

GL_COMBINER3_NV = $8553;

GL_COMBINER4_NV = $8554;

GL_COMBINER5_NV = $8555;

GL_COMBINER6_NV = $8556;

GL_COMBINER7_NV = $8557;

GL_PER_STAGE_CONSTANTS_NV = $8535;

GL_EMBOSS_LIGHT_NV = $855D;

GL_EMBOSS_CONSTANT_NV = $855E;

GL_EMBOSS_MAP_NV = $855F;

GL_NORMAL_MAP_NV = $8511;

GL_REFLECTION_MAP_NV = $8512;

GL_COMBINE4_NV = $8503;

GL_SOURCE3_RGB_NV = $8583;

GL_SOURCE3_ALPHA_NV = $858B;

GL_OPERAND3_RGB_NV = $8593;

GL_OPERAND3_ALPHA_NV = $859B;

GL_TEXTURE_UNSIGNED_REMAP_MODE_NV = $888F;

GL_TEXTURE_RECTANGLE_NV = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_NV = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_NV = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV = $84F8;

GL_OFFSET_TEXTURE_RECTANGLE_NV = $864C;

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV = $864D;

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV = $864E;

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV = $86D9;

GL_UNSIGNED_INT_S8_S8_8_8_NV = $86DA;

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV = $86DB;

GL_DSDT_MAG_INTENSITY_NV = $86DC;

GL_SHADER_CONSISTENT_NV = $86DD;

GL_TEXTURE_SHADER_NV = $86DE;

GL_SHADER_OPERATION_NV = $86DF;

GL_CULL_MODES_NV = $86E0;

GL_OFFSET_TEXTURE_MATRIX_NV = $86E1;

GL_OFFSET_TEXTURE_SCALE_NV = $86E2;

GL_OFFSET_TEXTURE_BIAS_NV = $86E3;

GL_OFFSET_TEXTURE_2D_MATRIX_NV = GL_OFFSET_TEXTURE_MATRIX_NV;

GL_OFFSET_TEXTURE_2D_SCALE_NV = GL_OFFSET_TEXTURE_SCALE_NV;

GL_OFFSET_TEXTURE_2D_BIAS_NV = GL_OFFSET_TEXTURE_BIAS_NV;

GL_PREVIOUS_TEXTURE_INPUT_NV = $86E4;

GL_CONST_EYE_NV = $86E5;

GL_PASS_THROUGH_NV = $86E6;

GL_CULL_FRAGMENT_NV = $86E7;

GL_OFFSET_TEXTURE_2D_NV = $86E8;

GL_DEPENDENT_AR_TEXTURE_2D_NV = $86E9;

GL_DEPENDENT_GB_TEXTURE_2D_NV = $86EA;

GL_DOT_PRODUCT_NV = $86EC;

GL_DOT_PRODUCT_DEPTH_REPLACE_NV = $86ED;

GL_DOT_PRODUCT_TEXTURE_2D_NV = $86EE;

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV = $86F0;

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV = $86F1;

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV = $86F2;

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV = $86F3;

GL_HILO_NV = $86F4;

GL_DSDT_NV = $86F5;

GL_DSDT_MAG_NV = $86F6;

GL_DSDT_MAG_VIB_NV = $86F7;

GL_HILO16_NV = $86F8;

GL_SIGNED_HILO_NV = $86F9;

GL_SIGNED_HILO16_NV = $86FA;

GL_SIGNED_RGBA_NV = $86FB;

GL_SIGNED_RGBA8_NV = $86FC;

GL_SIGNED_RGB_NV = $86FE;

GL_SIGNED_RGB8_NV = $86FF;

GL_SIGNED_LUMINANCE_NV = $8701;

GL_SIGNED_LUMINANCE8_NV = $8702;

GL_SIGNED_LUMINANCE_ALPHA_NV = $8703;

GL_SIGNED_LUMINANCE8_ALPHA8_NV = $8704;

GL_SIGNED_ALPHA_NV = $8705;

GL_SIGNED_ALPHA8_NV = $8706;

GL_SIGNED_INTENSITY_NV = $8707;

GL_SIGNED_INTENSITY8_NV = $8708;

GL_DSDT8_NV = $8709;

GL_DSDT8_MAG8_NV = $870A;

GL_DSDT8_MAG8_INTENSITY8_NV = $870B;

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV = $870C;

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV = $870D;

GL_HI_SCALE_NV = $870E;

GL_LO_SCALE_NV = $870F;

GL_DS_SCALE_NV = $8710;

GL_DT_SCALE_NV = $8711;

GL_MAGNITUDE_SCALE_NV = $8712;

GL_VIBRANCE_SCALE_NV = $8713;

GL_HI_BIAS_NV = $8714;

GL_LO_BIAS_NV = $8715;

GL_DS_BIAS_NV = $8716;

GL_DT_BIAS_NV = $8717;

GL_MAGNITUDE_BIAS_NV = $8718;

GL_VIBRANCE_BIAS_NV = $8719;

GL_TEXTURE_BORDER_VALUES_NV = $871A;

GL_TEXTURE_HI_SIZE_NV = $871B;

GL_TEXTURE_LO_SIZE_NV = $871C;

GL_TEXTURE_DS_SIZE_NV = $871D;

GL_TEXTURE_DT_SIZE_NV = $871E;

GL_TEXTURE_MAG_SIZE_NV = $871F;

GL_DOT_PRODUCT_TEXTURE_3D_NV = $86EF;

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV = $8850;

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV = $8851;

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8852;

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV = $8853;

GL_OFFSET_HILO_TEXTURE_2D_NV = $8854;

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV = $8855;

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV = $8856;

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8857;

GL_DEPENDENT_HILO_TEXTURE_2D_NV = $8858;

GL_DEPENDENT_RGB_TEXTURE_3D_NV = $8859;

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV = $885A;

GL_DOT_PRODUCT_PASS_THROUGH_NV = $885B;

GL_DOT_PRODUCT_TEXTURE_1D_NV = $885C;

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV = $885D;

GL_HILO8_NV = $885E;

GL_SIGNED_HILO8_NV = $885F;

GL_FORCE_BLUE_TO_ONE_NV = $8860;

GL_VERTEX_ARRAY_RANGE_NV = $851D;

GL_VERTEX_ARRAY_RANGE_LENGTH_NV = $851E;

GL_VERTEX_ARRAY_RANGE_VALID_NV = $851F;

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV = $8520;

GL_VERTEX_ARRAY_RANGE_POINTER_NV = $8521;

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV = $8533;

GL_VERTEX_PROGRAM_NV = $8620;

GL_VERTEX_STATE_PROGRAM_NV = $8621;

GL_ATTRIB_ARRAY_SIZE_NV = $8623;

GL_ATTRIB_ARRAY_STRIDE_NV = $8624;

GL_ATTRIB_ARRAY_TYPE_NV = $8625;

GL_CURRENT_ATTRIB_NV = $8626;

GL_PROGRAM_LENGTH_NV = $8627;

GL_PROGRAM_STRING_NV = $8628;

GL_MODELVIEW_PROJECTION_NV = $8629;

GL_IDENTITY_NV = $862A;

GL_INVERSE_NV = $862B;

GL_TRANSPOSE_NV = $862C;

GL_INVERSE_TRANSPOSE_NV = $862D;

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV = $862E;

GL_MAX_TRACK_MATRICES_NV = $862F;

GL_MATRIX0_NV = $8630;

GL_MATRIX1_NV = $8631;

GL_MATRIX2_NV = $8632;

GL_MATRIX3_NV = $8633;

GL_MATRIX4_NV = $8634;

GL_MATRIX5_NV = $8635;

GL_MATRIX6_NV = $8636;

GL_MATRIX7_NV = $8637;

GL_CURRENT_MATRIX_STACK_DEPTH_NV = $8640;

GL_CURRENT_MATRIX_NV = $8641;

GL_VERTEX_PROGRAM_POINT_SIZE_NV = $8642;

GL_VERTEX_PROGRAM_TWO_SIDE_NV = $8643;

GL_PROGRAM_PARAMETER_NV = $8644;

GL_ATTRIB_ARRAY_POINTER_NV = $8645;

GL_PROGRAM_TARGET_NV = $8646;

GL_PROGRAM_RESIDENT_NV = $8647;

GL_TRACK_MATRIX_NV = $8648;

GL_TRACK_MATRIX_TRANSFORM_NV = $8649;

GL_VERTEX_PROGRAM_BINDING_NV = $864A;

GL_PROGRAM_ERROR_POSITION_NV = $864B;

GL_VERTEX_ATTRIB_ARRAY0_NV = $8650;

GL_VERTEX_ATTRIB_ARRAY1_NV = $8651;

GL_VERTEX_ATTRIB_ARRAY2_NV = $8652;

GL_VERTEX_ATTRIB_ARRAY3_NV = $8653;

GL_VERTEX_ATTRIB_ARRAY4_NV = $8654;

GL_VERTEX_ATTRIB_ARRAY5_NV = $8655;

GL_VERTEX_ATTRIB_ARRAY6_NV = $8656;

GL_VERTEX_ATTRIB_ARRAY7_NV = $8657;

GL_VERTEX_ATTRIB_ARRAY8_NV = $8658;

GL_VERTEX_ATTRIB_ARRAY9_NV = $8659;

GL_VERTEX_ATTRIB_ARRAY10_NV = $865A;

GL_VERTEX_ATTRIB_ARRAY11_NV = $865B;

GL_VERTEX_ATTRIB_ARRAY12_NV = $865C;

GL_VERTEX_ATTRIB_ARRAY13_NV = $865D;

GL_VERTEX_ATTRIB_ARRAY14_NV = $865E;

GL_VERTEX_ATTRIB_ARRAY15_NV = $865F;

GL_MAP1_VERTEX_ATTRIB0_4_NV = $8660;

GL_MAP1_VERTEX_ATTRIB1_4_NV = $8661;

GL_MAP1_VERTEX_ATTRIB2_4_NV = $8662;

GL_MAP1_VERTEX_ATTRIB3_4_NV = $8663;

GL_MAP1_VERTEX_ATTRIB4_4_NV = $8664;

GL_MAP1_VERTEX_ATTRIB5_4_NV = $8665;

GL_MAP1_VERTEX_ATTRIB6_4_NV = $8666;

GL_MAP1_VERTEX_ATTRIB7_4_NV = $8667;

GL_MAP1_VERTEX_ATTRIB8_4_NV = $8668;

GL_MAP1_VERTEX_ATTRIB9_4_NV = $8669;

GL_MAP1_VERTEX_ATTRIB10_4_NV = $866A;

GL_MAP1_VERTEX_ATTRIB11_4_NV = $866B;

GL_MAP1_VERTEX_ATTRIB12_4_NV = $866C;

GL_MAP1_VERTEX_ATTRIB13_4_NV = $866D;

GL_MAP1_VERTEX_ATTRIB14_4_NV = $866E;

GL_MAP1_VERTEX_ATTRIB15_4_NV = $866F;

GL_MAP2_VERTEX_ATTRIB0_4_NV = $8670;

GL_MAP2_VERTEX_ATTRIB1_4_NV = $8671;

GL_MAP2_VERTEX_ATTRIB2_4_NV = $8672;

GL_MAP2_VERTEX_ATTRIB3_4_NV = $8673;

GL_MAP2_VERTEX_ATTRIB4_4_NV = $8674;

GL_MAP2_VERTEX_ATTRIB5_4_NV = $8675;

GL_MAP2_VERTEX_ATTRIB6_4_NV = $8676;

GL_MAP2_VERTEX_ATTRIB7_4_NV = $8677;

GL_MAP2_VERTEX_ATTRIB8_4_NV = $8678;

GL_MAP2_VERTEX_ATTRIB9_4_NV = $8679;

GL_MAP2_VERTEX_ATTRIB10_4_NV = $867A;

GL_MAP2_VERTEX_ATTRIB11_4_NV = $867B;

GL_MAP2_VERTEX_ATTRIB12_4_NV = $867C;

GL_MAP2_VERTEX_ATTRIB13_4_NV = $867D;

GL_MAP2_VERTEX_ATTRIB14_4_NV = $867E;

GL_MAP2_VERTEX_ATTRIB15_4_NV = $867F;

GL_MAX_PROGRAM_EXEC_INSTRUCTIONS_NV = $88F4;

GL_MAX_PROGRAM_CALL_DEPTH_NV = $88F5;

GL_MAX_PROGRAM_IF_DEPTH_NV = $88F6;

GL_MAX_PROGRAM_LOOP_DEPTH_NV = $88F7;

GL_MAX_PROGRAM_LOOP_COUNT_NV = $88F8;

MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

GL_FLOAT_32_UNSIGNED_INT_24_8_REV_NV = $8DAD;

GL_DEPTH_BUFFER_FLOAT_MODE_NV = $8DAF;

GL_RENDERBUFFER_COVERAGE_SAMPLES_NV = $8CAB;

GL_RENDERBUFFER_COLOR_SAMPLES_NV = $8E10;

GL_GEOMETRY_PROGRAM_NV = $8C26;

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV = $8C27;

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV = $8C28;

GL_PROGRAM_ATTRIB_COMPONENTS_NV = $8906;

GL_PROGRAM_RESULT_COMPONENTS_NV = $8907;

GL_MAX_PROGRAM_ATTRIB_COMPONENTS_NV = $8908;

GL_MAX_PROGRAM_RESULT_COMPONENTS_NV = $8909;

GL_MAX_PROGRAM_GENERIC_ATTRIBS_NV = $8DA5;

GL_MAX_PROGRAM_GENERIC_RESULTS_NV = $8DA6;

GL_MAX_PROGRAM_PARAMETER_BUFFER_BINDINGS_NV = $8DA0;

GL_MAX_PROGRAM_PARAMETER_BUFFER_SIZE_NV = $8DA1;

GL_VERTEX_PROGRAM_PARAMETER_BUFFER_NV = $8DA2;

GL_GEOMETRY_PROGRAM_PARAMETER_BUFFER_NV = $8DA3;

GL_FRAGMENT_PROGRAM_PARAMETER_BUFFER_NV = $8DA4;

GL_TRANSFORM_FEEDBACK_BUFFER_NV = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV = $8C85;

GL_TRANSFORM_FEEDBACK_RECORD_NV = $8C86;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV = $8C8F;

GL_INTERLEAVED_ATTRIBS_NV = $8C8C;

GL_SEPARATE_ATTRIBS_NV = $8C8D;

GL_PRIMITIVES_GENERATED_NV = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV = $8C88;

GL_RASTERIZER_DISCARD_NV = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV = $8C8B;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV = $8C80;

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV = $8C7E;

GL_ACTIVE_VARYINGS_NV = $8C81;

GL_ACTIVE_VARYING_MAX_LENGTH_NV = $8C82;

GL_TRANSFORM_FEEDBACK_VARYINGS_NV = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV = $8C7F;

GL_BACK_PRIMARY_COLOR_NV = $8C77;

GL_BACK_SECONDARY_COLOR_NV = $8C78;

GL_TEXTURE_COORD_NV = $8C79;

GL_CLIP_DISTANCE_NV = $8C7A;

GL_VERTEX_ID_NV = $8C7B;

GL_PRIMITIVE_ID_NV = $8C7C;

GL_GENERIC_ATTRIB_NV = $8C7D;

GL_LAYER_NV = $8DAA;

GL_NEXT_BUFFER_NV = -2;

GL_SKIP_COMPONENTS4_NV = -3;

GL_SKIP_COMPONENTS3_NV = -4;

GL_SKIP_COMPONENTS2_NV = -5;

GL_SKIP_COMPONENTS1_NV = -6;

GL_QUERY_WAIT_NV = $8E13;

GL_QUERY_NO_WAIT_NV = $8E14;

GL_QUERY_BY_REGION_WAIT_NV = $8E15;

GL_QUERY_BY_REGION_NO_WAIT_NV = $8E16;

GL_CONSERVATIVE_RASTERIZATION_NV = $9346;

GL_SUBPIXEL_PRECISION_BIAS_X_BITS_NV = $9347;

GL_SUBPIXEL_PRECISION_BIAS_Y_BITS_NV = $9348;

GL_MAX_SUBPIXEL_PRECISION_BIAS_BITS_NV = $9349;

GL_CONSERVATIVE_RASTER_DILATE_NV = $9379;

GL_CONSERVATIVE_RASTER_DILATE_RANGE_NV = $937A;

GL_CONSERVATIVE_RASTER_DILATE_GRANULARITY_NV = $937B;

GL_FRAME_NV = $8E26;

GL_FIELDS_NV = $8E27;

GL_CURRENT_TIME_NV = $8E28;

GL_NUM_FILL_STREAMS_NV = $8E29;

GL_PRESENT_TIME_NV = $8E2A;

GL_PRESENT_DURATION_NV = $8E2B;

GL_SAMPLE_POSITION_NV = $8E50;

GL_SAMPLE_MASK_NV = $8E51;

GL_SAMPLE_MASK_VALUE_NV = $8E52;

GL_TEXTURE_BINDING_RENDERBUFFER_NV = $8E53;

GL_TEXTURE_RENDERBUFFER_DATA_STORE_BINDING_NV = $8E54;

GL_TEXTURE_RENDERBUFFER_NV = $8E55;

GL_SAMPLER_RENDERBUFFER_NV = $8E56;

GL_INT_SAMPLER_RENDERBUFFER_NV = $8E57;

GL_UNSIGNED_INT_SAMPLER_RENDERBUFFER_NV = $8E58;

GL_MAX_SAMPLE_MASK_WORDS_NV = $8E59;

GL_TRANSFORM_FEEDBACK_NV = $8E22;

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED_NV = $8E23;

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE_NV = $8E24;

GL_TRANSFORM_FEEDBACK_BINDING_NV = $8E25;

GL_VIDEO_BUFFER_NV = $9020;

GL_VIDEO_BUFFER_BINDING_NV = $9021;

GL_FIELD_UPPER_NV = $9022;

GL_FIELD_LOWER_NV = $9023;

GL_NUM_VIDEO_CAPTURE_STREAMS_NV = $9024;

GL_NEXT_VIDEO_CAPTURE_BUFFER_STATUS_NV = $9025;

GL_VIDEO_CAPTURE_TO_422_SUPPORTED_NV = $9026;

GL_LAST_VIDEO_CAPTURE_STATUS_NV = $9027;

GL_VIDEO_BUFFER_PITCH_NV = $9028;

GL_VIDEO_COLOR_CONVERSION_MATRIX_NV = $9029;

GL_VIDEO_COLOR_CONVERSION_MAX_NV = $902A;

GL_VIDEO_COLOR_CONVERSION_MIN_NV = $902B;

GL_VIDEO_COLOR_CONVERSION_OFFSET_NV = $902C;

GL_VIDEO_BUFFER_INTERNAL_FORMAT_NV = $902D;

GL_PARTIAL_SUCCESS_NV = $902E;

GL_SUCCESS_NV = $902F;

GL_FAILURE_NV = $9030;

GL_YCBYCR8_422_NV = $9031;

GL_YCBAYCR8A_4224_NV = $9032;

GL_Z6Y10Z6CB10Z6Y10Z6CR10_422_NV = $9033;

GL_Z6Y10Z6CB10Z6A10Z6Y10Z6CR10Z6A10_4224_NV = $9034;

GL_Z4Y12Z4CB12Z4Y12Z4CR12_422_NV = $9035;

GL_Z4Y12Z4CB12Z4A12Z4Y12Z4CR12Z4A12_4224_NV = $9036;

GL_Z4Y12Z4CB12Z4CR12_444_NV = $9037;

GL_VIDEO_CAPTURE_FRAME_WIDTH_NV = $9038;

GL_VIDEO_CAPTURE_FRAME_HEIGHT_NV = $9039;

GL_VIDEO_CAPTURE_FIELD_UPPER_HEIGHT_NV = $903A;

GL_VIDEO_CAPTURE_FIELD_LOWER_HEIGHT_NV = $903B;

GL_VIDEO_CAPTURE_SURFACE_ORIGIN_NV = $903C;

GL_BUFFER_GPU_ADDRESS_NV = $8F1D;

GL_GPU_ADDRESS_NV = $8F34;

GL_MAX_SHADER_BUFFER_ADDRESS_NV = $8F35;

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV = $8F1E;

GL_ELEMENT_ARRAY_UNIFIED_NV = $8F1F;

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV = $8F20;

GL_VERTEX_ARRAY_ADDRESS_NV = $8F21;

GL_NORMAL_ARRAY_ADDRESS_NV = $8F22;

GL_COLOR_ARRAY_ADDRESS_NV = $8F23;

GL_INDEX_ARRAY_ADDRESS_NV = $8F24;

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV = $8F25;

GL_EDGE_FLAG_ARRAY_ADDRESS_NV = $8F26;

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV = $8F27;

GL_FOG_COORD_ARRAY_ADDRESS_NV = $8F28;

GL_ELEMENT_ARRAY_ADDRESS_NV = $8F29;

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV = $8F2A;

GL_VERTEX_ARRAY_LENGTH_NV = $8F2B;

GL_NORMAL_ARRAY_LENGTH_NV = $8F2C;

GL_COLOR_ARRAY_LENGTH_NV = $8F2D;

GL_INDEX_ARRAY_LENGTH_NV = $8F2E;

GL_TEXTURE_COORD_ARRAY_LENGTH_NV = $8F2F;

GL_EDGE_FLAG_ARRAY_LENGTH_NV = $8F30;

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV = $8F31;

GL_FOG_COORD_ARRAY_LENGTH_NV = $8F32;

GL_ELEMENT_ARRAY_LENGTH_NV = $8F33;

GL_DRAW_INDIRECT_UNIFIED_NV = $8F40;

GL_DRAW_INDIRECT_ADDRESS_NV = $8F41;

GL_DRAW_INDIRECT_LENGTH_NV = $8F42;

GL_MAX_GEOMETRY_PROGRAM_INVOCATIONS_NV = $8E5A;

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET_NV = $8E5B;

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET_NV = $8E5C;

GL_FRAGMENT_PROGRAM_INTERPOLATION_OFFSET_BITS_NV = $8E5D;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_NV = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_NV = $8E5F;

GL_MAX_PROGRAM_SUBROUTINE_PARAMETERS_NV = $8F44;

GL_MAX_PROGRAM_SUBROUTINE_NUM_NV = $8F45;

GL_INT64_NV = $140E;

GL_UNSIGNED_INT64_NV = $140F;

GL_INT8_NV = $8FE0;

GL_INT8_VEC2_NV = $8FE1;

GL_INT8_VEC3_NV = $8FE2;

GL_INT8_VEC4_NV = $8FE3;

GL_INT16_NV = $8FE4;

GL_INT16_VEC2_NV = $8FE5;

GL_INT16_VEC3_NV = $8FE6;

GL_INT16_VEC4_NV = $8FE7;

GL_INT64_VEC2_NV = $8FE9;

GL_INT64_VEC3_NV = $8FEA;

GL_INT64_VEC4_NV = $8FEB;

GL_UNSIGNED_INT8_NV = $8FEC;

GL_UNSIGNED_INT8_VEC2_NV = $8FED;

GL_UNSIGNED_INT8_VEC3_NV = $8FEE;

GL_UNSIGNED_INT8_VEC4_NV = $8FEF;

GL_UNSIGNED_INT16_NV = $8FF0;

GL_UNSIGNED_INT16_VEC2_NV = $8FF1;

GL_UNSIGNED_INT16_VEC3_NV = $8FF2;

GL_UNSIGNED_INT16_VEC4_NV = $8FF3;

GL_UNSIGNED_INT64_VEC2_NV = $8FF5;

GL_UNSIGNED_INT64_VEC3_NV = $8FF6;

GL_UNSIGNED_INT64_VEC4_NV = $8FF7;

GL_FLOAT16_NV = $8FF8;

GL_FLOAT16_VEC2_NV = $8FF9;

GL_FLOAT16_VEC3_NV = $8FFA;

GL_FLOAT16_VEC4_NV = $8FFB;

GL_SHADER_GLOBAL_ACCESS_BARRIER_BIT_NV = $00000010;

GL_MAX_PROGRAM_PATCH_ATTRIBS_NV = $86D8;

GL_TESS_CONTROL_PROGRAM_NV = $891E;

GL_TESS_EVALUATION_PROGRAM_NV = $891F;

GL_TESS_CONTROL_PROGRAM_PARAMETER_BUFFER_NV = $8C74;

GL_TESS_EVALUATION_PROGRAM_PARAMETER_BUFFER_NV = $8C75;

GL_COVERAGE_SAMPLES_NV = $80A9;

GL_COLOR_SAMPLES_NV = $8E20;

GL_SURFACE_STATE_NV = $86EB;

GL_SURFACE_REGISTERED_NV = $86FD;

GL_SURFACE_MAPPED_NV = $8700;

GL_WRITE_DISCARD_NV = $88BE;

GL_INTERLACE_OML = $8980;

GL_INTERLACE_READ_OML = $8981;

GL_PACK_RESAMPLE_OML = $8984;

GL_UNPACK_RESAMPLE_OML = $8985;

GL_RESAMPLE_REPLICATE_OML = $8986;

GL_RESAMPLE_ZERO_FILL_OML = $8987;

GL_RESAMPLE_AVERAGE_OML = $8988;

GL_RESAMPLE_DECIMATE_OML = $8989;

GL_FORMAT_SUBSAMPLE_24_24_OML = $8982;

GL_FORMAT_SUBSAMPLE_244_244_OML = $8983;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_NUM_VIEWS_OVR = $9630;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_BASE_VIEW_INDEX_OVR = $9632;

GL_MAX_VIEWS_OVR = $9631;

GL_FRAMEBUFFER_INCOMPLETE_VIEW_TARGETS_OVR = $9633;

GL_PREFER_DOUBLEBUFFER_HINT_PGI = $1A1F8;

GL_CONSERVE_MEMORY_HINT_PGI = $1A1FD;

GL_RECLAIM_MEMORY_HINT_PGI = $1A1FE;

GL_NATIVE_GRAPHICS_HANDLE_PGI = $1A202;

GL_NATIVE_GRAPHICS_BEGIN_HINT_PGI = $1A203;

GL_NATIVE_GRAPHICS_END_HINT_PGI = $1A204;

GL_ALWAYS_FAST_HINT_PGI = $1A20C;

GL_ALWAYS_SOFT_HINT_PGI = $1A20D;

GL_ALLOW_DRAW_OBJ_HINT_PGI = $1A20E;

GL_ALLOW_DRAW_WIN_HINT_PGI = $1A20F;

GL_ALLOW_DRAW_FRG_HINT_PGI = $1A210;

GL_ALLOW_DRAW_MEM_HINT_PGI = $1A211;

GL_STRICT_DEPTHFUNC_HINT_PGI = $1A216;

GL_STRICT_LIGHTING_HINT_PGI = $1A217;

GL_STRICT_SCISSOR_HINT_PGI = $1A218;

GL_FULL_STIPPLE_HINT_PGI = $1A219;

GL_CLIP_NEAR_HINT_PGI = $1A220;

GL_CLIP_FAR_HINT_PGI = $1A221;

GL_WIDE_LINE_HINT_PGI = $1A222;

GL_BACK_NORMALS_HINT_PGI = $1A223;

GL_VERTEX_DATA_HINT_PGI = $1A22A;

GL_VERTEX_CONSISTENT_HINT_PGI = $1A22B;

GL_MATERIAL_SIDE_HINT_PGI = $1A22C;

GL_MAX_VERTEX_HINT_PGI = $1A22D;

GL_COLOR3_BIT_PGI = $00010000;

GL_COLOR4_BIT_PGI = $00020000;

GL_EDGEFLAG_BIT_PGI = $00040000;

GL_INDEX_BIT_PGI = $00080000;

GL_MAT_AMBIENT_BIT_PGI = $00100000;

GL_MAT_AMBIENT_AND_DIFFUSE_BIT_PGI = $00200000;

GL_MAT_DIFFUSE_BIT_PGI = $00400000;

GL_MAT_EMISSION_BIT_PGI = $00800000;

GL_MAT_COLOR_INDEXES_BIT_PGI = $01000000;

GL_MAT_SHININESS_BIT_PGI = $02000000;

GL_MAT_SPECULAR_BIT_PGI = $04000000;

GL_NORMAL_BIT_PGI = $08000000;

GL_TEXCOORD1_BIT_PGI = $10000000;

GL_TEXCOORD2_BIT_PGI = $20000000;

GL_TEXCOORD3_BIT_PGI = $40000000;

GL_TEXCOORD4_BIT_PGI = $80000000;

GL_VERTEX23_BIT_PGI = $00000004;

GL_VERTEX4_BIT_PGI = $00000008;

GL_SCREEN_COORDINATES_REND = $8490;

GL_INVERTED_SCREEN_W_REND = $8491;

GL_RGB_S3TC = $83A0;

GL_RGB4_S3TC = $83A1;

GL_RGBA_S3TC = $83A2;

GL_RGBA4_S3TC = $83A3;

GL_DETAIL_TEXTURE_2D_SGIS = $8095;

GL_DETAIL_TEXTURE_2D_BINDING_SGIS = $8096;

GL_LINEAR_DETAIL_SGIS = $8097;

GL_LINEAR_DETAIL_ALPHA_SGIS = $8098;

GL_LINEAR_DETAIL_COLOR_SGIS = $8099;

GL_DETAIL_TEXTURE_LEVEL_SGIS = $809A;

GL_DETAIL_TEXTURE_MODE_SGIS = $809B;

GL_DETAIL_TEXTURE_FUNC_POINTS_SGIS = $809C;

GL_FOG_FUNC_SGIS = $812A;

GL_FOG_FUNC_POINTS_SGIS = $812B;

GL_MAX_FOG_FUNC_POINTS_SGIS = $812C;

GL_GENERATE_MIPMAP_SGIS = $8191;

GL_GENERATE_MIPMAP_HINT_SGIS = $8192;

GL_MULTISAMPLE_SGIS = $809D;

GL_SAMPLE_ALPHA_TO_MASK_SGIS = $809E;

GL_SAMPLE_ALPHA_TO_ONE_SGIS = $809F;

GL_SAMPLE_MASK_SGIS = $80A0;

GL_1PASS_SGIS = $80A1;

GL_2PASS_0_SGIS = $80A2;

GL_2PASS_1_SGIS = $80A3;

GL_4PASS_0_SGIS = $80A4;

GL_4PASS_1_SGIS = $80A5;

GL_4PASS_2_SGIS = $80A6;

GL_4PASS_3_SGIS = $80A7;

GL_SAMPLE_BUFFERS_SGIS = $80A8;

GL_SAMPLES_SGIS = $80A9;

GL_SAMPLE_MASK_VALUE_SGIS = $80AA;

GL_SAMPLE_MASK_INVERT_SGIS = $80AB;

GL_SAMPLE_PATTERN_SGIS = $80AC;

GL_PIXEL_TEXTURE_SGIS = $8353;

GL_PIXEL_FRAGMENT_RGB_SOURCE_SGIS = $8354;

GL_PIXEL_FRAGMENT_ALPHA_SOURCE_SGIS = $8355;

GL_PIXEL_GROUP_COLOR_SGIS = $8356;

GL_EYE_DISTANCE_TO_POINT_SGIS = $81F0;

GL_OBJECT_DISTANCE_TO_POINT_SGIS = $81F1;

GL_EYE_DISTANCE_TO_LINE_SGIS = $81F2;

GL_OBJECT_DISTANCE_TO_LINE_SGIS = $81F3;

GL_EYE_POINT_SGIS = $81F4;

GL_OBJECT_POINT_SGIS = $81F5;

GL_EYE_LINE_SGIS = $81F6;

GL_OBJECT_LINE_SGIS = $81F7;

GL_POINT_SIZE_MIN_SGIS = $8126;

GL_POINT_SIZE_MAX_SGIS = $8127;

GL_POINT_FADE_THRESHOLD_SIZE_SGIS = $8128;

GL_DISTANCE_ATTENUATION_SGIS = $8129;

GL_LINEAR_SHARPEN_SGIS = $80AD;

GL_LINEAR_SHARPEN_ALPHA_SGIS = $80AE;

GL_LINEAR_SHARPEN_COLOR_SGIS = $80AF;

GL_SHARPEN_TEXTURE_FUNC_POINTS_SGIS = $80B0;

GL_PACK_SKIP_VOLUMES_SGIS = $8130;

GL_PACK_IMAGE_DEPTH_SGIS = $8131;

GL_UNPACK_SKIP_VOLUMES_SGIS = $8132;

GL_UNPACK_IMAGE_DEPTH_SGIS = $8133;

GL_TEXTURE_4D_SGIS = $8134;

GL_PROXY_TEXTURE_4D_SGIS = $8135;

GL_TEXTURE_4DSIZE_SGIS = $8136;

GL_TEXTURE_WRAP_Q_SGIS = $8137;

GL_MAX_4D_TEXTURE_SIZE_SGIS = $8138;

GL_TEXTURE_4D_BINDING_SGIS = $814F;

GL_TEXTURE_COLOR_WRITEMASK_SGIS = $81EF;

GL_CLAMP_TO_EDGE_SGIS = $812F;

GL_FILTER4_SGIS = $8146;

GL_TEXTURE_FILTER4_SIZE_SGIS = $8147;

GL_TEXTURE_MIN_LOD_SGIS = $813A;

GL_TEXTURE_MAX_LOD_SGIS = $813B;

GL_TEXTURE_BASE_LEVEL_SGIS = $813C;

GL_TEXTURE_MAX_LEVEL_SGIS = $813D;

GL_DUAL_ALPHA4_SGIS = $8110;

GL_DUAL_ALPHA8_SGIS = $8111;

GL_DUAL_ALPHA12_SGIS = $8112;

GL_DUAL_ALPHA16_SGIS = $8113;

GL_DUAL_LUMINANCE4_SGIS = $8114;

GL_DUAL_LUMINANCE8_SGIS = $8115;

GL_DUAL_LUMINANCE12_SGIS = $8116;

GL_DUAL_LUMINANCE16_SGIS = $8117;

GL_DUAL_INTENSITY4_SGIS = $8118;

GL_DUAL_INTENSITY8_SGIS = $8119;

GL_DUAL_INTENSITY12_SGIS = $811A;

GL_DUAL_INTENSITY16_SGIS = $811B;

GL_DUAL_LUMINANCE_ALPHA4_SGIS = $811C;

GL_DUAL_LUMINANCE_ALPHA8_SGIS = $811D;

GL_QUAD_ALPHA4_SGIS = $811E;

GL_QUAD_ALPHA8_SGIS = $811F;

GL_QUAD_LUMINANCE4_SGIS = $8120;

GL_QUAD_LUMINANCE8_SGIS = $8121;

GL_QUAD_INTENSITY4_SGIS = $8122;

GL_QUAD_INTENSITY8_SGIS = $8123;

GL_DUAL_TEXTURE_SELECT_SGIS = $8124;

GL_QUAD_TEXTURE_SELECT_SGIS = $8125;

GL_ASYNC_MARKER_SGIX = $8329;

GL_ASYNC_HISTOGRAM_SGIX = $832C;

GL_MAX_ASYNC_HISTOGRAM_SGIX = $832D;

GL_ASYNC_TEX_IMAGE_SGIX = $835C;

GL_ASYNC_DRAW_PIXELS_SGIX = $835D;

GL_ASYNC_READ_PIXELS_SGIX = $835E;

GL_MAX_ASYNC_TEX_IMAGE_SGIX = $835F;

GL_MAX_ASYNC_DRAW_PIXELS_SGIX = $8360;

GL_MAX_ASYNC_READ_PIXELS_SGIX = $8361;

GL_ALPHA_MIN_SGIX = $8320;

GL_ALPHA_MAX_SGIX = $8321;

GL_CALLIGRAPHIC_FRAGMENT_SGIX = $8183;

GL_LINEAR_CLIPMAP_LINEAR_SGIX = $8170;

GL_TEXTURE_CLIPMAP_CENTER_SGIX = $8171;

GL_TEXTURE_CLIPMAP_FRAME_SGIX = $8172;

GL_TEXTURE_CLIPMAP_OFFSET_SGIX = $8173;

GL_TEXTURE_CLIPMAP_VIRTUAL_DEPTH_SGIX = $8174;

GL_TEXTURE_CLIPMAP_LOD_OFFSET_SGIX = $8175;

GL_TEXTURE_CLIPMAP_DEPTH_SGIX = $8176;

GL_MAX_CLIPMAP_DEPTH_SGIX = $8177;

GL_MAX_CLIPMAP_VIRTUAL_DEPTH_SGIX = $8178;

GL_NEAREST_CLIPMAP_NEAREST_SGIX = $844D;

GL_NEAREST_CLIPMAP_LINEAR_SGIX = $844E;

GL_LINEAR_CLIPMAP_NEAREST_SGIX = $844F;

GL_CONVOLUTION_HINT_SGIX = $8316;

GL_DEPTH_COMPONENT16_SGIX = $81A5;

GL_DEPTH_COMPONENT24_SGIX = $81A6;

GL_DEPTH_COMPONENT32_SGIX = $81A7;

GL_FOG_OFFSET_SGIX = $8198;

GL_FOG_OFFSET_VALUE_SGIX = $8199;

GL_FOG_SCALE_SGIX = $81FC;

GL_FOG_SCALE_VALUE_SGIX = $81FD;

GL_FRAGMENT_LIGHTING_SGIX = $8400;

GL_FRAGMENT_COLOR_MATERIAL_SGIX = $8401;

GL_FRAGMENT_COLOR_MATERIAL_FACE_SGIX = $8402;

GL_FRAGMENT_COLOR_MATERIAL_PARAMETER_SGIX = $8403;

GL_MAX_FRAGMENT_LIGHTS_SGIX = $8404;

GL_MAX_ACTIVE_LIGHTS_SGIX = $8405;

GL_CURRENT_RASTER_NORMAL_SGIX = $8406;

GL_LIGHT_ENV_MODE_SGIX = $8407;

GL_FRAGMENT_LIGHT_MODEL_LOCAL_VIEWER_SGIX = $8408;

GL_FRAGMENT_LIGHT_MODEL_TWO_SIDE_SGIX = $8409;

GL_FRAGMENT_LIGHT_MODEL_AMBIENT_SGIX = $840A;

GL_FRAGMENT_LIGHT_MODEL_NORMAL_INTERPOLATION_SGIX = $840B;

GL_FRAGMENT_LIGHT0_SGIX = $840C;

GL_FRAGMENT_LIGHT1_SGIX = $840D;

GL_FRAGMENT_LIGHT2_SGIX = $840E;

GL_FRAGMENT_LIGHT3_SGIX = $840F;

GL_FRAGMENT_LIGHT4_SGIX = $8410;

GL_FRAGMENT_LIGHT5_SGIX = $8411;

GL_FRAGMENT_LIGHT6_SGIX = $8412;

GL_FRAGMENT_LIGHT7_SGIX = $8413;

GL_FRAMEZOOM_SGIX = $818B;

GL_FRAMEZOOM_FACTOR_SGIX = $818C;

GL_MAX_FRAMEZOOM_FACTOR_SGIX = $818D;

GL_PIXEL_TEX_GEN_Q_CEILING_SGIX = $8184;

GL_PIXEL_TEX_GEN_Q_ROUND_SGIX = $8185;

GL_PIXEL_TEX_GEN_Q_FLOOR_SGIX = $8186;

GL_PIXEL_TEX_GEN_ALPHA_REPLACE_SGIX = $8187;

GL_PIXEL_TEX_GEN_ALPHA_NO_REPLACE_SGIX = $8188;

GL_PIXEL_TEX_GEN_ALPHA_LS_SGIX = $8189;

GL_PIXEL_TEX_GEN_ALPHA_MS_SGIX = $818A;

GL_INSTRUMENT_BUFFER_POINTER_SGIX = $8180;

GL_INSTRUMENT_MEASUREMENTS_SGIX = $8181;

GL_INTERLACE_SGIX = $8094;

GL_IR_INSTRUMENT1_SGIX = $817F;

GL_LIST_PRIORITY_SGIX = $8182;

GL_PIXEL_TEX_GEN_SGIX = $8139;

GL_PIXEL_TEX_GEN_MODE_SGIX = $832B;

GL_PIXEL_TILE_BEST_ALIGNMENT_SGIX = $813E;

GL_PIXEL_TILE_CACHE_INCREMENT_SGIX = $813F;

GL_PIXEL_TILE_WIDTH_SGIX = $8140;

GL_PIXEL_TILE_HEIGHT_SGIX = $8141;

GL_PIXEL_TILE_GRID_WIDTH_SGIX = $8142;

GL_PIXEL_TILE_GRID_HEIGHT_SGIX = $8143;

GL_PIXEL_TILE_GRID_DEPTH_SGIX = $8144;

GL_PIXEL_TILE_CACHE_SIZE_SGIX = $8145;

GL_GEOMETRY_DEFORMATION_SGIX = $8194;

GL_TEXTURE_DEFORMATION_SGIX = $8195;

GL_DEFORMATIONS_MASK_SGIX = $8196;

GL_MAX_DEFORMATION_ORDER_SGIX = $8197;

GL_REFERENCE_PLANE_SGIX = $817D;

GL_REFERENCE_PLANE_EQUATION_SGIX = $817E;

GL_PACK_RESAMPLE_SGIX = $842C;

GL_UNPACK_RESAMPLE_SGIX = $842D;

GL_RESAMPLE_REPLICATE_SGIX = $842E;

GL_RESAMPLE_ZERO_FILL_SGIX = $842F;

GL_RESAMPLE_DECIMATE_SGIX = $8430;

GL_SCALEBIAS_HINT_SGIX = $8322;

GL_TEXTURE_COMPARE_SGIX = $819A;

GL_TEXTURE_COMPARE_OPERATOR_SGIX = $819B;

GL_TEXTURE_LEQUAL_R_SGIX = $819C;

GL_TEXTURE_GEQUAL_R_SGIX = $819D;

GL_SHADOW_AMBIENT_SGIX = $80BF;

GL_SPRITE_SGIX = $8148;

GL_SPRITE_MODE_SGIX = $8149;

GL_SPRITE_AXIS_SGIX = $814A;

GL_SPRITE_TRANSLATION_SGIX = $814B;

GL_SPRITE_AXIAL_SGIX = $814C;

GL_SPRITE_OBJECT_ALIGNED_SGIX = $814D;

GL_SPRITE_EYE_ALIGNED_SGIX = $814E;

GL_PACK_SUBSAMPLE_RATE_SGIX = $85A0;

GL_UNPACK_SUBSAMPLE_RATE_SGIX = $85A1;

GL_PIXEL_SUBSAMPLE_4444_SGIX = $85A2;

GL_PIXEL_SUBSAMPLE_2424_SGIX = $85A3;

GL_PIXEL_SUBSAMPLE_4242_SGIX = $85A4;

GL_TEXTURE_ENV_BIAS_SGIX = $80BE;

GL_TEXTURE_MAX_CLAMP_S_SGIX = $8369;

GL_TEXTURE_MAX_CLAMP_T_SGIX = $836A;

GL_TEXTURE_MAX_CLAMP_R_SGIX = $836B;

GL_TEXTURE_LOD_BIAS_S_SGIX = $818E;

GL_TEXTURE_LOD_BIAS_T_SGIX = $818F;

GL_TEXTURE_LOD_BIAS_R_SGIX = $8190;

GL_TEXTURE_MULTI_BUFFER_HINT_SGIX = $812E;

GL_POST_TEXTURE_FILTER_BIAS_SGIX = $8179;

GL_POST_TEXTURE_FILTER_SCALE_SGIX = $817A;

GL_POST_TEXTURE_FILTER_BIAS_RANGE_SGIX = $817B;

GL_POST_TEXTURE_FILTER_SCALE_RANGE_SGIX = $817C;

GL_VERTEX_PRECLIP_SGIX = $83EE;

GL_VERTEX_PRECLIP_HINT_SGIX = $83EF;

GL_YCRCB_422_SGIX = $81BB;

GL_YCRCB_444_SGIX = $81BC;

GL_YCRCB_SGIX = $8318;

GL_YCRCBA_SGIX = $8319;

GL_COLOR_MATRIX_SGI = $80B1;

GL_COLOR_MATRIX_STACK_DEPTH_SGI = $80B2;

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI = $80B3;

GL_POST_COLOR_MATRIX_RED_SCALE_SGI = $80B4;

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI = $80B5;

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI = $80B6;

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI = $80B7;

GL_POST_COLOR_MATRIX_RED_BIAS_SGI = $80B8;

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI = $80B9;

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI = $80BA;

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI = $80BB;

GL_COLOR_TABLE_SGI = $80D0;

GL_POST_CONVOLUTION_COLOR_TABLE_SGI = $80D1;

GL_POST_COLOR_MATRIX_COLOR_TABLE_SGI = $80D2;

GL_PROXY_COLOR_TABLE_SGI = $80D3;

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE_SGI = $80D4;

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE_SGI = $80D5;

GL_COLOR_TABLE_SCALE_SGI = $80D6;

GL_COLOR_TABLE_BIAS_SGI = $80D7;

GL_COLOR_TABLE_FORMAT_SGI = $80D8;

GL_COLOR_TABLE_WIDTH_SGI = $80D9;

GL_COLOR_TABLE_RED_SIZE_SGI = $80DA;

GL_COLOR_TABLE_GREEN_SIZE_SGI = $80DB;

GL_COLOR_TABLE_BLUE_SIZE_SGI = $80DC;

GL_COLOR_TABLE_ALPHA_SIZE_SGI = $80DD;

GL_COLOR_TABLE_LUMINANCE_SIZE_SGI = $80DE;

GL_COLOR_TABLE_INTENSITY_SIZE_SGI = $80DF;

GL_DEPTH_PASS_INSTRUMENT_SGIX = $8310;

GL_DEPTH_PASS_INSTRUMENT_COUNTERS_SGIX = $8311;

GL_DEPTH_PASS_INSTRUMENT_MAX_SGIX = $8312;

GL_TEXTURE_COLOR_TABLE_SGI = $80BC;

GL_PROXY_TEXTURE_COLOR_TABLE_SGI = $80BD;

GL_UNPACK_CONSTANT_DATA_SUNX = $81D5;

GL_TEXTURE_CONSTANT_DATA_SUNX = $81D6;

GL_WRAP_BORDER_SUN = $81D4;

GL_GLOBAL_ALPHA_SUN = $81D9;

GL_GLOBAL_ALPHA_FACTOR_SUN = $81DA;

GL_QUAD_MESH_SUN = $8614;

GL_TRIANGLE_MESH_SUN = $8615;

GL_SLICE_ACCUM_SUN = $85CC;

GL_RESTART_SUN = $0001;

GL_REPLACE_MIDDLE_SUN = $0002;

GL_REPLACE_OLDEST_SUN = $0003;

GL_TRIANGLE_LIST_SUN = $81D7;

GL_REPLACEMENT_CODE_SUN = $81D8;

GL_REPLACEMENT_CODE_ARRAY_SUN = $85C0;

GL_REPLACEMENT_CODE_ARRAY_TYPE_SUN = $85C1;

GL_REPLACEMENT_CODE_ARRAY_STRIDE_SUN = $85C2;

GL_REPLACEMENT_CODE_ARRAY_POINTER_SUN = $85C3;

GL_R1UI_V3F_SUN = $85C4;

GL_R1UI_C4UB_V3F_SUN = $85C5;

GL_R1UI_C3F_V3F_SUN = $85C6;

GL_R1UI_N3F_V3F_SUN = $85C7;

GL_R1UI_C4F_N3F_V3F_SUN = $85C8;

GL_R1UI_T2F_V3F_SUN = $85C9;

GL_R1UI_T2F_N3F_V3F_SUN = $85CA;

GL_R1UI_T2F_C4F_N3F_V3F_SUN = $85CB;

GL_PHONG_WIN = $80EA;

GL_PHONG_HINT_WIN = $80EB;

GL_FOG_SPECULAR_TEXTURE_WIN = $80EC;

GL_VERTEX_SHADER_ARB = $8B31;

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB = $8B4A;

GL_MAX_VARYING_FLOATS_ARB = $8B4B;

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB = $8B4D;

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB = $8B89;

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB = $8B8A;

GL_MULTIPLY_KHR = $9294;

GL_SCREEN_KHR = $9295;

GL_OVERLAY_KHR = $9296;

GL_DARKEN_KHR = $9297;

GL_LIGHTEN_KHR = $9298;

GL_COLORDODGE_KHR = $9299;

GL_COLORBURN_KHR = $929A;

GL_HARDLIGHT_KHR = $929B;

GL_SOFTLIGHT_KHR = $929C;

GL_DIFFERENCE_KHR = $929E;

GL_EXCLUSION_KHR = $92A0;

GL_HSL_HUE_KHR = $92AD;

GL_HSL_SATURATION_KHR = $92AE;

GL_HSL_COLOR_KHR = $92AF;

GL_HSL_LUMINOSITY_KHR = $92B0;

GL_BLEND_ADVANCED_COHERENT_KHR = $9285;

GL_CONTEXT_ROBUST_ACCESS = $90F3;

GL_CONTEXT_FLAG_NO_ERROR_BIT_KHR = $00000008;

GL_FRAGMENT_SHADER_ARB = $8B30;

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB = $8B49;

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB = $8B8B;

GL_SAMPLES_PASSED_ARB = $8914;

GL_QUERY_COUNTER_BITS_ARB = $8864;

GL_CURRENT_QUERY_ARB = $8865;

GL_QUERY_RESULT_ARB = $8866;

GL_QUERY_RESULT_AVAILABLE_ARB = $8867;

GL_VERTICES_SUBMITTED_ARB = $82EE;

GL_PRIMITIVES_SUBMITTED_ARB = $82EF;

GL_VERTEX_SHADER_INVOCATIONS_ARB = $82F0;

GL_TESS_CONTROL_SHADER_PATCHES_ARB = $82F1;

GL_TESS_EVALUATION_SHADER_INVOCATIONS_ARB = $82F2;

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED_ARB = $82F3;

GL_FRAGMENT_SHADER_INVOCATIONS_ARB = $82F4;

GL_COMPUTE_SHADER_INVOCATIONS_ARB = $82F5;

GL_CLIPPING_INPUT_PRIMITIVES_ARB = $82F6;

GL_CLIPPING_OUTPUT_PRIMITIVES_ARB = $82F7;

GL_POINT_SPRITE_ARB = $8861;

GL_COORD_REPLACE_ARB = $8862;

GL_SHADING_LANGUAGE_VERSION_ARB = $8B8C;

GL_PROGRAM_OBJECT_ARB = $8B40;

GL_OBJECT_TYPE_ARB = $8B4E;

GL_OBJECT_SUBTYPE_ARB = $8B4F;

GL_OBJECT_DELETE_STATUS_ARB = $8B80;

GL_OBJECT_COMPILE_STATUS_ARB = $8B81;

GL_OBJECT_LINK_STATUS_ARB = $8B82;

GL_OBJECT_VALIDATE_STATUS_ARB = $8B83;

GL_OBJECT_INFO_LOG_LENGTH_ARB = $8B84;

GL_OBJECT_ATTACHED_OBJECTS_ARB = $8B85;

GL_OBJECT_ACTIVE_UNIFORMS_ARB = $8B86;

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB = $8B87;

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB = $8B88;

GL_SHADER_OBJECT_ARB = $8B48;

GL_FLOAT_VEC2_ARB = $8B50;

GL_FLOAT_VEC3_ARB = $8B51;

GL_FLOAT_VEC4_ARB = $8B52;

GL_INT_VEC2_ARB = $8B53;

GL_INT_VEC3_ARB = $8B54;

GL_INT_VEC4_ARB = $8B55;

GL_BOOL_ARB = $8B56;

GL_BOOL_VEC2_ARB = $8B57;

GL_BOOL_VEC3_ARB = $8B58;

GL_BOOL_VEC4_ARB = $8B59;

GL_FLOAT_MAT2_ARB = $8B5A;

GL_FLOAT_MAT3_ARB = $8B5B;

GL_FLOAT_MAT4_ARB = $8B5C;

GL_SAMPLER_1D_ARB = $8B5D;

GL_SAMPLER_2D_ARB = $8B5E;

GL_SAMPLER_3D_ARB = $8B5F;

GL_SAMPLER_CUBE_ARB = $8B60;

GL_SAMPLER_1D_SHADOW_ARB = $8B61;

GL_SAMPLER_2D_SHADOW_ARB = $8B62;

GL_SAMPLER_2D_RECT_ARB = $8B63;

GL_SAMPLER_2D_RECT_SHADOW_ARB = $8B64;

WGL_SAMPLE_BUFFERS_3DFX = $2060;

WGL_SAMPLES_3DFX = $2061;

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;

WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;

WGL_DEPTH_BUFFER_BIT_ARB = $00000004;

WGL_STENCIL_BUFFER_BIT_ARB = $00000008;

WGL_CONTEXT_RELEASE_BEHAVIOR_ARB = $2097;

WGL_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB = 0;

WGL_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB = $2098;

ERROR_INVALID_PIXEL_TYPE_ARB = $2043;

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB = $2054;

WGL_SAMPLE_BUFFERS_ARB = $2041;

WGL_SAMPLES_ARB = $2042;

WGL_DRAW_TO_PBUFFER_ARB = $202D;

WGL_MAX_PBUFFER_PIXELS_ARB = $202E;

WGL_MAX_PBUFFER_WIDTH_ARB = $202F;

WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;

WGL_PBUFFER_LARGEST_ARB = $2033;

WGL_PBUFFER_WIDTH_ARB = $2034;

WGL_PBUFFER_HEIGHT_ARB = $2035;

WGL_PBUFFER_LOST_ARB = $2036;

WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;

WGL_DRAW_TO_WINDOW_ARB = $2001;

WGL_DRAW_TO_BITMAP_ARB = $2002;

WGL_ACCELERATION_ARB = $2003;

WGL_NEED_PALETTE_ARB = $2004;

WGL_NEED_SYSTEM_PALETTE_ARB = $2005;

WGL_SWAP_LAYER_BUFFERS_ARB = $2006;

WGL_SWAP_METHOD_ARB = $2007;

WGL_NUMBER_OVERLAYS_ARB = $2008;

WGL_NUMBER_UNDERLAYS_ARB = $2009;

WGL_TRANSPARENT_ARB = $200A;

WGL_TRANSPARENT_RED_VALUE_ARB = $2037;

WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;

WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;

WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;

WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;

WGL_SHARE_DEPTH_ARB = $200C;

WGL_SHARE_STENCIL_ARB = $200D;

WGL_SHARE_ACCUM_ARB = $200E;

WGL_SUPPORT_GDI_ARB = $200F;

WGL_SUPPORT_OPENGL_ARB = $2010;

WGL_DOUBLE_BUFFER_ARB = $2011;

WGL_STEREO_ARB = $2012;

WGL_PIXEL_TYPE_ARB = $2013;

WGL_COLOR_BITS_ARB = $2014;

WGL_RED_BITS_ARB = $2015;

WGL_RED_SHIFT_ARB = $2016;

WGL_GREEN_BITS_ARB = $2017;

WGL_GREEN_SHIFT_ARB = $2018;

WGL_BLUE_BITS_ARB = $2019;

WGL_BLUE_SHIFT_ARB = $201A;

WGL_ALPHA_BITS_ARB = $201B;

WGL_ALPHA_SHIFT_ARB = $201C;

WGL_ACCUM_BITS_ARB = $201D;

WGL_ACCUM_RED_BITS_ARB = $201E;

WGL_ACCUM_GREEN_BITS_ARB = $201F;

WGL_ACCUM_BLUE_BITS_ARB = $2020;

WGL_ACCUM_ALPHA_BITS_ARB = $2021;

WGL_DEPTH_BITS_ARB = $2022;

WGL_STENCIL_BITS_ARB = $2023;

WGL_AUX_BUFFERS_ARB = $2024;

WGL_NO_ACCELERATION_ARB = $2025;

WGL_GENERIC_ACCELERATION_ARB = $2026;

WGL_FULL_ACCELERATION_ARB = $2027;

WGL_SWAP_EXCHANGE_ARB = $2028;

WGL_SWAP_COPY_ARB = $2029;

WGL_SWAP_UNDEFINED_ARB = $202A;

WGL_TYPE_RGBA_ARB = $202B;

WGL_TYPE_COLORINDEX_ARB = $202C;

WGL_RGBA_FLOAT_MODE_ARB = $8820;

WGL_CLAMP_VERTEX_COLOR_ARB = $891A;

WGL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

WGL_CLAMP_READ_COLOR_ARB = $891C;

WGL_FIXED_ONLY_ARB = $891D;

WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;

WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;

WGL_TEXTURE_FORMAT_ARB = $2072;

WGL_TEXTURE_TARGET_ARB = $2073;

WGL_MIPMAP_TEXTURE_ARB = $2074;

WGL_TEXTURE_RGB_ARB = $2075;

WGL_TEXTURE_RGBA_ARB = $2076;

WGL_NO_TEXTURE_ARB = $2077;

WGL_TEXTURE_CUBE_MAP_ARB = $2078;

WGL_TEXTURE_1D_ARB = $2079;

WGL_TEXTURE_2D_ARB = $207A;

WGL_MIPMAP_LEVEL_ARB = $207B;

WGL_CUBE_MAP_FACE_ARB = $207C;

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;

WGL_FRONT_LEFT_ARB = $2083;

WGL_FRONT_RIGHT_ARB = $2084;

WGL_BACK_LEFT_ARB = $2085;

WGL_BACK_RIGHT_ARB = $2086;

WGL_AUX0_ARB = $2087;

WGL_AUX1_ARB = $2088;

WGL_AUX2_ARB = $2089;

WGL_AUX3_ARB = $208A;

WGL_AUX4_ARB = $208B;

WGL_AUX5_ARB = $208C;

WGL_AUX6_ARB = $208D;

WGL_AUX7_ARB = $208E;

WGL_AUX8_ARB = $208F;

WGL_AUX9_ARB = $2090;

WGL_CONTEXT_RESET_ISOLATION_BIT_ARB = $00000008;

WGL_CONTEXT_DEBUG_BIT_ARB = $00000001;

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;

WGL_CONTEXT_MINOR_VERSION_ARB = $2092;

WGL_CONTEXT_LAYER_PLANE_ARB = $2093;

WGL_CONTEXT_FLAGS_ARB = $2094;

ERROR_INVALID_VERSION_ARB = $2095;

WGL_CONTEXT_PROFILE_MASK_ARB = $9126;

WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

ERROR_INVALID_PROFILE_ARB = $2096;

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;

WGL_CONTEXT_ROBUST_ACCESS_BIT_ARB = $00000004;

WGL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

WGL_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

WGL_NO_RESET_NOTIFICATION_ARB = $8261;

WGL_TYPE_RGBA_FLOAT_ATI = $21A0;

GL_TYPE_RGBA_FLOAT_ATI = $8820;

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI = $8835;

WGL_GPU_VENDOR_AMD = $1F00;

WGL_GPU_RENDERER_STRING_AMD = $1F01;

WGL_GPU_OPENGL_VERSION_STRING_AMD = $1F02;

WGL_GPU_FASTEST_TARGET_GPUS_AMD = $21A2;

WGL_GPU_RAM_AMD = $21A3;

WGL_GPU_CLOCK_AMD = $21A4;

WGL_GPU_NUM_PIPES_AMD = $21A5;

WGL_GPU_NUM_SIMD_AMD = $21A6;

WGL_GPU_NUM_RB_AMD = $21A7;

WGL_GPU_NUM_SPI_AMD = $21A8;

WGL_DEPTH_FLOAT_EXT = $2040;

ERROR_INVALID_PIXEL_TYPE_EXT = $2043;

WGL_SAMPLE_BUFFERS_EXT = $2041;

WGL_SAMPLES_EXT = $2042;

WGL_DRAW_TO_PBUFFER_EXT = $202D;

WGL_MAX_PBUFFER_PIXELS_EXT = $202E;

WGL_MAX_PBUFFER_WIDTH_EXT = $202F;

WGL_MAX_PBUFFER_HEIGHT_EXT = $2030;

WGL_OPTIMAL_PBUFFER_WIDTH_EXT = $2031;

WGL_OPTIMAL_PBUFFER_HEIGHT_EXT = $2032;

WGL_PBUFFER_LARGEST_EXT = $2033;

WGL_PBUFFER_WIDTH_EXT = $2034;

WGL_PBUFFER_HEIGHT_EXT = $2035;

WGL_NUMBER_PIXEL_FORMATS_EXT = $2000;

WGL_DRAW_TO_WINDOW_EXT = $2001;

WGL_DRAW_TO_BITMAP_EXT = $2002;

WGL_ACCELERATION_EXT = $2003;

WGL_NEED_PALETTE_EXT = $2004;

WGL_NEED_SYSTEM_PALETTE_EXT = $2005;

WGL_SWAP_LAYER_BUFFERS_EXT = $2006;

WGL_SWAP_METHOD_EXT = $2007;

WGL_NUMBER_OVERLAYS_EXT = $2008;

WGL_NUMBER_UNDERLAYS_EXT = $2009;

WGL_TRANSPARENT_EXT = $200A;

WGL_TRANSPARENT_VALUE_EXT = $200B;

WGL_SHARE_DEPTH_EXT = $200C;

WGL_SHARE_STENCIL_EXT = $200D;

WGL_SHARE_ACCUM_EXT = $200E;

WGL_SUPPORT_GDI_EXT = $200F;

WGL_SUPPORT_OPENGL_EXT = $2010;

WGL_DOUBLE_BUFFER_EXT = $2011;

WGL_STEREO_EXT = $2012;

WGL_PIXEL_TYPE_EXT = $2013;

WGL_COLOR_BITS_EXT = $2014;

WGL_RED_BITS_EXT = $2015;

WGL_RED_SHIFT_EXT = $2016;

WGL_GREEN_BITS_EXT = $2017;

WGL_GREEN_SHIFT_EXT = $2018;

WGL_BLUE_BITS_EXT = $2019;

WGL_BLUE_SHIFT_EXT = $201A;

WGL_ALPHA_BITS_EXT = $201B;

WGL_ALPHA_SHIFT_EXT = $201C;

WGL_ACCUM_BITS_EXT = $201D;

WGL_ACCUM_RED_BITS_EXT = $201E;

WGL_ACCUM_GREEN_BITS_EXT = $201F;

WGL_ACCUM_BLUE_BITS_EXT = $2020;

WGL_ACCUM_ALPHA_BITS_EXT = $2021;

WGL_DEPTH_BITS_EXT = $2022;

WGL_STENCIL_BITS_EXT = $2023;

WGL_AUX_BUFFERS_EXT = $2024;

WGL_NO_ACCELERATION_EXT = $2025;

WGL_GENERIC_ACCELERATION_EXT = $2026;

WGL_FULL_ACCELERATION_EXT = $2027;

WGL_SWAP_EXCHANGE_EXT = $2028;

WGL_SWAP_COPY_EXT = $2029;

WGL_SWAP_UNDEFINED_EXT = $202A;

WGL_TYPE_RGBA_EXT = $202B;

WGL_TYPE_COLORINDEX_EXT = $202C;

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_FRAMEBUFFER_I3D = $2050;

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_VALUE_I3D = $2051;

WGL_DIGITAL_VIDEO_CURSOR_INCLUDED_I3D = $2052;

WGL_DIGITAL_VIDEO_GAMMA_CORRECTED_I3D = $2053;

WGL_GAMMA_TABLE_SIZE_I3D = $204E;

WGL_GAMMA_EXCLUDE_DESKTOP_I3D = $204F;

WGL_GENLOCK_SOURCE_MULTIVIEW_I3D = $2044;

WGL_GENLOCK_SOURCE_EXTENAL_SYNC_I3D = $2045;

WGL_GENLOCK_SOURCE_EXTENAL_FIELD_I3D = $2046;

WGL_GENLOCK_SOURCE_EXTENAL_TTL_I3D = $2047;

WGL_GENLOCK_SOURCE_DIGITAL_SYNC_I3D = $2048;

WGL_GENLOCK_SOURCE_DIGITAL_FIELD_I3D = $2049;

WGL_GENLOCK_SOURCE_EDGE_FALLING_I3D = $204A;

WGL_GENLOCK_SOURCE_EDGE_RISING_I3D = $204B;

WGL_GENLOCK_SOURCE_EDGE_BOTH_I3D = $204C;

WGL_IMAGE_BUFFER_MIN_ACCESS_I3D = $00000001;

WGL_IMAGE_BUFFER_LOCK_I3D = $00000002;

WGL_FLOAT_COMPONENTS_NV = $20B0;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;

WGL_TEXTURE_FLOAT_R_NV = $20B5;

WGL_TEXTURE_FLOAT_RG_NV = $20B6;

WGL_TEXTURE_FLOAT_RGB_NV = $20B7;

WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;

WGL_BIND_TO_TEXTURE_DEPTH_NV = $20A3;

WGL_BIND_TO_TEXTURE_RECTANGLE_DEPTH_NV = $20A4;

WGL_DEPTH_TEXTURE_FORMAT_NV = $20A5;

WGL_TEXTURE_DEPTH_COMPONENT_NV = $20A6;

WGL_DEPTH_COMPONENT_NV = $20A7;

WGL_BIND_TO_TEXTURE_RECTANGLE_RGB_NV = $20A0;

WGL_BIND_TO_TEXTURE_RECTANGLE_RGBA_NV = $20A1;

WGL_TEXTURE_RECTANGLE_NV = $20A2;

WGL_NUM_VIDEO_SLOTS_NV = $20F0;

WGL_BIND_TO_VIDEO_RGB_NV = $20C0;

WGL_BIND_TO_VIDEO_RGBA_NV = $20C1;

WGL_BIND_TO_VIDEO_RGB_AND_DEPTH_NV = $20C2;

WGL_VIDEO_OUT_COLOR_NV = $20C3;

WGL_VIDEO_OUT_ALPHA_NV = $20C4;

WGL_VIDEO_OUT_DEPTH_NV = $20C5;

WGL_VIDEO_OUT_COLOR_AND_ALPHA_NV = $20C6;

WGL_VIDEO_OUT_COLOR_AND_DEPTH_NV = $20C7;

WGL_VIDEO_OUT_FRAME = $20C8;

WGL_VIDEO_OUT_FIELD_1 = $20C9;

WGL_VIDEO_OUT_FIELD_2 = $20CA;

WGL_VIDEO_OUT_STACKED_FIELDS_1_2 = $20CB;

WGL_VIDEO_OUT_STACKED_FIELDS_2_1 = $20CC;

WGL_ERROR_INCOMPATIBLE_AFFINITY_MASKS_NV = $20D0;

WGL_ERROR_MISSING_AFFINITY_MASK_NV = $20D1;

WGL_UNIQUE_ID_NV = $20CE;

WGL_NUM_VIDEO_CAPTURE_SLOTS_NV = $20CF;

WGL_COVERAGE_SAMPLES_NV = $2042;

WGL_COLOR_SAMPLES_NV = $20B9;

WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $00000004;

WGL_ACCESS_READ_ONLY_NV = $00000000;

WGL_ACCESS_READ_WRITE_NV = $00000001;

WGL_ACCESS_WRITE_DISCARD_NV = $00000002;

GL_MAX_ELEMENTS_VERTICES_WIN = $80E8;

GL_MAX_ELEMENTS_INDICES_WIN = $80E9;

GLX_VENDOR = 1;

GLX_VERSION = 2;

GLX_EXTENSIONS = 3;

GLX_USE_GL = 1;

GLX_BUFFER_SIZE = 2;

GLX_LEVEL = 3;

GLX_RGBA = 4;

GLX_DOUBLEBUFFER = 5;

GLX_STEREO = 6;

GLX_AUX_BUFFERS = 7;

GLX_RED_SIZE = 8;

GLX_GREEN_SIZE = 9;

GLX_BLUE_SIZE = 10;

GLX_ALPHA_SIZE = 11;

GLX_DEPTH_SIZE = 12;

GLX_STENCIL_SIZE = 13;

GLX_ACCUM_RED_SIZE = 14;

GLX_ACCUM_GREEN_SIZE = 15;

GLX_ACCUM_BLUE_SIZE = 16;

GLX_ACCUM_ALPHA_SIZE = 17;

GLX_WINDOW_BIT = $00000001;

GLX_PIXMAP_BIT = $00000002;

GLX_PBUFFER_BIT = $00000004;

GLX_RGBA_BIT = $00000001;

GLX_COLOR_INDEX_BIT = $00000002;

GLX_PBUFFER_CLOBBER_MASK = $08000000;

GLX_FRONT_LEFT_BUFFER_BIT = $00000001;

GLX_FRONT_RIGHT_BUFFER_BIT = $00000002;

GLX_BACK_LEFT_BUFFER_BIT = $00000004;

GLX_BACK_RIGHT_BUFFER_BIT = $00000008;

GLX_AUX_BUFFERS_BIT = $00000010;

GLX_DEPTH_BUFFER_BIT = $00000020;

GLX_STENCIL_BUFFER_BIT = $00000040;

GLX_ACCUM_BUFFER_BIT = $00000080;

GLX_CONFIG_CAVEAT = $20;

GLX_X_VISUAL_TYPE = $22;

GLX_TRANSPARENT_TYPE = $23;

GLX_TRANSPARENT_INDEX_VALUE = $24;

GLX_TRANSPARENT_RED_VALUE = $25;

GLX_TRANSPARENT_GREEN_VALUE = $26;

GLX_TRANSPARENT_BLUE_VALUE = $27;

GLX_TRANSPARENT_ALPHA_VALUE = $28;

GLX_DONT_CARE = $FFFFFFFF;

GLX_NONE = $8000;

GLX_SLOW_CONFIG = $8001;

GLX_TRUE_COLOR = $8002;

GLX_DIRECT_COLOR = $8003;

GLX_PSEUDO_COLOR = $8004;

GLX_STATIC_COLOR = $8005;

GLX_GRAY_SCALE = $8006;

GLX_STATIC_GRAY = $8007;

GLX_TRANSPARENT_RGB = $8008;

GLX_TRANSPARENT_INDEX = $8009;

GLX_VISUAL_ID = $800B;

GLX_SCREEN = $800C;

GLX_NON_CONFORMANT_CONFIG = $800D;

GLX_DRAWABLE_TYPE = $8010;

GLX_RENDER_TYPE = $8011;

GLX_X_RENDERABLE = $8012;

GLX_FBCONFIG_ID = $8013;

GLX_RGBA_TYPE = $8014;

GLX_COLOR_INDEX_TYPE = $8015;

GLX_MAX_PBUFFER_WIDTH = $8016;

GLX_MAX_PBUFFER_HEIGHT = $8017;

GLX_MAX_PBUFFER_PIXELS = $8018;

GLX_PRESERVED_CONTENTS = $801B;

GLX_LARGEST_PBUFFER = $801C;

GLX_WIDTH = $801D;

GLX_HEIGHT = $801E;

GLX_EVENT_MASK = $801F;

GLX_DAMAGED = $8020;

GLX_SAVED = $8021;

GLX_WINDOW = $8022;

GLX_PBUFFER = $8023;

GLX_PBUFFER_HEIGHT = $8040;

GLX_PBUFFER_WIDTH = $8041;

GLX_SAMPLE_BUFFERS = 100000;

GLX_SAMPLES = 100001;

GLX_SAMPLE_BUFFERS_ARB = 100000;

GLX_SAMPLES_ARB = 100001;

GLX_CONTEXT_RESET_ISOLATION_BIT_ARB = $00000008;

GLX_RGBA_FLOAT_TYPE_ARB = $20B9;

GLX_RGBA_FLOAT_BIT_ARB = $00000004;

GLX_CONTEXT_RELEASE_BEHAVIOR_ARB = $2097;

GLX_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB = 0;

GLX_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB = $2098;

GLX_CONTEXT_DEBUG_BIT_ARB = $00000001;

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

GLX_CONTEXT_MAJOR_VERSION_ARB = $2091;

GLX_CONTEXT_MINOR_VERSION_ARB = $2092;

GLX_CONTEXT_FLAGS_ARB = $2094;

GLX_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

GLX_CONTEXT_PROFILE_MASK_ARB = $9126;

GLX_CONTEXT_ALLOW_BUFFER_BYTE_ORDER_MISMATCH_ARB = $2095;

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20B2;

GLX_CONTEXT_ROBUST_ACCESS_BIT_ARB = $00000004;

GLX_LOSE_CONTEXT_ON_RESET_ARB = $8252;

GLX_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

GLX_NO_RESET_NOTIFICATION_ARB = $8261;

GLX_X_VISUAL_TYPE_EXT = $22;

GLX_TRANSPARENT_TYPE_EXT = $23;

GLX_TRANSPARENT_INDEX_VALUE_EXT = $24;

GLX_TRANSPARENT_RED_VALUE_EXT = $25;

GLX_TRANSPARENT_GREEN_VALUE_EXT = $26;

GLX_TRANSPARENT_BLUE_VALUE_EXT = $27;

GLX_TRANSPARENT_ALPHA_VALUE_EXT = $28;

GLX_NONE_EXT = $8000;

GLX_TRUE_COLOR_EXT = $8002;

GLX_DIRECT_COLOR_EXT = $8003;

GLX_PSEUDO_COLOR_EXT = $8004;

GLX_STATIC_COLOR_EXT = $8005;

GLX_GRAY_SCALE_EXT = $8006;

GLX_STATIC_GRAY_EXT = $8007;

GLX_TRANSPARENT_RGB_EXT = $8008;

GLX_TRANSPARENT_INDEX_EXT = $8009;

GLX_VISUAL_CAVEAT_EXT = $20;

GLX_SLOW_VISUAL_EXT = $8001;

GLX_NON_CONFORMANT_VISUAL_EXT = $800D;

GLX_SHARE_CONTEXT_EXT = $800A;

GLX_VISUAL_ID_EXT = $800B;

GLX_SCREEN_EXT = $800C;

GLX_TEXTURE_1D_BIT_EXT = $00000001;

GLX_TEXTURE_2D_BIT_EXT = $00000002;

GLX_TEXTURE_RECTANGLE_BIT_EXT = $00000004;

GLX_BIND_TO_TEXTURE_RGB_EXT = $20D0;

GLX_BIND_TO_TEXTURE_RGBA_EXT = $20D1;

GLX_BIND_TO_MIPMAP_TEXTURE_EXT = $20D2;

GLX_BIND_TO_TEXTURE_TARGETS_EXT = $20D3;

GLX_Y_INVERTED_EXT = $20D4;

GLX_TEXTURE_FORMAT_EXT = $20D5;

GLX_TEXTURE_TARGET_EXT = $20D6;

GLX_MIPMAP_TEXTURE_EXT = $20D7;

GLX_TEXTURE_FORMAT_NONE_EXT = $20D8;

GLX_TEXTURE_FORMAT_RGB_EXT = $20D9;

GLX_TEXTURE_FORMAT_RGBA_EXT = $20DA;

GLX_TEXTURE_1D_EXT = $20DB;

GLX_TEXTURE_2D_EXT = $20DC;

GLX_TEXTURE_RECTANGLE_EXT = $20DD;

GLX_FRONT_LEFT_EXT = $20DE;

GLX_FRONT_RIGHT_EXT = $20DF;

GLX_BACK_LEFT_EXT = $20E0;

GLX_BACK_RIGHT_EXT = $20E1;

GLX_FRONT_EXT = GLX_FRONT_LEFT_EXT;

GLX_BACK_EXT = GLX_BACK_LEFT_EXT;

GLX_AUX0_EXT = $20E2;

GLX_AUX1_EXT = $20E3;

GLX_AUX2_EXT = $20E4;

GLX_AUX3_EXT = $20E5;

GLX_AUX4_EXT = $20E6;

GLX_AUX5_EXT = $20E7;

GLX_AUX6_EXT = $20E8;

GLX_AUX7_EXT = $20E9;

GLX_AUX8_EXT = $20EA;

GLX_AUX9_EXT = $20EB;

GLX_SWAP_INTERVAL_EXT = $20F1;

GLX_MAX_SWAP_INTERVAL_EXT = $20F2;

GLX_CONTEXT_ES2_PROFILE_BIT_EXT = $00000004;

GLX_LATE_SWAPS_TEAR_EXT = $20F3;

GLU_INVALID_ENUM = 100900;

GLU_INVALID_VALUE = 100901;

GLU_OUT_OF_MEMORY = 100902;

GLU_INCOMPATIBLE_GL_VERSION = 100903;

GLU_VERSION = 100800;

GLU_EXTENSIONS = 100801;

GLU_TRUE = GL_TRUE;

GLU_FALSE = GL_FALSE;

GLU_SMOOTH = 100000;

GLU_FLAT = 100001;

GLU_NONE = 100002;

GLU_POINT = 100010;

GLU_LINE = 100011;

GLU_FILL = 100012;

GLU_SILHOUETTE = 100013;

GLU_OUTSIDE = 100020;

GLU_INSIDE = 100021;

GLU_TESS_MAX_COORD = 1.0E150;

GLU_TESS_WINDING_RULE = 100140;

GLU_TESS_BOUNDARY_ONLY = 100141;

GLU_TESS_TOLERANCE = 100142;

GLU_TESS_WINDING_ODD = 100130;

GLU_TESS_WINDING_NONZERO = 100131;

GLU_TESS_WINDING_POSITIVE = 100132;

GLU_TESS_WINDING_NEGATIVE = 100133;

GLU_TESS_WINDING_ABS_GEQ_TWO = 100134;

GLU_TESS_BEGIN = 100100;

GLU_TESS_VERTEX = 100101;

GLU_TESS_END = 100102;

GLU_TESS_ERROR = 100103;

GLU_TESS_EDGE_FLAG = 100104;

GLU_TESS_COMBINE = 100105;

GLU_TESS_BEGIN_DATA = 100106;

GLU_TESS_VERTEX_DATA = 100107;

GLU_TESS_END_DATA = 100108;

GLU_TESS_ERROR_DATA = 100109;

GLU_TESS_EDGE_FLAG_DATA = 100110;

GLU_TESS_COMBINE_DATA = 100111;

GLU_TESS_ERROR1 = 100151;

GLU_TESS_ERROR2 = 100152;

GLU_TESS_ERROR3 = 100153;

GLU_TESS_ERROR4 = 100154;

GLU_TESS_ERROR5 = 100155;

GLU_TESS_ERROR6 = 100156;

GLU_TESS_ERROR7 = 100157;

GLU_TESS_ERROR8 = 100158;

GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;

GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;

GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;

GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;

GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;

GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;

GLU_AUTO_LOAD_MATRIX = 100200;

GLU_CULLING = 100201;

GLU_SAMPLING_TOLERANCE = 100203;

GLU_DISPLAY_MODE = 100204;

GLU_PARAMETRIC_TOLERANCE = 100202;

GLU_SAMPLING_METHOD = 100205;

GLU_U_STEP = 100206;

GLU_V_STEP = 100207;

GLU_PATH_LENGTH = 100215;

GLU_PARAMETRIC_ERROR = 100216;

GLU_DOMAIN_DISTANCE = 100217;

GLU_MAP1_TRIM_2 = 100210;

GLU_MAP1_TRIM_3 = 100211;

GLU_OUTLINE_POLYGON = 100240;

GLU_OUTLINE_PATCH = 100241;

GLU_NURBS_ERROR1 = 100251;

GLU_NURBS_ERROR2 = 100252;

GLU_NURBS_ERROR3 = 100253;

GLU_NURBS_ERROR4 = 100254;

GLU_NURBS_ERROR5 = 100255;

GLU_NURBS_ERROR6 = 100256;

GLU_NURBS_ERROR7 = 100257;

GLU_NURBS_ERROR8 = 100258;

GLU_NURBS_ERROR9 = 100259;

GLU_NURBS_ERROR10 = 100260;

GLU_NURBS_ERROR11 = 100261;

GLU_NURBS_ERROR12 = 100262;

GLU_NURBS_ERROR13 = 100263;

GLU_NURBS_ERROR14 = 100264;

GLU_NURBS_ERROR15 = 100265;

GLU_NURBS_ERROR16 = 100266;

GLU_NURBS_ERROR17 = 100267;

GLU_NURBS_ERROR18 = 100268;

GLU_NURBS_ERROR19 = 100269;

GLU_NURBS_ERROR20 = 100270;

GLU_NURBS_ERROR21 = 100271;

GLU_NURBS_ERROR22 = 100272;

GLU_NURBS_ERROR23 = 100273;

GLU_NURBS_ERROR24 = 100274;

GLU_NURBS_ERROR25 = 100275;

GLU_NURBS_ERROR26 = 100276;

GLU_NURBS_ERROR27 = 100277;

GLU_NURBS_ERROR28 = 100278;

GLU_NURBS_ERROR29 = 100279;

GLU_NURBS_ERROR30 = 100280;

GLU_NURBS_ERROR31 = 100281;

GLU_NURBS_ERROR32 = 100282;

GLU_NURBS_ERROR33 = 100283;

GLU_NURBS_ERROR34 = 100284;

GLU_NURBS_ERROR35 = 100285;

GLU_NURBS_ERROR36 = 100286;

GLU_NURBS_ERROR37 = 100287;

GLU_CW = 100120;

GLU_CCW = 100121;

GLU_INTERIOR = 100122;

GLU_EXTERIOR = 100123;

GLU_UNKNOWN = 100124;

GLU_BEGIN = GLU_TESS_BEGIN;

GLU_VERTEX = GLU_TESS_VERTEX;

GLU_END = GLU_TESS_END;

GLU_ERROR = GLU_TESS_ERROR;

GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;

Variables

GL_VERSION_4_0: Boolean;

GL_VERSION_4_1: Boolean;

GL_VERSION_4_2: Boolean;

GL_VERSION_4_3: Boolean;

GL_VERSION_4_4: Boolean;

GL_VERSION_4_5: Boolean;

GL_VERSION_4_6: Boolean;

GLU_VERSION_1_3: Boolean;

GL_3DFX_multisample: Boolean;

GL_3DFX_tbuffer: Boolean;

GL_3DFX_texture_compression_FXT1: Boolean;

GL_APPLE_client_storage: Boolean;

GL_APPLE_element_array: Boolean;

GL_APPLE_fence: Boolean;

GL_APPLE_specular_vector: Boolean;

GL_APPLE_transform_hint: Boolean;

GL_APPLE_vertex_array_object: Boolean;

GL_APPLE_vertex_array_range: Boolean;

GL_APPLE_ycbcr_422: Boolean;

GL_APPLE_texture_range: Boolean;

GL_APPLE_float_pixels: Boolean;

GL_APPLE_vertex_program_evaluators: Boolean;

GL_APPLE_aux_depth_stencil: Boolean;

GL_APPLE_object_purgeable: Boolean;

GL_APPLE_row_bytes: Boolean;

GL_APPLE_rgb_422: Boolean;

GL_ARB_depth_texture: Boolean;

GL_ARB_fragment_program: Boolean;

GL_ARB_imaging: Boolean;

GL_ARB_matrix_palette: Boolean;

GL_ARB_multisample: Boolean;

GL_ARB_multitexture: Boolean;

GL_ARB_point_parameters: Boolean;

GL_ARB_shadow: Boolean;

GL_ARB_shadow_ambient: Boolean;

GL_ARB_texture_border_clamp: Boolean;

GL_ARB_texture_compression: Boolean;

GL_ARB_texture_cube_map: Boolean;

GL_ARB_texture_env_add: Boolean;

GL_ARB_texture_env_combine: Boolean;

GL_ARB_texture_env_crossbar: Boolean;

GL_ARB_texture_env_dot3: Boolean;

GL_ARB_texture_filter_minmax: Boolean;

GL_ARB_texture_mirrored_repeat: Boolean;

GL_ARB_transpose_matrix: Boolean;

GL_ARB_vertex_blend: Boolean;

GL_ARB_vertex_buffer_object: Boolean;

GL_ARB_vertex_program: Boolean;

GL_ARB_window_pos: Boolean;

GL_ARB_shader_objects: Boolean;

GL_ARB_vertex_shader: Boolean;

GL_ARB_fragment_shader: Boolean;

GL_ARB_fragment_shader_interlock: Boolean;

GL_ARB_shading_language_100: Boolean;

GL_ARB_occlusion_query: Boolean;

GL_ARB_texture_non_power_of_two: Boolean;

GL_ARB_point_sprite: Boolean;

GL_ARB_fragment_program_shadow: Boolean;

GL_ARB_draw_buffers: Boolean;

GL_ARB_texture_rectangle: Boolean;

GL_ARB_color_buffer_float: Boolean;

GL_ARB_half_float_pixel: Boolean;

GL_ARB_texture_float: Boolean;

GL_ARB_pixel_buffer_object: Boolean;

GL_ARB_depth_buffer_float: Boolean;

GL_ARB_draw_instanced: Boolean;

GL_ARB_framebuffer_object: Boolean;

GL_ARB_framebuffer_sRGB: Boolean;

GL_ARB_geometry_shader4: Boolean;

GL_ARB_half_float_vertex: Boolean;

GL_ARB_instanced_arrays: Boolean;

GL_ARB_map_buffer_range: Boolean;

GL_ARB_texture_buffer_object: Boolean;

GL_ARB_texture_compression_rgtc: Boolean;

GL_ARB_texture_rg: Boolean;

GL_ARB_vertex_array_object: Boolean;

GL_ARB_uniform_buffer_object: Boolean;

GL_ARB_compatibility: Boolean;

GL_ARB_copy_buffer: Boolean;

GL_ARB_shader_texture_lod: Boolean;

GL_ARB_shader_viewport_layer_array: Boolean;

GL_ARB_depth_clamp: Boolean;

GL_ARB_draw_elements_base_vertex: Boolean;

GL_ARB_fragment_coord_conventions: Boolean;

GL_ARB_provoking_vertex: Boolean;

GL_ARB_seamless_cube_map: Boolean;

GL_ARB_sync: Boolean;

GL_ARB_texture_multisample: Boolean;

GL_ARB_vertex_array_bgra: Boolean;

GL_ARB_draw_buffers_blend: Boolean;

GL_ARB_sample_shading: Boolean;

GL_ARB_sample_locations: Boolean;

GL_ARB_sparse_texture2: Boolean;

GL_ARB_sparse_texture_clamp: Boolean;

GL_ARB_texture_cube_map_array: Boolean;

GL_ARB_texture_gather: Boolean;

GL_ARB_texture_query_lod: Boolean;

GL_ARB_shading_language_include: Boolean;

GL_ARB_texture_compression_bptc: Boolean;

GL_ARB_blend_func_extended: Boolean;

GL_ARB_explicit_attrib_location: Boolean;

GL_ARB_occlusion_query2: Boolean;

GL_ARB_parallel_shader_compile: Boolean;

GL_ARB_post_depth_coverage: Boolean;

GL_ARB_sampler_objects: Boolean;

GL_ARB_shader_bit_encoding: Boolean;

GL_ARB_shader_clock: Boolean;

GL_ARB_texture_rgb10_a2ui: Boolean;

GL_ARB_texture_swizzle: Boolean;

GL_ARB_timer_query: Boolean;

GL_ARB_vertex_type_2_10_10_10_rev: Boolean;

GL_ARB_draw_indirect: Boolean;

GL_ARB_gpu_shader5: Boolean;

GL_ARB_gpu_shader_fp64: Boolean;

GL_ARB_gpu_shader_int64: Boolean;

GL_ARB_shader_subroutine: Boolean;

GL_ARB_tessellation_shader: Boolean;

GL_ARB_texture_buffer_object_rgb32: Boolean;

GL_ARB_transform_feedback2: Boolean;

GL_ARB_transform_feedback3: Boolean;

GL_ARB_ES2_compatibility: Boolean;

GL_ARB_ES3_2_compatibility: Boolean;

GL_ARB_get_program_binary: Boolean;

GL_ARB_separate_shader_objects: Boolean;

GL_ARB_shader_precision: Boolean;

GL_ARB_shader_ballot: Boolean;

GL_ARB_vertex_attrib_64bit: Boolean;

GL_ARB_viewport_array: Boolean;

GL_ARB_base_instance: Boolean;

GL_ARB_shading_language_420pack: Boolean;

GL_ARB_transform_feedback_instanced: Boolean;

GL_ARB_compressed_texture_pixel_storage: Boolean;

GL_ARB_conservative_depth: Boolean;

GL_ARB_internalformat_query: Boolean;

GL_ARB_map_buffer_alignment: Boolean;

GL_ARB_shader_atomic_counters: Boolean;

GL_ARB_shader_image_load_store: Boolean;

GL_ARB_shading_language_packing: Boolean;

GL_ARB_texture_storage: Boolean;

GL_ARB_arrays_of_arrays: Boolean;

GL_ARB_fragment_layer_viewport: Boolean;

GL_ARB_shader_image_size: Boolean;

GL_ARB_ES3_compatibility: Boolean;

GL_ARB_clear_buffer_object: Boolean;

GL_ARB_compute_shader: Boolean;

GL_ARB_copy_image: Boolean;

GL_KHR_debug: Boolean;

GL_ARB_explicit_uniform_location: Boolean;

GL_ARB_framebuffer_no_attachments: Boolean;

GL_ARB_internalformat_query2: Boolean;

GL_ARB_invalidate_subdata: Boolean;

GL_ARB_multi_draw_indirect: Boolean;

GL_ARB_program_interface_query: Boolean;

GL_ARB_robust_buffer_access_behavior: Boolean;

GL_ARB_shader_storage_buffer_object: Boolean;

GL_ARB_stencil_texturing: Boolean;

GL_ARB_texture_buffer_range: Boolean;

GL_ARB_texture_query_levels: Boolean;

GL_ARB_texture_storage_multisample: Boolean;

GL_ARB_texture_view: Boolean;

GL_ARB_vertex_attrib_binding: Boolean;

GL_NV_path_rendering: Boolean;

GL_AMD_pinned_memory: Boolean;

GL_AMD_stencil_operation_extended: Boolean;

GL_AMD_vertex_shader_viewport_index: Boolean;

GL_AMD_vertex_shader_layer: Boolean;

GL_NV_bindless_texture: Boolean;

GL_NV_shader_atomic_float: Boolean;

GL_AMD_query_buffer_object: Boolean;

GL_ARB_buffer_storage: Boolean;

GL_ARB_clear_texture: Boolean;

GL_ARB_enhanced_layouts: Boolean;

GL_ARB_multi_bind: Boolean;

GL_ARB_query_buffer_object: Boolean;

GL_ARB_texture_mirror_clamp_to_edge: Boolean;

GL_ARB_texture_stencil8: Boolean;

GL_ARB_vertex_type_10f_11f_11f_rev: Boolean;

GL_ARB_bindless_texture: Boolean;

GL_ARB_sparse_texture: Boolean;

GL_ARB_clip_control: Boolean;

GL_ARB_cull_distance: Boolean;

GL_ARB_ES3_1_compatibility: Boolean;

GL_ARB_conditional_render_inverted: Boolean;

GL_KHR_context_flush_control: Boolean;

GL_ARB_derivative_control: Boolean;

GL_ARB_direct_state_access: Boolean;

GL_ARB_get_texture_sub_image: Boolean;

GL_KHR_robustness: Boolean;

GL_KHR_blend_equation_advanced: Boolean;

GL_KHR_blend_equation_advanced_coherent: Boolean;

GL_KHR_robust_buffer_access_behavior: Boolean;

GL_ARB_shader_texture_image_samples: Boolean;

GL_ARB_texture_barrier: Boolean;

GL_ARB_indirect_parameters: Boolean;

GL_ARB_pipeline_statistics_query: Boolean;

GL_ARB_polygon_offset_clamp: Boolean;

GL_KHR_no_error: Boolean;

GL_ARB_shader_atomic_counter_ops: Boolean;

GL_ARB_shader_draw_parameters: Boolean;

GL_ARB_shader_group_vote: Boolean;

GL_ARB_gl_spirv: Boolean;

GL_ARB_spirv_extensions: Boolean;

GL_ARB_texture_filter_anisotropic: Boolean;

GL_ARB_transform_feedback_overflow_query: Boolean;

GL_ARB_cl_event: Boolean;

GL_ARB_compute_variable_group_size: Boolean;

GL_ARB_debug_output: Boolean;

GL_ARB_robustness: Boolean;

GL_ARB_shader_stencil_export: Boolean;

GL_ATI_draw_buffers: Boolean;

GL_ATI_element_array: Boolean;

GL_ATI_envmap_bumpmap: Boolean;

GL_ATI_fragment_shader: Boolean;

GL_ATI_map_object_buffer: Boolean;

GL_ATI_pn_triangles: Boolean;

GL_ATI_separate_stencil: Boolean;

GL_ATI_text_fragment_shader: Boolean;

GL_ATI_texture_env_combine3: Boolean;

GL_ATI_texture_float: Boolean;

GL_ATI_texture_mirror_once: Boolean;

GL_ATI_vertex_array_object: Boolean;

GL_ATI_vertex_attrib_array_object: Boolean;

GL_ATI_vertex_streams: Boolean;

GL_ATI_meminfo: Boolean;

GL_AMD_performance_monitor: Boolean;

GL_AMD_texture_texture4: Boolean;

GL_AMD_vertex_shader_tesselator: Boolean;

GL_AMD_draw_buffers_blend: Boolean;

GL_AMD_shader_stencil_export: Boolean;

GL_AMD_seamless_cubemap_per_texture: Boolean;

GL_AMD_conservative_depth: Boolean;

GL_AMD_name_gen_delete: Boolean;

GL_AMD_debug_output: Boolean;

GL_AMD_transform_feedback3_lines_triangles: Boolean;

GL_AMD_depth_clamp_separate: Boolean;

GL_EXT_422_pixels: Boolean;

GL_EXT_abgr: Boolean;

GL_EXT_bgra: Boolean;

GL_EXT_blend_color: Boolean;

GL_EXT_blend_func_separate: Boolean;

GL_EXT_blend_logic_op: Boolean;

GL_EXT_blend_minmax: Boolean;

GL_EXT_blend_subtract: Boolean;

GL_EXT_clip_volume_hint: Boolean;

GL_EXT_cmyka: Boolean;

GL_EXT_color_matrix: Boolean;

GL_EXT_color_subtable: Boolean;

GL_EXT_compiled_vertex_array: Boolean;

GL_EXT_convolution: Boolean;

GL_EXT_coordinate_frame: Boolean;

GL_EXT_copy_texture: Boolean;

GL_EXT_cull_vertex: Boolean;

GL_EXT_draw_range_elements: Boolean;

GL_EXT_fog_coord: Boolean;

GL_EXT_framebuffer_object: Boolean;

GL_EXT_histogram: Boolean;

GL_EXT_index_array_formats: Boolean;

GL_EXT_index_func: Boolean;

GL_EXT_index_material: Boolean;

GL_EXT_index_texture: Boolean;

GL_EXT_light_texture: Boolean;

GL_EXT_misc_attribute: Boolean;

GL_EXT_multi_draw_arrays: Boolean;

GL_EXT_multisample: Boolean;

GL_EXT_packed_pixels: Boolean;

GL_EXT_paletted_texture: Boolean;

GL_EXT_pixel_transform: Boolean;

GL_EXT_pixel_transform_color_table: Boolean;

GL_EXT_point_parameters: Boolean;

GL_EXT_polygon_offset: Boolean;

GL_EXT_rescale_normal: Boolean;

GL_EXT_secondary_color: Boolean;

GL_EXT_separate_specular_color: Boolean;

GL_EXT_shadow_funcs: Boolean;

GL_EXT_shared_texture_palette: Boolean;

GL_EXT_stencil_two_side: Boolean;

GL_EXT_stencil_wrap: Boolean;

GL_EXT_subtexture: Boolean;

GL_EXT_texture: Boolean;

GL_EXT_texture3D: Boolean;

GL_EXT_texture_compression_s3tc: Boolean;

GL_EXT_texture_cube_map: Boolean;

GL_EXT_texture_edge_clamp: Boolean;

GL_EXT_texture_env_add: Boolean;

GL_EXT_texture_env_combine: Boolean;

GL_EXT_texture_env_dot3: Boolean;

GL_EXT_texture_filter_anisotropic: Boolean;

GL_EXT_texture_lod_bias: Boolean;

GL_EXT_texture_object: Boolean;

GL_EXT_texture_perturb_normal: Boolean;

GL_EXT_texture_rectangle: Boolean;

GL_EXT_vertex_array: Boolean;

GL_EXT_vertex_shader: Boolean;

GL_EXT_vertex_weighting: Boolean;

GL_EXT_depth_bounds_test: Boolean;

GL_EXT_texture_mirror_clamp: Boolean;

GL_EXT_blend_equation_separate: Boolean;

GL_EXT_pixel_buffer_object: Boolean;

GL_EXT_texture_compression_dxt1: Boolean;

GL_EXT_stencil_clear_tag: Boolean;

GL_EXT_packed_depth_stencil: Boolean;

GL_EXT_texture_sRGB: Boolean;

GL_EXT_framebuffer_blit: Boolean;

GL_EXT_framebuffer_multisample: Boolean;

GL_EXT_timer_query: Boolean;

GL_EXT_gpu_program_parameters: Boolean;

GL_EXT_bindable_uniform: Boolean;

GL_EXT_draw_buffers2: Boolean;

GL_EXT_draw_instanced: Boolean;

GL_EXT_framebuffer_sRGB: Boolean;

GL_EXT_geometry_shader4: Boolean;

GL_EXT_gpu_shader4: Boolean;

GL_EXT_packed_float: Boolean;

GL_EXT_texture_array: Boolean;

GL_EXT_texture_buffer_object: Boolean;

GL_EXT_texture_compression_latc: Boolean;

GL_EXT_texture_compression_rgtc: Boolean;

GL_EXT_texture_integer: Boolean;

GL_EXT_texture_shared_exponent: Boolean;

GL_EXT_transform_feedback: Boolean;

GL_EXT_direct_state_access: Boolean;

GL_EXT_vertex_array_bgra: Boolean;

GL_EXT_texture_swizzle: Boolean;

GL_EXT_provoking_vertex: Boolean;

GL_EXT_texture_snorm: Boolean;

GL_EXT_separate_shader_objects: Boolean;

GL_EXT_shader_image_load_store: Boolean;

GL_EXT_vertex_attrib_64bit: Boolean;

GL_EXT_texture_sRGB_decode: Boolean;

GL_FfdMaskSGIX: Boolean;

GL_HP_convolution_border_modes: Boolean;

GL_HP_image_transform: Boolean;

GL_HP_occlusion_test: Boolean;

GL_HP_texture_lighting: Boolean;

GL_IBM_cull_vertex: Boolean;

GL_IBM_multimode_draw_arrays: Boolean;

GL_IBM_rasterpos_clip: Boolean;

GL_IBM_texture_mirrored_repeat: Boolean;

GL_IBM_vertex_array_lists: Boolean;

GL_INGR_blend_func_separate: Boolean;

GL_INGR_color_clamp: Boolean;

GL_INGR_interlace_read: Boolean;

GL_INGR_palette_buffer: Boolean;

GL_INTEL_framebuffer_CMAA: Boolean;

GL_INTEL_parallel_arrays: Boolean;

GL_INTEL_texture_scissor: Boolean;

GL_MESA_resize_buffers: Boolean;

GL_MESA_window_pos: Boolean;

GL_NV_blend_square: Boolean;

GL_NV_copy_depth_to_color: Boolean;

GL_NV_depth_clamp: Boolean;

GL_NV_evaluators: Boolean;

GL_NV_fence: Boolean;

GL_NV_float_buffer: Boolean;

GL_NV_fog_distance: Boolean;

GL_NV_fragment_program: Boolean;

GL_NV_half_float: Boolean;

GL_NV_light_max_exponent: Boolean;

GL_NV_multisample_filter_hint: Boolean;

GL_NV_occlusion_query: Boolean;

GL_NV_packed_depth_stencil: Boolean;

GL_NV_pixel_data_range: Boolean;

GL_NV_point_sprite: Boolean;

GL_NV_primitive_restart: Boolean;

GL_NV_register_combiners: Boolean;

GL_NV_register_combiners2: Boolean;

GL_NV_texgen_emboss: Boolean;

GL_NV_texgen_reflection: Boolean;

GL_NV_texture_compression_vtc: Boolean;

GL_NV_texture_env_combine4: Boolean;

GL_NV_texture_expand_normal: Boolean;

GL_NV_texture_rectangle: Boolean;

GL_NV_texture_shader: Boolean;

GL_NV_texture_shader2: Boolean;

GL_NV_texture_shader3: Boolean;

GL_NV_vertex_array_range: Boolean;

GL_NV_vertex_array_range2: Boolean;

GL_NV_vertex_program: Boolean;

GL_NV_vertex_program1_1: Boolean;

GL_NV_vertex_program2: Boolean;

GL_NV_fragment_program_option: Boolean;

GL_NV_fragment_program2: Boolean;

GL_NV_vertex_program2_option: Boolean;

GL_NV_vertex_program3: Boolean;

GL_NV_depth_buffer_float: Boolean;

GL_NV_fragment_program4: Boolean;

GL_NV_framebuffer_multisample_coverage: Boolean;

GL_NV_geometry_program4: Boolean;

GL_NV_gpu_program4: Boolean;

GL_NV_parameter_buffer_object: Boolean;

GL_NV_transform_feedback: Boolean;

GL_NV_vertex_program4: Boolean;

GL_NV_conditional_render: Boolean;

GL_NV_conservative_raster: Boolean;

GL_NV_conservative_raster_dilate: Boolean;

GL_NV_present_video: Boolean;

GL_NV_explicit_multisample: Boolean;

GL_NV_transform_feedback2: Boolean;

GL_NV_video_capture: Boolean;

GL_NV_copy_image: Boolean;

GL_NV_parameter_buffer_object2: Boolean;

GL_NV_shader_buffer_load: Boolean;

GL_NV_vertex_buffer_unified_memory: Boolean;

GL_NV_gpu_program5: Boolean;

GL_NV_gpu_shader5: Boolean;

GL_NV_shader_buffer_store: Boolean;

GL_NV_tessellation_program5: Boolean;

GL_NV_vertex_attrib_integer_64bit: Boolean;

GL_NV_multisample_coverage: Boolean;

GL_NV_vdpau_interop: Boolean;

GL_NV_texture_barrier: Boolean;

GL_OML_interlace: Boolean;

GL_OML_resample: Boolean;

GL_OML_subsample: Boolean;

GL_OVR_multiview: Boolean;

GL_OVR_multiview2: Boolean;

GL_PGI_misc_hints: Boolean;

GL_PGI_vertex_hints: Boolean;

GL_REND_screen_coordinates: Boolean;

GL_S3_s3tc: Boolean;

GL_SGIS_detail_texture: Boolean;

GL_SGIS_fog_function: Boolean;

GL_SGIS_generate_mipmap: Boolean;

GL_SGIS_multisample: Boolean;

GL_SGIS_pixel_texture: Boolean;

GL_SGIS_point_line_texgen: Boolean;

GL_SGIS_point_parameters: Boolean;

GL_SGIS_sharpen_texture: Boolean;

GL_SGIS_texture4D: Boolean;

GL_SGIS_texture_border_clamp: Boolean;

GL_SGIS_texture_color_mask: Boolean;

GL_SGIS_texture_edge_clamp: Boolean;

GL_SGIS_texture_filter4: Boolean;

GL_SGIS_texture_lod: Boolean;

GL_SGIS_texture_select: Boolean;

GL_SGIX_async: Boolean;

GL_SGIX_async_histogram: Boolean;

GL_SGIX_async_pixel: Boolean;

GL_SGIX_blend_alpha_minmax: Boolean;

GL_SGIX_calligraphic_fragment: Boolean;

GL_SGIX_clipmap: Boolean;

GL_SGIX_convolution_accuracy: Boolean;

GL_SGIX_depth_pass_instrument: Boolean;

GL_SGIX_depth_texture: Boolean;

GL_SGIX_flush_raster: Boolean;

GL_SGIX_fog_offset: Boolean;

GL_SGIX_fog_scale: Boolean;

GL_SGIX_fragment_lighting: Boolean;

GL_SGIX_framezoom: Boolean;

GL_SGIX_igloo_interface: Boolean;

GL_SGIX_impact_pixel_texture: Boolean;

GL_SGIX_instruments: Boolean;

GL_SGIX_interlace: Boolean;

GL_SGIX_ir_instrument1: Boolean;

GL_SGIX_list_priority: Boolean;

GL_SGIX_pixel_texture: Boolean;

GL_SGIX_pixel_tiles: Boolean;

GL_SGIX_polynomial_ffd: Boolean;

GL_SGIX_reference_plane: Boolean;

GL_SGIX_resample: Boolean;

GL_SGIX_scalebias_hint: Boolean;

GL_SGIX_shadow: Boolean;

GL_SGIX_shadow_ambient: Boolean;

GL_SGIX_sprite: Boolean;

GL_SGIX_subsample: Boolean;

GL_SGIX_tag_sample_buffer: Boolean;

GL_SGIX_texture_add_env: Boolean;

GL_SGIX_texture_coordinate_clamp: Boolean;

GL_SGIX_texture_lod_bias: Boolean;

GL_SGIX_texture_multi_buffer: Boolean;

GL_SGIX_texture_scale_bias: Boolean;

GL_SGIX_texture_select: Boolean;

GL_SGIX_vertex_preclip: Boolean;

GL_SGIX_ycrcb: Boolean;

GL_SGIX_ycrcb_subsample: Boolean;

GL_SGIX_ycrcba: Boolean;

GL_SGI_color_matrix: Boolean;

GL_SGI_color_table: Boolean;

GL_SGI_depth_pass_instrument: Boolean;

GL_SGI_texture_color_table: Boolean;

GL_SUNX_constant_data: Boolean;

GL_SUN_convolution_border_modes: Boolean;

GL_SUN_global_alpha: Boolean;

GL_SUN_mesh_array: Boolean;

GL_SUN_slice_accum: Boolean;

GL_SUN_triangle_list: Boolean;

GL_SUN_vertex: Boolean;

GL_WIN_phong_shading: Boolean;

GL_WIN_specular_fog: Boolean;

WGL_3DFX_multisample: Boolean;

WGL_ARB_buffer_region: Boolean;

WGL_ARB_extensions_string: Boolean;

WGL_ARB_make_current_read: Boolean;

WGL_ARB_multisample: Boolean;

WGL_ARB_pbuffer: Boolean;

WGL_ARB_pixel_format: Boolean;

WGL_ARB_pixel_format_float: Boolean;

WGL_ARB_render_texture: Boolean;

WGL_ARB_create_context: Boolean;

WGL_ARB_create_context_profile: Boolean;

WGL_ARB_framebuffer_sRGB: Boolean;

WGL_ARB_create_context_robustness: Boolean;

WGL_ATI_pixel_format_float: Boolean;

WGL_AMD_gpu_association: Boolean;

WGL_EXT_depth_float: Boolean;

WGL_EXT_display_color_table: Boolean;

WGL_EXT_extensions_string: Boolean;

WGL_EXT_make_current_read: Boolean;

WGL_EXT_multisample: Boolean;

WGL_EXT_pbuffer: Boolean;

WGL_EXT_pixel_format: Boolean;

WGL_EXT_swap_control: Boolean;

WGL_EXT_create_context_es2_profile: Boolean;

WGL_I3D_digital_video_control: Boolean;

WGL_I3D_gamma: Boolean;

WGL_I3D_genlock: Boolean;

WGL_I3D_image_buffer: Boolean;

WGL_I3D_swap_frame_lock: Boolean;

WGL_I3D_swap_frame_usage: Boolean;

WGL_NV_float_buffer: Boolean;

WGL_NV_render_depth_texture: Boolean;

WGL_NV_render_texture_rectangle: Boolean;

WGL_NV_vertex_array_range: Boolean;

WGL_NV_present_video: Boolean;

WGL_NV_video_output: Boolean;

WGL_NV_swap_group: Boolean;

WGL_NV_gpu_affinity: Boolean;

WGL_NV_video_capture: Boolean;

WGL_NV_copy_image: Boolean;

WGL_NV_multisample_coverage: Boolean;

WGL_NV_DX_interop: Boolean;

WGL_OML_sync_control: Boolean;

WGL_3DL_stereo_control: Boolean;

WGL_ARB_context_flush_control: Boolean;

WIN_draw_range_elements: Boolean;

WIN_swap_hint: Boolean;

GLX_VERSION_1_4: Boolean;

GLX_ARB_multisample: Boolean;

GLX_ARB_fbconfig_float: Boolean;

GLX_ARB_get_proc_address: Boolean;

GLX_ARB_create_context: Boolean;

GLX_ARB_create_context_profile: Boolean;

GLX_ARB_vertex_buffer_object: Boolean;

GLX_ARB_framebuffer_sRGB: Boolean;

GLX_ARB_create_context_robustness: Boolean;

GLX_EXT_visual_info: Boolean;

GLX_EXT_visual_rating: Boolean;

GLX_EXT_import_context: Boolean;

GLX_EXT_fbconfig_packed_float: Boolean;

GLX_EXT_framebuffer_sRGB: Boolean;

GLX_EXT_texture_from_pixmap: Boolean;

GLX_EXT_swap_control: Boolean;

GLX_ARB_context_flush_control: Boolean;

GLX_EXT_create_context_es2_profile: Boolean;

glBlendColor: procedure(red, green, blue, alpha: TGLclampf); stdcall;

glBlendEquation: procedure(mode: Cardinal); stdcall;

glDrawRangeElements: procedure(mode: Cardinal; Astart, Aend: TGLuint; count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

glTexImage3D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

glTexSubImage3D: procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

glCopyTexSubImage3D: procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

glColorTable: procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; table: Pointer); stdcall;

glColorTableParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glColorTableParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glCopyColorTable: procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

glGetColorTable: procedure(target, format, Atype: Cardinal; table: Pointer); stdcall;

glGetColorTableParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetColorTableParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glColorSubTable: procedure(target: Cardinal; start, count: TGLsizei; format, Atype: Cardinal; data: Pointer); stdcall;

glCopyColorSubTable: procedure(target: Cardinal; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;

glConvolutionFilter1D: procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

glConvolutionFilter2D: procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

glConvolutionParameterf: procedure(target, pname: Cardinal; param: Single); stdcall;

glConvolutionParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glConvolutionParameteri: procedure(target, pname: Cardinal; param: TGLint); stdcall;

glConvolutionParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glCopyConvolutionFilter1D: procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

glCopyConvolutionFilter2D: procedure(target, internalformat: Cardinal; x, y: TGLint; width, height: TGLsizei); stdcall;

glGetConvolutionFilter: procedure(target, internalformat, Atype: Cardinal; image: Pointer); stdcall;

glGetConvolutionParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetConvolutionParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glGetSeparableFilter: procedure(target, format, Atype: Cardinal; row, column, span: Pointer); stdcall;

glSeparableFilter2D: procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; row, column: Pointer); stdcall;

glGetHistogram: procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

glGetHistogramParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetHistogramParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glGetMinmax: procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

glGetMinmaxParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetMinmaxParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glHistogram: procedure(target: Cardinal; width: TGLsizei; internalformat: Cardinal; sink: TGLboolean); stdcall;

glMinmax: procedure(target, internalformat: Cardinal; sink: TGLboolean); stdcall;

glResetHistogram: procedure(target: Cardinal); stdcall;

glResetMinmax: procedure(target: Cardinal); stdcall;

glActiveTexture: procedure(texture: Cardinal); stdcall;

glSampleCoverage: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

glCompressedTexImage3D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexImage2D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexImage1D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage3D: procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage2D: procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage1D: procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glGetCompressedTexImage: procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

glClientActiveTexture: procedure(texture: Cardinal); stdcall;

glMultiTexCoord1d: procedure(target: Cardinal; s: TGLdouble); stdcall;

glMultiTexCoord1dV: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord1f: procedure(target: Cardinal; s: Single); stdcall;

glMultiTexCoord1fV: procedure(target: Cardinal; v: Single); stdcall;

glMultiTexCoord1i: procedure(target: Cardinal; s: TGLint); stdcall;

glMultiTexCoord1iV: procedure(target: Cardinal; v: PGLInt); stdcall;

glMultiTexCoord1s: procedure(target: Cardinal; s: TGLshort); stdcall;

glMultiTexCoord1sV: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord2d: procedure(target: Cardinal; s, t: TGLdouble); stdcall;

glMultiTexCoord2dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord2f: procedure(target: Cardinal; s, t: Single); stdcall;

glMultiTexCoord2fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord2i: procedure(target: Cardinal; s, t: TGLint); stdcall;

glMultiTexCoord2iv: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord2s: procedure(target: Cardinal; s, t: TGLshort); stdcall;

glMultiTexCoord2sv: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord3d: procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

glMultiTexCoord3dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord3f: procedure(target: Cardinal; s, t, r: Single); stdcall;

glMultiTexCoord3fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord3i: procedure(target: Cardinal; s, t, r: TGLint); stdcall;

glMultiTexCoord3iv: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord3s: procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

glMultiTexCoord3sv: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord4d: procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

glMultiTexCoord4dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord4f: procedure(target: Cardinal; s, t, r, q: Single); stdcall;

glMultiTexCoord4fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord4i: procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

glMultiTexCoord4iv: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord4s: procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

glMultiTexCoord4sv: procedure(target: Cardinal; v: PGLshort); stdcall;

glLoadTransposeMatrixf: procedure(m: PGLfloat); stdcall;

glLoadTransposeMatrixd: procedure(m: PGLdouble); stdcall;

glMultTransposeMatrixf: procedure(m: PGLfloat); stdcall;

glMultTransposeMatrixd: procedure(m: PGLdouble); stdcall;

glBlendFuncSeparate: procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

glMultiDrawArrays: procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

glMultiDrawElements: procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

glPointParameterf: procedure(pname: Cardinal; param: Single); stdcall;

glPointParameterfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

glPointParameteri: procedure(pname: Cardinal; param: TGLint); stdcall;

glPointParameteriv: procedure(pname: Cardinal; params: PGLint); stdcall;

glFogCoordf: procedure(coord: Single); stdcall;

glFogCoordfv: procedure(coord: PGLfloat); stdcall;

glFogCoordd: procedure(coord: TGLdouble); stdcall;

glFogCoorddv: procedure(coord: PGLdouble); stdcall;

glFogCoordPointer: procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

glSecondaryColor3b: procedure(red, green, blue: TGLbyte); stdcall;

glSecondaryColor3bv: procedure(v: PGLbyte); stdcall;

glSecondaryColor3d: procedure(red, green, blue: TGLdouble); stdcall;

glSecondaryColor3dv: procedure(v: PGLdouble); stdcall;

glSecondaryColor3f: procedure(red, green, blue: Single); stdcall;

glSecondaryColor3fv: procedure(v: PGLfloat); stdcall;

glSecondaryColor3i: procedure(red, green, blue: TGLint); stdcall;

glSecondaryColor3iv: procedure(v: PGLint); stdcall;

glSecondaryColor3s: procedure(red, green, blue: TGLshort); stdcall;

glSecondaryColor3sv: procedure(v: PGLshort); stdcall;

glSecondaryColor3ub: procedure(red, green, blue: TGLubyte); stdcall;

glSecondaryColor3ubv: procedure(v: PGLubyte); stdcall;

glSecondaryColor3ui: procedure(red, green, blue: TGLuint); stdcall;

glSecondaryColor3uiv: procedure(v: PGLuint); stdcall;

glSecondaryColor3us: procedure(red, green, blue: TGLushort); stdcall;

glSecondaryColor3usv: procedure(v: PGLushort); stdcall;

glSecondaryColorPointer: procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

glWindowPos2d: procedure(x,y : TGLdouble); stdcall;

glWindowPos2dv: procedure(v : PGLdouble); stdcall;

glWindowPos2f: procedure(x,y : Single); stdcall;

glWindowPos2fv: procedure(v : PGLfloat); stdcall;

glWindowPos2i: procedure(x,y : TGLint); stdcall;

glWindowPos2iv: procedure(v : PGLint); stdcall;

glWindowPos2s: procedure(x,y : TGLshort); stdcall;

glWindowPos2sv: procedure(v : PGLshort); stdcall;

glWindowPos3d: procedure(x,y,z : TGLdouble); stdcall;

glWindowPos3dv: procedure(v : PGLdouble); stdcall;

glWindowPos3f: procedure(x,y,z : Single); stdcall;

glWindowPos3fv: procedure(v : PGLfloat); stdcall;

glWindowPos3i: procedure(x,y,z : TGLint); stdcall;

glWindowPos3iv: procedure(v : PGLint); stdcall;

glWindowPos3s: procedure(x,y,z : TGLshort); stdcall;

glWindowPos3sv: procedure(v : PGLshort); stdcall;

glGenQueries: procedure(n: TGLsizei; ids: PGLuint); stdcall;

glDeleteQueries: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

glIsQuery: function(id: TGLuint): TGLboolean; stdcall;

glBeginQuery: procedure(target: Cardinal; id: TGLuint); stdcall;

glEndQuery: procedure(target: Cardinal); stdcall;

glGetQueryiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGetQueryObjectiv: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetQueryObjectuiv: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glBindBuffer: procedure(target: GLenum; buffer: GLuint); stdcall;

glDeleteBuffers: procedure(n: GLsizei; const buffers: PGLuint); stdcall;

glGenBuffers: procedure(n: GLsizei; buffers: PGLuint); stdcall;

glIsBuffer: function(buffer: GLuint): GLboolean; stdcall;

glBufferData: procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

glBufferSubData: procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

glGetBufferSubData: procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

glMapBuffer: function(target: GLenum; access: GLenum): Pointer; stdcall;

glUnmapBuffer: function(target: GLenum): GLboolean; stdcall;

glGetBufferParameteriv: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

glGetBufferPointerv: procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

glBlendEquationSeparate: procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

glDrawBuffers: procedure(n: GLSizei; const bufs: PGLenum); stdcall;

glStencilOpSeparate: procedure(face, sfail, dpfail, dppass: Cardinal); stdcall;

glStencilFuncSeparate: procedure(face, func: Cardinal; ref: TGLint; mask: TGLuint); stdcall;

glStencilMaskSeparate: procedure(face: Cardinal; mask: TGLuint); stdcall;

glAttachShader: procedure(_program: TGLuint; shader: TGLuint); stdcall;

glBindAttribLocation: procedure(_program: TGLuint; index: TGLuint; const name: PGLChar);

glCompileShader: procedure(shader: TGLuint); stdcall;

glCreateProgram: function(): TGLuint; stdcall;

glCreateShader: function(_type: Cardinal): TGLuint; stdcall;

glDeleteProgram: procedure(_program: TGLuint); stdcall;

glDeleteShader: procedure(shader: TGLuint); stdcall;

glDetachShader: procedure(_program: TGLuint; shader: TGLuint); stdcall;

glDisableVertexAttribArray: procedure(index: TGLuint); stdcall;

glEnableVertexAttribArray: procedure(index: TGLuint); stdcall;

glGetActiveAttrib: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

glGetActiveUniform: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

glGetAttachedShaders: procedure(_program: TGLuint; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;

glGetAttribLocation: function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

glGetProgramiv: procedure(_program: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetProgramInfoLog: procedure(_program: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

glGetShaderiv: procedure(shader: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetShaderInfoLog: procedure(shader: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

glGetShaderSource: procedure(shader:TGLuint; bufSize: TGLsizei; length: PGLsizei; source: PGLChar); stdcall;

glGetUniformLocation: function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

glGetUniformfv: procedure(_program: TGLuint; location: TGLint; params: PGLfloat); stdcall;

glGetUniformiv: procedure(_program: TGLuint; location: TGLint; params: PGLint); stdcall;

glGetVertexAttribdv: procedure(index:TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

glGetVertexAttribfv: procedure(index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glGetVertexAttribiv: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribPointerv: procedure(index: TGLuint; pname: Cardinal; _pointer:pointer); stdcall;

glIsProgram: function(_program: TGLuint):TGLboolean; stdcall;

glIsShader: function(shader: TGLuint): TGLboolean; stdcall;

glLinkProgram: procedure(_program: TGLuint); stdcall;

glShaderSource: procedure(shader: TGLuint; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

glUseProgram: procedure(_program: TGLuint); stdcall;

glUniform1f: procedure(location: GLint; v0: Single); stdcall;

glUniform2f: procedure(location: GLint; v0: Single; v1: Single); stdcall;

glUniform3f: procedure(location: GLint; v0: Single; v1: Single; v2: Single); stdcall;

glUniform4f: procedure(location: GLint; v0: Single; v1: Single; v2: Single; v3: Single); stdcall;

glUniform1i: procedure(location: GLint; v0: GLint); stdcall;

glUniform2i: procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

glUniform3i: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

glUniform4i: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

glUniform1fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform2fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform3fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform4fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform1iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform2iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform3iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform4iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniformMatrix2fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glUniformMatrix3fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glUniformMatrix4fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glValidateProgram: procedure(_program: TGLuint); stdcall;

glVertexAttrib1d: procedure(index:TGLuint; x: TGLdouble); stdcall;

glVertexAttrib1dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

glVertexAttrib1f: procedure(index:TGLuint; x: Single); stdcall;

glVertexAttrib1fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

glVertexAttrib1s: procedure(index:TGLuint; x: TGLshort); stdcall;

glVertexAttrib1sv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib2d: procedure(index:TGLuint; x,y: TGLdouble); stdcall;

glVertexAttrib2dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

glVertexAttrib2f: procedure(index:TGLuint; x,y: Single); stdcall;

glVertexAttrib2fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

glVertexAttrib2s: procedure(index:TGLuint; x,y: TGLshort); stdcall;

glVertexAttrib2sv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib3d: procedure(index:TGLuint; x,y,z: TGLdouble); stdcall;

glVertexAttrib3dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

glVertexAttrib3f: procedure(index:TGLuint; x,y,z: Single); stdcall;

glVertexAttrib3fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

glVertexAttrib3s: procedure(index:TGLuint; x,y,z: TGLshort); stdcall;

glVertexAttrib3sv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib4Nbv: procedure(index:TGLuint; v: PGLbyte); stdcall;

glVertexAttrib4Niv: procedure(index:TGLuint; v: PGLint); stdcall;

glVertexAttrib4Nsv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib4Nub: procedure(index:TGLuint; x,y,z,w: TGLubyte); stdcall;

glVertexAttrib4Nubv: procedure(index:TGLuint; v: PGLubyte); stdcall;

glVertexAttrib4Nuiv: procedure(index:TGLuint; v: PGLuint); stdcall;

glVertexAttrib4Nusv: procedure(index:TGLuint; v: PGLushort); stdcall;

glVertexAttrib4bv: procedure(index:TGLuint; v: PGLbyte); stdcall;

glVertexAttrib4d: procedure(index:TGLuint; x,y,z,w: TGLdouble); stdcall;

glVertexAttrib4dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

glVertexAttrib4f: procedure(index:TGLuint; x,y,z,w: Single); stdcall;

glVertexAttrib4fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

glVertexAttrib4iv: procedure(index:TGLuint; v: PGLint); stdcall;

glVertexAttrib4s: procedure(index:TGLuint; x,y,z,w: TGLshort); stdcall;

glVertexAttrib4sv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib4ubv: procedure(index:TGLuint; v: PGLubyte); stdcall;

glVertexAttrib4uiv: procedure(index:TGLuint; v: PGLuint); stdcall;

glVertexAttrib4usv: procedure(index:TGLuint; v: PGLushort); stdcall;

glVertexAttribPointer: procedure(index:TGLuint; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;

glUniformMatrix2x3fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix3x2fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix2x4fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix4x2fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix3x4fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix4x3fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glVertexAttribI1i: procedure(index: TGLuint; x: TGLint); stdcall;

glVertexAttribI2i: procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

glVertexAttribI3i: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

glVertexAttribI4i: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

glVertexAttribI1ui: procedure(index: TGLuint; x: TGLuint); stdcall;

glVertexAttribI2ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

glVertexAttribI3ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

glVertexAttribI4ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

glVertexAttribI1iv: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI2iv: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI3iv: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI4iv: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI1uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI2uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI3uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI4uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI4bv: procedure(index: TGLuint; v:PGLbyte); stdcall;

glVertexAttribI4sv: procedure(index: TGLuint; v:PGLshort); stdcall;

glVertexAttribI4ubv: procedure(index: TGLuint; v: PGLUbyte); stdcall;

glVertexAttribI4usv: procedure(index: TGLuint; v: PGLushort); stdcall;

glVertexAttribIPointer: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

glGetVertexAttribIiv: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribIuiv: procedure(index: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glUniform1ui: procedure(location: TGLInt; v0: TGLuint); stdcall;

glUniform2ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

glUniform3ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

glUniform4ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

glUniform1uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform2uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform3uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform4uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glGetUniformuiv: procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

glBindFragDataLocation: procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

glGetFragDataLocation: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

glBeginConditionalRender: procedure(id: TGLuint; mode: Cardinal); stdcall;

glEndConditionalRender: procedure(); stdcall;

glClampColor: procedure(target: Cardinal; clamp: Cardinal); stdcall;

glTexParameterIiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glTexParameterIuiv: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

glGetTexParameterIiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGetTexParameterIuiv: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

glColorMaski: procedure(index: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

glGetBooleani_v: procedure(target: Cardinal; index: TGLuint; data: PGLboolean); stdcall;

glGetIntegeri_v: procedure(target: Cardinal; index: TGLuint; data: PGLint); stdcall;

glEnablei: procedure(target: Cardinal; index: TGLuint); stdcall;

glDisablei: procedure(target: Cardinal; index: TGLuint); stdcall;

glIsEnabledi: function(target: Cardinal; index: TGLuint): TGLboolean; stdcall;

glBindBufferRange: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

glBindBufferBase: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

glBeginTransformFeedback: procedure(primitiveMode: Cardinal); stdcall;

glEndTransformFeedback: procedure(); stdcall;

glTransformFeedbackVaryings: procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

glGetTransformFeedbackVarying: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

glClearBufferiv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLint); stdcall;

glClearBufferuiv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLuint); stdcall;

glClearBufferfv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLfloat); stdcall;

glClearBufferfi: procedure(buffer: Cardinal; drawbuffer: TGLint; depth: Single; stencil: TGLint); stdcall;

glGetStringi: function(name: Cardinal; index: TGLuint): PGLChar; stdcall;

glDrawArraysInstanced: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

glDrawElementsInstanced: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

glTexBuffer: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

glPrimitiveRestartIndex: procedure(index: TGLuint); stdcall;

glGetInteger64i_v: procedure(target: Cardinal; index: TGLuint; data: PGLint64); stdcall;

glGetBufferParameteri64v: procedure(target: Cardinal; pname: Cardinal; params: PGLint64); stdcall;

glProgramParameteri: procedure(_program: TGLuint; pname: Cardinal; value: TGLint); stdcall;

glFramebufferTexture: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint); stdcall;

gluNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

gluNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;

gluDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

wglCreateBufferRegionARB: function(DC: HDC; iLayerPlane: Integer; uType: Cardinal) : Integer; stdcall;

wglDeleteBufferRegionARB: procedure(hRegion: Integer); stdcall;

wglSaveBufferRegionARB: function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;

wglRestoreBufferRegionARB: function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;

wglGetExtensionsStringARB: function(DC: HDC): PGLChar; stdcall;

wglGetPixelFormatAttribivARB: function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;

wglGetPixelFormatAttribfvARB: function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;

wglChoosePixelFormatARB: function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: GLuint; piFormats: PGLint; nNumFormats: PGLenum) : BOOL; stdcall;

wglMakeContextCurrentARB: function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;

wglGetCurrentReadDCARB: function(): HDC; stdcall;

wglCreatePbufferARB: function(DC: HDC; iPixelFormat: GLInt; iWidth, iHeight : GLInt; const piAttribList: PGLint) : HPBUFFERARB; stdcall;

wglGetPbufferDCARB: function(hPbuffer: HPBUFFERARB) : HDC; stdcall;

wglReleasePbufferDCARB: function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;

wglDestroyPbufferARB: function(hPbuffer: HPBUFFERARB): BOOL; stdcall;

wglQueryPbufferARB: function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;

wglBindTexImageARB: function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

wglReleaseTexImageARB: function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

wglSetPbufferAttribARB: function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;

wglCreateContextAttribsARB: function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;

wglEnumGpusNV: function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean;

wglEnumGpuDevicesNV: function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean;

wglCreateAffinityDCNV: function(hGpuList: PHGPUNV): HDC;

wglEnumGpusFromAffinityDCNV: function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean;

wglDeleteDCNV: function(hdc: HDC): Boolean;

wglSwapIntervalEXT: function(interval : Integer) : BOOL; stdcall;

wglGetSwapIntervalEXT: function: Integer; stdcall;

glSamplePassARB: procedure(pass: Cardinal); stdcall;

glActiveTextureARB: procedure(target: Cardinal); stdcall;

glClientActiveTextureARB: procedure(target: Cardinal); stdcall;

glMultiTexCoord1dARB: procedure(target: Cardinal; s: TGLdouble); stdcall;

glMultiTexCoord1dVARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord1fARB: procedure(target: Cardinal; s: Single); stdcall;

glMultiTexCoord1fVARB: procedure(target: Cardinal; v: Single); stdcall;

glMultiTexCoord1iARB: procedure(target: Cardinal; s: TGLint); stdcall;

glMultiTexCoord1iVARB: procedure(target: Cardinal; v: PGLInt); stdcall;

glMultiTexCoord1sARB: procedure(target: Cardinal; s: TGLshort); stdcall;

glMultiTexCoord1sVARB: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord2dARB: procedure(target: Cardinal; s, t: TGLdouble); stdcall;

glMultiTexCoord2dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord2fARB: procedure(target: Cardinal; s, t: Single); stdcall;

glMultiTexCoord2fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord2iARB: procedure(target: Cardinal; s, t: TGLint); stdcall;

glMultiTexCoord2ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord2sARB: procedure(target: Cardinal; s, t: TGLshort); stdcall;

glMultiTexCoord2svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord3dARB: procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

glMultiTexCoord3dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord3fARB: procedure(target: Cardinal; s, t, r: Single); stdcall;

glMultiTexCoord3fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord3iARB: procedure(target: Cardinal; s, t, r: TGLint); stdcall;

glMultiTexCoord3ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord3sARB: procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

glMultiTexCoord3svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord4dARB: procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

glMultiTexCoord4dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord4fARB: procedure(target: Cardinal; s, t, r, q: Single); stdcall;

glMultiTexCoord4fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord4iARB: procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

glMultiTexCoord4ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord4sARB: procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

glMultiTexCoord4svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

glLoadTransposeMatrixfARB: procedure(m: PGLfloat); stdcall;

glLoadTransposeMatrixdARB: procedure(m: PGLdouble); stdcall;

glMultTransposeMatrixfARB: procedure(m: PGLfloat); stdcall;

glMultTransposeMatrixdARB: procedure(m: PGLdouble); stdcall;

glSampleCoverageARB: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

glCompressedTexImage3DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexImage2DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexImage1DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage3DARB: procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage2DARB: procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage1DARB: procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glGetCompressedTexImageARB: procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

glPointParameterfARB: procedure(pname: Cardinal; param: Single); stdcall;

glPointParameterfvARB: procedure(pname: Cardinal; params: PGLfloat); stdcall;

glWeightbvARB: procedure(size: TGLint; weights: PGLbyte); stdcall;

glWeightsvARB: procedure(size: TGLint; weights: PGLshort); stdcall;

glWeightivARB: procedure(size: TGLint; weights: PGLint); stdcall;

glWeightfvARB: procedure(size: TGLint; weights: PGLfloat); stdcall;

glWeightdvARB: procedure(size: TGLint; weights: PGLdouble); stdcall;

glWeightubvARB: procedure(size: TGLint; weights: PGLubyte); stdcall;

glWeightusvARB: procedure(size: TGLint; weights: PGLushort); stdcall;

glWeightuivARB: procedure(size: TGLint; weights: PGLuint); stdcall;

glWeightPointerARB: procedure(size: TGLint; _type: Cardinal; stride:TGLsizei; _pointer:pointer); stdcall;

glVertexBlendARB: procedure(count: TGLint); stdcall;

glCurrentPaletteMatrixARB: procedure(index: TGLint); stdcall;

glMatrixIndexubvARB: procedure(size: TGLint; indices: PGLubyte); stdcall;

glMatrixIndexusvARB: procedure(size: TGLint; indices: PGLushort); stdcall;

glMatrixIndexuivARB: procedure(size: TGLint; indices: PGLuint); stdcall;

glMatrixIndexPointerARB: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer:pointer); stdcall;

glWindowPos2dARB: procedure(x,y : TGLdouble); stdcall;

glWindowPos2dvARB: procedure(v : PGLdouble); stdcall;

glWindowPos2fARB: procedure(x,y : Single); stdcall;

glWindowPos2fvARB: procedure(v : PGLfloat); stdcall;

glWindowPos2iARB: procedure(x,y : TGLint); stdcall;

glWindowPos2ivARB: procedure(v : PGLint); stdcall;

glWindowPos2sARB: procedure(x,y : TGLshort); stdcall;

glWindowPos2svARB: procedure(v : PGLshort); stdcall;

glWindowPos3dARB: procedure(x,y,z : TGLdouble); stdcall;

glWindowPos3dvARB: procedure(v : PGLdouble); stdcall;

glWindowPos3fARB: procedure(x,y,z : Single); stdcall;

glWindowPos3fvARB: procedure(v : PGLfloat); stdcall;

glWindowPos3iARB: procedure(x,y,z : TGLint); stdcall;

glWindowPos3ivARB: procedure(v : PGLint); stdcall;

glWindowPos3sARB: procedure(x,y,z : TGLshort); stdcall;

glWindowPos3svARB: procedure(v : PGLshort); stdcall;

glVertexAttrib1dARB: procedure(index: GLuint; x: GLdouble); stdcall;

glVertexAttrib1dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

glVertexAttrib1fARB: procedure(index: GLuint; x: Single); stdcall;

glVertexAttrib1fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

glVertexAttrib1sARB: procedure(index: GLuint; x: GLshort); stdcall;

glVertexAttrib1svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib2dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble); stdcall;

glVertexAttrib2dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

glVertexAttrib2fARB: procedure(index: GLuint; x: Single; y: Single); stdcall;

glVertexAttrib2fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

glVertexAttrib2sARB: procedure(index: GLuint; x: GLshort; y: GLshort); stdcall;

glVertexAttrib2svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib3dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

glVertexAttrib3dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

glVertexAttrib3fARB: procedure(index: GLuint; x: Single; y: Single; z: Single); stdcall;

glVertexAttrib3fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

glVertexAttrib3sARB: procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort); stdcall;

glVertexAttrib3svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib4NbvARB: procedure(index: GLuint; const v: PGLbyte); stdcall;

glVertexAttrib4NivARB: procedure(index: GLuint; const v: PGLint); stdcall;

glVertexAttrib4NsvARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib4NubARB: procedure(index: GLuint; x: GLubyte; y: GLubyte; z: GLubyte; w: GLubyte); stdcall;

glVertexAttrib4NubvARB: procedure(index: GLuint; const v: PGLubyte); stdcall;

glVertexAttrib4NuivARB: procedure(index: GLuint; const v: PGLuint); stdcall;

glVertexAttrib4NusvARB: procedure(index: GLuint; const v: PGLushort); stdcall;

glVertexAttrib4bvARB: procedure(index: GLuint; const v: PGLbyte); stdcall;

glVertexAttrib4dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

glVertexAttrib4dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

glVertexAttrib4fARB: procedure(index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

glVertexAttrib4fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

glVertexAttrib4ivARB: procedure(index: GLuint; const v: PGLint); stdcall;

glVertexAttrib4sARB: procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort; w: GLshort); stdcall;

glVertexAttrib4svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib4ubvARB: procedure(index: GLuint; const v: PGLubyte); stdcall;

glVertexAttrib4uivARB: procedure(index: GLuint; const v: PGLuint); stdcall;

glVertexAttrib4usvARB: procedure(index: GLuint; const v: PGLushort); stdcall;

glVertexAttribPointerARB: procedure(index: GLuint; size: GLint; _type: GLenum; normalized: GLboolean; stride: GLsizei; const _pointer: pointer); stdcall;

glEnableVertexAttribArrayARB: procedure(index: GLuint); stdcall;

glDisableVertexAttribArrayARB: procedure(index: GLuint); stdcall;

glProgramStringARB: procedure(target: GLenum; format: GLenum; len: GLsizei; const _string: pointer); stdcall;

glBindProgramARB: procedure(target: GLenum; _program: GLuint); stdcall;

glDeleteProgramsARB: procedure(n: GLsizei; const programs: PGLuint); stdcall;

glGenProgramsARB: procedure(n: GLsizei; programs: PGLuint); stdcall;

glProgramEnvParameter4dARB: procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

glProgramEnvParameter4dvARB: procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

glProgramEnvParameter4fARB: procedure(target: GLenum; index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

glProgramEnvParameter4fvARB: procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

glProgramLocalParameter4dARB: procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

glProgramLocalParameter4dvARB: procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

glProgramLocalParameter4fARB: procedure(target: GLenum; index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

glProgramLocalParameter4fvARB: procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

glGetProgramEnvParameterdvARB: procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

glGetProgramEnvParameterfvARB: procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

glGetProgramLocalParameterdvARB: procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

glGetProgramLocalParameterfvARB: procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

glGetProgramivARB: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

glGetProgramStringARB: procedure(target: GLenum; pname: GLenum; _string: pointer); stdcall;

glGetVertexAttribdvARB: procedure(index: GLuint; pname: GLenum; params: PGLdouble); stdcall;

glGetVertexAttribfvARB: procedure(index: GLuint; pname: GLenum; params: PGLfloat); stdcall;

glGetVertexAttribivARB: procedure(index: GLuint; pname: GLenum; params: PGLint); stdcall;

glGetVertexAttribPointervARB: procedure(index: GLuint; pname: GLenum; _pointer: pointer); stdcall;

glIsProgramARB: function(_program: GLuint): GLboolean; stdcall;

glBindBufferARB: procedure(target: GLenum; buffer: GLuint); stdcall;

glDeleteBuffersARB: procedure(n: GLsizei; const buffers: PGLuint); stdcall;

glGenBuffersARB: procedure(n: GLsizei; buffers: PGLuint); stdcall;

glIsBufferARB: function(buffer: GLuint): GLboolean; stdcall;

glBufferDataARB: procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

glBufferSubDataARB: procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

glGetBufferSubDataARB: procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

glMapBufferARB: function(target: GLenum; access: GLenum): Pointer; stdcall;

glUnmapBufferARB: function(target: GLenum): GLboolean; stdcall;

glGetBufferParameterivARB: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

glGetBufferPointervARB: procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

glGenQueriesARB: procedure(n: TGLsizei; ids: PGLuint); stdcall;

glDeleteQueriesARB: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

glIsQueryARB: function(id: TGLuint): TGLboolean; stdcall;

glBeginQueryARB: procedure(target: Cardinal; id: TGLuint); stdcall;

glEndQueryARB: procedure(target: Cardinal); stdcall;

glGetQueryivARB: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGetQueryObjectivARB: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetQueryObjectuivARB: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glDeleteObjectARB: procedure(obj: GLhandleARB); stdcall;

glGetHandleARB: function(pname: GLenum): GLhandleARB; stdcall;

glDetachObjectARB: procedure(containerObj: GLhandleARB; attachedObj: GLhandleARB); stdcall;

glCreateShaderObjectARB: function(shaderType: GLenum): GLhandleARB; stdcall;

glShaderSourceARB: procedure(shaderObj: GLhandleARB; count: GLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

glCompileShaderARB: procedure(shaderObj: GLhandleARB); stdcall;

glCreateProgramObjectARB: function(): GLhandleARB; stdcall;

glAttachObjectARB: procedure(containerObj: GLhandleARB; obj: GLhandleARB); stdcall;

glLinkProgramARB: procedure(programObj: GLhandleARB); stdcall;

glUseProgramObjectARB: procedure(programObj: GLhandleARB); stdcall;

glValidateProgramARB: procedure(programObj: GLhandleARB); stdcall;

glUniform1fARB: procedure(location: GLint; v0: Single); stdcall;

glUniform2fARB: procedure(location: GLint; v0: Single; v1: Single); stdcall;

glUniform3fARB: procedure(location: GLint; v0: Single; v1: Single; v2: Single); stdcall;

glUniform4fARB: procedure(location: GLint; v0: Single; v1: Single; v2: Single; v3: Single); stdcall;

glUniform1iARB: procedure(location: GLint; v0: GLint); stdcall;

glUniform2iARB: procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

glUniform3iARB: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

glUniform4iARB: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

glUniform1fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform2fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform3fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform4fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform1ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform2ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform3ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform4ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniformMatrix2fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glUniformMatrix3fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glUniformMatrix4fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glGetObjectParameterfvARB: procedure(obj: GLhandleARB; pname: GLenum; params: PGLfloat); stdcall;

glGetObjectParameterivARB: procedure(obj: GLhandleARB; pname: GLenum; params: PGLint); stdcall;

glGetInfoLogARB: procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

glGetAttachedObjectsARB: procedure(containerObj: GLhandleARB; maxCount: GLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;

glGetUniformLocationARB: function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

glGetActiveUniformARB: procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

glGetUniformfvARB: procedure(programObj: GLhandleARB; location: GLint; params: PGLfloat); stdcall;

glGetUniformivARB: procedure(programObj: GLhandleARB; location: GLint; params: PGLint); stdcall;

glGetShaderSourceARB: procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; source: PGLChar); stdcall;

glBindAttribLocationARB: procedure(programObj: GLhandleARB; index: GLuint; const name: PGLChar); stdcall;

glGetActiveAttribARB: procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

glGetAttribLocationARB: function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

glDrawBuffersARB: procedure(n: GLSizei; const bufs: PGLenum); stdcall;

glClampColorARB: procedure(target: Cardinal; clamp: Cardinal); stdcall;

glDrawArraysInstancedARB: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

glDrawElementsInstancedARB: procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

glIsRenderbuffer: function(renderbuffer: TGLuint): TGLBoolean; stdcall;

glBindRenderbuffer: procedure(target: Cardinal; renderbuffer: TGLuint); stdcall;

glDeleteRenderbuffers: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

glGenRenderbuffers: procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;

glRenderbufferStorage: procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

glRenderbufferStorageMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

glGetRenderbufferParameteriv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glIsFramebuffer: function(framebuffer: TGLuint): TGLboolean; stdcall;

glBindFramebuffer: procedure(target: Cardinal; framebuffer: TGLuint); stdcall;

glDeleteFramebuffers: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

glGenFramebuffers: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

glCheckFramebufferStatus: function(target: Cardinal): Cardinal; stdcall;

glFramebufferTexture1D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

glFramebufferTexture2D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

glFramebufferTexture3D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

glFramebufferTextureLayer: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

glFramebufferRenderbuffer: procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: TGLuint); stdcall;

glGetFramebufferAttachmentParameteriv: procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glBlitFramebuffer: procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

glGenerateMipmap: procedure(target: Cardinal); stdcall;

glProgramParameteriARB: procedure( _program:TGLuint; pname:Cardinal; value: TGLint); stdcall;

glFramebufferTextureARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint); stdcall;

glFramebufferTextureLayerARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

glFramebufferTextureFaceARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; face:Cardinal); stdcall;

glVertexAttribDivisorARB: procedure(index: TGLuint; divisor: TGLuint); stdcall;

glMapBufferRange: function(target: Cardinal; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;

glFlushMappedBufferRange: procedure( target: Cardinal; offset: TGLint; length: TGLsizei ); stdcall;

glTexBufferARB: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

glBindVertexArray: procedure(_array: TGLuint); stdcall;

glDeleteVertexArrays: procedure(n: TGLsizei; arrays: PGLuint); stdcall;

glGenVertexArrays: procedure(n: TGLsizei; arrays: PGLuint); stdcall;

glIsVertexArray: function(_array: TGLuint): TGLboolean; stdcall;

glGetUniformIndices: procedure(_program: TGLuint; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;

glGetActiveUniformsiv: procedure(_program: TGLuint; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetActiveUniformName: procedure(_program: TGLuint; uniformIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformName: PGLchar); stdcall;

glGetUniformBlockIndex: function(_program: TGLuint; uniformBlockName: PGLchar): TGLuint; stdcall;

glGetActiveUniformBlockiv: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetActiveUniformBlockName: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PGLchar); stdcall;

glUniformBlockBinding: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; uniformBlockBinding: TGLuint); stdcall;

glCopyBufferSubData: procedure(readTarget: Cardinal; writeTarget: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

glDrawElementsBaseVertex: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

glDrawRangeElementsBaseVertex: procedure(mode: Cardinal; start: TGLuint; _end: TGLuint; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

glDrawElementsInstancedBaseVertex: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;

glMultiDrawElementsBaseVertex: procedure(mode: Cardinal; count: PGLsizei; _type: Cardinal; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;

glProvokingVertex: procedure(mode: Cardinal); stdcall;

glFenceSync: function(condition: Cardinal; flags: TGLbitfield): TGLsync; stdcall;

glIsSync: function(sync: TGLsync): TGLboolean; stdcall;

glDeleteSync: procedure(sync: TGLsync); stdcall;

glClientWaitSync: function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): Cardinal; stdcall;

glWaitSync: procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;

glGetInteger64v: procedure(pname: Cardinal; params: PGLint64); stdcall;

glGetSynciv: procedure(sync: TGLsync; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

glTexImage2DMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

glTexImage3DMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

glGetMultisamplefv: procedure(pname: Cardinal; index: TGLuint; val: PGLfloat); stdcall;

glSampleMaski: procedure(index: TGLuint; mask: TGLbitfield); stdcall;

glBlendEquationi: procedure(buf: TGLuint; mode: Cardinal); stdcall;

glBlendEquationSeparatei: procedure(buf: TGLuint; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

glBlendFunci: procedure(buf: TGLuint; src: Cardinal; dst: Cardinal); stdcall;

glBlendFuncSeparatei: procedure(buf: TGLuint; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;

glMinSampleShading: procedure(value: TGLclampf); stdcall;

glBindFragDataLocationIndexed: procedure(_program: TGLuint; colorNumber: TGLuint; index: TGLuint; const name: PGLchar); stdcall;

glGetFragDataIndex: function(_program: TGLuint; const name: PGLchar): TGLint; stdcall;

glGenSamplers: procedure(count: TGLsizei; samplers: PGLuint); stdcall;

glDeleteSamplers: procedure(count: TGLsizei; const samplers: PGLuint); stdcall;

glIsSampler: function(sampler: TGLuint): TGLboolean; stdcall;

glBindSampler: procedure(_unit: TGLuint; sampler: TGLuint); stdcall;

glSamplerParameteri: procedure(sampler: TGLuint; pname: Cardinal; param: TGLint); stdcall;

glSamplerParameteriv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLint); stdcall;

glSamplerParameterf: procedure(sampler: TGLuint; pname: Cardinal; param: Single); stdcall;

glSamplerParameterfv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLfloat); stdcall;

glSamplerParameterIiv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLint); stdcall;

glSamplerParameterIuiv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLuint); stdcall;

glGetSamplerParameteriv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetSamplerParameterIiv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetSamplerParameterfv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glGetSamplerParameterIfv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glQueryCounter: procedure(id: TGLuint; target: Cardinal); stdcall;

glGetQueryObjecti64v: procedure(id: TGLuint; pname: Cardinal; params: PGLint64); stdcall;

glGetQueryObjectui64v: procedure(id: TGLuint; pname: Cardinal; params: PGLuint64); stdcall;

glVertexP2ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

glVertexP2uiv: procedure(_type: Cardinal; const value: PGLuint ); stdcall;

glVertexP3ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

glVertexP3uiv: procedure(_type: Cardinal; const value: PGLuint); stdcall;

glVertexP4ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

glVertexP4uiv: procedure(_type: Cardinal; const value: PGLuint); stdcall;

glTexCoordP1ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glTexCoordP1uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glTexCoordP2ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glTexCoordP2uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glTexCoordP3ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glTexCoordP3uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glTexCoordP4ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glTexCoordP4uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glMultiTexCoordP1ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

glMultiTexCoordP1uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

glMultiTexCoordP2ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

glMultiTexCoordP2uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

glMultiTexCoordP3ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

glMultiTexCoordP3uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

glMultiTexCoordP4ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

glMultiTexCoordP4uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

glNormalP3ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glNormalP3uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glColorP3ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

glColorP3uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

glColorP4ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

glColorP4uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

glSecondaryColorP3ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

glSecondaryColorP3uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

glVertexAttribP1ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

glVertexAttribP1uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

glVertexAttribP2ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

glVertexAttribP2uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

glVertexAttribP3ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

glVertexAttribP3uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

glVertexAttribP4ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

glVertexAttribP4uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

glDrawArraysIndirect: procedure(mode: Cardinal; const indirect: PGLvoid); stdcall;

glDrawElementsIndirect: procedure(mode: Cardinal; _type: Cardinal; const indirect: PGLvoid); stdcall;

glUniform1d: procedure(location: TGLint; x: TGLdouble); stdcall;

glUniform2d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

glUniform3d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

glUniform4d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

glUniform1dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glUniform2dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glUniform3dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glUniform4dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glUniformMatrix2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix2x3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix2x4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix3x2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix3x4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix4x2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix4x3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glGetUniformdv: procedure(_program: TGLuint; location: TGLint; params : PGLdouble); stdcall;

glProgramUniform1dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble); stdcall;

glProgramUniform2dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

glProgramUniform3dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

glProgramUniform4dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

glProgramUniform1dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glProgramUniform2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glProgramUniform3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glProgramUniform4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glProgramUniformMatrix2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix2x3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix2x4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix3x2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix3x4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix4x2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix4x3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glGetSubroutineUniformLocation: function(_program: TGLuint; shadertype: Cardinal; const name: PGLchar): TGLint; stdcall;

glGetSubroutineIndex: function(_program: TGLuint; shadertype: Cardinal; const name: PGLchar): TGLuint; stdcall;

glGetActiveSubroutineUniformiv: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; pname: Cardinal; values: PGLint); stdcall;

glGetActiveSubroutineUniformName: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

glGetActiveSubroutineName: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

glUniformSubroutinesuiv: procedure(shadertype: Cardinal; count: TGLsizei; const indices: PGLuint); stdcall;

glGetUniformSubroutineuiv: procedure(shadertype: Cardinal; location: TGLint; params: PGLuint); stdcall;

glGetProgramStageiv: procedure(_program: TGLuint; shadertype: Cardinal; pname: Cardinal; values: PGLint); stdcall;

glPatchParameteri: procedure(pname: Cardinal; value: TGLint); stdcall;

glPatchParameterfv: procedure(pname: Cardinal; const values: PGLfloat); stdcall;

glBindTransformFeedback: procedure(target: Cardinal; id: TGLuint); stdcall;

glDeleteTransformFeedbacks: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

glGenTransformFeedbacks: procedure(n: TGLsizei; ids: PGLuint); stdcall;

glIsTransformFeedback: function(id: TGLuint): TGLboolean; stdcall;

glPauseTransformFeedback: procedure(); stdcall;

glResumeTransformFeedback: procedure(); stdcall;

glDrawTransformFeedback: procedure(mode: Cardinal; id: TGLuint); stdcall;

glDrawTransformFeedbackStream: procedure(mode: Cardinal; id: TGLuint; stream: TGLuint); stdcall;

glBeginQueryIndexed: procedure(target: Cardinal; index: TGLuint; id: TGLuint); stdcall;

glEndQueryIndexed: procedure(target: Cardinal; index: TGLuint); stdcall;

glGetQueryIndexediv: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glArrayElementArrayEXT: procedure(mode: Cardinal; count: TGLsizei; pi: Pointer); stdcall;

glAddSwapHintRectWIN: procedure(x, y: TGLint; width, height: TGLsizei); stdcall;

glBlendColorEXT: procedure(red, green, blue: TGLclampf; alpha: TGLclampf); stdcall;

glPolygonOffsetEXT: procedure(factor, bias: Single); stdcall;

glTexImage3DEXT: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; Format, AType: Cardinal; pixels: Pointer); stdcall;

glTexSubImage1DEXT: procedure(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

glTexSubImage2DEXT: procedure(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

glTexSubImage3DEXT: procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

glCopyTexImage1DEXT: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;

glCopyTexImage2DEXT: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;

glCopyTexSubImage1DEXT: procedure(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;

glCopyTexSubImage2DEXT: procedure(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

glCopyTexSubImage3DEXT: procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

glGenTexturesEXT: procedure(n: TGLsizei; textures: PGLuint); stdcall;

glDeleteTexturesEXT: procedure(n: TGLsizei; textures: PGLuint); stdcall;

glBindTextureEXT: procedure(target: Cardinal; texture: TGLuint); stdcall;

glPrioritizeTexturesEXT: procedure(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall;

glAreTexturesResidentEXT: function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;

glIsTextureEXT: function(texture: TGLuint): TGLboolean; stdcall;

glSampleMaskSGIS: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

glSamplePatternSGIS: procedure(pattern: Cardinal); stdcall;

glBlendEquationEXT: procedure(mode: Cardinal); stdcall;

glColorTableEXT: procedure(target, internalFormat: Cardinal; width: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

glColorSubTableExt: procedure(target: Cardinal; start, count: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

glGetColorTableEXT: procedure(target, format, atype: Cardinal; data: Pointer); stdcall;

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glIndexMaterialEXT: procedure(face: Cardinal; mode: Cardinal); stdcall;

glIndexFuncEXT: procedure(func: Cardinal; ref: Single); stdcall;

glLockArraysEXT: procedure(first: TGLint; count: TGLsizei); stdcall;

glUnlockArraysEXT: procedure; stdcall;

glDrawRangeElementsEXT: procedure(mode: Cardinal; start, Aend: TGLuint; Count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

glBeginSceneEXT: procedure; stdcall;

glEndSceneEXT: procedure; stdcall;

glSecondaryColor3bEXT: procedure(red, green, blue: TGLbyte); stdcall;

glSecondaryColor3bvEXT: procedure(v: PGLbyte); stdcall;

glSecondaryColor3dEXT: procedure(red, green, blue: TGLdouble); stdcall;

glSecondaryColor3dvEXT: procedure(v: PGLdouble); stdcall;

glSecondaryColor3fEXT: procedure(red, green, blue: Single); stdcall;

glSecondaryColor3fvEXT: procedure(v: PGLfloat); stdcall;

glSecondaryColor3iEXT: procedure(red, green, blue: TGLint); stdcall;

glSecondaryColor3ivEXT: procedure(v: PGLint); stdcall;

glSecondaryColor3sEXT: procedure(red, green, blue: TGLshort); stdcall;

glSecondaryColor3svEXT: procedure(v: PGLshort); stdcall;

glSecondaryColor3ubEXT: procedure(red, green, blue: TGLubyte); stdcall;

glSecondaryColor3ubvEXT: procedure(v: PGLubyte); stdcall;

glSecondaryColor3uiEXT: procedure(red, green, blue: TGLuint); stdcall;

glSecondaryColor3uivEXT: procedure(v: PGLuint); stdcall;

glSecondaryColor3usEXT: procedure(red, green, blue: TGLushort); stdcall;

glSecondaryColor3usvEXT: procedure(v: PGLushort); stdcall;

glSecondaryColorPointerEXT: procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

glMultiDrawArraysEXT: procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

glMultiDrawElementsEXT: procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

glFogCoordfEXT: procedure(coord: Single); stdcall;

glFogCoordfvEXT: procedure(coord: PGLfloat); stdcall;

glFogCoorddEXT: procedure(coord: TGLdouble); stdcall;

glFogCoorddvEXT: procedure(coord: PGLdouble); stdcall;

glFogCoordPointerEXT: procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

glBlendFuncSeparateEXT: procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

glFlushVertexArrayRangeNV: procedure; stdcall;

glVertexArrayRangeNV: procedure(Size: TGLsizei; p: pointer); stdcall;

wglAllocateMemoryNV: function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;

wglFreeMemoryNV: procedure(ptr: Pointer); stdcall;

glCombinerParameterfvNV: procedure(pname: Cardinal; params: PGLfloat); stdcall;

glCombinerParameterfNV: procedure(pname: Cardinal; param: Single); stdcall;

glCombinerParameterivNV: procedure(pname: Cardinal; params: PGLint); stdcall;

glCombinerParameteriNV: procedure(pname: Cardinal; param: TGLint); stdcall;

glCombinerInputNV: procedure(stage, portion, variable, input, mapping, componentUsage: Cardinal); stdcall;

glCombinerOutputNV: procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: Cardinal; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;

glFinalCombinerInputNV: procedure(variable, input, mapping, componentUsage: Cardinal); stdcall;

glGetCombinerInputParameterfvNV: procedure(stage, portion, variable, pname: Cardinal; params: PGLfloat); stdcall;

glGetCombinerInputParameterivNV: procedure(stage, portion, variable, pname: Cardinal; params: PGLint); stdcall;

glGetCombinerOutputParameterfvNV: procedure(stage, portion, pname: Cardinal; params: PGLfloat); stdcall;

glGetCombinerOutputParameterivNV: procedure(stage, portion, pname: Cardinal; params: PGLint); stdcall;

glGetFinalCombinerInputParameterfvNV: procedure(variable, pname: Cardinal; params: PGLfloat); stdcall;

glGetFinalCombinerInputParameterivNV: procedure(variable, pname: Cardinal; params: PGLint); stdcall;

glResizeBuffersMESA: procedure; stdcall;

glTbufferMask3DFX: procedure(mask: TGLuint); stdcall;

glSampleMaskEXT: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

glSamplePatternEXT: procedure(pattern: Cardinal); stdcall;

glTextureColorMaskSGIS: procedure(red, green, blue, alpha: TGLboolean); stdcall;

glGenFencesNV: procedure(n: TGLsizei; fences: PGLuint); stdcall;

glDeleteFencesNV: procedure(n: TGLsizei; fences: PGLuint); stdcall;

glSetFenceNV: procedure(fence: TGLuint; condition: Cardinal); stdcall;

glTestFenceNV: function(fence: TGLuint): TGLboolean; stdcall;

glFinishFenceNV: procedure(fence: TGLuint); stdcall;

glIsFenceNV: function(fence: TGLuint): TGLboolean; stdcall;

glGetFenceivNV: procedure(fence: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glAreProgramsResidentNV: procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;

glBindProgramNV: procedure(target: Cardinal; id: TGLuint); stdcall;

glDeleteProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

glExecuteProgramNV: procedure(target: Cardinal; id: TGLuint; params: PGLfloat); stdcall;

glGenProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

glGetProgramParameterdvNV: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

glGetProgramParameterfvNV: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glGetProgramivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetProgramStringNV: procedure(id: TGLuint; pname: Cardinal; programIdx: PGLubyte); stdcall;

glGetTrackMatrixivNV: procedure(target: Cardinal; address: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribdvNV: procedure(index: TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

glGetVertexAttribfvNV: procedure(index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glGetVertexAttribivNV: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribPointervNV: procedure(index: TGLuint; pname: Cardinal; pointer: PGLPointer); stdcall;

glIsProgramNV: function(id: TGLuint): TGLboolean; stdcall;

glLoadProgramNV: procedure(target: Cardinal; id: TGLuint; len: TGLSizei; programIdx: PGLubyte); stdcall;

glProgramParameter4dNV: procedure(target: Cardinal; index: TGLuint; x, y, z, w: TGLdouble); stdcall;

glProgramParameter4dvNV: procedure(target: Cardinal; index: TGLuint; v: PGLdouble ); stdcall;

glProgramParameter4fNV: procedure(target: Cardinal; index: TGLuint; x, y, z, w: Single); stdcall;

glProgramParameter4fvNV: procedure(target: Cardinal; index: TGLuint; v: PGLfloat); stdcall;

glProgramParameters4dvNV: procedure(target: Cardinal; index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glProgramParameters4fvNV: procedure(target: Cardinal; index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glRequestResidentProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

glTrackMatrixNV: procedure(target: Cardinal; address: TGLuint; matrix: Cardinal; transform: Cardinal); stdcall;

glVertexAttribPointerNV: procedure(index: TGLuint; fsize: TGLint; vertextype: Cardinal; stride: TGLSizei; pointer: Pointer); stdcall;

glVertexAttrib1dNV: procedure(index: TGLuint; x: TGLdouble); stdcall;

glVertexAttrib1dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

glVertexAttrib1fNV: procedure(index: TGLuint; x: Single); stdcall;

glVertexAttrib1fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

glVertexAttrib1sNV: procedure(index: TGLuint; x: TGLshort); stdcall;

glVertexAttrib1svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

glVertexAttrib2dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble); stdcall;

glVertexAttrib2dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

glVertexAttrib2fNV: procedure(index: TGLuint; x: Single; y: Single); stdcall;

glVertexAttrib2fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

glVertexAttrib2sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort); stdcall;

glVertexAttrib2svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

glVertexAttrib3dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

glVertexAttrib3dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

glVertexAttrib3fNV: procedure(index: TGLuint; x: Single; y: Single; z: Single); stdcall;

glVertexAttrib3fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

glVertexAttrib3sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

glVertexAttrib3svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

glVertexAttrib4dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

glVertexAttrib4dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

glVertexAttrib4fNV: procedure(index: TGLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

glVertexAttrib4fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

glVertexAttrib4sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;

glVertexAttrib4svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

glVertexAttrib4ubvNV: procedure(index: TGLuint; v: PGLubyte); stdcall;

glVertexAttribs1dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glVertexAttribs1fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glVertexAttribs1svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

glVertexAttribs2dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glVertexAttribs2fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glVertexAttribs2svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

glVertexAttribs3dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glVertexAttribs3fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glVertexAttribs3svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

glVertexAttribs4dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glVertexAttribs4fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glVertexAttribs4svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

glVertexAttribs4ubvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLubyte); stdcall;

glGenOcclusionQueriesNV: procedure(n: TGLsizei; ids: PGLuint); stdcall;

glDeleteOcclusionQueriesNV: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

glIsOcclusionQueryNV: function(id: TGLuint): TGLboolean; stdcall;

glBeginOcclusionQueryNV: procedure(id: TGLuint); stdcall;

glEndOcclusionQueryNV: procedure; stdcall;

glGetOcclusionQueryivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetOcclusionQueryuivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glPointParameteriNV: procedure(pname: Cardinal; param: TGLint); stdcall;

glPointParameterivNV: procedure(pname: Cardinal; params: PGLint); stdcall;

glActiveStencilFaceEXT: procedure(face: Cardinal); stdcall;

glDrawBuffersATI: procedure(n: GLsizei; const bufs: PGLenum); stdcall;

glPrimitiveRestartNV: procedure(); stdcall;

glPrimitiveRestartIndexNV: procedure(index: TGLuint); stdcall;

glDepthBoundsEXT: procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;

glBlendEquationSeparateEXT: procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

glIsRenderbufferEXT: function(renderbuffer: TGLuint): TGLboolean; stdcall;

glBindRenderbufferEXT: procedure(target: Cardinal; renderbuffer: TGLuint); stdcall;

glDeleteRenderbuffersEXT: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

glGenRenderbuffersEXT: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

glRenderbufferStorageEXT: procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

glGetRenderbufferParameterivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glIsFramebufferEXT: function(framebuffer: TGLuint): TGLboolean; stdcall;

glBindFramebufferEXT: procedure(target: Cardinal; framebuffer: TGLuint); stdcall;

glDeleteFramebuffersEXT: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

glGenFramebuffersEXT: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

glCheckFramebufferStatusEXT: function(target: Cardinal): Cardinal; stdcall;

glFramebufferTexture1DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

glFramebufferTexture2DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

glFramebufferTexture3DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint; zoffset: TGLint); stdcall;

glFramebufferRenderbufferEXT: procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: TGLuint); stdcall;

glGetFramebufferAttachmentParameterivEXT: procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGenerateMipmapEXT: procedure(target: Cardinal); stdcall;

glStencilClearTagEXT: procedure(stencilTagBits: TGLsizei; stencilClearTag: TGLuint); stdcall;

glBlitFramebufferEXT: procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

glRenderbufferStorageMultisampleEXT: procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

glGetQueryObjecti64vEXT: procedure(id: TGLuint; pname: Cardinal; params: PGLint64EXT); stdcall;

glGetQueryObjectui64vEXT: procedure(id: TGLuint; pname: Cardinal; params: PGLuint64EXT); stdcall;

glProgramEnvParameters4fvEXT: procedure(target:Cardinal; index:TGLuint; count:TGLsizei; const params:PGLfloat); stdcall;

glProgramLocalParameters4fvEXT: procedure(target:Cardinal; index:TGLuint; count:TGLsizei; const params:PGLFloat); stdcall;

glProgramVertexLimitNV: procedure(target: Cardinal; limit: TGLint); stdcall;

glProgramParameteriEXT: procedure( _program:TGLuint; pname:Cardinal; value: TGLint); stdcall;

glFramebufferTextureEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint); stdcall;

glFramebufferTextureLayerEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

glFramebufferTextureFaceEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; face:Cardinal); stdcall;

glVertexAttribI1iEXT: procedure(index: TGLuint; x: TGLint); stdcall;

glVertexAttribI2iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

glVertexAttribI3iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

glVertexAttribI4iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

glVertexAttribI1uiEXT: procedure(index: TGLuint; x: TGLuint); stdcall;

glVertexAttribI2uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

glVertexAttribI3uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

glVertexAttribI4uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

glVertexAttribI1ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI2ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI3ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI4ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI1uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI2uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI3uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI4uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI4bvEXT: procedure(index: TGLuint; v:PGLbyte); stdcall;

glVertexAttribI4svEXT: procedure(index: TGLuint; v:PGLshort); stdcall;

glVertexAttribI4ubvEXT: procedure(index: TGLuint; v: PGLUbyte); stdcall;

glVertexAttribI4usvEXT: procedure(index: TGLuint; v: PGLushort); stdcall;

glVertexAttribIPointerEXT: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

glGetVertexAttribIivEXT: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribIuivEXT: procedure(index: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glUniform1uiEXT: procedure(location: TGLInt; v0: TGLuint); stdcall;

glUniform2uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

glUniform3uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

glUniform4uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

glUniform1uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform2uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform3uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform4uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glGetUniformuivEXT: procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

glBindFragDataLocationEXT: procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

glGetFragDataLocationEXT: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

glDrawArraysInstancedEXT: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

glDrawElementsInstancedEXT: procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

glTexBufferEXT: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

glColorMaskIndexedEXT: procedure(buf: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

glGetBooleanIndexedvEXT: procedure(value: Cardinal; index: TGLuint; data: PGLboolean); stdcall;

glGetIntegerIndexedvEXT: procedure(value: Cardinal; index: TGLuint; data: PGLint); stdcall;

glEnableIndexedEXT: procedure(target: Cardinal; index: TGLuint); stdcall;

glDisableIndexedEXT: procedure(target: Cardinal; index: TGLuint); stdcall;

glIsEnabledIndexedEXT: function(target: Cardinal; index: TGLuint): TGLboolean; stdcall;

glBindBufferRangeNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

glBindBufferOffsetNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr); stdcall;

glBindBufferBaseNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

glTransformFeedbackAttribsNV: procedure(count: TGLsizei; attribs: PGLint; bufferMode: Cardinal); stdcall;

glTransformFeedbackVaryingsNV: procedure(_program: TGLuint; count: TGLsizei; locations: PGLint; bufferMode: Cardinal); stdcall;

glBeginTransformFeedbackNV: procedure(primitiveMode: Cardinal); stdcall;

glEndTransformFeedbackNV: procedure(); stdcall;

glGetVaryingLocationNV: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

glGetActiveVaryingNV: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: Cardinal; name: PGLChar); stdcall;

glActiveVaryingNV: procedure(_program: TGLuint; name: PGLChar); stdcall;

glGetTransformFeedbackVaryingNV: procedure(_program: TGLuint; index: TGLuint; location: PGLint); stdcall;

glUniformBufferEXT: procedure(_program: TGLUint; location: TGLint; buffer: TGLuint); stdcall;

glGetUniformBufferSizeEXT: function(_program: TGLuint; location: TGLint): TGLint; stdcall;

glGetUniformOffsetEXT: function(_program: TGLuint; location: TGLint): PGLint; stdcall;

glClearColorIiEXT: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;

glClearColorIuiEXT: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint); stdcall;

glTexParameterIivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glTexParameterIuivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

glGetTexParameterIivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGetTexParameterIuivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

glBeginConditionalRenderNV: procedure(id: TGLuint; mode: Cardinal); stdcall;

glEndConditionalRenderNV: procedure(); stdcall;

glBindBufferRangeEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset:TGLintptr; size: TGLsizeiptr); stdcall;

glBindBufferOffsetEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset:TGLintptr); stdcall;

glBindBufferBaseEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

glBeginTransformFeedbackEXT: procedure(primitiveMode: Cardinal); stdcall;

glEndTransformFeedbackEXT: procedure(); stdcall;

glTransformFeedbackVaryingsEXT: procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

glGetTransformFeedbackVaryingEXT: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

glTessellationFactorAMD: procedure(factor: Single); stdcall;

glTessellationModeAMD: procedure(mode: Cardinal); stdcall;

glCopyImageSubDataNV: procedure( srcName: GLuint; srcTarget: GLenum; srcLevel: GLint; srcX: GLint; srcY: GLint; srcZ: GLint; dstName: GLuint; dstTarget: GLenum; dstLevel: GLint; dstX: GLint; dstY: GLint; dstZ: GLint; width: GLsizei; height: GLsizei; depth: GLsizei); stdcall;

glMakeBufferResidentNV: procedure(target: Cardinal; access: Cardinal); stdcall;

glMakeBufferNonResidentNV: procedure(target: Cardinal); stdcall;

glIsBufferResidentNV: function(target: Cardinal): TGLboolean; stdcall;

glMakeNamedBufferResidentNV: procedure(buffer: TGLuint; access: Cardinal); stdcall;

glMakeNamedBufferNonResidentNV: procedure(buffer: TGLuint); stdcall;

glIsNamedBufferResidentNV: function(buffer: TGLuint): TGLboolean; stdcall;

glGetBufferParameterui64vNV: procedure(target: Cardinal; pname: Cardinal; params: PGLuint64EXT ); stdcall;

glGetNamedBufferParameterui64vNV: procedure(buffer: TGLuint; pname: Cardinal; params: PGLuint64EXT); stdcall;

glGetIntegerui64vNV: procedure(value: Cardinal; result: PGLuint64EXT); stdcall;

glUniformui64NV: procedure(location: TGLint; value: TGLuint64EXT); stdcall;

glUniformui64vNV: procedure(location: GLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

glGetUniformui64vNV: procedure(_program: TGLuint; location: TGLint; params: PGLuint64EXT); stdcall;

glProgramUniformui64NV: procedure(_program: TGLuint; location: TGLint; value: TGLuint64EXT); stdcall;

glProgramUniformui64vNV: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

glBufferAddressRangeNV: procedure(pname: Cardinal; index: TGLuint; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;

glVertexFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glNormalFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

glColorFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glIndexFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

glTexCoordFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glEdgeFlagFormatNV: procedure(stride: TGLsizei); stdcall;

glSecondaryColorFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glFogCoordFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

glVertexAttribFormatNV: procedure(index: TGLuint; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei); stdcall;

glVertexAttribIFormatNV: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glGetIntegerui64i_vNV: procedure(value: Cardinal; index: TGLuint; result: PGLuint64EXT); stdcall;

glFrameTerminatorGREMEDY: procedure(); stdcall;

glStringMarkerGREMEDY: procedure(len: GLsizei; str: PGLChar); stdcall;

vIgnoreOpenGLErrors: Boolean = false;

Description

Functions and Procedures

procedure glAccum(op: TGLuint; value: Single); stdcall; external opengl32;

GL functions and procedures

procedure glAlphaFunc(func: Cardinal; ref: TGLclampf); stdcall; external opengl32;

deprecated;

function glAreTexturesResident(n: TGLsizei; Textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall; external opengl32;

deprecated;

procedure glArrayElement(i: TGLint); stdcall; external opengl32;

deprecated;

procedure glBegin(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glBindTexture(target: Cardinal; texture: TGLuint); stdcall; external opengl32;

deprecated;

procedure glBitmap(width: TGLsizei; height: TGLsizei; xorig, yorig: Single; xmove: Single; ymove: Single; bitmap: Pointer); stdcall; external opengl32;

This item has no description.

procedure glBlendFunc(sfactor: Cardinal; dfactor: Cardinal); stdcall; external opengl32;

deprecated;

procedure glCallList(list: TGLuint); stdcall; external opengl32;

This item has no description.

procedure glCallLists(n: TGLsizei; atype: Cardinal; lists: Pointer); stdcall; external opengl32;

deprecated;

procedure glClear(mask: TGLbitfield); stdcall; external opengl32;

deprecated;

procedure glClearAccum(red, green, blue, alpha: Single); stdcall; external opengl32;

This item has no description.

procedure glClearColor(red, green, blue, alpha: TGLclampf); stdcall; external opengl32;

deprecated;

procedure glClearDepth(depth: TGLclampd); stdcall; external opengl32;

This item has no description.

procedure glClearIndex(c: Single); stdcall; external opengl32;

This item has no description.

procedure glClearStencil(s: TGLint ); stdcall; external opengl32;

deprecated;

procedure glClipPlane(plane: Cardinal; equation: PGLdouble); stdcall; external opengl32;

This item has no description.

procedure glColor3b(red, green, blue: TGLbyte); stdcall; external opengl32;

deprecated;

procedure glColor3bv(v: PGLbyte); stdcall; external opengl32;

deprecated;

procedure glColor3d(red, green, blue: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glColor3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glColor3f(red, green, blue: Single); stdcall; external opengl32;

deprecated;

procedure glColor3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glColor3i(red, green, blue: TGLint); stdcall; external opengl32;

deprecated;

procedure glColor3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glColor3s(red, green, blue: TGLshort); stdcall; external opengl32;

deprecated;

procedure glColor3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glColor3ub(red, green, blue: TGLubyte); stdcall; external opengl32;

deprecated;

procedure glColor3ubv(v: PGLubyte); stdcall; external opengl32;

deprecated;

procedure glColor3ui(red, green, blue: TGLuint); stdcall; external opengl32;

deprecated;

procedure glColor3uiv(v: PGLuint); stdcall; external opengl32;

deprecated;

procedure glColor3us(red, green, blue: TGLushort); stdcall; external opengl32;

deprecated;

procedure glColor3usv(v: PGLushort); stdcall; external opengl32;

deprecated;

procedure glColor4b(red, green, blue, alpha: TGLbyte); stdcall; external opengl32;

deprecated;

procedure glColor4bv(v: PGLbyte); stdcall; external opengl32;

deprecated;

procedure glColor4d(red, green, blue, alpha: TGLdouble ); stdcall; external opengl32;

deprecated;

procedure glColor4dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glColor4f(red, green, blue, alpha: Single); stdcall; external opengl32;

deprecated;

procedure glColor4fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glColor4i(red, green, blue, alpha: TGLint); stdcall; external opengl32;

deprecated;

procedure glColor4iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glColor4s(red, green, blue, alpha: TGLshort); stdcall; external opengl32;

deprecated;

procedure glColor4sv(v: TGLshort); stdcall; external opengl32;

deprecated;

procedure glColor4ub(red, green, blue, alpha: TGLubyte); stdcall; external opengl32;

deprecated;

procedure glColor4ubv(v: PGLubyte); stdcall; external opengl32;

deprecated;

procedure glColor4ui(red, green, blue, alpha: TGLuint); stdcall; external opengl32;

deprecated;

procedure glColor4uiv(v: PGLuint); stdcall; external opengl32;

deprecated;

procedure glColor4us(red, green, blue, alpha: TGLushort); stdcall; external opengl32;

deprecated;

procedure glColor4usv(v: PGLushort); stdcall; external opengl32;

deprecated;

procedure glColorMask(red, green, blue, alpha: TGLboolean); stdcall; external opengl32;

deprecated;

procedure glColorMaterial(face: Cardinal; mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glColorPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glCopyPixels(x, y: TGLint; width, height: TGLsizei; atype: Cardinal); stdcall; external opengl32;

deprecated;

procedure glCopyTexImage1D(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall; external opengl32;

deprecated;

procedure glCopyTexImage2D(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall; external opengl32;

This item has no description.

procedure glCopyTexSubImage1D(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall; external opengl32;

This item has no description.

procedure glCopyTexSubImage2D(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

This item has no description.

procedure glCullFace(mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDeleteLists(list: TGLuint; range: TGLsizei); stdcall; external opengl32;

This item has no description.

procedure glDeleteTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;

deprecated;

procedure glDepthFunc(func: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDepthMask(flag: TGLboolean); stdcall; external opengl32;

This item has no description.

procedure glDepthRange(zNear, zFar: TGLclampd); stdcall; external opengl32;

This item has no description.

procedure glDisable(cap: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDisableClientState(aarray: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDrawArrays(mode: Cardinal; first: TGLint; count: TGLsizei); stdcall; external opengl32;

deprecated;

procedure glDrawBuffer(mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDrawElements(mode: Cardinal; count: TGLsizei; atype: Cardinal; indices: Pointer); stdcall; external opengl32;

This item has no description.

procedure glDrawPixels(width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

This item has no description.

procedure glEdgeFlag(flag: TGLboolean); stdcall; external opengl32;

deprecated;

procedure glEdgeFlagPointer(stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glEdgeFlagv(flag: PGLboolean); stdcall; external opengl32;

deprecated;

procedure glEnable(cap: Cardinal); stdcall; external opengl32;

deprecated;

procedure glEnableClientState(aarray: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glEnd; stdcall; external opengl32;

deprecated;

procedure glEndList; stdcall; external opengl32;

deprecated;

procedure glEvalCoord1d(u: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glEvalCoord1dv(u: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glEvalCoord1f(u: Single); stdcall; external opengl32;

deprecated;

procedure glEvalCoord1fv(u: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glEvalCoord2d(u: TGLdouble; v: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glEvalCoord2dv(u: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glEvalCoord2f(u, v: Single); stdcall; external opengl32;

deprecated;

procedure glEvalCoord2fv(u: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glEvalMesh1(mode: Cardinal; i1, i2: TGLint); stdcall; external opengl32;

deprecated;

procedure glEvalMesh2(mode: Cardinal; i1, i2, j1, j2: TGLint); stdcall; external opengl32;

deprecated;

procedure glEvalPoint1(i: TGLint); stdcall; external opengl32;

deprecated;

procedure glEvalPoint2(i, j: TGLint); stdcall; external opengl32;

deprecated;

procedure glFeedbackBuffer(size: TGLsizei; atype: Cardinal; buffer: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glFinish; stdcall; external opengl32;

deprecated;

procedure glFlush; stdcall; external opengl32;

This item has no description.

procedure glFogf(pname: Cardinal; param: Single); stdcall; external opengl32;

This item has no description.

procedure glFogfv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glFogi(pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glFogiv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glFrontFace(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glFrustum(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;

This item has no description.

function glGenLists(range: TGLsizei): TGLuint; stdcall; external opengl32;

deprecated;

procedure glGenTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;

deprecated;

procedure glGetBooleanv(pname: Cardinal; params: PGLboolean); stdcall; external opengl32;

This item has no description.

procedure glGetClipPlane(plane: Cardinal; equation: PGLdouble); stdcall; external opengl32;

This item has no description.

procedure glGetDoublev(pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

deprecated;

function glGetError: TGLuint; stdcall; external opengl32;

This item has no description.

procedure glGetFloatv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetIntegerv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

This item has no description.

procedure glGetLightfv(light, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetLightiv(light, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetMapdv(target, query: Cardinal; v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glGetMapfv(target, query: Cardinal; v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glGetMapiv(target, query: Cardinal; v: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetMaterialfv(face, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glGetMaterialiv(face, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetPixelMapfv(map: Cardinal; values: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glGetPixelMapuiv(map: Cardinal; values: PGLuint); stdcall; external opengl32;

deprecated;

procedure glGetPixelMapusv(map: Cardinal; values: PGLushort); stdcall; external opengl32;

deprecated;

procedure glGetPointerv(pname: Cardinal; var params); stdcall; external opengl32;

deprecated;

procedure glGetPolygonStipple(mask: PGLubyte); stdcall; external opengl32;

This item has no description.

function glGetString(name: Cardinal): PChar; stdcall; external opengl32;

deprecated;

procedure glGetTexEnvfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetTexEnviv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetTexGendv(coord, pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glGetTexGenfv(coord, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glGetTexGeniv(coord, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetTexImage(target: Cardinal; level: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

deprecated;

procedure glGetTexLevelParameterfv(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetTexLevelParameteriv(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall; external opengl32;

This item has no description.

procedure glGetTexParameterfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetTexParameteriv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

This item has no description.

procedure glHint(target, mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glIndexMask(mask: TGLuint); stdcall; external opengl32;

This item has no description.

procedure glIndexPointer(atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glIndexd(c: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glIndexdv(c: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glIndexf(c: Single); stdcall; external opengl32;

deprecated;

procedure glIndexfv(c: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glIndexi(c: TGLint); stdcall; external opengl32;

deprecated;

procedure glIndexiv(c: PGLint); stdcall; external opengl32;

deprecated;

procedure glIndexs(c: TGLshort); stdcall; external opengl32;

deprecated;

procedure glIndexsv(c: PGLshort); stdcall; external opengl32;

deprecated;

procedure glIndexub(c: TGLubyte); stdcall; external opengl32;

deprecated;

procedure glIndexubv(c: PGLubyte); stdcall; external opengl32;

deprecated;

procedure glInitNames; stdcall; external opengl32;

deprecated;

procedure glInterleavedArrays(format: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

function glIsEnabled(cap: Cardinal): TGLboolean; stdcall; external opengl32;

deprecated;

function glIsList(list: TGLuint): TGLboolean; stdcall; external opengl32;

This item has no description.

function glIsTexture(texture: TGLuint): TGLboolean; stdcall; external opengl32;

This item has no description.

procedure glLightModelf(pname: Cardinal; param: Single); stdcall; external opengl32;

This item has no description.

procedure glLightModelfv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glLightModeli(pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glLightModeliv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glLightf(light, pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glLightfv(light, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glLighti(light, pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glLightiv(light, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glLineStipple(factor: TGLint; pattern: TGLushort); stdcall; external opengl32;

deprecated;

procedure glLineWidth(width: Single); stdcall; external opengl32;

deprecated;

procedure glListBase(base: TGLuint); stdcall; external opengl32;

This item has no description.

procedure glLoadIdentity; stdcall; external opengl32;

deprecated;

procedure glLoadMatrixd(m: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glLoadMatrixf(m: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glLoadName(name: TGLuint); stdcall; external opengl32;

deprecated;

procedure glLogicOp(opcode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glMap1d(target: Cardinal; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall; external opengl32;

This item has no description.

procedure glMap1f(target: Cardinal; u1, u2: Single; stride, order: TGLint; points: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glMap2d(target: Cardinal; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glMap2f(target: Cardinal; u1, u2: Single; ustride, uorder: TGLint; v1, v2: Single; vstride, vorder: TGLint; points: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glMapGrid1d(un: TGLint; u1, u2: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glMapGrid1f(un: TGLint; u1, u2: Single); stdcall; external opengl32;

deprecated;

procedure glMapGrid2d(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glMapGrid2f(un: TGLint; u1, u2: Single; vn: TGLint; v1, v2: Single); stdcall; external opengl32;

deprecated;

procedure glMaterialf(face, pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glMaterialfv(face, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glMateriali(face, pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glMaterialiv(face, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glMatrixMode(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glMultMatrixd(m: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glMultMatrixf(m: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glNewList(list: TGLuint; mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glNormal3b(nx, ny, nz: TGLbyte); stdcall; external opengl32;

deprecated;

procedure glNormal3bv(v: PGLbyte); stdcall; external opengl32;

deprecated;

procedure glNormal3d(nx, ny, nz: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glNormal3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glNormal3f(nx, ny, nz: Single); stdcall; external opengl32;

deprecated;

procedure glNormal3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glNormal3i(nx, ny, nz: TGLint); stdcall; external opengl32;

deprecated;

procedure glNormal3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glNormal3s(nx, ny, nz: TGLshort); stdcall; external opengl32;

deprecated;

procedure glNormal3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glNormalPointer(atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glOrtho(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glPassThrough(token: Single); stdcall; external opengl32;

deprecated;

procedure glPixelMapfv(map: Cardinal; mapsize: TGLsizei; values: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glPixelMapuiv(map: Cardinal; mapsize: TGLsizei; values: PGLuint); stdcall; external opengl32;

deprecated;

procedure glPixelMapusv(map: Cardinal; mapsize: TGLsizei; values: PGLushort); stdcall; external opengl32;

deprecated;

procedure glPixelStoref(pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glPixelStorei(pname: Cardinal; param: TGLint); stdcall; external opengl32;

This item has no description.

procedure glPixelTransferf(pname: Cardinal; param: Single); stdcall; external opengl32;

This item has no description.

procedure glPixelTransferi(pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glPixelZoom(xfactor, yfactor: Single); stdcall; external opengl32;

deprecated;

procedure glPointSize(size: Single); stdcall; external opengl32;

deprecated;

procedure glPolygonMode(face, mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glPolygonOffset(factor, units: Single); stdcall; external opengl32;

This item has no description.

procedure glPolygonStipple(mask: PGLubyte); stdcall; external opengl32;

This item has no description.

procedure glPopAttrib; stdcall; external opengl32;

deprecated;

procedure glPopClientAttrib; stdcall; external opengl32;

deprecated;

procedure glPopMatrix; stdcall; external opengl32;

deprecated;

procedure glPopName; stdcall; external opengl32;

deprecated;

procedure glPrioritizeTextures(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall; external opengl32;

deprecated;

procedure glPushAttrib(mask: TGLbitfield); stdcall; external opengl32;

deprecated;

procedure glPushClientAttrib(mask: TGLbitfield); stdcall; external opengl32;

deprecated;

procedure glPushMatrix; stdcall; external opengl32;

deprecated;

procedure glPushName(name: TGLuint); stdcall; external opengl32;

deprecated;

procedure glRasterPos2d(x, y: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos2dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos2f(x, y: Single); stdcall; external opengl32;

deprecated;

procedure glRasterPos2fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glRasterPos2i(x, y: TGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos2iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos2s(x, y: PGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos2sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos3d(x, y, z: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos3f(x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glRasterPos3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glRasterPos3i(x, y, z: TGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos3s(x, y, z: TGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos4d(x, y, z, w: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos4dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos4f(x, y, z, w: Single); stdcall; external opengl32;

deprecated;

procedure glRasterPos4fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glRasterPos4i(x, y, z, w: TGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos4iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos4s(x, y, z, w: TGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos4sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glReadBuffer(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glReadPixels(x, y: TGLint; width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

This item has no description.

procedure glRectd(x1, y1, x2, y2: TGLdouble); stdcall; external opengl32;

This item has no description.

procedure glRectdv(v1, v2: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glRectf(x1, y1, x2, y2: Single); stdcall; external opengl32;

deprecated;

procedure glRectfv(v1, v2: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glRecti(x1, y1, x2, y2: TGLint); stdcall; external opengl32;

deprecated;

procedure glRectiv(v1, v2: PGLint); stdcall; external opengl32;

deprecated;

procedure glRects(x1, y1, x2, y2: TGLshort); stdcall; external opengl32;

deprecated;

procedure glRectsv(v1, v2: PGLshort); stdcall; external opengl32;

deprecated;

function glRenderMode(mode: Cardinal): TGLint; stdcall; external opengl32;

deprecated;

procedure glRotated(angle, x, y, z: TGLdouble); stdcall; external opengl32;

This item has no description.

procedure glRotatef(angle, x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glScaled(x, y, z: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glScalef(x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glScissor(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

deprecated;

procedure glSelectBuffer(size: TGLsizei; buffer: PGLuint); stdcall; external opengl32;

This item has no description.

procedure glShadeModel(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glStencilFunc(func: Cardinal; ref: TGLint; mask: TGLuint); stdcall; external opengl32;

deprecated;

procedure glStencilMask(mask: TGLuint); stdcall; external opengl32;

This item has no description.

procedure glStencilOp(fail, zfail, zpass: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glTexCoord1d(s: TGLdouble); stdcall; external opengl32;

This item has no description.

procedure glTexCoord1dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord1f(s: Single); stdcall; external opengl32;

deprecated;

procedure glTexCoord1fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexCoord1i(s: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord1iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord1s(s: TGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord1sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord2d(s, t: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord2dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord2f(s, t: Single); stdcall; external opengl32;

deprecated;

procedure glTexCoord2fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexCoord2i(s, t: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord2iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord2s(s, t: TGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord2sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord3d(s, t, r: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord3f(s, t, r: Single); stdcall; external opengl32;

deprecated;

procedure glTexCoord3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexCoord3i(s, t, r: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord3s(s, t, r: TGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord4d(s, t, r, q: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord4dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord4f(s, t, r, q: Single); stdcall; external opengl32;

deprecated;

procedure glTexCoord4fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexCoord4i(s, t, r, q: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord4iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord4s(s, t, r, q: TGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord4sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoordPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glTexEnvf(target, pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glTexEnvfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexEnvi(target, pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexEnviv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexGend(coord, pname: Cardinal; param: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexGendv(coord, pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexGenf(coord, pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glTexGenfv(coord, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexGeni(coord, pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexGeniv(coord, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexImage1D(target: Cardinal; level, internalformat: TGLint; width: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

deprecated;

procedure glTexImage2D(target: Cardinal; level, internalformat: TGLint; width, height: TGLsizei; border: TGLint; format, atype: Cardinal; Pixels:Pointer); stdcall; external opengl32;

This item has no description.

procedure glTexParameterf(target, pname: Cardinal; param: Single); stdcall; external opengl32;

This item has no description.

procedure glTexParameterfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glTexParameteri(target, pname: Cardinal; param: TGLint); stdcall; external opengl32;

This item has no description.

procedure glTexParameteriv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

This item has no description.

procedure glTexSubImage1D(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

This item has no description.

procedure glTexSubImage2D(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

This item has no description.

procedure glTranslated(x, y, z: TGLdouble); stdcall; external opengl32;

This item has no description.

procedure glTranslatef(x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glVertex2d(x, y: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex2dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex2f(x, y: Single); stdcall; external opengl32;

deprecated;

procedure glVertex2fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glVertex2i(x, y: TGLint); stdcall; external opengl32;

deprecated;

procedure glVertex2iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glVertex2s(x, y: TGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex2sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex3d(x, y, z: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex3f(x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glVertex3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glVertex3i(x, y, z: TGLint); stdcall; external opengl32;

deprecated;

procedure glVertex3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glVertex3s(x, y, z: TGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex4d(x, y, z, w: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex4dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex4f(x, y, z, w: Single); stdcall; external opengl32;

deprecated;

procedure glVertex4fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glVertex4i(x, y, z, w: TGLint); stdcall; external opengl32;

deprecated;

procedure glVertex4iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glVertex4s(x, y, z, w: TGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex4sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glVertexPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glViewport(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

deprecated;

function gluErrorString(errCode: Cardinal): PGLChar; stdcall; external glu32;

GLU utility functions and procedures

function gluGetString(name: Cardinal): PGLChar; stdcall; external glu32;

This item has no description.

procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;

This item has no description.

function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;

This item has no description.

function gluScaleImage(format: Cardinal; widthin, heightin: TGLint; typein: Cardinal; datain: Pointer; widthout, heightout: TGLint; typeout: Cardinal; dataout: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluBuild1DMipmaps(target: Cardinal; components, width: TGLint; format, atype: Cardinal; data: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluBuild2DMipmaps(target: Cardinal; components, width, height: TGLint; format, atype: Cardinal; data: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluNewQuadric: PGLUquadric; stdcall; external glu32;

This item has no description.

function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;

This item has no description.

function gluNewTess: PGLUtesselator; stdcall; external glu32;

This item has no description.

procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

This item has no description.

procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;

This item has no description.

procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;

This item has no description.

procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; value: PGLfloat); stdcall; external glu32;

This item has no description.

procedure gluGetTessProperty(tess: PGLUtesselator; which: Cardinal; value: PGLdouble); stdcall; external glu32;

This item has no description.

procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const viewport: TVector4i); stdcall; external glu32;

This item has no description.

procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluNextContour(tess: PGLUtesselator; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluNurbsCallback(nobj: PGLUnurbs; which: Cardinal; fn: TGLUNurbsErrorProc); stdcall; external glu32;

This item has no description.

procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; value: Single); stdcall; external glu32;

This item has no description.

procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPickMatrix(x, y, width, height: TGLdouble; const viewport: TVector4i); stdcall; external glu32;

This item has no description.

procedure gluPwlCurve(nobj: PGLUnurbs; count: TGLint; points: PGLfloat; stride: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricCallback(quadObject: PGLUquadric; which: Cardinal; fn: TGLUQuadricErrorProc); stdcall; external glu32;

This item has no description.

procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricNormals(quadObject: PGLUquadric; normals: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;

This item has no description.

procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

This item has no description.

procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;

This item has no description.

procedure gluTessCallback(tess: PGLUtesselator; which: Cardinal; fn: Pointer); stdcall; external glu32;

This item has no description.

procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessNormal(tess: PGLUtesselator; x, y, z: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluTessProperty(tess: PGLUtesselator; which: Cardinal; value: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; data: Pointer); stdcall; external glu32;

This item has no description.

function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: Cardinal): BOOL; stdcall; external opengl32;

This item has no description.

function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;

This item has no description.

function wglCreateLayerContext(p1: HDC; p2: Integer): HGLRC; stdcall; external opengl32;

This item has no description.

function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;

This item has no description.

function wglDescribeLayerPlane(p1: HDC; p2, p3: Integer; p4: Cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;

This item has no description.

function wglGetCurrentContext: HGLRC; stdcall; external opengl32;

This item has no description.

function wglGetCurrentDC: HDC; stdcall; external opengl32;

This item has no description.

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;

This item has no description.

function wglGetProcAddress(ProcName: PGLChar): Pointer; stdcall; external opengl32;

This item has no description.

function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;

This item has no description.

function wglRealizeLayerPalette(p1: HDC; p2: Integer; p3: BOOL): BOOL; stdcall; external opengl32;

This item has no description.

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;

This item has no description.

function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;

This item has no description.

function wglSwapLayerBuffers(p1: HDC; p2: Cardinal): BOOL; stdcall; external opengl32;

This item has no description.

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32;

This item has no description.

function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;

This item has no description.

function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;

This item has no description.

function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;

This item has no description.

function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;

This item has no description.

function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 name 'wglUseFontBitmapsA';

This item has no description.

function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 name 'wglUseFontOutlinesA';

This item has no description.

function GLGetProcAddress(ProcName: PGLChar): Pointer;

——————————————————————————

procedure ReadExtensions;

This item has no description.

procedure ReadImplementationProperties;

This item has no description.

procedure ReadWGLExtensions;

This item has no description.

procedure ReadWGLImplementationProperties;

This item has no description.

procedure CloseOpenGL;

This item has no description.

function InitOpenGL: Boolean;

This item has no description.

function InitOpenGLFromLibrary(const GLName, GLUName : String) : Boolean;

This item has no description.

function IsOpenGLInitialized: Boolean;

This item has no description.

procedure UnloadOpenGL;

compatibility routines

function LoadOpenGL: Boolean;

This item has no description.

function LoadOpenGLFromLibrary(const GLName, GLUName: String): Boolean;

This item has no description.

function IsOpenGLLoaded: Boolean;

This item has no description.

function IsMesaGL: Boolean;

This item has no description.

procedure TrimAndSplitVersionString(Buffer: String; out Max, Min: Integer);

This item has no description.

function IsVersionMet(MajorVersion,MinorVersion, actualMajorVersion, actualMinorVersion:Integer): boolean;

This item has no description.

function IsOpenGLVersionMet(MajorVersion,MinorVersion: Integer): boolean;

This item has no description.

procedure CheckOpenGLError;

This item has no description.

procedure ClearGLError;

Gets the oldest error and tries to clear the error queue

procedure RaiseOpenGLError(const msg : String);

Clears all pending OpenGL errors

Types

GLbitfield = UINT;

This item has no description.

GLboolean = BYTEBOOL;

This item has no description.

GLbyte = ShortInt;

This item has no description.

GLclampd = Double;

This item has no description.

GLclampf = Single;

This item has no description.

GLdouble = Double;

This item has no description.

GLenum = Cardinal;

This item has no description.

GLfloat = Single;

This item has no description.

GLhandleARB = Cardinal;

This item has no description.

GLint = Integer;

This item has no description.

GLint64 = Int64;

This item has no description.

GLint64EXT = Int64;

This item has no description.

GLshort = SmallInt;

This item has no description.

GLsizei = Integer;

This item has no description.

GLubyte = Byte;

This item has no description.

GLuint = UINT;

This item has no description.

GLuint64 = UInt64;

This item has no description.

GLuint64EXT = UInt64;

This item has no description.

GLushort = Word;

This item has no description.

HGPUNV = THandle;

This item has no description.

HPBUFFERARB = Integer;

This item has no description.

HVIDEOINPUTDEVICENV = THandle;

This item has no description.

PGLbitfield = ˆTGLbitfield;

This item has no description.

PGLboolean = ˆTGLboolean;

This item has no description.

PGLbyte = ˆTGLbyte;

This item has no description.

PGLChar = PAnsiChar;

This item has no description.

PGLclampd = ˆTGLclampd;

This item has no description.

PGLclampf = ˆTGLclampf;

This item has no description.

PGLdouble = System.PDouble;

This item has no description.

PGLenum = ˆCardinal;

This item has no description.

PGLfloat = System.PSingle;

This item has no description.

PGLhandleARB = ˆGLhandleARB;

This item has no description.

PGLint = ˆInteger;

This item has no description.

PGLint64 = ˆTGLint64;

This item has no description.

PGLint64EXT = ˆTGLint64EXT;

This item has no description.

PGLintptr = ˆTGLintptr;

This item has no description.

PGLPCharArray = ˆPGLChar;

This item has no description.

PGLPointer = ˆPointer;

This item has no description.

PGLshort = ˆTGLshort;

This item has no description.

PGLsizei = ˆTGLsizei;

This item has no description.

PGLubyte = System.PByte;

This item has no description.

PGLuint = ˆTGLuint;

This item has no description.

PGLuint64 = ˆTGLuint64;

This item has no description.

PGLuint64EXT = ˆTGLuint64EXT;

This item has no description.

PGLUNurbs = ˆTGLUNurbs;

This item has no description.

PGLUNurbsObj = PGLUNurbs;

This item has no description.

PGLUQuadric = ˆTGLUQuadric;

This item has no description.

PGLUQuadricObj = PGLUQuadric;

This item has no description.

PGLushort = System.PWord;

This item has no description.

PGLUTesselator = ˆTGLUTesselator;

This item has no description.

PGLUTesselatorObj = PGLUTesselator;

This item has no description.

PGLUTriangulatorObj = PGLUTesselator;

This item has no description.

PGLvoid = Pointer;

This item has no description.

PGPUDEVICE = ˆTGPUDEVICE;

This item has no description.

PHGPUNV = ˆHGPUNV;

—————————- OpenGL Utility (GLU) types ——————–

PHVIDEOINPUTDEVICENV = ˆHVIDEOINPUTDEVICENV;

This item has no description.

PWGLSwap = ˆTWGLSwap;

This item has no description.

TGLbitfield = UINT;

This item has no description.

TGLboolean = BYTEBOOL;

This item has no description.

TGLbyte = ShortInt;

This item has no description.

TGLclampd = Double;

This item has no description.

TGLclampf = Single;

This item has no description.

TGLdouble = Double;

This item has no description.

TGLEnum = Cardinal;

This item has no description.

TGLfloat = Single;

This item has no description.

TGLint = Integer;

This item has no description.

TGLint64 = Int64;

This item has no description.

TGLint64EXT = Int64;

This item has no description.

TGLintptr = NativeInt;

the size of these depend on platform (32bit or 64bit)

TGLshort = SmallInt;

This item has no description.

TGLsizei = Integer;

This item has no description.

TGLsizeiptr = NativeInt;

This item has no description.

TGLString = AnsiString;

This item has no description.

TGLsync = NativeInt;

This item has no description.

TGLubyte = Byte;

This item has no description.

TGLuint = UINT;

This item has no description.

TGLuint64 = UInt64;

This item has no description.

TGLuint64EXT = UInt64;

This item has no description.

TGLUNurbsErrorProc = procedure(errorCode: Cardinal); stdcall;

GLUNurbsCallback

TGLUNurbsObj = TGLUNurbs;

backwards compatibility

TGLUQuadricErrorProc = procedure(errorCode: Cardinal); stdcall;

GLUQuadricCallback

TGLUQuadricObj = TGLUQuadric;

This item has no description.

TGLushort = Word;

This item has no description.

TGLUTessBeginDataProc = procedure(AType: Cardinal; UserData: Pointer); stdcall;

This item has no description.

TGLUTessBeginProc = procedure(AType: Cardinal); stdcall;

GLUTessCallback

TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;

This item has no description.

TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;

This item has no description.

TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;

This item has no description.

TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;

This item has no description.

TGLUTesselatorObj = TGLUTesselator;

This item has no description.

TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;

This item has no description.

TGLUTessEndProc = procedure; stdcall;

This item has no description.

TGLUTessErrorDataProc = procedure(ErrNo: Cardinal; UserData: Pointer); stdcall;

This item has no description.

TGLUTessErrorProc = procedure(ErrNo: Cardinal); stdcall;

This item has no description.

TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;

This item has no description.

TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;

This item has no description.

TGLUTriangulatorObj = TGLUTesselator;

This item has no description.

TRCOptions = set of ( opDoubleBuffered, opGDI, opStereo );

This item has no description.

TVector4p = array[0..3] of Pointer;

This item has no description.

TWGLSwap = _WGLSWAP;

This item has no description.

WGLSWAP = _WGLSWAP;

This item has no description.

Constants

opengl32 = 'OpenGL32.dll';

This item has no description.

glu32 = 'GLU32.dll';

This item has no description.

libEGL = 'libEGL.dll';

This item has no description.

libGLES2 = 'libGLESv2.dll';

This item has no description.

GL_DEPTH_BUFFER_BIT = $00000100;

AttribMask

GL_STENCIL_BUFFER_BIT = $00000400;

This item has no description.

GL_COLOR_BUFFER_BIT = $00004000;

This item has no description.

GL_TRUE = 1;

This item has no description.

GL_FALSE = 0;

This item has no description.

GL_POINTS = $0000;

BeginMode

GL_LINES = $0001;

This item has no description.

GL_LINE_LOOP = $0002;

This item has no description.

GL_LINE_STRIP = $0003;

This item has no description.

GL_TRIANGLES = $0004;

This item has no description.

GL_TRIANGLE_STRIP = $0005;

This item has no description.

GL_TRIANGLE_FAN = $0006;

This item has no description.

GL_NEVER = $0200;

AlphaFunction

GL_LESS = $0201;

This item has no description.

GL_EQUAL = $0202;

This item has no description.

GL_LEQUAL = $0203;

This item has no description.

GL_GREATER = $0204;

This item has no description.

GL_NOTEQUAL = $0205;

This item has no description.

GL_GEQUAL = $0206;

This item has no description.

GL_ALWAYS = $0207;

This item has no description.

GL_ZERO = 0;

BlendingFactorDest

GL_ONE = 1;

This item has no description.

GL_SRC_COLOR = $0300;

This item has no description.

GL_ONE_MINUS_SRC_COLOR = $0301;

This item has no description.

GL_SRC_ALPHA = $0302;

This item has no description.

GL_ONE_MINUS_SRC_ALPHA = $0303;

This item has no description.

GL_DST_ALPHA = $0304;

This item has no description.

GL_ONE_MINUS_DST_ALPHA = $0305;

This item has no description.

GL_DST_COLOR = $0306;

BlendingFactorSrc

GL_ONE_MINUS_DST_COLOR = $0307;

This item has no description.

GL_SRC_ALPHA_SATURATE = $0308;

This item has no description.

GL_NONE = 0;

DrawBufferMode

GL_FRONT_LEFT = $0400;

This item has no description.

GL_FRONT_RIGHT = $0401;

This item has no description.

GL_BACK_LEFT = $0402;

This item has no description.

GL_BACK_RIGHT = $0403;

This item has no description.

GL_FRONT = $0404;

This item has no description.

GL_BACK = $0405;

This item has no description.

GL_LEFT = $0406;

This item has no description.

GL_RIGHT = $0407;

This item has no description.

GL_FRONT_AND_BACK = $0408;

This item has no description.

GL_NO_ERROR = 0;

ErrorCode

GL_INVALID_ENUM = $0500;

This item has no description.

GL_INVALID_VALUE = $0501;

This item has no description.

GL_INVALID_OPERATION = $0502;

This item has no description.

GL_OUT_OF_MEMORY = $0505;

This item has no description.

GL_CW = $0900;

FrontFaceDirection

GL_CCW = $0901;

This item has no description.

GL_POINT_SIZE = $0B11;

GetPName

GL_POINT_SIZE_RANGE = $0B12;

This item has no description.

GL_POINT_SIZE_GRANULARITY = $0B13;

This item has no description.

GL_LINE_SMOOTH = $0B20;

This item has no description.

GL_LINE_WIDTH = $0B21;

This item has no description.

GL_LINE_WIDTH_RANGE = $0B22;

This item has no description.

GL_LINE_WIDTH_GRANULARITY = $0B23;

This item has no description.

GL_POLYGON_SMOOTH = $0B41;

This item has no description.

GL_CULL_FACE = $0B44;

This item has no description.

GL_CULL_FACE_MODE = $0B45;

This item has no description.

GL_FRONT_FACE = $0B46;

This item has no description.

GL_DEPTH_RANGE = $0B70;

This item has no description.

GL_DEPTH_TEST = $0B71;

This item has no description.

GL_DEPTH_WRITEMASK = $0B72;

This item has no description.

GL_DEPTH_CLEAR_VALUE = $0B73;

This item has no description.

GL_DEPTH_FUNC = $0B74;

This item has no description.

GL_STENCIL_TEST = $0B90;

This item has no description.

GL_STENCIL_CLEAR_VALUE = $0B91;

This item has no description.

GL_STENCIL_FUNC = $0B92;

This item has no description.

GL_STENCIL_VALUE_MASK = $0B93;

This item has no description.

GL_STENCIL_FAIL = $0B94;

This item has no description.

GL_STENCIL_PASS_DEPTH_FAIL = $0B95;

This item has no description.

GL_STENCIL_PASS_DEPTH_PASS = $0B96;

This item has no description.

GL_STENCIL_REF = $0B97;

This item has no description.

GL_STENCIL_WRITEMASK = $0B98;

This item has no description.

GL_VIEWPORT = $0BA2;

This item has no description.

GL_DITHER = $0BD0;

This item has no description.

GL_BLEND_DST = $0BE0;

This item has no description.

GL_BLEND_SRC = $0BE1;

This item has no description.

GL_BLEND = $0BE2;

This item has no description.

GL_LOGIC_OP_MODE = $0BF0;

This item has no description.

GL_COLOR_LOGIC_OP = $0BF2;

This item has no description.

GL_DRAW_BUFFER = $0C01;

This item has no description.

GL_READ_BUFFER = $0C02;

This item has no description.

GL_SCISSOR_BOX = $0C10;

This item has no description.

GL_SCISSOR_TEST = $0C11;

This item has no description.

GL_COLOR_CLEAR_VALUE = $0C22;

This item has no description.

GL_COLOR_WRITEMASK = $0C23;

This item has no description.

GL_DOUBLEBUFFER = $0C32;

This item has no description.

GL_STEREO = $0C33;

This item has no description.

GL_LINE_SMOOTH_HINT = $0C52;

This item has no description.

GL_POLYGON_SMOOTH_HINT = $0C53;

This item has no description.

GL_UNPACK_SWAP_BYTES = $0CF0;

This item has no description.

GL_UNPACK_LSB_FIRST = $0CF1;

This item has no description.

GL_UNPACK_ROW_LENGTH = $0CF2;

This item has no description.

GL_UNPACK_SKIP_ROWS = $0CF3;

This item has no description.

GL_UNPACK_SKIP_PIXELS = $0CF4;

This item has no description.

GL_UNPACK_ALIGNMENT = $0CF5;

This item has no description.

GL_PACK_SWAP_BYTES = $0D00;

This item has no description.

GL_PACK_LSB_FIRST = $0D01;

This item has no description.

GL_PACK_ROW_LENGTH = $0D02;

This item has no description.

GL_PACK_SKIP_ROWS = $0D03;

This item has no description.

GL_PACK_SKIP_PIXELS = $0D04;

This item has no description.

GL_PACK_ALIGNMENT = $0D05;

This item has no description.

GL_MAX_TEXTURE_SIZE = $0D33;

This item has no description.

GL_MAX_VIEWPORT_DIMS = $0D3A;

This item has no description.

GL_SUBPIXEL_BITS = $0D50;

This item has no description.

GL_TEXTURE_1D = $0DE0;

This item has no description.

GL_TEXTURE_2D = $0DE1;

This item has no description.

GL_POLYGON_OFFSET_UNITS = $2A00;

This item has no description.

GL_POLYGON_OFFSET_POINT = $2A01;

This item has no description.

GL_POLYGON_OFFSET_LINE = $2A02;

This item has no description.

GL_POLYGON_OFFSET_FILL = $8037;

This item has no description.

GL_POLYGON_OFFSET_FACTOR = $8038;

This item has no description.

GL_TEXTURE_BINDING_1D = $8068;

This item has no description.

GL_TEXTURE_BINDING_2D = $8069;

This item has no description.

GL_TEXTURE_WIDTH = $1000;

GetTextureParameter

GL_TEXTURE_HEIGHT = $1001;

This item has no description.

GL_TEXTURE_INTERNAL_FORMAT = $1003;

This item has no description.

GL_TEXTURE_BORDER_COLOR = $1004;

This item has no description.

GL_TEXTURE_BORDER = $1005;

This item has no description.

GL_TEXTURE_RED_SIZE = $805C;

This item has no description.

GL_TEXTURE_GREEN_SIZE = $805D;

This item has no description.

GL_TEXTURE_BLUE_SIZE = $805E;

This item has no description.

GL_TEXTURE_ALPHA_SIZE = $805F;

This item has no description.

GL_DONT_CARE = $1100;

HintMode

GL_FASTEST = $1101;

This item has no description.

GL_NICEST = $1102;

This item has no description.

GL_BYTE = $1400;

DataType

GL_UNSIGNED_BYTE = $1401;

This item has no description.

GL_SHORT = $1402;

This item has no description.

GL_UNSIGNED_SHORT = $1403;

This item has no description.

GL_INT = $1404;

This item has no description.

GL_UNSIGNED_INT = $1405;

This item has no description.

GL_FLOAT = $1406;

This item has no description.

GL_DOUBLE = $140A;

This item has no description.

GL_CLEAR = $1500;

LogicOp

GL_AND = $1501;

This item has no description.

GL_AND_REVERSE = $1502;

This item has no description.

GL_COPY = $1503;

This item has no description.

GL_AND_INVERTED = $1504;

This item has no description.

GL_NOOP = $1505;

This item has no description.

GL_XOR = $1506;

This item has no description.

GL_OR = $1507;

This item has no description.

GL_NOR = $1508;

This item has no description.

GL_EQUIV = $1509;

This item has no description.

GL_INVERT = $150A;

This item has no description.

GL_OR_REVERSE = $150B;

This item has no description.

GL_COPY_INVERTED = $150C;

This item has no description.

GL_OR_INVERTED = $150D;

This item has no description.

GL_NAND = $150E;

This item has no description.

GL_SET = $150F;

This item has no description.

GL_TEXTURE = $1702;

MatrixMode (for gl3.h, FBO attachment type)

GL_COLOR = $1800;

PixelCopyType

GL_DEPTH = $1801;

This item has no description.

GL_STENCIL = $1802;

This item has no description.

GL_STENCIL_INDEX = $1901;

PixelFormat

GL_DEPTH_COMPONENT = $1902;

This item has no description.

GL_RED = $1903;

This item has no description.

GL_GREEN = $1904;

This item has no description.

GL_BLUE = $1905;

This item has no description.

GL_ALPHA = $1906;

This item has no description.

GL_RGB = $1907;

This item has no description.

GL_RGBA = $1908;

This item has no description.

GL_POINT = $1B00;

PolygonMode

GL_LINE = $1B01;

This item has no description.

GL_FILL = $1B02;

This item has no description.

GL_KEEP = $1E00;

StencilOp

GL_REPLACE = $1E01;

This item has no description.

GL_INCR = $1E02;

This item has no description.

GL_DECR = $1E03;

This item has no description.

GL_VENDOR = $1F00;

StringName

GL_RENDERER = $1F01;

This item has no description.

GL_VERSION = $1F02;

This item has no description.

GL_EXTENSIONS = $1F03;

This item has no description.

GL_NEAREST = $2600;

TextureMagFilter

GL_LINEAR = $2601;

This item has no description.

GL_NEAREST_MIPMAP_NEAREST = $2700;

TextureMinFilter

GL_LINEAR_MIPMAP_NEAREST = $2701;

This item has no description.

GL_NEAREST_MIPMAP_LINEAR = $2702;

This item has no description.

GL_LINEAR_MIPMAP_LINEAR = $2703;

This item has no description.

GL_TEXTURE_MAG_FILTER = $2800;

TextureParameterName

GL_TEXTURE_MIN_FILTER = $2801;

This item has no description.

GL_TEXTURE_WRAP_S = $2802;

This item has no description.

GL_TEXTURE_WRAP_T = $2803;

This item has no description.

GL_PROXY_TEXTURE_1D = $8063;

TextureTarget

GL_PROXY_TEXTURE_2D = $8064;

This item has no description.

GL_REPEAT = $2901;

TextureWrapMode

GL_R3_G3_B2 = $2A10;

PixelInternalFormat

GL_RGB4 = $804F;

This item has no description.

GL_RGB5 = $8050;

This item has no description.

GL_RGB8 = $8051;

This item has no description.

GL_RGB10 = $8052;

This item has no description.

GL_RGB12 = $8053;

This item has no description.

GL_RGB16 = $8054;

This item has no description.

GL_RGBA2 = $8055;

This item has no description.

GL_RGBA4 = $8056;

This item has no description.

GL_RGB5_A1 = $8057;

This item has no description.

GL_RGBA8 = $8058;

This item has no description.

GL_RGB10_A2 = $8059;

This item has no description.

GL_RGBA12 = $805A;

This item has no description.

GL_RGBA16 = $805B;

This item has no description.

GL_ACCUM = $0100;

This item has no description.

GL_LOAD = $0101;

This item has no description.

GL_RETURN = $0102;

This item has no description.

GL_MULT = $0103;

This item has no description.

GL_ADD = $0104;

This item has no description.

GL_CURRENT_BIT = $00000001;

This item has no description.

GL_POINT_BIT = $00000002;

This item has no description.

GL_LINE_BIT = $00000004;

This item has no description.

GL_POLYGON_BIT = $00000008;

This item has no description.

GL_POLYGON_STIPPLE_BIT = $00000010;

This item has no description.

GL_PIXEL_MODE_BIT = $00000020;

This item has no description.

GL_LIGHTING_BIT = $00000040;

This item has no description.

GL_FOG_BIT = $00000080;

This item has no description.

GL_ACCUM_BUFFER_BIT = $00000200;

This item has no description.

GL_VIEWPORT_BIT = $00000800;

This item has no description.

GL_TRANSFORM_BIT = $00001000;

This item has no description.

GL_ENABLE_BIT = $00002000;

This item has no description.

GL_HINT_BIT = $00008000;

This item has no description.

GL_EVAL_BIT = $00010000;

This item has no description.

GL_LIST_BIT = $00020000;

This item has no description.

GL_TEXTURE_BIT = $00040000;

This item has no description.

GL_SCISSOR_BIT = $00080000;

This item has no description.

GL_ALL_ATTRIB_BITS = $000FFFFF;

This item has no description.

GL_QUADS = $0007;

This item has no description.

GL_QUAD_STRIP = $0008;

This item has no description.

GL_POLYGON = $0009;

This item has no description.

GL_CLIP_PLANE0 = $3000;

This item has no description.

GL_CLIP_PLANE1 = $3001;

This item has no description.

GL_CLIP_PLANE2 = $3002;

This item has no description.

GL_CLIP_PLANE3 = $3003;

This item has no description.

GL_CLIP_PLANE4 = $3004;

This item has no description.

GL_CLIP_PLANE5 = $3005;

This item has no description.

GL_2_BYTES = $1407;

This item has no description.

GL_3_BYTES = $1408;

This item has no description.

GL_4_BYTES = $1409;

This item has no description.

GL_AUX0 = $0409;

This item has no description.

GL_AUX1 = $040A;

This item has no description.

GL_AUX2 = $040B;

This item has no description.

GL_AUX3 = $040C;

This item has no description.

GL_STACK_OVERFLOW = $0503;

This item has no description.

GL_STACK_UNDERFLOW = $0504;

This item has no description.

GL_2D = $0600;

This item has no description.

GL_3D = $0601;

This item has no description.

GL_3D_COLOR = $0602;

This item has no description.

GL_3D_COLOR_TEXTURE = $0603;

This item has no description.

GL_4D_COLOR_TEXTURE = $0604;

This item has no description.

GL_PASS_THROUGH_TOKEN = $0700;

This item has no description.

GL_POINT_TOKEN = $0701;

This item has no description.

GL_LINE_TOKEN = $0702;

This item has no description.

GL_POLYGON_TOKEN = $0703;

This item has no description.

GL_BITMAP_TOKEN = $0704;

This item has no description.

GL_DRAW_PIXEL_TOKEN = $0705;

This item has no description.

GL_COPY_PIXEL_TOKEN = $0706;

This item has no description.

GL_LINE_RESET_TOKEN = $0707;

This item has no description.

GL_EXP = $0800;

This item has no description.

GL_EXP2 = $0801;

This item has no description.

GL_COEFF = $0A00;

This item has no description.

GL_ORDER = $0A01;

This item has no description.

GL_DOMAIN = $0A02;

This item has no description.

GL_CURRENT_COLOR = $0B00;

This item has no description.

GL_CURRENT_INDEX = $0B01;

This item has no description.

GL_CURRENT_NORMAL = $0B02;

This item has no description.

GL_CURRENT_TEXTURE_COORDS = $0B03;

This item has no description.

GL_CURRENT_RASTER_COLOR = $0B04;

This item has no description.

GL_CURRENT_RASTER_INDEX = $0B05;

This item has no description.

GL_CURRENT_RASTER_TEXTURE_COORDS = $0B06;

This item has no description.

GL_CURRENT_RASTER_POSITION = $0B07;

This item has no description.

GL_CURRENT_RASTER_POSITION_VALID = $0B08;

This item has no description.

GL_CURRENT_RASTER_DISTANCE = $0B09;

This item has no description.

GL_POINT_SMOOTH = $0B10;

This item has no description.

GL_LINE_STIPPLE = $0B24;

This item has no description.

GL_LINE_STIPPLE_PATTERN = $0B25;

This item has no description.

GL_LINE_STIPPLE_REPEAT = $0B26;

This item has no description.

GL_LIST_MODE = $0B30;

This item has no description.

GL_MAX_LIST_NESTING = $0B31;

This item has no description.

GL_LIST_BASE = $0B32;

This item has no description.

GL_LIST_INDEX = $0B33;

This item has no description.

GL_POLYGON_MODE = $0B40;

This item has no description.

GL_POLYGON_STIPPLE = $0B42;

This item has no description.

GL_EDGE_FLAG = $0B43;

This item has no description.

GL_LIGHTING = $0B50;

This item has no description.

GL_LIGHT_MODEL_LOCAL_VIEWER = $0B51;

This item has no description.

GL_LIGHT_MODEL_TWO_SIDE = $0B52;

This item has no description.

GL_LIGHT_MODEL_AMBIENT = $0B53;

This item has no description.

GL_SHADE_MODEL = $0B54;

This item has no description.

GL_COLOR_MATERIAL_FACE = $0B55;

This item has no description.

GL_COLOR_MATERIAL_PARAMETER = $0B56;

This item has no description.

GL_COLOR_MATERIAL = $0B57;

This item has no description.

GL_FOG = $0B60;

This item has no description.

GL_FOG_INDEX = $0B61;

This item has no description.

GL_FOG_DENSITY = $0B62;

This item has no description.

GL_FOG_START = $0B63;

This item has no description.

GL_FOG_END = $0B64;

This item has no description.

GL_FOG_MODE = $0B65;

This item has no description.

GL_FOG_COLOR = $0B66;

This item has no description.

GL_ACCUM_CLEAR_VALUE = $0B80;

This item has no description.

GL_MATRIX_MODE = $0BA0;

This item has no description.

GL_NORMALIZE = $0BA1;

This item has no description.

GL_MODELVIEW_STACK_DEPTH = $0BA3;

This item has no description.

GL_PROJECTION_STACK_DEPTH = $0BA4;

This item has no description.

GL_TEXTURE_STACK_DEPTH = $0BA5;

This item has no description.

GL_MODELVIEW_MATRIX = $0BA6;

This item has no description.

GL_PROJECTION_MATRIX = $0BA7;

This item has no description.

GL_TEXTURE_MATRIX = $0BA8;

This item has no description.

GL_ATTRIB_STACK_DEPTH = $0BB0;

This item has no description.

GL_CLIENT_ATTRIB_STACK_DEPTH = $0BB1;

This item has no description.

GL_ALPHA_TEST = $0BC0;

This item has no description.

GL_ALPHA_TEST_FUNC = $0BC1;

This item has no description.

GL_ALPHA_TEST_REF = $0BC2;

This item has no description.

GL_INDEX_LOGIC_OP = $0BF1;

This item has no description.

GL_AUX_BUFFERS = $0C00;

This item has no description.

GL_INDEX_CLEAR_VALUE = $0C20;

This item has no description.

GL_INDEX_WRITEMASK = $0C21;

This item has no description.

GL_INDEX_MODE = $0C30;

This item has no description.

GL_RGBA_MODE = $0C31;

This item has no description.

GL_RENDER_MODE = $0C40;

This item has no description.

GL_PERSPECTIVE_CORRECTION_HINT = $0C50;

This item has no description.

GL_POINT_SMOOTH_HINT = $0C51;

This item has no description.

GL_FOG_HINT = $0C54;

This item has no description.

GL_TEXTURE_GEN_S = $0C60;

This item has no description.

GL_TEXTURE_GEN_T = $0C61;

This item has no description.

GL_TEXTURE_GEN_R = $0C62;

This item has no description.

GL_TEXTURE_GEN_Q = $0C63;

This item has no description.

GL_PIXEL_MAP_I_TO_I = $0C70;

This item has no description.

GL_PIXEL_MAP_S_TO_S = $0C71;

This item has no description.

GL_PIXEL_MAP_I_TO_R = $0C72;

This item has no description.

GL_PIXEL_MAP_I_TO_G = $0C73;

This item has no description.

GL_PIXEL_MAP_I_TO_B = $0C74;

This item has no description.

GL_PIXEL_MAP_I_TO_A = $0C75;

This item has no description.

GL_PIXEL_MAP_R_TO_R = $0C76;

This item has no description.

GL_PIXEL_MAP_G_TO_G = $0C77;

This item has no description.

GL_PIXEL_MAP_B_TO_B = $0C78;

This item has no description.

GL_PIXEL_MAP_A_TO_A = $0C79;

This item has no description.

GL_PIXEL_MAP_I_TO_I_SIZE = $0CB0;

This item has no description.

GL_PIXEL_MAP_S_TO_S_SIZE = $0CB1;

This item has no description.

GL_PIXEL_MAP_I_TO_R_SIZE = $0CB2;

This item has no description.

GL_PIXEL_MAP_I_TO_G_SIZE = $0CB3;

This item has no description.

GL_PIXEL_MAP_I_TO_B_SIZE = $0CB4;

This item has no description.

GL_PIXEL_MAP_I_TO_A_SIZE = $0CB5;

This item has no description.

GL_PIXEL_MAP_R_TO_R_SIZE = $0CB6;

This item has no description.

GL_PIXEL_MAP_G_TO_G_SIZE = $0CB7;

This item has no description.

GL_PIXEL_MAP_B_TO_B_SIZE = $0CB8;

This item has no description.

GL_PIXEL_MAP_A_TO_A_SIZE = $0CB9;

This item has no description.

GL_MAP_COLOR = $0D10;

This item has no description.

GL_MAP_STENCIL = $0D11;

This item has no description.

GL_INDEX_SHIFT = $0D12;

This item has no description.

GL_INDEX_OFFSET = $0D13;

This item has no description.

GL_RED_SCALE = $0D14;

This item has no description.

GL_RED_BIAS = $0D15;

This item has no description.

GL_ZOOM_X = $0D16;

This item has no description.

GL_ZOOM_Y = $0D17;

This item has no description.

GL_GREEN_SCALE = $0D18;

This item has no description.

GL_GREEN_BIAS = $0D19;

This item has no description.

GL_BLUE_SCALE = $0D1A;

This item has no description.

GL_BLUE_BIAS = $0D1B;

This item has no description.

GL_ALPHA_SCALE = $0D1C;

This item has no description.

GL_ALPHA_BIAS = $0D1D;

This item has no description.

GL_DEPTH_SCALE = $0D1E;

This item has no description.

GL_DEPTH_BIAS = $0D1F;

This item has no description.

GL_MAX_EVAL_ORDER = $0D30;

This item has no description.

GL_MAX_LIGHTS = $0D31;

This item has no description.

GL_MAX_CLIP_PLANES = $0D32;

This item has no description.

GL_MAX_PIXEL_MAP_TABLE = $0D34;

This item has no description.

GL_MAX_ATTRIB_STACK_DEPTH = $0D35;

This item has no description.

GL_MAX_MODELVIEW_STACK_DEPTH = $0D36;

This item has no description.

GL_MAX_NAME_STACK_DEPTH = $0D37;

This item has no description.

GL_MAX_PROJECTION_STACK_DEPTH = $0D38;

This item has no description.

GL_MAX_TEXTURE_STACK_DEPTH = $0D39;

This item has no description.

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH = $0D3B;

This item has no description.

GL_INDEX_BITS = $0D51;

This item has no description.

GL_RED_BITS = $0D52;

This item has no description.

GL_GREEN_BITS = $0D53;

This item has no description.

GL_BLUE_BITS = $0D54;

This item has no description.

GL_ALPHA_BITS = $0D55;

This item has no description.

GL_DEPTH_BITS = $0D56;

This item has no description.

GL_STENCIL_BITS = $0D57;

This item has no description.

GL_ACCUM_RED_BITS = $0D58;

This item has no description.

GL_ACCUM_GREEN_BITS = $0D59;

This item has no description.

GL_ACCUM_BLUE_BITS = $0D5A;

This item has no description.

GL_ACCUM_ALPHA_BITS = $0D5B;

This item has no description.

GL_NAME_STACK_DEPTH = $0D70;

This item has no description.

GL_AUTO_NORMAL = $0D80;

This item has no description.

GL_MAP1_COLOR_4 = $0D90;

This item has no description.

GL_MAP1_INDEX = $0D91;

This item has no description.

GL_MAP1_NORMAL = $0D92;

This item has no description.

GL_MAP1_TEXTURE_COORD_1 = $0D93;

This item has no description.

GL_MAP1_TEXTURE_COORD_2 = $0D94;

This item has no description.

GL_MAP1_TEXTURE_COORD_3 = $0D95;

This item has no description.

GL_MAP1_TEXTURE_COORD_4 = $0D96;

This item has no description.

GL_MAP1_VERTEX_3 = $0D97;

This item has no description.

GL_MAP1_VERTEX_4 = $0D98;

This item has no description.

GL_MAP2_COLOR_4 = $0DB0;

This item has no description.

GL_MAP2_INDEX = $0DB1;

This item has no description.

GL_MAP2_NORMAL = $0DB2;

This item has no description.

GL_MAP2_TEXTURE_COORD_1 = $0DB3;

This item has no description.

GL_MAP2_TEXTURE_COORD_2 = $0DB4;

This item has no description.

GL_MAP2_TEXTURE_COORD_3 = $0DB5;

This item has no description.

GL_MAP2_TEXTURE_COORD_4 = $0DB6;

This item has no description.

GL_MAP2_VERTEX_3 = $0DB7;

This item has no description.

GL_MAP2_VERTEX_4 = $0DB8;

This item has no description.

GL_MAP1_GRID_DOMAIN = $0DD0;

This item has no description.

GL_MAP1_GRID_SEGMENTS = $0DD1;

This item has no description.

GL_MAP2_GRID_DOMAIN = $0DD2;

This item has no description.

GL_MAP2_GRID_SEGMENTS = $0DD3;

This item has no description.

GL_FEEDBACK_BUFFER_POINTER = $0DF0;

This item has no description.

GL_FEEDBACK_BUFFER_SIZE = $0DF1;

This item has no description.

GL_FEEDBACK_BUFFER_TYPE = $0DF2;

This item has no description.

GL_SELECTION_BUFFER_POINTER = $0DF3;

This item has no description.

GL_SELECTION_BUFFER_SIZE = $0DF4;

This item has no description.

GL_LIGHT0 = $4000;

This item has no description.

GL_LIGHT1 = $4001;

This item has no description.

GL_LIGHT2 = $4002;

This item has no description.

GL_LIGHT3 = $4003;

This item has no description.

GL_LIGHT4 = $4004;

This item has no description.

GL_LIGHT5 = $4005;

This item has no description.

GL_LIGHT6 = $4006;

This item has no description.

GL_LIGHT7 = $4007;

This item has no description.

GL_AMBIENT = $1200;

This item has no description.

GL_DIFFUSE = $1201;

This item has no description.

GL_SPECULAR = $1202;

This item has no description.

GL_POSITION = $1203;

This item has no description.

GL_SPOT_DIRECTION = $1204;

This item has no description.

GL_SPOT_EXPONENT = $1205;

This item has no description.

GL_SPOT_CUTOFF = $1206;

This item has no description.

GL_CONSTANT_ATTENUATION = $1207;

This item has no description.

GL_LINEAR_ATTENUATION = $1208;

This item has no description.

GL_QUADRATIC_ATTENUATION = $1209;

This item has no description.

GL_COMPILE = $1300;

This item has no description.

GL_COMPILE_AND_EXECUTE = $1301;

This item has no description.

GL_EMISSION = $1600;

This item has no description.

GL_SHININESS = $1601;

This item has no description.

GL_AMBIENT_AND_DIFFUSE = $1602;

This item has no description.

GL_COLOR_INDEXES = $1603;

This item has no description.

GL_MODELVIEW = $1700;

This item has no description.

GL_PROJECTION = $1701;

This item has no description.

GL_COLOR_INDEX = $1900;

This item has no description.

GL_LUMINANCE = $1909;

This item has no description.

GL_LUMINANCE_ALPHA = $190A;

This item has no description.

GL_BITMAP = $1A00;

This item has no description.

GL_RENDER = $1C00;

This item has no description.

GL_FEEDBACK = $1C01;

This item has no description.

GL_SELECT = $1C02;

This item has no description.

GL_FLAT = $1D00;

This item has no description.

GL_SMOOTH = $1D01;

This item has no description.

GL_S = $2000;

This item has no description.

GL_T = $2001;

This item has no description.

GL_R = $2002;

This item has no description.

GL_Q = $2003;

This item has no description.

GL_MODULATE = $2100;

This item has no description.

GL_DECAL = $2101;

This item has no description.

GL_TEXTURE_ENV_MODE = $2200;

This item has no description.

GL_TEXTURE_ENV_COLOR = $2201;

This item has no description.

GL_TEXTURE_ENV = $2300;

This item has no description.

GL_EYE_LINEAR = $2400;

This item has no description.

GL_OBJECT_LINEAR = $2401;

This item has no description.

GL_SPHERE_MAP = $2402;

This item has no description.

GL_TEXTURE_GEN_MODE = $2500;

This item has no description.

GL_OBJECT_PLANE = $2501;

This item has no description.

GL_EYE_PLANE = $2502;

This item has no description.

GL_CLAMP = $2900;

This item has no description.

GL_CLIENT_PIXEL_STORE_BIT = $00000001;

This item has no description.

GL_CLIENT_VERTEX_ARRAY_BIT = $00000002;

This item has no description.

GL_CLIENT_ALL_ATTRIB_BITS = $FFFFFFFF;

This item has no description.

GL_ALPHA4 = $803B;

This item has no description.

GL_ALPHA8 = $803C;

This item has no description.

GL_ALPHA12 = $803D;

This item has no description.

GL_ALPHA16 = $803E;

This item has no description.

GL_LUMINANCE4 = $803F;

This item has no description.

GL_LUMINANCE8 = $8040;

This item has no description.

GL_LUMINANCE12 = $8041;

This item has no description.

GL_LUMINANCE16 = $8042;

This item has no description.

GL_LUMINANCE4_ALPHA4 = $8043;

This item has no description.

GL_LUMINANCE6_ALPHA2 = $8044;

This item has no description.

GL_LUMINANCE8_ALPHA8 = $8045;

This item has no description.

GL_LUMINANCE12_ALPHA4 = $8046;

This item has no description.

GL_LUMINANCE12_ALPHA12 = $8047;

This item has no description.

GL_LUMINANCE16_ALPHA16 = $8048;

This item has no description.

GL_INTENSITY = $8049;

This item has no description.

GL_INTENSITY4 = $804A;

This item has no description.

GL_INTENSITY8 = $804B;

This item has no description.

GL_INTENSITY12 = $804C;

This item has no description.

GL_INTENSITY16 = $804D;

This item has no description.

GL_TEXTURE_LUMINANCE_SIZE = $8060;

This item has no description.

GL_TEXTURE_INTENSITY_SIZE = $8061;

This item has no description.

GL_TEXTURE_PRIORITY = $8066;

This item has no description.

GL_TEXTURE_RESIDENT = $8067;

This item has no description.

GL_VERTEX_ARRAY = $8074;

This item has no description.

GL_NORMAL_ARRAY = $8075;

This item has no description.

GL_COLOR_ARRAY = $8076;

This item has no description.

GL_INDEX_ARRAY = $8077;

This item has no description.

GL_TEXTURE_COORD_ARRAY = $8078;

This item has no description.

GL_EDGE_FLAG_ARRAY = $8079;

This item has no description.

GL_VERTEX_ARRAY_SIZE = $807A;

This item has no description.

GL_VERTEX_ARRAY_TYPE = $807B;

This item has no description.

GL_VERTEX_ARRAY_STRIDE = $807C;

This item has no description.

GL_NORMAL_ARRAY_TYPE = $807E;

This item has no description.

GL_NORMAL_ARRAY_STRIDE = $807F;

This item has no description.

GL_COLOR_ARRAY_SIZE = $8081;

This item has no description.

GL_COLOR_ARRAY_TYPE = $8082;

This item has no description.

GL_COLOR_ARRAY_STRIDE = $8083;

This item has no description.

GL_INDEX_ARRAY_TYPE = $8085;

This item has no description.

GL_INDEX_ARRAY_STRIDE = $8086;

This item has no description.

GL_TEXTURE_COORD_ARRAY_SIZE = $8088;

This item has no description.

GL_TEXTURE_COORD_ARRAY_TYPE = $8089;

This item has no description.

GL_TEXTURE_COORD_ARRAY_STRIDE = $808A;

This item has no description.

GL_EDGE_FLAG_ARRAY_STRIDE = $808C;

This item has no description.

GL_VERTEX_ARRAY_POINTER = $808E;

This item has no description.

GL_NORMAL_ARRAY_POINTER = $808F;

This item has no description.

GL_COLOR_ARRAY_POINTER = $8090;

This item has no description.

GL_INDEX_ARRAY_POINTER = $8091;

This item has no description.

GL_TEXTURE_COORD_ARRAY_POINTER = $8092;

This item has no description.

GL_EDGE_FLAG_ARRAY_POINTER = $8093;

This item has no description.

GL_V2F = $2A20;

This item has no description.

GL_V3F = $2A21;

This item has no description.

GL_C4UB_V2F = $2A22;

This item has no description.

GL_C4UB_V3F = $2A23;

This item has no description.

GL_C3F_V3F = $2A24;

This item has no description.

GL_N3F_V3F = $2A25;

This item has no description.

GL_C4F_N3F_V3F = $2A26;

This item has no description.

GL_T2F_V3F = $2A27;

This item has no description.

GL_T4F_V4F = $2A28;

This item has no description.

GL_T2F_C4UB_V3F = $2A29;

This item has no description.

GL_T2F_C3F_V3F = $2A2A;

This item has no description.

GL_T2F_N3F_V3F = $2A2B;

This item has no description.

GL_T2F_C4F_N3F_V3F = $2A2C;

This item has no description.

GL_T4F_C4F_N3F_V4F = $2A2D;

This item has no description.

GL_COLOR_TABLE_FORMAT_EXT = $80D8;

This item has no description.

GL_COLOR_TABLE_WIDTH_EXT = $80D9;

This item has no description.

GL_COLOR_TABLE_RED_SIZE_EXT = $80DA;

This item has no description.

GL_COLOR_TABLE_GREEN_SIZE_EXT = $80DB;

This item has no description.

GL_COLOR_TABLE_BLUE_SIZE_EXT = $80DC;

This item has no description.

GL_COLOR_TABLE_ALPHA_SIZE_EXT = $80DD;

This item has no description.

GL_COLOR_TABLE_LUMINANCE_SIZE_EXT = $80DE;

This item has no description.

GL_COLOR_TABLE_INTENSITY_SIZE_EXT = $80DF;

This item has no description.

GL_LOGIC_OP = GL_INDEX_LOGIC_OP;

This item has no description.

GL_TEXTURE_COMPONENTS = GL_TEXTURE_INTERNAL_FORMAT;

This item has no description.

GL_UNSIGNED_BYTE_3_3_2 = $8032;

GL_VERSION_1_2

GL_UNSIGNED_SHORT_4_4_4_4 = $8033;

This item has no description.

GL_UNSIGNED_SHORT_5_5_5_1 = $8034;

This item has no description.

GL_UNSIGNED_INT_8_8_8_8 = $8035;

This item has no description.

GL_UNSIGNED_INT_10_10_10_2 = $8036;

This item has no description.

GL_TEXTURE_BINDING_3D = $806A;

This item has no description.

GL_PACK_SKIP_IMAGES = $806B;

This item has no description.

GL_PACK_IMAGE_HEIGHT = $806C;

This item has no description.

GL_UNPACK_SKIP_IMAGES = $806D;

This item has no description.

GL_UNPACK_IMAGE_HEIGHT = $806E;

This item has no description.

GL_TEXTURE_3D = $806F;

This item has no description.

GL_PROXY_TEXTURE_3D = $8070;

This item has no description.

GL_TEXTURE_DEPTH = $8071;

This item has no description.

GL_TEXTURE_WRAP_R = $8072;

This item has no description.

GL_MAX_3D_TEXTURE_SIZE = $8073;

This item has no description.

GL_UNSIGNED_BYTE_2_3_3_REV = $8362;

This item has no description.

GL_UNSIGNED_SHORT_5_6_5 = $8363;

This item has no description.

GL_UNSIGNED_SHORT_5_6_5_REV = $8364;

This item has no description.

GL_UNSIGNED_SHORT_4_4_4_4_REV = $8365;

This item has no description.

GL_UNSIGNED_SHORT_1_5_5_5_REV = $8366;

This item has no description.

GL_UNSIGNED_INT_8_8_8_8_REV = $8367;

This item has no description.

GL_UNSIGNED_INT_2_10_10_10_REV = $8368;

This item has no description.

GL_BGR = $80E0;

This item has no description.

GL_BGRA = $80E1;

This item has no description.

GL_MAX_ELEMENTS_VERTICES = $80E8;

This item has no description.

GL_MAX_ELEMENTS_INDICES = $80E9;

This item has no description.

GL_CLAMP_TO_EDGE = $812F;

This item has no description.

GL_TEXTURE_MIN_LOD = $813A;

This item has no description.

GL_TEXTURE_MAX_LOD = $813B;

This item has no description.

GL_TEXTURE_BASE_LEVEL = $813C;

This item has no description.

GL_TEXTURE_MAX_LEVEL = $813D;

This item has no description.

GL_SMOOTH_POINT_SIZE_RANGE = $0B12;

This item has no description.

GL_SMOOTH_POINT_SIZE_GRANULARITY = $0B13;

This item has no description.

GL_SMOOTH_LINE_WIDTH_RANGE = $0B22;

This item has no description.

GL_SMOOTH_LINE_WIDTH_GRANULARITY = $0B23;

This item has no description.

GL_ALIASED_LINE_WIDTH_RANGE = $846E;

This item has no description.

GL_RESCALE_NORMAL = $803A;

This item has no description.

GL_LIGHT_MODEL_COLOR_CONTROL = $81F8;

This item has no description.

GL_SINGLE_COLOR = $81F9;

This item has no description.

GL_SEPARATE_SPECULAR_COLOR = $81FA;

This item has no description.

GL_ALIASED_POINT_SIZE_RANGE = $846D;

This item has no description.

GL_TEXTURE0 = $84C0;

GL_VERSION_1_3

GL_TEXTURE1 = $84C1;

This item has no description.

GL_TEXTURE2 = $84C2;

This item has no description.

GL_TEXTURE3 = $84C3;

This item has no description.

GL_TEXTURE4 = $84C4;

This item has no description.

GL_TEXTURE5 = $84C5;

This item has no description.

GL_TEXTURE6 = $84C6;

This item has no description.

GL_TEXTURE7 = $84C7;

This item has no description.

GL_TEXTURE8 = $84C8;

This item has no description.

GL_TEXTURE9 = $84C9;

This item has no description.

GL_TEXTURE10 = $84CA;

This item has no description.

GL_TEXTURE11 = $84CB;

This item has no description.

GL_TEXTURE12 = $84CC;

This item has no description.

GL_TEXTURE13 = $84CD;

This item has no description.

GL_TEXTURE14 = $84CE;

This item has no description.

GL_TEXTURE15 = $84CF;

This item has no description.

GL_TEXTURE16 = $84D0;

This item has no description.

GL_TEXTURE17 = $84D1;

This item has no description.

GL_TEXTURE18 = $84D2;

This item has no description.

GL_TEXTURE19 = $84D3;

This item has no description.

GL_TEXTURE20 = $84D4;

This item has no description.

GL_TEXTURE21 = $84D5;

This item has no description.

GL_TEXTURE22 = $84D6;

This item has no description.

GL_TEXTURE23 = $84D7;

This item has no description.

GL_TEXTURE24 = $84D8;

This item has no description.

GL_TEXTURE25 = $84D9;

This item has no description.

GL_TEXTURE26 = $84DA;

This item has no description.

GL_TEXTURE27 = $84DB;

This item has no description.

GL_TEXTURE28 = $84DC;

This item has no description.

GL_TEXTURE29 = $84DD;

This item has no description.

GL_TEXTURE30 = $84DE;

This item has no description.

GL_TEXTURE31 = $84DF;

This item has no description.

GL_ACTIVE_TEXTURE = $84E0;

This item has no description.

GL_MULTISAMPLE = $809D;

This item has no description.

GL_SAMPLE_ALPHA_TO_COVERAGE = $809E;

This item has no description.

GL_SAMPLE_ALPHA_TO_ONE = $809F;

This item has no description.

GL_SAMPLE_COVERAGE = $80A0;

This item has no description.

GL_SAMPLE_BUFFERS = $80A8;

This item has no description.

GL_SAMPLES = $80A9;

This item has no description.

GL_SAMPLE_COVERAGE_VALUE = $80AA;

This item has no description.

GL_SAMPLE_COVERAGE_INVERT = $80AB;

This item has no description.

GL_TEXTURE_CUBE_MAP = $8513;

This item has no description.

GL_TEXTURE_BINDING_CUBE_MAP = $8514;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_X = $8515;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_X = $8516;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Y = $8517;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y = $8518;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Z = $8519;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z = $851A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP = $851B;

This item has no description.

GL_MAX_CUBE_MAP_TEXTURE_SIZE = $851C;

This item has no description.

GL_COMPRESSED_RGB = $84ED;

This item has no description.

GL_COMPRESSED_RGBA = $84EE;

This item has no description.

GL_TEXTURE_COMPRESSION_HINT = $84EF;

This item has no description.

GL_TEXTURE_COMPRESSED_IMAGE_SIZE = $86A0;

This item has no description.

GL_TEXTURE_COMPRESSED = $86A1;

This item has no description.

GL_NUM_COMPRESSED_TEXTURE_FORMATS = $86A2;

This item has no description.

GL_COMPRESSED_TEXTURE_FORMATS = $86A3;

This item has no description.

GL_CLAMP_TO_BORDER = $812D;

This item has no description.

GL_CLIENT_ACTIVE_TEXTURE = $84E1;

This item has no description.

GL_MAX_TEXTURE_UNITS = $84E2;

This item has no description.

GL_TRANSPOSE_MODELVIEW_MATRIX = $84E3;

This item has no description.

GL_TRANSPOSE_PROJECTION_MATRIX = $84E4;

This item has no description.

GL_TRANSPOSE_TEXTURE_MATRIX = $84E5;

This item has no description.

GL_TRANSPOSE_COLOR_MATRIX = $84E6;

This item has no description.

GL_MULTISAMPLE_BIT = $20000000;

This item has no description.

GL_NORMAL_MAP = $8511;

This item has no description.

GL_REFLECTION_MAP = $8512;

This item has no description.

GL_COMPRESSED_ALPHA = $84E9;

This item has no description.

GL_COMPRESSED_LUMINANCE = $84EA;

This item has no description.

GL_COMPRESSED_LUMINANCE_ALPHA = $84EB;

This item has no description.

GL_COMPRESSED_INTENSITY = $84EC;

This item has no description.

GL_COMBINE = $8570;

This item has no description.

GL_COMBINE_RGB = $8571;

This item has no description.

GL_COMBINE_ALPHA = $8572;

This item has no description.

GL_SOURCE0_RGB = $8580;

This item has no description.

GL_SOURCE1_RGB = $8581;

This item has no description.

GL_SOURCE2_RGB = $8582;

This item has no description.

GL_SOURCE0_ALPHA = $8588;

This item has no description.

GL_SOURCE1_ALPHA = $8589;

This item has no description.

GL_SOURCE2_ALPHA = $858A;

This item has no description.

GL_OPERAND0_RGB = $8590;

This item has no description.

GL_OPERAND1_RGB = $8591;

This item has no description.

GL_OPERAND2_RGB = $8592;

This item has no description.

GL_OPERAND0_ALPHA = $8598;

This item has no description.

GL_OPERAND1_ALPHA = $8599;

This item has no description.

GL_OPERAND2_ALPHA = $859A;

This item has no description.

GL_RGB_SCALE = $8573;

This item has no description.

GL_ADD_SIGNED = $8574;

This item has no description.

GL_INTERPOLATE = $8575;

This item has no description.

GL_SUBTRACT = $84E7;

This item has no description.

GL_CONSTANT = $8576;

This item has no description.

GL_PRIMARY_COLOR = $8577;

This item has no description.

GL_PREVIOUS = $8578;

This item has no description.

GL_DOT3_RGB = $86AE;

This item has no description.

GL_DOT3_RGBA = $86AF;

This item has no description.

GL_BLEND_DST_RGB = $80C8;

GL_VERSION_1_4

GL_BLEND_SRC_RGB = $80C9;

This item has no description.

GL_BLEND_DST_ALPHA = $80CA;

This item has no description.

GL_BLEND_SRC_ALPHA = $80CB;

This item has no description.

GL_POINT_FADE_THRESHOLD_SIZE = $8128;

This item has no description.

GL_DEPTH_COMPONENT16 = $81A5;

This item has no description.

GL_DEPTH_COMPONENT24 = $81A6;

This item has no description.

GL_DEPTH_COMPONENT32 = $81A7;

This item has no description.

GL_MIRRORED_REPEAT = $8370;

This item has no description.

GL_MAX_TEXTURE_LOD_BIAS = $84FD;

This item has no description.

GL_TEXTURE_LOD_BIAS = $8501;

This item has no description.

GL_INCR_WRAP = $8507;

This item has no description.

GL_DECR_WRAP = $8508;

This item has no description.

GL_TEXTURE_DEPTH_SIZE = $884A;

This item has no description.

GL_TEXTURE_COMPARE_MODE = $884C;

This item has no description.

GL_TEXTURE_COMPARE_FUNC = $884D;

This item has no description.

GL_POINT_SIZE_MIN = $8126;

This item has no description.

GL_POINT_SIZE_MAX = $8127;

This item has no description.

GL_POINT_DISTANCE_ATTENUATION = $8129;

This item has no description.

GL_GENERATE_MIPMAP = $8191;

This item has no description.

GL_GENERATE_MIPMAP_HINT = $8192;

This item has no description.

GL_FOG_COORDINATE_SOURCE = $8450;

This item has no description.

GL_FOG_COORDINATE = $8451;

This item has no description.

GL_FRAGMENT_DEPTH = $8452;

This item has no description.

GL_CURRENT_FOG_COORDINATE = $8453;

This item has no description.

GL_FOG_COORDINATE_ARRAY_TYPE = $8454;

This item has no description.

GL_FOG_COORDINATE_ARRAY_STRIDE = $8455;

This item has no description.

GL_FOG_COORDINATE_ARRAY_POINTER = $8456;

This item has no description.

GL_FOG_COORDINATE_ARRAY = $8457;

This item has no description.

GL_COLOR_SUM = $8458;

This item has no description.

GL_CURRENT_SECONDARY_COLOR = $8459;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_SIZE = $845A;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_TYPE = $845B;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_STRIDE = $845C;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_POINTER = $845D;

This item has no description.

GL_SECONDARY_COLOR_ARRAY = $845E;

This item has no description.

GL_TEXTURE_FILTER_CONTROL = $8500;

This item has no description.

GL_DEPTH_TEXTURE_MODE = $884B;

This item has no description.

GL_COMPARE_R_TO_TEXTURE = $884E;

This item has no description.

GL_BUFFER_SIZE = $8764;

GL_VERSION_1_5

GL_BUFFER_USAGE = $8765;

This item has no description.

GL_QUERY_COUNTER_BITS = $8864;

This item has no description.

GL_CURRENT_QUERY = $8865;

This item has no description.

GL_QUERY_RESULT = $8866;

This item has no description.

GL_QUERY_RESULT_AVAILABLE = $8867;

This item has no description.

GL_ARRAY_BUFFER = $8892;

This item has no description.

GL_ELEMENT_ARRAY_BUFFER = $8893;

This item has no description.

GL_ARRAY_BUFFER_BINDING = $8894;

This item has no description.

GL_ELEMENT_ARRAY_BUFFER_BINDING = $8895;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING = $889F;

This item has no description.

GL_READ_ONLY = $88B8;

This item has no description.

GL_WRITE_ONLY = $88B9;

This item has no description.

GL_READ_WRITE = $88BA;

This item has no description.

GL_BUFFER_ACCESS = $88BB;

This item has no description.

GL_BUFFER_MAPPED = $88BC;

This item has no description.

GL_BUFFER_MAP_POINTER = $88BD;

This item has no description.

GL_STREAM_DRAW = $88E0;

This item has no description.

GL_STREAM_READ = $88E1;

This item has no description.

GL_STREAM_COPY = $88E2;

This item has no description.

GL_STATIC_DRAW = $88E4;

This item has no description.

GL_STATIC_READ = $88E5;

This item has no description.

GL_STATIC_COPY = $88E6;

This item has no description.

GL_DYNAMIC_DRAW = $88E8;

This item has no description.

GL_DYNAMIC_READ = $88E9;

This item has no description.

GL_DYNAMIC_COPY = $88EA;

This item has no description.

GL_SAMPLES_PASSED = $8914;

This item has no description.

GL_VERTEX_ARRAY_BUFFER_BINDING = $8896;

This item has no description.

GL_NORMAL_ARRAY_BUFFER_BINDING = $8897;

This item has no description.

GL_COLOR_ARRAY_BUFFER_BINDING = $8898;

This item has no description.

GL_INDEX_ARRAY_BUFFER_BINDING = $8899;

This item has no description.

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING = $889A;

This item has no description.

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING = $889B;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING = $889C;

This item has no description.

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING = $889D;

This item has no description.

GL_WEIGHT_ARRAY_BUFFER_BINDING = $889E;

This item has no description.

GL_FOG_COORD_SRC = $8450;

This item has no description.

GL_FOG_COORD = $8451;

This item has no description.

GL_CURRENT_FOG_COORD = $8453;

This item has no description.

GL_FOG_COORD_ARRAY_TYPE = $8454;

This item has no description.

GL_FOG_COORD_ARRAY_STRIDE = $8455;

This item has no description.

GL_FOG_COORD_ARRAY_POINTER = $8456;

This item has no description.

GL_FOG_COORD_ARRAY = $8457;

This item has no description.

GL_FOG_COORD_ARRAY_BUFFER_BINDING = $889D;

This item has no description.

GL_SRC0_RGB = $8580;

This item has no description.

GL_SRC1_RGB = $8581;

This item has no description.

GL_SRC2_RGB = $8582;

This item has no description.

GL_SRC0_ALPHA = $8588;

This item has no description.

GL_SRC1_ALPHA = $8589;

This item has no description.

GL_SRC2_ALPHA = $858A;

This item has no description.

GL_BLEND_EQUATION_RGB = $8009;

GL_VERSION_2_0

GL_VERTEX_ATTRIB_ARRAY_ENABLED = $8622;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_SIZE = $8623;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_STRIDE = $8624;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_TYPE = $8625;

This item has no description.

GL_CURRENT_VERTEX_ATTRIB = $8626;

This item has no description.

GL_VERTEX_PROGRAM_POINT_SIZE = $8642;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_POINTER = $8645;

This item has no description.

GL_STENCIL_BACK_FUNC = $8800;

This item has no description.

GL_STENCIL_BACK_FAIL = $8801;

This item has no description.

GL_STENCIL_BACK_PASS_DEPTH_FAIL = $8802;

This item has no description.

GL_STENCIL_BACK_PASS_DEPTH_PASS = $8803;

This item has no description.

GL_MAX_DRAW_BUFFERS = $8824;

This item has no description.

GL_DRAW_BUFFER0 = $8825;

This item has no description.

GL_DRAW_BUFFER1 = $8826;

This item has no description.

GL_DRAW_BUFFER2 = $8827;

This item has no description.

GL_DRAW_BUFFER3 = $8828;

This item has no description.

GL_DRAW_BUFFER4 = $8829;

This item has no description.

GL_DRAW_BUFFER5 = $882A;

This item has no description.

GL_DRAW_BUFFER6 = $882B;

This item has no description.

GL_DRAW_BUFFER7 = $882C;

This item has no description.

GL_DRAW_BUFFER8 = $882D;

This item has no description.

GL_DRAW_BUFFER9 = $882E;

This item has no description.

GL_DRAW_BUFFER10 = $882F;

This item has no description.

GL_DRAW_BUFFER11 = $8830;

This item has no description.

GL_DRAW_BUFFER12 = $8831;

This item has no description.

GL_DRAW_BUFFER13 = $8832;

This item has no description.

GL_DRAW_BUFFER14 = $8833;

This item has no description.

GL_DRAW_BUFFER15 = $8834;

This item has no description.

GL_BLEND_EQUATION_ALPHA = $883D;

This item has no description.

GL_MAX_VERTEX_ATTRIBS = $8869;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED = $886A;

This item has no description.

GL_MAX_TEXTURE_IMAGE_UNITS = $8872;

This item has no description.

GL_FRAGMENT_SHADER = $8B30;

This item has no description.

GL_VERTEX_SHADER = $8B31;

This item has no description.

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS = $8B49;

This item has no description.

GL_MAX_VERTEX_UNIFORM_COMPONENTS = $8B4A;

This item has no description.

GL_MAX_VARYING_FLOATS = $8B4B;

This item has no description.

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = $8B4C;

This item has no description.

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS = $8B4D;

This item has no description.

GL_SHADER_TYPE = $8B4F;

This item has no description.

GL_FLOAT_VEC2 = $8B50;

This item has no description.

GL_FLOAT_VEC3 = $8B51;

This item has no description.

GL_FLOAT_VEC4 = $8B52;

This item has no description.

GL_INT_VEC2 = $8B53;

This item has no description.

GL_INT_VEC3 = $8B54;

This item has no description.

GL_INT_VEC4 = $8B55;

This item has no description.

GL_BOOL = $8B56;

This item has no description.

GL_BOOL_VEC2 = $8B57;

This item has no description.

GL_BOOL_VEC3 = $8B58;

This item has no description.

GL_BOOL_VEC4 = $8B59;

This item has no description.

GL_FLOAT_MAT2 = $8B5A;

This item has no description.

GL_FLOAT_MAT3 = $8B5B;

This item has no description.

GL_FLOAT_MAT4 = $8B5C;

This item has no description.

GL_SAMPLER_1D = $8B5D;

This item has no description.

GL_SAMPLER_2D = $8B5E;

This item has no description.

GL_SAMPLER_3D = $8B5F;

This item has no description.

GL_SAMPLER_CUBE = $8B60;

This item has no description.

GL_SAMPLER_1D_SHADOW = $8B61;

This item has no description.

GL_SAMPLER_2D_SHADOW = $8B62;

This item has no description.

GL_DELETE_STATUS = $8B80;

This item has no description.

GL_COMPILE_STATUS = $8B81;

This item has no description.

GL_LINK_STATUS = $8B82;

This item has no description.

GL_VALIDATE_STATUS = $8B83;

This item has no description.

GL_INFO_LOG_LENGTH = $8B84;

This item has no description.

GL_ATTACHED_SHADERS = $8B85;

This item has no description.

GL_ACTIVE_UNIFORMS = $8B86;

This item has no description.

GL_ACTIVE_UNIFORM_MAX_LENGTH = $8B87;

This item has no description.

GL_SHADER_SOURCE_LENGTH = $8B88;

This item has no description.

GL_ACTIVE_ATTRIBUTES = $8B89;

This item has no description.

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH = $8B8A;

This item has no description.

GL_FRAGMENT_SHADER_DERIVATIVE_HINT = $8B8B;

This item has no description.

GL_SHADING_LANGUAGE_VERSION = $8B8C;

This item has no description.

GL_CURRENT_PROGRAM = $8B8D;

This item has no description.

GL_POINT_SPRITE_COORD_ORIGIN = $8CA0;

This item has no description.

GL_LOWER_LEFT = $8CA1;

This item has no description.

GL_UPPER_LEFT = $8CA2;

This item has no description.

GL_STENCIL_BACK_REF = $8CA3;

This item has no description.

GL_STENCIL_BACK_VALUE_MASK = $8CA4;

This item has no description.

GL_STENCIL_BACK_WRITEMASK = $8CA5;

This item has no description.

GL_VERTEX_PROGRAM_TWO_SIDE = $8643;

This item has no description.

GL_POINT_SPRITE = $8861;

This item has no description.

GL_COORD_REPLACE = $8862;

This item has no description.

GL_MAX_TEXTURE_COORDS = $8871;

This item has no description.

GL_PIXEL_PACK_BUFFER = $88EB;

GL_VERSION_2_1

GL_PIXEL_UNPACK_BUFFER = $88EC;

This item has no description.

GL_PIXEL_PACK_BUFFER_BINDING = $88ED;

This item has no description.

GL_PIXEL_UNPACK_BUFFER_BINDING = $88EF;

This item has no description.

GL_FLOAT_MAT2x3 = $8B65;

This item has no description.

GL_FLOAT_MAT2x4 = $8B66;

This item has no description.

GL_FLOAT_MAT3x2 = $8B67;

This item has no description.

GL_FLOAT_MAT3x4 = $8B68;

This item has no description.

GL_FLOAT_MAT4x2 = $8B69;

This item has no description.

GL_FLOAT_MAT4x3 = $8B6A;

This item has no description.

GL_SRGB = $8C40;

This item has no description.

GL_SRGB8 = $8C41;

This item has no description.

GL_SRGB_ALPHA = $8C42;

This item has no description.

GL_SRGB8_ALPHA8 = $8C43;

This item has no description.

GL_COMPRESSED_SRGB = $8C48;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA = $8C49;

This item has no description.

GL_CURRENT_RASTER_SECONDARY_COLOR = $845F;

This item has no description.

GL_SLUMINANCE_ALPHA = $8C44;

This item has no description.

GL_SLUMINANCE8_ALPHA8 = $8C45;

This item has no description.

GL_SLUMINANCE = $8C46;

This item has no description.

GL_SLUMINANCE8 = $8C47;

This item has no description.

GL_COMPRESSED_SLUMINANCE = $8C4A;

This item has no description.

GL_COMPRESSED_SLUMINANCE_ALPHA = $8C4B;

This item has no description.

GL_COMPARE_REF_TO_TEXTURE = $884E;

GL_VERSION_3_0

GL_CLIP_DISTANCE0 = $3000;

This item has no description.

GL_CLIP_DISTANCE1 = $3001;

This item has no description.

GL_CLIP_DISTANCE2 = $3002;

This item has no description.

GL_CLIP_DISTANCE3 = $3003;

This item has no description.

GL_CLIP_DISTANCE4 = $3004;

This item has no description.

GL_CLIP_DISTANCE5 = $3005;

This item has no description.

GL_CLIP_DISTANCE6 = $3006;

This item has no description.

GL_CLIP_DISTANCE7 = $3007;

This item has no description.

GL_MAX_CLIP_DISTANCES = $0D32;

This item has no description.

GL_MAJOR_VERSION = $821B;

This item has no description.

GL_MINOR_VERSION = $821C;

This item has no description.

GL_NUM_EXTENSIONS = $821D;

This item has no description.

GL_CONTEXT_FLAGS = $821E;

This item has no description.

GL_DEPTH_BUFFER = $8223;

This item has no description.

GL_STENCIL_BUFFER = $8224;

This item has no description.

GL_COMPRESSED_RED = $8225;

This item has no description.

GL_COMPRESSED_RG = $8226;

This item has no description.

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT = $0001;

This item has no description.

GL_RGBA32F = $8814;

This item has no description.

GL_RGB32F = $8815;

This item has no description.

GL_RGBA16F = $881A;

This item has no description.

GL_RGB16F = $881B;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_INTEGER = $88FD;

This item has no description.

GL_MAX_ARRAY_TEXTURE_LAYERS = $88FF;

This item has no description.

GL_MIN_PROGRAM_TEXEL_OFFSET = $8904;

This item has no description.

GL_MAX_PROGRAM_TEXEL_OFFSET = $8905;

This item has no description.

GL_CLAMP_READ_COLOR = $891C;

This item has no description.

GL_FIXED_ONLY = $891D;

This item has no description.

GL_MAX_VARYING_COMPONENTS = $8B4B;

This item has no description.

GL_TEXTURE_1D_ARRAY = $8C18;

This item has no description.

GL_PROXY_TEXTURE_1D_ARRAY = $8C19;

This item has no description.

GL_TEXTURE_2D_ARRAY = $8C1A;

This item has no description.

GL_PROXY_TEXTURE_2D_ARRAY = $8C1B;

This item has no description.

GL_TEXTURE_BINDING_1D_ARRAY = $8C1C;

This item has no description.

GL_TEXTURE_BINDING_2D_ARRAY = $8C1D;

This item has no description.

GL_R11F_G11F_B10F = $8C3A;

This item has no description.

GL_UNSIGNED_INT_10F_11F_11F_REV = $8C3B;

This item has no description.

GL_RGB9_E5 = $8C3D;

This item has no description.

GL_UNSIGNED_INT_5_9_9_9_REV = $8C3E;

This item has no description.

GL_TEXTURE_SHARED_SIZE = $8C3F;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH = $8C76;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_MODE = $8C7F;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS = $8C80;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYINGS = $8C83;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_START = $8C84;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE = $8C85;

This item has no description.

GL_PRIMITIVES_GENERATED = $8C87;

This item has no description.

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN = $8C88;

This item has no description.

GL_RASTERIZER_DISCARD = $8C89;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS = $8C8A;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS = $8C8B;

This item has no description.

GL_INTERLEAVED_ATTRIBS = $8C8C;

This item has no description.

GL_SEPARATE_ATTRIBS = $8C8D;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER = $8C8E;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING = $8C8F;

This item has no description.

GL_RGBA32UI = $8D70;

This item has no description.

GL_RGB32UI = $8D71;

This item has no description.

GL_RGBA16UI = $8D76;

This item has no description.

GL_RGB16UI = $8D77;

This item has no description.

GL_RGBA8UI = $8D7C;

This item has no description.

GL_RGB8UI = $8D7D;

This item has no description.

GL_RGBA32I = $8D82;

This item has no description.

GL_RGB32I = $8D83;

This item has no description.

GL_RGBA16I = $8D88;

This item has no description.

GL_RGB16I = $8D89;

This item has no description.

GL_RGBA8I = $8D8E;

This item has no description.

GL_RGB8I = $8D8F;

This item has no description.

GL_RED_INTEGER = $8D94;

This item has no description.

GL_GREEN_INTEGER = $8D95;

This item has no description.

GL_BLUE_INTEGER = $8D96;

This item has no description.

GL_RGB_INTEGER = $8D98;

This item has no description.

GL_RGBA_INTEGER = $8D99;

This item has no description.

GL_BGR_INTEGER = $8D9A;

This item has no description.

GL_BGRA_INTEGER = $8D9B;

This item has no description.

GL_SAMPLER_1D_ARRAY = $8DC0;

This item has no description.

GL_SAMPLER_2D_ARRAY = $8DC1;

This item has no description.

GL_SAMPLER_1D_ARRAY_SHADOW = $8DC3;

This item has no description.

GL_SAMPLER_2D_ARRAY_SHADOW = $8DC4;

This item has no description.

GL_SAMPLER_CUBE_SHADOW = $8DC5;

This item has no description.

GL_UNSIGNED_INT_VEC2 = $8DC6;

This item has no description.

GL_UNSIGNED_INT_VEC3 = $8DC7;

This item has no description.

GL_UNSIGNED_INT_VEC4 = $8DC8;

This item has no description.

GL_INT_SAMPLER_1D = $8DC9;

This item has no description.

GL_INT_SAMPLER_2D = $8DCA;

This item has no description.

GL_INT_SAMPLER_3D = $8DCB;

This item has no description.

GL_INT_SAMPLER_CUBE = $8DCC;

This item has no description.

GL_INT_SAMPLER_1D_ARRAY = $8DCE;

This item has no description.

GL_INT_SAMPLER_2D_ARRAY = $8DCF;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_1D = $8DD1;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D = $8DD2;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_3D = $8DD3;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_CUBE = $8DD4;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY = $8DD6;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY = $8DD7;

This item has no description.

GL_QUERY_WAIT = $8E13;

This item has no description.

GL_QUERY_NO_WAIT = $8E14;

This item has no description.

GL_QUERY_BY_REGION_WAIT = $8E15;

This item has no description.

GL_QUERY_BY_REGION_NO_WAIT = $8E16;

This item has no description.

GL_BUFFER_ACCESS_FLAGS = $911F;

This item has no description.

GL_BUFFER_MAP_LENGTH = $9120;

This item has no description.

GL_BUFFER_MAP_OFFSET = $9121;

This item has no description.

GL_CLAMP_VERTEX_COLOR = $891A;

This item has no description.

GL_CLAMP_FRAGMENT_COLOR = $891B;

This item has no description.

GL_ALPHA_INTEGER = $8D97;

This item has no description.

GL_SAMPLER_2D_RECT = $8B63;

GL_VERSION_3_1

GL_SAMPLER_2D_RECT_SHADOW = $8B64;

This item has no description.

GL_SAMPLER_BUFFER = $8DC2;

This item has no description.

GL_INT_SAMPLER_2D_RECT = $8DCD;

This item has no description.

GL_INT_SAMPLER_BUFFER = $8DD0;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_RECT = $8DD5;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_BUFFER = $8DD8;

This item has no description.

GL_TEXTURE_BUFFER = $8C2A;

This item has no description.

GL_MAX_TEXTURE_BUFFER_SIZE = $8C2B;

This item has no description.

GL_TEXTURE_BINDING_BUFFER = $8C2C;

This item has no description.

GL_TEXTURE_BUFFER_DATA_STORE_BINDING = $8C2D;

This item has no description.

GL_TEXTURE_BUFFER_FORMAT = $8C2E;

This item has no description.

GL_TEXTURE_RECTANGLE = $84F5;

This item has no description.

GL_TEXTURE_BINDING_RECTANGLE = $84F6;

This item has no description.

GL_PROXY_TEXTURE_RECTANGLE = $84F7;

This item has no description.

GL_MAX_RECTANGLE_TEXTURE_SIZE = $84F8;

This item has no description.

GL_RED_SNORM = $8F90;

This item has no description.

GL_RG_SNORM = $8F91;

This item has no description.

GL_RGB_SNORM = $8F92;

This item has no description.

GL_RGBA_SNORM = $8F93;

This item has no description.

GL_R8_SNORM = $8F94;

This item has no description.

GL_RG8_SNORM = $8F95;

This item has no description.

GL_RGB8_SNORM = $8F96;

This item has no description.

GL_RGBA8_SNORM = $8F97;

This item has no description.

GL_R16_SNORM = $8F98;

This item has no description.

GL_RG16_SNORM = $8F99;

This item has no description.

GL_RGB16_SNORM = $8F9A;

This item has no description.

GL_RGBA16_SNORM = $8F9B;

This item has no description.

GL_SIGNED_NORMALIZED = $8F9C;

This item has no description.

GL_PRIMITIVE_RESTART = $8F9D;

This item has no description.

GL_PRIMITIVE_RESTART_INDEX = $8F9E;

This item has no description.

GL_CONTEXT_CORE_PROFILE_BIT = $00000001;

GL_VERSION_3_2

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT = $00000002;

This item has no description.

GL_LINES_ADJACENCY = $000A;

This item has no description.

GL_LINE_STRIP_ADJACENCY = $000B;

This item has no description.

GL_TRIANGLES_ADJACENCY = $000C;

This item has no description.

GL_TRIANGLE_STRIP_ADJACENCY = $000D;

This item has no description.

GL_PROGRAM_POINT_SIZE = $8642;

This item has no description.

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS = $8C29;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_LAYERED = $8DA7;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS = $8DA8;

This item has no description.

GL_GEOMETRY_SHADER = $8DD9;

This item has no description.

GL_GEOMETRY_VERTICES_OUT = $8916;

This item has no description.

GL_GEOMETRY_INPUT_TYPE = $8917;

This item has no description.

GL_GEOMETRY_OUTPUT_TYPE = $8918;

This item has no description.

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS = $8DDF;

This item has no description.

GL_MAX_GEOMETRY_OUTPUT_VERTICES = $8DE0;

This item has no description.

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS = $8DE1;

This item has no description.

GL_MAX_VERTEX_OUTPUT_COMPONENTS = $9122;

This item has no description.

GL_MAX_GEOMETRY_INPUT_COMPONENTS = $9123;

This item has no description.

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS = $9124;

This item has no description.

GL_MAX_FRAGMENT_INPUT_COMPONENTS = $9125;

This item has no description.

GL_CONTEXT_PROFILE_MASK = $9126;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_DIVISOR = $88FE;

GL_VERSION_3_3

GL_SAMPLE_SHADING = $8C36;

GL_VERSION_4_0

GL_MIN_SAMPLE_SHADING_VALUE = $8C37;

This item has no description.

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5E;

This item has no description.

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5F;

This item has no description.

GL_TEXTURE_CUBE_MAP_ARRAY = $9009;

This item has no description.

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY = $900A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY = $900B;

This item has no description.

GL_SAMPLER_CUBE_MAP_ARRAY = $900C;

This item has no description.

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW = $900D;

This item has no description.

GL_INT_SAMPLER_CUBE_MAP_ARRAY = $900E;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY = $900F;

This item has no description.

GL_NUM_SHADING_LANGUAGE_VERSIONS = $82E9;

GL_VERSION_4_1 GL_VERSION_4_2 GL_VERSION_4_3

GL_VERTEX_ATTRIB_ARRAY_LONG = $874E;

This item has no description.

GL_MULTISAMPLE_3DFX = $86B2;

GL_3DFX_multisample

GL_SAMPLE_BUFFERS_3DFX = $86B3;

This item has no description.

GL_SAMPLES_3DFX = $86B4;

This item has no description.

GL_MULTISAMPLE_BIT_3DFX = $20000000;

This item has no description.

GL_COMPRESSED_RGB_FXT1_3DFX = $86B0;

GL_3DFX_texture_compression_FXT1

GL_COMPRESSED_RGBA_FXT1_3DFX = $86B1;

This item has no description.

GL_UNPACK_CLIENT_STORAGE_APPLE = $85B2;

GL_APPLE_client_storage

GL_ELEMENT_ARRAY_APPLE = $8A0C;

GL_APPLE_element_array

GL_ELEMENT_ARRAY_TYPE_APPLE = $8A0D;

This item has no description.

GL_ELEMENT_ARRAY_POINTER_APPLE = $8A0E;

This item has no description.

GL_DRAW_PIXELS_APPLE = $8A0A;

GL_APPLE_fence

GL_FENCE_APPLE = $8A0B;

This item has no description.

GL_LIGHT_MODEL_SPECULAR_VECTOR_APPLE = $85B0;

GL_APPLE_specular_vector

GL_TRANSFORM_HINT_APPLE = $85B1;

GL_APPLE_transform_hint

GL_VERTEX_ARRAY_BINDING_APPLE = $85B5;

GL_APPLE_vertex_array_object

GL_VERTEX_ARRAY_RANGE_APPLE = $851D;

GL_APPLE_vertex_array_range

GL_VERTEX_ARRAY_RANGE_LENGTH_APPLE = $851E;

This item has no description.

GL_VERTEX_ARRAY_STORAGE_HINT_APPLE = $851F;

This item has no description.

GL_VERTEX_ARRAY_RANGE_POINTER_APPLE = $8521;

This item has no description.

GL_STORAGE_CLIENT_APPLE = $85B4;

This item has no description.

GL_STORAGE_CACHED_APPLE = $85BE;

This item has no description.

GL_STORAGE_SHARED_APPLE = $85BF;

This item has no description.

GL_YCBCR_422_APPLE = $85B9;

GL_APPLE_ycbcr_422

GL_UNSIGNED_SHORT_8_8_APPLE = $85BA;

This item has no description.

GL_UNSIGNED_SHORT_8_8_REV_APPLE = $85BB;

This item has no description.

GL_RGB_RAW_422_APPLE = $8A51;

This item has no description.

GL_TEXTURE_RANGE_LENGTH_APPLE = $85B7;

GL_APPLE_texture_range

GL_TEXTURE_RANGE_POINTER_APPLE = $85B8;

This item has no description.

GL_TEXTURE_STORAGE_HINT_APPLE = $85BC;

This item has no description.

GL_STORAGE_PRIVATE_APPLE = $85BD;

This item has no description.

GL_HALF_APPLE = $140B;

GL_APPLE_float_pixels

GL_RGBA_FLOAT32_APPLE = $8814;

This item has no description.

GL_RGB_FLOAT32_APPLE = $8815;

This item has no description.

GL_ALPHA_FLOAT32_APPLE = $8816;

This item has no description.

GL_INTENSITY_FLOAT32_APPLE = $8817;

This item has no description.

GL_LUMINANCE_FLOAT32_APPLE = $8818;

This item has no description.

GL_LUMINANCE_ALPHA_FLOAT32_APPLE = $8819;

This item has no description.

GL_RGBA_FLOAT16_APPLE = $881A;

This item has no description.

GL_RGB_FLOAT16_APPLE = $881B;

This item has no description.

GL_ALPHA_FLOAT16_APPLE = $881C;

This item has no description.

GL_INTENSITY_FLOAT16_APPLE = $881D;

This item has no description.

GL_LUMINANCE_FLOAT16_APPLE = $881E;

This item has no description.

GL_LUMINANCE_ALPHA_FLOAT16_APPLE = $881F;

This item has no description.

GL_COLOR_FLOAT_APPLE = $8A0F;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_APPLE = $8A00;

GL_APPLE_vertex_program_evaluators

GL_VERTEX_ATTRIB_MAP2_APPLE = $8A01;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_SIZE_APPLE = $8A02;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_COEFF_APPLE = $8A03;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_ORDER_APPLE = $8A04;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_DOMAIN_APPLE = $8A05;

This item has no description.

GL_VERTEX_ATTRIB_MAP2_SIZE_APPLE = $8A06;

This item has no description.

GL_VERTEX_ATTRIB_MAP2_COEFF_APPLE = $8A07;

This item has no description.

GL_VERTEX_ATTRIB_MAP2_ORDER_APPLE = $8A08;

This item has no description.

GL_VERTEX_ATTRIB_MAP2_DOMAIN_APPLE = $8A09;

This item has no description.

GL_AUX_DEPTH_STENCIL_APPLE = $8A14;

GL_APPLE_aux_depth_stencil

GL_BUFFER_OBJECT_APPLE = $85B3;

GL_APPLE_object_purgeable

GL_RELEASED_APPLE = $8A19;

This item has no description.

GL_VOLATILE_APPLE = $8A1A;

This item has no description.

GL_RETAINED_APPLE = $8A1B;

This item has no description.

GL_UNDEFINED_APPLE = $8A1C;

This item has no description.

GL_PURGEABLE_APPLE = $8A1D;

This item has no description.

GL_PACK_ROW_BYTES_APPLE = $8A15;

GL_APPLE_row_bytes

GL_UNPACK_ROW_BYTES_APPLE = $8A16;

This item has no description.

GL_DEPTH_COMPONENT16_ARB = $81A5;

GL_ARB_depth_texture

GL_DEPTH_COMPONENT24_ARB = $81A6;

This item has no description.

GL_DEPTH_COMPONENT32_ARB = $81A7;

This item has no description.

GL_TEXTURE_DEPTH_SIZE_ARB = $884A;

This item has no description.

GL_DEPTH_TEXTURE_MODE_ARB = $884B;

This item has no description.

GL_FRAGMENT_PROGRAM_ARB = $8804;

GL_ARB_fragment_program

GL_PROGRAM_ALU_INSTRUCTIONS_ARB = $8805;

This item has no description.

GL_PROGRAM_TEX_INSTRUCTIONS_ARB = $8806;

This item has no description.

GL_PROGRAM_TEX_INDIRECTIONS_ARB = $8807;

This item has no description.

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $8808;

This item has no description.

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $8809;

This item has no description.

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $880A;

This item has no description.

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB = $880B;

This item has no description.

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB = $880C;

This item has no description.

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB = $880D;

This item has no description.

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $880E;

This item has no description.

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $880F;

This item has no description.

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $8810;

This item has no description.

GL_MAX_TEXTURE_COORDS_ARB = $8871;

This item has no description.

GL_MAX_TEXTURE_IMAGE_UNITS_ARB = $8872;

This item has no description.

GL_CONSTANT_COLOR_ARB = $8001;

GL_ARB_imaging

GL_ONE_MINUS_CONSTANT_COLOR = $8002;

This item has no description.

GL_CONSTANT_ALPHA = $8003;

This item has no description.

GL_ONE_MINUS_CONSTANT_ALPHA = $8004;

This item has no description.

GL_BLEND_COLOR = $8005;

This item has no description.

GL_FUNC_ADD = $8006;

This item has no description.

GL_MIN = $8007;

This item has no description.

GL_MAX = $8008;

This item has no description.

GL_BLEND_EQUATION = $8009;

This item has no description.

GL_FUNC_SUBTRACT = $800A;

This item has no description.

GL_FUNC_REVERSE_SUBTRACT = $800B;

This item has no description.

GL_CONVOLUTION_1D = $8010;

This item has no description.

GL_CONVOLUTION_2D = $8011;

This item has no description.

GL_SEPARABLE_2D = $8012;

This item has no description.

GL_CONVOLUTION_BORDER_MODE = $8013;

This item has no description.

GL_CONVOLUTION_FILTER_SCALE = $8014;

This item has no description.

GL_CONVOLUTION_FILTER_BIAS = $8015;

This item has no description.

GL_REDUCE = $8016;

This item has no description.

GL_CONVOLUTION_FORMAT = $8017;

This item has no description.

GL_CONVOLUTION_WIDTH = $8018;

This item has no description.

GL_CONVOLUTION_HEIGHT = $8019;

This item has no description.

GL_MAX_CONVOLUTION_WIDTH = $801A;

This item has no description.

GL_MAX_CONVOLUTION_HEIGHT = $801B;

This item has no description.

GL_POST_CONVOLUTION_RED_SCALE = $801C;

This item has no description.

GL_POST_CONVOLUTION_GREEN_SCALE = $801D;

This item has no description.

GL_POST_CONVOLUTION_BLUE_SCALE = $801E;

This item has no description.

GL_POST_CONVOLUTION_ALPHA_SCALE = $801F;

This item has no description.

GL_POST_CONVOLUTION_RED_BIAS = $8020;

This item has no description.

GL_POST_CONVOLUTION_GREEN_BIAS = $8021;

This item has no description.

GL_POST_CONVOLUTION_BLUE_BIAS = $8022;

This item has no description.

GL_POST_CONVOLUTION_ALPHA_BIAS = $8023;

This item has no description.

GL_HISTOGRAM = $8024;

This item has no description.

GL_PROXY_HISTOGRAM = $8025;

This item has no description.

GL_HISTOGRAM_WIDTH = $8026;

This item has no description.

GL_HISTOGRAM_FORMAT = $8027;

This item has no description.

GL_HISTOGRAM_RED_SIZE = $8028;

This item has no description.

GL_HISTOGRAM_GREEN_SIZE = $8029;

This item has no description.

GL_HISTOGRAM_BLUE_SIZE = $802A;

This item has no description.

GL_HISTOGRAM_ALPHA_SIZE = $802B;

This item has no description.

GL_HISTOGRAM_LUMINANCE_SIZE = $802C;

This item has no description.

GL_HISTOGRAM_SINK = $802D;

This item has no description.

GL_MINMAX = $802E;

This item has no description.

GL_MINMAX_FORMAT = $802F;

This item has no description.

GL_MINMAX_SINK = $8030;

This item has no description.

GL_TABLE_TOO_LARGE = $8031;

This item has no description.

GL_COLOR_MATRIX = $80B1;

This item has no description.

GL_COLOR_MATRIX_STACK_DEPTH = $80B2;

This item has no description.

GL_MAX_COLOR_MATRIX_STACK_DEPTH = $80B3;

This item has no description.

GL_POST_COLOR_MATRIX_RED_SCALE = $80B4;

This item has no description.

GL_POST_COLOR_MATRIX_GREEN_SCALE = $80B5;

This item has no description.

GL_POST_COLOR_MATRIX_BLUE_SCALE = $80B6;

This item has no description.

GL_POST_COLOR_MATRIX_ALPHA_SCALE = $80B7;

This item has no description.

GL_POST_COLOR_MATRIX_RED_BIAS = $80B8;

This item has no description.

GL_POST_COLOR_MATRIX_GREEN_BIAS = $80B9;

This item has no description.

GL_POST_COLOR_MATRIX_BLUE_BIAS = $80BA;

This item has no description.

GL_POST_COLOR_MATRIX_ALPHA_BIAS = $80BB;

This item has no description.

GL_COLOR_TABLE = $80D0;

This item has no description.

GL_POST_CONVOLUTION_COLOR_TABLE = $80D1;

This item has no description.

GL_POST_COLOR_MATRIX_COLOR_TABLE = $80D2;

This item has no description.

GL_PROXY_COLOR_TABLE = $80D3;

This item has no description.

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE = $80D4;

This item has no description.

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE = $80D5;

This item has no description.

GL_COLOR_TABLE_SCALE = $80D6;

This item has no description.

GL_COLOR_TABLE_BIAS = $80D7;

This item has no description.

GL_COLOR_TABLE_FORMAT = $80D8;

This item has no description.

GL_COLOR_TABLE_WIDTH = $80D9;

This item has no description.

GL_COLOR_TABLE_RED_SIZE = $80DA;

This item has no description.

GL_COLOR_TABLE_GREEN_SIZE = $80DB;

This item has no description.

GL_COLOR_TABLE_BLUE_SIZE = $80DC;

This item has no description.

GL_COLOR_TABLE_ALPHA_SIZE = $80DD;

This item has no description.

GL_COLOR_TABLE_LUMINANCE_SIZE = $80DE;

This item has no description.

GL_COLOR_TABLE_INTENSITY_SIZE = $80DF;

This item has no description.

GL_CONSTANT_BORDER = $8151;

This item has no description.

GL_REPLICATE_BORDER = $8153;

This item has no description.

GL_CONVOLUTION_BORDER_COLOR = $8154;

This item has no description.

GL_MATRIX_PALETTE_ARB = $8840;

GL_ARB_matrix_palette

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB = $8841;

This item has no description.

GL_MAX_PALETTE_MATRICES_ARB = $8842;

This item has no description.

GL_CURRENT_PALETTE_MATRIX_ARB = $8843;

This item has no description.

GL_MATRIX_INDEX_ARRAY_ARB = $8844;

This item has no description.

GL_CURRENT_MATRIX_INDEX_ARB = $8845;

This item has no description.

GL_MATRIX_INDEX_ARRAY_SIZE_ARB = $8846;

This item has no description.

GL_MATRIX_INDEX_ARRAY_TYPE_ARB = $8847;

This item has no description.

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB = $8848;

This item has no description.

GL_MATRIX_INDEX_ARRAY_POINTER_ARB = $8849;

This item has no description.

GL_MULTISAMPLE_ARB = $809D;

GL_ARB_multisample

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB = $809E;

This item has no description.

GL_SAMPLE_ALPHA_TO_ONE_ARB = $809F;

This item has no description.

GL_SAMPLE_COVERAGE_ARB = $80A0;

This item has no description.

GL_SAMPLE_BUFFERS_ARB = $80A8;

This item has no description.

GL_SAMPLES_ARB = $80A9;

This item has no description.

GL_SAMPLE_COVERAGE_VALUE_ARB = $80AA;

This item has no description.

GL_SAMPLE_COVERAGE_INVERT_ARB = $80AB;

This item has no description.

GL_MULTISAMPLE_BIT_ARB = $20000000;

This item has no description.

GL_TEXTURE0_ARB = $84C0;

GL_ARB_multitexture

GL_TEXTURE1_ARB = $84C1;

This item has no description.

GL_TEXTURE2_ARB = $84C2;

This item has no description.

GL_TEXTURE3_ARB = $84C3;

This item has no description.

GL_TEXTURE4_ARB = $84C4;

This item has no description.

GL_TEXTURE5_ARB = $84C5;

This item has no description.

GL_TEXTURE6_ARB = $84C6;

This item has no description.

GL_TEXTURE7_ARB = $84C7;

This item has no description.

GL_TEXTURE8_ARB = $84C8;

This item has no description.

GL_TEXTURE9_ARB = $84C9;

This item has no description.

GL_TEXTURE10_ARB = $84CA;

This item has no description.

GL_TEXTURE11_ARB = $84CB;

This item has no description.

GL_TEXTURE12_ARB = $84CC;

This item has no description.

GL_TEXTURE13_ARB = $84CD;

This item has no description.

GL_TEXTURE14_ARB = $84CE;

This item has no description.

GL_TEXTURE15_ARB = $84CF;

This item has no description.

GL_TEXTURE16_ARB = $84D0;

This item has no description.

GL_TEXTURE17_ARB = $84D1;

This item has no description.

GL_TEXTURE18_ARB = $84D2;

This item has no description.

GL_TEXTURE19_ARB = $84D3;

This item has no description.

GL_TEXTURE20_ARB = $84D4;

This item has no description.

GL_TEXTURE21_ARB = $84D5;

This item has no description.

GL_TEXTURE22_ARB = $84D6;

This item has no description.

GL_TEXTURE23_ARB = $84D7;

This item has no description.

GL_TEXTURE24_ARB = $84D8;

This item has no description.

GL_TEXTURE25_ARB = $84D9;

This item has no description.

GL_TEXTURE26_ARB = $84DA;

This item has no description.

GL_TEXTURE27_ARB = $84DB;

This item has no description.

GL_TEXTURE28_ARB = $84DC;

This item has no description.

GL_TEXTURE29_ARB = $84DD;

This item has no description.

GL_TEXTURE30_ARB = $84DE;

This item has no description.

GL_TEXTURE31_ARB = $84DF;

This item has no description.

GL_ACTIVE_TEXTURE_ARB = $84E0;

This item has no description.

GL_CLIENT_ACTIVE_TEXTURE_ARB = $84E1;

This item has no description.

GL_MAX_TEXTURE_UNITS_ARB = $84E2;

This item has no description.

GL_POINT_SIZE_MIN_ARB = $8126;

GL_ARB_point_parameters

GL_POINT_SIZE_MAX_ARB = $8127;

This item has no description.

GL_POINT_FADE_THRESHOLD_SIZE_ARB = $8128;

This item has no description.

GL_POINT_DISTANCE_ATTENUATION_ARB = $8129;

This item has no description.

GL_TEXTURE_COMPARE_MODE_ARB = $884C;

GL_ARB_shadow

GL_TEXTURE_COMPARE_FUNC_ARB = $884D;

This item has no description.

GL_COMPARE_R_TO_TEXTURE_ARB = $884E;

This item has no description.

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB = $80BF;

GL_ARB_shadow_ambient

GL_SPARSE_STORAGE_BIT_ARB = $0400;

GL_ARB_sparse_buffer

GL_SPARSE_BUFFER_PAGE_SIZE_ARB = $82F8;

This item has no description.

GL_CLAMP_TO_BORDER_ARB = $812D;

GL_ARB_texture_border_clamp

GL_COMPRESSED_ALPHA_ARB = $84E9;

GL_ARB_texture_compression

GL_COMPRESSED_LUMINANCE_ARB = $84EA;

This item has no description.

GL_COMPRESSED_LUMINANCE_ALPHA_ARB = $84EB;

This item has no description.

GL_COMPRESSED_INTENSITY_ARB = $84EC;

This item has no description.

GL_COMPRESSED_RGB_ARB = $84ED;

This item has no description.

GL_COMPRESSED_RGBA_ARB = $84EE;

This item has no description.

GL_TEXTURE_COMPRESSION_HINT_ARB = $84EF;

This item has no description.

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB = $86A0;

This item has no description.

GL_TEXTURE_COMPRESSED_ARB = $86A1;

This item has no description.

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB = $86A2;

This item has no description.

GL_COMPRESSED_TEXTURE_FORMATS_ARB = $86A3;

This item has no description.

GL_NORMAL_MAP_ARB = $8511;

GL_ARB_texture_cube_map

GL_REFLECTION_MAP_ARB = $8512;

This item has no description.

GL_TEXTURE_CUBE_MAP_ARB = $8513;

This item has no description.

GL_TEXTURE_BINDING_CUBE_MAP_ARB = $8514;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $8515;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $8516;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $8517;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $8518;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $8519;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $851A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP_ARB = $851B;

This item has no description.

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = $851C;

This item has no description.

GL_COMBINE_ARB = $8570;

GL_ARB_texture_env_combine

GL_COMBINE_RGB_ARB = $8571;

This item has no description.

GL_COMBINE_ALPHA_ARB = $8572;

This item has no description.

GL_SOURCE0_RGB_ARB = $8580;

This item has no description.

GL_SOURCE1_RGB_ARB = $8581;

This item has no description.

GL_SOURCE2_RGB_ARB = $8582;

This item has no description.

GL_SOURCE0_ALPHA_ARB = $8588;

This item has no description.

GL_SOURCE1_ALPHA_ARB = $8589;

This item has no description.

GL_SOURCE2_ALPHA_ARB = $858A;

This item has no description.

GL_OPERAND0_RGB_ARB = $8590;

This item has no description.

GL_OPERAND1_RGB_ARB = $8591;

This item has no description.

GL_OPERAND2_RGB_ARB = $8592;

This item has no description.

GL_OPERAND0_ALPHA_ARB = $8598;

This item has no description.

GL_OPERAND1_ALPHA_ARB = $8599;

This item has no description.

GL_OPERAND2_ALPHA_ARB = $859A;

This item has no description.

GL_RGB_SCALE_ARB = $8573;

This item has no description.

GL_ADD_SIGNED_ARB = $8574;

This item has no description.

GL_INTERPOLATE_ARB = $8575;

This item has no description.

GL_SUBTRACT_ARB = $84E7;

This item has no description.

GL_CONSTANT_ARB = $8576;

This item has no description.

GL_PRIMARY_COLOR_ARB = $8577;

This item has no description.

GL_PREVIOUS_ARB = $8578;

This item has no description.

GL_DOT3_RGB_ARB = $86AE;

GL_ARB_texture_env_dot3

GL_DOT3_RGBA_ARB = $86AF;

This item has no description.

GL_TEXTURE_REDUCTION_MODE_ARB = $9366;

GL_ARB_texture_filter_minmax

GL_WEIGHTED_AVERAGE_ARB = $9367;

This item has no description.

GL_MIRRORED_REPEAT_ARB = $8370;

GL_ARB_texture_mirrored_repeat

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB = $84E3;

GL_ARB_transpose_matrix

GL_TRANSPOSE_PROJECTION_MATRIX_ARB = $84E4;

This item has no description.

GL_TRANSPOSE_TEXTURE_MATRIX_ARB = $84E5;

This item has no description.

GL_TRANSPOSE_COLOR_MATRIX_ARB = $84E6;

This item has no description.

GL_MAX_VERTEX_UNITS_ARB = $86A4;

GL_ARB_vertex_blend

GL_ACTIVE_VERTEX_UNITS_ARB = $86A5;

This item has no description.

GL_WEIGHT_SUM_UNITY_ARB = $86A6;

This item has no description.

GL_VERTEX_BLEND_ARB = $86A7;

This item has no description.

GL_CURRENT_WEIGHT_ARB = $86A8;

This item has no description.

GL_WEIGHT_ARRAY_TYPE_ARB = $86A9;

This item has no description.

GL_WEIGHT_ARRAY_STRIDE_ARB = $86AA;

This item has no description.

GL_WEIGHT_ARRAY_SIZE_ARB = $86AB;

This item has no description.

GL_WEIGHT_ARRAY_POINTER_ARB = $86AC;

This item has no description.

GL_WEIGHT_ARRAY_ARB = $86AD;

This item has no description.

GL_MODELVIEW0_ARB = $1700;

This item has no description.

GL_MODELVIEW1_ARB = $850A;

This item has no description.

GL_MODELVIEW2_ARB = $8722;

This item has no description.

GL_MODELVIEW3_ARB = $8723;

This item has no description.

GL_MODELVIEW4_ARB = $8724;

This item has no description.

GL_MODELVIEW5_ARB = $8725;

This item has no description.

GL_MODELVIEW6_ARB = $8726;

This item has no description.

GL_MODELVIEW7_ARB = $8727;

This item has no description.

GL_MODELVIEW8_ARB = $8728;

This item has no description.

GL_MODELVIEW9_ARB = $8729;

This item has no description.

GL_MODELVIEW10_ARB = $872A;

This item has no description.

GL_MODELVIEW11_ARB = $872B;

This item has no description.

GL_MODELVIEW12_ARB = $872C;

This item has no description.

GL_MODELVIEW13_ARB = $872D;

This item has no description.

GL_MODELVIEW14_ARB = $872E;

This item has no description.

GL_MODELVIEW15_ARB = $872F;

This item has no description.

GL_MODELVIEW16_ARB = $8730;

This item has no description.

GL_MODELVIEW17_ARB = $8731;

This item has no description.

GL_MODELVIEW18_ARB = $8732;

This item has no description.

GL_MODELVIEW19_ARB = $8733;

This item has no description.

GL_MODELVIEW20_ARB = $8734;

This item has no description.

GL_MODELVIEW21_ARB = $8735;

This item has no description.

GL_MODELVIEW22_ARB = $8736;

This item has no description.

GL_MODELVIEW23_ARB = $8737;

This item has no description.

GL_MODELVIEW24_ARB = $8738;

This item has no description.

GL_MODELVIEW25_ARB = $8739;

This item has no description.

GL_MODELVIEW26_ARB = $873A;

This item has no description.

GL_MODELVIEW27_ARB = $873B;

This item has no description.

GL_MODELVIEW28_ARB = $873C;

This item has no description.

GL_MODELVIEW29_ARB = $873D;

This item has no description.

GL_MODELVIEW30_ARB = $873E;

This item has no description.

GL_MODELVIEW31_ARB = $873F;

This item has no description.

GL_BUFFER_SIZE_ARB = $8764;

GL_ARB_vertex_buffer_object

GL_BUFFER_USAGE_ARB = $8765;

This item has no description.

GL_ARRAY_BUFFER_ARB = $8892;

This item has no description.

GL_ELEMENT_ARRAY_BUFFER_ARB = $8893;

This item has no description.

GL_ARRAY_BUFFER_BINDING_ARB = $8894;

This item has no description.

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB = $8895;

This item has no description.

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB = $8896;

This item has no description.

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB = $8897;

This item has no description.

GL_COLOR_ARRAY_BUFFER_BINDING_ARB = $8898;

This item has no description.

GL_INDEX_ARRAY_BUFFER_BINDING_ARB = $8899;

This item has no description.

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB = $889A;

This item has no description.

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB = $889B;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB = $889C;

This item has no description.

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB = $889D;

This item has no description.

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB = $889E;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB = $889F;

This item has no description.

GL_READ_ONLY_ARB = $88B8;

This item has no description.

GL_WRITE_ONLY_ARB = $88B9;

This item has no description.

GL_READ_WRITE_ARB = $88BA;

This item has no description.

GL_BUFFER_ACCESS_ARB = $88BB;

This item has no description.

GL_BUFFER_MAPPED_ARB = $88BC;

This item has no description.

GL_BUFFER_MAP_POINTER_ARB = $88BD;

This item has no description.

GL_STREAM_DRAW_ARB = $88E0;

This item has no description.

GL_STREAM_READ_ARB = $88E1;

This item has no description.

GL_STREAM_COPY_ARB = $88E2;

This item has no description.

GL_STATIC_DRAW_ARB = $88E4;

This item has no description.

GL_STATIC_READ_ARB = $88E5;

This item has no description.

GL_STATIC_COPY_ARB = $88E6;

This item has no description.

GL_DYNAMIC_DRAW_ARB = $88E8;

This item has no description.

GL_DYNAMIC_READ_ARB = $88E9;

This item has no description.

GL_DYNAMIC_COPY_ARB = $88EA;

This item has no description.

GL_COLOR_SUM_ARB = $8458;

GL_ARB_vertex_program

GL_VERTEX_PROGRAM_ARB = $8620;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB = $8622;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB = $8623;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB = $8624;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB = $8625;

This item has no description.

GL_CURRENT_VERTEX_ATTRIB_ARB = $8626;

This item has no description.

GL_PROGRAM_LENGTH_ARB = $8627;

This item has no description.

GL_PROGRAM_STRING_ARB = $8628;

This item has no description.

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB = $862E;

This item has no description.

GL_MAX_PROGRAM_MATRICES_ARB = $862F;

This item has no description.

GL_CURRENT_MATRIX_STACK_DEPTH_ARB = $8640;

This item has no description.

GL_CURRENT_MATRIX_ARB = $8641;

This item has no description.

GL_VERTEX_PROGRAM_POINT_SIZE_ARB = $8642;

This item has no description.

GL_VERTEX_PROGRAM_TWO_SIDE_ARB = $8643;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB = $8645;

This item has no description.

GL_PROGRAM_ERROR_POSITION_ARB = $864B;

This item has no description.

GL_PROGRAM_BINDING_ARB = $8677;

This item has no description.

GL_MAX_VERTEX_ATTRIBS_ARB = $8869;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB = $886A;

This item has no description.

GL_PROGRAM_ERROR_STRING_ARB = $8874;

This item has no description.

GL_PROGRAM_FORMAT_ASCII_ARB = $8875;

This item has no description.

GL_PROGRAM_FORMAT_ARB = $8876;

This item has no description.

GL_PROGRAM_INSTRUCTIONS_ARB = $88A0;

This item has no description.

GL_MAX_PROGRAM_INSTRUCTIONS_ARB = $88A1;

This item has no description.

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A2;

This item has no description.

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A3;

This item has no description.

GL_PROGRAM_TEMPORARIES_ARB = $88A4;

This item has no description.

GL_MAX_PROGRAM_TEMPORARIES_ARB = $88A5;

This item has no description.

GL_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A6;

This item has no description.

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A7;

This item has no description.

GL_PROGRAM_PARAMETERS_ARB = $88A8;

This item has no description.

GL_MAX_PROGRAM_PARAMETERS_ARB = $88A9;

This item has no description.

GL_PROGRAM_NATIVE_PARAMETERS_ARB = $88AA;

This item has no description.

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB = $88AB;

This item has no description.

GL_PROGRAM_ATTRIBS_ARB = $88AC;

This item has no description.

GL_MAX_PROGRAM_ATTRIBS_ARB = $88AD;

This item has no description.

GL_PROGRAM_NATIVE_ATTRIBS_ARB = $88AE;

This item has no description.

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB = $88AF;

This item has no description.

GL_PROGRAM_ADDRESS_REGISTERS_ARB = $88B0;

This item has no description.

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB = $88B1;

This item has no description.

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B2;

This item has no description.

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B3;

This item has no description.

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB = $88B4;

This item has no description.

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB = $88B5;

This item has no description.

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB = $88B6;

This item has no description.

GL_TRANSPOSE_CURRENT_MATRIX_ARB = $88B7;

This item has no description.

GL_MATRIX0_ARB = $88C0;

This item has no description.

GL_MATRIX1_ARB = $88C1;

This item has no description.

GL_MATRIX2_ARB = $88C2;

This item has no description.

GL_MATRIX3_ARB = $88C3;

This item has no description.

GL_MATRIX4_ARB = $88C4;

This item has no description.

GL_MATRIX5_ARB = $88C5;

This item has no description.

GL_MATRIX6_ARB = $88C6;

This item has no description.

GL_MATRIX7_ARB = $88C7;

This item has no description.

GL_MATRIX8_ARB = $88C8;

This item has no description.

GL_MATRIX9_ARB = $88C9;

This item has no description.

GL_MATRIX10_ARB = $88CA;

This item has no description.

GL_MATRIX11_ARB = $88CB;

This item has no description.

GL_MATRIX12_ARB = $88CC;

This item has no description.

GL_MATRIX13_ARB = $88CD;

This item has no description.

GL_MATRIX14_ARB = $88CE;

This item has no description.

GL_MATRIX15_ARB = $88CF;

This item has no description.

GL_MATRIX16_ARB = $88D0;

This item has no description.

GL_MATRIX17_ARB = $88D1;

This item has no description.

GL_MATRIX18_ARB = $88D2;

This item has no description.

GL_MATRIX19_ARB = $88D3;

This item has no description.

GL_MATRIX20_ARB = $88D4;

This item has no description.

GL_MATRIX21_ARB = $88D5;

This item has no description.

GL_MATRIX22_ARB = $88D6;

This item has no description.

GL_MATRIX23_ARB = $88D7;

This item has no description.

GL_MATRIX24_ARB = $88D8;

This item has no description.

GL_MATRIX25_ARB = $88D9;

This item has no description.

GL_MATRIX26_ARB = $88DA;

This item has no description.

GL_MATRIX27_ARB = $88DB;

This item has no description.

GL_MATRIX28_ARB = $88DC;

This item has no description.

GL_MATRIX29_ARB = $88DD;

This item has no description.

GL_MATRIX30_ARB = $88DE;

This item has no description.

GL_MATRIX31_ARB = $88DF;

This item has no description.

GL_MAX_DRAW_BUFFERS_ARB = $8824;

GL_ARB_draw_buffers

GL_DRAW_BUFFER0_ARB = $8825;

This item has no description.

GL_DRAW_BUFFER1_ARB = $8826;

This item has no description.

GL_DRAW_BUFFER2_ARB = $8827;

This item has no description.

GL_DRAW_BUFFER3_ARB = $8828;

This item has no description.

GL_DRAW_BUFFER4_ARB = $8829;

This item has no description.

GL_DRAW_BUFFER5_ARB = $882A;

This item has no description.

GL_DRAW_BUFFER6_ARB = $882B;

This item has no description.

GL_DRAW_BUFFER7_ARB = $882C;

This item has no description.

GL_DRAW_BUFFER8_ARB = $882D;

This item has no description.

GL_DRAW_BUFFER9_ARB = $882E;

This item has no description.

GL_DRAW_BUFFER10_ARB = $882F;

This item has no description.

GL_DRAW_BUFFER11_ARB = $8830;

This item has no description.

GL_DRAW_BUFFER12_ARB = $8831;

This item has no description.

GL_DRAW_BUFFER13_ARB = $8832;

This item has no description.

GL_DRAW_BUFFER14_ARB = $8833;

This item has no description.

GL_DRAW_BUFFER15_ARB = $8834;

This item has no description.

GL_TEXTURE_RECTANGLE_ARB = $84F5;

GL_ARB_texture_rectangle

GL_TEXTURE_BINDING_RECTANGLE_ARB = $84F6;

This item has no description.

GL_PROXY_TEXTURE_RECTANGLE_ARB = $84F7;

This item has no description.

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB = $84F8;

This item has no description.

GL_RGBA_FLOAT_MODE_ARB = $8820;

GL_ARB_color_buffer_float

GL_CLAMP_VERTEX_COLOR_ARB = $891A;

This item has no description.

GL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

This item has no description.

GL_CLAMP_READ_COLOR_ARB = $891C;

This item has no description.

GL_FIXED_ONLY_ARB = $891D;

This item has no description.

WGL_TYPE_RGBA_FLOAT_ARB = $21A0;

This item has no description.

GLX_RGBA_FLOAT_TYPE = $20B9;

This item has no description.

GLX_RGBA_FLOAT_BIT = $00000004;

This item has no description.

GL_MAX_COMPUTE_VARIABLE_GROUP_INVOCATIONS_ARB = $9344;

GL_ARB_compute_variable_group_size

GL_MAX_COMPUTE_FIXED_GROUP_INVOCATIONS_ARB = $90EB;

This item has no description.

GL_MAX_COMPUTE_VARIABLE_GROUP_SIZE_ARB = $9345;

This item has no description.

GL_MAX_COMPUTE_FIXED_GROUP_SIZE_ARB = $91BF;

This item has no description.

GL_HALF_FLOAT_ARB = $140B;

GL_ARB_half_float_pixel

GL_TEXTURE_RED_TYPE_ARB = $8C10;

GL_ARB_texture_float

GL_TEXTURE_GREEN_TYPE_ARB = $8C11;

This item has no description.

GL_TEXTURE_BLUE_TYPE_ARB = $8C12;

This item has no description.

GL_TEXTURE_ALPHA_TYPE_ARB = $8C13;

This item has no description.

GL_TEXTURE_LUMINANCE_TYPE_ARB = $8C14;

This item has no description.

GL_TEXTURE_INTENSITY_TYPE_ARB = $8C15;

This item has no description.

GL_TEXTURE_DEPTH_TYPE_ARB = $8C16;

This item has no description.

GL_UNSIGNED_NORMALIZED_ARB = $8C17;

This item has no description.

GL_RGBA32F_ARB = $8814;

This item has no description.

GL_RGB32F_ARB = $8815;

This item has no description.

GL_ALPHA32F_ARB = $8816;

This item has no description.

GL_INTENSITY32F_ARB = $8817;

This item has no description.

GL_LUMINANCE32F_ARB = $8818;

This item has no description.

GL_LUMINANCE_ALPHA32F_ARB = $8819;

This item has no description.

GL_RGBA16F_ARB = $881A;

This item has no description.

GL_RGB16F_ARB = $881B;

This item has no description.

GL_ALPHA16F_ARB = $881C;

This item has no description.

GL_INTENSITY16F_ARB = $881D;

This item has no description.

GL_LUMINANCE16F_ARB = $881E;

This item has no description.

GL_LUMINANCE_ALPHA16F_ARB = $881F;

This item has no description.

GL_PIXEL_PACK_BUFFER_ARB = $88EB;

GL_ARB_pixel_buffer_object

GL_PIXEL_UNPACK_BUFFER_ARB = $88EC;

This item has no description.

GL_PIXEL_PACK_BUFFER_BINDING_ARB = $88ED;

This item has no description.

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB = $88EF;

This item has no description.

GL_DEPTH_COMPONENT32F = $8CAC;

GL_ARB_depth_buffer_float

GL_DEPTH32F_STENCIL8 = $8CAD;

This item has no description.

GL_FLOAT_32_UNSIGNED_INT_24_8_REV = $8DAD;

This item has no description.

GL_INVALID_FRAMEBUFFER_OPERATION = $0506;

GL_ARB_framebuffer_object

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING = $8210;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE = $8211;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE = $8212;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE = $8213;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE = $8214;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE = $8215;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE = $8216;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE = $8217;

This item has no description.

GL_FRAMEBUFFER_DEFAULT = $8218;

This item has no description.

GL_FRAMEBUFFER_UNDEFINED = $8219;

This item has no description.

GL_DEPTH_STENCIL_ATTACHMENT = $821A;

This item has no description.

GL_MAX_RENDERBUFFER_SIZE = $84E8;

This item has no description.

GL_DEPTH_STENCIL = $84F9;

This item has no description.

GL_UNSIGNED_INT_24_8 = $84FA;

This item has no description.

GL_DEPTH24_STENCIL8 = $88F0;

This item has no description.

GL_TEXTURE_STENCIL_SIZE = $88F1;

This item has no description.

GL_TEXTURE_RED_TYPE = $8C10;

This item has no description.

GL_TEXTURE_GREEN_TYPE = $8C11;

This item has no description.

GL_TEXTURE_BLUE_TYPE = $8C12;

This item has no description.

GL_TEXTURE_ALPHA_TYPE = $8C13;

This item has no description.

GL_TEXTURE_DEPTH_TYPE = $8C16;

This item has no description.

GL_UNSIGNED_NORMALIZED = $8C17;

This item has no description.

GL_FRAMEBUFFER_BINDING = $8CA6;

This item has no description.

GL_DRAW_FRAMEBUFFER_BINDING = GL_FRAMEBUFFER_BINDING;

This item has no description.

GL_RENDERBUFFER_BINDING = $8CA7;

This item has no description.

GL_READ_FRAMEBUFFER = $8CA8;

This item has no description.

GL_DRAW_FRAMEBUFFER = $8CA9;

This item has no description.

GL_READ_FRAMEBUFFER_BINDING = $8CAA;

This item has no description.

GL_RENDERBUFFER_SAMPLES = $8CAB;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE = $8CD0;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME = $8CD1;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL = $8CD2;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE = $8CD3;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER = $8CD4;

This item has no description.

GL_FRAMEBUFFER_COMPLETE = $8CD5;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT = $8CD6;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT = $8CD7;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER = $8CDB;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER = $8CDC;

This item has no description.

GL_FRAMEBUFFER_UNSUPPORTED = $8CDD;

This item has no description.

GL_MAX_COLOR_ATTACHMENTS = $8CDF;

This item has no description.

GL_COLOR_ATTACHMENT0 = $8CE0;

This item has no description.

GL_COLOR_ATTACHMENT1 = $8CE1;

This item has no description.

GL_COLOR_ATTACHMENT2 = $8CE2;

This item has no description.

GL_COLOR_ATTACHMENT3 = $8CE3;

This item has no description.

GL_COLOR_ATTACHMENT4 = $8CE4;

This item has no description.

GL_COLOR_ATTACHMENT5 = $8CE5;

This item has no description.

GL_COLOR_ATTACHMENT6 = $8CE6;

This item has no description.

GL_COLOR_ATTACHMENT7 = $8CE7;

This item has no description.

GL_COLOR_ATTACHMENT8 = $8CE8;

This item has no description.

GL_COLOR_ATTACHMENT9 = $8CE9;

This item has no description.

GL_COLOR_ATTACHMENT10 = $8CEA;

This item has no description.

GL_COLOR_ATTACHMENT11 = $8CEB;

This item has no description.

GL_COLOR_ATTACHMENT12 = $8CEC;

This item has no description.

GL_COLOR_ATTACHMENT13 = $8CED;

This item has no description.

GL_COLOR_ATTACHMENT14 = $8CEE;

This item has no description.

GL_COLOR_ATTACHMENT15 = $8CEF;

This item has no description.

GL_DEPTH_ATTACHMENT = $8D00;

This item has no description.

GL_STENCIL_ATTACHMENT = $8D20;

This item has no description.

GL_FRAMEBUFFER = $8D40;

This item has no description.

GL_RENDERBUFFER = $8D41;

This item has no description.

GL_RENDERBUFFER_WIDTH = $8D42;

This item has no description.

GL_RENDERBUFFER_HEIGHT = $8D43;

This item has no description.

GL_RENDERBUFFER_INTERNAL_FORMAT = $8D44;

This item has no description.

GL_STENCIL_INDEX1 = $8D46;

This item has no description.

GL_STENCIL_INDEX4 = $8D47;

This item has no description.

GL_STENCIL_INDEX8 = $8D48;

This item has no description.

GL_STENCIL_INDEX16 = $8D49;

This item has no description.

GL_RENDERBUFFER_RED_SIZE = $8D50;

This item has no description.

GL_RENDERBUFFER_GREEN_SIZE = $8D51;

This item has no description.

GL_RENDERBUFFER_BLUE_SIZE = $8D52;

This item has no description.

GL_RENDERBUFFER_ALPHA_SIZE = $8D53;

This item has no description.

GL_RENDERBUFFER_DEPTH_SIZE = $8D54;

This item has no description.

GL_RENDERBUFFER_STENCIL_SIZE = $8D55;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE = $8D56;

This item has no description.

GL_MAX_SAMPLES = $8D57;

This item has no description.

GL_INDEX = $8222;

This item has no description.

GL_TEXTURE_LUMINANCE_TYPE = $8C14;

This item has no description.

GL_TEXTURE_INTENSITY_TYPE = $8C15;

This item has no description.

GL_FRAMEBUFFER_SRGB = $8DB9;

GL_ARB_framebuffer_sRGB

GL_LINES_ADJACENCY_ARB = $000A;

GL_ARB_geometry_shader4

GL_LINE_STRIP_ADJACENCY_ARB = $000B;

This item has no description.

GL_TRIANGLES_ADJACENCY_ARB = $000C;

This item has no description.

GL_TRIANGLE_STRIP_ADJACENCY_ARB = $000D;

This item has no description.

GL_PROGRAM_POINT_SIZE_ARB = $8642;

This item has no description.

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB = $8C29;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB = $8DA7;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB = $8DA8;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB = $8DA9;

This item has no description.

GL_GEOMETRY_SHADER_ARB = $8DD9;

This item has no description.

GL_GEOMETRY_VERTICES_OUT_ARB = $8DDA;

This item has no description.

GL_GEOMETRY_INPUT_TYPE_ARB = $8DDB;

This item has no description.

GL_GEOMETRY_OUTPUT_TYPE_ARB = $8DDC;

This item has no description.

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB = $8DDD;

This item has no description.

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB = $8DDE;

This item has no description.

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB = $8DDF;

This item has no description.

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB = $8DE0;

This item has no description.

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB = $8DE1;

This item has no description.

GL_SHADER_BINARY_FORMAT_SPIR_V_ARB = $9551;

GL_ARB_gl_spirv

GL_SPIR_V_BINARY_ARB = $9552;

This item has no description.

GL_HALF_FLOAT = $140B;

GL_ARB_half_float_vertex

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB = $88FE;

GL_ARB_instanced_arrays

GL_MAP_READ_BIT = $0001;

GL_ARB_map_buffer_range

GL_MAP_WRITE_BIT = $0002;

This item has no description.

GL_MAP_INVALIDATE_RANGE_BIT = $0004;

This item has no description.

GL_MAP_INVALIDATE_BUFFER_BIT = $0008;

This item has no description.

GL_MAP_FLUSH_EXPLICIT_BIT = $0010;

This item has no description.

GL_MAP_UNSYNCHRONIZED_BIT = $0020;

This item has no description.

GL_TEXTURE_BUFFER_ARB = $8C2A;

GL_ARB_texture_buffer_object

GL_MAX_TEXTURE_BUFFER_SIZE_ARB = $8C2B;

This item has no description.

GL_TEXTURE_BINDING_BUFFER_ARB = $8C2C;

This item has no description.

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB = $8C2D;

This item has no description.

GL_TEXTURE_BUFFER_FORMAT_ARB = $8C2E;

This item has no description.

GL_COMPRESSED_RED_RGTC1 = $8DBB;

GL_ARB_texture_compression_rgtc

GL_COMPRESSED_SIGNED_RED_RGTC1 = $8DBC;

This item has no description.

GL_COMPRESSED_RG_RGTC2 = $8DBD;

This item has no description.

GL_COMPRESSED_SIGNED_RG_RGTC2 = $8DBE;

This item has no description.

GL_RG = $8227;

GL_ARB_texture_rg

GL_RG_INTEGER = $8228;

This item has no description.

GL_R8 = $8229;

This item has no description.

GL_R16 = $822A;

This item has no description.

GL_RG8 = $822B;

This item has no description.

GL_RG16 = $822C;

This item has no description.

GL_R16F = $822D;

This item has no description.

GL_R32F = $822E;

This item has no description.

GL_RG16F = $822F;

This item has no description.

GL_RG32F = $8230;

This item has no description.

GL_R8I = $8231;

This item has no description.

GL_R8UI = $8232;

This item has no description.

GL_R16I = $8233;

This item has no description.

GL_R16UI = $8234;

This item has no description.

GL_R32I = $8235;

This item has no description.

GL_R32UI = $8236;

This item has no description.

GL_RG8I = $8237;

This item has no description.

GL_RG8UI = $8238;

This item has no description.

GL_RG16I = $8239;

This item has no description.

GL_RG16UI = $823A;

This item has no description.

GL_RG32I = $823B;

This item has no description.

GL_RG32UI = $823C;

This item has no description.

GL_VERTEX_ARRAY_BINDING = $85B5;

GL_ARB_vertex_array_object

GL_UNIFORM_BUFFER = $8A11;

GL_ARB_uniform_buffer_object

GL_UNIFORM_BUFFER_BINDING = $8A28;

This item has no description.

GL_UNIFORM_BUFFER_START = $8A29;

This item has no description.

GL_UNIFORM_BUFFER_SIZE = $8A2A;

This item has no description.

GL_MAX_VERTEX_UNIFORM_BLOCKS = $8A2B;

This item has no description.

GL_MAX_GEOMETRY_UNIFORM_BLOCKS = $8A2C;

This item has no description.

GL_MAX_FRAGMENT_UNIFORM_BLOCKS = $8A2D;

This item has no description.

GL_MAX_COMBINED_UNIFORM_BLOCKS = $8A2E;

This item has no description.

GL_MAX_UNIFORM_BUFFER_BINDINGS = $8A2F;

This item has no description.

GL_MAX_UNIFORM_BLOCK_SIZE = $8A30;

This item has no description.

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS = $8A31;

This item has no description.

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS = $8A32;

This item has no description.

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS = $8A33;

This item has no description.

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT = $8A34;

This item has no description.

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH = $8A35;

This item has no description.

GL_ACTIVE_UNIFORM_BLOCKS = $8A36;

This item has no description.

GL_UNIFORM_TYPE = $8A37;

This item has no description.

GL_UNIFORM_SIZE = $8A38;

This item has no description.

GL_UNIFORM_NAME_LENGTH = $8A39;

This item has no description.

GL_UNIFORM_BLOCK_INDEX = $8A3A;

This item has no description.

GL_UNIFORM_OFFSET = $8A3B;

This item has no description.

GL_UNIFORM_ARRAY_STRIDE = $8A3C;

This item has no description.

GL_UNIFORM_MATRIX_STRIDE = $8A3D;

This item has no description.

GL_UNIFORM_IS_ROW_MAJOR = $8A3E;

This item has no description.

GL_UNIFORM_BLOCK_BINDING = $8A3F;

This item has no description.

GL_UNIFORM_BLOCK_DATA_SIZE = $8A40;

This item has no description.

GL_UNIFORM_BLOCK_NAME_LENGTH = $8A41;

This item has no description.

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS = $8A42;

This item has no description.

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES = $8A43;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER = $8A44;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER = $8A45;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER = $8A46;

This item has no description.

GL_INVALID_INDEX = $FFFFFFFF;

This item has no description.

GL_COPY_READ_BUFFER_BINDING = $8F36;

GL_ARB_copy_buffer

GL_COPY_READ_BUFFER = GL_COPY_READ_BUFFER_BINDING;

This item has no description.

GL_COPY_WRITE_BUFFER_BINDING = $8F37;

This item has no description.

GL_COPY_WRITE_BUFFER = GL_COPY_WRITE_BUFFER_BINDING;

This item has no description.

GL_DEPTH_CLAMP = $864F;

GL_ARB_depth_clamp

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION = $8E4C;

GL_ARB_provoking_vertex

GL_FIRST_VERTEX_CONVENTION = $8E4D;

This item has no description.

GL_LAST_VERTEX_CONVENTION = $8E4E;

This item has no description.

GL_PROVOKING_VERTEX = $8E4F;

This item has no description.

GL_TEXTURE_CUBE_MAP_SEAMLESS = $884F;

GL_ARB_seamless_cube_map

GL_MAX_SERVER_WAIT_TIMEOUT = $9111;

GL_ARB_sync

GL_OBJECT_TYPE = $9112;

This item has no description.

GL_SYNC_CONDITION = $9113;

This item has no description.

GL_SYNC_STATUS = $9114;

This item has no description.

GL_SYNC_FLAGS = $9115;

This item has no description.

GL_SYNC_FENCE = $9116;

This item has no description.

GL_SYNC_GPU_COMMANDS_COMPLETE = $9117;

This item has no description.

GL_UNSIGNALED = $9118;

This item has no description.

GL_SIGNALED = $9119;

This item has no description.

GL_ALREADY_SIGNALED = $911A;

This item has no description.

GL_TIMEOUT_EXPIRED = $911B;

This item has no description.

GL_CONDITION_SATISFIED = $911C;

This item has no description.

GL_WAIT_FAILED = $911D;

This item has no description.

GL_SYNC_FLUSH_COMMANDS_BIT = $00000001;

This item has no description.

GL_TIMEOUT_IGNORED = $FFFFFFFFFFFFFFFF;

This item has no description.

GL_SAMPLE_POSITION = $8E50;

GL_ARB_texture_multisample

GL_SAMPLE_MASK = $8E51;

This item has no description.

GL_SAMPLE_MASK_VALUE = $8E52;

This item has no description.

GL_MAX_SAMPLE_MASK_WORDS = $8E59;

This item has no description.

GL_TEXTURE_2D_MULTISAMPLE = $9100;

This item has no description.

GL_PROXY_TEXTURE_2D_MULTISAMPLE = $9101;

This item has no description.

GL_TEXTURE_2D_MULTISAMPLE_ARRAY = $9102;

This item has no description.

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY = $9103;

This item has no description.

GL_TEXTURE_BINDING_2D_MULTISAMPLE = $9104;

This item has no description.

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY = $9105;

This item has no description.

GL_TEXTURE_SAMPLES = $9106;

This item has no description.

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS = $9107;

This item has no description.

GL_SAMPLER_2D_MULTISAMPLE = $9108;

This item has no description.

GL_INT_SAMPLER_2D_MULTISAMPLE = $9109;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE = $910A;

This item has no description.

GL_SAMPLER_2D_MULTISAMPLE_ARRAY = $910B;

This item has no description.

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910C;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910D;

This item has no description.

GL_MAX_COLOR_TEXTURE_SAMPLES = $910E;

This item has no description.

GL_MAX_DEPTH_TEXTURE_SAMPLES = $910F;

This item has no description.

GL_MAX_INTEGER_SAMPLES = $9110;

This item has no description.

GL_SAMPLE_SHADING_ARB = $8C36;

GL_ARB_sample_shading

GL_MIN_SAMPLE_SHADING_VALUE_ARB = $8C37;

This item has no description.

GL_SAMPLE_LOCATION_SUBPIXEL_BITS_ARB = $933D;

GL_ARB_sample_locations

GL_SAMPLE_LOCATION_PIXEL_GRID_WIDTH_ARB = $933E;

This item has no description.

GL_SAMPLE_LOCATION_PIXEL_GRID_HEIGHT_ARB = $933F;

This item has no description.

GL_PROGRAMMABLE_SAMPLE_LOCATION_TABLE_SIZE_ARB = $9340;

This item has no description.

GL_SAMPLE_LOCATION_ARB = $8E50;

This item has no description.

GL_PROGRAMMABLE_SAMPLE_LOCATION_ARB = $9341;

This item has no description.

GL_FRAMEBUFFER_PROGRAMMABLE_SAMPLE_LOCATIONS_ARB = $9342;

This item has no description.

GL_FRAMEBUFFER_SAMPLE_LOCATION_PIXEL_GRID_ARB = $9343;

This item has no description.

GL_TEXTURE_CUBE_MAP_ARRAY_ARB = $9009;

GL_ARB_texture_cube_map_array

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB = $900A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB = $900B;

This item has no description.

GL_SAMPLER_CUBE_MAP_ARRAY_ARB = $900C;

This item has no description.

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB = $900D;

This item has no description.

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900E;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900F;

This item has no description.

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5E;

GL_ARB_texture_gather

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5F;

This item has no description.

GL_SHADER_INCLUDE_ARB = $8DAE;

GL_ARB_shading_language_include

GL_NAMED_STRING_LENGTH_ARB = $8DE9;

This item has no description.

GL_NAMED_STRING_TYPE_ARB = $8DEA;

This item has no description.

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB = $8E8C;

GL_ARB_texture_compression_bptc

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB = $8E8D;

This item has no description.

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB = $8E8E;

This item has no description.

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB = $8E8F;

This item has no description.

GL_SRC1_COLOR = $88F9;

GL_ARB_blend_func_extended

GL_ONE_MINUS_SRC1_COLOR = $88FA;

This item has no description.

GL_ONE_MINUS_SRC1_ALPHA = $88FB;

This item has no description.

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS = $88FC;

This item has no description.

GL_ANY_SAMPLES_PASSED = $8C2F;

GL_ARB_occlusion_query2

GL_MAX_SHADER_COMPILER_THREADS_ARB = $91B0;

GL_ARB_parallel_shader_compile

GL_COMPLETION_STATUS_ARB = $91B1;

This item has no description.

GL_SAMPLER_BINDING = $8919;

GL_ARB_sampler_objects

GL_RGB10_A2UI = $906F;

GL_ARB_texture_rgb10_a2ui

GL_TEXTURE_SWIZZLE_R = $8E42;

GL_ARB_texture_swizzle

GL_TEXTURE_SWIZZLE_G = $8E43;

This item has no description.

GL_TEXTURE_SWIZZLE_B = $8E44;

This item has no description.

GL_TEXTURE_SWIZZLE_A = $8E45;

This item has no description.

GL_TEXTURE_SWIZZLE_RGBA = $8E46;

This item has no description.

GL_TEXTURE_SPARSE_ARB = $91A6;

GL_ARB_SPARSE_TEXTURE

GL_VIRTUAL_PAGE_SIZE_INDEX_ARB = $91A7;

This item has no description.

GL_NUM_VIRTUAL_PAGE_SIZES_ARB = $91A8;

This item has no description.

GL_SPARSE_TEXTURE_FULL_ARRAY_CUBE_MIPMAPS_ARB = $91A9;

This item has no description.

GL_NUM_SPARSE_LEVELS_ARB = $91AA;

This item has no description.

GL_VIRTUAL_PAGE_SIZE_X_ARB = $9195;

This item has no description.

GL_VIRTUAL_PAGE_SIZE_Y_ARB = $9196;

This item has no description.

GL_VIRTUAL_PAGE_SIZE_Z_ARB = $9197;

This item has no description.

GL_MAX_SPARSE_TEXTURE_SIZE_ARB = $9198;

This item has no description.

GL_MAX_SPARSE_3D_TEXTURE_SIZE_ARB = $9199;

This item has no description.

GL_MAX_SPARSE_ARRAY_TEXTURE_LAYERS_ARB = $919A;

This item has no description.

GL_MIN_SPARSE_LEVEL_ARB = $919B;

This item has no description.

GL_TIME_ELAPSED = $88BF;

GL_ARB_timer_query

GL_TIMESTAMP = $8E28;

This item has no description.

GL_INT_2_10_10_10_REV = $8D9F;

reuse GL_UNSIGNED_INT_2_10_10_10_REV

GL_DRAW_INDIRECT_BUFFER = $8F3F;

GL_ARB_draw_indirect

GL_DRAW_INDIRECT_BUFFER_BINDING = $8F43;

This item has no description.

GL_GEOMETRY_SHADER_INVOCATIONS = $887F;

GL_ARB_gpu_shader5

GL_MAX_GEOMETRY_SHADER_INVOCATIONS = $8E5A;

This item has no description.

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET = $8E5B;

This item has no description.

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET = $8E5C;

This item has no description.

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS = $8E5D;

This item has no description.

GL_DOUBLE_VEC2 = $8FFC;

GL_ARB_gpu_shader_fp64

GL_DOUBLE_VEC3 = $8FFD;

This item has no description.

GL_DOUBLE_VEC4 = $8FFE;

This item has no description.

GL_DOUBLE_MAT2 = $8F46;

This item has no description.

GL_DOUBLE_MAT3 = $8F47;

This item has no description.

GL_DOUBLE_MAT4 = $8F48;

This item has no description.

GL_DOUBLE_MAT2x3 = $8F49;

This item has no description.

GL_DOUBLE_MAT2x4 = $8F4A;

This item has no description.

GL_DOUBLE_MAT3x2 = $8F4B;

This item has no description.

GL_DOUBLE_MAT3x4 = $8F4C;

This item has no description.

GL_DOUBLE_MAT4x2 = $8F4D;

This item has no description.

GL_DOUBLE_MAT4x3 = $8F4E;

This item has no description.

GL_INT64_ARB = $140E;

GL_ARB_gpu_shader_int64

GL_INT64_VEC2_ARB = $8FE9;

This item has no description.

GL_INT64_VEC3_ARB = $8FEA;

This item has no description.

GL_INT64_VEC4_ARB = $8FEB;

This item has no description.

GL_UNSIGNED_INT64_VEC2_ARB = $8FF5;

This item has no description.

GL_UNSIGNED_INT64_VEC3_ARB = $8FF6;

This item has no description.

GL_UNSIGNED_INT64_VEC4_ARB = $8FF7;

This item has no description.

GL_ACTIVE_SUBROUTINES = $8DE5;

GL_ARB_shader_subroutine

GL_ACTIVE_SUBROUTINE_UNIFORMS = $8DE6;

This item has no description.

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS = $8E47;

This item has no description.

GL_ACTIVE_SUBROUTINE_MAX_LENGTH = $8E48;

This item has no description.

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH = $8E49;

This item has no description.

GL_MAX_SUBROUTINES = $8DE7;

This item has no description.

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS = $8DE8;

This item has no description.

GL_NUM_COMPATIBLE_SUBROUTINES = $8E4A;

This item has no description.

GL_COMPATIBLE_SUBROUTINES = $8E4B;

This item has no description.

GL_PATCHES = $000E;

GL_ARB_tessellation_shader

GL_PATCH_VERTICES = $8E72;

This item has no description.

GL_PATCH_DEFAULT_INNER_LEVEL = $8E73;

This item has no description.

GL_PATCH_DEFAULT_OUTER_LEVEL = $8E74;

This item has no description.

GL_TESS_CONTROL_OUTPUT_VERTICES = $8E75;

This item has no description.

GL_TESS_GEN_MODE = $8E76;

This item has no description.

GL_TESS_GEN_SPACING = $8E77;

This item has no description.

GL_TESS_GEN_VERTEX_ORDER = $8E78;

This item has no description.

GL_TESS_GEN_POINT_MODE = $8E79;

This item has no description.

GL_ISOLINES = $8E7A;

This item has no description.

GL_FRACTIONAL_ODD = $8E7B;

This item has no description.

GL_FRACTIONAL_EVEN = $8E7C;

This item has no description.

GL_MAX_PATCH_VERTICES = $8E7D;

This item has no description.

GL_MAX_TESS_GEN_LEVEL = $8E7E;

This item has no description.

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS = $8E7F;

This item has no description.

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E80;

This item has no description.

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS = $8E81;

This item has no description.

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS = $8E82;

This item has no description.

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS = $8E83;

This item has no description.

GL_MAX_TESS_PATCH_COMPONENTS = $8E84;

This item has no description.

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS = $8E85;

This item has no description.

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS = $8E86;

This item has no description.

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS = $8E89;

This item has no description.

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS = $8E8A;

This item has no description.

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS = $886C;

This item has no description.

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS = $886D;

This item has no description.

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS = $8E1E;

This item has no description.

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E1F;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER = $84F0;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER = $84F1;

This item has no description.

GL_TESS_EVALUATION_SHADER = $8E87;

This item has no description.

GL_TESS_CONTROL_SHADER = $8E88;

This item has no description.

GL_TRANSFORM_FEEDBACK = $8E22;

GL_ARB_texture_buffer_object_rgb32 GL_ARB_transform_feedback2

GL_TRANSFORM_FEEDBACK_PAUSED = $8E23;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED = GL_TRANSFORM_FEEDBACK_PAUSED;

This item has no description.

GL_TRANSFORM_FEEDBACK_ACTIVE = $8E24;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE = GL_TRANSFORM_FEEDBACK_ACTIVE;

This item has no description.

GL_TRANSFORM_FEEDBACK_BINDING = $8E25;

This item has no description.

GL_TRANSFORM_FEEDBACK_OVERFLOW_ARB = $82EC;

GL_ARB_transform_feedback_overflow_query

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW_ARB = $82ED;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS = $8E70;

GL_ARB_transform_feedback3

GL_MAX_VERTEX_STREAMS = $8E71;

This item has no description.

GL_FIXED = $140C;

GL_ARB_ES2_compatibility

GL_IMPLEMENTATION_COLOR_READ_TYPE = $8B9A;

This item has no description.

GL_IMPLEMENTATION_COLOR_READ_FORMAT = $8B9B;

This item has no description.

GL_LOW_FLOAT = $8DF0;

This item has no description.

GL_MEDIUM_FLOAT = $8DF1;

This item has no description.

GL_HIGH_FLOAT = $8DF2;

This item has no description.

GL_LOW_INT = $8DF3;

This item has no description.

GL_MEDIUM_INT = $8DF4;

This item has no description.

GL_HIGH_INT = $8DF5;

This item has no description.

GL_SHADER_COMPILER = $8DFA;

This item has no description.

GL_NUM_SHADER_BINARY_FORMATS = $8DF9;

This item has no description.

GL_MAX_VERTEX_UNIFORM_VECTORS = $8DFB;

This item has no description.

GL_MAX_VARYING_VECTORS = $8DFC;

This item has no description.

GL_MAX_FRAGMENT_UNIFORM_VECTORS = $8DFD;

This item has no description.

GL_RGB565 = $8D62;

This item has no description.

GL_PRIMITIVE_BOUNDING_BOX_ARB = $092BE;

GL_ARB_ES3_2_compatibility

GL_MULTISAMPLE_LINE_WIDTH_RANGE_ARB = $09381;

This item has no description.

GL_MULTISAMPLE_LINE_WIDTH_GRANULARITY_ARB = $09382;

This item has no description.

GL_PROGRAM_BINARY_RETRIEVABLE_HINT = $8257;

GL_ARB_get_program_binary

GL_PROGRAM_BINARY_LENGTH = $8741;

This item has no description.

GL_NUM_PROGRAM_BINARY_FORMATS = $87FE;

This item has no description.

GL_PROGRAM_BINARY_FORMATS = $87FF;

This item has no description.

GL_VERTEX_SHADER_BIT = $00000001;

GL_ARB_separate_shader_objects

GL_FRAGMENT_SHADER_BIT = $00000002;

This item has no description.

GL_GEOMETRY_SHADER_BIT = $00000004;

This item has no description.

GL_TESS_CONTROL_SHADER_BIT = $00000008;

This item has no description.

GL_TESS_EVALUATION_SHADER_BIT = $00000010;

This item has no description.

GL_ALL_SHADER_BITS = $FFFFFFFF;

This item has no description.

GL_PROGRAM_SEPARABLE = $8258;

This item has no description.

GL_ACTIVE_PROGRAM = $8259;

This item has no description.

GL_PROGRAM_PIPELINE_BINDING = $825A;

This item has no description.

GL_MAX_VIEWPORTS = $825B;

GL_ARB_vertex_attrib_64bit

GL_VIEWPORT_SUBPIXEL_BITS = $825C;

This item has no description.

GL_VIEWPORT_BOUNDS_RANGE = $825D;

This item has no description.

GL_LAYER_PROVOKING_VERTEX = $825E;

This item has no description.

GL_VIEWPORT_INDEX_PROVOKING_VERTEX = $825F;

This item has no description.

GL_UNDEFINED_VERTEX = $8260;

This item has no description.

GL_SYNC_CL_EVENT_ARB = $8240;

GL_ARB_cl_event

GL_SYNC_CL_EVENT_COMPLETE_ARB = $8241;

This item has no description.

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB = $8242;

GL_ARB_debug_output

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB = $8243;

This item has no description.

GL_DEBUG_CALLBACK_FUNCTION_ARB = $8244;

This item has no description.

GL_DEBUG_CALLBACK_USER_PARAM_ARB = $8245;

This item has no description.

GL_DEBUG_SOURCE_API_ARB = $8246;

This item has no description.

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB = $8247;

This item has no description.

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB = $8248;

This item has no description.

GL_DEBUG_SOURCE_THIRD_PARTY_ARB = $8249;

This item has no description.

GL_DEBUG_SOURCE_APPLICATION_ARB = $824A;

This item has no description.

GL_DEBUG_SOURCE_OTHER_ARB = $824B;

This item has no description.

GL_DEBUG_TYPE_ERROR_ARB = $824C;

This item has no description.

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB = $824D;

This item has no description.

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB = $824E;

This item has no description.

GL_DEBUG_TYPE_PORTABILITY_ARB = $824F;

This item has no description.

GL_DEBUG_TYPE_PERFORMANCE_ARB = $8250;

This item has no description.

GL_DEBUG_TYPE_OTHER_ARB = $8251;

This item has no description.

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB = $9143;

This item has no description.

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB = $9144;

This item has no description.

GL_DEBUG_LOGGED_MESSAGES_ARB = $9145;

This item has no description.

GL_DEBUG_SEVERITY_HIGH_ARB = $9146;

This item has no description.

GL_DEBUG_SEVERITY_MEDIUM_ARB = $9147;

This item has no description.

GL_DEBUG_SEVERITY_LOW_ARB = $9148;

This item has no description.

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB = $00000004;

GL_ARB_robustness

GL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

This item has no description.

GL_GUILTY_CONTEXT_RESET_ARB = $8253;

This item has no description.

GL_INNOCENT_CONTEXT_RESET_ARB = $8254;

This item has no description.

GL_UNKNOWN_CONTEXT_RESET_ARB = $8255;

This item has no description.

GL_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

This item has no description.

GL_NO_RESET_NOTIFICATION_ARB = $8261;

This item has no description.

GL_UNPACK_COMPRESSED_BLOCK_WIDTH = $09127;

GL_ARB_compressed_texture_pixel_storage

GL_UNPACK_COMPRESSED_BLOCK_HEIGHT = $09128;

This item has no description.

GL_UNPACK_COMPRESSED_BLOCK_DEPTH = $09129;

This item has no description.

GL_UNPACK_COMPRESSED_BLOCK_SIZE = $0912A;

This item has no description.

GL_PACK_COMPRESSED_BLOCK_WIDTH = $0912B;

This item has no description.

GL_PACK_COMPRESSED_BLOCK_HEIGHT = $0912C;

This item has no description.

GL_PACK_COMPRESSED_BLOCK_DEPTH = $0912D;

This item has no description.

GL_PACK_COMPRESSED_BLOCK_SIZE = $0912E;

This item has no description.

GL_NUM_SAMPLE_COUNTS = $09380;

GL_ARB_internalformat_query

GL_MIN_MAP_BUFFER_ALIGNMENT = $090BC;

GL_ARB_map_buffer_alignment

GL_ATOMIC_COUNTER_BUFFER = $92C0;

GL_ARB_shader_atomic_counters

GL_ATOMIC_COUNTER_BUFFER_BINDING = $92C1;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_START = $92C2;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_SIZE = $92C3;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_DATA_SIZE = $92C4;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTERS = $92C5;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTER_INDICES = $92C6;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_VERTEX_SHADER = $92C7;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_CONTROL_SHADER = $92C8;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_EVALUATION_SHADER = $92C9;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_GEOMETRY_SHADER = $92CA;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_FRAGMENT_SHADER = $92CB;

This item has no description.

GL_MAX_VERTEX_ATOMIC_COUNTER_BUFFERS = $92CC;

This item has no description.

GL_MAX_TESS_CONTROL_ATOMIC_COUNTER_BUFFERS = $92CD;

This item has no description.

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTER_BUFFERS = $92CE;

This item has no description.

GL_MAX_GEOMETRY_ATOMIC_COUNTER_BUFFERS = $92CF;

This item has no description.

GL_MAX_FRAGMENT_ATOMIC_COUNTER_BUFFERS = $92D0;

This item has no description.

GL_MAX_COMBINED_ATOMIC_COUNTER_BUFFERS = $92D1;

This item has no description.

GL_MAX_VERTEX_ATOMIC_COUNTERS = $92D2;

This item has no description.

GL_MAX_TESS_CONTROL_ATOMIC_COUNTERS = $92D3;

This item has no description.

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTERS = $92D4;

This item has no description.

GL_MAX_GEOMETRY_ATOMIC_COUNTERS = $92D5;

This item has no description.

GL_MAX_FRAGMENT_ATOMIC_COUNTERS = $92D6;

This item has no description.

GL_MAX_COMBINED_ATOMIC_COUNTERS = $92D7;

This item has no description.

GL_MAX_ATOMIC_COUNTER_BUFFER_SIZE = $92D8;

This item has no description.

GL_MAX_ATOMIC_COUNTER_BUFFER_BINDINGS = $92DC;

This item has no description.

GL_ACTIVE_ATOMIC_COUNTER_BUFFERS = $92D9;

This item has no description.

GL_UNIFORM_ATOMIC_COUNTER_BUFFER_INDEX = $92DA;

This item has no description.

GL_UNSIGNED_INT_ATOMIC_COUNTER = $92DB;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT = $00000001;

GL_ARB_shader_image_load_store

GL_ELEMENT_ARRAY_BARRIER_BIT = $00000002;

This item has no description.

GL_UNIFORM_BARRIER_BIT = $00000004;

This item has no description.

GL_TEXTURE_FETCH_BARRIER_BIT = $00000008;

This item has no description.

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT = $00000020;

This item has no description.

GL_COMMAND_BARRIER_BIT = $00000040;

This item has no description.

GL_PIXEL_BUFFER_BARRIER_BIT = $00000080;

This item has no description.

GL_TEXTURE_UPDATE_BARRIER_BIT = $00000100;

This item has no description.

GL_BUFFER_UPDATE_BARRIER_BIT = $00000200;

This item has no description.

GL_FRAMEBUFFER_BARRIER_BIT = $00000400;

This item has no description.

GL_TRANSFORM_FEEDBACK_BARRIER_BIT = $00000800;

This item has no description.

GL_ATOMIC_COUNTER_BARRIER_BIT = $00001000;

This item has no description.

GL_ALL_BARRIER_BITS = $FFFFFFFF;

This item has no description.

GL_MAX_IMAGE_UNITS = $8F38;

This item has no description.

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS = $8F39;

This item has no description.

GL_IMAGE_BINDING_NAME = $8F3A;

This item has no description.

GL_IMAGE_BINDING_LEVEL = $8F3B;

This item has no description.

GL_IMAGE_BINDING_LAYERED = $8F3C;

This item has no description.

GL_IMAGE_BINDING_LAYER = $8F3D;

This item has no description.

GL_IMAGE_BINDING_ACCESS = $8F3E;

This item has no description.

GL_IMAGE_1D = $904C;

This item has no description.

GL_IMAGE_2D = $904D;

This item has no description.

GL_IMAGE_3D = $904E;

This item has no description.

GL_IMAGE_2D_RECT = $904F;

This item has no description.

GL_IMAGE_CUBE = $9050;

This item has no description.

GL_IMAGE_BUFFER = $9051;

This item has no description.

GL_IMAGE_1D_ARRAY = $9052;

This item has no description.

GL_IMAGE_2D_ARRAY = $9053;

This item has no description.

GL_IMAGE_CUBE_MAP_ARRAY = $9054;

This item has no description.

GL_IMAGE_2D_MULTISAMPLE = $9055;

This item has no description.

GL_IMAGE_2D_MULTISAMPLE_ARRAY = $9056;

This item has no description.

GL_INT_IMAGE_1D = $9057;

This item has no description.

GL_INT_IMAGE_2D = $9058;

This item has no description.

GL_INT_IMAGE_3D = $9059;

This item has no description.

GL_INT_IMAGE_2D_RECT = $905A;

This item has no description.

GL_INT_IMAGE_CUBE = $905B;

This item has no description.

GL_INT_IMAGE_BUFFER = $905C;

This item has no description.

GL_INT_IMAGE_1D_ARRAY = $905D;

This item has no description.

GL_INT_IMAGE_2D_ARRAY = $905E;

This item has no description.

GL_INT_IMAGE_CUBE_MAP_ARRAY = $905F;

This item has no description.

GL_INT_IMAGE_2D_MULTISAMPLE = $9060;

This item has no description.

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY = $9061;

This item has no description.

GL_UNSIGNED_INT_IMAGE_1D = $9062;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D = $9063;

This item has no description.

GL_UNSIGNED_INT_IMAGE_3D = $9064;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_RECT = $9065;

This item has no description.

GL_UNSIGNED_INT_IMAGE_CUBE = $9066;

This item has no description.

GL_UNSIGNED_INT_IMAGE_BUFFER = $9067;

This item has no description.

GL_UNSIGNED_INT_IMAGE_1D_ARRAY = $9068;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_ARRAY = $9069;

This item has no description.

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY = $906A;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE = $906B;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY = $906C;

This item has no description.

GL_MAX_IMAGE_SAMPLES = $906D;

This item has no description.

GL_IMAGE_BINDING_FORMAT = $906E;

This item has no description.

GL_IMAGE_FORMAT_COMPATIBILITY_TYPE = $90C7;

This item has no description.

GL_IMAGE_FORMAT_COMPATIBILITY_BY_SIZE = $90C8;

This item has no description.

GL_IMAGE_FORMAT_COMPATIBILITY_BY_CLASS = $90C9;

This item has no description.

GL_MAX_VERTEX_IMAGE_UNIFORMS = $90CA;

This item has no description.

GL_MAX_TESS_CONTROL_IMAGE_UNIFORMS = $90CB;

This item has no description.

GL_MAX_TESS_EVALUATION_IMAGE_UNIFORMS = $90CC;

This item has no description.

GL_MAX_GEOMETRY_IMAGE_UNIFORMS = $90CD;

This item has no description.

GL_MAX_FRAGMENT_IMAGE_UNIFORMS = $90CE;

This item has no description.

GL_MAX_COMBINED_IMAGE_UNIFORMS = $90CF;

This item has no description.

GL_TEXTURE_IMMUTABLE_FORMAT = $912F;

GL_ARB_texture_storage

GL_COMPRESSED_RGBA_ASTC_4x4_KHR = $93B0;

4.3 GL_KHR_texture_compression_astc_hdr

GL_COMPRESSED_RGBA_ASTC_5x4_KHR = $93B1;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_5x5_KHR = $93B2;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_6x5_KHR = $93B3;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_6x6_KHR = $93B4;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_8x5_KHR = $93B5;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_8x6_KHR = $93B6;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_8x8_KHR = $93B7;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_105_KHR = $93B8;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_106_KHR = $93B9;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_108_KHR = $93BA;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_110_KHR = $93BB;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_12x10_KHR = $93BC;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_12x12_KHR = $93BD;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_4x4_KHR = $93D0;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x4_KHR = $93D1;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x5_KHR = $93D2;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x5_KHR = $93D3;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x6_KHR = $93D4;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x5_KHR = $93D5;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x6_KHR = $93D6;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x8_KHR = $93D7;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x5_KHR = $93D8;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x6_KHR = $93D9;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x8_KHR = $93DA;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x10_KHR = $93DB;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x10_KHR = $93DC;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x12_KHR = $93DD;

This item has no description.

GL_DEBUG_OUTPUT_SYNCHRONOUS = $8242;

(4.3) GL_KHR_debug

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH = $8243;

This item has no description.

GL_DEBUG_CALLBACK_FUNCTION = $8244;

This item has no description.

GL_DEBUG_CALLBACK_USER_PARAM = $8245;

This item has no description.

GL_DEBUG_SOURCE_API = $8246;

This item has no description.

GL_DEBUG_SOURCE_WINDOW_SYSTEM = $8247;

This item has no description.

GL_DEBUG_SOURCE_SHADER_COMPILER = $8248;

This item has no description.

GL_DEBUG_SOURCE_THIRD_PARTY = $8249;

This item has no description.

GL_DEBUG_SOURCE_APPLICATION = $824A;

This item has no description.

GL_DEBUG_SOURCE_OTHER = $824B;

This item has no description.

GL_DEBUG_TYPE_ERROR = $824C;

This item has no description.

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR = $824D;

This item has no description.

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR = $824E;

This item has no description.

GL_DEBUG_TYPE_PORTABILITY = $824F;

This item has no description.

GL_DEBUG_TYPE_PERFORMANCE = $8250;

This item has no description.

GL_DEBUG_TYPE_OTHER = $8251;

This item has no description.

GL_DEBUG_TYPE_MARKER = $8268;

This item has no description.

GL_DEBUG_TYPE_PUSH_GROUP = $8269;

This item has no description.

GL_DEBUG_TYPE_POP_GROUP = $826A;

This item has no description.

GL_DEBUG_SEVERITY_NOTIFICATION = $826B;

This item has no description.

GL_MAX_DEBUG_GROUP_STACK_DEPTH = $826C;

This item has no description.

GL_DEBUG_GROUP_STACK_DEPTH = $826D;

This item has no description.

GL_BUFFER = $82E0;

This item has no description.

GL_SHADER = $82E1;

This item has no description.

GL_PROGRAM = $82E2;

This item has no description.

GL_QUERY = $82E3;

This item has no description.

GL_PROGRAM_PIPELINE = $82E4;

This item has no description.

GL_SAMPLER = $82E6;

This item has no description.

GL_DISPLAY_LIST = $82E7;

This item has no description.

GL_MAX_LABEL_LENGTH = $82E8;

This item has no description.

GL_MAX_DEBUG_MESSAGE_LENGTH = $9143;

This item has no description.

GL_MAX_DEBUG_LOGGED_MESSAGES = $9144;

This item has no description.

GL_DEBUG_LOGGED_MESSAGES = $9145;

This item has no description.

GL_DEBUG_SEVERITY_HIGH = $9146;

This item has no description.

GL_DEBUG_SEVERITY_MEDIUM = $9147;

This item has no description.

GL_DEBUG_SEVERITY_LOW = $9148;

This item has no description.

GL_DEBUG_OUTPUT = $92E0;

This item has no description.

GL_CONTEXT_FLAG_DEBUG_BIT = $00000002;

This item has no description.

GL_COMPUTE_SHADER = $91B9;

This item has no description.

GL_MAX_COMPUTE_UNIFORM_BLOCKS = $91BB;

This item has no description.

GL_MAX_COMPUTE_TEXTURE_IMAGE_UNITS = $91BC;

This item has no description.

GL_MAX_COMPUTE_IMAGE_UNIFORMS = $91BD;

This item has no description.

GL_MAX_COMPUTE_SHARED_MEMORY_SIZE = $8262;

This item has no description.

GL_MAX_COMPUTE_UNIFORM_COMPONENTS = $8263;

This item has no description.

GL_MAX_COMPUTE_ATOMIC_COUNTER_BUFFERS = $8264;

This item has no description.

GL_MAX_COMPUTE_ATOMIC_COUNTERS = $8265;

This item has no description.

GL_MAX_COMBINED_COMPUTE_UNIFORM_COMPONENTS = $8266;

This item has no description.

GL_MAX_COMPUTE_LOCAL_INVOCATIONS = $90EB;

This item has no description.

GL_MAX_COMPUTE_WORK_GROUP_COUNT = $91BE;

This item has no description.

GL_MAX_COMPUTE_WORK_GROUP_SIZE = $91BF;

This item has no description.

GL_COMPUTE_LOCAL_WORK_SIZE = $8267;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_COMPUTE_SHADER = $90EC;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_COMPUTE_SHADER = $90ED;

This item has no description.

GL_DISPATCH_INDIRECT_BUFFER = $90EE;

This item has no description.

GL_DISPATCH_INDIRECT_BUFFER_BINDING = $90EF;

This item has no description.

GL_COMPUTE_SHADER_BIT = $00000020;

This item has no description.

GL_COMPRESSED_RGB8_ETC2 = $9274;

This item has no description.

GL_COMPRESSED_SRGB8_ETC2 = $9275;

This item has no description.

GL_COMPRESSED_RGB8_PUNCHTHROUGH_ALPHA1_ETC2 = $9276;

This item has no description.

GL_COMPRESSED_SRGB8_PUNCHTHROUGH_ALPHA1_ETC2 = $9277;

This item has no description.

GL_COMPRESSED_RGBA8_ETC2_EAC = $9278;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ETC2_EAC = $9279;

This item has no description.

GL_COMPRESSED_R11_EAC = $9270;

This item has no description.

GL_COMPRESSED_SIGNED_R11_EAC = $9271;

This item has no description.

GL_COMPRESSED_RG11_EAC = $9272;

This item has no description.

GL_COMPRESSED_SIGNED_RG11_EAC = $9273;

This item has no description.

GL_PRIMITIVE_RESTART_FIXED_INDEX = $8D69;

This item has no description.

GL_ANY_SAMPLES_PASSED_CONSERVATIVE = $8D6A;

This item has no description.

GL_MAX_ELEMENT_INDEX = $8D6B;

This item has no description.

GL_MAX_UNIFORM_LOCATIONS = $826E;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_WIDTH = $9310;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_HEIGHT = $9311;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_LAYERS = $9312;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_SAMPLES = $9313;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_FIXED_SAMPLE_LOCATIONS = $9314;

This item has no description.

GL_MAX_FRAMEBUFFER_WIDTH = $9315;

This item has no description.

GL_MAX_FRAMEBUFFER_HEIGHT = $9316;

This item has no description.

GL_MAX_FRAMEBUFFER_LAYERS = $9317;

This item has no description.

GL_MAX_FRAMEBUFFER_SAMPLES = $9318;

This item has no description.

GL_INTERNALFORMAT_SUPPORTED = $826F;

This item has no description.

GL_INTERNALFORMAT_PREFERRED = $8270;

This item has no description.

GL_INTERNALFORMAT_RED_SIZE = $8271;

This item has no description.

GL_INTERNALFORMAT_GREEN_SIZE = $8272;

This item has no description.

GL_INTERNALFORMAT_BLUE_SIZE = $8273;

This item has no description.

GL_INTERNALFORMAT_ALPHA_SIZE = $8274;

This item has no description.

GL_INTERNALFORMAT_DEPTH_SIZE = $8275;

This item has no description.

GL_INTERNALFORMAT_STENCIL_SIZE = $8276;

This item has no description.

GL_INTERNALFORMAT_SHARED_SIZE = $8277;

This item has no description.

GL_INTERNALFORMAT_RED_TYPE = $8278;

This item has no description.

GL_INTERNALFORMAT_GREEN_TYPE = $8279;

This item has no description.

GL_INTERNALFORMAT_BLUE_TYPE = $827A;

This item has no description.

GL_INTERNALFORMAT_ALPHA_TYPE = $827B;

This item has no description.

GL_INTERNALFORMAT_DEPTH_TYPE = $827C;

This item has no description.

GL_INTERNALFORMAT_STENCIL_TYPE = $827D;

This item has no description.

GL_MAX_WIDTH = $827E;

This item has no description.

GL_MAX_HEIGHT = $827F;

This item has no description.

GL_MAX_DEPTH = $8280;

This item has no description.

GL_MAX_LAYERS = $8281;

This item has no description.

GL_MAX_COMBINED_DIMENSIONS = $8282;

This item has no description.

GL_COLOR_COMPONENTS = $8283;

This item has no description.

GL_DEPTH_COMPONENTS = $8284;

This item has no description.

GL_STENCIL_COMPONENTS = $8285;

This item has no description.

GL_COLOR_RENDERABLE = $8286;

This item has no description.

GL_DEPTH_RENDERABLE = $8287;

This item has no description.

GL_STENCIL_RENDERABLE = $8288;

This item has no description.

GL_FRAMEBUFFER_RENDERABLE = $8289;

This item has no description.

GL_FRAMEBUFFER_RENDERABLE_LAYERED = $828A;

This item has no description.

GL_FRAMEBUFFER_BLEND = $828B;

This item has no description.

GL_READ_PIXELS = $828C;

This item has no description.

GL_READ_PIXELS_FORMAT = $828D;

This item has no description.

GL_READ_PIXELS_TYPE = $828E;

This item has no description.

GL_TEXTURE_IMAGE_FORMAT = $828F;

This item has no description.

GL_TEXTURE_IMAGE_TYPE = $8290;

This item has no description.

GL_GET_TEXTURE_IMAGE_FORMAT = $8291;

This item has no description.

GL_GET_TEXTURE_IMAGE_TYPE = $8292;

This item has no description.

GL_MIPMAP = $8293;

This item has no description.

GL_MANUAL_GENERATE_MIPMAP = $8294;

This item has no description.

GL_AUTO_GENERATE_MIPMAP = $8295;

This item has no description.

GL_COLOR_ENCODING = $8296;

This item has no description.

GL_SRGB_READ = $8297;

This item has no description.

GL_SRGB_WRITE = $8298;

This item has no description.

GL_SRGB_DECODE_ARB = $8299;

This item has no description.

GL_FILTER = $829A;

This item has no description.

GL_VERTEX_TEXTURE = $829B;

This item has no description.

GL_TESS_CONTROL_TEXTURE = $829C;

This item has no description.

GL_TESS_EVALUATION_TEXTURE = $829D;

This item has no description.

GL_GEOMETRY_TEXTURE = $829E;

This item has no description.

GL_FRAGMENT_TEXTURE = $829F;

This item has no description.

GL_COMPUTE_TEXTURE = $82A0;

This item has no description.

GL_TEXTURE_SHADOW = $82A1;

This item has no description.

GL_TEXTURE_GATHER = $82A2;

This item has no description.

GL_TEXTURE_GATHER_SHADOW = $82A3;

This item has no description.

GL_SHADER_IMAGE_LOAD = $82A4;

This item has no description.

GL_SHADER_IMAGE_STORE = $82A5;

This item has no description.

GL_SHADER_IMAGE_ATOMIC = $82A6;

This item has no description.

GL_IMAGE_TEXEL_SIZE = $82A7;

This item has no description.

GL_IMAGE_COMPATIBILITY_CLASS = $82A8;

This item has no description.

GL_IMAGE_PIXEL_FORMAT = $82A9;

This item has no description.

GL_IMAGE_PIXEL_TYPE = $82AA;

This item has no description.

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_TEST = $82AC;

This item has no description.

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_TEST = $82AD;

This item has no description.

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_WRITE = $82AE;

This item has no description.

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_WRITE = $82AF;

This item has no description.

GL_TEXTURE_COMPRESSED_BLOCK_WIDTH = $82B1;

This item has no description.

GL_TEXTURE_COMPRESSED_BLOCK_HEIGHT = $82B2;

This item has no description.

GL_TEXTURE_COMPRESSED_BLOCK_SIZE = $82B3;

This item has no description.

GL_CLEAR_BUFFER = $82B4;

This item has no description.

GL_TEXTURE_VIEW = $82B5;

This item has no description.

GL_VIEW_COMPATIBILITY_CLASS = $82B6;

This item has no description.

GL_FULL_SUPPORT = $82B7;

This item has no description.

GL_CAVEAT_SUPPORT = $82B8;

This item has no description.

GL_IMAGE_CLASS_4_X_32 = $82B9;

This item has no description.

GL_IMAGE_CLASS_2_X_32 = $82BA;

This item has no description.

GL_IMAGE_CLASS_1_X_32 = $82BB;

This item has no description.

GL_IMAGE_CLASS_4_X_16 = $82BC;

This item has no description.

GL_IMAGE_CLASS_2_X_16 = $82BD;

This item has no description.

GL_IMAGE_CLASS_1_X_16 = $82BE;

This item has no description.

GL_IMAGE_CLASS_4_X_8 = $82BF;

This item has no description.

GL_IMAGE_CLASS_2_X_8 = $82C0;

This item has no description.

GL_IMAGE_CLASS_1_X_8 = $82C1;

This item has no description.

GL_IMAGE_CLASS_11_11_10 = $82C2;

This item has no description.

GL_IMAGE_CLASS_10_10_10_2 = $82C3;

This item has no description.

GL_VIEW_CLASS_128_BITS = $82C4;

This item has no description.

GL_VIEW_CLASS_96_BITS = $82C5;

This item has no description.

GL_VIEW_CLASS_64_BITS = $82C6;

This item has no description.

GL_VIEW_CLASS_48_BITS = $82C7;

This item has no description.

GL_VIEW_CLASS_32_BITS = $82C8;

This item has no description.

GL_VIEW_CLASS_24_BITS = $82C9;

This item has no description.

GL_VIEW_CLASS_16_BITS = $82CA;

This item has no description.

GL_VIEW_CLASS_8_BITS = $82CB;

This item has no description.

GL_VIEW_CLASS_S3TC_DXT1_RGB = $82CC;

This item has no description.

GL_VIEW_CLASS_S3TC_DXT1_RGBA = $82CD;

This item has no description.

GL_VIEW_CLASS_S3TC_DXT3_RGBA = $82CE;

This item has no description.

GL_VIEW_CLASS_S3TC_DXT5_RGBA = $82CF;

This item has no description.

GL_VIEW_CLASS_RGTC1_RED = $82D0;

This item has no description.

GL_VIEW_CLASS_RGTC2_RG = $82D1;

This item has no description.

GL_VIEW_CLASS_BPTC_UNORM = $82D2;

This item has no description.

GL_VIEW_CLASS_BPTC_FLOAT = $82D3;

This item has no description.

GL_UNIFORM = $92E1;

This item has no description.

GL_UNIFORM_BLOCK = $92E2;

This item has no description.

GL_PROGRAM_INPUT = $92E3;

This item has no description.

GL_PROGRAM_OUTPUT = $92E4;

This item has no description.

GL_BUFFER_VARIABLE = $92E5;

This item has no description.

GL_SHADER_STORAGE_BLOCK = $92E6;

This item has no description.

GL_VERTEX_SUBROUTINE = $92E8;

This item has no description.

GL_TESS_CONTROL_SUBROUTINE = $92E9;

This item has no description.

GL_TESS_EVALUATION_SUBROUTINE = $92EA;

This item has no description.

GL_GEOMETRY_SUBROUTINE = $92EB;

This item has no description.

GL_FRAGMENT_SUBROUTINE = $92EC;

This item has no description.

GL_COMPUTE_SUBROUTINE = $92ED;

This item has no description.

GL_VERTEX_SUBROUTINE_UNIFORM = $92EE;

This item has no description.

GL_TESS_CONTROL_SUBROUTINE_UNIFORM = $92EF;

This item has no description.

GL_TESS_EVALUATION_SUBROUTINE_UNIFORM = $92F0;

This item has no description.

GL_GEOMETRY_SUBROUTINE_UNIFORM = $92F1;

This item has no description.

GL_FRAGMENT_SUBROUTINE_UNIFORM = $92F2;

This item has no description.

GL_COMPUTE_SUBROUTINE_UNIFORM = $92F3;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYING = $92F4;

This item has no description.

GL_ACTIVE_RESOURCES = $92F5;

This item has no description.

GL_MAX_NAME_LENGTH = $92F6;

This item has no description.

GL_MAX_NUM_ACTIVE_VARIABLES = $92F7;

This item has no description.

GL_MAX_NUM_COMPATIBLE_SUBROUTINES = $92F8;

This item has no description.

GL_NAME_LENGTH = $92F9;

This item has no description.

GL_TYPE = $92FA;

This item has no description.

GL_ARRAY_SIZE = $92FB;

This item has no description.

GL_OFFSET = $92FC;

This item has no description.

GL_BLOCK_INDEX = $92FD;

This item has no description.

GL_ARRAY_STRIDE = $92FE;

This item has no description.

GL_MATRIX_STRIDE = $92FF;

This item has no description.

GL_IS_ROW_MAJOR = $9300;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_INDEX = $9301;

This item has no description.

GL_BUFFER_BINDING = $9302;

This item has no description.

GL_BUFFER_DATA_SIZE = $9303;

This item has no description.

GL_NUM_ACTIVE_VARIABLES = $9304;

This item has no description.

GL_ACTIVE_VARIABLES = $9305;

This item has no description.

GL_REFERENCED_BY_VERTEX_SHADER = $9306;

This item has no description.

GL_REFERENCED_BY_TESS_CONTROL_SHADER = $9307;

This item has no description.

GL_REFERENCED_BY_TESS_EVALUATION_SHADER = $9308;

This item has no description.

GL_REFERENCED_BY_GEOMETRY_SHADER = $9309;

This item has no description.

GL_REFERENCED_BY_FRAGMENT_SHADER = $930A;

This item has no description.

GL_REFERENCED_BY_COMPUTE_SHADER = $930B;

This item has no description.

GL_TOP_LEVEL_ARRAY_SIZE = $930C;

This item has no description.

GL_TOP_LEVEL_ARRAY_STRIDE = $930D;

This item has no description.

GL_LOCATION = $930E;

This item has no description.

GL_LOCATION_INDEX = $930F;

This item has no description.

GL_IS_PER_PATCH = $92E7;

This item has no description.

GL_SHADER_STORAGE_BUFFER = $90D2;

This item has no description.

GL_SHADER_STORAGE_BUFFER_BINDING = $90D3;

This item has no description.

GL_SHADER_STORAGE_BUFFER_START = $90D4;

This item has no description.

GL_SHADER_STORAGE_BUFFER_SIZE = $90D5;

This item has no description.

GL_MAX_VERTEX_SHADER_STORAGE_BLOCKS = $90D6;

This item has no description.

GL_MAX_GEOMETRY_SHADER_STORAGE_BLOCKS = $90D7;

This item has no description.

GL_MAX_TESS_CONTROL_SHADER_STORAGE_BLOCKS = $90D8;

This item has no description.

GL_MAX_TESS_EVALUATION_SHADER_STORAGE_BLOCKS = $90D9;

This item has no description.

GL_MAX_FRAGMENT_SHADER_STORAGE_BLOCKS = $90DA;

This item has no description.

GL_MAX_COMPUTE_SHADER_STORAGE_BLOCKS = $90DB;

This item has no description.

GL_MAX_COMBINED_SHADER_STORAGE_BLOCKS = $90DC;

This item has no description.

GL_MAX_SHADER_STORAGE_BUFFER_BINDINGS = $90DD;

This item has no description.

GL_MAX_SHADER_STORAGE_BLOCK_SIZE = $90DE;

This item has no description.

GL_SHADER_STORAGE_BUFFER_OFFSET_ALIGNMENT = $90DF;

This item has no description.

GL_SHADER_STORAGE_BARRIER_BIT = $2000;

This item has no description.

GL_MAX_COMBINED_SHADER_OUTPUT_RESOURCES = GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS;

This item has no description.

GL_DEPTH_STENCIL_TEXTURE_MODE = $90EA;

This item has no description.

GL_TEXTURE_BUFFER_OFFSET = $919D;

This item has no description.

GL_TEXTURE_BUFFER_SIZE = $919E;

This item has no description.

GL_TEXTURE_BUFFER_OFFSET_ALIGNMENT = $919F;

This item has no description.

GL_TEXTURE_VIEW_MIN_LEVEL = $82DB;

This item has no description.

GL_TEXTURE_VIEW_NUM_LEVELS = $82DC;

This item has no description.

GL_TEXTURE_VIEW_MIN_LAYER = $82DD;

This item has no description.

GL_TEXTURE_VIEW_NUM_LAYERS = $82DE;

This item has no description.

GL_TEXTURE_IMMUTABLE_LEVELS = $82DF;

This item has no description.

GL_VERTEX_ATTRIB_BINDING = $82D4;

This item has no description.

GL_VERTEX_ATTRIB_RELATIVE_OFFSET = $82D5;

This item has no description.

GL_VERTEX_BINDING_DIVISOR = $82D6;

This item has no description.

GL_VERTEX_BINDING_OFFSET = $82D7;

This item has no description.

GL_VERTEX_BINDING_STRIDE = $82D8;

This item has no description.

GL_MAX_VERTEX_ATTRIB_RELATIVE_OFFSET = $82D9;

This item has no description.

GL_MAX_VERTEX_ATTRIB_BINDINGS = $82DA;

This item has no description.

GL_MAX_VERTEX_ATTRIB_STRIDE = $82E5;

GL 4.4

GL_PRIMITIVE_RESTART_FOR_PATCHES_SUPPORTED = $8221;

This item has no description.

GL_TEXTURE_BUFFER_BINDING = $8C2A;

This item has no description.

GL_MAP_PERSISTENT_BIT = $0040;

This item has no description.

GL_MAP_COHERENT_BIT = $0080;

This item has no description.

GL_DYNAMIC_STORAGE_BIT = $0100;

This item has no description.

GL_CLIENT_STORAGE_BIT = $0200;

This item has no description.

GL_CLIENT_MAPPED_BUFFER_BARRIER_BIT = $00004000;

This item has no description.

GL_BUFFER_IMMUTABLE_STORAGE = $821F;

This item has no description.

GL_BUFFER_STORAGE_FLAGS = $8220;

This item has no description.

GL_CLEAR_TEXTURE = $9365;

This item has no description.

GL_LOCATION_COMPONENT = $934A;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_INDEX = $934B;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_STRIDE = $934C;

This item has no description.

GL_QUERY_BUFFER = $9192;

This item has no description.

GL_QUERY_BUFFER_BARRIER_BIT = $00008000;

This item has no description.

GL_QUERY_BUFFER_BINDING = $9193;

This item has no description.

GL_QUERY_RESULT_NO_WAIT = $9194;

This item has no description.

GL_MIRROR_CLAMP_TO_EDGE = $8743;

This item has no description.

GL_CONTEXT_LOST = $0507;

GL 4.5

GL_NEGATIVE_ONE_TO_ONE = $935E;

This item has no description.

GL_ZERO_TO_ONE = $935F;

This item has no description.

GL_CLIP_ORIGIN = $935C;

This item has no description.

GL_CLIP_DEPTH_MODE = $935D;

This item has no description.

GL_QUERY_WAIT_INVERTED = $8E17;

This item has no description.

GL_QUERY_NO_WAIT_INVERTED = $8E18;

This item has no description.

GL_QUERY_BY_REGION_WAIT_INVERTED = $8E19;

This item has no description.

GL_QUERY_BY_REGION_NO_WAIT_INVERTED = $8E1A;

This item has no description.

GL_MAX_CULL_DISTANCES = $82F9;

This item has no description.

GL_MAX_COMBINED_CLIP_AND_CULL_DISTANCES = $82FA;

This item has no description.

GL_TEXTURE_TARGET = $1006;

This item has no description.

GL_QUERY_TARGET = $82EA;

This item has no description.

GL_TEXTURE_BINDING = $82EB;

This item has no description.

GL_GUILTY_CONTEXT_RESET = $8253;

This item has no description.

GL_INNOCENT_CONTEXT_RESET = $8254;

This item has no description.

GL_UNKNOWN_CONTEXT_RESET = $8255;

This item has no description.

GL_RESET_NOTIFICATION_STRATEGY = $8256;

This item has no description.

GL_LOSE_CONTEXT_ON_RESET = $8252;

This item has no description.

GL_NO_RESET_NOTIFICATION = $8261;

This item has no description.

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT = $00000004;

This item has no description.

GL_CONTEXT_RELEASE_BEHAVIOR = $82FB;

This item has no description.

GL_CONTEXT_RELEASE_BEHAVIOR_FLUSH = $82FC;

This item has no description.

GL_SHADER_BINARY_FORMAT_SPIR_V = $9551;

4.6

GL_SPIR_V_BINARY = $9552;

This item has no description.

GL_PARAMETER_BUFFER = $80EE;

This item has no description.

GL_PARAMETER_BUFFER_BINDING = $80EF;

This item has no description.

GL_CONTEXT_FLAG_NO_ERROR_BIT = $00000008;

This item has no description.

GL_VERTICES_SUBMITTED = $82EE;

This item has no description.

GL_PRIMITIVES_SUBMITTED = $82EF;

This item has no description.

GL_VERTEX_SHADER_INVOCATIONS = $82F0;

This item has no description.

GL_TESS_CONTROL_SHADER_PATCHES = $82F1;

This item has no description.

GL_TESS_EVALUATION_SHADER_INVOCATIONS = $82F2;

This item has no description.

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED = $82F3;

This item has no description.

GL_FRAGMENT_SHADER_INVOCATIONS = $82F4;

This item has no description.

GL_COMPUTE_SHADER_INVOCATIONS = $82F5;

This item has no description.

GL_CLIPPING_INPUT_PRIMITIVES = $82F6;

This item has no description.

GL_CLIPPING_OUTPUT_PRIMITIVES = $82F7;

This item has no description.

GL_POLYGON_OFFSET_CLAMP = $8E1B;

This item has no description.

GL_SPIR_V_EXTENSIONS = $9553;

This item has no description.

GL_NUM_SPIR_V_EXTENSIONS = $9554;

This item has no description.

GL_TEXTURE_MAX_ANISOTROPY = $84FE;

This item has no description.

GL_MAX_TEXTURE_MAX_ANISOTROPY = $84FF;

This item has no description.

GL_TRANSFORM_FEEDBACK_OVERFLOW = $82EC;

This item has no description.

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW = $82ED;

This item has no description.

GL_MAX_DRAW_BUFFERS_ATI = $8824;

GL_ATI_draw_buffers

GL_DRAW_BUFFER0_ATI = $8825;

This item has no description.

GL_DRAW_BUFFER1_ATI = $8826;

This item has no description.

GL_DRAW_BUFFER2_ATI = $8827;

This item has no description.

GL_DRAW_BUFFER3_ATI = $8828;

This item has no description.

GL_DRAW_BUFFER4_ATI = $8829;

This item has no description.

GL_DRAW_BUFFER5_ATI = $882A;

This item has no description.

GL_DRAW_BUFFER6_ATI = $882B;

This item has no description.

GL_DRAW_BUFFER7_ATI = $882C;

This item has no description.

GL_DRAW_BUFFER8_ATI = $882D;

This item has no description.

GL_DRAW_BUFFER9_ATI = $882E;

This item has no description.

GL_DRAW_BUFFER10_ATI = $882F;

This item has no description.

GL_DRAW_BUFFER11_ATI = $8830;

This item has no description.

GL_DRAW_BUFFER12_ATI = $8831;

This item has no description.

GL_DRAW_BUFFER13_ATI = $8832;

This item has no description.

GL_DRAW_BUFFER14_ATI = $8833;

This item has no description.

GL_DRAW_BUFFER15_ATI = $8834;

This item has no description.

GL_ELEMENT_ARRAY_ATI = $8768;

GL_ATI_element_array

GL_ELEMENT_ARRAY_TYPE_ATI = $8769;

This item has no description.

GL_ELEMENT_ARRAY_POINTER_ATI = $876A;

This item has no description.

GL_BUMP_ROT_MATRIX_ATI = $8775;

GL_ATI_envmap_bumpmap

GL_BUMP_ROT_MATRIX_SIZE_ATI = $8776;

This item has no description.

GL_BUMP_NUM_TEX_UNITS_ATI = $8777;

This item has no description.

GL_BUMP_TEX_UNITS_ATI = $8778;

This item has no description.

GL_DUDV_ATI = $8779;

This item has no description.

GL_DU8DV8_ATI = $877A;

This item has no description.

GL_BUMP_ENVMAP_ATI = $877B;

This item has no description.

GL_BUMP_TARGET_ATI = $877C;

This item has no description.

GL_FRAGMENT_SHADER_ATI = $8920;

GL_ATI_fragment_shader

GL_REG_0_ATI = $8921;

This item has no description.

GL_REG_1_ATI = $8922;

This item has no description.

GL_REG_2_ATI = $8923;

This item has no description.

GL_REG_3_ATI = $8924;

This item has no description.

GL_REG_4_ATI = $8925;

This item has no description.

GL_REG_5_ATI = $8926;

This item has no description.

GL_REG_6_ATI = $8927;

This item has no description.

GL_REG_7_ATI = $8928;

This item has no description.

GL_REG_8_ATI = $8929;

This item has no description.

GL_REG_9_ATI = $892A;

This item has no description.

GL_REG_10_ATI = $892B;

This item has no description.

GL_REG_11_ATI = $892C;

This item has no description.

GL_REG_12_ATI = $892D;

This item has no description.

GL_REG_13_ATI = $892E;

This item has no description.

GL_REG_14_ATI = $892F;

This item has no description.

GL_REG_15_ATI = $8930;

This item has no description.

GL_REG_16_ATI = $8931;

This item has no description.

GL_REG_17_ATI = $8932;

This item has no description.

GL_REG_18_ATI = $8933;

This item has no description.

GL_REG_19_ATI = $8934;

This item has no description.

GL_REG_20_ATI = $8935;

This item has no description.

GL_REG_21_ATI = $8936;

This item has no description.

GL_REG_22_ATI = $8937;

This item has no description.

GL_REG_23_ATI = $8938;

This item has no description.

GL_REG_24_ATI = $8939;

This item has no description.

GL_REG_25_ATI = $893A;

This item has no description.

GL_REG_26_ATI = $893B;

This item has no description.

GL_REG_27_ATI = $893C;

This item has no description.

GL_REG_28_ATI = $893D;

This item has no description.

GL_REG_29_ATI = $893E;

This item has no description.

GL_REG_30_ATI = $893F;

This item has no description.

GL_REG_31_ATI = $8940;

This item has no description.

GL_CON_0_ATI = $8941;

This item has no description.

GL_CON_1_ATI = $8942;

This item has no description.

GL_CON_2_ATI = $8943;

This item has no description.

GL_CON_3_ATI = $8944;

This item has no description.

GL_CON_4_ATI = $8945;

This item has no description.

GL_CON_5_ATI = $8946;

This item has no description.

GL_CON_6_ATI = $8947;

This item has no description.

GL_CON_7_ATI = $8948;

This item has no description.

GL_CON_8_ATI = $8949;

This item has no description.

GL_CON_9_ATI = $894A;

This item has no description.

GL_CON_10_ATI = $894B;

This item has no description.

GL_CON_11_ATI = $894C;

This item has no description.

GL_CON_12_ATI = $894D;

This item has no description.

GL_CON_13_ATI = $894E;

This item has no description.

GL_CON_14_ATI = $894F;

This item has no description.

GL_CON_15_ATI = $8950;

This item has no description.

GL_CON_16_ATI = $8951;

This item has no description.

GL_CON_17_ATI = $8952;

This item has no description.

GL_CON_18_ATI = $8953;

This item has no description.

GL_CON_19_ATI = $8954;

This item has no description.

GL_CON_20_ATI = $8955;

This item has no description.

GL_CON_21_ATI = $8956;

This item has no description.

GL_CON_22_ATI = $8957;

This item has no description.

GL_CON_23_ATI = $8958;

This item has no description.

GL_CON_24_ATI = $8959;

This item has no description.

GL_CON_25_ATI = $895A;

This item has no description.

GL_CON_26_ATI = $895B;

This item has no description.

GL_CON_27_ATI = $895C;

This item has no description.

GL_CON_28_ATI = $895D;

This item has no description.

GL_CON_29_ATI = $895E;

This item has no description.

GL_CON_30_ATI = $895F;

This item has no description.

GL_CON_31_ATI = $8960;

This item has no description.

GL_MOV_ATI = $8961;

This item has no description.

GL_ADD_ATI = $8963;

This item has no description.

GL_MUL_ATI = $8964;

This item has no description.

GL_SUB_ATI = $8965;

This item has no description.

GL_DOT3_ATI = $8966;

This item has no description.

GL_DOT4_ATI = $8967;

This item has no description.

GL_MAD_ATI = $8968;

This item has no description.

GL_LERP_ATI = $8969;

This item has no description.

GL_CND_ATI = $896A;

This item has no description.

GL_CND0_ATI = $896B;

This item has no description.

GL_DOT2_ADD_ATI = $896C;

This item has no description.

GL_SECONDARY_INTERPOLATOR_ATI = $896D;

This item has no description.

GL_NUM_FRAGMENT_REGISTERS_ATI = $896E;

This item has no description.

GL_NUM_FRAGMENT_CONSTANTS_ATI = $896F;

This item has no description.

GL_NUM_PASSES_ATI = $8970;

This item has no description.

GL_NUM_INSTRUCTIONS_PER_PASS_ATI = $8971;

This item has no description.

GL_NUM_INSTRUCTIONS_TOTAL_ATI = $8972;

This item has no description.

GL_NUM_INPUT_INTERPOLATOR_COMPONENTS_ATI = $8973;

This item has no description.

GL_NUM_LOOPBACK_COMPONENTS_ATI = $8974;

This item has no description.

GL_COLOR_ALPHA_PAIRING_ATI = $8975;

This item has no description.

GL_SWIZZLE_STR_ATI = $8976;

This item has no description.

GL_SWIZZLE_STQ_ATI = $8977;

This item has no description.

GL_SWIZZLE_STR_DR_ATI = $8978;

This item has no description.

GL_SWIZZLE_STQ_DQ_ATI = $8979;

This item has no description.

GL_SWIZZLE_STRQ_ATI = $897A;

This item has no description.

GL_SWIZZLE_STRQ_DQ_ATI = $897B;

This item has no description.

GL_RED_BIT_ATI = $00000001;

This item has no description.

GL_GREEN_BIT_ATI = $00000002;

This item has no description.

GL_BLUE_BIT_ATI = $00000004;

This item has no description.

GL_2X_BIT_ATI = $00000001;

This item has no description.

GL_4X_BIT_ATI = $00000002;

This item has no description.

GL_8X_BIT_ATI = $00000004;

This item has no description.

GL_HALF_BIT_ATI = $00000008;

This item has no description.

GL_QUARTER_BIT_ATI = $00000010;

This item has no description.

GL_EIGHTH_BIT_ATI = $00000020;

This item has no description.

GL_SATURATE_BIT_ATI = $00000040;

This item has no description.

GL_COMP_BIT_ATI = $00000002;

This item has no description.

GL_NEGATE_BIT_ATI = $00000004;

This item has no description.

GL_BIAS_BIT_ATI = $00000008;

This item has no description.

GL_PN_TRIANGLES_ATI = $87F0;

GL_ATI_pn_triangles

GL_MAX_PN_TRIANGLES_TESSELATION_LEVEL_ATI = $87F1;

This item has no description.

GL_PN_TRIANGLES_POINT_MODE_ATI = $87F2;

This item has no description.

GL_PN_TRIANGLES_NORMAL_MODE_ATI = $87F3;

This item has no description.

GL_PN_TRIANGLES_TESSELATION_LEVEL_ATI = $87F4;

This item has no description.

GL_PN_TRIANGLES_POINT_MODE_LINEAR_ATI = $87F5;

This item has no description.

GL_PN_TRIANGLES_POINT_MODE_CUBIC_ATI = $87F6;

This item has no description.

GL_PN_TRIANGLES_NORMAL_MODE_LINEAR_ATI = $87F7;

This item has no description.

GL_PN_TRIANGLES_NORMAL_MODE_QUADRATIC_ATI = $87F8;

This item has no description.

GL_STENCIL_BACK_FUNC_ATI = $8800;

GL_ATI_separate_stencil

GL_STENCIL_BACK_FAIL_ATI = $8801;

This item has no description.

GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI = $8802;

This item has no description.

GL_STENCIL_BACK_PASS_DEPTH_PASS_ATI = $8803;

This item has no description.

GL_TEXT_FRAGMENT_SHADER_ATI = $8200;

GL_ATI_text_fragment_shader

GL_MODULATE_ADD_ATI = $8744;

GL_ATI_texture_env_combine3

GL_MODULATE_SIGNED_ADD_ATI = $8745;

This item has no description.

GL_MODULATE_SUBTRACT_ATI = $8746;

This item has no description.

GL_RGBA_FLOAT32_ATI = $8814;

GL_ATI_texture_float

GL_RGB_FLOAT32_ATI = $8815;

This item has no description.

GL_ALPHA_FLOAT32_ATI = $8816;

This item has no description.

GL_INTENSITY_FLOAT32_ATI = $8817;

This item has no description.

GL_LUMINANCE_FLOAT32_ATI = $8818;

This item has no description.

GL_LUMINANCE_ALPHA_FLOAT32_ATI = $8819;

This item has no description.

GL_RGBA_FLOAT16_ATI = $881A;

This item has no description.

GL_RGB_FLOAT16_ATI = $881B;

This item has no description.

GL_ALPHA_FLOAT16_ATI = $881C;

This item has no description.

GL_INTENSITY_FLOAT16_ATI = $881D;

This item has no description.

GL_LUMINANCE_FLOAT16_ATI = $881E;

This item has no description.

GL_LUMINANCE_ALPHA_FLOAT16_ATI = $881F;

This item has no description.

GL_MIRROR_CLAMP_ATI = $8742;

GL_ATI_texture_mirror_once

GL_MIRROR_CLAMP_TO_EDGE_ATI = $8743;

This item has no description.

GL_STATIC_ATI = $8760;

GL_ATI_vertex_array_object

GL_DYNAMIC_ATI = $8761;

This item has no description.

GL_PRESERVE_ATI = $8762;

This item has no description.

GL_DISCARD_ATI = $8763;

This item has no description.

GL_OBJECT_BUFFER_SIZE_ATI = $8764;

This item has no description.

GL_OBJECT_BUFFER_USAGE_ATI = $8765;

This item has no description.

GL_ARRAY_OBJECT_BUFFER_ATI = $8766;

This item has no description.

GL_ARRAY_OBJECT_OFFSET_ATI = $8767;

This item has no description.

GL_MAX_VERTEX_STREAMS_ATI = $876B;

GL_ATI_vertex_streams

GL_VERTEX_STREAM0_ATI = $876C;

This item has no description.

GL_VERTEX_STREAM1_ATI = $876D;

This item has no description.

GL_VERTEX_STREAM2_ATI = $876E;

This item has no description.

GL_VERTEX_STREAM3_ATI = $876F;

This item has no description.

GL_VERTEX_STREAM4_ATI = $8770;

This item has no description.

GL_VERTEX_STREAM5_ATI = $8771;

This item has no description.

GL_VERTEX_STREAM6_ATI = $8772;

This item has no description.

GL_VERTEX_STREAM7_ATI = $8773;

This item has no description.

GL_VERTEX_SOURCE_ATI = $8774;

This item has no description.

GL_VBO_FREE_MEMORY_ATI = $87FB;

GL_ATI_meminfo

GL_TEXTURE_FREE_MEMORY_ATI = $87FC;

This item has no description.

GL_RENDERBUFFER_FREE_MEMORY_ATI = $87FD;

This item has no description.

GL_COUNTER_TYPE_AMD = $8BC0;

GL_AMD_performance_monitor

GL_COUNTER_RANGE_AMD = $8BC1;

This item has no description.

GL_UNSIGNED_INT64_AMD = $8BC2;

This item has no description.

GL_PERCENTAGE_AMD = $8BC3;

This item has no description.

GL_PERFMON_RESULT_AVAILABLE_AMD = $8BC4;

This item has no description.

GL_PERFMON_RESULT_SIZE_AMD = $8BC5;

This item has no description.

GL_PERFMON_RESULT_AMD = $8BC6;

This item has no description.

GL_SAMPLER_BUFFER_AMD = $9001;

GL_AMD_vertex_shader_tesselator

GL_INT_SAMPLER_BUFFER_AMD = $9002;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD = $9003;

This item has no description.

GL_TESSELLATION_MODE_AMD = $9004;

This item has no description.

GL_TESSELLATION_FACTOR_AMD = $9005;

This item has no description.

GL_DISCRETE_AMD = $9006;

This item has no description.

GL_CONTINUOUS_AMD = $9007;

This item has no description.

GL_DATA_BUFFER_AMD = $9151;

GL_AMD_name_gen_delete

GL_PERFORMANCE_MONITOR_AMD = $9152;

This item has no description.

GL_QUERY_OBJECT_AMD = $9153;

This item has no description.

GL_VERTEX_ARRAY_OBJECT_AMD = $9154;

This item has no description.

GL_SAMPLER_OBJECT_AMD = $9155;

This item has no description.

GL_MAX_DEBUG_LOGGED_MESSAGES_AMD = $9144;

GL_AMD_debug_output

GL_DEBUG_LOGGED_MESSAGES_AMD = $9145;

This item has no description.

GL_DEBUG_SEVERITY_HIGH_AMD = $9146;

This item has no description.

GL_DEBUG_SEVERITY_MEDIUM_AMD = $9147;

This item has no description.

GL_DEBUG_SEVERITY_LOW_AMD = $9148;

This item has no description.

GL_DEBUG_CATEGORY_API_ERROR_AMD = $9149;

This item has no description.

GL_DEBUG_CATEGORY_WINDOW_SYSTEM_AMD = $914A;

This item has no description.

GL_DEBUG_CATEGORY_DEPRECATION_AMD = $914B;

This item has no description.

GL_DEBUG_CATEGORY_UNDEFINED_BEHAVIOR_AMD = $914C;

This item has no description.

GL_DEBUG_CATEGORY_PERFORMANCE_AMD = $914D;

This item has no description.

GL_DEBUG_CATEGORY_SHADER_COMPILER_AMD = $914E;

This item has no description.

GL_DEBUG_CATEGORY_APPLICATION_AMD = $914F;

This item has no description.

GL_DEBUG_CATEGORY_OTHER_AMD = $9150;

This item has no description.

GL_DEPTH_CLAMP_NEAR_AMD = $901E;

GL_AMD_depth_clamp_separate

GL_DEPTH_CLAMP_FAR_AMD = $901F;

This item has no description.

GL_422_EXT = $80CC;

GL_EXT_422_pixels

GL_422_REV_EXT = $80CD;

This item has no description.

GL_422_AVERAGE_EXT = $80CE;

This item has no description.

GL_422_REV_AVERAGE_EXT = $80CF;

This item has no description.

GL_ABGR_EXT = $8000;

GL_EXT_abgr

GL_BGR_EXT = $80E0;

GL_EXT_bgra

GL_BGRA_EXT = $80E1;

This item has no description.

GL_CONSTANT_COLOR_EXT = $8001;

GL_EXT_blend_color

GL_ONE_MINUS_CONSTANT_COLOR_EXT = $8002;

This item has no description.

GL_CONSTANT_ALPHA_EXT = $8003;

This item has no description.

GL_ONE_MINUS_CONSTANT_ALPHA_EXT = $8004;

This item has no description.

GL_BLEND_COLOR_EXT = $8005;

This item has no description.

GL_BLEND_DST_RGB_EXT = $80C8;

GL_EXT_blend_func_separate

GL_BLEND_SRC_RGB_EXT = $80C9;

This item has no description.

GL_BLEND_DST_ALPHA_EXT = $80CA;

This item has no description.

GL_BLEND_SRC_ALPHA_EXT = $80CB;

This item has no description.

GL_FUNC_ADD_EXT = $8006;

GL_EXT_blend_minmax

GL_MIN_EXT = $8007;

This item has no description.

GL_MAX_EXT = $8008;

This item has no description.

GL_BLEND_EQUATION_EXT = $8009;

This item has no description.

GL_FUNC_SUBTRACT_EXT = $800A;

GL_EXT_blend_subtract

GL_FUNC_REVERSE_SUBTRACT_EXT = $800B;

This item has no description.

GL_CLIP_VOLUME_CLIPPING_HINT_EXT = $80F0;

GL_EXT_clip_volume_hint

GL_CMYK_EXT = $800C;

GL_EXT_cmyka

GL_CMYKA_EXT = $800D;

This item has no description.

GL_PACK_CMYK_HINT_EXT = $800E;

This item has no description.

GL_UNPACK_CMYK_HINT_EXT = $800F;

This item has no description.

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT = $81A8;

GL_EXT_compiled_vertex_array

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT = $81A9;

This item has no description.

GL_CONVOLUTION_1D_EXT = $8010;

GL_EXT_convolution

GL_CONVOLUTION_2D_EXT = $8011;

This item has no description.

GL_SEPARABLE_2D_EXT = $8012;

This item has no description.

GL_CONVOLUTION_BORDER_MODE_EXT = $8013;

This item has no description.

GL_CONVOLUTION_FILTER_SCALE_EXT = $8014;

This item has no description.

GL_CONVOLUTION_FILTER_BIAS_EXT = $8015;

This item has no description.

GL_REDUCE_EXT = $8016;

This item has no description.

GL_CONVOLUTION_FORMAT_EXT = $8017;

This item has no description.

GL_CONVOLUTION_WIDTH_EXT = $8018;

This item has no description.

GL_CONVOLUTION_HEIGHT_EXT = $8019;

This item has no description.

GL_MAX_CONVOLUTION_WIDTH_EXT = $801A;

This item has no description.

GL_MAX_CONVOLUTION_HEIGHT_EXT = $801B;

This item has no description.

GL_POST_CONVOLUTION_RED_SCALE_EXT = $801C;

This item has no description.

GL_POST_CONVOLUTION_GREEN_SCALE_EXT = $801D;

This item has no description.

GL_POST_CONVOLUTION_BLUE_SCALE_EXT = $801E;

This item has no description.

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT = $801F;

This item has no description.

GL_POST_CONVOLUTION_RED_BIAS_EXT = $8020;

This item has no description.

GL_POST_CONVOLUTION_GREEN_BIAS_EXT = $8021;

This item has no description.

GL_POST_CONVOLUTION_BLUE_BIAS_EXT = $8022;

This item has no description.

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT = $8023;

This item has no description.

GL_TANGENT_ARRAY_EXT = $8439;

GL_EXT_coordinate_frame

GL_BINORMAL_ARRAY_EXT = $843A;

This item has no description.

GL_CURRENT_TANGENT_EXT = $843B;

This item has no description.

GL_CURRENT_BINORMAL_EXT = $843C;

This item has no description.

GL_TANGENT_ARRAY_TYPE_EXT = $843E;

This item has no description.

GL_TANGENT_ARRAY_STRIDE_EXT = $843F;

This item has no description.

GL_BINORMAL_ARRAY_TYPE_EXT = $8440;

This item has no description.

GL_BINORMAL_ARRAY_STRIDE_EXT = $8441;

This item has no description.

GL_TANGENT_ARRAY_POINTER_EXT = $8442;

This item has no description.

GL_BINORMAL_ARRAY_POINTER_EXT = $8443;

This item has no description.

GL_MAP1_TANGENT_EXT = $8444;

This item has no description.

GL_MAP2_TANGENT_EXT = $8445;

This item has no description.

GL_MAP1_BINORMAL_EXT = $8446;

This item has no description.

GL_MAP2_BINORMAL_EXT = $8447;

This item has no description.

GL_CULL_VERTEX_EXT = $81AA;

GL_EXT_cull_vertex

GL_CULL_VERTEX_EYE_POSITION_EXT = $81AB;

This item has no description.

GL_CULL_VERTEX_OBJECT_POSITION_EXT = $81AC;

This item has no description.

GL_MAX_ELEMENTS_VERTICES_EXT = $80E8;

GL_EXT_draw_range_elements

GL_MAX_ELEMENTS_INDICES_EXT = $80E9;

This item has no description.

GL_FOG_COORDINATE_SOURCE_EXT = $8450;

GL_EXT_fog_coord

GL_FOG_COORDINATE_EXT = $8451;

This item has no description.

GL_FRAGMENT_DEPTH_EXT = $8452;

This item has no description.

GL_CURRENT_FOG_COORDINATE_EXT = $8453;

This item has no description.

GL_FOG_COORDINATE_ARRAY_TYPE_EXT = $8454;

This item has no description.

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT = $8455;

This item has no description.

GL_FOG_COORDINATE_ARRAY_POINTER_EXT = $8456;

This item has no description.

GL_FOG_COORDINATE_ARRAY_EXT = $8457;

This item has no description.

GL_FRAMEBUFFER_EXT = $8D40;

GL_EXT_framebuffer_object

GL_RENDERBUFFER_EXT = $8D41;

This item has no description.

GL_STENCIL_INDEX_EXT = $8D45;

This item has no description.

GL_STENCIL_INDEX1_EXT = $8D46;

This item has no description.

GL_STENCIL_INDEX4_EXT = $8D47;

This item has no description.

GL_STENCIL_INDEX8_EXT = $8D48;

This item has no description.

GL_STENCIL_INDEX16_EXT = $8D49;

This item has no description.

GL_RENDERBUFFER_WIDTH_EXT = $8D42;

This item has no description.

GL_RENDERBUFFER_HEIGHT_EXT = $8D43;

This item has no description.

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT = $8D44;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT = $8CD0;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT = $8CD1;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT = $8CD2;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT = $8CD3;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT = $8CD4;

This item has no description.

GL_COLOR_ATTACHMENT0_EXT = $8CE0;

This item has no description.

GL_COLOR_ATTACHMENT1_EXT = $8CE1;

This item has no description.

GL_COLOR_ATTACHMENT2_EXT = $8CE2;

This item has no description.

GL_COLOR_ATTACHMENT3_EXT = $8CE3;

This item has no description.

GL_COLOR_ATTACHMENT4_EXT = $8CE4;

This item has no description.

GL_COLOR_ATTACHMENT5_EXT = $8CE5;

This item has no description.

GL_COLOR_ATTACHMENT6_EXT = $8CE6;

This item has no description.

GL_COLOR_ATTACHMENT7_EXT = $8CE7;

This item has no description.

GL_COLOR_ATTACHMENT8_EXT = $8CE8;

This item has no description.

GL_COLOR_ATTACHMENT9_EXT = $8CE9;

This item has no description.

GL_COLOR_ATTACHMENT10_EXT = $8CEA;

This item has no description.

GL_COLOR_ATTACHMENT11_EXT = $8CEB;

This item has no description.

GL_COLOR_ATTACHMENT12_EXT = $8CEC;

This item has no description.

GL_COLOR_ATTACHMENT13_EXT = $8CED;

This item has no description.

GL_COLOR_ATTACHMENT14_EXT = $8CEE;

This item has no description.

GL_COLOR_ATTACHMENT15_EXT = $8CEF;

This item has no description.

GL_DEPTH_ATTACHMENT_EXT = $8D00;

This item has no description.

GL_STENCIL_ATTACHMENT_EXT = $8D20;

This item has no description.

GL_FRAMEBUFFER_COMPLETE_EXT = $8CD5;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT = $8CD6;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT = $8CD7;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT = $8CD9;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT = $8CDA;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT = $8CDB;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT = $8CDC;

This item has no description.

GL_FRAMEBUFFER_UNSUPPORTED_EXT = $8CDD;

This item has no description.

GL_FRAMEBUFFER_STATUS_ERROR_EXT = $8CDE;

This item has no description.

GL_FRAMEBUFFER_BINDING_EXT = $8CA6;

This item has no description.

GL_RENDERBUFFER_BINDING_EXT = $8CA7;

This item has no description.

GL_MAX_COLOR_ATTACHMENTS_EXT = $8CDF;

This item has no description.

GL_MAX_RENDERBUFFER_SIZE_EXT = $84E8;

This item has no description.

GL_INVALID_FRAMEBUFFER_OPERATION_EXT = $0506;

This item has no description.

GL_HISTOGRAM_EXT = $8024;

GL_EXT_histogram

GL_PROXY_HISTOGRAM_EXT = $8025;

This item has no description.

GL_HISTOGRAM_WIDTH_EXT = $8026;

This item has no description.

GL_HISTOGRAM_FORMAT_EXT = $8027;

This item has no description.

GL_HISTOGRAM_RED_SIZE_EXT = $8028;

This item has no description.

GL_HISTOGRAM_GREEN_SIZE_EXT = $8029;

This item has no description.

GL_HISTOGRAM_BLUE_SIZE_EXT = $802A;

This item has no description.

GL_HISTOGRAM_ALPHA_SIZE_EXT = $802B;

This item has no description.

GL_HISTOGRAM_LUMINANCE_SIZE_EXT = $802C;

This item has no description.

GL_HISTOGRAM_SINK_EXT = $802D;

This item has no description.

GL_MINMAX_EXT = $802E;

This item has no description.

GL_MINMAX_FORMAT_EXT = $802F;

This item has no description.

GL_MINMAX_SINK_EXT = $8030;

This item has no description.

GL_TABLE_TOO_LARGE_EXT = $8031;

This item has no description.

GL_IUI_V2F_EXT = $81AD;

GL_EXT_index_array_formats

GL_IUI_V3F_EXT = $81AE;

This item has no description.

GL_IUI_N3F_V2F_EXT = $81AF;

This item has no description.

GL_IUI_N3F_V3F_EXT = $81B0;

This item has no description.

GL_T2F_IUI_V2F_EXT = $81B1;

This item has no description.

GL_T2F_IUI_V3F_EXT = $81B2;

This item has no description.

GL_T2F_IUI_N3F_V2F_EXT = $81B3;

This item has no description.

GL_T2F_IUI_N3F_V3F_EXT = $81B4;

This item has no description.

GL_INDEX_TEST_EXT = $81B5;

GL_EXT_index_func

GL_INDEX_TEST_FUNC_EXT = $81B6;

This item has no description.

GL_INDEX_TEST_REF_EXT = $81B7;

This item has no description.

GL_INDEX_MATERIAL_EXT = $81B8;

GL_EXT_index_material

GL_INDEX_MATERIAL_PARAMETER_EXT = $81B9;

This item has no description.

GL_INDEX_MATERIAL_FACE_EXT = $81BA;

This item has no description.

GL_FRAGMENT_MATERIAL_EXT = $8349;

GL_EXT_light_texture

GL_FRAGMENT_NORMAL_EXT = $834A;

This item has no description.

GL_FRAGMENT_COLOR_EXT = $834C;

This item has no description.

GL_ATTENUATION_EXT = $834D;

This item has no description.

GL_SHADOW_ATTENUATION_EXT = $834E;

This item has no description.

GL_TEXTURE_APPLICATION_MODE_EXT = $834F;

This item has no description.

GL_TEXTURE_LIGHT_EXT = $8350;

This item has no description.

GL_TEXTURE_MATERIAL_FACE_EXT = $8351;

This item has no description.

GL_TEXTURE_MATERIAL_PARAMETER_EXT = $8352;

This item has no description.

GL_MULTISAMPLE_EXT = $809D;

GL_EXT_multisample

GL_SAMPLE_ALPHA_TO_MASK_EXT = $809E;

This item has no description.

GL_SAMPLE_ALPHA_TO_ONE_EXT = $809F;

This item has no description.

GL_SAMPLE_MASK_EXT = $80A0;

This item has no description.

GL_1PASS_EXT = $80A1;

This item has no description.

GL_2PASS_0_EXT = $80A2;

This item has no description.

GL_2PASS_1_EXT = $80A3;

This item has no description.

GL_4PASS_0_EXT = $80A4;

This item has no description.

GL_4PASS_1_EXT = $80A5;

This item has no description.

GL_4PASS_2_EXT = $80A6;

This item has no description.

GL_4PASS_3_EXT = $80A7;

This item has no description.

GL_SAMPLE_BUFFERS_EXT = $80A8;

This item has no description.

GL_SAMPLES_EXT = $80A9;

This item has no description.

GL_SAMPLE_MASK_VALUE_EXT = $80AA;

This item has no description.

GL_SAMPLE_MASK_INVERT_EXT = $80AB;

This item has no description.

GL_SAMPLE_PATTERN_EXT = $80AC;

This item has no description.

GL_MULTISAMPLE_BIT_EXT = $20000000;

This item has no description.

GL_UNSIGNED_BYTE_3_3_2_EXT = $8032;

GL_EXT_packed_pixels

GL_UNSIGNED_SHORT_4_4_4_4_EXT = $8033;

This item has no description.

GL_UNSIGNED_SHORT_5_5_5_1_EXT = $8034;

This item has no description.

GL_UNSIGNED_INT_8_8_8_8_EXT = $8035;

This item has no description.

GL_UNSIGNED_INT_10_10_10_2_EXT = $8036;

This item has no description.

GL_COLOR_INDEX1_EXT = $80E2;

GL_EXT_paletted_texture

GL_COLOR_INDEX2_EXT = $80E3;

This item has no description.

GL_COLOR_INDEX4_EXT = $80E4;

This item has no description.

GL_COLOR_INDEX8_EXT = $80E5;

This item has no description.

GL_COLOR_INDEX12_EXT = $80E6;

This item has no description.

GL_COLOR_INDEX16_EXT = $80E7;

This item has no description.

GL_TEXTURE_INDEX_SIZE_EXT = $80ED;

This item has no description.

GL_PIXEL_TRANSFORM_2D_EXT = $8330;

GL_EXT_pixel_transform

GL_PIXEL_MAG_FILTER_EXT = $8331;

This item has no description.

GL_PIXEL_MIN_FILTER_EXT = $8332;

This item has no description.

GL_PIXEL_CUBIC_WEIGHT_EXT = $8333;

This item has no description.

GL_CUBIC_EXT = $8334;

This item has no description.

GL_AVERAGE_EXT = $8335;

This item has no description.

GL_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT = $8336;

This item has no description.

GL_MAX_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT = $8337;

This item has no description.

GL_PIXEL_TRANSFORM_2D_MATRIX_EXT = $8338;

This item has no description.

GL_POINT_SIZE_MIN_EXT = $8126;

GL_EXT_point_parameters

GL_POINT_SIZE_MAX_EXT = $8127;

This item has no description.

GL_POINT_FADE_THRESHOLD_SIZE_EXT = $8128;

This item has no description.

GL_DISTANCE_ATTENUATION_EXT = $8129;

This item has no description.

GL_POLYGON_OFFSET_EXT = $8037;

GL_EXT_polygon_offset

GL_POLYGON_OFFSET_FACTOR_EXT = $8038;

This item has no description.

GL_POLYGON_OFFSET_BIAS_EXT = $8039;

This item has no description.

GL_RESCALE_NORMAL_EXT = $803A;

GL_EXT_rescale_normal

GL_COLOR_SUM_EXT = $8458;

GL_EXT_secondary_color

GL_CURRENT_SECONDARY_COLOR_EXT = $8459;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT = $845A;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT = $845B;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT = $845C;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT = $845D;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_EXT = $845E;

This item has no description.

GL_LIGHT_MODEL_COLOR_CONTROL_EXT = $81F8;

GL_EXT_separate_specular_color

GL_SINGLE_COLOR_EXT = $81F9;

This item has no description.

GL_SEPARATE_SPECULAR_COLOR_EXT = $81FA;

This item has no description.

GL_SHARED_TEXTURE_PALETTE_EXT = $81FB;

GL_EXT_shared_texture_palette

GL_STENCIL_TEST_TWO_SIDE_EXT = $8910;

GL_EXT_stencil_two_side

GL_ACTIVE_STENCIL_FACE_EXT = $8911;

This item has no description.

GL_INCR_WRAP_EXT = $8507;

GL_EXT_stencil_wrap

GL_DECR_WRAP_EXT = $8508;

This item has no description.

GL_ALPHA4_EXT = $803B;

GL_EXT_texture

GL_ALPHA8_EXT = $803C;

This item has no description.

GL_ALPHA12_EXT = $803D;

This item has no description.

GL_ALPHA16_EXT = $803E;

This item has no description.

GL_LUMINANCE4_EXT = $803F;

This item has no description.

GL_LUMINANCE8_EXT = $8040;

This item has no description.

GL_LUMINANCE12_EXT = $8041;

This item has no description.

GL_LUMINANCE16_EXT = $8042;

This item has no description.

GL_LUMINANCE4_ALPHA4_EXT = $8043;

This item has no description.

GL_LUMINANCE6_ALPHA2_EXT = $8044;

This item has no description.

GL_LUMINANCE8_ALPHA8_EXT = $8045;

This item has no description.

GL_LUMINANCE12_ALPHA4_EXT = $8046;

This item has no description.

GL_LUMINANCE12_ALPHA12_EXT = $8047;

This item has no description.

GL_LUMINANCE16_ALPHA16_EXT = $8048;

This item has no description.

GL_INTENSITY_EXT = $8049;

This item has no description.

GL_INTENSITY4_EXT = $804A;

This item has no description.

GL_INTENSITY8_EXT = $804B;

This item has no description.

GL_INTENSITY12_EXT = $804C;

This item has no description.

GL_INTENSITY16_EXT = $804D;

This item has no description.

GL_RGB2_EXT = $804E;

This item has no description.

GL_RGB4_EXT = $804F;

This item has no description.

GL_RGB5_EXT = $8050;

This item has no description.

GL_RGB8_EXT = $8051;

This item has no description.

GL_RGB10_EXT = $8052;

This item has no description.

GL_RGB12_EXT = $8053;

This item has no description.

GL_RGB16_EXT = $8054;

This item has no description.

GL_RGBA2_EXT = $8055;

This item has no description.

GL_RGBA4_EXT = $8056;

This item has no description.

GL_RGB5_A1_EXT = $8057;

This item has no description.

GL_RGBA8_EXT = $8058;

This item has no description.

GL_RGB10_A2_EXT = $8059;

This item has no description.

GL_RGBA12_EXT = $805A;

This item has no description.

GL_RGBA16_EXT = $805B;

This item has no description.

GL_TEXTURE_RED_SIZE_EXT = $805C;

This item has no description.

GL_TEXTURE_GREEN_SIZE_EXT = $805D;

This item has no description.

GL_TEXTURE_BLUE_SIZE_EXT = $805E;

This item has no description.

GL_TEXTURE_ALPHA_SIZE_EXT = $805F;

This item has no description.

GL_TEXTURE_LUMINANCE_SIZE_EXT = $8060;

This item has no description.

GL_TEXTURE_INTENSITY_SIZE_EXT = $8061;

This item has no description.

GL_REPLACE_EXT = $8062;

This item has no description.

GL_PROXY_TEXTURE_1D_EXT = $8063;

This item has no description.

GL_PROXY_TEXTURE_2D_EXT = $8064;

This item has no description.

GL_TEXTURE_TOO_LARGE_EXT = $8065;

This item has no description.

GL_PACK_SKIP_IMAGES_EXT = $806B;

GL_EXT_texture3D

GL_PACK_IMAGE_HEIGHT_EXT = $806C;

This item has no description.

GL_UNPACK_SKIP_IMAGES_EXT = $806D;

This item has no description.

GL_UNPACK_IMAGE_HEIGHT_EXT = $806E;

This item has no description.

GL_TEXTURE_3D_EXT = $806F;

This item has no description.

GL_PROXY_TEXTURE_3D_EXT = $8070;

This item has no description.

GL_TEXTURE_DEPTH_EXT = $8071;

This item has no description.

GL_TEXTURE_WRAP_R_EXT = $8072;

This item has no description.

GL_MAX_3D_TEXTURE_SIZE_EXT = $8073;

This item has no description.

GL_COMPRESSED_RGB_S3TC_DXT1_EXT = $83F0;

GL_EXT_texture_compression_s3tc

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT = $83F1;

This item has no description.

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT = $83F2;

This item has no description.

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT = $83F3;

This item has no description.

GL_NORMAL_MAP_EXT = $8511;

GL_EXT_texture_cube_map

GL_REFLECTION_MAP_EXT = $8512;

This item has no description.

GL_TEXTURE_CUBE_MAP_EXT = $8513;

This item has no description.

GL_TEXTURE_BINDING_CUBE_MAP_EXT = $8514;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT = $8515;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT = $8516;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT = $8517;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT = $8518;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT = $8519;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT = $851A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP_EXT = $851B;

This item has no description.

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT = $851C;

This item has no description.

GL_CLAMP_TO_EDGE_EXT = $812F;

GL_EXT_texture_edge_clamp

GL_COMBINE_EXT = $8570;

GL_EXT_texture_env_combine

GL_COMBINE_RGB_EXT = $8571;

This item has no description.

GL_COMBINE_ALPHA_EXT = $8572;

This item has no description.

GL_RGB_SCALE_EXT = $8573;

This item has no description.

GL_ADD_SIGNED_EXT = $8574;

This item has no description.

GL_INTERPOLATE_EXT = $8575;

This item has no description.

GL_CONSTANT_EXT = $8576;

This item has no description.

GL_PRIMARY_COLOR_EXT = $8577;

This item has no description.

GL_PREVIOUS_EXT = $8578;

This item has no description.

GL_SOURCE0_RGB_EXT = $8580;

This item has no description.

GL_SOURCE1_RGB_EXT = $8581;

This item has no description.

GL_SOURCE2_RGB_EXT = $8582;

This item has no description.

GL_SOURCE0_ALPHA_EXT = $8588;

This item has no description.

GL_SOURCE1_ALPHA_EXT = $8589;

This item has no description.

GL_SOURCE2_ALPHA_EXT = $858A;

This item has no description.

GL_OPERAND0_RGB_EXT = $8590;

This item has no description.

GL_OPERAND1_RGB_EXT = $8591;

This item has no description.

GL_OPERAND2_RGB_EXT = $8592;

This item has no description.

GL_OPERAND0_ALPHA_EXT = $8598;

This item has no description.

GL_OPERAND1_ALPHA_EXT = $8599;

This item has no description.

GL_OPERAND2_ALPHA_EXT = $859A;

This item has no description.

GL_DOT3_RGB_EXT = $8740;

GL_EXT_texture_env_dot3

GL_DOT3_RGBA_EXT = $8741;

This item has no description.

GL_TEXTURE_MAX_ANISOTROPY_EXT = $84FE;

GL_EXT_texture_filter_anisotropic

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT = $84FF;

This item has no description.

GL_MAX_TEXTURE_LOD_BIAS_EXT = $84FD;

GL_EXT_texture_lod_bias

GL_TEXTURE_FILTER_CONTROL_EXT = $8500;

This item has no description.

GL_TEXTURE_LOD_BIAS_EXT = $8501;

This item has no description.

GL_TEXTURE_PRIORITY_EXT = $8066;

GL_EXT_texture_object

GL_TEXTURE_RESIDENT_EXT = $8067;

This item has no description.

GL_TEXTURE_1D_BINDING_EXT = $8068;

This item has no description.

GL_TEXTURE_2D_BINDING_EXT = $8069;

This item has no description.

GL_TEXTURE_3D_BINDING_EXT = $806A;

This item has no description.

GL_PERTURB_EXT = $85AE;

GL_EXT_texture_perturb_normal

GL_TEXTURE_NORMAL_EXT = $85AF;

This item has no description.

GL_TEXTURE_RECTANGLE_EXT = $84F5;

GL_EXT_texture_rectangle

GL_TEXTURE_BINDING_RECTANGLE_EXT = $84F6;

This item has no description.

GL_PROXY_TEXTURE_RECTANGLE_EXT = $84F7;

This item has no description.

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT = $84F8;

This item has no description.

GL_VERTEX_ARRAY_EXT = $8074;

GL_EXT_vertex_array

GL_NORMAL_ARRAY_EXT = $8075;

This item has no description.

GL_COLOR_ARRAY_EXT = $8076;

This item has no description.

GL_INDEX_ARRAY_EXT = $8077;

This item has no description.

GL_TEXTURE_COORD_ARRAY_EXT = $8078;

This item has no description.

GL_EDGE_FLAG_ARRAY_EXT = $8079;

This item has no description.

GL_VERTEX_ARRAY_SIZE_EXT = $807A;

This item has no description.

GL_VERTEX_ARRAY_TYPE_EXT = $807B;

This item has no description.

GL_VERTEX_ARRAY_STRIDE_EXT = $807C;

This item has no description.

GL_VERTEX_ARRAY_COUNT_EXT = $807D;

This item has no description.

GL_NORMAL_ARRAY_TYPE_EXT = $807E;

This item has no description.

GL_NORMAL_ARRAY_STRIDE_EXT = $807F;

This item has no description.

GL_NORMAL_ARRAY_COUNT_EXT = $8080;

This item has no description.

GL_COLOR_ARRAY_SIZE_EXT = $8081;

This item has no description.

GL_COLOR_ARRAY_TYPE_EXT = $8082;

This item has no description.

GL_COLOR_ARRAY_STRIDE_EXT = $8083;

This item has no description.

GL_COLOR_ARRAY_COUNT_EXT = $8084;

This item has no description.

GL_INDEX_ARRAY_TYPE_EXT = $8085;

This item has no description.

GL_INDEX_ARRAY_STRIDE_EXT = $8086;

This item has no description.

GL_INDEX_ARRAY_COUNT_EXT = $8087;

This item has no description.

GL_TEXTURE_COORD_ARRAY_SIZE_EXT = $8088;

This item has no description.

GL_TEXTURE_COORD_ARRAY_TYPE_EXT = $8089;

This item has no description.

GL_TEXTURE_COORD_ARRAY_STRIDE_EXT = $808A;

This item has no description.

GL_TEXTURE_COORD_ARRAY_COUNT_EXT = $808B;

This item has no description.

GL_EDGE_FLAG_ARRAY_STRIDE_EXT = $808C;

This item has no description.

GL_EDGE_FLAG_ARRAY_COUNT_EXT = $808D;

This item has no description.

GL_VERTEX_ARRAY_POINTER_EXT = $808E;

This item has no description.

GL_NORMAL_ARRAY_POINTER_EXT = $808F;

This item has no description.

GL_COLOR_ARRAY_POINTER_EXT = $8090;

This item has no description.

GL_INDEX_ARRAY_POINTER_EXT = $8091;

This item has no description.

GL_TEXTURE_COORD_ARRAY_POINTER_EXT = $8092;

This item has no description.

GL_EDGE_FLAG_ARRAY_POINTER_EXT = $8093;

This item has no description.

GL_VERTEX_SHADER_EXT = $8780;

GL_EXT_vertex_shader

GL_VERTEX_SHADER_BINDING_EXT = $8781;

This item has no description.

GL_OP_INDEX_EXT = $8782;

This item has no description.

GL_OP_NEGATE_EXT = $8783;

This item has no description.

GL_OP_DOT3_EXT = $8784;

This item has no description.

GL_OP_DOT4_EXT = $8785;

This item has no description.

GL_OP_MUL_EXT = $8786;

This item has no description.

GL_OP_ADD_EXT = $8787;

This item has no description.

GL_OP_MADD_EXT = $8788;

This item has no description.

GL_OP_FRAC_EXT = $8789;

This item has no description.

GL_OP_MAX_EXT = $878A;

This item has no description.

GL_OP_MIN_EXT = $878B;

This item has no description.

GL_OP_SET_GE_EXT = $878C;

This item has no description.

GL_OP_SET_LT_EXT = $878D;

This item has no description.

GL_OP_CLAMP_EXT = $878E;

This item has no description.

GL_OP_FLOOR_EXT = $878F;

This item has no description.

GL_OP_ROUND_EXT = $8790;

This item has no description.

GL_OP_EXP_BASE_2_EXT = $8791;

This item has no description.

GL_OP_LOG_BASE_2_EXT = $8792;

This item has no description.

GL_OP_POWER_EXT = $8793;

This item has no description.

GL_OP_RECIP_EXT = $8794;

This item has no description.

GL_OP_RECIP_SQRT_EXT = $8795;

This item has no description.

GL_OP_SUB_EXT = $8796;

This item has no description.

GL_OP_CROSS_PRODUCT_EXT = $8797;

This item has no description.

GL_OP_MULTIPLY_MATRIX_EXT = $8798;

This item has no description.

GL_OP_MOV_EXT = $8799;

This item has no description.

GL_OUTPUT_VERTEX_EXT = $879A;

This item has no description.

GL_OUTPUT_COLOR0_EXT = $879B;

This item has no description.

GL_OUTPUT_COLOR1_EXT = $879C;

This item has no description.

GL_OUTPUT_TEXTURE_COORD0_EXT = $879D;

This item has no description.

GL_OUTPUT_TEXTURE_COORD1_EXT = $879E;

This item has no description.

GL_OUTPUT_TEXTURE_COORD2_EXT = $879F;

This item has no description.

GL_OUTPUT_TEXTURE_COORD3_EXT = $87A0;

This item has no description.

GL_OUTPUT_TEXTURE_COORD4_EXT = $87A1;

This item has no description.

GL_OUTPUT_TEXTURE_COORD5_EXT = $87A2;

This item has no description.

GL_OUTPUT_TEXTURE_COORD6_EXT = $87A3;

This item has no description.

GL_OUTPUT_TEXTURE_COORD7_EXT = $87A4;

This item has no description.

GL_OUTPUT_TEXTURE_COORD8_EXT = $87A5;

This item has no description.

GL_OUTPUT_TEXTURE_COORD9_EXT = $87A6;

This item has no description.

GL_OUTPUT_TEXTURE_COORD10_EXT = $87A7;

This item has no description.

GL_OUTPUT_TEXTURE_COORD11_EXT = $87A8;

This item has no description.

GL_OUTPUT_TEXTURE_COORD12_EXT = $87A9;

This item has no description.

GL_OUTPUT_TEXTURE_COORD13_EXT = $87AA;

This item has no description.

GL_OUTPUT_TEXTURE_COORD14_EXT = $87AB;

This item has no description.

GL_OUTPUT_TEXTURE_COORD15_EXT = $87AC;

This item has no description.

GL_OUTPUT_TEXTURE_COORD16_EXT = $87AD;

This item has no description.

GL_OUTPUT_TEXTURE_COORD17_EXT = $87AE;

This item has no description.

GL_OUTPUT_TEXTURE_COORD18_EXT = $87AF;

This item has no description.

GL_OUTPUT_TEXTURE_COORD19_EXT = $87B0;

This item has no description.

GL_OUTPUT_TEXTURE_COORD20_EXT = $87B1;

This item has no description.

GL_OUTPUT_TEXTURE_COORD21_EXT = $87B2;

This item has no description.

GL_OUTPUT_TEXTURE_COORD22_EXT = $87B3;

This item has no description.

GL_OUTPUT_TEXTURE_COORD23_EXT = $87B4;

This item has no description.

GL_OUTPUT_TEXTURE_COORD24_EXT = $87B5;

This item has no description.

GL_OUTPUT_TEXTURE_COORD25_EXT = $87B6;

This item has no description.

GL_OUTPUT_TEXTURE_COORD26_EXT = $87B7;

This item has no description.

GL_OUTPUT_TEXTURE_COORD27_EXT = $87B8;

This item has no description.

GL_OUTPUT_TEXTURE_COORD28_EXT = $87B9;

This item has no description.

GL_OUTPUT_TEXTURE_COORD29_EXT = $87BA;

This item has no description.

GL_OUTPUT_TEXTURE_COORD30_EXT = $87BB;

This item has no description.

GL_OUTPUT_TEXTURE_COORD31_EXT = $87BC;

This item has no description.

GL_OUTPUT_FOG_EXT = $87BD;

This item has no description.

GL_SCALAR_EXT = $87BE;

This item has no description.

GL_VECTOR_EXT = $87BF;

This item has no description.

GL_MATRIX_EXT = $87C0;

This item has no description.

GL_VARIANT_EXT = $87C1;

This item has no description.

GL_INVARIANT_EXT = $87C2;

This item has no description.

GL_LOCAL_CONSTANT_EXT = $87C3;

This item has no description.

GL_LOCAL_EXT = $87C4;

This item has no description.

GL_MAX_VERTEX_SHADER_INSTRUCTIONS_EXT = $87C5;

This item has no description.

GL_MAX_VERTEX_SHADER_VARIANTS_EXT = $87C6;

This item has no description.

GL_MAX_VERTEX_SHADER_INVARIANTS_EXT = $87C7;

This item has no description.

GL_MAX_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87C8;

This item has no description.

GL_MAX_VERTEX_SHADER_LOCALS_EXT = $87C9;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_INSTRUCTIONS_EXT = $87CA;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_VARIANTS_EXT = $87CB;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87CC;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_INVARIANTS_EXT = $87CD;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCALS_EXT = $87CE;

This item has no description.

GL_VERTEX_SHADER_INSTRUCTIONS_EXT = $87CF;

This item has no description.

GL_VERTEX_SHADER_VARIANTS_EXT = $87D0;

This item has no description.

GL_VERTEX_SHADER_INVARIANTS_EXT = $87D1;

This item has no description.

GL_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87D2;

This item has no description.

GL_VERTEX_SHADER_LOCALS_EXT = $87D3;

This item has no description.

GL_VERTEX_SHADER_OPTIMIZED_EXT = $87D4;

This item has no description.

GL_X_EXT = $87D5;

This item has no description.

GL_Y_EXT = $87D6;

This item has no description.

GL_Z_EXT = $87D7;

This item has no description.

GL_W_EXT = $87D8;

This item has no description.

GL_NEGATIVE_X_EXT = $87D9;

This item has no description.

GL_NEGATIVE_Y_EXT = $87DA;

This item has no description.

GL_NEGATIVE_Z_EXT = $87DB;

This item has no description.

GL_NEGATIVE_W_EXT = $87DC;

This item has no description.

GL_ZERO_EXT = $87DD;

This item has no description.

GL_ONE_EXT = $87DE;

This item has no description.

GL_NEGATIVE_ONE_EXT = $87DF;

This item has no description.

GL_NORMALIZED_RANGE_EXT = $87E0;

This item has no description.

GL_FULL_RANGE_EXT = $87E1;

This item has no description.

GL_CURRENT_VERTEX_EXT = $87E2;

This item has no description.

GL_MVP_MATRIX_EXT = $87E3;

This item has no description.

GL_VARIANT_VALUE_EXT = $87E4;

This item has no description.

GL_VARIANT_DATATYPE_EXT = $87E5;

This item has no description.

GL_VARIANT_ARRAY_STRIDE_EXT = $87E6;

This item has no description.

GL_VARIANT_ARRAY_TYPE_EXT = $87E7;

This item has no description.

GL_VARIANT_ARRAY_EXT = $87E8;

This item has no description.

GL_VARIANT_ARRAY_POINTER_EXT = $87E9;

This item has no description.

GL_INVARIANT_VALUE_EXT = $87EA;

This item has no description.

GL_INVARIANT_DATATYPE_EXT = $87EB;

This item has no description.

GL_LOCAL_CONSTANT_VALUE_EXT = $87EC;

This item has no description.

GL_LOCAL_CONSTANT_DATATYPE_EXT = $87ED;

This item has no description.

GL_MODELVIEW0_STACK_DEPTH_EXT = $0BA3;

GL_EXT_vertex_weighting

GL_MODELVIEW1_STACK_DEPTH_EXT = $8502;

This item has no description.

GL_MODELVIEW0_MATRIX_EXT = $0BA6;

This item has no description.

GL_MODELVIEW1_MATRIX_EXT = $8506;

This item has no description.

GL_VERTEX_WEIGHTING_EXT = $8509;

This item has no description.

GL_MODELVIEW0_EXT = $1700;

This item has no description.

GL_MODELVIEW1_EXT = $850A;

This item has no description.

GL_CURRENT_VERTEX_WEIGHT_EXT = $850B;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_EXT = $850C;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_SIZE_EXT = $850D;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_TYPE_EXT = $850E;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_STRIDE_EXT = $850F;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_POINTER_EXT = $8510;

This item has no description.

GL_DEPTH_BOUNDS_TEST_EXT = $8890;

GL_EXT_depth_bounds_test

GL_DEPTH_BOUNDS_EXT = $8891;

This item has no description.

GL_MIRROR_CLAMP_EXT = $8742;

GL_EXT_texture_mirror_clamp

GL_MIRROR_CLAMP_TO_EDGE_EXT = $8743;

This item has no description.

GL_MIRROR_CLAMP_TO_BORDER_EXT = $8912;

This item has no description.

GL_BLEND_EQUATION_RGB_EXT = $8009;

GL_EXT_blend_equation_separate

GL_BLEND_EQUATION_ALPHA_EXT = $883D;

This item has no description.

GL_PIXEL_PACK_BUFFER_EXT = $88EB;

GL_EXT_pixel_buffer_object

GL_PIXEL_UNPACK_BUFFER_EXT = $88EC;

This item has no description.

GL_PIXEL_PACK_BUFFER_BINDING_EXT = $88ED;

This item has no description.

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT = $88EF;

This item has no description.

GL_STENCIL_TAG_BITS_EXT = $88F2;

GL_EXT_stencil_clear_tag

GL_STENCIL_CLEAR_TAG_VALUE_EXT = $88F3;

This item has no description.

GL_DEPTH_STENCIL_EXT = $84F9;

GL_EXT_packed_depth_stencil

GL_UNSIGNED_INT_24_8_EXT = $84FA;

This item has no description.

GL_DEPTH24_STENCIL8_EXT = $88F0;

This item has no description.

GL_TEXTURE_STENCIL_SIZE_EXT = $88F1;

This item has no description.

GL_SRGB_EXT = $8C40;

GL_EXT_texture_sRGB

GL_SRGB8_EXT = $8C41;

This item has no description.

GL_SRGB_ALPHA_EXT = $8C42;

This item has no description.

GL_SRGB8_ALPHA8_EXT = $8C43;

This item has no description.

GL_SLUMINANCE_ALPHA_EXT = $8C44;

This item has no description.

GL_SLUMINANCE8_ALPHA8_EXT = $8C45;

This item has no description.

GL_SLUMINANCE_EXT = $8C46;

This item has no description.

GL_SLUMINANCE8_EXT = $8C47;

This item has no description.

GL_COMPRESSED_SRGB_EXT = $8C48;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA_EXT = $8C49;

This item has no description.

GL_COMPRESSED_SLUMINANCE_EXT = $8C4A;

This item has no description.

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT = $8C4B;

This item has no description.

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT = $8C4C;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT = $8C4D;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT = $8C4E;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT = $8C4F;

This item has no description.

GL_READ_FRAMEBUFFER_EXT = $8CA8;

GL_EXT_framebuffer_blit

GL_DRAW_FRAMEBUFFER_EXT = $8CA9;

This item has no description.

GL_READ_FRAMEBUFFER_BINDING_EXT = GL_FRAMEBUFFER_BINDING_EXT;

This item has no description.

GL_DRAW_FRAMEBUFFER_BINDING_EXT = $8CAA;

This item has no description.

GL_RENDERBUFFER_SAMPLES_EXT = $8CAB;

GL_EXT_framebuffer_multisample

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT = $8D56;

This item has no description.

GL_MAX_SAMPLES_EXT = $8D57;

This item has no description.

GL_TIME_ELAPSED_EXT = $88BF;

GL_EXT_timer_query

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT = $8DE2;

GL_EXT_bindable_uniform

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT = $8DE3;

This item has no description.

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT = $8DE4;

This item has no description.

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT = $8DED;

This item has no description.

GL_UNIFORM_BUFFER_EXT = $8DEE;

This item has no description.

GL_UNIFORM_BUFFER_BINDING_EXT = $8DEF;

This item has no description.

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2;

GL_EXT_framebuffer_sRGB

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20A9;

This item has no description.

GL_FRAMEBUFFER_SRGB_EXT = $8DB9;

This item has no description.

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $8DBA;

This item has no description.

GL_GEOMETRY_SHADER_EXT = $8DD9;

GL_EXT_geometry_shader4

GL_GEOMETRY_VERTICES_OUT_EXT = $8DDA;

This item has no description.

GL_GEOMETRY_INPUT_TYPE_EXT = $8DDB;

This item has no description.

GL_GEOMETRY_OUTPUT_TYPE_EXT = $8DDC;

This item has no description.

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT = $8C29;

This item has no description.

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT = $8DDD;

This item has no description.

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT = $8DDE;

This item has no description.

GL_MAX_VARYING_COMPONENTS_EXT = $8B4B;

This item has no description.

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT = $8DDF;

This item has no description.

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT = $8DE0;

This item has no description.

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT = $8DE1;

This item has no description.

GL_LINES_ADJACENCY_EXT = $A;

This item has no description.

GL_LINE_STRIP_ADJACENCY_EXT = $B;

This item has no description.

GL_TRIANGLES_ADJACENCY_EXT = $C;

This item has no description.

GL_TRIANGLE_STRIP_ADJACENCY_EXT = $D;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT = $8DA8;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT = $8DA9;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT = $8DA7;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT = $8CD4;

This item has no description.

GL_PROGRAM_POINT_SIZE_EXT = $8642;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT = $88FD;

GL_EXT_gpu_shader4

GL_SAMPLER_1D_ARRAY_EXT = $8DC0;

This item has no description.

GL_SAMPLER_2D_ARRAY_EXT = $8DC1;

This item has no description.

GL_SAMPLER_BUFFER_EXT = $8DC2;

This item has no description.

GL_SAMPLER_1D_ARRAY_SHADOW_EXT = $8DC3;

This item has no description.

GL_SAMPLER_2D_ARRAY_SHADOW_EXT = $8DC4;

This item has no description.

GL_SAMPLER_CUBE_SHADOW_EXT = $8DC5;

This item has no description.

GL_UNSIGNED_INT_VEC2_EXT = $8DC6;

This item has no description.

GL_UNSIGNED_INT_VEC3_EXT = $8DC7;

This item has no description.

GL_UNSIGNED_INT_VEC4_EXT = $8DC8;

This item has no description.

GL_INT_SAMPLER_1D_EXT = $8DC9;

This item has no description.

GL_INT_SAMPLER_2D_EXT = $8DCA;

This item has no description.

GL_INT_SAMPLER_3D_EXT = $8DCB;

This item has no description.

GL_INT_SAMPLER_CUBE_EXT = $8DCC;

This item has no description.

GL_INT_SAMPLER_2D_RECT_EXT = $8DCD;

This item has no description.

GL_INT_SAMPLER_1D_ARRAY_EXT = $8DCE;

This item has no description.

GL_INT_SAMPLER_2D_ARRAY_EXT = $8DCF;

This item has no description.

GL_INT_SAMPLER_BUFFER_EXT = $8DD0;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_1D_EXT = $8DD1;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_EXT = $8DD2;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_3D_EXT = $8DD3;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT = $8DD4;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT = $8DD5;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT = $8DD6;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT = $8DD7;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT = $8DD8;

This item has no description.

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT = $8904;

This item has no description.

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT = $8905;

This item has no description.

GL_R11F_G11F_B10F_EXT = $8C3A;

GL_EXT_packed_float

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT = $8C3B;

This item has no description.

RGBA_SIGNED_COMPONENTS_EXT = $8C3C;

This item has no description.

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;

This item has no description.

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1;

This item has no description.

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008;

This item has no description.

GL_TEXTURE_1D_ARRAY_EXT = $8C18;

GL_EXT_texture_array

GL_TEXTURE_2D_ARRAY_EXT = $8C1A;

This item has no description.

GL_PROXY_TEXTURE_2D_ARRAY_EXT = $8C1B;

This item has no description.

GL_PROXY_TEXTURE_1D_ARRAY_EXT = $8C19;

This item has no description.

GL_TEXTURE_BINDING_1D_ARRAY_EXT = $8C1C;

This item has no description.

GL_TEXTURE_BINDING_2D_ARRAY_EXT = $8C1D;

This item has no description.

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT = $88FF;

This item has no description.

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT = $884E;

This item has no description.

GL_TEXTURE_BUFFER_EXT = $8C2A;

GL_EXT_texture_buffer_object

GL_MAX_TEXTURE_BUFFER_SIZE_EXT = $8C2B;

This item has no description.

GL_TEXTURE_BINDING_BUFFER_EXT = $8C2C;

This item has no description.

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT = $8C2D;

This item has no description.

GL_TEXTURE_BUFFER_FORMAT_EXT = $8C2E;

This item has no description.

GL_COMPRESSED_LUMINANCE_LATC1_EXT = $8C70;

GL_EXT_texture_compression_latc

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT = $8C71;

This item has no description.

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT = $8C72;

This item has no description.

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT = $8C73;

This item has no description.

GL_COMPRESSED_RED_RGTC1_EXT = $8DBB;

GL_EXT_texture_compression_rgtc

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT = $8DBC;

This item has no description.

GL_COMPRESSED_RED_GREEN_RGTC2_EXT = $8DBD;

This item has no description.

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT = $8DBE;

This item has no description.

GL_RGBA_INTEGER_MODE_EXT = $8D9E;

GL_EXT_texture_integer

GL_RGBA32UI_EXT = $8D70;

This item has no description.

GL_RGB32UI_EXT = $8D71;

This item has no description.

GL_ALPHA32UI_EXT = $8D72;

This item has no description.

GL_INTENSITY32UI_EXT = $8D73;

This item has no description.

GL_LUMINANCE32UI_EXT = $8D74;

This item has no description.

GL_LUMINANCE_ALPHA32UI_EXT = $8D75;

This item has no description.

GL_RGBA16UI_EXT = $8D76;

This item has no description.

GL_RGB16UI_EXT = $8D77;

This item has no description.

GL_ALPHA16UI_EXT = $8D78;

This item has no description.

GL_INTENSITY16UI_EXT = $8D79;

This item has no description.

GL_LUMINANCE16UI_EXT = $8D7A;

This item has no description.

GL_LUMINANCE_ALPHA16UI_EXT = $8D7B;

This item has no description.

GL_RGBA8UI_EXT = $8D7C;

This item has no description.

GL_RGB8UI_EXT = $8D7D;

This item has no description.

GL_ALPHA8UI_EXT = $8D7E;

This item has no description.

GL_INTENSITY8UI_EXT = $8D7F;

This item has no description.

GL_LUMINANCE8UI_EXT = $8D80;

This item has no description.

GL_LUMINANCE_ALPHA8UI_EXT = $8D81;

This item has no description.

GL_RGBA32I_EXT = $8D82;

This item has no description.

GL_RGB32I_EXT = $8D83;

This item has no description.

GL_ALPHA32I_EXT = $8D84;

This item has no description.

GL_INTENSITY32I_EXT = $8D85;

This item has no description.

GL_LUMINANCE32I_EXT = $8D86;

This item has no description.

GL_LUMINANCE_ALPHA32I_EXT = $8D87;

This item has no description.

GL_RGBA16I_EXT = $8D88;

This item has no description.

GL_RGB16I_EXT = $8D89;

This item has no description.

GL_ALPHA16I_EXT = $8D8A;

This item has no description.

GL_INTENSITY16I_EXT = $8D8B;

This item has no description.

GL_LUMINANCE16I_EXT = $8D8C;

This item has no description.

GL_LUMINANCE_ALPHA16I_EXT = $8D8D;

This item has no description.

GL_RGBA8I_EXT = $8D8E;

This item has no description.

GL_RGB8I_EXT = $8D8F;

This item has no description.

GL_ALPHA8I_EXT = $8D90;

This item has no description.

GL_INTENSITY8I_EXT = $8D91;

This item has no description.

GL_LUMINANCE8I_EXT = $8D92;

This item has no description.

GL_LUMINANCE_ALPHA8I_EXT = $8D93;

This item has no description.

GL_RED_INTEGER_EXT = $8D94;

This item has no description.

GL_GREEN_INTEGER_EXT = $8D95;

This item has no description.

GL_BLUE_INTEGER_EXT = $8D96;

This item has no description.

GL_ALPHA_INTEGER_EXT = $8D97;

This item has no description.

GL_RGB_INTEGER_EXT = $8D98;

This item has no description.

GL_RGBA_INTEGER_EXT = $8D99;

This item has no description.

GL_BGR_INTEGER_EXT = $8D9A;

This item has no description.

GL_BGRA_INTEGER_EXT = $8D9B;

This item has no description.

GL_LUMINANCE_INTEGER_EXT = $8D9C;

This item has no description.

GL_LUMINANCE_ALPHA_INTEGER_EXT = $8D9D;

This item has no description.

GL_RGB9_E5_EXT = $8C3D;

GL_EXT_texture_shared_exponent

GL_UNSIGNED_INT_5_9_9_9_REV_EXT = $8C3E;

This item has no description.

GL_TEXTURE_SHARED_SIZE_EXT = $8C3F;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_EXT = $8C8E;

GL_EXT_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT = $8C84;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT = $8C85;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT = $8C8F;

This item has no description.

GL_INTERLEAVED_ATTRIBS_EXT = $8C8C;

This item has no description.

GL_SEPARATE_ATTRIBS_EXT = $8C8D;

This item has no description.

GL_PRIMITIVES_GENERATED_EXT = $8C87;

This item has no description.

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT = $8C88;

This item has no description.

GL_RASTERIZER_DISCARD_EXT = $8C89;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT = $8C8A;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT = $8C8B;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT = $8C80;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT = $8C83;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT = $8C7F;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT = $8C76;

This item has no description.

GL_PROGRAM_MATRIX_EXT = $8E2D;

GL_EXT_direct_state_access

GL_TRANSPOSE_PROGRAM_MATRIX_EXT = $8E2E;

This item has no description.

GL_PROGRAM_MATRIX_STACK_DEPTH_EXT = $8E2F;

This item has no description.

GL_TEXTURE_SWIZZLE_R_EXT = $8E42;

GL_EXT_texture_swizzle

GL_TEXTURE_SWIZZLE_G_EXT = $8E43;

This item has no description.

GL_TEXTURE_SWIZZLE_B_EXT = $8E44;

This item has no description.

GL_TEXTURE_SWIZZLE_A_EXT = $8E45;

This item has no description.

GL_TEXTURE_SWIZZLE_RGBA_EXT = $8E46;

This item has no description.

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION_EXT = $8E4C;

GL_EXT_provoking_vertex

GL_FIRST_VERTEX_CONVENTION_EXT = $8E4D;

This item has no description.

GL_LAST_VERTEX_CONVENTION_EXT = $8E4E;

This item has no description.

GL_PROVOKING_VERTEX_EXT = $8E4F;

This item has no description.

GL_ALPHA_SNORM = $9010;

GL_EXT_texture_snorm

GL_LUMINANCE_SNORM = $9011;

This item has no description.

GL_LUMINANCE_ALPHA_SNORM = $9012;

This item has no description.

GL_INTENSITY_SNORM = $9013;

This item has no description.

GL_ALPHA8_SNORM = $9014;

This item has no description.

GL_LUMINANCE8_SNORM = $9015;

This item has no description.

GL_LUMINANCE8_ALPHA8_SNORM = $9016;

This item has no description.

GL_INTENSITY8_SNORM = $9017;

This item has no description.

GL_ALPHA16_SNORM = $9018;

This item has no description.

GL_LUMINANCE16_SNORM = $9019;

This item has no description.

GL_LUMINANCE16_ALPHA16_SNORM = $901A;

This item has no description.

GL_INTENSITY16_SNORM = $901B;

This item has no description.

GL_ACTIVE_PROGRAM_EXT = $8B8D;

GL_EXT_separate_shader_objects

GL_MAX_IMAGE_UNITS_EXT = $8F38;

GL_EXT_shader_image_load_store

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS_EXT = $8F39;

This item has no description.

GL_IMAGE_BINDING_NAME_EXT = $8F3A;

This item has no description.

GL_IMAGE_BINDING_LEVEL_EXT = $8F3B;

This item has no description.

GL_IMAGE_BINDING_LAYERED_EXT = $8F3C;

This item has no description.

GL_IMAGE_BINDING_LAYER_EXT = $8F3D;

This item has no description.

GL_IMAGE_BINDING_ACCESS_EXT = $8F3E;

This item has no description.

GL_IMAGE_1D_EXT = $904C;

This item has no description.

GL_IMAGE_2D_EXT = $904D;

This item has no description.

GL_IMAGE_3D_EXT = $904E;

This item has no description.

GL_IMAGE_2D_RECT_EXT = $904F;

This item has no description.

GL_IMAGE_CUBE_EXT = $9050;

This item has no description.

GL_IMAGE_BUFFER_EXT = $9051;

This item has no description.

GL_IMAGE_1D_ARRAY_EXT = $9052;

This item has no description.

GL_IMAGE_2D_ARRAY_EXT = $9053;

This item has no description.

GL_IMAGE_CUBE_MAP_ARRAY_EXT = $9054;

This item has no description.

GL_IMAGE_2D_MULTISAMPLE_EXT = $9055;

This item has no description.

GL_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $9056;

This item has no description.

GL_INT_IMAGE_1D_EXT = $9057;

This item has no description.

GL_INT_IMAGE_2D_EXT = $9058;

This item has no description.

GL_INT_IMAGE_3D_EXT = $9059;

This item has no description.

GL_INT_IMAGE_2D_RECT_EXT = $905A;

This item has no description.

GL_INT_IMAGE_CUBE_EXT = $905B;

This item has no description.

GL_INT_IMAGE_BUFFER_EXT = $905C;

This item has no description.

GL_INT_IMAGE_1D_ARRAY_EXT = $905D;

This item has no description.

GL_INT_IMAGE_2D_ARRAY_EXT = $905E;

This item has no description.

GL_INT_IMAGE_CUBE_MAP_ARRAY_EXT = $905F;

This item has no description.

GL_INT_IMAGE_2D_MULTISAMPLE_EXT = $9060;

This item has no description.

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $9061;

This item has no description.

GL_UNSIGNED_INT_IMAGE_1D_EXT = $9062;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_EXT = $9063;

This item has no description.

GL_UNSIGNED_INT_IMAGE_3D_EXT = $9064;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_RECT_EXT = $9065;

This item has no description.

GL_UNSIGNED_INT_IMAGE_CUBE_EXT = $9066;

This item has no description.

GL_UNSIGNED_INT_IMAGE_BUFFER_EXT = $9067;

This item has no description.

GL_UNSIGNED_INT_IMAGE_1D_ARRAY_EXT = $9068;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_ARRAY_EXT = $9069;

This item has no description.

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY_EXT = $906A;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_EXT = $906B;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $906C;

This item has no description.

GL_MAX_IMAGE_SAMPLES_EXT = $906D;

This item has no description.

GL_IMAGE_BINDING_FORMAT_EXT = $906E;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT_EXT = $00000001;

This item has no description.

GL_ELEMENT_ARRAY_BARRIER_BIT_EXT = $00000002;

This item has no description.

GL_UNIFORM_BARRIER_BIT_EXT = $00000004;

This item has no description.

GL_TEXTURE_FETCH_BARRIER_BIT_EXT = $00000008;

This item has no description.

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT_EXT = $00000020;

This item has no description.

GL_COMMAND_BARRIER_BIT_EXT = $00000040;

This item has no description.

GL_PIXEL_BUFFER_BARRIER_BIT_EXT = $00000080;

This item has no description.

GL_TEXTURE_UPDATE_BARRIER_BIT_EXT = $00000100;

This item has no description.

GL_BUFFER_UPDATE_BARRIER_BIT_EXT = $00000200;

This item has no description.

GL_FRAMEBUFFER_BARRIER_BIT_EXT = $00000400;

This item has no description.

GL_TRANSFORM_FEEDBACK_BARRIER_BIT_EXT = $00000800;

This item has no description.

GL_ATOMIC_COUNTER_BARRIER_BIT_EXT = $00001000;

This item has no description.

GL_ALL_BARRIER_BITS_EXT = $FFFFFFFF;

This item has no description.

GL_DOUBLE_VEC2_EXT = $8FFC;

reuse GL_DOUBLE

GL_DOUBLE_VEC3_EXT = $8FFD;

This item has no description.

GL_DOUBLE_VEC4_EXT = $8FFE;

This item has no description.

GL_DOUBLE_MAT2_EXT = $8F46;

This item has no description.

GL_DOUBLE_MAT3_EXT = $8F47;

This item has no description.

GL_DOUBLE_MAT4_EXT = $8F48;

This item has no description.

GL_DOUBLE_MAT2x3_EXT = $8F49;

This item has no description.

GL_DOUBLE_MAT2x4_EXT = $8F4A;

This item has no description.

GL_DOUBLE_MAT3x2_EXT = $8F4B;

This item has no description.

GL_DOUBLE_MAT3x4_EXT = $8F4C;

This item has no description.

GL_DOUBLE_MAT4x2_EXT = $8F4D;

This item has no description.

GL_DOUBLE_MAT4x3_EXT = $8F4E;

This item has no description.

GL_TEXTURE_SRGB_DECODE_EXT = $8A48;

GL_EXT_texture_sRGB_decode

GL_DECODE_EXT = $8A49;

This item has no description.

GL_SKIP_DECODE_EXT = $8A4A;

This item has no description.

GL_TEXTURE_COVERAGE_SAMPLES_NV = $9045;

GL_NV_texture_multisample

GL_TEXTURE_COLOR_SAMPLES_NV = $9046;

This item has no description.

GL_FACTOR_MIN_AMD = $901C;

GL_AMD_blend_minmax_factor

GL_FACTOR_MAX_AMD = $901D;

This item has no description.

GL_SUBSAMPLE_DISTANCE_AMD = $883F;

GL_AMD_sample_positions

GL_SYNC_X11_FENCE_EXT = $90E1;

GL_EXT_x11_sync_object

GL_SCALED_RESOLVE_FASTEST_EXT = $90BA;

GL_EXT_framebuffer_multisample_blit_scaled

GL_SCALED_RESOLVE_NICEST_EXT = $90BB;

This item has no description.

GL_PATH_FORMAT_SVG_NV = $9070;

(4.3) GL_NV_path_rendering

GL_PATH_FORMAT_PS_NV = $9071;

This item has no description.

GL_STANDARD_FONT_NAME_NV = $9072;

This item has no description.

GL_SYSTEM_FONT_NAME_NV = $9073;

This item has no description.

GL_FILE_NAME_NV = $9074;

This item has no description.

GL_PATH_STROKE_WIDTH_NV = $9075;

This item has no description.

GL_PATH_END_CAPS_NV = $9076;

This item has no description.

GL_PATH_INITIAL_END_CAP_NV = $9077;

This item has no description.

GL_PATH_TERMINAL_END_CAP_NV = $9078;

This item has no description.

GL_PATH_JOIN_STYLE_NV = $9079;

This item has no description.

GL_PATH_MITER_LIMIT_NV = $907A;

This item has no description.

GL_PATH_DASH_CAPS_NV = $907B;

This item has no description.

GL_PATH_INITIAL_DASH_CAP_NV = $907C;

This item has no description.

GL_PATH_TERMINAL_DASH_CAP_NV = $907D;

This item has no description.

GL_PATH_DASH_OFFSET_NV = $907E;

This item has no description.

GL_PATH_CLIENT_LENGTH_NV = $907F;

This item has no description.

GL_PATH_FILL_MODE_NV = $9080;

This item has no description.

GL_PATH_FILL_MASK_NV = $9081;

This item has no description.

GL_PATH_FILL_COVER_MODE_NV = $9082;

This item has no description.

GL_PATH_STROKE_COVER_MODE_NV = $9083;

This item has no description.

GL_PATH_STROKE_MASK_NV = $9084;

This item has no description.

GL_PATH_SAMPLE_QUALITY_NV = $9085;

This item has no description.

GL_PATH_STROKE_BOUND_NV = $9086;

This item has no description.

GL_PATH_STROKE_OVERSAMPLE_COUNT_NV= $9087;

This item has no description.

GL_COUNT_UP_NV = $9088;

This item has no description.

GL_COUNT_DOWN_NV = $9089;

This item has no description.

GL_PATH_OBJECT_BOUNDING_BOX_NV = $908A;

This item has no description.

GL_CONVEX_HULL_NV = $908B;

This item has no description.

GL_MULTI_HULLS_NV = $908C;

This item has no description.

GL_BOUNDING_BOX_NV = $908D;

This item has no description.

GL_TRANSLATE_X_NV = $908E;

This item has no description.

GL_TRANSLATE_Y_NV = $908F;

This item has no description.

GL_TRANSLATE_2D_NV = $9090;

This item has no description.

GL_TRANSLATE_3D_NV = $9091;

This item has no description.

GL_AFFINE_2D_NV = $9092;

This item has no description.

GL_PROJECTIVE_2D_NV = $9093;

This item has no description.

GL_AFFINE_3D_NV = $9094;

This item has no description.

GL_PROJECTIVE_3D_NV = $9095;

This item has no description.

GL_TRANSPOSE_AFFINE_2D_NV = $9096;

This item has no description.

GL_TRANSPOSE_PROJECTIVE_2D_NV = $9097;

This item has no description.

GL_TRANSPOSE_AFFINE_3D_NV = $9098;

This item has no description.

GL_TRANSPOSE_PROJECTIVE_3D_NV = $9099;

This item has no description.

GL_UTF8_NV = $909A;

This item has no description.

GL_UTF16_NV = $909B;

This item has no description.

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV= $909C;

This item has no description.

GL_PATH_COMMAND_COUNT_NV = $909D;

This item has no description.

GL_PATH_COORD_COUNT_NV = $909E;

This item has no description.

GL_PATH_DASH_ARRAY_COUNT_NV = $909F;

This item has no description.

GL_PATH_COMPUTED_LENGTH_NV = $90A0;

This item has no description.

GL_PATH_FILL_BOUNDING_BOX_NV = $90A1;

This item has no description.

GL_PATH_STROKE_BOUNDING_BOX_NV = $90A2;

This item has no description.

GL_SQUARE_NV = $90A3;

This item has no description.

GL_ROUND_NV = $90A4;

This item has no description.

GL_TRIANGULAR_NV = $90A5;

This item has no description.

GL_BEVEL_NV = $90A6;

This item has no description.

GL_MITER_REVERT_NV = $90A7;

This item has no description.

GL_MITER_TRUNCATE_NV = $90A8;

This item has no description.

GL_SKIP_MISSING_GLYPH_NV = $90A9;

This item has no description.

GL_USE_MISSING_GLYPH_NV = $90AA;

This item has no description.

GL_PATH_ERROR_POSITION_NV = $90AB;

This item has no description.

GL_PATH_FOG_GEN_MODE_NV = $90AC;

This item has no description.

GL_ACCUM_ADJACENT_PAIRS_NV = $90AD;

This item has no description.

GL_ADJACENT_PAIRS_NV = $90AE;

This item has no description.

GL_FIRST_TO_REST_NV = $90AF;

This item has no description.

GL_PATH_GEN_MODE_NV = $90B0;

This item has no description.

GL_PATH_GEN_COEFF_NV = $90B1;

This item has no description.

GL_PATH_GEN_COLOR_FORMAT_NV = $90B2;

This item has no description.

GL_PATH_GEN_COMPONENTS_NV = $90B3;

This item has no description.

GL_PATH_STENCIL_FUNC_NV = $90B7;

This item has no description.

GL_PATH_STENCIL_REF_NV = $90B8;

This item has no description.

GL_PATH_STENCIL_VALUE_MASK_NV = $90B9;

This item has no description.

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV= $90BD;

This item has no description.

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV= $90BE;

This item has no description.

GL_PATH_COVER_DEPTH_FUNC_NV = $90BF;

This item has no description.

GL_PATH_DASH_OFFSET_RESET_NV = $90B4;

This item has no description.

GL_MOVE_TO_RESETS_NV = $90B5;

This item has no description.

GL_MOVE_TO_CONTINUES_NV = $90B6;

This item has no description.

GL_CLOSE_PATH_NV = $00;

This item has no description.

GL_MOVE_TO_NV = $02;

This item has no description.

GL_RELATIVE_MOVE_TO_NV = $03;

This item has no description.

GL_LINE_TO_NV = $04;

This item has no description.

GL_RELATIVE_LINE_TO_NV = $05;

This item has no description.

GL_HORIZONTAL_LINE_TO_NV = $06;

This item has no description.

GL_RELATIVE_HORIZONTAL_LINE_TO_NV= $07;

This item has no description.

GL_VERTICAL_LINE_TO_NV = $08;

This item has no description.

GL_RELATIVE_VERTICAL_LINE_TO_NV = $09;

This item has no description.

GL_QUADRATIC_CURVE_TO_NV = $0A;

This item has no description.

GL_RELATIVE_QUADRATIC_CURVE_TO_NV= $0B;

This item has no description.

GL_CUBIC_CURVE_TO_NV = $0C;

This item has no description.

GL_RELATIVE_CUBIC_CURVE_TO_NV = $0D;

This item has no description.

GL_SMOOTH_QUADRATIC_CURVE_TO_NV = $0E;

This item has no description.

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV= $0F;

This item has no description.

GL_SMOOTH_CUBIC_CURVE_TO_NV = $10;

This item has no description.

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV= $11;

This item has no description.

GL_SMALL_CCW_ARC_TO_NV = $12;

This item has no description.

GL_RELATIVE_SMALL_CCW_ARC_TO_NV = $13;

This item has no description.

GL_SMALL_CW_ARC_TO_NV = $14;

This item has no description.

GL_RELATIVE_SMALL_CW_ARC_TO_NV = $15;

This item has no description.

GL_LARGE_CCW_ARC_TO_NV = $16;

This item has no description.

GL_RELATIVE_LARGE_CCW_ARC_TO_NV = $17;

This item has no description.

GL_LARGE_CW_ARC_TO_NV = $18;

This item has no description.

GL_RELATIVE_LARGE_CW_ARC_TO_NV = $19;

This item has no description.

GL_RESTART_PATH_NV = $F0;

This item has no description.

GL_DUP_FIRST_CUBIC_CURVE_TO_NV = $F2;

This item has no description.

GL_DUP_LAST_CUBIC_CURVE_TO_NV = $F4;

This item has no description.

GL_RECT_NV = $F6;

This item has no description.

GL_CIRCULAR_CCW_ARC_TO_NV = $F8;

This item has no description.

GL_CIRCULAR_CW_ARC_TO_NV = $FA;

This item has no description.

GL_CIRCULAR_TANGENT_ARC_TO_NV = $FC;

This item has no description.

GL_ARC_TO_NV = $FE;

This item has no description.

GL_RELATIVE_ARC_TO_NV = $FF;

This item has no description.

GL_BOLD_BIT_NV = $01;

This item has no description.

GL_ITALIC_BIT_NV = $02;

This item has no description.

GL_GLYPH_WIDTH_BIT_NV = $01;

This item has no description.

GL_GLYPH_HEIGHT_BIT_NV = $02;

This item has no description.

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV= $04;

This item has no description.

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV= $08;

This item has no description.

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV= $10;

This item has no description.

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV= $20;

This item has no description.

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV= $40;

This item has no description.

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV= $80;

This item has no description.

GL_GLYPH_HAS_KERNING_NV = $100;

This item has no description.

GL_FONT_X_MIN_BOUNDS_NV = $00010000;

This item has no description.

GL_FONT_Y_MIN_BOUNDS_NV = $00020000;

This item has no description.

GL_FONT_X_MAX_BOUNDS_NV = $00040000;

This item has no description.

GL_FONT_Y_MAX_BOUNDS_NV = $00080000;

This item has no description.

GL_FONT_UNITS_PER_EM_NV = $00100000;

This item has no description.

GL_FONT_ASCENDER_NV = $00200000;

This item has no description.

GL_FONT_DESCENDER_NV = $00400000;

This item has no description.

GL_FONT_HEIGHT_NV = $00800000;

This item has no description.

GL_FONT_MAX_ADVANCE_WIDTH_NV = $01000000;

This item has no description.

GL_FONT_MAX_ADVANCE_HEIGHT_NV = $02000000;

This item has no description.

GL_FONT_UNDERLINE_POSITION_NV = $04000000;

This item has no description.

GL_FONT_UNDERLINE_THICKNESS_NV = $08000000;

This item has no description.

GL_FONT_HAS_KERNING_NV = $10000000;

This item has no description.

GL_EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD= $9160;

(4.3) GL_AMD_pinned_memory

GL_SET_AMD = $874A;

(4.3) GL_AMD_stencil_operation_extended

GL_REPLACE_VALUE_AMD = $874B;

This item has no description.

GL_STENCIL_OP_VALUE_AMD = $874C;

This item has no description.

GL_STENCIL_BACK_OP_VALUE_AMD = $874D;

This item has no description.

GL_QUERY_BUFFER_AMD = $9192;

(4.3) GL_AMD_vertex_shader_viewport_index (4.3) GL_AMD_vertex_shader_layer (4.3) GL_NV_bindless_texture (4.3) GL_NV_shader_atomic_float (4.3) GL_AMD_query_buffer_object

GL_QUERY_BUFFER_BINDING_AMD = $9193;

This item has no description.

GL_QUERY_RESULT_NO_WAIT_AMD = $9194;

This item has no description.

GL_TEXTURE_DEFORMATION_BIT_SGIX = $00000001;

GL_FfdMaskSGIX

GL_GEOMETRY_DEFORMATION_BIT_SGIX = $00000002;

This item has no description.

GL_IGNORE_BORDER_HP = $8150;

GL_HP_convolution_border_modes

GL_CONSTANT_BORDER_HP = $8151;

This item has no description.

GL_REPLICATE_BORDER_HP = $8153;

This item has no description.

GL_CONVOLUTION_BORDER_COLOR_HP = $8154;

This item has no description.

GL_IMAGE_SCALE_X_HP = $8155;

GL_HP_image_transform

GL_IMAGE_SCALE_Y_HP = $8156;

This item has no description.

GL_IMAGE_TRANSLATE_X_HP = $8157;

This item has no description.

GL_IMAGE_TRANSLATE_Y_HP = $8158;

This item has no description.

GL_IMAGE_ROTATE_ANGLE_HP = $8159;

This item has no description.

GL_IMAGE_ROTATE_ORIGIN_X_HP = $815A;

This item has no description.

GL_IMAGE_ROTATE_ORIGIN_Y_HP = $815B;

This item has no description.

GL_IMAGE_MAG_FILTER_HP = $815C;

This item has no description.

GL_IMAGE_MIN_FILTER_HP = $815D;

This item has no description.

GL_IMAGE_CUBIC_WEIGHT_HP = $815E;

This item has no description.

GL_CUBIC_HP = $815F;

This item has no description.

GL_AVERAGE_HP = $8160;

This item has no description.

GL_IMAGE_TRANSFORM_2D_HP = $8161;

This item has no description.

GL_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP = $8162;

This item has no description.

GL_PROXY_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP = $8163;

This item has no description.

GL_OCCLUSION_TEST_HP = $8165;

GL_HP_occlusion_test

GL_OCCLUSION_TEST_RESULT_HP = $8166;

This item has no description.

GL_TEXTURE_LIGHTING_MODE_HP = $8167;

GL_HP_texture_lighting

GL_TEXTURE_POST_SPECULAR_HP = $8168;

This item has no description.

GL_TEXTURE_PRE_SPECULAR_HP = $8169;

This item has no description.

GL_CULL_VERTEX_IBM = 103050;

GL_IBM_cull_vertex

GL_RASTER_POSITION_UNCLIPPED_IBM = $19262;

GL_IBM_rasterpos_clip

GL_MIRRORED_REPEAT_IBM = $8370;

GL_IBM_texture_mirrored_repeat

GL_VERTEX_ARRAY_LIST_IBM = 103070;

GL_IBM_vertex_array_lists

GL_NORMAL_ARRAY_LIST_IBM = 103071;

This item has no description.

GL_COLOR_ARRAY_LIST_IBM = 103072;

This item has no description.

GL_INDEX_ARRAY_LIST_IBM = 103073;

This item has no description.

GL_TEXTURE_COORD_ARRAY_LIST_IBM = 103074;

This item has no description.

GL_EDGE_FLAG_ARRAY_LIST_IBM = 103075;

This item has no description.

GL_FOG_COORDINATE_ARRAY_LIST_IBM = 103076;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_LIST_IBM = 103077;

This item has no description.

GL_VERTEX_ARRAY_LIST_STRIDE_IBM = 103080;

This item has no description.

GL_NORMAL_ARRAY_LIST_STRIDE_IBM = 103081;

This item has no description.

GL_COLOR_ARRAY_LIST_STRIDE_IBM = 103082;

This item has no description.

GL_INDEX_ARRAY_LIST_STRIDE_IBM = 103083;

This item has no description.

GL_TEXTURE_COORD_ARRAY_LIST_STRIDE_IBM = 103084;

This item has no description.

GL_EDGE_FLAG_ARRAY_LIST_STRIDE_IBM = 103085;

This item has no description.

GL_FOG_COORDINATE_ARRAY_LIST_STRIDE_IBM = 103086;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_LIST_STRIDE_IBM = 103087;

This item has no description.

GL_RED_MIN_CLAMP_INGR = $8560;

GL_INGR_color_clamp

GL_GREEN_MIN_CLAMP_INGR = $8561;

This item has no description.

GL_BLUE_MIN_CLAMP_INGR = $8562;

This item has no description.

GL_ALPHA_MIN_CLAMP_INGR = $8563;

This item has no description.

GL_RED_MAX_CLAMP_INGR = $8564;

This item has no description.

GL_GREEN_MAX_CLAMP_INGR = $8565;

This item has no description.

GL_BLUE_MAX_CLAMP_INGR = $8566;

This item has no description.

GL_ALPHA_MAX_CLAMP_INGR = $8567;

This item has no description.

GL_INTERLACE_READ_INGR = $8568;

GL_INGR_interlace_read

GL_PARALLEL_ARRAYS_INTEL = $83F4;

GL_INTEL_parallel_arrays

GL_VERTEX_ARRAY_PARALLEL_POINTERS_INTEL = $83F5;

This item has no description.

GL_NORMAL_ARRAY_PARALLEL_POINTERS_INTEL = $83F6;

This item has no description.

GL_COLOR_ARRAY_PARALLEL_POINTERS_INTEL = $83F7;

This item has no description.

GL_TEXTURE_COORD_ARRAY_PARALLEL_POINTERS_INTEL = $83F8;

This item has no description.

GL_DEPTH_STENCIL_TO_RGBA_NV = $886E;

GL_NV_copy_depth_to_color

GL_DEPTH_STENCIL_TO_BGRA_NV = $886F;

This item has no description.

GL_DEPTH_CLAMP_NV = $864F;

GL_NV_depth_clamp

GL_EVAL_2D_NV = $86C0;

GL_NV_evaluators

GL_EVAL_TRIANGULAR_2D_NV = $86C1;

This item has no description.

GL_MAP_TESSELLATION_NV = $86C2;

This item has no description.

GL_MAP_ATTRIB_U_ORDER_NV = $86C3;

This item has no description.

GL_MAP_ATTRIB_V_ORDER_NV = $86C4;

This item has no description.

GL_EVAL_FRACTIONAL_TESSELLATION_NV = $86C5;

This item has no description.

GL_EVAL_VERTEX_ATTRIB0_NV = $86C6;

This item has no description.

GL_EVAL_VERTEX_ATTRIB1_NV = $86C7;

This item has no description.

GL_EVAL_VERTEX_ATTRIB2_NV = $86C8;

This item has no description.

GL_EVAL_VERTEX_ATTRIB3_NV = $86C9;

This item has no description.

GL_EVAL_VERTEX_ATTRIB4_NV = $86CA;

This item has no description.

GL_EVAL_VERTEX_ATTRIB5_NV = $86CB;

This item has no description.

GL_EVAL_VERTEX_ATTRIB6_NV = $86CC;

This item has no description.

GL_EVAL_VERTEX_ATTRIB7_NV = $86CD;

This item has no description.

GL_EVAL_VERTEX_ATTRIB8_NV = $86CE;

This item has no description.

GL_EVAL_VERTEX_ATTRIB9_NV = $86CF;

This item has no description.

GL_EVAL_VERTEX_ATTRIB10_NV = $86D0;

This item has no description.

GL_EVAL_VERTEX_ATTRIB11_NV = $86D1;

This item has no description.

GL_EVAL_VERTEX_ATTRIB12_NV = $86D2;

This item has no description.

GL_EVAL_VERTEX_ATTRIB13_NV = $86D3;

This item has no description.

GL_EVAL_VERTEX_ATTRIB14_NV = $86D4;

This item has no description.

GL_EVAL_VERTEX_ATTRIB15_NV = $86D5;

This item has no description.

GL_MAX_MAP_TESSELLATION_NV = $86D6;

This item has no description.

GL_MAX_RATIONAL_EVAL_ORDER_NV = $86D7;

This item has no description.

GL_ALL_COMPLETED_NV = $84F2;

GL_NV_fence

GL_FENCE_STATUS_NV = $84F3;

This item has no description.

GL_FENCE_CONDITION_NV = $84F4;

This item has no description.

GL_FLOAT_R_NV = $8880;

GL_NV_float_buffer

GL_FLOAT_RG_NV = $8881;

This item has no description.

GL_FLOAT_RGB_NV = $8882;

This item has no description.

GL_FLOAT_RGBA_NV = $8883;

This item has no description.

GL_FLOAT_R16_NV = $8884;

This item has no description.

GL_FLOAT_R32_NV = $8885;

This item has no description.

GL_FLOAT_RG16_NV = $8886;

This item has no description.

GL_FLOAT_RG32_NV = $8887;

This item has no description.

GL_FLOAT_RGB16_NV = $8888;

This item has no description.

GL_FLOAT_RGB32_NV = $8889;

This item has no description.

GL_FLOAT_RGBA16_NV = $888A;

This item has no description.

GL_FLOAT_RGBA32_NV = $888B;

This item has no description.

GL_TEXTURE_FLOAT_COMPONENTS_NV = $888C;

This item has no description.

GL_FLOAT_CLEAR_COLOR_VALUE_NV = $888D;

This item has no description.

GL_FLOAT_RGBA_MODE_NV = $888E;

This item has no description.

GL_FOG_DISTANCE_MODE_NV = $855A;

GL_NV_fog_distance

GL_EYE_RADIAL_NV = $855B;

This item has no description.

GL_EYE_PLANE_ABSOLUTE_NV = $855C;

This item has no description.

GL_MAX_FRAGMENT_PROGRAM_LOCAL_PARAMETERS_NV = $8868;

GL_NV_fragment_program

GL_FRAGMENT_PROGRAM_NV = $8870;

This item has no description.

GL_MAX_TEXTURE_COORDS_NV = $8871;

This item has no description.

GL_MAX_TEXTURE_IMAGE_UNITS_NV = $8872;

This item has no description.

GL_FRAGMENT_PROGRAM_BINDING_NV = $8873;

This item has no description.

GL_PROGRAM_ERROR_STRING_NV = $8874;

This item has no description.

GL_HALF_FLOAT_NV = $140B;

GL_NV_half_float

GL_MAX_SHININESS_NV = $8504;

GL_NV_light_max_exponent

GL_MAX_SPOT_EXPONENT_NV = $8505;

This item has no description.

GL_MULTISAMPLE_FILTER_HINT_NV = $8534;

GL_NV_multisample_filter_hint

GL_PIXEL_COUNTER_BITS_NV = $8864;

GL_NV_occlusion_query

GL_CURRENT_OCCLUSION_QUERY_ID_NV = $8865;

This item has no description.

GL_PIXEL_COUNT_NV = $8866;

This item has no description.

GL_PIXEL_COUNT_AVAILABLE_NV = $8867;

This item has no description.

GL_DEPTH_STENCIL_NV = $84F9;

GL_NV_packed_depth_stencil

GL_UNSIGNED_INT_24_8_NV = $84FA;

This item has no description.

GL_WRITE_PIXEL_DATA_RANGE_NV = $8878;

GL_NV_pixel_data_range

GL_READ_PIXEL_DATA_RANGE_NV = $8879;

This item has no description.

GL_WRITE_PIXEL_DATA_RANGE_LENGTH_NV = $887A;

This item has no description.

GL_READ_PIXEL_DATA_RANGE_LENGTH_NV = $887B;

This item has no description.

GL_WRITE_PIXEL_DATA_RANGE_POINTER_NV = $887C;

This item has no description.

GL_READ_PIXEL_DATA_RANGE_POINTER_NV = $887D;

This item has no description.

GL_POINT_SPRITE_NV = $8861;

GL_NV_point_sprite

GL_COORD_REPLACE_NV = $8862;

This item has no description.

GL_POINT_SPRITE_R_MODE_NV = $8863;

This item has no description.

GL_PRIMITIVE_RESTART_NV = $8558;

GL_NV_primitive_restart

GL_PRIMITIVE_RESTART_INDEX_NV = $8559;

This item has no description.

GL_REGISTER_COMBINERS_NV = $8522;

GL_NV_register_combiners

GL_VARIABLE_A_NV = $8523;

This item has no description.

GL_VARIABLE_B_NV = $8524;

This item has no description.

GL_VARIABLE_C_NV = $8525;

This item has no description.

GL_VARIABLE_D_NV = $8526;

This item has no description.

GL_VARIABLE_E_NV = $8527;

This item has no description.

GL_VARIABLE_F_NV = $8528;

This item has no description.

GL_VARIABLE_G_NV = $8529;

This item has no description.

GL_CONSTANT_COLOR0_NV = $852A;

This item has no description.

GL_CONSTANT_COLOR1_NV = $852B;

This item has no description.

GL_PRIMARY_COLOR_NV = $852C;

This item has no description.

GL_SECONDARY_COLOR_NV = $852D;

This item has no description.

GL_SPARE0_NV = $852E;

This item has no description.

GL_SPARE1_NV = $852F;

This item has no description.

GL_DISCARD_NV = $8530;

This item has no description.

GL_E_TIMES_F_NV = $8531;

This item has no description.

GL_SPARE0_PLUS_SECONDARY_COLOR_NV = $8532;

This item has no description.

GL_UNSIGNED_IDENTITY_NV = $8536;

This item has no description.

GL_UNSIGNED_INVERT_NV = $8537;

This item has no description.

GL_EXPAND_NORMAL_NV = $8538;

This item has no description.

GL_EXPAND_NEGATE_NV = $8539;

This item has no description.

GL_HALF_BIAS_NORMAL_NV = $853A;

This item has no description.

GL_HALF_BIAS_NEGATE_NV = $853B;

This item has no description.

GL_SIGNED_IDENTITY_NV = $853C;

This item has no description.

GL_SIGNED_NEGATE_NV = $853D;

This item has no description.

GL_SCALE_BY_TWO_NV = $853E;

This item has no description.

GL_SCALE_BY_FOUR_NV = $853F;

This item has no description.

GL_SCALE_BY_ONE_HALF_NV = $8540;

This item has no description.

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV = $8541;

This item has no description.

GL_COMBINER_INPUT_NV = $8542;

This item has no description.

GL_COMBINER_MAPPING_NV = $8543;

This item has no description.

GL_COMBINER_COMPONENT_USAGE_NV = $8544;

This item has no description.

GL_COMBINER_AB_DOT_PRODUCT_NV = $8545;

This item has no description.

GL_COMBINER_CD_DOT_PRODUCT_NV = $8546;

This item has no description.

GL_COMBINER_MUX_SUM_NV = $8547;

This item has no description.

GL_COMBINER_SCALE_NV = $8548;

This item has no description.

GL_COMBINER_BIAS_NV = $8549;

This item has no description.

GL_COMBINER_AB_OUTPUT_NV = $854A;

This item has no description.

GL_COMBINER_CD_OUTPUT_NV = $854B;

This item has no description.

GL_COMBINER_SUM_OUTPUT_NV = $854C;

This item has no description.

GL_MAX_GENERAL_COMBINERS_NV = $854D;

This item has no description.

GL_NUM_GENERAL_COMBINERS_NV = $854E;

This item has no description.

GL_COLOR_SUM_CLAMP_NV = $854F;

This item has no description.

GL_COMBINER0_NV = $8550;

This item has no description.

GL_COMBINER1_NV = $8551;

This item has no description.

GL_COMBINER2_NV = $8552;

This item has no description.

GL_COMBINER3_NV = $8553;

This item has no description.

GL_COMBINER4_NV = $8554;

This item has no description.

GL_COMBINER5_NV = $8555;

This item has no description.

GL_COMBINER6_NV = $8556;

This item has no description.

GL_COMBINER7_NV = $8557;

This item has no description.

GL_PER_STAGE_CONSTANTS_NV = $8535;

GL_NV_register_combiners2

GL_EMBOSS_LIGHT_NV = $855D;

GL_NV_texgen_emboss

GL_EMBOSS_CONSTANT_NV = $855E;

This item has no description.

GL_EMBOSS_MAP_NV = $855F;

This item has no description.

GL_NORMAL_MAP_NV = $8511;

GL_NV_texgen_reflection

GL_REFLECTION_MAP_NV = $8512;

This item has no description.

GL_COMBINE4_NV = $8503;

GL_NV_texture_env_combine4

GL_SOURCE3_RGB_NV = $8583;

This item has no description.

GL_SOURCE3_ALPHA_NV = $858B;

This item has no description.

GL_OPERAND3_RGB_NV = $8593;

This item has no description.

GL_OPERAND3_ALPHA_NV = $859B;

This item has no description.

GL_TEXTURE_UNSIGNED_REMAP_MODE_NV = $888F;

GL_NV_texture_expand_normal

GL_TEXTURE_RECTANGLE_NV = $84F5;

GL_NV_texture_rectangle

GL_TEXTURE_BINDING_RECTANGLE_NV = $84F6;

This item has no description.

GL_PROXY_TEXTURE_RECTANGLE_NV = $84F7;

This item has no description.

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV = $84F8;

This item has no description.

GL_OFFSET_TEXTURE_RECTANGLE_NV = $864C;

GL_NV_texture_shader

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV = $864D;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV = $864E;

This item has no description.

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV = $86D9;

This item has no description.

GL_UNSIGNED_INT_S8_S8_8_8_NV = $86DA;

This item has no description.

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV = $86DB;

This item has no description.

GL_DSDT_MAG_INTENSITY_NV = $86DC;

This item has no description.

GL_SHADER_CONSISTENT_NV = $86DD;

This item has no description.

GL_TEXTURE_SHADER_NV = $86DE;

This item has no description.

GL_SHADER_OPERATION_NV = $86DF;

This item has no description.

GL_CULL_MODES_NV = $86E0;

This item has no description.

GL_OFFSET_TEXTURE_MATRIX_NV = $86E1;

This item has no description.

GL_OFFSET_TEXTURE_SCALE_NV = $86E2;

This item has no description.

GL_OFFSET_TEXTURE_BIAS_NV = $86E3;

This item has no description.

GL_OFFSET_TEXTURE_2D_MATRIX_NV = GL_OFFSET_TEXTURE_MATRIX_NV;

This item has no description.

GL_OFFSET_TEXTURE_2D_SCALE_NV = GL_OFFSET_TEXTURE_SCALE_NV;

This item has no description.

GL_OFFSET_TEXTURE_2D_BIAS_NV = GL_OFFSET_TEXTURE_BIAS_NV;

This item has no description.

GL_PREVIOUS_TEXTURE_INPUT_NV = $86E4;

This item has no description.

GL_CONST_EYE_NV = $86E5;

This item has no description.

GL_PASS_THROUGH_NV = $86E6;

This item has no description.

GL_CULL_FRAGMENT_NV = $86E7;

This item has no description.

GL_OFFSET_TEXTURE_2D_NV = $86E8;

This item has no description.

GL_DEPENDENT_AR_TEXTURE_2D_NV = $86E9;

This item has no description.

GL_DEPENDENT_GB_TEXTURE_2D_NV = $86EA;

This item has no description.

GL_DOT_PRODUCT_NV = $86EC;

This item has no description.

GL_DOT_PRODUCT_DEPTH_REPLACE_NV = $86ED;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_2D_NV = $86EE;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV = $86F0;

This item has no description.

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV = $86F1;

This item has no description.

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV = $86F2;

This item has no description.

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV = $86F3;

This item has no description.

GL_HILO_NV = $86F4;

This item has no description.

GL_DSDT_NV = $86F5;

This item has no description.

GL_DSDT_MAG_NV = $86F6;

This item has no description.

GL_DSDT_MAG_VIB_NV = $86F7;

This item has no description.

GL_HILO16_NV = $86F8;

This item has no description.

GL_SIGNED_HILO_NV = $86F9;

This item has no description.

GL_SIGNED_HILO16_NV = $86FA;

This item has no description.

GL_SIGNED_RGBA_NV = $86FB;

This item has no description.

GL_SIGNED_RGBA8_NV = $86FC;

This item has no description.

GL_SIGNED_RGB_NV = $86FE;

This item has no description.

GL_SIGNED_RGB8_NV = $86FF;

This item has no description.

GL_SIGNED_LUMINANCE_NV = $8701;

This item has no description.

GL_SIGNED_LUMINANCE8_NV = $8702;

This item has no description.

GL_SIGNED_LUMINANCE_ALPHA_NV = $8703;

This item has no description.

GL_SIGNED_LUMINANCE8_ALPHA8_NV = $8704;

This item has no description.

GL_SIGNED_ALPHA_NV = $8705;

This item has no description.

GL_SIGNED_ALPHA8_NV = $8706;

This item has no description.

GL_SIGNED_INTENSITY_NV = $8707;

This item has no description.

GL_SIGNED_INTENSITY8_NV = $8708;

This item has no description.

GL_DSDT8_NV = $8709;

This item has no description.

GL_DSDT8_MAG8_NV = $870A;

This item has no description.

GL_DSDT8_MAG8_INTENSITY8_NV = $870B;

This item has no description.

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV = $870C;

This item has no description.

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV = $870D;

This item has no description.

GL_HI_SCALE_NV = $870E;

This item has no description.

GL_LO_SCALE_NV = $870F;

This item has no description.

GL_DS_SCALE_NV = $8710;

This item has no description.

GL_DT_SCALE_NV = $8711;

This item has no description.

GL_MAGNITUDE_SCALE_NV = $8712;

This item has no description.

GL_VIBRANCE_SCALE_NV = $8713;

This item has no description.

GL_HI_BIAS_NV = $8714;

This item has no description.

GL_LO_BIAS_NV = $8715;

This item has no description.

GL_DS_BIAS_NV = $8716;

This item has no description.

GL_DT_BIAS_NV = $8717;

This item has no description.

GL_MAGNITUDE_BIAS_NV = $8718;

This item has no description.

GL_VIBRANCE_BIAS_NV = $8719;

This item has no description.

GL_TEXTURE_BORDER_VALUES_NV = $871A;

This item has no description.

GL_TEXTURE_HI_SIZE_NV = $871B;

This item has no description.

GL_TEXTURE_LO_SIZE_NV = $871C;

This item has no description.

GL_TEXTURE_DS_SIZE_NV = $871D;

This item has no description.

GL_TEXTURE_DT_SIZE_NV = $871E;

This item has no description.

GL_TEXTURE_MAG_SIZE_NV = $871F;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_3D_NV = $86EF;

GL_NV_texture_shader2

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV = $8850;

GL_NV_texture_shader3

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV = $8851;

This item has no description.

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8852;

This item has no description.

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV = $8853;

This item has no description.

GL_OFFSET_HILO_TEXTURE_2D_NV = $8854;

This item has no description.

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV = $8855;

This item has no description.

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV = $8856;

This item has no description.

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8857;

This item has no description.

GL_DEPENDENT_HILO_TEXTURE_2D_NV = $8858;

This item has no description.

GL_DEPENDENT_RGB_TEXTURE_3D_NV = $8859;

This item has no description.

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV = $885A;

This item has no description.

GL_DOT_PRODUCT_PASS_THROUGH_NV = $885B;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_1D_NV = $885C;

This item has no description.

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV = $885D;

This item has no description.

GL_HILO8_NV = $885E;

This item has no description.

GL_SIGNED_HILO8_NV = $885F;

This item has no description.

GL_FORCE_BLUE_TO_ONE_NV = $8860;

This item has no description.

GL_VERTEX_ARRAY_RANGE_NV = $851D;

GL_NV_vertex_array_range

GL_VERTEX_ARRAY_RANGE_LENGTH_NV = $851E;

This item has no description.

GL_VERTEX_ARRAY_RANGE_VALID_NV = $851F;

This item has no description.

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV = $8520;

This item has no description.

GL_VERTEX_ARRAY_RANGE_POINTER_NV = $8521;

This item has no description.

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV = $8533;

GL_NV_vertex_array_range2

GL_VERTEX_PROGRAM_NV = $8620;

GL_NV_vertex_program

GL_VERTEX_STATE_PROGRAM_NV = $8621;

This item has no description.

GL_ATTRIB_ARRAY_SIZE_NV = $8623;

This item has no description.

GL_ATTRIB_ARRAY_STRIDE_NV = $8624;

This item has no description.

GL_ATTRIB_ARRAY_TYPE_NV = $8625;

This item has no description.

GL_CURRENT_ATTRIB_NV = $8626;

This item has no description.

GL_PROGRAM_LENGTH_NV = $8627;

This item has no description.

GL_PROGRAM_STRING_NV = $8628;

This item has no description.

GL_MODELVIEW_PROJECTION_NV = $8629;

This item has no description.

GL_IDENTITY_NV = $862A;

This item has no description.

GL_INVERSE_NV = $862B;

This item has no description.

GL_TRANSPOSE_NV = $862C;

This item has no description.

GL_INVERSE_TRANSPOSE_NV = $862D;

This item has no description.

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV = $862E;

This item has no description.

GL_MAX_TRACK_MATRICES_NV = $862F;

This item has no description.

GL_MATRIX0_NV = $8630;

This item has no description.

GL_MATRIX1_NV = $8631;

This item has no description.

GL_MATRIX2_NV = $8632;

This item has no description.

GL_MATRIX3_NV = $8633;

This item has no description.

GL_MATRIX4_NV = $8634;

This item has no description.

GL_MATRIX5_NV = $8635;

This item has no description.

GL_MATRIX6_NV = $8636;

This item has no description.

GL_MATRIX7_NV = $8637;

This item has no description.

GL_CURRENT_MATRIX_STACK_DEPTH_NV = $8640;

This item has no description.

GL_CURRENT_MATRIX_NV = $8641;

This item has no description.

GL_VERTEX_PROGRAM_POINT_SIZE_NV = $8642;

This item has no description.

GL_VERTEX_PROGRAM_TWO_SIDE_NV = $8643;

This item has no description.

GL_PROGRAM_PARAMETER_NV = $8644;

This item has no description.

GL_ATTRIB_ARRAY_POINTER_NV = $8645;

This item has no description.

GL_PROGRAM_TARGET_NV = $8646;

This item has no description.

GL_PROGRAM_RESIDENT_NV = $8647;

This item has no description.

GL_TRACK_MATRIX_NV = $8648;

This item has no description.

GL_TRACK_MATRIX_TRANSFORM_NV = $8649;

This item has no description.

GL_VERTEX_PROGRAM_BINDING_NV = $864A;

This item has no description.

GL_PROGRAM_ERROR_POSITION_NV = $864B;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY0_NV = $8650;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY1_NV = $8651;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY2_NV = $8652;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY3_NV = $8653;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY4_NV = $8654;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY5_NV = $8655;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY6_NV = $8656;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY7_NV = $8657;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY8_NV = $8658;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY9_NV = $8659;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY10_NV = $865A;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY11_NV = $865B;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY12_NV = $865C;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY13_NV = $865D;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY14_NV = $865E;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY15_NV = $865F;

This item has no description.

GL_MAP1_VERTEX_ATTRIB0_4_NV = $8660;

This item has no description.

GL_MAP1_VERTEX_ATTRIB1_4_NV = $8661;

This item has no description.

GL_MAP1_VERTEX_ATTRIB2_4_NV = $8662;

This item has no description.

GL_MAP1_VERTEX_ATTRIB3_4_NV = $8663;

This item has no description.

GL_MAP1_VERTEX_ATTRIB4_4_NV = $8664;

This item has no description.

GL_MAP1_VERTEX_ATTRIB5_4_NV = $8665;

This item has no description.

GL_MAP1_VERTEX_ATTRIB6_4_NV = $8666;

This item has no description.

GL_MAP1_VERTEX_ATTRIB7_4_NV = $8667;

This item has no description.

GL_MAP1_VERTEX_ATTRIB8_4_NV = $8668;

This item has no description.

GL_MAP1_VERTEX_ATTRIB9_4_NV = $8669;

This item has no description.

GL_MAP1_VERTEX_ATTRIB10_4_NV = $866A;

This item has no description.

GL_MAP1_VERTEX_ATTRIB11_4_NV = $866B;

This item has no description.

GL_MAP1_VERTEX_ATTRIB12_4_NV = $866C;

This item has no description.

GL_MAP1_VERTEX_ATTRIB13_4_NV = $866D;

This item has no description.

GL_MAP1_VERTEX_ATTRIB14_4_NV = $866E;

This item has no description.

GL_MAP1_VERTEX_ATTRIB15_4_NV = $866F;

This item has no description.

GL_MAP2_VERTEX_ATTRIB0_4_NV = $8670;

This item has no description.

GL_MAP2_VERTEX_ATTRIB1_4_NV = $8671;

This item has no description.

GL_MAP2_VERTEX_ATTRIB2_4_NV = $8672;

This item has no description.

GL_MAP2_VERTEX_ATTRIB3_4_NV = $8673;

This item has no description.

GL_MAP2_VERTEX_ATTRIB4_4_NV = $8674;

This item has no description.

GL_MAP2_VERTEX_ATTRIB5_4_NV = $8675;

This item has no description.

GL_MAP2_VERTEX_ATTRIB6_4_NV = $8676;

This item has no description.

GL_MAP2_VERTEX_ATTRIB7_4_NV = $8677;

This item has no description.

GL_MAP2_VERTEX_ATTRIB8_4_NV = $8678;

This item has no description.

GL_MAP2_VERTEX_ATTRIB9_4_NV = $8679;

This item has no description.

GL_MAP2_VERTEX_ATTRIB10_4_NV = $867A;

This item has no description.

GL_MAP2_VERTEX_ATTRIB11_4_NV = $867B;

This item has no description.

GL_MAP2_VERTEX_ATTRIB12_4_NV = $867C;

This item has no description.

GL_MAP2_VERTEX_ATTRIB13_4_NV = $867D;

This item has no description.

GL_MAP2_VERTEX_ATTRIB14_4_NV = $867E;

This item has no description.

GL_MAP2_VERTEX_ATTRIB15_4_NV = $867F;

This item has no description.

GL_MAX_PROGRAM_EXEC_INSTRUCTIONS_NV = $88F4;

GL_NV_fragment_program2 and GL_NV_vertex_program2_option

GL_MAX_PROGRAM_CALL_DEPTH_NV = $88F5;

This item has no description.

GL_MAX_PROGRAM_IF_DEPTH_NV = $88F6;

GL_NV_fragment_program2

GL_MAX_PROGRAM_LOOP_DEPTH_NV = $88F7;

This item has no description.

GL_MAX_PROGRAM_LOOP_COUNT_NV = $88F8;

This item has no description.

MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

GL_NV_vertex_program3

GL_FLOAT_32_UNSIGNED_INT_24_8_REV_NV = $8DAD;

GL_NV_depth_buffer_float

GL_DEPTH_BUFFER_FLOAT_MODE_NV = $8DAF;

This item has no description.

GL_RENDERBUFFER_COVERAGE_SAMPLES_NV = $8CAB;

GL_NV_framebuffer_multisample_coverage

GL_RENDERBUFFER_COLOR_SAMPLES_NV = $8E10;

This item has no description.

GL_GEOMETRY_PROGRAM_NV = $8C26;

GL_NV_geometry_program4

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV = $8C27;

This item has no description.

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV = $8C28;

This item has no description.

GL_PROGRAM_ATTRIB_COMPONENTS_NV = $8906;

GL_NV_gpu_program4

GL_PROGRAM_RESULT_COMPONENTS_NV = $8907;

This item has no description.

GL_MAX_PROGRAM_ATTRIB_COMPONENTS_NV = $8908;

This item has no description.

GL_MAX_PROGRAM_RESULT_COMPONENTS_NV = $8909;

This item has no description.

GL_MAX_PROGRAM_GENERIC_ATTRIBS_NV = $8DA5;

This item has no description.

GL_MAX_PROGRAM_GENERIC_RESULTS_NV = $8DA6;

This item has no description.

GL_MAX_PROGRAM_PARAMETER_BUFFER_BINDINGS_NV = $8DA0;

GL_NV_parameter_buffer_object

GL_MAX_PROGRAM_PARAMETER_BUFFER_SIZE_NV = $8DA1;

This item has no description.

GL_VERTEX_PROGRAM_PARAMETER_BUFFER_NV = $8DA2;

This item has no description.

GL_GEOMETRY_PROGRAM_PARAMETER_BUFFER_NV = $8DA3;

This item has no description.

GL_FRAGMENT_PROGRAM_PARAMETER_BUFFER_NV = $8DA4;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_NV = $8C8E;

GL_NV_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV = $8C84;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV = $8C85;

This item has no description.

GL_TRANSFORM_FEEDBACK_RECORD_NV = $8C86;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV = $8C8F;

This item has no description.

GL_INTERLEAVED_ATTRIBS_NV = $8C8C;

This item has no description.

GL_SEPARATE_ATTRIBS_NV = $8C8D;

This item has no description.

GL_PRIMITIVES_GENERATED_NV = $8C87;

This item has no description.

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV = $8C88;

This item has no description.

GL_RASTERIZER_DISCARD_NV = $8C89;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV = $8C8A;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV = $8C8B;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV = $8C80;

This item has no description.

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV = $8C7E;

This item has no description.

GL_ACTIVE_VARYINGS_NV = $8C81;

This item has no description.

GL_ACTIVE_VARYING_MAX_LENGTH_NV = $8C82;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYINGS_NV = $8C83;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV = $8C7F;

This item has no description.

GL_BACK_PRIMARY_COLOR_NV = $8C77;

This item has no description.

GL_BACK_SECONDARY_COLOR_NV = $8C78;

This item has no description.

GL_TEXTURE_COORD_NV = $8C79;

This item has no description.

GL_CLIP_DISTANCE_NV = $8C7A;

This item has no description.

GL_VERTEX_ID_NV = $8C7B;

This item has no description.

GL_PRIMITIVE_ID_NV = $8C7C;

This item has no description.

GL_GENERIC_ATTRIB_NV = $8C7D;

This item has no description.

GL_LAYER_NV = $8DAA;

This item has no description.

GL_NEXT_BUFFER_NV = -2;

This item has no description.

GL_SKIP_COMPONENTS4_NV = -3;

This item has no description.

GL_SKIP_COMPONENTS3_NV = -4;

This item has no description.

GL_SKIP_COMPONENTS2_NV = -5;

This item has no description.

GL_SKIP_COMPONENTS1_NV = -6;

This item has no description.

GL_QUERY_WAIT_NV = $8E13;

GL_NV_conditional_render

GL_QUERY_NO_WAIT_NV = $8E14;

This item has no description.

GL_QUERY_BY_REGION_WAIT_NV = $8E15;

This item has no description.

GL_QUERY_BY_REGION_NO_WAIT_NV = $8E16;

This item has no description.

GL_CONSERVATIVE_RASTERIZATION_NV = $9346;

GL_NV_conservative_raster

GL_SUBPIXEL_PRECISION_BIAS_X_BITS_NV = $9347;

This item has no description.

GL_SUBPIXEL_PRECISION_BIAS_Y_BITS_NV = $9348;

This item has no description.

GL_MAX_SUBPIXEL_PRECISION_BIAS_BITS_NV = $9349;

This item has no description.

GL_CONSERVATIVE_RASTER_DILATE_NV = $9379;

GL_NV_conservative_raster_dilate

GL_CONSERVATIVE_RASTER_DILATE_RANGE_NV = $937A;

This item has no description.

GL_CONSERVATIVE_RASTER_DILATE_GRANULARITY_NV = $937B;

This item has no description.

GL_FRAME_NV = $8E26;

GL_NV_present_video

GL_FIELDS_NV = $8E27;

This item has no description.

GL_CURRENT_TIME_NV = $8E28;

This item has no description.

GL_NUM_FILL_STREAMS_NV = $8E29;

This item has no description.

GL_PRESENT_TIME_NV = $8E2A;

This item has no description.

GL_PRESENT_DURATION_NV = $8E2B;

This item has no description.

GL_SAMPLE_POSITION_NV = $8E50;

GL_NV_explicit_multisample

GL_SAMPLE_MASK_NV = $8E51;

This item has no description.

GL_SAMPLE_MASK_VALUE_NV = $8E52;

This item has no description.

GL_TEXTURE_BINDING_RENDERBUFFER_NV = $8E53;

This item has no description.

GL_TEXTURE_RENDERBUFFER_DATA_STORE_BINDING_NV = $8E54;

This item has no description.

GL_TEXTURE_RENDERBUFFER_NV = $8E55;

This item has no description.

GL_SAMPLER_RENDERBUFFER_NV = $8E56;

This item has no description.

GL_INT_SAMPLER_RENDERBUFFER_NV = $8E57;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_RENDERBUFFER_NV = $8E58;

This item has no description.

GL_MAX_SAMPLE_MASK_WORDS_NV = $8E59;

This item has no description.

GL_TRANSFORM_FEEDBACK_NV = $8E22;

GL_NV_transform_feedback2

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED_NV = $8E23;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE_NV = $8E24;

This item has no description.

GL_TRANSFORM_FEEDBACK_BINDING_NV = $8E25;

This item has no description.

GL_VIDEO_BUFFER_NV = $9020;

GL_NV_video_capture

GL_VIDEO_BUFFER_BINDING_NV = $9021;

This item has no description.

GL_FIELD_UPPER_NV = $9022;

This item has no description.

GL_FIELD_LOWER_NV = $9023;

This item has no description.

GL_NUM_VIDEO_CAPTURE_STREAMS_NV = $9024;

This item has no description.

GL_NEXT_VIDEO_CAPTURE_BUFFER_STATUS_NV = $9025;

This item has no description.

GL_VIDEO_CAPTURE_TO_422_SUPPORTED_NV = $9026;

This item has no description.

GL_LAST_VIDEO_CAPTURE_STATUS_NV = $9027;

This item has no description.

GL_VIDEO_BUFFER_PITCH_NV = $9028;

This item has no description.

GL_VIDEO_COLOR_CONVERSION_MATRIX_NV = $9029;

This item has no description.

GL_VIDEO_COLOR_CONVERSION_MAX_NV = $902A;

This item has no description.

GL_VIDEO_COLOR_CONVERSION_MIN_NV = $902B;

This item has no description.

GL_VIDEO_COLOR_CONVERSION_OFFSET_NV = $902C;

This item has no description.

GL_VIDEO_BUFFER_INTERNAL_FORMAT_NV = $902D;

This item has no description.

GL_PARTIAL_SUCCESS_NV = $902E;

This item has no description.

GL_SUCCESS_NV = $902F;

This item has no description.

GL_FAILURE_NV = $9030;

This item has no description.

GL_YCBYCR8_422_NV = $9031;

This item has no description.

GL_YCBAYCR8A_4224_NV = $9032;

This item has no description.

GL_Z6Y10Z6CB10Z6Y10Z6CR10_422_NV = $9033;

This item has no description.

GL_Z6Y10Z6CB10Z6A10Z6Y10Z6CR10Z6A10_4224_NV = $9034;

This item has no description.

GL_Z4Y12Z4CB12Z4Y12Z4CR12_422_NV = $9035;

This item has no description.

GL_Z4Y12Z4CB12Z4A12Z4Y12Z4CR12Z4A12_4224_NV = $9036;

This item has no description.

GL_Z4Y12Z4CB12Z4CR12_444_NV = $9037;

This item has no description.

GL_VIDEO_CAPTURE_FRAME_WIDTH_NV = $9038;

This item has no description.

GL_VIDEO_CAPTURE_FRAME_HEIGHT_NV = $9039;

This item has no description.

GL_VIDEO_CAPTURE_FIELD_UPPER_HEIGHT_NV = $903A;

This item has no description.

GL_VIDEO_CAPTURE_FIELD_LOWER_HEIGHT_NV = $903B;

This item has no description.

GL_VIDEO_CAPTURE_SURFACE_ORIGIN_NV = $903C;

This item has no description.

GL_BUFFER_GPU_ADDRESS_NV = $8F1D;

GL_NV_shader_buffer_load

GL_GPU_ADDRESS_NV = $8F34;

This item has no description.

GL_MAX_SHADER_BUFFER_ADDRESS_NV = $8F35;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV = $8F1E;

GL_NV_vertex_buffer_unified_memory

GL_ELEMENT_ARRAY_UNIFIED_NV = $8F1F;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV = $8F20;

This item has no description.

GL_VERTEX_ARRAY_ADDRESS_NV = $8F21;

This item has no description.

GL_NORMAL_ARRAY_ADDRESS_NV = $8F22;

This item has no description.

GL_COLOR_ARRAY_ADDRESS_NV = $8F23;

This item has no description.

GL_INDEX_ARRAY_ADDRESS_NV = $8F24;

This item has no description.

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV = $8F25;

This item has no description.

GL_EDGE_FLAG_ARRAY_ADDRESS_NV = $8F26;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV = $8F27;

This item has no description.

GL_FOG_COORD_ARRAY_ADDRESS_NV = $8F28;

This item has no description.

GL_ELEMENT_ARRAY_ADDRESS_NV = $8F29;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV = $8F2A;

This item has no description.

GL_VERTEX_ARRAY_LENGTH_NV = $8F2B;

This item has no description.

GL_NORMAL_ARRAY_LENGTH_NV = $8F2C;

This item has no description.

GL_COLOR_ARRAY_LENGTH_NV = $8F2D;

This item has no description.

GL_INDEX_ARRAY_LENGTH_NV = $8F2E;

This item has no description.

GL_TEXTURE_COORD_ARRAY_LENGTH_NV = $8F2F;

This item has no description.

GL_EDGE_FLAG_ARRAY_LENGTH_NV = $8F30;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV = $8F31;

This item has no description.

GL_FOG_COORD_ARRAY_LENGTH_NV = $8F32;

This item has no description.

GL_ELEMENT_ARRAY_LENGTH_NV = $8F33;

This item has no description.

GL_DRAW_INDIRECT_UNIFIED_NV = $8F40;

This item has no description.

GL_DRAW_INDIRECT_ADDRESS_NV = $8F41;

This item has no description.

GL_DRAW_INDIRECT_LENGTH_NV = $8F42;

This item has no description.

GL_MAX_GEOMETRY_PROGRAM_INVOCATIONS_NV = $8E5A;

GL_NV_gpu_program5

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET_NV = $8E5B;

This item has no description.

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET_NV = $8E5C;

This item has no description.

GL_FRAGMENT_PROGRAM_INTERPOLATION_OFFSET_BITS_NV = $8E5D;

This item has no description.

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_NV = $8E5E;

This item has no description.

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_NV = $8E5F;

This item has no description.

GL_MAX_PROGRAM_SUBROUTINE_PARAMETERS_NV = $8F44;

This item has no description.

GL_MAX_PROGRAM_SUBROUTINE_NUM_NV = $8F45;

This item has no description.

GL_INT64_NV = $140E;

GL_NV_gpu_shader5

GL_UNSIGNED_INT64_NV = $140F;

This item has no description.

GL_INT8_NV = $8FE0;

This item has no description.

GL_INT8_VEC2_NV = $8FE1;

This item has no description.

GL_INT8_VEC3_NV = $8FE2;

This item has no description.

GL_INT8_VEC4_NV = $8FE3;

This item has no description.

GL_INT16_NV = $8FE4;

This item has no description.

GL_INT16_VEC2_NV = $8FE5;

This item has no description.

GL_INT16_VEC3_NV = $8FE6;

This item has no description.

GL_INT16_VEC4_NV = $8FE7;

This item has no description.

GL_INT64_VEC2_NV = $8FE9;

This item has no description.

GL_INT64_VEC3_NV = $8FEA;

This item has no description.

GL_INT64_VEC4_NV = $8FEB;

This item has no description.

GL_UNSIGNED_INT8_NV = $8FEC;

This item has no description.

GL_UNSIGNED_INT8_VEC2_NV = $8FED;

This item has no description.

GL_UNSIGNED_INT8_VEC3_NV = $8FEE;

This item has no description.

GL_UNSIGNED_INT8_VEC4_NV = $8FEF;

This item has no description.

GL_UNSIGNED_INT16_NV = $8FF0;

This item has no description.

GL_UNSIGNED_INT16_VEC2_NV = $8FF1;

This item has no description.

GL_UNSIGNED_INT16_VEC3_NV = $8FF2;

This item has no description.

GL_UNSIGNED_INT16_VEC4_NV = $8FF3;

This item has no description.

GL_UNSIGNED_INT64_VEC2_NV = $8FF5;

This item has no description.

GL_UNSIGNED_INT64_VEC3_NV = $8FF6;

This item has no description.

GL_UNSIGNED_INT64_VEC4_NV = $8FF7;

This item has no description.

GL_FLOAT16_NV = $8FF8;

This item has no description.

GL_FLOAT16_VEC2_NV = $8FF9;

This item has no description.

GL_FLOAT16_VEC3_NV = $8FFA;

This item has no description.

GL_FLOAT16_VEC4_NV = $8FFB;

This item has no description.

GL_SHADER_GLOBAL_ACCESS_BARRIER_BIT_NV = $00000010;

GL_NV_shader_buffer_store

GL_MAX_PROGRAM_PATCH_ATTRIBS_NV = $86D8;

GL_NV_tessellation_program5

GL_TESS_CONTROL_PROGRAM_NV = $891E;

This item has no description.

GL_TESS_EVALUATION_PROGRAM_NV = $891F;

This item has no description.

GL_TESS_CONTROL_PROGRAM_PARAMETER_BUFFER_NV = $8C74;

This item has no description.

GL_TESS_EVALUATION_PROGRAM_PARAMETER_BUFFER_NV = $8C75;

This item has no description.

GL_COVERAGE_SAMPLES_NV = $80A9;

GL_NV_multisample_coverage

GL_COLOR_SAMPLES_NV = $8E20;

This item has no description.

GL_SURFACE_STATE_NV = $86EB;

GL_NV_vdpau_interop

GL_SURFACE_REGISTERED_NV = $86FD;

This item has no description.

GL_SURFACE_MAPPED_NV = $8700;

This item has no description.

GL_WRITE_DISCARD_NV = $88BE;

This item has no description.

GL_INTERLACE_OML = $8980;

GL_OML_interlace

GL_INTERLACE_READ_OML = $8981;

This item has no description.

GL_PACK_RESAMPLE_OML = $8984;

GL_OML_resample

GL_UNPACK_RESAMPLE_OML = $8985;

This item has no description.

GL_RESAMPLE_REPLICATE_OML = $8986;

This item has no description.

GL_RESAMPLE_ZERO_FILL_OML = $8987;

This item has no description.

GL_RESAMPLE_AVERAGE_OML = $8988;

This item has no description.

GL_RESAMPLE_DECIMATE_OML = $8989;

This item has no description.

GL_FORMAT_SUBSAMPLE_24_24_OML = $8982;

GL_OML_subsample

GL_FORMAT_SUBSAMPLE_244_244_OML = $8983;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_NUM_VIEWS_OVR = $9630;

GL_OVR_multiview

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_BASE_VIEW_INDEX_OVR = $9632;

This item has no description.

GL_MAX_VIEWS_OVR = $9631;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_VIEW_TARGETS_OVR = $9633;

This item has no description.

GL_PREFER_DOUBLEBUFFER_HINT_PGI = $1A1F8;

GL_PGI_misc_hints

GL_CONSERVE_MEMORY_HINT_PGI = $1A1FD;

This item has no description.

GL_RECLAIM_MEMORY_HINT_PGI = $1A1FE;

This item has no description.

GL_NATIVE_GRAPHICS_HANDLE_PGI = $1A202;

This item has no description.

GL_NATIVE_GRAPHICS_BEGIN_HINT_PGI = $1A203;

This item has no description.

GL_NATIVE_GRAPHICS_END_HINT_PGI = $1A204;

This item has no description.

GL_ALWAYS_FAST_HINT_PGI = $1A20C;

This item has no description.

GL_ALWAYS_SOFT_HINT_PGI = $1A20D;

This item has no description.

GL_ALLOW_DRAW_OBJ_HINT_PGI = $1A20E;

This item has no description.

GL_ALLOW_DRAW_WIN_HINT_PGI = $1A20F;

This item has no description.

GL_ALLOW_DRAW_FRG_HINT_PGI = $1A210;

This item has no description.

GL_ALLOW_DRAW_MEM_HINT_PGI = $1A211;

This item has no description.

GL_STRICT_DEPTHFUNC_HINT_PGI = $1A216;

This item has no description.

GL_STRICT_LIGHTING_HINT_PGI = $1A217;

This item has no description.

GL_STRICT_SCISSOR_HINT_PGI = $1A218;

This item has no description.

GL_FULL_STIPPLE_HINT_PGI = $1A219;

This item has no description.

GL_CLIP_NEAR_HINT_PGI = $1A220;

This item has no description.

GL_CLIP_FAR_HINT_PGI = $1A221;

This item has no description.

GL_WIDE_LINE_HINT_PGI = $1A222;

This item has no description.

GL_BACK_NORMALS_HINT_PGI = $1A223;

This item has no description.

GL_VERTEX_DATA_HINT_PGI = $1A22A;

GL_PGI_vertex_hints

GL_VERTEX_CONSISTENT_HINT_PGI = $1A22B;

This item has no description.

GL_MATERIAL_SIDE_HINT_PGI = $1A22C;

This item has no description.

GL_MAX_VERTEX_HINT_PGI = $1A22D;

This item has no description.

GL_COLOR3_BIT_PGI = $00010000;

This item has no description.

GL_COLOR4_BIT_PGI = $00020000;

This item has no description.

GL_EDGEFLAG_BIT_PGI = $00040000;

This item has no description.

GL_INDEX_BIT_PGI = $00080000;

This item has no description.

GL_MAT_AMBIENT_BIT_PGI = $00100000;

This item has no description.

GL_MAT_AMBIENT_AND_DIFFUSE_BIT_PGI = $00200000;

This item has no description.

GL_MAT_DIFFUSE_BIT_PGI = $00400000;

This item has no description.

GL_MAT_EMISSION_BIT_PGI = $00800000;

This item has no description.

GL_MAT_COLOR_INDEXES_BIT_PGI = $01000000;

This item has no description.

GL_MAT_SHININESS_BIT_PGI = $02000000;

This item has no description.

GL_MAT_SPECULAR_BIT_PGI = $04000000;

This item has no description.

GL_NORMAL_BIT_PGI = $08000000;

This item has no description.

GL_TEXCOORD1_BIT_PGI = $10000000;

This item has no description.

GL_TEXCOORD2_BIT_PGI = $20000000;

This item has no description.

GL_TEXCOORD3_BIT_PGI = $40000000;

This item has no description.

GL_TEXCOORD4_BIT_PGI = $80000000;

This item has no description.

GL_VERTEX23_BIT_PGI = $00000004;

This item has no description.

GL_VERTEX4_BIT_PGI = $00000008;

This item has no description.

GL_SCREEN_COORDINATES_REND = $8490;

GL_REND_screen_coordinates

GL_INVERTED_SCREEN_W_REND = $8491;

This item has no description.

GL_RGB_S3TC = $83A0;

GL_S3_s3tc

GL_RGB4_S3TC = $83A1;

This item has no description.

GL_RGBA_S3TC = $83A2;

This item has no description.

GL_RGBA4_S3TC = $83A3;

This item has no description.

GL_DETAIL_TEXTURE_2D_SGIS = $8095;

GL_SGIS_detail_texture

GL_DETAIL_TEXTURE_2D_BINDING_SGIS = $8096;

This item has no description.

GL_LINEAR_DETAIL_SGIS = $8097;

This item has no description.

GL_LINEAR_DETAIL_ALPHA_SGIS = $8098;

This item has no description.

GL_LINEAR_DETAIL_COLOR_SGIS = $8099;

This item has no description.

GL_DETAIL_TEXTURE_LEVEL_SGIS = $809A;

This item has no description.

GL_DETAIL_TEXTURE_MODE_SGIS = $809B;

This item has no description.

GL_DETAIL_TEXTURE_FUNC_POINTS_SGIS = $809C;

This item has no description.

GL_FOG_FUNC_SGIS = $812A;

GL_SGIS_fog_function

GL_FOG_FUNC_POINTS_SGIS = $812B;

This item has no description.

GL_MAX_FOG_FUNC_POINTS_SGIS = $812C;

This item has no description.

GL_GENERATE_MIPMAP_SGIS = $8191;

GL_SGIS_generate_mipmap

GL_GENERATE_MIPMAP_HINT_SGIS = $8192;

This item has no description.

GL_MULTISAMPLE_SGIS = $809D;

GL_SGIS_multisample

GL_SAMPLE_ALPHA_TO_MASK_SGIS = $809E;

This item has no description.

GL_SAMPLE_ALPHA_TO_ONE_SGIS = $809F;

This item has no description.

GL_SAMPLE_MASK_SGIS = $80A0;

This item has no description.

GL_1PASS_SGIS = $80A1;

This item has no description.

GL_2PASS_0_SGIS = $80A2;

This item has no description.

GL_2PASS_1_SGIS = $80A3;

This item has no description.

GL_4PASS_0_SGIS = $80A4;

This item has no description.

GL_4PASS_1_SGIS = $80A5;

This item has no description.

GL_4PASS_2_SGIS = $80A6;

This item has no description.

GL_4PASS_3_SGIS = $80A7;

This item has no description.

GL_SAMPLE_BUFFERS_SGIS = $80A8;

This item has no description.

GL_SAMPLES_SGIS = $80A9;

This item has no description.

GL_SAMPLE_MASK_VALUE_SGIS = $80AA;

This item has no description.

GL_SAMPLE_MASK_INVERT_SGIS = $80AB;

This item has no description.

GL_SAMPLE_PATTERN_SGIS = $80AC;

This item has no description.

GL_PIXEL_TEXTURE_SGIS = $8353;

GL_SGIS_pixel_texture

GL_PIXEL_FRAGMENT_RGB_SOURCE_SGIS = $8354;

This item has no description.

GL_PIXEL_FRAGMENT_ALPHA_SOURCE_SGIS = $8355;

This item has no description.

GL_PIXEL_GROUP_COLOR_SGIS = $8356;

This item has no description.

GL_EYE_DISTANCE_TO_POINT_SGIS = $81F0;

GL_SGIS_point_line_texgen

GL_OBJECT_DISTANCE_TO_POINT_SGIS = $81F1;

This item has no description.

GL_EYE_DISTANCE_TO_LINE_SGIS = $81F2;

This item has no description.

GL_OBJECT_DISTANCE_TO_LINE_SGIS = $81F3;

This item has no description.

GL_EYE_POINT_SGIS = $81F4;

This item has no description.

GL_OBJECT_POINT_SGIS = $81F5;

This item has no description.

GL_EYE_LINE_SGIS = $81F6;

This item has no description.

GL_OBJECT_LINE_SGIS = $81F7;

This item has no description.

GL_POINT_SIZE_MIN_SGIS = $8126;

GL_SGIS_point_parameters

GL_POINT_SIZE_MAX_SGIS = $8127;

This item has no description.

GL_POINT_FADE_THRESHOLD_SIZE_SGIS = $8128;

This item has no description.

GL_DISTANCE_ATTENUATION_SGIS = $8129;

This item has no description.

GL_LINEAR_SHARPEN_SGIS = $80AD;

GL_SGIS_sharpen_texture

GL_LINEAR_SHARPEN_ALPHA_SGIS = $80AE;

This item has no description.

GL_LINEAR_SHARPEN_COLOR_SGIS = $80AF;

This item has no description.

GL_SHARPEN_TEXTURE_FUNC_POINTS_SGIS = $80B0;

This item has no description.

GL_PACK_SKIP_VOLUMES_SGIS = $8130;

GL_SGIS_texture4D

GL_PACK_IMAGE_DEPTH_SGIS = $8131;

This item has no description.

GL_UNPACK_SKIP_VOLUMES_SGIS = $8132;

This item has no description.

GL_UNPACK_IMAGE_DEPTH_SGIS = $8133;

This item has no description.

GL_TEXTURE_4D_SGIS = $8134;

This item has no description.

GL_PROXY_TEXTURE_4D_SGIS = $8135;

This item has no description.

GL_TEXTURE_4DSIZE_SGIS = $8136;

This item has no description.

GL_TEXTURE_WRAP_Q_SGIS = $8137;

This item has no description.

GL_MAX_4D_TEXTURE_SIZE_SGIS = $8138;

This item has no description.

GL_TEXTURE_4D_BINDING_SGIS = $814F;

This item has no description.

GL_TEXTURE_COLOR_WRITEMASK_SGIS = $81EF;

GL_SGIS_texture_color_mask

GL_CLAMP_TO_EDGE_SGIS = $812F;

GL_SGIS_texture_edge_clamp

GL_FILTER4_SGIS = $8146;

GL_SGIS_texture_filter4

GL_TEXTURE_FILTER4_SIZE_SGIS = $8147;

This item has no description.

GL_TEXTURE_MIN_LOD_SGIS = $813A;

GL_SGIS_texture_lod

GL_TEXTURE_MAX_LOD_SGIS = $813B;

This item has no description.

GL_TEXTURE_BASE_LEVEL_SGIS = $813C;

This item has no description.

GL_TEXTURE_MAX_LEVEL_SGIS = $813D;

This item has no description.

GL_DUAL_ALPHA4_SGIS = $8110;

GL_SGIS_texture_select

GL_DUAL_ALPHA8_SGIS = $8111;

This item has no description.

GL_DUAL_ALPHA12_SGIS = $8112;

This item has no description.

GL_DUAL_ALPHA16_SGIS = $8113;

This item has no description.

GL_DUAL_LUMINANCE4_SGIS = $8114;

This item has no description.

GL_DUAL_LUMINANCE8_SGIS = $8115;

This item has no description.

GL_DUAL_LUMINANCE12_SGIS = $8116;

This item has no description.

GL_DUAL_LUMINANCE16_SGIS = $8117;

This item has no description.

GL_DUAL_INTENSITY4_SGIS = $8118;

This item has no description.

GL_DUAL_INTENSITY8_SGIS = $8119;

This item has no description.

GL_DUAL_INTENSITY12_SGIS = $811A;

This item has no description.

GL_DUAL_INTENSITY16_SGIS = $811B;

This item has no description.

GL_DUAL_LUMINANCE_ALPHA4_SGIS = $811C;

This item has no description.

GL_DUAL_LUMINANCE_ALPHA8_SGIS = $811D;

This item has no description.

GL_QUAD_ALPHA4_SGIS = $811E;

This item has no description.

GL_QUAD_ALPHA8_SGIS = $811F;

This item has no description.

GL_QUAD_LUMINANCE4_SGIS = $8120;

This item has no description.

GL_QUAD_LUMINANCE8_SGIS = $8121;

This item has no description.

GL_QUAD_INTENSITY4_SGIS = $8122;

This item has no description.

GL_QUAD_INTENSITY8_SGIS = $8123;

This item has no description.

GL_DUAL_TEXTURE_SELECT_SGIS = $8124;

This item has no description.

GL_QUAD_TEXTURE_SELECT_SGIS = $8125;

This item has no description.

GL_ASYNC_MARKER_SGIX = $8329;

GL_SGIX_async

GL_ASYNC_HISTOGRAM_SGIX = $832C;

GL_SGIX_async_histogram

GL_MAX_ASYNC_HISTOGRAM_SGIX = $832D;

This item has no description.

GL_ASYNC_TEX_IMAGE_SGIX = $835C;

GL_SGIX_async_pixel

GL_ASYNC_DRAW_PIXELS_SGIX = $835D;

This item has no description.

GL_ASYNC_READ_PIXELS_SGIX = $835E;

This item has no description.

GL_MAX_ASYNC_TEX_IMAGE_SGIX = $835F;

This item has no description.

GL_MAX_ASYNC_DRAW_PIXELS_SGIX = $8360;

This item has no description.

GL_MAX_ASYNC_READ_PIXELS_SGIX = $8361;

This item has no description.

GL_ALPHA_MIN_SGIX = $8320;

GL_SGIX_blend_alpha_minmax

GL_ALPHA_MAX_SGIX = $8321;

This item has no description.

GL_CALLIGRAPHIC_FRAGMENT_SGIX = $8183;

GL_SGIX_calligraphic_fragment

GL_LINEAR_CLIPMAP_LINEAR_SGIX = $8170;

GL_SGIX_clipmap

GL_TEXTURE_CLIPMAP_CENTER_SGIX = $8171;

This item has no description.

GL_TEXTURE_CLIPMAP_FRAME_SGIX = $8172;

This item has no description.

GL_TEXTURE_CLIPMAP_OFFSET_SGIX = $8173;

This item has no description.

GL_TEXTURE_CLIPMAP_VIRTUAL_DEPTH_SGIX = $8174;

This item has no description.

GL_TEXTURE_CLIPMAP_LOD_OFFSET_SGIX = $8175;

This item has no description.

GL_TEXTURE_CLIPMAP_DEPTH_SGIX = $8176;

This item has no description.

GL_MAX_CLIPMAP_DEPTH_SGIX = $8177;

This item has no description.

GL_MAX_CLIPMAP_VIRTUAL_DEPTH_SGIX = $8178;

This item has no description.

GL_NEAREST_CLIPMAP_NEAREST_SGIX = $844D;

This item has no description.

GL_NEAREST_CLIPMAP_LINEAR_SGIX = $844E;

This item has no description.

GL_LINEAR_CLIPMAP_NEAREST_SGIX = $844F;

This item has no description.

GL_CONVOLUTION_HINT_SGIX = $8316;

GL_SGIX_convolution_accuracy

GL_DEPTH_COMPONENT16_SGIX = $81A5;

GL_SGIX_depth_texture

GL_DEPTH_COMPONENT24_SGIX = $81A6;

This item has no description.

GL_DEPTH_COMPONENT32_SGIX = $81A7;

This item has no description.

GL_FOG_OFFSET_SGIX = $8198;

GL_SGIX_fog_offset

GL_FOG_OFFSET_VALUE_SGIX = $8199;

This item has no description.

GL_FOG_SCALE_SGIX = $81FC;

GL_SGIX_fog_scale

GL_FOG_SCALE_VALUE_SGIX = $81FD;

This item has no description.

GL_FRAGMENT_LIGHTING_SGIX = $8400;

GL_SGIX_fragment_lighting

GL_FRAGMENT_COLOR_MATERIAL_SGIX = $8401;

This item has no description.

GL_FRAGMENT_COLOR_MATERIAL_FACE_SGIX = $8402;

This item has no description.

GL_FRAGMENT_COLOR_MATERIAL_PARAMETER_SGIX = $8403;

This item has no description.

GL_MAX_FRAGMENT_LIGHTS_SGIX = $8404;

This item has no description.

GL_MAX_ACTIVE_LIGHTS_SGIX = $8405;

This item has no description.

GL_CURRENT_RASTER_NORMAL_SGIX = $8406;

This item has no description.

GL_LIGHT_ENV_MODE_SGIX = $8407;

This item has no description.

GL_FRAGMENT_LIGHT_MODEL_LOCAL_VIEWER_SGIX = $8408;

This item has no description.

GL_FRAGMENT_LIGHT_MODEL_TWO_SIDE_SGIX = $8409;

This item has no description.

GL_FRAGMENT_LIGHT_MODEL_AMBIENT_SGIX = $840A;

This item has no description.

GL_FRAGMENT_LIGHT_MODEL_NORMAL_INTERPOLATION_SGIX = $840B;

This item has no description.

GL_FRAGMENT_LIGHT0_SGIX = $840C;

This item has no description.

GL_FRAGMENT_LIGHT1_SGIX = $840D;

This item has no description.

GL_FRAGMENT_LIGHT2_SGIX = $840E;

This item has no description.

GL_FRAGMENT_LIGHT3_SGIX = $840F;

This item has no description.

GL_FRAGMENT_LIGHT4_SGIX = $8410;

This item has no description.

GL_FRAGMENT_LIGHT5_SGIX = $8411;

This item has no description.

GL_FRAGMENT_LIGHT6_SGIX = $8412;

This item has no description.

GL_FRAGMENT_LIGHT7_SGIX = $8413;

This item has no description.

GL_FRAMEZOOM_SGIX = $818B;

GL_SGIX_framezoom

GL_FRAMEZOOM_FACTOR_SGIX = $818C;

This item has no description.

GL_MAX_FRAMEZOOM_FACTOR_SGIX = $818D;

This item has no description.

GL_PIXEL_TEX_GEN_Q_CEILING_SGIX = $8184;

GL_SGIX_impact_pixel_texture

GL_PIXEL_TEX_GEN_Q_ROUND_SGIX = $8185;

This item has no description.

GL_PIXEL_TEX_GEN_Q_FLOOR_SGIX = $8186;

This item has no description.

GL_PIXEL_TEX_GEN_ALPHA_REPLACE_SGIX = $8187;

This item has no description.

GL_PIXEL_TEX_GEN_ALPHA_NO_REPLACE_SGIX = $8188;

This item has no description.

GL_PIXEL_TEX_GEN_ALPHA_LS_SGIX = $8189;

This item has no description.

GL_PIXEL_TEX_GEN_ALPHA_MS_SGIX = $818A;

This item has no description.

GL_INSTRUMENT_BUFFER_POINTER_SGIX = $8180;

GL_SGIX_instruments

GL_INSTRUMENT_MEASUREMENTS_SGIX = $8181;

This item has no description.

GL_INTERLACE_SGIX = $8094;

GL_SGIX_interlace

GL_IR_INSTRUMENT1_SGIX = $817F;

GL_SGIX_ir_instrument1

GL_LIST_PRIORITY_SGIX = $8182;

GL_SGIX_list_priority

GL_PIXEL_TEX_GEN_SGIX = $8139;

GL_SGIX_pixel_texture

GL_PIXEL_TEX_GEN_MODE_SGIX = $832B;

This item has no description.

GL_PIXEL_TILE_BEST_ALIGNMENT_SGIX = $813E;

GL_SGIX_pixel_tiles

GL_PIXEL_TILE_CACHE_INCREMENT_SGIX = $813F;

This item has no description.

GL_PIXEL_TILE_WIDTH_SGIX = $8140;

This item has no description.

GL_PIXEL_TILE_HEIGHT_SGIX = $8141;

This item has no description.

GL_PIXEL_TILE_GRID_WIDTH_SGIX = $8142;

This item has no description.

GL_PIXEL_TILE_GRID_HEIGHT_SGIX = $8143;

This item has no description.

GL_PIXEL_TILE_GRID_DEPTH_SGIX = $8144;

This item has no description.

GL_PIXEL_TILE_CACHE_SIZE_SGIX = $8145;

This item has no description.

GL_GEOMETRY_DEFORMATION_SGIX = $8194;

GL_SGIX_polynomial_ffd

GL_TEXTURE_DEFORMATION_SGIX = $8195;

This item has no description.

GL_DEFORMATIONS_MASK_SGIX = $8196;

This item has no description.

GL_MAX_DEFORMATION_ORDER_SGIX = $8197;

This item has no description.

GL_REFERENCE_PLANE_SGIX = $817D;

GL_SGIX_reference_plane

GL_REFERENCE_PLANE_EQUATION_SGIX = $817E;

This item has no description.

GL_PACK_RESAMPLE_SGIX = $842C;

GL_SGIX_resample

GL_UNPACK_RESAMPLE_SGIX = $842D;

This item has no description.

GL_RESAMPLE_REPLICATE_SGIX = $842E;

This item has no description.

GL_RESAMPLE_ZERO_FILL_SGIX = $842F;

This item has no description.

GL_RESAMPLE_DECIMATE_SGIX = $8430;

This item has no description.

GL_SCALEBIAS_HINT_SGIX = $8322;

GL_SGIX_scalebias_hint

GL_TEXTURE_COMPARE_SGIX = $819A;

GL_SGIX_shadow

GL_TEXTURE_COMPARE_OPERATOR_SGIX = $819B;

This item has no description.

GL_TEXTURE_LEQUAL_R_SGIX = $819C;

This item has no description.

GL_TEXTURE_GEQUAL_R_SGIX = $819D;

This item has no description.

GL_SHADOW_AMBIENT_SGIX = $80BF;

GL_SGIX_shadow_ambient

GL_SPRITE_SGIX = $8148;

GL_SGIX_sprite

GL_SPRITE_MODE_SGIX = $8149;

This item has no description.

GL_SPRITE_AXIS_SGIX = $814A;

This item has no description.

GL_SPRITE_TRANSLATION_SGIX = $814B;

This item has no description.

GL_SPRITE_AXIAL_SGIX = $814C;

This item has no description.

GL_SPRITE_OBJECT_ALIGNED_SGIX = $814D;

This item has no description.

GL_SPRITE_EYE_ALIGNED_SGIX = $814E;

This item has no description.

GL_PACK_SUBSAMPLE_RATE_SGIX = $85A0;

GL_SGIX_subsample

GL_UNPACK_SUBSAMPLE_RATE_SGIX = $85A1;

This item has no description.

GL_PIXEL_SUBSAMPLE_4444_SGIX = $85A2;

This item has no description.

GL_PIXEL_SUBSAMPLE_2424_SGIX = $85A3;

This item has no description.

GL_PIXEL_SUBSAMPLE_4242_SGIX = $85A4;

This item has no description.

GL_TEXTURE_ENV_BIAS_SGIX = $80BE;

GL_SGIX_texture_add_env

GL_TEXTURE_MAX_CLAMP_S_SGIX = $8369;

GL_SGIX_texture_coordinate_clamp

GL_TEXTURE_MAX_CLAMP_T_SGIX = $836A;

This item has no description.

GL_TEXTURE_MAX_CLAMP_R_SGIX = $836B;

This item has no description.

GL_TEXTURE_LOD_BIAS_S_SGIX = $818E;

GL_SGIX_texture_lod_bias

GL_TEXTURE_LOD_BIAS_T_SGIX = $818F;

This item has no description.

GL_TEXTURE_LOD_BIAS_R_SGIX = $8190;

This item has no description.

GL_TEXTURE_MULTI_BUFFER_HINT_SGIX = $812E;

GL_SGIX_texture_multi_buffer

GL_POST_TEXTURE_FILTER_BIAS_SGIX = $8179;

GL_SGIX_texture_scale_bias

GL_POST_TEXTURE_FILTER_SCALE_SGIX = $817A;

This item has no description.

GL_POST_TEXTURE_FILTER_BIAS_RANGE_SGIX = $817B;

This item has no description.

GL_POST_TEXTURE_FILTER_SCALE_RANGE_SGIX = $817C;

This item has no description.

GL_VERTEX_PRECLIP_SGIX = $83EE;

GL_SGIX_vertex_preclip

GL_VERTEX_PRECLIP_HINT_SGIX = $83EF;

This item has no description.

GL_YCRCB_422_SGIX = $81BB;

GL_SGIX_ycrcb

GL_YCRCB_444_SGIX = $81BC;

This item has no description.

GL_YCRCB_SGIX = $8318;

GL_SGIX_ycrcba

GL_YCRCBA_SGIX = $8319;

This item has no description.

GL_COLOR_MATRIX_SGI = $80B1;

GL_SGI_color_matrix

GL_COLOR_MATRIX_STACK_DEPTH_SGI = $80B2;

This item has no description.

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI = $80B3;

This item has no description.

GL_POST_COLOR_MATRIX_RED_SCALE_SGI = $80B4;

This item has no description.

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI = $80B5;

This item has no description.

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI = $80B6;

This item has no description.

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI = $80B7;

This item has no description.

GL_POST_COLOR_MATRIX_RED_BIAS_SGI = $80B8;

This item has no description.

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI = $80B9;

This item has no description.

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI = $80BA;

This item has no description.

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI = $80BB;

This item has no description.

GL_COLOR_TABLE_SGI = $80D0;

GL_SGI_color_table

GL_POST_CONVOLUTION_COLOR_TABLE_SGI = $80D1;

This item has no description.

GL_POST_COLOR_MATRIX_COLOR_TABLE_SGI = $80D2;

This item has no description.

GL_PROXY_COLOR_TABLE_SGI = $80D3;

This item has no description.

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE_SGI = $80D4;

This item has no description.

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE_SGI = $80D5;

This item has no description.

GL_COLOR_TABLE_SCALE_SGI = $80D6;

This item has no description.

GL_COLOR_TABLE_BIAS_SGI = $80D7;

This item has no description.

GL_COLOR_TABLE_FORMAT_SGI = $80D8;

This item has no description.

GL_COLOR_TABLE_WIDTH_SGI = $80D9;

This item has no description.

GL_COLOR_TABLE_RED_SIZE_SGI = $80DA;

This item has no description.

GL_COLOR_TABLE_GREEN_SIZE_SGI = $80DB;

This item has no description.

GL_COLOR_TABLE_BLUE_SIZE_SGI = $80DC;

This item has no description.

GL_COLOR_TABLE_ALPHA_SIZE_SGI = $80DD;

This item has no description.

GL_COLOR_TABLE_LUMINANCE_SIZE_SGI = $80DE;

This item has no description.

GL_COLOR_TABLE_INTENSITY_SIZE_SGI = $80DF;

This item has no description.

GL_DEPTH_PASS_INSTRUMENT_SGIX = $8310;

GL_SGI_depth_pass_instrument

GL_DEPTH_PASS_INSTRUMENT_COUNTERS_SGIX = $8311;

This item has no description.

GL_DEPTH_PASS_INSTRUMENT_MAX_SGIX = $8312;

This item has no description.

GL_TEXTURE_COLOR_TABLE_SGI = $80BC;

GL_SGI_texture_color_table

GL_PROXY_TEXTURE_COLOR_TABLE_SGI = $80BD;

This item has no description.

GL_UNPACK_CONSTANT_DATA_SUNX = $81D5;

GL_SUNX_constant_data

GL_TEXTURE_CONSTANT_DATA_SUNX = $81D6;

This item has no description.

GL_WRAP_BORDER_SUN = $81D4;

GL_SUN_convolution_border_modes

GL_GLOBAL_ALPHA_SUN = $81D9;

GL_SUN_global_alpha

GL_GLOBAL_ALPHA_FACTOR_SUN = $81DA;

This item has no description.

GL_QUAD_MESH_SUN = $8614;

GL_SUN_mesh_array

GL_TRIANGLE_MESH_SUN = $8615;

This item has no description.

GL_SLICE_ACCUM_SUN = $85CC;

GL_SUN_slice_accum

GL_RESTART_SUN = $0001;

GL_SUN_triangle_list

GL_REPLACE_MIDDLE_SUN = $0002;

This item has no description.

GL_REPLACE_OLDEST_SUN = $0003;

This item has no description.

GL_TRIANGLE_LIST_SUN = $81D7;

This item has no description.

GL_REPLACEMENT_CODE_SUN = $81D8;

This item has no description.

GL_REPLACEMENT_CODE_ARRAY_SUN = $85C0;

This item has no description.

GL_REPLACEMENT_CODE_ARRAY_TYPE_SUN = $85C1;

This item has no description.

GL_REPLACEMENT_CODE_ARRAY_STRIDE_SUN = $85C2;

This item has no description.

GL_REPLACEMENT_CODE_ARRAY_POINTER_SUN = $85C3;

This item has no description.

GL_R1UI_V3F_SUN = $85C4;

This item has no description.

GL_R1UI_C4UB_V3F_SUN = $85C5;

This item has no description.

GL_R1UI_C3F_V3F_SUN = $85C6;

This item has no description.

GL_R1UI_N3F_V3F_SUN = $85C7;

This item has no description.

GL_R1UI_C4F_N3F_V3F_SUN = $85C8;

This item has no description.

GL_R1UI_T2F_V3F_SUN = $85C9;

This item has no description.

GL_R1UI_T2F_N3F_V3F_SUN = $85CA;

This item has no description.

GL_R1UI_T2F_C4F_N3F_V3F_SUN = $85CB;

This item has no description.

GL_PHONG_WIN = $80EA;

GL_WIN_phong_shading

GL_PHONG_HINT_WIN = $80EB;

This item has no description.

GL_FOG_SPECULAR_TEXTURE_WIN = $80EC;

GL_WIN_specular_fog

GL_VERTEX_SHADER_ARB = $8B31;

GL_ARB_vertex_shader

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB = $8B4A;

This item has no description.

GL_MAX_VARYING_FLOATS_ARB = $8B4B;

This item has no description.

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

This item has no description.

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB = $8B4D;

This item has no description.

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB = $8B89;

This item has no description.

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB = $8B8A;

This item has no description.

GL_MULTIPLY_KHR = $9294;

GL_KHR_blend_equation_advanced

GL_SCREEN_KHR = $9295;

This item has no description.

GL_OVERLAY_KHR = $9296;

This item has no description.

GL_DARKEN_KHR = $9297;

This item has no description.

GL_LIGHTEN_KHR = $9298;

This item has no description.

GL_COLORDODGE_KHR = $9299;

This item has no description.

GL_COLORBURN_KHR = $929A;

This item has no description.

GL_HARDLIGHT_KHR = $929B;

This item has no description.

GL_SOFTLIGHT_KHR = $929C;

This item has no description.

GL_DIFFERENCE_KHR = $929E;

This item has no description.

GL_EXCLUSION_KHR = $92A0;

This item has no description.

GL_HSL_HUE_KHR = $92AD;

This item has no description.

GL_HSL_SATURATION_KHR = $92AE;

This item has no description.

GL_HSL_COLOR_KHR = $92AF;

This item has no description.

GL_HSL_LUMINOSITY_KHR = $92B0;

This item has no description.

GL_BLEND_ADVANCED_COHERENT_KHR = $9285;

GL_KHR_blend_equation_advanced_coherent

GL_CONTEXT_ROBUST_ACCESS = $90F3;

GL_KHR_robustness

GL_CONTEXT_FLAG_NO_ERROR_BIT_KHR = $00000008;

GL_KHR_no_error

GL_FRAGMENT_SHADER_ARB = $8B30;

GL_ARB_fragment_shader

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB = $8B49;

This item has no description.

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB = $8B8B;

1.4

GL_SAMPLES_PASSED_ARB = $8914;

1.4 GL_ARB_occlusion_query

GL_QUERY_COUNTER_BITS_ARB = $8864;

This item has no description.

GL_CURRENT_QUERY_ARB = $8865;

This item has no description.

GL_QUERY_RESULT_ARB = $8866;

This item has no description.

GL_QUERY_RESULT_AVAILABLE_ARB = $8867;

This item has no description.

GL_VERTICES_SUBMITTED_ARB = $82EE;

GL_ARB_pipeline_statistics_query

GL_PRIMITIVES_SUBMITTED_ARB = $82EF;

This item has no description.

GL_VERTEX_SHADER_INVOCATIONS_ARB = $82F0;

This item has no description.

GL_TESS_CONTROL_SHADER_PATCHES_ARB = $82F1;

This item has no description.

GL_TESS_EVALUATION_SHADER_INVOCATIONS_ARB = $82F2;

This item has no description.

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED_ARB = $82F3;

This item has no description.

GL_FRAGMENT_SHADER_INVOCATIONS_ARB = $82F4;

This item has no description.

GL_COMPUTE_SHADER_INVOCATIONS_ARB = $82F5;

This item has no description.

GL_CLIPPING_INPUT_PRIMITIVES_ARB = $82F6;

This item has no description.

GL_CLIPPING_OUTPUT_PRIMITIVES_ARB = $82F7;

This item has no description.

GL_POINT_SPRITE_ARB = $8861;

GL_ARB_point_sprite

GL_COORD_REPLACE_ARB = $8862;

This item has no description.

GL_SHADING_LANGUAGE_VERSION_ARB = $8B8C;

GL_ARB_shading_language_100

GL_PROGRAM_OBJECT_ARB = $8B40;

1.4 GL_ARB_shader_objects

GL_OBJECT_TYPE_ARB = $8B4E;

This item has no description.

GL_OBJECT_SUBTYPE_ARB = $8B4F;

This item has no description.

GL_OBJECT_DELETE_STATUS_ARB = $8B80;

This item has no description.

GL_OBJECT_COMPILE_STATUS_ARB = $8B81;

This item has no description.

GL_OBJECT_LINK_STATUS_ARB = $8B82;

This item has no description.

GL_OBJECT_VALIDATE_STATUS_ARB = $8B83;

This item has no description.

GL_OBJECT_INFO_LOG_LENGTH_ARB = $8B84;

This item has no description.

GL_OBJECT_ATTACHED_OBJECTS_ARB = $8B85;

This item has no description.

GL_OBJECT_ACTIVE_UNIFORMS_ARB = $8B86;

This item has no description.

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB = $8B87;

This item has no description.

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB = $8B88;

This item has no description.

GL_SHADER_OBJECT_ARB = $8B48;

This item has no description.

GL_FLOAT_VEC2_ARB = $8B50;

This item has no description.

GL_FLOAT_VEC3_ARB = $8B51;

This item has no description.

GL_FLOAT_VEC4_ARB = $8B52;

This item has no description.

GL_INT_VEC2_ARB = $8B53;

This item has no description.

GL_INT_VEC3_ARB = $8B54;

This item has no description.

GL_INT_VEC4_ARB = $8B55;

This item has no description.

GL_BOOL_ARB = $8B56;

This item has no description.

GL_BOOL_VEC2_ARB = $8B57;

This item has no description.

GL_BOOL_VEC3_ARB = $8B58;

This item has no description.

GL_BOOL_VEC4_ARB = $8B59;

This item has no description.

GL_FLOAT_MAT2_ARB = $8B5A;

This item has no description.

GL_FLOAT_MAT3_ARB = $8B5B;

This item has no description.

GL_FLOAT_MAT4_ARB = $8B5C;

This item has no description.

GL_SAMPLER_1D_ARB = $8B5D;

This item has no description.

GL_SAMPLER_2D_ARB = $8B5E;

This item has no description.

GL_SAMPLER_3D_ARB = $8B5F;

This item has no description.

GL_SAMPLER_CUBE_ARB = $8B60;

This item has no description.

GL_SAMPLER_1D_SHADOW_ARB = $8B61;

This item has no description.

GL_SAMPLER_2D_SHADOW_ARB = $8B62;

This item has no description.

GL_SAMPLER_2D_RECT_ARB = $8B63;

This item has no description.

GL_SAMPLER_2D_RECT_SHADOW_ARB = $8B64;

This item has no description.

WGL_SAMPLE_BUFFERS_3DFX = $2060;

WGL_3DFX_multisample

WGL_SAMPLES_3DFX = $2061;

This item has no description.

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;

WGL_ARB_buffer_region

WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;

This item has no description.

WGL_DEPTH_BUFFER_BIT_ARB = $00000004;

This item has no description.

WGL_STENCIL_BUFFER_BIT_ARB = $00000008;

This item has no description.

WGL_CONTEXT_RELEASE_BEHAVIOR_ARB = $2097;

WGL_ARB_context_flush_control

WGL_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB = 0;

This item has no description.

WGL_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB = $2098;

This item has no description.

ERROR_INVALID_PIXEL_TYPE_ARB = $2043;

WGL_ARB_make_current_read

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB = $2054;

This item has no description.

WGL_SAMPLE_BUFFERS_ARB = $2041;

WGL_ARB_multisample

WGL_SAMPLES_ARB = $2042;

This item has no description.

WGL_DRAW_TO_PBUFFER_ARB = $202D;

WGL_ARB_pbuffer

WGL_MAX_PBUFFER_PIXELS_ARB = $202E;

This item has no description.

WGL_MAX_PBUFFER_WIDTH_ARB = $202F;

This item has no description.

WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;

This item has no description.

WGL_PBUFFER_LARGEST_ARB = $2033;

This item has no description.

WGL_PBUFFER_WIDTH_ARB = $2034;

This item has no description.

WGL_PBUFFER_HEIGHT_ARB = $2035;

This item has no description.

WGL_PBUFFER_LOST_ARB = $2036;

This item has no description.

WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;

WGL_ARB_pixel_format

WGL_DRAW_TO_WINDOW_ARB = $2001;

This item has no description.

WGL_DRAW_TO_BITMAP_ARB = $2002;

This item has no description.

WGL_ACCELERATION_ARB = $2003;

This item has no description.

WGL_NEED_PALETTE_ARB = $2004;

This item has no description.

WGL_NEED_SYSTEM_PALETTE_ARB = $2005;

This item has no description.

WGL_SWAP_LAYER_BUFFERS_ARB = $2006;

This item has no description.

WGL_SWAP_METHOD_ARB = $2007;

This item has no description.

WGL_NUMBER_OVERLAYS_ARB = $2008;

This item has no description.

WGL_NUMBER_UNDERLAYS_ARB = $2009;

This item has no description.

WGL_TRANSPARENT_ARB = $200A;

This item has no description.

WGL_TRANSPARENT_RED_VALUE_ARB = $2037;

This item has no description.

WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;

This item has no description.

WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;

This item has no description.

WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;

This item has no description.

WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;

This item has no description.

WGL_SHARE_DEPTH_ARB = $200C;

This item has no description.

WGL_SHARE_STENCIL_ARB = $200D;

This item has no description.

WGL_SHARE_ACCUM_ARB = $200E;

This item has no description.

WGL_SUPPORT_GDI_ARB = $200F;

This item has no description.

WGL_SUPPORT_OPENGL_ARB = $2010;

This item has no description.

WGL_DOUBLE_BUFFER_ARB = $2011;

This item has no description.

WGL_STEREO_ARB = $2012;

This item has no description.

WGL_PIXEL_TYPE_ARB = $2013;

This item has no description.

WGL_COLOR_BITS_ARB = $2014;

This item has no description.

WGL_RED_BITS_ARB = $2015;

This item has no description.

WGL_RED_SHIFT_ARB = $2016;

This item has no description.

WGL_GREEN_BITS_ARB = $2017;

This item has no description.

WGL_GREEN_SHIFT_ARB = $2018;

This item has no description.

WGL_BLUE_BITS_ARB = $2019;

This item has no description.

WGL_BLUE_SHIFT_ARB = $201A;

This item has no description.

WGL_ALPHA_BITS_ARB = $201B;

This item has no description.

WGL_ALPHA_SHIFT_ARB = $201C;

This item has no description.

WGL_ACCUM_BITS_ARB = $201D;

This item has no description.

WGL_ACCUM_RED_BITS_ARB = $201E;

This item has no description.

WGL_ACCUM_GREEN_BITS_ARB = $201F;

This item has no description.

WGL_ACCUM_BLUE_BITS_ARB = $2020;

This item has no description.

WGL_ACCUM_ALPHA_BITS_ARB = $2021;

This item has no description.

WGL_DEPTH_BITS_ARB = $2022;

This item has no description.

WGL_STENCIL_BITS_ARB = $2023;

This item has no description.

WGL_AUX_BUFFERS_ARB = $2024;

This item has no description.

WGL_NO_ACCELERATION_ARB = $2025;

This item has no description.

WGL_GENERIC_ACCELERATION_ARB = $2026;

This item has no description.

WGL_FULL_ACCELERATION_ARB = $2027;

This item has no description.

WGL_SWAP_EXCHANGE_ARB = $2028;

This item has no description.

WGL_SWAP_COPY_ARB = $2029;

This item has no description.

WGL_SWAP_UNDEFINED_ARB = $202A;

This item has no description.

WGL_TYPE_RGBA_ARB = $202B;

This item has no description.

WGL_TYPE_COLORINDEX_ARB = $202C;

This item has no description.

WGL_RGBA_FLOAT_MODE_ARB = $8820;

WGL_ARB_pixel_format_float

WGL_CLAMP_VERTEX_COLOR_ARB = $891A;

This item has no description.

WGL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

This item has no description.

WGL_CLAMP_READ_COLOR_ARB = $891C;

This item has no description.

WGL_FIXED_ONLY_ARB = $891D;

This item has no description.

WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;

WGL_ARB_render_texture

WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;

This item has no description.

WGL_TEXTURE_FORMAT_ARB = $2072;

This item has no description.

WGL_TEXTURE_TARGET_ARB = $2073;

This item has no description.

WGL_MIPMAP_TEXTURE_ARB = $2074;

This item has no description.

WGL_TEXTURE_RGB_ARB = $2075;

This item has no description.

WGL_TEXTURE_RGBA_ARB = $2076;

This item has no description.

WGL_NO_TEXTURE_ARB = $2077;

This item has no description.

WGL_TEXTURE_CUBE_MAP_ARB = $2078;

This item has no description.

WGL_TEXTURE_1D_ARB = $2079;

This item has no description.

WGL_TEXTURE_2D_ARB = $207A;

This item has no description.

WGL_MIPMAP_LEVEL_ARB = $207B;

This item has no description.

WGL_CUBE_MAP_FACE_ARB = $207C;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;

This item has no description.

WGL_FRONT_LEFT_ARB = $2083;

This item has no description.

WGL_FRONT_RIGHT_ARB = $2084;

This item has no description.

WGL_BACK_LEFT_ARB = $2085;

This item has no description.

WGL_BACK_RIGHT_ARB = $2086;

This item has no description.

WGL_AUX0_ARB = $2087;

This item has no description.

WGL_AUX1_ARB = $2088;

This item has no description.

WGL_AUX2_ARB = $2089;

This item has no description.

WGL_AUX3_ARB = $208A;

This item has no description.

WGL_AUX4_ARB = $208B;

This item has no description.

WGL_AUX5_ARB = $208C;

This item has no description.

WGL_AUX6_ARB = $208D;

This item has no description.

WGL_AUX7_ARB = $208E;

This item has no description.

WGL_AUX8_ARB = $208F;

This item has no description.

WGL_AUX9_ARB = $2090;

This item has no description.

WGL_CONTEXT_RESET_ISOLATION_BIT_ARB = $00000008;

WGL_ARB_robustness_application_isolation

WGL_CONTEXT_DEBUG_BIT_ARB = $00000001;

WGL_ARB_create_context

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

This item has no description.

WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;

This item has no description.

WGL_CONTEXT_MINOR_VERSION_ARB = $2092;

This item has no description.

WGL_CONTEXT_LAYER_PLANE_ARB = $2093;

This item has no description.

WGL_CONTEXT_FLAGS_ARB = $2094;

This item has no description.

ERROR_INVALID_VERSION_ARB = $2095;

This item has no description.

WGL_CONTEXT_PROFILE_MASK_ARB = $9126;

WGL_ARB_create_context_profile

WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

This item has no description.

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

This item has no description.

ERROR_INVALID_PROFILE_ARB = $2096;

This item has no description.

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;

WGL_ARB_framebuffer_sRGB

WGL_CONTEXT_ROBUST_ACCESS_BIT_ARB = $00000004;

WGL_ARB_create_context_robustness

WGL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

This item has no description.

WGL_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

This item has no description.

WGL_NO_RESET_NOTIFICATION_ARB = $8261;

This item has no description.

WGL_TYPE_RGBA_FLOAT_ATI = $21A0;

WGL_ATI_pixel_format_float

GL_TYPE_RGBA_FLOAT_ATI = $8820;

This item has no description.

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI = $8835;

This item has no description.

WGL_GPU_VENDOR_AMD = $1F00;

WGL_AMD_gpu_association

WGL_GPU_RENDERER_STRING_AMD = $1F01;

This item has no description.

WGL_GPU_OPENGL_VERSION_STRING_AMD = $1F02;

This item has no description.

WGL_GPU_FASTEST_TARGET_GPUS_AMD = $21A2;

This item has no description.

WGL_GPU_RAM_AMD = $21A3;

This item has no description.

WGL_GPU_CLOCK_AMD = $21A4;

This item has no description.

WGL_GPU_NUM_PIPES_AMD = $21A5;

This item has no description.

WGL_GPU_NUM_SIMD_AMD = $21A6;

This item has no description.

WGL_GPU_NUM_RB_AMD = $21A7;

This item has no description.

WGL_GPU_NUM_SPI_AMD = $21A8;

This item has no description.

WGL_DEPTH_FLOAT_EXT = $2040;

WGL_EXT_depth_float

ERROR_INVALID_PIXEL_TYPE_EXT = $2043;

WGL_EXT_make_current_read

WGL_SAMPLE_BUFFERS_EXT = $2041;

WGL_EXT_multisample

WGL_SAMPLES_EXT = $2042;

This item has no description.

WGL_DRAW_TO_PBUFFER_EXT = $202D;

WGL_EXT_pbuffer

WGL_MAX_PBUFFER_PIXELS_EXT = $202E;

This item has no description.

WGL_MAX_PBUFFER_WIDTH_EXT = $202F;

This item has no description.

WGL_MAX_PBUFFER_HEIGHT_EXT = $2030;

This item has no description.

WGL_OPTIMAL_PBUFFER_WIDTH_EXT = $2031;

This item has no description.

WGL_OPTIMAL_PBUFFER_HEIGHT_EXT = $2032;

This item has no description.

WGL_PBUFFER_LARGEST_EXT = $2033;

This item has no description.

WGL_PBUFFER_WIDTH_EXT = $2034;

This item has no description.

WGL_PBUFFER_HEIGHT_EXT = $2035;

This item has no description.

WGL_NUMBER_PIXEL_FORMATS_EXT = $2000;

WGL_EXT_pixel_format

WGL_DRAW_TO_WINDOW_EXT = $2001;

This item has no description.

WGL_DRAW_TO_BITMAP_EXT = $2002;

This item has no description.

WGL_ACCELERATION_EXT = $2003;

This item has no description.

WGL_NEED_PALETTE_EXT = $2004;

This item has no description.

WGL_NEED_SYSTEM_PALETTE_EXT = $2005;

This item has no description.

WGL_SWAP_LAYER_BUFFERS_EXT = $2006;

This item has no description.

WGL_SWAP_METHOD_EXT = $2007;

This item has no description.

WGL_NUMBER_OVERLAYS_EXT = $2008;

This item has no description.

WGL_NUMBER_UNDERLAYS_EXT = $2009;

This item has no description.

WGL_TRANSPARENT_EXT = $200A;

This item has no description.

WGL_TRANSPARENT_VALUE_EXT = $200B;

This item has no description.

WGL_SHARE_DEPTH_EXT = $200C;

This item has no description.

WGL_SHARE_STENCIL_EXT = $200D;

This item has no description.

WGL_SHARE_ACCUM_EXT = $200E;

This item has no description.

WGL_SUPPORT_GDI_EXT = $200F;

This item has no description.

WGL_SUPPORT_OPENGL_EXT = $2010;

This item has no description.

WGL_DOUBLE_BUFFER_EXT = $2011;

This item has no description.

WGL_STEREO_EXT = $2012;

This item has no description.

WGL_PIXEL_TYPE_EXT = $2013;

This item has no description.

WGL_COLOR_BITS_EXT = $2014;

This item has no description.

WGL_RED_BITS_EXT = $2015;

This item has no description.

WGL_RED_SHIFT_EXT = $2016;

This item has no description.

WGL_GREEN_BITS_EXT = $2017;

This item has no description.

WGL_GREEN_SHIFT_EXT = $2018;

This item has no description.

WGL_BLUE_BITS_EXT = $2019;

This item has no description.

WGL_BLUE_SHIFT_EXT = $201A;

This item has no description.

WGL_ALPHA_BITS_EXT = $201B;

This item has no description.

WGL_ALPHA_SHIFT_EXT = $201C;

This item has no description.

WGL_ACCUM_BITS_EXT = $201D;

This item has no description.

WGL_ACCUM_RED_BITS_EXT = $201E;

This item has no description.

WGL_ACCUM_GREEN_BITS_EXT = $201F;

This item has no description.

WGL_ACCUM_BLUE_BITS_EXT = $2020;

This item has no description.

WGL_ACCUM_ALPHA_BITS_EXT = $2021;

This item has no description.

WGL_DEPTH_BITS_EXT = $2022;

This item has no description.

WGL_STENCIL_BITS_EXT = $2023;

This item has no description.

WGL_AUX_BUFFERS_EXT = $2024;

This item has no description.

WGL_NO_ACCELERATION_EXT = $2025;

This item has no description.

WGL_GENERIC_ACCELERATION_EXT = $2026;

This item has no description.

WGL_FULL_ACCELERATION_EXT = $2027;

This item has no description.

WGL_SWAP_EXCHANGE_EXT = $2028;

This item has no description.

WGL_SWAP_COPY_EXT = $2029;

This item has no description.

WGL_SWAP_UNDEFINED_EXT = $202A;

This item has no description.

WGL_TYPE_RGBA_EXT = $202B;

This item has no description.

WGL_TYPE_COLORINDEX_EXT = $202C;

This item has no description.

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_FRAMEBUFFER_I3D = $2050;

WGL_I3D_digital_video_control

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_VALUE_I3D = $2051;

This item has no description.

WGL_DIGITAL_VIDEO_CURSOR_INCLUDED_I3D = $2052;

This item has no description.

WGL_DIGITAL_VIDEO_GAMMA_CORRECTED_I3D = $2053;

This item has no description.

WGL_GAMMA_TABLE_SIZE_I3D = $204E;

WGL_I3D_gamma

WGL_GAMMA_EXCLUDE_DESKTOP_I3D = $204F;

This item has no description.

WGL_GENLOCK_SOURCE_MULTIVIEW_I3D = $2044;

WGL_I3D_genlock

WGL_GENLOCK_SOURCE_EXTENAL_SYNC_I3D = $2045;

This item has no description.

WGL_GENLOCK_SOURCE_EXTENAL_FIELD_I3D = $2046;

This item has no description.

WGL_GENLOCK_SOURCE_EXTENAL_TTL_I3D = $2047;

This item has no description.

WGL_GENLOCK_SOURCE_DIGITAL_SYNC_I3D = $2048;

This item has no description.

WGL_GENLOCK_SOURCE_DIGITAL_FIELD_I3D = $2049;

This item has no description.

WGL_GENLOCK_SOURCE_EDGE_FALLING_I3D = $204A;

This item has no description.

WGL_GENLOCK_SOURCE_EDGE_RISING_I3D = $204B;

This item has no description.

WGL_GENLOCK_SOURCE_EDGE_BOTH_I3D = $204C;

This item has no description.

WGL_IMAGE_BUFFER_MIN_ACCESS_I3D = $00000001;

WGL_I3D_image_buffer

WGL_IMAGE_BUFFER_LOCK_I3D = $00000002;

This item has no description.

WGL_FLOAT_COMPONENTS_NV = $20B0;

WGL_NV_float_buffer

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;

This item has no description.

WGL_TEXTURE_FLOAT_R_NV = $20B5;

This item has no description.

WGL_TEXTURE_FLOAT_RG_NV = $20B6;

This item has no description.

WGL_TEXTURE_FLOAT_RGB_NV = $20B7;

This item has no description.

WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;

This item has no description.

WGL_BIND_TO_TEXTURE_DEPTH_NV = $20A3;

WGL_NV_render_depth_texture

WGL_BIND_TO_TEXTURE_RECTANGLE_DEPTH_NV = $20A4;

This item has no description.

WGL_DEPTH_TEXTURE_FORMAT_NV = $20A5;

This item has no description.

WGL_TEXTURE_DEPTH_COMPONENT_NV = $20A6;

This item has no description.

WGL_DEPTH_COMPONENT_NV = $20A7;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_RGB_NV = $20A0;

WGL_NV_render_texture_rectangle

WGL_BIND_TO_TEXTURE_RECTANGLE_RGBA_NV = $20A1;

This item has no description.

WGL_TEXTURE_RECTANGLE_NV = $20A2;

This item has no description.

WGL_NUM_VIDEO_SLOTS_NV = $20F0;

WGL_NV_present_video

WGL_BIND_TO_VIDEO_RGB_NV = $20C0;

WGL_NV_video_output

WGL_BIND_TO_VIDEO_RGBA_NV = $20C1;

This item has no description.

WGL_BIND_TO_VIDEO_RGB_AND_DEPTH_NV = $20C2;

This item has no description.

WGL_VIDEO_OUT_COLOR_NV = $20C3;

This item has no description.

WGL_VIDEO_OUT_ALPHA_NV = $20C4;

This item has no description.

WGL_VIDEO_OUT_DEPTH_NV = $20C5;

This item has no description.

WGL_VIDEO_OUT_COLOR_AND_ALPHA_NV = $20C6;

This item has no description.

WGL_VIDEO_OUT_COLOR_AND_DEPTH_NV = $20C7;

This item has no description.

WGL_VIDEO_OUT_FRAME = $20C8;

This item has no description.

WGL_VIDEO_OUT_FIELD_1 = $20C9;

This item has no description.

WGL_VIDEO_OUT_FIELD_2 = $20CA;

This item has no description.

WGL_VIDEO_OUT_STACKED_FIELDS_1_2 = $20CB;

This item has no description.

WGL_VIDEO_OUT_STACKED_FIELDS_2_1 = $20CC;

This item has no description.

WGL_ERROR_INCOMPATIBLE_AFFINITY_MASKS_NV = $20D0;

WGL_NV_gpu_affinity

WGL_ERROR_MISSING_AFFINITY_MASK_NV = $20D1;

This item has no description.

WGL_UNIQUE_ID_NV = $20CE;

WGL_NV_video_capture

WGL_NUM_VIDEO_CAPTURE_SLOTS_NV = $20CF;

This item has no description.

WGL_COVERAGE_SAMPLES_NV = $2042;

WGL_NV_multisample_coverage

WGL_COLOR_SAMPLES_NV = $20B9;

This item has no description.

WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $00000004;

WGL_EXT_create_context_es2_profile

WGL_ACCESS_READ_ONLY_NV = $00000000;

WGL_NV_DX_interop

WGL_ACCESS_READ_WRITE_NV = $00000001;

This item has no description.

WGL_ACCESS_WRITE_DISCARD_NV = $00000002;

This item has no description.

GL_MAX_ELEMENTS_VERTICES_WIN = $80E8;

WIN_draw_range_elements

GL_MAX_ELEMENTS_INDICES_WIN = $80E9;

This item has no description.

GLX_VENDOR = 1;

GLX 1.1 and later:

GLX_VERSION = 2;

This item has no description.

GLX_EXTENSIONS = 3;

This item has no description.

GLX_USE_GL = 1;

This item has no description.

GLX_BUFFER_SIZE = 2;

This item has no description.

GLX_LEVEL = 3;

This item has no description.

GLX_RGBA = 4;

This item has no description.

GLX_DOUBLEBUFFER = 5;

This item has no description.

GLX_STEREO = 6;

This item has no description.

GLX_AUX_BUFFERS = 7;

This item has no description.

GLX_RED_SIZE = 8;

This item has no description.

GLX_GREEN_SIZE = 9;

This item has no description.

GLX_BLUE_SIZE = 10;

This item has no description.

GLX_ALPHA_SIZE = 11;

This item has no description.

GLX_DEPTH_SIZE = 12;

This item has no description.

GLX_STENCIL_SIZE = 13;

This item has no description.

GLX_ACCUM_RED_SIZE = 14;

This item has no description.

GLX_ACCUM_GREEN_SIZE = 15;

This item has no description.

GLX_ACCUM_BLUE_SIZE = 16;

This item has no description.

GLX_ACCUM_ALPHA_SIZE = 17;

This item has no description.

GLX_WINDOW_BIT = $00000001;

GLX_VERSION_1_3

GLX_PIXMAP_BIT = $00000002;

This item has no description.

GLX_PBUFFER_BIT = $00000004;

This item has no description.

GLX_RGBA_BIT = $00000001;

This item has no description.

GLX_COLOR_INDEX_BIT = $00000002;

This item has no description.

GLX_PBUFFER_CLOBBER_MASK = $08000000;

This item has no description.

GLX_FRONT_LEFT_BUFFER_BIT = $00000001;

This item has no description.

GLX_FRONT_RIGHT_BUFFER_BIT = $00000002;

This item has no description.

GLX_BACK_LEFT_BUFFER_BIT = $00000004;

This item has no description.

GLX_BACK_RIGHT_BUFFER_BIT = $00000008;

This item has no description.

GLX_AUX_BUFFERS_BIT = $00000010;

This item has no description.

GLX_DEPTH_BUFFER_BIT = $00000020;

This item has no description.

GLX_STENCIL_BUFFER_BIT = $00000040;

This item has no description.

GLX_ACCUM_BUFFER_BIT = $00000080;

This item has no description.

GLX_CONFIG_CAVEAT = $20;

This item has no description.

GLX_X_VISUAL_TYPE = $22;

This item has no description.

GLX_TRANSPARENT_TYPE = $23;

This item has no description.

GLX_TRANSPARENT_INDEX_VALUE = $24;

This item has no description.

GLX_TRANSPARENT_RED_VALUE = $25;

This item has no description.

GLX_TRANSPARENT_GREEN_VALUE = $26;

This item has no description.

GLX_TRANSPARENT_BLUE_VALUE = $27;

This item has no description.

GLX_TRANSPARENT_ALPHA_VALUE = $28;

This item has no description.

GLX_DONT_CARE = $FFFFFFFF;

This item has no description.

GLX_NONE = $8000;

This item has no description.

GLX_SLOW_CONFIG = $8001;

This item has no description.

GLX_TRUE_COLOR = $8002;

This item has no description.

GLX_DIRECT_COLOR = $8003;

This item has no description.

GLX_PSEUDO_COLOR = $8004;

This item has no description.

GLX_STATIC_COLOR = $8005;

This item has no description.

GLX_GRAY_SCALE = $8006;

This item has no description.

GLX_STATIC_GRAY = $8007;

This item has no description.

GLX_TRANSPARENT_RGB = $8008;

This item has no description.

GLX_TRANSPARENT_INDEX = $8009;

This item has no description.

GLX_VISUAL_ID = $800B;

This item has no description.

GLX_SCREEN = $800C;

This item has no description.

GLX_NON_CONFORMANT_CONFIG = $800D;

This item has no description.

GLX_DRAWABLE_TYPE = $8010;

This item has no description.

GLX_RENDER_TYPE = $8011;

This item has no description.

GLX_X_RENDERABLE = $8012;

This item has no description.

GLX_FBCONFIG_ID = $8013;

This item has no description.

GLX_RGBA_TYPE = $8014;

This item has no description.

GLX_COLOR_INDEX_TYPE = $8015;

This item has no description.

GLX_MAX_PBUFFER_WIDTH = $8016;

This item has no description.

GLX_MAX_PBUFFER_HEIGHT = $8017;

This item has no description.

GLX_MAX_PBUFFER_PIXELS = $8018;

This item has no description.

GLX_PRESERVED_CONTENTS = $801B;

This item has no description.

GLX_LARGEST_PBUFFER = $801C;

This item has no description.

GLX_WIDTH = $801D;

This item has no description.

GLX_HEIGHT = $801E;

This item has no description.

GLX_EVENT_MASK = $801F;

This item has no description.

GLX_DAMAGED = $8020;

This item has no description.

GLX_SAVED = $8021;

This item has no description.

GLX_WINDOW = $8022;

This item has no description.

GLX_PBUFFER = $8023;

This item has no description.

GLX_PBUFFER_HEIGHT = $8040;

This item has no description.

GLX_PBUFFER_WIDTH = $8041;

This item has no description.

GLX_SAMPLE_BUFFERS = 100000;

GLX_VERSION_1_4

GLX_SAMPLES = 100001;

This item has no description.

GLX_SAMPLE_BUFFERS_ARB = 100000;

GLX_ARB_multisample

GLX_SAMPLES_ARB = 100001;

This item has no description.

GLX_CONTEXT_RESET_ISOLATION_BIT_ARB = $00000008;

GLX_ARB_robustness_application_isolation

GLX_RGBA_FLOAT_TYPE_ARB = $20B9;

GLX_ARB_fbconfig_float

GLX_RGBA_FLOAT_BIT_ARB = $00000004;

This item has no description.

GLX_CONTEXT_RELEASE_BEHAVIOR_ARB = $2097;

GLX_ARB_context_flush_control

GLX_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB = 0;

This item has no description.

GLX_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB = $2098;

This item has no description.

GLX_CONTEXT_DEBUG_BIT_ARB = $00000001;

GLX_ARB_create_context

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

This item has no description.

GLX_CONTEXT_MAJOR_VERSION_ARB = $2091;

This item has no description.

GLX_CONTEXT_MINOR_VERSION_ARB = $2092;

This item has no description.

GLX_CONTEXT_FLAGS_ARB = $2094;

This item has no description.

GLX_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

GLX_ARB_create_context_profile

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

This item has no description.

GLX_CONTEXT_PROFILE_MASK_ARB = $9126;

This item has no description.

GLX_CONTEXT_ALLOW_BUFFER_BYTE_ORDER_MISMATCH_ARB = $2095;

GLX_ARB_vertex_buffer_object

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20B2;

GLX_ARB_framebuffer_sRGB

GLX_CONTEXT_ROBUST_ACCESS_BIT_ARB = $00000004;

GLX_ARB_create_context_robustness

GLX_LOSE_CONTEXT_ON_RESET_ARB = $8252;

This item has no description.

GLX_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

This item has no description.

GLX_NO_RESET_NOTIFICATION_ARB = $8261;

This item has no description.

GLX_X_VISUAL_TYPE_EXT = $22;

GLX_EXT_visual_info

GLX_TRANSPARENT_TYPE_EXT = $23;

This item has no description.

GLX_TRANSPARENT_INDEX_VALUE_EXT = $24;

This item has no description.

GLX_TRANSPARENT_RED_VALUE_EXT = $25;

This item has no description.

GLX_TRANSPARENT_GREEN_VALUE_EXT = $26;

This item has no description.

GLX_TRANSPARENT_BLUE_VALUE_EXT = $27;

This item has no description.

GLX_TRANSPARENT_ALPHA_VALUE_EXT = $28;

This item has no description.

GLX_NONE_EXT = $8000;

This item has no description.

GLX_TRUE_COLOR_EXT = $8002;

This item has no description.

GLX_DIRECT_COLOR_EXT = $8003;

This item has no description.

GLX_PSEUDO_COLOR_EXT = $8004;

This item has no description.

GLX_STATIC_COLOR_EXT = $8005;

This item has no description.

GLX_GRAY_SCALE_EXT = $8006;

This item has no description.

GLX_STATIC_GRAY_EXT = $8007;

This item has no description.

GLX_TRANSPARENT_RGB_EXT = $8008;

This item has no description.

GLX_TRANSPARENT_INDEX_EXT = $8009;

This item has no description.

GLX_VISUAL_CAVEAT_EXT = $20;

GLX_EXT_visual_rating

GLX_SLOW_VISUAL_EXT = $8001;

This item has no description.

GLX_NON_CONFORMANT_VISUAL_EXT = $800D;

This item has no description.

GLX_SHARE_CONTEXT_EXT = $800A;

GLX_EXT_import_context

GLX_VISUAL_ID_EXT = $800B;

This item has no description.

GLX_SCREEN_EXT = $800C;

This item has no description.

GLX_TEXTURE_1D_BIT_EXT = $00000001;

GLX_EXT_fbconfig_packed_float GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1; GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008; GLX_EXT_framebuffer_sRGB GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2; GLX_EXT_texture_from_pixmap

GLX_TEXTURE_2D_BIT_EXT = $00000002;

This item has no description.

GLX_TEXTURE_RECTANGLE_BIT_EXT = $00000004;

This item has no description.

GLX_BIND_TO_TEXTURE_RGB_EXT = $20D0;

This item has no description.

GLX_BIND_TO_TEXTURE_RGBA_EXT = $20D1;

This item has no description.

GLX_BIND_TO_MIPMAP_TEXTURE_EXT = $20D2;

This item has no description.

GLX_BIND_TO_TEXTURE_TARGETS_EXT = $20D3;

This item has no description.

GLX_Y_INVERTED_EXT = $20D4;

This item has no description.

GLX_TEXTURE_FORMAT_EXT = $20D5;

This item has no description.

GLX_TEXTURE_TARGET_EXT = $20D6;

This item has no description.

GLX_MIPMAP_TEXTURE_EXT = $20D7;

This item has no description.

GLX_TEXTURE_FORMAT_NONE_EXT = $20D8;

This item has no description.

GLX_TEXTURE_FORMAT_RGB_EXT = $20D9;

This item has no description.

GLX_TEXTURE_FORMAT_RGBA_EXT = $20DA;

This item has no description.

GLX_TEXTURE_1D_EXT = $20DB;

This item has no description.

GLX_TEXTURE_2D_EXT = $20DC;

This item has no description.

GLX_TEXTURE_RECTANGLE_EXT = $20DD;

This item has no description.

GLX_FRONT_LEFT_EXT = $20DE;

This item has no description.

GLX_FRONT_RIGHT_EXT = $20DF;

This item has no description.

GLX_BACK_LEFT_EXT = $20E0;

This item has no description.

GLX_BACK_RIGHT_EXT = $20E1;

This item has no description.

GLX_FRONT_EXT = GLX_FRONT_LEFT_EXT;

This item has no description.

GLX_BACK_EXT = GLX_BACK_LEFT_EXT;

This item has no description.

GLX_AUX0_EXT = $20E2;

This item has no description.

GLX_AUX1_EXT = $20E3;

This item has no description.

GLX_AUX2_EXT = $20E4;

This item has no description.

GLX_AUX3_EXT = $20E5;

This item has no description.

GLX_AUX4_EXT = $20E6;

This item has no description.

GLX_AUX5_EXT = $20E7;

This item has no description.

GLX_AUX6_EXT = $20E8;

This item has no description.

GLX_AUX7_EXT = $20E9;

This item has no description.

GLX_AUX8_EXT = $20EA;

This item has no description.

GLX_AUX9_EXT = $20EB;

This item has no description.

GLX_SWAP_INTERVAL_EXT = $20F1;

GLX_EXT_swap_control

GLX_MAX_SWAP_INTERVAL_EXT = $20F2;

This item has no description.

GLX_CONTEXT_ES2_PROFILE_BIT_EXT = $00000004;

GLX_EXT_create_context_es2_profile

GLX_LATE_SWAPS_TEAR_EXT = $20F3;

GL_EXT_Late_Swaps

GLU_INVALID_ENUM = 100900;

GLU

GLU_INVALID_VALUE = 100901;

This item has no description.

GLU_OUT_OF_MEMORY = 100902;

This item has no description.

GLU_INCOMPATIBLE_GL_VERSION = 100903;

This item has no description.

GLU_VERSION = 100800;

This item has no description.

GLU_EXTENSIONS = 100801;

This item has no description.

GLU_TRUE = GL_TRUE;

This item has no description.

GLU_FALSE = GL_FALSE;

This item has no description.

GLU_SMOOTH = 100000;

This item has no description.

GLU_FLAT = 100001;

This item has no description.

GLU_NONE = 100002;

This item has no description.

GLU_POINT = 100010;

This item has no description.

GLU_LINE = 100011;

This item has no description.

GLU_FILL = 100012;

This item has no description.

GLU_SILHOUETTE = 100013;

This item has no description.

GLU_OUTSIDE = 100020;

This item has no description.

GLU_INSIDE = 100021;

This item has no description.

GLU_TESS_MAX_COORD = 1.0E150;

This item has no description.

GLU_TESS_WINDING_RULE = 100140;

This item has no description.

GLU_TESS_BOUNDARY_ONLY = 100141;

This item has no description.

GLU_TESS_TOLERANCE = 100142;

This item has no description.

GLU_TESS_WINDING_ODD = 100130;

This item has no description.

GLU_TESS_WINDING_NONZERO = 100131;

This item has no description.

GLU_TESS_WINDING_POSITIVE = 100132;

This item has no description.

GLU_TESS_WINDING_NEGATIVE = 100133;

This item has no description.

GLU_TESS_WINDING_ABS_GEQ_TWO = 100134;

This item has no description.

GLU_TESS_BEGIN = 100100;

This item has no description.

GLU_TESS_VERTEX = 100101;

This item has no description.

GLU_TESS_END = 100102;

This item has no description.

GLU_TESS_ERROR = 100103;

This item has no description.

GLU_TESS_EDGE_FLAG = 100104;

This item has no description.

GLU_TESS_COMBINE = 100105;

This item has no description.

GLU_TESS_BEGIN_DATA = 100106;

This item has no description.

GLU_TESS_VERTEX_DATA = 100107;

This item has no description.

GLU_TESS_END_DATA = 100108;

This item has no description.

GLU_TESS_ERROR_DATA = 100109;

This item has no description.

GLU_TESS_EDGE_FLAG_DATA = 100110;

This item has no description.

GLU_TESS_COMBINE_DATA = 100111;

This item has no description.

GLU_TESS_ERROR1 = 100151;

This item has no description.

GLU_TESS_ERROR2 = 100152;

This item has no description.

GLU_TESS_ERROR3 = 100153;

This item has no description.

GLU_TESS_ERROR4 = 100154;

This item has no description.

GLU_TESS_ERROR5 = 100155;

This item has no description.

GLU_TESS_ERROR6 = 100156;

This item has no description.

GLU_TESS_ERROR7 = 100157;

This item has no description.

GLU_TESS_ERROR8 = 100158;

This item has no description.

GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;

This item has no description.

GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;

This item has no description.

GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;

This item has no description.

GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;

This item has no description.

GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;

This item has no description.

GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;

This item has no description.

GLU_AUTO_LOAD_MATRIX = 100200;

This item has no description.

GLU_CULLING = 100201;

This item has no description.

GLU_SAMPLING_TOLERANCE = 100203;

This item has no description.

GLU_DISPLAY_MODE = 100204;

This item has no description.

GLU_PARAMETRIC_TOLERANCE = 100202;

This item has no description.

GLU_SAMPLING_METHOD = 100205;

This item has no description.

GLU_U_STEP = 100206;

This item has no description.

GLU_V_STEP = 100207;

This item has no description.

GLU_PATH_LENGTH = 100215;

This item has no description.

GLU_PARAMETRIC_ERROR = 100216;

This item has no description.

GLU_DOMAIN_DISTANCE = 100217;

This item has no description.

GLU_MAP1_TRIM_2 = 100210;

This item has no description.

GLU_MAP1_TRIM_3 = 100211;

This item has no description.

GLU_OUTLINE_POLYGON = 100240;

This item has no description.

GLU_OUTLINE_PATCH = 100241;

This item has no description.

GLU_NURBS_ERROR1 = 100251;

This item has no description.

GLU_NURBS_ERROR2 = 100252;

This item has no description.

GLU_NURBS_ERROR3 = 100253;

This item has no description.

GLU_NURBS_ERROR4 = 100254;

This item has no description.

GLU_NURBS_ERROR5 = 100255;

This item has no description.

GLU_NURBS_ERROR6 = 100256;

This item has no description.

GLU_NURBS_ERROR7 = 100257;

This item has no description.

GLU_NURBS_ERROR8 = 100258;

This item has no description.

GLU_NURBS_ERROR9 = 100259;

This item has no description.

GLU_NURBS_ERROR10 = 100260;

This item has no description.

GLU_NURBS_ERROR11 = 100261;

This item has no description.

GLU_NURBS_ERROR12 = 100262;

This item has no description.

GLU_NURBS_ERROR13 = 100263;

This item has no description.

GLU_NURBS_ERROR14 = 100264;

This item has no description.

GLU_NURBS_ERROR15 = 100265;

This item has no description.

GLU_NURBS_ERROR16 = 100266;

This item has no description.

GLU_NURBS_ERROR17 = 100267;

This item has no description.

GLU_NURBS_ERROR18 = 100268;

This item has no description.

GLU_NURBS_ERROR19 = 100269;

This item has no description.

GLU_NURBS_ERROR20 = 100270;

This item has no description.

GLU_NURBS_ERROR21 = 100271;

This item has no description.

GLU_NURBS_ERROR22 = 100272;

This item has no description.

GLU_NURBS_ERROR23 = 100273;

This item has no description.

GLU_NURBS_ERROR24 = 100274;

This item has no description.

GLU_NURBS_ERROR25 = 100275;

This item has no description.

GLU_NURBS_ERROR26 = 100276;

This item has no description.

GLU_NURBS_ERROR27 = 100277;

This item has no description.

GLU_NURBS_ERROR28 = 100278;

This item has no description.

GLU_NURBS_ERROR29 = 100279;

This item has no description.

GLU_NURBS_ERROR30 = 100280;

This item has no description.

GLU_NURBS_ERROR31 = 100281;

This item has no description.

GLU_NURBS_ERROR32 = 100282;

This item has no description.

GLU_NURBS_ERROR33 = 100283;

This item has no description.

GLU_NURBS_ERROR34 = 100284;

This item has no description.

GLU_NURBS_ERROR35 = 100285;

This item has no description.

GLU_NURBS_ERROR36 = 100286;

This item has no description.

GLU_NURBS_ERROR37 = 100287;

This item has no description.

GLU_CW = 100120;

This item has no description.

GLU_CCW = 100121;

This item has no description.

GLU_INTERIOR = 100122;

This item has no description.

GLU_EXTERIOR = 100123;

This item has no description.

GLU_UNKNOWN = 100124;

This item has no description.

GLU_BEGIN = GLU_TESS_BEGIN;

This item has no description.

GLU_VERTEX = GLU_TESS_VERTEX;

This item has no description.

GLU_END = GLU_TESS_END;

This item has no description.

GLU_ERROR = GLU_TESS_ERROR;

This item has no description.

GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;

This item has no description.

Variables

GL_VERSION_4_0: Boolean;

This item has no description.

GL_VERSION_4_1: Boolean;

This item has no description.

GL_VERSION_4_2: Boolean;

This item has no description.

GL_VERSION_4_3: Boolean;

This item has no description.

GL_VERSION_4_4: Boolean;

This item has no description.

GL_VERSION_4_5: Boolean;

This item has no description.

GL_VERSION_4_6: Boolean;

This item has no description.

GLU_VERSION_1_3: Boolean;

This item has no description.

GL_3DFX_multisample: Boolean;

This item has no description.

GL_3DFX_tbuffer: Boolean;

This item has no description.

GL_3DFX_texture_compression_FXT1: Boolean;

This item has no description.

GL_APPLE_client_storage: Boolean;

This item has no description.

GL_APPLE_element_array: Boolean;

This item has no description.

GL_APPLE_fence: Boolean;

This item has no description.

GL_APPLE_specular_vector: Boolean;

This item has no description.

GL_APPLE_transform_hint: Boolean;

This item has no description.

GL_APPLE_vertex_array_object: Boolean;

This item has no description.

GL_APPLE_vertex_array_range: Boolean;

This item has no description.

GL_APPLE_ycbcr_422: Boolean;

This item has no description.

GL_APPLE_texture_range: Boolean;

This item has no description.

GL_APPLE_float_pixels: Boolean;

This item has no description.

GL_APPLE_vertex_program_evaluators: Boolean;

This item has no description.

GL_APPLE_aux_depth_stencil: Boolean;

This item has no description.

GL_APPLE_object_purgeable: Boolean;

This item has no description.

GL_APPLE_row_bytes: Boolean;

This item has no description.

GL_APPLE_rgb_422: Boolean;

This item has no description.

GL_ARB_depth_texture: Boolean;

This item has no description.

GL_ARB_fragment_program: Boolean;

This item has no description.

GL_ARB_imaging: Boolean;

This item has no description.

GL_ARB_matrix_palette: Boolean;

This item has no description.

GL_ARB_multisample: Boolean;

This item has no description.

GL_ARB_multitexture: Boolean;

This item has no description.

GL_ARB_point_parameters: Boolean;

This item has no description.

GL_ARB_shadow: Boolean;

This item has no description.

GL_ARB_shadow_ambient: Boolean;

This item has no description.

GL_ARB_texture_border_clamp: Boolean;

This item has no description.

GL_ARB_texture_compression: Boolean;

This item has no description.

GL_ARB_texture_cube_map: Boolean;

This item has no description.

GL_ARB_texture_env_add: Boolean;

This item has no description.

GL_ARB_texture_env_combine: Boolean;

This item has no description.

GL_ARB_texture_env_crossbar: Boolean;

This item has no description.

GL_ARB_texture_env_dot3: Boolean;

This item has no description.

GL_ARB_texture_filter_minmax: Boolean;

This item has no description.

GL_ARB_texture_mirrored_repeat: Boolean;

This item has no description.

GL_ARB_transpose_matrix: Boolean;

This item has no description.

GL_ARB_vertex_blend: Boolean;

This item has no description.

GL_ARB_vertex_buffer_object: Boolean;

This item has no description.

GL_ARB_vertex_program: Boolean;

This item has no description.

GL_ARB_window_pos: Boolean;

This item has no description.

GL_ARB_shader_objects: Boolean;

This item has no description.

GL_ARB_vertex_shader: Boolean;

This item has no description.

GL_ARB_fragment_shader: Boolean;

This item has no description.

GL_ARB_fragment_shader_interlock: Boolean;

This item has no description.

GL_ARB_shading_language_100: Boolean;

This item has no description.

GL_ARB_occlusion_query: Boolean;

This item has no description.

GL_ARB_texture_non_power_of_two: Boolean;

This item has no description.

GL_ARB_point_sprite: Boolean;

This item has no description.

GL_ARB_fragment_program_shadow: Boolean;

This item has no description.

GL_ARB_draw_buffers: Boolean;

This item has no description.

GL_ARB_texture_rectangle: Boolean;

This item has no description.

GL_ARB_color_buffer_float: Boolean;

This item has no description.

GL_ARB_half_float_pixel: Boolean;

This item has no description.

GL_ARB_texture_float: Boolean;

This item has no description.

GL_ARB_pixel_buffer_object: Boolean;

This item has no description.

GL_ARB_depth_buffer_float: Boolean;

This item has no description.

GL_ARB_draw_instanced: Boolean;

This item has no description.

GL_ARB_framebuffer_object: Boolean;

This item has no description.

GL_ARB_framebuffer_sRGB: Boolean;

This item has no description.

GL_ARB_geometry_shader4: Boolean;

This item has no description.

GL_ARB_half_float_vertex: Boolean;

This item has no description.

GL_ARB_instanced_arrays: Boolean;

This item has no description.

GL_ARB_map_buffer_range: Boolean;

This item has no description.

GL_ARB_texture_buffer_object: Boolean;

This item has no description.

GL_ARB_texture_compression_rgtc: Boolean;

This item has no description.

GL_ARB_texture_rg: Boolean;

This item has no description.

GL_ARB_vertex_array_object: Boolean;

This item has no description.

GL_ARB_uniform_buffer_object: Boolean;

This item has no description.

GL_ARB_compatibility: Boolean;

This item has no description.

GL_ARB_copy_buffer: Boolean;

This item has no description.

GL_ARB_shader_texture_lod: Boolean;

This item has no description.

GL_ARB_shader_viewport_layer_array: Boolean;

This item has no description.

GL_ARB_depth_clamp: Boolean;

This item has no description.

GL_ARB_draw_elements_base_vertex: Boolean;

This item has no description.

GL_ARB_fragment_coord_conventions: Boolean;

This item has no description.

GL_ARB_provoking_vertex: Boolean;

This item has no description.

GL_ARB_seamless_cube_map: Boolean;

This item has no description.

GL_ARB_sync: Boolean;

This item has no description.

GL_ARB_texture_multisample: Boolean;

This item has no description.

GL_ARB_vertex_array_bgra: Boolean;

This item has no description.

GL_ARB_draw_buffers_blend: Boolean;

This item has no description.

GL_ARB_sample_shading: Boolean;

This item has no description.

GL_ARB_sample_locations: Boolean;

This item has no description.

GL_ARB_sparse_texture2: Boolean;

This item has no description.

GL_ARB_sparse_texture_clamp: Boolean;

This item has no description.

GL_ARB_texture_cube_map_array: Boolean;

This item has no description.

GL_ARB_texture_gather: Boolean;

This item has no description.

GL_ARB_texture_query_lod: Boolean;

This item has no description.

GL_ARB_shading_language_include: Boolean;

This item has no description.

GL_ARB_texture_compression_bptc: Boolean;

This item has no description.

GL_ARB_blend_func_extended: Boolean;

This item has no description.

GL_ARB_explicit_attrib_location: Boolean;

This item has no description.

GL_ARB_occlusion_query2: Boolean;

This item has no description.

GL_ARB_parallel_shader_compile: Boolean;

This item has no description.

GL_ARB_post_depth_coverage: Boolean;

This item has no description.

GL_ARB_sampler_objects: Boolean;

This item has no description.

GL_ARB_shader_bit_encoding: Boolean;

This item has no description.

GL_ARB_shader_clock: Boolean;

This item has no description.

GL_ARB_texture_rgb10_a2ui: Boolean;

This item has no description.

GL_ARB_texture_swizzle: Boolean;

This item has no description.

GL_ARB_timer_query: Boolean;

This item has no description.

GL_ARB_vertex_type_2_10_10_10_rev: Boolean;

This item has no description.

GL_ARB_draw_indirect: Boolean;

This item has no description.

GL_ARB_gpu_shader5: Boolean;

This item has no description.

GL_ARB_gpu_shader_fp64: Boolean;

This item has no description.

GL_ARB_gpu_shader_int64: Boolean;

This item has no description.

GL_ARB_shader_subroutine: Boolean;

This item has no description.

GL_ARB_tessellation_shader: Boolean;

This item has no description.

GL_ARB_texture_buffer_object_rgb32: Boolean;

This item has no description.

GL_ARB_transform_feedback2: Boolean;

This item has no description.

GL_ARB_transform_feedback3: Boolean;

This item has no description.

GL_ARB_ES2_compatibility: Boolean;

This item has no description.

GL_ARB_ES3_2_compatibility: Boolean;

This item has no description.

GL_ARB_get_program_binary: Boolean;

This item has no description.

GL_ARB_separate_shader_objects: Boolean;

This item has no description.

GL_ARB_shader_precision: Boolean;

This item has no description.

GL_ARB_shader_ballot: Boolean;

This item has no description.

GL_ARB_vertex_attrib_64bit: Boolean;

This item has no description.

GL_ARB_viewport_array: Boolean;

This item has no description.

GL_ARB_base_instance: Boolean;

GL 4.2

GL_ARB_shading_language_420pack: Boolean;

GL 4.2

GL_ARB_transform_feedback_instanced: Boolean;

GL 4.2

GL_ARB_compressed_texture_pixel_storage: Boolean;

GL 4.2

GL_ARB_conservative_depth: Boolean;

GL 4.2

GL_ARB_internalformat_query: Boolean;

GL 4.2

GL_ARB_map_buffer_alignment: Boolean;

GL 4.2

GL_ARB_shader_atomic_counters: Boolean;

GL 4.2

GL_ARB_shader_image_load_store: Boolean;

GL 4.2

GL_ARB_shading_language_packing: Boolean;

GL 4.2

GL_ARB_texture_storage: Boolean;

GL 4.2

GL_ARB_arrays_of_arrays: Boolean;

GL 4.3

GL_ARB_fragment_layer_viewport: Boolean;

GL 4.3

GL_ARB_shader_image_size: Boolean;

GL 4.3

GL_ARB_ES3_compatibility: Boolean;

GL 4.3

GL_ARB_clear_buffer_object: Boolean;

GL 4.3

GL_ARB_compute_shader: Boolean;

GL 4.3

GL_ARB_copy_image: Boolean;

GL 4.3

GL_KHR_debug: Boolean;

GL 4.3

GL_ARB_explicit_uniform_location: Boolean;

GL 4.3

GL_ARB_framebuffer_no_attachments: Boolean;

GL 4.3

GL_ARB_internalformat_query2: Boolean;

GL 4.3

GL_ARB_invalidate_subdata: Boolean;

GL 4.3

GL_ARB_multi_draw_indirect: Boolean;

GL 4.3

GL_ARB_program_interface_query: Boolean;

GL 4.3

GL_ARB_robust_buffer_access_behavior: Boolean;

GL 4.3

GL_ARB_shader_storage_buffer_object: Boolean;

GL 4.3

GL_ARB_stencil_texturing: Boolean;

GL 4.3

GL_ARB_texture_buffer_range: Boolean;

GL 4.3

GL_ARB_texture_query_levels: Boolean;

GL 4.3

GL_ARB_texture_storage_multisample: Boolean;

GL 4.3

GL_ARB_texture_view: Boolean;

GL 4.3

GL_ARB_vertex_attrib_binding: Boolean;

GL 4.3

GL_NV_path_rendering: Boolean;

GL 4.3

GL_AMD_pinned_memory: Boolean;

GL 4.3

GL_AMD_stencil_operation_extended: Boolean;

GL 4.3

GL_AMD_vertex_shader_viewport_index: Boolean;

GL 4.3

GL_AMD_vertex_shader_layer: Boolean;

GL 4.3

GL_NV_bindless_texture: Boolean;

GL 4.3

GL_NV_shader_atomic_float: Boolean;

GL 4.3

GL_AMD_query_buffer_object: Boolean;

GL 4.3

GL_ARB_buffer_storage: Boolean;

GL 4.4

GL_ARB_clear_texture: Boolean;

GL 4.4

GL_ARB_enhanced_layouts: Boolean;

GL 4.4

GL_ARB_multi_bind: Boolean;

GL 4.4

GL_ARB_query_buffer_object: Boolean;

GL 4.4

GL_ARB_texture_mirror_clamp_to_edge: Boolean;

GL 4.4

GL_ARB_texture_stencil8: Boolean;

GL 4.4

GL_ARB_vertex_type_10f_11f_11f_rev: Boolean;

GL 4.4

GL_ARB_bindless_texture: Boolean;

GL 4.4

GL_ARB_sparse_texture: Boolean;

GL 4.4

GL_ARB_clip_control: Boolean;

GL 4.5

GL_ARB_cull_distance: Boolean;

GL 4.5

GL_ARB_ES3_1_compatibility: Boolean;

GL 4.5

GL_ARB_conditional_render_inverted: Boolean;

GL 4.5

GL_KHR_context_flush_control: Boolean;

GL 4.5

GL_ARB_derivative_control: Boolean;

GL 4.5

GL_ARB_direct_state_access: Boolean;

GL 4.5

GL_ARB_get_texture_sub_image: Boolean;

GL 4.5

GL_KHR_robustness: Boolean;

GL 4.5

GL_KHR_blend_equation_advanced: Boolean;

GL 4.5

GL_KHR_blend_equation_advanced_coherent: Boolean;

GL 4.5

GL_KHR_robust_buffer_access_behavior: Boolean;

GL 4.5

GL_ARB_shader_texture_image_samples: Boolean;

GL 4.5

GL_ARB_texture_barrier: Boolean;

GL 4.5

GL_ARB_indirect_parameters: Boolean;

GL 4.6

GL_ARB_pipeline_statistics_query: Boolean;

GL 4.6

GL_ARB_polygon_offset_clamp: Boolean;

GL 4.6

GL_KHR_no_error: Boolean;

GL 4.6

GL_ARB_shader_atomic_counter_ops: Boolean;

GL 4.6

GL_ARB_shader_draw_parameters: Boolean;

GL 4.6

GL_ARB_shader_group_vote: Boolean;

GL 4.6

GL_ARB_gl_spirv: Boolean;

GL 4.6

GL_ARB_spirv_extensions: Boolean;

GL 4.6

GL_ARB_texture_filter_anisotropic: Boolean;

GL 4.6

GL_ARB_transform_feedback_overflow_query: Boolean;

GL 4.6

GL_ARB_cl_event: Boolean;

GL 4.6

GL_ARB_compute_variable_group_size: Boolean;

GL 4.6

GL_ARB_debug_output: Boolean;

GL 4.6

GL_ARB_robustness: Boolean;

GL 4.6

GL_ARB_shader_stencil_export: Boolean;

GL 4.6

GL_ATI_draw_buffers: Boolean;

GL 4.6

GL_ATI_element_array: Boolean;

GL 4.6

GL_ATI_envmap_bumpmap: Boolean;

GL 4.6

GL_ATI_fragment_shader: Boolean;

GL 4.6

GL_ATI_map_object_buffer: Boolean;

GL 4.6

GL_ATI_pn_triangles: Boolean;

GL 4.6

GL_ATI_separate_stencil: Boolean;

GL 4.6

GL_ATI_text_fragment_shader: Boolean;

GL 4.6

GL_ATI_texture_env_combine3: Boolean;

GL 4.6

GL_ATI_texture_float: Boolean;

GL 4.6

GL_ATI_texture_mirror_once: Boolean;

GL 4.6

GL_ATI_vertex_array_object: Boolean;

GL 4.6

GL_ATI_vertex_attrib_array_object: Boolean;

GL 4.6

GL_ATI_vertex_streams: Boolean;

GL 4.6

GL_ATI_meminfo: Boolean;

GL 4.6

GL_AMD_performance_monitor: Boolean;

GL 4.6

GL_AMD_texture_texture4: Boolean;

GL 4.6

GL_AMD_vertex_shader_tesselator: Boolean;

GL 4.6

GL_AMD_draw_buffers_blend: Boolean;

GL 4.6

GL_AMD_shader_stencil_export: Boolean;

GL 4.6

GL_AMD_seamless_cubemap_per_texture: Boolean;

GL 4.6

GL_AMD_conservative_depth: Boolean;

GL 4.6

GL_AMD_name_gen_delete: Boolean;

GL 4.6

GL_AMD_debug_output: Boolean;

GL 4.6

GL_AMD_transform_feedback3_lines_triangles: Boolean;

GL 4.6

GL_AMD_depth_clamp_separate: Boolean;

GL 4.6

GL_EXT_422_pixels: Boolean;

GL 4.6

GL_EXT_abgr: Boolean;

GL 4.6

GL_EXT_bgra: Boolean;

GL 4.6

GL_EXT_blend_color: Boolean;

GL 4.6

GL_EXT_blend_func_separate: Boolean;

GL 4.6

GL_EXT_blend_logic_op: Boolean;

GL 4.6

GL_EXT_blend_minmax: Boolean;

GL 4.6

GL_EXT_blend_subtract: Boolean;

GL 4.6

GL_EXT_clip_volume_hint: Boolean;

GL 4.6

GL_EXT_cmyka: Boolean;

GL 4.6

GL_EXT_color_matrix: Boolean;

GL 4.6

GL_EXT_color_subtable: Boolean;

GL 4.6

GL_EXT_compiled_vertex_array: Boolean;

GL 4.6

GL_EXT_convolution: Boolean;

GL 4.6

GL_EXT_coordinate_frame: Boolean;

GL 4.6

GL_EXT_copy_texture: Boolean;

GL 4.6

GL_EXT_cull_vertex: Boolean;

GL 4.6

GL_EXT_draw_range_elements: Boolean;

GL 4.6

GL_EXT_fog_coord: Boolean;

GL 4.6

GL_EXT_framebuffer_object: Boolean;

GL 4.6

GL_EXT_histogram: Boolean;

GL 4.6

GL_EXT_index_array_formats: Boolean;

GL 4.6

GL_EXT_index_func: Boolean;

GL 4.6

GL_EXT_index_material: Boolean;

GL 4.6

GL_EXT_index_texture: Boolean;

GL 4.6

GL_EXT_light_texture: Boolean;

GL 4.6

GL_EXT_misc_attribute: Boolean;

GL 4.6

GL_EXT_multi_draw_arrays: Boolean;

GL 4.6

GL_EXT_multisample: Boolean;

GL 4.6

GL_EXT_packed_pixels: Boolean;

GL 4.6

GL_EXT_paletted_texture: Boolean;

GL 4.6

GL_EXT_pixel_transform: Boolean;

GL 4.6

GL_EXT_pixel_transform_color_table: Boolean;

GL 4.6

GL_EXT_point_parameters: Boolean;

GL 4.6

GL_EXT_polygon_offset: Boolean;

GL 4.6

GL_EXT_rescale_normal: Boolean;

GL 4.6

GL_EXT_secondary_color: Boolean;

GL 4.6

GL_EXT_separate_specular_color: Boolean;

GL 4.6

GL_EXT_shadow_funcs: Boolean;

GL 4.6

GL_EXT_shared_texture_palette: Boolean;

GL 4.6

GL_EXT_stencil_two_side: Boolean;

GL 4.6

GL_EXT_stencil_wrap: Boolean;

GL 4.6

GL_EXT_subtexture: Boolean;

GL 4.6

GL_EXT_texture: Boolean;

GL 4.6

GL_EXT_texture3D: Boolean;

GL 4.6

GL_EXT_texture_compression_s3tc: Boolean;

GL 4.6

GL_EXT_texture_cube_map: Boolean;

GL 4.6

GL_EXT_texture_edge_clamp: Boolean;

GL 4.6

GL_EXT_texture_env_add: Boolean;

GL 4.6

GL_EXT_texture_env_combine: Boolean;

GL 4.6

GL_EXT_texture_env_dot3: Boolean;

GL 4.6

GL_EXT_texture_filter_anisotropic: Boolean;

GL 4.6

GL_EXT_texture_lod_bias: Boolean;

GL 4.6

GL_EXT_texture_object: Boolean;

GL 4.6

GL_EXT_texture_perturb_normal: Boolean;

GL 4.6

GL_EXT_texture_rectangle: Boolean;

GL 4.6

GL_EXT_vertex_array: Boolean;

GL 4.6

GL_EXT_vertex_shader: Boolean;

GL 4.6

GL_EXT_vertex_weighting: Boolean;

GL 4.6

GL_EXT_depth_bounds_test: Boolean;

GL 4.6

GL_EXT_texture_mirror_clamp: Boolean;

GL 4.6

GL_EXT_blend_equation_separate: Boolean;

GL 4.6

GL_EXT_pixel_buffer_object: Boolean;

GL 4.6

GL_EXT_texture_compression_dxt1: Boolean;

GL 4.6

GL_EXT_stencil_clear_tag: Boolean;

GL 4.6

GL_EXT_packed_depth_stencil: Boolean;

GL 4.6

GL_EXT_texture_sRGB: Boolean;

GL 4.6

GL_EXT_framebuffer_blit: Boolean;

GL 4.6

GL_EXT_framebuffer_multisample: Boolean;

GL 4.6

GL_EXT_timer_query: Boolean;

GL 4.6

GL_EXT_gpu_program_parameters: Boolean;

GL 4.6

GL_EXT_bindable_uniform: Boolean;

GL 4.6

GL_EXT_draw_buffers2: Boolean;

GL 4.6

GL_EXT_draw_instanced: Boolean;

GL 4.6

GL_EXT_framebuffer_sRGB: Boolean;

GL 4.6

GL_EXT_geometry_shader4: Boolean;

GL 4.6

GL_EXT_gpu_shader4: Boolean;

GL 4.6

GL_EXT_packed_float: Boolean;

GL 4.6

GL_EXT_texture_array: Boolean;

GL 4.6

GL_EXT_texture_buffer_object: Boolean;

GL 4.6

GL_EXT_texture_compression_latc: Boolean;

GL 4.6

GL_EXT_texture_compression_rgtc: Boolean;

GL 4.6

GL_EXT_texture_integer: Boolean;

GL 4.6

GL_EXT_texture_shared_exponent: Boolean;

GL 4.6

GL_EXT_transform_feedback: Boolean;

GL 4.6

GL_EXT_direct_state_access: Boolean;

GL 4.6

GL_EXT_vertex_array_bgra: Boolean;

GL 4.6

GL_EXT_texture_swizzle: Boolean;

GL 4.6

GL_EXT_provoking_vertex: Boolean;

GL 4.6

GL_EXT_texture_snorm: Boolean;

GL 4.6

GL_EXT_separate_shader_objects: Boolean;

GL 4.6

GL_EXT_shader_image_load_store: Boolean;

GL 4.6

GL_EXT_vertex_attrib_64bit: Boolean;

GL 4.6

GL_EXT_texture_sRGB_decode: Boolean;

GL 4.6

GL_FfdMaskSGIX: Boolean;

GL 4.6

GL_HP_convolution_border_modes: Boolean;

GL 4.6

GL_HP_image_transform: Boolean;

GL 4.6

GL_HP_occlusion_test: Boolean;

GL 4.6

GL_HP_texture_lighting: Boolean;

GL 4.6

GL_IBM_cull_vertex: Boolean;

GL 4.6

GL_IBM_multimode_draw_arrays: Boolean;

GL 4.6

GL_IBM_rasterpos_clip: Boolean;

GL 4.6

GL_IBM_texture_mirrored_repeat: Boolean;

GL 4.6

GL_IBM_vertex_array_lists: Boolean;

GL 4.6

GL_INGR_blend_func_separate: Boolean;

GL 4.6

GL_INGR_color_clamp: Boolean;

GL 4.6

GL_INGR_interlace_read: Boolean;

GL 4.6

GL_INGR_palette_buffer: Boolean;

GL 4.6

GL_INTEL_framebuffer_CMAA: Boolean;

GL 4.6

GL_INTEL_parallel_arrays: Boolean;

GL 4.6

GL_INTEL_texture_scissor: Boolean;

GL 4.6

GL_MESA_resize_buffers: Boolean;

GL 4.6

GL_MESA_window_pos: Boolean;

GL 4.6

GL_NV_blend_square: Boolean;

GL 4.6

GL_NV_copy_depth_to_color: Boolean;

GL 4.6

GL_NV_depth_clamp: Boolean;

GL 4.6

GL_NV_evaluators: Boolean;

GL 4.6

GL_NV_fence: Boolean;

GL 4.6

GL_NV_float_buffer: Boolean;

GL 4.6

GL_NV_fog_distance: Boolean;

GL 4.6

GL_NV_fragment_program: Boolean;

GL 4.6

GL_NV_half_float: Boolean;

GL 4.6

GL_NV_light_max_exponent: Boolean;

GL 4.6

GL_NV_multisample_filter_hint: Boolean;

GL 4.6

GL_NV_occlusion_query: Boolean;

GL 4.6

GL_NV_packed_depth_stencil: Boolean;

GL 4.6

GL_NV_pixel_data_range: Boolean;

GL 4.6

GL_NV_point_sprite: Boolean;

GL 4.6

GL_NV_primitive_restart: Boolean;

GL 4.6

GL_NV_register_combiners: Boolean;

GL 4.6

GL_NV_register_combiners2: Boolean;

GL 4.6

GL_NV_texgen_emboss: Boolean;

GL 4.6

GL_NV_texgen_reflection: Boolean;

GL 4.6

GL_NV_texture_compression_vtc: Boolean;

GL 4.6

GL_NV_texture_env_combine4: Boolean;

GL 4.6

GL_NV_texture_expand_normal: Boolean;

GL 4.6

GL_NV_texture_rectangle: Boolean;

GL 4.6

GL_NV_texture_shader: Boolean;

GL 4.6

GL_NV_texture_shader2: Boolean;

GL 4.6

GL_NV_texture_shader3: Boolean;

GL 4.6

GL_NV_vertex_array_range: Boolean;

GL 4.6

GL_NV_vertex_array_range2: Boolean;

GL 4.6

GL_NV_vertex_program: Boolean;

GL 4.6

GL_NV_vertex_program1_1: Boolean;

GL 4.6

GL_NV_vertex_program2: Boolean;

GL 4.6

GL_NV_fragment_program_option: Boolean;

GL 4.6

GL_NV_fragment_program2: Boolean;

GL 4.6

GL_NV_vertex_program2_option: Boolean;

GL 4.6

GL_NV_vertex_program3: Boolean;

GL 4.6

GL_NV_depth_buffer_float: Boolean;

GL 4.6

GL_NV_fragment_program4: Boolean;

GL 4.6

GL_NV_framebuffer_multisample_coverage: Boolean;

GL 4.6

GL_NV_geometry_program4: Boolean;

GL 4.6

GL_NV_gpu_program4: Boolean;

GL 4.6

GL_NV_parameter_buffer_object: Boolean;

GL 4.6

GL_NV_transform_feedback: Boolean;

GL 4.6

GL_NV_vertex_program4: Boolean;

GL 4.6

GL_NV_conditional_render: Boolean;

GL 4.6

GL_NV_conservative_raster: Boolean;

GL 4.6

GL_NV_conservative_raster_dilate: Boolean;

GL 4.6

GL_NV_present_video: Boolean;

GL 4.6

GL_NV_explicit_multisample: Boolean;

GL 4.6

GL_NV_transform_feedback2: Boolean;

GL 4.6

GL_NV_video_capture: Boolean;

GL 4.6

GL_NV_copy_image: Boolean;

GL 4.6

GL_NV_parameter_buffer_object2: Boolean;

GL 4.6

GL_NV_shader_buffer_load: Boolean;

GL 4.6

GL_NV_vertex_buffer_unified_memory: Boolean;

GL 4.6

GL_NV_gpu_program5: Boolean;

GL 4.6

GL_NV_gpu_shader5: Boolean;

GL 4.6

GL_NV_shader_buffer_store: Boolean;

GL 4.6

GL_NV_tessellation_program5: Boolean;

GL 4.6

GL_NV_vertex_attrib_integer_64bit: Boolean;

GL 4.6

GL_NV_multisample_coverage: Boolean;

GL 4.6

GL_NV_vdpau_interop: Boolean;

GL 4.6

GL_NV_texture_barrier: Boolean;

GL 4.6

GL_OML_interlace: Boolean;

GL 4.6

GL_OML_resample: Boolean;

GL 4.6

GL_OML_subsample: Boolean;

GL 4.6

GL_OVR_multiview: Boolean;

GL 4.6

GL_OVR_multiview2: Boolean;

GL 4.6

GL_PGI_misc_hints: Boolean;

GL 4.6

GL_PGI_vertex_hints: Boolean;

GL 4.6

GL_REND_screen_coordinates: Boolean;

GL 4.6

GL_S3_s3tc: Boolean;

GL 4.6

GL_SGIS_detail_texture: Boolean;

GL 4.6

GL_SGIS_fog_function: Boolean;

GL 4.6

GL_SGIS_generate_mipmap: Boolean;

GL 4.6

GL_SGIS_multisample: Boolean;

GL 4.6

GL_SGIS_pixel_texture: Boolean;

GL 4.6

GL_SGIS_point_line_texgen: Boolean;

GL 4.6

GL_SGIS_point_parameters: Boolean;

GL 4.6

GL_SGIS_sharpen_texture: Boolean;

GL 4.6

GL_SGIS_texture4D: Boolean;

GL 4.6

GL_SGIS_texture_border_clamp: Boolean;

GL 4.6

GL_SGIS_texture_color_mask: Boolean;

GL 4.6

GL_SGIS_texture_edge_clamp: Boolean;

GL 4.6

GL_SGIS_texture_filter4: Boolean;

GL 4.6

GL_SGIS_texture_lod: Boolean;

GL 4.6

GL_SGIS_texture_select: Boolean;

GL 4.6

GL_SGIX_async: Boolean;

GL 4.6

GL_SGIX_async_histogram: Boolean;

GL 4.6

GL_SGIX_async_pixel: Boolean;

GL 4.6

GL_SGIX_blend_alpha_minmax: Boolean;

GL 4.6

GL_SGIX_calligraphic_fragment: Boolean;

GL 4.6

GL_SGIX_clipmap: Boolean;

GL 4.6

GL_SGIX_convolution_accuracy: Boolean;

GL 4.6

GL_SGIX_depth_pass_instrument: Boolean;

GL 4.6

GL_SGIX_depth_texture: Boolean;

GL 4.6

GL_SGIX_flush_raster: Boolean;

GL 4.6

GL_SGIX_fog_offset: Boolean;

GL 4.6

GL_SGIX_fog_scale: Boolean;

GL 4.6

GL_SGIX_fragment_lighting: Boolean;

GL 4.6

GL_SGIX_framezoom: Boolean;

GL 4.6

GL_SGIX_igloo_interface: Boolean;

GL 4.6

GL_SGIX_impact_pixel_texture: Boolean;

GL 4.6

GL_SGIX_instruments: Boolean;

GL 4.6

GL_SGIX_interlace: Boolean;

GL 4.6

GL_SGIX_ir_instrument1: Boolean;

GL 4.6

GL_SGIX_list_priority: Boolean;

GL 4.6

GL_SGIX_pixel_texture: Boolean;

GL 4.6

GL_SGIX_pixel_tiles: Boolean;

GL 4.6

GL_SGIX_polynomial_ffd: Boolean;

GL 4.6

GL_SGIX_reference_plane: Boolean;

GL 4.6

GL_SGIX_resample: Boolean;

GL 4.6

GL_SGIX_scalebias_hint: Boolean;

GL 4.6

GL_SGIX_shadow: Boolean;

GL 4.6

GL_SGIX_shadow_ambient: Boolean;

GL 4.6

GL_SGIX_sprite: Boolean;

GL 4.6

GL_SGIX_subsample: Boolean;

GL 4.6

GL_SGIX_tag_sample_buffer: Boolean;

GL 4.6

GL_SGIX_texture_add_env: Boolean;

GL 4.6

GL_SGIX_texture_coordinate_clamp: Boolean;

GL 4.6

GL_SGIX_texture_lod_bias: Boolean;

GL 4.6

GL_SGIX_texture_multi_buffer: Boolean;

GL 4.6

GL_SGIX_texture_scale_bias: Boolean;

GL 4.6

GL_SGIX_texture_select: Boolean;

GL 4.6

GL_SGIX_vertex_preclip: Boolean;

GL 4.6

GL_SGIX_ycrcb: Boolean;

GL 4.6

GL_SGIX_ycrcb_subsample: Boolean;

GL 4.6

GL_SGIX_ycrcba: Boolean;

GL 4.6

GL_SGI_color_matrix: Boolean;

GL 4.6

GL_SGI_color_table: Boolean;

GL 4.6

GL_SGI_depth_pass_instrument: Boolean;

GL 4.6

GL_SGI_texture_color_table: Boolean;

GL 4.6

GL_SUNX_constant_data: Boolean;

GL 4.6

GL_SUN_convolution_border_modes: Boolean;

GL 4.6

GL_SUN_global_alpha: Boolean;

GL 4.6

GL_SUN_mesh_array: Boolean;

GL 4.6

GL_SUN_slice_accum: Boolean;

GL 4.6

GL_SUN_triangle_list: Boolean;

GL 4.6

GL_SUN_vertex: Boolean;

GL 4.6

GL_WIN_phong_shading: Boolean;

WGL

GL_WIN_specular_fog: Boolean;

WGL

WGL_3DFX_multisample: Boolean;

WGL

WGL_ARB_buffer_region: Boolean;

WGL

WGL_ARB_extensions_string: Boolean;

WGL

WGL_ARB_make_current_read: Boolean;

WGL

WGL_ARB_multisample: Boolean;

WGL

WGL_ARB_pbuffer: Boolean;

WGL

WGL_ARB_pixel_format: Boolean;

WGL

WGL_ARB_pixel_format_float: Boolean;

WGL

WGL_ARB_render_texture: Boolean;

WGL

WGL_ARB_create_context: Boolean;

WGL

WGL_ARB_create_context_profile: Boolean;

WGL

WGL_ARB_framebuffer_sRGB: Boolean;

WGL

WGL_ARB_create_context_robustness: Boolean;

WGL

WGL_ATI_pixel_format_float: Boolean;

WGL

WGL_AMD_gpu_association: Boolean;

WGL

WGL_EXT_depth_float: Boolean;

WGL

WGL_EXT_display_color_table: Boolean;

WGL

WGL_EXT_extensions_string: Boolean;

WGL

WGL_EXT_make_current_read: Boolean;

WGL

WGL_EXT_multisample: Boolean;

WGL

WGL_EXT_pbuffer: Boolean;

WGL

WGL_EXT_pixel_format: Boolean;

WGL

WGL_EXT_swap_control: Boolean;

WGL

WGL_EXT_create_context_es2_profile: Boolean;

WGL

WGL_I3D_digital_video_control: Boolean;

WGL

WGL_I3D_gamma: Boolean;

WGL

WGL_I3D_genlock: Boolean;

WGL

WGL_I3D_image_buffer: Boolean;

WGL

WGL_I3D_swap_frame_lock: Boolean;

WGL

WGL_I3D_swap_frame_usage: Boolean;

WGL

WGL_NV_float_buffer: Boolean;

WGL

WGL_NV_render_depth_texture: Boolean;

WGL

WGL_NV_render_texture_rectangle: Boolean;

WGL

WGL_NV_vertex_array_range: Boolean;

WGL

WGL_NV_present_video: Boolean;

WGL

WGL_NV_video_output: Boolean;

WGL

WGL_NV_swap_group: Boolean;

WGL

WGL_NV_gpu_affinity: Boolean;

WGL

WGL_NV_video_capture: Boolean;

WGL

WGL_NV_copy_image: Boolean;

WGL

WGL_NV_multisample_coverage: Boolean;

WGL

WGL_NV_DX_interop: Boolean;

WGL

WGL_OML_sync_control: Boolean;

WGL

WGL_3DL_stereo_control: Boolean;

WGL

WGL_ARB_context_flush_control: Boolean;

WGL

WIN_draw_range_elements: Boolean;

WGL

WIN_swap_hint: Boolean;

WGL

GLX_VERSION_1_4: Boolean;

GLX

GLX_ARB_multisample: Boolean;

GLX

GLX_ARB_fbconfig_float: Boolean;

GLX

GLX_ARB_get_proc_address: Boolean;

GLX

GLX_ARB_create_context: Boolean;

GLX

GLX_ARB_create_context_profile: Boolean;

GLX

GLX_ARB_vertex_buffer_object: Boolean;

GLX

GLX_ARB_framebuffer_sRGB: Boolean;

GLX

GLX_ARB_create_context_robustness: Boolean;

GLX

GLX_EXT_visual_info: Boolean;

GLX

GLX_EXT_visual_rating: Boolean;

GLX

GLX_EXT_import_context: Boolean;

GLX

GLX_EXT_fbconfig_packed_float: Boolean;

GLX

GLX_EXT_framebuffer_sRGB: Boolean;

GLX

GLX_EXT_texture_from_pixmap: Boolean;

GLX

GLX_EXT_swap_control: Boolean;

GLX

GLX_ARB_context_flush_control: Boolean;

GLX

GLX_EXT_create_context_es2_profile: Boolean;

GLX

glBlendColor: procedure(red, green, blue, alpha: TGLclampf); stdcall;

——————- OpenGL extension function/procedure definitions —————— ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.2 Core ########################################################### promoted to core v1.2 from GL_EXT_blend_color (#2)

glBlendEquation: procedure(mode: Cardinal); stdcall;

promoted to core v1.2 from GL_EXT_blend_minmax (#37)

glDrawRangeElements: procedure(mode: Cardinal; Astart, Aend: TGLuint; count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)

glTexImage3D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

promoted to core v1.2 from GL_EXT_texture3D (#6)

glTexSubImage3D: procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

glCopyTexSubImage3D: procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

promoted to core v1.2 from GL_EXT_copy_texture

glColorTable: procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; table: Pointer); stdcall;

OpenGL 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)

glColorTableParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glColorTableParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glCopyColorTable: procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

glGetColorTable: procedure(target, format, Atype: Cardinal; table: Pointer); stdcall;

deprecated;

glGetColorTableParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glGetColorTableParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glColorSubTable: procedure(target: Cardinal; start, count: TGLsizei; format, Atype: Cardinal; data: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)

glCopyColorSubTable: procedure(target: Cardinal; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

glConvolutionFilter1D: procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)

glConvolutionFilter2D: procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

deprecated;

glConvolutionParameterf: procedure(target, pname: Cardinal; param: Single); stdcall;

deprecated;

glConvolutionParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glConvolutionParameteri: procedure(target, pname: Cardinal; param: TGLint); stdcall;

deprecated;

glConvolutionParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glCopyConvolutionFilter1D: procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

glCopyConvolutionFilter2D: procedure(target, internalformat: Cardinal; x, y: TGLint; width, height: TGLsizei); stdcall;

deprecated;

glGetConvolutionFilter: procedure(target, internalformat, Atype: Cardinal; image: Pointer); stdcall;

deprecated;

glGetConvolutionParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glGetConvolutionParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glGetSeparableFilter: procedure(target, format, Atype: Cardinal; row, column, span: Pointer); stdcall;

deprecated;

glSeparableFilter2D: procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; row, column: Pointer); stdcall;

deprecated;

glGetHistogram: procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)

glGetHistogramParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glGetHistogramParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glGetMinmax: procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

deprecated;

glGetMinmaxParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glGetMinmaxParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glHistogram: procedure(target: Cardinal; width: TGLsizei; internalformat: Cardinal; sink: TGLboolean); stdcall;

deprecated;

glMinmax: procedure(target, internalformat: Cardinal; sink: TGLboolean); stdcall;

deprecated;

glResetHistogram: procedure(target: Cardinal); stdcall;

deprecated;

glResetMinmax: procedure(target: Cardinal); stdcall;

deprecated;

glActiveTexture: procedure(texture: Cardinal); stdcall;

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.3 Core ########################################################### promoted to core v1.3 from GL_ARB_multitexture (#1)

glSampleCoverage: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

promoted to core v1.3 from GL_ARB_multisample (#5)

glCompressedTexImage3D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

promoted to core v1.3 from GL_ARB_texture_compression (#12)

glCompressedTexImage2D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexImage1D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage3D: procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage2D: procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage1D: procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glGetCompressedTexImage: procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

This item has no description.

glClientActiveTexture: procedure(texture: Cardinal); stdcall;

promoted to core v1.3 from GL_ARB_multitexture (#1)

glMultiTexCoord1d: procedure(target: Cardinal; s: TGLdouble); stdcall;

deprecated;

glMultiTexCoord1dV: procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

glMultiTexCoord1f: procedure(target: Cardinal; s: Single); stdcall;

deprecated;

glMultiTexCoord1fV: procedure(target: Cardinal; v: Single); stdcall;

deprecated;

glMultiTexCoord1i: procedure(target: Cardinal; s: TGLint); stdcall;

deprecated;

glMultiTexCoord1iV: procedure(target: Cardinal; v: PGLInt); stdcall;

deprecated;

glMultiTexCoord1s: procedure(target: Cardinal; s: TGLshort); stdcall;

deprecated;

glMultiTexCoord1sV: procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

glMultiTexCoord2d: procedure(target: Cardinal; s, t: TGLdouble); stdcall;

deprecated;

glMultiTexCoord2dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

glMultiTexCoord2f: procedure(target: Cardinal; s, t: Single); stdcall;

deprecated;

glMultiTexCoord2fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

glMultiTexCoord2i: procedure(target: Cardinal; s, t: TGLint); stdcall;

deprecated;

glMultiTexCoord2iv: procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

glMultiTexCoord2s: procedure(target: Cardinal; s, t: TGLshort); stdcall;

deprecated;

glMultiTexCoord2sv: procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

glMultiTexCoord3d: procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

deprecated;

glMultiTexCoord3dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

glMultiTexCoord3f: procedure(target: Cardinal; s, t, r: Single); stdcall;

deprecated;

glMultiTexCoord3fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

glMultiTexCoord3i: procedure(target: Cardinal; s, t, r: TGLint); stdcall;

deprecated;

glMultiTexCoord3iv: procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

glMultiTexCoord3s: procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

deprecated;

glMultiTexCoord3sv: procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

glMultiTexCoord4d: procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

deprecated;

glMultiTexCoord4dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

glMultiTexCoord4f: procedure(target: Cardinal; s, t, r, q: Single); stdcall;

deprecated;

glMultiTexCoord4fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

glMultiTexCoord4i: procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

deprecated;

glMultiTexCoord4iv: procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

glMultiTexCoord4s: procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

deprecated;

glMultiTexCoord4sv: procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

glLoadTransposeMatrixf: procedure(m: PGLfloat); stdcall;

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix

glLoadTransposeMatrixd: procedure(m: PGLdouble); stdcall;

deprecated;

glMultTransposeMatrixf: procedure(m: PGLfloat); stdcall;

deprecated;

glMultTransposeMatrixd: procedure(m: PGLdouble); stdcall;

deprecated;

glBlendFuncSeparate: procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.4 Core ########################################################### promoted to core v1.4 from GL_EXT_blend_func_separate (#173)

glMultiDrawArrays: procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)

glMultiDrawElements: procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

This item has no description.

glPointParameterf: procedure(pname: Cardinal; param: Single); stdcall;

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)

glPointParameterfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glPointParameteri: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

glPointParameteriv: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glFogCoordf: procedure(coord: Single); stdcall;

promoted to core v1.4 from GL_EXT_fog_coord (#149)

glFogCoordfv: procedure(coord: PGLfloat); stdcall;

deprecated;

glFogCoordd: procedure(coord: TGLdouble); stdcall;

deprecated;

glFogCoorddv: procedure(coord: PGLdouble); stdcall;

deprecated;

glFogCoordPointer: procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

deprecated;

glSecondaryColor3b: procedure(red, green, blue: TGLbyte); stdcall;

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)

glSecondaryColor3bv: procedure(v: PGLbyte); stdcall;

deprecated;

glSecondaryColor3d: procedure(red, green, blue: TGLdouble); stdcall;

deprecated;

glSecondaryColor3dv: procedure(v: PGLdouble); stdcall;

deprecated;

glSecondaryColor3f: procedure(red, green, blue: Single); stdcall;

deprecated;

glSecondaryColor3fv: procedure(v: PGLfloat); stdcall;

deprecated;

glSecondaryColor3i: procedure(red, green, blue: TGLint); stdcall;

deprecated;

glSecondaryColor3iv: procedure(v: PGLint); stdcall;

deprecated;

glSecondaryColor3s: procedure(red, green, blue: TGLshort); stdcall;

deprecated;

glSecondaryColor3sv: procedure(v: PGLshort); stdcall;

deprecated;

glSecondaryColor3ub: procedure(red, green, blue: TGLubyte); stdcall;

deprecated;

glSecondaryColor3ubv: procedure(v: PGLubyte); stdcall;

deprecated;

glSecondaryColor3ui: procedure(red, green, blue: TGLuint); stdcall;

deprecated;

glSecondaryColor3uiv: procedure(v: PGLuint); stdcall;

deprecated;

glSecondaryColor3us: procedure(red, green, blue: TGLushort); stdcall;

deprecated;

glSecondaryColor3usv: procedure(v: PGLushort); stdcall;

deprecated;

glSecondaryColorPointer: procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

deprecated;

glWindowPos2d: procedure(x,y : TGLdouble); stdcall;

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)

glWindowPos2dv: procedure(v : PGLdouble); stdcall;

deprecated;

glWindowPos2f: procedure(x,y : Single); stdcall;

deprecated;

glWindowPos2fv: procedure(v : PGLfloat); stdcall;

deprecated;

glWindowPos2i: procedure(x,y : TGLint); stdcall;

deprecated;

glWindowPos2iv: procedure(v : PGLint); stdcall;

deprecated;

glWindowPos2s: procedure(x,y : TGLshort); stdcall;

deprecated;

glWindowPos2sv: procedure(v : PGLshort); stdcall;

deprecated;

glWindowPos3d: procedure(x,y,z : TGLdouble); stdcall;

deprecated;

glWindowPos3dv: procedure(v : PGLdouble); stdcall;

deprecated;

glWindowPos3f: procedure(x,y,z : Single); stdcall;

deprecated;

glWindowPos3fv: procedure(v : PGLfloat); stdcall;

deprecated;

glWindowPos3i: procedure(x,y,z : TGLint); stdcall;

deprecated;

glWindowPos3iv: procedure(v : PGLint); stdcall;

deprecated;

glWindowPos3s: procedure(x,y,z : TGLshort); stdcall;

deprecated;

glWindowPos3sv: procedure(v : PGLshort); stdcall;

deprecated;

glGenQueries: procedure(n: TGLsizei; ids: PGLuint); stdcall;

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.5 Core ########################################################### promoted to core v1.5 from GL_ARB_occlusion_query (#29)

glDeleteQueries: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

glIsQuery: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glBeginQuery: procedure(target: Cardinal; id: TGLuint); stdcall;

This item has no description.

glEndQuery: procedure(target: Cardinal); stdcall;

This item has no description.

glGetQueryiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetQueryObjectiv: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetQueryObjectuiv: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glBindBuffer: procedure(target: GLenum; buffer: GLuint); stdcall;

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)

glDeleteBuffers: procedure(n: GLsizei; const buffers: PGLuint); stdcall;

This item has no description.

glGenBuffers: procedure(n: GLsizei; buffers: PGLuint); stdcall;

This item has no description.

glIsBuffer: function(buffer: GLuint): GLboolean; stdcall;

This item has no description.

glBufferData: procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

This item has no description.

glBufferSubData: procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

This item has no description.

glGetBufferSubData: procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

This item has no description.

glMapBuffer: function(target: GLenum; access: GLenum): Pointer; stdcall;

This item has no description.

glUnmapBuffer: function(target: GLenum): GLboolean; stdcall;

This item has no description.

glGetBufferParameteriv: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetBufferPointerv: procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

This item has no description.

glBlendEquationSeparate: procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

promoted to core v1.5 from GL_EXT_shadow_funcs (#267) (no functions or procedures) ########################################################### function and procedure definitions for extensions integrated into OpenGL 2.0 Core ########################################################### promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)

glDrawBuffers: procedure(n: GLSizei; const bufs: PGLenum); stdcall;

promoted to core v2.0 from GL_ARB_draw_buffers (#37)

glStencilOpSeparate: procedure(face, sfail, dpfail, dppass: Cardinal); stdcall;

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)

glStencilFuncSeparate: procedure(face, func: Cardinal; ref: TGLint; mask: TGLuint); stdcall;

This item has no description.

glStencilMaskSeparate: procedure(face: Cardinal; mask: TGLuint); stdcall;

This item has no description.

glAttachShader: procedure(_program: TGLuint; shader: TGLuint); stdcall;

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)

glBindAttribLocation: procedure(_program: TGLuint; index: TGLuint; const name: PGLChar);

This item has no description.

glCompileShader: procedure(shader: TGLuint); stdcall;

This item has no description.

glCreateProgram: function(): TGLuint; stdcall;

This item has no description.

glCreateShader: function(_type: Cardinal): TGLuint; stdcall;

This item has no description.

glDeleteProgram: procedure(_program: TGLuint); stdcall;

This item has no description.

glDeleteShader: procedure(shader: TGLuint); stdcall;

This item has no description.

glDetachShader: procedure(_program: TGLuint; shader: TGLuint); stdcall;

This item has no description.

glDisableVertexAttribArray: procedure(index: TGLuint); stdcall;

This item has no description.

glEnableVertexAttribArray: procedure(index: TGLuint); stdcall;

This item has no description.

glGetActiveAttrib: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glGetActiveUniform: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glGetAttachedShaders: procedure(_program: TGLuint; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;

This item has no description.

glGetAttribLocation: function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

This item has no description.

glGetProgramiv: procedure(_program: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetProgramInfoLog: procedure(_program: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

This item has no description.

glGetShaderiv: procedure(shader: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetShaderInfoLog: procedure(shader: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

This item has no description.

glGetShaderSource: procedure(shader:TGLuint; bufSize: TGLsizei; length: PGLsizei; source: PGLChar); stdcall;

This item has no description.

glGetUniformLocation: function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

This item has no description.

glGetUniformfv: procedure(_program: TGLuint; location: TGLint; params: PGLfloat); stdcall;

This item has no description.

glGetUniformiv: procedure(_program: TGLuint; location: TGLint; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribdv: procedure(index:TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

glGetVertexAttribfv: procedure(index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetVertexAttribiv: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribPointerv: procedure(index: TGLuint; pname: Cardinal; _pointer:pointer); stdcall;

This item has no description.

glIsProgram: function(_program: TGLuint):TGLboolean; stdcall;

This item has no description.

glIsShader: function(shader: TGLuint): TGLboolean; stdcall;

This item has no description.

glLinkProgram: procedure(_program: TGLuint); stdcall;

This item has no description.

glShaderSource: procedure(shader: TGLuint; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

This item has no description.

glUseProgram: procedure(_program: TGLuint); stdcall;

This item has no description.

glUniform1f: procedure(location: GLint; v0: Single); stdcall;

This item has no description.

glUniform2f: procedure(location: GLint; v0: Single; v1: Single); stdcall;

This item has no description.

glUniform3f: procedure(location: GLint; v0: Single; v1: Single; v2: Single); stdcall;

This item has no description.

glUniform4f: procedure(location: GLint; v0: Single; v1: Single; v2: Single; v3: Single); stdcall;

This item has no description.

glUniform1i: procedure(location: GLint; v0: GLint); stdcall;

This item has no description.

glUniform2i: procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

This item has no description.

glUniform3i: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

This item has no description.

glUniform4i: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

This item has no description.

glUniform1fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform2fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform3fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform4fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform1iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform2iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform3iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform4iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniformMatrix2fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix3fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix4fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glValidateProgram: procedure(_program: TGLuint); stdcall;

This item has no description.

glVertexAttrib1d: procedure(index:TGLuint; x: TGLdouble); stdcall;

This item has no description.

glVertexAttrib1dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib1f: procedure(index:TGLuint; x: Single); stdcall;

This item has no description.

glVertexAttrib1fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib1s: procedure(index:TGLuint; x: TGLshort); stdcall;

This item has no description.

glVertexAttrib1sv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib2d: procedure(index:TGLuint; x,y: TGLdouble); stdcall;

This item has no description.

glVertexAttrib2dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib2f: procedure(index:TGLuint; x,y: Single); stdcall;

This item has no description.

glVertexAttrib2fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib2s: procedure(index:TGLuint; x,y: TGLshort); stdcall;

This item has no description.

glVertexAttrib2sv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib3d: procedure(index:TGLuint; x,y,z: TGLdouble); stdcall;

This item has no description.

glVertexAttrib3dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib3f: procedure(index:TGLuint; x,y,z: Single); stdcall;

This item has no description.

glVertexAttrib3fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib3s: procedure(index:TGLuint; x,y,z: TGLshort); stdcall;

This item has no description.

glVertexAttrib3sv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4Nbv: procedure(index:TGLuint; v: PGLbyte); stdcall;

This item has no description.

glVertexAttrib4Niv: procedure(index:TGLuint; v: PGLint); stdcall;

This item has no description.

glVertexAttrib4Nsv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4Nub: procedure(index:TGLuint; x,y,z,w: TGLubyte); stdcall;

This item has no description.

glVertexAttrib4Nubv: procedure(index:TGLuint; v: PGLubyte); stdcall;

This item has no description.

glVertexAttrib4Nuiv: procedure(index:TGLuint; v: PGLuint); stdcall;

This item has no description.

glVertexAttrib4Nusv: procedure(index:TGLuint; v: PGLushort); stdcall;

This item has no description.

glVertexAttrib4bv: procedure(index:TGLuint; v: PGLbyte); stdcall;

This item has no description.

glVertexAttrib4d: procedure(index:TGLuint; x,y,z,w: TGLdouble); stdcall;

This item has no description.

glVertexAttrib4dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib4f: procedure(index:TGLuint; x,y,z,w: Single); stdcall;

This item has no description.

glVertexAttrib4fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib4iv: procedure(index:TGLuint; v: PGLint); stdcall;

This item has no description.

glVertexAttrib4s: procedure(index:TGLuint; x,y,z,w: TGLshort); stdcall;

This item has no description.

glVertexAttrib4sv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4ubv: procedure(index:TGLuint; v: PGLubyte); stdcall;

This item has no description.

glVertexAttrib4uiv: procedure(index:TGLuint; v: PGLuint); stdcall;

This item has no description.

glVertexAttrib4usv: procedure(index:TGLuint; v: PGLushort); stdcall;

This item has no description.

glVertexAttribPointer: procedure(index:TGLuint; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;

This item has no description.

glUniformMatrix2x3fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

########################################################### function and procedure definitions for extensions integrated into OpenGL 2.1 Core ###########################################################

glUniformMatrix3x2fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix2x4fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix4x2fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix3x4fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix4x3fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glVertexAttribI1i: procedure(index: TGLuint; x: TGLint); stdcall;

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.0 Core ###########################################################

glVertexAttribI2i: procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

This item has no description.

glVertexAttribI3i: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

This item has no description.

glVertexAttribI4i: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

glVertexAttribI1ui: procedure(index: TGLuint; x: TGLuint); stdcall;

This item has no description.

glVertexAttribI2ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

This item has no description.

glVertexAttribI3ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

This item has no description.

glVertexAttribI4ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

This item has no description.

glVertexAttribI1iv: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI2iv: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI3iv: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI4iv: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI1uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI2uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI3uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI4uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI4bv: procedure(index: TGLuint; v:PGLbyte); stdcall;

This item has no description.

glVertexAttribI4sv: procedure(index: TGLuint; v:PGLshort); stdcall;

This item has no description.

glVertexAttribI4ubv: procedure(index: TGLuint; v: PGLUbyte); stdcall;

This item has no description.

glVertexAttribI4usv: procedure(index: TGLuint; v: PGLushort); stdcall;

This item has no description.

glVertexAttribIPointer: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

This item has no description.

glGetVertexAttribIiv: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribIuiv: procedure(index: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glUniform1ui: procedure(location: TGLInt; v0: TGLuint); stdcall;

This item has no description.

glUniform2ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

This item has no description.

glUniform3ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

This item has no description.

glUniform4ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

This item has no description.

glUniform1uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform2uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform3uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform4uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glGetUniformuiv: procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

This item has no description.

glBindFragDataLocation: procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

This item has no description.

glGetFragDataLocation: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

This item has no description.

glBeginConditionalRender: procedure(id: TGLuint; mode: Cardinal); stdcall;

This item has no description.

glEndConditionalRender: procedure(); stdcall;

This item has no description.

glClampColor: procedure(target: Cardinal; clamp: Cardinal); stdcall;

This item has no description.

glTexParameterIiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

promoted to core v3.0 from GL_EXT_texture_integer glClearColorIi: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glClearColorIui: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF}

glTexParameterIuiv: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glGetTexParameterIiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetTexParameterIuiv: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glColorMaski: procedure(index: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

promoted to core v3.0 from GL_EXT_draw_buffers2

glGetBooleani_v: procedure(target: Cardinal; index: TGLuint; data: PGLboolean); stdcall;

This item has no description.

glGetIntegeri_v: procedure(target: Cardinal; index: TGLuint; data: PGLint); stdcall;

This item has no description.

glEnablei: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glDisablei: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glIsEnabledi: function(target: Cardinal; index: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindBufferRange: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

promoted to core v3.0 from GL_EXT_transform_feedback

glBindBufferBase: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

This item has no description.

glBeginTransformFeedback: procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

glEndTransformFeedback: procedure(); stdcall;

This item has no description.

glTransformFeedbackVaryings: procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

This item has no description.

glGetTransformFeedbackVarying: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glClearBufferiv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLint); stdcall;

New commands in OpenGL 3.0

glClearBufferuiv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLuint); stdcall;

This item has no description.

glClearBufferfv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLfloat); stdcall;

This item has no description.

glClearBufferfi: procedure(buffer: Cardinal; drawbuffer: TGLint; depth: Single; stencil: TGLint); stdcall;

This item has no description.

glGetStringi: function(name: Cardinal; index: TGLuint): PGLChar; stdcall;

This item has no description.

glDrawArraysInstanced: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.1 Core ###########################################################

glDrawElementsInstanced: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

glTexBuffer: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

This item has no description.

glPrimitiveRestartIndex: procedure(index: TGLuint); stdcall;

This item has no description.

glGetInteger64i_v: procedure(target: Cardinal; index: TGLuint; data: PGLint64); stdcall;

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.2 Core ###########################################################

glGetBufferParameteri64v: procedure(target: Cardinal; pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

glProgramParameteri: procedure(_program: TGLuint; pname: Cardinal; value: TGLint); stdcall;

This item has no description.

glFramebufferTexture: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

gluNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

GL_ARB_draw_indirect (ARB #87) GL_ARB_gpu_shader5 (ARB #88) (none) GL_ARB_gpu_shader_fp64 (ARB #89) GL_ARB_shader_subroutine (ARB #90) GL_ARB_tessellation_shader (ARB #91) GL_ARB_texture_buffer_object_rgb32 (ARB #92) (none) GL_ARB_transform_feedback2 (ARB #93) GL_ARB_transform_feedback3 (ARB #94) GL_VERSION_4_1 ########################################################### function and procedure definitions for GLU extensions ########################################################### GLU extensions

gluNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;

This item has no description.

gluDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

This item has no description.

wglCreateBufferRegionARB: function(DC: HDC; iLayerPlane: Integer; uType: Cardinal) : Integer; stdcall;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### WGL_buffer_region (ARB #4)

wglDeleteBufferRegionARB: procedure(hRegion: Integer); stdcall;

This item has no description.

wglSaveBufferRegionARB: function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;

This item has no description.

wglRestoreBufferRegionARB: function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;

This item has no description.

wglGetExtensionsStringARB: function(DC: HDC): PGLChar; stdcall;

WGL_ARB_extensions_string (ARB #8)

wglGetPixelFormatAttribivARB: function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;

WGL_ARB_pixel_format (ARB #9)

wglGetPixelFormatAttribfvARB: function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;

This item has no description.

wglChoosePixelFormatARB: function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: GLuint; piFormats: PGLint; nNumFormats: PGLenum) : BOOL; stdcall;

This item has no description.

wglMakeContextCurrentARB: function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;

WGL_make_current_read (ARB #10)

wglGetCurrentReadDCARB: function(): HDC; stdcall;

This item has no description.

wglCreatePbufferARB: function(DC: HDC; iPixelFormat: GLInt; iWidth, iHeight : GLInt; const piAttribList: PGLint) : HPBUFFERARB; stdcall;

WGL_ARB_pbuffer (ARB #11)

wglGetPbufferDCARB: function(hPbuffer: HPBUFFERARB) : HDC; stdcall;

This item has no description.

wglReleasePbufferDCARB: function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;

This item has no description.

wglDestroyPbufferARB: function(hPbuffer: HPBUFFERARB): BOOL; stdcall;

This item has no description.

wglQueryPbufferARB: function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;

This item has no description.

wglBindTexImageARB: function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

WGL_ARB_render_texture (ARB #20)

wglReleaseTexImageARB: function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

This item has no description.

wglSetPbufferAttribARB: function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;

This item has no description.

wglCreateContextAttribsARB: function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;

WGL_ARB_create_context (ARB #55)

wglEnumGpusNV: function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean;

WGL_NV_gpu_affinity

wglEnumGpuDevicesNV: function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean;

This item has no description.

wglCreateAffinityDCNV: function(hGpuList: PHGPUNV): HDC;

This item has no description.

wglEnumGpusFromAffinityDCNV: function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean;

This item has no description.

wglDeleteDCNV: function(hdc: HDC): Boolean;

This item has no description.

wglSwapIntervalEXT: function(interval : Integer) : BOOL; stdcall;

########################################################### function and procedure definitions for Vendor/EXT WGL extensions ########################################################### WGL_EXT_swap_control (EXT #172)

wglGetSwapIntervalEXT: function: Integer; stdcall;

This item has no description.

glSamplePassARB: procedure(pass: Cardinal); stdcall;

########################################################### function and procedure definitions for ARB approved extensions ########################################################### unknown ARB extension

glActiveTextureARB: procedure(target: Cardinal); stdcall;

GL_ARB_multitexture (ARB #1)

glClientActiveTextureARB: procedure(target: Cardinal); stdcall;

This item has no description.

glMultiTexCoord1dARB: procedure(target: Cardinal; s: TGLdouble); stdcall;

This item has no description.

glMultiTexCoord1dVARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

glMultiTexCoord1fARB: procedure(target: Cardinal; s: Single); stdcall;

This item has no description.

glMultiTexCoord1fVARB: procedure(target: Cardinal; v: Single); stdcall;

This item has no description.

glMultiTexCoord1iARB: procedure(target: Cardinal; s: TGLint); stdcall;

This item has no description.

glMultiTexCoord1iVARB: procedure(target: Cardinal; v: PGLInt); stdcall;

This item has no description.

glMultiTexCoord1sARB: procedure(target: Cardinal; s: TGLshort); stdcall;

This item has no description.

glMultiTexCoord1sVARB: procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

glMultiTexCoord2dARB: procedure(target: Cardinal; s, t: TGLdouble); stdcall;

This item has no description.

glMultiTexCoord2dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

glMultiTexCoord2fARB: procedure(target: Cardinal; s, t: Single); stdcall;

This item has no description.

glMultiTexCoord2fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

glMultiTexCoord2iARB: procedure(target: Cardinal; s, t: TGLint); stdcall;

This item has no description.

glMultiTexCoord2ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

glMultiTexCoord2sARB: procedure(target: Cardinal; s, t: TGLshort); stdcall;

This item has no description.

glMultiTexCoord2svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

glMultiTexCoord3dARB: procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

This item has no description.

glMultiTexCoord3dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

glMultiTexCoord3fARB: procedure(target: Cardinal; s, t, r: Single); stdcall;

This item has no description.

glMultiTexCoord3fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

glMultiTexCoord3iARB: procedure(target: Cardinal; s, t, r: TGLint); stdcall;

This item has no description.

glMultiTexCoord3ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

glMultiTexCoord3sARB: procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

This item has no description.

glMultiTexCoord3svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

glMultiTexCoord4dARB: procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

This item has no description.

glMultiTexCoord4dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

glMultiTexCoord4fARB: procedure(target: Cardinal; s, t, r, q: Single); stdcall;

This item has no description.

glMultiTexCoord4fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

glMultiTexCoord4iARB: procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

This item has no description.

glMultiTexCoord4ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

glMultiTexCoord4sARB: procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

This item has no description.

glMultiTexCoord4svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

glLoadTransposeMatrixfARB: procedure(m: PGLfloat); stdcall;

GL_ARB_transpose_matrix (ARB #3)

glLoadTransposeMatrixdARB: procedure(m: PGLdouble); stdcall;

This item has no description.

glMultTransposeMatrixfARB: procedure(m: PGLfloat); stdcall;

This item has no description.

glMultTransposeMatrixdARB: procedure(m: PGLdouble); stdcall;

This item has no description.

glSampleCoverageARB: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

GL_ARB_multisample (ARB #5)

glCompressedTexImage3DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

GL_ARB_texture_compression (ARB #12)

glCompressedTexImage2DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexImage1DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage3DARB: procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage2DARB: procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage1DARB: procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glGetCompressedTexImageARB: procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

This item has no description.

glPointParameterfARB: procedure(pname: Cardinal; param: Single); stdcall;

GL_ARB_point_parameter (ARB #14)

glPointParameterfvARB: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glWeightbvARB: procedure(size: TGLint; weights: PGLbyte); stdcall;

GL_ARB_vertex_blend (ARB #15) {deprecated?}

glWeightsvARB: procedure(size: TGLint; weights: PGLshort); stdcall;

This item has no description.

glWeightivARB: procedure(size: TGLint; weights: PGLint); stdcall;

This item has no description.

glWeightfvARB: procedure(size: TGLint; weights: PGLfloat); stdcall;

This item has no description.

glWeightdvARB: procedure(size: TGLint; weights: PGLdouble); stdcall;

This item has no description.

glWeightubvARB: procedure(size: TGLint; weights: PGLubyte); stdcall;

This item has no description.

glWeightusvARB: procedure(size: TGLint; weights: PGLushort); stdcall;

This item has no description.

glWeightuivARB: procedure(size: TGLint; weights: PGLuint); stdcall;

This item has no description.

glWeightPointerARB: procedure(size: TGLint; _type: Cardinal; stride:TGLsizei; _pointer:pointer); stdcall;

This item has no description.

glVertexBlendARB: procedure(count: TGLint); stdcall;

This item has no description.

glCurrentPaletteMatrixARB: procedure(index: TGLint); stdcall;

GL_ARB_matrix_palette (ARB #16) {deprecated?}

glMatrixIndexubvARB: procedure(size: TGLint; indices: PGLubyte); stdcall;

This item has no description.

glMatrixIndexusvARB: procedure(size: TGLint; indices: PGLushort); stdcall;

This item has no description.

glMatrixIndexuivARB: procedure(size: TGLint; indices: PGLuint); stdcall;

This item has no description.

glMatrixIndexPointerARB: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer:pointer); stdcall;

This item has no description.

glWindowPos2dARB: procedure(x,y : TGLdouble); stdcall;

GL_ARB_window_pos (ARB #25)

glWindowPos2dvARB: procedure(v : PGLdouble); stdcall;

This item has no description.

glWindowPos2fARB: procedure(x,y : Single); stdcall;

This item has no description.

glWindowPos2fvARB: procedure(v : PGLfloat); stdcall;

This item has no description.

glWindowPos2iARB: procedure(x,y : TGLint); stdcall;

This item has no description.

glWindowPos2ivARB: procedure(v : PGLint); stdcall;

This item has no description.

glWindowPos2sARB: procedure(x,y : TGLshort); stdcall;

This item has no description.

glWindowPos2svARB: procedure(v : PGLshort); stdcall;

This item has no description.

glWindowPos3dARB: procedure(x,y,z : TGLdouble); stdcall;

This item has no description.

glWindowPos3dvARB: procedure(v : PGLdouble); stdcall;

This item has no description.

glWindowPos3fARB: procedure(x,y,z : Single); stdcall;

This item has no description.

glWindowPos3fvARB: procedure(v : PGLfloat); stdcall;

This item has no description.

glWindowPos3iARB: procedure(x,y,z : TGLint); stdcall;

This item has no description.

glWindowPos3ivARB: procedure(v : PGLint); stdcall;

This item has no description.

glWindowPos3sARB: procedure(x,y,z : TGLshort); stdcall;

This item has no description.

glWindowPos3svARB: procedure(v : PGLshort); stdcall;

This item has no description.

glVertexAttrib1dARB: procedure(index: GLuint; x: GLdouble); stdcall;

GL_ARB_vertex_program (ARB #26)

glVertexAttrib1dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib1fARB: procedure(index: GLuint; x: Single); stdcall;

This item has no description.

glVertexAttrib1fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib1sARB: procedure(index: GLuint; x: GLshort); stdcall;

This item has no description.

glVertexAttrib1svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib2dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble); stdcall;

This item has no description.

glVertexAttrib2dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib2fARB: procedure(index: GLuint; x: Single; y: Single); stdcall;

This item has no description.

glVertexAttrib2fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib2sARB: procedure(index: GLuint; x: GLshort; y: GLshort); stdcall;

This item has no description.

glVertexAttrib2svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib3dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

This item has no description.

glVertexAttrib3dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib3fARB: procedure(index: GLuint; x: Single; y: Single; z: Single); stdcall;

This item has no description.

glVertexAttrib3fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib3sARB: procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort); stdcall;

This item has no description.

glVertexAttrib3svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4NbvARB: procedure(index: GLuint; const v: PGLbyte); stdcall;

This item has no description.

glVertexAttrib4NivARB: procedure(index: GLuint; const v: PGLint); stdcall;

This item has no description.

glVertexAttrib4NsvARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4NubARB: procedure(index: GLuint; x: GLubyte; y: GLubyte; z: GLubyte; w: GLubyte); stdcall;

This item has no description.

glVertexAttrib4NubvARB: procedure(index: GLuint; const v: PGLubyte); stdcall;

This item has no description.

glVertexAttrib4NuivARB: procedure(index: GLuint; const v: PGLuint); stdcall;

This item has no description.

glVertexAttrib4NusvARB: procedure(index: GLuint; const v: PGLushort); stdcall;

This item has no description.

glVertexAttrib4bvARB: procedure(index: GLuint; const v: PGLbyte); stdcall;

This item has no description.

glVertexAttrib4dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

This item has no description.

glVertexAttrib4dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib4fARB: procedure(index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

This item has no description.

glVertexAttrib4fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib4ivARB: procedure(index: GLuint; const v: PGLint); stdcall;

This item has no description.

glVertexAttrib4sARB: procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort; w: GLshort); stdcall;

This item has no description.

glVertexAttrib4svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4ubvARB: procedure(index: GLuint; const v: PGLubyte); stdcall;

This item has no description.

glVertexAttrib4uivARB: procedure(index: GLuint; const v: PGLuint); stdcall;

This item has no description.

glVertexAttrib4usvARB: procedure(index: GLuint; const v: PGLushort); stdcall;

This item has no description.

glVertexAttribPointerARB: procedure(index: GLuint; size: GLint; _type: GLenum; normalized: GLboolean; stride: GLsizei; const _pointer: pointer); stdcall;

This item has no description.

glEnableVertexAttribArrayARB: procedure(index: GLuint); stdcall;

This item has no description.

glDisableVertexAttribArrayARB: procedure(index: GLuint); stdcall;

This item has no description.

glProgramStringARB: procedure(target: GLenum; format: GLenum; len: GLsizei; const _string: pointer); stdcall;

This item has no description.

glBindProgramARB: procedure(target: GLenum; _program: GLuint); stdcall;

This item has no description.

glDeleteProgramsARB: procedure(n: GLsizei; const programs: PGLuint); stdcall;

This item has no description.

glGenProgramsARB: procedure(n: GLsizei; programs: PGLuint); stdcall;

This item has no description.

glProgramEnvParameter4dARB: procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

This item has no description.

glProgramEnvParameter4dvARB: procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

This item has no description.

glProgramEnvParameter4fARB: procedure(target: GLenum; index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

This item has no description.

glProgramEnvParameter4fvARB: procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

This item has no description.

glProgramLocalParameter4dARB: procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

This item has no description.

glProgramLocalParameter4dvARB: procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

This item has no description.

glProgramLocalParameter4fARB: procedure(target: GLenum; index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

This item has no description.

glProgramLocalParameter4fvARB: procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

This item has no description.

glGetProgramEnvParameterdvARB: procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

This item has no description.

glGetProgramEnvParameterfvARB: procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

This item has no description.

glGetProgramLocalParameterdvARB: procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

This item has no description.

glGetProgramLocalParameterfvARB: procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

This item has no description.

glGetProgramivARB: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetProgramStringARB: procedure(target: GLenum; pname: GLenum; _string: pointer); stdcall;

This item has no description.

glGetVertexAttribdvARB: procedure(index: GLuint; pname: GLenum; params: PGLdouble); stdcall;

This item has no description.

glGetVertexAttribfvARB: procedure(index: GLuint; pname: GLenum; params: PGLfloat); stdcall;

This item has no description.

glGetVertexAttribivARB: procedure(index: GLuint; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribPointervARB: procedure(index: GLuint; pname: GLenum; _pointer: pointer); stdcall;

This item has no description.

glIsProgramARB: function(_program: GLuint): GLboolean; stdcall;

This item has no description.

glBindBufferARB: procedure(target: GLenum; buffer: GLuint); stdcall;

GL_ARB_vertex_buffer_object (ARB #28)

glDeleteBuffersARB: procedure(n: GLsizei; const buffers: PGLuint); stdcall;

This item has no description.

glGenBuffersARB: procedure(n: GLsizei; buffers: PGLuint); stdcall;

This item has no description.

glIsBufferARB: function(buffer: GLuint): GLboolean; stdcall;

This item has no description.

glBufferDataARB: procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

This item has no description.

glBufferSubDataARB: procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

This item has no description.

glGetBufferSubDataARB: procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

This item has no description.

glMapBufferARB: function(target: GLenum; access: GLenum): Pointer; stdcall;

This item has no description.

glUnmapBufferARB: function(target: GLenum): GLboolean; stdcall;

This item has no description.

glGetBufferParameterivARB: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetBufferPointervARB: procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

This item has no description.

glGenQueriesARB: procedure(n: TGLsizei; ids: PGLuint); stdcall;

GL_ARB_occlusion_query (ARB #29)

glDeleteQueriesARB: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

glIsQueryARB: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glBeginQueryARB: procedure(target: Cardinal; id: TGLuint); stdcall;

This item has no description.

glEndQueryARB: procedure(target: Cardinal); stdcall;

This item has no description.

glGetQueryivARB: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetQueryObjectivARB: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetQueryObjectuivARB: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glDeleteObjectARB: procedure(obj: GLhandleARB); stdcall;

GL_ARB_shader_objects (ARB #30)

glGetHandleARB: function(pname: GLenum): GLhandleARB; stdcall;

This item has no description.

glDetachObjectARB: procedure(containerObj: GLhandleARB; attachedObj: GLhandleARB); stdcall;

This item has no description.

glCreateShaderObjectARB: function(shaderType: GLenum): GLhandleARB; stdcall;

This item has no description.

glShaderSourceARB: procedure(shaderObj: GLhandleARB; count: GLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

This item has no description.

glCompileShaderARB: procedure(shaderObj: GLhandleARB); stdcall;

This item has no description.

glCreateProgramObjectARB: function(): GLhandleARB; stdcall;

This item has no description.

glAttachObjectARB: procedure(containerObj: GLhandleARB; obj: GLhandleARB); stdcall;

This item has no description.

glLinkProgramARB: procedure(programObj: GLhandleARB); stdcall;

This item has no description.

glUseProgramObjectARB: procedure(programObj: GLhandleARB); stdcall;

This item has no description.

glValidateProgramARB: procedure(programObj: GLhandleARB); stdcall;

This item has no description.

glUniform1fARB: procedure(location: GLint; v0: Single); stdcall;

This item has no description.

glUniform2fARB: procedure(location: GLint; v0: Single; v1: Single); stdcall;

This item has no description.

glUniform3fARB: procedure(location: GLint; v0: Single; v1: Single; v2: Single); stdcall;

This item has no description.

glUniform4fARB: procedure(location: GLint; v0: Single; v1: Single; v2: Single; v3: Single); stdcall;

This item has no description.

glUniform1iARB: procedure(location: GLint; v0: GLint); stdcall;

This item has no description.

glUniform2iARB: procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

This item has no description.

glUniform3iARB: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

This item has no description.

glUniform4iARB: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

This item has no description.

glUniform1fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform2fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform3fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform4fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform1ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform2ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform3ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform4ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniformMatrix2fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix3fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix4fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glGetObjectParameterfvARB: procedure(obj: GLhandleARB; pname: GLenum; params: PGLfloat); stdcall;

This item has no description.

glGetObjectParameterivARB: procedure(obj: GLhandleARB; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetInfoLogARB: procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

This item has no description.

glGetAttachedObjectsARB: procedure(containerObj: GLhandleARB; maxCount: GLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;

This item has no description.

glGetUniformLocationARB: function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

This item has no description.

glGetActiveUniformARB: procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glGetUniformfvARB: procedure(programObj: GLhandleARB; location: GLint; params: PGLfloat); stdcall;

This item has no description.

glGetUniformivARB: procedure(programObj: GLhandleARB; location: GLint; params: PGLint); stdcall;

This item has no description.

glGetShaderSourceARB: procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; source: PGLChar); stdcall;

This item has no description.

glBindAttribLocationARB: procedure(programObj: GLhandleARB; index: GLuint; const name: PGLChar); stdcall;

GL_ARB_vertex_shader (ARB #31)

glGetActiveAttribARB: procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glGetAttribLocationARB: function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

This item has no description.

glDrawBuffersARB: procedure(n: GLSizei; const bufs: PGLenum); stdcall;

GL_ARB_DrawBuffers (ARB #37)

glClampColorARB: procedure(target: Cardinal; clamp: Cardinal); stdcall;

GL_ARB_color_buffer_float (ARB #39)

glDrawArraysInstancedARB: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

GL_ARB_draw_instanced (ARB #44)

glDrawElementsInstancedARB: procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

glIsRenderbuffer: function(renderbuffer: TGLuint): TGLBoolean; stdcall;

GL_ARB_framebuffer_object (ARB #45)

glBindRenderbuffer: procedure(target: Cardinal; renderbuffer: TGLuint); stdcall;

This item has no description.

glDeleteRenderbuffers: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

glGenRenderbuffers: procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;

This item has no description.

glRenderbufferStorage: procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

glRenderbufferStorageMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

glGetRenderbufferParameteriv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glIsFramebuffer: function(framebuffer: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindFramebuffer: procedure(target: Cardinal; framebuffer: TGLuint); stdcall;

This item has no description.

glDeleteFramebuffers: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

glGenFramebuffers: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

glCheckFramebufferStatus: function(target: Cardinal): Cardinal; stdcall;

This item has no description.

glFramebufferTexture1D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

glFramebufferTexture2D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

glFramebufferTexture3D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

This item has no description.

glFramebufferTextureLayer: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

This item has no description.

glFramebufferRenderbuffer: procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: TGLuint); stdcall;

This item has no description.

glGetFramebufferAttachmentParameteriv: procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glBlitFramebuffer: procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

This item has no description.

glGenerateMipmap: procedure(target: Cardinal); stdcall;

This item has no description.

glProgramParameteriARB: procedure( _program:TGLuint; pname:Cardinal; value: TGLint); stdcall;

GL_ARB_geometry_shader4 (ARB #47)

glFramebufferTextureARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint); stdcall;

This item has no description.

glFramebufferTextureLayerARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

This item has no description.

glFramebufferTextureFaceARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; face:Cardinal); stdcall;

This item has no description.

glVertexAttribDivisorARB: procedure(index: TGLuint; divisor: TGLuint); stdcall;

GL_ARB_instanced_arrays (ARB #49)

glMapBufferRange: function(target: Cardinal; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;

GL_ARB_map_buffer_range (ARB #50)

glFlushMappedBufferRange: procedure( target: Cardinal; offset: TGLint; length: TGLsizei ); stdcall;

This item has no description.

glTexBufferARB: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

GL_ARB_texture_buffer_object (ARB #51)

glBindVertexArray: procedure(_array: TGLuint); stdcall;

GL_ARB_vertex_array_object (ARB #54)

glDeleteVertexArrays: procedure(n: TGLsizei; arrays: PGLuint); stdcall;

This item has no description.

glGenVertexArrays: procedure(n: TGLsizei; arrays: PGLuint); stdcall;

This item has no description.

glIsVertexArray: function(_array: TGLuint): TGLboolean; stdcall;

This item has no description.

glGetUniformIndices: procedure(_program: TGLuint; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;

GL_ARB_uniform_buffer_object (ARB #57)

glGetActiveUniformsiv: procedure(_program: TGLuint; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetActiveUniformName: procedure(_program: TGLuint; uniformIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformName: PGLchar); stdcall;

This item has no description.

glGetUniformBlockIndex: function(_program: TGLuint; uniformBlockName: PGLchar): TGLuint; stdcall;

This item has no description.

glGetActiveUniformBlockiv: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetActiveUniformBlockName: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PGLchar); stdcall;

This item has no description.

glUniformBlockBinding: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; uniformBlockBinding: TGLuint); stdcall;

This item has no description.

glCopyBufferSubData: procedure(readTarget: Cardinal; writeTarget: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

GL_ARB_copy_buffer (ARB #59)

glDrawElementsBaseVertex: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

GL_ARB_draw_elements_base_vertex (ARB #62)

glDrawRangeElementsBaseVertex: procedure(mode: Cardinal; start: TGLuint; _end: TGLuint; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

This item has no description.

glDrawElementsInstancedBaseVertex: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;

This item has no description.

glMultiDrawElementsBaseVertex: procedure(mode: Cardinal; count: PGLsizei; _type: Cardinal; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;

This item has no description.

glProvokingVertex: procedure(mode: Cardinal); stdcall;

GL_ARB_provoking_vertex (ARB #64)

glFenceSync: function(condition: Cardinal; flags: TGLbitfield): TGLsync; stdcall;

GL_ARB_sync (ARB #66)

glIsSync: function(sync: TGLsync): TGLboolean; stdcall;

This item has no description.

glDeleteSync: procedure(sync: TGLsync); stdcall;

This item has no description.

glClientWaitSync: function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): Cardinal; stdcall;

This item has no description.

glWaitSync: procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;

This item has no description.

glGetInteger64v: procedure(pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

glGetSynciv: procedure(sync: TGLsync; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

This item has no description.

glTexImage2DMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

GL_ARB_texture_multisample (ARB #67)

glTexImage3DMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

This item has no description.

glGetMultisamplefv: procedure(pname: Cardinal; index: TGLuint; val: PGLfloat); stdcall;

This item has no description.

glSampleMaski: procedure(index: TGLuint; mask: TGLbitfield); stdcall;

This item has no description.

glBlendEquationi: procedure(buf: TGLuint; mode: Cardinal); stdcall;

GL_ARB_draw_buffers_blend (ARB #69)

glBlendEquationSeparatei: procedure(buf: TGLuint; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

This item has no description.

glBlendFunci: procedure(buf: TGLuint; src: Cardinal; dst: Cardinal); stdcall;

This item has no description.

glBlendFuncSeparatei: procedure(buf: TGLuint; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;

This item has no description.

glMinSampleShading: procedure(value: TGLclampf); stdcall;

GL_ARB_sample_shading (ARB #70)

glBindFragDataLocationIndexed: procedure(_program: TGLuint; colorNumber: TGLuint; index: TGLuint; const name: PGLchar); stdcall;

GL_ARB_blend_func_extended (ARB #78)

glGetFragDataIndex: function(_program: TGLuint; const name: PGLchar): TGLint; stdcall;

This item has no description.

glGenSamplers: procedure(count: TGLsizei; samplers: PGLuint); stdcall;

GL_ARB_sampler_objects (ARB #81)

glDeleteSamplers: procedure(count: TGLsizei; const samplers: PGLuint); stdcall;

This item has no description.

glIsSampler: function(sampler: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindSampler: procedure(_unit: TGLuint; sampler: TGLuint); stdcall;

This item has no description.

glSamplerParameteri: procedure(sampler: TGLuint; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

glSamplerParameteriv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

glSamplerParameterf: procedure(sampler: TGLuint; pname: Cardinal; param: Single); stdcall;

This item has no description.

glSamplerParameterfv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

glSamplerParameterIiv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

glSamplerParameterIuiv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLuint); stdcall;

This item has no description.

glGetSamplerParameteriv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetSamplerParameterIiv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetSamplerParameterfv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetSamplerParameterIfv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glQueryCounter: procedure(id: TGLuint; target: Cardinal); stdcall;

GL_ARB_timer_query (ARB #85)

glGetQueryObjecti64v: procedure(id: TGLuint; pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

glGetQueryObjectui64v: procedure(id: TGLuint; pname: Cardinal; params: PGLuint64); stdcall;

This item has no description.

glVertexP2ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)

glVertexP2uiv: procedure(_type: Cardinal; const value: PGLuint ); stdcall;

This item has no description.

glVertexP3ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

This item has no description.

glVertexP3uiv: procedure(_type: Cardinal; const value: PGLuint); stdcall;

This item has no description.

glVertexP4ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

This item has no description.

glVertexP4uiv: procedure(_type: Cardinal; const value: PGLuint); stdcall;

This item has no description.

glTexCoordP1ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glTexCoordP1uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glTexCoordP2ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glTexCoordP2uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glTexCoordP3ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glTexCoordP3uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glTexCoordP4ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glTexCoordP4uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glMultiTexCoordP1ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

This item has no description.

glMultiTexCoordP1uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

This item has no description.

glMultiTexCoordP2ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

This item has no description.

glMultiTexCoordP2uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

This item has no description.

glMultiTexCoordP3ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

This item has no description.

glMultiTexCoordP3uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

This item has no description.

glMultiTexCoordP4ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

This item has no description.

glMultiTexCoordP4uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

This item has no description.

glNormalP3ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glNormalP3uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glColorP3ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

This item has no description.

glColorP3uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

glColorP4ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

This item has no description.

glColorP4uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

glSecondaryColorP3ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

This item has no description.

glSecondaryColorP3uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

glVertexAttribP1ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

This item has no description.

glVertexAttribP1uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

glVertexAttribP2ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

This item has no description.

glVertexAttribP2uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

glVertexAttribP3ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

This item has no description.

glVertexAttribP3uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

glVertexAttribP4ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

This item has no description.

glVertexAttribP4uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

glDrawArraysIndirect: procedure(mode: Cardinal; const indirect: PGLvoid); stdcall;

GL_ARB_draw_indirect (ARB #87)

glDrawElementsIndirect: procedure(mode: Cardinal; _type: Cardinal; const indirect: PGLvoid); stdcall;

This item has no description.

glUniform1d: procedure(location: TGLint; x: TGLdouble); stdcall;

GL_ARB_gpu_shader_fp64 (ARB #89)

glUniform2d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

glUniform3d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

glUniform4d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

glUniform1dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glUniform2dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glUniform3dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glUniform4dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix2x3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix2x4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix3x2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix3x4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix4x2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix4x3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glGetUniformdv: procedure(_program: TGLuint; location: TGLint; params : PGLdouble); stdcall;

This item has no description.

glProgramUniform1dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble); stdcall;

glProgramUniformXXX only valid if EXT_direct_state_access is available

glProgramUniform2dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

glProgramUniform3dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

glProgramUniform4dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

glProgramUniform1dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniform2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniform3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniform4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix2x3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix2x4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix3x2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix3x4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix4x2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix4x3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glGetSubroutineUniformLocation: function(_program: TGLuint; shadertype: Cardinal; const name: PGLchar): TGLint; stdcall;

GL_ARB_shader_subroutine (ARB #90)

glGetSubroutineIndex: function(_program: TGLuint; shadertype: Cardinal; const name: PGLchar): TGLuint; stdcall;

This item has no description.

glGetActiveSubroutineUniformiv: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; pname: Cardinal; values: PGLint); stdcall;

This item has no description.

glGetActiveSubroutineUniformName: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

This item has no description.

glGetActiveSubroutineName: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

This item has no description.

glUniformSubroutinesuiv: procedure(shadertype: Cardinal; count: TGLsizei; const indices: PGLuint); stdcall;

This item has no description.

glGetUniformSubroutineuiv: procedure(shadertype: Cardinal; location: TGLint; params: PGLuint); stdcall;

This item has no description.

glGetProgramStageiv: procedure(_program: TGLuint; shadertype: Cardinal; pname: Cardinal; values: PGLint); stdcall;

This item has no description.

glPatchParameteri: procedure(pname: Cardinal; value: TGLint); stdcall;

GL_ARB_tessellation_shader (ARB #91)

glPatchParameterfv: procedure(pname: Cardinal; const values: PGLfloat); stdcall;

This item has no description.

glBindTransformFeedback: procedure(target: Cardinal; id: TGLuint); stdcall;

GL_ARB_transform_feedback2 (ARB #93)

glDeleteTransformFeedbacks: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

glGenTransformFeedbacks: procedure(n: TGLsizei; ids: PGLuint); stdcall;

This item has no description.

glIsTransformFeedback: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glPauseTransformFeedback: procedure(); stdcall;

This item has no description.

glResumeTransformFeedback: procedure(); stdcall;

This item has no description.

glDrawTransformFeedback: procedure(mode: Cardinal; id: TGLuint); stdcall;

This item has no description.

glDrawTransformFeedbackStream: procedure(mode: Cardinal; id: TGLuint; stream: TGLuint); stdcall;

GL_ARB_transform_feedback3 (ARB #94)

glBeginQueryIndexed: procedure(target: Cardinal; index: TGLuint; id: TGLuint); stdcall;

This item has no description.

glEndQueryIndexed: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glGetQueryIndexediv: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glArrayElementArrayEXT: procedure(mode: Cardinal; count: TGLsizei; pi: Pointer); stdcall;

########################################################### function and procedure definitions for Vendor/EXT extensions ########################################################### Unknown Vendor/EXT functions

glAddSwapHintRectWIN: procedure(x, y: TGLint; width, height: TGLsizei); stdcall;

GL_WIN_swap_hint (extension # not found)

glBlendColorEXT: procedure(red, green, blue: TGLclampf; alpha: TGLclampf); stdcall;

GL_EXT_blend_color (EXT #2)

glPolygonOffsetEXT: procedure(factor, bias: Single); stdcall;

GL_EXT_polygon_offset (EXT #3)

glTexImage3DEXT: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; Format, AType: Cardinal; pixels: Pointer); stdcall;

GL_EXT_texture3D (EXT #6)

glTexSubImage1DEXT: procedure(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

GL_EXT_subtexture (EXT #9)

glTexSubImage2DEXT: procedure(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

glTexSubImage3DEXT: procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

glCopyTexImage1DEXT: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;

GL_EXT_copy_texture (EXT #10)

glCopyTexImage2DEXT: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;

This item has no description.

glCopyTexSubImage1DEXT: procedure(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;

This item has no description.

glCopyTexSubImage2DEXT: procedure(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

This item has no description.

glCopyTexSubImage3DEXT: procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

This item has no description.

glGenTexturesEXT: procedure(n: TGLsizei; textures: PGLuint); stdcall;

GL_EXT_texture_object (EXT #20)

glDeleteTexturesEXT: procedure(n: TGLsizei; textures: PGLuint); stdcall;

This item has no description.

glBindTextureEXT: procedure(target: Cardinal; texture: TGLuint); stdcall;

This item has no description.

glPrioritizeTexturesEXT: procedure(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall;

This item has no description.

glAreTexturesResidentEXT: function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;

This item has no description.

glIsTextureEXT: function(texture: TGLuint): TGLboolean; stdcall;

This item has no description.

glSampleMaskSGIS: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

GL_SGIS_multisample (EXT #25)

glSamplePatternSGIS: procedure(pattern: Cardinal); stdcall;

This item has no description.

glBlendEquationEXT: procedure(mode: Cardinal); stdcall;

GL_EXT_blend_minmax (EXT #37)

glColorTableEXT: procedure(target, internalFormat: Cardinal; width: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

GL_EXT_paletted_texture (EXT #78)

glColorSubTableExt: procedure(target: Cardinal; start, count: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

This item has no description.

glGetColorTableEXT: procedure(target, format, atype: Cardinal; data: Pointer); stdcall;

This item has no description.

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glIndexMaterialEXT: procedure(face: Cardinal; mode: Cardinal); stdcall;

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} GL_EXT_index_material (EXT #94)

glIndexFuncEXT: procedure(func: Cardinal; ref: Single); stdcall;

GL_EXT_index_func (EXT #95)

glLockArraysEXT: procedure(first: TGLint; count: TGLsizei); stdcall;

GL_EXT_compiled_vertex_array (EXT #97)

glUnlockArraysEXT: procedure; stdcall;

This item has no description.

glDrawRangeElementsEXT: procedure(mode: Cardinal; start, Aend: TGLuint; Count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

GL_EXT_draw_range_elements (EXT #112)

glBeginSceneEXT: procedure; stdcall;

GL_EXT_scene_marker (EXT #120)

glEndSceneEXT: procedure; stdcall;

This item has no description.

glSecondaryColor3bEXT: procedure(red, green, blue: TGLbyte); stdcall;

GL_EXT_secondary_color (EXT #145)

glSecondaryColor3bvEXT: procedure(v: PGLbyte); stdcall;

This item has no description.

glSecondaryColor3dEXT: procedure(red, green, blue: TGLdouble); stdcall;

This item has no description.

glSecondaryColor3dvEXT: procedure(v: PGLdouble); stdcall;

This item has no description.

glSecondaryColor3fEXT: procedure(red, green, blue: Single); stdcall;

This item has no description.

glSecondaryColor3fvEXT: procedure(v: PGLfloat); stdcall;

This item has no description.

glSecondaryColor3iEXT: procedure(red, green, blue: TGLint); stdcall;

This item has no description.

glSecondaryColor3ivEXT: procedure(v: PGLint); stdcall;

This item has no description.

glSecondaryColor3sEXT: procedure(red, green, blue: TGLshort); stdcall;

This item has no description.

glSecondaryColor3svEXT: procedure(v: PGLshort); stdcall;

This item has no description.

glSecondaryColor3ubEXT: procedure(red, green, blue: TGLubyte); stdcall;

This item has no description.

glSecondaryColor3ubvEXT: procedure(v: PGLubyte); stdcall;

This item has no description.

glSecondaryColor3uiEXT: procedure(red, green, blue: TGLuint); stdcall;

This item has no description.

glSecondaryColor3uivEXT: procedure(v: PGLuint); stdcall;

This item has no description.

glSecondaryColor3usEXT: procedure(red, green, blue: TGLushort); stdcall;

This item has no description.

glSecondaryColor3usvEXT: procedure(v: PGLushort); stdcall;

This item has no description.

glSecondaryColorPointerEXT: procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

This item has no description.

glMultiDrawArraysEXT: procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

GL_EXT_multi_draw_arrays (EXT #148)

glMultiDrawElementsEXT: procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

This item has no description.

glFogCoordfEXT: procedure(coord: Single); stdcall;

GL_EXT_fog_coord (EXT #149)

glFogCoordfvEXT: procedure(coord: PGLfloat); stdcall;

This item has no description.

glFogCoorddEXT: procedure(coord: TGLdouble); stdcall;

This item has no description.

glFogCoorddvEXT: procedure(coord: PGLdouble); stdcall;

This item has no description.

glFogCoordPointerEXT: procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

This item has no description.

glBlendFuncSeparateEXT: procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

GL_EXT_blend_func_separate (EXT #173)

glFlushVertexArrayRangeNV: procedure; stdcall;

GL_NV_vertex_array_range (EXT #190)

glVertexArrayRangeNV: procedure(Size: TGLsizei; p: pointer); stdcall;

This item has no description.

wglAllocateMemoryNV: function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;

This item has no description.

wglFreeMemoryNV: procedure(ptr: Pointer); stdcall;

This item has no description.

glCombinerParameterfvNV: procedure(pname: Cardinal; params: PGLfloat); stdcall;

GL_NV_register_combiners (EXT #191)

glCombinerParameterfNV: procedure(pname: Cardinal; param: Single); stdcall;

This item has no description.

glCombinerParameterivNV: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glCombinerParameteriNV: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

glCombinerInputNV: procedure(stage, portion, variable, input, mapping, componentUsage: Cardinal); stdcall;

This item has no description.

glCombinerOutputNV: procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: Cardinal; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;

This item has no description.

glFinalCombinerInputNV: procedure(variable, input, mapping, componentUsage: Cardinal); stdcall;

This item has no description.

glGetCombinerInputParameterfvNV: procedure(stage, portion, variable, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetCombinerInputParameterivNV: procedure(stage, portion, variable, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetCombinerOutputParameterfvNV: procedure(stage, portion, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetCombinerOutputParameterivNV: procedure(stage, portion, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetFinalCombinerInputParameterfvNV: procedure(variable, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetFinalCombinerInputParameterivNV: procedure(variable, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glResizeBuffersMESA: procedure; stdcall;

GL_MESA_resize_buffers (EXT #196)

glTbufferMask3DFX: procedure(mask: TGLuint); stdcall;

GL_3DFX_tbuffer (EXT #208)

glSampleMaskEXT: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

GL_EXT_multisample (EXT #209)

glSamplePatternEXT: procedure(pattern: Cardinal); stdcall;

This item has no description.

glTextureColorMaskSGIS: procedure(red, green, blue, alpha: TGLboolean); stdcall;

GL_SGIS_texture_color_mask (EXT #214)

glGenFencesNV: procedure(n: TGLsizei; fences: PGLuint); stdcall;

GL_NV_fence (EXT #222)

glDeleteFencesNV: procedure(n: TGLsizei; fences: PGLuint); stdcall;

This item has no description.

glSetFenceNV: procedure(fence: TGLuint; condition: Cardinal); stdcall;

This item has no description.

glTestFenceNV: function(fence: TGLuint): TGLboolean; stdcall;

This item has no description.

glFinishFenceNV: procedure(fence: TGLuint); stdcall;

This item has no description.

glIsFenceNV: function(fence: TGLuint): TGLboolean; stdcall;

This item has no description.

glGetFenceivNV: procedure(fence: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glAreProgramsResidentNV: procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;

GL_NV_vertex_program (EXT #233)

glBindProgramNV: procedure(target: Cardinal; id: TGLuint); stdcall;

This item has no description.

glDeleteProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

glExecuteProgramNV: procedure(target: Cardinal; id: TGLuint; params: PGLfloat); stdcall;

This item has no description.

glGenProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

glGetProgramParameterdvNV: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

glGetProgramParameterfvNV: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetProgramivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetProgramStringNV: procedure(id: TGLuint; pname: Cardinal; programIdx: PGLubyte); stdcall;

This item has no description.

glGetTrackMatrixivNV: procedure(target: Cardinal; address: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribdvNV: procedure(index: TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

glGetVertexAttribfvNV: procedure(index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetVertexAttribivNV: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribPointervNV: procedure(index: TGLuint; pname: Cardinal; pointer: PGLPointer); stdcall;

This item has no description.

glIsProgramNV: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glLoadProgramNV: procedure(target: Cardinal; id: TGLuint; len: TGLSizei; programIdx: PGLubyte); stdcall;

This item has no description.

glProgramParameter4dNV: procedure(target: Cardinal; index: TGLuint; x, y, z, w: TGLdouble); stdcall;

This item has no description.

glProgramParameter4dvNV: procedure(target: Cardinal; index: TGLuint; v: PGLdouble ); stdcall;

This item has no description.

glProgramParameter4fNV: procedure(target: Cardinal; index: TGLuint; x, y, z, w: Single); stdcall;

This item has no description.

glProgramParameter4fvNV: procedure(target: Cardinal; index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glProgramParameters4dvNV: procedure(target: Cardinal; index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glProgramParameters4fvNV: procedure(target: Cardinal; index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glRequestResidentProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

glTrackMatrixNV: procedure(target: Cardinal; address: TGLuint; matrix: Cardinal; transform: Cardinal); stdcall;

This item has no description.

glVertexAttribPointerNV: procedure(index: TGLuint; fsize: TGLint; vertextype: Cardinal; stride: TGLSizei; pointer: Pointer); stdcall;

This item has no description.

glVertexAttrib1dNV: procedure(index: TGLuint; x: TGLdouble); stdcall;

This item has no description.

glVertexAttrib1dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib1fNV: procedure(index: TGLuint; x: Single); stdcall;

This item has no description.

glVertexAttrib1fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib1sNV: procedure(index: TGLuint; x: TGLshort); stdcall;

This item has no description.

glVertexAttrib1svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib2dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

glVertexAttrib2dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib2fNV: procedure(index: TGLuint; x: Single; y: Single); stdcall;

This item has no description.

glVertexAttrib2fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib2sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort); stdcall;

This item has no description.

glVertexAttrib2svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib3dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

glVertexAttrib3dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib3fNV: procedure(index: TGLuint; x: Single; y: Single; z: Single); stdcall;

This item has no description.

glVertexAttrib3fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib3sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

This item has no description.

glVertexAttrib3svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

glVertexAttrib4dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib4fNV: procedure(index: TGLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

This item has no description.

glVertexAttrib4fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib4sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;

This item has no description.

glVertexAttrib4svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4ubvNV: procedure(index: TGLuint; v: PGLubyte); stdcall;

This item has no description.

glVertexAttribs1dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glVertexAttribs1fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glVertexAttribs1svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

glVertexAttribs2dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glVertexAttribs2fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glVertexAttribs2svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

glVertexAttribs3dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glVertexAttribs3fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glVertexAttribs3svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

glVertexAttribs4dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glVertexAttribs4fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glVertexAttribs4svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

glVertexAttribs4ubvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLubyte); stdcall;

This item has no description.

glGenOcclusionQueriesNV: procedure(n: TGLsizei; ids: PGLuint); stdcall;

GL_NV_occlusion_query (EXT #261)

glDeleteOcclusionQueriesNV: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

glIsOcclusionQueryNV: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glBeginOcclusionQueryNV: procedure(id: TGLuint); stdcall;

This item has no description.

glEndOcclusionQueryNV: procedure; stdcall;

This item has no description.

glGetOcclusionQueryivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetOcclusionQueryuivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glPointParameteriNV: procedure(pname: Cardinal; param: TGLint); stdcall;

GL_NV_point_sprite (EXT #262)

glPointParameterivNV: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glActiveStencilFaceEXT: procedure(face: Cardinal); stdcall;

GL_EXT_stencil_two_side (EXT #268)

glDrawBuffersATI: procedure(n: GLsizei; const bufs: PGLenum); stdcall;

GL_ATI_draw_buffers (EXT #277)

glPrimitiveRestartNV: procedure(); stdcall;

GL_NV_primitive_restart (EXT #285)

glPrimitiveRestartIndexNV: procedure(index: TGLuint); stdcall;

This item has no description.

glDepthBoundsEXT: procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;

GL_EXT_depth_bounds_test (EXT #297)

glBlendEquationSeparateEXT: procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

GL_EXT_blend_equation_separate (EXT #299)

glIsRenderbufferEXT: function(renderbuffer: TGLuint): TGLboolean; stdcall;

GL_EXT_framebuffer_object (EXT #310)

glBindRenderbufferEXT: procedure(target: Cardinal; renderbuffer: TGLuint); stdcall;

This item has no description.

glDeleteRenderbuffersEXT: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

glGenRenderbuffersEXT: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

glRenderbufferStorageEXT: procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

glGetRenderbufferParameterivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glIsFramebufferEXT: function(framebuffer: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindFramebufferEXT: procedure(target: Cardinal; framebuffer: TGLuint); stdcall;

This item has no description.

glDeleteFramebuffersEXT: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

glGenFramebuffersEXT: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

glCheckFramebufferStatusEXT: function(target: Cardinal): Cardinal; stdcall;

This item has no description.

glFramebufferTexture1DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

glFramebufferTexture2DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

glFramebufferTexture3DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint; zoffset: TGLint); stdcall;

This item has no description.

glFramebufferRenderbufferEXT: procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: TGLuint); stdcall;

This item has no description.

glGetFramebufferAttachmentParameterivEXT: procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGenerateMipmapEXT: procedure(target: Cardinal); stdcall;

This item has no description.

glStencilClearTagEXT: procedure(stencilTagBits: TGLsizei; stencilClearTag: TGLuint); stdcall;

GL_EXT_stencil_clear_tag (EXT #314)

glBlitFramebufferEXT: procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

GL_EXT_framebuffer_blit (#316)

glRenderbufferStorageMultisampleEXT: procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

GL_EXT_framebuffer_multisample (#317)

glGetQueryObjecti64vEXT: procedure(id: TGLuint; pname: Cardinal; params: PGLint64EXT); stdcall;

GL_EXT_timer_query (#319)

glGetQueryObjectui64vEXT: procedure(id: TGLuint; pname: Cardinal; params: PGLuint64EXT); stdcall;

This item has no description.

glProgramEnvParameters4fvEXT: procedure(target:Cardinal; index:TGLuint; count:TGLsizei; const params:PGLfloat); stdcall;

GL_EXT_gpu_program_parameters (EXT #320)

glProgramLocalParameters4fvEXT: procedure(target:Cardinal; index:TGLuint; count:TGLsizei; const params:PGLFloat); stdcall;

This item has no description.

glProgramVertexLimitNV: procedure(target: Cardinal; limit: TGLint); stdcall;

GL_NV_geometry_program4 (EXT #323)

glProgramParameteriEXT: procedure( _program:TGLuint; pname:Cardinal; value: TGLint); stdcall;

GL_EXT_geometry_shader4 (EXT #324)

glFramebufferTextureEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint); stdcall;

This item has no description.

glFramebufferTextureLayerEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

This item has no description.

glFramebufferTextureFaceEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; face:Cardinal); stdcall;

This item has no description.

glVertexAttribI1iEXT: procedure(index: TGLuint; x: TGLint); stdcall;

GL_EXT_gpu_shader4 (EXT #326)

glVertexAttribI2iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

This item has no description.

glVertexAttribI3iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

This item has no description.

glVertexAttribI4iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

glVertexAttribI1uiEXT: procedure(index: TGLuint; x: TGLuint); stdcall;

This item has no description.

glVertexAttribI2uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

This item has no description.

glVertexAttribI3uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

This item has no description.

glVertexAttribI4uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

This item has no description.

glVertexAttribI1ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI2ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI3ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI4ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI1uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI2uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI3uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI4uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI4bvEXT: procedure(index: TGLuint; v:PGLbyte); stdcall;

This item has no description.

glVertexAttribI4svEXT: procedure(index: TGLuint; v:PGLshort); stdcall;

This item has no description.

glVertexAttribI4ubvEXT: procedure(index: TGLuint; v: PGLUbyte); stdcall;

This item has no description.

glVertexAttribI4usvEXT: procedure(index: TGLuint; v: PGLushort); stdcall;

This item has no description.

glVertexAttribIPointerEXT: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

This item has no description.

glGetVertexAttribIivEXT: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribIuivEXT: procedure(index: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glUniform1uiEXT: procedure(location: TGLInt; v0: TGLuint); stdcall;

This item has no description.

glUniform2uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

This item has no description.

glUniform3uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

This item has no description.

glUniform4uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

This item has no description.

glUniform1uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform2uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform3uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform4uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glGetUniformuivEXT: procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

This item has no description.

glBindFragDataLocationEXT: procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

This item has no description.

glGetFragDataLocationEXT: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

This item has no description.

glDrawArraysInstancedEXT: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

GL_EXT_draw_instanced (#327)

glDrawElementsInstancedEXT: procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

glTexBufferEXT: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

GL_EXT_packed_float (#328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (#329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (#330)

glColorMaskIndexedEXT: procedure(buf: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

GL_EXT_draw_buffers2 (#340)

glGetBooleanIndexedvEXT: procedure(value: Cardinal; index: TGLuint; data: PGLboolean); stdcall;

This item has no description.

glGetIntegerIndexedvEXT: procedure(value: Cardinal; index: TGLuint; data: PGLint); stdcall;

This item has no description.

glEnableIndexedEXT: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glDisableIndexedEXT: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glIsEnabledIndexedEXT: function(target: Cardinal; index: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindBufferRangeNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

GL_NV_transform_feedback (#341)

glBindBufferOffsetNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr); stdcall;

This item has no description.

glBindBufferBaseNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

This item has no description.

glTransformFeedbackAttribsNV: procedure(count: TGLsizei; attribs: PGLint; bufferMode: Cardinal); stdcall;

This item has no description.

glTransformFeedbackVaryingsNV: procedure(_program: TGLuint; count: TGLsizei; locations: PGLint; bufferMode: Cardinal); stdcall;

This item has no description.

glBeginTransformFeedbackNV: procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

glEndTransformFeedbackNV: procedure(); stdcall;

This item has no description.

glGetVaryingLocationNV: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

This item has no description.

glGetActiveVaryingNV: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: Cardinal; name: PGLChar); stdcall;

This item has no description.

glActiveVaryingNV: procedure(_program: TGLuint; name: PGLChar); stdcall;

This item has no description.

glGetTransformFeedbackVaryingNV: procedure(_program: TGLuint; index: TGLuint; location: PGLint); stdcall;

This item has no description.

glUniformBufferEXT: procedure(_program: TGLUint; location: TGLint; buffer: TGLuint); stdcall;

GL_EXT_bindable_uniform (#342)

glGetUniformBufferSizeEXT: function(_program: TGLuint; location: TGLint): TGLint; stdcall;

This item has no description.

glGetUniformOffsetEXT: function(_program: TGLuint; location: TGLint): PGLint; stdcall;

This item has no description.

glClearColorIiEXT: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;

GL_EXT_texture_integer (#343)

glClearColorIuiEXT: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint); stdcall;

This item has no description.

glTexParameterIivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glTexParameterIuivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glGetTexParameterIivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetTexParameterIuivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glBeginConditionalRenderNV: procedure(id: TGLuint; mode: Cardinal); stdcall;

GL_NV_conditional_render (#346)

glEndConditionalRenderNV: procedure(); stdcall;

This item has no description.

glBindBufferRangeEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset:TGLintptr; size: TGLsizeiptr); stdcall;

GL_EXT_transform_feedback (#352)

glBindBufferOffsetEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset:TGLintptr); stdcall;

This item has no description.

glBindBufferBaseEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

This item has no description.

glBeginTransformFeedbackEXT: procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

glEndTransformFeedbackEXT: procedure(); stdcall;

This item has no description.

glTransformFeedbackVaryingsEXT: procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

This item has no description.

glGetTransformFeedbackVaryingEXT: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glTessellationFactorAMD: procedure(factor: Single); stdcall;

GL_AMD_vertex_shader_tessellator (#363)

glTessellationModeAMD: procedure(mode: Cardinal); stdcall;

This item has no description.

glCopyImageSubDataNV: procedure( srcName: GLuint; srcTarget: GLenum; srcLevel: GLint; srcX: GLint; srcY: GLint; srcZ: GLint; dstName: GLuint; dstTarget: GLenum; dstLevel: GLint; dstX: GLint; dstY: GLint; dstZ: GLint; width: GLsizei; height: GLsizei; depth: GLsizei); stdcall;

GL_NV_copy_image (#376)

glMakeBufferResidentNV: procedure(target: Cardinal; access: Cardinal); stdcall;

GL_NV_shader_buffer_load (#379)

glMakeBufferNonResidentNV: procedure(target: Cardinal); stdcall;

This item has no description.

glIsBufferResidentNV: function(target: Cardinal): TGLboolean; stdcall;

This item has no description.

glMakeNamedBufferResidentNV: procedure(buffer: TGLuint; access: Cardinal); stdcall;

This item has no description.

glMakeNamedBufferNonResidentNV: procedure(buffer: TGLuint); stdcall;

This item has no description.

glIsNamedBufferResidentNV: function(buffer: TGLuint): TGLboolean; stdcall;

This item has no description.

glGetBufferParameterui64vNV: procedure(target: Cardinal; pname: Cardinal; params: PGLuint64EXT ); stdcall;

This item has no description.

glGetNamedBufferParameterui64vNV: procedure(buffer: TGLuint; pname: Cardinal; params: PGLuint64EXT); stdcall;

This item has no description.

glGetIntegerui64vNV: procedure(value: Cardinal; result: PGLuint64EXT); stdcall;

This item has no description.

glUniformui64NV: procedure(location: TGLint; value: TGLuint64EXT); stdcall;

This item has no description.

glUniformui64vNV: procedure(location: GLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

This item has no description.

glGetUniformui64vNV: procedure(_program: TGLuint; location: TGLint; params: PGLuint64EXT); stdcall;

This item has no description.

glProgramUniformui64NV: procedure(_program: TGLuint; location: TGLint; value: TGLuint64EXT); stdcall;

This item has no description.

glProgramUniformui64vNV: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

This item has no description.

glBufferAddressRangeNV: procedure(pname: Cardinal; index: TGLuint; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;

GL_NV_vertex_buffer_unified_memory (#380)

glVertexFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glNormalFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glColorFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glIndexFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glTexCoordFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glEdgeFlagFormatNV: procedure(stride: TGLsizei); stdcall;

This item has no description.

glSecondaryColorFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glFogCoordFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glVertexAttribFormatNV: procedure(index: TGLuint; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei); stdcall;

This item has no description.

glVertexAttribIFormatNV: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glGetIntegerui64i_vNV: procedure(value: Cardinal; index: TGLuint; result: PGLuint64EXT); stdcall;

This item has no description.

glFrameTerminatorGREMEDY: procedure(); stdcall;

Special Gremedy debugger extension

glStringMarkerGREMEDY: procedure(len: GLsizei; str: PGLChar); stdcall;

This item has no description.

vIgnoreOpenGLErrors: Boolean = false;

Raises an EOpenGLError with 'msg' error string


GLSysHelp v.2.5: GLScene.OpenGL4: Packed Record _WGLSWAP

Packed Record _WGLSWAP

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type _WGLSWAP = packed record

Description

This item has no description.

Overview

Fields

Public | hdc: HDC;
Public | uiFlags: UINT;

Description

Fields

Public hdc: HDC;

This item has no description.

Public uiFlags: UINT;


GLSysHelp v.2.5: GLScene.OpenGL4: Record TGPUDEVICE

Record TGPUDEVICE

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type TGPUDEVICE = record

Description

This item has no description.

Overview

Fields

Public | cb: Cardinal;
Public | DeviceName: array [0 .. 31] of AnsiChar;
Public | DeviceString: array [0 .. 127] of AnsiChar;
Public | Flags: Cardinal;
Public | rcVirtualScreen: TRect;

Description

Fields

Public cb: Cardinal;

This item has no description.

Public DeviceName: array [0 .. 31] of AnsiChar;

This item has no description.

Public DeviceString: array [0 .. 127] of AnsiChar;

This item has no description.

Public Flags: Cardinal;

This item has no description.

Public rcVirtualScreen: TRect;


GLSysHelp v.2.5: GLScene.OpenGL4: Record TGLUNurbs

Record TGLUNurbs

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type TGLUNurbs = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: GLScene.OpenGL4: Record TGLUQuadric

Record TGLUQuadric

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type TGLUQuadric = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: GLScene.OpenGL4: Record TGLUTesselator

Record TGLUTesselator

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type TGLUTesselator = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: GLScene.OpenGL4: Class EOpenGLError

Class EOpenGLError

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type EOpenGLError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EOpenGLError


GLSysHelp v.2.5: GLScene.OpenGLTokens

Unit GLScene.OpenGLTokens

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.OpenGLext
  • System.SysUtils
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record _WGLSWAP |
Record TGPUDEVICE |
Record TGLUNurbs |
Record TGLUQuadric |
Record TGLUTesselator |

Types

HGPUNV = THandle;
HPBUFFERARB = type UINT_PTR;
HVIDEOINPUTDEVICENV = THandle;
PFNGLACTIVESHADERPROGRAMPROC = procedure(pipeline: Cardinal; _program: Cardinal); stdcall;
PFNGLACTIVESTENCILFACEEXTPROC = procedure(face: Cardinal); stdcall;
PFNGLACTIVETEXTUREARBPROC = procedure(target: Cardinal); stdcall;
PFNGLACTIVETEXTUREPROC = procedure(texture: Cardinal); stdcall;
PFNGLACTIVEVARYINGNVPROC = procedure(_program: Cardinal; name: PAnsiChar); stdcall;
PFNGLADDSWAPHINTRECTWINPROC = procedure(x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLAREPROGRAMSRESIDENTNVPROC = procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;
PFNGLARETEXTURESRESIDENTEXTPROC = function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;
PFNGLARRAYELEMENTARRAYEXTPROC = procedure(mode: Cardinal; count: TGLsizei; pi: Pointer); stdcall;
PFNGLATTACHOBJECTARBPROC = procedure(containerObj: TGLhandleARB; obj: TGLhandleARB); stdcall;
PFNGLATTACHSHADERPROC = procedure(_program: Cardinal; shader: Cardinal); stdcall;
PFNGLBEGINCONDITIONALRENDERNVPROC = procedure(id: Cardinal; mode: Cardinal); stdcall;
PFNGLBEGINCONDITIONALRENDERPROC = procedure(id: Cardinal; mode: Cardinal); stdcall;
PFNGLBEGINOCCLUSIONQUERYNVPROC = procedure(id: Cardinal); stdcall;
PFNGLBEGINQUERYARBPROC = procedure(target: Cardinal; id: Cardinal); stdcall;
PFNGLBEGINQUERYINDEXEDPROC = procedure(target: Cardinal; index: Cardinal; id: Cardinal); stdcall;
PFNGLBEGINQUERYPROC = procedure(target: Cardinal; id: Cardinal); stdcall;
PFNGLBEGINSCENEEXTPROC = procedure; stdcall;
PFNGLBEGINTRANSFORMFEEDBACKEXTPROC = procedure(primitiveMode: Cardinal); stdcall;
PFNGLBEGINTRANSFORMFEEDBACKNVPROC = procedure(primitiveMode: Cardinal); stdcall;
PFNGLBEGINTRANSFORMFEEDBACKPROC = procedure(primitiveMode: Cardinal); stdcall;
PFNGLBINDATTRIBLOCATIONARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; const name: PAnsiChar); stdcall;
PFNGLBINDATTRIBLOCATIONPROC = procedure(_program: Cardinal; index: Cardinal; const name: PAnsiChar); stdcall;
PFNGLBINDBUFFERARBPROC = procedure(target: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFERBASEEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFERBASENVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFERBASEPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFEROFFSETEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr); stdcall;
PFNGLBINDBUFFEROFFSETNVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset: TGLintptr); stdcall;
PFNGLBINDBUFFERPROC = procedure(target: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFERRANGEEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLBINDBUFFERRANGENVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLBINDBUFFERRANGEPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLBindBuffersBase = procedure(target : Cardinal; first : Cardinal; count : TGLsizei; const buffers : PGLUint); stdcall;
PFNGLBindBuffersRange = procedure(target : Cardinal; first : Cardinal; count : TGLsizei; const buffers : PGLuint; const offsets : TGLintptr; const sizes : TGLsizeiptr); stdcall;
PFNGLBINDFRAGDATALOCATIONEXTPROC = procedure(_program: Cardinal; colorNumber: Cardinal; name: PAnsiChar); stdcall;
PFNGLBINDFRAGDATALOCATIONINDEXEDPROC = procedure (_program: Cardinal; colorNumber: Cardinal; index: Cardinal; const name: PAnsiChar); stdcall;
PFNGLBINDFRAGDATALOCATIONPROC = procedure(_program: Cardinal; colorNumber: Cardinal; name: PAnsiChar); stdcall;
PFNGLBINDFRAMEBUFFEREXTPROC = procedure(target: Cardinal; framebuffer: Cardinal); stdcall;
PFNGLBINDFRAMEBUFFERPROC = procedure(target: Cardinal; framebuffer: Cardinal); stdcall;
PFNGLBindImageTextures = procedure(first : Cardinal; count : TGLsizei; const textures : PGLuint); stdcall;
PFNGLBINDMULTITEXTUREEXTPROC = procedure(texunit: Cardinal; target: Cardinal; texture: Cardinal); stdcall;
PFNGLBINDPROGRAMARBPROC = procedure(target: Cardinal; _program: Cardinal); stdcall;
PFNGLBINDPROGRAMNVPROC = procedure(target: Cardinal; id: Cardinal); stdcall;
PFNGLBINDPROGRAMPIPELINEPROC = procedure(pipeline: Cardinal); stdcall;
PFNGLBINDRENDERBUFFEREXTPROC = procedure(target: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLBINDRENDERBUFFERPROC = procedure(target: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLBINDSAMPLERPROC = procedure(_unit: Cardinal; sampler: Cardinal); stdcall;
PFNGLBindSamplers = procedure(first : Cardinal; count : TGLsizei; const samplers : PGLuint); stdcall;
PFNGLBINDTEXTUREEXTPROC = procedure(target: Cardinal; texture: Cardinal); stdcall;
PFNGLBindTextures = procedure(first : Cardinal; count : TGLsizei; const textures : PGLuint); stdcall;
PFNGLBINDTRANSFORMFEEDBACKPROC = procedure(target: Cardinal; id: Cardinal); stdcall;
PFNGLBINDVERTEXARRAYPROC = procedure(_array: Cardinal); stdcall;
PFNGLBindVertexBuffer = procedure(bindingindex : Cardinal; buffer : Cardinal; offset : TGLintptr; stride : TGLsizei); stdcall;
PFNGLBindVertexBuffers = procedure(first : Cardinal; count : TGLsizei; const buffers : Cardinal; const offsets : TGLintptr; const strides : PGLsizei); stdcall;
PFNGLBLENDCOLOREXTPROC = procedure(red, green, blue: Single; alpha: Single); stdcall;
PFNGLBLENDCOLORPROC = procedure(red, green, blue, alpha: Single); stdcall;
PFNGLBLENDEQUATIONEXTPROC = procedure(mode: Cardinal); stdcall;
PFNGLBLENDEQUATIONIARBPROC = procedure(buf: Cardinal; mode: Cardinal); stdcall;
PFNGLBLENDEQUATIONIPROC = procedure(buf: Cardinal; mode: Cardinal); stdcall;
PFNGLBLENDEQUATIONPROC = procedure(mode: Cardinal); stdcall;
PFNGLBLENDEQUATIONSEPARATEEXTPROC = procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;
PFNGLBLENDEQUATIONSEPARATEIARBPROC = procedure(buf: Cardinal; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;
PFNGLBLENDEQUATIONSEPARATEIPROC = procedure(buf: Cardinal; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;
PFNGLBLENDEQUATIONSEPARATEPROC = procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;
PFNGLBLENDFUNCIARBPROC = procedure(buf: Cardinal; src: Cardinal; dst: Cardinal); stdcall;
PFNGLBLENDFUNCIPROC = procedure(buf: Cardinal; src: Cardinal; dst: Cardinal); stdcall;
PFNGLBLENDFUNCSEPARATEEXTPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;
PFNGLBLENDFUNCSEPARATEIARBPROC = procedure(buf: Cardinal; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;
PFNGLBLENDFUNCSEPARATEIPROC = procedure(buf: Cardinal; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;
PFNGLBLENDFUNCSEPARATEPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;
PFNGLBLITFRAMEBUFFEREXTPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;
PFNGLBLITFRAMEBUFFERPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;
PFNGLBUFFERADDRESSRANGENVPROC = procedure(pname: Cardinal; index: Cardinal; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;
PFNGLBUFFERDATAARBPROC = procedure(target: Cardinal; size: TGLsizei; const data: Pointer; usage: Cardinal); stdcall;
PFNGLBUFFERDATAPROC = procedure(target: Cardinal; size: TGLsizei; const data: Pointer; usage: Cardinal); stdcall;
PFNGLBufferStorage = procedure(target : Cardinal; size : TGLsizeiptr; const data : pointer; flags : TGLbitfield); stdcall;
PFNGLBUFFERSUBDATAARBPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; const data: Pointer); stdcall;
PFNGLBUFFERSUBDATAPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; const data: Pointer); stdcall;
PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC = function(target: Cardinal): Cardinal; stdcall;
PFNGLCHECKFRAMEBUFFERSTATUSPROC = function(target: Cardinal): Cardinal; stdcall;
PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC = function(framebuffer: Cardinal; target: Cardinal): Cardinal; stdcall;
PFNGLCLAMPCOLORARBPROC = procedure (target: Cardinal; clamp: Cardinal); stdcall;
PFNGLCLAMPCOLORPROC = procedure (target: Cardinal; clamp: Cardinal); stdcall;
PFNGLClearBufferData = procedure(target : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;
PFNGLCLEARBUFFERFIPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; depth: TGLfloat; stencil: TGLint); stdcall;
PFNGLCLEARBUFFERFVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLfloat); stdcall;
PFNGLCLEARBUFFERIVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLint); stdcall;
PFNGLClearBufferSubData = procedure(target : Cardinal; internalformat : Cardinal; offset : TGLintptr; size : TGLsizeiptr; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;
PFNGLCLEARBUFFERUIVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLuint); stdcall;
PFNGLCLEARCOLORIIEXTPROC = procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;
PFNGLCLEARCOLORIUIEXTPROC = procedure(r: Cardinal; g: Cardinal; b: Cardinal; a: Cardinal); stdcall;
PFNGLCLEARDEPTHFPROC = procedure(depth: TGLclampd); stdcall;
PFNGLClearNamedBufferData = procedure(buffer : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;
PFNGLClearNamedBufferSubData = procedure(buffer : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; offset : TGLsizeiptr; size : TGLsizeiptr; const data : Pointer); stdcall;
PFNGLClearTexImage = procedure(texture : Cardinal; level : TGLint; format : Cardinal; _type : Cardinal; const data : Pointer); stdcall;
PFNGLClearTexSubImage = procedure(texture : Cardinal; level : TGLint; xoffset : TGLint; yoffset : TGLint; zoffset : TGLint; width : TGLsizei; height : TGLsizei; depth : TGLsizei; format : Cardinal; _type : Cardinal; const Data : Pointer); stdcall;
PFNGLCLIENTACTIVETEXTUREARBPROC = procedure(target: Cardinal); stdcall;
PFNGLCLIENTACTIVETEXTUREPROC = procedure(texture: Cardinal); stdcall;
PFNGLCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: TGLbitfield); stdcall;
PFNGLCLIENTWAITSYNCPROC = function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): Cardinal; stdcall;
PFNGLCOLORFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLCOLORMASKINDEXEDEXTPROC = procedure(buf: Cardinal; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;
PFNGLCOLORMASKIPROC = procedure(index: Cardinal; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;
PFNGLCOLORP3UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;
PFNGLCOLORP3UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;
PFNGLCOLORP4UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;
PFNGLCOLORP4UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;
PFNGLCOLORSUBTABLEEXTPROC = procedure(target: Cardinal; start, count: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;
PFNGLCOLORSUBTABLEPROC = procedure(target: Cardinal; start, count: TGLsizei; format, Atype: Cardinal; data: Pointer); stdcall;
PFNGLCOLORTABLEEXTPROC = procedure(target, internalFormat: Cardinal; width: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;
PFNGLCOLORTABLEPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLCOLORTABLEPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLCOLORTABLEPROC = procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; table: Pointer); stdcall;
PFNGLCOMBINERINPUTNVPROC = procedure(stage, portion, variable, input, mapping, componentUsage: Cardinal); stdcall;
PFNGLCOMBINEROUTPUTNVPROC = procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: Cardinal; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;
PFNGLCOMBINERPARAMETERFNVPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;
PFNGLCOMBINERPARAMETERFVNVPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;
PFNGLCOMBINERPARAMETERINVPROC = procedure(pname: Cardinal; param: TGLint); stdcall;
PFNGLCOMBINERPARAMETERIVNVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;
PFNGLCOMPILESHADERARBPROC = procedure(shaderObj: TGLhandleARB); stdcall;
PFNGLCOMPILESHADERPROC = procedure(shader: Cardinal); stdcall;
PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXIMAGE1DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE1DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE2DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE2DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE3DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC = procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;
PFNGLCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;
PFNGLCONVOLUTIONPARAMETERFPROC = procedure(target, pname: Cardinal; param: TGLfloat); stdcall;
PFNGLCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLCONVOLUTIONPARAMETERIPROC = procedure(target, pname: Cardinal; param: TGLint); stdcall;
PFNGLCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLCOPYBUFFERSUBDATAPROC = procedure(readTarget: Cardinal; writeTarget: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLCOPYCOLORSUBTABLEPROC = procedure(target: Cardinal; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYCOLORTABLEPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLCopyImageSubData = procedure(srcName : Cardinal; srcTarget : Cardinal; srcLevel : TGLint; srcX : TGLint; srcY : TGLint; srcZ : TGLint; dstName : Cardinal; dstTarget : Cardinal; dstLevel : TGLint; dstX : TGLint; dstY : TGLint; dstZ : TGLint; srcWidth : TGLsizei; srcHeight : TGLsizei; srcDepth : TGLsizei); stdcall;
PFNGLCOPYIMAGESUBDATANVPROC = procedure( srcName: Cardinal; srcTarget: Cardinal; srcLevel: TGLint; srcX: TGLint; srcY: TGLint; srcZ: TGLint; dstName: Cardinal; dstTarget: Cardinal; dstLevel: TGLint; dstX: TGLint; dstY: TGLint; dstZ: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei); stdcall;
PFNGLCOPYMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLCOPYPATHNVPROC = procedure (resultPath: Cardinal; srcPath: Cardinal); stdcall;
PFNGLCOPYTEXIMAGE1DEXTPROC = procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYTEXIMAGE2DEXTPROC = procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYTEXSUBIMAGE1DEXTPROC = procedure(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYTEXSUBIMAGE2DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLCOPYTEXSUBIMAGE3DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLCOPYTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLCOPYTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLCOVERFILLPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; coverMode: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLCOVERFILLPATHNVPROC = procedure (path: Cardinal; coverMode: Cardinal); stdcall;
PFNGLCOVERSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; coverMode: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLCOVERSTROKEPATHNVPROC = procedure (path: Cardinal; coverMode: Cardinal); stdcall;
PFNGLCREATEPROGRAMOBJECTARBPROC = function(): TGLhandleARB; stdcall;
PFNGLCREATEPROGRAMPROC = function(): Cardinal; stdcall;
PFNGLCREATESHADEROBJECTARBPROC = function(shaderType: Cardinal): TGLhandleARB; stdcall;
PFNGLCREATESHADERPROC = function(_type: Cardinal): Cardinal; stdcall;
PFNGLCREATESHADERPROGRAMVPROC = function(_type: Cardinal; count: TGLsizei; const strings: PGLPCharArray): Cardinal; stdcall;
PFNGLCreateSyncFromCLevent = function(context: p_cl_context; event: p_cl_event; flags: TGLbitfield): TGLsync; stdcall;
PFNGLCURRENTPALETTEMATRIXARBPROC = procedure(index: TGLint); stdcall;
PFNGLDEBUGMESSAGECALLBACKARBPROC = procedure(callback: TGLDEBUGPROCARB; userParam: Pointer); stdcall;
PFNGLDEBUGMESSAGECONTROLARBPROC = procedure(source: Cardinal; _type: Cardinal; severity: Cardinal; count: TGLsizei; ids: PGLuint; enabled: TGLboolean); stdcall;
PFNGLDEBUGMESSAGEINSERTARBPROC = procedure(source: Cardinal; _type: Cardinal; id: Cardinal; severity: Cardinal; length: TGLsizei; buf: PAnsiChar); stdcall;
PFNGLDELETEBUFFERSARBPROC = procedure(n: TGLsizei; const buffers: PGLuint); stdcall;
PFNGLDELETEBUFFERSPROC = procedure(n: TGLsizei; const buffers: PGLuint); stdcall;
PFNGLDELETEFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;
PFNGLDELETEFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;
PFNGLDELETEFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;
PFNGLDELETEOBJECTARBPROC = procedure(obj: TGLhandleARB); stdcall;
PFNGLDELETEOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;
PFNGLDELETEPATHSNVPROC = procedure(path: Cardinal; range: TGLsizei); stdcall;
PFNGLDELETEPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;
PFNGLDELETEPROGRAMPROC = procedure(_program: Cardinal); stdcall;
PFNGLDELETEPROGRAMSARBPROC = procedure(n: TGLsizei; const programs: PGLuint); stdcall;
PFNGLDELETEPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;
PFNGLDELETEQUERIESARBPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;
PFNGLDELETEQUERIESPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;
PFNGLDELETERENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;
PFNGLDELETERENDERBUFFERSPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;
PFNGLDELETESAMPLERSPROC = procedure(count: TGLsizei; const samplers: PGLuint); stdcall;
PFNGLDELETESHADERPROC = procedure(shader: Cardinal); stdcall;
PFNGLDELETESYNCPROC = procedure(sync: TGLsync); stdcall;
PFNGLDELETETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;
PFNGLDELETETRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;
PFNGLDELETEVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;
PFNGLDEPTHBOUNDSEXTPROC = procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;
PFNGLDEPTHRANGEARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLclampd); stdcall;
PFNGLDEPTHRANGEFPROC = procedure(n: Single; f: Single); stdcall;
PFNGLDEPTHRANGEINDEXEDPROC = procedure(index: Cardinal; n: TGLclampd; f: TGLclampd); stdcall;
PFNGLDETACHOBJECTARBPROC = procedure(containerObj: TGLhandleARB; attachedObj: TGLhandleARB); stdcall;
PFNGLDETACHSHADERPROC = procedure(_program: Cardinal; shader: Cardinal); stdcall;
PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: Cardinal; index_: Cardinal); stdcall;
PFNGLDISABLEINDEXEDEXTPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLDISABLEIPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLDISABLEVERTEXATTRIBARRAYARBPROC = procedure(index: Cardinal); stdcall;
PFNGLDISABLEVERTEXATTRIBARRAYPROC = procedure(index: Cardinal); stdcall;
PFNGLDispatchCompute = procedure(num_groups_x : Cardinal; num_groups_y : Cardinal; num_groups_z : Cardinal); stdcall;
PFNGLDispatchComputeIndirect = procedure(indirect : TGLintptr); stdcall;
PFNGLDRAWARRAYSINDIRECTPROC = procedure(mode: Cardinal; const indirect: PGLvoid); stdcall;
PFNGLDRAWARRAYSINSTANCEDARBPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;
PFNGLDRAWARRAYSINSTANCEDEXTPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;
PFNGLDRAWARRAYSINSTANCEDPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;
PFNGLDRAWBUFFERSARBPROC = procedure (n: TGLsizei; const bufs: PCardinal); stdcall;
PFNGLDRAWBUFFERSATIPROC = procedure(n: TGLsizei; const bufs: PCardinal); stdcall;
PFNGLDRAWBUFFERSPROC = procedure(n: TGLsizei; const bufs: PCardinal); stdcall;
PFNGLDRAWELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;
PFNGLDRAWELEMENTSINDIRECTPROC = procedure(mode: Cardinal; _type: Cardinal; const indirect: PGLvoid); stdcall;
PFNGLDRAWELEMENTSINSTANCEDARBPROC = procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;
PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;
PFNGLDRAWELEMENTSINSTANCEDEXTPROC = procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;
PFNGLDRAWELEMENTSINSTANCEDPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;
PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; start: Cardinal; _end: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;
PFNGLDRAWRANGEELEMENTSEXTPROC = procedure(mode: Cardinal; start, Aend: Cardinal; Count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;
PFNGLDRAWRANGEELEMENTSPROC = procedure(mode: Cardinal; Astart, Aend: Cardinal; count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;
PFNGLDRAWTRANSFORMFEEDBACKPROC = procedure(mode: Cardinal; id: Cardinal); stdcall;
PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC = procedure(mode: Cardinal; id: Cardinal; stream: Cardinal); stdcall;
PFNGLEDGEFLAGFORMATNVPROC = procedure(stride: TGLsizei); stdcall;
PFNGLENABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: Cardinal; index_: Cardinal); stdcall;
PFNGLENABLEINDEXEDEXTPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLENABLEIPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLENABLEVERTEXATTRIBARRAYARBPROC = procedure(index: Cardinal); stdcall;
PFNGLENABLEVERTEXATTRIBARRAYPROC = procedure(index: Cardinal); stdcall;
PFNGLENDCONDITIONALRENDERNVPROC = procedure(); stdcall;
PFNGLENDCONDITIONALRENDERPROC = procedure(); stdcall;
PFNGLENDOCCLUSIONQUERYNVPROC = procedure; stdcall;
PFNGLENDQUERYARBPROC = procedure(target: Cardinal); stdcall;
PFNGLENDQUERYINDEXEDPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLENDQUERYPROC = procedure(target: Cardinal); stdcall;
PFNGLENDSCENEEXTPROC = procedure; stdcall;
PFNGLENDTRANSFORMFEEDBACKEXTPROC = procedure(); stdcall;
PFNGLENDTRANSFORMFEEDBACKNVPROC = procedure(); stdcall;
PFNGLENDTRANSFORMFEEDBACKPROC = procedure(); stdcall;
PFNGLEXECUTEPROGRAMNVPROC = procedure(target: Cardinal; id: Cardinal; params: PGLfloat); stdcall;
PFNGLFENCESYNCPROC = function(condition: Cardinal; flags: TGLbitfield): TGLsync; stdcall;
PFNGLFINALCOMBINERINPUTNVPROC = procedure(variable, input, mapping, componentUsage: Cardinal); stdcall;
PFNGLFINISHFENCENVPROC = procedure(fence: Cardinal); stdcall;
PFNGLFLUSHMAPPEDBUFFERRANGEPROC = procedure( target: Cardinal; offset: TGLint; length: TGLsizei ); stdcall;
PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; length: TGLsizeiptr); stdcall;
PFNGLFLUSHVERTEXARRAYRANGENVPROC = procedure; stdcall;
PFNGLFOGCOORDDEXTPROC = procedure(coord: TGLdouble); stdcall;
PFNGLFOGCOORDDPROC = procedure(coord: TGLdouble); stdcall;
PFNGLFOGCOORDDVEXTPROC = procedure(coord: PGLdouble); stdcall;
PFNGLFOGCOORDDVPROC = procedure(coord: PGLdouble); stdcall;
PFNGLFOGCOORDFEXTPROC = procedure(coord: TGLfloat); stdcall;
PFNGLFOGCOORDFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;
PFNGLFOGCOORDFPROC = procedure(coord: TGLfloat); stdcall;
PFNGLFOGCOORDFVEXTPROC = procedure(coord: PGLfloat); stdcall;
PFNGLFOGCOORDFVPROC = procedure(coord: PGLfloat); stdcall;
PFNGLFOGCOORDPOINTEREXTPROC = procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;
PFNGLFOGCOORDPOINTERPROC = procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;
PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC = procedure(framebuffer: Cardinal; mode: Cardinal); stdcall;
PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC = procedure(framebuffer: Cardinal; n: TGLsizei; const bufs: PCardinal); stdcall;
PFNGLFramebufferParameteri = procedure(target : Cardinal; pname : Cardinal; param : TGLint); stdcall;
PFNGLFRAMEBUFFERREADBUFFEREXTPROC = procedure(framebuffer: Cardinal; mode: Cardinal); stdcall;
PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLFRAMEBUFFERRENDERBUFFERPROC = procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLFRAMEBUFFERTEXTURE1DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE1DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE2DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE2DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE3DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; zoffset: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE3DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTUREARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTUREEXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTUREFACEARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; face:Cardinal); stdcall;
PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; face:Cardinal); stdcall;
PFNGLFRAMEBUFFERTEXTURELAYERARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; layer:TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; layer:TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURELAYERPROC = procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTUREPROC = procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMETERMINATORGREMEDYPROC = procedure(); stdcall;
PFNGLGENBUFFERSARBPROC = procedure(n: TGLsizei; buffers: PGLuint); stdcall;
PFNGLGENBUFFERSPROC = procedure(n: TGLsizei; buffers: PGLuint); stdcall;
PFNGLGENERATEMIPMAPEXTPROC = procedure(target: Cardinal); stdcall;
PFNGLGENERATEMIPMAPPROC = procedure(target: Cardinal); stdcall;
PFNGLGENERATEMULTITEXMIPMAPEXTPROC = procedure(texunit: Cardinal; target: Cardinal); stdcall;
PFNGLGENERATETEXTUREMIPMAPEXTPROC = procedure(texture: Cardinal; target: Cardinal); stdcall;
PFNGLGENFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;
PFNGLGENFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;
PFNGLGENFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;
PFNGLGENOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;
PFNGLGENPATHSNVPROC = function (range: TGLsizei): Cardinal; stdcall;
PFNGLGENPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;
PFNGLGENPROGRAMSARBPROC = procedure(n: TGLsizei; programs: PGLuint); stdcall;
PFNGLGENPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;
PFNGLGENQUERIESARBPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;
PFNGLGENQUERIESPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;
PFNGLGENRENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;
PFNGLGENRENDERBUFFERSPROC = procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;
PFNGLGENSAMPLERSPROC = procedure(count: TGLsizei; samplers: PGLuint); stdcall;
PFNGLGENTEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;
PFNGLGENTRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;
PFNGLGENVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;
PFNGLGETACTIVEATTRIBARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; maxLength: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETACTIVEATTRIBPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETACTIVESUBROUTINENAMEPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; bufsize: TGLsizei; length: PGLsizei; name: PAnsiChar); stdcall;
PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; pname: Cardinal; values: PGLint); stdcall;
PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; bufsize: TGLsizei; length: PGLsizei; name: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; maxLength: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMBLOCKIVPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMNAMEPROC = procedure(_program: Cardinal; uniformIndex: Cardinal; bufSize: TGLsizei; length: PGLsizei; uniformName: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMSIVPROC = procedure(_program: Cardinal; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETACTIVEVARYINGNVPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: Cardinal; name: PAnsiChar); stdcall;
PFNGLGETATTACHEDOBJECTSARBPROC = procedure(containerObj: TGLhandleARB; maxCount: TGLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;
PFNGLGETATTACHEDSHADERSPROC = procedure(_program: Cardinal; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;
PFNGLGETATTRIBLOCATIONARBPROC = function(programObj: TGLhandleARB; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETATTRIBLOCATIONPROC = function(_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETBOOLEANINDEXEDVEXTPROC = procedure(value: Cardinal; index: Cardinal; data: PGLboolean); stdcall;
PFNGLGETBOOLEANI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLboolean); stdcall;
PFNGLGETBUFFERPARAMETERI64VPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint64); stdcall;
PFNGLGETBUFFERPARAMETERIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETBUFFERPARAMETERIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETBUFFERPARAMETERUI64VNVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint64EXT ); stdcall;
PFNGLGETBUFFERPOINTERVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: Pointer); stdcall;
PFNGLGETBUFFERPOINTERVPROC = procedure(target: Cardinal; pname: Cardinal; params: Pointer); stdcall;
PFNGLGETBUFFERSUBDATAARBPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; data: Pointer); stdcall;
PFNGLGETBUFFERSUBDATAPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; data: Pointer); stdcall;
PFNGLGETCOLORTABLEEXTPROC = procedure(target, format, atype: Cardinal; data: Pointer); stdcall;
PFNGLGETCOLORTABLEPARAMETERFVEXTPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCOLORTABLEPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCOLORTABLEPARAMETERIVEXTPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETCOLORTABLEPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETCOLORTABLEPROC = procedure(target, format, Atype: Cardinal; table: Pointer); stdcall;
PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC = procedure(stage, portion, variable, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC = procedure(stage, portion, variable, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC = procedure(stage, portion, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC = procedure(stage, portion, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC = procedure(texunit: Cardinal; target: Cardinal; lod: TGLint; img: PGLvoid); stdcall;
PFNGLGETCOMPRESSEDTEXIMAGEARBPROC = procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;
PFNGLGETCOMPRESSEDTEXIMAGEPROC = procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;
PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC = procedure(texture: Cardinal; target: Cardinal; lod: TGLint; img: PGLvoid); stdcall;
PFNGLGETCONVOLUTIONFILTERPROC = procedure(target, internalformat, Atype: Cardinal; image: Pointer); stdcall;
PFNGLGETCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETDEBUGMESSAGELOGARBPROC = function(count: Cardinal; bufsize: TGLsizei; sources: PCardinal; types: PCardinal; ids: PGLuint; severities: PCardinal; lengths: PGLsizei; messageLog: PAnsiChar): Cardinal; stdcall;
PFNGLGETDOUBLEINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLdouble); stdcall;
PFNGLGETDOUBLEI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLdouble); stdcall;
PFNGLGETFENCEIVNVPROC = procedure(fence: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC = procedure(variable, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC = procedure(variable, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETFLOATINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLfloat); stdcall;
PFNGLGETFLOATI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLfloat); stdcall;
PFNGLGETFRAGDATAINDEXPROC = function (_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETFRAGDATALOCATIONEXTPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;
PFNGLGETFRAGDATALOCATIONPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;
PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC = procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGetFramebufferParameteriv = procedure(target : Cardinal; pname : Cardinal; params : PGLint); stdcall;
PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC = procedure(framebuffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETGRAPHICSRESETSTATUSARBPROC = function(): Cardinal; stdcall;
PFNGLGETHANDLEARBPROC = function(pname: Cardinal): TGLhandleARB; stdcall;
PFNGLGETHISTOGRAMPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETHISTOGRAMPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETHISTOGRAMPROC = procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;
PFNGLGETINFOLOGARBPROC = procedure(obj: TGLhandleARB; maxLength: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;
PFNGLGETINTEGER64I_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLint64); stdcall;
PFNGLGETINTEGER64VPROC = procedure(pname: Cardinal; params: PGLint64); stdcall;
PFNGLGETINTEGERINDEXEDVEXTPROC = procedure(value: Cardinal; index: Cardinal; data: PGLint); stdcall;
PFNGLGETINTEGERI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLint); stdcall;
PFNGLGETINTEGERUI64I_VNVPROC = procedure(value: Cardinal; index: Cardinal; result: PGLuint64EXT); stdcall;
PFNGLGETINTEGERUI64VNVPROC = procedure(value: Cardinal; result: PGLuint64EXT); stdcall;
PFNGLGetInternalformati64v = procedure(target : Cardinal; internalformat : Cardinal; pname : Cardinal; bufSize : TGLsizei; params : PGLint64); stdcall;
PFNGLGETMINMAXPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMINMAXPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMINMAXPROC = procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;
PFNGLGETMULTISAMPLEFVPROC = procedure(pname: Cardinal; index: Cardinal; val: PGLfloat); stdcall;
PFNGLGETMULTITEXENVFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMULTITEXENVIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMULTITEXGENDVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETMULTITEXGENFVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMULTITEXGENIVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMULTITEXIMAGEEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; format: Cardinal; type_: Cardinal; pixels: PGLvoid); stdcall;
PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMULTITEXPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMULTITEXPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETMULTITEXPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLuint64EXT); stdcall;
PFNGLGETNAMEDBUFFERPOINTERVEXTPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLvoid); stdcall;
PFNGLGETNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr; data: PGLvoid); stdcall;
PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGetNamedFramebufferParameteriv = procedure(framebuffer : Cardinal; pname : Cardinal; param : TGLint); stdcall;
PFNGLGETNAMEDPROGRAMIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLdouble); stdcall;
PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLfloat); stdcall;
PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLint); stdcall;
PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLuint); stdcall;
PFNGLGETNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: Cardinal; target: Cardinal; pname: Cardinal; string_: PGLvoid); stdcall;
PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC = procedure(renderbuffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETNCOLORTABLEARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; table: Pointer); stdcall;
PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC = procedure(target: Cardinal; lod: TGLint; bufSize: TGLsizei; img: Pointer); stdcall;
PFNGLGETNCONVOLUTIONFILTERARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; image: Pointer); stdcall;
PFNGLGETNHISTOGRAMARBPROC = procedure(target: Cardinal; reset: TGLboolean; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; values: Pointer); stdcall;
PFNGLGETNMAPDVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLdouble); stdcall;
PFNGLGETNMAPFVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLfloat); stdcall;
PFNGLGETNMAPIVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLint); stdcall;
PFNGLGETNMINMAXARBPROC = procedure(target: Cardinal; reset: TGLboolean; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; values: Pointer); stdcall;
PFNGLGETNPIXELMAPFVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLfloat); stdcall;
PFNGLGETNPIXELMAPUIVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLuint); stdcall;
PFNGLGETNPIXELMAPUSVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLushort); stdcall;
PFNGLGETNPOLYGONSTIPPLEARBPROC = procedure(bufSize: TGLsizei; pattern: PGLubyte); stdcall;
PFNGLGETNSEPARABLEFILTERARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; rowBufSize: TGLsizei; row: Pointer; columnBufSize: TGLsizei; column: Pointer; span: Pointer); stdcall;
PFNGLGETNTEXIMAGEARBPROC = procedure(target: Cardinal; level: TGLint; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; img: Pointer); stdcall;
PFNGLGETNUNIFORMDVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLdouble); stdcall;
PFNGLGETNUNIFORMFVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLfloat); stdcall;
PFNGLGETNUNIFORMIVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLint); stdcall;
PFNGLGETNUNIFORMUIVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLuint); stdcall;
PFNGLGetObjectLabel = procedure(identifier : Cardinal; name : Cardinal; bufsize : TGLsizei; length : PGLsizei; label_ : PAnsiChar); stdcall;
PFNGLGETOBJECTPARAMETERFVARBPROC = procedure(obj: TGLhandleARB; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETOBJECTPARAMETERIVARBPROC = procedure(obj: TGLhandleARB; pname: Cardinal; params: PGLint); stdcall;
PFNGLGetObjectPtrLabel = procedure(const ptr : Pointer; bufSize : TGLsizei; length : PGLsizei; label_ : PAnsiChar); stdcall;
PFNGLGETOCCLUSIONQUERYIVNVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETOCCLUSIONQUERYUIVNVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETPATHCOLORGENFVNVPROC = procedure (color: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;
PFNGLGETPATHCOLORGENIVNVPROC = procedure (color: Cardinal; pname: Cardinal; value: PGLint); stdcall;
PFNGLGETPATHCOMMANDSNVPROC = procedure (path: Cardinal; commands: PGLubyte); stdcall;
PFNGLGETPATHCOORDSNVPROC = procedure (path: Cardinal; coords: PGLfloat); stdcall;
PFNGLGETPATHDASHARRAYNVPROC = procedure (path: Cardinal; dashArray: PGLfloat); stdcall;
PFNGLGETPATHLENGTHNVPROC = function (path: Cardinal; startSegment: TGLsizei; numSegments: TGLsizei): TGLfloat; stdcall;
PFNGLGETPATHMETRICRANGENVPROC = procedure (metricQueryMask: TGLbitfield; firstPathName: Cardinal; numPaths: TGLsizei; stride: TGLsizei; metrics: PGLfloat); stdcall;
PFNGLGETPATHMETRICSNVPROC = procedure (metricQueryMask: TGLbitfield; numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; stride: TGLsizei; metrics: PGLfloat); stdcall;
PFNGLGETPATHPARAMETERFVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;
PFNGLGETPATHPARAMETERIVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLint); stdcall;
PFNGLGETPATHSPACINGNVPROC = procedure (pathListMode: Cardinal; numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; advanceScale: TGLfloat; kerningScale: TGLfloat; transformType: Cardinal; returnedSpacing: PGLfloat); stdcall;
PFNGLGETPATHTEXGENFVNVPROC = procedure (texCoordSet: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;
PFNGLGETPATHTEXGENIVNVPROC = procedure (texCoordSet: Cardinal; pname: Cardinal; value: PGLint); stdcall;
PFNGLGETPOINTERINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLvoid); stdcall;
PFNGLGETPROGRAMBINARYPROC = procedure(_program: Cardinal; bufSize: TGLsizei; length: PGLsizei; binaryFormat: PCardinal; binary: Pointer); stdcall;
PFNGLGETPROGRAMENVPARAMETERDVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLdouble); stdcall;
PFNGLGETPROGRAMENVPARAMETERFVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLfloat); stdcall;
PFNGLGETPROGRAMINFOLOGPROC = procedure(_program: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;
PFNGLGetProgramInterfaceiv = procedure(program_ : Cardinal;programInterface : Cardinal; pname : Cardinal; params : PGLint); stdcall;
PFNGLGETPROGRAMIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETPROGRAMIVNVPROC = procedure (id: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETPROGRAMIVPROC = procedure(_program: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLdouble); stdcall;
PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLfloat); stdcall;
PFNGLGETPROGRAMPARAMETERDVNVPROC = procedure (target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETPROGRAMPARAMETERFVNVPROC = procedure (target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETPROGRAMPIPELINEINFOLOGPROC = procedure(pipeline: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;
PFNGLGETPROGRAMPIPELINEIVPROC = procedure(pipeline: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGetProgramResourceIndex = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : Cardinal; stdcall;
PFNGLGetProgramResourceiv = procedure(program_ : Cardinal;programInterface : Cardinal; index : Cardinal; propCount : TGLsizei; const props : PCardinal; bufSize : TGLsizei; length : PGLsizei; params : PGLint); stdcall;
PFNGLGetProgramResourceLocation = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : TGLint; stdcall;
PFNGLGetProgramResourceLocationIndex = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : TGLint; stdcall;
PFNGLGetProgramResourceName = procedure(program_ : Cardinal;programInterface : Cardinal; index : Cardinal; bufSize : TGLsizei; length : PGLsizei; name : PAnsiChar); stdcall;
PFNGLGETPROGRAMSTAGEIVPROC = procedure(_program: Cardinal; shadertype: Cardinal; pname: Cardinal; values: PGLint); stdcall;
PFNGLGETPROGRAMSTRINGARBPROC = procedure(target: Cardinal; pname: Cardinal; _string: pointer); stdcall;
PFNGLGETPROGRAMSTRINGNVPROC = procedure (id: Cardinal; pname: Cardinal; programIdx: PGLubyte); stdcall;
PFNGLGETQUERYINDEXEDIVPROC = procedure(target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYOBJECTI64VEXTPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint64EXT); stdcall;
PFNGLGETQUERYOBJECTI64VPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint64); stdcall;
PFNGLGETQUERYOBJECTIVARBPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYOBJECTIVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYOBJECTUI64VEXTPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint64EXT); stdcall;
PFNGLGETQUERYOBJECTUI64VPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint64); stdcall;
PFNGLGETQUERYOBJECTUIVARBPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETQUERYOBJECTUIVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETRENDERBUFFERPARAMETERIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETSAMPLERPARAMETERFVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETSAMPLERPARAMETERIFVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETSAMPLERPARAMETERIIVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETSAMPLERPARAMETERIVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETSEPARABLEFILTERPROC = procedure(target, format, Atype: Cardinal; row, column, span: Pointer); stdcall;
PFNGLGETSHADERINFOLOGPROC = procedure(shader: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;
PFNGLGETSHADERIVPROC = procedure(shader: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETSHADERPRECISIONFORMATPROC = procedure(shadertype: Cardinal; precisiontype: Cardinal; range: PGLint; precision: PGLint); stdcall;
PFNGLGETSHADERSOURCEARBPROC = procedure(obj: TGLhandleARB; maxLength: TGLsizei; length: PGLsizei; source: PAnsiChar); stdcall;
PFNGLGETSHADERSOURCEPROC = procedure(shader:Cardinal; bufSize: TGLsizei; length: PGLsizei; source: PAnsiChar); stdcall;
PFNGLGETSTRINGIPROC = function(name: Cardinal; index: Cardinal): PAnsiChar; stdcall;
PFNGLGETSUBROUTINEINDEXPROC = function(_program: Cardinal; shadertype: Cardinal; const name: PAnsiChar): Cardinal; stdcall;
PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC = function(_program: Cardinal; shadertype: Cardinal; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETSYNCIVPROC = procedure(sync: TGLsync; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;
PFNGLGETTEXPARAMETERIIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTEXPARAMETERIIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTEXPARAMETERIUIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETTEXPARAMETERIUIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETTEXTUREIMAGEEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; format: Cardinal; type_: Cardinal; pixels: PGLvoid); stdcall;
PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: TGLint); stdcall;
PFNGLGETTEXTUREPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETTEXTUREPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETTEXTUREPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTRACKMATRIXIVNVPROC = procedure (target: Cardinal; address: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC = procedure(_program: Cardinal; index: Cardinal; location: PGLint); stdcall;
PFNGLGETTRANSFORMFEEDBACKVARYINGPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETUNIFORMBLOCKINDEXPROC = function(_program: Cardinal; uniformBlockName: PAnsiChar): Cardinal; stdcall;
PFNGLGETUNIFORMBUFFERSIZEEXTPROC = function(_program: Cardinal; location: TGLint): TGLint; stdcall;
PFNGLGETUNIFORMDVPROC = procedure(_program: Cardinal; location: TGLint; params : PGLdouble); stdcall;
PFNGLGETUNIFORMFVARBPROC = procedure(programObj: TGLhandleARB; location: TGLint; params: PGLfloat); stdcall;
PFNGLGETUNIFORMFVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLfloat); stdcall;
PFNGLGETUNIFORMINDICESPROC = procedure(_program: Cardinal; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;
PFNGLGETUNIFORMIVARBPROC = procedure(programObj: TGLhandleARB; location: TGLint; params: PGLint); stdcall;
PFNGLGETUNIFORMIVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLint); stdcall;
PFNGLGETUNIFORMLOCATIONARBPROC = function(programObj: TGLhandleARB; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETUNIFORMLOCATIONPROC = function(_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETUNIFORMOFFSETEXTPROC = function(_program: Cardinal; location: TGLint): PGLint; stdcall;
PFNGLGETUNIFORMSUBROUTINEUIVPROC = procedure(shadertype: Cardinal; location: TGLint; params: PGLuint); stdcall;
PFNGLGETUNIFORMUI64VNVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint64EXT); stdcall;
PFNGLGETUNIFORMUIVEXTPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint); stdcall;
PFNGLGETUNIFORMUIVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint); stdcall;
PFNGLGETVARYINGLOCATIONNVPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;
PFNGLGETVERTEXATTRIBDVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETVERTEXATTRIBDVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETVERTEXATTRIBDVPROC = procedure(index:Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETVERTEXATTRIBFVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETVERTEXATTRIBFVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETVERTEXATTRIBFVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETVERTEXATTRIBIIVEXTPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBIIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBIUIVEXTPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETVERTEXATTRIBIUIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETVERTEXATTRIBIVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBIVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBLDVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETVERTEXATTRIBPOINTERVARBPROC = procedure(index: Cardinal; pname: Cardinal; _pointer: pointer); stdcall;
PFNGLGETVERTEXATTRIBPOINTERVNVPROC = procedure (index: Cardinal; pname: Cardinal; pointer: PGLPointer); stdcall;
PFNGLGETVERTEXATTRIBPOINTERVPROC = procedure(index: Cardinal; pname: Cardinal; _pointer:pointer); stdcall;
PFNGLHISTOGRAMPROC = procedure(target: Cardinal; width: TGLsizei; internalformat: Cardinal; sink: TGLboolean); stdcall;
PFNGLINDEXFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;
PFNGLINDEXFUNCEXTPROC = procedure(func: Cardinal; ref: TGLfloat); stdcall;
PFNGLINDEXMATERIALEXTPROC = procedure(face: Cardinal; mode: Cardinal); stdcall;
PFNGLINTERPOLATEPATHSNVPROC = procedure (resultPath: Cardinal; pathA: Cardinal; pathB: Cardinal; weight: TGLfloat); stdcall;
PFNGLInvalidateBufferData = procedure(buffer : Cardinal); stdcall;
PFNGLInvalidateBufferSubData = procedure(buffer : Cardinal; offset : TGLintptr; length : TGLsizeiptr); stdcall;
PFNGLInvalidateFramebuffer = procedure(target : Cardinal; numAttachments : TGLsizei; const attachments : PCardinal); stdcall;
PFNGLInvalidateSubFramebuffer = procedure(target : Cardinal; numAttachments : TGLsizei; const attachments : PCardinal; x : TGLint; y : TGLint; width : TGLsizei; height : TGLsizei); stdcall;
PFNGLInvalidateTexImage = procedure(texture : Cardinal; level : TGLint); stdcall;
PFNGLInvalidateTexSubImage = procedure(texture : Cardinal; level : TGLint; xoffset : TGLint; yoffset : TGLint; zoffset : TGLint; width : TGLsizei; height : TGLsizei; depth : TGLsizei); stdcall;
PFNGLISBUFFERARBPROC = function(buffer: Cardinal): TGLboolean; stdcall;
PFNGLISBUFFERPROC = function(buffer: Cardinal): TGLboolean; stdcall;
PFNGLISBUFFERRESIDENTNVPROC = function(target: Cardinal): TGLboolean; stdcall;
PFNGLISENABLEDINDEXEDEXTPROC = function(target: Cardinal; index: Cardinal): TGLboolean; stdcall;
PFNGLISENABLEDIPROC = function(target: Cardinal; index: Cardinal): TGLboolean; stdcall;
PFNGLISFENCENVPROC = function(fence: Cardinal): TGLboolean; stdcall;
PFNGLISFRAMEBUFFEREXTPROC = function(framebuffer: Cardinal): TGLboolean; stdcall;
PFNGLISFRAMEBUFFERPROC = function(framebuffer: Cardinal): TGLboolean; stdcall;
PFNGLISNAMEDBUFFERRESIDENTNVPROC = function (buffer: Cardinal): TGLboolean; stdcall;
PFNGLISOCCLUSIONQUERYNVPROC = function(id: Cardinal): TGLboolean; stdcall;
PFNGLISPATHNVPROC = function(path: Cardinal): TGLboolean; stdcall;
PFNGLISPOINTINFILLPATHNVPROC = function (path: Cardinal; mask: Cardinal; x: TGLfloat; y: TGLfloat): TGLboolean; stdcall;
PFNGLISPOINTINSTROKEPATHNVPROC = function (path: Cardinal; x: TGLfloat; y: TGLfloat): TGLboolean; stdcall;
PFNGLISPROGRAMARBPROC = function(_program: Cardinal): TGLboolean; stdcall;
PFNGLISPROGRAMNVPROC = function (id: Cardinal): TGLboolean; stdcall;
PFNGLISPROGRAMPIPELINEPROC = function(pipeline: Cardinal): TGLboolean; stdcall;
PFNGLISPROGRAMPROC = function(_program: Cardinal):TGLboolean; stdcall;
PFNGLISQUERYARBPROC = function(id: Cardinal): TGLboolean; stdcall;
PFNGLISQUERYPROC = function(id: Cardinal): TGLboolean; stdcall;
PFNGLISRENDERBUFFEREXTPROC = function(renderbuffer: Cardinal): TGLboolean; stdcall;
PFNGLISRENDERBUFFERPROC = function(renderbuffer: Cardinal): TGLBoolean; stdcall;
PFNGLISSAMPLERPROC = function(sampler: Cardinal): TGLboolean; stdcall;
PFNGLISSHADERPROC = function(shader: Cardinal): TGLboolean; stdcall;
PFNGLISSYNCPROC = function(sync: TGLsync): TGLboolean; stdcall;
PFNGLISTEXTUREEXTPROC = function(texture: Cardinal): TGLboolean; stdcall;
PFNGLISTRANSFORMFEEDBACKPROC = function(id: Cardinal): TGLboolean; stdcall;
PFNGLISVERTEXARRAYPROC = function(_array: Cardinal): TGLboolean; stdcall;
PFNGLLINKPROGRAMARBPROC = procedure(programObj: TGLhandleARB); stdcall;
PFNGLLINKPROGRAMPROC = procedure(_program: Cardinal); stdcall;
PFNGLLOADPROGRAMNVPROC = procedure (target: Cardinal; id: Cardinal; len: TGLSizei; programIdx: PGLubyte); stdcall;
PFNGLLOADTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;
PFNGLLOADTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;
PFNGLLOADTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;
PFNGLLOADTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;
PFNGLLOCKARRAYSEXTPROC = procedure(first: TGLint; count: TGLsizei); stdcall;
PFNGLMAKEBUFFERNONRESIDENTNVPROC = procedure(target: Cardinal); stdcall;
PFNGLMAKEBUFFERRESIDENTNVPROC = procedure(target: Cardinal; access: Cardinal); stdcall;
PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC = procedure(buffer: Cardinal); stdcall;
PFNGLMAKENAMEDBUFFERRESIDENTNVPROC = procedure(buffer: Cardinal; access: Cardinal); stdcall;
PFNGLMAPBUFFERARBPROC = function(target: Cardinal; access: Cardinal): Pointer; stdcall;
PFNGLMAPBUFFERPROC = function(target: Cardinal; access: Cardinal): Pointer; stdcall;
PFNGLMAPBUFFERRANGEPROC = function(target: Cardinal; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;
PFNGLMAPNAMEDBUFFEREXTPROC = function(buffer: Cardinal; access: Cardinal): PGLvoid; stdcall;
PFNGLMAPNAMEDBUFFERRANGEEXTPROC = function(buffer: Cardinal; offset: TGLintptr; length: TGLsizeiptr; access: TGLbitfield): PGLvoid; stdcall;
PFNGLMATRIXFRUSTUMEXTPROC = procedure(mode: Cardinal; left: TGLdouble; right: TGLdouble; bottom: TGLdouble; top: TGLdouble; zNear: TGLdouble; zFar: TGLdouble); stdcall;
PFNGLMATRIXINDEXPOINTERARBPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer:pointer); stdcall;
PFNGLMATRIXINDEXUBVARBPROC = procedure(size: TGLint; indices: PGLubyte); stdcall;
PFNGLMATRIXINDEXUIVARBPROC = procedure(size: TGLint; indices: PGLuint); stdcall;
PFNGLMATRIXINDEXUSVARBPROC = procedure(size: TGLint; indices: PGLushort); stdcall;
PFNGLMATRIXLOADDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;
PFNGLMATRIXLOADFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;
PFNGLMATRIXLOADIDENTITYEXTPROC = procedure(mode: Cardinal); stdcall;
PFNGLMATRIXLOADTRANSPOSEDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;
PFNGLMATRIXLOADTRANSPOSEFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;
PFNGLMATRIXMULTDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;
PFNGLMATRIXMULTFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;
PFNGLMATRIXMULTTRANSPOSEDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;
PFNGLMATRIXMULTTRANSPOSEFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;
PFNGLMATRIXORTHOEXTPROC = procedure(mode: Cardinal; left: TGLdouble; right: TGLdouble; bottom: TGLdouble; top: TGLdouble; zNear: TGLdouble; zFar: TGLdouble); stdcall;
PFNGLMATRIXPOPEXTPROC = procedure(mode: Cardinal); stdcall;
PFNGLMATRIXPUSHEXTPROC = procedure(mode: Cardinal); stdcall;
PFNGLMATRIXROTATEDEXTPROC = procedure(mode: Cardinal; angle: TGLdouble; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLMATRIXROTATEFEXTPROC = procedure(mode: Cardinal; angle: TGLfloat; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLMATRIXSCALEDEXTPROC = procedure(mode: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLMATRIXSCALEFEXTPROC = procedure(mode: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLMATRIXTRANSLATEDEXTPROC = procedure(mode: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLMATRIXTRANSLATEFEXTPROC = procedure(mode: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLMINMAXPROC = procedure(target, internalformat: Cardinal; sink: TGLboolean); stdcall;
PFNGLMINSAMPLESHADINGARBPROC = procedure(value: Single); stdcall;
PFNGLMINSAMPLESHADINGPROC = procedure(value: Single); stdcall;
PFNGLMULTIDRAWARRAYSEXTPROC = procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;
PFNGLMultiDrawArraysIndirect = procedure(mode : Cardinal; const indirect : Pointer; drawcount : TGLsizei; stride : TGLsizei); stdcall;
PFNGLMULTIDRAWARRAYSPROC = procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;
PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; count: PGLsizei; _type: Cardinal; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;
PFNGLMULTIDRAWELEMENTSEXTPROC = procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;
PFNGLMultiDrawElementsIndirect = procedure(mode : Cardinal; type_ : Cardinal; const indirect : Pointer; drawcount : TGLsizei; stride : TGLsizei); stdcall;
PFNGLMULTIDRAWELEMENTSPROC = procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;
PFNGLMULTITEXBUFFEREXTPROC = procedure(texunit: Cardinal; target: Cardinal; interformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLMULTITEXCOORD1DARBPROC = procedure(target: Cardinal; s: TGLdouble); stdcall;
PFNGLMULTITEXCOORD1DPROC = procedure(target: Cardinal; s: TGLdouble); stdcall;
PFNGLMULTITEXCOORD1DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD1DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD1FARBPROC = procedure(target: Cardinal; s: TGLfloat); stdcall;
PFNGLMULTITEXCOORD1FPROC = procedure(target: Cardinal; s: TGLfloat); stdcall;
PFNGLMULTITEXCOORD1FVARBPROC = procedure(target: Cardinal; v: TGLfloat); stdcall;
PFNGLMULTITEXCOORD1FVPROC = procedure(target: Cardinal; v: TGLfloat); stdcall;
PFNGLMULTITEXCOORD1IARBPROC = procedure(target: Cardinal; s: TGLint); stdcall;
PFNGLMULTITEXCOORD1IPROC = procedure(target: Cardinal; s: TGLint); stdcall;
PFNGLMULTITEXCOORD1IVARBPROC = procedure(target: Cardinal; v: PGLInt); stdcall;
PFNGLMULTITEXCOORD1IVPROC = procedure(target: Cardinal; v: PGLInt); stdcall;
PFNGLMULTITEXCOORD1SARBPROC = procedure(target: Cardinal; s: TGLshort); stdcall;
PFNGLMULTITEXCOORD1SPROC = procedure(target: Cardinal; s: TGLshort); stdcall;
PFNGLMULTITEXCOORD1SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD1SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD2DARBPROC = procedure(target: Cardinal; s, t: TGLdouble); stdcall;
PFNGLMULTITEXCOORD2DPROC = procedure(target: Cardinal; s, t: TGLdouble); stdcall;
PFNGLMULTITEXCOORD2DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD2DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD2FARBPROC = procedure(target: Cardinal; s, t: TGLfloat); stdcall;
PFNGLMULTITEXCOORD2FPROC = procedure(target: Cardinal; s, t: TGLfloat); stdcall;
PFNGLMULTITEXCOORD2FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD2FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD2IARBPROC = procedure(target: Cardinal; s, t: TGLint); stdcall;
PFNGLMULTITEXCOORD2IPROC = procedure(target: Cardinal; s, t: TGLint); stdcall;
PFNGLMULTITEXCOORD2IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD2IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD2SARBPROC = procedure(target: Cardinal; s, t: TGLshort); stdcall;
PFNGLMULTITEXCOORD2SPROC = procedure(target: Cardinal; s, t: TGLshort); stdcall;
PFNGLMULTITEXCOORD2SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD2SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD3DARBPROC = procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;
PFNGLMULTITEXCOORD3DPROC = procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;
PFNGLMULTITEXCOORD3DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD3DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD3FARBPROC = procedure(target: Cardinal; s, t, r: TGLfloat); stdcall;
PFNGLMULTITEXCOORD3FPROC = procedure(target: Cardinal; s, t, r: TGLfloat); stdcall;
PFNGLMULTITEXCOORD3FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD3FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD3IARBPROC = procedure(target: Cardinal; s, t, r: TGLint); stdcall;
PFNGLMULTITEXCOORD3IPROC = procedure(target: Cardinal; s, t, r: TGLint); stdcall;
PFNGLMULTITEXCOORD3IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD3IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD3SARBPROC = procedure(target: Cardinal; s, t, r: TGLshort); stdcall;
PFNGLMULTITEXCOORD3SPROC = procedure(target: Cardinal; s, t, r: TGLshort); stdcall;
PFNGLMULTITEXCOORD3SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD3SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD4DARBPROC = procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;
PFNGLMULTITEXCOORD4DPROC = procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;
PFNGLMULTITEXCOORD4DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD4DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD4FARBPROC = procedure(target: Cardinal; s, t, r, q: TGLfloat); stdcall;
PFNGLMULTITEXCOORD4FPROC = procedure(target: Cardinal; s, t, r, q: TGLfloat); stdcall;
PFNGLMULTITEXCOORD4FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD4FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD4IARBPROC = procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;
PFNGLMULTITEXCOORD4IPROC = procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;
PFNGLMULTITEXCOORD4IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD4IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD4SARBPROC = procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;
PFNGLMULTITEXCOORD4SPROC = procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;
PFNGLMULTITEXCOORD4SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD4SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORDP1UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;
PFNGLMULTITEXCOORDP1UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;
PFNGLMULTITEXCOORDP2UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;
PFNGLMULTITEXCOORDP2UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;
PFNGLMULTITEXCOORDP3UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;
PFNGLMULTITEXCOORDP3UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;
PFNGLMULTITEXCOORDP4UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;
PFNGLMULTITEXCOORDP4UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;
PFNGLMULTITEXCOORDPOINTEREXTPROC = procedure(texunit: Cardinal; size: TGLint; type_: Cardinal; stride: TGLsizei; const pointer: PGLvoid); stdcall;
PFNGLMULTITEXENVFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;
PFNGLMULTITEXENVFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLMULTITEXENVIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLMULTITEXENVIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLMULTITEXGENDEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLdouble); stdcall;
PFNGLMULTITEXGENDVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLdouble); stdcall;
PFNGLMULTITEXGENFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;
PFNGLMULTITEXGENFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLMULTITEXGENIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLMULTITEXGENIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXPARAMETERFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;
PFNGLMULTITEXPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLMULTITEXPARAMETERIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLMULTITEXPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;
PFNGLMULTITEXPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLMULTITEXRENDERBUFFEREXTPROC = procedure(texunit: Cardinal; target: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; type_: Cardinal; const pixels:PGLvoid); stdcall;
PFNGLMULTTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;
PFNGLMULTTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;
PFNGLMULTTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;
PFNGLMULTTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;
PFNGLNAMEDBUFFERDATAEXTPROC = procedure(buffer: Cardinal; size: TGLsizei; const data: PGLvoid; usage: Cardinal); stdcall;
PFNGLNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr; const data: PGLvoid); stdcall;
PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC = procedure(readBuffer: Cardinal; writeBuffer: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLNamedFramebufferParameteri = procedure(framebuffer : Cardinal; pname : Cardinal; param : TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; zoffset: TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; face: Cardinal); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLdouble); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLfloat); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLuint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLfloat); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLuint); stdcall;
PFNGLNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: Cardinal; target: Cardinal; format: Cardinal; len: TGLsizei; const string_: PGLvoid); stdcall;
PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC = procedure(renderbuffer: Cardinal; interformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC = procedure(renderbuffer: Cardinal; coverageSamples: TGLsizei; colorSamples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(renderbuffer: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLNORMALFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;
PFNGLNORMALP3UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLNORMALP3UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLObjectLabel = procedure(identifier : Cardinal; name : Cardinal; length : TGLsizei; const label_ : PAnsiChar); stdcall;
PFNGLObjectPtrLabel = procedure(const ptr : Pointer; length : TGLsizei; const label_ : PAnsiChar); stdcall;
PFNGLPATCHPARAMETERFVPROC = procedure(pname: Cardinal; const values: PGLfloat); stdcall;
PFNGLPATCHPARAMETERIPROC = procedure(pname: Cardinal; value: TGLint); stdcall;
PFNGLPATHCOLORGENNVPROC = procedure (color: Cardinal; genMode: Cardinal; colorFormat: Cardinal; coeffs: PGLfloat); stdcall;
PFNGLPATHCOMMANDSNVPROC = procedure(path: Cardinal; numCommands: TGLsizei; commands: PGLubyte; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;
PFNGLPATHCOORDSNVPROC = procedure(path: Cardinal; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;
PFNGLPATHCOVERDEPTHFUNCNVPROC = procedure (func: Cardinal); stdcall;
PFNGLPATHDASHARRAYNVPROC = procedure (path: Cardinal; dashCount: TGLsizei; dashArray: PGLfloat); stdcall;
PFNGLPATHFOGGENNVPROC = procedure (genMode: Cardinal); stdcall;
PFNGLPATHGLYPHRANGENVPROC = procedure(firstPathName: Cardinal; fontTarget: Cardinal; fontName: PAnsiChar; fontStyle: TGLbitfield; firstGlyph: Cardinal; numGlyphs: TGLsizei; handleMissingGlyphs: Cardinal; pathParameterTemplate: Cardinal; emScale: TGLfloat); stdcall;
PFNGLPATHGLYPHSNVPROC = procedure(firstPathName: Cardinal; fontTarget: Cardinal; fontName: PGLvoid; fontStyle: TGLbitfield; numGlyphs: TGLsizei; _type: Cardinal; charcodes: PGLvoid; handleMissingGlyphs: Cardinal; pathParameterTemplate: Cardinal; emScale: TGLfloat); stdcall;
PFNGLPATHPARAMETERFNVPROC = procedure (path: Cardinal; pname: Cardinal; value: TGLfloat); stdcall;
PFNGLPATHPARAMETERFVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;
PFNGLPATHPARAMETERINVPROC = procedure (path: Cardinal; pname: Cardinal; value: TGLint); stdcall;
PFNGLPATHPARAMETERIVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLint); stdcall;
PFNGLPATHSTENCILDEPTHOFFSETNVPROC = procedure (factor: TGLfloat; units: TGLfloat); stdcall;
PFNGLPATHSTENCILFUNCNVPROC = procedure (func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;
PFNGLPATHSTRINGNVPROC = procedure(path: Cardinal; format: Cardinal; length: TGLsizei; pathString: PGLvoid); stdcall;
PFNGLPATHSUBCOMMANDSNVPROC = procedure(path: Cardinal; commandStart: TGLsizei; commandsToDelete: TGLsizei; numCommands: TGLsizei; commands: PGLubyte; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;
PFNGLPATHSUBCOORDSNVPROC = procedure(path: Cardinal; coordStart: TGLsizei; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;
PFNGLPATHTEXGENNVPROC = procedure (texCoordSet: Cardinal; genMode: Cardinal; components: TGLint; coeffs: PGLfloat); stdcall;
PFNGLPAUSETRANSFORMFEEDBACKPROC = procedure(); stdcall;
PFNGLPOINTALONGPATHNVPROC = function (path: Cardinal; startSegment: TGLsizei; numSegments: TGLsizei; distance: TGLfloat; x: PGLfloat; y: PGLfloat; tangentX: PGLfloat; tangentY: PGLfloat): TGLboolean; stdcall;
PFNGLPOINTPARAMETERFARBPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;
PFNGLPOINTPARAMETERFPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;
PFNGLPOINTPARAMETERFVARBPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;
PFNGLPOINTPARAMETERFVPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;
PFNGLPOINTPARAMETERINVPROC = procedure(pname: Cardinal; param: TGLint); stdcall;
PFNGLPOINTPARAMETERIPROC = procedure(pname: Cardinal; param: TGLint); stdcall;
PFNGLPOINTPARAMETERIVNVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;
PFNGLPOINTPARAMETERIVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;
PFNGLPOLYGONOFFSETEXTPROC = procedure(factor, bias: TGLfloat); stdcall;
PFNGLPopDebugGroup = procedure; stdcall;
PFNGLPRIMITIVERESTARTINDEXNVPROC = procedure(index: Cardinal); stdcall;
PFNGLPRIMITIVERESTARTINDEXPROC = procedure(index: Cardinal); stdcall;
PFNGLPRIMITIVERESTARTNVPROC = procedure(); stdcall;
PFNGLPRIORITIZETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint; priorities: PSingle); stdcall;
PFNGLPROGRAMBINARYPROC = procedure(_program: Cardinal; binaryFormat: Cardinal; binary: Pointer; length: TGLsizei); stdcall;
PFNGLPROGRAMENVPARAMETER4DARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLPROGRAMENVPARAMETER4DVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLdouble); stdcall;
PFNGLPROGRAMENVPARAMETER4FARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLPROGRAMENVPARAMETER4FVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLfloat); stdcall;
PFNGLPROGRAMENVPARAMETERS4FVEXTPROC = procedure(target:Cardinal; index:Cardinal; count:TGLsizei; const params:PGLfloat); stdcall;
PFNGLPROGRAMLOCALPARAMETER4DARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLPROGRAMLOCALPARAMETER4DVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLdouble); stdcall;
PFNGLPROGRAMLOCALPARAMETER4FARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLPROGRAMLOCALPARAMETER4FVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLfloat); stdcall;
PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(target:Cardinal; index:Cardinal; count:TGLsizei; const params:PGLFloat); stdcall;
PFNGLPROGRAMPARAMETER4DNVPROC = procedure (target: Cardinal; index: Cardinal; x, y, z, w: TGLdouble); stdcall;
PFNGLPROGRAMPARAMETER4DVNVPROC = procedure (target: Cardinal; index: Cardinal; v: PGLdouble ); stdcall;
PFNGLPROGRAMPARAMETER4FNVPROC = procedure (target: Cardinal; index: Cardinal; x, y, z, w: TGLfloat); stdcall;
PFNGLPROGRAMPARAMETER4FVNVPROC = procedure (target: Cardinal; index: Cardinal; v: PGLfloat); stdcall;
PFNGLPROGRAMPARAMETERIARBPROC = procedure ( _program:Cardinal; pname:Cardinal; value: TGLint); stdcall;
PFNGLPROGRAMPARAMETERIEXTPROC = procedure ( _program:Cardinal; pname:Cardinal; value: TGLint); stdcall;
PFNGLPROGRAMPARAMETERIPROC = procedure(_program: Cardinal; pname: Cardinal; value: TGLint); stdcall;
PFNGLPROGRAMPARAMETERS4DVNVPROC = procedure (target: Cardinal; index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLPROGRAMPARAMETERS4FVNVPROC = procedure (target: Cardinal; index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLPROGRAMSTRINGARBPROC = procedure(target: Cardinal; format: Cardinal; len: TGLsizei; const _string: pointer); stdcall;
PFNGLPROGRAMUNIFORM1DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM1DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM1DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM1DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM1FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat); stdcall;
PFNGLPROGRAMUNIFORM1FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORM1IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint); stdcall;
PFNGLPROGRAMUNIFORM1IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLPROGRAMUNIFORM1UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal); stdcall;
PFNGLPROGRAMUNIFORM1UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;
PFNGLPROGRAMUNIFORM2DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM2DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM2FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;
PFNGLPROGRAMUNIFORM2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORM2IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint); stdcall;
PFNGLPROGRAMUNIFORM2IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLPROGRAMUNIFORM2UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal); stdcall;
PFNGLPROGRAMUNIFORM2UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;
PFNGLPROGRAMUNIFORM3DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM3DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM3FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;
PFNGLPROGRAMUNIFORM3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORM3IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;
PFNGLPROGRAMUNIFORM3IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLPROGRAMUNIFORM3UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;
PFNGLPROGRAMUNIFORM3UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;
PFNGLPROGRAMUNIFORM4DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM4DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble; v3: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM4FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;
PFNGLPROGRAMUNIFORM4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORM4IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;
PFNGLPROGRAMUNIFORM4IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLPROGRAMUNIFORM4UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;
PFNGLPROGRAMUNIFORM4UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMUI64NVPROC = procedure(_program: Cardinal; location: TGLint; value: TGLuint64EXT); stdcall;
PFNGLPROGRAMUNIFORMUI64VNVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;
PFNGLPROGRAMVERTEXLIMITNVPROC = procedure (target: Cardinal; limit: TGLint); stdcall;
PFNGLPROVOKINGVERTEXPROC = procedure(mode: Cardinal); stdcall;
PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: TGLbitfield); stdcall;
PFNGLPushDebugGroup = procedure(source : Cardinal; id : Cardinal; length : TGLsizei; const message_ : PAnsiChar); stdcall;
PFNGLQUERYCOUNTERPROC = procedure(id: Cardinal; target: Cardinal); stdcall;
PFNGLREADNPIXELSARBPROC = procedure(x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; data: Pointer); stdcall;
PFNGLRELEASESHADERCOMPILERPROC = procedure(); stdcall;
PFNGLRENDERBUFFERSTORAGEEXTPROC = procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLRENDERBUFFERSTORAGEPROC = procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLREQUESTRESIDENTPROGRAMSNVPROC = procedure (n: TGLSizei; programs: PGLuint); stdcall;
PFNGLRESETHISTOGRAMPROC = procedure(target: Cardinal); stdcall;
PFNGLRESETMINMAXPROC = procedure(target: Cardinal); stdcall;
PFNGLRESIZEBUFFERSMESAPROC = procedure; stdcall;
PFNGLRESUMETRANSFORMFEEDBACKPROC = procedure(); stdcall;
PFNGLSAMPLECOVERAGEARBPROC = procedure(Value: Single; invert: TGLboolean); stdcall;
PFNGLSAMPLECOVERAGEPROC = procedure(Value: Single; invert: TGLboolean); stdcall;
PFNGLSAMPLEMASKEXTPROC = procedure(Value: Single; invert: TGLboolean); stdcall;
PFNGLSAMPLEMASKIPROC = procedure(index: Cardinal; mask: TGLbitfield); stdcall;
PFNGLSAMPLEMASKSGISPROC = procedure(Value: Single; invert: TGLboolean); stdcall;
PFNGLSAMPLEPASSARBPROC = procedure(pass: Cardinal); stdcall;
PFNGLSAMPLEPATTERNEXTPROC = procedure(pattern: Cardinal); stdcall;
PFNGLSAMPLEPATTERNSGISPROC = procedure(pattern: Cardinal); stdcall;
PFNGLSAMPLERPARAMETERFPROC = procedure(sampler: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;
PFNGLSAMPLERPARAMETERFVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLSAMPLERPARAMETERIIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLSAMPLERPARAMETERIPROC = procedure(sampler: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLSAMPLERPARAMETERIUIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;
PFNGLSAMPLERPARAMETERIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLSCISSORARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLint); stdcall;
PFNGLSCISSORINDEXEDPROC = procedure(index: Cardinal; left: TGLint; bottom: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLSCISSORINDEXEDVPROC = procedure(index: Cardinal; v: PGLint); stdcall;
PFNGLSECONDARYCOLOR3BEXTPROC = procedure(red, green, blue: TGLbyte); stdcall;
PFNGLSECONDARYCOLOR3BPROC = procedure(red, green, blue: TGLbyte); stdcall;
PFNGLSECONDARYCOLOR3BVEXTPROC = procedure(v: PGLbyte); stdcall;
PFNGLSECONDARYCOLOR3BVPROC = procedure(v: PGLbyte); stdcall;
PFNGLSECONDARYCOLOR3DEXTPROC = procedure(red, green, blue: TGLdouble); stdcall;
PFNGLSECONDARYCOLOR3DPROC = procedure(red, green, blue: TGLdouble); stdcall;
PFNGLSECONDARYCOLOR3DVEXTPROC = procedure(v: PGLdouble); stdcall;
PFNGLSECONDARYCOLOR3DVPROC = procedure(v: PGLdouble); stdcall;
PFNGLSECONDARYCOLOR3FEXTPROC = procedure(red, green, blue: TGLfloat); stdcall;
PFNGLSECONDARYCOLOR3FPROC = procedure(red, green, blue: TGLfloat); stdcall;
PFNGLSECONDARYCOLOR3FVEXTPROC = procedure(v: PGLfloat); stdcall;
PFNGLSECONDARYCOLOR3FVPROC = procedure(v: PGLfloat); stdcall;
PFNGLSECONDARYCOLOR3IEXTPROC = procedure(red, green, blue: TGLint); stdcall;
PFNGLSECONDARYCOLOR3IPROC = procedure(red, green, blue: TGLint); stdcall;
PFNGLSECONDARYCOLOR3IVEXTPROC = procedure(v: PGLint); stdcall;
PFNGLSECONDARYCOLOR3IVPROC = procedure(v: PGLint); stdcall;
PFNGLSECONDARYCOLOR3SEXTPROC = procedure(red, green, blue: TGLshort); stdcall;
PFNGLSECONDARYCOLOR3SPROC = procedure(red, green, blue: TGLshort); stdcall;
PFNGLSECONDARYCOLOR3SVEXTPROC = procedure(v: PGLshort); stdcall;
PFNGLSECONDARYCOLOR3SVPROC = procedure(v: PGLshort); stdcall;
PFNGLSECONDARYCOLOR3UBEXTPROC = procedure(red, green, blue: TGLubyte); stdcall;
PFNGLSECONDARYCOLOR3UBPROC = procedure(red, green, blue: TGLubyte); stdcall;
PFNGLSECONDARYCOLOR3UBVEXTPROC = procedure(v: PGLubyte); stdcall;
PFNGLSECONDARYCOLOR3UBVPROC = procedure(v: PGLubyte); stdcall;
PFNGLSECONDARYCOLOR3UIEXTPROC = procedure(red, green, blue: Cardinal); stdcall;
PFNGLSECONDARYCOLOR3UIPROC = procedure(red, green, blue: Cardinal); stdcall;
PFNGLSECONDARYCOLOR3UIVEXTPROC = procedure(v: PGLuint); stdcall;
PFNGLSECONDARYCOLOR3UIVPROC = procedure(v: PGLuint); stdcall;
PFNGLSECONDARYCOLOR3USEXTPROC = procedure(red, green, blue: TGLushort); stdcall;
PFNGLSECONDARYCOLOR3USPROC = procedure(red, green, blue: TGLushort); stdcall;
PFNGLSECONDARYCOLOR3USVEXTPROC = procedure(v: PGLushort); stdcall;
PFNGLSECONDARYCOLOR3USVPROC = procedure(v: PGLushort); stdcall;
PFNGLSECONDARYCOLORFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLSECONDARYCOLORP3UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;
PFNGLSECONDARYCOLORP3UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;
PFNGLSECONDARYCOLORPOINTEREXTPROC = procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;
PFNGLSECONDARYCOLORPOINTERPROC = procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;
PFNGLSEPARABLEFILTER2DPROC = procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; row, column: Pointer); stdcall;
PFNGLSETFENCENVPROC = procedure(fence: Cardinal; condition: Cardinal); stdcall;
PFNGLSHADERBINARYPROC = procedure(count: TGLsizei; shaders: PGLuint; binaryformat: Cardinal; binary: Pointer; length: TGLsizei); stdcall;
PFNGLSHADERSOURCEARBPROC = procedure(shaderObj: TGLhandleARB; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;
PFNGLSHADERSOURCEPROC = procedure(shader: Cardinal; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;
PFNGLShaderStorageBlockBinding = procedure(program_ : Cardinal; storageBlockIndex : Cardinal; storageBlockBinding : Cardinal); stdcall;
PFNGLSTENCILCLEARTAGEXTPROC = procedure(stencilTagBits: TGLsizei; stencilClearTag: Cardinal); stdcall;
PFNGLSTENCILFILLPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; fillMode: Cardinal; mask: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLSTENCILFILLPATHNVPROC = procedure (path: Cardinal; fillMode: Cardinal; mask: Cardinal); stdcall;
PFNGLSTENCILFUNCSEPARATEPROC = procedure(face, func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;
PFNGLSTENCILMASKSEPARATEPROC = procedure(face: Cardinal; mask: Cardinal); stdcall;
PFNGLSTENCILOPSEPARATEPROC = procedure(face, sfail, dpfail, dppass: Cardinal); stdcall;
PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; reference: TGLint; mask: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLSTENCILSTROKEPATHNVPROC = procedure(path: Cardinal; reference: TGLint; mask: Cardinal); stdcall;
PFNGLSTRINGMARKERGREMEDYPROC = procedure(len: TGLsizei; str: PAnsiChar); stdcall;
PFNGLTBUFFERMASK3DFXPROC = procedure(mask: Cardinal); stdcall;
PFNGLTESSELLATIONFACTORAMDPROC = procedure(factor: TGLfloat); stdcall;
PFNGLTESSELLATIONMODEAMDPROC = procedure(mode: Cardinal); stdcall;
PFNGLTESTFENCENVPROC = function(fence: Cardinal): TGLboolean; stdcall;
PFNGLTEXBUFFERARBPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLTEXBUFFEREXTPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLTEXBUFFERPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLTexBufferRange = procedure(target : Cardinal; internalformat : Cardinal; buffer : Cardinal; offset: TGLintptr; size : TGLsizeiptr); stdcall;
PFNGLTEXCOORDFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLTEXCOORDP1UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLTEXCOORDP1UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLTEXCOORDP2UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLTEXCOORDP2UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLTEXCOORDP3UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLTEXCOORDP3UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLTEXCOORDP4UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLTEXCOORDP4UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLTEXIMAGE2DMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;
PFNGLTEXIMAGE3DEXTPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; Format, AType: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXIMAGE3DMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;
PFNGLTEXIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXPARAMETERIIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLTEXPARAMETERIIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLTEXPARAMETERIUIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLTEXPARAMETERIUIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLTexStorage2DMultisample = procedure(target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;
PFNGLTexStorage3DMultisample = procedure(target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; depth : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;
PFNGLTEXSUBIMAGE1DEXTPROC = procedure(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXSUBIMAGE2DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXSUBIMAGE3DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXTUREBUFFEREXTPROC = procedure(texture: Cardinal; target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLTextureBufferRange = procedure(texture : Cardinal; target : Cardinal; internalformat : Cardinal; buffer : Cardinal; offset : TGLintptr; size : TGLsizeiptr); stdcall;
PFNGLTEXTURECOLORMASKSGISPROC = procedure(red, green, blue, alpha: TGLboolean); stdcall;
PFNGLTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTUREIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTUREPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLTEXTUREPARAMETERIEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLTEXTUREPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;
PFNGLTEXTUREPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLTEXTURERENDERBUFFEREXTPROC = procedure(texture: Cardinal; target: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLTextureStorage2DMultisample = procedure(texture : Cardinal; target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;
PFNGLTextureStorage3DMultisample = procedure(texture : Cardinal; target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; depth : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;
PFNGLTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTextureView = procedure(texture : Cardinal; target : Cardinal; origtexture : Cardinal; internalformat : Cardinal; minlevel : Cardinal; numlevels : Cardinal; minlayer : Cardinal; numlayers : Cardinal); stdcall;
PFNGLTRACKMATRIXNVPROC = procedure (target: Cardinal; address: Cardinal; matrix: Cardinal; transform: Cardinal); stdcall;
PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC = procedure(count: TGLsizei; attribs: PGLint; bufferMode: Cardinal); stdcall;
PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC = procedure(_program: Cardinal; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;
PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC = procedure(_program: Cardinal; count: TGLsizei; locations: PGLint; bufferMode: Cardinal); stdcall;
PFNGLTRANSFORMFEEDBACKVARYINGSPROC = procedure(_program: Cardinal; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;
PFNGLTRANSFORMPATHNVPROC = procedure ( resultPath: Cardinal; srcPath: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLUDELETENURBSTESSELLATOREXTPROC = procedure(nurb: PGLUnurbs); stdcall;
PFNGLUNEWNURBSTESSELLATOREXTPROC = function: PGLUnurbs; stdcall;
PFNGLUNIFORM1DPROC = procedure(location: TGLint; x: TGLdouble); stdcall;
PFNGLUNIFORM1DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLUNIFORM1FARBPROC = procedure(location: TGLint; v0: TGLfloat); stdcall;
PFNGLUNIFORM1FPROC = procedure(location: TGLint; v0: TGLfloat); stdcall;
PFNGLUNIFORM1FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM1FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM1IARBPROC = procedure(location: TGLint; v0: TGLint); stdcall;
PFNGLUNIFORM1IPROC = procedure(location: TGLint; v0: TGLint); stdcall;
PFNGLUNIFORM1IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM1IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM1UIEXTPROC = procedure(location: TGLInt; v0: Cardinal); stdcall;
PFNGLUNIFORM1UIPROC = procedure(location: TGLInt; v0: Cardinal); stdcall;
PFNGLUNIFORM1UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM1UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM2DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLUNIFORM2DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLUNIFORM2FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;
PFNGLUNIFORM2FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;
PFNGLUNIFORM2FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM2FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM2IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint); stdcall;
PFNGLUNIFORM2IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint); stdcall;
PFNGLUNIFORM2IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM2IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM2UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal); stdcall;
PFNGLUNIFORM2UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal); stdcall;
PFNGLUNIFORM2UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM2UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM3DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLUNIFORM3DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLUNIFORM3FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;
PFNGLUNIFORM3FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;
PFNGLUNIFORM3FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM3FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM3IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;
PFNGLUNIFORM3IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;
PFNGLUNIFORM3IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM3IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM3UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;
PFNGLUNIFORM3UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;
PFNGLUNIFORM3UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM3UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM4DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLUNIFORM4DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLUNIFORM4FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;
PFNGLUNIFORM4FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;
PFNGLUNIFORM4FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM4FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM4IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;
PFNGLUNIFORM4IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;
PFNGLUNIFORM4IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM4IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM4UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;
PFNGLUNIFORM4UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;
PFNGLUNIFORM4UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM4UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORMBLOCKBINDINGPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; uniformBlockBinding: Cardinal); stdcall;
PFNGLUNIFORMBUFFEREXTPROC = procedure(_program: Cardinal; location: TGLint; buffer: Cardinal); stdcall;
PFNGLUNIFORMMATRIX2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX2FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX2X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX2X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX2X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX2X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX3FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX3X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX3X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX3X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX3X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX4FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX4X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX4X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX4X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX4X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMSUBROUTINESUIVPROC = procedure(shadertype: Cardinal; count: TGLsizei; const indices: PGLuint); stdcall;
PFNGLUNIFORMUI64NVPROC = procedure(location: TGLint; value: TGLuint64EXT); stdcall;
PFNGLUNIFORMUI64VNVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;
PFNGLUNLOCKARRAYSEXTPROC = procedure; stdcall;
PFNGLUNMAPBUFFERARBPROC = function(target: Cardinal): TGLboolean; stdcall;
PFNGLUNMAPBUFFERPROC = function(target: Cardinal): TGLboolean; stdcall;
PFNGLUNMAPNAMEDBUFFEREXTPROC = function(buffer: Cardinal): TGLboolean; stdcall;
PFNGLUNURBSCALLBACKDATAEXTPROC = procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;
PFNGLUSEPROGRAMOBJECTARBPROC = procedure(programObj: TGLhandleARB); stdcall;
PFNGLUSEPROGRAMPROC = procedure(_program: Cardinal); stdcall;
PFNGLUSEPROGRAMSTAGESPROC = procedure(pipeline: Cardinal; stages: TGLbitfield; _program: Cardinal); stdcall;
PFNGLVALIDATEPROGRAMARBPROC = procedure(programObj: TGLhandleARB); stdcall;
PFNGLVALIDATEPROGRAMPIPELINEPROC = procedure(pipeline: Cardinal); stdcall;
PFNGLVALIDATEPROGRAMPROC = procedure(_program: Cardinal); stdcall;
PFNGLVertexArrayBindVertexBuffer = procedure(vaobj : Cardinal; bindingindex : Cardinal; buffer : Cardinal; offset : TGLintptr; stride : TGLsizei); stdcall;
PFNGLVERTEXARRAYRANGENVPROC = procedure(Size: TGLsizei; p: pointer); stdcall;
PFNGLVertexArrayVertexAttribBinding = procedure(vaobj : Cardinal; attribindex : Cardinal; bindingindex : Cardinal); stdcall;
PFNGLVertexArrayVertexAttribFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; normalized : TGLboolean; relativeoffset : Cardinal); stdcall;
PFNGLVertexArrayVertexAttribIFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;
PFNGLVertexArrayVertexAttribLFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;
PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC = procedure (vaobj: Cardinal; buffer: Cardinal; index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; offset: TGLintptr); stdcall;
PFNGLVertexArrayVertexBindingDivisor = procedure(vaobj : Cardinal; bindingindex : Cardinal; divisor : Cardinal); stdcall;
PFNGLVERTEXATTRIB1DARBPROC = procedure(index: Cardinal; x: TGLdouble); stdcall;
PFNGLVERTEXATTRIB1DNVPROC = procedure (index: Cardinal; x: TGLdouble); stdcall;
PFNGLVERTEXATTRIB1DPROC = procedure(index:Cardinal; x: TGLdouble); stdcall;
PFNGLVERTEXATTRIB1DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB1DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB1DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB1FARBPROC = procedure(index: Cardinal; x: TGLfloat); stdcall;
PFNGLVERTEXATTRIB1FNVPROC = procedure (index: Cardinal; x: TGLfloat); stdcall;
PFNGLVERTEXATTRIB1FPROC = procedure(index:Cardinal; x: TGLfloat); stdcall;
PFNGLVERTEXATTRIB1FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB1FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB1FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB1SARBPROC = procedure(index: Cardinal; x: TGLshort); stdcall;
PFNGLVERTEXATTRIB1SNVPROC = procedure (index: Cardinal; x: TGLshort); stdcall;
PFNGLVERTEXATTRIB1SPROC = procedure(index:Cardinal; x: TGLshort); stdcall;
PFNGLVERTEXATTRIB1SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB1SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB1SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB2DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLVERTEXATTRIB2DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLVERTEXATTRIB2DPROC = procedure(index:Cardinal; x,y: TGLdouble); stdcall;
PFNGLVERTEXATTRIB2DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB2DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB2DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB2FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat); stdcall;
PFNGLVERTEXATTRIB2FNVPROC = procedure (index: Cardinal; x: TGLfloat; y: TGLfloat); stdcall;
PFNGLVERTEXATTRIB2FPROC = procedure(index:Cardinal; x,y: TGLfloat); stdcall;
PFNGLVERTEXATTRIB2FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB2FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB2FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB2SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort); stdcall;
PFNGLVERTEXATTRIB2SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort); stdcall;
PFNGLVERTEXATTRIB2SPROC = procedure(index:Cardinal; x,y: TGLshort); stdcall;
PFNGLVERTEXATTRIB2SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB2SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB2SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB3DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLVERTEXATTRIB3DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLVERTEXATTRIB3DPROC = procedure(index:Cardinal; x,y,z: TGLdouble); stdcall;
PFNGLVERTEXATTRIB3DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB3DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB3DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB3FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLVERTEXATTRIB3FNVPROC = procedure (index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLVERTEXATTRIB3FPROC = procedure(index:Cardinal; x,y,z: TGLfloat); stdcall;
PFNGLVERTEXATTRIB3FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB3FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB3FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB3SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;
PFNGLVERTEXATTRIB3SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;
PFNGLVERTEXATTRIB3SPROC = procedure(index:Cardinal; x,y,z: TGLshort); stdcall;
PFNGLVERTEXATTRIB3SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB3SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB3SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4BVARBPROC = procedure(index: Cardinal; const v: PGLbyte); stdcall;
PFNGLVERTEXATTRIB4BVPROC = procedure(index:Cardinal; v: PGLbyte); stdcall;
PFNGLVERTEXATTRIB4DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLVERTEXATTRIB4DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLVERTEXATTRIB4DPROC = procedure(index:Cardinal; x,y,z,w: TGLdouble); stdcall;
PFNGLVERTEXATTRIB4DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB4DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB4DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB4FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLVERTEXATTRIB4FNVPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLVERTEXATTRIB4FPROC = procedure(index:Cardinal; x,y,z,w: TGLfloat); stdcall;
PFNGLVERTEXATTRIB4FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB4FVNVPROC = procedure(index: Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB4FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB4IVARBPROC = procedure(index: Cardinal; const v: PGLint); stdcall;
PFNGLVERTEXATTRIB4IVPROC = procedure(index:Cardinal; v: PGLint); stdcall;
PFNGLVERTEXATTRIB4NBVARBPROC = procedure(index: Cardinal; const v: PGLbyte); stdcall;
PFNGLVERTEXATTRIB4NBVPROC = procedure(index:Cardinal; v: PGLbyte); stdcall;
PFNGLVERTEXATTRIB4NIVARBPROC = procedure(index: Cardinal; const v: PGLint); stdcall;
PFNGLVERTEXATTRIB4NIVPROC = procedure(index:Cardinal; v: PGLint); stdcall;
PFNGLVERTEXATTRIB4NSVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4NSVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4NUBARBPROC = procedure(index: Cardinal; x: TGLubyte; y: TGLubyte; z: TGLubyte; w: TGLubyte); stdcall;
PFNGLVERTEXATTRIB4NUBPROC = procedure(index:Cardinal; x,y,z,w: TGLubyte); stdcall;
PFNGLVERTEXATTRIB4NUBVARBPROC = procedure(index: Cardinal; const v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4NUBVPROC = procedure(index:Cardinal; v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4NUIVARBPROC = procedure(index: Cardinal; const v: PGLuint); stdcall;
PFNGLVERTEXATTRIB4NUIVPROC = procedure(index:Cardinal; v: PGLuint); stdcall;
PFNGLVERTEXATTRIB4NUSVARBPROC = procedure(index: Cardinal; const v: PGLushort); stdcall;
PFNGLVERTEXATTRIB4NUSVPROC = procedure(index:Cardinal; v: PGLushort); stdcall;
PFNGLVERTEXATTRIB4SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort; w: TGLshort); stdcall;
PFNGLVERTEXATTRIB4SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;
PFNGLVERTEXATTRIB4SPROC = procedure(index:Cardinal; x,y,z,w: TGLshort); stdcall;
PFNGLVERTEXATTRIB4SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4UBVARBPROC = procedure(index: Cardinal; const v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4UBVNVPROC = procedure (index: Cardinal; v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4UBVPROC = procedure(index:Cardinal; v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4UIVARBPROC = procedure(index: Cardinal; const v: PGLuint); stdcall;
PFNGLVERTEXATTRIB4UIVPROC = procedure(index:Cardinal; v: PGLuint); stdcall;
PFNGLVERTEXATTRIB4USVARBPROC = procedure(index: Cardinal; const v: PGLushort); stdcall;
PFNGLVERTEXATTRIB4USVPROC = procedure(index:Cardinal; v: PGLushort); stdcall;
PFNGLVertexAttribBinding = procedure(attribindex : Cardinal; bindingindex : Cardinal); stdcall;
PFNGLVERTEXATTRIBDIVISORARBPROC = procedure(index: Cardinal; divisor: Cardinal); stdcall;
PFNGLVERTEXATTRIBDIVISORPROC = procedure(index: Cardinal; divisor: Cardinal); stdcall;
PFNGLVertexAttribFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; normalized : TGLboolean; relativeoffset : Cardinal); stdcall;
PFNGLVERTEXATTRIBFORMATNVPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei); stdcall;
PFNGLVERTEXATTRIBI1IEXTPROC = procedure(index: Cardinal; x: TGLint); stdcall;
PFNGLVERTEXATTRIBI1IPROC = procedure(index: Cardinal; x: TGLint); stdcall;
PFNGLVERTEXATTRIBI1IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI1IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI1UIEXTPROC = procedure(index: Cardinal; x: Cardinal); stdcall;
PFNGLVERTEXATTRIBI1UIPROC = procedure(index: Cardinal; x: Cardinal); stdcall;
PFNGLVERTEXATTRIBI1UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI1UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI2IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint); stdcall;
PFNGLVERTEXATTRIBI2IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint); stdcall;
PFNGLVERTEXATTRIBI2IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI2IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI2UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal); stdcall;
PFNGLVERTEXATTRIBI2UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal); stdcall;
PFNGLVERTEXATTRIBI2UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI2UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI3IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint); stdcall;
PFNGLVERTEXATTRIBI3IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint); stdcall;
PFNGLVERTEXATTRIBI3IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI3IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI3UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal); stdcall;
PFNGLVERTEXATTRIBI3UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal); stdcall;
PFNGLVERTEXATTRIBI3UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI3UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI4BVEXTPROC = procedure(index: Cardinal; v:PGLbyte); stdcall;
PFNGLVERTEXATTRIBI4BVPROC = procedure(index: Cardinal; v:PGLbyte); stdcall;
PFNGLVERTEXATTRIBI4IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;
PFNGLVERTEXATTRIBI4IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;
PFNGLVERTEXATTRIBI4IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI4IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI4SVEXTPROC = procedure(index: Cardinal; v:PGLshort); stdcall;
PFNGLVERTEXATTRIBI4SVPROC = procedure(index: Cardinal; v:PGLshort); stdcall;
PFNGLVERTEXATTRIBI4UBVEXTPROC = procedure(index: Cardinal; v: PGLUbyte); stdcall;
PFNGLVERTEXATTRIBI4UBVPROC = procedure(index: Cardinal; v: PGLUbyte); stdcall;
PFNGLVERTEXATTRIBI4UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;
PFNGLVERTEXATTRIBI4UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;
PFNGLVERTEXATTRIBI4UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI4UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI4USVEXTPROC = procedure(index: Cardinal; v: PGLushort); stdcall;
PFNGLVERTEXATTRIBI4USVPROC = procedure(index: Cardinal; v: PGLushort); stdcall;
PFNGLVertexAttribIFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;
PFNGLVERTEXATTRIBIFORMATNVPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLVERTEXATTRIBIPOINTEREXTPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;
PFNGLVERTEXATTRIBIPOINTERPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;
PFNGLVERTEXATTRIBL1DPROC = procedure(index: Cardinal; x: TGLdouble); stdcall;
PFNGLVERTEXATTRIBL1DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBL2DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLVERTEXATTRIBL2DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBL3DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLVERTEXATTRIBL3DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBL4DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLVERTEXATTRIBL4DVPROC = procedure(index: Cardinal; v :PGLdouble); stdcall;
PFNGLVertexAttribLFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;
PFNGLVERTEXATTRIBLPOINTERPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; ptr: Pointer); stdcall;
PFNGLVERTEXATTRIBP1UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;
PFNGLVERTEXATTRIBP1UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;
PFNGLVERTEXATTRIBP2UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;
PFNGLVERTEXATTRIBP2UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;
PFNGLVERTEXATTRIBP3UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;
PFNGLVERTEXATTRIBP3UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;
PFNGLVERTEXATTRIBP4UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;
PFNGLVERTEXATTRIBP4UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;
PFNGLVERTEXATTRIBPOINTERARBPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei; const _pointer: pointer); stdcall;
PFNGLVERTEXATTRIBPOINTERNVPROC = procedure (index: Cardinal; fsize: TGLint; vertextype: Cardinal; stride: TGLSizei; pointer: Pointer); stdcall;
PFNGLVERTEXATTRIBPOINTERPROC = procedure(index:Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;
PFNGLVERTEXATTRIBS1DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBS1FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIBS1SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;
PFNGLVERTEXATTRIBS2DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBS2FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIBS2SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;
PFNGLVERTEXATTRIBS3DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBS3FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIBS3SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;
PFNGLVERTEXATTRIBS4DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBS4FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIBS4SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;
PFNGLVERTEXATTRIBS4UBVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLubyte); stdcall;
PFNGLVertexBindingDivisor = procedure(bindingindex : Cardinal; divisor : Cardinal); stdcall;
PFNGLVERTEXBLENDARBPROC = procedure(count: TGLint); stdcall;
PFNGLVERTEXFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLVERTEXP2UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;
PFNGLVERTEXP2UIVPROC = procedure(_type: Cardinal; const value: PGLuint ); stdcall;
PFNGLVERTEXP3UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;
PFNGLVERTEXP3UIVPROC = procedure(_type: Cardinal; const value: PGLuint); stdcall;
PFNGLVERTEXP4UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;
PFNGLVERTEXP4UIVPROC = procedure(_type: Cardinal; const value: PGLuint); stdcall;
PFNGLVIEWPORTARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLfloat); stdcall;
PFNGLVIEWPORTINDEXEDFPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; w: TGLfloat; h: TGLfloat); stdcall;
PFNGLVIEWPORTINDEXEDFVPROC = procedure(index: Cardinal; v: PGLfloat); stdcall;
PFNGLWAITSYNCPROC = procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;
PFNGLWEIGHTBVARBPROC = procedure(size: TGLint; weights: PGLbyte); stdcall;
PFNGLWEIGHTDVARBPROC = procedure(size: TGLint; weights: PGLdouble); stdcall;
PFNGLWEIGHTFVARBPROC = procedure(size: TGLint; weights: PGLfloat); stdcall;
PFNGLWEIGHTIVARBPROC = procedure(size: TGLint; weights: PGLint); stdcall;
PFNGLWEIGHTPATHSNVPROC = procedure (resultPath: Cardinal; numPaths: TGLsizei; paths: PGLuint; weights: PGLfloat); stdcall;
PFNGLWEIGHTPOINTERARBPROC = procedure(size: TGLint; _type: Cardinal; stride:TGLsizei; _pointer:pointer); stdcall;
PFNGLWEIGHTSVARBPROC = procedure(size: TGLint; weights: PGLshort); stdcall;
PFNGLWEIGHTUBVARBPROC = procedure(size: TGLint; weights: PGLubyte); stdcall;
PFNGLWEIGHTUIVARBPROC = procedure(size: TGLint; weights: PGLuint); stdcall;
PFNGLWEIGHTUSVARBPROC = procedure(size: TGLint; weights: PGLushort); stdcall;
PFNGLWINDOWPOS2DARBPROC = procedure(x,y : TGLdouble); stdcall;
PFNGLWINDOWPOS2DPROC = procedure(x,y : TGLdouble); stdcall;
PFNGLWINDOWPOS2DVARBPROC = procedure(v : PGLdouble); stdcall;
PFNGLWINDOWPOS2DVPROC = procedure(v : PGLdouble); stdcall;
PFNGLWINDOWPOS2FARBPROC = procedure(x,y : TGLfloat); stdcall;
PFNGLWINDOWPOS2FPROC = procedure(x,y : TGLfloat); stdcall;
PFNGLWINDOWPOS2FVARBPROC = procedure(v : PGLfloat); stdcall;
PFNGLWINDOWPOS2FVPROC = procedure(v : PGLfloat); stdcall;
PFNGLWINDOWPOS2IARBPROC = procedure(x,y : TGLint); stdcall;
PFNGLWINDOWPOS2IPROC = procedure(x,y : TGLint); stdcall;
PFNGLWINDOWPOS2IVARBPROC = procedure(v : PGLint); stdcall;
PFNGLWINDOWPOS2IVPROC = procedure(v : PGLint); stdcall;
PFNGLWINDOWPOS2SARBPROC = procedure(x,y : TGLshort); stdcall;
PFNGLWINDOWPOS2SPROC = procedure(x,y : TGLshort); stdcall;
PFNGLWINDOWPOS2SVARBPROC = procedure(v : PGLshort); stdcall;
PFNGLWINDOWPOS2SVPROC = procedure(v : PGLshort); stdcall;
PFNGLWINDOWPOS3DARBPROC = procedure(x,y,z : TGLdouble); stdcall;
PFNGLWINDOWPOS3DPROC = procedure(x,y,z : TGLdouble); stdcall;
PFNGLWINDOWPOS3DVARBPROC = procedure(v : PGLdouble); stdcall;
PFNGLWINDOWPOS3DVPROC = procedure(v : PGLdouble); stdcall;
PFNGLWINDOWPOS3FARBPROC = procedure(x,y,z : TGLfloat); stdcall;
PFNGLWINDOWPOS3FPROC = procedure(x,y,z : TGLfloat); stdcall;
PFNGLWINDOWPOS3FVARBPROC = procedure(v : PGLfloat); stdcall;
PFNGLWINDOWPOS3FVPROC = procedure(v : PGLfloat); stdcall;
PFNGLWINDOWPOS3IARBPROC = procedure(x,y,z : TGLint); stdcall;
PFNGLWINDOWPOS3IPROC = procedure(x,y,z : TGLint); stdcall;
PFNGLWINDOWPOS3IVARBPROC = procedure(v : PGLint); stdcall;
PFNGLWINDOWPOS3IVPROC = procedure(v : PGLint); stdcall;
PFNGLWINDOWPOS3SARBPROC = procedure(x,y,z : TGLshort); stdcall;
PFNGLWINDOWPOS3SPROC = procedure(x,y,z : TGLshort); stdcall;
PFNGLWINDOWPOS3SVARBPROC = procedure(v : PGLshort); stdcall;
PFNGLWINDOWPOS3SVPROC = procedure(v : PGLshort); stdcall;
PFNWGLALLOCATEMEMORYNVPROC = function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;
PFNWGLBINDTEXIMAGEARBPROC = function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;
PFNWGLCHOOSEPIXELFORMATARBPROC = function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: Cardinal; piFormats: PGLint; nNumFormats: PCardinal) : BOOL; stdcall;
PFNWGLCREATEAFFINITYDCNVPROC = function(hGpuList: PHGPUNV): HDC; stdcall;
PFNWGLCREATEBUFFERREGIONARBPROC = function(DC: HDC; iLayerPlane: Integer; uType: Cardinal) : Integer; stdcall;
PFNWGLCREATECONTEXTATTRIBSARBPROC = function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;
PFNWGLCREATEPBUFFERARBPROC = function(DC: HDC; iPixelFormat: TGLint; iWidth, iHeight : TGLint; const piAttribList: PGLint) : HPBUFFERARB; stdcall;
PFNWGLDELETEBUFFERREGIONARBPROC = procedure(hRegion: Integer); stdcall;
PFNWGLDELETEDCNVPROC = function(hdc: HDC): Boolean; stdcall;
PFNWGLDESTROYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB): BOOL; stdcall;
PFNWGLDXCLOSEDEVICEPROC = function(hDevice: THandle): BOOL; stdcall;
PFNWGLDXLOCKOBJECTSPROC = function(hDevice: THandle; count: TGLint; hObjects: PHandle): BOOL; stdcall;
PFNWGLDXOBJECTACCESSPROC = function(hObject: THandle; access: Cardinal): BOOL; stdcall;
PFNWGLDXOPENDEVICEPROC = function(dxDevice: Pointer): THandle; stdcall;
PFNWGLDXREGISTEROBJECTPROC = function(hDevice: THandle; dxObject: Pointer; name: Cardinal; atype: Cardinal; access: Cardinal): THandle; stdcall;
PFNWGLDXSETRESOURCESHAREHANDLEPROC = function (dxObject: Pointer; shareHandle: THandle): BOOL; stdcall;
PFNWGLDXUNLOCKOBJECTSNVPROC = function (hDevice: THandle; count: TGLint; hObjects: PHandle): BOOL; stdcall;
PFNWGLDXUNREGISTEROBJECTPROC = function(hDevice: THandle; hObject: THandle): BOOL; stdcall;
PFNWGLENUMGPUDEVICESNVPROC = function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean; stdcall;
PFNWGLENUMGPUSFROMAFFINITYDCNVPROC = function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;
PFNWGLENUMGPUSNVPROC = function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;
PFNWGLFREEMEMORYNVPROC = procedure(ptr: Pointer); stdcall;
PFNWGLGETCURRENTREADDCARBPROC = function(): HDC; stdcall;
PFNWGLGETEXTENSIONSSTRINGARBPROC = function(DC: HDC): PAnsiChar; stdcall;
PFNWGLGETPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB) : HDC; stdcall;
PFNWGLGETPIXELFORMATATTRIBFVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;
PFNWGLGETPIXELFORMATATTRIBIVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;
PFNWGLGETSWAPINTERVALEXTPROC = function : Integer; stdcall;
PFNWGLMAKECONTEXTCURRENTARBPROC = function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;
PFNWGLQUERYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;
PFNWGLRELEASEPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;
PFNWGLRELEASETEXIMAGEARBPROC = function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;
PFNWGLRESTOREBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;
PFNWGLSAVEBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;
PFNWGLSETPBUFFERATTRIBARBPROC = function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;
PFNWGLSWAPINTERVALEXTPROC = function(interval : Integer) : BOOL; stdcall;
PGLbitfield = ˆTGLbitfield;
PGLboolean = ˆTGLboolean;
PGLbyte = ˆTGLbyte;
PGLchar = MarshaledAString;
PGLclampd = System.PDouble;
PGLclampf = System.PSingle;
PGLdouble = System.PDouble;
PGLenum = ˆTGLenum;
PGLfloat = System.PSingle;
PGLhalf = ˆTGLhalf;
PGLhandleARB = ˆTGLhandleARB;
PGLint = System.PInteger;
PGLint64 = System.PInt64;
PGLint64EXT = System.PInt64;
PGLintptr = ˆTGLintptr;
PGLPCharArray = ˆPAnsiChar;
PGLPointer = ˆPGLvoid;
PGLshort = ˆTGLshort;
PGLsizei = System.PInteger;
PGLsizeiptr = ˆTGLsizeiptr;
PGLsync = ˆTGLsync;
PGLubyte = System.PByte;
PGLuint = System.PCardinal;
PGLuint64 = System.PUInt64;
PGLuint64EXT = System.PUInt64;
PGLUNurbs = ˆTGLUNurbs;
PGLUNurbsObj = PGLUNurbs;
PGLUQuadric = ˆTGLUQuadric;
PGLUQuadricObj = PGLUQuadric;
PGLushort = System.PWord;
PGLUTesselator= ˆTGLUTesselator;
PGLUTesselatorObj = PGLUTesselator;
PGLUTriangulatorObj = PGLUTesselator;
PGLvdpauSurfaceNV = ˆTGLvdpauSurfaceNV;
PGLvoid = Pointer;
PGNGLGETBUFFERPARAMETERUI64VNV = procedure(value: Cardinal; index: Cardinal; result: PGLuint64EXT); stdcall;
PGPUDEVICE = ˆTGPUDEVICE;
PHGPUNV = ˆHGPUNV;
PHVIDEOINPUTDEVICENV = ˆHVIDEOINPUTDEVICENV;
PWGLswap = ˆTWGLswap;
TDebugProc = procedure( source: Cardinal; type_: Cardinal; id: Cardinal; severity: Cardinal; length: TGLsizei; const message: PAnsiChar; userParam: Pointer); stdcall;
TDebugProcAMD = procedure( id: Cardinal; category: Cardinal; severity: Cardinal; length: TGLsizei; message: PAnsiChar; userParam: Pointer); stdcall;
TGLbitfield = LongWord;
TGLboolean = BYTEBOOL;
TGLbyte = ShortInt;
TGLchar = Byte;
TGLclampd = Double;
TGLDEBUGPROCARB = TDebugProc;
TGLdouble = Double;
TGLenum = Cardinal;
TGLfloat = Single;
TGLhalf = WORD;
TGLhandleARB = Cardinal;
TGLint = Integer;
TGLint64 = Int64;
TGLint64EXT = Int64;
TGLintptr = NativeInt;
TGLshort = SmallInt;
TGLsizei = Integer;
TGLsizeiptr = NativeInt;
TGLsync = NativeInt;
TGLubyte = Byte;
TGLuint = Cardinal;
TGLuint64 = UInt64;
TGLuint64EXT = UInt64;
TGLUNurbsErrorProc = procedure(ErrorCode: Cardinal); stdcall;
TGLUNurbsObj = TGLUNurbs;
TGLUQuadricErrorProc = procedure(errorCode: Cardinal); stdcall;
TGLUQuadricObj = TGLUQuadric;
TGLushort = Word;
TGLUTessBeginDataProc = procedure(AType: Cardinal; UserData: Pointer); stdcall;
TGLUTessBeginProc = procedure(AType: Cardinal); stdcall;
TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;
TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;
TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;
TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;
TGLUTesselatorObj = TGLUTesselator;
TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;
TGLUTessEndProc = procedure; stdcall;
TGLUTessErrorDataProc = procedure(ErrNo: Cardinal; UserData: Pointer); stdcall;
TGLUTessErrorProc = procedure(ErrNo: Cardinal); stdcall;
TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;
TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;
TGLUTriangulatorObj = TGLUTesselator;
TGLvdpauSurfaceNV = TGLintptr;
TWGLswap = _WGLSWAP;
WGLSWAP = _WGLSWAP;

Constants

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;
WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;
WGL_DEPTH_BUFFER_BIT_ARB = $00000004;
WGL_STENCIL_BUFFER_BIT_ARB = $00000008;
WGL_SAMPLE_BUFFERS_ARB = $2041;
WGL_SAMPLES_ARB = $2042;
WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;
WGL_DRAW_TO_WINDOW_ARB = $2001;
WGL_DRAW_TO_BITMAP_ARB = $2002;
WGL_ACCELERATION_ARB = $2003;
WGL_NEED_PALETTE_ARB = $2004;
WGL_NEED_SYSTEM_PALETTE_ARB = $2005;
WGL_SWAP_LAYER_BUFFERS_ARB = $2006;
WGL_SWAP_METHOD_ARB = $2007;
WGL_NUMBER_OVERLAYS_ARB = $2008;
WGL_NUMBER_UNDERLAYS_ARB = $2009;
WGL_TRANSPARENT_ARB = $200A;
WGL_TRANSPARENT_RED_VALUE_ARB = $2037;
WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;
WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;
WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;
WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;
WGL_SHARE_DEPTH_ARB = $200C;
WGL_SHARE_STENCIL_ARB = $200D;
WGL_SHARE_ACCUM_ARB = $200E;
WGL_SUPPORT_GDI_ARB = $200F;
WGL_SUPPORT_OPENGL_ARB = $2010;
WGL_DOUBLE_BUFFER_ARB = $2011;
WGL_STEREO_ARB = $2012;
WGL_PIXEL_TYPE_ARB = $2013;
WGL_COLOR_BITS_ARB = $2014;
WGL_RED_BITS_ARB = $2015;
WGL_RED_SHIFT_ARB = $2016;
WGL_GREEN_BITS_ARB = $2017;
WGL_GREEN_SHIFT_ARB = $2018;
WGL_BLUE_BITS_ARB = $2019;
WGL_BLUE_SHIFT_ARB = $201A;
WGL_ALPHA_BITS_ARB = $201B;
WGL_ALPHA_SHIFT_ARB = $201C;
WGL_ACCUM_BITS_ARB = $201D;
WGL_ACCUM_RED_BITS_ARB = $201E;
WGL_ACCUM_GREEN_BITS_ARB = $201F;
WGL_ACCUM_BLUE_BITS_ARB = $2020;
WGL_ACCUM_ALPHA_BITS_ARB = $2021;
WGL_DEPTH_BITS_ARB = $2022;
WGL_STENCIL_BITS_ARB = $2023;
WGL_AUX_BUFFERS_ARB = $2024;
WGL_NO_ACCELERATION_ARB = $2025;
WGL_GENERIC_ACCELERATION_ARB = $2026;
WGL_FULL_ACCELERATION_ARB = $2027;
WGL_SWAP_EXCHANGE_ARB = $2028;
WGL_SWAP_COPY_ARB = $2029;
WGL_SWAP_UNDEFINED_ARB = $202A;
WGL_TYPE_RGBA_ARB = $202B;
WGL_TYPE_COLORINDEX_ARB = $202C;
WGL_DRAW_TO_PBUFFER_ARB = $202D;
WGL_MAX_PBUFFER_PIXELS_ARB = $202E;
WGL_MAX_PBUFFER_WIDTH_ARB = $202F;
WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;
WGL_PBUFFER_LARGEST_ARB = $2033;
WGL_PBUFFER_WIDTH_ARB = $2034;
WGL_PBUFFER_HEIGHT_ARB = $2035;
WGL_PBUFFER_LOST_ARB = $2036;
WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;
WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;
WGL_TEXTURE_FORMAT_ARB = $2072;
WGL_TEXTURE_TARGET_ARB = $2073;
WGL_MIPMAP_TEXTURE_ARB = $2074;
WGL_TEXTURE_RGB_ARB = $2075;
WGL_TEXTURE_RGBA_ARB = $2076;
WGL_NO_TEXTURE_ARB = $2077;
WGL_TEXTURE_CUBE_MAP_ARB = $2078;
WGL_TEXTURE_1D_ARB = $2079;
WGL_TEXTURE_2D_ARB = $207A;
WGL_MIPMAP_LEVEL_ARB = $207B;
WGL_CUBE_MAP_FACE_ARB = $207C;
WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;
WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;
WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;
WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;
WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;
WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;
WGL_FRONT_LEFT_ARB = $2083;
WGL_FRONT_RIGHT_ARB = $2084;
WGL_BACK_LEFT_ARB = $2085;
WGL_BACK_RIGHT_ARB = $2086;
WGL_AUX0_ARB = $2087;
WGL_AUX1_ARB = $2088;
WGL_AUX2_ARB = $2089;
WGL_AUX3_ARB = $208A;
WGL_AUX4_ARB = $208B;
WGL_AUX5_ARB = $208C;
WGL_AUX6_ARB = $208D;
WGL_AUX7_ARB = $208E;
WGL_AUX8_ARB = $208F;
WGL_AUX9_ARB = $2090;
WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;
WGL_COLOR_SAMPLES_NV = $20B9;
WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;
WGL_CONTEXT_MINOR_VERSION_ARB = $2092;
WGL_CONTEXT_LAYER_PLANE_ARB = $2093;
WGL_CONTEXT_FLAGS_ARB = $2094;
WGL_CONTEXT_DEBUG_BIT_ARB = $0001;
WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $0002;
ERROR_INVALID_VERSION_ARB = $2095;
WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $0004;
WGL_CONTEXT_PROFILE_MASK_ARB = $9126;
WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;
WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;
ERROR_INVALID_PROFILE_ARB = $2096;
WGL_TYPE_RGBA_FLOAT_ATI = $21A0;
WGL_FLOAT_COMPONENTS_NV = $20B0;
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;
WGL_TEXTURE_FLOAT_R_NV = $20B5;
WGL_TEXTURE_FLOAT_RG_NV = $20B6;
WGL_TEXTURE_FLOAT_RGB_NV = $20B7;
WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;
WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;
GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;
GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI = $8837;
WGL_ACCESS_READ_ONLY_NV = $0000;
WGL_ACCESS_READ_WRITE_NV = $0001;
WGL_ACCESS_WRITE_DISCARD_NV = $0002;
GLU_TESS_BEGIN = 100100;
GLU_TESS_VERTEX = 100101;
GLU_TESS_END = 100102;
GLU_TESS_ERROR = 100103;
GLU_TESS_EDGE_FLAG = 100104;
GLU_TESS_COMBINE = 100105;
GLU_TESS_BEGIN_DATA = 100106;
GLU_TESS_VERTEX_DATA = 100107;
GLU_TESS_END_DATA = 100108;
GLU_TESS_ERROR_DATA = 100109;
GLU_TESS_EDGE_FLAG_DATA = 100110;
GLU_TESS_COMBINE_DATA = 100111;
GLU_TESS_ERROR1 = 100151;
GLU_TESS_ERROR2 = 100152;
GLU_TESS_ERROR3 = 100153;
GLU_TESS_ERROR4 = 100154;
GLU_TESS_ERROR5 = 100155;
GLU_TESS_ERROR6 = 100156;
GLU_TESS_ERROR7 = 100157;
GLU_TESS_ERROR8 = 100158;
GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;
GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;
GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;
GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;
GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;
GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;
GLU_AUTO_LOAD_MATRIX = 100200;
GLU_CULLING = 100201;
GLU_SAMPLING_TOLERANCE = 100203;
GLU_DISPLAY_MODE = 100204;
GLU_PARAMETRIC_TOLERANCE = 100202;
GLU_SAMPLING_METHOD = 100205;
GLU_U_STEP = 100206;
GLU_V_STEP = 100207;
GLU_PATH_LENGTH = 100215;
GLU_PARAMETRIC_ERROR = 100216;
GLU_DOMAIN_DISTANCE = 100217;
GLU_MAP1_TRIM_2 = 100210;
GLU_MAP1_TRIM_3 = 100211;
GLU_OUTLINE_POLYGON = 100240;
GLU_OUTLINE_PATCH = 100241;
GLU_NURBS_ERROR1 = 100251;
GLU_NURBS_ERROR2 = 100252;
GLU_NURBS_ERROR3 = 100253;
GLU_NURBS_ERROR4 = 100254;
GLU_NURBS_ERROR5 = 100255;
GLU_NURBS_ERROR6 = 100256;
GLU_NURBS_ERROR7 = 100257;
GLU_NURBS_ERROR8 = 100258;
GLU_NURBS_ERROR9 = 100259;
GLU_NURBS_ERROR10 = 100260;
GLU_NURBS_ERROR11 = 100261;
GLU_NURBS_ERROR12 = 100262;
GLU_NURBS_ERROR13 = 100263;
GLU_NURBS_ERROR14 = 100264;
GLU_NURBS_ERROR15 = 100265;
GLU_NURBS_ERROR16 = 100266;
GLU_NURBS_ERROR17 = 100267;
GLU_NURBS_ERROR18 = 100268;
GLU_NURBS_ERROR19 = 100269;
GLU_NURBS_ERROR20 = 100270;
GLU_NURBS_ERROR21 = 100271;
GLU_NURBS_ERROR22 = 100272;
GLU_NURBS_ERROR23 = 100273;
GLU_NURBS_ERROR24 = 100274;
GLU_NURBS_ERROR25 = 100275;
GLU_NURBS_ERROR26 = 100276;
GLU_NURBS_ERROR27 = 100277;
GLU_NURBS_ERROR28 = 100278;
GLU_NURBS_ERROR29 = 100279;
GLU_NURBS_ERROR30 = 100280;
GLU_NURBS_ERROR31 = 100281;
GLU_NURBS_ERROR32 = 100282;
GLU_NURBS_ERROR33 = 100283;
GLU_NURBS_ERROR34 = 100284;
GLU_NURBS_ERROR35 = 100285;
GLU_NURBS_ERROR36 = 100286;
GLU_NURBS_ERROR37 = 100287;
GLU_CW = 100120;
GLU_CCW = 100121;
GLU_INTERIOR = 100122;
GLU_EXTERIOR = 100123;
GLU_UNKNOWN = 100124;
GLU_BEGIN = GLU_TESS_BEGIN;
GLU_VERTEX = GLU_TESS_VERTEX;
GLU_END = GLU_TESS_END;
GLU_ERROR = GLU_TESS_ERROR;
GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;

Description

Types

HGPUNV = THandle;

This item has no description.

HPBUFFERARB = type UINT_PTR;

This item has no description.

HVIDEOINPUTDEVICENV = THandle;

This item has no description.

PFNGLACTIVESHADERPROGRAMPROC = procedure(pipeline: Cardinal; _program: Cardinal); stdcall;

This item has no description.

PFNGLACTIVESTENCILFACEEXTPROC = procedure(face: Cardinal); stdcall;

GL_EXT_stencil_two_side (EXT #268)

PFNGLACTIVETEXTUREARBPROC = procedure(target: Cardinal); stdcall;

GL_ARB_multitexture (ARB #1)

PFNGLACTIVETEXTUREPROC = procedure(texture: Cardinal); stdcall;

deprecated; core 1.3 promoted to core v1.3 from GL_ARB_multitexture (#1)

PFNGLACTIVEVARYINGNVPROC = procedure(_program: Cardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLADDSWAPHINTRECTWINPROC = procedure(x, y: TGLint; width, height: TGLsizei); stdcall;

GL_WIN_swap_hint (extension # not found)

PFNGLAREPROGRAMSRESIDENTNVPROC = procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;

GL_NV_vertex_program (EXT #233)

PFNGLARETEXTURESRESIDENTEXTPROC = function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;

This item has no description.

PFNGLARRAYELEMENTARRAYEXTPROC = procedure(mode: Cardinal; count: TGLsizei; pi: Pointer); stdcall;

EXT/Vendor extensions Unknown Vendor/EXT functions

PFNGLATTACHOBJECTARBPROC = procedure(containerObj: TGLhandleARB; obj: TGLhandleARB); stdcall;

This item has no description.

PFNGLATTACHSHADERPROC = procedure(_program: Cardinal; shader: Cardinal); stdcall;

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)

PFNGLBEGINCONDITIONALRENDERNVPROC = procedure(id: Cardinal; mode: Cardinal); stdcall;

GL_NV_conditional_render (EXT #346)

PFNGLBEGINCONDITIONALRENDERPROC = procedure(id: Cardinal; mode: Cardinal); stdcall;

promoted to core v3.0 from GL_NV_conditional_render

PFNGLBEGINOCCLUSIONQUERYNVPROC = procedure(id: Cardinal); stdcall;

This item has no description.

PFNGLBEGINQUERYARBPROC = procedure(target: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLBEGINQUERYINDEXEDPROC = procedure(target: Cardinal; index: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLBEGINQUERYPROC = procedure(target: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLBEGINSCENEEXTPROC = procedure; stdcall;

GL_EXT_scene_marker (EXT #120)

PFNGLBEGINTRANSFORMFEEDBACKEXTPROC = procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

PFNGLBEGINTRANSFORMFEEDBACKNVPROC = procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

PFNGLBEGINTRANSFORMFEEDBACKPROC = procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

PFNGLBINDATTRIBLOCATIONARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; const name: PAnsiChar); stdcall;

GL_ARB_vertex_shader (ARB #31)

PFNGLBINDATTRIBLOCATIONPROC = procedure(_program: Cardinal; index: Cardinal; const name: PAnsiChar); stdcall;

This item has no description.

PFNGLBINDBUFFERARBPROC = procedure(target: Cardinal; buffer: Cardinal); stdcall;

GL_ARB_vertex_buffer_object (ARB #28)

PFNGLBINDBUFFERBASEEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDBUFFERBASENVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDBUFFERBASEPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDBUFFEROFFSETEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr); stdcall;

This item has no description.

PFNGLBINDBUFFEROFFSETNVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset: TGLintptr); stdcall;

This item has no description.

PFNGLBINDBUFFERPROC = procedure(target: Cardinal; buffer: Cardinal); stdcall;

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)

PFNGLBINDBUFFERRANGEEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr; size: TGLsizeiptr); stdcall;

GL_EXT_transform_feedback (EXT #352)

PFNGLBINDBUFFERRANGENVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr); stdcall;

GL_NV_transform_feedback (EXT #341)

PFNGLBINDBUFFERRANGEPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr; size: TGLsizeiptr); stdcall;

promoted to core v3.0 from GL_EXT_transform_feedback

PFNGLBindBuffersBase = procedure(target : Cardinal; first : Cardinal; count : TGLsizei; const buffers : PGLUint); stdcall;

This item has no description.

PFNGLBindBuffersRange = procedure(target : Cardinal; first : Cardinal; count : TGLsizei; const buffers : PGLuint; const offsets : TGLintptr; const sizes : TGLsizeiptr); stdcall;

This item has no description.

PFNGLBINDFRAGDATALOCATIONEXTPROC = procedure(_program: Cardinal; colorNumber: Cardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC = procedure (_program: Cardinal; colorNumber: Cardinal; index: Cardinal; const name: PAnsiChar); stdcall;

GL_ARB_blend_func_extended (ARB #78)

PFNGLBINDFRAGDATALOCATIONPROC = procedure(_program: Cardinal; colorNumber: Cardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLBINDFRAMEBUFFEREXTPROC = procedure(target: Cardinal; framebuffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDFRAMEBUFFERPROC = procedure(target: Cardinal; framebuffer: Cardinal); stdcall;

This item has no description.

PFNGLBindImageTextures = procedure(first : Cardinal; count : TGLsizei; const textures : PGLuint); stdcall;

This item has no description.

PFNGLBINDMULTITEXTUREEXTPROC = procedure(texunit: Cardinal; target: Cardinal; texture: Cardinal); stdcall;

This item has no description.

PFNGLBINDPROGRAMARBPROC = procedure(target: Cardinal; _program: Cardinal); stdcall;

This item has no description.

PFNGLBINDPROGRAMNVPROC = procedure(target: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLBINDPROGRAMPIPELINEPROC = procedure(pipeline: Cardinal); stdcall;

This item has no description.

PFNGLBINDRENDERBUFFEREXTPROC = procedure(target: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDRENDERBUFFERPROC = procedure(target: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDSAMPLERPROC = procedure(_unit: Cardinal; sampler: Cardinal); stdcall;

This item has no description.

PFNGLBindSamplers = procedure(first : Cardinal; count : TGLsizei; const samplers : PGLuint); stdcall;

This item has no description.

PFNGLBINDTEXTUREEXTPROC = procedure(target: Cardinal; texture: Cardinal); stdcall;

This item has no description.

PFNGLBindTextures = procedure(first : Cardinal; count : TGLsizei; const textures : PGLuint); stdcall;

This item has no description.

PFNGLBINDTRANSFORMFEEDBACKPROC = procedure(target: Cardinal; id: Cardinal); stdcall;

GL_ARB_transform_feedback2 (ARB #93)

PFNGLBINDVERTEXARRAYPROC = procedure(_array: Cardinal); stdcall;

GL_ARB_vertex_array_object (ARB #54)

PFNGLBindVertexBuffer = procedure(bindingindex : Cardinal; buffer : Cardinal; offset : TGLintptr; stride : TGLsizei); stdcall;

GL_ARB_vertex_attrib_binding (ARB #125)

PFNGLBindVertexBuffers = procedure(first : Cardinal; count : TGLsizei; const buffers : Cardinal; const offsets : TGLintptr; const strides : PGLsizei); stdcall;

This item has no description.

PFNGLBLENDCOLOREXTPROC = procedure(red, green, blue: Single; alpha: Single); stdcall;

GL_EXT_blend_color (EXT #2)

PFNGLBLENDCOLORPROC = procedure(red, green, blue, alpha: Single); stdcall;

====================================================================== core 1.2 promoted to core v1.2 from GL_EXT_blend_color (#2)

PFNGLBLENDEQUATIONEXTPROC = procedure(mode: Cardinal); stdcall;

GL_EXT_blend_minmax (EXT #37)

PFNGLBLENDEQUATIONIARBPROC = procedure(buf: Cardinal; mode: Cardinal); stdcall;

GL_ARB_draw_buffers_blend (ARB #69)

PFNGLBLENDEQUATIONIPROC = procedure(buf: Cardinal; mode: Cardinal); stdcall;

Core 4.0 promoted to core v4.0 from GL_ARB_draw_buffers_blend (ARB #69)

PFNGLBLENDEQUATIONPROC = procedure(mode: Cardinal); stdcall;

promoted to core v1.2 from GL_EXT_blend_minmax (#37)

PFNGLBLENDEQUATIONSEPARATEEXTPROC = procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

GL_EXT_blend_equation_separate (EXT #299)

PFNGLBLENDEQUATIONSEPARATEIARBPROC = procedure(buf: Cardinal; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

This item has no description.

PFNGLBLENDEQUATIONSEPARATEIPROC = procedure(buf: Cardinal; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

This item has no description.

PFNGLBLENDEQUATIONSEPARATEPROC = procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

core 2.0 promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)

PFNGLBLENDFUNCIARBPROC = procedure(buf: Cardinal; src: Cardinal; dst: Cardinal); stdcall;

This item has no description.

PFNGLBLENDFUNCIPROC = procedure(buf: Cardinal; src: Cardinal; dst: Cardinal); stdcall;

This item has no description.

PFNGLBLENDFUNCSEPARATEEXTPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

GL_EXT_blend_func_separate (EXT #173)

PFNGLBLENDFUNCSEPARATEIARBPROC = procedure(buf: Cardinal; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;

This item has no description.

PFNGLBLENDFUNCSEPARATEIPROC = procedure(buf: Cardinal; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;

This item has no description.

PFNGLBLENDFUNCSEPARATEPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

deprecated; core 1.4 promoted to core v1.4 from GL_EXT_blend_func_separate (#173)

PFNGLBLITFRAMEBUFFEREXTPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

GL_EXT_framebuffer_blit (EXT #316)

PFNGLBLITFRAMEBUFFERPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

This item has no description.

PFNGLBUFFERADDRESSRANGENVPROC = procedure(pname: Cardinal; index: Cardinal; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;

GL_NV_vertex_buffer_unified_memory (EXT #380)

PFNGLBUFFERDATAARBPROC = procedure(target: Cardinal; size: TGLsizei; const data: Pointer; usage: Cardinal); stdcall;

This item has no description.

PFNGLBUFFERDATAPROC = procedure(target: Cardinal; size: TGLsizei; const data: Pointer; usage: Cardinal); stdcall;

This item has no description.

PFNGLBufferStorage = procedure(target : Cardinal; size : TGLsizeiptr; const data : pointer; flags : TGLbitfield); stdcall;

This item has no description.

PFNGLBUFFERSUBDATAARBPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; const data: Pointer); stdcall;

This item has no description.

PFNGLBUFFERSUBDATAPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; const data: Pointer); stdcall;

This item has no description.

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC = function(target: Cardinal): Cardinal; stdcall;

This item has no description.

PFNGLCHECKFRAMEBUFFERSTATUSPROC = function(target: Cardinal): Cardinal; stdcall;

This item has no description.

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC = function(framebuffer: Cardinal; target: Cardinal): Cardinal; stdcall;

This item has no description.

PFNGLCLAMPCOLORARBPROC = procedure (target: Cardinal; clamp: Cardinal); stdcall;

GL_ARB_color_buffer_float (ARB #39)

PFNGLCLAMPCOLORPROC = procedure (target: Cardinal; clamp: Cardinal); stdcall;

promoted to core v3.0 from GL_ARB_color_buffer_float

PFNGLClearBufferData = procedure(target : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;

GL_ARB_clear_buffer_object (ARB #121)

PFNGLCLEARBUFFERFIPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; depth: TGLfloat; stencil: TGLint); stdcall;

This item has no description.

PFNGLCLEARBUFFERFVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLfloat); stdcall;

This item has no description.

PFNGLCLEARBUFFERIVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLint); stdcall;

New commands in OpenGL 3.0

PFNGLClearBufferSubData = procedure(target : Cardinal; internalformat : Cardinal; offset : TGLintptr; size : TGLsizeiptr; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;

This item has no description.

PFNGLCLEARBUFFERUIVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLuint); stdcall;

This item has no description.

PFNGLCLEARCOLORIIEXTPROC = procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;

GL_EXT_texture_integer (EXT #343)

PFNGLCLEARCOLORIUIEXTPROC = procedure(r: Cardinal; g: Cardinal; b: Cardinal; a: Cardinal); stdcall;

This item has no description.

PFNGLCLEARDEPTHFPROC = procedure(depth: TGLclampd); stdcall;

This item has no description.

PFNGLClearNamedBufferData = procedure(buffer : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;

This item has no description.

PFNGLClearNamedBufferSubData = procedure(buffer : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; offset : TGLsizeiptr; size : TGLsizeiptr; const data : Pointer); stdcall;

This item has no description.

PFNGLClearTexImage = procedure(texture : Cardinal; level : TGLint; format : Cardinal; _type : Cardinal; const data : Pointer); stdcall;

This item has no description.

PFNGLClearTexSubImage = procedure(texture : Cardinal; level : TGLint; xoffset : TGLint; yoffset : TGLint; zoffset : TGLint; width : TGLsizei; height : TGLsizei; depth : TGLsizei; format : Cardinal; _type : Cardinal; const Data : Pointer); stdcall;

This item has no description.

PFNGLCLIENTACTIVETEXTUREARBPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLCLIENTACTIVETEXTUREPROC = procedure(texture: Cardinal); stdcall;

core 1.3 deprecated promoted to core v1.3 from GL_ARB_multitexture (#1)

PFNGLCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: TGLbitfield); stdcall;

GL_EXT_direct_state_access

PFNGLCLIENTWAITSYNCPROC = function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): Cardinal; stdcall;

This item has no description.

PFNGLCOLORFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLCOLORMASKINDEXEDEXTPROC = procedure(buf: Cardinal; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

GL_EXT_draw_buffers2 (EXT #340)

PFNGLCOLORMASKIPROC = procedure(index: Cardinal; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

promoted to core v3.0 from GL_EXT_draw_buffers2

PFNGLCOLORP3UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;

This item has no description.

PFNGLCOLORP3UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

PFNGLCOLORP4UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;

This item has no description.

PFNGLCOLORP4UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

PFNGLCOLORSUBTABLEEXTPROC = procedure(target: Cardinal; start, count: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

This item has no description.

PFNGLCOLORSUBTABLEPROC = procedure(target: Cardinal; start, count: TGLsizei; format, Atype: Cardinal; data: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)

PFNGLCOLORTABLEEXTPROC = procedure(target, internalFormat: Cardinal; width: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

GL_EXT_paletted_texture (EXT #78)

PFNGLCOLORTABLEPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLCOLORTABLEPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLCOLORTABLEPROC = procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; table: Pointer); stdcall;

core 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)

PFNGLCOMBINERINPUTNVPROC = procedure(stage, portion, variable, input, mapping, componentUsage: Cardinal); stdcall;

This item has no description.

PFNGLCOMBINEROUTPUTNVPROC = procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: Cardinal; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;

This item has no description.

PFNGLCOMBINERPARAMETERFNVPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLCOMBINERPARAMETERFVNVPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;

GL_NV_register_combiners (EXT #191)

PFNGLCOMBINERPARAMETERINVPROC = procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLCOMBINERPARAMETERIVNVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLCOMPILESHADERARBPROC = procedure(shaderObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLCOMPILESHADERPROC = procedure(shader: Cardinal); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE1DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE2DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

GL_ARB_texture_compression (ARB #12)

PFNGLCOMPRESSEDTEXIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

promoted to core v1.3 from GL_ARB_texture_compression (#12)

PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC = procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)

PFNGLCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

deprecated;

PFNGLCONVOLUTIONPARAMETERFPROC = procedure(target, pname: Cardinal; param: TGLfloat); stdcall;

deprecated;

PFNGLCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLCONVOLUTIONPARAMETERIPROC = procedure(target, pname: Cardinal; param: TGLint); stdcall;

deprecated;

PFNGLCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLCOPYBUFFERSUBDATAPROC = procedure(readTarget: Cardinal; writeTarget: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

GL_ARB_copy_buffer (ARB #59)

PFNGLCOPYCOLORSUBTABLEPROC = procedure(target: Cardinal; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

PFNGLCOPYCOLORTABLEPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

PFNGLCOPYCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

PFNGLCOPYCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width, height: TGLsizei); stdcall;

deprecated;

PFNGLCopyImageSubData = procedure(srcName : Cardinal; srcTarget : Cardinal; srcLevel : TGLint; srcX : TGLint; srcY : TGLint; srcZ : TGLint; dstName : Cardinal; dstTarget : Cardinal; dstLevel : TGLint; dstX : TGLint; dstY : TGLint; dstZ : TGLint; srcWidth : TGLsizei; srcHeight : TGLsizei; srcDepth : TGLsizei); stdcall;

GL_ARB_copy_image (ARB #123)

PFNGLCOPYIMAGESUBDATANVPROC = procedure( srcName: Cardinal; srcTarget: Cardinal; srcLevel: TGLint; srcX: TGLint; srcY: TGLint; srcZ: TGLint; dstName: Cardinal; dstTarget: Cardinal; dstLevel: TGLint; dstX: TGLint; dstY: TGLint; dstZ: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei); stdcall;

GL_NV_copy_image (EXT #376)

PFNGLCOPYMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYPATHNVPROC = procedure (resultPath: Cardinal; srcPath: Cardinal); stdcall;

This item has no description.

PFNGLCOPYTEXIMAGE1DEXTPROC = procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;

GL_EXT_copy_texture (EXT #10)

PFNGLCOPYTEXIMAGE2DEXTPROC = procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYTEXSUBIMAGE1DEXTPROC = procedure(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXSUBIMAGE2DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXSUBIMAGE3DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

promoted to core v1.2 from GL_EXT_copy_texture

PFNGLCOPYTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLCOVERFILLPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; coverMode: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLCOVERFILLPATHNVPROC = procedure (path: Cardinal; coverMode: Cardinal); stdcall;

This item has no description.

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; coverMode: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLCOVERSTROKEPATHNVPROC = procedure (path: Cardinal; coverMode: Cardinal); stdcall;

This item has no description.

PFNGLCREATEPROGRAMOBJECTARBPROC = function(): TGLhandleARB; stdcall;

This item has no description.

PFNGLCREATEPROGRAMPROC = function(): Cardinal; stdcall;

This item has no description.

PFNGLCREATESHADEROBJECTARBPROC = function(shaderType: Cardinal): TGLhandleARB; stdcall;

This item has no description.

PFNGLCREATESHADERPROC = function(_type: Cardinal): Cardinal; stdcall;

This item has no description.

PFNGLCREATESHADERPROGRAMVPROC = function(_type: Cardinal; count: TGLsizei; const strings: PGLPCharArray): Cardinal; stdcall;

This item has no description.

PFNGLCreateSyncFromCLevent = function(context: p_cl_context; event: p_cl_event; flags: TGLbitfield): TGLsync; stdcall;

GL_ARB_robustness_isolation (ARB #126) (no entry points) GL_ARB_cl_event (ARB #103)

PFNGLCURRENTPALETTEMATRIXARBPROC = procedure(index: TGLint); stdcall;

GL_ARB_matrix_palette (ARB #16) {deprecated?}

PFNGLDEBUGMESSAGECALLBACKARBPROC = procedure(callback: TGLDEBUGPROCARB; userParam: Pointer); stdcall;

This item has no description.

PFNGLDEBUGMESSAGECONTROLARBPROC = procedure(source: Cardinal; _type: Cardinal; severity: Cardinal; count: TGLsizei; ids: PGLuint; enabled: TGLboolean); stdcall;

GL_ARB_debug_output (ARB #104)

PFNGLDEBUGMESSAGEINSERTARBPROC = procedure(source: Cardinal; _type: Cardinal; id: Cardinal; severity: Cardinal; length: TGLsizei; buf: PAnsiChar); stdcall;

This item has no description.

PFNGLDELETEBUFFERSARBPROC = procedure(n: TGLsizei; const buffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETEBUFFERSPROC = procedure(n: TGLsizei; const buffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETEFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;

This item has no description.

PFNGLDELETEFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETEFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETEOBJECTARBPROC = procedure(obj: TGLhandleARB); stdcall;

GL_ARB_shader_objects (ARB #30)

PFNGLDELETEOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

PFNGLDELETEPATHSNVPROC = procedure(path: Cardinal; range: TGLsizei); stdcall;

This item has no description.

PFNGLDELETEPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;

This item has no description.

PFNGLDELETEPROGRAMPROC = procedure(_program: Cardinal); stdcall;

This item has no description.

PFNGLDELETEPROGRAMSARBPROC = procedure(n: TGLsizei; const programs: PGLuint); stdcall;

This item has no description.

PFNGLDELETEPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

PFNGLDELETEQUERIESARBPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

PFNGLDELETEQUERIESPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

PFNGLDELETERENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETERENDERBUFFERSPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETESAMPLERSPROC = procedure(count: TGLsizei; const samplers: PGLuint); stdcall;

This item has no description.

PFNGLDELETESHADERPROC = procedure(shader: Cardinal); stdcall;

This item has no description.

PFNGLDELETESYNCPROC = procedure(sync: TGLsync); stdcall;

This item has no description.

PFNGLDELETETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;

This item has no description.

PFNGLDELETETRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

PFNGLDELETEVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;

This item has no description.

PFNGLDEPTHBOUNDSEXTPROC = procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;

GL_EXT_depth_bounds_test (EXT #297)

PFNGLDEPTHRANGEARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLclampd); stdcall;

This item has no description.

PFNGLDEPTHRANGEFPROC = procedure(n: Single; f: Single); stdcall;

This item has no description.

PFNGLDEPTHRANGEINDEXEDPROC = procedure(index: Cardinal; n: TGLclampd; f: TGLclampd); stdcall;

This item has no description.

PFNGLDETACHOBJECTARBPROC = procedure(containerObj: TGLhandleARB; attachedObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLDETACHSHADERPROC = procedure(_program: Cardinal; shader: Cardinal); stdcall;

This item has no description.

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: Cardinal; index_: Cardinal); stdcall;

This item has no description.

PFNGLDISABLEINDEXEDEXTPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLDISABLEIPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLDISABLEVERTEXATTRIBARRAYPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLDispatchCompute = procedure(num_groups_x : Cardinal; num_groups_y : Cardinal; num_groups_z : Cardinal); stdcall;

GL_ARB_compute_shader (ARB #122)

PFNGLDispatchComputeIndirect = procedure(indirect : TGLintptr); stdcall;

This item has no description.

PFNGLDRAWARRAYSINDIRECTPROC = procedure(mode: Cardinal; const indirect: PGLvoid); stdcall;

GL_ARB_draw_indirect (ARB #87)

PFNGLDRAWARRAYSINSTANCEDARBPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

GL_ARB_draw_instanced (ARB #44)

PFNGLDRAWARRAYSINSTANCEDEXTPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

GL_EXT_draw_instanced (EXT #327)

PFNGLDRAWARRAYSINSTANCEDPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

Core 3.1 New commands in OpenGL 3.1

PFNGLDRAWBUFFERSARBPROC = procedure (n: TGLsizei; const bufs: PCardinal); stdcall;

GL_ARB_DrawBuffers (ARB #37)

PFNGLDRAWBUFFERSATIPROC = procedure(n: TGLsizei; const bufs: PCardinal); stdcall;

GL_ATI_draw_buffers (EXT #277)

PFNGLDRAWBUFFERSPROC = procedure(n: TGLsizei; const bufs: PCardinal); stdcall;

promoted to core v2.0 from GL_ARB_draw_buffers (#37)

PFNGLDRAWELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

GL_ARB_draw_elements_base_vertex (ARB #62)

PFNGLDRAWELEMENTSINDIRECTPROC = procedure(mode: Cardinal; _type: Cardinal; const indirect: PGLvoid); stdcall;

This item has no description.

PFNGLDRAWELEMENTSINSTANCEDARBPROC = procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;

This item has no description.

PFNGLDRAWELEMENTSINSTANCEDEXTPROC = procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLDRAWELEMENTSINSTANCEDPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; start: Cardinal; _end: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

This item has no description.

PFNGLDRAWRANGEELEMENTSEXTPROC = procedure(mode: Cardinal; start, Aend: Cardinal; Count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

GL_EXT_draw_range_elements (EXT #112)

PFNGLDRAWRANGEELEMENTSPROC = procedure(mode: Cardinal; Astart, Aend: Cardinal; count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)

PFNGLDRAWTRANSFORMFEEDBACKPROC = procedure(mode: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC = procedure(mode: Cardinal; id: Cardinal; stream: Cardinal); stdcall;

GL_ARB_transform_feedback3 (ARB #94)

PFNGLEDGEFLAGFORMATNVPROC = procedure(stride: TGLsizei); stdcall;

This item has no description.

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: Cardinal; index_: Cardinal); stdcall;

This item has no description.

PFNGLENABLEINDEXEDEXTPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLENABLEIPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLENABLEVERTEXATTRIBARRAYARBPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLENABLEVERTEXATTRIBARRAYPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLENDCONDITIONALRENDERNVPROC = procedure(); stdcall;

This item has no description.

PFNGLENDCONDITIONALRENDERPROC = procedure(); stdcall;

This item has no description.

PFNGLENDOCCLUSIONQUERYNVPROC = procedure; stdcall;

This item has no description.

PFNGLENDQUERYARBPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLENDQUERYINDEXEDPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLENDQUERYPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLENDSCENEEXTPROC = procedure; stdcall;

This item has no description.

PFNGLENDTRANSFORMFEEDBACKEXTPROC = procedure(); stdcall;

This item has no description.

PFNGLENDTRANSFORMFEEDBACKNVPROC = procedure(); stdcall;

This item has no description.

PFNGLENDTRANSFORMFEEDBACKPROC = procedure(); stdcall;

This item has no description.

PFNGLEXECUTEPROGRAMNVPROC = procedure(target: Cardinal; id: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLFENCESYNCPROC = function(condition: Cardinal; flags: TGLbitfield): TGLsync; stdcall;

GL_ARB_sync (ARB #66)

PFNGLFINALCOMBINERINPUTNVPROC = procedure(variable, input, mapping, componentUsage: Cardinal); stdcall;

This item has no description.

PFNGLFINISHFENCENVPROC = procedure(fence: Cardinal); stdcall;

This item has no description.

PFNGLFLUSHMAPPEDBUFFERRANGEPROC = procedure( target: Cardinal; offset: TGLint; length: TGLsizei ); stdcall;

This item has no description.

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; length: TGLsizeiptr); stdcall;

This item has no description.

PFNGLFLUSHVERTEXARRAYRANGENVPROC = procedure; stdcall;

GL_NV_vertex_array_range (EXT #190)

PFNGLFOGCOORDDEXTPROC = procedure(coord: TGLdouble); stdcall;

This item has no description.

PFNGLFOGCOORDDPROC = procedure(coord: TGLdouble); stdcall;

deprecated;

PFNGLFOGCOORDDVEXTPROC = procedure(coord: PGLdouble); stdcall;

This item has no description.

PFNGLFOGCOORDDVPROC = procedure(coord: PGLdouble); stdcall;

deprecated;

PFNGLFOGCOORDFEXTPROC = procedure(coord: TGLfloat); stdcall;

GL_EXT_fog_coord (EXT #149)

PFNGLFOGCOORDFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLFOGCOORDFPROC = procedure(coord: TGLfloat); stdcall;

core 1.4 deprecated promoted to core v1.4 from GL_EXT_fog_coord (#149)

PFNGLFOGCOORDFVEXTPROC = procedure(coord: PGLfloat); stdcall;

This item has no description.

PFNGLFOGCOORDFVPROC = procedure(coord: PGLfloat); stdcall;

deprecated;

PFNGLFOGCOORDPOINTEREXTPROC = procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

This item has no description.

PFNGLFOGCOORDPOINTERPROC = procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

deprecated;

PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC = procedure(framebuffer: Cardinal; mode: Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC = procedure(framebuffer: Cardinal; n: TGLsizei; const bufs: PCardinal); stdcall;

This item has no description.

PFNGLFramebufferParameteri = procedure(target : Cardinal; pname : Cardinal; param : TGLint); stdcall;

GL_ARB_debug_group ARB_debug_group reuses entry points from KHR_debug GL_ARB_debug_label ARB_debug_label reuses entry points from KHR_debug GL_ARB_debug_output2 GL_ARB_ES3_compatibility GL_ARB_explicit_uniform_location GL_ARB_fragment_layer_viewport GL_ARB_framebuffer_no_attachments (ARB #130)

PFNGLFRAMEBUFFERREADBUFFEREXTPROC = procedure(framebuffer: Cardinal; mode: Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERRENDERBUFFERPROC = procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE1DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE2DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; zoffset: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE3DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREEXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; face:Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; face:Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; layer:TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; layer:TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURELAYERPROC = procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREPROC = procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMETERMINATORGREMEDYPROC = procedure(); stdcall;

GL_GREMEDY_frame_terminator (EXT #345)

PFNGLGENBUFFERSARBPROC = procedure(n: TGLsizei; buffers: PGLuint); stdcall;

This item has no description.

PFNGLGENBUFFERSPROC = procedure(n: TGLsizei; buffers: PGLuint); stdcall;

This item has no description.

PFNGLGENERATEMIPMAPEXTPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLGENERATEMIPMAPPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLGENERATEMULTITEXMIPMAPEXTPROC = procedure(texunit: Cardinal; target: Cardinal); stdcall;

This item has no description.

PFNGLGENERATETEXTUREMIPMAPEXTPROC = procedure(texture: Cardinal; target: Cardinal); stdcall;

This item has no description.

PFNGLGENFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;

GL_NV_fence (EXT #222)

PFNGLGENFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

PFNGLGENFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

PFNGLGENOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

GL_NV_occlusion_query (EXT #261)

PFNGLGENPATHSNVPROC = function (range: TGLsizei): Cardinal; stdcall;

GL_NV_path_rendering

PFNGLGENPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;

This item has no description.

PFNGLGENPROGRAMSARBPROC = procedure(n: TGLsizei; programs: PGLuint); stdcall;

This item has no description.

PFNGLGENPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

PFNGLGENQUERIESARBPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

GL_ARB_occlusion_query (ARB #29)

PFNGLGENQUERIESPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

deprecated; core 1.5 promoted to core v1.5 from GL_ARB_occlusion_query (#29)

PFNGLGENRENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

PFNGLGENRENDERBUFFERSPROC = procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;

This item has no description.

PFNGLGENSAMPLERSPROC = procedure(count: TGLsizei; samplers: PGLuint); stdcall;

GL_ARB_sampler_objects (ARB #81)

PFNGLGENTEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;

GL_EXT_texture_object (EXT #20)

PFNGLGENTRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

This item has no description.

PFNGLGENVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;

This item has no description.

PFNGLGETACTIVEATTRIBARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; maxLength: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEATTRIBPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVESUBROUTINENAMEPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; bufsize: TGLsizei; length: PGLsizei; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; pname: Cardinal; values: PGLint); stdcall;

This item has no description.

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; bufsize: TGLsizei; length: PGLsizei; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; maxLength: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMBLOCKIVPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMNAMEPROC = procedure(_program: Cardinal; uniformIndex: Cardinal; bufSize: TGLsizei; length: PGLsizei; uniformName: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMSIVPROC = procedure(_program: Cardinal; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETACTIVEVARYINGNVPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: Cardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETATTACHEDOBJECTSARBPROC = procedure(containerObj: TGLhandleARB; maxCount: TGLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;

This item has no description.

PFNGLGETATTACHEDSHADERSPROC = procedure(_program: Cardinal; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;

This item has no description.

PFNGLGETATTRIBLOCATIONARBPROC = function(programObj: TGLhandleARB; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETATTRIBLOCATIONPROC = function(_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETBOOLEANINDEXEDVEXTPROC = procedure(value: Cardinal; index: Cardinal; data: PGLboolean); stdcall;

This item has no description.

PFNGLGETBOOLEANI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLboolean); stdcall;

This item has no description.

PFNGLGETBUFFERPARAMETERI64VPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

PFNGLGETBUFFERPARAMETERIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETBUFFERPARAMETERIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETBUFFERPARAMETERUI64VNVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint64EXT ); stdcall;

This item has no description.

PFNGLGETBUFFERPOINTERVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: Pointer); stdcall;

This item has no description.

PFNGLGETBUFFERPOINTERVPROC = procedure(target: Cardinal; pname: Cardinal; params: Pointer); stdcall;

This item has no description.

PFNGLGETBUFFERSUBDATAARBPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; data: Pointer); stdcall;

This item has no description.

PFNGLGETBUFFERSUBDATAPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; data: Pointer); stdcall;

This item has no description.

PFNGLGETCOLORTABLEEXTPROC = procedure(target, format, atype: Cardinal; data: Pointer); stdcall;

This item has no description.

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETCOLORTABLEPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLGETCOLORTABLEPARAMETERIVEXTPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETCOLORTABLEPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLGETCOLORTABLEPROC = procedure(target, format, Atype: Cardinal; table: Pointer); stdcall;

deprecated;

PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC = procedure(stage, portion, variable, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC = procedure(stage, portion, variable, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC = procedure(stage, portion, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC = procedure(stage, portion, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC = procedure(texunit: Cardinal; target: Cardinal; lod: TGLint; img: PGLvoid); stdcall;

This item has no description.

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC = procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

This item has no description.

PFNGLGETCOMPRESSEDTEXIMAGEPROC = procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

This item has no description.

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC = procedure(texture: Cardinal; target: Cardinal; lod: TGLint; img: PGLvoid); stdcall;

This item has no description.

PFNGLGETCONVOLUTIONFILTERPROC = procedure(target, internalformat, Atype: Cardinal; image: Pointer); stdcall;

deprecated;

PFNGLGETCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLGETCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLGETDEBUGMESSAGELOGARBPROC = function(count: Cardinal; bufsize: TGLsizei; sources: PCardinal; types: PCardinal; ids: PGLuint; severities: PCardinal; lengths: PGLsizei; messageLog: PAnsiChar): Cardinal; stdcall;

This item has no description.

PFNGLGETDOUBLEINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLdouble); stdcall;

This item has no description.

PFNGLGETDOUBLEI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLdouble); stdcall;

This item has no description.

PFNGLGETFENCEIVNVPROC = procedure(fence: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC = procedure(variable, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC = procedure(variable, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETFLOATINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLfloat); stdcall;

This item has no description.

PFNGLGETFLOATI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLfloat); stdcall;

This item has no description.

PFNGLGETFRAGDATAINDEXPROC = function (_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETFRAGDATALOCATIONEXTPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETFRAGDATALOCATIONPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC = procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGetFramebufferParameteriv = procedure(target : Cardinal; pname : Cardinal; params : PGLint); stdcall;

This item has no description.

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC = procedure(framebuffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETGRAPHICSRESETSTATUSARBPROC = function(): Cardinal; stdcall;

GL_ARB_robustness (ARB #105)

PFNGLGETHANDLEARBPROC = function(pname: Cardinal): TGLhandleARB; stdcall;

This item has no description.

PFNGLGETHISTOGRAMPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLGETHISTOGRAMPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLGETHISTOGRAMPROC = procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)

PFNGLGETINFOLOGARBPROC = procedure(obj: TGLhandleARB; maxLength: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;

This item has no description.

PFNGLGETINTEGER64I_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLint64); stdcall;

Core 3.2

PFNGLGETINTEGER64VPROC = procedure(pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

PFNGLGETINTEGERINDEXEDVEXTPROC = procedure(value: Cardinal; index: Cardinal; data: PGLint); stdcall;

This item has no description.

PFNGLGETINTEGERI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLint); stdcall;

This item has no description.

PFNGLGETINTEGERUI64I_VNVPROC = procedure(value: Cardinal; index: Cardinal; result: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGETINTEGERUI64VNVPROC = procedure(value: Cardinal; result: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGetInternalformati64v = procedure(target : Cardinal; internalformat : Cardinal; pname : Cardinal; bufSize : TGLsizei; params : PGLint64); stdcall;

GL_ARB_internalformat_query2 (ARB #131)

PFNGLGETMINMAXPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLGETMINMAXPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLGETMINMAXPROC = procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

deprecated;

PFNGLGETMULTISAMPLEFVPROC = procedure(pname: Cardinal; index: Cardinal; val: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXENVFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXENVIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETMULTITEXGENDVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETMULTITEXGENFVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXGENIVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETMULTITEXIMAGEEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; format: Cardinal; type_: Cardinal; pixels: PGLvoid); stdcall;

This item has no description.

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETMULTITEXPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETMULTITEXPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLvoid); stdcall;

This item has no description.

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr; data: PGLvoid); stdcall;

This item has no description.

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGetNamedFramebufferParameteriv = procedure(framebuffer : Cardinal; pname : Cardinal; param : TGLint); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: Cardinal; target: Cardinal; pname: Cardinal; string_: PGLvoid); stdcall;

This item has no description.

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC = procedure(renderbuffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNCOLORTABLEARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; table: Pointer); stdcall;

This item has no description.

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC = procedure(target: Cardinal; lod: TGLint; bufSize: TGLsizei; img: Pointer); stdcall;

This item has no description.

PFNGLGETNCONVOLUTIONFILTERARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; image: Pointer); stdcall;

This item has no description.

PFNGLGETNHISTOGRAMARBPROC = procedure(target: Cardinal; reset: TGLboolean; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; values: Pointer); stdcall;

This item has no description.

PFNGLGETNMAPDVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLGETNMAPFVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLGETNMAPIVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLint); stdcall;

This item has no description.

PFNGLGETNMINMAXARBPROC = procedure(target: Cardinal; reset: TGLboolean; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; values: Pointer); stdcall;

This item has no description.

PFNGLGETNPIXELMAPFVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLfloat); stdcall;

This item has no description.

PFNGLGETNPIXELMAPUIVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLuint); stdcall;

This item has no description.

PFNGLGETNPIXELMAPUSVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLushort); stdcall;

This item has no description.

PFNGLGETNPOLYGONSTIPPLEARBPROC = procedure(bufSize: TGLsizei; pattern: PGLubyte); stdcall;

This item has no description.

PFNGLGETNSEPARABLEFILTERARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; rowBufSize: TGLsizei; row: Pointer; columnBufSize: TGLsizei; column: Pointer; span: Pointer); stdcall;

This item has no description.

PFNGLGETNTEXIMAGEARBPROC = procedure(target: Cardinal; level: TGLint; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; img: Pointer); stdcall;

This item has no description.

PFNGLGETNUNIFORMDVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETNUNIFORMFVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETNUNIFORMIVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLint); stdcall;

This item has no description.

PFNGLGETNUNIFORMUIVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLuint); stdcall;

This item has no description.

PFNGLGetObjectLabel = procedure(identifier : Cardinal; name : Cardinal; bufsize : TGLsizei; length : PGLsizei; label_ : PAnsiChar); stdcall;

This item has no description.

PFNGLGETOBJECTPARAMETERFVARBPROC = procedure(obj: TGLhandleARB; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETOBJECTPARAMETERIVARBPROC = procedure(obj: TGLhandleARB; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGetObjectPtrLabel = procedure(const ptr : Pointer; bufSize : TGLsizei; length : PGLsizei; label_ : PAnsiChar); stdcall;

This item has no description.

PFNGLGETOCCLUSIONQUERYIVNVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETOCCLUSIONQUERYUIVNVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETPATHCOLORGENFVNVPROC = procedure (color: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHCOLORGENIVNVPROC = procedure (color: Cardinal; pname: Cardinal; value: PGLint); stdcall;

This item has no description.

PFNGLGETPATHCOMMANDSNVPROC = procedure (path: Cardinal; commands: PGLubyte); stdcall;

This item has no description.

PFNGLGETPATHCOORDSNVPROC = procedure (path: Cardinal; coords: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHDASHARRAYNVPROC = procedure (path: Cardinal; dashArray: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHLENGTHNVPROC = function (path: Cardinal; startSegment: TGLsizei; numSegments: TGLsizei): TGLfloat; stdcall;

This item has no description.

PFNGLGETPATHMETRICRANGENVPROC = procedure (metricQueryMask: TGLbitfield; firstPathName: Cardinal; numPaths: TGLsizei; stride: TGLsizei; metrics: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHMETRICSNVPROC = procedure (metricQueryMask: TGLbitfield; numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; stride: TGLsizei; metrics: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHPARAMETERFVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHPARAMETERIVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLint); stdcall;

This item has no description.

PFNGLGETPATHSPACINGNVPROC = procedure (pathListMode: Cardinal; numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; advanceScale: TGLfloat; kerningScale: TGLfloat; transformType: Cardinal; returnedSpacing: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHTEXGENFVNVPROC = procedure (texCoordSet: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHTEXGENIVNVPROC = procedure (texCoordSet: Cardinal; pname: Cardinal; value: PGLint); stdcall;

This item has no description.

PFNGLGETPOINTERINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLvoid); stdcall;

This item has no description.

PFNGLGETPROGRAMBINARYPROC = procedure(_program: Cardinal; bufSize: TGLsizei; length: PGLsizei; binaryFormat: PCardinal; binary: Pointer); stdcall;

GL_ARB_get_program_binary (ARB #96)

PFNGLGETPROGRAMENVPARAMETERDVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETPROGRAMENVPARAMETERFVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETPROGRAMINFOLOGPROC = procedure(_program: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;

This item has no description.

PFNGLGetProgramInterfaceiv = procedure(program_ : Cardinal;programInterface : Cardinal; pname : Cardinal; params : PGLint); stdcall;

GL_ARB_program_interface_query (ARB #134)

PFNGLGETPROGRAMIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETPROGRAMIVNVPROC = procedure (id: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETPROGRAMIVPROC = procedure(_program: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETPROGRAMPARAMETERDVNVPROC = procedure (target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETPROGRAMPARAMETERFVNVPROC = procedure (target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETPROGRAMPIPELINEINFOLOGPROC = procedure(pipeline: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;

This item has no description.

PFNGLGETPROGRAMPIPELINEIVPROC = procedure(pipeline: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGetProgramResourceIndex = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : Cardinal; stdcall;

This item has no description.

PFNGLGetProgramResourceiv = procedure(program_ : Cardinal;programInterface : Cardinal; index : Cardinal; propCount : TGLsizei; const props : PCardinal; bufSize : TGLsizei; length : PGLsizei; params : PGLint); stdcall;

This item has no description.

PFNGLGetProgramResourceLocation = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : TGLint; stdcall;

This item has no description.

PFNGLGetProgramResourceLocationIndex = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : TGLint; stdcall;

This item has no description.

PFNGLGetProgramResourceName = procedure(program_ : Cardinal;programInterface : Cardinal; index : Cardinal; bufSize : TGLsizei; length : PGLsizei; name : PAnsiChar); stdcall;

This item has no description.

PFNGLGETPROGRAMSTAGEIVPROC = procedure(_program: Cardinal; shadertype: Cardinal; pname: Cardinal; values: PGLint); stdcall;

This item has no description.

PFNGLGETPROGRAMSTRINGARBPROC = procedure(target: Cardinal; pname: Cardinal; _string: pointer); stdcall;

This item has no description.

PFNGLGETPROGRAMSTRINGNVPROC = procedure (id: Cardinal; pname: Cardinal; programIdx: PGLubyte); stdcall;

This item has no description.

PFNGLGETQUERYINDEXEDIVPROC = procedure(target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTI64VEXTPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint64EXT); stdcall;

GL_EXT_timer_query (EXT #319)

PFNGLGETQUERYOBJECTI64VPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTIVARBPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTIVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTUI64VEXTPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTUI64VPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint64); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTUIVARBPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTUIVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETRENDERBUFFERPARAMETERIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETSAMPLERPARAMETERFVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETSAMPLERPARAMETERIFVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETSAMPLERPARAMETERIIVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETSAMPLERPARAMETERIVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETSEPARABLEFILTERPROC = procedure(target, format, Atype: Cardinal; row, column, span: Pointer); stdcall;

deprecated;

PFNGLGETSHADERINFOLOGPROC = procedure(shader: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;

This item has no description.

PFNGLGETSHADERIVPROC = procedure(shader: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETSHADERPRECISIONFORMATPROC = procedure(shadertype: Cardinal; precisiontype: Cardinal; range: PGLint; precision: PGLint); stdcall;

This item has no description.

PFNGLGETSHADERSOURCEARBPROC = procedure(obj: TGLhandleARB; maxLength: TGLsizei; length: PGLsizei; source: PAnsiChar); stdcall;

This item has no description.

PFNGLGETSHADERSOURCEPROC = procedure(shader:Cardinal; bufSize: TGLsizei; length: PGLsizei; source: PAnsiChar); stdcall;

This item has no description.

PFNGLGETSTRINGIPROC = function(name: Cardinal; index: Cardinal): PAnsiChar; stdcall;

This item has no description.

PFNGLGETSUBROUTINEINDEXPROC = function(_program: Cardinal; shadertype: Cardinal; const name: PAnsiChar): Cardinal; stdcall;

This item has no description.

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC = function(_program: Cardinal; shadertype: Cardinal; const name: PAnsiChar): TGLint; stdcall;

GL_ARB_shader_subroutine (ARB #90)

PFNGLGETSYNCIVPROC = procedure(sync: TGLsync; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

This item has no description.

PFNGLGETTEXPARAMETERIIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTEXPARAMETERIIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTEXPARAMETERIUIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETTEXPARAMETERIUIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETTEXTUREIMAGEEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; format: Cardinal; type_: Cardinal; pixels: PGLvoid); stdcall;

This item has no description.

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: TGLint); stdcall;

This item has no description.

PFNGLGETTEXTUREPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETTEXTUREPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETTEXTUREPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTRACKMATRIXIVNVPROC = procedure (target: Cardinal; address: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC = procedure(_program: Cardinal; index: Cardinal; location: PGLint); stdcall;

This item has no description.

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETUNIFORMBLOCKINDEXPROC = function(_program: Cardinal; uniformBlockName: PAnsiChar): Cardinal; stdcall;

This item has no description.

PFNGLGETUNIFORMBUFFERSIZEEXTPROC = function(_program: Cardinal; location: TGLint): TGLint; stdcall;

This item has no description.

PFNGLGETUNIFORMDVPROC = procedure(_program: Cardinal; location: TGLint; params : PGLdouble); stdcall;

This item has no description.

PFNGLGETUNIFORMFVARBPROC = procedure(programObj: TGLhandleARB; location: TGLint; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETUNIFORMFVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETUNIFORMINDICESPROC = procedure(_program: Cardinal; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;

GL_ARB_uniform_buffer_object (ARB #57)

PFNGLGETUNIFORMIVARBPROC = procedure(programObj: TGLhandleARB; location: TGLint; params: PGLint); stdcall;

This item has no description.

PFNGLGETUNIFORMIVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLint); stdcall;

This item has no description.

PFNGLGETUNIFORMLOCATIONARBPROC = function(programObj: TGLhandleARB; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETUNIFORMLOCATIONPROC = function(_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETUNIFORMOFFSETEXTPROC = function(_program: Cardinal; location: TGLint): PGLint; stdcall;

This item has no description.

PFNGLGETUNIFORMSUBROUTINEUIVPROC = procedure(shadertype: Cardinal; location: TGLint; params: PGLuint); stdcall;

This item has no description.

PFNGLGETUNIFORMUI64VNVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGETUNIFORMUIVEXTPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint); stdcall;

This item has no description.

PFNGLGETUNIFORMUIVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint); stdcall;

This item has no description.

PFNGLGETVARYINGLOCATIONNVPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBDVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBDVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBDVPROC = procedure(index:Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBFVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBFVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBFVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIIVEXTPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIUIVEXTPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIUIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBLDVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBPOINTERVARBPROC = procedure(index: Cardinal; pname: Cardinal; _pointer: pointer); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBPOINTERVNVPROC = procedure (index: Cardinal; pname: Cardinal; pointer: PGLPointer); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBPOINTERVPROC = procedure(index: Cardinal; pname: Cardinal; _pointer:pointer); stdcall;

This item has no description.

PFNGLHISTOGRAMPROC = procedure(target: Cardinal; width: TGLsizei; internalformat: Cardinal; sink: TGLboolean); stdcall;

deprecated;

PFNGLINDEXFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLINDEXFUNCEXTPROC = procedure(func: Cardinal; ref: TGLfloat); stdcall;

GL_EXT_index_func (EXT #95)

PFNGLINDEXMATERIALEXTPROC = procedure(face: Cardinal; mode: Cardinal); stdcall;

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; GL_EXT_index_material (EXT #94)

PFNGLINTERPOLATEPATHSNVPROC = procedure (resultPath: Cardinal; pathA: Cardinal; pathB: Cardinal; weight: TGLfloat); stdcall;

This item has no description.

PFNGLInvalidateBufferData = procedure(buffer : Cardinal); stdcall;

This item has no description.

PFNGLInvalidateBufferSubData = procedure(buffer : Cardinal; offset : TGLintptr; length : TGLsizeiptr); stdcall;

This item has no description.

PFNGLInvalidateFramebuffer = procedure(target : Cardinal; numAttachments : TGLsizei; const attachments : PCardinal); stdcall;

This item has no description.

PFNGLInvalidateSubFramebuffer = procedure(target : Cardinal; numAttachments : TGLsizei; const attachments : PCardinal; x : TGLint; y : TGLint; width : TGLsizei; height : TGLsizei); stdcall;

This item has no description.

PFNGLInvalidateTexImage = procedure(texture : Cardinal; level : TGLint); stdcall;

This item has no description.

PFNGLInvalidateTexSubImage = procedure(texture : Cardinal; level : TGLint; xoffset : TGLint; yoffset : TGLint; zoffset : TGLint; width : TGLsizei; height : TGLsizei; depth : TGLsizei); stdcall;

GL_ARB_invalidate_subdata (ARB #132)

PFNGLISBUFFERARBPROC = function(buffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISBUFFERPROC = function(buffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISBUFFERRESIDENTNVPROC = function(target: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISENABLEDINDEXEDEXTPROC = function(target: Cardinal; index: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISENABLEDIPROC = function(target: Cardinal; index: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISFENCENVPROC = function(fence: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISFRAMEBUFFEREXTPROC = function(framebuffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISFRAMEBUFFERPROC = function(framebuffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISNAMEDBUFFERRESIDENTNVPROC = function (buffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISOCCLUSIONQUERYNVPROC = function(id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPATHNVPROC = function(path: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPOINTINFILLPATHNVPROC = function (path: Cardinal; mask: Cardinal; x: TGLfloat; y: TGLfloat): TGLboolean; stdcall;

This item has no description.

PFNGLISPOINTINSTROKEPATHNVPROC = function (path: Cardinal; x: TGLfloat; y: TGLfloat): TGLboolean; stdcall;

This item has no description.

PFNGLISPROGRAMARBPROC = function(_program: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPROGRAMNVPROC = function (id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPROGRAMPIPELINEPROC = function(pipeline: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPROGRAMPROC = function(_program: Cardinal):TGLboolean; stdcall;

This item has no description.

PFNGLISQUERYARBPROC = function(id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISQUERYPROC = function(id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISRENDERBUFFEREXTPROC = function(renderbuffer: Cardinal): TGLboolean; stdcall;

GL_EXT_framebuffer_object (EXT #310)

PFNGLISRENDERBUFFERPROC = function(renderbuffer: Cardinal): TGLBoolean; stdcall;

GL_ARB_framebuffer_object (ARB #45)

PFNGLISSAMPLERPROC = function(sampler: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISSHADERPROC = function(shader: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISSYNCPROC = function(sync: TGLsync): TGLboolean; stdcall;

This item has no description.

PFNGLISTEXTUREEXTPROC = function(texture: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISTRANSFORMFEEDBACKPROC = function(id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISVERTEXARRAYPROC = function(_array: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLLINKPROGRAMARBPROC = procedure(programObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLLINKPROGRAMPROC = procedure(_program: Cardinal); stdcall;

This item has no description.

PFNGLLOADPROGRAMNVPROC = procedure (target: Cardinal; id: Cardinal; len: TGLSizei; programIdx: PGLubyte); stdcall;

This item has no description.

PFNGLLOADTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;

This item has no description.

PFNGLLOADTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;

deprecated;

PFNGLLOADTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;

GL_ARB_transpose_matrix (ARB #3)

PFNGLLOADTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix

PFNGLLOCKARRAYSEXTPROC = procedure(first: TGLint; count: TGLsizei); stdcall;

GL_EXT_compiled_vertex_array (EXT #97)

PFNGLMAKEBUFFERNONRESIDENTNVPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLMAKEBUFFERRESIDENTNVPROC = procedure(target: Cardinal; access: Cardinal); stdcall;

GL_NV_shader_buffer_load (EXT #379)

PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC = procedure(buffer: Cardinal); stdcall;

This item has no description.

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC = procedure(buffer: Cardinal; access: Cardinal); stdcall;

This item has no description.

PFNGLMAPBUFFERARBPROC = function(target: Cardinal; access: Cardinal): Pointer; stdcall;

This item has no description.

PFNGLMAPBUFFERPROC = function(target: Cardinal; access: Cardinal): Pointer; stdcall;

This item has no description.

PFNGLMAPBUFFERRANGEPROC = function(target: Cardinal; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;

GL_ARB_map_buffer_range (ARB #50)

PFNGLMAPNAMEDBUFFEREXTPROC = function(buffer: Cardinal; access: Cardinal): PGLvoid; stdcall;

This item has no description.

PFNGLMAPNAMEDBUFFERRANGEEXTPROC = function(buffer: Cardinal; offset: TGLintptr; length: TGLsizeiptr; access: TGLbitfield): PGLvoid; stdcall;

This item has no description.

PFNGLMATRIXFRUSTUMEXTPROC = procedure(mode: Cardinal; left: TGLdouble; right: TGLdouble; bottom: TGLdouble; top: TGLdouble; zNear: TGLdouble; zFar: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXINDEXPOINTERARBPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer:pointer); stdcall;

This item has no description.

PFNGLMATRIXINDEXUBVARBPROC = procedure(size: TGLint; indices: PGLubyte); stdcall;

This item has no description.

PFNGLMATRIXINDEXUIVARBPROC = procedure(size: TGLint; indices: PGLuint); stdcall;

This item has no description.

PFNGLMATRIXINDEXUSVARBPROC = procedure(size: TGLint; indices: PGLushort); stdcall;

This item has no description.

PFNGLMATRIXLOADDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;

This item has no description.

PFNGLMATRIXLOADFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;

This item has no description.

PFNGLMATRIXLOADIDENTITYEXTPROC = procedure(mode: Cardinal); stdcall;

This item has no description.

PFNGLMATRIXLOADTRANSPOSEDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;

This item has no description.

PFNGLMATRIXLOADTRANSPOSEFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;

This item has no description.

PFNGLMATRIXMULTDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;

This item has no description.

PFNGLMATRIXMULTFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;

This item has no description.

PFNGLMATRIXMULTTRANSPOSEDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;

This item has no description.

PFNGLMATRIXMULTTRANSPOSEFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;

This item has no description.

PFNGLMATRIXORTHOEXTPROC = procedure(mode: Cardinal; left: TGLdouble; right: TGLdouble; bottom: TGLdouble; top: TGLdouble; zNear: TGLdouble; zFar: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXPOPEXTPROC = procedure(mode: Cardinal); stdcall;

This item has no description.

PFNGLMATRIXPUSHEXTPROC = procedure(mode: Cardinal); stdcall;

This item has no description.

PFNGLMATRIXROTATEDEXTPROC = procedure(mode: Cardinal; angle: TGLdouble; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXROTATEFEXTPROC = procedure(mode: Cardinal; angle: TGLfloat; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLMATRIXSCALEDEXTPROC = procedure(mode: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXSCALEFEXTPROC = procedure(mode: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLMATRIXTRANSLATEDEXTPROC = procedure(mode: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXTRANSLATEFEXTPROC = procedure(mode: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLMINMAXPROC = procedure(target, internalformat: Cardinal; sink: TGLboolean); stdcall;

deprecated;

PFNGLMINSAMPLESHADINGARBPROC = procedure(value: Single); stdcall;

GL_ARB_sample_shading (ARB #70)

PFNGLMINSAMPLESHADINGPROC = procedure(value: Single); stdcall;

promoted to core v4.0 from GL_ARB_sample_shading (ARB #70)

PFNGLMULTIDRAWARRAYSEXTPROC = procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

GL_EXT_multi_draw_arrays (EXT #148)

PFNGLMultiDrawArraysIndirect = procedure(mode : Cardinal; const indirect : Pointer; drawcount : TGLsizei; stride : TGLsizei); stdcall;

GL_ARB_multi_draw_indirect (ARB #133)

PFNGLMULTIDRAWARRAYSPROC = procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)

PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; count: PGLsizei; _type: Cardinal; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;

This item has no description.

PFNGLMULTIDRAWELEMENTSEXTPROC = procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLMultiDrawElementsIndirect = procedure(mode : Cardinal; type_ : Cardinal; const indirect : Pointer; drawcount : TGLsizei; stride : TGLsizei); stdcall;

This item has no description.

PFNGLMULTIDRAWELEMENTSPROC = procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLMULTITEXBUFFEREXTPROC = procedure(texunit: Cardinal; target: Cardinal; interformat: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1DARBPROC = procedure(target: Cardinal; s: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1DPROC = procedure(target: Cardinal; s: TGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD1DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD1FARBPROC = procedure(target: Cardinal; s: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1FPROC = procedure(target: Cardinal; s: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD1FVARBPROC = procedure(target: Cardinal; v: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1FVPROC = procedure(target: Cardinal; v: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD1IARBPROC = procedure(target: Cardinal; s: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1IPROC = procedure(target: Cardinal; s: TGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD1IVARBPROC = procedure(target: Cardinal; v: PGLInt); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1IVPROC = procedure(target: Cardinal; v: PGLInt); stdcall;

deprecated;

PFNGLMULTITEXCOORD1SARBPROC = procedure(target: Cardinal; s: TGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1SPROC = procedure(target: Cardinal; s: TGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD1SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD2DARBPROC = procedure(target: Cardinal; s, t: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2DPROC = procedure(target: Cardinal; s, t: TGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD2DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD2FARBPROC = procedure(target: Cardinal; s, t: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2FPROC = procedure(target: Cardinal; s, t: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD2FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD2IARBPROC = procedure(target: Cardinal; s, t: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2IPROC = procedure(target: Cardinal; s, t: TGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD2IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD2SARBPROC = procedure(target: Cardinal; s, t: TGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2SPROC = procedure(target: Cardinal; s, t: TGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD2SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD3DARBPROC = procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3DPROC = procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD3DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD3FARBPROC = procedure(target: Cardinal; s, t, r: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3FPROC = procedure(target: Cardinal; s, t, r: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD3FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD3IARBPROC = procedure(target: Cardinal; s, t, r: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3IPROC = procedure(target: Cardinal; s, t, r: TGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD3IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD3SARBPROC = procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3SPROC = procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD3SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD4DARBPROC = procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4DPROC = procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD4DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD4FARBPROC = procedure(target: Cardinal; s, t, r, q: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4FPROC = procedure(target: Cardinal; s, t, r, q: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD4FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD4IARBPROC = procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4IPROC = procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD4IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD4SARBPROC = procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4SPROC = procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD4SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORDP1UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP1UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP2UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP2UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP3UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP3UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP4UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP4UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXCOORDPOINTEREXTPROC = procedure(texunit: Cardinal; size: TGLint; type_: Cardinal; stride: TGLsizei; const pointer: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXENVFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXENVFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXENVIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXENVIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXGENDEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXGENDVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXGENFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXGENFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXGENIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXGENIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXRENDERBUFFEREXTPROC = procedure(texunit: Cardinal; target: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; type_: Cardinal; const pixels:PGLvoid); stdcall;

This item has no description.

PFNGLMULTTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;

This item has no description.

PFNGLMULTTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;

deprecated;

PFNGLMULTTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;

This item has no description.

PFNGLMULTTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;

deprecated;

PFNGLNAMEDBUFFERDATAEXTPROC = procedure(buffer: Cardinal; size: TGLsizei; const data: PGLvoid; usage: Cardinal); stdcall;

This item has no description.

PFNGLNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr; const data: PGLvoid); stdcall;

This item has no description.

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC = procedure(readBuffer: Cardinal; writeBuffer: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

This item has no description.

PFNGLNamedFramebufferParameteri = procedure(framebuffer : Cardinal; pname : Cardinal; param : TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; zoffset: TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; face: Cardinal); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLdouble); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLuint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLfloat); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLuint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: Cardinal; target: Cardinal; format: Cardinal; len: TGLsizei; const string_: PGLvoid); stdcall;

This item has no description.

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC = procedure(renderbuffer: Cardinal; interformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC = procedure(renderbuffer: Cardinal; coverageSamples: TGLsizei; colorSamples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(renderbuffer: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLNORMALFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLNORMALP3UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLNORMALP3UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLObjectLabel = procedure(identifier : Cardinal; name : Cardinal; length : TGLsizei; const label_ : PAnsiChar); stdcall;

This item has no description.

PFNGLObjectPtrLabel = procedure(const ptr : Pointer; length : TGLsizei; const label_ : PAnsiChar); stdcall;

This item has no description.

PFNGLPATCHPARAMETERFVPROC = procedure(pname: Cardinal; const values: PGLfloat); stdcall;

This item has no description.

PFNGLPATCHPARAMETERIPROC = procedure(pname: Cardinal; value: TGLint); stdcall;

GL_ARB_tessellation_shader (ARB #91)

PFNGLPATHCOLORGENNVPROC = procedure (color: Cardinal; genMode: Cardinal; colorFormat: Cardinal; coeffs: PGLfloat); stdcall;

This item has no description.

PFNGLPATHCOMMANDSNVPROC = procedure(path: Cardinal; numCommands: TGLsizei; commands: PGLubyte; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;

This item has no description.

PFNGLPATHCOORDSNVPROC = procedure(path: Cardinal; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;

This item has no description.

PFNGLPATHCOVERDEPTHFUNCNVPROC = procedure (func: Cardinal); stdcall;

This item has no description.

PFNGLPATHDASHARRAYNVPROC = procedure (path: Cardinal; dashCount: TGLsizei; dashArray: PGLfloat); stdcall;

This item has no description.

PFNGLPATHFOGGENNVPROC = procedure (genMode: Cardinal); stdcall;

This item has no description.

PFNGLPATHGLYPHRANGENVPROC = procedure(firstPathName: Cardinal; fontTarget: Cardinal; fontName: PAnsiChar; fontStyle: TGLbitfield; firstGlyph: Cardinal; numGlyphs: TGLsizei; handleMissingGlyphs: Cardinal; pathParameterTemplate: Cardinal; emScale: TGLfloat); stdcall;

This item has no description.

PFNGLPATHGLYPHSNVPROC = procedure(firstPathName: Cardinal; fontTarget: Cardinal; fontName: PGLvoid; fontStyle: TGLbitfield; numGlyphs: TGLsizei; _type: Cardinal; charcodes: PGLvoid; handleMissingGlyphs: Cardinal; pathParameterTemplate: Cardinal; emScale: TGLfloat); stdcall;

This item has no description.

PFNGLPATHPARAMETERFNVPROC = procedure (path: Cardinal; pname: Cardinal; value: TGLfloat); stdcall;

This item has no description.

PFNGLPATHPARAMETERFVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;

This item has no description.

PFNGLPATHPARAMETERINVPROC = procedure (path: Cardinal; pname: Cardinal; value: TGLint); stdcall;

This item has no description.

PFNGLPATHPARAMETERIVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLint); stdcall;

This item has no description.

PFNGLPATHSTENCILDEPTHOFFSETNVPROC = procedure (factor: TGLfloat; units: TGLfloat); stdcall;

This item has no description.

PFNGLPATHSTENCILFUNCNVPROC = procedure (func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;

This item has no description.

PFNGLPATHSTRINGNVPROC = procedure(path: Cardinal; format: Cardinal; length: TGLsizei; pathString: PGLvoid); stdcall;

This item has no description.

PFNGLPATHSUBCOMMANDSNVPROC = procedure(path: Cardinal; commandStart: TGLsizei; commandsToDelete: TGLsizei; numCommands: TGLsizei; commands: PGLubyte; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;

This item has no description.

PFNGLPATHSUBCOORDSNVPROC = procedure(path: Cardinal; coordStart: TGLsizei; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;

This item has no description.

PFNGLPATHTEXGENNVPROC = procedure (texCoordSet: Cardinal; genMode: Cardinal; components: TGLint; coeffs: PGLfloat); stdcall;

This item has no description.

PFNGLPAUSETRANSFORMFEEDBACKPROC = procedure(); stdcall;

This item has no description.

PFNGLPOINTALONGPATHNVPROC = function (path: Cardinal; startSegment: TGLsizei; numSegments: TGLsizei; distance: TGLfloat; x: PGLfloat; y: PGLfloat; tangentX: PGLfloat; tangentY: PGLfloat): TGLboolean; stdcall;

This item has no description.

PFNGLPOINTPARAMETERFARBPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;

GL_ARB_point_parameter (ARB #14)

PFNGLPOINTPARAMETERFPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)

PFNGLPOINTPARAMETERFVARBPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLPOINTPARAMETERFVPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLPOINTPARAMETERINVPROC = procedure(pname: Cardinal; param: TGLint); stdcall;

GL_NV_point_sprite (EXT #262)

PFNGLPOINTPARAMETERIPROC = procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLPOINTPARAMETERIVNVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLPOINTPARAMETERIVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLPOLYGONOFFSETEXTPROC = procedure(factor, bias: TGLfloat); stdcall;

GL_EXT_polygon_offset (EXT #3)

PFNGLPopDebugGroup = procedure; stdcall;

This item has no description.

PFNGLPRIMITIVERESTARTINDEXNVPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLPRIMITIVERESTARTINDEXPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLPRIMITIVERESTARTNVPROC = procedure(); stdcall;

GL_NV_primitive_restart (EXT #285)

PFNGLPRIORITIZETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint; priorities: PSingle); stdcall;

This item has no description.

PFNGLPROGRAMBINARYPROC = procedure(_program: Cardinal; binaryFormat: Cardinal; binary: Pointer; length: TGLsizei); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETER4DARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETER4DVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETER4FARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETER4FVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC = procedure(target:Cardinal; index:Cardinal; count:TGLsizei; const params:PGLfloat); stdcall;

GL_EXT_gpu_program_parameters (EXT #320)

PFNGLPROGRAMLOCALPARAMETER4DARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMLOCALPARAMETER4FARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(target:Cardinal; index:Cardinal; count:TGLsizei; const params:PGLFloat); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETER4DNVPROC = procedure (target: Cardinal; index: Cardinal; x, y, z, w: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETER4DVNVPROC = procedure (target: Cardinal; index: Cardinal; v: PGLdouble ); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETER4FNVPROC = procedure (target: Cardinal; index: Cardinal; x, y, z, w: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETER4FVNVPROC = procedure (target: Cardinal; index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETERIARBPROC = procedure ( _program:Cardinal; pname:Cardinal; value: TGLint); stdcall;

GL_ARB_geometry_shader4 (ARB #47)

PFNGLPROGRAMPARAMETERIEXTPROC = procedure ( _program:Cardinal; pname:Cardinal; value: TGLint); stdcall;

GL_EXT_geometry_shader4 (EXT #324)

PFNGLPROGRAMPARAMETERIPROC = procedure(_program: Cardinal; pname: Cardinal; value: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETERS4DVNVPROC = procedure (target: Cardinal; index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETERS4FVNVPROC = procedure (target: Cardinal; index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMSTRINGARBPROC = procedure(target: Cardinal; format: Cardinal; len: TGLsizei; const _string: pointer); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble; v3: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMUI64NVPROC = procedure(_program: Cardinal; location: TGLint; value: TGLuint64EXT); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMUI64VNVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

This item has no description.

PFNGLPROGRAMVERTEXLIMITNVPROC = procedure (target: Cardinal; limit: TGLint); stdcall;

GL_NV_geometry_program4 (EXT #323)

PFNGLPROVOKINGVERTEXPROC = procedure(mode: Cardinal); stdcall;

GL_ARB_provoking_vertex (ARB #64)

PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: TGLbitfield); stdcall;

This item has no description.

PFNGLPushDebugGroup = procedure(source : Cardinal; id : Cardinal; length : TGLsizei; const message_ : PAnsiChar); stdcall;

GL_ARB_shader_stencil_export (ARB #106) (no entry points) GL_KHR_debug (ARB #119)

PFNGLQUERYCOUNTERPROC = procedure(id: Cardinal; target: Cardinal); stdcall;

GL_ARB_timer_query (ARB #85)

PFNGLREADNPIXELSARBPROC = procedure(x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; data: Pointer); stdcall;

This item has no description.

PFNGLRELEASESHADERCOMPILERPROC = procedure(); stdcall;

GL_ARB_ES2_compatibility (ARB #95)

PFNGLRENDERBUFFERSTORAGEEXTPROC = procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

GL_EXT_framebuffer_multisample (EXT #317)

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLRENDERBUFFERSTORAGEPROC = procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLREQUESTRESIDENTPROGRAMSNVPROC = procedure (n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

PFNGLRESETHISTOGRAMPROC = procedure(target: Cardinal); stdcall;

deprecated;

PFNGLRESETMINMAXPROC = procedure(target: Cardinal); stdcall;

deprecated;

PFNGLRESIZEBUFFERSMESAPROC = procedure; stdcall;

GL_MESA_resize_buffers (EXT #196)

PFNGLRESUMETRANSFORMFEEDBACKPROC = procedure(); stdcall;

This item has no description.

PFNGLSAMPLECOVERAGEARBPROC = procedure(Value: Single; invert: TGLboolean); stdcall;

GL_ARB_multisample (ARB #5)

PFNGLSAMPLECOVERAGEPROC = procedure(Value: Single; invert: TGLboolean); stdcall;

promoted to core v1.3 from GL_ARB_multisample (#5)

PFNGLSAMPLEMASKEXTPROC = procedure(Value: Single; invert: TGLboolean); stdcall;

GL_EXT_multisample (EXT #209)

PFNGLSAMPLEMASKIPROC = procedure(index: Cardinal; mask: TGLbitfield); stdcall;

This item has no description.

PFNGLSAMPLEMASKSGISPROC = procedure(Value: Single; invert: TGLboolean); stdcall;

GL_SGIS_multisample (EXT #25)

PFNGLSAMPLEPASSARBPROC = procedure(pass: Cardinal); stdcall;

ARB Extensions unknown ARB extension

PFNGLSAMPLEPATTERNEXTPROC = procedure(pattern: Cardinal); stdcall;

This item has no description.

PFNGLSAMPLEPATTERNSGISPROC = procedure(pattern: Cardinal); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERFPROC = procedure(sampler: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERFVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERIIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERIPROC = procedure(sampler: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERIUIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLSCISSORARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLint); stdcall;

This item has no description.

PFNGLSCISSORINDEXEDPROC = procedure(index: Cardinal; left: TGLint; bottom: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLSCISSORINDEXEDVPROC = procedure(index: Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3BEXTPROC = procedure(red, green, blue: TGLbyte); stdcall;

GL_EXT_secondary_color (EXT #145)

PFNGLSECONDARYCOLOR3BPROC = procedure(red, green, blue: TGLbyte); stdcall;

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)

PFNGLSECONDARYCOLOR3BVEXTPROC = procedure(v: PGLbyte); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3BVPROC = procedure(v: PGLbyte); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3DEXTPROC = procedure(red, green, blue: TGLdouble); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3DPROC = procedure(red, green, blue: TGLdouble); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3DVEXTPROC = procedure(v: PGLdouble); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3DVPROC = procedure(v: PGLdouble); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3FEXTPROC = procedure(red, green, blue: TGLfloat); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3FPROC = procedure(red, green, blue: TGLfloat); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3FVEXTPROC = procedure(v: PGLfloat); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3FVPROC = procedure(v: PGLfloat); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3IEXTPROC = procedure(red, green, blue: TGLint); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3IPROC = procedure(red, green, blue: TGLint); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3IVEXTPROC = procedure(v: PGLint); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3IVPROC = procedure(v: PGLint); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3SEXTPROC = procedure(red, green, blue: TGLshort); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3SPROC = procedure(red, green, blue: TGLshort); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3SVEXTPROC = procedure(v: PGLshort); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3SVPROC = procedure(v: PGLshort); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3UBEXTPROC = procedure(red, green, blue: TGLubyte); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3UBPROC = procedure(red, green, blue: TGLubyte); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3UBVEXTPROC = procedure(v: PGLubyte); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3UBVPROC = procedure(v: PGLubyte); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3UIEXTPROC = procedure(red, green, blue: Cardinal); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3UIPROC = procedure(red, green, blue: Cardinal); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3UIVEXTPROC = procedure(v: PGLuint); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3UIVPROC = procedure(v: PGLuint); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3USEXTPROC = procedure(red, green, blue: TGLushort); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3USPROC = procedure(red, green, blue: TGLushort); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3USVEXTPROC = procedure(v: PGLushort); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3USVPROC = procedure(v: PGLushort); stdcall;

deprecated;

PFNGLSECONDARYCOLORFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLSECONDARYCOLORP3UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;

This item has no description.

PFNGLSECONDARYCOLORP3UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

PFNGLSECONDARYCOLORPOINTEREXTPROC = procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

This item has no description.

PFNGLSECONDARYCOLORPOINTERPROC = procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

deprecated;

PFNGLSEPARABLEFILTER2DPROC = procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; row, column: Pointer); stdcall;

deprecated;

PFNGLSETFENCENVPROC = procedure(fence: Cardinal; condition: Cardinal); stdcall;

This item has no description.

PFNGLSHADERBINARYPROC = procedure(count: TGLsizei; shaders: PGLuint; binaryformat: Cardinal; binary: Pointer; length: TGLsizei); stdcall;

This item has no description.

PFNGLSHADERSOURCEARBPROC = procedure(shaderObj: TGLhandleARB; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

This item has no description.

PFNGLSHADERSOURCEPROC = procedure(shader: Cardinal; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

This item has no description.

PFNGLShaderStorageBlockBinding = procedure(program_ : Cardinal; storageBlockIndex : Cardinal; storageBlockBinding : Cardinal); stdcall;

GL_ARB_robust_buffer_access_behavior (ARB #135) (no entry points) GL_ARB_shader_image_size (ARB #136) (no entry points) GL_ARB_shader_storage_buffer_object (ARB #137)

PFNGLSTENCILCLEARTAGEXTPROC = procedure(stencilTagBits: TGLsizei; stencilClearTag: Cardinal); stdcall;

GL_EXT_stencil_clear_tag (EXT #314)

PFNGLSTENCILFILLPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; fillMode: Cardinal; mask: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLSTENCILFILLPATHNVPROC = procedure (path: Cardinal; fillMode: Cardinal; mask: Cardinal); stdcall;

This item has no description.

PFNGLSTENCILFUNCSEPARATEPROC = procedure(face, func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;

This item has no description.

PFNGLSTENCILMASKSEPARATEPROC = procedure(face: Cardinal; mask: Cardinal); stdcall;

This item has no description.

PFNGLSTENCILOPSEPARATEPROC = procedure(face, sfail, dpfail, dppass: Cardinal); stdcall;

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)

PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; reference: TGLint; mask: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLSTENCILSTROKEPATHNVPROC = procedure(path: Cardinal; reference: TGLint; mask: Cardinal); stdcall;

This item has no description.

PFNGLSTRINGMARKERGREMEDYPROC = procedure(len: TGLsizei; str: PAnsiChar); stdcall;

GL_GREMEDY_string_marker (EXT #311)

PFNGLTBUFFERMASK3DFXPROC = procedure(mask: Cardinal); stdcall;

GL_3DFX_tbuffer (EXT #208)

PFNGLTESSELLATIONFACTORAMDPROC = procedure(factor: TGLfloat); stdcall;

GL_AMD_vertex_shader_tessellator (EXT #363)

PFNGLTESSELLATIONMODEAMDPROC = procedure(mode: Cardinal); stdcall;

This item has no description.

PFNGLTESTFENCENVPROC = function(fence: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLTEXBUFFERARBPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;

GL_ARB_texture_buffer_object (ARB #51)

PFNGLTEXBUFFEREXTPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;

GL_EXT_packed_float (EXT #328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (EXT #329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (EXT #330)

PFNGLTEXBUFFERPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLTexBufferRange = procedure(target : Cardinal; internalformat : Cardinal; buffer : Cardinal; offset: TGLintptr; size : TGLsizeiptr); stdcall;

GL_ARB_stencil_texturing (ARB #138) (no entry points) GL_ARB_texture_buffer_range (ARB #139)

PFNGLTEXCOORDFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLTEXCOORDP1UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLTEXCOORDP1UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLTEXCOORDP2UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLTEXCOORDP2UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLTEXCOORDP3UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLTEXCOORDP3UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLTEXCOORDP4UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLTEXCOORDP4UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLTEXIMAGE2DMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

GL_ARB_texture_multisample (ARB #67)

PFNGLTEXIMAGE3DEXTPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; Format, AType: Cardinal; pixels: Pointer); stdcall;

GL_EXT_texture3D (EXT #6)

PFNGLTEXIMAGE3DMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

This item has no description.

PFNGLTEXIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

promoted to core v1.2 from GL_EXT_texture3D (#6)

PFNGLTEXPARAMETERIIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLTEXPARAMETERIIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

promoted to core v3.0 from GL_EXT_texture_integer

PFNGLTEXPARAMETERIUIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLTEXPARAMETERIUIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLTexStorage2DMultisample = procedure(target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;

GL_ARB_texture_query_levels (ARB #140) (no entry points) GL_ARB_texture_storage_multisample (ARB #141)

PFNGLTexStorage3DMultisample = procedure(target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; depth : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;

This item has no description.

PFNGLTEXSUBIMAGE1DEXTPROC = procedure(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

GL_EXT_subtexture (EXT #9)

PFNGLTEXSUBIMAGE2DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

PFNGLTEXSUBIMAGE3DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

PFNGLTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

PFNGLTEXTUREBUFFEREXTPROC = procedure(texture: Cardinal; target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLTextureBufferRange = procedure(texture : Cardinal; target : Cardinal; internalformat : Cardinal; buffer : Cardinal; offset : TGLintptr; size : TGLsizeiptr); stdcall;

This item has no description.

PFNGLTEXTURECOLORMASKSGISPROC = procedure(red, green, blue, alpha: TGLboolean); stdcall;

GL_SGIS_texture_color_mask (EXT #214)

PFNGLTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTUREIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERIEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLTEXTURERENDERBUFFEREXTPROC = procedure(texture: Cardinal; target: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLTextureStorage2DMultisample = procedure(texture : Cardinal; target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;

This item has no description.

PFNGLTextureStorage3DMultisample = procedure(texture : Cardinal; target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; depth : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;

This item has no description.

PFNGLTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTextureView = procedure(texture : Cardinal; target : Cardinal; origtexture : Cardinal; internalformat : Cardinal; minlevel : Cardinal; numlevels : Cardinal; minlayer : Cardinal; numlayers : Cardinal); stdcall;

GL_ARB_texture_view (ARB #124)

PFNGLTRACKMATRIXNVPROC = procedure (target: Cardinal; address: Cardinal; matrix: Cardinal; transform: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC = procedure(count: TGLsizei; attribs: PGLint; bufferMode: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC = procedure(_program: Cardinal; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC = procedure(_program: Cardinal; count: TGLsizei; locations: PGLint; bufferMode: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMFEEDBACKVARYINGSPROC = procedure(_program: Cardinal; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMPATHNVPROC = procedure ( resultPath: Cardinal; srcPath: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLUDELETENURBSTESSELLATOREXTPROC = procedure(nurb: PGLUnurbs); stdcall;

This item has no description.

PFNGLUNEWNURBSTESSELLATOREXTPROC = function: PGLUnurbs; stdcall;

This item has no description.

PFNGLUNIFORM1DPROC = procedure(location: TGLint; x: TGLdouble); stdcall;

GL_ARB_gpu_shader_fp64 (ARB #89)

PFNGLUNIFORM1DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM1FARBPROC = procedure(location: TGLint; v0: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM1FPROC = procedure(location: TGLint; v0: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM1FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM1FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM1IARBPROC = procedure(location: TGLint; v0: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM1IPROC = procedure(location: TGLint; v0: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM1IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM1IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM1UIEXTPROC = procedure(location: TGLInt; v0: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM1UIPROC = procedure(location: TGLInt; v0: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM1UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM1UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM2DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM2DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM2FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM2FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM2FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM2FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM2IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM2IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM2IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM2IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM2UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM2UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM2UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM2UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM3DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM3DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM3FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM3FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM3FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM3FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM3IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM3IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM3IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM3IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM3UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM3UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM3UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM3UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM4DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM4DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM4FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM4FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM4FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM4FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM4IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM4IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM4IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM4IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM4UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM4UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM4UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM4UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORMBLOCKBINDINGPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; uniformBlockBinding: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORMBUFFEREXTPROC = procedure(_program: Cardinal; location: TGLint; buffer: Cardinal); stdcall;

GL_EXT_bindable_uniform (EXT #342)

PFNGLUNIFORMMATRIX2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

core 2.1 new commands in OpenGL 2.1

PFNGLUNIFORMMATRIX2X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMSUBROUTINESUIVPROC = procedure(shadertype: Cardinal; count: TGLsizei; const indices: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORMUI64NVPROC = procedure(location: TGLint; value: TGLuint64EXT); stdcall;

This item has no description.

PFNGLUNIFORMUI64VNVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

This item has no description.

PFNGLUNLOCKARRAYSEXTPROC = procedure; stdcall;

This item has no description.

PFNGLUNMAPBUFFERARBPROC = function(target: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLUNMAPBUFFERPROC = function(target: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLUNMAPNAMEDBUFFEREXTPROC = function(buffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLUNURBSCALLBACKDATAEXTPROC = procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

GLU extensions (might not be same naming as c versions?)

PFNGLUSEPROGRAMOBJECTARBPROC = procedure(programObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLUSEPROGRAMPROC = procedure(_program: Cardinal); stdcall;

This item has no description.

PFNGLUSEPROGRAMSTAGESPROC = procedure(pipeline: Cardinal; stages: TGLbitfield; _program: Cardinal); stdcall;

GL_ARB_separate_shader_objects (ARB #97)

PFNGLVALIDATEPROGRAMARBPROC = procedure(programObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLVALIDATEPROGRAMPIPELINEPROC = procedure(pipeline: Cardinal); stdcall;

This item has no description.

PFNGLVALIDATEPROGRAMPROC = procedure(_program: Cardinal); stdcall;

This item has no description.

PFNGLVertexArrayBindVertexBuffer = procedure(vaobj : Cardinal; bindingindex : Cardinal; buffer : Cardinal; offset : TGLintptr; stride : TGLsizei); stdcall;

This item has no description.

PFNGLVERTEXARRAYRANGENVPROC = procedure(Size: TGLsizei; p: pointer); stdcall;

This item has no description.

PFNGLVertexArrayVertexAttribBinding = procedure(vaobj : Cardinal; attribindex : Cardinal; bindingindex : Cardinal); stdcall;

This item has no description.

PFNGLVertexArrayVertexAttribFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; normalized : TGLboolean; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVertexArrayVertexAttribIFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVertexArrayVertexAttribLFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC = procedure (vaobj: Cardinal; buffer: Cardinal; index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; offset: TGLintptr); stdcall;

VertexArrayVertexAttribLOffsetEXT only valid if EXT_direct_state_access is available

PFNGLVertexArrayVertexBindingDivisor = procedure(vaobj : Cardinal; bindingindex : Cardinal; divisor : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DARBPROC = procedure(index: Cardinal; x: TGLdouble); stdcall;

GL_ARB_vertex_program (ARB #26)

PFNGLVERTEXATTRIB1DNVPROC = procedure (index: Cardinal; x: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DPROC = procedure(index:Cardinal; x: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FARBPROC = procedure(index: Cardinal; x: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FNVPROC = procedure (index: Cardinal; x: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FPROC = procedure(index:Cardinal; x: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SARBPROC = procedure(index: Cardinal; x: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SNVPROC = procedure (index: Cardinal; x: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SPROC = procedure(index:Cardinal; x: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DPROC = procedure(index:Cardinal; x,y: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FNVPROC = procedure (index: Cardinal; x: TGLfloat; y: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FPROC = procedure(index:Cardinal; x,y: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SPROC = procedure(index:Cardinal; x,y: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DPROC = procedure(index:Cardinal; x,y,z: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FNVPROC = procedure (index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FPROC = procedure(index:Cardinal; x,y,z: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SPROC = procedure(index:Cardinal; x,y,z: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4BVARBPROC = procedure(index: Cardinal; const v: PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4BVPROC = procedure(index:Cardinal; v: PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DPROC = procedure(index:Cardinal; x,y,z,w: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FNVPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FPROC = procedure(index:Cardinal; x,y,z,w: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FVNVPROC = procedure(index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4IVARBPROC = procedure(index: Cardinal; const v: PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4IVPROC = procedure(index:Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NBVARBPROC = procedure(index: Cardinal; const v: PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NBVPROC = procedure(index:Cardinal; v: PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NIVARBPROC = procedure(index: Cardinal; const v: PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NIVPROC = procedure(index:Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NSVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NSVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUBARBPROC = procedure(index: Cardinal; x: TGLubyte; y: TGLubyte; z: TGLubyte; w: TGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUBPROC = procedure(index:Cardinal; x,y,z,w: TGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUBVARBPROC = procedure(index: Cardinal; const v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUBVPROC = procedure(index:Cardinal; v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUIVARBPROC = procedure(index: Cardinal; const v: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUIVPROC = procedure(index:Cardinal; v: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUSVARBPROC = procedure(index: Cardinal; const v: PGLushort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUSVPROC = procedure(index:Cardinal; v: PGLushort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort; w: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SPROC = procedure(index:Cardinal; x,y,z,w: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UBVARBPROC = procedure(index: Cardinal; const v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UBVNVPROC = procedure (index: Cardinal; v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UBVPROC = procedure(index:Cardinal; v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UIVARBPROC = procedure(index: Cardinal; const v: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UIVPROC = procedure(index:Cardinal; v: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4USVARBPROC = procedure(index: Cardinal; const v: PGLushort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4USVPROC = procedure(index:Cardinal; v: PGLushort); stdcall;

This item has no description.

PFNGLVertexAttribBinding = procedure(attribindex : Cardinal; bindingindex : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBDIVISORARBPROC = procedure(index: Cardinal; divisor: Cardinal); stdcall;

GL_ARB_instanced_arrays (ARB #49)

PFNGLVERTEXATTRIBDIVISORPROC = procedure(index: Cardinal; divisor: Cardinal); stdcall;

Core 3.3

PFNGLVertexAttribFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; normalized : TGLboolean; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBFORMATNVPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1IEXTPROC = procedure(index: Cardinal; x: TGLint); stdcall;

GL_EXT_gpu_shader4 (EXT #326)

PFNGLVERTEXATTRIBI1IPROC = procedure(index: Cardinal; x: TGLint); stdcall;

Core 3.0 promoted to core v3.0 from GL_EXT_gpu_shader4

PFNGLVERTEXATTRIBI1IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1UIEXTPROC = procedure(index: Cardinal; x: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1UIPROC = procedure(index: Cardinal; x: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4BVEXTPROC = procedure(index: Cardinal; v:PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4BVPROC = procedure(index: Cardinal; v:PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4SVEXTPROC = procedure(index: Cardinal; v:PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4SVPROC = procedure(index: Cardinal; v:PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UBVEXTPROC = procedure(index: Cardinal; v: PGLUbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UBVPROC = procedure(index: Cardinal; v: PGLUbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4USVEXTPROC = procedure(index: Cardinal; v: PGLushort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4USVPROC = procedure(index: Cardinal; v: PGLushort); stdcall;

This item has no description.

PFNGLVertexAttribIFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBIFORMATNVPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLVERTEXATTRIBIPOINTEREXTPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBIPOINTERPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL1DPROC = procedure(index: Cardinal; x: TGLdouble); stdcall;

GL_ARB_shader_precision (ARB #98) (no entry points) GL_ARB_vertex_attrib_64bit (ARB #99)

PFNGLVERTEXATTRIBL1DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL2DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL2DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL3DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL3DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL4DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL4DVPROC = procedure(index: Cardinal; v :PGLdouble); stdcall;

This item has no description.

PFNGLVertexAttribLFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBLPOINTERPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; ptr: Pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP1UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP1UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP2UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP2UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP3UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP3UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP4UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP4UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBPOINTERARBPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei; const _pointer: pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBPOINTERNVPROC = procedure (index: Cardinal; fsize: TGLint; vertextype: Cardinal; stride: TGLSizei; pointer: Pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBPOINTERPROC = procedure(index:Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS1DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS1FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS1SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS2DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS2FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS2SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS3DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS3FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS3SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS4DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS4FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS4SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS4UBVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLubyte); stdcall;

This item has no description.

PFNGLVertexBindingDivisor = procedure(bindingindex : Cardinal; divisor : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXBLENDARBPROC = procedure(count: TGLint); stdcall;

This item has no description.

PFNGLVERTEXFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLVERTEXP2UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)

PFNGLVERTEXP2UIVPROC = procedure(_type: Cardinal; const value: PGLuint ); stdcall;

This item has no description.

PFNGLVERTEXP3UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXP3UIVPROC = procedure(_type: Cardinal; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXP4UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXP4UIVPROC = procedure(_type: Cardinal; const value: PGLuint); stdcall;

This item has no description.

PFNGLVIEWPORTARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLfloat); stdcall;

GL_ARB_viewport_array (ARB #100)

PFNGLVIEWPORTINDEXEDFPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; w: TGLfloat; h: TGLfloat); stdcall;

This item has no description.

PFNGLVIEWPORTINDEXEDFVPROC = procedure(index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLWAITSYNCPROC = procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;

This item has no description.

PFNGLWEIGHTBVARBPROC = procedure(size: TGLint; weights: PGLbyte); stdcall;

GL_ARB_vertex_blend (ARB #15) {deprecated?}

PFNGLWEIGHTDVARBPROC = procedure(size: TGLint; weights: PGLdouble); stdcall;

This item has no description.

PFNGLWEIGHTFVARBPROC = procedure(size: TGLint; weights: PGLfloat); stdcall;

This item has no description.

PFNGLWEIGHTIVARBPROC = procedure(size: TGLint; weights: PGLint); stdcall;

This item has no description.

PFNGLWEIGHTPATHSNVPROC = procedure (resultPath: Cardinal; numPaths: TGLsizei; paths: PGLuint; weights: PGLfloat); stdcall;

This item has no description.

PFNGLWEIGHTPOINTERARBPROC = procedure(size: TGLint; _type: Cardinal; stride:TGLsizei; _pointer:pointer); stdcall;

This item has no description.

PFNGLWEIGHTSVARBPROC = procedure(size: TGLint; weights: PGLshort); stdcall;

This item has no description.

PFNGLWEIGHTUBVARBPROC = procedure(size: TGLint; weights: PGLubyte); stdcall;

This item has no description.

PFNGLWEIGHTUIVARBPROC = procedure(size: TGLint; weights: PGLuint); stdcall;

This item has no description.

PFNGLWEIGHTUSVARBPROC = procedure(size: TGLint; weights: PGLushort); stdcall;

This item has no description.

PFNGLWINDOWPOS2DARBPROC = procedure(x,y : TGLdouble); stdcall;

GL_ARB_window_pos (ARB #25)

PFNGLWINDOWPOS2DPROC = procedure(x,y : TGLdouble); stdcall;

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)

PFNGLWINDOWPOS2DVARBPROC = procedure(v : PGLdouble); stdcall;

This item has no description.

PFNGLWINDOWPOS2DVPROC = procedure(v : PGLdouble); stdcall;

deprecated;

PFNGLWINDOWPOS2FARBPROC = procedure(x,y : TGLfloat); stdcall;

This item has no description.

PFNGLWINDOWPOS2FPROC = procedure(x,y : TGLfloat); stdcall;

deprecated;

PFNGLWINDOWPOS2FVARBPROC = procedure(v : PGLfloat); stdcall;

This item has no description.

PFNGLWINDOWPOS2FVPROC = procedure(v : PGLfloat); stdcall;

deprecated;

PFNGLWINDOWPOS2IARBPROC = procedure(x,y : TGLint); stdcall;

This item has no description.

PFNGLWINDOWPOS2IPROC = procedure(x,y : TGLint); stdcall;

deprecated;

PFNGLWINDOWPOS2IVARBPROC = procedure(v : PGLint); stdcall;

This item has no description.

PFNGLWINDOWPOS2IVPROC = procedure(v : PGLint); stdcall;

deprecated;

PFNGLWINDOWPOS2SARBPROC = procedure(x,y : TGLshort); stdcall;

This item has no description.

PFNGLWINDOWPOS2SPROC = procedure(x,y : TGLshort); stdcall;

deprecated;

PFNGLWINDOWPOS2SVARBPROC = procedure(v : PGLshort); stdcall;

This item has no description.

PFNGLWINDOWPOS2SVPROC = procedure(v : PGLshort); stdcall;

deprecated;

PFNGLWINDOWPOS3DARBPROC = procedure(x,y,z : TGLdouble); stdcall;

This item has no description.

PFNGLWINDOWPOS3DPROC = procedure(x,y,z : TGLdouble); stdcall;

deprecated;

PFNGLWINDOWPOS3DVARBPROC = procedure(v : PGLdouble); stdcall;

This item has no description.

PFNGLWINDOWPOS3DVPROC = procedure(v : PGLdouble); stdcall;

deprecated;

PFNGLWINDOWPOS3FARBPROC = procedure(x,y,z : TGLfloat); stdcall;

This item has no description.

PFNGLWINDOWPOS3FPROC = procedure(x,y,z : TGLfloat); stdcall;

deprecated;

PFNGLWINDOWPOS3FVARBPROC = procedure(v : PGLfloat); stdcall;

This item has no description.

PFNGLWINDOWPOS3FVPROC = procedure(v : PGLfloat); stdcall;

deprecated;

PFNGLWINDOWPOS3IARBPROC = procedure(x,y,z : TGLint); stdcall;

This item has no description.

PFNGLWINDOWPOS3IPROC = procedure(x,y,z : TGLint); stdcall;

deprecated;

PFNGLWINDOWPOS3IVARBPROC = procedure(v : PGLint); stdcall;

This item has no description.

PFNGLWINDOWPOS3IVPROC = procedure(v : PGLint); stdcall;

deprecated;

PFNGLWINDOWPOS3SARBPROC = procedure(x,y,z : TGLshort); stdcall;

This item has no description.

PFNGLWINDOWPOS3SPROC = procedure(x,y,z : TGLshort); stdcall;

deprecated;

PFNGLWINDOWPOS3SVARBPROC = procedure(v : PGLshort); stdcall;

This item has no description.

PFNGLWINDOWPOS3SVPROC = procedure(v : PGLshort); stdcall;

deprecated;

PFNWGLALLOCATEMEMORYNVPROC = function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;

This item has no description.

PFNWGLBINDTEXIMAGEARBPROC = function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

WGL_ARB_render_texture (ARB #20)

PFNWGLCHOOSEPIXELFORMATARBPROC = function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: Cardinal; piFormats: PGLint; nNumFormats: PCardinal) : BOOL; stdcall;

This item has no description.

PFNWGLCREATEAFFINITYDCNVPROC = function(hGpuList: PHGPUNV): HDC; stdcall;

This item has no description.

PFNWGLCREATEBUFFERREGIONARBPROC = function(DC: HDC; iLayerPlane: Integer; uType: Cardinal) : Integer; stdcall;

WGL WGL - ARB WGL_buffer_region (ARB #4)

PFNWGLCREATECONTEXTATTRIBSARBPROC = function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;

WGL_ARB_create_context (ARB #55)

PFNWGLCREATEPBUFFERARBPROC = function(DC: HDC; iPixelFormat: TGLint; iWidth, iHeight : TGLint; const piAttribList: PGLint) : HPBUFFERARB; stdcall;

WGL_ARB_pbuffer (ARB #11)

PFNWGLDELETEBUFFERREGIONARBPROC = procedure(hRegion: Integer); stdcall;

This item has no description.

PFNWGLDELETEDCNVPROC = function(hdc: HDC): Boolean; stdcall;

This item has no description.

PFNWGLDESTROYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB): BOOL; stdcall;

This item has no description.

PFNWGLDXCLOSEDEVICEPROC = function(hDevice: THandle): BOOL; stdcall;

This item has no description.

PFNWGLDXLOCKOBJECTSPROC = function(hDevice: THandle; count: TGLint; hObjects: PHandle): BOOL; stdcall;

This item has no description.

PFNWGLDXOBJECTACCESSPROC = function(hObject: THandle; access: Cardinal): BOOL; stdcall;

This item has no description.

PFNWGLDXOPENDEVICEPROC = function(dxDevice: Pointer): THandle; stdcall;

This item has no description.

PFNWGLDXREGISTEROBJECTPROC = function(hDevice: THandle; dxObject: Pointer; name: Cardinal; atype: Cardinal; access: Cardinal): THandle; stdcall;

This item has no description.

PFNWGLDXSETRESOURCESHAREHANDLEPROC = function (dxObject: Pointer; shareHandle: THandle): BOOL; stdcall;

WGL_NV_DX_interop (EXT #407)

PFNWGLDXUNLOCKOBJECTSNVPROC = function (hDevice: THandle; count: TGLint; hObjects: PHandle): BOOL; stdcall;

This item has no description.

PFNWGLDXUNREGISTEROBJECTPROC = function(hDevice: THandle; hObject: THandle): BOOL; stdcall;

This item has no description.

PFNWGLENUMGPUDEVICESNVPROC = function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean; stdcall;

This item has no description.

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC = function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;

This item has no description.

PFNWGLENUMGPUSNVPROC = function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;

WGL_NV_gpu_affinity (EXT #355)

PFNWGLFREEMEMORYNVPROC = procedure(ptr: Pointer); stdcall;

This item has no description.

PFNWGLGETCURRENTREADDCARBPROC = function(): HDC; stdcall;

This item has no description.

PFNWGLGETEXTENSIONSSTRINGARBPROC = function(DC: HDC): PAnsiChar; stdcall;

WGL_ARB_extensions_string (ARB #8)

PFNWGLGETPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB) : HDC; stdcall;

This item has no description.

PFNWGLGETPIXELFORMATATTRIBFVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;

This item has no description.

PFNWGLGETPIXELFORMATATTRIBIVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;

WGL_ARB_pixel_format (ARB #9)

PFNWGLGETSWAPINTERVALEXTPROC = function : Integer; stdcall;

This item has no description.

PFNWGLMAKECONTEXTCURRENTARBPROC = function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;

WGL_make_current_read (ARB #10)

PFNWGLQUERYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;

This item has no description.

PFNWGLRELEASEPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;

This item has no description.

PFNWGLRELEASETEXIMAGEARBPROC = function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

This item has no description.

PFNWGLRESTOREBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;

This item has no description.

PFNWGLSAVEBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;

This item has no description.

PFNWGLSETPBUFFERATTRIBARBPROC = function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;

This item has no description.

PFNWGLSWAPINTERVALEXTPROC = function(interval : Integer) : BOOL; stdcall;

WGL - EXT WGL_EXT_swap_control (EXT #172)

PGLbitfield = ˆTGLbitfield;

UINT

PGLboolean = ˆTGLboolean;

This item has no description.

PGLbyte = ˆTGLbyte;

This item has no description.

PGLchar = MarshaledAString;

This item has no description.

PGLclampd = System.PDouble;

This item has no description.

PGLclampf = System.PSingle;

This item has no description.

PGLdouble = System.PDouble;

This item has no description.

PGLenum = ˆTGLenum;

This item has no description.

PGLfloat = System.PSingle;

This item has no description.

PGLhalf = ˆTGLhalf;

This item has no description.

PGLhandleARB = ˆTGLhandleARB;

This item has no description.

PGLint = System.PInteger;

This item has no description.

PGLint64 = System.PInt64;

This item has no description.

PGLint64EXT = System.PInt64;

This item has no description.

PGLintptr = ˆTGLintptr;

This item has no description.

PGLPCharArray = ˆPAnsiChar;

This item has no description.

PGLPointer = ˆPGLvoid;

This item has no description.

PGLshort = ˆTGLshort;

This item has no description.

PGLsizei = System.PInteger;

This item has no description.

PGLsizeiptr = ˆTGLsizeiptr;

This item has no description.

PGLsync = ˆTGLsync;

This item has no description.

PGLubyte = System.PByte;

This item has no description.

PGLuint = System.PCardinal;

This item has no description.

PGLuint64 = System.PUInt64;

This item has no description.

PGLuint64EXT = System.PUInt64;

This item has no description.

PGLUNurbs = ˆTGLUNurbs;

This item has no description.

PGLUNurbsObj = PGLUNurbs;

This item has no description.

PGLUQuadric = ˆTGLUQuadric;

This item has no description.

PGLUQuadricObj = PGLUQuadric;

This item has no description.

PGLushort = System.PWord;

This item has no description.

PGLUTesselator= ˆTGLUTesselator;

This item has no description.

PGLUTesselatorObj = PGLUTesselator;

This item has no description.

PGLUTriangulatorObj = PGLUTesselator;

This item has no description.

PGLvdpauSurfaceNV = ˆTGLvdpauSurfaceNV;

This item has no description.

PGLvoid = Pointer;

This item has no description.

PGNGLGETBUFFERPARAMETERUI64VNV = procedure(value: Cardinal; index: Cardinal; result: PGLuint64EXT); stdcall;

This item has no description.

PGPUDEVICE = ˆTGPUDEVICE;

This item has no description.

PHGPUNV = ˆHGPUNV;

This item has no description.

PHVIDEOINPUTDEVICENV = ˆHVIDEOINPUTDEVICENV;

This item has no description.

PWGLswap = ˆTWGLswap;

========= Windows types ==============

TDebugProc = procedure( source: Cardinal; type_: Cardinal; id: Cardinal; severity: Cardinal; length: TGLsizei; const message: PAnsiChar; userParam: Pointer); stdcall;

This item has no description.

TDebugProcAMD = procedure( id: Cardinal; category: Cardinal; severity: Cardinal; length: TGLsizei; message: PAnsiChar; userParam: Pointer); stdcall;

This item has no description.

TGLbitfield = LongWord;

This item has no description.

TGLboolean = BYTEBOOL;

=========== OpenGL types ============

TGLbyte = ShortInt;

This item has no description.

TGLchar = Byte;

This item has no description.

TGLclampd = Double;

This item has no description.

TGLDEBUGPROCARB = TDebugProc;

This item has no description.

TGLdouble = Double;

This item has no description.

TGLenum = Cardinal;

This item has no description.

TGLfloat = Single;

This item has no description.

TGLhalf = WORD;

This item has no description.

TGLhandleARB = Cardinal;

This item has no description.

TGLint = Integer;

This item has no description.

TGLint64 = Int64;

This item has no description.

TGLint64EXT = Int64;

This item has no description.

TGLintptr = NativeInt;

the size of these depend on platform (32bit or 64bit)

TGLshort = SmallInt;

This item has no description.

TGLsizei = Integer;

This item has no description.

TGLsizeiptr = NativeInt;

This item has no description.

TGLsync = NativeInt;

This item has no description.

TGLubyte = Byte;

This item has no description.

TGLuint = Cardinal;

This item has no description.

TGLuint64 = UInt64;

This item has no description.

TGLuint64EXT = UInt64;

This item has no description.

TGLUNurbsErrorProc = procedure(ErrorCode: Cardinal); stdcall;

This item has no description.

TGLUNurbsObj = TGLUNurbs;

backwards compatibility

TGLUQuadricErrorProc = procedure(errorCode: Cardinal); stdcall;

Callback function prototypes

TGLUQuadricObj = TGLUQuadric;

This item has no description.

TGLushort = Word;

This item has no description.

TGLUTessBeginDataProc = procedure(AType: Cardinal; UserData: Pointer); stdcall;

This item has no description.

TGLUTessBeginProc = procedure(AType: Cardinal); stdcall;

This item has no description.

TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;

This item has no description.

TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;

This item has no description.

TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;

This item has no description.

TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;

This item has no description.

TGLUTesselatorObj = TGLUTesselator;

This item has no description.

TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;

This item has no description.

TGLUTessEndProc = procedure; stdcall;

This item has no description.

TGLUTessErrorDataProc = procedure(ErrNo: Cardinal; UserData: Pointer); stdcall;

This item has no description.

TGLUTessErrorProc = procedure(ErrNo: Cardinal); stdcall;

This item has no description.

TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;

This item has no description.

TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;

This item has no description.

TGLUTriangulatorObj = TGLUTesselator;

This item has no description.

TGLvdpauSurfaceNV = TGLintptr;

This item has no description.

TWGLswap = _WGLSWAP;

This item has no description.

WGLSWAP = _WGLSWAP;

This item has no description.

Constants

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;

—————— OpenGL v1.1 generic constants ——————– ARB Extension #4 - WGL_ARB_buffer_region

WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;

This item has no description.

WGL_DEPTH_BUFFER_BIT_ARB = $00000004;

This item has no description.

WGL_STENCIL_BUFFER_BIT_ARB = $00000008;

This item has no description.

WGL_SAMPLE_BUFFERS_ARB = $2041;

This item has no description.

WGL_SAMPLES_ARB = $2042;

This item has no description.

WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;

ARB Extension #9 - WGL_ARB_pixel_format (no new tokens)

WGL_DRAW_TO_WINDOW_ARB = $2001;

This item has no description.

WGL_DRAW_TO_BITMAP_ARB = $2002;

This item has no description.

WGL_ACCELERATION_ARB = $2003;

This item has no description.

WGL_NEED_PALETTE_ARB = $2004;

This item has no description.

WGL_NEED_SYSTEM_PALETTE_ARB = $2005;

This item has no description.

WGL_SWAP_LAYER_BUFFERS_ARB = $2006;

This item has no description.

WGL_SWAP_METHOD_ARB = $2007;

This item has no description.

WGL_NUMBER_OVERLAYS_ARB = $2008;

This item has no description.

WGL_NUMBER_UNDERLAYS_ARB = $2009;

This item has no description.

WGL_TRANSPARENT_ARB = $200A;

This item has no description.

WGL_TRANSPARENT_RED_VALUE_ARB = $2037;

This item has no description.

WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;

This item has no description.

WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;

This item has no description.

WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;

This item has no description.

WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;

This item has no description.

WGL_SHARE_DEPTH_ARB = $200C;

This item has no description.

WGL_SHARE_STENCIL_ARB = $200D;

This item has no description.

WGL_SHARE_ACCUM_ARB = $200E;

This item has no description.

WGL_SUPPORT_GDI_ARB = $200F;

This item has no description.

WGL_SUPPORT_OPENGL_ARB = $2010;

This item has no description.

WGL_DOUBLE_BUFFER_ARB = $2011;

This item has no description.

WGL_STEREO_ARB = $2012;

This item has no description.

WGL_PIXEL_TYPE_ARB = $2013;

This item has no description.

WGL_COLOR_BITS_ARB = $2014;

This item has no description.

WGL_RED_BITS_ARB = $2015;

This item has no description.

WGL_RED_SHIFT_ARB = $2016;

This item has no description.

WGL_GREEN_BITS_ARB = $2017;

This item has no description.

WGL_GREEN_SHIFT_ARB = $2018;

This item has no description.

WGL_BLUE_BITS_ARB = $2019;

This item has no description.

WGL_BLUE_SHIFT_ARB = $201A;

This item has no description.

WGL_ALPHA_BITS_ARB = $201B;

This item has no description.

WGL_ALPHA_SHIFT_ARB = $201C;

This item has no description.

WGL_ACCUM_BITS_ARB = $201D;

This item has no description.

WGL_ACCUM_RED_BITS_ARB = $201E;

This item has no description.

WGL_ACCUM_GREEN_BITS_ARB = $201F;

This item has no description.

WGL_ACCUM_BLUE_BITS_ARB = $2020;

This item has no description.

WGL_ACCUM_ALPHA_BITS_ARB = $2021;

This item has no description.

WGL_DEPTH_BITS_ARB = $2022;

This item has no description.

WGL_STENCIL_BITS_ARB = $2023;

This item has no description.

WGL_AUX_BUFFERS_ARB = $2024;

This item has no description.

WGL_NO_ACCELERATION_ARB = $2025;

This item has no description.

WGL_GENERIC_ACCELERATION_ARB = $2026;

This item has no description.

WGL_FULL_ACCELERATION_ARB = $2027;

This item has no description.

WGL_SWAP_EXCHANGE_ARB = $2028;

This item has no description.

WGL_SWAP_COPY_ARB = $2029;

This item has no description.

WGL_SWAP_UNDEFINED_ARB = $202A;

This item has no description.

WGL_TYPE_RGBA_ARB = $202B;

This item has no description.

WGL_TYPE_COLORINDEX_ARB = $202C;

This item has no description.

WGL_DRAW_TO_PBUFFER_ARB = $202D;

ARB Extension #11 - WGL_ARB_pbuffer

WGL_MAX_PBUFFER_PIXELS_ARB = $202E;

This item has no description.

WGL_MAX_PBUFFER_WIDTH_ARB = $202F;

This item has no description.

WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;

This item has no description.

WGL_PBUFFER_LARGEST_ARB = $2033;

This item has no description.

WGL_PBUFFER_WIDTH_ARB = $2034;

This item has no description.

WGL_PBUFFER_HEIGHT_ARB = $2035;

This item has no description.

WGL_PBUFFER_LOST_ARB = $2036;

This item has no description.

WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;

ARB Extension #20 - WGL_ARB_render_texture

WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;

This item has no description.

WGL_TEXTURE_FORMAT_ARB = $2072;

This item has no description.

WGL_TEXTURE_TARGET_ARB = $2073;

This item has no description.

WGL_MIPMAP_TEXTURE_ARB = $2074;

This item has no description.

WGL_TEXTURE_RGB_ARB = $2075;

This item has no description.

WGL_TEXTURE_RGBA_ARB = $2076;

This item has no description.

WGL_NO_TEXTURE_ARB = $2077;

This item has no description.

WGL_TEXTURE_CUBE_MAP_ARB = $2078;

This item has no description.

WGL_TEXTURE_1D_ARB = $2079;

This item has no description.

WGL_TEXTURE_2D_ARB = $207A;

This item has no description.

WGL_MIPMAP_LEVEL_ARB = $207B;

This item has no description.

WGL_CUBE_MAP_FACE_ARB = $207C;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;

This item has no description.

WGL_FRONT_LEFT_ARB = $2083;

This item has no description.

WGL_FRONT_RIGHT_ARB = $2084;

This item has no description.

WGL_BACK_LEFT_ARB = $2085;

This item has no description.

WGL_BACK_RIGHT_ARB = $2086;

This item has no description.

WGL_AUX0_ARB = $2087;

This item has no description.

WGL_AUX1_ARB = $2088;

This item has no description.

WGL_AUX2_ARB = $2089;

This item has no description.

WGL_AUX3_ARB = $208A;

This item has no description.

WGL_AUX4_ARB = $208B;

This item has no description.

WGL_AUX5_ARB = $208C;

This item has no description.

WGL_AUX6_ARB = $208D;

This item has no description.

WGL_AUX7_ARB = $208E;

This item has no description.

WGL_AUX8_ARB = $208F;

This item has no description.

WGL_AUX9_ARB = $2090;

This item has no description.

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;

ARB Extension #46 - GL_ARB_framebuffer_sRGB

WGL_COLOR_SAMPLES_NV = $20B9;

unknown extension, where does it come from?

WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;

ARB Extension #55 - WGL_ARB_create_context see also WGL_ARB_create_context_profile (ARB #74)

WGL_CONTEXT_MINOR_VERSION_ARB = $2092;

This item has no description.

WGL_CONTEXT_LAYER_PLANE_ARB = $2093;

This item has no description.

WGL_CONTEXT_FLAGS_ARB = $2094;

This item has no description.

WGL_CONTEXT_DEBUG_BIT_ARB = $0001;

This item has no description.

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $0002;

This item has no description.

ERROR_INVALID_VERSION_ARB = $2095;

This item has no description.

WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $0004;

EXT #400 WGL_EXT_create_context_es2_profile

WGL_CONTEXT_PROFILE_MASK_ARB = $9126;

ARB Extension #74 - WGL_ARB_create_context_profile see also WGL_ARB_create_context (ARB #55)

WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

This item has no description.

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

This item has no description.

ERROR_INVALID_PROFILE_ARB = $2096;

This item has no description.

WGL_TYPE_RGBA_FLOAT_ATI = $21A0;

WGL_ATI_pixel_format_float (#278)

WGL_FLOAT_COMPONENTS_NV = $20B0;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;

This item has no description.

WGL_TEXTURE_FLOAT_R_NV = $20B5;

This item has no description.

WGL_TEXTURE_FLOAT_RG_NV = $20B6;

This item has no description.

WGL_TEXTURE_FLOAT_RGB_NV = $20B7;

This item has no description.

WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;

This item has no description.

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;

Vendor/EXT extensions constants, in extension number order

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI = $8837;

GL_ATI_texture_compression_3dc

WGL_ACCESS_READ_ONLY_NV = $0000;

WGL_NV_DX_interop (EXT #407)

WGL_ACCESS_READ_WRITE_NV = $0001;

This item has no description.

WGL_ACCESS_WRITE_DISCARD_NV = $0002;

This item has no description.

GLU_TESS_BEGIN = 100100;

********** GLU generic constants ********** TessCallback

GLU_TESS_VERTEX = 100101;

TGLUTessBeginProc

GLU_TESS_END = 100102;

TGLUTessVertexProc

GLU_TESS_ERROR = 100103;

TGLUTessEndProc

GLU_TESS_EDGE_FLAG = 100104;

TGLUTessErrorProc

GLU_TESS_COMBINE = 100105;

TGLUTessEdgeFlagProc

GLU_TESS_BEGIN_DATA = 100106;

TGLUTessCombineProc

GLU_TESS_VERTEX_DATA = 100107;

TGLUTessBeginDataProc

GLU_TESS_END_DATA = 100108;

TGLUTessVertexDataProc

GLU_TESS_ERROR_DATA = 100109;

TGLUTessEndDataProc

GLU_TESS_EDGE_FLAG_DATA = 100110;

TGLUTessErrorDataProc

GLU_TESS_COMBINE_DATA = 100111;

TGLUTessEdgeFlagDataProc

GLU_TESS_ERROR1 = 100151;

TGLUTessCombineDataProc TessError

GLU_TESS_ERROR2 = 100152;

This item has no description.

GLU_TESS_ERROR3 = 100153;

This item has no description.

GLU_TESS_ERROR4 = 100154;

This item has no description.

GLU_TESS_ERROR5 = 100155;

This item has no description.

GLU_TESS_ERROR6 = 100156;

This item has no description.

GLU_TESS_ERROR7 = 100157;

This item has no description.

GLU_TESS_ERROR8 = 100158;

This item has no description.

GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;

This item has no description.

GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;

This item has no description.

GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;

This item has no description.

GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;

This item has no description.

GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;

This item has no description.

GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;

This item has no description.

GLU_AUTO_LOAD_MATRIX = 100200;

NURBS constants NurbsProperty

GLU_CULLING = 100201;

This item has no description.

GLU_SAMPLING_TOLERANCE = 100203;

This item has no description.

GLU_DISPLAY_MODE = 100204;

This item has no description.

GLU_PARAMETRIC_TOLERANCE = 100202;

This item has no description.

GLU_SAMPLING_METHOD = 100205;

This item has no description.

GLU_U_STEP = 100206;

This item has no description.

GLU_V_STEP = 100207;

This item has no description.

GLU_PATH_LENGTH = 100215;

NurbsSampling

GLU_PARAMETRIC_ERROR = 100216;

This item has no description.

GLU_DOMAIN_DISTANCE = 100217;

This item has no description.

GLU_MAP1_TRIM_2 = 100210;

NurbsTrim

GLU_MAP1_TRIM_3 = 100211;

This item has no description.

GLU_OUTLINE_POLYGON = 100240;

NurbsDisplay

GLU_OUTLINE_PATCH = 100241;

This item has no description.

GLU_NURBS_ERROR1 = 100251;

NurbsErrors

GLU_NURBS_ERROR2 = 100252;

This item has no description.

GLU_NURBS_ERROR3 = 100253;

This item has no description.

GLU_NURBS_ERROR4 = 100254;

This item has no description.

GLU_NURBS_ERROR5 = 100255;

This item has no description.

GLU_NURBS_ERROR6 = 100256;

This item has no description.

GLU_NURBS_ERROR7 = 100257;

This item has no description.

GLU_NURBS_ERROR8 = 100258;

This item has no description.

GLU_NURBS_ERROR9 = 100259;

This item has no description.

GLU_NURBS_ERROR10 = 100260;

This item has no description.

GLU_NURBS_ERROR11 = 100261;

This item has no description.

GLU_NURBS_ERROR12 = 100262;

This item has no description.

GLU_NURBS_ERROR13 = 100263;

This item has no description.

GLU_NURBS_ERROR14 = 100264;

This item has no description.

GLU_NURBS_ERROR15 = 100265;

This item has no description.

GLU_NURBS_ERROR16 = 100266;

This item has no description.

GLU_NURBS_ERROR17 = 100267;

This item has no description.

GLU_NURBS_ERROR18 = 100268;

This item has no description.

GLU_NURBS_ERROR19 = 100269;

This item has no description.

GLU_NURBS_ERROR20 = 100270;

This item has no description.

GLU_NURBS_ERROR21 = 100271;

This item has no description.

GLU_NURBS_ERROR22 = 100272;

This item has no description.

GLU_NURBS_ERROR23 = 100273;

This item has no description.

GLU_NURBS_ERROR24 = 100274;

This item has no description.

GLU_NURBS_ERROR25 = 100275;

This item has no description.

GLU_NURBS_ERROR26 = 100276;

This item has no description.

GLU_NURBS_ERROR27 = 100277;

This item has no description.

GLU_NURBS_ERROR28 = 100278;

This item has no description.

GLU_NURBS_ERROR29 = 100279;

This item has no description.

GLU_NURBS_ERROR30 = 100280;

This item has no description.

GLU_NURBS_ERROR31 = 100281;

This item has no description.

GLU_NURBS_ERROR32 = 100282;

This item has no description.

GLU_NURBS_ERROR33 = 100283;

This item has no description.

GLU_NURBS_ERROR34 = 100284;

This item has no description.

GLU_NURBS_ERROR35 = 100285;

This item has no description.

GLU_NURBS_ERROR36 = 100286;

This item has no description.

GLU_NURBS_ERROR37 = 100287;

This item has no description.

GLU_CW = 100120;

Contours types – obsolete!

GLU_CCW = 100121;

This item has no description.

GLU_INTERIOR = 100122;

This item has no description.

GLU_EXTERIOR = 100123;

This item has no description.

GLU_UNKNOWN = 100124;

This item has no description.

GLU_BEGIN = GLU_TESS_BEGIN;

Names without "TESS_" prefix

GLU_VERTEX = GLU_TESS_VERTEX;

This item has no description.

GLU_END = GLU_TESS_END;

This item has no description.

GLU_ERROR = GLU_TESS_ERROR;

This item has no description.

GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;


GLSysHelp v.2.5: GLScene.OpenGLTokens: Packed Record _WGLSWAP

Packed Record _WGLSWAP

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type _WGLSWAP = packed record

Description

This item has no description.

Overview

Fields

Public | hdc: HDC;
Public | uiFlags: UINT;

Description

Fields

Public hdc: HDC;

This item has no description.

Public uiFlags: UINT;


GLSysHelp v.2.5: GLScene.OpenGLTokens: Record TGPUDEVICE

Record TGPUDEVICE

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type TGPUDEVICE = record

Description

This item has no description.

Overview

Fields

Public | cb: Cardinal;
Public | DeviceName: array[0..31] of AnsiChar;
Public | DeviceString: array[0..127] of AnsiChar;
Public | Flags: Cardinal;
Public | rcVirtualScreen: TRect;

Description

Fields

Public cb: Cardinal;

This item has no description.

Public DeviceName: array[0..31] of AnsiChar;

This item has no description.

Public DeviceString: array[0..127] of AnsiChar;

This item has no description.

Public Flags: Cardinal;

This item has no description.

Public rcVirtualScreen: TRect;


GLSysHelp v.2.5: GLScene.OpenGLTokens: Record TGLUNurbs

Record TGLUNurbs

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type TGLUNurbs = record

Description

——————- OpenGL Utility (GLU) types —————- GLU types


GLSysHelp v.2.5: GLScene.OpenGLTokens: Record TGLUQuadric

Record TGLUQuadric

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type TGLUQuadric = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: GLScene.OpenGLTokens: Record TGLUTesselator

Record TGLUTesselator

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type TGLUTesselator = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: GLScene.PipelineTransform

Unit GLScene.PipelineTransform

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgTransformationRec |
Class TgTransformation |

Types

PgTransformationRec = ˆTgTransformationRec;
TgOnMatricesPush = procedure() of object;
TgPipelineTransformationState = (...);
TgPipelineTransformationStates = set of TgPipelineTransformationState;

Constants

MAX_MATRIX_STACK_DEPTH = 128;
cAllStatesChanged = [trsModelViewChanged, trsInvModelViewChanged, trsInvModelChanged, trsViewProjChanged, trsNormalModelChanged, trsFrustum];

Description

Types

PgTransformationRec = ˆTgTransformationRec;

This item has no description.

TgOnMatricesPush = procedure() of object;

This item has no description.

TgPipelineTransformationState = (...);

This item has no description.

Values
  • trsModelViewChanged
  • trsInvModelViewChanged
  • trsInvModelChanged
  • trsNormalModelChanged
  • trsViewProjChanged
  • trsFrustum
TgPipelineTransformationStates = set of TgPipelineTransformationState;

This item has no description.

Constants

MAX_MATRIX_STACK_DEPTH = 128;

This item has no description.

cAllStatesChanged = [trsModelViewChanged, trsInvModelViewChanged, trsInvModelChanged, trsViewProjChanged, trsNormalModelChanged, trsFrustum];


GLSysHelp v.2.5: GLScene.PipelineTransform: Record TgTransformationRec

Record TgTransformationRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.PipelineTransform

Declaration

type TgTransformationRec = record

Description

This item has no description.

Overview

Fields

Public | FStates: TgPipelineTransformationStates;
Public | FModelMatrix: TGLMatrix;
Public | FViewMatrix: TGLMatrix;
Public | FProjectionMatrix: TGLMatrix;
Public | FInvModelMatrix: TGLMatrix;
Public | FNormalModelMatrix: TAffineMatrix;
Public | FModelViewMatrix: TGLMatrix;
Public | FInvModelViewMatrix: TGLMatrix;
Public | FViewProjectionMatrix: TGLMatrix;
Public | FFrustum: TFrustum;

Description

Fields

Public FStates: TgPipelineTransformationStates;

This item has no description.

Public FModelMatrix: TGLMatrix;

This item has no description.

Public FViewMatrix: TGLMatrix;

This item has no description.

Public FProjectionMatrix: TGLMatrix;

This item has no description.

Public FInvModelMatrix: TGLMatrix;

This item has no description.

Public FNormalModelMatrix: TAffineMatrix;

This item has no description.

Public FModelViewMatrix: TGLMatrix;

This item has no description.

Public FInvModelViewMatrix: TGLMatrix;

This item has no description.

Public FViewProjectionMatrix: TGLMatrix;

This item has no description.

Public FFrustum: TFrustum;


GLSysHelp v.2.5: GLScene.PipelineTransform: Class TgTransformation

Class TgTransformation

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.PipelineTransform

Declaration

type TgTransformation = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgTransformation

Overview

Fields

Private | FStackPos: Integer;
Private | FStack: array of TgTransformationRec;
Private | FLoadMatricesEnabled: Boolean;
Private | FOnPush: TGOnMatricesPush;

Methods

Public | constructor Create;
Public | function StackTop: TGTransformationRec; inline;
Private | function GetFrustum: TFrustum; inline;
Private | function GetInvModelMatrix: PGLMatrix; inline;
Private | function GetInvModelViewMatrix: PGLMatrix; inline;
Private | function GetModelMatrix: PGLMatrix; inline;
Private | function GetModelViewMatrix: PGLMatrix; inline;
Private | function GetNormalModelMatrix: PAffineMatrix; inline;
Private | function GetProjectionMatrix: PGLMatrix; inline;
Private | function GetViewMatrix: PGLMatrix; inline;
Private | function GetViewProjectionMatrix: PGLMatrix; inline;
Public | procedure IdentityAll; inline;
Public | procedure Pop;
Public | procedure Push(); overload; inline;
Public | procedure Push(AValue: PGTransformationRec); overload;
Public | procedure ReplaceFromStack;
Public | procedure SetModelMatrix(const AMatrix: TGLMatrix); inline;
Public | procedure SetProjectionMatrix(const AMatrix: TGLMatrix); inline;
Public | procedure SetViewMatrix(const AMatrix: TGLMatrix); inline;

Properties

Public | property Frustum: TFrustum read GetFrustum;
Public | property InvModelMatrix: PGLMatrix read GetInvModelMatrix;
Public | property InvModelViewMatrix: PGLMatrix read GetInvModelViewMatrix;
Public | property LoadMatricesEnabled: Boolean read FLoadMatricesEnabled write FLoadMatricesEnabled;
Public | property ModelMatrix: PGLMatrix read GetModelMatrix;
Public | property ModelViewMatrix: PGLMatrix read GetModelViewMatrix;
Public | property NormalModelMatrix: PAffineMatrix read GetNormalModelMatrix;
Public | property ProjectionMatrix: PGLMatrix read GetProjectionMatrix;
Public | property ViewMatrix: PGLMatrix read GetViewMatrix;
Public | property ViewProjectionMatrix: PGLMatrix read GetViewProjectionMatrix;

Description

Fields

Private FStackPos: Integer;

This item has no description.

Private FStack: array of TgTransformationRec;

This item has no description.

Private FLoadMatricesEnabled: Boolean;

This item has no description.

Private FOnPush: TGOnMatricesPush;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public function StackTop: TGTransformationRec; inline;

This item has no description.

Private function GetFrustum: TFrustum; inline;

This item has no description.

Private function GetInvModelMatrix: PGLMatrix; inline;

This item has no description.

Private function GetInvModelViewMatrix: PGLMatrix; inline;

This item has no description.

Private function GetModelMatrix: PGLMatrix; inline;

This item has no description.

Private function GetModelViewMatrix: PGLMatrix; inline;

This item has no description.

Private function GetNormalModelMatrix: PAffineMatrix; inline;

This item has no description.

Private function GetProjectionMatrix: PGLMatrix; inline;

This item has no description.

Private function GetViewMatrix: PGLMatrix; inline;

This item has no description.

Private function GetViewProjectionMatrix: PGLMatrix; inline;

This item has no description.

Public procedure IdentityAll; inline;

This item has no description.

Public procedure Pop;

This item has no description.

Public procedure Push(); overload; inline;

This item has no description.

Public procedure Push(AValue: PGTransformationRec); overload;

This item has no description.

Public procedure ReplaceFromStack;

This item has no description.

Public procedure SetModelMatrix(const AMatrix: TGLMatrix); inline;

This item has no description.

Public procedure SetProjectionMatrix(const AMatrix: TGLMatrix); inline;

This item has no description.

Public procedure SetViewMatrix(const AMatrix: TGLMatrix); inline;

This item has no description.

Properties

Public property Frustum: TFrustum read GetFrustum;

This item has no description.

Public property InvModelMatrix: PGLMatrix read GetInvModelMatrix;

This item has no description.

Public property InvModelViewMatrix: PGLMatrix read GetInvModelViewMatrix;

This item has no description.

Public property LoadMatricesEnabled: Boolean read FLoadMatricesEnabled write FLoadMatricesEnabled;

This item has no description.

Public property ModelMatrix: PGLMatrix read GetModelMatrix;

This item has no description.

Public property ModelViewMatrix: PGLMatrix read GetModelViewMatrix;

This item has no description.

Public property NormalModelMatrix: PAffineMatrix read GetNormalModelMatrix;

This item has no description.

Public property ProjectionMatrix: PGLMatrix read GetProjectionMatrix;

This item has no description.

Public property ViewMatrix: PGLMatrix read GetViewMatrix;

This item has no description.

Public property ViewProjectionMatrix: PGLMatrix read GetViewProjectionMatrix;


GLSysHelp v.2.5: GLScene.Polynomials

Unit GLScene.Polynomials

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLScene.VectorGeometry

Overview

Functions and Procedures

function EvalPolynom(const poly: TDoubleArray; const x: Double): Double;
function DerivatedPolynom(const poly: TDoubleArray): TDoubleArray;
function FindRoot(const poly: TDoubleArray; min, max, epsilon: Double): Double;
function MinPositiveCoef(const coefs: TDoubleArray; var aMin: Double): Boolean;
function cbrt(const x: Double): Double;
function SolveQuadric(const c: PDoubleArray): TDoubleArray;
function SolveCubic(const c: PDoubleArray): TDoubleArray;
function SolveQuartic(const c: PDoubleArray): TDoubleArray;

Types

TDoubleArray = array of Double;

Description

Functions and Procedures

function EvalPolynom(const poly: TDoubleArray; const x: Double): Double;

Computes polynom's value for given x

function DerivatedPolynom(const poly: TDoubleArray): TDoubleArray;

Calculates the polynom's derivative

function FindRoot(const poly: TDoubleArray; min, max, epsilon: Double): Double;

Finds a root between min and max with a precision of epsilon. The evaluation of min/max must be of opposit sign

function MinPositiveCoef(const coefs: TDoubleArray; var aMin: Double): Boolean;

Finds the minimum positive coef in the array in aMin. Returns true if such an item was found.

function cbrt(const x: Double): Double;

Calculates the cube root of its parameter.

function SolveQuadric(const c: PDoubleArray): TDoubleArray;

Computes the real roots of a real polynomial of the 2nd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2

function SolveCubic(const c: PDoubleArray): TDoubleArray;

Computes the real roots of a real polynomial of the 3rd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3

function SolveQuartic(const c: PDoubleArray): TDoubleArray;

Computes the real roots of a real polynomial of the 4th degree. The polynomial is of the form: A(0) + A(1)*Z + ... + A(4)*Z**4

Types

TDoubleArray = array of Double;


GLSysHelp v.2.5: GLScene.RandomLib

Unit GLScene.RandomLib

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Math
  • System.SysUtils

Overview

Functions and Procedures

function GenRandom: Extended;
function RandUniform(RLow, RHigh: Single): Single; overload;
function RandUniform(RLow, RHigh: Integer): Integer; overload;
function RandExponent(Mean: Single): single;
function RandNorm(Mean, StDev: single): single;
function RandLogNorm(Mean, StDev: single): single;
function RandGauss(Mean, StdDev: single): single;
function RandEmpiric(X: array of single; Fx: array of single; NClass: integer): single;
function Random_Normal: Extended; overload;
function Random_Normal(RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Normal(const Mean, StdDev: Extended): Extended; overload;
function Random_Normal(const Mean, StdDev: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_LogNormal(const Mean, StdDev: Extended): Extended; overload;
function Random_LogNormal(const Mean, StdDev: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Gamma(const Shape: Extended): Extended; overload;
function Random_Gamma(const Shape: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Gamma1(const Shape: Extended; RandomGenerator: TRandomGenFunction): Extended;
function Random_ChiSq(const DF: Integer): Extended; overload;
function Random_ChiSq(const DF: Integer; RandomGenerator: TRandomGenFunction) : Extended; overload;
function Random_Exponential: Extended; overload;
function Random_Exponential(RandomGenerator: TRandomGenFunction) : Extended; overload;
function Random_Weibull(const a: Extended): Extended; overload;
function Random_Weibull(const a: Extended; RandomGenerator: TRandomGenFunction) : Extended; overload;
function Random_Beta(const aa, bb: Extended): Extended; overload;
function Random_Beta(const aa, bb: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_T(const DF: Integer): Extended; overload;
function Random_T(const DF: Integer; RandomGenerator: TRandomGenFunction) : Extended; overload;
procedure Random_MVNorm(const h, d: TAMFloatVector; var f, x: TAMFloatVector; var ier: Integer); overload;
procedure Random_MVNorm(const h, d: TAMFloatVector; var f, x: TAMFloatVector; var ier: Integer; RandomGenerator: TRandomGenFunction); overload;
function Random_Inv_Gauss(const h, b: Extended): Extended; overload;
function Random_Inv_Gauss(const h, b: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Binomial1(const n: Integer; const p: Extended): Int64; overload;
function Random_Binomial1(const n: Integer; const p: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;
function Random_Binomial2(const n: Int64; const pp: Extended): Int64; overload;
function Random_Binomial2(const n: Int64; const pp: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;
function Random_Neg_Binomial(const sk, p: Extended): Int64; overload;
function Random_Neg_Binomial(const sk, p: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;
function Random_von_Mises(const k: Extended): Extended; overload;
function Random_von_Mises(const k: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Cauchy: Extended; overload;
function Random_Cauchy(RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Poisson(var mu: Extended): Int64; overload;
function Random_Poisson(var mu: Extended; RandomGenerator: TRandomGenFunction) : Int64; overload;
function LnGamma(const x: Extended): Extended;

Types

TAMFloatVector = array of Extended;
TRandomGenFunction = function: Extended;

Description

Functions and Procedures

function GenRandom: Extended;

Used to call Random Number Generator. Remember to use Randomize if you don't want repeatable sequences.

function RandUniform(RLow, RHigh: Single): Single; overload;

Uniform Random single numbers in RLow..RHigh range

function RandUniform(RLow, RHigh: Integer): Integer; overload;

This item has no description.

function RandExponent(Mean: Single): single;

This item has no description.

function RandNorm(Mean, StDev: single): single;

This item has no description.

function RandLogNorm(Mean, StDev: single): single;

This item has no description.

function RandGauss(Mean, StdDev: single): single;

Marsaglia-Bray algorithm

function RandEmpiric(X: array of single; Fx: array of single; NClass: integer): single;

Random Number for Empiricle Distribution X[I] - middle of I-interval Fx[I] - cummulative empiricle distribution with values in [0..1]

function Random_Normal: Extended; overload;

Adapted from the following Fortran 77 code ALGORITHM 712, COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves Returns a normally distributed pseudo-random number with zero mean and unit variance

function Random_Normal(RandomGenerator: TRandomGenFunction): Extended; overload;

Adapted from COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. Returns a normally distributed pseudo-random number with zero mean and unit variance. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves

function Random_Normal(const Mean, StdDev: Extended): Extended; overload;

This item has no description.

function Random_Normal(const Mean, StdDev: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_LogNormal(const Mean, StdDev: Extended): Extended; overload;

Adapted from approach suggested by Greg Hood, used with Permission.

function Random_LogNormal(const Mean, StdDev: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

Adapted from approach suggested by Greg Hood, used with Permission.

function Random_Gamma(const Shape: Extended): Extended; overload;

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL).

function Random_Gamma(const Shape: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL)

function Random_Gamma1(const Shape: Extended; RandomGenerator: TRandomGenFunction): Extended;

Uses the algorithm in Marsaglia, G. and Tsang, W.W. (2000) 'A simple method for generating gamma variables', Trans. om Math. Software (TOMS), vol.26(3), pp.363-372. Generates a random gamma deviate for shape parameter Shape >= 1.

function Random_ChiSq(const DF: Integer): Extended; overload;

Generates a random variate from the chi-squared distribution with dff degrees of freedom.

function Random_ChiSq(const DF: Integer; RandomGenerator: TRandomGenFunction) : Extended; overload;

This item has no description.

function Random_Exponential: Extended; overload;

Generates a random variate in [0,INFINITY) FROM A NEGATIVE EXPONENTIAL DlSTRIBUTION WlTH DENSITY PROPORTIONAL TO EXP(-random_exponential), USING INVERSION.

function Random_Exponential(RandomGenerator: TRandomGenFunction) : Extended; overload;

This item has no description.

function Random_Weibull(const a: Extended): Extended; overload;

Generates a random variate from the Weibull distribution with probability density: a a-1 -x f(x) = a.x e

function Random_Weibull(const a: Extended; RandomGenerator: TRandomGenFunction) : Extended; overload;

This item has no description.

function Random_Beta(const aa, bb: Extended): Extended; overload;

Generates a random variate in [0,1] FROM A BETA DISTRIBUTION WITH DENSITY PROPORTIONAL TO BETA**(AA-1) * (1-BETA)**(BB-1). USING CHENG'S LOG LOGISTIC METHOD. AA = Shape PARAMETER FROM DISTRIBUTION (0 < REAL) BB = Shape PARAMETER FROM DISTRIBUTION (0 < REAL)

function Random_Beta(const aa, bb: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_T(const DF: Integer): Extended; overload;

Generates a random variate FROM A T DISTRIBUTION USING KINDERMAN AND MONAHAN'S RATIO METHOD. DF = DEGREES OF FREEDOM OF DISTRIBUTION (DF >= 1)

function Random_T(const DF: Integer; RandomGenerator: TRandomGenFunction) : Extended; overload;

This item has no description.

procedure Random_MVNorm(const h, d: TAMFloatVector; var f, x: TAMFloatVector; var ier: Integer); overload;

GENERATES AN N VARIATE RANDOM NORMAL Vector USING A CHOLESKY DECOMPOSITION.

ARGUMENTS: N = NUMBER OF VARIATES IN Vector (INPUT,INTEGER >= 1) H(J) = J'TH ELEMENT OF Vector OF MEANS (INPUT,REAL) X(J) = J'TH ELEMENT OF DELIVERED Vector (OUTPUT,REAL)

D(J*(J-1)/2+I) = (I,J)'TH ELEMENT OF VARIANCE MATRIX (J> = I) (INPUT,REAL) F((J-1)*(2*N-J)/2+I) = (I,J)'TH ELEMENT OF LOWER TRIANGULAR DECOMPOSITION OF VARIANCE MATRIX (J <= I) (OUTPUT,REAL) ier = 1 if the input covariance matrix is not +ve definite = 0 otherwise

procedure Random_MVNorm(const h, d: TAMFloatVector; var f, x: TAMFloatVector; var ier: Integer; RandomGenerator: TRandomGenFunction); overload;

This item has no description.

function Random_Inv_Gauss(const h, b: Extended): Extended; overload;

Generates a random variate in [0,INFINITY] FROM A REPARAMETERISED GENERALISED INVERSE GAUSSIAN (GIG) DISTRIBUTION WITH DENSITY PROPORTIONAL TO GIG**(H-1) * EXP(-0.5*B*(GIG+1/GIG)) USING A RATIO METHOD.

h = PARAMETER OF DISTRIBUTION (0 <= REAL) b = PARAMETER OF DISTRIBUTION (0 < REAL)

function Random_Inv_Gauss(const h, b: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_Binomial1(const n: Integer; const p: Extended): Int64; overload;

GENERATES A RANDOM BINOMIAL VARIATE USING C.D.Kemp's method. This algorithm is suitable when many random variates are required with the SAME parameter values for n & p. P = Bernoulli SUCCESS PROBABILITY (0 <= REAL <= 1) N = Number of Bernoulli trials (1 <= INTEGER) Reference: Kemp, C.D. (1986). `A modal method for generating binomial variables', Commun. Statist. - Theor. Meth. 15(3), 805-813.

function Random_Binomial1(const n: Integer; const p: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;

This item has no description.

function Random_Binomial2(const n: Int64; const pp: Extended): Int64; overload;

Generates a single random deviate from a binomial distribution whose number of trials is N and whose probability of an event in each trial is P.

Arguments N –> The number of trials in the binomial distribution from which a random deviate is to be generated. INTEGER N P –> The probability of an event in each trial of the binomial distribution from which a random deviate is to be generated. REAL P

function Random_Binomial2(const n: Int64; const pp: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;

FIRST –> Set FIRST = .TRUE. for the first call to perform initialization the set FIRST = .FALSE. for further calls using the same pair of parameter values (N, P). LOGICAL FIRST random_binomial2 <– A random deviate yielding the number of events from N independent trials, each of which has a probability of event P. INTEGER –> random_binomial Method: This is algorithm BTPE from: Kachitvichyanukul, V. and Schmeiser, B. W. Binomial Random Variate Generation. Communications of the ACM, 31, 2 (February, 1988) 216.

function Random_Neg_Binomial(const sk, p: Extended): Int64; overload;

GENERATES A RANDOM NEGATIVE BINOMIAL VARIATE USING UNSTORED INVERSION AND/OR THE REPRODUCTIVE PROPERTY. SK = NUMBER OF FAILURES REQUIRED (Dagpunar's words!) = the `power' parameter of the negative binomial (0 < REAL) P = BERNOULLI SUCCESS PROBABILITY (0 < REAL < 1) THE PARAMETER H IS SET SO THAT UNSTORED INVERSION ONLY IS USED WHEN P <= H, OTHERWISE A COMBINATION OF UNSTORED INVERSION AND THE REPRODUCTIVE PROPERTY IS USED.

function Random_Neg_Binomial(const sk, p: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;

This item has no description.

function Random_von_Mises(const k: Extended): Extended; overload;

Algorithm VMD Arguments: k (real) - parameter of the von Mises distribution.

function Random_von_Mises(const k: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_Cauchy: Extended; overload;

Generate a random deviate from the standard Cauchy distribution

function Random_Cauchy(RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_Poisson(var mu: Extended): Int64; overload;

Generates a single random deviate from a Poisson distribution with mean mu. Arguments: mu –> The mean of the Poisson distribution from which a random deviate is to be generated. REAL mu Method: For details see Ahrens, J.H. and Dieter, U. Computer Generation of Poisson Deviates From Modified Normal Distributions. ACM Trans. Math. Software, 8, 2 (June 1982),163-179

TABLES: COEFFICIENTS A0-A7 FOR STEP F. FACTORIALS FACT COEFFICIENTS A(K) - FOR PX = FK*V*V*SUM(A(K)*V**K)-DEL

function Random_Poisson(var mu: Extended; RandomGenerator: TRandomGenFunction) : Int64; overload;

This item has no description.

function LnGamma(const x: Extended): Extended;

Logarithm to base e of the gamma function. Accurate to about 1.e-14. Programmer: Alan Miller Latest revision of Fortran 77 version - 28 February 1988

Types

TAMFloatVector = array of Extended;

Used as a Dynamic Vector

TRandomGenFunction = function: Extended;

Used for passing Random Number Generators


GLSysHelp v.2.5: GLScene.RedBlackTree

Unit GLScene.RedBlackTree

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class GRedBlackTree |

Functions and Procedures

function CompareInteger(const Item1, Item2: Integer): Integer;

Types

TRBColor = (...);

Description

Functions and Procedures

function CompareInteger(const Item1, Item2: Integer): Integer;

This item has no description.

Types

TRBColor = (...);

This item has no description.

Values
  • clRed
  • clBlack


GLSysHelp v.2.5: GLScene.RedBlackTree: Class GRedBlackTree

Class GRedBlackTree

Description
Hierarchy
Nested Classes and Records
Nested Types
Fields
Methods
Properties

Unit

GLScene.RedBlackTree

Declaration

type GRedBlackTree<TKey,TValue> = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • GRedBlackTree

Overview

Nested Classes and Records

Public TRBNode = class(TObject)

Nested Types

Published | TForEachProc = procedure(AKey: TKey; AValue: TValue; out AContinue: Boolean);
Published | TKeyCompareFunc = function(const Item1, Item2: TKey): Integer;
Published | TValueCompareFunc = function(const Item1, Item2: TValue): Boolean;

Fields

Public | var FRoot: TRBNode;
Public | FLeftmost: TRBNode;
Public | FRightmost: TRBNode;
Public | FLastFound: TRBNode;
Public | FLastNode: TRBNode;
Public | FCount: Integer;
Public | FKeyCompareFunc: TKeyCompareFunc;
Public | FDuplicateKeys: Boolean;
Public | FValueCompareFunc: TValueCompareFunc;
Public | FOnChange: TNotifyEvent;

Methods

Public | constructor Create(KeyCompare: TKeyCompareFunc; ValueCompare: TValueCompareFunc);
Public | destructor Destroy; override;
Public | function Find(const Key: TKey; out Value: TValue): Boolean;
Public | function FindNode(const Key: TKey): TRBNode;
Public | function GetFirst: TKey;
Public | function GetLast: TKey;
Public | function Maximum(var x: TRBNode): TRBNode;
Public | function Minimum(var x: TRBNode): TRBNode;
Public | function NextDublicate(out Value: TValue): Boolean;
Public | function NextKey(var Key: TKey; out Value: TValue): Boolean;
Public | function PrevKey(var Key: TKey; out Value: TValue): Boolean;
Public | procedure Add(const Key: TKey; const Value: TValue);
Public | procedure Clear;
Public | procedure Delete(const Key: TKey);
Public | class procedure FastErase(x: TRBNode);
Public | procedure ForEach(AProc: TForEachProc);
Public | procedure RotateLeft(var x: TRBNode);
Public | procedure RotateRight(var x: TRBNode);
Public | procedure SetDuplicateKeys(Value: Boolean);

Properties

Public | property Count: Integer read FCount;
Public | property DuplicateKeys: Boolean read FDuplicateKeys write SetDuplicateKeys;
Public | property First: TKey read GetFirst;
Public | property Last: TKey read GetLast;
Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;

Description

Nested Types

Published TForEachProc = procedure(AKey: TKey; AValue: TValue; out AContinue: Boolean);

This item has no description.

Published TKeyCompareFunc = function(const Item1, Item2: TKey): Integer;

This item has no description.

Published TValueCompareFunc = function(const Item1, Item2: TValue): Boolean;

This item has no description.

Fields

Public var FRoot: TRBNode;

This item has no description.

Public FLeftmost: TRBNode;

This item has no description.

Public FRightmost: TRBNode;

This item has no description.

Public FLastFound: TRBNode;

This item has no description.

Public FLastNode: TRBNode;

This item has no description.

Public FCount: Integer;

This item has no description.

Public FKeyCompareFunc: TKeyCompareFunc;

This item has no description.

Public FDuplicateKeys: Boolean;

This item has no description.

Public FValueCompareFunc: TValueCompareFunc;

This item has no description.

Public FOnChange: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(KeyCompare: TKeyCompareFunc; ValueCompare: TValueCompareFunc);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Find(const Key: TKey; out Value: TValue): Boolean;

Find value by key.

Public function FindNode(const Key: TKey): TRBNode;

This item has no description.

Public function GetFirst: TKey;

This item has no description.

Public function GetLast: TKey;

This item has no description.

Public function Maximum(var x: TRBNode): TRBNode;

This item has no description.

Public function Minimum(var x: TRBNode): TRBNode;

This item has no description.

Public function NextDublicate(out Value: TValue): Boolean;

This item has no description.

Public function NextKey(var Key: TKey; out Value: TValue): Boolean;

This item has no description.

Public function PrevKey(var Key: TKey; out Value: TValue): Boolean;

This item has no description.

Public procedure Add(const Key: TKey; const Value: TValue);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(const Key: TKey);

This item has no description.

Public class procedure FastErase(x: TRBNode);

This item has no description.

Public procedure ForEach(AProc: TForEachProc);

This item has no description.

Public procedure RotateLeft(var x: TRBNode);

This item has no description.

Public procedure RotateRight(var x: TRBNode);

This item has no description.

Public procedure SetDuplicateKeys(Value: Boolean);

This item has no description.

Properties

Public property Count: Integer read FCount;

This item has no description.

Public property DuplicateKeys: Boolean read FDuplicateKeys write SetDuplicateKeys;

This item has no description.

Public property First: TKey read GetFirst;

This item has no description.

Public property Last: TKey read GetLast;

This item has no description.

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;


GLSysHelp v.2.5: GLScene.RedBlackTree: Class GRedBlackTree.TRBNode

Class GRedBlackTree.TRBNode

Description
Hierarchy
Enclosing Class
Fields
Methods
Properties

Unit

GLScene.RedBlackTree

Declaration

type TRBNode = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • GRedBlackTree.TRBNode

Enclosing Class

  • GRedBlackTree

Overview

Fields

Public | Key: TKey;
Public | Left: TRBNode;
Public | Right: TRBNode;
Public | Parent: TRBNode;
Public | Twin: TRBNode;
Public | Color: TRBColor;
Public | Value: TValue;

Description

Fields

Public Key: TKey;

This item has no description.

Public Left: TRBNode;

This item has no description.

Public Right: TRBNode;

This item has no description.

Public Parent: TRBNode;

This item has no description.

Public Twin: TRBNode;

This item has no description.

Public Color: TRBColor;

This item has no description.

Public Value: TValue;


GLSysHelp v.2.5: GLScene.RGBE

Unit GLScene.RGBE

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Functions and Procedures

procedure Float2rgbe(var RGBE: TVector4b; const Red, Green, Blue: Single);
procedure Rgbe2float(var Red, Green, Blue: Single; const RGBE: TVector4b);
procedure LoadRLEpixels(Stream: TStream; Dst: PSingle; Scanline_width, Num_scanlines: Integer);
procedure LoadRGBEpixels(Stream: TStream; Dst: PSingle; Numpixels: Integer);

Description

Functions and Procedures

procedure Float2rgbe(var RGBE: TVector4b; const Red, Green, Blue: Single);

This item has no description.

procedure Rgbe2float(var Red, Green, Blue: Single; const RGBE: TVector4b);

This item has no description.

procedure LoadRLEpixels(Stream: TStream; Dst: PSingle; Scanline_width, Num_scanlines: Integer);

This item has no description.

procedure LoadRGBEpixels(Stream: TStream; Dst: PSingle; Numpixels: Integer);


GLSysHelp v.2.5: GLScene.Spline

Unit GLScene.Spline

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCubicSpline |

Types

TCubicSplineMatrix = array of array [0 .. 3] of Single;

Description

Types

TCubicSplineMatrix = array of array [0 .. 3] of Single;


GLSysHelp v.2.5: GLScene.Spline: Class TCubicSpline

Class TCubicSpline

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Spline

Declaration

type TCubicSpline = class(TObject)

Description

3D cubic spline handler class. This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline. Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector. Note : X, Y & Z are actually interpolated independently.

Hierarchy

  • TObject
  • TCubicSpline

Overview

Fields

Private | matX: TCubicSplineMatrix;
Private | matY: TCubicSplineMatrix;
Private | matZ: TCubicSplineMatrix;
Private | matW: TCubicSplineMatrix;
Private | FNb: Integer;

Methods

Public | constructor Create(const X, Y, Z, W: PFloatArray; const nb: Integer);
Public | destructor Destroy; override;
Public | function SplineAffineVector(const t: Single): TAffineVector; overload;
Public | function SplineIntersecXY(Z: Single; var X, Y: Single): Boolean;
Public | function SplineIntersecXZ(Y: Single; var X, Z: Single): Boolean;
Public | function SplineIntersecYZ(X: Single; var Y, Z: Single): Boolean;
Public | function SplineSlopeVector(const t: Single): TAffineVector; overload;
Public | function SplineSlopeW(const t: Single): Single;
Public | function SplineSlopeX(const t: Single): Single;
Public | function SplineSlopeY(const t: Single): Single;
Public | function SplineSlopeZ(const t: Single): Single;
Public | function SplineVector(const t: Single): TGLVector; overload;
Public | function SplineW(const t: Single): Single;
Public | function SplineX(const t: Single): Single;
Public | function SplineY(const t: Single): Single;
Public | function SplineZ(const t: Single): Single;
Public | procedure SplineAffineVector(const t: Single; var vector: TAffineVector); overload;
Public | procedure SplineVector(const t: Single; var vector: TGLVector); overload;
Public | procedure SplineXY(const t: Single; out X, Y: Single);
Public | procedure SplineXYZ(const t: Single; out X, Y, Z: Single);
Public | procedure SplineXYZW(const t: Single; out X, Y, Z, W: Single);

Description

Fields

Private matX: TCubicSplineMatrix;

This item has no description.

Private matY: TCubicSplineMatrix;

This item has no description.

Private matZ: TCubicSplineMatrix;

This item has no description.

Private matW: TCubicSplineMatrix;

This item has no description.

Private FNb: Integer;

This item has no description.

Methods

Public constructor Create(const X, Y, Z, W: PFloatArray; const nb: Integer);

Creates the spline and declares interpolation points. Time references go from 0 (first point) to nb-1 (last point), the first and last reference matrices respectively are used when T is used beyond this range. Note : "nil" single arrays are accepted, in this case the axis is disabled and calculus will return 0 (zero) for this component.

Public destructor Destroy; override;

This item has no description.

Public function SplineAffineVector(const t: Single): TAffineVector; overload;

Calculates affine vector at time t.

Public function SplineIntersecXY(Z: Single; var X, Y: Single): Boolean;

Calculates the intersection of the spline with the XY plane. Returns True if an intersection was found.

Public function SplineIntersecXZ(Y: Single; var X, Z: Single): Boolean;

Calculates the intersection of the spline with the XZ plane. Returns True if an intersection was found.

Public function SplineIntersecYZ(X: Single; var Y, Z: Single): Boolean;

Calculates the intersection of the spline with the YZ plane. Returns True if an intersection was found.

Public function SplineSlopeVector(const t: Single): TAffineVector; overload;

Calculates the spline slope at time t.

Public function SplineSlopeW(const t: Single): Single;

Calculates W component slope at time t.

Public function SplineSlopeX(const t: Single): Single;

Calculates X component slope at time t.

Public function SplineSlopeY(const t: Single): Single;

Calculates Y component slope at time t.

Public function SplineSlopeZ(const t: Single): Single;

Calculates Z component slope at time t.

Public function SplineVector(const t: Single): TGLVector; overload;

Calculates vector at time t.

Public function SplineW(const t: Single): Single;

Calculates W component at time t.

Public function SplineX(const t: Single): Single;

Calculates X component at time t.

Public function SplineY(const t: Single): Single;

Calculates Y component at time t.

Public function SplineZ(const t: Single): Single;

Calculates Z component at time t.

Public procedure SplineAffineVector(const t: Single; var vector: TAffineVector); overload;

Calculates affine vector at time t.

Public procedure SplineVector(const t: Single; var vector: TGLVector); overload;

Calculates vector at time t.

Public procedure SplineXY(const t: Single; out X, Y: Single);

Calculates X and Y components at time t.

Public procedure SplineXYZ(const t: Single; out X, Y, Z: Single);

Calculates X, Y and Z components at time t.

Public procedure SplineXYZW(const t: Single; out X, Y, Z, W: Single);

Calculates X, Y, Z and W components at time t.


GLSysHelp v.2.5: GLScene.Strings

Unit GLScene.Strings

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Overview

Constants

strDot = '.';
strError = 'Error!';
strErrorEx = 'Error: ';
strErrorLIB = 'ErrorLIB';
strInvalidType = 'Invalid data type';
strNothing = 'Nothing';
strStateCashMissing = 'States cash missing: ';
strUnknownArchiveVersion = 'Unknown archive version: ';
strObjectsNotSupported = 'Linked object not supported';
strGLSceneEditor = 'GLScene Editor';
strNoRenderingContext = 'Could not create a rendering context';
strWrongVersion = 'Need at least OpenGL version 1.1';
strTooManyLights = 'Too many lights in the scene';
strDisplayList = 'Failed to create a new display list for object ''%s''';
strWrongBitmapCanvas = 'Couldn''t create a rendering context for the given bitmap';
strWrongPrinter = 'Couldn''t render to printer';
strAlreadyRendering = 'Already rendering';
strSceneViewerNotDefined = 'SceneViewer not defined!';
strCadencerNotDefined = 'Cadencer not defined!';
strCadencerNotDefinedEx = 'Cadencer not defined for the ''%s'' component';
strCannotAlterAnActiveContext = 'Cannot alter an active context';
strContextActivationFailed = 'Context activation failed: %X, %s';
strContextAlreadyCreated = 'Context already created';
strContextDeactivationFailed = 'Context deactivation failed';
strContextNotCreated = 'Context not created';
strDeleteContextFailed = 'Delete context failed';
strFailedToShare = 'DoCreateContext - Failed to share contexts';
strIncompatibleContexts = 'Incompatible contexts';
strInvalidContextRegistration = 'Invalid context registration';
strInvalidNotificationRemoval = 'Invalid notification removal';
strNoActiveRC = 'No active rendering context';
strUnbalancedContexActivations = 'Unbalanced context activations';
strUnableToCreateLegacyContext = 'Unable to create legacy context';
strOpenGLError = 'OpenGL error - %s';
str3DSMapNotFound = 'Loading %s map texture failed: %s in %s';
strError3DS_NO_MEM = 'Not enough memory to complete operation.';
strError3DS_INVALID_ARG = 'The argument passed to the function is invalid.'#13+ 'Usually caused by a nil pointer or an out of range numeric argument.';
strError3DS_INVALID_DATA = 'The structure passed as an argument to the function has'#13+ 'invalid or out of range data in its fields.';
strError3DS_INVALID_CHUNK = 'An invalid Chunk structure was encountered while reading'#13+ 'the database. Usually caused by a corrupt database or file.';
strError3DS_INVALID_DATABASE = 'The database passed as an argument has not be created yet.';
strError3DS_WRONG_DATABASE = 'The database passed as an argument is the wrong kind of'#13+ 'database for this function.';
strError3DS_UNFOUND_CHUNK = 'The database is missing important file chunks needed to'#13+ 'fill out the requested structure. Usually caused by a corrupt database or file.';
strError3DS_WRONG_OBJECT = 'The Name passed to the functions exists but is not the type of object asked for.'#13+ 'For example asking for a mesh object with the GetCameraByName3DS function.';
strError3DS_NO_SUCH_FILE = 'The FileName passed as an argument for reading does not exist.';
strError3DS_INIT_FAILED = 'Failed to initialize structure passed as an argument.';
strError3DS_OPENING_FILE = 'Could not open requested file.';
strError3DS_CLOSING_FILE = 'Could not close requested file.';
strError3DS_READING_FILE = 'Error occured while reading file.';
strError3DS_CREATING_DATABASE = 'Error occured while creating database.';
strError3DS_READING_DATABASE = 'Error occured while reading database.';
strError3DS_WRITING_DATABASE = 'Error occured while writing database.';
strError3DS_WRITING_FILE = 'Error occured while writing file.';
strError3DS_STRING_TOO_LONG = 'String encountered in file structure or as an argument was longer than expected.'#13+ 'Possibly caused by an uninitialed pointer corrupt file or database.';
strError3DS_GET_FAIL = 'Failed to get new data from database.';
strError3DS_PUT_FAIL = 'Failed to add new data to the database.';
strError3DS_INVALID_INDEX = 'Invalid index %d.';
strCUTILFailed = 'Can not initialize cutil32.dll';
strCantConvertImg = '%s: can''t convert image to RGBA8 format';
strNoJoystickDriver = 'There''s no joystick driver present';
strConnectJoystick = 'Joystick is not connected to your system';
strJoystickError = 'Your system reports a joystick error, can''t do anything about it';
strCyclicRefMat = 'Cyclic reference detected in material "%s"';
strOctreeMustBePreparedBeforeUse = 'Octree must be prepared before use';
strInvalidFileSignature = 'Invalid file signature';
strBrokenObjectListArchive = 'Broken ObjectList archive';
strListIndexError = 'Invalid list index';
strForwardContextFailed = 'Can not create forward compatible context: #%X, %s';
strBackwardContextFailed = 'Can not create backward compatible context: #%X, %s';
strFailHWRC = 'Unable to create rendering context with hardware acceleration - down to software';
strTmpRC_Created = 'Temporary rendering context created';
strDriverNotSupportFRC = 'Driver not support creating of forward context';
strDriverNotSupportOESRC = 'Driver not support creating of OpenGL ES 2.0 context';
strDriverNotSupportDebugRC = 'Driver not support creating of debug context';
strOESvsForwardRC = 'OpenGL ES 2.0 context incompatible with Forward context - flag ignored';
strFRC_created = 'Forward core context seccussfuly created';
strOESRC_created = 'OpenGL ES 2.0 context seccussfuly created';
strPBufferRC_created = 'Backward compatible core PBuffer context successfully created';
strOpenGLCategoryName = 'OpenGL';
strLayoutCategoryName = 'Layout';
strLocalizableCategoryName = 'Localizable';
strVisualCategoryName = 'Visual';
strShaderNeedsAtLeastOneLightSource = 'This shader needs at least one LightSource!';
strShaderNeedsAtLeastOneLightSourceEx = 'Shader ''%s'' needs at least one LightSource!';
strSceneRoot = 'Scene root';
strObjectRoot = 'Scene objects';
strCameraRoot = 'Cameras';
strCamera = 'Camera';
strImageInvalid = 'Could not load texture, image is invalid';
strNoNewTexture = 'Could not get new texture name';
strMatLibNotDefined = 'Material Library not defined!';
strMaterialNotFoundInMatlib = 'Material not found in current Material Library!';
strMaterialNotFoundInMatlibEx = 'Material "%s" not found in current Material Library!';
strSphereTopBottom = 'The top angle must be higher than the bottom angle';
strSphereStartStop = 'The start angle must be smaller than then stop angle';
strMaterialNotFound = 'Loading failed: could not find material %s';
strInterleaveNotSupported = 'Interleaved Array format not supported yet. Sorry.';
strUnknownArchive = '%s : unknown archive version %d';
strOutOfMemory = 'Fatal: Out of memory';
strFileNotFound = 'File %s not found';
strFailedOpenFile = 'Could not open file: %s';
strFailedOpenFileFromCurrentDir = 'Could not open file: %s'#13#10'(Current directory is %s)';
strNoDescriptionAvailable = 'No description available';
strUnBalancedBeginEndUpdate = 'Unbalanced Begin/EndUpdate';
strUnknownExtension = 'Unknown file extension (%s), maybe you forgot to add the support ' +'unit to your uses? (%s?)' ;
strMissingResource = 'Missing application resource: %s: %s';
strIncompatibleTypes = 'Incompatible types!';
strUnknownType = 'Unknown type!';
strUnsupportedType = 'Unsupported type!';
strOCBasicGeometry = 'Basic geometry';
strOCAdvancedGeometry = 'Advanced geometry';
strOCMeshObjects = 'Mesh objects';
strOCParticleSystems = 'Particle systems';
strOCEnvironmentObjects = 'Environment objects';
strOCSpecialObjects = 'Special objects';
strOCGraphPlottingObjects = 'Graph-plotting objects';
strOCDoodad = 'Doodad objects';
strOCHUDObjects = 'HUD objects';
strOCGuiObjects = 'GUI objects';
strOCProxyObjects = 'Proxy objects';
strOCExperimental = 'Experimental objects';
strInvalidColor = '''%s'' is not a valid color format!';
strUnknownParam = 'Unknown %s "%s" for "%s" or program not in use';
strXCollectionEditor = 'XCollection editor';
strModuleAbsent = 'Module is absent';
strInvalidParamType = 'Invalid parameter type';
strInvalidContextReg = 'Invalid context registration.';
strInvalidValue = 'Invalid value';
strWrongParamSetup = 'Function''s parameters must be setup in OnParameterSetup event';
strLaunchFailed = 'Kernel function "%s" launch failed';
strFailMap = 'Unable to map %s - already mapped';
strFailUnmap = 'Unable to unmap %s - not mapped';
strFailCompilation = 'NVCC failed to compile:' + #10#13 + '%s';
strFailCreatePipe = 'Unable to create Pipe';
strFailRunNVCC = 'Unable to run process (NVCC)';
strFuncRetErr = '%s return error: %s';
strFuncNotConnected = '%s.Launch: Kernel function not connected';
strOnlyHostData = 'Only host data or mapped device or array data can be written/read';
strOutOfRange = 'Indexes out of range';
strSizeMismatch = 'Element size mismatch';
strCUDAEditor = 'Scene CUDA Component Editor';
strRequireFreeThread = 'CUFFT functions require context-free thread';
strBadPlanSize = 'MemData size less then Plan size';
strContextNotInit = 'Context not initialized';
strNoDeviceToCreate = 'No device to create CUDA context';
strThreadBusy = 'Unable to create CUDA context - thread is busy by another context';
strMakeFloatingFail = 'Unable to make context floating after creation';
strUnbalansedUsage = 'Unbalansed CUDA context usage';
strInvalidGLContext = 'Unable to create CUDA context with OpenGL interop' + ' - OpenGL context not ready';
strFFTFuncRetErr = '%s return error: %s';
strFailToBindArrayToTex = 'Unable to bind CUDA array to OpenGL unmaped t' + 'exture';
strOutOfAttribSize = 'The amount of device''s data less then size of att' + 'ribute''s data.';
strOutOfElementSize = 'The amount of device''s data less then size of in' + 'dexes data.';
strSourceFileNotFound = 'Source file not found';
strSuccessCompilation = 'Successful compilation:' + #10#13 + '%s';

Variables

Language: Integer;

Description

Constants

strDot = '.';

General

strError = 'Error!';

This item has no description.

strErrorEx = 'Error: ';

This item has no description.

strErrorLIB = 'ErrorLIB';

This item has no description.

strInvalidType = 'Invalid data type';

This item has no description.

strNothing = 'Nothing';

This item has no description.

strStateCashMissing = 'States cash missing: ';

This item has no description.

strUnknownArchiveVersion = 'Unknown archive version: ';

This item has no description.

strObjectsNotSupported = 'Linked object not supported';

This item has no description.

strGLSceneEditor = 'GLScene Editor';

SceneEdit

strNoRenderingContext = 'Could not create a rendering context';

SceneViewer

strWrongVersion = 'Need at least OpenGL version 1.1';

This item has no description.

strTooManyLights = 'Too many lights in the scene';

This item has no description.

strDisplayList = 'Failed to create a new display list for object ''%s''';

This item has no description.

strWrongBitmapCanvas = 'Couldn''t create a rendering context for the given bitmap';

This item has no description.

strWrongPrinter = 'Couldn''t render to printer';

This item has no description.

strAlreadyRendering = 'Already rendering';

This item has no description.

strSceneViewerNotDefined = 'SceneViewer not defined!';

This item has no description.

strCadencerNotDefined = 'Cadencer not defined!';

Cadencer

strCadencerNotDefinedEx = 'Cadencer not defined for the ''%s'' component';

This item has no description.

strCannotAlterAnActiveContext = 'Cannot alter an active context';

Context

strContextActivationFailed = 'Context activation failed: %X, %s';

This item has no description.

strContextAlreadyCreated = 'Context already created';

This item has no description.

strContextDeactivationFailed = 'Context deactivation failed';

This item has no description.

strContextNotCreated = 'Context not created';

This item has no description.

strDeleteContextFailed = 'Delete context failed';

This item has no description.

strFailedToShare = 'DoCreateContext - Failed to share contexts';

This item has no description.

strIncompatibleContexts = 'Incompatible contexts';

This item has no description.

strInvalidContextRegistration = 'Invalid context registration';

This item has no description.

strInvalidNotificationRemoval = 'Invalid notification removal';

This item has no description.

strNoActiveRC = 'No active rendering context';

This item has no description.

strUnbalancedContexActivations = 'Unbalanced context activations';

This item has no description.

strUnableToCreateLegacyContext = 'Unable to create legacy context';

This item has no description.

strOpenGLError = 'OpenGL error - %s';

InitOpenGL

str3DSMapNotFound = 'Loading %s map texture failed: %s in %s';

File3DS

strError3DS_NO_MEM = 'Not enough memory to complete operation.';

This item has no description.

strError3DS_INVALID_ARG = 'The argument passed to the function is invalid.'#13+ 'Usually caused by a nil pointer or an out of range numeric argument.';

This item has no description.

strError3DS_INVALID_DATA = 'The structure passed as an argument to the function has'#13+ 'invalid or out of range data in its fields.';

This item has no description.

strError3DS_INVALID_CHUNK = 'An invalid Chunk structure was encountered while reading'#13+ 'the database. Usually caused by a corrupt database or file.';

This item has no description.

strError3DS_INVALID_DATABASE = 'The database passed as an argument has not be created yet.';

This item has no description.

strError3DS_WRONG_DATABASE = 'The database passed as an argument is the wrong kind of'#13+ 'database for this function.';

This item has no description.

strError3DS_UNFOUND_CHUNK = 'The database is missing important file chunks needed to'#13+ 'fill out the requested structure. Usually caused by a corrupt database or file.';

This item has no description.

strError3DS_WRONG_OBJECT = 'The Name passed to the functions exists but is not the type of object asked for.'#13+ 'For example asking for a mesh object with the GetCameraByName3DS function.';

This item has no description.

strError3DS_NO_SUCH_FILE = 'The FileName passed as an argument for reading does not exist.';

This item has no description.

strError3DS_INIT_FAILED = 'Failed to initialize structure passed as an argument.';

This item has no description.

strError3DS_OPENING_FILE = 'Could not open requested file.';

This item has no description.

strError3DS_CLOSING_FILE = 'Could not close requested file.';

This item has no description.

strError3DS_READING_FILE = 'Error occured while reading file.';

This item has no description.

strError3DS_CREATING_DATABASE = 'Error occured while creating database.';

This item has no description.

strError3DS_READING_DATABASE = 'Error occured while reading database.';

This item has no description.

strError3DS_WRITING_DATABASE = 'Error occured while writing database.';

This item has no description.

strError3DS_WRITING_FILE = 'Error occured while writing file.';

This item has no description.

strError3DS_STRING_TOO_LONG = 'String encountered in file structure or as an argument was longer than expected.'#13+ 'Possibly caused by an uninitialed pointer corrupt file or database.';

This item has no description.

strError3DS_GET_FAIL = 'Failed to get new data from database.';

This item has no description.

strError3DS_PUT_FAIL = 'Failed to add new data to the database.';

This item has no description.

strError3DS_INVALID_INDEX = 'Invalid index %d.';

This item has no description.

strCUTILFailed = 'Can not initialize cutil32.dll';

FilePGM

strCantConvertImg = '%s: can''t convert image to RGBA8 format';

Graphics

strNoJoystickDriver = 'There''s no joystick driver present';

Joystick

strConnectJoystick = 'Joystick is not connected to your system';

This item has no description.

strJoystickError = 'Your system reports a joystick error, can''t do anything about it';

This item has no description.

strCyclicRefMat = 'Cyclic reference detected in material "%s"';

Material

strOctreeMustBePreparedBeforeUse = 'Octree must be prepared before use';

Octree

strInvalidFileSignature = 'Invalid file signature';

PersistentClasses

strBrokenObjectListArchive = 'Broken ObjectList archive';

This item has no description.

strListIndexError = 'Invalid list index';

This item has no description.

strForwardContextFailed = 'Can not create forward compatible context: #%X, %s';

SceneContext

strBackwardContextFailed = 'Can not create backward compatible context: #%X, %s';

This item has no description.

strFailHWRC = 'Unable to create rendering context with hardware acceleration - down to software';

This item has no description.

strTmpRC_Created = 'Temporary rendering context created';

This item has no description.

strDriverNotSupportFRC = 'Driver not support creating of forward context';

This item has no description.

strDriverNotSupportOESRC = 'Driver not support creating of OpenGL ES 2.0 context';

This item has no description.

strDriverNotSupportDebugRC = 'Driver not support creating of debug context';

This item has no description.

strOESvsForwardRC = 'OpenGL ES 2.0 context incompatible with Forward context - flag ignored';

This item has no description.

strFRC_created = 'Forward core context seccussfuly created';

This item has no description.

strOESRC_created = 'OpenGL ES 2.0 context seccussfuly created';

This item has no description.

strPBufferRC_created = 'Backward compatible core PBuffer context successfully created';

This item has no description.

strOpenGLCategoryName = 'OpenGL';

SceneRegister, strings additional to Designintf

strLayoutCategoryName = 'Layout';

This item has no description.

strLocalizableCategoryName = 'Localizable';

This item has no description.

strVisualCategoryName = 'Visual';

This item has no description.

strShaderNeedsAtLeastOneLightSource = 'This shader needs at least one LightSource!';

Shaders

strShaderNeedsAtLeastOneLightSourceEx = 'Shader ''%s'' needs at least one LightSource!';

This item has no description.

strSceneRoot = 'Scene root';

Tree

strObjectRoot = 'Scene objects';

This item has no description.

strCameraRoot = 'Cameras';

This item has no description.

strCamera = 'Camera';

This item has no description.

strImageInvalid = 'Could not load texture, image is invalid';

Textures

strNoNewTexture = 'Could not get new texture name';

This item has no description.

strMatLibNotDefined = 'Material Library not defined!';

Materials

strMaterialNotFoundInMatlib = 'Material not found in current Material Library!';

This item has no description.

strMaterialNotFoundInMatlibEx = 'Material "%s" not found in current Material Library!';

This item has no description.

strSphereTopBottom = 'The top angle must be higher than the bottom angle';

Objects

strSphereStartStop = 'The start angle must be smaller than then stop angle';

This item has no description.

strMaterialNotFound = 'Loading failed: could not find material %s';

This item has no description.

strInterleaveNotSupported = 'Interleaved Array format not supported yet. Sorry.';

This item has no description.

strUnknownArchive = '%s : unknown archive version %d';

Common messages

strOutOfMemory = 'Fatal: Out of memory';

This item has no description.

strFileNotFound = 'File %s not found';

This item has no description.

strFailedOpenFile = 'Could not open file: %s';

This item has no description.

strFailedOpenFileFromCurrentDir = 'Could not open file: %s'#13#10'(Current directory is %s)';

This item has no description.

strNoDescriptionAvailable = 'No description available';

This item has no description.

strUnBalancedBeginEndUpdate = 'Unbalanced Begin/EndUpdate';

This item has no description.

strUnknownExtension = 'Unknown file extension (%s), maybe you forgot to add the support ' +'unit to your uses? (%s?)' ;

This item has no description.

strMissingResource = 'Missing application resource: %s: %s';

This item has no description.

strIncompatibleTypes = 'Incompatible types!';

This item has no description.

strUnknownType = 'Unknown type!';

This item has no description.

strUnsupportedType = 'Unsupported type!';

This item has no description.

strOCBasicGeometry = 'Basic geometry';

Object categories in GLScene Registry

strOCAdvancedGeometry = 'Advanced geometry';

This item has no description.

strOCMeshObjects = 'Mesh objects';

This item has no description.

strOCParticleSystems = 'Particle systems';

This item has no description.

strOCEnvironmentObjects = 'Environment objects';

This item has no description.

strOCSpecialObjects = 'Special objects';

This item has no description.

strOCGraphPlottingObjects = 'Graph-plotting objects';

This item has no description.

strOCDoodad = 'Doodad objects';

This item has no description.

strOCHUDObjects = 'HUD objects';

This item has no description.

strOCGuiObjects = 'GUI objects';

This item has no description.

strOCProxyObjects = 'Proxy objects';

This item has no description.

strOCExperimental = 'Experimental objects';

This item has no description.

strInvalidColor = '''%s'' is not a valid color format!';

Utils

strUnknownParam = 'Unknown %s "%s" for "%s" or program not in use';

This item has no description.

strXCollectionEditor = 'XCollection editor';

FXCollectionEditor

strModuleAbsent = 'Module is absent';

CUDA strings

strInvalidParamType = 'Invalid parameter type';

This item has no description.

strInvalidContextReg = 'Invalid context registration.';

This item has no description.

strInvalidValue = 'Invalid value';

This item has no description.

strWrongParamSetup = 'Function''s parameters must be setup in OnParameterSetup event';

This item has no description.

strLaunchFailed = 'Kernel function "%s" launch failed';

This item has no description.

strFailMap = 'Unable to map %s - already mapped';

This item has no description.

strFailUnmap = 'Unable to unmap %s - not mapped';

This item has no description.

strFailCompilation = 'NVCC failed to compile:' + #10#13 + '%s';

This item has no description.

strFailCreatePipe = 'Unable to create Pipe';

This item has no description.

strFailRunNVCC = 'Unable to run process (NVCC)';

This item has no description.

strFuncRetErr = '%s return error: %s';

This item has no description.

strFuncNotConnected = '%s.Launch: Kernel function not connected';

This item has no description.

strOnlyHostData = 'Only host data or mapped device or array data can be written/read';

This item has no description.

strOutOfRange = 'Indexes out of range';

This item has no description.

strSizeMismatch = 'Element size mismatch';

This item has no description.

strCUDAEditor = 'Scene CUDA Component Editor';

This item has no description.

strRequireFreeThread = 'CUFFT functions require context-free thread';

This item has no description.

strBadPlanSize = 'MemData size less then Plan size';

This item has no description.

strContextNotInit = 'Context not initialized';

This item has no description.

strNoDeviceToCreate = 'No device to create CUDA context';

This item has no description.

strThreadBusy = 'Unable to create CUDA context - thread is busy by another context';

This item has no description.

strMakeFloatingFail = 'Unable to make context floating after creation';

This item has no description.

strUnbalansedUsage = 'Unbalansed CUDA context usage';

This item has no description.

strInvalidGLContext = 'Unable to create CUDA context with OpenGL interop' + ' - OpenGL context not ready';

This item has no description.

strFFTFuncRetErr = '%s return error: %s';

This item has no description.

strFailToBindArrayToTex = 'Unable to bind CUDA array to OpenGL unmaped t' + 'exture';

This item has no description.

strOutOfAttribSize = 'The amount of device''s data less then size of att' + 'ribute''s data.';

This item has no description.

strOutOfElementSize = 'The amount of device''s data less then size of in' + 'dexes data.';

This item has no description.

strSourceFileNotFound = 'Source file not found';

This item has no description.

strSuccessCompilation = 'Successful compilation:' + #10#13 + '%s';

This item has no description.

Variables

Language: Integer;

String constants that are used for internationalization

To build your project with a single language's translations in the executable itself, define one of the next languages

Language $DEFINE 2-character locale id ——————- ———- ——————— English LANG_EN en French LANG_FR fr German LANG_DE de Italian LANG_IT it Japanese LANG_JP jp Russian LANG_RU ru Spanish LANG_ES es


GLSysHelp v.2.5: GLScene.TextureFormat

Unit GLScene.TextureFormat

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • GLScene.OpenGLTokens
  • GLScene.Strings

Overview

Functions and Procedures

function InternalFormatToOpenGLFormat(intFormat: TGLInternalFormat): Cardinal;
function OpenGLFormatToInternalFormat(glFormat: Cardinal): TGLInternalFormat;
function GetTextureElementSize(intFormat: TGLInternalFormat): Integer; overload;
function GetTextureElementSize(colorFormat: Cardinal; dataType: Cardinal): Integer; overload;
procedure FindCompatibleDataFormat(intFormat: TGLInternalFormat; out dFormat: Cardinal; out dType: Cardinal);
function CompressedInternalFormatToOpenGL(intFormat: TGLInternalFormat): Integer;
function IsTargetSupported(glTarget: Cardinal): Boolean; overload;
function IsTargetSupported(target: TGLTextureTarget): Boolean; overload;
function IsFormatSupported(intFormat: TGLInternalFormat): Boolean;
function IsFloatFormat(intFormat: TGLInternalFormat): Boolean; overload;
function IsFloatFormat(glFormat: Cardinal): Boolean; overload;
function IsDepthFormat(intFormat: TGLInternalFormat): boolean; overload;
function IsDepthFormat(glFormat: Cardinal): Boolean; overload;
function IsCompressedFormat(intFormat: TGLInternalFormat): Boolean; overload;
function IsCompressedFormat(glFormat: Cardinal): Boolean; overload;
function GetGenericCompressedFormat(const intFormat: TGLInternalFormat; const colorFormat: Cardinal; out internalFormat: Cardinal): Boolean;
function GetUncompressedFormat(const intFormat: TGLInternalFormat; out internalFormat: TGLInternalFormat; out colorFormat: Cardinal): Boolean;
function DecodeTextureTarget(const TextureTarget: TGLTextureTarget): Cardinal;
function EncodeGLTextureTarget(const glTarget: Cardinal): TGLTextureTarget;
function IsTargetSupportMipmap(const TextureTarget: TGLTextureTarget): Boolean; overload;
function IsTargetSupportMipmap(const glTarget: Cardinal): Boolean; overload;

Types

TglInternalCompression = (...);
TglInternalFormat = (...);
TglSeparateTextureWrap = (...);
TglSwizzleVector = array[0..3] of TglTextureSwizzle;
TglTextureCompareMode = (...);
TglTextureFilteringQuality = (...);
TglTextureSwizzle = (...);
TglTextureTarget = (...);

Constants

cDefaultSwizzleVector: TglSwizzleVector = (tswRed, tswGreen, tswBlue, tswAlpha);

Variables

vDefaultTextureFormat: TglInternalFormat = tfRGBA8;
vDefaultTextureCompression: TglInternalCompression = tcNone;

Description

Functions and Procedures

function InternalFormatToOpenGLFormat(intFormat: TGLInternalFormat): Cardinal;

Give a openGL texture format from GLScene texture format

function OpenGLFormatToInternalFormat(glFormat: Cardinal): TGLInternalFormat;

Give a GLScene texture format from openGL texture format

function GetTextureElementSize(intFormat: TGLInternalFormat): Integer; overload;

Give a pixel size in bytes from texture format or data format

function GetTextureElementSize(colorFormat: Cardinal; dataType: Cardinal): Integer; overload;

This item has no description.

procedure FindCompatibleDataFormat(intFormat: TGLInternalFormat; out dFormat: Cardinal; out dType: Cardinal);

Give compatible openGL image format and data type

function CompressedInternalFormatToOpenGL(intFormat: TGLInternalFormat): Integer;

Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format

function IsTargetSupported(glTarget: Cardinal): Boolean; overload;

True if texture target supported

function IsTargetSupported(target: TGLTextureTarget): Boolean; overload;

This item has no description.

function IsFormatSupported(intFormat: TGLInternalFormat): Boolean;

True if texture format is supported by hardware or software

function IsFloatFormat(intFormat: TGLInternalFormat): Boolean; overload;

True if texture format is float

function IsFloatFormat(glFormat: Cardinal): Boolean; overload;

This item has no description.

function IsDepthFormat(intFormat: TGLInternalFormat): boolean; overload;

True if depth texture

function IsDepthFormat(glFormat: Cardinal): Boolean; overload;

This item has no description.

function IsCompressedFormat(intFormat: TGLInternalFormat): Boolean; overload;

True if texture compressed

function IsCompressedFormat(glFormat: Cardinal): Boolean; overload;

This item has no description.

function GetGenericCompressedFormat(const intFormat: TGLInternalFormat; const colorFormat: Cardinal; out internalFormat: Cardinal): Boolean;

Give generic compressed OpenGL texture format

function GetUncompressedFormat(const intFormat: TGLInternalFormat; out internalFormat: TGLInternalFormat; out colorFormat: Cardinal): Boolean;

Give uncompressed texture format and OpenGL color format

function DecodeTextureTarget(const TextureTarget: TGLTextureTarget): Cardinal;

This item has no description.

function EncodeGLTextureTarget(const glTarget: Cardinal): TGLTextureTarget;

This item has no description.

function IsTargetSupportMipmap(const TextureTarget: TGLTextureTarget): Boolean; overload;

This item has no description.

function IsTargetSupportMipmap(const glTarget: Cardinal): Boolean; overload;

This item has no description.

Types

TglInternalCompression = (...);

Texture compression option. If OpenGL supports it, this will activate a compressed texture format: tcDefault : uses global default compression option tcNone : do not use compression tcStandard : use standard compression, average quality, average rate tcHighQuality : choose a high-quality, low-speed compression tcHighSpeed : choose a high-speed, low-quality compression

Values
  • tcDefault
  • tcNone
  • tcStandard
  • tcHighQuality
  • tcHighSpeed
TglInternalFormat = (...);

This item has no description.

Values
  • tfALPHA4
  • tfALPHA8
  • tfALPHA12
  • tfALPHA16
  • tfDEPTH_COMPONENT16
  • tfDEPTH_COMPONENT24
  • tfDEPTH_COMPONENT32
  • tfLUMINANCE4
  • tfLUMINANCE8
  • tfLUMINANCE12
  • tfLUMINANCE16
  • tfLUMINANCE4_ALPHA4
  • tfLUMINANCE6_ALPHA2
  • tfLUMINANCE8_ALPHA8
  • tfLUMINANCE12_ALPHA4
  • tfLUMINANCE12_ALPHA12
  • tfLUMINANCE16_ALPHA16
  • tfINTENSITY4
  • tfINTENSITY8
  • tfINTENSITY12
  • tfINTENSITY16
  • tfR3_G3_B2
  • tfRGB4
  • tfRGB5
  • tfRGB8
  • tfRGB10
  • tfRGB12
  • tfR16G16B16
  • tfRGBA2
  • tfRGBA4
  • tfRGB5_A1
  • tfRGBA8
  • tfRGB10_A2
  • tfRGBA12
  • tfR16G16B16A16
  • tfCOMPRESSED_RGB_S3TC_DXT1
  • tfCOMPRESSED_RGBA_S3TC_DXT1
  • tfCOMPRESSED_RGBA_S3TC_DXT3
  • tfCOMPRESSED_RGBA_S3TC_DXT5
  • tfSIGNED_LUMINANCE8
  • tfSIGNED_LUMINANCE8_ALPHA8
  • tfSIGNED_RGB8
  • tfSIGNED_RGBA8
  • tfSIGNED_RGB8_UNSIGNED_ALPHA8
  • tfSIGNED_ALPHA8
  • tfSIGNED_INTENSITY8
  • tfHILO16
  • tfSIGNED_HILO16
  • tfDSDT8
  • tfDSDT8_MAG8
  • tfDSDT8_MAG8_INTENSITY8
  • tfHILO8
  • tfSIGNED_HILO8
  • tfFLOAT_R16
  • tfFLOAT_R32
  • tfFLOAT_RG16
  • tfFLOAT_RGB16
  • tfFLOAT_RGBA16
  • tfFLOAT_RG32
  • tfFLOAT_RGB32
  • tfFLOAT_RGBA32
  • tfRGBA_FLOAT32
  • tfRGB_FLOAT32
  • tfALPHA_FLOAT32
  • tfINTENSITY_FLOAT32
  • tfLUMINANCE_FLOAT32
  • tfLUMINANCE_ALPHA_FLOAT32
  • tfRGBA_FLOAT16
  • tfRGB_FLOAT16
  • tfALPHA_FLOAT16
  • tfINTENSITY_FLOAT16
  • tfLUMINANCE_FLOAT16
  • tfLUMINANCE_ALPHA_FLOAT16
  • tfDEPTH24_STENCIL8
  • tfDEPTH_COMPONENT32F
  • tfDEPTH32F_STENCIL8
  • tfSRGB8
  • tfSRGB8_ALPHA8
  • tfSLUMINANCE8
  • tfSLUMINANCE8_ALPHA8
  • tfCOMPRESSED_SRGB_S3TC_DXT1
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT1
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT3
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT5
  • tfRGB9_E5
  • tfR11F_G11F_B10F
  • tfCOMPRESSED_LUMINANCE_LATC1
  • tfCOMPRESSED_SIGNED_LUMINANCE_LATC1
  • tfCOMPRESSED_LUMINANCE_ALPHA_LATC2
  • tfCOMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2
  • tfCOMPRESSED_LUMINANCE_ALPHA_3DC
  • tfRGBA32UI
  • tfRGB32UI
  • tfALPHA32UI
  • tfINTENSITY32UI
  • tfLUMINANCE32UI
  • tfLUMINANCE_ALPHA32UI
  • tfRGBA16UI
  • tfRGB16UI
  • tfALPHA16UI
  • tfINTENSITY16UI
  • tfLUMINANCE16UI
  • tfLUMINANCE_ALPHA16UI
  • tfRGBA8UI
  • tfRGB8UI
  • tfALPHA8UI
  • tfINTENSITY8UI
  • tfLUMINANCE8UI
  • tfLUMINANCE_ALPHA8UI
  • tfRGBA32I
  • tfRGB32I
  • tfALPHA32I
  • tfINTENSITY32I
  • tfLUMINANCE32I
  • tfLUMINANCE_ALPHA32I
  • tfRGBA16I
  • tfRGB16I
  • tfALPHA16I
  • tfINTENSITY16I
  • tfLUMINANCE16I
  • tfLUMINANCE_ALPHA16I
  • tfRGBA8I
  • tfRGB8I
  • tfALPHA8I
  • tfINTENSITY8I
  • tfLUMINANCE8I
  • tfLUMINANCE_ALPHA8I
  • tfRG32UI
  • tfR32UI
  • tfRG16UI
  • tfR16UI
  • tfRG8UI
  • tfR8UI
  • tfRG32I
  • tfR32I
  • tfRG16I
  • tfR16I
  • tfRG8I
  • tfR8I
  • tfRG8
  • tfR8
  • tfRG16
  • tfR16
  • tfRG16F
  • tfR16F
  • tfRG32F
  • tfR32F
  • tfCOMPRESSED_RED_RGTC1
  • tfCOMPRESSED_SIGNED_RED_RGTC1
  • tfCOMPRESSED_RG_RGTC2
  • tfCOMPRESSED_SIGNED_RG_RGTC2
  • tfR8_SNORM
  • tfRG8_SNORM
  • tfRGB8_SNORM
  • tfRGBA8_SNORM
  • tfR16_SNORM
  • tfRG16_SNORM
  • tfRGB16_SNORM
  • tfRGBA16_SNORM
TglSeparateTextureWrap = (...);

Texture addressing rules

Values
  • twRepeat
  • twClampToEdge
  • twClampToBorder
  • twMirrorRepeat
  • twMirrorClampToEdge
  • twMirrorClampToBorder
TglSwizzleVector = array[0..3] of TglTextureSwizzle;

This item has no description.

TglTextureCompareMode = (...);

Specifies the texture comparison mode for currently bound depth textures. That is, a texture whose internal format is tfDEPTH_COMPONENT*

Values
  • tcmNone
  • tcmCompareRtoTexture
TglTextureFilteringQuality = (...);

Filtering quality

Values
  • tfIsotropic
  • tfAnisotropic
TglTextureSwizzle = (...);

This item has no description.

Values
  • tswRed
  • tswGreen
  • tswBlue
  • tswAlpha
  • tswZero
  • tswOne
TglTextureTarget = (...);

This item has no description.

Values
  • ttNoShape
  • ttTexture1D
  • ttTexture2D
  • ttTexture3D
  • ttTexture1DArray
  • ttTexture2DArray
  • ttTextureRect
  • ttTextureBuffer
  • ttTextureCube
  • ttTexture2DMultisample
  • ttTexture2DMultisampleArray
  • ttTextureCubeArray

Constants

cDefaultSwizzleVector: TglSwizzleVector = (tswRed, tswGreen, tswBlue, tswAlpha);

This item has no description.

Variables

vDefaultTextureFormat: TglInternalFormat = tfRGBA8;

This item has no description.

vDefaultTextureCompression: TglInternalCompression = tcNone;


GLSysHelp v.2.5: GLScene.Triangulation

Unit GLScene.Triangulation

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.Types
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record DVertex |
Record DTriangle |
Class TGDelaunay2D |

Types

TDComplete = array of Boolean;
TDEdges = array of array of LongInt;
TDProgressEvent = procedure(State: string; Pos, Max: Integer; AlwaysUpdate: Boolean = False) of object;
TDTriangle = array of DTriangle;
TDVertex = array of DVertex;

Constants

MaxVertices = 500000;
MaxTriangles = 1000000;
ExPtTolerance = 0.000001;

Description

Types

TDComplete = array of Boolean;

This item has no description.

TDEdges = array of array of LongInt;

This item has no description.

TDProgressEvent = procedure(State: string; Pos, Max: Integer; AlwaysUpdate: Boolean = False) of object;

This item has no description.

TDTriangle = array of DTriangle;

This item has no description.

TDVertex = array of DVertex;

This item has no description.

Constants

MaxVertices = 500000;

Set these as applicable

MaxTriangles = 1000000;

This item has no description.

ExPtTolerance = 0.000001;


GLSysHelp v.2.5: GLScene.Triangulation: Record DVertex

Record DVertex

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Triangulation

Declaration

type DVertex = record

Description

Points (Vertices)

Overview

Fields

Public | X: Single;
Public | Y: Single;
Public | Z: Single;
Public | U: Single;
Public | V: Single;
Public | MatIndex: Integer;

Description

Fields

Public X: Single;

This item has no description.

Public Y: Single;

This item has no description.

Public Z: Single;

This item has no description.

Public U: Single;

Added to save height of terrain.

Public V: Single;

This item has no description.

Public MatIndex: Integer;


GLSysHelp v.2.5: GLScene.Triangulation: Record DTriangle

Record DTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Triangulation

Declaration

type DTriangle = record

Description

Created Triangles, vv# are the vertex pointers

Overview

Fields

Public | vv0: LongInt;
Public | vv1: LongInt;
Public | vv2: LongInt;
Public | PreCalc: Integer;
Public | Xc: Single;
Public | Yc: Single;
Public | R: Single;

Description

Fields

Public vv0: LongInt;

This item has no description.

Public vv1: LongInt;

This item has no description.

Public vv2: LongInt;

This item has no description.

Public PreCalc: Integer;

This item has no description.

Public Xc: Single;

This item has no description.

Public Yc: Single;

This item has no description.

Public R: Single;


GLSysHelp v.2.5: GLScene.Triangulation: Class TGDelaunay2D

Class TGDelaunay2D

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Triangulation

Declaration

type TGDelaunay2D = class(TObject)

Description

TGDelaunay2D is a class for Delaunay triangulation of arbitrary points Credit to Paul Bourke (http://paulbourke.net/) for the original Fortran 77 Program :)) Conversion to Visual Basic by EluZioN (EluZioN@casesladder.com) Conversion from VB to Delphi6 by Dr Steve Evans (steve@lociuk.com) June 2002 Update by Dr Steve Evans: Heap memory allocation added to prevent stack overflow when MaxVertices and MaxTriangles are very large. Additional Updates in June 2002: Bug in InCircle function fixed. Radius r := Sqrt(rsqr). Check for duplicate points added when inserting new point. For speed, all points pre-sorted in x direction using quicksort algorithm and triangles flagged when no longer needed. The circumcircle centre and radius of the triangles are now stored to improve calculation time. You can use this code however you like providing the above credits remain in tact

Hierarchy

  • TObject
  • TGDelaunay2D

Overview

Fields

Public | Vertex: TDVertex;
Public | Triangle: TDTriangle;
Public | HowMany: Integer;
Public | TPoints: Integer;
Public | OnProgress: TDProgressEvent;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Private | function InCircle(Xp, Yp, X1, Y1, X2, Y2, X3, Y3: Single; out Xc,Yc, R: Single; j: Integer): Boolean;
Private | function Triangulate(nvert: Integer): Integer;
Public | procedure AddPoint(X, Y, Z, U, V: Single; MatIndex: Integer);
Public | procedure AddPointNoCheck(X, Y, Z, U, V: Single; MatIndex: Integer);
Public | procedure Mesh(sort: Boolean);
Public | procedure QuickSort(var A: TDVertex; Low, High: Integer);
Public | procedure RemoveLastPoint;

Description

Fields

Public Vertex: TDVertex;

This item has no description.

Public Triangle: TDTriangle;

This item has no description.

Public HowMany: Integer;

This item has no description.

Public TPoints: Integer;

Total number of points (vertices)

Public OnProgress: TDProgressEvent;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function InCircle(Xp, Yp, X1, Y1, X2, Y2, X3, Y3: Single; out Xc,Yc, R: Single; j: Integer): Boolean;

This item has no description.

Private function Triangulate(nvert: Integer): Integer;

Takes as input NVERT vertices in arrays Vertex() Returned is a list of NTRI triangular faces in the array Triangle(). These triangles are arranged in clockwise order.

Public procedure AddPoint(X, Y, Z, U, V: Single; MatIndex: Integer);

This item has no description.

Public procedure AddPointNoCheck(X, Y, Z, U, V: Single; MatIndex: Integer);

This item has no description.

Public procedure Mesh(sort: Boolean);

This item has no description.

Public procedure QuickSort(var A: TDVertex; Low, High: Integer);

This item has no description.

Public procedure RemoveLastPoint;


GLSysHelp v.2.5: GLScene.Utils

Unit GLScene.Utils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.ShellApi
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • GLScene.VectorGeometry
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLUtilsException |

Functions and Procedures

function GetCurrentAssetPath(): TFileName;
procedure WordToIntegerArray(Source: PWordArray; Dest: PIntegerArray; Count: Cardinal);
function RoundUpToPowerOf2(value: Integer): Integer;
function RoundDownToPowerOf2(value: Integer): Integer;
function IsPowerOf2(value: Integer): Boolean;
function ReadCRLFString(aStream: TStream): String;
procedure WriteCRLFString(aStream: TStream; const aString: String);
function StrToFloatDef(const strValue: string; defValue: Extended = 0) : Extended;
function Str2Float(const S: string): Single;
function ParseInteger(var p: PChar): Integer;
function ParseFloat(var p: PChar): Extended;
procedure SaveAnsiStringToFile(const fileName: string; const data: AnsiString);
function LoadAnsiStringFromFile(const fileName: string): AnsiString;
procedure SaveStringToFile(const fileName: string; const data: String);
function LoadStringFromFile(const fileName: string): String;
procedure SaveComponentToFile(const Component: TComponent; const fileName: string; const AsText: Boolean = True);
procedure LoadComponentFromFile(const Component: TComponent; const fileName: string; const AsText: Boolean = True);
function SizeOfFile(const fileName: string): Int64;
function GetSqrt255Array: PSqrt255Array;
function GetGLRect(const aLeft, aTop, aRight, aBottom: Integer): TRect;
procedure InflateGLRect(var aRect: TRect; dx, dy: Integer);
procedure IntersectGLRect(var aRect: TRect; const rect2: TRect);
procedure RaiseLastOSError;
procedure FixPathDelimiter(var S: string);
function RelativePath(const S: string): string;
procedure QueryPerformanceCounter(out val: Int64);
function QueryPerformanceFrequency(out val: Int64): Boolean;
function StartPrecisionTimer: Int64;
function PrecisionTimerLap(const precisionTimer: Int64): Double;
function StopPrecisionTimer(const precisionTimer: Int64): Double;
function AppTime: Double;
procedure ShowHTMLUrl(const Url: string);
procedure SetExeDirectory;
function AnsiStartsText(const ASubText, AText: string): Boolean;
function IsSubComponent(const AComponent: TComponent): Boolean; inline;
procedure MakeSubComponent(const AComponent: TComponent; const value: Boolean);
function FindUnitName(anObject: TObject): string; overload;
function FindUnitName(aClass: TClass): string; overload;
function FloatToHalf(Float: Single): THalfFloat;
function HalfToFloat(Half: THalfFloat): Single;
function GetValueFromStringsIndex(const AStrings: TStrings; const AIndex: Integer): string;
function IsDirectoryWriteable(const AName: string): Boolean;
function CharToWideChar(const AChar: AnsiChar): WideChar;
function GLStrToFloatDef(const S: string; const Default: Extended; fs: TFormatSettings): Extended; overload;
function GLStrToFloatDef(const S: string; const Default: Extended) : Extended; overload;
function GLStrToFloatDef(const S: string): Extended; overload;

Types

EGLOSError = EOSError;
PHalfFloat = ˆTHalfFloat;
PSqrt255Array = ˆTSqrt255Array;
THalfFloat = type Word;
TProjectTargetNameFunc = function(): string;
TSqrt255Array = array [0 .. 255] of Byte;

Constants

FONT_CHARS_COUNT = 2024;

Variables

IsDesignTime: Boolean = False;
vProjectTargetName: TProjectTargetNameFunc;

Description

Functions and Procedures

function GetCurrentAssetPath(): TFileName;

Get current path to assets from dir examples

procedure WordToIntegerArray(Source: PWordArray; Dest: PIntegerArray; Count: Cardinal);

Copies the values of Source to Dest (converting word values to integer values)

function RoundUpToPowerOf2(value: Integer): Integer;

Round ups to the nearest power of two, value must be positive

function RoundDownToPowerOf2(value: Integer): Integer;

Round down to the nearest power of two, value must be strictly positive

function IsPowerOf2(value: Integer): Boolean;

Returns True if value is a true power of two

function ReadCRLFString(aStream: TStream): String;

Read a CRLF terminated string from a stream. The CRLF is NOT in the returned string.

procedure WriteCRLFString(aStream: TStream; const aString: String);

Write the string and a CRLF in the stream

function StrToFloatDef(const strValue: string; defValue: Extended = 0) : Extended;

Similar to SysUtils.StrToFloatDef, but ignores user's locale

function Str2Float(const S: string): Single;

Trying to read string otherwise using '.' as Decimal Separator

function ParseInteger(var p: PChar): Integer;

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.

function ParseFloat(var p: PChar): Extended;

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.

procedure SaveAnsiStringToFile(const fileName: string; const data: AnsiString);

Saves ansistring "data" to "filename".

function LoadAnsiStringFromFile(const fileName: string): AnsiString;

Returns the ansistring content of "filename".

procedure SaveStringToFile(const fileName: string; const data: String);

Saves string "data" to "filename".

function LoadStringFromFile(const fileName: string): String;

Returns the string content of "filename".

procedure SaveComponentToFile(const Component: TComponent; const fileName: string; const AsText: Boolean = True);

Saves component to a file.

procedure LoadComponentFromFile(const Component: TComponent; const fileName: string; const AsText: Boolean = True);

Loads component from a file.

function SizeOfFile(const fileName: string): Int64;

Returns the size of "filename". Returns 0 (zero) is file does not exists.

function GetSqrt255Array: PSqrt255Array;

Returns a pointer to an array containing the results of "255*sqrt(i/255)".

function GetGLRect(const aLeft, aTop, aRight, aBottom: Integer): TRect;

Rectangle as function

procedure InflateGLRect(var aRect: TRect; dx, dy: Integer);

Increases or decreases the width and height of the specified rectangle. Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.

procedure IntersectGLRect(var aRect: TRect; const rect2: TRect);

This item has no description.

procedure RaiseLastOSError;

This item has no description.

procedure FixPathDelimiter(var S: string);

Replace path delimiter to delimiter of the current platform.

function RelativePath(const S: string): string;

Remove if possible part of path witch leads to project executable.

procedure QueryPerformanceCounter(out val: Int64);

Returns the current value of the highest-resolution counter. If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.

function QueryPerformanceFrequency(out val: Int64): Boolean;

Returns the frequency of the counter used by QueryPerformanceCounter. Return value is in ticks per second (Hz), returns False if no precision counter is available.

function StartPrecisionTimer: Int64;

Starts a precision timer. Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.

function PrecisionTimerLap(const precisionTimer: Int64): Double;

Computes time elapsed since timer start. Return time lap in seconds.

function StopPrecisionTimer(const precisionTimer: Int64): Double;

Computes time elapsed since timer start and stop timer. Return time lap in seconds.

function AppTime: Double;

Returns time in milisecond from application start.

procedure ShowHTMLUrl(const Url: string);

This item has no description.

procedure SetExeDirectory;

This item has no description.

function AnsiStartsText(const ASubText, AText: string): Boolean;

StrUtils.pas

function IsSubComponent(const AComponent: TComponent): Boolean; inline;

Classes.pas

procedure MakeSubComponent(const AComponent: TComponent; const value: Boolean);

This item has no description.

function FindUnitName(anObject: TObject): string; overload;

This item has no description.

function FindUnitName(aClass: TClass): string; overload;

This item has no description.

function FloatToHalf(Float: Single): THalfFloat;

This item has no description.

function HalfToFloat(Half: THalfFloat): Single;

This item has no description.

function GetValueFromStringsIndex(const AStrings: TStrings; const AIndex: Integer): string;

This item has no description.

function IsDirectoryWriteable(const AName: string): Boolean;

Determine if the directory is writable.

function CharToWideChar(const AChar: AnsiChar): WideChar;

This item has no description.

function GLStrToFloatDef(const S: string; const Default: Extended; fs: TFormatSettings): Extended; overload;

Added by PAL to fix problem with decimal separator in not En-US configurations Decimal separator in text descriptions of meshes for import/export is always '.' char But in System.SysUtils.TextToFloat is Windows char, maybe ',' or others...

function GLStrToFloatDef(const S: string; const Default: Extended) : Extended; overload;

This item has no description.

function GLStrToFloatDef(const S: string): Extended; overload;

This item has no description.

Types

EGLOSError = EOSError;

This item has no description.

PHalfFloat = ˆTHalfFloat;

This item has no description.

PSqrt255Array = ˆTSqrt255Array;

This item has no description.

THalfFloat = type Word;

This item has no description.

TProjectTargetNameFunc = function(): string;

This item has no description.

TSqrt255Array = array [0 .. 255] of Byte;

This item has no description.

Constants

FONT_CHARS_COUNT = 2024;

This item has no description.

Variables

IsDesignTime: Boolean = False;

This item has no description.

vProjectTargetName: TProjectTargetNameFunc;


GLSysHelp v.2.5: GLScene.Utils: Class EGLUtilsException

Class EGLUtilsException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Utils

Declaration

type EGLUtilsException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLUtilsException


GLSysHelp v.2.5: GLScene.VectorGeometry

Unit GLScene.VectorGeometry

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.Math
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TTexPoint |
Record TQuaternion |
Record TRectangle |
Record TFrustum |

Functions and Procedures

function TexPointMake(const S, T: Single): TTexPoint; inline;
function AffineVectorMake(const X, Y, Z: Single): TAffineVector; overload; inline;
function AffineVectorMake(const V: TGLVector): TAffineVector; overload; inline;
procedure SetAffineVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;
procedure SetVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;
procedure SetVector(out V: TAffineVector; const vSrc: TGLVector); overload; inline;
procedure SetVector(out V: TAffineVector; const vSrc: TAffineVector); overload; inline;
procedure SetVector(out V: TAffineDblVector; const vSrc: TAffineVector); overload; inline;
procedure SetVector(out V: TAffineDblVector; const vSrc: TGLVector); overload; inline;
function VectorMake(const V: TAffineVector; W: Single = 0): TGLVector; overload; inline;
function VectorMake(const X, Y, Z: Single; W: Single = 0): TGLVector; overload; inline;
function VectorMake(const Q: TQuaternion): TGLVector; overload; inline;
function PointMake(const X, Y, Z: Single): TGLVector; overload; inline;
function PointMake(const V: TAffineVector): TGLVector; overload; inline;
function PointMake(const V: TGLVector): TGLVector; overload; inline;
procedure SetVector(out V: TGLVector; const X, Y, Z: Single; W: Single = 0); overload; inline;
procedure SetVector(out V: TGLVector; const av: TAffineVector; W: Single = 0); overload; inline;
procedure SetVector(out V: TGLVector; const vSrc: TGLVector); overload; inline;
procedure MakePoint(out V: TGLVector; const X, Y, Z: Single); overload; inline;
procedure MakePoint(out V: TGLVector; const av: TAffineVector); overload; inline;
procedure MakePoint(out V: TGLVector; const av: TGLVector); overload; inline;
procedure MakeVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;
procedure MakeVector(out V: TGLVector; const X, Y, Z: Single); overload; inline;
procedure MakeVector(out V: TGLVector; const av: TAffineVector); overload; inline;
procedure MakeVector(out V: TGLVector; const av: TGLVector); overload; inline;
procedure RstVector(var V: TAffineVector); overload; inline;
procedure RstVector(var V: TGLVector); overload; inline;
function VectorEquals(const Vector1, Vector2: TVector2f): Boolean; overload; inline;
function VectorEquals(const Vector1, Vector2: TVector2i): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector2d): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector2s): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector2b): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector3i): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector3d): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector3s): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector3b): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector4i): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector4d): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector4s): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector4b): Boolean; overload; inline;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3f): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3i): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3d): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3s): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3b): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4f): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4i): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4d): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4s): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4b): Boolean; overload;
function Vector2fMake(const X, Y: Single): TVector2f; overload; inline;
function Vector2iMake(const X, Y: Longint): TVector2i; overload; inline;
function Vector2sMake(const X, Y: SmallInt): TVector2s; overload; inline;
function Vector2dMake(const X, Y: Double): TVector2d; overload; inline;
function Vector2bMake(const X, Y: Byte): TVector2b; overload; inline;
function Vector2fMake(const Vector: TVector3f): TVector2f; overload; inline;
function Vector2iMake(const Vector: TVector3i): TVector2i; overload; inline;
function Vector2sMake(const Vector: TVector3s): TVector2s; overload; inline;
function Vector2dMake(const Vector: TVector3d): TVector2d; overload; inline;
function Vector2bMake(const Vector: TVector3b): TVector2b; overload; inline;
function Vector2fMake(const Vector: TVector4f): TVector2f; overload; inline;
function Vector2iMake(const Vector: TVector4i): TVector2i; overload; inline;
function Vector2sMake(const Vector: TVector4s): TVector2s; overload; inline;
function Vector2dMake(const Vector: TVector4d): TVector2d; overload; inline;
function Vector2bMake(const Vector: TVector4b): TVector2b; overload; inline;
function Vector3fMake(const X: Single; const Y: Single = 0; const Z: Single = 0) : TVector3f; overload; inline;
function Vector3iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0): TVector3i; overload; inline;
function Vector3sMake(const X: SmallInt; const Y: SmallInt = 0; const Z: SmallInt = 0): TVector3s; overload; inline;
function Vector3dMake(const X: Double; const Y: Double = 0; const Z: Double = 0): TVector3d; overload; inline;
function Vector3bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0): TVector3b; overload; inline;
function Vector3fMake(const Vector: TVector2f; const Z: Single = 0): TVector3f; overload; inline;
function Vector3iMake(const Vector: TVector2i; const Z: Longint = 0): TVector3i; overload; inline;
function Vector3sMake(const Vector: TVector2s; const Z: SmallInt = 0): TVector3s; overload; inline;
function Vector3dMake(const Vector: TVector2d; const Z: Double = 0): TVector3d; overload; inline;
function Vector3bMake(const Vector: TVector2b; const Z: Byte = 0): TVector3b; overload; inline;
function Vector3fMake(const Vector: TVector4f): TVector3f; overload; inline;
function Vector3iMake(const Vector: TVector4i): TVector3i; overload; inline;
function Vector3sMake(const Vector: TVector4s): TVector3s; overload; inline;
function Vector3dMake(const Vector: TVector4d): TVector3d; overload; inline;
function Vector3bMake(const Vector: TVector4b): TVector3b; overload; inline;
function Vector4fMake(const X: Single; const Y: Single = 0; const Z: Single = 0; const W: Single = 0): TVector4f; overload; inline;
function Vector4iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload; inline;
function Vector4sMake(const X: SmallInt; const Y: SmallInt = 0; const Z: SmallInt = 0; const W: SmallInt = 0): TVector4s; overload; inline;
function Vector4dMake(const X: Double; const Y: Double = 0; const Z: Double = 0; const W: Double = 0): TVector4d; overload; inline;
function Vector4bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload; inline;
function Vector4fMake(const Vector: TVector3f; const W: Single = 0): TVector4f; overload; inline;
function Vector4iMake(const Vector: TVector3i; const W: Longint = 0): TVector4i; overload; inline;
function Vector4sMake(const Vector: TVector3s; const W: SmallInt = 0) : TVector4s; overload; inline;
function Vector4dMake(const Vector: TVector3d; const W: Double = 0): TVector4d; overload; inline;
function Vector4bMake(const Vector: TVector3b; const W: Byte = 0): TVector4b; overload; inline;
function Vector4fMake(const Vector: TVector2f; const Z: Single = 0; const W: Single = 0): TVector4f; overload; inline;
function Vector4iMake(const Vector: TVector2i; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload; inline;
function Vector4sMake(const Vector: TVector2s; const Z: SmallInt = 0; const W: SmallInt = 0): TVector4s; overload; inline;
function Vector4dMake(const Vector: TVector2d; const Z: Double = 0; const W: Double = 0): TVector4d; overload; inline;
function Vector4bMake(const Vector: TVector2b; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload; inline;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorAdd(const V1, V2: TVector2f): TVector2f; overload;
function VectorAdd(const V1, V2: TAffineVector): TAffineVector; overload;
procedure VectorAdd(const V1, V2: TAffineVector; var vr: TAffineVector); overload;
procedure VectorAdd(const V1, V2: TAffineVector; vr: PAffineVector); overload;
function VectorAdd(const V1, V2: TGLVector): TGLVector; overload;
procedure VectorAdd(const V1, V2: TGLVector; var vr: TGLVector); overload;
function VectorAdd(const V: TAffineVector; const f: Single): TAffineVector; overload; inline;
function VectorAdd(const V: TGLVector; const f: Single): TGLVector; overload; inline;
procedure AddVector(var V1: TAffineVector; const V2: TAffineVector); overload;
procedure AddVector(var V1: TAffineVector; const V2: TGLVector); overload;
procedure AddVector(var V1: TGLVector; const V2: TGLVector); overload;
procedure AddVector(var V: TAffineVector; const f: Single); overload; inline;
procedure AddVector(var V: TGLVector; const f: Single); overload; inline;
procedure AddPoint(var V1: TGLVector; const V2: TGLVector); overload; inline;
function PointAdd(var V1: TGLVector; const V2: TGLVector): TGLVector; overload; inline;
procedure TexPointArrayAdd(const src: PTexPointArray; const delta: TTexPoint; const nb: Integer; dest: PTexPointArray); overload;
procedure TexPointArrayScaleAndAdd(const src: PTexPointArray; const delta: TTexPoint; const nb: Integer; const scale: TTexPoint; dest: PTexPointArray); overload;
procedure VectorArrayAdd(const src: PAffineVectorArray; const delta: TAffineVector; const nb: Integer; dest: PAffineVectorArray); overload;
function VectorSubtract(const V1, V2: TVector2f): TVector2f; overload;
procedure SubtractVector(var V1: TVector2f; const V2: TVector2f); overload;
function VectorSubtract(const V1, V2: TAffineVector): TAffineVector; overload;
procedure VectorSubtract(const V1, V2: TAffineVector; var result: TAffineVector); overload;
procedure VectorSubtract(const V1, V2: TAffineVector; var result: TGLVector); overload;
procedure VectorSubtract(const V1: TGLVector; const V2: TAffineVector; var result: TGLVector); overload;
function VectorSubtract(const V1, V2: TGLVector): TGLVector; overload;
procedure VectorSubtract(const V1, V2: TGLVector; var result: TGLVector); overload;
procedure VectorSubtract(const V1, V2: TGLVector; var result: TAffineVector); overload;
function VectorSubtract(const V1: TAffineVector; delta: Single): TAffineVector; overload; inline;
function VectorSubtract(const V1: TGLVector; delta: Single): TGLVector; overload; inline;
procedure SubtractVector(var V1: TAffineVector; const V2: TAffineVector); overload;
procedure SubtractVector(var V1: TGLVector; const V2: TGLVector); overload;
procedure CombineVector(var vr: TAffineVector; const V: TAffineVector; var f: Single); overload;
procedure CombineVector(var vr: TAffineVector; const V: TAffineVector; pf: PFloat); overload;
function TexPointCombine(const t1, t2: TTexPoint; f1, f2: Single): TTexPoint; inline;
function VectorCombine(const V1, V2: TAffineVector; const f1, f2: Single): TAffineVector; overload; inline;
function VectorCombine3(const V1, V2, V3: TAffineVector; const f1, f2, F3: Single): TAffineVector; overload; inline;
procedure VectorCombine3(const V1, V2, V3: TAffineVector; const f1, f2, F3: Single; var vr: TAffineVector); overload; inline;
procedure CombineVector(var vr: TGLVector; const V: TGLVector; var f: Single); overload;
procedure CombineVector(var vr: TGLVector; const V: TAffineVector; var f: Single); overload;
function VectorCombine(const V1, V2: TGLVector; const F1, F2: Single): TGLVector; overload; inline;
function VectorCombine(const V1: TGLVector; const V2: TAffineVector; const F1, F2: Single): TGLVector; overload; inline;
procedure VectorCombine(const V1: TGLVector; const V2: TAffineVector; const F1, F2: Single; var VR: TGLVector); overload; inline;
procedure VectorCombine(const V1, V2: TGLVector; const F1, F2: Single; var vr: TGLVector); overload;
procedure VectorCombine(const V1, V2: TGLVector; const F2: Single; var vr: TGLVector); overload;
function VectorCombine3(const V1, V2, V3: TGLVector; const F1, F2, F3: Single): TGLVector; overload; inline;
procedure VectorCombine3(const V1, V2, V3: TGLVector; const F1, F2, F3: Single; var vr: TGLVector); overload;
function VectorDotProduct(const V1, V2: TVector2f): Single; overload;
function VectorDotProduct(const V1, V2: TAffineVector): Single; overload;
function VectorDotProduct(const V1, V2: TGLVector): Single; overload;
function VectorDotProduct(const V1: TGLVector; const V2: TAffineVector): Single; overload;
function PointProject(const p, origin, direction: TAffineVector): Single; overload;
function PointProject(const p, origin, direction: TGLVector): Single; overload;
function VectorCrossProduct(const V1, V2: TAffineVector): TAffineVector; overload;
function VectorCrossProduct(const V1, V2: TGLVector): TGLVector; overload;
procedure VectorCrossProduct(const V1, V2: TGLVector; var vr: TGLVector); overload;
procedure VectorCrossProduct(const V1, V2: TAffineVector; var vr: TGLVector); overload;
procedure VectorCrossProduct(const V1, V2: TGLVector; var vr: TAffineVector); overload;
procedure VectorCrossProduct(const V1, V2: TAffineVector; var vr: TAffineVector); overload;
function Lerp(const start, stop, T: Single): Single; inline;
function AngleLerp(start, stop, T: Single): Single; inline;
function MatrixLerp(const m1, m2: TGLMatrix; const delta: Single): TGLMatrix;
function DistanceBetweenAngles(angle1, angle2: Single): Single;
function TexPointLerp(const t1, t2: TTexPoint; T: Single): TTexPoint; overload; inline;
function VectorLerp(const V1, V2: TAffineVector; T: Single): TAffineVector; overload; inline;
procedure VectorLerp(const V1, V2: TAffineVector; T: Single; var vr: TAffineVector); overload;
function VectorLerp(const V1, V2: TGLVector; T: Single): TGLVector; overload; inline;
procedure VectorLerp(const V1, V2: TGLVector; T: Single; var vr: TGLVector); overload; inline;
function VectorAngleLerp(const V1, V2: TAffineVector; T: Single): TAffineVector; overload;
function VectorAngleCombine(const V1, V2: TAffineVector; f: Single): TAffineVector; overload;
procedure VectorArrayLerp(const src1, src2: PVectorArray; T: Single; n: Integer; dest: PVectorArray); overload;
procedure VectorArrayLerp(const src1, src2: PAffineVectorArray; T: Single; n: Integer; dest: PAffineVectorArray); overload;
procedure VectorArrayLerp(const src1, src2: PTexPointArray; T: Single; n: Integer; dest: PTexPointArray); overload;
function InterpolatePower(const start, stop, delta: Single; const DistortionDegree: Single): Single;
function InterpolateLn(const start, stop, delta: Single; const DistortionDegree: Single): Single;
function InterpolateExp(const start, stop, delta: Single; const DistortionDegree: Single): Single;
function InterpolateSin(const start, stop, delta: Single): Single;
function InterpolateTan(const start, stop, delta: Single): Single;
function InterpolateSinAlt(const start, stop, delta: Single): Single;
function InterpolateCombinedFastPower(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single): Single; inline;
function InterpolateCombinedSafe(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;
function InterpolateCombinedFast(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;
function InterpolateCombined(const start, stop, delta: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;
function VectorLength(const X, Y: Single): Single; overload;
function VectorLength(const X, Y, Z: Single): Single; overload;
function VectorLength(const V: TVector2f): Single; overload;
function VectorLength(const V: TAffineVector): Single; overload;
function VectorLength(const V: TGLVector): Single; overload;
function VectorLength(const V: array of Single): Single; overload;
function VectorNorm(const X, Y: Single): Single; overload;
function VectorNorm(const V: TAffineVector): Single; overload;
function VectorNorm(const V: TGLVector): Single; overload;
function VectorNorm(var V: array of Single): Single; overload;
procedure NormalizeVector(var V: TVector2f); overload;
procedure NormalizeVector(var V: TAffineVector); overload;
procedure NormalizeVector(var V: TGLVector); overload;
function VectorNormalize(const V: TVector2f): TVector2f; overload;
function VectorNormalize(const V: TAffineVector): TAffineVector; overload;
function VectorNormalize(const V: TGLVector): TGLVector; overload;
procedure NormalizeVectorArray(list: PAffineVectorArray; n: Integer); overload; inline;
function VectorAngleCosine(const V1, V2: TAffineVector): Single; overload;
function VectorAngleCosine(const V1, V2: TGLVector): Single; overload;
function VectorNegate(const Vector: TAffineVector): TAffineVector; overload;
function VectorNegate(const Vector: TGLVector): TGLVector; overload;
procedure NegateVector(var V: TAffineVector); overload;
procedure NegateVector(var V: TGLVector); overload;
procedure NegateVector(var V: array of Single); overload;
procedure ScaleVector(var V: TVector2f; factor: Single); overload;
procedure ScaleVector(var V: TAffineVector; factor: Single); overload;
procedure ScaleVector(var V: TAffineVector; const factor: TAffineVector); overload;
procedure ScaleVector(var V: TGLVector; factor: Single); overload;
procedure ScaleVector(var V: TGLVector; const factor: TGLVector); overload;
function VectorScale(const V: TVector2f; factor: Single): TVector2f; overload;
function VectorScale(const V: TAffineVector; factor: Single): TAffineVector; overload;
procedure VectorScale(const V: TAffineVector; factor: Single; var vr: TAffineVector); overload;
function VectorScale(const V: TGLVector; factor: Single): TGLVector; overload;
procedure VectorScale(const V: TGLVector; factor: Single; var vr: TGLVector); overload;
procedure VectorScale(const V: TGLVector; factor: Single; var vr: TAffineVector); overload;
function VectorScale(const V: TAffineVector; const factor: TAffineVector): TAffineVector; overload;
function VectorScale(const V: TGLVector; const factor: TGLVector): TGLVector; overload;
procedure DivideVector(var V: TGLVector; const divider: TGLVector); overload; inline;
procedure DivideVector(var V: TAffineVector; const divider: TAffineVector); overload; inline;
function VectorDivide(const V: TGLVector; const divider: TGLVector): TGLVector; overload; inline;
function VectorDivide(const V: TAffineVector; const divider: TAffineVector): TAffineVector; overload; inline;
function TexpointEquals(const p1, p2: TTexPoint): Boolean; inline;
function RectEquals(const Rect1, Rect2: TRect): Boolean; inline;
function VectorEquals(const V1, V2: TGLVector): Boolean; overload; inline;
function VectorEquals(const V1, V2: TAffineVector): Boolean; overload; inline;
function AffineVectorEquals(const V1, V2: TGLVector): Boolean; overload; inline;
function VectorIsNull(const V: TGLVector): Boolean; overload; inline;
function VectorIsNull(const V: TAffineVector): Boolean; overload; inline;
function VectorSpacing(const V1, V2: TTexPoint): Single; overload;
function VectorSpacing(const V1, V2: TAffineVector): Single; overload;
function VectorSpacing(const V1, V2: TGLVector): Single; overload;
function VectorDistance(const V1, V2: TAffineVector): Single; overload;
function VectorDistance(const V1, V2: TGLVector): Single; overload;
function VectorDistance2(const V1, V2: TAffineVector): Single; overload;
function VectorDistance2(const V1, V2: TGLVector): Single; overload;
function VectorPerpendicular(const V, n: TAffineVector): TAffineVector;
function VectorReflect(const V, n: TAffineVector): TAffineVector;
procedure RotateVector(var Vector: TGLVector; const axis: TAffineVector; angle: Single); overload;
procedure RotateVector(var Vector: TGLVector; const axis: TGLVector; angle: Single); overload;
procedure RotateVectorAroundY(var V: TAffineVector; alpha: Single);
function VectorRotateAroundX(const V: TAffineVector; alpha: Single): TAffineVector; overload;
function VectorRotateAroundY(const V: TAffineVector; alpha: Single): TAffineVector; overload;
procedure VectorRotateAroundY(const V: TAffineVector; alpha: Single; var vr: TAffineVector); overload;
function VectorRotateAroundZ(const V: TAffineVector; alpha: Single): TAffineVector; overload;
procedure AbsVector(var V: TGLVector); overload; inline;
procedure AbsVector(var V: TAffineVector); overload; inline;
function VectorAbs(const V: TGLVector): TGLVector; overload; inline;
function VectorAbs(const V: TAffineVector): TAffineVector; overload; inline;
function IsColinear(const V1, V2: TVector2f): Boolean; overload;
function IsColinear(const V1, V2: TAffineVector): Boolean; overload;
function IsColinear(const V1, V2: TGLVector): Boolean; overload;
procedure SetMatrix(var dest: THomogeneousDblMatrix; const src: TGLMatrix); overload;
procedure SetMatrix(var dest: TAffineMatrix; const src: TGLMatrix); overload;
procedure SetMatrix(var dest: TGLMatrix; const src: TAffineMatrix); overload;
procedure SetMatrixRow(var dest: TGLMatrix; rowNb: Integer; const aRow: TGLVector); overload;
function CreateScaleMatrix(const V: TAffineVector): TGLMatrix; overload;
function CreateScaleMatrix(const V: TGLVector): TGLMatrix; overload;
function CreateTranslationMatrix(const V: TAffineVector): TGLMatrix; overload;
function CreateTranslationMatrix(const V: TGLVector): TGLMatrix; overload;
function CreateScaleAndTranslationMatrix(const scale, offset: TGLVector): TGLMatrix; overload;
function CreateRotationMatrixX(const sine, cosine: Single): TGLMatrix; overload;
function CreateRotationMatrixX(const angle: Single): TGLMatrix; overload;
function CreateRotationMatrixY(const sine, cosine: Single): TGLMatrix; overload;
function CreateRotationMatrixY(const angle: Single): TGLMatrix; overload;
function CreateRotationMatrixZ(const sine, cosine: Single): TGLMatrix; overload;
function CreateRotationMatrixZ(const angle: Single): TGLMatrix; overload;
function CreateRotationMatrix(const anAxis: TAffineVector; angle: Single): TGLMatrix; overload;
function CreateRotationMatrix(const anAxis: TGLVector; angle: Single): TGLMatrix; overload;
function CreateAffineRotationMatrix(const anAxis: TAffineVector; angle: Single): TAffineMatrix;
function MatrixMultiply(const m1, m2: TAffineMatrix): TAffineMatrix; overload;
function MatrixMultiply(const m1, m2: TGLMatrix): TGLMatrix; overload;
procedure MatrixMultiply(const m1, m2: TGLMatrix; var MResult: TGLMatrix); overload;
function VectorTransform(const V: TGLVector; const M: TGLMatrix): TGLVector; overload;
function VectorTransform(const V: TGLVector; const M: TAffineMatrix): TGLVector; overload;
function VectorTransform(const V: TAffineVector; const M: TGLMatrix): TAffineVector; overload;
function VectorTransform(const V: TAffineVector; const M: TAffineMatrix): TAffineVector; overload;
function MatrixDeterminant(const M: TAffineMatrix): Single; overload;
function MatrixDeterminant(const M: TGLMatrix): Single; overload;
procedure AdjointMatrix(var M: TGLMatrix); overload;
procedure AdjointMatrix(var M: TAffineMatrix); overload;
procedure ScaleMatrix(var M: TAffineMatrix; const factor: Single); overload;
procedure ScaleMatrix(var M: TGLMatrix; const factor: Single); overload;
procedure TranslateMatrix(var M: TGLMatrix; const V: TAffineVector); overload;
procedure TranslateMatrix(var M: TGLMatrix; const V: TGLVector); overload;
procedure NormalizeMatrix(var M: TGLMatrix);
procedure TransposeMatrix(var M: TAffineMatrix); overload;
procedure TransposeMatrix(var M: TGLMatrix); overload;
procedure InvertMatrix(var M: TGLMatrix); overload;
function MatrixInvert(const M: TGLMatrix): TGLMatrix; overload;
procedure InvertMatrix(var M: TAffineMatrix); overload;
function MatrixInvert(const M: TAffineMatrix): TAffineMatrix; overload;
function AnglePreservingMatrixInvert(const mat: TGLMatrix): TGLMatrix;
function MatrixDecompose(const M: TGLMatrix; var Tran: TTransformations): Boolean;
function CreateLookAtMatrix(const eye, center, normUp: TGLVector): TGLMatrix;
function CreateMatrixFromFrustum(Left, Right, Bottom, Top, ZNear, ZFar: Single): TGLMatrix;
function CreatePerspectiveMatrix(FOV, Aspect, ZNear, ZFar: Single): TGLMatrix;
function CreateOrthoMatrix(Left, Right, Bottom, Top, ZNear, ZFar: Single): TGLMatrix;
function CreatePickMatrix(X, Y, deltax, deltay: Single; const viewport: TVector4i): TGLMatrix;
function Project(objectVector: TGLVector; const ViewProjMatrix: TGLMatrix; const viewport: TVector4i; out WindowVector: TGLVector): Boolean;
function UnProject(WindowVector: TGLVector; ViewProjMatrix: TGLMatrix; const viewport: TVector4i; out objectVector: TGLVector): Boolean;
function PlaneMake(const p1, p2, p3: TAffineVector): THmgPlane; overload;
function PlaneMake(const p1, p2, p3: TGLVector): THmgPlane; overload;
function PlaneMake(const point, normal: TAffineVector): THmgPlane; overload;
function PlaneMake(const point, normal: TGLVector): THmgPlane; overload;
procedure SetPlane(var dest: TDoubleHmgPlane; const src: THmgPlane);
procedure NormalizePlane(var plane: THmgPlane);
function PlaneEvaluatePoint(const plane: THmgPlane; const point: TAffineVector): Single; overload;
function PlaneEvaluatePoint(const plane: THmgPlane; const point: TGLVector): Single; overload;
function CalcPlaneNormal(const p1, p2, p3: TAffineVector): TAffineVector; overload;
procedure CalcPlaneNormal(const p1, p2, p3: TAffineVector; var vr: TAffineVector); overload;
procedure CalcPlaneNormal(const p1, p2, p3: TGLVector; var vr: TAffineVector); overload;
function PointIsInHalfSpace(const point, planePoint, planeNormal: TGLVector): Boolean; overload;
function PointIsInHalfSpace(const point, planePoint, planeNormal: TAffineVector): Boolean; overload;
function PointIsInHalfSpace(const point: TAffineVector; const plane: THmgPlane): Boolean; overload;
function PointPlaneDistance(const point, planePoint, planeNormal: TGLVector): Single; overload;
function PointPlaneDistance(const point, planePoint, planeNormal: TAffineVector): Single; overload;
function PointPlaneDistance(const point: TAffineVector; const plane: THmgPlane): Single; overload;
function PointPlaneOrthoProjection(const point: TAffineVector; const plane: THmgPlane; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointPlaneProjection(const point, direction: TAffineVector; const plane: THmgPlane; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function SegmentPlaneIntersection(const ptA, ptB: TAffineVector; const plane: THmgPlane; var inter: TAffineVector): Boolean;
function PointTriangleOrthoProjection(const point, ptA, ptB, ptC: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointTriangleProjection(const point, direction, ptA, ptB, ptC: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function IsLineIntersectTriangle(const point, direction, ptA, ptB, ptC: TAffineVector): Boolean;
function PointQuadOrthoProjection(const point, ptA, ptB, ptC, ptD: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointQuadProjection(const point, direction, ptA, ptB, ptC, ptD: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function IsLineIntersectQuad(const point, direction, ptA, ptB, ptC, ptD: TAffineVector): Boolean;
function PointDiskOrthoProjection(const point, center, up: TAffineVector; const radius: Single; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointDiskProjection(const point, direction, center, up: TAffineVector; const radius: Single; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointSegmentClosestPoint(const point, segmentStart, segmentStop: TAffineVector): TAffineVector; overload;
function PointSegmentClosestPoint(const point, segmentStart, segmentStop: TGLVector): TGLVector; overload;
function PointSegmentDistance(const point, segmentStart, segmentStop: TAffineVector): Single;
function PointLineClosestPoint(const point, linePoint, lineDirection: TAffineVector): TAffineVector;
function PointLineDistance(const point, linePoint, lineDirection: TAffineVector): Single;
procedure SegmentSegmentClosestPoint(const S0Start, S0Stop, S1Start, S1Stop: TAffineVector; var Segment0Closest, Segment1Closest: TAffineVector);
function SegmentSegmentDistance(const S0Start, S0Stop, S1Start, S1Stop: TAffineVector): Single;
function LineLineDistance(const linePt0, lineDir0, linePt1, lineDir1: TAffineVector): Single;
function QuaternionMake(const Imag: array of Single; Real: Single): TQuaternion; overload;
function QuaternionMake(const X,Y,Z,W: Single): TQuaternion; overload;
function QuaternionMake(const V: TGLVector): TQuaternion; overload;
function QuaternionConjugate(const Q: TQuaternion): TQuaternion;
function QuaternionMagnitude(const Q: TQuaternion): Single;
procedure NormalizeQuaternion(var Q: TQuaternion);
function QuaternionFromPoints(const V1, V2: TAffineVector): TQuaternion;
procedure QuaternionToPoints(const Q: TQuaternion; var ArcFrom, ArcTo: TAffineVector);
function QuaternionFromMatrix(const mat: TGLMatrix): TQuaternion;
function QuaternionToMatrix(quat: TQuaternion): TGLMatrix;
function QuaternionToAffineMatrix(quat: TQuaternion): TAffineMatrix;
function QuaternionFromAngleAxis(const angle: Single; const axis: TAffineVector): TQuaternion;
function QuaternionFromRollPitchYaw(const r, p, Y: Single): TQuaternion;
function QuaternionFromEuler(const X, Y, Z: Single; eulerOrder: TEulerOrder): TQuaternion;
function QuaternionMultiply(const qL, qR: TQuaternion): TQuaternion;
function QuaternionSlerp(const QStart, QEnd: TQuaternion; Spin: Integer; T: Single): TQuaternion; overload;
function QuaternionSlerp(const source, dest: TQuaternion; const T: Single): TQuaternion; overload;
function Logarithm2(const X: Single): Single; inline;
function PowerSingle(const Base, Exponent: Single): Single; overload;
function PowerInteger(Base: Single; Exponent: Integer): Single; overload;
function PowerInt64(Base: Single; Exponent: Int64): Single; overload;
function DegToRadian(const Degrees: Extended): Extended; overload;
function DegToRadian(const Degrees: Single): Single; overload;
function RadianToDeg(const Radians: Extended): Extended; overload;
function RadianToDeg(const Radians: Single): Single; overload;
function NormalizeAngle(angle: Single): Single;
function NormalizeDegAngle(angle: Single): Single;
procedure SinCosine(const Theta: Double; out Sin, Cos: Double); overload;
procedure SinCosine(const Theta: Single; out Sin, Cos: Single); overload;
procedure SinCosine(const Theta, radius: Double; out Sin, Cos: Double); overload;
procedure SinCosine(const Theta, radius: Single; out Sin, Cos: Single); overload;
procedure PrepareSinCosCache(var S, c: array of Single; startAngle, stopAngle: Single);
function ArcCosine(const X: Extended): Extended; overload;
function FastArcTangent2(Y, X: Single): Single;
function RSqrt(V: Single): Single;
function RLength(X, Y: Single): Single;
function ISqrt(i: Integer): Integer;
function ILength(X, Y: Integer): Integer; overload;
function ILength(X, Y, Z: Integer): Integer; overload;
procedure RandomPointOnSphere(var p: TAffineVector);
function RoundInt(V: Single): Single; overload;
function RoundInt(V: Extended): Extended; overload;
function ScaleAndRound(i: Integer; var S: Single): Integer;
function SignStrict(X: Single): Integer;
function IsInRange(const X, a, b: Single): Boolean; overload;
function IsInRange(const X, a, b: Double): Boolean; overload;
function IsInCube(const p, d: TAffineVector): Boolean; overload;
function IsInCube(const p, d: TGLVector): Boolean; overload;
function MinFloat(values: PSingleArray; nbItems: Integer): Single; overload;
function MinFloat(values: PDoubleArray; nbItems: Integer): Double; overload;
function MinFloat(values: PExtendedArray; nbItems: Integer): Extended; overload;
function MinFloat(const V1, V2: Single): Single; overload;
function MinFloat(const V: array of Single): Single; overload;
function MinFloat(const V1, V2: Double): Double; overload;
function MinFloat(const V1, V2, V3: Single): Single; overload;
function MinFloat(const V1, V2, V3: Double): Double; overload;
function MaxFloat(values: PSingleArray; nbItems: Integer): Single; overload;
function MaxFloat(values: PDoubleArray; nbItems: Integer): Double; overload;
function MaxFloat(values: PExtendedArray; nbItems: Integer): Extended; overload;
function MaxFloat(const V: array of Single): Single; overload;
function MaxFloat(const V1, V2: Single): Single; overload;
function MaxFloat(const V1, V2: Double): Double; overload;
function MaxFloat(const V1, V2, V3: Single): Single; overload;
function MaxFloat(const V1, V2, V3: Double): Double; overload;
function MinInteger(const V1, V2: Integer): Integer; overload;
function MinInteger(const V1, V2: Cardinal): Cardinal; overload;
function MinInteger(const V1, V2, V3: Integer): Integer; overload;
function MinInteger(const V1, V2, V3: Cardinal): Cardinal; overload;
function MaxInteger(const V1, V2: Integer): Integer; overload;
function MaxInteger(const V1, V2: Cardinal): Cardinal; overload;
function MaxInteger(const V1, V2, V3: Integer): Integer; overload;
function MaxInteger(const V1, V2, V3: Cardinal): Cardinal; overload;
function ClampInteger(const value, min, max: Integer): Integer; overload; inline;
function ClampInteger(const value, min, max: Cardinal): Cardinal; overload; inline;
function TriangleArea(const p1, p2, p3: TAffineVector): Single; overload;
function PolygonArea(const p: PAffineVectorArray; nSides: Integer): Single; overload;
function TriangleSignedArea(const p1, p2, p3: TAffineVector): Single; overload;
function PolygonSignedArea(const p: PAffineVectorArray; nSides: Integer): Single; overload;
procedure ScaleFloatArray(values: PSingleArray; nb: Integer; var factor: Single); overload;
procedure ScaleFloatArray(var values: TSingleArray; factor: Single); overload;
procedure OffsetFloatArray(values: PSingleArray; nb: Integer; var delta: Single); overload;
procedure OffsetFloatArray(var values: array of Single; delta: Single); overload;
procedure OffsetFloatArray(valuesDest, valuesDelta: PSingleArray; nb: Integer); overload;
function MaxXYZComponent(const V: TGLVector): Single; overload;
function MaxXYZComponent(const V: TAffineVector): Single; overload;
function MinXYZComponent(const V: TGLVector): Single; overload;
function MinXYZComponent(const V: TAffineVector): Single; overload;
function MaxAbsXYZComponent(V: TGLVector): Single;
function MinAbsXYZComponent(V: TGLVector): Single;
procedure MaxVector(var V: TGLVector; const V1: TGLVector); overload;
procedure MaxVector(var V: TAffineVector; const V1: TAffineVector); overload;
procedure MinVector(var V: TGLVector; const V1: TGLVector); overload;
procedure MinVector(var V: TAffineVector; const V1: TAffineVector); overload;
procedure SortArrayAscending(var a: array of Extended);
function ClampValue(const aValue, aMin, aMax: Single): Single; overload;
function ClampValue(const aValue, aMin: Single): Single; overload;
function GeometryOptimizationMode: String;
procedure BeginFPUOnlySection;
procedure EndFPUOnlySection;
function ConvertRotation(const Angles: TAffineVector): TGLVector;
function MakeAffineDblVector(var V: array of Double): TAffineDblVector;
function MakeDblVector(var V: array of Double): THomogeneousDblVector;
function VectorAffineDblToFlt(const V: TAffineDblVector): TAffineVector;
function VectorDblToFlt(const V: THomogeneousDblVector): THomogeneousVector;
function VectorAffineFltToDbl(const V: TAffineVector): TAffineDblVector;
function VectorFltToDbl(const V: TGLVector): THomogeneousDblVector;
function PointInPolygon(const xp, yp: array of Single; X, Y: Single): Boolean;
function IsPointInPolygon(const Polygon: array of TPoint; const p: TPoint): Boolean;
procedure DivMod(Dividend: Integer; Divisor: Word; var result, Remainder: Word);
function Turn(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;
function Turn(const Matrix: TGLMatrix; const MasterUp: TAffineVector; Angle: Single): TGLMatrix; overload;
function Pitch(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;
function Pitch(const Matrix: TGLMatrix; const MasterRight: TAffineVector; Angle: Single): TGLMatrix; overload;
function Roll(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;
function Roll(const Matrix: TGLMatrix; const MasterDirection: TAffineVector; Angle: Single): TGLMatrix; overload;
function IntersectLinePlane(const point, direction: TGLVector; const plane: THmgPlane; intersectPoint: PGLVector = nil): Integer; overload;
function IntersectTriangleBox(const p1, p2, p3, aMinExtent, aMaxExtent: TAffineVector): Boolean;
function IntersectSphereBox(const SpherePos: TGLVector; const SphereRadius: Single; const BoxMatrix: TGLMatrix; const BoxScale: TAffineVector; intersectPoint: PAffineVector = nil; normal: PAffineVector = nil; depth: PSingle = nil): Boolean;
function RayCastPlaneIntersect(const rayStart, rayVector: TGLVector; const planePoint, planeNormal: TGLVector; intersectPoint: PGLVector = nil): Boolean; overload;
function RayCastPlaneXZIntersect(const rayStart, rayVector: TGLVector; const planeY: Single; intersectPoint: PGLVector = nil): Boolean; overload;
function RayCastTriangleIntersect(const rayStart, rayVector: TGLVector; const p1, p2, p3: TAffineVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; overload;
function RayCastMinDistToPoint(const rayStart, rayVector: TGLVector; const point: TGLVector): Single;
function RayCastIntersectsSphere(const rayStart, rayVector: TGLVector; const sphereCenter: TGLVector; const SphereRadius: Single): Boolean; overload;
function RayCastSphereIntersect(const rayStart, rayVector: TGLVector; const sphereCenter: TGLVector; const SphereRadius: Single; var i1, i2: TGLVector): Integer; overload;
function RayCastBoxIntersect(const rayStart, rayVector, aMinExtent, aMaxExtent: TAffineVector; intersectPoint: PAffineVector = nil): Boolean;
function RectanglesIntersect(const ACenterOfRect1, ACenterOfRect2, ASizeOfRect1, ASizeOfRect2: TVector2f): Boolean;
function RectangleContains(const ACenterOfBigRect1, ACenterOfSmallRect2, ASizeOfBigRect1, ASizeOfSmallRect2: TVector2f; const AEps: Single = 0.0): Boolean;
function SphereVisibleRadius(distance, radius: Single): Single;
function ExtractFrustumFromModelViewProjection(const modelViewProj: TGLMatrix): TFrustum;
function IsVolumeClipped(const objPos: TAffineVector; const objRadius: Single; const Frustum: TFrustum): Boolean; overload;
function IsVolumeClipped(const objPos: TGLVector; const objRadius: Single; const Frustum: TFrustum): Boolean; overload; inline;
function IsVolumeClipped(const min, max: TAffineVector; const Frustum: TFrustum): Boolean; overload; inline;
function MakeParallelProjectionMatrix(const plane: THmgPlane; const dir: TGLVector): TGLMatrix;
function MakeShadowMatrix(const planePoint, planeNormal, lightPos: TGLVector): TGLMatrix;
function MakeReflectionMatrix(const planePoint, planeNormal: TAffineVector): TGLMatrix;
function PackRotationMatrix(const mat: TGLMatrix): TPackedRotationMatrix;
function UnPackRotationMatrix(const packedMatrix: TPackedRotationMatrix): TGLMatrix;
function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TGLVector): TVector2f; overload;
function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TAffineVector): TVector2f; overload;
function MoveObjectAround(const AMovingObjectPosition, AMovingObjectUp, ATargetPosition: TGLVector; pitchDelta, turnDelta: Single): TGLVector;
function AngleBetweenVectors(const a, b, ACenterPoint: TGLVector): Single; overload;
function AngleBetweenVectors(const a, b, ACenterPoint: TAffineVector): Single; overload;
function ShiftObjectFromCenter(const AOriginalPosition: TGLVector; const ACenter: TGLVector; const ADistance: Single; const AFromCenterSpot: Boolean): TGLVector; overload;
function ShiftObjectFromCenter(const AOriginalPosition: TAffineVector; const ACenter: TAffineVector; const ADistance: Single; const AFromCenterSpot: Boolean): TAffineVector; overload;

Types

PAffineByteVector = ˆTAffineByteVector;
PAffineDblVector = ˆTAffineDblVector;
PAffineExtVector = ˆTAffineExtVector;
PAffineFltVector = ˆTAffineFltVector;
PAffineIntVector = ˆTAffineIntVector;
PAffineMatrix = ˆTAffineMatrix;
PAffinePtrVector = ˆTAffinePtrVector;
PAffineVector = ˆTAffineVector;
PAffineVectorArray = ˆTAffineVectorArray;
PAffineWordVector = ˆTAffineWordVector;
PByteArray = PByteVector;
PByteVector = ˆTByteVector;
PCardinalArray = PCardinalVector;
PCardinalVector = ˆTCardinalVector;
PDoubleArray = PDoubleVector;
PDoubleVector = ˆTDoubleVector;
PExtendedArray = PExtendedVector;
PExtendedVector = ˆTExtendedVector;
PFloat = PSingle;
PFloatArray = PFloatVector;
PFloatVector = ˆTFloatVector;
PFrustum = ˆTFrustum;
PHomogeneousByteVector = ˆTHomogeneousByteVector;
PHomogeneousDblVector = ˆTHomogeneousDblVector;
PHomogeneousExtVector = ˆTHomogeneousExtVector;
PHomogeneousFltVector = ˆTHomogeneousFltVector;
PHomogeneousIntVector = ˆTHomogeneousIntVector;
PHomogeneousMatrix = ˆTHomogeneousMatrix;
PHomogeneousPtrVector = ˆTHomogeneousPtrVector;
PHomogeneousVector = ˆTHomogeneousVector;
PHomogeneousWordVector = ˆTHomogeneousWordVector;
PIntegerArray = PIntegerVector;
PIntegerVector = ˆTIntegerVector;
PLongWordArray = PLongWordVector;
PLongWordVector = ˆTLongWordVector;
PMatrixArray = ˆTMatrixArray;
PPointerArray = PPointerVector;
PPointerVector = ˆTPointerVector;
PQuaternion = ˆTQuaternion;
PQuaternionArray = ˆTQuaternionArray;
PSingleArray = PFloatArray;
PTexPoint = ˆTTexPoint;
PTexPointArray = ˆTTexPointArray;
PVector2f = ˆTVector2f;
PVectorArray = ˆTVectorArray;
PVertex = ˆTVertex;
PWordVector = ˆTWordVector;
TAffineByteMatrix = TMatrix3b;
TAffineByteVector = TVector3b;
TAffineDblMatrix = TMatrix3d;
TAffineDblVector = TVector3d;
TAffineExtMatrix = array [0 .. 2] of TAffineExtVector;
TAffineExtVector = TVector3e;
TAffineFltMatrix = TMatrix3f;
TAffineFltVector = TVector3f;
TAffineIntMatrix = TMatrix3i;
TAffineIntVector = TVector3i;
TAffineMatrix = TAffineFltMatrix;
TAffinePtrVector = TVector3p;
TAffineVector = TVector3f;
TAffineVectorArray = array [0 .. MaxInt shr 4] of TAffineVector;
TAffineWordMatrix = array [0 .. 2] of TAffineWordVector;
TAffineWordVector = TVector3w;
TByteVector = array [0 .. cMaxArray] of Byte;
TCardinalVector = array [0 .. cMaxArray] of Cardinal;
TDoubleHmgPlane = THomogeneousDblVector;
TDoubleVector = array [0 .. cMaxArray] of Double;
TEulerOrder = (...);
TExtendedVector = array [0 .. cMaxArray] of Extended;
TFloatVector = array [0 .. cMaxArray] of Single;
TGLInterpolationType = (...);
THmgPlane = TGLVector;
THomogeneousByteMatrix = TMatrix4b;
THomogeneousByteVector = TVector4b;
THomogeneousDblMatrix = TMatrix4d;
THomogeneousDblVector = TVector4d;
THomogeneousExtMatrix = array [0 .. 3] of THomogeneousExtVector;
THomogeneousExtVector = TVector4e;
THomogeneousFltMatrix = TMatrix4f;
THomogeneousFltVector = TVector4f;
THomogeneousIntMatrix = TMatrix4i;
THomogeneousIntVector = TVector4i;
THomogeneousMatrix = THomogeneousFltMatrix;
THomogeneousPtrVector = TVector4p;
THomogeneousVector = THomogeneousFltVector;
THomogeneousWordMatrix = array [0 .. 3] of THomogeneousWordVector;
THomogeneousWordVector = TVector4w;
TIntegerVector = array [0 .. cMaxArray] of Integer;
TLongWordVector = array [0 .. cMaxArray] of LongWord;
TMatrixArray = array [0 .. MaxInt shr 7] of TGLMatrix;
TPackedRotationMatrix = array [0 .. 2] of SmallInt;
TPointerVector = array [0 .. cMaxArray] of Pointer;
TQuaternionArray = array [0 .. MaxInt shr 5] of TQuaternion;
TSingleArray = array of Single;
TTexPointArray = array [0 .. MaxInt shr 4] of TTexPoint;
TTransformations = array [TTransType] of Single;
TTransType = (...);
TVectorArray = array [0 .. MaxInt shr 5] of TGLVector;
TVertex = TAffineVector;
TWordVector = array [0 .. cMaxArray] of Word;

Constants

cMaxArray = (MaxInt shr 4);
cColinearBias = 1E-8;
XTexPoint: TTexPoint = (S: 1; T: 0);
YTexPoint: TTexPoint = (S: 0; T: 1);
XYTexPoint: TTexPoint = (S: 1; T: 1);
NullTexPoint: TTexPoint = (S: 0; T: 0);
MidTexPoint: TTexPoint = (S: 0.5; T: 0.5);
XVector: TAffineVector = (X: 1; Y: 0; Z: 0);
YVector: TAffineVector = (X: 0; Y: 1; Z: 0);
ZVector: TAffineVector = (X: 0; Y: 0; Z: 1);
XYVector: TAffineVector = (X: 1; Y: 1; Z: 0);
XZVector: TAffineVector = (X: 1; Y: 0; Z: 1);
YZVector: TAffineVector = (X: 0; Y: 1; Z: 1);
XYZVector: TAffineVector = (X: 1; Y: 1; Z: 1);
NullVector: TAffineVector = (X: 0; Y: 0; Z: 0);
MinusXVector: TAffineVector = (X: - 1; Y: 0; Z: 0);
MinusYVector: TAffineVector = (X: 0; Y: - 1; Z: 0);
MinusZVector: TAffineVector = (X: 0; Y: 0; Z: - 1);
XHmgVector: THomogeneousVector = (X: 1; Y: 0; Z: 0; W: 0);
YHmgVector: THomogeneousVector = (X: 0; Y: 1; Z: 0; W: 0);
ZHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 1; W: 0);
WHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);
XYHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 0; W: 0);
YZHmgVector: THomogeneousVector = (X: 0; Y: 1; Z: 1; W: 0);
XZHmgVector: THomogeneousVector = (X: 1; Y: 0; Z: 1; W: 0);
XYZHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 1; W: 0);
XYZWHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 1; W: 1);
NullHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 0);
XHmgPoint: THomogeneousVector = (X: 1; Y: 0; Z: 0; W: 1);
YHmgPoint: THomogeneousVector = (X: 0; Y: 1; Z: 0; W: 1);
ZHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 1; W: 1);
WHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);
NullHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);
IdentityMatrix: TAffineMatrix = (V: ((X: 1; Y: 0; Z: 0), (X: 0; Y: 1; Z: 0), (X: 0; Y: 0; Z: 1)));
IdentityHmgMatrix: TGLMatrix = (V: ((X: 1; Y: 0; Z: 0; W: 0), (X: 0; Y: 1; Z: 0; W: 0), (X: 0; Y: 0; Z: 1; W: 0), (X: 0; Y: 0; Z: 0; W: 1)));
IdentityHmgDblMatrix: THomogeneousDblMatrix = (V: ((X: 1; Y: 0; Z: 0; W: 0), (X: 0; Y: 1; Z: 0; W: 0), (X: 0; Y: 0; Z: 1; W: 0), (X: 0; Y: 0; Z: 0; W: 1)));
EmptyMatrix: TAffineMatrix = (V: ((X: 0; Y: 0; Z: 0), (X: 0; Y: 0; Z: 0), (X: 0; Y: 0; Z: 0)));
EmptyHmgMatrix: TGLMatrix = (V: ((X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0)));
IdentityQuaternion: TQuaternion = (ImagPart: (X: 0; Y: 0; Z: 0); RealPart: 1);
EPSILON: Single = 1E-40;
EPSILON2: Single = 1E-30;
cPI: Single = 3.141592654;
cPIdiv180: Single = 0.017453292;
c180divPI: Single = 57.29577951;
c2PI: Single = 6.283185307;
cPIdiv2: Single = 1.570796326;
cPIdiv4: Single = 0.785398163;
c3PIdiv2: Single = 4.71238898;
c3PIdiv4: Single = 2.35619449;
cInv2PI: Single = 1 / 6.283185307;
cInv360: Single = 1 / 360;
c180: Single = 180;
c360: Single = 360;
cOneHalf: Single = 0.5;
cLn10: Single = 2.302585093;
MinSingle = 1.5E-45;
MaxSingle = 3.4E+38;
MinDouble = 5.0E-324;
MaxDouble = 1.7E+308;
MinExtended = 3.4E-4932;
MaxExtended = MaxDouble;
MinComp = -9.223372036854775807E+18;
MaxComp = 9.223372036854775807E+18;

Variables

vSIMD: Byte = 0;

Description

Functions and Procedures

function TexPointMake(const S, T: Single): TTexPoint; inline;

————————————————————————– Vector functions ————————————————————————–

function AffineVectorMake(const X, Y, Z: Single): TAffineVector; overload; inline;

This item has no description.

function AffineVectorMake(const V: TGLVector): TAffineVector; overload; inline;

This item has no description.

procedure SetAffineVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineVector; const vSrc: TGLVector); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineVector; const vSrc: TAffineVector); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineDblVector; const vSrc: TAffineVector); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineDblVector; const vSrc: TGLVector); overload; inline;

This item has no description.

function VectorMake(const V: TAffineVector; W: Single = 0): TGLVector; overload; inline;

This item has no description.

function VectorMake(const X, Y, Z: Single; W: Single = 0): TGLVector; overload; inline;

This item has no description.

function VectorMake(const Q: TQuaternion): TGLVector; overload; inline;

This item has no description.

function PointMake(const X, Y, Z: Single): TGLVector; overload; inline;

This item has no description.

function PointMake(const V: TAffineVector): TGLVector; overload; inline;

This item has no description.

function PointMake(const V: TGLVector): TGLVector; overload; inline;

This item has no description.

procedure SetVector(out V: TGLVector; const X, Y, Z: Single; W: Single = 0); overload; inline;

This item has no description.

procedure SetVector(out V: TGLVector; const av: TAffineVector; W: Single = 0); overload; inline;

This item has no description.

procedure SetVector(out V: TGLVector; const vSrc: TGLVector); overload; inline;

This item has no description.

procedure MakePoint(out V: TGLVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure MakePoint(out V: TGLVector; const av: TAffineVector); overload; inline;

This item has no description.

procedure MakePoint(out V: TGLVector; const av: TGLVector); overload; inline;

This item has no description.

procedure MakeVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure MakeVector(out V: TGLVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure MakeVector(out V: TGLVector; const av: TAffineVector); overload; inline;

This item has no description.

procedure MakeVector(out V: TGLVector; const av: TGLVector); overload; inline;

This item has no description.

procedure RstVector(var V: TAffineVector); overload; inline;

This item has no description.

procedure RstVector(var V: TGLVector); overload; inline;

This item has no description.

function VectorEquals(const Vector1, Vector2: TVector2f): Boolean; overload; inline;

This item has no description.

function VectorEquals(const Vector1, Vector2: TVector2i): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector2d): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector2s): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector2b): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector3i): Boolean; overload; inline;

function VectorEquals(const V1, V2: TVector3f): Boolean; overload; //declared further

function VectorEquals(const V1, V2: TVector3d): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector3s): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector3b): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector4i): Boolean; overload; inline;

function VectorEquals(const V1, V2: TVector4f): Boolean; overload; //declared further

function VectorEquals(const V1, V2: TVector4d): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector4s): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector4b): Boolean; overload; inline;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix3f): Boolean; overload;

3x3

function MatrixEquals(const Matrix1, Matrix2: TMatrix3i): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix3d): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix3s): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix3b): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix4f): Boolean; overload;

4x4

function MatrixEquals(const Matrix1, Matrix2: TMatrix4i): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix4d): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix4s): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix4b): Boolean; overload;

This item has no description.

function Vector2fMake(const X, Y: Single): TVector2f; overload; inline;

2x

function Vector2iMake(const X, Y: Longint): TVector2i; overload; inline;

This item has no description.

function Vector2sMake(const X, Y: SmallInt): TVector2s; overload; inline;

This item has no description.

function Vector2dMake(const X, Y: Double): TVector2d; overload; inline;

This item has no description.

function Vector2bMake(const X, Y: Byte): TVector2b; overload; inline;

This item has no description.

function Vector2fMake(const Vector: TVector3f): TVector2f; overload; inline;

This item has no description.

function Vector2iMake(const Vector: TVector3i): TVector2i; overload; inline;

This item has no description.

function Vector2sMake(const Vector: TVector3s): TVector2s; overload; inline;

This item has no description.

function Vector2dMake(const Vector: TVector3d): TVector2d; overload; inline;

This item has no description.

function Vector2bMake(const Vector: TVector3b): TVector2b; overload; inline;

This item has no description.

function Vector2fMake(const Vector: TVector4f): TVector2f; overload; inline;

This item has no description.

function Vector2iMake(const Vector: TVector4i): TVector2i; overload; inline;

This item has no description.

function Vector2sMake(const Vector: TVector4s): TVector2s; overload; inline;

This item has no description.

function Vector2dMake(const Vector: TVector4d): TVector2d; overload; inline;

This item has no description.

function Vector2bMake(const Vector: TVector4b): TVector2b; overload; inline;

This item has no description.

function Vector3fMake(const X: Single; const Y: Single = 0; const Z: Single = 0) : TVector3f; overload; inline;

3x

function Vector3iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0): TVector3i; overload; inline;

This item has no description.

function Vector3sMake(const X: SmallInt; const Y: SmallInt = 0; const Z: SmallInt = 0): TVector3s; overload; inline;

This item has no description.

function Vector3dMake(const X: Double; const Y: Double = 0; const Z: Double = 0): TVector3d; overload; inline;

This item has no description.

function Vector3bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0): TVector3b; overload; inline;

This item has no description.

function Vector3fMake(const Vector: TVector2f; const Z: Single = 0): TVector3f; overload; inline;

This item has no description.

function Vector3iMake(const Vector: TVector2i; const Z: Longint = 0): TVector3i; overload; inline;

This item has no description.

function Vector3sMake(const Vector: TVector2s; const Z: SmallInt = 0): TVector3s; overload; inline;

This item has no description.

function Vector3dMake(const Vector: TVector2d; const Z: Double = 0): TVector3d; overload; inline;

This item has no description.

function Vector3bMake(const Vector: TVector2b; const Z: Byte = 0): TVector3b; overload; inline;

This item has no description.

function Vector3fMake(const Vector: TVector4f): TVector3f; overload; inline;

This item has no description.

function Vector3iMake(const Vector: TVector4i): TVector3i; overload; inline;

This item has no description.

function Vector3sMake(const Vector: TVector4s): TVector3s; overload; inline;

This item has no description.

function Vector3dMake(const Vector: TVector4d): TVector3d; overload; inline;

This item has no description.

function Vector3bMake(const Vector: TVector4b): TVector3b; overload; inline;

This item has no description.

function Vector4fMake(const X: Single; const Y: Single = 0; const Z: Single = 0; const W: Single = 0): TVector4f; overload; inline;

4x

function Vector4iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload; inline;

This item has no description.

function Vector4sMake(const X: SmallInt; const Y: SmallInt = 0; const Z: SmallInt = 0; const W: SmallInt = 0): TVector4s; overload; inline;

This item has no description.

function Vector4dMake(const X: Double; const Y: Double = 0; const Z: Double = 0; const W: Double = 0): TVector4d; overload; inline;

This item has no description.

function Vector4bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload; inline;

This item has no description.

function Vector4fMake(const Vector: TVector3f; const W: Single = 0): TVector4f; overload; inline;

This item has no description.

function Vector4iMake(const Vector: TVector3i; const W: Longint = 0): TVector4i; overload; inline;

This item has no description.

function Vector4sMake(const Vector: TVector3s; const W: SmallInt = 0) : TVector4s; overload; inline;

This item has no description.

function Vector4dMake(const Vector: TVector3d; const W: Double = 0): TVector4d; overload; inline;

This item has no description.

function Vector4bMake(const Vector: TVector3b; const W: Byte = 0): TVector4b; overload; inline;

This item has no description.

function Vector4fMake(const Vector: TVector2f; const Z: Single = 0; const W: Single = 0): TVector4f; overload; inline;

This item has no description.

function Vector4iMake(const Vector: TVector2i; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload; inline;

This item has no description.

function Vector4sMake(const Vector: TVector2s; const Z: SmallInt = 0; const W: SmallInt = 0): TVector4s; overload; inline;

This item has no description.

function Vector4dMake(const Vector: TVector2d; const Z: Double = 0; const W: Double = 0): TVector4d; overload; inline;

This item has no description.

function Vector4bMake(const Vector: TVector2b; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload; inline;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

Vector comparison functions: 3f

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;

4f

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;

3i

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;

4i

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;

3s

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;

4s

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;

ComparedNumber 3f

function VectorMoreEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;

4f

function VectorMoreEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;

3i

function VectorMoreEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;

4i

function VectorMoreEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;

3s

function VectorMoreEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;

4s

function VectorMoreEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorAdd(const V1, V2: TVector2f): TVector2f; overload;

This item has no description.

function VectorAdd(const V1, V2: TAffineVector): TAffineVector; overload;

Returns the sum of two affine vectors

procedure VectorAdd(const V1, V2: TAffineVector; var vr: TAffineVector); overload;

Adds two vectors and places result in vr

procedure VectorAdd(const V1, V2: TAffineVector; vr: PAffineVector); overload;

This item has no description.

function VectorAdd(const V1, V2: TGLVector): TGLVector; overload;

Returns the sum of two homogeneous vectors

procedure VectorAdd(const V1, V2: TGLVector; var vr: TGLVector); overload;

This item has no description.

function VectorAdd(const V: TAffineVector; const f: Single): TAffineVector; overload; inline;

Sums up f to each component of the vector

function VectorAdd(const V: TGLVector; const f: Single): TGLVector; overload; inline;

Sums up f to each component of the vector

procedure AddVector(var V1: TAffineVector; const V2: TAffineVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var V1: TAffineVector; const V2: TGLVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var V1: TGLVector; const V2: TGLVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var V: TAffineVector; const f: Single); overload; inline;

Sums up f to each component of the vector

procedure AddVector(var V: TGLVector; const f: Single); overload; inline;

Sums up f to each component of the vector

procedure AddPoint(var V1: TGLVector; const V2: TGLVector); overload; inline;

Adds V2 to V1, result is placed in V1. W coordinate is always 1.

function PointAdd(var V1: TGLVector; const V2: TGLVector): TGLVector; overload; inline;

Returns the sum of two homogeneous vectors. W coordinate is always 1.

procedure TexPointArrayAdd(const src: PTexPointArray; const delta: TTexPoint; const nb: Integer; dest: PTexPointArray); overload;

Adds delta to nb texpoints in src and places result in dest

procedure TexPointArrayScaleAndAdd(const src: PTexPointArray; const delta: TTexPoint; const nb: Integer; const scale: TTexPoint; dest: PTexPointArray); overload;

This item has no description.

procedure VectorArrayAdd(const src: PAffineVectorArray; const delta: TAffineVector; const nb: Integer; dest: PAffineVectorArray); overload;

Adds delta to nb vectors in src and places result in dest

function VectorSubtract(const V1, V2: TVector2f): TVector2f; overload;

Returns V1-V2

procedure SubtractVector(var V1: TVector2f; const V2: TVector2f); overload;

Subtracts V2 from V1, result is placed in V1

function VectorSubtract(const V1, V2: TAffineVector): TAffineVector; overload;

Returns V1-V2

procedure VectorSubtract(const V1, V2: TAffineVector; var result: TAffineVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const V1, V2: TAffineVector; var result: TGLVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const V1: TGLVector; const V2: TAffineVector; var result: TGLVector); overload;

Subtracts V2 from V1 and return value in result

function VectorSubtract(const V1, V2: TGLVector): TGLVector; overload;

Returns V1-V2

procedure VectorSubtract(const V1, V2: TGLVector; var result: TGLVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const V1, V2: TGLVector; var result: TAffineVector); overload;

Subtracts V2 from V1 and return value in result

function VectorSubtract(const V1: TAffineVector; delta: Single): TAffineVector; overload; inline;

This item has no description.

function VectorSubtract(const V1: TGLVector; delta: Single): TGLVector; overload; inline;

This item has no description.

procedure SubtractVector(var V1: TAffineVector; const V2: TAffineVector); overload;

Subtracts V2 from V1, result is placed in V1

procedure SubtractVector(var V1: TGLVector; const V2: TGLVector); overload;

Subtracts V2 from V1, result is placed in V1

procedure CombineVector(var vr: TAffineVector; const V: TAffineVector; var f: Single); overload;

Combine the first vector with the second : vr:=vr+v*f

procedure CombineVector(var vr: TAffineVector; const V: TAffineVector; pf: PFloat); overload;

This item has no description.

function TexPointCombine(const t1, t2: TTexPoint; f1, f2: Single): TTexPoint; inline;

Makes a linear combination of two texpoints

function VectorCombine(const V1, V2: TAffineVector; const f1, f2: Single): TAffineVector; overload; inline;

Makes a linear combination of two vectors and return the result

function VectorCombine3(const V1, V2, V3: TAffineVector; const f1, f2, F3: Single): TAffineVector; overload; inline;

Makes a linear combination of three vectors and return the result

procedure VectorCombine3(const V1, V2, V3: TAffineVector; const f1, f2, F3: Single; var vr: TAffineVector); overload; inline;

This item has no description.

procedure CombineVector(var vr: TGLVector; const V: TGLVector; var f: Single); overload;

Combine the first vector with the second : vr:=vr+v*f

procedure CombineVector(var vr: TGLVector; const V: TAffineVector; var f: Single); overload;

Combine the first vector with the second : vr:=vr+v*f

function VectorCombine(const V1, V2: TGLVector; const F1, F2: Single): TGLVector; overload; inline;

Makes a linear combination of two vectors and return the result

function VectorCombine(const V1: TGLVector; const V2: TAffineVector; const F1, F2: Single): TGLVector; overload; inline;

Makes a linear combination of two vectors and return the result

procedure VectorCombine(const V1: TGLVector; const V2: TAffineVector; const F1, F2: Single; var VR: TGLVector); overload; inline;

Makes a linear combination of two vectors and place result in vr

procedure VectorCombine(const V1, V2: TGLVector; const F1, F2: Single; var vr: TGLVector); overload;

Makes a linear combination of two vectors and place result in vr

procedure VectorCombine(const V1, V2: TGLVector; const F2: Single; var vr: TGLVector); overload;

Makes a linear combination of two vectors and place result in vr, F1=1.0

function VectorCombine3(const V1, V2, V3: TGLVector; const F1, F2, F3: Single): TGLVector; overload; inline;

Makes a linear combination of three vectors and return the result

procedure VectorCombine3(const V1, V2, V3: TGLVector; const F1, F2, F3: Single; var vr: TGLVector); overload;

Makes a linear combination of three vectors and return the result

function VectorDotProduct(const V1, V2: TVector2f): Single; overload;

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y]

function VectorDotProduct(const V1, V2: TAffineVector): Single; overload;

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function VectorDotProduct(const V1, V2: TGLVector): Single; overload;

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function VectorDotProduct(const V1: TGLVector; const V2: TAffineVector): Single; overload;

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function PointProject(const p, origin, direction: TAffineVector): Single; overload;

Projects p on the line defined by o and direction. Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line

function PointProject(const p, origin, direction: TGLVector): Single; overload;

This item has no description.

function VectorCrossProduct(const V1, V2: TAffineVector): TAffineVector; overload;

Calculates the cross product between vector 1 and 2

function VectorCrossProduct(const V1, V2: TGLVector): TGLVector; overload;

Calculates the cross product between vector 1 and 2

procedure VectorCrossProduct(const V1, V2: TGLVector; var vr: TGLVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const V1, V2: TAffineVector; var vr: TGLVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const V1, V2: TGLVector; var vr: TAffineVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const V1, V2: TAffineVector; var vr: TAffineVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

function Lerp(const start, stop, T: Single): Single; inline;

Calculates linear interpolation between start and stop at point t

function AngleLerp(start, stop, T: Single): Single; inline;

Calculates angular interpolation between start and stop at point t

function MatrixLerp(const m1, m2: TGLMatrix; const delta: Single): TGLMatrix;

This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.

function DistanceBetweenAngles(angle1, angle2: Single): Single;

Calculates the angular distance between two angles in radians. Result is in the [0; PI] range.

function TexPointLerp(const t1, t2: TTexPoint; T: Single): TTexPoint; overload; inline;

Calculates linear interpolation between texpoint1 and texpoint2 at point t

function VectorLerp(const V1, V2: TAffineVector; T: Single): TAffineVector; overload; inline;

Calculates linear interpolation between vector1 and vector2 at point t

procedure VectorLerp(const V1, V2: TAffineVector; T: Single; var vr: TAffineVector); overload;

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

function VectorLerp(const V1, V2: TGLVector; T: Single): TGLVector; overload; inline;

Calculates linear interpolation between vector1 and vector2 at point t

procedure VectorLerp(const V1, V2: TGLVector; T: Single; var vr: TGLVector); overload; inline;

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

function VectorAngleLerp(const V1, V2: TAffineVector; T: Single): TAffineVector; overload;

This item has no description.

function VectorAngleCombine(const V1, V2: TAffineVector; f: Single): TAffineVector; overload;

This item has no description.

procedure VectorArrayLerp(const src1, src2: PVectorArray; T: Single; n: Integer; dest: PVectorArray); overload;

Calculates linear interpolation between vector arrays

procedure VectorArrayLerp(const src1, src2: PAffineVectorArray; T: Single; n: Integer; dest: PAffineVectorArray); overload;

This item has no description.

procedure VectorArrayLerp(const src1, src2: PTexPointArray; T: Single; n: Integer; dest: PTexPointArray); overload;

This item has no description.

function InterpolatePower(const start, stop, delta: Single; const DistortionDegree: Single): Single;

There functions that do the same as "Lerp", but add some distortions

function InterpolateLn(const start, stop, delta: Single; const DistortionDegree: Single): Single;

This item has no description.

function InterpolateExp(const start, stop, delta: Single; const DistortionDegree: Single): Single;

This item has no description.

function InterpolateSin(const start, stop, delta: Single): Single;

Only valid where Delta belongs to [0..1]

function InterpolateTan(const start, stop, delta: Single): Single;

This item has no description.

function InterpolateSinAlt(const start, stop, delta: Single): Single;

"Alt" functions are valid everywhere

function InterpolateCombinedFastPower(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single): Single; inline;

This item has no description.

function InterpolateCombinedSafe(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;

This item has no description.

function InterpolateCombinedFast(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;

This item has no description.

function InterpolateCombined(const start, stop, delta: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;

This item has no description.

function VectorLength(const X, Y: Single): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y).

function VectorLength(const X, Y, Z: Single): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

function VectorLength(const V: TVector2f): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y).

function VectorLength(const V: TAffineVector): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

function VectorLength(const V: TGLVector): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).

function VectorLength(const V: array of Single): Single; overload;

Calculates the length of a vector following the equation: sqrt(x*x+y*y+...). Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.

function VectorNorm(const X, Y: Single): Single; overload;

Calculates norm of a vector which is defined as norm = x * x + y * y Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(const V: TAffineVector): Single; overload;

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(const V: TGLVector): Single; overload;

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(var V: array of Single): Single; overload;

Calculates norm of a vector which is defined as norm = v.X*v.X + ... Also known as "Norm 2" in the math world, this is sqr(VectorLength).

procedure NormalizeVector(var V: TVector2f); overload;

Transforms a vector to unit length

procedure NormalizeVector(var V: TAffineVector); overload;

Returns the vector transformed to unit length Transforms a vector to unit length

procedure NormalizeVector(var V: TGLVector); overload;

Transforms a vector to unit length

function VectorNormalize(const V: TVector2f): TVector2f; overload;

Returns the vector transformed to unit length

function VectorNormalize(const V: TAffineVector): TAffineVector; overload;

Returns the vector transformed to unit length

function VectorNormalize(const V: TGLVector): TGLVector; overload;

Returns the vector transformed to unit length (w component dropped)

procedure NormalizeVectorArray(list: PAffineVectorArray; n: Integer); overload; inline;

Transforms vectors to unit length

function VectorAngleCosine(const V1, V2: TAffineVector): Single; overload;

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

function VectorAngleCosine(const V1, V2: TGLVector): Single; overload;

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

function VectorNegate(const Vector: TAffineVector): TAffineVector; overload;

Negates the vector

function VectorNegate(const Vector: TGLVector): TGLVector; overload;

This item has no description.

procedure NegateVector(var V: TAffineVector); overload;

Negates the vector

procedure NegateVector(var V: TGLVector); overload;

Negates the vector

procedure NegateVector(var V: array of Single); overload;

Negates the vector

procedure ScaleVector(var V: TVector2f; factor: Single); overload;

Scales given vector by a factor

procedure ScaleVector(var V: TAffineVector; factor: Single); overload;

Scales given vector by a factor

procedure ScaleVector(var V: TAffineVector; const factor: TAffineVector); overload;

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

procedure ScaleVector(var V: TGLVector; factor: Single); overload;

Scales given vector by a factor

procedure ScaleVector(var V: TGLVector; const factor: TGLVector); overload;

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

function VectorScale(const V: TVector2f; factor: Single): TVector2f; overload;

Returns a vector scaled by a factor

function VectorScale(const V: TAffineVector; factor: Single): TAffineVector; overload;

Returns a vector scaled by a factor

procedure VectorScale(const V: TAffineVector; factor: Single; var vr: TAffineVector); overload;

Scales a vector by a factor and places result in vr

function VectorScale(const V: TGLVector; factor: Single): TGLVector; overload;

Returns a vector scaled by a factor

procedure VectorScale(const V: TGLVector; factor: Single; var vr: TGLVector); overload;

Scales a vector by a factor and places result in vr

procedure VectorScale(const V: TGLVector; factor: Single; var vr: TAffineVector); overload;

Scales a vector by a factor and places result in vr

function VectorScale(const V: TAffineVector; const factor: TAffineVector): TAffineVector; overload;

Scales given vector by another vector

function VectorScale(const V: TGLVector; const factor: TGLVector): TGLVector; overload;

RScales given vector by another vector

procedure DivideVector(var V: TGLVector; const divider: TGLVector); overload; inline;

Divides given vector by another vector. v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.

procedure DivideVector(var V: TAffineVector; const divider: TAffineVector); overload; inline;

This item has no description.

function VectorDivide(const V: TGLVector; const divider: TGLVector): TGLVector; overload; inline;

This item has no description.

function VectorDivide(const V: TAffineVector; const divider: TAffineVector): TAffineVector; overload; inline;

This item has no description.

function TexpointEquals(const p1, p2: TTexPoint): Boolean; inline;

True if all components are equal.

function RectEquals(const Rect1, Rect2: TRect): Boolean; inline;

True if all components are equal.

function VectorEquals(const V1, V2: TGLVector): Boolean; overload; inline;

True if all components are equal.

function VectorEquals(const V1, V2: TAffineVector): Boolean; overload; inline;

True if all components are equal.

function AffineVectorEquals(const V1, V2: TGLVector): Boolean; overload; inline;

True if X, Y and Z components are equal.

function VectorIsNull(const V: TGLVector): Boolean; overload; inline;

True if x=y=z=0, w ignored

function VectorIsNull(const V: TAffineVector): Boolean; overload; inline;

True if x=y=z=0, w ignored

function VectorSpacing(const V1, V2: TTexPoint): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".

function VectorSpacing(const V1, V2: TAffineVector): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".

function VectorSpacing(const V1, V2: TGLVector): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".

function VectorDistance(const V1, V2: TAffineVector): Single; overload;

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...)

function VectorDistance(const V1, V2: TGLVector): Single; overload;

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)

function VectorDistance2(const V1, V2: TAffineVector): Single; overload;

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...

function VectorDistance2(const V1, V2: TGLVector): Single; overload;

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...(w component ignored)

function VectorPerpendicular(const V, n: TAffineVector): TAffineVector;

Calculates a vector perpendicular to N. N is assumed to be of unit length, subtract out any component parallel to N

function VectorReflect(const V, n: TAffineVector): TAffineVector;

Reflects vector V against N (assumes N is normalized)

procedure RotateVector(var Vector: TGLVector; const axis: TAffineVector; angle: Single); overload;

Rotates Vector about Axis with Angle radians

procedure RotateVector(var Vector: TGLVector; const axis: TGLVector; angle: Single); overload;

Rotates Vector about Axis with Angle radians

procedure RotateVectorAroundY(var V: TAffineVector; alpha: Single);

Rotate given vector around the Y axis (alpha is in rad)

function VectorRotateAroundX(const V: TAffineVector; alpha: Single): TAffineVector; overload;

Returns given vector rotated around the X axis (alpha is in rad)

function VectorRotateAroundY(const V: TAffineVector; alpha: Single): TAffineVector; overload;

Returns given vector rotated around the Y axis (alpha is in rad)

procedure VectorRotateAroundY(const V: TAffineVector; alpha: Single; var vr: TAffineVector); overload;

Returns given vector rotated around the Y axis in vr (alpha is in rad)

function VectorRotateAroundZ(const V: TAffineVector; alpha: Single): TAffineVector; overload;

Returns given vector rotated around the Z axis (alpha is in rad)

procedure AbsVector(var V: TGLVector); overload; inline;

Vector components are replaced by their Abs() value. }

procedure AbsVector(var V: TAffineVector); overload; inline;

Vector components are replaced by their Abs() value. }

function VectorAbs(const V: TGLVector): TGLVector; overload; inline;

Returns a vector with components replaced by their Abs value. }

function VectorAbs(const V: TAffineVector): TAffineVector; overload; inline;

Returns a vector with components replaced by their Abs value. }

function IsColinear(const V1, V2: TVector2f): Boolean; overload;

Returns true if both vector are colinear

function IsColinear(const V1, V2: TAffineVector): Boolean; overload;

Returns true if both vector are colinear

function IsColinear(const V1, V2: TGLVector): Boolean; overload;

Returns true if both vector are colinear

procedure SetMatrix(var dest: THomogeneousDblMatrix; const src: TGLMatrix); overload;

—————————————————————————- Matrix functions —————————————————————————-

procedure SetMatrix(var dest: TAffineMatrix; const src: TGLMatrix); overload;

This item has no description.

procedure SetMatrix(var dest: TGLMatrix; const src: TAffineMatrix); overload;

This item has no description.

procedure SetMatrixRow(var dest: TGLMatrix; rowNb: Integer; const aRow: TGLVector); overload;

This item has no description.

function CreateScaleMatrix(const V: TAffineVector): TGLMatrix; overload;

Creates scale matrix

function CreateScaleMatrix(const V: TGLVector): TGLMatrix; overload;

Creates scale matrix

function CreateTranslationMatrix(const V: TAffineVector): TGLMatrix; overload;

Creates translation matrix

function CreateTranslationMatrix(const V: TGLVector): TGLMatrix; overload;

Creates translation matrix

function CreateScaleAndTranslationMatrix(const scale, offset: TGLVector): TGLMatrix; overload;

Creates a scale+translation matrix. Scale is applied BEFORE applying offset

function CreateRotationMatrixX(const sine, cosine: Single): TGLMatrix; overload;

Creates matrix for rotation about x-axis (angle in rad)

function CreateRotationMatrixX(const angle: Single): TGLMatrix; overload;

This item has no description.

function CreateRotationMatrixY(const sine, cosine: Single): TGLMatrix; overload;

Creates matrix for rotation about y-axis (angle in rad)

function CreateRotationMatrixY(const angle: Single): TGLMatrix; overload;

This item has no description.

function CreateRotationMatrixZ(const sine, cosine: Single): TGLMatrix; overload;

Creates matrix for rotation about z-axis (angle in rad)

function CreateRotationMatrixZ(const angle: Single): TGLMatrix; overload;

This item has no description.

function CreateRotationMatrix(const anAxis: TAffineVector; angle: Single): TGLMatrix; overload;

Creates a rotation matrix along the given Axis by the given Angle in radians.

function CreateRotationMatrix(const anAxis: TGLVector; angle: Single): TGLMatrix; overload;

This item has no description.

function CreateAffineRotationMatrix(const anAxis: TAffineVector; angle: Single): TAffineMatrix;

Creates a rotation matrix along the given Axis by the given Angle in radians.

function MatrixMultiply(const m1, m2: TAffineMatrix): TAffineMatrix; overload;

Multiplies two 3x3 matrices

function MatrixMultiply(const m1, m2: TGLMatrix): TGLMatrix; overload;

Multiplies two 4x4 matrices

procedure MatrixMultiply(const m1, m2: TGLMatrix; var MResult: TGLMatrix); overload;

Multiplies M1 by M2 and places result in MResult

function VectorTransform(const V: TGLVector; const M: TGLMatrix): TGLVector; overload;

Transforms a homogeneous vector by multiplying it with a matrix

function VectorTransform(const V: TGLVector; const M: TAffineMatrix): TGLVector; overload;

Transforms a homogeneous vector by multiplying it with a matrix

function VectorTransform(const V: TAffineVector; const M: TGLMatrix): TAffineVector; overload;

Transforms an affine vector by multiplying it with a matrix

function VectorTransform(const V: TAffineVector; const M: TAffineMatrix): TAffineVector; overload;

Transforms an affine vector by multiplying it with a matrix

function MatrixDeterminant(const M: TAffineMatrix): Single; overload;

Determinant of a 3x3 matrix

function MatrixDeterminant(const M: TGLMatrix): Single; overload;

Determinant of a 4x4 matrix

procedure AdjointMatrix(var M: TGLMatrix); overload;

Adjoint of a 4x4 matrix, used in the computation of the inverse of a 4x4 matrix

procedure AdjointMatrix(var M: TAffineMatrix); overload;

Adjoint of a 3x3 matrix, used in the computation of the inverse of a 3x3 matrix

procedure ScaleMatrix(var M: TAffineMatrix; const factor: Single); overload;

Multiplies all elements of a 3x3 matrix with a factor

procedure ScaleMatrix(var M: TGLMatrix; const factor: Single); overload;

Multiplies all elements of a 4x4 matrix with a factor

procedure TranslateMatrix(var M: TGLMatrix; const V: TAffineVector); overload;

Adds the translation vector into the matrix

procedure TranslateMatrix(var M: TGLMatrix; const V: TGLVector); overload;

This item has no description.

procedure NormalizeMatrix(var M: TGLMatrix);

Normalize the matrix and remove the translation component. The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)

procedure TransposeMatrix(var M: TAffineMatrix); overload;

Computes transpose of 3x3 matrix

procedure TransposeMatrix(var M: TGLMatrix); overload;

Computes transpose of 4x4 matrix

procedure InvertMatrix(var M: TGLMatrix); overload;

Finds the inverse of a 4x4 matrix

function MatrixInvert(const M: TGLMatrix): TGLMatrix; overload;

This item has no description.

procedure InvertMatrix(var M: TAffineMatrix); overload;

Finds the inverse of a 3x3 matrix;

function MatrixInvert(const M: TAffineMatrix): TAffineMatrix; overload;

This item has no description.

function AnglePreservingMatrixInvert(const mat: TGLMatrix): TGLMatrix;

Finds the inverse of an angle preserving matrix. Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.

function MatrixDecompose(const M: TGLMatrix; var Tran: TTransformations): Boolean;

Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it. Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan The coefficient of each transformation is returned in the corresponding element of the vector Tran. Returns true upon success, false if the matrix is singular.

function CreateLookAtMatrix(const eye, center, normUp: TGLVector): TGLMatrix;

This item has no description.

function CreateMatrixFromFrustum(Left, Right, Bottom, Top, ZNear, ZFar: Single): TGLMatrix;

This item has no description.

function CreatePerspectiveMatrix(FOV, Aspect, ZNear, ZFar: Single): TGLMatrix;

This item has no description.

function CreateOrthoMatrix(Left, Right, Bottom, Top, ZNear, ZFar: Single): TGLMatrix;

This item has no description.

function CreatePickMatrix(X, Y, deltax, deltay: Single; const viewport: TVector4i): TGLMatrix;

This item has no description.

function Project(objectVector: TGLVector; const ViewProjMatrix: TGLMatrix; const viewport: TVector4i; out WindowVector: TGLVector): Boolean;

This item has no description.

function UnProject(WindowVector: TGLVector; ViewProjMatrix: TGLMatrix; const viewport: TVector4i; out objectVector: TGLVector): Boolean;

This item has no description.

function PlaneMake(const p1, p2, p3: TAffineVector): THmgPlane; overload;

Computes the parameters of a plane defined by three points.

function PlaneMake(const p1, p2, p3: TGLVector): THmgPlane; overload;

This item has no description.

function PlaneMake(const point, normal: TAffineVector): THmgPlane; overload;

Computes the parameters of a plane defined by a point and a normal.

function PlaneMake(const point, normal: TGLVector): THmgPlane; overload;

This item has no description.

procedure SetPlane(var dest: TDoubleHmgPlane; const src: THmgPlane);

Converts from single to double representation

procedure NormalizePlane(var plane: THmgPlane);

Normalize a plane so that point evaluation = plane distance. }

function PlaneEvaluatePoint(const plane: THmgPlane; const point: TAffineVector): Single; overload;

Calculates the cross-product between the plane normal and plane to point vector. This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive. This function performs an homogeneous space dot-product.

function PlaneEvaluatePoint(const plane: THmgPlane; const point: TGLVector): Single; overload;

This item has no description.

function CalcPlaneNormal(const p1, p2, p3: TAffineVector): TAffineVector; overload;

Calculate the normal of a plane defined by three points.

procedure CalcPlaneNormal(const p1, p2, p3: TAffineVector; var vr: TAffineVector); overload;

This item has no description.

procedure CalcPlaneNormal(const p1, p2, p3: TGLVector; var vr: TAffineVector); overload;

This item has no description.

function PointIsInHalfSpace(const point, planePoint, planeNormal: TGLVector): Boolean; overload;

Returns true if point is in the half-space defined by a plane with normal. The plane itself is not considered to be in the tested halfspace.

function PointIsInHalfSpace(const point, planePoint, planeNormal: TAffineVector): Boolean; overload;

This item has no description.

function PointIsInHalfSpace(const point: TAffineVector; const plane: THmgPlane): Boolean; overload;

This item has no description.

function PointPlaneDistance(const point, planePoint, planeNormal: TGLVector): Single; overload;

Computes algebraic distance between point and plane. Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.

function PointPlaneDistance(const point, planePoint, planeNormal: TAffineVector): Single; overload;

This item has no description.

function PointPlaneDistance(const point: TAffineVector; const plane: THmgPlane): Single; overload;

This item has no description.

function PointPlaneOrthoProjection(const point: TAffineVector; const plane: THmgPlane; var inter: TAffineVector; bothface: Boolean = True): Boolean;

Computes point to plane projection. Plane and direction have to be normalized

function PointPlaneProjection(const point, direction: TAffineVector; const plane: THmgPlane; var inter: TAffineVector; bothface: Boolean = True): Boolean;

This item has no description.

function SegmentPlaneIntersection(const ptA, ptB: TAffineVector; const plane: THmgPlane; var inter: TAffineVector): Boolean;

Computes segment / plane intersection return false if there isn't an intersection

function PointTriangleOrthoProjection(const point, ptA, ptB, ptC: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;

Computes point to triangle projection. Direction has to be normalized

function PointTriangleProjection(const point, direction, ptA, ptB, ptC: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;

This item has no description.

function IsLineIntersectTriangle(const point, direction, ptA, ptB, ptC: TAffineVector): Boolean;

Returns true if line intersect ABC triangle

function PointQuadOrthoProjection(const point, ptA, ptB, ptC, ptD: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;

Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex

function PointQuadProjection(const point, direction, ptA, ptB, ptC, ptD: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;

This item has no description.

function IsLineIntersectQuad(const point, direction, ptA, ptB, ptC, ptD: TAffineVector): Boolean;

Returns true if line intersect ABCD quad. Quad have to be flat and convex

function PointDiskOrthoProjection(const point, center, up: TAffineVector; const radius: Single; var inter: TAffineVector; bothface: Boolean = True): Boolean;

Computes point to disk projection. Direction has to be normalized

function PointDiskProjection(const point, direction, center, up: TAffineVector; const radius: Single; var inter: TAffineVector; bothface: Boolean = True): Boolean;

This item has no description.

function PointSegmentClosestPoint(const point, segmentStart, segmentStop: TAffineVector): TAffineVector; overload;

Computes closest point on a segment (a segment is a limited line)

function PointSegmentClosestPoint(const point, segmentStart, segmentStop: TGLVector): TGLVector; overload;

This item has no description.

function PointSegmentDistance(const point, segmentStart, segmentStop: TAffineVector): Single;

Computes algebraic distance between segment and line (a segment is a limited line)

function PointLineClosestPoint(const point, linePoint, lineDirection: TAffineVector): TAffineVector;

Computes closest point on a line

function PointLineDistance(const point, linePoint, lineDirection: TAffineVector): Single;

Computes algebraic distance between point and line

procedure SegmentSegmentClosestPoint(const S0Start, S0Stop, S1Start, S1Stop: TAffineVector; var Segment0Closest, Segment1Closest: TAffineVector);

Computes the closest points (2) given two segments

function SegmentSegmentDistance(const S0Start, S0Stop, S1Start, S1Stop: TAffineVector): Single;

Computes the closest distance between two segments

function LineLineDistance(const linePt0, lineDir0, linePt1, lineDir1: TAffineVector): Single;

Computes the closest distance between two lines

function QuaternionMake(const Imag: array of Single; Real: Single): TQuaternion; overload;

Creates a quaternion from the given values

function QuaternionMake(const X,Y,Z,W: Single): TQuaternion; overload;

This item has no description.

function QuaternionMake(const V: TGLVector): TQuaternion; overload;

This item has no description.

function QuaternionConjugate(const Q: TQuaternion): TQuaternion;

Returns the conjugate of a quaternion

function QuaternionMagnitude(const Q: TQuaternion): Single;

Returns the magnitude of the quaternion

procedure NormalizeQuaternion(var Q: TQuaternion);

Normalizes the given quaternion

function QuaternionFromPoints(const V1, V2: TAffineVector): TQuaternion;

Constructs a unit quaternion from two points on unit sphere

procedure QuaternionToPoints(const Q: TQuaternion; var ArcFrom, ArcTo: TAffineVector);

Converts a unit quaternion into two points on a unit sphere

function QuaternionFromMatrix(const mat: TGLMatrix): TQuaternion;

Constructs a unit quaternion from a rotation matrix

function QuaternionToMatrix(quat: TQuaternion): TGLMatrix;

Constructs a rotation matrix from (possibly non-unit) quaternion. Assumes matrix is used to multiply column vector on the left: vnew = mat vold. Works correctly for right-handed coordinate system and right-handed rotations

function QuaternionToAffineMatrix(quat: TQuaternion): TAffineMatrix;

Constructs an affine rotation matrix from (possibly non-unit) quaternion

function QuaternionFromAngleAxis(const angle: Single; const axis: TAffineVector): TQuaternion;

Constructs quaternion from angle (in deg) and axis

function QuaternionFromRollPitchYaw(const r, p, Y: Single): TQuaternion;

Constructs quaternion from Euler angles

function QuaternionFromEuler(const X, Y, Z: Single; eulerOrder: TEulerOrder): TQuaternion;

Constructs quaternion from Euler angles in arbitrary order (angles in degrees)

function QuaternionMultiply(const qL, qR: TQuaternion): TQuaternion;

Returns quaternion product qL * qR. Note: order is important! To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond

function QuaternionSlerp(const QStart, QEnd: TQuaternion; Spin: Integer; T: Single): TQuaternion; overload;

Spherical linear interpolation of unit quaternions with spins. QStart, QEnd - start and end unit quaternions t - interpolation parameter (0 to 1) Spin - number of extra spin rotations to involve

function QuaternionSlerp(const source, dest: TQuaternion; const T: Single): TQuaternion; overload;

This item has no description.

function Logarithm2(const X: Single): Single; inline;

—————————————————————————- Exponential functions —————————————————————————–

function PowerSingle(const Base, Exponent: Single): Single; overload;

Raise base to any power. For fractional exponents, or |exponents| > MaxInt, base must be > 0

function PowerInteger(Base: Single; Exponent: Integer): Single; overload;

Raise base to an integer

function PowerInt64(Base: Single; Exponent: Int64): Single; overload;

This item has no description.

function DegToRadian(const Degrees: Extended): Extended; overload;

—————————————————————————- Trigonometric functions —————————————————————————-

function DegToRadian(const Degrees: Single): Single; overload;

This item has no description.

function RadianToDeg(const Radians: Extended): Extended; overload;

This item has no description.

function RadianToDeg(const Radians: Single): Single; overload;

This item has no description.

function NormalizeAngle(angle: Single): Single;

Normalize to an angle in the [-PI; +PI] range

function NormalizeDegAngle(angle: Single): Single;

Normalize to an angle in the [-180; 180] range

procedure SinCosine(const Theta: Double; out Sin, Cos: Double); overload;

Calculates sine and cosine from the given angle Theta

procedure SinCosine(const Theta: Single; out Sin, Cos: Single); overload;

Calculates sine and cosine from the given angle Theta

procedure SinCosine(const Theta, radius: Double; out Sin, Cos: Double); overload;

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius

procedure SinCosine(const Theta, radius: Single; out Sin, Cos: Single); overload;

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius

procedure PrepareSinCosCache(var S, c: array of Single; startAngle, stopAngle: Single);

Fills up the two given dynamic arrays with sin cos values. start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.

function ArcCosine(const X: Extended): Extended; overload;

This item has no description.

function FastArcTangent2(Y, X: Single): Single;

Fast ArcTangent2 approximation, about 0.07 rads accuracy

function RSqrt(V: Single): Single;

—————————————————————————— Miscellanious math functions —————————————————————————— Computes 1/Sqrt(v)

function RLength(X, Y: Single): Single;

Computes 1/Sqrt(Sqr(x)+Sqr(y)).

function ISqrt(i: Integer): Integer;

Computes an integer sqrt approximation

function ILength(X, Y: Integer): Integer; overload;

Computes an integer length Result:=Sqrt(x*x+y*y)

function ILength(X, Y, Z: Integer): Integer; overload;

This item has no description.

procedure RandomPointOnSphere(var p: TAffineVector);

Generates a random point on the unit sphere. Point repartition is correctly isotropic with no privilegied direction

function RoundInt(V: Single): Single; overload;

Rounds the floating point value to the closest integer. Behaves like Round but returns a floating point value like Int.

function RoundInt(V: Extended): Extended; overload;

This item has no description.

function ScaleAndRound(i: Integer; var S: Single): Integer;

Multiples i by s and returns the rounded result.

function SignStrict(X: Single): Integer;

Returns the sign of the x value using the (-1, 0, +1) convention

function IsInRange(const X, a, b: Single): Boolean; overload;

Returns True if x is in [a; b]

function IsInRange(const X, a, b: Double): Boolean; overload;

This item has no description.

function IsInCube(const p, d: TAffineVector): Boolean; overload;

Returns True if p is in the cube defined by d.

function IsInCube(const p, d: TGLVector): Boolean; overload;

This item has no description.

function MinFloat(values: PSingleArray; nbItems: Integer): Single; overload;

Returns the minimum value of the array.

function MinFloat(values: PDoubleArray; nbItems: Integer): Double; overload;

This item has no description.

function MinFloat(values: PExtendedArray; nbItems: Integer): Extended; overload;

This item has no description.

function MinFloat(const V1, V2: Single): Single; overload;

Returns the minimum of given values.

function MinFloat(const V: array of Single): Single; overload;

This item has no description.

function MinFloat(const V1, V2: Double): Double; overload;

This item has no description.

function MinFloat(const V1, V2, V3: Single): Single; overload;

This item has no description.

function MinFloat(const V1, V2, V3: Double): Double; overload;

This item has no description.

function MaxFloat(values: PSingleArray; nbItems: Integer): Single; overload;

Returns the maximum value of the array.

function MaxFloat(values: PDoubleArray; nbItems: Integer): Double; overload;

This item has no description.

function MaxFloat(values: PExtendedArray; nbItems: Integer): Extended; overload;

This item has no description.

function MaxFloat(const V: array of Single): Single; overload;

This item has no description.

function MaxFloat(const V1, V2: Single): Single; overload;

Returns the maximum of given values.

function MaxFloat(const V1, V2: Double): Double; overload;

This item has no description.

function MaxFloat(const V1, V2, V3: Single): Single; overload;

This item has no description.

function MaxFloat(const V1, V2, V3: Double): Double; overload;

This item has no description.

function MinInteger(const V1, V2: Integer): Integer; overload;

This item has no description.

function MinInteger(const V1, V2: Cardinal): Cardinal; overload;

This item has no description.

function MinInteger(const V1, V2, V3: Integer): Integer; overload;

This item has no description.

function MinInteger(const V1, V2, V3: Cardinal): Cardinal; overload;

This item has no description.

function MaxInteger(const V1, V2: Integer): Integer; overload;

This item has no description.

function MaxInteger(const V1, V2: Cardinal): Cardinal; overload;

This item has no description.

function MaxInteger(const V1, V2, V3: Integer): Integer; overload;

This item has no description.

function MaxInteger(const V1, V2, V3: Cardinal): Cardinal; overload;

This item has no description.

function ClampInteger(const value, min, max: Integer): Integer; overload; inline;

This item has no description.

function ClampInteger(const value, min, max: Cardinal): Cardinal; overload; inline;

This item has no description.

function TriangleArea(const p1, p2, p3: TAffineVector): Single; overload;

Computes the triangle's area

function PolygonArea(const p: PAffineVectorArray; nSides: Integer): Single; overload;

Computes the polygons's area. Points must be coplanar. Polygon needs not be convex

function TriangleSignedArea(const p1, p2, p3: TAffineVector): Single; overload;

Computes a 2D triangle's signed area. Only X and Y coordinates are used, Z is ignored

function PolygonSignedArea(const p: PAffineVectorArray; nSides: Integer): Single; overload;

Computes a 2D polygon's signed area. Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex

procedure ScaleFloatArray(values: PSingleArray; nb: Integer; var factor: Single); overload;

Multiplies values in the array by factor. This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items. Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available

procedure ScaleFloatArray(var values: TSingleArray; factor: Single); overload;

This item has no description.

procedure OffsetFloatArray(values: PSingleArray; nb: Integer; var delta: Single); overload;

Adds delta to values in the array. Array size must be a multiple of four

procedure OffsetFloatArray(var values: array of Single; delta: Single); overload;

This item has no description.

procedure OffsetFloatArray(valuesDest, valuesDelta: PSingleArray; nb: Integer); overload;

This item has no description.

function MaxXYZComponent(const V: TGLVector): Single; overload;

Returns the max of the X, Y and Z components of a vector (W is ignored)

function MaxXYZComponent(const V: TAffineVector): Single; overload;

This item has no description.

function MinXYZComponent(const V: TGLVector): Single; overload;

Returns the min of the X, Y and Z components of a vector (W is ignored)

function MinXYZComponent(const V: TAffineVector): Single; overload;

This item has no description.

function MaxAbsXYZComponent(V: TGLVector): Single;

Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)

function MinAbsXYZComponent(V: TGLVector): Single;

Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)

procedure MaxVector(var V: TGLVector; const V1: TGLVector); overload;

Replace components of v with the max of v or v1 component. Maximum is computed per component

procedure MaxVector(var V: TAffineVector; const V1: TAffineVector); overload;

This item has no description.

procedure MinVector(var V: TGLVector; const V1: TGLVector); overload;

Replace components of v with the min of v or v1 component. Minimum is computed per component

procedure MinVector(var V: TAffineVector; const V1: TAffineVector); overload;

This item has no description.

procedure SortArrayAscending(var a: array of Extended);

Sorts given array in ascending order. NOTE : current implementation is a slow bubble sort...

function ClampValue(const aValue, aMin, aMax: Single): Single; overload;

Clamps aValue in the aMin-aMax interval

function ClampValue(const aValue, aMin: Single): Single; overload;

Clamps aValue in the aMin-INF interval

function GeometryOptimizationMode: String;

Returns the detected optimization mode. Returned values is either 'FPU', '3DNow!' or 'SSE'

procedure BeginFPUOnlySection;

Begins a FPU-only section. You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases. Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).

procedure EndFPUOnlySection;

Ends a FPU-only section. See BeginFPUOnlySection

function ConvertRotation(const Angles: TAffineVector): TGLVector;

Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians)

function MakeAffineDblVector(var V: array of Double): TAffineDblVector;

Miscellaneous functions

function MakeDblVector(var V: array of Double): THomogeneousDblVector;

This item has no description.

function VectorAffineDblToFlt(const V: TAffineDblVector): TAffineVector;

Converts a vector containing double sized values into a vector with single sized values

function VectorDblToFlt(const V: THomogeneousDblVector): THomogeneousVector;

Converts a vector containing double sized values into a vector with single sized values

function VectorAffineFltToDbl(const V: TAffineVector): TAffineDblVector;

Converts a vector containing single sized values into a vector with double sized values

function VectorFltToDbl(const V: TGLVector): THomogeneousDblVector;

Converts a vector containing single sized values into a vector with double sized values

function PointInPolygon(const xp, yp: array of Single; X, Y: Single): Boolean;

The code below is from Wm. Randolph Franklin <wrf@ecse.rpi.edu> with some minor modifications for speed. It returns 1 for strictly interior points, 0 for strictly exterior, and 0 or 1 for points on the boundary

function IsPointInPolygon(const Polygon: array of TPoint; const p: TPoint): Boolean;

PtInRegion

procedure DivMod(Dividend: Integer; Divisor: Word; var result, Remainder: Word);

This item has no description.

function Turn(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;

Coordinate system manipulation functions Rotates the given coordinate system (represented by the matrix) around its Y-axis

function Turn(const Matrix: TGLMatrix; const MasterUp: TAffineVector; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterUp

function Pitch(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around its X-axis

function Pitch(const Matrix: TGLMatrix; const MasterRight: TAffineVector; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterRight

function Roll(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around its Z-axis

function Roll(const Matrix: TGLMatrix; const MasterDirection: TAffineVector; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterDirection

function IntersectLinePlane(const point, direction: TGLVector; const plane: THmgPlane; intersectPoint: PGLVector = nil): Integer; overload;

Compute the intersection point "res" of a line with a plane. Return value: 0 : no intersection, line parallel to plane 1 : res is valid -1 : line is inside plane Adapted from: E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988

function IntersectTriangleBox(const p1, p2, p3, aMinExtent, aMaxExtent: TAffineVector): Boolean;

Compute intersection between a triangle and a box. Returns True if an intersection was found

function IntersectSphereBox(const SpherePos: TGLVector; const SphereRadius: Single; const BoxMatrix: TGLMatrix; const BoxScale: TAffineVector; intersectPoint: PAffineVector = nil; normal: PAffineVector = nil; depth: PSingle = nil): Boolean;

Compute intersection between a Sphere and a box. Up, Direction and Right must be normalized! Use CubDepth, CubeHeight and CubeWidth to scale TGLCube

function RayCastPlaneIntersect(const rayStart, rayVector: TGLVector; const planePoint, planeNormal: TGLVector; intersectPoint: PGLVector = nil): Boolean; overload;

Compute intersection between a ray and a plane. Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil

function RayCastPlaneXZIntersect(const rayStart, rayVector: TGLVector; const planeY: Single; intersectPoint: PGLVector = nil): Boolean; overload;

This item has no description.

function RayCastTriangleIntersect(const rayStart, rayVector: TGLVector; const p1, p2, p3: TAffineVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; overload;

Compute intersection between a ray and a triangle

function RayCastMinDistToPoint(const rayStart, rayVector: TGLVector; const point: TGLVector): Single;

Compute the min distance a ray will pass to a point

function RayCastIntersectsSphere(const rayStart, rayVector: TGLVector; const sphereCenter: TGLVector; const SphereRadius: Single): Boolean; overload;

Determines if a ray will intersect with a given sphere

function RayCastSphereIntersect(const rayStart, rayVector: TGLVector; const sphereCenter: TGLVector; const SphereRadius: Single; var i1, i2: TGLVector): Integer; overload;

Calculates the intersections between a sphere and a ray. Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined)

function RayCastBoxIntersect(const rayStart, rayVector, aMinExtent, aMaxExtent: TAffineVector; intersectPoint: PAffineVector = nil): Boolean;

Compute intersection between a ray and a box. Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil

function RectanglesIntersect(const ACenterOfRect1, ACenterOfRect2, ASizeOfRect1, ASizeOfRect2: TVector2f): Boolean;

Determine if 2 rectanges intersect

function RectangleContains(const ACenterOfBigRect1, ACenterOfSmallRect2, ASizeOfBigRect1, ASizeOfSmallRect2: TVector2f; const AEps: Single = 0.0): Boolean;

Determine if BigRect completely contains SmallRect

function SphereVisibleRadius(distance, radius: Single): Single;

Computes the visible radius of a sphere in a perspective projection. This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.

function ExtractFrustumFromModelViewProjection(const modelViewProj: TGLMatrix): TFrustum;

Extracts a TFrustum for combined modelview and projection matrices

function IsVolumeClipped(const objPos: TAffineVector; const objRadius: Single; const Frustum: TFrustum): Boolean; overload;

Determines if volume is clipped or not

function IsVolumeClipped(const objPos: TGLVector; const objRadius: Single; const Frustum: TFrustum): Boolean; overload; inline;

This item has no description.

function IsVolumeClipped(const min, max: TAffineVector; const Frustum: TFrustum): Boolean; overload; inline;

This item has no description.

function MakeParallelProjectionMatrix(const plane: THmgPlane; const dir: TGLVector): TGLMatrix;

Creates a parallel projection matrix. Transformed points will projected on the plane along the specified direction

function MakeShadowMatrix(const planePoint, planeNormal, lightPos: TGLVector): TGLMatrix;

Creates a shadow projection matrix. Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos

function MakeReflectionMatrix(const planePoint, planeNormal: TAffineVector): TGLMatrix;

Builds a reflection matrix for the given plane. Reflection matrix allow implementing planar reflectors (mirrors)

function PackRotationMatrix(const mat: TGLMatrix): TPackedRotationMatrix;

Packs an homogeneous rotation matrix to 6 bytes. The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each. Deviation is typically below 0.01% and around 0.1% in worst case situations. Note: quaternion conversion is faster and more robust than an angle decomposition

function UnPackRotationMatrix(const packedMatrix: TPackedRotationMatrix): TGLMatrix;

Restores a packed rotation matrix. See PackRotationMatrix

function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TGLVector): TVector2f; overload;

Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles

function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TAffineVector): TVector2f; overload;

This item has no description.

function MoveObjectAround(const AMovingObjectPosition, AMovingObjectUp, ATargetPosition: TGLVector; pitchDelta, turnDelta: Single): TGLVector;

Extracted from Camera.MoveAroundTarget(pitch, turn)

function AngleBetweenVectors(const a, b, ACenterPoint: TGLVector): Single; overload;

Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians

function AngleBetweenVectors(const a, b, ACenterPoint: TAffineVector): Single; overload;

This item has no description.

function ShiftObjectFromCenter(const AOriginalPosition: TGLVector; const ACenter: TGLVector; const ADistance: Single; const AFromCenterSpot: Boolean): TGLVector; overload;

AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced. ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center

function ShiftObjectFromCenter(const AOriginalPosition: TAffineVector; const ACenter: TAffineVector; const ADistance: Single; const AFromCenterSpot: Boolean): TAffineVector; overload;

This item has no description.

Types

PAffineByteVector = ˆTAffineByteVector;

This item has no description.

PAffineDblVector = ˆTAffineDblVector;

This item has no description.

PAffineExtVector = ˆTAffineExtVector;

This item has no description.

PAffineFltVector = ˆTAffineFltVector;

This item has no description.

PAffineIntVector = ˆTAffineIntVector;

This item has no description.

PAffineMatrix = ˆTAffineMatrix;

This item has no description.

PAffinePtrVector = ˆTAffinePtrVector;

This item has no description.

PAffineVector = ˆTAffineVector;

This item has no description.

PAffineVectorArray = ˆTAffineVectorArray;

Arrays of vectors

PAffineWordVector = ˆTAffineWordVector;

This item has no description.

PByteArray = PByteVector;

This item has no description.

PByteVector = ˆTByteVector;

Types to specify continous streams of a specific type switch off range checking to access values beyond the limits

PCardinalArray = PCardinalVector;

This item has no description.

PCardinalVector = ˆTCardinalVector;

This item has no description.

PDoubleArray = PDoubleVector;

This item has no description.

PDoubleVector = ˆTDoubleVector;

This item has no description.

PExtendedArray = PExtendedVector;

This item has no description.

PExtendedVector = ˆTExtendedVector;

This item has no description.

PFloat = PSingle;

Data types needed for 3D graphics calculation, included are 'C like' aliases for each type (to be conformal with OpenGL types)

PFloatArray = PFloatVector;

This item has no description.

PFloatVector = ˆTFloatVector;

This item has no description.

PFrustum = ˆTFrustum;

This item has no description.

PHomogeneousByteVector = ˆTHomogeneousByteVector;

Common vector and matrix types with predefined limits indices correspond like: x -> 0 y -> 1 z -> 2 w -> 3

PHomogeneousDblVector = ˆTHomogeneousDblVector;

This item has no description.

PHomogeneousExtVector = ˆTHomogeneousExtVector;

This item has no description.

PHomogeneousFltVector = ˆTHomogeneousFltVector;

This item has no description.

PHomogeneousIntVector = ˆTHomogeneousIntVector;

This item has no description.

PHomogeneousMatrix = ˆTHomogeneousMatrix;

This item has no description.

PHomogeneousPtrVector = ˆTHomogeneousPtrVector;

This item has no description.

PHomogeneousVector = ˆTHomogeneousVector;

some simplified names

PHomogeneousWordVector = ˆTHomogeneousWordVector;

This item has no description.

PIntegerArray = PIntegerVector;

This item has no description.

PIntegerVector = ˆTIntegerVector;

This item has no description.

PLongWordArray = PLongWordVector;

This item has no description.

PLongWordVector = ˆTLongWordVector;

This item has no description.

PMatrixArray = ˆTMatrixArray;

This item has no description.

PPointerArray = PPointerVector;

This item has no description.

PPointerVector = ˆTPointerVector;

This item has no description.

PQuaternion = ˆTQuaternion;

q = ([x, y, z], w)

PQuaternionArray = ˆTQuaternionArray;

This item has no description.

PSingleArray = PFloatArray;

This item has no description.

PTexPoint = ˆTTexPoint;

This item has no description.

PTexPointArray = ˆTTexPointArray;

This item has no description.

PVector2f = ˆTVector2f;

This item has no description.

PVectorArray = ˆTVectorArray;

This item has no description.

PVertex = ˆTVertex;

This item has no description.

PWordVector = ˆTWordVector;

This item has no description.

TAffineByteMatrix = TMatrix3b;

This item has no description.

TAffineByteVector = TVector3b;

This item has no description.

TAffineDblMatrix = TMatrix3d;

This item has no description.

TAffineDblVector = TVector3d;

This item has no description.

TAffineExtMatrix = array [0 .. 2] of TAffineExtVector;

This item has no description.

TAffineExtVector = TVector3e;

This item has no description.

TAffineFltMatrix = TMatrix3f;

This item has no description.

TAffineFltVector = TVector3f;

This item has no description.

TAffineIntMatrix = TMatrix3i;

This item has no description.

TAffineIntVector = TVector3i;

This item has no description.

TAffineMatrix = TAffineFltMatrix;

This item has no description.

TAffinePtrVector = TVector3p;

This item has no description.

TAffineVector = TVector3f;

This item has no description.

TAffineVectorArray = array [0 .. MaxInt shr 4] of TAffineVector;

This item has no description.

TAffineWordMatrix = array [0 .. 2] of TAffineWordVector;

This item has no description.

TAffineWordVector = TVector3w;

This item has no description.

TByteVector = array [0 .. cMaxArray] of Byte;

This item has no description.

TCardinalVector = array [0 .. cMaxArray] of Cardinal;

This item has no description.

TDoubleHmgPlane = THomogeneousDblVector;

This item has no description.

TDoubleVector = array [0 .. cMaxArray] of Double;

This item has no description.

TEulerOrder = (...);

—————————————————————————- Quaternion functions —————————————————————————-

Values
  • eulXYZ
  • eulXZY
  • eulYXZ
  • eulYZX
  • eulZXY
  • eulZYX
TExtendedVector = array [0 .. cMaxArray] of Extended;

This item has no description.

TFloatVector = array [0 .. cMaxArray] of Single;

This item has no description.

TGLInterpolationType = (...);

This item has no description.

Values
  • itLinear
  • itPower
  • itSin
  • itSinAlt
  • itTan
  • itLn
  • itExp
THmgPlane = TGLVector;

A plane equation. Defined by its equation A.x+B.y+C.z+D , a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here. The typename is just here for easing up data manipulation

THomogeneousByteMatrix = TMatrix4b;

Matrices

THomogeneousByteVector = TVector4b;

This item has no description.

THomogeneousDblMatrix = TMatrix4d;

This item has no description.

THomogeneousDblVector = TVector4d;

This item has no description.

THomogeneousExtMatrix = array [0 .. 3] of THomogeneousExtVector;

This item has no description.

THomogeneousExtVector = TVector4e;

This item has no description.

THomogeneousFltMatrix = TMatrix4f;

This item has no description.

THomogeneousFltVector = TVector4f;

This item has no description.

THomogeneousIntMatrix = TMatrix4i;

This item has no description.

THomogeneousIntVector = TVector4i;

This item has no description.

THomogeneousMatrix = THomogeneousFltMatrix;

This item has no description.

THomogeneousPtrVector = TVector4p;

This item has no description.

THomogeneousVector = THomogeneousFltVector;

This item has no description.

THomogeneousWordMatrix = array [0 .. 3] of THomogeneousWordVector;

This item has no description.

THomogeneousWordVector = TVector4w;

This item has no description.

TIntegerVector = array [0 .. cMaxArray] of Integer;

This item has no description.

TLongWordVector = array [0 .. cMaxArray] of LongWord;

This item has no description.

TMatrixArray = array [0 .. MaxInt shr 7] of TGLMatrix;

Some simplified names

TPackedRotationMatrix = array [0 .. 2] of SmallInt;

This item has no description.

TPointerVector = array [0 .. cMaxArray] of Pointer;

This item has no description.

TQuaternionArray = array [0 .. MaxInt shr 5] of TQuaternion;

This item has no description.

TSingleArray = array of Single;

This item has no description.

TTexPointArray = array [0 .. MaxInt shr 4] of TTexPoint;

This item has no description.

TTransformations = array [TTransType] of Single;

Used to describe a sequence of transformations in following order: [Sx][Sy][Sz][ShearXY][ShearXZ][ShearZY][Rx][Ry][Rz][Tx][Ty][Tz][P(x,y,z,w)] constants are declared for easier access (see MatrixDecompose below)

TTransType = (...);

This item has no description.

Values
  • ttScaleX
  • ttScaleY
  • ttScaleZ
  • ttShearXY
  • ttShearXZ
  • ttShearYZ
  • ttRotateX
  • ttRotateY
  • ttRotateZ
  • ttTranslateX
  • ttTranslateY
  • ttTranslateZ
  • ttPerspectiveX
  • ttPerspectiveY
  • ttPerspectiveZ
  • ttPerspectiveW
TVectorArray = array [0 .. MaxInt shr 5] of TGLVector;

This item has no description.

TVertex = TAffineVector;

This item has no description.

TWordVector = array [0 .. cMaxArray] of Word;

This item has no description.

Constants

cMaxArray = (MaxInt shr 4);

This item has no description.

cColinearBias = 1E-8;

This item has no description.

XTexPoint: TTexPoint = (S: 1; T: 0);

TexPoints (2D space)

YTexPoint: TTexPoint = (S: 0; T: 1);

This item has no description.

XYTexPoint: TTexPoint = (S: 1; T: 1);

This item has no description.

NullTexPoint: TTexPoint = (S: 0; T: 0);

This item has no description.

MidTexPoint: TTexPoint = (S: 0.5; T: 0.5);

This item has no description.

XVector: TAffineVector = (X: 1; Y: 0; Z: 0);

standard vectors

YVector: TAffineVector = (X: 0; Y: 1; Z: 0);

This item has no description.

ZVector: TAffineVector = (X: 0; Y: 0; Z: 1);

This item has no description.

XYVector: TAffineVector = (X: 1; Y: 1; Z: 0);

This item has no description.

XZVector: TAffineVector = (X: 1; Y: 0; Z: 1);

This item has no description.

YZVector: TAffineVector = (X: 0; Y: 1; Z: 1);

This item has no description.

XYZVector: TAffineVector = (X: 1; Y: 1; Z: 1);

This item has no description.

NullVector: TAffineVector = (X: 0; Y: 0; Z: 0);

This item has no description.

MinusXVector: TAffineVector = (X: - 1; Y: 0; Z: 0);

This item has no description.

MinusYVector: TAffineVector = (X: 0; Y: - 1; Z: 0);

This item has no description.

MinusZVector: TAffineVector = (X: 0; Y: 0; Z: - 1);

This item has no description.

XHmgVector: THomogeneousVector = (X: 1; Y: 0; Z: 0; W: 0);

Standard homogeneous vectors

YHmgVector: THomogeneousVector = (X: 0; Y: 1; Z: 0; W: 0);

This item has no description.

ZHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 1; W: 0);

This item has no description.

WHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);

This item has no description.

XYHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 0; W: 0);

This item has no description.

YZHmgVector: THomogeneousVector = (X: 0; Y: 1; Z: 1; W: 0);

This item has no description.

XZHmgVector: THomogeneousVector = (X: 1; Y: 0; Z: 1; W: 0);

This item has no description.

XYZHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 1; W: 0);

This item has no description.

XYZWHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 1; W: 1);

This item has no description.

NullHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 0);

This item has no description.

XHmgPoint: THomogeneousVector = (X: 1; Y: 0; Z: 0; W: 1);

Standard homogeneous points

YHmgPoint: THomogeneousVector = (X: 0; Y: 1; Z: 0; W: 1);

This item has no description.

ZHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 1; W: 1);

This item has no description.

WHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);

This item has no description.

NullHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);

This item has no description.

IdentityMatrix: TAffineMatrix = (V: ((X: 1; Y: 0; Z: 0), (X: 0; Y: 1; Z: 0), (X: 0; Y: 0; Z: 1)));

This item has no description.

IdentityHmgMatrix: TGLMatrix = (V: ((X: 1; Y: 0; Z: 0; W: 0), (X: 0; Y: 1; Z: 0; W: 0), (X: 0; Y: 0; Z: 1; W: 0), (X: 0; Y: 0; Z: 0; W: 1)));

This item has no description.

IdentityHmgDblMatrix: THomogeneousDblMatrix = (V: ((X: 1; Y: 0; Z: 0; W: 0), (X: 0; Y: 1; Z: 0; W: 0), (X: 0; Y: 0; Z: 1; W: 0), (X: 0; Y: 0; Z: 0; W: 1)));

This item has no description.

EmptyMatrix: TAffineMatrix = (V: ((X: 0; Y: 0; Z: 0), (X: 0; Y: 0; Z: 0), (X: 0; Y: 0; Z: 0)));

This item has no description.

EmptyHmgMatrix: TGLMatrix = (V: ((X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0)));

This item has no description.

IdentityQuaternion: TQuaternion = (ImagPart: (X: 0; Y: 0; Z: 0); RealPart: 1);

Quaternions

EPSILON: Single = 1E-40;

Some very small numbers

EPSILON2: Single = 1E-30;

This item has no description.

cPI: Single = 3.141592654;

This item has no description.

cPIdiv180: Single = 0.017453292;

This item has no description.

c180divPI: Single = 57.29577951;

This item has no description.

c2PI: Single = 6.283185307;

This item has no description.

cPIdiv2: Single = 1.570796326;

This item has no description.

cPIdiv4: Single = 0.785398163;

This item has no description.

c3PIdiv2: Single = 4.71238898;

This item has no description.

c3PIdiv4: Single = 2.35619449;

This item has no description.

cInv2PI: Single = 1 / 6.283185307;

This item has no description.

cInv360: Single = 1 / 360;

This item has no description.

c180: Single = 180;

This item has no description.

c360: Single = 360;

This item has no description.

cOneHalf: Single = 0.5;

This item has no description.

cLn10: Single = 2.302585093;

This item has no description.

MinSingle = 1.5E-45;

Ranges of the IEEE floating point types, including denormals with Math.pas compatible name

MaxSingle = 3.4E+38;

This item has no description.

MinDouble = 5.0E-324;

This item has no description.

MaxDouble = 1.7E+308;

This item has no description.

MinExtended = 3.4E-4932;

This item has no description.

MaxExtended = MaxDouble;

This item has no description.

MinComp = -9.223372036854775807E+18;

1.1E+4932 <-Overflowing in c++;

MaxComp = 9.223372036854775807E+18;

This item has no description.

Variables

vSIMD: Byte = 0;

This var is adjusted during "initialization", current values are + 0 : use standard optimized FPU code + 1 : use 3DNow! optimized code (requires K6-2/3 CPU) + 2 : use Intel SSE code (Pentium III, NOT IMPLEMENTED YET !)


GLSysHelp v.2.5: GLScene.VectorGeometry: Packed Record TTexPoint

Packed Record TTexPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorGeometry

Declaration

type TTexPoint = packed record

Description

This item has no description.

Overview

Fields

Public | S: Single;
Public | T: Single;

Description

Fields

Public S: Single;

This item has no description.

Public T: Single;


GLSysHelp v.2.5: GLScene.VectorGeometry: Record TQuaternion

Record TQuaternion

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorGeometry

Declaration

type TQuaternion = record

Description

This item has no description.

Overview

Fields

Public | ImagPart: TAffineVector;
Public | RealPart: Single
Public | X: Single
Public | Y: Single
Public | Z: Single
Public | W: Single

Description

Fields

Public ImagPart: TAffineVector;

This item has no description.

Public RealPart: Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single

This item has no description.

Public Z: Single

This item has no description.

Public W: Single


GLSysHelp v.2.5: GLScene.VectorGeometry: Record TRectangle

Record TRectangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorGeometry

Declaration

type TRectangle = record

Description

This item has no description.

Overview

Fields

Public | Left: Integer;
Public | Top: Integer;
Public | Width: Integer;
Public | Height: Integer;

Description

Fields

Public Left: Integer;

This item has no description.

Public Top: Integer;

This item has no description.

Public Width: Integer;

This item has no description.

Public Height: Integer;


GLSysHelp v.2.5: GLScene.VectorGeometry: Record TFrustum

Record TFrustum

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorGeometry

Declaration

type TFrustum = record

Description

This item has no description.

Overview

Fields

Public | pLeft: THmgPlane;
Public | pTop: THmgPlane;
Public | pRight: THmgPlane;
Public | pBottom: THmgPlane;
Public | pNear: THmgPlane;
Public | pFar: THmgPlane;

Description

Fields

Public pLeft: THmgPlane;

This item has no description.

Public pTop: THmgPlane;

This item has no description.

Public pRight: THmgPlane;

This item has no description.

Public pBottom: THmgPlane;

This item has no description.

Public pNear: THmgPlane;

This item has no description.

Public pFar: THmgPlane;


GLSysHelp v.2.5: GLScene.VectorTypes

Unit GLScene.VectorTypes

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TVector2d |
Record TVector2f |
Record TVector2h |
Record TVector2i |
Record TVector2ui |
Record TVector2s |
Record TVector2b |
Record TVector2sb |
Record TVector2e |
Record TVector2w |
Record TVector2p |
Record TVector3d |
Record TVector3f |
Record TVector3h |
Record TVector3i |
Record TVector3ui |
Record TVector3s |
Record TVector3b |
Record TVector3sb |
Record TVector3e |
Record TVector3w |
Record TVector3p |
Record TVector4d |
Record TVector4f |
Record TVector4h |
Record TVector4i |
Record TVector4ui |
Record TVector4s |
Record TVector4b |
Record TVector4sb |
Record TVector4e |
Record TVector4w |
Record TVector4p |
Record TMatrix2d |
Record TMatrix2f |
Record TMatrix2i |
Record TMatrix2s |
Record TMatrix2b |
Record TMatrix2e |
Record TMatrix2w |
Record TMatrix2p |
Record TMatrix3d |
Record TMatrix3f |
Record TMatrix3i |
Record TMatrix3s |
Record TMatrix3b |
Record TMatrix3e |
Record TMatrix3w |
Record TMatrix3p |
Record TMatrix4d |
Record TMatrix4f |
Record TMatrix4i |
Record TMatrix4s |
Record TMatrix4b |
Record TMatrix4e |
Record TMatrix4w |
Record TMatrix4p |
Packed Record TD3DVector |
Packed Record TD3DMatrix |

Types

PGLMatrix = ˆTGLMatrix;
PGLVector = ˆTGLVector;
PMatrix4f = ˆTMatrix4f;
PVector4f = ˆTVector4f;
TGLMatrix = TMatrix4f;
TGLVector = TVector4f;

Description

Types

PGLMatrix = ˆTGLMatrix;

The matrix by default

PGLVector = ˆTGLVector;

The vector by default

PMatrix4f = ˆTMatrix4f;

the matrix by default

PVector4f = ˆTVector4f;

This item has no description.

TGLMatrix = TMatrix4f;

This item has no description.

TGLVector = TVector4f;


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2d

Record TVector2d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2d = record

Description

=========== Vectors ============ 2

Overview

Fields

Public | V: array[0..1] of Double
Public | X: Double;
Public | Y: Double

Description

Fields

Public V: array[0..1] of Double

This item has no description.

Public X: Double;

This item has no description.

Public Y: Double


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2f

Record TVector2f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Single
Public | X: Single
Public | Y: Single

Description

Fields

Public V: array[0..1] of Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2h

Record TVector2h

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2h = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Word
Public | X: Word
Public | Y: Word

Description

Fields

Public V: array[0..1] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2i

Record TVector2i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Longint
Public | X: Longint
Public | Y: Longint

Description

Fields

Public V: array[0..1] of Longint

This item has no description.

Public X: Longint

This item has no description.

Public Y: Longint


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2ui

Record TVector2ui

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2ui = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Longword
Public | X: Longword
Public | Y: Longword

Description

Fields

Public V: array[0..1] of Longword

This item has no description.

Public X: Longword

This item has no description.

Public Y: Longword


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2s

Record TVector2s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Smallint
Public | X: Smallint
Public | Y: Smallint

Description

Fields

Public V: array[0..1] of Smallint

This item has no description.

Public X: Smallint

This item has no description.

Public Y: Smallint


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2b

Record TVector2b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Byte
Public | X: Byte
Public | Y: Byte

Description

Fields

Public V: array[0..1] of Byte

This item has no description.

Public X: Byte

This item has no description.

Public Y: Byte


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2sb

Record TVector2sb

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2sb = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of ShortInt
Public | X: ShortInt
Public | Y: ShortInt

Description

Fields

Public V: array[0..1] of ShortInt

This item has no description.

Public X: ShortInt

This item has no description.

Public Y: ShortInt


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2e

Record TVector2e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Extended
Public | X: Extended
Public | Y: Extended

Description

Fields

Public V: array[0..1] of Extended

This item has no description.

Public X: Extended

This item has no description.

Public Y: Extended


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2w

Record TVector2w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Word
Public | X: Word
Public | Y: Word

Description

Fields

Public V: array[0..1] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector2p

Record TVector2p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Pointer
Public | X: Pointer
Public | Y: Pointer

Description

Fields

Public V: array[0..1] of Pointer

This item has no description.

Public X: Pointer

This item has no description.

Public Y: Pointer


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3d

Record TVector3d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3d = record

Description

3

Overview

Fields

Public | V: array[0..2] of Double
Public | X: Double
Public | Y: Double
Public | Z: Double

Description

Fields

Public V: array[0..2] of Double

This item has no description.

Public X: Double

This item has no description.

Public Y: Double

This item has no description.

Public Z: Double


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3f

Record TVector3f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Single
Public | X: Single
Public | Y: Single
Public | Z: Single

Description

Fields

Public V: array[0..2] of Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single

This item has no description.

Public Z: Single


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3h

Record TVector3h

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3h = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Word
Public | X: Word
Public | Y: Word
Public | Z: Word

Description

Fields

Public V: array[0..2] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word

This item has no description.

Public Z: Word


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3i

Record TVector3i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Longint
Public | X: Longint
Public | Y: Longint
Public | Z: Longint

Description

Fields

Public V: array[0..2] of Longint

This item has no description.

Public X: Longint

This item has no description.

Public Y: Longint

This item has no description.

Public Z: Longint


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3ui

Record TVector3ui

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3ui = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Longword
Public | X: Longword
Public | Y: Longword
Public | Z: Longword

Description

Fields

Public V: array[0..2] of Longword

This item has no description.

Public X: Longword

This item has no description.

Public Y: Longword

This item has no description.

Public Z: Longword


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3s

Record TVector3s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Smallint
Public | X: Smallint
Public | Y: Smallint
Public | Z: Smallint

Description

Fields

Public V: array[0..2] of Smallint

This item has no description.

Public X: Smallint

This item has no description.

Public Y: Smallint

This item has no description.

Public Z: Smallint


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3b

Record TVector3b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Byte
Public | X: Byte
Public | Y: Byte
Public | Z: Byte

Description

Fields

Public V: array[0..2] of Byte

This item has no description.

Public X: Byte

This item has no description.

Public Y: Byte

This item has no description.

Public Z: Byte


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3sb

Record TVector3sb

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3sb = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of ShortInt
Public | X: ShortInt
Public | Y: ShortInt
Public | Z: ShortInt

Description

Fields

Public V: array[0..2] of ShortInt

This item has no description.

Public X: ShortInt

This item has no description.

Public Y: ShortInt

This item has no description.

Public Z: ShortInt


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3e

Record TVector3e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Extended
Public | X: Extended
Public | Y: Extended
Public | Z: Extended

Description

Fields

Public V: array[0..2] of Extended

This item has no description.

Public X: Extended

This item has no description.

Public Y: Extended

This item has no description.

Public Z: Extended


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3w

Record TVector3w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Word
Public | X: Word
Public | Y: Word
Public | Z: Word

Description

Fields

Public V: array[0..2] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word

This item has no description.

Public Z: Word


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector3p

Record TVector3p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Pointer
Public | X: Pointer
Public | Y: Pointer
Public | Z: Pointer

Description

Fields

Public V: array[0..2] of Pointer

This item has no description.

Public X: Pointer

This item has no description.

Public Y: Pointer

This item has no description.

Public Z: Pointer


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4d

Record TVector4d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4d = record

Description

4

Overview

Fields

Public | V: array[0..3] of Double
Public | X: Double
Public | Y: Double
Public | Z: Double
Public | W: Double

Description

Fields

Public V: array[0..3] of Double

This item has no description.

Public X: Double

This item has no description.

Public Y: Double

This item has no description.

Public Z: Double

This item has no description.

Public W: Double


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4f

Record TVector4f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Single
Public | X: Single
Public | Y: Single
Public | Z: Single
Public | W: Single

Description

Fields

Public V: array[0..3] of Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single

This item has no description.

Public Z: Single

This item has no description.

Public W: Single


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4h

Record TVector4h

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4h = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Word
Public | X: Word
Public | Y: Word
Public | Z: Word
Public | W: Word

Description

Fields

Public V: array[0..3] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word

This item has no description.

Public Z: Word

This item has no description.

Public W: Word


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4i

Record TVector4i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of LongInt
Public | X: Longint
Public | Y: Longint
Public | Z: Longint
Public | W: Longint

Description

Fields

Public V: array[0..3] of LongInt

This item has no description.

Public X: Longint

This item has no description.

Public Y: Longint

This item has no description.

Public Z: Longint

This item has no description.

Public W: Longint


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4ui

Record TVector4ui

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4ui = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of LongWord
Public | X: LongWord
Public | Y: LongWord
Public | Z: LongWord
Public | W: LongWord

Description

Fields

Public V: array[0..3] of LongWord

This item has no description.

Public X: LongWord

This item has no description.

Public Y: LongWord

This item has no description.

Public Z: LongWord

This item has no description.

Public W: LongWord


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4s

Record TVector4s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of SmallInt
Public | X: SmallInt
Public | Y: SmallInt
Public | Z: SmallInt
Public | W: SmallInt

Description

Fields

Public V: array[0..3] of SmallInt

This item has no description.

Public X: SmallInt

This item has no description.

Public Y: SmallInt

This item has no description.

Public Z: SmallInt

This item has no description.

Public W: SmallInt


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4b

Record TVector4b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Byte
Public | X: Byte
Public | Y: Byte
Public | Z: Byte
Public | W: Byte

Description

Fields

Public V: array[0..3] of Byte

This item has no description.

Public X: Byte

This item has no description.

Public Y: Byte

This item has no description.

Public Z: Byte

This item has no description.

Public W: Byte


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4sb

Record TVector4sb

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4sb = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of ShortInt
Public | X: ShortInt
Public | Y: ShortInt
Public | Z: ShortInt
Public | W: ShortInt

Description

Fields

Public V: array[0..3] of ShortInt

This item has no description.

Public X: ShortInt

This item has no description.

Public Y: ShortInt

This item has no description.

Public Z: ShortInt

This item has no description.

Public W: ShortInt


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4e

Record TVector4e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Extended
Public | X: Extended
Public | Y: Extended
Public | Z: Extended
Public | W: Extended

Description

Fields

Public V: array[0..3] of Extended

This item has no description.

Public X: Extended

This item has no description.

Public Y: Extended

This item has no description.

Public Z: Extended

This item has no description.

Public W: Extended


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4w

Record TVector4w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Word
Public | X: Word
Public | Y: Word
Public | Z: Word
Public | W: Word

Description

Fields

Public V: array[0..3] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word

This item has no description.

Public Z: Word

This item has no description.

Public W: Word


GLSysHelp v.2.5: GLScene.VectorTypes: Record TVector4p

Record TVector4p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Pointer
Public | X: Pointer
Public | Y: Pointer
Public | Z: Pointer
Public | W: Pointer

Description

Fields

Public V: array[0..3] of Pointer

This item has no description.

Public X: Pointer

This item has no description.

Public Y: Pointer

This item has no description.

Public Z: Pointer

This item has no description.

Public W: Pointer


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2d

Record TMatrix2d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2d = record

Description

=========== Matrices ============

Overview

Fields

Public | V: array[0..1] of TVector2d
Public | X: TVector2d
Public | Y: TVector2d

Description

Fields

Public V: array[0..1] of TVector2d

This item has no description.

Public X: TVector2d

This item has no description.

Public Y: TVector2d


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2f

Record TMatrix2f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2f
Public | X: TVector2f
Public | Y: TVector2f

Description

Fields

Public V: array[0..1] of TVector2f

This item has no description.

Public X: TVector2f

This item has no description.

Public Y: TVector2f


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2i

Record TMatrix2i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2i
Public | X: TVector2i
Public | Y: TVector2i

Description

Fields

Public V: array[0..1] of TVector2i

This item has no description.

Public X: TVector2i

This item has no description.

Public Y: TVector2i


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2s

Record TMatrix2s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2s
Public | X: TVector2s
Public | Y: TVector2s

Description

Fields

Public V: array[0..1] of TVector2s

This item has no description.

Public X: TVector2s

This item has no description.

Public Y: TVector2s


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2b

Record TMatrix2b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2b
Public | X: TVector2b
Public | Y: TVector2b

Description

Fields

Public V: array[0..1] of TVector2b

This item has no description.

Public X: TVector2b

This item has no description.

Public Y: TVector2b


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2e

Record TMatrix2e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2e
Public | X: TVector2e
Public | Y: TVector2e

Description

Fields

Public V: array[0..1] of TVector2e

This item has no description.

Public X: TVector2e

This item has no description.

Public Y: TVector2e


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2w

Record TMatrix2w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2w
Public | X: TVector2w
Public | Y: TVector2w

Description

Fields

Public V: array[0..1] of TVector2w

This item has no description.

Public X: TVector2w

This item has no description.

Public Y: TVector2w


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2p

Record TMatrix2p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2p
Public | X: TVector2p
Public | Y: TVector2p

Description

Fields

Public V: array[0..1] of TVector2p

This item has no description.

Public X: TVector2p

This item has no description.

Public Y: TVector2p


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3d

Record TMatrix3d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3d = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3d
Public | X: TVector3d
Public | Y: TVector3d
Public | Z: TVector3d

Description

Fields

Public V: array[0..2] of TVector3d

This item has no description.

Public X: TVector3d

This item has no description.

Public Y: TVector3d

This item has no description.

Public Z: TVector3d


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3f

Record TMatrix3f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3f
Public | X: TVector3f
Public | Y: TVector3f
Public | Z: TVector3f

Description

Fields

Public V: array[0..2] of TVector3f

This item has no description.

Public X: TVector3f

This item has no description.

Public Y: TVector3f

This item has no description.

Public Z: TVector3f


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3i

Record TMatrix3i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3i
Public | X: TVector3i
Public | Y: TVector3i
Public | Z: TVector3i

Description

Fields

Public V: array[0..2] of TVector3i

This item has no description.

Public X: TVector3i

This item has no description.

Public Y: TVector3i

This item has no description.

Public Z: TVector3i


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3s

Record TMatrix3s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3s
Public | X: TVector3s
Public | Y: TVector3s
Public | Z: TVector3s

Description

Fields

Public V: array[0..2] of TVector3s

This item has no description.

Public X: TVector3s

This item has no description.

Public Y: TVector3s

This item has no description.

Public Z: TVector3s


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3b

Record TMatrix3b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3b
Public | X: TVector3b
Public | Y: TVector3b
Public | Z: TVector3b

Description

Fields

Public V: array[0..2] of TVector3b

This item has no description.

Public X: TVector3b

This item has no description.

Public Y: TVector3b

This item has no description.

Public Z: TVector3b


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3e

Record TMatrix3e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3e
Public | X: TVector3e
Public | Y: TVector3e
Public | Z: TVector3e

Description

Fields

Public V: array[0..2] of TVector3e

This item has no description.

Public X: TVector3e

This item has no description.

Public Y: TVector3e

This item has no description.

Public Z: TVector3e


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3w

Record TMatrix3w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3w
Public | X: TVector3w
Public | Y: TVector3w
Public | Z: TVector3w

Description

Fields

Public V: array[0..2] of TVector3w

This item has no description.

Public X: TVector3w

This item has no description.

Public Y: TVector3w

This item has no description.

Public Z: TVector3w


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3p

Record TMatrix3p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3p
Public | X: TVector3p
Public | Y: TVector3p
Public | Z: TVector3p

Description

Fields

Public V: array[0..2] of TVector3p

This item has no description.

Public X: TVector3p

This item has no description.

Public Y: TVector3p

This item has no description.

Public Z: TVector3p


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4d

Record TMatrix4d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4d = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4d
Public | X: TVector4d
Public | Y: TVector4d
Public | Z: TVector4d
Public | W: TVector4d

Description

Fields

Public V: array[0..3] of TVector4d

This item has no description.

Public X: TVector4d

This item has no description.

Public Y: TVector4d

This item has no description.

Public Z: TVector4d

This item has no description.

Public W: TVector4d


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4f

Record TMatrix4f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4f
Public | X: TVector4f
Public | Y: TVector4f
Public | Z: TVector4f
Public | W: TVector4f

Description

Fields

Public V: array[0..3] of TVector4f

This item has no description.

Public X: TVector4f

This item has no description.

Public Y: TVector4f

This item has no description.

Public Z: TVector4f

This item has no description.

Public W: TVector4f


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4i

Record TMatrix4i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4i
Public | X: TVector4i
Public | Y: TVector4i
Public | Z: TVector4i
Public | W: TVector4i

Description

Fields

Public V: array[0..3] of TVector4i

This item has no description.

Public X: TVector4i

This item has no description.

Public Y: TVector4i

This item has no description.

Public Z: TVector4i

This item has no description.

Public W: TVector4i


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4s

Record TMatrix4s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4s
Public | X: TVector4s
Public | Y: TVector4s
Public | Z: TVector4s
Public | W: TVector4s

Description

Fields

Public V: array[0..3] of TVector4s

This item has no description.

Public X: TVector4s

This item has no description.

Public Y: TVector4s

This item has no description.

Public Z: TVector4s

This item has no description.

Public W: TVector4s


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4b

Record TMatrix4b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4b
Public | X: TVector4b
Public | Y: TVector4b
Public | Z: TVector4b
Public | W: TVector4b

Description

Fields

Public V: array[0..3] of TVector4b

This item has no description.

Public X: TVector4b

This item has no description.

Public Y: TVector4b

This item has no description.

Public Z: TVector4b

This item has no description.

Public W: TVector4b


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4e

Record TMatrix4e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4e
Public | X: TVector4e
Public | Y: TVector4e
Public | Z: TVector4e
Public | W: TVector4e

Description

Fields

Public V: array[0..3] of TVector4e

This item has no description.

Public X: TVector4e

This item has no description.

Public Y: TVector4e

This item has no description.

Public Z: TVector4e

This item has no description.

Public W: TVector4e


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4w

Record TMatrix4w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4w
Public | X: TVector4w
Public | Y: TVector4w
Public | Z: TVector4w
Public | W: TVector4w

Description

Fields

Public V: array[0..3] of TVector4w

This item has no description.

Public X: TVector4w

This item has no description.

Public Y: TVector4w

This item has no description.

Public Z: TVector4w

This item has no description.

Public W: TVector4w


GLSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4p

Record TMatrix4p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4p
Public | X: TVector4p
Public | Y: TVector4p
Public | Z: TVector4p
Public | W: TVector4p

Description

Fields

Public V: array[0..3] of TVector4p

This item has no description.

Public X: TVector4p

This item has no description.

Public Y: TVector4p

This item has no description.

Public Z: TVector4p

This item has no description.

Public W: TVector4p


GLSysHelp v.2.5: GLScene.VectorTypes: Packed Record TD3DVector

Packed Record TD3DVector

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TD3DVector = packed record

Description

This item has no description.

Overview

Fields

Public | X: single;
Public | Y: single;
Public | Z: single
Public | V: TVector3f

Description

Fields

Public X: single;

This item has no description.

Public Y: single;

This item has no description.

Public Z: single

This item has no description.

Public V: TVector3f


GLSysHelp v.2.5: GLScene.VectorTypes: Packed Record TD3DMatrix

Packed Record TD3DMatrix

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TD3DMatrix = packed record

Description

This item has no description.

Overview

Fields

Public | _11: single;
Public | _12: single;
Public | _13: single;
Public | _14: single;
Public | _21: single;
Public | _22: single;
Public | _23: single;
Public | _24: single;
Public | _31: single;
Public | _32: single;
Public | _33: single;
Public | _34: single;
Public | _41: single
Public | _42: single
Public | _43: single
Public | _44: single
Public | M: TMatrix4f

Description

Fields

Public _11: single;

This item has no description.

Public _12: single;

This item has no description.

Public _13: single;

This item has no description.

Public _14: single;

This item has no description.

Public _21: single;

This item has no description.

Public _22: single;

This item has no description.

Public _23: single;

This item has no description.

Public _24: single;

This item has no description.

Public _31: single;

This item has no description.

Public _32: single;

This item has no description.

Public _33: single;

This item has no description.

Public _34: single;

This item has no description.

Public _41: single

This item has no description.

Public _42: single

This item has no description.

Public _43: single

This item has no description.

Public _44: single

This item has no description.

Public M: TMatrix4f


GLSysHelp v.2.5: GLScene.VectorTypesExt

Unit GLScene.VectorTypesExt

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Types
  • System.TypInfo
  • System.SysUtils
  • System.Rtti
  • System.Math
  • System.Math.Vectors
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TQuaternionRec |
Record TVectorRec |
Record TMatrixRec |
Record TQuaternionHelper |
Record TVectorHelper |
Class TDim |
Record TVertexRec |
Record TFaceRec |
Record TPoint2DRec |
Record TPoint3DRec |
Record TVoxelRec |
Record TVector2DRec |
Record TVector3DRec |
Record TMatrix2DRec |
Record TMatrix3DRec |
Record TTriangleRec |
Record TMesh2DVert |
Packed Record TMesh3DVert |
Record TQuat3DRec |
Record TBoxRec |

Functions and Procedures

function GetVectorRec(V: TVectorExt): TVectorRec;
function GetMatrixRec(M: TMatrixExt): TMatrixRec;
function GetQuaternionRec(Q: TVectorExt): TQuaternionRec;
procedure Init(Obj, TypeInfoOfObj: Pointer; Offset: Integer = 0);

Types

PMatrixRec = ˆTMatrixRec;
PPoint2DRec = ˆTPoint2DRec;
PPoint3DRec = ˆTPoint3DRec;
PTriangleRecArray = ˆTTriangleRecArray;
PVectorRec = ˆTVectorRec;
PVertArray = ˆTVertArray;
PVoxelData = ˆTVoxelData;
PVoxelRec = ˆTVoxelRec;
TArray3DExt = array of array of array of Extended;
TDoubleArray = array of Double;
TIntegerArray = array of Integer;
TMatrix2DArray = array of TMatrix2DRec;
TMatrix2DType = array [0 .. 3] of TVector2DRec;
TMatrix3DArray = array of TMatrix3DRec;
TMatrix3DType = array [0 .. 3] of TVector3DRec;
TMatrixExt = array of array of Extended;
TMesh2DArray = array of TMesh2DVert;
TMesh3DArray = array of TMesh3DVert;
TPoint2DArray = array of TPoint2DRec;
TPoint3DArray = array of TPoint3DRec;
TPolygon2D = TPoint2DArray;
TPolygon3D = TPoint3DArray;
TPolyhedronArray = array of TPolygon3D;
TQuatArray = array of TQuat3DRec;
TScalarField = function(X, Y, Z: Extended): TScalarValue;
TScalarFieldInt = function(iX, iY, iZ: Integer): TScalarValue of object;
TScalarValue = Extended;
TTriangleRecArray = array [0 .. (MaxInt shr 8)] of TTriangleRec;
TVector2DArray = array of TVector2DRec;
TVector2DType = array [0 .. 1] of Extended;
TVector3DArray = array of TVector3DRec;
TVector3DType = array [0 .. 2] of Extended;
TVectorExt = array of Extended;
TVertArray = array [0 .. (MaxInt shr 8)] of TVertexRec;
TVertexArray = array of TVector3f;
TVoxelData = array [0 .. (MaxInt shr 8)] of TVoxelRec;
TVoxelStatus = (...);

Constants

ClosedPolygon2D: TPoint2DRec = (X: $FFFF; Y: $FFFF);
ClosedPolygon3D: TPoint3DRec = (X: $FFFF; Y: $FFFF; Z: $FFFF);
sWRONG_ELEMENT = 'Wrong element';
sWRONG_SIZE = 'Wrong size';
sNOT_QUAD = 'Matrix not quadratic';
sSINGULAR = 'Singular matrix founded';

Description

Functions and Procedures

function GetVectorRec(V: TVectorExt): TVectorRec;

This item has no description.

function GetMatrixRec(M: TMatrixExt): TMatrixRec;

This item has no description.

function GetQuaternionRec(Q: TVectorExt): TQuaternionRec;

This item has no description.

procedure Init(Obj, TypeInfoOfObj: Pointer; Offset: Integer = 0);

This item has no description.

Types

PMatrixRec = ˆTMatrixRec;

This item has no description.

PPoint2DRec = ˆTPoint2DRec;

This item has no description.

PPoint3DRec = ˆTPoint3DRec;

This item has no description.

PTriangleRecArray = ˆTTriangleRecArray;

This item has no description.

PVectorRec = ˆTVectorRec;

This item has no description.

PVertArray = ˆTVertArray;

This item has no description.

PVoxelData = ˆTVoxelData;

This item has no description.

PVoxelRec = ˆTVoxelRec;

This item has no description.

TArray3DExt = array of array of array of Extended;

This item has no description.

TDoubleArray = array of Double;

This item has no description.

TIntegerArray = array of Integer;

Extended may be replaced with BigDecimals

TMatrix2DArray = array of TMatrix2DRec;

Matrix Arrays

TMatrix2DType = array [0 .. 3] of TVector2DRec;

———————– Matrix types ———————–

TMatrix3DArray = array of TMatrix3DRec;

This item has no description.

TMatrix3DType = array [0 .. 3] of TVector3DRec;

This item has no description.

TMatrixExt = array of array of Extended;

This item has no description.

TMesh2DArray = array of TMesh2DVert;

This item has no description.

TMesh3DArray = array of TMesh3DVert;

This item has no description.

TPoint2DArray = array of TPoint2DRec;

This item has no description.

TPoint3DArray = array of TPoint3DRec;

This item has no description.

TPolygon2D = TPoint2DArray;

———————– Polygon types ———————–

TPolygon3D = TPoint3DArray;

This item has no description.

TPolyhedronArray = array of TPolygon3D;

———————– Polyhedron types ———————–

TQuatArray = array of TQuat3DRec;

This item has no description.

TScalarField = function(X, Y, Z: Extended): TScalarValue;

This item has no description.

TScalarFieldInt = function(iX, iY, iZ: Integer): TScalarValue of object;

if data are made on integer XYZ index may be replaced with BigIntegers

TScalarValue = Extended;

———————– Point types ———————–

TTriangleRecArray = array [0 .. (MaxInt shr 8)] of TTriangleRec;

This item has no description.

TVector2DArray = array of TVector2DRec;

Vector Arrays

TVector2DType = array [0 .. 1] of Extended;

———————– Vector types ———————–

TVector3DArray = array of TVector3DRec;

This item has no description.

TVector3DType = array [0 .. 2] of Extended;

This item has no description.

TVectorExt = array of Extended;

This item has no description.

TVertArray = array [0 .. (MaxInt shr 8)] of TVertexRec;

This item has no description.

TVertexArray = array of TVector3f;

This item has no description.

TVoxelData = array [0 .. (MaxInt shr 8)] of TVoxelRec;

This item has no description.

TVoxelStatus = (...);

Voxel types

Values
  • bpExternal
  • bpInternal

Constants

ClosedPolygon2D: TPoint2DRec = (X: $FFFF; Y: $FFFF);

TPolygon3D = record Vertices: array of TPoint3DRec; function Length; end;

ClosedPolygon3D: TPoint3DRec = (X: $FFFF; Y: $FFFF; Z: $FFFF);

This item has no description.

sWRONG_ELEMENT = 'Wrong element';

This item has no description.

sWRONG_SIZE = 'Wrong size';

This item has no description.

sNOT_QUAD = 'Matrix not quadratic';

This item has no description.

sSINGULAR = 'Singular matrix founded';


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TQuaternionRec

Record TQuaternionRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TQuaternionRec = record

Description

This item has no description.

Overview

Fields

Private FData: array [0 .. 3] of Extended;

Methods

Public | constructor Create(Q: TVectorExt);
Public | function Inv: TQuaternionRec;
Public | function TruncateSTI: TQuaternionRec;
Private | function GetElement(Index: Byte): Extended;
Private | procedure SetElement(Index: Byte; Value: Extended);
Public | class operator Implicit(V: TVectorExt): TQuaternionRec;
Public | class operator Multiply(Q1, Q2: TQuaternionRec): TQuaternionRec;
Public | class operator Multiply(Q: TQuaternionRec; Sc: Extended): TQuaternionRec;
Public | class operator Multiply(Scalar: Extended; Q: TQuaternionRec) : TQuaternionRec;

Properties

Public property Element[index: Byte]: Extended read GetElement write SetElement;

Description

Fields

Private FData: array [0 .. 3] of Extended;

This item has no description.

Methods

Public constructor Create(Q: TVectorExt);

This item has no description.

Public function Inv: TQuaternionRec;

This item has no description.

Public function TruncateSTI: TQuaternionRec;

This item has no description.

Private function GetElement(Index: Byte): Extended;

This item has no description.

Private procedure SetElement(Index: Byte; Value: Extended);

This item has no description.

Public class operator Implicit(V: TVectorExt): TQuaternionRec;

This item has no description.

Public class operator Multiply(Q1, Q2: TQuaternionRec): TQuaternionRec;

This item has no description.

Public class operator Multiply(Q: TQuaternionRec; Sc: Extended): TQuaternionRec;

This item has no description.

Public class operator Multiply(Scalar: Extended; Q: TQuaternionRec) : TQuaternionRec;

This item has no description.

Properties

Public property Element[index: Byte]: Extended read GetElement write SetElement;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TVectorRec

Record TVectorRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVectorRec = record

Description

This item has no description.

Overview

Fields

Private | FData: TVectorExt;
Private | FCount: Word;

Methods

Public | constructor Create(V: TVectorExt); overload;
Public | constructor Create(ElementsCount: Word); overload;
Public | function Norm: Extended;
Public | function ScalarMult(V: TVectorRec): Extended;
Public | function SumOfElments: Extended;
Public | function SumOfSquares: Extended;
Public | function ToQuat: TQuaternionRec;
Public | function TruncateSTI: TVectorRec;
Private | function GetElement(Index: Word): Extended;
Public | procedure Fill(Value: Extended);
Private | procedure CheckUnique;
Private | procedure SetElement(Index: Word; Value: Extended);
Public | class operator Add(V1, V2: TVectorRec): TVectorRec;
Public | class operator Add(Scalar: Extended; V: TVectorRec): TVectorRec;
Public | class operator Add(V: TVectorRec; Scalar: Extended): TVectorRec;
Public | class operator Divide(V1, V2: TVectorRec): TVectorRec;
Public | class operator Divide(V: TVectorRec; Scalar: Extended): TVectorRec;
Public | class operator Implicit(V: TVectorExt): TVectorRec;
Public | class operator Multiply(V1, V2: TVectorRec): TVectorRec;
Public | class operator Multiply(V: TVectorRec; Scalar: Extended): TVectorRec;
Public | class operator Multiply(Scalar: Extended; V: TVectorRec): TVectorRec;
Public | class operator Subtract(V1, V2: TVectorRec): TVectorRec;
Public | class operator Subtract(Scalar: Extended; V: TVectorRec): TVectorRec;
Public | class operator Subtract(V: TVectorRec; Scalar: Extended): TVectorRec;

Properties

Public | property Count: Word read FCount;
Public | property Elements[index: Word]: Extended read GetElement write SetElement;

Description

Fields

Private FData: TVectorExt;

This item has no description.

Private FCount: Word;

This item has no description.

Methods

Public constructor Create(V: TVectorExt); overload;

This item has no description.

Public constructor Create(ElementsCount: Word); overload;

This item has no description.

Public function Norm: Extended;

This item has no description.

Public function ScalarMult(V: TVectorRec): Extended;

This item has no description.

Public function SumOfElments: Extended;

This item has no description.

Public function SumOfSquares: Extended;

This item has no description.

Public function ToQuat: TQuaternionRec;

This item has no description.

Public function TruncateSTI: TVectorRec;

This item has no description.

Private function GetElement(Index: Word): Extended;

This item has no description.

Public procedure Fill(Value: Extended);

This item has no description.

Private procedure CheckUnique;

This item has no description.

Private procedure SetElement(Index: Word; Value: Extended);

This item has no description.

Public class operator Add(V1, V2: TVectorRec): TVectorRec;

This item has no description.

Public class operator Add(Scalar: Extended; V: TVectorRec): TVectorRec;

This item has no description.

Public class operator Add(V: TVectorRec; Scalar: Extended): TVectorRec;

This item has no description.

Public class operator Divide(V1, V2: TVectorRec): TVectorRec;

This item has no description.

Public class operator Divide(V: TVectorRec; Scalar: Extended): TVectorRec;

This item has no description.

Public class operator Implicit(V: TVectorExt): TVectorRec;

This item has no description.

Public class operator Multiply(V1, V2: TVectorRec): TVectorRec;

This item has no description.

Public class operator Multiply(V: TVectorRec; Scalar: Extended): TVectorRec;

This item has no description.

Public class operator Multiply(Scalar: Extended; V: TVectorRec): TVectorRec;

This item has no description.

Public class operator Subtract(V1, V2: TVectorRec): TVectorRec;

This item has no description.

Public class operator Subtract(Scalar: Extended; V: TVectorRec): TVectorRec;

This item has no description.

Public class operator Subtract(V: TVectorRec; Scalar: Extended): TVectorRec;

This item has no description.

Properties

Public property Count: Word read FCount;

This item has no description.

Public property Elements[index: Word]: Extended read GetElement write SetElement;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TMatrixRec

Record TMatrixRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMatrixRec = record

Description

This item has no description.

Overview

Fields

Private | FData: TMatrixExt;
Private | FRowsCount: Word;
Private | FColsCount: Word;

Methods

Public | constructor Create(M: TMatrixExt); overload;
Public | constructor Create(RowsCount, ColsCount: Word); overload;
Public | constructor CreateDiag(Dim: Word; Value: Extended = 1.0);
Public | function Determinant: Extended;
Public | function Inv: TMatrixRec;
Public | function ToQuat: TQuaternionRec;
Public | function Trace: Extended;
Public | function Transp: TMatrixRec;
Public | function TruncateSTI: TMatrixRec;
Private | function Del(A: TMatrixRec; I, J: Integer; M: Integer): TMatrixRec;
Private | function Det(A: TMatrixRec; M: Integer): Extended;
Private | function GetCol(Col: Word): TVectorRec;
Private | function GetElement(Row, Col: Word): Extended;
Private | function GetRow(Row: Word): TVectorRec;
Public | procedure Fill(Scalar: Extended);
Private | procedure CheckUnique;
Private | procedure SetCol(Col: Word; Value: TVectorRec);
Private | procedure SetElement(Row, Col: Word; Value: Extended);
Private | procedure SetRow(Row: Word; Value: TVectorRec);
Public | class operator Add(M1, M2: TMatrixRec): TMatrixRec;
Public | class operator Implicit(M: TMatrixExt): TMatrixRec;
Public | class operator Multiply(V: TVectorRec; M: TMatrixRec): TVectorRec;
Public | class operator Multiply(M: TMatrixRec; V: TVectorRec): TVectorRec;
Public | class operator Multiply(M1, M2: TMatrixRec): TMatrixRec;
Public | class operator Multiply(M: TMatrixRec; Q: TQuaternionRec): TQuaternionRec;
Public | class operator Multiply(Scalar: Extended; M: TMatrixRec): TMatrixRec;
Public | class operator Multiply(M: TMatrixRec; Scalar: Extended): TMatrixRec;
Public | class operator Subtract(M1, M2: TMatrixRec): TMatrixRec;

Properties

Public | property Col[Col: Word]: TVectorRec read GetCol write SetCol;
Public | property ColCount: Word read FColsCount;
Public | property Elements[Row,Col: Word]: Extended read GetElement write SetElement;
Public | property Row[Row: Word]: TVectorRec read GetRow write SetRow;
Public | property RowCount: Word read FRowsCount;

Description

Fields

Private FData: TMatrixExt;

This item has no description.

Private FRowsCount: Word;

This item has no description.

Private FColsCount: Word;

This item has no description.

Methods

Public constructor Create(M: TMatrixExt); overload;

This item has no description.

Public constructor Create(RowsCount, ColsCount: Word); overload;

This item has no description.

Public constructor CreateDiag(Dim: Word; Value: Extended = 1.0);

This item has no description.

Public function Determinant: Extended;

This item has no description.

Public function Inv: TMatrixRec;

This item has no description.

Public function ToQuat: TQuaternionRec;

This item has no description.

Public function Trace: Extended;

This item has no description.

Public function Transp: TMatrixRec;

This item has no description.

Public function TruncateSTI: TMatrixRec;

This item has no description.

Private function Del(A: TMatrixRec; I, J: Integer; M: Integer): TMatrixRec;

This item has no description.

Private function Det(A: TMatrixRec; M: Integer): Extended;

This item has no description.

Private function GetCol(Col: Word): TVectorRec;

This item has no description.

Private function GetElement(Row, Col: Word): Extended;

This item has no description.

Private function GetRow(Row: Word): TVectorRec;

This item has no description.

Public procedure Fill(Scalar: Extended);

sum on diagonal elements

Private procedure CheckUnique;

This item has no description.

Private procedure SetCol(Col: Word; Value: TVectorRec);

This item has no description.

Private procedure SetElement(Row, Col: Word; Value: Extended);

This item has no description.

Private procedure SetRow(Row: Word; Value: TVectorRec);

This item has no description.

Public class operator Add(M1, M2: TMatrixRec): TMatrixRec;

This item has no description.

Public class operator Implicit(M: TMatrixExt): TMatrixRec;

This item has no description.

Public class operator Multiply(V: TVectorRec; M: TMatrixRec): TVectorRec;

This item has no description.

Public class operator Multiply(M: TMatrixRec; V: TVectorRec): TVectorRec;

This item has no description.

Public class operator Multiply(M1, M2: TMatrixRec): TMatrixRec;

This item has no description.

Public class operator Multiply(M: TMatrixRec; Q: TQuaternionRec): TQuaternionRec;

This item has no description.

Public class operator Multiply(Scalar: Extended; M: TMatrixRec): TMatrixRec;

This item has no description.

Public class operator Multiply(M: TMatrixRec; Scalar: Extended): TMatrixRec;

This item has no description.

Public class operator Subtract(M1, M2: TMatrixRec): TMatrixRec;

This item has no description.

Properties

Public property Col[Col: Word]: TVectorRec read GetCol write SetCol;

This item has no description.

Public property ColCount: Word read FColsCount;

This item has no description.

Public property Elements[Row,Col: Word]: Extended read GetElement write SetElement;

This item has no description.

Public property Row[Row: Word]: TVectorRec read GetRow write SetRow;

This item has no description.

Public property RowCount: Word read FRowsCount;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TQuaternionHelper

Record TQuaternionHelper

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TQuaternionHelper = record helper for TQuaternionRec

Description

This item has no description.

Overview

Methods

Public function ToMatrix: TMatrixRec;

Description

Methods

Public function ToMatrix: TMatrixRec;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TVectorHelper

Record TVectorHelper

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVectorHelper = record helper for TVectorRec

Description

This item has no description.

Overview

Methods

Public function ToDiagMatrix: TMatrixRec;

Description

Methods

Public function ToDiagMatrix: TMatrixRec;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Class TDim

Class TDim

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TDim = class(TCustomAttribute)

Description

This item has no description.

Hierarchy

  • TCustomAttribute
  • TDim

Overview

Fields

Private | FRowCount: Integer;
Private | FColCount: Integer;

Methods

Public constructor Create(ARowCount: Integer; AColCount: Integer = 0); overload;

Properties

Public | property ColCount: Integer read FColCount;
Public | property RowCount: Integer read FRowCount;

Description

Fields

Private FRowCount: Integer;

This item has no description.

Private FColCount: Integer;

This item has no description.

Methods

Public constructor Create(ARowCount: Integer; AColCount: Integer = 0); overload;

This item has no description.

Properties

Public property ColCount: Integer read FColCount;

This item has no description.

Public property RowCount: Integer read FRowCount;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TVertexRec

Record TVertexRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVertexRec = record

Description

This item has no description.

Overview

Fields

Public | P: TVector3f;
Public | N: TVector3f;
Public | Density: Extended;

Description

Fields

Public P: TVector3f;

This item has no description.

Public N: TVector3f;

This item has no description.

Public Density: Extended;

Position and Normal


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TFaceRec

Record TFaceRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TFaceRec = record

Description

This item has no description.

Overview

Fields

Public | Normal: TVector3f;
Public | V1: TVector3f;
Public | V2: TVector3f;
Public | V3: TVector3f;
Public | Padding: array [0 .. 1] of Byte;

Description

Fields

Public Normal: TVector3f;

This item has no description.

Public V1: TVector3f;

This item has no description.

Public V2: TVector3f;

vertex 1

Public V3: TVector3f;

vertex 2

Public Padding: array [0 .. 1] of Byte;

vertex 3


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TPoint2DRec

Record TPoint2DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TPoint2DRec = record

Description

This item has no description.

Overview

Fields

Public | X: Extended;
Public | Y: Extended;

Methods

Public | function Add(const APoint2D: TPoint2DRec): TPoint2DRec;
Public | function Create(X, Y: Extended): TPoint2DRec;
Public | function Distance(const APoint2D: TPoint2DRec): Extended;
Public | function Length: Extended;
Public | class function PointInCircle(const Point, Center: TPoint2DRec; const Radius: Integer): Boolean; static; inline;
Public | procedure Offset(const ADeltaX, ADeltaY: Extended);
Public | procedure SetPosition(const X, Y: Extended);

Description

Fields

Public X: Extended;

This item has no description.

Public Y: Extended;

This item has no description.

Methods

Public function Add(const APoint2D: TPoint2DRec): TPoint2DRec;

This item has no description.

Public function Create(X, Y: Extended): TPoint2DRec;

This item has no description.

Public function Distance(const APoint2D: TPoint2DRec): Extended;

distance to origin

Public function Length: Extended;

This item has no description.

Public class function PointInCircle(const Point, Center: TPoint2DRec; const Radius: Integer): Boolean; static; inline;

This item has no description.

Public procedure Offset(const ADeltaX, ADeltaY: Extended);

This item has no description.

Public procedure SetPosition(const X, Y: Extended);


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TPoint3DRec

Record TPoint3DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TPoint3DRec = record

Description

This item has no description.

Overview

Fields

Public | X: Extended;
Public | Y: Extended;
Public | Z: Extended;

Methods

Public | function Add(const AGLPoint3D: TPoint3DRec): TPoint3DRec;
Public | function Create(X, Y, Z: Extended): TPoint3DRec;
Public | function Distance(const APoint3D: TPoint3DRec): Extended;
Public | function Length: Single;
Public | procedure Offset(const ADeltaX, ADeltaY, ADeltaZ: Extended);
Public | procedure SetPosition(const X, Y, Z: Extended);

Description

Fields

Public X: Extended;

This item has no description.

Public Y: Extended;

This item has no description.

Public Z: Extended;

This item has no description.

Methods

Public function Add(const AGLPoint3D: TPoint3DRec): TPoint3DRec;

This item has no description.

Public function Create(X, Y, Z: Extended): TPoint3DRec;

This item has no description.

Public function Distance(const APoint3D: TPoint3DRec): Extended;

distance to origin

Public function Length: Single;

This item has no description.

Public procedure Offset(const ADeltaX, ADeltaY, ADeltaZ: Extended);

This item has no description.

Public procedure SetPosition(const X, Y, Z: Extended);


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TVoxelRec

Record TVoxelRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVoxelRec = record

Description

This item has no description.

Overview

Fields

Public | P: TVector3f;
Public | Density: TScalarValue;
Public | Status: TVoxelStatus;

Description

Fields

Public P: TVector3f;

This item has no description.

Public Density: TScalarValue;

This item has no description.

Public Status: TVoxelStatus;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TVector2DRec

Record TVector2DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVector2DRec = record

Description

This item has no description.

Overview

Fields

Public | V: TVector2DType;
Public | X: Extended;
Public | Y: Extended;
Public | W: Extended;

Methods

Public | function Add(const AVector2D: TVector2DRec): TVector2DRec;
Public | function Create(const AX, AY, AW: Single): TVector2DRec;
Public | function CrossProduct(const AVector: TVector2DRec): TVector2DRec;
Public | function DotProduct(const AVector: TVector2DRec): Extended;
Public | function Length: Extended;
Public | function Norm: Extended;
Public | function Normalize: TVector2DRec;

Description

Fields

Public V: TVector2DType;

This item has no description.

Public X: Extended;

This item has no description.

Public Y: Extended;

This item has no description.

Public W: Extended;

This item has no description.

Methods

Public function Add(const AVector2D: TVector2DRec): TVector2DRec;

This item has no description.

Public function Create(const AX, AY, AW: Single): TVector2DRec;

This item has no description.

Public function CrossProduct(const AVector: TVector2DRec): TVector2DRec;

This item has no description.

Public function DotProduct(const AVector: TVector2DRec): Extended;

This item has no description.

Public function Length: Extended;

This item has no description.

Public function Norm: Extended;

This item has no description.

Public function Normalize: TVector2DRec;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TVector3DRec

Record TVector3DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVector3DRec = record

Description

This item has no description.

Overview

Fields

Public | V: TVector3DType;
Public | X: Extended;
Public | Y: Extended;
Public | Z: Extended;
Public | W: Extended;

Methods

Public | function Add(const AVector3D: TVector3DRec): TVector3DRec;
Public | function Create(const AX, AY, AZ, AW: Single): TVector3DRec;
Public | function CrossProduct(const AVector3D: TVector3D): TVector3D;
Public | function DotProduct(const AVector3D: TVector3D): Single; inline;
Public | function Length: Single;
Public | function Norm: Single;
Public | function Normalize: TVector3DRec;

Description

Fields

Public V: TVector3DType;

This item has no description.

Public X: Extended;

This item has no description.

Public Y: Extended;

This item has no description.

Public Z: Extended;

This item has no description.

Public W: Extended;

This item has no description.

Methods

Public function Add(const AVector3D: TVector3DRec): TVector3DRec;

This item has no description.

Public function Create(const AX, AY, AZ, AW: Single): TVector3DRec;

This item has no description.

Public function CrossProduct(const AVector3D: TVector3D): TVector3D;

This item has no description.

Public function DotProduct(const AVector3D: TVector3D): Single; inline;

This item has no description.

Public function Length: Single;

This item has no description.

Public function Norm: Single;

This item has no description.

Public function Normalize: TVector3DRec;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TMatrix2DRec

Record TMatrix2DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMatrix2DRec = record

Description

This item has no description.

Overview

Fields

Public | M: TMatrix2DType;
Public | e11: Single;
Public | e12: Single;
Public | e13: Single;
Public | e21: Single;
Public | e22: Single;
Public | e23: Single;
Public | e31: Single
Public | e32: Single
Public | e33: Single

Description

Fields

Public M: TMatrix2DType;

This item has no description.

Public e11: Single;

This item has no description.

Public e12: Single;

This item has no description.

Public e13: Single;

This item has no description.

Public e21: Single;

This item has no description.

Public e22: Single;

This item has no description.

Public e23: Single;

This item has no description.

Public e31: Single

This item has no description.

Public e32: Single

This item has no description.

Public e33: Single


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TMatrix3DRec

Record TMatrix3DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMatrix3DRec = record

Description

This item has no description.

Overview

Fields

Public | M: TMatrix3DType;
Public | e11: Single;
Public | e12: Single;
Public | e13: Single;
Public | e14: Single;
Public | e21: Single;
Public | e22: Single;
Public | e23: Single;
Public | e24: Single;
Public | e31: Single;
Public | e32: Single;
Public | e33: Single;
Public | e34: Single;
Public | e41: Single
Public | e42: Single
Public | e43: Single
Public | e44: Single

Description

Fields

Public M: TMatrix3DType;

This item has no description.

Public e11: Single;

This item has no description.

Public e12: Single;

This item has no description.

Public e13: Single;

This item has no description.

Public e14: Single;

This item has no description.

Public e21: Single;

This item has no description.

Public e22: Single;

This item has no description.

Public e23: Single;

This item has no description.

Public e24: Single;

This item has no description.

Public e31: Single;

This item has no description.

Public e32: Single;

This item has no description.

Public e33: Single;

This item has no description.

Public e34: Single;

This item has no description.

Public e41: Single

This item has no description.

Public e42: Single

This item has no description.

Public e43: Single

This item has no description.

Public e44: Single


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TTriangleRec

Record TTriangleRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TTriangleRec = record

Description

This item has no description.

Overview

Fields

Public | V1: Integer;
Public | V2: Integer;
Public | V3: Integer;

Description

Fields

Public V1: Integer;

This item has no description.

Public V2: Integer;

This item has no description.

Public V3: Integer;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TMesh2DVert

Record TMesh2DVert

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMesh2DVert = record

Description

————————– Mesh simple record types ————————–

Overview

Fields

Public | X: Single;
Public | Y: Single;
Public | NX: Single;
Public | NY: Single;
Public | tU: Single;
Public | tV: Single;

Description

Fields

Public X: Single;

This item has no description.

Public Y: Single;

This item has no description.

Public NX: Single;

This item has no description.

Public NY: Single;

This item has no description.

Public tU: Single;

This item has no description.

Public tV: Single;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Packed Record TMesh3DVert

Packed Record TMesh3DVert

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMesh3DVert = packed record

Description

This item has no description.

Overview

Fields

Public | X: Single;
Public | Y: Single;
Public | Z: Single;
Public | NX: Single;
Public | NY: Single;
Public | NZ: Single;
Public | tU: Single;
Public | tV: Single;

Description

Fields

Public X: Single;

This item has no description.

Public Y: Single;

This item has no description.

Public Z: Single;

This item has no description.

Public NX: Single;

This item has no description.

Public NY: Single;

This item has no description.

Public NZ: Single;

This item has no description.

Public tU: Single;

This item has no description.

Public tV: Single;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TQuat3DRec

Record TQuat3DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TQuat3DRec = record

Description

————————– Quaternion simple record types ————————–

Overview

Fields

Public | ImPart: TVector3DRec;
Public | RePart: Single;

Description

Fields

Public ImPart: TVector3DRec;

This item has no description.

Public RePart: Single;


GLSysHelp v.2.5: GLScene.VectorTypesExt: Record TBoxRec

Record TBoxRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TBoxRec = record

Description

This item has no description.

Overview

Fields

Public | ALeft: Single;
Public | ATop: Single;
Public | ANear: Single;
Public | ARight: Single;
Public | ABottom: Single;
Public | AFar: Single;

Description

Fields

Public ALeft: Single;

This item has no description.

Public ATop: Single;

This item has no description.

Public ANear: Single;

This item has no description.

Public ARight: Single;

This item has no description.

Public ABottom: Single;

This item has no description.

Public AFar: Single;


GLSysHelp v.2.5: GLScene.XCollection

Unit GLScene.XCollection

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.Strings
  • GLS.PersistentClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EFilerException |
Class TXCollectionItem |
Class TXCollection |

Functions and Procedures

procedure RegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);
procedure RegisterXCollectionItemClass(aClass: TXCollectionItemClass);
procedure UnregisterXCollectionItemClass(aClass: TXCollectionItemClass);
function FindXCollectionItemClass(const ClassName: string): TXCollectionItemClass;
function GetXCollectionItemClassesList(baseClass: TXCollectionItemClass = nil): TList;
procedure GetXCollectionClassesList(var ClassesList: TList; baseClass: TXCollectionItemClass = nil);

Types

TXCollectionItemClass = class of TXCollectionItem;

Description

Functions and Procedures

procedure RegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);

Registers an event to be called when an XCollection is destroyed

procedure DeRegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);

DeRegisters event

procedure RegisterXCollectionItemClass(aClass: TXCollectionItemClass);

Registers a TXCollectionItem subclass for persistence requirements

procedure UnregisterXCollectionItemClass(aClass: TXCollectionItemClass);

Removes a TXCollectionItem subclass from the list

function FindXCollectionItemClass(const ClassName: string): TXCollectionItemClass;

Retrieves a registered TXCollectionItemClass from its classname

function GetXCollectionItemClassesList(baseClass: TXCollectionItemClass = nil): TList;

Creates and returns a copy of internal list of TXCollectionItem classes. Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.

procedure GetXCollectionClassesList(var ClassesList: TList; baseClass: TXCollectionItemClass = nil);

This item has no description.

Types

TXCollectionItemClass = class of TXCollectionItem;


GLSysHelp v.2.5: GLScene.XCollection: Class EFilerException

Class EFilerException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.XCollection

Declaration

type EFilerException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EFilerException


GLSysHelp v.2.5: GLScene.XCollection: Class TXCollectionItem

Class TXCollectionItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.XCollection

Declaration

type TXCollectionItem = class(TGLInterfacedPersistent)

Description

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem

Overview

Fields

Private | FOwner: TXCollection;
Private | FName: string;

Methods

Public | constructor Create(aOwner: TXCollection); virtual;
Public | destructor Destroy; override;
Public | class function CanAddTo(collection: TXCollection): Boolean; virtual;
Public | class function FriendlyDescription: String; virtual;
Public | class function FriendlyName: String; virtual; abstract;
Public | function GetNamePath: string; override;
Public | function Index: integer;
Public | class function ItemCategory: string; virtual;
Public | class function UniqueItem: Boolean; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure MoveDown;
Public | procedure MoveUp;

Properties

Published | property Name: string read FName write SetName;
Public | property Owner: TXCollection read FOwner;

Description

Fields

Private FOwner: TXCollection;

This item has no description.

Private FName: string;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function CanAddTo(collection: TXCollection): Boolean; virtual;

Allows the XCollectionItem class to determine if it should be allowed to be added to the given collection.

Public class function FriendlyDescription: String; virtual;

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; virtual; abstract;

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function GetNamePath: string; override;

This item has no description.

Public function Index: integer;

This item has no description.

Public class function ItemCategory: string; virtual;

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public class function UniqueItem: Boolean; virtual;

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure MoveDown;

This item has no description.

Public procedure MoveUp;

This item has no description.

Properties

Published property Name: string read FName write SetName;

This item has no description.

Public property Owner: TXCollection read FOwner;


GLSysHelp v.2.5: GLScene.XCollection: Class TXCollection

Class TXCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.XCollection

Declaration

type TXCollection = class(TPersistent)

Description

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection

Overview

Fields

Private | FOwner: TPersistent;
Private | FList: TList;
Private | FCount: integer;
Private | FArchiveVersion: integer;

Methods

Public | constructor Create(aOwner: TPersistent); virtual;
Public | destructor Destroy; override;
Public | function Add(anItem: TXCollectionItem): integer;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; virtual;
Public | function GetByClass(aClass: TXCollectionItemClass): TXCollectionItem;
Public | function GetNamePath: string; override;
Public | function GetOrCreate(anItem: TXCollectionItemClass): TXCollectionItem;
Public | function IndexOf(anItem: TXCollectionItem): integer;
Public | function IndexOfClass(aClass: TXCollectionItemClass): integer;
Public | function IndexOfName(const aName: string): integer;
Public | class function ItemsClass: TXCollectionItemClass; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure Delete(Index: integer);
Public | procedure Loaded;
Public | procedure Remove(anItem: TXCollectionItem);

Properties

Public | property ArchiveVersion: integer read FArchiveVersion;
Public | property Count: integer read FCount;
Public | property Items[index: integer]: TXCollectionItem read GetItems;
Public | property Owner: TPersistent read FOwner write FOwner;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FList: TList;

This item has no description.

Private FCount: integer;

This item has no description.

Private FArchiveVersion: integer;

Archive Version is used to update the way data items is loaded

Methods

Public constructor Create(aOwner: TPersistent); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add(anItem: TXCollectionItem): integer;

This item has no description.

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; virtual;

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public function GetByClass(aClass: TXCollectionItemClass): TXCollectionItem;

Returns the first XCollection of the given class (or nil)

Public function GetNamePath: string; override;

This item has no description.

Public function GetOrCreate(anItem: TXCollectionItemClass): TXCollectionItem;

This item has no description.

Public function IndexOf(anItem: TXCollectionItem): integer;

This item has no description.

Public function IndexOfClass(aClass: TXCollectionItemClass): integer;

Returns the index of the first XCollectionItem of the given class (or -1)

Public function IndexOfName(const aName: string): integer;

Returns the index of the first XCollectionItem of the given name (or -1)

Public class function ItemsClass: TXCollectionItemClass; virtual;

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(Index: integer);

This item has no description.

Public procedure Loaded;

This item has no description.

Public procedure Remove(anItem: TXCollectionItem);

This item has no description.

Properties

Public property ArchiveVersion: integer read FArchiveVersion;

This item has no description.

Public property Count: integer read FCount;

This item has no description.

Public property Items[index: integer]: TXCollectionItem read GetItems;

This item has no description.

Public property Owner: TPersistent read FOwner write FOwner;


GLSysHelp v.2.5: GLSL.AsmShader

Unit GLSL.AsmShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.Texture
  • GLS.Context
  • GLSL.CustomShader
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLAsmShaderParameter |
Class TGLCustomAsmShader |
Class TGLAsmShader |

Types

TGLAsmShaderEvent = procedure(Shader: TGLCustomAsmShader) of object;
TGLAsmShaderUnUplyEvent = procedure(Shader: TGLCustomAsmShader; var ThereAreMorePasses: Boolean) of object;

Description

Types

TGLAsmShaderEvent = procedure(Shader: TGLCustomAsmShader) of object;

This item has no description.

TGLAsmShaderUnUplyEvent = procedure(Shader: TGLCustomAsmShader; var ThereAreMorePasses: Boolean) of object;


GLSysHelp v.2.5: GLSL.AsmShader: Class TGLAsmShaderParameter

Class TGLAsmShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.AsmShader

Declaration

type TGLAsmShaderParameter = class(TGLCustomShaderParameter)

Description

This item has no description. Showing description inherited from TGLCustomShaderParameter.

Wrapper around a parameter of the main program.

Hierarchy

  • TObject
  • TGLCustomShaderParameter
  • TGLAsmShaderParameter


GLSysHelp v.2.5: GLSL.AsmShader: Class TGLCustomAsmShader

Class TGLCustomAsmShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.AsmShader

Declaration

type TGLCustomAsmShader = class(TGLCustomShader)

Description

This item has no description. Showing description inherited from TGLCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomAsmShader

Overview

Fields

Private | FVPHandle: TGLARBVertexProgramHandle;
Private | FFPHandle: TGLARBFragmentProgramHandle;
Private | FGPHandle: TGLARBGeometryProgramHandle;
Private | FOnInitialize: TGLAsmShaderEvent;
Private | FOnApply: TGLAsmShaderEvent;
Private | FOnUnApply: TGLAsmShaderUnUplyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;

Description

Fields

Private FVPHandle: TGLARBVertexProgramHandle;

This item has no description.

Private FFPHandle: TGLARBFragmentProgramHandle;

This item has no description.

Private FGPHandle: TGLARBGeometryProgramHandle;

This item has no description.

Private FOnInitialize: TGLAsmShaderEvent;

This item has no description.

Private FOnApply: TGLAsmShaderEvent;

This item has no description.

Private FOnUnApply: TGLAsmShaderUnUplyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ShaderSupported: Boolean; override;

This item has no description. Showing description inherited from TGLShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public procedure Assign(Source: TPersistent); override;


GLSysHelp v.2.5: GLSL.AsmShader: Class TGLAsmShader

Class TGLAsmShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.AsmShader

Declaration

type TGLAsmShader = class(TGLCustomAsmShader)

Description

This item has no description. Showing description inherited from TGLCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomAsmShader
  • TGLAsmShader

Overview

Properties

Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property GeometryProgram;
Published | property OnApply;
Published | property OnInitialize;
Published | property OnUnApply;
Published | property ShaderStyle;
Published | property VertexProgram;

Description

Properties

Published property FailedInitAction;

This item has no description. Showing description inherited from TGLShader.FailedInitAction.

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Published property FragmentProgram;

This item has no description.

Published property GeometryProgram;

This item has no description.

Published property OnApply;

This item has no description.

Published property OnInitialize;

This item has no description.

Published property OnUnApply;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TGLShader.ShaderStyle.

Shader application style (default is ssLowLevel).

Published property VertexProgram;


GLSysHelp v.2.5: GLSL.BumpShaders

Unit GLSL.BumpShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Material
  • GLS.Graphics
  • GLS.VectorLists
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.State
  • GLScene.TextureFormat
  • GLS.Texture
  • GLS.Scene
  • GLS.Context
  • GLS.Cadencer
  • GLScene.Strings
  • GLSL.Shader
  • GLSL.CustomShader
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLSLBumpShaderException |
Class TGLBaseCustomGLSLBumpShader |
Class TGLBaseCustomGLSLBumpShaderMT |
Class TGLCustomGLSLBumpShaderAM |
Class TGLCustomGLSLBumpShaderMT |
Class TGLCustomGLSLBumpShader |
Class TGLCustomGLSLMLBumpShader |
Class TGLCustomGLSLMLBumpShaderMT |
Class TGLSLBumpShaderMT |
Class TGLSLBumpShader |
Class TGLSLBumpShaderAM |
Class TGLSLMLBumpShader |
Class TGLSLMLBumpShaderMT |
Class TGLBumpShader |

Types

TBumpMethod = (...);
TBumpOption = (...);
TBumpOptions = set of TBumpOption;
TBumpSpace = (...);
TSpecularMode = (...);

Description

Types

TBumpMethod = (...);

This item has no description.

Values
  • bmDot3TexCombiner
  • bmBasicARBFP
TBumpOption = (...);

This item has no description.

Values
  • boDiffuseTexture2
  • boSpecularTexture3: Use secondary texture as diffuse
  • boUseSecondaryTexCoords: Use tertiary texture as specular
  • boLightAttenuation: Pass through secondary texcoords
  • boParallaxMapping: Use light attenuation
TBumpOptions = set of TBumpOption;

Enable parallax offset mapping

TBumpSpace = (...);

This item has no description.

Values
  • bsObject
  • bsTangentExternal
  • bsTangentQuaternion
TSpecularMode = (...);

This item has no description.

Values
  • smOff
  • smBlinn
  • smPhong


GLSysHelp v.2.5: GLSL.BumpShaders: Class EGLSLBumpShaderException

Class EGLSLBumpShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type EGLSLBumpShaderException = class(EGLSLShaderException)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLShaderException
  • EGLCustomShaderException
  • EGLSLShaderException
  • EGLSLBumpShaderException


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLBaseCustomGLSLBumpShader

Class TGLBaseCustomGLSLBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLBaseCustomGLSLBumpShader = class(TGLCustomGLSLShader, IGLMaterialLibrarySupported)

Description

An abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader

Overview

Fields

Private | FBumpHeight: Single;
Private | FBumpSmoothness: Integer;
Private | FSpecularPower: Single;
Private | FSpecularSpread: Single;
Private | FLightPower: Single;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FNormalTexture: TGLTexture;
Private | FSpecularTexture: TGLTexture;
Private | FNormalTextureName: TGLLibMaterialName;
Private | FSpecularTextureName: TGLLibMaterialName;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function GetNormalTextureName: TGLLibMaterialName;
Private | function GetSpecularTextureName: TGLLibMaterialName;
Private | procedure SetNormalTexture(const Value: TGLTexture);
Private | procedure SetNormalTextureName(const Value: TGLLibMaterialName);
Private | procedure SetSpecularTexture(const Value: TGLTexture);
Private | procedure SetSpecularTextureName(const Value: TGLLibMaterialName);

Properties

Public | property BumpHeight: Single read FBumpHeight write FBumpHeight;
Public | property BumpSmoothness: Integer read FBumpSmoothness write FBumpSmoothness;
Public | property LightPower: Single read FLightPower write FLightPower;
Public | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property NormalTexture: TGLTexture read FNormalTexture write SetNormalTexture;
Public | property NormalTextureName: TGLLibMaterialName read GetNormalTextureName write SetNormalTextureName;
Public | property SpecularPower: Single read FSpecularPower write FSpecularPower;
Public | property SpecularSpread: Single read FSpecularSpread write FSpecularSpread;
Public | property SpecularTexture: TGLTexture read FSpecularTexture write SetSpecularTexture;
Public | property SpecularTextureName: TGLLibMaterialName read GetSpecularTextureName write SetSpecularTextureName;

Description

Fields

Private FBumpHeight: Single;

This item has no description.

Private FBumpSmoothness: Integer;

This item has no description.

Private FSpecularPower: Single;

This item has no description.

Private FSpecularSpread: Single;

This item has no description.

Private FLightPower: Single;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FNormalTexture: TGLTexture;

This item has no description.

Private FSpecularTexture: TGLTexture;

This item has no description.

Private FNormalTextureName: TGLLibMaterialName;

This item has no description.

Private FSpecularTextureName: TGLLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Private function GetNormalTextureName: TGLLibMaterialName;

This item has no description.

Private function GetSpecularTextureName: TGLLibMaterialName;

This item has no description.

Private procedure SetNormalTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetNormalTextureName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetSpecularTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetSpecularTextureName(const Value: TGLLibMaterialName);

This item has no description.

Properties

Public property BumpHeight: Single read FBumpHeight write FBumpHeight;

This item has no description.

Public property BumpSmoothness: Integer read FBumpSmoothness write FBumpSmoothness;

This item has no description.

Public property LightPower: Single read FLightPower write FLightPower;

This item has no description.

Public property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property NormalTexture: TGLTexture read FNormalTexture write SetNormalTexture;

This item has no description.

Public property NormalTextureName: TGLLibMaterialName read GetNormalTextureName write SetNormalTextureName;

This item has no description.

Public property SpecularPower: Single read FSpecularPower write FSpecularPower;

This item has no description.

Public property SpecularSpread: Single read FSpecularSpread write FSpecularSpread;

This item has no description.

Public property SpecularTexture: TGLTexture read FSpecularTexture write SetSpecularTexture;

This item has no description.

Public property SpecularTextureName: TGLLibMaterialName read GetSpecularTextureName write SetSpecularTextureName;


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLBaseCustomGLSLBumpShaderMT

Class TGLBaseCustomGLSLBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLBaseCustomGLSLBumpShaderMT = class(TGLBaseCustomGLSLBumpShader)

Description

An abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT

Overview

Fields

Private | FMainTexture: TGLTexture;
Private | FMainTextureName: TGLLibMaterialName;

Methods

Private | function GetMainTextureName: string;
Private | procedure SetMainTextureName(const Value: string);

Properties

Public | property MainTexture: TGLTexture read FMainTexture write FMainTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;

Description

Fields

Private FMainTexture: TGLTexture;

This item has no description.

Private FMainTextureName: TGLLibMaterialName;

This item has no description.

Methods

Private function GetMainTextureName: string;

This item has no description.

Private procedure SetMainTextureName(const Value: string);

This item has no description.

Properties

Public property MainTexture: TGLTexture read FMainTexture write FMainTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLCustomGLSLBumpShaderAM

Class TGLCustomGLSLBumpShaderAM

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLCustomGLSLBumpShaderAM = class(TGLBaseCustomGLSLBumpShaderMT)

Description

One Light shaders.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLBumpShaderAM

Overview

Fields

Private | FAmbientColor: TGLColor;
Private | FDiffuseColor: TGLColor;
Private | FSpecularColor: TGLColor;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetAlpha: Single;
Private | procedure SetAlpha(const Value: Single);

Properties

Public | property Alpha: Single read GetAlpha write SetAlpha;
Public | property AmbientColor: TGLColor read FAmbientColor;
Public | property DiffuseColor: TGLColor read FDiffuseColor;
Public | property SpecularColor: TGLColor read FSpecularColor;

Description

Fields

Private FAmbientColor: TGLColor;

This item has no description.

Private FDiffuseColor: TGLColor;

This item has no description.

Private FSpecularColor: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAlpha: Single;

This item has no description.

Private procedure SetAlpha(const Value: Single);

This item has no description.

Properties

Public property Alpha: Single read GetAlpha write SetAlpha;

This item has no description.

Public property AmbientColor: TGLColor read FAmbientColor;

This item has no description.

Public property DiffuseColor: TGLColor read FDiffuseColor;

This item has no description.

Public property SpecularColor: TGLColor read FSpecularColor;


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLCustomGLSLBumpShaderMT

Class TGLCustomGLSLBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLCustomGLSLBumpShaderMT = class(TGLBaseCustomGLSLBumpShaderMT)

Description

This item has no description. Showing description inherited from TGLBaseCustomGLSLBumpShaderMT.

An abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLBumpShaderMT


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLCustomGLSLBumpShader

Class TGLCustomGLSLBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLCustomGLSLBumpShader = class(TGLBaseCustomGLSLBumpShader, IGLShaderDescription)

Description

This item has no description. Showing description inherited from TGLBaseCustomGLSLBumpShader.

An abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLCustomGLSLBumpShader

Overview

Methods

Private | function GetShaderAlpha: Single;
Private | function GetShaderDescription: string;
Private | procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Private | procedure GetShaderMiscParameters(var ACadencer: TGLCadencer; var AMatLib: TGLMaterialLibrary; var ALightSources: TGLLightSourceSet);
Private | procedure GetShaderTextures(var Textures: array of TGLTexture);
Private | procedure SetShaderAlpha(const Value: Single);
Private | procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Private | procedure SetShaderMiscParameters(const ACadencer: TGLCadencer; const AMatLib: TGLMaterialLibrary; const ALightSources: TGLLightSourceSet);
Private | procedure SetShaderTextures(const Textures: array of TGLTexture);

Description

Methods

Private function GetShaderAlpha: Single;

This item has no description.

Private function GetShaderDescription: string;

This item has no description.

Private procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Private procedure GetShaderMiscParameters(var ACadencer: TGLCadencer; var AMatLib: TGLMaterialLibrary; var ALightSources: TGLLightSourceSet);

This item has no description.

Private procedure GetShaderTextures(var Textures: array of TGLTexture);

This item has no description.

Private procedure SetShaderAlpha(const Value: Single);

This item has no description.

Private procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Private procedure SetShaderMiscParameters(const ACadencer: TGLCadencer; const AMatLib: TGLMaterialLibrary; const ALightSources: TGLLightSourceSet);

This item has no description.

Private procedure SetShaderTextures(const Textures: array of TGLTexture);

Implementing IGLShaderDescription.


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLCustomGLSLMLBumpShader

Class TGLCustomGLSLMLBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLCustomGLSLMLBumpShader = class(TGLBaseCustomGLSLBumpShader, IGLShaderDescription)

Description

MultiLight shaders.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLCustomGLSLMLBumpShader

Overview

Fields

Private | FLightSources: TGLLightSourceSet;
Private | FLightCompensation: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | function GetShaderAlpha: Single;
Private | function GetShaderDescription: string;
Private | procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Private | procedure GetShaderMiscParameters(var ACadencer: TGLCadencer; var AMatLib: TGLMaterialLibrary; var ALightSources: TGLLightSourceSet);
Private | procedure GetShaderTextures(var Textures: array of TGLTexture);
Private | procedure SetLightCompensation(const Value: Single);
Private | procedure SetLightSources(const Value: TGLLightSourceSet);
Private | procedure SetShaderAlpha(const Value: Single);
Private | procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Private | procedure SetShaderMiscParameters(const ACadencer: TGLCadencer; const AMatLib: TGLMaterialLibrary; const ALightSources: TGLLightSourceSet);
Private | procedure SetShaderTextures(const Textures: array of TGLTexture);

Properties

Public | property LightCompensation: Single read FLightCompensation write SetLightCompensation;
Public | property LightSources: TGLLightSourceSet read FLightSources write SetLightSources default [1];

Description

Fields

Private FLightSources: TGLLightSourceSet;

This item has no description.

Private FLightCompensation: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private function GetShaderAlpha: Single;

This item has no description.

Private function GetShaderDescription: string;

This item has no description.

Private procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Private procedure GetShaderMiscParameters(var ACadencer: TGLCadencer; var AMatLib: TGLMaterialLibrary; var ALightSources: TGLLightSourceSet);

This item has no description.

Private procedure GetShaderTextures(var Textures: array of TGLTexture);

This item has no description.

Private procedure SetLightCompensation(const Value: Single);

This item has no description.

Private procedure SetLightSources(const Value: TGLLightSourceSet);

This item has no description.

Private procedure SetShaderAlpha(const Value: Single);

This item has no description.

Private procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Private procedure SetShaderMiscParameters(const ACadencer: TGLCadencer; const AMatLib: TGLMaterialLibrary; const ALightSources: TGLLightSourceSet);

This item has no description.

Private procedure SetShaderTextures(const Textures: array of TGLTexture);

Implementing IGLShaderDescription.

Properties

Public property LightCompensation: Single read FLightCompensation write SetLightCompensation;

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Public property LightSources: TGLLightSourceSet read FLightSources write SetLightSources default [1];


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLCustomGLSLMLBumpShaderMT

Class TGLCustomGLSLMLBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLCustomGLSLMLBumpShaderMT = class(TGLBaseCustomGLSLBumpShaderMT)

Description

This item has no description. Showing description inherited from TGLBaseCustomGLSLBumpShaderMT.

An abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLMLBumpShaderMT

Overview

Fields

Private | FLightSources: TGLLightSourceSet;
Private | FLightCompensation: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | procedure SetLightCompensation(const Value: Single);
Private | procedure SetLightSources(const Value: TGLLightSourceSet);

Properties

Public | property LightCompensation: Single read FLightCompensation write SetLightCompensation;
Public | property LightSources: TGLLightSourceSet read FLightSources write SetLightSources default [1];

Description

Fields

Private FLightSources: TGLLightSourceSet;

This item has no description.

Private FLightCompensation: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private procedure SetLightCompensation(const Value: Single);

This item has no description.

Private procedure SetLightSources(const Value: TGLLightSourceSet);

This item has no description.

Properties

Public property LightCompensation: Single read FLightCompensation write SetLightCompensation;

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Public property LightSources: TGLLightSourceSet read FLightSources write SetLightSources default [1];


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLSLBumpShaderMT

Class TGLSLBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLSLBumpShaderMT = class(TGLCustomGLSLBumpShaderMT)

Description

One light shaders.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLBumpShaderMT
  • TGLSLBumpShaderMT

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightPower;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property LightPower;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLSLBumpShader

Class TGLSLBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLSLBumpShader = class(TGLCustomGLSLBumpShader)

Description

This item has no description. Showing description inherited from TGLBaseCustomGLSLBumpShader.

An abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLCustomGLSLBumpShader
  • TGLSLBumpShader

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightPower;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property LightPower;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLSLBumpShaderAM

Class TGLSLBumpShaderAM

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLSLBumpShaderAM = class(TGLCustomGLSLBumpShaderAM)

Description

This item has no description. Showing description inherited from TGLCustomGLSLBumpShaderAM.

One Light shaders.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLBumpShaderAM
  • TGLSLBumpShaderAM

Overview

Properties

Published | property Alpha stored False;
Published | property AmbientColor;
Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property DiffuseColor;
Published | property LightPower;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularColor;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property Alpha stored False;

This item has no description.

Published property AmbientColor;

This item has no description.

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property DiffuseColor;

This item has no description.

Published property LightPower;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularColor;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLSLMLBumpShader

Class TGLSLMLBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLSLMLBumpShader = class(TGLCustomGLSLMLBumpShader)

Description

Multi light shaders.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLCustomGLSLMLBumpShader
  • TGLSLMLBumpShader

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightCompensation;
Published | property LightPower;
Published | property LightSources;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property LightCompensation;

This item has no description. Showing description inherited from TGLCustomGLSLMLBumpShader.LightCompensation.

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Published property LightPower;

This item has no description.

Published property LightSources;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLSLMLBumpShaderMT

Class TGLSLMLBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLSLMLBumpShaderMT = class(TGLCustomGLSLMLBumpShaderMT)

Description

This item has no description. Showing description inherited from TGLBaseCustomGLSLBumpShaderMT.

An abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLMLBumpShaderMT
  • TGLSLMLBumpShaderMT

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightCompensation;
Published | property LightPower;
Published | property LightSources;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property LightCompensation;

This item has no description. Showing description inherited from TGLCustomGLSLMLBumpShaderMT.LightCompensation.

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Published property LightPower;

This item has no description.

Published property LightSources;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GLSysHelp v.2.5: GLSL.BumpShaders: Class TGLBumpShader

Class TGLBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.BumpShaders

Declaration

type TGLBumpShader = class(TGLShader)

Description

A generic bump shader.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLBumpShader

Overview

Fields

Private | FVertexProgramHandle: TGLARBVertexProgramHandle;
Private | FFragmentProgramHandle: TGLARBFragmentProgramHandle;
Private | FLightIDs: TGLIntegerList;
Private | FLightsEnabled: Integer;
Private | FBumpMethod: TBumpMethod;
Private | FBumpSpace: TBumpSpace;
Private | FBumpOptions: TBumpOptions;
Private | FSpecularMode: TSpecularMode;
Private | FDesignTimeEnabled: Boolean;
Private | FAmbientPass: Boolean;
Private | FDiffusePass: Boolean;
Private | FVertexProgram: TStringList;
Private | FFragmentProgram: TStringList;
Private | FParallaxOffset: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function DoUnApply(var rci: TGLRenderContextInfo): Boolean; override;
Private | function GenerateFragmentProgram: string;
Private | function GenerateVertexProgram: string;
Public | procedure DoApply(var rci: TGLRenderContextInfo; Sender: TObject); override;
Private | procedure DoLightPass(var rci: TGLRenderContextInfo; lightID: Cardinal);

Properties

Published | property BumpMethod: TBumpMethod read FBumpMethod write SetBumpMethod;
Published | property BumpOptions: TBumpOptions read FBumpOptions write SetBumpOptions;
Published | property BumpSpace: TBumpSpace read FBumpSpace write SetBumpSpace;
Published | property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;
Published | property ParallaxOffset: Single read FParallaxOffset write SetParallaxOffset;
Published | property SpecularMode: TSpecularMode read FSpecularMode write SetSpecularMode;

Description

Fields

Private FVertexProgramHandle: TGLARBVertexProgramHandle;

This item has no description.

Private FFragmentProgramHandle: TGLARBFragmentProgramHandle;

This item has no description.

Private FLightIDs: TGLIntegerList;

This item has no description.

Private FLightsEnabled: Integer;

This item has no description.

Private FBumpMethod: TBumpMethod;

This item has no description.

Private FBumpSpace: TBumpSpace;

This item has no description.

Private FBumpOptions: TBumpOptions;

This item has no description.

Private FSpecularMode: TSpecularMode;

This item has no description.

Private FDesignTimeEnabled: Boolean;

This item has no description.

Private FAmbientPass: Boolean;

This item has no description.

Private FDiffusePass: Boolean;

This item has no description.

Private FVertexProgram: TStringList;

This item has no description.

Private FFragmentProgram: TStringList;

This item has no description.

Private FParallaxOffset: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DoUnApply(var rci: TGLRenderContextInfo): Boolean; override;

This item has no description.

Private function GenerateFragmentProgram: string;

This item has no description.

Private function GenerateVertexProgram: string;

This item has no description.

Public procedure DoApply(var rci: TGLRenderContextInfo; Sender: TObject); override;

This item has no description.

Private procedure DoLightPass(var rci: TGLRenderContextInfo; lightID: Cardinal);

This item has no description.

Properties

Published property BumpMethod: TBumpMethod read FBumpMethod write SetBumpMethod;

This item has no description.

Published property BumpOptions: TBumpOptions read FBumpOptions write SetBumpOptions;

This item has no description.

Published property BumpSpace: TBumpSpace read FBumpSpace write SetBumpSpace;

This item has no description.

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;

This item has no description.

Published property ParallaxOffset: Single read FParallaxOffset write SetParallaxOffset;

This item has no description.

Published property SpecularMode: TSpecularMode read FSpecularMode write SetSpecularMode;


GLSysHelp v.2.5: GLSL.CustomShader

Unit GLSL.CustomShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.OpenGLTokens
  • GLScene.TextureFormat
  • GLScene.Strings
  • GLS.Texture
  • GLS.Cadencer
  • GLS.Scene
  • GLS.Context
  • GLS.RenderContextInfo
  • GLS.Material
  • GLS.VectorLists
  • GLSL.ShaderParameter

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLCustomShaderException |
Interface IGLShaderDescription |
Interface IGLPostShader |
Class TGLCustomShader |
Class TGLShaderProgram |
Class TGLVertexProgram |
Class TGLFragmentProgram |
Class TGLGeometryProgram |
Class TGLCustomShaderParameter |

Functions and Procedures

procedure ApplyBlendingModeEx(const BlendingMode: TGLBlendingModeEx);
procedure UnApplyBlendingModeEx;
procedure InitTexture( const TextureHandle: Cardinal; const TextureSize: TGLSize; const TextureTarget: TGLTextureTarget = ttTexture2D);
procedure DrawTexturedScreenQuad;
procedure DrawTexturedScreenQuad2(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad3;
procedure DrawTexturedScreenQuad4(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad5(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad6(const ViewPortSize: TGLSize);
procedure CopyScreentoTexture(const ViewPortSize: TGLSize; const TextureTarget: Word = GL_TEXTURE_2D);
procedure CopyScreentoTexture2(const ViewPortSize: TGLSize; const TextureTarget: Word = GL_TEXTURE_2D);
function IsFogEnabled(const AFogSupportMode: TGLShaderFogSupport; var rci: TGLRenderContextInfo): Boolean;
procedure GetActiveLightsList(const ALightIDs: TGLIntegerList);

Types

TGLBlendingModeEx = (...);
TGLLightSourceEnum = 1..glsShaderMaxLightSources;
TGLLightSourceSet = set of TGLLightSourceEnum;
TGLShaderEvent = procedure(Shader: TGLCustomShader) of object;
TGLShaderFogSupport = (...);
TGLShaderUnAplyEvent = procedure(Shader: TGLCustomShader; var ThereAreMorePasses: Boolean) of object;
TGLTransformFeedBackMode = (...);

Constants

glsShaderMaxLightSources = 8;

Description

Functions and Procedures

procedure ApplyBlendingModeEx(const BlendingMode: TGLBlendingModeEx);

Exported procedures.

procedure UnApplyBlendingModeEx;

This item has no description.

procedure InitTexture( const TextureHandle: Cardinal; const TextureSize: TGLSize; const TextureTarget: TGLTextureTarget = ttTexture2D);

This item has no description.

procedure DrawTexturedScreenQuad;

Probably need to give them proper names, instead of numbers...

procedure DrawTexturedScreenQuad2(const ViewPortSize: TGLSize);

This item has no description.

procedure DrawTexturedScreenQuad3;

This item has no description.

procedure DrawTexturedScreenQuad4(const ViewPortSize: TGLSize);

This item has no description.

procedure DrawTexturedScreenQuad5(const ViewPortSize: TGLSize);

This item has no description.

procedure DrawTexturedScreenQuad6(const ViewPortSize: TGLSize);

This item has no description.

procedure CopyScreentoTexture(const ViewPortSize: TGLSize; const TextureTarget: Word = GL_TEXTURE_2D);

This item has no description.

procedure CopyScreentoTexture2(const ViewPortSize: TGLSize; const TextureTarget: Word = GL_TEXTURE_2D);

This item has no description.

function IsFogEnabled(const AFogSupportMode: TGLShaderFogSupport; var rci: TGLRenderContextInfo): Boolean;

This item has no description.

procedure GetActiveLightsList(const ALightIDs: TGLIntegerList);

This item has no description.

Types

TGLBlendingModeEx = (...);

Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.

Values
  • bmxOpaque
  • bmxTransparency
  • bmxAdditive
  • bmxAlphaTest50
  • bmxAlphaTest100
  • bmxModulate
  • bmxDestColorOne
  • bmxDestAlphaOne
TGLLightSourceEnum = 1..glsShaderMaxLightSources;

This item has no description.

TGLLightSourceSet = set of TGLLightSourceEnum;

This item has no description.

TGLShaderEvent = procedure(Shader: TGLCustomShader) of object;

This item has no description.

TGLShaderFogSupport = (...);

This item has no description.

Values
  • sfsEnabled
  • sfsDisabled
  • sfsAuto
TGLShaderUnAplyEvent = procedure(Shader: TGLCustomShader; var ThereAreMorePasses: Boolean) of object;

This item has no description.

TGLTransformFeedBackMode = (...);

This item has no description.

Values
  • tfbmInterleaved
  • tfbmSeparate

Constants

glsShaderMaxLightSources = 8;


GLSysHelp v.2.5: GLSL.CustomShader: Class EGLCustomShaderException

Class EGLCustomShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type EGLCustomShaderException = class(EGLShaderException)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLShaderException
  • EGLCustomShaderException


GLSysHelp v.2.5: GLSL.CustomShader: Interface IGLShaderDescription

Interface IGLShaderDescription

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type IGLShaderDescription = interface(IInterface)

Description

This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.

Attributes
GUID['{04089C64-60C2-43F5-AC9C-38ED46264812}']

Hierarchy

  • IInterface
  • IGLShaderDescription

Overview

Methods

Public | function GetShaderAlpha: Single;
Public | function GetShaderDescription: string;
Public | procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Public | procedure GetShaderMiscParameters(var ACadencer: TGLCadencer; var AMatLib: TGLMaterialLibrary; var ALightSources: TGLLightSourceSet);
Public | procedure GetShaderTextures(var Textures: array of TGLTexture);
Public | procedure SetShaderAlpha(const Value: Single);
Public | procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Public | procedure SetShaderMiscParameters(const ACadencer: TGLCadencer; const AMatLib: TGLMaterialLibrary; const ALightSources: TGLLightSourceSet);
Public | procedure SetShaderTextures(const Textures: array of TGLTexture);

Description

Methods

Public function GetShaderAlpha: Single;

This item has no description.

Public function GetShaderDescription: string;

This item has no description.

Public procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Public procedure GetShaderMiscParameters(var ACadencer: TGLCadencer; var AMatLib: TGLMaterialLibrary; var ALightSources: TGLLightSourceSet);

This item has no description.

Public procedure GetShaderTextures(var Textures: array of TGLTexture);

This item has no description.

Public procedure SetShaderAlpha(const Value: Single);

This item has no description.

Public procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Public procedure SetShaderMiscParameters(const ACadencer: TGLCadencer; const AMatLib: TGLMaterialLibrary; const ALightSources: TGLLightSourceSet);

This item has no description.

Public procedure SetShaderTextures(const Textures: array of TGLTexture);


GLSysHelp v.2.5: GLSL.CustomShader: Interface IGLPostShader

Interface IGLPostShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type IGLPostShader = interface(IInterface)

Description

Used in the TGLPostShaderHolder component.

Attributes
GUID['{68A62362-AF0A-4CE8-A9E1-714FE02AFA4A}']

Hierarchy

  • IInterface
  • IGLPostShader

Overview

Methods

Public | function GetTextureTarget: TGLTextureTarget;
Public | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle; TextureTarget: TGLTextureTarget);

Description

Methods

Public function GetTextureTarget: TGLTextureTarget;

Called to determine if it is compatible.

Public procedure DoUseTempTexture(const TempTexture: TGLTextureHandle; TextureTarget: TGLTextureTarget);

Called on every pass.


GLSysHelp v.2.5: GLSL.CustomShader: Class TGLCustomShader

Class TGLCustomShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type TGLCustomShader = class(TGLShader)

Description

A pure abstract class, must be overriden.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader

Overview

Fields

Private | FFragmentProgram: TGLFragmentProgram;
Private | FVertexProgram: TGLVertexProgram;
Private | FGeometryProgram: TGLGeometryProgram;
Private | FTagObject: TObject;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function StoreFragmentProgram: Boolean;
Private | function StoreGeometryProgram: Boolean;
Private | function StoreVertexProgram: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadShaderPrograms(const VPFilename, FPFilename: string; const GPFilename: string = '');
Private | procedure SetFragmentProgram(const Value: TGLFragmentProgram);
Private | procedure SetGeometryProgram(const Value: TGLGeometryProgram);
Private | procedure SetVertexProgram(const Value: TGLVertexProgram);

Description

Fields

Private FFragmentProgram: TGLFragmentProgram;

This item has no description.

Private FVertexProgram: TGLVertexProgram;

This item has no description.

Private FGeometryProgram: TGLGeometryProgram;

This item has no description.

Private FTagObject: TObject;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function StoreFragmentProgram: Boolean;

This item has no description.

Private function StoreGeometryProgram: Boolean;

This item has no description.

Private function StoreVertexProgram: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadShaderPrograms(const VPFilename, FPFilename: string; const GPFilename: string = '');

This item has no description.

Private procedure SetFragmentProgram(const Value: TGLFragmentProgram);

This item has no description.

Private procedure SetGeometryProgram(const Value: TGLGeometryProgram);

This item has no description.

Private procedure SetVertexProgram(const Value: TGLVertexProgram);


GLSysHelp v.2.5: GLSL.CustomShader: Class TGLShaderProgram

Class TGLShaderProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type TGLShaderProgram = class(TPersistent)

Description

A custom shader program.

Hierarchy

  • TObject
  • TPersistent
  • TGLShaderProgram

Overview

Fields

Private | FParent: TGLCustomShader;
Private | FEnabled: Boolean;
Private | FCode: TStrings;

Methods

Public | constructor Create(const AParent: TGLCustomShader); virtual;
Public | destructor Destroy; override;
Public | procedure Apply; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const AFileName: string);
Private | procedure OnChangeCode(Sender: TObject);
Private | procedure SetCode(const Value: TStrings);
Private | procedure SetEnabled(const Value: Boolean);

Properties

Published | property Code: TStrings read FCode write SetCode;
Published | property Enabled: Boolean read FEnabled write SetEnabled default False;

Description

Fields

Private FParent: TGLCustomShader;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FCode: TStrings;

This item has no description.

Methods

Public constructor Create(const AParent: TGLCustomShader); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply; virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const AFileName: string);

This item has no description.

Private procedure OnChangeCode(Sender: TObject);

This item has no description.

Private procedure SetCode(const Value: TStrings);

This item has no description.

Private procedure SetEnabled(const Value: Boolean);

This item has no description.

Properties

Published property Code: TStrings read FCode write SetCode;

This item has no description.

Published property Enabled: Boolean read FEnabled write SetEnabled default False;


GLSysHelp v.2.5: GLSL.CustomShader: Class TGLVertexProgram

Class TGLVertexProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type TGLVertexProgram = class(TGLShaderProgram)

Description

This item has no description. Showing description inherited from TGLShaderProgram.

A custom shader program.

Hierarchy

  • TObject
  • TPersistent
  • TGLShaderProgram
  • TGLVertexProgram

Overview

Properties

Published | property Code;
Published | property Enabled;

Description

Properties

Published property Code;

This item has no description.

Published property Enabled;


GLSysHelp v.2.5: GLSL.CustomShader: Class TGLFragmentProgram

Class TGLFragmentProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type TGLFragmentProgram = class(TGLShaderProgram)

Description

This item has no description. Showing description inherited from TGLShaderProgram.

A custom shader program.

Hierarchy

  • TObject
  • TPersistent
  • TGLShaderProgram
  • TGLFragmentProgram

Overview

Properties

Published | property Code;
Published | property Enabled;

Description

Properties

Published property Code;

This item has no description.

Published property Enabled;


GLSysHelp v.2.5: GLSL.CustomShader: Class TGLGeometryProgram

Class TGLGeometryProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type TGLGeometryProgram = class(TGLShaderProgram)

Description

This item has no description. Showing description inherited from TGLShaderProgram.

A custom shader program.

Hierarchy

  • TObject
  • TPersistent
  • TGLShaderProgram
  • TGLGeometryProgram

Overview

Fields

Private | FInputPrimitiveType: TGLgsInTypes;
Private | FOutputPrimitiveType: TGLgsOutTypes;
Private | FVerticesOut: TGLint;

Methods

Public | constructor Create(const AParent: TGLCustomShader); override;
Private | procedure SetInputPrimitiveType(const Value: TGLgsInTypes);
Private | procedure SetOutputPrimitiveType(const Value: TGLgsOutTypes);
Private | procedure SetVerticesOut(const Value: TGLint);

Properties

Published | property Code;
Published | property Enabled;
Published | property InputPrimitiveType: TGLgsInTypes read FInputPrimitiveType write SetInputPrimitiveType default gsInPoints;
Published | property OutputPrimitiveType: TGLgsOutTypes read FOutputPrimitiveType write SetOutputPrimitiveType default gsOutPoints;
Published | property VerticesOut: TGLint read FVerticesOut write SetVerticesOut default 0;

Description

Fields

Private FInputPrimitiveType: TGLgsInTypes;

This item has no description.

Private FOutputPrimitiveType: TGLgsOutTypes;

This item has no description.

Private FVerticesOut: TGLint;

This item has no description.

Methods

Public constructor Create(const AParent: TGLCustomShader); override;

This item has no description.

Private procedure SetInputPrimitiveType(const Value: TGLgsInTypes);

This item has no description.

Private procedure SetOutputPrimitiveType(const Value: TGLgsOutTypes);

This item has no description.

Private procedure SetVerticesOut(const Value: TGLint);

This item has no description.

Properties

Published property Code;

This item has no description.

Published property Enabled;

This item has no description.

Published property InputPrimitiveType: TGLgsInTypes read FInputPrimitiveType write SetInputPrimitiveType default gsInPoints;

This item has no description.

Published property OutputPrimitiveType: TGLgsOutTypes read FOutputPrimitiveType write SetOutputPrimitiveType default gsOutPoints;

This item has no description.

Published property VerticesOut: TGLint read FVerticesOut write SetVerticesOut default 0;


GLSysHelp v.2.5: GLSL.CustomShader: Class TGLCustomShaderParameter

Class TGLCustomShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.CustomShader

Declaration

type TGLCustomShaderParameter = class(TObject)

Description

Wrapper around a parameter of the main program.

Hierarchy

  • TObject
  • TGLCustomShaderParameter

Overview

Methods

Public | procedure SetAsVectorF(const Values: array of Single); overload;
Public | procedure SetAsVectorI(const Values: array of Integer); overload;
Public | procedure SetToTextureOf(const Texture: TGLTexture; const TextureIndex: Integer); overload;
Public | procedure SetToTextureOf(const LibMaterial: TGLLibMaterial; const TextureIndex: Integer); overload;

Properties

Public | property AsAffineVector: TAffineVector read GetAsVector3f write SetAsVector3f;
Public | property AsCustomTexture[const TextureIndex: Integer; TextureTarget: TGLTextureTarget]: Cardinal read GetAsCustomTexture write SetAsCustomTexture;
Public | property AsFloat: Single read GetAsVector1f write SetAsVector1f;
Public | property AsInteger: Integer read GetAsVector1i write SetAsVector1i;
Public | property AsMatrix2f: TMatrix2f read GetAsMatrix2f write SetAsMatrix2f;
Public | property AsMatrix3f: TMatrix3f read GetAsMatrix3f write SetAsMatrix3f;
Public | property AsMatrix4f: TMatrix4f read GetAsMatrix4f write SetAsMatrix4f;
Public | property AsTexture [const TextureIndex: Integer]: TGLTexture write SetAsTexture;
Public | property AsTexture1D [const TextureIndex: Integer]: TGLTexture write SetAsTexture1D;
Public | property AsTexture2D [const TextureIndex: Integer]: TGLTexture write SetAsTexture2D;
Public | property AsTexture3D [const TextureIndex: Integer]: TGLTexture write SetAsTexture3D;
Public | property AsTextureCube[const TextureIndex: Integer]: TGLTexture write SetAsTextureCube;
Public | property AsTextureRect[const TextureIndex: Integer]: TGLTexture write SetAsTextureRect;
Public | property AsUniformBuffer: Cardinal read GetAsUniformBuffer write SetAsUniformBuffer;
Public | property AsVector: TGLVector read GetAsVector4f write SetAsVector4f;
Public | property AsVector1f: Single read GetAsVector1f write SetAsVector1f;
Public | property AsVector1i: Integer read GetAsVector1i write SetAsVector1i;
Public | property AsVector1ui: Cardinal read GetAsVector1ui write SetAsVector1ui;
Public | property AsVector2f: TVector2f read GetAsVector2f write SetAsVector2f;
Public | property AsVector2i: TVector2i read GetAsVector2i write SetAsVector2i;
Public | property AsVector2ui: TVector2ui read GetAsVector2ui write SetAsVector2ui;
Public | property AsVector3f: TVector3f read GetAsVector3f write SetAsVector3f;
Public | property AsVector3i: TVector3i read GetAsVector3i write SetAsVector3i;
Public | property AsVector3ui: TVector3ui read GetAsVector3ui write SetAsVector3ui;
Public | property AsVector4f: TVector4f read GetAsVector4f write SetAsVector4f;
Public | property AsVector4i: TVector4i read GetAsVector4i write SetAsVector4i;
Public | property AsVector4ui: TVector4ui read GetAsVector4ui write SetAsVector4ui;

Description

Methods

Public procedure SetAsVectorF(const Values: array of Single); overload;

This overloaded SetAsVector accepts open array as input. e.g. SetAsVectorF([0.1, 0.2]). Array length must between 1-4.

Public procedure SetAsVectorI(const Values: array of Integer); overload;

This item has no description.

Public procedure SetToTextureOf(const Texture: TGLTexture; const TextureIndex: Integer); overload;

This item has no description.

Public procedure SetToTextureOf(const LibMaterial: TGLLibMaterial; const TextureIndex: Integer); overload;

SetToTextureOf determines texture type on-the-fly.

Properties

Public property AsAffineVector: TAffineVector read GetAsVector3f write SetAsVector3f;

This item has no description.

Public property AsCustomTexture[const TextureIndex: Integer; TextureTarget: TGLTextureTarget]: Cardinal read GetAsCustomTexture write SetAsCustomTexture;

This item has no description.

Public property AsFloat: Single read GetAsVector1f write SetAsVector1f;

Standard types.

Public property AsInteger: Integer read GetAsVector1i write SetAsVector1i;

This item has no description.

Public property AsMatrix2f: TMatrix2f read GetAsMatrix2f write SetAsMatrix2f;

Matrix Types.

Public property AsMatrix3f: TMatrix3f read GetAsMatrix3f write SetAsMatrix3f;

This item has no description.

Public property AsMatrix4f: TMatrix4f read GetAsMatrix4f write SetAsMatrix4f;

This item has no description.

Public property AsTexture [const TextureIndex: Integer]: TGLTexture write SetAsTexture;

Texture Types.

Public property AsTexture1D [const TextureIndex: Integer]: TGLTexture write SetAsTexture1D;

This item has no description.

Public property AsTexture2D [const TextureIndex: Integer]: TGLTexture write SetAsTexture2D;

This item has no description.

Public property AsTexture3D [const TextureIndex: Integer]: TGLTexture write SetAsTexture3D;

This item has no description.

Public property AsTextureCube[const TextureIndex: Integer]: TGLTexture write SetAsTextureCube;

This item has no description.

Public property AsTextureRect[const TextureIndex: Integer]: TGLTexture write SetAsTextureRect;

This item has no description.

Public property AsUniformBuffer: Cardinal read GetAsUniformBuffer write SetAsUniformBuffer;

This item has no description.

Public property AsVector: TGLVector read GetAsVector4f write SetAsVector4f;

GLScene-friendly properties.

Public property AsVector1f: Single read GetAsVector1f write SetAsVector1f;

Float vector types.

Public property AsVector1i: Integer read GetAsVector1i write SetAsVector1i;

Integer vector types.

Public property AsVector1ui: Cardinal read GetAsVector1ui write SetAsVector1ui;

Unsigned integer vector types.

Public property AsVector2f: TVector2f read GetAsVector2f write SetAsVector2f;

This item has no description.

Public property AsVector2i: TVector2i read GetAsVector2i write SetAsVector2i;

This item has no description.

Public property AsVector2ui: TVector2ui read GetAsVector2ui write SetAsVector2ui;

This item has no description.

Public property AsVector3f: TVector3f read GetAsVector3f write SetAsVector3f;

This item has no description.

Public property AsVector3i: TVector3i read GetAsVector3i write SetAsVector3i;

This item has no description.

Public property AsVector3ui: TVector3ui read GetAsVector3ui write SetAsVector3ui;

This item has no description.

Public property AsVector4f: TVector4f read GetAsVector4f write SetAsVector4f;

This item has no description.

Public property AsVector4i: TVector4i read GetAsVector4i write SetAsVector4i;

This item has no description.

Public property AsVector4ui: TVector4ui read GetAsVector4ui write SetAsVector4ui;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader

Unit GLSL.DiffuseSpecularShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.Texture
  • GLS.Scene
  • GLS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLSL.Shader
  • GLSL.CustomShader
  • GLS.Color
  • GLS.RenderContextInfo
  • GLS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLSLDiffuseSpecularShaderException |
Class TGLBaseCustomGLSLDiffuseSpecular |
Class TGLBaseGLSLDiffuseSpecularShaderMT |
Class TGLCustomGLSLDiffuseSpecularShader |
Class TGLCustomGLSLDiffuseSpecularShaderMT |
Record TLightRecord |
Class TGLCustomGLSLMLDiffuseSpecularShader |
Class TGLCustomGLSLMLDiffuseSpecularShaderMT |
Class TGLSLDiffuseSpecularShaderMT |
Class TGLSLDiffuseSpecularShader |
Class TGLSLMLDiffuseSpecularShaderMT |
Class TGLSLMLDiffuseSpecularShader |


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class EGLSLDiffuseSpecularShaderException

Class EGLSLDiffuseSpecularShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type EGLSLDiffuseSpecularShaderException = class(EGLSLShaderException)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLShaderException
  • EGLCustomShaderException
  • EGLSLShaderException
  • EGLSLDiffuseSpecularShaderException


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLBaseCustomGLSLDiffuseSpecular

Class TGLBaseCustomGLSLDiffuseSpecular

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLBaseCustomGLSLDiffuseSpecular = class(TGLCustomGLSLShader)

Description

Abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular

Overview

Fields

Private | FLightPower: Single;
Private | FRealisticSpecular: Boolean;
Private | FFogSupport: TGLShaderFogSupport;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | procedure SetFogSupport(const Value: TGLShaderFogSupport);
Private | procedure SetRealisticSpecular(const Value: Boolean);

Properties

Public | property FogSupport: TGLShaderFogSupport read FFogSupport write SetFogSupport default sfsAuto;
Public | property LightPower: Single read FLightPower write FLightPower;
Public | property RealisticSpecular: Boolean read FRealisticSpecular write SetRealisticSpecular;

Description

Fields

Private FLightPower: Single;

This item has no description.

Private FRealisticSpecular: Boolean;

This item has no description.

Private FFogSupport: TGLShaderFogSupport;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private procedure SetFogSupport(const Value: TGLShaderFogSupport);

This item has no description.

Private procedure SetRealisticSpecular(const Value: Boolean);

This item has no description.

Properties

Public property FogSupport: TGLShaderFogSupport read FFogSupport write SetFogSupport default sfsAuto;

User can disable fog support and save some FPS if he doesn't need it.

Public property LightPower: Single read FLightPower write FLightPower;

This item has no description.

Public property RealisticSpecular: Boolean read FRealisticSpecular write SetRealisticSpecular;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLBaseGLSLDiffuseSpecularShaderMT

Class TGLBaseGLSLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLBaseGLSLDiffuseSpecularShaderMT = class(TGLBaseCustomGLSLDiffuseSpecular, IGLMaterialLibrarySupported)

Description

Abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT

Overview

Fields

Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FMainTexture: TGLTexture;
Private | FMainTextureName: TGLLibMaterialName;

Methods

Private | function GetMainTextureName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | procedure SetMainTextureName(const Value: TGLLibMaterialName);

Properties

Public | property MainTexture: TGLTexture read FMainTexture write FMainTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;
Public | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Fields

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FMainTexture: TGLTexture;

This item has no description.

Private FMainTextureName: TGLLibMaterialName;

This item has no description.

Methods

Private function GetMainTextureName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Private procedure SetMainTextureName(const Value: TGLLibMaterialName);

This item has no description.

Properties

Public property MainTexture: TGLTexture read FMainTexture write FMainTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;

This item has no description.

Public property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLCustomGLSLDiffuseSpecularShader

Class TGLCustomGLSLDiffuseSpecularShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLCustomGLSLDiffuseSpecularShader = class(TGLBaseCustomGLSLDiffuseSpecular)

Description

******** Single Light ************

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLCustomGLSLDiffuseSpecularShader


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLCustomGLSLDiffuseSpecularShaderMT

Class TGLCustomGLSLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLCustomGLSLDiffuseSpecularShaderMT = class(TGLBaseGLSLDiffuseSpecularShaderMT)

Description

This item has no description. Showing description inherited from TGLBaseGLSLDiffuseSpecularShaderMT.

Abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLDiffuseSpecularShaderMT


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Record TLightRecord

Record TLightRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TLightRecord = record

Description

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas

Overview

Fields

Public | Enabled: Boolean;
Public | Style: TGLLightStyle;

Description

Fields

Public Enabled: Boolean;

This item has no description.

Public Style: TGLLightStyle;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLCustomGLSLMLDiffuseSpecularShader

Class TGLCustomGLSLMLDiffuseSpecularShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLCustomGLSLMLDiffuseSpecularShader = class(TGLBaseCustomGLSLDiffuseSpecular)

Description

This item has no description. Showing description inherited from TGLBaseCustomGLSLDiffuseSpecular.

Abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLCustomGLSLMLDiffuseSpecularShader

Overview

Fields

Private FLightTrace: array[0..7] of TLightRecord;

Methods

Public constructor Create(AOwner : TComponent); override;

Description

Fields

Private FLightTrace: array[0..7] of TLightRecord;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLCustomGLSLMLDiffuseSpecularShaderMT

Class TGLCustomGLSLMLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLCustomGLSLMLDiffuseSpecularShaderMT = class(TGLBaseGLSLDiffuseSpecularShaderMT)

Description

This item has no description. Showing description inherited from TGLBaseGLSLDiffuseSpecularShaderMT.

Abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLMLDiffuseSpecularShaderMT

Overview

Fields

Private FLightTrace: array[0..7] of TLightRecord;

Methods

Public constructor Create(AOwner : TComponent); override;

Description

Fields

Private FLightTrace: array[0..7] of TLightRecord;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLSLDiffuseSpecularShaderMT

Class TGLSLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLSLDiffuseSpecularShaderMT = class(TGLCustomGLSLDiffuseSpecularShaderMT)

Description

******** Published Stuff ************

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLDiffuseSpecularShaderMT
  • TGLSLDiffuseSpecularShaderMT

Overview

Properties

Published | property FogSupport;
Published | property LightPower;
Published | property MainTextureName;

Description

Properties

Published property FogSupport;

This item has no description. Showing description inherited from TGLBaseCustomGLSLDiffuseSpecular.FogSupport.

User can disable fog support and save some FPS if he doesn't need it.

Published property LightPower;

This item has no description.

Published property MainTextureName;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLSLDiffuseSpecularShader

Class TGLSLDiffuseSpecularShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLSLDiffuseSpecularShader = class(TGLCustomGLSLDiffuseSpecularShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLDiffuseSpecularShader.

******** Single Light ************

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLCustomGLSLDiffuseSpecularShader
  • TGLSLDiffuseSpecularShader

Overview

Properties

Published | property FogSupport;
Published | property LightPower;

Description

Properties

Published property FogSupport;

This item has no description. Showing description inherited from TGLBaseCustomGLSLDiffuseSpecular.FogSupport.

User can disable fog support and save some FPS if he doesn't need it.

Published property LightPower;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLSLMLDiffuseSpecularShaderMT

Class TGLSLMLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLSLMLDiffuseSpecularShaderMT = class(TGLCustomGLSLMLDiffuseSpecularShaderMT)

Description

This item has no description. Showing description inherited from TGLBaseGLSLDiffuseSpecularShaderMT.

Abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLMLDiffuseSpecularShaderMT
  • TGLSLMLDiffuseSpecularShaderMT

Overview

Properties

Published | property FogSupport;
Published | property LightPower;
Published | property MainTextureName;

Description

Properties

Published property FogSupport;

This item has no description. Showing description inherited from TGLBaseCustomGLSLDiffuseSpecular.FogSupport.

User can disable fog support and save some FPS if he doesn't need it.

Published property LightPower;

This item has no description.

Published property MainTextureName;


GLSysHelp v.2.5: GLSL.DiffuseSpecularShader: Class TGLSLMLDiffuseSpecularShader

Class TGLSLMLDiffuseSpecularShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.DiffuseSpecularShader

Declaration

type TGLSLMLDiffuseSpecularShader = class(TGLCustomGLSLMLDiffuseSpecularShader)

Description

This item has no description. Showing description inherited from TGLBaseCustomGLSLDiffuseSpecular.

Abstract class.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLCustomGLSLMLDiffuseSpecularShader
  • TGLSLMLDiffuseSpecularShader

Overview

Properties

Published | property FogSupport;
Published | property LightPower;

Description

Properties

Published property FogSupport;

This item has no description. Showing description inherited from TGLBaseCustomGLSLDiffuseSpecular.FogSupport.

User can disable fog support and save some FPS if he doesn't need it.

Published property LightPower;


GLSysHelp v.2.5: GLSL.LineShaders

Unit GLSL.LineShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLS.Scene
  • GLS.Color
  • GLS.Material
  • GLS.BaseClasses
  • GLS.RenderContextInfo
  • GLS.State
  • GLS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLineSettings |
Class TGLHiddenLineShader |
Class TGLOutlineShader |


GLSysHelp v.2.5: GLSL.LineShaders: Class TGLLineSettings

Class TGLLineSettings

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.LineShaders

Declaration

type TGLLineSettings = class(TGLUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TGLUpdateAbleObject
  • TGLLineSettings

Overview

Fields

Private | FColor: TGLColor;
Private | FWidth: Single;
Private | FPattern: TGLushort;
Private | FForceMaterial: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var rci: TGLRenderContextInfo);
Public | procedure UnApply(var rci: TGLRenderContextInfo);
Private | procedure SetColor(const v: TGLColor);
Private | procedure SetForceMaterial(v: boolean);
Private | procedure SetPattern(const value: TGLushort);
Private | procedure SetWidth(const Value: Single);

Properties

Published | property Color: TGLColor read FColor write SetColor;
Published | property ForceMaterial: Boolean read FForceMaterial write SetForceMaterial default false;
Published | property Pattern: TGLushort read FPattern write SetPattern default $FFFF;
Published | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FColor: TGLColor;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FPattern: TGLushort;

This item has no description.

Private FForceMaterial: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure UnApply(var rci: TGLRenderContextInfo);

This item has no description.

Private procedure SetColor(const v: TGLColor);

This item has no description.

Private procedure SetForceMaterial(v: boolean);

This item has no description.

Private procedure SetPattern(const value: TGLushort);

This item has no description.

Private procedure SetWidth(const Value: Single);

This item has no description.

Properties

Published property Color: TGLColor read FColor write SetColor;

This item has no description.

Published property ForceMaterial: Boolean read FForceMaterial write SetForceMaterial default false;

Set ForceMaterial to true to enforce the application of the line settings for objects that sets their own color, line width and pattern.

Published property Pattern: TGLushort read FPattern write SetPattern default $FFFF;

This item has no description.

Published property Width: Single read FWidth write SetWidth;


GLSysHelp v.2.5: GLSL.LineShaders: Class TGLHiddenLineShader

Class TGLHiddenLineShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.LineShaders

Declaration

type TGLHiddenLineShader = class(TGLShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLHiddenLineShader

Overview

Fields

Private | FPassCount: integer;
Private | FLineSmooth: Boolean;
Private | FSolid: Boolean;
Private | FBackGroundColor: TGLColor;
Private | FFrontLine: TGLLineSettings;
Private | FBackLine: TGLLineSettings;
Private | FLighting: Boolean;
Private | FShadeModel: TGLShadeModel;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetBackgroundColor(AColor: TGLColor);
Private | procedure SetLighting(v: boolean);
Private | procedure SetlineSmooth(v: boolean);
Private | procedure SetShadeModel(const val: TGLShadeModel);
Private | procedure SetSolid(v: boolean);

Properties

Published | property BackgroundColor: TGLColor read FBackgroundColor write SetBackgroundColor;
Published | property BackLine: TGLLineSettings read FBackLine write FBackLine;
Published | property FrontLine: TGLLineSettings read FFrontLine write FFrontLine;
Published | property LineSmooth: Boolean read FlineSmooth write SetlineSmooth default false;
Published | property ShadeModel: TGLShadeModel read FShadeModel write SetShadeModel default smDefault;
Published | property Solid: Boolean read FSolid write SetSolid default false;
Published | property SurfaceLit: Boolean read FLighting write SetLighting default true;

Description

Fields

Private FPassCount: integer;

This item has no description.

Private FLineSmooth: Boolean;

This item has no description.

Private FSolid: Boolean;

This item has no description.

Private FBackGroundColor: TGLColor;

This item has no description.

Private FFrontLine: TGLLineSettings;

This item has no description.

Private FBackLine: TGLLineSettings;

This item has no description.

Private FLighting: Boolean;

This item has no description.

Private FShadeModel: TGLShadeModel;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetBackgroundColor(AColor: TGLColor);

This item has no description.

Private procedure SetLighting(v: boolean);

This item has no description.

Private procedure SetlineSmooth(v: boolean);

This item has no description.

Private procedure SetShadeModel(const val: TGLShadeModel);

This item has no description.

Private procedure SetSolid(v: boolean);

This item has no description.

Properties

Published property BackgroundColor: TGLColor read FBackgroundColor write SetBackgroundColor;

Color used for solid fill.

Published property BackLine: TGLLineSettings read FBackLine write FBackLine;

This item has no description.

Published property FrontLine: TGLLineSettings read FFrontLine write FFrontLine;

This item has no description.

Published property LineSmooth: Boolean read FlineSmooth write SetlineSmooth default false;

Line smoothing control

Published property ShadeModel: TGLShadeModel read FShadeModel write SetShadeModel default smDefault;

Shade model. Default is "Smooth".

Published property Solid: Boolean read FSolid write SetSolid default false;

Solid controls if you can see through the front-line wireframe.

Published property SurfaceLit: Boolean read FLighting write SetLighting default true;

When Solid is True, determines if lighting or background color is used.


GLSysHelp v.2.5: GLSL.LineShaders: Class TGLOutlineShader

Class TGLOutlineShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.LineShaders

Declaration

type TGLOutlineShader = class(TGLShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLOutlineShader

Overview

Fields

Private | FPassCount: integer;
Private | FLineColor: TGLColor;
Private | FOutlineSmooth: Boolean;
Private | FOutlineWidth: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetOutlineSmooth(v: boolean);
Private | procedure SetOutlineWidth(v: single);

Properties

Published | property LineColor: TGLColor read FLineColor write FLineColor;
Published | property LineSmooth: Boolean read FOutlineSmooth write SetOutlineSmooth default false;
Published | property LineWidth: Single read FOutlineWidth write SetOutlineWidth;

Description

Fields

Private FPassCount: integer;

This item has no description.

Private FLineColor: TGLColor;

This item has no description.

Private FOutlineSmooth: Boolean;

This item has no description.

Private FOutlineWidth: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetOutlineSmooth(v: boolean);

This item has no description.

Private procedure SetOutlineWidth(v: single);

This item has no description.

Properties

Published property LineColor: TGLColor read FLineColor write FLineColor;

This item has no description.

Published property LineSmooth: Boolean read FOutlineSmooth write SetOutlineSmooth default false;

Line smoothing control

Published property LineWidth: Single read FOutlineWidth write SetOutlineWidth;


GLSysHelp v.2.5: GLSL.MultiMaterialShader

Unit GLSL.MultiMaterialShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLS.Material
  • GLS.Context
  • GLS.RenderContextInfo
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMultiMaterialShader |


GLSysHelp v.2.5: GLSL.MultiMaterialShader: Class TGLMultiMaterialShader

Class TGLMultiMaterialShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.MultiMaterialShader

Declaration

type TGLMultiMaterialShader = class(TGLShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLMultiMaterialShader

Overview

Fields

Private | FPass: Integer;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FVisibleAtDesignTime: boolean;
Private | FShaderActiveAtDesignTime: boolean;
Private | FShaderStyle: TGLShaderStyle;

Methods

Public | constructor Create(aOwner: TComponent); override;
Private | procedure SetShaderStyle(const Value: TGLShaderStyle);
Private | procedure SetVisibleAtDesignTime(const Value: boolean);

Properties

Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property ShaderStyle: TGLShaderStyle read FShaderStyle write SetShaderStyle;
Published | property VisibleAtDesignTime: boolean read FVisibleAtDesignTime write SetVisibleAtDesignTime;

Description

Fields

Private FPass: Integer;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FVisibleAtDesignTime: boolean;

This item has no description.

Private FShaderActiveAtDesignTime: boolean;

This item has no description.

Private FShaderStyle: TGLShaderStyle;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Private procedure SetShaderStyle(const Value: TGLShaderStyle);

This item has no description.

Private procedure SetVisibleAtDesignTime(const Value: boolean);

This item has no description.

Properties

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property ShaderStyle: TGLShaderStyle read FShaderStyle write SetShaderStyle;

This item has no description.

Published property VisibleAtDesignTime: boolean read FVisibleAtDesignTime write SetVisibleAtDesignTime;


GLSysHelp v.2.5: GLSL.PhongShader

Unit GLSL.PhongShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLS.Texture
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLScene.OpenGLTokens
  • GLS.Context
  • GLSL.AsmShader
  • GLS.RenderContextInfo
  • GLSL.CustomShader
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPhongShader |


GLSysHelp v.2.5: GLSL.PhongShader: Class TGLPhongShader

Class TGLPhongShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PhongShader

Declaration

type TGLPhongShader = class(TGLCustomAsmShader)

Description

This item has no description. Showing description inherited from TGLCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomAsmShader
  • TGLPhongShader

Overview

Fields

Private | FLightIDs: TGLIntegerList;
Private | FDesignTimeEnabled: Boolean;
Private | FAmbientPass: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; override;
Private | procedure SetDesignTimeEnabled(const Value: Boolean);

Properties

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled default False;

Description

Fields

Private FLightIDs: TGLIntegerList;

This item has no description.

Private FDesignTimeEnabled: Boolean;

This item has no description.

Private FAmbientPass: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ShaderSupported: Boolean; override;

This item has no description. Showing description inherited from TGLShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Private procedure SetDesignTimeEnabled(const Value: Boolean);

This item has no description.

Properties

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled default False;


GLSysHelp v.2.5: GLSL.PostEffects

Unit GLSL.PostEffects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.State
  • GLS.Context
  • GLS.PersistentClasses
  • GLS.Texture
  • GLS.Graphics
  • GLScene.Strings
  • GLSL.CustomShader
  • GLScene.VectorGeometry
  • GLS.RenderContextInfo
  • GLS.Material
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLPostShaderHolderException |
Class TGLPostShaderCollectionItem |
Class TGLPostShaderCollection |
Class TGLPostShaderHolder |
Record TGLPostEffectColor |
Class TGLPostEffect |

Types

TGLOnCustomPostEffectEvent = procedure(Sender: TObject; var rci: TGLRenderContextInfo; var Buffer: TGLPostEffectBuffer) of object;
TGLPostEffectBuffer = array of TGLPostEffectColor;
TGLPostEffectPreset = (...);

Description

Types

TGLOnCustomPostEffectEvent = procedure(Sender: TObject; var rci: TGLRenderContextInfo; var Buffer: TGLPostEffectBuffer) of object;

This item has no description.

TGLPostEffectBuffer = array of TGLPostEffectColor;

This item has no description.

TGLPostEffectPreset = (...);

Some presets for TGLPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.

Values
  • pepNone
  • pepGray
  • pepNegative
  • pepDistort
  • pepNoise
  • pepNightVision
  • pepBlur
  • pepCustom


GLSysHelp v.2.5: GLSL.PostEffects: Class EGLPostShaderHolderException

Class EGLPostShaderHolderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostEffects

Declaration

type EGLPostShaderHolderException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLPostShaderHolderException


GLSysHelp v.2.5: GLSL.PostEffects: Class TGLPostShaderCollectionItem

Class TGLPostShaderCollectionItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostEffects

Declaration

type TGLPostShaderCollectionItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLPostShaderCollectionItem

Overview

Fields

Private | FShader: TGLShader;
Private | FPostShaderInterface: IGLPostShader;

Methods

Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetShader(const Value: TGLShader);

Properties

Published property Shader: TGLShader read FShader write SetShader;

Description

Fields

Private FShader: TGLShader;

This item has no description.

Private FPostShaderInterface: IGLPostShader;

This item has no description.

Methods

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetShader(const Value: TGLShader);

This item has no description.

Properties

Published property Shader: TGLShader read FShader write SetShader;


GLSysHelp v.2.5: GLSL.PostEffects: Class TGLPostShaderCollection

Class TGLPostShaderCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostEffects

Declaration

type TGLPostShaderCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLPostShaderCollection

Overview

Methods

Public | function Add: TGLPostShaderCollectionItem;
Private | function GetItems(const Index: Integer): TGLPostShaderCollectionItem;
Public | procedure Remove(const Item: TGLShader);
Private | procedure SetItems(const Index: Integer; const Value: TGLPostShaderCollectionItem);

Properties

Public property Items[const Index: Integer]: TGLPostShaderCollectionItem read GetItems write SetItems;

Description

Methods

Public function Add: TGLPostShaderCollectionItem;

This item has no description.

Private function GetItems(const Index: Integer): TGLPostShaderCollectionItem;

This item has no description.

Public procedure Remove(const Item: TGLShader);

This item has no description.

Private procedure SetItems(const Index: Integer; const Value: TGLPostShaderCollectionItem);

This item has no description.

Properties

Public property Items[const Index: Integer]: TGLPostShaderCollectionItem read GetItems write SetItems;


GLSysHelp v.2.5: GLSL.PostEffects: Class TGLPostShaderHolder

Class TGLPostShaderHolder

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostEffects

Declaration

type TGLPostShaderHolder = class(TGLBaseSCeneObject)

Description

A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLPostShaderHolder

Overview

Fields

Private | FShaders: TGLPostShaderCollection;
Private | FTempTexture: TGLTextureHandle;
Private | FPreviousViewportSize: TGLSize;
Private | FTempTextureTarget: TGLTextureTarget;

Methods

Public | constructor Create(Owner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Private | procedure SetShaders(const Value: TGLPostShaderCollection);

Properties

Published | property OnProgress;
Published | property Shaders: TGLPostShaderCollection read FShaders write SetShaders;
Published | property TempTextureTarget: TGLTextureTarget read FTempTextureTarget write FTempTextureTarget default ttTexture2d;
Published | property Visible;

Description

Fields

Private FShaders: TGLPostShaderCollection;

This item has no description.

Private FTempTexture: TGLTextureHandle;

This item has no description.

Private FPreviousViewportSize: TGLSize;

This item has no description.

Private FTempTextureTarget: TGLTextureTarget;

This item has no description.

Methods

Public constructor Create(Owner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Private procedure SetShaders(const Value: TGLPostShaderCollection);

This item has no description.

Properties

Published property OnProgress;

This item has no description.

Published property Shaders: TGLPostShaderCollection read FShaders write SetShaders;

This item has no description.

Published property TempTextureTarget: TGLTextureTarget read FTempTextureTarget write FTempTextureTarget default ttTexture2d;

This item has no description.

Published property Visible;

Publish some stuff from TGLBaseSceneObject.


GLSysHelp v.2.5: GLSL.PostEffects: Record TGLPostEffectColor

Record TGLPostEffectColor

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostEffects

Declaration

type TGLPostEffectColor = record

Description

This item has no description.

Overview

Fields

Public | R: Byte;
Public | G: Byte;
Public | B: Byte;
Public | A: Byte;

Description

Fields

Public R: Byte;

This item has no description.

Public G: Byte;

This item has no description.

Public B: Byte;

This item has no description.

Public A: Byte;


GLSysHelp v.2.5: GLSL.PostEffects: Class TGLPostEffect

Class TGLPostEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostEffects

Declaration

type TGLPostEffect = class(TGLBaseSCeneObject)

Description

Provides a simple way to producing post-effects without shaders. It is slow as hell, but it's worth it in some cases.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLPostEffect

Overview

Fields

Private | FOnCustomEffect: TGLOnCustomPostEffectEvent;
Private | FPreset: TGLPostEffectPreset;
Private | FRenderBuffer: TGLPostEffectBuffer;

Methods

Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property OnCustomEffect: TGLOnCustomPostEffectEvent read FOnCustomEffect write FOnCustomEffect;
Published | property OnProgress;
Published | property Preset: TGLPostEffectPreset read FPreset write FPreset default pepNone;
Published | property Visible;

Description

Fields

Private FOnCustomEffect: TGLOnCustomPostEffectEvent;

This item has no description.

Private FPreset: TGLPostEffectPreset;

This item has no description.

Private FRenderBuffer: TGLPostEffectBuffer;

This item has no description.

Methods

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property OnCustomEffect: TGLOnCustomPostEffectEvent read FOnCustomEffect write FOnCustomEffect;

User creates this effect.

Published property OnProgress;

This item has no description.

Published property Preset: TGLPostEffectPreset read FPreset write FPreset default pepNone;

This item has no description.

Published property Visible;

Publish some stuff from TGLBaseSCeneObject.


GLSysHelp v.2.5: GLSL.PostShaders

Unit GLSL.PostShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.OpenGLTokens
  • GLS.Texture
  • GLS.Scene
  • GLS.State
  • GLScene.VectorGeometry
  • GLS.RenderContextInfo
  • GLScene.TextureFormat
  • GLS.Context
  • GLS.Material
  • GLSL.Shader
  • GLSL.CustomShader
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCustomGLSLPostBlurShader |
Class TGLSLPostBlurShader |
Class TGLCustomGLSLPostThermalVisionShader |
Class TGLSLPostThermalVisionShader |
Class TGLCustomGLSLPostDreamVisionShader |
Class TGLSLPostDreamVisionShader |
Class TGLCustomGLSLPostNightVisionShader |
Class TGLSLPostNightVisionShader |
Class TGLCustomGLSLPostPixelateShader |
Class TGLSLPostPixelateShader |
Class TGLCustomGLSLPostPosterizeShader |
Class TGLSLPostPosterizeShader |
Class TGLCustomGLSLPostFrostShader |
Class TGLSLPostFrostShader |
Class TGLCustomGLSLPostTroubleShader |
Class TGLSLPostTroubleShader |


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLCustomGLSLPostBlurShader

Class TGLCustomGLSLPostBlurShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLCustomGLSLPostBlurShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

Custom class for GLSLPostBlurShader. A shader that blurs the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostBlurShader

Overview

Fields

Private FThreshold: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TGLTextureTarget;
Private | function StoreThreshold: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle; TextureTarget: TGLTextureTarget);

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;

Description

Fields

Private FThreshold: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TGLTextureTarget;

This item has no description. Showing description inherited from IGLPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreThreshold: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TGLTextureHandle; TextureTarget: TGLTextureTarget);

Implementing IGLPostShader.

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLSLPostBlurShader

Class TGLSLPostBlurShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLSLPostBlurShader = class(TGLCustomGLSLPostBlurShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLPostBlurShader.

Custom class for GLSLPostBlurShader. A shader that blurs the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostBlurShader
  • TGLSLPostBlurShader

Overview

Properties

Published property Threshold;

Description

Properties

Published property Threshold;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLCustomGLSLPostThermalVisionShader

Class TGLCustomGLSLPostThermalVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLCustomGLSLPostThermalVisionShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

A shader that simulate a Thermal Vision of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostThermalVisionShader

Overview

Fields

Private | FThreshold: Single;
Private | Fintensity: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TGLTextureTarget;
Private | function StoreIntensity: Boolean;
Private | function StoreThreshold: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Properties

Public | property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;
Public | property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;

Description

Fields

Private FThreshold: Single;

This item has no description.

Private Fintensity: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TGLTextureTarget;

This item has no description. Showing description inherited from IGLPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreIntensity: Boolean;

This item has no description.

Private function StoreThreshold: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Implementing IGLPostShader.

Properties

Public property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;

This item has no description.

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLSLPostThermalVisionShader

Class TGLSLPostThermalVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLSLPostThermalVisionShader = class(TGLCustomGLSLPostThermalVisionShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLPostThermalVisionShader.

A shader that simulate a Thermal Vision of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostThermalVisionShader
  • TGLSLPostThermalVisionShader

Overview

Properties

Published | property Intensity;
Published | property Threshold;

Description

Properties

Published property Intensity;

This item has no description.

Published property Threshold;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLCustomGLSLPostDreamVisionShader

Class TGLCustomGLSLPostDreamVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLCustomGLSLPostDreamVisionShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

Custom class for GLSLPostDreamVisionShader. A shader that simulate a grayscale threshold vision (aka dream) of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostDreamVisionShader

Overview

Fields

Private FThreshold: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TGLTextureTarget;
Private | function StoreThreshold: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;

Description

Fields

Private FThreshold: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TGLTextureTarget;

This item has no description. Showing description inherited from IGLPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreThreshold: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

In percent 0..100; Implementing IGLPostShader.

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLSLPostDreamVisionShader

Class TGLSLPostDreamVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLSLPostDreamVisionShader = class(TGLCustomGLSLPostDreamVisionShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLPostDreamVisionShader.

Custom class for GLSLPostDreamVisionShader. A shader that simulate a grayscale threshold vision (aka dream) of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostDreamVisionShader
  • TGLSLPostDreamVisionShader

Overview

Properties

Published property Threshold;

Description

Properties

Published property Threshold;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLCustomGLSLPostNightVisionShader

Class TGLCustomGLSLPostNightVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLCustomGLSLPostNightVisionShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

Custom class for GLSLPostNightVisionShader. A shader that simulate a Night Vision of the scene throw a mask if enabled, or of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostNightVisionShader

Overview

Fields

Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FLuminanceThreshold: Single;
Private | FColorAmplification:Single;
Private | FElapsedTime: Single;
Private | FUseMask: Integer;
Private | FNoiseTex: TGLTexture;
Private | FMaskTex: TGLTexture;
Private | FNoiseTexName: TGLLibMaterialName;
Private | FMaskTexName: TGLLibMaterialName;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetMaskTexName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function GetNoiseTexName: TGLLibMaterialName;
Private | function GetTextureTarget: TGLTextureTarget;
Private | function StoreColorAmplification: Boolean;
Private | function StoreLuminanceThreshold: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);
Private | procedure SetMaskTexName(const Value: TGLLibMaterialName);
Private | procedure SetMaskTexTexture(const Value: TGLTexture);
Private | procedure SetNoiseTexName(const Value: TGLLibMaterialName);
Private | procedure SetNoiseTexTexture(const Value: TGLTexture);

Properties

Public | property ColorAmplification: Single read FColorAmplification write FColorAmplification stored StoreColorAmplification;
Public | property ElapsedTime: Single read FElapsedTime write FElapsedTime stored false;
Public | property LuminanceThreshold: Single read FLuminanceThreshold write FLuminanceThreshold stored StoreLuminanceThreshold;
Public | property MaskTex: TGLTexture read FMaskTex write SetMaskTexTexture;
Public | property MaskTexName: TGLLibMaterialName read GetMaskTexName write SetMaskTexName;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property NoiseTex: TGLTexture read FNoiseTex write SetNoiseTexTexture;
Public | property NoiseTexName: TGLLibMaterialName read GetNoiseTexName write SetNoiseTexName;
Public | property UseMask : Integer read FUseMask write FUseMask;

Description

Fields

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FLuminanceThreshold: Single;

This item has no description.

Private FColorAmplification:Single;

This item has no description.

Private FElapsedTime: Single;

This item has no description.

Private FUseMask: Integer;

This item has no description.

Private FNoiseTex: TGLTexture;

This item has no description.

Private FMaskTex: TGLTexture;

This item has no description.

Private FNoiseTexName: TGLLibMaterialName;

This item has no description.

Private FMaskTexName: TGLLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetMaskTexName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private function GetNoiseTexName: TGLLibMaterialName;

This item has no description.

Private function GetTextureTarget: TGLTextureTarget;

This item has no description. Showing description inherited from IGLPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreColorAmplification: Boolean;

This item has no description.

Private function StoreLuminanceThreshold: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Implementing IGLPostShader.

Private procedure SetMaskTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMaskTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetNoiseTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetNoiseTexTexture(const Value: TGLTexture);

This item has no description.

Properties

Public property ColorAmplification: Single read FColorAmplification write FColorAmplification stored StoreColorAmplification;

This item has no description.

Public property ElapsedTime: Single read FElapsedTime write FElapsedTime stored false;

This item has no description.

Public property LuminanceThreshold: Single read FLuminanceThreshold write FLuminanceThreshold stored StoreLuminanceThreshold;

This item has no description.

Public property MaskTex: TGLTexture read FMaskTex write SetMaskTexTexture;

This item has no description.

Public property MaskTexName: TGLLibMaterialName read GetMaskTexName write SetMaskTexName;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property NoiseTex: TGLTexture read FNoiseTex write SetNoiseTexTexture;

This item has no description.

Public property NoiseTexName: TGLLibMaterialName read GetNoiseTexName write SetNoiseTexName;

This item has no description.

Public property UseMask : Integer read FUseMask write FUseMask;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLSLPostNightVisionShader

Class TGLSLPostNightVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLSLPostNightVisionShader = class(TGLCustomGLSLPostNightVisionShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLPostNightVisionShader.

Custom class for GLSLPostNightVisionShader. A shader that simulate a Night Vision of the scene throw a mask if enabled, or of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostNightVisionShader
  • TGLSLPostNightVisionShader

Overview

Properties

Published | property ColorAmplification;
Published | property ElapsedTime;
Published | property LuminanceThreshold;
Published | property MaskTexName;
Published | property MaterialLibrary;
Published | property NoiseTexName;
Published | property UseMask;

Description

Properties

Published property ColorAmplification;

This item has no description.

Published property ElapsedTime;

This item has no description.

Published property LuminanceThreshold;

This item has no description.

Published property MaskTexName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NoiseTexName;

This item has no description.

Published property UseMask;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLCustomGLSLPostPixelateShader

Class TGLCustomGLSLPostPixelateShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLCustomGLSLPostPixelateShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

Custom class for GLSLPostPixelateShader. A shader that pixelate of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostPixelateShader

Overview

Fields

Private | FPixelWidth: Single;
Private | FPixelHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TGLTextureTarget;
Private | function StorePixelHeight: Boolean;
Private | function StorePixelWidth: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Properties

Public | property PixelHeight: Single read FPixelHeight write FPixelHeight stored StorePixelHeight;
Public | property PixelWidth: Single read FPixelWidth write FPixelWidth stored StorePixelWidth;

Description

Fields

Private FPixelWidth: Single;

This item has no description.

Private FPixelHeight: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TGLTextureTarget;

This item has no description. Showing description inherited from IGLPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StorePixelHeight: Boolean;

This item has no description.

Private function StorePixelWidth: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Implementing IGLPostShader.

Properties

Public property PixelHeight: Single read FPixelHeight write FPixelHeight stored StorePixelHeight;

This item has no description.

Public property PixelWidth: Single read FPixelWidth write FPixelWidth stored StorePixelWidth;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLSLPostPixelateShader

Class TGLSLPostPixelateShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLSLPostPixelateShader = class(TGLCustomGLSLPostPixelateShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLPostPixelateShader.

Custom class for GLSLPostPixelateShader. A shader that pixelate of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostPixelateShader
  • TGLSLPostPixelateShader

Overview

Properties

Published | property PixelHeight;
Published | property PixelWidth;

Description

Properties

Published property PixelHeight;

This item has no description.

Published property PixelWidth;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLCustomGLSLPostPosterizeShader

Class TGLCustomGLSLPostPosterizeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLCustomGLSLPostPosterizeShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

Custom class for GLSLPostPosterizeShader. A shader that posterize of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostPosterizeShader

Overview

Fields

Private | FGamma: Single;
Private | FNumColors: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TGLTextureTarget;
Private | function StoreGamma: Boolean;
Private | function StoreNumColors: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Properties

Public | property Gamma: Single read FGamma write FGamma stored StoreGamma;
Public | property NumColors: Single read FNumColors write FNumColors stored StoreNumColors;

Description

Fields

Private FGamma: Single;

This item has no description.

Private FNumColors: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TGLTextureTarget;

This item has no description. Showing description inherited from IGLPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreGamma: Boolean;

This item has no description.

Private function StoreNumColors: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Implementing IGLPostShader.

Properties

Public property Gamma: Single read FGamma write FGamma stored StoreGamma;

This item has no description.

Public property NumColors: Single read FNumColors write FNumColors stored StoreNumColors;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLSLPostPosterizeShader

Class TGLSLPostPosterizeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLSLPostPosterizeShader = class(TGLCustomGLSLPostPosterizeShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLPostPosterizeShader.

Custom class for GLSLPostPosterizeShader. A shader that posterize of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostPosterizeShader
  • TGLSLPostPosterizeShader

Overview

Properties

Published | property Gamma;
Published | property NumColors;

Description

Properties

Published property Gamma;

This item has no description.

Published property NumColors;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLCustomGLSLPostFrostShader

Class TGLCustomGLSLPostFrostShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLCustomGLSLPostFrostShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

Custom class for GLSLPostFrostShader. A shader that frost of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostFrostShader

Overview

Fields

Private | FRandScale: Single;
Private | FRandFactor: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TGLTextureTarget;
Private | function StoreRandFactor: Boolean;
Private | function StoreRandScale: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Properties

Public | property RandFactor: Single read FRandFactor write FRandFactor stored StoreRandFactor;
Public | property RandScale: Single read FRandScale write FRandScale stored StoreRandScale;

Description

Fields

Private FRandScale: Single;

This item has no description.

Private FRandFactor: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TGLTextureTarget;

This item has no description. Showing description inherited from IGLPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreRandFactor: Boolean;

This item has no description.

Private function StoreRandScale: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Implementing IGLPostShader.

Properties

Public property RandFactor: Single read FRandFactor write FRandFactor stored StoreRandFactor;

This item has no description.

Public property RandScale: Single read FRandScale write FRandScale stored StoreRandScale;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLSLPostFrostShader

Class TGLSLPostFrostShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLSLPostFrostShader = class(TGLCustomGLSLPostFrostShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLPostFrostShader.

Custom class for GLSLPostFrostShader. A shader that frost of the entire scene

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostFrostShader
  • TGLSLPostFrostShader

Overview

Properties

Published | property RandFactor;
Published | property RandScale;

Description

Properties

Published property RandFactor;

This item has no description.

Published property RandScale;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLCustomGLSLPostTroubleShader

Class TGLCustomGLSLPostTroubleShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLCustomGLSLPostTroubleShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

Custom class for GLSLPostTroubleShader. A shader that trouble of the entire scene. v2 This Shader is experimental it can do smooth the scene or double the scene and it's depends of PixelX, PixelY and Freq values if they are less than 1 or greater the effects will be very different

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostTroubleShader

Overview

Fields

Private | FPixelX: Single;
Private | FPixelY: Single;
Private | FFreq: Single;
Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FNoiseTex: TGLTexture;
Private | FNoiseTexName: TGLLibMaterialName;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function GetNoiseTexName: TGLLibMaterialName;
Private | function GetTextureTarget: TGLTextureTarget;
Private | function StoreFreq: Boolean;
Private | function StorePixelX: Boolean;
Private | function StorePixelY: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);
Private | procedure SetNoiseTexName(const Value: TGLLibMaterialName);
Private | procedure SetNoiseTexTexture(const Value: TGLTexture);

Properties

Public | property Freq: Single read FFreq write FFreq stored StoreFreq;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property NoiseTex: TGLTexture read FNoiseTex write SetNoiseTexTexture;
Public | property NoiseTexName: TGLLibMaterialName read GetNoiseTexName write SetNoiseTexName;
Public | property PixelX: Single read FPixelX write FPixelX stored StorePixelX;
Public | property PixelY: Single read FPixelY write FPixelY stored StorePixelY;

Description

Fields

Private FPixelX: Single;

This item has no description.

Private FPixelY: Single;

This item has no description.

Private FFreq: Single;

This item has no description.

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FNoiseTex: TGLTexture;

This item has no description.

Private FNoiseTexName: TGLLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private function GetNoiseTexName: TGLLibMaterialName;

This item has no description.

Private function GetTextureTarget: TGLTextureTarget;

This item has no description. Showing description inherited from IGLPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreFreq: Boolean;

This item has no description.

Private function StorePixelX: Boolean;

This item has no description.

Private function StorePixelY: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TGLTextureHandle;TextureTarget: TGLTextureTarget);

Implementing IGLPostShader.

Private procedure SetNoiseTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetNoiseTexTexture(const Value: TGLTexture);

This item has no description.

Properties

Public property Freq: Single read FFreq write FFreq stored StoreFreq;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property NoiseTex: TGLTexture read FNoiseTex write SetNoiseTexTexture;

This item has no description.

Public property NoiseTexName: TGLLibMaterialName read GetNoiseTexName write SetNoiseTexName;

This item has no description.

Public property PixelX: Single read FPixelX write FPixelX stored StorePixelX;

This item has no description.

Public property PixelY: Single read FPixelY write FPixelY stored StorePixelY;


GLSysHelp v.2.5: GLSL.PostShaders: Class TGLSLPostTroubleShader

Class TGLSLPostTroubleShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.PostShaders

Declaration

type TGLSLPostTroubleShader = class(TGLCustomGLSLPostTroubleShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLPostTroubleShader.

Custom class for GLSLPostTroubleShader. A shader that trouble of the entire scene. v2 This Shader is experimental it can do smooth the scene or double the scene and it's depends of PixelX, PixelY and Freq values if they are less than 1 or greater the effects will be very different

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostTroubleShader
  • TGLSLPostTroubleShader

Overview

Properties

Published | property Freq;
Published | property MaterialLibrary;
Published | property NoiseTexName;
Published | property PixelX;
Published | property PixelY;

Description

Properties

Published property Freq;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NoiseTexName;

This item has no description.

Published property PixelX;

This item has no description.

Published property PixelY;


GLSysHelp v.2.5: GLSL.ProjectedTextures

Unit GLSL.ProjectedTextures

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.PipelineTransform
  • GLS.Scene
  • GLS.PersistentClasses
  • GLS.Texture
  • GLScene.VectorGeometry
  • GLS.Context
  • GLS.Color
  • GLS.RenderContextInfo
  • GLScene.TextureFormat
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSLTextureEmitter |
Class TGLSLTextureEmitterItem |
Class TGLSLTextureEmitters |
Class TGLSLProjectedTextures |

Types

TGLSLProjectedTexturesStyle = (...);

Description

Types

TGLSLProjectedTexturesStyle = (...);

This item has no description.

Values
  • ptsLight
  • ptsShadow


GLSysHelp v.2.5: GLSL.ProjectedTextures: Class TGLSLTextureEmitter

Class TGLSLTextureEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ProjectedTextures

Declaration

type TGLSLTextureEmitter = class(TGLBaseSceneObject)

Description

A projected texture emmiter. Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLSLTextureEmitter

Overview

Fields

Private | FFOV: single;
Private | FAspect: single;
Private | FBrightness: single;
Private | FAttenuation: single;
Private | FStyle: TGLSLProjectedTexturesStyle;
Private | FColor: TGLColor;
Private | FUseAttenuation: boolean;
Private | FAllowReverseProjection: boolean;
Private | FUseQuadraticAttenuation: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: boolean); override;

Properties

Published | property AllowReverseProjection: boolean read FAllowReverseProjection write SetAllowReverseProjection;
Published | property Aspect: single read FAspect write FAspect;
Published | property Attenuation: single read FAttenuation write FAttenuation;
Published | property Behaviours;
Published | property Brightness: single read FBrightness write FBrightness;
Published | property Color: TGLColor read FColor write FColor;
Published | property Direction;
Published | property Effects;
Published | property FOV: single read FFOV write FFOV;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property Style: TGLSLProjectedTexturesStyle read FStyle write SetStyle;
Published | property TurnAngle;
Published | property Up;
Published | property UseAttenuation: boolean read FUseAttenuation write SetUseAttenuation;
Published | property UseQuadraticAttenuation: Boolean read FUseQuadraticAttenuation write SetUseQuadraticAttenuation;
Published | property VisibilityCulling;
Published | property Visible;

Description

Fields

Private FFOV: single;

This item has no description.

Private FAspect: single;

This item has no description.

Private FBrightness: single;

This item has no description.

Private FAttenuation: single;

This item has no description.

Private FStyle: TGLSLProjectedTexturesStyle;

This item has no description.

Private FColor: TGLColor;

This item has no description.

Private FUseAttenuation: boolean;

This item has no description.

Private FAllowReverseProjection: boolean;

This item has no description.

Private FUseQuadraticAttenuation: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: boolean); override;

This item has no description.

Properties

Published property AllowReverseProjection: boolean read FAllowReverseProjection write SetAllowReverseProjection;

This item has no description.

Published property Aspect: single read FAspect write FAspect;

x/y ratio. For no distortion, this should be set to texture.width/texture.height.

Published property Attenuation: single read FAttenuation write FAttenuation;

Fall off/ attenuation of the projected texture

Published property Behaviours;

This item has no description.

Published property Brightness: single read FBrightness write FBrightness;

This item has no description.

Published property Color: TGLColor read FColor write FColor;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property FOV: single read FFOV write FFOV;

Indicates the field-of-view of the projection frustum.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property Style: TGLSLProjectedTexturesStyle read FStyle write SetStyle;

Indicates the style of the projected textures.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property UseAttenuation: boolean read FUseAttenuation write SetUseAttenuation;

This item has no description.

Published property UseQuadraticAttenuation: Boolean read FUseQuadraticAttenuation write SetUseQuadraticAttenuation;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GLSysHelp v.2.5: GLSL.ProjectedTextures: Class TGLSLTextureEmitterItem

Class TGLSLTextureEmitterItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ProjectedTextures

Declaration

type TGLSLTextureEmitterItem = class(TCollectionItem)

Description

Specifies an item on the TGLSLTextureEmitters collection.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TGLSLTextureEmitterItem

Overview

Fields

Private FEmitter: TGLSLTextureEmitter;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property Emitter: TGLSLTextureEmitter read FEmitter write SetEmitter;

Description

Fields

Private FEmitter: TGLSLTextureEmitter;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Emitter: TGLSLTextureEmitter read FEmitter write SetEmitter;


GLSysHelp v.2.5: GLSL.ProjectedTextures: Class TGLSLTextureEmitters

Class TGLSLTextureEmitters

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ProjectedTextures

Declaration

type TGLSLTextureEmitters = class(TCollection)

Description

Collection of TGLSLTextureEmitter.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TGLSLTextureEmitters

Overview

Fields

Private FOwner: TGLSLProjectedTextures;

Methods

Public procedure AddEmitter(texEmitter: TGLSLTextureEmitter);

Properties

Public property Items[index: Integer]: TGLSLTextureEmitterItem read GetItems;

Description

Fields

Private FOwner: TGLSLProjectedTextures;

This item has no description.

Methods

Public procedure AddEmitter(texEmitter: TGLSLTextureEmitter);

This item has no description.

Properties

Public property Items[index: Integer]: TGLSLTextureEmitterItem read GetItems;


GLSysHelp v.2.5: GLSL.ProjectedTextures: Class TGLSLProjectedTextures

Class TGLSLProjectedTextures

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ProjectedTextures

Declaration

type TGLSLProjectedTextures = class(TGLSceneObject)

Description

Projected Texture Manager. Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.

Hierarchy

  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSLProjectedTextures

Overview

Fields

Private | ShaderSupported: boolean;
Private | FEmitters: TGLSLTextureEmitters;
Private | FUseLightmaps: boolean;
Private | Shader: TGLProgramHandle;
Private | FAmbient: TGLColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure StructureChanged; override;
Private | procedure SetupShader;

Properties

Published | property Ambient: TGLColor read fAmbient write fAmbient;
Published | property Emitters: TGLSLTextureEmitters read FEmitters write FEmitters;
Published | property UseLightmaps: boolean read FUseLightmaps write SetUseLightmaps;

Description

Fields

Private ShaderSupported: boolean;

This item has no description.

Private FEmitters: TGLSLTextureEmitters;

This item has no description.

Private FUseLightmaps: boolean;

This item has no description.

Private Shader: TGLProgramHandle;

This item has no description.

Private FAmbient: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var rci: TGLRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Private procedure SetupShader;

This item has no description.

Properties

Published property Ambient: TGLColor read fAmbient write fAmbient;

Ambient is use if no lightmap..

Published property Emitters: TGLSLTextureEmitters read FEmitters write FEmitters;

List of emitters.

Published property UseLightmaps: boolean read FUseLightmaps write SetUseLightmaps;


GLSysHelp v.2.5: GLSL.Shader

Unit GLSL.Shader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLS.Texture
  • GLS.Context
  • GLSL.CustomShader
  • GLS.RenderContextInfo
  • GLScene.TextureFormat
  • GLSL.ShaderParameter
  • GLS.Material
  • GLS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLSLShaderException |
Record TGLActiveAttrib |
Class TGLCustomGLSLShader |
Class TGLSLShaderParameter |
Class TGLSLShader |

Types

TGLActiveAttribArray = array of TGLActiveAttrib;
TGLSLShaderEvent = procedure(Shader: TGLCustomGLSLShader) of object;
TGLSLShaderEventEx = procedure(Shader: TGLCustomGLSLShader; Sender: TObject) of object;
TGLSLShaderUnApplyEvent = procedure(Shader: TGLCustomGLSLShader; var ThereAreMorePasses: Boolean) of object;

Description

Types

TGLActiveAttribArray = array of TGLActiveAttrib;

This item has no description.

TGLSLShaderEvent = procedure(Shader: TGLCustomGLSLShader) of object;

This item has no description.

TGLSLShaderEventEx = procedure(Shader: TGLCustomGLSLShader; Sender: TObject) of object;

This item has no description.

TGLSLShaderUnApplyEvent = procedure(Shader: TGLCustomGLSLShader; var ThereAreMorePasses: Boolean) of object;


GLSysHelp v.2.5: GLSL.Shader: Class EGLSLShaderException

Class EGLSLShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.Shader

Declaration

type EGLSLShaderException = class(EGLCustomShaderException)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLShaderException
  • EGLCustomShaderException
  • EGLSLShaderException


GLSysHelp v.2.5: GLSL.Shader: Record TGLActiveAttrib

Record TGLActiveAttrib

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.Shader

Declaration

type TGLActiveAttrib = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | Size: Integer;
Public | AType: TGLSLDataType;
Public | Location: Integer;

Description

Fields

Public Name: string;

This item has no description.

Public Size: Integer;

This item has no description.

Public AType: TGLSLDataType;

This item has no description.

Public Location: Integer;


GLSysHelp v.2.5: GLSL.Shader: Class TGLCustomGLSLShader

Class TGLCustomGLSLShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.Shader

Declaration

type TGLCustomGLSLShader = class(TGLCustomShader)

Description

This item has no description. Showing description inherited from TGLCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader

Overview

Fields

Private | FGLSLProg: TGLProgramHandle;
Private | FParam: TGLSLShaderParameter;
Private | FActiveVarying: TStrings;
Private | FTransformFeedBackMode: TGLTransformFeedBackMode;
Private | FOnInitialize: TGLSLShaderEvent;
Private | FOnApply: TGLSLShaderEvent;
Private | FOnUnApply: TGLSLShaderUnApplyEvent;
Private | FOnInitializeEx: TGLSLShaderEventEx;
Private | FOnApplyEx: TGLSLShaderEventEx;
Private | FNextTexIndex: integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetActiveAttribs: TGLActiveAttribArray;
Public | function ShaderSupported: Boolean; override;
Private | function GetDirectParam(const Index: Cardinal): TGLSLShaderParameter;
Private | function GetParam(const Index: string): TGLSLShaderParameter;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetTex(TexParam : TGLSLShaderParameter; Tex : TGLTexture); overload;
Public | procedure SetTex(TexParam : TGLSLShaderParameter; Mat : TGLLibMaterial); overload;
Public | procedure SetTex(const TexParamName : String; Mat : TGLLibMaterial); overload;
Public | procedure SetTex(const TexParamName : String; Tex : TGLTexture); overload;
Private | procedure OnChangeActiveVarying(Sender: TObject);

Properties

Public | property ActiveVarying: TStrings read FActiveVarying write SetActiveVarying;
Public | property DirectParam[const Index: Cardinal]: TGLSLShaderParameter read GetDirectParam;
Public | property Param[const Index: string]: TGLSLShaderParameter read GetParam;
Public | property TransformFeedBackMode: TGLTransformFeedBackMode read FTransformFeedBackMode write SetTransformFeedBackMode default tfbmInterleaved;

Description

Fields

Private FGLSLProg: TGLProgramHandle;

This item has no description.

Private FParam: TGLSLShaderParameter;

This item has no description.

Private FActiveVarying: TStrings;

This item has no description.

Private FTransformFeedBackMode: TGLTransformFeedBackMode;

This item has no description.

Private FOnInitialize: TGLSLShaderEvent;

This item has no description.

Private FOnApply: TGLSLShaderEvent;

This item has no description.

Private FOnUnApply: TGLSLShaderUnApplyEvent;

This item has no description.

Private FOnInitializeEx: TGLSLShaderEventEx;

This item has no description.

Private FOnApplyEx: TGLSLShaderEventEx;

This item has no description.

Private FNextTexIndex: integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetActiveAttribs: TGLActiveAttribArray;

This item has no description.

Public function ShaderSupported: Boolean; override;

This item has no description. Showing description inherited from TGLShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Private function GetDirectParam(const Index: Cardinal): TGLSLShaderParameter;

This item has no description.

Private function GetParam(const Index: string): TGLSLShaderParameter;

for auto texture unit indicing

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure SetTex(TexParam : TGLSLShaderParameter; Tex : TGLTexture); overload;

This item has no description.

Public procedure SetTex(TexParam : TGLSLShaderParameter; Mat : TGLLibMaterial); overload;

This item has no description.

Public procedure SetTex(const TexParamName : String; Mat : TGLLibMaterial); overload;

This item has no description.

Public procedure SetTex(const TexParamName : String; Tex : TGLTexture); overload;

SetTex() sets texture with automatic book-keeping of texture unit indices. Users can just call SetTex() in the OnApply event without keeping track of texture unit indices. Call from OnApply() only.

Private procedure OnChangeActiveVarying(Sender: TObject);

This item has no description.

Properties

Public property ActiveVarying: TStrings read FActiveVarying write SetActiveVarying;

This item has no description.

Public property DirectParam[const Index: Cardinal]: TGLSLShaderParameter read GetDirectParam;

This item has no description.

Public property Param[const Index: string]: TGLSLShaderParameter read GetParam;

This item has no description.

Public property TransformFeedBackMode: TGLTransformFeedBackMode read FTransformFeedBackMode write SetTransformFeedBackMode default tfbmInterleaved;


GLSysHelp v.2.5: GLSL.Shader: Class TGLSLShaderParameter

Class TGLSLShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.Shader

Declaration

type TGLSLShaderParameter = class(TGLCustomShaderParameter)

Description

Wrapper around a parameter of a GLSL program.

Hierarchy

  • TObject
  • TGLCustomShaderParameter
  • TGLSLShaderParameter

Overview

Fields

Private | FGLSLProg: TGLProgramHandle;
Private | FParameterID: Integer;

Description

Fields

Private FGLSLProg: TGLProgramHandle;

This item has no description.

Private FParameterID: Integer;


GLSysHelp v.2.5: GLSL.Shader: Class TGLSLShader

Class TGLSLShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.Shader

Declaration

type TGLSLShader = class(TGLCustomGLSLShader)

Description

This item has no description. Showing description inherited from TGLCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLSLShader

Overview

Properties

Published | property ActiveVarying;
Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property GeometryProgram;
Published | property OnApply;
Published | property OnApplyEx;
Published | property OnInitialize;
Published | property OnInitializeEx;
Published | property OnUnApply;
Published | property ShaderStyle;
Published | property TransformFeedBackMode;
Published | property VertexProgram;

Description

Properties

Published property ActiveVarying;

This item has no description.

Published property FailedInitAction;

This item has no description. Showing description inherited from TGLShader.FailedInitAction.

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Published property FragmentProgram;

This item has no description.

Published property GeometryProgram;

This item has no description.

Published property OnApply;

This item has no description.

Published property OnApplyEx;

This item has no description.

Published property OnInitialize;

This item has no description.

Published property OnInitializeEx;

This item has no description.

Published property OnUnApply;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TGLShader.ShaderStyle.

Shader application style (default is ssLowLevel).

Published property TransformFeedBackMode;

This item has no description.

Published property VertexProgram;


GLSysHelp v.2.5: GLSL.ShaderCombiner

Unit GLSL.ShaderCombiner

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLS.Material
  • GLS.Scene
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCustomShaderCombiner |
Class TGLShaderCombiner |

Types

TGLShaderCombinerType = (...);

Description

Types

TGLShaderCombinerType = (...);

MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader. sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself

TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.

Values
  • sctOneSPTwoAP
  • sctTwoSPOneAP
  • sctOneMPTwoSP
  • sctTwoMPOneSP


GLSysHelp v.2.5: GLSL.ShaderCombiner: Class TGLCustomShaderCombiner

Class TGLCustomShaderCombiner

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShaderCombiner

Declaration

type TGLCustomShaderCombiner = class(TGLShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShaderCombiner

Overview

Fields

Private | FCurrentPass: Integer;
Private | FCombinerType: TGLShaderCombinerType;
Private | FShaderOne: TGLShader;
Private | FShaderTwo: TGLShader;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function ShaderSupported: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetShaderOne(const Value: TGLShader);
Private | procedure SetShaderTwo(const Value: TGLShader);

Description

Fields

Private FCurrentPass: Integer;

This item has no description.

Private FCombinerType: TGLShaderCombinerType;

This item has no description.

Private FShaderOne: TGLShader;

This item has no description.

Private FShaderTwo: TGLShader;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function ShaderSupported: Boolean; override;

This item has no description. Showing description inherited from TGLShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetShaderOne(const Value: TGLShader);

This item has no description.

Private procedure SetShaderTwo(const Value: TGLShader);


GLSysHelp v.2.5: GLSL.ShaderCombiner: Class TGLShaderCombiner

Class TGLShaderCombiner

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShaderCombiner

Declaration

type TGLShaderCombiner = class(TGLCustomShaderCombiner)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShaderCombiner
  • TGLShaderCombiner

Overview

Properties

Published | property CombinerType;
Published | property ShaderOne;
Published | property ShaderStyle;
Published | property ShaderTwo;

Description

Properties

Published property CombinerType;

This item has no description.

Published property ShaderOne;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TGLShader.ShaderStyle.

Shader application style (default is ssLowLevel).

Published property ShaderTwo;


GLSysHelp v.2.5: GLSL.ShaderParameter

Unit GLSL.ShaderParameter

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • GLScene.Strings
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.TextureFormat
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IShaderParameter |

Functions and Procedures

function GLSLTypeEnum(AType: TGLSLDataType): Cardinal;
function GLSLTypeComponentCount(AType: TGLSLDataType): Integer;
procedure RegisterUniformAutoSetMethod(AMethodName: string; AType: TGLSLDataType; AMethod: TUniformAutoSetMethod);
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGLSLDataType); overload;
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGLSLSamplerType); overload;
function GetUniformAutoSetMethod(AMethodName: string): TUniformAutoSetMethod;
function GetUniformAutoSetMethodName(AMethod: TUniformAutoSetMethod): string;

Types

TGLgsInTypes = (...);
TGLgsOutTypes = (...);
TGLSLDataType = (...);
TGLSLSamplerType = (...);
TUniformAutoSetMethod = procedure(Sender: IShaderParameter; var ARci: TGLRenderContextInfo) of object;

Constants

cGLSLTypeString: array[TGLSLDataType] of AnsiString = ( 'undefined', 'float', 'vec2', 'vec3', 'vec4', 'int', 'ivec2', 'ivec3', 'ivec4', 'uint', 'uivec2', 'uivec3', 'uivec4', 'mat2', 'mat3', 'mat4', 'void');
cGLSLSamplerString: array[TGLSLSamplerType] of AnsiString = ( 'undefined', 'sampler1D', 'sampler2D', 'sampler3D', 'samplerCube', 'sampler1DShadow', 'sampler2DShadow', 'sampler1DArray', 'sampler2DArray', 'sampler1DArrayShadow', 'sampler2DArrayShadow', 'samplerCubeShadow', 'isampler1D', 'isampler2D', 'isampler3D', 'isamplerCube', 'isampler1DArray', 'isampler2DArray', 'usampler1D', 'usampler2D', 'usampler3D', 'usamplerCube', 'usampler1DArray', 'usampler2DArray', 'samplerRect', 'samplerRectShadow', 'samplerBuffer', 'isamplerRect', 'isamplerBuffer', 'usamplerRect', 'usamplerBuffer', 'samplerMS', 'isamplerMS', 'usamplerMS', 'samplerMSArray', 'isamplerMSArray', 'usamplerMSArray');
cGLgsInTypes : array[TGLgsInTypes] of Cardinal = (GL_POINTS, GL_LINES, GL_LINES_ADJACENCY_EXT, GL_TRIANGLES, GL_TRIANGLES_ADJACENCY_EXT);
cGLgsOutTypes: array[TGLgsOutTypes] of Cardinal = (GL_POINTS, GL_LINE_STRIP, GL_TRIANGLE_STRIP);

Description

Functions and Procedures

function GLSLTypeEnum(AType: TGLSLDataType): Cardinal;

This item has no description.

function GLSLTypeComponentCount(AType: TGLSLDataType): Integer;

This item has no description.

procedure RegisterUniformAutoSetMethod(AMethodName: string; AType: TGLSLDataType; AMethod: TUniformAutoSetMethod);

This item has no description.

procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGLSLDataType); overload;

This item has no description.

procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGLSLSamplerType); overload;

This item has no description.

function GetUniformAutoSetMethod(AMethodName: string): TUniformAutoSetMethod;

This item has no description.

function GetUniformAutoSetMethodName(AMethod: TUniformAutoSetMethod): string;

This item has no description.

Types

TGLgsInTypes = (...);

This item has no description.

Values
  • gsInPoints
  • gsInLines
  • gsInAdjLines
  • gsInTriangles
  • gsInAdjTriangles
TGLgsOutTypes = (...);

This item has no description.

Values
  • gsOutPoints
  • gsOutLineStrip
  • sOutTriangleStrip
TGLSLDataType = (...);

This item has no description.

Values
  • GLSLTypeUndefined
  • GLSLType1F
  • GLSLType2F
  • GLSLType3F
  • GLSLType4F
  • GLSLType1I
  • GLSLType2I
  • GLSLType3I
  • GLSLType4I
  • GLSLType1UI
  • GLSLType2UI
  • GLSLType3UI
  • GLSLType4UI
  • GLSLTypeMat2F
  • GLSLTypeMat3F
  • GLSLTypeMat4F
  • GLSLTypeVoid
TGLSLSamplerType = (...);

This item has no description.

Values
  • GLSLSamplerUndefined
  • GLSLSampler1D
  • GLSLSampler2D
  • GLSLSampler3D
  • GLSLSamplerCube
  • GLSLSampler1DShadow
  • GLSLSampler2DShadow
  • GLSLSampler1DArray
  • GLSLSampler2DArray
  • GLSLSampler1DArrayShadow
  • GLSLSampler2DArrayShadow
  • GLSLSamplerCubeShadow
  • GLSLIntSampler1D
  • GLSLIntSampler2D
  • GLSLIntSampler3D
  • GLSLIntSamplerCube
  • GLSLIntSampler1DArray
  • GLSLIntSampler2DArray
  • GLSLUIntSampler1D
  • GLSLUIntSampler2D
  • GLSLUIntSampler3D
  • GLSLUIntSamplerCube
  • GLSLUIntSampler1DArray
  • GLSLUIntSampler2DArray
  • GLSLSamplerRect
  • GLSLSamplerRectShadow
  • GLSLSamplerBuffer
  • GLSLIntSamplerRect
  • GLSLIntSamplerBuffer
  • GLSLUIntSamplerRect
  • GLSLUIntSamplerBuffer
  • GLSLSamplerMS
  • GLSLIntSamplerMS
  • GLSLUIntSamplerMS
  • GLSLSamplerMSArray
  • GLSLIntSamplerMSArray
  • GLSLUIntSamplerMSArray
TUniformAutoSetMethod = procedure(Sender: IShaderParameter; var ARci: TGLRenderContextInfo) of object;

This item has no description.

Constants

cGLSLTypeString: array[TGLSLDataType] of AnsiString = ( 'undefined', 'float', 'vec2', 'vec3', 'vec4', 'int', 'ivec2', 'ivec3', 'ivec4', 'uint', 'uivec2', 'uivec3', 'uivec4', 'mat2', 'mat3', 'mat4', 'void');

This item has no description.

cGLSLSamplerString: array[TGLSLSamplerType] of AnsiString = ( 'undefined', 'sampler1D', 'sampler2D', 'sampler3D', 'samplerCube', 'sampler1DShadow', 'sampler2DShadow', 'sampler1DArray', 'sampler2DArray', 'sampler1DArrayShadow', 'sampler2DArrayShadow', 'samplerCubeShadow', 'isampler1D', 'isampler2D', 'isampler3D', 'isamplerCube', 'isampler1DArray', 'isampler2DArray', 'usampler1D', 'usampler2D', 'usampler3D', 'usamplerCube', 'usampler1DArray', 'usampler2DArray', 'samplerRect', 'samplerRectShadow', 'samplerBuffer', 'isamplerRect', 'isamplerBuffer', 'usamplerRect', 'usamplerBuffer', 'samplerMS', 'isamplerMS', 'usamplerMS', 'samplerMSArray', 'isamplerMSArray', 'usamplerMSArray');

This item has no description.

cGLgsInTypes : array[TGLgsInTypes] of Cardinal = (GL_POINTS, GL_LINES, GL_LINES_ADJACENCY_EXT, GL_TRIANGLES, GL_TRIANGLES_ADJACENCY_EXT);

This item has no description.

cGLgsOutTypes: array[TGLgsOutTypes] of Cardinal = (GL_POINTS, GL_LINE_STRIP, GL_TRIANGLE_STRIP);


GLSysHelp v.2.5: GLSL.ShaderParameter: Interface IShaderParameter

Interface IShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShaderParameter

Declaration

type IShaderParameter = interface(IInterface)

Description

This item has no description.

Hierarchy

  • IInterface
  • IShaderParameter

Overview

Methods

Public | function GetAutoSetMethod: string;
Public | function GetFloat: Single;
Public | function GetGLSLSamplerType: TGLSLSamplerType;
Public | function GetGLSLType: TGLSLDataType;
Public | function GetInt: Integer;
Public | function GetIVec2: TVector2i;
Public | function GetIVec3: TVector3i;
Public | function GetIVec4: TVector4i;
Public | function GetMat2: TMatrix2f;
Public | function GetMat3: TMatrix3f;
Public | function GetMat4: TMatrix4f;
Public | function GetName: string;
Public | function GetSamplerName: string;
Public | function GetTextureName: string;
Public | function GetTextureSwizzle: TglSwizzleVector;
Public | function GetUInt: Cardinal;
Public | function GetUVec2: TVector2ui;
Public | function GetUVec3: TVector3ui;
Public | function GetUVec4: TVector4ui;
Public | function GetVec2: TVector2f;
Public | function GetVec3: TVector3f;
Public | function GetVec4: TVector4f;
Public | procedure SetAutoSetMethod(const AValue: string);
Public | procedure SetFloat(const Value: TGLFloat);
Public | procedure SetFloatArray(const Values: PGLFloat; Count: Integer);
Public | procedure SetInt(const Value: Integer);
Public | procedure SetIntArray(const Values: PGLInt; Count: Integer);
Public | procedure SetIVec2(const Value: TVector2i);
Public | procedure SetIVec3(const Value: TVector3i);
Public | procedure SetIVec4(const Value: TVector4i);
Public | procedure SetMat2(const Value: TMatrix2f);
Public | procedure SetMat3(const Value: TMatrix3f);
Public | procedure SetMat4(const Value: TMatrix4f);
Public | procedure SetSamplerName(const AValue: string);
Public | procedure SetTextureName(const AValue: string);
Public | procedure SetTextureSwizzle(const AValue: TglSwizzleVector);
Public | procedure SetUInt(const Value: Cardinal);
Public | procedure SetUIntArray(const Values: PGLUInt; Count: Integer);
Public | procedure SetUVec2(const Value: TVector2ui);
Public | procedure SetUVec3(const Value: TVector3ui);
Public | procedure SetUVec4(const Value: TVector4ui);
Public | procedure SetVec2(const Value: TVector2f);
Public | procedure SetVec3(const Value: TVector3f);
Public | procedure SetVec4(const Value: TVector4f);

Properties

Public | property AutoSetMethod: string read GetAutoSetMethod write SetAutoSetMethod;
Public | property float: TGLFloat read GetFloat write SetFloat;
Public | property GLSLSamplerType: TGLSLSamplerType read GetGLSLSamplerType;
Public | property GLSLType: TGLSLDataType read GetGLSLType;
Public | property int: Integer read GetInt write SetInt;
Public | property ivec2: TVector2i read GetIVec2 write SetIVec2;
Public | property ivec3: TVector3i read GetIVec3 write SetIVec3;
Public | property ivec4: TVector4i read GetIVec4 write SetIVec4;
Public | property mat2: TMatrix2f read GetMat2 write SetMat2;
Public | property mat3: TMatrix3f read GetMat3 write SetMat3;
Public | property mat4: TMatrix4f read GetMat4 write SetMat4;
Public | property Name: string read GetName;
Public | property SamplerName: string read GetSamplerName write SetSamplerName;
Public | property TextureName: string read GetTextureName write SetTextureName;
Public | property TextureSwizzle: TglSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;
Public | property uint: Cardinal read GetUInt write SetUInt;
Public | property uvec2: TVector2ui read GetUVec2 write SetUVec2;
Public | property uvec3: TVector3ui read GetUVec3 write SetUVec3;
Public | property uvec4: TVector4ui read GetUVec4 write SetUVec4;
Public | property vec2: TVector2f read GetVec2 write SetVec2;
Public | property vec3: TVector3f read GetVec3 write SetVec3;
Public | property vec4: TVector4f read GetVec4 write SetVec4;

Description

Methods

Public function GetAutoSetMethod: string;

This item has no description.

Public function GetFloat: Single;

This item has no description.

Public function GetGLSLSamplerType: TGLSLSamplerType;

This item has no description.

Public function GetGLSLType: TGLSLDataType;

This item has no description.

Public function GetInt: Integer;

This item has no description.

Public function GetIVec2: TVector2i;

This item has no description.

Public function GetIVec3: TVector3i;

This item has no description.

Public function GetIVec4: TVector4i;

This item has no description.

Public function GetMat2: TMatrix2f;

This item has no description.

Public function GetMat3: TMatrix3f;

This item has no description.

Public function GetMat4: TMatrix4f;

This item has no description.

Public function GetName: string;

This item has no description.

Public function GetSamplerName: string;

This item has no description.

Public function GetTextureName: string;

This item has no description.

Public function GetTextureSwizzle: TglSwizzleVector;

This item has no description.

Public function GetUInt: Cardinal;

This item has no description.

Public function GetUVec2: TVector2ui;

This item has no description.

Public function GetUVec3: TVector3ui;

This item has no description.

Public function GetUVec4: TVector4ui;

This item has no description.

Public function GetVec2: TVector2f;

This item has no description.

Public function GetVec3: TVector3f;

This item has no description.

Public function GetVec4: TVector4f;

This item has no description.

Public procedure SetAutoSetMethod(const AValue: string);

This item has no description.

Public procedure SetFloat(const Value: TGLFloat);

This item has no description.

Public procedure SetFloatArray(const Values: PGLFloat; Count: Integer);

This item has no description.

Public procedure SetInt(const Value: Integer);

This item has no description.

Public procedure SetIntArray(const Values: PGLInt; Count: Integer);

This item has no description.

Public procedure SetIVec2(const Value: TVector2i);

This item has no description.

Public procedure SetIVec3(const Value: TVector3i);

This item has no description.

Public procedure SetIVec4(const Value: TVector4i);

This item has no description.

Public procedure SetMat2(const Value: TMatrix2f);

This item has no description.

Public procedure SetMat3(const Value: TMatrix3f);

This item has no description.

Public procedure SetMat4(const Value: TMatrix4f);

This item has no description.

Public procedure SetSamplerName(const AValue: string);

This item has no description.

Public procedure SetTextureName(const AValue: string);

This item has no description.

Public procedure SetTextureSwizzle(const AValue: TglSwizzleVector);

This item has no description.

Public procedure SetUInt(const Value: Cardinal);

This item has no description.

Public procedure SetUIntArray(const Values: PGLUInt; Count: Integer);

This item has no description.

Public procedure SetUVec2(const Value: TVector2ui);

This item has no description.

Public procedure SetUVec3(const Value: TVector3ui);

This item has no description.

Public procedure SetUVec4(const Value: TVector4ui);

This item has no description.

Public procedure SetVec2(const Value: TVector2f);

This item has no description.

Public procedure SetVec3(const Value: TVector3f);

This item has no description.

Public procedure SetVec4(const Value: TVector4f);

This item has no description.

Properties

Public property AutoSetMethod: string read GetAutoSetMethod write SetAutoSetMethod;

Bindings.

Public property float: TGLFloat read GetFloat write SetFloat;

Scalar types.

Public property GLSLSamplerType: TGLSLSamplerType read GetGLSLSamplerType;

This item has no description.

Public property GLSLType: TGLSLDataType read GetGLSLType;

This item has no description.

Public property int: Integer read GetInt write SetInt;

This item has no description.

Public property ivec2: TVector2i read GetIVec2 write SetIVec2;

Integer vector types.

Public property ivec3: TVector3i read GetIVec3 write SetIVec3;

This item has no description.

Public property ivec4: TVector4i read GetIVec4 write SetIVec4;

This item has no description.

Public property mat2: TMatrix2f read GetMat2 write SetMat2;

Matrix Types.

Public property mat3: TMatrix3f read GetMat3 write SetMat3;

This item has no description.

Public property mat4: TMatrix4f read GetMat4 write SetMat4;

This item has no description.

Public property Name: string read GetName;

This item has no description.

Public property SamplerName: string read GetSamplerName write SetSamplerName;

This item has no description.

Public property TextureName: string read GetTextureName write SetTextureName;

This item has no description.

Public property TextureSwizzle: TglSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;

This item has no description.

Public property uint: Cardinal read GetUInt write SetUInt;

This item has no description.

Public property uvec2: TVector2ui read GetUVec2 write SetUVec2;

Unsigned integer vector types.

Public property uvec3: TVector3ui read GetUVec3 write SetUVec3;

This item has no description.

Public property uvec4: TVector4ui read GetUVec4 write SetUVec4;

This item has no description.

Public property vec2: TVector2f read GetVec2 write SetVec2;

Float vector types.

Public property vec3: TVector3f read GetVec3 write SetVec3;

This item has no description.

Public property vec4: TVector4f read GetVec4 write SetVec4;


GLSysHelp v.2.5: GLSL.ShapeShaders

Unit GLSL.ShapeShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.BaseClasses
  • GLS.State
  • GLS.Context
  • GLS.Graphics
  • GLS.RenderContextInfo
  • GLS.Coordinates
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.TextureFormat
  • GLS.Color
  • GLS.Texture
  • GLS.Material
  • GLSL.Shader
  • GLSL.CustomShader

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCelShader |
Class TGLCustomGLSLSimpleErosionShader |
Class TGLSLSimpleErosionShader |
Class TGLCustomGLSLGlassShader |
Class TGLSLGlassShader |
Class TGLCustomGLSLSimpleGoochShader |
Class TGLSLSimpleGoochShader |
Class TGLCustomGLSLFurShader |
Class TGLSLFurShader |
Class TGLCustomGLSLIvoryShader |
Class TGLSLIvoryShader |
Class TGLCustomGLSLSimpleLatticeShader |
Class TGLCustomGLSLLatticeShader |
Class TGLSLSimpleLatticeShader |
Class TGLSLLatticeShader |
Class TGLCustomGLSLSemShader |
Class TGLSLSemShader |
Class TGLCustomGLSLToonShader |
Class TGLSLToonShader |
Class TGLCustomGLSLVertexDisplacementShader |
Class TGLSLVertexDisplacementShader |

Types

TGLCelShaderGetIntensity = procedure(Sender: TObject; var intensity: Byte) of object;
TGLCelShaderOption = (...);
TGLCelShaderOptions = set of TGLCelShaderOption;

Description

Types

TGLCelShaderGetIntensity = procedure(Sender: TObject; var intensity: Byte) of object;

An event for user defined cel intensity.

TGLCelShaderOption = (...);

A shader that applies cel shading through a vertex program and shade definition texture. Cel shading options: csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.

Values
  • csoOutlines
  • csoTextured
  • csoNoBuildShadeTexture
TGLCelShaderOptions = set of TGLCelShaderOption;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCelShader

Class TGLCelShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCelShader = class(TGLShader)

Description

A generic cel shader.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCelShader

Overview

Fields

Private | FOutlineWidth: Single;
Private | FCelShaderOptions: TGLCelShaderOptions;
Private | FVPHandle: TGLARBVertexProgramHandle;
Private | FShadeTexture: TGLTexture;
Private | FOnGetIntensity: TGLCelShaderGetIntensity;
Private | FOutlinePass: Boolean;
Private | FUnApplyShadeTexture: Boolean;
Private | FOutlineColor: TGLColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function DoUnApply(var rci: TGLRenderContextInfo): Boolean; override;
Public | procedure DoApply(var rci: TGLRenderContextInfo; Sender: TObject); override;

Properties

Published | property CelShaderOptions: TGLCelShaderOptions read FCelShaderOptions write SetCelShaderOptions;
Published | property OnGetIntensity: TGLCelShaderGetIntensity read FOnGetIntensity write FOnGetIntensity;
Published | property OutlineColor: TGLColor read FOutlineColor write SetOutlineColor;
Published | property OutlineWidth: Single read FOutlineWidth write SetOutlineWidth;
Public | property ShadeTexture: TGLTexture read FShadeTexture;

Description

Fields

Private FOutlineWidth: Single;

This item has no description.

Private FCelShaderOptions: TGLCelShaderOptions;

This item has no description.

Private FVPHandle: TGLARBVertexProgramHandle;

This item has no description.

Private FShadeTexture: TGLTexture;

This item has no description.

Private FOnGetIntensity: TGLCelShaderGetIntensity;

This item has no description.

Private FOutlinePass: Boolean;

This item has no description.

Private FUnApplyShadeTexture: Boolean;

This item has no description.

Private FOutlineColor: TGLColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DoUnApply(var rci: TGLRenderContextInfo): Boolean; override;

This item has no description.

Public procedure DoApply(var rci: TGLRenderContextInfo; Sender: TObject); override;

This item has no description.

Properties

Published property CelShaderOptions: TGLCelShaderOptions read FCelShaderOptions write SetCelShaderOptions;

This item has no description.

Published property OnGetIntensity: TGLCelShaderGetIntensity read FOnGetIntensity write FOnGetIntensity;

This item has no description.

Published property OutlineColor: TGLColor read FOutlineColor write SetOutlineColor;

This item has no description.

Published property OutlineWidth: Single read FOutlineWidth write SetOutlineWidth;

This item has no description.

Public property ShadeTexture: TGLTexture read FShadeTexture;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLSimpleErosionShader

Class TGLCustomGLSLSimpleErosionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLSimpleErosionShader = class(TGLCustomGLSLShader)

Description

Custom class for a shader that Erode surface object

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSimpleErosionShader

Overview

Fields

Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FMainTex: TGLTexture;
Private | FNoiseTex: TGLTexture;
Private | FErosionTex: TGLTexture;
Private | FMainTexName: TGLLibMaterialName;
Private | FNoiseTexName: TGLLibMaterialName;
Private | FErosionTexName: TGLLibMaterialName;
Private | FErosionScale: Single;
Private | FErosionFactor: Single;
Private | FIntensityFactor1: Single;
Private | FIntensityFactor2: Single;
Private | FSpecularColor: TGLColor;
Private | FAmbientColor: TGLColor;
Private | FAmbientFactor: Single;
Private | FDiffuseFactor: Single;
Private | FSpecularFactor: Single;
Private | FSpecularRoughness: Single;
Private | FAnisotropicRoughness: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetErosionTexName: TGLLibMaterialName;
Private | function GetMainTexName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function GetNoiseTexName: TGLLibMaterialName;
Private | procedure SetAmbientColor(AValue: TGLColor);
Private | procedure SetErosionTexName(const Value: TGLLibMaterialName);
Private | procedure SetErosionTexTexture(const Value: TGLTexture);
Private | procedure SetMainTexName(const Value: TGLLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TGLTexture);
Private | procedure SetNoiseTexName(const Value: TGLLibMaterialName);
Private | procedure SetNoiseTexTexture(const Value: TGLTexture);
Private | procedure SetSpecularColor(AValue: TGLColor);

Properties

Public | property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;
Public | property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;
Public | property AnisotropicRoughness : Single Read FAnisotropicRoughness Write FAnisotropicRoughness;
Public | property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;
Public | property ErosionFactor: Single read FErosionFactor write FErosionFactor;
Public | property ErosionScale: Single read FErosionFactor write FErosionFactor;
Public | property ErosionTexture: TGLTexture read FErosionTex write SetErosionTexTexture;
Public | property ErosionTextureName: TGLLibMaterialName read GetErosionTexName write SetErosionTexName;
Public | property IntensityFactor1: Single read FIntensityFactor1 write FIntensityFactor1;
Public | property IntensityFactor2: Single read FIntensityFactor2 write FIntensityFactor2;
Public | property MainTexture: TGLTexture read FMainTex write SetMainTexTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property NoiseTexture: TGLTexture read FNoiseTex write SetNoiseTexTexture;
Public | property NoiseTextureName: TGLLibMaterialName read GetNoiseTexName write SetNoiseTexName;
Public | property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;
Public | property SpecularRoughness : Single Read FSpecularRoughness Write FSpecularRoughness;

Description

Fields

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FMainTex: TGLTexture;

This item has no description.

Private FNoiseTex: TGLTexture;

This item has no description.

Private FErosionTex: TGLTexture;

This item has no description.

Private FMainTexName: TGLLibMaterialName;

This item has no description.

Private FNoiseTexName: TGLLibMaterialName;

This item has no description.

Private FErosionTexName: TGLLibMaterialName;

This item has no description.

Private FErosionScale: Single;

This item has no description.

Private FErosionFactor: Single;

This item has no description.

Private FIntensityFactor1: Single;

This item has no description.

Private FIntensityFactor2: Single;

This item has no description.

Private FSpecularColor: TGLColor;

This item has no description.

Private FAmbientColor: TGLColor;

This item has no description.

Private FAmbientFactor: Single;

This item has no description.

Private FDiffuseFactor: Single;

This item has no description.

Private FSpecularFactor: Single;

This item has no description.

Private FSpecularRoughness: Single;

This item has no description.

Private FAnisotropicRoughness: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetErosionTexName: TGLLibMaterialName;

This item has no description.

Private function GetMainTexName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private function GetNoiseTexName: TGLLibMaterialName;

This item has no description.

Private procedure SetAmbientColor(AValue: TGLColor);

This item has no description.

Private procedure SetErosionTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetErosionTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetMainTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetNoiseTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetNoiseTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetSpecularColor(AValue: TGLColor);

This item has no description.

Properties

Public property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;

This item has no description.

Public property AnisotropicRoughness : Single Read FAnisotropicRoughness Write FAnisotropicRoughness;

This item has no description.

Public property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;

This item has no description.

Public property ErosionFactor: Single read FErosionFactor write FErosionFactor;

This item has no description.

Public property ErosionScale: Single read FErosionFactor write FErosionFactor;

This item has no description.

Public property ErosionTexture: TGLTexture read FErosionTex write SetErosionTexTexture;

This item has no description.

Public property ErosionTextureName: TGLLibMaterialName read GetErosionTexName write SetErosionTexName;

This item has no description.

Public property IntensityFactor1: Single read FIntensityFactor1 write FIntensityFactor1;

This item has no description.

Public property IntensityFactor2: Single read FIntensityFactor2 write FIntensityFactor2;

This item has no description.

Public property MainTexture: TGLTexture read FMainTex write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

property Color1: TGLColor read FColor1; property Color2: TGLColor read FColor2;

Public property NoiseTexture: TGLTexture read FNoiseTex write SetNoiseTexTexture;

This item has no description.

Public property NoiseTextureName: TGLLibMaterialName read GetNoiseTexName write SetNoiseTexName;

This item has no description.

Public property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;

This item has no description.

Public property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;

This item has no description.

Public property SpecularRoughness : Single Read FSpecularRoughness Write FSpecularRoughness;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLSimpleErosionShader

Class TGLSLSimpleErosionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLSimpleErosionShader = class(TGLCustomGLSLSimpleErosionShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLSimpleErosionShader.

Custom class for a shader that Erode surface object

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSimpleErosionShader
  • TGLSLSimpleErosionShader

Overview

Properties

Published | property AmbientColor;
Published | property AmbientFactor;
Published | property AnisotropicRoughness;
Published | property DiffuseFactor;
Published | property ErosionFactor;
Published | property ErosionScale;
Published | property ErosionTexture;
Published | property ErosionTextureName;
Published | property IntensityFactor1;
Published | property IntensityFactor2;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NoiseTexture;
Published | property NoiseTextureName;
Published | property SpecularColor;
Published | property SpecularFactor;
Published | property SpecularRoughness;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property AmbientFactor;

This item has no description.

Published property AnisotropicRoughness;

This item has no description.

Published property DiffuseFactor;

This item has no description.

Published property ErosionFactor;

This item has no description.

Published property ErosionScale;

This item has no description.

Published property ErosionTexture;

This item has no description.

Published property ErosionTextureName;

This item has no description.

Published property IntensityFactor1;

This item has no description.

Published property IntensityFactor2;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

property Color1; property Color2;

Published property NoiseTexture;

This item has no description.

Published property NoiseTextureName;

This item has no description.

Published property SpecularColor;

This item has no description.

Published property SpecularFactor;

This item has no description.

Published property SpecularRoughness;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLGlassShader

Class TGLCustomGLSLGlassShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLGlassShader = class(TGLCustomGLSLShader)

Description

Custom class for Glass shader: Environment mapping and refraction mapping using the fresnel terms

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLGlassShader

Overview

Fields

Private | FDiffuseColor: TGLColor;
Private | FDepth: Single;
Private | FMix: Single;
Private | FAlpha: Single;
Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FMainTexture: TGLTexture;
Private | FMainTexName: TGLLibMaterialName;
Private | FRefractionTexture: TGLTexture;
Private | FRefractionTexName: TGLLibMaterialName;
Private | FOwnerObject: TGLBaseSceneObject;
Private | FBlendSrc: TGLBlendFunction;
Private | FBlendDst: TGLBlendFunction;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function GetRefractionTexName: TGLLibMaterialName;
Private | procedure SetDiffuseColor(AValue: TGLColor);
Private | procedure SetMainTexName(const Value: TGLLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TGLTexture);
Private | procedure SetRefractionTexName(const Value: TGLLibMaterialName);
Private | procedure SetRefractionTexTexture(const Value: TGLTexture);

Properties

Public | property Alpha: Single read FAlpha write FAlpha;
Public | property BlendDst: TGLBlendFunction read FBlendDst write FBlendDst default bfDstAlpha;
Public | property BlendSrc: TGLBlendFunction read FBlendSrc write FBlendSrc default bfSrcAlpha;
Public | property Depth: Single read FDepth write FDepth;
Public | property DiffuseColor: TGLColor read FDiffuseColor Write SetDiffuseColor;
Public | property MainTexture: TGLTexture read FMainTexture write SetMainTexTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;
Public | property Mix: Single read FMix write FMix;
Public | property OwnerObject: TGLBaseSceneObject read FOwnerObject write FOwnerObject;
Public | property RefractionTexture: TGLTexture read FRefractionTexture write SetRefractionTexTexture;
Public | property RefractionTextureName: TGLLibMaterialName read GetRefractionTexName write SetRefractionTexName;

Description

Fields

Private FDiffuseColor: TGLColor;

This item has no description.

Private FDepth: Single;

This item has no description.

Private FMix: Single;

This item has no description.

Private FAlpha: Single;

This item has no description.

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FMainTexture: TGLTexture;

This item has no description.

Private FMainTexName: TGLLibMaterialName;

EnvMap

Private FRefractionTexture: TGLTexture;

This item has no description.

Private FRefractionTexName: TGLLibMaterialName;

This item has no description.

Private FOwnerObject: TGLBaseSceneObject;

This item has no description.

Private FBlendSrc: TGLBlendFunction;

This item has no description.

Private FBlendDst: TGLBlendFunction;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private function GetRefractionTexName: TGLLibMaterialName;

This item has no description.

Private procedure SetDiffuseColor(AValue: TGLColor);

This item has no description.

Private procedure SetMainTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetRefractionTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetRefractionTexTexture(const Value: TGLTexture);

This item has no description.

Properties

Public property Alpha: Single read FAlpha write FAlpha;

This item has no description.

Public property BlendDst: TGLBlendFunction read FBlendDst write FBlendDst default bfDstAlpha;

This item has no description.

Public property BlendSrc: TGLBlendFunction read FBlendSrc write FBlendSrc default bfSrcAlpha;

This item has no description.

Public property Depth: Single read FDepth write FDepth;

This item has no description.

Public property DiffuseColor: TGLColor read FDiffuseColor Write SetDiffuseColor;

This item has no description.

Public property MainTexture: TGLTexture read FMainTexture write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property Mix: Single read FMix write FMix;

This item has no description.

Public property OwnerObject: TGLBaseSceneObject read FOwnerObject write FOwnerObject;

This item has no description.

Public property RefractionTexture: TGLTexture read FRefractionTexture write SetRefractionTexTexture;

This item has no description.

Public property RefractionTextureName: TGLLibMaterialName read GetRefractionTexName write SetRefractionTexName;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLGlassShader

Class TGLSLGlassShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLGlassShader = class(TGLCustomGLSLGlassShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLGlassShader.

Custom class for Glass shader: Environment mapping and refraction mapping using the fresnel terms

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLGlassShader
  • TGLSLGlassShader

Overview

Properties

Published | property Alpha;
Published | property BlendDst;
Published | property BlendSrc;
Published | property Depth;
Published | property DiffuseColor;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property Mix;
Published | property OwnerObject;
Published | property RefractionTexture;
Published | property RefractionTextureName;

Description

Properties

Published property Alpha;

This item has no description.

Published property BlendDst;

This item has no description.

Published property BlendSrc;

This item has no description.

Published property Depth;

This item has no description.

Published property DiffuseColor;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property Mix;

This item has no description.

Published property OwnerObject;

This item has no description.

Published property RefractionTexture;

This item has no description.

Published property RefractionTextureName;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLSimpleGoochShader

Class TGLCustomGLSLSimpleGoochShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLSimpleGoochShader = class(TGLCustomGLSLShader)

Description

Custom class for Gooch Shader

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSimpleGoochShader

Overview

Fields

Private | FDiffuseColor: TGLColor;
Private | FWarmColor: TGLColor;
Private | FCoolColor: TGLColor;
Private | FSpecularColor: TGLColor;
Private | FAmbientColor: TGLColor;
Private | FDiffuseWarm: Single;
Private | FDiffuseCool: Single;
Private | FAmbientFactor: Single;
Private | FDiffuseFactor: Single;
Private | FSpecularFactor: Single;
Private | FBlendingMode: TGLBlendingModeEx;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetAmbientColor(AValue: TGLColor);
Private | procedure SetCoolColor(AValue: TGLColor);
Private | procedure SetDiffuseColor(AValue: TGLColor);
Private | procedure SetSpecularColor(AValue: TGLColor);
Private | procedure SetWarmColor(AValue: TGLColor);

Properties

Public | property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;
Public | property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;
Public | property BlendingMode: TGLBlendingModeEx read FBlendingMode write FBlendingMode default bmxOpaque;
Public | property CoolColor : TGLColor Read FCoolColor Write setCoolColor;
Public | property CoolFactor : Single Read FDiffuseCool Write FDiffuseCool;
Public | property DiffuseColor : TGLColor read FDiffuseColor Write setDiffuseColor;
Public | property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;
Public | property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;
Public | property WarmColor : TGLColor read FWarmColor Write setWarmColor;
Public | property WarmFactor : Single Read FDiffuseWarm Write FDiffuseWarm;

Description

Fields

Private FDiffuseColor: TGLColor;

This item has no description.

Private FWarmColor: TGLColor;

This item has no description.

Private FCoolColor: TGLColor;

This item has no description.

Private FSpecularColor: TGLColor;

This item has no description.

Private FAmbientColor: TGLColor;

This item has no description.

Private FDiffuseWarm: Single;

This item has no description.

Private FDiffuseCool: Single;

This item has no description.

Private FAmbientFactor: Single;

This item has no description.

Private FDiffuseFactor: Single;

This item has no description.

Private FSpecularFactor: Single;

This item has no description.

Private FBlendingMode: TGLBlendingModeEx;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetAmbientColor(AValue: TGLColor);

This item has no description.

Private procedure SetCoolColor(AValue: TGLColor);

This item has no description.

Private procedure SetDiffuseColor(AValue: TGLColor);

This item has no description.

Private procedure SetSpecularColor(AValue: TGLColor);

This item has no description.

Private procedure SetWarmColor(AValue: TGLColor);

This item has no description.

Properties

Public property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;

This item has no description.

Public property BlendingMode: TGLBlendingModeEx read FBlendingMode write FBlendingMode default bmxOpaque;

This item has no description.

Public property CoolColor : TGLColor Read FCoolColor Write setCoolColor;

This item has no description.

Public property CoolFactor : Single Read FDiffuseCool Write FDiffuseCool;

This item has no description.

Public property DiffuseColor : TGLColor read FDiffuseColor Write setDiffuseColor;

This item has no description.

Public property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;

This item has no description.

Public property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;

This item has no description.

Public property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;

This item has no description.

Public property WarmColor : TGLColor read FWarmColor Write setWarmColor;

This item has no description.

Public property WarmFactor : Single Read FDiffuseWarm Write FDiffuseWarm;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLSimpleGoochShader

Class TGLSLSimpleGoochShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLSimpleGoochShader = class(TGLCustomGLSLSimpleGoochShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLSimpleGoochShader.

Custom class for Gooch Shader

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSimpleGoochShader
  • TGLSLSimpleGoochShader

Overview

Properties

Published | property AmbientColor;
Published | property AmbientFactor;
Published | property CoolColor;
Published | property CoolFactor;
Published | property DiffuseColor;
Published | property DiffuseFactor;
Published | property SpecularColor;
Published | property SpecularFactor;
Published | property WarmColor;
Published | property WarmFactor;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property AmbientFactor;

This item has no description.

Published property CoolColor;

This item has no description.

Published property CoolFactor;

This item has no description.

Published property DiffuseColor;

This item has no description.

Published property DiffuseFactor;

This item has no description.

Published property SpecularColor;

This item has no description.

Published property SpecularFactor;

This item has no description.

Published property WarmColor;

This item has no description.

Published property WarmFactor;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLFurShader

Class TGLCustomGLSLFurShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLFurShader = class(TGLCustomGLSLShader)

Description

Custom class for Fur Shader

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLFurShader

Overview

Fields

Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FCurrentPass: Integer;
Private | FPassCount: Single;
Private | FFurLength: Single;
Private | FMaxFurLength: Single;
Private | FFurScale: Single;
Private | FRandomFurLength: Boolean;
Private | FColorScale: TGLColor;
Private | FAmbient: TGLColor;
Private | FGravity: TGLCoordinates;
Private | FLightIntensity: Single;
Private | FMainTex: TGLTexture;
Private | FNoiseTex: TGLTexture;
Private | FNoiseTexName: TGLLibMaterialName;
Private | FMainTexName: TGLLibMaterialName;
Private | FBlendSrc: TGLBlendFunction;
Private | FBlendDst: TGLBlendFunction;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | function GetNoiseTexName: TGLLibMaterialName;
Private | procedure SetAmbient(AValue: TGLColor);
Private | procedure SetColorScale(AValue: TGLColor);
Private | procedure SetGravity(APosition:TGLCoordinates);
Private | procedure SetMainTexName(const Value: TGLLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TGLTexture);
Private | procedure SetNoiseTexName(const Value: TGLLibMaterialName);
Private | procedure SetNoiseTexTexture(const Value: TGLTexture);

Properties

Public | property Ambient: TGLColor read FAmbient write setAmbient;
Public | property BlendDst : TGLBlendFunction read FBlendDst write FBlendDst default bfOneMinusDstColor;
Public | property BlendSrc : TGLBlendFunction read FBlendSrc write FBlendSrc default bfSrcColor;
Public | property ColorScale: TGLColor read FColorScale Write setColorScale;
Public | property FurDensity: Single read FFurScale write FFurScale;
Public | property FurLength: Single read FFurLength write FFurLength;
Public | property Gravity : TGLCoordinates Read FGravity write setGravity;
Public | property LightIntensity : Single read FLightIntensity Write FLightIntensity;
Public | property MainTexture: TGLTexture read FMainTex write SetMainTexTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property MaxFurLength: Single read FMaxFurLength write FMaxFurLength;
Public | property NoiseTexture: TGLTexture read FNoiseTex write SetNoiseTexTexture;
Public | property NoiseTextureName: TGLLibMaterialName read GetNoiseTexName write SetNoiseTexName;
Public | property PassCount: Single read FPassCount write FPassCount;
Public | property RandomFurLength : Boolean read FRandomFurLength Write FRandomFurLength;

Description

Fields

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FCurrentPass: Integer;

This item has no description.

Private FPassCount: Single;

This item has no description.

Private FFurLength: Single;

This item has no description.

Private FMaxFurLength: Single;

This item has no description.

Private FFurScale: Single;

This item has no description.

Private FRandomFurLength: Boolean;

This item has no description.

Private FColorScale: TGLColor;

This item has no description.

Private FAmbient: TGLColor;

This item has no description.

Private FGravity: TGLCoordinates;

This item has no description.

Private FLightIntensity: Single;

This item has no description.

Private FMainTex: TGLTexture;

This item has no description.

Private FNoiseTex: TGLTexture;

This item has no description.

Private FNoiseTexName: TGLLibMaterialName;

This item has no description.

Private FMainTexName: TGLLibMaterialName;

This item has no description.

Private FBlendSrc: TGLBlendFunction;

This item has no description.

Private FBlendDst: TGLBlendFunction;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

Common stuff

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

FBlendEquation : TGLBlendEquation;

Private function GetNoiseTexName: TGLLibMaterialName;

This item has no description.

Private procedure SetAmbient(AValue: TGLColor);

This item has no description.

Private procedure SetColorScale(AValue: TGLColor);

This item has no description.

Private procedure SetGravity(APosition:TGLCoordinates);

This item has no description.

Private procedure SetMainTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetNoiseTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetNoiseTexTexture(const Value: TGLTexture);

This item has no description.

Properties

Public property Ambient: TGLColor read FAmbient write setAmbient;

This item has no description.

Public property BlendDst : TGLBlendFunction read FBlendDst write FBlendDst default bfOneMinusDstColor;

This item has no description.

Public property BlendSrc : TGLBlendFunction read FBlendSrc write FBlendSrc default bfSrcColor;

property BlendEquation : TBlendEquation read FBlendEquation write FBlendEquation default beMin;

Public property ColorScale: TGLColor read FColorScale Write setColorScale;

This item has no description.

Public property FurDensity: Single read FFurScale write FFurScale;

This item has no description.

Public property FurLength: Single read FFurLength write FFurLength;

This item has no description.

Public property Gravity : TGLCoordinates Read FGravity write setGravity;

This item has no description.

Public property LightIntensity : Single read FLightIntensity Write FLightIntensity;

This item has no description.

Public property MainTexture: TGLTexture read FMainTex write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property MaxFurLength: Single read FMaxFurLength write FMaxFurLength;

This item has no description.

Public property NoiseTexture: TGLTexture read FNoiseTex write SetNoiseTexTexture;

This item has no description.

Public property NoiseTextureName: TGLLibMaterialName read GetNoiseTexName write SetNoiseTexName;

This item has no description.

Public property PassCount: Single read FPassCount write FPassCount;

This item has no description.

Public property RandomFurLength : Boolean read FRandomFurLength Write FRandomFurLength;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLFurShader

Class TGLSLFurShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLFurShader = class(TGLCustomGLSLFurShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLFurShader.

Custom class for Fur Shader

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLFurShader
  • TGLSLFurShader

Overview

Properties

Published | property Ambient;
Published | property BlendDst;
Published | property BlendSrc;
Published | property ColorScale;
Published | property FurDensity;
Published | property FurLength;
Published | property Gravity;
Published | property LightIntensity;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaxFurLength;
Published | property NoiseTexture;
Published | property NoiseTextureName;
Published | property PassCount;
Published | property RandomFurLength;

Description

Properties

Published property Ambient;

This item has no description.

Published property BlendDst;

This item has no description.

Published property BlendSrc;

This item has no description. Showing description inherited from TGLCustomGLSLFurShader.BlendSrc.

property BlendEquation : TBlendEquation read FBlendEquation write FBlendEquation default beMin;

Published property ColorScale;

This item has no description.

Published property FurDensity;

This item has no description.

Published property FurLength;

This item has no description.

Published property Gravity;

This item has no description.

Published property LightIntensity;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaxFurLength;

This item has no description.

Published property NoiseTexture;

This item has no description.

Published property NoiseTextureName;

This item has no description.

Published property PassCount;

This item has no description.

Published property RandomFurLength;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLIvoryShader

Class TGLCustomGLSLIvoryShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLIvoryShader = class(TGLCustomGLSLShader)

Description

Custom class for a shader that simulate Ivory Material

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLIvoryShader

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLIvoryShader

Class TGLSLIvoryShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLIvoryShader = class(TGLCustomGLSLIvoryShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLIvoryShader.

Custom class for a shader that simulate Ivory Material

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLIvoryShader
  • TGLSLIvoryShader


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLSimpleLatticeShader

Class TGLCustomGLSLSimpleLatticeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLSimpleLatticeShader = class(TGLCustomGLSLShader)

Description

Custom class for a shader that simulate Lattice

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSimpleLatticeShader

Overview

Fields

Private | FLatticeScale: TGLCoordinates2;
Private | FLatticeThreshold: TGLCoordinates2;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetLatticeScale(const Value: TGLCoordinates2);
Private | procedure SetLatticeThreshold(const Value: TGLCoordinates2);

Properties

Public | property LatticeScale: TGLCoordinates2 read FLatticeScale write SetLatticeScale;
Public | property LatticeThreshold: TGLCoordinates2 read FLatticeThreshold write SetLatticeThreshold;

Description

Fields

Private FLatticeScale: TGLCoordinates2;

This item has no description.

Private FLatticeThreshold: TGLCoordinates2;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetLatticeScale(const Value: TGLCoordinates2);

This item has no description.

Private procedure SetLatticeThreshold(const Value: TGLCoordinates2);

This item has no description.

Properties

Public property LatticeScale: TGLCoordinates2 read FLatticeScale write SetLatticeScale;

This item has no description.

Public property LatticeThreshold: TGLCoordinates2 read FLatticeThreshold write SetLatticeThreshold;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLLatticeShader

Class TGLCustomGLSLLatticeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLLatticeShader = class(TGLCustomGLSLSimpleLatticeShader)

Description

Custom class for GLSLLatticeShader. A shader that simulate Lattice with Diffuse/Specular and support Texture

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSimpleLatticeShader
  • TGLCustomGLSLLatticeShader

Overview

Fields

Private | FAmbientColor: TGLColor;
Private | FDiffuseColor: TGLColor;
Private | FSpecularColor: TGLColor;
Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FMainTexture: TGLTexture;
Private | FMainTexName: TGLLibMaterialName;
Private | FSpecularPower: Single;
Private | FLightPower: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | procedure SetAmbientColor(AValue: TGLColor);
Private | procedure SetDiffuseColor(AValue: TGLColor);
Private | procedure SetMainTexName(const Value: TGLLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TGLTexture);
Private | procedure SetSpecularColor(AValue: TGLColor);

Properties

Public | property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;
Public | property DiffuseColor : TGLColor read FDiffuseColor Write setDiffuseColor;
Public | property LightPower: Single read FLightPower write FLightPower;
Public | property MainTexture: TGLTexture read FMainTexture write SetMainTexTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularPower: Single read FSpecularPower write FSpecularPower;

Description

Fields

Private FAmbientColor: TGLColor;

This item has no description.

Private FDiffuseColor: TGLColor;

This item has no description.

Private FSpecularColor: TGLColor;

This item has no description.

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FMainTexture: TGLTexture;

This item has no description.

Private FMainTexName: TGLLibMaterialName;

This item has no description.

Private FSpecularPower: Single;

This item has no description.

Private FLightPower: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private procedure SetAmbientColor(AValue: TGLColor);

This item has no description.

Private procedure SetDiffuseColor(AValue: TGLColor);

This item has no description.

Private procedure SetMainTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetSpecularColor(AValue: TGLColor);

This item has no description.

Properties

Public property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property DiffuseColor : TGLColor read FDiffuseColor Write setDiffuseColor;

This item has no description.

Public property LightPower: Single read FLightPower write FLightPower;

This item has no description.

Public property MainTexture: TGLTexture read FMainTexture write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;

This item has no description.

Public property SpecularPower: Single read FSpecularPower write FSpecularPower;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLSimpleLatticeShader

Class TGLSLSimpleLatticeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLSimpleLatticeShader = class(TGLCustomGLSLSimpleLatticeShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLSimpleLatticeShader.

Custom class for a shader that simulate Lattice

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSimpleLatticeShader
  • TGLSLSimpleLatticeShader

Overview

Properties

Published | property LatticeScale;
Published | property LatticeThreshold;

Description

Properties

Published property LatticeScale;

This item has no description.

Published property LatticeThreshold;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLLatticeShader

Class TGLSLLatticeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLLatticeShader = class(TGLCustomGLSLLatticeShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLLatticeShader.

Custom class for GLSLLatticeShader. A shader that simulate Lattice with Diffuse/Specular and support Texture

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSimpleLatticeShader
  • TGLCustomGLSLLatticeShader
  • TGLSLLatticeShader

Overview

Properties

Published | property AmbientColor;
Published | property DiffuseColor;
Published | property LatticeScale;
Published | property LatticeThreshold;
Published | property LightPower;
Published | property MainTexture;
Published | property SpecularColor;
Published | property SpecularPower;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property DiffuseColor;

This item has no description.

Published property LatticeScale;

This item has no description.

Published property LatticeThreshold;

This item has no description.

Published property LightPower;

This item has no description.

Published property MainTexture;

This item has no description.

Published property SpecularColor;

This item has no description.

Published property SpecularPower;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLSemShader

Class TGLCustomGLSLSemShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLSemShader = class(TGLCustomGLSLShader)

Description

Custom class for SEM Shader : Spherical Environment Mapping

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSemShader

Overview

Fields

Private | FAmbientColor: TGLColor;
Private | FSpecularColor: TGLColor;
Private | FAmbientFactor: Single;
Private | FDiffuseFactor: Single;
Private | FSpecularFactor: Single;
Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FMainTexture: TGLTexture;
Private | FMainTexName: TGLLibMaterialName;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | procedure SetAmbientColor(AValue: TGLColor);
Private | procedure SetMainTexName(const Value: TGLLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TGLTexture);
Private | procedure SetSpecularColor(AValue: TGLColor);

Properties

Public | property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;
Public | property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;
Public | property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;
Public | property MainTexture: TGLTexture read FMainTexture write SetMainTexTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;

Description

Fields

Private FAmbientColor: TGLColor;

This item has no description.

Private FSpecularColor: TGLColor;

FDiffuseColor: TGLColor;

Private FAmbientFactor: Single;

This item has no description.

Private FDiffuseFactor: Single;

This item has no description.

Private FSpecularFactor: Single;

This item has no description.

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FMainTexture: TGLTexture;

This item has no description.

Private FMainTexName: TGLLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

FSpecularPower: Single; FLightPower: Single;

Private procedure SetAmbientColor(AValue: TGLColor);

procedure SetDiffuseColor(AValue: TGLColor);

Private procedure SetMainTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetSpecularColor(AValue: TGLColor);

This item has no description.

Properties

Public property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;

This item has no description.

Public property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;

This item has no description.

Public property MainTexture: TGLTexture read FMainTexture write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;

property DiffuseColor : TGLColor read FDiffuseColor Write setDiffuseColor;

Public property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLSemShader

Class TGLSLSemShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLSemShader = class(TGLCustomGLSLSemShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLSemShader.

Custom class for SEM Shader : Spherical Environment Mapping

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLSemShader
  • TGLSLSemShader

Overview

Properties

Published | property AmbientColor;
Published | property AmbientFactor;
Published | property DiffuseFactor;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property SpecularColor;
Published | property SpecularFactor;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property AmbientFactor;

This item has no description.

Published property DiffuseFactor;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property SpecularColor;

property DiffuseColor;

Published property SpecularFactor;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLToonShader

Class TGLCustomGLSLToonShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLToonShader = class(TGLCustomGLSLShader)

Description

Custom class for Toon Shader

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLToonShader

Overview

Fields

Private | FHighlightColor: TGLColor;
Private | FMidColor: TGLColor;
Private | FLightenShadowColor: TGLColor;
Private | FDarkenShadowColor: TGLColor;
Private | FOutlineColor: TGLColor;
Private | FHighlightSize: Single;
Private | FMidSize: Single;
Private | FShadowSize: Single;
Private | FOutlineWidth: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetDarkenShadowColor(AValue: TGLColor);
Private | procedure SetHighLightColor(AValue: TGLColor);
Private | procedure SetLightenShadowColor(AValue: TGLColor);
Private | procedure SetMidColor(AValue: TGLColor);
Private | procedure SetOutlineColor(AValue: TGLColor);

Properties

Public | property DarkenShadowrColor : TGLColor Read FDarkenShadowColor Write setDarkenShadowColor;
Public | property HighlightColor : TGLColor read FHighlightColor Write setHighlightColor;
Public | property HighlightSize : Single read FHighlightSize write FHighlightSize;
Public | property LightenShadowColor : TGLColor Read FLightenShadowColor Write setLightenShadowColor;
Public | property MidColor : TGLColor read FMidColor Write setMidColor;
Public | property MidSize : Single read FMidSize write FMidSize;
Public | property OutlinetColor : TGLColor Read FOutlineColor Write setOutlineColor;
Public | property OutlineWidth : Single read FOutlineWidth write FOutlineWidth;
Public | property ShadowSize : Single read FShadowSize write FShadowSize;

Description

Fields

Private FHighlightColor: TGLColor;

This item has no description.

Private FMidColor: TGLColor;

This item has no description.

Private FLightenShadowColor: TGLColor;

This item has no description.

Private FDarkenShadowColor: TGLColor;

This item has no description.

Private FOutlineColor: TGLColor;

This item has no description.

Private FHighlightSize: Single;

This item has no description.

Private FMidSize: Single;

This item has no description.

Private FShadowSize: Single;

This item has no description.

Private FOutlineWidth: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetDarkenShadowColor(AValue: TGLColor);

This item has no description.

Private procedure SetHighLightColor(AValue: TGLColor);

This item has no description.

Private procedure SetLightenShadowColor(AValue: TGLColor);

This item has no description.

Private procedure SetMidColor(AValue: TGLColor);

This item has no description.

Private procedure SetOutlineColor(AValue: TGLColor);

This item has no description.

Properties

Public property DarkenShadowrColor : TGLColor Read FDarkenShadowColor Write setDarkenShadowColor;

This item has no description.

Public property HighlightColor : TGLColor read FHighlightColor Write setHighlightColor;

This item has no description.

Public property HighlightSize : Single read FHighlightSize write FHighlightSize;

This item has no description.

Public property LightenShadowColor : TGLColor Read FLightenShadowColor Write setLightenShadowColor;

This item has no description.

Public property MidColor : TGLColor read FMidColor Write setMidColor;

This item has no description.

Public property MidSize : Single read FMidSize write FMidSize;

This item has no description.

Public property OutlinetColor : TGLColor Read FOutlineColor Write setOutlineColor;

This item has no description.

Public property OutlineWidth : Single read FOutlineWidth write FOutlineWidth;

This item has no description.

Public property ShadowSize : Single read FShadowSize write FShadowSize;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLToonShader

Class TGLSLToonShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLToonShader = class(TGLCustomGLSLToonShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLToonShader.

Custom class for Toon Shader

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLToonShader
  • TGLSLToonShader

Overview

Properties

Published | property DarkenShadowrColor;
Published | property HighlightColor;
Published | property HighlightSize;
Published | property LightenShadowColor;
Published | property MidColor;
Published | property MidSize;
Published | property OutlinetColor;
Published | property OutlineWidth;
Published | property ShadowSize;

Description

Properties

Published property DarkenShadowrColor;

This item has no description.

Published property HighlightColor;

This item has no description.

Published property HighlightSize;

This item has no description.

Published property LightenShadowColor;

This item has no description.

Published property MidColor;

This item has no description.

Published property MidSize;

This item has no description.

Published property OutlinetColor;

This item has no description.

Published property OutlineWidth;

This item has no description.

Published property ShadowSize;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLCustomGLSLVertexDisplacementShader

Class TGLCustomGLSLVertexDisplacementShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLCustomGLSLVertexDisplacementShader = class(TGLCustomGLSLShader)

Description

VertexDisplacement shader: Basic Vertex Displacement with Perlin Noise You can Improved it: The vertex displacement can be done by reading a 2D or 3D texture. It can be done along the normal or the tangent. It can be scaled, twisted, modulated, inverted... Converted from : https://www.clicktorelease.com/blog/vertex-displacement-noise-3d-webgl-glsl-three-js At this time only one light source is supported

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLVertexDisplacementShader

Overview

Fields

Private | FAmbientColor: TGLColor;
Private | FSpecularColor: TGLColor;
Private | FAmbientFactor: Single;
Private | FDiffuseFactor: Single;
Private | FSpecularFactor: Single;
Private | FMaterialLibrary: TGLAbstractMaterialLibrary;
Private | FMainTexture: TGLTexture;
Private | FMainTexName: TGLLibMaterialName;
Private | FElapsedTime: Single;
Private | FNoise: Single;
Private | FDisplacementScale: Single;
Private | FNoiseScale: Single;
Private | FTurbulenceFactor: Single;
Private | FNoisePeriod: Single;
Private | FTimeFactor: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TGLLibMaterialName;
Private | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Private | procedure SetAmbientColor(AValue: TGLColor);
Private | procedure SetMainTexName(const Value: TGLLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TGLTexture);
Private | procedure SetSpecularColor(AValue: TGLColor);

Properties

Public | property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;
Public | property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;
Public | property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;
Public | property DisplacementScale : Single read FDisplacementScale write FDisplacementScale;
Public | property ElapsedTime: Single read FElapsedTime write FElapsedTime;
Public | property MainTexture: TGLTexture read FMainTexture write SetMainTexTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property NoiseFactor : Single read FNoise write FNoise;
Public | property NoisePeriod : Single read FNoisePeriod write FNoisePeriod;
Public | property NoiseScale : Single read FNoiseScale write FNoiseScale;
Public | property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;
Public | property TimeFactor : Single read FTimeFactor write FTimeFactor;
Public | property TurbulenceFactor : Single read FTurbulenceFactor write FTurbulenceFactor;

Description

Fields

Private FAmbientColor: TGLColor;

This item has no description.

Private FSpecularColor: TGLColor;

FDiffuseColor: TGLColor;

Private FAmbientFactor: Single;

This item has no description.

Private FDiffuseFactor: Single;

This item has no description.

Private FSpecularFactor: Single;

This item has no description.

Private FMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private FMainTexture: TGLTexture;

This item has no description.

Private FMainTexName: TGLLibMaterialName;

This item has no description.

Private FElapsedTime: Single;

This item has no description.

Private FNoise: Single;

This item has no description.

Private FDisplacementScale: Single;

This item has no description.

Private FNoiseScale: Single;

This item has no description.

Private FTurbulenceFactor: Single;

This item has no description.

Private FNoisePeriod: Single;

This item has no description.

Private FTimeFactor: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TGLLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TGLAbstractMaterialLibrary;

This item has no description.

Private procedure SetAmbientColor(AValue: TGLColor);

procedure SetDiffuseColor(AValue: TGLColor);

Private procedure SetMainTexName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TGLTexture);

This item has no description.

Private procedure SetSpecularColor(AValue: TGLColor);

This item has no description.

Properties

Public property AmbientColor : TGLColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;

This item has no description.

Public property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;

This item has no description.

Public property DisplacementScale : Single read FDisplacementScale write FDisplacementScale;

This item has no description.

Public property ElapsedTime: Single read FElapsedTime write FElapsedTime;

This item has no description.

Public property MainTexture: TGLTexture read FMainTexture write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TGLLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TGLAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property NoiseFactor : Single read FNoise write FNoise;

This item has no description.

Public property NoisePeriod : Single read FNoisePeriod write FNoisePeriod;

This item has no description.

Public property NoiseScale : Single read FNoiseScale write FNoiseScale;

This item has no description.

Public property SpecularColor : TGLColor Read FSpecularColor Write setSpecularColor;

property DiffuseColor : TGLColor read FDiffuseColor Write setDiffuseColor;

Public property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;

This item has no description.

Public property TimeFactor : Single read FTimeFactor write FTimeFactor;

This item has no description.

Public property TurbulenceFactor : Single read FTurbulenceFactor write FTurbulenceFactor;


GLSysHelp v.2.5: GLSL.ShapeShaders: Class TGLSLVertexDisplacementShader

Class TGLSLVertexDisplacementShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.ShapeShaders

Declaration

type TGLSLVertexDisplacementShader = class(TGLCustomGLSLVertexDisplacementShader)

Description

This item has no description. Showing description inherited from TGLCustomGLSLVertexDisplacementShader.

VertexDisplacement shader: Basic Vertex Displacement with Perlin Noise You can Improved it: The vertex displacement can be done by reading a 2D or 3D texture. It can be done along the normal or the tangent. It can be scaled, twisted, modulated, inverted... Converted from : https://www.clicktorelease.com/blog/vertex-displacement-noise-3d-webgl-glsl-three-js At this time only one light source is supported

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLVertexDisplacementShader
  • TGLSLVertexDisplacementShader

Overview

Properties

Published | property AmbientColor;
Published | property AmbientFactor;
Published | property DiffuseFactor;
Published | property DisplacementScale;
Published | property ElapsedTime;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NoiseFactor;
Published | property NoisePeriod;
Published | property NoiseScale;
Published | property SpecularColor;
Published | property SpecularFactor;
Published | property TimeFactor;
Published | property TurbulenceFactor;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property AmbientFactor;

This item has no description.

Published property DiffuseFactor;

This item has no description.

Published property DisplacementScale;

This item has no description.

Published property ElapsedTime;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NoiseFactor;

This item has no description.

Published property NoisePeriod;

This item has no description.

Published property NoiseScale;

This item has no description.

Published property SpecularColor;

property DiffuseColor;

Published property SpecularFactor;

This item has no description.

Published property TimeFactor;

This item has no description.

Published property TurbulenceFactor;


GLSysHelp v.2.5: GLSL.TextureShaders

Unit GLSL.TextureShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLS.Scene
  • GLS.Context
  • GLS.Texture
  • GLS.TextureCombiners
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLS.Color
  • GLS.Material
  • GLScene.Strings
  • GLS.VectorFileObjects
  • GLS.XOpenGL
  • GLS.State
  • GLS.PersistentClasses
  • GLS.Coordinates
  • GLS.RenderContextInfo
  • GLS.ImageUtils
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextureSharingShaderMaterial |
Class TGLTextureSharingShaderMaterials |
Class TGLTextureSharingShader |
Class TGLTexCombineShader |


GLSysHelp v.2.5: GLSL.TextureShaders: Class TGLTextureSharingShaderMaterial

Class TGLTextureSharingShaderMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.TextureShaders

Declaration

type TGLTextureSharingShaderMaterial = class(TGLInterfacedCollectionItem, IGLMaterialLibrarySupported)

Description

This item has no description.

Hierarchy

  • TGLInterfacedCollectionItem
  • TGLTextureSharingShaderMaterial

Overview

Fields

Private | FTextureMatrix: TGLMatrix;
Private | FNeedToUpdateTextureMatrix: Boolean;
Private | FTextureMatrixIsUnitary: Boolean;
Private | FLibMaterial: TGLLibMaterial;
Private | FTexOffset: TGLCoordinates2;
Private | FTexScale: TGLCoordinates2;
Private | FBlendingMode: TGLBlendingMode;
Private | FSpecular: TGLColor;
Private | FAmbient: TGLColor;
Private | FDiffuse: TGLColor;
Private | FEmission: TGLColor;
Private | FShininess: TGLShininess;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FLibMaterialName: TGLLibMaterialName;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | function GetTextureMatrix: TGLMatrix;
Private | function GetTextureMatrixIsUnitary: Boolean;
Public | procedure Apply(var rci: TGLRenderContextInfo);
Public | procedure UnApply(var rci: TGLRenderContextInfo);
Private | procedure SetAmbient(const Value: TGLColor);
Private | procedure SetBlendingMode(const Value: TGLBlendingMode);
Private | procedure SetDiffuse(const Value: TGLColor);
Private | procedure SetEmission(const Value: TGLColor);
Private | procedure SetLibMaterial(const Value: TGLLibMaterial);
Private | procedure SetLibMaterialName(const Value: TGLLibMaterialName);
Private | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);
Private | procedure SetShininess(const Value: TGLShininess);
Private | procedure SetSpecular(const Value: TGLColor);
Private | procedure SetTexOffset(const Value: TGLCoordinates2);
Private | procedure SetTexScale(const Value: TGLCoordinates2);

Properties

Published | property Ambient: TGLColor read FAmbient write SetAmbient;
Published | property BlendingMode: TGLBlendingMode read FBlendingMode write SetBlendingMode;
Published | property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Published | property Emission: TGLColor read FEmission write SetEmission;
Public | property LibMaterial: TGLLibMaterial read FLibMaterial write SetLibMaterial;
Published | property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Shininess: TGLShininess read FShininess write SetShininess;
Published | property Specular: TGLColor read FSpecular write SetSpecular;
Published | property TexOffset: TGLCoordinates2 read FTexOffset write SetTexOffset;
Published | property TexScale: TGLCoordinates2 read FTexScale write SetTexScale;
Public | property TextureMatrix: TGLMatrix read GetTextureMatrix;
Public | property TextureMatrixIsUnitary: Boolean read GetTextureMatrixIsUnitary;

Description

Fields

Private FTextureMatrix: TGLMatrix;

This item has no description.

Private FNeedToUpdateTextureMatrix: Boolean;

This item has no description.

Private FTextureMatrixIsUnitary: Boolean;

This item has no description.

Private FLibMaterial: TGLLibMaterial;

This item has no description.

Private FTexOffset: TGLCoordinates2;

This item has no description.

Private FTexScale: TGLCoordinates2;

This item has no description.

Private FBlendingMode: TGLBlendingMode;

This item has no description.

Private FSpecular: TGLColor;

This item has no description.

Private FAmbient: TGLColor;

This item has no description.

Private FDiffuse: TGLColor;

This item has no description.

Private FEmission: TGLColor;

This item has no description.

Private FShininess: TGLShininess;

This item has no description.

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FLibMaterialName: TGLLibMaterialName;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetTextureMatrix: TGLMatrix;

This item has no description.

Private function GetTextureMatrixIsUnitary: Boolean;

This item has no description.

Public procedure Apply(var rci: TGLRenderContextInfo);

This item has no description.

Public procedure UnApply(var rci: TGLRenderContextInfo);

This item has no description.

Private procedure SetAmbient(const Value: TGLColor);

This item has no description.

Private procedure SetBlendingMode(const Value: TGLBlendingMode);

This item has no description.

Private procedure SetDiffuse(const Value: TGLColor);

This item has no description.

Private procedure SetEmission(const Value: TGLColor);

This item has no description.

Private procedure SetLibMaterial(const Value: TGLLibMaterial);

This item has no description.

Private procedure SetLibMaterialName(const Value: TGLLibMaterialName);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);

This item has no description.

Private procedure SetShininess(const Value: TGLShininess);

This item has no description.

Private procedure SetSpecular(const Value: TGLColor);

This item has no description.

Private procedure SetTexOffset(const Value: TGLCoordinates2);

This item has no description.

Private procedure SetTexScale(const Value: TGLCoordinates2);

This item has no description.

Properties

Published property Ambient: TGLColor read FAmbient write SetAmbient;

This item has no description.

Published property BlendingMode: TGLBlendingMode read FBlendingMode write SetBlendingMode;

This item has no description.

Published property Diffuse: TGLColor read FDiffuse write SetDiffuse;

This item has no description.

Published property Emission: TGLColor read FEmission write SetEmission;

This item has no description.

Public property LibMaterial: TGLLibMaterial read FLibMaterial write SetLibMaterial;

This item has no description.

Published property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property Shininess: TGLShininess read FShininess write SetShininess;

This item has no description.

Published property Specular: TGLColor read FSpecular write SetSpecular;

This item has no description.

Published property TexOffset: TGLCoordinates2 read FTexOffset write SetTexOffset;

This item has no description.

Published property TexScale: TGLCoordinates2 read FTexScale write SetTexScale;

This item has no description.

Public property TextureMatrix: TGLMatrix read GetTextureMatrix;

This item has no description.

Public property TextureMatrixIsUnitary: Boolean read GetTextureMatrixIsUnitary;


GLSysHelp v.2.5: GLSL.TextureShaders: Class TGLTextureSharingShaderMaterials

Class TGLTextureSharingShaderMaterials

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.TextureShaders

Declaration

type TGLTextureSharingShaderMaterials = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TGLTextureSharingShaderMaterials

Overview

Methods

Public | constructor Create(AOwner: TGLTextureSharingShader);
Public | function Add: TGLTextureSharingShaderMaterial;

Properties

Public property Items[const AIndex: Integer]: TGLTextureSharingShaderMaterial read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TGLTextureSharingShader);

This item has no description.

Public function Add: TGLTextureSharingShaderMaterial;

This item has no description.

Properties

Public property Items[const AIndex: Integer]: TGLTextureSharingShaderMaterial read GetItems write SetItems;


GLSysHelp v.2.5: GLSL.TextureShaders: Class TGLTextureSharingShader

Class TGLTextureSharingShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.TextureShaders

Declaration

type TGLTextureSharingShader = class(TGLShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLTextureSharingShader

Overview

Fields

Private | FMaterials: TGLTextureSharingShaderMaterials;
Private | FCurrentPass: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddLibMaterial(const ALibMaterial: TGLLibMaterial): TGLTextureSharingShaderMaterial;
Public | function FindLibMaterial(const ALibMaterial: TGLLibMaterial): TGLTextureSharingShaderMaterial;
Private | procedure SetMaterials(const Value: TGLTextureSharingShaderMaterials);

Properties

Published property Materials: TGLTextureSharingShaderMaterials read FMaterials write SetMaterials;

Description

Fields

Private FMaterials: TGLTextureSharingShaderMaterials;

This item has no description.

Private FCurrentPass: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddLibMaterial(const ALibMaterial: TGLLibMaterial): TGLTextureSharingShaderMaterial;

This item has no description.

Public function FindLibMaterial(const ALibMaterial: TGLLibMaterial): TGLTextureSharingShaderMaterial;

This item has no description.

Private procedure SetMaterials(const Value: TGLTextureSharingShaderMaterials);

This item has no description.

Properties

Published property Materials: TGLTextureSharingShaderMaterials read FMaterials write SetMaterials;


GLSysHelp v.2.5: GLSL.TextureShaders: Class TGLTexCombineShader

Class TGLTexCombineShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.TextureShaders

Declaration

type TGLTexCombineShader = class(TGLShader)

Description

A shader that can setup the texture combiner.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLTexCombineShader

Overview

Fields

Private | FCombiners: TStringList;
Private | FCommandCache: TCombinerCache;
Private | FCombinerIsValid: Boolean;
Private | FDesignTimeEnabled: Boolean;
Private | FMaterialLibrary: TGLMaterialLibrary;
Private | FLibMaterial3Name: TGLLibMaterialName;
Private | currentLibMaterial3: TGLLibMaterial;
Private | FLibMaterial4Name: TGLLibMaterialName;
Private | currentLibMaterial4: TGLLibMaterial;
Private | FApplied3: Boolean;
Private | FApplied4: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Combiners: TStringList read FCombiners write SetCombiners;
Published | property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;
Published | property LibMaterial3Name: TGLLibMaterialName read FLibMaterial3Name write SetLibMaterial3Name;
Published | property LibMaterial4Name: TGLLibMaterialName read FLibMaterial4Name write SetLibMaterial4Name;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Fields

Private FCombiners: TStringList;

This item has no description.

Private FCommandCache: TCombinerCache;

This item has no description.

Private FCombinerIsValid: Boolean;

This item has no description.

Private FDesignTimeEnabled: Boolean;

to avoid reparsing invalid stuff

Private FMaterialLibrary: TGLMaterialLibrary;

This item has no description.

Private FLibMaterial3Name: TGLLibMaterialName;

This item has no description.

Private currentLibMaterial3: TGLLibMaterial;

This item has no description.

Private FLibMaterial4Name: TGLLibMaterialName;

This item has no description.

Private currentLibMaterial4: TGLLibMaterial;

This item has no description.

Private FApplied3: Boolean;

This item has no description.

Private FApplied4: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description. Showing description inherited from TGLShader.NotifyChange.

Subclasses should invoke this function when shader properties are altered. This procedure can also be used to reset/recompile the shader.

Properties

Published property Combiners: TStringList read FCombiners write SetCombiners;

This item has no description.

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;

This item has no description.

Published property LibMaterial3Name: TGLLibMaterialName read FLibMaterial3Name write SetLibMaterial3Name;

This item has no description.

Published property LibMaterial4Name: TGLLibMaterialName read FLibMaterial4Name write SetLibMaterial4Name;

This item has no description.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;


GLSysHelp v.2.5: GLSL.UserShader

Unit GLSL.UserShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLS.Material
  • GLS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLUserShader |

Types

TOnDoApplyEvent = procedure (Sender : TObject; var rci : TGLRenderContextInfo) of Object;
TOnDoUnApplyEvent = procedure (Sender : TObject; Pass:Integer; var rci : TGLRenderContextInfo; var Continue : Boolean) of Object;

Description

Types

TOnDoApplyEvent = procedure (Sender : TObject; var rci : TGLRenderContextInfo) of Object;

This item has no description.

TOnDoUnApplyEvent = procedure (Sender : TObject; Pass:Integer; var rci : TGLRenderContextInfo; var Continue : Boolean) of Object;


GLSysHelp v.2.5: GLSL.UserShader: Class TGLUserShader

Class TGLUserShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GLSL.UserShader

Declaration

type TGLUserShader = class(TGLShader)

Description

This item has no description. Showing description inherited from TGLShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TGLUpdateAbleComponent
  • TGLShader
  • TGLUserShader

Overview

Fields

Private | FPass: Integer;
Private | FOnDoApply: TOnDoApplyEvent;
Private | FOnDoUnApply: TOnDoUnApplyEvent;

Properties

Published | property OnDoApply : TOnDoApplyEvent read FOnDoApply write FOnDoApply;
Published | property OnDoUnApply : TOnDoUnApplyEvent read FOnDoUnApply write FOnDoUnApply;
Published | property ShaderStyle;

Description

Fields

Private FPass: Integer;

This item has no description.

Private FOnDoApply: TOnDoApplyEvent;

This item has no description.

Private FOnDoUnApply: TOnDoUnApplyEvent;

This item has no description.

Properties

Published property OnDoApply : TOnDoApplyEvent read FOnDoApply write FOnDoApply;

This item has no description.

Published property OnDoUnApply : TOnDoUnApplyEvent read FOnDoUnApply write FOnDoUnApply;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TGLShader.ShaderStyle.

Shader application style (default is ssLowLevel).


GLSysHelp v.2.5: gnugettext

Unit gnugettext

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

*—————————————————————————— GNU gettext translation system for Delphi, Kylix, C++ Builder and others. All parts of the translation system are kept in this unit.

——————————————————————————-

Uses

  • Winapi.Windows
  • System.Classes
  • System.StrUtils
  • System.SysUtils
  • System.TypInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGnuGettext |
Class EGGProgrammingError |
Class EGGComponentError |
Class EGGIOError |
Class EGGAnsi2WideConvError |
Class TMoFile |
Class TDomain |
Class TExecutable |
Interface IGnuGettextInstanceWhenNewLanguageListener |
Class TGnuGettextInstance |

Functions and Procedures

function _(const szMsgId: MsgIdString): TranslatedUnicodeString;
function gettext(const szMsgId: MsgIdString): TranslatedUnicodeString;
function gettext_NoExtract(const szMsgId: MsgIdString): TranslatedUnicodeString;
function gettext_NoOp(const szMsgId: MsgIdString): TranslatedUnicodeString;
function dgettext(const szDomain: DomainString; const szMsgId: MsgIdString) : TranslatedUnicodeString;
function dgettext_NoExtract(const szDomain: DomainString; const szMsgId: MsgIdString): TranslatedUnicodeString;
function dngettext(const szDomain: DomainString; const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString;
function ngettext(const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString;
function ngettext_NoExtract(const singular, plural: MsgIdString; Number: longint): TranslatedUnicodeString;
procedure textdomain(const szDomain: DomainString);
function getcurrenttextdomain: DomainString;
procedure bindtextdomain(const szDomain: DomainString; const szDirectory: FilenameString);
procedure UseLanguage(LanguageCode: LanguageString);
function GetCurrentLanguage: LanguageString;
procedure TP_Ignore(AnObject: TObject; const name: ComponentNameString);
procedure TP_IgnoreClass(IgnClass: TClass);
procedure TP_IgnoreClassProperty(IgnClass: TClass; const propertyname: ComponentNameString);
procedure TP_GlobalIgnoreClass(IgnClass: TClass);
procedure TP_GlobalIgnoreClassProperty(IgnClass: TClass; const propertyname: ComponentNameString);
procedure TP_GlobalHandleClass(HClass: TClass; Handler: TTranslator);
procedure TranslateComponent(AnObject: TComponent; const textdomain: DomainString = '');
procedure RetranslateComponent(AnObject: TComponent; const textdomain: DomainString = '');
procedure AddDomainForResourceString(const domain: DomainString);
procedure RemoveDomainForResourceString(const domain: DomainString);
procedure AddDomains(const Domains: array of DomainString);
procedure AddDomainForComponent(const domain: DomainString);
procedure RemoveDomainForComponent(const domain: DomainString);
function LoadResString(ResStringRec: PResStringRec): WideString;
function LoadResStringW(ResStringRec: PResStringRec): UnicodeString;
function GetTranslatorNameAndEmail: TranslatedUnicodeString;
procedure HookIntoResourceStrings(enabled: boolean = True; SupportPackages: boolean = false);

Types

ComponentNameString = string;
DomainString = string;
FilenameString = string;
LanguageString = string;
MsgIdString = UnicodeString;
RawByteString = AnsiString;
RawUtf8String = AnsiString;
TDebugLogger = procedure(Line: AnsiString) of object;
TGetPluralForm = function(Number: longint): Integer;
TOnDebugLine = Procedure(Sender: TObject; const Line: String; var Discard: boolean) of Object;
TranslatedUnicodeString = UnicodeString;
TTranslator = procedure(obj: TObject) of object;
UnicodeString = WideString;

Constants

DefaultTextDomain = 'default';
PreferExternal = True;
UseMemoryMappedFiles = True;
ReReadMoFileOnSameLanguage = True;
VCSVersion = '$LastChangedRevision: 220 $';
AutoCreateHooks = True;

Variables

ExecutableFilename: FilenameString;
DefaultInstance: TGnuGettextInstance;

Description

Functions and Procedures

function _(const szMsgId: MsgIdString): TranslatedUnicodeString;

Main GNU gettext functions. See documentation for instructions on how to use them.

function gettext(const szMsgId: MsgIdString): TranslatedUnicodeString;

This item has no description.

function gettext_NoExtract(const szMsgId: MsgIdString): TranslatedUnicodeString;

This item has no description.

function gettext_NoOp(const szMsgId: MsgIdString): TranslatedUnicodeString;

This item has no description.

function dgettext(const szDomain: DomainString; const szMsgId: MsgIdString) : TranslatedUnicodeString;

This item has no description.

function dgettext_NoExtract(const szDomain: DomainString; const szMsgId: MsgIdString): TranslatedUnicodeString;

This item has no description.

function dngettext(const szDomain: DomainString; const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString;

This item has no description.

function ngettext(const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString;

This item has no description.

function ngettext_NoExtract(const singular, plural: MsgIdString; Number: longint): TranslatedUnicodeString;

This item has no description.

procedure textdomain(const szDomain: DomainString);

This item has no description.

function getcurrenttextdomain: DomainString;

This item has no description.

procedure bindtextdomain(const szDomain: DomainString; const szDirectory: FilenameString);

This item has no description.

procedure UseLanguage(LanguageCode: LanguageString);

Set language to use

function GetCurrentLanguage: LanguageString;

This item has no description.

procedure TP_Ignore(AnObject: TObject; const name: ComponentNameString);

This item has no description.

procedure TP_IgnoreClass(IgnClass: TClass);

This item has no description.

procedure TP_IgnoreClassProperty(IgnClass: TClass; const propertyname: ComponentNameString);

This item has no description.

procedure TP_GlobalIgnoreClass(IgnClass: TClass);

This item has no description.

procedure TP_GlobalIgnoreClassProperty(IgnClass: TClass; const propertyname: ComponentNameString);

This item has no description.

procedure TP_GlobalHandleClass(HClass: TClass; Handler: TTranslator);

This item has no description.

procedure TranslateComponent(AnObject: TComponent; const textdomain: DomainString = '');

This item has no description.

procedure RetranslateComponent(AnObject: TComponent; const textdomain: DomainString = '');

This item has no description.

procedure AddDomainForResourceString(const domain: DomainString);

Add more domains that resourcestrings can be extracted from. If a translation is not found in the default domain, this domain will be searched, too. This is useful for adding mo files for certain runtime libraries and 3rd party component libraries

procedure RemoveDomainForResourceString(const domain: DomainString);

This item has no description.

procedure AddDomains(const Domains: array of DomainString);

This item has no description.

procedure AddDomainForComponent(const domain: DomainString);

Add more domains that component strings can be extracted from. If a translation is not found in the default domain, this domain will be searched, too. This is useful when an application inherits components from a 3rd party component libraries

procedure RemoveDomainForComponent(const domain: DomainString);

This item has no description.

function LoadResString(ResStringRec: PResStringRec): WideString;

Unicode-enabled way to get resourcestrings, automatically translated Use like this: ws:=LoadResStringW(@NameOfResourceString);

function LoadResStringW(ResStringRec: PResStringRec): UnicodeString;

This item has no description.

function GetTranslatorNameAndEmail: TranslatedUnicodeString;

This returns an empty string if not translated or translator name is not specified.

procedure HookIntoResourceStrings(enabled: boolean = True; SupportPackages: boolean = false);

This item has no description.

Types

ComponentNameString = string;

This item has no description.

DomainString = string;

This item has no description.

FilenameString = string;

This item has no description.

LanguageString = string;

This item has no description.

MsgIdString = UnicodeString;

This item has no description.

RawByteString = AnsiString;

This item has no description.

RawUtf8String = AnsiString;

This item has no description.

TDebugLogger = procedure(Line: AnsiString) of object;

This item has no description.

TGetPluralForm = function(Number: longint): Integer;

Set Discard to false if output should still go to ordinary debug log

TOnDebugLine = Procedure(Sender: TObject; const Line: String; var Discard: boolean) of Object;

***************************************************************************

TranslatedUnicodeString = UnicodeString;

This item has no description.

TTranslator = procedure(obj: TObject) of object;

Translates a component (form, frame etc.) to the currently selected language. Put TranslateComponent(self) in the OnCreate event of all your forms. See the manual for documentation on these functions

UnicodeString = WideString;

***************************************************************************

Constants

DefaultTextDomain = 'default';

***************************************************************************

PreferExternal = True;

This is set to paramstr(0) or the name of the DLL you are creating.

UseMemoryMappedFiles = True;

Set to true, to prefer external *.mo over embedded translation

ReReadMoFileOnSameLanguage = True;

Set to False, to use the mo-file as independent copy in memory (you can update the file while it is in use)

VCSVersion = '$LastChangedRevision: 220 $';

Set to True, to reread mo-file if the current language is selected again Subversion source code version control version information

AutoCreateHooks = True;

This function will turn resourcestring hooks on or off, eventually with BPL file support. Please do not activate BPL file support when the package is in design mode.

Variables

ExecutableFilename: FilenameString;

This item has no description.

DefaultInstance: TGnuGettextInstance;

This item has no description.

Author

  • Lars B. Dybdahl and others


GLSysHelp v.2.5: gnugettext: Class EGnuGettext

Class EGnuGettext

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type EGnuGettext = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGnuGettext


GLSysHelp v.2.5: gnugettext: Class EGGProgrammingError

Class EGGProgrammingError

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type EGGProgrammingError = class(EGnuGettext)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGnuGettext
  • EGGProgrammingError


GLSysHelp v.2.5: gnugettext: Class EGGComponentError

Class EGGComponentError

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type EGGComponentError = class(EGnuGettext)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGnuGettext
  • EGGComponentError


GLSysHelp v.2.5: gnugettext: Class EGGIOError

Class EGGIOError

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type EGGIOError = class(EGnuGettext)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGnuGettext
  • EGGIOError


GLSysHelp v.2.5: gnugettext: Class EGGAnsi2WideConvError

Class EGGAnsi2WideConvError

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type EGGAnsi2WideConvError = class(EGnuGettext)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGnuGettext
  • EGGAnsi2WideConvError


GLSysHelp v.2.5: gnugettext: Class TMoFile

Class TMoFile

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type TMoFile = class(TObject)

Description

*—————————————————————————— Handles .mo files, in separate files or inside the exe file. Don't use this class. It's for internal use. ——————————————————————————-

Hierarchy

  • TObject
  • TMoFile

Overview

Fields

Private | doswap: boolean;
Public | Users: Integer;
Private | N: Cardinal;
Private | O: Cardinal;
Private | T: Cardinal;
Private | startindex: Integer;
Private | startstep: Integer;
Private | FUseMemoryMappedFiles: boolean;
Private | mo: THandle;
Private | momapping: THandle;
Private | momemoryHandle: PAnsiChar;
Private | momemory: PAnsiChar;

Methods

Public | constructor Create(const filename: FilenameString; const Offset: int64; Size: int64; const xUseMemoryMappedFiles: boolean);
Public | destructor Destroy; override;
Public | function gettext(const msgid: RawUtf8String; var found: boolean) : RawUtf8String;
Private | function autoswap32(i: Cardinal): Cardinal;
Private | function CardinalInMem(baseptr: PAnsiChar; Offset: Cardinal): Cardinal;

Properties

Public property isSwappedArchitecture: boolean read doswap;

Description

Fields

Private doswap: boolean;

Threadsafe. Only constructor and destructor are writing to memory

Public Users: Integer;

This item has no description.

Private N: Cardinal;

This item has no description.

Private O: Cardinal;

This item has no description.

Private T: Cardinal;

This item has no description.

Private startindex: Integer;

Values defined at http://www.linuxselfhelp.com/gnu/gettext/html_chapter/gettext_6.html

Private startstep: Integer;

Values defined at http://www.linuxselfhelp.com/gnu/gettext/html_chapter/gettext_6.html

Private FUseMemoryMappedFiles: boolean;

This item has no description.

Private mo: THandle;

This item has no description.

Private momapping: THandle;

This item has no description.

Private momemoryHandle: PAnsiChar;

This item has no description.

Private momemory: PAnsiChar;

This item has no description.

Methods

Public constructor Create(const filename: FilenameString; const Offset: int64; Size: int64; const xUseMemoryMappedFiles: boolean);

Reference count. If it reaches zero, this object should be destroyed.

Public destructor Destroy; override;

This item has no description.

Public function gettext(const msgid: RawUtf8String; var found: boolean) : RawUtf8String;

This item has no description.

Private function autoswap32(i: Cardinal): Cardinal;

This item has no description.

Private function CardinalInMem(baseptr: PAnsiChar; Offset: Cardinal): Cardinal;

This item has no description.

Properties

Public property isSwappedArchitecture: boolean read doswap;

uses mo file and utf-8


GLSysHelp v.2.5: gnugettext: Class TDomain

Class TDomain

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type TDomain = class(TObject)

Description

*—————————————————————————— Handles all issues regarding a specific domain. Don't use this class. It's for internal use. ——————————————————————————-

Hierarchy

  • TObject
  • TDomain

Overview

Fields

Private | enabled: boolean;
Private | vDirectory: FilenameString;
Public | DebugLogger: TDebugLogger;
Public | domain: DomainString;
Private | mofile: TMoFile;
Private | SpecificFilename: FilenameString;
Private | curlang: LanguageString;
Private | OpenHasFailedBefore: boolean;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function gettext(const msgid: RawUtf8String): RawUtf8String;
Public | function GetTranslationProperty(propertyname: ComponentNameString) : TranslatedUnicodeString;
Public | procedure GetListOfLanguages(list: TStrings);
Public | procedure SetFilename(const filename: FilenameString);
Public | procedure SetLanguageCode(const langcode: LanguageString);
Private | procedure CloseMoFile;
Private | procedure OpenMoFile;
Private | procedure setDirectory(const dir: FilenameString);

Properties

Public property Directory: FilenameString read vDirectory write setDirectory;

Description

Fields

Private enabled: boolean;

This item has no description.

Private vDirectory: FilenameString;

This item has no description.

Public DebugLogger: TDebugLogger;

This item has no description.

Public domain: DomainString;

This item has no description.

Private mofile: TMoFile;

uses mo file and utf-8

Private SpecificFilename: FilenameString;

This item has no description.

Private curlang: LanguageString;

This item has no description.

Private OpenHasFailedBefore: boolean;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function gettext(const msgid: RawUtf8String): RawUtf8String;

This item has no description.

Public function GetTranslationProperty(propertyname: ComponentNameString) : TranslatedUnicodeString;

This item has no description.

Public procedure GetListOfLanguages(list: TStrings);

Bind this domain to a specific file Get information

Public procedure SetFilename(const filename: FilenameString);

This item has no description.

Public procedure SetLanguageCode(const langcode: LanguageString);

Set parameters

Private procedure CloseMoFile;

This item has no description.

Private procedure OpenMoFile;

This item has no description.

Private procedure setDirectory(const dir: FilenameString);

This item has no description.

Properties

Public property Directory: FilenameString read vDirectory write setDirectory;


GLSysHelp v.2.5: gnugettext: Class TExecutable

Class TExecutable

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type TExecutable = class(TObject)

Description

*—————————————————————————— Helper class for invoking events. ——————————————————————————-

Hierarchy

  • TObject
  • TExecutable

Overview

Methods

Public procedure Execute; virtual; abstract;

Description

Methods

Public procedure Execute; virtual; abstract;


GLSysHelp v.2.5: gnugettext: Interface IGnuGettextInstanceWhenNewLanguageListener

Interface IGnuGettextInstanceWhenNewLanguageListener

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type IGnuGettextInstanceWhenNewLanguageListener = interface(IInterface)

Description

*—————————————————————————— Interface to implement if you want to register as a language change listener ——————————————————————————-

Hierarchy

  • IInterface
  • IGnuGettextInstanceWhenNewLanguageListener

Overview

Methods

Public procedure WhenNewLanguage(const LanguageID: LanguageString);

Description

Methods

Public procedure WhenNewLanguage(const LanguageID: LanguageString);


GLSysHelp v.2.5: gnugettext: Class TGnuGettextInstance

Class TGnuGettextInstance

Description
Hierarchy
Fields
Methods
Properties

Unit

gnugettext

Declaration

type TGnuGettextInstance = class(TObject)

Description

*—————————————————————————— The main translation engine. ——————————————————————————-

Hierarchy

  • TObject
  • TGnuGettextInstance

Overview

Fields

Private | fOnDebugLine: TOnDebugLine;
Public | enabled: boolean;
Public | DesignTimeCodePage: Integer;
Private | curlang: LanguageString;
Private | curGetPluralForm: TGetPluralForm;
Private | curmsgdomain: DomainString;
Private | savefileCS: TMultiReadExclusiveWriteSynchronizer;
Private | savefile: TextFile;
Private | savememory: TStringList;
Private | DefaultDomainDirectory: FilenameString;
Private | domainlist: TStringList;
Private | TP_IgnoreList: TStringList;
Private | TP_ClassHandling: TList;
Private | TP_GlobalClassHandling: TList;
Private | TP_Retranslator: TExecutable;
Private | fWhenNewLanguageListeners: TInterfaceList;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function ansi2wideDTCP(const s: AnsiString): MsgIdString;
Public | function dgettext(const szDomain: DomainString; const szMsgId: AnsiString) : TranslatedUnicodeString; overload; virtual;
Public | function dgettext(const szDomain: DomainString; const szMsgId: MsgIdString) : TranslatedUnicodeString; overload; virtual;
Public | function dgettext_NoExtract(const szDomain: DomainString; const szMsgId: MsgIdString): TranslatedUnicodeString;
Public | function dngettext(const szDomain: DomainString; const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString; overload; virtual;
Public | function dngettext(const szDomain: DomainString; const singular, plural: AnsiString; Number: longint) : TranslatedUnicodeString; overload; virtual;
Public | function dngettext_NoExtract(const szDomain: DomainString; const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString;
Public | function GetCurrentLanguage: LanguageString;
Public | function getcurrenttextdomain: DomainString;
Public | function gettext(const szMsgId: AnsiString): TranslatedUnicodeString; overload; virtual;
Public | function gettext(const szMsgId: MsgIdString): TranslatedUnicodeString; overload; virtual;
Public | function gettext_NoExtract(const szMsgId: MsgIdString) : TranslatedUnicodeString;
Public | function gettext_NoOp(const szMsgId: MsgIdString): TranslatedUnicodeString;
Public | function GetTranslationProperty(const propertyname: ComponentNameString) : TranslatedUnicodeString;
Public | function GetTranslatorNameAndEmail: TranslatedUnicodeString;
Public | function LoadResString(ResStringRec: PResStringRec): UnicodeString;
Public | function ngettext(const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString; overload; virtual;
Public | function ngettext(const singular, plural: AnsiString; Number: longint) : TranslatedUnicodeString; overload; virtual;
Public | function ngettext_NoExtract(const singular, plural: MsgIdString; Number: longint): TranslatedUnicodeString;
Private | function Getdomain(const domain: DomainString; const DefaultDomainDirectory: FilenameString; const curlang: LanguageString): TDomain;
Private | function TP_CreateRetranslator: TExecutable;
Public | procedure bindtextdomain(const szDomain: DomainString; const szDirectory: FilenameString);
Public | procedure bindtextdomainToFile(const szDomain: DomainString; const filename: FilenameString);
Public | procedure DebugLogPause(PauseEnabled: boolean);
Public | procedure DebugLogToFile(const filename: FilenameString; append: boolean = false);
Public | procedure GetListOfLanguages(const domain: DomainString; list: TStrings);
Public | procedure RegisterWhenNewLanguageListener(Listener: IGnuGettextInstanceWhenNewLanguageListener);
Public | procedure RetranslateComponent(AnObject: TComponent; const textdomain: DomainString = '');
Public | procedure textdomain(const szDomain: DomainString);
Public | procedure TP_GlobalHandleClass(HClass: TClass; Handler: TTranslator);
Public | procedure TP_GlobalIgnoreClass(IgnClass: TClass);
Public | procedure TP_GlobalIgnoreClassProperty(IgnClass: TClass; propertyname: ComponentNameString);
Public | procedure TP_Ignore(AnObject: TObject; const name: ComponentNameString);
Public | procedure TP_IgnoreClass(IgnClass: TClass);
Public | procedure TP_IgnoreClassProperty(IgnClass: TClass; propertyname: ComponentNameString);
Public | procedure TranslateComponent(AnObject: TComponent; const textdomain: DomainString = '');
Public | procedure TranslateProperties(AnObject: TObject; textdomain: DomainString = '');
Public | procedure UnregisterWhenNewLanguageListener(Listener: IGnuGettextInstanceWhenNewLanguageListener);
Public | procedure UseLanguage(LanguageCode: LanguageString);
Private | procedure FreeTP_ClassHandlingItems;
Private | procedure TranslateProperty(AnObject: TObject; PropInfo: PPropInfo; TodoList: TStrings; const textdomain: DomainString);

Properties

Public property OnDebugLine: TOnDebugLine read fOnDebugLine write fOnDebugLine;

Description

Fields

Private fOnDebugLine: TOnDebugLine;

This item has no description.

Public enabled: boolean;

This item has no description.

Public DesignTimeCodePage: Integer;

Set this to false to disable translations

Private curlang: LanguageString;

Override to know when any text domain's directory changes. It won't be called if a domain is fixed to a specific file.

Private curGetPluralForm: TGetPluralForm;

This item has no description.

Private curmsgdomain: DomainString;

This item has no description.

Private savefileCS: TMultiReadExclusiveWriteSynchronizer;

This item has no description.

Private savefile: TextFile;

This item has no description.

Private savememory: TStringList;

This item has no description.

Private DefaultDomainDirectory: FilenameString;

This item has no description.

Private domainlist: TStringList;

This item has no description.

Private TP_IgnoreList: TStringList;

List of domain names. Objects are TDomain.

Private TP_ClassHandling: TList;

Temporary list, reset each time TranslateProperties is called

Private TP_GlobalClassHandling: TList;

Items are TClassMode. If a is derived from b, a comes first

Private TP_Retranslator: TExecutable;

Items are TClassMode. If a is derived from b, a comes first

Private fWhenNewLanguageListeners: TInterfaceList;

Cast this to TTP_Retranslator

Methods

Public constructor Create;

See MultiByteToWideChar() in Win32 API for documentation

Public destructor Destroy; override;

This item has no description.

Public function ansi2wideDTCP(const s: AnsiString): MsgIdString;

If set, all debug output goes here Conversion according to design-time character set

Public function dgettext(const szDomain: DomainString; const szMsgId: AnsiString) : TranslatedUnicodeString; overload; virtual;

Multi-domain functions

Public function dgettext(const szDomain: DomainString; const szMsgId: MsgIdString) : TranslatedUnicodeString; overload; virtual;

This item has no description.

Public function dgettext_NoExtract(const szDomain: DomainString; const szMsgId: MsgIdString): TranslatedUnicodeString;

This item has no description.

Public function dngettext(const szDomain: DomainString; const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString; overload; virtual;

This item has no description.

Public function dngettext(const szDomain: DomainString; const singular, plural: AnsiString; Number: longint) : TranslatedUnicodeString; overload; virtual;

This item has no description.

Public function dngettext_NoExtract(const szDomain: DomainString; const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString;

This item has no description.

Public function GetCurrentLanguage: LanguageString;

This item has no description.

Public function getcurrenttextdomain: DomainString;

This item has no description.

Public function gettext(const szMsgId: AnsiString): TranslatedUnicodeString; overload; virtual;

Puts list of language codes, for which there are translations in the specified domain, into list

Public function gettext(const szMsgId: MsgIdString): TranslatedUnicodeString; overload; virtual;

This item has no description.

Public function gettext_NoExtract(const szMsgId: MsgIdString) : TranslatedUnicodeString;

This item has no description.

Public function gettext_NoOp(const szMsgId: MsgIdString): TranslatedUnicodeString;

This item has no description.

Public function GetTranslationProperty(const propertyname: ComponentNameString) : TranslatedUnicodeString;

This item has no description.

Public function GetTranslatorNameAndEmail: TranslatedUnicodeString;

This item has no description.

Public function LoadResString(ResStringRec: PResStringRec): UnicodeString;

Also works with files embedded in exe file Windows API functions

Public function ngettext(const singular, plural: MsgIdString; Number: longint) : TranslatedUnicodeString; overload; virtual;

This item has no description.

Public function ngettext(const singular, plural: AnsiString; Number: longint) : TranslatedUnicodeString; overload; virtual;

This item has no description.

Public function ngettext_NoExtract(const singular, plural: MsgIdString; Number: longint): TranslatedUnicodeString;

This item has no description.

Private function Getdomain(const domain: DomainString; const DefaultDomainDirectory: FilenameString; const curlang: LanguageString): TDomain;

This item has no description.

Private function TP_CreateRetranslator: TExecutable;

List of all registered WhenNewLanguage listeners

Public procedure bindtextdomain(const szDomain: DomainString; const szDirectory: FilenameString);

This item has no description.

Public procedure bindtextdomainToFile(const szDomain: DomainString; const filename: FilenameString);

This item has no description.

Public procedure DebugLogPause(PauseEnabled: boolean);

This item has no description.

Public procedure DebugLogToFile(const filename: FilenameString; append: boolean = false);

Output all log info to this file. This may only be called once.

Public procedure GetListOfLanguages(const domain: DomainString; list: TStrings);

This item has no description.

Public procedure RegisterWhenNewLanguageListener(Listener: IGnuGettextInstanceWhenNewLanguageListener);

Convert using Design Time Code Page

Public procedure RetranslateComponent(AnObject: TComponent; const textdomain: DomainString = '');

This item has no description.

Public procedure textdomain(const szDomain: DomainString);

This item has no description.

Public procedure TP_GlobalHandleClass(HClass: TClass; Handler: TTranslator);

This item has no description.

Public procedure TP_GlobalIgnoreClass(IgnClass: TClass);

This item has no description.

Public procedure TP_GlobalIgnoreClassProperty(IgnClass: TClass; propertyname: ComponentNameString);

This item has no description.

Public procedure TP_Ignore(AnObject: TObject; const name: ComponentNameString);

Form translation tools, these are not threadsafe. All TP_ procs must be called just before TranslateProperites()

Public procedure TP_IgnoreClass(IgnClass: TClass);

This item has no description.

Public procedure TP_IgnoreClassProperty(IgnClass: TClass; propertyname: ComponentNameString);

This item has no description.

Public procedure TranslateComponent(AnObject: TComponent; const textdomain: DomainString = '');

This item has no description.

Public procedure TranslateProperties(AnObject: TObject; textdomain: DomainString = '');

This item has no description.

Public procedure UnregisterWhenNewLanguageListener(Listener: IGnuGettextInstanceWhenNewLanguageListener);

This item has no description.

Public procedure UseLanguage(LanguageCode: LanguageString);

This item has no description.

Private procedure FreeTP_ClassHandlingItems;

Must be freed by caller!

Private procedure TranslateProperty(AnObject: TObject; PropInfo: PPropInfo; TodoList: TStrings; const textdomain: DomainString);

This item has no description.

Properties

Public property OnDebugLine: TOnDebugLine read fOnDebugLine write fOnDebugLine;


GLSysHelp v.2.5: GnuGetTextInit

Unit GnuGetTextInit

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Delphi-Unit - Initialization for GnuGetText =============================

© Dr. J. Rathlev, D-24222 Schwentinental (kontakt(a)rathlev-home.de)

The contents of this file may be used under the terms of the Mozilla Public License ("MPL") or GNU Lesser General Public License Version 2 or later (the "LGPL")

Software distributed under this License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License.

Vers. 1 - July 2023 last mdified: July 2023

Overview

Functions and Procedures

procedure InitTranslation(const Domains : array of string);

Description

Functions and Procedures

procedure InitTranslation(const Domains : array of string);

InitTranslation has to be placed in the project file before "Application.Initialize" "Domains" is a list of all po/mo files needed by the application Calling sample: InitTranslation(['delphi10','indy10']);


GLSysHelp v.2.5: ModuleLoader

Unit ModuleLoader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows

Overview

Functions and Procedures

function LoadModule(var Module: TModuleHandle; FileName: PChar): Boolean; stdcall;
function LoadModuleEx(var Module: TModuleHandle; FileName: PChar; Flags: Cardinal): Boolean; stdcall;
procedure UnloadModule(var Module: TModuleHandle); stdcall;
function GetModuleSymbol(Module: TModuleHandle; SymbolName: PChar): Pointer; stdcall;
function GetModuleSymbolEx(Module: TModuleHandle; SymbolName: PChar; var Accu: Boolean): Pointer; stdcall;
function ReadModuleData(Module: TModuleHandle; SymbolName: PChar; var Buffer; Size: Cardinal): Boolean; stdcall;
function WriteModuleData(Module: TModuleHandle; SymbolName: PChar; var Buffer; Size: Cardinal): Boolean; stdcall;

Types

TModuleHandle = HINST;

Constants

INVALID_MODULEHANDLE_VALUE = TModuleHandle(0);

Description

Functions and Procedures

function LoadModule(var Module: TModuleHandle; FileName: PChar): Boolean; stdcall;

This item has no description.

function LoadModuleEx(var Module: TModuleHandle; FileName: PChar; Flags: Cardinal): Boolean; stdcall;

This item has no description.

procedure UnloadModule(var Module: TModuleHandle); stdcall;

This item has no description.

function GetModuleSymbol(Module: TModuleHandle; SymbolName: PChar): Pointer; stdcall;

This item has no description.

function GetModuleSymbolEx(Module: TModuleHandle; SymbolName: PChar; var Accu: Boolean): Pointer; stdcall;

This item has no description.

function ReadModuleData(Module: TModuleHandle; SymbolName: PChar; var Buffer; Size: Cardinal): Boolean; stdcall;

This item has no description.

function WriteModuleData(Module: TModuleHandle; SymbolName: PChar; var Buffer; Size: Cardinal): Boolean; stdcall;

This item has no description.

Types

TModuleHandle = HINST;

Handle to a loaded DLL

Constants

INVALID_MODULEHANDLE_VALUE = TModuleHandle(0);

Value designating an unassigned TModuleHandle od a failed loading


GLSysHelp v.2.5: Newton.Import

Unit Newton.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Copyright (c) <2003-2020> <Julio Jerez, Newton Game Dynamics> * * This software is provided 'as-is', without any express or implied * warranty. In no event will the authors be held liable for any damages * arising from the use of this software. * * Permission is granted to anyone to use this software for any purpose, * including commercial applications, and to alter it and redistribute it * freely, subject to the following restrictions: * * 1. The origin of this software must not be misrepresented; you must not * claim that you wrote the original software. If you use this software * in a product, an acknowledgment in the product documentation would be * appreciated but is not required. * * 2. Altered source versions must be plainly marked as such, and must not be * misrepresented as being the original software. * * 3. This notice may not be removed or altered from any source distribution.

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TNewtonFuncLinkRecord |
Packed Record TNewtonMaterialData |
Packed Record TNewtonCollisionMaterial |
Packed Record TNewtonBoxParam |
Packed Record TNewtonSphereParam |
Packed Record TNewtonCapsuleParam |
Packed Record TNewtonCylinderParam |
Packed Record TNewtonConeParam |
Packed Record TNewtonTaperedCapsuleParam |
Packed Record TNewtonTaperedCylinderParam |
Packed Record TNewtonChamferCylinderParam |
Packed Record TNewtonConvexHullParam |
Packed Record TNewtonCompoundCollisionParam |
Packed Record TNewtonCollisionTreeParam |
Packed Record TNewtonDeformableMeshParam |
Packed Record TNewtonHeightFieldCollisionParam |
Packed Record TNewtonSceneCollisionParam |
Packed Record TNewtonCollisionNullParam |
Packed Record TNewtonCollisionInfoRecord |
Packed Record TNewtonJointRecord |
Packed Record TNewtonUserMeshCollisionCollideDesc |
Packed Record TNewtonWorldConvexCastReturnInfo |
Packed Record TNewtonUserMeshCollisionRayHitDesc |
Packed Record TNewtonHingeSliderUpdateDesc |
Packed Record TNewtonUserContactPoint |
Packed Record TNewtonImmediateModeConstraint |
Packed Record TNewtonMeshDoubleData |
Packed Record TNewtonMeshFloatData |
Packed Record TNewtonMeshVertexFormat |

Functions and Procedures

function NewtonWorldGetVersion(): Integer; cdecl; external NEWTON_API;
function NewtonWorldFloatSize(): Integer; cdecl; external NEWTON_API;
function NewtonGetMemoryUsed(): Integer; cdecl; external NEWTON_API;
procedure NewtonSetMemorySystem(malloc: NewtonAllocMemory; free: NewtonFreeMemory); cdecl; external NEWTON_API;
function NewtonCreate(): PNewtonWorld; cdecl; external NEWTON_API;
procedure NewtonDestroy(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
procedure NewtonDestroyAllBodies(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
function NewtonGetPostUpdateCallback(const newtonWorld: PNewtonWorld): PNewtonPostUpdateCallback; cdecl; external NEWTON_API;
procedure NewtonSetPostUpdateCallback(const newtonWorld: PNewtonWorld; callback: NewtonPostUpdateCallback); cdecl; external NEWTON_API;
function NewtonAlloc(sizeInBytes: Integer): Pointer; cdecl; external NEWTON_API;
procedure NewtonFree(const ptr: Pointer); cdecl; external NEWTON_API;
procedure NewtonLoadPlugins(const newtonWorld: PNewtonWorld; const plugInPath: pchar); cdecl; external NEWTON_API;
procedure NewtonUnloadPlugins(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
function NewtonCurrentPlugin(const newtonWorld: PNewtonWorld): Pointer; cdecl; external NEWTON_API;
function NewtonGetFirstPlugin(const newtonWorld: PNewtonWorld): Pointer; cdecl; external NEWTON_API;
function NewtonGetPreferedPlugin(const newtonWorld: PNewtonWorld): Pointer; cdecl; external NEWTON_API;
function NewtonGetNextPlugin(const newtonWorld: PNewtonWorld; const plugin: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonGetPluginString(const newtonWorld: PNewtonWorld; const plugin: Pointer): pchar; cdecl; external NEWTON_API;
procedure NewtonSelectPlugin(const newtonWorld: PNewtonWorld; const plugin: Pointer); cdecl; external NEWTON_API;
function NewtonGetContactMergeTolerance(const newtonWorld: PNewtonWorld): dfloat; cdecl; external NEWTON_API;
procedure NewtonSetContactMergeTolerance(const newtonWorld: PNewtonWorld; tolerance: dfloat); cdecl; external NEWTON_API;
procedure NewtonInvalidateCache(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
procedure NewtonSetSolverIterations(const newtonWorld: PNewtonWorld; model: Integer); cdecl; external NEWTON_API;
function NewtonGetSolverIterations(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
procedure NewtonSetParallelSolverOnLargeIsland(const newtonWorld: PNewtonWorld; mode: Integer); cdecl; external NEWTON_API;
function NewtonGetParallelSolverOnLargeIsland(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
function NewtonGetBroadphaseAlgorithm(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
procedure NewtonSelectBroadphaseAlgorithm(const newtonWorld: PNewtonWorld; algorithmType: Integer); cdecl; external NEWTON_API;
procedure NewtonResetBroadphase(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
procedure NewtonUpdate(const newtonWorld: PNewtonWorld; timestep: dfloat); cdecl; external NEWTON_API;
procedure NewtonUpdateAsync(const newtonWorld: PNewtonWorld; timestep: dfloat); cdecl; external NEWTON_API;
procedure NewtonWaitForUpdateToFinish(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
function NewtonGetNumberOfSubsteps(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
procedure NewtonSetNumberOfSubsteps(const newtonWorld: PNewtonWorld; subSteps: Integer); cdecl; external NEWTON_API;
function NewtonGetLastUpdateTime(const newtonWorld: PNewtonWorld): dfloat; cdecl; external NEWTON_API;
procedure NewtonSerializeToFile(const newtonWorld: PNewtonWorld; const filename: pchar; bodyCallback: NewtonOnBodySerializationCallback; const bodyUserData: Pointer); cdecl; external NEWTON_API;
procedure NewtonDeserializeFromFile(const newtonWorld: PNewtonWorld; const filename: pchar; bodyCallback: NewtonOnBodyDeserializationCallback; const bodyUserData: Pointer); cdecl; external NEWTON_API;
procedure NewtonSerializeScene(const newtonWorld: PNewtonWorld; bodyCallback: NewtonOnBodySerializationCallback; const bodyUserData: Pointer; serializeCallback: NewtonSerializeCallback; const serializeHandle: Pointer); cdecl; external NEWTON_API;
procedure NewtonDeserializeScene(const newtonWorld: PNewtonWorld; bodyCallback: NewtonOnBodyDeserializationCallback; const bodyUserData: Pointer; serializeCallback: NewtonDeserializeCallback; const serializeHandle: Pointer); cdecl; external NEWTON_API;
function NewtonFindSerializedBody(const newtonWorld: PNewtonWorld; bodySerializedID: Integer): pNewtonBody; cdecl; external NEWTON_API;
procedure NewtonSetJointSerializationCallbacks(const newtonWorld: PNewtonWorld; serializeJoint: NewtonOnJointSerializationCallback; deserializeJoint: NewtonOnJointDeserializationCallback); cdecl; external NEWTON_API;
procedure NewtonGetJointSerializationCallbacks(const newtonWorld: PNewtonWorld; const serializeJoint: NewtonOnJointSerializationCallback; const deserializeJoint: NewtonOnJointDeserializationCallback); cdecl; external NEWTON_API;
procedure NewtonWorldCriticalSectionLock(const newtonWorld: PNewtonWorld; threadIndex: Integer); cdecl; external NEWTON_API;
procedure NewtonWorldCriticalSectionUnlock(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
procedure NewtonSetThreadsCount(const newtonWorld: PNewtonWorld; threads: Integer); cdecl; external NEWTON_API;
function NewtonGetThreadsCount(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
function NewtonGetMaxThreadsCount(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
procedure NewtonDispachThreadJob(const newtonWorld: PNewtonWorld; task: NewtonJobTask; const usedData: Pointer; const functionName: pchar); cdecl; external NEWTON_API;
procedure NewtonSyncThreadJobs(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
function NewtonAtomicAdd(const ptr: Pinteger; value: Integer): Integer; cdecl; external NEWTON_API;
function NewtonAtomicSwap(const ptr: Pinteger; value: Integer): Integer; cdecl; external NEWTON_API;
procedure NewtonYield(); cdecl; external NEWTON_API;
procedure NewtonSetIslandUpdateEvent(const newtonWorld: PNewtonWorld; islandUpdate: NewtonIslandUpdate); cdecl; external NEWTON_API;
procedure NewtonWorldForEachJointDo(const newtonWorld: PNewtonWorld; callback: NewtonJointIterator; const userData: Pointer); cdecl; external NEWTON_API;
procedure NewtonWorldForEachBodyInAABBDo(const newtonWorld: PNewtonWorld; const p0: pfloat; const p1: pfloat; callback: NewtonBodyIterator; const userData: Pointer); cdecl; external NEWTON_API;
procedure NewtonWorldSetUserData(const newtonWorld: PNewtonWorld; const userData: Pointer); cdecl; external NEWTON_API;
function NewtonWorldGetUserData(const newtonWorld: PNewtonWorld): Pointer; cdecl; external NEWTON_API;
function NewtonWorldAddListener(const newtonWorld: PNewtonWorld; const nameId: pchar; const listenerUserData: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonWorldGetListener(const newtonWorld: PNewtonWorld; const nameId: pchar): Pointer; cdecl; external NEWTON_API;
procedure NewtonWorldListenerSetDebugCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldListenerDebugCallback); cdecl; external NEWTON_API;
procedure NewtonWorldListenerSetPostStepCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldUpdateListenerCallback); cdecl; external NEWTON_API;
procedure NewtonWorldListenerSetPreUpdateCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldUpdateListenerCallback); cdecl; external NEWTON_API;
procedure NewtonWorldListenerSetPostUpdateCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldUpdateListenerCallback); cdecl; external NEWTON_API;
procedure NewtonWorldListenerSetDestructorCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldDestroyListenerCallback); cdecl; external NEWTON_API;
procedure NewtonWorldListenerSetBodyDestroyCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldListenerBodyDestroyCallback); cdecl; external NEWTON_API;
procedure NewtonWorldListenerDebug(const newtonWorld: PNewtonWorld; const context: Pointer); cdecl; external NEWTON_API;
function NewtonWorldGetListenerUserData(const newtonWorld: PNewtonWorld; const listener: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonWorldListenerGetBodyDestroyCallback(const newtonWorld: PNewtonWorld; const listener: Pointer): PNewtonWorldListenerBodyDestroyCallback; cdecl; external NEWTON_API;
procedure NewtonWorldSetDestructorCallback(const newtonWorld: PNewtonWorld; destructorparam: NewtonWorldDestructorCallback); cdecl; external NEWTON_API;
function NewtonWorldGetDestructorCallback(const newtonWorld: PNewtonWorld): PNewtonWorldDestructorCallback; cdecl; external NEWTON_API;
procedure NewtonWorldSetCollisionConstructorDestructorCallback(const newtonWorld: PNewtonWorld; constructorparam: NewtonCollisionCopyConstructionCallback; destructorparam: NewtonCollisionDestructorCallback); cdecl; external NEWTON_API;
procedure NewtonWorldSetCreateDestroyContactCallback(const newtonWorld: PNewtonWorld; createContact: NewtonCreateContactCallback; destroyContact: NewtonDestroyContactCallback); cdecl; external NEWTON_API;
procedure NewtonWorldRayCast(const newtonWorld: PNewtonWorld; const p0: pfloat; const p1: pfloat; filter: NewtonWorldRayFilterCallback; const userData: Pointer; prefilter: NewtonWorldRayPrefilterCallback; threadIndex: Integer); cdecl; external NEWTON_API;
function NewtonWorldConvexCast(const newtonWorld: PNewtonWorld; const matrix: pfloat; const target: pfloat; const shape: PNewtonCollision; const param: pfloat; const userData: Pointer; prefilter: NewtonWorldRayPrefilterCallback; const info: PNewtonWorldConvexCastReturnInfo; maxContactsCount: Integer; threadIndex: Integer): Integer; cdecl; external NEWTON_API;
function NewtonWorldCollide(const newtonWorld: PNewtonWorld; const matrix: pfloat; const shape: PNewtonCollision; const userData: Pointer; prefilter: NewtonWorldRayPrefilterCallback; const info: PNewtonWorldConvexCastReturnInfo; maxContactsCount: Integer; threadIndex: Integer): Integer; cdecl; external NEWTON_API;
function NewtonWorldGetBodyCount(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
function NewtonWorldGetConstraintCount(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
function NewtonWorldFindJoint(const body0: pNewtonBody; const body1: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
function NewtonIslandGetBody(const island: Pointer; bodyIndex: Integer): pNewtonBody; cdecl; external NEWTON_API;
procedure NewtonIslandGetBodyAABB(const island: Pointer; bodyIndex: Integer; const p0: pfloat; const p1: pfloat); cdecl; external NEWTON_API;
function NewtonMaterialCreateGroupID(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
function NewtonMaterialGetDefaultGroupID(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;
procedure NewtonMaterialDestroyAllGroupID(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;
function NewtonMaterialGetUserData(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer): Pointer; cdecl; external NEWTON_API;
procedure NewtonMaterialSetSurfaceThickness(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; thickness: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetCallbackUserData(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; const userData: Pointer); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactGenerationCallback(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; contactGeneration: NewtonOnContactGeneration); cdecl; external NEWTON_API;
procedure NewtonMaterialSetCompoundCollisionCallback(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; compoundAabbOverlap: NewtonOnCompoundSubCollisionAABBOverlap); cdecl; external NEWTON_API;
procedure NewtonMaterialSetCollisionCallback(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; aabbOverlap: NewtonOnAABBOverlap; process: NewtonContactsProcess); cdecl; external NEWTON_API;
procedure NewtonMaterialSetDefaultSoftness(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; value: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetDefaultElasticity(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; elasticCoef: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetDefaultCollidable(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; state: Integer); cdecl; external NEWTON_API;
procedure NewtonMaterialSetDefaultFriction(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; staticFriction: dfloat; kineticFriction: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialJointResetIntraJointCollision(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer); cdecl; external NEWTON_API;
procedure NewtonMaterialJointResetSelftJointCollision(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer); cdecl; external NEWTON_API;
function NewtonWorldGetFirstMaterial(const newtonWorld: PNewtonWorld): PNewtonMaterial; cdecl; external NEWTON_API;
function NewtonWorldGetNextMaterial(const newtonWorld: PNewtonWorld; const material: PNewtonMaterial): PNewtonMaterial; cdecl; external NEWTON_API;
function NewtonWorldGetFirstBody(const newtonWorld: PNewtonWorld): pNewtonBody; cdecl; external NEWTON_API;
function NewtonWorldGetNextBody(const newtonWorld: PNewtonWorld; const curBody: pNewtonBody): pNewtonBody; cdecl; external NEWTON_API;
function NewtonMaterialGetMaterialPairUserData(const material: PNewtonMaterial): Pointer; cdecl; external NEWTON_API;
function NewtonMaterialGetContactFaceAttribute(const material: PNewtonMaterial): LongWord; cdecl; external NEWTON_API;
function NewtonMaterialGetBodyCollidingShape(const material: PNewtonMaterial; const body: pNewtonBody): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonMaterialGetContactNormalSpeed(const material: PNewtonMaterial): dfloat; cdecl; external NEWTON_API;
procedure NewtonMaterialGetContactForce(const material: PNewtonMaterial; const body: pNewtonBody; const force: pfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialGetContactPositionAndNormal(const material: PNewtonMaterial; const body: pNewtonBody; const posit: pfloat; const normal: pfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialGetContactTangentDirections(const material: PNewtonMaterial; const body: pNewtonBody; const dir0: pfloat; const dir1: pfloat); cdecl; external NEWTON_API;
function NewtonMaterialGetContactTangentSpeed(const material: PNewtonMaterial; index: Integer): dfloat; cdecl; external NEWTON_API;
function NewtonMaterialGetContactMaxNormalImpact(const material: PNewtonMaterial): dfloat; cdecl; external NEWTON_API;
function NewtonMaterialGetContactMaxTangentImpact(const material: PNewtonMaterial; index: Integer): dfloat; cdecl; external NEWTON_API;
function NewtonMaterialGetContactPenetration(const material: PNewtonMaterial): dfloat; cdecl; external NEWTON_API;
procedure NewtonMaterialSetAsSoftContact(const material: PNewtonMaterial; relaxation: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactSoftness(const material: PNewtonMaterial; softness: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactThickness(const material: PNewtonMaterial; thickness: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactElasticity(const material: PNewtonMaterial; restitution: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactFrictionState(const material: PNewtonMaterial; state: Integer; index: Integer); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactFrictionCoef(const material: PNewtonMaterial; staticFrictionCoef: dfloat; kineticFrictionCoef: dfloat; index: Integer); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactNormalAcceleration(const material: PNewtonMaterial; accel: dfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactNormalDirection(const material: PNewtonMaterial; const directionVector: pfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactPosition(const material: PNewtonMaterial; const position: pfloat); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactTangentFriction(const material: PNewtonMaterial; friction: dfloat; index: Integer); cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactTangentAcceleration(const material: PNewtonMaterial; accel: dfloat; index: Integer); cdecl; external NEWTON_API;
procedure NewtonMaterialContactRotateTangentDirections(const material: PNewtonMaterial; const directionVector: pfloat); cdecl; external NEWTON_API;
function NewtonMaterialGetContactPruningTolerance(const contactJoint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
procedure NewtonMaterialSetContactPruningTolerance(const contactJoint: PNewtonJoint; tolerance: dfloat); cdecl; external NEWTON_API;
function NewtonCreateNull(const newtonWorld: PNewtonWorld): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateSphere(const newtonWorld: PNewtonWorld; radius: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateBox(const newtonWorld: PNewtonWorld; dx: dfloat; dy: dfloat; dz: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateCone(const newtonWorld: PNewtonWorld; radius: dfloat; height: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateCapsule(const newtonWorld: PNewtonWorld; radius0: dfloat; radius1: dfloat; height: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateCylinder(const newtonWorld: PNewtonWorld; radio0: dfloat; radio1: dfloat; height: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateChamferCylinder(const newtonWorld: PNewtonWorld; radius: dfloat; height: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateConvexHull(const newtonWorld: PNewtonWorld; count: Integer; const vertexCloud: pfloat; strideInBytes: Integer; tolerance: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateConvexHullFromMesh(const newtonWorld: PNewtonWorld; const mesh: PNewtonMesh; tolerance: dfloat; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCollisionGetMode(const convexCollision: PNewtonCollision): Integer; cdecl; external NEWTON_API;
procedure NewtonCollisionSetMode(const convexCollision: PNewtonCollision; mode: Integer); cdecl; external NEWTON_API;
function NewtonConvexHullGetFaceIndices(const convexHullCollision: PNewtonCollision; face: Integer; const faceIndices: Pinteger): Integer; cdecl; external NEWTON_API;
function NewtonConvexHullGetVertexData(const convexHullCollision: PNewtonCollision; const vertexData: Pfloat; strideInBytes: Pinteger): Integer; cdecl; external NEWTON_API;
function NewtonConvexCollisionCalculateVolume(const convexCollision: PNewtonCollision): dfloat; cdecl; external NEWTON_API;
procedure NewtonConvexCollisionCalculateInertialMatrix(const convexCollision: PNewtonCollision; const inertia: pfloat; const origin: pfloat); cdecl; external NEWTON_API;
function NewtonConvexCollisionCalculateBuoyancyVolume(const convexCollision: PNewtonCollision; const matrix: pfloat; const fluidPlane: pfloat; const centerOfBuoyancy: pfloat): dfloat; cdecl; external NEWTON_API;
function NewtonCollisionDataPointer(const convexCollision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;
function NewtonCreateCompoundCollision(const newtonWorld: PNewtonWorld; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateCompoundCollisionFromMesh(const newtonWorld: PNewtonWorld; const mesh: PNewtonMesh; hullTolerance: dfloat; shapeID: Integer; subShapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
procedure NewtonCompoundCollisionBeginAddRemove(const compoundCollision: PNewtonCollision); cdecl; external NEWTON_API;
function NewtonCompoundCollisionAddSubCollision(const compoundCollision: PNewtonCollision; const convexCollision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;
procedure NewtonCompoundCollisionRemoveSubCollision(const compoundCollision: PNewtonCollision; const collisionNode: Pointer); cdecl; external NEWTON_API;
procedure NewtonCompoundCollisionRemoveSubCollisionByIndex(const compoundCollision: PNewtonCollision; nodeIndex: Integer); cdecl; external NEWTON_API;
procedure NewtonCompoundCollisionSetSubCollisionMatrix(const compoundCollision: PNewtonCollision; const collisionNode: Pointer; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonCompoundCollisionEndAddRemove(const compoundCollision: PNewtonCollision); cdecl; external NEWTON_API;
function NewtonCompoundCollisionGetFirstNode(const compoundCollision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;
function NewtonCompoundCollisionGetNextNode(const compoundCollision: PNewtonCollision; const collisionNode: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonCompoundCollisionGetNodeByIndex(const compoundCollision: PNewtonCollision; index: Integer): Pointer; cdecl; external NEWTON_API;
function NewtonCompoundCollisionGetNodeIndex(const compoundCollision: PNewtonCollision; const collisionNode: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonCompoundCollisionGetCollisionFromNode(const compoundCollision: PNewtonCollision; const collisionNode: Pointer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateFracturedCompoundCollision(const newtonWorld: PNewtonWorld; const solidMesh: PNewtonMesh; shapeID: Integer; fracturePhysicsMaterialID: Integer; pointcloudCount: Integer; const vertexCloud: pfloat; strideInBytes: Integer; materialID: Integer; const textureMatrix: pfloat; regenerateMainMeshCallback: NewtonFractureCompoundCollisionReconstructMainMeshCallBack; emitFracturedCompound: NewtonFractureCompoundCollisionOnEmitCompoundFractured; emitFracfuredChunk: NewtonFractureCompoundCollisionOnEmitChunk): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonFracturedCompoundPlaneClip(const fracturedCompound: PNewtonCollision; const plane: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
procedure NewtonFracturedCompoundSetCallbacks(const fracturedCompound: PNewtonCollision; regenerateMainMeshCallback: NewtonFractureCompoundCollisionReconstructMainMeshCallBack; emitFracturedCompound: NewtonFractureCompoundCollisionOnEmitCompoundFractured; emitFracfuredChunk: NewtonFractureCompoundCollisionOnEmitChunk); cdecl; external NEWTON_API;
function NewtonFracturedCompoundIsNodeFreeToDetach(const fracturedCompound: PNewtonCollision; const collisionNode: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonFracturedCompoundNeighborNodeList(const fracturedCompound: PNewtonCollision; const collisionNode: Pointer; const list: PPointer; maxCount: Integer): Integer; cdecl; external NEWTON_API;
function NewtonFracturedCompoundGetMainMesh(const fracturedCompound: PNewtonCollision): PNewtonFracturedCompoundMeshPart; cdecl; external NEWTON_API;
function NewtonFracturedCompoundGetFirstSubMesh(const fracturedCompound: PNewtonCollision): PNewtonFracturedCompoundMeshPart; cdecl; external NEWTON_API;
function NewtonFracturedCompoundGetNextSubMesh(const fracturedCompound: PNewtonCollision; const subMesh: PNewtonFracturedCompoundMeshPart): PNewtonFracturedCompoundMeshPart; cdecl; external NEWTON_API;
function NewtonFracturedCompoundCollisionGetVertexCount(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart): Integer; cdecl; external NEWTON_API;
function NewtonFracturedCompoundCollisionGetVertexPositions(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart): pfloat; cdecl; external NEWTON_API;
function NewtonFracturedCompoundCollisionGetVertexNormals(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart): pfloat; cdecl; external NEWTON_API;
function NewtonFracturedCompoundCollisionGetVertexUVs(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart): pfloat; cdecl; external NEWTON_API;
function NewtonFracturedCompoundMeshPartGetIndexStream(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart; const segment: Pointer; const index: Pinteger): Integer; cdecl; external NEWTON_API;
function NewtonFracturedCompoundMeshPartGetFirstSegment(const fractureCompoundMeshPart: PNewtonFracturedCompoundMeshPart): Pointer; cdecl; external NEWTON_API;
function NewtonFracturedCompoundMeshPartGetNextSegment(const fractureCompoundMeshSegment: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonFracturedCompoundMeshPartGetMaterial(const fractureCompoundMeshSegment: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonFracturedCompoundMeshPartGetIndexCount(const fractureCompoundMeshSegment: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonCreateSceneCollision(const newtonWorld: PNewtonWorld; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
procedure NewtonSceneCollisionBeginAddRemove(const sceneCollision: PNewtonCollision); cdecl; external NEWTON_API;
function NewtonSceneCollisionAddSubCollision(const sceneCollision: PNewtonCollision; const collision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;
procedure NewtonSceneCollisionRemoveSubCollision(const compoundCollision: PNewtonCollision; const collisionNode: Pointer); cdecl; external NEWTON_API;
procedure NewtonSceneCollisionRemoveSubCollisionByIndex(const sceneCollision: PNewtonCollision; nodeIndex: Integer); cdecl; external NEWTON_API;
procedure NewtonSceneCollisionSetSubCollisionMatrix(const sceneCollision: PNewtonCollision; const collisionNode: Pointer; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonSceneCollisionEndAddRemove(const sceneCollision: PNewtonCollision); cdecl; external NEWTON_API;
function NewtonSceneCollisionGetFirstNode(const sceneCollision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;
function NewtonSceneCollisionGetNextNode(const sceneCollision: PNewtonCollision; const collisionNode: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonSceneCollisionGetNodeByIndex(const sceneCollision: PNewtonCollision; index: Integer): Pointer; cdecl; external NEWTON_API;
function NewtonSceneCollisionGetNodeIndex(const sceneCollision: PNewtonCollision; const collisionNode: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonSceneCollisionGetCollisionFromNode(const sceneCollision: PNewtonCollision; const collisionNode: Pointer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateUserMeshCollision(const newtonWorld: PNewtonWorld; const minBox: pfloat; const maxBox: pfloat; const userData: Pointer; collideCallback: NewtonUserMeshCollisionCollideCallback; rayHitCallback: NewtonUserMeshCollisionRayHitCallback; destroyCallback: NewtonUserMeshCollisionDestroyCallback; getInfoCallback: NewtonUserMeshCollisionGetCollisionInfo; getLocalAABBCallback: NewtonUserMeshCollisionAABBTest; facesInAABBCallback: NewtonUserMeshCollisionGetFacesInAABB; serializeCallback: NewtonOnUserCollisionSerializationCallback; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonUserMeshCollisionContinuousOverlapTest(const collideDescData: PNewtonUserMeshCollisionCollideDesc; const continueCollisionHandle: Pointer; const minAabb: pfloat; const maxAabb: pfloat): Integer; cdecl; external NEWTON_API;
function NewtonCreateCollisionFromSerialization(const newtonWorld: PNewtonWorld; deserializeFunction: NewtonDeserializeCallback; const serializeHandle: Pointer): PNewtonCollision; cdecl; external NEWTON_API;
procedure NewtonCollisionSerialize(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; serializeFunction: NewtonSerializeCallback; const serializeHandle: Pointer); cdecl; external NEWTON_API;
procedure NewtonCollisionGetInfo(const collision: PNewtonCollision; const collisionInfo: PNewtonCollisionInfoRecord); cdecl; external NEWTON_API;
function NewtonCreateHeightFieldCollision(const newtonWorld: PNewtonWorld; width: Integer; height: Integer; gridsDiagonals: Integer; elevationdatType: Integer; const elevationMap: Pointer; const attributeMap: pchar; verticalScale: dfloat; horizontalScale_x: dfloat; horizontalScale_z: dfloat; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
procedure NewtonHeightFieldSetUserRayCastCallback(const heightfieldCollision: PNewtonCollision; rayHitCallback: NewtonHeightFieldRayCastCallback); cdecl; external NEWTON_API;
procedure NewtonHeightFieldSetHorizontalDisplacement(heightfieldCollision : PNewtonCollision; horizontalMap : Pword; scale : dFloat); cdecl; external NEWTON_API;
function NewtonCreateTreeCollision(const newtonWorld: PNewtonWorld; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateTreeCollisionFromMesh(const newtonWorld: PNewtonWorld; const mesh: PNewtonMesh; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
procedure NewtonTreeCollisionSetUserRayCastCallback(const treeCollision: PNewtonCollision; rayHitCallback: NewtonCollisionTreeRayCastCallback); cdecl; external NEWTON_API;
procedure NewtonTreeCollisionBeginBuild(const treeCollision: PNewtonCollision); cdecl; external NEWTON_API;
procedure NewtonTreeCollisionAddFace(const treeCollision: PNewtonCollision; vertexCount: Integer; const vertexPtr: pfloat; strideInBytes: Integer; faceAttribute: Integer); cdecl; external NEWTON_API;
procedure NewtonTreeCollisionEndBuild(const treeCollision: PNewtonCollision; optimize: Integer); cdecl; external NEWTON_API;
function NewtonTreeCollisionGetFaceAttribute(const treeCollision: PNewtonCollision; const faceIndexArray: Pinteger; indexCount: Integer): Integer; cdecl; external NEWTON_API;
procedure NewtonTreeCollisionSetFaceAttribute(const treeCollision: PNewtonCollision; const faceIndexArray: Pinteger; indexCount: Integer; attribute: Integer); cdecl; external NEWTON_API;
procedure NewtonTreeCollisionForEachFace(const treeCollision: PNewtonCollision; forEachFaceCallback: NewtonTreeCollisionFaceCallback; const context: Pointer); cdecl; external NEWTON_API;
function NewtonTreeCollisionGetVertexListTriangleListInAABB(const treeCollision: PNewtonCollision; const p0: pfloat; const p1: pfloat; const vertexArray: Pfloat; const vertexCount: Pinteger; const vertexStrideInBytes: Pinteger; const indexList: Pinteger; maxIndexCount: Integer; const faceAttribute: Pinteger): Integer; cdecl; external NEWTON_API;
procedure NewtonStaticCollisionSetDebugCallback(const staticCollision: PNewtonCollision; userCallback: NewtonTreeCollisionCallback); cdecl; external NEWTON_API;
function NewtonCollisionCreateInstance(const collision: PNewtonCollision): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCollisionGetType(const collision: PNewtonCollision): Integer; cdecl; external NEWTON_API;
function NewtonCollisionIsConvexShape(const collision: PNewtonCollision): Integer; cdecl; external NEWTON_API;
function NewtonCollisionIsStaticShape(const collision: PNewtonCollision): Integer; cdecl; external NEWTON_API;
procedure NewtonCollisionSetUserData(const collision: PNewtonCollision; const userData: Pointer); cdecl; external NEWTON_API;
function NewtonCollisionGetUserData(const collision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;
procedure NewtonCollisionSetUserID(const collision: PNewtonCollision; id: int64); cdecl; external NEWTON_API;
function NewtonCollisionGetUserID(const collision: PNewtonCollision): int64; cdecl; external NEWTON_API;
procedure NewtonCollisionGetMaterial(const collision: PNewtonCollision; const userData: PNewtonCollisionMaterial); cdecl; external NEWTON_API;
procedure NewtonCollisionSetMaterial(const collision: PNewtonCollision; const userData: PNewtonCollisionMaterial); cdecl; external NEWTON_API;
function NewtonCollisionGetSubCollisionHandle(const collision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;
function NewtonCollisionGetParentInstance(const collision: PNewtonCollision): PNewtonCollision; cdecl; external NEWTON_API;
procedure NewtonCollisionSetMatrix(const collision: PNewtonCollision; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonCollisionGetMatrix(const collision: PNewtonCollision; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonCollisionSetScale(const collision: PNewtonCollision; scaleX: dfloat; scaleY: dfloat; scaleZ: dfloat); cdecl; external NEWTON_API;
procedure NewtonCollisionGetScale(const collision: PNewtonCollision; const scaleX: pfloat; const scaleY: pfloat; const scaleZ: pfloat); cdecl; external NEWTON_API;
procedure NewtonDestroyCollision(const collision: PNewtonCollision); cdecl; external NEWTON_API;
function NewtonCollisionGetSkinThickness(const collision: PNewtonCollision): dfloat; cdecl; external NEWTON_API;
procedure NewtonCollisionSetSkinThickness(const collision: PNewtonCollision; thickness: dfloat); cdecl; external NEWTON_API;
function NewtonCollisionIntersectionTest(const newtonWorld: PNewtonWorld; const collisionA: PNewtonCollision; const matrixA: pfloat; const collisionB: PNewtonCollision; const matrixB: pfloat; threadIndex: Integer): Integer; cdecl; external NEWTON_API;
function NewtonCollisionPointDistance(const newtonWorld: PNewtonWorld; const point: pfloat; const collision: PNewtonCollision; const matrix: pfloat; const contact: pfloat; const normal: pfloat; threadIndex: Integer): Integer; cdecl; external NEWTON_API;
function NewtonCollisionClosestPoint(const newtonWorld: PNewtonWorld; const collisionA: PNewtonCollision; const matrixA: pfloat; const collisionB: PNewtonCollision; const matrixB: pfloat; const contactA: pfloat; const contactB: pfloat; const normalAB: pfloat; threadIndex: Integer): Integer; cdecl; external NEWTON_API;
function NewtonCollisionCollide(const newtonWorld: PNewtonWorld; maxSize: Integer; const collisionA: PNewtonCollision; const matrixA: pfloat; const collisionB: PNewtonCollision; const matrixB: pfloat; const contacts: pfloat; const normals: pfloat; const penetration: pfloat; const attributeA: Pint64; const attributeB: Pint64; threadIndex: Integer): Integer; cdecl; external NEWTON_API;
function NewtonCollisionCollideContinue(const newtonWorld: PNewtonWorld; maxSize: Integer; timestep: dfloat; const collisionA: PNewtonCollision; const matrixA: pfloat; const velocA: pfloat; const omegaA: pfloat; const collisionB: PNewtonCollision; const matrixB: pfloat; const velocB: pfloat; const omegaB: pfloat; const timeOfImpact: pfloat; const contacts: pfloat; const normals: pfloat; const penetration: pfloat; const attributeA: Pint64; const attributeB: Pint64; threadIndex: Integer): Integer; cdecl; external NEWTON_API;
procedure NewtonCollisionSupportVertex(const collision: PNewtonCollision; const dir: pfloat; const vertex: pfloat); cdecl; external NEWTON_API;
function NewtonCollisionRayCast(const collision: PNewtonCollision; const p0: pfloat; const p1: pfloat; const normal: pfloat; const attribute: Pint64): dfloat; cdecl; external NEWTON_API;
procedure NewtonCollisionCalculateAABB(const collision: PNewtonCollision; const matrix: pfloat; const p0: pfloat; const p1: pfloat); cdecl; external NEWTON_API;
procedure NewtonCollisionForEachPolygonDo(const collision: PNewtonCollision; const matrix: pfloat; callback: NewtonCollisionIterator; const userData: Pointer); cdecl; external NEWTON_API;
function NewtonCollisionAggregateCreate(const world: PNewtonWorld): Pointer; cdecl; external NEWTON_API;
procedure NewtonCollisionAggregateDestroy(const aggregate: Pointer); cdecl; external NEWTON_API;
procedure NewtonCollisionAggregateAddBody(const aggregate: Pointer; const body: pNewtonBody); cdecl; external NEWTON_API;
procedure NewtonCollisionAggregateRemoveBody(const aggregate: Pointer; const body: pNewtonBody); cdecl; external NEWTON_API;
function NewtonCollisionAggregateGetSelfCollision(const aggregate: Pointer): Integer; cdecl; external NEWTON_API;
procedure NewtonCollisionAggregateSetSelfCollision(const aggregate: Pointer; state: Integer); cdecl; external NEWTON_API;
procedure NewtonSetEulerAngle(const eulersAngles: pfloat; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonGetEulerAngle(const matrix: pfloat; const eulersAngles0: pfloat; const eulersAngles1: pfloat); cdecl; external NEWTON_API;
function NewtonCalculateSpringDamperAcceleration(dt: dfloat; ks: dfloat; x: dfloat; kd: dfloat; s: dfloat): dfloat; cdecl; external NEWTON_API;
function NewtonCreateDynamicBody(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; const matrix: pfloat): pNewtonBody; cdecl; external NEWTON_API;
function NewtonCreateKinematicBody(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; const matrix: pfloat): pNewtonBody; cdecl; external NEWTON_API;
function NewtonCreateAsymetricDynamicBody(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; const matrix: pfloat): pNewtonBody; cdecl; external NEWTON_API;
procedure NewtonDestroyBody(const body: pNewtonBody); cdecl; external NEWTON_API;
function NewtonBodyGetSimulationState(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
procedure NewtonBodySetSimulationState(const bodyPtr: pNewtonBody; const state: Integer); cdecl; external NEWTON_API;
function NewtonBodyGetType(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
function NewtonBodyGetCollidable(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
procedure NewtonBodySetCollidable(const body: pNewtonBody; collidableState: Integer); cdecl; external NEWTON_API;
procedure NewtonBodyAddForce(const body: pNewtonBody; const force: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyAddTorque(const body: pNewtonBody; const torque: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyCalculateInverseDynamicsForce(body : PNewtonBody; timestep : dFloat; desiredVeloc : PdFloat; forceOut : PdFloat); cdecl; external NEWTON_API;
procedure NewtonBodySetCentreOfMass(const body: pNewtonBody; const com: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetMassMatrix(const body: pNewtonBody; mass: dfloat; Ixx: dfloat; Iyy: dfloat; Izz: dfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetFullMassMatrix(const body: pNewtonBody; mass: dfloat; const inertiaMatrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetMassProperties(const body: pNewtonBody; mass: dfloat; const collision: PNewtonCollision); cdecl; external NEWTON_API;
procedure NewtonBodySetMatrix(const body: pNewtonBody; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetMatrixNoSleep(const body: pNewtonBody; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetMatrixRecursive(const body: pNewtonBody; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetMaterialGroupID(const body: pNewtonBody; id: Integer); cdecl; external NEWTON_API;
procedure NewtonBodySetContinuousCollisionMode(const body: pNewtonBody; state: LongWord); cdecl; external NEWTON_API;
procedure NewtonBodySetJointRecursiveCollision(const body: pNewtonBody; state: LongWord); cdecl; external NEWTON_API;
procedure NewtonBodySetOmega(const body: pNewtonBody; const omega: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetOmegaNoSleep(const body: pNewtonBody; const omega: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetVelocity(const body: pNewtonBody; const velocity: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetVelocityNoSleep(const body: pNewtonBody; const velocity: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetForce(const body: pNewtonBody; const force: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetTorque(const body: pNewtonBody; const torque: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetLinearDamping(const body: pNewtonBody; linearDamp: dfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetAngularDamping(const body: pNewtonBody; const angularDamp: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodySetCollision(const body: pNewtonBody; const collision: PNewtonCollision); cdecl; external NEWTON_API;
procedure NewtonBodySetCollisionScale(const body: pNewtonBody; scaleX: dfloat; scaleY: dfloat; scaleZ: dfloat); cdecl; external NEWTON_API;
function NewtonBodyGetSleepState(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
procedure NewtonBodySetSleepState(const body: pNewtonBody; state: Integer); cdecl; external NEWTON_API;
function NewtonBodyGetAutoSleep(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
procedure NewtonBodySetAutoSleep(const body: pNewtonBody; state: Integer); cdecl; external NEWTON_API;
function NewtonBodyGetFreezeState(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
procedure NewtonBodySetFreezeState(const body: pNewtonBody; state: Integer); cdecl; external NEWTON_API;
function NewtonBodyGetGyroscopicTorque(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
procedure NewtonBodySetGyroscopicTorque(const body: pNewtonBody; state: Integer); cdecl; external NEWTON_API;
procedure NewtonBodySetDestructorCallback(const body: pNewtonBody; callback: NewtonBodyDestructor); cdecl; external NEWTON_API;
function NewtonBodyGetDestructorCallback(const body: pNewtonBody): PNewtonBodyDestructor; cdecl; external NEWTON_API;
procedure NewtonBodySetTransformCallback(const body: pNewtonBody; callback: NewtonSetTransform); cdecl; external NEWTON_API;
function NewtonBodyGetTransformCallback(const body: pNewtonBody): PNewtonSetTransform; cdecl; external NEWTON_API;
procedure NewtonBodySetForceAndTorqueCallback(const body: pNewtonBody; callback: NewtonApplyForceAndTorque); cdecl; external NEWTON_API;
function NewtonBodyGetForceAndTorqueCallback(const body: pNewtonBody): PNewtonApplyForceAndTorque; cdecl; external NEWTON_API;
function NewtonBodyGetID(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
procedure NewtonBodySetUserData(const body: pNewtonBody; const userData: Pointer); cdecl; external NEWTON_API;
function NewtonBodyGetUserData(const body: pNewtonBody): Pointer; cdecl; external NEWTON_API;
function NewtonBodyGetWorld(const body: pNewtonBody): PNewtonWorld; cdecl; external NEWTON_API;
function NewtonBodyGetCollision(const body: pNewtonBody): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonBodyGetMaterialGroupID(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
function NewtonBodyGetSerializedID(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
function NewtonBodyGetContinuousCollisionMode(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
function NewtonBodyGetJointRecursiveCollision(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;
procedure NewtonBodyGetPosition(const body: pNewtonBody; const pos: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetMatrix(const body: pNewtonBody; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetRotation(const body: pNewtonBody; const rotation: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetMass(const body: pNewtonBody; mass: pfloat; const Ixx: pfloat; const Iyy: pfloat; const Izz: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetInvMass(const body: pNewtonBody; const invMass: pfloat; const invIxx: pfloat; const invIyy: pfloat; const invIzz: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetInertiaMatrix(const body: pNewtonBody; const inertiaMatrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetInvInertiaMatrix(const body: pNewtonBody; const invInertiaMatrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetOmega(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetVelocity(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetAlpha(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetAcceleration(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetForce(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetTorque(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetCentreOfMass(const body: pNewtonBody; const com: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetPointVelocity(const body: pNewtonBody; const point: pfloat; const velocOut: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyApplyImpulsePair(const body: pNewtonBody; const linearImpulse: pfloat; const angularImpulse: pfloat; timestep: dfloat); cdecl; external NEWTON_API;
procedure NewtonBodyAddImpulse(const body: pNewtonBody; const pointDeltaVeloc: pfloat; const pointPosit: pfloat; timestep: dfloat); cdecl; external NEWTON_API;
procedure NewtonBodyApplyImpulseArray(const body: pNewtonBody; impuleCount: Integer; strideInByte: Integer; const impulseArray: pfloat; const pointArray: pfloat; timestep: dfloat); cdecl; external NEWTON_API;
procedure NewtonBodyIntegrateVelocity(const body: pNewtonBody; timestep: dfloat); cdecl; external NEWTON_API;
function NewtonBodyGetLinearDamping(const body: pNewtonBody): dfloat; cdecl; external NEWTON_API;
procedure NewtonBodyGetAngularDamping(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;
procedure NewtonBodyGetAABB(const body: pNewtonBody; const p0: pfloat; const p1: pfloat); cdecl; external NEWTON_API;
function NewtonBodyGetFirstJoint(const body: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
function NewtonBodyGetNextJoint(const body: pNewtonBody; const joint: PNewtonJoint): PNewtonJoint; cdecl; external NEWTON_API;
function NewtonBodyGetFirstContactJoint(const body: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
function NewtonBodyGetNextContactJoint(const body: pNewtonBody; const contactJoint: PNewtonJoint): PNewtonJoint; cdecl; external NEWTON_API;
function NewtonBodyFindContact(const body0: pNewtonBody; const body1: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
function NewtonContactJointGetFirstContact(const contactJoint: PNewtonJoint): Pointer; cdecl; external NEWTON_API;
function NewtonContactJointGetNextContact(const contactJoint: PNewtonJoint; const contact: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonContactJointGetContactCount(const contactJoint: PNewtonJoint): Integer; cdecl; external NEWTON_API;
procedure NewtonContactJointRemoveContact(const contactJoint: PNewtonJoint; const contact: Pointer); cdecl; external NEWTON_API;
function NewtonContactJointGetClosestDistance(const contactJoint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
procedure NewtonContactJointResetSelftJointCollision(const contactJoint: PNewtonJoint); cdecl; external NEWTON_API;
procedure NewtonContactJointResetIntraJointCollision(const contactJoint: PNewtonJoint); cdecl; external NEWTON_API;
function NewtonContactGetMaterial(const contact: Pointer): PNewtonMaterial; cdecl; external NEWTON_API;
function NewtonContactGetCollision0(const contact: Pointer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonContactGetCollision1(const contact: Pointer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonContactGetCollisionID0(const contact: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonContactGetCollisionID1(const contact: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonJointGetUserData(const joint: PNewtonJoint): Pointer; cdecl; external NEWTON_API;
procedure NewtonJointSetUserData(const joint: PNewtonJoint; const userData: Pointer); cdecl; external NEWTON_API;
function NewtonJointGetBody0(const joint: PNewtonJoint): pNewtonBody; cdecl; external NEWTON_API;
function NewtonJointGetBody1(const joint: PNewtonJoint): pNewtonBody; cdecl; external NEWTON_API;
procedure NewtonJointGetInfo(const joint: PNewtonJoint; const info: PNewtonJointRecord); cdecl; external NEWTON_API;
function NewtonJointGetCollisionState(const joint: PNewtonJoint): Integer; cdecl; external NEWTON_API;
procedure NewtonJointSetCollisionState(const joint: PNewtonJoint; state: Integer); cdecl; external NEWTON_API;
function NewtonJointGetStiffness(const joint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
procedure NewtonJointSetStiffness(const joint: PNewtonJoint; state: dfloat); cdecl; external NEWTON_API;
procedure NewtonDestroyJoint(const newtonWorld: PNewtonWorld; const joint: PNewtonJoint); cdecl; external NEWTON_API;
procedure NewtonJointSetDestructor(const joint: PNewtonJoint; destructorparam: NewtonConstraintDestructor); cdecl; external NEWTON_API;
function NewtonJointIsActive(const joint: PNewtonJoint): Integer; cdecl; external NEWTON_API;
function NewtonCreateMassSpringDamperSystem(const newtonWorld: PNewtonWorld; shapeID: Integer; const points: pfloat; pointCount: Integer; strideInBytes: Integer; const pointMass: pfloat; const links: Pinteger; linksCount: Integer; const linksSpring: pfloat; const linksDamper: pfloat): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonCreateDeformableSolid(const newtonWorld: PNewtonWorld; const mesh: PNewtonMesh; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;
function NewtonDeformableMeshGetParticleCount(const deformableMesh: PNewtonCollision): Integer; cdecl; external NEWTON_API;
function NewtonDeformableMeshGetParticleStrideInBytes(const deformableMesh: PNewtonCollision): Integer; cdecl; external NEWTON_API;
function NewtonDeformableMeshGetParticleArray(const deformableMesh: PNewtonCollision): pfloat; cdecl; external NEWTON_API;
function NewtonConstraintCreateBall(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
procedure NewtonBallSetUserCallback(const ball: PNewtonJoint; callback: NewtonBallCallback); cdecl; external NEWTON_API;
procedure NewtonBallGetJointAngle(const ball: PNewtonJoint; angle: pfloat); cdecl; external NEWTON_API;
procedure NewtonBallGetJointOmega(const ball: PNewtonJoint; omega: pfloat); cdecl; external NEWTON_API;
procedure NewtonBallGetJointForce(const ball: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;
procedure NewtonBallSetConeLimits(const ball: PNewtonJoint; const pin: pfloat; maxConeAngle: dfloat; maxTwistAngle: dfloat); cdecl; external NEWTON_API;
function NewtonConstraintCreateHinge(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const pinDir: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
procedure NewtonHingeSetUserCallback(const hinge: PNewtonJoint; callback: NewtonHingeCallback); cdecl; external NEWTON_API;
function NewtonHingeGetJointAngle(const hinge: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonHingeGetJointOmega(const hinge: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
procedure NewtonHingeGetJointForce(const hinge: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;
function NewtonHingeCalculateStopAlpha(const hinge: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: dfloat): dfloat; cdecl; external NEWTON_API;
function NewtonConstraintCreateSlider(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const pinDir: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
procedure NewtonSliderSetUserCallback(const slider: PNewtonJoint; callback: NewtonSliderCallback); cdecl; external NEWTON_API;
function NewtonSliderGetJointPosit(const slider: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonSliderGetJointVeloc(const slider: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
procedure NewtonSliderGetJointForce(const slider: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;
function NewtonSliderCalculateStopAccel(const slider: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; position: dfloat): dfloat; cdecl; external NEWTON_API;
function NewtonConstraintCreateCorkscrew(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const pinDir: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
procedure NewtonCorkscrewSetUserCallback(const corkscrew: PNewtonJoint; callback: NewtonCorkscrewCallback); cdecl; external NEWTON_API;
function NewtonCorkscrewGetJointPosit(const corkscrew: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonCorkscrewGetJointAngle(const corkscrew: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonCorkscrewGetJointVeloc(const corkscrew: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonCorkscrewGetJointOmega(const corkscrew: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
procedure NewtonCorkscrewGetJointForce(const corkscrew: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;
function NewtonCorkscrewCalculateStopAlpha(const corkscrew: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: dfloat): dfloat; cdecl; external NEWTON_API;
function NewtonCorkscrewCalculateStopAccel(const corkscrew: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; position: dfloat): dfloat; cdecl; external NEWTON_API;
function NewtonConstraintCreateUniversal(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const pinDir0: pfloat; const pinDir1: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
procedure NewtonUniversalSetUserCallback(const universal: PNewtonJoint; callback: NewtonUniversalCallback); cdecl; external NEWTON_API;
function NewtonUniversalGetJointAngle0(const universal: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonUniversalGetJointAngle1(const universal: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonUniversalGetJointOmega0(const universal: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonUniversalGetJointOmega1(const universal: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
procedure NewtonUniversalGetJointForce(const universal: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;
function NewtonUniversalCalculateStopAlpha0(const universal: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: dfloat): dfloat; cdecl; external NEWTON_API;
function NewtonUniversalCalculateStopAlpha1(const universal: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: dfloat): dfloat; cdecl; external NEWTON_API;
function NewtonConstraintCreateUpVector(const newtonWorld: PNewtonWorld; const pinDir: pfloat; const body: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
procedure NewtonUpVectorGetPin(const upVector: PNewtonJoint; pin: dfloat); cdecl; external NEWTON_API;
procedure NewtonUpVectorSetPin(const upVector: PNewtonJoint; const pin: dfloat); cdecl; external NEWTON_API;
function NewtonConstraintCreateUserJoint(const newtonWorld: PNewtonWorld; maxDOF: Integer; callback: NewtonUserBilateralCallback; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;
function NewtonUserJointGetSolverModel(const joint: PNewtonJoint): Integer; cdecl; external NEWTON_API;
procedure NewtonUserJointSetSolverModel(const joint: PNewtonJoint; model: Integer); cdecl; external NEWTON_API;
procedure NewtonUserJointMassScale(const joint: PNewtonJoint; scaleBody0: dfloat; scaleBody1: dfloat); cdecl; external NEWTON_API;
procedure NewtonUserJointSetFeedbackCollectorCallback(const joint: PNewtonJoint; getFeedback: NewtonUserBilateralCallback); cdecl; external NEWTON_API;
procedure NewtonUserJointAddLinearRow(const joint: PNewtonJoint; const pivot0: pfloat; const pivot1: pfloat; const dir: pfloat); cdecl; external NEWTON_API;
procedure NewtonUserJointAddAngularRow(const joint: PNewtonJoint; relativeAngle: dfloat; const dir: pfloat); cdecl; external NEWTON_API;
procedure NewtonUserJointAddGeneralRow(const joint: PNewtonJoint; const jacobian0: pfloat; const jacobian1: pfloat); cdecl; external NEWTON_API;
procedure NewtonUserJointSetRowMinimumFriction(const joint: PNewtonJoint; friction: dfloat); cdecl; external NEWTON_API;
procedure NewtonUserJointSetRowMaximumFriction(const joint: PNewtonJoint; friction: dfloat); cdecl; external NEWTON_API;
function NewtonUserJointCalculateRowZeroAcceleration(const joint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
function NewtonUserJointGetRowAcceleration(const joint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;
procedure NewtonUserJointGetRowJacobian(const joint: PNewtonJoint; const linear0: pfloat; const angula0: pfloat; const linear1: pfloat; const angula1: pfloat); cdecl; external NEWTON_API;
procedure NewtonUserJointSetRowAcceleration(const joint: PNewtonJoint; acceleration: dfloat); cdecl; external NEWTON_API;
procedure NewtonUserJointSetRowSpringDamperAcceleration(const joint: PNewtonJoint; rowStiffness: dfloat; spring: dfloat; damper: dfloat); cdecl; external NEWTON_API;
procedure NewtonUserJointSetRowStiffness(const joint: PNewtonJoint; stiffness: dfloat); cdecl; external NEWTON_API;
function NewtonUserJoinRowsCount(const joint: PNewtonJoint): Integer; cdecl; external NEWTON_API;
procedure NewtonUserJointGetGeneralRow(const joint: PNewtonJoint; index: Integer; const jacobian0: pfloat; const jacobian1: pfloat); cdecl; external NEWTON_API;
function NewtonUserJointGetRowForce(const joint: PNewtonJoint; row: Integer): dfloat; cdecl; external NEWTON_API;
function NewtonMeshCreate(const newtonWorld: PNewtonWorld): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateFromMesh(const mesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateFromCollision(const collision: PNewtonCollision): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateTetrahedraIsoSurface(const mesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateConvexHull(const newtonWorld: PNewtonWorld; pointCount: Integer; const vertexCloud: pfloat; strideInBytes: Integer; tolerance: dfloat): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateVoronoiConvexDecomposition(const newtonWorld: PNewtonWorld; pointCount: Integer; const vertexCloud: pfloat; strideInBytes: Integer; materialID: Integer; const textureMatrix: pfloat): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateFromSerialization(const newtonWorld: PNewtonWorld; deserializeFunction: NewtonDeserializeCallback; const serializeHandle: Pointer): PNewtonMesh; cdecl; external NEWTON_API;
procedure NewtonMeshDestroy(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshSerialize(const mesh: PNewtonMesh; serializeFunction: NewtonSerializeCallback; const serializeHandle: Pointer); cdecl; external NEWTON_API;
procedure NewtonMeshSaveOFF(const mesh: PNewtonMesh; const filename: pchar); cdecl; external NEWTON_API;
function NewtonMeshLoadOFF(const newtonWorld: PNewtonWorld; const filename: pchar): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshLoadTetrahedraMesh(const newtonWorld: PNewtonWorld; const filename: pchar): PNewtonMesh; cdecl; external NEWTON_API;
procedure NewtonMeshFlipWinding(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshApplyTransform(const mesh: PNewtonMesh; const matrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshCalculateOOBB(const mesh: PNewtonMesh; const matrix: pfloat; const x: pfloat; const y: pfloat; const z: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshCalculateVertexNormals(const mesh: PNewtonMesh; angleInRadians: dfloat); cdecl; external NEWTON_API;
procedure NewtonMeshApplySphericalMapping(const mesh: PNewtonMesh; material: Integer; const aligmentMatrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshApplyCylindricalMapping(const mesh: PNewtonMesh; cylinderMaterial: Integer; capMaterial: Integer; const aligmentMatrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshApplyBoxMapping(const mesh: PNewtonMesh; frontMaterial: Integer; sideMaterial: Integer; topMaterial: Integer; const aligmentMatrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshApplyAngleBasedMapping(const mesh: PNewtonMesh; material: Integer; reportPrograssCallback: NewtonReportProgress; const reportPrgressUserData: Pointer; const aligmentMatrix: pfloat); cdecl; external NEWTON_API;
procedure NewtonCreateTetrahedraLinearBlendSkinWeightsChannel(const tetrahedraMesh: PNewtonMesh; const skinMesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshOptimize(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshOptimizePoints(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshOptimizeVertex(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
function NewtonMeshIsOpenMesh(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
procedure NewtonMeshFixTJoints(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshPolygonize(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshTriangulate(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
function NewtonMeshUnion(const mesh: PNewtonMesh; const clipper: PNewtonMesh; const clipperMatrix: pfloat): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshDifference(const mesh: PNewtonMesh; const clipper: PNewtonMesh; const clipperMatrix: pfloat): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshIntersection(const mesh: PNewtonMesh; const clipper: PNewtonMesh; const clipperMatrix: pfloat): PNewtonMesh; cdecl; external NEWTON_API;
procedure NewtonMeshClip(const mesh: PNewtonMesh; const clipper: PNewtonMesh; const clipperMatrix: pfloat; const topMesh: PNewtonMesh; const bottomMesh: PNewtonMesh); cdecl; external NEWTON_API;
function NewtonMeshConvexMeshIntersection(const mesh: PNewtonMesh; const convexMesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshSimplify(const mesh: PNewtonMesh; maxVertexCount: Integer; reportPrograssCallback: NewtonReportProgress; const reportPrgressUserData: Pointer): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshApproximateConvexDecomposition(const mesh: PNewtonMesh; maxConcavity: dfloat; backFaceDistanceFactor: dfloat; maxCount: Integer; maxVertexPerHull: Integer; reportProgressCallback: NewtonReportProgress; const reportProgressUserData: Pointer): PNewtonMesh; cdecl; external NEWTON_API;
procedure NewtonRemoveUnusedVertices(const mesh: PNewtonMesh; const vertexRemapTable: Pinteger); cdecl; external NEWTON_API;
procedure NewtonMeshBeginBuild(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshBeginFace(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshAddPoint(const mesh: PNewtonMesh; x: double; y: double; z: double); cdecl; external NEWTON_API;
procedure NewtonMeshAddLayer(const mesh: PNewtonMesh; layerIndex: Integer); cdecl; external NEWTON_API;
procedure NewtonMeshAddMaterial(const mesh: PNewtonMesh; materialIndex: Integer); cdecl; external NEWTON_API;
procedure NewtonMeshAddNormal(const mesh: PNewtonMesh; x: dfloat; y: dfloat; z: dfloat); cdecl; external NEWTON_API;
procedure NewtonMeshAddBinormal(const mesh: PNewtonMesh; x: dfloat; y: dfloat; z: dfloat); cdecl; external NEWTON_API;
procedure NewtonMeshAddUV0(const mesh: PNewtonMesh; u: dfloat; v: dfloat); cdecl; external NEWTON_API;
procedure NewtonMeshAddUV1(const mesh: PNewtonMesh; u: dfloat; v: dfloat); cdecl; external NEWTON_API;
procedure NewtonMeshAddVertexColor(const mesh: PNewtonMesh; r: Single; g: Single; b: Single; a: Single); cdecl; external NEWTON_API;
procedure NewtonMeshEndFace(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshEndBuild(const mesh: PNewtonMesh); cdecl; external NEWTON_API;
procedure NewtonMeshClearVertexFormat(const format: PNewtonMeshVertexFormat); cdecl; external NEWTON_API;
procedure NewtonMeshBuildFromVertexListIndexList(const mesh: PNewtonMesh; const format: PNewtonMeshVertexFormat); cdecl; external NEWTON_API;
function NewtonMeshGetPointCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetIndexToVertexMap(const mesh: PNewtonMesh): Pinteger; cdecl; external NEWTON_API;
function NewtonMeshGetVertexWeights(mesh : PNewtonMesh; vertexIndex : Integer; weightIndex : PInteger; weightFactor : PdFloat) : Integer; cdecl; external NEWTON_API;
procedure NewtonMeshGetVertexDoubleChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: Pdouble); cdecl; external NEWTON_API;
procedure NewtonMeshGetVertexChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshGetNormalChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshGetBinormalChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshGetUV0Channel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshGetUV1Channel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;
procedure NewtonMeshGetVertexColorChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;
function NewtonMeshHasNormalChannel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshHasBinormalChannel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshHasUV0Channel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshHasUV1Channel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshHasVertexColorChannel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshBeginHandle(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;
procedure NewtonMeshEndHandle(const mesh: PNewtonMesh; const handle: Pointer); cdecl; external NEWTON_API;
function NewtonMeshFirstMaterial(const mesh: PNewtonMesh; const handle: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonMeshNextMaterial(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer): Integer; cdecl; external NEWTON_API;
function NewtonMeshMaterialGetMaterial(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer): Integer; cdecl; external NEWTON_API;
function NewtonMeshMaterialGetIndexCount(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer): Integer; cdecl; external NEWTON_API;
procedure NewtonMeshMaterialGetIndexStream(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer; const index: Pinteger); cdecl; external NEWTON_API;
procedure NewtonMeshMaterialGetIndexStreamShort(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer; const index: SmallInt); cdecl; external NEWTON_API;
function NewtonMeshCreateFirstSingleSegment(const mesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateNextSingleSegment(const mesh: PNewtonMesh; const segment: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateFirstLayer(const mesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshCreateNextLayer(const mesh: PNewtonMesh; const segment: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;
function NewtonMeshGetTotalFaceCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetTotalIndexCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
procedure NewtonMeshGetFaces(const mesh: PNewtonMesh; const faceIndexCount: Pinteger; const faceMaterial: Pinteger; const faceIndices: PPointer); cdecl; external NEWTON_API;
function NewtonMeshGetVertexCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetVertexStrideInByte(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetVertexArray(const mesh: PNewtonMesh): Pdouble; cdecl; external NEWTON_API;
function NewtonMeshGetVertexBaseCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;
procedure NewtonMeshSetVertexBaseCount(const mesh: PNewtonMesh; baseCount: Integer); cdecl; external NEWTON_API;
function NewtonMeshGetFirstVertex(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;
function NewtonMeshGetNextVertex(const mesh: PNewtonMesh; const vertex: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonMeshGetVertexIndex(const mesh: PNewtonMesh; const vertex: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetFirstPoint(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;
function NewtonMeshGetNextPoint(const mesh: PNewtonMesh; const point: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonMeshGetPointIndex(const mesh: PNewtonMesh; const point: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetVertexIndexFromPoint(const mesh: PNewtonMesh; const point: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetFirstEdge(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;
function NewtonMeshGetNextEdge(const mesh: PNewtonMesh; const edge: Pointer): Pointer; cdecl; external NEWTON_API;
procedure NewtonMeshGetEdgeIndices(const mesh: PNewtonMesh; const edge: Pointer; const v0: Pinteger; const v1: Pinteger); cdecl; external NEWTON_API;
function NewtonMeshGetFirstFace(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;
function NewtonMeshGetNextFace(const mesh: PNewtonMesh; const face: Pointer): Pointer; cdecl; external NEWTON_API;
function NewtonMeshIsFaceOpen(const mesh: PNewtonMesh; const face: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetFaceMaterial(const mesh: PNewtonMesh; const face: Pointer): Integer; cdecl; external NEWTON_API;
function NewtonMeshGetFaceIndexCount(const mesh: PNewtonMesh; const face: Pointer): Integer; cdecl; external NEWTON_API;
procedure NewtonMeshGetFaceIndices(const mesh: PNewtonMesh; const face: Pointer; const indices: Pinteger); cdecl; external NEWTON_API;
procedure NewtonMeshGetFacePointIndices(const mesh: PNewtonMesh; const face: Pointer; const indices: Pinteger); cdecl; external NEWTON_API;
procedure NewtonMeshCalculateFaceNormal(const mesh: PNewtonMesh; const face: Pointer; const normal: Pdouble); cdecl; external NEWTON_API;
procedure NewtonMeshSetFaceMaterial(const mesh: PNewtonMesh; const face: Pointer; matId: Integer); cdecl; external NEWTON_API;

Types

dFloat = Single;
dFloat64 = Double;
dLong = Int64;
Float = Single;
NewtonAllocMemory = function(sizeInBytes: Integer): Pointer; cdecl;
NewtonApplyForceAndTorque = procedure(const body: pNewtonBody; timestep: dfloat; threadIndex: Integer); cdecl;
NewtonBallCallback = procedure(const ball: PNewtonJoint; timestep: dfloat); cdecl;
NewtonBodyDestructor = procedure(const body: pNewtonBody); cdecl;
NewtonBodyIterator = function(const body: pNewtonBody; const userData: Pointer): Integer; cdecl;
NewtonCollisionCopyConstructionCallback = procedure(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; const sourceCollision: PNewtonCollision); cdecl;
NewtonCollisionDestructorCallback = procedure(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision); cdecl;
NewtonCollisionIterator = procedure(const userData: Pointer; vertexCount: Integer; const faceArray: pfloat; faceId: Integer); cdecl;
NewtonCollisionTreeRayCastCallback = function(const body: pNewtonBody; const treeCollision: PNewtonCollision; intersection: dfloat; const normal: pfloat; faceId: Integer; const usedData: Pointer): dfloat; cdecl;
NewtonConstraintDestructor = procedure(const me: PNewtonJoint); cdecl;
NewtonContactsProcess = procedure(const contact: PNewtonJoint; timestep: dfloat; threadIndex: Integer); cdecl;
NewtonCorkscrewCallback = function(const corkscrew: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc): LongWord; cdecl;
NewtonCreateContactCallback = procedure(const newtonWorld: PNewtonWorld; const contact: PNewtonJoint); cdecl;
NewtonDeserializeCallback = procedure(const serializeHandle: Pointer; const buffer: Pointer; size: Integer); cdecl;
NewtonDestroyContactCallback = procedure(const newtonWorld: PNewtonWorld; const contact: PNewtonJoint); cdecl;
NewtonFractureCompoundCollisionOnEmitChunk = procedure(const chunkBody: pNewtonBody; const fracturexChunkMesh: PNewtonFracturedCompoundMeshPart; const fracturedCompountCollision: PNewtonCollision); cdecl;
NewtonFractureCompoundCollisionOnEmitCompoundFractured = procedure(const fracturedBody: pNewtonBody); cdecl;
NewtonFractureCompoundCollisionReconstructMainMeshCallBack = procedure(const body: pNewtonBody; const mainMesh: PNewtonFracturedCompoundMeshPart; const fracturedCompountCollision: PNewtonCollision); cdecl;
NewtonFreeMemory = procedure(const ptr: Pointer; sizeInBytes: Integer); cdecl;
NewtonGetTimeInMicrosencondsCallback = function(): int64; cdecl;
NewtonHeightFieldRayCastCallback = function(const body: pNewtonBody; const heightFieldCollision: PNewtonCollision; intersection: dfloat; row: Integer; col: Integer; const normal: pfloat; faceId: Integer; const usedData: Pointer): dfloat; cdecl;
NewtonHingeCallback = function(const hinge: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc): LongWord; cdecl;
NewtonIslandUpdate = function(const newtonWorld: PNewtonWorld; const islandHandle: Pointer; bodyCount: Integer): Integer; cdecl;
NewtonJobTask = procedure(const world: PNewtonWorld; const userData: Pointer; threadIndex: Integer); cdecl;
NewtonJointIterator = procedure(const joint: PNewtonJoint; const userData: Pointer); cdecl;
NewtonOnAABBOverlap = function(const contact: PNewtonJoint; timestep: dfloat; threadIndex: Integer): Integer; cdecl;
NewtonOnBodyDeserializationCallback = procedure(const body: pNewtonBody; const userData: Pointer; functionparam: PNewtonDeserializeCallback; const serializeHandle: Pointer); cdecl;
NewtonOnBodySerializationCallback = procedure(const body: pNewtonBody; const userData: Pointer; functionparam: PNewtonSerializeCallback; const serializeHandle: Pointer); cdecl;
NewtonOnCompoundSubCollisionAABBOverlap = function(const contact: PNewtonJoint; timestep: dfloat; const body0: pNewtonBody; const collisionNode0: Pointer; const body1: pNewtonBody; const collisionNode1: Pointer; threadIndex: Integer): Integer; cdecl;
NewtonOnContactGeneration = function(const material: PNewtonMaterial; const body0: pNewtonBody; const collision0: PNewtonCollision; const body1: pNewtonBody; const collision1: PNewtonCollision; const contactBuffer: PNewtonUserContactPoint; maxCount: Integer; threadIndex: Integer): Integer; cdecl;
NewtonOnJointDeserializationCallback = procedure(const body0: pNewtonBody; const body1: pNewtonBody; functionparam: PNewtonDeserializeCallback; const serializeHandle: Pointer); cdecl;
NewtonOnJointSerializationCallback = procedure(const joint: PNewtonJoint; functionparam: PNewtonSerializeCallback; const serializeHandle: Pointer); cdecl;
NewtonOnUserCollisionSerializationCallback = procedure(const userData: Pointer; functionparam: PNewtonSerializeCallback; const serializeHandle: Pointer); cdecl;
NewtonPostUpdateCallback = procedure(const world: PNewtonWorld; timestep: dfloat); cdecl;
NewtonReportProgress = function(normalizedProgressPercent: dfloat; const userData: Pointer): Integer; cdecl;
NewtonSerializeCallback = procedure(const serializeHandle: Pointer; const buffer: Pointer; size: Integer); cdecl;
NewtonSetTransform = procedure(const body: pNewtonBody; const matrix: pfloat; threadIndex: Integer); cdecl;
NewtonSliderCallback = function(const slider: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc): LongWord; cdecl;
NewtonTreeCollisionCallback = procedure(const bodyWithTreeCollision: pNewtonBody; const body: pNewtonBody; faceID: Integer; vertexCount: Integer; const vertex: pfloat; vertexStrideInBytes: Integer); cdecl;
NewtonTreeCollisionFaceCallback = function(const context: Pointer; const polygon: pfloat; strideInBytes: Integer; const indexArray: Pinteger; indexCount: Integer): Integer; cdecl;
NewtonUniversalCallback = function(const universal: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc): LongWord; cdecl;
NewtonUserBilateralCallback = procedure(const userJoint: PNewtonJoint; timestep: dfloat; threadIndex: Integer); cdecl;
NewtonUserBilateralGetInfoCallback = procedure(const userJoint: PNewtonJoint; const info: PNewtonJointRecord); cdecl;
NewtonUserMeshCollisionAABBTest = function(const userData: Pointer; const boxP0: pfloat; const boxP1: pfloat): Integer; cdecl;
NewtonUserMeshCollisionCollideCallback = procedure(const collideDescData: PNewtonUserMeshCollisionCollideDesc; const continueCollisionHandle: Pointer); cdecl;
NewtonUserMeshCollisionDestroyCallback = procedure(const userData: Pointer); cdecl;
NewtonUserMeshCollisionGetCollisionInfo = procedure(const userData: Pointer; const infoRecord: PNewtonCollisionInfoRecord); cdecl;
NewtonUserMeshCollisionGetFacesInAABB = function(const userData: Pointer; const p0: pfloat; const p1: pfloat; const vertexArray: Pfloat; const vertexCount: Pinteger; const vertexStrideInBytes: Pinteger; const indexList: Pinteger; maxIndexCount: Integer; const userDataList: Pinteger): Integer; cdecl;
NewtonUserMeshCollisionRayHitCallback = function(const lineDescData: PNewtonUserMeshCollisionRayHitDesc): dfloat; cdecl;
NewtonWorldDestroyListenerCallback = procedure(const world: PNewtonWorld; const listenerUserData: Pointer); cdecl;
NewtonWorldDestructorCallback = procedure(const world: PNewtonWorld); cdecl;
NewtonWorldListenerBodyDestroyCallback = procedure(const world: PNewtonWorld; const listenerUserData: Pointer; const body: pNewtonBody); cdecl;
NewtonWorldListenerDebugCallback = procedure(const world: PNewtonWorld; const listener: Pointer; const debugContext: Pointer); cdecl;
NewtonWorldRayFilterCallback = function(const body: pNewtonBody; const shapeHit: PNewtonCollision; const hitContact: pfloat; const hitNormal: pfloat; collisionID: int64; const userData: Pointer; intersectParam: dfloat): dfloat; cdecl;
NewtonWorldRayPrefilterCallback = function(const body: pNewtonBody; const collision: PNewtonCollision; const userData: Pointer): LongWord; cdecl;
NewtonWorldUpdateListenerCallback = procedure(const world: PNewtonWorld; const listenerUserData: Pointer; timestep: dfloat); cdecl;
PdFloat = ˆdFloat;
PdFloat64 = ˆdFloat64;
PdLong = ˆdLong;
PFloat = ˆFloat;
PInteger = ˆInteger;
PNewtonAcyclicArticulation = ˆPointer;
PNewtonAllocMemory = ˆNewtonAllocMemory;
PNewtonApplyForceAndTorque = ˆNewtonApplyForceAndTorque;
PNewtonBallCallback = ˆNewtonBallCallback;
PNewtonBody = ˆPointer;
PNewtonBodyDestructor = ˆNewtonBodyDestructor;
PNewtonBodyIterator = ˆNewtonBodyIterator;
PNewtonBoxParam = ˆTNewtonBoxParam;
PNewtonCapsuleParam = ˆTNewtonCapsuleParam;
PNewtonChamferCylinderParam = ˆTNewtonChamferCylinderParam;
PNewtonCollision = ˆPointer;
PNewtonCollisionCopyConstructionCallback = ˆNewtonCollisionCopyConstructionCallback;
PNewtonCollisionDestructorCallback = ˆNewtonCollisionDestructorCallback;
PNewtonCollisionInfoRecord = ˆTNewtonCollisionInfoRecord;
PNewtonCollisionIterator = ˆNewtonCollisionIterator;
PNewtonCollisionMaterial = ˆTNewtonCollisionMaterial;
PNewtonCollisionTreeParam = ˆTNewtonCollisionTreeParam;
PNewtonCollisionTreeRayCastCallback = ˆNewtonCollisionTreeRayCastCallback;
PNewtonCompoundCollisionParam = ˆTNewtonCompoundCollisionParam;
PNewtonConeParam = ˆTNewtonConeParam;
PNewtonConstraintDestructor = ˆNewtonConstraintDestructor;
PNewtonContactsProcess = ˆNewtonContactsProcess;
PNewtonConvexHullParam = ˆTNewtonConvexHullParam;
PNewtonCorkscrewCallback = ˆNewtonCorkscrewCallback;
PNewtonCreateContactCallback = ˆNewtonCreateContactCallback;
PNewtonCylinderParam = ˆTNewtonCylinderParam;
PNewtonDeformableMeshParam = ˆTNewtonDeformableMeshParam;
PNewtonDeformableMeshSegment = ˆPointer;
PNewtonDeserializeCallback = ˆNewtonDeserializeCallback;
PNewtonDestroyContactCallback = ˆNewtonDestroyContactCallback;
PNewtonFractureCompoundCollisionOnEmitChunk = ˆNewtonFractureCompoundCollisionOnEmitChunk;
PNewtonFractureCompoundCollisionOnEmitCompoundFractured = ˆNewtonFractureCompoundCollisionOnEmitCompoundFractured;
PNewtonFractureCompoundCollisionReconstructMainMeshCallBack = ˆNewtonFractureCompoundCollisionReconstructMainMeshCallBack;
PNewtonFracturedCompoundMeshPart = ˆPointer;
PNewtonFreeMemory = ˆNewtonFreeMemory;
PNewtonGetTimeInMicrosencondsCallback = ˆNewtonGetTimeInMicrosencondsCallback;
PNewtonHeightFieldCollisionParam = ˆTNewtonHeightFieldCollisionParam;
PNewtonHeightFieldRayCastCallback = ˆNewtonHeightFieldRayCastCallback;
PNewtonHingeCallback = ˆNewtonHingeCallback;
PNewtonHingeSliderUpdateDesc = ˆTNewtonHingeSliderUpdateDesc;
PNewtonImmediateModeConstraint = ˆTNewtonImmediateModeConstraint;
PNewtonInverseDynamics = ˆPointer;
PNewtonIslandUpdate = ˆNewtonIslandUpdate;
PNewtonJobTask = ˆNewtonJobTask;
PNewtonJoint = ˆPointer;
PNewtonJointIterator = ˆNewtonJointIterator;
PNewtonJointRecord = ˆTNewtonJointRecord;
PNewtonMaterial = ˆPointer;
PNewtonMaterialData = ˆTNewtonMaterialData;
PNewtonMesh = ˆPointer;
PNewtonMeshDoubleData = ˆTNewtonMeshDoubleData;
PNewtonMeshFloatData = ˆTNewtonMeshFloatData;
PNewtonMeshVertexFormat = ˆTNewtonMeshVertexFormat;
PNewtonOnAABBOverlap = ˆNewtonOnAABBOverlap;
PNewtonOnBodyDeserializationCallback = ˆNewtonOnBodyDeserializationCallback;
PNewtonOnBodySerializationCallback = ˆNewtonOnBodySerializationCallback;
PNewtonOnCompoundSubCollisionAABBOverlap = ˆNewtonOnCompoundSubCollisionAABBOverlap;
PNewtonOnContactGeneration = ˆNewtonOnContactGeneration;
PNewtonOnJointDeserializationCallback = ˆNewtonOnJointDeserializationCallback;
PNewtonOnJointSerializationCallback = ˆNewtonOnJointSerializationCallback;
PNewtonOnUserCollisionSerializationCallback = ˆNewtonOnUserCollisionSerializationCallback;
PNewtonPostUpdateCallback = ˆNewtonPostUpdateCallback;
PNewtonReportProgress = ˆNewtonReportProgress;
PNewtonSceneCollisionParam = ˆTNewtonSceneCollisionParam;
PNewtonSceneProxy = ˆPointer;
PNewtonSerializeCallback = ˆNewtonSerializeCallback;
PNewtonSetTransform = ˆNewtonSetTransform;
PNewtonSliderCallback = ˆNewtonSliderCallback;
PNewtonSphereParam = ˆTNewtonSphereParam;
PNewtonTaperedCapsuleParam = ˆTNewtonTaperedCapsuleParam;
PNewtonTaperedCylinderParam = ˆTNewtonTaperedCylinderParam;
PNewtonTreeCollisionCallback = ˆNewtonTreeCollisionCallback;
PNewtonTreeCollisionFaceCallback = ˆNewtonTreeCollisionFaceCallback;
PNewtonUniversalCallback = ˆNewtonUniversalCallback;
PNewtonUserBilateralCallback = ˆNewtonUserBilateralCallback;
PNewtonUserBilateralGetInfoCallback = ˆNewtonUserBilateralGetInfoCallback;
PNewtonUserContactPoint = ˆTNewtonUserContactPoint;
PNewtonUserMeshCollisionAABBTest = ˆNewtonUserMeshCollisionAABBTest;
PNewtonUserMeshCollisionCollideCallback = ˆNewtonUserMeshCollisionCollideCallback;
PNewtonUserMeshCollisionCollideDesc = ˆTNewtonUserMeshCollisionCollideDesc;
PNewtonUserMeshCollisionDestroyCallback = ˆNewtonUserMeshCollisionDestroyCallback;
PNewtonUserMeshCollisionGetCollisionInfo = ˆNewtonUserMeshCollisionGetCollisionInfo;
PNewtonUserMeshCollisionGetFacesInAABB = ˆNewtonUserMeshCollisionGetFacesInAABB;
PNewtonUserMeshCollisionRayHitCallback = ˆNewtonUserMeshCollisionRayHitCallback;
PNewtonUserMeshCollisionRayHitDesc = ˆTNewtonUserMeshCollisionRayHitDesc;
PNewtonWorld = ˆPointer;
PNewtonWorldConvexCastReturnInfo = ˆTNewtonWorldConvexCastReturnInfo;
PNewtonWorldDestroyListenerCallback = ˆNewtonWorldDestroyListenerCallback;
PNewtonWorldDestructorCallback = ˆNewtonWorldDestructorCallback;
PNewtonWorldListenerBodyDestroyCallback = ˆNewtonWorldListenerBodyDestroyCallback;
PNewtonWorldListenerDebugCallback = ˆNewtonWorldListenerDebugCallback;
PNewtonWorldRayFilterCallback = ˆNewtonWorldRayFilterCallback;
PNewtonWorldRayPrefilterCallback = ˆNewtonWorldRayPrefilterCallback;
PNewtonWorldUpdateListenerCallback = ˆNewtonWorldUpdateListenerCallback;
PPointer = ˆPointer;
Psmallint = ˆsmallint;

Constants

NEWTON_API = 'newton32s.dll';
NEWTON_MAJOR_VERSION = 3;
NEWTON_MINOR_VERSION = 15;
NEWTON_BROADPHASE_DEFAULT = 0;
NEWTON_BROADPHASE_PERSINTENT = 1;
NEWTON_DYNAMIC_BODY = 0;
NEWTON_KINEMATIC_BODY = 1;
NEWTON_DYNAMIC_ASYMETRIC_BODY = 2;
SERIALIZE_ID_SPHERE = 0;
SERIALIZE_ID_CAPSULE = 1;
SERIALIZE_ID_CYLINDER = 2;
SERIALIZE_ID_CHAMFERCYLINDER = 3;
SERIALIZE_ID_BOX = 4;
SERIALIZE_ID_CONE = 5;
SERIALIZE_ID_CONVEXHULL = 6;
SERIALIZE_ID_NULL = 7;
SERIALIZE_ID_COMPOUND = 8;
SERIALIZE_ID_TREE = 9;
SERIALIZE_ID_HEIGHTFIELD = 10;
SERIALIZE_ID_CLOTH_PATCH = 11;
SERIALIZE_ID_DEFORMABLE_SOLID = 12;
SERIALIZE_ID_USERMESH = 13;
SERIALIZE_ID_SCENE = 14;
SERIALIZE_ID_FRACTURED_COMPOUND = 15;

Description

Functions and Procedures

function NewtonWorldGetVersion(): Integer; cdecl; external NEWTON_API;

**********************************************************************************************

world control functions

**********************************************************************************************

function NewtonWorldFloatSize(): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonGetMemoryUsed(): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetMemorySystem(malloc: NewtonAllocMemory; free: NewtonFreeMemory); cdecl; external NEWTON_API;

This item has no description.

function NewtonCreate(): PNewtonWorld; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonDestroy(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonDestroyAllBodies(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

function NewtonGetPostUpdateCallback(const newtonWorld: PNewtonWorld): PNewtonPostUpdateCallback; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetPostUpdateCallback(const newtonWorld: PNewtonWorld; callback: NewtonPostUpdateCallback); cdecl; external NEWTON_API;

This item has no description.

function NewtonAlloc(sizeInBytes: Integer): Pointer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonFree(const ptr: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonLoadPlugins(const newtonWorld: PNewtonWorld; const plugInPath: pchar); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUnloadPlugins(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

function NewtonCurrentPlugin(const newtonWorld: PNewtonWorld): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonGetFirstPlugin(const newtonWorld: PNewtonWorld): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonGetPreferedPlugin(const newtonWorld: PNewtonWorld): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonGetNextPlugin(const newtonWorld: PNewtonWorld; const plugin: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonGetPluginString(const newtonWorld: PNewtonWorld; const plugin: Pointer): pchar; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSelectPlugin(const newtonWorld: PNewtonWorld; const plugin: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonGetContactMergeTolerance(const newtonWorld: PNewtonWorld): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetContactMergeTolerance(const newtonWorld: PNewtonWorld; tolerance: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonInvalidateCache(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetSolverIterations(const newtonWorld: PNewtonWorld; model: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonGetSolverIterations(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetParallelSolverOnLargeIsland(const newtonWorld: PNewtonWorld; mode: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonGetParallelSolverOnLargeIsland(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonGetBroadphaseAlgorithm(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSelectBroadphaseAlgorithm(const newtonWorld: PNewtonWorld; algorithmType: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonResetBroadphase(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUpdate(const newtonWorld: PNewtonWorld; timestep: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUpdateAsync(const newtonWorld: PNewtonWorld; timestep: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWaitForUpdateToFinish(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

function NewtonGetNumberOfSubsteps(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetNumberOfSubsteps(const newtonWorld: PNewtonWorld; subSteps: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonGetLastUpdateTime(const newtonWorld: PNewtonWorld): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSerializeToFile(const newtonWorld: PNewtonWorld; const filename: pchar; bodyCallback: NewtonOnBodySerializationCallback; const bodyUserData: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonDeserializeFromFile(const newtonWorld: PNewtonWorld; const filename: pchar; bodyCallback: NewtonOnBodyDeserializationCallback; const bodyUserData: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSerializeScene(const newtonWorld: PNewtonWorld; bodyCallback: NewtonOnBodySerializationCallback; const bodyUserData: Pointer; serializeCallback: NewtonSerializeCallback; const serializeHandle: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonDeserializeScene(const newtonWorld: PNewtonWorld; bodyCallback: NewtonOnBodyDeserializationCallback; const bodyUserData: Pointer; serializeCallback: NewtonDeserializeCallback; const serializeHandle: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonFindSerializedBody(const newtonWorld: PNewtonWorld; bodySerializedID: Integer): pNewtonBody; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetJointSerializationCallbacks(const newtonWorld: PNewtonWorld; serializeJoint: NewtonOnJointSerializationCallback; deserializeJoint: NewtonOnJointDeserializationCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonGetJointSerializationCallbacks(const newtonWorld: PNewtonWorld; const serializeJoint: NewtonOnJointSerializationCallback; const deserializeJoint: NewtonOnJointDeserializationCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldCriticalSectionLock(const newtonWorld: PNewtonWorld; threadIndex: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldCriticalSectionUnlock(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetThreadsCount(const newtonWorld: PNewtonWorld; threads: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonGetThreadsCount(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonGetMaxThreadsCount(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonDispachThreadJob(const newtonWorld: PNewtonWorld; task: NewtonJobTask; const usedData: Pointer; const functionName: pchar); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSyncThreadJobs(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

function NewtonAtomicAdd(const ptr: Pinteger; value: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonAtomicSwap(const ptr: Pinteger; value: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonYield(); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetIslandUpdateEvent(const newtonWorld: PNewtonWorld; islandUpdate: NewtonIslandUpdate); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldForEachJointDo(const newtonWorld: PNewtonWorld; callback: NewtonJointIterator; const userData: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldForEachBodyInAABBDo(const newtonWorld: PNewtonWorld; const p0: pfloat; const p1: pfloat; callback: NewtonBodyIterator; const userData: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldSetUserData(const newtonWorld: PNewtonWorld; const userData: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetUserData(const newtonWorld: PNewtonWorld): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldAddListener(const newtonWorld: PNewtonWorld; const nameId: pchar; const listenerUserData: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetListener(const newtonWorld: PNewtonWorld; const nameId: pchar): Pointer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldListenerSetDebugCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldListenerDebugCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldListenerSetPostStepCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldUpdateListenerCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldListenerSetPreUpdateCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldUpdateListenerCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldListenerSetPostUpdateCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldUpdateListenerCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldListenerSetDestructorCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldDestroyListenerCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldListenerSetBodyDestroyCallback(const newtonWorld: PNewtonWorld; const listener: Pointer; callback: NewtonWorldListenerBodyDestroyCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldListenerDebug(const newtonWorld: PNewtonWorld; const context: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetListenerUserData(const newtonWorld: PNewtonWorld; const listener: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldListenerGetBodyDestroyCallback(const newtonWorld: PNewtonWorld; const listener: Pointer): PNewtonWorldListenerBodyDestroyCallback; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldSetDestructorCallback(const newtonWorld: PNewtonWorld; destructorparam: NewtonWorldDestructorCallback); cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetDestructorCallback(const newtonWorld: PNewtonWorld): PNewtonWorldDestructorCallback; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldSetCollisionConstructorDestructorCallback(const newtonWorld: PNewtonWorld; constructorparam: NewtonCollisionCopyConstructionCallback; destructorparam: NewtonCollisionDestructorCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldSetCreateDestroyContactCallback(const newtonWorld: PNewtonWorld; createContact: NewtonCreateContactCallback; destroyContact: NewtonDestroyContactCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonWorldRayCast(const newtonWorld: PNewtonWorld; const p0: pfloat; const p1: pfloat; filter: NewtonWorldRayFilterCallback; const userData: Pointer; prefilter: NewtonWorldRayPrefilterCallback; threadIndex: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldConvexCast(const newtonWorld: PNewtonWorld; const matrix: pfloat; const target: pfloat; const shape: PNewtonCollision; const param: pfloat; const userData: Pointer; prefilter: NewtonWorldRayPrefilterCallback; const info: PNewtonWorldConvexCastReturnInfo; maxContactsCount: Integer; threadIndex: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldCollide(const newtonWorld: PNewtonWorld; const matrix: pfloat; const shape: PNewtonCollision; const userData: Pointer; prefilter: NewtonWorldRayPrefilterCallback; const info: PNewtonWorldConvexCastReturnInfo; maxContactsCount: Integer; threadIndex: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetBodyCount(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

world utility functions

function NewtonWorldGetConstraintCount(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldFindJoint(const body0: pNewtonBody; const body1: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

This item has no description.

function NewtonIslandGetBody(const island: Pointer; bodyIndex: Integer): pNewtonBody; cdecl; external NEWTON_API;

**********************************************************************************************

Simulation islands

**********************************************************************************************

procedure NewtonIslandGetBodyAABB(const island: Pointer; bodyIndex: Integer; const p0: pfloat; const p1: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialCreateGroupID(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

**********************************************************************************************

Physics Material Section

**********************************************************************************************

function NewtonMaterialGetDefaultGroupID(const newtonWorld: PNewtonWorld): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialDestroyAllGroupID(const newtonWorld: PNewtonWorld); cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetUserData(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer): Pointer; cdecl; external NEWTON_API;

material definitions that can not be overwritten in function callback

procedure NewtonMaterialSetSurfaceThickness(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; thickness: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetCallbackUserData(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; const userData: Pointer); cdecl; external NEWTON_API;

deprecated, not longer continue collision is set on the material NEWTON_API void NewtonMaterialSetContinuousCollisionMode (const NewtonWorld* const newtonWorld, int id0, int id1, int state);

procedure NewtonMaterialSetContactGenerationCallback(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; contactGeneration: NewtonOnContactGeneration); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetCompoundCollisionCallback(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; compoundAabbOverlap: NewtonOnCompoundSubCollisionAABBOverlap); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetCollisionCallback(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; aabbOverlap: NewtonOnAABBOverlap; process: NewtonContactsProcess); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetDefaultSoftness(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; value: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetDefaultElasticity(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; elasticCoef: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetDefaultCollidable(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; state: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetDefaultFriction(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer; staticFriction: dfloat; kineticFriction: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialJointResetIntraJointCollision(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialJointResetSelftJointCollision(const newtonWorld: PNewtonWorld; id0: Integer; id1: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetFirstMaterial(const newtonWorld: PNewtonWorld): PNewtonMaterial; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetNextMaterial(const newtonWorld: PNewtonWorld; const material: PNewtonMaterial): PNewtonMaterial; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetFirstBody(const newtonWorld: PNewtonWorld): pNewtonBody; cdecl; external NEWTON_API;

This item has no description.

function NewtonWorldGetNextBody(const newtonWorld: PNewtonWorld; const curBody: pNewtonBody): pNewtonBody; cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetMaterialPairUserData(const material: PNewtonMaterial): Pointer; cdecl; external NEWTON_API;

**********************************************************************************************

Physics Contact control functions

**********************************************************************************************

function NewtonMaterialGetContactFaceAttribute(const material: PNewtonMaterial): LongWord; cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetBodyCollidingShape(const material: PNewtonMaterial; const body: pNewtonBody): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetContactNormalSpeed(const material: PNewtonMaterial): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialGetContactForce(const material: PNewtonMaterial; const body: pNewtonBody; const force: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialGetContactPositionAndNormal(const material: PNewtonMaterial; const body: pNewtonBody; const posit: pfloat; const normal: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialGetContactTangentDirections(const material: PNewtonMaterial; const body: pNewtonBody; const dir0: pfloat; const dir1: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetContactTangentSpeed(const material: PNewtonMaterial; index: Integer): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetContactMaxNormalImpact(const material: PNewtonMaterial): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetContactMaxTangentImpact(const material: PNewtonMaterial; index: Integer): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetContactPenetration(const material: PNewtonMaterial): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetAsSoftContact(const material: PNewtonMaterial; relaxation: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactSoftness(const material: PNewtonMaterial; softness: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactThickness(const material: PNewtonMaterial; thickness: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactElasticity(const material: PNewtonMaterial; restitution: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactFrictionState(const material: PNewtonMaterial; state: Integer; index: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactFrictionCoef(const material: PNewtonMaterial; staticFrictionCoef: dfloat; kineticFrictionCoef: dfloat; index: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactNormalAcceleration(const material: PNewtonMaterial; accel: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactNormalDirection(const material: PNewtonMaterial; const directionVector: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactPosition(const material: PNewtonMaterial; const position: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactTangentFriction(const material: PNewtonMaterial; friction: dfloat; index: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactTangentAcceleration(const material: PNewtonMaterial; accel: dfloat; index: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialContactRotateTangentDirections(const material: PNewtonMaterial; const directionVector: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonMaterialGetContactPruningTolerance(const contactJoint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMaterialSetContactPruningTolerance(const contactJoint: PNewtonJoint; tolerance: dfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateNull(const newtonWorld: PNewtonWorld): PNewtonCollision; cdecl; external NEWTON_API;

**********************************************************************************************

convex collision primitives creation functions

**********************************************************************************************

function NewtonCreateSphere(const newtonWorld: PNewtonWorld; radius: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateBox(const newtonWorld: PNewtonWorld; dx: dfloat; dy: dfloat; dz: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateCone(const newtonWorld: PNewtonWorld; radius: dfloat; height: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateCapsule(const newtonWorld: PNewtonWorld; radius0: dfloat; radius1: dfloat; height: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateCylinder(const newtonWorld: PNewtonWorld; radio0: dfloat; radio1: dfloat; height: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateChamferCylinder(const newtonWorld: PNewtonWorld; radius: dfloat; height: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateConvexHull(const newtonWorld: PNewtonWorld; count: Integer; const vertexCloud: pfloat; strideInBytes: Integer; tolerance: dfloat; shapeID: Integer; const offsetMatrix: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateConvexHullFromMesh(const newtonWorld: PNewtonWorld; const mesh: PNewtonMesh; tolerance: dfloat; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionGetMode(const convexCollision: PNewtonCollision): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionSetMode(const convexCollision: PNewtonCollision; mode: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonConvexHullGetFaceIndices(const convexHullCollision: PNewtonCollision; face: Integer; const faceIndices: Pinteger): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonConvexHullGetVertexData(const convexHullCollision: PNewtonCollision; const vertexData: Pfloat; strideInBytes: Pinteger): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonConvexCollisionCalculateVolume(const convexCollision: PNewtonCollision): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonConvexCollisionCalculateInertialMatrix(const convexCollision: PNewtonCollision; const inertia: pfloat; const origin: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonConvexCollisionCalculateBuoyancyVolume(const convexCollision: PNewtonCollision; const matrix: pfloat; const fluidPlane: pfloat; const centerOfBuoyancy: pfloat): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionDataPointer(const convexCollision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateCompoundCollision(const newtonWorld: PNewtonWorld; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

**********************************************************************************************

compound collision primitives creation functions

**********************************************************************************************

function NewtonCreateCompoundCollisionFromMesh(const newtonWorld: PNewtonWorld; const mesh: PNewtonMesh; hullTolerance: dfloat; shapeID: Integer; subShapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCompoundCollisionBeginAddRemove(const compoundCollision: PNewtonCollision); cdecl; external NEWTON_API;

This item has no description.

function NewtonCompoundCollisionAddSubCollision(const compoundCollision: PNewtonCollision; const convexCollision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCompoundCollisionRemoveSubCollision(const compoundCollision: PNewtonCollision; const collisionNode: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCompoundCollisionRemoveSubCollisionByIndex(const compoundCollision: PNewtonCollision; nodeIndex: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCompoundCollisionSetSubCollisionMatrix(const compoundCollision: PNewtonCollision; const collisionNode: Pointer; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCompoundCollisionEndAddRemove(const compoundCollision: PNewtonCollision); cdecl; external NEWTON_API;

This item has no description.

function NewtonCompoundCollisionGetFirstNode(const compoundCollision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCompoundCollisionGetNextNode(const compoundCollision: PNewtonCollision; const collisionNode: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCompoundCollisionGetNodeByIndex(const compoundCollision: PNewtonCollision; index: Integer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCompoundCollisionGetNodeIndex(const compoundCollision: PNewtonCollision; const collisionNode: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCompoundCollisionGetCollisionFromNode(const compoundCollision: PNewtonCollision; const collisionNode: Pointer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateFracturedCompoundCollision(const newtonWorld: PNewtonWorld; const solidMesh: PNewtonMesh; shapeID: Integer; fracturePhysicsMaterialID: Integer; pointcloudCount: Integer; const vertexCloud: pfloat; strideInBytes: Integer; materialID: Integer; const textureMatrix: pfloat; regenerateMainMeshCallback: NewtonFractureCompoundCollisionReconstructMainMeshCallBack; emitFracturedCompound: NewtonFractureCompoundCollisionOnEmitCompoundFractured; emitFracfuredChunk: NewtonFractureCompoundCollisionOnEmitChunk): PNewtonCollision; cdecl; external NEWTON_API;

**********************************************************************************************

Fractured compound collision primitives interface

**********************************************************************************************

function NewtonFracturedCompoundPlaneClip(const fracturedCompound: PNewtonCollision; const plane: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonFracturedCompoundSetCallbacks(const fracturedCompound: PNewtonCollision; regenerateMainMeshCallback: NewtonFractureCompoundCollisionReconstructMainMeshCallBack; emitFracturedCompound: NewtonFractureCompoundCollisionOnEmitCompoundFractured; emitFracfuredChunk: NewtonFractureCompoundCollisionOnEmitChunk); cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundIsNodeFreeToDetach(const fracturedCompound: PNewtonCollision; const collisionNode: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundNeighborNodeList(const fracturedCompound: PNewtonCollision; const collisionNode: Pointer; const list: PPointer; maxCount: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundGetMainMesh(const fracturedCompound: PNewtonCollision): PNewtonFracturedCompoundMeshPart; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundGetFirstSubMesh(const fracturedCompound: PNewtonCollision): PNewtonFracturedCompoundMeshPart; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundGetNextSubMesh(const fracturedCompound: PNewtonCollision; const subMesh: PNewtonFracturedCompoundMeshPart): PNewtonFracturedCompoundMeshPart; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundCollisionGetVertexCount(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundCollisionGetVertexPositions(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart): pfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundCollisionGetVertexNormals(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart): pfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundCollisionGetVertexUVs(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart): pfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundMeshPartGetIndexStream(const fracturedCompound: PNewtonCollision; const meshOwner: PNewtonFracturedCompoundMeshPart; const segment: Pointer; const index: Pinteger): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundMeshPartGetFirstSegment(const fractureCompoundMeshPart: PNewtonFracturedCompoundMeshPart): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundMeshPartGetNextSegment(const fractureCompoundMeshSegment: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundMeshPartGetMaterial(const fractureCompoundMeshSegment: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonFracturedCompoundMeshPartGetIndexCount(const fractureCompoundMeshSegment: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateSceneCollision(const newtonWorld: PNewtonWorld; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

**********************************************************************************************

scene collision are static compound collision that can take polygonal static collisions

**********************************************************************************************

procedure NewtonSceneCollisionBeginAddRemove(const sceneCollision: PNewtonCollision); cdecl; external NEWTON_API;

This item has no description.

function NewtonSceneCollisionAddSubCollision(const sceneCollision: PNewtonCollision; const collision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSceneCollisionRemoveSubCollision(const compoundCollision: PNewtonCollision; const collisionNode: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSceneCollisionRemoveSubCollisionByIndex(const sceneCollision: PNewtonCollision; nodeIndex: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSceneCollisionSetSubCollisionMatrix(const sceneCollision: PNewtonCollision; const collisionNode: Pointer; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSceneCollisionEndAddRemove(const sceneCollision: PNewtonCollision); cdecl; external NEWTON_API;

This item has no description.

function NewtonSceneCollisionGetFirstNode(const sceneCollision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonSceneCollisionGetNextNode(const sceneCollision: PNewtonCollision; const collisionNode: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonSceneCollisionGetNodeByIndex(const sceneCollision: PNewtonCollision; index: Integer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonSceneCollisionGetNodeIndex(const sceneCollision: PNewtonCollision; const collisionNode: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonSceneCollisionGetCollisionFromNode(const sceneCollision: PNewtonCollision; const collisionNode: Pointer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateUserMeshCollision(const newtonWorld: PNewtonWorld; const minBox: pfloat; const maxBox: pfloat; const userData: Pointer; collideCallback: NewtonUserMeshCollisionCollideCallback; rayHitCallback: NewtonUserMeshCollisionRayHitCallback; destroyCallback: NewtonUserMeshCollisionDestroyCallback; getInfoCallback: NewtonUserMeshCollisionGetCollisionInfo; getLocalAABBCallback: NewtonUserMeshCollisionAABBTest; facesInAABBCallback: NewtonUserMeshCollisionGetFacesInAABB; serializeCallback: NewtonOnUserCollisionSerializationCallback; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

***********************************************************************************************************

User Static mesh collision interface

***********************************************************************************************************

function NewtonUserMeshCollisionContinuousOverlapTest(const collideDescData: PNewtonUserMeshCollisionCollideDesc; const continueCollisionHandle: Pointer; const minAabb: pfloat; const maxAabb: pfloat): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateCollisionFromSerialization(const newtonWorld: PNewtonWorld; deserializeFunction: NewtonDeserializeCallback; const serializeHandle: Pointer): PNewtonCollision; cdecl; external NEWTON_API;

***********************************************************************************************************

Collision serialization functions

***********************************************************************************************************

procedure NewtonCollisionSerialize(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; serializeFunction: NewtonSerializeCallback; const serializeHandle: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionGetInfo(const collision: PNewtonCollision; const collisionInfo: PNewtonCollisionInfoRecord); cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateHeightFieldCollision(const newtonWorld: PNewtonWorld; width: Integer; height: Integer; gridsDiagonals: Integer; elevationdatType: Integer; const elevationMap: Pointer; const attributeMap: pchar; verticalScale: dfloat; horizontalScale_x: dfloat; horizontalScale_z: dfloat; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

**********************************************************************************************

Static collision shapes functions

**********************************************************************************************

procedure NewtonHeightFieldSetUserRayCastCallback(const heightfieldCollision: PNewtonCollision; rayHitCallback: NewtonHeightFieldRayCastCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonHeightFieldSetHorizontalDisplacement(heightfieldCollision : PNewtonCollision; horizontalMap : Pword; scale : dFloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateTreeCollision(const newtonWorld: PNewtonWorld; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateTreeCollisionFromMesh(const newtonWorld: PNewtonWorld; const mesh: PNewtonMesh; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonTreeCollisionSetUserRayCastCallback(const treeCollision: PNewtonCollision; rayHitCallback: NewtonCollisionTreeRayCastCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonTreeCollisionBeginBuild(const treeCollision: PNewtonCollision); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonTreeCollisionAddFace(const treeCollision: PNewtonCollision; vertexCount: Integer; const vertexPtr: pfloat; strideInBytes: Integer; faceAttribute: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonTreeCollisionEndBuild(const treeCollision: PNewtonCollision; optimize: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonTreeCollisionGetFaceAttribute(const treeCollision: PNewtonCollision; const faceIndexArray: Pinteger; indexCount: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonTreeCollisionSetFaceAttribute(const treeCollision: PNewtonCollision; const faceIndexArray: Pinteger; indexCount: Integer; attribute: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonTreeCollisionForEachFace(const treeCollision: PNewtonCollision; forEachFaceCallback: NewtonTreeCollisionFaceCallback; const context: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonTreeCollisionGetVertexListTriangleListInAABB(const treeCollision: PNewtonCollision; const p0: pfloat; const p1: pfloat; const vertexArray: Pfloat; const vertexCount: Pinteger; const vertexStrideInBytes: Pinteger; const indexList: Pinteger; maxIndexCount: Integer; const faceAttribute: Pinteger): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonStaticCollisionSetDebugCallback(const staticCollision: PNewtonCollision; userCallback: NewtonTreeCollisionCallback); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionCreateInstance(const collision: PNewtonCollision): PNewtonCollision; cdecl; external NEWTON_API;

**********************************************************************************************

General purpose collision library functions

**********************************************************************************************

function NewtonCollisionGetType(const collision: PNewtonCollision): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionIsConvexShape(const collision: PNewtonCollision): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionIsStaticShape(const collision: PNewtonCollision): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionSetUserData(const collision: PNewtonCollision; const userData: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionGetUserData(const collision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionSetUserID(const collision: PNewtonCollision; id: int64); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionGetUserID(const collision: PNewtonCollision): int64; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionGetMaterial(const collision: PNewtonCollision; const userData: PNewtonCollisionMaterial); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionSetMaterial(const collision: PNewtonCollision; const userData: PNewtonCollisionMaterial); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionGetSubCollisionHandle(const collision: PNewtonCollision): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionGetParentInstance(const collision: PNewtonCollision): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionSetMatrix(const collision: PNewtonCollision; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionGetMatrix(const collision: PNewtonCollision; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionSetScale(const collision: PNewtonCollision; scaleX: dfloat; scaleY: dfloat; scaleZ: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionGetScale(const collision: PNewtonCollision; const scaleX: pfloat; const scaleY: pfloat; const scaleZ: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonDestroyCollision(const collision: PNewtonCollision); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionGetSkinThickness(const collision: PNewtonCollision): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionSetSkinThickness(const collision: PNewtonCollision; thickness: dfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionIntersectionTest(const newtonWorld: PNewtonWorld; const collisionA: PNewtonCollision; const matrixA: pfloat; const collisionB: PNewtonCollision; const matrixB: pfloat; threadIndex: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionPointDistance(const newtonWorld: PNewtonWorld; const point: pfloat; const collision: PNewtonCollision; const matrix: pfloat; const contact: pfloat; const normal: pfloat; threadIndex: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionClosestPoint(const newtonWorld: PNewtonWorld; const collisionA: PNewtonCollision; const matrixA: pfloat; const collisionB: PNewtonCollision; const matrixB: pfloat; const contactA: pfloat; const contactB: pfloat; const normalAB: pfloat; threadIndex: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionCollide(const newtonWorld: PNewtonWorld; maxSize: Integer; const collisionA: PNewtonCollision; const matrixA: pfloat; const collisionB: PNewtonCollision; const matrixB: pfloat; const contacts: pfloat; const normals: pfloat; const penetration: pfloat; const attributeA: Pint64; const attributeB: Pint64; threadIndex: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionCollideContinue(const newtonWorld: PNewtonWorld; maxSize: Integer; timestep: dfloat; const collisionA: PNewtonCollision; const matrixA: pfloat; const velocA: pfloat; const omegaA: pfloat; const collisionB: PNewtonCollision; const matrixB: pfloat; const velocB: pfloat; const omegaB: pfloat; const timeOfImpact: pfloat; const contacts: pfloat; const normals: pfloat; const penetration: pfloat; const attributeA: Pint64; const attributeB: Pint64; threadIndex: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionSupportVertex(const collision: PNewtonCollision; const dir: pfloat; const vertex: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionRayCast(const collision: PNewtonCollision; const p0: pfloat; const p1: pfloat; const normal: pfloat; const attribute: Pint64): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionCalculateAABB(const collision: PNewtonCollision; const matrix: pfloat; const p0: pfloat; const p1: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionForEachPolygonDo(const collision: PNewtonCollision; const matrix: pfloat; callback: NewtonCollisionIterator; const userData: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionAggregateCreate(const world: PNewtonWorld): Pointer; cdecl; external NEWTON_API;

**********************************************************************************************

collision aggregates, are a collision node on eh broad phase the serve as the root nod for a collection of rigid bodies that shared the property of being in close proximity all the time, they are similar to compound collision by the group bodies instead of collision instances These are good for speeding calculation calculation of rag doll, Vehicles or contractions of rigid bodied lined by joints. also for example if you know that many the life time of a group of bodies like the object on a house of a building will be localize to the confide of the building then warping the bodies under an aggregate will reduce collision calculation of almost an order of magnitude.

**********************************************************************************************

procedure NewtonCollisionAggregateDestroy(const aggregate: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionAggregateAddBody(const aggregate: Pointer; const body: pNewtonBody); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionAggregateRemoveBody(const aggregate: Pointer; const body: pNewtonBody); cdecl; external NEWTON_API;

This item has no description.

function NewtonCollisionAggregateGetSelfCollision(const aggregate: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCollisionAggregateSetSelfCollision(const aggregate: Pointer; state: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSetEulerAngle(const eulersAngles: pfloat; const matrix: pfloat); cdecl; external NEWTON_API;

transforms utility functions

procedure NewtonGetEulerAngle(const matrix: pfloat; const eulersAngles0: pfloat; const eulersAngles1: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonCalculateSpringDamperAcceleration(dt: dfloat; ks: dfloat; x: dfloat; kd: dfloat; s: dfloat): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateDynamicBody(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; const matrix: pfloat): pNewtonBody; cdecl; external NEWTON_API;

body manipulation functions

function NewtonCreateKinematicBody(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; const matrix: pfloat): pNewtonBody; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateAsymetricDynamicBody(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; const matrix: pfloat): pNewtonBody; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonDestroyBody(const body: pNewtonBody); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetSimulationState(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetSimulationState(const bodyPtr: pNewtonBody; const state: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetType(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetCollidable(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetCollidable(const body: pNewtonBody; collidableState: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyAddForce(const body: pNewtonBody; const force: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyAddTorque(const body: pNewtonBody; const torque: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyCalculateInverseDynamicsForce(body : PNewtonBody; timestep : dFloat; desiredVeloc : PdFloat; forceOut : PdFloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetCentreOfMass(const body: pNewtonBody; const com: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetMassMatrix(const body: pNewtonBody; mass: dfloat; Ixx: dfloat; Iyy: dfloat; Izz: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetFullMassMatrix(const body: pNewtonBody; mass: dfloat; const inertiaMatrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetMassProperties(const body: pNewtonBody; mass: dfloat; const collision: PNewtonCollision); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetMatrix(const body: pNewtonBody; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetMatrixNoSleep(const body: pNewtonBody; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetMatrixRecursive(const body: pNewtonBody; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetMaterialGroupID(const body: pNewtonBody; id: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetContinuousCollisionMode(const body: pNewtonBody; state: LongWord); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetJointRecursiveCollision(const body: pNewtonBody; state: LongWord); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetOmega(const body: pNewtonBody; const omega: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetOmegaNoSleep(const body: pNewtonBody; const omega: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetVelocity(const body: pNewtonBody; const velocity: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetVelocityNoSleep(const body: pNewtonBody; const velocity: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetForce(const body: pNewtonBody; const force: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetTorque(const body: pNewtonBody; const torque: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetLinearDamping(const body: pNewtonBody; linearDamp: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetAngularDamping(const body: pNewtonBody; const angularDamp: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetCollision(const body: pNewtonBody; const collision: PNewtonCollision); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetCollisionScale(const body: pNewtonBody; scaleX: dfloat; scaleY: dfloat; scaleZ: dfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetSleepState(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetSleepState(const body: pNewtonBody; state: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetAutoSleep(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetAutoSleep(const body: pNewtonBody; state: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetFreezeState(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetFreezeState(const body: pNewtonBody; state: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetGyroscopicTorque(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetGyroscopicTorque(const body: pNewtonBody; state: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetDestructorCallback(const body: pNewtonBody; callback: NewtonBodyDestructor); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetDestructorCallback(const body: pNewtonBody): PNewtonBodyDestructor; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetTransformCallback(const body: pNewtonBody; callback: NewtonSetTransform); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetTransformCallback(const body: pNewtonBody): PNewtonSetTransform; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetForceAndTorqueCallback(const body: pNewtonBody; callback: NewtonApplyForceAndTorque); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetForceAndTorqueCallback(const body: pNewtonBody): PNewtonApplyForceAndTorque; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetID(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodySetUserData(const body: pNewtonBody; const userData: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetUserData(const body: pNewtonBody): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetWorld(const body: pNewtonBody): PNewtonWorld; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetCollision(const body: pNewtonBody): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetMaterialGroupID(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetSerializedID(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetContinuousCollisionMode(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetJointRecursiveCollision(const body: pNewtonBody): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetPosition(const body: pNewtonBody; const pos: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetMatrix(const body: pNewtonBody; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetRotation(const body: pNewtonBody; const rotation: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetMass(const body: pNewtonBody; mass: pfloat; const Ixx: pfloat; const Iyy: pfloat; const Izz: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetInvMass(const body: pNewtonBody; const invMass: pfloat; const invIxx: pfloat; const invIyy: pfloat; const invIzz: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetInertiaMatrix(const body: pNewtonBody; const inertiaMatrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetInvInertiaMatrix(const body: pNewtonBody; const invInertiaMatrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetOmega(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetVelocity(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetAlpha(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetAcceleration(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetForce(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetTorque(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetCentreOfMass(const body: pNewtonBody; const com: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetPointVelocity(const body: pNewtonBody; const point: pfloat; const velocOut: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyApplyImpulsePair(const body: pNewtonBody; const linearImpulse: pfloat; const angularImpulse: pfloat; timestep: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyAddImpulse(const body: pNewtonBody; const pointDeltaVeloc: pfloat; const pointPosit: pfloat; timestep: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyApplyImpulseArray(const body: pNewtonBody; impuleCount: Integer; strideInByte: Integer; const impulseArray: pfloat; const pointArray: pfloat; timestep: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyIntegrateVelocity(const body: pNewtonBody; timestep: dfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetLinearDamping(const body: pNewtonBody): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetAngularDamping(const body: pNewtonBody; const vector: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBodyGetAABB(const body: pNewtonBody; const p0: pfloat; const p1: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetFirstJoint(const body: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetNextJoint(const body: pNewtonBody; const joint: PNewtonJoint): PNewtonJoint; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetFirstContactJoint(const body: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyGetNextContactJoint(const body: pNewtonBody; const contactJoint: PNewtonJoint): PNewtonJoint; cdecl; external NEWTON_API;

This item has no description.

function NewtonBodyFindContact(const body0: pNewtonBody; const body1: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

This item has no description.

function NewtonContactJointGetFirstContact(const contactJoint: PNewtonJoint): Pointer; cdecl; external NEWTON_API;

**********************************************************************************************

contact joints interface

**********************************************************************************************

function NewtonContactJointGetNextContact(const contactJoint: PNewtonJoint; const contact: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonContactJointGetContactCount(const contactJoint: PNewtonJoint): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonContactJointRemoveContact(const contactJoint: PNewtonJoint; const contact: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonContactJointGetClosestDistance(const contactJoint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonContactJointResetSelftJointCollision(const contactJoint: PNewtonJoint); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonContactJointResetIntraJointCollision(const contactJoint: PNewtonJoint); cdecl; external NEWTON_API;

This item has no description.

function NewtonContactGetMaterial(const contact: Pointer): PNewtonMaterial; cdecl; external NEWTON_API;

This item has no description.

function NewtonContactGetCollision0(const contact: Pointer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonContactGetCollision1(const contact: Pointer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonContactGetCollisionID0(const contact: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonContactGetCollisionID1(const contact: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonJointGetUserData(const joint: PNewtonJoint): Pointer; cdecl; external NEWTON_API;

**********************************************************************************************

Common joint functions

**********************************************************************************************

procedure NewtonJointSetUserData(const joint: PNewtonJoint; const userData: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonJointGetBody0(const joint: PNewtonJoint): pNewtonBody; cdecl; external NEWTON_API;

This item has no description.

function NewtonJointGetBody1(const joint: PNewtonJoint): pNewtonBody; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonJointGetInfo(const joint: PNewtonJoint; const info: PNewtonJointRecord); cdecl; external NEWTON_API;

This item has no description.

function NewtonJointGetCollisionState(const joint: PNewtonJoint): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonJointSetCollisionState(const joint: PNewtonJoint; state: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonJointGetStiffness(const joint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonJointSetStiffness(const joint: PNewtonJoint; state: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonDestroyJoint(const newtonWorld: PNewtonWorld; const joint: PNewtonJoint); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonJointSetDestructor(const joint: PNewtonJoint; destructorparam: NewtonConstraintDestructor); cdecl; external NEWTON_API;

This item has no description.

function NewtonJointIsActive(const joint: PNewtonJoint): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonCreateMassSpringDamperSystem(const newtonWorld: PNewtonWorld; shapeID: Integer; const points: pfloat; pointCount: Integer; strideInBytes: Integer; const pointMass: pfloat; const links: Pinteger; linksCount: Integer; const linksSpring: pfloat; const linksDamper: pfloat): PNewtonCollision; cdecl; external NEWTON_API;

**********************************************************************************************

particle system interface (soft bodies, individual, pressure bodies and cloth)

**********************************************************************************************

function NewtonCreateDeformableSolid(const newtonWorld: PNewtonWorld; const mesh: PNewtonMesh; shapeID: Integer): PNewtonCollision; cdecl; external NEWTON_API;

This item has no description.

function NewtonDeformableMeshGetParticleCount(const deformableMesh: PNewtonCollision): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonDeformableMeshGetParticleStrideInBytes(const deformableMesh: PNewtonCollision): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonDeformableMeshGetParticleArray(const deformableMesh: PNewtonCollision): pfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonConstraintCreateBall(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

**********************************************************************************************

Ball and Socket joint functions

**********************************************************************************************

procedure NewtonBallSetUserCallback(const ball: PNewtonJoint; callback: NewtonBallCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBallGetJointAngle(const ball: PNewtonJoint; angle: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBallGetJointOmega(const ball: PNewtonJoint; omega: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBallGetJointForce(const ball: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonBallSetConeLimits(const ball: PNewtonJoint; const pin: pfloat; maxConeAngle: dfloat; maxTwistAngle: dfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonConstraintCreateHinge(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const pinDir: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

**********************************************************************************************

Hinge joint functions

**********************************************************************************************

procedure NewtonHingeSetUserCallback(const hinge: PNewtonJoint; callback: NewtonHingeCallback); cdecl; external NEWTON_API;

This item has no description.

function NewtonHingeGetJointAngle(const hinge: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonHingeGetJointOmega(const hinge: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonHingeGetJointForce(const hinge: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonHingeCalculateStopAlpha(const hinge: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: dfloat): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonConstraintCreateSlider(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const pinDir: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

**********************************************************************************************

Slider joint functions

**********************************************************************************************

procedure NewtonSliderSetUserCallback(const slider: PNewtonJoint; callback: NewtonSliderCallback); cdecl; external NEWTON_API;

This item has no description.

function NewtonSliderGetJointPosit(const slider: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonSliderGetJointVeloc(const slider: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonSliderGetJointForce(const slider: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonSliderCalculateStopAccel(const slider: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; position: dfloat): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonConstraintCreateCorkscrew(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const pinDir: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

**********************************************************************************************

Corkscrew joint functions

**********************************************************************************************

procedure NewtonCorkscrewSetUserCallback(const corkscrew: PNewtonJoint; callback: NewtonCorkscrewCallback); cdecl; external NEWTON_API;

This item has no description.

function NewtonCorkscrewGetJointPosit(const corkscrew: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonCorkscrewGetJointAngle(const corkscrew: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonCorkscrewGetJointVeloc(const corkscrew: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonCorkscrewGetJointOmega(const corkscrew: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCorkscrewGetJointForce(const corkscrew: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonCorkscrewCalculateStopAlpha(const corkscrew: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: dfloat): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonCorkscrewCalculateStopAccel(const corkscrew: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; position: dfloat): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonConstraintCreateUniversal(const newtonWorld: PNewtonWorld; const pivotPoint: pfloat; const pinDir0: pfloat; const pinDir1: pfloat; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

**********************************************************************************************

Universal joint functions

**********************************************************************************************

procedure NewtonUniversalSetUserCallback(const universal: PNewtonJoint; callback: NewtonUniversalCallback); cdecl; external NEWTON_API;

This item has no description.

function NewtonUniversalGetJointAngle0(const universal: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonUniversalGetJointAngle1(const universal: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonUniversalGetJointOmega0(const universal: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonUniversalGetJointOmega1(const universal: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUniversalGetJointForce(const universal: PNewtonJoint; const force: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonUniversalCalculateStopAlpha0(const universal: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: dfloat): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonUniversalCalculateStopAlpha1(const universal: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: dfloat): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonConstraintCreateUpVector(const newtonWorld: PNewtonWorld; const pinDir: pfloat; const body: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

**********************************************************************************************

Up vector joint functions

**********************************************************************************************

procedure NewtonUpVectorGetPin(const upVector: PNewtonJoint; pin: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUpVectorSetPin(const upVector: PNewtonJoint; const pin: dfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonConstraintCreateUserJoint(const newtonWorld: PNewtonWorld; maxDOF: Integer; callback: NewtonUserBilateralCallback; const childBody: pNewtonBody; const parentBody: pNewtonBody): PNewtonJoint; cdecl; external NEWTON_API;

**********************************************************************************************

User defined bilateral Joint

**********************************************************************************************

function NewtonUserJointGetSolverModel(const joint: PNewtonJoint): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointSetSolverModel(const joint: PNewtonJoint; model: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointMassScale(const joint: PNewtonJoint; scaleBody0: dfloat; scaleBody1: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointSetFeedbackCollectorCallback(const joint: PNewtonJoint; getFeedback: NewtonUserBilateralCallback); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointAddLinearRow(const joint: PNewtonJoint; const pivot0: pfloat; const pivot1: pfloat; const dir: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointAddAngularRow(const joint: PNewtonJoint; relativeAngle: dfloat; const dir: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointAddGeneralRow(const joint: PNewtonJoint; const jacobian0: pfloat; const jacobian1: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointSetRowMinimumFriction(const joint: PNewtonJoint; friction: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointSetRowMaximumFriction(const joint: PNewtonJoint; friction: dfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonUserJointCalculateRowZeroAcceleration(const joint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonUserJointGetRowAcceleration(const joint: PNewtonJoint): dfloat; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointGetRowJacobian(const joint: PNewtonJoint; const linear0: pfloat; const angula0: pfloat; const linear1: pfloat; const angula1: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointSetRowAcceleration(const joint: PNewtonJoint; acceleration: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointSetRowSpringDamperAcceleration(const joint: PNewtonJoint; rowStiffness: dfloat; spring: dfloat; damper: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointSetRowStiffness(const joint: PNewtonJoint; stiffness: dfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonUserJoinRowsCount(const joint: PNewtonJoint): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonUserJointGetGeneralRow(const joint: PNewtonJoint; index: Integer; const jacobian0: pfloat; const jacobian1: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonUserJointGetRowForce(const joint: PNewtonJoint; row: Integer): dfloat; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreate(const newtonWorld: PNewtonWorld): PNewtonMesh; cdecl; external NEWTON_API;

**********************************************************************************************

Mesh joint functions

**********************************************************************************************

function NewtonMeshCreateFromMesh(const mesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateFromCollision(const collision: PNewtonCollision): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateTetrahedraIsoSurface(const mesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateConvexHull(const newtonWorld: PNewtonWorld; pointCount: Integer; const vertexCloud: pfloat; strideInBytes: Integer; tolerance: dfloat): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateVoronoiConvexDecomposition(const newtonWorld: PNewtonWorld; pointCount: Integer; const vertexCloud: pfloat; strideInBytes: Integer; materialID: Integer; const textureMatrix: pfloat): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateFromSerialization(const newtonWorld: PNewtonWorld; deserializeFunction: NewtonDeserializeCallback; const serializeHandle: Pointer): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshDestroy(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshSerialize(const mesh: PNewtonMesh; serializeFunction: NewtonSerializeCallback; const serializeHandle: Pointer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshSaveOFF(const mesh: PNewtonMesh; const filename: pchar); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshLoadOFF(const newtonWorld: PNewtonWorld; const filename: pchar): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshLoadTetrahedraMesh(const newtonWorld: PNewtonWorld; const filename: pchar): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshFlipWinding(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshApplyTransform(const mesh: PNewtonMesh; const matrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshCalculateOOBB(const mesh: PNewtonMesh; const matrix: pfloat; const x: pfloat; const y: pfloat; const z: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshCalculateVertexNormals(const mesh: PNewtonMesh; angleInRadians: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshApplySphericalMapping(const mesh: PNewtonMesh; material: Integer; const aligmentMatrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshApplyCylindricalMapping(const mesh: PNewtonMesh; cylinderMaterial: Integer; capMaterial: Integer; const aligmentMatrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshApplyBoxMapping(const mesh: PNewtonMesh; frontMaterial: Integer; sideMaterial: Integer; topMaterial: Integer; const aligmentMatrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshApplyAngleBasedMapping(const mesh: PNewtonMesh; material: Integer; reportPrograssCallback: NewtonReportProgress; const reportPrgressUserData: Pointer; const aligmentMatrix: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonCreateTetrahedraLinearBlendSkinWeightsChannel(const tetrahedraMesh: PNewtonMesh; const skinMesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshOptimize(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshOptimizePoints(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshOptimizeVertex(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshIsOpenMesh(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshFixTJoints(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshPolygonize(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshTriangulate(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshUnion(const mesh: PNewtonMesh; const clipper: PNewtonMesh; const clipperMatrix: pfloat): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshDifference(const mesh: PNewtonMesh; const clipper: PNewtonMesh; const clipperMatrix: pfloat): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshIntersection(const mesh: PNewtonMesh; const clipper: PNewtonMesh; const clipperMatrix: pfloat): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshClip(const mesh: PNewtonMesh; const clipper: PNewtonMesh; const clipperMatrix: pfloat; const topMesh: PNewtonMesh; const bottomMesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshConvexMeshIntersection(const mesh: PNewtonMesh; const convexMesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshSimplify(const mesh: PNewtonMesh; maxVertexCount: Integer; reportPrograssCallback: NewtonReportProgress; const reportPrgressUserData: Pointer): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshApproximateConvexDecomposition(const mesh: PNewtonMesh; maxConcavity: dfloat; backFaceDistanceFactor: dfloat; maxCount: Integer; maxVertexPerHull: Integer; reportProgressCallback: NewtonReportProgress; const reportProgressUserData: Pointer): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonRemoveUnusedVertices(const mesh: PNewtonMesh; const vertexRemapTable: Pinteger); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshBeginBuild(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshBeginFace(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshAddPoint(const mesh: PNewtonMesh; x: double; y: double; z: double); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshAddLayer(const mesh: PNewtonMesh; layerIndex: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshAddMaterial(const mesh: PNewtonMesh; materialIndex: Integer); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshAddNormal(const mesh: PNewtonMesh; x: dfloat; y: dfloat; z: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshAddBinormal(const mesh: PNewtonMesh; x: dfloat; y: dfloat; z: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshAddUV0(const mesh: PNewtonMesh; u: dfloat; v: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshAddUV1(const mesh: PNewtonMesh; u: dfloat; v: dfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshAddVertexColor(const mesh: PNewtonMesh; r: Single; g: Single; b: Single; a: Single); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshEndFace(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshEndBuild(const mesh: PNewtonMesh); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshClearVertexFormat(const format: PNewtonMeshVertexFormat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshBuildFromVertexListIndexList(const mesh: PNewtonMesh; const format: PNewtonMeshVertexFormat); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetPointCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetIndexToVertexMap(const mesh: PNewtonMesh): Pinteger; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetVertexWeights(mesh : PNewtonMesh; vertexIndex : Integer; weightIndex : PInteger; weightFactor : PdFloat) : Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetVertexDoubleChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: Pdouble); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetVertexChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetNormalChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetBinormalChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetUV0Channel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetUV1Channel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetVertexColorChannel(const mesh: PNewtonMesh; vertexStrideInByte: Integer; const outBuffer: pfloat); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshHasNormalChannel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshHasBinormalChannel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshHasUV0Channel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshHasUV1Channel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshHasVertexColorChannel(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshBeginHandle(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshEndHandle(const mesh: PNewtonMesh; const handle: Pointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshFirstMaterial(const mesh: PNewtonMesh; const handle: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshNextMaterial(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshMaterialGetMaterial(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshMaterialGetIndexCount(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshMaterialGetIndexStream(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer; const index: Pinteger); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshMaterialGetIndexStreamShort(const mesh: PNewtonMesh; const handle: Pointer; materialId: Integer; const index: SmallInt); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateFirstSingleSegment(const mesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateNextSingleSegment(const mesh: PNewtonMesh; const segment: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateFirstLayer(const mesh: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshCreateNextLayer(const mesh: PNewtonMesh; const segment: PNewtonMesh): PNewtonMesh; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetTotalFaceCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetTotalIndexCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetFaces(const mesh: PNewtonMesh; const faceIndexCount: Pinteger; const faceMaterial: Pinteger; const faceIndices: PPointer); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetVertexCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetVertexStrideInByte(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetVertexArray(const mesh: PNewtonMesh): Pdouble; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetVertexBaseCount(const mesh: PNewtonMesh): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshSetVertexBaseCount(const mesh: PNewtonMesh; baseCount: Integer); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetFirstVertex(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetNextVertex(const mesh: PNewtonMesh; const vertex: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetVertexIndex(const mesh: PNewtonMesh; const vertex: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetFirstPoint(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetNextPoint(const mesh: PNewtonMesh; const point: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetPointIndex(const mesh: PNewtonMesh; const point: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetVertexIndexFromPoint(const mesh: PNewtonMesh; const point: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetFirstEdge(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetNextEdge(const mesh: PNewtonMesh; const edge: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetEdgeIndices(const mesh: PNewtonMesh; const edge: Pointer; const v0: Pinteger; const v1: Pinteger); cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetFirstFace(const mesh: PNewtonMesh): Pointer; cdecl; external NEWTON_API;

NEWTON_API void NewtonMeshGetEdgePointIndices (const NewtonMesh* const mesh, const void* const edge, int* const v0, int* const v1);

function NewtonMeshGetNextFace(const mesh: PNewtonMesh; const face: Pointer): Pointer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshIsFaceOpen(const mesh: PNewtonMesh; const face: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetFaceMaterial(const mesh: PNewtonMesh; const face: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

function NewtonMeshGetFaceIndexCount(const mesh: PNewtonMesh; const face: Pointer): Integer; cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetFaceIndices(const mesh: PNewtonMesh; const face: Pointer; const indices: Pinteger); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshGetFacePointIndices(const mesh: PNewtonMesh; const face: Pointer; const indices: Pinteger); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshCalculateFaceNormal(const mesh: PNewtonMesh; const face: Pointer; const normal: Pdouble); cdecl; external NEWTON_API;

This item has no description.

procedure NewtonMeshSetFaceMaterial(const mesh: PNewtonMesh; const face: Pointer; matId: Integer); cdecl; external NEWTON_API;

This item has no description.

Types

dFloat = Single;

This item has no description.

dFloat64 = Double;

This item has no description.

dLong = Int64;

This item has no description.

Float = Single;

This item has no description.

NewtonAllocMemory = function(sizeInBytes: Integer): Pointer; cdecl;

Newton callback functions

NewtonApplyForceAndTorque = procedure(const body: pNewtonBody; timestep: dfloat; threadIndex: Integer); cdecl;

This item has no description.

NewtonBallCallback = procedure(const ball: PNewtonJoint; timestep: dfloat); cdecl;

This item has no description.

NewtonBodyDestructor = procedure(const body: pNewtonBody); cdecl;

This item has no description.

NewtonBodyIterator = function(const body: pNewtonBody; const userData: Pointer): Integer; cdecl;

This item has no description.

NewtonCollisionCopyConstructionCallback = procedure(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision; const sourceCollision: PNewtonCollision); cdecl;

This item has no description.

NewtonCollisionDestructorCallback = procedure(const newtonWorld: PNewtonWorld; const collision: PNewtonCollision); cdecl;

This item has no description.

NewtonCollisionIterator = procedure(const userData: Pointer; vertexCount: Integer; const faceArray: pfloat; faceId: Integer); cdecl;

This item has no description.

NewtonCollisionTreeRayCastCallback = function(const body: pNewtonBody; const treeCollision: PNewtonCollision; intersection: dfloat; const normal: pfloat; faceId: Integer; const usedData: Pointer): dfloat; cdecl;

This item has no description.

NewtonConstraintDestructor = procedure(const me: PNewtonJoint); cdecl;

This item has no description.

NewtonContactsProcess = procedure(const contact: PNewtonJoint; timestep: dfloat; threadIndex: Integer); cdecl;

This item has no description.

NewtonCorkscrewCallback = function(const corkscrew: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc): LongWord; cdecl;

This item has no description.

NewtonCreateContactCallback = procedure(const newtonWorld: PNewtonWorld; const contact: PNewtonJoint); cdecl;

This item has no description.

NewtonDeserializeCallback = procedure(const serializeHandle: Pointer; const buffer: Pointer; size: Integer); cdecl;

This item has no description.

NewtonDestroyContactCallback = procedure(const newtonWorld: PNewtonWorld; const contact: PNewtonJoint); cdecl;

This item has no description.

NewtonFractureCompoundCollisionOnEmitChunk = procedure(const chunkBody: pNewtonBody; const fracturexChunkMesh: PNewtonFracturedCompoundMeshPart; const fracturedCompountCollision: PNewtonCollision); cdecl;

This item has no description.

NewtonFractureCompoundCollisionOnEmitCompoundFractured = procedure(const fracturedBody: pNewtonBody); cdecl;

This item has no description.

NewtonFractureCompoundCollisionReconstructMainMeshCallBack = procedure(const body: pNewtonBody; const mainMesh: PNewtonFracturedCompoundMeshPart; const fracturedCompountCollision: PNewtonCollision); cdecl;

This item has no description.

NewtonFreeMemory = procedure(const ptr: Pointer; sizeInBytes: Integer); cdecl;

This item has no description.

NewtonGetTimeInMicrosencondsCallback = function(): int64; cdecl;

This item has no description.

NewtonHeightFieldRayCastCallback = function(const body: pNewtonBody; const heightFieldCollision: PNewtonCollision; intersection: dfloat; row: Integer; col: Integer; const normal: pfloat; faceId: Integer; const usedData: Pointer): dfloat; cdecl;

This item has no description.

NewtonHingeCallback = function(const hinge: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc): LongWord; cdecl;

This item has no description.

NewtonIslandUpdate = function(const newtonWorld: PNewtonWorld; const islandHandle: Pointer; bodyCount: Integer): Integer; cdecl;

This item has no description.

NewtonJobTask = procedure(const world: PNewtonWorld; const userData: Pointer; threadIndex: Integer); cdecl;

This item has no description.

NewtonJointIterator = procedure(const joint: PNewtonJoint; const userData: Pointer); cdecl;

This item has no description.

NewtonOnAABBOverlap = function(const contact: PNewtonJoint; timestep: dfloat; threadIndex: Integer): Integer; cdecl;

This item has no description.

NewtonOnBodyDeserializationCallback = procedure(const body: pNewtonBody; const userData: Pointer; functionparam: PNewtonDeserializeCallback; const serializeHandle: Pointer); cdecl;

This item has no description.

NewtonOnBodySerializationCallback = procedure(const body: pNewtonBody; const userData: Pointer; functionparam: PNewtonSerializeCallback; const serializeHandle: Pointer); cdecl;

This item has no description.

NewtonOnCompoundSubCollisionAABBOverlap = function(const contact: PNewtonJoint; timestep: dfloat; const body0: pNewtonBody; const collisionNode0: Pointer; const body1: pNewtonBody; const collisionNode1: Pointer; threadIndex: Integer): Integer; cdecl;

This item has no description.

NewtonOnContactGeneration = function(const material: PNewtonMaterial; const body0: pNewtonBody; const collision0: PNewtonCollision; const body1: pNewtonBody; const collision1: PNewtonCollision; const contactBuffer: PNewtonUserContactPoint; maxCount: Integer; threadIndex: Integer): Integer; cdecl;

This item has no description.

NewtonOnJointDeserializationCallback = procedure(const body0: pNewtonBody; const body1: pNewtonBody; functionparam: PNewtonDeserializeCallback; const serializeHandle: Pointer); cdecl;

This item has no description.

NewtonOnJointSerializationCallback = procedure(const joint: PNewtonJoint; functionparam: PNewtonSerializeCallback; const serializeHandle: Pointer); cdecl;

This item has no description.

NewtonOnUserCollisionSerializationCallback = procedure(const userData: Pointer; functionparam: PNewtonSerializeCallback; const serializeHandle: Pointer); cdecl;

user collision callbacks

NewtonPostUpdateCallback = procedure(const world: PNewtonWorld; timestep: dfloat); cdecl;

This item has no description.

NewtonReportProgress = function(normalizedProgressPercent: dfloat; const userData: Pointer): Integer; cdecl;

This item has no description.

NewtonSerializeCallback = procedure(const serializeHandle: Pointer; const buffer: Pointer; size: Integer); cdecl;

This item has no description.

NewtonSetTransform = procedure(const body: pNewtonBody; const matrix: pfloat; threadIndex: Integer); cdecl;

This item has no description.

NewtonSliderCallback = function(const slider: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc): LongWord; cdecl;

This item has no description.

NewtonTreeCollisionCallback = procedure(const bodyWithTreeCollision: pNewtonBody; const body: pNewtonBody; faceID: Integer; vertexCount: Integer; const vertex: pfloat; vertexStrideInBytes: Integer); cdecl;

This item has no description.

NewtonTreeCollisionFaceCallback = function(const context: Pointer; const polygon: pfloat; strideInBytes: Integer; const indexArray: Pinteger; indexCount: Integer): Integer; cdecl;

This item has no description.

NewtonUniversalCallback = function(const universal: PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc): LongWord; cdecl;

This item has no description.

NewtonUserBilateralCallback = procedure(const userJoint: PNewtonJoint; timestep: dfloat; threadIndex: Integer); cdecl;

This item has no description.

NewtonUserBilateralGetInfoCallback = procedure(const userJoint: PNewtonJoint; const info: PNewtonJointRecord); cdecl;

This item has no description.

NewtonUserMeshCollisionAABBTest = function(const userData: Pointer; const boxP0: pfloat; const boxP1: pfloat): Integer; cdecl;

This item has no description.

NewtonUserMeshCollisionCollideCallback = procedure(const collideDescData: PNewtonUserMeshCollisionCollideDesc; const continueCollisionHandle: Pointer); cdecl;

This item has no description.

NewtonUserMeshCollisionDestroyCallback = procedure(const userData: Pointer); cdecl;

This item has no description.

NewtonUserMeshCollisionGetCollisionInfo = procedure(const userData: Pointer; const infoRecord: PNewtonCollisionInfoRecord); cdecl;

This item has no description.

NewtonUserMeshCollisionGetFacesInAABB = function(const userData: Pointer; const p0: pfloat; const p1: pfloat; const vertexArray: Pfloat; const vertexCount: Pinteger; const vertexStrideInBytes: Pinteger; const indexList: Pinteger; maxIndexCount: Integer; const userDataList: Pinteger): Integer; cdecl;

This item has no description.

NewtonUserMeshCollisionRayHitCallback = function(const lineDescData: PNewtonUserMeshCollisionRayHitDesc): dfloat; cdecl;

This item has no description.

NewtonWorldDestroyListenerCallback = procedure(const world: PNewtonWorld; const listenerUserData: Pointer); cdecl;

This item has no description.

NewtonWorldDestructorCallback = procedure(const world: PNewtonWorld); cdecl;

This item has no description.

NewtonWorldListenerBodyDestroyCallback = procedure(const world: PNewtonWorld; const listenerUserData: Pointer; const body: pNewtonBody); cdecl;

This item has no description.

NewtonWorldListenerDebugCallback = procedure(const world: PNewtonWorld; const listener: Pointer; const debugContext: Pointer); cdecl;

This item has no description.

NewtonWorldRayFilterCallback = function(const body: pNewtonBody; const shapeHit: PNewtonCollision; const hitContact: pfloat; const hitNormal: pfloat; collisionID: int64; const userData: Pointer; intersectParam: dfloat): dfloat; cdecl;

This item has no description.

NewtonWorldRayPrefilterCallback = function(const body: pNewtonBody; const collision: PNewtonCollision; const userData: Pointer): LongWord; cdecl;

This item has no description.

NewtonWorldUpdateListenerCallback = procedure(const world: PNewtonWorld; const listenerUserData: Pointer; timestep: dfloat); cdecl;

This item has no description.

PdFloat = ˆdFloat;

This item has no description.

PdFloat64 = ˆdFloat64;

This item has no description.

PdLong = ˆdLong;

This item has no description.

PFloat = ˆFloat;

This item has no description.

PInteger = ˆInteger;

This item has no description.

PNewtonAcyclicArticulation = ˆPointer;

This item has no description.

PNewtonAllocMemory = ˆNewtonAllocMemory;

This item has no description.

PNewtonApplyForceAndTorque = ˆNewtonApplyForceAndTorque;

This item has no description.

PNewtonBallCallback = ˆNewtonBallCallback;

This item has no description.

PNewtonBody = ˆPointer;

This item has no description.

PNewtonBodyDestructor = ˆNewtonBodyDestructor;

This item has no description.

PNewtonBodyIterator = ˆNewtonBodyIterator;

This item has no description.

PNewtonBoxParam = ˆTNewtonBoxParam;

This item has no description.

PNewtonCapsuleParam = ˆTNewtonCapsuleParam;

This item has no description.

PNewtonChamferCylinderParam = ˆTNewtonChamferCylinderParam;

This item has no description.

PNewtonCollision = ˆPointer;

This item has no description.

PNewtonCollisionCopyConstructionCallback = ˆNewtonCollisionCopyConstructionCallback;

This item has no description.

PNewtonCollisionDestructorCallback = ˆNewtonCollisionDestructorCallback;

This item has no description.

PNewtonCollisionInfoRecord = ˆTNewtonCollisionInfoRecord;

This item has no description.

PNewtonCollisionIterator = ˆNewtonCollisionIterator;

This item has no description.

PNewtonCollisionMaterial = ˆTNewtonCollisionMaterial;

This item has no description.

PNewtonCollisionTreeParam = ˆTNewtonCollisionTreeParam;

This item has no description.

PNewtonCollisionTreeRayCastCallback = ˆNewtonCollisionTreeRayCastCallback;

This item has no description.

PNewtonCompoundCollisionParam = ˆTNewtonCompoundCollisionParam;

This item has no description.

PNewtonConeParam = ˆTNewtonConeParam;

This item has no description.

PNewtonConstraintDestructor = ˆNewtonConstraintDestructor;

This item has no description.

PNewtonContactsProcess = ˆNewtonContactsProcess;

This item has no description.

PNewtonConvexHullParam = ˆTNewtonConvexHullParam;

This item has no description.

PNewtonCorkscrewCallback = ˆNewtonCorkscrewCallback;

This item has no description.

PNewtonCreateContactCallback = ˆNewtonCreateContactCallback;

This item has no description.

PNewtonCylinderParam = ˆTNewtonCylinderParam;

This item has no description.

PNewtonDeformableMeshParam = ˆTNewtonDeformableMeshParam;

This item has no description.

PNewtonDeformableMeshSegment = ˆPointer;

This item has no description.

PNewtonDeserializeCallback = ˆNewtonDeserializeCallback;

This item has no description.

PNewtonDestroyContactCallback = ˆNewtonDestroyContactCallback;

This item has no description.

PNewtonFractureCompoundCollisionOnEmitChunk = ˆNewtonFractureCompoundCollisionOnEmitChunk;

This item has no description.

PNewtonFractureCompoundCollisionOnEmitCompoundFractured = ˆNewtonFractureCompoundCollisionOnEmitCompoundFractured;

This item has no description.

PNewtonFractureCompoundCollisionReconstructMainMeshCallBack = ˆNewtonFractureCompoundCollisionReconstructMainMeshCallBack;

This item has no description.

PNewtonFracturedCompoundMeshPart = ˆPointer;

This item has no description.

PNewtonFreeMemory = ˆNewtonFreeMemory;

This item has no description.

PNewtonGetTimeInMicrosencondsCallback = ˆNewtonGetTimeInMicrosencondsCallback;

This item has no description.

PNewtonHeightFieldCollisionParam = ˆTNewtonHeightFieldCollisionParam;

This item has no description.

PNewtonHeightFieldRayCastCallback = ˆNewtonHeightFieldRayCastCallback;

This item has no description.

PNewtonHingeCallback = ˆNewtonHingeCallback;

This item has no description.

PNewtonHingeSliderUpdateDesc = ˆTNewtonHingeSliderUpdateDesc;

This item has no description.

PNewtonImmediateModeConstraint = ˆTNewtonImmediateModeConstraint;

This item has no description.

PNewtonInverseDynamics = ˆPointer;

This item has no description.

PNewtonIslandUpdate = ˆNewtonIslandUpdate;

This item has no description.

PNewtonJobTask = ˆNewtonJobTask;

This item has no description.

PNewtonJoint = ˆPointer;

This item has no description.

PNewtonJointIterator = ˆNewtonJointIterator;

This item has no description.

PNewtonJointRecord = ˆTNewtonJointRecord;

This item has no description.

PNewtonMaterial = ˆPointer;

This item has no description.

PNewtonMaterialData = ˆTNewtonMaterialData;

This item has no description.

PNewtonMesh = ˆPointer;

This item has no description.

PNewtonMeshDoubleData = ˆTNewtonMeshDoubleData;

This item has no description.

PNewtonMeshFloatData = ˆTNewtonMeshFloatData;

This item has no description.

PNewtonMeshVertexFormat = ˆTNewtonMeshVertexFormat;

This item has no description.

PNewtonOnAABBOverlap = ˆNewtonOnAABBOverlap;

This item has no description.

PNewtonOnBodyDeserializationCallback = ˆNewtonOnBodyDeserializationCallback;

This item has no description.

PNewtonOnBodySerializationCallback = ˆNewtonOnBodySerializationCallback;

This item has no description.

PNewtonOnCompoundSubCollisionAABBOverlap = ˆNewtonOnCompoundSubCollisionAABBOverlap;

This item has no description.

PNewtonOnContactGeneration = ˆNewtonOnContactGeneration;

This item has no description.

PNewtonOnJointDeserializationCallback = ˆNewtonOnJointDeserializationCallback;

This item has no description.

PNewtonOnJointSerializationCallback = ˆNewtonOnJointSerializationCallback;

This item has no description.

PNewtonOnUserCollisionSerializationCallback = ˆNewtonOnUserCollisionSerializationCallback;

This item has no description.

PNewtonPostUpdateCallback = ˆNewtonPostUpdateCallback;

This item has no description.

PNewtonReportProgress = ˆNewtonReportProgress;

This item has no description.

PNewtonSceneCollisionParam = ˆTNewtonSceneCollisionParam;

This item has no description.

PNewtonSceneProxy = ˆPointer;

This item has no description.

PNewtonSerializeCallback = ˆNewtonSerializeCallback;

This item has no description.

PNewtonSetTransform = ˆNewtonSetTransform;

This item has no description.

PNewtonSliderCallback = ˆNewtonSliderCallback;

This item has no description.

PNewtonSphereParam = ˆTNewtonSphereParam;

This item has no description.

PNewtonTaperedCapsuleParam = ˆTNewtonTaperedCapsuleParam;

This item has no description.

PNewtonTaperedCylinderParam = ˆTNewtonTaperedCylinderParam;

This item has no description.

PNewtonTreeCollisionCallback = ˆNewtonTreeCollisionCallback;

This item has no description.

PNewtonTreeCollisionFaceCallback = ˆNewtonTreeCollisionFaceCallback;

This item has no description.

PNewtonUniversalCallback = ˆNewtonUniversalCallback;

This item has no description.

PNewtonUserBilateralCallback = ˆNewtonUserBilateralCallback;

This item has no description.

PNewtonUserBilateralGetInfoCallback = ˆNewtonUserBilateralGetInfoCallback;

This item has no description.

PNewtonUserContactPoint = ˆTNewtonUserContactPoint;

This item has no description.

PNewtonUserMeshCollisionAABBTest = ˆNewtonUserMeshCollisionAABBTest;

This item has no description.

PNewtonUserMeshCollisionCollideCallback = ˆNewtonUserMeshCollisionCollideCallback;

This item has no description.

PNewtonUserMeshCollisionCollideDesc = ˆTNewtonUserMeshCollisionCollideDesc;

This item has no description.

PNewtonUserMeshCollisionDestroyCallback = ˆNewtonUserMeshCollisionDestroyCallback;

This item has no description.

PNewtonUserMeshCollisionGetCollisionInfo = ˆNewtonUserMeshCollisionGetCollisionInfo;

This item has no description.

PNewtonUserMeshCollisionGetFacesInAABB = ˆNewtonUserMeshCollisionGetFacesInAABB;

This item has no description.

PNewtonUserMeshCollisionRayHitCallback = ˆNewtonUserMeshCollisionRayHitCallback;

This item has no description.

PNewtonUserMeshCollisionRayHitDesc = ˆTNewtonUserMeshCollisionRayHitDesc;

This item has no description.

PNewtonWorld = ˆPointer;

This item has no description.

PNewtonWorldConvexCastReturnInfo = ˆTNewtonWorldConvexCastReturnInfo;

This item has no description.

PNewtonWorldDestroyListenerCallback = ˆNewtonWorldDestroyListenerCallback;

This item has no description.

PNewtonWorldDestructorCallback = ˆNewtonWorldDestructorCallback;

This item has no description.

PNewtonWorldListenerBodyDestroyCallback = ˆNewtonWorldListenerBodyDestroyCallback;

This item has no description.

PNewtonWorldListenerDebugCallback = ˆNewtonWorldListenerDebugCallback;

This item has no description.

PNewtonWorldRayFilterCallback = ˆNewtonWorldRayFilterCallback;

This item has no description.

PNewtonWorldRayPrefilterCallback = ˆNewtonWorldRayPrefilterCallback;

This item has no description.

PNewtonWorldUpdateListenerCallback = ˆNewtonWorldUpdateListenerCallback;

This item has no description.

PPointer = ˆPointer;

This item has no description.

Psmallint = ˆsmallint;

This item has no description.

Constants

NEWTON_API = 'newton32s.dll';

.$DEFINE USE_DOUBLE_PRECISION

NEWTON_MAJOR_VERSION = 3;

This item has no description.

NEWTON_MINOR_VERSION = 15;

This item has no description.

NEWTON_BROADPHASE_DEFAULT = 0;

This item has no description.

NEWTON_BROADPHASE_PERSINTENT = 1;

This item has no description.

NEWTON_DYNAMIC_BODY = 0;

This item has no description.

NEWTON_KINEMATIC_BODY = 1;

This item has no description.

NEWTON_DYNAMIC_ASYMETRIC_BODY = 2;

This item has no description.

SERIALIZE_ID_SPHERE = 0;

NEWTON_DEFORMABLE_BODY = 2;

SERIALIZE_ID_CAPSULE = 1;

This item has no description.

SERIALIZE_ID_CYLINDER = 2;

This item has no description.

SERIALIZE_ID_CHAMFERCYLINDER = 3;

This item has no description.

SERIALIZE_ID_BOX = 4;

This item has no description.

SERIALIZE_ID_CONE = 5;

This item has no description.

SERIALIZE_ID_CONVEXHULL = 6;

This item has no description.

SERIALIZE_ID_NULL = 7;

This item has no description.

SERIALIZE_ID_COMPOUND = 8;

This item has no description.

SERIALIZE_ID_TREE = 9;

This item has no description.

SERIALIZE_ID_HEIGHTFIELD = 10;

This item has no description.

SERIALIZE_ID_CLOTH_PATCH = 11;

This item has no description.

SERIALIZE_ID_DEFORMABLE_SOLID = 12;

This item has no description.

SERIALIZE_ID_USERMESH = 13;

This item has no description.

SERIALIZE_ID_SCENE = 14;

This item has no description.

SERIALIZE_ID_FRACTURED_COMPOUND = 15;


GLSysHelp v.2.5: Newton.Import: Record TNewtonFuncLinkRecord

Record TNewtonFuncLinkRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonFuncLinkRecord = record

Description

PNewtonSerializeHandle = ˆPointer; PNewtonMeshHandle = ˆPointer; PNewtonMeshVertex = ˆPointer; PNewtonMeshPoint = ˆPointer; PNewtonMeshEdge = ˆPointer; PNewtonMeshFace = ˆPointer; PNewtonListener = ˆPointer;

Overview

Fields

Public | function_name: widestring;
Public | function_ptr: pointer

Description

Fields

Public function_name: widestring;

This item has no description.

Public function_ptr: pointer


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonMaterialData

Packed Record TNewtonMaterialData

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonMaterialData = packed record

Description

This item has no description.

Overview

Fields

Public | m_ptr: Pointer;
Public | m_int: dLong;
Public | m_float: dFloat;

Description

Fields

Public m_ptr: Pointer;

This item has no description.

Public m_int: dLong;

This item has no description.

Public m_float: dFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonCollisionMaterial

Packed Record TNewtonCollisionMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonCollisionMaterial = packed record

Description

This item has no description.

Overview

Fields

Public | m_userId: dLong;
Public | m_userData: TNewtonMaterialData;
Public | m_userParam: array[0..5] of TNewtonMaterialData;

Description

Fields

Public m_userId: dLong;

This item has no description.

Public m_userData: TNewtonMaterialData;

This item has no description.

Public m_userParam: array[0..5] of TNewtonMaterialData;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonBoxParam

Packed Record TNewtonBoxParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonBoxParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_x: dFloat;
Public | m_y: dFloat;
Public | m_z: dFloat;

Description

Fields

Public m_x: dFloat;

This item has no description.

Public m_y: dFloat;

This item has no description.

Public m_z: dFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonSphereParam

Packed Record TNewtonSphereParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonSphereParam = packed record

Description

This item has no description.

Overview

Fields

Public m_radio: dFloat;

Description

Fields

Public m_radio: dFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonCapsuleParam

Packed Record TNewtonCapsuleParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonCapsuleParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_radio0: dfloat;
Public | m_radio1: dfloat;
Public | m_height: dfloat;

Description

Fields

Public m_radio0: dfloat;

This item has no description.

Public m_radio1: dfloat;

This item has no description.

Public m_height: dfloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonCylinderParam

Packed Record TNewtonCylinderParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonCylinderParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_radio0: dfloat;
Public | m_radio1: dfloat;
Public | m_height: dfloat;

Description

Fields

Public m_radio0: dfloat;

This item has no description.

Public m_radio1: dfloat;

This item has no description.

Public m_height: dfloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonConeParam

Packed Record TNewtonConeParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonConeParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_radio: dfloat;
Public | m_height: dfloat;

Description

Fields

Public m_radio: dfloat;

This item has no description.

Public m_height: dfloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonTaperedCapsuleParam

Packed Record TNewtonTaperedCapsuleParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonTaperedCapsuleParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_radio0: dFloat;
Public | m_radio1: dFloat;
Public | m_height: dFloat;

Description

Fields

Public m_radio0: dFloat;

This item has no description.

Public m_radio1: dFloat;

This item has no description.

Public m_height: dFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonTaperedCylinderParam

Packed Record TNewtonTaperedCylinderParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonTaperedCylinderParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_radio0: dFloat;
Public | m_radio1: dFloat;
Public | m_height: dFloat;

Description

Fields

Public m_radio0: dFloat;

This item has no description.

Public m_radio1: dFloat;

This item has no description.

Public m_height: dFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonChamferCylinderParam

Packed Record TNewtonChamferCylinderParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonChamferCylinderParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_radio: dFloat;
Public | m_height: dFloat;

Description

Fields

Public m_radio: dFloat;

This item has no description.

Public m_height: dFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonConvexHullParam

Packed Record TNewtonConvexHullParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonConvexHullParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_vertexCount: Integer;
Public | m_vertexStrideInBytes: Integer;
Public | m_faceCount: Integer;
Public | m_vertex: PdFloat;

Description

Fields

Public m_vertexCount: Integer;

This item has no description.

Public m_vertexStrideInBytes: Integer;

This item has no description.

Public m_faceCount: Integer;

This item has no description.

Public m_vertex: PdFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonCompoundCollisionParam

Packed Record TNewtonCompoundCollisionParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonCompoundCollisionParam = packed record

Description

This item has no description.

Overview

Fields

Public m_chidrenCount: Integer;

Description

Fields

Public m_chidrenCount: Integer;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonCollisionTreeParam

Packed Record TNewtonCollisionTreeParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonCollisionTreeParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_vertexCount: Integer;
Public | m_indexCount: Integer;

Description

Fields

Public m_vertexCount: Integer;

This item has no description.

Public m_indexCount: Integer;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonDeformableMeshParam

Packed Record TNewtonDeformableMeshParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonDeformableMeshParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_vertexCount: Integer;
Public | m_triangleCount: Integer;
Public | m_vrtexStrideInBytes: Integer;
Public | m_indexList: PWord;
Public | m_vertexList: PdFloat;

Description

Fields

Public m_vertexCount: Integer;

This item has no description.

Public m_triangleCount: Integer;

This item has no description.

Public m_vrtexStrideInBytes: Integer;

This item has no description.

Public m_indexList: PWord;

This item has no description.

Public m_vertexList: PdFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonHeightFieldCollisionParam

Packed Record TNewtonHeightFieldCollisionParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonHeightFieldCollisionParam = packed record

Description

This item has no description.

Overview

Fields

Public | m_width: Integer;
Public | m_height: Integer;
Public | m_gridsDiagonals: Integer;
Public | m_elevationDataType: Integer;
Public | m_verticalScale: dFloat;
Public | m_horizonalScale_x: dFloat;
Public | m_horizonalScale_z: dFloat;
Public | m_vertialElevation: Pointer;
Public | m_atributes: PShortInt;

Description

Fields

Public m_width: Integer;

This item has no description.

Public m_height: Integer;

This item has no description.

Public m_gridsDiagonals: Integer;

This item has no description.

Public m_elevationDataType: Integer;

This item has no description.

Public m_verticalScale: dFloat;

0 = 32 bit floats, 1 = unsigned 16 bit integers

Public m_horizonalScale_x: dFloat;

This item has no description.

Public m_horizonalScale_z: dFloat;

This item has no description.

Public m_vertialElevation: Pointer;

This item has no description.

Public m_atributes: PShortInt;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonSceneCollisionParam

Packed Record TNewtonSceneCollisionParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonSceneCollisionParam = packed record

Description

This item has no description.

Overview

Fields

Public m_childrenProxyCount: Integer;

Description

Fields

Public m_childrenProxyCount: Integer;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonCollisionNullParam

Packed Record TNewtonCollisionNullParam

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonCollisionNullParam = packed record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonCollisionInfoRecord

Packed Record TNewtonCollisionInfoRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonCollisionInfoRecord = packed record

Description

This item has no description.

Overview

Fields

Public | m_offsetMatrix: array [0..3,0..3] of dFloat;
Public | m_collisionMaterial: TNewtonCollisionMaterial;
Public | m_collisionType: Integer;
Public | m_collisionUserID: Integer;
Public | shapedataBox: TNewtonBoxParam
Public | shapedataCone: TNewtonConeParam
Public | shapedataSphere: TNewtonSphereParam
Public | shapedataCapsule: TNewtonCapsuleParam
Public | shapedataCylinder: TNewtonCylinderParam
Public | shapedataChamferCylinder: TNewtonChamferCylinderParam
Public | shapedataConvexHull: TNewtonConvexHullParam
Public | m_deformableMesh: TNewtonDeformableMeshParam
Public | shapedataCompound: TNewtonCompoundCollisionParam
Public | shapedataTree: TNewtonCollisionTreeParam
Public | shapedataHeightField: TNewtonHeightFieldCollisionParam
Public | shapedataSceneCollision: TNewtonSceneCollisionParam
Public | m_paramArray: array[0..63] of float

Description

Fields

Public m_offsetMatrix: array [0..3,0..3] of dFloat;

This item has no description.

Public m_collisionMaterial: TNewtonCollisionMaterial;

This item has no description.

Public m_collisionType: Integer;

This item has no description.

Public m_collisionUserID: Integer;

tag id to identify the collision primitive

Public shapedataBox: TNewtonBoxParam

This item has no description.

Public shapedataCone: TNewtonConeParam

This item has no description.

Public shapedataSphere: TNewtonSphereParam

This item has no description.

Public shapedataCapsule: TNewtonCapsuleParam

This item has no description.

Public shapedataCylinder: TNewtonCylinderParam

This item has no description.

Public shapedataChamferCylinder: TNewtonChamferCylinderParam

SERIALIZE_ID_TAPEREDCAPSULE: (m_taperedCapsule: TNewtonTaperedCapsuleParam); SERIALIZE_ID_TAPEREDCYLINDER: (m_taperedCylinder: TNewtonTaperedCylinderParam); SERIALIZE_ID_NULL: (shapedataNull: TNewtonCollisionNullParam);

Public shapedataConvexHull: TNewtonConvexHullParam

This item has no description.

Public m_deformableMesh: TNewtonDeformableMeshParam

This item has no description.

Public shapedataCompound: TNewtonCompoundCollisionParam

This item has no description.

Public shapedataTree: TNewtonCollisionTreeParam

This item has no description.

Public shapedataHeightField: TNewtonHeightFieldCollisionParam

This item has no description.

Public shapedataSceneCollision: TNewtonSceneCollisionParam

This item has no description.

Public m_paramArray: array[0..63] of float


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonJointRecord

Packed Record TNewtonJointRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonJointRecord = packed record

Description

This item has no description.

Overview

Fields

Public | m_attachmenMatrix_0: array[0..3, 0..3] of dfloat;
Public | m_attachmenMatrix_1: array[0..3, 0..3] of dfloat;
Public | m_minLinearDof: array[0..2] of dfloat;
Public | m_maxLinearDof: array[0..2] of dfloat;
Public | m_minAngularDof: array[0..2] of dfloat;
Public | m_maxAngularDof: array[0..2] of dfloat;
Public | m_attachBody_0: pNewtonBody;
Public | m_attachBody_1: pNewtonBody;
Public | m_extraParameters: array[0..63] of dfloat;
Public | m_bodiesCollisionOn: Integer;
Public | m_descriptionType: array[0..127] of AnsiChar;

Description

Fields

Public m_attachmenMatrix_0: array[0..3, 0..3] of dfloat;

This item has no description.

Public m_attachmenMatrix_1: array[0..3, 0..3] of dfloat;

This item has no description.

Public m_minLinearDof: array[0..2] of dfloat;

This item has no description.

Public m_maxLinearDof: array[0..2] of dfloat;

This item has no description.

Public m_minAngularDof: array[0..2] of dfloat;

This item has no description.

Public m_maxAngularDof: array[0..2] of dfloat;

This item has no description.

Public m_attachBody_0: pNewtonBody;

This item has no description.

Public m_attachBody_1: pNewtonBody;

This item has no description.

Public m_extraParameters: array[0..63] of dfloat;

This item has no description.

Public m_bodiesCollisionOn: Integer;

This item has no description.

Public m_descriptionType: array[0..127] of AnsiChar;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonUserMeshCollisionCollideDesc

Packed Record TNewtonUserMeshCollisionCollideDesc

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonUserMeshCollisionCollideDesc = packed record

Description

This item has no description.

Overview

Fields

Public | m_boxP0: array [0..3] of dFloat;
Public | m_boxP1: array [0..3] of dFloat;
Public | m_boxDistanceTravel: array [0..3] of dFloat;
Public | m_threadNumber: Integer;
Public | m_faceCount: Integer;
Public | m_vertexStrideInBytes: Integer;
Public | m_skinThickness: dFloat;
Public | m_userData: Pointer;
Public | m_objBody: PNewtonBody;
Public | m_polySoupBody: PNewtonBody;
Public | m_objCollision: PNewtonCollision;
Public | m_polySoupCollision: PNewtonCollision;
Public | m_vertex: PdFloat;
Public | m_faceIndexCount: PInteger;
Public | m_faceVertexIndex: PInteger;

Description

Fields

Public m_boxP0: array [0..3] of dFloat;

This item has no description.

Public m_boxP1: array [0..3] of dFloat;

lower bounding box of intersection query in local space

Public m_boxDistanceTravel: array [0..3] of dFloat;

upper bounding box of intersection query in local space

Public m_threadNumber: Integer;

max distance that box bpxP0 and boxP1 can travel on this timestep, used this for continue collision mode.

Public m_faceCount: Integer;

current thread executing this query

Public m_vertexStrideInBytes: Integer;

the application should set here how many polygons intersect the query box

Public m_skinThickness: dFloat;

the application should set here the size of each vertex

Public m_userData: Pointer;

this is the minimum skin separation specified by the material between these two colliding shapes

Public m_objBody: PNewtonBody;

user data passed to the collision geometry at creation time

Public m_polySoupBody: PNewtonBody;

pointer to the colliding body

Public m_objCollision: PNewtonCollision;

pointer to the rigid body owner of this collision tree

Public m_polySoupCollision: PNewtonCollision;

collision shape of the colliding body, (no necessarily the collision of m_objBody)

Public m_vertex: PdFloat;

collision shape of teh collsion tree, (no necessarily the collision of m_polySoupBody)

Public m_faceIndexCount: PInteger;

the application should set here the pointer to the global vertex of the mesh.

Public m_faceVertexIndex: PInteger;

the application should set here the pointer to the vertex count of each face.


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonWorldConvexCastReturnInfo

Packed Record TNewtonWorldConvexCastReturnInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonWorldConvexCastReturnInfo = packed record

Description

This item has no description.

Overview

Fields

Public | m_point: array [0..3] of dFloat;
Public | m_normal: array [0..3] of dFloat;
Public | m_contactID: Integer;
Public | m_hitBody: PNewtonBody;
Public | m_penetration: dFloat;

Description

Fields

Public m_point: array [0..3] of dFloat;

This item has no description.

Public m_normal: array [0..3] of dFloat;

collision point in global space

Public m_contactID: Integer;

surface normal at collision point in global space m_normalOnHitPoint: array [0..3] of dFloat; // surface normal at the surface of the hit body, is the same as the normal calculated by a ray cast hitting the body at the hit point

Public m_hitBody: PNewtonBody;

collision ID at contact point

Public m_penetration: dFloat;

body hit at contact point


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonUserMeshCollisionRayHitDesc

Packed Record TNewtonUserMeshCollisionRayHitDesc

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonUserMeshCollisionRayHitDesc = packed record

Description

This item has no description.

Overview

Fields

Public | m_p0: array [0..3] of dFloat;
Public | m_p1: array [0..3] of dFloat;
Public | m_normalOut: array [0..3] of dFloat;
Public | m_userIdOut: dLong;
Public | m_userData: Pointer;

Description

Fields

Public m_p0: array [0..3] of dFloat;

This item has no description.

Public m_p1: array [0..3] of dFloat;

ray origin in collision local space

Public m_normalOut: array [0..3] of dFloat;

ray destination in collision local space

Public m_userIdOut: dLong;

copy here the normal at the ray intersection

Public m_userData: Pointer;

copy here a user defined id for further feedback


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonHingeSliderUpdateDesc

Packed Record TNewtonHingeSliderUpdateDesc

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonHingeSliderUpdateDesc = packed record

Description

This item has no description.

Overview

Fields

Public | m_accel: dFloat;
Public | m_minFriction: dFloat;
Public | m_maxFriction: dFloat;
Public | m_timestep: dFloat;

Description

Fields

Public m_accel: dFloat;

This item has no description.

Public m_minFriction: dFloat;

This item has no description.

Public m_maxFriction: dFloat;

This item has no description.

Public m_timestep: dFloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonUserContactPoint

Packed Record TNewtonUserContactPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonUserContactPoint = packed record

Description

This item has no description.

Overview

Fields

Public | m_point: array [0..3] of dFloat;
Public | m_normal: array [0..3] of dFloat;
Public | m_shapeId0: dLong;
Public | m_shapeId1: dLong;
Public | m_penetration: dFloat;
Public | m_unused: array [0..2] of Integer;

Description

Fields

Public m_point: array [0..3] of dFloat;

This item has no description.

Public m_normal: array [0..3] of dFloat;

This item has no description.

Public m_shapeId0: dLong;

This item has no description.

Public m_shapeId1: dLong;

This item has no description.

Public m_penetration: dFloat;

This item has no description.

Public m_unused: array [0..2] of Integer;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonImmediateModeConstraint

Packed Record TNewtonImmediateModeConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonImmediateModeConstraint = packed record

Description

This item has no description.

Overview

Fields

Public | m_jacobian01: array[0..7, 0..5] of dfloat;
Public | m_jacobian10: array[0..7, 0..5] of dfloat;
Public | m_minFriction: array[0..7] of dfloat;
Public | m_maxFriction: array[0..7] of dfloat;
Public | m_jointAccel: array[0..7] of dfloat;
Public | m_jointStiffness: array[0..7] of dfloat;

Description

Fields

Public m_jacobian01: array[0..7, 0..5] of dfloat;

This item has no description.

Public m_jacobian10: array[0..7, 0..5] of dfloat;

This item has no description.

Public m_minFriction: array[0..7] of dfloat;

This item has no description.

Public m_maxFriction: array[0..7] of dfloat;

This item has no description.

Public m_jointAccel: array[0..7] of dfloat;

This item has no description.

Public m_jointStiffness: array[0..7] of dfloat;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonMeshDoubleData

Packed Record TNewtonMeshDoubleData

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonMeshDoubleData = packed record

Description

data structure for interfacing with NewtonMesh

Overview

Fields

Public | m_data: Pdouble;
Public | m_indexList: PInteger;
Public | m_strideInBytes: Integer;

Description

Fields

Public m_data: Pdouble;

This item has no description.

Public m_indexList: PInteger;

This item has no description.

Public m_strideInBytes: Integer;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonMeshFloatData

Packed Record TNewtonMeshFloatData

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonMeshFloatData = packed record

Description

This item has no description.

Overview

Fields

Public | m_data: PdFloat;
Public | m_indexList: PInteger;
Public | m_strideInBytes: Integer;

Description

Fields

Public m_data: PdFloat;

This item has no description.

Public m_indexList: PInteger;

This item has no description.

Public m_strideInBytes: Integer;


GLSysHelp v.2.5: Newton.Import: Packed Record TNewtonMeshVertexFormat

Packed Record TNewtonMeshVertexFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

Newton.Import

Declaration

type TNewtonMeshVertexFormat = packed record

Description

This item has no description.

Overview

Fields

Public | m_faceCount: Integer;
Public | m_faceIndexCount: PInteger;
Public | m_faceMaterial: PInteger;
Public | m_vertex: TNewtonMeshDoubleData;
Public | m_normal: TNewtonMeshFloatData;
Public | m_binormal: TNewtonMeshFloatData;
Public | m_uv0: TNewtonMeshFloatData;
Public | m_uv1: TNewtonMeshFloatData;
Public | m_vertexColor: TNewtonMeshFloatData;

Description

Fields

Public m_faceCount: Integer;

This item has no description.

Public m_faceIndexCount: PInteger;

This item has no description.

Public m_faceMaterial: PInteger;

This item has no description.

Public m_vertex: TNewtonMeshDoubleData;

This item has no description.

Public m_normal: TNewtonMeshFloatData;

This item has no description.

Public m_binormal: TNewtonMeshFloatData;

This item has no description.

Public m_uv0: TNewtonMeshFloatData;

This item has no description.

Public m_uv1: TNewtonMeshFloatData;

This item has no description.

Public m_vertexColor: TNewtonMeshFloatData;


GLSysHelp v.2.5: ODE.Import

Unit ODE.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • ModuleLoader

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TdxJointGroup |
Record TdxJointLimitMotor |
Record TdMass |
Record TdxAutoDisable |
Record TdxDampingParameters |
Record TdxContactParameters |
Record TdxQuickStepParameters |
Record TdObject |
Record TdxJointNode |
Record TJointInfo1 |
Record TJointInfo2 |
Record TdxJoint |
Record TdxJointBall |
Record TdxJointHinge |
Record TdxJointUniversial |
Record TdxJointPR |
Record TdxJointPiston |
Record TdxJointSlider |
Record TdxJointHinge2 |
Record TdxJointAMotor |
Record TdxJointLMotor |
Record TdxJointPlane2D |
Record TdxJointFixed |
Record TdxPosR |
Record TdxBody |
Class TBodyList |
Record TdxWorld |
Record TdJointFeedback |
Record TdSurfaceParameters |
Record TdContactGeom |
Record TdContact |
Record TdGeomClass |
Record TdxTriMeshData |
Record TdxHeightfieldData |
Record TdGeomSpaceData |
Record TdxGeom |
Class TGeomList |
Record TdxSpace |
Record TdxHashSpace |
Record TdxQuadTreeSpace |

Functions and Procedures

procedure dInitODE; cdecl; external ODEDLL;
function dInitODE2(uiInitFlags: longword): Integer; cdecl; external ODEDLL;
procedure dCloseODE; cdecl; external ODEDLL;
function dWorldCreate: PdxWorld; cdecl; external ODEDLL;
procedure dWorldDestroy(const World: PdxWorld); cdecl; external ODEDLL;
function dWorldGetCFM(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
function dWorldGetERP(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldGetGravity(const World: PdxWorld; var gravity: TdVector3); cdecl; external ODEDLL;
procedure dWorldImpulseToForce(const World: PdxWorld; const stepsize, ix, iy, iz: TdReal; var force: TdVector3); cdecl; external ODEDLL;
procedure dWorldSetCFM(const World: PdxWorld; cfm: TdReal); cdecl; external ODEDLL;
procedure dWorldSetERP(const World: PdxWorld; erp: TdReal); cdecl; external ODEDLL;
procedure dWorldSetGravity(const World: PdxWorld; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dWorldSetContactMaxCorrectingVel(const World: PdxWorld; const vel: TdReal); cdecl; external ODEDLL;
function dWorldGetContactMaxCorrectingVel(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetContactSurfaceLayer(const World: PdxWorld; const depth: TdReal); cdecl; external ODEDLL;
function dWorldGetContactSurfaceLayer(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldExportDIF(const World: PdxWorld; fileHandle: cardinal; const world_name: PAnsiChar); cdecl; external ODEDLL;
function dWorldGetLinearDampingThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetLinearDampingThreshold(const World: PdxWorld; const threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAngularDampingThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAngularDampingThreshold(const World: PdxWorld; const threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetLinearDamping(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetLinearDamping(const World: PdxWorld; const scale: TdReal); cdecl; external ODEDLL;
function dWorldGetAngularDamping(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAngularDamping(const World: PdxWorld; const scale: TdReal); cdecl; external ODEDLL;
procedure dWorldSetDamping(const World: PdxWorld; const linear_scale, angular_scale: TdReal); cdecl; external ODEDLL;
function dWorldGetMaxAngularSpeed(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetMaxAngularSpeed(const World: PdxWorld; const max_speed: TdReal); cdecl; external ODEDLL;
procedure dWorldStep(const World: PdxWorld; const stepsize: TdReal); cdecl; external ODEDLL;
procedure dWorldQuickStep(const World: PdxWorld; const stepsize: TdReal); cdecl; external ODEDLL;
procedure dWorldSetQuickStepNumIterations(const World: PdxWorld; const num: Integer); cdecl; external ODEDLL;
function dWorldGetQuickStepNumIterations(const World: PdxWorld): Integer; cdecl; external ODEDLL;
procedure dWorldSetQuickStepW(const World: PdxWorld; const param: TdReal); cdecl; external ODEDLL;
function dWorldGetQuickStepW(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
function dWorldGetAutoDisableLinearAverageThreshold(const World: PdxWorld) : TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableLinearAverageThreshold(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAngularAverageThreshold(const World: PdxWorld) : TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAngularAverageThreshold(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAverageSamplesCount(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAverageSamplesCount(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableLinearThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableLinearThreshold(const World: PdxWorld; linThreshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAngularThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAngularThreshold(const World: PdxWorld; angThreshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableSteps(const World: PdxWorld): Integer; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableSteps(const World: PdxWorld; steps: Integer); cdecl; external ODEDLL;
function dWorldGetAutoDisableTime(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableTime(const World: PdxWorld; time: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableFlag(const World: PdxWorld): Integer; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableFlag(const World: PdxWorld; do_auto_disable: Integer); cdecl; external ODEDLL;
procedure dBodyAddForce(const body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddForceAtPos(const body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddForceAtRelPos(const body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForce(const body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForceAtPos(const body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForceAtRelPos(const body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelTorque(const body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddTorque(const body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
function dBodyCreate(const World: PdxWorld): PdxBody; cdecl; external ODEDLL;
procedure dBodyDestroy(const body: PdxBody); cdecl; external ODEDLL;
procedure dBodyDisable(const body: PdxBody); cdecl; external ODEDLL;
procedure dBodyEnable(const body: PdxBody); cdecl; external ODEDLL;
function dBodyGetAngularVel(const body: PdxBody): PdVector3; cdecl; external ODEDLL;
procedure dBodyGetFiniteRotationAxis(const body: PdxBody; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetFiniteRotationMode(const body: PdxBody): Integer; cdecl; external ODEDLL;
function dBodyGetForce(const body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyGetGravityMode(const body: PdxBody): Integer; cdecl; external ODEDLL;
function dBodyGetJoint(const body: PdxBody; const index: Integer): TdJointID; cdecl; external ODEDLL;
function dBodyGetLinearVel(const body: PdxBody): PdVector3; cdecl; external ODEDLL;
procedure dBodyGetMass(const body: PdxBody; var mass: TdMass); cdecl; external ODEDLL;
function dBodyGetNumJoints(const body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodyGetPointVel(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyGetPosRelPoint(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetPosition(const body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyGetQuaternion(const body: PdxBody): PdQuaternion; cdecl; external ODEDLL;
procedure dBodyGetRelPointPos(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyGetRelPointVel(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetRotation(const body: PdxBody): PdMatrix3; cdecl; external ODEDLL;
function dBodyGetTorque(const body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyIsEnabled(const body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAngularVel(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetFiniteRotationAxis(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetFiniteRotationMode(const body: PdxBody; const mode: Integer); cdecl; external ODEDLL;
procedure dBodySetForce(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetGravityMode(const body: PdxBody; const mode: Integer); cdecl; external ODEDLL;
procedure dBodySetLinearVel(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetMass(const body: PdxBody; const mass: PdMass); cdecl; external ODEDLL;
procedure dBodySetPosition(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetQuaternion(const body: PdxBody; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dBodySetRotation(const body: PdxBody; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dBodySetTorque(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodyVectorFromWorld(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyVectorToWorld(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodySetData(const body: PdxBody; data: pointer); cdecl; external ODEDLL;
function dBodyGetData(const body: PdxBody): pointer; cdecl; external ODEDLL;
procedure dBodySetMovedCallback(const body: PdxBody; callback: TdMovedCallback); cdecl; external ODEDLL;
procedure dBodyCopyPosition(const body: PdxBody; const pos: TdVector3); cdecl; external ODEDLL;
procedure dBodyCopyRotation(const body: PdxBody; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dBodyCopyQuaternion(const body: PdxBody; const quat: TdQuaternion); cdecl; external ODEDLL;
procedure dBodySetLinearDamping(const body: PdxBody; scale: TdReal); cdecl; external ODEDLL;
function dBodyGetLinearDamping(const body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAngularDamping(const body: PdxBody; scale: TdReal); cdecl; external ODEDLL;
function dBodyGetAngularDamping(const body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetDamping(const body: PdxBody; linear_scale, angular_scale: TdReal); cdecl; external ODEDLL;
function dBodyGetLinearDampingThreshold(const body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetLinearDampingThreshold(const body: PdxBody; threshold: TdReal); cdecl; external ODEDLL;
function dBodyGetAngularDampingThreshold(const body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAngularDampingThreshold(const body: PdxBody; threshold: TdReal); cdecl; external ODEDLL;
procedure dBodySetDampingDefaults(const body: PdxBody; threshold: TdReal); cdecl; external ODEDLL;
procedure dBodySetMaxAngularSpeed(const body: PdxBody; max_speed: TdReal); cdecl; external ODEDLL;
function dBodyGetMaxAngularSpeed(const body: PdxBody): TdReal; cdecl; external ODEDLL;
function dBodyGetAutoDisableLinearThreshold(const body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableLinearThreshold(const body: PdxBody; linThreshold: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableAngularThreshold(const body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableAngularThreshold(const body: PdxBody; angThreshold: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableSteps(const body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAutoDisableSteps(const body: PdxBody; steps: Integer); cdecl; external ODEDLL;
function dBodyGetAutoDisableTime(const body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableTime(const body: PdxBody; time: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableFlag(const body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAutoDisableFlag(const body: PdxBody; do_auto_disable: Integer); cdecl; external ODEDLL;
procedure dBodySetAutoDisableDefaults(const body: PdxBody); cdecl; external ODEDLL;
procedure dBodySetAutoDisableAverageSamplesCount(const body: PdxBody; average_samples_count: longword); cdecl; external ODEDLL;
procedure dJointGroupDestroy(const dJointGroupID: TdJointGroupID); cdecl; external ODEDLL;
function dJointGroupCreate(const max_size: Integer): TdJointGroupID; cdecl; external ODEDLL;
procedure dJointGroupEmpty(const dJointGroupID: TdJointGroupID); cdecl; external ODEDLL;
procedure dJointAttach(const dJointID: TdJointID; const body1, body2: PdxBody); cdecl; external ODEDLL;
procedure dJointDestroy(const dJointID: TdJointID); cdecl; external ODEDLL;
function dJointGetData(const dJointID: TdJointID): pointer; cdecl; external ODEDLL;
procedure dJointSetData(const dJointID: TdJointID; data: pointer); cdecl; external ODEDLL;
procedure dJointSetFeedback(const dJointID: TdJointID; Feedback: PTdJointFeedback); cdecl; external ODEDLL;
function dJointGetFeedback(const dJointID: TdJointID): PTdJointFeedback; cdecl; external ODEDLL;
function dJointGetType(const dJointID: TdJointID): Integer; cdecl; external ODEDLL;
function dJointGetBody(const dJointID: TdJointID; const index: Integer) : PdxBody; cdecl; external ODEDLL;
function dJointCreateContact(const World: PdxWorld; dJointGroupID: TdJointGroupID; const dContact: PdContact): TdJointID; cdecl; external ODEDLL;
function dJointCreateAMotor(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetAMotorAngle(const dJointID: TdJointID; const anum: Integer; const angle: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorAngle(const dJointID: TdJointID; const anum: Integer) : TdReal; cdecl; external ODEDLL;
procedure dJointSetAMotorAxis(const dJointID: TdJointID; const anum, rel: Integer; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetAMotorAxis(const dJointID: TdJointID; const anum: Integer; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetAMotorNumAxes(const dJointID: TdJointID; const num: Integer); cdecl; external ODEDLL;
function dJointGetAMotorNumAxes(const dJointID: TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointSetAMotorParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
procedure dJointSetAMotorMode(const dJointID: TdJointID; const mode: TdAngularMotorModeNumbers); cdecl; external ODEDLL;
function dJointGetAMotorMode(const dJointID: TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointAddAMotorTorques(const dJointID: TdJointID; torque1, torque2, torque3: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorAngleRate(const dJointID: TdJointID; const anum: Integer): TdReal; cdecl; external ODEDLL;
function dJointGetAMotorAxisRel(const dJointID: TdJointID; const anum: Integer) : Integer; cdecl; external ODEDLL;
function dJointCreateLMotor(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetLMotorAxis(const dJointID: TdJointID; const anum, rel: Integer; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetLMotorAxis(const dJointID: TdJointID; const anum: Integer; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetLMotorNumAxes(const dJointID: TdJointID; const num: Integer); cdecl; external ODEDLL;
function dJointGetLMotorNumAxes(const dJointID: TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointSetLMotorParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;
function dJointGetLMotorParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointCreateBall(const World: PdxWorld; dJointGroupID: TdJointGroupID) : TdJointID; cdecl; external ODEDLL;
procedure dJointSetBallAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetBallAnchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetBallAnchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
function dJointCreateHinge(const World: PdxWorld; dJointGroupID: TdJointGroupID) : TdJointID; cdecl; external ODEDLL;
procedure dJointSetHingeAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHingeAnchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetHingeAnchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHingeAxis(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHingeAxis(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHingeParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;
function dJointGetHingeParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetHingeAngle(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHingeAngleRate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddHingeTorque(const dJointID: TdJointID; torque: TdReal); cdecl; external ODEDLL;
function dJointCreateHinge2(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetHinge2Anchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Anchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetHinge2Anchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Axis1(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Axis1(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Axis2(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Axis2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Param(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;
function dJointGetHinge2Param(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle1(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle1Rate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle2Rate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddHinge2Torques(const dJointID: TdJointID; torque1, torque2: TdReal); cdecl; external ODEDLL;
procedure dJointCorrectHinge2(const dJointID: TdJointID); cdecl; external ODEDLL;
function dJointCreateSlider(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetSliderAxis(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetSliderAxis(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetSliderParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;
function dJointGetSliderParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetSliderPosition(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetSliderPositionRate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddSliderForce(const dJointID: TdJointID; force: TdReal); cdecl; external ODEDLL;
function dJointCreateUniversal(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointGetUniversalAnchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetUniversalAnchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalAxis1(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetUniversalAxis1(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalAxis2(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetUniversalAxis2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;
function dJointGetUniversalParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle1(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle2(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle1Rate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle2Rate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointSetUniversalAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointAddUniversalTorques(const dJointID: TdJointID; torque1, torque2: TdReal); cdecl; external ODEDLL;
function dJointCreateFixed(const World: PdxWorld; dJointGroupID: TdJointGroupID) : TdJointID; cdecl; external ODEDLL;
procedure dJointSetFixed(const dJointID: TdJointID); cdecl; external ODEDLL;
function dJointCreatePlane2D(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetPlane2DXParam(const dJointID: TdJointID; const parameter: Integer; const Value: TdReal); cdecl; external ODEDLL;
procedure dJointSetPlane2DYParam(const dJointID: TdJointID; const parameter: Integer; const Value: TdReal); cdecl; external ODEDLL;
procedure dJointSetPlane2DAngleParam(const dJointID: TdJointID; const parameter: Integer; const Value: TdReal); cdecl; external ODEDLL;
function dJointCreatePR(const World: PdxWorld; dJointGroupID: TdJointGroupID) : TdJointID; cdecl; external ODEDLL;
procedure dJointSetPRAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointSetPRAxis1(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPRAxis1(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPRAxis2(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPRAxis2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPRParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;
function dJointGetPRParam(const dJointID: TdJointID; parameter: Integer) : TdReal; cdecl; external ODEDLL;
procedure dJointAddPRTorque(const dJointID: TdJointID; torque: TdReal); cdecl; external ODEDLL;
function dJointCreatePiston(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetPistonAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPistonAnchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetPistonAnchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPistonAxis(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPistonAxis(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPistonParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;
function dJointGetPistonParam(const dJointID: TdJointID; parameter: Integer) : TdReal; cdecl; external ODEDLL;
procedure dJointSetPistonAxisDelta(const dJointID: TdJointID; const x, y, z, ax, ay, az: TdReal); cdecl; external ODEDLL;
procedure dJointAddPistonForce(const dJointID: TdJointID; force: TdReal); cdecl; external ODEDLL;
function dJointGetPistonPosition(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonAngle(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonAngleRate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonRate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;
function dCreateGeom(classnum: Integer): PdxGeom; cdecl; external ODEDLL;
procedure dGeomDestroy(const geom: PdxGeom); cdecl; external ODEDLL;
function dCreateGeomClass(const classptr: TdGeomClass): Integer; cdecl; external ODEDLL;
function dGeomGetClass(const geom: PdxGeom): Integer; cdecl; external ODEDLL;
function dGeomGetClassData(o: PdxGeom): pointer; cdecl; external ODEDLL;
function dGeomGetSpace(const geom: PdxGeom): PdxSpace; cdecl; external ODEDLL;
function dGeomIsSpace(const geom: PdxGeom): Integer; cdecl; external ODEDLL;
procedure dGeomSetBody(const geom: PdxGeom; body: PdxBody); cdecl; external ODEDLL;
function dGeomGetBody(const geom: PdxGeom): PdxBody; cdecl; external ODEDLL;
procedure dGeomSetPosition(const geom: PdxGeom; const x, y, z: TdReal); cdecl; external ODEDLL;
function dGeomGetPosition(const geom: PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetRotation(const geom: PdxGeom; const R: TdMatrix3); cdecl; external ODEDLL;
function dGeomGetRotation(const geom: PdxGeom): PdMatrix3; cdecl; external ODEDLL;
procedure dGeomSetQuaternion(const geom: PdxGeom; const TdQuaternion); cdecl; external ODEDLL;
procedure dGeomGetQuaternion(const geom: PdxGeom; var result: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomCopyPosition(const geom: PdxGeom; const pos: TdVector3); cdecl; external ODEDLL;
procedure dGeomCopyRotation(const geom: PdxGeom; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dGeomCopyQuaternion(const geom: PdxGeom; const quat: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomSetData(const geom: PdxGeom; data: pointer); cdecl; external ODEDLL;
function dGeomGetData(const geom: PdxGeom): pointer; cdecl; external ODEDLL;
procedure dGeomEnable(const geom: PdxGeom); cdecl; external ODEDLL;
procedure dGeomDisable(const geom: PdxGeom); cdecl; external ODEDLL;
function dGeomIsEnabled(const geom: PdxGeom): Integer; cdecl; external ODEDLL;
procedure dGeomGetAABB(const geom: PdxGeom; var aabb: TdAABB); cdecl; external ODEDLL;
procedure dGeomSetCategoryBits(const geom: PdxGeom; bits: cardinal); cdecl; external ODEDLL;
function dGeomGetCategoryBits(const geom: PdxGeom): cardinal; cdecl; external ODEDLL;
procedure dGeomSetCollideBits(const geom: PdxGeom; bits: cardinal); cdecl; external ODEDLL;
function dGeomGetCollideBits(const geom: PdxGeom): cardinal; cdecl; external ODEDLL;
procedure dGeomSetOffsetPosition(const geom: PdxGeom; x, y, z: TdReal); cdecl; external ODEDLL;
function dGeomGetOffsetPosition(const geom: PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetOffsetRotation(const geom: PdxGeom; R: TdMatrix3); cdecl; external ODEDLL;
function dGeomGetOffsetRotation(const geom: PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetOffsetQuaternion(const geom: PdxGeom; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomGetOffsetQuaternion(const geom: PdxGeom; var q: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomClearOffset(const geom: PdxGeom); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldPosition(const geom: PdxGeom; x, y, z: TdReal); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldRotation(const geom: PdxGeom; R: TdMatrix3); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldQuaternion(const geom: PdxGeom; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomCopyOffsetPosition(const geom: PdxGeom; var pos: TdVector3); cdecl; external ODEDLL;
procedure dGeomCopyOffsetRotation(const geom: PdxGeom; var R: TdMatrix3); cdecl; external ODEDLL;
procedure dGeomIsOffset(const geom: PdxGeom); cdecl; external ODEDLL;
function dCreateGeomTransform(const Space: PdxSpace): PdxGeom; cdecl; external ODEDLL;
procedure dGeomTransformSetGeom(const geom, obj: PdxGeom); cdecl; external ODEDLL;
function dGeomTransformGetGeom(const geom: PdxGeom): PdxGeom; cdecl; external ODEDLL;
procedure dGeomTransformSetInfo(const geom: PdxGeom; mode: Integer); cdecl; external ODEDLL;
function dGeomTransformGetInfo(const geom: PdxGeom): Integer; cdecl; external ODEDLL;
procedure dGeomTransformSetCleanup(const geom: PdxGeom; const mode: Integer); cdecl; external ODEDLL;
function dGeomTransformGetCleanup(const geom: PdxGeom): Integer; cdecl; external ODEDLL;
function dCreateBox(const Space: PdxSpace; const lx, ly, lz: TdReal): PdxGeom; cdecl; external ODEDLL;
procedure dGeomBoxGetLengths(const geom: PdxGeom; var result: TdVector3); cdecl; external ODEDLL;
procedure dGeomBoxSetLengths(const geom: PdxGeom; const lx, ly, lz: TdReal); cdecl; external ODEDLL;
function dGeomBoxPointDepth(const geom: PdxGeom; const x, y, z: TdReal): TdReal; cdecl; external ODEDLL;
function dCreateCylinder(const Space: PdxSpace; R, lz: TdReal): PdxGeom; cdecl; external ODEDLL;
procedure dGeomCylinderSetParams(const geom: PdxGeom; radius, length: TdReal); cdecl; external ODEDLL;
procedure dGeomCylinderGetParams(const geom: PdxGeom; var radius, length: TdReal); cdecl; external ODEDLL;
function dCreateCapsule(const Space: PdxSpace; const radius, length: TdReal) : PdxGeom; cdecl; external ODEDLL;
procedure dGeomCapsuleSetParams(const geom: PdxGeom; const radius, length: TdReal); cdecl; external ODEDLL;
procedure dGeomCapsuleGetParams(const geom: PdxGeom; var radius, length: TdReal); cdecl; external ODEDLL;
function dGeomCapsulePointDepth(const geom: PdxGeom; const x, y, z: TdReal) : TdReal; cdecl; external ODEDLL;
function dCreatePlane(const Space: PdxSpace; const a, b, c, d: TdReal): PdxGeom; cdecl; external ODEDLL;
procedure dGeomPlaneSetParams(const geom: PdxGeom; const a, b, c, d: TdReal); cdecl; external ODEDLL;
procedure dGeomPlaneGetParams(const geom: PdxGeom; var result: TdVector4); cdecl; external ODEDLL;
function dGeomPlanePointDepth(const geom: PdxGeom; const x, y, z: TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateSphere(const Space: PdxSpace; const radius: TdReal): PdxGeom; cdecl; external ODEDLL;
procedure dGeomSphereSetRadius(const geom: PdxGeom; const radius: TdReal); cdecl; external ODEDLL;
function dGeomSphereGetRadius(const geom: PdxGeom): TdReal; cdecl; external ODEDLL;
function dGeomSpherePointDepth(const geom: PdxGeom; const x, y, z: TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateConvex(const Space: PdxSpace; _planes: PdReal; _planecount: longword; _points: PdReal; _pointcount: longword; const _polygons: longword): PdxGeom; cdecl; external ODEDLL;
procedure dGeomSetConvex(const geom: PdxGeom; _planes: PdReal; _planecount: longword; _points: PdReal; _pointcount: longword; const _polygons: longword); cdecl; external ODEDLL;
function dCreateHeightfield(const Space: PdxSpace; data: PdxHeightfieldData; bPlaceable: Integer): PdxGeom; cdecl; external ODEDLL;
function dGeomHeightfieldDataCreate: PdxHeightfieldData; cdecl; external ODEDLL;
procedure dGeomHeightfieldDataDestroy(data: PdxHeightfieldData); cdecl; external ODEDLL;
procedure dGeomHeightfieldSetHeightfieldData(const geom: PdxGeom; data: PdxHeightfieldData); cdecl; external ODEDLL;
function dGeomHeightfieldGetHeightfieldData(const geom: PdxGeom) : PdxHeightfieldData; cdecl; external ODEDLL;
function dGeomHeightfieldDataSetBounds(data: PdxHeightfieldData; minHeight, MaxHeight: TdReal): TdReal; cdecl; external ODEDLL;
function dCreateRay(const Space: PdxSpace; length: TdReal): PdxGeom; cdecl; external ODEDLL;
procedure dGeomRaySet(const geom: PdxGeom; px, py, pz, dx, dy, dz: TdReal); cdecl; external ODEDLL;
procedure dGeomRayGet(const geom: PdxGeom; var start, dir: TdVector3); cdecl; external ODEDLL;
procedure dGeomRaySetLength(const geom: PdxGeom; length: TdReal); cdecl; external ODEDLL;
function dGeomRayGetLength(const geom: PdxGeom): TdReal; cdecl; external ODEDLL;
procedure dGeomRaySetParams(const geom: PdxGeom; FirstContact, BackfacCull: Integer); cdecl; external ODEDLL;
procedure dGeomRayGetParams(const geom: PdxGeom; var FirstContact, BackfacCull: Integer); cdecl; external ODEDLL;
procedure dGeomRaySetClosestHit(const geom: PdxGeom; closestHit: Integer); cdecl; external ODEDLL;
function dGeomRayGetClosestHit(const geom: PdxGeom): Integer; cdecl; external ODEDLL;
function dCreateTriMesh(const Space: PdxSpace; data: PdxTriMeshData; callback: TdTriCallback; ArrayCallback: TdTriArrayCallback; RayCallback: TdTriRayCallback): PdxGeom; cdecl; external ODEDLL;
procedure dGeomTriMeshSetData(g: PdxGeom; data: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshGetData(g: PdxGeom): PdxTriMeshData; cdecl; external ODEDLL;
function dGeomTriMeshGetTriMeshDataID(g: PdxGeom): PdxTriMeshData; cdecl; external ODEDLL;
procedure dGeomTriMeshDataUpdate(g: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshIsTCEnabled(g: PdxGeom; geomClass: Integer): Integer; cdecl; external ODEDLL;
procedure dGeomTriMeshEnableTC(g: PdxGeom; geomClass, enable: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshClearTCCache(g: PdxGeom); cdecl; external ODEDLL;
function dGeomTriMeshGetTriangleCount(g: PdxGeom): Integer; cdecl; external ODEDLL;
procedure dGeomTriMeshGetTriangle(g: PdxGeom; index: Integer; v0, v1, v2: PdVector3); cdecl; external ODEDLL;
procedure dGeomTriMeshGetPoint(g: PdxGeom; index: Integer; u, v: TdReal; result: TdVector3); cdecl; external ODEDLL;
function dGeomTriMeshGetArrayCallback(g: PdxGeom): pointer; cdecl; external ODEDLL;
function dGeomTriMeshGetRayCallback(g: PdxGeom): pointer; cdecl; external ODEDLL;
procedure dGeomTriMeshSetArrayCallback(g: PdxGeom; ArrayCallback: pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshSetRayCallback(g: PdxGeom; RayCallback: pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshSetCallback(g: PdxGeom; callback: pointer); cdecl; external ODEDLL;
function dGeomTriMeshGetCallback(g: PdxGeom): pointer; cdecl; external ODEDLL;
procedure dGeomTriMeshDataDestroy(g: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshDataCreate: PdxTriMeshData; cdecl; external ODEDLL;
procedure dGeomTriMeshDataSet(g: PdxTriMeshData; data_id: Integer; data: pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSimple(g: PdxTriMeshData; Vertices: PdVector3Array; VertexCount: Integer; Indices: PdIntegerArray; IndexCount: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSimple1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexCount: Integer; Indices: PdIntegerArray; IndexCount: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildDouble(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildDouble1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSingle(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSingle1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dInfiniteAABB(geom: PdxGeom; var aabb: TdAABB); cdecl; external ODEDLL;
procedure dSpaceDestroy(const Space: PdxSpace); cdecl; external ODEDLL;
function dSimpleSpaceCreate(Space: PdxSpace): PdxSpace; cdecl; external ODEDLL;
function dHashSpaceCreate(Space: PdxSpace): PdxSpace; cdecl; external ODEDLL;
function dQuadTreeSpaceCreate(const Space: PdxSpace; const Center, Extents: TdVector3; const depth: Integer): PdxSpace; cdecl; external ODEDLL;
procedure dSpaceAdd(const Space: PdxSpace; const geom: PdxGeom); cdecl; external ODEDLL;
procedure dSpaceRemove(const Space: PdxSpace; const geom: PdxGeom); cdecl; external ODEDLL;
procedure dSpaceClean(const Space: PdxSpace); cdecl; external ODEDLL;
function dSpaceQuery(const Space: PdxSpace; const geom: PdxGeom): Integer; cdecl; external ODEDLL;
function dSpaceGetNumGeoms(const Space: PdxSpace): Integer; cdecl; external ODEDLL;
function dSpaceGetGeom(const Space: PdxSpace; const I: Integer): PdxGeom; cdecl; external ODEDLL;
procedure dHashSpaceSetLevels(const Space: PdxSpace; const minlevel, maxlevel: Integer); cdecl; external ODEDLL;
procedure dHashSpaceGetLevels(const Space: PdxSpace; var minlevel, maxlevel: Integer); cdecl; external ODEDLL;
procedure dSpaceSetCleanup(Space: PdxSpace; const mode: Integer); cdecl; external ODEDLL;
function dSpaceGetCleanup(Space: PdxSpace): Integer; cdecl; external ODEDLL;
function dCollide(o1, o2: PdxGeom; flags: Integer; var contact: TdContactGeom; skip: Integer): Integer; cdecl; external ODEDLL;
procedure dSpaceCollide(const Space: PdxSpace; data: pointer; callback: TdNearCallback); cdecl; external ODEDLL;
procedure dSpaceCollide2(o1, o2: PdxGeom; data: pointer; callback: TdNearCallback); cdecl; external ODEDLL;
procedure dMassSetParameters(var m: TdMass; themass, cgx, cgy, cgz, I11, I22, I33, I12, I13, I23: TdReal); cdecl; external ODEDLL;
procedure dMassAdd(var a, b: TdMass); cdecl; external ODEDLL;
procedure dMassAdjust(var m: TdMass; newmass: TdReal); cdecl; external ODEDLL;
procedure dMassTranslate(var m: TdMass; x, y, z: TdReal); cdecl; external ODEDLL;
procedure dMassRotate(var m: TdMass; var R: TdMatrix3); cdecl; external ODEDLL;
procedure dMassSetZero(var m: TdMass); cdecl; external ODEDLL;
procedure dMassSetBox(var m: TdMass; density, lx, ly, lz: TdReal); cdecl; external ODEDLL;
procedure dMassSetBoxTotal(var m: TdMass; total_mass, lx, ly, lz: TdReal); cdecl; external ODEDLL;
procedure dMassSetCylinder(var m: TdMass; density: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCylinderTotal(var m: TdMass; total_mass: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCapsule(var m: TdMass; density: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCapsuleTotal(var m: TdMass; total_mass: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetSphere(var m: TdMass; density, radius: TdReal); cdecl; external ODEDLL;
procedure dMassSetSphereTotal(var m: TdMass; total_mass, radius: TdReal); cdecl; external ODEDLL;
procedure dMassSetTrimesh(var m: TdMass; density: TdReal; TriMesh: PdxGeom); cdecl; external ODEDLL;
procedure dMassSetTrimeshTotal(var m: TdMass; total_mass: TdReal; TriMesh: PdxGeom); cdecl; external ODEDLL;
procedure dQFromAxisAndAngle(var q: TdQuaternion; const ax, ay, az, angle: TdReal); cdecl; external ODEDLL;
procedure dRFromAxisAndAngle(var R: TdMatrix3; const ax, ay, az, angle: TdReal); cdecl; external ODEDLL;
procedure dRSetIdentity(var R: TdMatrix3); cdecl; external ODEDLL;
procedure dQSetIdentity(var q: TdQuaternion); cdecl; external ODEDLL;
procedure dRFromEulerAngles(var R: TdMatrix3; const phi, theta, psi: TdReal); cdecl; external ODEDLL;
procedure dRFrom2Axes(var R: TdMatrix3; const ax, ay, az, bx, by, bz: TdReal); cdecl; external ODEDLL;
procedure dRFromZAxis(var R: TdMatrix3; const ax, ay, az: TdReal); cdecl; external ODEDLL;
procedure dMultiply0(const a: PdReal; const b, c: PdReal; p, q, R: Integer); cdecl; external ODEDLL;
procedure dMultiply1(const a: PdReal; const b, c: PdReal; p, q, R: Integer); cdecl; external ODEDLL;
procedure dMultiply2(const a: PdReal; const b, c: PdReal; p, q, R: Integer); cdecl; external ODEDLL;
procedure dQMultiply0(var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply1(var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply2(var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply3(var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dRfromQ(var R: TdMatrix3; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dQfromR(var q: TdQuaternion; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dDQfromW(var dq: TdVector4; const w: TdVector3; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dNormalize3(var a: TdVector3); cdecl; external ODEDLL;
procedure dNormalize4(var a: TdVector4); cdecl; external ODEDLL;
procedure dClosestLineSegmentPoints(const a1, a2, b1, b2: TdVector3; var cp1, cp2: TdVector3); cdecl; external ODEDLL;
function dBoxTouchesBox(const _p1: TdVector3; const R1: TdMatrix3; const side1: TdVector3; const _p2: TdVector3; const R2: TdMatrix3; const side2: TdVector3): Integer; cdecl; external ODEDLL;
function dMaxDifference(a, b: PdReal; n, m: Integer): TdReal; cdecl; external ODEDLL;
procedure dMakeRandomVector(var n1: TdVector3; a: Integer; f: TdReal); cdecl; external ODEDLL;
function dAreConnected(a, b: PdxBody): Integer; cdecl; external ODEDLL;
function dAreConnectedExcluding(a, b: PdxBody; joint_type: TdJointTypeNumbers) : Integer; cdecl; external ODEDLL;
procedure dMakeRandomMatrix(a: PdRealArray; n, m: Integer; range: TdReal); cdecl; external ODEDLL;
procedure dClearUpperTriangle(a: PdRealArray; n: Integer); cdecl; external ODEDLL;
function dRandGetSeed: cardinal; cdecl; external ODEDLL;
procedure dRandSetSeed(const s: cardinal); cdecl; external ODEDLL;
function dRandInt(const n: Integer): Integer; cdecl; external ODEDLL;
function dRandReal: TdReal; cdecl; external ODEDLL;
function dTestRand: Integer; cdecl; external ODEDLL;
procedure dTestMatrixComparison; cdecl; external ODEDLL;
procedure dTestSolveLCP; cdecl; external ODEDLL;
function dDot(const a, b: TdVector3): TdReal; overload;
function dDot(const a, b: PdVector3): TdReal; overload;
function dDOT14(const a, b: TdRealArray): TdReal; overload;
function dDOT14(const a, b: PdRealArray): TdReal; overload;
procedure dMULTIPLY0_333(var a: TdMatrix3; const b, c: TdMatrix3);
procedure dMULTIPLY0_331(var a: TdVector3; const b: TdMatrix3; const c: TdVector3);
function Vector3ScalarMul(const a: TdVector3; const Scalar: TdReal): TdVector3;
function Vector3ADD(const a, b: TdVector3): TdVector3;
function Vector3SUB(const a, b: TdVector3): TdVector3;
function Vector3Length(const a: TdVector3): TdReal;
function Vector3Cross(const v1, v2: TdVector3): TdVector3;
function Vector3Make(const x, y, z: TdReal): TdVector3;
procedure VerifyDelphiODE(body: PdxBody; geom: PdxGeom);
function InitODE(ADllName: PChar): boolean;
procedure CloseODE;

Types

Pd3Axis = ˆTd3Axis;
PdContact = ˆTdContact;
PdContactGeom = ˆTdContactGeom;
PdGeomClass = ˆTdGeomClass;
PdInteger3 = ˆTdInteger3;
PdIntegerArray = ˆTdIntegerArray;
PdMass = ˆTdMass;
PdMatrix3 = ˆTdMatrix3;
PdMatrix3_As3x4 = ˆTdMatrix3_As3x4;
PdMatrix4 = ˆTdMatrix4;
PdMatrix6 = ˆTdMatrix6;
PdObject = ˆTdObject;
PdQuaternion = ˆTdQuaternion;
PdReal = ˆTdReal;
PdRealArray = ˆTdRealArray;
PdRealHugeArray = ˆTdRealHugeArray;
PdVector3 = ˆTdVector3;
PdVector3Array = ˆTdVector3Array;
PdVector4 = ˆTdVector4;
PdxBody = ˆTdxBody;
PdxGeom = ˆTdxGeom;
PdxHashSpace = ˆTdxHashSpace;
PdxHeightfieldData = ˆTdxHeightfieldData;
PdxJoint = ˆTdxJoint;
PdxJointBall = ˆTdxJointBall;
PdxJointGroup = ˆTdxJointGroup;
PdxJointHinge = ˆTdxJointHinge;
PdxJointHinge2 = ˆTdxJointHinge2;
PdxJointLimitMotor = ˆTdxJointLimitMotor;
PdxJointLimitMotor3 = ˆTdxJointLimitMotor3;
PdxJointNode = ˆTdxJointNode;
PdxJointPiston = ˆTdxJointPiston;
PdxJointPR = ˆTdxJointPR;
PdxJointSlider = ˆTdxJointSlider;
PdxJointUniversial = ˆTdxJointUniversial;
PdxPosR = ˆTdxPosR;
PdxSimpleSpace = ˆTdxSimpleSpace;
PdxSpace = ˆTdxSpace;
PdxTriMeshData = ˆTdxTriMeshData;
PdxWorld = ˆTdxWorld;
PPdObject = ˆPdObject;
PPdxGeom = ˆPdxGeom;
PTdJointFeedback = ˆTdJointFeedback;
TBodyFlags = Integer;
Td3Axis = array [0 .. 2] of TdVector3;
TdAABB = array [0 .. 5] of TdReal;
TdAABBTestFn = function(o1, o2: PdxGeom; const aabb2: TdAABB): Integer; cdecl;
TdAngularMotorModeNumbers = (...);
TdColliderFn = function(o1, o2: PdxGeom; flags: Integer; contact: PdContactGeom; skip: Integer): Integer; cdecl;
TdContactType = Integer;
TdErrorType = (...);
TdGeomDtorFn = procedure(o: PdxGeom); cdecl;
TdGetAABBFn = procedure(g: PdxGeom; var aabb: TdAABB); cdecl;
TdGetColliderFnFn = function(num: Integer): TdColliderFn; cdecl;
TdInteger3 = array [0 .. 2] of Integer;
TdIntegerArray = array [0 .. 65535] of Integer;
TdJointGroupID = PdxJointGroup;
TdJointID = PdxJoint;
TdJointTypeNumbers = (...);
TdMatrix3 = array [0 .. 4 * 3 - 1] of TdReal;
TdMatrix3_As3x4 = array [0 .. 2, 0 .. 3] of TdReal;
TdMatrix4 = array [0 .. 4 * 4 - 1] of TdReal;
TdMatrix6 = array [0 .. 8 * 6 - 1] of TdReal;
TdMovedCallback = procedure(o1: PdxGeom); cdecl;
TdNearCallback = procedure(data: pointer; o1, o2: PdxGeom); cdecl;
TdQuaternion = TdVector4;
TdReal = single;
TdRealArray = array [0 .. 15] of TdReal;
TdRealHugeArray = array [0 .. 65535] of TdReal;
TdTriArrayCallback = procedure(TriMesh, RefObject: PdxGeom; TriIndices: PIntegerArray; TriCount: Integer);
TdTriCallback = function(TriMesh, RefObject: PdxGeom; TriangleIndex: Integer): Integer;
TdTriRayCallback = function(TriMesh, Ray: PdxGeom; TriangleIndex: Integer; u, v: TdReal): Integer;
TdVector3 = array [0 .. 3] of TdReal;
TdVector3Array = array [0 .. 65535] of TdVector3;
TdVector4 = array [0 .. 3] of TdReal;
TdxJointLimitMotor3 = array [0 .. 2] of TdxJointLimitMotor;
TdxJointNull = TdxJoint;
TdxSimpleSpace = TdxSpace;
TJointFlag = Integer;
TJointParams = Integer;

Constants

ODEDLL = 'ode32s.dll';
TRIMESH_FACE_NORMALS = 0;
TRIMESH_LAST_TRANSFORMATION = 1;
CONTACTS_UNIMPORTANT = $80000000;
dJOINT_INGROUP: TJointFlag = 1;
dJOINT_REVERSE: TJointFlag = 2;
dJOINT_TWOBODIES: TJointFlag = 4;
dContactMu2: TdContactType = $0001;
dContactFDir1: TdContactType = $0002;
dContactBounce: TdContactType = $0004;
dContactSoftERP: TdContactType = $0008;
dContactSoftCFM: TdContactType = $0010;
dContactMotion1: TdContactType = $0020;
dContactMotion2: TdContactType = $0040;
dContactMotionN: TdContactType = $0080;
dContactSlip1: TdContactType = $0100;
dContactSlip2: TdContactType = $0200;
dContactApprox0: TdContactType = $0000;
dContactApprox1_1: TdContactType = $1000;
dContactApprox1_2: TdContactType = $2000;
dContactApprox1: TdContactType = $3000;
dxBodyFlagFiniteRotation: TBodyFlags = 1;
dxBodyFlagFiniteRotationAxis: TBodyFlags = 2;
dxBodyDisabled: TBodyFlags = 4;
dxBodyNoGravity: TBodyFlags = 8;
_priv_dParamLoStop = $000;
_priv_dParamLoStop2 = $100;
_priv_dParamLoStop3 = $200;
dParamLoStop: TJointParams = _priv_dParamLoStop;
dParamHiStop: TJointParams = _priv_dParamLoStop + 1;
dParamVel: TJointParams = _priv_dParamLoStop + 2;
dParamFMax: TJointParams = _priv_dParamLoStop + 3;
dParamFudgeFactor: TJointParams = _priv_dParamLoStop + 4;
dParamBounce: TJointParams = _priv_dParamLoStop + 5;
dParamCFM: TJointParams = _priv_dParamLoStop + 6;
dParamStopERP: TJointParams = _priv_dParamLoStop + 7;
dParamStopCFM: TJointParams = _priv_dParamLoStop + 8;
dParamSuspensionERP: TJointParams = _priv_dParamLoStop + 9;
dParamSuspensionCFM: TJointParams = _priv_dParamLoStop + 10;
dParamERP: TJointParams = _priv_dParamLoStop + 11;
dParamGroup1: TJointParams = $000;
dParamLoStop1: TJointParams = _priv_dParamLoStop;
dParamHiStop1: TJointParams = _priv_dParamLoStop + 1;
dParamVel1: TJointParams = _priv_dParamLoStop + 2;
dParamFMax1: TJointParams = _priv_dParamLoStop + 3;
dParamFudgeFactor1: TJointParams = _priv_dParamLoStop + 4;
dParamBounce1: TJointParams = _priv_dParamLoStop + 5;
dParamCFM1: TJointParams = _priv_dParamLoStop + 6;
dParamStopERP1: TJointParams = _priv_dParamLoStop + 7;
dParamStopCFM1: TJointParams = _priv_dParamLoStop + 8;
dParamSuspensionERP1: TJointParams = _priv_dParamLoStop + 9;
dParamSuspensionCFM1: TJointParams = _priv_dParamLoStop + 10;
dParamERP1: TJointParams = _priv_dParamLoStop + 11;
dParamGroup2: TJointParams = $100;
dParamLoStop2: TJointParams = _priv_dParamLoStop2;
dParamHiStop2: TJointParams = _priv_dParamLoStop2 + 1;
dParamVel2: TJointParams = _priv_dParamLoStop2 + 2;
dParamFMax2: TJointParams = _priv_dParamLoStop2 + 3;
dParamFudgeFactor2: TJointParams = _priv_dParamLoStop2 + 4;
dParamBounce2: TJointParams = _priv_dParamLoStop2 + 5;
dParamCFM2: TJointParams = _priv_dParamLoStop2 + 6;
dParamStopERP2: TJointParams = _priv_dParamLoStop2 + 7;
dParamStopCFM2: TJointParams = _priv_dParamLoStop2 + 8;
dParamSuspensionERP2: TJointParams = _priv_dParamLoStop2 + 9;
dParamSuspensionCFM2: TJointParams = _priv_dParamLoStop2 + 10;
dParamERP2: TJointParams = _priv_dParamLoStop2 + 11;
dParamGroup3: TJointParams = $200;
dParamLoStop3: TJointParams = _priv_dParamLoStop3;
dParamHiStop3: TJointParams = _priv_dParamLoStop3 + 1;
dParamVel3: TJointParams = _priv_dParamLoStop3 + 2;
dParamFMax3: TJointParams = _priv_dParamLoStop3 + 3;
dParamFudgeFactor3: TJointParams = _priv_dParamLoStop3 + 4;
dParamBounce3: TJointParams = _priv_dParamLoStop3 + 5;
dParamCFM3: TJointParams = _priv_dParamLoStop3 + 6;
dParamStopERP3: TJointParams = _priv_dParamLoStop3 + 7;
dParamStopCFM3: TJointParams = _priv_dParamLoStop3 + 8;
dParamSuspensionERP3: TJointParams = _priv_dParamLoStop3 + 9;
dParamSuspensionCFM3: TJointParams = _priv_dParamLoStop3 + 10;
dParamERP3: TJointParams = _priv_dParamLoStop3 + 11;
dParamGroup: TJointParams = $100;
MaxUserClasses = 4;

Variables

dSphereClass: Integer = 0;
dBoxClass: Integer = 1;
dCapsuleClass: Integer = 2;
dCylinderClass: Integer = 3;
dPlaneClass: Integer = 4;
dRayClass: Integer = 5;
dConvexClass: Integer = 6;
dGeomTransformClass: Integer = 7;
dTriMeshClass: Integer = 8;
dHeightFieldClass: Integer = 9;
dFirstSpaceClass: Integer = 10;
dSimpleSpaceClass: Integer = 10;
dHashSpaceClass: Integer = 11;
dSweepAndPruneSpaceClass: Integer = 12;
dQuadTreeSpaceClass: Integer = 13;
dLastSpaceClass: Integer = 13;
dFirstUserClass: Integer = 14;
dLastUserClass: Integer = 17;
dGeomNumClasses: Integer = 18;
IsODEInitialized: boolean = false;
DisabledDebugGeom: boolean = false;
DisabledDebugCollision: boolean = false;

Description

Functions and Procedures

procedure dInitODE; cdecl; external ODEDLL;

added by PAR

function dInitODE2(uiInitFlags: longword): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dCloseODE; cdecl; external ODEDLL;

This item has no description.

function dWorldCreate: PdxWorld; cdecl; external ODEDLL;

—– dWorld —–

procedure dWorldDestroy(const World: PdxWorld); cdecl; external ODEDLL;

This item has no description.

function dWorldGetCFM(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

function dWorldGetERP(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldGetGravity(const World: PdxWorld; var gravity: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dWorldImpulseToForce(const World: PdxWorld; const stepsize, ix, iy, iz: TdReal; var force: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetCFM(const World: PdxWorld; cfm: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetERP(const World: PdxWorld; erp: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetGravity(const World: PdxWorld; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetContactMaxCorrectingVel(const World: PdxWorld; const vel: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetContactMaxCorrectingVel(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetContactSurfaceLayer(const World: PdxWorld; const depth: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetContactSurfaceLayer(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldExportDIF(const World: PdxWorld; fileHandle: cardinal; const world_name: PAnsiChar); cdecl; external ODEDLL;

This item has no description.

function dWorldGetLinearDampingThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

Damping

procedure dWorldSetLinearDampingThreshold(const World: PdxWorld; const threshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAngularDampingThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAngularDampingThreshold(const World: PdxWorld; const threshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetLinearDamping(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetLinearDamping(const World: PdxWorld; const scale: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAngularDamping(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAngularDamping(const World: PdxWorld; const scale: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetDamping(const World: PdxWorld; const linear_scale, angular_scale: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetMaxAngularSpeed(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetMaxAngularSpeed(const World: PdxWorld; const max_speed: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dWorldStep(const World: PdxWorld; const stepsize: TdReal); cdecl; external ODEDLL;

Step

procedure dWorldQuickStep(const World: PdxWorld; const stepsize: TdReal); cdecl; external ODEDLL;

QuickStep

procedure dWorldSetQuickStepNumIterations(const World: PdxWorld; const num: Integer); cdecl; external ODEDLL;

This item has no description.

function dWorldGetQuickStepNumIterations(const World: PdxWorld): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetQuickStepW(const World: PdxWorld; const param: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetQuickStepW(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

function dWorldGetAutoDisableLinearAverageThreshold(const World: PdxWorld) : TdReal; cdecl; external ODEDLL;

Auto-disable functions

procedure dWorldSetAutoDisableLinearAverageThreshold(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAutoDisableAngularAverageThreshold(const World: PdxWorld) : TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAutoDisableAngularAverageThreshold(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAutoDisableAverageSamplesCount(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAutoDisableAverageSamplesCount(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAutoDisableLinearThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAutoDisableLinearThreshold(const World: PdxWorld; linThreshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAutoDisableAngularThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAutoDisableAngularThreshold(const World: PdxWorld; angThreshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAutoDisableSteps(const World: PdxWorld): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAutoDisableSteps(const World: PdxWorld; steps: Integer); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAutoDisableTime(const World: PdxWorld): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAutoDisableTime(const World: PdxWorld; time: TdReal); cdecl; external ODEDLL;

This item has no description.

function dWorldGetAutoDisableFlag(const World: PdxWorld): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dWorldSetAutoDisableFlag(const World: PdxWorld; do_auto_disable: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dBodyAddForce(const body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;

—– dBody —–

procedure dBodyAddForceAtPos(const body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodyAddForceAtRelPos(const body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodyAddRelForce(const body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodyAddRelForceAtPos(const body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodyAddRelForceAtRelPos(const body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodyAddRelTorque(const body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodyAddTorque(const body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;

This item has no description.

function dBodyCreate(const World: PdxWorld): PdxBody; cdecl; external ODEDLL;

This item has no description.

procedure dBodyDestroy(const body: PdxBody); cdecl; external ODEDLL;

This item has no description.

procedure dBodyDisable(const body: PdxBody); cdecl; external ODEDLL;

This item has no description.

procedure dBodyEnable(const body: PdxBody); cdecl; external ODEDLL;

This item has no description.

function dBodyGetAngularVel(const body: PdxBody): PdVector3; cdecl; external ODEDLL;

This item has no description.

procedure dBodyGetFiniteRotationAxis(const body: PdxBody; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

function dBodyGetFiniteRotationMode(const body: PdxBody): Integer; cdecl; external ODEDLL;

This item has no description.

function dBodyGetForce(const body: PdxBody): PdVector3; cdecl; external ODEDLL;

This item has no description.

function dBodyGetGravityMode(const body: PdxBody): Integer; cdecl; external ODEDLL;

This item has no description.

function dBodyGetJoint(const body: PdxBody; const index: Integer): TdJointID; cdecl; external ODEDLL;

This item has no description.

function dBodyGetLinearVel(const body: PdxBody): PdVector3; cdecl; external ODEDLL;

This item has no description.

procedure dBodyGetMass(const body: PdxBody; var mass: TdMass); cdecl; external ODEDLL;

This item has no description.

function dBodyGetNumJoints(const body: PdxBody): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dBodyGetPointVel(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dBodyGetPosRelPoint(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

function dBodyGetPosition(const body: PdxBody): PdVector3; cdecl; external ODEDLL;

This item has no description.

function dBodyGetQuaternion(const body: PdxBody): PdQuaternion; cdecl; external ODEDLL;

This item has no description.

procedure dBodyGetRelPointPos(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dBodyGetRelPointVel(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

function dBodyGetRotation(const body: PdxBody): PdMatrix3; cdecl; external ODEDLL;

This item has no description.

function dBodyGetTorque(const body: PdxBody): PdVector3; cdecl; external ODEDLL;

This item has no description.

function dBodyIsEnabled(const body: PdxBody): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAngularVel(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetFiniteRotationAxis(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetFiniteRotationMode(const body: PdxBody; const mode: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetForce(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetGravityMode(const body: PdxBody; const mode: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetLinearVel(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetMass(const body: PdxBody; const mass: PdMass); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetPosition(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetQuaternion(const body: PdxBody; const q: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetRotation(const body: PdxBody; const R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetTorque(const body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodyVectorFromWorld(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dBodyVectorToWorld(const body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetData(const body: PdxBody; data: pointer); cdecl; external ODEDLL;

This item has no description.

function dBodyGetData(const body: PdxBody): pointer; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetMovedCallback(const body: PdxBody; callback: TdMovedCallback); cdecl; external ODEDLL;

This item has no description.

procedure dBodyCopyPosition(const body: PdxBody; const pos: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dBodyCopyRotation(const body: PdxBody; const R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

procedure dBodyCopyQuaternion(const body: PdxBody; const quat: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetLinearDamping(const body: PdxBody; scale: TdReal); cdecl; external ODEDLL;

damping functions

function dBodyGetLinearDamping(const body: PdxBody): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAngularDamping(const body: PdxBody; scale: TdReal); cdecl; external ODEDLL;

This item has no description.

function dBodyGetAngularDamping(const body: PdxBody): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetDamping(const body: PdxBody; linear_scale, angular_scale: TdReal); cdecl; external ODEDLL;

This item has no description.

function dBodyGetLinearDampingThreshold(const body: PdxBody): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetLinearDampingThreshold(const body: PdxBody; threshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dBodyGetAngularDampingThreshold(const body: PdxBody): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAngularDampingThreshold(const body: PdxBody; threshold: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetDampingDefaults(const body: PdxBody; threshold: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetMaxAngularSpeed(const body: PdxBody; max_speed: TdReal); cdecl; external ODEDLL;

This item has no description.

function dBodyGetMaxAngularSpeed(const body: PdxBody): TdReal; cdecl; external ODEDLL;

This item has no description.

function dBodyGetAutoDisableLinearThreshold(const body: PdxBody): TdReal; cdecl; external ODEDLL;

Auto-disable functions

procedure dBodySetAutoDisableLinearThreshold(const body: PdxBody; linThreshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dBodyGetAutoDisableAngularThreshold(const body: PdxBody): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAutoDisableAngularThreshold(const body: PdxBody; angThreshold: TdReal); cdecl; external ODEDLL;

This item has no description.

function dBodyGetAutoDisableSteps(const body: PdxBody): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAutoDisableSteps(const body: PdxBody; steps: Integer); cdecl; external ODEDLL;

This item has no description.

function dBodyGetAutoDisableTime(const body: PdxBody): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAutoDisableTime(const body: PdxBody; time: TdReal); cdecl; external ODEDLL;

This item has no description.

function dBodyGetAutoDisableFlag(const body: PdxBody): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAutoDisableFlag(const body: PdxBody; do_auto_disable: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAutoDisableDefaults(const body: PdxBody); cdecl; external ODEDLL;

This item has no description.

procedure dBodySetAutoDisableAverageSamplesCount(const body: PdxBody; average_samples_count: longword); cdecl; external ODEDLL;

This item has no description.

procedure dJointGroupDestroy(const dJointGroupID: TdJointGroupID); cdecl; external ODEDLL;

—– dJoint —– normal joints

function dJointGroupCreate(const max_size: Integer): TdJointGroupID; cdecl; external ODEDLL;

This item has no description.

procedure dJointGroupEmpty(const dJointGroupID: TdJointGroupID); cdecl; external ODEDLL;

This item has no description.

procedure dJointAttach(const dJointID: TdJointID; const body1, body2: PdxBody); cdecl; external ODEDLL;

This item has no description.

procedure dJointDestroy(const dJointID: TdJointID); cdecl; external ODEDLL;

This item has no description.

function dJointGetData(const dJointID: TdJointID): pointer; cdecl; external ODEDLL;

This item has no description.

procedure dJointSetData(const dJointID: TdJointID; data: pointer); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetFeedback(const dJointID: TdJointID; Feedback: PTdJointFeedback); cdecl; external ODEDLL;

callback routines for feedback of joints

function dJointGetFeedback(const dJointID: TdJointID): PTdJointFeedback; cdecl; external ODEDLL;

This item has no description.

function dJointGetType(const dJointID: TdJointID): Integer; cdecl; external ODEDLL;

This item has no description.

function dJointGetBody(const dJointID: TdJointID; const index: Integer) : PdxBody; cdecl; external ODEDLL;

This item has no description.

function dJointCreateContact(const World: PdxWorld; dJointGroupID: TdJointGroupID; const dContact: PdContact): TdJointID; cdecl; external ODEDLL;

Contact

function dJointCreateAMotor(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;

AMotor

procedure dJointSetAMotorAngle(const dJointID: TdJointID; const anum: Integer; const angle: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetAMotorAngle(const dJointID: TdJointID; const anum: Integer) : TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dJointSetAMotorAxis(const dJointID: TdJointID; const anum, rel: Integer; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetAMotorAxis(const dJointID: TdJointID; const anum: Integer; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetAMotorNumAxes(const dJointID: TdJointID; const num: Integer); cdecl; external ODEDLL;

This item has no description.

function dJointGetAMotorNumAxes(const dJointID: TdJointID): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dJointSetAMotorParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetAMotorParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dJointSetAMotorMode(const dJointID: TdJointID; const mode: TdAngularMotorModeNumbers); cdecl; external ODEDLL;

This item has no description.

function dJointGetAMotorMode(const dJointID: TdJointID): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dJointAddAMotorTorques(const dJointID: TdJointID; torque1, torque2, torque3: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetAMotorAngleRate(const dJointID: TdJointID; const anum: Integer): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetAMotorAxisRel(const dJointID: TdJointID; const anum: Integer) : Integer; cdecl; external ODEDLL;

This item has no description.

function dJointCreateLMotor(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;

LMotor

procedure dJointSetLMotorAxis(const dJointID: TdJointID; const anum, rel: Integer; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetLMotorAxis(const dJointID: TdJointID; const anum: Integer; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetLMotorNumAxes(const dJointID: TdJointID; const num: Integer); cdecl; external ODEDLL;

This item has no description.

function dJointGetLMotorNumAxes(const dJointID: TdJointID): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dJointSetLMotorParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetLMotorParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointCreateBall(const World: PdxWorld; dJointGroupID: TdJointGroupID) : TdJointID; cdecl; external ODEDLL;

Ball

procedure dJointSetBallAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetBallAnchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetBallAnchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

function dJointCreateHinge(const World: PdxWorld; dJointGroupID: TdJointGroupID) : TdJointID; cdecl; external ODEDLL;

Hinge

procedure dJointSetHingeAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetHingeAnchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetHingeAnchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetHingeAxis(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetHingeAxis(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetHingeParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetHingeParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetHingeAngle(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetHingeAngleRate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dJointAddHingeTorque(const dJointID: TdJointID; torque: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointCreateHinge2(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;

Hinge2

procedure dJointSetHinge2Anchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetHinge2Anchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetHinge2Anchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetHinge2Axis1(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetHinge2Axis1(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetHinge2Axis2(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetHinge2Axis2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetHinge2Param(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetHinge2Param(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetHinge2Angle1(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetHinge2Angle1Rate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetHinge2Angle2Rate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dJointAddHinge2Torques(const dJointID: TdJointID; torque1, torque2: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointCorrectHinge2(const dJointID: TdJointID); cdecl; external ODEDLL;

This item has no description.

function dJointCreateSlider(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;

Slider

procedure dJointSetSliderAxis(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetSliderAxis(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetSliderParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetSliderParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetSliderPosition(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetSliderPositionRate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dJointAddSliderForce(const dJointID: TdJointID; force: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointCreateUniversal(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;

Universal

procedure dJointGetUniversalAnchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetUniversalAnchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetUniversalAxis1(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetUniversalAxis1(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetUniversalAxis2(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetUniversalAxis2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetUniversalParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetUniversalParam(const dJointID: TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetUniversalAngle1(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetUniversalAngle2(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetUniversalAngle1Rate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetUniversalAngle2Rate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dJointSetUniversalAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointAddUniversalTorques(const dJointID: TdJointID; torque1, torque2: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointCreateFixed(const World: PdxWorld; dJointGroupID: TdJointGroupID) : TdJointID; cdecl; external ODEDLL;

Fixed

procedure dJointSetFixed(const dJointID: TdJointID); cdecl; external ODEDLL;

This item has no description.

function dJointCreatePlane2D(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;

Plane2D

procedure dJointSetPlane2DXParam(const dJointID: TdJointID; const parameter: Integer; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetPlane2DYParam(const dJointID: TdJointID; const parameter: Integer; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetPlane2DAngleParam(const dJointID: TdJointID; const parameter: Integer; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointCreatePR(const World: PdxWorld; dJointGroupID: TdJointGroupID) : TdJointID; cdecl; external ODEDLL;

PR

procedure dJointSetPRAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetPRAxis1(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetPRAxis1(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetPRAxis2(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetPRAxis2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetPRParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetPRParam(const dJointID: TdJointID; parameter: Integer) : TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dJointAddPRTorque(const dJointID: TdJointID; torque: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointCreatePiston(const World: PdxWorld; dJointGroupID: TdJointGroupID): TdJointID; cdecl; external ODEDLL;

Piston

procedure dJointSetPistonAnchor(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetPistonAnchor(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetPistonAnchor2(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetPistonAxis(const dJointID: TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointGetPistonAxis(const dJointID: TdJointID; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dJointSetPistonParam(const dJointID: TdJointID; const parameter: TJointParams; const Value: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetPistonParam(const dJointID: TdJointID; parameter: Integer) : TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dJointSetPistonAxisDelta(const dJointID: TdJointID; const x, y, z, ax, ay, az: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dJointAddPistonForce(const dJointID: TdJointID; force: TdReal); cdecl; external ODEDLL;

This item has no description.

function dJointGetPistonPosition(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetPistonAngle(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetPistonAngleRate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dJointGetPistonRate(const dJointID: TdJointID): TdReal; cdecl; external ODEDLL;

This item has no description.

function dCreateGeom(classnum: Integer): PdxGeom; cdecl; external ODEDLL;

—– dGeom —–

procedure dGeomDestroy(const geom: PdxGeom); cdecl; external ODEDLL;

This item has no description.

function dCreateGeomClass(const classptr: TdGeomClass): Integer; cdecl; external ODEDLL;

This item has no description.

function dGeomGetClass(const geom: PdxGeom): Integer; cdecl; external ODEDLL;

This item has no description.

function dGeomGetClassData(o: PdxGeom): pointer; cdecl; external ODEDLL;

This item has no description.

function dGeomGetSpace(const geom: PdxGeom): PdxSpace; cdecl; external ODEDLL;

This item has no description.

function dGeomIsSpace(const geom: PdxGeom): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetBody(const geom: PdxGeom; body: PdxBody); cdecl; external ODEDLL;

This item has no description.

function dGeomGetBody(const geom: PdxGeom): PdxBody; cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetPosition(const geom: PdxGeom; const x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

function dGeomGetPosition(const geom: PdxGeom): PdVector3; cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetRotation(const geom: PdxGeom; const R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

function dGeomGetRotation(const geom: PdxGeom): PdMatrix3; cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetQuaternion(const geom: PdxGeom; const TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dGeomGetQuaternion(const geom: PdxGeom; var result: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dGeomCopyPosition(const geom: PdxGeom; const pos: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dGeomCopyRotation(const geom: PdxGeom; const R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

procedure dGeomCopyQuaternion(const geom: PdxGeom; const quat: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetData(const geom: PdxGeom; data: pointer); cdecl; external ODEDLL;

This item has no description.

function dGeomGetData(const geom: PdxGeom): pointer; cdecl; external ODEDLL;

This item has no description.

procedure dGeomEnable(const geom: PdxGeom); cdecl; external ODEDLL;

This item has no description.

procedure dGeomDisable(const geom: PdxGeom); cdecl; external ODEDLL;

This item has no description.

function dGeomIsEnabled(const geom: PdxGeom): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dGeomGetAABB(const geom: PdxGeom; var aabb: TdAABB); cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetCategoryBits(const geom: PdxGeom; bits: cardinal); cdecl; external ODEDLL;

This item has no description.

function dGeomGetCategoryBits(const geom: PdxGeom): cardinal; cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetCollideBits(const geom: PdxGeom; bits: cardinal); cdecl; external ODEDLL;

This item has no description.

function dGeomGetCollideBits(const geom: PdxGeom): cardinal; cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetOffsetPosition(const geom: PdxGeom; x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

function dGeomGetOffsetPosition(const geom: PdxGeom): PdVector3; cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetOffsetRotation(const geom: PdxGeom; R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

function dGeomGetOffsetRotation(const geom: PdxGeom): PdVector3; cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetOffsetQuaternion(const geom: PdxGeom; const q: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dGeomGetOffsetQuaternion(const geom: PdxGeom; var q: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dGeomClearOffset(const geom: PdxGeom); cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetOffsetWorldPosition(const geom: PdxGeom; x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetOffsetWorldRotation(const geom: PdxGeom; R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

procedure dGeomSetOffsetWorldQuaternion(const geom: PdxGeom; const q: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dGeomCopyOffsetPosition(const geom: PdxGeom; var pos: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dGeomCopyOffsetRotation(const geom: PdxGeom; var R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

procedure dGeomIsOffset(const geom: PdxGeom); cdecl; external ODEDLL;

This item has no description.

function dCreateGeomTransform(const Space: PdxSpace): PdxGeom; cdecl; external ODEDLL;

Transform

procedure dGeomTransformSetGeom(const geom, obj: PdxGeom); cdecl; external ODEDLL;

This item has no description.

function dGeomTransformGetGeom(const geom: PdxGeom): PdxGeom; cdecl; external ODEDLL;

This item has no description.

procedure dGeomTransformSetInfo(const geom: PdxGeom; mode: Integer); cdecl; external ODEDLL;

This item has no description.

function dGeomTransformGetInfo(const geom: PdxGeom): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dGeomTransformSetCleanup(const geom: PdxGeom; const mode: Integer); cdecl; external ODEDLL;

This item has no description.

function dGeomTransformGetCleanup(const geom: PdxGeom): Integer; cdecl; external ODEDLL;

This item has no description.

function dCreateBox(const Space: PdxSpace; const lx, ly, lz: TdReal): PdxGeom; cdecl; external ODEDLL;

Box

procedure dGeomBoxGetLengths(const geom: PdxGeom; var result: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dGeomBoxSetLengths(const geom: PdxGeom; const lx, ly, lz: TdReal); cdecl; external ODEDLL;

This item has no description.

function dGeomBoxPointDepth(const geom: PdxGeom; const x, y, z: TdReal): TdReal; cdecl; external ODEDLL;

This item has no description.

function dCreateCylinder(const Space: PdxSpace; R, lz: TdReal): PdxGeom; cdecl; external ODEDLL;

dCylinder (not a capped cylinder).

procedure dGeomCylinderSetParams(const geom: PdxGeom; radius, length: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dGeomCylinderGetParams(const geom: PdxGeom; var radius, length: TdReal); cdecl; external ODEDLL;

This item has no description.

function dCreateCapsule(const Space: PdxSpace; const radius, length: TdReal) : PdxGeom; cdecl; external ODEDLL;

dCapsule (a capped cylinder).

procedure dGeomCapsuleSetParams(const geom: PdxGeom; const radius, length: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dGeomCapsuleGetParams(const geom: PdxGeom; var radius, length: TdReal); cdecl; external ODEDLL;

This item has no description.

function dGeomCapsulePointDepth(const geom: PdxGeom; const x, y, z: TdReal) : TdReal; cdecl; external ODEDLL;

This item has no description.

function dCreatePlane(const Space: PdxSpace; const a, b, c, d: TdReal): PdxGeom; cdecl; external ODEDLL;

Plane

procedure dGeomPlaneSetParams(const geom: PdxGeom; const a, b, c, d: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dGeomPlaneGetParams(const geom: PdxGeom; var result: TdVector4); cdecl; external ODEDLL;

This item has no description.

function dGeomPlanePointDepth(const geom: PdxGeom; const x, y, z: TdReal) : TdReal; cdecl; external ODEDLL;

This item has no description.

function dCreateSphere(const Space: PdxSpace; const radius: TdReal): PdxGeom; cdecl; external ODEDLL;

Sphere

procedure dGeomSphereSetRadius(const geom: PdxGeom; const radius: TdReal); cdecl; external ODEDLL;

This item has no description.

function dGeomSphereGetRadius(const geom: PdxGeom): TdReal; cdecl; external ODEDLL;

This item has no description.

function dGeomSpherePointDepth(const geom: PdxGeom; const x, y, z: TdReal) : TdReal; cdecl; external ODEDLL;

This item has no description.

function dCreateConvex(const Space: PdxSpace; _planes: PdReal; _planecount: longword; _points: PdReal; _pointcount: longword; const _polygons: longword): PdxGeom; cdecl; external ODEDLL;

Convex

procedure dGeomSetConvex(const geom: PdxGeom; _planes: PdReal; _planecount: longword; _points: PdReal; _pointcount: longword; const _polygons: longword); cdecl; external ODEDLL;

This item has no description.

function dCreateHeightfield(const Space: PdxSpace; data: PdxHeightfieldData; bPlaceable: Integer): PdxGeom; cdecl; external ODEDLL;

Heightfield (incomplete)

function dGeomHeightfieldDataCreate: PdxHeightfieldData; cdecl; external ODEDLL;

This item has no description.

procedure dGeomHeightfieldDataDestroy(data: PdxHeightfieldData); cdecl; external ODEDLL;

This item has no description.

procedure dGeomHeightfieldSetHeightfieldData(const geom: PdxGeom; data: PdxHeightfieldData); cdecl; external ODEDLL;

This item has no description.

function dGeomHeightfieldGetHeightfieldData(const geom: PdxGeom) : PdxHeightfieldData; cdecl; external ODEDLL;

This item has no description.

function dGeomHeightfieldDataSetBounds(data: PdxHeightfieldData; minHeight, MaxHeight: TdReal): TdReal; cdecl; external ODEDLL;

This item has no description.

function dCreateRay(const Space: PdxSpace; length: TdReal): PdxGeom; cdecl; external ODEDLL;

dRay

procedure dGeomRaySet(const geom: PdxGeom; px, py, pz, dx, dy, dz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dGeomRayGet(const geom: PdxGeom; var start, dir: TdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dGeomRaySetLength(const geom: PdxGeom; length: TdReal); cdecl; external ODEDLL;

This item has no description.

function dGeomRayGetLength(const geom: PdxGeom): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dGeomRaySetParams(const geom: PdxGeom; FirstContact, BackfacCull: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomRayGetParams(const geom: PdxGeom; var FirstContact, BackfacCull: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomRaySetClosestHit(const geom: PdxGeom; closestHit: Integer); cdecl; external ODEDLL;

This item has no description.

function dGeomRayGetClosestHit(const geom: PdxGeom): Integer; cdecl; external ODEDLL;

This item has no description.

function dCreateTriMesh(const Space: PdxSpace; data: PdxTriMeshData; callback: TdTriCallback; ArrayCallback: TdTriArrayCallback; RayCallback: TdTriRayCallback): PdxGeom; cdecl; external ODEDLL;

TriMesh

procedure dGeomTriMeshSetData(g: PdxGeom; data: PdxTriMeshData); cdecl; external ODEDLL;

This item has no description.

function dGeomTriMeshGetData(g: PdxGeom): PdxTriMeshData; cdecl; external ODEDLL;

This item has no description.

function dGeomTriMeshGetTriMeshDataID(g: PdxGeom): PdxTriMeshData; cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataUpdate(g: PdxTriMeshData); cdecl; external ODEDLL;

This item has no description.

function dGeomTriMeshIsTCEnabled(g: PdxGeom; geomClass: Integer): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshEnableTC(g: PdxGeom; geomClass, enable: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshClearTCCache(g: PdxGeom); cdecl; external ODEDLL;

This item has no description.

function dGeomTriMeshGetTriangleCount(g: PdxGeom): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshGetTriangle(g: PdxGeom; index: Integer; v0, v1, v2: PdVector3); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshGetPoint(g: PdxGeom; index: Integer; u, v: TdReal; result: TdVector3); cdecl; external ODEDLL;

This item has no description.

function dGeomTriMeshGetArrayCallback(g: PdxGeom): pointer; cdecl; external ODEDLL;

This item has no description.

function dGeomTriMeshGetRayCallback(g: PdxGeom): pointer; cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshSetArrayCallback(g: PdxGeom; ArrayCallback: pointer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshSetRayCallback(g: PdxGeom; RayCallback: pointer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshSetCallback(g: PdxGeom; callback: pointer); cdecl; external ODEDLL;

This item has no description.

function dGeomTriMeshGetCallback(g: PdxGeom): pointer; cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataDestroy(g: PdxTriMeshData); cdecl; external ODEDLL;

This item has no description.

function dGeomTriMeshDataCreate: PdxTriMeshData; cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataSet(g: PdxTriMeshData; data_id: Integer; data: pointer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataBuildSimple(g: PdxTriMeshData; Vertices: PdVector3Array; VertexCount: Integer; Indices: PdIntegerArray; IndexCount: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataBuildSimple1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexCount: Integer; Indices: PdIntegerArray; IndexCount: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataBuildDouble(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataBuildDouble1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataBuildSingle(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dGeomTriMeshDataBuildSingle1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;

This item has no description.

procedure dInfiniteAABB(geom: PdxGeom; var aabb: TdAABB); cdecl; external ODEDLL;

This item has no description.

procedure dSpaceDestroy(const Space: PdxSpace); cdecl; external ODEDLL;

—– dSpace —–

function dSimpleSpaceCreate(Space: PdxSpace): PdxSpace; cdecl; external ODEDLL;

This item has no description.

function dHashSpaceCreate(Space: PdxSpace): PdxSpace; cdecl; external ODEDLL;

This item has no description.

function dQuadTreeSpaceCreate(const Space: PdxSpace; const Center, Extents: TdVector3; const depth: Integer): PdxSpace; cdecl; external ODEDLL;

This item has no description.

procedure dSpaceAdd(const Space: PdxSpace; const geom: PdxGeom); cdecl; external ODEDLL;

This item has no description.

procedure dSpaceRemove(const Space: PdxSpace; const geom: PdxGeom); cdecl; external ODEDLL;

This item has no description.

procedure dSpaceClean(const Space: PdxSpace); cdecl; external ODEDLL;

This item has no description.

function dSpaceQuery(const Space: PdxSpace; const geom: PdxGeom): Integer; cdecl; external ODEDLL;

This item has no description.

function dSpaceGetNumGeoms(const Space: PdxSpace): Integer; cdecl; external ODEDLL;

This item has no description.

function dSpaceGetGeom(const Space: PdxSpace; const I: Integer): PdxGeom; cdecl; external ODEDLL;

This item has no description.

procedure dHashSpaceSetLevels(const Space: PdxSpace; const minlevel, maxlevel: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dHashSpaceGetLevels(const Space: PdxSpace; var minlevel, maxlevel: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dSpaceSetCleanup(Space: PdxSpace; const mode: Integer); cdecl; external ODEDLL;

This item has no description.

function dSpaceGetCleanup(Space: PdxSpace): Integer; cdecl; external ODEDLL;

This item has no description.

function dCollide(o1, o2: PdxGeom; flags: Integer; var contact: TdContactGeom; skip: Integer): Integer; cdecl; external ODEDLL;

This item has no description.

procedure dSpaceCollide(const Space: PdxSpace; data: pointer; callback: TdNearCallback); cdecl; external ODEDLL;

This item has no description.

procedure dSpaceCollide2(o1, o2: PdxGeom; data: pointer; callback: TdNearCallback); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetParameters(var m: TdMass; themass, cgx, cgy, cgz, I11, I22, I33, I12, I13, I23: TdReal); cdecl; external ODEDLL;

—– dMass —–

procedure dMassAdd(var a, b: TdMass); cdecl; external ODEDLL;

This item has no description.

procedure dMassAdjust(var m: TdMass; newmass: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassTranslate(var m: TdMass; x, y, z: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassRotate(var m: TdMass; var R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetZero(var m: TdMass); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetBox(var m: TdMass; density, lx, ly, lz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetBoxTotal(var m: TdMass; total_mass, lx, ly, lz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetCylinder(var m: TdMass; density: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetCylinderTotal(var m: TdMass; total_mass: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetCapsule(var m: TdMass; density: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetCapsuleTotal(var m: TdMass; total_mass: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetSphere(var m: TdMass; density, radius: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetSphereTotal(var m: TdMass; total_mass, radius: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetTrimesh(var m: TdMass; density: TdReal; TriMesh: PdxGeom); cdecl; external ODEDLL;

This item has no description.

procedure dMassSetTrimeshTotal(var m: TdMass; total_mass: TdReal; TriMesh: PdxGeom); cdecl; external ODEDLL;

This item has no description.

procedure dQFromAxisAndAngle(var q: TdQuaternion; const ax, ay, az, angle: TdReal); cdecl; external ODEDLL;

—– Rotation.h —–

procedure dRFromAxisAndAngle(var R: TdMatrix3; const ax, ay, az, angle: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dRSetIdentity(var R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

procedure dQSetIdentity(var q: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dRFromEulerAngles(var R: TdMatrix3; const phi, theta, psi: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dRFrom2Axes(var R: TdMatrix3; const ax, ay, az, bx, by, bz: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dRFromZAxis(var R: TdMatrix3; const ax, ay, az: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dMultiply0(const a: PdReal; const b, c: PdReal; p, q, R: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dMultiply1(const a: PdReal; const b, c: PdReal; p, q, R: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dMultiply2(const a: PdReal; const b, c: PdReal; p, q, R: Integer); cdecl; external ODEDLL;

This item has no description.

procedure dQMultiply0(var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dQMultiply1(var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dQMultiply2(var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dQMultiply3(var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dRfromQ(var R: TdMatrix3; const q: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dQfromR(var q: TdQuaternion; const R: TdMatrix3); cdecl; external ODEDLL;

This item has no description.

procedure dDQfromW(var dq: TdVector4; const w: TdVector3; const q: TdQuaternion); cdecl; external ODEDLL;

This item has no description.

procedure dNormalize3(var a: TdVector3); cdecl; external ODEDLL;

—– Math —–

procedure dNormalize4(var a: TdVector4); cdecl; external ODEDLL;

This item has no description.

procedure dClosestLineSegmentPoints(const a1, a2, b1, b2: TdVector3; var cp1, cp2: TdVector3); cdecl; external ODEDLL;

—– Misc —–

function dBoxTouchesBox(const _p1: TdVector3; const R1: TdMatrix3; const side1: TdVector3; const _p2: TdVector3; const R2: TdMatrix3; const side2: TdVector3): Integer; cdecl; external ODEDLL;

This item has no description.

function dMaxDifference(a, b: PdReal; n, m: Integer): TdReal; cdecl; external ODEDLL;

This item has no description.

procedure dMakeRandomVector(var n1: TdVector3; a: Integer; f: TdReal); cdecl; external ODEDLL;

This item has no description.

function dAreConnected(a, b: PdxBody): Integer; cdecl; external ODEDLL;

This item has no description.

function dAreConnectedExcluding(a, b: PdxBody; joint_type: TdJointTypeNumbers) : Integer; cdecl; external ODEDLL;

This item has no description.

procedure dMakeRandomMatrix(a: PdRealArray; n, m: Integer; range: TdReal); cdecl; external ODEDLL;

This item has no description.

procedure dClearUpperTriangle(a: PdRealArray; n: Integer); cdecl; external ODEDLL;

This item has no description.

function dRandGetSeed: cardinal; cdecl; external ODEDLL;

This item has no description.

procedure dRandSetSeed(const s: cardinal); cdecl; external ODEDLL;

This item has no description.

function dRandInt(const n: Integer): Integer; cdecl; external ODEDLL;

This item has no description.

function dRandReal: TdReal; cdecl; external ODEDLL;

This item has no description.

function dTestRand: Integer; cdecl; external ODEDLL;

return 1 if the random number generator is working.

procedure dTestMatrixComparison; cdecl; external ODEDLL;

This item has no description.

procedure dTestSolveLCP; cdecl; external ODEDLL;

This item has no description.

function dDot(const a, b: TdVector3): TdReal; overload;

—– Recreated —–

function dDot(const a, b: PdVector3): TdReal; overload;

This item has no description.

function dDOT14(const a, b: TdRealArray): TdReal; overload;

This item has no description.

function dDOT14(const a, b: PdRealArray): TdReal; overload;

This item has no description.

procedure dMULTIPLY0_333(var a: TdMatrix3; const b, c: TdMatrix3);

This item has no description.

procedure dMULTIPLY0_331(var a: TdVector3; const b: TdMatrix3; const c: TdVector3);

This item has no description.

function Vector3ScalarMul(const a: TdVector3; const Scalar: TdReal): TdVector3;

This item has no description.

function Vector3ADD(const a, b: TdVector3): TdVector3;

This item has no description.

function Vector3SUB(const a, b: TdVector3): TdVector3;

This item has no description.

function Vector3Length(const a: TdVector3): TdReal;

This item has no description.

function Vector3Cross(const v1, v2: TdVector3): TdVector3;

This item has no description.

function Vector3Make(const x, y, z: TdReal): TdVector3;

This item has no description.

procedure VerifyDelphiODE(body: PdxBody; geom: PdxGeom);

This item has no description.

function InitODE(ADllName: PChar): boolean;

These are made public in the dynamic version MRQZZZ

procedure CloseODE;

This item has no description.

Types

Pd3Axis = ˆTd3Axis;

This item has no description.

PdContact = ˆTdContact;

This item has no description.

PdContactGeom = ˆTdContactGeom;

This item has no description.

PdGeomClass = ˆTdGeomClass;

This item has no description.

PdInteger3 = ˆTdInteger3;

This item has no description.

PdIntegerArray = ˆTdIntegerArray;

This item has no description.

PdMass = ˆTdMass;

This item has no description.

PdMatrix3 = ˆTdMatrix3;

This item has no description.

PdMatrix3_As3x4 = ˆTdMatrix3_As3x4;

This item has no description.

PdMatrix4 = ˆTdMatrix4;

This item has no description.

PdMatrix6 = ˆTdMatrix6;

This item has no description.

PdObject = ˆTdObject;

This item has no description.

PdQuaternion = ˆTdQuaternion;

array[0..3] of TdReal;

PdReal = ˆTdReal;

This item has no description.

PdRealArray = ˆTdRealArray;

This item has no description.

PdRealHugeArray = ˆTdRealHugeArray;

This item has no description.

PdVector3 = ˆTdVector3;

Q: Why isn't TdVector3 = array[0..2] of TdReal? A: Because of SIMD alignment.

PdVector3Array = ˆTdVector3Array;

This item has no description.

PdVector4 = ˆTdVector4;

This item has no description.

PdxBody = ˆTdxBody;

This item has no description.

PdxGeom = ˆTdxGeom;

This item has no description.

PdxHashSpace = ˆTdxHashSpace;

//currently the space 'container' is just a list of the geoms in the space. struct dxHashSpace : public dxSpace { dxGeom *first; int global_minlevel; // smallest hash table level to put AABBs in int global_maxlevel; // objects that need a level larger than this will be // put in a "big objects" list instead of a hash table void destroy(); void add (dGeomID); void remove (dGeomID); void collide (void *data, dNearCallback *callback); int query (dGeomID); };

PdxHeightfieldData = ˆTdxHeightfieldData;

This item has no description.

PdxJoint = ˆTdxJoint;

This item has no description.

PdxJointBall = ˆTdxJointBall;

This item has no description.

PdxJointGroup = ˆTdxJointGroup;

Pointers to internal ODE structures to reproduce C++ classes in Delphi

PdxJointHinge = ˆTdxJointHinge;

This item has no description.

PdxJointHinge2 = ˆTdxJointHinge2;

This item has no description.

PdxJointLimitMotor = ˆTdxJointLimitMotor;

This item has no description.

PdxJointLimitMotor3 = ˆTdxJointLimitMotor3;

This item has no description.

PdxJointNode = ˆTdxJointNode;

This item has no description.

PdxJointPiston = ˆTdxJointPiston;

This item has no description.

PdxJointPR = ˆTdxJointPR;

This item has no description.

PdxJointSlider = ˆTdxJointSlider;

This item has no description.

PdxJointUniversial = ˆTdxJointUniversial;

This item has no description.

PdxPosR = ˆTdxPosR;

position vector and rotation matrix for geometry objects that are not connected to bodies.

PdxSimpleSpace = ˆTdxSimpleSpace;

//simple space - reports all nˆ2 object intersections struct dxSimpleSpace : public dxSpace { dGeomID first; void destroy(); void add (dGeomID); void remove (dGeomID); void collide (void *data, dNearCallback *callback); int query (dGeomID); };

PdxSpace = ˆTdxSpace;

struct dxSpace : public dBase { int type; // don't want to use RTTI virtual void destroy()=0; virtual void add (dGeomID)=0; virtual void remove (dGeomID)=0; virtual void collide (void *data, dNearCallback *callback)=0; virtual int query (dGeomID)=0; };

PdxTriMeshData = ˆTdxTriMeshData;

This item has no description.

PdxWorld = ˆTdxWorld;

This item has no description.

PPdObject = ˆPdObject;

This item has no description.

PPdxGeom = ˆPdxGeom;

This item has no description.

PTdJointFeedback = ˆTdJointFeedback;

This item has no description.

TBodyFlags = Integer;

Change: New Type added, syntax enforcement

Td3Axis = array [0 .. 2] of TdVector3;

This item has no description.

TdAABB = array [0 .. 5] of TdReal;

No typedef for AABB

TdAABBTestFn = function(o1, o2: PdxGeom; const aabb2: TdAABB): Integer; cdecl;

This item has no description.

TdAngularMotorModeNumbers = (...);

This item has no description.

Values
  • dAMotorUser
  • dAMotorEuler
TdColliderFn = function(o1, o2: PdxGeom; flags: Integer; contact: PdContactGeom; skip: Integer): Integer; cdecl;

This item has no description.

TdContactType = Integer;

Change: New Type added, syntax enforcement

TdErrorType = (...);

This item has no description.

Values
  • d_ERR_UNKNOWN
  • d_ERR_IASSERT: unknown error
  • d_ERR_UASSERT: user assertion failed */
  • d_ERR_LCP: user assertion failed */
TdGeomDtorFn = procedure(o: PdxGeom); cdecl;

This item has no description.

TdGetAABBFn = procedure(g: PdxGeom; var aabb: TdAABB); cdecl;

This item has no description.

TdGetColliderFnFn = function(num: Integer): TdColliderFn; cdecl;

This item has no description.

TdInteger3 = array [0 .. 2] of Integer;

This item has no description.

TdIntegerArray = array [0 .. 65535] of Integer;

Tri-list collider

TdJointGroupID = PdxJointGroup;

This item has no description.

TdJointID = PdxJoint;

This item has no description.

TdJointTypeNumbers = (...);

This item has no description.

Values
  • dJointTypeNone
  • dJointTypeBall: or "unknown"
  • dJointTypeHinge
  • dJointTypeSlider
  • dJointTypeContact
  • dJointTypeUniversal
  • dJointTypeHinge2
  • dJointTypeFixed
  • dJointTypeNull
  • dJointTypeAMotor
  • dJointTypeLMotor
  • dJointTypePlane2D
  • dJointTypePR
  • dJointTypePU
  • dJointTypePiston
TdMatrix3 = array [0 .. 4 * 3 - 1] of TdReal;

typedef dReal dMatrix3[4*3];

TdMatrix3_As3x4 = array [0 .. 2, 0 .. 3] of TdReal;

This item has no description.

TdMatrix4 = array [0 .. 4 * 4 - 1] of TdReal;

typedef dReal dMatrix4[4*4];

TdMatrix6 = array [0 .. 8 * 6 - 1] of TdReal;

typedef dReal dMatrix6[8*6];

TdMovedCallback = procedure(o1: PdxGeom); cdecl;

Whenever a body has its position or rotation changed during the timestep, the callback will be called (with body as the argument). Use it to know which body may need an update in an external structure (like a 3D engine).

TdNearCallback = procedure(data: pointer; o1, o2: PdxGeom); cdecl;

Collission callback structure

TdQuaternion = TdVector4;

typedef dReal dQuaternion[4];

TdReal = single;

body is not influenced by gravity

TdRealArray = array [0 .. 15] of TdReal;

This item has no description.

TdRealHugeArray = array [0 .. 65535] of TdReal;

This item has no description.

TdTriArrayCallback = procedure(TriMesh, RefObject: PdxGeom; TriIndices: PIntegerArray; TriCount: Integer);

Per object callback. Allows the user to get the list of triangles in 1 shot. Maybe we should remove this one.

TdTriCallback = function(TriMesh, RefObject: PdxGeom; TriangleIndex: Integer): Integer;

Per triangle callback. Allows the user to say if he wants a collision with a particular triangle.

TdTriRayCallback = function(TriMesh, Ray: PdxGeom; TriangleIndex: Integer; u, v: TdReal): Integer;

Allows the user to say if a ray collides with a triangle on barycentric coords. The user can for example sample a texture with alpha transparency to determine if a collision should occur.

TdVector3 = array [0 .. 3] of TdReal;

typedef dReal dVector33[4];

TdVector3Array = array [0 .. 65535] of TdVector3;

This item has no description.

TdVector4 = array [0 .. 3] of TdReal;

typedef dReal dVector4[4];

TdxJointLimitMotor3 = array [0 .. 2] of TdxJointLimitMotor;

This item has no description.

TdxJointNull = TdxJoint;

This item has no description.

TdxSimpleSpace = TdxSpace;

Copies settings from TdxSpace, beacause pascal doeasn't do inheritance for records

TJointFlag = Integer;

Change: New Type added, syntax enforcement

TJointParams = Integer;

TJointParams = ( parameters for limits and motors Change: New Type added, sintax enforcement

Constants

ODEDLL = 'ode32s.dll';

********************************************************************

ODE precision:

ODE can be run in Single or Double precision, Single is less precise, but requires less memory.

If you choose to run in Single mode, you must deploy the single precision dll (this is default)

If you choose to run in Double mode, you must deploy the double precision dll (named ode_double.dll and located in the dll directory) Insert . before "$" to make ODEImport double based

TRIMESH_FACE_NORMALS = 0;

enum (* TRIMESH_FACE_NORMALS, TRIMESH_LAST_TRANSFORMATION ; *)

TRIMESH_LAST_TRANSFORMATION = 1;

This item has no description.

CONTACTS_UNIMPORTANT = $80000000;

Just generate any contacts (disables any contact refining).

dJOINT_INGROUP: TJointFlag = 1;

These consts now have defined types if this flag is set, the joint was allocated in a joint group

dJOINT_REVERSE: TJointFlag = 2;

if this flag is set, the joint was attached with arguments (0,body). our convention is to treat all attaches as (body,0), i.e. so node[0].body is always nonzero, so this flag records the fact that the arguments were swapped

dJOINT_TWOBODIES: TJointFlag = 4;

if this flag is set, the joint can not have just one body attached to it, it must have either zero or two bodies attached

dContactMu2: TdContactType = $0001;

These consts now have defined types

dContactFDir1: TdContactType = $0002;

This item has no description.

dContactBounce: TdContactType = $0004;

This item has no description.

dContactSoftERP: TdContactType = $0008;

This item has no description.

dContactSoftCFM: TdContactType = $0010;

This item has no description.

dContactMotion1: TdContactType = $0020;

This item has no description.

dContactMotion2: TdContactType = $0040;

This item has no description.

dContactMotionN: TdContactType = $0080;

This item has no description.

dContactSlip1: TdContactType = $0100;

This item has no description.

dContactSlip2: TdContactType = $0200;

This item has no description.

dContactApprox0: TdContactType = $0000;

This item has no description.

dContactApprox1_1: TdContactType = $1000;

This item has no description.

dContactApprox1_2: TdContactType = $2000;

This item has no description.

dContactApprox1: TdContactType = $3000;

This item has no description.

dxBodyFlagFiniteRotation: TBodyFlags = 1;

These consts now have defined types

dxBodyFlagFiniteRotationAxis: TBodyFlags = 2;

use finite rotations

dxBodyDisabled: TBodyFlags = 4;

use finite rotations only along axis

dxBodyNoGravity: TBodyFlags = 8;

body is disabled

_priv_dParamLoStop = $000;

These consts now have defined types

_priv_dParamLoStop2 = $100;

This item has no description.

_priv_dParamLoStop3 = $200;

This item has no description.

dParamLoStop: TJointParams = _priv_dParamLoStop;

This item has no description.

dParamHiStop: TJointParams = _priv_dParamLoStop + 1;

This item has no description.

dParamVel: TJointParams = _priv_dParamLoStop + 2;

This item has no description.

dParamFMax: TJointParams = _priv_dParamLoStop + 3;

This item has no description.

dParamFudgeFactor: TJointParams = _priv_dParamLoStop + 4;

This item has no description.

dParamBounce: TJointParams = _priv_dParamLoStop + 5;

This item has no description.

dParamCFM: TJointParams = _priv_dParamLoStop + 6;

This item has no description.

dParamStopERP: TJointParams = _priv_dParamLoStop + 7;

This item has no description.

dParamStopCFM: TJointParams = _priv_dParamLoStop + 8;

This item has no description.

dParamSuspensionERP: TJointParams = _priv_dParamLoStop + 9;

parameters for suspension

dParamSuspensionCFM: TJointParams = _priv_dParamLoStop + 10;

This item has no description.

dParamERP: TJointParams = _priv_dParamLoStop + 11;

This item has no description.

dParamGroup1: TJointParams = $000;

This item has no description.

dParamLoStop1: TJointParams = _priv_dParamLoStop;

This item has no description.

dParamHiStop1: TJointParams = _priv_dParamLoStop + 1;

This item has no description.

dParamVel1: TJointParams = _priv_dParamLoStop + 2;

This item has no description.

dParamFMax1: TJointParams = _priv_dParamLoStop + 3;

This item has no description.

dParamFudgeFactor1: TJointParams = _priv_dParamLoStop + 4;

This item has no description.

dParamBounce1: TJointParams = _priv_dParamLoStop + 5;

This item has no description.

dParamCFM1: TJointParams = _priv_dParamLoStop + 6;

This item has no description.

dParamStopERP1: TJointParams = _priv_dParamLoStop + 7;

This item has no description.

dParamStopCFM1: TJointParams = _priv_dParamLoStop + 8;

This item has no description.

dParamSuspensionERP1: TJointParams = _priv_dParamLoStop + 9;

parameters for suspension

dParamSuspensionCFM1: TJointParams = _priv_dParamLoStop + 10;

This item has no description.

dParamERP1: TJointParams = _priv_dParamLoStop + 11;

This item has no description.

dParamGroup2: TJointParams = $100;

SECOND AXEL parameters for limits and motors

dParamLoStop2: TJointParams = _priv_dParamLoStop2;

This item has no description.

dParamHiStop2: TJointParams = _priv_dParamLoStop2 + 1;

This item has no description.

dParamVel2: TJointParams = _priv_dParamLoStop2 + 2;

This item has no description.

dParamFMax2: TJointParams = _priv_dParamLoStop2 + 3;

This item has no description.

dParamFudgeFactor2: TJointParams = _priv_dParamLoStop2 + 4;

This item has no description.

dParamBounce2: TJointParams = _priv_dParamLoStop2 + 5;

This item has no description.

dParamCFM2: TJointParams = _priv_dParamLoStop2 + 6;

This item has no description.

dParamStopERP2: TJointParams = _priv_dParamLoStop2 + 7;

This item has no description.

dParamStopCFM2: TJointParams = _priv_dParamLoStop2 + 8;

This item has no description.

dParamSuspensionERP2: TJointParams = _priv_dParamLoStop2 + 9;

parameters for suspension

dParamSuspensionCFM2: TJointParams = _priv_dParamLoStop2 + 10;

This item has no description.

dParamERP2: TJointParams = _priv_dParamLoStop2 + 11;

This item has no description.

dParamGroup3: TJointParams = $200;

THIRD AXEL parameters for limits and motors

dParamLoStop3: TJointParams = _priv_dParamLoStop3;

This item has no description.

dParamHiStop3: TJointParams = _priv_dParamLoStop3 + 1;

This item has no description.

dParamVel3: TJointParams = _priv_dParamLoStop3 + 2;

This item has no description.

dParamFMax3: TJointParams = _priv_dParamLoStop3 + 3;

This item has no description.

dParamFudgeFactor3: TJointParams = _priv_dParamLoStop3 + 4;

This item has no description.

dParamBounce3: TJointParams = _priv_dParamLoStop3 + 5;

This item has no description.

dParamCFM3: TJointParams = _priv_dParamLoStop3 + 6;

This item has no description.

dParamStopERP3: TJointParams = _priv_dParamLoStop3 + 7;

This item has no description.

dParamStopCFM3: TJointParams = _priv_dParamLoStop3 + 8;

This item has no description.

dParamSuspensionERP3: TJointParams = _priv_dParamLoStop3 + 9;

parameters for suspension

dParamSuspensionCFM3: TJointParams = _priv_dParamLoStop3 + 10;

This item has no description.

dParamERP3: TJointParams = _priv_dParamLoStop3 + 11;

This item has no description.

dParamGroup: TJointParams = $100;

This item has no description.

MaxUserClasses = 4;

ExportInitODEMarker

Variables

dSphereClass: Integer = 0;

This item has no description.

dBoxClass: Integer = 1;

This item has no description.

dCapsuleClass: Integer = 2;

This item has no description.

dCylinderClass: Integer = 3;

This item has no description.

dPlaneClass: Integer = 4;

This item has no description.

dRayClass: Integer = 5;

This item has no description.

dConvexClass: Integer = 6;

This item has no description.

dGeomTransformClass: Integer = 7;

This item has no description.

dTriMeshClass: Integer = 8;

This item has no description.

dHeightFieldClass: Integer = 9;

This item has no description.

dFirstSpaceClass: Integer = 10;

This item has no description.

dSimpleSpaceClass: Integer = 10;

This item has no description.

dHashSpaceClass: Integer = 11;

This item has no description.

dSweepAndPruneSpaceClass: Integer = 12;

This item has no description.

dQuadTreeSpaceClass: Integer = 13;

This item has no description.

dLastSpaceClass: Integer = 13;

This item has no description.

dFirstUserClass: Integer = 14;

This item has no description.

dLastUserClass: Integer = 17;

This item has no description.

dGeomNumClasses: Integer = 18;

This item has no description.

IsODEInitialized: boolean = false;

This item has no description.

DisabledDebugGeom: boolean = false;

This item has no description.

DisabledDebugCollision: boolean = false;


GLSysHelp v.2.5: ODE.Import: Record TdxJointGroup

Record TdxJointGroup

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointGroup = record

Description

This item has no description.

Overview

Fields

Public | num: Integer;
Public | stack: pointer;

Description

Fields

Public num: Integer;

This item has no description.

Public stack: pointer;


GLSysHelp v.2.5: ODE.Import: Record TdxJointLimitMotor

Record TdxJointLimitMotor

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointLimitMotor = record

Description

This item has no description.

Overview

Fields

Public | vel: TdReal;
Public | fmax: TdReal;
Public | lostop: TdReal;
Public | histop: TdReal;
Public | fudge_factor: TdReal;
Public | normal_cfm: TdReal;
Public | stop_erp: TdReal;
Public | stop_sfm: TdReal;
Public | bounce: TdReal;
Public | limit: Integer;
Public | limit_err: TdReal;

Description

Fields

Public vel: TdReal;

This item has no description.

Public fmax: TdReal;

This item has no description.

Public lostop: TdReal;

powered joint: velocity, max force

Public histop: TdReal;

powered joint: velocity, max force

Public fudge_factor: TdReal;

joint limits, relative to initial position

Public normal_cfm: TdReal;

when powering away from joint limits

Public stop_erp: TdReal;

cfm to use when not at a stop

Public stop_sfm: TdReal;

cfm to use when not at a stop

Public bounce: TdReal;

erp and cfm for when at joint limit

Public limit: Integer;

restitution factor variables used between getInfo1() and getInfo2()

Public limit_err: TdReal;

0=free, 1=at lo limit, 2=at hi limit


GLSysHelp v.2.5: ODE.Import: Record TdMass

Record TdMass

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdMass = record

Description

This item has no description.

Overview

Fields

Public | mass: TdReal;
Public | c: TdVector4;
Public | I: TdMatrix3;

Description

Fields

Public mass: TdReal;

This item has no description.

Public c: TdVector4;

total mass of the rigid body

Public I: TdMatrix3;

center of gravity position in body frame (x,y,z)


GLSysHelp v.2.5: ODE.Import: Record TdxAutoDisable

Record TdxAutoDisable

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxAutoDisable = record

Description

This item has no description.

Overview

Fields

Public | idle_time: TdReal;
Public | idle_steps: Integer;
Public | linear_average_threashold: TdReal;
Public | angular_average_threashold: TdReal;
Public | average_samples: longword;

Description

Fields

Public idle_time: TdReal;

This item has no description.

Public idle_steps: Integer;

time the body needs to be idle to auto-disable it

Public linear_average_threashold: TdReal;

steps the body needs to be idle to auto-disable it

Public angular_average_threashold: TdReal;

linear (squared) average velocity threshold

Public average_samples: longword;

angular (squared) average velocity threshold


GLSysHelp v.2.5: ODE.Import: Record TdxDampingParameters

Record TdxDampingParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxDampingParameters = record

Description

This item has no description.

Overview

Fields

Public | linear_scale: TdReal;
Public | angular_scale: TdReal;
Public | linear_threahold: TdReal;
Public | angular_threashold: TdReal;

Description

Fields

Public linear_scale: TdReal;

This item has no description.

Public angular_scale: TdReal;

multiply the linear velocity by (1 - scale)

Public linear_threahold: TdReal;

multiply the angular velocity by (1 - scale)

Public angular_threashold: TdReal;

linear (squared) average speed threshold


GLSysHelp v.2.5: ODE.Import: Record TdxContactParameters

Record TdxContactParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxContactParameters = record

Description

This item has no description.

Overview

Fields

Public | max_vel: TdReal;
Public | min_depth: TdReal;

Description

Fields

Public max_vel: TdReal;

This item has no description.

Public min_depth: TdReal;

maximum correcting velocity


GLSysHelp v.2.5: ODE.Import: Record TdxQuickStepParameters

Record TdxQuickStepParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxQuickStepParameters = record

Description

This item has no description.

Overview

Fields

Public | num_iterations: Integer;
Public | w: TdReal;

Description

Fields

Public num_iterations: Integer;

This item has no description.

Public w: TdReal;

number of SOR iterations to perform


GLSysHelp v.2.5: ODE.Import: Record TdObject

Record TdObject

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdObject = record

Description

This item has no description.

Overview

Fields

Public | World: PdxWorld;
Public | next: PdObject;
Public | tome: PPdObject;
Public | userdata: pointer;
Public | tag: Integer;

Description

Fields

Public World: PdxWorld;

This item has no description.

Public next: PdObject;

world this object is in

Public tome: PPdObject;

next object of this type in list

Public userdata: pointer;

pointer to previous object's next ptr

Public tag: Integer;

user settable data


GLSysHelp v.2.5: ODE.Import: Record TdxJointNode

Record TdxJointNode

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointNode = record

Description

This item has no description.

Overview

Fields

Public | joint: PdxJoint;
Public | body: PdxBody;
Public | next: PdxJointNode;

Description

Fields

Public joint: PdxJoint;

This item has no description.

Public body: PdxBody;

pointer to enclosing dxJoint object

Public next: PdxJointNode;

*other* body this joint is connected to


GLSysHelp v.2.5: ODE.Import: Record TJointInfo1

Record TJointInfo1

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TJointInfo1 = record

Description

info returned by getInfo1 function. the constraint dimension is m (<=6). i.e. that is the total number of rows in the jacobian. `nub' is the number of unbounded variables (which have lo,hi = -/+ infinity).

Overview

Fields

Public | m: Integer;
Public | nub: Integer;

Description

Fields

Public m: Integer;

This item has no description.

Public nub: Integer;


GLSysHelp v.2.5: ODE.Import: Record TJointInfo2

Record TJointInfo2

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TJointInfo2 = record

Description

info returned by getInfo2 function

Overview

Fields

Public | fps: TdReal;
Public | erp: TdReal;
Public | J1l: PdReal;
Public | J1a: PdReal;
Public | J2l: PdReal;
Public | J2a: PdReal;
Public | rowskip: Integer;
Public | c: PdReal;
Public | cfm: PdReal;
Public | lo: PdReal;
Public | hi: PdReal;
Public | findex: pinteger;

Description

Fields

Public fps: TdReal;

integrator parameters: frames per second (1/stepsize), default error reduction parameter (0..1).

Public erp: TdReal;

integrator parameters: frames per second (1/stepsize), default error reduction parameter (0..1).

Public J1l: PdReal;

for the first and second body, pointers to two (linear and angular) n*3 jacobian sub matrices, stored by rows. these matrices will have been initialized to 0 on entry. if the second body is zero then the J2xx pointers may be 0.

Public J1a: PdReal;

for the first and second body, pointers to two (linear and angular) n*3 jacobian sub matrices, stored by rows. these matrices will have been initialized to 0 on entry. if the second body is zero then the J2xx pointers may be 0.

Public J2l: PdReal;

for the first and second body, pointers to two (linear and angular) n*3 jacobian sub matrices, stored by rows. these matrices will have been initialized to 0 on entry. if the second body is zero then the J2xx pointers may be 0.

Public J2a: PdReal;

for the first and second body, pointers to two (linear and angular) n*3 jacobian sub matrices, stored by rows. these matrices will have been initialized to 0 on entry. if the second body is zero then the J2xx pointers may be 0.

Public rowskip: Integer;

elements to jump from one row to the next in J's

Public c: PdReal;

right hand sides of the equation J*v = c + cfm * lambda. cfm is the "constraint force mixing" vector. c is set to zero on entry, cfm is set to a constant value (typically very small or zero) value on entry.

Public cfm: PdReal;

right hand sides of the equation J*v = c + cfm * lambda. cfm is the "constraint force mixing" vector. c is set to zero on entry, cfm is set to a constant value (typically very small or zero) value on entry.

Public lo: PdReal;

lo and hi limits for variables (set to -/+ infinity on entry).

Public hi: PdReal;

lo and hi limits for variables (set to -/+ infinity on entry).

Public findex: pinteger;

findex vector for variables. see the LCP solver interface for a description of what this does. this is set to -1 on entry. note that the returned indexes are relative to the first index of the constraint.


GLSysHelp v.2.5: ODE.Import: Record TdxJoint

Record TdxJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJoint = record

Description

This item has no description.

Overview

Fields

Public | baseObject: TdObject;
Public | Info1: TJointInfo1;
Public | Info2: TJointInfo2;

Description

Fields

Public baseObject: TdObject;

This item has no description.

Public Info1: TJointInfo1;

This item has no description.

Public Info2: TJointInfo2;


GLSysHelp v.2.5: ODE.Import: Record TdxJointBall

Record TdxJointBall

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointBall = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | anchor1: TdVector3;
Public | anchor2: TdVector3;
Public | erp: TdReal;
Public | cfm: TdReal;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public anchor1: TdVector3;

This item has no description.

Public anchor2: TdVector3;

anchor w.r.t first body

Public erp: TdReal;

anchor w.r.t second body

Public cfm: TdReal;

error reduction


GLSysHelp v.2.5: ODE.Import: Record TdxJointHinge

Record TdxJointHinge

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointHinge = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | anchor1: TdVector3;
Public | anchor2: TdVector3;
Public | axis1: TdVector3;
Public | axis2: TdVector3;
Public | qrel: TdQuaternion;
Public | limot: TdxJointLimitMotor;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public anchor1: TdVector3;

This item has no description.

Public anchor2: TdVector3;

anchor w.r.t first body

Public axis1: TdVector3;

anchor w.r.t second body

Public axis2: TdVector3;

axis w.r.t first body

Public qrel: TdQuaternion;

axis w.r.t second body

Public limot: TdxJointLimitMotor;

initial relative rotation body1 -> body2


GLSysHelp v.2.5: ODE.Import: Record TdxJointUniversial

Record TdxJointUniversial

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointUniversial = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | anchor1: TdVector3;
Public | anchor2: TdVector3;
Public | axis1: TdVector3;
Public | axis2: TdVector3;
Public | qrel1: TdQuaternion;
Public | qrel2: TdQuaternion;
Public | limot1: TdxJointLimitMotor;
Public | limot2: TdxJointLimitMotor;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public anchor1: TdVector3;

This item has no description.

Public anchor2: TdVector3;

anchor w.r.t first body

Public axis1: TdVector3;

anchor w.r.t second body

Public axis2: TdVector3;

axis w.r.t first body

Public qrel1: TdQuaternion;

axis w.r.t second body

Public qrel2: TdQuaternion;

initial relative rotation body1 -> virtual cross piece

Public limot1: TdxJointLimitMotor;

initial relative rotation virtual cross piece -> body2

Public limot2: TdxJointLimitMotor;

limit and motor information for axis1


GLSysHelp v.2.5: ODE.Import: Record TdxJointPR

Record TdxJointPR

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointPR = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | anchor2: TdVector3;
Public | axisR1: TdVector3;
Public | axisR2: TdVector3;
Public | axisP1: TdVector3;
Public | qrel: TdQuaternion;
Public | offset: TdVector3;
Public | limotR: TdxJointLimitMotor;
Public | limotP: TdxJointLimitMotor;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public anchor2: TdVector3;

This item has no description.

Public axisR1: TdVector3;

< @brief Position of the rotoide articulation < w.r.t second body. <

Note
Position of body 2 in world frame +
< anchor2 in world frame give the position < of the rotoide articulation

Public axisR2: TdVector3;

< axis of the rotoide articulation w.r.t first body. <

Note
This is considered as axis1 from the parameter
< view.

Public axisP1: TdVector3;

< axis of the rotoide articulation w.r.t second body. <

Note
This is considered also as axis1 from the
< parameter view

Public qrel: TdQuaternion;

< axis for the prismatic articulation w.r.t first body. <

Note
This is considered as axis2 in from the parameter
< view

Public offset: TdVector3;

< initial relative rotation body1 -> body2.

Public limotR: TdxJointLimitMotor;

< @brief vector between the body1 and the rotoide < articulation. < < Going from the first to the second in the frame < of body1. < That should be aligned with body1 center along axisP < This is calculated when the axis are set.

Public limotP: TdxJointLimitMotor;

< limit and motor information for the rotoide articulation.


GLSysHelp v.2.5: ODE.Import: Record TdxJointPiston

Record TdxJointPiston

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointPiston = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | axis1: TdVector3;
Public | axis2: TdVector3;
Public | qrel: TdQuaternion;
Public | anchor1: TdVector3;
Public | anchor2: TdVector3;
Public | limotP: TdxJointLimitMotor;
Public | limotR: TdxJointLimitMotor;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public axis1: TdVector3;

This item has no description.

Public axis2: TdVector3;

< Axis of the prismatic and rotoide w.r.t first body

Public qrel: TdQuaternion;

< Axis of the prismatic and rotoide w.r.t second body

Public anchor1: TdVector3;

< Initial relative rotation body1 -> body2 Anchor w.r.t first body. This is the same as the offset for the Slider joint

Note
To find the position of the anchor when the body 1 has moved
you must add the position of the prismatic joint i.e anchor = R1 * anchor1 + dJointGetPistonPosition() * (R1 * axis1)

Public anchor2: TdVector3;

This item has no description.

Public limotP: TdxJointLimitMotor;

< anchor w.r.t second body limit and motor information for the prismatic part of the joint

Public limotR: TdxJointLimitMotor;

limit and motor information for the rotoide part of the joint


GLSysHelp v.2.5: ODE.Import: Record TdxJointSlider

Record TdxJointSlider

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointSlider = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | axis1: TdVector3;
Public | qrel: TdQuaternion;
Public | offset: TdVector3;
Public | limot: TdxJointLimitMotor;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public axis1: TdVector3;

This item has no description.

Public qrel: TdQuaternion;

axis w.r.t first body

Public offset: TdVector3;

initial relative rotation body1 -> body2

Public limot: TdxJointLimitMotor;

point relative to body2 that should be aligned with body1 center along axis1


GLSysHelp v.2.5: ODE.Import: Record TdxJointHinge2

Record TdxJointHinge2

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointHinge2 = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | anchor1: TdVector3;
Public | anchor2: TdVector3;
Public | axis1: TdVector3;
Public | axis2: TdVector3;
Public | c0: TdReal;
Public | s0: TdReal;
Public | v1: TdVector3;
Public | v2: TdVector3;
Public | limot1: TdxJointLimitMotor;
Public | limot2: TdxJointLimitMotor;
Public | susp_erp: TdReal;
Public | susp_cfm: TdReal;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public anchor1: TdVector3;

This item has no description.

Public anchor2: TdVector3;

anchor w.r.t first body

Public axis1: TdVector3;

anchor w.r.t second body

Public axis2: TdVector3;

axis 1 w.r.t first body

Public c0: TdReal;

axis 2 w.r.t second body

Public s0: TdReal;

axis 2 w.r.t second body

Public v1: TdVector3;

cos,sin of desired angle between axis 1,2

Public v2: TdVector3;

cos,sin of desired angle between axis 1,2

Public limot1: TdxJointLimitMotor;

angle ref vectors embedded in first body

Public limot2: TdxJointLimitMotor;

limit+motor info for axis 1

Public susp_erp: TdReal;

limit+motor info for axis 2

Public susp_cfm: TdReal;

limit+motor info for axis 2


GLSysHelp v.2.5: ODE.Import: Record TdxJointAMotor

Record TdxJointAMotor

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointAMotor = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | num: Integer;
Public | mode: Integer;
Public | rel: TdInteger3;
Public | axis: Td3Axis;
Public | limot: TdxJointLimitMotor3;
Public | angle: TdVector3;
Public | reference1: TdVector3;
Public | reference2: TdVector3;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public num: Integer;

This item has no description.

Public mode: Integer;

number of axes (0..3)

Public rel: TdInteger3;

a dAMotorXXX constant

Public axis: Td3Axis;

what the axes are relative to (global,b1,b2)

Public limot: TdxJointLimitMotor3;

three axes

Public angle: TdVector3;

limit+motor info for axes

Public reference1: TdVector3;

user-supplied angles for axes these vectors are used for calculating euler angles

Public reference2: TdVector3;

original axis[2], relative to body 1


GLSysHelp v.2.5: ODE.Import: Record TdxJointLMotor

Record TdxJointLMotor

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointLMotor = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | num: Integer;
Public | rel: TdInteger3;
Public | axis: Td3Axis;
Public | limot: TdxJointLimitMotor3;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public num: Integer;

This item has no description.

Public rel: TdInteger3;

This item has no description.

Public axis: Td3Axis;

This item has no description.

Public limot: TdxJointLimitMotor3;

three axes


GLSysHelp v.2.5: ODE.Import: Record TdxJointPlane2D

Record TdxJointPlane2D

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointPlane2D = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | row_motor_x: Integer;
Public | row_motor_y: Integer;
Public | row_motor_angle: Integer;
Public | motor_x: TdxJointLimitMotor;
Public | motor_y: TdxJointLimitMotor;
Public | motor_angle: TdxJointLimitMotor;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public row_motor_x: Integer;

This item has no description.

Public row_motor_y: Integer;

This item has no description.

Public row_motor_angle: Integer;

This item has no description.

Public motor_x: TdxJointLimitMotor;

This item has no description.

Public motor_y: TdxJointLimitMotor;

This item has no description.

Public motor_angle: TdxJointLimitMotor;


GLSysHelp v.2.5: ODE.Import: Record TdxJointFixed

Record TdxJointFixed

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxJointFixed = record

Description

This item has no description.

Overview

Fields

Public | BaseJoint: TdxJoint;
Public | qrel: TdQuaternion;
Public | offset: TdVector3;
Public | erp: TdReal;
Public | cfm: TdReal;

Description

Fields

Public BaseJoint: TdxJoint;

This item has no description.

Public qrel: TdQuaternion;

This item has no description.

Public offset: TdVector3;

initial relative rotation body1 -> body2

Public erp: TdReal;

relative offset between the bodies

Public cfm: TdReal;

error reduction parameter


GLSysHelp v.2.5: ODE.Import: Record TdxPosR

Record TdxPosR

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxPosR = record

Description

This item has no description.

Overview

Fields

Public | pos: TdVector3;
Public | R: TdMatrix3;

Description

Fields

Public pos: TdVector3;

This item has no description.

Public R: TdMatrix3;


GLSysHelp v.2.5: ODE.Import: Record TdxBody

Record TdxBody

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxBody = record

Description

This item has no description.

Overview

Fields

Public | baseObject: TdObject;
Public | Padding: byte;
Public | firstjoint: TdJointID;
Public | flags: Integer;
Public | geom: PdxGeom;
Public | mass: TdMass;
Public | invI: TdMatrix3;
Public | invMass: TdReal;
Public | posr: TdxPosR;
Public | q: TdQuaternion;
Public | lvel: TdVector3;
Public | avel: TdVector3;
Public | facc: TdVector3;
Public | tacc: TdVector3;
Public | finite_rot_axis: TdVector3;
Public | adis: TdxAutoDisable;
Public | adis_timeleft: TdReal;
Public | adis_stepsleft: Integer;
Public | average_lvel_buffer: PdVector3;
Public | average_avel_buffer: PdVector3;
Public | average_counter: longword;
Public | average_ready: Integer;
Public | moved_callback: TdMovedCallback;
Public | dampingp: TdxDampingParameters;
Public | max_angular_speed: TdReal;

Description

Fields

Public baseObject: TdObject;

This item has no description.

Public Padding: byte;

This item has no description.

Public firstjoint: TdJointID;

This item has no description.

Public flags: Integer;

list of attached joints

Public geom: PdxGeom;

some dxBodyFlagXXX flags

Public mass: TdMass;

first collision geom associated with body

Public invI: TdMatrix3;

mass parameters about POR

Public invMass: TdReal;

inverse of mass.I

Public posr: TdxPosR;

1 / mass.mass

Public q: TdQuaternion;

position and orientation of point of reference

Public lvel: TdVector3;

orientation quaternion

Public avel: TdVector3;

orientation quaternion

Public facc: TdVector3;

linear and angular velocity of POR

Public tacc: TdVector3;

linear and angular velocity of POR

Public finite_rot_axis: TdVector3;

force and torque accululators

Public adis: TdxAutoDisable;

finite rotation axis, unit length or 0=none

Public adis_timeleft: TdReal;

auto-disable parameters

Public adis_stepsleft: Integer;

time left to be idle

Public average_lvel_buffer: PdVector3;

steps left to be idle

Public average_avel_buffer: PdVector3;

buffer for the linear average velocity calculation

Public average_counter: longword;

buffer for the angular average velocity calculation

Public average_ready: Integer;

counter/index to fill the average-buffers

Public moved_callback: TdMovedCallback;

indicates ( with = 1 ), if the Body's buffers are ready for average-calculations

Public dampingp: TdxDampingParameters;

let the user know the body moved

Public max_angular_speed: TdReal;

damping parameters, depends on flags


GLSysHelp v.2.5: ODE.Import: Class TBodyList

Class TBodyList

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TBodyList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TBodyList

Overview

Methods

Private | function GetItems(I: Integer): PdxBody;
Public | procedure DeleteAllBodies;
Private | procedure SetItems(I: Integer; const Value: PdxBody);

Properties

Public property Items[I: Integer]: PdxBody read GetItems write SetItems;

Description

Methods

Private function GetItems(I: Integer): PdxBody;

This item has no description.

Public procedure DeleteAllBodies;

This item has no description.

Private procedure SetItems(I: Integer; const Value: PdxBody);

This item has no description.

Properties

Public property Items[I: Integer]: PdxBody read GetItems write SetItems;


GLSysHelp v.2.5: ODE.Import: Record TdxWorld

Record TdxWorld

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxWorld = record

Description

struct dxWorld : public dBase { dxBody *firstbody; // body linked list dxJoint *firstjoint; // joint linked list int nb,nj; // number of bodies and joints in lists dVector3 gravity; // gravity vector (m/s/s) dReal global_erp; // global error reduction parameter dReal global_cfm; // global costraint force mixing parameter };

Overview

Fields

Public | firstbody: PdxBody;
Public | firstjoint: PdxJoint;
Public | nb: Integer;
Public | nj: Integer;
Public | gravity: TdVector3;
Public | global_erp: TdReal;
Public | global_cfm: TdReal;
Public | adis: TdxAutoDisable;
Public | body_flags: Integer;
Public | qs: TdxQuickStepParameters;
Public | contactp: TdxContactParameters;
Public | dampingp: TdxDampingParameters;
Public | max_angular_speed: TdReal;

Description

Fields

Public firstbody: PdxBody;

(TdBase)

Public firstjoint: PdxJoint;

body linked list

Public nb: Integer;

joint linked list

Public nj: Integer;

joint linked list

Public gravity: TdVector3;

number of bodies and joints in lists

Public global_erp: TdReal;

gravity vector (m/s/s)

Public global_cfm: TdReal;

global error reduction parameter

Public adis: TdxAutoDisable;

global costraint force mixing parameter

Public body_flags: Integer;

This item has no description.

Public qs: TdxQuickStepParameters;

This item has no description.

Public contactp: TdxContactParameters;

This item has no description.

Public dampingp: TdxDampingParameters;

This item has no description.

Public max_angular_speed: TdReal;


GLSysHelp v.2.5: ODE.Import: Record TdJointFeedback

Record TdJointFeedback

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdJointFeedback = record

Description

This item has no description.

Overview

Fields

Public | f1: TdVector3;
Public | t1: TdVector3;
Public | f2: TdVector3;
Public | t2: TdVector3;

Description

Fields

Public f1: TdVector3;

This item has no description.

Public t1: TdVector3;

force that joint applies to body 1

Public f2: TdVector3;

torque that joint applies to body 1

Public t2: TdVector3;

force that joint applies to body 2


GLSysHelp v.2.5: ODE.Import: Record TdSurfaceParameters

Record TdSurfaceParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdSurfaceParameters = record

Description

This item has no description.

Overview

Fields

Public | mode: Integer;
Public | mu: TdReal;
Public | mu2: TdReal
Public | bounce: TdReal
Public | bounce_vel: TdReal
Public | soft_erp: TdReal
Public | soft_cfm: TdReal
Public | motion1: TdReal
Public | motion2: TdReal
Public | motionN: TdReal
Public | slip1: TdReal
Public | slip2: TdReal

Description

Fields

Public mode: Integer;

must always be defined

Public mu: TdReal;

This item has no description.

Public mu2: TdReal

only defined if the corresponding flag is set in mode

Public bounce: TdReal

only defined if the corresponding flag is set in mode

Public bounce_vel: TdReal

only defined if the corresponding flag is set in mode

Public soft_erp: TdReal

only defined if the corresponding flag is set in mode

Public soft_cfm: TdReal

only defined if the corresponding flag is set in mode

Public motion1: TdReal

only defined if the corresponding flag is set in mode

Public motion2: TdReal

only defined if the corresponding flag is set in mode

Public motionN: TdReal

only defined if the corresponding flag is set in mode

Public slip1: TdReal

only defined if the corresponding flag is set in mode

Public slip2: TdReal

only defined if the corresponding flag is set in mode


GLSysHelp v.2.5: ODE.Import: Record TdContactGeom

Record TdContactGeom

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdContactGeom = record

Description

This item has no description.

Overview

Fields

Public | pos: TdVector3;
Public | normal: TdVector3;
Public | depth: TdReal;
Public | g1: PdxGeom;
Public | g2: PdxGeom;
Public | side1: Integer;
Public | side2: Integer;

Description

Fields

Public pos: TdVector3;

This item has no description.

Public normal: TdVector3;

This item has no description.

Public depth: TdReal;

This item has no description.

Public g1: PdxGeom;

This item has no description.

Public g2: PdxGeom;

This item has no description.

Public side1: Integer;

This item has no description.

Public side2: Integer;


GLSysHelp v.2.5: ODE.Import: Record TdContact

Record TdContact

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdContact = record

Description

This item has no description.

Overview

Fields

Public | surface: TdSurfaceParameters;
Public | geom: TdContactGeom;
Public | fdir1: TdVector3;

Description

Fields

Public surface: TdSurfaceParameters;

This item has no description.

Public geom: TdContactGeom;

This item has no description.

Public fdir1: TdVector3;


GLSysHelp v.2.5: ODE.Import: Record TdGeomClass

Record TdGeomClass

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdGeomClass = record

Description

typedef struct dGeomClass { int bytes; dGetColliderFnFn *collider; dGetAABBFn *aabb; dAABBTestFn *aabb_test; dGeomDtorFn *dtor; } dGeomClass;

Overview

Fields

Public | bytes: Integer;
Public | collider: TdGetColliderFnFn;
Public | aabb: TdGetAABBFn;
Public | aabb_test: TdAABBTestFn;
Public | dtor: TdGeomDtorFn;

Description

Fields

Public bytes: Integer;

This item has no description.

Public collider: TdGetColliderFnFn;

extra storage size

Public aabb: TdGetAABBFn;

collider function

Public aabb_test: TdAABBTestFn;

bounding box function

Public dtor: TdGeomDtorFn;

aabb tester, can be 0 for none


GLSysHelp v.2.5: ODE.Import: Record TdxTriMeshData

Record TdxTriMeshData

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxTriMeshData = record

Description

struct dxTriMeshData{ Model BVTree; MeshInterface Mesh;

dxTriMeshData(); ~dxTriMeshData();

void Build(const void* Vertices, int VertexStide, int VertexCount, const void* Indices, int IndexCount, int TriStride, const void* Normals, bool Single);

/* aabb in model space */ dVector3 AABBCenter; dVector3 AABBExtents;

/* data for use in collison resolution */ const void* Normals; Matrix4x4 last_trans; };

Overview

Fields

Public unknown: byte;

Description

Fields

Public unknown: byte;


GLSysHelp v.2.5: ODE.Import: Record TdxHeightfieldData

Record TdxHeightfieldData

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxHeightfieldData = record

Description

This item has no description.

Overview

Fields

Public | m_fWidth: TdReal;
Public | m_fDepth: TdReal;
Public | m_fSampleWidth: TdReal;
Public | m_fSampleDepth: TdReal;
Public | m_fInvSampleWidth: TdReal;
Public | m_fInvSampleDepth: TdReal;
Public | m_fHalfWidth: TdReal;
Public | m_fHalfDepth: TdReal;
Public | m_fMinHeight: TdReal;
Public | m_fMaxHeight: TdReal;
Public | m_fThickness: TdReal;
Public | m_fScale: TdReal;
Public | m_fOffset: TdReal;
Public | m_nWidthSamples: Integer;
Public | m_nDepthSamples: Integer;
Public | m_bCopyHeightData: Integer;
Public | m_bWrapMode: Integer;
Public | m_nGetHeightMode: Integer;
Public | m_pHeightData: pointer;
Public | m_pUserData: pointer;
Public | m_contacts: PdContactGeom;

Description

Fields

Public m_fWidth: TdReal;

This item has no description.

Public m_fDepth: TdReal;

This item has no description.

Public m_fSampleWidth: TdReal;

This item has no description.

Public m_fSampleDepth: TdReal;

This item has no description.

Public m_fInvSampleWidth: TdReal;

This item has no description.

Public m_fInvSampleDepth: TdReal;

This item has no description.

Public m_fHalfWidth: TdReal;

This item has no description.

Public m_fHalfDepth: TdReal;

This item has no description.

Public m_fMinHeight: TdReal;

This item has no description.

Public m_fMaxHeight: TdReal;

This item has no description.

Public m_fThickness: TdReal;

This item has no description.

Public m_fScale: TdReal;

This item has no description.

Public m_fOffset: TdReal;

This item has no description.

Public m_nWidthSamples: Integer;

This item has no description.

Public m_nDepthSamples: Integer;

This item has no description.

Public m_bCopyHeightData: Integer;

This item has no description.

Public m_bWrapMode: Integer;

This item has no description.

Public m_nGetHeightMode: Integer;

This item has no description.

Public m_pHeightData: pointer;

This item has no description.

Public m_pUserData: pointer;

This item has no description.

Public m_contacts: PdContactGeom;


GLSysHelp v.2.5: ODE.Import: Record TdGeomSpaceData

Record TdGeomSpaceData

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdGeomSpaceData = record

Description

typedef struct dGeomSpaceData { dGeomID next; } dGeomSpaceData;

Overview

Fields

Public next: PdxGeom;

Description

Fields

Public next: PdxGeom;


GLSysHelp v.2.5: ODE.Import: Record TdxGeom

Record TdxGeom

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxGeom = record

Description

// common data for all geometry objects. the class-specific data area follows // this structure. pos and R will either point to a separately allocated // buffer (if body is 0 - pos points to the dxPosR object) or to the pos and // R of the body (if body nonzero). struct dxGeom { // a dGeomID is a pointer to this dxGeomClass *_class; // class of this object void *data; // user data pointer dBodyID body; // dynamics body associated with this object (if any) dReal *pos; // pointer to object's position vector dReal *R; // pointer to object's rotation matrix dSpaceID spaceid; // the space this object is in dGeomSpaceData space; // reserved for use by space this object is in dReal *space_aabb; // ptr to aabb array held by dSpaceCollide() fn // class-specific data follows here, with proper alignment. };

Overview

Fields

Public | _type: Integer;
Public | Padding: byte;
Public | gflags: Integer;
Public | data: pointer;
Public | body: PdxBody;
Public | body_next: PdxGeom;
Public | final_posr: PdxPosR;
Public | offset_posr: PdxPosR;
Public | next: PdxGeom;
Public | tome: PPdxGeom;
Public | parent_space: PdxSpace;
Public | aabb: TdAABB;
Public | category_bits: longword;
Public | collide_bits: longword;

Description

Fields

Public _type: Integer;

a dGeomID is a pointer to this

Public Padding: byte;

class of this object

Public gflags: Integer;

This item has no description.

Public data: pointer;

This item has no description.

Public body: PdxBody;

user data pointer

Public body_next: PdxGeom;

dynamics body associated with this object (if any)

Public final_posr: PdxPosR;

next geom in body's linked list of associated geoms

Public offset_posr: PdxPosR;

final position of the geom in world coordinates

Public next: PdxGeom;

offset from body in local coordinates

Public tome: PPdxGeom;

This item has no description.

Public parent_space: PdxSpace;

This item has no description.

Public aabb: TdAABB;

This item has no description.

Public category_bits: longword;

This item has no description.

Public collide_bits: longword;


GLSysHelp v.2.5: ODE.Import: Class TGeomList

Class TGeomList

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TGeomList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TGeomList

Overview

Methods

Private | function GetItems(I: Integer): PdxGeom;
Public | procedure DeleteAllGeoms(DeleteDataAsObject: boolean = false);
Private | procedure SetItems(I: Integer; const Value: PdxGeom);

Properties

Public property Items[I: Integer]: PdxGeom read GetItems write SetItems;

Description

Methods

Private function GetItems(I: Integer): PdxGeom;

This item has no description.

Public procedure DeleteAllGeoms(DeleteDataAsObject: boolean = false);

This item has no description.

Private procedure SetItems(I: Integer; const Value: PdxGeom);

This item has no description.

Properties

Public property Items[I: Integer]: PdxGeom read GetItems write SetItems;


GLSysHelp v.2.5: ODE.Import: Record TdxSpace

Record TdxSpace

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxSpace = record

Description

This item has no description.

Overview

Fields

Public | baseGeom: TdxGeom;
Public | count: Integer;
Public | first: PdxGeom;
Public | cleanup: Integer;
Public | current_index: Integer;
Public | current_geom: PdxGeom;
Public | lock_count: Integer;

Description

Fields

Public baseGeom: TdxGeom;

This item has no description.

Public count: Integer;

This item has no description.

Public first: PdxGeom;

This item has no description.

Public cleanup: Integer;

This item has no description.

Public current_index: Integer;

This item has no description.

Public current_geom: PdxGeom;

This item has no description.

Public lock_count: Integer;


GLSysHelp v.2.5: ODE.Import: Record TdxHashSpace

Record TdxHashSpace

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxHashSpace = record

Description

Copies settings from TdxSpace, beacause pascal doeasn't do inheritance for records

Overview

Fields

Public | BaseSpace: TdxSpace;
Public | global_minlevel: Integer;
Public | global_maxlevel: Integer;

Description

Fields

Public BaseSpace: TdxSpace;

This item has no description.

Public global_minlevel: Integer;

This item has no description.

Public global_maxlevel: Integer;


GLSysHelp v.2.5: ODE.Import: Record TdxQuadTreeSpace

Record TdxQuadTreeSpace

Description
Hierarchy
Fields
Methods
Properties

Unit

ODE.Import

Declaration

type TdxQuadTreeSpace = record

Description

This item has no description.

Overview

Fields

Public | BaseSpace: TdxSpace;
Public | Blocks: pointer;
Public | DirtyList: pointer;

Description

Fields

Public BaseSpace: TdxSpace;

This item has no description.

Public Blocks: pointer;

This item has no description.

Public DirtyList: pointer;


GLSysHelp v.2.5: OpenAL.Import

Unit OpenAL.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Version: MPL 1.1/GPL 2.0/LGPL 2.1 * * The contents of this file are subject to the Mozilla Public License Version * 1.1 (the "License"); you may not use this file except in compliance with * the License. You may obtain a copy of the License at * http://www.mozilla.org/MPL/ * * Software distributed under the License is distributed on an "AS IS" basis, * WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License * for the specific language governing rights and limitations under the * License. * * The Original Code is OpenAL1.0 - Headertranslation to Object Pascal. * * The Initial Developer of the Original Code is * Delphi OpenAL Translation Team. * Portions created by the Initial Developer are Copyright (C) 2001-2004 * the Initial Developer. All Rights Reserved. * * Contributor(s): * Tom Nuydens (delphi3d@gamedeveloper.org) * Dean Ellis (dean.ellis@sxmedia.co.uk) * Amresh Ramachandran (amreshr@hotmail.com) * Pranav Joshi (pranavjosh@yahoo.com) * Marten van der Honing (mvdhoning@noeska.com) * Benjamin Rosseaux (BeRo) * * Alternatively, the contents of this file may be used under the terms of * either the GNU General Public License Version 2 or later (the "GPL"), or * the GNU Lesser General Public License Version 2.1 or later (the "LGPL"), * in which case the provisions of the GPL or the LGPL are applicable instead * of those above. If you wish to allow use of your version of this file only * under the terms of either the GPL or the LGPL, and not to allow others to * use your version of this file under the terms of the MPL, indicate your * decision by deleting the provisions above and replace them with the notice * and other provisions required by the GPL or the LGPL. If you do not delete * the provisions above, a recipient may use your version of this file under * the terms of any one of the MPL, the GPL or the LGPL.

Uses

  • System.SysUtils
  • Winapi.Windows

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TEaxListenerProperties |
Packed Record TEaxBufferProperties |
Packed Record _EFXEAXREVERBPROPERTIES |
Packed Record _EFXLOWPASSFILTER |

Functions and Procedures

procedure alutInit(argc: PALint; argv: array of PALbyte);
procedure alutExit;
procedure alutLoadWAVFile(fname: string; var format: TALenum; var data: TALvoid; var size: TALsizei; var freq: TALsizei; var loop: TALint);
procedure alutLoadWAVMemory(memory: PALbyte; var format: TALenum; var data: TALvoid; var size: TALsizei; var freq: TALsizei; var loop: TALint);
procedure alutUnloadWAV(format: TALenum; data: TALvoid; size: TALsizei; freq: TALsizei);
function InitOpenAL(LibName: String = callibname): Boolean;
procedure ReadOpenALExtensions;

Types

DSPROPERTY_EAX_BUFFERPROPERTY = LongWORD;
DSPROPERTY_EAX_LISTENERPROPERTY = LongWORD;
EFXEAXREVERBPROPERTIES = _EFXEAXREVERBPROPERTIES;
EFXLOWPASSFILTER = _EFXLOWPASSFILTER;
HMODULE = THandle;
PALbitfield = ˆTALbitfield;
PALboolean = ˆTALboolean;
PALbyte = ˆTALbyte;
PALCboolean = ˆTALCboolean;
PALCbyte = ˆTALCbyte;
PALCchar = PAnsiChar;
PALCcontext = ˆTALCcontext;
PALCdevice = ˆTALCdevice;
PALCdouble = ˆTALCdouble;
PALCenum = ˆTALCenum;
PALCfloat = ˆTALCfloat;
PALchar = PAnsiChar;
PALCint = ˆTALCint;
PALclampd = ˆTALclampd;
PALclampf = ˆTALclampf;
PALCshort = ˆTALCshort;
PALCsizei = ˆTALCsizei;
PALCubyte = PAnsiChar;
PALCuint = ˆTALCuint;
PALCushort = ˆTALCushort;
PALCvoid = ˆTALCvoid;
PALdouble = ˆTALdouble;
PALenum = ˆTALenum;
PALfloat = ˆTALfloat;
PALint = ˆTALint;
PALshort = ˆTALshort;
PALsizei = ˆTALsizei;
PALuByte = PAnsiChar;
PALuint = ˆTALuint;
PALushort = ˆTALushort;
PALvoid = ˆTALvoid;
PEaxBufferProperties = ˆTEaxBufferProperties;
PEaxListenerProperties = ˆTEaxListenerProperties;
PEFXEAXREVERBPROPERTIES = ˆ_EFXEAXREVERBPROPERTIES;
PEFXLOWPASSFILTER = ˆ_EFXLOWPASSFILTER;
PPALvoid = ˆPALvoid;
TALbitfield = Cardinal;
TALboolean = Boolean;
TALbyte = ShortInt;
TALCboolean = boolean;
TALCbyte = ShortInt;
TALCchar = char;
TALCcontext = TALCvoid;
TALCdevice = TALCvoid;
TALCdouble = double;
TALCenum = integer;
TALCfloat = single;
TALchar = char;
TALCint = integer;
TALclampd = TALdouble;
TALclampf = TALfloat;
TALCshort = smallint;
TALCsizei = integer;
TALCubyte = Char;
TALCuint = Cardinal;
TALCushort = Word;
TALCvoid = Pointer;
TALdouble = Double;
TALenum = Integer;
TALfloat = Single;
TALint = Integer;
TALshort = SmallInt;
TALsizei = Cardinal;
TALuByte = Char;
TALuint = Cardinal;
TALushort = Word;
TALvoid = Pointer;

Constants

callibname='OpenAL32.dll';
calutlibname='Alut.dll';
AL_INVALID = -1;
AL_NONE = 0;
AL_FALSE = 0;
AL_TRUE = 1;
AL_SOURCE_ABSOLUTE = $201;
AL_SOURCE_RELATIVE = $202;
AL_CONE_INNER_ANGLE = $1001;
AL_CONE_OUTER_ANGLE = $1002;
AL_PITCH =$1003;
AL_POSITION =$1004;
AL_DIRECTION =$1005;
AL_VELOCITY =$1006;
AL_LOOPING =$1007;
AL_BUFFER =$1009;
AL_GAIN =$100A;
AL_MIN_GAIN =$100D;
AL_MAX_GAIN =$100E;
AL_ORIENTATION =$100F;
AL_CHANNEL_MASK =$3000;
AL_SOURCE_STATE =$1010;
AL_INITIAL =$1011;
AL_PLAYING =$1012;
AL_PAUSED =$1013;
AL_STOPPED =$1014;
AL_BUFFERS_QUEUED =$1015;
AL_BUFFERS_PROCESSED =$1016;
AL_SEC_OFFSET = $1024;
AL_SAMPLE_OFFSET = $1025;
AL_BYTE_OFFSET = $1026;
AL_SOURCE_TYPE = $1027;
AL_STATIC = $1028;
AL_STREAMING = $1029;
AL_UNDETERMINED = $1030;
AL_FORMAT_MONO8 =$1100;
AL_FORMAT_MONO16 =$1101;
AL_FORMAT_STEREO8 =$1102;
AL_FORMAT_STEREO16 =$1103;
AL_REFERENCE_DISTANCE =$1020;
AL_ROLLOFF_FACTOR =$1021;
AL_CONE_OUTER_GAIN =$1022;
AL_MAX_DISTANCE =$1023;
AL_FREQUENCY =$2001;
AL_BITS =$2002;
AL_CHANNELS =$2003;
AL_SIZE =$2004;
AL_UNUSED =$2010;
AL_PENDING =$2011;
AL_PROCESSED =$2012;
AL_NO_ERROR =AL_FALSE;
AL_INVALID_NAME =$A001;
AL_ILLEGAL_ENUM =$A002;
AL_INVALID_ENUM =$A002;
AL_INVALID_VALUE =$A003;
AL_ILLEGAL_COMMAND =$A004;
AL_INVALID_OPERATION =$A004;
AL_OUT_OF_MEMORY =$A005;
AL_VENDOR =$B001;
AL_VERSION =$B002;
AL_RENDERER =$B003;
AL_EXTENSIONS =$B004;
AL_DOPPLER_FACTOR =$C000;
AL_DOPPLER_VELOCITY =$C001;
AL_SPEED_OF_SOUND = $C003;
AL_DISTANCE_MODEL =$D000;
AL_INVERSE_DISTANCE =$D001;
AL_INVERSE_DISTANCE_CLAMPED =$D002;
AL_LINEAR_DISTANCE =$D003;
AL_LINEAR_DISTANCE_CLAMPED =$D004;
AL_EXPONENT_DISTANCE =$D005;
AL_EXPONENT_DISTANCE_CLAMPED =$D006;
ALC_INVALID =0;
ALC_FALSE =0;
ALC_TRUE =1;
ALC_FREQUENCY =$1007;
ALC_REFRESH =$1008;
ALC_SYNC =$1009;
ALC_MONO_SOURCES =$1010;
ALC_STEREO_SOURCES =$1011;
ALC_NO_ERROR =ALC_FALSE;
ALC_INVALID_DEVICE =$A001;
ALC_INVALID_CONTEXT =$A002;
ALC_INVALID_ENUM =$A003;
ALC_INVALID_VALUE =$A004;
ALC_OUT_OF_MEMORY =$A005;
ALC_DEFAULT_DEVICE_SPECIFIER =$1004;
ALC_DEVICE_SPECIFIER =$1005;
ALC_EXTENSIONS =$1006;
ALC_MAJOR_VERSION =$1000;
ALC_MINOR_VERSION =$1001;
ALC_ATTRIBUTES_SIZE =$1002;
ALC_ALL_ATTRIBUTES =$1003;
ALC_DEFAULT_ALL_DEVICES_SPECIFIER =$1012;
ALC_ALL_DEVICES_SPECIFIER =$1013;
ALC_CAPTURE_DEVICE_SPECIFIER =$310;
ALC_CAPTURE_DEFAULT_DEVICE_SPECIFIER =$311;
ALC_CAPTURE_SAMPLES =$312;
ALC_EXT_EFX_NAME ='ALC_EXT_EFX';
ALC_EFX_MAJOR_VERSION =$20001;
ALC_EFX_MINOR_VERSION =$20002;
ALC_MAX_AUXILIARY_SENDS =$20003;
AL_METERS_PER_UNIT =$20004;
AL_DIRECT_FILTER =$20005;
AL_AUXILIARY_SEND_FILTER =$20006;
AL_AIR_ABSORPTION_FACTOR =$20007;
AL_ROOM_ROLLOFF_FACTOR =$20008;
AL_CONE_OUTER_GAINHF =$20009;
AL_DIRECT_FILTER_GAINHF_AUTO =$2000A;
AL_AUXILIARY_SEND_FILTER_GAIN_AUTO =$2000B;
AL_AUXILIARY_SEND_FILTER_GAINHF_AUTO =$2000C;
AL_REVERB_DENSITY =$0001;
AL_REVERB_DIFFUSION =$0002;
AL_REVERB_GAIN =$0003;
AL_REVERB_GAINHF =$0004;
AL_REVERB_DECAY_TIME =$0005;
AL_REVERB_DECAY_HFRATIO =$0006;
AL_REVERB_REFLECTIONS_GAIN =$0007;
AL_REVERB_REFLECTIONS_DELAY =$0008;
AL_REVERB_LATE_REVERB_GAIN =$0009;
AL_REVERB_LATE_REVERB_DELAY =$000A;
AL_REVERB_AIR_ABSORPTION_GAINHF =$000B;
AL_REVERB_ROOM_ROLLOFF_FACTOR =$000C;
AL_REVERB_DECAY_HFLIMIT =$000D;
AL_CHORUS_WAVEFORM =$0001;
AL_CHORUS_PHASE =$0002;
AL_CHORUS_RATE =$0003;
AL_CHORUS_DEPTH =$0004;
AL_CHORUS_FEEDBACK =$0005;
AL_CHORUS_DELAY =$0006;
AL_DISTORTION_EDGE =$0001;
AL_DISTORTION_GAIN =$0002;
AL_DISTORTION_LOWPASS_CUTOFF =$0003;
AL_DISTORTION_EQCENTER =$0004;
AL_DISTORTION_EQBANDWIDTH =$0005;
AL_ECHO_DELAY =$0001;
AL_ECHO_LRDELAY =$0002;
AL_ECHO_DAMPING =$0003;
AL_ECHO_FEEDBACK =$0004;
AL_ECHO_SPREAD =$0005;
AL_FLANGER_WAVEFORM =$0001;
AL_FLANGER_PHASE =$0002;
AL_FLANGER_RATE =$0003;
AL_FLANGER_DEPTH =$0004;
AL_FLANGER_FEEDBACK =$0005;
AL_FLANGER_DELAY =$0006;
AL_FREQUENCY_SHIFTER_FREQUENCY =$0001;
AL_FREQUENCY_SHIFTER_LEFT_DIRECTION =$0002;
AL_FREQUENCY_SHIFTER_RIGHT_DIRECTION =$0003;
AL_VOCAL_MORPHER_PHONEMEA =$0001;
AL_VOCAL_MORPHER_PHONEMEA_COARSE_TUNING =$0002;
AL_VOCAL_MORPHER_PHONEMEB =$0003;
AL_VOCAL_MORPHER_PHONEMEB_COARSE_TUNING =$0004;
AL_VOCAL_MORPHER_WAVEFORM =$0005;
AL_VOCAL_MORPHER_RATE =$0006;
AL_PITCH_SHIFTER_COARSE_TUNE =$0001;
AL_PITCH_SHIFTER_FINE_TUNE =$0002;
AL_RING_MODULATOR_FREQUENCY =$0001;
AL_RING_MODULATOR_HIGHPASS_CUTOFF =$0002;
AL_RING_MODULATOR_WAVEFORM =$0003;
AL_AUTOWAH_ATTACK_TIME =$0001;
AL_AUTOWAH_RELEASE_TIME =$0002;
AL_AUTOWAH_RESONANCE =$0003;
AL_AUTOWAH_PEAK_GAIN =$0004;
AL_COMPRESSOR_ONOFF =$0001;
AL_EQUALIZER_LOW_GAIN =$0001;
AL_EQUALIZER_LOW_CUTOFF =$0002;
AL_EQUALIZER_MID1_GAIN =$0003;
AL_EQUALIZER_MID1_CENTER =$0004;
AL_EQUALIZER_MID1_WIDTH =$0005;
AL_EQUALIZER_MID2_GAIN =$0006;
AL_EQUALIZER_MID2_CENTER =$0007;
AL_EQUALIZER_MID2_WIDTH =$0008;
AL_EQUALIZER_HIGH_GAIN =$0009;
AL_EQUALIZER_HIGH_CUTOFF =$000A;
AL_EFFECT_FIRST_PARAMETER =$0000;
AL_EFFECT_LAST_PARAMETER =$8000;
AL_EFFECT_TYPE =$8001;
AL_EFFECT_NULL =$0000;
AL_EFFECT_REVERB =$0001;
AL_EFFECT_CHORUS =$0002;
AL_EFFECT_DISTORTION =$0003;
AL_EFFECT_ECHO =$0004;
AL_EFFECT_FLANGER =$0005;
AL_EFFECT_FREQUENCY_SHIFTER =$0006;
AL_EFFECT_VOCAL_MORPHER =$0007;
AL_EFFECT_PITCH_SHIFTER =$0008;
AL_EFFECT_RING_MODULATOR =$0009;
AL_EFFECT_AUTOWAH =$000A;
AL_EFFECT_COMPRESSOR =$000B;
AL_EFFECT_EQUALIZER =$000C;
AL_EFFECTSLOT_EFFECT =$0001;
AL_EFFECTSLOT_GAIN =$0002;
AL_EFFECTSLOT_AUXILIARY_SEND_AUTO =$0003;
AL_EFFECTSLOT_NULL =$0000;
AL_LOWPASS_GAIN =$0001;
AL_LOWPASS_GAINHF =$0002;
AL_HIGHPASS_GAIN =$0001;
AL_HIGHPASS_GAINLF =$0002;
AL_BANDPASS_GAIN =$0001;
AL_BANDPASS_GAINLF =$0002;
AL_BANDPASS_GAINHF =$0003;
AL_FILTER_FIRST_PARAMETER =$0000;
AL_FILTER_LAST_PARAMETER =$8000;
AL_FILTER_TYPE =$8001;
AL_FILTER_NULL =$0000;
AL_FILTER_LOWPASS =$0001;
AL_FILTER_HIGHPASS =$0002;
AL_FILTER_BANDPASS =$0003;
LOWPASS_MIN_GAIN =0.0;
LOWPASS_MAX_GAIN =1.0;
LOWPASS_DEFAULT_GAIN =1.0;
LOWPASS_MIN_GAINHF =0.0;
LOWPASS_MAX_GAINHF =1.0;
LOWPASS_DEFAULT_GAINHF =1.0;
HIGHPASS_MIN_GAIN =0.0;
HIGHPASS_MAX_GAIN =1.0;
HIGHPASS_DEFAULT_GAIN =1.0;
HIGHPASS_MIN_GAINLF =0.0;
HIGHPASS_MAX_GAINLF =1.0;
HIGHPASS_DEFAULT_GAINLF =1.0;
BANDPASS_MIN_GAIN =0.0;
BANDPASS_MAX_GAIN =1.0;
BANDPASS_DEFAULT_GAIN =1.0;
BANDPASS_MIN_GAINHF =0.0;
BANDPASS_MAX_GAINHF =1.0;
BANDPASS_DEFAULT_GAINHF =1.0;
BANDPASS_MIN_GAINLF =0.0;
BANDPASS_MAX_GAINLF =1.0;
BANDPASS_DEFAULT_GAINLF =1.0;
AL_REVERB_MIN_DENSITY =0.0;
AL_REVERB_MAX_DENSITY =1.0;
AL_REVERB_DEFAULT_DENSITY =1.0;
AL_REVERB_MIN_DIFFUSION =0.0;
AL_REVERB_MAX_DIFFUSION =1.0;
AL_REVERB_DEFAULT_DIFFUSION =1.0;
AL_REVERB_MIN_GAIN =0.0;
AL_REVERB_MAX_GAIN =1.0;
AL_REVERB_DEFAULT_GAIN =0.32;
AL_REVERB_MIN_GAINHF =0.0;
AL_REVERB_MAX_GAINHF =1.0;
AL_REVERB_DEFAULT_GAINHF =0.89;
AL_REVERB_MIN_DECAY_TIME =0.1;
AL_REVERB_MAX_DECAY_TIME =20.0;
AL_REVERB_DEFAULT_DECAY_TIME =1.49;
AL_REVERB_MIN_DECAY_HFRATIO =0.1;
AL_REVERB_MAX_DECAY_HFRATIO =2.0;
AL_REVERB_DEFAULT_DECAY_HFRATIO =0.83;
AL_REVERB_MIN_REFLECTIONS_GAIN =0.0;
AL_REVERB_MAX_REFLECTIONS_GAIN =3.16;
AL_REVERB_DEFAULT_REFLECTIONS_GAIN =0.05;
AL_REVERB_MIN_REFLECTIONS_DELAY =0.0;
AL_REVERB_MAX_REFLECTIONS_DELAY =0.3;
AL_REVERB_DEFAULT_REFLECTIONS_DELAY =0.007;
AL_REVERB_MIN_LATE_REVERB_GAIN =0.0;
AL_REVERB_MAX_LATE_REVERB_GAIN =10.0;
AL_REVERB_DEFAULT_LATE_REVERB_GAIN =1.26;
AL_REVERB_MIN_LATE_REVERB_DELAY =0.0;
AL_REVERB_MAX_LATE_REVERB_DELAY =0.1;
AL_REVERB_DEFAULT_LATE_REVERB_DELAY =0.011;
AL_REVERB_MIN_AIR_ABSORPTION_GAINHF =0.892;
AL_REVERB_MAX_AIR_ABSORPTION_GAINHF =1.0;
AL_REVERB_DEFAULT_AIR_ABSORPTION_GAINHF =0.994;
AL_REVERB_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_REVERB_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_REVERB_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_REVERB_MIN_DECAY_HFLIMIT =AL_FALSE;
AL_REVERB_MAX_DECAY_HFLIMIT =AL_TRUE;
AL_REVERB_DEFAULT_DECAY_HFLIMIT =AL_TRUE;
AL_CHORUS_MIN_WAVEFORM =0;
AL_CHORUS_MAX_WAVEFORM =1;
AL_CHORUS_DEFAULT_WAVEFORM =1;
AL_CHORUS_WAVEFORM_SINUSOID =0;
AL_CHORUS_WAVEFORM_TRIANGLE =1;
AL_CHORUS_MIN_PHASE =-180;
AL_CHORUS_MAX_PHASE =180;
AL_CHORUS_DEFAULT_PHASE =90;
AL_CHORUS_MIN_RATE =0.0;
AL_CHORUS_MAX_RATE =10.0;
AL_CHORUS_DEFAULT_RATE =1.1;
AL_CHORUS_MIN_DEPTH =0.0;
AL_CHORUS_MAX_DEPTH =1.0;
AL_CHORUS_DEFAULT_DEPTH =0.1;
AL_CHORUS_MIN_FEEDBACK =-1.0;
AL_CHORUS_MAX_FEEDBACK =1.0;
AL_CHORUS_DEFAULT_FEEDBACK =0.25;
AL_CHORUS_MIN_DELAY =0.0;
AL_CHORUS_MAX_DELAY =0.016;
AL_CHORUS_DEFAULT_DELAY =0.016;
AL_DISTORTION_MIN_EDGE =0.0;
AL_DISTORTION_MAX_EDGE =1.0;
AL_DISTORTION_DEFAULT_EDGE =0.2;
AL_DISTORTION_MIN_GAIN =0.01;
AL_DISTORTION_MAX_GAIN =1.0;
AL_DISTORTION_DEFAULT_GAIN =0.05;
AL_DISTORTION_MIN_LOWPASS_CUTOFF =80.0;
AL_DISTORTION_MAX_LOWPASS_CUTOFF =24000.0;
AL_DISTORTION_DEFAULT_LOWPASS_CUTOFF =8000.0;
AL_DISTORTION_MIN_EQCENTER =80.0;
AL_DISTORTION_MAX_EQCENTER =24000.0;
AL_DISTORTION_DEFAULT_EQCENTER =3600.0;
AL_DISTORTION_MIN_EQBANDWIDTH =80.0;
AL_DISTORTION_MAX_EQBANDWIDTH =24000.0;
AL_DISTORTION_DEFAULT_EQBANDWIDTH =3600.0;
AL_ECHO_MIN_DELAY =0.0;
AL_ECHO_MAX_DELAY =0.207;
AL_ECHO_DEFAULT_DELAY =0.1;
AL_ECHO_MIN_LRDELAY =0.0;
AL_ECHO_MAX_LRDELAY =0.404;
AL_ECHO_DEFAULT_LRDELAY =0.1;
AL_ECHO_MIN_DAMPING =0.0;
AL_ECHO_MAX_DAMPING =0.99;
AL_ECHO_DEFAULT_DAMPING =0.5;
AL_ECHO_MIN_FEEDBACK =0.0;
AL_ECHO_MAX_FEEDBACK =1.0;
AL_ECHO_DEFAULT_FEEDBACK =0.5;
AL_ECHO_MIN_SPREAD =-1.0;
AL_ECHO_MAX_SPREAD =1.0;
AL_ECHO_DEFAULT_SPREAD =-1.0;
AL_FLANGER_MIN_WAVEFORM =0;
AL_FLANGER_MAX_WAVEFORM =1;
AL_FLANGER_DEFAULT_WAVEFORM =1;
AL_FLANGER_WAVEFORM_SINUSOID =0;
AL_FLANGER_WAVEFORM_TRIANGLE =1;
AL_FLANGER_MIN_PHASE =-180;
AL_FLANGER_MAX_PHASE =180;
AL_FLANGER_DEFAULT_PHASE =0;
AL_FLANGER_MIN_RATE =0.0;
AL_FLANGER_MAX_RATE =10.0;
AL_FLANGER_DEFAULT_RATE =0.27;
AL_FLANGER_MIN_DEPTH =0.0;
AL_FLANGER_MAX_DEPTH =1.0;
AL_FLANGER_DEFAULT_DEPTH =1.0;
AL_FLANGER_MIN_FEEDBACK =-1.0;
AL_FLANGER_MAX_FEEDBACK =1.0;
AL_FLANGER_DEFAULT_FEEDBACK =-0.5;
AL_FLANGER_MIN_DELAY =0.0;
AL_FLANGER_MAX_DELAY =0.004;
AL_FLANGER_DEFAULT_DELAY =0.002;
AL_FREQUENCY_SHIFTER_MIN_FREQUENCY =0.0;
AL_FREQUENCY_SHIFTER_MAX_FREQUENCY =24000.0;
AL_FREQUENCY_SHIFTER_DEFAULT_FREQUENCY =0.0;
AL_FREQUENCY_SHIFTER_MIN_LEFT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MAX_LEFT_DIRECTION =2;
AL_FREQUENCY_SHIFTER_DEFAULT_LEFT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MIN_RIGHT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MAX_RIGHT_DIRECTION =2;
AL_FREQUENCY_SHIFTER_DEFAULT_RIGHT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_DIRECTION_DOWN =0;
AL_FREQUENCY_SHIFTER_DIRECTION_UP =1;
AL_FREQUENCY_SHIFTER_DIRECTION_OFF =2;
AL_VOCAL_MORPHER_MIN_PHONEMEA =0;
AL_VOCAL_MORPHER_MAX_PHONEMEA =29;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEA =0;
AL_VOCAL_MORPHER_MIN_PHONEMEA_COARSE_TUNING =-24;
AL_VOCAL_MORPHER_MAX_PHONEMEA_COARSE_TUNING =24;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEA_COARSE_TUNING =0;
AL_VOCAL_MORPHER_MIN_PHONEMEB =0;
AL_VOCAL_MORPHER_MAX_PHONEMEB =29;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEB =10;
AL_VOCAL_MORPHER_PHONEME_A =0;
AL_VOCAL_MORPHER_PHONEME_E =1;
AL_VOCAL_MORPHER_PHONEME_I =2;
AL_VOCAL_MORPHER_PHONEME_O =3;
AL_VOCAL_MORPHER_PHONEME_U =4;
AL_VOCAL_MORPHER_PHONEME_AA =5;
AL_VOCAL_MORPHER_PHONEME_AE =6;
AL_VOCAL_MORPHER_PHONEME_AH =7;
AL_VOCAL_MORPHER_PHONEME_AO =8;
AL_VOCAL_MORPHER_PHONEME_EH =9;
AL_VOCAL_MORPHER_PHONEME_ER =10;
AL_VOCAL_MORPHER_PHONEME_IH =11;
AL_VOCAL_MORPHER_PHONEME_IY =12;
AL_VOCAL_MORPHER_PHONEME_UH =13;
AL_VOCAL_MORPHER_PHONEME_UW =14;
AL_VOCAL_MORPHER_PHONEME_B =15;
AL_VOCAL_MORPHER_PHONEME_D =16;
AL_VOCAL_MORPHER_PHONEME_F =17;
AL_VOCAL_MORPHER_PHONEME_G =18;
AL_VOCAL_MORPHER_PHONEME_J =19;
AL_VOCAL_MORPHER_PHONEME_K =20;
AL_VOCAL_MORPHER_PHONEME_L =21;
AL_VOCAL_MORPHER_PHONEME_M =22;
AL_VOCAL_MORPHER_PHONEME_N =23;
AL_VOCAL_MORPHER_PHONEME_P =24;
AL_VOCAL_MORPHER_PHONEME_R =25;
AL_VOCAL_MORPHER_PHONEME_S =26;
AL_VOCAL_MORPHER_PHONEME_T =27;
AL_VOCAL_MORPHER_PHONEME_V =28;
AL_VOCAL_MORPHER_PHONEME_Z =29;
AL_VOCAL_MORPHER_MIN_PHONEMEB_COARSE_TUNING =-24;
AL_VOCAL_MORPHER_MAX_PHONEMEB_COARSE_TUNING =24;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEB_COARSE_TUNING =0;
AL_VOCAL_MORPHER_MIN_WAVEFORM =0;
AL_VOCAL_MORPHER_MAX_WAVEFORM =2;
AL_VOCAL_MORPHER_DEFAULT_WAVEFORM =0;
AL_VOCAL_MORPHER_WAVEFORM_SINUSOID =0;
AL_VOCAL_MORPHER_WAVEFORM_TRIANGLE =1;
AL_VOCAL_MORPHER_WAVEFORM_SAWTOOTH =2;
AL_VOCAL_MORPHER_MIN_RATE =0.0;
AL_VOCAL_MORPHER_MAX_RATE =10.0;
AL_VOCAL_MORPHER_DEFAULT_RATE =1.41;
AL_PITCH_SHIFTER_MIN_COARSE_TUNE =-12;
AL_PITCH_SHIFTER_MAX_COARSE_TUNE =12;
AL_PITCH_SHIFTER_DEFAULT_COARSE_TUNE =12;
AL_PITCH_SHIFTER_MIN_FINE_TUNE =-50;
AL_PITCH_SHIFTER_MAX_FINE_TUNE =50;
AL_PITCH_SHIFTER_DEFAULT_FINE_TUNE =0;
AL_RING_MODULATOR_MIN_FREQUENCY =0.0;
AL_RING_MODULATOR_MAX_FREQUENCY =8000.0;
AL_RING_MODULATOR_DEFAULT_FREQUENCY =440.0;
AL_RING_MODULATOR_MIN_HIGHPASS_CUTOFF =0.0;
AL_RING_MODULATOR_MAX_HIGHPASS_CUTOFF =24000.0;
AL_RING_MODULATOR_DEFAULT_HIGHPASS_CUTOFF =800.0;
AL_RING_MODULATOR_MIN_WAVEFORM =0;
AL_RING_MODULATOR_MAX_WAVEFORM =2;
AL_RING_MODULATOR_DEFAULT_WAVEFORM =0;
AL_RING_MODULATOR_SINUSOID =0;
AL_RING_MODULATOR_SAWTOOTH =1;
AL_RING_MODULATOR_SQUARE =2;
AL_AUTOWAH_MIN_ATTACK_TIME =0.0001;
AL_AUTOWAH_MAX_ATTACK_TIME =1.0;
AL_AUTOWAH_DEFAULT_ATTACK_TIME =0.06;
AL_AUTOWAH_MIN_RELEASE_TIME =0.0001;
AL_AUTOWAH_MAX_RELEASE_TIME =1.0;
AL_AUTOWAH_DEFAULT_RELEASE_TIME =0.06;
AL_AUTOWAH_MIN_RESONANCE =2.0;
AL_AUTOWAH_MAX_RESONANCE =1000.0;
AL_AUTOWAH_DEFAULT_RESONANCE =1000.0;
AL_AUTOWAH_MIN_PEAK_GAIN =0.00003;
AL_AUTOWAH_MAX_PEAK_GAIN =31621.0;
AL_AUTOWAH_DEFAULT_PEAK_GAIN =11.22;
AL_COMPRESSOR_MIN_ONOFF =0;
AL_COMPRESSOR_MAX_ONOFF =1;
AL_COMPRESSOR_DEFAULT_ONOFF =1;
AL_EQUALIZER_MIN_LOW_GAIN =0.126;
AL_EQUALIZER_MAX_LOW_GAIN =7.943;
AL_EQUALIZER_DEFAULT_LOW_GAIN =1.0;
AL_EQUALIZER_MIN_LOW_CUTOFF =50.0;
AL_EQUALIZER_MAX_LOW_CUTOFF =800.0;
AL_EQUALIZER_DEFAULT_LOW_CUTOFF =200.0;
AL_EQUALIZER_MIN_MID1_GAIN =0.126;
AL_EQUALIZER_MAX_MID1_GAIN =7.943;
AL_EQUALIZER_DEFAULT_MID1_GAIN =1.0;
AL_EQUALIZER_MIN_MID1_CENTER =200.0;
AL_EQUALIZER_MAX_MID1_CENTER =3000.0;
AL_EQUALIZER_DEFAULT_MID1_CENTER =500.0;
AL_EQUALIZER_MIN_MID1_WIDTH =0.01;
AL_EQUALIZER_MAX_MID1_WIDTH =1.0;
AL_EQUALIZER_DEFAULT_MID1_WIDTH =1.0;
AL_EQUALIZER_MIN_MID2_GAIN =0.126;
AL_EQUALIZER_MAX_MID2_GAIN =7.943;
AL_EQUALIZER_DEFAULT_MID2_GAIN =1.0;
AL_EQUALIZER_MIN_MID2_CENTER =1000.0;
AL_EQUALIZER_MAX_MID2_CENTER =8000.0;
AL_EQUALIZER_DEFAULT_MID2_CENTER =3000.0;
AL_EQUALIZER_MIN_MID2_WIDTH =0.01;
AL_EQUALIZER_MAX_MID2_WIDTH =1.0;
AL_EQUALIZER_DEFAULT_MID2_WIDTH =1.0;
AL_EQUALIZER_MIN_HIGH_GAIN =0.126;
AL_EQUALIZER_MAX_HIGH_GAIN =7.943;
AL_EQUALIZER_DEFAULT_HIGH_GAIN =1.0;
AL_EQUALIZER_MIN_HIGH_CUTOFF =4000.0;
AL_EQUALIZER_MAX_HIGH_CUTOFF =16000.0;
AL_EQUALIZER_DEFAULT_HIGH_CUTOFF =6000.0;
AL_MIN_AIR_ABSORPTION_FACTOR =0.0;
AL_MAX_AIR_ABSORPTION_FACTOR =10.0;
AL_DEFAULT_AIR_ABSORPTION_FACTOR =0.0;
AL_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_MIN_CONE_OUTER_GAINHF =0.0;
AL_MAX_CONE_OUTER_GAINHF =1.0;
AL_DEFAULT_CONE_OUTER_GAINHF =1.0;
AL_MIN_DIRECT_FILTER_GAINHF_AUTO =AL_FALSE;
AL_MAX_DIRECT_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_DIRECT_FILTER_GAINHF_AUTO =AL_TRUE;
AL_MIN_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_FALSE;
AL_MAX_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_TRUE;
AL_DEFAULT_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_TRUE;
AL_MIN_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_FALSE;
AL_MAX_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_METERS_PER_UNIT =1.0;
AL_EAXREVERB_DENSITY =$0001;
AL_EAXREVERB_DIFFUSION =$0002;
AL_EAXREVERB_GAIN =$0003;
AL_EAXREVERB_GAINHF =$0004;
AL_EAXREVERB_GAINLF =$0005;
AL_EAXREVERB_DECAY_TIME =$0006;
AL_EAXREVERB_DECAY_HFRATIO =$0007;
AL_EAXREVERB_DECAY_LFRATIO =$0008;
AL_EAXREVERB_REFLECTIONS_GAIN =$0009;
AL_EAXREVERB_REFLECTIONS_DELAY =$000A;
AL_EAXREVERB_REFLECTIONS_PAN =$000B;
AL_EAXREVERB_LATE_REVERB_GAIN =$000C;
AL_EAXREVERB_LATE_REVERB_DELAY =$000D;
AL_EAXREVERB_LATE_REVERB_PAN =$000E;
AL_EAXREVERB_ECHO_TIME =$000F;
AL_EAXREVERB_ECHO_DEPTH =$0010;
AL_EAXREVERB_MODULATION_TIME =$0011;
AL_EAXREVERB_MODULATION_DEPTH =$0012;
AL_EAXREVERB_AIR_ABSORPTION_GAINHF =$0013;
AL_EAXREVERB_HFREFERENCE =$0014;
AL_EAXREVERB_LFREFERENCE =$0015;
AL_EAXREVERB_ROOM_ROLLOFF_FACTOR =$0016;
AL_EAXREVERB_DECAY_HFLIMIT =$0017;
AL_EFFECT_EAXREVERB =$8000;
AL_EAXREVERB_MIN_DENSITY =0.0;
AL_EAXREVERB_MAX_DENSITY =1.0;
AL_EAXREVERB_DEFAULT_DENSITY =1.0;
AL_EAXREVERB_MIN_DIFFUSION =0.0;
AL_EAXREVERB_MAX_DIFFUSION =1.0;
AL_EAXREVERB_DEFAULT_DIFFUSION =1.0;
AL_EAXREVERB_MIN_GAIN =0.0;
AL_EAXREVERB_MAX_GAIN =1.0;
AL_EAXREVERB_DEFAULT_GAIN =0.32;
AL_EAXREVERB_MIN_GAINHF =0.0;
AL_EAXREVERB_MAX_GAINHF =1.0;
AL_EAXREVERB_DEFAULT_GAINHF =0.89;
AL_EAXREVERB_MIN_GAINLF =0.0;
AL_EAXREVERB_MAX_GAINLF =1.0;
AL_EAXREVERB_DEFAULT_GAINLF =1.0;
AL_EAXREVERB_MIN_DECAY_TIME =0.1;
AL_EAXREVERB_MAX_DECAY_TIME =20.0;
AL_EAXREVERB_DEFAULT_DECAY_TIME =1.49;
AL_EAXREVERB_MIN_DECAY_HFRATIO =0.1;
AL_EAXREVERB_MAX_DECAY_HFRATIO =2.0;
AL_EAXREVERB_DEFAULT_DECAY_HFRATIO =0.83;
AL_EAXREVERB_MIN_DECAY_LFRATIO =0.1;
AL_EAXREVERB_MAX_DECAY_LFRATIO =2.0;
AL_EAXREVERB_DEFAULT_DECAY_LFRATIO =1.0;
AL_EAXREVERB_MIN_REFLECTIONS_GAIN =0.0;
AL_EAXREVERB_MAX_REFLECTIONS_GAIN =3.16;
AL_EAXREVERB_DEFAULT_REFLECTIONS_GAIN =0.05;
AL_EAXREVERB_MIN_REFLECTIONS_DELAY =0.0;
AL_EAXREVERB_MAX_REFLECTIONS_DELAY =0.3;
AL_EAXREVERB_DEFAULT_REFLECTIONS_DELAY =0.007;
AL_EAXREVERB_DEFAULT_REFLECTIONS_PAN: array[0..2] of TALFloat = (0.0, 0.0, 0.0);
AL_EAXREVERB_MIN_LATE_REVERB_GAIN =0.0;
AL_EAXREVERB_MAX_LATE_REVERB_GAIN =10.0;
AL_EAXREVERB_DEFAULT_LATE_REVERB_GAIN =1.26;
AL_EAXREVERB_MIN_LATE_REVERB_DELAY =0.0;
AL_EAXREVERB_MAX_LATE_REVERB_DELAY =0.1;
AL_EAXREVERB_DEFAULT_LATE_REVERB_DELAY =0.011;
AL_EAXREVERB_DEFAULT_LATE_REVERB_PAN: array[0..2] of TALFloat = (0.0, 0.0, 0.0);
AL_EAXREVERB_MIN_ECHO_TIME =0.075;
AL_EAXREVERB_MAX_ECHO_TIME =0.25;
AL_EAXREVERB_DEFAULT_ECHO_TIME =0.25;
AL_EAXREVERB_MIN_ECHO_DEPTH =0.0;
AL_EAXREVERB_MAX_ECHO_DEPTH =1.0;
AL_EAXREVERB_DEFAULT_ECHO_DEPTH =0.0;
AL_EAXREVERB_MIN_MODULATION_TIME =0.04;
AL_EAXREVERB_MAX_MODULATION_TIME =4.0;
AL_EAXREVERB_DEFAULT_MODULATION_TIME =0.25;
AL_EAXREVERB_MIN_MODULATION_DEPTH =0.0;
AL_EAXREVERB_MAX_MODULATION_DEPTH =1.0;
AL_EAXREVERB_DEFAULT_MODULATION_DEPTH =0.0;
AL_EAXREVERB_MIN_AIR_ABSORPTION_GAINHF =0.892;
AL_EAXREVERB_MAX_AIR_ABSORPTION_GAINHF =1.0;
AL_EAXREVERB_DEFAULT_AIR_ABSORPTION_GAINHF =0.994;
AL_EAXREVERB_MIN_HFREFERENCE =1000.0;
AL_EAXREVERB_MAX_HFREFERENCE =20000.0;
AL_EAXREVERB_DEFAULT_HFREFERENCE =5000.0;
AL_EAXREVERB_MIN_LFREFERENCE =20.0;
AL_EAXREVERB_MAX_LFREFERENCE =1000.0;
AL_EAXREVERB_DEFAULT_LFREFERENCE =250.0;
AL_EAXREVERB_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_EAXREVERB_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_EAXREVERB_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_EAXREVERB_MIN_DECAY_HFLIMIT = AL_FALSE;
AL_EAXREVERB_MAX_DECAY_HFLIMIT = AL_TRUE;
AL_EAXREVERB_DEFAULT_DECAY_HFLIMIT = AL_TRUE;
DSPROPSETID_EAX20_ListenerProperties : TGuid = '{0306A6A8-B224-11d2-99E5-0000E8D8C722}';
DSPROPSETID_EAX20_BufferProperties : TGuid = '{0306A6A7-B224-11d2-99E5-0000E8D8C722}';
DSPROPERTY_EAXLISTENER_NONE = 0;
DSPROPERTY_EAXLISTENER_ALLPARAMETERS = 1;
DSPROPERTY_EAXLISTENER_ROOM = 2;
DSPROPERTY_EAXLISTENER_ROOMHF = 3;
DSPROPERTY_EAXLISTENER_ROOMROLLOFFFACTOR = 4;
DSPROPERTY_EAXLISTENER_DECAYTIME = 5;
DSPROPERTY_EAXLISTENER_DECAYHFRATIO = 6;
DSPROPERTY_EAXLISTENER_REFLECTIONS = 7;
DSPROPERTY_EAXLISTENER_REFLECTIONSDELAY = 8;
DSPROPERTY_EAXLISTENER_REVERB = 9;
DSPROPERTY_EAXLISTENER_REVERBDELAY = 10;
DSPROPERTY_EAXLISTENER_ENVIRONMENT = 11;
DSPROPERTY_EAXLISTENER_ENVIRONMENTSIZE = 12;
DSPROPERTY_EAXLISTENER_ENVIRONMENTDIFFUSION = 13;
DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF = 14;
DSPROPERTY_EAXLISTENER_FLAGS = 15;
DSPROPERTY_EAXLISTENER_IMMEDIATE = $00000000;
DSPROPERTY_EAXLISTENER_DEFERRED = LongWORD($80000000);
DSPROPERTY_EAXLISTENER_COMMITDEFERREDSETTINGS = (DSPROPERTY_EAXLISTENER_NONE or DSPROPERTY_EAXLISTENER_IMMEDIATE);
EAX_ENVIRONMENT_GENERIC = 0;
EAX_ENVIRONMENT_PADDEDCELL = 1;
EAX_ENVIRONMENT_ROOM = 2;
EAX_ENVIRONMENT_BATHROOM = 3;
EAX_ENVIRONMENT_LIVINGROOM = 4;
EAX_ENVIRONMENT_STONEROOM = 5;
EAX_ENVIRONMENT_AUDITORIUM = 6;
EAX_ENVIRONMENT_CONCERTHALL = 7;
EAX_ENVIRONMENT_CAVE = 8;
EAX_ENVIRONMENT_ARENA = 9;
EAX_ENVIRONMENT_HANGAR = 10;
EAX_ENVIRONMENT_CARPETEDHALLWAY = 11;
EAX_ENVIRONMENT_HALLWAY = 12;
EAX_ENVIRONMENT_STONECORRIDOR = 13;
EAX_ENVIRONMENT_ALLEY = 14;
EAX_ENVIRONMENT_FOREST = 15;
EAX_ENVIRONMENT_CITY = 16;
EAX_ENVIRONMENT_MOUNTAINS = 17;
EAX_ENVIRONMENT_QUARRY = 18;
EAX_ENVIRONMENT_PLAIN = 19;
EAX_ENVIRONMENT_PARKINGLOT = 20;
EAX_ENVIRONMENT_SEWERPIPE = 21;
EAX_ENVIRONMENT_UNDERWATER = 22;
EAX_ENVIRONMENT_DRUGGED = 23;
EAX_ENVIRONMENT_DIZZY = 24;
EAX_ENVIRONMENT_PSYCHOTIC = 25;
EAX_ENVIRONMENT_COUNT = 26;
EAXLISTENERFLAGS_DECAYTIMESCALE = $00000001;
EAXLISTENERFLAGS_REFLECTIONSSCALE = $00000002;
EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE = $00000004;
EAXLISTENERFLAGS_REVERBSCALE = $00000008;
EAXLISTENERFLAGS_REVERBDELAYSCALE = $00000010;
EAXLISTENERFLAGS_DECAYHFLIMIT = $00000020;
EAXLISTENERFLAGS_RESERVED = $FFFFFFC0;
EAXLISTENER_MINROOM = -10000;
EAXLISTENER_MAXROOM = 0;
EAXLISTENER_DEFAULTROOM = -1000;
EAXLISTENER_MINROOMHF = -10000;
EAXLISTENER_MAXROOMHF = 0;
EAXLISTENER_DEFAULTROOMHF = -100;
EAXLISTENER_MINROOMROLLOFFFACTOR = 0.0;
EAXLISTENER_MAXROOMROLLOFFFACTOR = 10.0;
EAXLISTENER_DEFAULTROOMROLLOFFFACTOR = 0.0;
EAXLISTENER_MINDECAYTIME = 0.1;
EAXLISTENER_MAXDECAYTIME = 20.0;
EAXLISTENER_DEFAULTDECAYTIME = 1.49;
EAXLISTENER_MINDECAYHFRATIO = 0.1;
EAXLISTENER_MAXDECAYHFRATIO = 2.0;
EAXLISTENER_DEFAULTDECAYHFRATIO = 0.83;
EAXLISTENER_MINREFLECTIONS = -10000;
EAXLISTENER_MAXREFLECTIONS = 1000;
EAXLISTENER_DEFAULTREFLECTIONS = -2602;
EAXLISTENER_MINREFLECTIONSDELAY = 0.0;
EAXLISTENER_MAXREFLECTIONSDELAY = 0.3;
EAXLISTENER_DEFAULTREFLECTIONSDELAY = 0.007;
EAXLISTENER_MINREVERB = -10000;
EAXLISTENER_MAXREVERB = 2000;
EAXLISTENER_DEFAULTREVERB = 200;
EAXLISTENER_MINREVERBDELAY = 0.0;
EAXLISTENER_MAXREVERBDELAY = 0.1;
EAXLISTENER_DEFAULTREVERBDELAY = 0.011;
EAXLISTENER_MINENVIRONMENT = 0;
EAXLISTENER_MAXENVIRONMENT = EAX_ENVIRONMENT_COUNT - 1;
EAXLISTENER_DEFAULTENVIRONMENT = EAX_ENVIRONMENT_GENERIC;
EAXLISTENER_MINENVIRONMENTSIZE = 1.0;
EAXLISTENER_MAXENVIRONMENTSIZE = 100.0;
EAXLISTENER_DEFAULTENVIRONMENTSIZE = 7.5;
EAXLISTENER_MINENVIRONMENTDIFFUSION = 0.0;
EAXLISTENER_MAXENVIRONMENTDIFFUSION = 1.0;
EAXLISTENER_DEFAULTENVIRONMENTDIFFUSION = 1.0;
EAXLISTENER_MINAIRABSORPTIONHF = -100.0;
EAXLISTENER_MAXAIRABSORPTIONHF = 0.0;
EAXLISTENER_DEFAULTAIRABSORPTIONHF = -5.0;
EAXLISTENER_DEFAULTFLAGS = EAXLISTENERFLAGS_DECAYTIMESCALE or EAXLISTENERFLAGS_REFLECTIONSSCALE or EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE or EAXLISTENERFLAGS_REVERBSCALE or EAXLISTENERFLAGS_REVERBDELAYSCALE or EAXLISTENERFLAGS_DECAYHFLIMIT;
DSPROPERTY_EAXBUFFER_NONE = 0;
DSPROPERTY_EAXBUFFER_ALLPARAMETERS = 1;
DSPROPERTY_EAXBUFFER_DIRECT = 2;
DSPROPERTY_EAXBUFFER_DIRECTHF = 3;
DSPROPERTY_EAXBUFFER_ROOM = 4;
DSPROPERTY_EAXBUFFER_ROOMHF = 5;
DSPROPERTY_EAXBUFFER_ROOMROLLOFFFACTOR = 6;
DSPROPERTY_EAXBUFFER_OBSTRUCTION = 7;
DSPROPERTY_EAXBUFFER_OBSTRUCTIONLFRATIO = 8;
DSPROPERTY_EAXBUFFER_OCCLUSION = 9;
DSPROPERTY_EAXBUFFER_OCCLUSIONLFRATIO = 10;
DSPROPERTY_EAXBUFFER_OCCLUSIONROOMRATIO = 11;
DSPROPERTY_EAXBUFFER_OUTSIDEVOLUMEHF = 12;
DSPROPERTY_EAXBUFFER_AIRABSORPTIONFACTOR = 13;
DSPROPERTY_EAXBUFFER_FLAG = 14;
DSPROPERTY_EAXBUFFER_IMMEDIATE = $00000000;
DSPROPERTY_EAXBUFFER_DEFERRED = LongWORD($80000000);
DSPROPERTY_EAXBUFFER_COMMITDEFERREDSETTINGS = DSPROPERTY_EAXBUFFER_NONE or DSPROPERTY_EAXBUFFER_IMMEDIATE;
EAXBUFFERFLAGS_DIRECTHFAUTO = $00000001;
EAXBUFFERFLAGS_ROOMAUTO = $00000002;
EAXBUFFERFLAGS_ROOMHFAUTO = $00000004;
EAXBUFFERFLAGS_RESERVED = $FFFFFFF8;
EAXBUFFER_MINDIRECT = -10000;
EAXBUFFER_MAXDIRECT = 1000;
EAXBUFFER_DEFAULTDIRECT = 0;
EAXBUFFER_MINDIRECTHF = -10000;
EAXBUFFER_MAXDIRECTHF = 0;
EAXBUFFER_DEFAULTDIRECTHF = 0;
EAXBUFFER_MINROOM = -10000;
EAXBUFFER_MAXROOM = 1000;
EAXBUFFER_DEFAULTROOM = 0;
EAXBUFFER_MINROOMHF = -10000;
EAXBUFFER_MAXROOMHF = 0;
EAXBUFFER_DEFAULTROOMHF = 0;
EAXBUFFER_MINROOMROLLOFFFACTOR = 0.0;
EAXBUFFER_MAXROOMROLLOFFFACTOR = 10.;
EAXBUFFER_DEFAULTROOMROLLOFFFACTOR = 0.0;
EAXBUFFER_MINOBSTRUCTION = -10000;
EAXBUFFER_MAXOBSTRUCTION = 0;
EAXBUFFER_DEFAULTOBSTRUCTION = 0;
EAXBUFFER_MINOBSTRUCTIONLFRATIO = 0.0;
EAXBUFFER_MAXOBSTRUCTIONLFRATIO = 1.0;
EAXBUFFER_DEFAULTOBSTRUCTIONLFRATIO = 0.0;
EAXBUFFER_MINOCCLUSION = -10000;
EAXBUFFER_MAXOCCLUSION = 0;
EAXBUFFER_DEFAULTOCCLUSION = 0;
EAXBUFFER_MINOCCLUSIONLFRATIO = 0.0;
EAXBUFFER_MAXOCCLUSIONLFRATIO = 1.0;
EAXBUFFER_DEFAULTOCCLUSIONLFRATIO = 0.25;
EAXBUFFER_MINOCCLUSIONROOMRATIO = 0.0;
EAXBUFFER_MAXOCCLUSIONROOMRATIO = 10.0;
EAXBUFFER_DEFAULTOCCLUSIONROOMRATIO = 0.5;
EAXBUFFER_MINOUTSIDEVOLUMEHF = -10000;
EAXBUFFER_MAXOUTSIDEVOLUMEHF = 0;
EAXBUFFER_DEFAULTOUTSIDEVOLUMEHF = 0;
EAXBUFFER_MINAIRABSORPTIONFACTOR = 0.0;
EAXBUFFER_MAXAIRABSORPTIONFACTOR = 10.0;
EAXBUFFER_DEFAULTAIRABSORPTIONFACTOR = 1.0;
EAXBUFFER_DEFAULTFLAGS = EAXBUFFERFLAGS_DIRECTHFAUTO or EAXBUFFERFLAGS_ROOMAUTO or EAXBUFFERFLAGS_ROOMHFAUTO;
EAX_MATERIAL_SINGLEWINDOW = -2800;
EAX_MATERIAL_SINGLEWINDOWLF = 0.71;
EAX_MATERIAL_SINGLEWINDOWROOMRATIO = 0.43;
EAX_MATERIAL_DOUBLEWINDOW = -5000;
EAX_MATERIAL_DOUBLEWINDOWHF = 0.40;
EAX_MATERIAL_DOUBLEWINDOWROOMRATIO = 0.24;
EAX_MATERIAL_THINDOOR = -1800;
EAX_MATERIAL_THINDOORLF = 0.66;
EAX_MATERIAL_THINDOORROOMRATIO = 0.66;
EAX_MATERIAL_THICKDOOR = -4400;
EAX_MATERIAL_THICKDOORLF = 0.64;
EAX_MATERIAL_THICKDOORROOMRTATION = 0.27;
EAX_MATERIAL_WOODWALL = -4000;
EAX_MATERIAL_WOODWALLLF = 0.50;
EAX_MATERIAL_WOODWALLROOMRATIO = 0.30;
EAX_MATERIAL_BRICKWALL = -5000;
EAX_MATERIAL_BRICKWALLLF = 0.60;
EAX_MATERIAL_BRICKWALLROOMRATIO = 0.24;
EAX_MATERIAL_STONEWALL = -6000;
EAX_MATERIAL_STONEWALLLF = 0.68;
EAX_MATERIAL_STONEWALLROOMRATIO = 0.20;
EAX_MATERIAL_CURTAIN = -1200;
EAX_MATERIAL_CURTAINLF = 0.15;
EAX_MATERIAL_CURTAINROOMRATIO = 1.00;

Variables

alEnable: procedure(capability: TALenum); cdecl;
alDisable: procedure(capability: TALenum); cdecl;
alIsEnabled: function(capability: TALenum): TALboolean; cdecl;
alHint: procedure(target, mode: TALenum); cdecl;
alGetBooleanv: procedure(param: TALenum; data: PALboolean); cdecl;
alGetIntegerv: procedure(param: TALenum; data: PALint); cdecl;
alGetFloatv: procedure(param: TALenum; data: PALfloat); cdecl;
alGetDoublev: procedure(param: TALenum; data: PALdouble); cdecl;
alGetString: function(param: TALenum): PALubyte; cdecl;
alGetBoolean: function(param: TALenum): TALboolean; cdecl;
alGetInteger: function(param: TALenum): TALint; cdecl;
alGetFloat: function(param: TALenum): TALfloat; cdecl;
alGetDouble: function(param: TALenum): TALdouble; cdecl;
alGetError: function: TALenum; cdecl;
alIsExtensionPresent: function(fname: PAnsiChar): TALboolean; cdecl;
alGetProcAddress: function(fname: PALuByte): Pointer; cdecl;
alGetEnumValue: function(ename: PALuByte): TALenum; cdecl;
alListenerf: procedure(param: TALenum; value: TALfloat); cdecl;
alListener3f: procedure(param: TALenum; f1: TALfloat; f2: TALfloat; f3: TALfloat); cdecl;
alListenerfv: procedure(param: TALenum; values: PALfloat); cdecl;
alListeneri: procedure(param: TAlenum; value: TALint); cdecl;
alListener3i: procedure(param: TALenum; value1: TALint; value2: TALint; value3: TALint );
alListeneriv: procedure(param: TALenum; const values: PALint );
alGetListeneriv: procedure(param: TALenum; values: PALint); cdecl;
alGetListenerfv: procedure(param: TALenum; values: PALfloat); cdecl;
alGenSources: procedure(n: TALsizei; sources: PALuint); cdecl;
alDeleteSources: procedure(n: TALsizei; sources: PALuint); cdecl;
alIsSource: function(id: TALuint): TALboolean; cdecl;
alSourcei: procedure(source: TALuint; param: TALenum; value: TALint); cdecl;
alSource3i: procedure(source: TALuint; param: TALenum; v1: TALint; v2: TALint; v3: TALint); cdecl;
alSourceiv: procedure(source: TALuint; param: TALenum; values: PALint); cdecl;
alSourcef: procedure(source: TALuint; param: TALenum; value: TALfloat); cdecl;
alSource3f: procedure(source: TALuint; param: TALenum; v1: TALfloat; v2: TALfloat; v3: TALfloat); cdecl;
alSourcefv: procedure(source: TALuint; param: TALenum; values: PALfloat); cdecl;
alGetSourcei: procedure(source: TALuint; param: TALenum; value: PALint); cdecl;
alGetSource3i: procedure(source: TALuint; param: TALenum; v1: PALint; v2: PALint; v3: PALint); cdecl;
alGetSourceiv: procedure(source: TALuint; param: TALenum; values: PALint); cdecl;
alGetSourcef: procedure(source: TALuint; param: TALenum; value: PALfloat); cdecl;
alGetSource3f: procedure(source: TALuint; param: TALenum; v1: PALfloat; v2: PALfloat; v3: PALfloat); cdecl;
alGetSourcefv: procedure(source: TALuint; param: TALenum; values: PALfloat); cdecl;
alSourcePlay: procedure(source: TALuint); cdecl;
alSourcePause: procedure(source: TALuint); cdecl;
alSourceStop: procedure(source: TALuint); cdecl;
alSourceRewind: procedure(source: TALuint); cdecl;
alSourcePlayv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceStopv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceRewindv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourcePausev: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceQueueBuffers: procedure(source: TALuint; n: TALsizei; buffers: PALuint); cdecl;
alSourceUnqueueBuffers: procedure(source: TALuint; n: TALsizei; buffers: PALuint); cdecl;
alGenBuffers: procedure(n: TALsizei; buffers: PALuint); cdecl;
alDeleteBuffers: procedure(n: TALsizei; buffers: PALuint); cdecl;
alIsBuffer: function(buffer: TALuint): TALboolean; cdecl;
alBufferData: procedure(buffer: TALuint; format: TALenum; data: Pointer; size, freq: TALsizei); cdecl;
alBufferi: procedure(buffer: TALuint; param: TALenum; value: TALint); cdecl;
alBuffer3i: procedure(buffer: TALuint; param: TALenum; v1: TALint; v2: TALint; v3: TALint); cdecl;
alBufferiv: procedure(buffer: TALuint; param: TALenum; values: PALint); cdecl;
alBufferf: procedure(buffer: TALuint; param: TALenum; value: TALfloat); cdecl;
alBuffer3f: procedure(buffer: TALuint; param: TALenum; v1: TALfloat; v2: TALfloat; v3: TALfloat); cdecl;
alBufferfv: procedure(buffer: TALuint; param: TALenum; values: PALfloat); cdecl;
alGetBufferi: procedure(buffer: TALuint; param: TALenum; value: PALint); cdecl;
alGetBuffer3i: procedure(buffer: TALuint; param: TALenum; v1: PALint; v2: PALint; v3: PALint); cdecl;
alGetBufferiv: procedure(buffer: TALuint; param: TALenum; values: PALint); cdecl;
alGetBufferf: procedure(buffer: TALuint; param: TALenum; value: PALfloat); cdecl;
alGetBuffer3f: procedure(buffer: TALuint; param: TALenum; v1: PALfloat; v2: PALfloat; v3: PALfloat); cdecl;
alGetBufferfv: procedure(buffer: TALuint; param: TALenum; values: PALfloat); cdecl;
alDistanceModel: procedure(value: TALenum); cdecl;
alDopplerFactor: procedure(value: TALfloat); cdecl;
alDopplerVelocity: procedure(value: TALfloat); cdecl;
alSpeedOfSound: procedure( value: TALfloat ); cdecl;
alcCreateContext: function(device: TALCdevice; attrlist: PALCint): TALCcontext; cdecl;
alcMakeContextCurrent: function(context: TALCcontext): TALCenum; cdecl;
alcProcessContext: procedure(context: TALCcontext); cdecl;
alcSuspendContext: procedure(context: TALCcontext); cdecl;
alcDestroyContext: procedure(context: TALCcontext); cdecl;
alcGetCurrentContext: function: TALCcontext; cdecl;
alcGetContextsDevice: function(context: TALCcontext): TALCdevice; cdecl;
alcOpenDevice: function(deviceName: PALCuByte): TALCdevice; cdecl;
alcCloseDevice: procedure(device: TALCdevice); cdecl;
alcGetError: function(device: TALCdevice): TALCenum; cdecl;
alcIsExtensionPresent: function(device: TALCdevice; extName: PALuByte): TALCboolean; cdecl;
alcGetProcAddress: function(device: TALCdevice; funcName: PALuByte): TALCvoid; cdecl;
alcGetEnumValue: function(device: TALCdevice; enumName: PALuByte): TALCenum; cdecl;
alcGetString: function(device: TALCdevice; param: TALCenum): PALCubyte; cdecl;
alcGetIntegerv: procedure(device: TALCdevice; param: TALCenum; size: TALCsizei; data: PALCint); cdecl;
alcCaptureOpenDevice: function( const devicename: PALCchar; frequency: TALCuint; format: TALCenum; buffersize: TALCsizei): PALCdevice; cdecl;
alcCaptureCloseDevice: function( device: PALCdevice ): TALCboolean; cdecl;
alcCaptureStart: procedure( device: PALCdevice ); cdecl;
alcCaptureStop: procedure( device: PALCdevice ); cdecl;
alcCaptureSamples: procedure( device: PALCdevice; buffer: TALCvoid; samples: TALCsizei ); cdecl;
EAXSet: Function(const Guid: TGUID; ALuint1: TALuint; ALuint2: TALuint; point: Pointer; ALuint3: TALuint): TALenum; cdecl;
EAXGet: Function(const Guid: TGUID; ALuint1: TALuint; ALuint2: TALuint; point: Pointer; ALuint3: TALuint): TALenum; cdecl;
AL_EAX_RAM_SIZE: TALEnum;
AL_EAX_RAM_FREE: TALEnum;
AL_STORAGE_AUTOMATIC: TALEnum;
AL_STORAGE_HARDWARE: TALEnum;
AL_STORAGE_ACCESSIBLE: TALEnum;
EAXSetBufferMode: function(n: TALsizei;buffers: PALuint; value: TALint ): TALboolean; cdecl;
EAXGetBufferMode: function(buffer: TALuint; value: PALint ): TALenum; cdecl;
ALGENEFFECTS: procedure( n: TALsizei; effects: PALuint ); cdecl;
ALDELETEEFFECTS: procedure( n: TALsizei; effects: PALuint ); cdecl;
ALISEFFECT: function( eid: TALuint ): TALboolean; cdecl;
ALEFFECTI: procedure( eid: TALuint; param: TALCenum; value: TALint); cdecl;
ALEFFECTIV: procedure( eid: TALuint; param: TALenum; values: PALint ); cdecl;
ALEFFECTF: procedure( eid: TALuint; param: TALenum; value: TALfloat); cdecl;
ALEFFECTFV: procedure( eid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETEFFECTI: procedure( eid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETEFFECTIV: procedure( eid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETEFFECTF: procedure( eid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETEFFECTFV: procedure( eid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGENFILTERS: procedure( n: TALsizei; filters: PALuint ); cdecl;
ALDELETEFILTERS: procedure( n: TALsizei; filters: PALuint ); cdecl;
ALISFILTER: function( fid: TALuint ): TALboolean; cdecl;
ALFILTERI: procedure( fid: TALuint; param: TALenum; value: TALint ); cdecl;
ALFILTERIV: procedure( fid: TALuint; param: TALenum; values: PALint ); cdecl;
ALFILTERF: procedure( fid: TALuint; param: TALenum; value: TALfloat); cdecl;
ALFILTERFV: procedure( fid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETFILTERI: procedure( fid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETFILTERIV: procedure( fid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETFILTERF: procedure( fid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETFILTERFV: procedure( fid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGENAUXILIARYEFFECTSLOTS: procedure( n: TALsizei; slots: PALuint ); cdecl;
ALDELETEAUXILIARYEFFECTSLOTS: procedure( n: TALsizei; slots: PALuint ); cdecl;
ALISAUXILIARYEFFECTSLOT: function( slot: TALuint ): TALboolean; cdecl;
ALAUXILIARYEFFECTSLOTI: procedure( asid: TALuint; param: TALenum; value: TALint ); cdecl;
ALAUXILIARYEFFECTSLOTIV: procedure( asid: TALuint; param: TALenum; values: PALint ); cdecl;
ALAUXILIARYEFFECTSLOTF: procedure( asid: TALuint; param: TALenum; value: TALfloat ); cdecl;
ALAUXILIARYEFFECTSLOTFV: procedure( asid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETAUXILIARYEFFECTSLOTI: procedure( asid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETAUXILIARYEFFECTSLOTIV: procedure( asid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETAUXILIARYEFFECTSLOTF: procedure( asid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETAUXILIARYEFFECTSLOTFV: procedure( asid: TALuint; param: TALenum; values: PALfloat ); cdecl;
LibHandle: THandle = 0;
EFXUtilLibHandle: THandle = 0;

Description

Functions and Procedures

procedure alutInit(argc: PALint; argv: array of PALbyte);

Internal Alut functions

procedure alutExit;

This item has no description.

procedure alutLoadWAVFile(fname: string; var format: TALenum; var data: TALvoid; var size: TALsizei; var freq: TALsizei; var loop: TALint);

This item has no description.

procedure alutLoadWAVMemory(memory: PALbyte; var format: TALenum; var data: TALvoid; var size: TALsizei; var freq: TALsizei; var loop: TALint);

This item has no description.

procedure alutUnloadWAV(format: TALenum; data: TALvoid; size: TALsizei; freq: TALsizei);

This item has no description.

function InitOpenAL(LibName: String = callibname): Boolean;

This item has no description.

procedure ReadOpenALExtensions;

This item has no description.

Types

DSPROPERTY_EAX_BUFFERPROPERTY = LongWORD;

This item has no description.

DSPROPERTY_EAX_LISTENERPROPERTY = LongWORD;

EAX extension

EFXEAXREVERBPROPERTIES = _EFXEAXREVERBPROPERTIES;

This item has no description.

EFXLOWPASSFILTER = _EFXLOWPASSFILTER;

This item has no description.

HMODULE = THandle;

This item has no description.

PALbitfield = ˆTALbitfield;

This item has no description.

PALboolean = ˆTALboolean;

This item has no description.

PALbyte = ˆTALbyte;

This item has no description.

PALCboolean = ˆTALCboolean;

This item has no description.

PALCbyte = ˆTALCbyte;

This item has no description.

PALCchar = PAnsiChar;

This item has no description.

PALCcontext = ˆTALCcontext;

This item has no description.

PALCdevice = ˆTALCdevice;

This item has no description.

PALCdouble = ˆTALCdouble;

This item has no description.

PALCenum = ˆTALCenum;

This item has no description.

PALCfloat = ˆTALCfloat;

This item has no description.

PALchar = PAnsiChar;

This item has no description.

PALCint = ˆTALCint;

This item has no description.

PALclampd = ˆTALclampd;

This item has no description.

PALclampf = ˆTALclampf;

This item has no description.

PALCshort = ˆTALCshort;

This item has no description.

PALCsizei = ˆTALCsizei;

This item has no description.

PALCubyte = PAnsiChar;

This item has no description.

PALCuint = ˆTALCuint;

This item has no description.

PALCushort = ˆTALCushort;

This item has no description.

PALCvoid = ˆTALCvoid;

This item has no description.

PALdouble = ˆTALdouble;

This item has no description.

PALenum = ˆTALenum;

This item has no description.

PALfloat = ˆTALfloat;

This item has no description.

PALint = ˆTALint;

This item has no description.

PALshort = ˆTALshort;

This item has no description.

PALsizei = ˆTALsizei;

This item has no description.

PALuByte = PAnsiChar;

This item has no description.

PALuint = ˆTALuint;

This item has no description.

PALushort = ˆTALushort;

This item has no description.

PALvoid = ˆTALvoid;

This item has no description.

PEaxBufferProperties = ˆTEaxBufferProperties;

This item has no description.

PEaxListenerProperties = ˆTEaxListenerProperties;

This item has no description.

PEFXEAXREVERBPROPERTIES = ˆ_EFXEAXREVERBPROPERTIES;

This item has no description.

PEFXLOWPASSFILTER = ˆ_EFXLOWPASSFILTER;

This item has no description.

PPALvoid = ˆPALvoid;

This item has no description.

TALbitfield = Cardinal;

OpenAL bitfields.

TALboolean = Boolean;

OpenAL boolean type.

TALbyte = ShortInt;

OpenAL 8bit signed byte.

TALCboolean = boolean;

ALC boolean type.

TALCbyte = ShortInt;

ALC 8bit signed byte.

TALCchar = char;

ALC character type

TALCcontext = TALCvoid;

ALC context

TALCdevice = TALCvoid;

ALC device

TALCdouble = double;

ALC 64bit double point type.

TALCenum = integer;

ALC enumerations.

TALCfloat = single;

ALC 32bit floating point type.

TALchar = char;

character

TALCint = integer;

ALC 32bit signed integer type.

TALclampd = TALdouble;

Openal clamped double.

TALclampf = TALfloat;

OpenAL clamped float.

TALCshort = smallint;

ALC 16bit signed short integer type.

TALCsizei = integer;

ALC 32bit type.

TALCubyte = Char;

ALC 8bit unsigned byte.

TALCuint = Cardinal;

ALC 32bit unsigned integer type.

TALCushort = Word;

ALC 16bit unsigned short integer type.

TALCvoid = Pointer;

ALC void type

TALdouble = Double;

OpenAL 64bit double point type.

TALenum = Integer;

OpenAL enumerations.

TALfloat = Single;

OpenAL 32bit floating point type.

TALint = Integer;

OpenAL 32bit signed integer type.

TALshort = SmallInt;

OpenAL 16bit signed short integer type.

TALsizei = Cardinal;

OpenAL 32bit type.

TALuByte = Char;

OpenAL 8bit unsigned byte.

TALuint = Cardinal;

OpenAL 32bit unsigned integer type.

TALushort = Word;

OpenAL 16bit unsigned short integer type.

TALvoid = Pointer;

OpenAL void type

Constants

callibname='OpenAL32.dll';

define ALUT to use alut.dll

calutlibname='Alut.dll';

This item has no description.

AL_INVALID = -1;

END EAX Extension bad value

AL_NONE = 0;

This item has no description.

AL_FALSE = 0;

Boolean False.

AL_TRUE = 1;

Boolean True.

AL_SOURCE_ABSOLUTE = $201;

Indicate the type of AL_SOURCE. Sources can be spatialized AL_SOURCE_TYPE = $200; Indicate source has absolute coordinates.

AL_SOURCE_RELATIVE = $202;

Indicate Source has relative coordinates.

AL_CONE_INNER_ANGLE = $1001;

Directional source, inner cone angle, in degrees. Range: [0-360] Default: 360

AL_CONE_OUTER_ANGLE = $1002;

Directional source, outer cone angle, in degrees. Range: [0-360] Default: 360

AL_PITCH =$1003;

Specify the pitch to be applied, either at source, or on mixer results, at listener. Range: [0.5-2.0] Default: 1.0

AL_POSITION =$1004;

Specify the current location in three dimensional space. OpenAL, like OpenGL, uses a right handed coordinate system, where in a frontal default view X (thumb) points right, Y points up (index finger), and Z points towards the viewer/camera (middle finger). To switch from a left handed coordinate system, flip the sign on the Z coordinate. Listener position is always in the world coordinate system.

AL_DIRECTION =$1005;

Specify the current direction.

AL_VELOCITY =$1006;

Specify the current velocity in three dimensional space.

AL_LOOPING =$1007;

Indicate whether source is looping. Type: ALboolean? Range: [AL_TRUE, AL_FALSE] Default: FALSE.

AL_BUFFER =$1009;

Indicate the buffer to provide sound samples. Type: ALuint. Range: any valid Buffer id.

AL_GAIN =$100A;

Indicate the gain (volume amplification) applied. Type: ALfloat. Range: ]0.0- ] A value of 1.0 means un-attenuated/unchanged. Each division by 2 equals an attenuation of -6dB. Each multiplicaton with 2 equals an amplification of +6dB. A value of 0.0 is meaningless with respect to a logarithmic scale; it is interpreted as zero volume - the channel is effectively disabled.

AL_MIN_GAIN =$100D;

Indicate minimum source attenuation Type: ALfloat Range: [0.0 - 1.0] Logarthmic

AL_MAX_GAIN =$100E;

Indicate maximum source attenuation Type: ALfloat Range: [0.0 - 1.0] Logarthmic

AL_ORIENTATION =$100F;

Indicate listener orientation. at/up

AL_CHANNEL_MASK =$3000;

Specify the channel mask. (Creative) Type: ALuint Range: [0 - 255]

AL_SOURCE_STATE =$1010;

Source state information.

AL_INITIAL =$1011;

This item has no description.

AL_PLAYING =$1012;

This item has no description.

AL_PAUSED =$1013;

This item has no description.

AL_STOPPED =$1014;

This item has no description.

AL_BUFFERS_QUEUED =$1015;

Buffer Queue params

AL_BUFFERS_PROCESSED =$1016;

This item has no description.

AL_SEC_OFFSET = $1024;

Source buffer position information

AL_SAMPLE_OFFSET = $1025;

This item has no description.

AL_BYTE_OFFSET = $1026;

This item has no description.

AL_SOURCE_TYPE = $1027;

Source type (Static, Streaming or undetermined) Source is Static if a Buffer has been attached using AL_BUFFER Source is Streaming if one or more Buffers have been attached using alSourceQueueBuffers Source is undetermined when it has the NULL buffer attached

AL_STATIC = $1028;

This item has no description.

AL_STREAMING = $1029;

This item has no description.

AL_UNDETERMINED = $1030;

This item has no description.

AL_FORMAT_MONO8 =$1100;

Sound samples: format specifier.

AL_FORMAT_MONO16 =$1101;

This item has no description.

AL_FORMAT_STEREO8 =$1102;

This item has no description.

AL_FORMAT_STEREO16 =$1103;

This item has no description.

AL_REFERENCE_DISTANCE =$1020;

source specific reference distance Type: ALfloat Range: 0.0 - +inf At 0.0, no distance attenuation occurs. Default is 1.0.

AL_ROLLOFF_FACTOR =$1021;

source specific rolloff factor Type: ALfloat Range: 0.0 - +inf

AL_CONE_OUTER_GAIN =$1022;

Directional source, outer cone gain. Default: 0.0 Range: [0.0 - 1.0] Logarithmic

AL_MAX_DISTANCE =$1023;

Indicate distance above which sources are not attenuated using the inverse clamped distance model. Default: +inf Type: ALfloat Range: 0.0 - +inf

AL_FREQUENCY =$2001;

Sound samples: frequency, in units of Hertz [Hz]. This is the number of samples per second. Half of the sample frequency marks the maximum significant frequency component.

AL_BITS =$2002;

This item has no description.

AL_CHANNELS =$2003;

This item has no description.

AL_SIZE =$2004;

This item has no description.

AL_UNUSED =$2010;

AL_DATA =$2005; Buffer state. Not supported for public use (yet).

AL_PENDING =$2011;

This item has no description.

AL_PROCESSED =$2012;

This item has no description.

AL_NO_ERROR =AL_FALSE;

Errors: No Error.

AL_INVALID_NAME =$A001;

Invalid Name paramater passed to AL call.

AL_ILLEGAL_ENUM =$A002;

Invalid parameter passed to AL call.

AL_INVALID_ENUM =$A002;

This item has no description.

AL_INVALID_VALUE =$A003;

Invalid enum parameter value.

AL_ILLEGAL_COMMAND =$A004;

Illegal call.

AL_INVALID_OPERATION =$A004;

This item has no description.

AL_OUT_OF_MEMORY =$A005;

No mojo.

AL_VENDOR =$B001;

Context strings: Vendor Name.

AL_VERSION =$B002;

This item has no description.

AL_RENDERER =$B003;

This item has no description.

AL_EXTENSIONS =$B004;

This item has no description.

AL_DOPPLER_FACTOR =$C000;

Global tweakage. Doppler scale. Default 1.0

AL_DOPPLER_VELOCITY =$C001;

Tweaks speed of propagation.

AL_SPEED_OF_SOUND = $C003;

Speed of Sound in units per second

AL_DISTANCE_MODEL =$D000;

Distance models

used in conjunction with DistanceModel

implicit: NONE, which disances distance attenuation.

AL_INVERSE_DISTANCE =$D001;

This item has no description.

AL_INVERSE_DISTANCE_CLAMPED =$D002;

This item has no description.

AL_LINEAR_DISTANCE =$D003;

This item has no description.

AL_LINEAR_DISTANCE_CLAMPED =$D004;

This item has no description.

AL_EXPONENT_DISTANCE =$D005;

This item has no description.

AL_EXPONENT_DISTANCE_CLAMPED =$D006;

This item has no description.

ALC_INVALID =0;

bad value

ALC_FALSE =0;

Boolean False.

ALC_TRUE =1;

Boolean True.

ALC_FREQUENCY =$1007;

followed by <int> Hz

ALC_REFRESH =$1008;

followed by <int> Hz

ALC_SYNC =$1009;

followed by AL_TRUE, AL_FALSE

ALC_MONO_SOURCES =$1010;

followed by <int> Num of requested Mono (3D) Sources

ALC_STEREO_SOURCES =$1011;

followed by <int> Num of requested Stereo Sources

ALC_NO_ERROR =ALC_FALSE;

errors No error

ALC_INVALID_DEVICE =$A001;

No device

ALC_INVALID_CONTEXT =$A002;

invalid context ID

ALC_INVALID_ENUM =$A003;

bad enum

ALC_INVALID_VALUE =$A004;

bad value

ALC_OUT_OF_MEMORY =$A005;

Out of memory.

ALC_DEFAULT_DEVICE_SPECIFIER =$1004;

The Specifier string for default device

ALC_DEVICE_SPECIFIER =$1005;

This item has no description.

ALC_EXTENSIONS =$1006;

This item has no description.

ALC_MAJOR_VERSION =$1000;

This item has no description.

ALC_MINOR_VERSION =$1001;

This item has no description.

ALC_ATTRIBUTES_SIZE =$1002;

This item has no description.

ALC_ALL_ATTRIBUTES =$1003;

This item has no description.

ALC_DEFAULT_ALL_DEVICES_SPECIFIER =$1012;

ALC_ENUMERATE_ALL_EXT enums

ALC_ALL_DEVICES_SPECIFIER =$1013;

This item has no description.

ALC_CAPTURE_DEVICE_SPECIFIER =$310;

Capture extension

ALC_CAPTURE_DEFAULT_DEVICE_SPECIFIER =$311;

This item has no description.

ALC_CAPTURE_SAMPLES =$312;

This item has no description.

ALC_EXT_EFX_NAME ='ALC_EXT_EFX';

EFX Extension

ALC_EFX_MAJOR_VERSION =$20001;

Context definitions to be used with alcCreateContext. These values must be unique and not conflict with other al context values.

ALC_EFX_MINOR_VERSION =$20002;

This item has no description.

ALC_MAX_AUXILIARY_SENDS =$20003;

This item has no description.

AL_METERS_PER_UNIT =$20004;

Listener definitions to be used with alListener functions. These values must be unique and not conflict with other al listener values.

AL_DIRECT_FILTER =$20005;

Source definitions to be used with alSource functions. These values must be unique and not conflict with other al source values.

AL_AUXILIARY_SEND_FILTER =$20006;

This item has no description.

AL_AIR_ABSORPTION_FACTOR =$20007;

This item has no description.

AL_ROOM_ROLLOFF_FACTOR =$20008;

This item has no description.

AL_CONE_OUTER_GAINHF =$20009;

This item has no description.

AL_DIRECT_FILTER_GAINHF_AUTO =$2000A;

This item has no description.

AL_AUXILIARY_SEND_FILTER_GAIN_AUTO =$2000B;

This item has no description.

AL_AUXILIARY_SEND_FILTER_GAINHF_AUTO =$2000C;

This item has no description.

AL_REVERB_DENSITY =$0001;

Effect object definitions to be used with alEffect functions. Effect parameter value definitions, ranges, and defaults appear farther down in this file. Reverb Parameters

AL_REVERB_DIFFUSION =$0002;

This item has no description.

AL_REVERB_GAIN =$0003;

This item has no description.

AL_REVERB_GAINHF =$0004;

This item has no description.

AL_REVERB_DECAY_TIME =$0005;

This item has no description.

AL_REVERB_DECAY_HFRATIO =$0006;

This item has no description.

AL_REVERB_REFLECTIONS_GAIN =$0007;

This item has no description.

AL_REVERB_REFLECTIONS_DELAY =$0008;

This item has no description.

AL_REVERB_LATE_REVERB_GAIN =$0009;

This item has no description.

AL_REVERB_LATE_REVERB_DELAY =$000A;

This item has no description.

AL_REVERB_AIR_ABSORPTION_GAINHF =$000B;

This item has no description.

AL_REVERB_ROOM_ROLLOFF_FACTOR =$000C;

This item has no description.

AL_REVERB_DECAY_HFLIMIT =$000D;

This item has no description.

AL_CHORUS_WAVEFORM =$0001;

Chorus Parameters

AL_CHORUS_PHASE =$0002;

This item has no description.

AL_CHORUS_RATE =$0003;

This item has no description.

AL_CHORUS_DEPTH =$0004;

This item has no description.

AL_CHORUS_FEEDBACK =$0005;

This item has no description.

AL_CHORUS_DELAY =$0006;

This item has no description.

AL_DISTORTION_EDGE =$0001;

Distortion Parameters

AL_DISTORTION_GAIN =$0002;

This item has no description.

AL_DISTORTION_LOWPASS_CUTOFF =$0003;

This item has no description.

AL_DISTORTION_EQCENTER =$0004;

This item has no description.

AL_DISTORTION_EQBANDWIDTH =$0005;

This item has no description.

AL_ECHO_DELAY =$0001;

Echo Parameters

AL_ECHO_LRDELAY =$0002;

This item has no description.

AL_ECHO_DAMPING =$0003;

This item has no description.

AL_ECHO_FEEDBACK =$0004;

This item has no description.

AL_ECHO_SPREAD =$0005;

This item has no description.

AL_FLANGER_WAVEFORM =$0001;

Flanger Parameters

AL_FLANGER_PHASE =$0002;

This item has no description.

AL_FLANGER_RATE =$0003;

This item has no description.

AL_FLANGER_DEPTH =$0004;

This item has no description.

AL_FLANGER_FEEDBACK =$0005;

This item has no description.

AL_FLANGER_DELAY =$0006;

This item has no description.

AL_FREQUENCY_SHIFTER_FREQUENCY =$0001;

Frequencyshifter Parameters

AL_FREQUENCY_SHIFTER_LEFT_DIRECTION =$0002;

This item has no description.

AL_FREQUENCY_SHIFTER_RIGHT_DIRECTION =$0003;

This item has no description.

AL_VOCAL_MORPHER_PHONEMEA =$0001;

Vocalmorpher Parameters

AL_VOCAL_MORPHER_PHONEMEA_COARSE_TUNING =$0002;

This item has no description.

AL_VOCAL_MORPHER_PHONEMEB =$0003;

This item has no description.

AL_VOCAL_MORPHER_PHONEMEB_COARSE_TUNING =$0004;

This item has no description.

AL_VOCAL_MORPHER_WAVEFORM =$0005;

This item has no description.

AL_VOCAL_MORPHER_RATE =$0006;

This item has no description.

AL_PITCH_SHIFTER_COARSE_TUNE =$0001;

Pitchshifter Parameters

AL_PITCH_SHIFTER_FINE_TUNE =$0002;

This item has no description.

AL_RING_MODULATOR_FREQUENCY =$0001;

Ringmodulator Parameters

AL_RING_MODULATOR_HIGHPASS_CUTOFF =$0002;

This item has no description.

AL_RING_MODULATOR_WAVEFORM =$0003;

This item has no description.

AL_AUTOWAH_ATTACK_TIME =$0001;

Autowah Parameters

AL_AUTOWAH_RELEASE_TIME =$0002;

This item has no description.

AL_AUTOWAH_RESONANCE =$0003;

This item has no description.

AL_AUTOWAH_PEAK_GAIN =$0004;

This item has no description.

AL_COMPRESSOR_ONOFF =$0001;

Compressor Parameters

AL_EQUALIZER_LOW_GAIN =$0001;

Equalizer Parameters

AL_EQUALIZER_LOW_CUTOFF =$0002;

This item has no description.

AL_EQUALIZER_MID1_GAIN =$0003;

This item has no description.

AL_EQUALIZER_MID1_CENTER =$0004;

This item has no description.

AL_EQUALIZER_MID1_WIDTH =$0005;

This item has no description.

AL_EQUALIZER_MID2_GAIN =$0006;

This item has no description.

AL_EQUALIZER_MID2_CENTER =$0007;

This item has no description.

AL_EQUALIZER_MID2_WIDTH =$0008;

This item has no description.

AL_EQUALIZER_HIGH_GAIN =$0009;

This item has no description.

AL_EQUALIZER_HIGH_CUTOFF =$000A;

This item has no description.

AL_EFFECT_FIRST_PARAMETER =$0000;

Effect type

AL_EFFECT_LAST_PARAMETER =$8000;

This item has no description.

AL_EFFECT_TYPE =$8001;

This item has no description.

AL_EFFECT_NULL =$0000;

Effect type definitions to be used with AL_EFFECT_TYPE.

AL_EFFECT_REVERB =$0001;

Can also be used as an Effect Object ID

AL_EFFECT_CHORUS =$0002;

This item has no description.

AL_EFFECT_DISTORTION =$0003;

This item has no description.

AL_EFFECT_ECHO =$0004;

This item has no description.

AL_EFFECT_FLANGER =$0005;

This item has no description.

AL_EFFECT_FREQUENCY_SHIFTER =$0006;

This item has no description.

AL_EFFECT_VOCAL_MORPHER =$0007;

This item has no description.

AL_EFFECT_PITCH_SHIFTER =$0008;

This item has no description.

AL_EFFECT_RING_MODULATOR =$0009;

This item has no description.

AL_EFFECT_AUTOWAH =$000A;

This item has no description.

AL_EFFECT_COMPRESSOR =$000B;

This item has no description.

AL_EFFECT_EQUALIZER =$000C;

This item has no description.

AL_EFFECTSLOT_EFFECT =$0001;

Auxiliary Slot object definitions to be used with alAuxiliaryEffectSlot functions.

AL_EFFECTSLOT_GAIN =$0002;

This item has no description.

AL_EFFECTSLOT_AUXILIARY_SEND_AUTO =$0003;

This item has no description.

AL_EFFECTSLOT_NULL =$0000;

Value to be used as an Auxiliary Slot ID to disable a source send..

AL_LOWPASS_GAIN =$0001;

Filter object definitions to be used with alFilter functions. Lowpass parameters.

AL_LOWPASS_GAINHF =$0002;

This item has no description.

AL_HIGHPASS_GAIN =$0001;

Highpass Parameters

AL_HIGHPASS_GAINLF =$0002;

This item has no description.

AL_BANDPASS_GAIN =$0001;

Bandpass Parameters

AL_BANDPASS_GAINLF =$0002;

This item has no description.

AL_BANDPASS_GAINHF =$0003;

This item has no description.

AL_FILTER_FIRST_PARAMETER =$0000;

Filter type

AL_FILTER_LAST_PARAMETER =$8000;

This item has no description.

AL_FILTER_TYPE =$8001;

This item has no description.

AL_FILTER_NULL =$0000;

Filter type definitions to be used with AL_FILTER_TYPE.

AL_FILTER_LOWPASS =$0001;

Can also be used as a Filter Object ID

AL_FILTER_HIGHPASS =$0002;

This item has no description.

AL_FILTER_BANDPASS =$0003;

This item has no description.

LOWPASS_MIN_GAIN =0.0;

Filter ranges and defaults. Lowpass filter

LOWPASS_MAX_GAIN =1.0;

This item has no description.

LOWPASS_DEFAULT_GAIN =1.0;

This item has no description.

LOWPASS_MIN_GAINHF =0.0;

This item has no description.

LOWPASS_MAX_GAINHF =1.0;

This item has no description.

LOWPASS_DEFAULT_GAINHF =1.0;

This item has no description.

HIGHPASS_MIN_GAIN =0.0;

Highpass filter

HIGHPASS_MAX_GAIN =1.0;

This item has no description.

HIGHPASS_DEFAULT_GAIN =1.0;

This item has no description.

HIGHPASS_MIN_GAINLF =0.0;

This item has no description.

HIGHPASS_MAX_GAINLF =1.0;

This item has no description.

HIGHPASS_DEFAULT_GAINLF =1.0;

This item has no description.

BANDPASS_MIN_GAIN =0.0;

Bandpass filter

BANDPASS_MAX_GAIN =1.0;

This item has no description.

BANDPASS_DEFAULT_GAIN =1.0;

This item has no description.

BANDPASS_MIN_GAINHF =0.0;

This item has no description.

BANDPASS_MAX_GAINHF =1.0;

This item has no description.

BANDPASS_DEFAULT_GAINHF =1.0;

This item has no description.

BANDPASS_MIN_GAINLF =0.0;

This item has no description.

BANDPASS_MAX_GAINLF =1.0;

This item has no description.

BANDPASS_DEFAULT_GAINLF =1.0;

This item has no description.

AL_REVERB_MIN_DENSITY =0.0;

Effect parameter structures, value definitions, ranges and defaults. AL reverb effect parameter ranges and defaults

AL_REVERB_MAX_DENSITY =1.0;

This item has no description.

AL_REVERB_DEFAULT_DENSITY =1.0;

This item has no description.

AL_REVERB_MIN_DIFFUSION =0.0;

This item has no description.

AL_REVERB_MAX_DIFFUSION =1.0;

This item has no description.

AL_REVERB_DEFAULT_DIFFUSION =1.0;

This item has no description.

AL_REVERB_MIN_GAIN =0.0;

This item has no description.

AL_REVERB_MAX_GAIN =1.0;

This item has no description.

AL_REVERB_DEFAULT_GAIN =0.32;

This item has no description.

AL_REVERB_MIN_GAINHF =0.0;

This item has no description.

AL_REVERB_MAX_GAINHF =1.0;

This item has no description.

AL_REVERB_DEFAULT_GAINHF =0.89;

This item has no description.

AL_REVERB_MIN_DECAY_TIME =0.1;

This item has no description.

AL_REVERB_MAX_DECAY_TIME =20.0;

This item has no description.

AL_REVERB_DEFAULT_DECAY_TIME =1.49;

This item has no description.

AL_REVERB_MIN_DECAY_HFRATIO =0.1;

This item has no description.

AL_REVERB_MAX_DECAY_HFRATIO =2.0;

This item has no description.

AL_REVERB_DEFAULT_DECAY_HFRATIO =0.83;

This item has no description.

AL_REVERB_MIN_REFLECTIONS_GAIN =0.0;

This item has no description.

AL_REVERB_MAX_REFLECTIONS_GAIN =3.16;

This item has no description.

AL_REVERB_DEFAULT_REFLECTIONS_GAIN =0.05;

This item has no description.

AL_REVERB_MIN_REFLECTIONS_DELAY =0.0;

This item has no description.

AL_REVERB_MAX_REFLECTIONS_DELAY =0.3;

This item has no description.

AL_REVERB_DEFAULT_REFLECTIONS_DELAY =0.007;

This item has no description.

AL_REVERB_MIN_LATE_REVERB_GAIN =0.0;

This item has no description.

AL_REVERB_MAX_LATE_REVERB_GAIN =10.0;

This item has no description.

AL_REVERB_DEFAULT_LATE_REVERB_GAIN =1.26;

This item has no description.

AL_REVERB_MIN_LATE_REVERB_DELAY =0.0;

This item has no description.

AL_REVERB_MAX_LATE_REVERB_DELAY =0.1;

This item has no description.

AL_REVERB_DEFAULT_LATE_REVERB_DELAY =0.011;

This item has no description.

AL_REVERB_MIN_AIR_ABSORPTION_GAINHF =0.892;

This item has no description.

AL_REVERB_MAX_AIR_ABSORPTION_GAINHF =1.0;

This item has no description.

AL_REVERB_DEFAULT_AIR_ABSORPTION_GAINHF =0.994;

This item has no description.

AL_REVERB_MIN_ROOM_ROLLOFF_FACTOR =0.0;

This item has no description.

AL_REVERB_MAX_ROOM_ROLLOFF_FACTOR =10.0;

This item has no description.

AL_REVERB_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;

This item has no description.

AL_REVERB_MIN_DECAY_HFLIMIT =AL_FALSE;

This item has no description.

AL_REVERB_MAX_DECAY_HFLIMIT =AL_TRUE;

This item has no description.

AL_REVERB_DEFAULT_DECAY_HFLIMIT =AL_TRUE;

This item has no description.

AL_CHORUS_MIN_WAVEFORM =0;

AL chorus effect parameter ranges and defaults

AL_CHORUS_MAX_WAVEFORM =1;

This item has no description.

AL_CHORUS_DEFAULT_WAVEFORM =1;

This item has no description.

AL_CHORUS_WAVEFORM_SINUSOID =0;

This item has no description.

AL_CHORUS_WAVEFORM_TRIANGLE =1;

This item has no description.

AL_CHORUS_MIN_PHASE =-180;

This item has no description.

AL_CHORUS_MAX_PHASE =180;

This item has no description.

AL_CHORUS_DEFAULT_PHASE =90;

This item has no description.

AL_CHORUS_MIN_RATE =0.0;

This item has no description.

AL_CHORUS_MAX_RATE =10.0;

This item has no description.

AL_CHORUS_DEFAULT_RATE =1.1;

This item has no description.

AL_CHORUS_MIN_DEPTH =0.0;

This item has no description.

AL_CHORUS_MAX_DEPTH =1.0;

This item has no description.

AL_CHORUS_DEFAULT_DEPTH =0.1;

This item has no description.

AL_CHORUS_MIN_FEEDBACK =-1.0;

This item has no description.

AL_CHORUS_MAX_FEEDBACK =1.0;

This item has no description.

AL_CHORUS_DEFAULT_FEEDBACK =0.25;

This item has no description.

AL_CHORUS_MIN_DELAY =0.0;

This item has no description.

AL_CHORUS_MAX_DELAY =0.016;

This item has no description.

AL_CHORUS_DEFAULT_DELAY =0.016;

This item has no description.

AL_DISTORTION_MIN_EDGE =0.0;

AL distortion effect parameter ranges and defaults

AL_DISTORTION_MAX_EDGE =1.0;

This item has no description.

AL_DISTORTION_DEFAULT_EDGE =0.2;

This item has no description.

AL_DISTORTION_MIN_GAIN =0.01;

This item has no description.

AL_DISTORTION_MAX_GAIN =1.0;

This item has no description.

AL_DISTORTION_DEFAULT_GAIN =0.05;

This item has no description.

AL_DISTORTION_MIN_LOWPASS_CUTOFF =80.0;

This item has no description.

AL_DISTORTION_MAX_LOWPASS_CUTOFF =24000.0;

This item has no description.

AL_DISTORTION_DEFAULT_LOWPASS_CUTOFF =8000.0;

This item has no description.

AL_DISTORTION_MIN_EQCENTER =80.0;

This item has no description.

AL_DISTORTION_MAX_EQCENTER =24000.0;

This item has no description.

AL_DISTORTION_DEFAULT_EQCENTER =3600.0;

This item has no description.

AL_DISTORTION_MIN_EQBANDWIDTH =80.0;

This item has no description.

AL_DISTORTION_MAX_EQBANDWIDTH =24000.0;

This item has no description.

AL_DISTORTION_DEFAULT_EQBANDWIDTH =3600.0;

This item has no description.

AL_ECHO_MIN_DELAY =0.0;

AL echo effect parameter ranges and defaults

AL_ECHO_MAX_DELAY =0.207;

This item has no description.

AL_ECHO_DEFAULT_DELAY =0.1;

This item has no description.

AL_ECHO_MIN_LRDELAY =0.0;

This item has no description.

AL_ECHO_MAX_LRDELAY =0.404;

This item has no description.

AL_ECHO_DEFAULT_LRDELAY =0.1;

This item has no description.

AL_ECHO_MIN_DAMPING =0.0;

This item has no description.

AL_ECHO_MAX_DAMPING =0.99;

This item has no description.

AL_ECHO_DEFAULT_DAMPING =0.5;

This item has no description.

AL_ECHO_MIN_FEEDBACK =0.0;

This item has no description.

AL_ECHO_MAX_FEEDBACK =1.0;

This item has no description.

AL_ECHO_DEFAULT_FEEDBACK =0.5;

This item has no description.

AL_ECHO_MIN_SPREAD =-1.0;

This item has no description.

AL_ECHO_MAX_SPREAD =1.0;

This item has no description.

AL_ECHO_DEFAULT_SPREAD =-1.0;

This item has no description.

AL_FLANGER_MIN_WAVEFORM =0;

AL flanger effect parameter ranges and defaults

AL_FLANGER_MAX_WAVEFORM =1;

This item has no description.

AL_FLANGER_DEFAULT_WAVEFORM =1;

This item has no description.

AL_FLANGER_WAVEFORM_SINUSOID =0;

This item has no description.

AL_FLANGER_WAVEFORM_TRIANGLE =1;

This item has no description.

AL_FLANGER_MIN_PHASE =-180;

This item has no description.

AL_FLANGER_MAX_PHASE =180;

This item has no description.

AL_FLANGER_DEFAULT_PHASE =0;

This item has no description.

AL_FLANGER_MIN_RATE =0.0;

This item has no description.

AL_FLANGER_MAX_RATE =10.0;

This item has no description.

AL_FLANGER_DEFAULT_RATE =0.27;

This item has no description.

AL_FLANGER_MIN_DEPTH =0.0;

This item has no description.

AL_FLANGER_MAX_DEPTH =1.0;

This item has no description.

AL_FLANGER_DEFAULT_DEPTH =1.0;

This item has no description.

AL_FLANGER_MIN_FEEDBACK =-1.0;

This item has no description.

AL_FLANGER_MAX_FEEDBACK =1.0;

This item has no description.

AL_FLANGER_DEFAULT_FEEDBACK =-0.5;

This item has no description.

AL_FLANGER_MIN_DELAY =0.0;

This item has no description.

AL_FLANGER_MAX_DELAY =0.004;

This item has no description.

AL_FLANGER_DEFAULT_DELAY =0.002;

This item has no description.

AL_FREQUENCY_SHIFTER_MIN_FREQUENCY =0.0;

AL frequency shifter effect parameter ranges and defaults

AL_FREQUENCY_SHIFTER_MAX_FREQUENCY =24000.0;

This item has no description.

AL_FREQUENCY_SHIFTER_DEFAULT_FREQUENCY =0.0;

This item has no description.

AL_FREQUENCY_SHIFTER_MIN_LEFT_DIRECTION =0;

This item has no description.

AL_FREQUENCY_SHIFTER_MAX_LEFT_DIRECTION =2;

This item has no description.

AL_FREQUENCY_SHIFTER_DEFAULT_LEFT_DIRECTION =0;

This item has no description.

AL_FREQUENCY_SHIFTER_MIN_RIGHT_DIRECTION =0;

This item has no description.

AL_FREQUENCY_SHIFTER_MAX_RIGHT_DIRECTION =2;

This item has no description.

AL_FREQUENCY_SHIFTER_DEFAULT_RIGHT_DIRECTION =0;

This item has no description.

AL_FREQUENCY_SHIFTER_DIRECTION_DOWN =0;

This item has no description.

AL_FREQUENCY_SHIFTER_DIRECTION_UP =1;

This item has no description.

AL_FREQUENCY_SHIFTER_DIRECTION_OFF =2;

This item has no description.

AL_VOCAL_MORPHER_MIN_PHONEMEA =0;

AL vocal morpher effect parameter ranges and defaults

AL_VOCAL_MORPHER_MAX_PHONEMEA =29;

This item has no description.

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA =0;

This item has no description.

AL_VOCAL_MORPHER_MIN_PHONEMEA_COARSE_TUNING =-24;

This item has no description.

AL_VOCAL_MORPHER_MAX_PHONEMEA_COARSE_TUNING =24;

This item has no description.

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA_COARSE_TUNING =0;

This item has no description.

AL_VOCAL_MORPHER_MIN_PHONEMEB =0;

This item has no description.

AL_VOCAL_MORPHER_MAX_PHONEMEB =29;

This item has no description.

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB =10;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_A =0;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_E =1;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_I =2;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_O =3;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_U =4;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_AA =5;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_AE =6;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_AH =7;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_AO =8;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_EH =9;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_ER =10;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_IH =11;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_IY =12;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_UH =13;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_UW =14;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_B =15;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_D =16;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_F =17;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_G =18;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_J =19;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_K =20;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_L =21;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_M =22;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_N =23;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_P =24;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_R =25;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_S =26;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_T =27;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_V =28;

This item has no description.

AL_VOCAL_MORPHER_PHONEME_Z =29;

This item has no description.

AL_VOCAL_MORPHER_MIN_PHONEMEB_COARSE_TUNING =-24;

This item has no description.

AL_VOCAL_MORPHER_MAX_PHONEMEB_COARSE_TUNING =24;

This item has no description.

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB_COARSE_TUNING =0;

This item has no description.

AL_VOCAL_MORPHER_MIN_WAVEFORM =0;

This item has no description.

AL_VOCAL_MORPHER_MAX_WAVEFORM =2;

This item has no description.

AL_VOCAL_MORPHER_DEFAULT_WAVEFORM =0;

This item has no description.

AL_VOCAL_MORPHER_WAVEFORM_SINUSOID =0;

This item has no description.

AL_VOCAL_MORPHER_WAVEFORM_TRIANGLE =1;

This item has no description.

AL_VOCAL_MORPHER_WAVEFORM_SAWTOOTH =2;

This item has no description.

AL_VOCAL_MORPHER_MIN_RATE =0.0;

This item has no description.

AL_VOCAL_MORPHER_MAX_RATE =10.0;

This item has no description.

AL_VOCAL_MORPHER_DEFAULT_RATE =1.41;

This item has no description.

AL_PITCH_SHIFTER_MIN_COARSE_TUNE =-12;

AL pitch shifter effect parameter ranges and defaults

AL_PITCH_SHIFTER_MAX_COARSE_TUNE =12;

This item has no description.

AL_PITCH_SHIFTER_DEFAULT_COARSE_TUNE =12;

This item has no description.

AL_PITCH_SHIFTER_MIN_FINE_TUNE =-50;

This item has no description.

AL_PITCH_SHIFTER_MAX_FINE_TUNE =50;

This item has no description.

AL_PITCH_SHIFTER_DEFAULT_FINE_TUNE =0;

This item has no description.

AL_RING_MODULATOR_MIN_FREQUENCY =0.0;

AL ring modulator effect parameter ranges and defaults

AL_RING_MODULATOR_MAX_FREQUENCY =8000.0;

This item has no description.

AL_RING_MODULATOR_DEFAULT_FREQUENCY =440.0;

This item has no description.

AL_RING_MODULATOR_MIN_HIGHPASS_CUTOFF =0.0;

This item has no description.

AL_RING_MODULATOR_MAX_HIGHPASS_CUTOFF =24000.0;

This item has no description.

AL_RING_MODULATOR_DEFAULT_HIGHPASS_CUTOFF =800.0;

This item has no description.

AL_RING_MODULATOR_MIN_WAVEFORM =0;

This item has no description.

AL_RING_MODULATOR_MAX_WAVEFORM =2;

This item has no description.

AL_RING_MODULATOR_DEFAULT_WAVEFORM =0;

This item has no description.

AL_RING_MODULATOR_SINUSOID =0;

This item has no description.

AL_RING_MODULATOR_SAWTOOTH =1;

This item has no description.

AL_RING_MODULATOR_SQUARE =2;

This item has no description.

AL_AUTOWAH_MIN_ATTACK_TIME =0.0001;

AL autowah effect parameter ranges and defaults

AL_AUTOWAH_MAX_ATTACK_TIME =1.0;

This item has no description.

AL_AUTOWAH_DEFAULT_ATTACK_TIME =0.06;

This item has no description.

AL_AUTOWAH_MIN_RELEASE_TIME =0.0001;

This item has no description.

AL_AUTOWAH_MAX_RELEASE_TIME =1.0;

This item has no description.

AL_AUTOWAH_DEFAULT_RELEASE_TIME =0.06;

This item has no description.

AL_AUTOWAH_MIN_RESONANCE =2.0;

This item has no description.

AL_AUTOWAH_MAX_RESONANCE =1000.0;

This item has no description.

AL_AUTOWAH_DEFAULT_RESONANCE =1000.0;

This item has no description.

AL_AUTOWAH_MIN_PEAK_GAIN =0.00003;

This item has no description.

AL_AUTOWAH_MAX_PEAK_GAIN =31621.0;

This item has no description.

AL_AUTOWAH_DEFAULT_PEAK_GAIN =11.22;

This item has no description.

AL_COMPRESSOR_MIN_ONOFF =0;

AL compressor effect parameter ranges and defaults

AL_COMPRESSOR_MAX_ONOFF =1;

This item has no description.

AL_COMPRESSOR_DEFAULT_ONOFF =1;

This item has no description.

AL_EQUALIZER_MIN_LOW_GAIN =0.126;

AL equalizer effect parameter ranges and defaults

AL_EQUALIZER_MAX_LOW_GAIN =7.943;

This item has no description.

AL_EQUALIZER_DEFAULT_LOW_GAIN =1.0;

This item has no description.

AL_EQUALIZER_MIN_LOW_CUTOFF =50.0;

This item has no description.

AL_EQUALIZER_MAX_LOW_CUTOFF =800.0;

This item has no description.

AL_EQUALIZER_DEFAULT_LOW_CUTOFF =200.0;

This item has no description.

AL_EQUALIZER_MIN_MID1_GAIN =0.126;

This item has no description.

AL_EQUALIZER_MAX_MID1_GAIN =7.943;

This item has no description.

AL_EQUALIZER_DEFAULT_MID1_GAIN =1.0;

This item has no description.

AL_EQUALIZER_MIN_MID1_CENTER =200.0;

This item has no description.

AL_EQUALIZER_MAX_MID1_CENTER =3000.0;

This item has no description.

AL_EQUALIZER_DEFAULT_MID1_CENTER =500.0;

This item has no description.

AL_EQUALIZER_MIN_MID1_WIDTH =0.01;

This item has no description.

AL_EQUALIZER_MAX_MID1_WIDTH =1.0;

This item has no description.

AL_EQUALIZER_DEFAULT_MID1_WIDTH =1.0;

This item has no description.

AL_EQUALIZER_MIN_MID2_GAIN =0.126;

This item has no description.

AL_EQUALIZER_MAX_MID2_GAIN =7.943;

This item has no description.

AL_EQUALIZER_DEFAULT_MID2_GAIN =1.0;

This item has no description.

AL_EQUALIZER_MIN_MID2_CENTER =1000.0;

This item has no description.

AL_EQUALIZER_MAX_MID2_CENTER =8000.0;

This item has no description.

AL_EQUALIZER_DEFAULT_MID2_CENTER =3000.0;

This item has no description.

AL_EQUALIZER_MIN_MID2_WIDTH =0.01;

This item has no description.

AL_EQUALIZER_MAX_MID2_WIDTH =1.0;

This item has no description.

AL_EQUALIZER_DEFAULT_MID2_WIDTH =1.0;

This item has no description.

AL_EQUALIZER_MIN_HIGH_GAIN =0.126;

This item has no description.

AL_EQUALIZER_MAX_HIGH_GAIN =7.943;

This item has no description.

AL_EQUALIZER_DEFAULT_HIGH_GAIN =1.0;

This item has no description.

AL_EQUALIZER_MIN_HIGH_CUTOFF =4000.0;

This item has no description.

AL_EQUALIZER_MAX_HIGH_CUTOFF =16000.0;

This item has no description.

AL_EQUALIZER_DEFAULT_HIGH_CUTOFF =6000.0;

This item has no description.

AL_MIN_AIR_ABSORPTION_FACTOR =0.0;

Source parameter value definitions, ranges and defaults.

AL_MAX_AIR_ABSORPTION_FACTOR =10.0;

This item has no description.

AL_DEFAULT_AIR_ABSORPTION_FACTOR =0.0;

This item has no description.

AL_MIN_ROOM_ROLLOFF_FACTOR =0.0;

This item has no description.

AL_MAX_ROOM_ROLLOFF_FACTOR =10.0;

This item has no description.

AL_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;

This item has no description.

AL_MIN_CONE_OUTER_GAINHF =0.0;

This item has no description.

AL_MAX_CONE_OUTER_GAINHF =1.0;

This item has no description.

AL_DEFAULT_CONE_OUTER_GAINHF =1.0;

This item has no description.

AL_MIN_DIRECT_FILTER_GAINHF_AUTO =AL_FALSE;

This item has no description.

AL_MAX_DIRECT_FILTER_GAINHF_AUTO =AL_TRUE;

This item has no description.

AL_DEFAULT_DIRECT_FILTER_GAINHF_AUTO =AL_TRUE;

This item has no description.

AL_MIN_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_FALSE;

This item has no description.

AL_MAX_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_TRUE;

This item has no description.

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_TRUE;

This item has no description.

AL_MIN_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_FALSE;

This item has no description.

AL_MAX_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_TRUE;

This item has no description.

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_TRUE;

This item has no description.

AL_DEFAULT_METERS_PER_UNIT =1.0;

Listener parameter value definitions, ranges and defaults. AL_MIN_METERS_PER_UNIT =FLT_MIN; AL_MAX_METERS_PER_UNIT =FLT_MAX;

AL_EAXREVERB_DENSITY =$0001;

EFX AEX extenstion Effect object definitions to be used with alEffect functions. Effect parameter value definitions, ranges, and defaults appear farther down in this file. AL EAXReverb effect parameters.

AL_EAXREVERB_DIFFUSION =$0002;

This item has no description.

AL_EAXREVERB_GAIN =$0003;

This item has no description.

AL_EAXREVERB_GAINHF =$0004;

This item has no description.

AL_EAXREVERB_GAINLF =$0005;

This item has no description.

AL_EAXREVERB_DECAY_TIME =$0006;

This item has no description.

AL_EAXREVERB_DECAY_HFRATIO =$0007;

This item has no description.

AL_EAXREVERB_DECAY_LFRATIO =$0008;

This item has no description.

AL_EAXREVERB_REFLECTIONS_GAIN =$0009;

This item has no description.

AL_EAXREVERB_REFLECTIONS_DELAY =$000A;

This item has no description.

AL_EAXREVERB_REFLECTIONS_PAN =$000B;

This item has no description.

AL_EAXREVERB_LATE_REVERB_GAIN =$000C;

This item has no description.

AL_EAXREVERB_LATE_REVERB_DELAY =$000D;

This item has no description.

AL_EAXREVERB_LATE_REVERB_PAN =$000E;

This item has no description.

AL_EAXREVERB_ECHO_TIME =$000F;

This item has no description.

AL_EAXREVERB_ECHO_DEPTH =$0010;

This item has no description.

AL_EAXREVERB_MODULATION_TIME =$0011;

This item has no description.

AL_EAXREVERB_MODULATION_DEPTH =$0012;

This item has no description.

AL_EAXREVERB_AIR_ABSORPTION_GAINHF =$0013;

This item has no description.

AL_EAXREVERB_HFREFERENCE =$0014;

This item has no description.

AL_EAXREVERB_LFREFERENCE =$0015;

This item has no description.

AL_EAXREVERB_ROOM_ROLLOFF_FACTOR =$0016;

This item has no description.

AL_EAXREVERB_DECAY_HFLIMIT =$0017;

This item has no description.

AL_EFFECT_EAXREVERB =$8000;

Effect type definitions to be used with AL_EFFECT_TYPE.

AL_EAXREVERB_MIN_DENSITY =0.0;

Effect parameter structures, value definitions, ranges and defaults. AL reverb effect parameter ranges and defaults

AL_EAXREVERB_MAX_DENSITY =1.0;

This item has no description.

AL_EAXREVERB_DEFAULT_DENSITY =1.0;

This item has no description.

AL_EAXREVERB_MIN_DIFFUSION =0.0;

This item has no description.

AL_EAXREVERB_MAX_DIFFUSION =1.0;

This item has no description.

AL_EAXREVERB_DEFAULT_DIFFUSION =1.0;

This item has no description.

AL_EAXREVERB_MIN_GAIN =0.0;

This item has no description.

AL_EAXREVERB_MAX_GAIN =1.0;

This item has no description.

AL_EAXREVERB_DEFAULT_GAIN =0.32;

This item has no description.

AL_EAXREVERB_MIN_GAINHF =0.0;

This item has no description.

AL_EAXREVERB_MAX_GAINHF =1.0;

This item has no description.

AL_EAXREVERB_DEFAULT_GAINHF =0.89;

This item has no description.

AL_EAXREVERB_MIN_GAINLF =0.0;

This item has no description.

AL_EAXREVERB_MAX_GAINLF =1.0;

This item has no description.

AL_EAXREVERB_DEFAULT_GAINLF =1.0;

This item has no description.

AL_EAXREVERB_MIN_DECAY_TIME =0.1;

This item has no description.

AL_EAXREVERB_MAX_DECAY_TIME =20.0;

This item has no description.

AL_EAXREVERB_DEFAULT_DECAY_TIME =1.49;

This item has no description.

AL_EAXREVERB_MIN_DECAY_HFRATIO =0.1;

This item has no description.

AL_EAXREVERB_MAX_DECAY_HFRATIO =2.0;

This item has no description.

AL_EAXREVERB_DEFAULT_DECAY_HFRATIO =0.83;

This item has no description.

AL_EAXREVERB_MIN_DECAY_LFRATIO =0.1;

This item has no description.

AL_EAXREVERB_MAX_DECAY_LFRATIO =2.0;

This item has no description.

AL_EAXREVERB_DEFAULT_DECAY_LFRATIO =1.0;

This item has no description.

AL_EAXREVERB_MIN_REFLECTIONS_GAIN =0.0;

This item has no description.

AL_EAXREVERB_MAX_REFLECTIONS_GAIN =3.16;

This item has no description.

AL_EAXREVERB_DEFAULT_REFLECTIONS_GAIN =0.05;

This item has no description.

AL_EAXREVERB_MIN_REFLECTIONS_DELAY =0.0;

This item has no description.

AL_EAXREVERB_MAX_REFLECTIONS_DELAY =0.3;

This item has no description.

AL_EAXREVERB_DEFAULT_REFLECTIONS_DELAY =0.007;

This item has no description.

AL_EAXREVERB_DEFAULT_REFLECTIONS_PAN: array[0..2] of TALFloat = (0.0, 0.0, 0.0);

This item has no description.

AL_EAXREVERB_MIN_LATE_REVERB_GAIN =0.0;

This item has no description.

AL_EAXREVERB_MAX_LATE_REVERB_GAIN =10.0;

This item has no description.

AL_EAXREVERB_DEFAULT_LATE_REVERB_GAIN =1.26;

This item has no description.

AL_EAXREVERB_MIN_LATE_REVERB_DELAY =0.0;

This item has no description.

AL_EAXREVERB_MAX_LATE_REVERB_DELAY =0.1;

This item has no description.

AL_EAXREVERB_DEFAULT_LATE_REVERB_DELAY =0.011;

This item has no description.

AL_EAXREVERB_DEFAULT_LATE_REVERB_PAN: array[0..2] of TALFloat = (0.0, 0.0, 0.0);

This item has no description.

AL_EAXREVERB_MIN_ECHO_TIME =0.075;

This item has no description.

AL_EAXREVERB_MAX_ECHO_TIME =0.25;

This item has no description.

AL_EAXREVERB_DEFAULT_ECHO_TIME =0.25;

This item has no description.

AL_EAXREVERB_MIN_ECHO_DEPTH =0.0;

This item has no description.

AL_EAXREVERB_MAX_ECHO_DEPTH =1.0;

This item has no description.

AL_EAXREVERB_DEFAULT_ECHO_DEPTH =0.0;

This item has no description.

AL_EAXREVERB_MIN_MODULATION_TIME =0.04;

This item has no description.

AL_EAXREVERB_MAX_MODULATION_TIME =4.0;

This item has no description.

AL_EAXREVERB_DEFAULT_MODULATION_TIME =0.25;

This item has no description.

AL_EAXREVERB_MIN_MODULATION_DEPTH =0.0;

This item has no description.

AL_EAXREVERB_MAX_MODULATION_DEPTH =1.0;

This item has no description.

AL_EAXREVERB_DEFAULT_MODULATION_DEPTH =0.0;

This item has no description.

AL_EAXREVERB_MIN_AIR_ABSORPTION_GAINHF =0.892;

This item has no description.

AL_EAXREVERB_MAX_AIR_ABSORPTION_GAINHF =1.0;

This item has no description.

AL_EAXREVERB_DEFAULT_AIR_ABSORPTION_GAINHF =0.994;

This item has no description.

AL_EAXREVERB_MIN_HFREFERENCE =1000.0;

This item has no description.

AL_EAXREVERB_MAX_HFREFERENCE =20000.0;

This item has no description.

AL_EAXREVERB_DEFAULT_HFREFERENCE =5000.0;

This item has no description.

AL_EAXREVERB_MIN_LFREFERENCE =20.0;

This item has no description.

AL_EAXREVERB_MAX_LFREFERENCE =1000.0;

This item has no description.

AL_EAXREVERB_DEFAULT_LFREFERENCE =250.0;

This item has no description.

AL_EAXREVERB_MIN_ROOM_ROLLOFF_FACTOR =0.0;

This item has no description.

AL_EAXREVERB_MAX_ROOM_ROLLOFF_FACTOR =10.0;

This item has no description.

AL_EAXREVERB_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;

This item has no description.

AL_EAXREVERB_MIN_DECAY_HFLIMIT = AL_FALSE;

This item has no description.

AL_EAXREVERB_MAX_DECAY_HFLIMIT = AL_TRUE;

This item has no description.

AL_EAXREVERB_DEFAULT_DECAY_HFLIMIT = AL_TRUE;

This item has no description.

DSPROPSETID_EAX20_ListenerProperties : TGuid = '{0306A6A8-B224-11d2-99E5-0000E8D8C722}';

END EFX extension EAX extension

DSPROPSETID_EAX20_BufferProperties : TGuid = '{0306A6A7-B224-11d2-99E5-0000E8D8C722}';

This item has no description.

DSPROPERTY_EAXLISTENER_NONE = 0;

For compatibility with future EAX versions: DSPROPSETID_EAX_ListenerProperties = DSPROPSETID_EAX20_ListenerProperties; DSPROPSETID_EAX_SourceProperties = DSPROPSETID_EAX20_BufferProperties; Enumerations DSPROPERTY_EAX_LISTENERPROPERTY

DSPROPERTY_EAXLISTENER_ALLPARAMETERS = 1;

This item has no description.

DSPROPERTY_EAXLISTENER_ROOM = 2;

This item has no description.

DSPROPERTY_EAXLISTENER_ROOMHF = 3;

This item has no description.

DSPROPERTY_EAXLISTENER_ROOMROLLOFFFACTOR = 4;

This item has no description.

DSPROPERTY_EAXLISTENER_DECAYTIME = 5;

This item has no description.

DSPROPERTY_EAXLISTENER_DECAYHFRATIO = 6;

This item has no description.

DSPROPERTY_EAXLISTENER_REFLECTIONS = 7;

This item has no description.

DSPROPERTY_EAXLISTENER_REFLECTIONSDELAY = 8;

This item has no description.

DSPROPERTY_EAXLISTENER_REVERB = 9;

This item has no description.

DSPROPERTY_EAXLISTENER_REVERBDELAY = 10;

This item has no description.

DSPROPERTY_EAXLISTENER_ENVIRONMENT = 11;

This item has no description.

DSPROPERTY_EAXLISTENER_ENVIRONMENTSIZE = 12;

This item has no description.

DSPROPERTY_EAXLISTENER_ENVIRONMENTDIFFUSION = 13;

This item has no description.

DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF = 14;

This item has no description.

DSPROPERTY_EAXLISTENER_FLAGS = 15;

This item has no description.

DSPROPERTY_EAXLISTENER_IMMEDIATE = $00000000;

OR these flags with property id

DSPROPERTY_EAXLISTENER_DEFERRED = LongWORD($80000000);

changes take effect immediately

DSPROPERTY_EAXLISTENER_COMMITDEFERREDSETTINGS = (DSPROPERTY_EAXLISTENER_NONE or DSPROPERTY_EAXLISTENER_IMMEDIATE);

This item has no description.

EAX_ENVIRONMENT_GENERIC = 0;

used by DSPROPERTY_EAXLISTENER_ENVIRONMENT Enummetation

EAX_ENVIRONMENT_PADDEDCELL = 1;

This item has no description.

EAX_ENVIRONMENT_ROOM = 2;

This item has no description.

EAX_ENVIRONMENT_BATHROOM = 3;

This item has no description.

EAX_ENVIRONMENT_LIVINGROOM = 4;

This item has no description.

EAX_ENVIRONMENT_STONEROOM = 5;

This item has no description.

EAX_ENVIRONMENT_AUDITORIUM = 6;

This item has no description.

EAX_ENVIRONMENT_CONCERTHALL = 7;

This item has no description.

EAX_ENVIRONMENT_CAVE = 8;

This item has no description.

EAX_ENVIRONMENT_ARENA = 9;

This item has no description.

EAX_ENVIRONMENT_HANGAR = 10;

This item has no description.

EAX_ENVIRONMENT_CARPETEDHALLWAY = 11;

This item has no description.

EAX_ENVIRONMENT_HALLWAY = 12;

This item has no description.

EAX_ENVIRONMENT_STONECORRIDOR = 13;

This item has no description.

EAX_ENVIRONMENT_ALLEY = 14;

This item has no description.

EAX_ENVIRONMENT_FOREST = 15;

This item has no description.

EAX_ENVIRONMENT_CITY = 16;

This item has no description.

EAX_ENVIRONMENT_MOUNTAINS = 17;

This item has no description.

EAX_ENVIRONMENT_QUARRY = 18;

This item has no description.

EAX_ENVIRONMENT_PLAIN = 19;

This item has no description.

EAX_ENVIRONMENT_PARKINGLOT = 20;

This item has no description.

EAX_ENVIRONMENT_SEWERPIPE = 21;

This item has no description.

EAX_ENVIRONMENT_UNDERWATER = 22;

This item has no description.

EAX_ENVIRONMENT_DRUGGED = 23;

This item has no description.

EAX_ENVIRONMENT_DIZZY = 24;

This item has no description.

EAX_ENVIRONMENT_PSYCHOTIC = 25;

This item has no description.

EAX_ENVIRONMENT_COUNT = 26;

This item has no description.

EAXLISTENERFLAGS_DECAYTIMESCALE = $00000001;

Used by DSPROPERTY_EAXLISTENER_FLAGS

Note: The number and order of flags may change in future EAX versions. It is recommended to use the flag defines as follows: myFlags = EAXLISTENERFLAGS_DECAYTIMESCALE | EAXLISTENERFLAGS_REVERBSCALE; instead of: myFlags = 0x00000009;

These flags determine what properties are affected by environment size.

EAXLISTENERFLAGS_REFLECTIONSSCALE = $00000002;

reverberation decay time

EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE = $00000004;

reflection level

EAXLISTENERFLAGS_REVERBSCALE = $00000008;

initial reflection delay time

EAXLISTENERFLAGS_REVERBDELAYSCALE = $00000010;

reflections level

EAXLISTENERFLAGS_DECAYHFLIMIT = $00000020;

late reverberation delay time This flag limits high-frequency decay time according to air absorption.

EAXLISTENERFLAGS_RESERVED = $FFFFFFC0;

This item has no description.

EAXLISTENER_MINROOM = -10000;

reserved future use property ranges and defaults:

EAXLISTENER_MAXROOM = 0;

This item has no description.

EAXLISTENER_DEFAULTROOM = -1000;

This item has no description.

EAXLISTENER_MINROOMHF = -10000;

This item has no description.

EAXLISTENER_MAXROOMHF = 0;

This item has no description.

EAXLISTENER_DEFAULTROOMHF = -100;

This item has no description.

EAXLISTENER_MINROOMROLLOFFFACTOR = 0.0;

This item has no description.

EAXLISTENER_MAXROOMROLLOFFFACTOR = 10.0;

This item has no description.

EAXLISTENER_DEFAULTROOMROLLOFFFACTOR = 0.0;

This item has no description.

EAXLISTENER_MINDECAYTIME = 0.1;

This item has no description.

EAXLISTENER_MAXDECAYTIME = 20.0;

This item has no description.

EAXLISTENER_DEFAULTDECAYTIME = 1.49;

This item has no description.

EAXLISTENER_MINDECAYHFRATIO = 0.1;

This item has no description.

EAXLISTENER_MAXDECAYHFRATIO = 2.0;

This item has no description.

EAXLISTENER_DEFAULTDECAYHFRATIO = 0.83;

This item has no description.

EAXLISTENER_MINREFLECTIONS = -10000;

This item has no description.

EAXLISTENER_MAXREFLECTIONS = 1000;

This item has no description.

EAXLISTENER_DEFAULTREFLECTIONS = -2602;

This item has no description.

EAXLISTENER_MINREFLECTIONSDELAY = 0.0;

This item has no description.

EAXLISTENER_MAXREFLECTIONSDELAY = 0.3;

This item has no description.

EAXLISTENER_DEFAULTREFLECTIONSDELAY = 0.007;

This item has no description.

EAXLISTENER_MINREVERB = -10000;

This item has no description.

EAXLISTENER_MAXREVERB = 2000;

This item has no description.

EAXLISTENER_DEFAULTREVERB = 200;

This item has no description.

EAXLISTENER_MINREVERBDELAY = 0.0;

This item has no description.

EAXLISTENER_MAXREVERBDELAY = 0.1;

This item has no description.

EAXLISTENER_DEFAULTREVERBDELAY = 0.011;

This item has no description.

EAXLISTENER_MINENVIRONMENT = 0;

This item has no description.

EAXLISTENER_MAXENVIRONMENT = EAX_ENVIRONMENT_COUNT - 1;

This item has no description.

EAXLISTENER_DEFAULTENVIRONMENT = EAX_ENVIRONMENT_GENERIC;

This item has no description.

EAXLISTENER_MINENVIRONMENTSIZE = 1.0;

This item has no description.

EAXLISTENER_MAXENVIRONMENTSIZE = 100.0;

This item has no description.

EAXLISTENER_DEFAULTENVIRONMENTSIZE = 7.5;

This item has no description.

EAXLISTENER_MINENVIRONMENTDIFFUSION = 0.0;

This item has no description.

EAXLISTENER_MAXENVIRONMENTDIFFUSION = 1.0;

This item has no description.

EAXLISTENER_DEFAULTENVIRONMENTDIFFUSION = 1.0;

This item has no description.

EAXLISTENER_MINAIRABSORPTIONHF = -100.0;

This item has no description.

EAXLISTENER_MAXAIRABSORPTIONHF = 0.0;

This item has no description.

EAXLISTENER_DEFAULTAIRABSORPTIONHF = -5.0;

This item has no description.

EAXLISTENER_DEFAULTFLAGS = EAXLISTENERFLAGS_DECAYTIMESCALE or EAXLISTENERFLAGS_REFLECTIONSSCALE or EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE or EAXLISTENERFLAGS_REVERBSCALE or EAXLISTENERFLAGS_REVERBDELAYSCALE or EAXLISTENERFLAGS_DECAYHFLIMIT;

This item has no description.

DSPROPERTY_EAXBUFFER_NONE = 0;

For compatibility with future EAX versions: DSPROPSETID_EAX_BufferProperties = DSPROPSETID_EAX20_BufferProperties; Enumeration DSPROPERTY_EAX_BUFFERPROPERTY

DSPROPERTY_EAXBUFFER_ALLPARAMETERS = 1;

This item has no description.

DSPROPERTY_EAXBUFFER_DIRECT = 2;

This item has no description.

DSPROPERTY_EAXBUFFER_DIRECTHF = 3;

This item has no description.

DSPROPERTY_EAXBUFFER_ROOM = 4;

This item has no description.

DSPROPERTY_EAXBUFFER_ROOMHF = 5;

This item has no description.

DSPROPERTY_EAXBUFFER_ROOMROLLOFFFACTOR = 6;

This item has no description.

DSPROPERTY_EAXBUFFER_OBSTRUCTION = 7;

This item has no description.

DSPROPERTY_EAXBUFFER_OBSTRUCTIONLFRATIO = 8;

This item has no description.

DSPROPERTY_EAXBUFFER_OCCLUSION = 9;

This item has no description.

DSPROPERTY_EAXBUFFER_OCCLUSIONLFRATIO = 10;

This item has no description.

DSPROPERTY_EAXBUFFER_OCCLUSIONROOMRATIO = 11;

This item has no description.

DSPROPERTY_EAXBUFFER_OUTSIDEVOLUMEHF = 12;

This item has no description.

DSPROPERTY_EAXBUFFER_AIRABSORPTIONFACTOR = 13;

This item has no description.

DSPROPERTY_EAXBUFFER_FLAG = 14;

This item has no description.

DSPROPERTY_EAXBUFFER_IMMEDIATE = $00000000;

OR these flags with property id

DSPROPERTY_EAXBUFFER_DEFERRED = LongWORD($80000000);

changes take effect immediately

DSPROPERTY_EAXBUFFER_COMMITDEFERREDSETTINGS = DSPROPERTY_EAXBUFFER_NONE or DSPROPERTY_EAXBUFFER_IMMEDIATE;

This item has no description.

EAXBUFFERFLAGS_DIRECTHFAUTO = $00000001;

Used by DSPROPERTY_EAXBUFFER_FLAGS TRUE: value is computed automatically - property is an offset FALSE: value is used directly

Note: The number and order of flags may change in future EAX versions. To insure future compatibility, use flag defines as follows: myFlags = EAXBUFFERFLAGS_DIRECTHFAUTO | EAXBUFFERFLAGS_ROOMAUTO; instead of: myFlags = 0x00000003;

EAXBUFFERFLAGS_ROOMAUTO = $00000002;

affects DSPROPERTY_EAXBUFFER_DIRECTHF

EAXBUFFERFLAGS_ROOMHFAUTO = $00000004;

affects DSPROPERTY_EAXBUFFER_ROOM

EAXBUFFERFLAGS_RESERVED = $FFFFFFF8;

affects DSPROPERTY_EAXBUFFER_ROOMHF

EAXBUFFER_MINDIRECT = -10000;

reserved future use property ranges and defaults:

EAXBUFFER_MAXDIRECT = 1000;

This item has no description.

EAXBUFFER_DEFAULTDIRECT = 0;

This item has no description.

EAXBUFFER_MINDIRECTHF = -10000;

This item has no description.

EAXBUFFER_MAXDIRECTHF = 0;

This item has no description.

EAXBUFFER_DEFAULTDIRECTHF = 0;

This item has no description.

EAXBUFFER_MINROOM = -10000;

This item has no description.

EAXBUFFER_MAXROOM = 1000;

This item has no description.

EAXBUFFER_DEFAULTROOM = 0;

This item has no description.

EAXBUFFER_MINROOMHF = -10000;

This item has no description.

EAXBUFFER_MAXROOMHF = 0;

This item has no description.

EAXBUFFER_DEFAULTROOMHF = 0;

This item has no description.

EAXBUFFER_MINROOMROLLOFFFACTOR = 0.0;

This item has no description.

EAXBUFFER_MAXROOMROLLOFFFACTOR = 10.;

This item has no description.

EAXBUFFER_DEFAULTROOMROLLOFFFACTOR = 0.0;

This item has no description.

EAXBUFFER_MINOBSTRUCTION = -10000;

This item has no description.

EAXBUFFER_MAXOBSTRUCTION = 0;

This item has no description.

EAXBUFFER_DEFAULTOBSTRUCTION = 0;

This item has no description.

EAXBUFFER_MINOBSTRUCTIONLFRATIO = 0.0;

This item has no description.

EAXBUFFER_MAXOBSTRUCTIONLFRATIO = 1.0;

This item has no description.

EAXBUFFER_DEFAULTOBSTRUCTIONLFRATIO = 0.0;

This item has no description.

EAXBUFFER_MINOCCLUSION = -10000;

This item has no description.

EAXBUFFER_MAXOCCLUSION = 0;

This item has no description.

EAXBUFFER_DEFAULTOCCLUSION = 0;

This item has no description.

EAXBUFFER_MINOCCLUSIONLFRATIO = 0.0;

This item has no description.

EAXBUFFER_MAXOCCLUSIONLFRATIO = 1.0;

This item has no description.

EAXBUFFER_DEFAULTOCCLUSIONLFRATIO = 0.25;

This item has no description.

EAXBUFFER_MINOCCLUSIONROOMRATIO = 0.0;

This item has no description.

EAXBUFFER_MAXOCCLUSIONROOMRATIO = 10.0;

This item has no description.

EAXBUFFER_DEFAULTOCCLUSIONROOMRATIO = 0.5;

This item has no description.

EAXBUFFER_MINOUTSIDEVOLUMEHF = -10000;

This item has no description.

EAXBUFFER_MAXOUTSIDEVOLUMEHF = 0;

This item has no description.

EAXBUFFER_DEFAULTOUTSIDEVOLUMEHF = 0;

This item has no description.

EAXBUFFER_MINAIRABSORPTIONFACTOR = 0.0;

This item has no description.

EAXBUFFER_MAXAIRABSORPTIONFACTOR = 10.0;

This item has no description.

EAXBUFFER_DEFAULTAIRABSORPTIONFACTOR = 1.0;

This item has no description.

EAXBUFFER_DEFAULTFLAGS = EAXBUFFERFLAGS_DIRECTHFAUTO or EAXBUFFERFLAGS_ROOMAUTO or EAXBUFFERFLAGS_ROOMHFAUTO;

This item has no description.

EAX_MATERIAL_SINGLEWINDOW = -2800;

Material transmission presets 3 values in this order: 1: occlusion (or obstruction) 2: occlusion LF Ratio (or obstruction LF Ratio) 3: occlusion Room Ratio Single window material preset

EAX_MATERIAL_SINGLEWINDOWLF = 0.71;

This item has no description.

EAX_MATERIAL_SINGLEWINDOWROOMRATIO = 0.43;

This item has no description.

EAX_MATERIAL_DOUBLEWINDOW = -5000;

Double window material preset

EAX_MATERIAL_DOUBLEWINDOWHF = 0.40;

This item has no description.

EAX_MATERIAL_DOUBLEWINDOWROOMRATIO = 0.24;

This item has no description.

EAX_MATERIAL_THINDOOR = -1800;

Thin door material preset

EAX_MATERIAL_THINDOORLF = 0.66;

This item has no description.

EAX_MATERIAL_THINDOORROOMRATIO = 0.66;

This item has no description.

EAX_MATERIAL_THICKDOOR = -4400;

Thick door material preset

EAX_MATERIAL_THICKDOORLF = 0.64;

This item has no description.

EAX_MATERIAL_THICKDOORROOMRTATION = 0.27;

This item has no description.

EAX_MATERIAL_WOODWALL = -4000;

Wood wall material preset

EAX_MATERIAL_WOODWALLLF = 0.50;

This item has no description.

EAX_MATERIAL_WOODWALLROOMRATIO = 0.30;

This item has no description.

EAX_MATERIAL_BRICKWALL = -5000;

Brick wall material preset

EAX_MATERIAL_BRICKWALLLF = 0.60;

This item has no description.

EAX_MATERIAL_BRICKWALLROOMRATIO = 0.24;

This item has no description.

EAX_MATERIAL_STONEWALL = -6000;

Stone wall material preset

EAX_MATERIAL_STONEWALLLF = 0.68;

This item has no description.

EAX_MATERIAL_STONEWALLROOMRATIO = 0.20;

This item has no description.

EAX_MATERIAL_CURTAIN = -1200;

Curtain material preset

EAX_MATERIAL_CURTAINLF = 0.15;

This item has no description.

EAX_MATERIAL_CURTAINROOMRATIO = 1.00;

This item has no description.

Variables

alEnable: procedure(capability: TALenum); cdecl;

END EAX extension OpenAL Maintenance Functions State Management and Query. Error Handling. Extension Support. Renderer State management.

alDisable: procedure(capability: TALenum); cdecl;

This item has no description.

alIsEnabled: function(capability: TALenum): TALboolean; cdecl;

This item has no description.

alHint: procedure(target, mode: TALenum); cdecl;

Application preferences for driver performance choices.

alGetBooleanv: procedure(param: TALenum; data: PALboolean); cdecl;

State retrieval.

alGetIntegerv: procedure(param: TALenum; data: PALint); cdecl;

This item has no description.

alGetFloatv: procedure(param: TALenum; data: PALfloat); cdecl;

This item has no description.

alGetDoublev: procedure(param: TALenum; data: PALdouble); cdecl;

This item has no description.

alGetString: function(param: TALenum): PALubyte; cdecl;

This item has no description.

alGetBoolean: function(param: TALenum): TALboolean; cdecl;

State retrieval.through return value ( for compatibility )

alGetInteger: function(param: TALenum): TALint; cdecl;

This item has no description.

alGetFloat: function(param: TALenum): TALfloat; cdecl;

This item has no description.

alGetDouble: function(param: TALenum): TALdouble; cdecl;

This item has no description.

alGetError: function: TALenum; cdecl;

ERROR support. Obtain the most recent error generated in the AL state machine.

alIsExtensionPresent: function(fname: PAnsiChar): TALboolean; cdecl;

EXTENSION support. Obtain the address of a function (usually an extension) with the name fname. All addresses are context-independent.

alGetProcAddress: function(fname: PALuByte): Pointer; cdecl;

Obtain the address of a function (usually an extension) with the name fname. All addresses are context-independent.

alGetEnumValue: function(ename: PALuByte): TALenum; cdecl;

Obtain the integer value of an enumeration (usually an extension) with the name ename.

alListenerf: procedure(param: TALenum; value: TALfloat); cdecl;

LISTENER Listener is the sample position for a given context. The multi-channel (usually stereo) output stream generated by the mixer is parametrized by this Listener object: its position and velocity relative to Sources, within occluder and reflector geometry. Listener Gain: default 1.0f.

alListener3f: procedure(param: TALenum; f1: TALfloat; f2: TALfloat; f3: TALfloat); cdecl;

Listener Position. Listener Velocity.

alListenerfv: procedure(param: TALenum; values: PALfloat); cdecl;

Listener Position: array [0..2] of TALfloat Listener Velocity: array [0..2] of TALfloat Listener Orientation: array [0..5] of TALfloat forward and up vector.

alListeneri: procedure(param: TAlenum; value: TALint); cdecl;

Listener Environment: default 0.

alListener3i: procedure(param: TALenum; value1: TALint; value2: TALint; value3: TALint );

This item has no description.

alListeneriv: procedure(param: TALenum; const values: PALint );

This item has no description.

alGetListeneriv: procedure(param: TALenum; values: PALint); cdecl;

TODO: verder ontbrekende functies toevoegen. Retrieve listener information

alGetListenerfv: procedure(param: TALenum; values: PALfloat); cdecl;

This item has no description.

alGenSources: procedure(n: TALsizei; sources: PALuint); cdecl;

SOURCE Source objects are by default localized. Sources take the PCM data provided in the specified Buffer, apply Source-specific modifications, and then submit them to be mixed according to spatial arrangement etc. Create Source objects.

alDeleteSources: procedure(n: TALsizei; sources: PALuint); cdecl;

Delete Source objects.

alIsSource: function(id: TALuint): TALboolean; cdecl;

Verify a handle is a valid Source.

alSourcei: procedure(source: TALuint; param: TALenum; value: TALint); cdecl;

Set an integer parameter for a Source object.

alSource3i: procedure(source: TALuint; param: TALenum; v1: TALint; v2: TALint; v3: TALint); cdecl;

Set an 3 integer parameter for a Source object.

alSourceiv: procedure(source: TALuint; param: TALenum; values: PALint); cdecl;

Set an integer vector parameter for a Source object.

alSourcef: procedure(source: TALuint; param: TALenum; value: TALfloat); cdecl;

Set a float parameter for a Source object.

alSource3f: procedure(source: TALuint; param: TALenum; v1: TALfloat; v2: TALfloat; v3: TALfloat); cdecl;

Set a 3 float parameter for a Source object.

alSourcefv: procedure(source: TALuint; param: TALenum; values: PALfloat); cdecl;

Set a float vector parameter for a Source object.

alGetSourcei: procedure(source: TALuint; param: TALenum; value: PALint); cdecl;

Get an integer scalar parameter for a Source object.

alGetSource3i: procedure(source: TALuint; param: TALenum; v1: PALint; v2: PALint; v3: PALint); cdecl;

Get three integer scalar parameter for a Source object.

alGetSourceiv: procedure(source: TALuint; param: TALenum; values: PALint); cdecl;

Get a integer vector parameter for a Source object.

alGetSourcef: procedure(source: TALuint; param: TALenum; value: PALfloat); cdecl;

Get a float scalar parameter for a Source object.

alGetSource3f: procedure(source: TALuint; param: TALenum; v1: PALfloat; v2: PALfloat; v3: PALfloat); cdecl;

Get three float scalar parameter for a Source object.

alGetSourcefv: procedure(source: TALuint; param: TALenum; values: PALfloat); cdecl;

Get a float vector parameter for a Source object.

alSourcePlay: procedure(source: TALuint); cdecl;

Activate a source, start replay.

alSourcePause: procedure(source: TALuint); cdecl;

Pause a source, temporarily remove it from the mixer list.

alSourceStop: procedure(source: TALuint); cdecl;

Stop a source, temporarily remove it from the mixer list, and reset its internal state to pre-Play. To remove a Source completely, it has to be deleted following Stop, or before Play.

alSourceRewind: procedure(source: TALuint); cdecl;

Rewind a souce. Stopped paused and playing sources, resets the offset into the PCM data and sets state to AL_INITIAL.

alSourcePlayv: procedure(n: TALsizei; sources: PALuint); cdecl;

vector forms of those functions we all love

alSourceStopv: procedure(n: TALsizei; sources: PALuint); cdecl;

This item has no description.

alSourceRewindv: procedure(n: TALsizei; sources: PALuint); cdecl;

This item has no description.

alSourcePausev: procedure(n: TALsizei; sources: PALuint); cdecl;

This item has no description.

alSourceQueueBuffers: procedure(source: TALuint; n: TALsizei; buffers: PALuint); cdecl;

Queue stuff

alSourceUnqueueBuffers: procedure(source: TALuint; n: TALsizei; buffers: PALuint); cdecl;

This item has no description.

alGenBuffers: procedure(n: TALsizei; buffers: PALuint); cdecl;

BUFFER Buffer objects are storage space for sample data. Buffers are referred to by Sources. There can be more than one Source using the same Buffer data. If Buffers have to be duplicated on a per-Source basis, the driver has to take care of allocation, copying, and deallocation as well as propagating buffer data changes. Buffer object generation.

alDeleteBuffers: procedure(n: TALsizei; buffers: PALuint); cdecl;

This item has no description.

alIsBuffer: function(buffer: TALuint): TALboolean; cdecl;

This item has no description.

alBufferData: procedure(buffer: TALuint; format: TALenum; data: Pointer; size, freq: TALsizei); cdecl;

Specify the data to be filled into a buffer.

alBufferi: procedure(buffer: TALuint; param: TALenum; value: TALint); cdecl;

set parameter for an buffer object

alBuffer3i: procedure(buffer: TALuint; param: TALenum; v1: TALint; v2: TALint; v3: TALint); cdecl;

This item has no description.

alBufferiv: procedure(buffer: TALuint; param: TALenum; values: PALint); cdecl;

This item has no description.

alBufferf: procedure(buffer: TALuint; param: TALenum; value: TALfloat); cdecl;

This item has no description.

alBuffer3f: procedure(buffer: TALuint; param: TALenum; v1: TALfloat; v2: TALfloat; v3: TALfloat); cdecl;

This item has no description.

alBufferfv: procedure(buffer: TALuint; param: TALenum; values: PALfloat); cdecl;

This item has no description.

alGetBufferi: procedure(buffer: TALuint; param: TALenum; value: PALint); cdecl;

read parameter for an buffer object

alGetBuffer3i: procedure(buffer: TALuint; param: TALenum; v1: PALint; v2: PALint; v3: PALint); cdecl;

This item has no description.

alGetBufferiv: procedure(buffer: TALuint; param: TALenum; values: PALint); cdecl;

This item has no description.

alGetBufferf: procedure(buffer: TALuint; param: TALenum; value: PALfloat); cdecl;

This item has no description.

alGetBuffer3f: procedure(buffer: TALuint; param: TALenum; v1: PALfloat; v2: PALfloat; v3: PALfloat); cdecl;

This item has no description.

alGetBufferfv: procedure(buffer: TALuint; param: TALenum; values: PALfloat); cdecl;

This item has no description.

alDistanceModel: procedure(value: TALenum); cdecl;

Global Parameters

alDopplerFactor: procedure(value: TALfloat); cdecl;

This item has no description.

alDopplerVelocity: procedure(value: TALfloat); cdecl;

This item has no description.

alSpeedOfSound: procedure( value: TALfloat ); cdecl;

This item has no description.

alcCreateContext: function(device: TALCdevice; attrlist: PALCint): TALCcontext; cdecl;

alc functions Context Support

alcMakeContextCurrent: function(context: TALCcontext): TALCenum; cdecl;

This item has no description.

alcProcessContext: procedure(context: TALCcontext); cdecl;

This item has no description.

alcSuspendContext: procedure(context: TALCcontext); cdecl;

This item has no description.

alcDestroyContext: procedure(context: TALCcontext); cdecl;

This item has no description.

alcGetCurrentContext: function: TALCcontext; cdecl;

This item has no description.

alcGetContextsDevice: function(context: TALCcontext): TALCdevice; cdecl;

This item has no description.

alcOpenDevice: function(deviceName: PALCuByte): TALCdevice; cdecl;

Device Management

alcCloseDevice: procedure(device: TALCdevice); cdecl;

This item has no description.

alcGetError: function(device: TALCdevice): TALCenum; cdecl;

Error Support Obtain the most recent Context error

alcIsExtensionPresent: function(device: TALCdevice; extName: PALuByte): TALCboolean; cdecl;

Extension support. Query for the presence of an extension, and obtain any appropriate function pointers and enum values.

alcGetProcAddress: function(device: TALCdevice; funcName: PALuByte): TALCvoid; cdecl;

This item has no description.

alcGetEnumValue: function(device: TALCdevice; enumName: PALuByte): TALCenum; cdecl;

This item has no description.

alcGetString: function(device: TALCdevice; param: TALCenum): PALCubyte; cdecl;

Query functions

alcGetIntegerv: procedure(device: TALCdevice; param: TALCenum; size: TALCsizei; data: PALCint); cdecl;

This item has no description.

alcCaptureOpenDevice: function( const devicename: PALCchar; frequency: TALCuint; format: TALCenum; buffersize: TALCsizei): PALCdevice; cdecl;

Capture functions

alcCaptureCloseDevice: function( device: PALCdevice ): TALCboolean; cdecl;

This item has no description.

alcCaptureStart: procedure( device: PALCdevice ); cdecl;

This item has no description.

alcCaptureStop: procedure( device: PALCdevice ); cdecl;

This item has no description.

alcCaptureSamples: procedure( device: PALCdevice; buffer: TALCvoid; samples: TALCsizei ); cdecl;

This item has no description.

EAXSet: Function(const Guid: TGUID; ALuint1: TALuint; ALuint2: TALuint; point: Pointer; ALuint3: TALuint): TALenum; cdecl;

EAX functions

EAXGet: Function(const Guid: TGUID; ALuint1: TALuint; ALuint2: TALuint; point: Pointer; ALuint3: TALuint): TALenum; cdecl;

This item has no description.

AL_EAX_RAM_SIZE: TALEnum;

X-RAM enums

AL_EAX_RAM_FREE: TALEnum;

This item has no description.

AL_STORAGE_AUTOMATIC: TALEnum;

This item has no description.

AL_STORAGE_HARDWARE: TALEnum;

This item has no description.

AL_STORAGE_ACCESSIBLE: TALEnum;

This item has no description.

EAXSetBufferMode: function(n: TALsizei;buffers: PALuint; value: TALint ): TALboolean; cdecl;

X-RAM functions

EAXGetBufferMode: function(buffer: TALuint; value: PALint ): TALenum; cdecl;

This item has no description.

ALGENEFFECTS: procedure( n: TALsizei; effects: PALuint ); cdecl;

EFX functions Effect object functions. Create Effect objects.

ALDELETEEFFECTS: procedure( n: TALsizei; effects: PALuint ); cdecl;

Delete Effect objects.

ALISEFFECT: function( eid: TALuint ): TALboolean; cdecl;

Verify a handle is a valid Effect.

ALEFFECTI: procedure( eid: TALuint; param: TALCenum; value: TALint); cdecl;

Set an integer parameter for an Effect object.

ALEFFECTIV: procedure( eid: TALuint; param: TALenum; values: PALint ); cdecl;

This item has no description.

ALEFFECTF: procedure( eid: TALuint; param: TALenum; value: TALfloat); cdecl;

Set a floating point parameter for an Effect object.

ALEFFECTFV: procedure( eid: TALuint; param: TALenum; values: PALfloat ); cdecl;

This item has no description.

ALGETEFFECTI: procedure( eid: TALuint; param: TALenum; value: PALint ); cdecl;

Get an integer parameter for an Effect object.

ALGETEFFECTIV: procedure( eid: TALuint; param: TALenum; values: PALint ); cdecl;

This item has no description.

ALGETEFFECTF: procedure( eid: TALuint; param: TALenum; value: PALfloat ); cdecl;

Get a floating point parameter for an Effect object.

ALGETEFFECTFV: procedure( eid: TALuint; param: TALenum; values: PALfloat ); cdecl;

This item has no description.

ALGENFILTERS: procedure( n: TALsizei; filters: PALuint ); cdecl;

Filter object functions Creates Filter objects.

ALDELETEFILTERS: procedure( n: TALsizei; filters: PALuint ); cdecl;

Delete Filter objects.

ALISFILTER: function( fid: TALuint ): TALboolean; cdecl;

Verify a handle is a valid Filter.

ALFILTERI: procedure( fid: TALuint; param: TALenum; value: TALint ); cdecl;

Set an integer parameter for a Filter object.

ALFILTERIV: procedure( fid: TALuint; param: TALenum; values: PALint ); cdecl;

This item has no description.

ALFILTERF: procedure( fid: TALuint; param: TALenum; value: TALfloat); cdecl;

Set a floating point parameter for an Filter object.

ALFILTERFV: procedure( fid: TALuint; param: TALenum; values: PALfloat ); cdecl;

This item has no description.

ALGETFILTERI: procedure( fid: TALuint; param: TALenum; value: PALint ); cdecl;

Get an integer parameter for a Filter object.

ALGETFILTERIV: procedure( fid: TALuint; param: TALenum; values: PALint ); cdecl;

This item has no description.

ALGETFILTERF: procedure( fid: TALuint; param: TALenum; value: PALfloat ); cdecl;

Get a floating point parameter for a Filter object.

ALGETFILTERFV: procedure( fid: TALuint; param: TALenum; values: PALfloat ); cdecl;

This item has no description.

ALGENAUXILIARYEFFECTSLOTS: procedure( n: TALsizei; slots: PALuint ); cdecl;

Auxiliary Slot object functions Creates Auxiliary Slot objects.

ALDELETEAUXILIARYEFFECTSLOTS: procedure( n: TALsizei; slots: PALuint ); cdecl;

Delete Auxiliary Slot objects.

ALISAUXILIARYEFFECTSLOT: function( slot: TALuint ): TALboolean; cdecl;

Verify a handle is a valid Auxiliary Slot.

ALAUXILIARYEFFECTSLOTI: procedure( asid: TALuint; param: TALenum; value: TALint ); cdecl;

Set an integer parameter for a Auxiliary Slot object.

ALAUXILIARYEFFECTSLOTIV: procedure( asid: TALuint; param: TALenum; values: PALint ); cdecl;

This item has no description.

ALAUXILIARYEFFECTSLOTF: procedure( asid: TALuint; param: TALenum; value: TALfloat ); cdecl;

Set a floating point parameter for an Auxiliary Slot object.

ALAUXILIARYEFFECTSLOTFV: procedure( asid: TALuint; param: TALenum; values: PALfloat ); cdecl;

This item has no description.

ALGETAUXILIARYEFFECTSLOTI: procedure( asid: TALuint; param: TALenum; value: PALint ); cdecl;

Get an integer parameter for a Auxiliary Slot object.

ALGETAUXILIARYEFFECTSLOTIV: procedure( asid: TALuint; param: TALenum; values: PALint ); cdecl;

This item has no description.

ALGETAUXILIARYEFFECTSLOTF: procedure( asid: TALuint; param: TALenum; value: PALfloat ); cdecl;

Get a floating point parameter for a Auxiliary Slot object.

ALGETAUXILIARYEFFECTSLOTFV: procedure( asid: TALuint; param: TALenum; values: PALfloat ); cdecl;

This item has no description.

LibHandle: THandle = 0;

This item has no description.

EFXUtilLibHandle: THandle = 0;


GLSysHelp v.2.5: OpenAL.Import: Packed Record TEaxListenerProperties

Packed Record TEaxListenerProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenAL.Import

Declaration

type TEaxListenerProperties = packed record

Description

Use this structure for DSPROPERTY_EAXLISTENER_ALLPARAMETERS - all levels are hundredths of decibels - all times are in seconds - the reference for high frequency controls is 5 kHz

NOTE: This structure may change in future EAX versions. It is recommended to initialize fields by name: myListener.lRoom = -1000; myListener.lRoomHF = -100; ... myListener.dwFlags = myFlags /* see EAXLISTENERFLAGS below */ ; instead of: myListener = { -1000, -100, ... , 0x00000009 }; If you want to save and load presets in binary form, you should define your own structure to insure future compatibility.

Overview

Fields

Public | lRoom: integer;
Public | lRoomHF: integer;
Public | flRoomRolloffFactor: double;
Public | flDecayTime: double;
Public | flDecayHFRatio: double;
Public | lReflections: integer;
Public | flReflectionsDelay: double;
Public | lReverb: integer;
Public | flReverbDelay: double;
Public | dwEnvironment: cardinal;
Public | flEnvironmentSize: double;
Public | flEnvironmentDiffusion: double;
Public | flAirAbsorptionHF: double;
Public | dwFlags: cardinal;

Description

Fields

Public lRoom: integer;

This item has no description.

Public lRoomHF: integer;

room effect level at low frequencies

Public flRoomRolloffFactor: double;

room effect high-frequency level re. low frequency levelimplementation

Public flDecayTime: double;

like DS3D flRolloffFactor but for room effect

Public flDecayHFRatio: double;

reverberation decay time at low frequenciesend.

Public lReflections: integer;

high-frequency to low-frequency decay time ratio

Public flReflectionsDelay: double;

early reflections level relative to room effect

Public lReverb: integer;

initial reflection delay time

Public flReverbDelay: double;

late reverberation level relative to room effect

Public dwEnvironment: cardinal;

late reverberation delay time relative to initial reflection

Public flEnvironmentSize: double;

sets all listener properties

Public flEnvironmentDiffusion: double;

environment size in meters

Public flAirAbsorptionHF: double;

environment diffusion

Public dwFlags: cardinal;

change in level per meter at 5 kHz


GLSysHelp v.2.5: OpenAL.Import: Packed Record TEaxBufferProperties

Packed Record TEaxBufferProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenAL.Import

Declaration

type TEaxBufferProperties = packed record

Description

Use this structure for DSPROPERTY_EAXBUFFER_ALLPARAMETERS - all levels are hundredths of decibels

NOTE: This structure may change in future EAX versions. It is recommended to initialize fields by name: myBuffer.lDirect = 0; myBuffer.lDirectHF = -200; ... myBuffer.dwFlags = myFlags /* see EAXBUFFERFLAGS below */ ; instead of: myBuffer = { 0, -200, ... , 0x00000003 };

Overview

Fields

Public | lDirect: integer;
Public | lDirectHF: integer;
Public | lRoom: integer;
Public | lRoomHF: integer;
Public | flRoomRolloffFactor: double;
Public | lObstruction: integer;
Public | flObstructionLFRatio: double;
Public | lOcclusion: integer;
Public | flOcclusionLFRatio: double;
Public | flOcclusionRoomRatio: double;
Public | lOutsideVolumeHF: integer;
Public | flAirAbsorptionFactor: double;
Public | dwFlags: Cardinal;

Description

Fields

Public lDirect: integer;

This item has no description.

Public lDirectHF: integer;

direct path level

Public lRoom: integer;

direct path level at high frequencies

Public lRoomHF: integer;

room effect level

Public flRoomRolloffFactor: double;

room effect level at high frequencies

Public lObstruction: integer;

like DS3D flRolloffFactor but for room effect

Public flObstructionLFRatio: double;

main obstruction control (attenuation at high frequencies)

Public lOcclusion: integer;

obstruction low-frequency level re. main control

Public flOcclusionLFRatio: double;

main occlusion control (attenuation at high frequencies)

Public flOcclusionRoomRatio: double;

occlusion low-frequency level re. main control

Public lOutsideVolumeHF: integer;

occlusion room effect level re. main control

Public flAirAbsorptionFactor: double;

outside sound cone level at high frequencies

Public dwFlags: Cardinal;

multiplies DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF


GLSysHelp v.2.5: OpenAL.Import: Packed Record _EFXEAXREVERBPROPERTIES

Packed Record _EFXEAXREVERBPROPERTIES

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenAL.Import

Declaration

type _EFXEAXREVERBPROPERTIES = packed record

Description

END EFX AEX extension EFX utils version 1.0

Overview

Fields

Public | flDensity: single;
Public | flDiffusion: single;
Public | flGain: single;
Public | flGainHF: single;
Public | flGainLF: single;
Public | flDecayTime: single;
Public | flDecayHFRatio: single;
Public | flDecayLFRatio: single;
Public | flReflectionsGain: single;
Public | flReflectionsDelay: single;
Public | flReflectionsPan: packed[0..2] of single;
Public | flLateReverbGain: single;
Public | flLateReverbDelay: single;
Public | flLateReverbPan: packed[0..2] of single;
Public | flEchoTime: single;
Public | flEchoDepth: single;
Public | flModulationTime: single;
Public | flModulationDepth: single;
Public | flAirAbsorptionGainHF: single;
Public | flHFReference: single;
Public | flLFReference: single;
Public | flRoomRolloffFactor: single;
Public | iDecayHFLimit: integer;

Description

Fields

Public flDensity: single;

This item has no description.

Public flDiffusion: single;

This item has no description.

Public flGain: single;

This item has no description.

Public flGainHF: single;

This item has no description.

Public flGainLF: single;

This item has no description.

Public flDecayTime: single;

This item has no description.

Public flDecayHFRatio: single;

This item has no description.

Public flDecayLFRatio: single;

This item has no description.

Public flReflectionsGain: single;

This item has no description.

Public flReflectionsDelay: single;

This item has no description.

Public flReflectionsPan: packed[0..2] of single;

This item has no description.

Public flLateReverbGain: single;

This item has no description.

Public flLateReverbDelay: single;

This item has no description.

Public flLateReverbPan: packed[0..2] of single;

This item has no description.

Public flEchoTime: single;

This item has no description.

Public flEchoDepth: single;

This item has no description.

Public flModulationTime: single;

This item has no description.

Public flModulationDepth: single;

This item has no description.

Public flAirAbsorptionGainHF: single;

This item has no description.

Public flHFReference: single;

This item has no description.

Public flLFReference: single;

This item has no description.

Public flRoomRolloffFactor: single;

This item has no description.

Public iDecayHFLimit: integer;


GLSysHelp v.2.5: OpenAL.Import: Packed Record _EFXLOWPASSFILTER

Packed Record _EFXLOWPASSFILTER

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenAL.Import

Declaration

type _EFXLOWPASSFILTER = packed record

Description

This item has no description.

Overview

Fields

Public | flGain: single;
Public | flGainHF: single;

Description

Fields

Public flGain: single;

This item has no description.

Public flGainHF: single;


GLSysHelp v.2.5: OpenCL.GL

Unit OpenCL.GL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • OpenCL.Import
  • OpenCL.Platform

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record __GLsync |

Functions and Procedures

function clCreateFromGLBuffer(context: Tcl_context; flags: Tcl_mem_flags; bufobj: Cardinal; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clCreateFromGLTexture3D(context: Tcl_context; flags: Tcl_mem_flags; target: Cardinal; miplevel: Integer; texture: Cardinal; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clCreateFromGLRenderbuffer(context: Tcl_context; flags: Tcl_mem_flags; renderbuffer: Cardinal; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clGetGLObjectInfo(memobj: Tcl_mem; gl_object_type: Pcl_gl_object_type; gl_object_name: PGLuint): Tcl_int; stdcall; external LibOpenCL;
function clGetGLTextureInfo(memobj: Tcl_mem; param_name: Tcl_gl_texture_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueAcquireGLObjects(command_queue: Tcl_command_queue; num_objects: Tcl_uint; mem_objects: Pcl_mem; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueReleaseGLObjects(command_queue: Tcl_command_queue; num_objects: Tcl_uint; mem_objects: Pcl_mem; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clGetGLContextInfoKHR(properties: Tcl_context_properties; param_name: Tcl_gl_context_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

Types

Pcl_GLsync = ˆ__GLsync;
Pcl_gl_context_info = ˆTcl_gl_context_info;
Pcl_gl_object_type = ˆTcl_gl_object_type;
Pcl_gl_platform_info = ˆTcl_gl_platform_info;
Pcl_gl_texture_info = ˆTcl_gl_texture_info;
PGLuint = ˆCardinal;
Tcl_gl_context_info = Tcl_uint;
Tcl_gl_object_type = Tcl_uint;
Tcl_gl_platform_info = Tcl_uint;
Tcl_gl_texture_info = Tcl_uint;

Constants

CL_GL_OBJECT_BUFFER = $2000;
CL_GL_OBJECT_TEXTURE2D = $2001;
CL_GL_OBJECT_TEXTURE3D = $2002;
CL_GL_OBJECT_RENDERBUFFER = $2003;
CL_GL_OBJECT_TEXTURE2D_ARRAY = $200E;
CL_GL_OBJECT_TEXTURE1D = $200F;
CL_GL_OBJECT_TEXTURE1D_ARRAY = $2010;
CL_GL_OBJECT_TEXTURE_BUFFER = $2011;
CL_GL_TEXTURE_TARGET = $2004;
CL_GL_MIPMAP_LEVEL = $2005;
CL_GL_NUM_SAMPLES = $2012;
cl_khr_gl_sharing = 1;
CL_INVALID_GL_SHAREGROUP_REFERENCE_KHR = -1000;
CL_CURRENT_DEVICE_FOR_GL_CONTEXT_KHR = $2006;
CL_DEVICES_FOR_GL_CONTEXT_KHR = $2007;
CL_GL_CONTEXT_KHR = $2008;
CL_EGL_DISPLAY_KHR = $2009;
CL_GLX_DISPLAY_KHR = $200A;
CL_WGL_HDC_KHR = $200B;
CL_CGL_SHAREGROUP_KHR = $200C;

Description

Functions and Procedures

function clCreateFromGLBuffer(context: Tcl_context; flags: Tcl_mem_flags; bufobj: Cardinal; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0;

function clCreateFromGLTexture3D(context: Tcl_context; flags: Tcl_mem_flags; target: Cardinal; miplevel: Integer; texture: Cardinal; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2;

function clCreateFromGLRenderbuffer(context: Tcl_context; flags: Tcl_mem_flags; renderbuffer: Cardinal; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0;

function clGetGLObjectInfo(memobj: Tcl_mem; gl_object_type: Pcl_gl_object_type; gl_object_name: PGLuint): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0;

function clGetGLTextureInfo(memobj: Tcl_mem; param_name: Tcl_gl_texture_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0;

function clEnqueueAcquireGLObjects(command_queue: Tcl_command_queue; num_objects: Tcl_uint; mem_objects: Pcl_mem; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0;

function clEnqueueReleaseGLObjects(command_queue: Tcl_command_queue; num_objects: Tcl_uint; mem_objects: Pcl_mem; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0;

function clGetGLContextInfoKHR(properties: Tcl_context_properties; param_name: Tcl_gl_context_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

This item has no description.

Types

Pcl_GLsync = ˆ__GLsync;

This item has no description.

Pcl_gl_context_info = ˆTcl_gl_context_info;

This item has no description.

Pcl_gl_object_type = ˆTcl_gl_object_type;

This item has no description.

Pcl_gl_platform_info = ˆTcl_gl_platform_info;

This item has no description.

Pcl_gl_texture_info = ˆTcl_gl_texture_info;

This item has no description.

PGLuint = ˆCardinal;

This item has no description.

Tcl_gl_context_info = Tcl_uint;

This item has no description.

Tcl_gl_object_type = Tcl_uint;

This item has no description.

Tcl_gl_platform_info = Tcl_uint;

This item has no description.

Tcl_gl_texture_info = Tcl_uint;

This item has no description.

Constants

CL_GL_OBJECT_BUFFER = $2000;

* cl_gl_object_type = 0x2000 - 0x200F enum values are currently taken *//

CL_GL_OBJECT_TEXTURE2D = $2001;

This item has no description.

CL_GL_OBJECT_TEXTURE3D = $2002;

This item has no description.

CL_GL_OBJECT_RENDERBUFFER = $2003;

This item has no description.

CL_GL_OBJECT_TEXTURE2D_ARRAY = $200E;

This item has no description.

CL_GL_OBJECT_TEXTURE1D = $200F;

This item has no description.

CL_GL_OBJECT_TEXTURE1D_ARRAY = $2010;

This item has no description.

CL_GL_OBJECT_TEXTURE_BUFFER = $2011;

This item has no description.

CL_GL_TEXTURE_TARGET = $2004;

* cl_gl_texture_info *//

CL_GL_MIPMAP_LEVEL = $2005;

This item has no description.

CL_GL_NUM_SAMPLES = $2012;

This item has no description.

cl_khr_gl_sharing = 1;

* cl_khr_gl_sharing extension *//

CL_INVALID_GL_SHAREGROUP_REFERENCE_KHR = -1000;

* Additional Error Codes *//

CL_CURRENT_DEVICE_FOR_GL_CONTEXT_KHR = $2006;

* cl_gl_context_info *//

CL_DEVICES_FOR_GL_CONTEXT_KHR = $2007;

This item has no description.

CL_GL_CONTEXT_KHR = $2008;

* Additional cl_context_properties *//

CL_EGL_DISPLAY_KHR = $2009;

This item has no description.

CL_GLX_DISPLAY_KHR = $200A;

This item has no description.

CL_WGL_HDC_KHR = $200B;

This item has no description.

CL_CGL_SHAREGROUP_KHR = $200C;


GLSysHelp v.2.5: OpenCL.GL: Record __GLsync

Record __GLsync

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.GL

Declaration

type __GLsync = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import

Unit OpenCL.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • OpenCL.Platform

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record T_cl_platform_id |
Record T_cl_device_id |
Record T_cl_context |
Record T_cl_command_queue |
Record T_cl_mem |
Record T_cl_program |
Record T_cl_kernel |
Record T_cl_event |
Record T_cl_sampler |
Packed Record Tcl_image_format |
Packed Record Tcl_image_desc |
Packed Record Tcl_buffer_region |

Functions and Procedures

function clGetPlatformIDs(num_entries: Tcl_uint; platforms: Pcl_platform_id; num_platforms: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;
function clGetPlatformInfo(cl_platform: Tcl_platform_id; param_name: Tcl_platform_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clGetDeviceIDs(_platform: Pcl_platform_id; device_type: Tcl_device_type; num_entries: Tcl_uint; devices: Pcl_device_id; num_devices: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;
function clGetDeviceInfo(device: Pcl_device_id; param_name: Tcl_device_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clCreateSubDevices(in_device: Pcl_device_id; properties: Pcl_device_partition_property; num_devices: Tcl_uint; out_devices: Pcl_device_id; num_devices_ret: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;
function clRetainDevice(device : Pcl_device_id): Tcl_int; stdcall; external LibOpenCL;
function clReleaseDevice(device : Pcl_device_id): Tcl_int; stdcall; external LibOpenCL;
function clSetDefaultDeviceCommandQueue(context: Pcl_context; device: Pcl_device_id; command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;
function clGetDeviceAndHostTimer(device: Pcl_device_id; device_timestamp: Pcl_ulong; host_timestamp: Pcl_ulong): Tcl_int; stdcall; external LibOpenCL;
function clGetHostTimer(device: Pcl_device_id; host_timestamp: Pcl_ulong): Tcl_int; stdcall; external LibOpenCL;
function clCreateContext(properties: Pcl_context_properties; num_devices: Tcl_uint; devices: Pcl_device_id; pfn_notify: Tcl_context_notify; user_data: Pointer; errcode_ret: Pcl_int): Pcl_context; stdcall; external LibOpenCL;
function clCreateContextFromType(properties: Pcl_context_properties; device_type: Tcl_device_type; pfn_notify: Tcl_context_notify; user_data: Pointer; errcode_ret: Pcl_int): Pcl_context; stdcall; external LibOpenCL;
function clRetainContext(context: Pcl_context): Tcl_int; stdcall; external LibOpenCL;
function clReleaseContext(context: Pcl_context): Tcl_int; stdcall; external LibOpenCL;
function clGetContextInfo(context: Pcl_context; param_name: Tcl_context_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clCreateCommandQueue(context: Pcl_context; device: Pcl_device_id; properties: Tcl_command_queue_properties; errcode_ret: Pcl_int): Pcl_command_queue; stdcall; external LibOpenCL;
function clRetainCommandQueue(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;
function clReleaseCommandQueue(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;
function clGetCommandQueueInfo(command_queue: Pcl_command_queue; param_name: Tcl_command_queue_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clCreateBuffer(context: Pcl_context; flags: Tcl_mem_flags; size: NativeUInt; host_ptr: Pointer; errcode_ret: Pcl_int): Pcl_mem; stdcall; external LibOpenCL;
function clCreateSubBuffer(buffer: Pcl_mem; flags: Tcl_mem_flags; buffer_create_type: Tcl_buffer_create_type; buffer_create_info: Pointer; errcode_ret: Pcl_int): Pcl_mem; stdcall; external LibOpenCL;
function clCreateImage(context: Pcl_context; flags: Tcl_mem_flags; image_format: Pcl_image_format; image_desc: Pcl_image_desc; host_ptr: Pointer; errcode_ret: Pcl_int): Pcl_mem; stdcall; external LibOpenCL;
function clCreatePipe(context: Pcl_context; flags: Tcl_mem_flags; pipe_packet_size: Tcl_uint; pipe_max_packets: Tcl_uint; properties: Pcl_pipe_properties; errcode_ret: Pcl_int): Pcl_mem; stdcall; external LibOpenCL;
function clRetainMemObject(memobj: Pcl_mem): Tcl_int; stdcall; external LibOpenCL;
function clReleaseMemObject(memobj: Pcl_mem): Tcl_int; stdcall; external LibOpenCL;
function clGetSupportedImageFormats(context: Pcl_context; flags: Tcl_mem_flags; image_type: Tcl_mem_object_type; num_entries: Tcl_uint; image_formats: Pcl_image_format; num_image_formats: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;
function clGetMemObjectInfo(memobj: Pcl_mem; param_name: Tcl_mem_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clGetImageInfo(image: Pcl_mem; param_name: Tcl_image_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clGetPipeInfo(pipe: Pcl_mem; param_name: Tcl_pipe_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clSetMemObjectDestructorCallback(memobj: Pcl_mem; pfn_notify: Tcl_destructor_notify; user_data: Pointer): Tcl_int; stdcall; external LibOpenCL;
function clSVMAlloc(context: Pcl_context; flags: Tcl_svm_mem_flags; size: NativeUInt; alignment: Tcl_uint): Pointer; stdcall; external LibOpenCL;
procedure clSVMFree(context: Pcl_context; svm_pointer: Pointer); stdcall; external LibOpenCL;
function clCreateSamplerWithProperties(context: Pcl_context; normalized_coords: Pcl_sampler_properties; addressing_mode: Tcl_addressing_mode; errcode_ret: Pcl_int): Pcl_sampler; stdcall; external LibOpenCL;
function clRetainSampler(sampler: Pcl_sampler): Tcl_int; stdcall; external LibOpenCL;
function clReleaseSampler(sampler: Pcl_sampler): Tcl_int; stdcall; external LibOpenCL;
function clGetSamplerInfo(sampler: Pcl_sampler; param_name: Tcl_sampler_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clCreateProgramWithSource(context: Pcl_context; count: Tcl_uint; strings: PPAnsiChar; lengths: Psize_t; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;
function clCreateProgramWithBinary(context: Pcl_context; num_devices: Tcl_uint; device_list: Pcl_device_id; lengths: Psize_t; binaries: PByte; binary_status: Pcl_int; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;
function clCreateProgramWithBuiltInKernels(context: Pcl_context; num_devices: Tcl_uint; device_list: Pcl_device_id; kernel_names: Pcl_char; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;
function clCreateProgramWithIL(context: Pcl_context; il: Pointer; length: NativeUInt; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;
function clRetainProgram(_program: Pcl_program): Tcl_int; stdcall; external LibOpenCL;
function clReleaseProgram(_program: Pcl_program): Tcl_int; stdcall; external LibOpenCL;
function clBuildProgram(_program: Pcl_program; num_devices: Tcl_uint; device_list: Pcl_device_id; options: Pcl_char; pfn_notify: Tcl_programbuilt_notify; user_data: Pointer): Tcl_int; stdcall; external LibOpenCL;
function clCompileProgram(_program: Pcl_program; num_devices: Tcl_uint; device_list: Pcl_device_id; options: Pcl_char; num_input_headers: Tcl_uint; input_headers: Pcl_program; header_include_names: PPAnsiChar; pfn_notify: Tcl_programbuilt_notify; user_data: Pointer): Tcl_int; stdcall; external LibOpenCL;
function clLinkProgram(context: Pcl_context; num_devices: Tcl_uint; device_list: Pcl_device_id; options: Pcl_char; num_input_programs: Pcl_uint; input_programs: Pcl_program; pfn_notify: Tcl_programbuilt_notify; user_data: Pointer; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;
function clUnloadPlatformCompiler: Tcl_int; stdcall; external LibOpenCL;
function clGetProgramInfo(_program: Pcl_program; param_name: Tcl_program_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clGetProgramBuildInfo(_program: Pcl_program; device: Pcl_device_id; param_name: Tcl_program_build_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clCreateKernel(_program: Pcl_program; kernel_name: PAnsiChar; errcode_ret: Pcl_int): Pcl_kernel; stdcall; external LibOpenCL;
function clCreateKernelsInProgram(_program: Pcl_program; num_kernels: Tcl_uint; kernels: Pcl_kernel; num_kernels_ret: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;
function clCloneKernel(source_kernel: Pcl_kernel; errocode_ret: Pcl_int): Tcl_int; stdcall; external LibOpenCL;
function clRetainKernel(kernel: Pcl_kernel): Tcl_int; stdcall; external LibOpenCL;
function clReleaseKernel(kernel: Pcl_kernel): Tcl_int; stdcall; external LibOpenCL;
function clSetKernelArg(kernel: Pcl_kernel; arg_index: Tcl_uint; arg_size: NativeUInt; arg_value: Pointer): Tcl_int; stdcall; external LibOpenCL;
function clSetKernelArgSVMPointer(kernel: Pcl_kernel; arg_index: Tcl_uint; arg_value: Pointer): Tcl_int; stdcall; external LibOpenCL;
function clSetKernelExecInfo(kernel: Pcl_kernel; param_name: Tcl_kernel_exec_info; param_value_size: NativeUInt; param_value: Pointer): Tcl_int; stdcall; external LibOpenCL;
function clGetKernelInfo(kernel: Pcl_kernel; param_name: Tcl_kernel_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clGetKernelArgInfo(kernel: Pcl_kernel; arg_indx: Tcl_uint; param_name: Tcl_kernel_arg_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clGetKernelWorkGroupInfo(kernel: Pcl_kernel; device: Pcl_device_id; param_name: Tcl_kernel_work_group_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clGetKernelSubGroupInfo(kernel: Pcl_kernel; device: Pcl_device_id; param_name: Tcl_kernel_sub_group_info; input_value_size: NativeUInt; input_value: Pointer; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clWaitForEvents(num_events: Tcl_uint; event_list: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clGetEventInfo(event: Pcl_event; param_name: Tcl_event_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clCreateUserEvent(context: Pcl_context; errcode_ret: Pcl_int): Pcl_event; stdcall; external LibOpenCL;
function clRetainEvent(event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clReleaseEvent(event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clSetUserEventStatus(event: Pcl_event; execution_status: Tcl_int): Tcl_int; stdcall; external LibOpenCL;
function clSetEventCallback(event: Pcl_event; command_exec_callback_type: Tcl_int; pfn_notify: Tcl_event_notify; user_data: Pointer): Tcl_int; stdcall; external LibOpenCL;
function clGetEventProfilingInfo(event: Pcl_event; param_name: Tcl_profiling_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;
function clFlush(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;
function clFinish(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueReadBuffer(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_read: Tcl_bool; offset: NativeUInt; size: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueReadBufferRect(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_read: Tcl_bool; buffer_offset: Psize_t; host_offset: Psize_t; region: Psize_t; buffer_row_pitch: NativeUInt; buffer_slice_pitch: NativeUInt; host_row_pitch: NativeUInt; host_slice_pitch: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueWriteBuffer(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_write: Tcl_bool; offset: NativeUInt; size: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueWriteBufferRect(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_write: Tcl_bool; buffer_offset: Psize_t; host_offset: Psize_t; region: Psize_t; buffer_row_pitch: NativeUInt; buffer_slice_pitch: NativeUInt; host_row_pitch: NativeUInt; host_slice_pitch: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueFillBuffer(command_queue: Pcl_command_queue; buffer: Pcl_mem; pattern: Pointer; pattern_size: NativeUInt; offset: NativeUInt; size: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueCopyBuffer(command_queue: Pcl_command_queue; src_buffer: Pcl_mem; dst_buffer: Pcl_mem; src_offset: NativeUInt; dst_offset: NativeUInt; size: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueCopyBufferRect(command_queue: Pcl_command_queue; src_buffer: Pcl_mem; dst_buffer: Pcl_mem; src_offset: NativeUInt; dst_offset: NativeUInt; region: NativeUInt; src_row_pitch: NativeUInt; src_slice_pitch: NativeUInt; dst_row_pitch: NativeUInt; dst_slice_pitch: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueReadImage(command_queue: Pcl_command_queue; image: Pcl_mem; blocking_read: Tcl_bool; origin: Psize_t; region: Psize_t; row_pitch: NativeUInt; slice_pitch: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueWriteImage(command_queue: Pcl_command_queue; image: Pcl_mem; blocking_write: Tcl_bool; origin: Psize_t; region: Psize_t; input_row_pitch: NativeUInt; input_slice_pitch: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueFillImage(command_queue: Pcl_command_queue; image: Pcl_mem; fill_color: Pointer; origin: Psize_t; region: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueCopyImage(command_queue: Pcl_command_queue; src_image: Pcl_mem; dst_image: Pcl_mem; src_origin: Psize_t; dst_origin: Psize_t; region: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueCopyImageToBuffer(command_queue: Pcl_command_queue; src_image: Pcl_mem; dst_buffer: Pcl_mem; src_origin: Psize_t; region: Psize_t; dst_offset: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueCopyBufferToImage(command_queue: Pcl_command_queue; src_buffer: Pcl_mem; dst_image: Pcl_mem; src_offset: NativeUInt; dst_origin: Psize_t; region: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueMapBuffer(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_map: Pcl_bool; map_flags: Tcl_map_flags; offset: NativeUInt; cb: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event; errcode_ret: Pcl_int): Pointer; stdcall; external LibOpenCL;
function clEnqueueMapImage(command_queue: Pcl_command_queue; image: Pcl_mem; blocking_map: Tcl_bool; map_flags: Tcl_map_flags; origin: Psize_t; region: Psize_t; image_row_pitch: Psize_t; image_slice_pitch: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event; errcode_ret: Pcl_int): Pointer; stdcall; external LibOpenCL;
function clEnqueueUnmapMemObject(command_queue: Pcl_command_queue; memobj: Pcl_mem; mapped_ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueMigrateMemObjects(command_queue: Pcl_command_queue; num_mem_objects: Tcl_uint; mem_objects: Pcl_mem; flags: Tcl_mem_flags; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueNDRangeKernel(command_queue: Pcl_command_queue; kernel: Pcl_kernel; work_dim: Tcl_uint; global_work_offset: Psize_t; global_work_size: Psize_t; local_work_size: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueNativeKernel(command_queue: Pcl_command_queue; user_func: Tcl_EnqueueNativeKernel; args: Pointer; cb_args: NativeUInt; num_mem_objects: Tcl_uint; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueMarkerWithWaitList(command_queue: Pcl_command_queue; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueBarrierWithWaitList(command_queue: Pcl_command_queue; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueSVMFree(command_queue: Pcl_command_queue; num_svm_pointers: Tcl_uint; args: Pointer; pfn_free_func: Tcl_EnqueueSVM_fn; user_data: Pointer; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueSVMMemcpy(command_queue: Pcl_command_queue; num_svm_pointers: Tcl_uint; args: Pointer; user_data: Pointer; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueSVMMap(command_queue: Pcl_command_queue; num_svm_pointers: Tcl_uint; args: Pointer; user_data: Pointer; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueSVMUnmap(command_queue: Pcl_command_queue; svm_ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueSVMmigrateMem(command_queue: Pcl_command_queue; num_svm_pointers: Tcl_uint; svm_pointers: PPointer; sizes: Psize_t; flags: Tcl_mem_flags; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueWaitForEvents(command_queue: Pcl_command_queue; num_events: Tcl_uint; event_list: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueBarrier(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;
function clGetExtensionFunctionAddressForPlatform(_platform: Pcl_platform_id; func_name: Pcl_char): Pointer; stdcall; external LibOpenCL;
function InitOpenCL: Boolean;
procedure CloseOpenCL;
function InitFromLibraryOpenCL(const CLName: WideString): Boolean;
function IsInitializedOpenCL: Boolean;

Types

Pcl_addressing_mode = ˆTcl_addressing_mode;
Pcl_bitfield = ˆTcl_bitfield;
Pcl_bool = ˆTcl_bool;
Pcl_buffer_create_type = ˆTcl_buffer_create_type;
Pcl_buffer_region = ˆTcl_buffer_region;
Pcl_build_status = ˆTcl_build_status;
Pcl_channel_order = ˆTcl_channel_order;
Pcl_channel_type = ˆTcl_channel_type;
Pcl_command_queue = ˆTcl_command_queue;
Pcl_command_queue_info = ˆTcl_command_queue_info;
Pcl_command_queue_properties = ˆTcl_command_queue_properties;
Pcl_command_type = ˆTcl_command_type;
Pcl_context = ˆTcl_context;
Pcl_context_info = ˆTcl_context_info;
Pcl_context_properties = ˆTcl_context_properties;
Pcl_device_affinity_domain = ˆTcl_device_affinity_domain;
Pcl_device_exec_capabilities = ˆTcl_device_exec_capabilities;
Pcl_device_fp_config = ˆTcl_device_fp_config;
Pcl_device_id = ˆTcl_device_id;
Pcl_device_info = ˆTcl_device_info;
Pcl_device_local_mem_type = ˆTcl_device_local_mem_type;
Pcl_device_mem_cache_type = ˆTcl_device_mem_cache_type;
Pcl_device_partition_property = ˆTcl_device_partition_property;
Pcl_device_svm_capabilities = ˆTcl_device_svm_capabilities;
Pcl_device_type = ˆTcl_device_type;
Pcl_event = ˆTcl_event;
Pcl_event_info = ˆTcl_event_info;
Pcl_filter_mode = ˆTcl_filter_mode;
Pcl_image_desc = ˆTcl_image_desc;
Pcl_image_format = ˆTcl_image_format;
Pcl_image_info = ˆTcl_image_info;
Pcl_kernel = ˆTcl_kernel;
Pcl_kernel_arg_access_qualifier = ˆTcl_kernel_arg_access_qualifier;
Pcl_kernel_arg_address_qualifier = ˆTcl_kernel_arg_address_qualifier;
Pcl_kernel_arg_info = ˆTcl_kernel_arg_info;
Pcl_kernel_arg_type_qualifier = ˆTcl_kernel_arg_type_qualifier;
Pcl_kernel_exec_info = ˆTcl_kernel_exec_info;
Pcl_kernel_info = ˆTcl_kernel_info;
Pcl_kernel_sub_group_info = ˆTcl_kernel_sub_group_info;
Pcl_kernel_work_group_info = ˆTcl_kernel_work_group_info;
Pcl_map_flags = ˆTcl_map_flags;
Pcl_mem = ˆTcl_mem;
Pcl_mem_flags = ˆTcl_mem_flags;
Pcl_mem_info = ˆTcl_mem_info;
Pcl_mem_migration_flag = ˆTcl_mem_migration_flag;
Pcl_mem_object_type = ˆTcl_mem_object_type;
Pcl_pipe_info = ˆTcl_pipe_info;
Pcl_pipe_properties = ˆTcl_pipe_properties;
Pcl_platform_id = ˆTcl_platform_id;
Pcl_platform_info = ˆTcl_platform_info;
Pcl_profiling_info = ˆTcl_profiling_info;
Pcl_program = ˆTcl_program;
Pcl_program_binary_type = ˆTcl_program_binary_type;
Pcl_program_build_info = ˆTcl_program_build_info;
Pcl_program_info = ˆTcl_program_info;
Pcl_queue_properties = ˆTcl_queue_properties;
Pcl_sampler = ˆTcl_sampler;
Pcl_sampler_info = ˆTcl_sampler_info;
Pcl_sampler_properties = ˆTcl_sampler_properties;
Pcl_svm_mem_flags = ˆTcl_svm_mem_flags;
Tcl_addressing_mode = Tcl_uint;
Tcl_bitfield = Tcl_ulong;
Tcl_bool = Tcl_uint;
Tcl_buffer_create_type = Tcl_uint;
Tcl_build_status = Tcl_int;
Tcl_channel_order = Tcl_uint;
Tcl_channel_type = Tcl_uint;
Tcl_command_queue = ˆT_cl_command_queue;
Tcl_command_queue_info = Tcl_uint;
Tcl_command_queue_properties = Tcl_bitfield;
Tcl_command_type = Tcl_uint;
Tcl_context = ˆT_cl_context;
Tcl_context_info = Tcl_uint;
Tcl_context_notify = procedure(errinfo: PAnsiChar; private_info: Pointer; size: NativeUInt; user_data: Pointer); stdcall;
Tcl_context_properties = intptr_t;
Tcl_destructor_notify = procedure(memobj: Pcl_mem; user_data: Pointer); stdcall;
Tcl_device_affinity_domain = Tcl_bitfield;
Tcl_device_exec_capabilities = Tcl_bitfield;
Tcl_device_fp_config = Tcl_bitfield;
Tcl_device_id = ˆT_cl_device_id;
Tcl_device_info = Tcl_uint;
Tcl_device_local_mem_type = Tcl_uint;
Tcl_device_mem_cache_type = Tcl_uint;
Tcl_device_partition_property = intptr_t;
Tcl_device_svm_capabilities = Tcl_bitfield;
Tcl_device_type = Tcl_bitfield;
Tcl_EnqueueNativeKernel = procedure(); stdcall;
Tcl_EnqueueSVM_fn = procedure(); stdcall;
Tcl_event = ˆT_cl_event;
Tcl_event_info = Tcl_uint;
Tcl_event_notify = procedure(event: Pcl_event; num_event: Tcl_int; user_data: Pointer); stdcall;
Tcl_filter_mode = Tcl_uint;
Tcl_image_info = Tcl_uint;
Tcl_kernel = ˆT_cl_kernel;
Tcl_kernel_arg_access_qualifier = Tcl_uint;
Tcl_kernel_arg_address_qualifier = Tcl_uint;
Tcl_kernel_arg_info = Tcl_uint;
Tcl_kernel_arg_type_qualifier = Tcl_bitfield;
Tcl_kernel_exec_info = Tcl_uint;
Tcl_kernel_info = Tcl_uint;
Tcl_kernel_sub_group_info = Tcl_uint;
Tcl_kernel_work_group_info = Tcl_uint;
Tcl_map_flags = Tcl_bitfield;
Tcl_mem = ˆT_cl_mem;
Tcl_mem_flags = Tcl_bitfield;
Tcl_mem_info = Tcl_uint;
Tcl_mem_migration_flag = Tcl_bitfield;
Tcl_mem_object_type = Tcl_uint;
Tcl_pipe_info = Tcl_uint;
Tcl_pipe_properties = intptr_t;
Tcl_platform_id = ˆT_cl_platform_id;
Tcl_platform_info = Tcl_uint;
Tcl_profiling_info = Tcl_uint;
Tcl_program = ˆT_cl_program;
Tcl_programbuilt_notify = procedure(_program: Pcl_program; user_data: Pointer); stdcall;
Tcl_program_binary_type = Tcl_uint;
Tcl_program_build_info = Tcl_uint;
Tcl_program_info = Tcl_uint;
Tcl_queue_properties = Tcl_bitfield;
Tcl_sampler = ˆT_cl_sampler;
Tcl_sampler_info = Tcl_uint;
Tcl_sampler_properties = Tcl_bitfield;
Tcl_svm_mem_flags = Tcl_bitfield;

Constants

LibOpenCL = 'OpenCL.dll';
CL_SUCCESS = 0;
CL_DEVICE_NOT_FOUND = -1;
CL_DEVICE_NOT_AVAILABLE = -2;
CL_COMPILER_NOT_AVAILABLE = -3;
CL_MEM_OBJECT_ALLOCATION_FAILURE = -4;
CL_OUT_OF_RESOURCES = -5;
CL_OUT_OF_HOST_MEMORY = -6;
CL_PROFILING_INFO_NOT_AVAILABLE = -7;
CL_MEM_COPY_OVERLAP = -8;
CL_IMAGE_FORMAT_MISMATCH = -9;
CL_IMAGE_FORMAT_NOT_SUPPORTED = -10;
CL_BUILD_PROGRAM_FAILURE = -11;
CL_MAP_FAILURE = -12;
CL_MISALIGNED_SUB_BUFFER_OFFSET = -13;
CL_EXEC_STATUS_ERROR_FOR_EVENTS_IN_WAIT_LIST = -14;
CL_COMPILE_PROGRAM_FAILURE = -15;
CL_LINKER_NOT_AVAILABLE = -16;
CL_LINK_PROGRAM_FAILURE = -17;
CL_DEVICE_PARTITION_FAILED = -18;
CL_KERNEL_ARG_INFO_NOT_AVAILABLE = -19;
CL_INVALID_VALUE = -30;
CL_INVALID_DEVICE_TYPE = -31;
CL_INVALID_PLATFORM = -32;
CL_INVALID_DEVICE = -33;
CL_INVALID_CONTEXT = -34;
CL_INVALID_QUEUE_PROPERTIES = -35;
CL_INVALID_COMMAND_QUEUE = -36;
CL_INVALID_HOST_PTR = -37;
CL_INVALID_MEM_OBJECT = -38;
CL_INVALID_IMAGE_FORMAT_DESCRIPTOR = -39;
CL_INVALID_IMAGE_SIZE = -40;
CL_INVALID_SAMPLER = -41;
CL_INVALID_BINARY = -42;
CL_INVALID_BUILD_OPTIONS = -43;
CL_INVALID_PROGRAM = -44;
CL_INVALID_PROGRAM_EXECUTABLE = -45;
CL_INVALID_KERNEL_NAME = -46;
CL_INVALID_KERNEL_DEFINITION = -47;
CL_INVALID_KERNEL = -48;
CL_INVALID_ARG_INDEX = -49;
CL_INVALID_ARG_VALUE = -50;
CL_INVALID_ARG_SIZE = -51;
CL_INVALID_KERNEL_ARGS = -52;
CL_INVALID_WORK_DIMENSION = -53;
CL_INVALID_WORK_GROUP_SIZE = -54;
CL_INVALID_WORK_ITEM_SIZE = -55;
CL_INVALID_GLOBAL_OFFSET = -56;
CL_INVALID_EVENT_WAIT_LIST = -57;
CL_INVALID_EVENT = -58;
CL_INVALID_OPERATION = -59;
CL_INVALID_GL_OBJECT = -60;
CL_INVALID_BUFFER_SIZE = -61;
CL_INVALID_MIP_LEVEL = -62;
CL_INVALID_GLOBAL_WORK_SIZE = -63;
CL_INVALID_PROPERTY = -64;
CL_INVALID_IMAGE_DESCRIPTOR = -65;
CL_INVALID_COMPILER_OPTIONS = -66;
CL_INVALID_LINKER_OPTIONS = -67;
CL_INVALID_DEVICE_PARTITION_COUNT = -68;
CL_INVALID_PIPE_SIZE = -69;
CL_INVALID_DEVICE_QUEUE = -70;
CL_INVALID_SPEC_ID = -71;
CL_MAX_SIZE_RESTRICTION_EXCEEDED = -72;
CL_VERSION_1_0 = 1;
CL_VERSION_1_1 = 1;
CL_VERSION_1_2 = 1;
CL_VERSION_2_0 = 1;
CL_VERSION_2_1 = 1;
CL_VERSION_2_2 = 1;
CL_FALSE = 0;
CL_TRUE = 1;
CL_BLOCKING = CL_TRUE;
CL_NON_BLOCKING = CL_FALSE;
CL_PLATFORM_PROFILE = $0900;
CL_PLATFORM_VERSION = $0901;
CL_PLATFORM_NAME = $0902;
CL_PLATFORM_VENDOR = $0903;
CL_PLATFORM_EXTENSIONS = $0904;
CL_PLATFORM_HOST_TIMER_RESOLUTION = $0905;
CL_DEVICE_TYPE_DEFAULT = (1 shl 0);
CL_DEVICE_TYPE_CPU = (1 shl 1);
CL_DEVICE_TYPE_GPU = (1 shl 2);
CL_DEVICE_TYPE_ACCELERATOR = (1 shl 3);
CL_DEVICE_TYPE_CUSTOM = (1 shl 4);
CL_DEVICE_TYPE_ALL = $FFFFFFFF;
CL_DEVICE_TYPE = $1000;
CL_DEVICE_VENDOR_ID = $1001;
CL_DEVICE_MAX_COMPUTE_UNITS = $1002;
CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS = $1003;
CL_DEVICE_MAX_WORK_GROUP_SIZE = $1004;
CL_DEVICE_MAX_WORK_ITEM_SIZES = $1005;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_CHAR = $1006;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_SHORT = $1007;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT = $1008;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG = $1009;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT = $100A;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE = $100B;
CL_DEVICE_MAX_CLOCK_FREQUENCY = $100C;
CL_DEVICE_ADDRESS_BITS = $100D;
CL_DEVICE_MAX_READ_IMAGE_ARGS = $100E;
CL_DEVICE_MAX_WRITE_IMAGE_ARGS = $100F;
CL_DEVICE_MAX_MEM_ALLOC_SIZE = $1010;
CL_DEVICE_IMAGE2D_MAX_WIDTH = $1011;
CL_DEVICE_IMAGE2D_MAX_HEIGHT = $1012;
CL_DEVICE_IMAGE3D_MAX_WIDTH = $1013;
CL_DEVICE_IMAGE3D_MAX_HEIGHT = $1014;
CL_DEVICE_IMAGE3D_MAX_DEPTH = $1015;
CL_DEVICE_IMAGE_SUPPORT = $1016;
CL_DEVICE_MAX_PARAMETER_SIZE = $1017;
CL_DEVICE_MAX_SAMPLERS = $1018;
CL_DEVICE_MEM_BASE_ADDR_ALIGN = $1019;
CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE = $101A;
CL_DEVICE_SINGLE_FP_CONFIG = $101B;
CL_DEVICE_GLOBAL_MEM_CACHE_TYPE = $101C;
CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE = $101D;
CL_DEVICE_GLOBAL_MEM_CACHE_SIZE = $101E;
CL_DEVICE_GLOBAL_MEM_SIZE = $101F;
CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE = $1020;
CL_DEVICE_MAX_CONSTANT_ARGS = $1021;
CL_DEVICE_LOCAL_MEM_TYPE = $1022;
CL_DEVICE_LOCAL_MEM_SIZE = $1023;
CL_DEVICE_ERROR_CORRECTION_SUPPORT = $1024;
CL_DEVICE_PROFILING_TIMER_RESOLUTION = $1025;
CL_DEVICE_ENDIAN_LITTLE = $1026;
CL_DEVICE_AVAILABLE = $1027;
CL_DEVICE_COMPILER_AVAILABLE = $1028;
CL_DEVICE_EXECUTION_CAPABILITIES = $1029;
CL_DEVICE_QUEUE_PROPERTIES = $102A;
CL_DEVICE_QUEUE_ON_HOST_PROPERTIES = $102A;
CL_DEVICE_NAME = $102B;
CL_DEVICE_VENDOR = $102C;
CL_DRIVER_VERSION = $102D;
CL_DEVICE_PROFILE = $102E;
CL_DEVICE_VERSION = $102F;
CL_DEVICE_EXTENSIONS = $1030;
CL_DEVICE_PLATFORM = $1031;
CL_DEVICE_DOUBLE_FP_CONFIG = $1032;
CL_DEVICE_HALF_FP_CONFIG = $1033;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_HALF = $1034;
CL_DEVICE_HOST_UNIFIED_MEMORY = $1035;
CL_DEVICE_NATIVE_VECTOR_WIDTH_CHAR = $1036;
CL_DEVICE_NATIVE_VECTOR_WIDTH_SHORT = $1037;
CL_DEVICE_NATIVE_VECTOR_WIDTH_INT = $1038;
CL_DEVICE_NATIVE_VECTOR_WIDTH_LONG = $1039;
CL_DEVICE_NATIVE_VECTOR_WIDTH_FLOAT = $103A;
CL_DEVICE_NATIVE_VECTOR_WIDTH_DOUBLE = $103B;
CL_DEVICE_NATIVE_VECTOR_WIDTH_HALF = $103C;
CL_DEVICE_OPENCL_C_VERSION = $103D;
CL_DEVICE_LINKER_AVAILABLE = $103E;
CL_DEVICE_BUILT_IN_KERNELS = $103F;
CL_DEVICE_IMAGE_MAX_BUFFER_SIZE = $1040;
CL_DEVICE_IMAGE_MAX_ARRAY_SIZE = $1041;
CL_DEVICE_PARENT_DEVICE = $1042;
CL_DEVICE_PARTITION_MAX_SUB_DEVICES = $1043;
CL_DEVICE_PARTITION_PROPERTIES = $1044;
CL_DEVICE_PARTITION_AFFINITY_DOMAIN = $1045;
CL_DEVICE_PARTITION_TYPE = $1046;
CL_DEVICE_REFERENCE_COUNT = $1047;
CL_DEVICE_PREFERRED_INTEROP_USER_SYNC = $1048;
CL_DEVICE_PRINTF_BUFFER_SIZE = $1049;
CL_DEVICE_IMAGE_PITCH_ALIGNMENT = $104A;
CL_DEVICE_IMAGE_BASE_ADDRESS_ALIGNMENT = $104B;
CL_DEVICE_MAX_READ_WRITE_IMAGE_ARGS = $104C;
CL_DEVICE_MAX_GLOBAL_VARIABLE_SIZE = $104D;
CL_DEVICE_QUEUE_ON_DEVICE_PROPERTIES = $104E;
CL_DEVICE_QUEUE_ON_DEVICE_PREFERRED_SIZE = $104F;
CL_DEVICE_QUEUE_ON_DEVICE_MAX_SIZE = $1050;
CL_DEVICE_MAX_ON_DEVICE_QUEUES = $1051;
CL_DEVICE_MAX_ON_DEVICE_EVENTS = $1052;
CL_DEVICE_SVM_CAPABILITIES = $1053;
CL_DEVICE_GLOBAL_VARIABLE_PREFERRED_TOTAL_SIZE = $1054;
CL_DEVICE_MAX_PIPE_ARGS = $1055;
CL_DEVICE_PIPE_MAX_ACTIVE_RESERVATIONS = $1056;
CL_DEVICE_PIPE_MAX_PACKET_SIZE = $1057;
CL_DEVICE_PREFERRED_PLATFORM_ATOMIC_ALIGNMENT = $1058;
CL_DEVICE_PREFERRED_GLOBAL_ATOMIC_ALIGNMENT = $1059;
CL_DEVICE_PREFERRED_LOCAL_ATOMIC_ALIGNMENT = $105A;
CL_DEVICE_IL_VERSION = $105B;
CL_DEVICE_MAX_NUM_SUB_GROUPS = $105C;
CL_DEVICE_SUB_GROUP_INDEPENDENT_FORWARD_PROGRESS = $105D;
CL_FP_DENORM = (1 shl 0);
CL_FP_INF_NAN = (1 shl 1);
CL_FP_ROUND_TO_NEAREST = (1 shl 2);
CL_FP_ROUND_TO_ZERO = (1 shl 3);
CL_FP_ROUND_TO_INF = (1 shl 4);
CL_FP_FMA = (1 shl 5);
CL_FP_SOFT_FLOAT = (1 shl 6);
CL_FP_CORRECTLY_ROUNDED_DIVIDE_SQRT = (1 shl 7);
CL_NONE = $0;
CL_READ_ONLY_CACHE = $1;
CL_READ_WRITE_CACHE = $2;
CL_LOCAL = $1;
CL_GLOBAL = $2;
CL_EXEC_KERNEL = (1 shl 0);
CL_EXEC_NATIVE_KERNEL = (1 shl 1);
CL_QUEUE_OUT_OF_ORDER_EXEC_MODE_ENABLE = (1 shl 0);
CL_QUEUE_PROFILING_ENABLE = (1 shl 1);
CL_QUEUE_ON_DEVICE = (1 shl 2);
CL_QUEUE_ON_DEVICE_DEFAULT = (1 shl 3);
CL_CONTEXT_REFERENCE_COUNT = $1080;
CL_CONTEXT_DEVICES = $1081;
CL_CONTEXT_PROPERTIES = $1082;
CL_CONTEXT_NUM_DEVICES = $1083;
CL_CONTEXT_PLATFORM = $1084;
CL_CONTEXT_INTEROP_USER_SYNC = $1085;
CL_DEVICE_PARTITION_EQUALLY = $1086;
CL_DEVICE_PARTITION_BY_COUNTS = $1087;
CL_DEVICE_PARTITION_BY_COUNTS_LIST_END = $0;
CL_DEVICE_PARTITION_BY_AFFINITY_DOMAIN = $1088;
CL_DEVICE_AFFINITY_DOMAIN_NUMA = (1 shl 0);
CL_DEVICE_AFFINITY_DOMAIN_L4_CACHE = (1 shl 1);
CL_DEVICE_AFFINITY_DOMAIN_L3_CACHE = (1 shl 2);
CL_DEVICE_AFFINITY_DOMAIN_L2_CACHE = (1 shl 3);
CL_DEVICE_AFFINITY_DOMAIN_L1_CACHE = (1 shl 4);
CL_DEVICE_AFFINITY_DOMAIN_NEXT_PARTITIONABLE = (1 shl 5);
CL_DEVICE_SVM_COARSE_GRAIN_BUFFER = (1 shl 0);
CL_DEVICE_SVM_FINE_GRAIN_BUFFER = (1 shl 1);
CL_DEVICE_SVM_FINE_GRAIN_SYSTEM = (1 shl 2);
CL_DEVICE_SVM_ATOMICS = (1 shl 3);
CL_QUEUE_CONTEXT = $1090;
CL_QUEUE_DEVICE = $1091;
CL_QUEUE_REFERENCE_COUNT = $1092;
CL_QUEUE_PROPERTIES = $1093;
CL_QUEUE_SIZE = $1094;
CL_QUEUE_DEVICE_DEFAULT = $1095;
CL_MEM_READ_WRITE = (1 shl 0);
CL_MEM_WRITE_ONLY = (1 shl 1);
CL_MEM_READ_ONLY = (1 shl 2);
CL_MEM_USE_HOST_PTR = (1 shl 3);
CL_MEM_ALLOC_HOST_PTR = (1 shl 4);
CL_MEM_COPY_HOST_PTR = (1 shl 5);
CL_MEM_HOST_WRITE_ONLY = (1 shl 7);
CL_MEM_HOST_READ_ONLY = (1 shl 8);
CL_MEM_HOST_NO_ACCESS = (1 shl 9);
CL_MEM_SVM_FINE_GRAIN_BUFFER = (1 shl 10);
CL_MEM_SVM_ATOMICS = (1 shl 11);
CL_MEM_KERNEL_READ_AND_WRITE = (1 shl 12);
CL_MIGRATE_MEM_OBJECT_HOST = (1 shl 0);
CL_MIGRATE_MEM_OBJECT_CONTENT_UNDEFINED = (1 shl 1);
CL_R = $10B0;
CL_A = $10B1;
CL_RG = $10B2;
CL_RA = $10B3;
CL_RGB = $10B4;
CL_RGBA = $10B5;
CL_BGRA = $10B6;
CL_ARGB = $10B7;
CL_INTENSITY = $10B8;
CL_LUMINANCE = $10B9;
CL_Rx = $10BA;
CL_RGx = $10BB;
CL_RGBx = $10BC;
CL_DEPTH = $10BD;
CL_DEPTH_STENCIL = $10BE;
CL_sRGB = $10BF;
CL_sRGBx = $10C0;
CL_sRGBA = $10C1;
CL_sBGRA = $10C2;
CL_ABGR = $10C3;
CL_SNORM_INT8 = $10D0;
CL_SNORM_INT16 = $10D1;
CL_UNORM_INT8 = $10D2;
CL_UNORM_INT16 = $10D3;
CL_UNORM_SHORT_565 = $10D4;
CL_UNORM_SHORT_555 = $10D5;
CL_UNORM_INT_101010 = $10D6;
CL_SIGNED_INT8 = $10D7;
CL_SIGNED_INT16 = $10D8;
CL_SIGNED_INT32 = $10D9;
CL_UNSIGNED_INT8 = $10DA;
CL_UNSIGNED_INT16 = $10DB;
CL_UNSIGNED_INT32 = $10DC;
CL_HALF_FLOAT = $10DD;
CL_FLOAT = $10DE;
CL_UNORM_INT24 = $10DF;
CL_UNORM_INT_101010_2 = $10E0;
CL_MEM_OBJECT_BUFFER = $10F0;
CL_MEM_OBJECT_IMAGE2D = $10F1;
CL_MEM_OBJECT_IMAGE3D = $10F2;
CL_MEM_OBJECT_IMAGE2D_ARRAY = $10F3;
CL_MEM_OBJECT_IMAGE1D = $10F4;
CL_MEM_OBJECT_IMAGE1D_ARRAY = $10F5;
CL_MEM_OBJECT_IMAGE1D_BUFFER = $10F6;
CL_MEM_OBJECT_PIPE = $10F7;
CL_MEM_TYPE = $1100;
CL_MEM_FLAGS = $1101;
CL_MEM_SIZE = $1102;
CL_MEM_HOST_PTR = $1103;
CL_MEM_MAP_COUNT = $1104;
CL_MEM_REFERENCE_COUNT = $1105;
CL_MEM_CONTEXT = $1106;
CL_MEM_ASSOCIATED_MEMOBJECT = $1107;
CL_MEM_OFFSET = $1108;
CL_MEM_USES_SVM_POINTER = $1109;
CL_IMAGE_FORMAT = $1110;
CL_IMAGE_ELEMENT_SIZE = $1111;
CL_IMAGE_ROW_PITCH = $1112;
CL_IMAGE_SLICE_PITCH = $1113;
CL_IMAGE_WIDTH = $1114;
CL_IMAGE_HEIGHT = $1115;
CL_IMAGE_DEPTH = $1116;
CL_IMAGE_ARRAY_SIZE = $1117;
CL_IMAGE_BUFFER = $1118;
CL_IMAGE_NUM_MIP_LEVELS = $1119;
CL_IMAGE_NUM_SAMPLES = $111A;
CL_PIPE_PACKET_SIZE = $1120;
CL_PIPE_MAX_PACKETS = $1121;
CL_ADDRESS_NONE = $1130;
CL_ADDRESS_CLAMP_TO_EDGE = $1131;
CL_ADDRESS_CLAMP = $1132;
CL_ADDRESS_REPEAT = $1133;
CL_ADDRESS_MIRRORED_REPEAT = $1134;
CL_FILTER_NEAREST = $1140;
CL_FILTER_LINEAR = $1141;
CL_SAMPLER_REFERENCE_COUNT = $1150;
CL_SAMPLER_CONTEXT = $1151;
CL_SAMPLER_NORMALIZED_COORDS = $1152;
CL_SAMPLER_ADDRESSING_MODE = $1153;
CL_SAMPLER_FILTER_MODE = $1154;
CL_SAMPLER_MIP_FILTER_MODE = $1155;
CL_SAMPLER_LOD_MIN = $1156;
CL_SAMPLER_LOD_MAX = $1157;
CL_MAP_READ = (1 shl 0);
CL_MAP_WRITE = (1 shl 1);
CL_MAP_WRITE_INVALIDATE_REGION = (1 shl 2);
CL_PROGRAM_REFERENCE_COUNT = $1160;
CL_PROGRAM_CONTEXT = $1161;
CL_PROGRAM_NUM_DEVICES = $1162;
CL_PROGRAM_DEVICES = $1163;
CL_PROGRAM_SOURCE = $1164;
CL_PROGRAM_BINARY_SIZES = $1165;
CL_PROGRAM_BINARIES = $1166;
CL_PROGRAM_NUM_KERNELS = $1167;
CL_PROGRAM_KERNEL_NAMES = $1168;
CL_PROGRAM_IL = $1169;
CL_PROGRAM_SCOPE_GLOBAL_CTORS_PRESENT = $116A;
CL_PROGRAM_SCOPE_GLOBAL_DTORS_PRESENT = $116B;
CL_PROGRAM_BUILD_STATUS = $1181;
CL_PROGRAM_BUILD_OPTIONS = $1182;
CL_PROGRAM_BUILD_LOG = $1183;
CL_PROGRAM_BINARY_TYPE = $1184;
CL_PROGRAM_BUILD_GLOBAL_VARIABLE_TOTAL_SIZE = $1185;
CL_PROGBRAM_BINARY_TYPE_NONE = $0;
CL_PROGRAM_BINARY_TYPE_COMPILED_OBJECT = $1;
CL_PROGRAM_BINARY_TYPE_LIBRARY = $2;
CL_PROGRAM_BINARY_TYPE_EXECUTABLE = $4;
CL_BUILD_SUCCESS = 0;
CL_BUILD_NONE = -1;
CL_BUILD_ERROR = -2;
CL_BUILD_IN_PROGRESS = -3;
CL_KERNEL_FUNCTION_NAME = $1190;
CL_KERNEL_NUM_ARGS = $1191;
CL_KERNEL_REFERENCE_COUNT = $1192;
CL_KERNEL_CONTEXT = $1193;
CL_KERNEL_PROGRAM = $1194;
CL_KERNEL_ATTRIBUTES = $1195;
CL_KERNEL_MAX_NUM_SUB_GROUPS = $11B9;
CL_KERNEL_COMPILE_NUM_SUB_GROUPS = $11BA;
CL_KERNEL_ARG_ADDRESS_QUALIFIER = $1196;
CL_KERNEL_ARG_ACCESS_QUALIFIER = $1197;
CL_KERNEL_ARG_TYPE_NAME = $1198;
CL_KERNEL_ARG_TYPE_QUALIFIER = $1199;
CL_KERNEL_ARG_NAME = $119A;
CL_KERNEL_ARG_ADDRESS_GLOBAL = $119B;
CL_KERNEL_ARG_ADDRESS_LOCAL = $119C;
CL_KERNEL_ARG_ADDRESS_CONSTANT = $119D;
CL_KERNEL_ARG_ADDRESS_PRIVATE = $119E;
CL_KERNEL_ARG_ACCESS_READ_ONLY = $11A0;
CL_KERNEL_ARG_ACCESS_WRITE_ONLY = $11A1;
CL_KERNEL_ARG_ACCESS_READ_WRITE = $11A2;
CL_KERNEL_ARG_ACCESS_NONE = $11A3;
CL_KERNEL_ARG_TYPE_NONE = 0;
CL_KERNEL_ARG_TYPE_CONST = (1 shl 0);
CL_KERNEL_ARG_TYPE_RESTRICT = (1 shl 1);
CL_KERNEL_ARG_TYPE_VOLATILE = (1 shl 2);
CL_KERNEL_ARG_TYPE_PIPE = (1 shl 3);
CL_KERNEL_WORK_GROUP_SIZE = $11B0;
CL_KERNEL_COMPILE_WORK_GROUP_SIZE = $11B1;
CL_KERNEL_LOCAL_MEM_SIZE = $11B2;
CL_KERNEL_PREFERRED_WORK_GROUP_SIZE_MULTIPLE = $11B3;
CL_KERNEL_PRIVATE_MEM_SIZE = $11B4;
CL_KERNEL_GLOBAL_WORK_SIZE = $11B5;
CL_KERNEL_MAX_SUB_GROUP_SIZE_FOR_NDRANGE = $2033;
CL_KERNEL_SUB_GROUP_COUNT_FOR_NDRANGE = $2034;
CL_KERNEL_LOCAL_SIZE_FOR_SUB_GROUP_COUNT = $11B8;
CL_KERNEL_EXEC_INFO_SVM_PTRS = $11B6;
CL_KERNEL_EXEC_INFO_SVM_FINE_GRAIN_SYSTEM = $11B7;
CL_EVENT_COMMAND_QUEUE = $11D0;
CL_EVENT_COMMAND_TYPE = $11D1;
CL_EVENT_REFERENCE_COUNT = $11D2;
CL_EVENT_COMMAND_EXECUTION_STATUS = $11D3;
CL_EVENT_CONTEXT = $11D4;
CL_COMMAND_NDRANGE_KERNEL = $11F0;
CL_COMMAND_TASK = $11F1;
CL_COMMAND_NATIVE_KERNEL = $11F2;
CL_COMMAND_READ_BUFFER = $11F3;
CL_COMMAND_WRITE_BUFFER = $11F4;
CL_COMMAND_COPY_BUFFER = $11F5;
CL_COMMAND_READ_IMAGE = $11F6;
CL_COMMAND_WRITE_IMAGE = $11F7;
CL_COMMAND_COPY_IMAGE = $11F8;
CL_COMMAND_COPY_IMAGE_TO_BUFFER = $11F9;
CL_COMMAND_COPY_BUFFER_TO_IMAGE = $11FA;
CL_COMMAND_MAP_BUFFER = $11FB;
CL_COMMAND_MAP_IMAGE = $11FC;
CL_COMMAND_UNMAP_MEM_OBJECT = $11FD;
CL_COMMAND_MARKER = $11FE;
CL_COMMAND_ACQUIRE_GL_OBJECTS = $11FF;
CL_COMMAND_RELEASE_GL_OBJECTS = $1200;
CL_COMMAND_READ_BUFFER_RECT = $1201;
CL_COMMAND_WRITE_BUFFER_RECT = $1202;
CL_COMMAND_COPY_BUFFER_RECT = $1203;
CL_COMMAND_USER = $1204;
CL_COMMAND_BARRIER = $1205;
CL_COMMAND_MIGRATE_MEM_OBJECTS = $1206;
CL_COMMAND_FILL_BUFFER = $1207;
CL_COMMAND_FILL_IMAGE = $1208;
CL_COMMAND_SVM_FREE = $1209;
CL_COMMAND_SVM_MEMCPY = $120A;
CL_COMMAND_SVM_MEMFILL = $120B;
CL_COMMAND_SVM_MAP = $120C;
CL_COMMAND_SVM_UNMAP = $120D;
CL_COMPLETE = $0;
CL_RUNNING = $1;
CL_SUBMITTED = $2;
CL_QUEUED = $3;
CL_BUFFER_CREATE_TYPE_REGION = $1220;
CL_PROFILING_COMMAND_QUEUED = $1280;
CL_PROFILING_COMMAND_SUBMIT = $1281;
CL_PROFILING_COMMAND_START = $1282;
CL_PROFILING_COMMAND_END = $1283;
CL_PROFILING_COMMAND_COMPLETE = $1284;

Description

Functions and Procedures

function clGetPlatformIDs(num_entries: Tcl_uint; platforms: Pcl_platform_id; num_platforms: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;

Platform API

function clGetPlatformInfo(cl_platform: Tcl_platform_id; param_name: Tcl_platform_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetDeviceIDs(_platform: Pcl_platform_id; device_type: Tcl_device_type; num_entries: Tcl_uint; devices: Pcl_device_id; num_devices: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0 * Device APIs *//

function clGetDeviceInfo(device: Pcl_device_id; param_name: Tcl_device_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateSubDevices(in_device: Pcl_device_id; properties: Pcl_device_partition_property; num_devices: Tcl_uint; out_devices: Pcl_device_id; num_devices_ret: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clRetainDevice(device : Pcl_device_id): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clReleaseDevice(device : Pcl_device_id): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clSetDefaultDeviceCommandQueue(context: Pcl_context; device: Pcl_device_id; command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clGetDeviceAndHostTimer(device: Pcl_device_id; device_timestamp: Pcl_ulong; host_timestamp: Pcl_ulong): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_1

function clGetHostTimer(device: Pcl_device_id; host_timestamp: Pcl_ulong): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_1

function clCreateContext(properties: Pcl_context_properties; num_devices: Tcl_uint; devices: Pcl_device_id; pfn_notify: Tcl_context_notify; user_data: Pointer; errcode_ret: Pcl_int): Pcl_context; stdcall; external LibOpenCL;

This item has no description.

function clCreateContextFromType(properties: Pcl_context_properties; device_type: Tcl_device_type; pfn_notify: Tcl_context_notify; user_data: Pointer; errcode_ret: Pcl_int): Pcl_context; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clRetainContext(context: Pcl_context): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clReleaseContext(context: Pcl_context): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetContextInfo(context: Pcl_context; param_name: Tcl_context_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateCommandQueue(context: Pcl_context; device: Pcl_device_id; properties: Tcl_command_queue_properties; errcode_ret: Pcl_int): Pcl_command_queue; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0 * Command Queue APIs *//

function clRetainCommandQueue(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clReleaseCommandQueue(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetCommandQueueInfo(command_queue: Pcl_command_queue; param_name: Tcl_command_queue_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateBuffer(context: Pcl_context; flags: Tcl_mem_flags; size: NativeUInt; host_ptr: Pointer; errcode_ret: Pcl_int): Pcl_mem; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0 * Memory Object APIs *//

function clCreateSubBuffer(buffer: Pcl_mem; flags: Tcl_mem_flags; buffer_create_type: Tcl_buffer_create_type; buffer_create_info: Pointer; errcode_ret: Pcl_int): Pcl_mem; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateImage(context: Pcl_context; flags: Tcl_mem_flags; image_format: Pcl_image_format; image_desc: Pcl_image_desc; host_ptr: Pointer; errcode_ret: Pcl_int): Pcl_mem; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_1

function clCreatePipe(context: Pcl_context; flags: Tcl_mem_flags; pipe_packet_size: Tcl_uint; pipe_max_packets: Tcl_uint; properties: Pcl_pipe_properties; errcode_ret: Pcl_int): Pcl_mem; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clRetainMemObject(memobj: Pcl_mem): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clReleaseMemObject(memobj: Pcl_mem): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetSupportedImageFormats(context: Pcl_context; flags: Tcl_mem_flags; image_type: Tcl_mem_object_type; num_entries: Tcl_uint; image_formats: Pcl_image_format; num_image_formats: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetMemObjectInfo(memobj: Pcl_mem; param_name: Tcl_mem_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetImageInfo(image: Pcl_mem; param_name: Tcl_image_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetPipeInfo(pipe: Pcl_mem; param_name: Tcl_pipe_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clSetMemObjectDestructorCallback(memobj: Pcl_mem; pfn_notify: Tcl_destructor_notify; user_data: Pointer): Tcl_int; stdcall; external LibOpenCL;

This item has no description.

function clSVMAlloc(context: Pcl_context; flags: Tcl_svm_mem_flags; size: NativeUInt; alignment: Tcl_uint): Pointer; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_1 * SVM Allocation APIs *//

procedure clSVMFree(context: Pcl_context; svm_pointer: Pointer); stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clCreateSamplerWithProperties(context: Pcl_context; normalized_coords: Pcl_sampler_properties; addressing_mode: Tcl_addressing_mode; errcode_ret: Pcl_int): Pcl_sampler; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0 * Sampler APIs *//

function clRetainSampler(sampler: Pcl_sampler): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clReleaseSampler(sampler: Pcl_sampler): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetSamplerInfo(sampler: Pcl_sampler; param_name: Tcl_sampler_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateProgramWithSource(context: Pcl_context; count: Tcl_uint; strings: PPAnsiChar; lengths: Psize_t; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;

Program Object APIs

function clCreateProgramWithBinary(context: Pcl_context; num_devices: Tcl_uint; device_list: Pcl_device_id; lengths: Psize_t; binaries: PByte; binary_status: Pcl_int; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateProgramWithBuiltInKernels(context: Pcl_context; num_devices: Tcl_uint; device_list: Pcl_device_id; kernel_names: Pcl_char; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateProgramWithIL(context: Pcl_context; il: Pointer; length: NativeUInt; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clRetainProgram(_program: Pcl_program): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_1

function clReleaseProgram(_program: Pcl_program): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clBuildProgram(_program: Pcl_program; num_devices: Tcl_uint; device_list: Pcl_device_id; options: Pcl_char; pfn_notify: Tcl_programbuilt_notify; user_data: Pointer): Tcl_int; stdcall; external LibOpenCL;

This item has no description.

function clCompileProgram(_program: Pcl_program; num_devices: Tcl_uint; device_list: Pcl_device_id; options: Pcl_char; num_input_headers: Tcl_uint; input_headers: Pcl_program; header_include_names: PPAnsiChar; pfn_notify: Tcl_programbuilt_notify; user_data: Pointer): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clLinkProgram(context: Pcl_context; num_devices: Tcl_uint; device_list: Pcl_device_id; options: Pcl_char; num_input_programs: Pcl_uint; input_programs: Pcl_program; pfn_notify: Tcl_programbuilt_notify; user_data: Pointer; errcode_ret: Pcl_int): Pcl_program; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clUnloadPlatformCompiler: Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clGetProgramInfo(_program: Pcl_program; param_name: Tcl_program_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clGetProgramBuildInfo(_program: Pcl_program; device: Pcl_device_id; param_name: Tcl_program_build_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateKernel(_program: Pcl_program; kernel_name: PAnsiChar; errcode_ret: Pcl_int): Pcl_kernel; stdcall; external LibOpenCL;

Kernel Object APIs

function clCreateKernelsInProgram(_program: Pcl_program; num_kernels: Tcl_uint; kernels: Pcl_kernel; num_kernels_ret: Pcl_uint): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCloneKernel(source_kernel: Pcl_kernel; errocode_ret: Pcl_int): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clRetainKernel(kernel: Pcl_kernel): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_1

function clReleaseKernel(kernel: Pcl_kernel): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clSetKernelArg(kernel: Pcl_kernel; arg_index: Tcl_uint; arg_size: NativeUInt; arg_value: Pointer): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clSetKernelArgSVMPointer(kernel: Pcl_kernel; arg_index: Tcl_uint; arg_value: Pointer): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clSetKernelExecInfo(kernel: Pcl_kernel; param_name: Tcl_kernel_exec_info; param_value_size: NativeUInt; param_value: Pointer): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clGetKernelInfo(kernel: Pcl_kernel; param_name: Tcl_kernel_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clGetKernelArgInfo(kernel: Pcl_kernel; arg_indx: Tcl_uint; param_name: Tcl_kernel_arg_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clGetKernelWorkGroupInfo(kernel: Pcl_kernel; device: Pcl_device_id; param_name: Tcl_kernel_work_group_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clGetKernelSubGroupInfo(kernel: Pcl_kernel; device: Pcl_device_id; param_name: Tcl_kernel_sub_group_info; input_value_size: NativeUInt; input_value: Pointer; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clWaitForEvents(num_events: Tcl_uint; event_list: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0 * Event Object APIs *//

function clGetEventInfo(event: Pcl_event; param_name: Tcl_event_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clCreateUserEvent(context: Pcl_context; errcode_ret: Pcl_int): Pcl_event; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clRetainEvent(event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_1

function clReleaseEvent(event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clSetUserEventStatus(event: Pcl_event; execution_status: Tcl_int): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clSetEventCallback(event: Pcl_event; command_exec_callback_type: Tcl_int; pfn_notify: Tcl_event_notify; user_data: Pointer): Tcl_int; stdcall; external LibOpenCL;

This item has no description.

function clGetEventProfilingInfo(event: Pcl_event; param_name: Tcl_profiling_info; param_value_size: NativeUInt; param_value: Pointer; param_value_size_ret: Psize_t): Tcl_int; stdcall; external LibOpenCL;

Profiling APIs

function clFlush(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0 * Flush and Finish APIs *//

function clFinish(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueReadBuffer(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_read: Tcl_bool; offset: NativeUInt; size: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0 * Enqueued Commands APIs *//

function clEnqueueReadBufferRect(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_read: Tcl_bool; buffer_offset: Psize_t; host_offset: Psize_t; region: Psize_t; buffer_row_pitch: NativeUInt; buffer_slice_pitch: NativeUInt; host_row_pitch: NativeUInt; host_slice_pitch: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueWriteBuffer(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_write: Tcl_bool; offset: NativeUInt; size: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_1

function clEnqueueWriteBufferRect(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_write: Tcl_bool; buffer_offset: Psize_t; host_offset: Psize_t; region: Psize_t; buffer_row_pitch: NativeUInt; buffer_slice_pitch: NativeUInt; host_row_pitch: NativeUInt; host_slice_pitch: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueFillBuffer(command_queue: Pcl_command_queue; buffer: Pcl_mem; pattern: Pointer; pattern_size: NativeUInt; offset: NativeUInt; size: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_1

function clEnqueueCopyBuffer(command_queue: Pcl_command_queue; src_buffer: Pcl_mem; dst_buffer: Pcl_mem; src_offset: NativeUInt; dst_offset: NativeUInt; size: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clEnqueueCopyBufferRect(command_queue: Pcl_command_queue; src_buffer: Pcl_mem; dst_buffer: Pcl_mem; src_offset: NativeUInt; dst_offset: NativeUInt; region: NativeUInt; src_row_pitch: NativeUInt; src_slice_pitch: NativeUInt; dst_row_pitch: NativeUInt; dst_slice_pitch: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueReadImage(command_queue: Pcl_command_queue; image: Pcl_mem; blocking_read: Tcl_bool; origin: Psize_t; region: Psize_t; row_pitch: NativeUInt; slice_pitch: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_1

function clEnqueueWriteImage(command_queue: Pcl_command_queue; image: Pcl_mem; blocking_write: Tcl_bool; origin: Psize_t; region: Psize_t; input_row_pitch: NativeUInt; input_slice_pitch: NativeUInt; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueFillImage(command_queue: Pcl_command_queue; image: Pcl_mem; fill_color: Pointer; origin: Psize_t; region: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueCopyImage(command_queue: Pcl_command_queue; src_image: Pcl_mem; dst_image: Pcl_mem; src_origin: Psize_t; dst_origin: Psize_t; region: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clEnqueueCopyImageToBuffer(command_queue: Pcl_command_queue; src_image: Pcl_mem; dst_buffer: Pcl_mem; src_origin: Psize_t; region: Psize_t; dst_offset: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueCopyBufferToImage(command_queue: Pcl_command_queue; src_buffer: Pcl_mem; dst_image: Pcl_mem; src_offset: NativeUInt; dst_origin: Psize_t; region: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueMapBuffer(command_queue: Pcl_command_queue; buffer: Pcl_mem; blocking_map: Pcl_bool; map_flags: Tcl_map_flags; offset: NativeUInt; cb: NativeUInt; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event; errcode_ret: Pcl_int): Pointer; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueMapImage(command_queue: Pcl_command_queue; image: Pcl_mem; blocking_map: Tcl_bool; map_flags: Tcl_map_flags; origin: Psize_t; region: Psize_t; image_row_pitch: Psize_t; image_slice_pitch: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event; errcode_ret: Pcl_int): Pointer; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueUnmapMemObject(command_queue: Pcl_command_queue; memobj: Pcl_mem; mapped_ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueMigrateMemObjects(command_queue: Pcl_command_queue; num_mem_objects: Tcl_uint; mem_objects: Pcl_mem; flags: Tcl_mem_flags; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueNDRangeKernel(command_queue: Pcl_command_queue; kernel: Pcl_kernel; work_dim: Tcl_uint; global_work_offset: Psize_t; global_work_size: Psize_t; local_work_size: Psize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clEnqueueNativeKernel(command_queue: Pcl_command_queue; user_func: Tcl_EnqueueNativeKernel; args: Pointer; cb_args: NativeUInt; num_mem_objects: Tcl_uint; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

This item has no description.

function clEnqueueMarkerWithWaitList(command_queue: Pcl_command_queue; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueBarrierWithWaitList(command_queue: Pcl_command_queue; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_2

function clEnqueueSVMFree(command_queue: Pcl_command_queue; num_svm_pointers: Tcl_uint; args: Pointer; pfn_free_func: Tcl_EnqueueSVM_fn; user_data: Pointer; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

This item has no description.

function clEnqueueSVMMemcpy(command_queue: Pcl_command_queue; num_svm_pointers: Tcl_uint; args: Pointer; user_data: Pointer; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_1_0

function clEnqueueSVMMap(command_queue: Pcl_command_queue; num_svm_pointers: Tcl_uint; args: Pointer; user_data: Pointer; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clEnqueueSVMUnmap(command_queue: Pcl_command_queue; svm_ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clEnqueueSVMmigrateMem(command_queue: Pcl_command_queue; num_svm_pointers: Tcl_uint; svm_pointers: PPointer; sizes: Psize_t; flags: Tcl_mem_flags; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_0

function clEnqueueWaitForEvents(command_queue: Pcl_command_queue; num_events: Tcl_uint; event_list: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

CL_API_SUFFIX__VERSION_2_1

function clEnqueueBarrier(command_queue: Pcl_command_queue): Tcl_int; stdcall; external LibOpenCL;

This item has no description.

function clGetExtensionFunctionAddressForPlatform(_platform: Pcl_platform_id; func_name: Pcl_char): Pointer; stdcall; external LibOpenCL;

* Extension function access * * Returns the extension function address for the given function name, * or NULL if a valid function can not be found. The client must * check to make sure the address is not NULL, before using or * calling the returned function address. *

function InitOpenCL: Boolean;

CL_API_SUFFIX__VERSION_1_2 * Deprecated OpenCL 1.1 APIs *// clCreateImage2D(); clCreateImage3D(); clEnqueueMarker(); clEnqueueWaitForEvents(); clEnqueueBarrier(); clUnloadCompiler(); clGetExtensionFunctionAddress(); * Deprecated OpenCL 2.0 APIs *// clCreateCommandQueue(); clCreateSampler(); clEnqueueTask(); ————————————————————————-

procedure CloseOpenCL;

This item has no description.

function InitFromLibraryOpenCL(const CLName: WideString): Boolean;

This item has no description.

function IsInitializedOpenCL: Boolean;

This item has no description.

Types

Pcl_addressing_mode = ˆTcl_addressing_mode;

This item has no description.

Pcl_bitfield = ˆTcl_bitfield;

This item has no description.

Pcl_bool = ˆTcl_bool;

* WARNING! Unlike cl_ types in cl_platform.h, cl_bool is not guaranteed to be the same size as the bool in kernels. *//

Pcl_buffer_create_type = ˆTcl_buffer_create_type;

This item has no description.

Pcl_buffer_region = ˆTcl_buffer_region;

This item has no description.

Pcl_build_status = ˆTcl_build_status;

This item has no description.

Pcl_channel_order = ˆTcl_channel_order;

This item has no description.

Pcl_channel_type = ˆTcl_channel_type;

This item has no description.

Pcl_command_queue = ˆTcl_command_queue;

This item has no description.

Pcl_command_queue_info = ˆTcl_command_queue_info;

This item has no description.

Pcl_command_queue_properties = ˆTcl_command_queue_properties;

This item has no description.

Pcl_command_type = ˆTcl_command_type;

This item has no description.

Pcl_context = ˆTcl_context;

This item has no description.

Pcl_context_info = ˆTcl_context_info;

This item has no description.

Pcl_context_properties = ˆTcl_context_properties;

This item has no description.

Pcl_device_affinity_domain = ˆTcl_device_affinity_domain;

This item has no description.

Pcl_device_exec_capabilities = ˆTcl_device_exec_capabilities;

This item has no description.

Pcl_device_fp_config = ˆTcl_device_fp_config;

This item has no description.

Pcl_device_id = ˆTcl_device_id;

This item has no description.

Pcl_device_info = ˆTcl_device_info;

This item has no description.

Pcl_device_local_mem_type = ˆTcl_device_local_mem_type;

This item has no description.

Pcl_device_mem_cache_type = ˆTcl_device_mem_cache_type;

This item has no description.

Pcl_device_partition_property = ˆTcl_device_partition_property;

This item has no description.

Pcl_device_svm_capabilities = ˆTcl_device_svm_capabilities;

This item has no description.

Pcl_device_type = ˆTcl_device_type;

This item has no description.

Pcl_event = ˆTcl_event;

This item has no description.

Pcl_event_info = ˆTcl_event_info;

This item has no description.

Pcl_filter_mode = ˆTcl_filter_mode;

This item has no description.

Pcl_image_desc = ˆTcl_image_desc;

This item has no description.

Pcl_image_format = ˆTcl_image_format;

This item has no description.

Pcl_image_info = ˆTcl_image_info;

This item has no description.

Pcl_kernel = ˆTcl_kernel;

This item has no description.

Pcl_kernel_arg_access_qualifier = ˆTcl_kernel_arg_access_qualifier;

This item has no description.

Pcl_kernel_arg_address_qualifier = ˆTcl_kernel_arg_address_qualifier;

This item has no description.

Pcl_kernel_arg_info = ˆTcl_kernel_arg_info;

This item has no description.

Pcl_kernel_arg_type_qualifier = ˆTcl_kernel_arg_type_qualifier;

This item has no description.

Pcl_kernel_exec_info = ˆTcl_kernel_exec_info;

This item has no description.

Pcl_kernel_info = ˆTcl_kernel_info;

This item has no description.

Pcl_kernel_sub_group_info = ˆTcl_kernel_sub_group_info;

This item has no description.

Pcl_kernel_work_group_info = ˆTcl_kernel_work_group_info;

This item has no description.

Pcl_map_flags = ˆTcl_map_flags;

This item has no description.

Pcl_mem = ˆTcl_mem;

This item has no description.

Pcl_mem_flags = ˆTcl_mem_flags;

This item has no description.

Pcl_mem_info = ˆTcl_mem_info;

This item has no description.

Pcl_mem_migration_flag = ˆTcl_mem_migration_flag;

This item has no description.

Pcl_mem_object_type = ˆTcl_mem_object_type;

This item has no description.

Pcl_pipe_info = ˆTcl_pipe_info;

This item has no description.

Pcl_pipe_properties = ˆTcl_pipe_properties;

This item has no description.

Pcl_platform_id = ˆTcl_platform_id;

This item has no description.

Pcl_platform_info = ˆTcl_platform_info;

This item has no description.

Pcl_profiling_info = ˆTcl_profiling_info;

This item has no description.

Pcl_program = ˆTcl_program;

This item has no description.

Pcl_program_binary_type = ˆTcl_program_binary_type;

This item has no description.

Pcl_program_build_info = ˆTcl_program_build_info;

This item has no description.

Pcl_program_info = ˆTcl_program_info;

This item has no description.

Pcl_queue_properties = ˆTcl_queue_properties;

This item has no description.

Pcl_sampler = ˆTcl_sampler;

This item has no description.

Pcl_sampler_info = ˆTcl_sampler_info;

This item has no description.

Pcl_sampler_properties = ˆTcl_sampler_properties;

This item has no description.

Pcl_svm_mem_flags = ˆTcl_svm_mem_flags;

This item has no description.

Tcl_addressing_mode = Tcl_uint;

This item has no description.

Tcl_bitfield = Tcl_ulong;

This item has no description.

Tcl_bool = Tcl_uint;

This item has no description.

Tcl_buffer_create_type = Tcl_uint;

This item has no description.

Tcl_build_status = Tcl_int;

This item has no description.

Tcl_channel_order = Tcl_uint;

This item has no description.

Tcl_channel_type = Tcl_uint;

This item has no description.

Tcl_command_queue = ˆT_cl_command_queue;

This item has no description.

Tcl_command_queue_info = Tcl_uint;

This item has no description.

Tcl_command_queue_properties = Tcl_bitfield;

This item has no description.

Tcl_command_type = Tcl_uint;

This item has no description.

Tcl_context = ˆT_cl_context;

This item has no description.

Tcl_context_info = Tcl_uint;

This item has no description.

Tcl_context_notify = procedure(errinfo: PAnsiChar; private_info: Pointer; size: NativeUInt; user_data: Pointer); stdcall;

CL_API_SUFFIX__VERSION_2_1 * Context APIs *//

Tcl_context_properties = intptr_t;

This item has no description.

Tcl_destructor_notify = procedure(memobj: Pcl_mem; user_data: Pointer); stdcall;

CL_API_SUFFIX__VERSION_2_0

Tcl_device_affinity_domain = Tcl_bitfield;

This item has no description.

Tcl_device_exec_capabilities = Tcl_bitfield;

This item has no description.

Tcl_device_fp_config = Tcl_bitfield;

This item has no description.

Tcl_device_id = ˆT_cl_device_id;

This item has no description.

Tcl_device_info = Tcl_uint;

This item has no description.

Tcl_device_local_mem_type = Tcl_uint;

This item has no description.

Tcl_device_mem_cache_type = Tcl_uint;

This item has no description.

Tcl_device_partition_property = intptr_t;

This item has no description.

Tcl_device_svm_capabilities = Tcl_bitfield;

This item has no description.

Tcl_device_type = Tcl_bitfield;

This item has no description.

Tcl_EnqueueNativeKernel = procedure(); stdcall;

CL_API_SUFFIX__VERSION_1_0

Tcl_EnqueueSVM_fn = procedure(); stdcall;

CL_API_SUFFIX__VERSION_1_2

Tcl_event = ˆT_cl_event;

This item has no description.

Tcl_event_info = Tcl_uint;

This item has no description.

Tcl_event_notify = procedure(event: Pcl_event; num_event: Tcl_int; user_data: Pointer); stdcall;

CL_API_SUFFIX__VERSION_1_1

Tcl_filter_mode = Tcl_uint;

This item has no description.

Tcl_image_info = Tcl_uint;

This item has no description.

Tcl_kernel = ˆT_cl_kernel;

This item has no description.

Tcl_kernel_arg_access_qualifier = Tcl_uint;

This item has no description.

Tcl_kernel_arg_address_qualifier = Tcl_uint;

This item has no description.

Tcl_kernel_arg_info = Tcl_uint;

This item has no description.

Tcl_kernel_arg_type_qualifier = Tcl_bitfield;

This item has no description.

Tcl_kernel_exec_info = Tcl_uint;

This item has no description.

Tcl_kernel_info = Tcl_uint;

This item has no description.

Tcl_kernel_sub_group_info = Tcl_uint;

This item has no description.

Tcl_kernel_work_group_info = Tcl_uint;

This item has no description.

Tcl_map_flags = Tcl_bitfield;

This item has no description.

Tcl_mem = ˆT_cl_mem;

This item has no description.

Tcl_mem_flags = Tcl_bitfield;

This item has no description.

Tcl_mem_info = Tcl_uint;

This item has no description.

Tcl_mem_migration_flag = Tcl_bitfield;

This item has no description.

Tcl_mem_object_type = Tcl_uint;

This item has no description.

Tcl_pipe_info = Tcl_uint;

This item has no description.

Tcl_pipe_properties = intptr_t;

This item has no description.

Tcl_platform_id = ˆT_cl_platform_id;

This item has no description.

Tcl_platform_info = Tcl_uint;

This item has no description.

Tcl_profiling_info = Tcl_uint;

This item has no description.

Tcl_program = ˆT_cl_program;

This item has no description.

Tcl_programbuilt_notify = procedure(_program: Pcl_program; user_data: Pointer); stdcall;

CL_API_SUFFIX__VERSION_1_0

Tcl_program_binary_type = Tcl_uint;

This item has no description.

Tcl_program_build_info = Tcl_uint;

This item has no description.

Tcl_program_info = Tcl_uint;

This item has no description.

Tcl_queue_properties = Tcl_bitfield;

This item has no description.

Tcl_sampler = ˆT_cl_sampler;

This item has no description.

Tcl_sampler_info = Tcl_uint;

This item has no description.

Tcl_sampler_properties = Tcl_bitfield;

This item has no description.

Tcl_svm_mem_flags = Tcl_bitfield;

This item has no description.

Constants

LibOpenCL = 'OpenCL.dll';

This item has no description.

CL_SUCCESS = 0;

Error Codes

CL_DEVICE_NOT_FOUND = -1;

This item has no description.

CL_DEVICE_NOT_AVAILABLE = -2;

This item has no description.

CL_COMPILER_NOT_AVAILABLE = -3;

This item has no description.

CL_MEM_OBJECT_ALLOCATION_FAILURE = -4;

This item has no description.

CL_OUT_OF_RESOURCES = -5;

This item has no description.

CL_OUT_OF_HOST_MEMORY = -6;

This item has no description.

CL_PROFILING_INFO_NOT_AVAILABLE = -7;

This item has no description.

CL_MEM_COPY_OVERLAP = -8;

This item has no description.

CL_IMAGE_FORMAT_MISMATCH = -9;

This item has no description.

CL_IMAGE_FORMAT_NOT_SUPPORTED = -10;

This item has no description.

CL_BUILD_PROGRAM_FAILURE = -11;

This item has no description.

CL_MAP_FAILURE = -12;

This item has no description.

CL_MISALIGNED_SUB_BUFFER_OFFSET = -13;

This item has no description.

CL_EXEC_STATUS_ERROR_FOR_EVENTS_IN_WAIT_LIST = -14;

This item has no description.

CL_COMPILE_PROGRAM_FAILURE = -15;

This item has no description.

CL_LINKER_NOT_AVAILABLE = -16;

This item has no description.

CL_LINK_PROGRAM_FAILURE = -17;

This item has no description.

CL_DEVICE_PARTITION_FAILED = -18;

This item has no description.

CL_KERNEL_ARG_INFO_NOT_AVAILABLE = -19;

This item has no description.

CL_INVALID_VALUE = -30;

This item has no description.

CL_INVALID_DEVICE_TYPE = -31;

This item has no description.

CL_INVALID_PLATFORM = -32;

This item has no description.

CL_INVALID_DEVICE = -33;

This item has no description.

CL_INVALID_CONTEXT = -34;

This item has no description.

CL_INVALID_QUEUE_PROPERTIES = -35;

This item has no description.

CL_INVALID_COMMAND_QUEUE = -36;

This item has no description.

CL_INVALID_HOST_PTR = -37;

This item has no description.

CL_INVALID_MEM_OBJECT = -38;

This item has no description.

CL_INVALID_IMAGE_FORMAT_DESCRIPTOR = -39;

This item has no description.

CL_INVALID_IMAGE_SIZE = -40;

This item has no description.

CL_INVALID_SAMPLER = -41;

This item has no description.

CL_INVALID_BINARY = -42;

This item has no description.

CL_INVALID_BUILD_OPTIONS = -43;

This item has no description.

CL_INVALID_PROGRAM = -44;

This item has no description.

CL_INVALID_PROGRAM_EXECUTABLE = -45;

This item has no description.

CL_INVALID_KERNEL_NAME = -46;

This item has no description.

CL_INVALID_KERNEL_DEFINITION = -47;

This item has no description.

CL_INVALID_KERNEL = -48;

This item has no description.

CL_INVALID_ARG_INDEX = -49;

This item has no description.

CL_INVALID_ARG_VALUE = -50;

This item has no description.

CL_INVALID_ARG_SIZE = -51;

This item has no description.

CL_INVALID_KERNEL_ARGS = -52;

This item has no description.

CL_INVALID_WORK_DIMENSION = -53;

This item has no description.

CL_INVALID_WORK_GROUP_SIZE = -54;

This item has no description.

CL_INVALID_WORK_ITEM_SIZE = -55;

This item has no description.

CL_INVALID_GLOBAL_OFFSET = -56;

This item has no description.

CL_INVALID_EVENT_WAIT_LIST = -57;

This item has no description.

CL_INVALID_EVENT = -58;

This item has no description.

CL_INVALID_OPERATION = -59;

This item has no description.

CL_INVALID_GL_OBJECT = -60;

This item has no description.

CL_INVALID_BUFFER_SIZE = -61;

This item has no description.

CL_INVALID_MIP_LEVEL = -62;

This item has no description.

CL_INVALID_GLOBAL_WORK_SIZE = -63;

This item has no description.

CL_INVALID_PROPERTY = -64;

This item has no description.

CL_INVALID_IMAGE_DESCRIPTOR = -65;

This item has no description.

CL_INVALID_COMPILER_OPTIONS = -66;

This item has no description.

CL_INVALID_LINKER_OPTIONS = -67;

This item has no description.

CL_INVALID_DEVICE_PARTITION_COUNT = -68;

This item has no description.

CL_INVALID_PIPE_SIZE = -69;

This item has no description.

CL_INVALID_DEVICE_QUEUE = -70;

This item has no description.

CL_INVALID_SPEC_ID = -71;

This item has no description.

CL_MAX_SIZE_RESTRICTION_EXCEEDED = -72;

This item has no description.

CL_VERSION_1_0 = 1;

OpenCL Version

CL_VERSION_1_1 = 1;

This item has no description.

CL_VERSION_1_2 = 1;

This item has no description.

CL_VERSION_2_0 = 1;

This item has no description.

CL_VERSION_2_1 = 1;

This item has no description.

CL_VERSION_2_2 = 1;

This item has no description.

CL_FALSE = 0;

cl_bool

CL_TRUE = 1;

This item has no description.

CL_BLOCKING = CL_TRUE;

This item has no description.

CL_NON_BLOCKING = CL_FALSE;

This item has no description.

CL_PLATFORM_PROFILE = $0900;

cl_platform_info

CL_PLATFORM_VERSION = $0901;

This item has no description.

CL_PLATFORM_NAME = $0902;

This item has no description.

CL_PLATFORM_VENDOR = $0903;

This item has no description.

CL_PLATFORM_EXTENSIONS = $0904;

This item has no description.

CL_PLATFORM_HOST_TIMER_RESOLUTION = $0905;

This item has no description.

CL_DEVICE_TYPE_DEFAULT = (1 shl 0);

cl_device_type - bitfield

CL_DEVICE_TYPE_CPU = (1 shl 1);

This item has no description.

CL_DEVICE_TYPE_GPU = (1 shl 2);

This item has no description.

CL_DEVICE_TYPE_ACCELERATOR = (1 shl 3);

This item has no description.

CL_DEVICE_TYPE_CUSTOM = (1 shl 4);

This item has no description.

CL_DEVICE_TYPE_ALL = $FFFFFFFF;

This item has no description.

CL_DEVICE_TYPE = $1000;

cl_device_info

CL_DEVICE_VENDOR_ID = $1001;

This item has no description.

CL_DEVICE_MAX_COMPUTE_UNITS = $1002;

This item has no description.

CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS = $1003;

This item has no description.

CL_DEVICE_MAX_WORK_GROUP_SIZE = $1004;

This item has no description.

CL_DEVICE_MAX_WORK_ITEM_SIZES = $1005;

This item has no description.

CL_DEVICE_PREFERRED_VECTOR_WIDTH_CHAR = $1006;

This item has no description.

CL_DEVICE_PREFERRED_VECTOR_WIDTH_SHORT = $1007;

This item has no description.

CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT = $1008;

This item has no description.

CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG = $1009;

This item has no description.

CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT = $100A;

This item has no description.

CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE = $100B;

This item has no description.

CL_DEVICE_MAX_CLOCK_FREQUENCY = $100C;

This item has no description.

CL_DEVICE_ADDRESS_BITS = $100D;

This item has no description.

CL_DEVICE_MAX_READ_IMAGE_ARGS = $100E;

This item has no description.

CL_DEVICE_MAX_WRITE_IMAGE_ARGS = $100F;

This item has no description.

CL_DEVICE_MAX_MEM_ALLOC_SIZE = $1010;

This item has no description.

CL_DEVICE_IMAGE2D_MAX_WIDTH = $1011;

This item has no description.

CL_DEVICE_IMAGE2D_MAX_HEIGHT = $1012;

This item has no description.

CL_DEVICE_IMAGE3D_MAX_WIDTH = $1013;

This item has no description.

CL_DEVICE_IMAGE3D_MAX_HEIGHT = $1014;

This item has no description.

CL_DEVICE_IMAGE3D_MAX_DEPTH = $1015;

This item has no description.

CL_DEVICE_IMAGE_SUPPORT = $1016;

This item has no description.

CL_DEVICE_MAX_PARAMETER_SIZE = $1017;

This item has no description.

CL_DEVICE_MAX_SAMPLERS = $1018;

This item has no description.

CL_DEVICE_MEM_BASE_ADDR_ALIGN = $1019;

This item has no description.

CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE = $101A;

This item has no description.

CL_DEVICE_SINGLE_FP_CONFIG = $101B;

This item has no description.

CL_DEVICE_GLOBAL_MEM_CACHE_TYPE = $101C;

This item has no description.

CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE = $101D;

This item has no description.

CL_DEVICE_GLOBAL_MEM_CACHE_SIZE = $101E;

This item has no description.

CL_DEVICE_GLOBAL_MEM_SIZE = $101F;

This item has no description.

CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE = $1020;

This item has no description.

CL_DEVICE_MAX_CONSTANT_ARGS = $1021;

This item has no description.

CL_DEVICE_LOCAL_MEM_TYPE = $1022;

This item has no description.

CL_DEVICE_LOCAL_MEM_SIZE = $1023;

This item has no description.

CL_DEVICE_ERROR_CORRECTION_SUPPORT = $1024;

This item has no description.

CL_DEVICE_PROFILING_TIMER_RESOLUTION = $1025;

This item has no description.

CL_DEVICE_ENDIAN_LITTLE = $1026;

This item has no description.

CL_DEVICE_AVAILABLE = $1027;

This item has no description.

CL_DEVICE_COMPILER_AVAILABLE = $1028;

This item has no description.

CL_DEVICE_EXECUTION_CAPABILITIES = $1029;

This item has no description.

CL_DEVICE_QUEUE_PROPERTIES = $102A;

This item has no description.

CL_DEVICE_QUEUE_ON_HOST_PROPERTIES = $102A;

deprecated

CL_DEVICE_NAME = $102B;

This item has no description.

CL_DEVICE_VENDOR = $102C;

This item has no description.

CL_DRIVER_VERSION = $102D;

This item has no description.

CL_DEVICE_PROFILE = $102E;

This item has no description.

CL_DEVICE_VERSION = $102F;

This item has no description.

CL_DEVICE_EXTENSIONS = $1030;

This item has no description.

CL_DEVICE_PLATFORM = $1031;

This item has no description.

CL_DEVICE_DOUBLE_FP_CONFIG = $1032;

This item has no description.

CL_DEVICE_HALF_FP_CONFIG = $1033;

This item has no description.

CL_DEVICE_PREFERRED_VECTOR_WIDTH_HALF = $1034;

This item has no description.

CL_DEVICE_HOST_UNIFIED_MEMORY = $1035;

This item has no description.

CL_DEVICE_NATIVE_VECTOR_WIDTH_CHAR = $1036;

deprecated

CL_DEVICE_NATIVE_VECTOR_WIDTH_SHORT = $1037;

This item has no description.

CL_DEVICE_NATIVE_VECTOR_WIDTH_INT = $1038;

This item has no description.

CL_DEVICE_NATIVE_VECTOR_WIDTH_LONG = $1039;

This item has no description.

CL_DEVICE_NATIVE_VECTOR_WIDTH_FLOAT = $103A;

This item has no description.

CL_DEVICE_NATIVE_VECTOR_WIDTH_DOUBLE = $103B;

This item has no description.

CL_DEVICE_NATIVE_VECTOR_WIDTH_HALF = $103C;

This item has no description.

CL_DEVICE_OPENCL_C_VERSION = $103D;

This item has no description.

CL_DEVICE_LINKER_AVAILABLE = $103E;

This item has no description.

CL_DEVICE_BUILT_IN_KERNELS = $103F;

This item has no description.

CL_DEVICE_IMAGE_MAX_BUFFER_SIZE = $1040;

This item has no description.

CL_DEVICE_IMAGE_MAX_ARRAY_SIZE = $1041;

This item has no description.

CL_DEVICE_PARENT_DEVICE = $1042;

This item has no description.

CL_DEVICE_PARTITION_MAX_SUB_DEVICES = $1043;

This item has no description.

CL_DEVICE_PARTITION_PROPERTIES = $1044;

This item has no description.

CL_DEVICE_PARTITION_AFFINITY_DOMAIN = $1045;

This item has no description.

CL_DEVICE_PARTITION_TYPE = $1046;

This item has no description.

CL_DEVICE_REFERENCE_COUNT = $1047;

This item has no description.

CL_DEVICE_PREFERRED_INTEROP_USER_SYNC = $1048;

This item has no description.

CL_DEVICE_PRINTF_BUFFER_SIZE = $1049;

This item has no description.

CL_DEVICE_IMAGE_PITCH_ALIGNMENT = $104A;

This item has no description.

CL_DEVICE_IMAGE_BASE_ADDRESS_ALIGNMENT = $104B;

This item has no description.

CL_DEVICE_MAX_READ_WRITE_IMAGE_ARGS = $104C;

This item has no description.

CL_DEVICE_MAX_GLOBAL_VARIABLE_SIZE = $104D;

This item has no description.

CL_DEVICE_QUEUE_ON_DEVICE_PROPERTIES = $104E;

This item has no description.

CL_DEVICE_QUEUE_ON_DEVICE_PREFERRED_SIZE = $104F;

This item has no description.

CL_DEVICE_QUEUE_ON_DEVICE_MAX_SIZE = $1050;

This item has no description.

CL_DEVICE_MAX_ON_DEVICE_QUEUES = $1051;

This item has no description.

CL_DEVICE_MAX_ON_DEVICE_EVENTS = $1052;

This item has no description.

CL_DEVICE_SVM_CAPABILITIES = $1053;

This item has no description.

CL_DEVICE_GLOBAL_VARIABLE_PREFERRED_TOTAL_SIZE = $1054;

This item has no description.

CL_DEVICE_MAX_PIPE_ARGS = $1055;

This item has no description.

CL_DEVICE_PIPE_MAX_ACTIVE_RESERVATIONS = $1056;

This item has no description.

CL_DEVICE_PIPE_MAX_PACKET_SIZE = $1057;

This item has no description.

CL_DEVICE_PREFERRED_PLATFORM_ATOMIC_ALIGNMENT = $1058;

This item has no description.

CL_DEVICE_PREFERRED_GLOBAL_ATOMIC_ALIGNMENT = $1059;

This item has no description.

CL_DEVICE_PREFERRED_LOCAL_ATOMIC_ALIGNMENT = $105A;

This item has no description.

CL_DEVICE_IL_VERSION = $105B;

This item has no description.

CL_DEVICE_MAX_NUM_SUB_GROUPS = $105C;

This item has no description.

CL_DEVICE_SUB_GROUP_INDEPENDENT_FORWARD_PROGRESS = $105D;

This item has no description.

CL_FP_DENORM = (1 shl 0);

cl_device_fp_config - bitfield

CL_FP_INF_NAN = (1 shl 1);

This item has no description.

CL_FP_ROUND_TO_NEAREST = (1 shl 2);

This item has no description.

CL_FP_ROUND_TO_ZERO = (1 shl 3);

This item has no description.

CL_FP_ROUND_TO_INF = (1 shl 4);

This item has no description.

CL_FP_FMA = (1 shl 5);

This item has no description.

CL_FP_SOFT_FLOAT = (1 shl 6);

This item has no description.

CL_FP_CORRECTLY_ROUNDED_DIVIDE_SQRT = (1 shl 7);

This item has no description.

CL_NONE = $0;

cl_device_mem_cache_type

CL_READ_ONLY_CACHE = $1;

This item has no description.

CL_READ_WRITE_CACHE = $2;

This item has no description.

CL_LOCAL = $1;

cl_device_local_mem_type

CL_GLOBAL = $2;

This item has no description.

CL_EXEC_KERNEL = (1 shl 0);

cl_device_exec_capabilities - bitfield

CL_EXEC_NATIVE_KERNEL = (1 shl 1);

This item has no description.

CL_QUEUE_OUT_OF_ORDER_EXEC_MODE_ENABLE = (1 shl 0);

cl_command_queue_properties - bitfield

CL_QUEUE_PROFILING_ENABLE = (1 shl 1);

This item has no description.

CL_QUEUE_ON_DEVICE = (1 shl 2);

This item has no description.

CL_QUEUE_ON_DEVICE_DEFAULT = (1 shl 3);

This item has no description.

CL_CONTEXT_REFERENCE_COUNT = $1080;

cl_context_info

CL_CONTEXT_DEVICES = $1081;

This item has no description.

CL_CONTEXT_PROPERTIES = $1082;

This item has no description.

CL_CONTEXT_NUM_DEVICES = $1083;

This item has no description.

CL_CONTEXT_PLATFORM = $1084;

cl_context_properties

CL_CONTEXT_INTEROP_USER_SYNC = $1085;

This item has no description.

CL_DEVICE_PARTITION_EQUALLY = $1086;

cl_device_partition_property

CL_DEVICE_PARTITION_BY_COUNTS = $1087;

This item has no description.

CL_DEVICE_PARTITION_BY_COUNTS_LIST_END = $0;

This item has no description.

CL_DEVICE_PARTITION_BY_AFFINITY_DOMAIN = $1088;

This item has no description.

CL_DEVICE_AFFINITY_DOMAIN_NUMA = (1 shl 0);

cl_device_affinity_domain

CL_DEVICE_AFFINITY_DOMAIN_L4_CACHE = (1 shl 1);

This item has no description.

CL_DEVICE_AFFINITY_DOMAIN_L3_CACHE = (1 shl 2);

This item has no description.

CL_DEVICE_AFFINITY_DOMAIN_L2_CACHE = (1 shl 3);

This item has no description.

CL_DEVICE_AFFINITY_DOMAIN_L1_CACHE = (1 shl 4);

This item has no description.

CL_DEVICE_AFFINITY_DOMAIN_NEXT_PARTITIONABLE = (1 shl 5);

This item has no description.

CL_DEVICE_SVM_COARSE_GRAIN_BUFFER = (1 shl 0);

cl_device_svm_capabilities

CL_DEVICE_SVM_FINE_GRAIN_BUFFER = (1 shl 1);

This item has no description.

CL_DEVICE_SVM_FINE_GRAIN_SYSTEM = (1 shl 2);

This item has no description.

CL_DEVICE_SVM_ATOMICS = (1 shl 3);

This item has no description.

CL_QUEUE_CONTEXT = $1090;

cl_command_queue_info

CL_QUEUE_DEVICE = $1091;

This item has no description.

CL_QUEUE_REFERENCE_COUNT = $1092;

This item has no description.

CL_QUEUE_PROPERTIES = $1093;

This item has no description.

CL_QUEUE_SIZE = $1094;

This item has no description.

CL_QUEUE_DEVICE_DEFAULT = $1095;

This item has no description.

CL_MEM_READ_WRITE = (1 shl 0);

cl_mem_flags - bitfield

CL_MEM_WRITE_ONLY = (1 shl 1);

This item has no description.

CL_MEM_READ_ONLY = (1 shl 2);

This item has no description.

CL_MEM_USE_HOST_PTR = (1 shl 3);

This item has no description.

CL_MEM_ALLOC_HOST_PTR = (1 shl 4);

This item has no description.

CL_MEM_COPY_HOST_PTR = (1 shl 5);

This item has no description.

CL_MEM_HOST_WRITE_ONLY = (1 shl 7);

reserved (1 shl 6);

CL_MEM_HOST_READ_ONLY = (1 shl 8);

This item has no description.

CL_MEM_HOST_NO_ACCESS = (1 shl 9);

This item has no description.

CL_MEM_SVM_FINE_GRAIN_BUFFER = (1 shl 10);

This item has no description.

CL_MEM_SVM_ATOMICS = (1 shl 11);

used by cl_svm_mem_flags only

CL_MEM_KERNEL_READ_AND_WRITE = (1 shl 12);

used by cl_svm_mem_flags only

CL_MIGRATE_MEM_OBJECT_HOST = (1 shl 0);

cl_mem_migration_flags - bitfield

CL_MIGRATE_MEM_OBJECT_CONTENT_UNDEFINED = (1 shl 1);

This item has no description.

CL_R = $10B0;

cl_channel_order

CL_A = $10B1;

This item has no description.

CL_RG = $10B2;

This item has no description.

CL_RA = $10B3;

This item has no description.

CL_RGB = $10B4;

This item has no description.

CL_RGBA = $10B5;

This item has no description.

CL_BGRA = $10B6;

This item has no description.

CL_ARGB = $10B7;

This item has no description.

CL_INTENSITY = $10B8;

This item has no description.

CL_LUMINANCE = $10B9;

This item has no description.

CL_Rx = $10BA;

This item has no description.

CL_RGx = $10BB;

This item has no description.

CL_RGBx = $10BC;

This item has no description.

CL_DEPTH = $10BD;

This item has no description.

CL_DEPTH_STENCIL = $10BE;

This item has no description.

CL_sRGB = $10BF;

This item has no description.

CL_sRGBx = $10C0;

This item has no description.

CL_sRGBA = $10C1;

This item has no description.

CL_sBGRA = $10C2;

This item has no description.

CL_ABGR = $10C3;

This item has no description.

CL_SNORM_INT8 = $10D0;

* cl_channel_type *//

CL_SNORM_INT16 = $10D1;

This item has no description.

CL_UNORM_INT8 = $10D2;

This item has no description.

CL_UNORM_INT16 = $10D3;

This item has no description.

CL_UNORM_SHORT_565 = $10D4;

This item has no description.

CL_UNORM_SHORT_555 = $10D5;

This item has no description.

CL_UNORM_INT_101010 = $10D6;

This item has no description.

CL_SIGNED_INT8 = $10D7;

This item has no description.

CL_SIGNED_INT16 = $10D8;

This item has no description.

CL_SIGNED_INT32 = $10D9;

This item has no description.

CL_UNSIGNED_INT8 = $10DA;

This item has no description.

CL_UNSIGNED_INT16 = $10DB;

This item has no description.

CL_UNSIGNED_INT32 = $10DC;

This item has no description.

CL_HALF_FLOAT = $10DD;

This item has no description.

CL_FLOAT = $10DE;

This item has no description.

CL_UNORM_INT24 = $10DF;

This item has no description.

CL_UNORM_INT_101010_2 = $10E0;

This item has no description.

CL_MEM_OBJECT_BUFFER = $10F0;

cl_mem_object_type

CL_MEM_OBJECT_IMAGE2D = $10F1;

This item has no description.

CL_MEM_OBJECT_IMAGE3D = $10F2;

This item has no description.

CL_MEM_OBJECT_IMAGE2D_ARRAY = $10F3;

This item has no description.

CL_MEM_OBJECT_IMAGE1D = $10F4;

This item has no description.

CL_MEM_OBJECT_IMAGE1D_ARRAY = $10F5;

This item has no description.

CL_MEM_OBJECT_IMAGE1D_BUFFER = $10F6;

This item has no description.

CL_MEM_OBJECT_PIPE = $10F7;

This item has no description.

CL_MEM_TYPE = $1100;

cl_mem_info

CL_MEM_FLAGS = $1101;

This item has no description.

CL_MEM_SIZE = $1102;

This item has no description.

CL_MEM_HOST_PTR = $1103;

This item has no description.

CL_MEM_MAP_COUNT = $1104;

This item has no description.

CL_MEM_REFERENCE_COUNT = $1105;

This item has no description.

CL_MEM_CONTEXT = $1106;

This item has no description.

CL_MEM_ASSOCIATED_MEMOBJECT = $1107;

This item has no description.

CL_MEM_OFFSET = $1108;

This item has no description.

CL_MEM_USES_SVM_POINTER = $1109;

This item has no description.

CL_IMAGE_FORMAT = $1110;

cl_image_info

CL_IMAGE_ELEMENT_SIZE = $1111;

This item has no description.

CL_IMAGE_ROW_PITCH = $1112;

This item has no description.

CL_IMAGE_SLICE_PITCH = $1113;

This item has no description.

CL_IMAGE_WIDTH = $1114;

This item has no description.

CL_IMAGE_HEIGHT = $1115;

This item has no description.

CL_IMAGE_DEPTH = $1116;

This item has no description.

CL_IMAGE_ARRAY_SIZE = $1117;

This item has no description.

CL_IMAGE_BUFFER = $1118;

This item has no description.

CL_IMAGE_NUM_MIP_LEVELS = $1119;

This item has no description.

CL_IMAGE_NUM_SAMPLES = $111A;

This item has no description.

CL_PIPE_PACKET_SIZE = $1120;

cl_pipe_info

CL_PIPE_MAX_PACKETS = $1121;

This item has no description.

CL_ADDRESS_NONE = $1130;

cl_addressing_mode

CL_ADDRESS_CLAMP_TO_EDGE = $1131;

This item has no description.

CL_ADDRESS_CLAMP = $1132;

This item has no description.

CL_ADDRESS_REPEAT = $1133;

This item has no description.

CL_ADDRESS_MIRRORED_REPEAT = $1134;

This item has no description.

CL_FILTER_NEAREST = $1140;

cl_filter_mode

CL_FILTER_LINEAR = $1141;

This item has no description.

CL_SAMPLER_REFERENCE_COUNT = $1150;

cl_sampler_info

CL_SAMPLER_CONTEXT = $1151;

This item has no description.

CL_SAMPLER_NORMALIZED_COORDS = $1152;

This item has no description.

CL_SAMPLER_ADDRESSING_MODE = $1153;

This item has no description.

CL_SAMPLER_FILTER_MODE = $1154;

This item has no description.

CL_SAMPLER_MIP_FILTER_MODE = $1155;

This item has no description.

CL_SAMPLER_LOD_MIN = $1156;

This item has no description.

CL_SAMPLER_LOD_MAX = $1157;

This item has no description.

CL_MAP_READ = (1 shl 0);

cl_map_flags - bitfield

CL_MAP_WRITE = (1 shl 1);

This item has no description.

CL_MAP_WRITE_INVALIDATE_REGION = (1 shl 2);

This item has no description.

CL_PROGRAM_REFERENCE_COUNT = $1160;

cl_program_info

CL_PROGRAM_CONTEXT = $1161;

This item has no description.

CL_PROGRAM_NUM_DEVICES = $1162;

This item has no description.

CL_PROGRAM_DEVICES = $1163;

This item has no description.

CL_PROGRAM_SOURCE = $1164;

This item has no description.

CL_PROGRAM_BINARY_SIZES = $1165;

This item has no description.

CL_PROGRAM_BINARIES = $1166;

This item has no description.

CL_PROGRAM_NUM_KERNELS = $1167;

This item has no description.

CL_PROGRAM_KERNEL_NAMES = $1168;

This item has no description.

CL_PROGRAM_IL = $1169;

This item has no description.

CL_PROGRAM_SCOPE_GLOBAL_CTORS_PRESENT = $116A;

This item has no description.

CL_PROGRAM_SCOPE_GLOBAL_DTORS_PRESENT = $116B;

This item has no description.

CL_PROGRAM_BUILD_STATUS = $1181;

cl_program_build_info

CL_PROGRAM_BUILD_OPTIONS = $1182;

This item has no description.

CL_PROGRAM_BUILD_LOG = $1183;

This item has no description.

CL_PROGRAM_BINARY_TYPE = $1184;

This item has no description.

CL_PROGRAM_BUILD_GLOBAL_VARIABLE_TOTAL_SIZE = $1185;

This item has no description.

CL_PROGBRAM_BINARY_TYPE_NONE = $0;

cl_program_binary_type

CL_PROGRAM_BINARY_TYPE_COMPILED_OBJECT = $1;

This item has no description.

CL_PROGRAM_BINARY_TYPE_LIBRARY = $2;

This item has no description.

CL_PROGRAM_BINARY_TYPE_EXECUTABLE = $4;

This item has no description.

CL_BUILD_SUCCESS = 0;

cl_build_status

CL_BUILD_NONE = -1;

This item has no description.

CL_BUILD_ERROR = -2;

This item has no description.

CL_BUILD_IN_PROGRESS = -3;

This item has no description.

CL_KERNEL_FUNCTION_NAME = $1190;

cl_kernel_info

CL_KERNEL_NUM_ARGS = $1191;

This item has no description.

CL_KERNEL_REFERENCE_COUNT = $1192;

This item has no description.

CL_KERNEL_CONTEXT = $1193;

This item has no description.

CL_KERNEL_PROGRAM = $1194;

This item has no description.

CL_KERNEL_ATTRIBUTES = $1195;

This item has no description.

CL_KERNEL_MAX_NUM_SUB_GROUPS = $11B9;

This item has no description.

CL_KERNEL_COMPILE_NUM_SUB_GROUPS = $11BA;

This item has no description.

CL_KERNEL_ARG_ADDRESS_QUALIFIER = $1196;

cl_kernel_arg_info

CL_KERNEL_ARG_ACCESS_QUALIFIER = $1197;

This item has no description.

CL_KERNEL_ARG_TYPE_NAME = $1198;

This item has no description.

CL_KERNEL_ARG_TYPE_QUALIFIER = $1199;

This item has no description.

CL_KERNEL_ARG_NAME = $119A;

This item has no description.

CL_KERNEL_ARG_ADDRESS_GLOBAL = $119B;

cl_kernel_arg_address_qualifier

CL_KERNEL_ARG_ADDRESS_LOCAL = $119C;

This item has no description.

CL_KERNEL_ARG_ADDRESS_CONSTANT = $119D;

This item has no description.

CL_KERNEL_ARG_ADDRESS_PRIVATE = $119E;

This item has no description.

CL_KERNEL_ARG_ACCESS_READ_ONLY = $11A0;

cl_kernel_arg_access_qualifier

CL_KERNEL_ARG_ACCESS_WRITE_ONLY = $11A1;

This item has no description.

CL_KERNEL_ARG_ACCESS_READ_WRITE = $11A2;

This item has no description.

CL_KERNEL_ARG_ACCESS_NONE = $11A3;

This item has no description.

CL_KERNEL_ARG_TYPE_NONE = 0;

cl_kernel_arg_type_qualifer

CL_KERNEL_ARG_TYPE_CONST = (1 shl 0);

This item has no description.

CL_KERNEL_ARG_TYPE_RESTRICT = (1 shl 1);

This item has no description.

CL_KERNEL_ARG_TYPE_VOLATILE = (1 shl 2);

This item has no description.

CL_KERNEL_ARG_TYPE_PIPE = (1 shl 3);

This item has no description.

CL_KERNEL_WORK_GROUP_SIZE = $11B0;

cl_kernel_work_group_info

CL_KERNEL_COMPILE_WORK_GROUP_SIZE = $11B1;

This item has no description.

CL_KERNEL_LOCAL_MEM_SIZE = $11B2;

This item has no description.

CL_KERNEL_PREFERRED_WORK_GROUP_SIZE_MULTIPLE = $11B3;

This item has no description.

CL_KERNEL_PRIVATE_MEM_SIZE = $11B4;

This item has no description.

CL_KERNEL_GLOBAL_WORK_SIZE = $11B5;

This item has no description.

CL_KERNEL_MAX_SUB_GROUP_SIZE_FOR_NDRANGE = $2033;

cl_kernel_sub_group_info

CL_KERNEL_SUB_GROUP_COUNT_FOR_NDRANGE = $2034;

This item has no description.

CL_KERNEL_LOCAL_SIZE_FOR_SUB_GROUP_COUNT = $11B8;

This item has no description.

CL_KERNEL_EXEC_INFO_SVM_PTRS = $11B6;

cl_kernel_exec_info

CL_KERNEL_EXEC_INFO_SVM_FINE_GRAIN_SYSTEM = $11B7;

This item has no description.

CL_EVENT_COMMAND_QUEUE = $11D0;

cl_event_info

CL_EVENT_COMMAND_TYPE = $11D1;

This item has no description.

CL_EVENT_REFERENCE_COUNT = $11D2;

This item has no description.

CL_EVENT_COMMAND_EXECUTION_STATUS = $11D3;

This item has no description.

CL_EVENT_CONTEXT = $11D4;

This item has no description.

CL_COMMAND_NDRANGE_KERNEL = $11F0;

cl_command_type

CL_COMMAND_TASK = $11F1;

This item has no description.

CL_COMMAND_NATIVE_KERNEL = $11F2;

This item has no description.

CL_COMMAND_READ_BUFFER = $11F3;

This item has no description.

CL_COMMAND_WRITE_BUFFER = $11F4;

This item has no description.

CL_COMMAND_COPY_BUFFER = $11F5;

This item has no description.

CL_COMMAND_READ_IMAGE = $11F6;

This item has no description.

CL_COMMAND_WRITE_IMAGE = $11F7;

This item has no description.

CL_COMMAND_COPY_IMAGE = $11F8;

This item has no description.

CL_COMMAND_COPY_IMAGE_TO_BUFFER = $11F9;

This item has no description.

CL_COMMAND_COPY_BUFFER_TO_IMAGE = $11FA;

This item has no description.

CL_COMMAND_MAP_BUFFER = $11FB;

This item has no description.

CL_COMMAND_MAP_IMAGE = $11FC;

This item has no description.

CL_COMMAND_UNMAP_MEM_OBJECT = $11FD;

This item has no description.

CL_COMMAND_MARKER = $11FE;

This item has no description.

CL_COMMAND_ACQUIRE_GL_OBJECTS = $11FF;

This item has no description.

CL_COMMAND_RELEASE_GL_OBJECTS = $1200;

This item has no description.

CL_COMMAND_READ_BUFFER_RECT = $1201;

This item has no description.

CL_COMMAND_WRITE_BUFFER_RECT = $1202;

This item has no description.

CL_COMMAND_COPY_BUFFER_RECT = $1203;

This item has no description.

CL_COMMAND_USER = $1204;

This item has no description.

CL_COMMAND_BARRIER = $1205;

This item has no description.

CL_COMMAND_MIGRATE_MEM_OBJECTS = $1206;

This item has no description.

CL_COMMAND_FILL_BUFFER = $1207;

This item has no description.

CL_COMMAND_FILL_IMAGE = $1208;

This item has no description.

CL_COMMAND_SVM_FREE = $1209;

This item has no description.

CL_COMMAND_SVM_MEMCPY = $120A;

This item has no description.

CL_COMMAND_SVM_MEMFILL = $120B;

This item has no description.

CL_COMMAND_SVM_MAP = $120C;

This item has no description.

CL_COMMAND_SVM_UNMAP = $120D;

This item has no description.

CL_COMPLETE = $0;

command execution status

CL_RUNNING = $1;

This item has no description.

CL_SUBMITTED = $2;

This item has no description.

CL_QUEUED = $3;

This item has no description.

CL_BUFFER_CREATE_TYPE_REGION = $1220;

cl_buffer_create_type

CL_PROFILING_COMMAND_QUEUED = $1280;

cl_profiling_info

CL_PROFILING_COMMAND_SUBMIT = $1281;

This item has no description.

CL_PROFILING_COMMAND_START = $1282;

This item has no description.

CL_PROFILING_COMMAND_END = $1283;

This item has no description.

CL_PROFILING_COMMAND_COMPLETE = $1284;


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_platform_id

Record T_cl_platform_id

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_platform_id = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_device_id

Record T_cl_device_id

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_device_id = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_context

Record T_cl_context

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_context = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_command_queue

Record T_cl_command_queue

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_command_queue = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_mem

Record T_cl_mem

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_mem = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_program

Record T_cl_program

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_program = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_kernel

Record T_cl_kernel

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_kernel = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_event

Record T_cl_event

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_event = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Record T_cl_sampler

Record T_cl_sampler

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type T_cl_sampler = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: OpenCL.Import: Packed Record Tcl_image_format

Packed Record Tcl_image_format

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type Tcl_image_format = packed record

Description

This item has no description.

Overview

Fields

Public | image_channel_order: Tcl_channel_order;
Public | image_channel_data_type: Tcl_channel_type;

Description

Fields

Public image_channel_order: Tcl_channel_order;

This item has no description.

Public image_channel_data_type: Tcl_channel_type;


GLSysHelp v.2.5: OpenCL.Import: Packed Record Tcl_image_desc

Packed Record Tcl_image_desc

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type Tcl_image_desc = packed record

Description

This item has no description.

Overview

Fields

Public | image_type: Tcl_mem_object_type;
Public | image_width: NativeUInt;
Public | image_height: NativeUInt;
Public | image_depth: NativeUInt;
Public | image_array_size: NativeUInt;
Public | image_row_pitch: NativeUInt;
Public | image_slice_pitch: NativeUInt;
Public | num_mip_levels: Tcl_uint;
Public | num_samples: Tcl_uint;
Public | buffer: Pcl_mem;
Public | mem_object: Pcl_mem;

Description

Fields

Public image_type: Tcl_mem_object_type;

This item has no description.

Public image_width: NativeUInt;

This item has no description.

Public image_height: NativeUInt;

This item has no description.

Public image_depth: NativeUInt;

This item has no description.

Public image_array_size: NativeUInt;

This item has no description.

Public image_row_pitch: NativeUInt;

This item has no description.

Public image_slice_pitch: NativeUInt;

This item has no description.

Public num_mip_levels: Tcl_uint;

This item has no description.

Public num_samples: Tcl_uint;

This item has no description.

Public buffer: Pcl_mem;

This item has no description.

Public mem_object: Pcl_mem;


GLSysHelp v.2.5: OpenCL.Import: Packed Record Tcl_buffer_region

Packed Record Tcl_buffer_region

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenCL.Import

Declaration

type Tcl_buffer_region = packed record

Description

This item has no description.

Overview

Fields

Public | origin: NativeUInt;
Public | size: NativeUInt;

Description

Fields

Public origin: NativeUInt;

This item has no description.

Public size: NativeUInt;


GLSysHelp v.2.5: OpenCL.Platform

Unit OpenCL.Platform

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Overview

Types

intptr_t = NativeUInt;
Pcl_char = ˆTcl_char;
Pcl_double = ˆTcl_double;
Pcl_float = ˆTcl_float;
Pcl_half = ˆTcl_half;
Pcl_int = ˆTcl_int;
Pcl_long = ˆTcl_long;
Pcl_short = ˆTcl_short;
Pcl_uchar = ˆTcl_uchar;
Pcl_uint = ˆTcl_uint;
Pcl_ulong = ˆTcl_ulong;
Pcl_ushort = ˆTcl_ushort;
Pintptr_t = ˆintptr_t;
Psize_t = ˆTsize_t;
Tcl_char = ShortInt;
Tcl_char16 = array [0 .. 15] of Tcl_char;
Tcl_char2 = array [0 .. 1] of Tcl_char;
Tcl_char4 = array [0 .. 3] of Tcl_char;
Tcl_char8 = array [0 .. 7] of Tcl_char;
Tcl_double = Double;
Tcl_double16 = array [0 .. 15] of Tcl_double;
Tcl_double2 = array [0 .. 1] of Tcl_double;
Tcl_double4 = array [0 .. 3] of Tcl_double;
Tcl_double8 = array [0 .. 7] of Tcl_double;
Tcl_float = Single;
Tcl_float16 = array [0 .. 15] of Tcl_float;
Tcl_float2 = array [0 .. 1] of Tcl_float;
Tcl_float4 = array [0 .. 3] of Tcl_float;
Tcl_float8 = array [0 .. 7] of Tcl_float;
Tcl_half = Word;
Tcl_int = LongInt;
Tcl_int16 = array [0 .. 15] of Tcl_int;
Tcl_int2 = array [0 .. 1] of Tcl_int;
Tcl_int4 = array [0 .. 3] of Tcl_int;
Tcl_int8 = array [0 .. 7] of Tcl_int;
Tcl_long = Int64;
Tcl_long16 = array [0 .. 15] of Tcl_long;
Tcl_long2 = array [0 .. 1] of Tcl_long;
Tcl_long4 = array [0 .. 3] of Tcl_long;
Tcl_long8 = array [0 .. 7] of Tcl_long;
Tcl_short = SmallInt;
Tcl_short16 = array [0 .. 15] of Tcl_short;
Tcl_short2 = array [0 .. 1] of Tcl_short;
Tcl_short4 = array [0 .. 3] of Tcl_short;
Tcl_short8 = array [0 .. 7] of Tcl_short;
Tcl_uchar = Byte;
Tcl_uchar16 = array [0 .. 15] of Tcl_uchar;
Tcl_uchar2 = array [0 .. 1] of Tcl_uchar;
Tcl_uchar4 = array [0 .. 3] of Tcl_uchar;
Tcl_uchar8 = array [0 .. 7] of Tcl_uchar;
Tcl_uint = LongWord;
Tcl_uint16 = array [0 .. 15] of Tcl_uint;
Tcl_uint2 = array [0 .. 1] of Tcl_uint;
Tcl_uint4 = array [0 .. 3] of Tcl_uint;
Tcl_uint8 = array [0 .. 7] of Tcl_uint;
Tcl_ulong = UInt64;
Tcl_ulong16 = array [0 .. 15] of Tcl_ulong;
Tcl_ulong2 = array [0 .. 1] of Tcl_ulong;
Tcl_ulong4 = array [0 .. 3] of Tcl_ulong;
Tcl_ulong8 = array [0 .. 7] of Tcl_ulong;
Tcl_ushort = Word;
Tcl_ushort16 = array [0 .. 15] of Tcl_ushort;
Tcl_ushort2 = array [0 .. 1] of Tcl_ushort;
Tcl_ushort4 = array [0 .. 3] of Tcl_ushort;
Tcl_ushort8 = array [0 .. 7] of Tcl_ushort;
Tsize_t = NativeUInt;

Constants

CL_APT_CALL = 'stdcall';
CL_CALLBACK = 'stdcall';
CL_CHAR_BIT = 8;
CL_SCHAR_MAX = 127;
CL_SCHAR_MIN = (-127 - 1);
CL_CHAR_MAX = CL_SCHAR_MAX;
CL_CHAR_MIN = CL_SCHAR_MIN;
CL_UCHAR_MAX = 255;
CL_SHRT_MAX = 32767;
CL_SHRT_MIN = (-32767 - 1);
CL_USHRT_MAX = 65535;
CL_INT_MAX = 2147483647;
CL_INT_MIN = (-2147483647 - 1);
CL_UINT_MAX = $FFFFFFFF;
CL_LONG_MAX = $7FFFFFFFFFFFFFFF;
CL_LONG_MIN = -$7FFFFFFFFFFFFFFF - 1;
CL_ULONG_MAX = $FFFFFFFFFFFFFFFF;
CL_FLT_DIG = 6;
CL_FLT_MANT_DIG = 24;
CL_FLT_MAX_10_EXP = +38;
CL_FLT_MAX_EXP = +128;
CL_FLT_MIN_10_EXP = -37;
CL_FLT_MIN_EXP = -125;
CL_FLT_RADIX = 2;
CL_FLT_MAX = 1.7E38;
CL_FLT_MIN = 1.17E-38;
CL_FLT_EPSILON = 1.0E-7;
CL_DBL_DIG = 15;
CL_DBL_MANT_DIG = 53;
CL_DBL_MAX_10_EXP = +308;
CL_DBL_MAX_EXP = +1024;
CL_DBL_MIN_10_EXP = -307;
CL_DBL_MIN_EXP = -1021;
CL_DBL_RADIX = 2;
CL_DBL_MAX = 8.98E307;
CL_DBL_MIN = 2.2E-308;
CL_DBL_EPSILON = 2.2E-16;
CL_M_E = 2.718281828459045090796;
CL_M_LOG2E = 1.442695040888963387005;
CL_M_LOG10E = 0.434294481903251816668;
CL_M_LN2 = 0.693147180559945286227;
CL_M_LN10 = 2.302585092994045901094;
CL_M_PI = 3.141592653589793115998;
CL_M_PI_2 = 1.570796326794896557999;
CL_M_PI_4 = 0.785398163397448278999;
CL_M_1_PI = 0.318309886183790691216;
CL_M_2_PI = 0.636619772367581382433;
CL_M_2_SQRTPI = 1.128379167095512558561;
CL_M_SQRT2 = 1.414213562373095145475;
CL_M_SQRT1_2 = 0.707106781186547572737;
CL_M_E_F = 2.71828174591064;
CL_M_LOG2E_F = 1.44269502162933;
CL_M_LOG10E_F = 0.43429449200630;
CL_M_LN2_F = 0.69314718246460;
CL_M_LN10_F = 2.30258512496948;
CL_M_PI_F = 3.14159274101257;
CL_M_PI_2_F = 1.57079637050629;
CL_M_PI_4_F = 0.78539818525314;
CL_M_1_PI_F = 0.31830987334251;
CL_M_2_PI_F = 0.63661974668503;
CL_M_2_SQRTPI_F = 1.12837922573090;
CL_M_SQRT2_F = 1.41421353816986;
CL_M_SQRT1_2_F = 0.70710676908493;
CL_NAN = 0;
CL_HUGE_VALF = 1.0E50;
CL_HUGE_VAL = 1.0E500;
CL_MAXFLOAT = CL_FLT_MAX;
CL_INFINITY = CL_HUGE_VALF;

Description

Types

intptr_t = NativeUInt;

This item has no description.

Pcl_char = ˆTcl_char;

This item has no description.

Pcl_double = ˆTcl_double;

This item has no description.

Pcl_float = ˆTcl_float;

This item has no description.

Pcl_half = ˆTcl_half;

This item has no description.

Pcl_int = ˆTcl_int;

This item has no description.

Pcl_long = ˆTcl_long;

This item has no description.

Pcl_short = ˆTcl_short;

This item has no description.

Pcl_uchar = ˆTcl_uchar;

This item has no description.

Pcl_uint = ˆTcl_uint;

This item has no description.

Pcl_ulong = ˆTcl_ulong;

This item has no description.

Pcl_ushort = ˆTcl_ushort;

This item has no description.

Pintptr_t = ˆintptr_t;

This item has no description.

Psize_t = ˆTsize_t;

This item has no description.

Tcl_char = ShortInt;

scalar types

Tcl_char16 = array [0 .. 15] of Tcl_char;

This item has no description.

Tcl_char2 = array [0 .. 1] of Tcl_char;

* Vector types * * Note: OpenCL requires that all types be naturally aligned. * This means that vector types must be naturally aligned. * For example, a vector of four floats must be aligned to * a 16 byte boundary (calculated as 4 * the natural 4-byte * alignment of the float). The alignment qualifiers here * will only function properly if your compiler supports them * and if you don't actively work to defeat them. For example, * in order for a cl_float4 to be 16 byte aligned in a struct, * the start of the struct must itself be 16-byte aligned. * * Maintaining proper alignment is the user's responsibility.

Tcl_char4 = array [0 .. 3] of Tcl_char;

This item has no description.

Tcl_char8 = array [0 .. 7] of Tcl_char;

This item has no description.

Tcl_double = Double;

This item has no description.

Tcl_double16 = array [0 .. 15] of Tcl_double;

This item has no description.

Tcl_double2 = array [0 .. 1] of Tcl_double;

This item has no description.

Tcl_double4 = array [0 .. 3] of Tcl_double;

This item has no description.

Tcl_double8 = array [0 .. 7] of Tcl_double;

This item has no description.

Tcl_float = Single;

This item has no description.

Tcl_float16 = array [0 .. 15] of Tcl_float;

This item has no description.

Tcl_float2 = array [0 .. 1] of Tcl_float;

This item has no description.

Tcl_float4 = array [0 .. 3] of Tcl_float;

This item has no description.

Tcl_float8 = array [0 .. 7] of Tcl_float;

This item has no description.

Tcl_half = Word;

This item has no description.

Tcl_int = LongInt;

This item has no description.

Tcl_int16 = array [0 .. 15] of Tcl_int;

This item has no description.

Tcl_int2 = array [0 .. 1] of Tcl_int;

This item has no description.

Tcl_int4 = array [0 .. 3] of Tcl_int;

This item has no description.

Tcl_int8 = array [0 .. 7] of Tcl_int;

This item has no description.

Tcl_long = Int64;

This item has no description.

Tcl_long16 = array [0 .. 15] of Tcl_long;

This item has no description.

Tcl_long2 = array [0 .. 1] of Tcl_long;

This item has no description.

Tcl_long4 = array [0 .. 3] of Tcl_long;

This item has no description.

Tcl_long8 = array [0 .. 7] of Tcl_long;

This item has no description.

Tcl_short = SmallInt;

This item has no description.

Tcl_short16 = array [0 .. 15] of Tcl_short;

This item has no description.

Tcl_short2 = array [0 .. 1] of Tcl_short;

This item has no description.

Tcl_short4 = array [0 .. 3] of Tcl_short;

This item has no description.

Tcl_short8 = array [0 .. 7] of Tcl_short;

This item has no description.

Tcl_uchar = Byte;

This item has no description.

Tcl_uchar16 = array [0 .. 15] of Tcl_uchar;

This item has no description.

Tcl_uchar2 = array [0 .. 1] of Tcl_uchar;

This item has no description.

Tcl_uchar4 = array [0 .. 3] of Tcl_uchar;

This item has no description.

Tcl_uchar8 = array [0 .. 7] of Tcl_uchar;

This item has no description.

Tcl_uint = LongWord;

This item has no description.

Tcl_uint16 = array [0 .. 15] of Tcl_uint;

This item has no description.

Tcl_uint2 = array [0 .. 1] of Tcl_uint;

This item has no description.

Tcl_uint4 = array [0 .. 3] of Tcl_uint;

This item has no description.

Tcl_uint8 = array [0 .. 7] of Tcl_uint;

This item has no description.

Tcl_ulong = UInt64;

This item has no description.

Tcl_ulong16 = array [0 .. 15] of Tcl_ulong;

This item has no description.

Tcl_ulong2 = array [0 .. 1] of Tcl_ulong;

This item has no description.

Tcl_ulong4 = array [0 .. 3] of Tcl_ulong;

This item has no description.

Tcl_ulong8 = array [0 .. 7] of Tcl_ulong;

This item has no description.

Tcl_ushort = Word;

This item has no description.

Tcl_ushort16 = array [0 .. 15] of Tcl_ushort;

This item has no description.

Tcl_ushort2 = array [0 .. 1] of Tcl_ushort;

This item has no description.

Tcl_ushort4 = array [0 .. 3] of Tcl_ushort;

This item has no description.

Tcl_ushort8 = array [0 .. 7] of Tcl_ushort;

This item has no description.

Tsize_t = NativeUInt;

This item has no description.

Constants

CL_APT_CALL = 'stdcall';

*************************************************************************** * Copyright (c) 2008-2023 The Khronos Group Inc. * * Permission is hereby granted, free of charge, to any person obtaining a * copy of this software and/or associated documentation files (the * "Materials"), to deal in the Materials without restriction, including * without limitation the rights to use, copy, modify, merge, publish, * distribute, sublicense, and/or sell copies of the Materials, and to * permit persons to whom the Materials are furnished to do so, subject to * the following conditions: * * The above copyright notice and this permission notice shall be included * in all copies or substantial portions of the Materials. * * MODIFICATIONS TO THIS FILE MAY MEAN IT NO LONGER ACCURATELY REFLECTS * KHRONOS STANDARDS. THE UNMODIFIED, NORMATIVE VERSIONS OF KHRONOS * SPECIFICATIONS AND HEADER INFORMATION ARE LOCATED AT * https://www.khronos.org/registry/ * * THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE * MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS. *************************************************************************

CL_CALLBACK = 'stdcall';

This item has no description.

CL_CHAR_BIT = 8;

Macro names and corresponding values defined by OpenCL

CL_SCHAR_MAX = 127;

This item has no description.

CL_SCHAR_MIN = (-127 - 1);

This item has no description.

CL_CHAR_MAX = CL_SCHAR_MAX;

This item has no description.

CL_CHAR_MIN = CL_SCHAR_MIN;

This item has no description.

CL_UCHAR_MAX = 255;

This item has no description.

CL_SHRT_MAX = 32767;

This item has no description.

CL_SHRT_MIN = (-32767 - 1);

This item has no description.

CL_USHRT_MAX = 65535;

This item has no description.

CL_INT_MAX = 2147483647;

This item has no description.

CL_INT_MIN = (-2147483647 - 1);

This item has no description.

CL_UINT_MAX = $FFFFFFFF;

This item has no description.

CL_LONG_MAX = $7FFFFFFFFFFFFFFF;

This item has no description.

CL_LONG_MIN = -$7FFFFFFFFFFFFFFF - 1;

This item has no description.

CL_ULONG_MAX = $FFFFFFFFFFFFFFFF;

This item has no description.

CL_FLT_DIG = 6;

This item has no description.

CL_FLT_MANT_DIG = 24;

This item has no description.

CL_FLT_MAX_10_EXP = +38;

This item has no description.

CL_FLT_MAX_EXP = +128;

This item has no description.

CL_FLT_MIN_10_EXP = -37;

This item has no description.

CL_FLT_MIN_EXP = -125;

This item has no description.

CL_FLT_RADIX = 2;

This item has no description.

CL_FLT_MAX = 1.7E38;

This item has no description.

CL_FLT_MIN = 1.17E-38;

0x1.fffffep127f;

CL_FLT_EPSILON = 1.0E-7;

0x1.0p-126f;

CL_DBL_DIG = 15;

0x1.0p-23f;

CL_DBL_MANT_DIG = 53;

This item has no description.

CL_DBL_MAX_10_EXP = +308;

This item has no description.

CL_DBL_MAX_EXP = +1024;

This item has no description.

CL_DBL_MIN_10_EXP = -307;

This item has no description.

CL_DBL_MIN_EXP = -1021;

This item has no description.

CL_DBL_RADIX = 2;

This item has no description.

CL_DBL_MAX = 8.98E307;

This item has no description.

CL_DBL_MIN = 2.2E-308;

0x1.fffffffffffffp1023;

CL_DBL_EPSILON = 2.2E-16;

0x1.0p-1022;

CL_M_E = 2.718281828459045090796;

0x1.0p-52;

CL_M_LOG2E = 1.442695040888963387005;

This item has no description.

CL_M_LOG10E = 0.434294481903251816668;

This item has no description.

CL_M_LN2 = 0.693147180559945286227;

This item has no description.

CL_M_LN10 = 2.302585092994045901094;

This item has no description.

CL_M_PI = 3.141592653589793115998;

This item has no description.

CL_M_PI_2 = 1.570796326794896557999;

This item has no description.

CL_M_PI_4 = 0.785398163397448278999;

This item has no description.

CL_M_1_PI = 0.318309886183790691216;

This item has no description.

CL_M_2_PI = 0.636619772367581382433;

This item has no description.

CL_M_2_SQRTPI = 1.128379167095512558561;

This item has no description.

CL_M_SQRT2 = 1.414213562373095145475;

This item has no description.

CL_M_SQRT1_2 = 0.707106781186547572737;

This item has no description.

CL_M_E_F = 2.71828174591064;

This item has no description.

CL_M_LOG2E_F = 1.44269502162933;

This item has no description.

CL_M_LOG10E_F = 0.43429449200630;

This item has no description.

CL_M_LN2_F = 0.69314718246460;

This item has no description.

CL_M_LN10_F = 2.30258512496948;

This item has no description.

CL_M_PI_F = 3.14159274101257;

This item has no description.

CL_M_PI_2_F = 1.57079637050629;

This item has no description.

CL_M_PI_4_F = 0.78539818525314;

This item has no description.

CL_M_1_PI_F = 0.31830987334251;

This item has no description.

CL_M_2_PI_F = 0.63661974668503;

This item has no description.

CL_M_2_SQRTPI_F = 1.12837922573090;

This item has no description.

CL_M_SQRT2_F = 1.41421353816986;

This item has no description.

CL_M_SQRT1_2_F = 0.70710676908493;

This item has no description.

CL_NAN = 0;

This item has no description.

CL_HUGE_VALF = 1.0E50;

(CL_INFINITY - CL_INFINITY);

CL_HUGE_VAL = 1.0E500;

This item has no description.

CL_MAXFLOAT = CL_FLT_MAX;

This item has no description.

CL_INFINITY = CL_HUGE_VALF;


GLSysHelp v.2.5: PasDblStrUtils

Unit PasDblStrUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

***************************************************************************** * PasDblStrUtils * ****************************************************************************** * Version 2021-06-21-01-13-0000 * ****************************************************************************** * zlib license * *============================================================================* * * * Copyright (C) 2016-2021, Benjamin Rosseaux (benjamin@rosseaux.de) * * * * This software is provided 'as-is', without any express or implied * * warranty. In no event will the authors be held liable for any damages * * arising from the use of this software. * * * * Permission is granted to anyone to use this software for any purpose, * * including commercial applications, and to alter it and redistribute it * * freely, subject to the following restrictions: * * * * 1. The origin of this software must not be misrepresented; you must not * * claim that you wrote the original software. If you use this software * * in a product, an acknowledgement in the product documentation would be * * appreciated but is not required. * * 2. Altered source versions must be plainly marked as such, and must not be * * misrepresented as being the original software. * * 3. This notice may not be removed or altered from any source distribution. * * * ****************************************************************************** * General guidelines for code contributors * *============================================================================* * * * 1. Make sure you are legally allowed to make a contribution under the zlib * * license. * * 2. The zlib license header goes at the top of each source file, with * * appropriate copyright notice. * * 3. After a pull request, check the status of your pull request on * http://github.com/BeRo1985/pasdblstrutils * * 4. Write code, which is compatible with Delphi >=XE7 and FreePascal * * >= 3.0 * * 5. Don't use Delphi-only, FreePascal-only or Lazarus-only libraries/units, * * but if needed, make it out-ifdef-able. * * 6. No use of third-party libraries/units as possible, but if needed, make * * it out-ifdef-able. * * 7. Try to use const when possible. * * 8. Make sure to comment out writeln, used while debugging. * * 9. Make sure the code compiles on 32-bit and 64-bit platforms (x86-32, * * x86-64, ARM, ARM64, etc.). * * 10. Make sure the code runs on platforms with weak and strong memory * * models without any issues. * * * *****************************************************************************

Uses

  • System.SysUtils
  • System.Math

Overview

Functions and Procedures

function FallbackStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aRoundingMode: TPasDblStrUtilsRoundingMode = rmNearest; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;
function FallbackStringToDouble(const aStringValue: TPasDblStrUtilsString; const aRoundingMode: TPasDblStrUtilsRoundingMode = rmNearest; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;
function AlgorithmMStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;
function AlgorithmMStringToDouble(const aStringValue: TPasDblStrUtilsString; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;
function EiselLemireStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aOK: PPasDblStrUtilsBoolean = nil): TPasDblStrUtilsDouble; overload;
function EiselLemireStringToDouble(const aStringValue: TPasDblStrUtilsString; const aOK: PPasDblStrUtilsBoolean = nil): TPasDblStrUtilsDouble; overload;
function RyuStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aOK: PPasDblStrUtilsBoolean = nil; const aCountDigits: PPasDblStrUtilsInt32 = nil) : TPasDblStrUtilsDouble; overload;
function RyuStringToDouble(const aStringValue: TPasDblStrUtilsString; const aOK: PPasDblStrUtilsBoolean = nil; const aCountDigits: PPasDblStrUtilsInt32 = nil) : TPasDblStrUtilsDouble; overload;
function RyuDoubleToString(const aValue: TPasDblStrUtilsDouble; const aExponential: Boolean = true): TPasDblStrUtilsString;
function ConvertStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aRoundingMode: TPasDblStrUtilsRoundingMode = rmNearest; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;
function ConvertStringToDouble(const aStringValue: TPasDblStrUtilsString; const aRoundingMode: TPasDblStrUtilsRoundingMode = rmNearest; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;
function ConvertDoubleToString(const aValue: TPasDblStrUtilsDouble; const aOutputMode: TPasDblStrUtilsOutputMode = omStandard; aRequestedDigits: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsString;

Types

PPasDblStrUtilsBoolean = ˆTPasDblStrUtilsBoolean;
PPasDblStrUtilsChar = PAnsiChar;
PPasDblStrUtilsDouble = ˆTPasDblStrUtilsDouble;
PPasDblStrUtilsInt16 = ˆTPasDblStrUtilsInt16;
PPasDblStrUtilsInt32 = ˆTPasDblStrUtilsInt32;
PPasDblStrUtilsInt64 = ˆTPasDblStrUtilsInt64;
PPasDblStrUtilsInt8 = ˆTPasDblStrUtilsInt8;
PPasDblStrUtilsNativeInt = ˆTPasDblStrUtilsNativeInt;
PPasDblStrUtilsNativeUInt = ˆTPasDblStrUtilsNativeUInt;
PPasDblStrUtilsPointer = ˆTPasDblStrUtilsPointer;
PPasDblStrUtilsPtrInt = ˆTPasDblStrUtilsPtrInt;
PPasDblStrUtilsPtrUInt = ˆTPasDblStrUtilsPtrUInt;
PPasDblStrUtilsRawByteChar = PAnsiChar;
PPasDblStrUtilsRawByteCharSet = ˆTPasDblStrUtilsRawByteCharSet;
PPasDblStrUtilsRawByteString = ˆTPasDblStrUtilsRawByteString;
PPasDblStrUtilsRoundingMode = ˆTPasDblStrUtilsRoundingMode;
PPasDblStrUtilsString = ˆTPasDblStrUtilsString;
PPasDblStrUtilsUInt16 = ˆTPasDblStrUtilsUInt16;
PPasDblStrUtilsUInt32 = ˆTPasDblStrUtilsUInt32;
PPasDblStrUtilsUInt64 = ˆTPasDblStrUtilsUInt64;
PPasDblStrUtilsUInt8 = ˆTPasDblStrUtilsUInt8;
PPasDblStrUtilsUTF16Char = PWideChar;
PPasDblStrUtilsUTF16String = ˆTPasDblStrUtilsUTF16String;
PPasDblStrUtilsUTF8Char = PAnsiChar;
PPasDblStrUtilsUTF8String = ˆTPasDblStrUtilsUTF8String;
TPasDblStrUtilsBoolean = Boolean;
TPasDblStrUtilsChar = AnsiChar;
TPasDblStrUtilsDouble = Double;
TPasDblStrUtilsInt16 = SmallInt;
TPasDblStrUtilsInt32 = LongInt;
TPasDblStrUtilsInt64 = Int64;
TPasDblStrUtilsInt8 = ShortInt;
TPasDblStrUtilsNativeInt = TPasDblStrUtilsPtrInt;
TPasDblStrUtilsNativeUInt = TPasDblStrUtilsPtrUInt;
TPasDblStrUtilsOutputMode = (...);
TPasDblStrUtilsPointer = Pointer;
TPasDblStrUtilsPtrInt = NativeInt;
TPasDblStrUtilsPtrUInt = NativeUInt;
TPasDblStrUtilsRawByteChar = AnsiChar;
TPasDblStrUtilsRawByteCharSet = set of TPasDblStrUtilsRawByteChar;
TPasDblStrUtilsRawByteString = AnsiString;
TPasDblStrUtilsRoundingMode = type TFPURoundingMode;
TPasDblStrUtilsString = AnsiString;
TPasDblStrUtilsUInt16 = Word;
TPasDblStrUtilsUInt32 = LongWord;
TPasDblStrUtilsUInt64 = UInt64;
TPasDblStrUtilsUInt8 = Byte;
TPasDblStrUtilsUTF16Char = WideChar;
TPasDblStrUtilsUTF16String = WideString;
TPasDblStrUtilsUTF8Char = AnsiChar;
TPasDblStrUtilsUTF8String = AnsiString;

Description

Functions and Procedures

function FallbackStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aRoundingMode: TPasDblStrUtilsRoundingMode = rmNearest; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;

This item has no description.

function FallbackStringToDouble(const aStringValue: TPasDblStrUtilsString; const aRoundingMode: TPasDblStrUtilsRoundingMode = rmNearest; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;

This item has no description.

function AlgorithmMStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;

This item has no description.

function AlgorithmMStringToDouble(const aStringValue: TPasDblStrUtilsString; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;

This item has no description.

function EiselLemireStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aOK: PPasDblStrUtilsBoolean = nil): TPasDblStrUtilsDouble; overload;

This item has no description.

function EiselLemireStringToDouble(const aStringValue: TPasDblStrUtilsString; const aOK: PPasDblStrUtilsBoolean = nil): TPasDblStrUtilsDouble; overload;

This item has no description.

function RyuStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aOK: PPasDblStrUtilsBoolean = nil; const aCountDigits: PPasDblStrUtilsInt32 = nil) : TPasDblStrUtilsDouble; overload;

This item has no description.

function RyuStringToDouble(const aStringValue: TPasDblStrUtilsString; const aOK: PPasDblStrUtilsBoolean = nil; const aCountDigits: PPasDblStrUtilsInt32 = nil) : TPasDblStrUtilsDouble; overload;

This item has no description.

function RyuDoubleToString(const aValue: TPasDblStrUtilsDouble; const aExponential: Boolean = true): TPasDblStrUtilsString;

This item has no description.

function ConvertStringToDouble(const aStringValue: PPasDblStrUtilsChar; const aStringLength: TPasDblStrUtilsInt32; const aRoundingMode: TPasDblStrUtilsRoundingMode = rmNearest; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;

This item has no description.

function ConvertStringToDouble(const aStringValue: TPasDblStrUtilsString; const aRoundingMode: TPasDblStrUtilsRoundingMode = rmNearest; const aOK: PPasDblStrUtilsBoolean = nil; const aBase: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsDouble; overload;

This item has no description.

function ConvertDoubleToString(const aValue: TPasDblStrUtilsDouble; const aOutputMode: TPasDblStrUtilsOutputMode = omStandard; aRequestedDigits: TPasDblStrUtilsInt32 = -1): TPasDblStrUtilsString;

This item has no description.

Types

PPasDblStrUtilsBoolean = ˆTPasDblStrUtilsBoolean;

This item has no description.

PPasDblStrUtilsChar = PAnsiChar;

This item has no description.

PPasDblStrUtilsDouble = ˆTPasDblStrUtilsDouble;

This item has no description.

PPasDblStrUtilsInt16 = ˆTPasDblStrUtilsInt16;

This item has no description.

PPasDblStrUtilsInt32 = ˆTPasDblStrUtilsInt32;

This item has no description.

PPasDblStrUtilsInt64 = ˆTPasDblStrUtilsInt64;

This item has no description.

PPasDblStrUtilsInt8 = ˆTPasDblStrUtilsInt8;

This item has no description.

PPasDblStrUtilsNativeInt = ˆTPasDblStrUtilsNativeInt;

This item has no description.

PPasDblStrUtilsNativeUInt = ˆTPasDblStrUtilsNativeUInt;

This item has no description.

PPasDblStrUtilsPointer = ˆTPasDblStrUtilsPointer;

This item has no description.

PPasDblStrUtilsPtrInt = ˆTPasDblStrUtilsPtrInt;

This item has no description.

PPasDblStrUtilsPtrUInt = ˆTPasDblStrUtilsPtrUInt;

This item has no description.

PPasDblStrUtilsRawByteChar = PAnsiChar;

This item has no description.

PPasDblStrUtilsRawByteCharSet = ˆTPasDblStrUtilsRawByteCharSet;

This item has no description.

PPasDblStrUtilsRawByteString = ˆTPasDblStrUtilsRawByteString;

This item has no description.

PPasDblStrUtilsRoundingMode = ˆTPasDblStrUtilsRoundingMode;

This item has no description.

PPasDblStrUtilsString = ˆTPasDblStrUtilsString;

This item has no description.

PPasDblStrUtilsUInt16 = ˆTPasDblStrUtilsUInt16;

This item has no description.

PPasDblStrUtilsUInt32 = ˆTPasDblStrUtilsUInt32;

This item has no description.

PPasDblStrUtilsUInt64 = ˆTPasDblStrUtilsUInt64;

This item has no description.

PPasDblStrUtilsUInt8 = ˆTPasDblStrUtilsUInt8;

This item has no description.

PPasDblStrUtilsUTF16Char = PWideChar;

This item has no description.

PPasDblStrUtilsUTF16String = ˆTPasDblStrUtilsUTF16String;

This item has no description.

PPasDblStrUtilsUTF8Char = PAnsiChar;

This item has no description.

PPasDblStrUtilsUTF8String = ˆTPasDblStrUtilsUTF8String;

This item has no description.

TPasDblStrUtilsBoolean = Boolean;

This item has no description.

TPasDblStrUtilsChar = AnsiChar;

This item has no description.

TPasDblStrUtilsDouble = Double;

This item has no description.

TPasDblStrUtilsInt16 = SmallInt;

This item has no description.

TPasDblStrUtilsInt32 = LongInt;

This item has no description.

TPasDblStrUtilsInt64 = Int64;

This item has no description.

TPasDblStrUtilsInt8 = ShortInt;

This item has no description.

TPasDblStrUtilsNativeInt = TPasDblStrUtilsPtrInt;

This item has no description.

TPasDblStrUtilsNativeUInt = TPasDblStrUtilsPtrUInt;

This item has no description.

TPasDblStrUtilsOutputMode = (...);

This item has no description.

Values
  • omStandard
  • omStandardExponential
  • omFixed
  • omExponential
  • omPrecision
  • omRadix
TPasDblStrUtilsPointer = Pointer;

This item has no description.

TPasDblStrUtilsPtrInt = NativeInt;

This item has no description.

TPasDblStrUtilsPtrUInt = NativeUInt;

This item has no description.

TPasDblStrUtilsRawByteChar = AnsiChar;

This item has no description.

TPasDblStrUtilsRawByteCharSet = set of TPasDblStrUtilsRawByteChar;

This item has no description.

TPasDblStrUtilsRawByteString = AnsiString;

This item has no description.

TPasDblStrUtilsRoundingMode = type TFPURoundingMode;

This item has no description.

TPasDblStrUtilsString = AnsiString;

This item has no description.

TPasDblStrUtilsUInt16 = Word;

This item has no description.

TPasDblStrUtilsUInt32 = LongWord;

This item has no description.

TPasDblStrUtilsUInt64 = UInt64;

This item has no description.

TPasDblStrUtilsUInt8 = Byte;

This item has no description.

TPasDblStrUtilsUTF16Char = WideChar;

This item has no description.

TPasDblStrUtilsUTF16String = WideString;

This item has no description.

TPasDblStrUtilsUTF8Char = AnsiChar;

This item has no description.

TPasDblStrUtilsUTF8String = AnsiString;


GLSysHelp v.2.5: PasJSON

Unit PasJSON

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

***************************************************************************** * PasJSON * ****************************************************************************** * Version 2020-03-04-02-20 * ****************************************************************************** * zlib license * *============================================================================* * * * Copyright (C) 2016-2020, Benjamin Rosseaux (benjamin@rosseaux.de) * * * * This software is provided 'as-is', without any express or implied * * warranty. In no event will the authors be held liable for any damages * * arising from the use of this software. * * * * Permission is granted to anyone to use this software for any purpose, * * including commercial applications, and to alter it and redistribute it * * freely, subject to the following restrictions: * * * * 1. The origin of this software must not be misrepresented; you must not * * claim that you wrote the original software. If you use this software * * in a product, an acknowledgement in the product documentation would be * * appreciated but is not required. * * 2. Altered source versions must be plainly marked as such, and must not be * * misrepresented as being the original software. * * 3. This notice may not be removed or altered from any source distribution. * * * ****************************************************************************** * General guidelines for code contributors * *============================================================================* * * * 1. Make sure you are legally allowed to make a contribution under the zlib * * license. * * 2. The zlib license header goes at the top of each source file, with * * appropriate copyright notice. * * 3. After a pull request, check the status of your pull request on * * http://github.com/BeRo1985/pasjson * * 4. Write code which's compatible with newer modern Delphi versions and * * FreePascal >= 3.0.0 * * 5. Don't use Delphi-only, FreePascal-only or Lazarus-only libraries/units, * * but if needed, make it out-ifdef-able. * * 6. No use of third-party libraries/units as possible, but if needed, make * * it out-ifdef-able. * * 7. Try to use const when possible. * * 8. Make sure to comment out writeln, used while debugging. * * 9. Make sure the code compiles on 32-bit and 64-bit platforms (x86-32, * * x86-64, ARM, ARM64, etc.). * * * *****************************************************************************

Uses

  • System.SysUtils
  • System.Classes
  • System.Math

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EPasJSONSyntaxError |
Class EPasJSONMergeError |
Class TPasJSONItem |
Class TPasJSONItemNull |
Class TPasJSONItemBoolean |
Class TPasJSONItemNumber |
Class TPasJSONItemString |
Class TPasJSONItemObjectProperty |
Class TPasJSONItemObject |
Class TPasJSONItemArray |
Class TPasJSON |

Types

PPasJSONChar = PAnsiChar;
PPasJSONDouble = ˆTPasJSONDouble;
PPasJSONEncoding = ˆTPasJSONEncoding;
PPasJSONFloat = ˆTPasJSONFloat;
PPasJSONInt16 = ˆTPasJSONInt16;
PPasJSONInt32 = ˆTPasJSONInt32;
PPasJSONInt64 = ˆTPasJSONInt64;
PPasJSONInt8 = ˆTPasJSONInt8;
PPasJSONModeFlag = ˆTPasJSONModeFlag;
PPasJSONModeFlags = ˆTPasJSONModeFlag;
PPasJSONNativeInt = ˆTPasJSONNativeInt;
PPasJSONNativeUInt = ˆTPasJSONNativeUInt;
PPasJSONPointer = ˆTPasJSONPointer;
PPasJSONPointers = ˆTPasJSONPointers;
PPasJSONPtrDiff = ˆTPasJSONPtrDiff;
PPasJSONPtrInt = ˆTPasJSONPtrInt;
PPasJSONPtrUInt = ˆTPasJSONPtrUInt;
PPasJSONRawByteChar = PAnsiChar;
PPasJSONRawByteString = ˆTPasJSONRawByteString;
PPasJSONSize = ˆTPasJSONSizeUInt;
PPasJSONSizeInt = ˆTPasJSONSizeInt;
PPasJSONSizeUInt = ˆTPasJSONSizeUInt;
PPasJSONUInt16 = ˆTPasJSONUInt16;
PPasJSONUInt32 = ˆTPasJSONUInt32;
PPasJSONUInt64 = ˆTPasJSONUInt64;
PPasJSONUInt8 = ˆTPasJSONUInt8;
PPasJSONUInt8Array = ˆTPasJSONUInt8Array;
PPasJSONUTF16Char = PWideChar;
PPasJSONUTF16String = ˆTPasJSONUTF16String;
PPasJSONUTF8String = ˆTPasJSONUTF8String;
PPasJSONVoid = TPasJSONPointer;
PPPasJSONChar = ˆPAnsiChar;
PPPasJSONDouble = ˆPPasJSONDouble;
PPPasJSONFloat = ˆPPasJSONFloat;
PPPasJSONInt16 = ˆPPasJSONInt16;
PPPasJSONInt32 = ˆPPasJSONInt32;
PPPasJSONInt64 = ˆPPasJSONInt64;
PPPasJSONInt8 = ˆPPasJSONInt8;
PPPasJSONNativeInt = ˆPPasJSONNativeInt;
PPPasJSONNativeUInt = ˆPPasJSONNativeUInt;
PPPasJSONPointer = ˆPPasJSONPointer;
PPPasJSONPointers = ˆPPasJSONPointers;
PPPasJSONPtrDiff = ˆPPasJSONPtrDiff;
PPPasJSONPtrInt = ˆPPasJSONPtrInt;
PPPasJSONPtrUInt = ˆPPasJSONPtrUInt;
PPPasJSONRawByteChar = ˆPAnsiChar;
PPPasJSONRawByteString = ˆPPasJSONRawByteString;
PPPasJSONSize = ˆPPasJSONSizeUInt;
PPPasJSONSizeInt = ˆPPasJSONSizeInt;
PPPasJSONSizeUInt = ˆPPasJSONSizeUInt;
PPPasJSONUInt16 = ˆPPasJSONUInt16;
PPPasJSONUInt32 = ˆPPasJSONUInt32;
PPPasJSONUInt64 = ˆPPasJSONUInt64;
PPPasJSONUInt8 = ˆPPasJSONUInt8;
PPPasJSONUInt8Array = ˆPPasJSONUInt8Array;
PPPasJSONUTF16Char = ˆPWideChar;
PPPasJSONUTF16String = ˆPPasJSONUTF16String;
PPPasJSONUTF8String = ˆPPasJSONUTF8String;
PPPasJSONVoid = ˆPPasJSONVoid;
TPasJSONChar = AnsiChar;
TPasJSONDouble = Double;
TPasJSONEncoding = (...);
TPasJSONFloat = Single;
TPasJSONFloats = array of TPasJSONFloat;
TPasJSONInt16 = smallint;
TPasJSONInt32 = longint;
TPasJSONInt64 = Int64;
TPasJSONInt8 = shortint;
TPasJSONItemObjectProperties = array of TPasJSONItemObjectProperty;
TPasJSONItems = array of TPasJSONItem;
TPasJSONMergeFlag = (...);
TPasJSONMergeFlags = set of TPasJSONMergeFlag;
TPasJSONModeFlag = (...);
TPasJSONModeFlags = set of TPasJSONModeFlag;
TPasJSONNativeInt = TPasJSONPtrInt;
TPasJSONNativeUInt = TPasJSONPtrUInt;
TPasJSONPointer = Pointer;
TPasJSONPointers = array [0 .. 65535] of TPasJSONPointer;
TPasJSONPtrDiff = TPasJSONPtrInt;
TPasJSONPtrInt = longint;
TPasJSONPtrUInt = longword;
TPasJSONRawByteChar = AnsiChar;
TPasJSONRawByteString = RawByteString;
TPasJSONSize = TPasJSONPtrUInt;
TPasJSONSizeInt = TPasJSONPtrInt;
TPasJSONSizeUInt = TPasJSONPtrUInt;
TPasJSONUInt16 = word;
TPasJSONUInt32 = longword;
TPasJSONUInt64 = UInt64;
TPasJSONUInt8 = byte;
TPasJSONUInt8Array = array [0 .. 65535] of TPasJSONUInt8;
TPasJSONUTF16Char = WideChar;
TPasJSONUTF16String = UnicodeString;
TPasJSONUTF8String = UTF8String;

Description

Types

PPasJSONChar = PAnsiChar;

This item has no description.

PPasJSONDouble = ˆTPasJSONDouble;

This item has no description.

PPasJSONEncoding = ˆTPasJSONEncoding;

This item has no description.

PPasJSONFloat = ˆTPasJSONFloat;

This item has no description.

PPasJSONInt16 = ˆTPasJSONInt16;

This item has no description.

PPasJSONInt32 = ˆTPasJSONInt32;

This item has no description.

PPasJSONInt64 = ˆTPasJSONInt64;

This item has no description.

PPasJSONInt8 = ˆTPasJSONInt8;

This item has no description.

PPasJSONModeFlag = ˆTPasJSONModeFlag;

This item has no description.

PPasJSONModeFlags = ˆTPasJSONModeFlag;

This item has no description.

PPasJSONNativeInt = ˆTPasJSONNativeInt;

This item has no description.

PPasJSONNativeUInt = ˆTPasJSONNativeUInt;

This item has no description.

PPasJSONPointer = ˆTPasJSONPointer;

This item has no description.

PPasJSONPointers = ˆTPasJSONPointers;

This item has no description.

PPasJSONPtrDiff = ˆTPasJSONPtrDiff;

This item has no description.

PPasJSONPtrInt = ˆTPasJSONPtrInt;

This item has no description.

PPasJSONPtrUInt = ˆTPasJSONPtrUInt;

This item has no description.

PPasJSONRawByteChar = PAnsiChar;

This item has no description.

PPasJSONRawByteString = ˆTPasJSONRawByteString;

This item has no description.

PPasJSONSize = ˆTPasJSONSizeUInt;

This item has no description.

PPasJSONSizeInt = ˆTPasJSONSizeInt;

This item has no description.

PPasJSONSizeUInt = ˆTPasJSONSizeUInt;

This item has no description.

PPasJSONUInt16 = ˆTPasJSONUInt16;

This item has no description.

PPasJSONUInt32 = ˆTPasJSONUInt32;

This item has no description.

PPasJSONUInt64 = ˆTPasJSONUInt64;

This item has no description.

PPasJSONUInt8 = ˆTPasJSONUInt8;

This item has no description.

PPasJSONUInt8Array = ˆTPasJSONUInt8Array;

This item has no description.

PPasJSONUTF16Char = PWideChar;

This item has no description.

PPasJSONUTF16String = ˆTPasJSONUTF16String;

This item has no description.

PPasJSONUTF8String = ˆTPasJSONUTF8String;

This item has no description.

PPasJSONVoid = TPasJSONPointer;

This item has no description.

PPPasJSONChar = ˆPAnsiChar;

This item has no description.

PPPasJSONDouble = ˆPPasJSONDouble;

This item has no description.

PPPasJSONFloat = ˆPPasJSONFloat;

This item has no description.

PPPasJSONInt16 = ˆPPasJSONInt16;

This item has no description.

PPPasJSONInt32 = ˆPPasJSONInt32;

This item has no description.

PPPasJSONInt64 = ˆPPasJSONInt64;

This item has no description.

PPPasJSONInt8 = ˆPPasJSONInt8;

This item has no description.

PPPasJSONNativeInt = ˆPPasJSONNativeInt;

This item has no description.

PPPasJSONNativeUInt = ˆPPasJSONNativeUInt;

This item has no description.

PPPasJSONPointer = ˆPPasJSONPointer;

This item has no description.

PPPasJSONPointers = ˆPPasJSONPointers;

This item has no description.

PPPasJSONPtrDiff = ˆPPasJSONPtrDiff;

This item has no description.

PPPasJSONPtrInt = ˆPPasJSONPtrInt;

This item has no description.

PPPasJSONPtrUInt = ˆPPasJSONPtrUInt;

This item has no description.

PPPasJSONRawByteChar = ˆPAnsiChar;

This item has no description.

PPPasJSONRawByteString = ˆPPasJSONRawByteString;

This item has no description.

PPPasJSONSize = ˆPPasJSONSizeUInt;

This item has no description.

PPPasJSONSizeInt = ˆPPasJSONSizeInt;

This item has no description.

PPPasJSONSizeUInt = ˆPPasJSONSizeUInt;

This item has no description.

PPPasJSONUInt16 = ˆPPasJSONUInt16;

This item has no description.

PPPasJSONUInt32 = ˆPPasJSONUInt32;

This item has no description.

PPPasJSONUInt64 = ˆPPasJSONUInt64;

This item has no description.

PPPasJSONUInt8 = ˆPPasJSONUInt8;

This item has no description.

PPPasJSONUInt8Array = ˆPPasJSONUInt8Array;

This item has no description.

PPPasJSONUTF16Char = ˆPWideChar;

This item has no description.

PPPasJSONUTF16String = ˆPPasJSONUTF16String;

This item has no description.

PPPasJSONUTF8String = ˆPPasJSONUTF8String;

This item has no description.

PPPasJSONVoid = ˆPPasJSONVoid;

This item has no description.

TPasJSONChar = AnsiChar;

This item has no description.

TPasJSONDouble = Double;

This item has no description.

TPasJSONEncoding = (...);

This item has no description.

Values
  • AutomaticDetection
  • Latin1
  • UTF8
  • UTF16LE
  • UTF16BE
  • UTF32LE
  • UTF32BE
TPasJSONFloat = Single;

This item has no description.

TPasJSONFloats = array of TPasJSONFloat;

This item has no description.

TPasJSONInt16 = smallint;

This item has no description.

TPasJSONInt32 = longint;

This item has no description.

TPasJSONInt64 = Int64;

This item has no description.

TPasJSONInt8 = shortint;

This item has no description.

TPasJSONItemObjectProperties = array of TPasJSONItemObjectProperty;

This item has no description.

TPasJSONItems = array of TPasJSONItem;

This item has no description.

TPasJSONMergeFlag = (...);

This item has no description.

Values
  • ForceObjectPropertyValueDestinationType
TPasJSONMergeFlags = set of TPasJSONMergeFlag;

This item has no description.

TPasJSONModeFlag = (...);

This item has no description.

Values
  • UnquotedKeys
  • Comments
  • ImplicitRootObject
  • OptionalCommas
  • EqualsForColon
  • MultilineStrings
  • HexadecimalNumbers
TPasJSONModeFlags = set of TPasJSONModeFlag;

This item has no description.

TPasJSONNativeInt = TPasJSONPtrInt;

This item has no description.

TPasJSONNativeUInt = TPasJSONPtrUInt;

This item has no description.

TPasJSONPointer = Pointer;

This item has no description.

TPasJSONPointers = array [0 .. 65535] of TPasJSONPointer;

This item has no description.

TPasJSONPtrDiff = TPasJSONPtrInt;

This item has no description.

TPasJSONPtrInt = longint;

This item has no description.

TPasJSONPtrUInt = longword;

This item has no description.

TPasJSONRawByteChar = AnsiChar;

This item has no description.

TPasJSONRawByteString = RawByteString;

This item has no description.

TPasJSONSize = TPasJSONPtrUInt;

This item has no description.

TPasJSONSizeInt = TPasJSONPtrInt;

This item has no description.

TPasJSONSizeUInt = TPasJSONPtrUInt;

This item has no description.

TPasJSONUInt16 = word;

This item has no description.

TPasJSONUInt32 = longword;

This item has no description.

TPasJSONUInt64 = UInt64;

This item has no description.

TPasJSONUInt8 = byte;

This item has no description.

TPasJSONUInt8Array = array [0 .. 65535] of TPasJSONUInt8;

This item has no description.

TPasJSONUTF16Char = WideChar;

This item has no description.

TPasJSONUTF16String = UnicodeString;

This item has no description.

TPasJSONUTF8String = UTF8String;


GLSysHelp v.2.5: PasJSON: Class EPasJSONSyntaxError

Class EPasJSONSyntaxError

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type EPasJSONSyntaxError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EPasJSONSyntaxError

Overview

Fields

Private fPosition: TPasJSONSizeInt;

Methods

Public constructor Create(const aMessage: string; const aPosition: TPasJSONSizeInt); reintroduce;

Properties

Published property Position: TPasJSONSizeInt read fPosition write fPosition;

Description

Fields

Private fPosition: TPasJSONSizeInt;

This item has no description.

Methods

Public constructor Create(const aMessage: string; const aPosition: TPasJSONSizeInt); reintroduce;

This item has no description.

Properties

Published property Position: TPasJSONSizeInt read fPosition write fPosition;


GLSysHelp v.2.5: PasJSON: Class EPasJSONMergeError

Class EPasJSONMergeError

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type EPasJSONMergeError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EPasJSONMergeError


GLSysHelp v.2.5: PasJSON: Class TPasJSONItem

Class TPasJSONItem

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItem = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSONItem

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); virtual;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); virtual;


GLSysHelp v.2.5: PasJSON: Class TPasJSONItemNull

Class TPasJSONItemNull

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemNull = class(TPasJSONItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSONItem
  • TPasJSONItemNull

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;


GLSysHelp v.2.5: PasJSON: Class TPasJSONItemBoolean

Class TPasJSONItemBoolean

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemBoolean = class(TPasJSONItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSONItem
  • TPasJSONItemBoolean

Overview

Fields

Private fValue: boolean;

Methods

Public | constructor Create(const AValue: boolean);
Public | destructor Destroy; override;
Public | procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

Properties

Published property Value: boolean read fValue write fValue;

Description

Fields

Private fValue: boolean;

This item has no description.

Methods

Public constructor Create(const AValue: boolean);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

This item has no description.

Properties

Published property Value: boolean read fValue write fValue;


GLSysHelp v.2.5: PasJSON: Class TPasJSONItemNumber

Class TPasJSONItemNumber

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemNumber = class(TPasJSONItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSONItem
  • TPasJSONItemNumber

Overview

Fields

Private fValue: TPasJSONDouble;

Methods

Public | constructor Create(const AValue: TPasJSONDouble);
Public | destructor Destroy; override;
Public | procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

Properties

Published property Value: TPasJSONDouble read fValue write fValue;

Description

Fields

Private fValue: TPasJSONDouble;

This item has no description.

Methods

Public constructor Create(const AValue: TPasJSONDouble);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

This item has no description.

Properties

Published property Value: TPasJSONDouble read fValue write fValue;


GLSysHelp v.2.5: PasJSON: Class TPasJSONItemString

Class TPasJSONItemString

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemString = class(TPasJSONItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSONItem
  • TPasJSONItemString

Overview

Fields

Private fValue: TPasJSONUTF8String;

Methods

Public | constructor Create(const AValue: TPasJSONUTF8String);
Public | destructor Destroy; override;
Public | procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

Properties

Published property Value: TPasJSONUTF8String read fValue write fValue;

Description

Fields

Private fValue: TPasJSONUTF8String;

This item has no description.

Methods

Public constructor Create(const AValue: TPasJSONUTF8String);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

This item has no description.

Properties

Published property Value: TPasJSONUTF8String read fValue write fValue;


GLSysHelp v.2.5: PasJSON: Class TPasJSONItemObjectProperty

Class TPasJSONItemObjectProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemObjectProperty = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSONItemObjectProperty

Overview

Fields

Private | fKey: TPasJSONUTF8String;
Private | fValue: TPasJSONItem;

Methods

Public | constructor Create; reintroduce;
Public | destructor Destroy; override;

Properties

Published | property Key: TPasJSONUTF8String read fKey write fKey;
Published | property Value: TPasJSONItem read fValue write fValue;

Description

Fields

Private fKey: TPasJSONUTF8String;

This item has no description.

Private fValue: TPasJSONItem;

This item has no description.

Methods

Public constructor Create; reintroduce;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Key: TPasJSONUTF8String read fKey write fKey;

This item has no description.

Published property Value: TPasJSONItem read fValue write fValue;


GLSysHelp v.2.5: PasJSON: Class TPasJSONItemObject

Class TPasJSONItemObject

Description
Hierarchy
Nested Classes and Records
Nested Types
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemObject = class(TPasJSONItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSONItem
  • TPasJSONItemObject

Overview

Nested Classes and Records

Public TPasJSONItemObjectEnumerator = record

Nested Types

Public PPasJSONItemObjectEnumerator = ˆTPasJSONItemObjectEnumerator;

Fields

Private | fProperties: TPasJSONItemObjectProperties;
Private | fCount: TPasJSONSizeInt;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetEnumerator: TPasJSONItemObjectEnumerator; inline;
Private | function GetKey(const aIndex: TPasJSONSizeInt): TPasJSONUTF8String;
Private | function GetKeyIndex(const aKey: TPasJSONUTF8String): TPasJSONInt32;
Private | function GetProperty(const aKey: TPasJSONUTF8String): TPasJSONItem;
Private | function GetValue(const aIndex: TPasJSONSizeInt): TPasJSONItem;
Public | procedure Add(const aKey: TPasJSONUTF8String; const AValue: TPasJSONItem);
Public | procedure Clear;
Public | procedure Delete(const aIndex: TPasJSONSizeInt); overload;
Public | procedure Delete(const aKey: TPasJSONUTF8String); overload;
Public | procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;
Private | procedure SetKey(const aIndex: TPasJSONSizeInt; const aKey: TPasJSONUTF8String);
Private | procedure SetProperty(const aKey: TPasJSONUTF8String; const aItem: TPasJSONItem);
Private | procedure SetValue(const aIndex: TPasJSONSizeInt; const aItem: TPasJSONItem);

Properties

Public | property Count: TPasJSONSizeInt read fCount;
Public | property Indices[const Key: TPasJSONUTF8String]: TPasJSONInt32 read GetKeyIndex;
Public | property Keys[const Index: TPasJSONSizeInt]: TPasJSONUTF8String read GetKey write SetKey;
Public | property Properties[const Key: TPasJSONUTF8String]: TPasJSONItem read GetProperty write SetProperty;
Public | property Values[const Index: TPasJSONSizeInt]: TPasJSONItem read GetValue write SetValue;

Description

Nested Types

Public PPasJSONItemObjectEnumerator = ˆTPasJSONItemObjectEnumerator;

This item has no description.

Fields

Private fProperties: TPasJSONItemObjectProperties;

This item has no description.

Private fCount: TPasJSONSizeInt;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetEnumerator: TPasJSONItemObjectEnumerator; inline;

This item has no description.

Private function GetKey(const aIndex: TPasJSONSizeInt): TPasJSONUTF8String;

This item has no description.

Private function GetKeyIndex(const aKey: TPasJSONUTF8String): TPasJSONInt32;

This item has no description.

Private function GetProperty(const aKey: TPasJSONUTF8String): TPasJSONItem;

This item has no description.

Private function GetValue(const aIndex: TPasJSONSizeInt): TPasJSONItem;

This item has no description.

Public procedure Add(const aKey: TPasJSONUTF8String; const AValue: TPasJSONItem);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(const aIndex: TPasJSONSizeInt); overload;

This item has no description.

Public procedure Delete(const aKey: TPasJSONUTF8String); overload;

This item has no description.

Public procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

This item has no description.

Private procedure SetKey(const aIndex: TPasJSONSizeInt; const aKey: TPasJSONUTF8String);

This item has no description.

Private procedure SetProperty(const aKey: TPasJSONUTF8String; const aItem: TPasJSONItem);

This item has no description.

Private procedure SetValue(const aIndex: TPasJSONSizeInt; const aItem: TPasJSONItem);

This item has no description.

Properties

Public property Count: TPasJSONSizeInt read fCount;

This item has no description.

Public property Indices[const Key: TPasJSONUTF8String]: TPasJSONInt32 read GetKeyIndex;

This item has no description.

Public property Keys[const Index: TPasJSONSizeInt]: TPasJSONUTF8String read GetKey write SetKey;

This item has no description.

Public property Properties[const Key: TPasJSONUTF8String]: TPasJSONItem read GetProperty write SetProperty;

This item has no description.

Public property Values[const Index: TPasJSONSizeInt]: TPasJSONItem read GetValue write SetValue;


GLSysHelp v.2.5: PasJSON: Record TPasJSONItemObject.TPasJSONItemObjectEnumerator

Record TPasJSONItemObject.TPasJSONItemObjectEnumerator

Description
Hierarchy
Enclosing Class
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemObjectEnumerator = record

Description

This item has no description.

Enclosing Class

  • TPasJSONItemObject

Overview

Fields

Private | fOwner: TPasJSONItemObject;
Private | fIndex: TPasJSONSizeInt;

Methods

Public | constructor Create(const aOwner: TPasJSONItemObject);
Public | function MoveNext: boolean; inline;
Private | function GetCurrent: TPasJSONItemObjectProperty; inline;

Properties

Public property Current: TPasJSONItemObjectProperty read GetCurrent;

Description

Fields

Private fOwner: TPasJSONItemObject;

This item has no description.

Private fIndex: TPasJSONSizeInt;

This item has no description.

Methods

Public constructor Create(const aOwner: TPasJSONItemObject);

This item has no description.

Public function MoveNext: boolean; inline;

This item has no description.

Private function GetCurrent: TPasJSONItemObjectProperty; inline;

This item has no description.

Properties

Public property Current: TPasJSONItemObjectProperty read GetCurrent;


GLSysHelp v.2.5: PasJSON: Class TPasJSONItemArray

Class TPasJSONItemArray

Description
Hierarchy
Nested Classes and Records
Nested Types
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemArray = class(TPasJSONItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSONItem
  • TPasJSONItemArray

Overview

Nested Classes and Records

Public TPasJSONItemArrayEnumerator = record

Nested Types

Public PPasJSONItemArrayEnumerator = ˆTPasJSONItemArrayEnumerator;

Fields

Private | fItems: TPasJSONItems;
Private | fCount: TPasJSONInt32;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetEnumerator: TPasJSONItemArrayEnumerator; inline;
Private | function GetValue(const Index: TPasJSONInt32): TPasJSONItem;
Public | procedure Add(const AValue: TPasJSONItem);
Public | procedure Clear;
Public | procedure Delete(const aIndex: TPasJSONSizeInt);
Public | procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;
Private | procedure SetValue(const Index: TPasJSONInt32; const Item: TPasJSONItem);

Properties

Public | property Count: TPasJSONInt32 read fCount;
Public | property Items[const Index: TPasJSONInt32]: TPasJSONItem read GetValue write SetValue;

Description

Nested Types

Public PPasJSONItemArrayEnumerator = ˆTPasJSONItemArrayEnumerator;

This item has no description.

Fields

Private fItems: TPasJSONItems;

This item has no description.

Private fCount: TPasJSONInt32;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetEnumerator: TPasJSONItemArrayEnumerator; inline;

This item has no description.

Private function GetValue(const Index: TPasJSONInt32): TPasJSONItem;

This item has no description.

Public procedure Add(const AValue: TPasJSONItem);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(const aIndex: TPasJSONSizeInt);

This item has no description.

Public procedure Merge(const aWith: TPasJSONItem; const aFlags: TPasJSONMergeFlags = []); override;

This item has no description.

Private procedure SetValue(const Index: TPasJSONInt32; const Item: TPasJSONItem);

This item has no description.

Properties

Public property Count: TPasJSONInt32 read fCount;

This item has no description.

Public property Items[const Index: TPasJSONInt32]: TPasJSONItem read GetValue write SetValue;


GLSysHelp v.2.5: PasJSON: Record TPasJSONItemArray.TPasJSONItemArrayEnumerator

Record TPasJSONItemArray.TPasJSONItemArrayEnumerator

Description
Hierarchy
Enclosing Class
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSONItemArrayEnumerator = record

Description

This item has no description.

Enclosing Class

  • TPasJSONItemArray

Overview

Fields

Private | fOwner: TPasJSONItemArray;
Private | fIndex: TPasJSONSizeInt;

Methods

Public | constructor Create(const aOwner: TPasJSONItemArray);
Public | function MoveNext: boolean; inline;
Private | function GetCurrent: TPasJSONItem; inline;

Properties

Public property Current: TPasJSONItem read GetCurrent;

Description

Fields

Private fOwner: TPasJSONItemArray;

This item has no description.

Private fIndex: TPasJSONSizeInt;

This item has no description.

Methods

Public constructor Create(const aOwner: TPasJSONItemArray);

This item has no description.

Public function MoveNext: boolean; inline;

This item has no description.

Private function GetCurrent: TPasJSONItem; inline;

This item has no description.

Properties

Public property Current: TPasJSONItem read GetCurrent;


GLSysHelp v.2.5: PasJSON: Class TPasJSON

Class TPasJSON

Description
Hierarchy
Fields
Methods
Properties

Unit

PasJSON

Declaration

type TPasJSON = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TPasJSON

Overview

Fields

Public nested const SimplifiedJSONModeFlags: TPasJSONModeFlags = [TPasJSONModeFlag.UnquotedKeys, TPasJSONModeFlag.Comments, TPasJSONModeFlag.ImplicitRootObject, TPasJSONModeFlag.OptionalCommas, TPasJSONModeFlag.EqualsForColon, TPasJSONModeFlag.MultilineStrings];

Methods

Public | class function GetBoolean(const aItem: TPasJSONItem; const aDefault: boolean = false): boolean; static;
Public | class function GetInt64(const aItem: TPasJSONItem; const aDefault: TPasJSONInt64 = 0): TPasJSONInt64; static;
Public | class function GetNumber(const aItem: TPasJSONItem; const aDefault: TPasJSONDouble = 0.0): TPasJSONDouble; static;
Public | class function GetString(const aItem: TPasJSONItem; const aDefault: TPasJSONUTF8String = ''): TPasJSONUTF8String; static;
Public | class function LoadBinaryFromStream(const aStream: TStream) : TPasJSONItem; static;
Public | class function Parse(const aSource: TPasJSONRawByteString; const aModeFlags: TPasJSONModeFlags = [TPasJSONModeFlag.Comments]; const aEncoding: TPasJSONEncoding = TPasJSONEncoding.AutomaticDetection) : TPasJSONItem; overload; static;
Public | class function Parse(const aStream: TStream; const aModeFlags: TPasJSONModeFlags = [TPasJSONModeFlag.Comments]; const aEncoding: TPasJSONEncoding = TPasJSONEncoding.AutomaticDetection) : TPasJSONItem; overload; static;
Public | class function Stringify(const aJSONItem: TPasJSONItem; const aFormatting: boolean = false; const aModeFlags: TPasJSONModeFlags = []; const aLevel: TPasJSONInt32 = 0) : TPasJSONRawByteString; static;
Public | class function StringQuote(const aString: TPasJSONUTF8String) : TPasJSONRawByteString; static;
Public | class procedure SaveBinaryToStream(const aStream: TStream; const aJSONItem: TPasJSONItem); static;
Public | class procedure StringifyToStream(const aStream: TStream; const aJSONItem: TPasJSONItem; const aFormatting: boolean = false; const aModeFlags: TPasJSONModeFlags = []; const aLevel: TPasJSONInt32 = 0); static;

Description

Fields

Public nested const SimplifiedJSONModeFlags: TPasJSONModeFlags = [TPasJSONModeFlag.UnquotedKeys, TPasJSONModeFlag.Comments, TPasJSONModeFlag.ImplicitRootObject, TPasJSONModeFlag.OptionalCommas, TPasJSONModeFlag.EqualsForColon, TPasJSONModeFlag.MultilineStrings];

Simplified JSON notation as in http://bitsquid.blogspot.de/2009/10/simplified-json-notation.html

Methods

Public class function GetBoolean(const aItem: TPasJSONItem; const aDefault: boolean = false): boolean; static;

This item has no description.

Public class function GetInt64(const aItem: TPasJSONItem; const aDefault: TPasJSONInt64 = 0): TPasJSONInt64; static;

This item has no description.

Public class function GetNumber(const aItem: TPasJSONItem; const aDefault: TPasJSONDouble = 0.0): TPasJSONDouble; static;

This item has no description.

Public class function GetString(const aItem: TPasJSONItem; const aDefault: TPasJSONUTF8String = ''): TPasJSONUTF8String; static;

This item has no description.

Public class function LoadBinaryFromStream(const aStream: TStream) : TPasJSONItem; static;

This item has no description.

Public class function Parse(const aSource: TPasJSONRawByteString; const aModeFlags: TPasJSONModeFlags = [TPasJSONModeFlag.Comments]; const aEncoding: TPasJSONEncoding = TPasJSONEncoding.AutomaticDetection) : TPasJSONItem; overload; static;

This item has no description.

Public class function Parse(const aStream: TStream; const aModeFlags: TPasJSONModeFlags = [TPasJSONModeFlag.Comments]; const aEncoding: TPasJSONEncoding = TPasJSONEncoding.AutomaticDetection) : TPasJSONItem; overload; static;

This item has no description.

Public class function Stringify(const aJSONItem: TPasJSONItem; const aFormatting: boolean = false; const aModeFlags: TPasJSONModeFlags = []; const aLevel: TPasJSONInt32 = 0) : TPasJSONRawByteString; static;

This item has no description.

Public class function StringQuote(const aString: TPasJSONUTF8String) : TPasJSONRawByteString; static;

This item has no description.

Public class procedure SaveBinaryToStream(const aStream: TStream; const aJSONItem: TPasJSONItem); static;

This item has no description.

Public class procedure StringifyToStream(const aStream: TStream; const aJSONItem: TPasJSONItem; const aFormatting: boolean = false; const aModeFlags: TPasJSONModeFlags = []; const aLevel: TPasJSONInt32 = 0); static;


GLSysHelp v.2.5: PhysX.Import

Unit PhysX.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows

Overview

Functions and Procedures

procedure SDK_Version(major, minor, bugfix: pdword); stdcall; external PhysXDLL;
procedure InitNx; stdcall; external PhysXDLL;
procedure ReleaseNx; stdcall; external PhysXDLL;
procedure SimulateNx(dt: single); stdcall; external PhysXDLL;
procedure GetResultsNx; stdcall; external PhysXDLL;
procedure ActorCount(count: pdword); stdcall; external PhysXDLL;
procedure GetActor(index: dword; obj: pdword); stdcall; external PhysXDLL;
procedure GetActorGlobalPosition(actor: dword; x,y,z: psingle); stdcall; external PhysXDLL;
procedure SetActorGlobalPosition(actor: dword; x,y,z: single); stdcall; external PhysXDLL;
procedure GetActorGlobalOrientation(actor: dword; x,y,z,w: psingle); stdcall; external PhysXDLL;
procedure SetActorGlobalOrientation(actor: dword; x,y,z,w: single); stdcall; external PhysXDLL;
procedure GetActorCMassGlobalPosition(actor: dword; x,y,z: psingle); stdcall; external PhysXDLL;
procedure SetActorCMassGlobalPosition(actor: dword; x,y,z: single); stdcall; external PhysXDLL;
procedure GetActorMass(actor: dword; m: psingle); stdcall; external PhysXDLL;
procedure SetActorMass(actor: dword; m: single); stdcall; external PhysXDLL;
procedure ActorAddForce(actor: dword; x,y,z: single); stdcall; external PhysXDLL;
procedure CreateGroundPlane(actor: pdword); stdcall; external PhysXDLL;
procedure CreateBox(actor: pdword; sx,sy,sz,dens: single); stdcall; external PhysXDLL;
procedure CreateSphere(actor: pdword; rad: single; dens: single); stdcall; external PhysXDLL;
procedure CreateCylinder(actor: pdword; rad: single; height: single; dens: single); stdcall; external PhysXDLL;

Constants

PhysXDLL = 'PhysXwrap.dll';

Description

Functions and Procedures

procedure SDK_Version(major, minor, bugfix: pdword); stdcall; external PhysXDLL;

This item has no description.

procedure InitNx; stdcall; external PhysXDLL;

This item has no description.

procedure ReleaseNx; stdcall; external PhysXDLL;

This item has no description.

procedure SimulateNx(dt: single); stdcall; external PhysXDLL;

This item has no description.

procedure GetResultsNx; stdcall; external PhysXDLL;

This item has no description.

procedure ActorCount(count: pdword); stdcall; external PhysXDLL;

This item has no description.

procedure GetActor(index: dword; obj: pdword); stdcall; external PhysXDLL;

This item has no description.

procedure GetActorGlobalPosition(actor: dword; x,y,z: psingle); stdcall; external PhysXDLL;

This item has no description.

procedure SetActorGlobalPosition(actor: dword; x,y,z: single); stdcall; external PhysXDLL;

This item has no description.

procedure GetActorGlobalOrientation(actor: dword; x,y,z,w: psingle); stdcall; external PhysXDLL;

This item has no description.

procedure SetActorGlobalOrientation(actor: dword; x,y,z,w: single); stdcall; external PhysXDLL;

This item has no description.

procedure GetActorCMassGlobalPosition(actor: dword; x,y,z: psingle); stdcall; external PhysXDLL;

This item has no description.

procedure SetActorCMassGlobalPosition(actor: dword; x,y,z: single); stdcall; external PhysXDLL;

This item has no description.

procedure GetActorMass(actor: dword; m: psingle); stdcall; external PhysXDLL;

This item has no description.

procedure SetActorMass(actor: dword; m: single); stdcall; external PhysXDLL;

This item has no description.

procedure ActorAddForce(actor: dword; x,y,z: single); stdcall; external PhysXDLL;

This item has no description.

procedure CreateGroundPlane(actor: pdword); stdcall; external PhysXDLL;

This item has no description.

procedure CreateBox(actor: pdword; sx,sy,sz,dens: single); stdcall; external PhysXDLL;

This item has no description.

procedure CreateSphere(actor: pdword; rad: single; dens: single); stdcall; external PhysXDLL;

This item has no description.

procedure CreateCylinder(actor: pdword; rad: single; height: single; dens: single); stdcall; external PhysXDLL;

This item has no description.

Constants

PhysXDLL = 'PhysXwrap.dll';


GLSysHelp v.2.5: SDL.Import

Unit SDL.Import

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • Winapi.Windows

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TSDL_Version |
Record TSDL_Error |
Record TStdio |
Record TMem |
Record TUnknown |
Record TAndroidIO |
Record TWindowsIOBuffer |
Record TWindowsIO |
Packed Record TSDL_RWops |
Record TSDL_AudioSpec |
Record TSDL_AudioCVT |
Record TSDL_Thread |
Record TSDL_Mutex |
Record TSDL_Color |
Record TSDL_Palette |
Record TSDL_PixelFormat |
Record TSDL_Point |
Record TSDL_Rect |
Record TSDL_BlitMap |
Record TSDL_Surface |
Record TSDL_WindowShapeParams |
Record TSDL_WindowShapeMode |
Record TSDL_DisplayMode |
Record TSDL_WindowShaper |
Record TSDL_WindowUserData |
Record TSDL_Window |
Record TSDL_RendererInfo |
Record TSDL_Keysym |
Record TSDL_JoystickGUID |
Record THat |
Record TSDL_GameControllerButtonBind |
Record TSDL_Haptic |
Record TSDL_HapticDirection |
Record TSDL_HapticConstant |
Record TSDL_HapticPeriodic |
Record TSDL_HapticCondition |
Record TSDL_HapticRamp |
Record TSDL_HapticCustom |
Record TSDL_HapticEffect |
Record TSDL_Finger |
Record TSDL_CommonEvent |
Record TSDL_WindowEvent |
Record TSDL_KeyboardEvent |
Record TSDL_TextEditingEvent |
Record TSDL_TextInputEvent |
Record TSDL_MouseMotionEvent |
Record TSDL_MouseButtonEvent |
Record TSDL_MouseWheelEvent |
Record TSDL_JoyAxisEvent |
Record TSDL_JoyBallEvent |
Record TSDL_JoyHatEvent |
Record TSDL_JoyButtonEvent |
Record TSDL_JoyDeviceEvent |
Record TSDL_ControllerAxisEvent |
Record TSDL_ControllerButtonEvent |
Record TSDL_ControllerDeviceEvent |
Record TSDL_TouchFingerEvent |
Record TSDL_MultiGestureEvent |
Record TSDL_DollarGestureEvent |
Record TSDL_DropEvent |
Record TSDL_QuitEvent |
Record TSDL_UserEvent |
Record TSDL_SysWMmsg |
Record TSDL_SysWMinfo |
Record TSDL_SysWMEvent |
Record TSDL_Event |
Record TSDL_MessageBoxButtonData |
Record TSDL_MessageBoxColor |
Record TSDL_MessageBoxColorScheme |
Record TSDL_MessageBoxData |
Record TSDLPantalla |

Functions and Procedures

procedure SDL_VERSION(x: PSDL_Version);
function SDL_VERSIONNUM(X,Y,Z: UInt32): Cardinal;
function SDL_COMPILEDVERSION(): Cardinal;
function SDL_VERSION_ATLEAST(X,Y,Z: Cardinal): Boolean;
procedure SDL_GetVersion(ver: PSDL_Version); cdecl; external SDL_LibName;
function SDL_GetRevision(): PChar; cdecl; external SDL_LibName;
function SDL_GetRevisionNumber(): SInt32; cdecl; external SDL_LibName;
function SDL_SetError(const fmt: PChar): SInt32; cdecl; external SDL_LibName;
function SDL_GetError(): PChar; cdecl; external SDL_LibName;
procedure SDL_ClearError(); cdecl; external SDL_LibName;
function SDL_Error(code: TSDL_ErrorCode): SInt32; cdecl; external SDL_LibName;
function SDL_RWFromFile(const _file: PChar; const mode: PChar): PSDL_RWops; cdecl; external SDL_LibName;
function SDL_RWFromFP(fp: Pointer; autoclose: TSDL_Bool): PSDL_RWops; cdecl; external SDL_LibName;
function SDL_RWFromMem(mem: Pointer; size: SInt32): PSDL_RWops; cdecl; external SDL_LibName;
function SDL_RWFromConstMem(const mem: Pointer; size: SInt32): PSDL_RWops; cdecl; external SDL_LibName;
function SDL_AllocRW(): PSDL_RWops; cdecl; external SDL_LibName;
procedure SDL_FreeRW(area: PSDL_RWops); cdecl; external SDL_LibName;
function SDL_RWsize(ctx: PSDL_RWops): SInt64;
function SDL_RWseek(ctx: PSDL_RWops; offset: SInt64; whence: SInt32): SInt64;
function SDL_RWtell(ctx: PSDL_RWops): SInt64;
function SDL_RWread(ctx: PSDL_RWops; ptr: Pointer; size: size_t; n: size_t): size_t;
function SDL_RWwrite(ctx: PSDL_RWops; ptr: Pointer; size: size_t; n: size_t): size_t;
function SDL_RWclose(ctx: PSDL_RWops): SInt32;
function SDL_ReadU8(src: PSDL_RWops): UInt8; cdecl; external SDL_LibName;
function SDL_ReadLE16(src: PSDL_RWops): UInt16; cdecl; external SDL_LibName;
function SDL_ReadBE16(src: PSDL_RWops): UInt16; cdecl; external SDL_LibName;
function SDL_ReadLE32(src: PSDL_RWops): UInt32; cdecl; external SDL_LibName;
function SDL_ReadBE32(src: PSDL_RWops): UInt32; cdecl; external SDL_LibName;
function SDL_ReadLE64(src: PSDL_RWops): UInt64; cdecl; external SDL_LibName;
function SDL_ReadBE64(src: PSDL_RWops): UInt64; cdecl; external SDL_LibName;
function SDL_WriteU8(dst: PSDL_RWops; value: UInt8): size_t; cdecl; external SDL_LibName;
function SDL_WriteLE16(dst: PSDL_RWops; value: UInt16): size_t; cdecl; external SDL_LibName;
function SDL_WriteBE16(dst: PSDL_RWops; value: UInt16): size_t; cdecl; external SDL_LibName;
function SDL_WriteLE32(dst: PSDL_RWops; value: UInt32): size_t; cdecl; external SDL_LibName;
function SDL_WriteBE32(dst: PSDL_RWops; value: UInt32): size_t; cdecl; external SDL_LibName;
function SDL_WriteLE64(dst: PSDL_RWops; value: UInt64): size_t; cdecl; external SDL_LibName;
function SDL_WriteBE64(dst: PSDL_RWops; value: UInt64): size_t; cdecl; external SDL_LibName;
function SDL_AUDIO_BITSIZE(x: Cardinal): Cardinal;
function SDL_AUDIO_ISFLOAT(x: Cardinal): Cardinal;
function SDL_AUDIO_ISBIGENDIAN(x: Cardinal): Cardinal;
function SDL_AUDIO_ISSIGNED(x: Cardinal): Cardinal;
function SDL_AUDIO_ISINT(x: Cardinal): Cardinal;
function SDL_AUDIO_ISLITTLEENDIAN(x: Cardinal): Cardinal;
function SDL_AUDIO_ISUNSIGNED(x: Cardinal): Cardinal;
function SDL_GetNumAudioDrivers(): Integer; cdecl; external SDL_LibName;
function SDL_GetAudioDriver(index: Integer): PChar; cdecl; external SDL_LibName;
function SDL_AudioInit(driver_name: PChar): Integer; cdecl; external SDL_LibName;
procedure SDL_AudioQuit(); cdecl; external SDL_LibName;
function SDL_GetCurrentAudioDriver(): PChar; cdecl; external SDL_LibName;
function SDL_OpenAudio(desired: PSDL_AudioSpec; obtained: PSDL_AudioSpec): Integer; cdecl; external SDL_LibName;
function SDL_GetNumAudioDevices(iscapture: Integer): Integer; cdecl; external SDL_LibName;
function SDL_GetAudioDeviceName(index: Integer; iscapture: Integer): PChar; cdecl; external SDL_LibName;
function SDL_OpenAudioDevice(device: PChar; iscapture: Integer; desired: PSDL_AudioSpec; obtained: PSDL_AudioSpec; allowed_changes: Integer): TSDL_AudioDeviceID; cdecl; external SDL_LibName;
function SDL_GetAudioStatus(): TSDL_AudioStatus; cdecl; external SDL_LibName;
function SDL_GetAudioDeviceStatus(dev: TSDL_AudioDeviceID): TSDL_AudioStatus; cdecl; external SDL_LibName;
procedure SDL_PauseAudio(pause_on: Integer); cdecl; external SDL_LibName;
procedure SDL_PauseAudioDevice(dev: TSDL_AudioDeviceID; pause_on: Integer); cdecl; external SDL_LibName;
function SDL_LoadWAV_RW(src: PSDL_RWops; freesrc: Integer; spec: PSDL_AudioSpec; audio_buf: PPUInt8; audio_len: PUInt32): PSDL_AudioSpec; cdecl; external SDL_LibName;
function SDL_LoadWAV(_file: PChar; spec: PSDL_AudioSpec; audio_buf: PPUInt8; audio_len: PUInt32): PSDL_AudioSpec;
procedure SDL_FreeWAV(audio_buf: PUInt8); cdecl; external SDL_LibName;
function SDL_BuildAudioCVT(cvt: PSDL_AudioCVT; src_format: TSDL_AudioFormat; src_channels: UInt8; src_rate: Integer; dst_format: TSDL_AudioFormat; dst_channels: UInt8; dst_rate: Integer): Integer; cdecl; external SDL_LibName;
function SDL_ConvertAudio(cvt: PSDL_AudioCVT): Integer; cdecl; external SDL_LibName;
procedure SDL_MixAudio(dst: PUInt8; src: PUInt8; len: UInt32; volume: Integer); cdecl; external SDL_LibName;
procedure SDL_MixAudioFormat(dst: PUInt8; src: PUInt8; format: TSDL_AudioFormat; len: UInt32; volume: Integer); cdecl; external SDL_LibName;
procedure SDL_LockAudio(); cdecl; external SDL_LibName;
procedure SDL_LockAudioDevice(dev: TSDL_AudioDeviceID); cdecl; external SDL_LibName;
procedure SDL_UnlockAudio(); cdecl; external SDL_LibName;
procedure SDL_UnlockAudioDevice(dev: TSDL_AudioDeviceID); cdecl; external SDL_LibName;
procedure SDL_CloseAudio(); cdecl; external SDL_LibName;
procedure SDL_CloseAudioDevice(dev: TSDL_AudioDeviceID); cdecl; external SDL_LibName;
function SDL_AudioDeviceConnected(dev: TSDL_AudioDeviceID): Integer; cdecl; external SDL_LibName;
function SDL_GetPowerInfo(secs: PInt; pct: PInt): TSDL_PowerState; cdecl; external SDL_LibName;
function SDL_CreateThread(fn: TSDL_ThreadFunction; name: PChar; data: Pointer; pfnBeginThread: TpfnSDL_CurrentBeginThread; pfnEndThread: TpfnSDL_CurrentEndThread): PSDL_Thread; cdecl; overload; external SDL_LibName;
function SDL_CreateThread(fn: TSDL_ThreadFunction; name: PChar; data: Pointer): PSDL_Thread; overload;
function SDL_GetThreadName(thread: PSDL_Thread): PChar; cdecl; external SDL_LibName;
function SDL_ThreadID(): TSDL_ThreadID; cdecl; external SDL_LibName;
function SDL_GetThreadID(thread: PSDL_Thread): TSDL_ThreadID; cdecl; external SDL_LibName;
function SDL_SetThreadPriority(priority: TSDL_ThreadPriority): SInt32; cdecl; external SDL_LibName;
procedure SDL_WaitThread(thread: PSDL_Thread; status: PInt); cdecl; external SDL_LibName;
function SDL_TLSCreate(): TSDL_TLSID; cdecl; external SDL_LibName;
function SDL_TLSGet(id: TSDL_TLSID): Pointer; cdecl; external SDL_LibName;
function SDL_TLSSet(id: TSDL_TLSID; value: Pointer; destructor_: Pointer): SInt32; cdecl; external SDL_LibName;
function SDL_CreateMutex(): PSDL_Mutex; cdecl; external SDL_LibName;
function SDL_LockMutex(mutex: PSDL_Mutex): SInt32; cdecl; external SDL_LibName;
function SDL_TryLockMutex(mutex: PSDL_Mutex): SInt32; cdecl; external SDL_LibName;
function SDL_UnlockMutex(mutex: PSDL_Mutex): SInt32; cdecl; external SDL_LibName;
procedure SDL_DestroyMutex(mutex: PSDL_Mutex); cdecl; external SDL_LibName;
function SDL_CreateSemaphore(initial_value: UInt32): PSDL_sem; cdecl; external SDL_LibName;
procedure SDL_DestroySemaphore(sem: PSDL_Sem); cdecl; external SDL_LibName;
function SDL_SemWait(sem: PSDL_Sem): SInt32; cdecl; external SDL_LibName;
function SDL_SemTryWait(sem: PSDL_Sem): SInt32; cdecl; external SDL_LibName;
function SDL_SemWaitTimeout(sem: PSDL_Sem; ms: UInt32): SInt32; cdecl; external SDL_LibName;
function SDL_SemPost(sem: PSDL_Sem): SInt32; cdecl; external SDL_LibName;
function SDL_SemValue(sem: PSDL_Sem): UInt32; cdecl; external SDL_LibName;
function SDL_CreateCond(): PSDL_Cond; cdecl; external SDL_LibName;
procedure SDL_DestroyCond(cond: PSDL_Cond); cdecl; external SDL_LibName;
function SDL_CondSignal(cond: PSDL_Cond): SInt32; cdecl; external SDL_LibName;
function SDL_CondBroadcast(cond: PSDL_Cond): SInt32; cdecl; external SDL_LibName;
function SDL_CondWait(cond: PSDL_Cond; mutex: PSDL_Mutex): SInt32; cdecl; external SDL_LibName;
function SDL_CondWaitTimeout(cond: PSDL_Cond; mutex: PSDL_Mutex; ms: UInt32): SInt32; cdecl; external SDL_LibName;
function SDL_GetTicks(): UInt32; cdecl; external SDL_LibName;
function SDL_GetPerformanceCounter(): UInt64; cdecl; external SDL_LibName;
function SDL_GetPerformanceFrequency(): UInt64; cdecl; external SDL_LibName;
procedure SDL_Delay(ms: UInt32); cdecl; external SDL_LibName;
function SDL_AddTimer(interval: UInt32; callback: TSDL_TimerCallback; param: Pointer): TSDL_TimerID; cdecl; external SDL_LibName;
function SDL_RemoveTimer(id: TSDL_TimerID): Boolean; cdecl; external SDL_LibName;
function SDL_PIXELFLAG(X: Cardinal): Boolean;
function SDL_PIXELTYPE(X: Cardinal): Boolean;
function SDL_PIXELORDER(X: Cardinal): Boolean;
function SDL_PIXELLAYOUT(X: Cardinal): Boolean;
function SDL_BITSPERPIXEL(X: Cardinal): Boolean;
function SDL_BYTESPERPIXEL(X: Integer): Integer;
function SDL_GetPixelFormatName(format: UInt32): PChar; cdecl; external SDL_LibName;
function SDL_PixelFormatEnumToMasks(format: UInt32; bpp: PInt; Rmask: PUInt32; Gmask: PUInt32; Bmask: PUInt32; Amask: PUInt32): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_MasksToPixelFormatEnum(bpp: SInt32; Rmask: UInt32; Gmask: UInt32; Bmask: UInt32; Amask: UInt32): UInt32; cdecl; external SDL_LibName;
function SDL_AllocFormat(pixel_format: UInt32): PSDL_PixelFormat; cdecl; external SDL_LibName;
procedure SDL_FreeFormat(format: PSDL_PixelFormat); cdecl; external SDL_LibName;
function SDL_AllocPalette(ncolors: SInt32): PSDL_Palette; cdecl; external SDL_LibName;
function SDL_SetPixelFormatPalette(format: PSDL_PixelFormat; palette: PSDL_Palette): SInt32; cdecl; external SDL_LibName;
function SDL_SetPaletteColors(palette: PSDL_Palette; const colors: PSDL_Color; firstcolor: SInt32; ncolors: SInt32): SInt32; cdecl; external SDL_LibName;
procedure SDL_FreePalette(palette: PSDL_Palette); cdecl; external SDL_LibName;
function SDL_MapRGB(const format: PSDL_PixelFormat; r: UInt8; g: UInt8; b: UInt8): UInt32; cdecl; external SDL_LibName;
function SDL_MapRGBA(const format: PSDL_PixelFormat; r: UInt8; g: UInt8; b: UInt8; a: UInt8): UInt32; cdecl; external SDL_LibName;
procedure SDL_GetRGB(pixel: UInt32; const format: PSDL_PixelFormat; r: PUInt8; g: PUInt8; b: PUInt8); cdecl; external SDL_LibName;
procedure SDL_GetRGBA(pixel: UInt32; const format: PSDL_PixelFormat; r: PUInt8; g: PUInt8; b: PUInt8; a: PUInt8); cdecl; external SDL_LibName;
procedure SDL_CalculateGammaRamp(gamma: Float; ramp: PUInt16); cdecl; external SDL_LibName;
function SDL_RectEmpty(X: TSDL_Rect): Boolean;
function SDL_RectEquals(A: TSDL_Rect; B: TSDL_Rect): Boolean;
function SDL_HasIntersection(const A: PSDL_Rect; const B: PSDL_Rect): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_IntersectRect(const A: PSDL_Rect; const B: PSDL_Rect; result: PSDL_Rect): TSDL_Bool; cdecl; external SDL_LibName;
procedure SDL_UnionRect(const A: PSDL_Rect; const B: PSDL_Rect; result: PSDL_Rect); cdecl; external SDL_LibName;
function SDL_EnclosePoints(const points: PSDL_Point; count: SInt32; const clip: PSDL_Rect; result: PSDL_Rect): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_IntersectRectAndLine(const rect: PSDL_Rect; X1: PInt; Y1: PInt; X2: PInt; Y2: PInt): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_CreateRGBSurface(flags: UInt32; width: SInt32; height: SInt32; depth: SInt32; Rmask: UInt32; Gmask: UInt32; Bmask: UInt32; Amask: UInt32): PSDL_Surface; cdecl; external SDL_LibName;
function SDL_CreateRGBSurfaceFrom(pixels: Pointer; width: SInt32; height: SInt32; depth: SInt32; pitch: SInt32; Rmask: UInt32; Gmask: UInt32; Bmask: UInt32; Amask: UInt32): PSDL_Surface; cdecl; external SDL_LibName;
procedure SDL_FreeSurface(surface: PSDL_Surface); cdecl; external SDL_LibName;
function SDL_SetSurfacePalette(surface: PSDL_Surface; palette: PSDL_Palette): SInt32; cdecl; external SDL_LibName;
function SDL_LockSurface(surface: PSDL_Surface): SInt32; cdecl; external SDL_LibName;
procedure SDL_UnlockSurface(surface: PSDL_Surface); cdecl; external SDL_LibName;
function SDL_LoadBMP_RW(src: PSDL_RWops; freesrc: SInt32): PSDL_Surface; cdecl; external SDL_LibName;
function SDL_LoadBMP(_file: PChar): PSDL_Surface;
function SDL_SaveBMP_RW(surface: PSDL_Surface; dst: PSDL_RWops; freedst: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_SaveBMP(surface: PSDL_Surface; _file: PChar): SInt32;
function SDL_SetSurfaceRLE(surface: PSDL_Surface; flag: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_SetColorKey(surface: PSDL_Surface; flag: SInt32; key: UInt32): SInt32; cdecl; external SDL_LibName;
function SDL_GetColorKey(surface: PSDL_Surface; key: PUInt32): SInt32; cdecl; external SDL_LibName;
function SDL_SetSurfaceColorMod(surface: PSDL_Surface; r: UInt8; g: UInt8; b: UInt8): SInt32; cdecl; external SDL_LibName;
function SDL_GetSurfaceColorMod(surface: PSDL_Surface; r: PUInt8; g: PUInt8; b: PUInt8): SInt32; cdecl; external SDL_LibName;
function SDL_SetSurfaceAlphaMod(surface: PSDL_Surface; alpha: UInt8): SInt32; cdecl; external SDL_LibName;
function SDL_GetSurfaceAlphaMod(surface: PSDL_Surface; alpha: PUInt8): SInt32; cdecl; external SDL_LibName;
function SDL_SetSurfaceBlendMode(surface: PSDL_Surface; blendMode: TSDL_BlendMode): SInt32; cdecl; external SDL_LibName;
function SDL_GetSurfaceBlendMode(surface: PSDL_Surface; blendMode: PSDL_BlendMode): SInt32; cdecl; external SDL_LibName;
function SDL_SetClipRect(surface: PSDL_Surface; const rect: PSDL_Rect): TSDL_Bool; cdecl; external SDL_LibName;
procedure SDL_GetClipRect(surface: PSDL_Surface; rect: PSDL_Rect); cdecl; external SDL_LibName;
function SDL_ConvertSurface(src: PSDL_Surface; fmt: PSDL_PixelFormat; flags: UInt32): PSDL_Surface; cdecl; external SDL_LibName;
function SDL_ConvertSurfaceFormat(src: PSDL_Surface; pixel_format: UInt32; flags: UInt32): PSDL_Surface; cdecl; external SDL_LibName;
function SDL_ConvertPixels(width: SInt32; height: SInt32; src_format: UInt32; const src: Pointer; src_pitch: SInt32; dst_format: UInt32; dst: Pointer; dst_pitch: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_FillRect(dst: PSDL_Surface; const rect: PSDL_Rect; color: UInt32): SInt32; cdecl; external SDL_LibName;
function SDL_FillRects(dst: PSDL_Surface; const rects: PSDL_Rect; count: SInt32; color: UInt32): SInt32; cdecl; external SDL_LibName;
function SDL_UpperBlit(src: PSDL_Surface; const srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
function SDL_LowerBlit(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
function SDL_SoftStretch(src: PSDL_Surface; const srcrect: PSDL_Rect; dst: PSDL_Surface; const dstrect: PSDL_Surface): SInt32; cdecl; external SDL_LibName;
function SDL_UpperBlitScaled(src: PSDL_Surface; const srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
function SDL_LowerBlitScaled(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
function SDL_GetShapedWindowMode(window: PSDL_Window; shape_mode: TSDL_WindowShapeMode): SInt32; cdecl; external SDL_LibName;
function SDL_SetWindowShape(window: PSDL_Window; shape: PSDL_Surface; shape_mode: PSDL_WindowShapeMode): SInt32; cdecl; external SDL_LibName;
function SDL_CreateShapedWindow(title: PChar; x: UInt32; y: UInt32; w: UInt32; h: UInt32; flags: UInt32): PSDL_Window; cdecl; external SDL_LibName;
function SDL_IsShapedWindow(window: PSDL_Window): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_WindowPos_IsUndefined(X: Variant): Variant;
function SDL_WindowPos_IsCentered(X: Variant): Variant;
function SDL_GetNumVideoDrivers(): SInt32; cdecl; external SDL_LibName;
function SDL_GetVideoDriver(index: SInt32): PChar; cdecl; external SDL_LibName;
function SDL_VideoInit(const driver_name: PChar): SInt32; cdecl; external SDL_LibName;
procedure SDL_VideoQuit(); cdecl; external SDL_LibName;
function SDL_GetCurrentVideoDriver(): PChar; cdecl; external SDL_LibName;
function SDL_GetNumVideoDisplays(): SInt32; cdecl; external SDL_LibName;
function SDL_GetDisplayName(displayIndex: SInt32): PChar; cdecl; external SDL_LibName;
function SDL_GetDisplayBounds(displayIndex: SInt32; rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
function SDL_GetNumDisplayModes(displayIndex: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_GetDisplayMode(displayIndex: SInt32; modeIndex: SInt32; mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;
function SDL_GetDesktopDisplayMode(displayIndex: SInt32; mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;
function SDL_GetCurrentDisplayMode(displayIndex: SInt32; mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;
function SDL_GetClosestDisplayMode(displayIndex: SInt32; const mode: PSDL_DisplayMode; closest: PSDL_DisplayMode): PSDL_DisplayMode; cdecl; external SDL_LibName;
function SDL_GetWindowDisplayIndex(window: PSDL_Window): SInt32; cdecl; external SDL_LibName;
function SDL_SetWindowDisplayMode(window: PSDL_Window; const mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;
function SDL_GetWindowDisplayMode(window: PSDL_Window; mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;
function SDL_GetWindowPixelFormat(window: PSDL_Window): UInt32; cdecl; external SDL_LibName;
function SDL_CreateWindow(const title: PChar; x: SInt32; y: SInt32; w: SInt32; h: SInt32; flags: UInt32): PSDL_Window; cdecl; external SDL_LibName;
function SDL_CreateWindowFrom(const data: Pointer): PSDL_Window; cdecl; external SDL_LibName;
function SDL_GetWindowID(window: PSDL_Window): UInt32; cdecl; external SDL_LibName;
function SDL_GetWindowFromID(id: UInt32): PSDL_Window; cdecl; external SDL_LibName;
function SDL_GetWindowFlags(window: PSDL_Window): UInt32; cdecl; external SDL_LibName;
procedure SDL_SetWindowTitle(window: PSDL_Window; const title: PChar); cdecl; external SDL_LibName;
function SDL_GetWindowTitle(window: PSDL_Window): PChar; cdecl; external SDL_LibName;
procedure SDL_SetWindowIcon(window: PSDL_Window; icon: PSDL_Surface); cdecl; external SDL_LibName;
function SDL_SetWindowData(window: PSDL_Window; const name: PChar; userdata: Pointer): Pointer; cdecl; external SDL_LibName;
function SDL_GetWindowData(window: PSDL_Window; const name: PChar): Pointer; cdecl; external SDL_LibName;
procedure SDL_SetWindowPosition(window: PSDL_Window; x: SInt32; y: SInt32); cdecl; external SDL_LibName;
procedure SDL_GetWindowPosition(window: PSDL_Window; x: PInt; y: PInt); cdecl; external SDL_LibName;
procedure SDL_SetWindowSize(window: PSDL_Window; w: SInt32; h: SInt32); cdecl; external SDL_LibName;
procedure SDL_GetWindowSize(window: PSDL_Window; w: PInt; h: PInt); cdecl; external SDL_LibName;
procedure SDL_SetWindowMinimumSize(window: PSDL_Window; min_w: SInt32; min_h: SInt32); cdecl; external SDL_LibName;
procedure SDL_GetWindowMinimumSize(window: PSDL_Window; w: PInt; h: PInt); cdecl; external SDL_LibName;
procedure SDL_SetWindowMaximumSize(window: PSDL_Window; max_w: SInt32; max_h: SInt32); cdecl; external SDL_LibName;
procedure SDL_GetWindowMaximumSize(window: PSDL_Window; w: PInt; h: PInt); cdecl; external SDL_LibName;
procedure SDL_SetWindowBordered(window: PSDL_Window; bordered: TSDL_Bool); cdecl; external SDL_LibName;
procedure SDL_ShowWindow(window: PSDL_Window); cdecl; external SDL_LibName;
procedure SDL_HideWindow(window: PSDL_Window); cdecl; external SDL_LibName;
procedure SDL_RaiseWindow(window: PSDL_Window); cdecl; external SDL_LibName;
procedure SDL_MaximizeWindow(window: PSDL_Window); cdecl; external SDL_LibName;
procedure SDL_MinimizeWindow(window: PSDL_Window); cdecl; external SDL_LibName;
procedure SDL_RestoreWindow(window: PSDL_Window); cdecl; external SDL_LibName;
function SDL_SetWindowFullscreen(window: PSDL_Window; flags: UInt32): SInt32; cdecl; external SDL_LibName;
function SDL_GetWindowSurface(window: PSDL_Window): PSDL_Surface; cdecl; external SDL_LibName;
function SDL_UpdateWindowSurface(window: PSDL_Window): SInt32; cdecl; external SDL_LibName;
function SDL_UpdateWindowSurfaceRects(window: PSDL_Window; rects: PSDL_Rect; numrects: SInt32): SInt32; cdecl; external SDL_LibName;
procedure SDL_SetWindowGrab(window: PSDL_Window; grabbed: TSDL_Bool); cdecl; external SDL_LibName;
function SDL_GetWindowGrab(window: PSDL_Window): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_SetWindowBrightness(window: PSDL_Window; brightness: Float): SInt32; cdecl; external SDL_LibName;
function SDL_GetWindowBrightness(window: PSDL_Window): Float; cdecl; external SDL_LibName;
function SDL_SetWindowGammaRamp(window: PSDL_Window; const red: PUInt16; const green: PUInt16; const blue: PUInt16): SInt32; cdecl; external SDL_LibName;
function SDL_GetWindowGammaRamp(window: PSDL_Window; red: PUInt16; green: PUInt16; blue: PUInt16): SInt32; cdecl; external SDL_LibName;
procedure SDL_DestroyWindow(window: PSDL_Window); cdecl; external SDL_LibName;
function SDL_IsScreenSaverEnabled: TSDL_Bool; cdecl; external SDL_LibName;
procedure SDL_EnableScreenSaver(); cdecl; external SDL_LibName;
procedure SDL_DisableScreenSaver(); cdecl; external SDL_LibName;
function SDL_GL_LoadLibrary(const path: PChar): SInt32; cdecl; external SDL_LibName;
function SDL_GL_GetProcAddress(const proc: PChar): Pointer; cdecl; external SDL_LibName;
procedure SDL_GL_UnloadLibrary(); cdecl; external SDL_LibName;
function SDL_GL_ExtensionSupported(const extension: PChar): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_GL_SetAttribute(attr: TSDL_GLattr; value: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_GL_GetAttribute(attr: TSDL_GLattr; value: PInt): SInt32; cdecl; external SDL_LibName;
function SDL_GL_CreateContext(window: PSDL_Window): TSDL_GLContext; cdecl; external SDL_LibName;
function SDL_GL_MakeCurrent(window: PSDL_Window; context: TSDL_GLContext): SInt32; cdecl; external SDL_LibName;
function SDL_GL_GetCurrentWindow(): PSDL_Window; cdecl; external SDL_LibName;
function SDL_GL_GetCurrentContext(): TSDL_GLContext; cdecl; external SDL_LibName;
function SDL_GL_SetSwapInterval(interval: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_GL_GetSwapInterval(): SInt32; cdecl; external SDL_LibName;
procedure SDL_GL_SwapWindow(window: PSDL_Window); cdecl; external SDL_LibName;
procedure SDL_GL_DeleteContext(context: TSDL_GLContext); cdecl; external SDL_LibName;
function SDL_GetNumRenderDrivers(): SInt32; cdecl; external SDL_LibName;
function SDL_GetRenderDriverInfo(index: SInt32; info: PSDL_RendererInfo): SInt32; cdecl; external SDL_LibName;
function SDL_CreateWindowAndRenderer(width: SInt32; height: SInt32; window_flags: UInt32; window: PPSDL_Window; renderer: PPSDL_Renderer): SInt32; cdecl; external SDL_LibName;
function SDL_CreateRenderer(window: PSDL_Window; index: SInt32; flags: UInt32): PSDL_Renderer; cdecl; external SDL_LibName;
function SDL_CreateSoftwareRenderer(surface: PSDL_Surface): PSDL_Renderer; cdecl; external SDL_LibName;
function SDL_GetRenderer(window: PSDL_Window): PSDL_Renderer; cdecl; external SDL_LibName;
function SDL_GetRendererInfo(renderer: PSDL_Renderer; info: PSDL_RendererInfo): SInt32; cdecl; external SDL_LibName;
function SDL_GetRendererOutputSize(renderer: PSDL_Renderer; w: PInt; h: PInt): SInt32; cdecl; external SDL_LibName;
function SDL_CreateTexture(renderer: PSDL_Renderer; format: UInt32; access: SInt32; w: SInt32; h: SInt32): PSDL_Texture; cdecl; external SDL_LibName;
function SDL_CreateTextureFromSurface(renderer: PSDL_Renderer; surface: PSDL_Surface): PSDL_Texture; cdecl; external SDL_LibName;
function SDL_QueryTexture(texture: PSDL_Texture; format: PUInt32; access: PInt; w: PInt; h: PInt): SInt32; cdecl; external SDL_LibName;
function SDL_SetTextureColorMod(texture: PSDL_Texture; r: UInt8; g: UInt8; b: UInt8): SInt32; cdecl; external SDL_LibName;
function SDL_GetTextureColorMod(texture: PSDL_Texture; r: PUInt8; g: PUInt8; b: PUInt8): SInt32; cdecl; external SDL_LibName;
function SDL_SetTextureAlphaMod(texture: PSDL_Texture; alpha: UInt8): SInt32; cdecl; external SDL_LibName;
function SDL_GetTextureAlphaMod(texture: PSDL_Texture; alpha: PUInt8): SInt32; cdecl; external SDL_LibName;
function SDL_SetTextureBlendMode(texture: PSDL_Texture; blendMode: TSDL_BlendMode): SInt32; cdecl; external SDL_LibName;
function SDL_GetTextureBlendMode(texture: PSDL_Texture; blendMode: PSDL_BlendMode): SInt32; cdecl; external SDL_LibName;
function SDL_UpdateTexture(texture: PSDL_Texture; rect: PSDL_Rect; pixels: Pointer; pitch: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_LockTexture(texture: PSDL_Texture; rect: PSDL_Rect; pixels: PPointer; pitch: PInt): SInt32; cdecl; external SDL_LibName;
procedure SDL_UnlockTexture(texture: PSDL_Texture); cdecl; external SDL_LibName;
function SDL_RenderTargetSupported(renderer: PSDL_Renderer): Boolean; cdecl; external SDL_LibName;
function SDL_SetRenderTarget(renderer: PSDL_Renderer; texture: PSDL_Texture): SInt32; cdecl; external SDL_LibName;
function SDL_GetRenderTarget(renderer: PSDL_Renderer): PSDL_Texture; cdecl; external SDL_LibName;
function SDL_RenderSetLogicalSize(renderer: PSDL_Renderer; w: SInt32; h: SInt32): SInt32; cdecl; external SDL_LibName;
procedure SDL_RenderGetLogicalSize(renderer: PSDL_Renderer; w: PInt; h: PInt); cdecl; external SDL_LibName;
function SDL_RenderSetViewport(renderer: PSDL_Renderer; const rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
procedure SDL_RenderGetViewport(renderer: PSDL_Renderer; rect: PSDL_Rect); cdecl; external SDL_LibName;
function SDL_RenderSetClipRect(renderer: PSDL_Renderer; rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
procedure SDL_RenderGetClipRect(renderer: PSDL_Renderer; rect: PSDL_Rect); cdecl; external SDL_LibName;
function SDL_RenderSetScale(renderer: PSDL_Renderer; scaleX: Float; scaleY: Float): SInt32; cdecl; external SDL_LibName;
procedure SDL_RenderGetScale(renderer: PSDL_Renderer; scaleX: PFloat; scaleY: PFloat); cdecl; external SDL_LibName;
function SDL_SetRenderDrawColor(renderer: PSDL_Renderer; r: UInt8; g: UInt8; b: UInt8; a: UInt8): SInt32; cdecl; external SDL_LibName;
function SDL_GetRenderDrawColor(renderer: PSDL_Renderer; r: PUInt8; g: PUInt8; b: PUInt8; a: PUInt8): SInt32; cdecl; external SDL_LibName;
function SDL_SetRenderDrawBlendMode(renderer: PSDL_Renderer; blendMode: TSDL_BlendMode): SInt32; cdecl; external SDL_LibName;
function SDL_GetRenderDrawBlendMode(renderer: PSDL_Renderer; blendMode: PSDL_BlendMode): SInt32; cdecl; external SDL_LibName;
function SDL_RenderClear(renderer: PSDL_Renderer): SInt32; cdecl; external SDL_LibName;
function SDL_RenderDrawPoint(renderer: PSDL_Renderer; x: SInt32; y: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_RenderDrawPoints(renderer: PSDL_Renderer; points: PSDL_Point; count: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_RenderDrawLine(renderer: PSDL_Renderer; x1: SInt32; y1: SInt32; x2: SInt32; y2: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_RenderDrawLines(renderer: PSDL_Renderer; points: PSDL_Point; count: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_RenderDrawRect(renderer: PSDL_Renderer; rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
function SDL_RenderDrawRects(renderer: PSDL_Renderer; rects: PSDL_Rect; count: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_RenderFillRect(renderer: PSDL_Renderer; rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
function SDL_RenderFillRects(renderer: PSDL_Renderer; rects: PSDL_Rect; count: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_RenderCopy(renderer: PSDL_Renderer; texture: PSDL_Texture; srcrect: PSDL_Rect; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;
function SDL_RenderCopyEx(renderer: PSDL_Renderer; texture: PSDL_Texture; const srcrect: PSDL_Rect; dstrect: PSDL_Rect; angle: Double; center: PSDL_Point; flip: PSDL_RendererFlip): SInt32; cdecl; external SDL_LibName;
function SDL_RenderReadPixels(renderer: PSDL_Renderer; rect: PSDL_Rect; format: UInt32; pixels: Pointer; pitch: SInt32): SInt32; cdecl; external SDL_LibName;
procedure SDL_RenderPresent(renderer: PSDL_Renderer); cdecl; external SDL_LibName;
procedure SDL_DestroyTexture(texture: PSDL_Texture); cdecl; external SDL_LibName;
procedure SDL_DestroyRenderer(renderer: PSDL_Renderer); cdecl; external SDL_LibName;
function SDL_GL_BindTexture(texture: PSDL_Texture; texw: PFloat; texh: PFloat): SInt32; cdecl; external SDL_LibName;
function SDL_GL_UnbindTexture(texture: PSDL_Texture): SInt32; cdecl; external SDL_LibName;
function SDL_GetKeyboardFocus(): PSDL_Window; cdecl; external SDL_LibName;
function SDL_GetKeyboardState(numkeys: PInt): PUInt8; cdecl; external SDL_LibName;
function SDL_GetModState(): TSDL_KeyMod; cdecl; external SDL_LibName;
procedure SDL_SetModState(modstate: TSDL_KeyMod); cdecl; external SDL_LibName;
function SDL_GetKeyFromScancode(scancode: TSDL_ScanCode): TSDL_KeyCode; cdecl; external SDL_LibName;
function SDL_GetScancodeFromKey(key: TSDL_KeyCode): TSDL_ScanCode; cdecl; external SDL_LibName;
function SDL_GetScancodeName(scancode: TSDL_ScanCode): PChar; cdecl; external SDL_LibName;
function SDL_GetScancodeFromName(const name: PChar): TSDL_ScanCode; cdecl; external SDL_LibName;
function SDL_GetKeyName(key: TSDL_ScanCode): PChar; cdecl; external SDL_LibName;
function SDL_GetKeyFromName(const name: PChar): TSDL_KeyCode; cdecl; external SDL_LibName;
procedure SDL_StartTextInput(); cdecl; external SDL_LibName;
function SDL_IsTextInputActive(): TSDL_Bool; cdecl; external SDL_LibName;
procedure SDL_StopTextInput(); cdecl; external SDL_LibName;
procedure SDL_SetTextInputRect(rect: PSDL_Rect); cdecl; external SDL_LibName;
function SDL_HasScreenKeyboardSupport(): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_IsScreenKeyboardShown(window: PSDL_Window): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_GetMouseFocus(): PSDL_Window; cdecl; external SDL_LibName;
function SDL_GetMouseState(x: PInt; y: PInt): UInt32; cdecl; external SDL_LibName;
function SDL_GetRelativeMouseState(x: PInt; y: PInt): UInt32; cdecl; external SDL_LibName;
procedure SDL_WarpMouseInWindow(window: PSDL_Window; x: SInt32; y: SInt32); cdecl; external SDL_LibName;
function SDL_SetRelativeMouseMode(enabled: TSDL_Bool): SInt32; cdecl; external SDL_LibName;
function SDL_GetRelativeMouseMode(): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_CreateCursor(const data: PUInt8; const mask: PUInt8; w: SInt32; h: SInt32; hot_x: SInt32; hot_y: SInt32): PSDL_Cursor; cdecl; external SDL_LibName;
function SDL_CreateColorCursor(surface: PSDL_Surface; hot_x: SInt32; hot_y: SInt32): PSDL_Cursor; cdecl; external SDL_LibName;
function SDL_CreateSystemCursor(id: TSDL_SystemCursor): PSDL_Cursor; cdecl; external SDL_LibName;
procedure SDL_SetCursor(cursor: PSDL_Cursor); cdecl; external SDL_LibName;
function SDL_GetCursor(): PSDL_Cursor; cdecl; external SDL_LibName;
procedure SDL_FreeCursor(cursor: PSDL_Cursor); cdecl; external SDL_LibName;
function SDL_ShowCursor(toggle: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_NumJoysticks(): SInt32; cdecl; external SDL_LibName;
function SDL_JoystickNameForIndex(device_index: SInt32): PChar; cdecl; external SDL_LibName;
function SDL_JoystickOpen(device_index: SInt32): PSDL_Joystick; cdecl; external SDL_LibName;
function SDL_JoystickName(joystick: PSDL_Joystick): PChar; cdecl; external SDL_LibName;
function SDL_JoystickGetDeviceGUID(device_index: SInt32): TSDL_JoystickGUID; cdecl; external SDL_LibName;
function SDL_JoystickGetGUID(joystick: PSDL_Joystick): TSDL_JoystickGUID; cdecl; external SDL_LibName;
procedure SDL_JoystickGetGUIDString(guid: TSDL_JoystickGUId; pszGUID: PChar; cbGUID: SInt32); cdecl; external SDL_LibName;
function SDL_JoystickGetGUIDFromString(const pchGUID: PChar): TSDL_JoystickGUID; cdecl; external SDL_LibName;
function SDL_JoystickGetAttached(joystick: PSDL_Joystick): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_JoystickInstanceID(joystick: PSDL_Joystick): TSDL_JoystickID; cdecl; external SDL_LibName;
function SDL_JoystickNumAxes(joystick: PSDL_Joystick): SInt32; cdecl; external SDL_LibName;
function SDL_JoystickNumBalls(joystick: PSDL_Joystick): SInt32; cdecl; external SDL_LibName;
function SDL_JoystickNumHats(joystick: PSDL_Joystick): SInt32; cdecl; external SDL_LibName;
function SDL_JoystickNumButtons(joystick: PSDL_Joystick): SInt32; cdecl; external SDL_LibName;
procedure SDL_JoystickUpdate(); cdecl; external SDL_LibName;
function SDL_JoystickEventState(state: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_JoystickGetAxis(joystick: PSDL_Joystick; axis: SInt32): SInt16; cdecl; external SDL_LibName;
function SDL_JoystickGetHat(joystick: PSDL_Joystick; hat: SInt32): UInt8; cdecl; external SDL_LibName;
function SDL_JoystickGetBall(joystick: PSDL_Joystick; ball: SInt32; dx: PInt; dy: PInt): SInt32; cdecl; external SDL_LibName;
function SDL_JoystickGetButton(joystick: PSDL_Joystick; button: SInt32): UInt8; cdecl; external SDL_LibName;
procedure SDL_JoystickClose(joystick: PSDL_Joystick); cdecl; external SDL_LibName;
function SDL_GameControllerAddMapping( mappingString: PChar ): Integer; cdecl; external SDL_LibName;
function SDL_GameControllerMappingForGUID( guid: TSDL_JoystickGUID ): PChar; cdecl; external SDL_LibName;
function SDL_GameControllerMapping( gamecontroller: PSDL_GameController ): PChar; cdecl; external SDL_LibName;
function SDL_IsGameController(joystick_index: Integer): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_GameControllerNameForIndex(joystick_index: Integer): PChar; cdecl; external SDL_LibName;
function SDL_GameControllerOpen(joystick_index: Integer): PSDL_GameController; cdecl; external SDL_LibName;
function SDL_GameControllerName(gamecontroller: PSDL_GameController): PChar; cdecl; external SDL_LibName;
function SDL_GameControllerGetAttached(gamecontroller: PSDL_GameController): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_GameControllerGetJoystick(gamecontroller: PSDL_GameController): PSDL_Joystick; cdecl; external SDL_LibName;
function SDL_GameControllerEventState(state: Integer): Integer; cdecl; external SDL_LibName;
procedure SDL_GameControllerUpdate(); cdecl; external SDL_LibName;
function SDL_GameControllerGetAxisFromString(pchString: PChar): TSDL_GameControllerAxis; cdecl; external SDL_LibName;
function SDL_GameControllerGetStringForAxis(axis: TSDL_GameControllerAxis): PChar; cdecl; external SDL_LibName;
function SDL_GameControllerGetBindForAxis(gamecontroller: PSDL_GameController; axis: TSDL_GameControllerAxis): TSDL_GameControllerButtonBind; cdecl; external SDL_LibName;
function SDL_GameControllerGetAxis(gamecontroller: PSDL_GameController; axis: TSDL_GameControllerAxis): SInt16; cdecl; external SDL_LibName;
function SDL_GameControllerGetButtonFromString(pchString: PChar): TSDL_GameControllerButton; cdecl; external SDL_LibName;
function SDL_GameControllerGetStringForButton(button: TSDL_GameControllerButton): PChar; cdecl; external SDL_LibName;
function SDL_GameControllerGetBindForButton(gamecontroller: PSDL_GameController; button: TSDL_GameControllerButton): TSDL_GameControllerButtonBind; cdecl; external SDL_LibName;
function SDL_GameControllerGetButton(gamecontroller: PSDL_GameController; button: TSDL_GameControllerButton): UInt8; cdecl; external SDL_LibName;
procedure SDL_GameControllerClose(gamecontroller: PSDL_GameController); cdecl; external SDL_LibName;
function SDL_NumHaptics(): Integer; cdecl; external SDL_LibName;
function SDL_HapticName(device_index: Integer): PChar; cdecl; external SDL_LibName;
function SDL_HapticOpen(device_index: Integer): PSDL_Haptic; cdecl; external SDL_LibName;
function SDL_HapticOpened(device_index: Integer): Integer; cdecl; external SDL_LibName;
function SDL_HapticIndex(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_MouseIsHaptic() : Integer; cdecl; external SDL_LibName;
function SDL_HapticOpenFromMouse() : PSDL_Haptic; cdecl; external SDL_LibName;
function SDL_JoystickIsHaptic(joystick: PSDL_Joystick): Integer; cdecl; external SDL_LibName;
function SDL_HapticOpenFromJoystick(joystick: PSDL_Joystick): PSDL_Haptic; cdecl; external SDL_LibName;
procedure SDL_HapticClose(haptic: PSDL_Haptic); cdecl; external SDL_LibName;
function SDL_HapticNumEffects(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_HapticNumEffectsPlaying(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_HapticQuery(haptic: PSDL_Haptic): UInt32; cdecl; external SDL_LibName;
function SDL_HapticNumAxes(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_HapticEffectSupported(haptic: PSDL_Haptic; effect: PSDL_HapticEffect): Integer; cdecl; external SDL_LibName;
function SDL_HapticNewEffect(haptic: PSDL_Haptic; effect: PSDL_HapticEffect): Integer; cdecl; external SDL_LibName;
function SDL_HapticUpdateEffect(haptic: PSDL_Haptic; effect: Integer; data: PSDL_HapticEffect): Integer; cdecl; external SDL_LibName;
function SDL_HapticRunEffect(haptic: PSDL_Haptic; effect: Integer; iterations: UInt32): Integer; cdecl; external SDL_LibName;
function SDL_HapticStopEffect(haptic: PSDL_Haptic; effect: Integer): Integer; cdecl; external SDL_LibName;
procedure SDL_HapticDestroyEffect(haptic: PSDL_Haptic; effect: Integer); cdecl; external SDL_LibName;
function SDL_HapticGetEffectStatus(haptic: PSDL_Haptic; effect: Integer): Integer; cdecl; external SDL_LibName;
function SDL_HapticSetGain(haptic: PSDL_Haptic; gain: Integer): Integer; cdecl; external SDL_LibName;
function SDL_HapticSetAutocenter(haptic: PSDL_Haptic; autocenter: Integer): Integer; cdecl; external SDL_LibName;
function SDL_HapticPause(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_HapticUnpause(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_HapticStopAll(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_HapticRumbleSupported(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_HapticRumbleInit(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_HapticRumblePlay(haptic: PSDL_Haptic; strength: Float; length: UInt32): Integer; cdecl; external SDL_LibName;
function SDL_HapticRumbleStop(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;
function SDL_GetNumTouchDevices(): SInt32; cdecl; external SDL_LibName;
function SDL_GetTouchDevice(index: SInt32): TSDL_TouchID; cdecl; external SDL_LibName;
function SDL_GetNumTouchFingers(touchID: TSDL_TouchID): SInt32; cdecl; external SDL_LibName;
function SDL_GetTouchFinger(touchID: TSDL_TouchID; index: SInt32): PSDL_Finger; cdecl; external SDL_LibName;
function SDL_RecordGesture(touchId: TSDL_TouchID): SInt32; cdecl; external SDL_LibName;
function SDL_SaveAllDollarTemplates(src: PSDL_RWops): SInt32; cdecl; external SDL_LibName;
function SDL_SaveDollarTemplate(gestureId: TSDL_GestureID; src: PSDL_RWops): SInt32; cdecl; external SDL_LibName;
function SDL_LoadDollarTemplates(touchId: TSDL_TouchID; src: PSDL_RWops): SInt32; cdecl; external SDL_LibName;
procedure SDL_PumpEvents(); cdecl; external SDL_LibName;
function SDL_PeepEvents(events: PSDL_Event; numevents: SInt32; action: TSDL_EventAction; minType: UInt32; maxType: UInt32): SInt32; cdecl; external SDL_LibName;
function SDL_HasEvent(type_: UInt32): TSDL_Bool; cdecl; external SDL_LibName;
function SDL_HasEvents(minType: UInt32; maxType: UInt32): TSDL_Bool; cdecl; external SDL_LibName;
procedure SDL_FlushEvent(type_: UInt32); cdecl; external SDL_LibName;
procedure SDL_FlushEvents(minType: UInt32; maxType: UInt32); cdecl; external SDL_LibName;
function SDL_PollEvent(event: PSDL_Event): SInt32; cdecl; external SDL_LibName;
function SDL_WaitEvent(event: PSDL_Event): SInt32; cdecl; external SDL_LibName;
function SDL_WaitEventTimeout(event: PSDL_Event; timeout: SInt32): SInt32; cdecl; external SDL_LibName;
function SDL_PushEvent(event: PSDL_Event): SInt32; cdecl; external SDL_LibName;
procedure SDL_SetEventFilter(filter: TSDL_EventFilter; userdata: Pointer); cdecl; external SDL_LibName;
function SDL_GetEventFilter(filter: PSDL_EventFilter; userdata: Pointer): TSDL_Bool; cdecl; external SDL_LibName;
procedure SDL_AddEventWatch(filter: TSDL_EventFilter; userdata: Pointer); cdecl; external SDL_LibName;
procedure SDL_DelEventWatch(filter: TSDL_EventFilter; userdata: Pointer); cdecl; external SDL_LibName;
procedure SDL_FilterEvents(filter: TSDL_EventFilter; userdata: Pointer); cdecl; external SDL_LibName;
function SDL_EventState(type_: UInt32; state: SInt32): UInt8; cdecl; external SDL_LibName;
function SDL_GetEventState(type_: UInt32): UInt8;
function SDL_RegisterEvents(numevents: SInt32): UInt32; cdecl; external SDL_LibName;
function SDL_Init(flags: UInt32): SInt32; cdecl; external SDL_LibName;
function SDL_InitSubSystem(flags: UInt32): SInt32; cdecl; external SDL_LibName;
procedure SDL_QuitSubSystem(flags: UInt32); cdecl; external SDL_LibName;
function SDL_WasInit(flags: UInt32): UInt32; cdecl; external SDL_LibName;
procedure SDL_Quit(); cdecl; external SDL_LibName;
function SDL_LoadObject(sofile: PChar): Pointer; cdecl; external SDL_LibName;
function SDL_LoadFunction(handle: Pointer; name: PChar): Pointer; cdecl; external SDL_LibName;
procedure SDL_UnloadObject(handle: Pointer); cdecl; external SDL_LibName;
function SDL_GetPlatform(): PChar; cdecl; external SDL_LibName;
function SDL_SetHintWithPriority( const name: PChar; const value: PChar; priority: SDL_HintPriority) : boolean; cdecl; external SDL_LibName;
function SDL_SetHint( const name: PChar; const value: PChar) : boolean; cdecl; external SDL_LibName;
function SDL_GetHint( const name: PChar): PChar; cdecl; external SDL_LibName;
procedure SDL_AddHintCallback(const name: PChar; callback: TSDL_HintCallback; userdata: Pointer); cdecl; external SDL_LibName;
procedure SDL_DelHintCallback(const name: PChar; callback: TSDL_HintCallback; userdata: Pointer); cdecl; external SDL_LibName;
procedure SDL_ClearHints(); cdecl; external SDL_LibName;
function SDL_ShowMessageBox(messageboxdata: PSDL_MessageBoxData; buttonid: PInt): Integer; cdecl; external SDL_LibName;
function SDL_ShowSimpleMessageBox(flags: UInt32; title: PChar; _message: PChar; window: PSDL_Window): Integer; cdecl; external SDL_LibName;
function SDL_Swap32(D: Uint32): Uint32;
function SDLStreamSetup( stream : TStream ) : PSDL_RWops;
function LoadSDLBMPFromStream( Stream : TStream ) : PSDL_Surface;
procedure SaveSDLBMPToStream( SDL_Surface : PSDL_Surface; stream : TStream );
procedure SDLStreamCloseRWops( SDL_RWops : PSDL_RWops );

Types

DWord = LongWord;
Float = Single;
PFloat = ˆFloat;
PInt = ˆLongInt;
PPSDL_Renderer = ˆPSDL_Renderer;
PPSDL_Window = ˆPSDL_Window;
PPUInt8 = ˆPUInt8;
PSDLPantalla = ˆTSDLPantalla;
PSDL_AudioCVT = ˆTSDL_AudioCVT;
PSDL_AudioSpec = ˆTSDL_AudioSpec;
PSDL_BlendMode = ˆTSDL_BlendMode;
PSDL_BlitMap = ˆTSDL_BlitMap;
PSDL_Color = ˆTSDL_Color;
PSDL_Colour = ˆTSDL_Colour;
PSDL_Cond = Pointer;
PSDL_Cursor = Pointer;
PSDL_DisplayMode = ˆTSDL_DisplayMode;
PSDL_Event = ˆTSDL_Event;
PSDL_EventFilter = ˆTSDL_EventFilter;
PSDL_Finger = ˆTSDL_Finger;
PSDL_FingerID = ˆTSDL_FingerID;
PSDL_GameController = ˆTSDL_GameController;
PSDL_Haptic = ˆTSDL_Haptic;
PSDL_HapticEffect = ˆTSDL_HapticEffect;
PSDL_Joystick = Pointer;
PSDL_KeyCode = ˆTSDL_KeyCode;
PSDL_KeyMod = ˆTSDL_KeyMod;
PSDL_Keysym = ˆTSDL_Keysym;
PSDL_MessageBoxButtonData = ˆTSDL_MessageBoxButtonData;
PSDL_MessageBoxColor = ˆTSDL_MessageBoxColor;
PSDL_MessageBoxColorScheme = ˆTSDL_MessageBoxColorScheme;
PSDL_MessageBoxColorType = ˆTSDL_MessageBoxColorType;
PSDL_MessageBoxData = ˆTSDL_MessageBoxData;
PSDL_Mutex = ˆTSDL_Mutex;
PSDL_Palette = ˆTSDL_Palette;
PSDL_PixelFormat = ˆTSDL_PixelFormat;
PSDL_Point = ˆTSDL_Point;
PSDL_Rect = ˆTSDL_Rect;
PSDL_Renderer = Pointer;
PSDL_RendererFlags = ˆTSDL_RendererFlags;
PSDL_RendererFlip = ˆTSDL_RendererFlip;
PSDL_RendererInfo = ˆTSDL_RendererInfo;
PSDL_RWops = ˆTSDL_RWops;
PSDL_ScanCode = ˆTSDL_ScanCode;
PSDL_Sem = Pointer;
PSDL_Surface = ˆTSDL_Surface;
PSDL_SystemCursor = ˆTSDL_SystemCursor;
PSDL_SysWMEvent = ˆTSDL_SysWMEvent;
PSDL_SysWMinfo = ˆTSDL_SysWMinfo;
PSDL_SysWMmsg = ˆTSDL_SysWMmsg;
PSDL_Texture = Pointer;
PSDL_TextureAccess = ˆTSDL_TextureAccess;
PSDL_TextureModulate = ˆTSDL_TextureModulate;
PSDL_Thread = ˆTSDL_Thread;
PSDL_ThreadFunction = ˆTSDL_ThreadFunction;
PSDL_TouchID = ˆTSDL_TouchID;
PSDL_Version = ˆTSDL_Version;
PSDL_Window = ˆTSDL_Window;
PSDL_WindowShapeMode = ˆTSDL_WindowShapeMode;
PSDL_WindowShaper = ˆTSDL_WindowShaper;
PSDL_WindowUserData = ˆTSDL_WindowUserData;
PShortInt = ˆShortInt;
PSInt16 = ˆSInt16;
PSInt64 = ˆSInt64;
PSInt8 = ˆSInt8;
PUInt16 = ˆUInt16;
PUInt32 = ˆUInt32;
PUInt8 = ˆUInt8;
PUInt8Array = ˆTUInt8Array;
SDL_HintPriority = (...);
SInt16 = smallint;
SInt32 = LongInt;
SInt64 = Int64;
SInt8 = Shortint;
size_t = UInt32;
TClose = function(context: PSDL_RWops): SInt32; cdecl;
TpfnSDL_CurrentBeginThread = function(SecurityAttributes: Pointer; StackSize: LongWord; ThreadFunc: TThreadFunc; Parameter: Pointer; CreationFlags: LongWord; var ThreadId: TThreadID): Integer;
TpfnSDL_CurrentEndThread = procedure(ExitCode: Integer);
TRead = function(context: PSDL_RWops; ptr: Pointer; size: size_t; maxnum: size_t): size_t; cdecl;
TSDL_AudioCallback = procedure(userdata: Pointer; stream: PUInt8; len: Integer);
TSDL_AudioDeviceID = UInt32;
TSDL_AudioFilter = procedure(cvt: PSDL_AudioCVT; format: TSDL_AudioFormat);
TSDL_AudioFormat = UInt16;
TSDL_AudioStatus = (...);
TSDL_BlendMode = DWord;
TSDL_Blit = function(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32;
TSDL_Bool = (...);
TSDL_Colour = TSDL_Color;
TSDL_ErrorCode = (...);
TSDL_EventAction = Word;
TSDL_EventFilter = function( event: PSDL_Event ): Integer; cdecl;
TSDL_EventType = Word;
TSDL_FingerID = SInt64;
TSDL_GameController = Pointer;
TSDL_GameControllerAxis = Byte;
TSDL_GameControllerBindType = (...);
TSDL_GameControllerButton = Byte;
TSDL_GestureID = SInt64;
TSDL_GLattr = DWord;
TSDL_GLContext = Pointer;
TSDL_GLcontextFlag = DWord;
TSDL_GLprofile = DWord;
TSDL_HintCallback = procedure(userdata: Pointer; const name: PChar; const oldValue: PChar; const newValue: PChar);
TSDL_JoystickID = SInt32;
TSDL_KeyCode = SInt32;
TSDL_KeyMod = Word;
TSDL_MessageBoxButtonFlags = Byte;
TSDL_MessageBoxColorType = (...);
TSDL_MessageBoxFlags = Byte;
TSDL_PowerState = (...);
TSDL_RendererFlags = Word;
TSDL_RendererFlip = (...);
TSDL_ScanCode = DWord;
TSDL_SystemCursor = Word;
TSDL_TextureAccess = (...);
TSDL_TextureModulate = (...);
TSDL_ThreadFunction = function(data: Pointer): Integer; cdecl;
TSDL_ThreadID = LongWord;
TSDL_ThreadPriority = (...);
TSDL_TimerCallback = function(interval: UInt32; param: Pointer): UInt32;
TSDL_TimerID = SInt32;
TSDL_TLSID = Cardinal;
TSDL_TouchID = SInt64;
TSDL_WindowEventID = DWord;
TSDL_WindowFlags = DWord;
TSeek = function(context: PSDL_RWops; offset: SInt64; whence: SInt32): SInt64; cdecl;
TSize = function(context: PSDL_RWops): SInt64; cdecl;
TThreadID = Cardinal;
TUInt8Array = array [0..MAXINT shr 1] of UInt8;
TWindowShapeMode = (...);
TWrite = function(context: PSDL_RWops; const ptr: Pointer; size: size_t; num: size_t): size_t; cdecl;
UInt16 = word;
UInt32 = Cardinal;
UInt8 = Byte;

Constants

SDL_LibName = 'sdl2.dll';
SDL_MAJOR_VERSION = 2;
SDL_MINOR_VERSION = 0;
SDL_PATCHLEVEL = 0;
ERR_MAX_STRLEN = 128;
ERR_MAX_ARGS = 5;
SDL_RWOPS_UNKNOWN = 0;
SDL_RWOPS_WINFILE = 1;
SDL_RWOPS_STDFILE = 2;
SDL_RWOPS_JNIFILE = 3;
SDL_RWOPS_MEMORY = 4;
SDL_RWOPS_MEMORY_RO = 5;
RW_SEEK_SET = 0;
RW_SEEK_CUR = 1;
RW_SEEK_END = 2;
SDL_AUDIO_MASK_BITSIZE = ($FF);
SDL_AUDIO_MASK_DATATYPE = (1 shl 8);
SDL_AUDIO_MASK_ENDIAN = (1 shl 12);
SDL_AUDIO_MASK_SIGNED = (1 shl 15);
AUDIO_U8 = $0008;
AUDIO_S8 = $8008;
AUDIO_U16LSB = $0010;
AUDIO_S16LSB = $8010;
AUDIO_U16MSB = $1010;
AUDIO_S16MSB = $9010;
AUDIO_U16 = AUDIO_U16LSB;
AUDIO_S16 = AUDIO_S16LSB;
AUDIO_S32LSB = $8020;
AUDIO_S32MSB = $9020;
AUDIO_S32 = AUDIO_S32LSB;
AUDIO_F32LSB = $8120;
AUDIO_F32MSB = $9120;
AUDIO_F32 = AUDIO_F32LSB;
SDL_AUDIO_ALLOW_FREQUENCY_CHANGE = $00000001;
SDL_AUDIO_ALLOW_FORMAT_CHANGE = $00000002;
SDL_AUDIO_ALLOW_CHANNELS_CHANGE = $00000004;
SDL_AUDIO_ALLOW_ANY_CHANGE = (SDL_AUDIO_ALLOW_FREQUENCY_CHANGE or SDL_AUDIO_ALLOW_FORMAT_CHANGE or SDL_AUDIO_ALLOW_CHANNELS_CHANGE);
SDL_MIX_MAXVOLUME = 128;
SDL_MUTEX_TIMEDOUT = 1;
SDL_ALPHA_OPAQUE = 255;
SDL_ALPHA_TRANSPARENT = 0;
SDL_PIXELTYPE_UNKNOWN = 0;
SDL_PIXELTYPE_INDEX1 = 1;
SDL_PIXELTYPE_INDEX4 = 2;
SDL_PIXELTYPE_INDEX8 = 3;
SDL_PIXELTYPE_PACKED8 = 4;
SDL_PIXELTYPE_PACKED16 = 5;
SDL_PIXELTYPE_PACKED32 = 6;
SDL_PIXELTYPE_ARRAYU8 = 7;
SDL_PIXELTYPE_ARRAYU16 = 8;
SDL_PIXELTYPE_ARRAYU32 = 9;
SDL_PIXELTYPE_ARRAYF16 = 10;
SDL_PIXELTYPE_ARRAYF32 = 11;
SDL_BITMAPORDER_NONE = 0;
SDL_BITMAPORDER_4321 = 1;
SDL_BITMAPORDER_1234 = 2;
SDL_PACKEDORDER_NONE = 0;
SDL_PACKEDORDER_XRGB = 1;
SDL_PACKEDORDER_RGBX = 2;
SDL_PACKEDORDER_ARGB = 3;
SDL_PACKEDORDER_RGBA = 4;
SDL_PACKEDORDER_XBGR = 5;
SDL_PACKEDORDER_BGRX = 6;
SDL_PACKEDORDER_ABGR = 7;
SDL_PACKEDORDER_BGRA = 8;
SDL_ARRAYORDER_NONE = 0;
SDL_ARRAYORDER_RGB = 1;
SDL_ARRAYORDER_RGBA = 2;
SDL_ARRAYORDER_ARGB = 3;
SDL_ARRAYORDER_BGR = 4;
SDL_ARRAYORDER_BGRA = 5;
SDL_ARRAYORDER_ABGR = 6;
SDL_PACKEDLAYOUT_NONE = 0;
SDL_PACKEDLAYOUT_332 = 1;
SDL_PACKEDLAYOUT_4444 = 2;
SDL_PACKEDLAYOUT_1555 = 3;
SDL_PACKEDLAYOUT_5551 = 4;
SDL_PACKEDLAYOUT_565 = 5;
SDL_PACKEDLAYOUT_8888 = 6;
SDL_PACKEDLAYOUT_2101010 = 7;
SDL_PACKEDLAYOUT_1010102 = 8;
SDL_PIXELFORMAT_UNKNOWN = 0;
SDL_PIXELFORMAT_INDEX1LSB = (1 shl 28) or (SDL_PIXELTYPE_INDEX1 shl 24) or (SDL_BITMAPORDER_4321 shl 20) or (0 shl 16) or (1 shl 8) or (0 shl 0);
SDL_PIXELFORMAT_INDEX1MSB = (1 shl 28) or (SDL_PIXELTYPE_INDEX1 shl 24) or (SDL_BITMAPORDER_1234 shl 20) or (0 shl 16) or (1 shl 8) or (0 shl 0);
SDL_PIXELFORMAT_INDEX4LSB = (1 shl 28) or (SDL_PIXELTYPE_INDEX4 shl 24) or (SDL_BITMAPORDER_4321 shl 20) or (0 shl 16) or (4 shl 8) or (0 shl 0);
SDL_PIXELFORMAT_INDEX4MSB = (1 shl 28) or (SDL_PIXELTYPE_INDEX4 shl 24) or (SDL_BITMAPORDER_1234 shl 20) or (0 shl 16) or (4 shl 8) or (0 shl 0);
SDL_PIXELFORMAT_INDEX8 = (1 shl 28) or (SDL_PIXELTYPE_PACKED8 shl 24) or (0 shl 20) or (0 shl 16) or (8 shl 8) or (1 shl 0);
SDL_PIXELFORMAT_RGB332 = (1 shl 28) or (SDL_PIXELTYPE_PACKED8 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_332 shl 16) or (8 shl 8) or (1 shl 0);
SDL_PIXELFORMAT_RGB444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (12 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_RGB555 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (15 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_BGR555 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XBGR shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (15 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_ARGB4444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_ARGB shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_RGBA4444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_RGBA shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_ABGR4444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_ABGR shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_BGRA4444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_BGRA shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_ARGB1555 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_ARGB shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_RGBA5551 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_RGBA shl 20) or (SDL_PACKEDLAYOUT_5551 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_ABGR1555 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_ABGR shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_BGRA5551 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_BGRA shl 20) or (SDL_PACKEDLAYOUT_5551 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_RGB565 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_565 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_BGR565 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XBGR shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (16 shl 8) or (2 shl 0);
SDL_PIXELFORMAT_RGB24 = (1 shl 28) or (SDL_PIXELTYPE_ARRAYU8 shl 24) or (SDL_ARRAYORDER_RGB shl 20) or (0 shl 16) or (24 shl 8) or (3 shl 0);
SDL_PIXELFORMAT_BGR24 = (1 shl 28) or (SDL_PIXELTYPE_ARRAYU8 shl 24) or (SDL_ARRAYORDER_BGR shl 20) or (0 shl 16) or (24 shl 8) or (3 shl 0);
SDL_PIXELFORMAT_RGB888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (24 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_RGBX8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_RGBX shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (24 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_BGR888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_XBGR shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (24 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_BGRX8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_BGRX shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (24 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_ARGB8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_ARGB shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (32 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_RGBA8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_RGBA shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (32 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_ABGR8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_ABGR shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (32 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_BGRA8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_RGBX shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (32 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_ARGB2101010 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_ARGB shl 20) or (SDL_PACKEDLAYOUT_2101010 shl 16)or (32 shl 8) or (4 shl 0);
SDL_PIXELFORMAT_YV12 = (Integer('Y') ) or (Integer('V') shl 8) or (Integer('1') shl 16) or (Integer('2') shl 24);
SDL_PIXELFORMAT_IYUV = (Integer('I') ) or (Integer('Y') shl 8) or (Integer('U') shl 16) or (Integer('V') shl 24);
SDL_PIXELFORMAT_YUY2 = (Integer('Y') ) or (Integer('U') shl 8) or (Integer('Y') shl 16) or (Integer('2') shl 24);
SDL_PIXELFORMAT_UYVY = (Integer('U') ) or (Integer('Y') shl 8) or (Integer('V') shl 16) or (Integer('Y') shl 24);
SDL_PIXELFORMAT_YVYU = (Integer('Y') ) or (Integer('V') shl 8) or (Integer('Y') shl 16) or (Integer('U') shl 24);
SDL_BLENDMODE_NONE = $00000000;
SDL_BLENDMODE_BLEND = $00000001;
SDL_BLENDMODE_ADD = $00000002;
SDL_BLENDMODE_MOD = $00000004;
SDL_SWSURFACE = 0;
SDL_PREALLOC = $00000001;
SDL_RLEACCEL = $00000002;
SDL_DONTFREE = $00000004;
SDL_NONSHAPEABLE_WINDOW = -1;
SDL_INVALID_SHAPE_ARGUMENT = -2;
SDL_WINDOW_LACKS_SHAPE = -3;
SDL_WINDOW_FULLSCREEN = $00000001;
SDL_WINDOW_OPENGL = $00000002;
SDL_WINDOW_SHOWN = $00000004;
SDL_WINDOW_HIDDEN = $00000008;
SDL_WINDOW_BORDERLESS = $00000010;
SDL_WINDOW_RESIZABLE = $00000020;
SDL_WINDOW_MINIMIZED = $00000040;
SDL_WINDOW_MAXIMIZED = $00000080;
SDL_WINDOW_INPUT_GRABBED = $00000100;
SDL_WINDOW_INPUT_FOCUS = $00000200;
SDL_WINDOW_MOUSE_FOCUS = $00000400;
SDL_WINDOW_FULLSCREEN_DESKTOP = SDL_WINDOW_FULLSCREEN or $00001000;
SDL_WINDOW_FOREIGN = $00000800;
SDL_WINDOWPOS_UNDEFINED_MASK = $1FFF0000;
SDL_WINDOWPOS_UNDEFINED = SDL_WINDOWPOS_UNDEFINED_MASK or 0;
SDL_WINDOWPOS_CENTERED_MASK = $2FFF0000;
SDL_WINDOWPOS_CENTERED = SDL_WINDOWPOS_CENTERED_MASK or 0;
SDL_WINDOWEVENT_NONE = 0;
SDL_WINDOWEVENT_SHOWN = 1;
SDL_WINDOWEVENT_HIDDEN = 2;
SDL_WINDOWEVENT_EXPOSED = 3;
SDL_WINDOWEVENT_MOVED = 4;
SDL_WINDOWEVENT_RESIZED = 5;
SDL_WINDOWEVENT_SIZE_CHANGED = 6;
SDL_WINDOWEVENT_MINIMIZED = 7;
SDL_WINDOWEVENT_MAXIMIZED = 8;
SDL_WINDOWEVENT_RESTORED = 9;
SDL_WINDOWEVENT_ENTER = 10;
SDL_WINDOWEVENT_LEAVE = 11;
SDL_WINDOWEVENT_FOCUS_GAINED = 12;
SDL_WINDOWEVENT_FOCUS_LOST = 13;
SDL_WINDOWEVENT_CLOSE = 14;
SDL_GL_RED_SIZE = 0;
SDL_GL_GREEN_SIZE = 1;
SDL_GL_BLUE_SIZE = 2;
SDL_GL_ALPHA_SIZE = 3;
SDL_GL_BUFFER_SIZE = 4;
SDL_GL_DOUBLEBUFFER = 5;
SDL_GL_DEPTH_SIZE = 6;
SDL_GL_STENCIL_SIZE = 7;
SDL_GL_ACCUM_RED_SIZE = 8;
SDL_GL_ACCUM_GREEN_SIZE = 9;
SDL_GL_ACCUM_BLUE_SIZE = 10;
SDL_GL_ACCUM_ALPHA_SIZE = 11;
SDL_GL_STEREO = 12;
SDL_GL_MULTISAMPLEBUFFERS = 13;
SDL_GL_MULTISAMPLESAMPLES = 14;
SDL_GL_ACCELERATED_VISUAL = 15;
SDL_GL_RETAINED_BACKING = 16;
SDL_GL_CONTEXT_MAJOR_VERSION = 17;
SDL_GL_CONTEXT_MINOR_VERSION = 18;
SDL_GL_CONTEXT_EGL = 19;
SDL_GL_CONTEXT_FLAGS = 20;
SDL_GL_CONTEXT_PROFILE_MASK = 21;
SDL_GL_SHARE_WITH_CURRENT_CONTEXT = 22;
SDL_GL_CONTEXT_PROFILE_CORE = $0001;
SDL_GL_CONTEXT_PROFILE_COMPATIBILITY = $0002;
SDL_GL_CONTEXT_PROFILE_ES = $0004;
SDL_GL_CONTEXT_DEBUG_FLAG = $0001;
SDL_GL_CONTEXT_FORWARD_COMPATIBLE_FLAG = $0002;
SDL_GL_CONTEXT_ROBUST_ACCESS_FLAG = $0004;
SDL_GL_CONTEXT_RESET_ISOLATION_FLAG = $0008;
SDL_RENDERER_SOFTWARE = $00000001;
SDL_RENDERER_ACCELERATED = $00000002;
SDL_RENDERER_PRESENTVSYNC = $00000004;
SDL_RENDERER_TARGETTEXTURE = $00000008;
SDL_SCANCODE_UNKNOWN = 0;
SDL_SCANCODE_A = 4;
SDL_SCANCODE_B = 5;
SDL_SCANCODE_C = 6;
SDL_SCANCODE_D = 7;
SDL_SCANCODE_E = 8;
SDL_SCANCODE_F = 9;
SDL_SCANCODE_G = 10;
SDL_SCANCODE_H = 11;
SDL_SCANCODE_I = 12;
SDL_SCANCODE_J = 13;
SDL_SCANCODE_K = 14;
SDL_SCANCODE_L = 15;
SDL_SCANCODE_M = 16;
SDL_SCANCODE_N = 17;
SDL_SCANCODE_O = 18;
SDL_SCANCODE_P = 19;
SDL_SCANCODE_Q = 20;
SDL_SCANCODE_R = 21;
SDL_SCANCODE_S = 22;
SDL_SCANCODE_T = 23;
SDL_SCANCODE_U = 24;
SDL_SCANCODE_V = 25;
SDL_SCANCODE_W = 26;
SDL_SCANCODE_X = 27;
SDL_SCANCODE_Y = 28;
SDL_SCANCODE_Z = 29;
SDL_SCANCODE_1 = 30;
SDL_SCANCODE_2 = 31;
SDL_SCANCODE_3 = 32;
SDL_SCANCODE_4 = 33;
SDL_SCANCODE_5 = 34;
SDL_SCANCODE_6 = 35;
SDL_SCANCODE_7 = 36;
SDL_SCANCODE_8 = 37;
SDL_SCANCODE_9 = 38;
SDL_SCANCODE_0 = 39;
SDL_SCANCODE_RETURN = 40;
SDL_SCANCODE_ESCAPE = 41;
SDL_SCANCODE_BACKSPACE = 42;
SDL_SCANCODE_TAB = 43;
SDL_SCANCODE_SPACE = 44;
SDL_SCANCODE_MINUS = 45;
SDL_SCANCODE_EQUALS = 46;
SDL_SCANCODE_LEFTBRACKET = 47;
SDL_SCANCODE_RIGHTBRACKET = 48;
SDL_SCANCODE_BACKSLASH = 49;
SDL_SCANCODE_NONUSHASH = 50;
SDL_SCANCODE_SEMICOLON = 51;
SDL_SCANCODE_APOSTROPHE = 52;
SDL_SCANCODE_GRAVE = 53;
SDL_SCANCODE_COMMA = 54;
SDL_SCANCODE_PERIOD = 55;
SDL_SCANCODE_SLASH = 56;
SDL_SCANCODE_CAPSLOCK = 57;
SDL_SCANCODE_F1 = 58;
SDL_SCANCODE_F2 = 59;
SDL_SCANCODE_F3 = 60;
SDL_SCANCODE_F4 = 61;
SDL_SCANCODE_F5 = 62;
SDL_SCANCODE_F6 = 63;
SDL_SCANCODE_F7 = 64;
SDL_SCANCODE_F8 = 65;
SDL_SCANCODE_F9 = 66;
SDL_SCANCODE_F10 = 67;
SDL_SCANCODE_F11 = 68;
SDL_SCANCODE_F12 = 69;
SDL_SCANCODE_PRINTSCREEN = 70;
SDL_SCANCODE_SCROLLLOCK = 71;
SDL_SCANCODE_PAUSE = 72;
SDL_SCANCODE_INSERT = 73;
SDL_SCANCODE_HOME = 74;
SDL_SCANCODE_PAGEUP = 75;
SDL_SCANCODE_DELETE = 76;
SDL_SCANCODE_END = 77;
SDL_SCANCODE_PAGEDOWN = 78;
SDL_SCANCODE_RIGHT = 79;
SDL_SCANCODE_LEFT = 80;
SDL_SCANCODE_DOWN = 81;
SDL_SCANCODE_UP = 82;
SDL_SCANCODE_NUMLOCKCLEAR = 83;
SDL_SCANCODE_KP_DIVIDE = 84;
SDL_SCANCODE_KP_MULTIPLY = 85;
SDL_SCANCODE_KP_MINUS = 86;
SDL_SCANCODE_KP_PLUS = 87;
SDL_SCANCODE_KP_ENTER = 88;
SDL_SCANCODE_KP_1 = 89;
SDL_SCANCODE_KP_2 = 90;
SDL_SCANCODE_KP_3 = 91;
SDL_SCANCODE_KP_4 = 92;
SDL_SCANCODE_KP_5 = 93;
SDL_SCANCODE_KP_6 = 94;
SDL_SCANCODE_KP_7 = 95;
SDL_SCANCODE_KP_8 = 96;
SDL_SCANCODE_KP_9 = 97;
SDL_SCANCODE_KP_0 = 98;
SDL_SCANCODE_KP_PERIOD = 99;
SDL_SCANCODE_NONUSBACKSLASH = 100;
SDL_SCANCODE_APPLICATION = 101;
SDL_SCANCODE_POWER = 102;
SDL_SCANCODE_KP_EQUALS = 103;
SDL_SCANCODE_F13 = 104;
SDL_SCANCODE_F14 = 105;
SDL_SCANCODE_F15 = 106;
SDL_SCANCODE_F16 = 107;
SDL_SCANCODE_F17 = 108;
SDL_SCANCODE_F18 = 109;
SDL_SCANCODE_F19 = 110;
SDL_SCANCODE_F20 = 111;
SDL_SCANCODE_F21 = 112;
SDL_SCANCODE_F22 = 113;
SDL_SCANCODE_F23 = 114;
SDL_SCANCODE_F24 = 115;
SDL_SCANCODE_EXECUTE = 116;
SDL_SCANCODE_HELP = 117;
SDL_SCANCODE_MENU = 118;
SDL_SCANCODE_SELECT = 119;
SDL_SCANCODE_STOP = 120;
SDL_SCANCODE_AGAIN = 121;
SDL_SCANCODE_UNDO = 122;
SDL_SCANCODE_CUT = 123;
SDL_SCANCODE_COPY = 124;
SDL_SCANCODE_PASTE = 125;
SDL_SCANCODE_FIND = 126;
SDL_SCANCODE_MUTE = 127;
SDL_SCANCODE_VOLUMEUP = 128;
SDL_SCANCODE_VOLUMEDOWN = 129;
SDL_SCANCODE_KP_COMMA = 133;
SDL_SCANCODE_KP_EQUALSAS400 = 134;
SDL_SCANCODE_INTERNATIONAL1 = 135;
SDL_SCANCODE_INTERNATIONAL2 = 136;
SDL_SCANCODE_INTERNATIONAL3 = 137;
SDL_SCANCODE_INTERNATIONAL4 = 138;
SDL_SCANCODE_INTERNATIONAL5 = 139;
SDL_SCANCODE_INTERNATIONAL6 = 140;
SDL_SCANCODE_INTERNATIONAL7 = 141;
SDL_SCANCODE_INTERNATIONAL8 = 142;
SDL_SCANCODE_INTERNATIONAL9 = 143;
SDL_SCANCODE_LANG1 = 144;
SDL_SCANCODE_LANG2 = 145;
SDL_SCANCODE_LANG3 = 146;
SDL_SCANCODE_LANG4 = 147;
SDL_SCANCODE_LANG5 = 148;
SDL_SCANCODE_LANG6 = 149;
SDL_SCANCODE_LANG7 = 150;
SDL_SCANCODE_LANG8 = 151;
SDL_SCANCODE_LANG9 = 152;
SDL_SCANCODE_ALTERASE = 153;
SDL_SCANCODE_SYSREQ = 154;
SDL_SCANCODE_CANCEL = 155;
SDL_SCANCODE_CLEAR = 156;
SDL_SCANCODE_PRIOR = 157;
SDL_SCANCODE_RETURN2 = 158;
SDL_SCANCODE_SEPARATOR = 159;
SDL_SCANCODE_OUT = 160;
SDL_SCANCODE_OPER = 161;
SDL_SCANCODE_CLEARAGAIN = 162;
SDL_SCANCODE_CRSEL = 163;
SDL_SCANCODE_EXSEL = 164;
SDL_SCANCODE_KP_00 = 176;
SDL_SCANCODE_KP_000 = 177;
SDL_SCANCODE_THOUSANDSSEPARATOR = 178;
SDL_SCANCODE_DECIMALSEPARATOR = 179;
SDL_SCANCODE_CURRENCYUNIT = 180;
SDL_SCANCODE_CURRENCYSUBUNIT = 181;
SDL_SCANCODE_KP_LEFTPAREN = 182;
SDL_SCANCODE_KP_RIGHTPAREN = 183;
SDL_SCANCODE_KP_LEFTBRACE = 184;
SDL_SCANCODE_KP_RIGHTBRACE = 185;
SDL_SCANCODE_KP_TAB = 186;
SDL_SCANCODE_KP_BACKSPACE = 187;
SDL_SCANCODE_KP_A = 188;
SDL_SCANCODE_KP_B = 189;
SDL_SCANCODE_KP_C = 190;
SDL_SCANCODE_KP_D = 191;
SDL_SCANCODE_KP_E = 192;
SDL_SCANCODE_KP_F = 193;
SDL_SCANCODE_KP_XOR = 194;
SDL_SCANCODE_KP_POWER = 195;
SDL_SCANCODE_KP_PERCENT = 196;
SDL_SCANCODE_KP_LESS = 197;
SDL_SCANCODE_KP_GREATER = 198;
SDL_SCANCODE_KP_AMPERSAND = 199;
SDL_SCANCODE_KP_DBLAMPERSAND = 200;
SDL_SCANCODE_KP_VERTICALBAR = 201;
SDL_SCANCODE_KP_DBLVERTICALBAR = 202;
SDL_SCANCODE_KP_COLON = 203;
SDL_SCANCODE_KP_HASH = 204;
SDL_SCANCODE_KP_SPACE = 205;
SDL_SCANCODE_KP_AT = 206;
SDL_SCANCODE_KP_EXCLAM = 207;
SDL_SCANCODE_KP_MEMSTORE = 208;
SDL_SCANCODE_KP_MEMRECALL = 209;
SDL_SCANCODE_KP_MEMCLEAR = 210;
SDL_SCANCODE_KP_MEMADD = 211;
SDL_SCANCODE_KP_MEMSUBTRACT = 212;
SDL_SCANCODE_KP_MEMMULTIPLY = 213;
SDL_SCANCODE_KP_MEMDIVIDE = 214;
SDL_SCANCODE_KP_PLUSMINUS = 215;
SDL_SCANCODE_KP_CLEAR = 216;
SDL_SCANCODE_KP_CLEARENTRY = 217;
SDL_SCANCODE_KP_BINARY = 218;
SDL_SCANCODE_KP_OCTAL = 219;
SDL_SCANCODE_KP_DECIMAL = 220;
SDL_SCANCODE_KP_HEXADECIMAL = 221;
SDL_SCANCODE_LCTRL = 224;
SDL_SCANCODE_LSHIFT = 225;
SDL_SCANCODE_LALT = 226;
SDL_SCANCODE_LGUI = 227;
SDL_SCANCODE_RCTRL = 228;
SDL_SCANCODE_RSHIFT = 229;
SDL_SCANCODE_RALT = 230;
SDL_SCANCODE_RGUI = 231;
SDL_SCANCODE_MODE = 257;
SDL_SCANCODE_AUDIONEXT = 258;
SDL_SCANCODE_AUDIOPREV = 259;
SDL_SCANCODE_AUDIOSTOP = 260;
SDL_SCANCODE_AUDIOPLAY = 261;
SDL_SCANCODE_AUDIOMUTE = 262;
SDL_SCANCODE_MEDIASELECT = 263;
SDL_SCANCODE_WWW = 264;
SDL_SCANCODE_MAIL = 265;
SDL_SCANCODE_CALCULATOR = 266;
SDL_SCANCODE_COMPUTER = 267;
SDL_SCANCODE_AC_SEARCH = 268;
SDL_SCANCODE_AC_HOME = 269;
SDL_SCANCODE_AC_BACK = 270;
SDL_SCANCODE_AC_FORWARD = 271;
SDL_SCANCODE_AC_STOP = 272;
SDL_SCANCODE_AC_REFRESH = 273;
SDL_SCANCODE_AC_BOOKMARKS = 274;
SDL_SCANCODE_BRIGHTNESSDOWN = 275;
SDL_SCANCODE_BRIGHTNESSUP = 276;
SDL_SCANCODE_DISPLAYSWITCH = 277;
SDL_SCANCODE_KBDILLUMTOGGLE = 278;
SDL_SCANCODE_KBDILLUMDOWN = 279;
SDL_SCANCODE_KBDILLUMUP = 280;
SDL_SCANCODE_EJECT = 281;
SDL_SCANCODE_SLEEP = 282;
SDL_SCANCODE_APP1 = 283;
SDL_SCANCODE_APP2 = 284;
SDL_NUM_SCANCODES = 512;
SDLK_SCANCODE_MASK = 1 shl 30;
SDLK_UNKNOWN = 0;
SDLK_RETURN = '\r';
SDLK_ESCAPE = '\033';
SDLK_BACKSPACE = '\b';
SDLK_TAB = '\t';
SDLK_SPACE = ' ';
SDLK_EXCLAIM = '!';
SDLK_QUOTEDBL = '"';
SDLK_HASH = '#';
SDLK_PERCENT = '%';
SDLK_DOLLAR = '$';
SDLK_AMPERSAND = '&';
SDLK_QUOTE = '\';
SDLK_LEFTPAREN = '(';
SDLK_RIGHTPAREN = ')';
SDLK_ASTERISK = '*';
SDLK_PLUS = '+';
SDLK_COMMA = ';';
SDLK_MINUS = '-';
SDLK_PERIOD = '.';
SDLK_SLASH = '/';
SDLK_0 = '0';
SDLK_1 = '1';
SDLK_2 = '2';
SDLK_3 = '3';
SDLK_4 = '4';
SDLK_5 = '5';
SDLK_6 = '6';
SDLK_7 = '7';
SDLK_8 = '8';
SDLK_9 = '9';
SDLK_COLON = ':';
SDLK_SEMICOLON = ';';
SDLK_LESS = '<';
SDLK_EQUALS = '=';
SDLK_GREATER = '>';
SDLK_QUESTION = '?';
SDLK_AT = '@';
SDLK_LEFTBRACKET = '[';
SDLK_BACKSLASH = '\\';
SDLK_RIGHTBRACKET = ']';
SDLK_CARET = 'ˆ';
SDLK_UNDERSCORE = '_';
SDLK_BACKQUOTE = '`';
SDLK_a = 'a';
SDLK_b = 'b';
SDLK_c = 'c';
SDLK_d = 'd';
SDLK_e = 'e';
SDLK_f = 'f';
SDLK_g = 'g';
SDLK_h = 'h';
SDLK_i = 'i';
SDLK_j = 'j';
SDLK_k = 'k';
SDLK_l = 'l';
SDLK_m = 'm';
SDLK_n = 'n';
SDLK_o = 'o';
SDLK_p = 'p';
SDLK_q = 'q';
SDLK_r = 'r';
SDLK_s = 's';
SDLK_t = 't';
SDLK_u = 'u';
SDLK_v = 'v';
SDLK_w = 'w';
SDLK_x = 'x';
SDLK_y = 'y';
SDLK_z = 'z';
SDLK_CAPSLOCK = SDL_SCANCODE_CAPSLOCK or SDLK_SCANCODE_MASK;
SDLK_F1 = SDL_SCANCODE_F1 or SDLK_SCANCODE_MASK;
SDLK_F2 = SDL_SCANCODE_F2 or SDLK_SCANCODE_MASK;
SDLK_F3 = SDL_SCANCODE_F3 or SDLK_SCANCODE_MASK;
SDLK_F4 = SDL_SCANCODE_F4 or SDLK_SCANCODE_MASK;
SDLK_F5 = SDL_SCANCODE_F5 or SDLK_SCANCODE_MASK;
SDLK_F6 = SDL_SCANCODE_F6 or SDLK_SCANCODE_MASK;
SDLK_F7 = SDL_SCANCODE_F7 or SDLK_SCANCODE_MASK;
SDLK_F8 = SDL_SCANCODE_F8 or SDLK_SCANCODE_MASK;
SDLK_F9 = SDL_SCANCODE_F9 or SDLK_SCANCODE_MASK;
SDLK_F10 = SDL_SCANCODE_F10 or SDLK_SCANCODE_MASK;
SDLK_F11 = SDL_SCANCODE_F11 or SDLK_SCANCODE_MASK;
SDLK_F12 = SDL_SCANCODE_F12 or SDLK_SCANCODE_MASK;
SDLK_PRINTSCREEN = SDL_SCANCODE_PRINTSCREEN or SDLK_SCANCODE_MASK;
SDLK_SCROLLLOCK = SDL_SCANCODE_SCROLLLOCK or SDLK_SCANCODE_MASK;
SDLK_PAUSE = SDL_SCANCODE_PAUSE or SDLK_SCANCODE_MASK;
SDLK_INSERT = SDL_SCANCODE_INSERT or SDLK_SCANCODE_MASK;
SDLK_HOME = SDL_SCANCODE_HOME or SDLK_SCANCODE_MASK;
SDLK_PAGEUP = SDL_SCANCODE_PAGEUP or SDLK_SCANCODE_MASK;
SDLK_DELETE = '\177';
SDLK_END = SDL_SCANCODE_END or SDLK_SCANCODE_MASK;
SDLK_PAGEDOWN = SDL_SCANCODE_PAGEDOWN or SDLK_SCANCODE_MASK;
SDLK_RIGHT = SDL_SCANCODE_RIGHT or SDLK_SCANCODE_MASK;
SDLK_LEFT = SDL_SCANCODE_LEFT or SDLK_SCANCODE_MASK;
SDLK_DOWN = SDL_SCANCODE_DOWN or SDLK_SCANCODE_MASK;
SDLK_UP = SDL_SCANCODE_UP or SDLK_SCANCODE_MASK;
SDLK_NUMLOCKCLEAR = SDL_SCANCODE_NUMLOCKCLEAR or SDLK_SCANCODE_MASK;
SDLK_KP_DIVIDE = SDL_SCANCODE_KP_DIVIDE or SDLK_SCANCODE_MASK;
SDLK_KP_MULTIPLY = SDL_SCANCODE_KP_MULTIPLY or SDLK_SCANCODE_MASK;
SDLK_KP_MINUS = SDL_SCANCODE_KP_MINUS or SDLK_SCANCODE_MASK;
SDLK_KP_PLUS = SDL_SCANCODE_KP_PLUS or SDLK_SCANCODE_MASK;
SDLK_KP_ENTER = SDL_SCANCODE_KP_ENTER or SDLK_SCANCODE_MASK;
SDLK_KP_1 = SDL_SCANCODE_KP_1 or SDLK_SCANCODE_MASK;
SDLK_KP_2 = SDL_SCANCODE_KP_2 or SDLK_SCANCODE_MASK;
SDLK_KP_3 = SDL_SCANCODE_KP_3 or SDLK_SCANCODE_MASK;
SDLK_KP_4 = SDL_SCANCODE_KP_4 or SDLK_SCANCODE_MASK;
SDLK_KP_5 = SDL_SCANCODE_KP_5 or SDLK_SCANCODE_MASK;
SDLK_KP_6 = SDL_SCANCODE_KP_6 or SDLK_SCANCODE_MASK;
SDLK_KP_7 = SDL_SCANCODE_KP_7 or SDLK_SCANCODE_MASK;
SDLK_KP_8 = SDL_SCANCODE_KP_8 or SDLK_SCANCODE_MASK;
SDLK_KP_9 = SDL_SCANCODE_KP_9 or SDLK_SCANCODE_MASK;
SDLK_KP_0 = SDL_SCANCODE_KP_0 or SDLK_SCANCODE_MASK;
SDLK_KP_PERIOD = SDL_SCANCODE_KP_PERIOD or SDLK_SCANCODE_MASK;
SDLK_APPLICATION = SDL_SCANCODE_APPLICATION or SDLK_SCANCODE_MASK;
SDLK_POWER = SDL_SCANCODE_POWER or SDLK_SCANCODE_MASK;
SDLK_KP_EQUALS = SDL_SCANCODE_KP_EQUALS or SDLK_SCANCODE_MASK;
SDLK_F13 = SDL_SCANCODE_F13 or SDLK_SCANCODE_MASK;
SDLK_F14 = SDL_SCANCODE_F14 or SDLK_SCANCODE_MASK;
SDLK_F15 = SDL_SCANCODE_F15 or SDLK_SCANCODE_MASK;
SDLK_F16 = SDL_SCANCODE_F16 or SDLK_SCANCODE_MASK;
SDLK_F17 = SDL_SCANCODE_F17 or SDLK_SCANCODE_MASK;
SDLK_F18 = SDL_SCANCODE_F18 or SDLK_SCANCODE_MASK;
SDLK_F19 = SDL_SCANCODE_F19 or SDLK_SCANCODE_MASK;
SDLK_F20 = SDL_SCANCODE_F20 or SDLK_SCANCODE_MASK;
SDLK_F21 = SDL_SCANCODE_F21 or SDLK_SCANCODE_MASK;
SDLK_F22 = SDL_SCANCODE_F22 or SDLK_SCANCODE_MASK;
SDLK_F23 = SDL_SCANCODE_F23 or SDLK_SCANCODE_MASK;
SDLK_F24 = SDL_SCANCODE_F24 or SDLK_SCANCODE_MASK;
SDLK_EXECUTE = SDL_SCANCODE_EXECUTE or SDLK_SCANCODE_MASK;
SDLK_HELP = SDL_SCANCODE_HELP or SDLK_SCANCODE_MASK;
SDLK_MENU = SDL_SCANCODE_MENU or SDLK_SCANCODE_MASK;
SDLK_SELECT = SDL_SCANCODE_SELECT or SDLK_SCANCODE_MASK;
SDLK_STOP = SDL_SCANCODE_STOP or SDLK_SCANCODE_MASK;
SDLK_AGAIN = SDL_SCANCODE_AGAIN or SDLK_SCANCODE_MASK;
SDLK_UNDO = SDL_SCANCODE_UNDO or SDLK_SCANCODE_MASK;
SDLK_CUT = SDL_SCANCODE_CUT or SDLK_SCANCODE_MASK;
SDLK_COPY = SDL_SCANCODE_COPY or SDLK_SCANCODE_MASK;
SDLK_PASTE = SDL_SCANCODE_PASTE or SDLK_SCANCODE_MASK;
SDLK_FIND = SDL_SCANCODE_FIND or SDLK_SCANCODE_MASK;
SDLK_MUTE = SDL_SCANCODE_MUTE or SDLK_SCANCODE_MASK;
SDLK_VOLUMEUP = SDL_SCANCODE_VOLUMEUP or SDLK_SCANCODE_MASK;
SDLK_VOLUMEDOWN = SDL_SCANCODE_VOLUMEDOWN or SDLK_SCANCODE_MASK;
SDLK_KP_COMMA = SDL_SCANCODE_KP_COMMA or SDLK_SCANCODE_MASK;
SDLK_KP_EQUALSAS400 = SDL_SCANCODE_KP_EQUALSAS400 or SDLK_SCANCODE_MASK;
SDLK_ALTERASE = SDL_SCANCODE_ALTERASE or SDLK_SCANCODE_MASK;
SDLK_SYSREQ = SDL_SCANCODE_SYSREQ or SDLK_SCANCODE_MASK;
SDLK_CANCEL = SDL_SCANCODE_CANCEL or SDLK_SCANCODE_MASK;
SDLK_CLEAR = SDL_SCANCODE_CLEAR or SDLK_SCANCODE_MASK;
SDLK_PRIOR = SDL_SCANCODE_PRIOR or SDLK_SCANCODE_MASK;
SDLK_RETURN2 = SDL_SCANCODE_RETURN2 or SDLK_SCANCODE_MASK;
SDLK_SEPARATOR = SDL_SCANCODE_SEPARATOR or SDLK_SCANCODE_MASK;
SDLK_OUT = SDL_SCANCODE_OUT or SDLK_SCANCODE_MASK;
SDLK_OPER = SDL_SCANCODE_OPER or SDLK_SCANCODE_MASK;
SDLK_CLEARAGAIN = SDL_SCANCODE_CLEARAGAIN or SDLK_SCANCODE_MASK;
SDLK_CRSEL = SDL_SCANCODE_CRSEL or SDLK_SCANCODE_MASK;
SDLK_EXSEL = SDL_SCANCODE_EXSEL or SDLK_SCANCODE_MASK;
SDLK_KP_00 = SDL_SCANCODE_KP_00 or SDLK_SCANCODE_MASK;
SDLK_KP_000 = SDL_SCANCODE_KP_000 or SDLK_SCANCODE_MASK;
SDLK_THOUSANDSSEPARATOR = SDL_SCANCODE_THOUSANDSSEPARATOR or SDLK_SCANCODE_MASK;
SDLK_DECIMALSEPARATOR = SDL_SCANCODE_DECIMALSEPARATOR or SDLK_SCANCODE_MASK;
SDLK_CURRENCYUNIT = SDL_SCANCODE_CURRENCYUNIT or SDLK_SCANCODE_MASK;
SDLK_CURRENCYSUBUNIT = SDL_SCANCODE_CURRENCYSUBUNIT or SDLK_SCANCODE_MASK;
SDLK_KP_LEFTPAREN = SDL_SCANCODE_KP_LEFTPAREN or SDLK_SCANCODE_MASK;
SDLK_KP_RIGHTPAREN = SDL_SCANCODE_KP_RIGHTPAREN or SDLK_SCANCODE_MASK;
SDLK_KP_LEFTBRACE = SDL_SCANCODE_KP_LEFTBRACE or SDLK_SCANCODE_MASK;
SDLK_KP_RIGHTBRACE = SDL_SCANCODE_KP_RIGHTBRACE or SDLK_SCANCODE_MASK;
SDLK_KP_TAB = SDL_SCANCODE_KP_TAB or SDLK_SCANCODE_MASK;
SDLK_KP_BACKSPACE = SDL_SCANCODE_KP_BACKSPACE or SDLK_SCANCODE_MASK;
SDLK_KP_A = SDL_SCANCODE_KP_A or SDLK_SCANCODE_MASK;
SDLK_KP_B = SDL_SCANCODE_KP_B or SDLK_SCANCODE_MASK;
SDLK_KP_C = SDL_SCANCODE_KP_C or SDLK_SCANCODE_MASK;
SDLK_KP_D = SDL_SCANCODE_KP_D or SDLK_SCANCODE_MASK;
SDLK_KP_E = SDL_SCANCODE_KP_E or SDLK_SCANCODE_MASK;
SDLK_KP_F = SDL_SCANCODE_KP_F or SDLK_SCANCODE_MASK;
SDLK_KP_XOR = SDL_SCANCODE_KP_XOR or SDLK_SCANCODE_MASK;
SDLK_KP_POWER = SDL_SCANCODE_KP_POWER or SDLK_SCANCODE_MASK;
SDLK_KP_PERCENT = SDL_SCANCODE_KP_PERCENT or SDLK_SCANCODE_MASK;
SDLK_KP_LESS = SDL_SCANCODE_KP_LESS or SDLK_SCANCODE_MASK;
SDLK_KP_GREATER = SDL_SCANCODE_KP_GREATER or SDLK_SCANCODE_MASK;
SDLK_KP_AMPERSAND = SDL_SCANCODE_KP_AMPERSAND or SDLK_SCANCODE_MASK;
SDLK_KP_DBLAMPERSAND = SDL_SCANCODE_KP_DBLAMPERSAND or SDLK_SCANCODE_MASK;
SDLK_KP_VERTICALBAR = SDL_SCANCODE_KP_VERTICALBAR or SDLK_SCANCODE_MASK;
SDLK_KP_DBLVERTICALBAR = SDL_SCANCODE_KP_DBLVERTICALBAR or SDLK_SCANCODE_MASK;
SDLK_KP_COLON = SDL_SCANCODE_KP_COLON or SDLK_SCANCODE_MASK;
SDLK_KP_HASH = SDL_SCANCODE_KP_HASH or SDLK_SCANCODE_MASK;
SDLK_KP_SPACE = SDL_SCANCODE_KP_SPACE or SDLK_SCANCODE_MASK;
SDLK_KP_AT = SDL_SCANCODE_KP_AT or SDLK_SCANCODE_MASK;
SDLK_KP_EXCLAM = SDL_SCANCODE_KP_EXCLAM or SDLK_SCANCODE_MASK;
SDLK_KP_MEMSTORE = SDL_SCANCODE_KP_MEMSTORE or SDLK_SCANCODE_MASK;
SDLK_KP_MEMRECALL = SDL_SCANCODE_KP_MEMRECALL or SDLK_SCANCODE_MASK;
SDLK_KP_MEMCLEAR = SDL_SCANCODE_KP_MEMCLEAR or SDLK_SCANCODE_MASK;
SDLK_KP_MEMADD = SDL_SCANCODE_KP_MEMADD or SDLK_SCANCODE_MASK;
SDLK_KP_MEMSUBTRACT = SDL_SCANCODE_KP_MEMSUBTRACT or SDLK_SCANCODE_MASK;
SDLK_KP_MEMMULTIPLY = SDL_SCANCODE_KP_MEMMULTIPLY or SDLK_SCANCODE_MASK;
SDLK_KP_MEMDIVIDE = SDL_SCANCODE_KP_MEMDIVIDE or SDLK_SCANCODE_MASK;
SDLK_KP_PLUSMINUS = SDL_SCANCODE_KP_PLUSMINUS or SDLK_SCANCODE_MASK;
SDLK_KP_CLEAR = SDL_SCANCODE_KP_CLEAR or SDLK_SCANCODE_MASK;
SDLK_KP_CLEARENTRY = SDL_SCANCODE_KP_CLEARENTRY or SDLK_SCANCODE_MASK;
SDLK_KP_BINARY = SDL_SCANCODE_KP_BINARY or SDLK_SCANCODE_MASK;
SDLK_KP_OCTAL = SDL_SCANCODE_KP_OCTAL or SDLK_SCANCODE_MASK;
SDLK_KP_DECIMAL = SDL_SCANCODE_KP_DECIMAL or SDLK_SCANCODE_MASK;
SDLK_KP_HEXADECIMAL = SDL_SCANCODE_KP_HEXADECIMAL or SDLK_SCANCODE_MASK;
SDLK_LCTRL = SDL_SCANCODE_LCTRL or SDLK_SCANCODE_MASK;
SDLK_LSHIFT = SDL_SCANCODE_LSHIFT or SDLK_SCANCODE_MASK;
SDLK_LALT = SDL_SCANCODE_LALT or SDLK_SCANCODE_MASK;
SDLK_LGUI = SDL_SCANCODE_LGUI or SDLK_SCANCODE_MASK;
SDLK_RCTRL = SDL_SCANCODE_RCTRL or SDLK_SCANCODE_MASK;
SDLK_RSHIFT = SDL_SCANCODE_RSHIFT or SDLK_SCANCODE_MASK;
SDLK_RALT = SDL_SCANCODE_RALT or SDLK_SCANCODE_MASK;
SDLK_RGUI = SDL_SCANCODE_RGUI or SDLK_SCANCODE_MASK;
SDLK_MODE = SDL_SCANCODE_MODE or SDLK_SCANCODE_MASK;
SDLK_AUDIONEXT = SDL_SCANCODE_AUDIONEXT or SDLK_SCANCODE_MASK;
SDLK_AUDIOPREV = SDL_SCANCODE_AUDIOPREV or SDLK_SCANCODE_MASK;
SDLK_AUDIOSTOP = SDL_SCANCODE_AUDIOSTOP or SDLK_SCANCODE_MASK;
SDLK_AUDIOPLAY = SDL_SCANCODE_AUDIOPLAY or SDLK_SCANCODE_MASK;
SDLK_AUDIOMUTE = SDL_SCANCODE_AUDIOMUTE or SDLK_SCANCODE_MASK;
SDLK_MEDIASELECT = SDL_SCANCODE_MEDIASELECT or SDLK_SCANCODE_MASK;
SDLK_WWW = SDL_SCANCODE_WWW or SDLK_SCANCODE_MASK;
SDLK_MAIL = SDL_SCANCODE_MAIL or SDLK_SCANCODE_MASK;
SDLK_CALCULATOR = SDL_SCANCODE_CALCULATOR or SDLK_SCANCODE_MASK;
SDLK_COMPUTER = SDL_SCANCODE_COMPUTER or SDLK_SCANCODE_MASK;
SDLK_AC_SEARCH = SDL_SCANCODE_AC_SEARCH or SDLK_SCANCODE_MASK;
SDLK_AC_HOME = SDL_SCANCODE_AC_HOME or SDLK_SCANCODE_MASK;
SDLK_AC_BACK = SDL_SCANCODE_AC_BACK or SDLK_SCANCODE_MASK;
SDLK_AC_FORWARD = SDL_SCANCODE_AC_FORWARD or SDLK_SCANCODE_MASK;
SDLK_AC_STOP = SDL_SCANCODE_AC_STOP or SDLK_SCANCODE_MASK;
SDLK_AC_REFRESH = SDL_SCANCODE_AC_REFRESH or SDLK_SCANCODE_MASK;
SDLK_AC_BOOKMARKS = SDL_SCANCODE_AC_BOOKMARKS or SDLK_SCANCODE_MASK;
SDLK_BRIGHTNESSDOWN = SDL_SCANCODE_BRIGHTNESSDOWN or SDLK_SCANCODE_MASK;
SDLK_BRIGHTNESSUP = SDL_SCANCODE_BRIGHTNESSUP or SDLK_SCANCODE_MASK;
SDLK_DISPLAYSWITCH = SDL_SCANCODE_DISPLAYSWITCH or SDLK_SCANCODE_MASK;
SDLK_KBDILLUMTOGGLE = SDL_SCANCODE_KBDILLUMTOGGLE or SDLK_SCANCODE_MASK;
SDLK_KBDILLUMDOWN = SDL_SCANCODE_KBDILLUMDOWN or SDLK_SCANCODE_MASK;
SDLK_KBDILLUMUP = SDL_SCANCODE_KBDILLUMUP or SDLK_SCANCODE_MASK;
SDLK_EJECT = SDL_SCANCODE_EJECT or SDLK_SCANCODE_MASK;
SDLK_SLEEP = SDL_SCANCODE_SLEEP or SDLK_SCANCODE_MASK;
KMOD_NONE = $0000;
KMOD_LSHIFT = $0001;
KMOD_RSHIFT = $0002;
KMOD_LCTRL = $0040;
KMOD_RCTRL = $0080;
KMOD_LALT = $0100;
KMOD_RALT = $0200;
KMOD_LGUI = $0400;
KMOD_RGUI = $0800;
KMOD_NUM = $1000;
KMOD_CAPS = $2000;
KMOD_MODE = $4000;
KMOD_RESERVED = $8000;
KMOD_CTRL = KMOD_LCTRL or KMOD_RCTRL;
KMOD_SHIFT = KMOD_LSHIFT or KMOD_RSHIFT;
KMOD_ALT = KMOD_LALT or KMOD_RALT;
KMOD_GUI = KMOD_LGUI or KMOD_RGUI;
SDL_SYSTEM_CURSOR_ARROW = 0;
SDL_SYSTEM_CURSOR_IBEAM = 1;
SDL_SYSTEM_CURSOR_WAIT = 2;
SDL_SYSTEM_CURSOR_CROSSHAIR = 3;
SDL_SYSTEM_CURSOR_WAITARROW = 4;
SDL_SYSTEM_CURSOR_SIZENWSE = 5;
SDL_SYSTEM_CURSOR_SIZENESW = 6;
SDL_SYSTEM_CURSOR_SIZEWE = 7;
SDL_SYSTEM_CURSOR_SIZENS = 8;
SDL_SYSTEM_CURSOR_SIZEALL = 9;
SDL_SYSTEM_CURSOR_NO = 10;
SDL_SYSTEM_CURSOR_HAND = 11;
SDL_NUM_SYSTEM_CURSORS = 12;
SDL_BUTTON_LEFT = 1;
SDL_BUTTON_MIDDLE = 2;
SDL_BUTTON_RIGHT = 3;
SDL_BUTTON_X1 = 4;
SDL_BUTTON_X2 = 5;
SDL_BUTTON_LMASK = 1 shl ((SDL_BUTTON_LEFT) - 1);
SDL_BUTTON_MMASK = 1 shl ((SDL_BUTTON_MIDDLE) - 1);
SDL_BUTTON_RMASK = 1 shl ((SDL_BUTTON_RIGHT) - 1);
SDL_BUTTON_X1MASK = 1 shl ((SDL_BUTTON_X1) - 1);
SDL_BUTTON_X2MASK = 1 shl ((SDL_BUTTON_X2) - 1);
SDL_HAT_CENTERED = $00;
SDL_HAT_UP = $01;
SDL_HAT_RIGHT = $02;
SDL_HAT_DOWN = $04;
SDL_HAT_LEFT = $08;
SDL_HAT_RIGHTUP = SDL_HAT_RIGHT or SDL_HAT_UP;
SDL_HAT_RIGHTDOWN = SDL_HAT_RIGHT or SDL_HAT_DOWN;
SDL_HAT_LEFTUP = SDL_HAT_LEFT or SDL_HAT_UP;
SDL_HAT_LEFTDOWN = SDL_HAT_LEFT or SDL_HAT_DOWN;
SDL_CONTROLLER_AXIS_INVALID = -1;
SDL_CONTROLLER_AXIS_LEFTX = 0;
SDL_CONTROLLER_AXIS_LEFTY = 1;
SDL_CONTROLLER_AXIS_RIGHTX = 2;
SDL_CONTROLLER_AXIS_RIGHTY = 3;
SDL_CONTROLLER_AXIS_TRIGGERLEFT = 4;
SDL_CONTROLLER_AXIS_TRIGGERRIGHT = 5;
SDL_CONTROLLER_AXIS_MAX = 6;
SDL_CONTROLLER_BUTTON_INVALID = -1;
SDL_CONTROLLER_BUTTON_A = 0;
SDL_CONTROLLER_BUTTON_B = 1;
SDL_CONTROLLER_BUTTON_X = 2;
SDL_CONTROLLER_BUTTON_Y = 3;
SDL_CONTROLLER_BUTTON_BACK = 4;
SDL_CONTROLLER_BUTTON_GUIDE = 5;
SDL_CONTROLLER_BUTTON_START = 6;
SDL_CONTROLLER_BUTTON_LEFTSTICK = 7;
SDL_CONTROLLER_BUTTON_RIGHTSTICK = 8;
SDL_CONTROLLER_BUTTON_LEFTSHOULDER = 9;
SDL_CONTROLLER_BUTTON_RIGHTSHOULDER = 10;
SDL_CONTROLLER_BUTTON_DPAD_UP = 11;
SDL_CONTROLLER_BUTTON_DPAD_DOWN = 12;
SDL_CONTROLLER_BUTTON_DPAD_LEFT = 13;
SDL_CONTROLLER_BUTTON_DPAD_RIGHT = 14;
SDL_CONTROLLER_BUTTON_MAX = 15;
SDL_HAPTIC_CONSTANT = (1 shl 0);
SDL_HAPTIC_SINE = (1 shl 1);
SDL_HAPTIC_SQUARE = (1 shl 2);
SDL_HAPTIC_TRIANGLE = (1 shl 3);
SDL_HAPTIC_SAWTOOTHUP = (1 shl 4);
SDL_HAPTIC_SAWTOOTHDOWN = (1 shl 5);
SDL_HAPTIC_RAMP = (1 shl 6);
SDL_HAPTIC_SPRING = (1 shl 7);
SDL_HAPTIC_DAMPER = (1 shl 8);
SDL_HAPTIC_INERTIA = (1 shl 9);
SDL_HAPTIC_FRICTION = (1 shl 10);
SDL_HAPTIC_CUSTOM = (1 shl 11);
SDL_HAPTIC_GAIN = (1 shl 12);
SDL_HAPTIC_AUTOCENTER = (1 shl 13);
SDL_HAPTIC_STATUS = (1 shl 14);
SDL_HAPTIC_PAUSE = (1 shl 15);
SDL_HAPTIC_POLAR = 0;
SDL_HAPTIC_CARTESIAN = 1;
SDL_HAPTIC_SPHERICAL = 2;
SDL_HAPTIC_INFINITY = 4294967295;
SDL_TOUCH_MOUSEID = UInt32(-1);
SDL_FIRSTEVENT = 0;
SDL_COMMONEVENT = 1;
SDL_QUITEV = $100;
SDL_APP_TERMINATING = $101;
SDL_APP_LOWMEMORY = $102;
SDL_APP_WILLENTERBACKGROUND = $103;
SDL_APP_DIDENTERBACKGROUND = $104;
SDL_APP_WILLENTERFOREGROUND = $105;
SDL_APP_DIDENTERFOREGROUND = $106;
SDL_WINDOWEVENT = $200;
SDL_SYSWMEVENT = $201;
SDL_KEYDOWN = $300;
SDL_KEYUP = $301;
SDL_TEXTEDITING = $302;
SDL_TEXTINPUT = $303;
SDL_MOUSEMOTION = $400;
SDL_MOUSEBUTTONDOWN = $401;
SDL_MOUSEBUTTONUP = $402;
SDL_MOUSEWHEEL = $403;
SDL_JOYAXISMOTION = $600;
SDL_JOYBALLMOTION = $601;
SDL_JOYHATMOTION = $602;
SDL_JOYBUTTONDOWN = $603;
SDL_JOYBUTTONUP = $604;
SDL_JOYDEVICEADDED = $605;
SDL_JOYDEVICEREMOVED = $606;
SDL_CONTROLLERAXISMOTION = $650;
SDL_CONTROLLERBUTTONDOWN = $651;
SDL_CONTROLLERBUTTONUP = $652;
SDL_CONTROLLERDEVICEADDED = $653;
SDL_CONTROLLERDEVICEREMOVED = $654;
SDL_CONTROLLERDEVICEREMAPPED = $655;
SDL_FINGERDOWN = $700;
SDL_FINGERUP = $701;
SDL_FINGERMOTION = $702;
SDL_DOLLARGESTURE = $800;
SDL_DOLLARRECORD = $801;
SDL_MULTIGESTURE = $802;
SDL_CLIPBOARDUPDATE = $900;
SDL_DROPFILE = $1000;
SDL_USEREVENT = $8000;
SDL_LASTEVENT = $FFFF;
SDL_TEXTEDITINGEVENT_TEXT_SIZE = 32;
SDL_TEXTINPUTEVENT_TEXT_SIZE = 32;
SDL_ADDEVENT = 0;
SDL_PEEKEVENT = 1;
SDL_GETEVENT = 2;
SDL_QUERY = -1;
SDL_IGNORE = 0;
SDL_DISABLE = 0;
SDL_ENABLE = 1;
SDL_INIT_TIMER = $00000001;
SDL_INIT_AUDIO = $00000010;
SDL_INIT_VIDEO = $00000020;
SDL_INIT_JOYSTICK = $00000200;
SDL_INIT_HAPTIC = $00001000;
SDL_INIT_GAMECONTROLLER = $00002000;
SDL_INIT_NOPARACHUTE = $00100000;
SDL_INIT_EVERYTHING = SDL_INIT_TIMER or SDL_INIT_AUDIO or SDL_INIT_VIDEO or SDL_INIT_JOYSTICK or SDL_INIT_HAPTIC or SDL_INIT_GAMECONTROLLER;
SDL_HINT_FRAMEBUFFER_ACCELERATION = 'SDL_FRAMEBUFFER_ACCELERATION';
SDL_HINT_RENDER_DRIVER = 'SDL_RENDER_DRIVER';
SDL_HINT_RENDER_OPENGL_SHADERS = 'SDL_RENDER_OPENGL_SHADERS';
SDL_HINT_RENDER_SCALE_QUALITY = 'SDL_RENDER_SCALE_QUALITY';
SDL_HINT_RENDER_VSYNC = 'SDL_RENDER_VSYNC';
SDL_HINT_VIDEO_X11_XVIDMODE = 'SDL_VIDEO_X11_XVIDMODE';
SDL_HINT_VIDEO_X11_XINERAMA = 'SDL_VIDEO_X11_XINERAMA';
SDL_HINT_VIDEO_X11_XRANDR = 'SDL_VIDEO_X11_XRANDR';
SDL_HINT_GRAB_KEYBOARD = 'SDL_GRAB_KEYBOARD';
SDL_HINT_VIDEO_MINIMIZE_ON_FOCUS_LOSS = 'SDL_VIDEO_MINIMIZE_ON_FOCUS_LOSS';
SDL_HINT_IDLE_TIMER_DISABLED = 'SDL_IOS_IDLE_TIMER_DISABLED';
SDL_HINT_ORIENTATIONS = 'SDL_IOS_ORIENTATIONS';
SDL_HINT_XINPUT_ENABLED = 'SDL_XINPUT_ENABLED';
SDL_HINT_GAMECONTROLLERCONFIG = 'SDL_GAMECONTROLLERCONFIG';
SDL_HINT_JOYSTICK_ALLOW_BACKGROUND_EVENTS = 'SDL_JOYSTICK_ALLOW_BACKGROUND_EVENTS';
SDL_HINT_ALLOW_TOPMOST = 'SDL_ALLOW_TOPMOST';
SDL_HINT_TIMER_RESOLUTION = 'SDL_TIMER_RESOLUTION';
SDL_HINT_RENDER_DIRECT3D_THREADSAFE = 'SDL_RENDER_DIRECT3D_THREADSAFE';
SDL_LIL_ENDIAN = 1234;
SDL_BIG_ENDIAN = 4321;
SDL_BYTEORDER = SDL_LIL_ENDIAN;
SDL_MESSAGEBOX_ERROR = $00000010;
SDL_MESSAGEBOX_WARNING = $00000020;
SDL_MESSAGEBOX_INFORMATION = $00000040;
SDL_MESSAGEBOX_BUTTON_RETURNKEY_DEFAULT = $00000001;
SDL_MESSAGEBOX_BUTTON_ESCAPEKEY_DEFAULT = $00000002;

Description

Functions and Procedures

procedure SDL_VERSION(x: PSDL_Version);

** * Macro to determine SDL version program was compiled against. * * This macro fills in a SDL_version structure with the version of the * library you compiled against. This is determined by what header the * compiler uses. Note that if you dynamically linked the library, you might * have a slightly newer or older version at runtime. That version can be * determined with SDL_GetVersion(), which, unlike SDL_VERSION(), * is not a macro. * * x A pointer to a SDL_version struct to initialize. * * SDL_version * SDL_GetVersion *

function SDL_VERSIONNUM(X,Y,Z: UInt32): Cardinal;

** * This macro turns the version numbers into a numeric value: * * (1,2,3) -> (1203) * * * This assumes that there will never be more than 100 patchlevels. *

function SDL_COMPILEDVERSION(): Cardinal;

** * This is the version number macro for the current SDL version. *

function SDL_VERSION_ATLEAST(X,Y,Z: Cardinal): Boolean;

** * This macro will evaluate to true if compiled with SDL at least X.Y.Z. *

procedure SDL_GetVersion(ver: PSDL_Version); cdecl; external SDL_LibName;

** * Get the version of SDL that is linked against your program. * * If you are linking to SDL dynamically, then it is possible that the * current version will be different than the version you compiled against. * This function returns the current version, while SDL_VERSION() is a * macro that tells you what version you compiled with. * * * compiled: TSDL_Version; * linked: TSDL_Version; * * SDL_VERSION(@compiled); * SDL_GetVersion(@linked); * WriteLn('We compiled against SDL version: ' + * IntToStr(compiled.major) + * IntToStr(compiled.minor) + * IntToStr(compiled.patch)); * WriteLn('But we linked against SDL version:' + * IntToStr(compiled.major) + * IntToStr(compiled.minor) + * IntToStr(compiled.patch)); * * * This function may be called safely at any time, even before SDL_Init(). * * SDL_VERSION *

function SDL_GetRevision(): PChar; cdecl; external SDL_LibName;

** * Get the code revision of SDL that is linked against your program. * * Returns an arbitrary string (a hash value) uniquely identifying the * exact revision of the SDL library in use, and is only useful in comparing * against other revisions. It is NOT an incrementing number. *

function SDL_GetRevisionNumber(): SInt32; cdecl; external SDL_LibName;

** * Get the revision number of SDL that is linked against your program. * * Returns a number uniquely identifying the exact revision of the SDL * library in use. It is an incrementing number based on commits to * hg.libsdl.org. *

function SDL_SetError(const fmt: PChar): SInt32; cdecl; external SDL_LibName;

* SDL_SetError() unconditionally returns -1. *

function SDL_GetError(): PChar; cdecl; external SDL_LibName;

This item has no description.

procedure SDL_ClearError(); cdecl; external SDL_LibName;

This item has no description.

function SDL_Error(code: TSDL_ErrorCode): SInt32; cdecl; external SDL_LibName;

* SDL_Error() unconditionally returns -1. *

function SDL_RWFromFile(const _file: PChar; const mode: PChar): PSDL_RWops; cdecl; external SDL_LibName;

** * RWFrom functions * * Functions to create SDL_RWops structures from various data streams. *

function SDL_RWFromFP(fp: Pointer; autoclose: TSDL_Bool): PSDL_RWops; cdecl; external SDL_LibName;

This item has no description.

function SDL_RWFromMem(mem: Pointer; size: SInt32): PSDL_RWops; cdecl; external SDL_LibName;

This item has no description.

function SDL_RWFromConstMem(const mem: Pointer; size: SInt32): PSDL_RWops; cdecl; external SDL_LibName;

This item has no description.

function SDL_AllocRW(): PSDL_RWops; cdecl; external SDL_LibName;

*RWFrom functions*

procedure SDL_FreeRW(area: PSDL_RWops); cdecl; external SDL_LibName;

This item has no description.

function SDL_RWsize(ctx: PSDL_RWops): SInt64;

** * Read/write macros * * Macros to easily read and write from an SDL_RWops structure. *

function SDL_RWseek(ctx: PSDL_RWops; offset: SInt64; whence: SInt32): SInt64;

This item has no description.

function SDL_RWtell(ctx: PSDL_RWops): SInt64;

This item has no description.

function SDL_RWread(ctx: PSDL_RWops; ptr: Pointer; size: size_t; n: size_t): size_t;

This item has no description.

function SDL_RWwrite(ctx: PSDL_RWops; ptr: Pointer; size: size_t; n: size_t): size_t;

This item has no description.

function SDL_RWclose(ctx: PSDL_RWops): SInt32;

This item has no description.

function SDL_ReadU8(src: PSDL_RWops): UInt8; cdecl; external SDL_LibName;

** * Read endian functions * * Read an item of the specified endianness and return in native format. *

function SDL_ReadLE16(src: PSDL_RWops): UInt16; cdecl; external SDL_LibName;

This item has no description.

function SDL_ReadBE16(src: PSDL_RWops): UInt16; cdecl; external SDL_LibName;

This item has no description.

function SDL_ReadLE32(src: PSDL_RWops): UInt32; cdecl; external SDL_LibName;

This item has no description.

function SDL_ReadBE32(src: PSDL_RWops): UInt32; cdecl; external SDL_LibName;

This item has no description.

function SDL_ReadLE64(src: PSDL_RWops): UInt64; cdecl; external SDL_LibName;

This item has no description.

function SDL_ReadBE64(src: PSDL_RWops): UInt64; cdecl; external SDL_LibName;

This item has no description.

function SDL_WriteU8(dst: PSDL_RWops; value: UInt8): size_t; cdecl; external SDL_LibName;

** * Write endian functions * * Write an item of native format to the specified endianness. *

function SDL_WriteLE16(dst: PSDL_RWops; value: UInt16): size_t; cdecl; external SDL_LibName;

This item has no description.

function SDL_WriteBE16(dst: PSDL_RWops; value: UInt16): size_t; cdecl; external SDL_LibName;

This item has no description.

function SDL_WriteLE32(dst: PSDL_RWops; value: UInt32): size_t; cdecl; external SDL_LibName;

This item has no description.

function SDL_WriteBE32(dst: PSDL_RWops; value: UInt32): size_t; cdecl; external SDL_LibName;

This item has no description.

function SDL_WriteLE64(dst: PSDL_RWops; value: UInt64): size_t; cdecl; external SDL_LibName;

This item has no description.

function SDL_WriteBE64(dst: PSDL_RWops; value: UInt64): size_t; cdecl; external SDL_LibName;

This item has no description.

function SDL_AUDIO_BITSIZE(x: Cardinal): Cardinal;

This item has no description.

function SDL_AUDIO_ISFLOAT(x: Cardinal): Cardinal;

This item has no description.

function SDL_AUDIO_ISBIGENDIAN(x: Cardinal): Cardinal;

This item has no description.

function SDL_AUDIO_ISSIGNED(x: Cardinal): Cardinal;

This item has no description.

function SDL_AUDIO_ISINT(x: Cardinal): Cardinal;

This item has no description.

function SDL_AUDIO_ISLITTLEENDIAN(x: Cardinal): Cardinal;

This item has no description.

function SDL_AUDIO_ISUNSIGNED(x: Cardinal): Cardinal;

This item has no description.

function SDL_GetNumAudioDrivers(): Integer; cdecl; external SDL_LibName;

** * Driver discovery functions * * These functions return the list of built in audio drivers, in the * order that they are normally initialized by default. *

function SDL_GetAudioDriver(index: Integer): PChar; cdecl; external SDL_LibName;

This item has no description.

function SDL_AudioInit(driver_name: PChar): Integer; cdecl; external SDL_LibName;

** * Initialization and cleanup * * These functions are used internally, and should not be used unless * you have a specific need to specify the audio driver you want to * use. You should normally use SDL_Init() or SDL_InitSubSystem(). *

procedure SDL_AudioQuit(); cdecl; external SDL_LibName;

This item has no description.

function SDL_GetCurrentAudioDriver(): PChar; cdecl; external SDL_LibName;

** * This function returns the name of the current audio driver, or NULL * if no driver has been initialized. *

function SDL_OpenAudio(desired: PSDL_AudioSpec; obtained: PSDL_AudioSpec): Integer; cdecl; external SDL_LibName;

** * This function opens the audio device with the desired parameters, and * returns 0 if successful, placing the actual hardware parameters in the * structure pointed to by obtained. If obtained is NULL, the audio * data passed to the callback function will be guaranteed to be in the * requested format, and will be automatically converted to the hardware * audio format if necessary. This function returns -1 if it failed * to open the audio device, or couldn't set up the audio thread. * * When filling in the desired audio spec structure, * - desired->freq should be the desired audio frequency in samples-per- * second. * - desired->format should be the desired audio format. * - desired->samples is the desired size of the audio buffer, in * samples. This number should be a power of two, and may be adjusted by * the audio driver to a value more suitable for the hardware. Good values * seem to range between 512 and 8096 inclusive, depending on the * application and CPU speed. Smaller values yield faster response time, * but can lead to underflow if the application is doing heavy processing * and cannot fill the audio buffer in time. A stereo sample consists of * both right and left channels in LR ordering. * Note that the number of samples is directly related to time by the * following formula: ms := (samples*1000)/freq; * - desired->size is the size in bytes of the audio buffer, and is * calculated by SDL_OpenAudio(). * - desired->silence is the value used to set the buffer to silence, * and is calculated by SDL_OpenAudio(). * - desired->callback should be set to a function that will be called * when the audio device is ready for more data. It is passed a pointer * to the audio buffer, and the length in bytes of the audio buffer. * This function usually runs in a separate thread, and so you should * protect data structures that it accesses by calling SDL_LockAudio() * and SDL_UnlockAudio() in your code. * - desired->userdata is passed as the first parameter to your callback * function. * * The audio device starts out playing silence when it's opened, and should * be enabled for playing by calling SDL_PauseAudio(0) when you are ready * for your audio callback function to be called. Since the audio driver * may modify the requested size of the audio buffer, you should allocate * any local mixing buffers after you open the audio device. *

function SDL_GetNumAudioDevices(iscapture: Integer): Integer; cdecl; external SDL_LibName;

** * Get the number of available devices exposed by the current driver. * Only valid after a successfully initializing the audio subsystem. * Returns -1 if an explicit list of devices can't be determined; this is * not an error. For example, if SDL is set up to talk to a remote audio * server, it can't list every one available on the Internet, but it will * still allow a specific host to be specified to SDL_OpenAudioDevice(). * * In many common cases, when this function returns a value <= 0, it can still * successfully open the default device (NULL for first argument of * SDL_OpenAudioDevice()). *

function SDL_GetAudioDeviceName(index: Integer; iscapture: Integer): PChar; cdecl; external SDL_LibName;

** * Get the human-readable name of a specific audio device. * Must be a value between 0 and (number of audio devices-1). * Only valid after a successfully initializing the audio subsystem. * The values returned by this function reflect the latest call to * SDL_GetNumAudioDevices(); recall that function to redetect available * hardware. * * The string returned by this function is UTF-8 encoded, read-only, and * managed internally. You are not to free it. If you need to keep the * string for any length of time, you should make your own copy of it, as it * will be invalid next time any of several other SDL functions is called. *

function SDL_OpenAudioDevice(device: PChar; iscapture: Integer; desired: PSDL_AudioSpec; obtained: PSDL_AudioSpec; allowed_changes: Integer): TSDL_AudioDeviceID; cdecl; external SDL_LibName;

** * Open a specific audio device. Passing in a device name of NULL requests * the most reasonable default (and is equivalent to calling SDL_OpenAudio()). * * The device name is a UTF-8 string reported by SDL_GetAudioDeviceName(), but * some drivers allow arbitrary and driver-specific strings, such as a * hostname/IP address for a remote audio server, or a filename in the * diskaudio driver. * * 0 on error, a valid device ID that is >= 2 on success. * * SDL_OpenAudio(), unlike this function, always acts on device ID 1. *

function SDL_GetAudioStatus(): TSDL_AudioStatus; cdecl; external SDL_LibName;

This item has no description.

function SDL_GetAudioDeviceStatus(dev: TSDL_AudioDeviceID): TSDL_AudioStatus; cdecl; external SDL_LibName;

This item has no description.

procedure SDL_PauseAudio(pause_on: Integer); cdecl; external SDL_LibName;

** * Pause audio functions * * These functions pause and unpause the audio callback processing. * They should be called with a parameter of 0 after opening the audio * device to start playing sound. This is so you can safely initialize * data for your callback function after opening the audio device. * Silence will be written to the audio device during the pause. *

procedure SDL_PauseAudioDevice(dev: TSDL_AudioDeviceID; pause_on: Integer); cdecl; external SDL_LibName;

This item has no description.

function SDL_LoadWAV_RW(src: PSDL_RWops; freesrc: Integer; spec: PSDL_AudioSpec; audio_buf: PPUInt8; audio_len: PUInt32): PSDL_AudioSpec; cdecl; external SDL_LibName;

** * This function loads a WAVE from the data source, automatically freeing * that source if freesrc is non-zero. For example, to load a WAVE file, * you could do: * * SDL_LoadWAV_RW(SDL_RWFromFile("sample.wav", "rb"), 1, ...); * * * If this function succeeds, it returns the given SDL_AudioSpec, * filled with the audio data format of the wave data, and sets * *audio_buf to a malloc()'d buffer containing the audio data, * and sets *audio_len to the length of that audio buffer, in bytes. * You need to free the audio buffer with SDL_FreeWAV() when you are * done with it. * * This function returns NULL and sets the SDL error message if the * wave file cannot be opened, uses an unknown data format, or is * corrupt. Currently raw and MS-ADPCM WAVE files are supported. *

function SDL_LoadWAV(_file: PChar; spec: PSDL_AudioSpec; audio_buf: PPUInt8; audio_len: PUInt32): PSDL_AudioSpec;

** * Loads a WAV from a file. * Compatibility convenience function. *

procedure SDL_FreeWAV(audio_buf: PUInt8); cdecl; external SDL_LibName;

** * This function frees data previously allocated with SDL_LoadWAV_RW() *

function SDL_BuildAudioCVT(cvt: PSDL_AudioCVT; src_format: TSDL_AudioFormat; src_channels: UInt8; src_rate: Integer; dst_format: TSDL_AudioFormat; dst_channels: UInt8; dst_rate: Integer): Integer; cdecl; external SDL_LibName;

** * This function takes a source format and rate and a destination format * and rate, and initializes the cvt structure with information needed * by SDL_ConvertAudio() to convert a buffer of audio data from one format * to the other. * * -1 if the format conversion is not supported, 0 if there's * no conversion needed, or 1 if the audio filter is set up. *

function SDL_ConvertAudio(cvt: PSDL_AudioCVT): Integer; cdecl; external SDL_LibName;

** * Once you have initialized the cvt structure using SDL_BuildAudioCVT(), * created an audio buffer cvt->buf, and filled it with cvt->len bytes of * audio data in the source format, this function will convert it in-place * to the desired format. * * The data conversion may expand the size of the audio data, so the buffer * cvt->buf should be allocated after the cvt structure is initialized by * SDL_BuildAudioCVT(), and should be cvt->len*cvt->len_mult bytes long. *

procedure SDL_MixAudio(dst: PUInt8; src: PUInt8; len: UInt32; volume: Integer); cdecl; external SDL_LibName;

** * This takes two audio buffers of the playing audio format and mixes * them, performing addition, volume adjustment, and overflow clipping. * The volume ranges from 0 - 128, and should be set to ::SDL_MIX_MAXVOLUME * for full audio volume. Note this does not change hardware volume. * This is provided for convenience – you can mix your own audio data. *

procedure SDL_MixAudioFormat(dst: PUInt8; src: PUInt8; format: TSDL_AudioFormat; len: UInt32; volume: Integer); cdecl; external SDL_LibName;

** * This works like SDL_MixAudio(), but you specify the audio format instead of * using the format of audio device 1. Thus it can be used when no audio * device is open at all. *

procedure SDL_LockAudio(); cdecl; external SDL_LibName;

** * Audio lock functions * * The lock manipulated by these functions protects the callback function. * During a SDL_LockAudio()/SDL_UnlockAudio() pair, you can be guaranteed that * the callback function is not running. Do not call these from the callback * function or you will cause deadlock. *

procedure SDL_LockAudioDevice(dev: TSDL_AudioDeviceID); cdecl; external SDL_LibName;

This item has no description.

procedure SDL_UnlockAudio(); cdecl; external SDL_LibName;

This item has no description.

procedure SDL_UnlockAudioDevice(dev: TSDL_AudioDeviceID); cdecl; external SDL_LibName;

This item has no description.

procedure SDL_CloseAudio(); cdecl; external SDL_LibName;

** * This function shuts down audio processing and closes the audio device. *

procedure SDL_CloseAudioDevice(dev: TSDL_AudioDeviceID); cdecl; external SDL_LibName;

This item has no description.

function SDL_AudioDeviceConnected(dev: TSDL_AudioDeviceID): Integer; cdecl; external SDL_LibName;

** * 1 if audio device is still functioning, zero if not, -1 on error. *

function SDL_GetPowerInfo(secs: PInt; pct: PInt): TSDL_PowerState; cdecl; external SDL_LibName;

** * Get the current power supply details. * * secs Seconds of battery life left. You can pass a NULL here if * you don't care. Will return -1 if we can't determine a * value, or we're not running on a battery. * * pct Percentage of battery life left, between 0 and 100. You can * pass a NULL here if you don't care. Will return -1 if we * can't determine a value, or we're not running on a battery. * * The state of the battery (if any). *

function SDL_CreateThread(fn: TSDL_ThreadFunction; name: PChar; data: Pointer; pfnBeginThread: TpfnSDL_CurrentBeginThread; pfnEndThread: TpfnSDL_CurrentEndThread): PSDL_Thread; cdecl; overload; external SDL_LibName;

** * Create a thread. *

function SDL_CreateThread(fn: TSDL_ThreadFunction; name: PChar; data: Pointer): PSDL_Thread; overload;

** * Create a thread. *

function SDL_GetThreadName(thread: PSDL_Thread): PChar; cdecl; external SDL_LibName;

** * Get the thread name, as it was specified in SDL_CreateThread(). * This function returns a pointer to a UTF-8 string that names the * specified thread, or NULL if it doesn't have a name. This is internal * memory, not to be free()'d by the caller, and remains valid until the * specified thread is cleaned up by SDL_WaitThread(). *

function SDL_ThreadID(): TSDL_ThreadID; cdecl; external SDL_LibName;

** * Get the thread identifier for the current thread. *

function SDL_GetThreadID(thread: PSDL_Thread): TSDL_ThreadID; cdecl; external SDL_LibName;

** * Get the thread identifier for the specified thread. * * Equivalent to SDL_ThreadID() if the specified thread is NULL. *

function SDL_SetThreadPriority(priority: TSDL_ThreadPriority): SInt32; cdecl; external SDL_LibName;

** * Set the priority for the current thread *

procedure SDL_WaitThread(thread: PSDL_Thread; status: PInt); cdecl; external SDL_LibName;

** * Wait for a thread to finish. * * The return code for the thread function is placed in the area * pointed to by status, if status is not NULL. *

function SDL_TLSCreate(): TSDL_TLSID; cdecl; external SDL_LibName;

* * SDL_TLSGet() * SDL_TLSSet() *

function SDL_TLSGet(id: TSDL_TLSID): Pointer; cdecl; external SDL_LibName;

** * Get the value associated with a thread local storage ID for the current thread. * * id The thread local storage ID * * The value associated with the ID for the current thread, or NULL if no value has been set. * * SDL_TLSCreate() * SDL_TLSSet() *

function SDL_TLSSet(id: TSDL_TLSID; value: Pointer; destructor_: Pointer): SInt32; cdecl; external SDL_LibName;

** * Set the value associated with a thread local storage ID for the current thread. * * id The thread local storage ID * value The value to associate with the ID for the current thread * destructor_ A function called when the thread exits, to free the value. * * 0 on success, -1 on error * * SDL_TLSCreate() * SDL_TLSGet() *

function SDL_CreateMutex(): PSDL_Mutex; cdecl; external SDL_LibName;

** * Create a mutex, initialized unlocked. *

function SDL_LockMutex(mutex: PSDL_Mutex): SInt32; cdecl; external SDL_LibName;

#define SDL_mutexP(m) SDL_LockMutex(m)

function SDL_TryLockMutex(mutex: PSDL_Mutex): SInt32; cdecl; external SDL_LibName;

** * Try to lock the mutex * * 0, SDL_MUTEX_TIMEDOUT, or -1 on error *

function SDL_UnlockMutex(mutex: PSDL_Mutex): SInt32; cdecl; external SDL_LibName;

#define SDL_mutexV(m) SDL_UnlockMutex(m)

procedure SDL_DestroyMutex(mutex: PSDL_Mutex); cdecl; external SDL_LibName;

** * Destroy a mutex. *

function SDL_CreateSemaphore(initial_value: UInt32): PSDL_sem; cdecl; external SDL_LibName;

** * Create a semaphore, initialized with value, returns NULL on failure. *

procedure SDL_DestroySemaphore(sem: PSDL_Sem); cdecl; external SDL_LibName;

** * Destroy a semaphore. *

function SDL_SemWait(sem: PSDL_Sem): SInt32; cdecl; external SDL_LibName;

** * This function suspends the calling thread until the semaphore pointed * to by sem has a positive count. It then atomically decreases the * semaphore count. *

function SDL_SemTryWait(sem: PSDL_Sem): SInt32; cdecl; external SDL_LibName;

** * Non-blocking variant of SDL_SemWait(). * * 0 if the wait succeeds, SDL_MUTEX_TIMEDOUT if the wait would * block, and -1 on error. *

function SDL_SemWaitTimeout(sem: PSDL_Sem; ms: UInt32): SInt32; cdecl; external SDL_LibName;

** * Variant of SDL_SemWait() with a timeout in milliseconds. * * 0 if the wait succeeds, ::SDL_MUTEX_TIMEDOUT if the wait does not * succeed in the allotted time, and -1 on error. * * On some platforms this function is implemented by looping with a * delay of 1 ms, and so should be avoided if possible. *

function SDL_SemPost(sem: PSDL_Sem): SInt32; cdecl; external SDL_LibName;

** * Atomically increases the semaphore's count (not blocking). * * 0, or -1 on error. *

function SDL_SemValue(sem: PSDL_Sem): UInt32; cdecl; external SDL_LibName;

** * Returns the current count of the semaphore. *

function SDL_CreateCond(): PSDL_Cond; cdecl; external SDL_LibName;

** * Create a condition variable. * * Typical use of condition variables: * * Thread A: * SDL_LockMutex(lock); * while ( not condition ) * begin * SDL_CondWait(cond, lock); * end; * SDL_UnlockMutex(lock); * * Thread B: * SDL_LockMutex(lock); * ... * condition := true; * ... * SDL_CondSignal(cond); * SDL_UnlockMutex(lock); * * There is some discussion whether to signal the condition variable * with the mutex locked or not. There is some potential performance * benefit to unlocking first on some platforms, but there are some * potential race conditions depending on how your code is structured. * * In general it's safer to signal the condition variable while the * mutex is locked. *

procedure SDL_DestroyCond(cond: PSDL_Cond); cdecl; external SDL_LibName;

** * Destroy a condition variable. *

function SDL_CondSignal(cond: PSDL_Cond): SInt32; cdecl; external SDL_LibName;

** * Restart one of the threads that are waiting on the condition variable. * * 0 or -1 on error. *

function SDL_CondBroadcast(cond: PSDL_Cond): SInt32; cdecl; external SDL_LibName;

** * Restart all threads that are waiting on the condition variable. * * 0 or -1 on error. *

function SDL_CondWait(cond: PSDL_Cond; mutex: PSDL_Mutex): SInt32; cdecl; external SDL_LibName;

** * Wait on the condition variable, unlocking the provided mutex. * * The mutex must be locked before entering this function! * * The mutex is re-locked once the condition variable is signaled. * * 0 when it is signaled, or -1 on error. *

function SDL_CondWaitTimeout(cond: PSDL_Cond; mutex: PSDL_Mutex; ms: UInt32): SInt32; cdecl; external SDL_LibName;

** * Waits for at most ms milliseconds, and returns 0 if the condition * variable is signaled, SDL_MUTEX_TIMEDOUT if the condition is not * signaled in the allotted time, and -1 on error. * * On some platforms this function is implemented by looping with a * delay of 1 ms, and so should be avoided if possible. *

function SDL_GetTicks(): UInt32; cdecl; external SDL_LibName;

** * Get the number of milliseconds since the SDL library initialization. * * This value wraps if the program runs for more than ~49 days. *

function SDL_GetPerformanceCounter(): UInt64; cdecl; external SDL_LibName;

** * Get the current value of the high resolution counter *

function SDL_GetPerformanceFrequency(): UInt64; cdecl; external SDL_LibName;

** * Get the count per second of the high resolution counter *

procedure SDL_Delay(ms: UInt32); cdecl; external SDL_LibName;

** * Wait a specified number of milliseconds before returning. *

function SDL_AddTimer(interval: UInt32; callback: TSDL_TimerCallback; param: Pointer): TSDL_TimerID; cdecl; external SDL_LibName;

** * Add a new timer to the pool of timers already running. * * A timer ID, or NULL when an error occurs. *

function SDL_RemoveTimer(id: TSDL_TimerID): Boolean; cdecl; external SDL_LibName;

** * Remove a timer knowing its ID. * * A boolean value indicating success or failure. * * It is not safe to remove a timer multiple times. *

function SDL_PIXELFLAG(X: Cardinal): Boolean;

//todo!! function SDL_DEFINE_PIXELFORMAT(type, order, layour, bit, bytes: UInt32): Result;

function SDL_DEFINE_PIXELFOURCC(A,B,C,D: Variant): Variant;

#define SDL_DEFINE_PIXELFORMAT(type, order, layout, bits, bytes) \ ((1 << 28) | ((type) << 24) | ((order) << 20) | ((layout) << 16) | \ ((bits) << 8) | ((bytes) << 0))

function SDL_PIXELTYPE(X: Cardinal): Boolean;

This item has no description.

function SDL_PIXELORDER(X: Cardinal): Boolean;

This item has no description.

function SDL_PIXELLAYOUT(X: Cardinal): Boolean;

This item has no description.

function SDL_BITSPERPIXEL(X: Cardinal): Boolean;

This item has no description.

function SDL_BYTESPERPIXEL(X: Integer): Integer;

This item has no description.

function SDL_GetPixelFormatName(format: UInt32): PChar; cdecl; external SDL_LibName;

** * Get the human readable name of a pixel format *

function SDL_PixelFormatEnumToMasks(format: UInt32; bpp: PInt; Rmask: PUInt32; Gmask: PUInt32; Bmask: PUInt32; Amask: PUInt32): TSDL_Bool; cdecl; external SDL_LibName;

** * Convert one of the enumerated pixel formats to a bpp and RGBA masks. * * SDL_TRUE, or SDL_FALSE if the conversion wasn't possible. * * SDL_MasksToPixelFormatEnum() *

function SDL_MasksToPixelFormatEnum(bpp: SInt32; Rmask: UInt32; Gmask: UInt32; Bmask: UInt32; Amask: UInt32): UInt32; cdecl; external SDL_LibName;

** * Convert a bpp and RGBA masks to an enumerated pixel format. * * The pixel format, or SDL_PIXELFORMAT_UNKNOWN if the conversion * wasn't possible. * * SDL_PixelFormatEnumToMasks() *

function SDL_AllocFormat(pixel_format: UInt32): PSDL_PixelFormat; cdecl; external SDL_LibName;

** * Create an SDL_PixelFormat structure from a pixel format enum. *

procedure SDL_FreeFormat(format: PSDL_PixelFormat); cdecl; external SDL_LibName;

** * Free an SDL_PixelFormat structure. *

function SDL_AllocPalette(ncolors: SInt32): PSDL_Palette; cdecl; external SDL_LibName;

** * Create a palette structure with the specified number of color * entries. * * A new palette, or nil if there wasn't enough memory. * * The palette entries are initialized to white. * * SDL_FreePalette() *

function SDL_SetPixelFormatPalette(format: PSDL_PixelFormat; palette: PSDL_Palette): SInt32; cdecl; external SDL_LibName;

** * Set the palette for a pixel format structure. *

function SDL_SetPaletteColors(palette: PSDL_Palette; const colors: PSDL_Color; firstcolor: SInt32; ncolors: SInt32): SInt32; cdecl; external SDL_LibName;

** * Set a range of colors in a palette. * * palette The palette to modify. * colors An array of colors to copy into the palette. * firstcolor The index of the first palette entry to modify. * ncolors The number of entries to modify. * * 0 on success, or -1 if not all of the colors could be set. *

procedure SDL_FreePalette(palette: PSDL_Palette); cdecl; external SDL_LibName;

** * Free a palette created with SDL_AllocPalette(). * * SDL_AllocPalette() *

function SDL_MapRGB(const format: PSDL_PixelFormat; r: UInt8; g: UInt8; b: UInt8): UInt32; cdecl; external SDL_LibName;

** * Maps an RGB triple to an opaque pixel value for a given pixel format. * * SDL_MapRGBA *

function SDL_MapRGBA(const format: PSDL_PixelFormat; r: UInt8; g: UInt8; b: UInt8; a: UInt8): UInt32; cdecl; external SDL_LibName;

** * Maps an RGBA quadruple to a pixel value for a given pixel format. * * SDL_MapRGB *

procedure SDL_GetRGB(pixel: UInt32; const format: PSDL_PixelFormat; r: PUInt8; g: PUInt8; b: PUInt8); cdecl; external SDL_LibName;

** * Get the RGB components from a pixel of the specified format. * * SDL_GetRGBA *

procedure SDL_GetRGBA(pixel: UInt32; const format: PSDL_PixelFormat; r: PUInt8; g: PUInt8; b: PUInt8; a: PUInt8); cdecl; external SDL_LibName;

** * Get the RGBA components from a pixel of the specified format. * * SDL_GetRGB *

procedure SDL_CalculateGammaRamp(gamma: Float; ramp: PUInt16); cdecl; external SDL_LibName;

** * Calculate a 256 entry gamma ramp for a gamma value. *

function SDL_RectEmpty(X: TSDL_Rect): Boolean;

changed from variant(b?????h!) to TSDL_Rect maybe PSDL_Rect?

function SDL_RectEquals(A: TSDL_Rect; B: TSDL_Rect): Boolean;

** * Returns true if the two rectangles are equal. *

function SDL_HasIntersection(const A: PSDL_Rect; const B: PSDL_Rect): TSDL_Bool; cdecl; external SDL_LibName;

** * Determine whether two rectangles intersect. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *

function SDL_IntersectRect(const A: PSDL_Rect; const B: PSDL_Rect; result: PSDL_Rect): TSDL_Bool; cdecl; external SDL_LibName;

** * Calculate the intersection of two rectangles. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *

procedure SDL_UnionRect(const A: PSDL_Rect; const B: PSDL_Rect; result: PSDL_Rect); cdecl; external SDL_LibName;

** * Calculate the union of two rectangles. *

function SDL_EnclosePoints(const points: PSDL_Point; count: SInt32; const clip: PSDL_Rect; result: PSDL_Rect): TSDL_Bool; cdecl; external SDL_LibName;

** * Calculate a minimal rectangle enclosing a set of points * * SDL_TRUE if any points were within the clipping rect *

function SDL_IntersectRectAndLine(const rect: PSDL_Rect; X1: PInt; Y1: PInt; X2: PInt; Y2: PInt): TSDL_Bool; cdecl; external SDL_LibName;

** * Calculate the intersection of a rectangle and line segment. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *

function SDL_CreateRGBSurface(flags: UInt32; width: SInt32; height: SInt32; depth: SInt32; Rmask: UInt32; Gmask: UInt32; Bmask: UInt32; Amask: UInt32): PSDL_Surface; cdecl; external SDL_LibName;

** * Allocate and free an RGB surface. * * If the depth is 4 or 8 bits, an empty palette is allocated for the surface. * If the depth is greater than 8 bits, the pixel format is set using the * flags '[RGB]mask'. * * If the function runs out of memory, it will return NULL. * * flags The flags are obsolete and should be set to 0. *

function SDL_CreateRGBSurfaceFrom(pixels: Pointer; width: SInt32; height: SInt32; depth: SInt32; pitch: SInt32; Rmask: UInt32; Gmask: UInt32; Bmask: UInt32; Amask: UInt32): PSDL_Surface; cdecl; external SDL_LibName;

This item has no description.

procedure SDL_FreeSurface(surface: PSDL_Surface); cdecl; external SDL_LibName;

This item has no description.

function SDL_SetSurfacePalette(surface: PSDL_Surface; palette: PSDL_Palette): SInt32; cdecl; external SDL_LibName;

** * Set the palette used by a surface. * * 0, or -1 if the surface format doesn't use a palette. * * A single palette can be shared with many surfaces. *

function SDL_LockSurface(surface: PSDL_Surface): SInt32; cdecl; external SDL_LibName;

** * Sets up a surface for directly accessing the pixels. * * Between calls to SDL_LockSurface() / SDL_UnlockSurface(), you can write * to and read from surface.pixels, using the pixel format stored in * surface.format. Once you are done accessing the surface, you should * use SDL_UnlockSurface() to release it. * * Not all surfaces require locking. If SDL_MUSTLOCK(surface) evaluates * to 0, then you can read and write to the surface at any time, and the * pixel format of the surface will not change. * * No operating system or library calls should be made between lock/unlock * pairs, as critical system locks may be held during this time. * * SDL_LockSurface() returns 0, or -1 if the surface couldn't be locked. * * SDL_UnlockSurface() *

procedure SDL_UnlockSurface(surface: PSDL_Surface); cdecl; external SDL_LibName;

** SDL_LockSurface() *

function SDL_LoadBMP_RW(src: PSDL_RWops; freesrc: SInt32): PSDL_Surface; cdecl; external SDL_LibName;

** * Load a surface from a seekable SDL data stream (memory or file). * * If freesrc is non-zero, the stream will be closed after being read. * * The new surface should be freed with SDL_FreeSurface(). * * the new surface, or NULL if there was an error. *

function SDL_LoadBMP(_file: PChar): PSDL_Surface;

** * Load a surface from a file. * * Convenience macro. *

function SDL_SaveBMP_RW(surface: PSDL_Surface; dst: PSDL_RWops; freedst: SInt32): SInt32; cdecl; external SDL_LibName;

** * Save a surface to a seekable SDL data stream (memory or file). * * If freedst is non-zero, the stream will be closed after being written. * * 0 if successful or -1 if there was an error. *

function SDL_SaveBMP(surface: PSDL_Surface; _file: PChar): SInt32;

** * Save a surface to a file. * * Convenience macro. *

function SDL_SetSurfaceRLE(surface: PSDL_Surface; flag: SInt32): SInt32; cdecl; external SDL_LibName;

** * Sets the RLE acceleration hint for a surface. * * 0 on success, or -1 if the surface is not valid * * If RLE is enabled, colorkey and alpha blending blits are much faster, * but the surface must be locked before directly accessing the pixels. *

function SDL_SetColorKey(surface: PSDL_Surface; flag: SInt32; key: UInt32): SInt32; cdecl; external SDL_LibName;

** * Sets the color key (transparent pixel) in a blittable surface. * * surface The surface to update * flag Non-zero to enable colorkey and 0 to disable colorkey * key The transparent pixel in the native surface format * * 0 on success, or -1 if the surface is not valid * * You can pass SDL_RLEACCEL to enable RLE accelerated blits. *

function SDL_GetColorKey(surface: PSDL_Surface; key: PUInt32): SInt32; cdecl; external SDL_LibName;

** * Gets the color key (transparent pixel) in a blittable surface. * * surface The surface to update * key A pointer filled in with the transparent pixel in the native * surface format * * 0 on success, or -1 if the surface is not valid or colorkey is not * enabled. *

function SDL_SetSurfaceColorMod(surface: PSDL_Surface; r: UInt8; g: UInt8; b: UInt8): SInt32; cdecl; external SDL_LibName;

** * Set an additional color value used in blit operations. * * surface The surface to update. * r The red color value multiplied into blit operations. * g The green color value multiplied into blit operations. * b The blue color value multiplied into blit operations. * * 0 on success, or -1 if the surface is not valid. * * SDL_GetSurfaceColorMod() *

function SDL_GetSurfaceColorMod(surface: PSDL_Surface; r: PUInt8; g: PUInt8; b: PUInt8): SInt32; cdecl; external SDL_LibName;

** * Get the additional color value used in blit operations. * * surface The surface to query. * r A pointer filled in with the current red color value. * g A pointer filled in with the current green color value. * b A pointer filled in with the current blue color value. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceColorMod() *

function SDL_SetSurfaceAlphaMod(surface: PSDL_Surface; alpha: UInt8): SInt32; cdecl; external SDL_LibName;

** * Set an additional alpha value used in blit operations. * * surface The surface to update. * alpha The alpha value multiplied into blit operations. * * 0 on success, or -1 if the surface is not valid. * * SDL_GetSurfaceAlphaMod() *

function SDL_GetSurfaceAlphaMod(surface: PSDL_Surface; alpha: PUInt8): SInt32; cdecl; external SDL_LibName;

** * Get the additional alpha value used in blit operations. * * surface The surface to query. * alpha A pointer filled in with the current alpha value. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceAlphaMod() *

function SDL_SetSurfaceBlendMode(surface: PSDL_Surface; blendMode: TSDL_BlendMode): SInt32; cdecl; external SDL_LibName;

** * Set the blend mode used for blit operations. * * surface The surface to update. * blendMode ::SDL_BlendMode to use for blit blending. * * 0 on success, or -1 if the parameters are not valid. * * SDL_GetSurfaceBlendMode() *

function SDL_GetSurfaceBlendMode(surface: PSDL_Surface; blendMode: PSDL_BlendMode): SInt32; cdecl; external SDL_LibName;

** * Get the blend mode used for blit operations. * * surface The surface to query. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceBlendMode() *

function SDL_SetClipRect(surface: PSDL_Surface; const rect: PSDL_Rect): TSDL_Bool; cdecl; external SDL_LibName;

** * Sets the clipping rectangle for the destination surface in a blit. * * If the clip rectangle is NULL, clipping will be disabled. * * If the clip rectangle doesn't intersect the surface, the function will * return SDL_FALSE and blits will be completely clipped. Otherwise the * function returns SDL_TRUE and blits to the surface will be clipped to * the intersection of the surface area and the clipping rectangle. * * Note that blits are automatically clipped to the edges of the source * and destination surfaces. *

procedure SDL_GetClipRect(surface: PSDL_Surface; rect: PSDL_Rect); cdecl; external SDL_LibName;

** * Gets the clipping rectangle for the destination surface in a blit. * * rect must be a pointer to a valid rectangle which will be filled * with the correct values. *

function SDL_ConvertSurface(src: PSDL_Surface; fmt: PSDL_PixelFormat; flags: UInt32): PSDL_Surface; cdecl; external SDL_LibName;

** * Creates a new surface of the specified format, and then copies and maps * the given surface to it so the blit of the converted surface will be as * fast as possible. If this function fails, it returns NULL. * * The flags parameter is passed to SDL_CreateRGBSurface() and has those * semantics. You can also pass SDL_RLEACCEL in the flags parameter and * SDL will try to RLE accelerate colorkey and alpha blits in the resulting * surface. *

function SDL_ConvertSurfaceFormat(src: PSDL_Surface; pixel_format: UInt32; flags: UInt32): PSDL_Surface; cdecl; external SDL_LibName;

This item has no description.

function SDL_ConvertPixels(width: SInt32; height: SInt32; src_format: UInt32; const src: Pointer; src_pitch: SInt32; dst_format: UInt32; dst: Pointer; dst_pitch: SInt32): SInt32; cdecl; external SDL_LibName;

** * Copy a block of pixels of one format to another format * * 0 on success, or -1 if there was an error *

function SDL_FillRect(dst: PSDL_Surface; const rect: PSDL_Rect; color: UInt32): SInt32; cdecl; external SDL_LibName;

** * Performs a fast fill of the given rectangle with color. * * If rect is NULL, the whole surface will be filled with color. * * The color should be a pixel of the format used by the surface, and * can be generated by the SDL_MapRGB() function. * * 0 on success, or -1 on error. *

function SDL_FillRects(dst: PSDL_Surface; const rects: PSDL_Rect; count: SInt32; color: UInt32): SInt32; cdecl; external SDL_LibName;

This item has no description.

function SDL_UpperBlit(src: PSDL_Surface; const srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * This is the public blit function, SDL_BlitSurface(), and it performs * rectangle validation and clipping before passing it to SDL_LowerBlit() *

function SDL_LowerBlit(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * This is a semi-private blit function and it performs low-level surface * blitting only. *

function SDL_SoftStretch(src: PSDL_Surface; const srcrect: PSDL_Rect; dst: PSDL_Surface; const dstrect: PSDL_Surface): SInt32; cdecl; external SDL_LibName;

** * Perform a fast, low quality, stretch blit between two surfaces of the * same pixel format. * * This function uses a static buffer, and is not thread-safe. *

function SDL_UpperBlitScaled(src: PSDL_Surface; const srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * This is the public scaled blit function, SDL_BlitScaled(), and it performs * rectangle validation and clipping before passing it to SDL_LowerBlitScaled() *

function SDL_LowerBlitScaled(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * This is a semi-private blit function and it performs low-level surface * scaled blitting only. *

function SDL_GetShapedWindowMode(window: PSDL_Window; shape_mode: TSDL_WindowShapeMode): SInt32; cdecl; external SDL_LibName;

** * Get the shape parameters of a shaped window. * * window The shaped window whose parameters should be retrieved. * shape_mode An empty shape-mode structure to fill, or NULL to check whether the window has a shape. * * 0 if the window has a shape and, provided shape_mode was not NULL, shape_mode has been filled with the mode * data, SDL_NONSHAPEABLE_WINDOW if the SDL_Window given is not a shaped window, or SDL_WINDOW_LACKS_SHAPE if * the SDL_Window* given is a shapeable window currently lacking a shape. * * SDL_WindowShapeMode * SDL_SetWindowShape *

function SDL_SetWindowShape(window: PSDL_Window; shape: PSDL_Surface; shape_mode: PSDL_WindowShapeMode): SInt32; cdecl; external SDL_LibName;

** * Set the shape and parameters of a shaped window. * * window The shaped window whose parameters should be set. * shape A surface encoding the desired shape for the window. * shape_mode The parameters to set for the shaped window. * * 0 on success, SDL_INVALID_SHAPE_ARGUMENT on invalid an invalid shape argument, or SDL_NONSHAPEABLE_WINDOW * if the SDL_Window* given does not reference a valid shaped window. * * SDL_WindowShapeMode * SDL_GetShapedWindowMode. *

function SDL_CreateShapedWindow(title: PChar; x: UInt32; y: UInt32; w: UInt32; h: UInt32; flags: UInt32): PSDL_Window; cdecl; external SDL_LibName;

** * Create a window that can be shaped with the specified position, dimensions, and flags. * * title The title of the window, in UTF-8 encoding. * x The x position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * y The y position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * w The width of the window. * h The height of the window. * flags The flags for the window, a mask of SDL_WINDOW_BORDERLESS with any of the following: * SDL_WINDOW_OPENGL, SDL_WINDOW_INPUT_GRABBED, * SDL_WINDOW_SHOWN, SDL_WINDOW_RESIZABLE, * SDL_WINDOW_MAXIMIZED, SDL_WINDOW_MINIMIZED, * SDL_WINDOW_BORDERLESS is always set, and SDL_WINDOW_FULLSCREEN is always unset. * * The window created, or NULL if window creation failed. * * SDL_DestroyWindow() *

function SDL_IsShapedWindow(window: PSDL_Window): TSDL_Bool; cdecl; external SDL_LibName;

** * Return whether the given window is a shaped window. * * window The window to query for being shaped. * * SDL_TRUE if the window is a window that can be shaped, SDL_FALSE if the window is unshaped or NULL. * SDL_CreateShapedWindow *

function SDL_WindowPos_IsUndefined(X: Variant): Variant;

This item has no description.

function SDL_WindowPos_IsCentered(X: Variant): Variant;

This item has no description.

function SDL_GetNumVideoDrivers(): SInt32; cdecl; external SDL_LibName;

** * Get the number of video drivers compiled into SDL * * SDL_GetVideoDriver() *

function SDL_GetVideoDriver(index: SInt32): PChar; cdecl; external SDL_LibName;

** * Get the name of a built in video driver. * * The video drivers are presented in the order in which they are * normally checked during initialization. * * SDL_GetNumVideoDrivers() *

function SDL_VideoInit(const driver_name: PChar): SInt32; cdecl; external SDL_LibName;

** * Initialize the video subsystem, optionally specifying a video driver. * * driver_name Initialize a specific driver by name, or nil for the * default video driver. * * 0 on success, -1 on error * * This function initializes the video subsystem; setting up a connection * to the window manager, etc, and determines the available display modes * and pixel formats, but does not initialize a window or graphics mode. * * SDL_VideoQuit() *

procedure SDL_VideoQuit(); cdecl; external SDL_LibName;

** * Shuts down the video subsystem. * * function closes all windows, and restores the original video mode. * * SDL_VideoInit() *

function SDL_GetCurrentVideoDriver(): PChar; cdecl; external SDL_LibName;

** * Returns the name of the currently initialized video driver. * * The name of the current video driver or nil if no driver * has been initialized * * SDL_GetNumVideoDrivers() * SDL_GetVideoDriver() *

function SDL_GetNumVideoDisplays(): SInt32; cdecl; external SDL_LibName;

** * Returns the number of available video displays. * * SDL_GetDisplayBounds() *

function SDL_GetDisplayName(displayIndex: SInt32): PChar; cdecl; external SDL_LibName;

** * Get the name of a display in UTF-8 encoding * * The name of a display, or nil for an invalid display index. * * SDL_GetNumVideoDisplays() *

function SDL_GetDisplayBounds(displayIndex: SInt32; rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * Get the desktop area represented by a display, with the primary * display located at 0,0 * * 0 on success, or -1 if the index is out of range. * * SDL_GetNumVideoDisplays() *

function SDL_GetNumDisplayModes(displayIndex: SInt32): SInt32; cdecl; external SDL_LibName;

** * Returns the number of available display modes. * * SDL_GetDisplayMode() *

function SDL_GetDisplayMode(displayIndex: SInt32; modeIndex: SInt32; mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;

** * Fill in information about a specific display mode. * * The display modes are sorted in this priority: * bits per pixel -> more colors to fewer colors * width -> largest to smallest * height -> largest to smallest * refresh rate -> highest to lowest * * SDL_GetNumDisplayModes() *

function SDL_GetDesktopDisplayMode(displayIndex: SInt32; mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;

** * Fill in information about the desktop display mode. *

function SDL_GetCurrentDisplayMode(displayIndex: SInt32; mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;

** * Fill in information about the current display mode. *

function SDL_GetClosestDisplayMode(displayIndex: SInt32; const mode: PSDL_DisplayMode; closest: PSDL_DisplayMode): PSDL_DisplayMode; cdecl; external SDL_LibName;

** * Get the closest match to the requested display mode. * * mode The desired display mode * closest A pointer to a display mode to be filled in with the closest * match of the available display modes. * * The passed in value closest, or nil if no matching video mode * was available. * * The available display modes are scanned, and closest is filled in with the * closest mode matching the requested mode and returned. The mode format and * refresh_rate default to the desktop mode if they are 0. The modes are * scanned with size being first priority, format being second priority, and * finally checking the refresh_rate. If all the available modes are too * small, then nil is returned. * * SDL_GetNumDisplayModes() * SDL_GetDisplayMode() *

function SDL_GetWindowDisplayIndex(window: PSDL_Window): SInt32; cdecl; external SDL_LibName;

** * Get the display index associated with a window. * * the display index of the display containing the center of the * window, or -1 on error. *

function SDL_SetWindowDisplayMode(window: PSDL_Window; const mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;

** * Set the display mode used when a fullscreen window is visible. * * By default the window's dimensions and the desktop format and refresh rate * are used. * * mode The mode to use, or nil for the default mode. * * 0 on success, or -1 if setting the display mode failed. * * SDL_GetWindowDisplayMode() * SDL_SetWindowFullscreen() *

function SDL_GetWindowDisplayMode(window: PSDL_Window; mode: PSDL_DisplayMode): SInt32; cdecl; external SDL_LibName;

** * Fill in information about the display mode used when a fullscreen * window is visible. * * SDL_SetWindowDisplayMode() * SDL_SetWindowFullscreen() *

function SDL_GetWindowPixelFormat(window: PSDL_Window): UInt32; cdecl; external SDL_LibName;

** * Get the pixel format associated with the window. *

function SDL_CreateWindow(const title: PChar; x: SInt32; y: SInt32; w: SInt32; h: SInt32; flags: UInt32): PSDL_Window; cdecl; external SDL_LibName;

** * Create a window with the specified position, dimensions, and flags. * * title The title of the window, in UTF-8 encoding. * x The x position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * y The y position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * w The width of the window. * h The height of the window. * flags The flags for the window, a mask of any of the following: * ::SDL_WINDOW_FULLSCREEN, ::SDL_WINDOW_OPENGL, * ::SDL_WINDOW_SHOWN, ::SDL_WINDOW_BORDERLESS, * ::SDL_WINDOW_RESIZABLE, ::SDL_WINDOW_MAXIMIZED, * ::SDL_WINDOW_MINIMIZED, ::SDL_WINDOW_INPUT_GRABBED. * * The id of the window created, or zero if window creation failed. * * SDL_DestroyWindow() *

function SDL_CreateWindowFrom(const data: Pointer): PSDL_Window; cdecl; external SDL_LibName;

** * Create an SDL window from an existing native window. * * data A pointer to driver-dependent window creation data * * The id of the window created, or zero if window creation failed. * * SDL_DestroyWindow() *

function SDL_GetWindowID(window: PSDL_Window): UInt32; cdecl; external SDL_LibName;

** * Get the numeric ID of a window, for logging purposes. *

function SDL_GetWindowFromID(id: UInt32): PSDL_Window; cdecl; external SDL_LibName;

** * Get a window from a stored ID, or nil if it doesn't exist. *

function SDL_GetWindowFlags(window: PSDL_Window): UInt32; cdecl; external SDL_LibName;

** * Get the window flags. *

procedure SDL_SetWindowTitle(window: PSDL_Window; const title: PChar); cdecl; external SDL_LibName;

** * Set the title of a window, in UTF-8 format. * * SDL_GetWindowTitle() *

function SDL_GetWindowTitle(window: PSDL_Window): PChar; cdecl; external SDL_LibName;

** * Get the title of a window, in UTF-8 format. * * SDL_SetWindowTitle() *

procedure SDL_SetWindowIcon(window: PSDL_Window; icon: PSDL_Surface); cdecl; external SDL_LibName;

** * Set the icon for a window. * * icon The icon for the window. *

function SDL_SetWindowData(window: PSDL_Window; const name: PChar; userdata: Pointer): Pointer; cdecl; external SDL_LibName;

** * Associate an arbitrary named pointer with a window. * * window The window to associate with the pointer. * name The name of the pointer. * userdata The associated pointer. * * The previous value associated with 'name' * * The name is case-sensitive. * * SDL_GetWindowData() *

function SDL_GetWindowData(window: PSDL_Window; const name: PChar): Pointer; cdecl; external SDL_LibName;

** * Retrieve the data pointer associated with a window. * * window The window to query. * name The name of the pointer. * * The value associated with 'name' * * SDL_SetWindowData() *

procedure SDL_SetWindowPosition(window: PSDL_Window; x: SInt32; y: SInt32); cdecl; external SDL_LibName;

** * Set the position of a window. * * window The window to reposition. * x The x coordinate of the window, SDL_WINDOWPOS_CENTERED, or * SDL_WINDOWPOS_UNDEFINED. * y The y coordinate of the window, SDL_WINDOWPOS_CENTERED, or * SDL_WINDOWPOS_UNDEFINED. * * The window coordinate origin is the upper left of the display. * * SDL_GetWindowPosition() *

procedure SDL_GetWindowPosition(window: PSDL_Window; x: PInt; y: PInt); cdecl; external SDL_LibName;

** * Get the position of a window. * * x Pointer to variable for storing the x position, may be nil * y Pointer to variable for storing the y position, may be nil * * SDL_SetWindowPosition() *

procedure SDL_SetWindowSize(window: PSDL_Window; w: SInt32; h: SInt32); cdecl; external SDL_LibName;

** * Set the size of a window's client area. * * w The width of the window, must be >0 * h The height of the window, must be >0 * * You can't change the size of a fullscreen window, it automatically * matches the size of the display mode. * * SDL_GetWindowSize() *

procedure SDL_GetWindowSize(window: PSDL_Window; w: PInt; h: PInt); cdecl; external SDL_LibName;

** * Get the size of a window's client area. * * w Pointer to variable for storing the width, may be nil * h Pointer to variable for storing the height, may be nil * * SDL_SetWindowSize() *

procedure SDL_SetWindowMinimumSize(window: PSDL_Window; min_w: SInt32; min_h: SInt32); cdecl; external SDL_LibName;

** * Set the minimum size of a window's client area. * * min_w The minimum width of the window, must be >0 * min_h The minimum height of the window, must be >0 * * You can't change the minimum size of a fullscreen window, it * automatically matches the size of the display mode. * * SDL_GetWindowMinimumSize() * SDL_SetWindowMaximumSize() *

procedure SDL_GetWindowMinimumSize(window: PSDL_Window; w: PInt; h: PInt); cdecl; external SDL_LibName;

** * Get the minimum size of a window's client area. * * w Pointer to variable for storing the minimum width, may be nil * h Pointer to variable for storing the minimum height, may be nil * * SDL_GetWindowMaximumSize() * SDL_SetWindowMinimumSize() *

procedure SDL_SetWindowMaximumSize(window: PSDL_Window; max_w: SInt32; max_h: SInt32); cdecl; external SDL_LibName;

** * Set the maximum size of a window's client area. * * max_w The maximum width of the window, must be >0 * max_h The maximum height of the window, must be >0 * * You can't change the maximum size of a fullscreen window, it * automatically matches the size of the display mode. * * SDL_GetWindowMaximumSize() * SDL_SetWindowMinimumSize() *

procedure SDL_GetWindowMaximumSize(window: PSDL_Window; w: PInt; h: PInt); cdecl; external SDL_LibName;

** * Get the maximum size of a window's client area. * * w Pointer to variable for storing the maximum width, may be nil * h Pointer to variable for storing the maximum height, may be nil * * SDL_GetWindowMinimumSize() * SDL_SetWindowMaximumSize() *

procedure SDL_SetWindowBordered(window: PSDL_Window; bordered: TSDL_Bool); cdecl; external SDL_LibName;

** * Set the border state of a window. * * This will add or remove the window's SDL_WINDOW_BORDERLESS flag and * add or remove the border from the actual window. This is a no-op if the * window's border already matches the requested state. * * window The window of which to change the border state. * bordered SDL_FALSE to remove border, SDL_TRUE to add border. * * You can't change the border state of a fullscreen window. * * SDL_GetWindowFlags() *

procedure SDL_ShowWindow(window: PSDL_Window); cdecl; external SDL_LibName;

** * Show a window. * * SDL_HideWindow() *

procedure SDL_HideWindow(window: PSDL_Window); cdecl; external SDL_LibName;

** * Hide a window. * * SDL_ShowWindow() *

procedure SDL_RaiseWindow(window: PSDL_Window); cdecl; external SDL_LibName;

** * Raise a window above other windows and set the input focus. *

procedure SDL_MaximizeWindow(window: PSDL_Window); cdecl; external SDL_LibName;

** * Make a window as large as possible. * * SDL_RestoreWindow() *

procedure SDL_MinimizeWindow(window: PSDL_Window); cdecl; external SDL_LibName;

** * Minimize a window to an iconic representation. * * SDL_RestoreWindow() *

procedure SDL_RestoreWindow(window: PSDL_Window); cdecl; external SDL_LibName;

** * Restore the size and position of a minimized or maximized window. * * SDL_MaximizeWindow() * SDL_MinimizeWindow() *

function SDL_SetWindowFullscreen(window: PSDL_Window; flags: UInt32): SInt32; cdecl; external SDL_LibName;

** * Set a window's fullscreen state. * * 0 on success, or -1 if setting the display mode failed. * * SDL_SetWindowDisplayMode() * SDL_GetWindowDisplayMode() *

function SDL_GetWindowSurface(window: PSDL_Window): PSDL_Surface; cdecl; external SDL_LibName;

** * Get the SDL surface associated with the window. * * The window's framebuffer surface, or nil on error. * * A new surface will be created with the optimal format for the window, * if necessary. This surface will be freed when the window is destroyed. * * You may not combine this with 3D or the rendering API on this window. * * SDL_UpdateWindowSurface() * SDL_UpdateWindowSurfaceRects() *

function SDL_UpdateWindowSurface(window: PSDL_Window): SInt32; cdecl; external SDL_LibName;

** * Copy the window surface to the screen. * * 0 on success, or -1 on error. * * SDL_GetWindowSurface() * SDL_UpdateWindowSurfaceRects() *

function SDL_UpdateWindowSurfaceRects(window: PSDL_Window; rects: PSDL_Rect; numrects: SInt32): SInt32; cdecl; external SDL_LibName;

** * Copy a number of rectangles on the window surface to the screen. * * 0 on success, or -1 on error. * * SDL_GetWindowSurface() * SDL_UpdateWindowSurfaceRect() *

procedure SDL_SetWindowGrab(window: PSDL_Window; grabbed: TSDL_Bool); cdecl; external SDL_LibName;

** * Set a window's input grab mode. * * grabbed This is SDL_TRUE to grab input, and SDL_FALSE to release input. * * SDL_GetWindowGrab() *

function SDL_GetWindowGrab(window: PSDL_Window): TSDL_Bool; cdecl; external SDL_LibName;

** * Get a window's input grab mode. * * This returns SDL_TRUE if input is grabbed, and SDL_FALSE otherwise. * * SDL_SetWindowGrab() *

function SDL_SetWindowBrightness(window: PSDL_Window; brightness: Float): SInt32; cdecl; external SDL_LibName;

** * Set the brightness (gamma correction) for a window. * * 0 on success, or -1 if setting the brightness isn't supported. * * SDL_GetWindowBrightness() * SDL_SetWindowGammaRamp() *

function SDL_GetWindowBrightness(window: PSDL_Window): Float; cdecl; external SDL_LibName;

** * Get the brightness (gamma correction) for a window. * * The last brightness value passed to SDL_SetWindowBrightness() * * SDL_SetWindowBrightness() *

function SDL_SetWindowGammaRamp(window: PSDL_Window; const red: PUInt16; const green: PUInt16; const blue: PUInt16): SInt32; cdecl; external SDL_LibName;

** * Set the gamma ramp for a window. * * red The translation table for the red channel, or nil. * green The translation table for the green channel, or nil. * blue The translation table for the blue channel, or nil. * * 0 on success, or -1 if gamma ramps are unsupported. * * Set the gamma translation table for the red, green, and blue channels * of the video hardware. Each table is an array of 256 16-bit quantities, * representing a mapping between the input and output for that channel. * The input is the index into the array, and the output is the 16-bit * gamma value at that index, scaled to the output color precision. * * SDL_GetWindowGammaRamp() *

function SDL_GetWindowGammaRamp(window: PSDL_Window; red: PUInt16; green: PUInt16; blue: PUInt16): SInt32; cdecl; external SDL_LibName;

** * Get the gamma ramp for a window. * * red A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the red channel, or nil. * green A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the green channel, or nil. * blue A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the blue channel, or nil. * * 0 on success, or -1 if gamma ramps are unsupported. * * SDL_SetWindowGammaRamp() *

procedure SDL_DestroyWindow(window: PSDL_Window); cdecl; external SDL_LibName;

** * Destroy a window. *

function SDL_IsScreenSaverEnabled: TSDL_Bool; cdecl; external SDL_LibName;

** * Returns whether the screensaver is currently enabled (default on). * * SDL_EnableScreenSaver() * SDL_DisableScreenSaver() *

procedure SDL_EnableScreenSaver(); cdecl; external SDL_LibName;

** * Allow the screen to be blanked by a screensaver * * SDL_IsScreenSaverEnabled() * SDL_DisableScreenSaver() *

procedure SDL_DisableScreenSaver(); cdecl; external SDL_LibName;

** * Prevent the screen from being blanked by a screensaver * * SDL_IsScreenSaverEnabled() * SDL_EnableScreenSaver() *

function SDL_GL_LoadLibrary(const path: PChar): SInt32; cdecl; external SDL_LibName;

** * Dynamically load an OpenGL library. * * path The platform dependent OpenGL library name, or nil to open the * default OpenGL library. * * 0 on success, or -1 if the library couldn't be loaded. * * This should be done after initializing the video driver, but before * creating any OpenGL windows. If no OpenGL library is loaded, the default * library will be loaded upon creation of the first OpenGL window. * * If you do this, you need to retrieve all of the GL functions used in * your program from the dynamic library using SDL_GL_GetProcAddress(). * * SDL_GL_GetProcAddress() * SDL_GL_UnloadLibrary() *

function SDL_GL_GetProcAddress(const proc: PChar): Pointer; cdecl; external SDL_LibName;

** * Get the address of an OpenGL function. *

procedure SDL_GL_UnloadLibrary(); cdecl; external SDL_LibName;

** * Unload the OpenGL library previously loaded by SDL_GL_LoadLibrary(). * * SDL_GL_LoadLibrary() *

function SDL_GL_ExtensionSupported(const extension: PChar): TSDL_Bool; cdecl; external SDL_LibName;

** * Return true if an OpenGL extension is supported for the current * context. *

function SDL_GL_SetAttribute(attr: TSDL_GLattr; value: SInt32): SInt32; cdecl; external SDL_LibName;

** * Set an OpenGL window attribute before window creation. *

function SDL_GL_GetAttribute(attr: TSDL_GLattr; value: PInt): SInt32; cdecl; external SDL_LibName;

** * Get the actual value for an attribute from the current context. *

function SDL_GL_CreateContext(window: PSDL_Window): TSDL_GLContext; cdecl; external SDL_LibName;

** * Create an OpenGL context for use with an OpenGL window, and make it * current. * * SDL_GL_DeleteContext() *

function SDL_GL_MakeCurrent(window: PSDL_Window; context: TSDL_GLContext): SInt32; cdecl; external SDL_LibName;

** * Set up an OpenGL context for rendering into an OpenGL window. * * The context must have been created with a compatible window. *

function SDL_GL_GetCurrentWindow(): PSDL_Window; cdecl; external SDL_LibName;

** * Get the currently active OpenGL window. *

function SDL_GL_GetCurrentContext(): TSDL_GLContext; cdecl; external SDL_LibName;

** * Get the currently active OpenGL context. *

function SDL_GL_SetSwapInterval(interval: SInt32): SInt32; cdecl; external SDL_LibName;

** * Set the swap interval for the current OpenGL context. * * interval 0 for immediate updates, 1 for updates synchronized with the * vertical retrace. If the system supports it, you may * specify -1 to allow late swaps to happen immediately * instead of waiting for the next retrace. * * 0 on success, or -1 if setting the swap interval is not supported. * * SDL_GL_GetSwapInterval() *

function SDL_GL_GetSwapInterval(): SInt32; cdecl; external SDL_LibName;

** * Get the swap interval for the current OpenGL context. * * 0 if there is no vertical retrace synchronization, 1 if the buffer * swap is synchronized with the vertical retrace, and -1 if late * swaps happen immediately instead of waiting for the next retrace. * If the system can't determine the swap interval, or there isn't a * valid current context, this will return 0 as a safe default. * * SDL_GL_SetSwapInterval() *

procedure SDL_GL_SwapWindow(window: PSDL_Window); cdecl; external SDL_LibName;

** * Swap the OpenGL buffers for a window, if double-buffering is * supported. *

procedure SDL_GL_DeleteContext(context: TSDL_GLContext); cdecl; external SDL_LibName;

** * Delete an OpenGL context. * * SDL_GL_CreateContext() *

function SDL_GetNumRenderDrivers(): SInt32; cdecl; external SDL_LibName;

** * Get the number of 2D rendering drivers available for the current * display. * * A render driver is a set of code that handles rendering and texture * management on a particular display. Normally there is only one, but * some drivers may have several available with different capabilities. * * SDL_GetRenderDriverInfo() * SDL_CreateRenderer() *

function SDL_GetRenderDriverInfo(index: SInt32; info: PSDL_RendererInfo): SInt32; cdecl; external SDL_LibName;

** * Get information about a specific 2D rendering driver for the current * display. * * index The index of the driver to query information about. * info A pointer to an SDL_RendererInfo struct to be filled with * information on the rendering driver. * * 0 on success, -1 if the index was out of range. * * SDL_CreateRenderer() *

function SDL_CreateWindowAndRenderer(width: SInt32; height: SInt32; window_flags: UInt32; window: PPSDL_Window; renderer: PPSDL_Renderer): SInt32; cdecl; external SDL_LibName;

** * Create a window and default renderer * * width The width of the window * height The height of the window * window_flags The flags used to create the window * window A pointer filled with the window, or NULL on error * renderer A pointer filled with the renderer, or NULL on error * * 0 on success, or -1 on error *

function SDL_CreateRenderer(window: PSDL_Window; index: SInt32; flags: UInt32): PSDL_Renderer; cdecl; external SDL_LibName;

** * Create a 2D rendering context for a window. * * window The window where rendering is displayed. * index The index of the rendering driver to initialize, or -1 to * initialize the first one supporting the requested flags. * flags ::SDL_RendererFlags. * * A valid rendering context or NULL if there was an error. * * SDL_CreateSoftwareRenderer() * SDL_GetRendererInfo() * SDL_DestroyRenderer() *

function SDL_CreateSoftwareRenderer(surface: PSDL_Surface): PSDL_Renderer; cdecl; external SDL_LibName;

** * Create a 2D software rendering context for a surface. * * surface The surface where rendering is done. * * A valid rendering context or NULL if there was an error. * * SDL_CreateRenderer() * SDL_DestroyRenderer() *

function SDL_GetRenderer(window: PSDL_Window): PSDL_Renderer; cdecl; external SDL_LibName;

** * Get the renderer associated with a window. *

function SDL_GetRendererInfo(renderer: PSDL_Renderer; info: PSDL_RendererInfo): SInt32; cdecl; external SDL_LibName;

** * Get information about a rendering context. *

function SDL_GetRendererOutputSize(renderer: PSDL_Renderer; w: PInt; h: PInt): SInt32; cdecl; external SDL_LibName;

** * Get the output size of a rendering context. *

function SDL_CreateTexture(renderer: PSDL_Renderer; format: UInt32; access: SInt32; w: SInt32; h: SInt32): PSDL_Texture; cdecl; external SDL_LibName;

** * Create a texture for a rendering context. * * renderer The renderer. * format The format of the texture. * access One of the enumerated values in ::SDL_TextureAccess. * w The width of the texture in pixels. * h The height of the texture in pixels. * * The created texture is returned, or 0 if no rendering context was * active, the format was unsupported, or the width or height were out * of range. * * SDL_QueryTexture() * SDL_UpdateTexture() * SDL_DestroyTexture() *

function SDL_CreateTextureFromSurface(renderer: PSDL_Renderer; surface: PSDL_Surface): PSDL_Texture; cdecl; external SDL_LibName;

** * Create a texture from an existing surface. * * renderer The renderer. * surface The surface containing pixel data used to fill the texture. * * The created texture is returned, or 0 on error. * * The surface is not modified or freed by this function. * * SDL_QueryTexture() * SDL_DestroyTexture() *

function SDL_QueryTexture(texture: PSDL_Texture; format: PUInt32; access: PInt; w: PInt; h: PInt): SInt32; cdecl; external SDL_LibName;

** * Query the attributes of a texture * * texture A texture to be queried. * format A pointer filled in with the raw format of the texture. The * actual format may differ, but pixel transfers will use this * format. * access A pointer filled in with the actual access to the texture. * w A pointer filled in with the width of the texture in pixels. * h A pointer filled in with the height of the texture in pixels. * * 0 on success, or -1 if the texture is not valid. *

function SDL_SetTextureColorMod(texture: PSDL_Texture; r: UInt8; g: UInt8; b: UInt8): SInt32; cdecl; external SDL_LibName;

** * Set an additional color value used in render copy operations. * * texture The texture to update. * r The red color value multiplied into copy operations. * g The green color value multiplied into copy operations. * b The blue color value multiplied into copy operations. * * 0 on success, or -1 if the texture is not valid or color modulation * is not supported. * * SDL_GetTextureColorMod() *

function SDL_GetTextureColorMod(texture: PSDL_Texture; r: PUInt8; g: PUInt8; b: PUInt8): SInt32; cdecl; external SDL_LibName;

** * Get the additional color value used in render copy operations. * * texture The texture to query. * r A pointer filled in with the current red color value. * g A pointer filled in with the current green color value. * b A pointer filled in with the current blue color value. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureColorMod() *

function SDL_SetTextureAlphaMod(texture: PSDL_Texture; alpha: UInt8): SInt32; cdecl; external SDL_LibName;

** * Set an additional alpha value used in render copy operations. * * texture The texture to update. * alpha The alpha value multiplied into copy operations. * * 0 on success, or -1 if the texture is not valid or alpha modulation * is not supported. * * SDL_GetTextureAlphaMod() *

function SDL_GetTextureAlphaMod(texture: PSDL_Texture; alpha: PUInt8): SInt32; cdecl; external SDL_LibName;

** * Get the additional alpha value used in render copy operations. * * texture The texture to query. * alpha A pointer filled in with the current alpha value. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureAlphaMod() *

function SDL_SetTextureBlendMode(texture: PSDL_Texture; blendMode: TSDL_BlendMode): SInt32; cdecl; external SDL_LibName;

** * Set the blend mode used for texture copy operations. * * texture The texture to update. * blendMode ::SDL_BlendMode to use for texture blending. * * 0 on success, or -1 if the texture is not valid or the blend mode is * not supported. * * If the blend mode is not supported, the closest supported mode is * chosen. * * SDL_GetTextureBlendMode() *

function SDL_GetTextureBlendMode(texture: PSDL_Texture; blendMode: PSDL_BlendMode): SInt32; cdecl; external SDL_LibName;

** * Get the blend mode used for texture copy operations. * * texture The texture to query. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureBlendMode() *

function SDL_UpdateTexture(texture: PSDL_Texture; rect: PSDL_Rect; pixels: Pointer; pitch: SInt32): SInt32; cdecl; external SDL_LibName;

** * Update the given texture rectangle with new pixel data. * * texture The texture to update * rect A pointer to the rectangle of pixels to update, or NULL to * update the entire texture. * pixels The raw pixel data. * pitch The number of bytes between rows of pixel data. * * 0 on success, or -1 if the texture is not valid. * * This is a fairly slow function. *

function SDL_LockTexture(texture: PSDL_Texture; rect: PSDL_Rect; pixels: PPointer; pitch: PInt): SInt32; cdecl; external SDL_LibName;

** * Lock a portion of the texture for write-only pixel access. * * texture The texture to lock for access, which was created with * SDL_TEXTUREACCESS_STREAMING. * rect A pointer to the rectangle to lock for access. If the rect * is NULL, the entire texture will be locked. * pixels This is filled in with a pointer to the locked pixels, * appropriately offset by the locked area. * pitch This is filled in with the pitch of the locked pixels. * * 0 on success, or -1 if the texture is not valid or was not created with ::SDL_TEXTUREACCESS_STREAMING. * * SDL_UnlockTexture() *

procedure SDL_UnlockTexture(texture: PSDL_Texture); cdecl; external SDL_LibName;

** * Unlock a texture, uploading the changes to video memory, if needed. * * SDL_LockTexture() *

function SDL_RenderTargetSupported(renderer: PSDL_Renderer): Boolean; cdecl; external SDL_LibName;

** * Determines whether a window supports the use of render targets * * renderer The renderer that will be checked * * SDL_TRUE if supported, SDL_FALSE if not. *

function SDL_SetRenderTarget(renderer: PSDL_Renderer; texture: PSDL_Texture): SInt32; cdecl; external SDL_LibName;

** * Set a texture as the current rendering target. * * renderer The renderer. * texture The targeted texture, which must be created with the SDL_TEXTUREACCESS_TARGET flag, or NULL for the default render target * * 0 on success, or -1 on error * * SDL_GetRenderTarget() *

function SDL_GetRenderTarget(renderer: PSDL_Renderer): PSDL_Texture; cdecl; external SDL_LibName;

** * Get the current render target or NULL for the default render target. * * The current render target * * SDL_SetRenderTarget() *

function SDL_RenderSetLogicalSize(renderer: PSDL_Renderer; w: SInt32; h: SInt32): SInt32; cdecl; external SDL_LibName;

** * Set device independent resolution for rendering * * renderer The renderer for which resolution should be set. * w The width of the logical resolution * h The height of the logical resolution * * This function uses the viewport and scaling functionality to allow a fixed logical * resolution for rendering, regardless of the actual output resolution. If the actual * output resolution doesn't have the same aspect ratio the output rendering will be * centered within the output display. * * If the output display is a window, mouse events in the window will be filtered * and scaled so they seem to arrive within the logical resolution. * * If this function results in scaling or subpixel drawing by the * rendering backend, it will be handled using the appropriate * quality hints. * * SDL_RenderGetLogicalSize() * SDL_RenderSetScale() * SDL_RenderSetViewport() *

procedure SDL_RenderGetLogicalSize(renderer: PSDL_Renderer; w: PInt; h: PInt); cdecl; external SDL_LibName;

** * Get device independent resolution for rendering * * renderer The renderer from which resolution should be queried. * w A pointer filled with the width of the logical resolution * h A pointer filled with the height of the logical resolution * * SDL_RenderSetLogicalSize() *

function SDL_RenderSetViewport(renderer: PSDL_Renderer; const rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * Set the drawing area for rendering on the current target. * * renderer The renderer for which the drawing area should be set. * rect The rectangle representing the drawing area, or NULL to set the viewport to the entire target. * * The x,y of the viewport rect represents the origin for rendering. * * 0 on success, or -1 on error * * If the window associated with the renderer is resized, the viewport is automatically reset. * * SDL_RenderGetViewport() * SDL_RenderSetLogicalSize() *

procedure SDL_RenderGetViewport(renderer: PSDL_Renderer; rect: PSDL_Rect); cdecl; external SDL_LibName;

** * Get the drawing area for the current target. * * SDL_RenderSetViewport() *

function SDL_RenderSetClipRect(renderer: PSDL_Renderer; rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * Set the clip rectangle for the current target. * * renderer The renderer for which clip rectangle should be set. * rect A pointer to the rectangle to set as the clip rectangle, or * NULL to disable clipping. * * 0 on success, or -1 on error * * SDL_RenderGetClipRect() *

procedure SDL_RenderGetClipRect(renderer: PSDL_Renderer; rect: PSDL_Rect); cdecl; external SDL_LibName;

** * Get the clip rectangle for the current target. * * renderer The renderer from which clip rectangle should be queried. * rect A pointer filled in with the current clip rectangle, or * an empty rectangle if clipping is disabled. * * SDL_RenderSetClipRect() *

function SDL_RenderSetScale(renderer: PSDL_Renderer; scaleX: Float; scaleY: Float): SInt32; cdecl; external SDL_LibName;

** * Set the drawing scale for rendering on the current target. * * renderer The renderer for which the drawing scale should be set. * scaleX The horizontal scaling factor * scaleY The vertical scaling factor * * The drawing coordinates are scaled by the x/y scaling factors * before they are used by the renderer. This allows resolution * independent drawing with a single coordinate system. * * If this results in scaling or subpixel drawing by the * rendering backend, it will be handled using the appropriate * quality hints. For best results use integer scaling factors. * * SDL_RenderGetScale() * SDL_RenderSetLogicalSize() *

procedure SDL_RenderGetScale(renderer: PSDL_Renderer; scaleX: PFloat; scaleY: PFloat); cdecl; external SDL_LibName;

** * Get the drawing scale for the current target. * * renderer The renderer from which drawing scale should be queried. * scaleX A pointer filled in with the horizontal scaling factor * scaleY A pointer filled in with the vertical scaling factor * * SDL_RenderSetScale() *

function SDL_SetRenderDrawColor(renderer: PSDL_Renderer; r: UInt8; g: UInt8; b: UInt8; a: UInt8): SInt32; cdecl; external SDL_LibName;

** * Set the color used for drawing operations (Rect, Line and Clear). * * renderer The renderer for which drawing color should be set. * r The red value used to draw on the rendering target. * g The green value used to draw on the rendering target. * b The blue value used to draw on the rendering target. * a The alpha value used to draw on the rendering target, usually * SDL_ALPHA_OPAQUE (255). * * 0 on success, or -1 on error *

function SDL_GetRenderDrawColor(renderer: PSDL_Renderer; r: PUInt8; g: PUInt8; b: PUInt8; a: PUInt8): SInt32; cdecl; external SDL_LibName;

** * Get the color used for drawing operations (Rect, Line and Clear). * * renderer The renderer from which drawing color should be queried. * r A pointer to the red value used to draw on the rendering target. * g A pointer to the green value used to draw on the rendering target. * b A pointer to the blue value used to draw on the rendering target. * a A pointer to the alpha value used to draw on the rendering target, * usually SDL_ALPHA_OPAQUE (255). * * 0 on success, or -1 on error *

function SDL_SetRenderDrawBlendMode(renderer: PSDL_Renderer; blendMode: TSDL_BlendMode): SInt32; cdecl; external SDL_LibName;

** * Set the blend mode used for drawing operations (Fill and Line). * * renderer The renderer for which blend mode should be set. * blendMode SDL_BlendMode to use for blending. * * 0 on success, or -1 on error * * If the blend mode is not supported, the closest supported mode is * chosen. * * SDL_GetRenderDrawBlendMode() *

function SDL_GetRenderDrawBlendMode(renderer: PSDL_Renderer; blendMode: PSDL_BlendMode): SInt32; cdecl; external SDL_LibName;

** * Get the blend mode used for drawing operations. * * renderer The renderer from which blend mode should be queried. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 on error * * SDL_SetRenderDrawBlendMode() *

function SDL_RenderClear(renderer: PSDL_Renderer): SInt32; cdecl; external SDL_LibName;

** * Clear the current rendering target with the drawing color * * This function clears the entire rendering target, ignoring the viewport. * * 0 on success, or -1 on error *

function SDL_RenderDrawPoint(renderer: PSDL_Renderer; x: SInt32; y: SInt32): SInt32; cdecl; external SDL_LibName;

** * Draw a point on the current rendering target. * * renderer The renderer which should draw a point. * x The x coordinate of the point. * y The y coordinate of the point. * * 0 on success, or -1 on error *

function SDL_RenderDrawPoints(renderer: PSDL_Renderer; points: PSDL_Point; count: SInt32): SInt32; cdecl; external SDL_LibName;

** * Draw multiple points on the current rendering target. * * renderer The renderer which should draw multiple points. * points The points to draw * count The number of points to draw * * 0 on success, or -1 on error *

function SDL_RenderDrawLine(renderer: PSDL_Renderer; x1: SInt32; y1: SInt32; x2: SInt32; y2: SInt32): SInt32; cdecl; external SDL_LibName;

** * Draw a line on the current rendering target. * * renderer The renderer which should draw a line. * x1 The x coordinate of the start point. * y1 The y coordinate of the start point. * x2 The x coordinate of the end point. * y2 The y coordinate of the end point. * * 0 on success, or -1 on error *

function SDL_RenderDrawLines(renderer: PSDL_Renderer; points: PSDL_Point; count: SInt32): SInt32; cdecl; external SDL_LibName;

** * \brief Draw a series of connected lines on the current rendering target. * * \param renderer The renderer which should draw multiple lines. * \param points The points along the lines * \param count The number of points, drawing count-1 lines * * \return 0 on success, or -1 on error *

function SDL_RenderDrawRect(renderer: PSDL_Renderer; rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * Draw a rectangle on the current rendering target. * * renderer The renderer which should draw a rectangle. * rect A pointer to the destination rectangle, or NULL to outline the entire rendering target. * * 0 on success, or -1 on error *

function SDL_RenderDrawRects(renderer: PSDL_Renderer; rects: PSDL_Rect; count: SInt32): SInt32; cdecl; external SDL_LibName;

** * Draw some number of rectangles on the current rendering target. * * renderer The renderer which should draw multiple rectangles. * rects A pointer to an array of destination rectangles. * count The number of rectangles. * * 0 on success, or -1 on error *

function SDL_RenderFillRect(renderer: PSDL_Renderer; rect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * Fill a rectangle on the current rendering target with the drawing color. * * renderer The renderer which should fill a rectangle. * rect A pointer to the destination rectangle, or NULL for the entire * rendering target. * * 0 on success, or -1 on error *

function SDL_RenderFillRects(renderer: PSDL_Renderer; rects: PSDL_Rect; count: SInt32): SInt32; cdecl; external SDL_LibName;

** * Fill some number of rectangles on the current rendering target with the drawing color. * * renderer The renderer which should fill multiple rectangles. * rects A pointer to an array of destination rectangles. * count The number of rectangles. * * 0 on success, or -1 on error *

function SDL_RenderCopy(renderer: PSDL_Renderer; texture: PSDL_Texture; srcrect: PSDL_Rect; dstrect: PSDL_Rect): SInt32; cdecl; external SDL_LibName;

** * Copy a portion of the texture to the current rendering target. * * renderer The renderer which should copy parts of a texture. * texture The source texture. * srcrect A pointer to the source rectangle, or NULL for the entire * texture. * dstrect A pointer to the destination rectangle, or NULL for the * entire rendering target. * * 0 on success, or -1 on error *

function SDL_RenderCopyEx(renderer: PSDL_Renderer; texture: PSDL_Texture; const srcrect: PSDL_Rect; dstrect: PSDL_Rect; angle: Double; center: PSDL_Point; flip: PSDL_RendererFlip): SInt32; cdecl; external SDL_LibName;

** * Copy a portion of the source texture to the current rendering target, rotating it by angle around the given center * * renderer The renderer which should copy parts of a texture. * texture The source texture. * srcrect A pointer to the source rectangle, or NULL for the entire * texture. * dstrect A pointer to the destination rectangle, or NULL for the * entire rendering target. * angle An angle in degrees that indicates the rotation that will be applied to dstrect * center A pointer to a point indicating the point around which dstrect will be rotated (if NULL, rotation will be done aroud dstrect.w/2, dstrect.h/2) * flip An SDL_RendererFlip value stating which flipping actions should be performed on the texture * * 0 on success, or -1 on error *

function SDL_RenderReadPixels(renderer: PSDL_Renderer; rect: PSDL_Rect; format: UInt32; pixels: Pointer; pitch: SInt32): SInt32; cdecl; external SDL_LibName;

** * Read pixels from the current rendering target. * * renderer The renderer from which pixels should be read. * rect A pointer to the rectangle to read, or NULL for the entire * render target. * format The desired format of the pixel data, or 0 to use the format * of the rendering target * pixels A pointer to be filled in with the pixel data * pitch The pitch of the pixels parameter. * * 0 on success, or -1 if pixel reading is not supported. * * This is a very slow operation, and should not be used frequently. *

procedure SDL_RenderPresent(renderer: PSDL_Renderer); cdecl; external SDL_LibName;

** * Update the screen with rendering performed. *

procedure SDL_DestroyTexture(texture: PSDL_Texture); cdecl; external SDL_LibName;

** * Destroy the specified texture. * * SDL_CreateTexture() * SDL_CreateTextureFromSurface() *

procedure SDL_DestroyRenderer(renderer: PSDL_Renderer); cdecl; external SDL_LibName;

** * Destroy the rendering context for a window and free associated * textures. * * SDL_CreateRenderer() *

function SDL_GL_BindTexture(texture: PSDL_Texture; texw: PFloat; texh: PFloat): SInt32; cdecl; external SDL_LibName;

** * Bind the texture to the current OpenGL/ES/ES2 context for use with * OpenGL instructions. * * texture The SDL texture to bind * texw A pointer to a float that will be filled with the texture width * texh A pointer to a float that will be filled with the texture height * * 0 on success, or -1 if the operation is not supported *

function SDL_GL_UnbindTexture(texture: PSDL_Texture): SInt32; cdecl; external SDL_LibName;

** * Unbind a texture from the current OpenGL/ES/ES2 context. * * texture The SDL texture to unbind * * 0 on success, or -1 if the operation is not supported *

function SDL_GetKeyboardFocus(): PSDL_Window; cdecl; external SDL_LibName;

** * Get the window which currently has keyboard focus. *

function SDL_GetKeyboardState(numkeys: PInt): PUInt8; cdecl; external SDL_LibName;

** * Get a snapshot of the current state of the keyboard. * * numkeys if non-nil, receives the length of the returned array. * * An array of key states. Indexes into this array are obtained by using SDL_Scancode values. * *

function SDL_GetModState(): TSDL_KeyMod; cdecl; external SDL_LibName;

** * Get the current key modifier state for the keyboard. *

procedure SDL_SetModState(modstate: TSDL_KeyMod); cdecl; external SDL_LibName;

** * Set the current key modifier state for the keyboard. * * This does not change the keyboard state, only the key modifier flags. *

function SDL_GetKeyFromScancode(scancode: TSDL_ScanCode): TSDL_KeyCode; cdecl; external SDL_LibName;

** * Get the key code corresponding to the given scancode according * to the current keyboard layout. * * See SDL_Keycode for details. * * SDL_GetKeyName() *

function SDL_GetScancodeFromKey(key: TSDL_KeyCode): TSDL_ScanCode; cdecl; external SDL_LibName;

** * Get the scancode corresponding to the given key code according to the * current keyboard layout. * * See SDL_Scancode for details. * * SDL_GetScancodeName() *

function SDL_GetScancodeName(scancode: TSDL_ScanCode): PChar; cdecl; external SDL_LibName;

** * Get a human-readable name for a scancode. * * A pointer to the name for the scancode. * * If the scancode doesn't have a name, this function returns * an empty string (""). * *

function SDL_GetScancodeFromName(const name: PChar): TSDL_ScanCode; cdecl; external SDL_LibName;

** * Get a scancode from a human-readable name * * scancode, or SDL_SCANCODE_UNKNOWN if the name wasn't recognized * * SDL_Scancode *

function SDL_GetKeyName(key: TSDL_ScanCode): PChar; cdecl; external SDL_LibName;

** * Get a human-readable name for a key. * * A pointer to a UTF-8 string that stays valid at least until the next * call to this function. If you need it around any longer, you must * copy it. If the key doesn't have a name, this function returns an * empty string (""). * * SDL_Key *

function SDL_GetKeyFromName(const name: PChar): TSDL_KeyCode; cdecl; external SDL_LibName;

** * Get a key code from a human-readable name * * key code, or SDLK_UNKNOWN if the name wasn't recognized * * SDL_Keycode *

procedure SDL_StartTextInput(); cdecl; external SDL_LibName;

** * Start accepting Unicode text input events. * This function will show the on-screen keyboard if supported. * * SDL_StopTextInput() * SDL_SetTextInputRect() * SDL_HasScreenKeyboardSupport() *

function SDL_IsTextInputActive(): TSDL_Bool; cdecl; external SDL_LibName;

** * Return whether or not Unicode text input events are enabled. * * SDL_StartTextInput() * SDL_StopTextInput() *

procedure SDL_StopTextInput(); cdecl; external SDL_LibName;

** * Stop receiving any text input events. * This function will hide the on-screen keyboard if supported. * * SDL_StartTextInput() * SDL_HasScreenKeyboardSupport() *

procedure SDL_SetTextInputRect(rect: PSDL_Rect); cdecl; external SDL_LibName;

** * Set the rectangle used to type Unicode text inputs. * This is used as a hint for IME and on-screen keyboard placement. * * SDL_StartTextInput() *

function SDL_HasScreenKeyboardSupport(): TSDL_Bool; cdecl; external SDL_LibName;

** * Returns whether the platform has some screen keyboard support. * * SDL_TRUE if some keyboard support is available else SDL_FALSE. * * Not all screen keyboard functions are supported on all platforms. * * SDL_IsScreenKeyboardShown() *

function SDL_IsScreenKeyboardShown(window: PSDL_Window): TSDL_Bool; cdecl; external SDL_LibName;

** * Returns whether the screen keyboard is shown for given window. * * window The window for which screen keyboard should be queried. * * Result - SDL_TRUE if screen keyboard is shown else SDL_FALSE. * * SDL_HasScreenKeyboardSupport() *

function SDL_GetMouseFocus(): PSDL_Window; cdecl; external SDL_LibName;

** * Get the window which currently has mouse focus. *

function SDL_GetMouseState(x: PInt; y: PInt): UInt32; cdecl; external SDL_LibName;

** * Retrieve the current state of the mouse. * * The current button state is returned as a button bitmask, which can * be tested using the SDL_BUTTON(X) macros, and x and y are set to the * mouse cursor position relative to the focus window for the currently * selected mouse. You can pass nil for either x or y. * * SDL_Button = 1 shl ((X)-1) *

function SDL_GetRelativeMouseState(x: PInt; y: PInt): UInt32; cdecl; external SDL_LibName;

** * Retrieve the relative state of the mouse. * * The current button state is returned as a button bitmask, which can * be tested using the SDL_BUTTON(X) macros, and x and y are set to the * mouse deltas since the last call to SDL_GetRelativeMouseState(). *

procedure SDL_WarpMouseInWindow(window: PSDL_Window; x: SInt32; y: SInt32); cdecl; external SDL_LibName;

** * Moves the mouse to the given position within the window. * * window The window to move the mouse into, or nil for the current mouse focus * x The x coordinate within the window * y The y coordinate within the window * * This function generates a mouse motion event *

function SDL_SetRelativeMouseMode(enabled: TSDL_Bool): SInt32; cdecl; external SDL_LibName;

** * Set relative mouse mode. * * enabled Whether or not to enable relative mode * * 0 on success, or -1 if relative mode is not supported. * * While the mouse is in relative mode, the cursor is hidden, and the * driver will try to report continuous motion in the current window. * Only relative motion events will be delivered, the mouse position * will not change. * * This function will flush any pending mouse motion. * * SDL_GetRelativeMouseMode() *

function SDL_GetRelativeMouseMode(): TSDL_Bool; cdecl; external SDL_LibName;

** * Query whether relative mouse mode is enabled. * * SDL_SetRelativeMouseMode() *

function SDL_CreateCursor(const data: PUInt8; const mask: PUInt8; w: SInt32; h: SInt32; hot_x: SInt32; hot_y: SInt32): PSDL_Cursor; cdecl; external SDL_LibName;

** * Create a cursor, using the specified bitmap data and * mask (in MSB format). * * The cursor width must be a multiple of 8 bits. * * The cursor is created in black and white according to the following: * <table> * <tr><td> data </td><td> mask </td><td> resulting pixel on screen </td></tr> * <tr><td> 0 </td><td> 1 </td><td> White </td></tr> * <tr><td> 1 </td><td> 1 </td><td> Black </td></tr> * <tr><td> 0 </td><td> 0 </td><td> Transparent </td></tr> * <tr><td> 1 </td><td> 0 </td><td> Inverted color if possible, black * if not. </td></tr> * </table> * * SDL_FreeCursor() *

function SDL_CreateColorCursor(surface: PSDL_Surface; hot_x: SInt32; hot_y: SInt32): PSDL_Cursor; cdecl; external SDL_LibName;

** * Create a color cursor. * * SDL_FreeCursor() *

function SDL_CreateSystemCursor(id: TSDL_SystemCursor): PSDL_Cursor; cdecl; external SDL_LibName;

** * Create a system cursor. * * SDL_FreeCursor() *

procedure SDL_SetCursor(cursor: PSDL_Cursor); cdecl; external SDL_LibName;

** * Set the active cursor. *

function SDL_GetCursor(): PSDL_Cursor; cdecl; external SDL_LibName;

** * Return the active cursor. *

procedure SDL_FreeCursor(cursor: PSDL_Cursor); cdecl; external SDL_LibName;

** * Frees a cursor created with SDL_CreateCursor(). * * SDL_CreateCursor() *

function SDL_ShowCursor(toggle: SInt32): SInt32; cdecl; external SDL_LibName;

** * Toggle whether or not the cursor is shown. * * toggle 1 to show the cursor, 0 to hide it, -1 to query the current * state. * * 1 if the cursor is shown, or 0 if the cursor is hidden. *

function SDL_NumJoysticks(): SInt32; cdecl; external SDL_LibName;

** * Count the number of joysticks attached to the system right now *

function SDL_JoystickNameForIndex(device_index: SInt32): PChar; cdecl; external SDL_LibName;

** * Get the implementation dependent name of a joystick. * This can be called before any joysticks are opened. * If no name can be found, this function returns NULL. *

function SDL_JoystickOpen(device_index: SInt32): PSDL_Joystick; cdecl; external SDL_LibName;

** * Open a joystick for use. * The index passed as an argument refers tothe N'th joystick on the system. * This index is the value which will identify this joystick in future joystick * events. * * A joystick identifier, or NULL if an error occurred. *

function SDL_JoystickName(joystick: PSDL_Joystick): PChar; cdecl; external SDL_LibName;

** * Return the name for this currently opened joystick. * If no name can be found, this function returns NULL. *

function SDL_JoystickGetDeviceGUID(device_index: SInt32): TSDL_JoystickGUID; cdecl; external SDL_LibName;

** * Return the GUID for the joystick at this index *

function SDL_JoystickGetGUID(joystick: PSDL_Joystick): TSDL_JoystickGUID; cdecl; external SDL_LibName;

** * Return the GUID for this opened joystick *

procedure SDL_JoystickGetGUIDString(guid: TSDL_JoystickGUId; pszGUID: PChar; cbGUID: SInt32); cdecl; external SDL_LibName;

** * Return a string representation for this guid. pszGUID must point to at least 33 bytes * (32 for the string plus a NULL terminator). *

function SDL_JoystickGetGUIDFromString(const pchGUID: PChar): TSDL_JoystickGUID; cdecl; external SDL_LibName;

** * convert a string into a joystick formatted guid *

function SDL_JoystickGetAttached(joystick: PSDL_Joystick): TSDL_Bool; cdecl; external SDL_LibName;

** * Returns SDL_TRUE if the joystick has been opened and currently connected, or SDL_FALSE if it has not. *

function SDL_JoystickInstanceID(joystick: PSDL_Joystick): TSDL_JoystickID; cdecl; external SDL_LibName;

** * Get the instance ID of an opened joystick or -1 if the joystick is invalid. *

function SDL_JoystickNumAxes(joystick: PSDL_Joystick): SInt32; cdecl; external SDL_LibName;

** * Get the number of general axis controls on a joystick. *

function SDL_JoystickNumBalls(joystick: PSDL_Joystick): SInt32; cdecl; external SDL_LibName;

** * Get the number of trackballs on a joystick. * * Joystick trackballs have only relative motion events associated * with them and their state cannot be polled. *

function SDL_JoystickNumHats(joystick: PSDL_Joystick): SInt32; cdecl; external SDL_LibName;

** * Get the number of POV hats on a joystick. *

function SDL_JoystickNumButtons(joystick: PSDL_Joystick): SInt32; cdecl; external SDL_LibName;

** * Get the number of buttons on a joystick. *

procedure SDL_JoystickUpdate(); cdecl; external SDL_LibName;

** * Update the current state of the open joysticks. * * This is called automatically by the event loop if any joystick * events are enabled. *

function SDL_JoystickEventState(state: SInt32): SInt32; cdecl; external SDL_LibName;

** * Enable/disable joystick event polling. * * If joystick events are disabled, you must call SDL_JoystickUpdate() * yourself and check the state of the joystick when you want joystick * information. * * The state can be one of ::SDL_QUERY, ::SDL_ENABLE or ::SDL_IGNORE. *

function SDL_JoystickGetAxis(joystick: PSDL_Joystick; axis: SInt32): SInt16; cdecl; external SDL_LibName;

** * Get the current state of an axis control on a joystick. * * The state is a value ranging from -32768 to 32767. * * The axis indices start at index 0. *

function SDL_JoystickGetHat(joystick: PSDL_Joystick; hat: SInt32): UInt8; cdecl; external SDL_LibName;

** * Get the current state of a POV hat on a joystick. * * The hat indices start at index 0. * * The return value is one of the following positions: * - SDL_HAT_CENTERED * - SDL_HAT_UP * - SDL_HAT_RIGHT * - SDL_HAT_DOWN * - SDL_HAT_LEFT * - SDL_HAT_RIGHTUP * - SDL_HAT_RIGHTDOWN * - SDL_HAT_LEFTUP * - SDL_HAT_LEFTDOWN *

function SDL_JoystickGetBall(joystick: PSDL_Joystick; ball: SInt32; dx: PInt; dy: PInt): SInt32; cdecl; external SDL_LibName;

** * Get the ball axis change since the last poll. * * 0, or -1 if you passed it invalid parameters. * * The ball indices start at index 0. *

function SDL_JoystickGetButton(joystick: PSDL_Joystick; button: SInt32): UInt8; cdecl; external SDL_LibName;

** * Get the current state of a button on a joystick. * * The button indices start at index 0. *

procedure SDL_JoystickClose(joystick: PSDL_Joystick); cdecl; external SDL_LibName;

** * Close a joystick previously opened with SDL_JoystickOpen(). *

function SDL_GameControllerAddMapping( mappingString: PChar ): Integer; cdecl; external SDL_LibName;

** * Add or update an existing mapping configuration * * 1 if mapping is added, 0 if updated, -1 on error *

function SDL_GameControllerMappingForGUID( guid: TSDL_JoystickGUID ): PChar; cdecl; external SDL_LibName;

** * Get a mapping string for a GUID * * the mapping string. Must be freed with SDL_free. Returns NULL if no mapping is available *

function SDL_GameControllerMapping( gamecontroller: PSDL_GameController ): PChar; cdecl; external SDL_LibName;

** * Get a mapping string for an open GameController * * the mapping string. Must be freed with SDL_free. Returns NULL if no mapping is available *

function SDL_IsGameController(joystick_index: Integer): TSDL_Bool; cdecl; external SDL_LibName;

** * Is the joystick on this index supported by the game controller interface? *

function SDL_GameControllerNameForIndex(joystick_index: Integer): PChar; cdecl; external SDL_LibName;

** * Get the implementation dependent name of a game controller. * This can be called before any controllers are opened. * If no name can be found, this function returns NULL. *

function SDL_GameControllerOpen(joystick_index: Integer): PSDL_GameController; cdecl; external SDL_LibName;

** * Open a game controller for use. * The index passed as an argument refers to the N'th game controller on the system. * This index is the value which will identify this controller in future controller * events. * * A controller identifier, or NULL if an error occurred. *

function SDL_GameControllerName(gamecontroller: PSDL_GameController): PChar; cdecl; external SDL_LibName;

** * Return the name for this currently opened controller *

function SDL_GameControllerGetAttached(gamecontroller: PSDL_GameController): TSDL_Bool; cdecl; external SDL_LibName;

** * Returns SDL_TRUE if the controller has been opened and currently connected, * or SDL_FALSE if it has not. *

function SDL_GameControllerGetJoystick(gamecontroller: PSDL_GameController): PSDL_Joystick; cdecl; external SDL_LibName;

** * Get the underlying joystick object used by a controller *

function SDL_GameControllerEventState(state: Integer): Integer; cdecl; external SDL_LibName;

** * Enable/disable controller event polling. * * If controller events are disabled, you must call SDL_GameControllerUpdate() * yourself and check the state of the controller when you want controller * information. * * The state can be one of ::SDL_QUERY, ::SDL_ENABLE or ::SDL_IGNORE. *

procedure SDL_GameControllerUpdate(); cdecl; external SDL_LibName;

** * Update the current state of the open game controllers. * * This is called automatically by the event loop if any game controller * events are enabled. *

function SDL_GameControllerGetAxisFromString(pchString: PChar): TSDL_GameControllerAxis; cdecl; external SDL_LibName;

** * turn this string into a axis mapping *

function SDL_GameControllerGetStringForAxis(axis: TSDL_GameControllerAxis): PChar; cdecl; external SDL_LibName;

** * turn this axis enum into a string mapping *

function SDL_GameControllerGetBindForAxis(gamecontroller: PSDL_GameController; axis: TSDL_GameControllerAxis): TSDL_GameControllerButtonBind; cdecl; external SDL_LibName;

** * Get the SDL joystick layer binding for this controller button mapping *

function SDL_GameControllerGetAxis(gamecontroller: PSDL_GameController; axis: TSDL_GameControllerAxis): SInt16; cdecl; external SDL_LibName;

** * Get the current state of an axis control on a game controller. * * The state is a value ranging from -32768 to 32767. * * The axis indices start at index 0. *

function SDL_GameControllerGetButtonFromString(pchString: PChar): TSDL_GameControllerButton; cdecl; external SDL_LibName;

** * turn this string into a button mapping *

function SDL_GameControllerGetStringForButton(button: TSDL_GameControllerButton): PChar; cdecl; external SDL_LibName;

** * turn this button enum into a string mapping *

function SDL_GameControllerGetBindForButton(gamecontroller: PSDL_GameController; button: TSDL_GameControllerButton): TSDL_GameControllerButtonBind; cdecl; external SDL_LibName;

** * Get the SDL joystick layer binding for this controller button mapping *

function SDL_GameControllerGetButton(gamecontroller: PSDL_GameController; button: TSDL_GameControllerButton): UInt8; cdecl; external SDL_LibName;

** * Get the current state of a button on a game controller. * * The button indices start at index 0. *

procedure SDL_GameControllerClose(gamecontroller: PSDL_GameController); cdecl; external SDL_LibName;

** * Close a controller previously opened with SDL_GameControllerOpen(). *

function SDL_NumHaptics(): Integer; cdecl; external SDL_LibName;

** * Count the number of haptic devices attached to the system. * * Number of haptic devices detected on the system. *

function SDL_HapticName(device_index: Integer): PChar; cdecl; external SDL_LibName;

** * Get the implementation dependent name of a Haptic device. * * This can be called before any joysticks are opened. * If no name can be found, this function returns NULL. * * device_index Index of the device to get its name. * Name of the device or NULL on error. * * SDL_NumHaptics *

function SDL_HapticOpen(device_index: Integer): PSDL_Haptic; cdecl; external SDL_LibName;

** * Opens a Haptic device for usage. * * The index passed as an argument refers to the N'th Haptic device on this * system. * * When opening a haptic device, its gain will be set to maximum and * autocenter will be disabled. To modify these values use * SDL_HapticSetGain() and SDL_HapticSetAutocenter(). * * device_index Index of the device to open. * Device identifier or NULL on error. * * SDL_HapticIndex * SDL_HapticOpenFromMouse * SDL_HapticOpenFromJoystick * SDL_HapticClose * SDL_HapticSetGain * SDL_HapticSetAutocenter * SDL_HapticPause * SDL_HapticStopAll *

function SDL_HapticOpened(device_index: Integer): Integer; cdecl; external SDL_LibName;

** * Checks if the haptic device at index has been opened. * * device_index Index to check to see if it has been opened. * 1 if it has been opened or 0 if it hasn't. * * SDL_HapticOpen * SDL_HapticIndex *

function SDL_HapticIndex(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Gets the index of a haptic device. * * haptic Haptic device to get the index of. * The index of the haptic device or -1 on error. * * SDL_HapticOpen * SDL_HapticOpened *

function SDL_MouseIsHaptic() : Integer; cdecl; external SDL_LibName;

** * Gets whether or not the current mouse has haptic capabilities. * * SDL_TRUE if the mouse is haptic, SDL_FALSE if it isn't. * * SDL_HapticOpenFromMouse *

function SDL_HapticOpenFromMouse() : PSDL_Haptic; cdecl; external SDL_LibName;

** * Tries to open a haptic device from the current mouse. * * The haptic device identifier or NULL on error. * * SDL_MouseIsHaptic * SDL_HapticOpen *

function SDL_JoystickIsHaptic(joystick: PSDL_Joystick): Integer; cdecl; external SDL_LibName;

** * Checks to see if a joystick has haptic features. * * joystick Joystick to test for haptic capabilities. * 1 if the joystick is haptic, 0 if it isn't * or -1 if an error ocurred. * * SDL_HapticOpenFromJoystick *

function SDL_HapticOpenFromJoystick(joystick: PSDL_Joystick): PSDL_Haptic; cdecl; external SDL_LibName;

** * Opens a Haptic device for usage from a Joystick device. * * You must still close the haptic device seperately. It will not be closed * with the joystick. * * When opening from a joystick you should first close the haptic device before * closing the joystick device. If not, on some implementations the haptic * device will also get unallocated and you'll be unable to use force feedback * on that device. * * joystick Joystick to create a haptic device from. * A valid haptic device identifier on success or NULL on error. * * SDL_HapticOpen * SDL_HapticClose *

procedure SDL_HapticClose(haptic: PSDL_Haptic); cdecl; external SDL_LibName;

** * Closes a Haptic device previously opened with SDL_HapticOpen(). * * haptic Haptic device to close. *

function SDL_HapticNumEffects(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Returns the number of effects a haptic device can store. * * On some platforms this isn't fully supported, and therefore is an * approximation. Always check to see if your created effect was actually * created and do not rely solely on SDL_HapticNumEffects(). * * haptic The haptic device to query effect max. * The number of effects the haptic device can store or * -1 on error. * * SDL_HapticNumEffectsPlaying * SDL_HapticQuery *

function SDL_HapticNumEffectsPlaying(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Returns the number of effects a haptic device can play at the same * time. * * This is not supported on all platforms, but will always return a value. * Added here for the sake of completeness. * * haptic The haptic device to query maximum playing effects. * The number of effects the haptic device can play at the same time * or -1 on error. * * SDL_HapticNumEffects * SDL_HapticQuery *

function SDL_HapticQuery(haptic: PSDL_Haptic): UInt32; cdecl; external SDL_LibName;

** * Gets the haptic devices supported features in bitwise matter. * * Example: * * if (SDL_HapticQueryEffects(haptic) & SDL_HAPTIC_CONSTANT) * printf("We have constant haptic effect!"); * * * * haptic The haptic device to query. * Haptic features in bitwise manner (OR'd). * * SDL_HapticNumEffects * SDL_HapticEffectSupported *

function SDL_HapticNumAxes(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Gets the number of haptic axes the device has. * * SDL_HapticDirection *

function SDL_HapticEffectSupported(haptic: PSDL_Haptic; effect: PSDL_HapticEffect): Integer; cdecl; external SDL_LibName;

** * Checks to see if effect is supported by haptic. * * haptic Haptic device to check on. * effect Effect to check to see if it is supported. * SDL_TRUE if effect is supported, SDL_FALSE if it isn't or -1 on error. * * SDL_HapticQuery * SDL_HapticNewEffect *

function SDL_HapticNewEffect(haptic: PSDL_Haptic; effect: PSDL_HapticEffect): Integer; cdecl; external SDL_LibName;

** * Creates a new haptic effect on the device. * * haptic Haptic device to create the effect on. * effect Properties of the effect to create. * The id of the effect on success or -1 on error. * * SDL_HapticUpdateEffect * SDL_HapticRunEffect * SDL_HapticDestroyEffect *

function SDL_HapticUpdateEffect(haptic: PSDL_Haptic; effect: Integer; data: PSDL_HapticEffect): Integer; cdecl; external SDL_LibName;

** * Updates the properties of an effect. * * Can be used dynamically, although behaviour when dynamically changing * direction may be strange. Specifically the effect may reupload itself * and start playing from the start. You cannot change the type either when * running SDL_HapticUpdateEffect(). * * haptic Haptic device that has the effect. * effect Effect to update. * data New effect properties to use. * The id of the effect on success or -1 on error. * * SDL_HapticNewEffect * SDL_HapticRunEffect * SDL_HapticDestroyEffect *

function SDL_HapticRunEffect(haptic: PSDL_Haptic; effect: Integer; iterations: UInt32): Integer; cdecl; external SDL_LibName;

** * Runs the haptic effect on its associated haptic device. * * If iterations are ::SDL_HAPTIC_INFINITY, it'll run the effect over and over * repeating the envelope (attack and fade) every time. If you only want the * effect to last forever, set ::SDL_HAPTIC_INFINITY in the effect's length * parameter. * * haptic Haptic device to run the effect on. * effect Identifier of the haptic effect to run. * iterations Number of iterations to run the effect. Use * SDL_HAPTIC_INFINITY for infinity. * 0 on success or -1 on error. * * SDL_HapticStopEffect * SDL_HapticDestroyEffect * SDL_HapticGetEffectStatus *

function SDL_HapticStopEffect(haptic: PSDL_Haptic; effect: Integer): Integer; cdecl; external SDL_LibName;

** * Stops the haptic effect on its associated haptic device. * * haptic Haptic device to stop the effect on. * effect Identifier of the effect to stop. * 0 on success or -1 on error. * * SDL_HapticRunEffect * SDL_HapticDestroyEffect *

procedure SDL_HapticDestroyEffect(haptic: PSDL_Haptic; effect: Integer); cdecl; external SDL_LibName;

** * Destroys a haptic effect on the device. * * This will stop the effect if it's running. Effects are automatically * destroyed when the device is closed. * * haptic Device to destroy the effect on. * effect Identifier of the effect to destroy. * * SDL_HapticNewEffect *

function SDL_HapticGetEffectStatus(haptic: PSDL_Haptic; effect: Integer): Integer; cdecl; external SDL_LibName;

** * Gets the status of the current effect on the haptic device. * * Device must support the ::SDL_HAPTIC_STATUS feature. * * haptic Haptic device to query the effect status on. * effect Identifier of the effect to query its status. * 0 if it isn't playing, 1 if it is playing or -1 on error. * * SDL_HapticRunEffect * SDL_HapticStopEffect *

function SDL_HapticSetGain(haptic: PSDL_Haptic; gain: Integer): Integer; cdecl; external SDL_LibName;

** * Sets the global gain of the device. * * Device must support the SDL_HAPTIC_GAIN feature. * * The user may specify the maximum gain by setting the environment variable * SDL_HAPTIC_GAIN_MAX which should be between 0 and 100. All calls to * SDL_HapticSetGain() will scale linearly using SDL_HAPTIC_GAIN_MAX as the * maximum. * * haptic Haptic device to set the gain on. * gain Value to set the gain to, should be between 0 and 100. * 0 on success or -1 on error. * * SDL_HapticQuery *

function SDL_HapticSetAutocenter(haptic: PSDL_Haptic; autocenter: Integer): Integer; cdecl; external SDL_LibName;

** * Sets the global autocenter of the device. * * Autocenter should be between 0 and 100. Setting it to 0 will disable * autocentering. * * Device must support the ::SDL_HAPTIC_AUTOCENTER feature. * * haptic Haptic device to set autocentering on. * autocenter Value to set autocenter to, 0 disables autocentering. * 0 on success or -1 on error. * * SDL_HapticQuery *

function SDL_HapticPause(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Pauses a haptic device. * * Device must support the SDL_HAPTIC_PAUSE feature. Call * SDL_HapticUnpause() to resume playback. * * Do not modify the effects nor add new ones while the device is paused. * That can cause all sorts of weird errors. * * haptic Haptic device to pause. * 0 on success or -1 on error. * * SDL_HapticUnpause *

function SDL_HapticUnpause(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Unpauses a haptic device. * * Call to unpause after SDL_HapticPause(). * * haptic Haptic device to pause. * 0 on success or -1 on error. * * SDL_HapticPause *

function SDL_HapticStopAll(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Stops all the currently playing effects on a haptic device. * * haptic Haptic device to stop. * 0 on success or -1 on error. *

function SDL_HapticRumbleSupported(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Checks to see if rumble is supported on a haptic device.. * * haptic Haptic device to check to see if it supports rumble. * SDL_TRUE if effect is supported, SDL_FALSE if it isn't or -1 on error. * * SDL_HapticRumbleInit * SDL_HapticRumblePlay * SDL_HapticRumbleStop *

function SDL_HapticRumbleInit(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Initializes the haptic device for simple rumble playback. * * haptic Haptic device to initialize for simple rumble playback. * 0 on success or -1 on error. * * SDL_HapticOpen * SDL_HapticRumbleSupported * SDL_HapticRumblePlay * SDL_HapticRumbleStop *

function SDL_HapticRumblePlay(haptic: PSDL_Haptic; strength: Float; length: UInt32): Integer; cdecl; external SDL_LibName;

** * Runs simple rumble on a haptic device * * haptic Haptic device to play rumble effect on. * strength Strength of the rumble to play as a 0-1 float value. * length Length of the rumble to play in milliseconds. * 0 on success or -1 on error. * * SDL_HapticRumbleSupported * SDL_HapticRumbleInit * SDL_HapticRumbleStop *

function SDL_HapticRumbleStop(haptic: PSDL_Haptic): Integer; cdecl; external SDL_LibName;

** * Stops the simple rumble on a haptic device. * * haptic Haptic to stop the rumble on. * 0 on success or -1 on error. * * SDL_HapticRumbleSupported * SDL_HapticRumbleInit * SDL_HapticRumblePlay *

function SDL_GetNumTouchDevices(): SInt32; cdecl; external SDL_LibName;

** * Get the number of registered touch devices. *

function SDL_GetTouchDevice(index: SInt32): TSDL_TouchID; cdecl; external SDL_LibName;

** * Get the touch ID with the given index, or 0 if the index is invalid. *

function SDL_GetNumTouchFingers(touchID: TSDL_TouchID): SInt32; cdecl; external SDL_LibName;

** * Get the number of active fingers for a given touch device. *

function SDL_GetTouchFinger(touchID: TSDL_TouchID; index: SInt32): PSDL_Finger; cdecl; external SDL_LibName;

** * Get the finger object of the given touch, with the given index. *

function SDL_RecordGesture(touchId: TSDL_TouchID): SInt32; cdecl; external SDL_LibName;

** * Begin Recording a gesture on the specified touch, or all touches (-1) * * *

function SDL_SaveAllDollarTemplates(src: PSDL_RWops): SInt32; cdecl; external SDL_LibName;

** * Save all currently loaded Dollar Gesture templates * * *

function SDL_SaveDollarTemplate(gestureId: TSDL_GestureID; src: PSDL_RWops): SInt32; cdecl; external SDL_LibName;

** * Save a currently loaded Dollar Gesture template * * *

function SDL_LoadDollarTemplates(touchId: TSDL_TouchID; src: PSDL_RWops): SInt32; cdecl; external SDL_LibName;

** * Load Dollar Gesture templates from a file * * *

procedure SDL_PumpEvents(); cdecl; external SDL_LibName;

** * Pumps the event loop, gathering events from the input devices. * * This function updates the event queue and internal input device state. * * This should only be run in the thread that sets the video mode. *

function SDL_PeepEvents(events: PSDL_Event; numevents: SInt32; action: TSDL_EventAction; minType: UInt32; maxType: UInt32): SInt32; cdecl; external SDL_LibName;

** * Checks the event queue for messages and optionally returns them. * * If action is SDL_ADDEVENT, up to numevents events will be added to * the back of the event queue. * * If action is SDL_PEEKEVENT, up to numevents events at the front * of the event queue, within the specified minimum and maximum type, * will be returned and will not be removed from the queue. * * If action is SDL_GETEVENT, up to numevents events at the front * of the event queue, within the specified minimum and maximum type, * will be returned and will be removed from the queue. * * Result: The number of events actually stored, or -1 if there was an error. * * This function is thread-safe. *

function SDL_HasEvent(type_: UInt32): TSDL_Bool; cdecl; external SDL_LibName;

** * Checks to see if certain event types are in the event queue. *

function SDL_HasEvents(minType: UInt32; maxType: UInt32): TSDL_Bool; cdecl; external SDL_LibName;

This item has no description.

procedure SDL_FlushEvent(type_: UInt32); cdecl; external SDL_LibName;

** * This function clears events from the event queue *

procedure SDL_FlushEvents(minType: UInt32; maxType: UInt32); cdecl; external SDL_LibName;

This item has no description.

function SDL_PollEvent(event: PSDL_Event): SInt32; cdecl; external SDL_LibName;

** * Polls for currently pending events. * * 1 if there are any pending events, or 0 if there are none available. * * event - If not nil, the next event is removed from the queue and * stored in that area. *

function SDL_WaitEvent(event: PSDL_Event): SInt32; cdecl; external SDL_LibName;

** * Waits indefinitely for the next available event. * * 1, or 0 if there was an error while waiting for events. * * event - If not nil, the next event is removed from the queue and * stored in that area. *

function SDL_WaitEventTimeout(event: PSDL_Event; timeout: SInt32): SInt32; cdecl; external SDL_LibName;

** * Waits until the specified timeout (in milliseconds) for the next * available event. * * 1, or 0 if there was an error while waiting for events. * * event - If not nil, the next event is removed from the queue and * stored in that area. *

function SDL_PushEvent(event: PSDL_Event): SInt32; cdecl; external SDL_LibName;

** * Add an event to the event queue. * * 1 on success, 0 if the event was filtered, or -1 if the event queue * was full or there was some other error. *

procedure SDL_SetEventFilter(filter: TSDL_EventFilter; userdata: Pointer); cdecl; external SDL_LibName;

** * Sets up a filter to process all events before they change internal state and * are posted to the internal event queue. * * If the filter returns 1, then the event will be added to the internal queue. * If it returns 0, then the event will be dropped from the queue, but the * internal state will still be updated. This allows selective filtering of * dynamically arriving events. * * Be very careful of what you do in the event filter function, as * it may run in a different thread! * * There is one caveat when dealing with the SDL_QUITEVENT event type. The * event filter is only called when the window manager desires to close the * application window. If the event filter returns 1, then the window will * be closed, otherwise the window will remain open if possible. * * If the quit event is generated by an interrupt signal, it will bypass the * internal queue and be delivered to the application at the next event poll. *

function SDL_GetEventFilter(filter: PSDL_EventFilter; userdata: Pointer): TSDL_Bool; cdecl; external SDL_LibName;

** * Return the current event filter - can be used to "chain" filters. * If there is no event filter set, this function returns SDL_FALSE. *

procedure SDL_AddEventWatch(filter: TSDL_EventFilter; userdata: Pointer); cdecl; external SDL_LibName;

** * Add a function which is called when an event is added to the queue. *

procedure SDL_DelEventWatch(filter: TSDL_EventFilter; userdata: Pointer); cdecl; external SDL_LibName;

** * Remove an event watch function added with SDL_AddEventWatch() *

procedure SDL_FilterEvents(filter: TSDL_EventFilter; userdata: Pointer); cdecl; external SDL_LibName;

** * Run the filter function on the current event queue, removing any * events for which the filter returns 0. *

function SDL_EventState(type_: UInt32; state: SInt32): UInt8; cdecl; external SDL_LibName;

** * This function allows you to set the state of processing certain events. * - If state is set to SDL_IGNORE, that event will be automatically * dropped from the event queue and will not event be filtered. * - If state is set to SDL_ENABLE, that event will be processed * normally. * - If state is set to SDL_QUERY, SDL_EventState() will return the * current processing state of the specified event. *

function SDL_GetEventState(type_: UInt32): UInt8;

This item has no description.

function SDL_RegisterEvents(numevents: SInt32): UInt32; cdecl; external SDL_LibName;

** * This function allocates a set of user-defined events, and returns * the beginning event number for that set of events. * * If there aren't enough user-defined events left, this function * returns (Uint32)-1 *

function SDL_Init(flags: UInt32): SInt32; cdecl; external SDL_LibName;

** * This function initializes the subsystems specified by flags * Unless the SDL_INIT_NOPARACHUTE flag is set, it will install cleanup * signal handlers for some commonly ignored fatal signals (like SIGSEGV). *

function SDL_InitSubSystem(flags: UInt32): SInt32; cdecl; external SDL_LibName;

** * This function initializes specific SDL subsystems *

procedure SDL_QuitSubSystem(flags: UInt32); cdecl; external SDL_LibName;

** * This function cleans up specific SDL subsystems *

function SDL_WasInit(flags: UInt32): UInt32; cdecl; external SDL_LibName;

** * This function returns a mask of the specified subsystems which have * previously been initialized. * * If flags is 0, it returns a mask of all initialized subsystems. *

procedure SDL_Quit(); cdecl; external SDL_LibName;

** * This function cleans up all initialized subsystems. You should * call it upon all exit conditions. *

function SDL_LoadObject(sofile: PChar): Pointer; cdecl; external SDL_LibName;

** * This function dynamically loads a shared object and returns a pointer * to the object handle (or NULL if there was an error). * The 'sofile' parameter is a system dependent name of the object file. *

function SDL_LoadFunction(handle: Pointer; name: PChar): Pointer; cdecl; external SDL_LibName;

** * Given an object handle, this function looks up the address of the * named function in the shared object and returns it. This address * is no longer valid after calling SDL_UnloadObject(). *

procedure SDL_UnloadObject(handle: Pointer); cdecl; external SDL_LibName;

** * Unload a shared object from memory. *

function SDL_GetPlatform(): PChar; cdecl; external SDL_LibName;

** * Gets the name of the platform. *

function SDL_SetHintWithPriority( const name: PChar; const value: PChar; priority: SDL_HintPriority) : boolean; cdecl; external SDL_LibName;

/** * \brief Set a hint with a specific priority * * The priority controls the behavior when setting a hint that already * has a value. Hints will replace existing hints of their priority and * lower. Environment variables are considered to have override priority. * * \return SDL_TRUE if the hint was set, SDL_FALSE otherwise */

function SDL_SetHint( const name: PChar; const value: PChar) : boolean; cdecl; external SDL_LibName;

/** * \brief Set a hint with normal priority * * \return SDL_TRUE if the hint was set, SDL_FALSE otherwise */

function SDL_GetHint( const name: PChar): PChar; cdecl; external SDL_LibName;

/** * \brief Get a hint * * \return The string value of a hint variable. */

procedure SDL_AddHintCallback(const name: PChar; callback: TSDL_HintCallback; userdata: Pointer); cdecl; external SDL_LibName;

This item has no description.

procedure SDL_DelHintCallback(const name: PChar; callback: TSDL_HintCallback; userdata: Pointer); cdecl; external SDL_LibName;

/** * \brief Remove a function watching a particular hint * * \param name The hint being watched * \param callback The function being called when the hint value changes * \param userdata A pointer being passed to the callback function */

procedure SDL_ClearHints(); cdecl; external SDL_LibName;

/** * \brief Clear all hints * * This function is called during SDL_Quit() to free stored hints. */

function SDL_ShowMessageBox(messageboxdata: PSDL_MessageBoxData; buttonid: PInt): Integer; cdecl; external SDL_LibName;

** * Create a modal message box. * * messageboxdata The SDL_MessageBoxData structure with title, text, etc. * buttonid The pointer to which user id of hit button should be copied. * * -1 on error, otherwise 0 and buttonid contains user id of button * hit or -1 if dialog was closed. * * This function should be called on the thread that created the parent * window, or on the main thread if the messagebox has no parent. It will * block execution of that thread until the user clicks a button or * closes the messagebox. *

function SDL_ShowSimpleMessageBox(flags: UInt32; title: PChar; _message: PChar; window: PSDL_Window): Integer; cdecl; external SDL_LibName;

** * Create a simple modal message box * * flags SDL_MessageBoxFlags * title UTF-8 title text * message UTF-8 message text * window The parent window, or NULL for no parent * * 0 on success, -1 on error * * SDL_ShowMessageBox *

function SDL_Swap32(D: Uint32): Uint32;

This item has no description.

function SDLStreamSetup( stream : TStream ) : PSDL_RWops;

This item has no description.

function LoadSDLBMPFromStream( Stream : TStream ) : PSDL_Surface;

This item has no description.

procedure SaveSDLBMPToStream( SDL_Surface : PSDL_Surface; stream : TStream );

This item has no description.

procedure SDLStreamCloseRWops( SDL_RWops : PSDL_RWops );

This item has no description.

Types

DWord = LongWord;

This item has no description.

Float = Single;

This item has no description.

PFloat = ˆFloat;

This item has no description.

PInt = ˆLongInt;

This item has no description.

PPSDL_Renderer = ˆPSDL_Renderer;

** * A structure representing rendering state *

PPSDL_Window = ˆPSDL_Window;

This item has no description.

PPUInt8 = ˆPUInt8;

This item has no description.

PSDLPantalla = ˆTSDLPantalla;

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// *** KTI *** //////////////////////////////////////////////// ///////////////////////////////////////////////////////////////////////////////////////////////////// SDLPantalla contiene la ventana SDL el Render donde se pinta y el zoom de los ejes X e Y

PSDL_AudioCVT = ˆTSDL_AudioCVT;

This item has no description.

PSDL_AudioSpec = ˆTSDL_AudioSpec;

** * The calculated values in this structure are calculated by SDL_OpenAudio(). *

PSDL_BlendMode = ˆTSDL_BlendMode;

** * The blend mode used in SDL_RenderCopy() and drawing operations. *

PSDL_BlitMap = ˆTSDL_BlitMap;

** * A collection of pixels used in software blitting. * * This structure should be treated as read-only, except for \c pixels, * which, if not NULL, contains the raw pixel data for the surface. *

PSDL_Color = ˆTSDL_Color;

This item has no description.

PSDL_Colour = ˆTSDL_Colour;

This item has no description.

PSDL_Cond = Pointer;

* The SDL condition variable structure, defined in SDL_cond.c *

PSDL_Cursor = Pointer;

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_mouse.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

PSDL_DisplayMode = ˆTSDL_DisplayMode;

** * The structure that defines a display mode * * SDL_GetNumDisplayModes() * SDL_GetDisplayMode() * SDL_GetDesktopDisplayMode() * SDL_GetCurrentDisplayMode() * SDL_GetClosestDisplayMode() * SDL_SetWindowDisplayMode() * SDL_GetWindowDisplayMode() *

PSDL_Event = ˆTSDL_Event;

** * General event structure *

PSDL_EventFilter = ˆTSDL_EventFilter;

This item has no description.

PSDL_Finger = ˆTSDL_Finger;

This item has no description.

PSDL_FingerID = ˆTSDL_FingerID;

This item has no description.

PSDL_GameController = ˆTSDL_GameController;

* The gamecontroller structure used to identify an SDL game controller *

PSDL_Haptic = ˆTSDL_Haptic;

** * SDL_Haptic * * The haptic structure used to identify an SDL haptic. * * SDL_HapticOpen * SDL_HapticOpenFromJoystick * SDL_HapticClose *

PSDL_HapticEffect = ˆTSDL_HapticEffect;

** * The generic template for any haptic effect. * * All values max at 32767 (0x7FFF). Signed values also can be negative. * Time values unless specified otherwise are in milliseconds. * * You can also pass SDL_HAPTIC_INFINITY to length instead of a 0-32767 * value. Neither delay, interval, attack_length nor fade_length support * SDL_HAPTIC_INFINITY. Fade will also not be used since effect never ends. * * Additionally, the SDL_HAPTIC_RAMP effect does not support a duration of * SDL_HAPTIC_INFINITY. * * Button triggers may not be supported on all devices, it is advised to not * use them if possible. Buttons start at index 1 instead of index 0 like * the joystick. * * If both attack_length and fade_level are 0, the envelope is not used, * otherwise both values are used. * * Common parts: * * // Replay - All effects have this * Uint32 length; // Duration of effect (ms). * Uint16 delay; // Delay before starting effect. * * // Trigger - All effects have this * Uint16 button; // Button that triggers effect. * Uint16 interval; // How soon before effect can be triggered again. * * // Envelope - All effects except condition effects have this * Uint16 attack_length; // Duration of the attack (ms). * Uint16 attack_level; // Level at the start of the attack. * Uint16 fade_length; // Duration of the fade out (ms). * Uint16 fade_level; // Level at the end of the fade. * * * * Here we have an example of a constant effect evolution in time: * Strength ˆ | | effect level –> _________________ | / \ | / \ | / \ | / \ | attack_level –> | \ | | | <— fade_level | +————————————————–> Time [–] [—] attack_length fade_length

[——————][———————–] delay length

* * Note either the attack_level or the fade_level may be above the actual * effect level. * * SDL_HapticConstant * SDL_HapticPeriodic * SDL_HapticCondition * SDL_HapticRamp * SDL_HapticCustom *

PSDL_Joystick = Pointer;

* The joystick structure used to identify an SDL joystick *

PSDL_KeyCode = ˆTSDL_KeyCode;

** * The SDL virtual key representation. * * Values of this type are used to represent keyboard keys using the current * layout of the keyboard. These values include Unicode values representing * the unmodified character that would be generated by pressing the key, or * an SDLK_* constant for those keys that do not generate characters. *

PSDL_KeyMod = ˆTSDL_KeyMod;

This item has no description.

PSDL_Keysym = ˆTSDL_Keysym;

** * The SDL keysym structure, used in key events. *

PSDL_MessageBoxButtonData = ˆTSDL_MessageBoxButtonData;

** * Individual button data. *

PSDL_MessageBoxColor = ˆTSDL_MessageBoxColor;

** * RGB value used in a message box color scheme *

PSDL_MessageBoxColorScheme = ˆTSDL_MessageBoxColorScheme;

** * A set of colors to use for message box dialogs *

PSDL_MessageBoxColorType = ˆTSDL_MessageBoxColorType;

This item has no description.

PSDL_MessageBoxData = ˆTSDL_MessageBoxData;

** * MessageBox structure containing title, text, window, etc. *

PSDL_Mutex = ˆTSDL_Mutex;

PSDL_Mutex = Pointer; //todo!

PSDL_Palette = ˆTSDL_Palette;

This item has no description.

PSDL_PixelFormat = ˆTSDL_PixelFormat;

** * Everything in the pixel format structure is read-only. *

PSDL_Point = ˆTSDL_Point;

** * The structure that defines a point * * SDL_EnclosePoints *

PSDL_Rect = ˆTSDL_Rect;

** * A rectangle, with the origin at the upper left. * * SDL_RectEmpty * SDL_RectEquals * SDL_HasIntersection * SDL_IntersectRect * SDL_UnionRect * SDL_EnclosePoints *

PSDL_Renderer = Pointer;

This item has no description.

PSDL_RendererFlags = ˆTSDL_RendererFlags;

**< The renderer supports rendering to texture *

PSDL_RendererFlip = ˆTSDL_RendererFlip;

** * Flip constants for SDL_RenderCopyEx *

PSDL_RendererInfo = ˆTSDL_RendererInfo;

** * Information on the capabilities of a render driver or context. *

PSDL_RWops = ˆTSDL_RWops;

* Read-Only memory stream *

PSDL_ScanCode = ˆTSDL_ScanCode;

**< not a key, just marks the number of scancodes for array bounds *

PSDL_Sem = Pointer;

* The SDL semaphore structure, defined in SDL_sem.c *

PSDL_Surface = ˆTSDL_Surface;

This item has no description.

PSDL_SystemCursor = ˆTSDL_SystemCursor;

This item has no description.

PSDL_SysWMEvent = ˆTSDL_SysWMEvent;

** * A video driver dependent system event (event.syswm.*) * This event is disabled by default, you can enable it with SDL_EventState() * * If you want to use this event, you should include SDL_syswm.h. *

PSDL_SysWMinfo = ˆTSDL_SysWMinfo;

The Windows custom window manager information structure

PSDL_SysWMmsg = ˆTSDL_SysWMmsg;

The windows custom event structure

PSDL_Texture = Pointer;

** * An efficient driver-specific representation of pixel data *

PSDL_TextureAccess = ˆTSDL_TextureAccess;

** * The access pattern allowed for a texture. *

PSDL_TextureModulate = ˆTSDL_TextureModulate;

** * The texture channel modulation used in SDL_RenderCopy(). *

PSDL_Thread = ˆTSDL_Thread;

PSDL_Thread = Pointer;

PSDL_ThreadFunction = ˆTSDL_ThreadFunction;

* The function passed to SDL_CreateThread() It is passed a void* user context parameter and returns an int. *

PSDL_TouchID = ˆTSDL_TouchID;

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_touch.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

PSDL_Version = ˆTSDL_Version;

** * Information the version of SDL in use. * * Represents the library's version as three levels: major revision * (increments with massive changes, additions, and enhancements), * minor revision (increments with backwards-compatible changes to the * major revision), and patchlevel (increments with fixes to the minor * revision). * * SDL_VERSION * SDL_GetVersion *

PSDL_Window = ˆTSDL_Window;

This item has no description.

PSDL_WindowShapeMode = ˆTSDL_WindowShapeMode;

** A struct that tags the SDL_WindowShapeParams union with an enum describing the type of its contents. *

PSDL_WindowShaper = ˆTSDL_WindowShaper;

* Define the SDL window-shaper structure *

PSDL_WindowUserData = ˆTSDL_WindowUserData;

This item has no description.

PShortInt = ˆShortInt;

This item has no description.

PSInt16 = ˆSInt16;

This item has no description.

PSInt64 = ˆSInt64;

This item has no description.

PSInt8 = ˆSInt8;

This item has no description.

PUInt16 = ˆUInt16;

This item has no description.

PUInt32 = ˆUInt32;

This item has no description.

PUInt8 = ˆUInt8;

This item has no description.

PUInt8Array = ˆTUInt8Array;

This item has no description.

SDL_HintPriority = (...);

/** * \brief An enumeration of hint priorities */

Values
  • SDL_HINT_DEFAULT
  • SDL_HINT_NORMAL
  • SDL_HINT_OVERRIDE
SInt16 = smallint;

This item has no description.

SInt32 = LongInt;

This item has no description.

SInt64 = Int64;

This item has no description.

SInt8 = Shortint;

This item has no description.

size_t = UInt32;

This item has no description.

TClose = function(context: PSDL_RWops): SInt32; cdecl;

** * Close and free an allocated SDL_RWops structure. * * 0 if successful or -1 on write error when flushing data. *

TpfnSDL_CurrentBeginThread = function(SecurityAttributes: Pointer; StackSize: LongWord; ThreadFunc: TThreadFunc; Parameter: Pointer; CreationFlags: LongWord; var ThreadId: TThreadID): Integer;

This item has no description.

TpfnSDL_CurrentEndThread = procedure(ExitCode: Integer);

This item has no description.

TRead = function(context: PSDL_RWops; ptr: Pointer; size: size_t; maxnum: size_t): size_t; cdecl;

** * Read up to maxnum objects each of size size from the data * stream to the area pointed at by ptr. * * the number of objects read, or 0 at error or end of file. *

TSDL_AudioCallback = procedure(userdata: Pointer; stream: PUInt8; len: Integer);

** * This function is called when the audio device needs more data. * * userdata An application-specific parameter saved in * the SDL_AudioSpec structure * stream A pointer to the audio data buffer. * len The length of that buffer in bytes. * * Once the callback returns, the buffer will no longer be valid. * Stereo samples are stored in a LRLRLR ordering. *

TSDL_AudioDeviceID = UInt32;

** * SDL Audio Device IDs. * * A successful call to SDL_OpenAudio() is always device id 1, and legacy * SDL audio APIs assume you want this device ID. SDL_OpenAudioDevice() calls * always returns devices >= 2 on success. The legacy calls are good both * for backwards compatibility and when you don't care about multiple, * specific, or capture devices. *

TSDL_AudioFilter = procedure(cvt: PSDL_AudioCVT; format: TSDL_AudioFormat);

This item has no description.

TSDL_AudioFormat = UInt16;

** * Audio format flags. * * These are what the 16 bits in SDL_AudioFormat currently mean... * (Unspecified bits are always zero). * * ++———————–sample is signed if set || || ++———–sample is bigendian if set || || || || ++—sample is float if set || || || || || || +—sample bit size—+ || || || | | 15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00 * * There are macros in SDL 2.0 and later to query these bits. *

TSDL_AudioStatus = (...);

** * Audio state * * Get the current audio state. *

Values
  • SDL_AUDIO_STOPPED
  • SDL_AUDIO_PLAYING
  • SDL_AUDIO_PAUSED
TSDL_BlendMode = DWord;

This item has no description.

TSDL_Blit = function(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): SInt32;

** * The type of function used for surface blitting functions. *

TSDL_Bool = (...);

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDLtype_s.h / SDL_stdinc.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

Values
  • SDL_FALSE
  • SDL_TRUE
TSDL_Colour = TSDL_Color;

This item has no description.

TSDL_ErrorCode = (...);

#define SDL_OutOfMemory() SDL_Error(SDL_ENOMEM) #define SDL_Unsupported() SDL_Error(SDL_UNSUPPORTED) #define SDL_InvalidParamError(param) SDL_SetError("Parameter '%s' is invalid", (param))

Values
  • SDL_ENOMEM
  • SDL_EFREAD
  • SDL_EFWRITE
  • SDL_EFSEEK
  • SDL_UNSUPPORTED
  • SDL_LASTERROR
TSDL_EventAction = Word;

This item has no description.

TSDL_EventFilter = function( event: PSDL_Event ): Integer; cdecl;

This item has no description.

TSDL_EventType = Word;

This item has no description.

TSDL_FingerID = SInt64;

This item has no description.

TSDL_GameController = Pointer;

This item has no description.

TSDL_GameControllerAxis = Byte;

This item has no description.

TSDL_GameControllerBindType = (...);

todo

Values
  • SDL_CONTROLLER_BINDTYPE_NONE
  • SDL_CONTROLLER_BINDTYPE_BUTTON
  • SDL_CONTROLLER_BINDTYPE_AXIS
  • SDL_CONTROLLER_BINDTYPE_HAT
TSDL_GameControllerButton = Byte;

This item has no description.

TSDL_GestureID = SInt64;

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_gesture.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

TSDL_GLattr = DWord;

This item has no description.

TSDL_GLContext = Pointer;

** * An opaque handle to an OpenGL context. *

TSDL_GLcontextFlag = DWord;

This item has no description.

TSDL_GLprofile = DWord;

This item has no description.

TSDL_HintCallback = procedure(userdata: Pointer; const name: PChar; const oldValue: PChar; const newValue: PChar);

/** * \brief Add a function to watch a particular hint * * \param name The hint to watch * \param callback The function to call when the hint value changes * \param userdata A pointer to pass to the callback function */

TSDL_JoystickID = SInt32;

This item has no description.

TSDL_KeyCode = SInt32;

This item has no description.

TSDL_KeyMod = Word;

This item has no description.

TSDL_MessageBoxButtonFlags = Byte;

**< Marks the default button when escape is hit *

TSDL_MessageBoxColorType = (...);

This item has no description.

Values
  • SDL_MESSAGEBOX_COLOR_BACKGROUND
  • SDL_MESSAGEBOX_COLOR_TEXT
  • SDL_MESSAGEBOX_COLOR_BUTTON_BORDER
  • SDL_MESSAGEBOX_COLOR_BUTTON_BACKGROUND
  • SDL_MESSAGEBOX_COLOR_BUTTON_SELECTED
  • SDL_MESSAGEBOX_COLOR_MAX
TSDL_MessageBoxFlags = Byte;

**< informational dialog *

TSDL_PowerState = (...);

** * The basic state for the system's power supply. *

Values
  • SDL_POWERSTATE_UNKNOWN
  • SDL_POWERSTATE_ON_BATTERY: **< cannot determine power status *
  • SDL_POWERSTATE_NO_BATTERY: **< Not plugged in, running on the battery *
  • SDL_POWERSTATE_CHARGING: **< Plugged in, no battery available *
  • SDL_POWERSTATE_CHARGED: **< Plugged in, charging battery *
TSDL_RendererFlags = Word;

This item has no description.

TSDL_RendererFlip = (...);

This item has no description.

Values
  • SDL_FLIP_NONE
  • SDL_FLIP_HORIZONTAL: **< Do not flip *
  • SDL_FLIP_VERTICAL: **< flip horizontally *
TSDL_ScanCode = DWord;

This item has no description.

TSDL_SystemCursor = Word;

This item has no description.

TSDL_TextureAccess = (...);

This item has no description.

Values
  • SDL_TEXTUREACCESS_STATIC
  • SDL_TEXTUREACCESS_STREAMING: **< Changes rarely, not lockable *
  • SDL_TEXTUREACCESS_TARGET: **< Changes frequently, lockable *
TSDL_TextureModulate = (...);

This item has no description.

Values
  • SDL_TEXTUREMODULATE_NONE
  • SDL_TEXTUREMODULATE_COLOR: **< No modulation *
  • SDL_TEXTUREMODULATE_ALPHA: **< srcC = srcC * color *
TSDL_ThreadFunction = function(data: Pointer): Integer; cdecl;

This item has no description.

TSDL_ThreadID = LongWord;

* The SDL thread ID *

TSDL_ThreadPriority = (...);

* The SDL thread priority * * Note: On many systems you require special privileges to set high priority. *

Values
  • SDL_THREAD_PRIORITY_LOW
  • SDL_THREAD_PRIORITY_NORMAL
  • SDL_THREAD_PRIORITY_HIGH
TSDL_TimerCallback = function(interval: UInt32; param: Pointer): UInt32;

** * Function prototype for the timer callback function. * * The callback function is passed the current timer interval and returns * the next timer interval. If the returned value is the same as the one * passed in, the periodic alarm continues, otherwise a new alarm is * scheduled. If the callback returns 0, the periodic alarm is cancelled. *

TSDL_TimerID = SInt32;

** * Definition of the timer ID type. *

TSDL_TLSID = Cardinal;

This item has no description.

TSDL_TouchID = SInt64;

This item has no description.

TSDL_WindowEventID = DWord;

**< The window manager requests that the window be closed *

TSDL_WindowFlags = DWord;

**< window not created by SDL *

TSeek = function(context: PSDL_RWops; offset: SInt64; whence: SInt32): SInt64; cdecl;

** * Seek to offset relative to whence, one of stdio's whence values: * RW_SEEK_SET, RW_SEEK_CUR, RW_SEEK_END * * the final offset in the data stream, or -1 on error. *

TSize = function(context: PSDL_RWops): SInt64; cdecl;

** * Return the size of the file in this rwops, or -1 if unknown *

TThreadID = Cardinal;

** * SDL_thread.h * * We compile SDL into a DLL. This means, that it's the DLL which * creates a new thread for the calling process with the SDL_CreateThread() * API. There is a problem with this, that only the RTL of the SDL.DLL will * be initialized for those threads, and not the RTL of the calling * application! * * To solve this, we make a little hack here. * * We'll always use the caller's _beginthread() and _endthread() APIs to * start a new thread. This way, if it's the SDL.DLL which uses this API, * then the RTL of SDL.DLL will be used to create the new thread, and if it's * the application, then the RTL of the application will be used. * * So, in short: * Always use the _beginthread() and _endthread() of the calling runtime * library! *

TUInt8Array = array [0..MAXINT shr 1] of UInt8;

This item has no description.

TWindowShapeMode = (...);

** An enum denoting the specific type of contents present in an SDL_WindowShapeParams union. *

Values
  • ShapeModeDefault: ** The default mode, a binarized alpha cutoff of 1. *
  • ShapeModeBinarizeAlpha: ** A binarized alpha cutoff with a given integer value. *
  • ShapeModeReverseBinarizeAlpha: ** A binarized alpha cutoff with a given integer value, but with the opposite comparison. *
  • ShapeModeColorKey: ** A color key is applied. *
TWrite = function(context: PSDL_RWops; const ptr: Pointer; size: size_t; num: size_t): size_t; cdecl;

** * Write exactly num objects each of size size from the area * pointed at by ptr to data stream. * * the number of objects written, or 0 at error or end of file. *

UInt16 = word;

This item has no description.

UInt32 = Cardinal;

This item has no description.

UInt8 = Byte;

This item has no description.

Constants

SDL_LibName = 'sdl2.dll';

This item has no description.

SDL_MAJOR_VERSION = 2;

* Printable format: "%d.%d.%d", MAJOR, MINOR, PATCHLEVEL *

SDL_MINOR_VERSION = 0;

This item has no description.

SDL_PATCHLEVEL = 0;

This item has no description.

ERR_MAX_STRLEN = 128;

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_error.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

ERR_MAX_ARGS = 5;

This item has no description.

SDL_RWOPS_UNKNOWN = 0;

* RWops Types *

SDL_RWOPS_WINFILE = 1;

* Unknown stream type *

SDL_RWOPS_STDFILE = 2;

* Win32 file *

SDL_RWOPS_JNIFILE = 3;

* Stdio file *

SDL_RWOPS_MEMORY = 4;

* Android asset *

SDL_RWOPS_MEMORY_RO = 5;

* Memory stream *

RW_SEEK_SET = 0;

This item has no description.

RW_SEEK_CUR = 1;

**< Seek from the beginning of data *

RW_SEEK_END = 2;

**< Seek relative to current read point *

SDL_AUDIO_MASK_BITSIZE = ($FF);

** * Audio flags *

SDL_AUDIO_MASK_DATATYPE = (1 shl 8);

This item has no description.

SDL_AUDIO_MASK_ENDIAN = (1 shl 12);

This item has no description.

SDL_AUDIO_MASK_SIGNED = (1 shl 15);

This item has no description.

AUDIO_U8 = $0008;

** * Audio format flags * * Defaults to LSB byte order. *

AUDIO_S8 = $8008;

**< Unsigned 8-bit samples *

AUDIO_U16LSB = $0010;

**< Signed 8-bit samples *

AUDIO_S16LSB = $8010;

**< Unsigned 16-bit samples *

AUDIO_U16MSB = $1010;

**< Signed 16-bit samples *

AUDIO_S16MSB = $9010;

**< As above, but big-endian byte order *

AUDIO_U16 = AUDIO_U16LSB;

**< As above, but big-endian byte order *

AUDIO_S16 = AUDIO_S16LSB;

This item has no description.

AUDIO_S32LSB = $8020;

** * int32 support *

AUDIO_S32MSB = $9020;

**< 32-bit integer samples *

AUDIO_S32 = AUDIO_S32LSB;

**< As above, but big-endian byte order *

AUDIO_F32LSB = $8120;

** * float32 support *

AUDIO_F32MSB = $9120;

**< 32-bit floating point samples *

AUDIO_F32 = AUDIO_F32LSB;

**< As above, but big-endian byte order *

SDL_AUDIO_ALLOW_FREQUENCY_CHANGE = $00000001;

** * Allow change flags * * Which audio format changes are allowed when opening a device. *

SDL_AUDIO_ALLOW_FORMAT_CHANGE = $00000002;

This item has no description.

SDL_AUDIO_ALLOW_CHANNELS_CHANGE = $00000004;

This item has no description.

SDL_AUDIO_ALLOW_ANY_CHANGE = (SDL_AUDIO_ALLOW_FREQUENCY_CHANGE or SDL_AUDIO_ALLOW_FORMAT_CHANGE or SDL_AUDIO_ALLOW_CHANNELS_CHANGE);

This item has no description.

SDL_MIX_MAXVOLUME = 128;

This item has no description.

SDL_MUTEX_TIMEDOUT = 1;

** * Synchronization functions which can time out return this value * if they time out. *

SDL_ALPHA_OPAQUE = 255;

** * Transparency definitions * * These define alpha as the opacity of a surface. *

SDL_ALPHA_TRANSPARENT = 0;

This item has no description.

SDL_PIXELTYPE_UNKNOWN = 0;

** Pixel type. *

SDL_PIXELTYPE_INDEX1 = 1;

This item has no description.

SDL_PIXELTYPE_INDEX4 = 2;

This item has no description.

SDL_PIXELTYPE_INDEX8 = 3;

This item has no description.

SDL_PIXELTYPE_PACKED8 = 4;

This item has no description.

SDL_PIXELTYPE_PACKED16 = 5;

This item has no description.

SDL_PIXELTYPE_PACKED32 = 6;

This item has no description.

SDL_PIXELTYPE_ARRAYU8 = 7;

This item has no description.

SDL_PIXELTYPE_ARRAYU16 = 8;

This item has no description.

SDL_PIXELTYPE_ARRAYU32 = 9;

This item has no description.

SDL_PIXELTYPE_ARRAYF16 = 10;

This item has no description.

SDL_PIXELTYPE_ARRAYF32 = 11;

This item has no description.

SDL_BITMAPORDER_NONE = 0;

** Bitmap pixel order, high bit -> low bit. *

SDL_BITMAPORDER_4321 = 1;

This item has no description.

SDL_BITMAPORDER_1234 = 2;

This item has no description.

SDL_PACKEDORDER_NONE = 0;

** Packed component order, high bit -> low bit. *

SDL_PACKEDORDER_XRGB = 1;

This item has no description.

SDL_PACKEDORDER_RGBX = 2;

This item has no description.

SDL_PACKEDORDER_ARGB = 3;

This item has no description.

SDL_PACKEDORDER_RGBA = 4;

This item has no description.

SDL_PACKEDORDER_XBGR = 5;

This item has no description.

SDL_PACKEDORDER_BGRX = 6;

This item has no description.

SDL_PACKEDORDER_ABGR = 7;

This item has no description.

SDL_PACKEDORDER_BGRA = 8;

This item has no description.

SDL_ARRAYORDER_NONE = 0;

** Array component order, low byte -> high byte. *

SDL_ARRAYORDER_RGB = 1;

This item has no description.

SDL_ARRAYORDER_RGBA = 2;

This item has no description.

SDL_ARRAYORDER_ARGB = 3;

This item has no description.

SDL_ARRAYORDER_BGR = 4;

This item has no description.

SDL_ARRAYORDER_BGRA = 5;

This item has no description.

SDL_ARRAYORDER_ABGR = 6;

This item has no description.

SDL_PACKEDLAYOUT_NONE = 0;

** Packed component layout. *

SDL_PACKEDLAYOUT_332 = 1;

This item has no description.

SDL_PACKEDLAYOUT_4444 = 2;

This item has no description.

SDL_PACKEDLAYOUT_1555 = 3;

This item has no description.

SDL_PACKEDLAYOUT_5551 = 4;

This item has no description.

SDL_PACKEDLAYOUT_565 = 5;

This item has no description.

SDL_PACKEDLAYOUT_8888 = 6;

This item has no description.

SDL_PACKEDLAYOUT_2101010 = 7;

This item has no description.

SDL_PACKEDLAYOUT_1010102 = 8;

This item has no description.

SDL_PIXELFORMAT_UNKNOWN = 0;

#define SDL_BYTESPERPIXEL(X) \ (SDL_ISPIXELFORMAT_FOURCC(X) ? \ ((((X) == SDL_PIXELFORMAT_YUY2) || \ ((X) == SDL_PIXELFORMAT_UYVY) || \ ((X) == SDL_PIXELFORMAT_YVYU)) ? 2 : 1) : (((X) >> 0) & 0xFF))

#define SDL_ISPIXELFORMAT_INDEXED(format) \ (!SDL_ISPIXELFORMAT_FOURCC(format) && \ ((SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX1) || \ (SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX4) || \ (SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX8)))

#define SDL_ISPIXELFORMAT_ALPHA(format) \ (!SDL_ISPIXELFORMAT_FOURCC(format) && \ ((SDL_PIXELORDER(format) == SDL_PACKEDORDER_ARGB) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_RGBA) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_ABGR) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_BGRA)))

function SDL_IsPixelFormat_FOURCC(format: Variant);

{* Note: If you modify this list, update SDL_GetPixelFormatName() *

SDL_PIXELFORMAT_INDEX1LSB = (1 shl 28) or (SDL_PIXELTYPE_INDEX1 shl 24) or (SDL_BITMAPORDER_4321 shl 20) or (0 shl 16) or (1 shl 8) or (0 shl 0);

This item has no description.

SDL_PIXELFORMAT_INDEX1MSB = (1 shl 28) or (SDL_PIXELTYPE_INDEX1 shl 24) or (SDL_BITMAPORDER_1234 shl 20) or (0 shl 16) or (1 shl 8) or (0 shl 0);

This item has no description.

SDL_PIXELFORMAT_INDEX4LSB = (1 shl 28) or (SDL_PIXELTYPE_INDEX4 shl 24) or (SDL_BITMAPORDER_4321 shl 20) or (0 shl 16) or (4 shl 8) or (0 shl 0);

This item has no description.

SDL_PIXELFORMAT_INDEX4MSB = (1 shl 28) or (SDL_PIXELTYPE_INDEX4 shl 24) or (SDL_BITMAPORDER_1234 shl 20) or (0 shl 16) or (4 shl 8) or (0 shl 0);

This item has no description.

SDL_PIXELFORMAT_INDEX8 = (1 shl 28) or (SDL_PIXELTYPE_PACKED8 shl 24) or (0 shl 20) or (0 shl 16) or (8 shl 8) or (1 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGB332 = (1 shl 28) or (SDL_PIXELTYPE_PACKED8 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_332 shl 16) or (8 shl 8) or (1 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGB444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (12 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGB555 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (15 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_BGR555 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XBGR shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (15 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_ARGB4444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_ARGB shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGBA4444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_RGBA shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_ABGR4444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_ABGR shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_BGRA4444 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_BGRA shl 20) or (SDL_PACKEDLAYOUT_4444 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_ARGB1555 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_ARGB shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGBA5551 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_RGBA shl 20) or (SDL_PACKEDLAYOUT_5551 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_ABGR1555 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_ABGR shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_BGRA5551 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_BGRA shl 20) or (SDL_PACKEDLAYOUT_5551 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGB565 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_565 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_BGR565 = (1 shl 28) or (SDL_PIXELTYPE_PACKED16 shl 24) or (SDL_PACKEDORDER_XBGR shl 20) or (SDL_PACKEDLAYOUT_1555 shl 16) or (16 shl 8) or (2 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGB24 = (1 shl 28) or (SDL_PIXELTYPE_ARRAYU8 shl 24) or (SDL_ARRAYORDER_RGB shl 20) or (0 shl 16) or (24 shl 8) or (3 shl 0);

This item has no description.

SDL_PIXELFORMAT_BGR24 = (1 shl 28) or (SDL_PIXELTYPE_ARRAYU8 shl 24) or (SDL_ARRAYORDER_BGR shl 20) or (0 shl 16) or (24 shl 8) or (3 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGB888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_XRGB shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (24 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGBX8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_RGBX shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (24 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_BGR888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_XBGR shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (24 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_BGRX8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_BGRX shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (24 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_ARGB8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_ARGB shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (32 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_RGBA8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_RGBA shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (32 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_ABGR8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_ABGR shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (32 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_BGRA8888 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_RGBX shl 20) or (SDL_PACKEDLAYOUT_8888 shl 16) or (32 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_ARGB2101010 = (1 shl 28) or (SDL_PIXELTYPE_PACKED32 shl 24) or (SDL_PACKEDORDER_ARGB shl 20) or (SDL_PACKEDLAYOUT_2101010 shl 16)or (32 shl 8) or (4 shl 0);

This item has no description.

SDL_PIXELFORMAT_YV12 = (Integer('Y') ) or (Integer('V') shl 8) or (Integer('1') shl 16) or (Integer('2') shl 24);

**< Planar mode: Y + V + U (3 planes) *

SDL_PIXELFORMAT_IYUV = (Integer('I') ) or (Integer('Y') shl 8) or (Integer('U') shl 16) or (Integer('V') shl 24);

**< Planar mode: Y + U + V (3 planes) *

SDL_PIXELFORMAT_YUY2 = (Integer('Y') ) or (Integer('U') shl 8) or (Integer('Y') shl 16) or (Integer('2') shl 24);

**< Packed mode: Y0+U0+Y1+V0 (1 plane) *

SDL_PIXELFORMAT_UYVY = (Integer('U') ) or (Integer('Y') shl 8) or (Integer('V') shl 16) or (Integer('Y') shl 24);

**< Packed mode: U0+Y0+V0+Y1 (1 plane) *

SDL_PIXELFORMAT_YVYU = (Integer('Y') ) or (Integer('V') shl 8) or (Integer('Y') shl 16) or (Integer('U') shl 24);

**< Packed mode: Y0+V0+Y1+U0 (1 plane) *

SDL_BLENDMODE_NONE = $00000000;

This item has no description.

SDL_BLENDMODE_BLEND = $00000001;

**< No blending *

SDL_BLENDMODE_ADD = $00000002;

**< dst = (src * A) + (dst * (1-A)) *

SDL_BLENDMODE_MOD = $00000004;

**< dst = (src * A) + dst *

SDL_SWSURFACE = 0;

** * Surface flags * * These are the currently supported flags for the ::SDL_surface. * * Used internally (read-only). *

SDL_PREALLOC = $00000001;

**< Just here for compatibility *

SDL_RLEACCEL = $00000002;

**< Surface uses preallocated memory *

SDL_DONTFREE = $00000004;

**< Surface is RLE encoded *

SDL_NONSHAPEABLE_WINDOW = -1;

** SDL_shape.h * * Header file for the shaped window API. *

SDL_INVALID_SHAPE_ARGUMENT = -2;

This item has no description.

SDL_WINDOW_LACKS_SHAPE = -3;

This item has no description.

SDL_WINDOW_FULLSCREEN = $00000001;

** * The flags on a window * * SDL_GetWindowFlags() *

SDL_WINDOW_OPENGL = $00000002;

**< fullscreen window *

SDL_WINDOW_SHOWN = $00000004;

**< window usable with OpenGL context *

SDL_WINDOW_HIDDEN = $00000008;

**< window is visible *

SDL_WINDOW_BORDERLESS = $00000010;

**< window is not visible *

SDL_WINDOW_RESIZABLE = $00000020;

**< no window decoration *

SDL_WINDOW_MINIMIZED = $00000040;

**< window can be resized *

SDL_WINDOW_MAXIMIZED = $00000080;

**< window is minimized *

SDL_WINDOW_INPUT_GRABBED = $00000100;

**< window is maximized *

SDL_WINDOW_INPUT_FOCUS = $00000200;

**< window has grabbed input focus *

SDL_WINDOW_MOUSE_FOCUS = $00000400;

**< window has input focus *

SDL_WINDOW_FULLSCREEN_DESKTOP = SDL_WINDOW_FULLSCREEN or $00001000;

**< window has mouse focus *

SDL_WINDOW_FOREIGN = $00000800;

This item has no description.

SDL_WINDOWPOS_UNDEFINED_MASK = $1FFF0000;

** * Used to indicate that you don't care what the window position is. *

SDL_WINDOWPOS_UNDEFINED = SDL_WINDOWPOS_UNDEFINED_MASK or 0;

This item has no description.

SDL_WINDOWPOS_CENTERED_MASK = $2FFF0000;

** * Used to indicate that the window position should be centered. *

SDL_WINDOWPOS_CENTERED = SDL_WINDOWPOS_CENTERED_MASK or 0;

This item has no description.

SDL_WINDOWEVENT_NONE = 0;

** * Event subtype for window events *

SDL_WINDOWEVENT_SHOWN = 1;

**< Never used *

SDL_WINDOWEVENT_HIDDEN = 2;

**< Window has been shown *

SDL_WINDOWEVENT_EXPOSED = 3;

**< Window has been hidden *

SDL_WINDOWEVENT_MOVED = 4;

**< Window has been exposed and should be redrawn *

SDL_WINDOWEVENT_RESIZED = 5;

**< Window has been moved to data1; data2 *

SDL_WINDOWEVENT_SIZE_CHANGED = 6;

**< Window has been resized to data1xdata2 *

SDL_WINDOWEVENT_MINIMIZED = 7;

**< The window size has changed; either as a result of an API call or through the system or user changing the window size. *

SDL_WINDOWEVENT_MAXIMIZED = 8;

**< Window has been minimized *

SDL_WINDOWEVENT_RESTORED = 9;

**< Window has been maximized *

SDL_WINDOWEVENT_ENTER = 10;

**< Window has been restored to normal size and position *

SDL_WINDOWEVENT_LEAVE = 11;

**< Window has gained mouse focus *

SDL_WINDOWEVENT_FOCUS_GAINED = 12;

**< Window has lost mouse focus *

SDL_WINDOWEVENT_FOCUS_LOST = 13;

**< Window has gained keyboard focus *

SDL_WINDOWEVENT_CLOSE = 14;

**< Window has lost keyboard focus *

SDL_GL_RED_SIZE = 0;

** * OpenGL configuration attributes *

SDL_GL_GREEN_SIZE = 1;

This item has no description.

SDL_GL_BLUE_SIZE = 2;

This item has no description.

SDL_GL_ALPHA_SIZE = 3;

This item has no description.

SDL_GL_BUFFER_SIZE = 4;

This item has no description.

SDL_GL_DOUBLEBUFFER = 5;

This item has no description.

SDL_GL_DEPTH_SIZE = 6;

This item has no description.

SDL_GL_STENCIL_SIZE = 7;

This item has no description.

SDL_GL_ACCUM_RED_SIZE = 8;

This item has no description.

SDL_GL_ACCUM_GREEN_SIZE = 9;

This item has no description.

SDL_GL_ACCUM_BLUE_SIZE = 10;

This item has no description.

SDL_GL_ACCUM_ALPHA_SIZE = 11;

This item has no description.

SDL_GL_STEREO = 12;

This item has no description.

SDL_GL_MULTISAMPLEBUFFERS = 13;

This item has no description.

SDL_GL_MULTISAMPLESAMPLES = 14;

This item has no description.

SDL_GL_ACCELERATED_VISUAL = 15;

This item has no description.

SDL_GL_RETAINED_BACKING = 16;

This item has no description.

SDL_GL_CONTEXT_MAJOR_VERSION = 17;

This item has no description.

SDL_GL_CONTEXT_MINOR_VERSION = 18;

This item has no description.

SDL_GL_CONTEXT_EGL = 19;

This item has no description.

SDL_GL_CONTEXT_FLAGS = 20;

This item has no description.

SDL_GL_CONTEXT_PROFILE_MASK = 21;

This item has no description.

SDL_GL_SHARE_WITH_CURRENT_CONTEXT = 22;

This item has no description.

SDL_GL_CONTEXT_PROFILE_CORE = $0001;

This item has no description.

SDL_GL_CONTEXT_PROFILE_COMPATIBILITY = $0002;

This item has no description.

SDL_GL_CONTEXT_PROFILE_ES = $0004;

This item has no description.

SDL_GL_CONTEXT_DEBUG_FLAG = $0001;

This item has no description.

SDL_GL_CONTEXT_FORWARD_COMPATIBLE_FLAG = $0002;

This item has no description.

SDL_GL_CONTEXT_ROBUST_ACCESS_FLAG = $0004;

This item has no description.

SDL_GL_CONTEXT_RESET_ISOLATION_FLAG = $0008;

This item has no description.

SDL_RENDERER_SOFTWARE = $00000001;

** * Flags used when creating a rendering context *

SDL_RENDERER_ACCELERATED = $00000002;

**< The renderer is a software fallback *

SDL_RENDERER_PRESENTVSYNC = $00000004;

**< The renderer uses hardware acceleration *

SDL_RENDERER_TARGETTEXTURE = $00000008;

**< Present is synchronized with the refresh rate *

SDL_SCANCODE_UNKNOWN = 0;

** * The SDL keyboard scancode representation. * * Values of this type are used to represent keyboard keys, among other places * in the SDL_Keysym.scancode key.keysym.scancode \endlink field of the * SDL_Event structure. * * The values in this enumeration are based on the USB usage page standard: * http://www.usb.org/developers/devclass_docs/Hut1_12v2.pdf *

SDL_SCANCODE_A = 4;

** * Usage page $07 * * These values are from usage page $07 (USB keyboard page). *

SDL_SCANCODE_B = 5;

This item has no description.

SDL_SCANCODE_C = 6;

This item has no description.

SDL_SCANCODE_D = 7;

This item has no description.

SDL_SCANCODE_E = 8;

This item has no description.

SDL_SCANCODE_F = 9;

This item has no description.

SDL_SCANCODE_G = 10;

This item has no description.

SDL_SCANCODE_H = 11;

This item has no description.

SDL_SCANCODE_I = 12;

This item has no description.

SDL_SCANCODE_J = 13;

This item has no description.

SDL_SCANCODE_K = 14;

This item has no description.

SDL_SCANCODE_L = 15;

This item has no description.

SDL_SCANCODE_M = 16;

This item has no description.

SDL_SCANCODE_N = 17;

This item has no description.

SDL_SCANCODE_O = 18;

This item has no description.

SDL_SCANCODE_P = 19;

This item has no description.

SDL_SCANCODE_Q = 20;

This item has no description.

SDL_SCANCODE_R = 21;

This item has no description.

SDL_SCANCODE_S = 22;

This item has no description.

SDL_SCANCODE_T = 23;

This item has no description.

SDL_SCANCODE_U = 24;

This item has no description.

SDL_SCANCODE_V = 25;

This item has no description.

SDL_SCANCODE_W = 26;

This item has no description.

SDL_SCANCODE_X = 27;

This item has no description.

SDL_SCANCODE_Y = 28;

This item has no description.

SDL_SCANCODE_Z = 29;

This item has no description.

SDL_SCANCODE_1 = 30;

This item has no description.

SDL_SCANCODE_2 = 31;

This item has no description.

SDL_SCANCODE_3 = 32;

This item has no description.

SDL_SCANCODE_4 = 33;

This item has no description.

SDL_SCANCODE_5 = 34;

This item has no description.

SDL_SCANCODE_6 = 35;

This item has no description.

SDL_SCANCODE_7 = 36;

This item has no description.

SDL_SCANCODE_8 = 37;

This item has no description.

SDL_SCANCODE_9 = 38;

This item has no description.

SDL_SCANCODE_0 = 39;

This item has no description.

SDL_SCANCODE_RETURN = 40;

This item has no description.

SDL_SCANCODE_ESCAPE = 41;

This item has no description.

SDL_SCANCODE_BACKSPACE = 42;

This item has no description.

SDL_SCANCODE_TAB = 43;

This item has no description.

SDL_SCANCODE_SPACE = 44;

This item has no description.

SDL_SCANCODE_MINUS = 45;

This item has no description.

SDL_SCANCODE_EQUALS = 46;

This item has no description.

SDL_SCANCODE_LEFTBRACKET = 47;

This item has no description.

SDL_SCANCODE_RIGHTBRACKET = 48;

This item has no description.

SDL_SCANCODE_BACKSLASH = 49;

This item has no description.

SDL_SCANCODE_NONUSHASH = 50;

**< Located at the lower left of the return * key on ISO keyboards and at the right end * of the QWERTY row on ANSI keyboards. * Produces REVERSE SOLIDUS (backslash) and * VERTICAL LINE in a US layout; REVERSE * SOLIDUS and VERTICAL LINE in a UK Mac * layout; NUMBER SIGN and TILDE in a UK * Windows layout; DOLLAR SIGN and POUND SIGN * in a Swiss German layout; NUMBER SIGN and * APOSTROPHE in a German layout; GRAVE * ACCENT and POUND SIGN in a French Mac * layout; and ASTERISK and MICRO SIGN in a * French Windows layout. *

SDL_SCANCODE_SEMICOLON = 51;

**< ISO USB keyboards actually use this code * instead of 49 for the same key; but all * OSes I've seen treat the two codes * identically. So; as an implementor; unless * your keyboard generates both of those * codes and your OS treats them differently; * you should generate SDL_SCANCODE_BACKSLASH * instead of this code. As a user; you * should not rely on this code because SDL * will never generate it with most (all?) * keyboards. *

SDL_SCANCODE_APOSTROPHE = 52;

This item has no description.

SDL_SCANCODE_GRAVE = 53;

This item has no description.

SDL_SCANCODE_COMMA = 54;

**< Located in the top left corner (on both ANSI * and ISO keyboards). Produces GRAVE ACCENT and * TILDE in a US Windows layout and in US and UK * Mac layouts on ANSI keyboards; GRAVE ACCENT * and NOT SIGN in a UK Windows layout; SECTION * SIGN and PLUS-MINUS SIGN in US and UK Mac * layouts on ISO keyboards; SECTION SIGN and * DEGREE SIGN in a Swiss German layout (Mac: * only on ISO keyboards); CIRCUMFLEX ACCENT and * DEGREE SIGN in a German layout (Mac: only on * ISO keyboards); SUPERSCRIPT TWO and TILDE in a * French Windows layout; COMMERCIAL AT and * NUMBER SIGN in a French Mac layout on ISO * keyboards; and LESS-THAN SIGN and GREATER-THAN * SIGN in a Swiss German; German; or French Mac * layout on ANSI keyboards. *

SDL_SCANCODE_PERIOD = 55;

This item has no description.

SDL_SCANCODE_SLASH = 56;

This item has no description.

SDL_SCANCODE_CAPSLOCK = 57;

This item has no description.

SDL_SCANCODE_F1 = 58;

This item has no description.

SDL_SCANCODE_F2 = 59;

This item has no description.

SDL_SCANCODE_F3 = 60;

This item has no description.

SDL_SCANCODE_F4 = 61;

This item has no description.

SDL_SCANCODE_F5 = 62;

This item has no description.

SDL_SCANCODE_F6 = 63;

This item has no description.

SDL_SCANCODE_F7 = 64;

This item has no description.

SDL_SCANCODE_F8 = 65;

This item has no description.

SDL_SCANCODE_F9 = 66;

This item has no description.

SDL_SCANCODE_F10 = 67;

This item has no description.

SDL_SCANCODE_F11 = 68;

This item has no description.

SDL_SCANCODE_F12 = 69;

This item has no description.

SDL_SCANCODE_PRINTSCREEN = 70;

This item has no description.

SDL_SCANCODE_SCROLLLOCK = 71;

This item has no description.

SDL_SCANCODE_PAUSE = 72;

This item has no description.

SDL_SCANCODE_INSERT = 73;

This item has no description.

SDL_SCANCODE_HOME = 74;

**< insert on PC; help on some Mac keyboards (but does send code 73; not 117) *

SDL_SCANCODE_PAGEUP = 75;

This item has no description.

SDL_SCANCODE_DELETE = 76;

This item has no description.

SDL_SCANCODE_END = 77;

This item has no description.

SDL_SCANCODE_PAGEDOWN = 78;

This item has no description.

SDL_SCANCODE_RIGHT = 79;

This item has no description.

SDL_SCANCODE_LEFT = 80;

This item has no description.

SDL_SCANCODE_DOWN = 81;

This item has no description.

SDL_SCANCODE_UP = 82;

This item has no description.

SDL_SCANCODE_NUMLOCKCLEAR = 83;

This item has no description.

SDL_SCANCODE_KP_DIVIDE = 84;

**< num lock on PC; clear on Mac keyboards *

SDL_SCANCODE_KP_MULTIPLY = 85;

This item has no description.

SDL_SCANCODE_KP_MINUS = 86;

This item has no description.

SDL_SCANCODE_KP_PLUS = 87;

This item has no description.

SDL_SCANCODE_KP_ENTER = 88;

This item has no description.

SDL_SCANCODE_KP_1 = 89;

This item has no description.

SDL_SCANCODE_KP_2 = 90;

This item has no description.

SDL_SCANCODE_KP_3 = 91;

This item has no description.

SDL_SCANCODE_KP_4 = 92;

This item has no description.

SDL_SCANCODE_KP_5 = 93;

This item has no description.

SDL_SCANCODE_KP_6 = 94;

This item has no description.

SDL_SCANCODE_KP_7 = 95;

This item has no description.

SDL_SCANCODE_KP_8 = 96;

This item has no description.

SDL_SCANCODE_KP_9 = 97;

This item has no description.

SDL_SCANCODE_KP_0 = 98;

This item has no description.

SDL_SCANCODE_KP_PERIOD = 99;

This item has no description.

SDL_SCANCODE_NONUSBACKSLASH = 100;

This item has no description.

SDL_SCANCODE_APPLICATION = 101;

**< This is the additional key that ISO * keyboards have over ANSI ones; * located between left shift and Y. * Produces GRAVE ACCENT and TILDE in a * US or UK Mac layout; REVERSE SOLIDUS * (backslash) and VERTICAL LINE in a * US or UK Windows layout; and * LESS-THAN SIGN and GREATER-THAN SIGN * in a Swiss German; German; or French * layout. *

SDL_SCANCODE_POWER = 102;

**< windows contextual menu; compose *

SDL_SCANCODE_KP_EQUALS = 103;

**< The USB document says this is a status flag; * not a physical key - but some Mac keyboards * do have a power key. *

SDL_SCANCODE_F13 = 104;

This item has no description.

SDL_SCANCODE_F14 = 105;

This item has no description.

SDL_SCANCODE_F15 = 106;

This item has no description.

SDL_SCANCODE_F16 = 107;

This item has no description.

SDL_SCANCODE_F17 = 108;

This item has no description.

SDL_SCANCODE_F18 = 109;

This item has no description.

SDL_SCANCODE_F19 = 110;

This item has no description.

SDL_SCANCODE_F20 = 111;

This item has no description.

SDL_SCANCODE_F21 = 112;

This item has no description.

SDL_SCANCODE_F22 = 113;

This item has no description.

SDL_SCANCODE_F23 = 114;

This item has no description.

SDL_SCANCODE_F24 = 115;

This item has no description.

SDL_SCANCODE_EXECUTE = 116;

This item has no description.

SDL_SCANCODE_HELP = 117;

This item has no description.

SDL_SCANCODE_MENU = 118;

This item has no description.

SDL_SCANCODE_SELECT = 119;

This item has no description.

SDL_SCANCODE_STOP = 120;

This item has no description.

SDL_SCANCODE_AGAIN = 121;

This item has no description.

SDL_SCANCODE_UNDO = 122;

**< redo *

SDL_SCANCODE_CUT = 123;

This item has no description.

SDL_SCANCODE_COPY = 124;

This item has no description.

SDL_SCANCODE_PASTE = 125;

This item has no description.

SDL_SCANCODE_FIND = 126;

This item has no description.

SDL_SCANCODE_MUTE = 127;

This item has no description.

SDL_SCANCODE_VOLUMEUP = 128;

This item has no description.

SDL_SCANCODE_VOLUMEDOWN = 129;

This item has no description.

SDL_SCANCODE_KP_COMMA = 133;

* SDL_SCANCODE_LOCKINGSCROLLLOCK = 132; *

SDL_SCANCODE_KP_EQUALSAS400 = 134;

This item has no description.

SDL_SCANCODE_INTERNATIONAL1 = 135;

This item has no description.

SDL_SCANCODE_INTERNATIONAL2 = 136;

**< used on Asian keyboards; see footnotes in USB doc *

SDL_SCANCODE_INTERNATIONAL3 = 137;

This item has no description.

SDL_SCANCODE_INTERNATIONAL4 = 138;

**< Yen *

SDL_SCANCODE_INTERNATIONAL5 = 139;

This item has no description.

SDL_SCANCODE_INTERNATIONAL6 = 140;

This item has no description.

SDL_SCANCODE_INTERNATIONAL7 = 141;

This item has no description.

SDL_SCANCODE_INTERNATIONAL8 = 142;

This item has no description.

SDL_SCANCODE_INTERNATIONAL9 = 143;

This item has no description.

SDL_SCANCODE_LANG1 = 144;

This item has no description.

SDL_SCANCODE_LANG2 = 145;

**< Hangul{English toggle *

SDL_SCANCODE_LANG3 = 146;

**< Hanja conversion *

SDL_SCANCODE_LANG4 = 147;

**< Katakana *

SDL_SCANCODE_LANG5 = 148;

**< Hiragana *

SDL_SCANCODE_LANG6 = 149;

**< Zenkaku{Hankaku *

SDL_SCANCODE_LANG7 = 150;

**< reserved *

SDL_SCANCODE_LANG8 = 151;

**< reserved *

SDL_SCANCODE_LANG9 = 152;

**< reserved *

SDL_SCANCODE_ALTERASE = 153;

**< reserved *

SDL_SCANCODE_SYSREQ = 154;

**< Erase-Eaze *

SDL_SCANCODE_CANCEL = 155;

This item has no description.

SDL_SCANCODE_CLEAR = 156;

This item has no description.

SDL_SCANCODE_PRIOR = 157;

This item has no description.

SDL_SCANCODE_RETURN2 = 158;

This item has no description.

SDL_SCANCODE_SEPARATOR = 159;

This item has no description.

SDL_SCANCODE_OUT = 160;

This item has no description.

SDL_SCANCODE_OPER = 161;

This item has no description.

SDL_SCANCODE_CLEARAGAIN = 162;

This item has no description.

SDL_SCANCODE_CRSEL = 163;

This item has no description.

SDL_SCANCODE_EXSEL = 164;

This item has no description.

SDL_SCANCODE_KP_00 = 176;

This item has no description.

SDL_SCANCODE_KP_000 = 177;

This item has no description.

SDL_SCANCODE_THOUSANDSSEPARATOR = 178;

This item has no description.

SDL_SCANCODE_DECIMALSEPARATOR = 179;

This item has no description.

SDL_SCANCODE_CURRENCYUNIT = 180;

This item has no description.

SDL_SCANCODE_CURRENCYSUBUNIT = 181;

This item has no description.

SDL_SCANCODE_KP_LEFTPAREN = 182;

This item has no description.

SDL_SCANCODE_KP_RIGHTPAREN = 183;

This item has no description.

SDL_SCANCODE_KP_LEFTBRACE = 184;

This item has no description.

SDL_SCANCODE_KP_RIGHTBRACE = 185;

This item has no description.

SDL_SCANCODE_KP_TAB = 186;

This item has no description.

SDL_SCANCODE_KP_BACKSPACE = 187;

This item has no description.

SDL_SCANCODE_KP_A = 188;

This item has no description.

SDL_SCANCODE_KP_B = 189;

This item has no description.

SDL_SCANCODE_KP_C = 190;

This item has no description.

SDL_SCANCODE_KP_D = 191;

This item has no description.

SDL_SCANCODE_KP_E = 192;

This item has no description.

SDL_SCANCODE_KP_F = 193;

This item has no description.

SDL_SCANCODE_KP_XOR = 194;

This item has no description.

SDL_SCANCODE_KP_POWER = 195;

This item has no description.

SDL_SCANCODE_KP_PERCENT = 196;

This item has no description.

SDL_SCANCODE_KP_LESS = 197;

This item has no description.

SDL_SCANCODE_KP_GREATER = 198;

This item has no description.

SDL_SCANCODE_KP_AMPERSAND = 199;

This item has no description.

SDL_SCANCODE_KP_DBLAMPERSAND = 200;

This item has no description.

SDL_SCANCODE_KP_VERTICALBAR = 201;

This item has no description.

SDL_SCANCODE_KP_DBLVERTICALBAR = 202;

This item has no description.

SDL_SCANCODE_KP_COLON = 203;

This item has no description.

SDL_SCANCODE_KP_HASH = 204;

This item has no description.

SDL_SCANCODE_KP_SPACE = 205;

This item has no description.

SDL_SCANCODE_KP_AT = 206;

This item has no description.

SDL_SCANCODE_KP_EXCLAM = 207;

This item has no description.

SDL_SCANCODE_KP_MEMSTORE = 208;

This item has no description.

SDL_SCANCODE_KP_MEMRECALL = 209;

This item has no description.

SDL_SCANCODE_KP_MEMCLEAR = 210;

This item has no description.

SDL_SCANCODE_KP_MEMADD = 211;

This item has no description.

SDL_SCANCODE_KP_MEMSUBTRACT = 212;

This item has no description.

SDL_SCANCODE_KP_MEMMULTIPLY = 213;

This item has no description.

SDL_SCANCODE_KP_MEMDIVIDE = 214;

This item has no description.

SDL_SCANCODE_KP_PLUSMINUS = 215;

This item has no description.

SDL_SCANCODE_KP_CLEAR = 216;

This item has no description.

SDL_SCANCODE_KP_CLEARENTRY = 217;

This item has no description.

SDL_SCANCODE_KP_BINARY = 218;

This item has no description.

SDL_SCANCODE_KP_OCTAL = 219;

This item has no description.

SDL_SCANCODE_KP_DECIMAL = 220;

This item has no description.

SDL_SCANCODE_KP_HEXADECIMAL = 221;

This item has no description.

SDL_SCANCODE_LCTRL = 224;

This item has no description.

SDL_SCANCODE_LSHIFT = 225;

This item has no description.

SDL_SCANCODE_LALT = 226;

This item has no description.

SDL_SCANCODE_LGUI = 227;

**< alt; option *

SDL_SCANCODE_RCTRL = 228;

**< windows; command (apple); meta *

SDL_SCANCODE_RSHIFT = 229;

This item has no description.

SDL_SCANCODE_RALT = 230;

This item has no description.

SDL_SCANCODE_RGUI = 231;

**< alt gr; option *

SDL_SCANCODE_MODE = 257;

**< windows; command (apple); meta *

SDL_SCANCODE_AUDIONEXT = 258;

** * Usage page $0C * * These values are mapped from usage page $0C (USB consumer page). *

SDL_SCANCODE_AUDIOPREV = 259;

This item has no description.

SDL_SCANCODE_AUDIOSTOP = 260;

This item has no description.

SDL_SCANCODE_AUDIOPLAY = 261;

This item has no description.

SDL_SCANCODE_AUDIOMUTE = 262;

This item has no description.

SDL_SCANCODE_MEDIASELECT = 263;

This item has no description.

SDL_SCANCODE_WWW = 264;

This item has no description.

SDL_SCANCODE_MAIL = 265;

This item has no description.

SDL_SCANCODE_CALCULATOR = 266;

This item has no description.

SDL_SCANCODE_COMPUTER = 267;

This item has no description.

SDL_SCANCODE_AC_SEARCH = 268;

This item has no description.

SDL_SCANCODE_AC_HOME = 269;

This item has no description.

SDL_SCANCODE_AC_BACK = 270;

This item has no description.

SDL_SCANCODE_AC_FORWARD = 271;

This item has no description.

SDL_SCANCODE_AC_STOP = 272;

This item has no description.

SDL_SCANCODE_AC_REFRESH = 273;

This item has no description.

SDL_SCANCODE_AC_BOOKMARKS = 274;

This item has no description.

SDL_SCANCODE_BRIGHTNESSDOWN = 275;

** * Walther keys * * These are values that Christian Walther added (for mac keyboard?). *

SDL_SCANCODE_BRIGHTNESSUP = 276;

This item has no description.

SDL_SCANCODE_DISPLAYSWITCH = 277;

This item has no description.

SDL_SCANCODE_KBDILLUMTOGGLE = 278;

**< display mirroring{dual display switch; video mode switch *

SDL_SCANCODE_KBDILLUMDOWN = 279;

This item has no description.

SDL_SCANCODE_KBDILLUMUP = 280;

This item has no description.

SDL_SCANCODE_EJECT = 281;

This item has no description.

SDL_SCANCODE_SLEEP = 282;

This item has no description.

SDL_SCANCODE_APP1 = 283;

This item has no description.

SDL_SCANCODE_APP2 = 284;

This item has no description.

SDL_NUM_SCANCODES = 512;

* Add any other keys here. *

SDLK_SCANCODE_MASK = 1 shl 30;

This item has no description.

SDLK_UNKNOWN = 0;

This item has no description.

SDLK_RETURN = '\r';

This item has no description.

SDLK_ESCAPE = '\033';

This item has no description.

SDLK_BACKSPACE = '\b';

This item has no description.

SDLK_TAB = '\t';

This item has no description.

SDLK_SPACE = ' ';

This item has no description.

SDLK_EXCLAIM = '!';

This item has no description.

SDLK_QUOTEDBL = '"';

This item has no description.

SDLK_HASH = '#';

This item has no description.

SDLK_PERCENT = '%';

This item has no description.

SDLK_DOLLAR = '$';

This item has no description.

SDLK_AMPERSAND = '&';

This item has no description.

SDLK_QUOTE = '\';

This item has no description.

SDLK_LEFTPAREN = '(';

This item has no description.

SDLK_RIGHTPAREN = ')';

This item has no description.

SDLK_ASTERISK = '*';

This item has no description.

SDLK_PLUS = '+';

This item has no description.

SDLK_COMMA = ';';

This item has no description.

SDLK_MINUS = '-';

This item has no description.

SDLK_PERIOD = '.';

This item has no description.

SDLK_SLASH = '/';

This item has no description.

SDLK_0 = '0';

This item has no description.

SDLK_1 = '1';

This item has no description.

SDLK_2 = '2';

This item has no description.

SDLK_3 = '3';

This item has no description.

SDLK_4 = '4';

This item has no description.

SDLK_5 = '5';

This item has no description.

SDLK_6 = '6';

This item has no description.

SDLK_7 = '7';

This item has no description.

SDLK_8 = '8';

This item has no description.

SDLK_9 = '9';

This item has no description.

SDLK_COLON = ':';

This item has no description.

SDLK_SEMICOLON = ';';

This item has no description.

SDLK_LESS = '<';

This item has no description.

SDLK_EQUALS = '=';

This item has no description.

SDLK_GREATER = '>';

This item has no description.

SDLK_QUESTION = '?';

This item has no description.

SDLK_AT = '@';

This item has no description.

SDLK_LEFTBRACKET = '[';

* Skip uppercase letters *

SDLK_BACKSLASH = '\\';

This item has no description.

SDLK_RIGHTBRACKET = ']';

This item has no description.

SDLK_CARET = 'ˆ';

This item has no description.

SDLK_UNDERSCORE = '_';

This item has no description.

SDLK_BACKQUOTE = '`';

This item has no description.

SDLK_a = 'a';

This item has no description.

SDLK_b = 'b';

This item has no description.

SDLK_c = 'c';

This item has no description.

SDLK_d = 'd';

This item has no description.

SDLK_e = 'e';

This item has no description.

SDLK_f = 'f';

This item has no description.

SDLK_g = 'g';

This item has no description.

SDLK_h = 'h';

This item has no description.

SDLK_i = 'i';

This item has no description.

SDLK_j = 'j';

This item has no description.

SDLK_k = 'k';

This item has no description.

SDLK_l = 'l';

This item has no description.

SDLK_m = 'm';

This item has no description.

SDLK_n = 'n';

This item has no description.

SDLK_o = 'o';

This item has no description.

SDLK_p = 'p';

This item has no description.

SDLK_q = 'q';

This item has no description.

SDLK_r = 'r';

This item has no description.

SDLK_s = 's';

This item has no description.

SDLK_t = 't';

This item has no description.

SDLK_u = 'u';

This item has no description.

SDLK_v = 'v';

This item has no description.

SDLK_w = 'w';

This item has no description.

SDLK_x = 'x';

This item has no description.

SDLK_y = 'y';

This item has no description.

SDLK_z = 'z';

This item has no description.

SDLK_CAPSLOCK = SDL_SCANCODE_CAPSLOCK or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F1 = SDL_SCANCODE_F1 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F2 = SDL_SCANCODE_F2 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F3 = SDL_SCANCODE_F3 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F4 = SDL_SCANCODE_F4 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F5 = SDL_SCANCODE_F5 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F6 = SDL_SCANCODE_F6 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F7 = SDL_SCANCODE_F7 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F8 = SDL_SCANCODE_F8 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F9 = SDL_SCANCODE_F9 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F10 = SDL_SCANCODE_F10 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F11 = SDL_SCANCODE_F11 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F12 = SDL_SCANCODE_F12 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_PRINTSCREEN = SDL_SCANCODE_PRINTSCREEN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_SCROLLLOCK = SDL_SCANCODE_SCROLLLOCK or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_PAUSE = SDL_SCANCODE_PAUSE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_INSERT = SDL_SCANCODE_INSERT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_HOME = SDL_SCANCODE_HOME or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_PAGEUP = SDL_SCANCODE_PAGEUP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_DELETE = '\177';

This item has no description.

SDLK_END = SDL_SCANCODE_END or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_PAGEDOWN = SDL_SCANCODE_PAGEDOWN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_RIGHT = SDL_SCANCODE_RIGHT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_LEFT = SDL_SCANCODE_LEFT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_DOWN = SDL_SCANCODE_DOWN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_UP = SDL_SCANCODE_UP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_NUMLOCKCLEAR = SDL_SCANCODE_NUMLOCKCLEAR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_DIVIDE = SDL_SCANCODE_KP_DIVIDE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MULTIPLY = SDL_SCANCODE_KP_MULTIPLY or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MINUS = SDL_SCANCODE_KP_MINUS or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_PLUS = SDL_SCANCODE_KP_PLUS or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_ENTER = SDL_SCANCODE_KP_ENTER or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_1 = SDL_SCANCODE_KP_1 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_2 = SDL_SCANCODE_KP_2 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_3 = SDL_SCANCODE_KP_3 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_4 = SDL_SCANCODE_KP_4 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_5 = SDL_SCANCODE_KP_5 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_6 = SDL_SCANCODE_KP_6 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_7 = SDL_SCANCODE_KP_7 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_8 = SDL_SCANCODE_KP_8 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_9 = SDL_SCANCODE_KP_9 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_0 = SDL_SCANCODE_KP_0 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_PERIOD = SDL_SCANCODE_KP_PERIOD or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_APPLICATION = SDL_SCANCODE_APPLICATION or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_POWER = SDL_SCANCODE_POWER or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_EQUALS = SDL_SCANCODE_KP_EQUALS or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F13 = SDL_SCANCODE_F13 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F14 = SDL_SCANCODE_F14 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F15 = SDL_SCANCODE_F15 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F16 = SDL_SCANCODE_F16 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F17 = SDL_SCANCODE_F17 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F18 = SDL_SCANCODE_F18 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F19 = SDL_SCANCODE_F19 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F20 = SDL_SCANCODE_F20 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F21 = SDL_SCANCODE_F21 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F22 = SDL_SCANCODE_F22 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F23 = SDL_SCANCODE_F23 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_F24 = SDL_SCANCODE_F24 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_EXECUTE = SDL_SCANCODE_EXECUTE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_HELP = SDL_SCANCODE_HELP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_MENU = SDL_SCANCODE_MENU or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_SELECT = SDL_SCANCODE_SELECT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_STOP = SDL_SCANCODE_STOP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AGAIN = SDL_SCANCODE_AGAIN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_UNDO = SDL_SCANCODE_UNDO or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_CUT = SDL_SCANCODE_CUT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_COPY = SDL_SCANCODE_COPY or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_PASTE = SDL_SCANCODE_PASTE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_FIND = SDL_SCANCODE_FIND or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_MUTE = SDL_SCANCODE_MUTE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_VOLUMEUP = SDL_SCANCODE_VOLUMEUP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_VOLUMEDOWN = SDL_SCANCODE_VOLUMEDOWN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_COMMA = SDL_SCANCODE_KP_COMMA or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_EQUALSAS400 = SDL_SCANCODE_KP_EQUALSAS400 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_ALTERASE = SDL_SCANCODE_ALTERASE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_SYSREQ = SDL_SCANCODE_SYSREQ or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_CANCEL = SDL_SCANCODE_CANCEL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_CLEAR = SDL_SCANCODE_CLEAR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_PRIOR = SDL_SCANCODE_PRIOR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_RETURN2 = SDL_SCANCODE_RETURN2 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_SEPARATOR = SDL_SCANCODE_SEPARATOR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_OUT = SDL_SCANCODE_OUT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_OPER = SDL_SCANCODE_OPER or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_CLEARAGAIN = SDL_SCANCODE_CLEARAGAIN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_CRSEL = SDL_SCANCODE_CRSEL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_EXSEL = SDL_SCANCODE_EXSEL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_00 = SDL_SCANCODE_KP_00 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_000 = SDL_SCANCODE_KP_000 or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_THOUSANDSSEPARATOR = SDL_SCANCODE_THOUSANDSSEPARATOR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_DECIMALSEPARATOR = SDL_SCANCODE_DECIMALSEPARATOR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_CURRENCYUNIT = SDL_SCANCODE_CURRENCYUNIT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_CURRENCYSUBUNIT = SDL_SCANCODE_CURRENCYSUBUNIT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_LEFTPAREN = SDL_SCANCODE_KP_LEFTPAREN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_RIGHTPAREN = SDL_SCANCODE_KP_RIGHTPAREN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_LEFTBRACE = SDL_SCANCODE_KP_LEFTBRACE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_RIGHTBRACE = SDL_SCANCODE_KP_RIGHTBRACE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_TAB = SDL_SCANCODE_KP_TAB or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_BACKSPACE = SDL_SCANCODE_KP_BACKSPACE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_A = SDL_SCANCODE_KP_A or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_B = SDL_SCANCODE_KP_B or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_C = SDL_SCANCODE_KP_C or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_D = SDL_SCANCODE_KP_D or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_E = SDL_SCANCODE_KP_E or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_F = SDL_SCANCODE_KP_F or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_XOR = SDL_SCANCODE_KP_XOR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_POWER = SDL_SCANCODE_KP_POWER or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_PERCENT = SDL_SCANCODE_KP_PERCENT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_LESS = SDL_SCANCODE_KP_LESS or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_GREATER = SDL_SCANCODE_KP_GREATER or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_AMPERSAND = SDL_SCANCODE_KP_AMPERSAND or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_DBLAMPERSAND = SDL_SCANCODE_KP_DBLAMPERSAND or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_VERTICALBAR = SDL_SCANCODE_KP_VERTICALBAR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_DBLVERTICALBAR = SDL_SCANCODE_KP_DBLVERTICALBAR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_COLON = SDL_SCANCODE_KP_COLON or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_HASH = SDL_SCANCODE_KP_HASH or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_SPACE = SDL_SCANCODE_KP_SPACE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_AT = SDL_SCANCODE_KP_AT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_EXCLAM = SDL_SCANCODE_KP_EXCLAM or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MEMSTORE = SDL_SCANCODE_KP_MEMSTORE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MEMRECALL = SDL_SCANCODE_KP_MEMRECALL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MEMCLEAR = SDL_SCANCODE_KP_MEMCLEAR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MEMADD = SDL_SCANCODE_KP_MEMADD or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MEMSUBTRACT = SDL_SCANCODE_KP_MEMSUBTRACT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MEMMULTIPLY = SDL_SCANCODE_KP_MEMMULTIPLY or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_MEMDIVIDE = SDL_SCANCODE_KP_MEMDIVIDE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_PLUSMINUS = SDL_SCANCODE_KP_PLUSMINUS or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_CLEAR = SDL_SCANCODE_KP_CLEAR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_CLEARENTRY = SDL_SCANCODE_KP_CLEARENTRY or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_BINARY = SDL_SCANCODE_KP_BINARY or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_OCTAL = SDL_SCANCODE_KP_OCTAL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_DECIMAL = SDL_SCANCODE_KP_DECIMAL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KP_HEXADECIMAL = SDL_SCANCODE_KP_HEXADECIMAL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_LCTRL = SDL_SCANCODE_LCTRL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_LSHIFT = SDL_SCANCODE_LSHIFT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_LALT = SDL_SCANCODE_LALT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_LGUI = SDL_SCANCODE_LGUI or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_RCTRL = SDL_SCANCODE_RCTRL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_RSHIFT = SDL_SCANCODE_RSHIFT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_RALT = SDL_SCANCODE_RALT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_RGUI = SDL_SCANCODE_RGUI or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_MODE = SDL_SCANCODE_MODE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AUDIONEXT = SDL_SCANCODE_AUDIONEXT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AUDIOPREV = SDL_SCANCODE_AUDIOPREV or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AUDIOSTOP = SDL_SCANCODE_AUDIOSTOP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AUDIOPLAY = SDL_SCANCODE_AUDIOPLAY or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AUDIOMUTE = SDL_SCANCODE_AUDIOMUTE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_MEDIASELECT = SDL_SCANCODE_MEDIASELECT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_WWW = SDL_SCANCODE_WWW or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_MAIL = SDL_SCANCODE_MAIL or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_CALCULATOR = SDL_SCANCODE_CALCULATOR or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_COMPUTER = SDL_SCANCODE_COMPUTER or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AC_SEARCH = SDL_SCANCODE_AC_SEARCH or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AC_HOME = SDL_SCANCODE_AC_HOME or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AC_BACK = SDL_SCANCODE_AC_BACK or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AC_FORWARD = SDL_SCANCODE_AC_FORWARD or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AC_STOP = SDL_SCANCODE_AC_STOP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AC_REFRESH = SDL_SCANCODE_AC_REFRESH or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_AC_BOOKMARKS = SDL_SCANCODE_AC_BOOKMARKS or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_BRIGHTNESSDOWN = SDL_SCANCODE_BRIGHTNESSDOWN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_BRIGHTNESSUP = SDL_SCANCODE_BRIGHTNESSUP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_DISPLAYSWITCH = SDL_SCANCODE_DISPLAYSWITCH or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KBDILLUMTOGGLE = SDL_SCANCODE_KBDILLUMTOGGLE or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KBDILLUMDOWN = SDL_SCANCODE_KBDILLUMDOWN or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_KBDILLUMUP = SDL_SCANCODE_KBDILLUMUP or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_EJECT = SDL_SCANCODE_EJECT or SDLK_SCANCODE_MASK;

This item has no description.

SDLK_SLEEP = SDL_SCANCODE_SLEEP or SDLK_SCANCODE_MASK;

This item has no description.

KMOD_NONE = $0000;

** * Enumeration of valid key mods (possibly OR'd together). *

KMOD_LSHIFT = $0001;

This item has no description.

KMOD_RSHIFT = $0002;

This item has no description.

KMOD_LCTRL = $0040;

This item has no description.

KMOD_RCTRL = $0080;

This item has no description.

KMOD_LALT = $0100;

This item has no description.

KMOD_RALT = $0200;

This item has no description.

KMOD_LGUI = $0400;

This item has no description.

KMOD_RGUI = $0800;

This item has no description.

KMOD_NUM = $1000;

This item has no description.

KMOD_CAPS = $2000;

This item has no description.

KMOD_MODE = $4000;

This item has no description.

KMOD_RESERVED = $8000;

This item has no description.

KMOD_CTRL = KMOD_LCTRL or KMOD_RCTRL;

This item has no description.

KMOD_SHIFT = KMOD_LSHIFT or KMOD_RSHIFT;

This item has no description.

KMOD_ALT = KMOD_LALT or KMOD_RALT;

This item has no description.

KMOD_GUI = KMOD_LGUI or KMOD_RGUI;

This item has no description.

SDL_SYSTEM_CURSOR_ARROW = 0;

** * Cursor types for SDL_CreateSystemCursor. *

SDL_SYSTEM_CURSOR_IBEAM = 1;

Arrow

SDL_SYSTEM_CURSOR_WAIT = 2;

I-beam

SDL_SYSTEM_CURSOR_CROSSHAIR = 3;

Wait

SDL_SYSTEM_CURSOR_WAITARROW = 4;

Crosshair

SDL_SYSTEM_CURSOR_SIZENWSE = 5;

Small wait cursor (or Wait if not available)

SDL_SYSTEM_CURSOR_SIZENESW = 6;

Double arrow pointing northwest and southeast

SDL_SYSTEM_CURSOR_SIZEWE = 7;

Double arrow pointing northeast and southwest

SDL_SYSTEM_CURSOR_SIZENS = 8;

Double arrow pointing west and east

SDL_SYSTEM_CURSOR_SIZEALL = 9;

Double arrow pointing north and south

SDL_SYSTEM_CURSOR_NO = 10;

Four pointed arrow pointing north, south, east, and west

SDL_SYSTEM_CURSOR_HAND = 11;

Slashed circle or crossbones

SDL_NUM_SYSTEM_CURSORS = 12;

Hand

SDL_BUTTON_LEFT = 1;

** * Used as a mask when testing buttons in buttonstate. * - Button 1: Left mouse button * - Button 2: Middle mouse button * - Button 3: Right mouse button *

SDL_BUTTON_MIDDLE = 2;

This item has no description.

SDL_BUTTON_RIGHT = 3;

This item has no description.

SDL_BUTTON_X1 = 4;

This item has no description.

SDL_BUTTON_X2 = 5;

This item has no description.

SDL_BUTTON_LMASK = 1 shl ((SDL_BUTTON_LEFT) - 1);

This item has no description.

SDL_BUTTON_MMASK = 1 shl ((SDL_BUTTON_MIDDLE) - 1);

This item has no description.

SDL_BUTTON_RMASK = 1 shl ((SDL_BUTTON_RIGHT) - 1);

This item has no description.

SDL_BUTTON_X1MASK = 1 shl ((SDL_BUTTON_X1) - 1);

This item has no description.

SDL_BUTTON_X2MASK = 1 shl ((SDL_BUTTON_X2) - 1);

This item has no description.

SDL_HAT_CENTERED = $00;

** * Hat positions *

SDL_HAT_UP = $01;

This item has no description.

SDL_HAT_RIGHT = $02;

This item has no description.

SDL_HAT_DOWN = $04;

This item has no description.

SDL_HAT_LEFT = $08;

This item has no description.

SDL_HAT_RIGHTUP = SDL_HAT_RIGHT or SDL_HAT_UP;

This item has no description.

SDL_HAT_RIGHTDOWN = SDL_HAT_RIGHT or SDL_HAT_DOWN;

This item has no description.

SDL_HAT_LEFTUP = SDL_HAT_LEFT or SDL_HAT_UP;

This item has no description.

SDL_HAT_LEFTDOWN = SDL_HAT_LEFT or SDL_HAT_DOWN;

This item has no description.

SDL_CONTROLLER_AXIS_INVALID = -1;

** * The list of axes available from a controller *

SDL_CONTROLLER_AXIS_LEFTX = 0;

This item has no description.

SDL_CONTROLLER_AXIS_LEFTY = 1;

This item has no description.

SDL_CONTROLLER_AXIS_RIGHTX = 2;

This item has no description.

SDL_CONTROLLER_AXIS_RIGHTY = 3;

This item has no description.

SDL_CONTROLLER_AXIS_TRIGGERLEFT = 4;

This item has no description.

SDL_CONTROLLER_AXIS_TRIGGERRIGHT = 5;

This item has no description.

SDL_CONTROLLER_AXIS_MAX = 6;

This item has no description.

SDL_CONTROLLER_BUTTON_INVALID = -1;

** * The list of buttons available from a controller *

SDL_CONTROLLER_BUTTON_A = 0;

This item has no description.

SDL_CONTROLLER_BUTTON_B = 1;

This item has no description.

SDL_CONTROLLER_BUTTON_X = 2;

This item has no description.

SDL_CONTROLLER_BUTTON_Y = 3;

This item has no description.

SDL_CONTROLLER_BUTTON_BACK = 4;

This item has no description.

SDL_CONTROLLER_BUTTON_GUIDE = 5;

This item has no description.

SDL_CONTROLLER_BUTTON_START = 6;

This item has no description.

SDL_CONTROLLER_BUTTON_LEFTSTICK = 7;

This item has no description.

SDL_CONTROLLER_BUTTON_RIGHTSTICK = 8;

This item has no description.

SDL_CONTROLLER_BUTTON_LEFTSHOULDER = 9;

This item has no description.

SDL_CONTROLLER_BUTTON_RIGHTSHOULDER = 10;

This item has no description.

SDL_CONTROLLER_BUTTON_DPAD_UP = 11;

This item has no description.

SDL_CONTROLLER_BUTTON_DPAD_DOWN = 12;

This item has no description.

SDL_CONTROLLER_BUTTON_DPAD_LEFT = 13;

This item has no description.

SDL_CONTROLLER_BUTTON_DPAD_RIGHT = 14;

This item has no description.

SDL_CONTROLLER_BUTTON_MAX = 15;

This item has no description.

SDL_HAPTIC_CONSTANT = (1 shl 0);

** * Constant effect supported. * * Constant haptic effect. * * SDL_HapticCondition *

SDL_HAPTIC_SINE = (1 shl 1);

** * Sine wave effect supported. * * Periodic haptic effect that simulates sine waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SQUARE = (1 shl 2);

** * Square wave effect supported. * * Periodic haptic effect that simulates square waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_TRIANGLE = (1 shl 3);

** * Triangle wave effect supported. * * Periodic haptic effect that simulates triangular waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SAWTOOTHUP = (1 shl 4);

** * Sawtoothup wave effect supported. * * Periodic haptic effect that simulates saw tooth up waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SAWTOOTHDOWN = (1 shl 5);

** * Sawtoothdown wave effect supported. * * Periodic haptic effect that simulates saw tooth down waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_RAMP = (1 shl 6);

** * Ramp effect supported. * * Ramp haptic effect. * * SDL_HapticRamp *

SDL_HAPTIC_SPRING = (1 shl 7);

** * Spring effect supported - uses axes position. * * Condition haptic effect that simulates a spring. Effect is based on the * axes position. * * SDL_HapticCondition *

SDL_HAPTIC_DAMPER = (1 shl 8);

** * Damper effect supported - uses axes velocity. * * Condition haptic effect that simulates dampening. Effect is based on the * axes velocity. * * SDL_HapticCondition *

SDL_HAPTIC_INERTIA = (1 shl 9);

** * Inertia effect supported - uses axes acceleration. * * Condition haptic effect that simulates inertia. Effect is based on the axes * acceleration. * * SDL_HapticCondition *

SDL_HAPTIC_FRICTION = (1 shl 10);

** * Friction effect supported - uses axes movement. * * Condition haptic effect that simulates friction. Effect is based on the * axes movement. * * SDL_HapticCondition *

SDL_HAPTIC_CUSTOM = (1 shl 11);

** * Custom effect is supported. * * User defined custom haptic effect. *

SDL_HAPTIC_GAIN = (1 shl 12);

** * Device can set global gain. * * Device supports setting the global gain. * * SDL_HapticSetGain *

SDL_HAPTIC_AUTOCENTER = (1 shl 13);

** * Device can set autocenter. * * Device supports setting autocenter. * * SDL_HapticSetAutocenter *

SDL_HAPTIC_STATUS = (1 shl 14);

** * Device can be queried for effect status. * * Device can be queried for effect status. * * SDL_HapticGetEffectStatus *

SDL_HAPTIC_PAUSE = (1 shl 15);

** * Device can be paused. * * SDL_HapticPause * SDL_HapticUnpause *

SDL_HAPTIC_POLAR = 0;

** * Uses polar coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_CARTESIAN = 1;

** * Uses cartesian coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_SPHERICAL = 2;

** * Uses spherical coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_INFINITY = 4294967295;

SDL_HAPTIC_INFINITY = 4294967295U;

SDL_TOUCH_MOUSEID = UInt32(-1);

* Used as the device ID for mouse events simulated with touch input *

SDL_FIRSTEVENT = 0;

** * The types of events that can be delivered. *

SDL_COMMONEVENT = 1;

Unused (do not remove) (needed in pascal?)

SDL_QUITEV = $100;

Application events

SDL_APP_TERMINATING = $101;

* These application events have special meaning on iOS, see README.iOS for details *

SDL_APP_LOWMEMORY = $102;

**< The application is being terminated by the OS Called on iOS in applicationWillTerminate() Called on Android in onDestroy() *

SDL_APP_WILLENTERBACKGROUND = $103;

**< The application is low on memory, free memory if possible. Called on iOS in applicationDidReceiveMemoryWarning() Called on Android in onLowMemory() *

SDL_APP_DIDENTERBACKGROUND = $104;

**< The application is about to enter the background Called on iOS in applicationWillResignActive() Called on Android in onPause() *

SDL_APP_WILLENTERFOREGROUND = $105;

**< The application did enter the background and may not get CPU for some time Called on iOS in applicationDidEnterBackground() Called on Android in onPause() *

SDL_APP_DIDENTERFOREGROUND = $106;

**< The application is about to enter the foreground Called on iOS in applicationWillEnterForeground() Called on Android in onResume() *

SDL_WINDOWEVENT = $200;

Window events

SDL_SYSWMEVENT = $201;

Window state change

SDL_KEYDOWN = $300;

Keyboard events

SDL_KEYUP = $301;

Key pressed

SDL_TEXTEDITING = $302;

Key released

SDL_TEXTINPUT = $303;

Keyboard text editing (composition)

SDL_MOUSEMOTION = $400;

Mouse events

SDL_MOUSEBUTTONDOWN = $401;

Mouse moved

SDL_MOUSEBUTTONUP = $402;

Mouse button pressed

SDL_MOUSEWHEEL = $403;

Mouse button released

SDL_JOYAXISMOTION = $600;

Joystick events

SDL_JOYBALLMOTION = $601;

Joystick axis motion

SDL_JOYHATMOTION = $602;

Joystick trackball motion

SDL_JOYBUTTONDOWN = $603;

Joystick hat position change

SDL_JOYBUTTONUP = $604;

Joystick button pressed

SDL_JOYDEVICEADDED = $605;

Joystick button released

SDL_JOYDEVICEREMOVED = $606;

A new joystick has been inserted into the system

SDL_CONTROLLERAXISMOTION = $650;

Game controller events

SDL_CONTROLLERBUTTONDOWN = $651;

Game controller axis motion

SDL_CONTROLLERBUTTONUP = $652;

Game controller button pressed

SDL_CONTROLLERDEVICEADDED = $653;

Game controller button released

SDL_CONTROLLERDEVICEREMOVED = $654;

A new Game controller has been inserted into the system

SDL_CONTROLLERDEVICEREMAPPED = $655;

An opened Game controller has been removed

SDL_FINGERDOWN = $700;

Touch events

SDL_FINGERUP = $701;

This item has no description.

SDL_FINGERMOTION = $702;

This item has no description.

SDL_DOLLARGESTURE = $800;

Gesture events

SDL_DOLLARRECORD = $801;

This item has no description.

SDL_MULTIGESTURE = $802;

This item has no description.

SDL_CLIPBOARDUPDATE = $900;

Clipboard events

SDL_DROPFILE = $1000;

Drag and drop events

SDL_USEREVENT = $8000;

** Events SDL_USEREVENT through SDL_LASTEVENT are for your use, * and should be allocated with SDL_RegisterEvents() *

SDL_LASTEVENT = $FFFF;

** * This last event is only for bounding internal arrays (needed in pascal ??) *

SDL_TEXTEDITINGEVENT_TEXT_SIZE = 32;

This item has no description.

SDL_TEXTINPUTEVENT_TEXT_SIZE = 32;

This item has no description.

SDL_ADDEVENT = 0;

This item has no description.

SDL_PEEKEVENT = 1;

This item has no description.

SDL_GETEVENT = 2;

This item has no description.

SDL_QUERY = -1;

This item has no description.

SDL_IGNORE = 0;

This item has no description.

SDL_DISABLE = 0;

This item has no description.

SDL_ENABLE = 1;

This item has no description.

SDL_INIT_TIMER = $00000001;

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

SDL_INIT_AUDIO = $00000010;

This item has no description.

SDL_INIT_VIDEO = $00000020;

This item has no description.

SDL_INIT_JOYSTICK = $00000200;

This item has no description.

SDL_INIT_HAPTIC = $00001000;

This item has no description.

SDL_INIT_GAMECONTROLLER = $00002000;

This item has no description.

SDL_INIT_NOPARACHUTE = $00100000;

turn on game controller also implicitly does JOYSTICK

SDL_INIT_EVERYTHING = SDL_INIT_TIMER or SDL_INIT_AUDIO or SDL_INIT_VIDEO or SDL_INIT_JOYSTICK or SDL_INIT_HAPTIC or SDL_INIT_GAMECONTROLLER;

Don't catch fatal signals

SDL_HINT_FRAMEBUFFER_ACCELERATION = 'SDL_FRAMEBUFFER_ACCELERATION';

* * \brief A variable controlling how 3D acceleration is used to accelerate the SDL screen surface. * * SDL can try to accelerate the SDL screen surface by using streaming * textures with a 3D rendering engine. This variable controls whether and * how this is done. * * This variable can be set to the following values: * "0" - Disable 3D acceleration * "1" - Enable 3D acceleration, using the default renderer. * "X" - Enable 3D acceleration, using X where X is one of the valid rendering drivers. (e.g. "direct3d", "opengl", etc.) * * By default SDL tries to make a best guess for each platform whether * to use acceleration or not.

SDL_HINT_RENDER_DRIVER = 'SDL_RENDER_DRIVER';

/** * \brief A variable specifying which render driver to use. * * If the application doesn't pick a specific renderer to use, this variable * specifies the name of the preferred renderer. If the preferred renderer * can't be initialized, the normal default renderer is used. * * This variable is case insensitive and can be set to the following values: * "direct3d" * "opengl" * "opengles2" * "opengles" * "software" * * The default varies by platform, but it's the first one in the list that * is available on the current platform. */

SDL_HINT_RENDER_OPENGL_SHADERS = 'SDL_RENDER_OPENGL_SHADERS';

/** * \brief A variable controlling whether the OpenGL render driver uses shaders if they are available. * * This variable can be set to the following values: * "0" - Disable shaders * "1" - Enable shaders * * By default shaders are used if OpenGL supports them. */

SDL_HINT_RENDER_SCALE_QUALITY = 'SDL_RENDER_SCALE_QUALITY';

/** * \brief A variable controlling the scaling quality * * This variable can be set to the following values: * "0" or "nearest" - Nearest pixel sampling * "1" or "linear" - Linear filtering (supported by OpenGL and Direct3D) * "2" or "best" - Currently this is the same as "linear" * * By default nearest pixel sampling is used */

SDL_HINT_RENDER_VSYNC = 'SDL_RENDER_VSYNC';

/** * \brief A variable controlling whether updates to the SDL screen surface should be synchronized with the vertical refresh, to avoid tearing. * * This variable can be set to the following values: * "0" - Disable vsync * "1" - Enable vsync * * By default SDL does not sync screen surface updates with vertical refresh. */

SDL_HINT_VIDEO_X11_XVIDMODE = 'SDL_VIDEO_X11_XVIDMODE';

/** * \brief A variable controlling whether the X11 VidMode extension should be used. * * This variable can be set to the following values: * "0" - Disable XVidMode * "1" - Enable XVidMode * * By default SDL will use XVidMode if it is available. */

SDL_HINT_VIDEO_X11_XINERAMA = 'SDL_VIDEO_X11_XINERAMA';

/** * \brief A variable controlling whether the X11 Xinerama extension should be used. * * This variable can be set to the following values: * "0" - Disable Xinerama * "1" - Enable Xinerama * * By default SDL will use Xinerama if it is available. */

SDL_HINT_VIDEO_X11_XRANDR = 'SDL_VIDEO_X11_XRANDR';

/** * \brief A variable controlling whether the X11 XRandR extension should be used. * * This variable can be set to the following values: * "0" - Disable XRandR * "1" - Enable XRandR * * By default SDL will not use XRandR because of window manager issues. */

SDL_HINT_GRAB_KEYBOARD = 'SDL_GRAB_KEYBOARD';

/** * \brief A variable controlling whether grabbing input grabs the keyboard * * This variable can be set to the following values: * "0" - Grab will affect only the mouse * "1" - Grab will affect mouse and keyboard * * By default SDL will not grab the keyboard so system shortcuts still work. */

SDL_HINT_VIDEO_MINIMIZE_ON_FOCUS_LOSS = 'SDL_VIDEO_MINIMIZE_ON_FOCUS_LOSS';

/** * \brief Minimize your SDL_Window if it loses key focus when in Fullscreen mode. Defaults to true. * */

SDL_HINT_IDLE_TIMER_DISABLED = 'SDL_IOS_IDLE_TIMER_DISABLED';

/** * \brief A variable controlling whether the idle timer is disabled on iOS. * * When an iOS app does not receive touches for some time, the screen is * dimmed automatically. For games where the accelerometer is the only input * this is problematic. This functionality can be disabled by setting this * hint. * * This variable can be set to the following values: * "0" - Enable idle timer * "1" - Disable idle timer */

SDL_HINT_ORIENTATIONS = 'SDL_IOS_ORIENTATIONS';

/** * \brief A variable controlling which orientations are allowed on iOS. * * In some circumstances it is necessary to be able to explicitly control * which UI orientations are allowed. * * This variable is a space delimited list of the following values: * "LandscapeLeft", "LandscapeRight", "Portrait" "PortraitUpsideDown" */

SDL_HINT_XINPUT_ENABLED = 'SDL_XINPUT_ENABLED';

/** * \brief A variable that lets you disable the detection and use of Xinput gamepad devices * * The variable can be set to the following values: * "0" - Disable XInput timer (only uses direct input) * "1" - Enable XInput timer (the default) */

SDL_HINT_GAMECONTROLLERCONFIG = 'SDL_GAMECONTROLLERCONFIG';

/** * \brief A variable that lets you manually hint extra gamecontroller db entries * * The variable should be newline delimited rows of gamecontroller config data, see SDL_gamecontroller.h * * This hint must be set before calling SDL_Init(SDL_INIT_GAMECONTROLLER) * You can update mappings after the system is initialized with SDL_GameControllerMappingForGUID() and SDL_GameControllerAddMapping() */

SDL_HINT_JOYSTICK_ALLOW_BACKGROUND_EVENTS = 'SDL_JOYSTICK_ALLOW_BACKGROUND_EVENTS';

/** * \brief A variable that lets you enable joystick (and gamecontroller) events even when your app is in the background. * * The variable can be set to the following values: * "0" - Disable joystick & gamecontroller input events when the * application is in the background. * "1" - Enable joystick & gamecontroller input events when the * application is in the backgroumd. * * The default value is "0". This hint may be set at any time. */

SDL_HINT_ALLOW_TOPMOST = 'SDL_ALLOW_TOPMOST';

/** * \brief If set to 0 then never set the top most bit on a SDL Window, even if the video mode expects it. * This is a debugging aid for developers and not expected to be used by end users. The default is "1" * * This variable can be set to the following values: * "0" - don't allow topmost * "1" - allow topmost */

SDL_HINT_TIMER_RESOLUTION = 'SDL_TIMER_RESOLUTION';

/** * \brief A variable that controls the timer resolution, in milliseconds. * * The higher resolution the timer, the more frequently the CPU services * timer interrupts, and the more precise delays are, but this takes up * power and CPU time. This hint is only used on Windows 7 and earlier. * * See this blog post for more information: * http://randomascii.wordpress.com/2013/07/08/windows-timer-resolution-megawatts-wasted/ * * If this variable is set to "0", the system timer resolution is not set. * * The default value is "1". This hint may be set at any time. */

SDL_HINT_RENDER_DIRECT3D_THREADSAFE = 'SDL_RENDER_DIRECT3D_THREADSAFE';

/** * \brief A hint that specifies whether the Direct3D device is initialized for thread-safe operations. * * By default the Direct3D device is created with thread-safety disabled. * * This variable can be set to the following values: * "0" - disable thread-safety (faster) * "1" - enable thread-safety (slower) */

SDL_LIL_ENDIAN = 1234;

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_byteorder.h //////////////////////////////////////////////// ///////////////////////////////////////////////////////////////////////////////////////////////////// SDL_byteorder.h constants The two types of endianness

SDL_BIG_ENDIAN = 4321;

This item has no description.

SDL_BYTEORDER = SDL_LIL_ENDIAN;

This item has no description.

SDL_MESSAGEBOX_ERROR = $00000010;

** * SDL_MessageBox flags. If supported will display warning icon, etc. *

SDL_MESSAGEBOX_WARNING = $00000020;

**< error dialog *

SDL_MESSAGEBOX_INFORMATION = $00000040;

**< warning dialog *

SDL_MESSAGEBOX_BUTTON_RETURNKEY_DEFAULT = $00000001;

** * Flags for SDL_MessageBoxButtonData. *

SDL_MESSAGEBOX_BUTTON_ESCAPEKEY_DEFAULT = $00000002;

**< Marks the default button when return is hit *


GLSysHelp v.2.5: SDL.Import: Record TSDL_Version

Record TSDL_Version

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Version = record

Description

This item has no description.

Overview

Fields

Public | major: UInt8;
Public | minor: UInt8;
Public | patch: UInt8;

Description

Fields

Public major: UInt8;

This item has no description.

Public minor: UInt8;

**< major version *

Public patch: UInt8;

**< minor version *


GLSysHelp v.2.5: SDL.Import: Record TSDL_Error

Record TSDL_Error

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Error = record

Description

This item has no description.

Overview

Fields

Public | error: SInt32;
Public | key: array [0..ERR_MAX_STRLEN] of Char;
Public | argc: SInt32;
Public | value_c: Byte;
Public | value_ptr: Pointer;
Public | value_i: SInt32;
Public | value_f: Double;
Public | buf: array [0..ERR_MAX_STRLEN] of Char;

Description

Fields

Public error: SInt32;

* This is a numeric value corresponding to the current error *

Public key: array [0..ERR_MAX_STRLEN] of Char;

* This is a key used to index into a language hashtable containing internationalized versions of the SDL error messages. If the key is not in the hashtable, or no hashtable is available, the key is used directly as an error message format string. *

Public argc: SInt32;

* These are the arguments for the error functions *

Public value_c: Byte;

* What is a character anyway? (UNICODE issues) *

Public value_ptr: Pointer;

This item has no description.

Public value_i: SInt32;

This item has no description.

Public value_f: Double;

This item has no description.

Public buf: array [0..ERR_MAX_STRLEN] of Char;


GLSysHelp v.2.5: SDL.Import: Record TStdio

Record TStdio

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TStdio = record

Description

This item has no description.

Overview

Fields

Public | autoclose: TSDL_Bool;
Public | fp: file;

Description

Fields

Public autoclose: TSDL_Bool;

This item has no description.

Public fp: file;


GLSysHelp v.2.5: SDL.Import: Record TMem

Record TMem

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TMem = record

Description

This item has no description.

Overview

Fields

Public | base: PUInt8;
Public | here: PUInt8;
Public | stop: PUInt8;

Description

Fields

Public base: PUInt8;

This item has no description.

Public here: PUInt8;

This item has no description.

Public stop: PUInt8;


GLSysHelp v.2.5: SDL.Import: Record TUnknown

Record TUnknown

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TUnknown = record

Description

This item has no description.

Overview

Fields

Public data1: Pointer;

Description

Fields

Public data1: Pointer;


GLSysHelp v.2.5: SDL.Import: Record TAndroidIO

Record TAndroidIO

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TAndroidIO = record

Description

This item has no description.

Overview

Fields

Public | fileNameRef: Pointer;
Public | inputStreamRef: Pointer;
Public | readableByteChannelRef: Pointer;
Public | readMethod: Pointer;
Public | assetFileDescriptorRef: Pointer;
Public | position: LongInt;
Public | size: LongInt;
Public | offset: LongInt;
Public | fd: SInt32;

Description

Fields

Public fileNameRef: Pointer;

This item has no description.

Public inputStreamRef: Pointer;

This item has no description.

Public readableByteChannelRef: Pointer;

This item has no description.

Public readMethod: Pointer;

This item has no description.

Public assetFileDescriptorRef: Pointer;

This item has no description.

Public position: LongInt;

This item has no description.

Public size: LongInt;

This item has no description.

Public offset: LongInt;

This item has no description.

Public fd: SInt32;


GLSysHelp v.2.5: SDL.Import: Record TWindowsIOBuffer

Record TWindowsIOBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TWindowsIOBuffer = record

Description

This item has no description.

Overview

Fields

Public | data: Pointer;
Public | size: size_t;
Public | left: size_t;

Description

Fields

Public data: Pointer;

This item has no description.

Public size: size_t;

This item has no description.

Public left: size_t;


GLSysHelp v.2.5: SDL.Import: Record TWindowsIO

Record TWindowsIO

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TWindowsIO = record

Description

This item has no description.

Overview

Fields

Public | append: TSDL_Bool;
Public | h: Pointer;
Public | buffer: TWindowsIOBuffer;

Description

Fields

Public append: TSDL_Bool;

This item has no description.

Public h: Pointer;

This item has no description.

Public buffer: TWindowsIOBuffer;


GLSysHelp v.2.5: SDL.Import: Packed Record TSDL_RWops

Packed Record TSDL_RWops

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_RWops = packed record

Description

This item has no description.

Overview

Fields

Public | size: TSize;
Public | seek: TSeek;
Public | read: TRead;
Public | write: TWrite;
Public | close: TClose;
Public | _type: UInt32;
Public | stdio: TStdio
Public | mem: TMem
Public | unknown: TUnknown
Public | windowsio: TWindowsIO

Description

Fields

Public size: TSize;

This item has no description.

Public seek: TSeek;

This item has no description.

Public read: TRead;

This item has no description.

Public write: TWrite;

This item has no description.

Public close: TClose;

This item has no description.

Public _type: UInt32;

This item has no description.

Public stdio: TStdio

This item has no description.

Public mem: TMem

This item has no description.

Public unknown: TUnknown

This item has no description.

Public windowsio: TWindowsIO


GLSysHelp v.2.5: SDL.Import: Record TSDL_AudioSpec

Record TSDL_AudioSpec

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_AudioSpec = record

Description

This item has no description.

Overview

Fields

Public | freq: Integer;
Public | format: TSDL_AudioFormat;
Public | channels: UInt8;
Public | silence: UInt8;
Public | samples: UInt16;
Public | padding: UInt16;
Public | size: UInt32;
Public | callback: TSDL_AudioCallback;
Public | userdata: Pointer;

Description

Fields

Public freq: Integer;

This item has no description.

Public format: TSDL_AudioFormat;

**< DSP frequency – samples per second *

Public channels: UInt8;

**< Audio data format *

Public silence: UInt8;

**< Number of channels: 1 mono, 2 stereo *

Public samples: UInt16;

**< Audio buffer silence value (calculated) *

Public padding: UInt16;

**< Audio buffer size in samples (power of 2) *

Public size: UInt32;

**< Necessary for some compile environments *

Public callback: TSDL_AudioCallback;

**< Audio buffer size in bytes (calculated) *

Public userdata: Pointer;


GLSysHelp v.2.5: SDL.Import: Record TSDL_AudioCVT

Record TSDL_AudioCVT

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_AudioCVT = record

Description

** * A structure to hold a set of audio conversion filters and buffers. *

Overview

Fields

Public | needed: Integer;
Public | src_format: TSDL_AudioFormat;
Public | dst_format: TSDL_AudioFormat;
Public | rate_incr: Double;
Public | buf: PUInt8;
Public | len: Integer;
Public | len_cvt: Integer;
Public | len_mult: Integer;
Public | len_ratio: Double;
Public | filters: array[0..9] of TSDL_AudioFilter;
Public | filter_index: Integer;

Description

Fields

Public needed: Integer;

This item has no description.

Public src_format: TSDL_AudioFormat;

**< Set to 1 if conversion possible *

Public dst_format: TSDL_AudioFormat;

**< Source audio format *

Public rate_incr: Double;

**< Target audio format *

Public buf: PUInt8;

**< Rate conversion increment *

Public len: Integer;

**< Buffer to hold entire audio data *

Public len_cvt: Integer;

**< Length of original audio buffer *

Public len_mult: Integer;

**< Length of converted audio buffer *

Public len_ratio: Double;

**< buffer must be len*len_mult big *

Public filters: array[0..9] of TSDL_AudioFilter;

**< Given len, final size is len*len_ratio *

Public filter_index: Integer;

**< Filter list *


GLSysHelp v.2.5: SDL.Import: Record TSDL_Thread

Record TSDL_Thread

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Thread = record

Description

This item has no description.

Overview

Fields

Public | threadid: TSDL_ThreadID;
Public | handle: THandle;
Public | status: SInt32;
Public | errbuf: TSDL_Error;
Public | name: PChar;
Public | data: Pointer;

Description

Fields

Public threadid: TSDL_ThreadID;

This item has no description.

Public handle: THandle;

This item has no description.

Public status: SInt32;

This item has no description.

Public errbuf: TSDL_Error;

This item has no description.

Public name: PChar;

This item has no description.

Public data: Pointer;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Mutex

Record TSDL_Mutex

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Mutex = record

Description

***KTI***

Overview

Fields

Public id: THANDLE;

Description

Fields

Public id: THANDLE;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Color

Record TSDL_Color

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Color = record

Description

This item has no description.

Overview

Fields

Public | r: UInt8;
Public | g: UInt8;
Public | b: UInt8;
Public | unused: UInt8;

Description

Fields

Public r: UInt8;

This item has no description.

Public g: UInt8;

This item has no description.

Public b: UInt8;

This item has no description.

Public unused: UInt8;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Palette

Record TSDL_Palette

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Palette = record

Description

This item has no description.

Overview

Fields

Public | ncolors: SInt32;
Public | colors: PSDL_Color;
Public | version: UInt32;
Public | refcount: SInt32;

Description

Fields

Public ncolors: SInt32;

This item has no description.

Public colors: PSDL_Color;

This item has no description.

Public version: UInt32;

This item has no description.

Public refcount: SInt32;


GLSysHelp v.2.5: SDL.Import: Record TSDL_PixelFormat

Record TSDL_PixelFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_PixelFormat = record

Description

This item has no description.

Overview

Fields

Public | format: UInt32;
Public | palette: PSDL_Palette;
Public | BitsPerPixel: UInt8;
Public | BytesPerPixel: UInt8;
Public | padding: array[0..1] of UInt8;
Public | Rmask: UInt32;
Public | Gmask: UInt32;
Public | Bmask: UInt32;
Public | Amask: UInt32;
Public | Rloss: UInt8;
Public | Gloss: UInt8;
Public | Bloss: UInt8;
Public | Aloss: UInt8;
Public | Rshift: UInt8;
Public | Gshift: UInt8;
Public | Bshift: UInt8;
Public | Ashift: UInt8;
Public | refcount: SInt32;
Public | next: PSDL_PixelFormat;

Description

Fields

Public format: UInt32;

This item has no description.

Public palette: PSDL_Palette;

This item has no description.

Public BitsPerPixel: UInt8;

This item has no description.

Public BytesPerPixel: UInt8;

This item has no description.

Public padding: array[0..1] of UInt8;

This item has no description.

Public Rmask: UInt32;

This item has no description.

Public Gmask: UInt32;

This item has no description.

Public Bmask: UInt32;

This item has no description.

Public Amask: UInt32;

This item has no description.

Public Rloss: UInt8;

This item has no description.

Public Gloss: UInt8;

This item has no description.

Public Bloss: UInt8;

This item has no description.

Public Aloss: UInt8;

This item has no description.

Public Rshift: UInt8;

This item has no description.

Public Gshift: UInt8;

This item has no description.

Public Bshift: UInt8;

This item has no description.

Public Ashift: UInt8;

This item has no description.

Public refcount: SInt32;

This item has no description.

Public next: PSDL_PixelFormat;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Point

Record TSDL_Point

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Point = record

Description

This item has no description.

Overview

Fields

Public | x: SInt32;
Public | y: SInt32;

Description

Fields

Public x: SInt32;

This item has no description.

Public y: SInt32;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Rect

Record TSDL_Rect

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Rect = record

Description

This item has no description.

Overview

Fields

Public | x: SInt32;
Public | y: SInt32;
Public | w: SInt32;
Public | h: SInt32;

Description

Fields

Public x: SInt32;

This item has no description.

Public y: SInt32;

This item has no description.

Public w: SInt32;

This item has no description.

Public h: SInt32;


GLSysHelp v.2.5: SDL.Import: Record TSDL_BlitMap

Record TSDL_BlitMap

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_BlitMap = record

Description

This item has no description.

Overview

Fields

Public map: Pointer;

Description

Fields

Public map: Pointer;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Surface

Record TSDL_Surface

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Surface = record

Description

This item has no description.

Overview

Fields

Public | flags: UInt32;
Public | format: PSDL_PixelFormat;
Public | w: SInt32;
Public | h: SInt32;
Public | pitch: SInt32;
Public | pixels: Pointer;
Public | userdata: Pointer;
Public | locked: SInt32;
Public | lock_data: Pointer;
Public | clip_rect: PSDL_Rect;
Public | map: Pointer;
Public | refcount: SInt32;

Description

Fields

Public flags: UInt32;

This item has no description.

Public format: PSDL_PixelFormat;

**< Read-only *

Public w: SInt32;

**< Read-only *

Public h: SInt32;

**< Read-only *

Public pitch: SInt32;

**< Read-only *

Public pixels: Pointer;

**< Read-only *

Public userdata: Pointer;

** Application data associated with the surface *

Public locked: SInt32;

** information needed for surfaces requiring locks *

Public lock_data: Pointer;

**< Read-only *

Public clip_rect: PSDL_Rect;

** clipping information *

Public map: Pointer;

** info for fast blit mapping to other surfaces *

Public refcount: SInt32;

** Reference count – used when freeing surface *


GLSysHelp v.2.5: SDL.Import: Record TSDL_WindowShapeParams

Record TSDL_WindowShapeParams

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_WindowShapeParams = record

Description

** A union containing parameters for shaped windows. *

Overview

Fields

Public | binarizationCutoff: UInt8;
Public | colorKey: TSDL_Color;

Description

Fields

Public binarizationCutoff: UInt8;

** a cutoff alpha value for binarization of the window shape's alpha channel. *

Public colorKey: TSDL_Color;


GLSysHelp v.2.5: SDL.Import: Record TSDL_WindowShapeMode

Record TSDL_WindowShapeMode

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_WindowShapeMode = record

Description

This item has no description.

Overview

Fields

Public | mode: TWindowShapeMode;
Public | parameters: TSDL_WindowShapeParams;

Description

Fields

Public mode: TWindowShapeMode;

** The mode of these window-shape parameters. *

Public parameters: TSDL_WindowShapeParams;

** Window-shape parameters. *


GLSysHelp v.2.5: SDL.Import: Record TSDL_DisplayMode

Record TSDL_DisplayMode

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_DisplayMode = record

Description

This item has no description.

Overview

Fields

Public | format: UInt32;
Public | w: SInt32;
Public | h: SInt32;
Public | refresh_rate: SInt32;
Public | driverdata: Pointer;

Description

Fields

Public format: UInt32;

This item has no description.

Public w: SInt32;

**< pixel format *

Public h: SInt32;

**< width *

Public refresh_rate: SInt32;

**< height *

Public driverdata: Pointer;

**< refresh rate (or zero for unspecified) *


GLSysHelp v.2.5: SDL.Import: Record TSDL_WindowShaper

Record TSDL_WindowShaper

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_WindowShaper = record

Description

This item has no description.

Overview

Fields

Public | window: PSDL_Window;
Public | userx: UInt32;
Public | usery: UInt32;
Public | mode: TSDL_WindowShapeMode;
Public | hasshape: TSDL_Bool;
Public | driverdata: Pointer;

Description

Fields

Public window: PSDL_Window;

* The window associated with the shaper *

Public userx: UInt32;

* The user's specified coordinates for the window, for once we give it a shape. *

Public usery: UInt32;

* The user's specified coordinates for the window, for once we give it a shape. *

Public mode: TSDL_WindowShapeMode;

* The parameters for shape calculation. *

Public hasshape: TSDL_Bool;

* Has this window been assigned a shape? *

Public driverdata: Pointer;


GLSysHelp v.2.5: SDL.Import: Record TSDL_WindowUserData

Record TSDL_WindowUserData

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_WindowUserData = record

Description

This item has no description.

Overview

Fields

Public | name: PChar;
Public | data: Pointer;
Public | next: PSDL_WindowUserData;

Description

Fields

Public name: PChar;

This item has no description.

Public data: Pointer;

This item has no description.

Public next: PSDL_WindowUserData;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Window

Record TSDL_Window

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Window = record

Description

* Define the SDL window structure, corresponding to toplevel windows *

Overview

Fields

Public | magic: Pointer;
Public | id: UInt32;
Public | title: PChar;
Public | fin_UTF8_title: SInt32;
Public | x: SInt32;
Public | y: SInt32;
Public | w: SInt32;
Public | h: SInt32;
Public | min_w: SInt32;
Public | min_h: SInt32;
Public | max_w: SInt32;
Public | max_h: SInt32;
Public | flags: UInt32;
Public | windowed: TSDL_Rect;
Public | fullscreen_mode: TSDL_DisplayMode;
Public | brightness: Float;
Public | gamma: PUInt16;
Public | saved_gamma: PUInt16;
Public | surface: PSDL_Surface;
Public | surface_valid: TSDL_Bool;
Public | shaper: PSDL_WindowShaper;
Public | data: PSDL_WindowUserData;
Public | driverdata: Pointer;
Public | prev: PSDL_Window;
Public | next: PSDL_Window;

Description

Fields

Public magic: Pointer;

This item has no description.

Public id: UInt32;

This item has no description.

Public title: PChar;

This item has no description.

Public fin_UTF8_title: SInt32;

This item has no description.

Public x: SInt32;

esta variable está puesta porque la última versión SDL2.dll devuelve un caracter de más en el title y se desplazan todos los otros campos

Public y: SInt32;

esta variable está puesta porque la última versión SDL2.dll devuelve un caracter de más en el title y se desplazan todos los otros campos

Public w: SInt32;

This item has no description.

Public h: SInt32;

This item has no description.

Public min_w: SInt32;

This item has no description.

Public min_h: SInt32;

This item has no description.

Public max_w: SInt32;

This item has no description.

Public max_h: SInt32;

This item has no description.

Public flags: UInt32;

This item has no description.

Public windowed: TSDL_Rect;

* Stored position and size for windowed mode *

Public fullscreen_mode: TSDL_DisplayMode;

This item has no description.

Public brightness: Float;

This item has no description.

Public gamma: PUInt16;

This item has no description.

Public saved_gamma: PUInt16;

This item has no description.

Public surface: PSDL_Surface;

* (just offset into gamma) *

Public surface_valid: TSDL_Bool;

This item has no description.

Public shaper: PSDL_WindowShaper;

This item has no description.

Public data: PSDL_WindowUserData;

This item has no description.

Public driverdata: Pointer;

This item has no description.

Public prev: PSDL_Window;

This item has no description.

Public next: PSDL_Window;


GLSysHelp v.2.5: SDL.Import: Record TSDL_RendererInfo

Record TSDL_RendererInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_RendererInfo = record

Description

This item has no description.

Overview

Fields

Public | name: PChar;
Public | flags: UInt32;
Public | num_texture_formats: UInt32;
Public | texture_formats: array[0..15] of UInt32;
Public | max_texture_width: SInt32;
Public | max_texture_height: SInt32;

Description

Fields

Public name: PChar;

This item has no description.

Public flags: UInt32;

**< The name of the renderer *

Public num_texture_formats: UInt32;

**< Supported ::SDL_RendererFlags *

Public texture_formats: array[0..15] of UInt32;

**< The number of available texture formats *

Public max_texture_width: SInt32;

**< The available texture formats *

Public max_texture_height: SInt32;

**< The maximimum texture width *


GLSysHelp v.2.5: SDL.Import: Record TSDL_Keysym

Record TSDL_Keysym

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Keysym = record

Description

This item has no description.

Overview

Fields

Public | scancode: TSDL_ScanCode;
Public | sym: TSDL_KeyCode;
Public | _mod: UInt16;
Public | unicode: UInt32;

Description

Fields

Public scancode: TSDL_ScanCode;

This item has no description.

Public sym: TSDL_KeyCode;

SDL physical key code - see SDL_Scancode for details

Public _mod: UInt16;

SDL virtual key code - see SDL_Keycode for details

Public unicode: UInt32;

current key modifiers


GLSysHelp v.2.5: SDL.Import: Record TSDL_JoystickGUID

Record TSDL_JoystickGUID

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_JoystickGUID = record

Description

* A structure that encodes the stable unique id for a joystick device *

Overview

Fields

Public data: array[0..15] of UInt8;

Description

Fields

Public data: array[0..15] of UInt8;


GLSysHelp v.2.5: SDL.Import: Record THat

Record THat

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type THat = record

Description

** * Get the SDL joystick layer binding for this controller button/axis mapping *

Overview

Fields

Public | hat: Integer;
Public | hat_mask: Integer;

Description

Fields

Public hat: Integer;

This item has no description.

Public hat_mask: Integer;


GLSysHelp v.2.5: SDL.Import: Record TSDL_GameControllerButtonBind

Record TSDL_GameControllerButtonBind

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_GameControllerButtonBind = record

Description

This item has no description.

Overview

Fields

Public | bindType: TSDL_GameControllerBindType;
Public | button: Integer;
Public | axis: Integer;
Public | hat: THat;

Description

Fields

Public bindType: TSDL_GameControllerBindType;

This item has no description.

Public button: Integer;

This item has no description.

Public axis: Integer;

This item has no description.

Public hat: THat;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Haptic

Record TSDL_Haptic

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Haptic = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GLSysHelp v.2.5: SDL.Import: Record TSDL_HapticDirection

Record TSDL_HapticDirection

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_HapticDirection = record

Description

** * Structure that represents a haptic direction. * * Directions can be specified by: * - SDL_HAPTIC_POLAR : Specified by polar coordinates. * - SDL_HAPTIC_CARTESIAN : Specified by cartesian coordinates. * - SDL_HAPTIC_SPHERICAL : Specified by spherical coordinates. * * Cardinal directions of the haptic device are relative to the positioning * of the device. North is considered to be away from the user. * * The following diagram represents the cardinal directions: * .–. |__| .——-. |=.| |.—–.| |–| || || | | |'—–'| |__|~')_____(' [ COMPUTER ]

North (0,-1) ˆ | | (1,0) West <—-[ HAPTIC ]—-> East (-1,0) | | v South (0,1)

[ USER ] \|||/ (o o) —ooO-(_)-Ooo—

* * If type is SDL_HAPTIC_POLAR, direction is encoded by hundredths of a * degree starting north and turning clockwise. ::SDL_HAPTIC_POLAR only uses * the first dir parameter. The cardinal directions would be: * - North: 0 (0 degrees) * - East: 9000 (90 degrees) * - South: 18000 (180 degrees) * - West: 27000 (270 degrees) * * If type is SDL_HAPTIC_CARTESIAN, direction is encoded by three positions * (X axis, Y axis and Z axis (with 3 axes)). ::SDL_HAPTIC_CARTESIAN uses * the first three dir parameters. The cardinal directions would be: * - North: 0,-1, 0 * - East: -1, 0, 0 * - South: 0, 1, 0 * - West: 1, 0, 0 * * The Z axis represents the height of the effect if supported, otherwise * it's unused. In cartesian encoding (1, 2) would be the same as (2, 4), you * can use any multiple you want, only the direction matters. * * If type is SDL_HAPTIC_SPHERICAL, direction is encoded by two rotations. * The first two dir parameters are used. The dir parameters are as * follows (all values are in hundredths of degrees): * - Degrees from (1, 0) rotated towards (0, 1). * - Degrees towards (0, 0, 1) (device needs at least 3 axes). * * * Example of force coming from the south with all encodings (force coming * from the south means the user will have to pull the stick to counteract): * * SDL_HapticDirection direction; * * // Cartesian directions * direction.type = SDL_HAPTIC_CARTESIAN; // Using cartesian direction encoding. * direction.dir[0] = 0; // X position * direction.dir[1] = 1; // Y position * // Assuming the device has 2 axes, we don't need to specify third parameter. * * // Polar directions * direction.type = SDL_HAPTIC_POLAR; // We'll be using polar direction encoding. * direction.dir[0] = 18000; // Polar only uses first parameter * * // Spherical coordinates * direction.type = SDL_HAPTIC_SPHERICAL; // Spherical encoding * direction.dir[0] = 9000; // Since we only have two axes we don't need more parameters. * * * SDL_HAPTIC_POLAR * SDL_HAPTIC_CARTESIAN * SDL_HAPTIC_SPHERICAL * SDL_HapticEffect * SDL_HapticNumAxes *

Overview

Fields

Public | _type: UInt8;
Public | dir: array[0..2] of SInt32;

Description

Fields

Public _type: UInt8;

This item has no description.

Public dir: array[0..2] of SInt32;

**< The type of encoding. *


GLSysHelp v.2.5: SDL.Import: Record TSDL_HapticConstant

Record TSDL_HapticConstant

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_HapticConstant = record

Description

** * A structure containing a template for a Constant effect. * * The struct is exclusive to the ::SDL_HAPTIC_CONSTANT effect. * * A constant effect applies a constant force in the specified direction * to the joystick. * * SDL_HAPTIC_CONSTANT * SDL_HapticEffect *

Overview

Fields

Public | _type: UInt16;
Public | direction: TSDL_HapticDirection;
Public | length: UInt32;
Public | delay: UInt16;
Public | button: UInt16;
Public | interval: UInt16;
Public | level: SInt16;
Public | attack_length: UInt16;
Public | attack_level: UInt16;
Public | fade_length: UInt16;
Public | fade_level: UInt16;

Description

Fields

Public _type: UInt16;

* Header *

Public direction: TSDL_HapticDirection;

**< SDL_HAPTIC_CONSTANT *

Public length: UInt32;

* Replay *

Public delay: UInt16;

**< Duration of the effect. *

Public button: UInt16;

* Trigger *

Public interval: UInt16;

**< Button that triggers the effect. *

Public level: SInt16;

* Constant *

Public attack_length: UInt16;

* Envelope *

Public attack_level: UInt16;

**< Duration of the attack. *

Public fade_length: UInt16;

**< Level at the start of the attack. *

Public fade_level: UInt16;

**< Duration of the fade. *


GLSysHelp v.2.5: SDL.Import: Record TSDL_HapticPeriodic

Record TSDL_HapticPeriodic

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_HapticPeriodic = record

Description

** * A structure containing a template for a Periodic effect. * * The struct handles the following effects: * - SDL_HAPTIC_SINE * - SDL_HAPTIC_SQUARE * - SDL_HAPTIC_TRIANGLE * - SDL_HAPTIC_SAWTOOTHUP * - SDL_HAPTIC_SAWTOOTHDOWN * * A periodic effect consists in a wave-shaped effect that repeats itself * over time. The type determines the shape of the wave and the parameters * determine the dimensions of the wave. * * Phase is given by hundredth of a cycle meaning that giving the phase a value * of 9000 will displace it 25% of its period. Here are sample values: * - 0: No phase displacement. * - 9000: Displaced 25% of its period. * - 18000: Displaced 50% of its period. * - 27000: Displaced 75% of its period. * - 36000: Displaced 100% of its period, same as 0, but 0 is preferred. * * Examples: * SDL_HAPTIC_SINE __ __ __ __ / \ / \ / \ / / \__/ \__/ \__/

SDL_HAPTIC_SQUARE __ __ __ __ __ | | | | | | | | | | | |__| |__| |__| |__| |

SDL_HAPTIC_TRIANGLE /\ /\ /\ /\ /\ / \ / \ / \ / \ / / \/ \/ \/ \/

SDL_HAPTIC_SAWTOOTHUP /| /| /| /| /| /| /| / | / | / | / | / | / | / | / |/ |/ |/ |/ |/ |/ |

SDL_HAPTIC_SAWTOOTHDOWN \ |\ |\ |\ |\ |\ |\ | \ | \ | \ | \ | \ | \ | \ | \| \| \| \| \| \| \|

* * SDL_HAPTIC_SINE * SDL_HAPTIC_SQUARE * SDL_HAPTIC_TRIANGLE * SDL_HAPTIC_SAWTOOTHUP * SDL_HAPTIC_SAWTOOTHDOWN * SDL_HapticEffect *

Overview

Fields

Public | _type: UInt16;
Public | direction: TSDL_HapticDirection;
Public | length: UInt32;
Public | delay: UInt16;
Public | button: UInt16;
Public | interval: UInt16;
Public | period: UInt16;
Public | magnitude: SInt16;
Public | offset: SInt16;
Public | phase: UInt16;
Public | attack_length: UInt16;
Public | attack_level: UInt16;
Public | fade_length: UInt16;
Public | fade_level: UInt16;

Description

Fields

Public _type: UInt16;

Header *

Public direction: TSDL_HapticDirection;

**< SDL_HAPTIC_SINE, SDL_HAPTIC_SQUARE, SDL_HAPTIC_TRIANGLE, SDL_HAPTIC_SAWTOOTHUP or SDL_HAPTIC_SAWTOOTHDOWN *

Public length: UInt32;

* Replay *

Public delay: UInt16;

**< Duration of the effect. *

Public button: UInt16;

* Trigger *

Public interval: UInt16;

**< Button that triggers the effect. *

Public period: UInt16;

* Periodic *

Public magnitude: SInt16;

**< Period of the wave. *

Public offset: SInt16;

**< Peak value. *

Public phase: UInt16;

**< Mean value of the wave. *

Public attack_length: UInt16;

* Envelope *

Public attack_level: UInt16;

**< Duration of the attack. *

Public fade_length: UInt16;

**< Level at the start of the attack. *

Public fade_level: UInt16;

**< Duration of the fade. *


GLSysHelp v.2.5: SDL.Import: Record TSDL_HapticCondition

Record TSDL_HapticCondition

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_HapticCondition = record

Description

** * A structure containing a template for a Condition effect. * * The struct handles the following effects: * - SDL_HAPTIC_SPRING: Effect based on axes position. * - SDL_HAPTIC_DAMPER: Effect based on axes velocity. * - SDL_HAPTIC_INERTIA: Effect based on axes acceleration. * - SDL_HAPTIC_FRICTION: Effect based on axes movement. * * Direction is handled by condition internals instead of a direction member. * The condition effect specific members have three parameters. The first * refers to the X axis, the second refers to the Y axis and the third * refers to the Z axis. The right terms refer to the positive side of the * axis and the left terms refer to the negative side of the axis. Please * refer to the ::SDL_HapticDirection diagram for which side is positive and * which is negative. * * SDL_HapticDirection * SDL_HAPTIC_SPRING * SDL_HAPTIC_DAMPER * SDL_HAPTIC_INERTIA * SDL_HAPTIC_FRICTION * SDL_HapticEffect *

Overview

Fields

Public | _type: UInt16;
Public | direction: TSDL_HapticDirection;
Public | length: UInt32;
Public | delay: UInt16;
Public | button: UInt16;
Public | interval: UInt16;
Public | right_sat: array[0..2] of UInt16;
Public | left_sat: array[0..2] of UInt16;
Public | right_coeff: array[0..2] of SInt16;
Public | left_coeff: array[0..2] of SInt16;
Public | deadband: array[0..2] of UInt16;
Public | center: array[0..2] of SInt16;

Description

Fields

Public _type: UInt16;

* Header *

Public direction: TSDL_HapticDirection;

**< SDL_HAPTIC_SPRING, SDL_HAPTIC_DAMPER, SDL_HAPTIC_INERTIA or SDL_HAPTIC_FRICTION *

Public length: UInt32;

* Replay *

Public delay: UInt16;

**< Duration of the effect. *

Public button: UInt16;

* Trigger *

Public interval: UInt16;

**< Button that triggers the effect. *

Public right_sat: array[0..2] of UInt16;

* Condition *

Public left_sat: array[0..2] of UInt16;

**< Level when joystick is to the positive side. *

Public right_coeff: array[0..2] of SInt16;

**< Level when joystick is to the negative side. *

Public left_coeff: array[0..2] of SInt16;

**< How fast to increase the force towards the positive side. *

Public deadband: array[0..2] of UInt16;

**< How fast to increase the force towards the negative side. *

Public center: array[0..2] of SInt16;

**< Size of the dead zone. *


GLSysHelp v.2.5: SDL.Import: Record TSDL_HapticRamp

Record TSDL_HapticRamp

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_HapticRamp = record

Description

** * A structure containing a template for a Ramp effect. * * This struct is exclusively for the ::SDL_HAPTIC_RAMP effect. * * The ramp effect starts at start strength and ends at end strength. * It augments in linear fashion. If you use attack and fade with a ramp * the effects get added to the ramp effect making the effect become * quadratic instead of linear. * * SDL_HAPTIC_RAMP * SDL_HapticEffect *

Overview

Fields

Public | _type: UInt16;
Public | direction: TSDL_HapticDirection;
Public | length: UInt32;
Public | delay: UInt16;
Public | button: UInt16;
Public | interval: UInt16;
Public | start: SInt16;
Public | _end: SInt16;
Public | attack_length: UInt16;
Public | attack_level: UInt16;
Public | fade_length: UInt16;
Public | fade_level: UInt16;

Description

Fields

Public _type: UInt16;

* Header *

Public direction: TSDL_HapticDirection;

**< SDL_HAPTIC_RAMP *

Public length: UInt32;

* Replay *

Public delay: UInt16;

**< Duration of the effect. *

Public button: UInt16;

* Trigger *

Public interval: UInt16;

**< Button that triggers the effect. *

Public start: SInt16;

* Ramp *

Public _end: SInt16;

**< Beginning strength level. *

Public attack_length: UInt16;

* Envelope *

Public attack_level: UInt16;

**< Duration of the attack. *

Public fade_length: UInt16;

**< Level at the start of the attack. *

Public fade_level: UInt16;

**< Duration of the fade. *


GLSysHelp v.2.5: SDL.Import: Record TSDL_HapticCustom

Record TSDL_HapticCustom

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_HapticCustom = record

Description

** * A structure containing a template for the ::SDL_HAPTIC_CUSTOM effect. * * A custom force feedback effect is much like a periodic effect, where the * application can define its exact shape. You will have to allocate the * data yourself. Data should consist of channels * samples Uint16 samples. * * If channels is one, the effect is rotated using the defined direction. * Otherwise it uses the samples in data for the different axes. * * SDL_HAPTIC_CUSTOM * SDL_HapticEffect *

Overview

Fields

Public | _type: UInt16;
Public | direction: TSDL_HapticDirection;
Public | length: UInt32;
Public | delay: UInt16;
Public | button: UInt16;
Public | interval: UInt16;
Public | channels: UInt8;
Public | period: UInt16;
Public | samples: UInt16;
Public | data: PUInt16;
Public | attack_length: UInt16;
Public | attack_level: UInt16;
Public | fade_length: UInt16;
Public | fade_level: UInt16;

Description

Fields

Public _type: UInt16;

* Header *

Public direction: TSDL_HapticDirection;

**< SDL_HAPTIC_CUSTOM *

Public length: UInt32;

* Replay *

Public delay: UInt16;

**< Duration of the effect. *

Public button: UInt16;

* Trigger *

Public interval: UInt16;

**< Button that triggers the effect. *

Public channels: UInt8;

* Custom *

Public period: UInt16;

**< Axes to use, minimum of one. *

Public samples: UInt16;

**< Sample periods. *

Public data: PUInt16;

**< Amount of samples. *

Public attack_length: UInt16;

* Envelope *

Public attack_level: UInt16;

**< Duration of the attack. *

Public fade_length: UInt16;

**< Level at the start of the attack. *

Public fade_level: UInt16;

**< Duration of the fade. *


GLSysHelp v.2.5: SDL.Import: Record TSDL_HapticEffect

Record TSDL_HapticEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_HapticEffect = record

Description

This item has no description.

Overview

Fields

Public | _type: UInt16;
Public | constant: TSDL_HapticConstant;
Public | periodic: TSDL_HapticPeriodic;
Public | condition: TSDL_HapticCondition;
Public | ramp: TSDL_HapticRamp;
Public | custom: TSDL_HapticCustom;

Description

Fields

Public _type: UInt16;

* Common for all force feedback effects *

Public constant: TSDL_HapticConstant;

**< Effect type. *

Public periodic: TSDL_HapticPeriodic;

**< Constant effect. *

Public condition: TSDL_HapticCondition;

**< Periodic effect. *

Public ramp: TSDL_HapticRamp;

**< Condition effect. *

Public custom: TSDL_HapticCustom;

**< Ramp effect. *


GLSysHelp v.2.5: SDL.Import: Record TSDL_Finger

Record TSDL_Finger

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Finger = record

Description

This item has no description.

Overview

Fields

Public | id: TSDL_FingerID;
Public | x: Float;
Public | y: Float;
Public | pressure: Float;

Description

Fields

Public id: TSDL_FingerID;

This item has no description.

Public x: Float;

This item has no description.

Public y: Float;

This item has no description.

Public pressure: Float;


GLSysHelp v.2.5: SDL.Import: Record TSDL_CommonEvent

Record TSDL_CommonEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_CommonEvent = record

Description

** * Fields shared by every event *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;


GLSysHelp v.2.5: SDL.Import: Record TSDL_WindowEvent

Record TSDL_WindowEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_WindowEvent = record

Description

** * Window state change event data (event.window.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | windowID: UInt32;
Public | event: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;
Public | padding3: UInt8;
Public | data1: SInt32;
Public | data2: SInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_WINDOWEVENT

Public windowID: UInt32;

This item has no description.

Public event: UInt8;

The associated window

Public padding1: UInt8;

SDL_WindowEventID

Public padding2: UInt8;

This item has no description.

Public padding3: UInt8;

This item has no description.

Public data1: SInt32;

This item has no description.

Public data2: SInt32;

event dependent data


GLSysHelp v.2.5: SDL.Import: Record TSDL_KeyboardEvent

Record TSDL_KeyboardEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_KeyboardEvent = record

Description

** * Keyboard button event structure (event.key.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | windowID: UInt32;
Public | state: UInt8;
Public | _repeat: UInt8;
Public | padding2: UInt8;
Public | padding3: UInt8;
Public | keysym: TSDL_KeySym;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_KEYDOWN or SDL_KEYUP

Public windowID: UInt32;

This item has no description.

Public state: UInt8;

The window with keyboard focus, if any

Public _repeat: UInt8;

SDL_PRESSED or SDL_RELEASED

Public padding2: UInt8;

Non-zero if this is a key repeat

Public padding3: UInt8;

This item has no description.

Public keysym: TSDL_KeySym;


GLSysHelp v.2.5: SDL.Import: Record TSDL_TextEditingEvent

Record TSDL_TextEditingEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_TextEditingEvent = record

Description

** * Keyboard text editing event structure (event.edit.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | windowID: UInt32;
Public | text: array[0..SDL_TEXTEDITINGEVENT_TEXT_SIZE] of Char;
Public | start: SInt32;
Public | length: SInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_TEXTEDITING

Public windowID: UInt32;

This item has no description.

Public text: array[0..SDL_TEXTEDITINGEVENT_TEXT_SIZE] of Char;

The window with keyboard focus, if any

Public start: SInt32;

The editing text

Public length: SInt32;

The start cursor of selected editing text


GLSysHelp v.2.5: SDL.Import: Record TSDL_TextInputEvent

Record TSDL_TextInputEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_TextInputEvent = record

Description

** * Keyboard text input event structure (event.text.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | windowID: UInt32;
Public | text: array[0..SDL_TEXTINPUTEVENT_TEXT_SIZE] of Char;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_TEXTINPUT

Public windowID: UInt32;

This item has no description.

Public text: array[0..SDL_TEXTINPUTEVENT_TEXT_SIZE] of Char;

The window with keyboard focus, if any


GLSysHelp v.2.5: SDL.Import: Record TSDL_MouseMotionEvent

Record TSDL_MouseMotionEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_MouseMotionEvent = record

Description

** * Mouse motion event structure (event.motion.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | windowID: UInt32;
Public | which: UInt32;
Public | state: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;
Public | padding3: UInt8;
Public | x: SInt32;
Public | y: SInt32;
Public | xrel: SInt32;
Public | yrel: SInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_MOUSEMOTION

Public windowID: UInt32;

This item has no description.

Public which: UInt32;

The window with mouse focus, if any

Public state: UInt8;

The mouse instance id, or SDL_TOUCH_MOUSEID

Public padding1: UInt8;

The current button state

Public padding2: UInt8;

This item has no description.

Public padding3: UInt8;

This item has no description.

Public x: SInt32;

This item has no description.

Public y: SInt32;

X coordinate, relative to window

Public xrel: SInt32;

Y coordinate, relative to window

Public yrel: SInt32;

The relative motion in the X direction


GLSysHelp v.2.5: SDL.Import: Record TSDL_MouseButtonEvent

Record TSDL_MouseButtonEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_MouseButtonEvent = record

Description

** * Mouse button event structure (event.button.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | windowID: UInt32;
Public | which: UInt32;
Public | button: UInt8;
Public | state: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;
Public | x: SInt32;
Public | y: SInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_MOUSEBUTTONDOWN or SDL_MOUSEBUTTONUP

Public windowID: UInt32;

This item has no description.

Public which: UInt32;

The window with mouse focus, if any

Public button: UInt8;

The mouse instance id, or SDL_TOUCH_MOUSEID

Public state: UInt8;

The mouse button index

Public padding1: UInt8;

SDL_PRESSED or SDL_RELEASED

Public padding2: UInt8;

This item has no description.

Public x: SInt32;

This item has no description.

Public y: SInt32;

X coordinate, relative to window


GLSysHelp v.2.5: SDL.Import: Record TSDL_MouseWheelEvent

Record TSDL_MouseWheelEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_MouseWheelEvent = record

Description

** * Mouse wheel event structure (event.wheel.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | windowID: UInt32;
Public | which: UInt32;
Public | x: SInt32;
Public | y: SInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_MOUSEWHEEL

Public windowID: UInt32;

This item has no description.

Public which: UInt32;

The window with mouse focus, if any

Public x: SInt32;

The mouse instance id, or SDL_TOUCH_MOUSEID

Public y: SInt32;

The amount scrolled horizontally


GLSysHelp v.2.5: SDL.Import: Record TSDL_JoyAxisEvent

Record TSDL_JoyAxisEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_JoyAxisEvent = record

Description

** * Joystick axis motion event structure (event.jaxis.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | which: TSDL_JoystickID;
Public | axis: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;
Public | padding3: UInt8;
Public | value: SInt16;
Public | padding4: UInt16;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_JOYAXISMOTION

Public which: TSDL_JoystickID;

This item has no description.

Public axis: UInt8;

The joystick instance id

Public padding1: UInt8;

The joystick axis index

Public padding2: UInt8;

This item has no description.

Public padding3: UInt8;

This item has no description.

Public value: SInt16;

This item has no description.

Public padding4: UInt16;

The axis value (range: -32768 to 32767)


GLSysHelp v.2.5: SDL.Import: Record TSDL_JoyBallEvent

Record TSDL_JoyBallEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_JoyBallEvent = record

Description

** * Joystick trackball motion event structure (event.jball.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | which: TSDL_JoystickID;
Public | ball: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;
Public | padding3: UInt8;
Public | xrel: SInt16;
Public | yrel: SInt16;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_JOYBALLMOTION

Public which: TSDL_JoystickID;

This item has no description.

Public ball: UInt8;

The joystick instance id

Public padding1: UInt8;

The joystick trackball index

Public padding2: UInt8;

This item has no description.

Public padding3: UInt8;

This item has no description.

Public xrel: SInt16;

This item has no description.

Public yrel: SInt16;

The relative motion in the X direction


GLSysHelp v.2.5: SDL.Import: Record TSDL_JoyHatEvent

Record TSDL_JoyHatEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_JoyHatEvent = record

Description

** * Joystick hat position change event structure (event.jhat.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | which: TSDL_JoystickID;
Public | hat: UInt8;
Public | value: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_JOYHATMOTION

Public which: TSDL_JoystickID;

This item has no description.

Public hat: UInt8;

The joystick instance id

Public value: UInt8;

The joystick hat index

Public padding1: UInt8;

* The hat position value. * SDL_HAT_LEFTUP SDL_HAT_UP SDL_HAT_RIGHTUP * SDL_HAT_LEFT SDL_HAT_CENTERED SDL_HAT_RIGHT * SDL_HAT_LEFTDOWN SDL_HAT_DOWN SDL_HAT_RIGHTDOWN * * Note that zero means the POV is centered. *

Public padding2: UInt8;


GLSysHelp v.2.5: SDL.Import: Record TSDL_JoyButtonEvent

Record TSDL_JoyButtonEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_JoyButtonEvent = record

Description

** * Joystick button event structure (event.jbutton.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | which: TSDL_JoystickID;
Public | button: UInt8;
Public | state: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_JOYBUTTONDOWN or SDL_JOYBUTTONUP

Public which: TSDL_JoystickID;

This item has no description.

Public button: UInt8;

The joystick instance id

Public state: UInt8;

The joystick button index

Public padding1: UInt8;

SDL_PRESSED or SDL_RELEASED

Public padding2: UInt8;


GLSysHelp v.2.5: SDL.Import: Record TSDL_JoyDeviceEvent

Record TSDL_JoyDeviceEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_JoyDeviceEvent = record

Description

** * Joystick device event structure (event.jdevice.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | which: SInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_JOYDEVICEADDED or SDL_JOYDEVICEREMOVED

Public which: SInt32;


GLSysHelp v.2.5: SDL.Import: Record TSDL_ControllerAxisEvent

Record TSDL_ControllerAxisEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_ControllerAxisEvent = record

Description

** * Game controller axis motion event structure (event.caxis.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | which: TSDL_JoystickID;
Public | axis: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;
Public | padding3: UInt8;
Public | value: SInt16;
Public | padding4: UInt16;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_CONTROLLERAXISMOTION

Public which: TSDL_JoystickID;

This item has no description.

Public axis: UInt8;

The joystick instance id

Public padding1: UInt8;

The controller axis (SDL_GameControllerAxis)

Public padding2: UInt8;

This item has no description.

Public padding3: UInt8;

This item has no description.

Public value: SInt16;

This item has no description.

Public padding4: UInt16;

The axis value (range: -32768 to 32767)


GLSysHelp v.2.5: SDL.Import: Record TSDL_ControllerButtonEvent

Record TSDL_ControllerButtonEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_ControllerButtonEvent = record

Description

** * Game controller button event structure (event.cbutton.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | which: TSDL_JoystickID;
Public | button: UInt8;
Public | state: UInt8;
Public | padding1: UInt8;
Public | padding2: UInt8;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_CONTROLLERBUTTONDOWN or SDL_CONTROLLERBUTTONUP

Public which: TSDL_JoystickID;

This item has no description.

Public button: UInt8;

The joystick instance id

Public state: UInt8;

The controller button (SDL_GameControllerButton)

Public padding1: UInt8;

SDL_PRESSED or SDL_RELEASED

Public padding2: UInt8;


GLSysHelp v.2.5: SDL.Import: Record TSDL_ControllerDeviceEvent

Record TSDL_ControllerDeviceEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_ControllerDeviceEvent = record

Description

** * Controller device event structure (event.cdevice.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | which: SInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_CONTROLLERDEVICEADDED, SDL_CONTROLLERDEVICEREMOVED, or SDL_CONTROLLERDEVICEREMAPPED

Public which: SInt32;


GLSysHelp v.2.5: SDL.Import: Record TSDL_TouchFingerEvent

Record TSDL_TouchFingerEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_TouchFingerEvent = record

Description

** * Touch finger event structure (event.tfinger.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | touchId: TSDL_TouchID;
Public | fingerId: TSDL_FingerID;
Public | x: Float;
Public | y: Float;
Public | dx: Float;
Public | dy: Float;
Public | pressure: Float;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_FINGERMOTION or SDL_FINGERDOWN or SDL_FINGERUP

Public touchId: TSDL_TouchID;

This item has no description.

Public fingerId: TSDL_FingerID;

The touch device id

Public x: Float;

This item has no description.

Public y: Float;

Normalized in the range 0...1

Public dx: Float;

Normalized in the range 0...1

Public dy: Float;

Normalized in the range 0...1

Public pressure: Float;

Normalized in the range 0...1


GLSysHelp v.2.5: SDL.Import: Record TSDL_MultiGestureEvent

Record TSDL_MultiGestureEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_MultiGestureEvent = record

Description

** * Multiple Finger Gesture Event (event.mgesture.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | touchId: TSDL_TouchID;
Public | dTheta: Float;
Public | dDist: Float;
Public | x: Float;
Public | y: Float;
Public | numFingers: UInt16;
Public | padding: UInt16;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_MULTIGESTURE

Public touchId: TSDL_TouchID;

This item has no description.

Public dTheta: Float;

The touch device index

Public dDist: Float;

This item has no description.

Public x: Float;

This item has no description.

Public y: Float;

This item has no description.

Public numFingers: UInt16;

This item has no description.

Public padding: UInt16;


GLSysHelp v.2.5: SDL.Import: Record TSDL_DollarGestureEvent

Record TSDL_DollarGestureEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_DollarGestureEvent = record

Description

* (event.dgesture.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | touchId: TSDL_TouchID;
Public | gestureId: TSDL_GestureID;
Public | numFingers: UInt32;
Public | error: Float;
Public | x: Float;
Public | y: Float;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_DOLLARGESTURE

Public touchId: TSDL_TouchID;

This item has no description.

Public gestureId: TSDL_GestureID;

The touch device id

Public numFingers: UInt32;

This item has no description.

Public error: Float;

This item has no description.

Public x: Float;

This item has no description.

Public y: Float;

Normalized center of gesture


GLSysHelp v.2.5: SDL.Import: Record TSDL_DropEvent

Record TSDL_DropEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_DropEvent = record

Description

** * An event used to request a file open by the system (event.drop.*) * This event is disabled by default, you can enable it with SDL_EventState() * If you enable this event, you must free the filename in the event. *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | _file: PChar;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_DROPFILE

Public _file: PChar;


GLSysHelp v.2.5: SDL.Import: Record TSDL_QuitEvent

Record TSDL_QuitEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_QuitEvent = record

Description

** * The "quit requested" event *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_QUIT


GLSysHelp v.2.5: SDL.Import: Record TSDL_UserEvent

Record TSDL_UserEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_UserEvent = record

Description

** * A user-defined event type (event.user.*) *

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | windowID: UInt32;
Public | code: SInt32;
Public | data1: Pointer;
Public | data2: Pointer;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_USEREVENT through SDL_NUMEVENTS-1

Public windowID: UInt32;

This item has no description.

Public code: SInt32;

The associated window if any

Public data1: Pointer;

User defined event code

Public data2: Pointer;

User defined data pointer


GLSysHelp v.2.5: SDL.Import: Record TSDL_SysWMmsg

Record TSDL_SysWMmsg

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_SysWMmsg = record

Description

This item has no description.

Overview

Fields

Public | version: TSDL_Version;
Public | h_wnd: HWND;
Public | msg: UInt32;
Public | w_Param: WPARAM;
Public | lParam: LPARAM;

Description

Fields

Public version: TSDL_Version;

This item has no description.

Public h_wnd: HWND;

This item has no description.

Public msg: UInt32;

The window for the message

Public w_Param: WPARAM;

The type of message

Public lParam: LPARAM;

WORD message parameter


GLSysHelp v.2.5: SDL.Import: Record TSDL_SysWMinfo

Record TSDL_SysWMinfo

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_SysWMinfo = record

Description

This item has no description.

Overview

Fields

Public | version: TSDL_Version;
Public | window: HWnd;

Description

Fields

Public version: TSDL_Version;

This item has no description.

Public window: HWnd;


GLSysHelp v.2.5: SDL.Import: Record TSDL_SysWMEvent

Record TSDL_SysWMEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_SysWMEvent = record

Description

This item has no description.

Overview

Fields

Public | type_: UInt32;
Public | timestamp: UInt32;
Public | msg: PSDL_SysWMmsg;

Description

Fields

Public type_: UInt32;

This item has no description.

Public timestamp: UInt32;

SDL_SYSWMEVENT

Public msg: PSDL_SysWMmsg;


GLSysHelp v.2.5: SDL.Import: Record TSDL_Event

Record TSDL_Event

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_Event = record

Description

This item has no description.

Overview

Fields

Public | type_: UInt32
Public | common: TSDL_CommonEvent
Public | window: TSDL_WindowEvent
Public | key: TSDL_KeyboardEvent
Public | edit: TSDL_TextEditingEvent
Public | text: TSDL_TextInputEvent
Public | motion: TSDL_MouseMotionEvent
Public | button: TSDL_MouseButtonEvent
Public | wheel: TSDL_MouseWheelEvent
Public | jaxis: TSDL_JoyAxisEvent
Public | jball: TSDL_JoyBallEvent
Public | jhat: TSDL_JoyHatEvent
Public | jbutton: TSDL_JoyButtonEvent
Public | jdevice: TSDL_JoyDeviceEvent
Public | caxis: TSDL_ControllerAxisEvent
Public | cbutton: TSDL_ControllerButtonEvent
Public | cdevice: TSDL_ControllerDeviceEvent
Public | quit: TSDL_QuitEvent
Public | user: TSDL_UserEvent
Public | syswm: TSDL_SysWMEvent
Public | tfinger: TSDL_TouchFingerEvent
Public | mgesture: TSDL_MultiGestureEvent
Public | dgesture: TSDL_DollarGestureEvent
Public | drop: TSDL_DropEvent

Description

Fields

Public type_: UInt32

This item has no description.

Public common: TSDL_CommonEvent

This item has no description.

Public window: TSDL_WindowEvent

This item has no description.

Public key: TSDL_KeyboardEvent

This item has no description.

Public edit: TSDL_TextEditingEvent

This item has no description.

Public text: TSDL_TextInputEvent

This item has no description.

Public motion: TSDL_MouseMotionEvent

This item has no description.

Public button: TSDL_MouseButtonEvent

This item has no description.

Public wheel: TSDL_MouseWheelEvent

This item has no description.

Public jaxis: TSDL_JoyAxisEvent

This item has no description.

Public jball: TSDL_JoyBallEvent

This item has no description.

Public jhat: TSDL_JoyHatEvent

This item has no description.

Public jbutton: TSDL_JoyButtonEvent

This item has no description.

Public jdevice: TSDL_JoyDeviceEvent

This item has no description.

Public caxis: TSDL_ControllerAxisEvent

This item has no description.

Public cbutton: TSDL_ControllerButtonEvent

This item has no description.

Public cdevice: TSDL_ControllerDeviceEvent

This item has no description.

Public quit: TSDL_QuitEvent

This item has no description.

Public user: TSDL_UserEvent

This item has no description.

Public syswm: TSDL_SysWMEvent

This item has no description.

Public tfinger: TSDL_TouchFingerEvent

This item has no description.

Public mgesture: TSDL_MultiGestureEvent

This item has no description.

Public dgesture: TSDL_DollarGestureEvent

This item has no description.

Public drop: TSDL_DropEvent


GLSysHelp v.2.5: SDL.Import: Record TSDL_MessageBoxButtonData

Record TSDL_MessageBoxButtonData

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_MessageBoxButtonData = record

Description

This item has no description.

Overview

Fields

Public | flags: UInt32;
Public | buttonid: Integer;
Public | text: PChar;

Description

Fields

Public flags: UInt32;

This item has no description.

Public buttonid: Integer;

**< ::SDL_MessageBoxButtonFlags *

Public text: PChar;

**< User defined button id (value returned via SDL_ShowMessageBox) *


GLSysHelp v.2.5: SDL.Import: Record TSDL_MessageBoxColor

Record TSDL_MessageBoxColor

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_MessageBoxColor = record

Description

This item has no description.

Overview

Fields

Public | r: UInt8;
Public | g: UInt8;
Public | b: UInt8;

Description

Fields

Public r: UInt8;

This item has no description.

Public g: UInt8;

This item has no description.

Public b: UInt8;


GLSysHelp v.2.5: SDL.Import: Record TSDL_MessageBoxColorScheme

Record TSDL_MessageBoxColorScheme

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_MessageBoxColorScheme = record

Description

This item has no description.

Overview

Fields

Public colors: array[0..4] of TSDL_MessageBoxColor;

Description

Fields

Public colors: array[0..4] of TSDL_MessageBoxColor;

colors: array[0..SDL_MESSAGEBOX_COLOR_MAX-1] of TSDL_MessageBoxColor;


GLSysHelp v.2.5: SDL.Import: Record TSDL_MessageBoxData

Record TSDL_MessageBoxData

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDL_MessageBoxData = record

Description

This item has no description.

Overview

Fields

Public | flags: UInt32;
Public | window: PSDL_Window;
Public | title: PChar;
Public | _message: PChar;
Public | numbuttons: Integer;
Public | buttons: PSDL_MessageBoxButtonData;
Public | colorScheme: PSDL_MessageBoxColorScheme;

Description

Fields

Public flags: UInt32;

This item has no description.

Public window: PSDL_Window;

**< SDL_MessageBoxFlags *

Public title: PChar;

**< Parent window, can be NULL *

Public _message: PChar;

**< UTF-8 title *

Public numbuttons: Integer;

**< UTF-8 message text *

Public buttons: PSDL_MessageBoxButtonData;

This item has no description.

Public colorScheme: PSDL_MessageBoxColorScheme;


GLSysHelp v.2.5: SDL.Import: Record TSDLPantalla

Record TSDLPantalla

Description
Hierarchy
Fields
Methods
Properties

Unit

SDL.Import

Declaration

type TSDLPantalla = record

Description

This item has no description.

Overview

Fields

Public | Window: PSDL_Window;
Public | Renderer: PSDL_Renderer;
Public | rx: Integer;
Public | ry: Integer;
Public | lw: Integer;
Public | lh: Integer;
Public | sx: Float;
Public | sy: Float;
Public | max_texture_width: SInt32;
Public | max_texture_height: SInt32;
Public | hardware: Boolean;
Public | render_name: String;

Description

Fields

Public Window: PSDL_Window;

This item has no description.

Public Renderer: PSDL_Renderer;

This item has no description.

Public rx: Integer;

This item has no description.

Public ry: Integer;

X donde empieza el render (para los ClipRect y el ratón) expresado en resolución lógica

Public lw: Integer;

Y donde empieza el render (para los ClipRect y el ratón)

Public lh: Integer;

ancho de la ventana en resolución lógica

Public sx: Float;

alto de la ventana en resolución lógica

Public sy: Float;

multiplicador para pasar de resolución lógica a resolución real

Public max_texture_width: SInt32;

multiplicador para pasar de resolución lógica a resolución real

Public max_texture_height: SInt32;

ancho máximo de las texturas

Public hardware: Boolean;

alto máximo de las texturas

Public render_name: String;

indica si usamos aceleración hardware


GLSysHelp v.2.5: Class Hierarchy

Class Hierarchy

  • IGLNotifyAble
    • IGLTextureNotifyAble
  • IInterface
    • IGLInitializable
    • IGLMaterialLibrarySupported
    • IGLPostShader
    • IGLShaderDescription
    • IGnuGettextInstanceWhenNewLanguageListener
    • IShaderParameter
  • IUnknown
    • IAVIEditStream
    • IAVIFile
    • IAVIStream
    • IAVIStreaming
    • IGetFrame
  • TBitmap
    • TDDSImage
    • THDRImage
    • TTGAImage
  • TClassProperty
    • TGLColorProperty
    • TGLCoordinatesProperty
    • TGLImageClassProperty
    • TGLMaterialProperty
    • TGLShaderEditorProperty
    • TGLSoundFileProperty
    • TGLTextureImageProperty
    • TGLTextureProperty
    • TXCollectionProperty
  • TComponentEditor
    • TGLCUDACompilerEditor
    • TGLCUDAEditor
    • TGLGUILayoutEditor
    • TGLReuseableDefaultEditor
      • TGLMaterialLibraryEditor
      • TGLSArchiveManagerEditor
    • TGLSceneEditor
    • TGLSceneViewerEditor
  • TCustomAttribute
    • TDim
  • TCustomControl
    • TGLSMemoAbstractScrollableObject
      • TGLSCustomMemo
        • TGLSMemo
        • TGLSSynHiMemo
  • TEvent
    • TFinishTaskEvent
  • TForm
    • TGLCUDAEditorForm
    • TGLInfoForm
    • TGLLayoutEditorForm
    • TGLLibMaterialPickerForm
    • TGLMaterialEditorForm
    • TGLSceneEditorForm
    • TGLSceneForm
    • TGLShaderUniformEditor
    • TGLSkinEditorForm
    • TGLVectorEditorForm
    • TShaderMemoForm
    • TXCollectionEditorForm
  • TFrame
    • TRColorEditor
    • TRFaceEditor
    • TRMaterialPreview
    • TRTextureEdit
    • TRTrackBarEdit
  • TGLCadenceAbleComponent
    • TGLAbstractMaterialLibrary
      • TGLMaterialLibrary
      • TGLMaterialLibraryEx
    • TGLFireFXManager
    • TGLSoundManager
      • TGLSMBASS
      • TGLSMFMOD
      • TGLSMOpenAL
      • TGLSMWaveOut
    • TGLThorFXManager
  • TGLCoordinatesUpdateAbleComponent
    • TGLBaseSceneObject
      • TCUDACustomFeedBackMesh
        • TCUDAFeedbackMesh
      • TGLAnimatedSprite
      • TGLBaseGuiObject
        • TGLBaseComponent
          • TGLBaseControl
            • TGLBaseFontControl
              • TGLBaseTextControl
                • TGLFocusControl
                  • TGLAdvancedLabel
                  • TGLButton
                  • TGLCustomControl
                  • TGLEdit
                  • TGLPopupMenu
                  • TGLScrollbar
                  • TGLStringGrid
                • TGLForm
                • TGLLabel
            • TGLCheckBox
            • TGLPanel
      • TGLCamera
        • TGLFile3DSCamera
      • TGLCustomAtmosphere
        • TGLAtmosphere
      • TGLCustomConsole
        • TGLConsole
      • TGLCustomSceneObject
        • TGLImmaterialSceneObject
          • TGLCameraInvariantObject
            • TGLDummyCube
            • TGLSkyBox
            • TGLSkyDome
              • TGLEarthSkyDome
          • TGLDirectOpenGL
          • TGLFlatText
            • TGLGizmoExUIFlatText
          • TGLHUDText
            • TGLAbsoluteHUDText
            • TGLResolutionIndependantHUDText
          • TGLImposter
          • TGLLineBase
            • TGLNodedLines
              • TGLLines
                • TGLGizmoExUILines
                • TGLIsolines
            • TGLXYZGrid
          • TGLParticles
          • TGLPoints
            • TGLSwartSwarm
          • TGLProjectedTextures
          • TGLRenderPoint
          • TGLShadowVolume
          • TGLTilePlane
          • TGLTree
        • TGLMotionBlur
        • TGLSceneObject
          • TGLBaseMesh
            • TGLActor
              • TGLCyborg
              • TGLFile3DSActor
            • TGLDodecahedron
            • TGLFreeForm
              • TGLFile3DSFreeForm
              • TGLMeshLines
            • TGLHexahedron
            • TGLIcosahedron
            • TGLOctahedron
            • TGLPortal
            • TGLTetrahedron
          • TGLCapsule
          • TGLCube
            • TGLGizmoPickCube
            • TGLODERagdollCube
          • TGLFrustrum
            • TGLGizmoExUIFrustrum
          • TGLGameMenu
          • TGLHeightField
          • TGLMesh
            • TGLTrail
          • TGLMirror
          • TGLMultiPolygonBase
            • TGLExtrusionSolid
            • TGLMultiPolygon
          • TGLMultiProxy
          • TGLPlane
            • TGLShadowPlane
          • TGLPolygonBase
            • TGLPipe
            • TGLPolygon
              • TGLGizmoExUIPolygon
              • TGLPolyTet
            • TGLRevolutionSolid
          • TGLQuadricObject
            • TGLCylinderBase
              • TGLAnnulus
              • TGLArrowArc
              • TGLArrowLine
                • TGLGizmoExUIArrowLine
              • TGLCone
              • TGLCylinder
            • TGLDisk
              • TGLGizmoExUIDisk
            • TGLSphere
              • TGLGizmoExUISphere
            • TGLSuperellipsoid
          • TGLSLProjectedTextures
          • TGLSpaceText
          • TGLSprite
            • TGLHUDSprite
              • TGLBlur
          • TGLTeapot
          • TGLTerrainRenderer
          • TGLTextureEmitter
          • TGLTorus
            • TGLGizmoExUITorus
            • TGLGizmoPickTorus
          • TGLWaterPlane
      • TGLFBORenderer
      • TGLFeedback
      • TGLLensFlare
      • TGLLightSource
        • TGLFile3DSLight
      • TGLMaterialMultiProxy
      • TGLNaviCube
      • TGLParticleFXRenderer
      • TGLPostEffect
      • TGLPostShaderHolder
      • TGLProxyObject
        • TGLActorProxy
        • TGLColorProxy
        • TGLFreeFormProxy
        • TGLMaterialProxy
      • TGLSceneRootObject
      • TGLSLTextureEmitter
      • TGLTextureLensFlare
      • TGLZShadows
  • TGLCustomCoordinates
    • TGLLightmapBounds
  • TGLInterfacedCollectionItem
    • TGLMaterialMultiProxyMaster
    • TGLTextureSharingShaderMaterial
  • TGLInterfacedPersistent
    • TXCollectionItem
      • TGLBaseBehaviour
        • TGLBehaviour
          • TGLBAcceleration
          • TGLBaseForceFieldEmitter
            • TGLDampingFieldEmitter
            • TGLRadialGravityEmitter
            • TGLUniformGravityEmitter
          • TGLBaseInertia
            • TGLParticleInertia
              • TGLRigidBodyInertia
          • TGLBCollision
          • TGLBFPSMovement
          • TGLBInertia
          • TGLBSoundEmitter
          • TGLDCEDynamic
          • TGLDCEStatic
          • TGLMovement
          • TGLNGDBehaviour
            • TGLNGDDynamic
            • TGLNGDStatic
          • TGLODEBehaviour
            • TGLODECustomCollider
              • TGLODEHeightField
            • TGLODEDynamic
            • TGLODEStatic
        • TGLEffect
          • TGLObjectAfterEffect
          • TGLObjectPostEffect
            • TGLBFireFX
            • TGLBThorFX
            • TGLParticleFXEffect
              • TGLSourcePFXEffect
          • TGLObjectPreEffect
            • TGLBExplosionFX
      • TGLBaseMaterialCollectionItem
        • TGLAbstractTexture
          • TGLFrameBufferAttachment
          • TGLTextureImageEx
        • TGLASMVertexProgram
        • TGLShaderEx
        • TGLTextureCombiner
        • TGLTextureSampler
      • TGLForce
        • TGLHookesSpring
          • TGLHookesString
      • TGLMapCollectionItem
      • TGLNavigatorSmoothChangeItem
        • TGLNavigatorSmoothChangeSingle
        • TGLNavigatorSmoothChangeVector
      • TGLODEElementBase
        • TGLODEElementBox
        • TGLODEElementCapsule
        • TGLODEElementCylinder
        • TGLODEElementPlane
        • TGLODEElementSphere
        • TGLODEElementTriMesh
      • TGLODEJointBase
        • TGLODEJointBall
        • TGLODEJointFixed
        • TGLODEJointHinge
        • TGLODEJointHinge2
        • TGLODEJointSlider
        • TGLODEJointUniversal
      • TGLScriptBase
        • TGLScriptPython
      • TGLSpriteAnimation
      • TGLSpriteAnimFrame
  • TGLPersistentObject
    • TDXMaterial
    • TGLBaseMeshObject
      • TGLMeshMorphTarget
      • TGLMeshObject
        • TBSPMeshObject
        • TGLMorphableMeshObject
          • TGLFile3DSDummyObject
            • TGLFile3DSCameraObject
            • TGLFile3DSMeshObject
            • TGLFile3DSOmniLightObject
              • TGLFile3DSSpotLightObject
          • TGLSectorMeshObject
          • TGLSkeletonMeshObject
        • TMOParametricSurface
    • TGLBaseSpacePartition
      • TGLLeavedSpacePartition
        • TGLSectoredSpacePartition
          • TGLOctreeSpacePartition
          • TGLQuadtreeSpacePartition
    • TGLFaceGroup
      • TFGBezierSurface
      • TFGVertexIndexList
        • TFGBSPNode
        • TFGIndexTexCoordList
        • TFGVertexNormalTexIndexList
          • TFGPolygon
            • TFGPortalPolygon
    • TGLFile3DSAnimationKeyList
    • TGLFile3DSAnimationKeys
      • TGLFile3DSColorAnimationKeys
      • TGLFile3DSLightHotSpotAnimationKeys
      • TGLFile3DSPositionAnimationKeys
      • TGLFile3DSRollAnimationKeys
      • TGLFile3DSRotationAnimationKeys
      • TGLFile3DSScaleAnimationKeys
      • TGLFile3DSSpotLightCutOffAnimationKeys
      • TTGLFile3DSPositionAnimationKeys
    • TGLParticle
      • TGLLineParticle
    • TGLParticleList
    • TGLRagdoll
      • TGLODERagdoll
    • TGLSkeleton
    • TGLSkeletonCollider
      • TGLVerletSkeletonCollider
        • TGLVerletCapsule
        • TGLVerletSphere
      • TSCODEBase
        • TSCODEBox
        • TSCODECCylinder
        • TSCODESphere
    • TGLSkeletonFrame
    • TGLSpacePartitionLeaf
      • TGLBaseVerletNode
        • TGLVerletNode
          • TGLMeshObjectVerletNode
      • TGLSceneObj
      • TGLSpacePartitionLeafS
      • TGLVerletEdge
    • TGLTiledArea
    • TGLTiledAreaRow
  • TGLPersistentObjectList
    • TGLArchiveFileFormatsList
    • TGLCyborgThinksList
    • TGLFaceGroups
    • TGLMeshMorphTargetList
    • TGLMeshObjectList
      • TGLPortalMeshObjectList
    • TGLPickList
    • TGLPolygonList
    • TGLRagdolBoneList
      • TGLRagdolBone
        • TGLODERagdollBone
    • TGLRasterFileFormatsList
    • TGLSkeletonBoneList
      • TGLSkeletonBone
      • TGLSkeletonRootBoneList
    • TGLSkeletonColliderList
    • TGLSkeletonFrameList
    • TGLSpacePartitionLeafList
    • TGLVectorFileFormatsList
  • TGLUpdateAbleComponent
    • TGLCustomBitmapFont
      • TGLBitmapFont
      • TGLWindowsBitmapFont
    • TGLCustomCadencedComponent
      • TGLCadencedComponent
        • TGLParticleFXManager
          • TGLDynamicPFXManager
            • TGLLifeColoredPFXManager
              • TGLBaseSpritePFXManager
                • TGLCustomSpritePFXManager
                • TGLPerlinPFXManager
                • TGLPointLightPFXManager
              • TGLCustomPFXManager
              • TGLLinePFXManager
              • TGLPolygonPFXManager
    • TGLGuiLayout
    • TGLImposterBuilder
      • TGLDynamicImposterBuilder
      • TGLStaticImposterBuilder
    • TGLScene
    • TGLShader
      • TCustomCgShader
        • TCadencableCustomCgShader
          • TCgCustomBombShader
            • TCgBombShader
        • TCgShader
        • TGLCustomCGPostTransformationShader
          • TGLCGPostTransformationShader
      • TGLBumpShader
      • TGLCelShader
      • TGLCustomShader
        • TGLCustomAsmShader
          • TGLAsmShader
          • TGLPhongShader
        • TGLCustomGLSLShader
          • TGLBaseCustomGLSLBumpShader
            • TGLBaseCustomGLSLBumpShaderMT
              • TGLCustomGLSLBumpShaderAM
                • TGLSLBumpShaderAM
              • TGLCustomGLSLBumpShaderMT
                • TGLSLBumpShaderMT
              • TGLCustomGLSLMLBumpShaderMT
                • TGLSLMLBumpShaderMT
            • TGLCustomGLSLBumpShader
              • TGLSLBumpShader
            • TGLCustomGLSLMLBumpShader
              • TGLSLMLBumpShader
          • TGLBaseCustomGLSLDiffuseSpecular
            • TGLBaseGLSLDiffuseSpecularShaderMT
              • TGLCustomGLSLDiffuseSpecularShaderMT
                • TGLSLDiffuseSpecularShaderMT
              • TGLCustomGLSLMLDiffuseSpecularShaderMT
                • TGLSLMLDiffuseSpecularShaderMT
            • TGLCustomGLSLDiffuseSpecularShader
              • TGLSLDiffuseSpecularShader
            • TGLCustomGLSLMLDiffuseSpecularShader
              • TGLSLMLDiffuseSpecularShader
          • TGLCustomGLSLFurShader
            • TGLSLFurShader
          • TGLCustomGLSLGlassShader
            • TGLSLGlassShader
          • TGLCustomGLSLIvoryShader
            • TGLSLIvoryShader
          • TGLCustomGLSLPostBlurShader
            • TGLSLPostBlurShader
          • TGLCustomGLSLPostDreamVisionShader
            • TGLSLPostDreamVisionShader
          • TGLCustomGLSLPostFrostShader
            • TGLSLPostFrostShader
          • TGLCustomGLSLPostNightVisionShader
            • TGLSLPostNightVisionShader
          • TGLCustomGLSLPostPixelateShader
            • TGLSLPostPixelateShader
          • TGLCustomGLSLPostPosterizeShader
            • TGLSLPostPosterizeShader
          • TGLCustomGLSLPostThermalVisionShader
            • TGLSLPostThermalVisionShader
          • TGLCustomGLSLPostTroubleShader
            • TGLSLPostTroubleShader
          • TGLCustomGLSLSemShader
            • TGLSLSemShader
          • TGLCustomGLSLSimpleErosionShader
            • TGLSLSimpleErosionShader
          • TGLCustomGLSLSimpleGoochShader
            • TGLSLSimpleGoochShader
          • TGLCustomGLSLSimpleLatticeShader
            • TGLCustomGLSLLatticeShader
              • TGLSLLatticeShader
            • TGLSLSimpleLatticeShader
          • TGLCustomGLSLToonShader
            • TGLSLToonShader
          • TGLCustomGLSLVertexDisplacementShader
            • TGLSLVertexDisplacementShader
          • TGLSLShader
      • TGLCustomShaderCombiner
        • TGLShaderCombiner
      • TGLHiddenLineShader
      • TGLMultiMaterialShader
      • TGLOutlineShader
      • TGLShaderF
      • TGLShaderG
      • TGLShaderV
      • TGLTexCombineShader
      • TGLTextureSharingShader
      • TGLUserShader
    • TGLTimeEventsMGR
  • TGLUpdateAbleObject
    • TCgProgram
      • TCgFragmentProgram
      • TCgVertexProgram
    • TCUDADimensions
    • TGLAbstractShaderUniform
      • TGLShaderUniform
        • TGLShaderUniformDSA
        • TGLShaderUniformTexture
    • TGLBlendingParameters
    • TGLDamping
    • TGLDataFile
      • TGLBaseArchive
        • TPAKArchive
        • TZLibArchive
      • TGLBaseImage
        • TGLBMPImage
        • TGLDDSImage
        • TGLHDRImage
        • TGLImage
        • TGLJPEGImage
        • TGLPGMImage
        • TGLPNGImage
        • TGLTGAImage
      • TGLSoundFile
        • TGLMP3File
        • TGLWAVFile
      • TGLVectorFile
        • TGL3DSVectorFile
        • TGLASEVectorFile
        • TGLAVectorFile
        • TGLB3DVectorFile
        • TGLDELVectorFile
        • TGLDXFVectorFile
        • TGLglTFVectorFile
        • TGLGRDVectorFile
        • TGLGTSVectorFile
        • TGLIDTFVectorFile
          • TGLU3DVectorFile
        • TGLLMTSVectorFile
        • TGLLWOVectorFile
        • TGLMD2VectorFile
        • TGLMD3VectorFile
        • TGLMD5VectorFile
        • TGLMDCVectorFile
        • TGLMS3DVectorFile
        • TGLMVectorFile
        • TGLNMFVectorFile
        • TGLNurbsVectorFile
        • TGLOBJVectorFile
        • TGLOCTGLVectorFile
        • TGLPLYVectorFile
        • TGLQ3BSPVectorFile
        • TGLSMDVectorFile
        • TGLSMVectorFile
        • TGLSTLVectorFile
        • TGLTINVectorFile
        • TGLVORVectorFile
        • TGLVRMLVectorFile
        • TGLXVectorFile
    • TGLDepthProperties
    • TGLFaceProperties
    • TGLFlareGradient
    • TGLFogEnvironment
    • TGLHeightData
    • TGLInertiaTensor
    • TGLLibMaterialProperty
      • TGLBaseShaderModel
        • TGLShaderModel3
        • TGLShaderModel4
        • TGLShaderModel5
      • TGLFixedFunctionProperties
      • TGLMultitexturingProperties
      • TGLTextureProperties
    • TGLLineSettings
    • TGLMaterial
    • TGLPointParameters
    • TGLSamplingScale
    • TGLSceneBuffer
    • TGLTexture
    • TGLTextureImage
      • TGLBlankImage
        • TGLDynamicTextureImage
      • TGLCompositeImage
      • TGLCubeMapImage
      • TGLMultisampleImage
      • TGLPictureImage
        • TGLPersistentImage
        • TGLPicFileImage
      • TGLProcTextureNoise
    • TGLTextureSwizzling
    • TGLVertexList
  • TGNotifyCollection
    • TGLContours
  • TObject
    • CUDAContextManager
    • Exception
      • EDDSException
      • EFilerException
      • EGLAtmosphereException
      • EGLCameraController
      • EGLConsoleException
      • EGLContext
        • EGLShader
      • EGLFile3DS
      • EGLImageUtils
      • EGLMotionBlurException
      • EGLOBJFileError
      • EGLPostShaderHolderException
      • EGLProxyException
      • EGLROAMException
      • EGLShaderException
        • ECgShaderException
          • ECgBombShaderException
        • EGLCustomShaderException
          • EGLSLShaderException
            • EGLSLBumpShaderException
            • EGLSLDiffuseSpecularShaderException
      • EGLUtilsException
      • EGnuGettext
        • EGGAnsi2WideConvError
        • EGGComponentError
        • EGGIOError
        • EGGProgrammingError
      • EInvalidArchiveFile
      • EInvalidRasterFile
      • EInvalidVectorFile
      • EOpenGLError
      • EPasJSONMergeError
      • EPasJSONSyntaxError
      • EPBuffer
      • ESDLError
      • ETexture
      • ETextureCombinerError
      • ETGAException
      • EZBufferException
    • GCUDAHostElementAccess
    • GRedBlackTree
    • TB3DMaterial
    • TB3DNode
    • TB3DTexture
    • TBoneMatrixObj
    • TBSPClusterVisibility
    • TCgParameter
    • TCubicSpline
    • TCUDAContext
    • TCUDAModuleInfo
    • TDESolver
      • TDESolverExplicit
        • TDESolverEuler
        • TDESolverRungeKutta4
      • TDESolverImplicit
        • TDESolverVerlet
    • TDomain
    • TDXFile
    • TECPlane
    • TExecutable
    • TFile3DS
    • TFileB3D
    • TFileGLA
    • TFileGLM
    • TFileMD2
    • TFileMD3
    • TFileNMF
    • TGDelaunay2D
    • TGLAbstractMemoObject
      • TGLSMemoScrollBar
    • TGLArchiveFileFormat
    • TGLArray
    • TGLASEFace
    • TGLASEFaceList
    • TGLASEMaterial
    • TGLASEMaterialList
    • TGLASEMeshObject
    • TGLBaseConnectivity
      • TGLBaseMeshConnectivity
      • TGLConnectivity
        • TGLFaceGroupConnectivity
    • TGLBaseJoint
      • TGLJoint
        • TGLBallAndSocketJoint
        • TGLPrismaticJoint
        • TGLRevoluteJoint
    • TGLBaseLink
      • TGLLink
        • TGLType1Link
        • TGLType2Link
        • TGLType3Link
        • TGLType4Link
        • TGLType5Link
        • TGLType6Link
        • TGLType7Link
        • TGLType8Link
    • TGLBasePerlinOctav
      • TGL2DPerlinOctav
    • TGLBaseSelectTechnique
      • TGLSelectRenderModeTechnique
    • TGLBuffer
      • TGLBufferI
      • TGLBufferU
      • TGLBufferV
    • TGLCameraJob
      • TGLMoveToPosJob
      • TGLOrbitToPosAdvJob
        • TGLSmoothOrbitToPosAdvJob
      • TGLOrbitToPosJob
        • TGLSmoothOrbitToPos
      • TGLZoomToDistanceJob
    • TGLCanvas
    • TGLCollisionState
    • TGLContext
      • TGLScreenControlingContext
        • TSDLContext
      • TGLWindowsContext
    • TGLContextHandle
      • TGLARBProgramHandle
        • TGLARBFragmentProgramHandle
        • TGLARBGeometryProgramHandle
        • TGLARBVertexProgramHandle
      • TGLBufferObjectHandle
        • TGLPackPBOHandle
        • TGLTextureBufferHandle
        • TGLTransformFeedbackBufferHandle
        • TGLUniformBufferHandle
        • TGLUnpackPBOHandle
        • TGLVBOHandle
          • TGLVBOArrayBufferHandle
          • TGLVBOElementArrayHandle
      • TGLFramebufferHandle
      • TGLListHandle
      • TGLQueryHandle
        • TGLBooleanOcclusionQueryHandle
        • TGLOcclusionQueryHandle
        • TGLPrimitiveQueryHandle
        • TGLTimerQueryHandle
      • TGLRenderbufferHandle
      • TGLSamplerHandle
      • TGLSLHandle
        • TGLProgramHandle
        • TGLShaderHandle
          • TGLFragmentShaderHandle
          • TGLGeometryShaderHandle
          • TGLTessControlShaderHandle
          • TGLTessEvaluationShaderHandle
          • TGLVertexShaderHandle
      • TGLTextureHandle
      • TGLVertexArrayHandle
      • TGLVirtualHandle
        • TGLVirtualHandleTransf
    • TGLContextManager
    • TGLCustomShaderParameter
      • TGLAsmShaderParameter
      • TGLSLShaderParameter
    • TGLCyborgManager
    • TGLEdge
    • TGLExtensionsAndEntryPoints
    • TGLFace
    • TGLFaceExtractor
      • TGLEdgeDetector
    • TGLFrameBuffer
    • TGLHeightTileFile
    • TGLIsoline
    • TGLIsoSurfaceExtractor
    • TGLMarchingCube
    • TGLMultitextureCoordinator
    • TGLOctree
    • TGLODEContactPoint
    • TGLODERagdollWorld
    • TGLOpenGL
    • TGLPerlin3DNoise
    • TGLProgram
    • TGLRagdolJoint
      • TGLODERagdollDummyJoint
      • TGLODERagdollHingeJoint
        • TGLODERagdollUniversalJoint
    • TGLRasterFileFormat
    • TGLRenderbuffer
      • TGLDepthRBO
      • TGLStencilRBO
    • TGLROAMPatch
    • TGLSectorNode
      • TSPOctreeNode
        • TSPQuadtreeNode
    • TGLSilhouette
    • TGLSMemoGutter
    • TGLSMemoUndo
      • TGLSMemoDelCharUndo
      • TGLSMEmoDelLineUndo
      • TGLSMemoInsCharUndo
      • TGLSMemoPasteUndo
      • TGLSMemoSelUndo
        • TGLSMemoDeleteBufUndo
    • TGLStateCache
    • TGLTextureImageEditor
      • TGLBlankTIE
      • TGLPersistentTIE
      • TGLPicFileTIE
      • TGLProcTextureNoiseTIE
    • TGLTreeBranch
    • TGLTreeBranches
    • TGLTreeBranchNoise
    • TGLTreeLeaves
    • TGLVectorFileFormat
    • TGLVerletConstraint
      • TGLVerletDualConstraint
        • TGLVerletSlider
        • TGLVerletStick
      • TGLVerletGlobalConstraint
        • TGLVerletGlobalFrictionConstraint
          • TGLVerletFrictionCylinder
          • TGLVerletGlobalFrictionConstraintSP
            • TGLVerletFloor
              • TGLVerletHeightField
            • TGLVerletGlobalFrictionConstraintBox
              • TGLVerletFrictionCube
            • TGLVerletGlobalFrictionConstraintSphere
              • TGLVerletFrictionCapsule
              • TGLVerletFrictionSphere
      • TGLVerletGroupConstraint
        • TGLVerletRigidBody
    • TGLVerletForce
      • TGLVerletDualForce
        • TGLVerletSpring
      • TGLVerletGlobalForce
        • TGLVerletAirResistance
        • TGLVerletGravity
      • TGLVerletGroupForce
    • TGLVerletHair
    • TGLVerletWorld
    • TGnuGettextInstance
    • TgTransformation
    • TImposter
      • TStaticImposter
    • TKeyFramer
    • TLineProp
    • TList
      • TBodyList
      • TDXNode
        • TDXFrame
        • TDXMaterialList
        • TDXMesh
      • TFontManager
      • TGeomList
      • TGLCollisionStates
      • TGLEdgeList
      • TGLFaceList
      • TGLInitializableObjectList
      • TGLNGDBehaviourList
      • TGLSMemoUndoList
      • TGLSoundFileFormatsList
      • TGLVectorPool
      • TGLVerletConstraintList
      • TGLVerletEdgeList
      • TGLVerletForceList
      • TGLVerletNodeList
      • TLWChunkList
      • TMS3DCommentList
      • TStyleList
      • TVertexWeightList
    • TLWContentDir
    • TLWObjectFile
    • TMaterialList
    • TMD3TagList
    • TMoFile
    • TMS3DGroup
    • TNewtonRagdoll
    • TObjectList
      • TGLCameraJobList
    • TOCTFile
    • TPasJSON
    • TPasJSONItem
      • TPasJSONItemArray
      • TPasJSONItemBoolean
      • TPasJSONItemNull
      • TPasJSONItemNumber
      • TPasJSONItemObject
      • TPasJSONItemString
    • TPasJSONItemObjectProperty
    • TPersistent
      • TCharStyle
      • TCollection
        • TGLActorAnimations
        • TGLBitmapFontRanges
        • TGLConsoleCommandList
        • TGLCyborgThinks
        • TGLEParticleMasks
        • TGLSkyDomeBands
        • TGLSkyDomeStars
        • TGLSLTextureEmitters
        • TGLSoundSamples
        • TGLSoundSources
        • TGLTextureEmitters
        • TGLTextureEx
        • TOwnedCollection
          • TGLAbstractLibMaterials
            • TGLLibMaterials
            • TGLLibMaterialsEx
          • TGLGizmoExActionHistoryCollection
          • TGLGizmoExObjectCollection
          • TGLGizmoUndoCollection
          • TGLGuiComponentList
          • TGLGuiElementList
          • TGLLibArchives
          • TGLLineCollection
          • TGLMaterialLibraryItems
          • TGLMaterialMultiProxyMasters
          • TGLMovementPaths
          • TGLMultiProxyMasters
          • TGLNodes
            • TGLContourNodes
            • TGLLineNodes
            • TGLLinesNodes
              • TGLPipeNodes
          • TGLPathNodes
          • TGLPostShaderCollection
          • TGLShaderItems
          • TGLShadowVolumeCasters
          • TGLSimpleNavigationKeyCombinations
          • TGLStaticImposterBuilderCoronas
          • TGLTextureSharingShaderMaterials
          • TGLVertexAttributes
          • TPFXLifeColors
        • TTimeEvents
      • TCollectionItem
        • TGLAbstractLibMaterial
          • TGLLibMaterial
          • TGLLibMaterialEx
        • TGLActorAnimation
        • TGLBaseSoundSource
          • TGLSoundSource
        • TGLBitmapFontRange
        • TGLConsoleCommand
        • TGLContour
        • TGLEParticleMask
        • TGLGizmoExActionHistoryItem
        • TGLGizmoExObjectItem
        • TGLGizmoUndoItem
        • TGLGuiComponent
        • TGLGuiElement
        • TGLLibArchive
        • TGLLineItem
        • TGLMaterialLibraryItem
        • TGLMovementPath
        • TGLMultiProxyMaster
        • TGLNGDJoint
        • TGLNGDSurfaceItem
        • TGLNGDSurfacePair
        • TGLNode
          • TGLLineNode
          • TGLLinesNode
          • TGLPipeNode
        • TGLPathNode
        • TGLPostShaderCollectionItem
        • TGLShaderItem
        • TGLShadowVolumeCaster
          • TGLShadowVolumeLight
          • TGLShadowVolumeOccluder
        • TGLSimpleNavigationKeyCombination
        • TGLSkyDomeBand
        • TGLSkyDomeStar
        • TGLSLTextureEmitterItem
        • TGLSoundSample
        • TGLStaticImposterBuilderCorona
        • TGLTextureEmitterItem
        • TGLTextureExItem
        • TGLVertexAttribute
        • TPFXLifeColor
        • TTimeEvent
      • TComponent
        • TCUDAHandlesMaster
          • TCUDAComponent
            • TCUDAFFTPlan
            • TCUDAFunction
            • TCUDAGraphicResource
              • TCUDAGeometryResource
              • TCUDAImageResource
            • TCUDAMemData
            • TCUDAModule
            • TCUDATexture
            • TCUDAUniform
              • TCUDAConstant
              • TCUDAFuncParam
            • TGLCUDA
        • TGLApplicationFileIO
        • TGLAsyncTimer
        • TGLAVIRecorder
        • TGLBaseAnimationControler
          • TGLAnimationControler
        • TGLBasePerlin
          • TGL1DPerlin
          • TGL2DPerlin
        • TGLCadencer
        • TGLCameraController
        • TGLCollisionManager
        • TGLCUDACompiler
        • TGLCUDADevice
        • TGLDCEManager
        • TGLEParticleMasksManager
        • TGLFPSMovementManager
        • TGLGizmo
        • TGLGizmoEx
        • TGLHeightDataSource
          • TGLBaseRandomHDS
            • TGLCustomRandomHDS
              • TGLFractalHDS
            • TGLTiledRndLandscape
              • TGLFractalArchipelago
          • TGLBitmapHDS
          • TGLCustomHDS
          • TGLHeightDataSourceFilter
            • TGLAsyncHDS
            • TGLBumpmapHDS
            • TGLShadowHDS
          • TGLHeightTileFileHDS
          • TGLPerlinHDS
          • TGLTerrainBaseHDS
          • TGLTexturedHDS
        • TGLJoystick
        • TGLMaterialScripter
        • TGLNavigator
          • TGLSmoothNavigator
        • TGLNGDManager
        • TGLNonVisualViewer
          • TGLFullScreenViewer
          • TGLMemoryViewer
          • TSDLViewer
        • TGLObjectManager
        • TGLODEJointList
        • TGLODEManager
        • TGLPhysManager
        • TGLSArchiveManager
        • TGLScreenSaver
        • TGLScriptLibrary
        • TGLSimpleNavigation
        • TGLSLogger
        • TGLSmoothUserInterface
        • TGLSoundLibrary
        • TGLUserInterface
        • TGLVfsPAK
        • TSDLWindow
      • TCUDADevice
      • TGLConsoleControls
      • TGLDisplayOptions
      • TGLFullScreenVideoMode
      • TGLGizmoRayCastHitData
      • TGLNavigatorAbstractParameters
        • TGLNavigatorAdjustDistanceParameters
        • TGLNavigatorAdjustDistanceParametersEx
      • TGLNavigatorGeneralParameters
      • TGLNavigatorInertiaParameters
      • TGLNavigatorMoveAroundParameters
      • TGLNGDDebugOption
      • TGLNGDJointKinematicController
      • TGLNGDJointPivot
        • TGLNGDJointBallAndSocket
        • TGLNGDJointPin
          • TGLNGDJointHinge
          • TGLNGDJointPin2
          • TGLNGDJointSlider
      • TGLODECollisionSurface
      • TGLODEJointParams
      • TGLShaderProgram
        • TGLFragmentProgram
        • TGLGeometryProgram
        • TGLVertexProgram
      • TGLSoundSampling
      • TGLSpriteAnimMargins
      • TGLTextAdjust
      • TGLzBuffer
      • TLogSession
      • TLWChunk
        • TLWParentChunk
          • TLWClip
          • TLWLayr
          • TLWPnts
          • TLWPols
          • TLWSurf
        • TLWPTag
        • TLWSubChunk
        • TLWTags
        • TLWVMap
      • TStrings
        • TStringList
          • TGLConsoleStringList
          • TGLMTLFile
          • TGLSMemoStringList
          • TGLSMemoStrings
      • TXCollection
        • TGLBehaviours
        • TGLEffects
        • TGLForces
        • TGLMapCollection
        • TGLMatLibComponents
        • TGLNavigatorSmoothChangeItems
        • TGLODEElements
        • TGLODEJoints
        • TGLScripts
        • TGLSpriteAnimationList
        • TGLSpriteAnimFrameList
    • TPickRecord
    • TQ3BSP
    • GRedBlackTree.TRBNode
    • TThread
      • TGLHeightDataThread
        • TGLAsyncHDThread
        • TGLPerlinHDSThread
      • TLogBufferFlushThread
      • TLogCheckSizeThread
    • TVRMLNode
      • TVRMLIntegerArray
      • TVRMLMaterial
      • TVRMLShapeHints
      • TVRMLSingleArray
      • TVRMLTransform
      • TVRMLUse
    • TVRMLParser
  • TPropertyEditor
    • TGLResolutionProperty
    • TUniformAutoSetProperty
  • TPythonEngine
    • TGLPythonEngine
  • TSelectionEditor
    • TGLBaseSceneObjectSelectionEditor
    • TGLSoundLibrarySelectionEditor
  • TStringProperty
    • TAsmProgFileProperty
    • TGLAnimationNameProperty
    • TGLCUDACompilerSourceProperty
    • TGLCUDADeviceProperty
    • TGLLibMaterialNameProperty
    • TGLMaterialComponentNameProperty
      • TGLLibAsmProgNameProperty
      • TGLLibAttachmentNameProperty
      • TGLLibCombinerNameProperty
      • TGLLibSamplerNameProperty
      • TGLLibShaderNameProperty
      • TGLLibTextureNameProperty
    • TGLSoundNameProperty
    • TPictureFileProperty
    • TShaderFileProperty
  • TWinControl
    • TGLSceneViewer


GLSysHelp v.2.5: All Classes, Interfaces, Objects and Records

All Classes, Interfaces, Objects and Records

Name Unit Description
BASS_3DVECTOR BASS.Import

3D vector (for 3D positions/velocities/orientations)
BASS_CHANNELINFO BASS.Import

Channel info structure
BASS_DEVICEINFO BASS.Import

plugin handle Device info structure
BASS_DX8_CHORUS BASS.Import

BASS_DX8_COMPRESSOR BASS.Import

BASS_DX8_DISTORTION BASS.Import

BASS_DX8_ECHO BASS.Import

BASS_DX8_FLANGER BASS.Import

BASS_DX8_GARGLE BASS.Import

BASS_DX8_I3DL2REVERB BASS.Import

BASS_DX8_PARAMEQ BASS.Import

BASS_DX8_REVERB BASS.Import

BASS_FILEPROCS BASS.Import

BASS_FX_VOLUME_PARAM BASS.Import

BASS_INFO BASS.Import

BASS_PLUGINFORM BASS.Import

BASS_PLUGININFO BASS.Import

BASS_RECORDINFO BASS.Import

Recording device info structure
BASS_SAMPLE BASS.Import

Sample info structure
CUDAContextManager GLS.CUDA.Context

Static class of CUDA contexts manager
DTriangle GLScene.Triangulation

Created Triangles, vv# are the vertex pointers
DVertex GLScene.Triangulation

Points (Vertices)
DXT3AlphaBlock Formats.DXTC

DXT5AlphaBlock Formats.DXTC

DXTColBlock Formats.DXTC

ECgBombShaderException GLS.CgBombShader

ECgShaderException GLS.CgShader

Define OutputCompilerWarnings to output Cg compiler warnings to a file. Useful for detecting bugs caused by using uninitialized value, implicit type cast, etc.
EDDSException Formats.DDSImage

EFilerException GLScene.XCollection

EGGAnsi2WideConvError gnugettext

EGGComponentError gnugettext

EGGIOError gnugettext

EGGProgrammingError gnugettext

EGLAtmosphereException GLS.Atmosphere

EGLCameraController GLS.CameraController

EGLConsoleException GLS.Console

EGLContext GLS.Context

EGLCustomShaderException GLSL.CustomShader

EGLFile3DS GLS.File3DS

EGLImageUtils GLS.ImageUtils

EGLMotionBlurException GLS.Blur

EGLOBJFileError GLS.FileOBJ

EGLPostShaderHolderException GLSL.PostEffects

EGLProxyException GLS.ProxyObjects

EGLROAMException GLS.ROAMPatch

Exception use by splitter for SafeTesselation
EGLShader GLS.Context

EGLShaderException GLS.Texture

EGLSLBumpShaderException GLSL.BumpShaders

EGLSLDiffuseSpecularShaderException GLSL.DiffuseSpecularShader

EGLSLShaderException GLSL.Shader

EGLUtilsException GLScene.Utils

EGnuGettext gnugettext

EInvalidArchiveFile GLS.ArchiveManager

EInvalidRasterFile GLS.Graphics

EInvalidVectorFile GLS.VectorFileObjects

EOpenGLError GLS.OpenGLAdapter

EOpenGLError GLScene.OpenGL4

EPasJSONMergeError PasJSON

EPasJSONSyntaxError PasJSON

EPBuffer GLS.Context

ESDLError GLS.SDL.Window

Generic SDL or SDLWindow exception
ETexture GLS.Texture

ETextureCombinerError GLS.TextureCombiners

ETGAException GLS.FileTGA

EZBufferException GLS.zBuffer

GCUDAHostElementAccess CUDA.DataAccess

GRedBlackTree GLScene.RedBlackTree

GRedBlackTree.TRBNode GLScene.RedBlackTree

IAVIEditStream Formats.VFW

IAVIFile Formats.VFW

– AVIFile ——————————————————————
IAVIStream Formats.VFW

- - - - - - - - */

/****** AVI Stream Interface ******************************************
IAVIStreaming Formats.VFW

IGetFrame Formats.VFW

The functions 'BeginExtraction' and 'EndExtraction' have actually the names 'Begin' and 'End', but we cannot use that identifiers for obvious reasons.
IGLInitializable GLS.Scene

Interface to objects that need initialization
IGLMaterialLibrarySupported GLS.Material

an interface for proper TGLLibMaterialNameProperty support
IGLPostShader GLSL.CustomShader

Used in the TGLPostShaderHolder component.
IGLShaderDescription GLSL.CustomShader

This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.
IGLTextureNotifyAble GLS.Texture

IGnuGettextInstanceWhenNewLanguageListener gnugettext

*—————————————————————————— Interface to implement if you want to register as a language change listener ——————————————————————————-
IShaderParameter GLSL.ShaderParameter

TAABB GLScene.GeometryBB

Structure for storing Axis Aligned Bounding Boxes
TACubic3DS Formats.m3DSTypes

TAG_APE_BINARY BASS.Import

TAG_BEXT BASS.Import

TAG_ID3 BASS.Import

TAndroidIO SDL.Import

TANIMChunk Formats.B3D

TAsmProgFileProperty GLS.SceneRegister

TAtmosphere3DS Formats.m3DSTypes

TAVICOMPRESSOPTIONS Formats.VFW

TAVIFileInfoA Formats.VFW

TAVIFileInfoW Formats.VFW

TAVIINDEXENTRY Formats.VFW

TAVIPALCHANGE Formats.VFW

TAVIStreamHeader Formats.VFW

TAVIStreamInfoA Formats.VFW

TAVIStreamInfoW Formats.VFW

TB3DChunk Formats.B3D

TB3DMaterial Formats.B3D

TB3DNode Formats.B3D

TB3DTexture Formats.B3D

TBackground3DS Formats.m3DSTypes

TBB3DChunk Formats.B3D

TBitmap3DS Formats.m3DSTypes

TBodyList ODE.Import

TBONEChunk Formats.B3D

TBoneMatrixObj GLS.ProxyObjects

An object containing the bone matrix for TGLActorProxy.
TBoundBox Formats.m3DSTypes

TBoxRec GLScene.VectorTypesExt

TBRUSChunk Formats.B3D

TBSPClusterVisibility GLS.MeshBSP

TBSPCullingSphere GLS.MeshBSP

TBSPFace Formats.Q3BSP

TBSPHeader Formats.Q3BSP

TBSphere GLScene.GeometryBB

Structure for storing BoundingSpheres. Similar to TAABB
TBSPLeaf Formats.Q3BSP

TBSPLightmap Formats.Q3BSP

TBSPLump Formats.Q3BSP

TBSPMeshObject GLS.MeshBSP

A BSP mesh object. Stores the geometry information, BSP rendering options and offers some basic BSP utility methods. Geometry information is indexed in the facegroups, the 1st facegroup (of index 0) being the root node of the BSP tree.
TBSPModel Formats.Q3BSP

TBSPNode Formats.Q3BSP

TBSPRenderContextInfo GLS.MeshBSP

TBSPTexture Formats.Q3BSP

TBSPVertex Formats.Q3BSP

TBSPVisData Formats.Q3BSP

TCadencableCustomCgShader GLS.CgShader

Allows to use a Cadencer, which is used for noise generation in many shaders.
TCamera3DS Formats.m3DSTypes

TCamRanges Formats.m3DSTypes

TCamRanges3DS Formats.m3DSTypes

TCAPDRIVERCAPS Formats.VFW

TCAPINFOCHUNK Formats.VFW

TCAPSTATUS Formats.VFW

TCAPTUREPARMS Formats.VFW

TCellPos GLS.Memo

TCellSize GLS.Memo

TCgBombShader GLS.CgBombShader

TCgCustomBombShader GLS.CgBombShader

Just a good-looking shader.
TCgFragmentProgram GLS.CgShader

TCgParameter GLS.CgShader

Wrapper around a Cg parameter of the main program.
TCgProgram GLS.CgShader

Wrapper around a Cg program.
TCgShader GLS.CgShader

TCgVertexProgram GLS.CgShader

TChannelTypeAndNum GLS.CUDA.APIComps

TCHANNEL_CAPS Formats.VFW

TCharInfo GLS.BitmapFont

TCharStyle GLS.Memo

TChunk3DS Formats.m3DSTypes

finally the chunk definition
TChunkData Formats.m3DSTypes

to avoid zillion type casts, we use this variant record for chunk data, effectively this defines the same pointer differently for different chunk types this is only possible because all types are just pointers
TChunkList3DS Formats.m3DSTypes

list of cross references
TChunkListEntry3DS Formats.m3DSTypes

cross reference between Name and Chunk
Tcl_buffer_region OpenCL.Import

Tcl_image_desc OpenCL.Import

Tcl_image_format OpenCL.Import

TColor24 Formats.m3DSTypes

TColorF Formats.m3DSTypes

TColTrackTag Formats.m3DSTypes

TCombinerCommand GLS.TextureCombiners

TCOMPVARS Formats.VFW

TCoronaTangentLookup GLS.Imposter

TCUarray CUDA.Import

TCubicSpline GLScene.Spline

3D cubic spline handler class. This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline. Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector. Note : X, Y & Z are actually interpolated independently.
TCUcontext CUDA.Import

TcudaArray CUDA.Runtime

+//DEVICE_BUILTIN*/
TCudaChannelFormatDesc CUDA.Runtime

TCUDAComponent GLS.CUDA.APIComps

TCUDAConstant GLS.CUDA.APIComps

TCUDAConstantInfo CUDA.Parser

TCUDAContext GLS.CUDA.Context

TCUDACustomFeedBackMesh GLS.CUDA.Graphics

====================================================
TCUDADevice GLS.CUDA.Context

TCudaDeviceProp CUDA.Runtime

TCUDADimensions GLS.CUDA.Context

TcudaExtent CUDA.Runtime

+//DEVICE_BUILTIN*/
TCUDAFeedbackMesh GLS.CUDA.Graphics

TCUDAFFTPlan GLS.CUDA.FFTPlan

TCUDAFuncArgInfo CUDA.Parser

TcudaFuncAttributes CUDA.Import

* CUDA function attributes
TCUDAFuncInfo CUDA.Parser

TCUDAFuncParam GLS.CUDA.APIComps

TCUDAFunction GLS.CUDA.APIComps

TCUDAGeometryResource GLS.CUDA.Graphics

TCUDAGraphicResource GLS.CUDA.APIComps

Abstract class of graphic resources.
TCUDAHandlesMaster GLS.CUDA.Context

TCUDAImageResource GLS.CUDA.Graphics

TcudaMemcpy3DParms CUDA.Runtime

+//DEVICE_BUILTIN*/
TCUDAMemData GLS.CUDA.APIComps

TCUDAModule GLS.CUDA.APIComps

TCUDAModuleInfo CUDA.Parser

TcudaPitchedPtr CUDA.Runtime

+//DEVICE_BUILTIN*/
TcudaPos CUDA.Runtime

+//DEVICE_BUILTIN*/
TCUDATexRefInfo CUDA.Parser

TCUDATexture GLS.CUDA.APIComps

TCUDAUniform GLS.CUDA.APIComps

TCUDA_ARRAY3D_DESCRIPTOR CUDA.Import

3D array descriptor
TCUDA_ARRAY_DESCRIPTOR CUDA.Import

TCUDA_MEMCPY2D CUDA.Import

TCUDA_MEMCPY3D CUDA.Import

3D memory copy parameters
TCUdevprop CUDA.Import

Legacy device properties
TCUDPPConfiguration CUDA.ParallelPrimitives

Placeholder at end of enum
TCUevent CUDA.Import

TcufftComplex CUDA.FourierTransform

TcufftDoubleComplex CUDA.FourierTransform

TCUfunction CUDA.Import

TCUgraphicsResource CUDA.Import

TCUmodule CUDA.Import

TCustomCgShader GLS.CgShader

TCUstream CUDA.Import

TCUtexref CUDA.Import

TD3DMatrix GLScene.VectorTypes

TD3DVector GLScene.VectorTypes

TDatabase3DS Formats.m3DSTypes

file database
TDCECollision GLS.DCE

TdContact ODE.Import

TdContactGeom ODE.Import

TDCueSettings3DS Formats.m3DSTypes

distance cue atmosphere parameters
TDDPIXELFORMAT Formats.DXTC

TDDSHeader Formats.DXTC

TDDSImage Formats.DDSImage

TDDSURFACEDESC2 Formats.DXTC

TDDS_HEADER_DXT10 Formats.DXTC

);
TDESolver GLS.PhysManager

need to have state array(s) seperate from inertias to allow for implicit & explicit methods
TDESolverEuler GLS.PhysManager

TDESolverExplicit GLS.PhysManager

explicit e.g. Euler, Mid-point, Runge-Kutta integration
TDESolverImplicit GLS.PhysManager

implicit e.g. Verlet Integration
TDESolverRungeKutta4 GLS.PhysManager

TDESolverVerlet GLS.PhysManager

TdGeomClass ODE.Import

typedef struct dGeomClass { int bytes; dGetColliderFnFn *collider; dGetAABBFn *aabb; dAABBTestFn *aabb_test; dGeomDtorFn *dtor; } dGeomClass;
TdGeomSpaceData ODE.Import

typedef struct dGeomSpaceData { dGeomID next; } dGeomSpaceData;
TDim GLScene.VectorTypesExt

TDistanceCue Formats.m3DSTypes

TdJointFeedback ODE.Import

TDlLocalShadow2 Formats.m3DSTypes

TDlSpotlight Formats.m3DSTypes

TdMass ODE.Import

TdObject ODE.Import

TDomain gnugettext

*—————————————————————————— Handles all issues regarding a specific domain. Don't use this class. It's for internal use. ——————————————————————————-
TDRAWDIBTIME Formats.VFW

TdSurfaceParameters ODE.Import

TdxAutoDisable ODE.Import

TdxBody ODE.Import

TdxContactParameters ODE.Import

TdxDampingParameters ODE.Import

TDXFile Formats.X

TDXFileHeader Formats.X

TDXFrame Formats.X

TdxGeom ODE.Import

// common data for all geometry objects. the class-specific data area follows // this structure. pos and R will either point to a separately allocated // buffer (if body is 0 - pos points to the dxPosR object) or to the pos and // R of the body (if body nonzero). struct dxGeom { // a dGeomID is a pointer to this dxGeomClass *_class; // class of this object void *data; // user data pointer dBodyID body; // dynamics body associated with this object (if any) dReal *pos; // pointer to object's position vector dReal *R; // pointer to object's rotation matrix dSpaceID spaceid; // the space this object is in dGeomSpaceData space; // reserved for use by space this object is in dReal *space_aabb; // ptr to aabb array held by dSpaceCollide() fn // class-specific data follows here, with proper alignment. };
TdxHashSpace ODE.Import

Copies settings from TdxSpace, beacause pascal doeasn't do inheritance for records
TdxHeightfieldData ODE.Import

TdxJoint ODE.Import

TdxJointAMotor ODE.Import

TdxJointBall ODE.Import

TdxJointFixed ODE.Import

TdxJointGroup ODE.Import

TdxJointHinge ODE.Import

TdxJointHinge2 ODE.Import

TdxJointLimitMotor ODE.Import

TdxJointLMotor ODE.Import

TdxJointNode ODE.Import

TdxJointPiston ODE.Import

TdxJointPlane2D ODE.Import

TdxJointPR ODE.Import

TdxJointSlider ODE.Import

TdxJointUniversial ODE.Import

TDXMaterial Formats.X

TDXMaterialList Formats.X

TDXMesh Formats.X

TDXNode Formats.X

TdxPosR ODE.Import

TdxQuadTreeSpace ODE.Import

TdxQuickStepParameters ODE.Import

TdxSpace ODE.Import

TdxTriMeshData ODE.Import

struct dxTriMeshData{ Model BVTree; MeshInterface Mesh;

dxTriMeshData(); ~dxTriMeshData();

void Build(const void* Vertices, int VertexStide, int VertexCount, const void* Indices, int IndexCount, int TriStride, const void* Normals, bool Single);

/* aabb in model space */ dVector3 AABBCenter; dVector3 AABBExtents;

/* data for use in collison resolution */ const void* Normals; Matrix4x4 last_trans; };
TdxWorld ODE.Import

struct dxWorld : public dBase { dxBody *firstbody; // body linked list dxJoint *firstjoint; // joint linked list int nb,nj; // number of bodies and joints in lists dVector3 gravity; // gravity vector (m/s/s) dReal global_erp; // global error reduction parameter dReal global_cfm; // global costraint force mixing parameter };
TEaxBufferProperties OpenAL.Import

Use this structure for DSPROPERTY_EAXBUFFER_ALLPARAMETERS - all levels are hundredths of decibels

NOTE: This structure may change in future EAX versions. It is recommended to initialize fields by name: myBuffer.lDirect = 0; myBuffer.lDirectHF = -200; ... myBuffer.dwFlags = myFlags /* see EAXBUFFERFLAGS below */ ; instead of: myBuffer = { 0, -200, ... , 0x00000003 };
TEaxListenerProperties OpenAL.Import

Use this structure for DSPROPERTY_EAXLISTENER_ALLPARAMETERS - all levels are hundredths of decibels - all times are in seconds - the reference for high frequency controls is 5 kHz

NOTE: This structure may change in future EAX versions. It is recommended to initialize fields by name: myListener.lRoom = -1000; myListener.lRoomHF = -100; ... myListener.dwFlags = myFlags /* see EAXLISTENERFLAGS below */ ; instead of: myListener = { -1000, -100, ... , 0x00000009 }; If you want to save and load presets in binary form, you should define your own structure to insure future compatibility.
TECCollider GLS.EllipseCollision

TECCollisionPacket GLS.EllipseCollision

TECContact GLS.EllipseCollision

TECFreeForm GLS.EllipseCollision

Ellipsoid collision FreeForm
TECMovePack GLS.EllipseCollision

TECObjectInfo GLS.EllipseCollision

Object collision properties
TECPlane GLS.EllipseCollision

The Ellipsoid collision class
TECTriangle GLS.EllipseCollision

Ellipsoid collision Triangle
TECTriMesh GLS.EllipseCollision

Ellipsoid collision Mesh
TExecutable gnugettext

*—————————————————————————— Helper class for invoking events. ——————————————————————————-
TFace3DS Formats.m3DSTypes

Face List element
TFaceArray Formats.m3DSTypes

TFaceRec GLScene.VectorTypesExt

TFallTrackTag Formats.m3DSTypes

TFColor3DS Formats.m3DSTypes

RGB Color components
TFGBezierSurface GLS.ParametricSurfaces

A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.
TFGBSPNode GLS.MeshBSP

A node in the BSP tree. The description does not explicitly differentiates nodes and leafs, nodes are referred by their index.
TFGIndexTexCoordList GLS.VectorFileObjects

Adds per index texture coordinates to its ancestor. Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.
TFGPolygon GLS.Portal

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.
TFGPortalPolygon GLS.Portal

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.
TFGVertexIndexList GLS.VectorFileObjects

A face group based on an indexlist. The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.
TFGVertexNormalTexIndexList GLS.VectorFileObjects

Adds normals and texcoords indices. Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.
TFile3DS Formats.m3DS

The main class that supplies the user with all available data from a specific 3DS file. The data is currently read only, but the class might be finished sometime later...
TFileB3D Formats.B3D

TFileGLA Formats.GL2

Ghoul2 Animation structure
TFileGLM Formats.GL2

Ghoul2 Model structure
TFileMD2 Formats.MD2

TFileMD3 Formats.MD3

MD3 Main file class
TFileNMF GLS.FileNMF

TFileSection GLS.FileVfsPAK

TFileSection GLS.FileZLIB

TFileSection GLS.PAKArchive

TFinishTaskEvent GLS.Context

TFog Formats.m3DSTypes

TFogSettings3DS Formats.m3DSTypes

Fog atmosphere parameters
TFontEntry GLS.SpaceText

TFontManager GLS.SpaceText

Manages a list of fonts for which display lists were created.
TFovTrackTag Formats.m3DSTypes

TFractionErosion GLS.RandomHDS

TFrustum GLScene.VectorGeometry

TFSoundReverbChannelProperties FMOD.types

[STRUCTURE] [ [DESCRIPTION] Structure defining the properties for a reverb source, related to a FSOUND channel. For more indepth descriptions of the reverb properties under win32, please see the EAX3 documentation at http://developer.creative.com/ under the 'downloads' section. If they do not have the EAX3 documentation, then most information can be attained from the EAX2 documentation, as EAX3 only adds some more parameters and functionality on top of EAX2.

Note the default reverb properties are the same as the FSOUND_PRESET_GENERIC preset. Note that integer values that typically range from -10,000 to 1000 are represented in decibels, and are of a logarithmic scale, not linear, wheras float values are typically linear. PORTABILITY: Each member has the platform it supports in braces ie (win32/xbox). Some reverb parameters are only supported in win32 and some only on xbox. If all parameters are set then the reverb should product a similar effect on either platform. Linux and FMODCE do not support the reverb api.

The numerical values listed below are the maximum, minimum and default values for each variable respectively.

[SEE_ALSO] FSOUND_Reverb_SetChannelProperties FSOUND_Reverb_GetChannelProperties FSOUND_REVERB_CHANNELFLAGS ]
TFSoundReverbProperties FMOD.types

[STRUCT_START] [ [NAME] FSOUND_REVERB_PROPERTIES

[DESCRIPTION] Structure defining a reverb environment.

[REMARKS] For more indepth descriptions of the reverb properties under win32, please see the EAX2/EAX3 documentation at http://developer.creative.com/ under the 'downloads' section. If they do not have the EAX3 documentation, then most information can be attained from the EAX2 documentation, as EAX3 only adds some more parameters and functionality on top of EAX2. Note the default reverb properties are the same as the FSOUND_PRESET_GENERIC preset. Note that integer values that typically range from -10,000 to 1000 are represented in decibels, and are of a logarithmic scale, not linear, wheras float values are typically linear. PORTABILITY: Each member has the platform it supports in braces ie (win32/xbox). Some reverb parameters are only supported in win32 and some only on xbox. If all parameters are set then the reverb should product a similar effect on either platform. Only WIN32 supports the reverb api.

The numerical values listed below are the maximum, minimum and default values for each variable respectively.

[SEE_ALSO] FSOUND_Reverb_SetProperties FSOUND_Reverb_GetProperties FSOUND_REVERB_PRESETS FSOUND_REVERB_FLAGS ]
TFSoundTOCTag FMOD.types

[STRUCTURE] [ [DESCRIPTION] Structure defining a CD table of contents. This structure is returned as a tag from FSOUND_Stream_FindTagField when the tag name "CD_TOC" is specified. Note: All tracks on the CD - including data tracks- will be represented in this structure so it's use for anything other than generating disc id information is not recommended. See the cdda example program for info on retrieving and using this structure.

[SEE_ALSO] FSOUND_Stream_Open FSOUND_Stream_FindTagField ]
TFSoundVector FMOD.types

TFullPos GLS.Memo

TGClipRect GLScene.GeometryBB

TGDelaunay2D GLScene.Triangulation

TGDelaunay2D is a class for Delaunay triangulation of arbitrary points Credit to Paul Bourke (http://paulbourke.net/) for the original Fortran 77 Program :)) Conversion to Visual Basic by EluZioN (EluZioN@casesladder.com) Conversion from VB to Delphi6 by Dr Steve Evans (steve@lociuk.com) June 2002 Update by Dr Steve Evans: Heap memory allocation added to prevent stack overflow when MaxVertices and MaxTriangles are very large. Additional Updates in June 2002: Bug in InCircle function fixed. Radius r := Sqrt(rsqr). Check for duplicate points added when inserting new point. For speed, all points pre-sorted in x direction using quicksort algorithm and triangles flagged when no longer needed. The circumcircle centre and radius of the triangles are now stored to improve calculation time. You can use this code however you like providing the above credits remain in tact
TGeomList ODE.Import

TGL1DPerlin GLS.Perlin

TGL2DPerlin GLS.Perlin

TGL2DPerlinOctav GLS.Perlin

TGL3DSVectorFile GLS.File3DS

The 3DStudio vector file. Uses an upgraded version if a 3DS import library by Mike Lischke. (http://www.lishcke-online.de). A 3DS file may contain material information and require textures when loading.
TGLAbsoluteHUDText GLS.HUDObjects

Position (X, Y and X) is in absolute coordinates. This component converts them to screen coordinates and renderes text there.
TGLAbstractLibMaterial GLS.Material

TGLAbstractLibMaterials GLS.Material

TGLAbstractMaterialLibrary GLS.Material

TGLAbstractMemoObject GLS.Memo

TGLAbstractShaderUniform GLS.MaterialEx

TGLAbstractTexture GLS.MaterialEx

TGLActiveAttrib GLSL.Shader

TGLActor GLS.VectorFileObjects

Mesh class specialized in animated meshes. The TGLActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TGLAnimationController components).
TGLActorAnimation GLS.VectorFileObjects

An actor animation sequence. An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property). An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TGLAnimationControler.
TGLActorAnimations GLS.VectorFileObjects

Collection of actor animations sequences.
TGLActorProxy GLS.ProxyObjects

A proxy object specialized for Actors.
TGLAdvancedLabel GLS.Windows

TGLAHeader Formats.GL2

TGLAnimatedSprite GLS.AnimatedSprite

An animated version for using offset texture coordinate animation.
TGLAnimationControler GLS.VectorFileObjects

Controls the blending of an additionnal skeletal animation into an actor. The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TGLActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.
TGLAnimationNameProperty GLS.SceneRegister

TGLAnnulus GLS.GeomObjects

An annulus is a cylinder that can be made hollow (pipe-like)
TGLApplicationFileIO GLS.ApplicationFileIO

Allows specifying a custom behaviour for CreateFileStream. The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable. If multiple ApplicationFileIO components exist in the application, the last one created will be the active one.
TGLARBFragmentProgramHandle GLS.Context

TGLARBGeometryProgramHandle GLS.Context

TGLARBProgramHandle GLS.Context

TGLARBVertexProgramHandle GLS.Context

TGLArchiveFileFormat GLS.ArchiveManager

The type to record a registered class
TGLArchiveFileFormatsList GLS.ArchiveManager

The list of registered classes
TGLArray GLS.InitOpenGL

TGLArrowArc GLS.GeomObjects

Draws an arrowhead (Sliced Torus + cone). The arrow head is a cone that shares the attributes of the Torus (ie stacks/slices, materials etc). This is useful for displaying a movement (eg twist) or other arc arrows that might be required. By default the bottom arrow is off
TGLArrowLine GLS.GeomObjects

Draws an arrowhead (cylinder + cone). The arrow head is a cone that shares the attributes of the cylinder (ie stacks/slices, materials etc). Seems to work ok. This is useful for displaying a vector based field (eg velocity) or other arrows that might be required. By default the bottom arrow is off
TGLASEFace GLS.FileASE

ASE mesh face
TGLASEFaceList GLS.FileASE

ASE mesh faces list
TGLASEFaceTexure GLS.FileASE

maximum texture maps face texture channel indices
TGLASEFaceTexureChannels GLS.FileASE

face texture channels
TGLASEMaterial GLS.FileASE

TGLASEMaterialList GLS.FileASE

TGLASEMaterialTextureMap GLS.FileASE

TGLASEMaterialTextureMaps GLS.FileASE

TGLASEMeshObject GLS.FileASE

ASE geom object, represents single mesh object; contains: vertices, faces, verice indices, faces and vertices normals, channels of texture coordinates and indices, scaling and location info; this object used only to store ASE data temporary to copy supported piece of it into GLScene TGLMeshObject
TGLASESmoothingGroups GLS.FileASE

TGLASESubMaterial GLS.FileASE

TGLASESubMaterialList GLS.FileASE

TGLASEVectorFile GLS.FileASE

ASE vector file parser
TGLASkeleton Formats.GL2

TGLAsmShader GLSL.AsmShader

TGLAsmShaderParameter GLSL.AsmShader

TGLASMVertexProgram GLS.MaterialEx

TGLAsteroidData GLS.SkyDome

Asteroid Comet spheres..NOT DebrisAsteroid
TGLAsyncHDS GLS.AsyncHDS

TGLAsyncHDThread GLS.AsyncHDS

TGLAsyncTimer GLS.AsyncTimer

Asynchronous timer component (actual 1 ms resolution, if CPU fast enough). Keep in mind timer resolution is obtained in-between events, but events are not triggered every x ms. For instance if you set the interval to 5 ms, and your Timer event takes 1 ms to complete, Timer events will actually be triggered every 5+1=6 ms (that's why it's "asynchronous"). This component is based on ThreadedTimer by Carlos Barbosa.
TGLAtmosphere GLS.Atmosphere

TGLAVectorFile GLS.FileGL2

TGLAVIRecorder GLS.AVIRecorder

Component to make it easy to record GLScene frames into an AVI file.
TGLB3DVectorFile GLS.FileB3D

TGLBAcceleration GLS.Behaviours

Applies a constant acceleration to a TGLBInertia.
TGLBallAndSocketJoint GLS.PhysJoints

TGLBaseAnimationControler GLS.VectorFileObjects

Base class for skeletal animation control.
TGLBaseArchive GLS.ArchiveManager

BaseArchive class
TGLBaseBehaviour GLS.Scene

Base class for implementing behaviours in TGLScene. Behaviours are regrouped in a collection attached to a TGLBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...). Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses : stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.)

Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object). NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function
TGLBaseComponent GLS.Windows

TGLBaseConnectivity GLS.Silhouette

TGLBaseControl GLS.Windows

TGLBaseCustomGLSLBumpShader GLSL.BumpShaders

An abstract class.
TGLBaseCustomGLSLBumpShaderMT GLSL.BumpShaders

An abstract class.
TGLBaseCustomGLSLDiffuseSpecular GLSL.DiffuseSpecularShader

Abstract class.
TGLBaseFontControl GLS.Windows

TGLBaseForceFieldEmitter GLS.PhysManager

A base for different types of force-field behaviours
TGLBaseGLSLDiffuseSpecularShaderMT GLSL.DiffuseSpecularShader

Abstract class.
TGLBaseGuiObject GLS.Gui

TGLBaseImage GLS.Graphics

TGLBaseInertia GLS.PhysManager

purpose of TGLBaseInertia is to allow for inertias that may be constrained to 1 or 2 dimensions Shouldn't be used directly, instead use TGLParticleInertia (for a 3D particle) TGLRigidBodyInertia (for a 3D rigid-body) or define a new sub-class e.g. TGL1DParticleInertia, this will allow for faster speed
TGLBaseJoint GLS.PhysJoints

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)
TGLBaseLink GLS.PhysJoints

TGLBaseMaterialCollectionItem GLS.MaterialEx

TGLBaseMesh GLS.VectorFileObjects

Base class for mesh objects.
TGLBaseMeshConnectivity GLS.BaseMeshSilhouette

TGLBaseMeshObject GLS.VectorFileObjects

A base class for mesh objects. The class introduces a set of vertices and normals for the object but does no rendering of its own
TGLBasePerlin GLS.Perlin

TGLBasePerlinOctav GLS.Perlin

TGLBaseRandomHDS GLS.RandomHDS

This class introduces all the basic properties of random landscape. No method implemented though. It is used as a descendant for - TGLCustomRandomLandscape: one tile landscape (cyclic or not) - TGLTiledRndLandscape: "infinite" landscapes (grids of TGLCustomRandomLandscape)
TGLBaseSceneObject GLS.Scene

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged
TGLBaseSceneObjectSelectionEditor GLS.SceneRegister

Selection editor for TGLBaseSceneObject. Allows units to be added to the uses clause automatically when behaviours/effects are added to a TGLBaseSceneObject at design-time.
TGLBaseSelectTechnique GLS.Selection

TGLBaseShaderModel GLS.MaterialEx

TGLBaseSoundSource GLS.SoundManager

Base class for origin of sound playback.
TGLBaseSpacePartition GLS.SpacePartition

Basic space partition, does not implement any actual space partitioning
TGLBaseSpritePFXManager GLS.ParticleFX

Base class for sprite-based particles FX managers. The particles are made of optionally centered single-textured quads.
TGLBaseTextControl GLS.Windows

TGLBaseVerletNode GLS.VerletTypes

Basic Verlet Node
TGLBCollision GLS.Collision

Collision detection behaviour. Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms. An object may have multiple TGLBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.
TGLBehaviour GLS.Scene

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".
TGLBehaviours GLS.Scene

Holds a list of TGLBehaviour objects. This object expects itself to be owned by a TGLBaseSceneObject. As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TGLBehaviour subclasses.
TGLBExplosionFX GLS.ExplosionFx

TGLBFireFX GLS.FireFX

Fire special effect. This effect works as a client of TFireFXManager
TGLBFPSMovement GLS.FPSMovement

TGLBInertia GLS.Behaviours

Simple translation and rotation Inertia behaviour. Stores translation and rotation speeds, to which you can apply accelerations. Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).
TGLBitmapFont GLS.BitmapFont

See TGLCustomBitmapFont. This class only publuishes some of the properties.
TGLBitmapFontRange GLS.BitmapFont

An individual character range in a bitmap font. A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).
TGLBitmapFontRanges GLS.BitmapFont

TGLBitmapHDS GLS.HeightData

Bitmap-based Height Data Source. The image is automatically wrapped if requested data is out of picture Size, or if requested data is larger than the picture. The internal format is an 8 bit bitmap whose dimensions are a power of two, if the original image does not comply, it is StretchDraw'ed on a monochrome (gray) bitmap.
TGLBlankImage GLS.Texture

A texture image with no specified content, only a size. This texture image type is of use if the context of your texture is calculated at run-time (with a TGLMemoryViewer for instance).
TGLBlankTIE GLS.TextureImageEditors

TGLBlendedLerpInfo GLS.VectorFileObjects

Small structure to store a weighted lerp for use in blending
TGLBlendingParameters GLS.Material

TGLBlur GLS.Blur

TGLBMPImage GLS.FileBMP

TGLBooleanOcclusionQueryHandle GLS.Context

TGLBSoundEmitter GLS.SoundManager

A sound emitter behaviour, plug it on any object to make it noisy. This behaviour is just an interface to a TGLSoundSource, for editing convenience.
TGLBThorFX GLS.ThorFX

Thor special effect
TGLBuffer GLS.InitOpenGL

TGLBufferI GLS.InitOpenGL

TGLBufferObjectHandle GLS.Context

Manages a handle to a Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TGLBufferU GLS.InitOpenGL

TGLBufferV GLS.InitOpenGL

TGLBumpmapHDS GLS.BumpmapHDS

An Height Data Source that generates elevation bumpmaps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.
TGLBumpShader GLSL.BumpShaders

A generic bump shader.
TGLButton GLS.Windows

TGLCadencedComponent GLS.Cadencer

TGLCadencer GLS.Cadencer

This component allows auto-progression of animation. Basicly dropping this component and linking it to your TGLScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene). The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).
TGLCamera GLS.Scene

Camera object. This object is commonly referred by TGLSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.
TGLCameraController GLS.CameraController

TGLCameraInvariantObject GLS.Scene

Base class for camera invariant objects. Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).
TGLCameraJob GLS.CameraController

TGLCameraJobList GLS.CameraController

TGLCanvas GLS.Canvas

A simple Canvas-like interface for OpenGL. This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points. This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner. All coordinates are internally maintained with floating point precision. Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).
TGLCapsule GLS.GeomObjects

Capsule object, can also be used to make truncated cones
TGLCelShader GLSL.ShapeShaders

A generic cel shader.
TGLCGPostTransformationShader GLS.CgPostTransformationShader

TGLCheckBox GLS.Windows

TGLCollisionManager GLS.Collision

TGLCollisionState GLS.FPSMovement

TGLCollisionStates GLS.FPSMovement

TGLColorProperty GLS.SceneRegister

TGLColorProxy GLS.ProxyObjects

A proxy object with its own color. This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.
TGLCompositeImage GLS.CompositeImage

TGLCone GLS.GeomObjects

A cone object
TGLConeSP GLS.SpacePartition

Describes a cone, and is used for cone collision
TGLConnectivity GLS.Silhouette

TGLConsole GLS.Console

TGLConsoleCommand GLS.Console

A wrapper for a console command.
TGLConsoleCommandList GLS.Console

TGLConsoleControls GLS.Console

TGLConsoleStringList GLS.Console

A class that checks for duplicates.
TGLContactPoint GLS.FPSMovement

TGLContext GLS.Context

Wrapper around an OpenGL rendering context. The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection. This is a virtual abstract a class, and platform-specific subclasses must be used. All rendering context share the same lists
TGLContextHandle GLS.Context

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses
TGLContextManager GLS.Context

Stores and manages all the TGLContext objects.
TGLContextNotification GLS.Context

TGLContour GLS.MultiPolygon

TGLContourNodes GLS.MultiPolygon

TGLContours GLS.MultiPolygon

TGLCoordinatesProperty GLS.SceneRegister

TGLCube GLS.Objects

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TGLFreeForm and a material library. Ref: https://mathworld.wolfram.com/Cube.html
TGLCubeMapImage GLS.Texture

A texture image used for specifying and stroing a cube map. Not unlike TGLPictureImage, but storing 6 of them instead of just one. Saving & loading as a whole currently not supported.
TGLCUDA GLS.CUDA.APIComps

TGLCUDACompiler GLS.CUDA.Compiler

TGLCUDACompilerEditor GLS.CUDA.PropEditors

TGLCUDACompilerSourceProperty GLS.CUDA.PropEditors

TGLCUDADevice GLS.CUDA.Context

TGLCUDADeviceProperty GLS.CUDA.PropEditors

TGLCUDAEditor GLS.CUDA.PropEditors

TGLCUDAEditorForm FmCUDAEditor

TGLCustomAsmShader GLSL.AsmShader

TGLCustomAtmosphere GLS.Atmosphere

This class imitates an atmosphere around a planet
TGLCustomBitmapFont GLS.BitmapFont

Provides access to individual characters in a BitmapFont. Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column). Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap. Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.
TGLCustomCadencedComponent GLS.Cadencer

Adds a property to connect/subscribe to a cadencer.
TGLCustomCGPostTransformationShader GLS.CgPostTransformationShader

TGLCustomConsole GLS.Console

TGLCustomControl GLS.Windows

TGLCustomGLSLBumpShader GLSL.BumpShaders

TGLCustomGLSLBumpShaderAM GLSL.BumpShaders

One Light shaders.
TGLCustomGLSLBumpShaderMT GLSL.BumpShaders

TGLCustomGLSLDiffuseSpecularShader GLSL.DiffuseSpecularShader

******** Single Light ************
TGLCustomGLSLDiffuseSpecularShaderMT GLSL.DiffuseSpecularShader

TGLCustomGLSLFurShader GLSL.ShapeShaders

Custom class for Fur Shader
TGLCustomGLSLGlassShader GLSL.ShapeShaders

Custom class for Glass shader: Environment mapping and refraction mapping using the fresnel terms
TGLCustomGLSLIvoryShader GLSL.ShapeShaders

Custom class for a shader that simulate Ivory Material
TGLCustomGLSLLatticeShader GLSL.ShapeShaders

Custom class for GLSLLatticeShader. A shader that simulate Lattice with Diffuse/Specular and support Texture
TGLCustomGLSLMLBumpShader GLSL.BumpShaders

MultiLight shaders.
TGLCustomGLSLMLBumpShaderMT GLSL.BumpShaders

TGLCustomGLSLMLDiffuseSpecularShader GLSL.DiffuseSpecularShader

TGLCustomGLSLMLDiffuseSpecularShaderMT GLSL.DiffuseSpecularShader

TGLCustomGLSLPostBlurShader GLSL.PostShaders

Custom class for GLSLPostBlurShader. A shader that blurs the entire scene
TGLCustomGLSLPostDreamVisionShader GLSL.PostShaders

Custom class for GLSLPostDreamVisionShader. A shader that simulate a grayscale threshold vision (aka dream) of the entire scene
TGLCustomGLSLPostFrostShader GLSL.PostShaders

Custom class for GLSLPostFrostShader. A shader that frost of the entire scene
TGLCustomGLSLPostNightVisionShader GLSL.PostShaders

Custom class for GLSLPostNightVisionShader. A shader that simulate a Night Vision of the scene throw a mask if enabled, or of the entire scene
TGLCustomGLSLPostPixelateShader GLSL.PostShaders

Custom class for GLSLPostPixelateShader. A shader that pixelate of the entire scene
TGLCustomGLSLPostPosterizeShader GLSL.PostShaders

Custom class for GLSLPostPosterizeShader. A shader that posterize of the entire scene
TGLCustomGLSLPostThermalVisionShader GLSL.PostShaders

A shader that simulate a Thermal Vision of the entire scene
TGLCustomGLSLPostTroubleShader GLSL.PostShaders

Custom class for GLSLPostTroubleShader. A shader that trouble of the entire scene. v2 This Shader is experimental it can do smooth the scene or double the scene and it's depends of PixelX, PixelY and Freq values if they are less than 1 or greater the effects will be very different
TGLCustomGLSLSemShader GLSL.ShapeShaders

Custom class for SEM Shader : Spherical Environment Mapping
TGLCustomGLSLShader GLSL.Shader

TGLCustomGLSLSimpleErosionShader GLSL.ShapeShaders

Custom class for a shader that Erode surface object
TGLCustomGLSLSimpleGoochShader GLSL.ShapeShaders

Custom class for Gooch Shader
TGLCustomGLSLSimpleLatticeShader GLSL.ShapeShaders

Custom class for a shader that simulate Lattice
TGLCustomGLSLToonShader GLSL.ShapeShaders

Custom class for Toon Shader
TGLCustomGLSLVertexDisplacementShader GLSL.ShapeShaders

VertexDisplacement shader: Basic Vertex Displacement with Perlin Noise You can Improved it: The vertex displacement can be done by reading a 2D or 3D texture. It can be done along the normal or the tangent. It can be scaled, twisted, modulated, inverted... Converted from : https://www.clicktorelease.com/blog/vertex-displacement-noise-3d-webgl-glsl-three-js At this time only one light source is supported
TGLCustomHDS GLS.HeightData

An Height Data Source for custom use. Provides event handlers for the various requests to be implemented application-side (for application-specific needs).
TGLCustomPFXManager GLS.ParticleFX

A particles FX manager offering events for customization/experimentation. This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager. If the events aren't handled, nothing will be rendered.
TGLCustomRandomHDS GLS.RandomHDS

Base structure for all random landscape objects. It can't be used directly since its BuildHeightField procedure is abstract. Use one of its descendants instead.
TGLCustomSceneObject GLS.Scene

Extended base scene object class with a material property. The material allows defining a color and texture for the object, see TGLMaterial
TGLCustomShader GLSL.CustomShader

A pure abstract class, must be overriden.
TGLCustomShaderCombiner GLSL.ShaderCombiner

TGLCustomShaderParameter GLSL.CustomShader

Wrapper around a parameter of the main program.
TGLCustomSpritePFXManager GLS.ParticleFX

A sprite-based particles FX managers using user-specified code to prepare the texture
TGLCyborg GLS.SmartObjects

The Cyborg class specialized as a smart actor with AI. The TGLCyborg provides a quick interface to animated actors based on morph or skeleton frames, it is capable of performing frame interpolation and thinking blending (via TGLThinkingController components).
TGLCyborgManager GLS.CyborgManager

TGLCyborgThinks GLS.SmartObjects

TGLCyborgThinksList GLS.SmartObjects

A list of thinking periods for TGLCyborgThinkMode
TGLCylinder GLS.GeomObjects

Cylinder object, can also be used to make truncated cones
TGLCylinderBase GLS.GeomObjects

Base class to cylinder-like objects that introduces the basic cylinder description properties. Be aware teh default slices and stacks make up for a high-poly cylinder, unless you're after high-quality lighting it is recommended to reduce the Stacks property to 1.
TGLCylinderProperties GLS.MeshBuilder

Properties of a cylinder with 8 parts for 2 hemicylinders using 6 points to make each part for hemidisk caps and side surfaces
TGLDamping GLS.Behaviours

Holds parameters for a basic damping model by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass. Formulas: damping = constant + linear * Speed + quadratic * Speedˆ2 accel = damping / Mass That's just basic physics. A note on the components: constant: use it for solid friction (will stop abruptly an object after decreasing its speed. linear: linear friction damping. quadratic: expresses viscosity
TGLDampingFieldEmitter GLS.PhysFields

TGLDataFile GLS.ApplicationFileIO

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.
TGLDCEDynamic GLS.DCE

TGLDCEManager GLS.DCE

The Dynamic Collision Engine Manager class
TGLDCEStatic GLS.DCE

TGLDDSImage GLS.FileDDS

TGLDELVectorFile GLS.FileDEL

The DEL vector file (tetrahedra irregular network)
TGLDepthProperties GLS.Material

TGLDepthRBO GLS.FBORenderer

TGLDirectOpenGL GLS.Scene

Provides a way to issue direct OpenGL calls during the rendering. You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.
TGLDisk GLS.GeomObjects

A Disk object that may not be complete, it can have a hole (controlled by the InnerRadius property) and can only be a slice (controlled by the StartAngle and SweepAngle properties).
TGLDisplayOptions GLS.Screen

TGLDodecahedron GLS.GeomObjects

TGLDummyCube GLS.Objects

A simple cube, invisible at run-time. This is a usually non-visible object -except at design-time- used for building hierarchies or groups, when some kind of joint or movement mechanism needs be described, you can use DummyCubes. DummyCube's barycenter is its children's barycenter. The DummyCube can optionnally amalgamate all its children into a single display list (see Amalgamate property).
TGLDXFVectorFile GLS.FileDXF

TGLDynamicImposterBuilder GLS.Imposter

TGLDynamicPFXManager GLS.ParticleFX

An abstract PFX manager for simple dynamic particles. Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).
TGLDynamicTextureImage GLS.DynamicTexture

Allows for fast updating of the texture at runtime
TGLEarthSkyDome GLS.SkyDome

Render a skydome like what can be seen on earth. Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render exoplanet atmospheres too. The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TGLEarthSkyDome.
TGLEdge GLS.VerletClothify

TGLEdgeDetector GLS.VerletClothify

TGLEdgeList GLS.VerletClothify

TGLEdit GLS.Windows

TGLEffect GLS.Scene

A rendering effect that can be applied to SceneObjects. ObjectEffect is a subclass of behaviour that gets a chance to Render an object-related special effect. TGLEffect should not be used as base class for custom effects, instead you should use the following base classes : TGLObjectPreEffect is rendered before owner object render TGLObjectPostEffect is rendered after the owner object render TGLObjectAfterEffect is rendered at the end of the scene rendering NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function
TGLEffects GLS.Scene

Holds a list of object effects. This object expects itself to be owned by a TGLBaseSceneObject.
TGLEParticleMask GLS.EParticleMasksManager

TGLEParticleMasks GLS.EParticleMasksManager

TGLEParticleMasksManager GLS.EParticleMasksManager

TGLExtendedFrustum GLS.SpacePartition

Extended frustum, used for fast intersection testing
TGLExtensionsAndEntryPoints GLS.OpenGLAdapter

TGLExtrusionSolid GLS.Extrusion

Extrudes a complex Polygon into Z direction. For contour description see TGLMultiPolygonBase. properties Parts, Height (or should we better cal it Depth, because its in Z?), Stacks, Normals and NormalDirection are equivalent to TGLRevolutionSolid. If Normals=nsSmooth and the angle between two consecutive normals along the contour is less than MinSmoothAngle, smoothing is done, otherweise flat normals are used. This makes it possible to have smooth normals on sharp edged contours.
TGLFace GLS.VerletClothify

Class that represents a face. This structure is not used for rendering, but for extracting info from meshes
TGLFaceExtractor GLS.VerletClothify

Class that extracts faces from a GLBaseMesh
TGLFaceGroup GLS.VectorFileObjects

Describes a face group of a TGLMeshObject. Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object". Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.
TGLFaceGroupConnectivity GLS.BaseMeshSilhouette

TGLFaceGroups GLS.VectorFileObjects

A list of TGLFaceGroup objects.
TGLFaceList GLS.VerletClothify

List of faces
TGLFaceProperties GLS.Material

Stores basic face lighting properties. The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools. You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).
TGLFBORenderer GLS.FBORenderer

TGLFeedback GLS.Feedback

An object encapsulating the OpenGL feedback rendering mode.
TGLFile3DSActor GLS.File3DSSceneObjects

TGLFile3DSAnimationData GLS.File3DS

A record that holds all the information that is used during 3ds animation.
TGLFile3DSAnimationKeyList GLS.File3DS

TGLFile3DSAnimationKeys GLS.File3DS

An abstract class that describes how to interpolate animation keys.
TGLFile3DSCamera GLS.File3DSSceneObjects

TGLFile3DSCameraObject GLS.File3DS

A 3ds-specific camera.
TGLFile3DSColorAnimationKeys GLS.File3DS

TGLFile3DSDummyObject GLS.File3DS

A 3ds-specific TGLMorphableMeshObject.
TGLFile3DSFreeForm GLS.File3DSSceneObjects

TGLFile3DSLight GLS.File3DSSceneObjects

TGLFile3DSLightHotSpotAnimationKeys GLS.File3DS

TGLFile3DSMeshObject GLS.File3DS

A 3ds-specific mesh object.
TGLFile3DSOmniLightObject GLS.File3DS

A 3ds-specific omni light.
TGLFile3DSPositionAnimationKeys GLS.File3DS

TGLFile3DSRollAnimationKeys GLS.File3DS

TGLFile3DSRotationAnimationKeys GLS.File3DS

TGLFile3DSScaleAnimationKeys GLS.File3DS

TGLFile3DSSpotLightCutOffAnimationKeys GLS.File3DS

TGLFile3DSSpotLightObject GLS.File3DS

A 3ds-specific spot light.
TGLFireFXManager GLS.FireFX

Fire special effect manager. Defines the looks and behaviour of a particle system that can be made to look fire-like.
TGLFireParticle GLS.FireFX

TGLFixedFunctionProperties GLS.MaterialEx

TGLFlareGradient GLS.LensFlare

The actual gradients between two colors are, of course, calculated by OpenGL. The start and end colors of a gradient are stored to represent the color of lens flare elements.
TGLFlatText GLS.BitmapFont

A 2D text displayed and positionned in 3D coordinates. The FlatText uses a character font defined and stored by a TGLBitmapFont component. Default character scale is 1 font pixel = 1 space unit.
TGLFocusControl GLS.Windows

TGLFogEnvironment GLS.Scene

Parameters for fog environment in a scene. The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.
TGLForce GLS.PhysForces

TGLForces GLS.PhysManager

TGLForm GLS.Windows

TGLFPSMovementManager GLS.FPSMovement

TGLFractalArchipelago GLS.RandomHDS

TGLFractalHDS GLS.RandomHDS

Random landscape based on the middle-point displacement algorithm
TGLFragmentProgram GLSL.CustomShader

TGLFragmentShaderHandle GLS.Context

Manages a handle to a Fragment Shader Object
TGLFrameBuffer GLS.FBORenderer

TGLFrameBufferAttachment GLS.MaterialEx

TGLFramebufferHandle GLS.Context

Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered
TGLFreeForm GLS.VectorFileObjects

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.
TGLFreeFormProxy GLS.ProxyObjects

A proxy object specialized for FreeForms.
TGLFrustrum GLS.GeomObjects

A frustrum is a pyramid with the top chopped off. The height of the imaginary pyramid is ApexHeight, the height of the frustrum is Height. If ApexHeight and Height are the same, the frustrum degenerates into a pyramid. Height cannot be greater than ApexHeight.
TGLFullScreenVideoMode GLS.SceneForm

Screen mode settings
TGLFullScreenViewer GLS.FullScreenViewer

A FullScreen viewer. This non visual viewer will, when activated, use the full screen as rendering surface. It will also switch/restore videomode depending on the required width/height. This is performed by creating an underlying TForm and using its surface for rendering OpenGL, "decent" ICDs will automatically use PageFlipping instead of BlockTransfer (slower buffer flipping mode used for windowed OpenGL). Note: if you terminate the application either via a kill or in the IDE, the original resolution isn't restored.
TGLGameMenu GLS.GameMenu

Classic game menu interface made of several lines.
TGLGeometryProgram GLSL.CustomShader

TGLGeometryShaderHandle GLS.Context

Manages a handle to a Geometry Shader Object
TGLGizmo GLS.Gizmo

TGLGizmoEx GLS.GizmoEx

TGLGizmoExActionHistoryCollection GLS.GizmoEx

TGLGizmoExActionHistoryItem GLS.GizmoEx

TGLGizmoExObjectCollection GLS.GizmoEx

TGLGizmoExObjectItem GLS.GizmoEx

TGLGizmoExUIArrowLine GLS.GizmoEx

TGLGizmoExUIDisk GLS.GizmoEx

TGLGizmoExUIFlatText GLS.GizmoEx

TGLGizmoExUIFrustrum GLS.GizmoEx

Gizmo objects
TGLGizmoExUILines GLS.GizmoEx

TGLGizmoExUIPolygon GLS.GizmoEx

TGLGizmoExUISphere GLS.GizmoEx

TGLGizmoExUITorus GLS.GizmoEx

TGLGizmoPickCube GLS.Gizmo

TGLGizmoPickTorus GLS.Gizmo

TGLGizmoRayCastHitData GLS.Gizmo

TGLGizmoUndoCollection GLS.Gizmo

TGLGizmoUndoItem GLS.Gizmo

TGLglTFVectorFile GLS.FileGLTF

The glTF format is a runtime asset delivery format for GL APIs: WebGL, OpenGL ES OpenGL and Vulkan.
TGLGRDVectorFile GLS.FileGRD

The GRD file represents ascii grid formats in 2D/3D. This is a format for storing regular grid values as a matrices of cell centers. The format supports variations and subformats. This importer works for Sutfer, ArcInfo and GMS formats
TGLGTSVectorFile GLS.FileGTS

The GTS vector file (GNU Triangulated Surface library). It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces. Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices). http://gts.sourceforge.net/
TGLGuiComponent GLS.Gui

TGLGuiComponentList GLS.Gui

TGLGuiElement GLS.Gui

TGLGuiElementList GLS.Gui

TGLGuiLayout GLS.Gui

TGLGUILayoutEditor GLS.SceneRegister

TGLHDRImage GLS.FileHDR

TGLHeightData GLS.HeightData

TGLHeightData = class (TObject)
TGLHeightDataSource GLS.HeightData

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TGLHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TGLHeightData with its "Release" method) Pre-loading : specify a list of TGLHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task.
TGLHeightDataSourceFilter GLS.HeightData

Height Data Source Filter. This component sits between the TGLTerrainRenderer, and a real TGLHeightDataSource. i.e. TGLTerrainRenderer links to this. This links to the real TGLHeightDataSource. Use the 'HeightDataSource' property, to link to a source HDS. The 'OnSourceDataFetched' event then gives you the opportunity to make any changes, or link in a texture to the TGLHeightData object, BEFORE it is cached. It bypasses the cache of the source HDS, by calling the source's StartPreparingData procedure directly. The TGLHeightData objects are then cached by THIS component, AFTER you have made your changes. This eliminates the need to copy and release the TGLHeightData object from the Source HDS's cache, before linking your texture. See the new version of TGLBumpmapHDS for an example. (LIN) To create your own HDSFilters, Derive from this component, and override the PreparingData procedure.
TGLHeightDataThread GLS.HeightData

A thread specialized for processing TGLHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly
TGLHeightDataUser GLS.HeightData

TGLHeightField GLS.Graph

Renders a sampled height-field. HeightFields are used to materialize z=f(x, y) surfaces, you can use it to render anything from math formulas to statistics. Most important properties of an height field are its sampling scales (X & Y) that determine the extents and the resolution of the base grid. The component will then invoke it OnGetHeight event to retrieve Z values for all of the grid points (values are retrieved only once for each point). Each point may have an additionnal color and texture coordinate.
TGLHeightTile GLS.HeightTileFileHDS

TGLHeightTileFile GLS.HeightTileFileHDS

Interfaces a Tiled file
TGLHeightTileFileHDS GLS.HeightTileFileHDS

—————- TGLHeightTileFileHDS class ———————– An Height Data Source for the HTF format.
TGLHeightTileInfo GLS.HeightTileFileHDS

TGLHexahedron GLS.GeomObjects

TGLHexahedronProperties GLS.MeshBuilder

Properties of a hexahedron with 6 quad parts
TGLHiddenLineShader GLSL.LineShaders

TGLHookesSpring GLS.PhysForces

TGLHookesString GLS.PhysForces

TGLHUDSprite GLS.HUDObjects

A rectangular area, NOT perspective projected. (x, y) coordinates map directly to the viewport (in pixels) and refer the center of the area. The coordinate system is that of an equivalent TCanvas, ie. top-left point is the origin (0, 0). The z component is ignored and Z-Buffer is disabled when rendering. Using TGLHUDSprite in 2D only scenes : The most convenient way to use a TGLHUDSprite as a simple 2D sprite with blending capabilities (transparency or additive), is to set the texture mode to tmModulate, in FrontProperties, to use the Emission color to control coloring/intensity, and finally use the Diffuse color's alpha to control transparency (while setting the other RGB components to 0). You can also control aplha-blending by defining a <1 value in the sprite's AlphaChannel field. This provides you with hardware accelerated, alpha-blended blitting. Note : since TGLHUDSprite works in absolute coordinates, TGLProxyObject can't be used to duplicate an hud sprite.
TGLHUDText GLS.HUDObjects

A 2D text displayed and positionned in 2D coordinates. The HUDText uses a character font defined and stored by a TGLBitmapFont component. The text can be scaled and rotated (2D), the layout and alignment can also be controled.
TGLIcosahedron GLS.GeomObjects

TGLIDTFVectorFile GLS.File3DPDF

The IDTF vector file (Intermediate Data Text File). Used for converting to IDTF -> U3D -> 3D PDF
TGLImage GLS.Graphics

Contains and manipulates a 32 bits (24+8) bitmap. This is the base class for preparing and manipulating textures in GLS.Scene, this function does not rely on a windows handle and should be used for in-memory manipulations only. 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL. The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.
TGLImageClassProperty GLS.SceneRegister

TGLImageDataFormat Formats.DXTC

TGLImageLevelDesc GLS.Graphics

TGLImmaterialSceneObject GLS.Scene

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.
TGLImposter GLS.Imposter

TGLImposterBuilder GLS.Imposter

Abstract ImposterBuilder class.
TGLInertiaTensor GLS.PhysInertias

Stores Inertia Tensor for TGLRigidBodyInertia model
TGLInfoForm FmInfo

TGLInitializableObjectList GLS.Scene

Just a list of objects that support IGLInitializable.
TGLIsoline GLS.Isolines

TGLIsolines GLS.Isolines

TGLIsoSurfaceExtractor GLS.Isosurface

3D isosurface extractor class. This class allows to calculate and exctract isosurfaces from scalar field voxel models using a given isovalue
TGLJoint GLS.PhysJoints

TGLJoystick GLS.Joystick

A component interfacing the Joystick via the (regular) windows API.
TGLJPEGImage GLS.FileJPEG

TGLLabel GLS.Windows

TGLLayoutEditorForm FmGuiLayoutEditor

TGLLeavedSpacePartition GLS.SpacePartition

Implements a list of all leaves added to the space partition, _not_ a good solution, but it can be used as a benchmark against more complex methods
TGLLensFlare GLS.LensFlare

TGLLibArchive GLS.ArchiveManager

Using the collection item for simultaneous work with several archives
TGLLibArchives GLS.ArchiveManager

TGLLibAsmProgNameProperty GLS.SceneRegister

TGLLibAttachmentNameProperty GLS.SceneRegister

TGLLibCombinerNameProperty GLS.SceneRegister

TGLLibMaterial GLS.Material

Material in a material library. Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).
TGLLibMaterialEx GLS.MaterialEx

TGLLibMaterialNameProperty GLS.SceneRegister

TGLLibMaterialPickerForm FmLibMaterialPicker

TGLLibMaterialProperty GLS.MaterialEx

TGLLibMaterials GLS.Material

A collection of materials, mainly used in material libraries.
TGLLibMaterialsEx GLS.MaterialEx

TGLLibSamplerNameProperty GLS.SceneRegister

TGLLibShaderNameProperty GLS.SceneRegister

TGLLibTextureNameProperty GLS.SceneRegister

TGLLifeColoredPFXManager GLS.ParticleFX

Base PFX manager for particles with life colors. Particles have a core and edge color, for subclassing.
TGLLightmapBounds GLS.MeshLines

TGLLightSource GLS.Scene

Standard light source. The standard GLScene light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle). Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property. Lightsources are managed in a specific object by the TGLScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.
TGLLightSourceState GLS.State

TGLLineBase GLS.Objects

Base class for line objects. Introduces line style properties (width, color...)
TGLLineCollection GLS.MeshLines

TGLLineItem GLS.MeshLines

TGLLineNode GLS.MeshLines

Specialized Node for use in a TGLLines objects. Adds a Width property
TGLLineNodes GLS.MeshLines

Specialized collection for Nodes in TGLMeshLines objects. Stores TGLLineNode items.
TGLLineParticle GLS.LinePFX

Linear particle.
TGLLinePFXManager GLS.LinePFX

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.
TGLLines GLS.Objects

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.
TGLLineSettings GLSL.LineShaders

TGLLinesNode GLS.Objects

Specialized Node for use in a TGLLines objects. Adds a Color property (TGLColor) }
TGLLinesNodes GLS.Objects

Specialized collection for Nodes in a TGLLines objects. Stores TGLLinesNode items
TGLLink GLS.PhysJoints

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned
TGLListHandle GLS.Context

Manages a handle to a display list
TGLLMTSVectorFile GLS.FileLMTS

TGLLWOVectorFile GLS.FileLWO

TGLMapCollection GLS.FPSMovement

TGLMapCollectionItem GLS.FPSMovement

TGLMarchingCube GLS.Isosurface

TGLMaterial GLS.Material

Describes a rendering material. A material is basically a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping. An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TGLLibMaterial (taken for a material library). The TGLLibMaterial has more advanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps.
TGLMaterialComponentNameProperty GLS.SceneRegister

TGLMaterialEditorForm FmMaterialEditor

TGLMaterialLibrary GLS.Material

Stores a set of materials, to be used and shared by scene objects. Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time. Materials in a material library also feature advanced control properties like texture coordinates transforms.
TGLMaterialLibraryEditor GLS.SceneRegister

Editor for material library.
TGLMaterialLibraryEx GLS.MaterialEx

TGLMaterialLibraryItem GLS.MaterialScript

TGLMaterialLibraryItems GLS.MaterialScript

TGLMaterialMultiProxy GLS.MaterialMultiProxy

Multiple Proxy object. This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).
TGLMaterialMultiProxyMaster GLS.MaterialMultiProxy

MasterObject description for a MultiProxy object.
TGLMaterialMultiProxyMasters GLS.MaterialMultiProxy

Collection of TGLMaterialMultiProxyMaster.
TGLMaterialProperty GLS.SceneRegister

TGLMaterialProxy GLS.ProxyObjects

A proxy object with its own material. This proxy object can take a mesh from one master and a materia from a material library.
TGLMaterialScripter GLS.MaterialScript

TGLMatLibComponents GLS.MaterialEx

TGLMD2VectorFile GLS.FileMD2

The MD2 vector file (Quake2 actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TGLActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap). Based on code by Roger Cao.
TGLMD3VectorFile GLS.FileMD3

TGLMD5VectorFile GLS.FileMD5

TGLMDCVectorFile GLS.FileMDC

TGLMemoryViewer GLS.Scene

Component to render a scene to memory only. This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).
TGLMesh GLS.Mesh

Basic mesh object. Each mesh holds a set of vertices and a Mode value defines how they make up the mesh (triangles, strips...)
TGLMeshLines GLS.MeshLines

TGLMeshMorphTarget GLS.VectorFileObjects

A morph target, stores alternate lists of vertices and normals.
TGLMeshMorphTargetList GLS.VectorFileObjects

A list of TGLMeshMorphTarget objects.
TGLMeshObject GLS.VectorFileObjects

Base mesh class. Introduces base methods and properties for mesh objects. Subclasses are named "TGLMOxxx".
TGLMeshObjectList GLS.VectorFileObjects

A list of TGLMeshObject objects.
TGLMeshObjectVerletNode GLS.VerletClothify

TGLMHeader Formats.GL2

TGLMirror GLS.Mirror

A simple plane mirror. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered). It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.
TGLMLODInfo Formats.GL2

TGLMLODs Formats.GL2

TGLMoonRingData GLS.SkyDome

3ds files and DebrisAsteroid too
TGLMorphableMeshObject GLS.VectorFileObjects

Mesh object with support for morph targets. The morph targets allow to change vertices and normals according to pre-existing "morph targets".
TGLMotionBlur GLS.Blur

This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders. Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;) I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup.
TGLMovement GLS.Movement

TGLMovementPath GLS.Movement

TGLMovementPaths GLS.Movement

TGLMoveToPosJob GLS.CameraController

TGLMP3File GLS.FileMP3

Support for MP3 format. *Partial* support only, access to PCMData is NOT supported.
TGLMS3DVectorFile GLS.FileMS3D

The MilkShape vector file. By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!
TGLMSurface Formats.GL2

TGLMSurfaceHeader Formats.GL2

TGLMSurfaceHeirachy Formats.GL2

TGLMTLFile GLS.FileOBJ

A simple class that know how to extract infos from a mtl file. mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more): materials begin with a 'newmtl' command followed by material name *Kd command defines the diffuse color *map_Kd command defines the diffuse texture image *Ka/map_Ka define the ambient color and texmap *Ks/map_Ks define the specular color and texmap *Ke/map_Ke define the self-illumination/lightmap texmap map_Bump specifies the bump map *d specifies transparency (alpha-channel, range [0; 1]) map_d specifies the opcaity texture map Ns defines the specular exponent or shininess or phong specular (?) Ni is the refraction index (greater than 1) *illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting)
TGLMTriangle Formats.GL2

TGLMultiMaterialShader GLSL.MultiMaterialShader

TGLMultiPolygon GLS.MultiPolygon

A polygon that can have holes and multiple contours. Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).
TGLMultiPolygonBase GLS.MultiPolygon

Multipolygon is defined with multiple contours. The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator). The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one. Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended. TGLMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of GLS.VectorLists.
TGLMultiProxy GLS.MultiProxy

Multiple Proxy object. This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).
TGLMultiProxyMaster GLS.MultiProxy

MasterObject description for a MultiProxy object
TGLMultiProxyMasters GLS.MultiProxy

Collection of TGLMultiProxyMaster.
TGLMultisampleImage GLS.MultiSampleImage

TGLMultitextureCoordinator GLS.XOpenGL

TGLMultitexturingProperties GLS.MaterialEx

TGLMVectorFile GLS.FileGL2

TGLMVertex Formats.GL2

TGLNaviCube GLS.Navigator

TGLNavigator GLS.Navigator

TGLNavigator is the component for moving a TGLBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor. The four calls to get you started is TurnHorisontal : it turns left and right. TurnVertical : it turns up and down. MoveForward : moves back and forth. FlyForward : moves back and forth in the movingobject's direction The three properties to get you started is MovingObject : The Object that you are moving. UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't more like Descent. AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane...(no tilt and flying) InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal
TGLNavigatorAbstractParameters GLS.SmoothNavigator

Includes a basic set of parameters that control the smoothness of movement.
TGLNavigatorAdjustDistanceParameters GLS.SmoothNavigator

The wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work
TGLNavigatorAdjustDistanceParametersEx GLS.SmoothNavigator

The wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.
TGLNavigatorGeneralParameters GLS.SmoothNavigator

The wrapper for all general inertia parameters. These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.
TGLNavigatorInertiaParameters GLS.SmoothNavigator

The wrapper for all parameters that affect the smoothness of movement
TGLNavigatorMoveAroundParameters GLS.SmoothNavigator

The wrapper for all parameters that effect how the TGLBaseSceneObject.MoveObjectAround() procedure works
TGLNavigatorSmoothChangeItem GLS.SmoothNavigator

Includes a basic set of parameters that control the smoothness of movement.
TGLNavigatorSmoothChangeItems GLS.SmoothNavigator

XCollection of TGLNavigatorSmoothChangeItem.
TGLNavigatorSmoothChangeSingle GLS.SmoothNavigator

Smoothly change any Single value, so it will become TargetValue in the end.
TGLNavigatorSmoothChangeVector GLS.SmoothNavigator

Smoothly change any Vector4f value, so it will become TargetValue in the end.
TGLNGDBehaviour GLS.NGDManager

Basis structures for Behaviour style implementations.
TGLNGDBehaviourList GLS.NGDManager

TGLNGDDebugOption GLS.NGDManager

TGLNGDDynamic GLS.NGDManager

TGLNGDHeightField GLS.NGDManager

TComponent TList TWriter TReader TPersistent Samevalue isZero to compare single NGD.Joints, // old joints Physics.NewtonImport, // new version 4.0 PGLVector TGLVector TGLMatrix PGLMatrix NullHmgVector... TGLAffineVectorList for Tree TXCollection file function For show debug cube cone freeform...
TGLNGDJoint GLS.NGDManager

TGLNGDJointBallAndSocket GLS.NGDManager

TGLNGDJointHinge GLS.NGDManager

TGLNGDJointKinematicController GLS.NGDManager

TGLNGDJointPin GLS.NGDManager

TGLNGDJointPin2 GLS.NGDManager

TGLNGDJointPivot GLS.NGDManager

TGLNGDJointSlider GLS.NGDManager

TGLNGDManager GLS.NGDManager

TGLNGDStatic GLS.NGDManager

TGLNGDSurfaceItem GLS.NGDManager

TGLNGDSurfacePair GLS.NGDManager

TGLNMFVectorFile GLS.FileNMF

TGLNode GLS.Nodes

TGLNodedLines GLS.Objects

Class that defines lines via a series of nodes. Base class, does not render anything
TGLNodes GLS.Nodes

TGLNonVisualViewer GLS.Scene

Base class for non-visual viewer. Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.
TGLNurbsVectorFile GLS.FileNurbs

TGLObjectAfterEffect GLS.Scene

An object effect that gets rendered at scene's end. No particular OpenGL matrices or material should be assumed.
TGLObjectManager GLS.ObjectManager

TGLObjectPostEffect GLS.Scene

An object effect that gets rendered after owner object's render. The current OpenGL matrices and material are that of the owner object.
TGLObjectPreEffect GLS.Scene

An object effect that gets rendered before owner object's render. The current OpenGL matrices and material are that of the owner object.
TGLOBJVectorFile GLS.FileOBJ

TGLOcclusionQueryHandle GLS.Context

Manages a handle to an occlusion query. Requires OpenGL 1.5+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TGLOctahedron GLS.GeomObjects

TGLOCTGLVectorFile GLS.FileOCT

The OCT vector file (FSRad output).
TGLOctree GLS.Octree

Manages an Octree containing references to triangles.
TGLOctreeNode GLS.Octree

TGLOctreeSpacePartition GLS.SpacePartition

Implements octrees
TGLODEBehaviour GLS.ODEManager

Basis structures for behaviour style implementations
TGLODECollisionSurface GLS.ODEManager

TGLODEContactPoint GLS.ODEManager

TGLODECustomCollider GLS.ODEManager

The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms. Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE
TGLODEDynamic GLS.ODEManager

TGLODEElementBase GLS.ODEManager

TGLODEElementBox GLS.ODEManager

ODE box implementation
TGLODEElementCapsule GLS.ODEManager

ODE capped cylinder implementation
TGLODEElementCylinder GLS.ODEManager

ODE cylinder implementation
TGLODEElementPlane GLS.ODEManager

ODE plane implementation
TGLODEElements GLS.ODEManager

TGLODEElementSphere GLS.ODEManager

ODE sphere implementation
TGLODEElementTriMesh GLS.ODEManager

ODE tri-mesh implementation
TGLODEHeightField GLS.ODEManager

Add this behaviour to a TGLHeightField or TGLTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.
TGLODEJointBall GLS.ODEManager

ODE ball joint implementation
TGLODEJointBase GLS.ODEManager

Base structures for ODE Joints
TGLODEJointFixed GLS.ODEManager

ODE fixed joint implementation
TGLODEJointHinge GLS.ODEManager

ODE hinge joint implementation
TGLODEJointHinge2 GLS.ODEManager

ODE hinge2 joint implementation
TGLODEJointList GLS.ODEManager

Component front-end for storing ODE Joints
TGLODEJointParams GLS.ODEManager

TGLODEJoints GLS.ODEManager

An XCollection decendant for ODE Joints
TGLODEJointSlider GLS.ODEManager

ODE slider joint implementation
TGLODEJointUniversal GLS.ODEManager

ODE universal joint implementation
TGLODEManager GLS.ODEManager

The visual component to manage behaviours of ODE objects
TGLODERagdoll GLS.ODERagdoll

TGLODERagdollBone GLS.ODERagdoll

TGLODERagdollCube GLS.ODERagdoll

TGLODERagdollDummyJoint GLS.ODERagdoll

TGLODERagdollHingeJoint GLS.ODERagdoll

TGLODERagdollUniversalJoint GLS.ODERagdoll

TGLODERagdollWorld GLS.ODERagdoll

TGLODEStatic GLS.ODEManager

TGLOpenGL GLS.InitOpenGL

TGLOrbitalElements GLS.SkyDome

For recomputation of TOrbitalElementsData
TGLOrbitToPosAdvJob GLS.CameraController

TGLOrbitToPosJob GLS.CameraController

TGLOutlineShader GLSL.LineShaders

TGLPackPBOHandle GLS.Context

Manages a handle to PBO Pixel Pack Buffer. When bound, commands such as ReadPixels write their data into a buffer object.
TGLPanel GLS.Windows

TGLParticle GLS.ParticleFX

Base class for particles. The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).
TGLParticleFXEffect GLS.ParticleFX

Base class for linking scene objects to a particle FX manager.
TGLParticleFXManager GLS.ParticleFX

Base class for particle FX managers. Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer. Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).
TGLParticleFXRenderer GLS.ParticleFX

Rendering interface for scene-wide particle FX. A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately. This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.
TGLParticleInertia GLS.PhysInertias

TGLParticleList GLS.ParticleFX

List of particles. This list is managed with particles and performance in mind, make sure to check methods doc.
TGLParticles GLS.Particles

Manager object of a particle system. Particles in a TGLParticles system are described as normal scene objects, however their children are to be : "particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. "live particle" : the other objects (index>0), this ones are rendered and receive progression events. TGLParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and GLScene objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle. All direct access to a TGLParticles children should be avoided. For high-performance particle systems of basic particles, you should look into GLParticleFX instead, TGLParticles being rather focused on complex particles.
TGLPathNode GLS.Movement

TGLPathNodes GLS.Movement

TGLPerlin3DNoise GLS.PerlinPFX

Generates Perlin Noise in the [-1; 1] range. 2D noise requests are taken in the Z=0 slice
TGLPerlinHDS GLS.Perlin

TGLPerlinHDSThread GLS.Perlin

TGLPerlinPFXManager GLS.PerlinPFX

A sprite-based particles FX manager using perlin-based sprites. This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles. The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.
TGLPersistentImage GLS.Texture

Stores any image compatible with Delphi's TPicture mechanism. The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour of TImage. Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)
TGLPersistentTIE GLS.TextureImageEditors

TGLPGMImage GLS.FilePGM

TGLPhongShader GLSL.PhongShader

TGLPhysManager GLS.PhysManager

The Simple Physics Interaction (SPI) manager can only deal with objects from one scene More than one physics manager can be assigned to a scene
TGLPicFileImage GLS.Texture

Uses a picture whose data is found in a file (only filename is stored). The image is unloaded after upload to OpenGL.
TGLPicFileTIE GLS.TextureImageEditors

TGLPickList GLS.Selection

List class for object picking. This list is used to store the results of a PickObjects call.
TGLPictureImage GLS.Texture

Base class for image data classes internally based on a TPicture.
TGLPipe GLS.Extrusion

A solid object generated by extruding a circle along a trajectory. Texture coordinates NOT supported yet.
TGLPipeNode GLS.Extrusion

TGLPipeNodes GLS.Extrusion

TGLPixel24 GLS.Graphics

TGLPixel32 GLS.Graphics

TGLPlane GLS.Objects

A simple plane object. Note that a plane is always made of a single quad (two triangles) and the tiling is only applied to texture coordinates.
TGLPlanetData GLS.SkyDome

TGLPLYVectorFile GLS.FilePLY

The PLY vector file aka Stanford Triangle Format. This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.
TGLPNGImage GLS.FilePNG

TGLPointLightPFXManager GLS.ParticleFX

A sprite-based particles FX managers using point light maps. The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property. This PFX manager renders particles similar to what you can get with TGLPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.
TGLPointParameters GLS.Objects

Point parameters as in ARB_point_parameters. Make sure to read the ARB_point_parameters spec if you want to understand what each parameter does.
TGLPoints GLS.Objects

Renders a set of non-transparent colored points. The points positions and their color are defined through the Positions and Colors properties
TGLPolygon GLS.GeomObjects

A basic polygon object. The contour is described by the Nodes and SplineMode properties, it should be planar and is automatically tessellated. Texture coordinates are deduced from X and Y coordinates only. This object allows only for polygons described by a single contour, if you need "complex polygons" with holes, patches and cutouts, see GLS.MultiPolygon.
TGLPolygonBase GLS.Objects

Base class for objects based on a polygon
TGLPolygonList GLS.MultiPolygon

TGLPolygonPFXManager GLS.ParticleFX

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.
TGLPolyTet GLS.Polyhedra

A PolyTet object that handles polygyns for tetrahedron
TGLPopupMenu GLS.Windows

TGLPortal GLS.Portal

Portal Renderer class.
TGLPortalMeshObjectList GLS.Portal

A mesh object list that handles portal rendering. The items are treated as being sectors.
TGLPostEffect GLSL.PostEffects

Provides a simple way to producing post-effects without shaders. It is slow as hell, but it's worth it in some cases.
TGLPostEffectColor GLSL.PostEffects

TGLPostShaderCollection GLSL.PostEffects

TGLPostShaderCollectionItem GLSL.PostEffects

TGLPostShaderHolder GLSL.PostEffects

A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.
TGLPrimitiveQueryHandle GLS.Context

Manages a handle to a primitive query. Requires OpenGL 3.0+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TGLPrismaticJoint GLS.PhysJoints

TGLProcTextureNoise GLS.ProcTextures

TGLProcTextureNoiseTIE GLS.TextureImageEditors

TGLProgram GLS.InitOpenGL

TGLProgramHandle GLS.Context

Manages a GLSL Program Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user
TGLProjectedTextures GLS.ProjectedTextures

Projected Textures Manager. Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).
TGLProxyObject GLS.Scene

A full proxy object. This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own. Use it for duplicates of an object.
TGLPythonEngine GLS.Pythons.Script

This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TGLScriptPython) retain it's assigned compiler from design to run -time.
TGLQ3BSPVectorFile GLS.FileQ3BSP

The Q3BSP vector file (Quake III BSP).
TGLQuadricObject GLS.Objects

Base class for quadric objects. Introduces some basic Quadric interaction functions (the actual quadric math is part of the GLU library).
TGLQuadtreeSpacePartition GLS.SpacePartition

Implements quadtrees. Quadtrees are hardcoded to completely ignore the Y axis, only using X and Z to determine positioning. This means that they're well suited for 2d-ish situations (landscapes with trees for instance) but not for fully 3d situations (space fighting)
TGLQueryHandle GLS.Context

Manages a handle to a query. Do not use this class directly, use one of its subclasses instead.
TGLRadialGravityEmitter GLS.PhysFields

TGLRagdolBone GLS.Ragdoll

TGLRagdolBoneList GLS.Ragdoll

TGLRagdolJoint GLS.Ragdoll

TGLRagdoll GLS.Ragdoll

TGLRasterFileFormat GLS.Graphics

TGLRasterFileFormatsList GLS.Graphics

Stores registered raster file formats.
TGLRCHandle GLS.Context

TGLRenderbuffer GLS.FBORenderer

TGLRenderbufferHandle GLS.Context

Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).
TGLRenderContextClippingInfo GLS.RenderContextInfo

TGLRenderContextInfo GLS.RenderContextInfo

Stores contextual info useful during rendering methods.
TGLRenderPoint GLS.Scene

Scene object that allows other objects to issue rendering at some point. This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase. Callbacks must be explicitly unregistered.
TGLResolutionIndependantHUDText GLS.HUDObjects

Position (X and Y) is expected in a [0..1] range (from Screen size) This component converts this position to the actual screen position and renders the text there. This way a HUD text always appears to be in the the same place, regardless of the currect screen resolution. Note: this still does not solve the font scaling problem.
TGLResolutionProperty GLS.SceneRegister

TGLReuseableDefaultEditor GLS.SceneRegister

Editor copied from DsgnIntf. Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TGLSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! and he did that again in D7! Grrr...
TGLRevoluteJoint GLS.PhysJoints

TGLRevolutionSolid GLS.Extrusion

A solid object generated by rotating a curve along the Y axis. The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF). The TGLRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution. If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.
TGLRigidBodyInertia GLS.PhysInertias

A more complex model than TGLBInertia for Inertia
TGLROAMPatch GLS.ROAMPatch

TGLSamplerHandle GLS.Context

Manages a handle to a sampler
TGLSamplingScale GLS.Graph

TGLSArchiveManager GLS.ArchiveManager

ArchiveManager class
TGLSArchiveManagerEditor GLS.SceneRegister

Editor for Archive Manager
TGLScene GLS.Scene

Scene component class. The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TGLBaseSceneObject. It will usually contain one or more TGLCamera object, which can be referred by a Viewer component for rendering purposes. The scene's objects can be accessed directly from code (as regular components), but those are edited with a specific editor (double-click on the TGLScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TGLBaseSceneObject.
TGLSceneBuffer GLS.Scene

Encapsulates a frame/rendering buffer.
TGLSceneEditor GLS.SceneRegister

TGLSceneEditorForm FmSceneEditor

TGLSceneForm GLS.SceneForm

TGLSceneObj GLS.SpacePartition

Object for holding glscene objects in a spatial partitioning
TGLSceneObject GLS.Scene

Base class for standard scene objects. Publishes the Material property.
TGLSceneObjectEntry GLS.ObjectManager

holds a relation between an scene object class, its global identification, its location in the object stock and its icon reference
TGLSceneRootObject GLS.Scene

This class shall be used only as a hierarchy root. It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations. Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.
TGLSceneViewer GLS.SceneViewer

Component where the GLScene objects get rendered. This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap. It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form). This viewer also allows to define rendering options such as fog, face culling, depth testing, etc. and can take care of framerate calculation.
TGLSceneViewerEditor GLS.SceneRegister

TGLScreenControlingContext GLS.Context

A TGLContext with screen control property and methods. This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API. TGLSceneViewer won't use them, TGLMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass
TGLScreenSaver GLS.ScreenSaver

Drop this component on your main form to make it a screensaver. You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab). How this component works : At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) At run-time, once its props are loaded, this component will parse the command line and trigger relevant events Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible) There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).
TGLScriptBase GLS.ScriptBase

The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.
TGLScriptLibrary GLS.ScriptBase

Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.
TGLScriptPython GLS.Pythons.Script

Implements Python scripting functionality through the abstracted GLS.ScriptBase
TGLScripts GLS.ScriptBase

XCollection descendant for storing and handling scripts.
TGLScrollbar GLS.Windows

TGLSCustomMemo GLS.Memo

TGLSectoredSpacePartition GLS.SpacePartition

Implements sectored space partitioning, sectored space partitions include Octrees, Quadtrees and BSP-trees
TGLSectorMeshObject GLS.Portal

A portal renderer sector.
TGLSectorNode GLS.SpacePartition

Implements a SectorNode node. Each node can have 0 or 8 children, each child being a portion of the size of the parent. For quadtrees, that's 1/4, for octrees, it's 1/8
TGLSelectRenderModeTechnique GLS.Selection

TGLShader GLS.InitOpenGL

TGLShader GLS.Material

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.
TGLShaderCombiner GLSL.ShaderCombiner

TGLShaderEditorProperty GLS.SceneRegister

TGLShaderEx GLS.MaterialEx

TGLShaderF GLS.InitOpenGL

TGLShaderG GLS.InitOpenGL

TGLShaderHandle GLS.Context

Manages a handle to a Shader Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead
TGLShaderItem GLS.MaterialScript

TGLShaderItems GLS.MaterialScript

TGLShaderLightSourceState GLS.State

TGLShaderModel3 GLS.MaterialEx

TGLShaderModel4 GLS.MaterialEx

TGLShaderModel5 GLS.MaterialEx

TGLShaderProgram GLSL.CustomShader

A custom shader program.
TGLShaderUniform GLS.MaterialEx

TGLShaderUniformDSA GLS.MaterialEx

TGLShaderUniformEditor FmShaderUniformEditor

TGLShaderUniformTexture GLS.MaterialEx

TGLShaderV GLS.InitOpenGL

TGLShadowHDS GLS.ShadowHDS

An Height Data Source that generates terrain shadow maps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.
TGLShadowPlane GLS.ShadowPlane

A simple shadow plane. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered). If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently. You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones
TGLShadowVolume GLS.ShadowVolume

Simple shadow volumes. Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection. Shadow volumes require that the buffer allows stencil buffers, GLSceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly. Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.
TGLShadowVolumeCaster GLS.ShadowVolume

Specifies an individual shadow caster. Can be a light or an opaque object.
TGLShadowVolumeCasters GLS.ShadowVolume

Collection of TGLShadowVolumeCaster.
TGLShadowVolumeLight GLS.ShadowVolume

Specifies an individual shadow casting light.
TGLShadowVolumeOccluder GLS.ShadowVolume

Specifies an individual shadow casting occluder.
TGLSilhouette GLS.Silhouette

Base class storing a volume silhouette. Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system. This is the base class, you can use the TGLSilhouette subclass if you need some helper methods for generating the indexed sets.
TGLSilhouetteParameters GLS.Silhouette

Silouhette generation parameters. SeenFrom and LightDirection are expected in local coordinates.
TGLSimpleNavigation GLS.SimpleNavigation

TGLSimpleNavigationKeyCombination GLS.SimpleNavigation

TGLSimpleNavigationKeyCombinations GLS.SimpleNavigation

TGLSize GLS.RenderContextInfo

TGLSkeleton GLS.VectorFileObjects

Main skeleton object. This class stores the bones hierarchy and animation frames. It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.
TGLSkeletonBone GLS.VectorFileObjects

A skeleton bone or node and its children. This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TGLSkeletonFrame, but the calculated bone matrices are stored here.
TGLSkeletonBoneList GLS.VectorFileObjects

A list of skeleton bones
TGLSkeletonCollider GLS.VectorFileObjects

A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.
TGLSkeletonColliderList GLS.VectorFileObjects

List class for storing TGLSkeletonCollider objects
TGLSkeletonFrame GLS.VectorFileObjects

Stores position and rotation for skeleton joints. If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty)
TGLSkeletonFrameList GLS.VectorFileObjects

A list of TGLSkeletonFrame objects
TGLSkeletonMeshObject GLS.VectorFileObjects

A mesh object with vertice bone attachments. The class adds per vertex bone weights to the standard morphable mesh. The TGLVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method. When BonesPerVertex is 1, the weight is ignored (set to 1.0).
TGLSkeletonRootBoneList GLS.VectorFileObjects

This list store skeleton root bones exclusively
TGLSkinEditorForm FmGuiSkinEditor

TGLSkyBox GLS.SkyDome

TGLSkyDome GLS.SkyDome

Renders a sky dome always centered on the camera. If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system. The skydome is described by "bands", each "band" is a horizontal cut of a sphere, and you can have as many bands as you wish
TGLSkyDomeBand GLS.SkyDome

——————— SkyDome classes —————————–
TGLSkyDomeBands GLS.SkyDome

TGLSkyDomeStar GLS.SkyDome

TGLSkyDomeStars GLS.SkyDome

TGLSLBumpShader GLSL.BumpShaders

TGLSLBumpShaderAM GLSL.BumpShaders

TGLSLBumpShaderMT GLSL.BumpShaders

One light shaders.
TGLSLDiffuseSpecularShader GLSL.DiffuseSpecularShader

TGLSLDiffuseSpecularShaderMT GLSL.DiffuseSpecularShader

******** Published Stuff ************
TGLSLFurShader GLSL.ShapeShaders

TGLSLGlassShader GLSL.ShapeShaders

TGLSLHandle GLS.Context

Base class for GLSL handles (programs and shaders). Do not use this class directly, use one of its subclasses instead
TGLSLIvoryShader GLSL.ShapeShaders

TGLSLLatticeShader GLSL.ShapeShaders

TGLSLMLBumpShader GLSL.BumpShaders

Multi light shaders.
TGLSLMLBumpShaderMT GLSL.BumpShaders

TGLSLMLDiffuseSpecularShader GLSL.DiffuseSpecularShader

TGLSLMLDiffuseSpecularShaderMT GLSL.DiffuseSpecularShader

TGLSLogger GLScene.Logger

Abstract class for control logging.
TGLSLPostBlurShader GLSL.PostShaders

TGLSLPostDreamVisionShader GLSL.PostShaders

TGLSLPostFrostShader GLSL.PostShaders

TGLSLPostNightVisionShader GLSL.PostShaders

TGLSLPostPixelateShader GLSL.PostShaders

TGLSLPostPosterizeShader GLSL.PostShaders

TGLSLPostThermalVisionShader GLSL.PostShaders

TGLSLPostTroubleShader GLSL.PostShaders

TGLSLProjectedTextures GLSL.ProjectedTextures

Projected Texture Manager. Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.
TGLSLSemShader GLSL.ShapeShaders

TGLSLShader GLSL.Shader

TGLSLShaderParameter GLSL.Shader

Wrapper around a parameter of a GLSL program.
TGLSLSimpleErosionShader GLSL.ShapeShaders

TGLSLSimpleGoochShader GLSL.ShapeShaders

TGLSLSimpleLatticeShader GLSL.ShapeShaders

TGLSLTextureEmitter GLSL.ProjectedTextures

A projected texture emmiter. Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader
TGLSLTextureEmitterItem GLSL.ProjectedTextures

Specifies an item on the TGLSLTextureEmitters collection.
TGLSLTextureEmitters GLSL.ProjectedTextures

Collection of TGLSLTextureEmitter.
TGLSLToonShader GLSL.ShapeShaders

TGLSLVertexDisplacementShader GLSL.ShapeShaders

TGLSMBASS GLS.Sounds.BASS

TGLSMDVectorFile GLS.FileSMD

The SMD vector file is Half-life's skeleton format. The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames. This reader curently reads both, but requires that the main file (the one with mesh data) be read first.
TGLSMemo GLS.Memo

TGLSMemoAbstractScrollableObject GLS.Memo

TGLSMemoDelCharUndo GLS.Memo

TGLSMemoDeleteBufUndo GLS.Memo

TGLSMEmoDelLineUndo GLS.Memo

TGLSMemoGutter GLS.Memo

TGLSMemoInsCharUndo GLS.Memo

TGLSMemoPasteUndo GLS.Memo

TGLSMemoScrollBar GLS.Memo

TGLSMemoSelUndo GLS.Memo

TGLSMemoStringList GLS.Memo

TGLSMemoStrings GLS.Memo

TGLSMemoUndo GLS.Memo

TGLSMemoUndoList GLS.Memo

TGLSMFMOD GLS.Sounds.FMOD

TGLSmoothNavigator GLS.SmoothNavigator

The component for moving a TGLBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor. It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.
TGLSmoothOrbitToPos GLS.CameraController

TGLSmoothOrbitToPosAdvJob GLS.CameraController

TGLSmoothUserInterface GLS.SmoothNavigator

The component which reads the userinput and transform it into action. Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....
TGLSMOpenAL GLS.Sounds.OpenAL

TGLSMVectorFile GLS.VectorFileObjects

GLSM (GLScene Mesh) vector file. This corresponds to the 'native' GLScene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GLScene features.
TGLSMWaveOut GLS.Sounds.WaveOut

Basic sound manager based on WinMM waveOut function. This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality. Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).
TGLSoundFile GLS.SoundFileObjects

Abstract base class for different Sound file formats. The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TGLSoundFile is very similar to TGraphic (see Delphi Help). Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.
TGLSoundFileFormat GLS.SoundFileObjects

TGLSoundFileFormatsList GLS.SoundFileObjects

TGLSoundFileProperty GLS.SceneRegister

TGLSoundLibrary GLS.SoundManager

TGLSoundLibrarySelectionEditor GLS.SceneRegister

Selection editor for TGLSoundLibrary Allows units to be added to the uses clause automatically when sound files are loaded into a TGLSoundLibrary at design-time.
TGLSoundManager GLS.SoundManager

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.
TGLSoundNameProperty GLS.SceneRegister

TGLSoundSample GLS.SoundManager

Platform Specific

.NET Stores a single PCM coded sound sample.
TGLSoundSamples GLS.SoundManager

TGLSoundSampling GLS.SoundFileObjects

Defines a sound sampling quality.
TGLSoundSource GLS.SoundManager

Origin of sound playback. Just publishes the 'Origin' property. Note that the "orientation" is the the source's Direction, ie. the "Z" vector.
TGLSoundSources GLS.SoundManager

TGLSourcePFXEffect GLS.ParticleFX

Simple Particles Source.
TGLSpacePartitionLeaf GLS.SpacePartition

Used to store the actual objects in the SpacePartition
TGLSpacePartitionLeafList GLS.SpacePartition

List for storing space partition leaves
TGLSpacePartitionLeafS GLS.SpacePartition

The Space Partition updating for a bounding sphere
TGLSpaceText GLS.SpaceText

Renders a text in 3D.
TGLSphere GLS.Objects

A sphere object. The sphere can have to and bottom caps, as well as being just a slice of sphere. Ref: https://mathworld.wolfram.com/Sphere.html Ref: https://mathworld.wolfram.com/GeodesicDome.html
TGLSphereProperties GLS.MeshBuilder

Properties of a sphere with two hemispheres using 5 points to make each hemisphere part
TGLSprite GLS.Objects

A rectangular area, perspective projected, but always facing the camera. A TGLSprite is perspective projected and as such is scaled with distance, if you want a 2D sprite that does not get scaled, see TGLHUDSprite.
TGLSpriteAnimation GLS.AnimatedSprite

Animations define how the texture coordinates for each offset are to be determined.
TGLSpriteAnimationList GLS.AnimatedSprite

A collection for storing SpriteAnimation objects.
TGLSpriteAnimFrame GLS.AnimatedSprite

Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.
TGLSpriteAnimFrameList GLS.AnimatedSprite

TGLSpriteAnimMargins GLS.AnimatedSprite

Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.
TGLSSynHiMemo GLS.Memo

————————————————————– SYNTAX MEMO - declaration ————————————————————–
TGLStarData GLS.SkyDome

TGLStarRecord GLS.SkyDome

TGLStarSysData GLS.SkyDome

TGLStateCache GLS.State

Manages an application-side cache of OpenGL states and parameters. Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context
TGLStaticImposterBuilder GLS.Imposter

Builds imposters whose texture is a catalog of prerendered views.
TGLStaticImposterBuilderCorona GLS.Imposter

Describes a set of orientation in a corona fashion.
TGLStaticImposterBuilderCoronas GLS.Imposter

TGLStencilRBO GLS.FBORenderer

TGLSTLVectorFile GLS.FileSTL

TGLStringGrid GLS.Windows

TGLSuperellipsoid GLS.Objects

A Superellipsoid object. The Superellipsoid can have top and bottom caps, as well as being just a slice of Superellipsoid. Ref: https://mathworld.wolfram.com/Superellipse.html
TGLSwartSwarm GLS.SmartObjects

Synchronize self thinking with an other thinkers in the swarm Copies Ai/Current/End values,ThinkingMode and GridInterpolation. procedure Synchronize(IntelSwarm: TGLIntelSwarm);
TGLTeapot GLS.GeomObjects

The classic teapot. The only use of this object is as placeholder for testing...
TGLTerrainBaseHDS GLS.HeightData

TerrainBase-based Height Data Source. This component takes its data from the TerrainBase Gobal Terrain Model. Though it can be used directly, the resolution of the TerrainBase dataset isn't high enough for accurate short-range representation and the data should rather be used as basis for further (fractal) refinement. TerrainBase is freely available from the National Geophysical Data Center and World Data Center web site (http://ngdc.noaa.com). (this component expects to find "tbase.bin" in the current directory).
TGLTerrainRenderer GLS.TerrainRenderer

Basic terrain renderer. This renderer uses no sophisticated meshing, it just builds and maintains a set of terrain tiles, performs basic visibility culling and renders its stuff. You can use it has a base class/sample for more specialized terrain renderers. The Terrain heightdata is retrieved directly from a TGLHeightDataSource, and expressed as z=f(x, y) data.
TGLTessControlShaderHandle GLS.Context

Manages a handle to a Tessellation Control Shader Object
TGLTessEvaluationShaderHandle GLS.Context

Manages a handle to a Tessellation Evaluation Shader Object
TGLTetrahedron GLS.GeomObjects

This objects has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.
TGLTexCombineShader GLSL.TextureShaders

A shader that can setup the texture combiner.
TGLTextAdjust GLS.SpaceText

TGLTexture GLS.Texture

Defines basic texturing properties. You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default). A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TGLTextureImageAlpha).
TGLTextureBufferHandle GLS.Context

Manages a handle to a Buffer Texture. (TBO)
TGLTextureCombiner GLS.MaterialEx

TGLTexturedHDS GLS.TexturedHDS

TGLTextureEmitter GLS.ProjectedTextures

A projected texture emmiter. It's material property will be used as the projected texture. Can be places anywhere in the scene.
TGLTextureEmitterItem GLS.ProjectedTextures

Specifies an item on the TGLTextureEmitters collection.
TGLTextureEmitters GLS.ProjectedTextures

Collection of TGLTextureEmitter.
TGLTextureEx GLS.Texture

TGLTextureExItem GLS.Texture

TGLTextureHandle GLS.Context

Manages a handle to a texture
TGLTextureImage GLS.Texture

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.
TGLTextureImageEditor GLS.TextureImageEditors

TGLTextureImageEx GLS.MaterialEx

TGLTextureImageProperty GLS.SceneRegister

TGLTextureLensFlare GLS.TexLensFlare

TGLTextureProperties GLS.MaterialEx

TGLTextureProperty GLS.SceneRegister

TGLTextureSampler GLS.MaterialEx

TGLTextureSharingShader GLSL.TextureShaders

TGLTextureSharingShaderMaterial GLSL.TextureShaders

TGLTextureSharingShaderMaterials GLSL.TextureShaders

TGLTextureSwizzling GLS.MaterialEx

Swizzle the components of a texture fetches in shader or fixed-function pipeline.
TGLTGAImage Formats.TGA

TGLThorFXManager GLS.ThorFX

Thor special effect manager.
TGLTiledArea GLS.TilePlane

Stores tile information in a tiled area. Each tile stores an integer value with zero the default value, assumed as "empty".
TGLTiledAreaRow GLS.TilePlane

Stores row information for a tiled area.
TGLTiledRndLandscape GLS.RandomHDS

TGLTilePlane GLS.TilePlane

A tiled textured plane. This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering. Its bounding dimensions are determined by its painted tile.
TGLTimeEventsMGR GLS.TimeEventsMgr

TGLTimerQueryHandle GLS.Context

Manages a handle to a timer query. Requires GL_EXT_timer_query extension. Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TGLTINVectorFile GLS.FileTIN

The TIN vector file (triangle irregular network). It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files). This format is encountered in the DEM/DTED world and used in place of grids.
TGLTorus GLS.GeomObjects

A Torus object
TGLTrail GLS.Trail

TGLTransformFeedbackBufferHandle GLS.Context

Manages a handle to a Transform Feedback Buffer Object. Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.
TGLTree GLS.Tree

TGLTreeBranch GLS.Tree

TGLTreeBranches GLS.Tree

TGLTreeBranchNoise GLS.Tree

TGLTreeLeaves GLS.Tree

TGLType1Link GLS.PhysJoints

// Type 1 Two-Link Manipulator // // _ ________ // / \ \ // / \/________/ // / / // / / // / / // / / // / / // \_/ //
TGLType2Link GLS.PhysJoints

// Type 2 Two-Link Manipulator // ___ // / \___________________ // | + |___________________| // \ / // | | // | | // | | // | | // | | // | | // __|_|__ // |___.___| //
TGLType3Link GLS.PhysJoints

// Type 3 Two-Link Manipulator // _______ // _________| |__ // <-|_________| |__|-> // |__ __| // | | // | | // | | // | | // | | // _|_|_ // |__.__|
TGLType4Link GLS.PhysJoints

TGLType5Link GLS.PhysJoints

// Type 5 Two-Link Manipulator // // _ // ________|_|__ // <-|_____________|-> // | | // | | // | | // | | // | | // __| |__ // |__| |__| // |_| // | // V //
TGLType6Link GLS.PhysJoints

TGLType7Link GLS.PhysJoints

TGLType8Link GLS.PhysJoints

TGLU3DVectorFile GLS.File3DPDF

The U3D vector file (using IDTF and U3DConverter).
TGLUniformBufferHandle GLS.Context

Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program
TGLUniformGravityEmitter GLS.PhysFields

GLS.RigidBodyInertia
TGLUnpackPBOHandle GLS.Context

Manages a handle to PBO Pixel Unpack Buffer. When bound, commands such as DrawPixels read their data from a buffer object
TGLUNurbs GLScene.OpenGL4

TGLUNurbs GLScene.OpenGLTokens

——————- OpenGL Utility (GLU) types —————- GLU types
TGLUQuadric GLScene.OpenGL4

TGLUQuadric GLScene.OpenGLTokens

TGLUserInputCommand GLS.Console

Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...
TGLUserInterface GLS.Navigator

TGLUserInterface is the component which reads the user input and transform it into action. The four calls to get you started is MouseLookActivate : set us up the bomb. MouseLookDeActivate : defuses it. Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. MouseSpeed : Also known as mouse sensitivity. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....
TGLUserShader GLSL.UserShader

TGLUTesselator GLScene.OpenGL4

TGLUTesselator GLScene.OpenGLTokens

TGLVBOArrayBufferHandle GLS.Context

Manages a handle to VBO Array Buffer. Typically used to store vertices, normals, texcoords, etc.
TGLVBOElementArrayHandle GLS.Context

Manages a handle to VBO Element Array Buffer. Typically used to store vertex indices.
TGLVBOHandle GLS.Context

Manages a handle to an Vertex Buffer Object, VBO. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.
TGLVectorEditorForm FmVectorEditor

TGLVectorFile GLS.VectorFileObjects

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic
TGLVectorFileFormat GLS.VectorFileObjects

TGLVectorFileFormatsList GLS.VectorFileObjects

Stores registered vector file formats
TGLVectorPool GLS.MultiPolygon

Page oriented pointer array, with persistent pointer target memory. In TGLVectorList a pointer to a vector will not be valid any more after a call to SetCapacity, which might be done implicitely during Add. The TGLVectorPool keeps memory in its original position during its whole lifetime.
TGLVerletAirResistance GLS.VerletTypes

TGLVerletCapsule GLS.VerletTypes

Capsule shaped verlet constraint in a skeleton collider
TGLVerletConstraint GLS.VerletTypes

TGLVerletConstraintList GLS.VerletTypes

TGLVerletDualConstraint GLS.VerletTypes

TGLVerletDualForce GLS.VerletTypes

A verlet force that applies to two specified nodes.
TGLVerletEdge GLS.VerletTypes

Verlet edges simulate rigid collission edges
TGLVerletEdgeList GLS.VerletTypes

TGLVerletFloor GLS.VerletTypes

Floor Collision Constraint
TGLVerletForce GLS.VerletTypes

Generic verlet force.
TGLVerletForceList GLS.VerletTypes

TGLVerletFrictionCapsule GLS.VerletTypes

Capsule collision Friction Constraint.
TGLVerletFrictionCube GLS.VerletTypes

Cube Сollision Friction Constraint.
TGLVerletFrictionCylinder GLS.VerletTypes

Cylinder collision Friction Constraint. The cylinder is considered infinite by this constraint.
TGLVerletFrictionSphere GLS.VerletTypes

Sphere Сollision Friction Constraint
TGLVerletGlobalConstraint GLS.VerletTypes

TGLVerletGlobalForce GLS.VerletTypes

A global force (applied to all verlet nodes).
TGLVerletGlobalFrictionConstraint GLS.VerletTypes

TGLVerletGlobalFrictionConstraintBox GLS.VerletTypes

TGLVerletGlobalFrictionConstraintSP GLS.VerletTypes

TGLVerletGlobalFrictionConstraintSphere GLS.VerletTypes

TGLVerletGravity GLS.VerletTypes

TGLVerletGroupConstraint GLS.VerletTypes

TGLVerletGroupForce GLS.VerletTypes

A verlet force that applies to a specified group of nodes.
TGLVerletHair GLS.VerletTypes

Verlet Hair class
TGLVerletHeightField GLS.VerletTypes

HeightField collision constraint (punctual!)
TGLVerletNode GLS.VerletTypes

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.
TGLVerletNodeList GLS.VerletTypes

TGLVerletRigidBody GLS.VerletTypes

Rigid body verlet Collision constraint. Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. EXPERIMENTAL, STILL DOES NOT WORK!
TGLVerletSkeletonCollider GLS.VerletTypes

Base Verlet Skeleton Collider class.
TGLVerletSlider GLS.VerletTypes

Slider constraint. Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.
TGLVerletSphere GLS.VerletTypes

Sphere shaped verlet constraint in a skeleton collider
TGLVerletSpring GLS.VerletTypes

TGLVerletStick GLS.VerletTypes

Stick Verlet Collision Constraint. Imposes a fixed distance between two nodes
TGLVerletWorld GLS.VerletTypes

TGLVertexArrayHandle GLS.Context

Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state
TGLVertexAttribute GLS.CUDA.Graphics

TGLVertexAttributes GLS.CUDA.Graphics

TGLVertexBoneWeight GLS.VectorFileObjects

TGLVertexData GLS.Mesh

TGLVertexList GLS.Mesh

Stores an interlaced vertex list for direct use in OpenGL. Locking (hardware passthrough) is supported, see "Locked" property for details.
TGLVertexProgram GLSL.CustomShader

TGLVertexRec GLS.Objects

TGLVertexShaderHandle GLS.Context

Manages a handle to a Vertex Shader Object
TGLVfsPAK GLS.FileVfsPAK

TGLVideoMode GLS.Screen

TGLVirtualHandle GLS.Context

A context handle with event-based handle allocation and destruction
TGLVirtualHandleTransf GLS.Context

Transferable virtual handle
TGLVORVectorFile GLS.FileVOR

TGLVRMLVectorFile GLS.FileVRML

TGLWaterPlane GLS.WaterPlane

TGLWAVFile GLS.FileWAV

Support for Windows WAV format.
TGLWindowsBitmapFont GLS.WindowsFont

A bitmap font automatically built from a TFont. It works like a TGLBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders in GLScene as close to that font as posible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations. Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.
TGLWindowsContext GLS.WindowsContext

A context driver for standard Windows OpenGL (via MS OpenGL).
TGLXVectorFile GLS.FileX

TGLXYZGrid GLS.Graph

An XYZ Grid object. Renders an XYZ grid using lines
TGLzBuffer GLS.zBuffer

TGLZoomToDistanceJob GLS.CameraController

TGLZShadows GLS.zBuffer

TGnuGettextInstance gnugettext

*—————————————————————————— The main translation engine. ——————————————————————————-
TGPUDEVICE GLScene.OpenGL4

TGPUDEVICE GLScene.OpenGLTokens

TgTransformation GLScene.PipelineTransform

TgTransformationRec GLScene.PipelineTransform

TGUIRect GLS.Gui

THat SDL.Import

** * Get the SDL joystick layer binding for this controller button/axis mapping *
THDRImage Formats.HDRImage

THideTrackTag Formats.m3DSTypes

THmgBoundingBox GLScene.GeometryBB

THotTrackTag Formats.m3DSTypes

THTFHeader GLS.HeightTileFileHDS

TICCOMPRESS Formats.VFW

TICCOMPRESSFRAMES Formats.VFW

TICDECOMPRESS Formats.VFW

TICDECOMPRESSEX Formats.VFW

TICDRAW Formats.VFW

TICDRAWBEGIN Formats.VFW

TICDRAWSUGGEST Formats.VFW

TICINFO Formats.VFW

TICOPEN Formats.VFW

TICPALETTE Formats.VFW

TICSETSTATUSPROC Formats.VFW

TImposter GLS.Imposter

Base class for imposters manipulation and handling. Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.

Note: Remeber to enable Destination Alpha on your viewer.
TIntermediateFormat GLS.ImageUtils

Relative sample radius for filtering
TIpasData Formats.m3DSTypes

TJointInfo1 ODE.Import

info returned by getInfo1 function. the constraint dimension is m (<=6). i.e. that is the total number of rows in the jacobian. `nub' is the number of unbounded variables (which have lo,hi = -/+ infinity).
TJointInfo2 ODE.Import

info returned by getInfo2 function
TKeyFramer Formats.m3DS

TKeyHeader3DS Formats.m3DSTypes

Animation key settings
TKEYSChunk Formats.B3D

TKFAmbient3DS Formats.m3DSTypes

TKFCamera3DS Formats.m3DSTypes

TKFHdr Formats.m3DSTypes

TKFKeyInfo3DS Formats.m3DSTypes

TKFMesh3DS Formats.m3DSTypes

TKFOmni3DS Formats.m3DSTypes

TKFRotKey3DS Formats.m3DSTypes

Rotation key
TKFSeg Formats.m3DSTypes

TKFSegment3DS Formats.m3DSTypes

TKFSets3DS Formats.m3DSTypes

TKFSpot3DS Formats.m3DSTypes

TLandTileInfo GLS.RandomHDS

TLayerFog Formats.m3DSTypes

TLayerFogSettings3DS Formats.m3DSTypes

layered Fog atmosphere parameters
TLifeErosion GLS.RandomHDS

TLight3DS Formats.m3DSTypes

TLightRecord GLSL.DiffuseSpecularShader

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas
TLineProp GLS.Memo

TLiteAttenuate3DS Formats.m3DSTypes

TLMTS GLS.FileLMTS

TLMTS_Header GLS.FileLMTS

TLMTS_Subset GLS.FileLMTS

TLMTS_TexData GLS.FileLMTS

TLMTS_Vertex GLS.FileLMTS

TLogBufferFlushThread GLScene.Logger

Thread that periodically flushes the buffer to disk.
TLogCheckSizeThread GLScene.Logger

Thread that checks file size and splits the file if nessesary.
TLogSession GLScene.Logger

Abstract Logger class
TLWChunk Formats.LWO

TLWChunkList Formats.LWO

TLWChunkRec Formats.LWO

TLWClip Formats.LWO

TLWContentDir Formats.LWO

TLWLayr Formats.LWO

TLWObjectFile Formats.LWO

TLWParentChunk Formats.LWO

TLWPnts Formats.LWO

TLWPntsInfo Formats.LWO

TLWPols Formats.LWO

TLWPolsInfo Formats.LWO

TLWPolyTagMap Formats.LWO

TLWPTag Formats.LWO

TLWSubChunk Formats.LWO

TLWSubChunkRec Formats.LWO

TLWSurf Formats.LWO

TLWTags Formats.LWO

TLWVertexMap Formats.LWO

Value Map
TLWVMap Formats.LWO

TMainAVIHeader Formats.VFW

TMapInfo3DS Formats.m3DSTypes

TMapSet3DS Formats.m3DSTypes

TMatAcubic Formats.m3DSTypes

TMaterial3DS Formats.m3DSTypes

TMaterialInfo GLS.FileLMTS

TMaterialList Formats.m3DS

Progress : TProgressBar;

This allows to use something like that:

procedure TSomeForm.CreateForm(Sender: TObject); begin .... 3DSReader.OnProgress := LoadProgress; .... end; procedure TSomeForm.LoadProgress(StreamPos, StreamMax : Longint); begin if StreamMax <> 0 then Progress.MaxValue := StreamMax; Progress.Position := StreamPos; end; —– support classes —– All structure data of a 3DS file is actually held in TFile3DS.FDatabase as a tree with lots of links across the various chunks. For convinience and speed the data of the chunks is collected into some special structures (FMaterialList etc.) and presented to the user by the following helper classes:
TMatrix2b GLScene.VectorTypes

TMatrix2d GLScene.VectorTypes

=========== Matrices ============
TMatrix2DRec GLScene.VectorTypesExt

TMatrix2e GLScene.VectorTypes

TMatrix2f GLScene.VectorTypes

TMatrix2i GLScene.VectorTypes

TMatrix2p GLScene.VectorTypes

TMatrix2s GLScene.VectorTypes

TMatrix2w GLScene.VectorTypes

TMatrix3b GLScene.VectorTypes

TMatrix3d GLScene.VectorTypes

TMatrix3DRec GLScene.VectorTypesExt

TMatrix3e GLScene.VectorTypes

TMatrix3f GLScene.VectorTypes

TMatrix3i GLScene.VectorTypes

TMatrix3p GLScene.VectorTypes

TMatrix3s GLScene.VectorTypes

TMatrix3w GLScene.VectorTypes

TMatrix4b GLScene.VectorTypes

TMatrix4d GLScene.VectorTypes

TMatrix4e GLScene.VectorTypes

TMatrix4f GLScene.VectorTypes

TMatrix4i GLScene.VectorTypes

TMatrix4p GLScene.VectorTypes

TMatrix4s GLScene.VectorTypes

TMatrix4w GLScene.VectorTypes

TMatrixRec GLScene.VectorTypesExt

TMD2AliasFrame Formats.MD2

TMD2Header Formats.MD2

TMD2Triangle Formats.MD2

TMD2TriangleVertex Formats.MD2

TMD2VertexIndex Formats.MD2

TMD3Bone Formats.MD3

TMD3Frame = record min_bound,max_bounds, local_origin : TVector3f; radius : single; name : array[0..15] of char; end;
TMD3Face Formats.MD3

TMD3Header Formats.MD3

TMD3MeshData Formats.MD3

TMD3MeshHeader Formats.MD3

TMD3Skin Formats.MD3

TMD3Tag Formats.MD3

Quake3 MD3 structure types
TMD3TagList GLS.FileQ3MD3

This class is used to extract the tag transform information stored in the MD3 files. The data is used to offset each part of the model based on the parent parts animation state.
TMD3TexCoord Formats.MD3

TMD3Triangle Formats.MD3

TMDCBaseFrame GLS.FileMDC

TMDCBorderFrame GLS.FileMDC

TMDCCompFrame GLS.FileMDC

TMDCFileHeader GLS.FileMDC

TMDCSkin GLS.FileMDC

TMDCSurfaceHeader GLS.FileMDC

TMDCTag GLS.FileMDC

TMDCTagFrame GLS.FileMDC

TMDCTagName GLS.FileMDC

TMem SDL.Import

TMesh2DVert GLScene.VectorTypesExt

————————– Mesh simple record types ————————–
TMesh3DS Formats.m3DSTypes

TMesh3DVert GLScene.VectorTypesExt

TMESHChunk Formats.B3D

TMeshSet3DS Formats.m3DSTypes

TMeshTextureInfo Formats.m3DSTypes

TMoFile gnugettext

*—————————————————————————— Handles .mo files, in separate files or inside the exe file. Don't use this class. It's for internal use. ——————————————————————————-
TMOParametricSurface GLS.ParametricSurfaces

TMorphTrackTag Formats.m3DSTypes

TMS3DComment GLS.FileMS3D

TMS3DCommentList GLS.FileMS3D

TMS3DGroup GLS.FileMS3D

typedef struct (* byte flags; // SELECTED | HIDDEN char name[32]; // word numtriangles; // word triangleIndices[numtriangles]; // the groups group the triangles char materialIndex; // -1 = no material *) ms3d_group_t;
TMS3DHeader GLS.FileMS3D

typdef struct (* char id[10]; // always "MS3D000000" int version; // 4 *) ms3d_header_t;
TMS3DJoint GLS.FileMS3D

TMS3DJointBase GLS.FileMS3D

typedef struct (* byte flags; // SELECTED | DIRTY char name[32]; // char parentName[32]; // float rotation[3]; // local reference matrix float position[3];

word numKeyFramesRot; // word numKeyFramesTrans; //

ms3d_keyframe_rot_t keyFramesRot[numKeyFramesRot]; // local animation matrices ms3d_keyframe_pos_t keyFramesTrans[numKeyFramesTrans]; // local animation matrices *) ms3d_joint_t;
TMS3DKeyframePosition GLS.FileMS3D

typedef struct (* float time; // time in seconds float position[3]; // local position *) ms3d_keyframe_pos_t;
TMS3DKeyframeRotation GLS.FileMS3D

typedef struct (* float time; // time in seconds float rotation[3]; // x, y, z angles *) ms3d_keyframe_rot_t;
TMS3DMaterial GLS.FileMS3D

typedef struct (* char name[32]; // float ambient[4]; // float diffuse[4]; // float specular[4]; // float emissive[4]; // float shininess; // 0.0f - 128.0f float transparency; // 0.0f - 1.0f char mode; // 0, 1, 2 is unused now char texture[128]; // texture.bmp char alphamap[128]; // alpha.bmp *) ms3d_material_t;
TMS3DTriangle GLS.FileMS3D

typedef struct (* word flags; // SELECTED | SELECTED2 | HIDDEN word vertexIndices[3]; // float vertexNormals[3][3]; // float s[3]; // float t[3]; // byte smoothingGroup; // 1 - 32 byte groupIndex; // *) ms3d_triangle_t;
TMS3DVertex GLS.FileMS3D

typedef struct (* byte flags; // SELECTED | SELECTED2 | HIDDEN float vertex[3]; // char boneId; // -1 = no bone byte referenceCount; *) ms3d_vertex_t;
TMS3D_vertex_ex_t GLS.FileMS3D

TMshMatGroup Formats.m3DSTypes

TNCamera Formats.m3DSTypes

TNewtonBoxParam Newton.Import

TNewtonCapsuleParam Newton.Import

TNewtonChamferCylinderParam Newton.Import

TNewtonCollisionInfoRecord Newton.Import

TNewtonCollisionMaterial Newton.Import

TNewtonCollisionNullParam Newton.Import

TNewtonCollisionTreeParam Newton.Import

TNewtonCompoundCollisionParam Newton.Import

TNewtonConeParam Newton.Import

TNewtonConvexHullParam Newton.Import

TNewtonCylinderParam Newton.Import

TNewtonDeformableMeshParam Newton.Import

TNewtonFuncLinkRecord Newton.Import

PNewtonSerializeHandle = ˆPointer; PNewtonMeshHandle = ˆPointer; PNewtonMeshVertex = ˆPointer; PNewtonMeshPoint = ˆPointer; PNewtonMeshEdge = ˆPointer; PNewtonMeshFace = ˆPointer; PNewtonListener = ˆPointer;
TNewtonHeightFieldCollisionParam Newton.Import

TNewtonHingeSliderUpdateDesc Newton.Import

TNewtonImmediateModeConstraint Newton.Import

TNewtonJointRecord Newton.Import

TNewtonMaterialData Newton.Import

TNewtonMeshDoubleData Newton.Import

data structure for interfacing with NewtonMesh
TNewtonMeshFloatData Newton.Import

TNewtonMeshVertexFormat Newton.Import

TNewtonRagdoll GLS.NGDRagdoll

TNewtonSceneCollisionParam Newton.Import

TNewtonSphereParam Newton.Import

TNewtonTaperedCapsuleParam Newton.Import

TNewtonTaperedCylinderParam Newton.Import

TNewtonUserContactPoint Newton.Import

TNewtonUserMeshCollisionCollideDesc Newton.Import

TNewtonUserMeshCollisionRayHitDesc Newton.Import

TNewtonWorldConvexCastReturnInfo Newton.Import

TNmHeader GLS.FileNMF

TNmRawTriangle GLS.FileNMF

TNODEChunk Formats.B3D

TNodeHdr Formats.m3DSTypes

TNodeList Formats.m3DSTypes

TObjectList Formats.m3DS

TObjMat3DS Formats.m3DSTypes

TOCTFace Formats.OCT

TOCTFile Formats.OCT

TOCTHeader Formats.OCT

TOCTLight Formats.OCT

TOCTLightmap Formats.OCT

TOctreeTriangleInfo GLS.Octree

TOCTTexture Formats.OCT

TOCTVertex Formats.OCT

TOrbitalElementsData GLS.SkyDome

TOrthoView3DS Formats.m3DSTypes

Used to describe Top, Bottom, left, right, front and back views
TPAKArchive GLS.PAKArchive

TPakHeader GLS.FileVfsPAK

TPakHeader GLS.PAKArchive

TParticleReference GLS.ParticleFX

PFX region rendering structures
TPasJSON PasJSON

TPasJSONItem PasJSON

TPasJSONItemArray PasJSON

TPasJSONItemArray.TPasJSONItemArrayEnumerator PasJSON

TPasJSONItemBoolean PasJSON

TPasJSONItemNull PasJSON

TPasJSONItemNumber PasJSON

TPasJSONItemObject PasJSON

TPasJSONItemObject.TPasJSONItemObjectEnumerator PasJSON

TPasJSONItemObjectProperty PasJSON

TPasJSONItemString PasJSON

TPFXLifeColor GLS.ParticleFX

TPFXLifeColors GLS.ParticleFX

TPFXRegion GLS.ParticleFX

TPickRecord GLS.Selection

TPictureFileProperty GLS.SceneRegister

TPoint2DRec GLScene.VectorTypesExt

TPoint3DRec GLScene.VectorTypesExt

TPoint3DS Formats.m3DSTypes

3D point structure
TPointArray Formats.m3DSTypes

TPointFlagArray Formats.m3DSTypes

TPosTrackTag Formats.m3DSTypes

TQ3BSP Formats.Q3BSP

TQuat3DRec GLScene.VectorTypesExt

————————– Quaternion simple record types ————————–
TQuaternion GLScene.VectorGeometry

TQuaternionHelper GLScene.VectorTypesExt

TQuaternionRec GLScene.VectorTypesExt

TRainErosion GLS.RandomHDS

TRColorEditor FRColorEditor

TRectangle GLScene.VectorGeometry

TRelativeCoordinate GLS.RandomHDS

TRFaceEditor FRFaceEditor

TRGBPixel GLS.Blur

TRMapSet3DS Formats.m3DSTypes

TRMaterialPreview FRMaterialPreview

TROAMRenderPoint GLS.ROAMPatch

TROAMTriangleNode GLS.ROAMPatch

TRollTrackTag Formats.m3DSTypes

TRotTrackTag Formats.m3DSTypes

TRTextureEdit FRTextureEdit

TRTrackBarEdit FRTrackBarEdit

TScaleTrackTag Formats.m3DSTypes

TSCODEBase GLS.ODESkeletonColliders

Base ODE skeleton collider class
TSCODEBox GLS.ODESkeletonColliders

Box shaped ODE geom in a skeleton collider
TSCODECCylinder GLS.ODESkeletonColliders

Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider
TSCODESphere GLS.ODESkeletonColliders

Sphere shaped ODE geom in a skeleton collider
TSDLContext GLS.SDL.Context

A context driver for OpenGL via SDL (libsdl.org). Due to limitations of SDL: you may have only one SDL window opened at any time (you cannot have memory viewers) closing the SDL window will terminate the application
TSDLPantalla SDL.Import

TSDLViewer GLS.SDL.Context

A viewer using SDL. Beware: only one at a time, no other viewers allowed! Will also close the application when the window is closed!
TSDLWindow GLS.SDL.Window

A basic SDL-based window (non-visual component). Only a limited subset of SDL's features are available, and this window is heavily oriented toward using it for OpenGL rendering. Be aware SDL is currently limited to a single window at any time... so you may have multiple components, but only one can be used
TSDL_AudioCVT SDL.Import

** * A structure to hold a set of audio conversion filters and buffers. *
TSDL_AudioSpec SDL.Import

TSDL_BlitMap SDL.Import

TSDL_Color SDL.Import

TSDL_CommonEvent SDL.Import

** * Fields shared by every event *
TSDL_ControllerAxisEvent SDL.Import

** * Game controller axis motion event structure (event.caxis.*) *
TSDL_ControllerButtonEvent SDL.Import

** * Game controller button event structure (event.cbutton.*) *
TSDL_ControllerDeviceEvent SDL.Import

** * Controller device event structure (event.cdevice.*) *
TSDL_DisplayMode SDL.Import

TSDL_DollarGestureEvent SDL.Import

* (event.dgesture.*) *
TSDL_DropEvent SDL.Import

** * An event used to request a file open by the system (event.drop.*) * This event is disabled by default, you can enable it with SDL_EventState() * If you enable this event, you must free the filename in the event. *
TSDL_Error SDL.Import

TSDL_Event SDL.Import

TSDL_Finger SDL.Import

TSDL_GameControllerButtonBind SDL.Import

TSDL_Haptic SDL.Import

TSDL_HapticCondition SDL.Import

** * A structure containing a template for a Condition effect. * * The struct handles the following effects: * - SDL_HAPTIC_SPRING: Effect based on axes position. * - SDL_HAPTIC_DAMPER: Effect based on axes velocity. * - SDL_HAPTIC_INERTIA: Effect based on axes acceleration. * - SDL_HAPTIC_FRICTION: Effect based on axes movement. * * Direction is handled by condition internals instead of a direction member. * The condition effect specific members have three parameters. The first * refers to the X axis, the second refers to the Y axis and the third * refers to the Z axis. The right terms refer to the positive side of the * axis and the left terms refer to the negative side of the axis. Please * refer to the ::SDL_HapticDirection diagram for which side is positive and * which is negative. * * SDL_HapticDirection * SDL_HAPTIC_SPRING * SDL_HAPTIC_DAMPER * SDL_HAPTIC_INERTIA * SDL_HAPTIC_FRICTION * SDL_HapticEffect *
TSDL_HapticConstant SDL.Import

** * A structure containing a template for a Constant effect. * * The struct is exclusive to the ::SDL_HAPTIC_CONSTANT effect. * * A constant effect applies a constant force in the specified direction * to the joystick. * * SDL_HAPTIC_CONSTANT * SDL_HapticEffect *
TSDL_HapticCustom SDL.Import

** * A structure containing a template for the ::SDL_HAPTIC_CUSTOM effect. * * A custom force feedback effect is much like a periodic effect, where the * application can define its exact shape. You will have to allocate the * data yourself. Data should consist of channels * samples Uint16 samples. * * If channels is one, the effect is rotated using the defined direction. * Otherwise it uses the samples in data for the different axes. * * SDL_HAPTIC_CUSTOM * SDL_HapticEffect *
TSDL_HapticDirection SDL.Import

** * Structure that represents a haptic direction. * * Directions can be specified by: * - SDL_HAPTIC_POLAR : Specified by polar coordinates. * - SDL_HAPTIC_CARTESIAN : Specified by cartesian coordinates. * - SDL_HAPTIC_SPHERICAL : Specified by spherical coordinates. * * Cardinal directions of the haptic device are relative to the positioning * of the device. North is considered to be away from the user. * * The following diagram represents the cardinal directions: * .–. |__| .——-. |=.| |.—–.| |–| || || | | |'—–'| |__|~')_____(' [ COMPUTER ]

North (0,-1) ˆ | | (1,0) West <—-[ HAPTIC ]—-> East (-1,0) | | v South (0,1)

[ USER ] \|||/ (o o) —ooO-(_)-Ooo—

* * If type is SDL_HAPTIC_POLAR, direction is encoded by hundredths of a * degree starting north and turning clockwise. ::SDL_HAPTIC_POLAR only uses * the first dir parameter. The cardinal directions would be: * - North: 0 (0 degrees) * - East: 9000 (90 degrees) * - South: 18000 (180 degrees) * - West: 27000 (270 degrees) * * If type is SDL_HAPTIC_CARTESIAN, direction is encoded by three positions * (X axis, Y axis and Z axis (with 3 axes)). ::SDL_HAPTIC_CARTESIAN uses * the first three dir parameters. The cardinal directions would be: * - North: 0,-1, 0 * - East: -1, 0, 0 * - South: 0, 1, 0 * - West: 1, 0, 0 * * The Z axis represents the height of the effect if supported, otherwise * it's unused. In cartesian encoding (1, 2) would be the same as (2, 4), you * can use any multiple you want, only the direction matters. * * If type is SDL_HAPTIC_SPHERICAL, direction is encoded by two rotations. * The first two dir parameters are used. The dir parameters are as * follows (all values are in hundredths of degrees): * - Degrees from (1, 0) rotated towards (0, 1). * - Degrees towards (0, 0, 1) (device needs at least 3 axes). * * * Example of force coming from the south with all encodings (force coming * from the south means the user will have to pull the stick to counteract): * * SDL_HapticDirection direction; * * // Cartesian directions * direction.type = SDL_HAPTIC_CARTESIAN; // Using cartesian direction encoding. * direction.dir[0] = 0; // X position * direction.dir[1] = 1; // Y position * // Assuming the device has 2 axes, we don't need to specify third parameter. * * // Polar directions * direction.type = SDL_HAPTIC_POLAR; // We'll be using polar direction encoding. * direction.dir[0] = 18000; // Polar only uses first parameter * * // Spherical coordinates * direction.type = SDL_HAPTIC_SPHERICAL; // Spherical encoding * direction.dir[0] = 9000; // Since we only have two axes we don't need more parameters. * * * SDL_HAPTIC_POLAR * SDL_HAPTIC_CARTESIAN * SDL_HAPTIC_SPHERICAL * SDL_HapticEffect * SDL_HapticNumAxes *
TSDL_HapticEffect SDL.Import

TSDL_HapticPeriodic SDL.Import

** * A structure containing a template for a Periodic effect. * * The struct handles the following effects: * - SDL_HAPTIC_SINE * - SDL_HAPTIC_SQUARE * - SDL_HAPTIC_TRIANGLE * - SDL_HAPTIC_SAWTOOTHUP * - SDL_HAPTIC_SAWTOOTHDOWN * * A periodic effect consists in a wave-shaped effect that repeats itself * over time. The type determines the shape of the wave and the parameters * determine the dimensions of the wave. * * Phase is given by hundredth of a cycle meaning that giving the phase a value * of 9000 will displace it 25% of its period. Here are sample values: * - 0: No phase displacement. * - 9000: Displaced 25% of its period. * - 18000: Displaced 50% of its period. * - 27000: Displaced 75% of its period. * - 36000: Displaced 100% of its period, same as 0, but 0 is preferred. * * Examples: * SDL_HAPTIC_SINE __ __ __ __ / \ / \ / \ / / \__/ \__/ \__/

SDL_HAPTIC_SQUARE __ __ __ __ __ | | | | | | | | | | | |__| |__| |__| |__| |

SDL_HAPTIC_TRIANGLE /\ /\ /\ /\ /\ / \ / \ / \ / \ / / \/ \/ \/ \/

SDL_HAPTIC_SAWTOOTHUP /| /| /| /| /| /| /| / | / | / | / | / | / | / | / |/ |/ |/ |/ |/ |/ |

SDL_HAPTIC_SAWTOOTHDOWN \ |\ |\ |\ |\ |\ |\ | \ | \ | \ | \ | \ | \ | \ | \| \| \| \| \| \| \|

* * SDL_HAPTIC_SINE * SDL_HAPTIC_SQUARE * SDL_HAPTIC_TRIANGLE * SDL_HAPTIC_SAWTOOTHUP * SDL_HAPTIC_SAWTOOTHDOWN * SDL_HapticEffect *
TSDL_HapticRamp SDL.Import

** * A structure containing a template for a Ramp effect. * * This struct is exclusively for the ::SDL_HAPTIC_RAMP effect. * * The ramp effect starts at start strength and ends at end strength. * It augments in linear fashion. If you use attack and fade with a ramp * the effects get added to the ramp effect making the effect become * quadratic instead of linear. * * SDL_HAPTIC_RAMP * SDL_HapticEffect *
TSDL_JoyAxisEvent SDL.Import

** * Joystick axis motion event structure (event.jaxis.*) *
TSDL_JoyBallEvent SDL.Import

** * Joystick trackball motion event structure (event.jball.*) *
TSDL_JoyButtonEvent SDL.Import

** * Joystick button event structure (event.jbutton.*) *
TSDL_JoyDeviceEvent SDL.Import

** * Joystick device event structure (event.jdevice.*) *
TSDL_JoyHatEvent SDL.Import

** * Joystick hat position change event structure (event.jhat.*) *
TSDL_JoystickGUID SDL.Import

* A structure that encodes the stable unique id for a joystick device *
TSDL_KeyboardEvent SDL.Import

** * Keyboard button event structure (event.key.*) *
TSDL_Keysym SDL.Import

TSDL_MessageBoxButtonData SDL.Import

TSDL_MessageBoxColor SDL.Import

TSDL_MessageBoxColorScheme SDL.Import

TSDL_MessageBoxData SDL.Import

TSDL_MouseButtonEvent SDL.Import

** * Mouse button event structure (event.button.*) *
TSDL_MouseMotionEvent SDL.Import

** * Mouse motion event structure (event.motion.*) *
TSDL_MouseWheelEvent SDL.Import

** * Mouse wheel event structure (event.wheel.*) *
TSDL_MultiGestureEvent SDL.Import

** * Multiple Finger Gesture Event (event.mgesture.*) *
TSDL_Mutex SDL.Import

***KTI***
TSDL_Palette SDL.Import

TSDL_PixelFormat SDL.Import

TSDL_Point SDL.Import

TSDL_QuitEvent SDL.Import

** * The "quit requested" event *
TSDL_Rect SDL.Import

TSDL_RendererInfo SDL.Import

TSDL_RWops SDL.Import

TSDL_Surface SDL.Import

TSDL_SysWMEvent SDL.Import

TSDL_SysWMinfo SDL.Import

TSDL_SysWMmsg SDL.Import

TSDL_TextEditingEvent SDL.Import

** * Keyboard text editing event structure (event.edit.*) *
TSDL_TextInputEvent SDL.Import

** * Keyboard text input event structure (event.text.*) *
TSDL_Thread SDL.Import

TSDL_TouchFingerEvent SDL.Import

** * Touch finger event structure (event.tfinger.*) *
TSDL_UserEvent SDL.Import

** * A user-defined event type (event.user.*) *
TSDL_Version SDL.Import

TSDL_Window SDL.Import

* Define the SDL window structure, corresponding to toplevel windows *
TSDL_WindowEvent SDL.Import

** * Window state change event data (event.window.*) *
TSDL_WindowShapeMode SDL.Import

TSDL_WindowShapeParams SDL.Import

** A union containing parameters for shaped windows. *
TSDL_WindowShaper SDL.Import

TSDL_WindowUserData SDL.Import

TSeaErosion GLS.RandomHDS

TServiceContextTask GLS.Context

TShaderFileProperty GLS.SceneRegister

TShaderMemoForm FmShaderMemo

TShadowSets3DS Formats.m3DSTypes

global Shadow settings
TSmoothGroup Formats.m3DSTypes

TSPOctreeNode GLS.SpacePartition

** OCTTREE Implements sector node that handles octrees
TSpotCone3DS Formats.m3DSTypes

TSpotLight3DS Formats.m3DSTypes

TSpotProjector3DS Formats.m3DSTypes

TSpotShadow3DS Formats.m3DSTypes

TSPQuadtreeNode GLS.SpacePartition

** QUADTREE Implements sector node that handles quadtrees
TStateRecord GLS.State

TStaticImposter GLS.Imposter

Imposter class whose texture contains several views from different angles.
TStdio SDL.Import

TSteps GLS.RandomHDS

TSTLFace GLS.FileSTL

TSTLHeader GLS.FileSTL

TStyleList GLS.Memo

TTexPoint GLScene.VectorGeometry

TTEXSChunk Formats.B3D

TTextureReference CUDA.Runtime

TTexVert3DS Formats.m3DSTypes

Texture assignment coordinate
TTexVerts Formats.m3DSTypes

TTGAImage GLS.FileTGA

TGA image load/save capable class. TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.
TTGLFile3DSPositionAnimationKeys GLS.File3DS

TThorpoint GLS.ThorFX

TTimeEvent GLS.TimeEventsMgr

TTimeEvents GLS.TimeEventsMgr

TTrackHeader3DS Formats.m3DSTypes

Global track settings
TTriangleRec GLScene.VectorTypesExt

TTRISChunk Formats.B3D

TUBOStates GLS.State

TUniformAutoSetProperty GLS.SceneRegister

TUnknown SDL.Import

TUserView3DS Formats.m3DSTypes

TVector2b GLScene.VectorTypes

TVector2d GLScene.VectorTypes

=========== Vectors ============ 2
TVector2DRec GLScene.VectorTypesExt

TVector2e GLScene.VectorTypes

TVector2f GLScene.VectorTypes

TVector2h GLScene.VectorTypes

TVector2i GLScene.VectorTypes

TVector2p GLScene.VectorTypes

TVector2s GLScene.VectorTypes

TVector2sb GLScene.VectorTypes

TVector2ui GLScene.VectorTypes

TVector2w GLScene.VectorTypes

TVector3b GLScene.VectorTypes

TVector3d GLScene.VectorTypes

3
TVector3DRec GLScene.VectorTypesExt

TVector3e GLScene.VectorTypes

TVector3f GLScene.VectorTypes

TVector3h GLScene.VectorTypes

TVector3i GLScene.VectorTypes

TVector3p GLScene.VectorTypes

TVector3s GLScene.VectorTypes

TVector3sb GLScene.VectorTypes

TVector3ui GLScene.VectorTypes

TVector3w GLScene.VectorTypes

TVector4b GLScene.VectorTypes

TVector4d GLScene.VectorTypes

4
TVector4e GLScene.VectorTypes

TVector4f GLScene.VectorTypes

TVector4h GLScene.VectorTypes

TVector4i GLScene.VectorTypes

TVector4p GLScene.VectorTypes

TVector4s GLScene.VectorTypes

TVector4sb GLScene.VectorTypes

TVector4ui GLScene.VectorTypes

TVector4w GLScene.VectorTypes

TVectorHelper GLScene.VectorTypesExt

TVectorRec GLScene.VectorTypesExt

TVertexData Formats.B3D

TVertexRec GLScene.VectorTypesExt

TVertexWeightList GLS.FileMS3D

TVGradientBgnd3DS Formats.m3DSTypes

TVIDEOHDR Formats.VFW

TViewport3DS Formats.m3DSTypes

Viewport structure details the kind of View in a viewport
TViewportData Formats.m3DSTypes

TViewportLayout Formats.m3DSTypes

TViewportSize Formats.m3DSTypes

TViewSize3DS Formats.m3DSTypes

TViewStandard Formats.m3DSTypes

TViewUser Formats.m3DSTypes

TVORFace GLS.FileVOR

TVORHeader GLS.FileVOR

TVoxelRec GLScene.VectorTypesExt

TVRMLIntegerArray Formats.VRML

TVRMLMaterial Formats.VRML

TVRMLNode Formats.VRML

TVRMLParser Formats.VRML

TVRMLShapeHints Formats.VRML

TVRMLSingleArray Formats.VRML

TVRMLTransform Formats.VRML

TVRMLUse Formats.VRML

TVRTSChunk Formats.B3D

TWindowsIO SDL.Import

TWindowsIOBuffer SDL.Import

TXCollection GLScene.XCollection

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility
TXCollectionEditorForm FmXCollectionEditor

TXCollectionItem GLScene.XCollection

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation
TXCollectionProperty GLS.XCollectionRegister

TXDataEntry Formats.m3DSTypes

TXDataRaw3DS Formats.m3DSTypes

TZLibArchive GLS.FileZLIB

TZLibHeader GLS.FileZLIB

Signature for compressed zlib.
T_cl_command_queue OpenCL.Import

T_cl_context OpenCL.Import

T_cl_device_id OpenCL.Import

T_cl_event OpenCL.Import

T_cl_kernel OpenCL.Import

T_cl_mem OpenCL.Import

T_cl_platform_id OpenCL.Import

T_cl_program OpenCL.Import

T_cl_sampler OpenCL.Import

_CGcontext Cg.Import

_CGparameter Cg.Import

_CGprogram Cg.Import

_EFXEAXREVERBPROPERTIES OpenAL.Import

END EFX AEX extension EFX utils version 1.0
_EFXLOWPASSFILTER OpenAL.Import

_WGLSWAP GLScene.OpenGL4

_WGLSWAP GLScene.OpenGLTokens

__GLsync OpenCL.GL


GLSysHelp v.2.5: All Types

All Types

Name Unit Description
BOOL BASS.Import

ByteElement CUDA.DataAccess

CGbool Cg.Import

CGcontext Cg.Import

CGenum Cg.Import

CGerror Cg.Import

CGerrorCallbackFunc Cg.Import

CGGLenum Cg.GL

CGLAbstractShaderUniform GLS.MaterialEx

CGLBaseMaterialCollectionItem GLS.MaterialEx

CGparameter Cg.Import

CGprofile Cg.Import

CGprogram Cg.Import

CGresource Cg.Import

CGtype Cg.Import

CG_DATATYPE_MACRO(Bool4x4,bool4x4,CG_BOOL4x4,4,4)
CLogSession GLScene.Logger

Class reference to log session class
ComponentNameString gnugettext

cudaError_t CUDA.Runtime

+//DEVICE_BUILTIN*/
cudaEvent_t CUDA.Runtime

+//DEVICE_BUILTIN*/
cudaStream_t CUDA.Runtime

+//DEVICE_BUILTIN*/
dFloat Newton.Import

dFloat64 Newton.Import

dLong Newton.Import

DomainString gnugettext

DoubleElement CUDA.DataAccess

DOWNLOADPROC BASS.Import

User file stream callback function. action : The action to perform, one of BASS_FILE_xxx values. param1 : Depends on "action" param2 : Depends on "action" user : The 'user' parameter value given when calling BASS_StreamCreate RETURN : Depends on "action"
DSPPROC BASS.Import

Sync callback function. NOTE: a sync callback function should be very quick as other syncs cannot be processed until it has finished. If the sync is a "mixtime" sync, then other streams and MOD musics can not be mixed until it's finished either. handle : The sync that has occured channel: Channel that the sync occured in data : Additional data associated with the sync's occurance user : The 'user' parameter given when calling BASS_ChannelSetSync
DSPROPERTY_EAX_BUFFERPROPERTY OpenAL.Import

DSPROPERTY_EAX_LISTENERPROPERTY OpenAL.Import

EAX extension
DWORD BASS.Import

DWord SDL.Import

EFXEAXREVERBPROPERTIES OpenAL.Import

EFXLOWPASSFILTER OpenAL.Import

EGLOSError GLScene.Utils

EOpenALError GLS.Sounds.OpenAL

FILECLOSEPROC BASS.Import

User file stream callback functions
FILELENPROC BASS.Import

FilenameString gnugettext

FILEREADPROC BASS.Import

FILESEEKPROC BASS.Import

Float Newton.Import

Float SDL.Import

FloatElement CUDA.DataAccess

FSOUND_SPEAKERMODES FMOD.types

The audio is played through a speaker arrangement of surround speakers with a subwoofer.
GLbitfield GLScene.OpenGL4

GLboolean GLScene.OpenGL4

GLbyte GLScene.OpenGL4

GLclampd GLScene.OpenGL4

GLclampf GLScene.OpenGL4

GLdouble GLScene.OpenGL4

GLenum GLScene.OpenGL4

GLfloat GLScene.OpenGL4

GLhandleARB GLScene.OpenGL4

GLint GLScene.OpenGL4

GLint64 GLScene.OpenGL4

GLint64EXT GLScene.OpenGL4

GLshort GLScene.OpenGL4

GLsizei GLScene.OpenGL4

GLubyte GLScene.OpenGL4

GLuint GLScene.OpenGL4

GLuint64 GLScene.OpenGL4

GLuint64EXT GLScene.OpenGL4

GLushort GLScene.OpenGL4

HalfElement CUDA.DataAccess

HCHANNEL BASS.Import

sample handle
HDRAWDIB Formats.VFW

************************************************************************* * * DRAWDIB - Routines for drawing to the display. * ************************************************************************
HDSP BASS.Import

synchronizer handle
HFX BASS.Import

DSP handle
HGPUNV CUDA.Import

HGPUNV GLScene.OpenGL4

HGPUNV GLScene.OpenGLTokens

HIC Formats.VFW

HMODULE OpenAL.Import

HMUSIC BASS.Import

HPBUFFERARB GLScene.OpenGL4

HPBUFFERARB GLScene.OpenGLTokens

HPLUGIN BASS.Import

effect handle
HRECORD BASS.Import

sample stream handle
HSAMPLE BASS.Import

MOD music handle
HSTREAM BASS.Import

sample playback handle
HSYNC BASS.Import

recording handle
HVIDEO Formats.VFW

== VIDEO - Video capture driver interface ===================================
HVIDEOINPUTDEVICENV GLScene.OpenGL4

HVIDEOINPUTDEVICENV GLScene.OpenGLTokens

int Formats.VFW

IntElement CUDA.DataAccess

intptr_t OpenCL.Platform

LanguageString gnugettext

LONG Formats.VFW

MsgIdString gnugettext

NewtonAllocMemory Newton.Import

Newton callback functions
NewtonApplyForceAndTorque Newton.Import

NewtonBallCallback Newton.Import

NewtonBodyDestructor Newton.Import

NewtonBodyIterator Newton.Import

NewtonCollisionCopyConstructionCallback Newton.Import

NewtonCollisionDestructorCallback Newton.Import

NewtonCollisionIterator Newton.Import

NewtonCollisionTreeRayCastCallback Newton.Import

NewtonConstraintDestructor Newton.Import

NewtonContactsProcess Newton.Import

NewtonCorkscrewCallback Newton.Import

NewtonCreateContactCallback Newton.Import

NewtonDeserializeCallback Newton.Import

NewtonDestroyContactCallback Newton.Import

NewtonFractureCompoundCollisionOnEmitChunk Newton.Import

NewtonFractureCompoundCollisionOnEmitCompoundFractured Newton.Import

NewtonFractureCompoundCollisionReconstructMainMeshCallBack Newton.Import

NewtonFreeMemory Newton.Import

NewtonGetTimeInMicrosencondsCallback Newton.Import

NewtonHeightFieldRayCastCallback Newton.Import

NewtonHingeCallback Newton.Import

NewtonIslandUpdate Newton.Import

NewtonJobTask Newton.Import

NewtonJointIterator Newton.Import

NewtonOnAABBOverlap Newton.Import

NewtonOnBodyDeserializationCallback Newton.Import

NewtonOnBodySerializationCallback Newton.Import

NewtonOnCompoundSubCollisionAABBOverlap Newton.Import

NewtonOnContactGeneration Newton.Import

NewtonOnJointDeserializationCallback Newton.Import

NewtonOnJointSerializationCallback Newton.Import

NewtonOnUserCollisionSerializationCallback Newton.Import

user collision callbacks
NewtonPostUpdateCallback Newton.Import

NewtonReportProgress Newton.Import

NewtonSerializeCallback Newton.Import

NewtonSetTransform Newton.Import

NewtonSliderCallback Newton.Import

NewtonTreeCollisionCallback Newton.Import

NewtonTreeCollisionFaceCallback Newton.Import

NewtonUniversalCallback Newton.Import

NewtonUserBilateralCallback Newton.Import

NewtonUserBilateralGetInfoCallback Newton.Import

NewtonUserMeshCollisionAABBTest Newton.Import

NewtonUserMeshCollisionCollideCallback Newton.Import

NewtonUserMeshCollisionDestroyCallback Newton.Import

NewtonUserMeshCollisionGetCollisionInfo Newton.Import

NewtonUserMeshCollisionGetFacesInAABB Newton.Import

NewtonUserMeshCollisionRayHitCallback Newton.Import

NewtonWorldDestroyListenerCallback Newton.Import

NewtonWorldDestructorCallback Newton.Import

NewtonWorldListenerBodyDestroyCallback Newton.Import

NewtonWorldListenerDebugCallback Newton.Import

NewtonWorldRayFilterCallback Newton.Import

NewtonWorldRayPrefilterCallback Newton.Import

NewtonWorldUpdateListenerCallback Newton.Import

PAABB GLScene.GeometryBB

PAArray GLS.zBuffer

PACubic3DS Formats.m3DSTypes

used by AddMaterial3DS
PAffineByteVector GLScene.VectorGeometry

PAffineDblVector GLScene.VectorGeometry

PAffineExtVector GLScene.VectorGeometry

PAffineFltVector GLScene.VectorGeometry

PAffineIntVector GLScene.VectorGeometry

PAffineMatrix GLScene.VectorGeometry

PAffinePtrVector GLScene.VectorGeometry

PAffineVector GLScene.VectorGeometry

PAffineVectorArray GLScene.VectorGeometry

Arrays of vectors
PAffineWordVector GLScene.VectorGeometry

PALbitfield OpenAL.Import

PALboolean OpenAL.Import

PALbyte OpenAL.Import

PALCboolean OpenAL.Import

PALCbyte OpenAL.Import

PALCchar OpenAL.Import

PALCcontext OpenAL.Import

PALCdevice OpenAL.Import

PALCdouble OpenAL.Import

PALCenum OpenAL.Import

PALCfloat OpenAL.Import

PALchar OpenAL.Import

PALCint OpenAL.Import

PALclampd OpenAL.Import

PALclampf OpenAL.Import

PALCshort OpenAL.Import

PALCsizei OpenAL.Import

PALCubyte OpenAL.Import

PALCuint OpenAL.Import

PALCushort OpenAL.Import

PALCvoid OpenAL.Import

PALdouble OpenAL.Import

PALenum OpenAL.Import

PALfloat OpenAL.Import

PALint OpenAL.Import

PALshort OpenAL.Import

PALsizei OpenAL.Import

PALuByte OpenAL.Import

PALuint OpenAL.Import

PALushort OpenAL.Import

PALvoid OpenAL.Import

PANG4 Formats.LWO

PANIMChunk Formats.B3D

PAtmosphere3DS Formats.m3DSTypes

PAVICOMPRESSOPTIONS Formats.VFW

Make sure it matches the AutoDoc in avisave.c !!!
PAVIFileInfo Formats.VFW

PAVIFileInfoA Formats.VFW

PAVIFileInfoW Formats.VFW

– AVIFILEINFO ————————————————————–
PAVIINDEXENTRY Formats.VFW

these bits are for compressor use
PAVIPALCHANGE Formats.VFW

– Palette change chunk (used in video streams) —————————–
PAVIStream GLS.AVIRecorder

PAVIStreamHeader Formats.VFW

PAVIStreamInfo Formats.VFW

PAVIStreamInfoA Formats.VFW

PAVIStreamInfoW Formats.VFW

for Unicode/Ansi thunking we need to declare three versions of this!
PB3DChunk Formats.B3D

PBackground3DS Formats.m3DSTypes

PBASS_PLUGINFORMS BASS.Import

PBASS_PLUGININFO BASS.Import

PBB3DChunk Formats.B3D

PBitmap3DS Formats.m3DSTypes

Cubic reflection Map defintion
PBitmapBgnd3DS Formats.m3DSTypes

PBitMapName Formats.m3DSTypes

PBONEChunk Formats.B3D

PBoundBox Formats.m3DSTypes

PBRUSChunk Formats.B3D

PBSPFace Formats.Q3BSP

PBSPLightmap Formats.Q3BSP

PBSPTexture Formats.Q3BSP

PBSPVertex Formats.Q3BSP

PByteArray GLScene.VectorGeometry

PByteRaster GLS.HeightData

PByteVector GLScene.VectorGeometry

Types to specify continous streams of a specific type switch off range checking to access values beyond the limits
PCamera3DS Formats.m3DSTypes

PCamRanges Formats.m3DSTypes

PCamRanges3DS Formats.m3DSTypes

Camera atomosphere Ranges
PCAPDRIVERCAPS Formats.VFW

– Structures —————————————————————
PCAPINFOCHUNK Formats.VFW

No master
PCAPSTATUS Formats.VFW

PCAPTUREPARMS Formats.VFW

Default values in parenthesis
PCardinalArray Formats.m3DSTypes

PCardinalArray GLScene.VectorGeometry

PCardinalVector GLScene.VectorGeometry

PCGcontext Cg.Import

PCGerror Cg.Import

* The following macro invocations define error codes returned by various cg * API functions. * * The macros have the form : * * CG_ERROR_MACRO(code, enum_name, message) * * code : The integer error code associated with the error. * enum_name : The name of enumerant of the error code in the API. * message : A description string associated with the error. *
PCGparameter Cg.Import

PCGprogram Cg.Import

PCHANNEL_CAPS Formats.VFW

– Channel capabilities structure ——————————————-
PChar3DS Formats.m3DSTypes

PCharCG Cg.Import

***********************************************************************
PCharInfo GLS.BitmapFont

PChunk3DS Formats.m3DSTypes

PChunkList Formats.m3DSTypes

PChunkList3DS Formats.m3DSTypes

PChunkListEntry3DS Formats.m3DSTypes

internal database representation of file information
Pcl_addressing_mode OpenCL.Import

Pcl_bitfield OpenCL.Import

Pcl_bool OpenCL.Import

* WARNING! Unlike cl_ types in cl_platform.h, cl_bool is not guaranteed to be the same size as the bool in kernels. *//
Pcl_buffer_create_type OpenCL.Import

Pcl_buffer_region OpenCL.Import

Pcl_build_status OpenCL.Import

Pcl_channel_order OpenCL.Import

Pcl_channel_type OpenCL.Import

Pcl_char OpenCL.Platform

Pcl_command_queue OpenCL.Import

Pcl_command_queue_info OpenCL.Import

Pcl_command_queue_properties OpenCL.Import

Pcl_command_type OpenCL.Import

Pcl_context OpenCL.Import

Pcl_context_info OpenCL.Import

Pcl_context_properties OpenCL.Import

Pcl_device_affinity_domain OpenCL.Import

Pcl_device_exec_capabilities OpenCL.Import

Pcl_device_fp_config OpenCL.Import

Pcl_device_id OpenCL.Import

Pcl_device_info OpenCL.Import

Pcl_device_local_mem_type OpenCL.Import

Pcl_device_mem_cache_type OpenCL.Import

Pcl_device_partition_property OpenCL.Import

Pcl_device_svm_capabilities OpenCL.Import

Pcl_device_type OpenCL.Import

Pcl_double OpenCL.Platform

Pcl_event OpenCL.Import

Pcl_event_info OpenCL.Import

Pcl_filter_mode OpenCL.Import

Pcl_float OpenCL.Platform

Pcl_GLsync OpenCL.GL

Pcl_gl_context_info OpenCL.GL

Pcl_gl_object_type OpenCL.GL

Pcl_gl_platform_info OpenCL.GL

Pcl_gl_texture_info OpenCL.GL

Pcl_half OpenCL.Platform

Pcl_image_desc OpenCL.Import

Pcl_image_format OpenCL.Import

Pcl_image_info OpenCL.Import

Pcl_int OpenCL.Platform

Pcl_kernel OpenCL.Import

Pcl_kernel_arg_access_qualifier OpenCL.Import

Pcl_kernel_arg_address_qualifier OpenCL.Import

Pcl_kernel_arg_info OpenCL.Import

Pcl_kernel_arg_type_qualifier OpenCL.Import

Pcl_kernel_exec_info OpenCL.Import

Pcl_kernel_info OpenCL.Import

Pcl_kernel_sub_group_info OpenCL.Import

Pcl_kernel_work_group_info OpenCL.Import

Pcl_long OpenCL.Platform

Pcl_map_flags OpenCL.Import

Pcl_mem OpenCL.Import

Pcl_mem_flags OpenCL.Import

Pcl_mem_info OpenCL.Import

Pcl_mem_migration_flag OpenCL.Import

Pcl_mem_object_type OpenCL.Import

Pcl_pipe_info OpenCL.Import

Pcl_pipe_properties OpenCL.Import

Pcl_platform_id OpenCL.Import

Pcl_platform_info OpenCL.Import

Pcl_profiling_info OpenCL.Import

Pcl_program OpenCL.Import

Pcl_program_binary_type OpenCL.Import

Pcl_program_build_info OpenCL.Import

Pcl_program_info OpenCL.Import

Pcl_queue_properties OpenCL.Import

Pcl_sampler OpenCL.Import

Pcl_sampler_info OpenCL.Import

Pcl_sampler_properties OpenCL.Import

Pcl_short OpenCL.Platform

Pcl_svm_mem_flags OpenCL.Import

Pcl_uchar OpenCL.Platform

Pcl_uint OpenCL.Platform

Pcl_ulong OpenCL.Platform

Pcl_ushort OpenCL.Platform

PColor24 Formats.m3DSTypes

PColorF Formats.m3DSTypes

inner datatypes not followed by a '3DS' to show they are locally used (mostly as a part of another chunk or while collecting specific data)
PColr12 Formats.LWO

PColr4 Formats.LWO

PColTrackTag Formats.m3DSTypes

PCOMPVARS Formats.VFW

Structure used by ICSeqCompressFrame and ICCompressorChoose routines Make sure this matches the autodoc in icm.c!
PCUarray CUDA.Import

CUDA array
PCUcontext CUDA.Import

CUDA context
PcudaArray CUDA.Runtime

PcudaChannelFormatDesc CUDA.Runtime

+//DEVICE_BUILTIN*/
PCudaDeviceProp CUDA.Runtime

+//DEVICE_BUILTIN*/
PCUDA_ARRAY_DESCRIPTOR CUDA.Import

Array descriptor
PCUDA_MEMCPY2D CUDA.Import

2D memory copy parameters
PCUevent CUDA.Import

CUDA event
PcufftComplex CUDA.FourierTransform

PcufftDoubleComplex CUDA.FourierTransform

PcufftDoubleReal CUDA.FourierTransform

PcufftReal CUDA.FourierTransform

PCUfunction CUDA.Import

CUDA function
PCUgraphicsResource CUDA.Import

PCUmodule CUDA.Import

CUDA module
PCUstream CUDA.Import

CUDA stream
PCUtexref CUDA.Import

CUDA texture reference
Pd3Axis ODE.Import

PDatabase3DS Formats.m3DSTypes

PdContact ODE.Import

PdContactGeom ODE.Import

PDCueSettings3DS Formats.m3DSTypes

PdFloat Newton.Import

PdFloat64 Newton.Import

PdGeomClass ODE.Import

PdInteger3 ODE.Import

PdIntegerArray ODE.Import

PDistanceCue Formats.m3DSTypes

PDlExclude Formats.m3DSTypes

PDlInnerRange Formats.m3DSTypes

PDlLocalShadow2 Formats.m3DSTypes

PDlMultiplier Formats.m3DSTypes

PdLong Newton.Import

PDlOuterRange Formats.m3DSTypes

PDlRayBias Formats.m3DSTypes

PDlSpotAspect Formats.m3DSTypes

PDlSpotlight Formats.m3DSTypes

PDlSpotProjector Formats.m3DSTypes

PDlSpotRoll Formats.m3DSTypes

PdMass ODE.Import

PdMatrix3 ODE.Import

PdMatrix3_As3x4 ODE.Import

PdMatrix4 ODE.Import

PdMatrix6 ODE.Import

PdObject ODE.Import

PDoubleArray GLScene.VectorGeometry

PDoubleVector GLScene.VectorGeometry

PdQuaternion ODE.Import

array[0..3] of TdReal;
PDRAWDIBTIME Formats.VFW

– DrawDibTime() - for debugging purposes only ——————————
PdReal ODE.Import

PdRealArray ODE.Import

PdRealHugeArray ODE.Import

PdVector3 ODE.Import

Q: Why isn't TdVector3 = array[0..2] of TdReal? A: Because of SIMD alignment.
PdVector3Array ODE.Import

PdVector4 ODE.Import

PdxBody ODE.Import

PdxGeom ODE.Import

PdxHashSpace ODE.Import

//currently the space 'container' is just a list of the geoms in the space. struct dxHashSpace : public dxSpace { dxGeom *first; int global_minlevel; // smallest hash table level to put AABBs in int global_maxlevel; // objects that need a level larger than this will be // put in a "big objects" list instead of a hash table void destroy(); void add (dGeomID); void remove (dGeomID); void collide (void *data, dNearCallback *callback); int query (dGeomID); };
PdxHeightfieldData ODE.Import

PdxJoint ODE.Import

PdxJointBall ODE.Import

PdxJointGroup ODE.Import

Pointers to internal ODE structures to reproduce C++ classes in Delphi
PdxJointHinge ODE.Import

PdxJointHinge2 ODE.Import

PdxJointLimitMotor ODE.Import

PdxJointLimitMotor3 ODE.Import

PdxJointNode ODE.Import

PdxJointPiston ODE.Import

PdxJointPR ODE.Import

PdxJointSlider ODE.Import

PdxJointUniversial ODE.Import

PdxPosR ODE.Import

position vector and rotation matrix for geometry objects that are not connected to bodies.
PdxSimpleSpace ODE.Import

//simple space - reports all nˆ2 object intersections struct dxSimpleSpace : public dxSpace { dGeomID first; void destroy(); void add (dGeomID); void remove (dGeomID); void collide (void *data, dNearCallback *callback); int query (dGeomID); };
PdxSpace ODE.Import

struct dxSpace : public dBase { int type; // don't want to use RTTI virtual void destroy()=0; virtual void add (dGeomID)=0; virtual void remove (dGeomID)=0; virtual void collide (void *data, dNearCallback *callback)=0; virtual int query (dGeomID)=0; };
PDXT3AlphaBlock Formats.DXTC

PDXT5AlphaBlock Formats.DXTC

PDXTColBlock Formats.DXTC

PdxTriMeshData ODE.Import

PdxWorld ODE.Import

PEaxBufferProperties OpenAL.Import

PEaxListenerProperties OpenAL.Import

PEFXEAXREVERBPROPERTIES OpenAL.Import

PEFXLOWPASSFILTER OpenAL.Import

PExtendedArray GLScene.VectorGeometry

PExtendedVector GLScene.VectorGeometry

PF4 Formats.LWO

PF4Array Formats.LWO

PFace3DS Formats.m3DSTypes

PFaceArray Formats.m3DSTypes

PFaceList Formats.m3DSTypes

PFallTrackTag Formats.m3DSTypes

PFastCollisionChecker GLS.Collision

PFColor3DS Formats.m3DSTypes

PFColorList Formats.m3DSTypes

PFloat GLScene.VectorGeometry

Data types needed for 3D graphics calculation, included are 'C like' aliases for each type (to be conformal with OpenGL types)
PFloat Newton.Import

PFloat SDL.Import

PFloatArray GLScene.VectorGeometry

PFloatPercentage Formats.m3DSTypes

PFloatVector GLScene.VectorGeometry

PFMusicModule FMOD.types

PFNGLACTIVESHADERPROGRAMPROC GLScene.OpenGLTokens

PFNGLACTIVESTENCILFACEEXTPROC GLScene.OpenGLTokens

GL_EXT_stencil_two_side (EXT #268)
PFNGLACTIVETEXTUREARBPROC GLScene.OpenGLTokens

GL_ARB_multitexture (ARB #1)
PFNGLACTIVETEXTUREPROC GLScene.OpenGLTokens

deprecated; core 1.3 promoted to core v1.3 from GL_ARB_multitexture (#1)
PFNGLACTIVEVARYINGNVPROC GLScene.OpenGLTokens

PFNGLADDSWAPHINTRECTWINPROC GLScene.OpenGLTokens

GL_WIN_swap_hint (extension # not found)
PFNGLAREPROGRAMSRESIDENTNVPROC GLScene.OpenGLTokens

GL_NV_vertex_program (EXT #233)
PFNGLARETEXTURESRESIDENTEXTPROC GLScene.OpenGLTokens

PFNGLARRAYELEMENTARRAYEXTPROC GLScene.OpenGLTokens

EXT/Vendor extensions Unknown Vendor/EXT functions
PFNGLATTACHOBJECTARBPROC GLScene.OpenGLTokens

PFNGLATTACHSHADERPROC GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)
PFNGLBEGINCONDITIONALRENDERNVPROC GLScene.OpenGLTokens

GL_NV_conditional_render (EXT #346)
PFNGLBEGINCONDITIONALRENDERPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_NV_conditional_render
PFNGLBEGINOCCLUSIONQUERYNVPROC GLScene.OpenGLTokens

PFNGLBEGINQUERYARBPROC GLScene.OpenGLTokens

PFNGLBEGINQUERYINDEXEDPROC GLScene.OpenGLTokens

PFNGLBEGINQUERYPROC GLScene.OpenGLTokens

PFNGLBEGINSCENEEXTPROC GLScene.OpenGLTokens

GL_EXT_scene_marker (EXT #120)
PFNGLBEGINTRANSFORMFEEDBACKEXTPROC GLScene.OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKNVPROC GLScene.OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLBINDATTRIBLOCATIONARBPROC GLScene.OpenGLTokens

GL_ARB_vertex_shader (ARB #31)
PFNGLBINDATTRIBLOCATIONPROC GLScene.OpenGLTokens

PFNGLBINDBUFFERARBPROC GLScene.OpenGLTokens

GL_ARB_vertex_buffer_object (ARB #28)
PFNGLBINDBUFFERBASEEXTPROC GLScene.OpenGLTokens

PFNGLBINDBUFFERBASENVPROC GLScene.OpenGLTokens

PFNGLBINDBUFFERBASEPROC GLScene.OpenGLTokens

PFNGLBINDBUFFEROFFSETEXTPROC GLScene.OpenGLTokens

PFNGLBINDBUFFEROFFSETNVPROC GLScene.OpenGLTokens

PFNGLBINDBUFFERPROC GLScene.OpenGLTokens

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)
PFNGLBINDBUFFERRANGEEXTPROC GLScene.OpenGLTokens

GL_EXT_transform_feedback (EXT #352)
PFNGLBINDBUFFERRANGENVPROC GLScene.OpenGLTokens

GL_NV_transform_feedback (EXT #341)
PFNGLBINDBUFFERRANGEPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_transform_feedback
PFNGLBindBuffersBase GLScene.OpenGLTokens

PFNGLBindBuffersRange GLScene.OpenGLTokens

PFNGLBINDFRAGDATALOCATIONEXTPROC GLScene.OpenGLTokens

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC GLScene.OpenGLTokens

GL_ARB_blend_func_extended (ARB #78)
PFNGLBINDFRAGDATALOCATIONPROC GLScene.OpenGLTokens

PFNGLBINDFRAMEBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLBINDFRAMEBUFFERPROC GLScene.OpenGLTokens

PFNGLBindImageTextures GLScene.OpenGLTokens

PFNGLBINDMULTITEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLBINDPROGRAMARBPROC GLScene.OpenGLTokens

PFNGLBINDPROGRAMNVPROC GLScene.OpenGLTokens

PFNGLBINDPROGRAMPIPELINEPROC GLScene.OpenGLTokens

PFNGLBINDRENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLBINDRENDERBUFFERPROC GLScene.OpenGLTokens

PFNGLBINDSAMPLERPROC GLScene.OpenGLTokens

PFNGLBindSamplers GLScene.OpenGLTokens

PFNGLBINDTEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLBindTextures GLScene.OpenGLTokens

PFNGLBINDTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

GL_ARB_transform_feedback2 (ARB #93)
PFNGLBINDVERTEXARRAYPROC GLScene.OpenGLTokens

GL_ARB_vertex_array_object (ARB #54)
PFNGLBindVertexBuffer GLScene.OpenGLTokens

GL_ARB_vertex_attrib_binding (ARB #125)
PFNGLBindVertexBuffers GLScene.OpenGLTokens

PFNGLBLENDCOLOREXTPROC GLScene.OpenGLTokens

GL_EXT_blend_color (EXT #2)
PFNGLBLENDCOLORPROC GLScene.OpenGLTokens

====================================================================== core 1.2 promoted to core v1.2 from GL_EXT_blend_color (#2)
PFNGLBLENDEQUATIONEXTPROC GLScene.OpenGLTokens

GL_EXT_blend_minmax (EXT #37)
PFNGLBLENDEQUATIONIARBPROC GLScene.OpenGLTokens

GL_ARB_draw_buffers_blend (ARB #69)
PFNGLBLENDEQUATIONIPROC GLScene.OpenGLTokens

Core 4.0 promoted to core v4.0 from GL_ARB_draw_buffers_blend (ARB #69)
PFNGLBLENDEQUATIONPROC GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_blend_minmax (#37)
PFNGLBLENDEQUATIONSEPARATEEXTPROC GLScene.OpenGLTokens

GL_EXT_blend_equation_separate (EXT #299)
PFNGLBLENDEQUATIONSEPARATEIARBPROC GLScene.OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEIPROC GLScene.OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEPROC GLScene.OpenGLTokens

core 2.0 promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)
PFNGLBLENDFUNCIARBPROC GLScene.OpenGLTokens

PFNGLBLENDFUNCIPROC GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEEXTPROC GLScene.OpenGLTokens

GL_EXT_blend_func_separate (EXT #173)
PFNGLBLENDFUNCSEPARATEIARBPROC GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEIPROC GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEPROC GLScene.OpenGLTokens

deprecated; core 1.4 promoted to core v1.4 from GL_EXT_blend_func_separate (#173)
PFNGLBLITFRAMEBUFFEREXTPROC GLScene.OpenGLTokens

GL_EXT_framebuffer_blit (EXT #316)
PFNGLBLITFRAMEBUFFERPROC GLScene.OpenGLTokens

PFNGLBUFFERADDRESSRANGENVPROC GLScene.OpenGLTokens

GL_NV_vertex_buffer_unified_memory (EXT #380)
PFNGLBUFFERDATAARBPROC GLScene.OpenGLTokens

PFNGLBUFFERDATAPROC GLScene.OpenGLTokens

PFNGLBufferStorage GLScene.OpenGLTokens

PFNGLBUFFERSUBDATAARBPROC GLScene.OpenGLTokens

PFNGLBUFFERSUBDATAPROC GLScene.OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC GLScene.OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSPROC GLScene.OpenGLTokens

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC GLScene.OpenGLTokens

PFNGLCLAMPCOLORARBPROC GLScene.OpenGLTokens

GL_ARB_color_buffer_float (ARB #39)
PFNGLCLAMPCOLORPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_ARB_color_buffer_float
PFNGLClearBufferData GLScene.OpenGLTokens

GL_ARB_clear_buffer_object (ARB #121)
PFNGLCLEARBUFFERFIPROC GLScene.OpenGLTokens

PFNGLCLEARBUFFERFVPROC GLScene.OpenGLTokens

PFNGLCLEARBUFFERIVPROC GLScene.OpenGLTokens

New commands in OpenGL 3.0
PFNGLClearBufferSubData GLScene.OpenGLTokens

PFNGLCLEARBUFFERUIVPROC GLScene.OpenGLTokens

PFNGLCLEARCOLORIIEXTPROC GLScene.OpenGLTokens

GL_EXT_texture_integer (EXT #343)
PFNGLCLEARCOLORIUIEXTPROC GLScene.OpenGLTokens

PFNGLCLEARDEPTHFPROC GLScene.OpenGLTokens

PFNGLClearNamedBufferData GLScene.OpenGLTokens

PFNGLClearNamedBufferSubData GLScene.OpenGLTokens

PFNGLClearTexImage GLScene.OpenGLTokens

PFNGLClearTexSubImage GLScene.OpenGLTokens

PFNGLCLIENTACTIVETEXTUREARBPROC GLScene.OpenGLTokens

PFNGLCLIENTACTIVETEXTUREPROC GLScene.OpenGLTokens

core 1.3 deprecated promoted to core v1.3 from GL_ARB_multitexture (#1)
PFNGLCLIENTATTRIBDEFAULTEXTPROC GLScene.OpenGLTokens

GL_EXT_direct_state_access
PFNGLCLIENTWAITSYNCPROC GLScene.OpenGLTokens

PFNGLCOLORFORMATNVPROC GLScene.OpenGLTokens

PFNGLCOLORMASKINDEXEDEXTPROC GLScene.OpenGLTokens

GL_EXT_draw_buffers2 (EXT #340)
PFNGLCOLORMASKIPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_draw_buffers2
PFNGLCOLORP3UIPROC GLScene.OpenGLTokens

PFNGLCOLORP3UIVPROC GLScene.OpenGLTokens

PFNGLCOLORP4UIPROC GLScene.OpenGLTokens

PFNGLCOLORP4UIVPROC GLScene.OpenGLTokens

PFNGLCOLORSUBTABLEEXTPROC GLScene.OpenGLTokens

PFNGLCOLORSUBTABLEPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)
PFNGLCOLORTABLEEXTPROC GLScene.OpenGLTokens

GL_EXT_paletted_texture (EXT #78)
PFNGLCOLORTABLEPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOLORTABLEPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOLORTABLEPROC GLScene.OpenGLTokens

core 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)
PFNGLCOMBINERINPUTNVPROC GLScene.OpenGLTokens

PFNGLCOMBINEROUTPUTNVPROC GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERFNVPROC GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERFVNVPROC GLScene.OpenGLTokens

GL_NV_register_combiners (EXT #191)
PFNGLCOMBINERPARAMETERINVPROC GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLCOMPILESHADERARBPROC GLScene.OpenGLTokens

PFNGLCOMPILESHADERPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC GLScene.OpenGLTokens

GL_ARB_texture_compression (ARB #12)
PFNGLCOMPRESSEDTEXIMAGE3DPROC GLScene.OpenGLTokens

promoted to core v1.3 from GL_ARB_texture_compression (#12)
PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCONVOLUTIONFILTER1DPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)
PFNGLCONVOLUTIONFILTER2DPROC GLScene.OpenGLTokens

deprecated;
PFNGLCONVOLUTIONPARAMETERFPROC GLScene.OpenGLTokens

deprecated;
PFNGLCONVOLUTIONPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLCONVOLUTIONPARAMETERIPROC GLScene.OpenGLTokens

deprecated;
PFNGLCONVOLUTIONPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOPYBUFFERSUBDATAPROC GLScene.OpenGLTokens

GL_ARB_copy_buffer (ARB #59)
PFNGLCOPYCOLORSUBTABLEPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOPYCOLORTABLEPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOPYCONVOLUTIONFILTER1DPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOPYCONVOLUTIONFILTER2DPROC GLScene.OpenGLTokens

deprecated;
PFNGLCopyImageSubData GLScene.OpenGLTokens

GL_ARB_copy_image (ARB #123)
PFNGLCOPYIMAGESUBDATANVPROC GLScene.OpenGLTokens

GL_NV_copy_image (EXT #376)
PFNGLCOPYMULTITEXIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYMULTITEXIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYPATHNVPROC GLScene.OpenGLTokens

PFNGLCOPYTEXIMAGE1DEXTPROC GLScene.OpenGLTokens

GL_EXT_copy_texture (EXT #10)
PFNGLCOPYTEXIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DPROC GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_copy_texture
PFNGLCOPYTEXTUREIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXTUREIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOVERFILLPATHINSTANCEDNVPROC GLScene.OpenGLTokens

PFNGLCOVERFILLPATHNVPROC GLScene.OpenGLTokens

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC GLScene.OpenGLTokens

PFNGLCOVERSTROKEPATHNVPROC GLScene.OpenGLTokens

PFNGLCREATEPROGRAMOBJECTARBPROC GLScene.OpenGLTokens

PFNGLCREATEPROGRAMPROC GLScene.OpenGLTokens

PFNGLCREATESHADEROBJECTARBPROC GLScene.OpenGLTokens

PFNGLCREATESHADERPROC GLScene.OpenGLTokens

PFNGLCREATESHADERPROGRAMVPROC GLScene.OpenGLTokens

PFNGLCreateSyncFromCLevent GLScene.OpenGLTokens

GL_ARB_robustness_isolation (ARB #126) (no entry points) GL_ARB_cl_event (ARB #103)
PFNGLCURRENTPALETTEMATRIXARBPROC GLScene.OpenGLTokens

GL_ARB_matrix_palette (ARB #16) {deprecated?}
PFNGLDEBUGMESSAGECALLBACKARBPROC GLScene.OpenGLTokens

PFNGLDEBUGMESSAGECONTROLARBPROC GLScene.OpenGLTokens

GL_ARB_debug_output (ARB #104)
PFNGLDEBUGMESSAGEINSERTARBPROC GLScene.OpenGLTokens

PFNGLDELETEBUFFERSARBPROC GLScene.OpenGLTokens

PFNGLDELETEBUFFERSPROC GLScene.OpenGLTokens

PFNGLDELETEFENCESNVPROC GLScene.OpenGLTokens

PFNGLDELETEFRAMEBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLDELETEFRAMEBUFFERSPROC GLScene.OpenGLTokens

PFNGLDELETEOBJECTARBPROC GLScene.OpenGLTokens

GL_ARB_shader_objects (ARB #30)
PFNGLDELETEOCCLUSIONQUERIESNVPROC GLScene.OpenGLTokens

PFNGLDELETEPATHSNVPROC GLScene.OpenGLTokens

PFNGLDELETEPROGRAMPIPELINESPROC GLScene.OpenGLTokens

PFNGLDELETEPROGRAMPROC GLScene.OpenGLTokens

PFNGLDELETEPROGRAMSARBPROC GLScene.OpenGLTokens

PFNGLDELETEPROGRAMSNVPROC GLScene.OpenGLTokens

PFNGLDELETEQUERIESARBPROC GLScene.OpenGLTokens

PFNGLDELETEQUERIESPROC GLScene.OpenGLTokens

PFNGLDELETERENDERBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLDELETERENDERBUFFERSPROC GLScene.OpenGLTokens

PFNGLDELETESAMPLERSPROC GLScene.OpenGLTokens

PFNGLDELETESHADERPROC GLScene.OpenGLTokens

PFNGLDELETESYNCPROC GLScene.OpenGLTokens

PFNGLDELETETEXTURESEXTPROC GLScene.OpenGLTokens

PFNGLDELETETRANSFORMFEEDBACKSPROC GLScene.OpenGLTokens

PFNGLDELETEVERTEXARRAYSPROC GLScene.OpenGLTokens

PFNGLDEPTHBOUNDSEXTPROC GLScene.OpenGLTokens

GL_EXT_depth_bounds_test (EXT #297)
PFNGLDEPTHRANGEARRAYVPROC GLScene.OpenGLTokens

PFNGLDEPTHRANGEFPROC GLScene.OpenGLTokens

PFNGLDEPTHRANGEINDEXEDPROC GLScene.OpenGLTokens

PFNGLDETACHOBJECTARBPROC GLScene.OpenGLTokens

PFNGLDETACHSHADERPROC GLScene.OpenGLTokens

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLDISABLEINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLDISABLEIPROC GLScene.OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC GLScene.OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYPROC GLScene.OpenGLTokens

PFNGLDispatchCompute GLScene.OpenGLTokens

GL_ARB_compute_shader (ARB #122)
PFNGLDispatchComputeIndirect GLScene.OpenGLTokens

PFNGLDRAWARRAYSINDIRECTPROC GLScene.OpenGLTokens

GL_ARB_draw_indirect (ARB #87)
PFNGLDRAWARRAYSINSTANCEDARBPROC GLScene.OpenGLTokens

GL_ARB_draw_instanced (ARB #44)
PFNGLDRAWARRAYSINSTANCEDEXTPROC GLScene.OpenGLTokens

GL_EXT_draw_instanced (EXT #327)
PFNGLDRAWARRAYSINSTANCEDPROC GLScene.OpenGLTokens

Core 3.1 New commands in OpenGL 3.1
PFNGLDRAWBUFFERSARBPROC GLScene.OpenGLTokens

GL_ARB_DrawBuffers (ARB #37)
PFNGLDRAWBUFFERSATIPROC GLScene.OpenGLTokens

GL_ATI_draw_buffers (EXT #277)
PFNGLDRAWBUFFERSPROC GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_draw_buffers (#37)
PFNGLDRAWELEMENTSBASEVERTEXPROC GLScene.OpenGLTokens

GL_ARB_draw_elements_base_vertex (ARB #62)
PFNGLDRAWELEMENTSINDIRECTPROC GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDARBPROC GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDEXTPROC GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDPROC GLScene.OpenGLTokens

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC GLScene.OpenGLTokens

PFNGLDRAWRANGEELEMENTSEXTPROC GLScene.OpenGLTokens

GL_EXT_draw_range_elements (EXT #112)
PFNGLDRAWRANGEELEMENTSPROC GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)
PFNGLDRAWTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC GLScene.OpenGLTokens

GL_ARB_transform_feedback3 (ARB #94)
PFNGLEDGEFLAGFORMATNVPROC GLScene.OpenGLTokens

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLENABLEINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLENABLEIPROC GLScene.OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYARBPROC GLScene.OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYPROC GLScene.OpenGLTokens

PFNGLENDCONDITIONALRENDERNVPROC GLScene.OpenGLTokens

PFNGLENDCONDITIONALRENDERPROC GLScene.OpenGLTokens

PFNGLENDOCCLUSIONQUERYNVPROC GLScene.OpenGLTokens

PFNGLENDQUERYARBPROC GLScene.OpenGLTokens

PFNGLENDQUERYINDEXEDPROC GLScene.OpenGLTokens

PFNGLENDQUERYPROC GLScene.OpenGLTokens

PFNGLENDSCENEEXTPROC GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKEXTPROC GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKNVPROC GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLEXECUTEPROGRAMNVPROC GLScene.OpenGLTokens

PFNGLFENCESYNCPROC GLScene.OpenGLTokens

GL_ARB_sync (ARB #66)
PFNGLFINALCOMBINERINPUTNVPROC GLScene.OpenGLTokens

PFNGLFINISHFENCENVPROC GLScene.OpenGLTokens

PFNGLFLUSHMAPPEDBUFFERRANGEPROC GLScene.OpenGLTokens

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC GLScene.OpenGLTokens

PFNGLFLUSHVERTEXARRAYRANGENVPROC GLScene.OpenGLTokens

GL_NV_vertex_array_range (EXT #190)
PFNGLFOGCOORDDEXTPROC GLScene.OpenGLTokens

PFNGLFOGCOORDDPROC GLScene.OpenGLTokens

deprecated;
PFNGLFOGCOORDDVEXTPROC GLScene.OpenGLTokens

PFNGLFOGCOORDDVPROC GLScene.OpenGLTokens

deprecated;
PFNGLFOGCOORDFEXTPROC GLScene.OpenGLTokens

GL_EXT_fog_coord (EXT #149)
PFNGLFOGCOORDFORMATNVPROC GLScene.OpenGLTokens

PFNGLFOGCOORDFPROC GLScene.OpenGLTokens

core 1.4 deprecated promoted to core v1.4 from GL_EXT_fog_coord (#149)
PFNGLFOGCOORDFVEXTPROC GLScene.OpenGLTokens

PFNGLFOGCOORDFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLFOGCOORDPOINTEREXTPROC GLScene.OpenGLTokens

PFNGLFOGCOORDPOINTERPROC GLScene.OpenGLTokens

deprecated;
PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLFramebufferParameteri GLScene.OpenGLTokens

GL_ARB_debug_group ARB_debug_group reuses entry points from KHR_debug GL_ARB_debug_label ARB_debug_label reuses entry points from KHR_debug GL_ARB_debug_output2 GL_ARB_ES3_compatibility GL_ARB_explicit_uniform_location GL_ARB_fragment_layer_viewport GL_ARB_framebuffer_no_attachments (ARB #130)
PFNGLFRAMEBUFFERREADBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFERPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREARBPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREPROC GLScene.OpenGLTokens

PFNGLFRAMETERMINATORGREMEDYPROC GLScene.OpenGLTokens

GL_GREMEDY_frame_terminator (EXT #345)
PFNGLGENBUFFERSARBPROC GLScene.OpenGLTokens

PFNGLGENBUFFERSPROC GLScene.OpenGLTokens

PFNGLGENERATEMIPMAPEXTPROC GLScene.OpenGLTokens

PFNGLGENERATEMIPMAPPROC GLScene.OpenGLTokens

PFNGLGENERATEMULTITEXMIPMAPEXTPROC GLScene.OpenGLTokens

PFNGLGENERATETEXTUREMIPMAPEXTPROC GLScene.OpenGLTokens

PFNGLGENFENCESNVPROC GLScene.OpenGLTokens

GL_NV_fence (EXT #222)
PFNGLGENFRAMEBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLGENFRAMEBUFFERSPROC GLScene.OpenGLTokens

PFNGLGENOCCLUSIONQUERIESNVPROC GLScene.OpenGLTokens

GL_NV_occlusion_query (EXT #261)
PFNGLGENPATHSNVPROC GLScene.OpenGLTokens

GL_NV_path_rendering
PFNGLGENPROGRAMPIPELINESPROC GLScene.OpenGLTokens

PFNGLGENPROGRAMSARBPROC GLScene.OpenGLTokens

PFNGLGENPROGRAMSNVPROC GLScene.OpenGLTokens

PFNGLGENQUERIESARBPROC GLScene.OpenGLTokens

GL_ARB_occlusion_query (ARB #29)
PFNGLGENQUERIESPROC GLScene.OpenGLTokens

deprecated; core 1.5 promoted to core v1.5 from GL_ARB_occlusion_query (#29)
PFNGLGENRENDERBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLGENRENDERBUFFERSPROC GLScene.OpenGLTokens

PFNGLGENSAMPLERSPROC GLScene.OpenGLTokens

GL_ARB_sampler_objects (ARB #81)
PFNGLGENTEXTURESEXTPROC GLScene.OpenGLTokens

GL_EXT_texture_object (EXT #20)
PFNGLGENTRANSFORMFEEDBACKSPROC GLScene.OpenGLTokens

PFNGLGENVERTEXARRAYSPROC GLScene.OpenGLTokens

PFNGLGETACTIVEATTRIBARBPROC GLScene.OpenGLTokens

PFNGLGETACTIVEATTRIBPROC GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINENAMEPROC GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMARBPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKIVPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMNAMEPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMSIVPROC GLScene.OpenGLTokens

PFNGLGETACTIVEVARYINGNVPROC GLScene.OpenGLTokens

PFNGLGETATTACHEDOBJECTSARBPROC GLScene.OpenGLTokens

PFNGLGETATTACHEDSHADERSPROC GLScene.OpenGLTokens

PFNGLGETATTRIBLOCATIONARBPROC GLScene.OpenGLTokens

PFNGLGETATTRIBLOCATIONPROC GLScene.OpenGLTokens

PFNGLGETBOOLEANINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETBOOLEANI_VPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERI64VPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERIVARBPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERUI64VNVPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPOINTERVARBPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPOINTERVPROC GLScene.OpenGLTokens

PFNGLGETBUFFERSUBDATAARBPROC GLScene.OpenGLTokens

PFNGLGETBUFFERSUBDATAPROC GLScene.OpenGLTokens

PFNGLGETCOLORTABLEEXTPROC GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCOLORTABLEPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCOLORTABLEPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEPROC GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC GLScene.OpenGLTokens

PFNGLGETCONVOLUTIONFILTERPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCONVOLUTIONPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCONVOLUTIONPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETDEBUGMESSAGELOGARBPROC GLScene.OpenGLTokens

PFNGLGETDOUBLEINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETDOUBLEI_VPROC GLScene.OpenGLTokens

PFNGLGETFENCEIVNVPROC GLScene.OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLGETFLOATINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETFLOATI_VPROC GLScene.OpenGLTokens

PFNGLGETFRAGDATAINDEXPROC GLScene.OpenGLTokens

PFNGLGETFRAGDATALOCATIONEXTPROC GLScene.OpenGLTokens

PFNGLGETFRAGDATALOCATIONPROC GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLGetFramebufferParameteriv GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETGRAPHICSRESETSTATUSARBPROC GLScene.OpenGLTokens

GL_ARB_robustness (ARB #105)
PFNGLGETHANDLEARBPROC GLScene.OpenGLTokens

PFNGLGETHISTOGRAMPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETHISTOGRAMPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETHISTOGRAMPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)
PFNGLGETINFOLOGARBPROC GLScene.OpenGLTokens

PFNGLGETINTEGER64I_VPROC GLScene.OpenGLTokens

Core 3.2
PFNGLGETINTEGER64VPROC GLScene.OpenGLTokens

PFNGLGETINTEGERINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETINTEGERI_VPROC GLScene.OpenGLTokens

PFNGLGETINTEGERUI64I_VNVPROC GLScene.OpenGLTokens

PFNGLGETINTEGERUI64VNVPROC GLScene.OpenGLTokens

PFNGLGetInternalformati64v GLScene.OpenGLTokens

GL_ARB_internalformat_query2 (ARB #131)
PFNGLGETMINMAXPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETMINMAXPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETMINMAXPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETMULTISAMPLEFVPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXENVFVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXENVIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXGENDVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXGENFVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXGENIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXIMAGEEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGetNamedFramebufferParameteriv GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNCOLORTABLEARBPROC GLScene.OpenGLTokens

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC GLScene.OpenGLTokens

PFNGLGETNCONVOLUTIONFILTERARBPROC GLScene.OpenGLTokens

PFNGLGETNHISTOGRAMARBPROC GLScene.OpenGLTokens

PFNGLGETNMAPDVARBPROC GLScene.OpenGLTokens

PFNGLGETNMAPFVARBPROC GLScene.OpenGLTokens

PFNGLGETNMAPIVARBPROC GLScene.OpenGLTokens

PFNGLGETNMINMAXARBPROC GLScene.OpenGLTokens

PFNGLGETNPIXELMAPFVARBPROC GLScene.OpenGLTokens

PFNGLGETNPIXELMAPUIVARBPROC GLScene.OpenGLTokens

PFNGLGETNPIXELMAPUSVARBPROC GLScene.OpenGLTokens

PFNGLGETNPOLYGONSTIPPLEARBPROC GLScene.OpenGLTokens

PFNGLGETNSEPARABLEFILTERARBPROC GLScene.OpenGLTokens

PFNGLGETNTEXIMAGEARBPROC GLScene.OpenGLTokens

PFNGLGETNUNIFORMDVARBPROC GLScene.OpenGLTokens

PFNGLGETNUNIFORMFVARBPROC GLScene.OpenGLTokens

PFNGLGETNUNIFORMIVARBPROC GLScene.OpenGLTokens

PFNGLGETNUNIFORMUIVARBPROC GLScene.OpenGLTokens

PFNGLGetObjectLabel GLScene.OpenGLTokens

PFNGLGETOBJECTPARAMETERFVARBPROC GLScene.OpenGLTokens

PFNGLGETOBJECTPARAMETERIVARBPROC GLScene.OpenGLTokens

PFNGLGetObjectPtrLabel GLScene.OpenGLTokens

PFNGLGETOCCLUSIONQUERYIVNVPROC GLScene.OpenGLTokens

PFNGLGETOCCLUSIONQUERYUIVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHCOLORGENFVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHCOLORGENIVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHCOMMANDSNVPROC GLScene.OpenGLTokens

PFNGLGETPATHCOORDSNVPROC GLScene.OpenGLTokens

PFNGLGETPATHDASHARRAYNVPROC GLScene.OpenGLTokens

PFNGLGETPATHLENGTHNVPROC GLScene.OpenGLTokens

PFNGLGETPATHMETRICRANGENVPROC GLScene.OpenGLTokens

PFNGLGETPATHMETRICSNVPROC GLScene.OpenGLTokens

PFNGLGETPATHPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHSPACINGNVPROC GLScene.OpenGLTokens

PFNGLGETPATHTEXGENFVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHTEXGENIVNVPROC GLScene.OpenGLTokens

PFNGLGETPOINTERINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMBINARYPROC GLScene.OpenGLTokens

GL_ARB_get_program_binary (ARB #96)
PFNGLGETPROGRAMENVPARAMETERDVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMENVPARAMETERFVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMINFOLOGPROC GLScene.OpenGLTokens

PFNGLGetProgramInterfaceiv GLScene.OpenGLTokens

GL_ARB_program_interface_query (ARB #134)
PFNGLGETPROGRAMIVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMIVNVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMIVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMPARAMETERDVNVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMPIPELINEINFOLOGPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMPIPELINEIVPROC GLScene.OpenGLTokens

PFNGLGetProgramResourceIndex GLScene.OpenGLTokens

PFNGLGetProgramResourceiv GLScene.OpenGLTokens

PFNGLGetProgramResourceLocation GLScene.OpenGLTokens

PFNGLGetProgramResourceLocationIndex GLScene.OpenGLTokens

PFNGLGetProgramResourceName GLScene.OpenGLTokens

PFNGLGETPROGRAMSTAGEIVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMSTRINGARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMSTRINGNVPROC GLScene.OpenGLTokens

PFNGLGETQUERYINDEXEDIVPROC GLScene.OpenGLTokens

PFNGLGETQUERYIVARBPROC GLScene.OpenGLTokens

PFNGLGETQUERYIVPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTI64VEXTPROC GLScene.OpenGLTokens

GL_EXT_timer_query (EXT #319)
PFNGLGETQUERYOBJECTI64VPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTIVARBPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTIVPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUI64VEXTPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUI64VPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUIVARBPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUIVPROC GLScene.OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERFVPROC GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIFVPROC GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIIVPROC GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLGETSEPARABLEFILTERPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETSHADERINFOLOGPROC GLScene.OpenGLTokens

PFNGLGETSHADERIVPROC GLScene.OpenGLTokens

PFNGLGETSHADERPRECISIONFORMATPROC GLScene.OpenGLTokens

PFNGLGETSHADERSOURCEARBPROC GLScene.OpenGLTokens

PFNGLGETSHADERSOURCEPROC GLScene.OpenGLTokens

PFNGLGETSTRINGIPROC GLScene.OpenGLTokens

PFNGLGETSUBROUTINEINDEXPROC GLScene.OpenGLTokens

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC GLScene.OpenGLTokens

GL_ARB_shader_subroutine (ARB #90)
PFNGLGETSYNCIVPROC GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIIVPROC GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIUIVPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREIMAGEEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTRACKMATRIXIVNVPROC GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMBLOCKINDEXPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMBUFFERSIZEEXTPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMDVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMFVARBPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMFVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMINDICESPROC GLScene.OpenGLTokens

GL_ARB_uniform_buffer_object (ARB #57)
PFNGLGETUNIFORMIVARBPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMIVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMLOCATIONARBPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMLOCATIONPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMOFFSETEXTPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMSUBROUTINEUIVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMUI64VNVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMUIVPROC GLScene.OpenGLTokens

PFNGLGETVARYINGLOCATIONNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVARBPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVARBPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIIVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVARBPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBLDVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVARBPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVPROC GLScene.OpenGLTokens

PFNGLHISTOGRAMPROC GLScene.OpenGLTokens

deprecated;
PFNGLINDEXFORMATNVPROC GLScene.OpenGLTokens

PFNGLINDEXFUNCEXTPROC GLScene.OpenGLTokens

GL_EXT_index_func (EXT #95)
PFNGLINDEXMATERIALEXTPROC GLScene.OpenGLTokens

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; GL_EXT_index_material (EXT #94)
PFNGLINTERPOLATEPATHSNVPROC GLScene.OpenGLTokens

PFNGLInvalidateBufferData GLScene.OpenGLTokens

PFNGLInvalidateBufferSubData GLScene.OpenGLTokens

PFNGLInvalidateFramebuffer GLScene.OpenGLTokens

PFNGLInvalidateSubFramebuffer GLScene.OpenGLTokens

PFNGLInvalidateTexImage GLScene.OpenGLTokens

PFNGLInvalidateTexSubImage GLScene.OpenGLTokens

GL_ARB_invalidate_subdata (ARB #132)
PFNGLISBUFFERARBPROC GLScene.OpenGLTokens

PFNGLISBUFFERPROC GLScene.OpenGLTokens

PFNGLISBUFFERRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLISENABLEDINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLISENABLEDIPROC GLScene.OpenGLTokens

PFNGLISFENCENVPROC GLScene.OpenGLTokens

PFNGLISFRAMEBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLISFRAMEBUFFERPROC GLScene.OpenGLTokens

PFNGLISNAMEDBUFFERRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLISOCCLUSIONQUERYNVPROC GLScene.OpenGLTokens

PFNGLISPATHNVPROC GLScene.OpenGLTokens

PFNGLISPOINTINFILLPATHNVPROC GLScene.OpenGLTokens

PFNGLISPOINTINSTROKEPATHNVPROC GLScene.OpenGLTokens

PFNGLISPROGRAMARBPROC GLScene.OpenGLTokens

PFNGLISPROGRAMNVPROC GLScene.OpenGLTokens

PFNGLISPROGRAMPIPELINEPROC GLScene.OpenGLTokens

PFNGLISPROGRAMPROC GLScene.OpenGLTokens

PFNGLISQUERYARBPROC GLScene.OpenGLTokens

PFNGLISQUERYPROC GLScene.OpenGLTokens

PFNGLISRENDERBUFFEREXTPROC GLScene.OpenGLTokens

GL_EXT_framebuffer_object (EXT #310)
PFNGLISRENDERBUFFERPROC GLScene.OpenGLTokens

GL_ARB_framebuffer_object (ARB #45)
PFNGLISSAMPLERPROC GLScene.OpenGLTokens

PFNGLISSHADERPROC GLScene.OpenGLTokens

PFNGLISSYNCPROC GLScene.OpenGLTokens

PFNGLISTEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLISTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLISVERTEXARRAYPROC GLScene.OpenGLTokens

PFNGLLINKPROGRAMARBPROC GLScene.OpenGLTokens

PFNGLLINKPROGRAMPROC GLScene.OpenGLTokens

PFNGLLOADPROGRAMNVPROC GLScene.OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDARBPROC GLScene.OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDPROC GLScene.OpenGLTokens

deprecated;
PFNGLLOADTRANSPOSEMATRIXFARBPROC GLScene.OpenGLTokens

GL_ARB_transpose_matrix (ARB #3)
PFNGLLOADTRANSPOSEMATRIXFPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix
PFNGLLOCKARRAYSEXTPROC GLScene.OpenGLTokens

GL_EXT_compiled_vertex_array (EXT #97)
PFNGLMAKEBUFFERNONRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLMAKEBUFFERRESIDENTNVPROC GLScene.OpenGLTokens

GL_NV_shader_buffer_load (EXT #379)
PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLMAPBUFFERARBPROC GLScene.OpenGLTokens

PFNGLMAPBUFFERPROC GLScene.OpenGLTokens

PFNGLMAPBUFFERRANGEPROC GLScene.OpenGLTokens

GL_ARB_map_buffer_range (ARB #50)
PFNGLMAPNAMEDBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLMAPNAMEDBUFFERRANGEEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXFRUSTUMEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXINDEXPOINTERARBPROC GLScene.OpenGLTokens

PFNGLMATRIXINDEXUBVARBPROC GLScene.OpenGLTokens

PFNGLMATRIXINDEXUIVARBPROC GLScene.OpenGLTokens

PFNGLMATRIXINDEXUSVARBPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADIDENTITYEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXMULTDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXMULTFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXORTHOEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXPOPEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXPUSHEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXROTATEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXROTATEFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXSCALEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXSCALEFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXTRANSLATEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXTRANSLATEFEXTPROC GLScene.OpenGLTokens

PFNGLMINMAXPROC GLScene.OpenGLTokens

deprecated;
PFNGLMINSAMPLESHADINGARBPROC GLScene.OpenGLTokens

GL_ARB_sample_shading (ARB #70)
PFNGLMINSAMPLESHADINGPROC GLScene.OpenGLTokens

promoted to core v4.0 from GL_ARB_sample_shading (ARB #70)
PFNGLMULTIDRAWARRAYSEXTPROC GLScene.OpenGLTokens

GL_EXT_multi_draw_arrays (EXT #148)
PFNGLMultiDrawArraysIndirect GLScene.OpenGLTokens

GL_ARB_multi_draw_indirect (ARB #133)
PFNGLMULTIDRAWARRAYSPROC GLScene.OpenGLTokens

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)
PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC GLScene.OpenGLTokens

PFNGLMULTIDRAWELEMENTSEXTPROC GLScene.OpenGLTokens

PFNGLMultiDrawElementsIndirect GLScene.OpenGLTokens

PFNGLMULTIDRAWELEMENTSPROC GLScene.OpenGLTokens

PFNGLMULTITEXBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1DVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1FARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1FPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1FVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1IARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1IPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1IVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1SARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1SPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1SVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2DARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2DPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2DVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2FARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2FPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2FVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2IARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2IPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2IVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2SARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2SPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2SVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3DARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3DPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3DVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3FARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3FPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3FVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3IARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3IPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3IVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3SARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3SPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3SVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4DARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4DPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4DVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4FARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4FPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4FVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4IARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4IPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4IVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4SARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4SPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4SVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORDP1UIPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP1UIVPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP2UIPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP2UIVPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP3UIPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP3UIVPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP4UIPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP4UIVPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDPOINTEREXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXENVFEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXENVFVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXENVIEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXENVIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENDEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENDVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENFEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENFVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENIEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERFEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXRENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDARBPROC GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTTRANSPOSEMATRIXFARBPROC GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXFPROC GLScene.OpenGLTokens

deprecated;
PFNGLNAMEDBUFFERDATAEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDBUFFERSUBDATAEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC GLScene.OpenGLTokens

PFNGLNamedFramebufferParameteri GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMSTRINGEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC GLScene.OpenGLTokens

PFNGLNORMALFORMATNVPROC GLScene.OpenGLTokens

PFNGLNORMALP3UIPROC GLScene.OpenGLTokens

PFNGLNORMALP3UIVPROC GLScene.OpenGLTokens

PFNGLObjectLabel GLScene.OpenGLTokens

PFNGLObjectPtrLabel GLScene.OpenGLTokens

PFNGLPATCHPARAMETERFVPROC GLScene.OpenGLTokens

PFNGLPATCHPARAMETERIPROC GLScene.OpenGLTokens

GL_ARB_tessellation_shader (ARB #91)
PFNGLPATHCOLORGENNVPROC GLScene.OpenGLTokens

PFNGLPATHCOMMANDSNVPROC GLScene.OpenGLTokens

PFNGLPATHCOORDSNVPROC GLScene.OpenGLTokens

PFNGLPATHCOVERDEPTHFUNCNVPROC GLScene.OpenGLTokens

PFNGLPATHDASHARRAYNVPROC GLScene.OpenGLTokens

PFNGLPATHFOGGENNVPROC GLScene.OpenGLTokens

PFNGLPATHGLYPHRANGENVPROC GLScene.OpenGLTokens

PFNGLPATHGLYPHSNVPROC GLScene.OpenGLTokens

PFNGLPATHPARAMETERFNVPROC GLScene.OpenGLTokens

PFNGLPATHPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLPATHPARAMETERINVPROC GLScene.OpenGLTokens

PFNGLPATHPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLPATHSTENCILDEPTHOFFSETNVPROC GLScene.OpenGLTokens

PFNGLPATHSTENCILFUNCNVPROC GLScene.OpenGLTokens

PFNGLPATHSTRINGNVPROC GLScene.OpenGLTokens

PFNGLPATHSUBCOMMANDSNVPROC GLScene.OpenGLTokens

PFNGLPATHSUBCOORDSNVPROC GLScene.OpenGLTokens

PFNGLPATHTEXGENNVPROC GLScene.OpenGLTokens

PFNGLPAUSETRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLPOINTALONGPATHNVPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERFARBPROC GLScene.OpenGLTokens

GL_ARB_point_parameter (ARB #14)
PFNGLPOINTPARAMETERFPROC GLScene.OpenGLTokens

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)
PFNGLPOINTPARAMETERFVARBPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERFVPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERINVPROC GLScene.OpenGLTokens

GL_NV_point_sprite (EXT #262)
PFNGLPOINTPARAMETERIPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLPOLYGONOFFSETEXTPROC GLScene.OpenGLTokens

GL_EXT_polygon_offset (EXT #3)
PFNGLPopDebugGroup GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXNVPROC GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXPROC GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTNVPROC GLScene.OpenGLTokens

GL_NV_primitive_restart (EXT #285)
PFNGLPRIORITIZETEXTURESEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMBINARYPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DVARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FVARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC GLScene.OpenGLTokens

GL_EXT_gpu_program_parameters (EXT #320)
PFNGLPROGRAMLOCALPARAMETER4DARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4DNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4DVNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4FNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4FVNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERIARBPROC GLScene.OpenGLTokens

GL_ARB_geometry_shader4 (ARB #47)
PFNGLPROGRAMPARAMETERIEXTPROC GLScene.OpenGLTokens

GL_EXT_geometry_shader4 (EXT #324)
PFNGLPROGRAMPARAMETERIPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERS4DVNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERS4FVNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMSTRINGARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1FPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1IPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1IVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1UIPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1UIVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2FPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2IPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2IVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2UIPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2UIVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3FPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3IPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3IVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3UIPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3UIVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4FPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4IPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4IVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4UIPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4UIVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMUI64NVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMUI64VNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMVERTEXLIMITNVPROC GLScene.OpenGLTokens

GL_NV_geometry_program4 (EXT #323)
PFNGLPROVOKINGVERTEXPROC GLScene.OpenGLTokens

GL_ARB_provoking_vertex (ARB #64)
PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC GLScene.OpenGLTokens

PFNGLPushDebugGroup GLScene.OpenGLTokens

GL_ARB_shader_stencil_export (ARB #106) (no entry points) GL_KHR_debug (ARB #119)
PFNGLQUERYCOUNTERPROC GLScene.OpenGLTokens

GL_ARB_timer_query (ARB #85)
PFNGLREADNPIXELSARBPROC GLScene.OpenGLTokens

PFNGLRELEASESHADERCOMPILERPROC GLScene.OpenGLTokens

GL_ARB_ES2_compatibility (ARB #95)
PFNGLRENDERBUFFERSTORAGEEXTPROC GLScene.OpenGLTokens

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC GLScene.OpenGLTokens

GL_EXT_framebuffer_multisample (EXT #317)
PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC GLScene.OpenGLTokens

PFNGLRENDERBUFFERSTORAGEPROC GLScene.OpenGLTokens

PFNGLREQUESTRESIDENTPROGRAMSNVPROC GLScene.OpenGLTokens

PFNGLRESETHISTOGRAMPROC GLScene.OpenGLTokens

deprecated;
PFNGLRESETMINMAXPROC GLScene.OpenGLTokens

deprecated;
PFNGLRESIZEBUFFERSMESAPROC GLScene.OpenGLTokens

GL_MESA_resize_buffers (EXT #196)
PFNGLRESUMETRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLSAMPLECOVERAGEARBPROC GLScene.OpenGLTokens

GL_ARB_multisample (ARB #5)
PFNGLSAMPLECOVERAGEPROC GLScene.OpenGLTokens

promoted to core v1.3 from GL_ARB_multisample (#5)
PFNGLSAMPLEMASKEXTPROC GLScene.OpenGLTokens

GL_EXT_multisample (EXT #209)
PFNGLSAMPLEMASKIPROC GLScene.OpenGLTokens

PFNGLSAMPLEMASKSGISPROC GLScene.OpenGLTokens

GL_SGIS_multisample (EXT #25)
PFNGLSAMPLEPASSARBPROC GLScene.OpenGLTokens

ARB Extensions unknown ARB extension
PFNGLSAMPLEPATTERNEXTPROC GLScene.OpenGLTokens

PFNGLSAMPLEPATTERNSGISPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERFPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERFVPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIIVPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIUIVPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLSCISSORARRAYVPROC GLScene.OpenGLTokens

PFNGLSCISSORINDEXEDPROC GLScene.OpenGLTokens

PFNGLSCISSORINDEXEDVPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3BEXTPROC GLScene.OpenGLTokens

GL_EXT_secondary_color (EXT #145)
PFNGLSECONDARYCOLOR3BPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)
PFNGLSECONDARYCOLOR3BVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3BVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3DEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3DPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3DVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3FEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3FPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3FVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3IEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3IPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3IVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3SEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3SPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3SVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3UBEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UBPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3UBVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UBVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3UIEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UIPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3UIVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3USEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3USPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3USVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3USVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLORFORMATNVPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLORP3UIPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLORP3UIVPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLORPOINTEREXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLORPOINTERPROC GLScene.OpenGLTokens

deprecated;
PFNGLSEPARABLEFILTER2DPROC GLScene.OpenGLTokens

deprecated;
PFNGLSETFENCENVPROC GLScene.OpenGLTokens

PFNGLSHADERBINARYPROC GLScene.OpenGLTokens

PFNGLSHADERSOURCEARBPROC GLScene.OpenGLTokens

PFNGLSHADERSOURCEPROC GLScene.OpenGLTokens

PFNGLShaderStorageBlockBinding GLScene.OpenGLTokens

GL_ARB_robust_buffer_access_behavior (ARB #135) (no entry points) GL_ARB_shader_image_size (ARB #136) (no entry points) GL_ARB_shader_storage_buffer_object (ARB #137)
PFNGLSTENCILCLEARTAGEXTPROC GLScene.OpenGLTokens

GL_EXT_stencil_clear_tag (EXT #314)
PFNGLSTENCILFILLPATHINSTANCEDNVPROC GLScene.OpenGLTokens

PFNGLSTENCILFILLPATHNVPROC GLScene.OpenGLTokens

PFNGLSTENCILFUNCSEPARATEPROC GLScene.OpenGLTokens

PFNGLSTENCILMASKSEPARATEPROC GLScene.OpenGLTokens

PFNGLSTENCILOPSEPARATEPROC GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)
PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC GLScene.OpenGLTokens

PFNGLSTENCILSTROKEPATHNVPROC GLScene.OpenGLTokens

PFNGLSTRINGMARKERGREMEDYPROC GLScene.OpenGLTokens

GL_GREMEDY_string_marker (EXT #311)
PFNGLTBUFFERMASK3DFXPROC GLScene.OpenGLTokens

GL_3DFX_tbuffer (EXT #208)
PFNGLTESSELLATIONFACTORAMDPROC GLScene.OpenGLTokens

GL_AMD_vertex_shader_tessellator (EXT #363)
PFNGLTESSELLATIONMODEAMDPROC GLScene.OpenGLTokens

PFNGLTESTFENCENVPROC GLScene.OpenGLTokens

PFNGLTEXBUFFERARBPROC GLScene.OpenGLTokens

GL_ARB_texture_buffer_object (ARB #51)
PFNGLTEXBUFFEREXTPROC GLScene.OpenGLTokens

GL_EXT_packed_float (EXT #328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (EXT #329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (EXT #330)
PFNGLTEXBUFFERPROC GLScene.OpenGLTokens

PFNGLTexBufferRange GLScene.OpenGLTokens

GL_ARB_stencil_texturing (ARB #138) (no entry points) GL_ARB_texture_buffer_range (ARB #139)
PFNGLTEXCOORDFORMATNVPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP1UIPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP1UIVPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP2UIPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP2UIVPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP3UIPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP3UIVPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP4UIPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP4UIVPROC GLScene.OpenGLTokens

PFNGLTEXIMAGE2DMULTISAMPLEPROC GLScene.OpenGLTokens

GL_ARB_texture_multisample (ARB #67)
PFNGLTEXIMAGE3DEXTPROC GLScene.OpenGLTokens

GL_EXT_texture3D (EXT #6)
PFNGLTEXIMAGE3DMULTISAMPLEPROC GLScene.OpenGLTokens

PFNGLTEXIMAGE3DPROC GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_texture3D (#6)
PFNGLTEXPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXPARAMETERIIVPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_texture_integer
PFNGLTEXPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXPARAMETERIUIVPROC GLScene.OpenGLTokens

PFNGLTexStorage2DMultisample GLScene.OpenGLTokens

GL_ARB_texture_query_levels (ARB #140) (no entry points) GL_ARB_texture_storage_multisample (ARB #141)
PFNGLTexStorage3DMultisample GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

GL_EXT_subtexture (EXT #9)
PFNGLTEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE3DPROC GLScene.OpenGLTokens

PFNGLTEXTUREBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLTextureBufferRange GLScene.OpenGLTokens

PFNGLTEXTURECOLORMASKSGISPROC GLScene.OpenGLTokens

GL_SGIS_texture_color_mask (EXT #214)
PFNGLTEXTUREIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXTURERENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLTextureStorage2DMultisample GLScene.OpenGLTokens

PFNGLTextureStorage3DMultisample GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLTextureView GLScene.OpenGLTokens

GL_ARB_texture_view (ARB #124)
PFNGLTRACKMATRIXNVPROC GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSPROC GLScene.OpenGLTokens

PFNGLTRANSFORMPATHNVPROC GLScene.OpenGLTokens

PFNGLUDELETENURBSTESSELLATOREXTPROC GLScene.OpenGLTokens

PFNGLUNEWNURBSTESSELLATOREXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM1DPROC GLScene.OpenGLTokens

GL_ARB_gpu_shader_fp64 (ARB #89)
PFNGLUNIFORM1DVPROC GLScene.OpenGLTokens

PFNGLUNIFORM1FARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM1FPROC GLScene.OpenGLTokens

PFNGLUNIFORM1FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM1FVPROC GLScene.OpenGLTokens

PFNGLUNIFORM1IARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM1IPROC GLScene.OpenGLTokens

PFNGLUNIFORM1IVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM1IVPROC GLScene.OpenGLTokens

PFNGLUNIFORM1UIEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM1UIPROC GLScene.OpenGLTokens

PFNGLUNIFORM1UIVEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM1UIVPROC GLScene.OpenGLTokens

PFNGLUNIFORM2DPROC GLScene.OpenGLTokens

PFNGLUNIFORM2DVPROC GLScene.OpenGLTokens

PFNGLUNIFORM2FARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM2FPROC GLScene.OpenGLTokens

PFNGLUNIFORM2FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM2FVPROC GLScene.OpenGLTokens

PFNGLUNIFORM2IARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM2IPROC GLScene.OpenGLTokens

PFNGLUNIFORM2IVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM2IVPROC GLScene.OpenGLTokens

PFNGLUNIFORM2UIEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM2UIPROC GLScene.OpenGLTokens

PFNGLUNIFORM2UIVEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM2UIVPROC GLScene.OpenGLTokens

PFNGLUNIFORM3DPROC GLScene.OpenGLTokens

PFNGLUNIFORM3DVPROC GLScene.OpenGLTokens

PFNGLUNIFORM3FARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM3FPROC GLScene.OpenGLTokens

PFNGLUNIFORM3FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM3FVPROC GLScene.OpenGLTokens

PFNGLUNIFORM3IARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM3IPROC GLScene.OpenGLTokens

PFNGLUNIFORM3IVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM3IVPROC GLScene.OpenGLTokens

PFNGLUNIFORM3UIEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM3UIPROC GLScene.OpenGLTokens

PFNGLUNIFORM3UIVEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM3UIVPROC GLScene.OpenGLTokens

PFNGLUNIFORM4DPROC GLScene.OpenGLTokens

PFNGLUNIFORM4DVPROC GLScene.OpenGLTokens

PFNGLUNIFORM4FARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM4FPROC GLScene.OpenGLTokens

PFNGLUNIFORM4FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM4FVPROC GLScene.OpenGLTokens

PFNGLUNIFORM4IARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM4IPROC GLScene.OpenGLTokens

PFNGLUNIFORM4IVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM4IVPROC GLScene.OpenGLTokens

PFNGLUNIFORM4UIEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM4UIPROC GLScene.OpenGLTokens

PFNGLUNIFORM4UIVEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM4UIVPROC GLScene.OpenGLTokens

PFNGLUNIFORMBLOCKBINDINGPROC GLScene.OpenGLTokens

PFNGLUNIFORMBUFFEREXTPROC GLScene.OpenGLTokens

GL_EXT_bindable_uniform (EXT #342)
PFNGLUNIFORMMATRIX2DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X3DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X3FVPROC GLScene.OpenGLTokens

core 2.1 new commands in OpenGL 2.1
PFNGLUNIFORMMATRIX2X4DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X4FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X2DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X2FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X4DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X4FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X2DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X2FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X3DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X3FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMSUBROUTINESUIVPROC GLScene.OpenGLTokens

PFNGLUNIFORMUI64NVPROC GLScene.OpenGLTokens

PFNGLUNIFORMUI64VNVPROC GLScene.OpenGLTokens

PFNGLUNLOCKARRAYSEXTPROC GLScene.OpenGLTokens

PFNGLUNMAPBUFFERARBPROC GLScene.OpenGLTokens

PFNGLUNMAPBUFFERPROC GLScene.OpenGLTokens

PFNGLUNMAPNAMEDBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLUNURBSCALLBACKDATAEXTPROC GLScene.OpenGLTokens

GLU extensions (might not be same naming as c versions?)
PFNGLUSEPROGRAMOBJECTARBPROC GLScene.OpenGLTokens

PFNGLUSEPROGRAMPROC GLScene.OpenGLTokens

PFNGLUSEPROGRAMSTAGESPROC GLScene.OpenGLTokens

GL_ARB_separate_shader_objects (ARB #97)
PFNGLVALIDATEPROGRAMARBPROC GLScene.OpenGLTokens

PFNGLVALIDATEPROGRAMPIPELINEPROC GLScene.OpenGLTokens

PFNGLVALIDATEPROGRAMPROC GLScene.OpenGLTokens

PFNGLVertexArrayBindVertexBuffer GLScene.OpenGLTokens

PFNGLVERTEXARRAYRANGENVPROC GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribBinding GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribFormat GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribIFormat GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribLFormat GLScene.OpenGLTokens

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC GLScene.OpenGLTokens

VertexArrayVertexAttribLOffsetEXT only valid if EXT_direct_state_access is available
PFNGLVertexArrayVertexBindingDivisor GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DARBPROC GLScene.OpenGLTokens

GL_ARB_vertex_program (ARB #26)
PFNGLVERTEXATTRIB1DNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4BVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4BVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4IVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NBVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NBVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NIVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NSVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NSVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUIVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUSVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUSVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UIVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4USVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4USVPROC GLScene.OpenGLTokens

PFNGLVertexAttribBinding GLScene.OpenGLTokens

PFNGLVERTEXATTRIBDIVISORARBPROC GLScene.OpenGLTokens

GL_ARB_instanced_arrays (ARB #49)
PFNGLVERTEXATTRIBDIVISORPROC GLScene.OpenGLTokens

Core 3.3
PFNGLVertexAttribFormat GLScene.OpenGLTokens

PFNGLVERTEXATTRIBFORMATNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1IEXTPROC GLScene.OpenGLTokens

GL_EXT_gpu_shader4 (EXT #326)
PFNGLVERTEXATTRIBI1IPROC GLScene.OpenGLTokens

Core 3.0 promoted to core v3.0 from GL_EXT_gpu_shader4
PFNGLVERTEXATTRIBI1IVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4BVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4BVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4SVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UBVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UBVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4USVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4USVPROC GLScene.OpenGLTokens

PFNGLVertexAttribIFormat GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIFORMATNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIPOINTEREXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIPOINTERPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL1DPROC GLScene.OpenGLTokens

GL_ARB_shader_precision (ARB #98) (no entry points) GL_ARB_vertex_attrib_64bit (ARB #99)
PFNGLVERTEXATTRIBL1DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL2DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL2DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL3DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL3DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL4DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL4DVPROC GLScene.OpenGLTokens

PFNGLVertexAttribLFormat GLScene.OpenGLTokens

PFNGLVERTEXATTRIBLPOINTERPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP1UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP1UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP2UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP2UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP3UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP3UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP4UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP4UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4UBVNVPROC GLScene.OpenGLTokens

PFNGLVertexBindingDivisor GLScene.OpenGLTokens

PFNGLVERTEXBLENDARBPROC GLScene.OpenGLTokens

PFNGLVERTEXFORMATNVPROC GLScene.OpenGLTokens

PFNGLVERTEXP2UIPROC GLScene.OpenGLTokens

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)
PFNGLVERTEXP2UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXP3UIPROC GLScene.OpenGLTokens

PFNGLVERTEXP3UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXP4UIPROC GLScene.OpenGLTokens

PFNGLVERTEXP4UIVPROC GLScene.OpenGLTokens

PFNGLVIEWPORTARRAYVPROC GLScene.OpenGLTokens

GL_ARB_viewport_array (ARB #100)
PFNGLVIEWPORTINDEXEDFPROC GLScene.OpenGLTokens

PFNGLVIEWPORTINDEXEDFVPROC GLScene.OpenGLTokens

PFNGLWAITSYNCPROC GLScene.OpenGLTokens

PFNGLWEIGHTBVARBPROC GLScene.OpenGLTokens

GL_ARB_vertex_blend (ARB #15) {deprecated?}
PFNGLWEIGHTDVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTFVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTIVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTPATHSNVPROC GLScene.OpenGLTokens

PFNGLWEIGHTPOINTERARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTSVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTUBVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTUIVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTUSVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2DARBPROC GLScene.OpenGLTokens

GL_ARB_window_pos (ARB #25)
PFNGLWINDOWPOS2DPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)
PFNGLWINDOWPOS2DVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2FARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2FPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2FVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2IARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2IPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2IVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2SARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2SPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2SVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3DARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3DPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3DVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3FARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3FPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3FVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3IARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3IPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3IVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3SARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3SPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3SVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3SVPROC GLScene.OpenGLTokens

deprecated;
PFNWGLALLOCATEMEMORYNVPROC GLScene.OpenGLTokens

PFNWGLBINDTEXIMAGEARBPROC GLScene.OpenGLTokens

WGL_ARB_render_texture (ARB #20)
PFNWGLCHOOSEPIXELFORMATARBPROC GLScene.OpenGLTokens

PFNWGLCREATEAFFINITYDCNVPROC GLScene.OpenGLTokens

PFNWGLCREATEBUFFERREGIONARBPROC GLScene.OpenGLTokens

WGL WGL - ARB WGL_buffer_region (ARB #4)
PFNWGLCREATECONTEXTATTRIBSARBPROC GLScene.OpenGLTokens

WGL_ARB_create_context (ARB #55)
PFNWGLCREATEPBUFFERARBPROC GLScene.OpenGLTokens

WGL_ARB_pbuffer (ARB #11)
PFNWGLDELETEBUFFERREGIONARBPROC GLScene.OpenGLTokens

PFNWGLDELETEDCNVPROC GLScene.OpenGLTokens

PFNWGLDESTROYPBUFFERARBPROC GLScene.OpenGLTokens

PFNWGLDXCLOSEDEVICEPROC GLScene.OpenGLTokens

PFNWGLDXLOCKOBJECTSPROC GLScene.OpenGLTokens

PFNWGLDXOBJECTACCESSPROC GLScene.OpenGLTokens

PFNWGLDXOPENDEVICEPROC GLScene.OpenGLTokens

PFNWGLDXREGISTEROBJECTPROC GLScene.OpenGLTokens

PFNWGLDXSETRESOURCESHAREHANDLEPROC GLScene.OpenGLTokens

WGL_NV_DX_interop (EXT #407)
PFNWGLDXUNLOCKOBJECTSNVPROC GLScene.OpenGLTokens

PFNWGLDXUNREGISTEROBJECTPROC GLScene.OpenGLTokens

PFNWGLENUMGPUDEVICESNVPROC GLScene.OpenGLTokens

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC GLScene.OpenGLTokens

PFNWGLENUMGPUSNVPROC GLScene.OpenGLTokens

WGL_NV_gpu_affinity (EXT #355)
PFNWGLFREEMEMORYNVPROC GLScene.OpenGLTokens

PFNWGLGETCURRENTREADDCARBPROC GLScene.OpenGLTokens

PFNWGLGETEXTENSIONSSTRINGARBPROC GLScene.OpenGLTokens

WGL_ARB_extensions_string (ARB #8)
PFNWGLGETPBUFFERDCARBPROC GLScene.OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBFVARBPROC GLScene.OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBIVARBPROC GLScene.OpenGLTokens

WGL_ARB_pixel_format (ARB #9)
PFNWGLGETSWAPINTERVALEXTPROC GLScene.OpenGLTokens

PFNWGLMAKECONTEXTCURRENTARBPROC GLScene.OpenGLTokens

WGL_make_current_read (ARB #10)
PFNWGLQUERYPBUFFERARBPROC GLScene.OpenGLTokens

PFNWGLRELEASEPBUFFERDCARBPROC GLScene.OpenGLTokens

PFNWGLRELEASETEXIMAGEARBPROC GLScene.OpenGLTokens

PFNWGLRESTOREBUFFERREGIONARBPROC GLScene.OpenGLTokens

PFNWGLSAVEBUFFERREGIONARBPROC GLScene.OpenGLTokens

PFNWGLSETPBUFFERATTRIBARBPROC GLScene.OpenGLTokens

PFNWGLSWAPINTERVALEXTPROC GLScene.OpenGLTokens

WGL - EXT WGL_EXT_swap_control (EXT #172)
PFog Formats.m3DSTypes

PFogSettings3DS Formats.m3DSTypes

FallOff to the Bottom
PFontEntry GLS.SpaceText

holds an entry in the font manager list (used in TGLSpaceText)
PFovTrackTag Formats.m3DSTypes

PFrustum GLScene.VectorGeometry

PFSoundDSPUnit FMOD.types

PFSoundSample FMOD.types

FMOD defined types
PFSoundStream FMOD.types

PFSoundVector FMOD.types

PFSyncPoint FMOD.types

PFXPointerList GLS.ParticleFX

PGLbitfield GLScene.OpenGL4

PGLbitfield GLScene.OpenGLTokens

UINT
PGLboolean GLScene.OpenGL4

PGLboolean GLScene.OpenGLTokens

PGLbyte GLScene.OpenGL4

PGLbyte GLScene.OpenGLTokens

PGLChar GLScene.OpenGL4

PGLchar GLScene.OpenGLTokens

PGLclampd GLScene.OpenGL4

PGLclampd GLScene.OpenGLTokens

PGLclampf GLScene.OpenGL4

PGLclampf GLScene.OpenGLTokens

PGLdouble GLScene.OpenGL4

PGLdouble GLScene.OpenGLTokens

PGLenum GLScene.OpenGL4

PGLenum GLScene.OpenGLTokens

PGLFireParticle GLS.FireFX

PGLFireParticleArray GLS.FireFX

PGLfloat GLScene.OpenGL4

PGLfloat GLScene.OpenGLTokens

PGLhalf GLScene.OpenGLTokens

PGLhandleARB GLScene.OpenGL4

PGLhandleARB GLScene.OpenGLTokens

PGLHeightTile GLS.HeightTileFileHDS

PGLHeightTileInfo GLS.HeightTileFileHDS

PGLint GLScene.OpenGL4

PGLint GLScene.OpenGLTokens

PGLint64 GLScene.OpenGL4

PGLint64 GLScene.OpenGLTokens

PGLint64EXT GLScene.OpenGL4

PGLint64EXT GLScene.OpenGLTokens

PGLintptr GLScene.OpenGL4

PGLintptr GLScene.OpenGLTokens

PGLIsoline GLS.Isolines

PGLMatrix GLScene.VectorTypes

The matrix by default
PGLOctreeNode GLS.Octree

PGLParticleArray GLS.ParticleFX

PGLPCharArray GLScene.OpenGL4

PGLPCharArray GLScene.OpenGLTokens

PGLPixel24 GLS.Graphics

PGLPixel32 GLS.Graphics

PGLPixel32Array GLS.Graphics

PGLPointer GLScene.OpenGL4

PGLPointer GLScene.OpenGLTokens

PGLRCHandle GLS.Context

PGLRenderContextInfo GLS.RenderContextInfo

PGLshort GLScene.OpenGL4

PGLshort GLScene.OpenGLTokens

PGLsizei GLScene.OpenGL4

PGLsizei GLScene.OpenGLTokens

PGLsizeiptr GLScene.OpenGLTokens

PGLStarRecord GLS.SkyDome

PGLsync GLScene.OpenGLTokens

PGLubyte GLScene.OpenGL4

PGLubyte GLScene.OpenGLTokens

PGLuint GLScene.OpenGL4

PGLuint GLScene.OpenGLTokens

PGLuint OpenCL.GL

PGLuint64 GLScene.OpenGL4

PGLuint64 GLScene.OpenGLTokens

PGLuint64EXT GLScene.OpenGL4

PGLuint64EXT GLScene.OpenGLTokens

PGLUNurbs GLScene.OpenGL4

PGLUNurbs GLScene.OpenGLTokens

PGLUNurbsObj GLScene.OpenGL4

PGLUNurbsObj GLScene.OpenGLTokens

PGLUQuadric GLScene.OpenGL4

PGLUQuadric GLScene.OpenGLTokens

PGLUQuadricObj GLScene.OpenGL4

PGLUQuadricObj GLScene.OpenGLTokens

PGLushort GLScene.OpenGL4

PGLushort GLScene.OpenGLTokens

PGLUTesselator GLScene.OpenGL4

PGLUTesselator GLScene.OpenGLTokens

PGLUTesselatorObj GLScene.OpenGL4

PGLUTesselatorObj GLScene.OpenGLTokens

PGLUTriangulatorObj GLScene.OpenGL4

PGLUTriangulatorObj GLScene.OpenGLTokens

PGLvdpauSurfaceNV GLScene.OpenGLTokens

PGLVector GLScene.VectorTypes

The vector by default
PGLVertexBoneWeightArray GLS.VectorFileObjects

PGLVertexData GLS.Mesh

PGLVertexDataArray GLS.Mesh

PGLVertexRec GLS.Objects

PGLVerticesBoneWeights GLS.VectorFileObjects

PGLVideoMode GLS.Screen

PGLvoid GLScene.OpenGL4

PGLvoid GLScene.OpenGLTokens

PGNGLGETBUFFERPARAMETERUI64VNV GLScene.OpenGLTokens

PGPUDEVICE GLScene.OpenGL4

PGPUDEVICE GLScene.OpenGLTokens

PgTransformationRec GLScene.PipelineTransform

PHalfFloat GLScene.Utils

PHGPUNV GLScene.OpenGL4

—————————- OpenGL Utility (GLU) types ——————–
PHGPUNV GLScene.OpenGLTokens

PHideTrackTag Formats.m3DSTypes

PHiShadowBias Formats.m3DSTypes

PHmgBoundingBox GLScene.GeometryBB

Structure for storing Bounding Boxes
PHomogeneousByteVector GLScene.VectorGeometry

Common vector and matrix types with predefined limits indices correspond like: x -> 0 y -> 1 z -> 2 w -> 3
PHomogeneousDblVector GLScene.VectorGeometry

PHomogeneousExtVector GLScene.VectorGeometry

PHomogeneousFltVector GLScene.VectorGeometry

PHomogeneousIntVector GLScene.VectorGeometry

PHomogeneousMatrix GLScene.VectorGeometry

PHomogeneousPtrVector GLScene.VectorGeometry

PHomogeneousVector GLScene.VectorGeometry

some simplified names
PHomogeneousWordVector GLScene.VectorGeometry

PHotTrackTag Formats.m3DSTypes

PHVIDEO Formats.VFW

PHVIDEOINPUTDEVICENV GLScene.OpenGL4

PHVIDEOINPUTDEVICENV GLScene.OpenGLTokens

PI1 Formats.LWO

PI2 Formats.LWO

PI4 Formats.LWO

PICCOMPRESS Formats.VFW

PICCOMPRESSFRAMES Formats.VFW

PICDECOMPRESS Formats.VFW

this frame is not a key frame
PICDECOMPRESSEX Formats.VFW

PICDRAW Formats.VFW

this frame is not a key frame
PICDRAWBEGIN Formats.VFW

please buffer this data offscreen, we will need to update it
PICDRAWSUGGEST Formats.VFW

PICINFO Formats.VFW

*********************************************************************** ***********************************************************************
PICOPEN Formats.VFW

*********************************************************************** ***********************************************************************
PICPALETTE Formats.VFW

*********************************************************************** ***********************************************************************
PICSETSTATUSPROC Formats.VFW

PID4 Formats.LWO

PInstanceName Formats.m3DSTypes

PInt SDL.Import

PInteger Newton.Import

PIntegerArray Formats.m3DSTypes

PIntegerArray GLS.HeightTileFileHDS

PIntegerArray GLScene.VectorGeometry

PIntegerVector GLScene.VectorGeometry

PIntermediateFormatArray GLS.ImageUtils

PIntPercentage Formats.m3DSTypes

Pintptr_t OpenCL.Platform

PIpasData Formats.m3DSTypes

PKeyHeader3DS Formats.m3DSTypes

PKeyHeaderList Formats.m3DSTypes

PKEYSChunk Formats.B3D

PKFAmbient3DS Formats.m3DSTypes

Ambient Light animation
PKFCamera3DS Formats.m3DSTypes

PKFCurtime Formats.m3DSTypes

PKFHdr Formats.m3DSTypes

PKFId Formats.m3DSTypes

PKFKeyInfo3DS Formats.m3DSTypes

PKFMesh3DS Formats.m3DSTypes

used by ObjectMotion3DS
PKFMorphKey3DS Formats.m3DSTypes

PKFMorphKeyList Formats.m3DSTypes

Name of Target Morph object
PKFOmni3DS Formats.m3DSTypes

used by OmnilightMotion3DS
PKFRotKey3DS Formats.m3DSTypes

PKFRotKeyList Formats.m3DSTypes

PKFSeg Formats.m3DSTypes

PKFSegment3DS Formats.m3DSTypes

PKFSets3DS Formats.m3DSTypes

PKFSpot3DS Formats.m3DSTypes

PLayerFog Formats.m3DSTypes

PLayerFogSettings3DS Formats.m3DSTypes

PLight3DS Formats.m3DSTypes

omni and spotlight settings
PLinColor24 Formats.m3DSTypes

PLinColorF Formats.m3DSTypes

PLiteAttenuate3DS Formats.m3DSTypes

Light Attenuation settings
PLMTS GLS.FileLMTS

PLMTS_Header GLS.FileLMTS

max texture filename length
PLMTS_Subset GLS.FileLMTS

PLMTS_TexData GLS.FileLMTS

PLMTS_Vertex GLS.FileLMTS

PLONG Formats.VFW

PLongWordArray GLScene.VectorGeometry

PLongWordVector GLScene.VectorGeometry

PLoShadowBias Formats.m3DSTypes

PLWChunkRec Formats.LWO

Lightwave Chunk Struct - Used in TLWOReadCallback
PLWPolyTagMap Formats.LWO

PLWSubChunkRec Formats.LWO

Lightwave SubChunk Struct - Used in TLWOReadCallback
PM3dVersion Formats.m3DSTypes

PMainAVIHeader Formats.VFW

size of AVI header list
PMapInfo3DS Formats.m3DSTypes

Texture Map icon placement
PMapSet3DS Formats.m3DSTypes

Bit Map definition Structure to all Map settings
PMasterScale Formats.m3DSTypes

PMatAcubic Formats.m3DSTypes

PMatBumpPercent Formats.m3DSTypes

PMaterial3DS Formats.m3DSTypes

PMatMapAng Formats.m3DSTypes

PMatMapBCol Formats.m3DSTypes

PMatMapCol1 Formats.m3DSTypes

PMatMapCol2 Formats.m3DSTypes

PMatMapGCol Formats.m3DSTypes

PMatMapname Formats.m3DSTypes

PMatMapRCol Formats.m3DSTypes

PMatMapTexblur Formats.m3DSTypes

PMatMapTiling Formats.m3DSTypes

PMatMapUOffset Formats.m3DSTypes

PMatMapUScale Formats.m3DSTypes

PMatMapVOffset Formats.m3DSTypes

PMatMapVScale Formats.m3DSTypes

PMatName Formats.m3DSTypes

PMatrix4f GLScene.VectorTypes

the matrix by default
PMatrixArray GLScene.VectorGeometry

PMatrixRec GLScene.VectorTypesExt

PMatShading Formats.m3DSTypes

PMatWireSize Formats.m3DSTypes

PMD2AliasFrame Formats.MD2

PMD2VertexIndex Formats.MD2

PMDCTagFrame GLS.FileMDC

PMDCTagName GLS.FileMDC

PMesh3DS Formats.m3DSTypes

Mesh object definition
PMESHChunk Formats.B3D

PMeshColor Formats.m3DSTypes

PMeshMatrix Formats.m3DSTypes

Mesh definition
PMeshSet3DS Formats.m3DSTypes

PMeshTextureInfo Formats.m3DSTypes

PMeshVersion Formats.m3DSTypes

PMorphSmooth Formats.m3DSTypes

PMorphTrackTag Formats.m3DSTypes

pMS3DComment GLS.FileMS3D

PMS3DJointArray GLS.FileMS3D

PMS3DKeyframePositionArray GLS.FileMS3D

PMS3DKeyframeRotationArray GLS.FileMS3D

PMS3DTriangleArray GLS.FileMS3D

PMS3DVertexArray GLS.FileMS3D

pMS3D_vertex_ex_t GLS.FileMS3D

PMshBoxmap Formats.m3DSTypes

PMshMatGroup Formats.m3DSTypes

PNamedObject Formats.m3DSTypes

PNCamera Formats.m3DSTypes

PNDirectLight Formats.m3DSTypes

PNewtonAcyclicArticulation Newton.Import

PNewtonAllocMemory Newton.Import

PNewtonApplyForceAndTorque Newton.Import

PNewtonBallCallback Newton.Import

PNewtonBody Newton.Import

PNewtonBodyDestructor Newton.Import

PNewtonBodyIterator Newton.Import

PNewtonBoxParam Newton.Import

PNewtonCapsuleParam Newton.Import

PNewtonChamferCylinderParam Newton.Import

PNewtonCollision Newton.Import

PNewtonCollisionCopyConstructionCallback Newton.Import

PNewtonCollisionDestructorCallback Newton.Import

PNewtonCollisionInfoRecord Newton.Import

PNewtonCollisionIterator Newton.Import

PNewtonCollisionMaterial Newton.Import

PNewtonCollisionTreeParam Newton.Import

PNewtonCollisionTreeRayCastCallback Newton.Import

PNewtonCompoundCollisionParam Newton.Import

PNewtonConeParam Newton.Import

PNewtonConstraintDestructor Newton.Import

PNewtonContactsProcess Newton.Import

PNewtonConvexHullParam Newton.Import

PNewtonCorkscrewCallback Newton.Import

PNewtonCreateContactCallback Newton.Import

PNewtonCylinderParam Newton.Import

PNewtonDeformableMeshParam Newton.Import

PNewtonDeformableMeshSegment Newton.Import

PNewtonDeserializeCallback Newton.Import

PNewtonDestroyContactCallback Newton.Import

PNewtonFractureCompoundCollisionOnEmitChunk Newton.Import

PNewtonFractureCompoundCollisionOnEmitCompoundFractured Newton.Import

PNewtonFractureCompoundCollisionReconstructMainMeshCallBack Newton.Import

PNewtonFracturedCompoundMeshPart Newton.Import

PNewtonFreeMemory Newton.Import

PNewtonGetTimeInMicrosencondsCallback Newton.Import

PNewtonHeightFieldCollisionParam Newton.Import

PNewtonHeightFieldRayCastCallback Newton.Import

PNewtonHingeCallback Newton.Import

PNewtonHingeSliderUpdateDesc Newton.Import

PNewtonImmediateModeConstraint Newton.Import

PNewtonInverseDynamics Newton.Import

PNewtonIslandUpdate Newton.Import

PNewtonJobTask Newton.Import

PNewtonJoint Newton.Import

PNewtonJointIterator Newton.Import

PNewtonJointRecord Newton.Import

PNewtonMaterial Newton.Import

PNewtonMaterialData Newton.Import

PNewtonMesh Newton.Import

PNewtonMeshDoubleData Newton.Import

PNewtonMeshFloatData Newton.Import

PNewtonMeshVertexFormat Newton.Import

PNewtonOnAABBOverlap Newton.Import

PNewtonOnBodyDeserializationCallback Newton.Import

PNewtonOnBodySerializationCallback Newton.Import

PNewtonOnCompoundSubCollisionAABBOverlap Newton.Import

PNewtonOnContactGeneration Newton.Import

PNewtonOnJointDeserializationCallback Newton.Import

PNewtonOnJointSerializationCallback Newton.Import

PNewtonOnUserCollisionSerializationCallback Newton.Import

PNewtonPostUpdateCallback Newton.Import

PNewtonReportProgress Newton.Import

PNewtonSceneCollisionParam Newton.Import

PNewtonSceneProxy Newton.Import

PNewtonSerializeCallback Newton.Import

PNewtonSetTransform Newton.Import

PNewtonSliderCallback Newton.Import

PNewtonSphereParam Newton.Import

PNewtonTaperedCapsuleParam Newton.Import

PNewtonTaperedCylinderParam Newton.Import

PNewtonTreeCollisionCallback Newton.Import

PNewtonTreeCollisionFaceCallback Newton.Import

PNewtonUniversalCallback Newton.Import

PNewtonUserBilateralCallback Newton.Import

PNewtonUserBilateralGetInfoCallback Newton.Import

PNewtonUserContactPoint Newton.Import

PNewtonUserMeshCollisionAABBTest Newton.Import

PNewtonUserMeshCollisionCollideCallback Newton.Import

PNewtonUserMeshCollisionCollideDesc Newton.Import

PNewtonUserMeshCollisionDestroyCallback Newton.Import

PNewtonUserMeshCollisionGetCollisionInfo Newton.Import

PNewtonUserMeshCollisionGetFacesInAABB Newton.Import

PNewtonUserMeshCollisionRayHitCallback Newton.Import

PNewtonUserMeshCollisionRayHitDesc Newton.Import

PNewtonWorld Newton.Import

PNewtonWorldConvexCastReturnInfo Newton.Import

PNewtonWorldDestroyListenerCallback Newton.Import

PNewtonWorldDestructorCallback Newton.Import

PNewtonWorldListenerBodyDestroyCallback Newton.Import

PNewtonWorldListenerDebugCallback Newton.Import

PNewtonWorldRayFilterCallback Newton.Import

PNewtonWorldRayPrefilterCallback Newton.Import

PNewtonWorldUpdateListenerCallback Newton.Import

PNODEChunk Formats.B3D

PNodeHdr Formats.m3DSTypes

PNodeList Formats.m3DSTypes

3D Studio .MLI file
PObjMat3DS Formats.m3DSTypes

Material assignments by face
PObjMatList Formats.m3DSTypes

POConsts Formats.m3DSTypes

POCTFace Formats.OCT

POCTLightmap Formats.OCT

POctreeTriangleInfo GLS.Octree

Stores information about an intersected triangle
POrthoView3DS Formats.m3DSTypes

PPALvoid OpenAL.Import

PParticleReference GLS.ParticleFX

PParticleReferenceArray GLS.ParticleFX

PPasDblStrUtilsBoolean PasDblStrUtils

PPasDblStrUtilsChar PasDblStrUtils

PPasDblStrUtilsDouble PasDblStrUtils

PPasDblStrUtilsInt16 PasDblStrUtils

PPasDblStrUtilsInt32 PasDblStrUtils

PPasDblStrUtilsInt64 PasDblStrUtils

PPasDblStrUtilsInt8 PasDblStrUtils

PPasDblStrUtilsNativeInt PasDblStrUtils

PPasDblStrUtilsNativeUInt PasDblStrUtils

PPasDblStrUtilsPointer PasDblStrUtils

PPasDblStrUtilsPtrInt PasDblStrUtils

PPasDblStrUtilsPtrUInt PasDblStrUtils

PPasDblStrUtilsRawByteChar PasDblStrUtils

PPasDblStrUtilsRawByteCharSet PasDblStrUtils

PPasDblStrUtilsRawByteString PasDblStrUtils

PPasDblStrUtilsRoundingMode PasDblStrUtils

PPasDblStrUtilsString PasDblStrUtils

PPasDblStrUtilsUInt16 PasDblStrUtils

PPasDblStrUtilsUInt32 PasDblStrUtils

PPasDblStrUtilsUInt64 PasDblStrUtils

PPasDblStrUtilsUInt8 PasDblStrUtils

PPasDblStrUtilsUTF16Char PasDblStrUtils

PPasDblStrUtilsUTF16String PasDblStrUtils

PPasDblStrUtilsUTF8Char PasDblStrUtils

PPasDblStrUtilsUTF8String PasDblStrUtils

PPasJSONChar PasJSON

PPasJSONDouble PasJSON

PPasJSONEncoding PasJSON

PPasJSONFloat PasJSON

PPasJSONInt16 PasJSON

PPasJSONInt32 PasJSON

PPasJSONInt64 PasJSON

PPasJSONInt8 PasJSON

PPasJSONModeFlag PasJSON

PPasJSONModeFlags PasJSON

PPasJSONNativeInt PasJSON

PPasJSONNativeUInt PasJSON

PPasJSONPointer PasJSON

PPasJSONPointers PasJSON

PPasJSONPtrDiff PasJSON

PPasJSONPtrInt PasJSON

PPasJSONPtrUInt PasJSON

PPasJSONRawByteChar PasJSON

PPasJSONRawByteString PasJSON

PPasJSONSize PasJSON

PPasJSONSizeInt PasJSON

PPasJSONSizeUInt PasJSON

PPasJSONUInt16 PasJSON

PPasJSONUInt32 PasJSON

PPasJSONUInt64 PasJSON

PPasJSONUInt8 PasJSON

PPasJSONUInt8Array PasJSON

PPasJSONUTF16Char PasJSON

PPasJSONUTF16String PasJSON

PPasJSONUTF8String PasJSON

PPasJSONVoid PasJSON

PPCharCG Cg.Import

PPCUgraphicsResource CUDA.Import

CUDA graphics interop resource
PPdObject ODE.Import

PPdxGeom ODE.Import

PPFXRegion GLS.ParticleFX

PPHeightTileInfo GLS.HeightTileFileHDS

PPivot Formats.m3DSTypes

PPoint2DRec GLScene.VectorTypesExt

PPoint3DRec GLScene.VectorTypesExt

PPoint3DS Formats.m3DSTypes

PPointArray Formats.m3DSTypes

PPointer Newton.Import

PPointerArray GLScene.VectorGeometry

PPointerVector GLScene.VectorGeometry

PPointFlagArray Formats.m3DSTypes

PPointList Formats.m3DSTypes

PPosTrackTag Formats.m3DSTypes

PPPasJSONChar PasJSON

PPPasJSONDouble PasJSON

PPPasJSONFloat PasJSON

PPPasJSONInt16 PasJSON

PPPasJSONInt32 PasJSON

PPPasJSONInt64 PasJSON

PPPasJSONInt8 PasJSON

PPPasJSONNativeInt PasJSON

PPPasJSONNativeUInt PasJSON

PPPasJSONPointer PasJSON

PPPasJSONPointers PasJSON

PPPasJSONPtrDiff PasJSON

PPPasJSONPtrInt PasJSON

PPPasJSONPtrUInt PasJSON

PPPasJSONRawByteChar PasJSON

PPPasJSONRawByteString PasJSON

PPPasJSONSize PasJSON

PPPasJSONSizeInt PasJSON

PPPasJSONSizeUInt PasJSON

PPPasJSONUInt16 PasJSON

PPPasJSONUInt32 PasJSON

PPPasJSONUInt64 PasJSON

PPPasJSONUInt8 PasJSON

PPPasJSONUInt8Array PasJSON

PPPasJSONUTF16Char PasJSON

PPPasJSONUTF16String PasJSON

PPPasJSONUTF8String PasJSON

PPPasJSONVoid PasJSON

PProcName Formats.m3DSTypes

PPSDL_Renderer SDL.Import

** * A structure representing rendering state *
PPSDL_Window SDL.Import

PPUInt8 SDL.Import

PQuaternion GLScene.VectorGeometry

q = ([x, y, z], w)
PQuaternionArray GLScene.VectorGeometry

PRayBias Formats.m3DSTypes

PRGBA32F GLS.ImageUtils

PROAMTriangleNode GLS.ROAMPatch

PRollTrackTag Formats.m3DSTypes

PRotTrackTag Formats.m3DSTypes

PScaleTrackTag Formats.m3DSTypes

PSceneObjectEntry GLS.ObjectManager

PSDLPantalla SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// *** KTI *** //////////////////////////////////////////////// ///////////////////////////////////////////////////////////////////////////////////////////////////// SDLPantalla contiene la ventana SDL el Render donde se pinta y el zoom de los ejes X e Y
PSDL_AudioCVT SDL.Import

PSDL_AudioSpec SDL.Import

** * The calculated values in this structure are calculated by SDL_OpenAudio(). *
PSDL_BlendMode SDL.Import

** * The blend mode used in SDL_RenderCopy() and drawing operations. *
PSDL_BlitMap SDL.Import

** * A collection of pixels used in software blitting. * * This structure should be treated as read-only, except for \c pixels, * which, if not NULL, contains the raw pixel data for the surface. *
PSDL_Color SDL.Import

PSDL_Colour SDL.Import

PSDL_Cond SDL.Import

* The SDL condition variable structure, defined in SDL_cond.c *
PSDL_Cursor SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_mouse.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////
PSDL_DisplayMode SDL.Import

** * The structure that defines a display mode * * SDL_GetNumDisplayModes() * SDL_GetDisplayMode() * SDL_GetDesktopDisplayMode() * SDL_GetCurrentDisplayMode() * SDL_GetClosestDisplayMode() * SDL_SetWindowDisplayMode() * SDL_GetWindowDisplayMode() *
PSDL_Event SDL.Import

** * General event structure *
PSDL_EventFilter SDL.Import

PSDL_Finger SDL.Import

PSDL_FingerID SDL.Import

PSDL_GameController SDL.Import

* The gamecontroller structure used to identify an SDL game controller *
PSDL_Haptic SDL.Import

** * SDL_Haptic * * The haptic structure used to identify an SDL haptic. * * SDL_HapticOpen * SDL_HapticOpenFromJoystick * SDL_HapticClose *
PSDL_HapticEffect SDL.Import

** * The generic template for any haptic effect. * * All values max at 32767 (0x7FFF). Signed values also can be negative. * Time values unless specified otherwise are in milliseconds. * * You can also pass SDL_HAPTIC_INFINITY to length instead of a 0-32767 * value. Neither delay, interval, attack_length nor fade_length support * SDL_HAPTIC_INFINITY. Fade will also not be used since effect never ends. * * Additionally, the SDL_HAPTIC_RAMP effect does not support a duration of * SDL_HAPTIC_INFINITY. * * Button triggers may not be supported on all devices, it is advised to not * use them if possible. Buttons start at index 1 instead of index 0 like * the joystick. * * If both attack_length and fade_level are 0, the envelope is not used, * otherwise both values are used. * * Common parts: * * // Replay - All effects have this * Uint32 length; // Duration of effect (ms). * Uint16 delay; // Delay before starting effect. * * // Trigger - All effects have this * Uint16 button; // Button that triggers effect. * Uint16 interval; // How soon before effect can be triggered again. * * // Envelope - All effects except condition effects have this * Uint16 attack_length; // Duration of the attack (ms). * Uint16 attack_level; // Level at the start of the attack. * Uint16 fade_length; // Duration of the fade out (ms). * Uint16 fade_level; // Level at the end of the fade. * * * * Here we have an example of a constant effect evolution in time: * Strength ˆ | | effect level –> _________________ | / \ | / \ | / \ | / \ | attack_level –> | \ | | | <— fade_level | +————————————————–> Time [–] [—] attack_length fade_length

[——————][———————–] delay length

* * Note either the attack_level or the fade_level may be above the actual * effect level. * * SDL_HapticConstant * SDL_HapticPeriodic * SDL_HapticCondition * SDL_HapticRamp * SDL_HapticCustom *
PSDL_Joystick SDL.Import

* The joystick structure used to identify an SDL joystick *
PSDL_KeyCode SDL.Import

** * The SDL virtual key representation. * * Values of this type are used to represent keyboard keys using the current * layout of the keyboard. These values include Unicode values representing * the unmodified character that would be generated by pressing the key, or * an SDLK_* constant for those keys that do not generate characters. *
PSDL_KeyMod SDL.Import

PSDL_Keysym SDL.Import

** * The SDL keysym structure, used in key events. *
PSDL_MessageBoxButtonData SDL.Import

** * Individual button data. *
PSDL_MessageBoxColor SDL.Import

** * RGB value used in a message box color scheme *
PSDL_MessageBoxColorScheme SDL.Import

** * A set of colors to use for message box dialogs *
PSDL_MessageBoxColorType SDL.Import

PSDL_MessageBoxData SDL.Import

** * MessageBox structure containing title, text, window, etc. *
PSDL_Mutex SDL.Import

PSDL_Mutex = Pointer; //todo!
PSDL_Palette SDL.Import

PSDL_PixelFormat SDL.Import

** * Everything in the pixel format structure is read-only. *
PSDL_Point SDL.Import

** * The structure that defines a point * * SDL_EnclosePoints *
PSDL_Rect SDL.Import

** * A rectangle, with the origin at the upper left. * * SDL_RectEmpty * SDL_RectEquals * SDL_HasIntersection * SDL_IntersectRect * SDL_UnionRect * SDL_EnclosePoints *
PSDL_Renderer SDL.Import

PSDL_RendererFlags SDL.Import

**< The renderer supports rendering to texture *
PSDL_RendererFlip SDL.Import

** * Flip constants for SDL_RenderCopyEx *
PSDL_RendererInfo SDL.Import

** * Information on the capabilities of a render driver or context. *
PSDL_RWops SDL.Import

* Read-Only memory stream *
PSDL_ScanCode SDL.Import

**< not a key, just marks the number of scancodes for array bounds *
PSDL_Sem SDL.Import

* The SDL semaphore structure, defined in SDL_sem.c *
PSDL_Surface SDL.Import

PSDL_SystemCursor SDL.Import

PSDL_SysWMEvent SDL.Import

** * A video driver dependent system event (event.syswm.*) * This event is disabled by default, you can enable it with SDL_EventState() * * If you want to use this event, you should include SDL_syswm.h. *
PSDL_SysWMinfo SDL.Import

The Windows custom window manager information structure
PSDL_SysWMmsg SDL.Import

The windows custom event structure
PSDL_Texture SDL.Import

** * An efficient driver-specific representation of pixel data *
PSDL_TextureAccess SDL.Import

** * The access pattern allowed for a texture. *
PSDL_TextureModulate SDL.Import

** * The texture channel modulation used in SDL_RenderCopy(). *
PSDL_Thread SDL.Import

PSDL_Thread = Pointer;
PSDL_ThreadFunction SDL.Import

* The function passed to SDL_CreateThread() It is passed a void* user context parameter and returns an int. *
PSDL_TouchID SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_touch.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////
PSDL_Version SDL.Import

** * Information the version of SDL in use. * * Represents the library's version as three levels: major revision * (increments with massive changes, additions, and enhancements), * minor revision (increments with backwards-compatible changes to the * major revision), and patchlevel (increments with fixes to the minor * revision). * * SDL_VERSION * SDL_GetVersion *
PSDL_Window SDL.Import

PSDL_WindowShapeMode SDL.Import

** A struct that tags the SDL_WindowShapeParams union with an enum describing the type of its contents. *
PSDL_WindowShaper SDL.Import

* Define the SDL window-shaper structure *
PSDL_WindowUserData SDL.Import

PShadowFilter Formats.m3DSTypes

PShadowMapSize Formats.m3DSTypes

PShadowRange Formats.m3DSTypes

PShadowSamples Formats.m3DSTypes

PShadowSets3DS Formats.m3DSTypes

PShortInt SDL.Import

PShortIntArray GLS.HeightTileFileHDS

PSingleArray GLScene.VectorGeometry

PSingleList Formats.m3DSTypes

PSingleRaster GLS.HeightData

PSInt16 SDL.Import

PSInt64 SDL.Import

PSInt8 SDL.Import

Psize_t OpenCL.Platform

Psmallint Newton.Import

PSmallIntArray GLS.HeightData

PSmallIntArray GLS.HeightTileFileHDS

PSmallIntRaster GLS.HeightData

PSmoothGroup Formats.m3DSTypes

PSoundFileFormat GLS.SoundFileObjects

PSpotCone3DS Formats.m3DSTypes

Cone visibility settings
PSpotLight3DS Formats.m3DSTypes

spotlight settings
PSpotProjector3DS Formats.m3DSTypes

spotlight projectio Bitmap
PSpotShadow3DS Formats.m3DSTypes

Spotlight shadow settings
PSqrt255Array GLScene.Utils

PTAG_APE_BINARY BASS.Import

Binary APEv2 tag structure
PTAG_BEXT BASS.Import

BWF "bext" tag structure
PTAG_ID3 BASS.Import

ID3v1 tag structure
PTdJointFeedback ODE.Import

PTexPoint GLScene.VectorGeometry

PTexPointArray GLScene.VectorGeometry

PTEXSChunk Formats.B3D

PTextureReference CUDA.Runtime

PTexVert3DS Formats.m3DSTypes

PTexVertList Formats.m3DSTypes

PTexVerts Formats.m3DSTypes

PThorpoint GLS.ThorFX

PThorpointArray GLS.ThorFX

PTrackHeader3DS Formats.m3DSTypes

PTriangleRecArray GLScene.VectorTypesExt

PTRISChunk Formats.B3D

PU1 Formats.LWO

PU2 Formats.LWO

PU2Array Formats.LWO

PU4 Formats.LWO

PU4Array Formats.LWO

PUInt16 SDL.Import

PUInt32 SDL.Import

PUInt8 SDL.Import

PUInt8Array SDL.Import

PUnknown Formats.VFW

PUserView3DS Formats.m3DSTypes

PVec12 Formats.LWO

PVec12Array Formats.LWO

PVector2f GLScene.VectorGeometry

PVector4f GLScene.VectorTypes

PVectorArray GLScene.VectorGeometry

PVectorRec GLScene.VectorTypesExt

PVertArray GLScene.VectorTypesExt

PVertex GLScene.VectorGeometry

PVertex2DArr GLS.Isolines

PVertexData Formats.B3D

PVGradient Formats.m3DSTypes

PVGradientBgnd3DS Formats.m3DSTypes

Color of Solid background
PVIDEOHDR Formats.VFW

– Video data block header ————————————————–
PViewCamera Formats.m3DSTypes

PViewport3DS Formats.m3DSTypes

PViewportData Formats.m3DSTypes

PViewportData3 Formats.m3DSTypes

PViewportLayout Formats.m3DSTypes

PViewportSize Formats.m3DSTypes

PViewSize3DS Formats.m3DSTypes

PViewStandard Formats.m3DSTypes

PViewUser Formats.m3DSTypes

PVOID Formats.VFW

*************************************************************************** * * types * **************************************************************************
PVoxelData GLScene.VectorTypesExt

PVoxelRec GLScene.VectorTypesExt

PVRTSChunk Formats.B3D

PWGLSwap GLScene.OpenGL4

PWGLswap GLScene.OpenGLTokens

========= Windows types ==============
PWordList Formats.m3DSTypes

PWordVector GLScene.VectorGeometry

PXDataAppName Formats.m3DSTypes

PXDataDouble Formats.m3DSTypes

PXDataEntry Formats.m3DSTypes

PXDataFloat Formats.m3DSTypes

PXDataLong Formats.m3DSTypes

PXDataRaw3DS Formats.m3DSTypes

PXDataShort Formats.m3DSTypes

PXDataString Formats.m3DSTypes

PXDataVoid Formats.m3DSTypes

PZArray GLS.zBuffer

QWORD BASS.Import

RawByteString gnugettext

RawUtf8String gnugettext

RECORDPROC BASS.Import

DSP callback function. NOTE: A DSP function should obviously be as quick as possible... other DSP functions, streams and MOD musics can not be processed until it's finished. handle : The DSP handle channel: Channel that the DSP is being applied to buffer : Buffer to apply the DSP to length : Number of bytes in the buffer user : The 'user' parameter given when calling BASS_ChannelSetDSP
SDL_HintPriority SDL.Import

/** * \brief An enumeration of hint priorities */
ShortElement CUDA.DataAccess

SInt16 SDL.Import

SInt32 SDL.Import

SInt64 SDL.Import

SInt8 SDL.Import

size_t SDL.Import

STREAMPROC BASS.Import

callback function types
String3DS Formats.m3DSTypes

String64 Formats.m3DSTypes

StringCG Cg.Import

SYNCPROC BASS.Import

Internet stream download callback function. buffer : Buffer containing the downloaded data... NULL=end of download length : Number of bytes in the buffer user : The 'user' parameter value given when calling BASS_StreamCreateURL
T1DPerlinArray GLS.Perlin

T2DPerlinArray GLS.Perlin

T48BitBlock GLS.ImageUtils

TAABBCorners GLScene.GeometryBB

Structure for storing the corners of an AABB, used with ExtractAABBCorners
TAABBOverlapEvent GLS.NGDManager

TAArray GLS.zBuffer

TAArrayIdx GLS.zBuffer

TAffineByteMatrix GLScene.VectorGeometry

TAffineByteVector GLScene.VectorGeometry

TAffineDblMatrix GLScene.VectorGeometry

TAffineDblVector GLScene.VectorGeometry

TAffineExtMatrix GLScene.VectorGeometry

TAffineExtVector GLScene.VectorGeometry

TAffineFltMatrix GLScene.VectorGeometry

TAffineFltVector GLScene.VectorGeometry

TAffineIntMatrix GLScene.VectorGeometry

TAffineIntVector GLScene.VectorGeometry

TAffineMatrix GLScene.VectorGeometry

TAffinePtrVector GLScene.VectorGeometry

TAffineVector GLScene.VectorGeometry

TAffineVectorArray GLScene.VectorGeometry

TAffineWordMatrix GLScene.VectorGeometry

TAffineWordVector GLScene.VectorGeometry

TALbitfield OpenAL.Import

OpenAL bitfields.
TALboolean OpenAL.Import

OpenAL boolean type.
TALbyte OpenAL.Import

OpenAL 8bit signed byte.
TALCboolean OpenAL.Import

ALC boolean type.
TALCbyte OpenAL.Import

ALC 8bit signed byte.
TALCchar OpenAL.Import

ALC character type
TALCcontext OpenAL.Import

ALC context
TALCdevice OpenAL.Import

ALC device
TALCdouble OpenAL.Import

ALC 64bit double point type.
TALCenum OpenAL.Import

ALC enumerations.
TALCfloat OpenAL.Import

ALC 32bit floating point type.
TALchar OpenAL.Import

character
TALCint OpenAL.Import

ALC 32bit signed integer type.
TALclampd OpenAL.Import

Openal clamped double.
TALclampf OpenAL.Import

OpenAL clamped float.
TALCshort OpenAL.Import

ALC 16bit signed short integer type.
TALCsizei OpenAL.Import

ALC 32bit type.
TALCubyte OpenAL.Import

ALC 8bit unsigned byte.
TALCuint OpenAL.Import

ALC 32bit unsigned integer type.
TALCushort OpenAL.Import

ALC 16bit unsigned short integer type.
TALCvoid OpenAL.Import

ALC void type
TALdouble OpenAL.Import

OpenAL 64bit double point type.
TALenum OpenAL.Import

OpenAL enumerations.
TALfloat OpenAL.Import

OpenAL 32bit floating point type.
TALint OpenAL.Import

OpenAL 32bit signed integer type.
TALshort OpenAL.Import

OpenAL 16bit signed short integer type.
TALsizei OpenAL.Import

OpenAL 32bit type.
TALuByte OpenAL.Import

OpenAL 8bit unsigned byte.
TALuint OpenAL.Import

OpenAL 32bit unsigned integer type.
TALushort OpenAL.Import

OpenAL 16bit unsigned short integer type.
TALvoid OpenAL.Import

OpenAL void type
TAMFloatVector GLScene.RandomLib

Used as a Dynamic Vector
TANG4 Formats.LWO

TApplyForceAndTorqueEvent GLS.NGDManager

TArray3DExt GLScene.VectorTypesExt

TASETextureMap GLS.FileASE

TAtmosphereType3DS Formats.m3DSTypes

TAVICompressor GLS.AVIRecorder

TAVIFileInfo Formats.VFW

TAVIImageRetrievalMode GLS.AVIRecorder

Image retrieval mode for frame capture. Following modes are supported: irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution
TAVIRecorderPostProcessEvent GLS.AVIRecorder

TAVIRecorderState GLS.AVIRecorder

TAVISAVECALLBACK Formats.VFW

TAVISizeRestriction GLS.AVIRecorder

Frame size restriction. Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.
TAVIStreamInfo Formats.VFW

TB3DChunkType Formats.B3D

TBackgroundType3DS Formats.m3DSTypes

enumerate list of possible backgrounds used in file
TBASS3DAlgorithm GLS.Sounds.BASS

TBASSModuleHandle BASS.Import

This function is defined in the implementation part of this unit. It is not part of BASS.DLL but an extra function which makes it easier to set the predefined EAX environments. env : a EAX_ENVIRONMENT_xxx constant
TBASS_PLUGINFORMS BASS.Import

TBitmapBgnd3DS Formats.m3DSTypes

TBodyFlags ODE.Import

Change: New Type added, syntax enforcement
TBorderType GLS.Memo

TBSPBBox Formats.Q3BSP

TBSPRenderSort GLS.MeshBSP

TBumpMethod GLSL.BumpShaders

TBumpOption GLSL.BumpShaders

TBumpOptions GLSL.BumpShaders

Enable parallax offset mapping
TBumpSpace GLSL.BumpShaders

TByteArray GLS.HeightData

to CreateMonochromeBitmap
TByteMatrixArr GLS.Isolines

TByteRaster GLS.HeightData

TByteVector GLScene.VectorGeometry

TByteVectorArr GLS.Isolines

TCalcPointEvent GLS.ThorFX

TCAPCONTROLCALLBACK Formats.VFW

TCAPERRORCALLBACK Formats.VFW

TCAPERRORCALLBACKA Formats.VFW

TCAPERRORCALLBACKW Formats.VFW

TCAPSTATUSCALLBACK Formats.VFW

TCAPSTATUSCALLBACKA Formats.VFW

TCAPSTATUSCALLBACKW Formats.VFW

TCAPVIDEOCALLBACK Formats.VFW

TCAPWAVECALLBACK Formats.VFW

TCAPYIELDCALLBACK Formats.VFW

– Callback definitions —————————————————–
TCardinalArray Formats.m3DSTypes

TCardinalVector GLScene.VectorGeometry

TCastArray GLS.Isolines

TCgApplyEvent GLS.CgShader

TCGbool Cg.Import

TCGenum Cg.Import

"Connecting the parameters failed because The type of the source parameter is not defined within the given program or does not match the type with the same name in the program."
TCGerror Cg.Import

TCGerrorCallbackFunc Cg.Import

TCgFPProfile GLS.CgShader

Available fragment program profile
TCGGLenum Cg.GL

***************************************************************************
TCGprofile Cg.Import

* The following macro invocations define the supported CG profiles. * * The macros have the form : * * CG_PROFILE_MACRO(name, compiler_id, compiler_opt) * * name : The name of the profile. Used consistently with the API. * compiler_id : The identifier string for the profile used by the compiler. * compiler_id_caps : compiler_id in caps. * compiler_opt : The command-line switch used to force compilation into * the profile. * int_id : Integer enumerant associated with this bind location. * vertex_profile : Non-zero if this is a vertex profile, otherwise it * is considered to be a fragment profile. * *
TcgProgramType GLS.CgShader

TCGresource Cg.Import

* The following macro invocations define the supported CG basic hardware * bind locations. * * The macros have the form : * * CG_BINDLOCATION_MACRO(name, compiler_name, enum_int) * * name : The name of the location. * enum_name : The C enumerant. * compiler_name : The name of the location within the compiler syntax. * int_id : Integer enumerant associated with this bind location. * addressable : The bind location must have an integer address * associated with it. * ParamType : the cgParamType of this register. *
TCgShaderEvent GLS.CgShader

TCGtype Cg.Import

* The following macro invocations define the supported CG basic data types. * * The macros have the form : * * CG_DATATYPE_MACRO(name, compiler_name, nrows, ncols) * * name : The name of the data type. * compiler_name : The name of the data type within the compiler syntax. * enum_name : The C enumerant. * nrows : Number of rows for matrix types. Should be 0 other-wise. * ncols : Number of columns for matrix types. Should be 0 * other-wise. *
TCgUnApplyEvent GLS.CgShader

TCgVPProfile GLS.CgShader

Available vertex program profile
TChunkList Formats.m3DSTypes

TClose SDL.Import

** * Close and free an allocated SDL_RWops structure. * * 0 if successful or -1 on write error when flushing data. *
Tcl_addressing_mode OpenCL.Import

Tcl_bitfield OpenCL.Import

Tcl_bool OpenCL.Import

Tcl_buffer_create_type OpenCL.Import

Tcl_build_status OpenCL.Import

Tcl_channel_order OpenCL.Import

Tcl_channel_type OpenCL.Import

Tcl_char OpenCL.Platform

scalar types
Tcl_char16 OpenCL.Platform

Tcl_char2 OpenCL.Platform

* Vector types * * Note: OpenCL requires that all types be naturally aligned. * This means that vector types must be naturally aligned. * For example, a vector of four floats must be aligned to * a 16 byte boundary (calculated as 4 * the natural 4-byte * alignment of the float). The alignment qualifiers here * will only function properly if your compiler supports them * and if you don't actively work to defeat them. For example, * in order for a cl_float4 to be 16 byte aligned in a struct, * the start of the struct must itself be 16-byte aligned. * * Maintaining proper alignment is the user's responsibility.
Tcl_char4 OpenCL.Platform

Tcl_char8 OpenCL.Platform

Tcl_command_queue OpenCL.Import

Tcl_command_queue_info OpenCL.Import

Tcl_command_queue_properties OpenCL.Import

Tcl_command_type OpenCL.Import

Tcl_context OpenCL.Import

Tcl_context_info OpenCL.Import

Tcl_context_notify OpenCL.Import

CL_API_SUFFIX__VERSION_2_1 * Context APIs *//
Tcl_context_properties OpenCL.Import

Tcl_destructor_notify OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
Tcl_device_affinity_domain OpenCL.Import

Tcl_device_exec_capabilities OpenCL.Import

Tcl_device_fp_config OpenCL.Import

Tcl_device_id OpenCL.Import

Tcl_device_info OpenCL.Import

Tcl_device_local_mem_type OpenCL.Import

Tcl_device_mem_cache_type OpenCL.Import

Tcl_device_partition_property OpenCL.Import

Tcl_device_svm_capabilities OpenCL.Import

Tcl_device_type OpenCL.Import

Tcl_double OpenCL.Platform

Tcl_double16 OpenCL.Platform

Tcl_double2 OpenCL.Platform

Tcl_double4 OpenCL.Platform

Tcl_double8 OpenCL.Platform

Tcl_EnqueueNativeKernel OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
Tcl_EnqueueSVM_fn OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
Tcl_event OpenCL.Import

Tcl_event_info OpenCL.Import

Tcl_event_notify OpenCL.Import

CL_API_SUFFIX__VERSION_1_1
Tcl_filter_mode OpenCL.Import

Tcl_float OpenCL.Platform

Tcl_float16 OpenCL.Platform

Tcl_float2 OpenCL.Platform

Tcl_float4 OpenCL.Platform

Tcl_float8 OpenCL.Platform

Tcl_gl_context_info OpenCL.GL

Tcl_gl_object_type OpenCL.GL

Tcl_gl_platform_info OpenCL.GL

Tcl_gl_texture_info OpenCL.GL

Tcl_half OpenCL.Platform

Tcl_image_info OpenCL.Import

Tcl_int OpenCL.Platform

Tcl_int16 OpenCL.Platform

Tcl_int2 OpenCL.Platform

Tcl_int4 OpenCL.Platform

Tcl_int8 OpenCL.Platform

Tcl_kernel OpenCL.Import

Tcl_kernel_arg_access_qualifier OpenCL.Import

Tcl_kernel_arg_address_qualifier OpenCL.Import

Tcl_kernel_arg_info OpenCL.Import

Tcl_kernel_arg_type_qualifier OpenCL.Import

Tcl_kernel_exec_info OpenCL.Import

Tcl_kernel_info OpenCL.Import

Tcl_kernel_sub_group_info OpenCL.Import

Tcl_kernel_work_group_info OpenCL.Import

Tcl_long OpenCL.Platform

Tcl_long16 OpenCL.Platform

Tcl_long2 OpenCL.Platform

Tcl_long4 OpenCL.Platform

Tcl_long8 OpenCL.Platform

Tcl_map_flags OpenCL.Import

Tcl_mem OpenCL.Import

Tcl_mem_flags OpenCL.Import

Tcl_mem_info OpenCL.Import

Tcl_mem_migration_flag OpenCL.Import

Tcl_mem_object_type OpenCL.Import

Tcl_pipe_info OpenCL.Import

Tcl_pipe_properties OpenCL.Import

Tcl_platform_id OpenCL.Import

Tcl_platform_info OpenCL.Import

Tcl_profiling_info OpenCL.Import

Tcl_program OpenCL.Import

Tcl_programbuilt_notify OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
Tcl_program_binary_type OpenCL.Import

Tcl_program_build_info OpenCL.Import

Tcl_program_info OpenCL.Import

Tcl_queue_properties OpenCL.Import

Tcl_sampler OpenCL.Import

Tcl_sampler_info OpenCL.Import

Tcl_sampler_properties OpenCL.Import

Tcl_short OpenCL.Platform

Tcl_short16 OpenCL.Platform

Tcl_short2 OpenCL.Platform

Tcl_short4 OpenCL.Platform

Tcl_short8 OpenCL.Platform

Tcl_svm_mem_flags OpenCL.Import

Tcl_uchar OpenCL.Platform

Tcl_uchar16 OpenCL.Platform

Tcl_uchar2 OpenCL.Platform

Tcl_uchar4 OpenCL.Platform

Tcl_uchar8 OpenCL.Platform

Tcl_uint OpenCL.Platform

Tcl_uint16 OpenCL.Platform

Tcl_uint2 OpenCL.Platform

Tcl_uint4 OpenCL.Platform

Tcl_uint8 OpenCL.Platform

Tcl_ulong OpenCL.Platform

Tcl_ulong16 OpenCL.Platform

Tcl_ulong2 OpenCL.Platform

Tcl_ulong4 OpenCL.Platform

Tcl_ulong8 OpenCL.Platform

Tcl_ushort OpenCL.Platform

Tcl_ushort16 OpenCL.Platform

Tcl_ushort2 OpenCL.Platform

Tcl_ushort4 OpenCL.Platform

Tcl_ushort8 OpenCL.Platform

TCollisionBoundingMode GLS.Collision

Defines how fine collision bounding is for a particular object. Possible values are : cbmPoint : the object is punctual and may only collide with volumes cbmSphere : the object is defined by its bounding sphere (radius is the max of axis-aligned dimensions) cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid cbmCube : the object is defined by a bounding axis-aligned "cube" cbmFaces : the object is defined by its faces (needs object-level support, if unavailable, uses cbmCube code)
TCollisionConstraintTypes GLS.VerletTypes

TCollisionConstraintTypesSet GLS.VerletTypes

TCollisionIteratorEvent GLS.NGDManager

Events for Newton Callback
TColr12 Formats.LWO

TColr12DynArray Formats.LWO

TColr4 Formats.LWO

TCombinerCache GLS.TextureCombiners

TCommand GLS.Memo

TCompressionLevel GLS.ArchiveManager

TConeStyle3DS Formats.m3DSTypes

Spotlight projection cone shape
TContactProcessEvent GLS.NGDManager

TCSGOperation GLS.MeshCSG

TCuAddresMode GLS.CUDA.APIComps

TCUaddress_mode CUDA.Import

Texture reference addressing modes
TcuArray3DCreate CUDA.Import

TcuArray3DGetDescriptor CUDA.Import

TcuArrayCreate CUDA.Import

TcuArrayDestroy CUDA.Import

TcuArrayGetDescriptor CUDA.Import

TCUarray_cubemap_face CUDA.Import

Array indices for cube faces
TCUarray_format CUDA.Import

Array formats
TCubicSplineMatrix GLScene.Spline

TCUcomputemode CUDA.Import

Compute Modes
TcuCtxAttach CUDA.Import

TcuCtxCreate CUDA.Import

TcuCtxDestroy CUDA.Import

TcuCtxDetach CUDA.Import

TcuCtxGetDevice CUDA.Import

TcuCtxPopCurrent CUDA.Import

TcuCtxPushCurrent CUDA.Import

TcuCtxSynchronize CUDA.Import

TCUctx_flags CUDA.Import

Context creation flags
TCUDAChange GLS.CUDA.APIComps

TCUDAChanges GLS.CUDA.APIComps

TCudaChannelFormatKind CUDA.Runtime

+//DEVICE_BUILTIN*/
TCUDAChannelNum GLS.CUDA.APIComps

TCUDAChannelType GLS.CUDA.APIComps

TCUDAComponentClass GLS.CUDA.APIComps

TCUDAContextList GLS.CUDA.Context

TCUDADeviceList GLS.CUDA.Context

TcudaError CUDA.Runtime

TCUDAFFTdir GLS.CUDA.FFTPlan

TCUDAFFTransform GLS.CUDA.FFTPlan

TcudaFuncCache CUDA.Import

* * CUDA function cache configurations
TCudaGLMapFlags CUDA.Runtime

TCUDAHandleList GLS.CUDA.Context

TcudaLimit CUDA.Import

* * CUDA Limits
TCUDAMapping GLS.CUDA.APIComps

TcudaMemcpyKind CUDA.Runtime

+//DEVICE_BUILTIN*/
TCUDAMemMapFlag GLS.CUDA.APIComps

TCUDAMemMapFlags GLS.CUDA.APIComps

Fast write, slow read
TCUDAMemType GLS.CUDA.APIComps

TcudaRoundMode CUDA.FourierTransform

TcudaTextureAddressMode CUDA.Runtime

TcudaTextureFilterMode CUDA.Runtime

TcudaTextureReadMode CUDA.Runtime

TCUDAType CUDA.Parser

TCUdevice CUDA.Import

CUDA device
TcuDeviceComputeCapability CUDA.Import

TcuDeviceGet CUDA.Import

TcuDeviceGetAttribute CUDA.Import

TcuDeviceGetCount CUDA.Import

TcuDeviceGetName CUDA.Import

TcuDeviceGetProperties CUDA.Import

TCUdeviceptr CUDA.Import

CUDA device pointer
TcuDeviceTotalMem CUDA.Import

TCUdevice_attribute CUDA.Import

Device properties
TCUDPPAlgorithm CUDA.ParallelPrimitives

Maximum of two operands
TCUDPPDatatype CUDA.ParallelPrimitives

Each key has an associated value
TCUDPPHandle CUDA.ParallelPrimitives

TCUDPPOperator CUDA.ParallelPrimitives

Float type (C float)
TCUDPPOption CUDA.ParallelPrimitives

Unknown or untraceable error.
TCUDPPResult CUDA.ParallelPrimitives

TcuDriverGetVersion CUDA.Import

TcuEventCreate CUDA.Import

TcuEventDestroy CUDA.Import

TcuEventElapsedTime CUDA.Import

TcuEventQuery CUDA.Import

TcuEventRecord CUDA.Import

TcuEventSynchronize CUDA.Import

TCUevent_flags CUDA.Import

Event creation flags
TcufftCompatibility CUDA.FourierTransform

Certain R2C and C2R transforms go much more slowly when FFTW memory layout and behaviour is required. The default is "best performance", which means not-compatible-with-fftw. Use the cufftSetCompatibilityMode API to enable exact FFTW-like behaviour.

These flags can be ORed together to select precise FFTW compatibility behaviour. The two levels presently supported are:

CUFFT_COMPATIBILITY_FFTW_PADDING Inserts extra padding between packed in-place transforms for batched transforms with power-of-2 size.

CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC Guarantees FFTW-compatible output for non-symmetric complex inputs for transforms with power-of-2 size. This is only useful for artificial (i.e. random) datasets as actual data will always be symmetric if it has come from the real plane. If you don't understand what this means, you probably don't have to use it.

CUFFT_COMPATIBILITY_FFTW For convenience, enables all FFTW compatibility modes at once.
TcufftDestroy CUDA.FourierTransform

TcufftDoubleReal CUDA.FourierTransform

TcufftExecC2C CUDA.FourierTransform

TcufftExecC2R CUDA.FourierTransform

TcufftExecD2Z CUDA.FourierTransform

TcufftExecR2C CUDA.FourierTransform

TcufftExecZ2D CUDA.FourierTransform

TcufftExecZ2Z CUDA.FourierTransform

TcufftHandle CUDA.FourierTransform

CUFFT API function return values CUFFT defines and supports the following data types cufftHandle is a handle type used to store and access CUFFT plans.
TcufftPlan1d CUDA.FourierTransform

TcufftPlan2d CUDA.FourierTransform

TcufftPlan3d CUDA.FourierTransform

TcufftPlanMany CUDA.FourierTransform

TcufftReal CUDA.FourierTransform

TcufftRealfloat CUDA.FourierTransform

TcufftResult CUDA.FourierTransform

TcufftSetCompatibilityMode CUDA.FourierTransform

TcufftSetStream CUDA.FourierTransform

TcufftType CUDA.FourierTransform

TCuFilterMode GLS.CUDA.APIComps

TCUfilter_mode CUDA.Import

Texture reference filtering modes
TcuFuncGetAttribute CUDA.Import

TcuFuncSetBlockShape CUDA.Import

TcuFuncSetSharedSize CUDA.Import

TCUfunction_attribute CUDA.Import

Function properties
TcuGLCtxCreate CUDA.Import

TcuGLInit CUDA.Import

TcuGLMapBufferObject CUDA.Import

TcuGLMapBufferObjectAsync CUDA.Import

TCUGLmap_flags CUDA.Import

Flags to map or unmap a resource
TcuGLRegisterBufferObject CUDA.Import

TcuGLSetBufferObjectMapFlags CUDA.Import

TcuGLUnmapBufferObject CUDA.Import

TcuGLUnmapBufferObjectAsync CUDA.Import

TcuGLUnregisterBufferObject CUDA.Import

TcuGraphicsGLRegisterBuffer CUDA.Import

TcuGraphicsGLRegisterImage CUDA.Import

TCUgraphicsMapResourceFlags CUDA.Import

Flags for mapping and unmapping interop resources
TcuGraphicsMapResources CUDA.Import

TCUgraphicsRegisterFlags CUDA.Import

Flags to register a graphics resource
TcuGraphicsResourceGetMappedPointer CUDA.Import

TcuGraphicsResourceSetMapFlags CUDA.Import

TcuGraphicsSubResourceGetMappedArray CUDA.Import

TcuGraphicsUnmapResources CUDA.Import

TcuGraphicsUnregisterResource CUDA.Import

TcuInit CUDA.Import

TCUjit_fallback CUDA.Import

Cubin matching fallback strategies
TCUjit_option CUDA.Import

Online compiler options
TCUjit_target CUDA.Import

Online compilation targets
TcuLaunch CUDA.Import

TcuLaunchGrid CUDA.Import

TcuLaunchGridAsync CUDA.Import

TcuMemAlloc CUDA.Import

TcuMemAllocHost CUDA.Import

TcuMemAllocPitch CUDA.Import

TcuMemcpy2D CUDA.Import

TcuMemcpy2DAsync CUDA.Import

TcuMemcpy2DUnaligned CUDA.Import

TcuMemcpy3D CUDA.Import

TcuMemcpy3DAsync CUDA.Import

TcuMemcpyAtoA CUDA.Import

TcuMemcpyAtoD CUDA.Import

TcuMemcpyAtoH CUDA.Import

TcuMemcpyAtoHAsync CUDA.Import

TcuMemcpyDtoA CUDA.Import

TcuMemcpyDtoD CUDA.Import

TcuMemcpyDtoDAsync CUDA.Import

TcuMemcpyDtoH CUDA.Import

TcuMemcpyDtoHAsync CUDA.Import

TcuMemcpyHtoA CUDA.Import

TcuMemcpyHtoAAsync CUDA.Import

TcuMemcpyHtoD CUDA.Import

TcuMemcpyHtoDAsync CUDA.Import

TcuMemFree CUDA.Import

TcuMemFreeHost CUDA.Import

TcuMemGetAddressRange CUDA.Import

TcuMemGetInfo CUDA.Import

TcuMemHostAlloc CUDA.Import

TcuMemHostGetDevicePointer CUDA.Import

TcuMemHostGetFlags CUDA.Import

TCUmemorytype CUDA.Import

Memory types
TcuMemsetD16 CUDA.Import

TcuMemsetD2D16 CUDA.Import

TcuMemsetD2D32 CUDA.Import

TcuMemsetD2D8 CUDA.Import

TcuMemsetD32 CUDA.Import

TcuMemsetD8 CUDA.Import

TcuModuleGetFunction CUDA.Import

TcuModuleGetGlobal CUDA.Import

TcuModuleGetTexRef CUDA.Import

TcuModuleLoad CUDA.Import

TcuModuleLoadData CUDA.Import

TcuModuleLoadDataEx CUDA.Import

TcuModuleLoadFatBinary CUDA.Import

TcuModuleUnload CUDA.Import

TcuParamSetf CUDA.Import

TcuParamSeti CUDA.Import

TcuParamSetSize CUDA.Import

TcuParamSetTexRef CUDA.Import

TcuParamSetv CUDA.Import

TCUresult CUDA.Import

************************************ ** ** Error codes ** ***********************************/ Error codes
TcuStreamCreate CUDA.Import

TcuStreamDestroy CUDA.Import

TcuStreamQuery CUDA.Import

TcuStreamSynchronize CUDA.Import

TcuTexRefCreate CUDA.Import

TcuTexRefDestroy CUDA.Import

TcuTexRefGetAddress CUDA.Import

TcuTexRefGetAddressMode CUDA.Import

TcuTexRefGetArray CUDA.Import

TcuTexRefGetFilterMode CUDA.Import

TcuTexRefGetFlags CUDA.Import

TcuTexRefGetFormat CUDA.Import

TcuTexRefSetAddress CUDA.Import

TcuTexRefSetAddress2D CUDA.Import

TcuTexRefSetAddressMode CUDA.Import

TcuTexRefSetArray CUDA.Import

TcuTexRefSetFilterMode CUDA.Import

TcuTexRefSetFlags CUDA.Import

TcuTexRefSetFormat CUDA.Import

TcuWGLGetDevice CUDA.Import

Td3Axis ODE.Import

TdAABB ODE.Import

No typedef for AABB
TdAABBTestFn ODE.Import

TdAngularMotorModeNumbers ODE.Import

TDBType3DS Formats.m3DSTypes

Database type settings
TDCECollisionEvent GLS.DCE

TDCECollisionSelection GLS.DCE

Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: ccsDCEStandard: Collides bodies if A.layer <= B.layer ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0)
TDCEObjectCollisionEvent GLS.DCE

TDCEShape GLS.DCE

Only csEllipsoid can have dynamic behaviour
TDCESlideOrBounce GLS.DCE

TdColliderFn ODE.Import

TDComplete GLScene.Triangulation

TdContactType ODE.Import

Change: New Type added, syntax enforcement
TDebugLogger gnugettext

TDebugProc GLScene.OpenGLTokens

TDebugProcAMD GLScene.OpenGLTokens

TDEdges GLScene.Triangulation

TDelimiters GLS.Memo

TdErrorType ODE.Import

TDeSerializeEvent GLS.NGDManager

TDESolverType GLS.PhysManager

only ssEuler is usable at the moment
TdGeomDtorFn ODE.Import

TdGetAABBFn ODE.Import

TdGetColliderFnFn ODE.Import

TDim3 CUDA.Import

TdInteger3 ODE.Import

TdIntegerArray ODE.Import

Tri-list collider
TDirPlan GLScene.GeometryBB

TdJointGroupID ODE.Import

TdJointID ODE.Import

TdJointTypeNumbers ODE.Import

TDlInnerRange Formats.m3DSTypes

TDlMultiplier Formats.m3DSTypes

TDlOuterRange Formats.m3DSTypes

TDlRayBias Formats.m3DSTypes

TDlSpotAspect Formats.m3DSTypes

TDlSpotRoll Formats.m3DSTypes

TdMatrix3 ODE.Import

typedef dReal dMatrix3[4*3];
TdMatrix3_As3x4 ODE.Import

TdMatrix4 ODE.Import

typedef dReal dMatrix4[4*4];
TdMatrix6 ODE.Import

typedef dReal dMatrix6[8*6];
TdMovedCallback ODE.Import

Whenever a body has its position or rotation changed during the timestep, the callback will be called (with body as the argument). Use it to know which body may need an update in an external structure (like a 3D engine).
TdNearCallback ODE.Import

Collission callback structure
TDoubleArray GLScene.Polynomials

TDoubleArray GLScene.VectorTypesExt

TDoubleHmgPlane GLScene.VectorGeometry

TDoubleVector GLScene.VectorGeometry

TDProgressEvent GLScene.Triangulation

TdQuaternion ODE.Import

typedef dReal dQuaternion[4];
TdReal ODE.Import

body is not influenced by gravity
TdRealArray ODE.Import

TdRealHugeArray ODE.Import

TDTriangle GLScene.Triangulation

TdTriArrayCallback ODE.Import

Per object callback. Allows the user to get the list of triangles in 1 shot. Maybe we should remove this one.
TdTriCallback ODE.Import

Per triangle callback. Allows the user to say if he wants a collision with a particular triangle.
TdTriRayCallback ODE.Import

Allows the user to say if a ray collides with a triangle on barycentric coords. The user can for example sample a texture with alpha transparency to determine if a collision should occur.
TDumpLevel Formats.m3DSTypes

for TStringList —————- commonly used structures ———————————-
TdVector3 ODE.Import

typedef dReal dVector33[4];
TdVector3Array ODE.Import

TdVector4 ODE.Import

typedef dReal dVector4[4];
TDVertex GLScene.Triangulation

TdxJointLimitMotor3 ODE.Import

TdxJointNull ODE.Import

TdxSimpleSpace ODE.Import

Copies settings from TdxSpace, beacause pascal doeasn't do inheritance for records
TEaseType GLScene.AnimationUtils

TECColliderList GLS.EllipseCollision

TECColliderShape GLS.EllipseCollision

TECContactList GLS.EllipseCollision

TECFreeFormList GLS.EllipseCollision

TECTriMeshList GLS.EllipseCollision

TEulerOrder GLScene.VectorGeometry

—————————————————————————- Quaternion functions —————————————————————————-
TExtendedVector GLScene.VectorGeometry

TF4 Formats.LWO

TF4Array Formats.LWO

TF4DynArray Formats.LWO

TFaceList Formats.m3DSTypes

TFastCollisionChecker GLS.Collision

TFColorList Formats.m3DSTypes

TFeedBackMeshLaunching GLS.CUDA.Graphics

TFeedBackMeshPrimitive GLS.CUDA.Graphics

TFilterType3DS Formats.m3DSTypes

TFindCuFileFunc GLS.CUDA.Compiler

TFloatPercentage Formats.m3DSTypes

TFloatVector GLScene.VectorGeometry

TFMetaDataCallback FMOD.types

TFModErrors FMOD.types

[ENUM] [ [DESCRIPTION] On failure of commands in FMOD, use FSOUND_GetError to attain what happened.

[SEE_ALSO] FSOUND_GetError ]
TFMusicCallback FMOD.types

TFMusicTypes FMOD.types

[ENUM] [ [DESCRIPTION] These definitions describe the type of song being played.

[SEE_ALSO] FMUSIC_GetType ]
TFogDistance GLS.Scene

Fog distance calculation mode. fdDefault: let OpenGL use its default formula fdEyeRadial: uses radial "true" distance (best quality) fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.
TFogMode GLS.Scene

TFOURCC Formats.DXTC

TFSoundAllocCallback FMOD.types

TFSoundCloseCallback FMOD.types

TFSoundDSPCallback FMOD.types

TFSoundFreeCallback FMOD.types

TFSoundFXModes FMOD.types

[ENUM] [ [DESCRIPTION] These values are used with FSOUND_FX_Enable to enable DirectX 8 FX for a channel.

[SEE_ALSO] FSOUND_FX_Enable FSOUND_FX_Disable FSOUND_FX_SetChorus FSOUND_FX_SetCompressor FSOUND_FX_SetDistortion FSOUND_FX_SetEcho FSOUND_FX_SetFlanger FSOUND_FX_SetGargle FSOUND_FX_SetI3DL2Reverb FSOUND_FX_SetParamEQ FSOUND_FX_SetWavesReverb ]
TFSoundMixerTypes FMOD.types

[ENUM] [ [DESCRIPTION] These mixer types are used with FSOUND_SetMixer, to choose which mixer to use, or to act upon for other reasons using FSOUND_GetMixer. It is not necessary to set the mixer. FMOD will autodetect the best mixer for you.

[SEE_ALSO] FSOUND_SetMixer FSOUND_GetMixer ]
TFSoundOpenCallback FMOD.types

TFSoundOutputTypes FMOD.types

[ENUM] [ [DESCRIPTION] These output types are used with FSOUND_SetOutput, to choose which output driver to use.

FSOUND_OUTPUT_DSOUND will not support hardware 3d acceleration if the sound card driver does not support DirectX 6 Voice Manager Extensions.

FSOUND_OUTPUT_WINMM is recommended for NT and CE.

[SEE_ALSO] FSOUND_SetOutput FSOUND_GetOutput ]
TFSoundReadCallback FMOD.types

TFSoundReallocCallback FMOD.types

TFSoundSeekCallback FMOD.types

TFSoundSpeakerModes FMOD.types

[ENUM] [ [DESCRIPTION] These are speaker types defined for use with the FSOUND_SetSpeakerMode command. Note - Only reliably works with FSOUND_OUTPUT_DSOUND or FSOUND_OUTPUT_XBOX output modes. Other output modes will only interpret FSOUND_SPEAKERMODE_MONO and set everything else to be stereo.

[SEE_ALSO] FSOUND_SetSpeakerMode

[REMARKS] Note - Only reliably works with FSOUND_OUTPUT_DSOUND or FSOUND_OUTPUT_XBOX output modes. Other output modes will only interpret FSOUND_SPEAKERMODE_MONO and set everything else to be stereo.

Using either DolbyDigital or DTS will use whatever 5.1 digital mode is available if destination hardware is unsure. ]
TFSoundStreamCallback FMOD.types

Callback types
TFSoundStreamNetStatus FMOD.types

[ENUM] [ [DESCRIPTION] Status values for internet streams. Use FSOUND_Stream_Net_GetStatus to get the current status of an internet stream.

[SEE_ALSO] FSOUND_Stream_Net_GetStatus ]
TFSoundTagFieldType FMOD.types

[ENUM] [ [DESCRIPTION] Describes the type of a particular tag field.

[SEE_ALSO] FSOUND_Stream_GetNumTagFields FSOUND_Stream_GetTagField FSOUND_Stream_FindTagField ]
TFSoundTellCallback FMOD.types

TFXPointerList GLS.ParticleFX

TGetLineAttrsEvent GLS.Memo

TGetPluralForm gnugettext

Set Discard to false if output should still go to ordinary debug log
TGetTerrainBoundsEvent GLS.TerrainRenderer

TGLABone Formats.GL2

TGLAcceptMouseQuery GLS.Windows

TGLACompQuatBone Formats.GL2

TGLActiveAttribArray GLSL.Shader

TGLActorAnimationMode GLS.VectorFileObjects

Defines how an actor plays between its StartFrame and EndFrame. aamNone : no animation is performed aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward aamExternal : Allows for external animation control
TGLActorAnimationName GLS.VectorFileObjects

TGLActorAnimationReference GLS.VectorFileObjects

TGLActorFrameInterpolation GLS.VectorFileObjects

Actor frame-interpolation mode. - afpNone : no interpolation, display CurrentFrame only - afpLinear : perform linear interpolation between current and next frame
TGLActorOption GLS.VectorFileObjects

Miscellanious actor options. aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance.
TGLActorOptions GLS.VectorFileObjects

TGLActorProxyAnimationMode GLS.ProxyObjects

pamLoop mode was too difficalt to implement, so it was discarded ...for now. pamPlayOnce only works if Actor.AnimationMode <> aamNone.
TGLAdvancedBlurImagePrepareEvent GLS.Blur

TGLAFIOCreateFileStream GLS.ApplicationFileIO

TGLAFIOFileStreamEvent GLS.ApplicationFileIO

TGLAFIOFileStreamExists GLS.ApplicationFileIO

TGLAFIOFileStreamExistsEvent GLS.ApplicationFileIO

TGlAlphaFunc GLS.Material

TGLAngleLimit180 GLS.Objects

TGLAngleLimit360 GLS.Objects

TGLAnnulusPart GLS.GeomObjects

TGLAnnulusParts GLS.GeomObjects

TGLAntiAliasing GLS.Context

TGLApplicationResource GLS.ApplicationFileIO

TGLArcDirection GLS.Canvas

TGLArrowArcPart GLS.GeomObjects

TGLArrowArcParts GLS.GeomObjects

TGLArrowHeadStyle GLS.GeomObjects

TGLArrowLinePart GLS.GeomObjects

TGLArrowLineParts GLS.GeomObjects

TGLASkeletonOffsets Formats.GL2

14 bytes
TGLAsmShaderEvent GLSL.AsmShader

TGLAsmShaderUnUplyEvent GLSL.AsmShader

TGLAtmosphereBlendingMode GLS.Atmosphere

With atmosphere options: - aabmOneMinusSrcAlpha is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big; - bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).
TGLBaseArchiveClass GLS.ArchiveManager

TGLBaseImageClass GLS.Graphics

TGLBaseSelectTechniqueClass GLS.Selection

TGLBehaviourClass GLS.Scene

TGLbitfield GLScene.OpenGL4

TGLbitfield GLScene.OpenGLTokens

TGLBitmap32 GLS.Graphics

TGLBlendEquation GLS.State

TGLBlendFunction GLS.State

TGLBlendingMode GLS.Material

Simplified blending options. bmOpaque : disable blending bmTransparency : uses standard alpha blending bmAdditive : activates additive blending (with saturation) bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise) bmAlphaTest100 : uses opaque blending, with alpha-testing at 100% bmModulate : uses modulation blending bmCustom : uses TGLBlendingParameters options
TGLBlendingModeEx GLSL.CustomShader

Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.
TGLBlurkind GLS.Blur

TGLBlurPreset GLS.Blur

TGLboolean GLScene.OpenGL4

TGLboolean GLScene.OpenGLTokens

=========== OpenGL types ============
TGLBufferBindingTarget GLS.State

TGLbyte GLScene.OpenGL4

TGLbyte GLScene.OpenGLTokens

TGLCadencerMode GLS.Cadencer

Determines how the TGLCadencer operates. - cmManual : you must trigger progress manually (in your code) - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.
TGLCadencerTimeReference GLS.Cadencer

Determines which time reference the TGLCadencer should use. - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems) - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems) - cmExternal : the CurrentTime property is used
TGLCameraInvarianceMode GLS.Scene

TGLCameraJobEvent GLS.CameraController

TGLCameraKeepFOVMode GLS.Scene

TGLCameraStyle GLS.Scene

TGLCapType GLS.Objects

TGLCelShaderGetIntensity GLSL.ShapeShaders

An event for user defined cel intensity.
TGLCelShaderOption GLSL.ShapeShaders

A shader that applies cel shading through a vertex program and shade definition texture. Cel shading options: csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.
TGLCelShaderOptions GLSL.ShapeShaders

TGLCgBombShaderTextureSource GLS.CgBombShader

TGLchar GLScene.OpenGLTokens

TGLclampd GLScene.OpenGL4

TGLclampd GLScene.OpenGLTokens

TGLclampf GLScene.OpenGL4

TGLColorComponent GLS.State

TSingleCullFaceMode = cmFront..cmBack;
TGLColorDepth GLS.Scene

TGLColorMask GLS.State

TGLComparisonFunction GLS.State

TGLConePart GLS.GeomObjects

TGLConeParts GLS.GeomObjects

TGLConsoleMatchList GLS.Console

TGLConsoleOption GLS.Console

TGLConsoleOptions GLS.Console

remove quotes when a command line is parsed
TGLContextAcceleration GLS.Context

TGLContextClass GLS.Context

TGLContextLayer GLS.Context

TGLContextOption GLS.Scene

Options for the rendering context. roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering. roRenderToWindows: ignored (legacy). roTwoSideLighting: enables two-side lighting model. roStereo: enables stereo support in the driver (need to test with a stereo device...) roDestinationAlpha: request an Alpha channel for the rendered output roNoColorBuffer: don't request a color buffer (color depth setting ignored) roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling. roForwardContext: force OpenGL forward context
TGLContextOptions GLS.Scene

TGLContourClass GLS.MultiPolygon

TGLCubeMapTarget GLS.Texture

TGLCubePart GLS.Objects

TGLCubeParts GLS.Objects

TGLCUDACompilerOutput GLS.CUDA.Compiler

VCL.Dialogs,
TGLCUDARealArch GLS.CUDA.Compiler

sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown
TGLCUDARealArchs GLS.CUDA.Compiler

TGLCUDAVirtArch GLS.CUDA.Compiler

compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support
TGLCullFaceMode GLS.State

TGLCullingMode GLS.SpacePartition

TGLCustomRenderEvent GLS.Windows

TGLCyborgOption GLS.SmartObjects

TGLCyborgOptions GLS.SmartObjects

TGLCyborgReference GLS.SmartObjects

TGLCyborgSenceOrgans GLS.SmartObjects

TGLCyborgThinkMode GLS.SmartObjects

TGLCylinderAlignment GLS.GeomObjects

TGLCylinderPart GLS.GeomObjects

TGLCylinderParts GLS.GeomObjects

TGLDataFileCapabilities GLS.ApplicationFileIO

TGLDataFileCapability GLS.ApplicationFileIO

TGLDataFileClass GLS.ApplicationFileIO

TGLDDSDetailLevels GLS.FileDDS

TGLDEBUGPROCARB GLScene.OpenGLTokens

TGLDepthCompareFunc GLS.Texture

Specifies the depth comparison function.
TGLDepthFunction GLS.State

TGLDepthPrecision GLS.Scene

TGLDepthTextureMode GLS.Texture

Specifies how depth values should be treated during filtering and texture application
TGLDirectRenderEvent GLS.Scene

Event for user-specific rendering in a TGLDirectOpenGL object.
TGLdouble GLScene.OpenGL4

TGLdouble GLScene.OpenGLTokens

TGLDrawState GLS.RenderContextInfo

TGLDstBlendFunction GLS.State

TGLEarthSkydomeOption GLS.SkyDome

TGLEarthSkydomeOptions GLS.SkyDome

TGLEffectClass GLS.Scene

TGLEnabledRenderBuffer GLS.FBORenderer

———————– GLS.FBORenderer classes ————————–
TGLEnabledRenderBuffers GLS.FBORenderer

TGLEnum GLScene.OpenGL4

TGLenum GLScene.OpenGLTokens

TGLEProjectedParticleMask GLS.EParticleMasksManager

TGLExtrusionSolidPart GLS.Extrusion

TGLExtrusionSolidParts GLS.Extrusion

TGLFaceCulling GLS.Material

TGLFaceGroupMeshMode GLS.VectorFileObjects

Known descriptions for face group mesh modes. - fgmmTriangles : issue all vertices with GL_TRIANGLES. - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP. - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle. - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN. - fgmmQuads : issue all vertices with GL_QUADS.
TGLFaceWinding GLS.State

Describe what kind of winding has a front face
TGLFBOClearOption GLS.FBORenderer

TGLFBOClearOptions GLS.FBORenderer

TGLFBOTargetVisibility GLS.FBORenderer

TGLFeedbackMode GLS.Feedback

TGLFile3DSAnimKeysClassType GLS.File3DS

Used only for serialization. There probably is a more efficient way to do it.
TGLFireParticleArray GLS.FireFX

TGLFlareElement GLS.LensFlare

TGLFlareElements GLS.LensFlare

TGLFlatTextOption GLS.BitmapFont

TGLFlatTextOptions GLS.BitmapFont

TGLfloat GLScene.OpenGL4

TGLfloat GLScene.OpenGLTokens

TGLForceType GLS.PhysForces

TGLFormCanClose GLS.Windows

TGLFormCanRequest GLS.Windows

TGLFormCloseOptions GLS.Windows

TGLFormMove GLS.Windows

TGLFormNotify GLS.Windows

TGLFramebufferStatus GLS.Context

TGLFrustrumPart GLS.GeomObjects

TGLFrustrumParts GLS.GeomObjects

TGLFullScreenResolution GLS.SceneForm

Defines how GLSceneForm will handle fullscreen request fcWindowMaximize: Use current resolution (just maximize form and hide OS bars) fcNearestResolution: Change to nearest valid resolution from current window size fcManualResolution: Use FFullScreenVideoMode settings
TGLGameMenuScale GLS.GameMenu

TGLGizmoAcceptEvent GLS.Gizmo

TGLGizmoAxis GLS.Gizmo

TGLGizmoElement GLS.Gizmo

TGLGizmoElements GLS.Gizmo

TGLGizmoExAcceptEvent GLS.GizmoEx

TGLGizmoExAxis GLS.GizmoEx

TGLGizmoExAxisSelected GLS.GizmoEx

TGLGizmoExOperation GLS.GizmoEx

TGLGizmoExOperationMode GLS.GizmoEx

TGLGizmoExPickMode GLS.GizmoEx

TGLGizmoExReferenceCoordinateSystem GLS.GizmoEx

TGLGizmoExSelectionRegion GLS.GizmoEx

TGLGizmoExSelRec GLS.GizmoEx

TGLGizmoExVisibleInfoLabel GLS.GizmoEx

TGLGizmoExVisibleInfoLabels GLS.GizmoEx

TGLGizmoOperation GLS.Gizmo

TGLGizmoPickMode GLS.Gizmo

TGLGizmoUpdateEvent GLS.Gizmo

TGLGizmoVisibleInfoLabel GLS.Gizmo

TGLGizmoVisibleInfoLabels GLS.Gizmo

TGLGrowMethod GLS.SpacePartition

TGLgsInTypes GLSL.ShaderParameter

TGLgsOutTypes GLSL.ShaderParameter

TGLGuiComponentName GLS.Gui

TGLGuiElementName GLS.Gui

TGLhalf GLScene.OpenGLTokens

TGLhandleARB GLScene.OpenGLTokens

TGLHeightDataClass GLS.HeightData

TGLHeightDataPostRenderEvent GLS.TerrainRenderer

TGLHeightDataState GLS.HeightData

Possible states for a TGLHeightData. hdsQueued : the data has been queued for loading hdsPreparing : the data is currently loading or being prepared for use hdsReady : the data is fully loaded and ready for use hdsNone : the height data does not exist for this tile
TGLHeightDataType GLS.HeightData

Determines the type of data stored in a TGLHeightData. There are 3 data types (8 bits unsigned, signed 16 bits and 32 bits). Conversions: (128*(ByteValue-128)) = SmallIntValue = Round(SingleValue). The 'hdtDefault' type is used for request only, and specifies that the default type for the source should be used.
TGLHeightFieldColorMode GLS.Graph

TGLHeightFieldGetHeight2Event GLS.Graph

TGLHeightFieldGetHeightEvent GLS.Graph

TGLHeightFieldOption GLS.Graph

TGLHeightFieldOptions GLS.Graph

TGLHintType GLS.State

TGLImageLODRange GLS.Graphics

TGLImagePiramid GLS.Graphics

TGLint GLScene.OpenGL4

TGLint GLScene.OpenGLTokens

TGLint64 GLScene.OpenGL4

TGLint64 GLScene.OpenGLTokens

TGLint64EXT GLScene.OpenGL4

TGLint64EXT GLScene.OpenGLTokens

TglInternalCompression GLScene.TextureFormat

Texture compression option. If OpenGL supports it, this will activate a compressed texture format: tcDefault : uses global default compression option tcNone : do not use compression tcStandard : use standard compression, average quality, average rate tcHighQuality : choose a high-quality, low-speed compression tcHighSpeed : choose a high-speed, low-quality compression
TglInternalFormat GLScene.TextureFormat

TGLInterpolationType GLScene.VectorGeometry

TGLintptr GLScene.OpenGL4

the size of these depend on platform (32bit or 64bit)
TGLintptr GLScene.OpenGLTokens

the size of these depend on platform (32bit or 64bit)
TGLIsolineState GLS.Isolines

TGLLandTile GLS.RandomHDS

TMapOfLandscapes: array of array of TGLBaseRandomHDS;
TGLlConsoleEvent GLS.Console

Event called when used presses the "Enter"
TGLLibMaterialName GLS.Material

TGLLightSourceEnum GLSL.CustomShader

TGLLightSourceSet GLSL.CustomShader

TGLLightStyle GLS.Scene

Defines the various styles for lightsources. lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering)
TGLLimitType GLS.Scene

IDs for limit determination
TGLLineNodesAspect GLS.Objects

Possible aspects for the nodes of a TLine.
TGLLineOperation GLS.MeshLines

TGLLinesOption GLS.Objects

TGLLinesOptions GLS.Objects

TGLLineSplineMode GLS.Objects

Available spline modes for a TLine.
TGLLODStreamingState GLS.Graphics

TGLLogicOp GLS.State

TGLMagFilter GLS.Texture

TGLMapCollectionItemClass GLS.FPSMovement

TGLMaterialComponentName GLS.MaterialEx

TGLMaterialLevel GLS.State

TGLMaterialOption GLS.Material

Control special rendering options for a material. moIgnoreFog : fog is deactivated when the material is rendered
TGLMaterialOptions GLS.Material

TGLMatrix GLScene.VectorTypes

TGLMeshAutoCentering GLS.VectorFileObjects

TGLMeshAutoCenterings GLS.VectorFileObjects

TGLMeshMode GLS.Mesh

TGLMeshNormalsOrientation GLS.VectorFileObjects

Determines how normals orientation is defined in a mesh. - mnoDefault : uses default orientation - mnoInvert : inverse of default orientation - mnoAutoSolid : autocalculate to make the mesh globally solid - mnoAutoHollow : autocalculate to make the mesh globally hollow
TGLMeshObjectListClass GLS.VectorFileObjects

TGLMeshObjectMode GLS.VectorFileObjects

TGLMeshObjectRenderingOption GLS.VectorFileObjects

Rendering options per TGLMeshObject.moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list
TGLMeshObjectRenderingOptions GLS.VectorFileObjects

TGLMeshOptimizerOption GLS.MeshBuilder

TGLMeshOptimizerOptions GLS.MeshBuilder

TGLMeshPrimitive GLS.State

TGLMeshPrimitives GLS.State

TGLMinFilter GLS.Texture

TGLMirrorOption GLS.Mirror

TGLMirrorOptions GLS.Mirror

TGLMLODSurfaceOffsets Formats.GL2

TGLMouseAction GLS.Windows

TGLMovementRotationMode GLS.Movement

TGLMSurfaceHeirachyOffsets Formats.GL2

TGLNavigatorSmoothChangeItemClass GLS.SmoothNavigator

TGLNavigatorSmoothChangeSingleGetEvent GLS.SmoothNavigator

TGLNavigatorSmoothChangeSingleSetEvent GLS.SmoothNavigator

TGLNavigatorSmoothChangeVectorGetEvent GLS.SmoothNavigator

TGLNavigatorSmoothChangeVectorSetEvent GLS.SmoothNavigator

TGLNGDCollisions GLS.NGDManager

TGLNGDFrictionModels GLS.NGDManager

TGLNGDJoints GLS.NGDManager

TGLNGDManagerDebug GLS.NGDManager

TGLNGDManagerDebugs GLS.NGDManager

TGLNGDPickedActions GLS.NGDManager

TGLNGDSolverModels GLS.NGDManager

TGLNodesClass GLS.Nodes

TGLNormalDirection GLS.Scene

TGLNormalMapSpace GLS.BumpmapHDS

TGLNormalSmoothing GLS.Objects

Determines how and if normals are smoothed. - nsFlat : facetted look - nsSmooth : smooth look - nsNone : unlighted rendering, usefull for decla texturing
TGLObjectBBChange GLS.Scene

TGLObjectBBChanges GLS.Scene

TGLObjectChange GLS.Scene

Used to describe the changes in an object, which have to be reflected in the scene
TGLObjectChanges GLS.Scene

TGLObjectsSorting GLS.RenderContextInfo

Determines if objects are sorted, and how. Sorting is done level by level (and not for all entities), values are : osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst osNone : do not sort objects. osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. osRenderNearestFirst : render objects whose Position is the nearest to the camera first.
TGLObjectStyle GLS.Scene

Possible styles/options for a GLScene object. Allowed styles are: osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered
TGLObjectStyles GLS.Scene

TGLODECollisionEvent GLS.ODEManager

TGLODECollisionSurfaceMode GLS.ODEManager

TGLODECustomCollisionEvent GLS.ODEManager

TGLODEElementClass GLS.ODEManager

TGLODEGetParamCallback GLS.ODEManager

TGLODEJointOption GLS.ODEManager

TGLODEJointOptions GLS.ODEManager

TGLODEObjectCollisionEvent GLS.ODEManager

TGLODESetParamCallback GLS.ODEManager

TGLODESolverMethod GLS.ODEManager

TGLODESurfaceModes GLS.ODEManager

TGLOnCustomPostEffectEvent GLSL.PostEffects

TGLOnLightsChanged GLS.State

TGLParticleArray GLS.ParticleFX

TGLParticleClass GLS.ParticleFX

TGLParticleEvent GLS.Particles

TGLPerlinInterpolation GLS.Perlin

TGLPerlinOctav GLS.Perlin

TGLPixel32Array GLS.Graphics

TGLPlaneStyle GLS.Objects

TGLPlaneStyles GLS.Objects

TGLPointStyle GLS.Objects

TGLPolygonMode GLS.State

TGLPolygonPart GLS.GeomObjects

TGLPolygonParts GLS.GeomObjects

TGLPopupMenuClick GLS.Windows

TGLPostEffectBuffer GLSL.PostEffects

TGLPostEffectPreset GLSL.PostEffects

Some presets for TGLPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.
TGLProjectedTexturesStyle GLS.ProjectedTextures

Possible styles of texture projection. Possible values: ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures).
TGLProxyObjectClass GLS.Scene

TGLProxyObjectOption GLS.Scene

Defines which features are taken from the master object.
TGLProxyObjectOptions GLS.Scene

TGLQueryType GLS.State

TGLRCOption GLS.Context

TGLRCOptions GLS.Context

TGLResourceStream GLS.ApplicationFileIO

TGLResourceType GLS.CUDA.APIComps

TGLRevolutionSolidPart GLS.Extrusion

TGLRevolutionSolidParts GLS.Extrusion

TGLSceneObjectClass GLS.Scene

TGLSceneOperation GLS.Scene

Flags for design notification
TGLSceneViewerMode GLS.Scene

TGLScreenDepth GLS.FullScreenViewer

TGLScriptState GLS.ScriptBase

TGLSectorNodeArray GLS.SpacePartition

TglSeparateTextureWrap GLScene.TextureFormat

Texture addressing rules
TGLShadeModel GLS.Scene

TGLShaderClass GLS.Material

TGLShaderCombinerType GLSL.ShaderCombiner

MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader. sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself

TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.
TGLShaderEvent GLSL.CustomShader

TGLShaderFailedInitAction GLS.Material

Defines what to do if for some reason shader failed to initialize. fiaSilentdisable: just disable it fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage fiaReRaiseException: Re-raises the exception fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;)
TGLShaderFogSupport GLSL.CustomShader

TGLShaderHandleClass GLS.Context

TGLShaderStyle GLS.Material

Define GLShader style application relatively to a material. ssHighLevel: shader is applied before material application, and unapplied after material unapplication ssLowLevel: shader is applied after material application, and unapplied before material unapplication ssReplace: shader is applied in place of the material (and material is completely ignored)
TGLShaderType GLS.MaterialEx

TGLShaderUnAplyEvent GLSL.CustomShader

TGLShadowCastingMode GLS.ShadowVolume

Determines when a caster should actually produce a shadow; scmAlways : Caster always produces a shadow, ignoring visibility scmVisible : Caster casts shadow if the object has visible=true scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true scmParentVisible : Caster produces shadow if parent has visible=true scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting)
TGLShadowVolumeCapping GLS.ShadowVolume

Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option. Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera.

svcDefault : Default behaviour svcAlways : Always generates caps svcNever : Never generates caps
TGLShadowVolumeMode GLS.ShadowVolume

Shadow rendering modes. svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) svmOff : no shadowing will take place
TGLShadowVolumeOption GLS.ShadowVolume

Shadow volume rendering options/optimizations. svoShowVolumes : make the shadow volumes visible svoDesignVisible : the shadow are visible at design-time svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface
TGLShadowVolumeOptions GLS.ShadowVolume

TGLShininess GLS.Material

TGLshort GLScene.OpenGL4

TGLshort GLScene.OpenGLTokens

TGLSimpleNavigationAction GLS.SimpleNavigation

TGLSimpleNavigationCustomActionEvent GLS.SimpleNavigation

TGLSimpleNavigationOption GLS.SimpleNavigation

TGLSimpleNavigationOptions GLS.SimpleNavigation

Show FPS
TGLsizei GLScene.OpenGL4

TGLsizei GLScene.OpenGLTokens

TGLsizeiptr GLScene.OpenGL4

TGLsizeiptr GLScene.OpenGLTokens

TGLSkeletonFrameTransform GLS.VectorFileObjects

TGLSkyBoxStyle GLS.SkyDome

————————- SkyBox class ————————-
TGLSkyDomeOption GLS.SkyDome

TGLSkyDomeOptions GLS.SkyDome

TGLSLDataType GLSL.ShaderParameter

TGLSLProjectedTexturesStyle GLSL.ProjectedTextures

TGLSLSamplerType GLSL.ShaderParameter

TGLSLShaderEvent GLSL.Shader

TGLSLShaderEventEx GLSL.Shader

TGLSLShaderUnApplyEvent GLSL.Shader

TGLSmartSwarmMode GLS.SmartObjects

TGLSoundEnvironment GLS.SoundManager

EAX standard sound environments.
TGLSoundFileClass GLS.SoundFileObjects

TGLSoundSourceChange GLS.SoundManager

TGLSoundSourceChanges GLS.SoundManager

TGLSourcePFXDispersionMode GLS.ParticleFX

TGLSourcePFXPositionMode GLS.ParticleFX

TGLSourcePFXVelocityMode GLS.ParticleFX

TGLSpaceTextCharRange GLS.SpaceText

TGLSpriteAnimationMode GLS.AnimatedSprite

Sets the current animation playback mode: samNone - No playback, the animation does not progress. samPlayOnce - Plays the animation once then switches to samNone. samLoop - Play the animation forward in a continuous loop. samLoopBackward - Same as samLoop but reversed direction. samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached.
TGLSpriteFrameDimensions GLS.AnimatedSprite

Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.
TGLState GLS.State

Reflects all relevant (binary) states of OpenGL subsystem
TGLStates GLS.State

TGLStateType GLS.State

TGLStateTypes GLS.State

TGLStencilFunction GLS.State

TGLStencilOp GLS.State

TGLStencilPrecision GLS.FBORenderer

TGLStiffnessSetVH GLS.VerletTypes

TGLStiffnessVH GLS.VerletTypes

TGLString GLScene.OpenGL4

TglSwizzleVector GLScene.TextureFormat

TGLsync GLScene.OpenGL4

TGLsync GLScene.OpenGLTokens

TGLTextHorzAdjust GLS.SpaceText

Note: haAligned, haCentrically, haFitIn have not been implemented!
TGLTextureArray GLS.FBORenderer

TGLTextureChange GLS.Texture

TGLTextureChanges GLS.Texture

TglTextureCompareMode GLScene.TextureFormat

Specifies the texture comparison mode for currently bound depth textures. That is, a texture whose internal format is tfDEPTH_COMPONENT*
TGLTextureCompression GLS.Texture

TglTextureFilteringQuality GLScene.TextureFormat

Filtering quality
TGLTextureFormat GLS.Texture

Texture format for OpenGL (rendering) use. Internally, GLScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:
TGLTextureImageAlpha GLS.Texture

Defines how and if Alpha channel is defined for a texture image. tiaDefault : uses the alpha channel in the image if any tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) tiaOpaque : alpha channel is uniformously set to 1.0 tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque.
TGLTextureImageClass GLS.Texture

TGLTextureImageEditorClass GLS.TextureImageEditors

TGLTextureMappingMode GLS.Texture

TGLTextureMode GLS.Texture

TGLTextureNeededEvent GLS.Texture

TglTextureSwizzle GLScene.TextureFormat

TglTextureTarget GLScene.TextureFormat

TGLTextureWrap GLS.Texture

TGLTextVertAdjust GLS.SpaceText

TGLTorusPart GLS.GeomObjects

TGLTorusParts GLS.GeomObjects

TGLTransformFeedBackMode GLSL.CustomShader

TGLubyte GLScene.OpenGL4

TGLubyte GLScene.OpenGLTokens

TGLuint GLScene.OpenGL4

TGLuint GLScene.OpenGLTokens

TGLuint64 GLScene.OpenGL4

TGLuint64 GLScene.OpenGLTokens

TGLuint64EXT GLScene.OpenGL4

TGLuint64EXT GLScene.OpenGLTokens

TGLUNurbsErrorProc GLScene.OpenGL4

GLUNurbsCallback
TGLUNurbsErrorProc GLScene.OpenGLTokens

TGLUNurbsObj GLScene.OpenGL4

backwards compatibility
TGLUNurbsObj GLScene.OpenGLTokens

backwards compatibility
TGLUQuadricErrorProc GLScene.OpenGL4

GLUQuadricCallback
TGLUQuadricErrorProc GLScene.OpenGLTokens

Callback function prototypes
TGLUQuadricObj GLScene.OpenGL4

TGLUQuadricObj GLScene.OpenGLTokens

TGLushort GLScene.OpenGL4

TGLushort GLScene.OpenGLTokens

TGLUTessBeginDataProc GLScene.OpenGL4

TGLUTessBeginDataProc GLScene.OpenGLTokens

TGLUTessBeginProc GLScene.OpenGL4

GLUTessCallback
TGLUTessBeginProc GLScene.OpenGLTokens

TGLUTessCombineDataProc GLScene.OpenGL4

TGLUTessCombineDataProc GLScene.OpenGLTokens

TGLUTessCombineProc GLScene.OpenGL4

TGLUTessCombineProc GLScene.OpenGLTokens

TGLUTessEdgeFlagDataProc GLScene.OpenGL4

TGLUTessEdgeFlagDataProc GLScene.OpenGLTokens

TGLUTessEdgeFlagProc GLScene.OpenGL4

TGLUTessEdgeFlagProc GLScene.OpenGLTokens

TGLUTesselatorObj GLScene.OpenGL4

TGLUTesselatorObj GLScene.OpenGLTokens

TGLUTessEndDataProc GLScene.OpenGL4

TGLUTessEndDataProc GLScene.OpenGLTokens

TGLUTessEndProc GLScene.OpenGL4

TGLUTessEndProc GLScene.OpenGLTokens

TGLUTessErrorDataProc GLScene.OpenGL4

TGLUTessErrorDataProc GLScene.OpenGLTokens

TGLUTessErrorProc GLScene.OpenGL4

TGLUTessErrorProc GLScene.OpenGLTokens

TGLUTessVertexDataProc GLScene.OpenGL4

TGLUTessVertexDataProc GLScene.OpenGLTokens

TGLUTessVertexProc GLScene.OpenGL4

TGLUTessVertexProc GLScene.OpenGLTokens

TGLUTriangulatorObj GLScene.OpenGL4

TGLUTriangulatorObj GLScene.OpenGLTokens

TGLVBOBuffer GLS.VectorFileObjects

TGLVBOBuffers GLS.VectorFileObjects

TGLvdpauSurfaceNV GLScene.OpenGLTokens

TGLVector GLScene.VectorTypes

TGLVectorFileClass GLS.VectorFileObjects

TGLVerletHeightFieldOnNeedHeight GLS.VerletTypes

TGLVerletNodeClass GLS.VerletTypes

TGLVertexBoneWeightArray GLS.VectorFileObjects

TGLVertexBoneWeightDynArray GLS.VectorFileObjects

TGLVertexDataArray GLS.Mesh

TGLVertexList Formats.MD2

TGLVertexMode GLS.Mesh

TGLVerticesBoneWeights GLS.VectorFileObjects

TGLVirtualHandleEvent GLS.Context

TGLVisibilityCulling GLS.RenderContextInfo

Determines the visibility culling mode. Culling is done level by level, allowed values are: vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone vcNone : no visibility culling is performed vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).
TGLVisibilityDeterminationEvent GLS.Objects

TGLVSyncMode GLS.Context

TGLWaterPlaneOption GLS.WaterPlane

TGLWaterPlaneOptions GLS.WaterPlane

TGLWindowAttribute GLS.Screen

window attributes
TGLWindowAttributes GLS.Screen

TGLWindowFitting GLS.Screen

window-to-screen fitting
TGLXYZGridLinesStyle GLS.Graph

Rendering Style for grid lines. - glsLine : a single line is used for each grid line (from Min to Max), this provides the fastest rendering - glsSegments : line segments are used between each node of the grid, this enhances perspective and quality, at the expense of computing power.
TGLXYZGridPart GLS.Graph

TGLXYZGridParts GLS.Graph

TgOnMatricesPush GLScene.PipelineTransform

TgPipelineTransformationState GLScene.PipelineTransform

TgPipelineTransformationStates GLScene.PipelineTransform

TGSilhouetteStyle GLS.Silhouette

TGUIAlignments GLS.Gui

TGUIDrawResult GLS.Gui

TGutterClickEvent GLS.Memo

————————————————————–
TGutterDrawEvent GLS.Memo

THalfFloat CUDA.DataAccess

THalfFloat GLScene.Utils

THDTextureCoordinatesMode GLS.HeightData

THiShadowBias Formats.m3DSTypes

THmgPlane GLScene.VectorGeometry

A plane equation. Defined by its equation A.x+B.y+C.z+D , a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here. The typename is just here for easing up data manipulation
THomogeneousByteMatrix GLScene.VectorGeometry

Matrices
THomogeneousByteVector GLScene.VectorGeometry

THomogeneousDblMatrix GLScene.VectorGeometry

THomogeneousDblVector GLScene.VectorGeometry

THomogeneousExtMatrix GLScene.VectorGeometry

THomogeneousExtVector GLScene.VectorGeometry

THomogeneousFltMatrix GLScene.VectorGeometry

THomogeneousFltVector GLScene.VectorGeometry

THomogeneousIntMatrix GLScene.VectorGeometry

THomogeneousIntVector GLScene.VectorGeometry

THomogeneousMatrix GLScene.VectorGeometry

THomogeneousPtrVector GLScene.VectorGeometry

THomogeneousVector GLScene.VectorGeometry

THomogeneousWordMatrix GLScene.VectorGeometry

THomogeneousWordVector GLScene.VectorGeometry

TI1 Formats.LWO

TI2 Formats.LWO

TI4 Formats.LWO

TICCompressProc Formats.VFW

TICStatusProc Formats.VFW

return nonzero means abort operation in progress
TID4 Formats.LWO

TID4DynArray Formats.LWO

TIDELogProc GLScene.Logger

TIdleEvent GLS.AsyncHDS

TImageAlphaProc GLS.ImageUtils

TImageFilterFunction GLS.ImageUtils

TImposterLoadedEvent GLS.Imposter

Used CPPB procedure instead of Delphi function TLoadingImposterEvent = procedure (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter; var result : TGLBitmap32) of object;
TImposterOption GLS.Imposter

Imposter rendering options. Following options are supported: impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing
TImposterOptions GLS.Imposter

TImposterReference GLS.Imposter

TIndexList Formats.MD2

TInfoLabelCoordType GLS.GizmoEx

TIntegerArray Formats.m3DSTypes

TIntegerArray GLS.HeightTileFileHDS

Access to large tiled height data files. Performance vs Raw file accesses (for perfect tile match): Cached data: "Smooth" terrain 1:2 to 1:10 Random terrain 1:1

Non-cached data: "Smooth" terrain 1:100 to 1:1000 Random terrain 1:100
TIntegerArray GLScene.VectorTypesExt

Extended may be replaced with BigDecimals
TIntegerClamp GLS.RandomHDS

TIntegerVector GLScene.VectorGeometry

TIntermediateFormatArray GLS.ImageUtils

TIntPercentage Formats.m3DSTypes

TInvokeInfoForm GLS.Scene

TIsDefaultTile GLS.RandomHDS

TJointFlag ODE.Import

Change: New Type added, syntax enforcement
TJointParams ODE.Import

TJointParams = ( parameters for limits and motors Change: New Type added, sintax enforcement
TJoyAxis GLS.Joystick

TJoyPos GLS.Joystick

TJoystickButton GLS.Joystick

TJoystickButtons GLS.Joystick

TJoystickDesignMode GLS.Joystick

TJoystickEvent GLS.Joystick

TJoystickID GLS.Joystick

TKeyHeaderList Formats.m3DSTypes

TKFCurtime Formats.m3DSTypes

TKFId Formats.m3DSTypes

TKFMorphKey3DS Formats.m3DSTypes

Object Morph key
TKFMorphKeyList Formats.m3DSTypes

TKFRotKeyList Formats.m3DSTypes

TLayerFogFalloff3DS Formats.m3DSTypes

distance cue atmospheric
TLightDir2TexEnvColor GLS.MaterialEx

TLinColor24 Formats.m3DSTypes

TLinColorF Formats.m3DSTypes

TLoadingImposterEvent GLS.Imposter

Imposter loading events
TLoadProgress Formats.m3DS

TLogBufferingMode GLScene.Logger

How log is buffered.
TLogLevel GLScene.Logger

Levels of importance of log messages
TLogLevels GLScene.Logger

Log level setting type
TLogMessageLimitAction GLScene.Logger

What to do when number of messages exceeds message limit.
TLogTimeFormat GLScene.Logger

Log date and time setting type
TLongWordVector GLScene.VectorGeometry

TLoShadowBias Formats.m3DSTypes

TLWChunkClass Formats.LWO

TLWChunkFind Formats.LWO

TLWContentNotify Formats.LWO

TLWOReadCallback Formats.LWO

TLWPntsInfoDynArray Formats.LWO

TLWPolsDynArray Formats.LWO

TLWPolsInfoDynArray Formats.LWO

TLWPolyTagMapDynArray Formats.LWO

TLWVertexMapDynArray Formats.LWO

TM3dVersion Formats.m3DSTypes

TMapOfSingle GLS.RandomHDS

TMapOfVector GLS.RandomHDS

TMapTexCoordMode GLS.XOpenGL

TMarkDirtyEvent GLS.HeightData

TMarkStyle GLS.Trail

TMasterScale Formats.m3DSTypes

TMatBumpPercent Formats.m3DSTypes

TMatMapAng Formats.m3DSTypes

TMatMapBCol Formats.m3DSTypes

TMatMapCol1 Formats.m3DSTypes

TMatMapCol2 Formats.m3DSTypes

TMatMapGCol Formats.m3DSTypes

TMatMapRCol Formats.m3DSTypes

TMatMapTexblur Formats.m3DSTypes

TMatMapTiling Formats.m3DSTypes

TMatMapUOffset Formats.m3DSTypes

TMatMapUScale Formats.m3DSTypes

TMatMapVOffset Formats.m3DSTypes

TMatMapVScale Formats.m3DSTypes

TMatrix2DArray GLScene.VectorTypesExt

Matrix Arrays
TMatrix2DType GLScene.VectorTypesExt

———————– Matrix types ———————–
TMatrix3DArray GLScene.VectorTypesExt

TMatrix3DType GLScene.VectorTypesExt

TMatrixArr GLS.Isolines

TMatrixArray GLScene.VectorGeometry

Some simplified names
TMatrixExt GLScene.VectorTypesExt

TMatShading Formats.m3DSTypes

TMatWireSize Formats.m3DSTypes

TMaxCLODTrianglesReachedEvent GLS.TerrainRenderer

TMDCAngle GLS.FileMDC

TMDCBaseVertex GLS.FileMDC

TMDCCompVertex GLS.FileMDC

TMDCPoint GLS.FileMDC

3/64;
TMDCTexCoord GLS.FileMDC

TMDCTriangle GLS.FileMDC

TMesh2DArray GLScene.VectorTypesExt

TMesh3DArray GLScene.VectorTypesExt

TMeshColor Formats.m3DSTypes

TMeshMatrix Formats.m3DSTypes

TMeshVersion Formats.m3DSTypes

TMipmapGenerationMode GLS.MaterialEx

TMirrorShapes GLS.Mirror

TModuleHandle ModuleLoader

Handle to a loaded DLL
TMorphSmooth Formats.m3DSTypes

TMS3DJointArray GLS.FileMS3D

TMS3DKeyframePositionArray GLS.FileMS3D

TMS3DKeyframeRotationArray GLS.FileMS3D

TMS3DTriangleArray GLS.FileMS3D

TMS3DVertexArray GLS.FileMS3D

TMshBoxmap Formats.m3DSTypes

TNDirectLight Formats.m3DSTypes

TNewTilePreparedEvent GLS.AsyncHDS

TNewTilePreparedEvent GLS.BumpmapHDS

TNewTilePreparedEvent GLS.ShadowHDS

TObjectCollisionEvent GLS.Collision

TObjMatList Formats.m3DSTypes

TOConsts Formats.m3DSTypes

TOnAsmProgSetting GLS.MaterialEx

TOnBeforeKernelLaunch GLS.CUDA.Graphics

TOnCreateLandTile GLS.RandomHDS

TOnCustomForce GLS.PhysForces

TOnCustomPerspective GLS.Scene

TOnDebugLine gnugettext

***************************************************************************
TOnDoApplyEvent GLSL.UserShader

TOnDoUnApplyEvent GLSL.UserShader

TOnDrawTexture GLS.RandomHDS

Function type to use for topography-based texture
TOnHeightDataDirtyEvent GLS.HeightData

TOnOpenGLInteropInit GLS.CUDA.Context

TOnPrepareHandleData GLS.Context

TOnUniformInitialize GLS.MaterialEx

TOnUniformSetting GLS.MaterialEx

TOptimise GLS.zBuffer

TPackedRotationMatrix GLScene.VectorGeometry

TParametricSurfaceBasis GLS.ParametricSurfaces

psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.
TParametricSurfaceRenderer GLS.ParametricSurfaces

psrGLScene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenGL uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.
TParticleReferenceArray GLS.ParticleFX

TPasDblStrUtilsBoolean PasDblStrUtils

TPasDblStrUtilsChar PasDblStrUtils

TPasDblStrUtilsDouble PasDblStrUtils

TPasDblStrUtilsInt16 PasDblStrUtils

TPasDblStrUtilsInt32 PasDblStrUtils

TPasDblStrUtilsInt64 PasDblStrUtils

TPasDblStrUtilsInt8 PasDblStrUtils

TPasDblStrUtilsNativeInt PasDblStrUtils

TPasDblStrUtilsNativeUInt PasDblStrUtils

TPasDblStrUtilsOutputMode PasDblStrUtils

TPasDblStrUtilsPointer PasDblStrUtils

TPasDblStrUtilsPtrInt PasDblStrUtils

TPasDblStrUtilsPtrUInt PasDblStrUtils

TPasDblStrUtilsRawByteChar PasDblStrUtils

TPasDblStrUtilsRawByteCharSet PasDblStrUtils

TPasDblStrUtilsRawByteString PasDblStrUtils

TPasDblStrUtilsRoundingMode PasDblStrUtils

TPasDblStrUtilsString PasDblStrUtils

TPasDblStrUtilsUInt16 PasDblStrUtils

TPasDblStrUtilsUInt32 PasDblStrUtils

TPasDblStrUtilsUInt64 PasDblStrUtils

TPasDblStrUtilsUInt8 PasDblStrUtils

TPasDblStrUtilsUTF16Char PasDblStrUtils

TPasDblStrUtilsUTF16String PasDblStrUtils

TPasDblStrUtilsUTF8Char PasDblStrUtils

TPasDblStrUtilsUTF8String PasDblStrUtils

TPasJSONChar PasJSON

TPasJSONDouble PasJSON

TPasJSONEncoding PasJSON

TPasJSONFloat PasJSON

TPasJSONFloats PasJSON

TPasJSONInt16 PasJSON

TPasJSONInt32 PasJSON

TPasJSONInt64 PasJSON

TPasJSONInt8 PasJSON

TPasJSONItemObjectProperties PasJSON

TPasJSONItems PasJSON

TPasJSONMergeFlag PasJSON

TPasJSONMergeFlags PasJSON

TPasJSONModeFlag PasJSON

TPasJSONModeFlags PasJSON

TPasJSONNativeInt PasJSON

TPasJSONNativeUInt PasJSON

TPasJSONPointer PasJSON

TPasJSONPointers PasJSON

TPasJSONPtrDiff PasJSON

TPasJSONPtrInt PasJSON

TPasJSONPtrUInt PasJSON

TPasJSONRawByteChar PasJSON

TPasJSONRawByteString PasJSON

TPasJSONSize PasJSON

TPasJSONSizeInt PasJSON

TPasJSONSizeUInt PasJSON

TPasJSONUInt16 PasJSON

TPasJSONUInt32 PasJSON

TPasJSONUInt64 PasJSON

TPasJSONUInt8 PasJSON

TPasJSONUInt8Array PasJSON

TPasJSONUTF16Char PasJSON

TPasJSONUTF16String PasJSON

TPasJSONUTF8String PasJSON

TPatchPostRenderEvent GLS.TerrainRenderer

TPathTravelStartEvent GLS.Movement

Event for path related event
TPathTravelStopEvent GLS.Movement

TpfnSDL_CurrentBeginThread SDL.Import

TpfnSDL_CurrentEndThread SDL.Import

TPFXCreateParticleEvent GLS.ParticleFX

TPFXDirectRenderEvent GLS.ParticleFX

TPFXGetParticleCountEvent GLS.ParticleFX

TPFXParticleProgress GLS.ParticleFX

TPFXPrepareTextureImageEvent GLS.ParticleFX

TPFXProgressEvent GLS.ParticleFX

TPFXSortAccuracy GLS.ParticleFX

TPickSortType GLS.Selection

TPickSubObjects GLS.Selection

TPipeNodesColorMode GLS.Extrusion

TPipeNormalMode GLS.Extrusion

TPipePart GLS.Extrusion

TPipeParts GLS.Extrusion

TPipeTexCoordMode GLS.Extrusion

TPivot Formats.m3DSTypes

TPlanBB GLScene.GeometryBB

TPlanIndices GLScene.GeometryBB

TPoint2DArray GLScene.VectorTypesExt

TPoint3DArray GLScene.VectorTypesExt

TPointerArray GLS.ImageUtils

TPointerVector GLScene.VectorGeometry

TPointList Formats.m3DSTypes

TPolygon2D GLScene.VectorTypesExt

———————– Polygon types ———————–
TPolygon3D GLScene.VectorTypesExt

TPolyhedronArray GLScene.VectorTypesExt

———————– Polyhedron types ———————–
TPrecisionSetting GLS.CgShader

TProcAffineAffineAffine GLS.Octree

TProcInt GLS.Octree

TProjectTargetNameFunc GLScene.Utils

TQuatArray GLScene.VectorTypesExt

TQuaternionArray GLScene.VectorGeometry

TRandomGenFunction GLScene.RandomLib

Used for passing Random Number Generators
TranslatedUnicodeString gnugettext

TRayBias Formats.m3DSTypes

TRBColor GLScene.RedBlackTree

TRCOptions GLScene.OpenGL4

TRead SDL.Import

** * Read up to maxnum objects each of size size from the data * stream to the area pointed at by ptr. * * the number of objects read, or 0 at error or end of file. *
TReleaseLevel Formats.m3DSTypes

TResolution GLS.Screen

TRGBPixelBuffer GLS.Blur

TsbState GLS.Memo

TScalarField GLScene.VectorTypesExt

TScalarFieldInt GLScene.VectorTypesExt

if data are made on integer XYZ index may be replaced with BigIntegers
TScalarValue GLScene.VectorTypesExt

———————– Point types ———————–
TScreenSaverOption GLS.ScreenSaver

Options d'automatisation du screen-saver. ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer)
TScreenSaverOptions GLS.ScreenSaver

TScreenSaverPreviewEvent GLS.ScreenSaver

This event is fired when screen saver should start in preview mode. The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).
TScrollMode GLS.Memo

TSDLEvent GLS.SDL.Window

TSDLWindowOption GLS.SDL.Window

Specifies optional settings for the SDL window. Those options are a simplified subset of the SDL options: voDoubleBuffer: create a double-buffered window voOpenGL: requires OpenGL capability for the window voResizable: window should be resizable voFullScreen: requires a full screen "window" (screen resolution may be changed) voStencilBuffer: requires a stencil buffer (8bits, use along voOpenGL)
TSDLWindowOptions GLS.SDL.Window

TSDLWindowPixelDepth GLS.SDL.Window

Pixel Depth options. vpd16bits: 16bpp graphics (565) (and 16 bits depth buffer for OpenGL) vpd24bits: 24bpp graphics (565) (and 24 bits depth buffer for OpenGL)
TSDL_AudioCallback SDL.Import

** * This function is called when the audio device needs more data. * * userdata An application-specific parameter saved in * the SDL_AudioSpec structure * stream A pointer to the audio data buffer. * len The length of that buffer in bytes. * * Once the callback returns, the buffer will no longer be valid. * Stereo samples are stored in a LRLRLR ordering. *
TSDL_AudioDeviceID SDL.Import

** * SDL Audio Device IDs. * * A successful call to SDL_OpenAudio() is always device id 1, and legacy * SDL audio APIs assume you want this device ID. SDL_OpenAudioDevice() calls * always returns devices >= 2 on success. The legacy calls are good both * for backwards compatibility and when you don't care about multiple, * specific, or capture devices. *
TSDL_AudioFilter SDL.Import

TSDL_AudioFormat SDL.Import

** * Audio format flags. * * These are what the 16 bits in SDL_AudioFormat currently mean... * (Unspecified bits are always zero). * * ++———————–sample is signed if set || || ++———–sample is bigendian if set || || || || ++—sample is float if set || || || || || || +—sample bit size—+ || || || | | 15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00 * * There are macros in SDL 2.0 and later to query these bits. *
TSDL_AudioStatus SDL.Import

** * Audio state * * Get the current audio state. *
TSDL_BlendMode SDL.Import

TSDL_Blit SDL.Import

** * The type of function used for surface blitting functions. *
TSDL_Bool SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDLtype_s.h / SDL_stdinc.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////
TSDL_Colour SDL.Import

TSDL_ErrorCode SDL.Import

#define SDL_OutOfMemory() SDL_Error(SDL_ENOMEM) #define SDL_Unsupported() SDL_Error(SDL_UNSUPPORTED) #define SDL_InvalidParamError(param) SDL_SetError("Parameter '%s' is invalid", (param))
TSDL_EventAction SDL.Import

TSDL_EventFilter SDL.Import

TSDL_EventType SDL.Import

TSDL_FingerID SDL.Import

TSDL_GameController SDL.Import

TSDL_GameControllerAxis SDL.Import

TSDL_GameControllerBindType SDL.Import

todo
TSDL_GameControllerButton SDL.Import

TSDL_GestureID SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_gesture.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////
TSDL_GLattr SDL.Import

TSDL_GLContext SDL.Import

** * An opaque handle to an OpenGL context. *
TSDL_GLcontextFlag SDL.Import

TSDL_GLprofile SDL.Import

TSDL_HintCallback SDL.Import

/** * \brief Add a function to watch a particular hint * * \param name The hint to watch * \param callback The function to call when the hint value changes * \param userdata A pointer to pass to the callback function */
TSDL_JoystickID SDL.Import

TSDL_KeyCode SDL.Import

TSDL_KeyMod SDL.Import

TSDL_MessageBoxButtonFlags SDL.Import

**< Marks the default button when escape is hit *
TSDL_MessageBoxColorType SDL.Import

TSDL_MessageBoxFlags SDL.Import

**< informational dialog *
TSDL_PowerState SDL.Import

** * The basic state for the system's power supply. *
TSDL_RendererFlags SDL.Import

TSDL_RendererFlip SDL.Import

TSDL_ScanCode SDL.Import

TSDL_SystemCursor SDL.Import

TSDL_TextureAccess SDL.Import

TSDL_TextureModulate SDL.Import

TSDL_ThreadFunction SDL.Import

TSDL_ThreadID SDL.Import

* The SDL thread ID *
TSDL_ThreadPriority SDL.Import

* The SDL thread priority * * Note: On many systems you require special privileges to set high priority. *
TSDL_TimerCallback SDL.Import

** * Function prototype for the timer callback function. * * The callback function is passed the current timer interval and returns * the next timer interval. If the returned value is the same as the one * passed in, the periodic alarm continues, otherwise a new alarm is * scheduled. If the callback returns 0, the periodic alarm is cancelled. *
TSDL_TimerID SDL.Import

** * Definition of the timer ID type. *
TSDL_TLSID SDL.Import

TSDL_TouchID SDL.Import

TSDL_WindowEventID SDL.Import

**< The window manager requests that the window be closed *
TSDL_WindowFlags SDL.Import

**< window not created by SDL *
TSeek SDL.Import

** * Seek to offset relative to whence, one of stdio's whence values: * RW_SEEK_SET, RW_SEEK_CUR, RW_SEEK_END * * the final offset in the data stream, or -1 on error. *
TSerializeEvent GLS.NGDManager

TSetSubItemsEvent FmSceneEditor

TSetTextureTargetsEvent GLS.FBORenderer

TSetTransformEvent GLS.NGDManager

TShadeType3DS Formats.m3DSTypes

used for shading field in TMaterial3DS structure
TShadowFilter Formats.m3DSTypes

TShadowMapSize Formats.m3DSTypes

TShadowPlaneOption GLS.ShadowPlane

TShadowPlaneOptions GLS.ShadowPlane

TShadowRange Formats.m3DSTypes

TShadowSamples Formats.m3DSTypes

TShadowStyle3DS Formats.m3DSTypes

TShortIntArray GLS.HeightTileFileHDS

TSIBLigthing GLS.Imposter

TSingleArray GLScene.VectorGeometry

TSingleClamp GLS.RandomHDS

TSingleList Formats.m3DSTypes

TSingleRaster GLS.HeightData

TSize SDL.Import

** * Return the size of the file in this rwops, or -1 if unknown *
Tsize_t OpenCL.Platform

TSmallintArray GLS.HeightData

TSmallIntArray GLS.HeightTileFileHDS

TSmallIntRaster GLS.HeightData

TSolidBgnd3DS Formats.m3DSTypes

Name of background Bitmap
TSourceDataFetchedEvent GLS.HeightData

TSpaceContains GLScene.GeometryBB

Result type for space intersection tests, like AABBContainsAABB or BSphereContainsAABB
TSpecularMode GLSL.BumpShaders

TSpriteColorMode GLS.ParticleFX

Sprite color modes. scmFade: vertex coloring is used to fade inner-outer scmInner: vertex coloring uses inner color only scmOuter: vertex coloring uses outer color only scmNone: vertex coloring is NOT used (colors are ignored)
TSpritesPerTexture GLS.ParticleFX

Sprites per sprite texture for the SpritePFX.
TSqrt255Array GLScene.Utils

TStartPreparingDataEvent GLS.HeightData

TStateArray GLS.PhysManager

TDESolver = procedure((*RigidBody:TGLRigidBody;*)DeltaTime:Real) of object;
TSTLVertex GLS.FileSTL

TSubdivideEdgeEvent GLS.MeshUtils

TTargetType3DS Formats.m3DSTypes

TTaskProcedure GLS.Context

TTerrainHighResStyle GLS.TerrainRenderer

TTerrainOcclusionTesselate GLS.TerrainRenderer

TTexPointArray GLScene.VectorGeometry

TTexVertList Formats.m3DSTypes

TThorpointArray GLS.ThorFX

TThreadBmp32 GLS.ShadowHDS

TThreadID SDL.Import

** * SDL_thread.h * * We compile SDL into a DLL. This means, that it's the DLL which * creates a new thread for the calling process with the SDL_CreateThread() * API. There is a problem with this, that only the RTL of the SDL.DLL will * be initialized for those threads, and not the RTL of the calling * application! * * To solve this, we make a little hack here. * * We'll always use the caller's _beginthread() and _endthread() APIs to * start a new thread. This way, if it's the SDL.DLL which uses this API, * then the RTL of SDL.DLL will be used to create the new thread, and if it's * the application, then the RTL of the application will be used. * * So, in short: * Always use the _beginthread() and _endthread() of the calling runtime * library! *
TTileManagementFlag GLS.TerrainRenderer

TTileManagementFlags GLS.TerrainRenderer

TTileType3DS Formats.m3DSTypes

used for tiling field in TBitmap3DS structure
TTimeEventProc GLS.TimeEventsMgr

TTimeEventType GLS.TimeEventsMgr

TTintType3DS Formats.m3DSTypes

TTokenType GLS.Memo

TTouchEvent GLS.SceneViewer

TTransformations GLScene.VectorGeometry

Used to describe a sequence of transformations in following order: [Sx][Sy][Sz][ShearXY][ShearXZ][ShearZY][Rx][Ry][Rz][Tx][Ty][Tz][P(x,y,z,w)] constants are declared for easier access (see MatrixDecompose below)
TTranslator gnugettext

Translates a component (form, frame etc.) to the currently selected language. Put TranslateComponent(self) in the OnCreate event of all your forms. See the manual for documentation on these functions
TTransType GLScene.VectorGeometry

TTriangleRecArray GLScene.VectorTypesExt

TU1 Formats.LWO

TU1DynArray Formats.LWO

TU2 Formats.LWO

TU2Array Formats.LWO

TU2DynArray Formats.LWO

TU4 Formats.LWO

TU48BitBlock GLS.ImageUtils

TU4Array Formats.LWO

TU4DynArray Formats.LWO

TUInt8Array SDL.Import

TUndoChangeEvent GLS.Memo

TUniformAutoSetMethod GLSL.ShaderParameter

TUpdateSpacePartion GLS.VerletTypes

TUseDirtyTiles GLS.AsyncHDS

Determines if/how dirty tiles are displayed and when they are released. When a tile is maked as dirty, a replacement is queued immediately. However, the replacement cant be used until the HDThread has finished preparing it. Dirty tiles can be deleted as soon as they are no longer used/displayed. Possible states for a TUseDirtyTiles. hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, before allowing the renderer to switch over to the new set of tiles. (This prevents a fading checkerbox effect.)
TVec12 Formats.LWO

TS0 = PAnsiChar;
TVec12Array Formats.LWO

TVec12DynArray Formats.LWO

TVector2DArray GLScene.VectorTypesExt

Vector Arrays
TVector2DType GLScene.VectorTypesExt

———————– Vector types ———————–
TVector3DArray GLScene.VectorTypesExt

TVector3DType GLScene.VectorTypesExt

TVector4p GLScene.OpenGL4

TVectorArr GLS.Isolines

TVectorArray GLScene.VectorGeometry

TVectorExt GLScene.VectorTypesExt

TVectorL4D GLS.Isolines

TVectorL4I GLS.Isolines

TVertArray GLScene.VectorTypesExt

TVertex GLScene.VectorGeometry

TVertex2DArr GLS.Isolines

TVertexArray GLScene.VectorTypesExt

TVGradient Formats.m3DSTypes

TViewportData3 Formats.m3DSTypes

TViewType3DS Formats.m3DSTypes

TVirtualKeyCode GLScene.Keyboard

TVORVertex GLS.FileVOR

TVoxelData GLScene.VectorTypesExt

TVoxelStatus GLScene.VectorTypesExt

Voxel types
TWGLSwap GLScene.OpenGL4

TWGLswap GLScene.OpenGLTokens

TWindowShapeMode SDL.Import

** An enum denoting the specific type of contents present in an SDL_WindowShapeParams union. *
TWOCC Formats.VFW

TWordList Formats.m3DSTypes

TWordVector GLScene.VectorGeometry

TWrite SDL.Import

** * Write exactly num objects each of size size from the area * pointed at by ptr to data stream. * * the number of objects written, or 0 at error or end of file. *
TXCollectionItemClass GLScene.XCollection

TXDataDouble Formats.m3DSTypes

TXDataFloat Formats.m3DSTypes

TXDataLong Formats.m3DSTypes

TXDataShort Formats.m3DSTypes

TXDataVoid Formats.m3DSTypes

TZArray GLS.zBuffer

TZArrayIdx GLS.zBuffer

TZCompressedMode GLS.FileVfsPAK

Signature for compressed pak.
UByteElement CUDA.DataAccess

UInt16 SDL.Import

UInt32 SDL.Import

UInt8 SDL.Import

UIntElement CUDA.DataAccess

UnicodeString gnugettext

***************************************************************************
UShortElement CUDA.DataAccess

WGLSWAP GLScene.OpenGL4

WGLSWAP GLScene.OpenGLTokens


GLSysHelp v.2.5: All Variables

All Variables

Name Unit Description
ActiveVfsPAK GLS.FileVfsPAK

ALAUXILIARYEFFECTSLOTF OpenAL.Import

Set a floating point parameter for an Auxiliary Slot object.
ALAUXILIARYEFFECTSLOTFV OpenAL.Import

ALAUXILIARYEFFECTSLOTI OpenAL.Import

Set an integer parameter for a Auxiliary Slot object.
ALAUXILIARYEFFECTSLOTIV OpenAL.Import

alBuffer3f OpenAL.Import

alBuffer3i OpenAL.Import

alBufferData OpenAL.Import

Specify the data to be filled into a buffer.
alBufferf OpenAL.Import

alBufferfv OpenAL.Import

alBufferi OpenAL.Import

set parameter for an buffer object
alBufferiv OpenAL.Import

alcCaptureCloseDevice OpenAL.Import

alcCaptureOpenDevice OpenAL.Import

Capture functions
alcCaptureSamples OpenAL.Import

alcCaptureStart OpenAL.Import

alcCaptureStop OpenAL.Import

alcCloseDevice OpenAL.Import

alcCreateContext OpenAL.Import

alc functions Context Support
alcDestroyContext OpenAL.Import

alcGetContextsDevice OpenAL.Import

alcGetCurrentContext OpenAL.Import

alcGetEnumValue OpenAL.Import

alcGetError OpenAL.Import

Error Support Obtain the most recent Context error
alcGetIntegerv OpenAL.Import

alcGetProcAddress OpenAL.Import

alcGetString OpenAL.Import

Query functions
alcIsExtensionPresent OpenAL.Import

Extension support. Query for the presence of an extension, and obtain any appropriate function pointers and enum values.
alcMakeContextCurrent OpenAL.Import

alcOpenDevice OpenAL.Import

Device Management
alcProcessContext OpenAL.Import

alcSuspendContext OpenAL.Import

ALDELETEAUXILIARYEFFECTSLOTS OpenAL.Import

Delete Auxiliary Slot objects.
alDeleteBuffers OpenAL.Import

ALDELETEEFFECTS OpenAL.Import

Delete Effect objects.
ALDELETEFILTERS OpenAL.Import

Delete Filter objects.
alDeleteSources OpenAL.Import

Delete Source objects.
alDisable OpenAL.Import

alDistanceModel OpenAL.Import

Global Parameters
alDopplerFactor OpenAL.Import

alDopplerVelocity OpenAL.Import

ALEFFECTF OpenAL.Import

Set a floating point parameter for an Effect object.
ALEFFECTFV OpenAL.Import

ALEFFECTI OpenAL.Import

Set an integer parameter for an Effect object.
ALEFFECTIV OpenAL.Import

alEnable OpenAL.Import

END EAX extension OpenAL Maintenance Functions State Management and Query. Error Handling. Extension Support. Renderer State management.
ALFILTERF OpenAL.Import

Set a floating point parameter for an Filter object.
ALFILTERFV OpenAL.Import

ALFILTERI OpenAL.Import

Set an integer parameter for a Filter object.
ALFILTERIV OpenAL.Import

ALGENAUXILIARYEFFECTSLOTS OpenAL.Import

Auxiliary Slot object functions Creates Auxiliary Slot objects.
alGenBuffers OpenAL.Import

BUFFER Buffer objects are storage space for sample data. Buffers are referred to by Sources. There can be more than one Source using the same Buffer data. If Buffers have to be duplicated on a per-Source basis, the driver has to take care of allocation, copying, and deallocation as well as propagating buffer data changes. Buffer object generation.
ALGENEFFECTS OpenAL.Import

EFX functions Effect object functions. Create Effect objects.
ALGENFILTERS OpenAL.Import

Filter object functions Creates Filter objects.
alGenSources OpenAL.Import

SOURCE Source objects are by default localized. Sources take the PCM data provided in the specified Buffer, apply Source-specific modifications, and then submit them to be mixed according to spatial arrangement etc. Create Source objects.
ALGETAUXILIARYEFFECTSLOTF OpenAL.Import

Get a floating point parameter for a Auxiliary Slot object.
ALGETAUXILIARYEFFECTSLOTFV OpenAL.Import

ALGETAUXILIARYEFFECTSLOTI OpenAL.Import

Get an integer parameter for a Auxiliary Slot object.
ALGETAUXILIARYEFFECTSLOTIV OpenAL.Import

alGetBoolean OpenAL.Import

State retrieval.through return value ( for compatibility )
alGetBooleanv OpenAL.Import

State retrieval.
alGetBuffer3f OpenAL.Import

alGetBuffer3i OpenAL.Import

alGetBufferf OpenAL.Import

alGetBufferfv OpenAL.Import

alGetBufferi OpenAL.Import

read parameter for an buffer object
alGetBufferiv OpenAL.Import

alGetDouble OpenAL.Import

alGetDoublev OpenAL.Import

ALGETEFFECTF OpenAL.Import

Get a floating point parameter for an Effect object.
ALGETEFFECTFV OpenAL.Import

ALGETEFFECTI OpenAL.Import

Get an integer parameter for an Effect object.
ALGETEFFECTIV OpenAL.Import

alGetEnumValue OpenAL.Import

Obtain the integer value of an enumeration (usually an extension) with the name ename.
alGetError OpenAL.Import

ERROR support. Obtain the most recent error generated in the AL state machine.
ALGETFILTERF OpenAL.Import

Get a floating point parameter for a Filter object.
ALGETFILTERFV OpenAL.Import

ALGETFILTERI OpenAL.Import

Get an integer parameter for a Filter object.
ALGETFILTERIV OpenAL.Import

alGetFloat OpenAL.Import

alGetFloatv OpenAL.Import

alGetInteger OpenAL.Import

alGetIntegerv OpenAL.Import

alGetListenerfv OpenAL.Import

alGetListeneriv OpenAL.Import

TODO: verder ontbrekende functies toevoegen. Retrieve listener information
alGetProcAddress OpenAL.Import

Obtain the address of a function (usually an extension) with the name fname. All addresses are context-independent.
alGetSource3f OpenAL.Import

Get three float scalar parameter for a Source object.
alGetSource3i OpenAL.Import

Get three integer scalar parameter for a Source object.
alGetSourcef OpenAL.Import

Get a float scalar parameter for a Source object.
alGetSourcefv OpenAL.Import

Get a float vector parameter for a Source object.
alGetSourcei OpenAL.Import

Get an integer scalar parameter for a Source object.
alGetSourceiv OpenAL.Import

Get a integer vector parameter for a Source object.
alGetString OpenAL.Import

alHint OpenAL.Import

Application preferences for driver performance choices.
ALISAUXILIARYEFFECTSLOT OpenAL.Import

Verify a handle is a valid Auxiliary Slot.
alIsBuffer OpenAL.Import

ALISEFFECT OpenAL.Import

Verify a handle is a valid Effect.
alIsEnabled OpenAL.Import

alIsExtensionPresent OpenAL.Import

EXTENSION support. Obtain the address of a function (usually an extension) with the name fname. All addresses are context-independent.
ALISFILTER OpenAL.Import

Verify a handle is a valid Filter.
alIsSource OpenAL.Import

Verify a handle is a valid Source.
alListener3f OpenAL.Import

Listener Position. Listener Velocity.
alListener3i OpenAL.Import

alListenerf OpenAL.Import

LISTENER Listener is the sample position for a given context. The multi-channel (usually stereo) output stream generated by the mixer is parametrized by this Listener object: its position and velocity relative to Sources, within occluder and reflector geometry. Listener Gain: default 1.0f.
alListenerfv OpenAL.Import

Listener Position: array [0..2] of TALfloat Listener Velocity: array [0..2] of TALfloat Listener Orientation: array [0..5] of TALfloat forward and up vector.
alListeneri OpenAL.Import

Listener Environment: default 0.
alListeneriv OpenAL.Import

alSource3f OpenAL.Import

Set a 3 float parameter for a Source object.
alSource3i OpenAL.Import

Set an 3 integer parameter for a Source object.
alSourcef OpenAL.Import

Set a float parameter for a Source object.
alSourcefv OpenAL.Import

Set a float vector parameter for a Source object.
alSourcei OpenAL.Import

Set an integer parameter for a Source object.
alSourceiv OpenAL.Import

Set an integer vector parameter for a Source object.
alSourcePause OpenAL.Import

Pause a source, temporarily remove it from the mixer list.
alSourcePausev OpenAL.Import

alSourcePlay OpenAL.Import

Activate a source, start replay.
alSourcePlayv OpenAL.Import

vector forms of those functions we all love
alSourceQueueBuffers OpenAL.Import

Queue stuff
alSourceRewind OpenAL.Import

Rewind a souce. Stopped paused and playing sources, resets the offset into the PCM data and sets state to AL_INITIAL.
alSourceRewindv OpenAL.Import

alSourceStop OpenAL.Import

Stop a source, temporarily remove it from the mixer list, and reset its internal state to pre-Play. To remove a Source completely, it has to be deleted following Stop, or before Play.
alSourceStopv OpenAL.Import

alSourceUnqueueBuffers OpenAL.Import

alSpeedOfSound OpenAL.Import

AL_EAX_RAM_FREE OpenAL.Import

AL_EAX_RAM_SIZE OpenAL.Import

X-RAM enums
AL_STORAGE_ACCESSIBLE OpenAL.Import

AL_STORAGE_AUTOMATIC OpenAL.Import

AL_STORAGE_HARDWARE OpenAL.Import

BASS_Apply3D BASS.Import

external bassdll;
BASS_ChannelBytes2Seconds BASS.Import

external bassdll;
BASS_ChannelFlags BASS.Import

external bassdll;
BASS_ChannelGet3DAttributes BASS.Import

external bassdll;
BASS_ChannelGet3DPosition BASS.Import

external bassdll;
BASS_ChannelGetAttribute BASS.Import

external bassdll;
BASS_ChannelGetAttributeEx BASS.Import

external bassdll;
BASS_ChannelGetData BASS.Import

external bassdll;
BASS_ChannelGetDevice BASS.Import

external bassdll;
BASS_ChannelGetInfo BASS.Import

external bassdll;
BASS_ChannelGetLength BASS.Import

external bassdll;
BASS_ChannelGetLevel BASS.Import

external bassdll;
BASS_ChannelGetLevelEx BASS.Import

external bassdll;
BASS_ChannelGetPosition BASS.Import

external bassdll;
BASS_ChannelGetTags BASS.Import

external bassdll;
BASS_ChannelIsActive BASS.Import

external bassdll;
BASS_ChannelIsSliding BASS.Import

external bassdll;
BASS_ChannelLock BASS.Import

external bassdll;
BASS_ChannelPause BASS.Import

external bassdll;
BASS_ChannelPlay BASS.Import

external bassdll;
BASS_ChannelRemoveDSP BASS.Import

external bassdll;
BASS_ChannelRemoveFX BASS.Import

external bassdll;
BASS_ChannelRemoveLink BASS.Import

external bassdll;
BASS_ChannelRemoveSync BASS.Import

external bassdll;
BASS_ChannelSeconds2Bytes BASS.Import

external bassdll;
BASS_ChannelSet3DAttributes BASS.Import

external bassdll;
BASS_ChannelSet3DPosition BASS.Import

external bassdll;
BASS_ChannelSetAttribute BASS.Import

external bassdll;
BASS_ChannelSetAttributeEx BASS.Import

external bassdll;
BASS_ChannelSetDevice BASS.Import

external bassdll;
BASS_ChannelSetDSP BASS.Import

external bassdll;
BASS_ChannelSetFX BASS.Import

external bassdll;
BASS_ChannelSetLink BASS.Import

external bassdll;
BASS_ChannelSetPosition BASS.Import

external bassdll;
BASS_ChannelSetSync BASS.Import

external bassdll;
BASS_ChannelSlideAttribute BASS.Import

external bassdll;
BASS_ChannelStop BASS.Import

external bassdll;
BASS_ChannelUpdate BASS.Import

external bassdll;
BASS_ErrorGetCode BASS.Import

external bassdll;
BASS_Free BASS.Import

external bassdll;
BASS_FXGetParameters BASS.Import

external bassdll;
BASS_FXReset BASS.Import

external bassdll;
BASS_FXSetParameters BASS.Import

external bassdll;
BASS_FXSetPriority BASS.Import

external bassdll;
BASS_Get3DFactors BASS.Import

external bassdll;
BASS_Get3DPosition BASS.Import

external bassdll;
BASS_GetConfig BASS.Import

external bassdll;
BASS_GetConfigPtr BASS.Import

external bassdll;
BASS_GetCPU BASS.Import

external bassdll;
BASS_GetDevice BASS.Import

external bassdll;
BASS_GetDeviceInfo BASS.Import

external bassdll;
BASS_GetDSoundObject BASS.Import

external bassdll;
BASS_GetEAXParameters BASS.Import

external bassdll;
BASS_GetInfo BASS.Import

external bassdll;
BASS_GetVersion BASS.Import

external bassdll;
BASS_GetVolume BASS.Import

external bassdll;
BASS_Init BASS.Import

external bassdll;
BASS_MusicFree BASS.Import

external bassdll;
BASS_MusicLoad BASS.Import

external bassdll;
BASS_Pause BASS.Import

external bassdll;
BASS_PluginFree BASS.Import

external bassdll;
BASS_PluginGetInfo BASS.Import

external bassdll;
BASS_PluginLoad BASS.Import

external bassdll;
BASS_RecordFree BASS.Import

external bassdll;
BASS_RecordGetDevice BASS.Import

external bassdll;
BASS_RecordGetDeviceInfo BASS.Import

external bassdll;
BASS_RecordGetInfo BASS.Import

external bassdll;
BASS_RecordGetInput BASS.Import

external bassdll;
BASS_RecordGetInputName BASS.Import

external bassdll;
BASS_RecordInit BASS.Import

external bassdll;
BASS_RecordSetDevice BASS.Import

external bassdll;
BASS_RecordSetInput BASS.Import

external bassdll;
BASS_RecordStart BASS.Import

external bassdll;
BASS_SampleCreate BASS.Import

external bassdll;
BASS_SampleFree BASS.Import

external bassdll;
BASS_SampleGetChannel BASS.Import

external bassdll;
BASS_SampleGetChannels BASS.Import

external bassdll;
BASS_SampleGetData BASS.Import

external bassdll;
BASS_SampleGetInfo BASS.Import

external bassdll;
BASS_SampleLoad BASS.Import

external bassdll;
BASS_SampleSetData BASS.Import

external bassdll;
BASS_SampleSetInfo BASS.Import

external bassdll;
BASS_SampleStop BASS.Import

external bassdll;
BASS_Set3DFactors BASS.Import

external bassdll;
BASS_Set3DPosition BASS.Import

external bassdll;
BASS_SetConfig BASS.Import

Recording callback function. handle : The recording handle buffer : Buffer containing the recorded sample data length : Number of bytes user : The 'user' parameter value given when calling BASS_RecordStart RETURN : TRUE = continue recording, FALSE = stop
BASS_SetConfigPtr BASS.Import

external bassdll;
BASS_SetDevice BASS.Import

external bassdll;
BASS_SetEAXParameters BASS.Import

external bassdll;
BASS_SetVolume BASS.Import

external bassdll;
BASS_Start BASS.Import

external bassdll;
BASS_Stop BASS.Import

external bassdll;
BASS_StreamCreate BASS.Import

external bassdll;
BASS_StreamCreateFile BASS.Import

external bassdll;
BASS_StreamCreateFileUser BASS.Import

external bassdll;
BASS_StreamCreateURL BASS.Import

external bassdll;
BASS_StreamFree BASS.Import

external bassdll;
BASS_StreamGetFilePosition BASS.Import

external bassdll;
BASS_StreamPutData BASS.Import

external bassdll;
BASS_StreamPutFileData BASS.Import

external bassdll;
BASS_Update BASS.Import

external bassdll;
cuArray3DCreate CUDA.Import

cuArray3DGetDescriptor CUDA.Import

cuArrayCreate CUDA.Import

cuArrayDestroy CUDA.Import

cuArrayGetDescriptor CUDA.Import

cuCtxAttach CUDA.Import

cuCtxCreate CUDA.Import

cuCtxDestroy CUDA.Import

cuCtxDetach CUDA.Import

cuCtxGetDevice CUDA.Import

cuCtxPopCurrent CUDA.Import

cuCtxPushCurrent CUDA.Import

cuCtxSynchronize CUDA.Import

cudaBindTexture CUDA.Runtime

*****************************************************************************
cudaBindTexture2D CUDA.Runtime

cudaBindTextureToArray CUDA.Runtime

cudaChooseDevice CUDA.Runtime

cudaConfigureCall CUDA.Runtime

***************************************************************************** * * * ****************************************************************************
cudaCreateChannelDesc CUDA.Runtime

cudaDriverGetVersion CUDA.Runtime

cudaEventCreate CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************
cudaEventCreateWithFlags CUDA.Runtime

cudaEventDestroy CUDA.Runtime

cudaEventElapsedTime CUDA.Runtime

cudaEventQuery CUDA.Runtime

cudaEventRecord CUDA.Runtime

cudaEventSynchronize CUDA.Runtime

cudaFree CUDA.Runtime

cudaFreeArray CUDA.Runtime

cudaFreeHost CUDA.Runtime

cudaFuncGetAttributes CUDA.Runtime

cudaFuncSetCacheConfig CUDA.Runtime

cudaGetChannelDesc CUDA.Runtime

cudaGetDevice CUDA.Runtime

cudaGetDeviceCount CUDA.Runtime

=*****************************************************************************
cudaGetDeviceProperties CUDA.Runtime

cudaGetErrorString CUDA.Runtime

cudaGetLastError CUDA.Runtime

=*******************************************************************************/
cudaGetSymbolAddress CUDA.Runtime

**************************************************************************** * * * * * * ****************************************************************************
cudaGetSymbolSize CUDA.Runtime

cudaGetTextureAlignmentOffset CUDA.Runtime

cudaGetTextureReference CUDA.Runtime

cudaGLMapBufferObject CUDA.Runtime

cudaGLMapBufferObjectAsync CUDA.Runtime

cudaGLRegisterBufferObject CUDA.Runtime

cudaGLSetBufferObjectMapFlags CUDA.Runtime

cudaGLSetGLDevice CUDA.Runtime

=*******************************************************************************/
cudaGLUnmapBufferObject CUDA.Runtime

cudaGLUnmapBufferObjectAsync CUDA.Runtime

cudaGLUnregisterBufferObject CUDA.Runtime

cudaGraphicsGLRegisterBuffer CUDA.Runtime

cudaGraphicsGLRegisterImage CUDA.Runtime

cudaGraphicsMapResources CUDA.Runtime

cudaGraphicsResourceGetMappedPointer CUDA.Runtime

cudaGraphicsResourceSetMapFlags CUDA.Runtime

cudaGraphicsSubResourceGetMappedArray CUDA.Runtime

cudaGraphicsUnmapResources CUDA.Runtime

cudaGraphicsUnregisterResource CUDA.Runtime

cudaHostAlloc CUDA.Runtime

cudaHostGetDevicePointer CUDA.Runtime

cudaHostGetFlags CUDA.Runtime

cudaLaunch CUDA.Runtime

cudaMalloc CUDA.Runtime

cudaMalloc3D CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************
cudaMalloc3DArray CUDA.Runtime

cudaMallocArray CUDA.Runtime

cudaMallocHost CUDA.Runtime

cudaMallocPitch CUDA.Runtime

cudaMemcpy CUDA.Runtime

cudaMemcpy2D CUDA.Runtime

cudaMemcpy2DArrayToArray CUDA.Runtime

cudaMemcpy2DAsync CUDA.Runtime

cudaMemcpy2DFromArray CUDA.Runtime

cudaMemcpy2DFromArrayAsync CUDA.Runtime

cudaMemcpy2DToArray CUDA.Runtime

cudaMemcpy2DToArrayAsync CUDA.Runtime

cudaMemcpy3D CUDA.Runtime

cudaMemcpy3DAsync CUDA.Runtime

cudaMemcpyArrayToArray CUDA.Runtime

cudaMemcpyAsync CUDA.Runtime

=*****************************************************************************
cudaMemcpyFromArray CUDA.Runtime

cudaMemcpyFromArrayAsync CUDA.Runtime

cudaMemcpyFromSymbol CUDA.Runtime

cudaMemcpyFromSymbolAsync CUDA.Runtime

cudaMemcpyToArray CUDA.Runtime

cudaMemcpyToArrayAsync CUDA.Runtime

cudaMemcpyToSymbol CUDA.Runtime

cudaMemcpyToSymbolAsync CUDA.Runtime

cudaMemGetInfo CUDA.Runtime

cudaMemset CUDA.Runtime

***************************************************************************** * * * * * * ****************************************************************************
cudaMemset2D CUDA.Runtime

cudaMemset3D CUDA.Runtime

cudaRuntimeGetVersion CUDA.Runtime

cudaSetDevice CUDA.Runtime

cudaSetDeviceFlags CUDA.Runtime

cudaSetDoubleForDevice CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************
cudaSetDoubleForHost CUDA.Runtime

cudaSetupArgument CUDA.Runtime

cudaSetValidDevices CUDA.Runtime

cudaStreamCreate CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************
cudaStreamDestroy CUDA.Runtime

cudaStreamQuery CUDA.Runtime

cudaStreamSynchronize CUDA.Runtime

cudaThreadExit CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************
cudaThreadGetLimit CUDA.Runtime

cudaThreadSetLimit CUDA.Runtime

cudaThreadSynchronize CUDA.Runtime

cudaUnbindTexture CUDA.Runtime

cudaWGLGetDevice CUDA.Runtime

cuDeviceComputeCapability CUDA.Import

cuDeviceGet CUDA.Import

cuDeviceGetAttribute CUDA.Import

cuDeviceGetCount CUDA.Import

cuDeviceGetName CUDA.Import

cuDeviceGetProperties CUDA.Import

cuDeviceTotalMem CUDA.Import

cuDriverGetVersion CUDA.Import

cuEventCreate CUDA.Import

cuEventDestroy CUDA.Import

cuEventElapsedTime CUDA.Import

cuEventQuery CUDA.Import

cuEventRecord CUDA.Import

cuEventSynchronize CUDA.Import

cufftDestroy CUDA.FourierTransform

cufftExecC2C CUDA.FourierTransform

cufftExecC2R CUDA.FourierTransform

cufftExecD2Z CUDA.FourierTransform

cufftExecR2C CUDA.FourierTransform

cufftExecZ2D CUDA.FourierTransform

cufftExecZ2Z CUDA.FourierTransform

cufftPlan1d CUDA.FourierTransform

cufftPlan2d CUDA.FourierTransform

cufftPlan3d CUDA.FourierTransform

cufftPlanMany CUDA.FourierTransform

cufftSetCompatibilityMode CUDA.FourierTransform

cufftSetStream CUDA.FourierTransform

cuFuncGetAttribute CUDA.Import

cuFuncSetBlockShape CUDA.Import

cuFuncSetSharedSize CUDA.Import

cuGLCtxCreate CUDA.Import

cuGLInit CUDA.Import

cuGLMapBufferObject CUDA.Import

cuGLMapBufferObjectAsync CUDA.Import

cuGLRegisterBufferObject CUDA.Import

cuGLSetBufferObjectMapFlags CUDA.Import

cuGLUnmapBufferObject CUDA.Import

cuGLUnmapBufferObjectAsync CUDA.Import

cuGLUnregisterBufferObject CUDA.Import

cuGraphicsGLRegisterBuffer CUDA.Import

cuGraphicsGLRegisterImage CUDA.Import

cuGraphicsMapResources CUDA.Import

cuGraphicsResourceGetMappedPointer CUDA.Import

cuGraphicsResourceSetMapFlags CUDA.Import

cuGraphicsSubResourceGetMappedArray CUDA.Import

cuGraphicsUnmapResources CUDA.Import

cuGraphicsUnregisterResource CUDA.Import

cuInit CUDA.Import

cuLaunch CUDA.Import

cuLaunchGrid CUDA.Import

cuLaunchGridAsync CUDA.Import

cuMemAlloc CUDA.Import

cuMemAllocHost CUDA.Import

cuMemAllocPitch CUDA.Import

cuMemcpy2D CUDA.Import

cuMemcpy2DAsync CUDA.Import

cuMemcpy2DUnaligned CUDA.Import

cuMemcpy3D CUDA.Import

cuMemcpy3DAsync CUDA.Import

cuMemcpyAtoA CUDA.Import

cuMemcpyAtoD CUDA.Import

cuMemcpyAtoH CUDA.Import

cuMemcpyAtoHAsync CUDA.Import

cuMemcpyDtoA CUDA.Import

cuMemcpyDtoD CUDA.Import

cuMemcpyDtoDAsync CUDA.Import

cuMemcpyDtoH CUDA.Import

cuMemcpyDtoHAsync CUDA.Import

cuMemcpyHtoA CUDA.Import

cuMemcpyHtoAAsync CUDA.Import

cuMemcpyHtoD CUDA.Import

cuMemcpyHtoDAsync CUDA.Import

cuMemFree CUDA.Import

cuMemFreeHost CUDA.Import

cuMemGetAddressRange CUDA.Import

cuMemGetInfo CUDA.Import

cuMemHostAlloc CUDA.Import

cuMemHostGetDevicePointer CUDA.Import

cuMemHostGetFlags CUDA.Import

cuMemsetD16 CUDA.Import

cuMemsetD2D16 CUDA.Import

cuMemsetD2D32 CUDA.Import

cuMemsetD2D8 CUDA.Import

cuMemsetD32 CUDA.Import

cuMemsetD8 CUDA.Import

cuModuleGetFunction CUDA.Import

cuModuleGetGlobal CUDA.Import

cuModuleGetTexRef CUDA.Import

cuModuleLoad CUDA.Import

cuModuleLoadData CUDA.Import

cuModuleLoadDataEx CUDA.Import

cuModuleLoadFatBinary CUDA.Import

cuModuleUnload CUDA.Import

cuParamSetf CUDA.Import

cuParamSeti CUDA.Import

cuParamSetSize CUDA.Import

cuParamSetTexRef CUDA.Import

cuParamSetv CUDA.Import

cuStreamCreate CUDA.Import

cuStreamDestroy CUDA.Import

cuStreamQuery CUDA.Import

cuStreamSynchronize CUDA.Import

cutComparef CUDA.Utility

cutComparefe CUDA.Utility

cutComparefet CUDA.Utility

cutComparei CUDA.Utility

cutCompareL2fe CUDA.Utility

cutCompareub CUDA.Utility

cutCompareube CUDA.Utility

cutCompareubt CUDA.Utility

cutCompareuit CUDA.Utility

cutCreateTimer CUDA.Utility

cutDeleteTimer CUDA.Utility

cuTexRefCreate CUDA.Import

cuTexRefDestroy CUDA.Import

cuTexRefGetAddress CUDA.Import

cuTexRefGetAddressMode CUDA.Import

cuTexRefGetArray CUDA.Import

cuTexRefGetFilterMode CUDA.Import

cuTexRefGetFlags CUDA.Import

cuTexRefGetFormat CUDA.Import

cuTexRefSetAddress CUDA.Import

cuTexRefSetAddress2D CUDA.Import

cuTexRefSetAddressMode CUDA.Import

cuTexRefSetArray CUDA.Import

cuTexRefSetFilterMode CUDA.Import

cuTexRefSetFlags CUDA.Import

cuTexRefSetFormat CUDA.Import

cutFindFilePath CUDA.Utility

cutFree CUDA.Utility

cutGetAverageTimerValue CUDA.Utility

cutGetTimerValue CUDA.Utility

cutLoadPGMf CUDA.Utility

cutLoadPGMi CUDA.Utility

cutLoadPGMs CUDA.Utility

cutLoadPGMub CUDA.Utility

cutLoadPPM4ub CUDA.Utility

cutLoadPPMub CUDA.Utility

cutResetTimer CUDA.Utility

cutSavePGMf CUDA.Utility

cutSavePGMi CUDA.Utility

cutSavePGMs CUDA.Utility

cutSavePGMub CUDA.Utility

cutSavePPM4ub CUDA.Utility

cutSavePPMub CUDA.Utility

cutStartTimer CUDA.Utility

cutStopTimer CUDA.Utility

cuWGLGetDevice CUDA.Import

dBoxClass ODE.Import

dCapsuleClass ODE.Import

dConvexClass ODE.Import

dCylinderClass ODE.Import

Debug_Tri GLS.EllipseCollision

.$DEFINE DEBUG
DefaultInstance gnugettext

dFirstSpaceClass ODE.Import

dFirstUserClass ODE.Import

dGeomNumClasses ODE.Import

dGeomTransformClass ODE.Import

dHashSpaceClass ODE.Import

dHeightFieldClass ODE.Import

DisabledDebugCollision ODE.Import

DisabledDebugGeom ODE.Import

dLastSpaceClass ODE.Import

dLastUserClass ODE.Import

dPlaneClass ODE.Import

dQuadTreeSpaceClass ODE.Import

dRayClass ODE.Import

dSimpleSpaceClass ODE.Import

dSphereClass ODE.Import

dSweepAndPruneSpaceClass ODE.Import

dTriMeshClass ODE.Import

EAXGet OpenAL.Import

EAXGetBufferMode OpenAL.Import

EAXSet OpenAL.Import

EAX functions
EAXSetBufferMode OpenAL.Import

X-RAM functions
EFXUtilLibHandle OpenAL.Import

ExecutableFilename gnugettext

GL GLS.Context

glActiveStencilFaceEXT GLScene.OpenGL4

GL_EXT_stencil_two_side (EXT #268)
glActiveTexture GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.3 Core ########################################################### promoted to core v1.3 from GL_ARB_multitexture (#1)
glActiveTextureARB GLScene.OpenGL4

GL_ARB_multitexture (ARB #1)
glActiveVaryingNV GLScene.OpenGL4

glAddSwapHintRectWIN GLScene.OpenGL4

GL_WIN_swap_hint (extension # not found)
glAreProgramsResidentNV GLScene.OpenGL4

GL_NV_vertex_program (EXT #233)
glAreTexturesResidentEXT GLScene.OpenGL4

glArrayElementArrayEXT GLScene.OpenGL4

########################################################### function and procedure definitions for Vendor/EXT extensions ########################################################### Unknown Vendor/EXT functions
glAttachObjectARB GLScene.OpenGL4

glAttachShader GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)
glBeginConditionalRender GLScene.OpenGL4

glBeginConditionalRenderNV GLScene.OpenGL4

GL_NV_conditional_render (#346)
glBeginOcclusionQueryNV GLScene.OpenGL4

glBeginQuery GLScene.OpenGL4

glBeginQueryARB GLScene.OpenGL4

glBeginQueryIndexed GLScene.OpenGL4

glBeginSceneEXT GLScene.OpenGL4

GL_EXT_scene_marker (EXT #120)
glBeginTransformFeedback GLScene.OpenGL4

glBeginTransformFeedbackEXT GLScene.OpenGL4

glBeginTransformFeedbackNV GLScene.OpenGL4

glBindAttribLocation GLScene.OpenGL4

glBindAttribLocationARB GLScene.OpenGL4

GL_ARB_vertex_shader (ARB #31)
glBindBuffer GLScene.OpenGL4

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)
glBindBufferARB GLScene.OpenGL4

GL_ARB_vertex_buffer_object (ARB #28)
glBindBufferBase GLScene.OpenGL4

glBindBufferBaseEXT GLScene.OpenGL4

glBindBufferBaseNV GLScene.OpenGL4

glBindBufferOffsetEXT GLScene.OpenGL4

glBindBufferOffsetNV GLScene.OpenGL4

glBindBufferRange GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_transform_feedback
glBindBufferRangeEXT GLScene.OpenGL4

GL_EXT_transform_feedback (#352)
glBindBufferRangeNV GLScene.OpenGL4

GL_NV_transform_feedback (#341)
glBindFragDataLocation GLScene.OpenGL4

glBindFragDataLocationEXT GLScene.OpenGL4

glBindFragDataLocationIndexed GLScene.OpenGL4

GL_ARB_blend_func_extended (ARB #78)
glBindFramebuffer GLScene.OpenGL4

glBindFramebufferEXT GLScene.OpenGL4

glBindProgramARB GLScene.OpenGL4

glBindProgramNV GLScene.OpenGL4

glBindRenderbuffer GLScene.OpenGL4

glBindRenderbufferEXT GLScene.OpenGL4

glBindSampler GLScene.OpenGL4

glBindTextureEXT GLScene.OpenGL4

glBindTransformFeedback GLScene.OpenGL4

GL_ARB_transform_feedback2 (ARB #93)
glBindVertexArray GLScene.OpenGL4

GL_ARB_vertex_array_object (ARB #54)
glBlendColor GLScene.OpenGL4

——————- OpenGL extension function/procedure definitions —————— ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.2 Core ########################################################### promoted to core v1.2 from GL_EXT_blend_color (#2)
glBlendColorEXT GLScene.OpenGL4

GL_EXT_blend_color (EXT #2)
glBlendEquation GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_blend_minmax (#37)
glBlendEquationEXT GLScene.OpenGL4

GL_EXT_blend_minmax (EXT #37)
glBlendEquationi GLScene.OpenGL4

GL_ARB_draw_buffers_blend (ARB #69)
glBlendEquationSeparate GLScene.OpenGL4

promoted to core v1.5 from GL_EXT_shadow_funcs (#267) (no functions or procedures) ########################################################### function and procedure definitions for extensions integrated into OpenGL 2.0 Core ########################################################### promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)
glBlendEquationSeparateEXT GLScene.OpenGL4

GL_EXT_blend_equation_separate (EXT #299)
glBlendEquationSeparatei GLScene.OpenGL4

glBlendFunci GLScene.OpenGL4

glBlendFuncSeparate GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.4 Core ########################################################### promoted to core v1.4 from GL_EXT_blend_func_separate (#173)
glBlendFuncSeparateEXT GLScene.OpenGL4

GL_EXT_blend_func_separate (EXT #173)
glBlendFuncSeparatei GLScene.OpenGL4

glBlitFramebuffer GLScene.OpenGL4

glBlitFramebufferEXT GLScene.OpenGL4

GL_EXT_framebuffer_blit (#316)
glBufferAddressRangeNV GLScene.OpenGL4

GL_NV_vertex_buffer_unified_memory (#380)
glBufferData GLScene.OpenGL4

glBufferDataARB GLScene.OpenGL4

glBufferSubData GLScene.OpenGL4

glBufferSubDataARB GLScene.OpenGL4

glCheckFramebufferStatus GLScene.OpenGL4

glCheckFramebufferStatusEXT GLScene.OpenGL4

glClampColor GLScene.OpenGL4

glClampColorARB GLScene.OpenGL4

GL_ARB_color_buffer_float (ARB #39)
glClearBufferfi GLScene.OpenGL4

glClearBufferfv GLScene.OpenGL4

glClearBufferiv GLScene.OpenGL4

New commands in OpenGL 3.0
glClearBufferuiv GLScene.OpenGL4

glClearColorIiEXT GLScene.OpenGL4

GL_EXT_texture_integer (#343)
glClearColorIuiEXT GLScene.OpenGL4

glClientActiveTexture GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_multitexture (#1)
glClientActiveTextureARB GLScene.OpenGL4

glClientWaitSync GLScene.OpenGL4

glColorFormatNV GLScene.OpenGL4

glColorMaski GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_draw_buffers2
glColorMaskIndexedEXT GLScene.OpenGL4

GL_EXT_draw_buffers2 (#340)
glColorP3ui GLScene.OpenGL4

glColorP3uiv GLScene.OpenGL4

glColorP4ui GLScene.OpenGL4

glColorP4uiv GLScene.OpenGL4

glColorSubTable GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)
glColorSubTableExt GLScene.OpenGL4

glColorTable GLScene.OpenGL4

OpenGL 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)
glColorTableEXT GLScene.OpenGL4

GL_EXT_paletted_texture (EXT #78)
glColorTableParameterfv GLScene.OpenGL4

deprecated;
glColorTableParameteriv GLScene.OpenGL4

deprecated;
glCombinerInputNV GLScene.OpenGL4

glCombinerOutputNV GLScene.OpenGL4

glCombinerParameterfNV GLScene.OpenGL4

glCombinerParameterfvNV GLScene.OpenGL4

GL_NV_register_combiners (EXT #191)
glCombinerParameteriNV GLScene.OpenGL4

glCombinerParameterivNV GLScene.OpenGL4

glCompileShader GLScene.OpenGL4

glCompileShaderARB GLScene.OpenGL4

glCompressedTexImage1D GLScene.OpenGL4

glCompressedTexImage1DARB GLScene.OpenGL4

glCompressedTexImage2D GLScene.OpenGL4

glCompressedTexImage2DARB GLScene.OpenGL4

glCompressedTexImage3D GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_texture_compression (#12)
glCompressedTexImage3DARB GLScene.OpenGL4

GL_ARB_texture_compression (ARB #12)
glCompressedTexSubImage1D GLScene.OpenGL4

glCompressedTexSubImage1DARB GLScene.OpenGL4

glCompressedTexSubImage2D GLScene.OpenGL4

glCompressedTexSubImage2DARB GLScene.OpenGL4

glCompressedTexSubImage3D GLScene.OpenGL4

glCompressedTexSubImage3DARB GLScene.OpenGL4

GLContextManager GLS.Context

glConvolutionFilter1D GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)
glConvolutionFilter2D GLScene.OpenGL4

deprecated;
glConvolutionParameterf GLScene.OpenGL4

deprecated;
glConvolutionParameterfv GLScene.OpenGL4

deprecated;
glConvolutionParameteri GLScene.OpenGL4

deprecated;
glConvolutionParameteriv GLScene.OpenGL4

deprecated;
glCopyBufferSubData GLScene.OpenGL4

GL_ARB_copy_buffer (ARB #59)
glCopyColorSubTable GLScene.OpenGL4

deprecated;
glCopyColorTable GLScene.OpenGL4

deprecated;
glCopyConvolutionFilter1D GLScene.OpenGL4

deprecated;
glCopyConvolutionFilter2D GLScene.OpenGL4

deprecated;
glCopyImageSubDataNV GLScene.OpenGL4

GL_NV_copy_image (#376)
glCopyTexImage1DEXT GLScene.OpenGL4

GL_EXT_copy_texture (EXT #10)
glCopyTexImage2DEXT GLScene.OpenGL4

glCopyTexSubImage1DEXT GLScene.OpenGL4

glCopyTexSubImage2DEXT GLScene.OpenGL4

glCopyTexSubImage3D GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_copy_texture
glCopyTexSubImage3DEXT GLScene.OpenGL4

glCreateProgram GLScene.OpenGL4

glCreateProgramObjectARB GLScene.OpenGL4

glCreateShader GLScene.OpenGL4

glCreateShaderObjectARB GLScene.OpenGL4

glCurrentPaletteMatrixARB GLScene.OpenGL4

GL_ARB_matrix_palette (ARB #16) {deprecated?}
glDeleteBuffers GLScene.OpenGL4

glDeleteBuffersARB GLScene.OpenGL4

glDeleteFencesNV GLScene.OpenGL4

glDeleteFramebuffers GLScene.OpenGL4

glDeleteFramebuffersEXT GLScene.OpenGL4

glDeleteObjectARB GLScene.OpenGL4

GL_ARB_shader_objects (ARB #30)
glDeleteOcclusionQueriesNV GLScene.OpenGL4

glDeleteProgram GLScene.OpenGL4

glDeleteProgramsARB GLScene.OpenGL4

glDeleteProgramsNV GLScene.OpenGL4

glDeleteQueries GLScene.OpenGL4

glDeleteQueriesARB GLScene.OpenGL4

glDeleteRenderbuffers GLScene.OpenGL4

glDeleteRenderbuffersEXT GLScene.OpenGL4

glDeleteSamplers GLScene.OpenGL4

glDeleteShader GLScene.OpenGL4

glDeleteSync GLScene.OpenGL4

glDeleteTexturesEXT GLScene.OpenGL4

glDeleteTransformFeedbacks GLScene.OpenGL4

glDeleteVertexArrays GLScene.OpenGL4

glDepthBoundsEXT GLScene.OpenGL4

GL_EXT_depth_bounds_test (EXT #297)
glDetachObjectARB GLScene.OpenGL4

glDetachShader GLScene.OpenGL4

glDisablei GLScene.OpenGL4

glDisableIndexedEXT GLScene.OpenGL4

glDisableVertexAttribArray GLScene.OpenGL4

glDisableVertexAttribArrayARB GLScene.OpenGL4

glDrawArraysIndirect GLScene.OpenGL4

GL_ARB_draw_indirect (ARB #87)
glDrawArraysInstanced GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.1 Core ###########################################################
glDrawArraysInstancedARB GLScene.OpenGL4

GL_ARB_draw_instanced (ARB #44)
glDrawArraysInstancedEXT GLScene.OpenGL4

GL_EXT_draw_instanced (#327)
glDrawBuffers GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_draw_buffers (#37)
glDrawBuffersARB GLScene.OpenGL4

GL_ARB_DrawBuffers (ARB #37)
glDrawBuffersATI GLScene.OpenGL4

GL_ATI_draw_buffers (EXT #277)
glDrawElementsBaseVertex GLScene.OpenGL4

GL_ARB_draw_elements_base_vertex (ARB #62)
glDrawElementsIndirect GLScene.OpenGL4

glDrawElementsInstanced GLScene.OpenGL4

glDrawElementsInstancedARB GLScene.OpenGL4

glDrawElementsInstancedBaseVertex GLScene.OpenGL4

glDrawElementsInstancedEXT GLScene.OpenGL4

glDrawRangeElements GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)
glDrawRangeElementsBaseVertex GLScene.OpenGL4

glDrawRangeElementsEXT GLScene.OpenGL4

GL_EXT_draw_range_elements (EXT #112)
glDrawTransformFeedback GLScene.OpenGL4

glDrawTransformFeedbackStream GLScene.OpenGL4

GL_ARB_transform_feedback3 (ARB #94)
glEdgeFlagFormatNV GLScene.OpenGL4

glEnablei GLScene.OpenGL4

glEnableIndexedEXT GLScene.OpenGL4

glEnableVertexAttribArray GLScene.OpenGL4

glEnableVertexAttribArrayARB GLScene.OpenGL4

glEndConditionalRender GLScene.OpenGL4

glEndConditionalRenderNV GLScene.OpenGL4

glEndOcclusionQueryNV GLScene.OpenGL4

glEndQuery GLScene.OpenGL4

glEndQueryARB GLScene.OpenGL4

glEndQueryIndexed GLScene.OpenGL4

glEndSceneEXT GLScene.OpenGL4

glEndTransformFeedback GLScene.OpenGL4

glEndTransformFeedbackEXT GLScene.OpenGL4

glEndTransformFeedbackNV GLScene.OpenGL4

glExecuteProgramNV GLScene.OpenGL4

glFenceSync GLScene.OpenGL4

GL_ARB_sync (ARB #66)
glFinalCombinerInputNV GLScene.OpenGL4

glFinishFenceNV GLScene.OpenGL4

glFlushMappedBufferRange GLScene.OpenGL4

glFlushVertexArrayRangeNV GLScene.OpenGL4

GL_NV_vertex_array_range (EXT #190)
glFogCoordd GLScene.OpenGL4

deprecated;
glFogCoorddEXT GLScene.OpenGL4

glFogCoorddv GLScene.OpenGL4

deprecated;
glFogCoorddvEXT GLScene.OpenGL4

glFogCoordf GLScene.OpenGL4

promoted to core v1.4 from GL_EXT_fog_coord (#149)
glFogCoordfEXT GLScene.OpenGL4

GL_EXT_fog_coord (EXT #149)
glFogCoordFormatNV GLScene.OpenGL4

glFogCoordfv GLScene.OpenGL4

deprecated;
glFogCoordfvEXT GLScene.OpenGL4

glFogCoordPointer GLScene.OpenGL4

deprecated;
glFogCoordPointerEXT GLScene.OpenGL4

glFramebufferRenderbuffer GLScene.OpenGL4

glFramebufferRenderbufferEXT GLScene.OpenGL4

glFramebufferTexture GLScene.OpenGL4

glFramebufferTexture1D GLScene.OpenGL4

glFramebufferTexture1DEXT GLScene.OpenGL4

glFramebufferTexture2D GLScene.OpenGL4

glFramebufferTexture2DEXT GLScene.OpenGL4

glFramebufferTexture3D GLScene.OpenGL4

glFramebufferTexture3DEXT GLScene.OpenGL4

glFramebufferTextureARB GLScene.OpenGL4

glFramebufferTextureEXT GLScene.OpenGL4

glFramebufferTextureFaceARB GLScene.OpenGL4

glFramebufferTextureFaceEXT GLScene.OpenGL4

glFramebufferTextureLayer GLScene.OpenGL4

glFramebufferTextureLayerARB GLScene.OpenGL4

glFramebufferTextureLayerEXT GLScene.OpenGL4

glFrameTerminatorGREMEDY GLScene.OpenGL4

Special Gremedy debugger extension
glGenBuffers GLScene.OpenGL4

glGenBuffersARB GLScene.OpenGL4

glGenerateMipmap GLScene.OpenGL4

glGenerateMipmapEXT GLScene.OpenGL4

glGenFencesNV GLScene.OpenGL4

GL_NV_fence (EXT #222)
glGenFramebuffers GLScene.OpenGL4

glGenFramebuffersEXT GLScene.OpenGL4

glGenOcclusionQueriesNV GLScene.OpenGL4

GL_NV_occlusion_query (EXT #261)
glGenProgramsARB GLScene.OpenGL4

glGenProgramsNV GLScene.OpenGL4

glGenQueries GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.5 Core ########################################################### promoted to core v1.5 from GL_ARB_occlusion_query (#29)
glGenQueriesARB GLScene.OpenGL4

GL_ARB_occlusion_query (ARB #29)
glGenRenderbuffers GLScene.OpenGL4

glGenRenderbuffersEXT GLScene.OpenGL4

glGenSamplers GLScene.OpenGL4

GL_ARB_sampler_objects (ARB #81)
glGenTexturesEXT GLScene.OpenGL4

GL_EXT_texture_object (EXT #20)
glGenTransformFeedbacks GLScene.OpenGL4

glGenVertexArrays GLScene.OpenGL4

glGetActiveAttrib GLScene.OpenGL4

glGetActiveAttribARB GLScene.OpenGL4

glGetActiveSubroutineName GLScene.OpenGL4

glGetActiveSubroutineUniformiv GLScene.OpenGL4

glGetActiveSubroutineUniformName GLScene.OpenGL4

glGetActiveUniform GLScene.OpenGL4

glGetActiveUniformARB GLScene.OpenGL4

glGetActiveUniformBlockiv GLScene.OpenGL4

glGetActiveUniformBlockName GLScene.OpenGL4

glGetActiveUniformName GLScene.OpenGL4

glGetActiveUniformsiv GLScene.OpenGL4

glGetActiveVaryingNV GLScene.OpenGL4

glGetAttachedObjectsARB GLScene.OpenGL4

glGetAttachedShaders GLScene.OpenGL4

glGetAttribLocation GLScene.OpenGL4

glGetAttribLocationARB GLScene.OpenGL4

glGetBooleanIndexedvEXT GLScene.OpenGL4

glGetBooleani_v GLScene.OpenGL4

glGetBufferParameteri64v GLScene.OpenGL4

glGetBufferParameteriv GLScene.OpenGL4

glGetBufferParameterivARB GLScene.OpenGL4

glGetBufferParameterui64vNV GLScene.OpenGL4

glGetBufferPointerv GLScene.OpenGL4

glGetBufferPointervARB GLScene.OpenGL4

glGetBufferSubData GLScene.OpenGL4

glGetBufferSubDataARB GLScene.OpenGL4

glGetColorTable GLScene.OpenGL4

deprecated;
glGetColorTableEXT GLScene.OpenGL4

glGetColorTableParameterfv GLScene.OpenGL4

deprecated;
glGetColorTableParameterfvEXT GLScene.OpenGL4

glGetColorTableParameteriv GLScene.OpenGL4

deprecated;
glGetColorTableParameterivEXT GLScene.OpenGL4

glGetCombinerInputParameterfvNV GLScene.OpenGL4

glGetCombinerInputParameterivNV GLScene.OpenGL4

glGetCombinerOutputParameterfvNV GLScene.OpenGL4

glGetCombinerOutputParameterivNV GLScene.OpenGL4

glGetCompressedTexImage GLScene.OpenGL4

glGetCompressedTexImageARB GLScene.OpenGL4

glGetConvolutionFilter GLScene.OpenGL4

deprecated;
glGetConvolutionParameterfv GLScene.OpenGL4

deprecated;
glGetConvolutionParameteriv GLScene.OpenGL4

deprecated;
glGetFenceivNV GLScene.OpenGL4

glGetFinalCombinerInputParameterfvNV GLScene.OpenGL4

glGetFinalCombinerInputParameterivNV GLScene.OpenGL4

glGetFragDataIndex GLScene.OpenGL4

glGetFragDataLocation GLScene.OpenGL4

glGetFragDataLocationEXT GLScene.OpenGL4

glGetFramebufferAttachmentParameteriv GLScene.OpenGL4

glGetFramebufferAttachmentParameterivEXT GLScene.OpenGL4

glGetHandleARB GLScene.OpenGL4

glGetHistogram GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)
glGetHistogramParameterfv GLScene.OpenGL4

deprecated;
glGetHistogramParameteriv GLScene.OpenGL4

deprecated;
glGetInfoLogARB GLScene.OpenGL4

glGetInteger64i_v GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.2 Core ###########################################################
glGetInteger64v GLScene.OpenGL4

glGetIntegerIndexedvEXT GLScene.OpenGL4

glGetIntegeri_v GLScene.OpenGL4

glGetIntegerui64i_vNV GLScene.OpenGL4

glGetIntegerui64vNV GLScene.OpenGL4

glGetMinmax GLScene.OpenGL4

deprecated;
glGetMinmaxParameterfv GLScene.OpenGL4

deprecated;
glGetMinmaxParameteriv GLScene.OpenGL4

deprecated;
glGetMultisamplefv GLScene.OpenGL4

glGetNamedBufferParameterui64vNV GLScene.OpenGL4

glGetObjectParameterfvARB GLScene.OpenGL4

glGetObjectParameterivARB GLScene.OpenGL4

glGetOcclusionQueryivNV GLScene.OpenGL4

glGetOcclusionQueryuivNV GLScene.OpenGL4

glGetProgramEnvParameterdvARB GLScene.OpenGL4

glGetProgramEnvParameterfvARB GLScene.OpenGL4

glGetProgramInfoLog GLScene.OpenGL4

glGetProgramiv GLScene.OpenGL4

glGetProgramivARB GLScene.OpenGL4

glGetProgramivNV GLScene.OpenGL4

glGetProgramLocalParameterdvARB GLScene.OpenGL4

glGetProgramLocalParameterfvARB GLScene.OpenGL4

glGetProgramParameterdvNV GLScene.OpenGL4

glGetProgramParameterfvNV GLScene.OpenGL4

glGetProgramStageiv GLScene.OpenGL4

glGetProgramStringARB GLScene.OpenGL4

glGetProgramStringNV GLScene.OpenGL4

glGetQueryIndexediv GLScene.OpenGL4

glGetQueryiv GLScene.OpenGL4

glGetQueryivARB GLScene.OpenGL4

glGetQueryObjecti64v GLScene.OpenGL4

glGetQueryObjecti64vEXT GLScene.OpenGL4

GL_EXT_timer_query (#319)
glGetQueryObjectiv GLScene.OpenGL4

glGetQueryObjectivARB GLScene.OpenGL4

glGetQueryObjectui64v GLScene.OpenGL4

glGetQueryObjectui64vEXT GLScene.OpenGL4

glGetQueryObjectuiv GLScene.OpenGL4

glGetQueryObjectuivARB GLScene.OpenGL4

glGetRenderbufferParameteriv GLScene.OpenGL4

glGetRenderbufferParameterivEXT GLScene.OpenGL4

glGetSamplerParameterfv GLScene.OpenGL4

glGetSamplerParameterIfv GLScene.OpenGL4

glGetSamplerParameterIiv GLScene.OpenGL4

glGetSamplerParameteriv GLScene.OpenGL4

glGetSeparableFilter GLScene.OpenGL4

deprecated;
glGetShaderInfoLog GLScene.OpenGL4

glGetShaderiv GLScene.OpenGL4

glGetShaderSource GLScene.OpenGL4

glGetShaderSourceARB GLScene.OpenGL4

glGetStringi GLScene.OpenGL4

glGetSubroutineIndex GLScene.OpenGL4

glGetSubroutineUniformLocation GLScene.OpenGL4

GL_ARB_shader_subroutine (ARB #90)
glGetSynciv GLScene.OpenGL4

glGetTexParameterIiv GLScene.OpenGL4

glGetTexParameterIivEXT GLScene.OpenGL4

glGetTexParameterIuiv GLScene.OpenGL4

glGetTexParameterIuivEXT GLScene.OpenGL4

glGetTrackMatrixivNV GLScene.OpenGL4

glGetTransformFeedbackVarying GLScene.OpenGL4

glGetTransformFeedbackVaryingEXT GLScene.OpenGL4

glGetTransformFeedbackVaryingNV GLScene.OpenGL4

glGetUniformBlockIndex GLScene.OpenGL4

glGetUniformBufferSizeEXT GLScene.OpenGL4

glGetUniformdv GLScene.OpenGL4

glGetUniformfv GLScene.OpenGL4

glGetUniformfvARB GLScene.OpenGL4

glGetUniformIndices GLScene.OpenGL4

GL_ARB_uniform_buffer_object (ARB #57)
glGetUniformiv GLScene.OpenGL4

glGetUniformivARB GLScene.OpenGL4

glGetUniformLocation GLScene.OpenGL4

glGetUniformLocationARB GLScene.OpenGL4

glGetUniformOffsetEXT GLScene.OpenGL4

glGetUniformSubroutineuiv GLScene.OpenGL4

glGetUniformui64vNV GLScene.OpenGL4

glGetUniformuiv GLScene.OpenGL4

glGetUniformuivEXT GLScene.OpenGL4

glGetVaryingLocationNV GLScene.OpenGL4

glGetVertexAttribdv GLScene.OpenGL4

glGetVertexAttribdvARB GLScene.OpenGL4

glGetVertexAttribdvNV GLScene.OpenGL4

glGetVertexAttribfv GLScene.OpenGL4

glGetVertexAttribfvARB GLScene.OpenGL4

glGetVertexAttribfvNV GLScene.OpenGL4

glGetVertexAttribIiv GLScene.OpenGL4

glGetVertexAttribIivEXT GLScene.OpenGL4

glGetVertexAttribIuiv GLScene.OpenGL4

glGetVertexAttribIuivEXT GLScene.OpenGL4

glGetVertexAttribiv GLScene.OpenGL4

glGetVertexAttribivARB GLScene.OpenGL4

glGetVertexAttribivNV GLScene.OpenGL4

glGetVertexAttribPointerv GLScene.OpenGL4

glGetVertexAttribPointervARB GLScene.OpenGL4

glGetVertexAttribPointervNV GLScene.OpenGL4

glHistogram GLScene.OpenGL4

deprecated;
glIndexFormatNV GLScene.OpenGL4

glIndexFuncEXT GLScene.OpenGL4

GL_EXT_index_func (EXT #95)
glIndexMaterialEXT GLScene.OpenGL4

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} GL_EXT_index_material (EXT #94)
glIsBuffer GLScene.OpenGL4

glIsBufferARB GLScene.OpenGL4

glIsBufferResidentNV GLScene.OpenGL4

glIsEnabledi GLScene.OpenGL4

glIsEnabledIndexedEXT GLScene.OpenGL4

glIsFenceNV GLScene.OpenGL4

glIsFramebuffer GLScene.OpenGL4

glIsFramebufferEXT GLScene.OpenGL4

glIsNamedBufferResidentNV GLScene.OpenGL4

glIsOcclusionQueryNV GLScene.OpenGL4

glIsProgram GLScene.OpenGL4

glIsProgramARB GLScene.OpenGL4

glIsProgramNV GLScene.OpenGL4

glIsQuery GLScene.OpenGL4

glIsQueryARB GLScene.OpenGL4

glIsRenderbuffer GLScene.OpenGL4

GL_ARB_framebuffer_object (ARB #45)
glIsRenderbufferEXT GLScene.OpenGL4

GL_EXT_framebuffer_object (EXT #310)
glIsSampler GLScene.OpenGL4

glIsShader GLScene.OpenGL4

glIsSync GLScene.OpenGL4

glIsTextureEXT GLScene.OpenGL4

glIsTransformFeedback GLScene.OpenGL4

glIsVertexArray GLScene.OpenGL4

glLinkProgram GLScene.OpenGL4

glLinkProgramARB GLScene.OpenGL4

glLoadProgramNV GLScene.OpenGL4

glLoadTransposeMatrixd GLScene.OpenGL4

deprecated;
glLoadTransposeMatrixdARB GLScene.OpenGL4

glLoadTransposeMatrixf GLScene.OpenGL4

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix
glLoadTransposeMatrixfARB GLScene.OpenGL4

GL_ARB_transpose_matrix (ARB #3)
glLockArraysEXT GLScene.OpenGL4

GL_EXT_compiled_vertex_array (EXT #97)
glMakeBufferNonResidentNV GLScene.OpenGL4

glMakeBufferResidentNV GLScene.OpenGL4

GL_NV_shader_buffer_load (#379)
glMakeNamedBufferNonResidentNV GLScene.OpenGL4

glMakeNamedBufferResidentNV GLScene.OpenGL4

glMapBuffer GLScene.OpenGL4

glMapBufferARB GLScene.OpenGL4

glMapBufferRange GLScene.OpenGL4

GL_ARB_map_buffer_range (ARB #50)
glMatrixIndexPointerARB GLScene.OpenGL4

glMatrixIndexubvARB GLScene.OpenGL4

glMatrixIndexuivARB GLScene.OpenGL4

glMatrixIndexusvARB GLScene.OpenGL4

glMinmax GLScene.OpenGL4

deprecated;
glMinSampleShading GLScene.OpenGL4

GL_ARB_sample_shading (ARB #70)
glMultiDrawArrays GLScene.OpenGL4

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)
glMultiDrawArraysEXT GLScene.OpenGL4

GL_EXT_multi_draw_arrays (EXT #148)
glMultiDrawElements GLScene.OpenGL4

glMultiDrawElementsBaseVertex GLScene.OpenGL4

glMultiDrawElementsEXT GLScene.OpenGL4

glMultiTexCoord1d GLScene.OpenGL4

deprecated;
glMultiTexCoord1dARB GLScene.OpenGL4

glMultiTexCoord1dV GLScene.OpenGL4

deprecated;
glMultiTexCoord1dVARB GLScene.OpenGL4

glMultiTexCoord1f GLScene.OpenGL4

deprecated;
glMultiTexCoord1fARB GLScene.OpenGL4

glMultiTexCoord1fV GLScene.OpenGL4

deprecated;
glMultiTexCoord1fVARB GLScene.OpenGL4

glMultiTexCoord1i GLScene.OpenGL4

deprecated;
glMultiTexCoord1iARB GLScene.OpenGL4

glMultiTexCoord1iV GLScene.OpenGL4

deprecated;
glMultiTexCoord1iVARB GLScene.OpenGL4

glMultiTexCoord1s GLScene.OpenGL4

deprecated;
glMultiTexCoord1sARB GLScene.OpenGL4

glMultiTexCoord1sV GLScene.OpenGL4

deprecated;
glMultiTexCoord1sVARB GLScene.OpenGL4

glMultiTexCoord2d GLScene.OpenGL4

deprecated;
glMultiTexCoord2dARB GLScene.OpenGL4

glMultiTexCoord2dv GLScene.OpenGL4

deprecated;
glMultiTexCoord2dvARB GLScene.OpenGL4

glMultiTexCoord2f GLScene.OpenGL4

deprecated;
glMultiTexCoord2fARB GLScene.OpenGL4

glMultiTexCoord2fv GLScene.OpenGL4

deprecated;
glMultiTexCoord2fvARB GLScene.OpenGL4

glMultiTexCoord2i GLScene.OpenGL4

deprecated;
glMultiTexCoord2iARB GLScene.OpenGL4

glMultiTexCoord2iv GLScene.OpenGL4

deprecated;
glMultiTexCoord2ivARB GLScene.OpenGL4

glMultiTexCoord2s GLScene.OpenGL4

deprecated;
glMultiTexCoord2sARB GLScene.OpenGL4

glMultiTexCoord2sv GLScene.OpenGL4

deprecated;
glMultiTexCoord2svARB GLScene.OpenGL4

glMultiTexCoord3d GLScene.OpenGL4

deprecated;
glMultiTexCoord3dARB GLScene.OpenGL4

glMultiTexCoord3dv GLScene.OpenGL4

deprecated;
glMultiTexCoord3dvARB GLScene.OpenGL4

glMultiTexCoord3f GLScene.OpenGL4

deprecated;
glMultiTexCoord3fARB GLScene.OpenGL4

glMultiTexCoord3fv GLScene.OpenGL4

deprecated;
glMultiTexCoord3fvARB GLScene.OpenGL4

glMultiTexCoord3i GLScene.OpenGL4

deprecated;
glMultiTexCoord3iARB GLScene.OpenGL4

glMultiTexCoord3iv GLScene.OpenGL4

deprecated;
glMultiTexCoord3ivARB GLScene.OpenGL4

glMultiTexCoord3s GLScene.OpenGL4

deprecated;
glMultiTexCoord3sARB GLScene.OpenGL4

glMultiTexCoord3sv GLScene.OpenGL4

deprecated;
glMultiTexCoord3svARB GLScene.OpenGL4

glMultiTexCoord4d GLScene.OpenGL4

deprecated;
glMultiTexCoord4dARB GLScene.OpenGL4

glMultiTexCoord4dv GLScene.OpenGL4

deprecated;
glMultiTexCoord4dvARB GLScene.OpenGL4

glMultiTexCoord4f GLScene.OpenGL4

deprecated;
glMultiTexCoord4fARB GLScene.OpenGL4

glMultiTexCoord4fv GLScene.OpenGL4

deprecated;
glMultiTexCoord4fvARB GLScene.OpenGL4

glMultiTexCoord4i GLScene.OpenGL4

deprecated;
glMultiTexCoord4iARB GLScene.OpenGL4

glMultiTexCoord4iv GLScene.OpenGL4

deprecated;
glMultiTexCoord4ivARB GLScene.OpenGL4

glMultiTexCoord4s GLScene.OpenGL4

deprecated;
glMultiTexCoord4sARB GLScene.OpenGL4

glMultiTexCoord4sv GLScene.OpenGL4

deprecated;
glMultiTexCoord4svARB GLScene.OpenGL4

glMultiTexCoordP1ui GLScene.OpenGL4

glMultiTexCoordP1uiv GLScene.OpenGL4

glMultiTexCoordP2ui GLScene.OpenGL4

glMultiTexCoordP2uiv GLScene.OpenGL4

glMultiTexCoordP3ui GLScene.OpenGL4

glMultiTexCoordP3uiv GLScene.OpenGL4

glMultiTexCoordP4ui GLScene.OpenGL4

glMultiTexCoordP4uiv GLScene.OpenGL4

glMultTransposeMatrixd GLScene.OpenGL4

deprecated;
glMultTransposeMatrixdARB GLScene.OpenGL4

glMultTransposeMatrixf GLScene.OpenGL4

deprecated;
glMultTransposeMatrixfARB GLScene.OpenGL4

glNormalFormatNV GLScene.OpenGL4

glNormalP3ui GLScene.OpenGL4

glNormalP3uiv GLScene.OpenGL4

GLOpenGL GLS.InitOpenGL

glPatchParameterfv GLScene.OpenGL4

glPatchParameteri GLScene.OpenGL4

GL_ARB_tessellation_shader (ARB #91)
glPauseTransformFeedback GLScene.OpenGL4

glPointParameterf GLScene.OpenGL4

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)
glPointParameterfARB GLScene.OpenGL4

GL_ARB_point_parameter (ARB #14)
glPointParameterfv GLScene.OpenGL4

glPointParameterfvARB GLScene.OpenGL4

glPointParameteri GLScene.OpenGL4

glPointParameteriNV GLScene.OpenGL4

GL_NV_point_sprite (EXT #262)
glPointParameteriv GLScene.OpenGL4

glPointParameterivNV GLScene.OpenGL4

glPolygonOffsetEXT GLScene.OpenGL4

GL_EXT_polygon_offset (EXT #3)
glPrimitiveRestartIndex GLScene.OpenGL4

glPrimitiveRestartIndexNV GLScene.OpenGL4

glPrimitiveRestartNV GLScene.OpenGL4

GL_NV_primitive_restart (EXT #285)
glPrioritizeTexturesEXT GLScene.OpenGL4

glProgramEnvParameter4dARB GLScene.OpenGL4

glProgramEnvParameter4dvARB GLScene.OpenGL4

glProgramEnvParameter4fARB GLScene.OpenGL4

glProgramEnvParameter4fvARB GLScene.OpenGL4

glProgramEnvParameters4fvEXT GLScene.OpenGL4

GL_EXT_gpu_program_parameters (EXT #320)
glProgramLocalParameter4dARB GLScene.OpenGL4

glProgramLocalParameter4dvARB GLScene.OpenGL4

glProgramLocalParameter4fARB GLScene.OpenGL4

glProgramLocalParameter4fvARB GLScene.OpenGL4

glProgramLocalParameters4fvEXT GLScene.OpenGL4

glProgramParameter4dNV GLScene.OpenGL4

glProgramParameter4dvNV GLScene.OpenGL4

glProgramParameter4fNV GLScene.OpenGL4

glProgramParameter4fvNV GLScene.OpenGL4

glProgramParameteri GLScene.OpenGL4

glProgramParameteriARB GLScene.OpenGL4

GL_ARB_geometry_shader4 (ARB #47)
glProgramParameteriEXT GLScene.OpenGL4

GL_EXT_geometry_shader4 (EXT #324)
glProgramParameters4dvNV GLScene.OpenGL4

glProgramParameters4fvNV GLScene.OpenGL4

glProgramStringARB GLScene.OpenGL4

glProgramUniform1dEXT GLScene.OpenGL4

glProgramUniformXXX only valid if EXT_direct_state_access is available
glProgramUniform1dvEXT GLScene.OpenGL4

glProgramUniform2dEXT GLScene.OpenGL4

glProgramUniform2dvEXT GLScene.OpenGL4

glProgramUniform3dEXT GLScene.OpenGL4

glProgramUniform3dvEXT GLScene.OpenGL4

glProgramUniform4dEXT GLScene.OpenGL4

glProgramUniform4dvEXT GLScene.OpenGL4

glProgramUniformMatrix2dvEXT GLScene.OpenGL4

glProgramUniformMatrix2x3dvEXT GLScene.OpenGL4

glProgramUniformMatrix2x4dvEXT GLScene.OpenGL4

glProgramUniformMatrix3dvEXT GLScene.OpenGL4

glProgramUniformMatrix3x2dvEXT GLScene.OpenGL4

glProgramUniformMatrix3x4dvEXT GLScene.OpenGL4

glProgramUniformMatrix4dvEXT GLScene.OpenGL4

glProgramUniformMatrix4x2dvEXT GLScene.OpenGL4

glProgramUniformMatrix4x3dvEXT GLScene.OpenGL4

glProgramUniformui64NV GLScene.OpenGL4

glProgramUniformui64vNV GLScene.OpenGL4

glProgramVertexLimitNV GLScene.OpenGL4

GL_NV_geometry_program4 (EXT #323)
glProvokingVertex GLScene.OpenGL4

GL_ARB_provoking_vertex (ARB #64)
glQueryCounter GLScene.OpenGL4

GL_ARB_timer_query (ARB #85)
glRenderbufferStorage GLScene.OpenGL4

glRenderbufferStorageEXT GLScene.OpenGL4

glRenderbufferStorageMultisample GLScene.OpenGL4

glRenderbufferStorageMultisampleEXT GLScene.OpenGL4

GL_EXT_framebuffer_multisample (#317)
glRequestResidentProgramsNV GLScene.OpenGL4

glResetHistogram GLScene.OpenGL4

deprecated;
glResetMinmax GLScene.OpenGL4

deprecated;
glResizeBuffersMESA GLScene.OpenGL4

GL_MESA_resize_buffers (EXT #196)
glResumeTransformFeedback GLScene.OpenGL4

glSampleCoverage GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_multisample (#5)
glSampleCoverageARB GLScene.OpenGL4

GL_ARB_multisample (ARB #5)
glSampleMaskEXT GLScene.OpenGL4

GL_EXT_multisample (EXT #209)
glSampleMaski GLScene.OpenGL4

glSampleMaskSGIS GLScene.OpenGL4

GL_SGIS_multisample (EXT #25)
glSamplePassARB GLScene.OpenGL4

########################################################### function and procedure definitions for ARB approved extensions ########################################################### unknown ARB extension
glSamplePatternEXT GLScene.OpenGL4

glSamplePatternSGIS GLScene.OpenGL4

glSamplerParameterf GLScene.OpenGL4

glSamplerParameterfv GLScene.OpenGL4

glSamplerParameteri GLScene.OpenGL4

glSamplerParameterIiv GLScene.OpenGL4

glSamplerParameterIuiv GLScene.OpenGL4

glSamplerParameteriv GLScene.OpenGL4

glSecondaryColor3b GLScene.OpenGL4

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)
glSecondaryColor3bEXT GLScene.OpenGL4

GL_EXT_secondary_color (EXT #145)
glSecondaryColor3bv GLScene.OpenGL4

deprecated;
glSecondaryColor3bvEXT GLScene.OpenGL4

glSecondaryColor3d GLScene.OpenGL4

deprecated;
glSecondaryColor3dEXT GLScene.OpenGL4

glSecondaryColor3dv GLScene.OpenGL4

deprecated;
glSecondaryColor3dvEXT GLScene.OpenGL4

glSecondaryColor3f GLScene.OpenGL4

deprecated;
glSecondaryColor3fEXT GLScene.OpenGL4

glSecondaryColor3fv GLScene.OpenGL4

deprecated;
glSecondaryColor3fvEXT GLScene.OpenGL4

glSecondaryColor3i GLScene.OpenGL4

deprecated;
glSecondaryColor3iEXT GLScene.OpenGL4

glSecondaryColor3iv GLScene.OpenGL4

deprecated;
glSecondaryColor3ivEXT GLScene.OpenGL4

glSecondaryColor3s GLScene.OpenGL4

deprecated;
glSecondaryColor3sEXT GLScene.OpenGL4

glSecondaryColor3sv GLScene.OpenGL4

deprecated;
glSecondaryColor3svEXT GLScene.OpenGL4

glSecondaryColor3ub GLScene.OpenGL4

deprecated;
glSecondaryColor3ubEXT GLScene.OpenGL4

glSecondaryColor3ubv GLScene.OpenGL4

deprecated;
glSecondaryColor3ubvEXT GLScene.OpenGL4

glSecondaryColor3ui GLScene.OpenGL4

deprecated;
glSecondaryColor3uiEXT GLScene.OpenGL4

glSecondaryColor3uiv GLScene.OpenGL4

deprecated;
glSecondaryColor3uivEXT GLScene.OpenGL4

glSecondaryColor3us GLScene.OpenGL4

deprecated;
glSecondaryColor3usEXT GLScene.OpenGL4

glSecondaryColor3usv GLScene.OpenGL4

deprecated;
glSecondaryColor3usvEXT GLScene.OpenGL4

glSecondaryColorFormatNV GLScene.OpenGL4

glSecondaryColorP3ui GLScene.OpenGL4

glSecondaryColorP3uiv GLScene.OpenGL4

glSecondaryColorPointer GLScene.OpenGL4

deprecated;
glSecondaryColorPointerEXT GLScene.OpenGL4

glSeparableFilter2D GLScene.OpenGL4

deprecated;
glSetFenceNV GLScene.OpenGL4

glShaderSource GLScene.OpenGL4

glShaderSourceARB GLScene.OpenGL4

GLSkinEditorForm FmGuiSkinEditor

glStencilClearTagEXT GLScene.OpenGL4

GL_EXT_stencil_clear_tag (EXT #314)
glStencilFuncSeparate GLScene.OpenGL4

glStencilMaskSeparate GLScene.OpenGL4

glStencilOpSeparate GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)
glStringMarkerGREMEDY GLScene.OpenGL4

glTbufferMask3DFX GLScene.OpenGL4

GL_3DFX_tbuffer (EXT #208)
glTessellationFactorAMD GLScene.OpenGL4

GL_AMD_vertex_shader_tessellator (#363)
glTessellationModeAMD GLScene.OpenGL4

glTestFenceNV GLScene.OpenGL4

glTexBuffer GLScene.OpenGL4

glTexBufferARB GLScene.OpenGL4

GL_ARB_texture_buffer_object (ARB #51)
glTexBufferEXT GLScene.OpenGL4

GL_EXT_packed_float (#328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (#329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (#330)
glTexCoordFormatNV GLScene.OpenGL4

glTexCoordP1ui GLScene.OpenGL4

glTexCoordP1uiv GLScene.OpenGL4

glTexCoordP2ui GLScene.OpenGL4

glTexCoordP2uiv GLScene.OpenGL4

glTexCoordP3ui GLScene.OpenGL4

glTexCoordP3uiv GLScene.OpenGL4

glTexCoordP4ui GLScene.OpenGL4

glTexCoordP4uiv GLScene.OpenGL4

glTexImage2DMultisample GLScene.OpenGL4

GL_ARB_texture_multisample (ARB #67)
glTexImage3D GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_texture3D (#6)
glTexImage3DEXT GLScene.OpenGL4

GL_EXT_texture3D (EXT #6)
glTexImage3DMultisample GLScene.OpenGL4

glTexParameterIiv GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_texture_integer glClearColorIi: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glClearColorIui: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF}
glTexParameterIivEXT GLScene.OpenGL4

glTexParameterIuiv GLScene.OpenGL4

glTexParameterIuivEXT GLScene.OpenGL4

glTexSubImage1DEXT GLScene.OpenGL4

GL_EXT_subtexture (EXT #9)
glTexSubImage2DEXT GLScene.OpenGL4

glTexSubImage3D GLScene.OpenGL4

glTexSubImage3DEXT GLScene.OpenGL4

glTextureColorMaskSGIS GLScene.OpenGL4

GL_SGIS_texture_color_mask (EXT #214)
glTFUseEmbeddedColors GLS.FileGLTF

glTrackMatrixNV GLScene.OpenGL4

glTransformFeedbackAttribsNV GLScene.OpenGL4

glTransformFeedbackVaryings GLScene.OpenGL4

glTransformFeedbackVaryingsEXT GLScene.OpenGL4

glTransformFeedbackVaryingsNV GLScene.OpenGL4

gluDeleteNurbsTessellatorEXT GLScene.OpenGL4

gluNewNurbsTessellatorEXT GLScene.OpenGL4

glUniform1d GLScene.OpenGL4

GL_ARB_gpu_shader_fp64 (ARB #89)
glUniform1dv GLScene.OpenGL4

glUniform1f GLScene.OpenGL4

glUniform1fARB GLScene.OpenGL4

glUniform1fv GLScene.OpenGL4

glUniform1fvARB GLScene.OpenGL4

glUniform1i GLScene.OpenGL4

glUniform1iARB GLScene.OpenGL4

glUniform1iv GLScene.OpenGL4

glUniform1ivARB GLScene.OpenGL4

glUniform1ui GLScene.OpenGL4

glUniform1uiEXT GLScene.OpenGL4

glUniform1uiv GLScene.OpenGL4

glUniform1uivEXT GLScene.OpenGL4

glUniform2d GLScene.OpenGL4

glUniform2dv GLScene.OpenGL4

glUniform2f GLScene.OpenGL4

glUniform2fARB GLScene.OpenGL4

glUniform2fv GLScene.OpenGL4

glUniform2fvARB GLScene.OpenGL4

glUniform2i GLScene.OpenGL4

glUniform2iARB GLScene.OpenGL4

glUniform2iv GLScene.OpenGL4

glUniform2ivARB GLScene.OpenGL4

glUniform2ui GLScene.OpenGL4

glUniform2uiEXT GLScene.OpenGL4

glUniform2uiv GLScene.OpenGL4

glUniform2uivEXT GLScene.OpenGL4

glUniform3d GLScene.OpenGL4

glUniform3dv GLScene.OpenGL4

glUniform3f GLScene.OpenGL4

glUniform3fARB GLScene.OpenGL4

glUniform3fv GLScene.OpenGL4

glUniform3fvARB GLScene.OpenGL4

glUniform3i GLScene.OpenGL4

glUniform3iARB GLScene.OpenGL4

glUniform3iv GLScene.OpenGL4

glUniform3ivARB GLScene.OpenGL4

glUniform3ui GLScene.OpenGL4

glUniform3uiEXT GLScene.OpenGL4

glUniform3uiv GLScene.OpenGL4

glUniform3uivEXT GLScene.OpenGL4

glUniform4d GLScene.OpenGL4

glUniform4dv GLScene.OpenGL4

glUniform4f GLScene.OpenGL4

glUniform4fARB GLScene.OpenGL4

glUniform4fv GLScene.OpenGL4

glUniform4fvARB GLScene.OpenGL4

glUniform4i GLScene.OpenGL4

glUniform4iARB GLScene.OpenGL4

glUniform4iv GLScene.OpenGL4

glUniform4ivARB GLScene.OpenGL4

glUniform4ui GLScene.OpenGL4

glUniform4uiEXT GLScene.OpenGL4

glUniform4uiv GLScene.OpenGL4

glUniform4uivEXT GLScene.OpenGL4

glUniformBlockBinding GLScene.OpenGL4

glUniformBufferEXT GLScene.OpenGL4

GL_EXT_bindable_uniform (#342)
glUniformMatrix2dv GLScene.OpenGL4

glUniformMatrix2fv GLScene.OpenGL4

glUniformMatrix2fvARB GLScene.OpenGL4

glUniformMatrix2x3dv GLScene.OpenGL4

glUniformMatrix2x3fv GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 2.1 Core ###########################################################
glUniformMatrix2x4dv GLScene.OpenGL4

glUniformMatrix2x4fv GLScene.OpenGL4

glUniformMatrix3dv GLScene.OpenGL4

glUniformMatrix3fv GLScene.OpenGL4

glUniformMatrix3fvARB GLScene.OpenGL4

glUniformMatrix3x2dv GLScene.OpenGL4

glUniformMatrix3x2fv GLScene.OpenGL4

glUniformMatrix3x4dv GLScene.OpenGL4

glUniformMatrix3x4fv GLScene.OpenGL4

glUniformMatrix4dv GLScene.OpenGL4

glUniformMatrix4fv GLScene.OpenGL4

glUniformMatrix4fvARB GLScene.OpenGL4

glUniformMatrix4x2dv GLScene.OpenGL4

glUniformMatrix4x2fv GLScene.OpenGL4

glUniformMatrix4x3dv GLScene.OpenGL4

glUniformMatrix4x3fv GLScene.OpenGL4

glUniformSubroutinesuiv GLScene.OpenGL4

glUniformui64NV GLScene.OpenGL4

glUniformui64vNV GLScene.OpenGL4

glUnlockArraysEXT GLScene.OpenGL4

glUnmapBuffer GLScene.OpenGL4

glUnmapBufferARB GLScene.OpenGL4

gluNurbsCallbackDataEXT GLScene.OpenGL4

GL_ARB_draw_indirect (ARB #87) GL_ARB_gpu_shader5 (ARB #88) (none) GL_ARB_gpu_shader_fp64 (ARB #89) GL_ARB_shader_subroutine (ARB #90) GL_ARB_tessellation_shader (ARB #91) GL_ARB_texture_buffer_object_rgb32 (ARB #92) (none) GL_ARB_transform_feedback2 (ARB #93) GL_ARB_transform_feedback3 (ARB #94) GL_VERSION_4_1 ########################################################### function and procedure definitions for GLU extensions ########################################################### GLU extensions
glUseProgram GLScene.OpenGL4

glUseProgramObjectARB GLScene.OpenGL4

GLU_VERSION_1_3 GLScene.OpenGL4

glValidateProgram GLScene.OpenGL4

glValidateProgramARB GLScene.OpenGL4

glVertexArrayRangeNV GLScene.OpenGL4

glVertexAttrib1d GLScene.OpenGL4

glVertexAttrib1dARB GLScene.OpenGL4

GL_ARB_vertex_program (ARB #26)
glVertexAttrib1dNV GLScene.OpenGL4

glVertexAttrib1dv GLScene.OpenGL4

glVertexAttrib1dvARB GLScene.OpenGL4

glVertexAttrib1dvNV GLScene.OpenGL4

glVertexAttrib1f GLScene.OpenGL4

glVertexAttrib1fARB GLScene.OpenGL4

glVertexAttrib1fNV GLScene.OpenGL4

glVertexAttrib1fv GLScene.OpenGL4

glVertexAttrib1fvARB GLScene.OpenGL4

glVertexAttrib1fvNV GLScene.OpenGL4

glVertexAttrib1s GLScene.OpenGL4

glVertexAttrib1sARB GLScene.OpenGL4

glVertexAttrib1sNV GLScene.OpenGL4

glVertexAttrib1sv GLScene.OpenGL4

glVertexAttrib1svARB GLScene.OpenGL4

glVertexAttrib1svNV GLScene.OpenGL4

glVertexAttrib2d GLScene.OpenGL4

glVertexAttrib2dARB GLScene.OpenGL4

glVertexAttrib2dNV GLScene.OpenGL4

glVertexAttrib2dv GLScene.OpenGL4

glVertexAttrib2dvARB GLScene.OpenGL4

glVertexAttrib2dvNV GLScene.OpenGL4

glVertexAttrib2f GLScene.OpenGL4

glVertexAttrib2fARB GLScene.OpenGL4

glVertexAttrib2fNV GLScene.OpenGL4

glVertexAttrib2fv GLScene.OpenGL4

glVertexAttrib2fvARB GLScene.OpenGL4

glVertexAttrib2fvNV GLScene.OpenGL4

glVertexAttrib2s GLScene.OpenGL4

glVertexAttrib2sARB GLScene.OpenGL4

glVertexAttrib2sNV GLScene.OpenGL4

glVertexAttrib2sv GLScene.OpenGL4

glVertexAttrib2svARB GLScene.OpenGL4

glVertexAttrib2svNV GLScene.OpenGL4

glVertexAttrib3d GLScene.OpenGL4

glVertexAttrib3dARB GLScene.OpenGL4

glVertexAttrib3dNV GLScene.OpenGL4

glVertexAttrib3dv GLScene.OpenGL4

glVertexAttrib3dvARB GLScene.OpenGL4

glVertexAttrib3dvNV GLScene.OpenGL4

glVertexAttrib3f GLScene.OpenGL4

glVertexAttrib3fARB GLScene.OpenGL4

glVertexAttrib3fNV GLScene.OpenGL4

glVertexAttrib3fv GLScene.OpenGL4

glVertexAttrib3fvARB GLScene.OpenGL4

glVertexAttrib3fvNV GLScene.OpenGL4

glVertexAttrib3s GLScene.OpenGL4

glVertexAttrib3sARB GLScene.OpenGL4

glVertexAttrib3sNV GLScene.OpenGL4

glVertexAttrib3sv GLScene.OpenGL4

glVertexAttrib3svARB GLScene.OpenGL4

glVertexAttrib3svNV GLScene.OpenGL4

glVertexAttrib4bv GLScene.OpenGL4

glVertexAttrib4bvARB GLScene.OpenGL4

glVertexAttrib4d GLScene.OpenGL4

glVertexAttrib4dARB GLScene.OpenGL4

glVertexAttrib4dNV GLScene.OpenGL4

glVertexAttrib4dv GLScene.OpenGL4

glVertexAttrib4dvARB GLScene.OpenGL4

glVertexAttrib4dvNV GLScene.OpenGL4

glVertexAttrib4f GLScene.OpenGL4

glVertexAttrib4fARB GLScene.OpenGL4

glVertexAttrib4fNV GLScene.OpenGL4

glVertexAttrib4fv GLScene.OpenGL4

glVertexAttrib4fvARB GLScene.OpenGL4

glVertexAttrib4fvNV GLScene.OpenGL4

glVertexAttrib4iv GLScene.OpenGL4

glVertexAttrib4ivARB GLScene.OpenGL4

glVertexAttrib4Nbv GLScene.OpenGL4

glVertexAttrib4NbvARB GLScene.OpenGL4

glVertexAttrib4Niv GLScene.OpenGL4

glVertexAttrib4NivARB GLScene.OpenGL4

glVertexAttrib4Nsv GLScene.OpenGL4

glVertexAttrib4NsvARB GLScene.OpenGL4

glVertexAttrib4Nub GLScene.OpenGL4

glVertexAttrib4NubARB GLScene.OpenGL4

glVertexAttrib4Nubv GLScene.OpenGL4

glVertexAttrib4NubvARB GLScene.OpenGL4

glVertexAttrib4Nuiv GLScene.OpenGL4

glVertexAttrib4NuivARB GLScene.OpenGL4

glVertexAttrib4Nusv GLScene.OpenGL4

glVertexAttrib4NusvARB GLScene.OpenGL4

glVertexAttrib4s GLScene.OpenGL4

glVertexAttrib4sARB GLScene.OpenGL4

glVertexAttrib4sNV GLScene.OpenGL4

glVertexAttrib4sv GLScene.OpenGL4

glVertexAttrib4svARB GLScene.OpenGL4

glVertexAttrib4svNV GLScene.OpenGL4

glVertexAttrib4ubv GLScene.OpenGL4

glVertexAttrib4ubvARB GLScene.OpenGL4

glVertexAttrib4ubvNV GLScene.OpenGL4

glVertexAttrib4uiv GLScene.OpenGL4

glVertexAttrib4uivARB GLScene.OpenGL4

glVertexAttrib4usv GLScene.OpenGL4

glVertexAttrib4usvARB GLScene.OpenGL4

glVertexAttribDivisorARB GLScene.OpenGL4

GL_ARB_instanced_arrays (ARB #49)
glVertexAttribFormatNV GLScene.OpenGL4

glVertexAttribI1i GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.0 Core ###########################################################
glVertexAttribI1iEXT GLScene.OpenGL4

GL_EXT_gpu_shader4 (EXT #326)
glVertexAttribI1iv GLScene.OpenGL4

glVertexAttribI1ivEXT GLScene.OpenGL4

glVertexAttribI1ui GLScene.OpenGL4

glVertexAttribI1uiEXT GLScene.OpenGL4

glVertexAttribI1uiv GLScene.OpenGL4

glVertexAttribI1uivEXT GLScene.OpenGL4

glVertexAttribI2i GLScene.OpenGL4

glVertexAttribI2iEXT GLScene.OpenGL4

glVertexAttribI2iv GLScene.OpenGL4

glVertexAttribI2ivEXT GLScene.OpenGL4

glVertexAttribI2ui GLScene.OpenGL4

glVertexAttribI2uiEXT GLScene.OpenGL4

glVertexAttribI2uiv GLScene.OpenGL4

glVertexAttribI2uivEXT GLScene.OpenGL4

glVertexAttribI3i GLScene.OpenGL4

glVertexAttribI3iEXT GLScene.OpenGL4

glVertexAttribI3iv GLScene.OpenGL4

glVertexAttribI3ivEXT GLScene.OpenGL4

glVertexAttribI3ui GLScene.OpenGL4

glVertexAttribI3uiEXT GLScene.OpenGL4

glVertexAttribI3uiv GLScene.OpenGL4

glVertexAttribI3uivEXT GLScene.OpenGL4

glVertexAttribI4bv GLScene.OpenGL4

glVertexAttribI4bvEXT GLScene.OpenGL4

glVertexAttribI4i GLScene.OpenGL4

glVertexAttribI4iEXT GLScene.OpenGL4

glVertexAttribI4iv GLScene.OpenGL4

glVertexAttribI4ivEXT GLScene.OpenGL4

glVertexAttribI4sv GLScene.OpenGL4

glVertexAttribI4svEXT GLScene.OpenGL4

glVertexAttribI4ubv GLScene.OpenGL4

glVertexAttribI4ubvEXT GLScene.OpenGL4

glVertexAttribI4ui GLScene.OpenGL4

glVertexAttribI4uiEXT GLScene.OpenGL4

glVertexAttribI4uiv GLScene.OpenGL4

glVertexAttribI4uivEXT GLScene.OpenGL4

glVertexAttribI4usv GLScene.OpenGL4

glVertexAttribI4usvEXT GLScene.OpenGL4

glVertexAttribIFormatNV GLScene.OpenGL4

glVertexAttribIPointer GLScene.OpenGL4

glVertexAttribIPointerEXT GLScene.OpenGL4

glVertexAttribP1ui GLScene.OpenGL4

glVertexAttribP1uiv GLScene.OpenGL4

glVertexAttribP2ui GLScene.OpenGL4

glVertexAttribP2uiv GLScene.OpenGL4

glVertexAttribP3ui GLScene.OpenGL4

glVertexAttribP3uiv GLScene.OpenGL4

glVertexAttribP4ui GLScene.OpenGL4

glVertexAttribP4uiv GLScene.OpenGL4

glVertexAttribPointer GLScene.OpenGL4

glVertexAttribPointerARB GLScene.OpenGL4

glVertexAttribPointerNV GLScene.OpenGL4

glVertexAttribs1dvNV GLScene.OpenGL4

glVertexAttribs1fvNV GLScene.OpenGL4

glVertexAttribs1svNV GLScene.OpenGL4

glVertexAttribs2dvNV GLScene.OpenGL4

glVertexAttribs2fvNV GLScene.OpenGL4

glVertexAttribs2svNV GLScene.OpenGL4

glVertexAttribs3dvNV GLScene.OpenGL4

glVertexAttribs3fvNV GLScene.OpenGL4

glVertexAttribs3svNV GLScene.OpenGL4

glVertexAttribs4dvNV GLScene.OpenGL4

glVertexAttribs4fvNV GLScene.OpenGL4

glVertexAttribs4svNV GLScene.OpenGL4

glVertexAttribs4ubvNV GLScene.OpenGL4

glVertexBlendARB GLScene.OpenGL4

glVertexFormatNV GLScene.OpenGL4

glVertexP2ui GLScene.OpenGL4

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)
glVertexP2uiv GLScene.OpenGL4

glVertexP3ui GLScene.OpenGL4

glVertexP3uiv GLScene.OpenGL4

glVertexP4ui GLScene.OpenGL4

glVertexP4uiv GLScene.OpenGL4

glWaitSync GLScene.OpenGL4

glWeightbvARB GLScene.OpenGL4

GL_ARB_vertex_blend (ARB #15) {deprecated?}
glWeightdvARB GLScene.OpenGL4

glWeightfvARB GLScene.OpenGL4

glWeightivARB GLScene.OpenGL4

glWeightPointerARB GLScene.OpenGL4

glWeightsvARB GLScene.OpenGL4

glWeightubvARB GLScene.OpenGL4

glWeightuivARB GLScene.OpenGL4

glWeightusvARB GLScene.OpenGL4

glWindowPos2d GLScene.OpenGL4

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)
glWindowPos2dARB GLScene.OpenGL4

GL_ARB_window_pos (ARB #25)
glWindowPos2dv GLScene.OpenGL4

deprecated;
glWindowPos2dvARB GLScene.OpenGL4

glWindowPos2f GLScene.OpenGL4

deprecated;
glWindowPos2fARB GLScene.OpenGL4

glWindowPos2fv GLScene.OpenGL4

deprecated;
glWindowPos2fvARB GLScene.OpenGL4

glWindowPos2i GLScene.OpenGL4

deprecated;
glWindowPos2iARB GLScene.OpenGL4

glWindowPos2iv GLScene.OpenGL4

deprecated;
glWindowPos2ivARB GLScene.OpenGL4

glWindowPos2s GLScene.OpenGL4

deprecated;
glWindowPos2sARB GLScene.OpenGL4

glWindowPos2sv GLScene.OpenGL4

deprecated;
glWindowPos2svARB GLScene.OpenGL4

glWindowPos3d GLScene.OpenGL4

deprecated;
glWindowPos3dARB GLScene.OpenGL4

glWindowPos3dv GLScene.OpenGL4

deprecated;
glWindowPos3dvARB GLScene.OpenGL4

glWindowPos3f GLScene.OpenGL4

deprecated;
glWindowPos3fARB GLScene.OpenGL4

glWindowPos3fv GLScene.OpenGL4

deprecated;
glWindowPos3fvARB GLScene.OpenGL4

glWindowPos3i GLScene.OpenGL4

deprecated;
glWindowPos3iARB GLScene.OpenGL4

glWindowPos3iv GLScene.OpenGL4

deprecated;
glWindowPos3ivARB GLScene.OpenGL4

glWindowPos3s GLScene.OpenGL4

deprecated;
glWindowPos3sARB GLScene.OpenGL4

glWindowPos3sv GLScene.OpenGL4

deprecated;
glWindowPos3svARB GLScene.OpenGL4

GLwithoutContext GLS.Context

GLX_ARB_context_flush_control GLScene.OpenGL4

GLX
GLX_ARB_create_context GLScene.OpenGL4

GLX
GLX_ARB_create_context_profile GLScene.OpenGL4

GLX
GLX_ARB_create_context_robustness GLScene.OpenGL4

GLX
GLX_ARB_fbconfig_float GLScene.OpenGL4

GLX
GLX_ARB_framebuffer_sRGB GLScene.OpenGL4

GLX
GLX_ARB_get_proc_address GLScene.OpenGL4

GLX
GLX_ARB_multisample GLScene.OpenGL4

GLX
GLX_ARB_vertex_buffer_object GLScene.OpenGL4

GLX
GLX_EXT_create_context_es2_profile GLScene.OpenGL4

GLX
GLX_EXT_fbconfig_packed_float GLScene.OpenGL4

GLX
GLX_EXT_framebuffer_sRGB GLScene.OpenGL4

GLX
GLX_EXT_import_context GLScene.OpenGL4

GLX
GLX_EXT_swap_control GLScene.OpenGL4

GLX
GLX_EXT_texture_from_pixmap GLScene.OpenGL4

GLX
GLX_EXT_visual_info GLScene.OpenGL4

GLX
GLX_EXT_visual_rating GLScene.OpenGL4

GLX
GLX_VERSION_1_4 GLScene.OpenGL4

GLX
GL_3DFX_multisample GLScene.OpenGL4

GL_3DFX_tbuffer GLScene.OpenGL4

GL_3DFX_texture_compression_FXT1 GLScene.OpenGL4

GL_AMD_conservative_depth GLScene.OpenGL4

GL 4.6
GL_AMD_debug_output GLScene.OpenGL4

GL 4.6
GL_AMD_depth_clamp_separate GLScene.OpenGL4

GL 4.6
GL_AMD_draw_buffers_blend GLScene.OpenGL4

GL 4.6
GL_AMD_name_gen_delete GLScene.OpenGL4

GL 4.6
GL_AMD_performance_monitor GLScene.OpenGL4

GL 4.6
GL_AMD_pinned_memory GLScene.OpenGL4

GL 4.3
GL_AMD_query_buffer_object GLScene.OpenGL4

GL 4.3
GL_AMD_seamless_cubemap_per_texture GLScene.OpenGL4

GL 4.6
GL_AMD_shader_stencil_export GLScene.OpenGL4

GL 4.6
GL_AMD_stencil_operation_extended GLScene.OpenGL4

GL 4.3
GL_AMD_texture_texture4 GLScene.OpenGL4

GL 4.6
GL_AMD_transform_feedback3_lines_triangles GLScene.OpenGL4

GL 4.6
GL_AMD_vertex_shader_layer GLScene.OpenGL4

GL 4.3
GL_AMD_vertex_shader_tesselator GLScene.OpenGL4

GL 4.6
GL_AMD_vertex_shader_viewport_index GLScene.OpenGL4

GL 4.3
GL_APPLE_aux_depth_stencil GLScene.OpenGL4

GL_APPLE_client_storage GLScene.OpenGL4

GL_APPLE_element_array GLScene.OpenGL4

GL_APPLE_fence GLScene.OpenGL4

GL_APPLE_float_pixels GLScene.OpenGL4

GL_APPLE_object_purgeable GLScene.OpenGL4

GL_APPLE_rgb_422 GLScene.OpenGL4

GL_APPLE_row_bytes GLScene.OpenGL4

GL_APPLE_specular_vector GLScene.OpenGL4

GL_APPLE_texture_range GLScene.OpenGL4

GL_APPLE_transform_hint GLScene.OpenGL4

GL_APPLE_vertex_array_object GLScene.OpenGL4

GL_APPLE_vertex_array_range GLScene.OpenGL4

GL_APPLE_vertex_program_evaluators GLScene.OpenGL4

GL_APPLE_ycbcr_422 GLScene.OpenGL4

GL_ARB_arrays_of_arrays GLScene.OpenGL4

GL 4.3
GL_ARB_base_instance GLScene.OpenGL4

GL 4.2
GL_ARB_bindless_texture GLScene.OpenGL4

GL 4.4
GL_ARB_blend_func_extended GLScene.OpenGL4

GL_ARB_buffer_storage GLScene.OpenGL4

GL 4.4
GL_ARB_clear_buffer_object GLScene.OpenGL4

GL 4.3
GL_ARB_clear_texture GLScene.OpenGL4

GL 4.4
GL_ARB_clip_control GLScene.OpenGL4

GL 4.5
GL_ARB_cl_event GLScene.OpenGL4

GL 4.6
GL_ARB_color_buffer_float GLScene.OpenGL4

GL_ARB_compatibility GLScene.OpenGL4

GL_ARB_compressed_texture_pixel_storage GLScene.OpenGL4

GL 4.2
GL_ARB_compute_shader GLScene.OpenGL4

GL 4.3
GL_ARB_compute_variable_group_size GLScene.OpenGL4

GL 4.6
GL_ARB_conditional_render_inverted GLScene.OpenGL4

GL 4.5
GL_ARB_conservative_depth GLScene.OpenGL4

GL 4.2
GL_ARB_copy_buffer GLScene.OpenGL4

GL_ARB_copy_image GLScene.OpenGL4

GL 4.3
GL_ARB_cull_distance GLScene.OpenGL4

GL 4.5
GL_ARB_debug_output GLScene.OpenGL4

GL 4.6
GL_ARB_depth_buffer_float GLScene.OpenGL4

GL_ARB_depth_clamp GLScene.OpenGL4

GL_ARB_depth_texture GLScene.OpenGL4

GL_ARB_derivative_control GLScene.OpenGL4

GL 4.5
GL_ARB_direct_state_access GLScene.OpenGL4

GL 4.5
GL_ARB_draw_buffers GLScene.OpenGL4

GL_ARB_draw_buffers_blend GLScene.OpenGL4

GL_ARB_draw_elements_base_vertex GLScene.OpenGL4

GL_ARB_draw_indirect GLScene.OpenGL4

GL_ARB_draw_instanced GLScene.OpenGL4

GL_ARB_enhanced_layouts GLScene.OpenGL4

GL 4.4
GL_ARB_ES2_compatibility GLScene.OpenGL4

GL_ARB_ES3_1_compatibility GLScene.OpenGL4

GL 4.5
GL_ARB_ES3_2_compatibility GLScene.OpenGL4

GL_ARB_ES3_compatibility GLScene.OpenGL4

GL 4.3
GL_ARB_explicit_attrib_location GLScene.OpenGL4

GL_ARB_explicit_uniform_location GLScene.OpenGL4

GL 4.3
GL_ARB_fragment_coord_conventions GLScene.OpenGL4

GL_ARB_fragment_layer_viewport GLScene.OpenGL4

GL 4.3
GL_ARB_fragment_program GLScene.OpenGL4

GL_ARB_fragment_program_shadow GLScene.OpenGL4

GL_ARB_fragment_shader GLScene.OpenGL4

GL_ARB_fragment_shader_interlock GLScene.OpenGL4

GL_ARB_framebuffer_no_attachments GLScene.OpenGL4

GL 4.3
GL_ARB_framebuffer_object GLScene.OpenGL4

GL_ARB_framebuffer_sRGB GLScene.OpenGL4

GL_ARB_geometry_shader4 GLScene.OpenGL4

GL_ARB_get_program_binary GLScene.OpenGL4

GL_ARB_get_texture_sub_image GLScene.OpenGL4

GL 4.5
GL_ARB_gl_spirv GLScene.OpenGL4

GL 4.6
GL_ARB_gpu_shader5 GLScene.OpenGL4

GL_ARB_gpu_shader_fp64 GLScene.OpenGL4

GL_ARB_gpu_shader_int64 GLScene.OpenGL4

GL_ARB_half_float_pixel GLScene.OpenGL4

GL_ARB_half_float_vertex GLScene.OpenGL4

GL_ARB_imaging GLScene.OpenGL4

GL_ARB_indirect_parameters GLScene.OpenGL4

GL 4.6
GL_ARB_instanced_arrays GLScene.OpenGL4

GL_ARB_internalformat_query GLScene.OpenGL4

GL 4.2
GL_ARB_internalformat_query2 GLScene.OpenGL4

GL 4.3
GL_ARB_invalidate_subdata GLScene.OpenGL4

GL 4.3
GL_ARB_map_buffer_alignment GLScene.OpenGL4

GL 4.2
GL_ARB_map_buffer_range GLScene.OpenGL4

GL_ARB_matrix_palette GLScene.OpenGL4

GL_ARB_multisample GLScene.OpenGL4

GL_ARB_multitexture GLScene.OpenGL4

GL_ARB_multi_bind GLScene.OpenGL4

GL 4.4
GL_ARB_multi_draw_indirect GLScene.OpenGL4

GL 4.3
GL_ARB_occlusion_query GLScene.OpenGL4

GL_ARB_occlusion_query2 GLScene.OpenGL4

GL_ARB_parallel_shader_compile GLScene.OpenGL4

GL_ARB_pipeline_statistics_query GLScene.OpenGL4

GL 4.6
GL_ARB_pixel_buffer_object GLScene.OpenGL4

GL_ARB_point_parameters GLScene.OpenGL4

GL_ARB_point_sprite GLScene.OpenGL4

GL_ARB_polygon_offset_clamp GLScene.OpenGL4

GL 4.6
GL_ARB_post_depth_coverage GLScene.OpenGL4

GL_ARB_program_interface_query GLScene.OpenGL4

GL 4.3
GL_ARB_provoking_vertex GLScene.OpenGL4

GL_ARB_query_buffer_object GLScene.OpenGL4

GL 4.4
GL_ARB_robustness GLScene.OpenGL4

GL 4.6
GL_ARB_robust_buffer_access_behavior GLScene.OpenGL4

GL 4.3
GL_ARB_sampler_objects GLScene.OpenGL4

GL_ARB_sample_locations GLScene.OpenGL4

GL_ARB_sample_shading GLScene.OpenGL4

GL_ARB_seamless_cube_map GLScene.OpenGL4

GL_ARB_separate_shader_objects GLScene.OpenGL4

GL_ARB_shader_atomic_counters GLScene.OpenGL4

GL 4.2
GL_ARB_shader_atomic_counter_ops GLScene.OpenGL4

GL 4.6
GL_ARB_shader_ballot GLScene.OpenGL4

GL_ARB_shader_bit_encoding GLScene.OpenGL4

GL_ARB_shader_clock GLScene.OpenGL4

GL_ARB_shader_draw_parameters GLScene.OpenGL4

GL 4.6
GL_ARB_shader_group_vote GLScene.OpenGL4

GL 4.6
GL_ARB_shader_image_load_store GLScene.OpenGL4

GL 4.2
GL_ARB_shader_image_size GLScene.OpenGL4

GL 4.3
GL_ARB_shader_objects GLScene.OpenGL4

GL_ARB_shader_precision GLScene.OpenGL4

GL_ARB_shader_stencil_export GLScene.OpenGL4

GL 4.6
GL_ARB_shader_storage_buffer_object GLScene.OpenGL4

GL 4.3
GL_ARB_shader_subroutine GLScene.OpenGL4

GL_ARB_shader_texture_image_samples GLScene.OpenGL4

GL 4.5
GL_ARB_shader_texture_lod GLScene.OpenGL4

GL_ARB_shader_viewport_layer_array GLScene.OpenGL4

GL_ARB_shading_language_100 GLScene.OpenGL4

GL_ARB_shading_language_420pack GLScene.OpenGL4

GL 4.2
GL_ARB_shading_language_include GLScene.OpenGL4

GL_ARB_shading_language_packing GLScene.OpenGL4

GL 4.2
GL_ARB_shadow GLScene.OpenGL4

GL_ARB_shadow_ambient GLScene.OpenGL4

GL_ARB_sparse_texture GLScene.OpenGL4

GL 4.4
GL_ARB_sparse_texture2 GLScene.OpenGL4

GL_ARB_sparse_texture_clamp GLScene.OpenGL4

GL_ARB_spirv_extensions GLScene.OpenGL4

GL 4.6
GL_ARB_stencil_texturing GLScene.OpenGL4

GL 4.3
GL_ARB_sync GLScene.OpenGL4

GL_ARB_tessellation_shader GLScene.OpenGL4

GL_ARB_texture_barrier GLScene.OpenGL4

GL 4.5
GL_ARB_texture_border_clamp GLScene.OpenGL4

GL_ARB_texture_buffer_object GLScene.OpenGL4

GL_ARB_texture_buffer_object_rgb32 GLScene.OpenGL4

GL_ARB_texture_buffer_range GLScene.OpenGL4

GL 4.3
GL_ARB_texture_compression GLScene.OpenGL4

GL_ARB_texture_compression_bptc GLScene.OpenGL4

GL_ARB_texture_compression_rgtc GLScene.OpenGL4

GL_ARB_texture_cube_map GLScene.OpenGL4

GL_ARB_texture_cube_map_array GLScene.OpenGL4

GL_ARB_texture_env_add GLScene.OpenGL4

GL_ARB_texture_env_combine GLScene.OpenGL4

GL_ARB_texture_env_crossbar GLScene.OpenGL4

GL_ARB_texture_env_dot3 GLScene.OpenGL4

GL_ARB_texture_filter_anisotropic GLScene.OpenGL4

GL 4.6
GL_ARB_texture_filter_minmax GLScene.OpenGL4

GL_ARB_texture_float GLScene.OpenGL4

GL_ARB_texture_gather GLScene.OpenGL4

GL_ARB_texture_mirrored_repeat GLScene.OpenGL4

GL_ARB_texture_mirror_clamp_to_edge GLScene.OpenGL4

GL 4.4
GL_ARB_texture_multisample GLScene.OpenGL4

GL_ARB_texture_non_power_of_two GLScene.OpenGL4

GL_ARB_texture_query_levels GLScene.OpenGL4

GL 4.3
GL_ARB_texture_query_lod GLScene.OpenGL4

GL_ARB_texture_rectangle GLScene.OpenGL4

GL_ARB_texture_rg GLScene.OpenGL4

GL_ARB_texture_rgb10_a2ui GLScene.OpenGL4

GL_ARB_texture_stencil8 GLScene.OpenGL4

GL 4.4
GL_ARB_texture_storage GLScene.OpenGL4

GL 4.2
GL_ARB_texture_storage_multisample GLScene.OpenGL4

GL 4.3
GL_ARB_texture_swizzle GLScene.OpenGL4

GL_ARB_texture_view GLScene.OpenGL4

GL 4.3
GL_ARB_timer_query GLScene.OpenGL4

GL_ARB_transform_feedback2 GLScene.OpenGL4

GL_ARB_transform_feedback3 GLScene.OpenGL4

GL_ARB_transform_feedback_instanced GLScene.OpenGL4

GL 4.2
GL_ARB_transform_feedback_overflow_query GLScene.OpenGL4

GL 4.6
GL_ARB_transpose_matrix GLScene.OpenGL4

GL_ARB_uniform_buffer_object GLScene.OpenGL4

GL_ARB_vertex_array_bgra GLScene.OpenGL4

GL_ARB_vertex_array_object GLScene.OpenGL4

GL_ARB_vertex_attrib_64bit GLScene.OpenGL4

GL_ARB_vertex_attrib_binding GLScene.OpenGL4

GL 4.3
GL_ARB_vertex_blend GLScene.OpenGL4

GL_ARB_vertex_buffer_object GLScene.OpenGL4

GL_ARB_vertex_program GLScene.OpenGL4

GL_ARB_vertex_shader GLScene.OpenGL4

GL_ARB_vertex_type_10f_11f_11f_rev GLScene.OpenGL4

GL 4.4
GL_ARB_vertex_type_2_10_10_10_rev GLScene.OpenGL4

GL_ARB_viewport_array GLScene.OpenGL4

GL_ARB_window_pos GLScene.OpenGL4

GL_ATI_draw_buffers GLScene.OpenGL4

GL 4.6
GL_ATI_element_array GLScene.OpenGL4

GL 4.6
GL_ATI_envmap_bumpmap GLScene.OpenGL4

GL 4.6
GL_ATI_fragment_shader GLScene.OpenGL4

GL 4.6
GL_ATI_map_object_buffer GLScene.OpenGL4

GL 4.6
GL_ATI_meminfo GLScene.OpenGL4

GL 4.6
GL_ATI_pn_triangles GLScene.OpenGL4

GL 4.6
GL_ATI_separate_stencil GLScene.OpenGL4

GL 4.6
GL_ATI_texture_env_combine3 GLScene.OpenGL4

GL 4.6
GL_ATI_texture_float GLScene.OpenGL4

GL 4.6
GL_ATI_texture_mirror_once GLScene.OpenGL4

GL 4.6
GL_ATI_text_fragment_shader GLScene.OpenGL4

GL 4.6
GL_ATI_vertex_array_object GLScene.OpenGL4

GL 4.6
GL_ATI_vertex_attrib_array_object GLScene.OpenGL4

GL 4.6
GL_ATI_vertex_streams GLScene.OpenGL4

GL 4.6
GL_EXT_422_pixels GLScene.OpenGL4

GL 4.6
GL_EXT_abgr GLScene.OpenGL4

GL 4.6
GL_EXT_bgra GLScene.OpenGL4

GL 4.6
GL_EXT_bindable_uniform GLScene.OpenGL4

GL 4.6
GL_EXT_blend_color GLScene.OpenGL4

GL 4.6
GL_EXT_blend_equation_separate GLScene.OpenGL4

GL 4.6
GL_EXT_blend_func_separate GLScene.OpenGL4

GL 4.6
GL_EXT_blend_logic_op GLScene.OpenGL4

GL 4.6
GL_EXT_blend_minmax GLScene.OpenGL4

GL 4.6
GL_EXT_blend_subtract GLScene.OpenGL4

GL 4.6
GL_EXT_clip_volume_hint GLScene.OpenGL4

GL 4.6
GL_EXT_cmyka GLScene.OpenGL4

GL 4.6
GL_EXT_color_matrix GLScene.OpenGL4

GL 4.6
GL_EXT_color_subtable GLScene.OpenGL4

GL 4.6
GL_EXT_compiled_vertex_array GLScene.OpenGL4

GL 4.6
GL_EXT_convolution GLScene.OpenGL4

GL 4.6
GL_EXT_coordinate_frame GLScene.OpenGL4

GL 4.6
GL_EXT_copy_texture GLScene.OpenGL4

GL 4.6
GL_EXT_cull_vertex GLScene.OpenGL4

GL 4.6
GL_EXT_depth_bounds_test GLScene.OpenGL4

GL 4.6
GL_EXT_direct_state_access GLScene.OpenGL4

GL 4.6
GL_EXT_draw_buffers2 GLScene.OpenGL4

GL 4.6
GL_EXT_draw_instanced GLScene.OpenGL4

GL 4.6
GL_EXT_draw_range_elements GLScene.OpenGL4

GL 4.6
GL_EXT_fog_coord GLScene.OpenGL4

GL 4.6
GL_EXT_framebuffer_blit GLScene.OpenGL4

GL 4.6
GL_EXT_framebuffer_multisample GLScene.OpenGL4

GL 4.6
GL_EXT_framebuffer_object GLScene.OpenGL4

GL 4.6
GL_EXT_framebuffer_sRGB GLScene.OpenGL4

GL 4.6
GL_EXT_geometry_shader4 GLScene.OpenGL4

GL 4.6
GL_EXT_gpu_program_parameters GLScene.OpenGL4

GL 4.6
GL_EXT_gpu_shader4 GLScene.OpenGL4

GL 4.6
GL_EXT_histogram GLScene.OpenGL4

GL 4.6
GL_EXT_index_array_formats GLScene.OpenGL4

GL 4.6
GL_EXT_index_func GLScene.OpenGL4

GL 4.6
GL_EXT_index_material GLScene.OpenGL4

GL 4.6
GL_EXT_index_texture GLScene.OpenGL4

GL 4.6
GL_EXT_light_texture GLScene.OpenGL4

GL 4.6
GL_EXT_misc_attribute GLScene.OpenGL4

GL 4.6
GL_EXT_multisample GLScene.OpenGL4

GL 4.6
GL_EXT_multi_draw_arrays GLScene.OpenGL4

GL 4.6
GL_EXT_packed_depth_stencil GLScene.OpenGL4

GL 4.6
GL_EXT_packed_float GLScene.OpenGL4

GL 4.6
GL_EXT_packed_pixels GLScene.OpenGL4

GL 4.6
GL_EXT_paletted_texture GLScene.OpenGL4

GL 4.6
GL_EXT_pixel_buffer_object GLScene.OpenGL4

GL 4.6
GL_EXT_pixel_transform GLScene.OpenGL4

GL 4.6
GL_EXT_pixel_transform_color_table GLScene.OpenGL4

GL 4.6
GL_EXT_point_parameters GLScene.OpenGL4

GL 4.6
GL_EXT_polygon_offset GLScene.OpenGL4

GL 4.6
GL_EXT_provoking_vertex GLScene.OpenGL4

GL 4.6
GL_EXT_rescale_normal GLScene.OpenGL4

GL 4.6
GL_EXT_secondary_color GLScene.OpenGL4

GL 4.6
GL_EXT_separate_shader_objects GLScene.OpenGL4

GL 4.6
GL_EXT_separate_specular_color GLScene.OpenGL4

GL 4.6
GL_EXT_shader_image_load_store GLScene.OpenGL4

GL 4.6
GL_EXT_shadow_funcs GLScene.OpenGL4

GL 4.6
GL_EXT_shared_texture_palette GLScene.OpenGL4

GL 4.6
GL_EXT_stencil_clear_tag GLScene.OpenGL4

GL 4.6
GL_EXT_stencil_two_side GLScene.OpenGL4

GL 4.6
GL_EXT_stencil_wrap GLScene.OpenGL4

GL 4.6
GL_EXT_subtexture GLScene.OpenGL4

GL 4.6
GL_EXT_texture GLScene.OpenGL4

GL 4.6
GL_EXT_texture3D GLScene.OpenGL4

GL 4.6
GL_EXT_texture_array GLScene.OpenGL4

GL 4.6
GL_EXT_texture_buffer_object GLScene.OpenGL4

GL 4.6
GL_EXT_texture_compression_dxt1 GLScene.OpenGL4

GL 4.6
GL_EXT_texture_compression_latc GLScene.OpenGL4

GL 4.6
GL_EXT_texture_compression_rgtc GLScene.OpenGL4

GL 4.6
GL_EXT_texture_compression_s3tc GLScene.OpenGL4

GL 4.6
GL_EXT_texture_cube_map GLScene.OpenGL4

GL 4.6
GL_EXT_texture_edge_clamp GLScene.OpenGL4

GL 4.6
GL_EXT_texture_env_add GLScene.OpenGL4

GL 4.6
GL_EXT_texture_env_combine GLScene.OpenGL4

GL 4.6
GL_EXT_texture_env_dot3 GLScene.OpenGL4

GL 4.6
GL_EXT_texture_filter_anisotropic GLScene.OpenGL4

GL 4.6
GL_EXT_texture_integer GLScene.OpenGL4

GL 4.6
GL_EXT_texture_lod_bias GLScene.OpenGL4

GL 4.6
GL_EXT_texture_mirror_clamp GLScene.OpenGL4

GL 4.6
GL_EXT_texture_object GLScene.OpenGL4

GL 4.6
GL_EXT_texture_perturb_normal GLScene.OpenGL4

GL 4.6
GL_EXT_texture_rectangle GLScene.OpenGL4

GL 4.6
GL_EXT_texture_shared_exponent GLScene.OpenGL4

GL 4.6
GL_EXT_texture_snorm GLScene.OpenGL4

GL 4.6
GL_EXT_texture_sRGB GLScene.OpenGL4

GL 4.6
GL_EXT_texture_sRGB_decode GLScene.OpenGL4

GL 4.6
GL_EXT_texture_swizzle GLScene.OpenGL4

GL 4.6
GL_EXT_timer_query GLScene.OpenGL4

GL 4.6
GL_EXT_transform_feedback GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_array GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_array_bgra GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_attrib_64bit GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_shader GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_weighting GLScene.OpenGL4

GL 4.6
GL_FfdMaskSGIX GLScene.OpenGL4

GL 4.6
GL_HP_convolution_border_modes GLScene.OpenGL4

GL 4.6
GL_HP_image_transform GLScene.OpenGL4

GL 4.6
GL_HP_occlusion_test GLScene.OpenGL4

GL 4.6
GL_HP_texture_lighting GLScene.OpenGL4

GL 4.6
GL_IBM_cull_vertex GLScene.OpenGL4

GL 4.6
GL_IBM_multimode_draw_arrays GLScene.OpenGL4

GL 4.6
GL_IBM_rasterpos_clip GLScene.OpenGL4

GL 4.6
GL_IBM_texture_mirrored_repeat GLScene.OpenGL4

GL 4.6
GL_IBM_vertex_array_lists GLScene.OpenGL4

GL 4.6
GL_INGR_blend_func_separate GLScene.OpenGL4

GL 4.6
GL_INGR_color_clamp GLScene.OpenGL4

GL 4.6
GL_INGR_interlace_read GLScene.OpenGL4

GL 4.6
GL_INGR_palette_buffer GLScene.OpenGL4

GL 4.6
GL_INTEL_framebuffer_CMAA GLScene.OpenGL4

GL 4.6
GL_INTEL_parallel_arrays GLScene.OpenGL4

GL 4.6
GL_INTEL_texture_scissor GLScene.OpenGL4

GL 4.6
GL_KHR_blend_equation_advanced GLScene.OpenGL4

GL 4.5
GL_KHR_blend_equation_advanced_coherent GLScene.OpenGL4

GL 4.5
GL_KHR_context_flush_control GLScene.OpenGL4

GL 4.5
GL_KHR_debug GLScene.OpenGL4

GL 4.3
GL_KHR_no_error GLScene.OpenGL4

GL 4.6
GL_KHR_robustness GLScene.OpenGL4

GL 4.5
GL_KHR_robust_buffer_access_behavior GLScene.OpenGL4

GL 4.5
GL_MESA_resize_buffers GLScene.OpenGL4

GL 4.6
GL_MESA_window_pos GLScene.OpenGL4

GL 4.6
GL_NV_bindless_texture GLScene.OpenGL4

GL 4.3
GL_NV_blend_square GLScene.OpenGL4

GL 4.6
GL_NV_conditional_render GLScene.OpenGL4

GL 4.6
GL_NV_conservative_raster GLScene.OpenGL4

GL 4.6
GL_NV_conservative_raster_dilate GLScene.OpenGL4

GL 4.6
GL_NV_copy_depth_to_color GLScene.OpenGL4

GL 4.6
GL_NV_copy_image GLScene.OpenGL4

GL 4.6
GL_NV_depth_buffer_float GLScene.OpenGL4

GL 4.6
GL_NV_depth_clamp GLScene.OpenGL4

GL 4.6
GL_NV_evaluators GLScene.OpenGL4

GL 4.6
GL_NV_explicit_multisample GLScene.OpenGL4

GL 4.6
GL_NV_fence GLScene.OpenGL4

GL 4.6
GL_NV_float_buffer GLScene.OpenGL4

GL 4.6
GL_NV_fog_distance GLScene.OpenGL4

GL 4.6
GL_NV_fragment_program GLScene.OpenGL4

GL 4.6
GL_NV_fragment_program2 GLScene.OpenGL4

GL 4.6
GL_NV_fragment_program4 GLScene.OpenGL4

GL 4.6
GL_NV_fragment_program_option GLScene.OpenGL4

GL 4.6
GL_NV_framebuffer_multisample_coverage GLScene.OpenGL4

GL 4.6
GL_NV_geometry_program4 GLScene.OpenGL4

GL 4.6
GL_NV_gpu_program4 GLScene.OpenGL4

GL 4.6
GL_NV_gpu_program5 GLScene.OpenGL4

GL 4.6
GL_NV_gpu_shader5 GLScene.OpenGL4

GL 4.6
GL_NV_half_float GLScene.OpenGL4

GL 4.6
GL_NV_light_max_exponent GLScene.OpenGL4

GL 4.6
GL_NV_multisample_coverage GLScene.OpenGL4

GL 4.6
GL_NV_multisample_filter_hint GLScene.OpenGL4

GL 4.6
GL_NV_occlusion_query GLScene.OpenGL4

GL 4.6
GL_NV_packed_depth_stencil GLScene.OpenGL4

GL 4.6
GL_NV_parameter_buffer_object GLScene.OpenGL4

GL 4.6
GL_NV_parameter_buffer_object2 GLScene.OpenGL4

GL 4.6
GL_NV_path_rendering GLScene.OpenGL4

GL 4.3
GL_NV_pixel_data_range GLScene.OpenGL4

GL 4.6
GL_NV_point_sprite GLScene.OpenGL4

GL 4.6
GL_NV_present_video GLScene.OpenGL4

GL 4.6
GL_NV_primitive_restart GLScene.OpenGL4

GL 4.6
GL_NV_register_combiners GLScene.OpenGL4

GL 4.6
GL_NV_register_combiners2 GLScene.OpenGL4

GL 4.6
GL_NV_shader_atomic_float GLScene.OpenGL4

GL 4.3
GL_NV_shader_buffer_load GLScene.OpenGL4

GL 4.6
GL_NV_shader_buffer_store GLScene.OpenGL4

GL 4.6
GL_NV_tessellation_program5 GLScene.OpenGL4

GL 4.6
GL_NV_texgen_emboss GLScene.OpenGL4

GL 4.6
GL_NV_texgen_reflection GLScene.OpenGL4

GL 4.6
GL_NV_texture_barrier GLScene.OpenGL4

GL 4.6
GL_NV_texture_compression_vtc GLScene.OpenGL4

GL 4.6
GL_NV_texture_env_combine4 GLScene.OpenGL4

GL 4.6
GL_NV_texture_expand_normal GLScene.OpenGL4

GL 4.6
GL_NV_texture_rectangle GLScene.OpenGL4

GL 4.6
GL_NV_texture_shader GLScene.OpenGL4

GL 4.6
GL_NV_texture_shader2 GLScene.OpenGL4

GL 4.6
GL_NV_texture_shader3 GLScene.OpenGL4

GL 4.6
GL_NV_transform_feedback GLScene.OpenGL4

GL 4.6
GL_NV_transform_feedback2 GLScene.OpenGL4

GL 4.6
GL_NV_vdpau_interop GLScene.OpenGL4

GL 4.6
GL_NV_vertex_array_range GLScene.OpenGL4

GL 4.6
GL_NV_vertex_array_range2 GLScene.OpenGL4

GL 4.6
GL_NV_vertex_attrib_integer_64bit GLScene.OpenGL4

GL 4.6
GL_NV_vertex_buffer_unified_memory GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program1_1 GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program2 GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program2_option GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program3 GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program4 GLScene.OpenGL4

GL 4.6
GL_NV_video_capture GLScene.OpenGL4

GL 4.6
GL_OML_interlace GLScene.OpenGL4

GL 4.6
GL_OML_resample GLScene.OpenGL4

GL 4.6
GL_OML_subsample GLScene.OpenGL4

GL 4.6
GL_OVR_multiview GLScene.OpenGL4

GL 4.6
GL_OVR_multiview2 GLScene.OpenGL4

GL 4.6
GL_PGI_misc_hints GLScene.OpenGL4

GL 4.6
GL_PGI_vertex_hints GLScene.OpenGL4

GL 4.6
GL_REND_screen_coordinates GLScene.OpenGL4

GL 4.6
GL_S3_s3tc GLScene.OpenGL4

GL 4.6
GL_SGIS_detail_texture GLScene.OpenGL4

GL 4.6
GL_SGIS_fog_function GLScene.OpenGL4

GL 4.6
GL_SGIS_generate_mipmap GLScene.OpenGL4

GL 4.6
GL_SGIS_multisample GLScene.OpenGL4

GL 4.6
GL_SGIS_pixel_texture GLScene.OpenGL4

GL 4.6
GL_SGIS_point_line_texgen GLScene.OpenGL4

GL 4.6
GL_SGIS_point_parameters GLScene.OpenGL4

GL 4.6
GL_SGIS_sharpen_texture GLScene.OpenGL4

GL 4.6
GL_SGIS_texture4D GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_border_clamp GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_color_mask GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_edge_clamp GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_filter4 GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_lod GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_select GLScene.OpenGL4

GL 4.6
GL_SGIX_async GLScene.OpenGL4

GL 4.6
GL_SGIX_async_histogram GLScene.OpenGL4

GL 4.6
GL_SGIX_async_pixel GLScene.OpenGL4

GL 4.6
GL_SGIX_blend_alpha_minmax GLScene.OpenGL4

GL 4.6
GL_SGIX_calligraphic_fragment GLScene.OpenGL4

GL 4.6
GL_SGIX_clipmap GLScene.OpenGL4

GL 4.6
GL_SGIX_convolution_accuracy GLScene.OpenGL4

GL 4.6
GL_SGIX_depth_pass_instrument GLScene.OpenGL4

GL 4.6
GL_SGIX_depth_texture GLScene.OpenGL4

GL 4.6
GL_SGIX_flush_raster GLScene.OpenGL4

GL 4.6
GL_SGIX_fog_offset GLScene.OpenGL4

GL 4.6
GL_SGIX_fog_scale GLScene.OpenGL4

GL 4.6
GL_SGIX_fragment_lighting GLScene.OpenGL4

GL 4.6
GL_SGIX_framezoom GLScene.OpenGL4

GL 4.6
GL_SGIX_igloo_interface GLScene.OpenGL4

GL 4.6
GL_SGIX_impact_pixel_texture GLScene.OpenGL4

GL 4.6
GL_SGIX_instruments GLScene.OpenGL4

GL 4.6
GL_SGIX_interlace GLScene.OpenGL4

GL 4.6
GL_SGIX_ir_instrument1 GLScene.OpenGL4

GL 4.6
GL_SGIX_list_priority GLScene.OpenGL4

GL 4.6
GL_SGIX_pixel_texture GLScene.OpenGL4

GL 4.6
GL_SGIX_pixel_tiles GLScene.OpenGL4

GL 4.6
GL_SGIX_polynomial_ffd GLScene.OpenGL4

GL 4.6
GL_SGIX_reference_plane GLScene.OpenGL4

GL 4.6
GL_SGIX_resample GLScene.OpenGL4

GL 4.6
GL_SGIX_scalebias_hint GLScene.OpenGL4

GL 4.6
GL_SGIX_shadow GLScene.OpenGL4

GL 4.6
GL_SGIX_shadow_ambient GLScene.OpenGL4

GL 4.6
GL_SGIX_sprite GLScene.OpenGL4

GL 4.6
GL_SGIX_subsample GLScene.OpenGL4

GL 4.6
GL_SGIX_tag_sample_buffer GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_add_env GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_coordinate_clamp GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_lod_bias GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_multi_buffer GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_scale_bias GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_select GLScene.OpenGL4

GL 4.6
GL_SGIX_vertex_preclip GLScene.OpenGL4

GL 4.6
GL_SGIX_ycrcb GLScene.OpenGL4

GL 4.6
GL_SGIX_ycrcba GLScene.OpenGL4

GL 4.6
GL_SGIX_ycrcb_subsample GLScene.OpenGL4

GL 4.6
GL_SGI_color_matrix GLScene.OpenGL4

GL 4.6
GL_SGI_color_table GLScene.OpenGL4

GL 4.6
GL_SGI_depth_pass_instrument GLScene.OpenGL4

GL 4.6
GL_SGI_texture_color_table GLScene.OpenGL4

GL 4.6
GL_SUNX_constant_data GLScene.OpenGL4

GL 4.6
GL_SUN_convolution_border_modes GLScene.OpenGL4

GL 4.6
GL_SUN_global_alpha GLScene.OpenGL4

GL 4.6
GL_SUN_mesh_array GLScene.OpenGL4

GL 4.6
GL_SUN_slice_accum GLScene.OpenGL4

GL 4.6
GL_SUN_triangle_list GLScene.OpenGL4

GL 4.6
GL_SUN_vertex GLScene.OpenGL4

GL 4.6
GL_VERSION_4_0 GLScene.OpenGL4

GL_VERSION_4_1 GLScene.OpenGL4

GL_VERSION_4_2 GLScene.OpenGL4

GL_VERSION_4_3 GLScene.OpenGL4

GL_VERSION_4_4 GLScene.OpenGL4

GL_VERSION_4_5 GLScene.OpenGL4

GL_VERSION_4_6 GLScene.OpenGL4

GL_WIN_phong_shading GLScene.OpenGL4

WGL
GL_WIN_specular_fog GLScene.OpenGL4

WGL
IDTFConverterFileName GLS.File3DPDF

global variable for accing the IDTF->U3D converter
IncludeFilePath GLS.CgShader

Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.
IsDesignTime GLScene.Utils

IsODEInitialized ODE.Import

Language GLScene.Strings

String constants that are used for internationalization

To build your project with a single language's translations in the executable itself, define one of the next languages

Language $DEFINE 2-character locale id ——————- ———- ——————— English LANG_EN en French LANG_FR fr German LANG_DE de Italian LANG_IT it Japanese LANG_JP jp Russian LANG_RU ru Spanish LANG_ES es
LibHandle OpenAL.Import

lkPrefix GLScene.Logger

llMessageLimit GLScene.Logger

sH2 GLS.Navigator

STLUseEmbeddedColors GLS.FileSTL

sW2 GLS.Navigator

vAFIOCreateFileStream GLS.ApplicationFileIO

vAFIOFileStreamExists GLS.ApplicationFileIO

vContextActivationFailureOccurred GLS.Context

vCounterFrequency GLS.Scene

vCurrentGLContext GLS.Context

vCurrentRenderingObject GLS.Scene

vCurrentVideoMode GLS.Screen

vCustomColliderClass GLS.ODEManager

vCustomColliderClassNum GLS.ODEManager

vDDSDetailLevel GLS.FileDDS

Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.
vDefaultMeshOptimizerOptions GLS.MeshBuilder

vDefaultTextureCompression GLScene.TextureFormat

vDefaultTextureFormat GLScene.TextureFormat

vEdgeInfoReserveSize GLS.MeshUtils

vFindCuFileFunc GLS.CUDA.Compiler

vFontManagerMsgID GLS.SpaceText

vGhoul2LevelOfDetail GLS.FileGL2

vGhoul2MaxBonesPerVertex GLS.FileGL2

Highest detail level by default
vGLFile3DSSceneObjects_RenderCameraAndLights GLS.File3DSSceneObjects

vGLFile3DS_EnableAnimation GLS.File3DS

If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TGLFreeForm.AutoCentering does now work correctly. - TGLMeshObject.vertices return values different from TGLMeshObject.ExtractTriangles()
vGLFile3DS_FixDefaultUpAxisY GLS.File3DS

If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vGLFile3DS_EnableAnimation = true)
vGLFile3DS_LoadedStaticFrame GLS.File3DS

If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vGLFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.
vGLFile3DS_UseTextureEx GLS.File3DS

If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.
vGLFileOBJ_SplitMesh GLS.FileOBJ

If enabled, main mesh will be splitted into multiple mesh from facegroup data.
vGLFileOCTAllocateMaterials GLS.FileOCT

Scaling factor, 1.0 = unchanged
vGLFileOCTLightmapBrightness GLS.FileOCT

vGLFileOCTLightmapGammaCorrection GLS.FileOCT

Scaling factor, 1.0 = unchanged
vGLFileQ3BSPLoadMaterials GLS.FileQ3BSP

scaling factor, 1.0 = unchanged
vGLSmartObjectsAllocate GLS.SmartObjects

vGLSmartObjectsEnableByDefault GLS.SmartObjects

vGLVectorFileObjectsAllocateMaterials GLS.VectorFileObjects

vGLVectorFileObjectsEnableVBOByDefault GLS.VectorFileObjects

Flag to avoid loading materials (useful for IDE Extentions or scene editors)
vIDELogProc GLScene.Logger

vIgnoreOpenGLErrors GLS.Context

vIgnoreOpenGLErrors GLScene.OpenGL4

Raises an EOpenGLError with 'msg' error string
vImageScaleFilterWidth GLS.ImageUtils

vImprovedFixingOpenTriangleEdge GLS.MeshUtils

vLastWheelDelta GLScene.Keyboard

vMainThread GLS.Context

vMD5TextureExtensions GLS.FileMD5

vNumberVideoModes GLS.Screen

vODEObjectRegister GLS.ODEManager

vODERagdoll_cDensity GLS.ODERagdoll

vODERagdoll_cMass GLS.ODERagdoll

VORUseEmbeddedColors GLS.FileVOR

vProjectTargetName GLScene.Utils

vQ3BSPLightmapBrightness GLS.FileQ3BSP

vQ3BSPLightmapGammaCorrection GLS.FileQ3BSP

Q3 lightmaps are quite dark, we brighten them a lot by default
vSIMD GLScene.VectorGeometry

This var is adjusted during "initialization", current values are + 0 : use standard optimized FPU code + 1 : use 3DNow! optimized code (requires K6-2/3 CPU) + 2 : use Intel SSE code (Pentium III, NOT IMPLEMENTED YET !)
vUseWindowTrackingHook GLS.WindowsContext

This boolean controls a hook-based tracking of top-level forms destruction, with the purpose of being able to properly release OpenGL contexts before they are (improperly) released by some drivers upon top-level form destruction
vVerboseGLSMErrors GLS.SoundManager

If this variable is true, errors in GLSM may be displayed to the user
vVerticalFlipDDS GLS.Graphics

vVideoModes GLS.Screen

wglAllocateMemoryNV GLScene.OpenGL4

wglBindTexImageARB GLScene.OpenGL4

WGL_ARB_render_texture (ARB #20)
wglChoosePixelFormatARB GLScene.OpenGL4

wglCreateAffinityDCNV GLScene.OpenGL4

wglCreateBufferRegionARB GLScene.OpenGL4

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### WGL_buffer_region (ARB #4)
wglCreateContextAttribsARB GLScene.OpenGL4

WGL_ARB_create_context (ARB #55)
wglCreatePbufferARB GLScene.OpenGL4

WGL_ARB_pbuffer (ARB #11)
wglDeleteBufferRegionARB GLScene.OpenGL4

wglDeleteDCNV GLScene.OpenGL4

wglDestroyPbufferARB GLScene.OpenGL4

wglEnumGpuDevicesNV GLScene.OpenGL4

wglEnumGpusFromAffinityDCNV GLScene.OpenGL4

wglEnumGpusNV GLScene.OpenGL4

WGL_NV_gpu_affinity
wglFreeMemoryNV GLScene.OpenGL4

wglGetCurrentReadDCARB GLScene.OpenGL4

wglGetExtensionsStringARB GLScene.OpenGL4

WGL_ARB_extensions_string (ARB #8)
wglGetPbufferDCARB GLScene.OpenGL4

wglGetPixelFormatAttribfvARB GLScene.OpenGL4

wglGetPixelFormatAttribivARB GLScene.OpenGL4

WGL_ARB_pixel_format (ARB #9)
wglGetSwapIntervalEXT GLScene.OpenGL4

wglMakeContextCurrentARB GLScene.OpenGL4

WGL_make_current_read (ARB #10)
wglQueryPbufferARB GLScene.OpenGL4

wglReleasePbufferDCARB GLScene.OpenGL4

wglReleaseTexImageARB GLScene.OpenGL4

wglRestoreBufferRegionARB GLScene.OpenGL4

wglSaveBufferRegionARB GLScene.OpenGL4

wglSetPbufferAttribARB GLScene.OpenGL4

wglSwapIntervalEXT GLScene.OpenGL4

########################################################### function and procedure definitions for Vendor/EXT WGL extensions ########################################################### WGL_EXT_swap_control (EXT #172)
WGL_3DFX_multisample GLScene.OpenGL4

WGL
WGL_3DL_stereo_control GLScene.OpenGL4

WGL
WGL_AMD_gpu_association GLScene.OpenGL4

WGL
WGL_ARB_buffer_region GLScene.OpenGL4

WGL
WGL_ARB_context_flush_control GLScene.OpenGL4

WGL
WGL_ARB_create_context GLScene.OpenGL4

WGL
WGL_ARB_create_context_profile GLScene.OpenGL4

WGL
WGL_ARB_create_context_robustness GLScene.OpenGL4

WGL
WGL_ARB_extensions_string GLScene.OpenGL4

WGL
WGL_ARB_framebuffer_sRGB GLScene.OpenGL4

WGL
WGL_ARB_make_current_read GLScene.OpenGL4

WGL
WGL_ARB_multisample GLScene.OpenGL4

WGL
WGL_ARB_pbuffer GLScene.OpenGL4

WGL
WGL_ARB_pixel_format GLScene.OpenGL4

WGL
WGL_ARB_pixel_format_float GLScene.OpenGL4

WGL
WGL_ARB_render_texture GLScene.OpenGL4

WGL
WGL_ATI_pixel_format_float GLScene.OpenGL4

WGL
WGL_EXT_create_context_es2_profile GLScene.OpenGL4

WGL
WGL_EXT_depth_float GLScene.OpenGL4

WGL
WGL_EXT_display_color_table GLScene.OpenGL4

WGL
WGL_EXT_extensions_string GLScene.OpenGL4

WGL
WGL_EXT_make_current_read GLScene.OpenGL4

WGL
WGL_EXT_multisample GLScene.OpenGL4

WGL
WGL_EXT_pbuffer GLScene.OpenGL4

WGL
WGL_EXT_pixel_format GLScene.OpenGL4

WGL
WGL_EXT_swap_control GLScene.OpenGL4

WGL
WGL_I3D_digital_video_control GLScene.OpenGL4

WGL
WGL_I3D_gamma GLScene.OpenGL4

WGL
WGL_I3D_genlock GLScene.OpenGL4

WGL
WGL_I3D_image_buffer GLScene.OpenGL4

WGL
WGL_I3D_swap_frame_lock GLScene.OpenGL4

WGL
WGL_I3D_swap_frame_usage GLScene.OpenGL4

WGL
WGL_NV_copy_image GLScene.OpenGL4

WGL
WGL_NV_DX_interop GLScene.OpenGL4

WGL
WGL_NV_float_buffer GLScene.OpenGL4

WGL
WGL_NV_gpu_affinity GLScene.OpenGL4

WGL
WGL_NV_multisample_coverage GLScene.OpenGL4

WGL
WGL_NV_present_video GLScene.OpenGL4

WGL
WGL_NV_render_depth_texture GLScene.OpenGL4

WGL
WGL_NV_render_texture_rectangle GLScene.OpenGL4

WGL
WGL_NV_swap_group GLScene.OpenGL4

WGL
WGL_NV_vertex_array_range GLScene.OpenGL4

WGL
WGL_NV_video_capture GLScene.OpenGL4

WGL
WGL_NV_video_output GLScene.OpenGL4

WGL
WGL_OML_sync_control GLScene.OpenGL4

WGL
WIN_draw_range_elements GLScene.OpenGL4

WGL
WIN_swap_hint GLScene.OpenGL4

WGL
xgl GLS.Context


GLSysHelp v.2.5: All Constants

All Constants

Name

Unit

Description

ACubicFirst3DS

Formats.m3DSConst

maximum reflection map aliasing used with TAcubic3DS structure

ACubicFlat3DS

Formats.m3DSConst

ALC_ALL_ATTRIBUTES

OpenAL.Import

ALC_ALL_DEVICES_SPECIFIER

OpenAL.Import

ALC_ATTRIBUTES_SIZE

OpenAL.Import

ALC_CAPTURE_DEFAULT_DEVICE_SPECIFIER

OpenAL.Import

ALC_CAPTURE_DEVICE_SPECIFIER

OpenAL.Import

Capture extension

ALC_CAPTURE_SAMPLES

OpenAL.Import

ALC_DEFAULT_ALL_DEVICES_SPECIFIER

OpenAL.Import

ALC_ENUMERATE_ALL_EXT enums

ALC_DEFAULT_DEVICE_SPECIFIER

OpenAL.Import

The Specifier string for default device

ALC_DEVICE_SPECIFIER

OpenAL.Import

ALC_EFX_MAJOR_VERSION

OpenAL.Import

Context definitions to be used with alcCreateContext. These values must be unique and not conflict with other al context values.

ALC_EFX_MINOR_VERSION

OpenAL.Import

ALC_EXTENSIONS

OpenAL.Import

ALC_EXT_EFX_NAME

OpenAL.Import

EFX Extension

ALC_FALSE

OpenAL.Import

Boolean False.

ALC_FREQUENCY

OpenAL.Import

followed by <int> Hz

ALC_INVALID

OpenAL.Import

bad value

ALC_INVALID_CONTEXT

OpenAL.Import

invalid context ID

ALC_INVALID_DEVICE

OpenAL.Import

No device

ALC_INVALID_ENUM

OpenAL.Import

bad enum

ALC_INVALID_VALUE

OpenAL.Import

bad value

ALC_MAJOR_VERSION

OpenAL.Import

ALC_MAX_AUXILIARY_SENDS

OpenAL.Import

ALC_MINOR_VERSION

OpenAL.Import

ALC_MONO_SOURCES

OpenAL.Import

followed by <int> Num of requested Mono (3D) Sources

ALC_NO_ERROR

OpenAL.Import

errors No error

ALC_OUT_OF_MEMORY

OpenAL.Import

Out of memory.

ALC_REFRESH

OpenAL.Import

followed by <int> Hz

ALC_STEREO_SOURCES

OpenAL.Import

followed by <int> Num of requested Stereo Sources

ALC_SYNC

OpenAL.Import

followed by AL_TRUE, AL_FALSE

ALC_TRUE

OpenAL.Import

Boolean True.

ALLOC_SIZE

GLS.Isosurface

AL_AIR_ABSORPTION_FACTOR

OpenAL.Import

AL_AUTOWAH_ATTACK_TIME

OpenAL.Import

Autowah Parameters

AL_AUTOWAH_DEFAULT_ATTACK_TIME

OpenAL.Import

AL_AUTOWAH_DEFAULT_PEAK_GAIN

OpenAL.Import

AL_AUTOWAH_DEFAULT_RELEASE_TIME

OpenAL.Import

AL_AUTOWAH_DEFAULT_RESONANCE

OpenAL.Import

AL_AUTOWAH_MAX_ATTACK_TIME

OpenAL.Import

AL_AUTOWAH_MAX_PEAK_GAIN

OpenAL.Import

AL_AUTOWAH_MAX_RELEASE_TIME

OpenAL.Import

AL_AUTOWAH_MAX_RESONANCE

OpenAL.Import

AL_AUTOWAH_MIN_ATTACK_TIME

OpenAL.Import

AL autowah effect parameter ranges and defaults

AL_AUTOWAH_MIN_PEAK_GAIN

OpenAL.Import

AL_AUTOWAH_MIN_RELEASE_TIME

OpenAL.Import

AL_AUTOWAH_MIN_RESONANCE

OpenAL.Import

AL_AUTOWAH_PEAK_GAIN

OpenAL.Import

AL_AUTOWAH_RELEASE_TIME

OpenAL.Import

AL_AUTOWAH_RESONANCE

OpenAL.Import

AL_AUXILIARY_SEND_FILTER

OpenAL.Import

AL_AUXILIARY_SEND_FILTER_GAINHF_AUTO

OpenAL.Import

AL_AUXILIARY_SEND_FILTER_GAIN_AUTO

OpenAL.Import

AL_BANDPASS_GAIN

OpenAL.Import

Bandpass Parameters

AL_BANDPASS_GAINHF

OpenAL.Import

AL_BANDPASS_GAINLF

OpenAL.Import

AL_BITS

OpenAL.Import

AL_BUFFER

OpenAL.Import

Indicate the buffer to provide sound samples. Type: ALuint. Range: any valid Buffer id.

AL_BUFFERS_PROCESSED

OpenAL.Import

AL_BUFFERS_QUEUED

OpenAL.Import

Buffer Queue params

AL_BYTE_OFFSET

OpenAL.Import

AL_CHANNELS

OpenAL.Import

AL_CHANNEL_MASK

OpenAL.Import

Specify the channel mask. (Creative) Type: ALuint Range: [0 - 255]

AL_CHORUS_DEFAULT_DELAY

OpenAL.Import

AL_CHORUS_DEFAULT_DEPTH

OpenAL.Import

AL_CHORUS_DEFAULT_FEEDBACK

OpenAL.Import

AL_CHORUS_DEFAULT_PHASE

OpenAL.Import

AL_CHORUS_DEFAULT_RATE

OpenAL.Import

AL_CHORUS_DEFAULT_WAVEFORM

OpenAL.Import

AL_CHORUS_DELAY

OpenAL.Import

AL_CHORUS_DEPTH

OpenAL.Import

AL_CHORUS_FEEDBACK

OpenAL.Import

AL_CHORUS_MAX_DELAY

OpenAL.Import

AL_CHORUS_MAX_DEPTH

OpenAL.Import

AL_CHORUS_MAX_FEEDBACK

OpenAL.Import

AL_CHORUS_MAX_PHASE

OpenAL.Import

AL_CHORUS_MAX_RATE

OpenAL.Import

AL_CHORUS_MAX_WAVEFORM

OpenAL.Import

AL_CHORUS_MIN_DELAY

OpenAL.Import

AL_CHORUS_MIN_DEPTH

OpenAL.Import

AL_CHORUS_MIN_FEEDBACK

OpenAL.Import

AL_CHORUS_MIN_PHASE

OpenAL.Import

AL_CHORUS_MIN_RATE

OpenAL.Import

AL_CHORUS_MIN_WAVEFORM

OpenAL.Import

AL chorus effect parameter ranges and defaults

AL_CHORUS_PHASE

OpenAL.Import

AL_CHORUS_RATE

OpenAL.Import

AL_CHORUS_WAVEFORM

OpenAL.Import

Chorus Parameters

AL_CHORUS_WAVEFORM_SINUSOID

OpenAL.Import

AL_CHORUS_WAVEFORM_TRIANGLE

OpenAL.Import

AL_COMPRESSOR_DEFAULT_ONOFF

OpenAL.Import

AL_COMPRESSOR_MAX_ONOFF

OpenAL.Import

AL_COMPRESSOR_MIN_ONOFF

OpenAL.Import

AL compressor effect parameter ranges and defaults

AL_COMPRESSOR_ONOFF

OpenAL.Import

Compressor Parameters

AL_CONE_INNER_ANGLE

OpenAL.Import

Directional source, inner cone angle, in degrees. Range: [0-360] Default: 360

AL_CONE_OUTER_ANGLE

OpenAL.Import

Directional source, outer cone angle, in degrees. Range: [0-360] Default: 360

AL_CONE_OUTER_GAIN

OpenAL.Import

Directional source, outer cone gain. Default: 0.0 Range: [0.0 - 1.0] Logarithmic

AL_CONE_OUTER_GAINHF

OpenAL.Import

AL_DEFAULT_AIR_ABSORPTION_FACTOR

OpenAL.Import

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAINHF_AUTO

OpenAL.Import

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAIN_AUTO

OpenAL.Import

AL_DEFAULT_CONE_OUTER_GAINHF

OpenAL.Import

AL_DEFAULT_DIRECT_FILTER_GAINHF_AUTO

OpenAL.Import

AL_DEFAULT_METERS_PER_UNIT

OpenAL.Import

Listener parameter value definitions, ranges and defaults. AL_MIN_METERS_PER_UNIT =FLT_MIN; AL_MAX_METERS_PER_UNIT =FLT_MAX;

AL_DEFAULT_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_DIRECTION

OpenAL.Import

Specify the current direction.

AL_DIRECT_FILTER

OpenAL.Import

Source definitions to be used with alSource functions. These values must be unique and not conflict with other al source values.

AL_DIRECT_FILTER_GAINHF_AUTO

OpenAL.Import

AL_DISTANCE_MODEL

OpenAL.Import

Distance models
used in conjunction with DistanceModel
implicit: NONE, which disances distance attenuation.

AL_DISTORTION_DEFAULT_EDGE

OpenAL.Import

AL_DISTORTION_DEFAULT_EQBANDWIDTH

OpenAL.Import

AL_DISTORTION_DEFAULT_EQCENTER

OpenAL.Import

AL_DISTORTION_DEFAULT_GAIN

OpenAL.Import

AL_DISTORTION_DEFAULT_LOWPASS_CUTOFF

OpenAL.Import

AL_DISTORTION_EDGE

OpenAL.Import

Distortion Parameters

AL_DISTORTION_EQBANDWIDTH

OpenAL.Import

AL_DISTORTION_EQCENTER

OpenAL.Import

AL_DISTORTION_GAIN

OpenAL.Import

AL_DISTORTION_LOWPASS_CUTOFF

OpenAL.Import

AL_DISTORTION_MAX_EDGE

OpenAL.Import

AL_DISTORTION_MAX_EQBANDWIDTH

OpenAL.Import

AL_DISTORTION_MAX_EQCENTER

OpenAL.Import

AL_DISTORTION_MAX_GAIN

OpenAL.Import

AL_DISTORTION_MAX_LOWPASS_CUTOFF

OpenAL.Import

AL_DISTORTION_MIN_EDGE

OpenAL.Import

AL distortion effect parameter ranges and defaults

AL_DISTORTION_MIN_EQBANDWIDTH

OpenAL.Import

AL_DISTORTION_MIN_EQCENTER

OpenAL.Import

AL_DISTORTION_MIN_GAIN

OpenAL.Import

AL_DISTORTION_MIN_LOWPASS_CUTOFF

OpenAL.Import

AL_DOPPLER_FACTOR

OpenAL.Import

Global tweakage. Doppler scale. Default 1.0

AL_DOPPLER_VELOCITY

OpenAL.Import

Tweaks speed of propagation.

AL_EAXREVERB_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_EAXREVERB_DECAY_HFLIMIT

OpenAL.Import

AL_EAXREVERB_DECAY_HFRATIO

OpenAL.Import

AL_EAXREVERB_DECAY_LFRATIO

OpenAL.Import

AL_EAXREVERB_DECAY_TIME

OpenAL.Import

AL_EAXREVERB_DEFAULT_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_EAXREVERB_DEFAULT_DECAY_HFLIMIT

OpenAL.Import

AL_EAXREVERB_DEFAULT_DECAY_HFRATIO

OpenAL.Import

AL_EAXREVERB_DEFAULT_DECAY_LFRATIO

OpenAL.Import

AL_EAXREVERB_DEFAULT_DECAY_TIME

OpenAL.Import

AL_EAXREVERB_DEFAULT_DENSITY

OpenAL.Import

AL_EAXREVERB_DEFAULT_DIFFUSION

OpenAL.Import

AL_EAXREVERB_DEFAULT_ECHO_DEPTH

OpenAL.Import

AL_EAXREVERB_DEFAULT_ECHO_TIME

OpenAL.Import

AL_EAXREVERB_DEFAULT_GAIN

OpenAL.Import

AL_EAXREVERB_DEFAULT_GAINHF

OpenAL.Import

AL_EAXREVERB_DEFAULT_GAINLF

OpenAL.Import

AL_EAXREVERB_DEFAULT_HFREFERENCE

OpenAL.Import

AL_EAXREVERB_DEFAULT_LATE_REVERB_DELAY

OpenAL.Import

AL_EAXREVERB_DEFAULT_LATE_REVERB_GAIN

OpenAL.Import

AL_EAXREVERB_DEFAULT_LATE_REVERB_PAN

OpenAL.Import

AL_EAXREVERB_DEFAULT_LFREFERENCE

OpenAL.Import

AL_EAXREVERB_DEFAULT_MODULATION_DEPTH

OpenAL.Import

AL_EAXREVERB_DEFAULT_MODULATION_TIME

OpenAL.Import

AL_EAXREVERB_DEFAULT_REFLECTIONS_DELAY

OpenAL.Import

AL_EAXREVERB_DEFAULT_REFLECTIONS_GAIN

OpenAL.Import

AL_EAXREVERB_DEFAULT_REFLECTIONS_PAN

OpenAL.Import

AL_EAXREVERB_DEFAULT_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_EAXREVERB_DENSITY

OpenAL.Import

EFX AEX extenstion Effect object definitions to be used with alEffect functions. Effect parameter value definitions, ranges, and defaults appear farther down in this file. AL EAXReverb effect parameters.

AL_EAXREVERB_DIFFUSION

OpenAL.Import

AL_EAXREVERB_ECHO_DEPTH

OpenAL.Import

AL_EAXREVERB_ECHO_TIME

OpenAL.Import

AL_EAXREVERB_GAIN

OpenAL.Import

AL_EAXREVERB_GAINHF

OpenAL.Import

AL_EAXREVERB_GAINLF

OpenAL.Import

AL_EAXREVERB_HFREFERENCE

OpenAL.Import

AL_EAXREVERB_LATE_REVERB_DELAY

OpenAL.Import

AL_EAXREVERB_LATE_REVERB_GAIN

OpenAL.Import

AL_EAXREVERB_LATE_REVERB_PAN

OpenAL.Import

AL_EAXREVERB_LFREFERENCE

OpenAL.Import

AL_EAXREVERB_MAX_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_EAXREVERB_MAX_DECAY_HFLIMIT

OpenAL.Import

AL_EAXREVERB_MAX_DECAY_HFRATIO

OpenAL.Import

AL_EAXREVERB_MAX_DECAY_LFRATIO

OpenAL.Import

AL_EAXREVERB_MAX_DECAY_TIME

OpenAL.Import

AL_EAXREVERB_MAX_DENSITY

OpenAL.Import

AL_EAXREVERB_MAX_DIFFUSION

OpenAL.Import

AL_EAXREVERB_MAX_ECHO_DEPTH

OpenAL.Import

AL_EAXREVERB_MAX_ECHO_TIME

OpenAL.Import

AL_EAXREVERB_MAX_GAIN

OpenAL.Import

AL_EAXREVERB_MAX_GAINHF

OpenAL.Import

AL_EAXREVERB_MAX_GAINLF

OpenAL.Import

AL_EAXREVERB_MAX_HFREFERENCE

OpenAL.Import

AL_EAXREVERB_MAX_LATE_REVERB_DELAY

OpenAL.Import

AL_EAXREVERB_MAX_LATE_REVERB_GAIN

OpenAL.Import

AL_EAXREVERB_MAX_LFREFERENCE

OpenAL.Import

AL_EAXREVERB_MAX_MODULATION_DEPTH

OpenAL.Import

AL_EAXREVERB_MAX_MODULATION_TIME

OpenAL.Import

AL_EAXREVERB_MAX_REFLECTIONS_DELAY

OpenAL.Import

AL_EAXREVERB_MAX_REFLECTIONS_GAIN

OpenAL.Import

AL_EAXREVERB_MAX_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_EAXREVERB_MIN_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_EAXREVERB_MIN_DECAY_HFLIMIT

OpenAL.Import

AL_EAXREVERB_MIN_DECAY_HFRATIO

OpenAL.Import

AL_EAXREVERB_MIN_DECAY_LFRATIO

OpenAL.Import

AL_EAXREVERB_MIN_DECAY_TIME

OpenAL.Import

AL_EAXREVERB_MIN_DENSITY

OpenAL.Import

Effect parameter structures, value definitions, ranges and defaults. AL reverb effect parameter ranges and defaults

AL_EAXREVERB_MIN_DIFFUSION

OpenAL.Import

AL_EAXREVERB_MIN_ECHO_DEPTH

OpenAL.Import

AL_EAXREVERB_MIN_ECHO_TIME

OpenAL.Import

AL_EAXREVERB_MIN_GAIN

OpenAL.Import

AL_EAXREVERB_MIN_GAINHF

OpenAL.Import

AL_EAXREVERB_MIN_GAINLF

OpenAL.Import

AL_EAXREVERB_MIN_HFREFERENCE

OpenAL.Import

AL_EAXREVERB_MIN_LATE_REVERB_DELAY

OpenAL.Import

AL_EAXREVERB_MIN_LATE_REVERB_GAIN

OpenAL.Import

AL_EAXREVERB_MIN_LFREFERENCE

OpenAL.Import

AL_EAXREVERB_MIN_MODULATION_DEPTH

OpenAL.Import

AL_EAXREVERB_MIN_MODULATION_TIME

OpenAL.Import

AL_EAXREVERB_MIN_REFLECTIONS_DELAY

OpenAL.Import

AL_EAXREVERB_MIN_REFLECTIONS_GAIN

OpenAL.Import

AL_EAXREVERB_MIN_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_EAXREVERB_MODULATION_DEPTH

OpenAL.Import

AL_EAXREVERB_MODULATION_TIME

OpenAL.Import

AL_EAXREVERB_REFLECTIONS_DELAY

OpenAL.Import

AL_EAXREVERB_REFLECTIONS_GAIN

OpenAL.Import

AL_EAXREVERB_REFLECTIONS_PAN

OpenAL.Import

AL_EAXREVERB_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_ECHO_DAMPING

OpenAL.Import

AL_ECHO_DEFAULT_DAMPING

OpenAL.Import

AL_ECHO_DEFAULT_DELAY

OpenAL.Import

AL_ECHO_DEFAULT_FEEDBACK

OpenAL.Import

AL_ECHO_DEFAULT_LRDELAY

OpenAL.Import

AL_ECHO_DEFAULT_SPREAD

OpenAL.Import

AL_ECHO_DELAY

OpenAL.Import

Echo Parameters

AL_ECHO_FEEDBACK

OpenAL.Import

AL_ECHO_LRDELAY

OpenAL.Import

AL_ECHO_MAX_DAMPING

OpenAL.Import

AL_ECHO_MAX_DELAY

OpenAL.Import

AL_ECHO_MAX_FEEDBACK

OpenAL.Import

AL_ECHO_MAX_LRDELAY

OpenAL.Import

AL_ECHO_MAX_SPREAD

OpenAL.Import

AL_ECHO_MIN_DAMPING

OpenAL.Import

AL_ECHO_MIN_DELAY

OpenAL.Import

AL echo effect parameter ranges and defaults

AL_ECHO_MIN_FEEDBACK

OpenAL.Import

AL_ECHO_MIN_LRDELAY

OpenAL.Import

AL_ECHO_MIN_SPREAD

OpenAL.Import

AL_ECHO_SPREAD

OpenAL.Import

AL_EFFECTSLOT_AUXILIARY_SEND_AUTO

OpenAL.Import

AL_EFFECTSLOT_EFFECT

OpenAL.Import

Auxiliary Slot object definitions to be used with alAuxiliaryEffectSlot functions.

AL_EFFECTSLOT_GAIN

OpenAL.Import

AL_EFFECTSLOT_NULL

OpenAL.Import

Value to be used as an Auxiliary Slot ID to disable a source send..

AL_EFFECT_AUTOWAH

OpenAL.Import

AL_EFFECT_CHORUS

OpenAL.Import

AL_EFFECT_COMPRESSOR

OpenAL.Import

AL_EFFECT_DISTORTION

OpenAL.Import

AL_EFFECT_EAXREVERB

OpenAL.Import

Effect type definitions to be used with AL_EFFECT_TYPE.

AL_EFFECT_ECHO

OpenAL.Import

AL_EFFECT_EQUALIZER

OpenAL.Import

AL_EFFECT_FIRST_PARAMETER

OpenAL.Import

Effect type

AL_EFFECT_FLANGER

OpenAL.Import

AL_EFFECT_FREQUENCY_SHIFTER

OpenAL.Import

AL_EFFECT_LAST_PARAMETER

OpenAL.Import

AL_EFFECT_NULL

OpenAL.Import

Effect type definitions to be used with AL_EFFECT_TYPE.

AL_EFFECT_PITCH_SHIFTER

OpenAL.Import

AL_EFFECT_REVERB

OpenAL.Import

Can also be used as an Effect Object ID

AL_EFFECT_RING_MODULATOR

OpenAL.Import

AL_EFFECT_TYPE

OpenAL.Import

AL_EFFECT_VOCAL_MORPHER

OpenAL.Import

AL_EQUALIZER_DEFAULT_HIGH_CUTOFF

OpenAL.Import

AL_EQUALIZER_DEFAULT_HIGH_GAIN

OpenAL.Import

AL_EQUALIZER_DEFAULT_LOW_CUTOFF

OpenAL.Import

AL_EQUALIZER_DEFAULT_LOW_GAIN

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID1_CENTER

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID1_GAIN

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID1_WIDTH

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID2_CENTER

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID2_GAIN

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID2_WIDTH

OpenAL.Import

AL_EQUALIZER_HIGH_CUTOFF

OpenAL.Import

AL_EQUALIZER_HIGH_GAIN

OpenAL.Import

AL_EQUALIZER_LOW_CUTOFF

OpenAL.Import

AL_EQUALIZER_LOW_GAIN

OpenAL.Import

Equalizer Parameters

AL_EQUALIZER_MAX_HIGH_CUTOFF

OpenAL.Import

AL_EQUALIZER_MAX_HIGH_GAIN

OpenAL.Import

AL_EQUALIZER_MAX_LOW_CUTOFF

OpenAL.Import

AL_EQUALIZER_MAX_LOW_GAIN

OpenAL.Import

AL_EQUALIZER_MAX_MID1_CENTER

OpenAL.Import

AL_EQUALIZER_MAX_MID1_GAIN

OpenAL.Import

AL_EQUALIZER_MAX_MID1_WIDTH

OpenAL.Import

AL_EQUALIZER_MAX_MID2_CENTER

OpenAL.Import

AL_EQUALIZER_MAX_MID2_GAIN

OpenAL.Import

AL_EQUALIZER_MAX_MID2_WIDTH

OpenAL.Import

AL_EQUALIZER_MID1_CENTER

OpenAL.Import

AL_EQUALIZER_MID1_GAIN

OpenAL.Import

AL_EQUALIZER_MID1_WIDTH

OpenAL.Import

AL_EQUALIZER_MID2_CENTER

OpenAL.Import

AL_EQUALIZER_MID2_GAIN

OpenAL.Import

AL_EQUALIZER_MID2_WIDTH

OpenAL.Import

AL_EQUALIZER_MIN_HIGH_CUTOFF

OpenAL.Import

AL_EQUALIZER_MIN_HIGH_GAIN

OpenAL.Import

AL_EQUALIZER_MIN_LOW_CUTOFF

OpenAL.Import

AL_EQUALIZER_MIN_LOW_GAIN

OpenAL.Import

AL equalizer effect parameter ranges and defaults

AL_EQUALIZER_MIN_MID1_CENTER

OpenAL.Import

AL_EQUALIZER_MIN_MID1_GAIN

OpenAL.Import

AL_EQUALIZER_MIN_MID1_WIDTH

OpenAL.Import

AL_EQUALIZER_MIN_MID2_CENTER

OpenAL.Import

AL_EQUALIZER_MIN_MID2_GAIN

OpenAL.Import

AL_EQUALIZER_MIN_MID2_WIDTH

OpenAL.Import

AL_EXPONENT_DISTANCE

OpenAL.Import

AL_EXPONENT_DISTANCE_CLAMPED

OpenAL.Import

AL_EXTENSIONS

OpenAL.Import

AL_FALSE

OpenAL.Import

Boolean False.

AL_FILTER_BANDPASS

OpenAL.Import

AL_FILTER_FIRST_PARAMETER

OpenAL.Import

Filter type

AL_FILTER_HIGHPASS

OpenAL.Import

AL_FILTER_LAST_PARAMETER

OpenAL.Import

AL_FILTER_LOWPASS

OpenAL.Import

Can also be used as a Filter Object ID

AL_FILTER_NULL

OpenAL.Import

Filter type definitions to be used with AL_FILTER_TYPE.

AL_FILTER_TYPE

OpenAL.Import

AL_FLANGER_DEFAULT_DELAY

OpenAL.Import

AL_FLANGER_DEFAULT_DEPTH

OpenAL.Import

AL_FLANGER_DEFAULT_FEEDBACK

OpenAL.Import

AL_FLANGER_DEFAULT_PHASE

OpenAL.Import

AL_FLANGER_DEFAULT_RATE

OpenAL.Import

AL_FLANGER_DEFAULT_WAVEFORM

OpenAL.Import

AL_FLANGER_DELAY

OpenAL.Import

AL_FLANGER_DEPTH

OpenAL.Import

AL_FLANGER_FEEDBACK

OpenAL.Import

AL_FLANGER_MAX_DELAY

OpenAL.Import

AL_FLANGER_MAX_DEPTH

OpenAL.Import

AL_FLANGER_MAX_FEEDBACK

OpenAL.Import

AL_FLANGER_MAX_PHASE

OpenAL.Import

AL_FLANGER_MAX_RATE

OpenAL.Import

AL_FLANGER_MAX_WAVEFORM

OpenAL.Import

AL_FLANGER_MIN_DELAY

OpenAL.Import

AL_FLANGER_MIN_DEPTH

OpenAL.Import

AL_FLANGER_MIN_FEEDBACK

OpenAL.Import

AL_FLANGER_MIN_PHASE

OpenAL.Import

AL_FLANGER_MIN_RATE

OpenAL.Import

AL_FLANGER_MIN_WAVEFORM

OpenAL.Import

AL flanger effect parameter ranges and defaults

AL_FLANGER_PHASE

OpenAL.Import

AL_FLANGER_RATE

OpenAL.Import

AL_FLANGER_WAVEFORM

OpenAL.Import

Flanger Parameters

AL_FLANGER_WAVEFORM_SINUSOID

OpenAL.Import

AL_FLANGER_WAVEFORM_TRIANGLE

OpenAL.Import

AL_FORMAT_MONO16

OpenAL.Import

AL_FORMAT_MONO8

OpenAL.Import

Sound samples: format specifier.

AL_FORMAT_STEREO16

OpenAL.Import

AL_FORMAT_STEREO8

OpenAL.Import

AL_FREQUENCY

OpenAL.Import

Sound samples: frequency, in units of Hertz [Hz]. This is the number of samples per second. Half of the sample frequency marks the maximum significant frequency component.

AL_FREQUENCY_SHIFTER_DEFAULT_FREQUENCY

OpenAL.Import

AL_FREQUENCY_SHIFTER_DEFAULT_LEFT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_DEFAULT_RIGHT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_DIRECTION_DOWN

OpenAL.Import

AL_FREQUENCY_SHIFTER_DIRECTION_OFF

OpenAL.Import

AL_FREQUENCY_SHIFTER_DIRECTION_UP

OpenAL.Import

AL_FREQUENCY_SHIFTER_FREQUENCY

OpenAL.Import

Frequencyshifter Parameters

AL_FREQUENCY_SHIFTER_LEFT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_MAX_FREQUENCY

OpenAL.Import

AL_FREQUENCY_SHIFTER_MAX_LEFT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_MAX_RIGHT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_MIN_FREQUENCY

OpenAL.Import

AL frequency shifter effect parameter ranges and defaults

AL_FREQUENCY_SHIFTER_MIN_LEFT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_MIN_RIGHT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_RIGHT_DIRECTION

OpenAL.Import

AL_GAIN

OpenAL.Import

Indicate the gain (volume amplification) applied. Type: ALfloat. Range: ]0.0- ] A value of 1.0 means un-attenuated/unchanged. Each division by 2 equals an attenuation of -6dB. Each multiplicaton with 2 equals an amplification of +6dB. A value of 0.0 is meaningless with respect to a logarithmic scale; it is interpreted as zero volume - the channel is effectively disabled.

AL_HIGHPASS_GAIN

OpenAL.Import

Highpass Parameters

AL_HIGHPASS_GAINLF

OpenAL.Import

AL_ILLEGAL_COMMAND

OpenAL.Import

Illegal call.

AL_ILLEGAL_ENUM

OpenAL.Import

Invalid parameter passed to AL call.

AL_INITIAL

OpenAL.Import

AL_INVALID

OpenAL.Import

END EAX Extension bad value

AL_INVALID_ENUM

OpenAL.Import

AL_INVALID_NAME

OpenAL.Import

Invalid Name paramater passed to AL call.

AL_INVALID_OPERATION

OpenAL.Import

AL_INVALID_VALUE

OpenAL.Import

Invalid enum parameter value.

AL_INVERSE_DISTANCE

OpenAL.Import

AL_INVERSE_DISTANCE_CLAMPED

OpenAL.Import

AL_LINEAR_DISTANCE

OpenAL.Import

AL_LINEAR_DISTANCE_CLAMPED

OpenAL.Import

AL_LOOPING

OpenAL.Import

Indicate whether source is looping. Type: ALboolean? Range: [AL_TRUE, AL_FALSE] Default: FALSE.

AL_LOWPASS_GAIN

OpenAL.Import

Filter object definitions to be used with alFilter functions. Lowpass parameters.

AL_LOWPASS_GAINHF

OpenAL.Import

AL_MAX_AIR_ABSORPTION_FACTOR

OpenAL.Import

AL_MAX_AUXILIARY_SEND_FILTER_GAINHF_AUTO

OpenAL.Import

AL_MAX_AUXILIARY_SEND_FILTER_GAIN_AUTO

OpenAL.Import

AL_MAX_CONE_OUTER_GAINHF

OpenAL.Import

AL_MAX_DIRECT_FILTER_GAINHF_AUTO

OpenAL.Import

AL_MAX_DISTANCE

OpenAL.Import

Indicate distance above which sources are not attenuated using the inverse clamped distance model. Default: +inf Type: ALfloat Range: 0.0 - +inf

AL_MAX_GAIN

OpenAL.Import

Indicate maximum source attenuation Type: ALfloat Range: [0.0 - 1.0] Logarthmic

AL_MAX_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_METERS_PER_UNIT

OpenAL.Import

Listener definitions to be used with alListener functions. These values must be unique and not conflict with other al listener values.

AL_MIN_AIR_ABSORPTION_FACTOR

OpenAL.Import

Source parameter value definitions, ranges and defaults.

AL_MIN_AUXILIARY_SEND_FILTER_GAINHF_AUTO

OpenAL.Import

AL_MIN_AUXILIARY_SEND_FILTER_GAIN_AUTO

OpenAL.Import

AL_MIN_CONE_OUTER_GAINHF

OpenAL.Import

AL_MIN_DIRECT_FILTER_GAINHF_AUTO

OpenAL.Import

AL_MIN_GAIN

OpenAL.Import

Indicate minimum source attenuation Type: ALfloat Range: [0.0 - 1.0] Logarthmic

AL_MIN_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_NONE

OpenAL.Import

AL_NO_ERROR

OpenAL.Import

Errors: No Error.

AL_ORIENTATION

OpenAL.Import

Indicate listener orientation. at/up

AL_OUT_OF_MEMORY

OpenAL.Import

No mojo.

AL_PAUSED

OpenAL.Import

AL_PENDING

OpenAL.Import

AL_PITCH

OpenAL.Import

Specify the pitch to be applied, either at source, or on mixer results, at listener. Range: [0.5-2.0] Default: 1.0

AL_PITCH_SHIFTER_COARSE_TUNE

OpenAL.Import

Pitchshifter Parameters

AL_PITCH_SHIFTER_DEFAULT_COARSE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_DEFAULT_FINE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_FINE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_MAX_COARSE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_MAX_FINE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_MIN_COARSE_TUNE

OpenAL.Import

AL pitch shifter effect parameter ranges and defaults

AL_PITCH_SHIFTER_MIN_FINE_TUNE

OpenAL.Import

AL_PLAYING

OpenAL.Import

AL_POSITION

OpenAL.Import

Specify the current location in three dimensional space. OpenAL, like OpenGL, uses a right handed coordinate system, where in a frontal default view X (thumb) points right, Y points up (index finger), and Z points towards the viewer/camera (middle finger). To switch from a left handed coordinate system, flip the sign on the Z coordinate. Listener position is always in the world coordinate system.

AL_PROCESSED

OpenAL.Import

AL_REFERENCE_DISTANCE

OpenAL.Import

source specific reference distance Type: ALfloat Range: 0.0 - +inf At 0.0, no distance attenuation occurs. Default is 1.0.

AL_RENDERER

OpenAL.Import

AL_REVERB_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_REVERB_DECAY_HFLIMIT

OpenAL.Import

AL_REVERB_DECAY_HFRATIO

OpenAL.Import

AL_REVERB_DECAY_TIME

OpenAL.Import

AL_REVERB_DEFAULT_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_REVERB_DEFAULT_DECAY_HFLIMIT

OpenAL.Import

AL_REVERB_DEFAULT_DECAY_HFRATIO

OpenAL.Import

AL_REVERB_DEFAULT_DECAY_TIME

OpenAL.Import

AL_REVERB_DEFAULT_DENSITY

OpenAL.Import

AL_REVERB_DEFAULT_DIFFUSION

OpenAL.Import

AL_REVERB_DEFAULT_GAIN

OpenAL.Import

AL_REVERB_DEFAULT_GAINHF

OpenAL.Import

AL_REVERB_DEFAULT_LATE_REVERB_DELAY

OpenAL.Import

AL_REVERB_DEFAULT_LATE_REVERB_GAIN

OpenAL.Import

AL_REVERB_DEFAULT_REFLECTIONS_DELAY

OpenAL.Import

AL_REVERB_DEFAULT_REFLECTIONS_GAIN

OpenAL.Import

AL_REVERB_DEFAULT_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_REVERB_DENSITY

OpenAL.Import

Effect object definitions to be used with alEffect functions. Effect parameter value definitions, ranges, and defaults appear farther down in this file. Reverb Parameters

AL_REVERB_DIFFUSION

OpenAL.Import

AL_REVERB_GAIN

OpenAL.Import

AL_REVERB_GAINHF

OpenAL.Import

AL_REVERB_LATE_REVERB_DELAY

OpenAL.Import

AL_REVERB_LATE_REVERB_GAIN

OpenAL.Import

AL_REVERB_MAX_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_REVERB_MAX_DECAY_HFLIMIT

OpenAL.Import

AL_REVERB_MAX_DECAY_HFRATIO

OpenAL.Import

AL_REVERB_MAX_DECAY_TIME

OpenAL.Import

AL_REVERB_MAX_DENSITY

OpenAL.Import

AL_REVERB_MAX_DIFFUSION

OpenAL.Import

AL_REVERB_MAX_GAIN

OpenAL.Import

AL_REVERB_MAX_GAINHF

OpenAL.Import

AL_REVERB_MAX_LATE_REVERB_DELAY

OpenAL.Import

AL_REVERB_MAX_LATE_REVERB_GAIN

OpenAL.Import

AL_REVERB_MAX_REFLECTIONS_DELAY

OpenAL.Import

AL_REVERB_MAX_REFLECTIONS_GAIN

OpenAL.Import

AL_REVERB_MAX_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_REVERB_MIN_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_REVERB_MIN_DECAY_HFLIMIT

OpenAL.Import

AL_REVERB_MIN_DECAY_HFRATIO

OpenAL.Import

AL_REVERB_MIN_DECAY_TIME

OpenAL.Import

AL_REVERB_MIN_DENSITY

OpenAL.Import

Effect parameter structures, value definitions, ranges and defaults. AL reverb effect parameter ranges and defaults

AL_REVERB_MIN_DIFFUSION

OpenAL.Import

AL_REVERB_MIN_GAIN

OpenAL.Import

AL_REVERB_MIN_GAINHF

OpenAL.Import

AL_REVERB_MIN_LATE_REVERB_DELAY

OpenAL.Import

AL_REVERB_MIN_LATE_REVERB_GAIN

OpenAL.Import

AL_REVERB_MIN_REFLECTIONS_DELAY

OpenAL.Import

AL_REVERB_MIN_REFLECTIONS_GAIN

OpenAL.Import

AL_REVERB_MIN_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_REVERB_REFLECTIONS_DELAY

OpenAL.Import

AL_REVERB_REFLECTIONS_GAIN

OpenAL.Import

AL_REVERB_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_RING_MODULATOR_DEFAULT_FREQUENCY

OpenAL.Import

AL_RING_MODULATOR_DEFAULT_HIGHPASS_CUTOFF

OpenAL.Import

AL_RING_MODULATOR_DEFAULT_WAVEFORM

OpenAL.Import

AL_RING_MODULATOR_FREQUENCY

OpenAL.Import

Ringmodulator Parameters

AL_RING_MODULATOR_HIGHPASS_CUTOFF

OpenAL.Import

AL_RING_MODULATOR_MAX_FREQUENCY

OpenAL.Import

AL_RING_MODULATOR_MAX_HIGHPASS_CUTOFF

OpenAL.Import

AL_RING_MODULATOR_MAX_WAVEFORM

OpenAL.Import

AL_RING_MODULATOR_MIN_FREQUENCY

OpenAL.Import

AL ring modulator effect parameter ranges and defaults

AL_RING_MODULATOR_MIN_HIGHPASS_CUTOFF

OpenAL.Import

AL_RING_MODULATOR_MIN_WAVEFORM

OpenAL.Import

AL_RING_MODULATOR_SAWTOOTH

OpenAL.Import

AL_RING_MODULATOR_SINUSOID

OpenAL.Import

AL_RING_MODULATOR_SQUARE

OpenAL.Import

AL_RING_MODULATOR_WAVEFORM

OpenAL.Import

AL_ROLLOFF_FACTOR

OpenAL.Import

source specific rolloff factor Type: ALfloat Range: 0.0 - +inf

AL_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_SAMPLE_OFFSET

OpenAL.Import

AL_SEC_OFFSET

OpenAL.Import

Source buffer position information

AL_SIZE

OpenAL.Import

AL_SOURCE_ABSOLUTE

OpenAL.Import

Indicate the type of AL_SOURCE. Sources can be spatialized AL_SOURCE_TYPE = $200; Indicate source has absolute coordinates.

AL_SOURCE_RELATIVE

OpenAL.Import

Indicate Source has relative coordinates.

AL_SOURCE_STATE

OpenAL.Import

Source state information.

AL_SOURCE_TYPE

OpenAL.Import

Source type (Static, Streaming or undetermined) Source is Static if a Buffer has been attached using AL_BUFFER Source is Streaming if one or more Buffers have been attached using alSourceQueueBuffers Source is undetermined when it has the NULL buffer attached

AL_SPEED_OF_SOUND

OpenAL.Import

Speed of Sound in units per second

AL_STATIC

OpenAL.Import

AL_STOPPED

OpenAL.Import

AL_STREAMING

OpenAL.Import

AL_TRUE

OpenAL.Import

Boolean True.

AL_UNDETERMINED

OpenAL.Import

AL_UNUSED

OpenAL.Import

AL_DATA =$2005; Buffer state. Not supported for public use (yet).

AL_VELOCITY

OpenAL.Import

Specify the current velocity in three dimensional space.

AL_VENDOR

OpenAL.Import

Context strings: Vendor Name.

AL_VERSION

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_RATE

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_WAVEFORM

OpenAL.Import

AL_VOCAL_MORPHER_MAX_PHONEMEA

OpenAL.Import

AL_VOCAL_MORPHER_MAX_PHONEMEA_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_MAX_PHONEMEB

OpenAL.Import

AL_VOCAL_MORPHER_MAX_PHONEMEB_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_MAX_RATE

OpenAL.Import

AL_VOCAL_MORPHER_MAX_WAVEFORM

OpenAL.Import

AL_VOCAL_MORPHER_MIN_PHONEMEA

OpenAL.Import

AL vocal morpher effect parameter ranges and defaults

AL_VOCAL_MORPHER_MIN_PHONEMEA_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_MIN_PHONEMEB

OpenAL.Import

AL_VOCAL_MORPHER_MIN_PHONEMEB_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_MIN_RATE

OpenAL.Import

AL_VOCAL_MORPHER_MIN_WAVEFORM

OpenAL.Import

AL_VOCAL_MORPHER_PHONEMEA

OpenAL.Import

Vocalmorpher Parameters

AL_VOCAL_MORPHER_PHONEMEA_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_PHONEMEB

OpenAL.Import

AL_VOCAL_MORPHER_PHONEMEB_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_A

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_AA

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_AE

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_AH

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_AO

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_B

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_D

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_E

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_EH

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_ER

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_F

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_G

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_I

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_IH

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_IY

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_J

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_K

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_L

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_M

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_N

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_O

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_P

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_R

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_S

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_T

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_U

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_UH

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_UW

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_V

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_Z

OpenAL.Import

AL_VOCAL_MORPHER_RATE

OpenAL.Import

AL_VOCAL_MORPHER_WAVEFORM

OpenAL.Import

AL_VOCAL_MORPHER_WAVEFORM_SAWTOOTH

OpenAL.Import

AL_VOCAL_MORPHER_WAVEFORM_SINUSOID

OpenAL.Import

AL_VOCAL_MORPHER_WAVEFORM_TRIANGLE

OpenAL.Import

AMBIENT_LIGHT

Formats.m3DSConst

AMBIENT_NODE_TAG

Formats.m3DSConst

ATKEY1

Formats.m3DSConst

ATKEY2

Formats.m3DSConst

ATKEY3

Formats.m3DSConst

ATKEY4

Formats.m3DSConst

ATKEY5

Formats.m3DSConst

ATKEYFLAGS

Formats.m3DSConst

AUDIO_F32

SDL.Import

**< As above, but big-endian byte order *

AUDIO_F32LSB

SDL.Import

** * float32 support *

AUDIO_F32MSB

SDL.Import

**< 32-bit floating point samples *

AUDIO_S16

SDL.Import

AUDIO_S16LSB

SDL.Import

**< Unsigned 16-bit samples *

AUDIO_S16MSB

SDL.Import

**< As above, but big-endian byte order *

AUDIO_S32

SDL.Import

**< As above, but big-endian byte order *

AUDIO_S32LSB

SDL.Import

** * int32 support *

AUDIO_S32MSB

SDL.Import

**< 32-bit integer samples *

AUDIO_S8

SDL.Import

**< Unsigned 8-bit samples *

AUDIO_U16

SDL.Import

**< As above, but big-endian byte order *

AUDIO_U16LSB

SDL.Import

**< Signed 8-bit samples *

AUDIO_U16MSB

SDL.Import

**< Signed 16-bit samples *

AUDIO_U8

SDL.Import

** * Audio format flags * * Defaults to LSB byte order. *

AutoCreateHooks

gnugettext

This function will turn resourcestring hooks on or off, eventually with BPL file support. Please do not activate BPL file support when the package is in design mode.

AVICOMPRESSF_DATARATE

Formats.VFW

interleave

AVICOMPRESSF_INTERLEAVE

Formats.VFW

Defines for the dwFlags field of the AVICOMPRESSOPTIONS struct Each of these flags determines if the appropriate field in the structure (dwInterleaveEvery, dwBytesPerSecond, and dwKeyFrameEvery) is payed attention to. See the autodoc in avisave.c for details.

AVICOMPRESSF_KEYFRAMES

Formats.VFW

use a data rate

AVICOMPRESSF_VALID

Formats.VFW

use keyframes

AVIERR_BADFLAGS

Formats.VFW

MAKE_AVIERR(104)

AVIERR_BADFORMAT

Formats.VFW

MAKE_AVIERR(101)

AVIERR_BADHANDLE

Formats.VFW

MAKE_AVIERR(107)

AVIERR_BADPARAM

Formats.VFW

MAKE_AVIERR(105)

AVIERR_BADSIZE

Formats.VFW

MAKE_AVIERR(106)

AVIERR_BUFFERTOOSMALL

Formats.VFW

MAKE_AVIERR(115)

AVIERR_CANTCOMPRESS

Formats.VFW

MAKE_AVIERR(116)

AVIERR_COMPRESSOR

Formats.VFW

MAKE_AVIERR(111)

AVIERR_ERROR

Formats.VFW

MAKE_AVIERR(198)

AVIERR_FILEOPEN

Formats.VFW

MAKE_AVIERR(110)

AVIERR_FILEREAD

Formats.VFW

MAKE_AVIERR(108)

AVIERR_FILEWRITE

Formats.VFW

MAKE_AVIERR(109)

AVIERR_INTERNAL

Formats.VFW

MAKE_AVIERR(103)

AVIERR_MEMORY

Formats.VFW

MAKE_AVIERR(102)

AVIERR_NOCOMPRESSOR

Formats.VFW

MAKE_AVIERR(112)

AVIERR_NODATA

Formats.VFW

MAKE_AVIERR(114)

AVIERR_OK

Formats.VFW

– Error handling ———————————————————–

AVIERR_READONLY

Formats.VFW

MAKE_AVIERR(113)

AVIERR_UNSUPPORTED

Formats.VFW

!!! Questions to be answered: How can you get a string form of these errors? Which of these errors should be replaced by errors in SCODE.H?

AVIERR_USERABORT

Formats.VFW

MAKE_AVIERR(117)

AVIFILECAPS_ALLKEYFRAMES

Formats.VFW

AVIFILECAPS_CANREAD

Formats.VFW

– Flags for dwCaps ———————————————————

AVIFILECAPS_CANWRITE

Formats.VFW

AVIFILECAPS_NOCOMPRESSION

Formats.VFW

AVIFILEHANDLER_CANACCEPTNONRGB

Formats.VFW

AVIFILEHANDLER_CANREAD

Formats.VFW

AVIFILEHANDLER_CANWRITE

Formats.VFW

AVIFILEINFO_COPYRIGHTED

Formats.VFW

AVIFILEINFO_HASINDEX

Formats.VFW

– Flags for dwFlags ——————————————————–

AVIFILEINFO_ISINTERLEAVED

Formats.VFW

AVIFILEINFO_MUSTUSEINDEX

Formats.VFW

AVIFILEINFO_WASCAPTUREFILE

Formats.VFW

AVIF_COPYRIGHTED

Formats.VFW

AVIF_HASINDEX

Formats.VFW

– flags for use in <dwFlags> in AVIFileHdr ———————————

AVIF_ISINTERLEAVED

Formats.VFW

AVIF_MUSTUSEINDEX

Formats.VFW

Index at end of file?

AVIF_TRUSTCKTYPE

Formats.VFW

AVIF_WASCAPTUREFILE

Formats.VFW

Use CKType to find key frames?

AVIGETFRAMEF_BESTDISPLAYFMT

Formats.VFW

Ansi - Unicode thunking.
Unicode or Ansi-only apps can call the avifile APIs. any Win32 app who wants to use any of the AVI COM interfaces must be UNICODE - the AVISTREAMINFO and AVIFILEINFO structures used in the Info methods of these interfaces are the unicode variants, and no thunking to or from ansi takes place except in the AVIFILE api entrypoints.
For Ansi/Unicode thunking: for each entrypoint or structure that uses chars or strings, two versions are declared in the Win32 version, ApiNameW and ApiNameA. The default name ApiName is #defined to one or other of these depending on whether UNICODE is defined (during compilation of the app that is including this header). The source will contain ApiName and ApiNameA (with ApiName being the Win16 implementation, and also #defined to ApiNameW, and ApiNameA being the thunk entrypoint).
For GetFrame::SetFormat - use the best format for the display

AVIIF_COMPUSE

Formats.VFW

this frame doesn't take any time

AVIIF_KEYFRAME

Formats.VFW

AVIIF_LIST

Formats.VFW

– Flags for AVI file index ————————————————-

AVIIF_NOTIME

Formats.VFW

– Flags for index ———————————————————-

AVIIF_TWOCC

Formats.VFW

AVISF_DISABLED

Formats.VFW

– Stream header ————————————————————

AVISF_VIDEO_PALCHANGES

Formats.VFW

AVISTREAMINFO_DISABLED

Formats.VFW

AVISTREAMINFO_FORMATCHANGES

Formats.VFW

AVISTREAMREAD_CONVENIENT

Formats.VFW

AVI_HEADERSIZE

Formats.VFW

– The AVI File Header LIST chunk should be padded to this size ————-

AVSTREAMMASTER_AUDIO

Formats.VFW

Since Audio and Video streams generally use non-synchronized capture clocks, this flag determines whether the audio stream is to be considered the master or controlling clock when writing the AVI file:
AVSTREAMMASTER_AUDIO - Audio is master, video frame duration is forced to match audio duration (VFW 1.0, 1.1 default) AVSTREAMMASTER_NONE - No master, audio and video streams may be of different lengths

AVSTREAMMASTER_NONE

Formats.VFW

Audio master (VFW 1.0, 1.1)

BANDPASS_DEFAULT_GAIN

OpenAL.Import

BANDPASS_DEFAULT_GAINHF

OpenAL.Import

BANDPASS_DEFAULT_GAINLF

OpenAL.Import

BANDPASS_MAX_GAIN

OpenAL.Import

BANDPASS_MAX_GAINHF

OpenAL.Import

BANDPASS_MAX_GAINLF

OpenAL.Import

BANDPASS_MIN_GAIN

OpenAL.Import

Bandpass filter

BANDPASS_MIN_GAINHF

OpenAL.Import

BANDPASS_MIN_GAINLF

OpenAL.Import

bassdll

BASS.Import

libraries

BASSVERSION

BASS.Import

BASSVERSIONTEXT

BASS.Import

API version

BASS_3DALG_DEFAULT

BASS.Import

software 3D mixing algorithms (used with BASS_CONFIG_3DALGORITHM)

BASS_3DALG_FULL

BASS.Import

Uses normal left and right panning. The vertical axis is ignored except for scaling of volume due to distance. Doppler shift and volume scaling are still applied, but the 3D filtering is not performed. This is the most CPU efficient software implementation, but provides no virtual 3D audio effect. Head Related Transfer Function processing will not be done. Since only normal stereo panning is used, a channel using this algorithm may be accelerated by a 2D hardware voice if no free 3D hardware voices are available.

BASS_3DALG_LIGHT

BASS.Import

This algorithm gives the highest quality 3D audio effect, but uses more CPU. Requires Windows 98 2nd Edition or Windows 2000 that uses WDM drivers, if this mode is not available then BASS_3DALG_OFF will be used instead.

BASS_3DALG_OFF

BASS.Import

default algorithm (currently translates to BASS_3DALG_OFF)

BASS_3DMODE_NORMAL

BASS.Import

3D channel modes

BASS_3DMODE_OFF

BASS.Import

The channel's 3D position (position/velocity/ orientation) are relative to the listener. When the listener's position/velocity/orientation is changed with BASS_Set3DPosition, the channel's position relative to the listener does not change.

BASS_3DMODE_RELATIVE

BASS.Import

normal 3D processing

BASS_ACTIVE_PAUSED

BASS.Import

BASS_ACTIVE_PAUSED_DEVICE

BASS.Import

BASS_ACTIVE_PLAYING

BASS.Import

BASS_ACTIVE_STALLED

BASS.Import

BASS_ACTIVE_STOPPED

BASS.Import

flag: sync only once, else continuously BASS_ChannelIsActive return values

BASS_ASYNCFILE

BASS.Import

BASS_ATTRIB_BITRATE

BASS.Import

BASS_ATTRIB_BUFFER

BASS.Import

BASS_ATTRIB_CPU

BASS.Import

BASS_ATTRIB_DOWNLOADPROC

BASS.Import

BASS_ATTRIB_EAXMIX

BASS.Import

BASS_ATTRIB_FREQ

BASS.Import

Channel attributes

BASS_ATTRIB_GRANULE

BASS.Import

BASS_ATTRIB_MUSIC_ACTIVE

BASS.Import

BASS_ATTRIB_MUSIC_AMPLIFY

BASS.Import

BASS_ATTRIB_MUSIC_BPM

BASS.Import

BASS_ATTRIB_MUSIC_PANSEP

BASS.Import

BASS_ATTRIB_MUSIC_PSCALER

BASS.Import

BASS_ATTRIB_MUSIC_SPEED

BASS.Import

BASS_ATTRIB_MUSIC_VOL_CHAN

BASS.Import

BASS_ATTRIB_MUSIC_VOL_GLOBAL

BASS.Import

BASS_ATTRIB_MUSIC_VOL_INST

BASS.Import

+ channel #

BASS_ATTRIB_NET_RESUME

BASS.Import

BASS_ATTRIB_NOBUFFER

BASS.Import

BASS_ATTRIB_NORAMP

BASS.Import

BASS_ATTRIB_PAN

BASS.Import

BASS_ATTRIB_PUSH_LIMIT

BASS.Import

BASS_ATTRIB_SCANINFO

BASS.Import

BASS_ATTRIB_SRC

BASS.Import

BASS_ATTRIB_TAIL

BASS.Import

BASS_ATTRIB_USER

BASS.Import

BASS_ATTRIB_VBR

BASS.Import

BASS_ATTRIB_VOL

BASS.Import

BASS_ATTRIB_VOLDSP

BASS.Import

BASS_ATTRIB_VOLDSP_PRIORITY

BASS.Import

BASS_CONFIG_3DALGORITHM

BASS.Import

BASS_CONFIG_AIRPLAY

BASS.Import

BASS_CONFIG_AM_DISABLE

BASS.Import

BASS_CONFIG_ANDROID_AAUDIO

BASS.Import

BASS_CONFIG_ANDROID_JAVAVM

BASS.Import

BASS_CONFIG_ANDROID_SESSIONID

BASS.Import

BASS_CONFIG_ASYNCFILE_BUFFER

BASS.Import

BASS_CONFIG_BUFFER

BASS.Import

some other mystery problem BASS_SetConfig options

BASS_CONFIG_CURVE_PAN

BASS.Import

BASS_CONFIG_CURVE_VOL

BASS.Import

BASS_CONFIG_DEV_BUFFER

BASS.Import

BASS_CONFIG_DEV_DEFAULT

BASS.Import

BASS_CONFIG_DEV_NONSTOP

BASS.Import

BASS_CONFIG_DEV_PERIOD

BASS.Import

BASS_CONFIG_FILENAME

BASS.Import

BASS_CONFIG_FLOAT

BASS.Import

BASS_CONFIG_FLOATDSP

BASS.Import

BASS_CONFIG_GVOL_MUSIC

BASS.Import

BASS_CONFIG_GVOL_SAMPLE

BASS.Import

BASS_CONFIG_GVOL_STREAM

BASS.Import

BASS_CONFIG_HANDLES

BASS.Import

BASS_CONFIG_IOS_MIXAUDIO

BASS.Import

BASS_CONFIG_IOS_NOCATEGORY

BASS.Import

BASS_CONFIG_IOS_SESSION

BASS.Import

BASS_CONFIG_IOS_SPEAKER

BASS.Import

BASS_CONFIG_LIBSSL

BASS.Import

BASS_CONFIG_MF_DISABLE

BASS.Import

BASS_CONFIG_MF_VIDEO

BASS.Import

BASS_CONFIG_MUSIC_VIRTUAL

BASS.Import

BASS_CONFIG_NET_AGENT

BASS.Import

BASS_SetConfigPtr options

BASS_CONFIG_NET_BUFFER

BASS.Import

BASS_CONFIG_NET_META

BASS.Import

BASS_CONFIG_NET_PASSIVE

BASS.Import

BASS_CONFIG_NET_PLAYLIST

BASS.Import

BASS_CONFIG_NET_PLAYLIST_DEPTH

BASS.Import

BASS_CONFIG_NET_PREBUF

BASS.Import

BASS_CONFIG_NET_PREBUF_WAIT

BASS.Import

BASS_CONFIG_NET_PROXY

BASS.Import

BASS_CONFIG_NET_READTIMEOUT

BASS.Import

BASS_CONFIG_NET_RESTRATE

BASS.Import

BASS_CONFIG_NET_SEEK

BASS.Import

BASS_CONFIG_NET_TIMEOUT

BASS.Import

BASS_CONFIG_NORAMP

BASS.Import

BASS_CONFIG_OGG_PRESCAN

BASS.Import

BASS_CONFIG_PAUSE_NOPLAY

BASS.Import

BASS_CONFIG_REC_BUFFER

BASS.Import

BASS_CONFIG_REC_DEFAULT

BASS.Import

BASS_CONFIG_REC_LOOPBACK

BASS.Import

BASS_CONFIG_REC_WASAPI

BASS.Import

BASS_CONFIG_SAMPLE_ONEHANDLE

BASS.Import

BASS_CONFIG_SRC

BASS.Import

BASS_CONFIG_SRC_SAMPLE

BASS.Import

BASS_CONFIG_THREAD

BASS.Import

BASS_CONFIG_UNICODE

BASS.Import

BASS_CONFIG_UPDATEPERIOD

BASS.Import

BASS_CONFIG_UPDATETHREADS

BASS.Import

BASS_CONFIG_VERIFY

BASS.Import

BASS_CONFIG_VERIFY_NET

BASS.Import

BASS_CONFIG_VISTA_SPEAKERS

BASS.Import

BASS_CONFIG_VISTA_TRUEPOS

BASS.Import

BASS_CONFIG_WASAPI_PERSIST

BASS.Import

BASS_CTYPE_MUSIC_IT

BASS.Import

BASS_CTYPE_MUSIC_MO3

BASS.Import

BASS_CTYPE_MUSIC_MOD

BASS.Import

BASS_CTYPE_MUSIC_MTM

BASS.Import

BASS_CTYPE_MUSIC_S3M

BASS.Import

BASS_CTYPE_MUSIC_XM

BASS.Import

BASS_CTYPE_RECORD

BASS.Import

BASS_CTYPE_SAMPLE

BASS.Import

BASS_CHANNELINFO types

BASS_CTYPE_STREAM

BASS.Import

BASS_CTYPE_STREAM_AIFF

BASS.Import

BASS_CTYPE_STREAM_AM

BASS.Import

BASS_CTYPE_STREAM_CA

BASS.Import

BASS_CTYPE_STREAM_DEVICE

BASS.Import

BASS_CTYPE_STREAM_DUMMY

BASS.Import

BASS_CTYPE_STREAM_MF

BASS.Import

BASS_CTYPE_STREAM_MP1

BASS.Import

BASS_CTYPE_STREAM_MP2

BASS.Import

BASS_CTYPE_STREAM_MP3

BASS.Import

BASS_CTYPE_STREAM_OGG

BASS.Import

BASS_CTYPE_STREAM_SAMPLE

BASS.Import

BASS_CTYPE_STREAM_VORBIS

BASS.Import

BASS_CTYPE_STREAM_WAV

BASS.Import

BASS_CTYPE_STREAM_WAV_FLOAT

BASS.Import

BASS_CTYPE_STREAM_WAV_PCM

BASS.Import

WAVE flag (LOWORD=codec)

BASS_DATA_AVAILABLE

BASS.Import

BASS_ChannelGetData flags

BASS_DATA_FFT1024

BASS.Import

512 FFT

BASS_DATA_FFT16384

BASS.Import

8192 FFT

BASS_DATA_FFT2048

BASS.Import

1024 FFT

BASS_DATA_FFT256

BASS.Import

flag: return floating-point sample data

BASS_DATA_FFT32768

BASS.Import

16384 FFT

BASS_DATA_FFT4096

BASS.Import

2048 FFT

BASS_DATA_FFT512

BASS.Import

256 sample FFT

BASS_DATA_FFT8192

BASS.Import

4096 FFT

BASS_DATA_FFT_COMPLEX

BASS.Import

FFT flag: pre-remove DC bias

BASS_DATA_FFT_INDIVIDUAL

BASS.Import

32768 FFT

BASS_DATA_FFT_NOWINDOW

BASS.Import

FFT flag: FFT for each channel, else all combined

BASS_DATA_FFT_NYQUIST

BASS.Import

FFT flag: return complex data

BASS_DATA_FFT_REMOVEDC

BASS.Import

FFT flag: no Hanning window

BASS_DATA_FIXED

BASS.Import

flag: don't remove data from recording buffer

BASS_DATA_FLOAT

BASS.Import

unused

BASS_DATA_NOREMOVE

BASS.Import

query how much data is buffered

BASS_DEVICES_AIRPLAY

BASS.Import

BASS_GetDeviceInfo flags

BASS_DEVICE_16BITS

BASS.Import

unused

BASS_DEVICE_3D

BASS.Import

mono

BASS_DEVICE_8BITS

BASS.Import

BASS_Init flags

BASS_DEVICE_AUDIOTRACK

BASS.Import

limit output to stereo

BASS_DEVICE_CPSPEAKERS

BASS.Import

unused

BASS_DEVICE_DEFAULT

BASS.Import

BASS_DEVICE_DEFAULTCOM

BASS.Import

BASS_DEVICE_DMIX

BASS.Import

ignore speaker arrangement

BASS_DEVICE_DSOUND

BASS.Import

use AudioTrack output

BASS_DEVICE_ENABLED

BASS.Import

IDirectSound3DListener BASS_DEVICEINFO flags

BASS_DEVICE_FREQ

BASS.Import

use ALSA "dmix" plugin

BASS_DEVICE_INIT

BASS.Import

BASS_DEVICE_LATENCY

BASS.Import

reinitialize

BASS_DEVICE_LOOPBACK

BASS.Import

BASS_DEVICE_MONO

BASS.Import

unused

BASS_DEVICE_NOSPEAKER

BASS.Import

force enabling of speaker assignment

BASS_DEVICE_REINIT

BASS.Import

limit output to 16-bit

BASS_DEVICE_SOFTWARE

BASS.Import

use DirectSound output

BASS_DEVICE_SPEAKERS

BASS.Import

unused

BASS_DEVICE_STEREO

BASS.Import

set device sample rate

BASS_DEVICE_TYPE_DIGITAL

BASS.Import

BASS_DEVICE_TYPE_DISPLAYPORT

BASS.Import

BASS_DEVICE_TYPE_HANDSET

BASS.Import

BASS_DEVICE_TYPE_HDMI

BASS.Import

BASS_DEVICE_TYPE_HEADPHONES

BASS.Import

BASS_DEVICE_TYPE_HEADSET

BASS.Import

BASS_DEVICE_TYPE_LINE

BASS.Import

BASS_DEVICE_TYPE_MASK

BASS.Import

BASS_DEVICE_TYPE_MICROPHONE

BASS.Import

BASS_DEVICE_TYPE_NETWORK

BASS.Import

BASS_DEVICE_TYPE_SPDIF

BASS.Import

BASS_DEVICE_TYPE_SPEAKERS

BASS.Import

BASS_DX8_PHASE_180

BASS.Import

BASS_DX8_PHASE_90

BASS.Import

BASS_DX8_PHASE_NEG_180

BASS.Import

BASS_DX8_PHASE_NEG_90

BASS.Import

BASS_DX8_PHASE_ZERO

BASS.Import

BASS_ERROR_ALREADY

BASS.Import

device needs to be reinitialized

BASS_ERROR_BUFLOST

BASS.Import

can't find a free sound driver

BASS_ERROR_BUSY

BASS.Import

the channel/file has ended

BASS_ERROR_CODEC

BASS.Import

invalid BASS version (used by add-ons)

BASS_ERROR_CREATE

BASS.Import

no internet connection could be opened

BASS_ERROR_DECODE

BASS.Import

requested data/action is not available

BASS_ERROR_DENIED

BASS.Import

unsupported protocol

BASS_ERROR_DEVICE

BASS.Import

no EAX support

BASS_ERROR_DRIVER

BASS.Import

can't open the file

BASS_ERROR_DX

BASS.Import

the channel is/isn't a "decoding channel"

BASS_ERROR_EMPTY

BASS.Import

no hardware voices available

BASS_ERROR_ENDED

BASS.Import

codec is not available/supported

BASS_ERROR_FILEFORM

BASS.Import

connection timedout

BASS_ERROR_FILEOPEN

BASS.Import

memory error

BASS_ERROR_FORMAT

BASS.Import

invalid handle

BASS_ERROR_FREQ

BASS.Import

not playing

BASS_ERROR_HANDLE

BASS.Import

the sample buffer was lost

BASS_ERROR_ILLPARAM

BASS.Import

an illegal type was specified

BASS_ERROR_ILLTYPE

BASS.Import

can't get a free channel

BASS_ERROR_INIT

BASS.Import

invalid position

BASS_ERROR_MEM

BASS.Import

all is OK

BASS_ERROR_NO3D

BASS.Import

an illegal parameter was specified

BASS_ERROR_NOCHAN

BASS.Import

file does not contain audio

BASS_ERROR_NOEAX

BASS.Import

no 3D support

BASS_ERROR_NOFX

BASS.Import

couldn't create the file

BASS_ERROR_NOHW

BASS.Import

the stream is not a file stream

BASS_ERROR_NONET

BASS.Import

the file has no sample data

BASS_ERROR_NOPLAY

BASS.Import

illegal device number

BASS_ERROR_NOTAUDIO

BASS.Import

already initialized/paused/whatever

BASS_ERROR_NOTAVAIL

BASS.Import

effects are not available

BASS_ERROR_NOTFILE

BASS.Import

illegal sample rate

BASS_ERROR_POSITION

BASS.Import

unsupported sample format

BASS_ERROR_PROTOCOL

BASS.Import

unstreamable file

BASS_ERROR_REINIT

BASS.Import

SSL/HTTPS support isn't available

BASS_ERROR_SPEAKER

BASS.Import

unsupported file format

BASS_ERROR_SSL

BASS.Import

BASS_Start has not been successfully called

BASS_ERROR_START

BASS.Import

BASS_Init has not been successfully called

BASS_ERROR_TIMEOUT

BASS.Import

a sufficient DirectX version is not installed

BASS_ERROR_UNKNOWN

BASS.Import

access denied

BASS_ERROR_UNSTREAMABLE

BASS.Import

the device is busy

BASS_ERROR_VERSION

BASS.Import

unavailable speaker

BASS_FILEDATA_END

BASS.Import

BASS_StreamPutFileData options

BASS_FILEPOS_ASYNCBUF

BASS.Import

BASS_FILEPOS_AVAILABLE

BASS.Import

BASS_FILEPOS_BUFFER

BASS.Import

BASS_FILEPOS_BUFFERING

BASS.Import

BASS_FILEPOS_CONNECTED

BASS.Import

BASS_FILEPOS_CURRENT

BASS.Import

end & close the file BASS_StreamGetFilePosition modes

BASS_FILEPOS_DECODE

BASS.Import

BASS_FILEPOS_DOWNLOAD

BASS.Import

BASS_FILEPOS_END

BASS.Import

BASS_FILEPOS_SIZE

BASS.Import

BASS_FILEPOS_SOCKET

BASS.Import

BASS_FILEPOS_START

BASS.Import

BASS_FX_DX8_CHORUS

BASS.Import

BASS_ChannelSetFX effect types

BASS_FX_DX8_COMPRESSOR

BASS.Import

BASS_FX_DX8_DISTORTION

BASS.Import

BASS_FX_DX8_ECHO

BASS.Import

BASS_FX_DX8_FLANGER

BASS.Import

BASS_FX_DX8_GARGLE

BASS.Import

BASS_FX_DX8_I3DL2REVERB

BASS.Import

BASS_FX_DX8_PARAMEQ

BASS.Import

BASS_FX_DX8_REVERB

BASS.Import

BASS_FX_VOLUME

BASS.Import

BASS_INPUT_OFF

BASS.Import

BASS_RecordSetInput flags

BASS_INPUT_ON

BASS.Import

BASS_INPUT_TYPE_ANALOG

BASS.Import

BASS_INPUT_TYPE_AUX

BASS.Import

BASS_INPUT_TYPE_CD

BASS.Import

BASS_INPUT_TYPE_DIGITAL

BASS.Import

BASS_INPUT_TYPE_LINE

BASS.Import

BASS_INPUT_TYPE_MASK

BASS.Import

BASS_INPUT_TYPE_MIC

BASS.Import

BASS_INPUT_TYPE_PHONE

BASS.Import

BASS_INPUT_TYPE_SPEAKER

BASS.Import

BASS_INPUT_TYPE_SYNTH

BASS.Import

BASS_INPUT_TYPE_UNDEF

BASS.Import

BASS_INPUT_TYPE_WAVE

BASS.Import

BASS_IOS_SESSION_AIRPLAY

BASS.Import

BASS_IOS_SESSION_AMBIENT

BASS.Import

BASS_IOS_SESSION_BTA2DP

BASS.Import

BASS_IOS_SESSION_BTHFP

BASS.Import

BASS_IOS_SESSION_DEACTIVATE

BASS.Import

BASS_IOS_SESSION_DISABLE

BASS.Import

BASS_IOS_SESSION_DUCK

BASS.Import

BASS_IOS_SESSION_MIX

BASS.Import

flag: thread-specific setting BASS_CONFIG_IOS_SESSION flags

BASS_IOS_SESSION_SPEAKER

BASS.Import

BASS_LEVEL_MONO

BASS.Import

FFT flag: return extra Nyquist value BASS_ChannelGetLevelEx flags

BASS_LEVEL_NOREMOVE

BASS.Import

apply VOL/PAN attributes to the levels

BASS_LEVEL_RMS

BASS.Import

get stereo level

BASS_LEVEL_STEREO

BASS.Import

get mono level

BASS_LEVEL_VOLPAN

BASS.Import

get RMS levels

BASS_MP3_IGNOREDELAY

BASS.Import

give server status info (HTTP/ICY tags) in DOWNLOADPROC

BASS_MP3_SETPOS

BASS.Import

ignore LAME/Xing/VBRI/iTunes delay & padding info

BASS_MUSIC_3D

BASS.Import

BASS_MUSIC_AUTOFREE

BASS.Import

BASS_MUSIC_CALCLEN

BASS.Import

calculate playback length

BASS_MUSIC_DECODE

BASS.Import

BASS_MUSIC_FLOAT

BASS.Import

BASS_MUSIC_FT2MOD

BASS.Import

apply FastTracker 2 panning to XM files

BASS_MUSIC_FT2PAN

BASS.Import

surround sound (mode 2)

BASS_MUSIC_FX

BASS.Import

BASS_MUSIC_LOOP

BASS.Import

BASS_MUSIC_MONO

BASS.Import

BASS_MUSIC_NONINTER

BASS.Import

play .MOD as ProTracker 1 does

BASS_MUSIC_NOSAMPLE

BASS.Import

stop the music on a backwards jump effect

BASS_MUSIC_POSRESET

BASS.Import

sinc interpolated sample mixing

BASS_MUSIC_POSRESETEX

BASS.Import

stop all notes when moving position

BASS_MUSIC_PRESCAN

BASS.Import

BASS_MUSIC_PT1MOD

BASS.Import

play .MOD as FastTracker 2 does

BASS_MUSIC_RAMP

BASS.Import

BASS_MUSIC_RAMPS

BASS.Import

normal ramping

BASS_MUSIC_SINCINTER

BASS.Import

non-interpolated sample mixing

BASS_MUSIC_STOPBACK

BASS.Import

stop all notes and reset bmp/etc when moving position

BASS_MUSIC_SURROUND

BASS.Import

sensitive ramping

BASS_MUSIC_SURROUND2

BASS.Import

surround sound

BASS_NODEVICE

BASS.Import

flag: scan to the position BASS_ChannelSetDevice/GetDevice option

BASS_OBJECT_DS

BASS.Import

disable hardware/fastpath output DirectSound interfaces (for use with BASS_GetDSoundObject)

BASS_OBJECT_DS3DL

BASS.Import

IDirectSound

BASS_OK

BASS.Import

-1 (QWORD) Error codes returned by BASS_ErrorGetCode()

BASS_ORIGRES_FLOAT

BASS.Import

BASS_PLUGIN_PROC

BASS.Import

MO3 flag BASS_PluginLoad flags

BASS_POS_BYTE

BASS.Import

+ sample #, MOD sample name : ANSI string BASS_ChannelGetLength/GetPosition/SetPosition modes

BASS_POS_DECODE

BASS.Import

flag: allow seeking to inexact position

BASS_POS_DECODETO

BASS.Import

flag: get the decoding (not playing) position

BASS_POS_END

BASS.Import

OGG bitstream number

BASS_POS_FLUSH

BASS.Import

loop start positiom

BASS_POS_INEXACT

BASS.Import

flag: seek relative to the current position

BASS_POS_LOOP

BASS.Import

trimmed end position

BASS_POS_MUSIC_ORDER

BASS.Import

byte position

BASS_POS_OGG

BASS.Import

order.row position, MAKELONG(order,row)

BASS_POS_RELATIVE

BASS.Import

flag: reset user file buffers

BASS_POS_RESET

BASS.Import

flag: flush decoder/FX buffers

BASS_POS_SCAN

BASS.Import

flag: decode to the position instead of seeking

BASS_RECORD_PAUSE

BASS.Import

BASS_SAMPLE_3D

BASS.Import

looped

BASS_SAMPLE_8BITS

BASS.Import

WAVE_FORMAT_1M08 = $00000001; // 11.025 kHz, Mono, 8-bit WAVE_FORMAT_1S08 = $00000002; // 11.025 kHz, Stereo, 8-bit WAVE_FORMAT_1M16 = $00000004; // 11.025 kHz, Mono, 16-bit WAVE_FORMAT_1S16 = $00000008; // 11.025 kHz, Stereo, 16-bit WAVE_FORMAT_2M08 = $00000010; // 22.05 kHz, Mono, 8-bit WAVE_FORMAT_2S08 = $00000020; // 22.05 kHz, Stereo, 8-bit WAVE_FORMAT_2M16 = $00000040; // 22.05 kHz, Mono, 16-bit WAVE_FORMAT_2S16 = $00000080; // 22.05 kHz, Stereo, 16-bit WAVE_FORMAT_4M08 = $00000100; // 44.1 kHz, Mono, 8-bit WAVE_FORMAT_4S08 = $00000200; // 44.1 kHz, Stereo, 8-bit WAVE_FORMAT_4M16 = $00000400; // 44.1 kHz, Mono, 16-bit WAVE_FORMAT_4S16 = $00000800; // 44.1 kHz, Stereo, 16-bit

BASS_SAMPLE_FLOAT

BASS.Import

8 bit

BASS_SAMPLE_FX

BASS.Import

unused

BASS_SAMPLE_LOOP

BASS.Import

mono

BASS_SAMPLE_MONO

BASS.Import

32 bit floating-point

BASS_SAMPLE_MUTEMAX

BASS.Import

unused

BASS_SAMPLE_OVER_DIST

BASS.Import

override longest playing

BASS_SAMPLE_OVER_POS

BASS.Import

override lowest volume

BASS_SAMPLE_OVER_VOL

BASS.Import

unused

BASS_SAMPLE_SOFTWARE

BASS.Import

3D functionality

BASS_SAMPLE_VAM

BASS.Import

mute at max distance (3D only)

BASS_SLIDE_LOG

BASS.Import

+ instrument # BASS_ChannelSlideAttribute flags

BASS_SPEAKER_CENLFE

BASS.Import

rear speakers

BASS_SPEAKER_CENTER

BASS.Import

BASS_SPEAKER_FRONT

BASS.Import

don't load the samples Speaker assignment flags

BASS_SPEAKER_FRONTLEFT

BASS.Import

modifier: right

BASS_SPEAKER_FRONTRIGHT

BASS.Import

BASS_SPEAKER_LEFT

BASS.Import

side speakers (7.1)

BASS_SPEAKER_LFE

BASS.Import

BASS_SPEAKER_REAR

BASS.Import

front speakers

BASS_SPEAKER_REAR2

BASS.Import

BASS_SPEAKER_REAR2LEFT

BASS.Import

BASS_SPEAKER_REAR2RIGHT

BASS.Import

BASS_SPEAKER_REARLEFT

BASS.Import

BASS_SPEAKER_REARRIGHT

BASS.Import

BASS_SPEAKER_RIGHT

BASS.Import

modifier: left

BASS_SPEAKER_SIDE

BASS.Import

center & LFE speakers (5.1)

BASS_SPEAKER_SIDELEFT

BASS.Import

BASS_SPEAKER_SIDERIGHT

BASS.Import

BASS_STREAMPROC_END

BASS.Import

BASS_STREAM_AUTOFREE

BASS.Import

scan file for accurate seeking and length

BASS_STREAM_BLOCK

BASS.Import

restrict the download rate of internet file streams

BASS_STREAM_DECODE

BASS.Import

download/play internet file stream in small blocks

BASS_STREAM_PRESCAN

BASS.Import

override furthest from listener (3D only)

BASS_STREAM_RESTRATE

BASS.Import

automatically free the stream when it stops/ends

BASS_STREAM_STATUS

BASS.Import

don't play the stream, only decode

BASS_SYNC_DEV_FAIL

BASS.Import

BASS_SYNC_DEV_FORMAT

BASS.Import

BASS_SYNC_DOWNLOAD

BASS.Import

Sync when playback has stalled. param: not used data : 0=stalled, 1=resumed

BASS_SYNC_END

BASS.Import

Sync when a channel reaches a position. param: position in bytes data : not used

BASS_SYNC_FREE

BASS.Import

Sync when downloading of an internet (or "buffered" user file) stream has ended. param: not used data : not used

BASS_SYNC_META

BASS.Import

Sync when a channel reaches the end. param: not used data : not used

BASS_SYNC_MIXTIME

BASS.Import

flag: call sync in other thread

BASS_SYNC_MUSICFX

BASS.Import

Sync when an instrument (sample for the non-instrument based formats) is played in a MOD music (not including retrigs). param: LOWORD=instrument (1=first) HIWORD=note (0=c0...119=b9, -1=all) data : LOWORD=note HIWORD=volume (0-64)

BASS_SYNC_MUSICINST

BASS.Import

Sync when a MOD music reaches an order:row position. param: LOWORD=order (0=first, -1=all) HIWORD=row (0=first, -1=all) data : LOWORD=order HIWORD=row

BASS_SYNC_MUSICPOS

BASS.Import

Sync when a channel's position is set. param: not used data : 0 = playback buffer not flushed, 1 = playback buffer flushed

BASS_SYNC_OGG_CHANGE

BASS.Import

Sync when the "sync" effect (XM/MTM/MOD: E8x/Wxx, IT/S3M: S2x) is used. param: 0:data=pos, 1:data="x" value data : param=0: LOWORD=order HIWORD=row, param=1: "x" value

BASS_SYNC_ONETIME

BASS.Import

flag: sync at mixtime, else at playtime

BASS_SYNC_POS

BASS.Import

Sync types (with BASS_ChannelSetSync() "param" and SYNCPROC "data" definitions) & flags.

BASS_SYNC_SETPOS

BASS.Import

Sync when a channel is freed. param: not used data : not used

BASS_SYNC_SLIDE

BASS.Import

Sync when metadata is received in a stream. param: not used data : pointer to the metadata

BASS_SYNC_STALL

BASS.Import

Sync when an attribute slide is completed. param: not used data : the type of slide completed (one of the BASS_SLIDE_xxx values)

BASS_SYNC_THREAD

BASS.Import

BASS_TAG_AM_MIME

BASS.Import

ID3v2 tags (2nd block) : variable length block

BASS_TAG_AM_NAME

BASS.Import

WAVE format : WAVEFORMATEEX structure

BASS_TAG_APE

BASS.Import

ICY metadata : ANSI string

BASS_TAG_APE_BINARY

BASS.Import

RIFF "smpl" chunk : TAG_SMPL structure

BASS_TAG_CA_CODEC

BASS.Import

Lyric3v2 tag : ASCII string

BASS_TAG_HTTP

BASS.Import

OGG comments : series of null-terminated UTF-8 strings

BASS_TAG_ICY

BASS.Import

HTTP headers : series of null-terminated ASCII strings

BASS_TAG_ID3

BASS.Import

don't remove data from recording buffer BASS_ChannelGetTags types : what's returned

BASS_TAG_ID3V2

BASS.Import

ID3v1 tags : TAG_ID3 structure

BASS_TAG_ID3V2_2

BASS.Import

Android Media codec name : ASCII string

BASS_TAG_LOCATION

BASS.Import

Android Media MIME type : ASCII string

BASS_TAG_LYRICS3

BASS.Import

OGG encoder : UTF-8 string

BASS_TAG_META

BASS.Import

ICY headers : series of null-terminated ANSI strings

BASS_TAG_MF

BASS.Import

CoreAudio codec info : TAG_CA_CODEC structure

BASS_TAG_MP4

BASS.Import

APEv2 tags : series of null-terminated UTF-8 strings

BASS_TAG_MUSIC_AUTH

BASS.Import

MOD order list : BYTE array of pattern numbers

BASS_TAG_MUSIC_CHAN

BASS.Import

+ instrument #, MOD instrument name : ANSI string

BASS_TAG_MUSIC_INST

BASS.Import

MOD author : UTF-8 string

BASS_TAG_MUSIC_MESSAGE

BASS.Import

MOD music name : ANSI string

BASS_TAG_MUSIC_NAME

BASS.Import

+ index #, binary APEv2 tag : TAG_APE_BINARY structure

BASS_TAG_MUSIC_ORDERS

BASS.Import

MOD message : ANSI string

BASS_TAG_MUSIC_SAMPLE

BASS.Import

+ channel #, MOD channel name : ANSI string

BASS_TAG_OGG

BASS.Import

ID3v2 tags : variable length block

BASS_TAG_RIFF_BEXT

BASS.Import

RIFF "INFO" tags : series of null-terminated ANSI strings

BASS_TAG_RIFF_CART

BASS.Import

RIFF/BWF "bext" tags : TAG_BEXT structure

BASS_TAG_RIFF_CUE

BASS.Import

RIFF "DISP" text tag : ANSI string

BASS_TAG_RIFF_DISP

BASS.Import

RIFF/BWF "cart" tags : TAG_CART structure

BASS_TAG_RIFF_INFO

BASS.Import

redirected URL : ASCII string

BASS_TAG_RIFF_SMPL

BASS.Import

RIFF "cue " chunk : TAG_CUE structure

BASS_TAG_VENDOR

BASS.Import

WMA tags : series of null-terminated UTF-8 strings

BASS_TAG_WAVEFORMAT

BASS.Import

Media Foundation tags : series of null-terminated UTF-8 strings

BASS_TAG_WMA

BASS.Import

MP4/iTunes metadata : series of null-terminated UTF-8 strings

BASS_UNICODE

BASS.Import

BASS_VAM_HARDWARE

BASS.Import

start recording paused DX7 voice allocation & management flags

BASS_VAM_SOFTWARE

BASS.Import

Play the sample in hardware. If no hardware voices are available then the "play" call will fail

BASS_VAM_TERM_DIST

BASS.Import

If there are no free hardware voices, the buffer to be terminated will be the one with the least time left to play.

BASS_VAM_TERM_PRIO

BASS.Import

If there are no free hardware voices, the buffer to be terminated will be one that was loaded/created with the BASS_SAMPLE_MUTEMAX flag and is beyond it's max distance. If there are no buffers that match this criteria, then the "play" call will fail.

BASS_VAM_TERM_TIME

BASS.Import

These flags enable hardware resource stealing... if the hardware has no available voices, a currently playing buffer will be stopped to make room for the new buffer. NOTE: only samples loaded/created with the BASS_SAMPLE_VAM flag are considered for termination by the DX7 voice management.

BEHAVIOURS_SELECTED

FmSceneEditor

BinormalAttributeName

GLS.Objects

BitMapStrMax3DS

Formats.m3DSConst

inclusive maximum value for shadow filter BITMAP chunk

BIT_MAP

Formats.m3DSConst

BI_1632

Formats.VFW

Handle to an Installable Compressor
this code in biCompression means the DIB must be accesed via 48 bit pointers! using *ONLY* the selector given.

BottomFalloff

Formats.m3DSConst

BOUNDBOX

Formats.m3DSConst

BufSize

GLS.FileOBJ

Load input data in chunks of BufSize Bytes.

c180

GLScene.VectorGeometry

c180divPI

GLScene.VectorGeometry

c2PI

GLScene.VectorGeometry

c360

GLScene.VectorGeometry

c3PIdiv2

GLScene.VectorGeometry

c3PIdiv4

GLScene.VectorGeometry

cAllAttribBits

GLS.State

cAllColorComponents

GLS.State

cAllFrustrumParts

GLS.GeomObjects

callibname

OpenAL.Import

define ALUT to use alut.dll

cAllMeshPrimitive

GLS.State

cAllStatesChanged

GLScene.PipelineTransform

calutlibname

OpenAL.Import

CAMERA_NODE_TAG

Formats.m3DSConst

CAM_RANGES

Formats.m3DSConst

CAM_SEE_CONE

Formats.m3DSConst

cAUToKilometers

GLS.SkyDome

(AU)

CBBBack

GLScene.GeometryBB

CBBBottom

GLScene.GeometryBB

CBBFront

GLScene.GeometryBB

CBBLeft

GLScene.GeometryBB

CBBPlans

GLScene.GeometryBB

CBBRight

GLScene.GeometryBB

CBBTop

GLScene.GeometryBB

cColinearBias

GLScene.VectorGeometry

cDefaultActorOptions

GLS.VectorFileObjects

cDefaultCyborgOptions

GLS.SmartObjects

cDefaultFlareElements

GLS.LensFlare

cDefaultImposterOptions

GLS.Imposter

cDefaultMirrorOptions

GLS.Mirror

cDefaultNormalMapScale

GLS.Texture

cDefaultPointSize

GLS.Objects

cDefaultProxyOptions

GLS.Scene

cDefaultScreenSaverOptions

GLS.ScreenSaver

cDefaultSDLWindowOptions

GLS.SDL.Window

cDefaultShadowPlaneOptions

GLS.ShadowPlane

cDefaultSwizzleVector

GLScene.TextureFormat

cDefaultWaterPlaneOptions

GLS.WaterPlane

cDEFAULT_CONSTRAINT_FRICTION

GLS.VerletTypes

cDEFAULT_TIMER_INTERVAL

GLS.AsyncTimer

CDirPlan

GLScene.GeometryBB

cEarthRadius

GLS.SkyDome

astronomical units to kilometers

cECCloseDistance

GLS.EllipseCollision

CgGLlibrary

Cg.GL

cGLBlendEquationToGLEnum

GLS.State

valid for src only

cGLBlendFunctionToGLEnum

GLS.State

cGLBufferBindingTarget

GLS.State

cGLComparisonFunctionToGLEnum

GLS.State

cGLCullFaceModeToGLEnum

GLS.State

cGLFaceWindingToGLEnum

GLS.State

cGLgsInTypes

GLSL.ShaderParameter

cGLgsOutTypes

GLSL.ShaderParameter

cGLHintToGLEnum

GLS.State

CgLibrary

Cg.Import

cGLLogicOpToGLEnum

GLS.State

cGLPolygonModeToGLEnum

GLS.State

cGLQueryTypeToGLEnum

GLS.State

cGLSLSamplerString

GLSL.ShaderParameter

cGLSLTypeString

GLSL.ShaderParameter

cGLStateToGLEnum

GLS.State

cGLStateTypeToGLEnum

GLS.State

cGLStencilOpToGLEnum

GLS.State

cGLTexTypeToGLEnum

GLS.State

CG_ARRAY_DIMENSIONS_DO_NOT_MATCH_ERROR

Cg.Import

"Cannot bind the given parameters. Array types do not match."

CG_ARRAY_HAS_WRONG_DIMENSION_ERROR

Cg.Import

"Cannot bind the given parameters. Array dimensions do not match."

CG_ARRAY_PARAM_ERROR

Cg.Import

"The dimension value is invalid."

CG_ARRAY_TYPES_DO_NOT_MATCH_ERROR

Cg.Import

"Cannot bind the given parameters. Binding will form a cycle."

CG_BIND_CREATES_CYCLE_ERROR

Cg.Import

"The size value is invalid."

CG_CANNOT_DESTROY_PARAMETER_ERROR

Cg.Import

"The parameter could not be changed to the given variability."

CG_COMPILER_ERROR

Cg.Import

"No error has occurred."

CG_CONFLICTING_PARAMETER_TYPES_ERROR

Cg.Import

"A type being added to the context conflicts with an existing type."

CG_CONFLICTING_TYPES_ERROR

Cg.Import

"Index into the array is out of bounds."

CG_FALSE

Cg.Import

CG_FILE_READ_ERROR

Cg.Import

"The parameter must be a 4x4 matrix type."

CG_FILE_WRITE_ERROR

Cg.Import

"The file could not be read."

CG_GL_FRAGMENT

Cg.GL

CG_GL_MATRIX_IDENTITY

Cg.GL

CG_GL_MATRIX_INVERSE

Cg.GL

CG_GL_MATRIX_INVERSE_TRANSPOSE

Cg.GL

CG_GL_MATRIX_TRANSPOSE

Cg.GL

CG_GL_MODELVIEW_MATRIX

Cg.GL

CG_GL_MODELVIEW_PROJECTION_MATRIX

Cg.GL

CG_GL_PROJECTION_MATRIX

Cg.GL

CG_GL_TEXTURE_MATRIX

Cg.GL

CG_GL_VERTEX

Cg.GL

CG_INVALID_CONTEXT_HANDLE_ERROR

Cg.Import

"Memory allocation failed."

CG_INVALID_DIMENSION_ERROR

Cg.Import

"The variable arguments were specified incorrectly."

CG_INVALID_ENUMERANT_ERROR

Cg.Import

"The parameter is not of matrix type."

CG_INVALID_PARAMETER_ERROR

Cg.Import

"The compile returned an error."

CG_INVALID_PARAMETER_TYPE_ERROR

Cg.Import

"The parameter is not a program parameter."

CG_INVALID_PARAMETER_VARIABILITY_ERROR

Cg.Import

"The parameter must be global."

CG_INVALID_PARAM_HANDLE_ERROR

Cg.Import

"Invalid program handle."

CG_INVALID_PROFILE_ERROR

Cg.Import

"The parameter used is invalid."

CG_INVALID_PROGRAM_HANDLE_ERROR

Cg.Import

"Invalid context handle."

CG_INVALID_SIZE_ERROR

Cg.Import

"The parameter must be a resizable array."

CG_INVALID_VALUE_TYPE_ERROR

Cg.Import

"An unsupported GL extension was required to perform this operation."

CG_IS_NOT_PROGRAM_PARAMETER_ERROR

Cg.Import

"The two parameters being bound do not match."

CG_MEMORY_ALLOC_ERROR

Cg.Import

"nvparse could not successfully parse the output from the Cg compiler backend."

CG_NOT_4x4_MATRIX_ERROR

Cg.Import

"The enumerant parameter has an invalid value."

CG_NOT_MATRIX_PARAM_ERROR

Cg.Import

"An unknown value type was assigned to a parameter."

CG_NOT_ROOT_PARAMETER_ERROR

Cg.Import

"Cannot destroy the parameter. It is bound to other parameters or is not a root parameter."

CG_NO_ERROR

Cg.Import

# define CG_ERROR_MACRO(code, enum_name, new_enum_name, message) \ new_enum_name = code,

CG_NVPARSE_ERROR

Cg.Import

"The file could not be written."

CG_OUT_OF_ARRAY_BOUNDS_ERROR

Cg.Import

"The parameter must be an array."

CG_PARAMETERS_DO_NOT_MATCH_ERROR

Cg.Import

"The parameter is not a root parameter."

CG_PARAMETER_IS_NOT_RESIZABLE_ARRAY_ERROR

Cg.Import

"The type of the parameter is invalid."

CG_PARAMETER_IS_NOT_SHARED_ERROR

Cg.Import

"The parameters being bound have conflicting types."

CG_PROGRAM_BIND_ERROR

Cg.Import

"The program did could not load."

CG_PROGRAM_LOAD_ERROR

Cg.Import

"The profile is not supported."

CG_PROGRAM_NOT_LOADED_ERROR

Cg.Import

"The program could not bind."

CG_TRUE

Cg.Import

CG_TYPE_IS_NOT_DEFINED_IN_PROGRAM_ERROR

Cg.Import

"The array is has the wrong dimension."

CG_UNKNOWN_PROFILE_ERROR

Cg.Import

"Invalid parameter handle."

CG_UNSUPPORTED_GL_EXTENSION_ERROR

Cg.Import

"The program must be loaded before this operation may be used."

CG_VAR_ARG_ERROR

Cg.Import

"The specified profile is unknown."

CG_VERSION_1_2

Cg.Import

CG_VERSION_NUM

Cg.Import

cHTFHashTableSize

GLS.HeightTileFileHDS

cHTFQuadTableSize

GLS.HeightTileFileHDS

ChunkType

Formats.m3DSConst

Trick Chunk Flags For ChunkSyntax function

ChunkUnique

Formats.m3DSConst

cImageDataFormat16bits

Formats.DXTC

cImageDataFormat24bits

Formats.DXTC

cImageDataFormat32bits

Formats.DXTC

cImageDataFormat8bits

Formats.DXTC

cInv2PI

GLScene.VectorGeometry

cInv360

GLScene.VectorGeometry

cJupiterOrbitalElements

GLS.SkyDome

(AU) heliocentric jupiter elements

ckidAVIMAINHDR

Formats.VFW

mmioFOURCC('h', 'd', 'r', 'l')

ckidAVINEWINDEX

Formats.VFW

mmioFOURCC('r', 'e', 'c', ' ')

ckidAVIPADDING

Formats.VFW

– Chunk id to use for extra chunks for padding —————————–

ckidSTREAMFORMAT

Formats.VFW

mmioFOURCC('s', 't', 'r', 'h')

ckidSTREAMHANDLERDATA

Formats.VFW

mmioFOURCC('s', 't', 'r', 'f')

ckidSTREAMHEADER

Formats.VFW

mmioFOURCC('s', 't', 'r', 'l')

ckidSTREAMNAME

Formats.VFW

mmioFOURCC('s', 't', 'r', 'd')

cktypeDIBbits

Formats.VFW

– Basic chunk types ——————————————————–

cktypeDIBcompressed

Formats.VFW

aviTWOCC('d', 'b')

cktypePALchange

Formats.VFW

aviTWOCC('d', 'c')

cktypeWAVEbytes

Formats.VFW

aviTWOCC('p', 'c')

cLn10

GLScene.VectorGeometry

ClosedPolygon2D

GLScene.VectorTypesExt

TPolygon3D = record Vertices: array of TPoint3DRec; function Length; end;

ClosedPolygon3D

GLScene.VectorTypesExt

CLSID_AVIFile

Formats.VFW

CLSID_AVISimpleUnMarshal

Formats.VFW

CL_A

OpenCL.Import

CL_ABGR

OpenCL.Import

CL_ADDRESS_CLAMP

OpenCL.Import

CL_ADDRESS_CLAMP_TO_EDGE

OpenCL.Import

CL_ADDRESS_MIRRORED_REPEAT

OpenCL.Import

CL_ADDRESS_NONE

OpenCL.Import

cl_addressing_mode

CL_ADDRESS_REPEAT

OpenCL.Import

CL_APT_CALL

OpenCL.Platform

*************************************************************************** * Copyright (c) 2008-2023 The Khronos Group Inc. * * Permission is hereby granted, free of charge, to any person obtaining a * copy of this software and/or associated documentation files (the * "Materials"), to deal in the Materials without restriction, including * without limitation the rights to use, copy, modify, merge, publish, * distribute, sublicense, and/or sell copies of the Materials, and to * permit persons to whom the Materials are furnished to do so, subject to * the following conditions: * * The above copyright notice and this permission notice shall be included * in all copies or substantial portions of the Materials. * * MODIFICATIONS TO THIS FILE MAY MEAN IT NO LONGER ACCURATELY REFLECTS * KHRONOS STANDARDS. THE UNMODIFIED, NORMATIVE VERSIONS OF KHRONOS * SPECIFICATIONS AND HEADER INFORMATION ARE LOCATED AT * https://www.khronos.org/registry/ * * THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE * MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS. *************************************************************************

CL_ARGB

OpenCL.Import

CL_BGRA

OpenCL.Import

CL_BLOCKING

OpenCL.Import

CL_BUFFER_CREATE_TYPE_REGION

OpenCL.Import

cl_buffer_create_type

CL_BUILD_ERROR

OpenCL.Import

CL_BUILD_IN_PROGRESS

OpenCL.Import

CL_BUILD_NONE

OpenCL.Import

CL_BUILD_PROGRAM_FAILURE

OpenCL.Import

CL_BUILD_SUCCESS

OpenCL.Import

cl_build_status

CL_CALLBACK

OpenCL.Platform

CL_CGL_SHAREGROUP_KHR

OpenCL.GL

CL_CHAR_BIT

OpenCL.Platform

Macro names and corresponding values defined by OpenCL

CL_CHAR_MAX

OpenCL.Platform

CL_CHAR_MIN

OpenCL.Platform

CL_COMMAND_ACQUIRE_GL_OBJECTS

OpenCL.Import

CL_COMMAND_BARRIER

OpenCL.Import

CL_COMMAND_COPY_BUFFER

OpenCL.Import

CL_COMMAND_COPY_BUFFER_RECT

OpenCL.Import

CL_COMMAND_COPY_BUFFER_TO_IMAGE

OpenCL.Import

CL_COMMAND_COPY_IMAGE

OpenCL.Import

CL_COMMAND_COPY_IMAGE_TO_BUFFER

OpenCL.Import

CL_COMMAND_FILL_BUFFER

OpenCL.Import

CL_COMMAND_FILL_IMAGE

OpenCL.Import

CL_COMMAND_MAP_BUFFER

OpenCL.Import

CL_COMMAND_MAP_IMAGE

OpenCL.Import

CL_COMMAND_MARKER

OpenCL.Import

CL_COMMAND_MIGRATE_MEM_OBJECTS

OpenCL.Import

CL_COMMAND_NATIVE_KERNEL

OpenCL.Import

CL_COMMAND_NDRANGE_KERNEL

OpenCL.Import

cl_command_type

CL_COMMAND_READ_BUFFER

OpenCL.Import

CL_COMMAND_READ_BUFFER_RECT

OpenCL.Import

CL_COMMAND_READ_IMAGE

OpenCL.Import

CL_COMMAND_RELEASE_GL_OBJECTS

OpenCL.Import

CL_COMMAND_SVM_FREE

OpenCL.Import

CL_COMMAND_SVM_MAP

OpenCL.Import

CL_COMMAND_SVM_MEMCPY

OpenCL.Import

CL_COMMAND_SVM_MEMFILL

OpenCL.Import

CL_COMMAND_SVM_UNMAP

OpenCL.Import

CL_COMMAND_TASK

OpenCL.Import

CL_COMMAND_UNMAP_MEM_OBJECT

OpenCL.Import

CL_COMMAND_USER

OpenCL.Import

CL_COMMAND_WRITE_BUFFER

OpenCL.Import

CL_COMMAND_WRITE_BUFFER_RECT

OpenCL.Import

CL_COMMAND_WRITE_IMAGE

OpenCL.Import

CL_COMPILER_NOT_AVAILABLE

OpenCL.Import

CL_COMPILE_PROGRAM_FAILURE

OpenCL.Import

CL_COMPLETE

OpenCL.Import

command execution status

CL_CONTEXT_DEVICES

OpenCL.Import

CL_CONTEXT_INTEROP_USER_SYNC

OpenCL.Import

CL_CONTEXT_NUM_DEVICES

OpenCL.Import

CL_CONTEXT_PLATFORM

OpenCL.Import

cl_context_properties

CL_CONTEXT_PROPERTIES

OpenCL.Import

CL_CONTEXT_REFERENCE_COUNT

OpenCL.Import

cl_context_info

CL_CURRENT_DEVICE_FOR_GL_CONTEXT_KHR

OpenCL.GL

* cl_gl_context_info *//

CL_DBL_DIG

OpenCL.Platform

0x1.0p-23f;

CL_DBL_EPSILON

OpenCL.Platform

0x1.0p-1022;

CL_DBL_MANT_DIG

OpenCL.Platform

CL_DBL_MAX

OpenCL.Platform

CL_DBL_MAX_10_EXP

OpenCL.Platform

CL_DBL_MAX_EXP

OpenCL.Platform

CL_DBL_MIN

OpenCL.Platform

0x1.fffffffffffffp1023;

CL_DBL_MIN_10_EXP

OpenCL.Platform

CL_DBL_MIN_EXP

OpenCL.Platform

CL_DBL_RADIX

OpenCL.Platform

CL_DEPTH

OpenCL.Import

CL_DEPTH_STENCIL

OpenCL.Import

CL_DEVICES_FOR_GL_CONTEXT_KHR

OpenCL.GL

CL_DEVICE_ADDRESS_BITS

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_L1_CACHE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_L2_CACHE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_L3_CACHE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_L4_CACHE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_NEXT_PARTITIONABLE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_NUMA

OpenCL.Import

cl_device_affinity_domain

CL_DEVICE_AVAILABLE

OpenCL.Import

CL_DEVICE_BUILT_IN_KERNELS

OpenCL.Import

CL_DEVICE_COMPILER_AVAILABLE

OpenCL.Import

CL_DEVICE_DOUBLE_FP_CONFIG

OpenCL.Import

CL_DEVICE_ENDIAN_LITTLE

OpenCL.Import

CL_DEVICE_ERROR_CORRECTION_SUPPORT

OpenCL.Import

CL_DEVICE_EXECUTION_CAPABILITIES

OpenCL.Import

CL_DEVICE_EXTENSIONS

OpenCL.Import

CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE

OpenCL.Import

CL_DEVICE_GLOBAL_MEM_CACHE_SIZE

OpenCL.Import

CL_DEVICE_GLOBAL_MEM_CACHE_TYPE

OpenCL.Import

CL_DEVICE_GLOBAL_MEM_SIZE

OpenCL.Import

CL_DEVICE_GLOBAL_VARIABLE_PREFERRED_TOTAL_SIZE

OpenCL.Import

CL_DEVICE_HALF_FP_CONFIG

OpenCL.Import

CL_DEVICE_HOST_UNIFIED_MEMORY

OpenCL.Import

CL_DEVICE_IL_VERSION

OpenCL.Import

CL_DEVICE_IMAGE2D_MAX_HEIGHT

OpenCL.Import

CL_DEVICE_IMAGE2D_MAX_WIDTH

OpenCL.Import

CL_DEVICE_IMAGE3D_MAX_DEPTH

OpenCL.Import

CL_DEVICE_IMAGE3D_MAX_HEIGHT

OpenCL.Import

CL_DEVICE_IMAGE3D_MAX_WIDTH

OpenCL.Import

CL_DEVICE_IMAGE_BASE_ADDRESS_ALIGNMENT

OpenCL.Import

CL_DEVICE_IMAGE_MAX_ARRAY_SIZE

OpenCL.Import

CL_DEVICE_IMAGE_MAX_BUFFER_SIZE

OpenCL.Import

CL_DEVICE_IMAGE_PITCH_ALIGNMENT

OpenCL.Import

CL_DEVICE_IMAGE_SUPPORT

OpenCL.Import

CL_DEVICE_LINKER_AVAILABLE

OpenCL.Import

CL_DEVICE_LOCAL_MEM_SIZE

OpenCL.Import

CL_DEVICE_LOCAL_MEM_TYPE

OpenCL.Import

CL_DEVICE_MAX_CLOCK_FREQUENCY

OpenCL.Import

CL_DEVICE_MAX_COMPUTE_UNITS

OpenCL.Import

CL_DEVICE_MAX_CONSTANT_ARGS

OpenCL.Import

CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE

OpenCL.Import

CL_DEVICE_MAX_GLOBAL_VARIABLE_SIZE

OpenCL.Import

CL_DEVICE_MAX_MEM_ALLOC_SIZE

OpenCL.Import

CL_DEVICE_MAX_NUM_SUB_GROUPS

OpenCL.Import

CL_DEVICE_MAX_ON_DEVICE_EVENTS

OpenCL.Import

CL_DEVICE_MAX_ON_DEVICE_QUEUES

OpenCL.Import

CL_DEVICE_MAX_PARAMETER_SIZE

OpenCL.Import

CL_DEVICE_MAX_PIPE_ARGS

OpenCL.Import

CL_DEVICE_MAX_READ_IMAGE_ARGS

OpenCL.Import

CL_DEVICE_MAX_READ_WRITE_IMAGE_ARGS

OpenCL.Import

CL_DEVICE_MAX_SAMPLERS

OpenCL.Import

CL_DEVICE_MAX_WORK_GROUP_SIZE

OpenCL.Import

CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS

OpenCL.Import

CL_DEVICE_MAX_WORK_ITEM_SIZES

OpenCL.Import

CL_DEVICE_MAX_WRITE_IMAGE_ARGS

OpenCL.Import

CL_DEVICE_MEM_BASE_ADDR_ALIGN

OpenCL.Import

CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE

OpenCL.Import

CL_DEVICE_NAME

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_CHAR

OpenCL.Import

deprecated

CL_DEVICE_NATIVE_VECTOR_WIDTH_DOUBLE

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_FLOAT

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_HALF

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_INT

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_LONG

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_SHORT

OpenCL.Import

CL_DEVICE_NOT_AVAILABLE

OpenCL.Import

CL_DEVICE_NOT_FOUND

OpenCL.Import

CL_DEVICE_OPENCL_C_VERSION

OpenCL.Import

CL_DEVICE_PARENT_DEVICE

OpenCL.Import

CL_DEVICE_PARTITION_AFFINITY_DOMAIN

OpenCL.Import

CL_DEVICE_PARTITION_BY_AFFINITY_DOMAIN

OpenCL.Import

CL_DEVICE_PARTITION_BY_COUNTS

OpenCL.Import

CL_DEVICE_PARTITION_BY_COUNTS_LIST_END

OpenCL.Import

CL_DEVICE_PARTITION_EQUALLY

OpenCL.Import

cl_device_partition_property

CL_DEVICE_PARTITION_FAILED

OpenCL.Import

CL_DEVICE_PARTITION_MAX_SUB_DEVICES

OpenCL.Import

CL_DEVICE_PARTITION_PROPERTIES

OpenCL.Import

CL_DEVICE_PARTITION_TYPE

OpenCL.Import

CL_DEVICE_PIPE_MAX_ACTIVE_RESERVATIONS

OpenCL.Import

CL_DEVICE_PIPE_MAX_PACKET_SIZE

OpenCL.Import

CL_DEVICE_PLATFORM

OpenCL.Import

CL_DEVICE_PREFERRED_GLOBAL_ATOMIC_ALIGNMENT

OpenCL.Import

CL_DEVICE_PREFERRED_INTEROP_USER_SYNC

OpenCL.Import

CL_DEVICE_PREFERRED_LOCAL_ATOMIC_ALIGNMENT

OpenCL.Import

CL_DEVICE_PREFERRED_PLATFORM_ATOMIC_ALIGNMENT

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_CHAR

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_HALF

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_SHORT

OpenCL.Import

CL_DEVICE_PRINTF_BUFFER_SIZE

OpenCL.Import

CL_DEVICE_PROFILE

OpenCL.Import

CL_DEVICE_PROFILING_TIMER_RESOLUTION

OpenCL.Import

CL_DEVICE_QUEUE_ON_DEVICE_MAX_SIZE

OpenCL.Import

CL_DEVICE_QUEUE_ON_DEVICE_PREFERRED_SIZE

OpenCL.Import

CL_DEVICE_QUEUE_ON_DEVICE_PROPERTIES

OpenCL.Import

CL_DEVICE_QUEUE_ON_HOST_PROPERTIES

OpenCL.Import

deprecated

CL_DEVICE_QUEUE_PROPERTIES

OpenCL.Import

CL_DEVICE_REFERENCE_COUNT

OpenCL.Import

CL_DEVICE_SINGLE_FP_CONFIG

OpenCL.Import

CL_DEVICE_SUB_GROUP_INDEPENDENT_FORWARD_PROGRESS

OpenCL.Import

CL_DEVICE_SVM_ATOMICS

OpenCL.Import

CL_DEVICE_SVM_CAPABILITIES

OpenCL.Import

CL_DEVICE_SVM_COARSE_GRAIN_BUFFER

OpenCL.Import

cl_device_svm_capabilities

CL_DEVICE_SVM_FINE_GRAIN_BUFFER

OpenCL.Import

CL_DEVICE_SVM_FINE_GRAIN_SYSTEM

OpenCL.Import

CL_DEVICE_TYPE

OpenCL.Import

cl_device_info

CL_DEVICE_TYPE_ACCELERATOR

OpenCL.Import

CL_DEVICE_TYPE_ALL

OpenCL.Import

CL_DEVICE_TYPE_CPU

OpenCL.Import

CL_DEVICE_TYPE_CUSTOM

OpenCL.Import

CL_DEVICE_TYPE_DEFAULT

OpenCL.Import

cl_device_type - bitfield

CL_DEVICE_TYPE_GPU

OpenCL.Import

CL_DEVICE_VENDOR

OpenCL.Import

CL_DEVICE_VENDOR_ID

OpenCL.Import

CL_DEVICE_VERSION

OpenCL.Import

CL_DRIVER_VERSION

OpenCL.Import

CL_EGL_DISPLAY_KHR

OpenCL.GL

CL_EVENT_COMMAND_EXECUTION_STATUS

OpenCL.Import

CL_EVENT_COMMAND_QUEUE

OpenCL.Import

cl_event_info

CL_EVENT_COMMAND_TYPE

OpenCL.Import

CL_EVENT_CONTEXT

OpenCL.Import

CL_EVENT_REFERENCE_COUNT

OpenCL.Import

CL_EXEC_KERNEL

OpenCL.Import

cl_device_exec_capabilities - bitfield

CL_EXEC_NATIVE_KERNEL

OpenCL.Import

CL_EXEC_STATUS_ERROR_FOR_EVENTS_IN_WAIT_LIST

OpenCL.Import

CL_FALSE

OpenCL.Import

cl_bool

CL_FILTER_LINEAR

OpenCL.Import

CL_FILTER_NEAREST

OpenCL.Import

cl_filter_mode

CL_FLOAT

OpenCL.Import

CL_FLT_DIG

OpenCL.Platform

CL_FLT_EPSILON

OpenCL.Platform

0x1.0p-126f;

CL_FLT_MANT_DIG

OpenCL.Platform

CL_FLT_MAX

OpenCL.Platform

CL_FLT_MAX_10_EXP

OpenCL.Platform

CL_FLT_MAX_EXP

OpenCL.Platform

CL_FLT_MIN

OpenCL.Platform

0x1.fffffep127f;

CL_FLT_MIN_10_EXP

OpenCL.Platform

CL_FLT_MIN_EXP

OpenCL.Platform

CL_FLT_RADIX

OpenCL.Platform

CL_FP_CORRECTLY_ROUNDED_DIVIDE_SQRT

OpenCL.Import

CL_FP_DENORM

OpenCL.Import

cl_device_fp_config - bitfield

CL_FP_FMA

OpenCL.Import

CL_FP_INF_NAN

OpenCL.Import

CL_FP_ROUND_TO_INF

OpenCL.Import

CL_FP_ROUND_TO_NEAREST

OpenCL.Import

CL_FP_ROUND_TO_ZERO

OpenCL.Import

CL_FP_SOFT_FLOAT

OpenCL.Import

CL_GLOBAL

OpenCL.Import

CL_GLX_DISPLAY_KHR

OpenCL.GL

CL_GL_CONTEXT_KHR

OpenCL.GL

* Additional cl_context_properties *//

CL_GL_MIPMAP_LEVEL

OpenCL.GL

CL_GL_NUM_SAMPLES

OpenCL.GL

CL_GL_OBJECT_BUFFER

OpenCL.GL

* cl_gl_object_type = 0x2000 - 0x200F enum values are currently taken *//

CL_GL_OBJECT_RENDERBUFFER

OpenCL.GL

CL_GL_OBJECT_TEXTURE1D

OpenCL.GL

CL_GL_OBJECT_TEXTURE1D_ARRAY

OpenCL.GL

CL_GL_OBJECT_TEXTURE2D

OpenCL.GL

CL_GL_OBJECT_TEXTURE2D_ARRAY

OpenCL.GL

CL_GL_OBJECT_TEXTURE3D

OpenCL.GL

CL_GL_OBJECT_TEXTURE_BUFFER

OpenCL.GL

CL_GL_TEXTURE_TARGET

OpenCL.GL

* cl_gl_texture_info *//

CL_HALF_FLOAT

OpenCL.Import

CL_HUGE_VAL

OpenCL.Platform

CL_HUGE_VALF

OpenCL.Platform

(CL_INFINITY - CL_INFINITY);

CL_IMAGE_ARRAY_SIZE

OpenCL.Import

CL_IMAGE_BUFFER

OpenCL.Import

CL_IMAGE_DEPTH

OpenCL.Import

CL_IMAGE_ELEMENT_SIZE

OpenCL.Import

CL_IMAGE_FORMAT

OpenCL.Import

cl_image_info

CL_IMAGE_FORMAT_MISMATCH

OpenCL.Import

CL_IMAGE_FORMAT_NOT_SUPPORTED

OpenCL.Import

CL_IMAGE_HEIGHT

OpenCL.Import

CL_IMAGE_NUM_MIP_LEVELS

OpenCL.Import

CL_IMAGE_NUM_SAMPLES

OpenCL.Import

CL_IMAGE_ROW_PITCH

OpenCL.Import

CL_IMAGE_SLICE_PITCH

OpenCL.Import

CL_IMAGE_WIDTH

OpenCL.Import

CL_INFINITY

OpenCL.Platform

CL_INTENSITY

OpenCL.Import

CL_INT_MAX

OpenCL.Platform

CL_INT_MIN

OpenCL.Platform

CL_INVALID_ARG_INDEX

OpenCL.Import

CL_INVALID_ARG_SIZE

OpenCL.Import

CL_INVALID_ARG_VALUE

OpenCL.Import

CL_INVALID_BINARY

OpenCL.Import

CL_INVALID_BUFFER_SIZE

OpenCL.Import

CL_INVALID_BUILD_OPTIONS

OpenCL.Import

CL_INVALID_COMMAND_QUEUE

OpenCL.Import

CL_INVALID_COMPILER_OPTIONS

OpenCL.Import

CL_INVALID_CONTEXT

OpenCL.Import

CL_INVALID_DEVICE

OpenCL.Import

CL_INVALID_DEVICE_PARTITION_COUNT

OpenCL.Import

CL_INVALID_DEVICE_QUEUE

OpenCL.Import

CL_INVALID_DEVICE_TYPE

OpenCL.Import

CL_INVALID_EVENT

OpenCL.Import

CL_INVALID_EVENT_WAIT_LIST

OpenCL.Import

CL_INVALID_GLOBAL_OFFSET

OpenCL.Import

CL_INVALID_GLOBAL_WORK_SIZE

OpenCL.Import

CL_INVALID_GL_OBJECT

OpenCL.Import

CL_INVALID_GL_SHAREGROUP_REFERENCE_KHR

OpenCL.GL

* Additional Error Codes *//

CL_INVALID_HOST_PTR

OpenCL.Import

CL_INVALID_IMAGE_DESCRIPTOR

OpenCL.Import

CL_INVALID_IMAGE_FORMAT_DESCRIPTOR

OpenCL.Import

CL_INVALID_IMAGE_SIZE

OpenCL.Import

CL_INVALID_KERNEL

OpenCL.Import

CL_INVALID_KERNEL_ARGS

OpenCL.Import

CL_INVALID_KERNEL_DEFINITION

OpenCL.Import

CL_INVALID_KERNEL_NAME

OpenCL.Import

CL_INVALID_LINKER_OPTIONS

OpenCL.Import

CL_INVALID_MEM_OBJECT

OpenCL.Import

CL_INVALID_MIP_LEVEL

OpenCL.Import

CL_INVALID_OPERATION

OpenCL.Import

CL_INVALID_PIPE_SIZE

OpenCL.Import

CL_INVALID_PLATFORM

OpenCL.Import

CL_INVALID_PROGRAM

OpenCL.Import

CL_INVALID_PROGRAM_EXECUTABLE

OpenCL.Import

CL_INVALID_PROPERTY

OpenCL.Import

CL_INVALID_QUEUE_PROPERTIES

OpenCL.Import

CL_INVALID_SAMPLER

OpenCL.Import

CL_INVALID_SPEC_ID

OpenCL.Import

CL_INVALID_VALUE

OpenCL.Import

CL_INVALID_WORK_DIMENSION

OpenCL.Import

CL_INVALID_WORK_GROUP_SIZE

OpenCL.Import

CL_INVALID_WORK_ITEM_SIZE

OpenCL.Import

CL_KERNEL_ARG_ACCESS_NONE

OpenCL.Import

CL_KERNEL_ARG_ACCESS_QUALIFIER

OpenCL.Import

CL_KERNEL_ARG_ACCESS_READ_ONLY

OpenCL.Import

cl_kernel_arg_access_qualifier

CL_KERNEL_ARG_ACCESS_READ_WRITE

OpenCL.Import

CL_KERNEL_ARG_ACCESS_WRITE_ONLY

OpenCL.Import

CL_KERNEL_ARG_ADDRESS_CONSTANT

OpenCL.Import

CL_KERNEL_ARG_ADDRESS_GLOBAL

OpenCL.Import

cl_kernel_arg_address_qualifier

CL_KERNEL_ARG_ADDRESS_LOCAL

OpenCL.Import

CL_KERNEL_ARG_ADDRESS_PRIVATE

OpenCL.Import

CL_KERNEL_ARG_ADDRESS_QUALIFIER

OpenCL.Import

cl_kernel_arg_info

CL_KERNEL_ARG_INFO_NOT_AVAILABLE

OpenCL.Import

CL_KERNEL_ARG_NAME

OpenCL.Import

CL_KERNEL_ARG_TYPE_CONST

OpenCL.Import

CL_KERNEL_ARG_TYPE_NAME

OpenCL.Import

CL_KERNEL_ARG_TYPE_NONE

OpenCL.Import

cl_kernel_arg_type_qualifer

CL_KERNEL_ARG_TYPE_PIPE

OpenCL.Import

CL_KERNEL_ARG_TYPE_QUALIFIER

OpenCL.Import

CL_KERNEL_ARG_TYPE_RESTRICT

OpenCL.Import

CL_KERNEL_ARG_TYPE_VOLATILE

OpenCL.Import

CL_KERNEL_ATTRIBUTES

OpenCL.Import

CL_KERNEL_COMPILE_NUM_SUB_GROUPS

OpenCL.Import

CL_KERNEL_COMPILE_WORK_GROUP_SIZE

OpenCL.Import

CL_KERNEL_CONTEXT

OpenCL.Import

CL_KERNEL_EXEC_INFO_SVM_FINE_GRAIN_SYSTEM

OpenCL.Import

CL_KERNEL_EXEC_INFO_SVM_PTRS

OpenCL.Import

cl_kernel_exec_info

CL_KERNEL_FUNCTION_NAME

OpenCL.Import

cl_kernel_info

CL_KERNEL_GLOBAL_WORK_SIZE

OpenCL.Import

CL_KERNEL_LOCAL_MEM_SIZE

OpenCL.Import

CL_KERNEL_LOCAL_SIZE_FOR_SUB_GROUP_COUNT

OpenCL.Import

CL_KERNEL_MAX_NUM_SUB_GROUPS

OpenCL.Import

CL_KERNEL_MAX_SUB_GROUP_SIZE_FOR_NDRANGE

OpenCL.Import

cl_kernel_sub_group_info

CL_KERNEL_NUM_ARGS

OpenCL.Import

CL_KERNEL_PREFERRED_WORK_GROUP_SIZE_MULTIPLE

OpenCL.Import

CL_KERNEL_PRIVATE_MEM_SIZE

OpenCL.Import

CL_KERNEL_PROGRAM

OpenCL.Import

CL_KERNEL_REFERENCE_COUNT

OpenCL.Import

CL_KERNEL_SUB_GROUP_COUNT_FOR_NDRANGE

OpenCL.Import

CL_KERNEL_WORK_GROUP_SIZE

OpenCL.Import

cl_kernel_work_group_info

cl_khr_gl_sharing

OpenCL.GL

* cl_khr_gl_sharing extension *//

CL_LINKER_NOT_AVAILABLE

OpenCL.Import

CL_LINK_PROGRAM_FAILURE

OpenCL.Import

CL_LOCAL

OpenCL.Import

cl_device_local_mem_type

CL_LONG_MAX

OpenCL.Platform

CL_LONG_MIN

OpenCL.Platform

CL_LUMINANCE

OpenCL.Import

CL_MAP_FAILURE

OpenCL.Import

CL_MAP_READ

OpenCL.Import

cl_map_flags - bitfield

CL_MAP_WRITE

OpenCL.Import

CL_MAP_WRITE_INVALIDATE_REGION

OpenCL.Import

CL_MAXFLOAT

OpenCL.Platform

CL_MAX_SIZE_RESTRICTION_EXCEEDED

OpenCL.Import

CL_MEM_ALLOC_HOST_PTR

OpenCL.Import

CL_MEM_ASSOCIATED_MEMOBJECT

OpenCL.Import

CL_MEM_CONTEXT

OpenCL.Import

CL_MEM_COPY_HOST_PTR

OpenCL.Import

CL_MEM_COPY_OVERLAP

OpenCL.Import

CL_MEM_FLAGS

OpenCL.Import

CL_MEM_HOST_NO_ACCESS

OpenCL.Import

CL_MEM_HOST_PTR

OpenCL.Import

CL_MEM_HOST_READ_ONLY

OpenCL.Import

CL_MEM_HOST_WRITE_ONLY

OpenCL.Import

reserved (1 shl 6);

CL_MEM_KERNEL_READ_AND_WRITE

OpenCL.Import

used by cl_svm_mem_flags only

CL_MEM_MAP_COUNT

OpenCL.Import

CL_MEM_OBJECT_ALLOCATION_FAILURE

OpenCL.Import

CL_MEM_OBJECT_BUFFER

OpenCL.Import

cl_mem_object_type

CL_MEM_OBJECT_IMAGE1D

OpenCL.Import

CL_MEM_OBJECT_IMAGE1D_ARRAY

OpenCL.Import

CL_MEM_OBJECT_IMAGE1D_BUFFER

OpenCL.Import

CL_MEM_OBJECT_IMAGE2D

OpenCL.Import

CL_MEM_OBJECT_IMAGE2D_ARRAY

OpenCL.Import

CL_MEM_OBJECT_IMAGE3D

OpenCL.Import

CL_MEM_OBJECT_PIPE

OpenCL.Import

CL_MEM_OFFSET

OpenCL.Import

CL_MEM_READ_ONLY

OpenCL.Import

CL_MEM_READ_WRITE

OpenCL.Import

cl_mem_flags - bitfield

CL_MEM_REFERENCE_COUNT

OpenCL.Import

CL_MEM_SIZE

OpenCL.Import

CL_MEM_SVM_ATOMICS

OpenCL.Import

used by cl_svm_mem_flags only

CL_MEM_SVM_FINE_GRAIN_BUFFER

OpenCL.Import

CL_MEM_TYPE

OpenCL.Import

cl_mem_info

CL_MEM_USES_SVM_POINTER

OpenCL.Import

CL_MEM_USE_HOST_PTR

OpenCL.Import

CL_MEM_WRITE_ONLY

OpenCL.Import

CL_MIGRATE_MEM_OBJECT_CONTENT_UNDEFINED

OpenCL.Import

CL_MIGRATE_MEM_OBJECT_HOST

OpenCL.Import

cl_mem_migration_flags - bitfield

CL_MISALIGNED_SUB_BUFFER_OFFSET

OpenCL.Import

CL_M_1_PI

OpenCL.Platform

CL_M_1_PI_F

OpenCL.Platform

CL_M_2_PI

OpenCL.Platform

CL_M_2_PI_F

OpenCL.Platform

CL_M_2_SQRTPI

OpenCL.Platform

CL_M_2_SQRTPI_F

OpenCL.Platform

CL_M_E

OpenCL.Platform

0x1.0p-52;

CL_M_E_F

OpenCL.Platform

CL_M_LN10

OpenCL.Platform

CL_M_LN10_F

OpenCL.Platform

CL_M_LN2

OpenCL.Platform

CL_M_LN2_F

OpenCL.Platform

CL_M_LOG10E

OpenCL.Platform

CL_M_LOG10E_F

OpenCL.Platform

CL_M_LOG2E

OpenCL.Platform

CL_M_LOG2E_F

OpenCL.Platform

CL_M_PI

OpenCL.Platform

CL_M_PI_2

OpenCL.Platform

CL_M_PI_2_F

OpenCL.Platform

CL_M_PI_4

OpenCL.Platform

CL_M_PI_4_F

OpenCL.Platform

CL_M_PI_F

OpenCL.Platform

CL_M_SQRT1_2

OpenCL.Platform

CL_M_SQRT1_2_F

OpenCL.Platform

CL_M_SQRT2

OpenCL.Platform

CL_M_SQRT2_F

OpenCL.Platform

CL_NAN

OpenCL.Platform

CL_NONE

OpenCL.Import

cl_device_mem_cache_type

CL_NON_BLOCKING

OpenCL.Import

CL_OUT_OF_HOST_MEMORY

OpenCL.Import

CL_OUT_OF_RESOURCES

OpenCL.Import

CL_PIPE_MAX_PACKETS

OpenCL.Import

CL_PIPE_PACKET_SIZE

OpenCL.Import

cl_pipe_info

CL_PLATFORM_EXTENSIONS

OpenCL.Import

CL_PLATFORM_HOST_TIMER_RESOLUTION

OpenCL.Import

CL_PLATFORM_NAME

OpenCL.Import

CL_PLATFORM_PROFILE

OpenCL.Import

cl_platform_info

CL_PLATFORM_VENDOR

OpenCL.Import

CL_PLATFORM_VERSION

OpenCL.Import

CL_PROFILING_COMMAND_COMPLETE

OpenCL.Import

CL_PROFILING_COMMAND_END

OpenCL.Import

CL_PROFILING_COMMAND_QUEUED

OpenCL.Import

cl_profiling_info

CL_PROFILING_COMMAND_START

OpenCL.Import

CL_PROFILING_COMMAND_SUBMIT

OpenCL.Import

CL_PROFILING_INFO_NOT_AVAILABLE

OpenCL.Import

CL_PROGBRAM_BINARY_TYPE_NONE

OpenCL.Import

cl_program_binary_type

CL_PROGRAM_BINARIES

OpenCL.Import

CL_PROGRAM_BINARY_SIZES

OpenCL.Import

CL_PROGRAM_BINARY_TYPE

OpenCL.Import

CL_PROGRAM_BINARY_TYPE_COMPILED_OBJECT

OpenCL.Import

CL_PROGRAM_BINARY_TYPE_EXECUTABLE

OpenCL.Import

CL_PROGRAM_BINARY_TYPE_LIBRARY

OpenCL.Import

CL_PROGRAM_BUILD_GLOBAL_VARIABLE_TOTAL_SIZE

OpenCL.Import

CL_PROGRAM_BUILD_LOG

OpenCL.Import

CL_PROGRAM_BUILD_OPTIONS

OpenCL.Import

CL_PROGRAM_BUILD_STATUS

OpenCL.Import

cl_program_build_info

CL_PROGRAM_CONTEXT

OpenCL.Import

CL_PROGRAM_DEVICES

OpenCL.Import

CL_PROGRAM_IL

OpenCL.Import

CL_PROGRAM_KERNEL_NAMES

OpenCL.Import

CL_PROGRAM_NUM_DEVICES

OpenCL.Import

CL_PROGRAM_NUM_KERNELS

OpenCL.Import

CL_PROGRAM_REFERENCE_COUNT

OpenCL.Import

cl_program_info

CL_PROGRAM_SCOPE_GLOBAL_CTORS_PRESENT

OpenCL.Import

CL_PROGRAM_SCOPE_GLOBAL_DTORS_PRESENT

OpenCL.Import

CL_PROGRAM_SOURCE

OpenCL.Import

CL_QUEUED

OpenCL.Import

CL_QUEUE_CONTEXT

OpenCL.Import

cl_command_queue_info

CL_QUEUE_DEVICE

OpenCL.Import

CL_QUEUE_DEVICE_DEFAULT

OpenCL.Import

CL_QUEUE_ON_DEVICE

OpenCL.Import

CL_QUEUE_ON_DEVICE_DEFAULT

OpenCL.Import

CL_QUEUE_OUT_OF_ORDER_EXEC_MODE_ENABLE

OpenCL.Import

cl_command_queue_properties - bitfield

CL_QUEUE_PROFILING_ENABLE

OpenCL.Import

CL_QUEUE_PROPERTIES

OpenCL.Import

CL_QUEUE_REFERENCE_COUNT

OpenCL.Import

CL_QUEUE_SIZE

OpenCL.Import

CL_R

OpenCL.Import

cl_channel_order

CL_RA

OpenCL.Import

CL_READ_ONLY_CACHE

OpenCL.Import

CL_READ_WRITE_CACHE

OpenCL.Import

CL_RG

OpenCL.Import

CL_RGB

OpenCL.Import

CL_RGBA

OpenCL.Import

CL_RGBx

OpenCL.Import

CL_RGx

OpenCL.Import

CL_RUNNING

OpenCL.Import

CL_Rx

OpenCL.Import

CL_SAMPLER_ADDRESSING_MODE

OpenCL.Import

CL_SAMPLER_CONTEXT

OpenCL.Import

CL_SAMPLER_FILTER_MODE

OpenCL.Import

CL_SAMPLER_LOD_MAX

OpenCL.Import

CL_SAMPLER_LOD_MIN

OpenCL.Import

CL_SAMPLER_MIP_FILTER_MODE

OpenCL.Import

CL_SAMPLER_NORMALIZED_COORDS

OpenCL.Import

CL_SAMPLER_REFERENCE_COUNT

OpenCL.Import

cl_sampler_info

CL_sBGRA

OpenCL.Import

CL_SCHAR_MAX

OpenCL.Platform

CL_SCHAR_MIN

OpenCL.Platform

CL_SHRT_MAX

OpenCL.Platform

CL_SHRT_MIN

OpenCL.Platform

CL_SIGNED_INT16

OpenCL.Import

CL_SIGNED_INT32

OpenCL.Import

CL_SIGNED_INT8

OpenCL.Import

CL_SNORM_INT16

OpenCL.Import

CL_SNORM_INT8

OpenCL.Import

* cl_channel_type *//

CL_sRGB

OpenCL.Import

CL_sRGBA

OpenCL.Import

CL_sRGBx

OpenCL.Import

CL_SUBMITTED

OpenCL.Import

CL_SUCCESS

OpenCL.Import

Error Codes

CL_TRUE

OpenCL.Import

CL_UCHAR_MAX

OpenCL.Platform

CL_UINT_MAX

OpenCL.Platform

CL_ULONG_MAX

OpenCL.Platform

CL_UNORM_INT16

OpenCL.Import

CL_UNORM_INT24

OpenCL.Import

CL_UNORM_INT8

OpenCL.Import

CL_UNORM_INT_101010

OpenCL.Import

CL_UNORM_INT_101010_2

OpenCL.Import

CL_UNORM_SHORT_555

OpenCL.Import

CL_UNORM_SHORT_565

OpenCL.Import

CL_UNSIGNED_INT16

OpenCL.Import

CL_UNSIGNED_INT32

OpenCL.Import

CL_UNSIGNED_INT8

OpenCL.Import

CL_USHRT_MAX

OpenCL.Platform

CL_VERSION_1_0

OpenCL.Import

OpenCL Version

CL_VERSION_1_1

OpenCL.Import

CL_VERSION_1_2

OpenCL.Import

CL_VERSION_2_0

OpenCL.Import

CL_VERSION_2_1

OpenCL.Import

CL_VERSION_2_2

OpenCL.Import

CL_WGL_HDC_KHR

OpenCL.GL

CMAGIC

Formats.m3DSConst

cMarsOrbitalElements

GLS.SkyDome

(AU) heliocentric mars elements

cMaxArray

GLScene.VectorGeometry

cMaxContacts

GLS.ODERagdoll

cMaxVerts

GLS.Trail

cMercuryOrbitalElements

GLS.SkyDome

(Earth radii) heliocentric mercury elements

cMeshHexahedron

GLS.MeshBuilder

Hexahedron arrays for 6 parts

cMeshModeToGLEnum

GLS.Mesh

cMeshSphere

GLS.MeshBuilder

Front Quad Back Quad Top Quad Bottom Quad Right Quad Left Quad Sphere arrays for parts with 2 hemispheres

cMoonOrbitalElements

GLS.SkyDome

(AU) geocentric moon elements

CmtNX

GLS.Texture

CmtNY

GLS.Texture

CmtNZ

GLS.Texture

CmtPX

GLS.Texture

CmtPY

GLS.Texture

CmtPZ

GLS.Texture

cNeptuneOrbitalElements

GLS.SkyDome

(AU) heliocentric neptune elements

COctree_GROW_GRAVY

GLS.SpacePartition

COctree_LEAF_TRHESHOLD

GLS.SpacePartition

COctree_MAX_TREE_DEPTH

GLS.SpacePartition

ColorFMax3DS

Formats.m3DSConst

minimum color value in a channel

ColorFMin3DS

Formats.m3DSConst

maximum shadow map size COLOR_F

COLOR_24

Formats.m3DSConst

COLOR_F

Formats.m3DSConst

ColTrackTagMax3DS

Formats.m3DSConst

Minimum color value

ColTrackTagMin3DS

Formats.m3DSConst

Minimum number of keys in a track COL_TRACK_TAG_KEY

COL_TRACK_TAG

Formats.m3DSConst

COL_TRACK_TAG_KEY

Formats.m3DSConst

comptypeDIB

Formats.VFW

== AVISave routines and structures ==========================================

cOneHalf

GLScene.VectorGeometry

CONSOLE_MAX_COMMANDS

GLS.Console

CONTACTS_UNIMPORTANT

ODE.Import

Just generate any contacts (disables any contact refining).

Container

Formats.m3DSConst

CONTROLCALLBACK_CAPTURING

Formats.VFW

Waiting to start capture

CONTROLCALLBACK_PREROLL

Formats.VFW

– CapControlCallback states ————————————————

cPERLIN_TABLE_SIZE

GLS.PerlinPFX

cPFXGranularity

GLS.ParticleFX

number of distance regions

cPFXNbRegions

GLS.ParticleFX

cPI

GLScene.VectorGeometry

cPIdiv180

GLScene.VectorGeometry

cPIdiv2

GLScene.VectorGeometry

cPIdiv4

GLScene.VectorGeometry

cPlutoOrbitalElements

GLS.SkyDome

(AU) heliocentric pluto elements

cSaturnOrbitalElements

GLS.SkyDome

(AU) heliocentric saturn elements

cSunOrbitalElements

GLS.SkyDome

geocentric sun elements

cTilesHashSize

GLS.TerrainRenderer

CUDAAPIDLL

CUDA.Import

CUDARTDLLNAMES

CUDA.Runtime

CUDART_2_OVER_PI

CUDA.Runtime

CUDART_2_OVER_PI_F

CUDA.Runtime

CUDART_3PIO4

CUDA.Runtime

CUDART_3PIO4_F

CUDA.Runtime

CUDART_INF

CUDA.Runtime

double precision constants */

CUDART_INF_F

CUDA.Runtime

single precision constants

CUDART_L2E

CUDA.Runtime

CUDART_L2E_F

CUDA.Runtime

CUDART_L2E_HI

CUDA.Runtime

CUDART_L2E_LO

CUDA.Runtime

CUDART_L2T

CUDA.Runtime

CUDART_L2T_F

CUDA.Runtime

CUDART_LG2

CUDA.Runtime

CUDART_LG2_F

CUDA.Runtime

CUDART_LG2_HI

CUDA.Runtime

CUDART_LG2_LO

CUDA.Runtime

CUDART_LG2_X_1024

CUDA.Runtime

CUDART_LG2_X_1075

CUDA.Runtime

CUDART_LGE

CUDA.Runtime

CUDART_LGE_F

CUDA.Runtime

CUDART_LGE_HI

CUDA.Runtime

CUDART_LGE_LO

CUDA.Runtime

CUDART_LN2

CUDA.Runtime

CUDART_LN2_F

CUDA.Runtime

CUDART_LN2_HI

CUDA.Runtime

CUDART_LN2_LO

CUDA.Runtime

CUDART_LN2_X_1024

CUDA.Runtime

CUDART_LN2_X_1025

CUDA.Runtime

CUDART_LN2_X_1075

CUDA.Runtime

CUDART_LNPI

CUDA.Runtime

CUDART_LNPI_F

CUDA.Runtime

CUDART_LNT

CUDA.Runtime

CUDART_LNT_F

CUDA.Runtime

CUDART_LNT_HI

CUDA.Runtime

CUDART_LNT_LO

CUDA.Runtime

CUDART_MAX_NORMAL_F

CUDA.Runtime

CUDART_MIN_DENORM

CUDA.Runtime

CUDART_MIN_DENORM_F

CUDA.Runtime

CUDART_NAN

CUDA.Runtime

CUDART_NAN_F

CUDA.Runtime

CUDART_NEG_ZERO

CUDA.Runtime

CUDART_NEG_ZERO_F

CUDA.Runtime

CUDART_NORM_HUGE_F

CUDA.Runtime

CUDART_ONE

CUDA.Runtime

CUDART_ONE_F

CUDA.Runtime

CUDART_PI

CUDA.Runtime

CUDART_PIO2

CUDA.Runtime

CUDART_PIO2_F

CUDA.Runtime

CUDART_PIO2_HI

CUDA.Runtime

CUDART_PIO2_LO

CUDA.Runtime

CUDART_PIO4

CUDA.Runtime

CUDART_PIO4_F

CUDA.Runtime

CUDART_PIO4_HI

CUDA.Runtime

CUDART_PIO4_LO

CUDA.Runtime

CUDART_PI_F

CUDA.Runtime

CUDART_PI_HI

CUDA.Runtime

CUDART_PI_LO

CUDA.Runtime

CUDART_REMQUO_BITS_F

CUDA.Runtime

CUDART_REMQUO_MASK_F

CUDA.Runtime

CUDART_SQRT_2PI_HI

CUDA.Runtime

CUDART_SQRT_2PI_LO

CUDA.Runtime

CUDART_SQRT_HALF

CUDA.Runtime

CUDART_SQRT_HALF_F

CUDA.Runtime

CUDART_SQRT_PIO2_HI

CUDA.Runtime

CUDART_SQRT_PIO2_LO

CUDA.Runtime

CUDART_SQRT_TWO

CUDA.Runtime

CUDART_SQRT_TWO_F

CUDA.Runtime

CUDART_THIRD

CUDA.Runtime

CUDART_THIRD_F

CUDA.Runtime

CUDART_TRIG_PLOSS

CUDA.Runtime

CUDART_TRIG_PLOSS_F

CUDA.Runtime

CUDART_TWOTHIRD

CUDA.Runtime

CUDART_TWO_TO_126_F

CUDA.Runtime

CUDART_TWO_TO_23

CUDA.Runtime

CUDART_TWO_TO_23_F

CUDA.Runtime

CUDART_TWO_TO_24_F

CUDA.Runtime

CUDART_TWO_TO_31_F

CUDA.Runtime

CUDART_TWO_TO_32_F

CUDA.Runtime

CUDART_TWO_TO_52

CUDA.Runtime

CUDART_TWO_TO_54

CUDA.Runtime

CUDART_TWO_TO_M1022

CUDA.Runtime

CUDART_TWO_TO_M126_F

CUDA.Runtime

CUDART_TWO_TO_M54

CUDA.Runtime

CUDART_ZERO

CUDA.Runtime

CUDART_ZERO_F

CUDA.Runtime

CUDA_ERROR_ALREADY_ACQUIRED

CUDA.Import

< No binary for GPU

CUDA_ERROR_ALREADY_MAPPED

CUDA.Import

< Array is mapped

CUDA_ERROR_ARRAY_IS_MAPPED

CUDA.Import

< Unmap failed

CUDA_ERROR_CONTEXT_ALREADY_CURRENT

CUDA.Import

< Invalid context

CUDA_ERROR_DEINITIALIZED

CUDA.Import

< Driver not initialized

CUDA_ERROR_FILE_NOT_FOUND

CUDA.Import

< Invalid source

CUDA_ERROR_INVALID_CONTEXT

CUDA.Import

< Invalid kernel image

CUDA_ERROR_INVALID_DEVICE

CUDA.Import

< No CUDA-capable device available

CUDA_ERROR_INVALID_HANDLE

CUDA.Import

< File not found

CUDA_ERROR_INVALID_IMAGE

CUDA.Import

< Invalid device

CUDA_ERROR_INVALID_SOURCE

CUDA.Import

< Mapped resource not available for access as a pointer

CUDA_ERROR_INVALID_VALUE

CUDA.Import

< No errors

CUDA_ERROR_LAUNCH_FAILED

CUDA.Import

< CUDA not ready

CUDA_ERROR_LAUNCH_INCOMPATIBLE_TEXTURING

CUDA.Import

< Launch exceeded timeout

CUDA_ERROR_LAUNCH_OUT_OF_RESOURCES

CUDA.Import

< Launch failed

CUDA_ERROR_LAUNCH_TIMEOUT

CUDA.Import

< Launch exceeded resources

CUDA_ERROR_MAP_FAILED

CUDA.Import

< Context already current

CUDA_ERROR_NOT_FOUND

CUDA.Import

< Invalid handle

CUDA_ERROR_NOT_INITIALIZED

CUDA.Import

< Out of memory

CUDA_ERROR_NOT_MAPPED

CUDA.Import

< Already acquired

CUDA_ERROR_NOT_MAPPED_AS_ARRAY

CUDA.Import

< Not mapped

CUDA_ERROR_NOT_MAPPED_AS_POINTER

CUDA.Import

< Mapped resource not available for access as an array

CUDA_ERROR_NOT_READY

CUDA.Import

< Not found

CUDA_ERROR_NO_BINARY_FOR_GPU

CUDA.Import

< Already mapped

CUDA_ERROR_NO_DEVICE

CUDA.Import

< Driver deinitialized

CUDA_ERROR_OUT_OF_MEMORY

CUDA.Import

< Invalid value

CUDA_ERROR_POINTER_IS_64BIT

CUDA.Import

< Launch with incompatible texturing

CUDA_ERROR_SIZE_IS_64BIT

CUDA.Import

< Attempted to retrieve 64-bit pointer via 32-bit API function

CUDA_ERROR_UNKNOWN

CUDA.Import

< Attempted to retrieve 64-bit size via 32-bit API function

CUDA_ERROR_UNMAP_FAILED

CUDA.Import

< Map failed

CUDA_SUCCESS

CUDA.Import

CUDPPDLL

CUDA.ParallelPrimitives

————————————————————- cuDPP – CUDA Data Parallel Primitives library ————————————————————- $Revision: 4567 $ $Date: 2020-05-17 ————————————————————- This source code is distributed under the terms of license.txt in the root directory of this source distribution. ————————————————————-

CUDPP_INVALID_HANDLE

CUDA.ParallelPrimitives

CUFFTDLLNAMES

CUDA.FourierTransform

CUFFT_ALLOC_FAILED

CUDA.FourierTransform

CUFFT_C2C

CUDA.FourierTransform

Complex (interleaved) to Real

CUFFT_C2R

CUDA.FourierTransform

Real to Complex (interleaved)

CUFFT_COMPATIBILITY_FFTW

CUDA.FourierTransform

CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC

CUDA.FourierTransform

CUFFT_COMPATIBILITY_FFTW_PADDING

CUDA.FourierTransform

The default value

CUFFT_COMPATIBILITY_NORMAL

CUDA.FourierTransform

CUFFT_D2Z

CUDA.FourierTransform

Complex to Complex, interleaved

CUFFT_EXEC_FAILED

CUDA.FourierTransform

CUFFT_FORWARD

CUDA.FourierTransform

CUFFT transform directions

CUFFT_INTERNAL_ERROR

CUDA.FourierTransform

CUFFT_INVALID_PLAN

CUDA.FourierTransform

CUFFT_INVALID_SIZE

CUDA.FourierTransform

CUFFT_INVALID_TYPE

CUDA.FourierTransform

CUFFT_INVALID_VALUE

CUDA.FourierTransform

CUFFT_INVERSE

CUDA.FourierTransform

Forward FFT

CUFFT_R2C

CUDA.FourierTransform

Inverse FFT CUFFT supports the following transform types

CUFFT_SETUP_FAILED

CUDA.FourierTransform

CUFFT_SUCCESS

CUDA.FourierTransform

CUFFT_Z2D

CUDA.FourierTransform

Double to Double-Complex

CUFFT_Z2Z

CUDA.FourierTransform

Double-Complex to Double

cUranusOrbitalElements

GLS.SkyDome

(AU) heliocentric uranus elements

CURV_CONTINUITY_FIRST

Formats.LWO

CURV_CONTINUITY_LAST

Formats.LWO

CUTILDLL

CUDA.Utility

CU_MEMHOSTALLOC_DEVICEMAP

CUDA.Import

* If set, host memory is mapped into CUDA address space and * ::cuMemHostGetDevicePointer() may be called on the host pointer. * Flag for ::cuMemHostAlloc()

CU_MEMHOSTALLOC_PORTABLE

CUDA.Import

* If set, host memory is portable between CUDA contexts. * Flag for ::cuMemHostAlloc()

CU_MEMHOSTALLOC_WRITECOMBINED

CUDA.Import

* If set, host memory is allocated as write-combined - fast to write, * faster to DMA, slow to read except via SSE4 streaming load instruction * (MOVNTDQA). * Flag for ::cuMemHostAlloc()

CU_PARAM_TR_DEFAULT

CUDA.Import

* For texture references loaded into the module, use default texunit from * texture reference.

CU_TRSA_OVERRIDE_FORMAT

CUDA.Import

* Override the texref format with a format inferred from the array. * Flag for ::cuTexRefSetArray()

CU_TRSF_NORMALIZED_COORDINATES

CUDA.Import

* Use normalized texture coordinates in the range [0,1) instead of [0,dim). * Flag for ::cuTexRefSetFlags()

CU_TRSF_READ_AS_INTEGER

CUDA.Import

* Read the texture as integers rather than promoting the values to floats * in the range [0,1]. * Flag for ::cuTexRefSetFlags()

cVenusOrbitalElements

GLS.SkyDome

(AU) heliocentric venus elements

cVertexModeToGLEnum

GLS.Mesh

C_ALL_LINES

Formats.m3DSConst

C_ALPHA_SPLIT

Formats.m3DSConst

C_ANG_THRESH

Formats.m3DSConst

C_ANIMLENGTH

Formats.m3DSConst

C_APPLY_DISP_GAMMA

Formats.m3DSConst

C_APPLY_FBUF_GAMMA

Formats.m3DSConst

OBSOLETE

C_APPLY_FILE_GAMMA

Formats.m3DSConst

OBSOLETE

C_ARCH_DENOM

Formats.m3DSConst

C_ASNAPS

Formats.m3DSConst

C_AUTO_REFLECT

Formats.m3DSConst

C_AUTO_SMOOTH

Formats.m3DSConst

C_AUTO_UNIFY

Formats.m3DSConst

C_AUTO_WELD

Formats.m3DSConst

C_BACKUP_FILE

Formats.m3DSConst

system options

C_BACK_TYPE

Formats.m3DSConst

C_BGND_METHOD

Formats.m3DSConst

C_BGND_PRES_RATIO

Formats.m3DSConst

C_BGTYPE

Formats.m3DSConst

C_BIAS_DEFAULT

Formats.m3DSConst

C_BITMAP_DRAWER

Formats.m3DSConst

C_BLUR_DUR

Formats.m3DSConst

C_BLUR_FRAMES

Formats.m3DSConst

C_BLUR_SAMPLES

Formats.m3DSConst

C_BOOLTYPE

Formats.m3DSConst

C_BOOLWELD

Formats.m3DSConst

Booleans

C_CAMNAME

Formats.m3DSConst

C_COMM_PORT

Formats.m3DSConst

C_CONESEGS

Formats.m3DSConst

C_CONESIDES

Formats.m3DSConst

C_CONSTS

Formats.m3DSConst

C_CONT_DEFAULT

Formats.m3DSConst

C_CUBDRAWER

Formats.m3DSConst

C_CURMTL_FROM_MESH

Formats.m3DSConst

C_CURTIME

Formats.m3DSConst

C_CUR_MNAME

Formats.m3DSConst

C_DETAIL

Formats.m3DSConst

C_DISP_GAMMA

Formats.m3DSConst

C_DITHER_24

Formats.m3DSConst

C_DITHER_256

Formats.m3DSConst

C_DXFNAME_SRC

Formats.m3DSConst

C_DXF_SMOOTH_ANG

Formats.m3DSConst

C_EDITOR_OK

Formats.m3DSConst

C_ETAPE

Formats.m3DSConst

C_FBUF_GAMMA

Formats.m3DSConst

C_FILE_IN_GAMMA

Formats.m3DSConst

C_FILE_OUT_GAMMA

Formats.m3DSConst

C_FLIDRAWER

Formats.m3DSConst

C_FLIFILE

Formats.m3DSConst

C_FONTSEL

Formats.m3DSConst

C_FORCE_WIRE

Formats.m3DSConst

OBSOLETE

C_FROZ_DISPLAY

Formats.m3DSConst

3d frozen display

C_GAMMA_CORRECT

Formats.m3DSConst

C_GEOSMOOTH

Formats.m3DSConst

C_GET_SHAPE_MAKE_FACES

Formats.m3DSConst

C_GRIDS

Formats.m3DSConst

C_GRID_RANGE

Formats.m3DSConst

C_HEBOT

Formats.m3DSConst

C_HEDEG

Formats.m3DSConst

C_HEDIR

Formats.m3DSConst

C_HEHT

Formats.m3DSConst

C_HEMISEGS

Formats.m3DSConst

C_HESEG

Formats.m3DSConst

C_HETOP

Formats.m3DSConst

C_HETURNS

Formats.m3DSConst

C_HI_CONTRAST

Formats.m3DSConst

C_HOT_CHECK

Formats.m3DSConst

C_HOT_METHOD

Formats.m3DSConst

C_IN_DEVICE

Formats.m3DSConst

C_JPEG_COMPRESSION

Formats.m3DSConst

C_KEYFRAMER_OK

Formats.m3DSConst

C_KF_SHOW_BACKFACE

Formats.m3DSConst

C_KTAPE

Formats.m3DSConst

C_LMTS_ID

GLS.FileLMTS

C_LMTS_SUBS

GLS.FileLMTS

C_LMTS_TEXFNLEN

GLS.FileLMTS

C_LMTS_TEXT

GLS.FileLMTS

C_LMTS_TRIS

GLS.FileLMTS

C_LMTS_VER

GLS.FileLMTS

C_LOFTER_OK

Formats.m3DSConst

C_LOFT_L_REPEAT

Formats.m3DSConst

C_LOFT_UV_NORMALIZE

Formats.m3DSConst

C_LOFT_WITH_TEXTURE

Formats.m3DSConst

C_LOFT_W_REPEAT

Formats.m3DSConst

C_LO_CONTRAST

Formats.m3DSConst

Contrast

C_LTAPE

Formats.m3DSConst

C_LTNAME

Formats.m3DSConst

C_MAPDRAWER

Formats.m3DSConst

C_MAPDRAWER1

Formats.m3DSConst

C_MAPDRAWER2

Formats.m3DSConst

C_MAPDRAWER3

Formats.m3DSConst

C_MAPDRAWER4

Formats.m3DSConst

C_MAPDRAWER5

Formats.m3DSConst

C_MAPDRAWER6

Formats.m3DSConst

C_MAPDRAWER7

Formats.m3DSConst

C_MAPDRAWER8

Formats.m3DSConst

C_MAPDRAWER9

Formats.m3DSConst

C_MAPDRAWER_ENTRY

Formats.m3DSConst

C_MAPTYPE

Formats.m3DSConst

C_MAP_DISPLAY

Formats.m3DSConst

C_MAP_MATRIX

Formats.m3DSConst

C_MAP_MATRIX_OLD

Formats.m3DSConst

C_MAP_SCALE

Formats.m3DSConst

C_MAP_WID_HT

Formats.m3DSConst

C_MAP_XYZ

Formats.m3DSConst

C_MASTER_AMBIENT

Formats.m3DSConst

C_MASTER_SCALES

Formats.m3DSConst

C_MBLUR_DITHER

Formats.m3DSConst

C_MDRAWER

Formats.m3DSConst

C_MD_CE

Formats.m3DSConst

C_MD_CS

Formats.m3DSConst

C_MD_PDET

Formats.m3DSConst

C_MD_SDET

Formats.m3DSConst

C_MD_SML

Formats.m3DSConst

C_MD_SMW

Formats.m3DSConst

C_MEDTILE

Formats.m3DSConst

C_MESHSEL

Formats.m3DSConst

C_MESHUNSEL

Formats.m3DSConst

C_MFILE

Formats.m3DSConst

C_MFTSYM

Formats.m3DSConst

C_MODDRAWER

Formats.m3DSConst

C_MODFILE

Formats.m3DSConst

C_MODICOUNT

Formats.m3DSConst

C_MODMODEL

Formats.m3DSConst

C_MODWMODE

Formats.m3DSConst

C_MSCALE

Formats.m3DSConst

C_MSCSYM

Formats.m3DSConst

C_MSHAX

Formats.m3DSConst

C_MSHCP

Formats.m3DSConst

C_MSHLOCAL

Formats.m3DSConst

C_MTLDRAWER

Formats.m3DSConst

C_MTLFILE

Formats.m3DSConst

C_MTTSYM

Formats.m3DSConst

C_NET_FIELD_ORDER

Formats.m3DSConst

C_NET_USE_GAMMA

Formats.m3DSConst

C_NET_USE_VPOST

Formats.m3DSConst

Special network-use chunks

C_NGPARMS

Formats.m3DSConst

C_NTH_SERIAL_NUM

Formats.m3DSConst

C_NUM_FORMAT

Formats.m3DSConst

C_OBJECT_MBLUR

Formats.m3DSConst

C_OBNAME

Formats.m3DSConst

C_OPTIMIZE_LOFT

Formats.m3DSConst

C_PALFILE

Formats.m3DSConst

C_PAL_TYPE

Formats.m3DSConst

C_PDRAWER

Formats.m3DSConst

C_PFILE

Formats.m3DSConst

C_PICKSIZE

Formats.m3DSConst

C_PIXEL_SIZE

Formats.m3DSConst

C_POLYSEL

Formats.m3DSConst

C_POLYUNSEL

Formats.m3DSConst

C_PREVMODE

Formats.m3DSConst

C_PRISMSEGS

Formats.m3DSConst

C_PRISMSIDES

Formats.m3DSConst

C_PROGMODE

Formats.m3DSConst

C_PTHLEVEL

Formats.m3DSConst

C_PV_DOFNUM

Formats.m3DSConst

C_PV_FPS

Formats.m3DSConst

C_PV_FROM

Formats.m3DSConst

C_PV_METHOD

Formats.m3DSConst

C_PV_NTH

Formats.m3DSConst

C_PV_RNG

Formats.m3DSConst

C_PV_TO

Formats.m3DSConst

C_PV_TYPE

Formats.m3DSConst

C_QUIKSTUFF

Formats.m3DSConst

C_RAX

Formats.m3DSConst

C_RAY_SHADOWS

Formats.m3DSConst

C_REFLIP

Formats.m3DSConst

C_RENDER_ALL

Formats.m3DSConst

C_RENDTYPE

Formats.m3DSConst

C_REND_FIELDS

Formats.m3DSConst

C_REND_FROM

Formats.m3DSConst

C_REND_NTH

Formats.m3DSConst

C_REND_TO

Formats.m3DSConst

C_REND_TSTEP

Formats.m3DSConst

C_RGB_AA

Formats.m3DSConst

C_RGB_ANIMTYPE

Formats.m3DSConst

C_RGB_COMPRESS

Formats.m3DSConst

C_RGB_DISPDEV

Formats.m3DSConst

C_RGB_FILE

Formats.m3DSConst

C_RGB_HARDDEV

Formats.m3DSConst

C_RGB_HIDE

Formats.m3DSConst

C_RGB_MAPSW

Formats.m3DSConst

C_RGB_OUTPUT

Formats.m3DSConst

C_RGB_OVASPECT

Formats.m3DSConst

C_RGB_OVH

Formats.m3DSConst

C_RGB_OVW

Formats.m3DSConst

C_RGB_PATH

Formats.m3DSConst

C_RGB_PICTYPE

Formats.m3DSConst

C_RGB_RMODE

Formats.m3DSConst

C_RGB_SHADOW

Formats.m3DSConst

C_RGB_TODISK

Formats.m3DSConst

C_RGB_TWOSIDE

Formats.m3DSConst

C_RIPDRAWER

Formats.m3DSConst

C_RIPFILE

Formats.m3DSConst

C_RND_MIP

Formats.m3DSConst

C_RND_TURBO

Formats.m3DSConst

C_SAFE_FRAME

Formats.m3DSConst

C_SAVE_LAST

Formats.m3DSConst

C_SEE_3D

Formats.m3DSConst

C_SEE_CAMERAS

Formats.m3DSConst

C_SEE_LIGHTS

Formats.m3DSConst

C_SEG_END

Formats.m3DSConst

C_SEG_START

Formats.m3DSConst

C_SEL_ITEMTOG

Formats.m3DSConst

C_SEL_RESET

Formats.m3DSConst

C_SHAPER_OK

Formats.m3DSConst

C_SHOOK

Formats.m3DSConst

C_SHOW_1STVERT

Formats.m3DSConst

C_SHPDRAWER

Formats.m3DSConst

C_SHPFILE

Formats.m3DSConst

C_SHPLOCAL

Formats.m3DSConst

C_SMOOTHING

Formats.m3DSConst

C_SMOOTH_ANG

Formats.m3DSConst

C_SNAPS

Formats.m3DSConst

C_SPHSEGS

Formats.m3DSConst

C_SRDEG

Formats.m3DSConst

C_SRDIAM

Formats.m3DSConst

C_SRDIR

Formats.m3DSConst

C_SRSEG

Formats.m3DSConst

C_SS_THRESH

Formats.m3DSConst

C_STAPE

Formats.m3DSConst

C_STICKY_KEYINF

Formats.m3DSConst

C_SUPER_BLACK

Formats.m3DSConst

C_SUPER_SAMPLE

Formats.m3DSConst

C_SXP_BUMP_DATA

Formats.m3DSConst

C_SXP_BUMP_MASKDATA

Formats.m3DSConst

C_SXP_OPAC_DATA

Formats.m3DSConst

C_SXP_OPAC_MASKDATA

Formats.m3DSConst

C_SXP_REFL_MASKDATA

Formats.m3DSConst

C_SXP_SELFI_DATA

Formats.m3DSConst

C_SXP_SELFI_MASKDATA

Formats.m3DSConst

C_SXP_SHIN_DATA

Formats.m3DSConst

C_SXP_SHIN_MASKDATA

Formats.m3DSConst

C_SXP_SPEC_DATA

Formats.m3DSConst

C_SXP_SPEC_MASKDATA

Formats.m3DSConst

C_SXP_TEXT2_DATA

Formats.m3DSConst

C_SXP_TEXT2_MASKDATA

Formats.m3DSConst

C_SXP_TEXT_DATA

Formats.m3DSConst

C_SXP_TEXT_MASKDATA

Formats.m3DSConst

C_TAB_BASES

Formats.m3DSConst

C_TAB_DIVS

Formats.m3DSConst

C_TDRAWER

Formats.m3DSConst

C_TENS_DEFAULT

Formats.m3DSConst

C_TESS_TENSION

Formats.m3DSConst

C_TESS_TYPE

Formats.m3DSConst

C_TEXTURE_BLUR_DEFAULT

Formats.m3DSConst

C_TGA_DEPTH

Formats.m3DSConst

C_TILE_XY

Formats.m3DSConst

C_TORSEGS

Formats.m3DSConst

C_TORSIDES

Formats.m3DSConst

C_TUBESEGS

Formats.m3DSConst

C_TUBESIDES

Formats.m3DSConst

C_TXDRAWER

Formats.m3DSConst

C_TXFILE

Formats.m3DSConst

C_TX_STRING

Formats.m3DSConst

C_USERAX

Formats.m3DSConst

C_USE_ALPHA

Formats.m3DSConst

C_VERTMARK

Formats.m3DSConst

C_VIEW_PRES_RATIO

Formats.m3DSConst

C_VP_FROM

Formats.m3DSConst

C_VP_NTH

Formats.m3DSConst

C_VP_TO

Formats.m3DSConst

C_VP_TSTEP

Formats.m3DSConst

C_VTR_FRAMES

Formats.m3DSConst

C_VTR_HD

Formats.m3DSConst

C_VTR_HDTL

Formats.m3DSConst

C_VTR_IN

Formats.m3DSConst

C_VTR_PK

Formats.m3DSConst

C_VTR_SH

Formats.m3DSConst

C_VTR_TL

Formats.m3DSConst

C_WELD_LOFT

Formats.m3DSConst

C_WELD_THRESHOLD

Formats.m3DSConst

C_WORKMTL

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS

Formats.m3DSConst

Material chunks

C_WORK_MTLS_2

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_3

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_4

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_5

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_6

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_7

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_8

Formats.m3DSConst

Old-style – now ignored

C_ZCLIP_POINT

Formats.m3DSConst

D3D11_RESOURCE_DIMENSION_BUFFER

Formats.DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE1D

Formats.DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE2D

Formats.DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE3D

Formats.DXTC

D3D11_RESOURCE_DIMENSION_UNKNOWN

Formats.DXTC

); TD3D11_RESOURCE_DIMENSION = (

DAMP_SHIFT

GLS.ProcTextures

DCEBox

GLS.DCE

dContactApprox0

ODE.Import

dContactApprox1

ODE.Import

dContactApprox1_1

ODE.Import

dContactApprox1_2

ODE.Import

dContactBounce

ODE.Import

dContactFDir1

ODE.Import

dContactMotion1

ODE.Import

dContactMotion2

ODE.Import

dContactMotionN

ODE.Import

dContactMu2

ODE.Import

These consts now have defined types

dContactSlip1

ODE.Import

dContactSlip2

ODE.Import

dContactSoftCFM

ODE.Import

dContactSoftERP

ODE.Import

DCUE_BGND

Formats.m3DSConst

DDF_ANIMATE

Formats.VFW

dont draw frame, just decompress

DDF_BACKGROUNDPAL

Formats.VFW

use DisplayDib

DDF_BUFFER

Formats.VFW

allow palette animation

DDF_DONTDRAW

Formats.VFW

draw params are the same

DDF_FULLSCREEN

Formats.VFW

just draw it with GDI

DDF_HALFTONE

Formats.VFW

hurry up please!

DDF_HURRYUP

Formats.VFW

this is a partial frame update, hint

DDF_JUSTDRAWIT

Formats.VFW

always buffer image

DDF_NOTKEYFRAME

Formats.VFW

Realize palette in background

DDF_PREROLL

Formats.VFW

always halftone

DDF_SAME_DIB

Formats.VFW

Builing up a non-keyframe

DDF_SAME_DRAW

Formats.VFW

HDC same as last call (all setup)

DDF_SAME_HDC

Formats.VFW

re-draw the last DIB

DDF_SAME_SIZE

Formats.VFW

DDF_UPDATE

Formats.VFW

********************************************************************
DrawDib Flags
*********************************************************************

DDPF_A

Formats.DXTC

DDPF_ALPHAPIXELS

Formats.DXTC

DDPF_FOURCC

Formats.DXTC

DDPF_L

Formats.DXTC

DDPF_LA

Formats.DXTC

DDPF_RGB

Formats.DXTC

DDPF_RGBA

Formats.DXTC

DDSCAPS2_CUBEMAP

Formats.DXTC

DDSCAPS2_CUBEMAP_NEGATIVEX

Formats.DXTC

DDSCAPS2_CUBEMAP_NEGATIVEY

Formats.DXTC

DDSCAPS2_CUBEMAP_NEGATIVEZ

Formats.DXTC

DDSCAPS2_CUBEMAP_POSITIVEX

Formats.DXTC

DDSCAPS2_CUBEMAP_POSITIVEY

Formats.DXTC

DDSCAPS2_CUBEMAP_POSITIVEZ

Formats.DXTC

DDSCAPS2_VOLUME

Formats.DXTC

DDSCAPS_COMPLEX

Formats.DXTC

DDSCAPS_MIPMAP

Formats.DXTC

DDSCAPS_TEXTURE

Formats.DXTC

DDSD_CAPS

Formats.DXTC

DDSD_DEPTH

Formats.DXTC

DDSD_HEIGHT

Formats.DXTC

DDSD_LINEARSIZE

Formats.DXTC

DDSD_MIPMAPCOUNT

Formats.DXTC

DDSD_PITCH

Formats.DXTC

DDSD_PIXELFORMAT

Formats.DXTC

DDSD_WIDTH

Formats.DXTC

DebugMode

GLS.PhysInertias

DefaultTextDomain

gnugettext

***************************************************************************

DEFAULT_VIEW

Formats.m3DSConst

DefFace3DS

Formats.m3DSConst

DefKeyHeader3DS

Formats.m3DSConst

DefKFRotKey3DS

Formats.m3DSConst

DefObjMat3DS

Formats.m3DSConst

DEFORM_LIMIT

Formats.m3DSConst

DefPoint3DS

Formats.m3DSConst

Basic structure default contents for ease of initialization

DefTextVert3DS

Formats.m3DSConst

DefTrackHeader3DS

Formats.m3DSConst

DISABLE_NODE

Formats.m3DSConst

DistanceCueMax3DS

Formats.m3DSConst

minimum value for dimming factor

DistanceCueMin3DS

Formats.m3DSConst

maximum value for fogging plane density DISTANCE_CUE

DISTANCE_CUE

Formats.m3DSConst

dJOINT_INGROUP

ODE.Import

These consts now have defined types if this flag is set, the joint was allocated in a joint group

dJOINT_REVERSE

ODE.Import

if this flag is set, the joint was attached with arguments (0,body). our convention is to treat all attaches as (body,0), i.e. so node[0].body is always nonzero, so this flag records the fact that the arguments were swapped

dJOINT_TWOBODIES

ODE.Import

if this flag is set, the joint can not have just one body attached to it, it must have either zero or two bodies attached

DLLocalShadow2FMax3DS

Formats.m3DSConst

minimum shadow map size

DLLocalShadow2FMin3DS

Formats.m3DSConst

maximum shadow map size

DLLocalShadow2SMax3DS

Formats.m3DSConst

minimum shadow map size

DLLocalShadow2SMin3DS

Formats.m3DSConst

maximum for hotspot and falloff cones DL_LOCAL_SHADOW2

DLSpotlightMax3DS

Formats.m3DSConst

minimum for hotspot and falloff cones

DLSpotlightMin3DS

Formats.m3DSConst

maximum string length for axp process DL_SPOTLIGHT

DL_ATTENUATE

Formats.m3DSConst

DL_EXCLUDE

Formats.m3DSConst

DL_INNER_RANGE

Formats.m3DSConst

DL_LOCAL_SHADOW

Formats.m3DSConst

DL_LOCAL_SHADOW2

Formats.m3DSConst

DL_MULTIPLIER

Formats.m3DSConst

DL_OFF

Formats.m3DSConst

DL_OUTER_RANGE

Formats.m3DSConst

DL_RANGE

Formats.m3DSConst

DL_RAYSHAD

Formats.m3DSConst

DL_RAY_BIAS

Formats.m3DSConst

DL_SEE_CONE

Formats.m3DSConst

DL_SHADOWED

Formats.m3DSConst

DL_SPOTLIGHT

Formats.m3DSConst

DL_SPOT_ASPECT

Formats.m3DSConst

DL_SPOT_OVERSHOOT

Formats.m3DSConst

DL_SPOT_PROJECTOR

Formats.m3DSConst

DL_SPOT_RECTANGULAR

Formats.m3DSConst

DL_SPOT_ROLL

Formats.m3DSConst

Not used in R3

dParamBounce

ODE.Import

dParamBounce1

ODE.Import

dParamBounce2

ODE.Import

dParamBounce3

ODE.Import

dParamCFM

ODE.Import

dParamCFM1

ODE.Import

dParamCFM2

ODE.Import

dParamCFM3

ODE.Import

dParamERP

ODE.Import

dParamERP1

ODE.Import

dParamERP2

ODE.Import

dParamERP3

ODE.Import

dParamFMax

ODE.Import

dParamFMax1

ODE.Import

dParamFMax2

ODE.Import

dParamFMax3

ODE.Import

dParamFudgeFactor

ODE.Import

dParamFudgeFactor1

ODE.Import

dParamFudgeFactor2

ODE.Import

dParamFudgeFactor3

ODE.Import

dParamGroup

ODE.Import

dParamGroup1

ODE.Import

dParamGroup2

ODE.Import

SECOND AXEL parameters for limits and motors

dParamGroup3

ODE.Import

THIRD AXEL parameters for limits and motors

dParamHiStop

ODE.Import

dParamHiStop1

ODE.Import

dParamHiStop2

ODE.Import

dParamHiStop3

ODE.Import

dParamLoStop

ODE.Import

dParamLoStop1

ODE.Import

dParamLoStop2

ODE.Import

dParamLoStop3

ODE.Import

dParamStopCFM

ODE.Import

dParamStopCFM1

ODE.Import

dParamStopCFM2

ODE.Import

dParamStopCFM3

ODE.Import

dParamStopERP

ODE.Import

dParamStopERP1

ODE.Import

dParamStopERP2

ODE.Import

dParamStopERP3

ODE.Import

dParamSuspensionCFM

ODE.Import

dParamSuspensionCFM1

ODE.Import

dParamSuspensionCFM2

ODE.Import

dParamSuspensionCFM3

ODE.Import

dParamSuspensionERP

ODE.Import

parameters for suspension

dParamSuspensionERP1

ODE.Import

parameters for suspension

dParamSuspensionERP2

ODE.Import

parameters for suspension

dParamSuspensionERP3

ODE.Import

parameters for suspension

dParamVel

ODE.Import

dParamVel1

ODE.Import

dParamVel2

ODE.Import

dParamVel3

ODE.Import

DSCAPS_CERTIFIED

BASS.Import

device does not have hardware DirectSound support

DSCAPS_EMULDRIVER

BASS.Import

BASS_INFO flags (from DSOUND.H)

DSCAPS_HARDWARE

BASS.Import

device driver has been certified by Microsoft

DSCCAPS_CERTIFIED

BASS.Import

device does not have hardware DirectSound recording support

DSCCAPS_EMULDRIVER

BASS.Import

hardware mixed BASS_RECORDINFO flags (from DSOUND.H)

DSPROPERTY_EAXBUFFER_AIRABSORPTIONFACTOR

OpenAL.Import

DSPROPERTY_EAXBUFFER_ALLPARAMETERS

OpenAL.Import

DSPROPERTY_EAXBUFFER_COMMITDEFERREDSETTINGS

OpenAL.Import

DSPROPERTY_EAXBUFFER_DEFERRED

OpenAL.Import

changes take effect immediately

DSPROPERTY_EAXBUFFER_DIRECT

OpenAL.Import

DSPROPERTY_EAXBUFFER_DIRECTHF

OpenAL.Import

DSPROPERTY_EAXBUFFER_FLAG

OpenAL.Import

DSPROPERTY_EAXBUFFER_IMMEDIATE

OpenAL.Import

OR these flags with property id

DSPROPERTY_EAXBUFFER_NONE

OpenAL.Import

For compatibility with future EAX versions: DSPROPSETID_EAX_BufferProperties = DSPROPSETID_EAX20_BufferProperties; Enumeration DSPROPERTY_EAX_BUFFERPROPERTY

DSPROPERTY_EAXBUFFER_OBSTRUCTION

OpenAL.Import

DSPROPERTY_EAXBUFFER_OBSTRUCTIONLFRATIO

OpenAL.Import

DSPROPERTY_EAXBUFFER_OCCLUSION

OpenAL.Import

DSPROPERTY_EAXBUFFER_OCCLUSIONLFRATIO

OpenAL.Import

DSPROPERTY_EAXBUFFER_OCCLUSIONROOMRATIO

OpenAL.Import

DSPROPERTY_EAXBUFFER_OUTSIDEVOLUMEHF

OpenAL.Import

DSPROPERTY_EAXBUFFER_ROOM

OpenAL.Import

DSPROPERTY_EAXBUFFER_ROOMHF

OpenAL.Import

DSPROPERTY_EAXBUFFER_ROOMROLLOFFFACTOR

OpenAL.Import

DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF

OpenAL.Import

DSPROPERTY_EAXLISTENER_ALLPARAMETERS

OpenAL.Import

DSPROPERTY_EAXLISTENER_COMMITDEFERREDSETTINGS

OpenAL.Import

DSPROPERTY_EAXLISTENER_DECAYHFRATIO

OpenAL.Import

DSPROPERTY_EAXLISTENER_DECAYTIME

OpenAL.Import

DSPROPERTY_EAXLISTENER_DEFERRED

OpenAL.Import

changes take effect immediately

DSPROPERTY_EAXLISTENER_ENVIRONMENT

OpenAL.Import

DSPROPERTY_EAXLISTENER_ENVIRONMENTDIFFUSION

OpenAL.Import

DSPROPERTY_EAXLISTENER_ENVIRONMENTSIZE

OpenAL.Import

DSPROPERTY_EAXLISTENER_FLAGS

OpenAL.Import

DSPROPERTY_EAXLISTENER_IMMEDIATE

OpenAL.Import

OR these flags with property id

DSPROPERTY_EAXLISTENER_NONE

OpenAL.Import

For compatibility with future EAX versions: DSPROPSETID_EAX_ListenerProperties = DSPROPSETID_EAX20_ListenerProperties; DSPROPSETID_EAX_SourceProperties = DSPROPSETID_EAX20_BufferProperties; Enumerations DSPROPERTY_EAX_LISTENERPROPERTY

DSPROPERTY_EAXLISTENER_REFLECTIONS

OpenAL.Import

DSPROPERTY_EAXLISTENER_REFLECTIONSDELAY

OpenAL.Import

DSPROPERTY_EAXLISTENER_REVERB

OpenAL.Import

DSPROPERTY_EAXLISTENER_REVERBDELAY

OpenAL.Import

DSPROPERTY_EAXLISTENER_ROOM

OpenAL.Import

DSPROPERTY_EAXLISTENER_ROOMHF

OpenAL.Import

DSPROPERTY_EAXLISTENER_ROOMROLLOFFFACTOR

OpenAL.Import

DSPROPSETID_EAX20_BufferProperties

OpenAL.Import

DSPROPSETID_EAX20_ListenerProperties

OpenAL.Import

END EFX extension EAX extension

DUMMY

Formats.m3DSConst

Dummy Chunk that sometimes appears in 3DS files created by prerelease 3D Studio R2

DummyName3DS

Formats.m3DSConst

DVM_CONFIGURE_END

Formats.VFW

DVM_CONFIGURE_START

Formats.VFW

DVM_DST_RECT

Formats.VFW

DVM_FORMAT

Formats.VFW

DVM_PALETTE

Formats.VFW

DVM_PALETTERGB555

Formats.VFW

DVM_SRC_RECT

Formats.VFW

DVM_USER

Formats.VFW

== Configure messages =======================================================

DV_ERR_13

Formats.VFW

DV_ERR_ALLOCATED

Formats.VFW

out of memory

DV_ERR_BADDEVICEID

Formats.VFW

device is allocated

DV_ERR_BADERRNUM

Formats.VFW

DV_ERR_BADFORMAT

Formats.VFW

DV_ERR_BADINSTALL

Formats.VFW

HW not detected

DV_ERR_BASE

Formats.VFW

No error

DV_ERR_CONFIG1

Formats.VFW

DV_ERR_CONFIG2

Formats.VFW

DV_ERR_CREATEPALETTE

Formats.VFW

Can not get Profile

DV_ERR_DMA_CONFLICT

Formats.VFW

I/O conflict detected

DV_ERR_FLAGS

Formats.VFW

DV_ERR_INT_CONFLICT

Formats.VFW

DMA conflict detected

DV_ERR_INVALHANDLE

Formats.VFW

DV_ERR_IO_CONFLICT

Formats.VFW

Mem conflict detected

DV_ERR_LASTERROR

Formats.VFW

Can not run in standard mode

DV_ERR_MEM_CONFLICT

Formats.VFW

out of buffers

DV_ERR_NOMEM

Formats.VFW

function not suported

DV_ERR_NONSPECIFIC

Formats.VFW

Error Base

DV_ERR_NOTDETECTED

Formats.VFW

number of channels exceeded

DV_ERR_NOTSUPPORTED

Formats.VFW

DV_ERR_NO_BUFFERS

Formats.VFW

DV_ERR_OK

Formats.VFW

– Error return values ——————————————————

DV_ERR_PARAM1

Formats.VFW

DV_ERR_PARAM2

Formats.VFW

DV_ERR_PROTECT_ONLY

Formats.VFW

Interrupt conflict detected

DV_ERR_SIZEFIELD

Formats.VFW

DV_ERR_STILLPLAYING

Formats.VFW

unsupported video format

DV_ERR_SYNC

Formats.VFW

header not prepared

DV_ERR_TOOMANYCHANNELS

Formats.VFW

device is synchronous

DV_ERR_UNPREPARED

Formats.VFW

still something playing

DV_ERR_USER_MSG

Formats.VFW

DV_VM_CLOSE

Formats.VFW

Obsolete messages

DV_VM_DATA

Formats.VFW

DV_VM_ERROR

Formats.VFW

DV_VM_OPEN

Formats.VFW

Note that the values for all installable driver callback messages are identical, (ie. MM_DRVM_DATA has the same value for capture drivers, installable video codecs, and the audio compression manager).

DW_ERROR

BASS.Import

Use these to test for error from functions that return a DWORD or QWORD

dxBodyDisabled

ODE.Import

use finite rotations only along axis

dxBodyFlagFiniteRotation

ODE.Import

These consts now have defined types

dxBodyFlagFiniteRotationAxis

ODE.Import

use finite rotations

dxBodyNoGravity

ODE.Import

body is disabled

DXGI_FORMAT_A8_UNORM

Formats.DXTC

DXGI_FORMAT_B5G5R5A1_UNORM

Formats.DXTC

DXGI_FORMAT_B5G6R5_UNORM

Formats.DXTC

DXGI_FORMAT_B8G8R8A8_TYPELESS

Formats.DXTC

DXGI_FORMAT_B8G8R8A8_UNORM

Formats.DXTC

DXGI_FORMAT_B8G8R8A8_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_B8G8R8X8_TYPELESS

Formats.DXTC

DXGI_FORMAT_B8G8R8X8_UNORM

Formats.DXTC

DXGI_FORMAT_B8G8R8X8_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_BC1_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC1_UNORM

Formats.DXTC

DXGI_FORMAT_BC1_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_BC2_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC2_UNORM

Formats.DXTC

DXGI_FORMAT_BC2_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_BC3_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC3_UNORM

Formats.DXTC

DXGI_FORMAT_BC3_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_BC4_SNORM

Formats.DXTC

DXGI_FORMAT_BC4_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC4_UNORM

Formats.DXTC

DXGI_FORMAT_BC5_SNORM

Formats.DXTC

DXGI_FORMAT_BC5_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC5_UNORM

Formats.DXTC

DXGI_FORMAT_BC6H_SF16

Formats.DXTC

DXGI_FORMAT_BC6H_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC6H_UF16

Formats.DXTC

DXGI_FORMAT_BC7_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC7_UNORM

Formats.DXTC

DXGI_FORMAT_BC7_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_D16_UNORM

Formats.DXTC

DXGI_FORMAT_D24_UNORM_S8_UINT

Formats.DXTC

DXGI_FORMAT_D32_FLOAT

Formats.DXTC

DXGI_FORMAT_D32_FLOAT_S8X24_UINT

Formats.DXTC

DXGI_FORMAT_FORCE_UINT

Formats.DXTC

TDXGI_FORMAT = (

DXGI_FORMAT_G8R8_G8B8_UNORM

Formats.DXTC

DXGI_FORMAT_R10G10B10A2_TYPELESS

Formats.DXTC

DXGI_FORMAT_R10G10B10A2_UINT

Formats.DXTC

DXGI_FORMAT_R10G10B10A2_UNORM

Formats.DXTC

DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM

Formats.DXTC

DXGI_FORMAT_R11G11B10_FLOAT

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_FLOAT

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_SINT

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_SNORM

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_TYPELESS

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_UINT

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_UNORM

Formats.DXTC

DXGI_FORMAT_R16G16_FLOAT

Formats.DXTC

DXGI_FORMAT_R16G16_SINT

Formats.DXTC

DXGI_FORMAT_R16G16_SNORM

Formats.DXTC

DXGI_FORMAT_R16G16_TYPELESS

Formats.DXTC

DXGI_FORMAT_R16G16_UINT

Formats.DXTC

DXGI_FORMAT_R16G16_UNORM

Formats.DXTC

DXGI_FORMAT_R16_FLOAT

Formats.DXTC

DXGI_FORMAT_R16_SINT

Formats.DXTC

DXGI_FORMAT_R16_SNORM

Formats.DXTC

DXGI_FORMAT_R16_TYPELESS

Formats.DXTC

DXGI_FORMAT_R16_UINT

Formats.DXTC

DXGI_FORMAT_R16_UNORM

Formats.DXTC

DXGI_FORMAT_R1_UNORM

Formats.DXTC

DXGI_FORMAT_R24G8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R24_UNORM_X8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32G32B32A32_FLOAT

Formats.DXTC

DXGI_FORMAT_R32G32B32A32_SINT

Formats.DXTC

DXGI_FORMAT_R32G32B32A32_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32G32B32A32_UINT

Formats.DXTC

DXGI_FORMAT_R32G32B32_FLOAT

Formats.DXTC

DXGI_FORMAT_R32G32B32_SINT

Formats.DXTC

DXGI_FORMAT_R32G32B32_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32G32B32_UINT

Formats.DXTC

DXGI_FORMAT_R32G32_FLOAT

Formats.DXTC

DXGI_FORMAT_R32G32_SINT

Formats.DXTC

DXGI_FORMAT_R32G32_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32G32_UINT

Formats.DXTC

DXGI_FORMAT_R32G8X24_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32_FLOAT

Formats.DXTC

DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32_SINT

Formats.DXTC

DXGI_FORMAT_R32_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32_UINT

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_SINT

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_SNORM

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_UINT

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_UNORM

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_R8G8_B8G8_UNORM

Formats.DXTC

DXGI_FORMAT_R8G8_SINT

Formats.DXTC

DXGI_FORMAT_R8G8_SNORM

Formats.DXTC

DXGI_FORMAT_R8G8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R8G8_UINT

Formats.DXTC

DXGI_FORMAT_R8G8_UNORM

Formats.DXTC

DXGI_FORMAT_R8_SINT

Formats.DXTC

DXGI_FORMAT_R8_SNORM

Formats.DXTC

DXGI_FORMAT_R8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R8_UINT

Formats.DXTC

DXGI_FORMAT_R8_UNORM

Formats.DXTC

DXGI_FORMAT_R9G9B9E5_SHAREDEXP

Formats.DXTC

DXGI_FORMAT_UNKNOWN

Formats.DXTC

DXGI_FORMAT_X24_TYPELESS_G8_UINT

Formats.DXTC

DXGI_FORMAT_X32_TYPELESS_G8X24_UINT

Formats.DXTC

EAXBUFFERFLAGS_DIRECTHFAUTO

OpenAL.Import

Used by DSPROPERTY_EAXBUFFER_FLAGS TRUE: value is computed automatically - property is an offset FALSE: value is used directly
Note: The number and order of flags may change in future EAX versions. To insure future compatibility, use flag defines as follows: myFlags = EAXBUFFERFLAGS_DIRECTHFAUTO | EAXBUFFERFLAGS_ROOMAUTO; instead of: myFlags = 0x00000003;

EAXBUFFERFLAGS_RESERVED

OpenAL.Import

affects DSPROPERTY_EAXBUFFER_ROOMHF

EAXBUFFERFLAGS_ROOMAUTO

OpenAL.Import

affects DSPROPERTY_EAXBUFFER_DIRECTHF

EAXBUFFERFLAGS_ROOMHFAUTO

OpenAL.Import

affects DSPROPERTY_EAXBUFFER_ROOM

EAXBUFFER_DEFAULTAIRABSORPTIONFACTOR

OpenAL.Import

EAXBUFFER_DEFAULTDIRECT

OpenAL.Import

EAXBUFFER_DEFAULTDIRECTHF

OpenAL.Import

EAXBUFFER_DEFAULTFLAGS

OpenAL.Import

EAXBUFFER_DEFAULTOBSTRUCTION

OpenAL.Import

EAXBUFFER_DEFAULTOBSTRUCTIONLFRATIO

OpenAL.Import

EAXBUFFER_DEFAULTOCCLUSION

OpenAL.Import

EAXBUFFER_DEFAULTOCCLUSIONLFRATIO

OpenAL.Import

EAXBUFFER_DEFAULTOCCLUSIONROOMRATIO

OpenAL.Import

EAXBUFFER_DEFAULTOUTSIDEVOLUMEHF

OpenAL.Import

EAXBUFFER_DEFAULTROOM

OpenAL.Import

EAXBUFFER_DEFAULTROOMHF

OpenAL.Import

EAXBUFFER_DEFAULTROOMROLLOFFFACTOR

OpenAL.Import

EAXBUFFER_MAXAIRABSORPTIONFACTOR

OpenAL.Import

EAXBUFFER_MAXDIRECT

OpenAL.Import

EAXBUFFER_MAXDIRECTHF

OpenAL.Import

EAXBUFFER_MAXOBSTRUCTION

OpenAL.Import

EAXBUFFER_MAXOBSTRUCTIONLFRATIO

OpenAL.Import

EAXBUFFER_MAXOCCLUSION

OpenAL.Import

EAXBUFFER_MAXOCCLUSIONLFRATIO

OpenAL.Import

EAXBUFFER_MAXOCCLUSIONROOMRATIO

OpenAL.Import

EAXBUFFER_MAXOUTSIDEVOLUMEHF

OpenAL.Import

EAXBUFFER_MAXROOM

OpenAL.Import

EAXBUFFER_MAXROOMHF

OpenAL.Import

EAXBUFFER_MAXROOMROLLOFFFACTOR

OpenAL.Import

EAXBUFFER_MINAIRABSORPTIONFACTOR

OpenAL.Import

EAXBUFFER_MINDIRECT

OpenAL.Import

reserved future use property ranges and defaults:

EAXBUFFER_MINDIRECTHF

OpenAL.Import

EAXBUFFER_MINOBSTRUCTION

OpenAL.Import

EAXBUFFER_MINOBSTRUCTIONLFRATIO

OpenAL.Import

EAXBUFFER_MINOCCLUSION

OpenAL.Import

EAXBUFFER_MINOCCLUSIONLFRATIO

OpenAL.Import

EAXBUFFER_MINOCCLUSIONROOMRATIO

OpenAL.Import

EAXBUFFER_MINOUTSIDEVOLUMEHF

OpenAL.Import

EAXBUFFER_MINROOM

OpenAL.Import

EAXBUFFER_MINROOMHF

OpenAL.Import

EAXBUFFER_MINROOMROLLOFFFACTOR

OpenAL.Import

EAXLISTENERFLAGS_DECAYHFLIMIT

OpenAL.Import

late reverberation delay time This flag limits high-frequency decay time according to air absorption.

EAXLISTENERFLAGS_DECAYTIMESCALE

OpenAL.Import

Used by DSPROPERTY_EAXLISTENER_FLAGS
Note: The number and order of flags may change in future EAX versions. It is recommended to use the flag defines as follows: myFlags = EAXLISTENERFLAGS_DECAYTIMESCALE | EAXLISTENERFLAGS_REVERBSCALE; instead of: myFlags = 0x00000009;
These flags determine what properties are affected by environment size.

EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE

OpenAL.Import

reflection level

EAXLISTENERFLAGS_REFLECTIONSSCALE

OpenAL.Import

reverberation decay time

EAXLISTENERFLAGS_RESERVED

OpenAL.Import

EAXLISTENERFLAGS_REVERBDELAYSCALE

OpenAL.Import

reflections level

EAXLISTENERFLAGS_REVERBSCALE

OpenAL.Import

initial reflection delay time

EAXLISTENER_DEFAULTAIRABSORPTIONHF

OpenAL.Import

EAXLISTENER_DEFAULTDECAYHFRATIO

OpenAL.Import

EAXLISTENER_DEFAULTDECAYTIME

OpenAL.Import

EAXLISTENER_DEFAULTENVIRONMENT

OpenAL.Import

EAXLISTENER_DEFAULTENVIRONMENTDIFFUSION

OpenAL.Import

EAXLISTENER_DEFAULTENVIRONMENTSIZE

OpenAL.Import

EAXLISTENER_DEFAULTFLAGS

OpenAL.Import

EAXLISTENER_DEFAULTREFLECTIONS

OpenAL.Import

EAXLISTENER_DEFAULTREFLECTIONSDELAY

OpenAL.Import

EAXLISTENER_DEFAULTREVERB

OpenAL.Import

EAXLISTENER_DEFAULTREVERBDELAY

OpenAL.Import

EAXLISTENER_DEFAULTROOM

OpenAL.Import

EAXLISTENER_DEFAULTROOMHF

OpenAL.Import

EAXLISTENER_DEFAULTROOMROLLOFFFACTOR

OpenAL.Import

EAXLISTENER_MAXAIRABSORPTIONHF

OpenAL.Import

EAXLISTENER_MAXDECAYHFRATIO

OpenAL.Import

EAXLISTENER_MAXDECAYTIME

OpenAL.Import

EAXLISTENER_MAXENVIRONMENT

OpenAL.Import

EAXLISTENER_MAXENVIRONMENTDIFFUSION

OpenAL.Import

EAXLISTENER_MAXENVIRONMENTSIZE

OpenAL.Import

EAXLISTENER_MAXREFLECTIONS

OpenAL.Import

EAXLISTENER_MAXREFLECTIONSDELAY

OpenAL.Import

EAXLISTENER_MAXREVERB

OpenAL.Import

EAXLISTENER_MAXREVERBDELAY

OpenAL.Import

EAXLISTENER_MAXROOM

OpenAL.Import

EAXLISTENER_MAXROOMHF

OpenAL.Import

EAXLISTENER_MAXROOMROLLOFFFACTOR

OpenAL.Import

EAXLISTENER_MINAIRABSORPTIONHF

OpenAL.Import

EAXLISTENER_MINDECAYHFRATIO

OpenAL.Import

EAXLISTENER_MINDECAYTIME

OpenAL.Import

EAXLISTENER_MINENVIRONMENT

OpenAL.Import

EAXLISTENER_MINENVIRONMENTDIFFUSION

OpenAL.Import

EAXLISTENER_MINENVIRONMENTSIZE

OpenAL.Import

EAXLISTENER_MINREFLECTIONS

OpenAL.Import

EAXLISTENER_MINREFLECTIONSDELAY

OpenAL.Import

EAXLISTENER_MINREVERB

OpenAL.Import

EAXLISTENER_MINREVERBDELAY

OpenAL.Import

EAXLISTENER_MINROOM

OpenAL.Import

reserved future use property ranges and defaults:

EAXLISTENER_MINROOMHF

OpenAL.Import

EAXLISTENER_MINROOMROLLOFFFACTOR

OpenAL.Import

EAX_ENVIRONMENT_ALLEY

BASS.Import

EAX_ENVIRONMENT_ALLEY

OpenAL.Import

EAX_ENVIRONMENT_ARENA

BASS.Import

EAX_ENVIRONMENT_ARENA

OpenAL.Import

EAX_ENVIRONMENT_AUDITORIUM

BASS.Import

EAX_ENVIRONMENT_AUDITORIUM

OpenAL.Import

EAX_ENVIRONMENT_BATHROOM

BASS.Import

EAX_ENVIRONMENT_BATHROOM

OpenAL.Import

EAX_ENVIRONMENT_CARPETEDHALLWAY

BASS.Import

EAX_ENVIRONMENT_CARPETEDHALLWAY

OpenAL.Import

EAX_ENVIRONMENT_CAVE

BASS.Import

EAX_ENVIRONMENT_CAVE

OpenAL.Import

EAX_ENVIRONMENT_CITY

BASS.Import

EAX_ENVIRONMENT_CITY

OpenAL.Import

EAX_ENVIRONMENT_CONCERTHALL

BASS.Import

EAX_ENVIRONMENT_CONCERTHALL

OpenAL.Import

EAX_ENVIRONMENT_COUNT

BASS.Import

total number of environments

EAX_ENVIRONMENT_COUNT

OpenAL.Import

EAX_ENVIRONMENT_DIZZY

BASS.Import

EAX_ENVIRONMENT_DIZZY

OpenAL.Import

EAX_ENVIRONMENT_DRUGGED

BASS.Import

EAX_ENVIRONMENT_DRUGGED

OpenAL.Import

EAX_ENVIRONMENT_FOREST

BASS.Import

EAX_ENVIRONMENT_FOREST

OpenAL.Import

EAX_ENVIRONMENT_GENERIC

BASS.Import

EAX environments, use with BASS_SetEAXParameters

EAX_ENVIRONMENT_GENERIC

OpenAL.Import

used by DSPROPERTY_EAXLISTENER_ENVIRONMENT Enummetation

EAX_ENVIRONMENT_HALLWAY

BASS.Import

EAX_ENVIRONMENT_HALLWAY

OpenAL.Import

EAX_ENVIRONMENT_HANGAR

BASS.Import

EAX_ENVIRONMENT_HANGAR

OpenAL.Import

EAX_ENVIRONMENT_LIVINGROOM

BASS.Import

EAX_ENVIRONMENT_LIVINGROOM

OpenAL.Import

EAX_ENVIRONMENT_MOUNTAINS

BASS.Import

EAX_ENVIRONMENT_MOUNTAINS

OpenAL.Import

EAX_ENVIRONMENT_PADDEDCELL

BASS.Import

EAX_ENVIRONMENT_PADDEDCELL

OpenAL.Import

EAX_ENVIRONMENT_PARKINGLOT

BASS.Import

EAX_ENVIRONMENT_PARKINGLOT

OpenAL.Import

EAX_ENVIRONMENT_PLAIN

BASS.Import

EAX_ENVIRONMENT_PLAIN

OpenAL.Import

EAX_ENVIRONMENT_PSYCHOTIC

BASS.Import

EAX_ENVIRONMENT_PSYCHOTIC

OpenAL.Import

EAX_ENVIRONMENT_QUARRY

BASS.Import

EAX_ENVIRONMENT_QUARRY

OpenAL.Import

EAX_ENVIRONMENT_ROOM

BASS.Import

EAX_ENVIRONMENT_ROOM

OpenAL.Import

EAX_ENVIRONMENT_SEWERPIPE

BASS.Import

EAX_ENVIRONMENT_SEWERPIPE

OpenAL.Import

EAX_ENVIRONMENT_STONECORRIDOR

BASS.Import

EAX_ENVIRONMENT_STONECORRIDOR

OpenAL.Import

EAX_ENVIRONMENT_STONEROOM

BASS.Import

EAX_ENVIRONMENT_STONEROOM

OpenAL.Import

EAX_ENVIRONMENT_UNDERWATER

BASS.Import

EAX_ENVIRONMENT_UNDERWATER

OpenAL.Import

EAX_MATERIAL_BRICKWALL

OpenAL.Import

Brick wall material preset

EAX_MATERIAL_BRICKWALLLF

OpenAL.Import

EAX_MATERIAL_BRICKWALLROOMRATIO

OpenAL.Import

EAX_MATERIAL_CURTAIN

OpenAL.Import

Curtain material preset

EAX_MATERIAL_CURTAINLF

OpenAL.Import

EAX_MATERIAL_CURTAINROOMRATIO

OpenAL.Import

EAX_MATERIAL_DOUBLEWINDOW

OpenAL.Import

Double window material preset

EAX_MATERIAL_DOUBLEWINDOWHF

OpenAL.Import

EAX_MATERIAL_DOUBLEWINDOWROOMRATIO

OpenAL.Import

EAX_MATERIAL_SINGLEWINDOW

OpenAL.Import

Material transmission presets 3 values in this order: 1: occlusion (or obstruction) 2: occlusion LF Ratio (or obstruction LF Ratio) 3: occlusion Room Ratio Single window material preset

EAX_MATERIAL_SINGLEWINDOWLF

OpenAL.Import

EAX_MATERIAL_SINGLEWINDOWROOMRATIO

OpenAL.Import

EAX_MATERIAL_STONEWALL

OpenAL.Import

Stone wall material preset

EAX_MATERIAL_STONEWALLLF

OpenAL.Import

EAX_MATERIAL_STONEWALLROOMRATIO

OpenAL.Import

EAX_MATERIAL_THICKDOOR

OpenAL.Import

Thick door material preset

EAX_MATERIAL_THICKDOORLF

OpenAL.Import

EAX_MATERIAL_THICKDOORROOMRTATION

OpenAL.Import

EAX_MATERIAL_THINDOOR

OpenAL.Import

Thin door material preset

EAX_MATERIAL_THINDOORLF

OpenAL.Import

EAX_MATERIAL_THINDOORROOMRATIO

OpenAL.Import

EAX_MATERIAL_WOODWALL

OpenAL.Import

Wood wall material preset

EAX_MATERIAL_WOODWALLLF

OpenAL.Import

EAX_MATERIAL_WOODWALLROOMRATIO

OpenAL.Import

EFFECTS_SELECTED

FmSceneEditor

EmptyHmgMatrix

GLScene.VectorGeometry

EmptyMatrix

GLScene.VectorGeometry

ENVL_CHAN

Formats.LWO

SPAN

ENVL_KEY

Formats.LWO

POST

ENVL_NAME

Formats.LWO

CHAN

ENVL_POST

Formats.LWO

PRE-BEHAVIOUR

ENVL_PRE

Formats.LWO

ICON

ENVL_SPAN

Formats.LWO

KEY

EPSILON

GLScene.VectorGeometry

Some very small numbers

EPSILON2

GLScene.VectorGeometry

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB

GLScene.OpenGL4

ERROR_INVALID_PIXEL_TYPE_ARB

GLScene.OpenGL4

WGL_ARB_make_current_read

ERROR_INVALID_PIXEL_TYPE_EXT

GLScene.OpenGL4

WGL_EXT_make_current_read

ERROR_INVALID_PROFILE_ARB

GLScene.OpenGL4

ERROR_INVALID_PROFILE_ARB

GLScene.OpenGLTokens

ERROR_INVALID_VERSION_ARB

GLScene.OpenGL4

ERROR_INVALID_VERSION_ARB

GLScene.OpenGLTokens

ERR_MAX_ARGS

SDL.Import

ERR_MAX_STRLEN

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_error.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

ExPtTolerance

GLScene.Triangulation

FaceABVisable3DS

Formats.m3DSConst

flags the BC edge as visible

FaceArrayMin3DS

Formats.m3DSConst

minimum number of vertices FACE_ARRAY

FaceBCVisable3DS

Formats.m3DSConst

flags the CA edge as visible

FaceCAVisable3DS

Formats.m3DSConst

—————- Constants for commonly used structures ——————– Flags used by the flag field of the Mesh3DS structure

FaceUWrap3DS

Formats.m3DSConst

flags the AB edge as visible

FaceVWrap3DS

Formats.m3DSConst

flags the face as being at a texture coord u wrap seam

FACE_ARRAY

Formats.m3DSConst

FACE_ARRAY_ENTRY

Formats.m3DSConst

FACE_POLYGON

Formats.Q3BSP

FallTrackTagMax3DS

Formats.m3DSConst

Minimum fall off angle

FallTrackTagMin3DS

Formats.m3DSConst

Maximum hot spot angle FALL_TRACK_TAG_KEY

FALL_TRACK_TAG

Formats.m3DSConst

FALL_TRACK_TAG_KEY

Formats.m3DSConst

FAST_NODE

Formats.m3DSConst

FileAttrStrMax3DS

Formats.m3DSConst

3DS file attributes

FileNameStrMax3DS

Formats.m3DSConst

————– constants that define various value ranges for specific chunks 3DS filename

FIND_ANY

Formats.VFW

find key frame.

FIND_DIR

Formats.VFW

– Flags for AVIStreamFindSample ——————————————–

FIND_FORMAT

Formats.VFW

find any (non-empty) sample

FIND_FROM_START

Formats.VFW

go backward

FIND_INDEX

Formats.VFW

return physical size

FIND_KEY

Formats.VFW

type mask

FIND_LENGTH

Formats.VFW

return logical position

FIND_NEXT

Formats.VFW

direction

FIND_OFFSET

Formats.VFW

return logical size

FIND_POS

Formats.VFW

return mask

FIND_PREV

Formats.VFW

go forward

FIND_RET

Formats.VFW

find format change

FIND_SIZE

Formats.VFW

return physical position

FIND_TYPE

Formats.VFW

start at the logical beginning

FloatPercentageMax3DS

Formats.m3DSConst

Maximum integer percentage FLOAT_PERCENTAGE

FLOAT_PERCENTAGE

Formats.m3DSConst

FMOD_DLL

FMOD.Import

FMOD_VERSION

FMOD.types

Force four-byte enums

FOG

Formats.m3DSConst

FogMax3DS

Formats.m3DSConst

minimum value for fogging plane density

FogMin3DS

Formats.m3DSConst

maximum value for gradient midpoint FOG chunk

FOG_BGND

Formats.m3DSConst

FONT_CHARS_COUNT

GLScene.Utils

formtypeAVI

Formats.VFW

– form types, list types and chunk types ———————————–

FOURCC_A16B16G16R16

Formats.DXTC

FOURCC_A16B16G16R16F

Formats.DXTC

FOURCC_A1R5G5B5

Formats.DXTC

FOURCC_A2B10G10R10

Formats.DXTC

FOURCC_A2R10G10B10

Formats.DXTC

FOURCC_A32B32G32R32F

Formats.DXTC

FOURCC_A4L4

Formats.DXTC

FOURCC_A4R4G4B4

Formats.DXTC

FOURCC_A8

Formats.DXTC

FOURCC_A8B8G8R8

Formats.DXTC

FOURCC_A8L8

Formats.DXTC

FOURCC_A8R3G3B2

Formats.DXTC

FOURCC_A8R8G8B8

Formats.DXTC

FOURCC_ATI1

Formats.DXTC

FOURCC_ATI2

Formats.DXTC

FOURCC_D16

Formats.DXTC

FOURCC_D16_LOCKABLE

Formats.DXTC

FOURCC_D24X8

Formats.DXTC

FOURCC_D32

Formats.DXTC

FOURCC_D32F_LOCKABLE

Formats.DXTC

FOURCC_DX10

Formats.DXTC

DX10 header indicator

FOURCC_DXT1

Formats.DXTC

FOURCC_DXT2

Formats.DXTC

FOURCC_DXT3

Formats.DXTC

FOURCC_DXT4

Formats.DXTC

FOURCC_DXT5

Formats.DXTC

FOURCC_G16R16

Formats.DXTC

FOURCC_G16R16F

Formats.DXTC

FOURCC_G32R32F

Formats.DXTC

FOURCC_L16

Formats.DXTC

FOURCC_L8

Formats.DXTC

FOURCC_R16F

Formats.DXTC

Floating point surface formats s10e5 formats (16-bits per channel)

FOURCC_R32F

Formats.DXTC

IEEE s23e8 formats (32-bits per channel)

FOURCC_R3G3B2

Formats.DXTC

FOURCC_R5G6B5

Formats.DXTC

FOURCC_R8G8B8

Formats.DXTC

FOURCC_UNKNOWN

Formats.DXTC

FOURCC_X1R5G5B5

Formats.DXTC

FOURCC_X4R4G4B4

Formats.DXTC

FOURCC_X8B8G8R8

Formats.DXTC

FOURCC_X8R8G8B8

Formats.DXTC

FOVTrackTagMax3DS

Formats.m3DSConst

Minimum camera FOV

FOVTrackTagMin3DS

Formats.m3DSConst

Maximum color value FOV_TRACK_TAG_KEY

FOV_TRACK_TAG

Formats.m3DSConst

FOV_TRACK_TAG_KEY

Formats.m3DSConst

FSOUND_16BITS

FMOD.types

For 8 bit samples.

FSOUND_2D

FMOD.types

Attempts to make samples use 3d hardware acceleration. (if the card supports it)

FSOUND_8BITS

FMOD.types

For bidirectional looping samples. (no effect if in hardware).

FSOUND_ALL

FMOD.types

value to allocate a sample that is NOT managed by FSOUND or placed in a sample slot.

FSOUND_CAPS_EAX2

FMOD.types

This driver supports hardware accelerated 3d sound.

FSOUND_CAPS_EAX3

FMOD.types

This driver supports EAX 2 reverb

FSOUND_CAPS_HARDWARE

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_CAPS
[DESCRIPTION] Driver description bitfields. Use FSOUND_Driver_GetCaps to determine if a driver enumerated has the settings you are after. The enumerated driver depends on the output mode, see FSOUND_OUTPUTTYPES
[SEE_ALSO] FSOUND_GetDriverCaps FSOUND_OUTPUTTYPES ]

FSOUND_CD_PLAYCONTINUOUS

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_CDPLAYMODES
[DESCRIPTION] Playback method for a CD Audio track, using FSOUND_CD_SetPlayMode
[SEE_ALSO] FSOUND_CD_SetPlayMode FSOUND_CD_Play ]

FSOUND_CD_PLAYLOOPED

FMOD.types

Plays the specified track then stops.

FSOUND_CD_PLAYONCE

FMOD.types

Starts from the current track and plays to end of CD.

FSOUND_CD_PLAYRANDOM

FMOD.types

Plays the specified track looped, forever until stopped manually.

FSOUND_DELTA

FMOD.types

For user created source data containing signed data.

FSOUND_DSP_DEFAULTPRIORITY_CLEARUNIT

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_DSP_PRIORITIES
[DESCRIPTION] These default priorities are used by FMOD internal system DSP units. They describe the position of the DSP chain, and the order of how audio processing is executed. You can actually through the use of FSOUND_DSP_GetxxxUnit (where xxx is the name of the DSP unit), disable or even change the priority of a DSP unit.
[SEE_ALSO] FSOUND_DSP_Create FSOUND_DSP_SetPriority FSOUND_DSP_GetSpectrum ]

FSOUND_DSP_DEFAULTPRIORITY_CLIPANDCOPYUNIT

FMOD.types

This reads data for FSOUND_DSP_GetSpectrum, so it comes after user units

FSOUND_DSP_DEFAULTPRIORITY_FFTUNIT

FMOD.types

User priority, use this as reference for your own DSP units

FSOUND_DSP_DEFAULTPRIORITY_MUSICUNIT

FMOD.types

DSP SFX unit - done second

FSOUND_DSP_DEFAULTPRIORITY_SFXUNIT

FMOD.types

DSP CLEAR unit - done first

FSOUND_DSP_DEFAULTPRIORITY_USER

FMOD.types

DSP MUSIC unit - done third

FSOUND_ENABLEFX

FMOD.types

2D hardware sounds. allows hardware specific effects

FSOUND_FORCEMONO

FMOD.types

For FSOUND_Stream_OpenFile - for accurate FSOUND_Stream_GetLengthMs/FSOUND_Stream_SetTime. WARNING, see FSOUND_Stream_OpenFile for inital opening time performance issues.

FSOUND_FORMAT_MPEG

FMOD.types

FSOUND_FORMAT_OGGVORBIS

FMOD.types

FSOUND_FREE

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_CHANNELSAMPLEMODE
[DESCRIPTION] Miscellaneous values for FMOD functions.
[SEE_ALSO] FSOUND_PlaySound FSOUND_PlaySoundEx FSOUND_Sample_Alloc FSOUND_Sample_Load FSOUND_SetPan ]

FSOUND_GCADPCM

FMOD.types

For FSOUND_Stream_OpenFile - Causes stream to open in the background and not block the foreground app - stream plays only when ready.

FSOUND_HW2D

FMOD.types

For forcing stereo streams and samples to be mono - needed if using FSOUND_HW3D and stereo data - incurs a small speed hit for streams

FSOUND_HW3D

FMOD.types

For user created source data stored using IT215 compression.

FSOUND_INIT_ACCURATEVULEVELS

FMOD.types

For DirectSound output - Allows FSOUND_FX api to be used on global software mixer output!

FSOUND_INIT_DONTLATENCYADJUST

FMOD.types

PS2 only - By default FMOD uses DMA CH0 for mixing, CH1 for uploads, this flag swaps them around.

FSOUND_INIT_DSOUND_DEFERRED

FMOD.types

PS2 only - Turns on volume ramping system to remove hardware clicks.

FSOUND_INIT_DSOUND_HRTF_FULL

FMOD.types

Win32 only - For DirectSound output. FSOUND_HW3D buffers use a slightly higher quality algorithm when 3d hardware acceleration is not present.

FSOUND_INIT_DSOUND_HRTF_LIGHT

FMOD.types

Win32 only - For DirectSound output. 3D commands are batched together and executed at FSOUND_Update.

FSOUND_INIT_ENABLESYSTEMCHANNELFX

FMOD.types

For DirectSound output - sound is not muted when window is out of focus.

FSOUND_INIT_GC_INITLIBS

FMOD.types

Callbacks are not latency adjusted, and are called at mix time. Also information functions are immediate.

FSOUND_INIT_GLOBALFOCUS

FMOD.types

Causes MIDI playback to force software decoding.

FSOUND_INIT_PS2_DISABLECORE0REVERB

FMOD.types

This latency adjusts FSOUND_GetCurrentLevels, but incurs a small cpu and memory hit.

FSOUND_INIT_PS2_DISABLECORE1REVERB

FMOD.types

PS2 only - Disable reverb on CORE 0 to regain SRAM.

FSOUND_INIT_PS2_SWAPDMACORES

FMOD.types

PS2 only - Disable reverb on CORE 1 to regain SRAM.

FSOUND_INIT_PS2_USEVOLUMERAMPING

FMOD.types

Turns off fmod streamer thread, and makes streaming update from FSOUND_Update called by the user.

FSOUND_INIT_PSP_SILENCEONUNDERRUN

FMOD.types

XBox only - By default directsound attenuates all sound by 6db to avoid clipping/distortion. CAUTION. If you use this flag you are responsible for the final mix to make sure clipping / distortion doesn't happen.

FSOUND_INIT_STREAM_FROM_MAIN_THREAD

FMOD.types

Gamecube only - Initializes GC audio libraries.

FSOUND_INIT_USEDEFAULTMIDISYNTH

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_INIT_FLAGS
[DESCRIPTION] Initialization flags. Use them with FSOUND_Init in the flags parameter to change various behaviour.
FSOUND_INIT_ENABLESYSTEMCHANNELFX Is an init mode which enables the FSOUND mixer buffer to be affected by DirectX 8 effects. Note that due to limitations of DirectSound, FSOUND_Init may fail if this is enabled because the buffersize is too small. This can be fixed with FSOUND_SetBufferSize. Increase the BufferSize until it works. When it is enabled you can use the FSOUND_FX api, and use FSOUND_SYSTEMCHANNEL as the channel id when setting parameters.
[SEE_ALSO] FSOUND_Init ]

FSOUND_INIT_XBOX_REMOVEHEADROOM

FMOD.types

Win32 only - For DirectSound output. FSOUND_HW3D buffers use full quality 3d playback when 3d hardware acceleration is not present.

FSOUND_IT214

FMOD.types

For user created source data stored as delta values.

FSOUND_IT215

FMOD.types

For user created source data stored using IT214 compression.

FSOUND_LOADMEMORY

FMOD.types

For a streamimg sound where you feed the data to it. */

FSOUND_LOADMEMORYIOP

FMOD.types

For PS2 only - Sample/Stream is forced to use hardware voices 24-47

FSOUND_LOADRAW

FMOD.types

"name" will be interpreted as a pointer to data for streaming and samples.

FSOUND_LOOP_BIDI

FMOD.types

For forward looping samples.

FSOUND_LOOP_NORMAL

FMOD.types

For non looping samples.

FSOUND_LOOP_OFF

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_MODES
[DESCRIPTION] Sample description bitfields, OR them together for loading and describing samples. NOTE. If the file format being loaded already has a defined format, such as WAV or MP3, then trying to override the pre-defined format with a new set of format flags will not work. For example, an 8 bit WAV file will not load as 16bit if you specify FSOUND_16BITS. It will just ignore the flag and go ahead loading it as 8bits. For these type of formats the only flags you can specify that will really alter the behaviour of how it is loaded, are the following.
Looping behaviour - FSOUND_LOOP_OFF, FSOUND_LOOP_NORMAL, FSOUND_LOOP_BIDI Load destination - FSOUND_HW3D, FSOUND_HW2D, FSOUND_2D Loading behaviour - FSOUND_NONBLOCKING, FSOUND_LOADMEMORY, FSOUND_LOADRAW, FSOUND_MPEGACCURATE, FSOUND_MPEGHALFRATE, FSOUND_FORCEMONO Playback behaviour - FSOUND_STREAMABLE, FSOUND_ENABLEFX PlayStation 2 only - FSOUND_USECORE0, FSOUND_USECORE1, FSOUND_LOADMEMORYIOP
See flag descriptions for what these do. ]

FSOUND_MONO

FMOD.types

For 16 bit samples.

FSOUND_MPEGACCURATE

FMOD.types

Will ignore file format and treat as raw pcm.

FSOUND_MPEGHALFRATE

FMOD.types

Allows DX8 FX to be played back on a sound. Requires DirectX 8 - Note these sounds cannot be played more than once, be 8 bit, be less than a certain size, or have a changing frequency

FSOUND_MULTICHANNEL

FMOD.types

For Gamecube only - Contents are compressed as Gamecube DSP-ADPCM format

FSOUND_NONBLOCKING

FMOD.types

For PS2 only - Contents are compressed as Sony VAG format */

FSOUND_NORMAL

FMOD.types

For PS2 only - "name" will be interpreted as a pointer to data for streaming and samples. The address provided will be an IOP address

FSOUND_PRESET_ALLEY

FMOD.presets

FSOUND_PRESET_ARENA

FMOD.presets

FSOUND_PRESET_AUDITORIUM

FMOD.presets

FSOUND_PRESET_BATHROOM

FMOD.presets

FSOUND_PRESET_CARPETTEDHALLWAY

FMOD.presets

FSOUND_PRESET_CAVE

FMOD.presets

FSOUND_PRESET_CITY

FMOD.presets

FSOUND_PRESET_CONCERTHALL

FMOD.presets

FSOUND_PRESET_DIZZY

FMOD.presets

FSOUND_PRESET_DRUGGED

FMOD.presets

Non I3DL2 presets

FSOUND_PRESET_FOREST

FMOD.presets

FSOUND_PRESET_GENERIC

FMOD.presets

FSOUND_PRESET_HALLWAY

FMOD.presets

FSOUND_PRESET_HANGAR

FMOD.presets

FSOUND_PRESET_LIVINGROOM

FMOD.presets

FSOUND_PRESET_MOUNTAINS

FMOD.presets

FSOUND_PRESET_OFF

FMOD.presets

[DEFINE_START] [ [NAME] FSOUND_REVERB_PRESETS
[DESCRIPTION] A set of predefined environment PARAMETERS, created by Creative Labs These are used to initialize an FSOUND_REVERB_PROPERTIES structure statically. ie FSOUND_REVERB_PROPERTIES prop = FSOUND_PRESET_GENERIC;
[SEE_ALSO] FSOUND_Reverb_SetProperties ]

FSOUND_PRESET_PADDEDCELL

FMOD.presets

FSOUND_PRESET_PARKINGLOT

FMOD.presets

FSOUND_PRESET_PLAIN

FMOD.presets

FSOUND_PRESET_PSYCHOTIC

FMOD.presets

FSOUND_PRESET_QUARRY

FMOD.presets

FSOUND_PRESET_ROOM

FMOD.presets

FSOUND_PRESET_SEWERPIPE

FMOD.presets

FSOUND_PRESET_STONECORRIDOR

FMOD.presets

FSOUND_PRESET_STONEROOM

FMOD.presets

FSOUND_PRESET_UNDERWATER

FMOD.presets

FSOUND_PROTOCOL_HTTP

FMOD.types

FSOUND_PROTOCOL_ICECAST

FMOD.types

FSOUND_PROTOCOL_SHOUTCAST

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_STATUS_FLAGS
[DESCRIPTION] These values describe the protocol and format of an internet stream. Use FSOUND_Stream_Net_GetStatus to retrieve this information for an open internet stream.
[SEE_ALSO] FSOUND_Stream_Net_GetStatus ]

FSOUND_REVERBFLAGS_DECAYHFLIMIT

FMOD.types

EnvironmentSize affects late reverberation delay time

FSOUND_REVERBFLAGS_DECAYTIMESCALE

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_REVERB_FLAGS
[DESCRIPTION] Values for the Flags member of the FSOUND_REVERB_PROPERTIES structure.
[SEE_ALSO] FSOUND_REVERB_PROPERTIES ]

FSOUND_REVERBFLAGS_DEFAULT

FMOD.types

PS2 Only - Reverb is applied to CORE1 (hw voices 24-47)

FSOUND_REVERBFLAGS_ECHOTIMESCALE

FMOD.types

AirAbsorptionHF affects DecayHFRatio

FSOUND_REVERBFLAGS_MODULATIONTIMESCALE

FMOD.types

EnvironmentSize affects echo time

FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE

FMOD.types

EnvironmentSize affects reflection level

FSOUND_REVERBFLAGS_REFLECTIONSSCALE

FMOD.types

EnvironmentSize affects reverberation decay time

FSOUND_REVERBFLAGS_REVERBDELAYSCALE

FMOD.types

EnvironmentSize affects reflections level

FSOUND_REVERBFLAGS_REVERBSCALE

FMOD.types

EnvironmentSize affects initial reflection delay time

FSOUND_REVERB_CHANNELFLAGS_DEFAULT

FMOD.types

Automatic setting of 'RoomHF' due to distance from listener

FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_REVERB_CHANNELFLAGS
[DESCRIPTION] Values for the Flags member of the FSOUND_REVERB_CHANNELPROPERTIES structure.
[SEE_ALSO] FSOUND_REVERB_CHANNELPROPERTIES ]

FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO

FMOD.types

Automatic setting of 'Direct' due to distance from listener

FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO

FMOD.types

Automatic setting of 'Room' due to distance from listener

FSOUND_REVERB_FLAGS_CORE0

FMOD.types

EnvironmentSize affects modulation time

FSOUND_REVERB_FLAGS_CORE1

FMOD.types

PS2 Only - Reverb is applied to CORE0 (hw voices 0-23)

FSOUND_SIGNED

FMOD.types

For user created source data containing unsigned samples.

FSOUND_STEREO

FMOD.types

For mono samples.

FSOUND_STEREOPAN

FMOD.types

for a channel index , this flag will affect ALL channels available! Not supported by every function.

FSOUND_STREAMABLE

FMOD.types

Ignores any 3d processing. Overrides FSOUND_HW3D. Located in software.

FSOUND_SYSTEMCHANNEL

FMOD.types

value for FSOUND_SetPan so that stereo sounds are not played at half volume. See FSOUND_SetPan for more on this.

FSOUND_SYSTEMSAMPLE

FMOD.types

special 'channel' ID for all channel based functions that want to alter the global FSOUND software mixing output

FSOUND_UNMANAGED

FMOD.types

value to play on any free channel, or to allocate a sample in a free sample slot.

FSOUND_UNSIGNED

FMOD.types

For stereo samples.

FSOUND_USECORE0

FMOD.types

For PS2 only - Contents are interleaved into a multi-channel (more than stereo) format

FSOUND_USECORE1

FMOD.types

For PS2 only - Sample/Stream is forced to use hardware voices 00-23

FSOUND_VAG

FMOD.types

For XBOX only - Contents are compressed as XADPCM */

FSOUND_XADPCM

FMOD.types

For FMODCE only - decodes mpeg streams using a lower quality decode, but faster execution

GLSCENE_REVISION

GLS.Scene

GLSCENE_VERSION

GLS.Scene

glsShaderMaxLightSources

GLSL.CustomShader

GLS_RC_DDS_Type

GLS.ApplicationFileIO

GLS_RC_JPG_Type

GLS.ApplicationFileIO

GLS_RC_String_Type

GLS.ApplicationFileIO

GLS_RC_XML_Type

GLS.ApplicationFileIO

GLS_VERTEX_ATTR_NUM

GLS.State

glu32

GLS.OpenGLAdapter

glu32

GLScene.OpenGL4

GLU_AUTO_LOAD_MATRIX

GLScene.OpenGL4

GLU_AUTO_LOAD_MATRIX

GLScene.OpenGLTokens

NURBS constants NurbsProperty

GLU_BEGIN

GLScene.OpenGL4

GLU_BEGIN

GLScene.OpenGLTokens

Names without "TESS_" prefix

GLU_CCW

GLScene.OpenGL4

GLU_CCW

GLScene.OpenGLTokens

GLU_CULLING

GLScene.OpenGL4

GLU_CULLING

GLScene.OpenGLTokens

GLU_CW

GLScene.OpenGL4

GLU_CW

GLScene.OpenGLTokens

Contours types – obsolete!

GLU_DISPLAY_MODE

GLScene.OpenGL4

GLU_DISPLAY_MODE

GLScene.OpenGLTokens

GLU_DOMAIN_DISTANCE

GLScene.OpenGL4

GLU_DOMAIN_DISTANCE

GLScene.OpenGLTokens

GLU_EDGE_FLAG

GLScene.OpenGL4

GLU_EDGE_FLAG

GLScene.OpenGLTokens

GLU_END

GLScene.OpenGL4

GLU_END

GLScene.OpenGLTokens

GLU_ERROR

GLScene.OpenGL4

GLU_ERROR

GLScene.OpenGLTokens

GLU_EXTENSIONS

GLScene.OpenGL4

GLU_EXTERIOR

GLScene.OpenGL4

GLU_EXTERIOR

GLScene.OpenGLTokens

GLU_FALSE

GLScene.OpenGL4

GLU_FILL

GLScene.OpenGL4

GLU_FLAT

GLScene.OpenGL4

GLU_INCOMPATIBLE_GL_VERSION

GLScene.OpenGL4

GLU_INSIDE

GLScene.OpenGL4

GLU_INTERIOR

GLScene.OpenGL4

GLU_INTERIOR

GLScene.OpenGLTokens

GLU_INVALID_ENUM

GLScene.OpenGL4

GLU

GLU_INVALID_VALUE

GLScene.OpenGL4

GLU_LINE

GLScene.OpenGL4

GLU_MAP1_TRIM_2

GLScene.OpenGL4

GLU_MAP1_TRIM_2

GLScene.OpenGLTokens

NurbsTrim

GLU_MAP1_TRIM_3

GLScene.OpenGL4

GLU_MAP1_TRIM_3

GLScene.OpenGLTokens

GLU_NONE

GLScene.OpenGL4

GLU_NURBS_ERROR1

GLScene.OpenGL4

GLU_NURBS_ERROR1

GLScene.OpenGLTokens

NurbsErrors

GLU_NURBS_ERROR10

GLScene.OpenGL4

GLU_NURBS_ERROR10

GLScene.OpenGLTokens

GLU_NURBS_ERROR11

GLScene.OpenGL4

GLU_NURBS_ERROR11

GLScene.OpenGLTokens

GLU_NURBS_ERROR12

GLScene.OpenGL4

GLU_NURBS_ERROR12

GLScene.OpenGLTokens

GLU_NURBS_ERROR13

GLScene.OpenGL4

GLU_NURBS_ERROR13

GLScene.OpenGLTokens

GLU_NURBS_ERROR14

GLScene.OpenGL4

GLU_NURBS_ERROR14

GLScene.OpenGLTokens

GLU_NURBS_ERROR15

GLScene.OpenGL4

GLU_NURBS_ERROR15

GLScene.OpenGLTokens

GLU_NURBS_ERROR16

GLScene.OpenGL4

GLU_NURBS_ERROR16

GLScene.OpenGLTokens

GLU_NURBS_ERROR17

GLScene.OpenGL4

GLU_NURBS_ERROR17

GLScene.OpenGLTokens

GLU_NURBS_ERROR18

GLScene.OpenGL4

GLU_NURBS_ERROR18

GLScene.OpenGLTokens

GLU_NURBS_ERROR19

GLScene.OpenGL4

GLU_NURBS_ERROR19

GLScene.OpenGLTokens

GLU_NURBS_ERROR2

GLScene.OpenGL4

GLU_NURBS_ERROR2

GLScene.OpenGLTokens

GLU_NURBS_ERROR20

GLScene.OpenGL4

GLU_NURBS_ERROR20

GLScene.OpenGLTokens

GLU_NURBS_ERROR21

GLScene.OpenGL4

GLU_NURBS_ERROR21

GLScene.OpenGLTokens

GLU_NURBS_ERROR22

GLScene.OpenGL4

GLU_NURBS_ERROR22

GLScene.OpenGLTokens

GLU_NURBS_ERROR23

GLScene.OpenGL4

GLU_NURBS_ERROR23

GLScene.OpenGLTokens

GLU_NURBS_ERROR24

GLScene.OpenGL4

GLU_NURBS_ERROR24

GLScene.OpenGLTokens

GLU_NURBS_ERROR25

GLScene.OpenGL4

GLU_NURBS_ERROR25

GLScene.OpenGLTokens

GLU_NURBS_ERROR26

GLScene.OpenGL4

GLU_NURBS_ERROR26

GLScene.OpenGLTokens

GLU_NURBS_ERROR27

GLScene.OpenGL4

GLU_NURBS_ERROR27

GLScene.OpenGLTokens

GLU_NURBS_ERROR28

GLScene.OpenGL4

GLU_NURBS_ERROR28

GLScene.OpenGLTokens

GLU_NURBS_ERROR29

GLScene.OpenGL4

GLU_NURBS_ERROR29

GLScene.OpenGLTokens

GLU_NURBS_ERROR3

GLScene.OpenGL4

GLU_NURBS_ERROR3

GLScene.OpenGLTokens

GLU_NURBS_ERROR30

GLScene.OpenGL4

GLU_NURBS_ERROR30

GLScene.OpenGLTokens

GLU_NURBS_ERROR31

GLScene.OpenGL4

GLU_NURBS_ERROR31

GLScene.OpenGLTokens

GLU_NURBS_ERROR32

GLScene.OpenGL4

GLU_NURBS_ERROR32

GLScene.OpenGLTokens

GLU_NURBS_ERROR33

GLScene.OpenGL4

GLU_NURBS_ERROR33

GLScene.OpenGLTokens

GLU_NURBS_ERROR34

GLScene.OpenGL4

GLU_NURBS_ERROR34

GLScene.OpenGLTokens

GLU_NURBS_ERROR35

GLScene.OpenGL4

GLU_NURBS_ERROR35

GLScene.OpenGLTokens

GLU_NURBS_ERROR36

GLScene.OpenGL4

GLU_NURBS_ERROR36

GLScene.OpenGLTokens

GLU_NURBS_ERROR37

GLScene.OpenGL4

GLU_NURBS_ERROR37

GLScene.OpenGLTokens

GLU_NURBS_ERROR4

GLScene.OpenGL4

GLU_NURBS_ERROR4

GLScene.OpenGLTokens

GLU_NURBS_ERROR5

GLScene.OpenGL4

GLU_NURBS_ERROR5

GLScene.OpenGLTokens

GLU_NURBS_ERROR6

GLScene.OpenGL4

GLU_NURBS_ERROR6

GLScene.OpenGLTokens

GLU_NURBS_ERROR7

GLScene.OpenGL4

GLU_NURBS_ERROR7

GLScene.OpenGLTokens

GLU_NURBS_ERROR8

GLScene.OpenGL4

GLU_NURBS_ERROR8

GLScene.OpenGLTokens

GLU_NURBS_ERROR9

GLScene.OpenGL4

GLU_NURBS_ERROR9

GLScene.OpenGLTokens

GLU_OUTLINE_PATCH

GLScene.OpenGL4

GLU_OUTLINE_PATCH

GLScene.OpenGLTokens

GLU_OUTLINE_POLYGON

GLScene.OpenGL4

GLU_OUTLINE_POLYGON

GLScene.OpenGLTokens

NurbsDisplay

GLU_OUTSIDE

GLScene.OpenGL4

GLU_OUT_OF_MEMORY

GLScene.OpenGL4

GLU_PARAMETRIC_ERROR

GLScene.OpenGL4

GLU_PARAMETRIC_ERROR

GLScene.OpenGLTokens

GLU_PARAMETRIC_TOLERANCE

GLScene.OpenGL4

GLU_PARAMETRIC_TOLERANCE

GLScene.OpenGLTokens

GLU_PATH_LENGTH

GLScene.OpenGL4

GLU_PATH_LENGTH

GLScene.OpenGLTokens

NurbsSampling

GLU_POINT

GLScene.OpenGL4

GLU_SAMPLING_METHOD

GLScene.OpenGL4

GLU_SAMPLING_METHOD

GLScene.OpenGLTokens

GLU_SAMPLING_TOLERANCE

GLScene.OpenGL4

GLU_SAMPLING_TOLERANCE

GLScene.OpenGLTokens

GLU_SILHOUETTE

GLScene.OpenGL4

GLU_SMOOTH

GLScene.OpenGL4

GLU_TESS_BEGIN

GLScene.OpenGL4

GLU_TESS_BEGIN

GLScene.OpenGLTokens

********** GLU generic constants ********** TessCallback

GLU_TESS_BEGIN_DATA

GLScene.OpenGL4

GLU_TESS_BEGIN_DATA

GLScene.OpenGLTokens

TGLUTessCombineProc

GLU_TESS_BOUNDARY_ONLY

GLScene.OpenGL4

GLU_TESS_COMBINE

GLScene.OpenGL4

GLU_TESS_COMBINE

GLScene.OpenGLTokens

TGLUTessEdgeFlagProc

GLU_TESS_COMBINE_DATA

GLScene.OpenGL4

GLU_TESS_COMBINE_DATA

GLScene.OpenGLTokens

TGLUTessEdgeFlagDataProc

GLU_TESS_COORD_TOO_LARGE

GLScene.OpenGL4

GLU_TESS_COORD_TOO_LARGE

GLScene.OpenGLTokens

GLU_TESS_EDGE_FLAG

GLScene.OpenGL4

GLU_TESS_EDGE_FLAG

GLScene.OpenGLTokens

TGLUTessErrorProc

GLU_TESS_EDGE_FLAG_DATA

GLScene.OpenGL4

GLU_TESS_EDGE_FLAG_DATA

GLScene.OpenGLTokens

TGLUTessErrorDataProc

GLU_TESS_END

GLScene.OpenGL4

GLU_TESS_END

GLScene.OpenGLTokens

TGLUTessVertexProc

GLU_TESS_END_DATA

GLScene.OpenGL4

GLU_TESS_END_DATA

GLScene.OpenGLTokens

TGLUTessVertexDataProc

GLU_TESS_ERROR

GLScene.OpenGL4

GLU_TESS_ERROR

GLScene.OpenGLTokens

TGLUTessEndProc

GLU_TESS_ERROR1

GLScene.OpenGL4

GLU_TESS_ERROR1

GLScene.OpenGLTokens

TGLUTessCombineDataProc TessError

GLU_TESS_ERROR2

GLScene.OpenGL4

GLU_TESS_ERROR2

GLScene.OpenGLTokens

GLU_TESS_ERROR3

GLScene.OpenGL4

GLU_TESS_ERROR3

GLScene.OpenGLTokens

GLU_TESS_ERROR4

GLScene.OpenGL4

GLU_TESS_ERROR4

GLScene.OpenGLTokens

GLU_TESS_ERROR5

GLScene.OpenGL4

GLU_TESS_ERROR5

GLScene.OpenGLTokens

GLU_TESS_ERROR6

GLScene.OpenGL4

GLU_TESS_ERROR6

GLScene.OpenGLTokens

GLU_TESS_ERROR7

GLScene.OpenGL4

GLU_TESS_ERROR7

GLScene.OpenGLTokens

GLU_TESS_ERROR8

GLScene.OpenGL4

GLU_TESS_ERROR8

GLScene.OpenGLTokens

GLU_TESS_ERROR_DATA

GLScene.OpenGL4

GLU_TESS_ERROR_DATA

GLScene.OpenGLTokens

TGLUTessEndDataProc

GLU_TESS_MAX_COORD

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_CONTOUR

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_CONTOUR

GLScene.OpenGLTokens

GLU_TESS_MISSING_BEGIN_POLYGON

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_POLYGON

GLScene.OpenGLTokens

GLU_TESS_MISSING_END_CONTOUR

GLScene.OpenGL4

GLU_TESS_MISSING_END_CONTOUR

GLScene.OpenGLTokens

GLU_TESS_MISSING_END_POLYGON

GLScene.OpenGL4

GLU_TESS_MISSING_END_POLYGON

GLScene.OpenGLTokens

GLU_TESS_NEED_COMBINE_CALLBACK

GLScene.OpenGL4

GLU_TESS_NEED_COMBINE_CALLBACK

GLScene.OpenGLTokens

GLU_TESS_TOLERANCE

GLScene.OpenGL4

GLU_TESS_VERTEX

GLScene.OpenGL4

GLU_TESS_VERTEX

GLScene.OpenGLTokens

TGLUTessBeginProc

GLU_TESS_VERTEX_DATA

GLScene.OpenGL4

GLU_TESS_VERTEX_DATA

GLScene.OpenGLTokens

TGLUTessBeginDataProc

GLU_TESS_WINDING_ABS_GEQ_TWO

GLScene.OpenGL4

GLU_TESS_WINDING_NEGATIVE

GLScene.OpenGL4

GLU_TESS_WINDING_NONZERO

GLScene.OpenGL4

GLU_TESS_WINDING_ODD

GLScene.OpenGL4

GLU_TESS_WINDING_POSITIVE

GLScene.OpenGL4

GLU_TESS_WINDING_RULE

GLScene.OpenGL4

GLU_TRUE

GLScene.OpenGL4

GLU_UNKNOWN

GLScene.OpenGL4

GLU_UNKNOWN

GLScene.OpenGLTokens

GLU_U_STEP

GLScene.OpenGL4

GLU_U_STEP

GLScene.OpenGLTokens

GLU_VERSION

GLScene.OpenGL4

GLU_VERTEX

GLScene.OpenGL4

GLU_VERTEX

GLScene.OpenGLTokens

GLU_V_STEP

GLScene.OpenGL4

GLU_V_STEP

GLScene.OpenGLTokens

GLX_ACCUM_ALPHA_SIZE

GLScene.OpenGL4

GLX_ACCUM_BLUE_SIZE

GLScene.OpenGL4

GLX_ACCUM_BUFFER_BIT

GLScene.OpenGL4

GLX_ACCUM_GREEN_SIZE

GLScene.OpenGL4

GLX_ACCUM_RED_SIZE

GLScene.OpenGL4

GLX_ALPHA_SIZE

GLScene.OpenGL4

GLX_AUX0_EXT

GLScene.OpenGL4

GLX_AUX1_EXT

GLScene.OpenGL4

GLX_AUX2_EXT

GLScene.OpenGL4

GLX_AUX3_EXT

GLScene.OpenGL4

GLX_AUX4_EXT

GLScene.OpenGL4

GLX_AUX5_EXT

GLScene.OpenGL4

GLX_AUX6_EXT

GLScene.OpenGL4

GLX_AUX7_EXT

GLScene.OpenGL4

GLX_AUX8_EXT

GLScene.OpenGL4

GLX_AUX9_EXT

GLScene.OpenGL4

GLX_AUX_BUFFERS

GLScene.OpenGL4

GLX_AUX_BUFFERS_BIT

GLScene.OpenGL4

GLX_BACK_EXT

GLScene.OpenGL4

GLX_BACK_LEFT_BUFFER_BIT

GLScene.OpenGL4

GLX_BACK_LEFT_EXT

GLScene.OpenGL4

GLX_BACK_RIGHT_BUFFER_BIT

GLScene.OpenGL4

GLX_BACK_RIGHT_EXT

GLScene.OpenGL4

GLX_BIND_TO_MIPMAP_TEXTURE_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_RGBA_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_RGB_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_TARGETS_EXT

GLScene.OpenGL4

GLX_BLUE_SIZE

GLScene.OpenGL4

GLX_BUFFER_SIZE

GLScene.OpenGL4

GLX_COLOR_INDEX_BIT

GLScene.OpenGL4

GLX_COLOR_INDEX_TYPE

GLScene.OpenGL4

GLX_CONFIG_CAVEAT

GLScene.OpenGL4

GLX_CONTEXT_ALLOW_BUFFER_BYTE_ORDER_MISMATCH_ARB

GLScene.OpenGL4

GLX_ARB_vertex_buffer_object

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGL4

GLX_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context_profile

GLX_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context

GLX_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGL4

GLX_EXT_create_context_es2_profile

GLX_CONTEXT_FLAGS_ARB

GLScene.OpenGL4

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGL4

GLX_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGL4

GLX_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGL4

GLX_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGL4

GLX_CONTEXT_RELEASE_BEHAVIOR_ARB

GLScene.OpenGL4

GLX_ARB_context_flush_control

GLX_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB

GLScene.OpenGL4

GLX_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB

GLScene.OpenGL4

GLX_CONTEXT_RESET_ISOLATION_BIT_ARB

GLScene.OpenGL4

GLX_ARB_robustness_application_isolation

GLX_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

GLX_CONTEXT_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context_robustness

GLX_DAMAGED

GLScene.OpenGL4

GLX_DEPTH_BUFFER_BIT

GLScene.OpenGL4

GLX_DEPTH_SIZE

GLScene.OpenGL4

GLX_DIRECT_COLOR

GLScene.OpenGL4

GLX_DIRECT_COLOR_EXT

GLScene.OpenGL4

GLX_DONT_CARE

GLScene.OpenGL4

GLX_DOUBLEBUFFER

GLScene.OpenGL4

GLX_DRAWABLE_TYPE

GLScene.OpenGL4

GLX_EVENT_MASK

GLScene.OpenGL4

GLX_EXTENSIONS

GLScene.OpenGL4

GLX_FBCONFIG_ID

GLScene.OpenGL4

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGL4

GLX_ARB_framebuffer_sRGB

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_sRGB

GLX_FRONT_EXT

GLScene.OpenGL4

GLX_FRONT_LEFT_BUFFER_BIT

GLScene.OpenGL4

GLX_FRONT_LEFT_EXT

GLScene.OpenGL4

GLX_FRONT_RIGHT_BUFFER_BIT

GLScene.OpenGL4

GLX_FRONT_RIGHT_EXT

GLScene.OpenGL4

GLX_GRAY_SCALE

GLScene.OpenGL4

GLX_GRAY_SCALE_EXT

GLScene.OpenGL4

GLX_GREEN_SIZE

GLScene.OpenGL4

GLX_HEIGHT

GLScene.OpenGL4

GLX_LARGEST_PBUFFER

GLScene.OpenGL4

GLX_LATE_SWAPS_TEAR_EXT

GLScene.OpenGL4

GL_EXT_Late_Swaps

GLX_LEVEL

GLScene.OpenGL4

GLX_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

GLX_MAX_PBUFFER_HEIGHT

GLScene.OpenGL4

GLX_MAX_PBUFFER_PIXELS

GLScene.OpenGL4

GLX_MAX_PBUFFER_WIDTH

GLScene.OpenGL4

GLX_MAX_SWAP_INTERVAL_EXT

GLScene.OpenGL4

GLX_MIPMAP_TEXTURE_EXT

GLScene.OpenGL4

GLX_NONE

GLScene.OpenGL4

GLX_NONE_EXT

GLScene.OpenGL4

GLX_NON_CONFORMANT_CONFIG

GLScene.OpenGL4

GLX_NON_CONFORMANT_VISUAL_EXT

GLScene.OpenGL4

GLX_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

GLX_PBUFFER

GLScene.OpenGL4

GLX_PBUFFER_BIT

GLScene.OpenGL4

GLX_PBUFFER_CLOBBER_MASK

GLScene.OpenGL4

GLX_PBUFFER_HEIGHT

GLScene.OpenGL4

GLX_PBUFFER_WIDTH

GLScene.OpenGL4

GLX_PIXMAP_BIT

GLScene.OpenGL4

GLX_PRESERVED_CONTENTS

GLScene.OpenGL4

GLX_PSEUDO_COLOR

GLScene.OpenGL4

GLX_PSEUDO_COLOR_EXT

GLScene.OpenGL4

GLX_RED_SIZE

GLScene.OpenGL4

GLX_RENDER_TYPE

GLScene.OpenGL4

GLX_RGBA

GLScene.OpenGL4

GLX_RGBA_BIT

GLScene.OpenGL4

GLX_RGBA_FLOAT_BIT

GLScene.OpenGL4

GLX_RGBA_FLOAT_BIT_ARB

GLScene.OpenGL4

GLX_RGBA_FLOAT_TYPE

GLScene.OpenGL4

GLX_RGBA_FLOAT_TYPE_ARB

GLScene.OpenGL4

GLX_ARB_fbconfig_float

GLX_RGBA_TYPE

GLScene.OpenGL4

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT

GLScene.OpenGL4

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT

GLScene.OpenGL4

GLX_SAMPLES

GLScene.OpenGL4

GLX_SAMPLES_ARB

GLScene.OpenGL4

GLX_SAMPLE_BUFFERS

GLScene.OpenGL4

GLX_VERSION_1_4

GLX_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

GLX_ARB_multisample

GLX_SAVED

GLScene.OpenGL4

GLX_SCREEN

GLScene.OpenGL4

GLX_SCREEN_EXT

GLScene.OpenGL4

GLX_SHARE_CONTEXT_EXT

GLScene.OpenGL4

GLX_EXT_import_context

GLX_SLOW_CONFIG

GLScene.OpenGL4

GLX_SLOW_VISUAL_EXT

GLScene.OpenGL4

GLX_STATIC_COLOR

GLScene.OpenGL4

GLX_STATIC_COLOR_EXT

GLScene.OpenGL4

GLX_STATIC_GRAY

GLScene.OpenGL4

GLX_STATIC_GRAY_EXT

GLScene.OpenGL4

GLX_STENCIL_BUFFER_BIT

GLScene.OpenGL4

GLX_STENCIL_SIZE

GLScene.OpenGL4

GLX_STEREO

GLScene.OpenGL4

GLX_SWAP_INTERVAL_EXT

GLScene.OpenGL4

GLX_EXT_swap_control

GLX_TEXTURE_1D_BIT_EXT

GLScene.OpenGL4

GLX_EXT_fbconfig_packed_float GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1; GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008; GLX_EXT_framebuffer_sRGB GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2; GLX_EXT_texture_from_pixmap

GLX_TEXTURE_1D_EXT

GLScene.OpenGL4

GLX_TEXTURE_2D_BIT_EXT

GLScene.OpenGL4

GLX_TEXTURE_2D_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_NONE_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_RGBA_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_RGB_EXT

GLScene.OpenGL4

GLX_TEXTURE_RECTANGLE_BIT_EXT

GLScene.OpenGL4

GLX_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GLX_TEXTURE_TARGET_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_ALPHA_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_ALPHA_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_BLUE_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_BLUE_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_GREEN_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_GREEN_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_RED_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_RED_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_RGB

GLScene.OpenGL4

GLX_TRANSPARENT_RGB_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_TYPE

GLScene.OpenGL4

GLX_TRANSPARENT_TYPE_EXT

GLScene.OpenGL4

GLX_TRUE_COLOR

GLScene.OpenGL4

GLX_TRUE_COLOR_EXT

GLScene.OpenGL4

GLX_USE_GL

GLScene.OpenGL4

GLX_VENDOR

GLScene.OpenGL4

GLX 1.1 and later:

GLX_VERSION

GLScene.OpenGL4

GLX_VISUAL_CAVEAT_EXT

GLScene.OpenGL4

GLX_EXT_visual_rating

GLX_VISUAL_ID

GLScene.OpenGL4

GLX_VISUAL_ID_EXT

GLScene.OpenGL4

GLX_WIDTH

GLScene.OpenGL4

GLX_WINDOW

GLScene.OpenGL4

GLX_WINDOW_BIT

GLScene.OpenGL4

GLX_VERSION_1_3

GLX_X_RENDERABLE

GLScene.OpenGL4

GLX_X_VISUAL_TYPE

GLScene.OpenGL4

GLX_X_VISUAL_TYPE_EXT

GLScene.OpenGL4

GLX_EXT_visual_info

GLX_Y_INVERTED_EXT

GLScene.OpenGL4

GL_1PASS_EXT

GLScene.OpenGL4

GL_1PASS_SGIS

GLScene.OpenGL4

GL_2D

GLScene.OpenGL4

GL_2PASS_0_EXT

GLScene.OpenGL4

GL_2PASS_0_SGIS

GLScene.OpenGL4

GL_2PASS_1_EXT

GLScene.OpenGL4

GL_2PASS_1_SGIS

GLScene.OpenGL4

GL_2X_BIT_ATI

GLScene.OpenGL4

GL_2_BYTES

GLScene.OpenGL4

GL_3D

GLScene.OpenGL4

GL_3D_COLOR

GLScene.OpenGL4

GL_3D_COLOR_TEXTURE

GLScene.OpenGL4

GL_3_BYTES

GLScene.OpenGL4

GL_422_AVERAGE_EXT

GLScene.OpenGL4

GL_422_EXT

GLScene.OpenGL4

GL_EXT_422_pixels

GL_422_REV_AVERAGE_EXT

GLScene.OpenGL4

GL_422_REV_EXT

GLScene.OpenGL4

GL_4D_COLOR_TEXTURE

GLScene.OpenGL4

GL_4PASS_0_EXT

GLScene.OpenGL4

GL_4PASS_0_SGIS

GLScene.OpenGL4

GL_4PASS_1_EXT

GLScene.OpenGL4

GL_4PASS_1_SGIS

GLScene.OpenGL4

GL_4PASS_2_EXT

GLScene.OpenGL4

GL_4PASS_2_SGIS

GLScene.OpenGL4

GL_4PASS_3_EXT

GLScene.OpenGL4

GL_4PASS_3_SGIS

GLScene.OpenGL4

GL_4X_BIT_ATI

GLScene.OpenGL4

GL_4_BYTES

GLScene.OpenGL4

GL_8X_BIT_ATI

GLScene.OpenGL4

GL_ABGR_EXT

GLScene.OpenGL4

GL_EXT_abgr

GL_ACCUM

GLScene.OpenGL4

GL_ACCUM_ADJACENT_PAIRS_NV

GLScene.OpenGL4

GL_ACCUM_ALPHA_BITS

GLScene.OpenGL4

GL_ACCUM_BLUE_BITS

GLScene.OpenGL4

GL_ACCUM_BUFFER_BIT

GLScene.OpenGL4

GL_ACCUM_CLEAR_VALUE

GLScene.OpenGL4

GL_ACCUM_GREEN_BITS

GLScene.OpenGL4

GL_ACCUM_RED_BITS

GLScene.OpenGL4

GL_ACTIVE_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_ACTIVE_ATTRIBUTES

GLScene.OpenGL4

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_PROGRAM

GLScene.OpenGL4

GL_ACTIVE_PROGRAM_EXT

GLScene.OpenGL4

GL_EXT_separate_shader_objects

GL_ACTIVE_RESOURCES

GLScene.OpenGL4

GL_ACTIVE_STENCIL_FACE_EXT

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINES

GLScene.OpenGL4

GL_ARB_shader_subroutine

GL_ACTIVE_SUBROUTINE_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORMS

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_TEXTURE

GLScene.OpenGL4

GL_ACTIVE_TEXTURE_ARB

GLScene.OpenGL4

GL_ACTIVE_UNIFORMS

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_ACTIVE_VARYINGS_NV

GLScene.OpenGL4

GL_ACTIVE_VARYING_MAX_LENGTH_NV

GLScene.OpenGL4

GL_ACTIVE_VERTEX_UNITS_ARB

GLScene.OpenGL4

GL_ADD

GLScene.OpenGL4

GL_ADD_ATI

GLScene.OpenGL4

GL_ADD_SIGNED

GLScene.OpenGL4

GL_ADD_SIGNED_ARB

GLScene.OpenGL4

GL_ADD_SIGNED_EXT

GLScene.OpenGL4

GL_ADJACENT_PAIRS_NV

GLScene.OpenGL4

GL_AFFINE_2D_NV

GLScene.OpenGL4

GL_AFFINE_3D_NV

GLScene.OpenGL4

GL_ALIASED_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_ALIASED_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_ALLOW_DRAW_FRG_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_MEM_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_OBJ_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_WIN_HINT_PGI

GLScene.OpenGL4

GL_ALL_ATTRIB_BITS

GLScene.OpenGL4

GL_ALL_BARRIER_BITS

GLScene.OpenGL4

GL_ALL_BARRIER_BITS_EXT

GLScene.OpenGL4

GL_ALL_COMPLETED_NV

GLScene.OpenGL4

GL_NV_fence

GL_ALL_SHADER_BITS

GLScene.OpenGL4

GL_ALPHA

GLScene.OpenGL4

GL_ALPHA12

GLScene.OpenGL4

GL_ALPHA12_EXT

GLScene.OpenGL4

GL_ALPHA16

GLScene.OpenGL4

GL_ALPHA16F_ARB

GLScene.OpenGL4

GL_ALPHA16I_EXT

GLScene.OpenGL4

GL_ALPHA16UI_EXT

GLScene.OpenGL4

GL_ALPHA16_EXT

GLScene.OpenGL4

GL_ALPHA16_SNORM

GLScene.OpenGL4

GL_ALPHA32F_ARB

GLScene.OpenGL4

GL_ALPHA32I_EXT

GLScene.OpenGL4

GL_ALPHA32UI_EXT

GLScene.OpenGL4

GL_ALPHA4

GLScene.OpenGL4

GL_ALPHA4_EXT

GLScene.OpenGL4

GL_EXT_texture

GL_ALPHA8

GLScene.OpenGL4

GL_ALPHA8I_EXT

GLScene.OpenGL4

GL_ALPHA8UI_EXT

GLScene.OpenGL4

GL_ALPHA8_EXT

GLScene.OpenGL4

GL_ALPHA8_SNORM

GLScene.OpenGL4

GL_ALPHA_BIAS

GLScene.OpenGL4

GL_ALPHA_BITS

GLScene.OpenGL4

GL_ALPHA_FLOAT16_APPLE

GLScene.OpenGL4

GL_ALPHA_FLOAT16_ATI

GLScene.OpenGL4

GL_ALPHA_FLOAT32_APPLE

GLScene.OpenGL4

GL_ALPHA_FLOAT32_ATI

GLScene.OpenGL4

GL_ALPHA_INTEGER

GLScene.OpenGL4

GL_ALPHA_INTEGER_EXT

GLScene.OpenGL4

GL_ALPHA_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_ALPHA_MAX_SGIX

GLScene.OpenGL4

GL_ALPHA_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_ALPHA_MIN_SGIX

GLScene.OpenGL4

GL_SGIX_blend_alpha_minmax

GL_ALPHA_SCALE

GLScene.OpenGL4

GL_ALPHA_SNORM

GLScene.OpenGL4

GL_EXT_texture_snorm

GL_ALPHA_TEST

GLScene.OpenGL4

GL_ALPHA_TEST_FUNC

GLScene.OpenGL4

GL_ALPHA_TEST_REF

GLScene.OpenGL4

GL_ALREADY_SIGNALED

GLScene.OpenGL4

GL_ALWAYS

GLScene.OpenGL4

GL_ALWAYS_FAST_HINT_PGI

GLScene.OpenGL4

GL_ALWAYS_SOFT_HINT_PGI

GLScene.OpenGL4

GL_AMBIENT

GLScene.OpenGL4

GL_AMBIENT_AND_DIFFUSE

GLScene.OpenGL4

GL_AND

GLScene.OpenGL4

GL_AND_INVERTED

GLScene.OpenGL4

GL_AND_REVERSE

GLScene.OpenGL4

GL_ANY_SAMPLES_PASSED

GLScene.OpenGL4

GL_ARB_occlusion_query2

GL_ANY_SAMPLES_PASSED_CONSERVATIVE

GLScene.OpenGL4

GL_ARC_TO_NV

GLScene.OpenGL4

GL_ARRAY_BUFFER

GLScene.OpenGL4

GL_ARRAY_BUFFER_ARB

GLScene.OpenGL4

GL_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT

GLScene.OpenGL4

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT

GLScene.OpenGL4

GL_EXT_compiled_vertex_array

GL_ARRAY_OBJECT_BUFFER_ATI

GLScene.OpenGL4

GL_ARRAY_OBJECT_OFFSET_ATI

GLScene.OpenGL4

GL_ARRAY_SIZE

GLScene.OpenGL4

GL_ARRAY_STRIDE

GLScene.OpenGL4

GL_ASE_MAX_SMOOTH_GROUPS

GLS.FileASE

maximum material submaterials

GL_ASE_MAX_SUBMATERIALS

GLS.FileASE

maximum texture channels

GL_ASE_MAX_TEXTURE_MAPS

GLS.FileASE

maximum smoothing groups

GL_ASE_MAX_TEXURE_CHANNELS

GLS.FileASE

GL_ASYNC_DRAW_PIXELS_SGIX

GLScene.OpenGL4

GL_ASYNC_HISTOGRAM_SGIX

GLScene.OpenGL4

GL_SGIX_async_histogram

GL_ASYNC_MARKER_SGIX

GLScene.OpenGL4

GL_SGIX_async

GL_ASYNC_READ_PIXELS_SGIX

GLScene.OpenGL4

GL_ASYNC_TEX_IMAGE_SGIX

GLScene.OpenGL4

GL_SGIX_async_pixel

GL_ATOMIC_COUNTER_BARRIER_BIT

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER

GLScene.OpenGL4

GL_ARB_shader_atomic_counters

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTER_INDICES

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_BINDING

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_DATA_SIZE

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_INDEX

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_SIZE

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_START

GLScene.OpenGL4

GL_ATTACHED_SHADERS

GLScene.OpenGL4

GL_ATTENUATION_EXT

GLScene.OpenGL4

GL_ATTRIB_ARRAY_POINTER_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_SIZE_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_STRIDE_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_TYPE_NV

GLScene.OpenGL4

GL_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_AUTO_GENERATE_MIPMAP

GLScene.OpenGL4

GL_AUTO_NORMAL

GLScene.OpenGL4

GL_AUX0

GLScene.OpenGL4

GL_AUX1

GLScene.OpenGL4

GL_AUX2

GLScene.OpenGL4

GL_AUX3

GLScene.OpenGL4

GL_AUX_BUFFERS

GLScene.OpenGL4

GL_AUX_DEPTH_STENCIL_APPLE

GLScene.OpenGL4

GL_APPLE_aux_depth_stencil

GL_AVERAGE_EXT

GLScene.OpenGL4

GL_AVERAGE_HP

GLScene.OpenGL4

GL_BACK

GLScene.OpenGL4

GL_BACK_LEFT

GLScene.OpenGL4

GL_BACK_NORMALS_HINT_PGI

GLScene.OpenGL4

GL_BACK_PRIMARY_COLOR_NV

GLScene.OpenGL4

GL_BACK_RIGHT

GLScene.OpenGL4

GL_BACK_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_BEVEL_NV

GLScene.OpenGL4

GL_BGR

GLScene.OpenGL4

GL_BGRA

GLScene.OpenGL4

GL_BGRA_EXT

GLScene.OpenGL4

GL_BGRA_INTEGER

GLScene.OpenGL4

GL_BGRA_INTEGER_EXT

GLScene.OpenGL4

GL_BGR_EXT

GLScene.OpenGL4

GL_EXT_bgra

GL_BGR_INTEGER

GLScene.OpenGL4

GL_BGR_INTEGER_EXT

GLScene.OpenGL4

GL_BIAS_BIT_ATI

GLScene.OpenGL4

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV

GLScene.OpenGL4

GL_BINORMAL_ARRAY_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_BITMAP

GLScene.OpenGL4

GL_BITMAP_TOKEN

GLScene.OpenGL4

GL_BLEND

GLScene.OpenGL4

GL_BLEND_ADVANCED_COHERENT_KHR

GLScene.OpenGL4

GL_KHR_blend_equation_advanced_coherent

GL_BLEND_COLOR

GLScene.OpenGL4

GL_BLEND_COLOR_EXT

GLScene.OpenGL4

GL_BLEND_DST

GLScene.OpenGL4

GL_BLEND_DST_ALPHA

GLScene.OpenGL4

GL_BLEND_DST_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_DST_RGB

GLScene.OpenGL4

GL_VERSION_1_4

GL_BLEND_DST_RGB_EXT

GLScene.OpenGL4

GL_EXT_blend_func_separate

GL_BLEND_EQUATION

GLScene.OpenGL4

GL_BLEND_EQUATION_ALPHA

GLScene.OpenGL4

GL_BLEND_EQUATION_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_EQUATION_EXT

GLScene.OpenGL4

GL_BLEND_EQUATION_RGB

GLScene.OpenGL4

GL_VERSION_2_0

GL_BLEND_EQUATION_RGB_EXT

GLScene.OpenGL4

GL_EXT_blend_equation_separate

GL_BLEND_SRC

GLScene.OpenGL4

GL_BLEND_SRC_ALPHA

GLScene.OpenGL4

GL_BLEND_SRC_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_SRC_RGB

GLScene.OpenGL4

GL_BLEND_SRC_RGB_EXT

GLScene.OpenGL4

GL_BLOCK_INDEX

GLScene.OpenGL4

GL_BLUE

GLScene.OpenGL4

GL_BLUE_BIAS

GLScene.OpenGL4

GL_BLUE_BITS

GLScene.OpenGL4

GL_BLUE_BIT_ATI

GLScene.OpenGL4

GL_BLUE_INTEGER

GLScene.OpenGL4

GL_BLUE_INTEGER_EXT

GLScene.OpenGL4

GL_BLUE_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_BLUE_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_BLUE_SCALE

GLScene.OpenGL4

GL_BOLD_BIT_NV

GLScene.OpenGL4

GL_BOOL

GLScene.OpenGL4

GL_BOOL_ARB

GLScene.OpenGL4

GL_BOOL_VEC2

GLScene.OpenGL4

GL_BOOL_VEC2_ARB

GLScene.OpenGL4

GL_BOOL_VEC3

GLScene.OpenGL4

GL_BOOL_VEC3_ARB

GLScene.OpenGL4

GL_BOOL_VEC4

GLScene.OpenGL4

GL_BOOL_VEC4_ARB

GLScene.OpenGL4

GL_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV

GLScene.OpenGL4

GL_BUFFER

GLScene.OpenGL4

GL_BUFFER_ACCESS

GLScene.OpenGL4

GL_BUFFER_ACCESS_ARB

GLScene.OpenGL4

GL_BUFFER_ACCESS_FLAGS

GLScene.OpenGL4

GL_BUFFER_BINDING

GLScene.OpenGL4

GL_BUFFER_DATA_SIZE

GLScene.OpenGL4

GL_BUFFER_GPU_ADDRESS_NV

GLScene.OpenGL4

GL_NV_shader_buffer_load

GL_BUFFER_IMMUTABLE_STORAGE

GLScene.OpenGL4

GL_BUFFER_MAPPED

GLScene.OpenGL4

GL_BUFFER_MAPPED_ARB

GLScene.OpenGL4

GL_BUFFER_MAP_LENGTH

GLScene.OpenGL4

GL_BUFFER_MAP_OFFSET

GLScene.OpenGL4

GL_BUFFER_MAP_POINTER

GLScene.OpenGL4

GL_BUFFER_MAP_POINTER_ARB

GLScene.OpenGL4

GL_BUFFER_OBJECT_APPLE

GLScene.OpenGL4

GL_APPLE_object_purgeable

GL_BUFFER_SIZE

GLScene.OpenGL4

GL_VERSION_1_5

GL_BUFFER_SIZE_ARB

GLScene.OpenGL4

GL_ARB_vertex_buffer_object

GL_BUFFER_STORAGE_FLAGS

GLScene.OpenGL4

GL_BUFFER_UPDATE_BARRIER_BIT

GLScene.OpenGL4

GL_BUFFER_UPDATE_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_BUFFER_USAGE

GLScene.OpenGL4

GL_BUFFER_USAGE_ARB

GLScene.OpenGL4

GL_BUFFER_VARIABLE

GLScene.OpenGL4

GL_BUMP_ENVMAP_ATI

GLScene.OpenGL4

GL_BUMP_NUM_TEX_UNITS_ATI

GLScene.OpenGL4

GL_BUMP_ROT_MATRIX_ATI

GLScene.OpenGL4

GL_ATI_envmap_bumpmap

GL_BUMP_ROT_MATRIX_SIZE_ATI

GLScene.OpenGL4

GL_BUMP_TARGET_ATI

GLScene.OpenGL4

GL_BUMP_TEX_UNITS_ATI

GLScene.OpenGL4

GL_BYTE

GLScene.OpenGL4

DataType

GL_C3F_V3F

GLScene.OpenGL4

GL_C4F_N3F_V3F

GLScene.OpenGL4

GL_C4UB_V2F

GLScene.OpenGL4

GL_C4UB_V3F

GLScene.OpenGL4

GL_CALLIGRAPHIC_FRAGMENT_SGIX

GLScene.OpenGL4

GL_SGIX_calligraphic_fragment

GL_CAVEAT_SUPPORT

GLScene.OpenGL4

GL_CCW

GLScene.OpenGL4

GL_CIRCULAR_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_CIRCULAR_CW_ARC_TO_NV

GLScene.OpenGL4

GL_CIRCULAR_TANGENT_ARC_TO_NV

GLScene.OpenGL4

GL_CLAMP

GLScene.OpenGL4

GL_CLAMP_FRAGMENT_COLOR

GLScene.OpenGL4

GL_CLAMP_FRAGMENT_COLOR_ARB

GLScene.OpenGL4

GL_CLAMP_READ_COLOR

GLScene.OpenGL4

GL_CLAMP_READ_COLOR_ARB

GLScene.OpenGL4

GL_CLAMP_TO_BORDER

GLScene.OpenGL4

GL_CLAMP_TO_BORDER_ARB

GLScene.OpenGL4

GL_ARB_texture_border_clamp

GL_CLAMP_TO_EDGE

GLScene.OpenGL4

GL_CLAMP_TO_EDGE_EXT

GLScene.OpenGL4

GL_EXT_texture_edge_clamp

GL_CLAMP_TO_EDGE_SGIS

GLScene.OpenGL4

GL_SGIS_texture_edge_clamp

GL_CLAMP_VERTEX_COLOR

GLScene.OpenGL4

GL_CLAMP_VERTEX_COLOR_ARB

GLScene.OpenGL4

GL_CLEAR

GLScene.OpenGL4

LogicOp

GL_CLEAR_BUFFER

GLScene.OpenGL4

GL_CLEAR_TEXTURE

GLScene.OpenGL4

GL_CLIENT_ACTIVE_TEXTURE

GLScene.OpenGL4

GL_CLIENT_ACTIVE_TEXTURE_ARB

GLScene.OpenGL4

GL_CLIENT_ALL_ATTRIB_BITS

GLScene.OpenGL4

GL_CLIENT_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_CLIENT_MAPPED_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_CLIENT_PIXEL_STORE_BIT

GLScene.OpenGL4

GL_CLIENT_STORAGE_BIT

GLScene.OpenGL4

GL_CLIENT_VERTEX_ARRAY_BIT

GLScene.OpenGL4

GL_CLIPPING_INPUT_PRIMITIVES

GLScene.OpenGL4

GL_CLIPPING_INPUT_PRIMITIVES_ARB

GLScene.OpenGL4

GL_CLIPPING_OUTPUT_PRIMITIVES

GLScene.OpenGL4

GL_CLIPPING_OUTPUT_PRIMITIVES_ARB

GLScene.OpenGL4

GL_CLIP_DEPTH_MODE

GLScene.OpenGL4

GL_CLIP_DISTANCE0

GLScene.OpenGL4

GL_CLIP_DISTANCE1

GLScene.OpenGL4

GL_CLIP_DISTANCE2

GLScene.OpenGL4

GL_CLIP_DISTANCE3

GLScene.OpenGL4

GL_CLIP_DISTANCE4

GLScene.OpenGL4

GL_CLIP_DISTANCE5

GLScene.OpenGL4

GL_CLIP_DISTANCE6

GLScene.OpenGL4

GL_CLIP_DISTANCE7

GLScene.OpenGL4

GL_CLIP_DISTANCE_NV

GLScene.OpenGL4

GL_CLIP_FAR_HINT_PGI

GLScene.OpenGL4

GL_CLIP_NEAR_HINT_PGI

GLScene.OpenGL4

GL_CLIP_ORIGIN

GLScene.OpenGL4

GL_CLIP_PLANE0

GLScene.OpenGL4

GL_CLIP_PLANE1

GLScene.OpenGL4

GL_CLIP_PLANE2

GLScene.OpenGL4

GL_CLIP_PLANE3

GLScene.OpenGL4

GL_CLIP_PLANE4

GLScene.OpenGL4

GL_CLIP_PLANE5

GLScene.OpenGL4

GL_CLIP_VOLUME_CLIPPING_HINT_EXT

GLScene.OpenGL4

GL_EXT_clip_volume_hint

GL_CLOSE_PATH_NV

GLScene.OpenGL4

GL_CMYKA_EXT

GLScene.OpenGL4

GL_CMYK_EXT

GLScene.OpenGL4

GL_EXT_cmyka

GL_CND0_ATI

GLScene.OpenGL4

GL_CND_ATI

GLScene.OpenGL4

GL_COEFF

GLScene.OpenGL4

GL_COLOR

GLScene.OpenGL4

PixelCopyType

GL_COLOR3_BIT_PGI

GLScene.OpenGL4

GL_COLOR4_BIT_PGI

GLScene.OpenGL4

GL_COLORBURN_KHR

GLScene.OpenGL4

GL_COLORDODGE_KHR

GLScene.OpenGL4

GL_COLOR_ALPHA_PAIRING_ATI

GLScene.OpenGL4

GL_COLOR_ARRAY

GLScene.OpenGL4

GL_COLOR_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_COLOR_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_COLOR_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_COLOR_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_COLOR_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_COLOR_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_COLOR_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_COLOR_ARRAY_POINTER

GLScene.OpenGL4

GL_COLOR_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_SIZE

GLScene.OpenGL4

GL_COLOR_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_STRIDE

GLScene.OpenGL4

GL_COLOR_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_TYPE

GLScene.OpenGL4

GL_COLOR_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT0

GLScene.OpenGL4

GL_COLOR_ATTACHMENT0_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT1

GLScene.OpenGL4

GL_COLOR_ATTACHMENT10

GLScene.OpenGL4

GL_COLOR_ATTACHMENT10_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT11

GLScene.OpenGL4

GL_COLOR_ATTACHMENT11_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT12

GLScene.OpenGL4

GL_COLOR_ATTACHMENT12_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT13

GLScene.OpenGL4

GL_COLOR_ATTACHMENT13_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT14

GLScene.OpenGL4

GL_COLOR_ATTACHMENT14_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT15

GLScene.OpenGL4

GL_COLOR_ATTACHMENT15_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT1_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT2

GLScene.OpenGL4

GL_COLOR_ATTACHMENT2_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT3

GLScene.OpenGL4

GL_COLOR_ATTACHMENT3_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT4

GLScene.OpenGL4

GL_COLOR_ATTACHMENT4_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT5

GLScene.OpenGL4

GL_COLOR_ATTACHMENT5_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT6

GLScene.OpenGL4

GL_COLOR_ATTACHMENT6_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT7

GLScene.OpenGL4

GL_COLOR_ATTACHMENT7_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT8

GLScene.OpenGL4

GL_COLOR_ATTACHMENT8_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT9

GLScene.OpenGL4

GL_COLOR_ATTACHMENT9_EXT

GLScene.OpenGL4

GL_COLOR_BUFFER_BIT

GLScene.OpenGL4

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI

GLScene.OpenGL4

GL_COLOR_CLEAR_VALUE

GLScene.OpenGL4

GL_COLOR_COMPONENTS

GLScene.OpenGL4

GL_COLOR_ENCODING

GLScene.OpenGL4

GL_COLOR_FLOAT_APPLE

GLScene.OpenGL4

GL_COLOR_INDEX

GLScene.OpenGL4

GL_COLOR_INDEX12_EXT

GLScene.OpenGL4

GL_COLOR_INDEX16_EXT

GLScene.OpenGL4

GL_COLOR_INDEX1_EXT

GLScene.OpenGL4

GL_EXT_paletted_texture

GL_COLOR_INDEX2_EXT

GLScene.OpenGL4

GL_COLOR_INDEX4_EXT

GLScene.OpenGL4

GL_COLOR_INDEX8_EXT

GLScene.OpenGL4

GL_COLOR_INDEXES

GLScene.OpenGL4

GL_COLOR_LOGIC_OP

GLScene.OpenGL4

GL_COLOR_MATERIAL

GLScene.OpenGL4

GL_COLOR_MATERIAL_FACE

GLScene.OpenGL4

GL_COLOR_MATERIAL_PARAMETER

GLScene.OpenGL4

GL_COLOR_MATRIX

GLScene.OpenGL4

GL_COLOR_MATRIX_SGI

GLScene.OpenGL4

GL_SGI_color_matrix

GL_COLOR_MATRIX_STACK_DEPTH

GLScene.OpenGL4

GL_COLOR_MATRIX_STACK_DEPTH_SGI

GLScene.OpenGL4

GL_COLOR_RENDERABLE

GLScene.OpenGL4

GL_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_COLOR_SUM

GLScene.OpenGL4

GL_COLOR_SUM_ARB

GLScene.OpenGL4

GL_ARB_vertex_program

GL_COLOR_SUM_CLAMP_NV

GLScene.OpenGL4

GL_COLOR_SUM_EXT

GLScene.OpenGL4

GL_EXT_secondary_color

GL_COLOR_TABLE

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_BIAS

GLScene.OpenGL4

GL_COLOR_TABLE_BIAS_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_SCALE

GLScene.OpenGL4

GL_COLOR_TABLE_SCALE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_SGI_color_table

GL_COLOR_TABLE_WIDTH

GLScene.OpenGL4

GL_COLOR_TABLE_WIDTH_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_WIDTH_SGI

GLScene.OpenGL4

GL_COLOR_WRITEMASK

GLScene.OpenGL4

GL_COMBINE

GLScene.OpenGL4

GL_COMBINE4_NV

GLScene.OpenGL4

GL_NV_texture_env_combine4

GL_COMBINER0_NV

GLScene.OpenGL4

GL_COMBINER1_NV

GLScene.OpenGL4

GL_COMBINER2_NV

GLScene.OpenGL4

GL_COMBINER3_NV

GLScene.OpenGL4

GL_COMBINER4_NV

GLScene.OpenGL4

GL_COMBINER5_NV

GLScene.OpenGL4

GL_COMBINER6_NV

GLScene.OpenGL4

GL_COMBINER7_NV

GLScene.OpenGL4

GL_COMBINER_AB_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_COMBINER_AB_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINER_BIAS_NV

GLScene.OpenGL4

GL_COMBINER_CD_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_COMBINER_CD_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINER_COMPONENT_USAGE_NV

GLScene.OpenGL4

GL_COMBINER_INPUT_NV

GLScene.OpenGL4

GL_COMBINER_MAPPING_NV

GLScene.OpenGL4

GL_COMBINER_MUX_SUM_NV

GLScene.OpenGL4

GL_COMBINER_SCALE_NV

GLScene.OpenGL4

GL_COMBINER_SUM_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINE_ALPHA

GLScene.OpenGL4

GL_COMBINE_ALPHA_ARB

GLScene.OpenGL4

GL_COMBINE_ALPHA_EXT

GLScene.OpenGL4

GL_COMBINE_ARB

GLScene.OpenGL4

GL_ARB_texture_env_combine

GL_COMBINE_EXT

GLScene.OpenGL4

GL_EXT_texture_env_combine

GL_COMBINE_RGB

GLScene.OpenGL4

GL_COMBINE_RGB_ARB

GLScene.OpenGL4

GL_COMBINE_RGB_EXT

GLScene.OpenGL4

GL_COMMAND_BARRIER_BIT

GLScene.OpenGL4

GL_COMMAND_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT

GLScene.OpenGL4

GL_COMPARE_REF_TO_TEXTURE

GLScene.OpenGL4

GL_VERSION_3_0

GL_COMPARE_R_TO_TEXTURE

GLScene.OpenGL4

GL_COMPARE_R_TO_TEXTURE_ARB

GLScene.OpenGL4

GL_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_COMPILE

GLScene.OpenGL4

GL_COMPILE_AND_EXECUTE

GLScene.OpenGL4

GL_COMPILE_STATUS

GLScene.OpenGL4

GL_COMPLETION_STATUS_ARB

GLScene.OpenGL4

GL_COMPRESSED_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_ALPHA_ARB

GLScene.OpenGL4

GL_ARB_texture_compression

GL_COMPRESSED_INTENSITY

GLScene.OpenGL4

GL_COMPRESSED_INTENSITY_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI

GLScene.OpenGLTokens

GL_ATI_texture_compression_3dc

GL_COMPRESSED_LUMINANCE_ALPHA_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_LATC1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_latc

GL_COMPRESSED_R11_EAC

GLScene.OpenGL4

GL_COMPRESSED_RED

GLScene.OpenGL4

GL_COMPRESSED_RED_GREEN_RGTC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_RED_RGTC1

GLScene.OpenGL4

GL_ARB_texture_compression_rgtc

GL_COMPRESSED_RED_RGTC1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_rgtc

GL_COMPRESSED_RG

GLScene.OpenGL4

GL_COMPRESSED_RG11_EAC

GLScene.OpenGL4

GL_COMPRESSED_RGB

GLScene.OpenGL4

GL_COMPRESSED_RGB8_ETC2

GLScene.OpenGL4

GL_COMPRESSED_RGB8_PUNCHTHROUGH_ALPHA1_ETC2

GLScene.OpenGL4

GL_COMPRESSED_RGBA

GLScene.OpenGL4

GL_COMPRESSED_RGBA8_ETC2_EAC

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_105_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_106_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_108_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_110_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_12x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_12x12_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_4x4_KHR

GLScene.OpenGL4

4.3 GL_KHR_texture_compression_astc_hdr

GL_COMPRESSED_RGBA_ASTC_5x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_5x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_6x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_6x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB

GLScene.OpenGL4

GL_ARB_texture_compression_bptc

GL_COMPRESSED_RGBA_FXT1_3DFX

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGB_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_FXT1_3DFX

GLScene.OpenGL4

GL_3DFX_texture_compression_FXT1

GL_COMPRESSED_RGB_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_s3tc

GL_COMPRESSED_RG_RGTC2

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_R11_EAC

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_RGTC1

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RG11_EAC

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RG_RGTC2

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x12_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_4x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ETC2_EAC

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ETC2

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_PUNCHTHROUGH_ALPHA1_ETC2

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_TEXTURE_FORMATS

GLScene.OpenGL4

GL_COMPRESSED_TEXTURE_FORMATS_ARB

GLScene.OpenGL4

GL_COMPUTE_LOCAL_WORK_SIZE

GLScene.OpenGL4

GL_COMPUTE_SHADER

GLScene.OpenGL4

GL_COMPUTE_SHADER_BIT

GLScene.OpenGL4

GL_COMPUTE_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_COMPUTE_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_COMPUTE_SUBROUTINE

GLScene.OpenGL4

GL_COMPUTE_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_COMPUTE_TEXTURE

GLScene.OpenGL4

GL_COMP_BIT_ATI

GLScene.OpenGL4

GL_CONDITION_SATISFIED

GLScene.OpenGL4

GL_CONSERVATIVE_RASTERIZATION_NV

GLScene.OpenGL4

GL_NV_conservative_raster

GL_CONSERVATIVE_RASTER_DILATE_GRANULARITY_NV

GLScene.OpenGL4

GL_CONSERVATIVE_RASTER_DILATE_NV

GLScene.OpenGL4

GL_NV_conservative_raster_dilate

GL_CONSERVATIVE_RASTER_DILATE_RANGE_NV

GLScene.OpenGL4

GL_CONSERVE_MEMORY_HINT_PGI

GLScene.OpenGL4

GL_CONSTANT

GLScene.OpenGL4

GL_CONSTANT_ALPHA

GLScene.OpenGL4

GL_CONSTANT_ALPHA_EXT

GLScene.OpenGL4

GL_CONSTANT_ARB

GLScene.OpenGL4

GL_CONSTANT_ATTENUATION

GLScene.OpenGL4

GL_CONSTANT_BORDER

GLScene.OpenGL4

GL_CONSTANT_BORDER_HP

GLScene.OpenGL4

GL_CONSTANT_COLOR0_NV

GLScene.OpenGL4

GL_CONSTANT_COLOR1_NV

GLScene.OpenGL4

GL_CONSTANT_COLOR_ARB

GLScene.OpenGL4

GL_ARB_imaging

GL_CONSTANT_COLOR_EXT

GLScene.OpenGL4

GL_EXT_blend_color

GL_CONSTANT_EXT

GLScene.OpenGL4

GL_CONST_EYE_NV

GLScene.OpenGL4

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT

GLScene.OpenGL4

GL_CONTEXT_CORE_PROFILE_BIT

GLScene.OpenGL4

GL_VERSION_3_2

GL_CONTEXT_FLAGS

GLScene.OpenGL4

GL_CONTEXT_FLAG_DEBUG_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_NO_ERROR_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_NO_ERROR_BIT_KHR

GLScene.OpenGL4

GL_KHR_no_error

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

GL_ARB_robustness

GL_CONTEXT_LOST

GLScene.OpenGL4

GL 4.5

GL_CONTEXT_PROFILE_MASK

GLScene.OpenGL4

GL_CONTEXT_RELEASE_BEHAVIOR

GLScene.OpenGL4

GL_CONTEXT_RELEASE_BEHAVIOR_FLUSH

GLScene.OpenGL4

GL_CONTEXT_ROBUST_ACCESS

GLScene.OpenGL4

GL_KHR_robustness

GL_CONTINUOUS_AMD

GLScene.OpenGL4

GL_CONVEX_HULL_NV

GLScene.OpenGL4

GL_CONVOLUTION_1D

GLScene.OpenGL4

GL_CONVOLUTION_1D_EXT

GLScene.OpenGL4

GL_EXT_convolution

GL_CONVOLUTION_2D

GLScene.OpenGL4

GL_CONVOLUTION_2D_EXT

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_COLOR

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_COLOR_HP

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_MODE

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_MODE_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_BIAS

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_BIAS_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_SCALE

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_SCALE_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FORMAT

GLScene.OpenGL4

GL_CONVOLUTION_FORMAT_EXT

GLScene.OpenGL4

GL_CONVOLUTION_HEIGHT

GLScene.OpenGL4

GL_CONVOLUTION_HEIGHT_EXT

GLScene.OpenGL4

GL_CONVOLUTION_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_convolution_accuracy

GL_CONVOLUTION_WIDTH

GLScene.OpenGL4

GL_CONVOLUTION_WIDTH_EXT

GLScene.OpenGL4

GL_CON_0_ATI

GLScene.OpenGL4

GL_CON_10_ATI

GLScene.OpenGL4

GL_CON_11_ATI

GLScene.OpenGL4

GL_CON_12_ATI

GLScene.OpenGL4

GL_CON_13_ATI

GLScene.OpenGL4

GL_CON_14_ATI

GLScene.OpenGL4

GL_CON_15_ATI

GLScene.OpenGL4

GL_CON_16_ATI

GLScene.OpenGL4

GL_CON_17_ATI

GLScene.OpenGL4

GL_CON_18_ATI

GLScene.OpenGL4

GL_CON_19_ATI

GLScene.OpenGL4

GL_CON_1_ATI

GLScene.OpenGL4

GL_CON_20_ATI

GLScene.OpenGL4

GL_CON_21_ATI

GLScene.OpenGL4

GL_CON_22_ATI

GLScene.OpenGL4

GL_CON_23_ATI

GLScene.OpenGL4

GL_CON_24_ATI

GLScene.OpenGL4

GL_CON_25_ATI

GLScene.OpenGL4

GL_CON_26_ATI

GLScene.OpenGL4

GL_CON_27_ATI

GLScene.OpenGL4

GL_CON_28_ATI

GLScene.OpenGL4

GL_CON_29_ATI

GLScene.OpenGL4

GL_CON_2_ATI

GLScene.OpenGL4

GL_CON_30_ATI

GLScene.OpenGL4

GL_CON_31_ATI

GLScene.OpenGL4

GL_CON_3_ATI

GLScene.OpenGL4

GL_CON_4_ATI

GLScene.OpenGL4

GL_CON_5_ATI

GLScene.OpenGL4

GL_CON_6_ATI

GLScene.OpenGL4

GL_CON_7_ATI

GLScene.OpenGL4

GL_CON_8_ATI

GLScene.OpenGL4

GL_CON_9_ATI

GLScene.OpenGL4

GL_COORD_REPLACE

GLScene.OpenGL4

GL_COORD_REPLACE_ARB

GLScene.OpenGL4

GL_COORD_REPLACE_NV

GLScene.OpenGL4

GL_COPY

GLScene.OpenGL4

GL_COPY_INVERTED

GLScene.OpenGL4

GL_COPY_PIXEL_TOKEN

GLScene.OpenGL4

GL_COPY_READ_BUFFER

GLScene.OpenGL4

GL_COPY_READ_BUFFER_BINDING

GLScene.OpenGL4

GL_ARB_copy_buffer

GL_COPY_WRITE_BUFFER

GLScene.OpenGL4

GL_COPY_WRITE_BUFFER_BINDING

GLScene.OpenGL4

GL_COUNTER_RANGE_AMD

GLScene.OpenGL4

GL_COUNTER_TYPE_AMD

GLScene.OpenGL4

GL_AMD_performance_monitor

GL_COUNT_DOWN_NV

GLScene.OpenGL4

GL_COUNT_UP_NV

GLScene.OpenGL4

GL_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_multisample_coverage

GL_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_CUBIC_EXT

GLScene.OpenGL4

GL_CUBIC_HP

GLScene.OpenGL4

GL_CULL_FACE

GLScene.OpenGL4

GL_CULL_FACE_MODE

GLScene.OpenGL4

GL_CULL_FRAGMENT_NV

GLScene.OpenGL4

GL_CULL_MODES_NV

GLScene.OpenGL4

GL_CULL_VERTEX_EXT

GLScene.OpenGL4

GL_EXT_cull_vertex

GL_CULL_VERTEX_EYE_POSITION_EXT

GLScene.OpenGL4

GL_CULL_VERTEX_IBM

GLScene.OpenGL4

GL_IBM_cull_vertex

GL_CULL_VERTEX_OBJECT_POSITION_EXT

GLScene.OpenGL4

GL_CURRENT_ATTRIB_NV

GLScene.OpenGL4

GL_CURRENT_BINORMAL_EXT

GLScene.OpenGL4

GL_CURRENT_BIT

GLScene.OpenGL4

GL_CURRENT_COLOR

GLScene.OpenGL4

GL_CURRENT_FOG_COORD

GLScene.OpenGL4

GL_CURRENT_FOG_COORDINATE

GLScene.OpenGL4

GL_CURRENT_FOG_COORDINATE_EXT

GLScene.OpenGL4

GL_CURRENT_INDEX

GLScene.OpenGL4

GL_CURRENT_MATRIX_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_INDEX_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_NV

GLScene.OpenGL4

GL_CURRENT_MATRIX_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_STACK_DEPTH_NV

GLScene.OpenGL4

GL_CURRENT_NORMAL

GLScene.OpenGL4

GL_CURRENT_OCCLUSION_QUERY_ID_NV

GLScene.OpenGL4

GL_CURRENT_PALETTE_MATRIX_ARB

GLScene.OpenGL4

GL_CURRENT_PROGRAM

GLScene.OpenGL4

GL_CURRENT_QUERY

GLScene.OpenGL4

GL_CURRENT_QUERY_ARB

GLScene.OpenGL4

GL_CURRENT_RASTER_COLOR

GLScene.OpenGL4

GL_CURRENT_RASTER_DISTANCE

GLScene.OpenGL4

GL_CURRENT_RASTER_INDEX

GLScene.OpenGL4

GL_CURRENT_RASTER_NORMAL_SGIX

GLScene.OpenGL4

GL_CURRENT_RASTER_POSITION

GLScene.OpenGL4

GL_CURRENT_RASTER_POSITION_VALID

GLScene.OpenGL4

GL_CURRENT_RASTER_SECONDARY_COLOR

GLScene.OpenGL4

GL_CURRENT_RASTER_TEXTURE_COORDS

GLScene.OpenGL4

GL_CURRENT_SECONDARY_COLOR

GLScene.OpenGL4

GL_CURRENT_SECONDARY_COLOR_EXT

GLScene.OpenGL4

GL_CURRENT_TANGENT_EXT

GLScene.OpenGL4

GL_CURRENT_TEXTURE_COORDS

GLScene.OpenGL4

GL_CURRENT_TIME_NV

GLScene.OpenGL4

GL_CURRENT_VERTEX_ATTRIB

GLScene.OpenGL4

GL_CURRENT_VERTEX_ATTRIB_ARB

GLScene.OpenGL4

GL_CURRENT_VERTEX_EXT

GLScene.OpenGL4

GL_CURRENT_VERTEX_WEIGHT_EXT

GLScene.OpenGL4

GL_CURRENT_WEIGHT_ARB

GLScene.OpenGL4

GL_CW

GLScene.OpenGL4

FrontFaceDirection

GL_DARKEN_KHR

GLScene.OpenGL4

GL_DATA_BUFFER_AMD

GLScene.OpenGL4

GL_AMD_name_gen_delete

GL_DEBUG_CALLBACK_FUNCTION

GLScene.OpenGL4

GL_DEBUG_CALLBACK_FUNCTION_ARB

GLScene.OpenGL4

GL_DEBUG_CALLBACK_USER_PARAM

GLScene.OpenGL4

GL_DEBUG_CALLBACK_USER_PARAM_ARB

GLScene.OpenGL4

GL_DEBUG_CATEGORY_API_ERROR_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_APPLICATION_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_DEPRECATION_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_OTHER_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_PERFORMANCE_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_SHADER_COMPILER_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_UNDEFINED_BEHAVIOR_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_WINDOW_SYSTEM_AMD

GLScene.OpenGL4

GL_DEBUG_GROUP_STACK_DEPTH

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES_AMD

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES_ARB

GLScene.OpenGL4

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH

GLScene.OpenGL4

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB

GLScene.OpenGL4

GL_DEBUG_OUTPUT

GLScene.OpenGL4

GL_DEBUG_OUTPUT_SYNCHRONOUS

GLScene.OpenGL4

(4.3) GL_KHR_debug

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB

GLScene.OpenGL4

GL_ARB_debug_output

GL_DEBUG_SEVERITY_HIGH

GLScene.OpenGL4

GL_DEBUG_SEVERITY_HIGH_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_HIGH_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_NOTIFICATION

GLScene.OpenGL4

GL_DEBUG_SOURCE_API

GLScene.OpenGL4

GL_DEBUG_SOURCE_API_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_APPLICATION

GLScene.OpenGL4

GL_DEBUG_SOURCE_APPLICATION_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_OTHER

GLScene.OpenGL4

GL_DEBUG_SOURCE_OTHER_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_SHADER_COMPILER

GLScene.OpenGL4

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_THIRD_PARTY

GLScene.OpenGL4

GL_DEBUG_SOURCE_THIRD_PARTY_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_WINDOW_SYSTEM

GLScene.OpenGL4

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR

GLScene.OpenGL4

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_ERROR

GLScene.OpenGL4

GL_DEBUG_TYPE_ERROR_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_MARKER

GLScene.OpenGL4

GL_DEBUG_TYPE_OTHER

GLScene.OpenGL4

GL_DEBUG_TYPE_OTHER_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_PERFORMANCE

GLScene.OpenGL4

GL_DEBUG_TYPE_PERFORMANCE_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_POP_GROUP

GLScene.OpenGL4

GL_DEBUG_TYPE_PORTABILITY

GLScene.OpenGL4

GL_DEBUG_TYPE_PORTABILITY_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_PUSH_GROUP

GLScene.OpenGL4

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR

GLScene.OpenGL4

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB

GLScene.OpenGL4

GL_DECAL

GLScene.OpenGL4

GL_DECODE_EXT

GLScene.OpenGL4

GL_DECR

GLScene.OpenGL4

GL_DECR_WRAP

GLScene.OpenGL4

GL_DECR_WRAP_EXT

GLScene.OpenGL4

GL_DEFORMATIONS_MASK_SGIX

GLScene.OpenGL4

GL_DELETE_STATUS

GLScene.OpenGL4

GL_DEPENDENT_AR_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_GB_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_HILO_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_RGB_TEXTURE_3D_NV

GLScene.OpenGL4

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DEPTH

GLScene.OpenGL4

GL_DEPTH24_STENCIL8

GLScene.OpenGL4

GL_DEPTH24_STENCIL8_EXT

GLScene.OpenGL4

GL_DEPTH32F_STENCIL8

GLScene.OpenGL4

GL_DEPTH_ATTACHMENT

GLScene.OpenGL4

GL_DEPTH_ATTACHMENT_EXT

GLScene.OpenGL4

GL_DEPTH_BIAS

GLScene.OpenGL4

GL_DEPTH_BITS

GLScene.OpenGL4

GL_DEPTH_BOUNDS_EXT

GLScene.OpenGL4

GL_DEPTH_BOUNDS_TEST_EXT

GLScene.OpenGL4

GL_EXT_depth_bounds_test

GL_DEPTH_BUFFER

GLScene.OpenGL4

GL_DEPTH_BUFFER_BIT

GLScene.OpenGL4

AttribMask

GL_DEPTH_BUFFER_FLOAT_MODE_NV

GLScene.OpenGL4

GL_DEPTH_CLAMP

GLScene.OpenGL4

GL_ARB_depth_clamp

GL_DEPTH_CLAMP_FAR_AMD

GLScene.OpenGL4

GL_DEPTH_CLAMP_NEAR_AMD

GLScene.OpenGL4

GL_AMD_depth_clamp_separate

GL_DEPTH_CLAMP_NV

GLScene.OpenGL4

GL_NV_depth_clamp

GL_DEPTH_CLEAR_VALUE

GLScene.OpenGL4

GL_DEPTH_COMPONENT

GLScene.OpenGL4

GL_DEPTH_COMPONENT16

GLScene.OpenGL4

GL_DEPTH_COMPONENT16_ARB

GLScene.OpenGL4

GL_ARB_depth_texture

GL_DEPTH_COMPONENT16_SGIX

GLScene.OpenGL4

GL_SGIX_depth_texture

GL_DEPTH_COMPONENT24

GLScene.OpenGL4

GL_DEPTH_COMPONENT24_ARB

GLScene.OpenGL4

GL_DEPTH_COMPONENT24_SGIX

GLScene.OpenGL4

GL_DEPTH_COMPONENT32

GLScene.OpenGL4

GL_DEPTH_COMPONENT32F

GLScene.OpenGL4

GL_ARB_depth_buffer_float

GL_DEPTH_COMPONENT32_ARB

GLScene.OpenGL4

GL_DEPTH_COMPONENT32_SGIX

GLScene.OpenGL4

GL_DEPTH_COMPONENTS

GLScene.OpenGL4

GL_DEPTH_FUNC

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_COUNTERS_SGIX

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_MAX_SGIX

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_SGIX

GLScene.OpenGL4

GL_SGI_depth_pass_instrument

GL_DEPTH_RANGE

GLScene.OpenGL4

GL_DEPTH_RENDERABLE

GLScene.OpenGL4

GL_DEPTH_SCALE

GLScene.OpenGL4

GL_DEPTH_STENCIL

GLScene.OpenGL4

GL_DEPTH_STENCIL_ATTACHMENT

GLScene.OpenGL4

GL_DEPTH_STENCIL_EXT

GLScene.OpenGL4

GL_EXT_packed_depth_stencil

GL_DEPTH_STENCIL_NV

GLScene.OpenGL4

GL_NV_packed_depth_stencil

GL_DEPTH_STENCIL_TEXTURE_MODE

GLScene.OpenGL4

GL_DEPTH_STENCIL_TO_BGRA_NV

GLScene.OpenGL4

GL_DEPTH_STENCIL_TO_RGBA_NV

GLScene.OpenGL4

GL_NV_copy_depth_to_color

GL_DEPTH_TEST

GLScene.OpenGL4

GL_DEPTH_TEXTURE_MODE

GLScene.OpenGL4

GL_DEPTH_TEXTURE_MODE_ARB

GLScene.OpenGL4

GL_DEPTH_WRITEMASK

GLScene.OpenGL4

GL_DETAIL_TEXTURE_2D_BINDING_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_2D_SGIS

GLScene.OpenGL4

GL_SGIS_detail_texture

GL_DETAIL_TEXTURE_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_LEVEL_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_MODE_SGIS

GLScene.OpenGL4

GL_DIFFERENCE_KHR

GLScene.OpenGL4

GL_DIFFUSE

GLScene.OpenGL4

GL_DISCARD_ATI

GLScene.OpenGL4

GL_DISCARD_NV

GLScene.OpenGL4

GL_DISCRETE_AMD

GLScene.OpenGL4

GL_DISPATCH_INDIRECT_BUFFER

GLScene.OpenGL4

GL_DISPATCH_INDIRECT_BUFFER_BINDING

GLScene.OpenGL4

GL_DISPLAY_LIST

GLScene.OpenGL4

GL_DISTANCE_ATTENUATION_EXT

GLScene.OpenGL4

GL_DISTANCE_ATTENUATION_SGIS

GLScene.OpenGL4

GL_DITHER

GLScene.OpenGL4

GL_DOMAIN

GLScene.OpenGL4

GL_DONT_CARE

GLScene.OpenGL4

HintMode

GL_DOT2_ADD_ATI

GLScene.OpenGL4

GL_DOT3_ATI

GLScene.OpenGL4

GL_DOT3_RGB

GLScene.OpenGL4

GL_DOT3_RGBA

GLScene.OpenGL4

GL_DOT3_RGBA_ARB

GLScene.OpenGL4

GL_DOT3_RGBA_EXT

GLScene.OpenGL4

GL_DOT3_RGB_ARB

GLScene.OpenGL4

GL_ARB_texture_env_dot3

GL_DOT3_RGB_EXT

GLScene.OpenGL4

GL_EXT_texture_env_dot3

GL_DOT4_ATI

GLScene.OpenGL4

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_DEPTH_REPLACE_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_PASS_THROUGH_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_1D_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_3D_NV

GLScene.OpenGL4

GL_NV_texture_shader2

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_DOUBLE

GLScene.OpenGL4

GL_DOUBLEBUFFER

GLScene.OpenGL4

GL_DOUBLE_MAT2

GLScene.OpenGL4

GL_DOUBLE_MAT2x3

GLScene.OpenGL4

GL_DOUBLE_MAT2x3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT2x4

GLScene.OpenGL4

GL_DOUBLE_MAT2x4_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3

GLScene.OpenGL4

GL_DOUBLE_MAT3x2

GLScene.OpenGL4

GL_DOUBLE_MAT3x2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3x4

GLScene.OpenGL4

GL_DOUBLE_MAT3x4_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4

GLScene.OpenGL4

GL_DOUBLE_MAT4x2

GLScene.OpenGL4

GL_DOUBLE_MAT4x2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4x3

GLScene.OpenGL4

GL_DOUBLE_MAT4x3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4_EXT

GLScene.OpenGL4

GL_DOUBLE_VEC2

GLScene.OpenGL4

GL_ARB_gpu_shader_fp64

GL_DOUBLE_VEC2_EXT

GLScene.OpenGL4

reuse GL_DOUBLE

GL_DOUBLE_VEC3

GLScene.OpenGL4

GL_DOUBLE_VEC3_EXT

GLScene.OpenGL4

GL_DOUBLE_VEC4

GLScene.OpenGL4

GL_DOUBLE_VEC4_EXT

GLScene.OpenGL4

GL_DRAW_BUFFER

GLScene.OpenGL4

GL_DRAW_BUFFER0

GLScene.OpenGL4

GL_DRAW_BUFFER0_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER0_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER1

GLScene.OpenGL4

GL_DRAW_BUFFER10

GLScene.OpenGL4

GL_DRAW_BUFFER10_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER10_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER11

GLScene.OpenGL4

GL_DRAW_BUFFER11_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER11_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER12

GLScene.OpenGL4

GL_DRAW_BUFFER12_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER12_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER13

GLScene.OpenGL4

GL_DRAW_BUFFER13_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER13_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER14

GLScene.OpenGL4

GL_DRAW_BUFFER14_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER14_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER15

GLScene.OpenGL4

GL_DRAW_BUFFER15_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER15_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER1_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER1_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER2

GLScene.OpenGL4

GL_DRAW_BUFFER2_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER2_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER3

GLScene.OpenGL4

GL_DRAW_BUFFER3_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER3_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER4

GLScene.OpenGL4

GL_DRAW_BUFFER4_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER4_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER5

GLScene.OpenGL4

GL_DRAW_BUFFER5_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER5_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER6

GLScene.OpenGL4

GL_DRAW_BUFFER6_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER6_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER7

GLScene.OpenGL4

GL_DRAW_BUFFER7_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER7_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER8

GLScene.OpenGL4

GL_DRAW_BUFFER8_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER8_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER9

GLScene.OpenGL4

GL_DRAW_BUFFER9_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER9_ATI

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_DRAW_INDIRECT_ADDRESS_NV

GLScene.OpenGL4

GL_DRAW_INDIRECT_BUFFER

GLScene.OpenGL4

GL_ARB_draw_indirect

GL_DRAW_INDIRECT_BUFFER_BINDING

GLScene.OpenGL4

GL_DRAW_INDIRECT_LENGTH_NV

GLScene.OpenGL4

GL_DRAW_INDIRECT_UNIFIED_NV

GLScene.OpenGL4

GL_DRAW_PIXELS_APPLE

GLScene.OpenGL4

GL_APPLE_fence

GL_DRAW_PIXEL_TOKEN

GLScene.OpenGL4

GL_DSDT8_MAG8_INTENSITY8_NV

GLScene.OpenGL4

GL_DSDT8_MAG8_NV

GLScene.OpenGL4

GL_DSDT8_NV

GLScene.OpenGL4

GL_DSDT_MAG_INTENSITY_NV

GLScene.OpenGL4

GL_DSDT_MAG_NV

GLScene.OpenGL4

GL_DSDT_MAG_VIB_NV

GLScene.OpenGL4

GL_DSDT_NV

GLScene.OpenGL4

GL_DST_ALPHA

GLScene.OpenGL4

GL_DST_COLOR

GLScene.OpenGL4

BlendingFactorSrc

GL_DS_BIAS_NV

GLScene.OpenGL4

GL_DS_SCALE_NV

GLScene.OpenGL4

GL_DT_BIAS_NV

GLScene.OpenGL4

GL_DT_SCALE_NV

GLScene.OpenGL4

GL_DU8DV8_ATI

GLScene.OpenGL4

GL_DUAL_ALPHA12_SGIS

GLScene.OpenGL4

GL_DUAL_ALPHA16_SGIS

GLScene.OpenGL4

GL_DUAL_ALPHA4_SGIS

GLScene.OpenGL4

GL_SGIS_texture_select

GL_DUAL_ALPHA8_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY12_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY16_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY4_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY8_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE12_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE16_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE4_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE8_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE_ALPHA4_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE_ALPHA8_SGIS

GLScene.OpenGL4

GL_DUAL_TEXTURE_SELECT_SGIS

GLScene.OpenGL4

GL_DUDV_ATI

GLScene.OpenGL4

GL_DUP_FIRST_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_DUP_LAST_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_DYNAMIC_ATI

GLScene.OpenGL4

GL_DYNAMIC_COPY

GLScene.OpenGL4

GL_DYNAMIC_COPY_ARB

GLScene.OpenGL4

GL_DYNAMIC_DRAW

GLScene.OpenGL4

GL_DYNAMIC_DRAW_ARB

GLScene.OpenGL4

GL_DYNAMIC_READ

GLScene.OpenGL4

GL_DYNAMIC_READ_ARB

GLScene.OpenGL4

GL_DYNAMIC_STORAGE_BIT

GLScene.OpenGL4

GL_EDGEFLAG_BIT_PGI

GLScene.OpenGL4

GL_EDGE_FLAG

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_POINTER

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_STRIDE

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_EIGHTH_BIT_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_ELEMENT_ARRAY_APPLE

GLScene.OpenGL4

GL_APPLE_element_array

GL_ELEMENT_ARRAY_ATI

GLScene.OpenGL4

GL_ATI_element_array

GL_ELEMENT_ARRAY_BARRIER_BIT

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_ARB

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_ELEMENT_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_ELEMENT_ARRAY_POINTER_APPLE

GLScene.OpenGL4

GL_ELEMENT_ARRAY_POINTER_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_TYPE_APPLE

GLScene.OpenGL4

GL_ELEMENT_ARRAY_TYPE_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_UNIFIED_NV

GLScene.OpenGL4

GL_EMBOSS_CONSTANT_NV

GLScene.OpenGL4

GL_EMBOSS_LIGHT_NV

GLScene.OpenGL4

GL_NV_texgen_emboss

GL_EMBOSS_MAP_NV

GLScene.OpenGL4

GL_EMISSION

GLScene.OpenGL4

GL_ENABLE_BIT

GLScene.OpenGL4

GL_EQUAL

GLScene.OpenGL4

GL_EQUIV

GLScene.OpenGL4

GL_EVAL_2D_NV

GLScene.OpenGL4

GL_NV_evaluators

GL_EVAL_BIT

GLScene.OpenGL4

GL_EVAL_FRACTIONAL_TESSELLATION_NV

GLScene.OpenGL4

GL_EVAL_TRIANGULAR_2D_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB0_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB10_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB11_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB12_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB13_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB14_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB15_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB1_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB2_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB3_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB4_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB5_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB6_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB7_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB8_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB9_NV

GLScene.OpenGL4

GL_EXCLUSION_KHR

GLScene.OpenGL4

GL_EXP

GLScene.OpenGL4

GL_EXP2

GLScene.OpenGL4

GL_EXPAND_NEGATE_NV

GLScene.OpenGL4

GL_EXPAND_NORMAL_NV

GLScene.OpenGL4

GL_EXTENSIONS

GLScene.OpenGL4

GL_EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD

GLScene.OpenGL4

(4.3) GL_AMD_pinned_memory

GL_EYE_DISTANCE_TO_LINE_SGIS

GLScene.OpenGL4

GL_EYE_DISTANCE_TO_POINT_SGIS

GLScene.OpenGL4

GL_SGIS_point_line_texgen

GL_EYE_LINEAR

GLScene.OpenGL4

GL_EYE_LINE_SGIS

GLScene.OpenGL4

GL_EYE_PLANE

GLScene.OpenGL4

GL_EYE_PLANE_ABSOLUTE_NV

GLScene.OpenGL4

GL_EYE_POINT_SGIS

GLScene.OpenGL4

GL_EYE_RADIAL_NV

GLScene.OpenGL4

GL_E_TIMES_F_NV

GLScene.OpenGL4

GL_FACTOR_MAX_AMD

GLScene.OpenGL4

GL_FACTOR_MIN_AMD

GLScene.OpenGL4

GL_AMD_blend_minmax_factor

GL_FAILURE_NV

GLScene.OpenGL4

GL_FALSE

GLScene.OpenGL4

GL_FASTEST

GLScene.OpenGL4

GL_FEEDBACK

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_POINTER

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_SIZE

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_TYPE

GLScene.OpenGL4

GL_FENCE_APPLE

GLScene.OpenGL4

GL_FENCE_CONDITION_NV

GLScene.OpenGL4

GL_FENCE_STATUS_NV

GLScene.OpenGL4

GL_FIELDS_NV

GLScene.OpenGL4

GL_FIELD_LOWER_NV

GLScene.OpenGL4

GL_FIELD_UPPER_NV

GLScene.OpenGL4

GL_FILE_NAME_NV

GLScene.OpenGL4

GL_FILL

GLScene.OpenGL4

GL_FILTER

GLScene.OpenGL4

GL_FILTER4_SGIS

GLScene.OpenGL4

GL_SGIS_texture_filter4

GL_FIRST_TO_REST_NV

GLScene.OpenGL4

GL_FIRST_VERTEX_CONVENTION

GLScene.OpenGL4

GL_FIRST_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_FIXED

GLScene.OpenGL4

GL_ARB_ES2_compatibility

GL_FIXED_ONLY

GLScene.OpenGL4

GL_FIXED_ONLY_ARB

GLScene.OpenGL4

GL_FLAT

GLScene.OpenGL4

GL_FLOAT

GLScene.OpenGL4

GL_FLOAT16_NV

GLScene.OpenGL4

GL_FLOAT16_VEC2_NV

GLScene.OpenGL4

GL_FLOAT16_VEC3_NV

GLScene.OpenGL4

GL_FLOAT16_VEC4_NV

GLScene.OpenGL4

GL_FLOAT_32_UNSIGNED_INT_24_8_REV

GLScene.OpenGL4

GL_FLOAT_32_UNSIGNED_INT_24_8_REV_NV

GLScene.OpenGL4

GL_NV_depth_buffer_float

GL_FLOAT_CLEAR_COLOR_VALUE_NV

GLScene.OpenGL4

GL_FLOAT_MAT2

GLScene.OpenGL4

GL_FLOAT_MAT2x3

GLScene.OpenGL4

GL_FLOAT_MAT2x4

GLScene.OpenGL4

GL_FLOAT_MAT2_ARB

GLScene.OpenGL4

GL_FLOAT_MAT3

GLScene.OpenGL4

GL_FLOAT_MAT3x2

GLScene.OpenGL4

GL_FLOAT_MAT3x4

GLScene.OpenGL4

GL_FLOAT_MAT3_ARB

GLScene.OpenGL4

GL_FLOAT_MAT4

GLScene.OpenGL4

GL_FLOAT_MAT4x2

GLScene.OpenGL4

GL_FLOAT_MAT4x3

GLScene.OpenGL4

GL_FLOAT_MAT4_ARB

GLScene.OpenGL4

GL_FLOAT_R16_NV

GLScene.OpenGL4

GL_FLOAT_R32_NV

GLScene.OpenGL4

GL_FLOAT_RG16_NV

GLScene.OpenGL4

GL_FLOAT_RG32_NV

GLScene.OpenGL4

GL_FLOAT_RGB16_NV

GLScene.OpenGL4

GL_FLOAT_RGB32_NV

GLScene.OpenGL4

GL_FLOAT_RGBA16_NV

GLScene.OpenGL4

GL_FLOAT_RGBA32_NV

GLScene.OpenGL4

GL_FLOAT_RGBA_MODE_NV

GLScene.OpenGL4

GL_FLOAT_RGBA_NV

GLScene.OpenGL4

GL_FLOAT_RGB_NV

GLScene.OpenGL4

GL_FLOAT_RG_NV

GLScene.OpenGL4

GL_FLOAT_R_NV

GLScene.OpenGL4

GL_NV_float_buffer

GL_FLOAT_VEC2

GLScene.OpenGL4

GL_FLOAT_VEC2_ARB

GLScene.OpenGL4

GL_FLOAT_VEC3

GLScene.OpenGL4

GL_FLOAT_VEC3_ARB

GLScene.OpenGL4

GL_FLOAT_VEC4

GLScene.OpenGL4

GL_FLOAT_VEC4_ARB

GLScene.OpenGL4

GL_FOG

GLScene.OpenGL4

GL_FOG_BIT

GLScene.OpenGL4

GL_FOG_COLOR

GLScene.OpenGL4

GL_FOG_COORD

GLScene.OpenGL4

GL_FOG_COORDINATE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_POINTER

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_STRIDE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_TYPE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_SOURCE

GLScene.OpenGL4

GL_FOG_COORDINATE_SOURCE_EXT

GLScene.OpenGL4

GL_EXT_fog_coord

GL_FOG_COORD_ARRAY

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_POINTER

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_STRIDE

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_TYPE

GLScene.OpenGL4

GL_FOG_COORD_SRC

GLScene.OpenGL4

GL_FOG_DENSITY

GLScene.OpenGL4

GL_FOG_DISTANCE_MODE_NV

GLScene.OpenGL4

GL_NV_fog_distance

GL_FOG_END

GLScene.OpenGL4

GL_FOG_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_FOG_FUNC_SGIS

GLScene.OpenGL4

GL_SGIS_fog_function

GL_FOG_HINT

GLScene.OpenGL4

GL_FOG_INDEX

GLScene.OpenGL4

GL_FOG_MODE

GLScene.OpenGL4

GL_FOG_OFFSET_SGIX

GLScene.OpenGL4

GL_SGIX_fog_offset

GL_FOG_OFFSET_VALUE_SGIX

GLScene.OpenGL4

GL_FOG_SCALE_SGIX

GLScene.OpenGL4

GL_SGIX_fog_scale

GL_FOG_SCALE_VALUE_SGIX

GLScene.OpenGL4

GL_FOG_SPECULAR_TEXTURE_WIN

GLScene.OpenGL4

GL_WIN_specular_fog

GL_FOG_START

GLScene.OpenGL4

GL_FONT_ASCENDER_NV

GLScene.OpenGL4

GL_FONT_DESCENDER_NV

GLScene.OpenGL4

GL_FONT_HAS_KERNING_NV

GLScene.OpenGL4

GL_FONT_HEIGHT_NV

GLScene.OpenGL4

GL_FONT_MAX_ADVANCE_HEIGHT_NV

GLScene.OpenGL4

GL_FONT_MAX_ADVANCE_WIDTH_NV

GLScene.OpenGL4

GL_FONT_UNDERLINE_POSITION_NV

GLScene.OpenGL4

GL_FONT_UNDERLINE_THICKNESS_NV

GLScene.OpenGL4

GL_FONT_UNITS_PER_EM_NV

GLScene.OpenGL4

GL_FONT_X_MAX_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_X_MIN_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_Y_MAX_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_Y_MIN_BOUNDS_NV

GLScene.OpenGL4

GL_FORCE_BLUE_TO_ONE_NV

GLScene.OpenGL4

GL_FORMAT_SUBSAMPLE_244_244_OML

GLScene.OpenGL4

GL_FORMAT_SUBSAMPLE_24_24_OML

GLScene.OpenGL4

GL_OML_subsample

GL_FRACTIONAL_EVEN

GLScene.OpenGL4

GL_FRACTIONAL_ODD

GLScene.OpenGL4

GL_FRAGMENT_COLOR_EXT

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_FACE_SGIX

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_PARAMETER_SGIX

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_SGIX

GLScene.OpenGL4

GL_FRAGMENT_DEPTH

GLScene.OpenGL4

GL_FRAGMENT_DEPTH_EXT

GLScene.OpenGL4

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS

GLScene.OpenGL4

GL_FRAGMENT_LIGHT0_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT1_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT2_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT3_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT4_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT5_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT6_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT7_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHTING_SGIX

GLScene.OpenGL4

GL_SGIX_fragment_lighting

GL_FRAGMENT_LIGHT_MODEL_AMBIENT_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_LOCAL_VIEWER_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_NORMAL_INTERPOLATION_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_TWO_SIDE_SGIX

GLScene.OpenGL4

GL_FRAGMENT_MATERIAL_EXT

GLScene.OpenGL4

GL_EXT_light_texture

GL_FRAGMENT_NORMAL_EXT

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_ARB

GLScene.OpenGL4

GL_ARB_fragment_program

GL_FRAGMENT_PROGRAM_BINDING_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_INTERPOLATION_OFFSET_BITS_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_FRAGMENT_SHADER

GLScene.OpenGL4

GL_FRAGMENT_SHADER_ARB

GLScene.OpenGL4

GL_ARB_fragment_shader

GL_FRAGMENT_SHADER_ATI

GLScene.OpenGL4

GL_ATI_fragment_shader

GL_FRAGMENT_SHADER_BIT

GLScene.OpenGL4

GL_FRAGMENT_SHADER_DERIVATIVE_HINT

GLScene.OpenGL4

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB

GLScene.OpenGL4

1.4

GL_FRAGMENT_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_FRAGMENT_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_FRAGMENT_SUBROUTINE

GLScene.OpenGL4

GL_FRAGMENT_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_FRAGMENT_TEXTURE

GLScene.OpenGL4

GL_FRAMEBUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_BASE_VIEW_INDEX_OVR

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_NUM_VIEWS_OVR

GLScene.OpenGL4

GL_OVR_multiview

GL_FRAMEBUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_FRAMEBUFFER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_BLEND

GLScene.OpenGL4

GL_FRAMEBUFFER_COMPLETE

GLScene.OpenGL4

GL_FRAMEBUFFER_COMPLETE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_FIXED_SAMPLE_LOCATIONS

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_HEIGHT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_LAYERS

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_SAMPLES

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_WIDTH

GLScene.OpenGL4

GL_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_object

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT

GLScene.OpenGLTokens

Vendor/EXT extensions constants, in extension number order

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_VIEW_TARGETS_OVR

GLScene.OpenGL4

GL_FRAMEBUFFER_PROGRAMMABLE_SAMPLE_LOCATIONS_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_RENDERABLE

GLScene.OpenGL4

GL_FRAMEBUFFER_RENDERABLE_LAYERED

GLScene.OpenGL4

GL_FRAMEBUFFER_SAMPLE_LOCATION_PIXEL_GRID_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_SRGB

GLScene.OpenGL4

GL_ARB_framebuffer_sRGB

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_SRGB_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_STATUS_ERROR_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_UNDEFINED

GLScene.OpenGL4

GL_FRAMEBUFFER_UNSUPPORTED

GLScene.OpenGL4

GL_FRAMEBUFFER_UNSUPPORTED_EXT

GLScene.OpenGL4

GL_FRAMEZOOM_FACTOR_SGIX

GLScene.OpenGL4

GL_FRAMEZOOM_SGIX

GLScene.OpenGL4

GL_SGIX_framezoom

GL_FRAME_NV

GLScene.OpenGL4

GL_NV_present_video

GL_FRONT

GLScene.OpenGL4

GL_FRONT_AND_BACK

GLScene.OpenGL4

GL_FRONT_FACE

GLScene.OpenGL4

GL_FRONT_LEFT

GLScene.OpenGL4

GL_FRONT_RIGHT

GLScene.OpenGL4

GL_FULL_RANGE_EXT

GLScene.OpenGL4

GL_FULL_STIPPLE_HINT_PGI

GLScene.OpenGL4

GL_FULL_SUPPORT

GLScene.OpenGL4

GL_FUNC_ADD

GLScene.OpenGL4

GL_FUNC_ADD_EXT

GLScene.OpenGL4

GL_EXT_blend_minmax

GL_FUNC_REVERSE_SUBTRACT

GLScene.OpenGL4

GL_FUNC_REVERSE_SUBTRACT_EXT

GLScene.OpenGL4

GL_FUNC_SUBTRACT

GLScene.OpenGL4

GL_FUNC_SUBTRACT_EXT

GLScene.OpenGL4

GL_EXT_blend_subtract

GL_GENERATE_MIPMAP

GLScene.OpenGL4

GL_GENERATE_MIPMAP_HINT

GLScene.OpenGL4

GL_GENERATE_MIPMAP_HINT_SGIS

GLScene.OpenGL4

GL_GENERATE_MIPMAP_SGIS

GLScene.OpenGL4

GL_SGIS_generate_mipmap

GL_GENERIC_ATTRIB_NV

GLScene.OpenGL4

GL_GEOMETRY_DEFORMATION_BIT_SGIX

GLScene.OpenGL4

GL_GEOMETRY_DEFORMATION_SGIX

GLScene.OpenGL4

GL_SGIX_polynomial_ffd

GL_GEOMETRY_INPUT_TYPE

GLScene.OpenGL4

GL_GEOMETRY_INPUT_TYPE_ARB

GLScene.OpenGL4

GL_GEOMETRY_INPUT_TYPE_EXT

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE_ARB

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE_EXT

GLScene.OpenGL4

GL_GEOMETRY_PROGRAM_NV

GLScene.OpenGL4

GL_NV_geometry_program4

GL_GEOMETRY_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_GEOMETRY_SHADER

GLScene.OpenGL4

GL_GEOMETRY_SHADER_ARB

GLScene.OpenGL4

GL_GEOMETRY_SHADER_BIT

GLScene.OpenGL4

GL_GEOMETRY_SHADER_EXT

GLScene.OpenGL4

GL_EXT_geometry_shader4

GL_GEOMETRY_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_ARB_gpu_shader5

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED

GLScene.OpenGL4

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED_ARB

GLScene.OpenGL4

GL_GEOMETRY_SUBROUTINE

GLScene.OpenGL4

GL_GEOMETRY_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_GEOMETRY_TEXTURE

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT_ARB

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT_EXT

GLScene.OpenGL4

GL_GEQUAL

GLScene.OpenGL4

GL_GET_TEXTURE_IMAGE_FORMAT

GLScene.OpenGL4

GL_GET_TEXTURE_IMAGE_TYPE

GLScene.OpenGL4

GL_GLOBAL_ALPHA_FACTOR_SUN

GLScene.OpenGL4

GL_GLOBAL_ALPHA_SUN

GLScene.OpenGL4

GL_SUN_global_alpha

GL_GLYPH_HAS_KERNING_NV

GLScene.OpenGL4

GL_GLYPH_HEIGHT_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV

GLScene.OpenGL4

GL_GLYPH_WIDTH_BIT_NV

GLScene.OpenGL4

GL_GPU_ADDRESS_NV

GLScene.OpenGL4

GL_GREATER

GLScene.OpenGL4

GL_GREEN

GLScene.OpenGL4

GL_GREEN_BIAS

GLScene.OpenGL4

GL_GREEN_BITS

GLScene.OpenGL4

GL_GREEN_BIT_ATI

GLScene.OpenGL4

GL_GREEN_INTEGER

GLScene.OpenGL4

GL_GREEN_INTEGER_EXT

GLScene.OpenGL4

GL_GREEN_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_GREEN_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_GREEN_SCALE

GLScene.OpenGL4

GL_GUILTY_CONTEXT_RESET

GLScene.OpenGL4

GL_GUILTY_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_HALF_APPLE

GLScene.OpenGL4

GL_APPLE_float_pixels

GL_HALF_BIAS_NEGATE_NV

GLScene.OpenGL4

GL_HALF_BIAS_NORMAL_NV

GLScene.OpenGL4

GL_HALF_BIT_ATI

GLScene.OpenGL4

GL_HALF_FLOAT

GLScene.OpenGL4

GL_ARB_half_float_vertex

GL_HALF_FLOAT_ARB

GLScene.OpenGL4

GL_ARB_half_float_pixel

GL_HALF_FLOAT_NV

GLScene.OpenGL4

GL_NV_half_float

GL_HARDLIGHT_KHR

GLScene.OpenGL4

GL_HIGH_FLOAT

GLScene.OpenGL4

GL_HIGH_INT

GLScene.OpenGL4

GL_HILO16_NV

GLScene.OpenGL4

GL_HILO8_NV

GLScene.OpenGL4

GL_HILO_NV

GLScene.OpenGL4

GL_HINT_BIT

GLScene.OpenGL4

GL_HISTOGRAM

GLScene.OpenGL4

GL_HISTOGRAM_ALPHA_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_BLUE_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_EXT

GLScene.OpenGL4

GL_EXT_histogram

GL_HISTOGRAM_FORMAT

GLScene.OpenGL4

GL_HISTOGRAM_FORMAT_EXT

GLScene.OpenGL4

GL_HISTOGRAM_GREEN_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_LUMINANCE_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_RED_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_RED_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_SINK

GLScene.OpenGL4

GL_HISTOGRAM_SINK_EXT

GLScene.OpenGL4

GL_HISTOGRAM_WIDTH

GLScene.OpenGL4

GL_HISTOGRAM_WIDTH_EXT

GLScene.OpenGL4

GL_HI_BIAS_NV

GLScene.OpenGL4

GL_HI_SCALE_NV

GLScene.OpenGL4

GL_HORIZONTAL_LINE_TO_NV

GLScene.OpenGL4

GL_HSL_COLOR_KHR

GLScene.OpenGL4

GL_HSL_HUE_KHR

GLScene.OpenGL4

GL_HSL_LUMINOSITY_KHR

GLScene.OpenGL4

GL_HSL_SATURATION_KHR

GLScene.OpenGL4

GL_IDENTITY_NV

GLScene.OpenGL4

GL_IGNORE_BORDER_HP

GLScene.OpenGL4

GL_HP_convolution_border_modes

GL_IMAGE_1D

GLScene.OpenGL4

GL_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_1D_EXT

GLScene.OpenGL4

GL_IMAGE_2D

GLScene.OpenGL4

GL_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_2D_EXT

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_IMAGE_2D_RECT

GLScene.OpenGL4

GL_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_IMAGE_3D

GLScene.OpenGL4

GL_IMAGE_3D_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_ACCESS

GLScene.OpenGL4

GL_IMAGE_BINDING_ACCESS_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_FORMAT

GLScene.OpenGL4

GL_IMAGE_BINDING_FORMAT_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYER

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYERED

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYERED_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYER_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LEVEL

GLScene.OpenGL4

GL_IMAGE_BINDING_LEVEL_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_NAME

GLScene.OpenGL4

GL_IMAGE_BINDING_NAME_EXT

GLScene.OpenGL4

GL_IMAGE_BUFFER

GLScene.OpenGL4

GL_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_IMAGE_CLASS_10_10_10_2

GLScene.OpenGL4

GL_IMAGE_CLASS_11_11_10

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_8

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_8

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_8

GLScene.OpenGL4

GL_IMAGE_COMPATIBILITY_CLASS

GLScene.OpenGL4

GL_IMAGE_CUBE

GLScene.OpenGL4

GL_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_CUBIC_WEIGHT_HP

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_BY_CLASS

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_BY_SIZE

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_TYPE

GLScene.OpenGL4

GL_IMAGE_MAG_FILTER_HP

GLScene.OpenGL4

GL_IMAGE_MIN_FILTER_HP

GLScene.OpenGL4

GL_IMAGE_PIXEL_FORMAT

GLScene.OpenGL4

GL_IMAGE_PIXEL_TYPE

GLScene.OpenGL4

GL_IMAGE_ROTATE_ANGLE_HP

GLScene.OpenGL4

GL_IMAGE_ROTATE_ORIGIN_X_HP

GLScene.OpenGL4

GL_IMAGE_ROTATE_ORIGIN_Y_HP

GLScene.OpenGL4

GL_IMAGE_SCALE_X_HP

GLScene.OpenGL4

GL_HP_image_transform

GL_IMAGE_SCALE_Y_HP

GLScene.OpenGL4

GL_IMAGE_TEXEL_SIZE

GLScene.OpenGL4

GL_IMAGE_TRANSFORM_2D_HP

GLScene.OpenGL4

GL_IMAGE_TRANSLATE_X_HP

GLScene.OpenGL4

GL_IMAGE_TRANSLATE_Y_HP

GLScene.OpenGL4

GL_IMPLEMENTATION_COLOR_READ_FORMAT

GLScene.OpenGL4

GL_IMPLEMENTATION_COLOR_READ_TYPE

GLScene.OpenGL4

GL_INCR

GLScene.OpenGL4

GL_INCR_WRAP

GLScene.OpenGL4

GL_INCR_WRAP_EXT

GLScene.OpenGL4

GL_EXT_stencil_wrap

GL_INDEX

GLScene.OpenGL4

GL_INDEX_ARRAY

GLScene.OpenGL4

GL_INDEX_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_INDEX_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_INDEX_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_INDEX_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_INDEX_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_INDEX_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_INDEX_ARRAY_POINTER

GLScene.OpenGL4

GL_INDEX_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_STRIDE

GLScene.OpenGL4

GL_INDEX_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_TYPE

GLScene.OpenGL4

GL_INDEX_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_INDEX_BITS

GLScene.OpenGL4

GL_INDEX_BIT_PGI

GLScene.OpenGL4

GL_INDEX_CLEAR_VALUE

GLScene.OpenGL4

GL_INDEX_LOGIC_OP

GLScene.OpenGL4

GL_INDEX_MATERIAL_EXT

GLScene.OpenGL4

GL_EXT_index_material

GL_INDEX_MATERIAL_FACE_EXT

GLScene.OpenGL4

GL_INDEX_MATERIAL_PARAMETER_EXT

GLScene.OpenGL4

GL_INDEX_MODE

GLScene.OpenGL4

GL_INDEX_OFFSET

GLScene.OpenGL4

GL_INDEX_SHIFT

GLScene.OpenGL4

GL_INDEX_TEST_EXT

GLScene.OpenGL4

GL_EXT_index_func

GL_INDEX_TEST_FUNC_EXT

GLScene.OpenGL4

GL_INDEX_TEST_REF_EXT

GLScene.OpenGL4

GL_INDEX_WRITEMASK

GLScene.OpenGL4

GL_INFO_LOG_LENGTH

GLScene.OpenGL4

GL_INNOCENT_CONTEXT_RESET

GLScene.OpenGL4

GL_INNOCENT_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_INSTRUMENT_BUFFER_POINTER_SGIX

GLScene.OpenGL4

GL_SGIX_instruments

GL_INSTRUMENT_MEASUREMENTS_SGIX

GLScene.OpenGL4

GL_INT

GLScene.OpenGL4

GL_INT16_NV

GLScene.OpenGL4

GL_INT16_VEC2_NV

GLScene.OpenGL4

GL_INT16_VEC3_NV

GLScene.OpenGL4

GL_INT16_VEC4_NV

GLScene.OpenGL4

GL_INT64_ARB

GLScene.OpenGL4

GL_ARB_gpu_shader_int64

GL_INT64_NV

GLScene.OpenGL4

GL_NV_gpu_shader5

GL_INT64_VEC2_ARB

GLScene.OpenGL4

GL_INT64_VEC2_NV

GLScene.OpenGL4

GL_INT64_VEC3_ARB

GLScene.OpenGL4

GL_INT64_VEC3_NV

GLScene.OpenGL4

GL_INT64_VEC4_ARB

GLScene.OpenGL4

GL_INT64_VEC4_NV

GLScene.OpenGL4

GL_INT8_NV

GLScene.OpenGL4

GL_INT8_VEC2_NV

GLScene.OpenGL4

GL_INT8_VEC3_NV

GLScene.OpenGL4

GL_INT8_VEC4_NV

GLScene.OpenGL4

GL_INTENSITY

GLScene.OpenGL4

GL_INTENSITY12

GLScene.OpenGL4

GL_INTENSITY12_EXT

GLScene.OpenGL4

GL_INTENSITY16

GLScene.OpenGL4

GL_INTENSITY16F_ARB

GLScene.OpenGL4

GL_INTENSITY16I_EXT

GLScene.OpenGL4

GL_INTENSITY16UI_EXT

GLScene.OpenGL4

GL_INTENSITY16_EXT

GLScene.OpenGL4

GL_INTENSITY16_SNORM

GLScene.OpenGL4

GL_INTENSITY32F_ARB

GLScene.OpenGL4

GL_INTENSITY32I_EXT

GLScene.OpenGL4

GL_INTENSITY32UI_EXT

GLScene.OpenGL4

GL_INTENSITY4

GLScene.OpenGL4

GL_INTENSITY4_EXT

GLScene.OpenGL4

GL_INTENSITY8

GLScene.OpenGL4

GL_INTENSITY8I_EXT

GLScene.OpenGL4

GL_INTENSITY8UI_EXT

GLScene.OpenGL4

GL_INTENSITY8_EXT

GLScene.OpenGL4

GL_INTENSITY8_SNORM

GLScene.OpenGL4

GL_INTENSITY_EXT

GLScene.OpenGL4

GL_INTENSITY_FLOAT16_APPLE

GLScene.OpenGL4

GL_INTENSITY_FLOAT16_ATI

GLScene.OpenGL4

GL_INTENSITY_FLOAT32_APPLE

GLScene.OpenGL4

GL_INTENSITY_FLOAT32_ATI

GLScene.OpenGL4

GL_INTENSITY_SNORM

GLScene.OpenGL4

GL_INTERLACE_OML

GLScene.OpenGL4

GL_OML_interlace

GL_INTERLACE_READ_INGR

GLScene.OpenGL4

GL_INGR_interlace_read

GL_INTERLACE_READ_OML

GLScene.OpenGL4

GL_INTERLACE_SGIX

GLScene.OpenGL4

GL_SGIX_interlace

GL_INTERLEAVED_ATTRIBS

GLScene.OpenGL4

GL_INTERLEAVED_ATTRIBS_EXT

GLScene.OpenGL4

GL_INTERLEAVED_ATTRIBS_NV

GLScene.OpenGL4

GL_INTERNALFORMAT_ALPHA_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_ALPHA_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_BLUE_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_BLUE_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_DEPTH_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_DEPTH_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_GREEN_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_GREEN_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_PREFERRED

GLScene.OpenGL4

GL_INTERNALFORMAT_RED_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_RED_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_SHARED_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_STENCIL_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_STENCIL_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_SUPPORTED

GLScene.OpenGL4

GL_INTERPOLATE

GLScene.OpenGL4

GL_INTERPOLATE_ARB

GLScene.OpenGL4

GL_INTERPOLATE_EXT

GLScene.OpenGL4

GL_INT_2_10_10_10_REV

GLScene.OpenGL4

reuse GL_UNSIGNED_INT_2_10_10_10_REV

GL_INT_IMAGE_1D

GLScene.OpenGL4

GL_INT_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_1D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D

GLScene.OpenGL4

GL_INT_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_RECT

GLScene.OpenGL4

GL_INT_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_INT_IMAGE_3D

GLScene.OpenGL4

GL_INT_IMAGE_3D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_BUFFER

GLScene.OpenGL4

GL_INT_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_INT_IMAGE_CUBE

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_1D

GLScene.OpenGL4

GL_INT_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_1D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D

GLScene.OpenGL4

GL_INT_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_RECT_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_3D

GLScene.OpenGL4

GL_INT_SAMPLER_3D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_INT_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_INT_VEC2

GLScene.OpenGL4

GL_INT_VEC2_ARB

GLScene.OpenGL4

GL_INT_VEC3

GLScene.OpenGL4

GL_INT_VEC3_ARB

GLScene.OpenGL4

GL_INT_VEC4

GLScene.OpenGL4

GL_INT_VEC4_ARB

GLScene.OpenGL4

GL_INVALID_ENUM

GLScene.OpenGL4

GL_INVALID_FRAMEBUFFER_OPERATION

GLScene.OpenGL4

GL_ARB_framebuffer_object

GL_INVALID_FRAMEBUFFER_OPERATION_EXT

GLScene.OpenGL4

GL_INVALID_INDEX

GLScene.OpenGL4

GL_INVALID_OPERATION

GLScene.OpenGL4

GL_INVALID_VALUE

GLScene.OpenGL4

GL_INVARIANT_DATATYPE_EXT

GLScene.OpenGL4

GL_INVARIANT_EXT

GLScene.OpenGL4

GL_INVARIANT_VALUE_EXT

GLScene.OpenGL4

GL_INVERSE_NV

GLScene.OpenGL4

GL_INVERSE_TRANSPOSE_NV

GLScene.OpenGL4

GL_INVERT

GLScene.OpenGL4

GL_INVERTED_SCREEN_W_REND

GLScene.OpenGL4

GL_IR_INSTRUMENT1_SGIX

GLScene.OpenGL4

GL_SGIX_ir_instrument1

GL_ISOLINES

GLScene.OpenGL4

GL_IS_PER_PATCH

GLScene.OpenGL4

GL_IS_ROW_MAJOR

GLScene.OpenGL4

GL_ITALIC_BIT_NV

GLScene.OpenGL4

GL_IUI_N3F_V2F_EXT

GLScene.OpenGL4

GL_IUI_N3F_V3F_EXT

GLScene.OpenGL4

GL_IUI_V2F_EXT

GLScene.OpenGL4

GL_EXT_index_array_formats

GL_IUI_V3F_EXT

GLScene.OpenGL4

GL_KEEP

GLScene.OpenGL4

StencilOp

GL_LARGE_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_LARGE_CW_ARC_TO_NV

GLScene.OpenGL4

GL_LAST_VERTEX_CONVENTION

GLScene.OpenGL4

GL_LAST_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_LAST_VIDEO_CAPTURE_STATUS_NV

GLScene.OpenGL4

GL_LAYER_NV

GLScene.OpenGL4

GL_LAYER_PROVOKING_VERTEX

GLScene.OpenGL4

GL_LEFT

GLScene.OpenGL4

GL_LEQUAL

GLScene.OpenGL4

GL_LERP_ATI

GLScene.OpenGL4

GL_LESS

GLScene.OpenGL4

GL_LIGHT0

GLScene.OpenGL4

GL_LIGHT1

GLScene.OpenGL4

GL_LIGHT2

GLScene.OpenGL4

GL_LIGHT3

GLScene.OpenGL4

GL_LIGHT4

GLScene.OpenGL4

GL_LIGHT5

GLScene.OpenGL4

GL_LIGHT6

GLScene.OpenGL4

GL_LIGHT7

GLScene.OpenGL4

GL_LIGHTEN_KHR

GLScene.OpenGL4

GL_LIGHTING

GLScene.OpenGL4

GL_LIGHTING_BIT

GLScene.OpenGL4

GL_LIGHT_ENV_MODE_SGIX

GLScene.OpenGL4

GL_LIGHT_MODEL_AMBIENT

GLScene.OpenGL4

GL_LIGHT_MODEL_COLOR_CONTROL

GLScene.OpenGL4

GL_LIGHT_MODEL_COLOR_CONTROL_EXT

GLScene.OpenGL4

GL_EXT_separate_specular_color

GL_LIGHT_MODEL_LOCAL_VIEWER

GLScene.OpenGL4

GL_LIGHT_MODEL_SPECULAR_VECTOR_APPLE

GLScene.OpenGL4

GL_APPLE_specular_vector

GL_LIGHT_MODEL_TWO_SIDE

GLScene.OpenGL4

GL_LINE

GLScene.OpenGL4

GL_LINEAR

GLScene.OpenGL4

GL_LINEAR_ATTENUATION

GLScene.OpenGL4

GL_LINEAR_CLIPMAP_LINEAR_SGIX

GLScene.OpenGL4

GL_SGIX_clipmap

GL_LINEAR_CLIPMAP_NEAREST_SGIX

GLScene.OpenGL4

GL_LINEAR_DETAIL_ALPHA_SGIS

GLScene.OpenGL4

GL_LINEAR_DETAIL_COLOR_SGIS

GLScene.OpenGL4

GL_LINEAR_DETAIL_SGIS

GLScene.OpenGL4

GL_LINEAR_MIPMAP_LINEAR

GLScene.OpenGL4

GL_LINEAR_MIPMAP_NEAREST

GLScene.OpenGL4

GL_LINEAR_SHARPEN_ALPHA_SGIS

GLScene.OpenGL4

GL_LINEAR_SHARPEN_COLOR_SGIS

GLScene.OpenGL4

GL_LINEAR_SHARPEN_SGIS

GLScene.OpenGL4

GL_SGIS_sharpen_texture

GL_LINES

GLScene.OpenGL4

GL_LINES_ADJACENCY

GLScene.OpenGL4

GL_LINES_ADJACENCY_ARB

GLScene.OpenGL4

GL_ARB_geometry_shader4

GL_LINES_ADJACENCY_EXT

GLScene.OpenGL4

GL_LINE_BIT

GLScene.OpenGL4

GL_LINE_LOOP

GLScene.OpenGL4

GL_LINE_RESET_TOKEN

GLScene.OpenGL4

GL_LINE_SMOOTH

GLScene.OpenGL4

GL_LINE_SMOOTH_HINT

GLScene.OpenGL4

GL_LINE_STIPPLE

GLScene.OpenGL4

GL_LINE_STIPPLE_PATTERN

GLScene.OpenGL4

GL_LINE_STIPPLE_REPEAT

GLScene.OpenGL4

GL_LINE_STRIP

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY_ARB

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY_EXT

GLScene.OpenGL4

GL_LINE_TOKEN

GLScene.OpenGL4

GL_LINE_TO_NV

GLScene.OpenGL4

GL_LINE_WIDTH

GLScene.OpenGL4

GL_LINE_WIDTH_GRANULARITY

GLScene.OpenGL4

GL_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_LINK_STATUS

GLScene.OpenGL4

GL_LIST_BASE

GLScene.OpenGL4

GL_LIST_BIT

GLScene.OpenGL4

GL_LIST_INDEX

GLScene.OpenGL4

GL_LIST_MODE

GLScene.OpenGL4

GL_LIST_PRIORITY_SGIX

GLScene.OpenGL4

GL_SGIX_list_priority

GL_LOAD

GLScene.OpenGL4

GL_LOCAL_CONSTANT_DATATYPE_EXT

GLScene.OpenGL4

GL_LOCAL_CONSTANT_EXT

GLScene.OpenGL4

GL_LOCAL_CONSTANT_VALUE_EXT

GLScene.OpenGL4

GL_LOCAL_EXT

GLScene.OpenGL4

GL_LOCATION

GLScene.OpenGL4

GL_LOCATION_COMPONENT

GLScene.OpenGL4

GL_LOCATION_INDEX

GLScene.OpenGL4

GL_LOGIC_OP

GLScene.OpenGL4

GL_LOGIC_OP_MODE

GLScene.OpenGL4

GL_LOSE_CONTEXT_ON_RESET

GLScene.OpenGL4

GL_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

GL_LOWER_LEFT

GLScene.OpenGL4

GL_LOW_FLOAT

GLScene.OpenGL4

GL_LOW_INT

GLScene.OpenGL4

GL_LO_BIAS_NV

GLScene.OpenGL4

GL_LO_SCALE_NV

GLScene.OpenGL4

GL_LUMINANCE

GLScene.OpenGL4

GL_LUMINANCE12

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA12

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA12_EXT

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA4

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA4_EXT

GLScene.OpenGL4

GL_LUMINANCE12_EXT

GLScene.OpenGL4

GL_LUMINANCE16

GLScene.OpenGL4

GL_LUMINANCE16F_ARB

GLScene.OpenGL4

GL_LUMINANCE16I_EXT

GLScene.OpenGL4

GL_LUMINANCE16UI_EXT

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16_EXT

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16_SNORM

GLScene.OpenGL4

GL_LUMINANCE16_EXT

GLScene.OpenGL4

GL_LUMINANCE16_SNORM

GLScene.OpenGL4

GL_LUMINANCE32F_ARB

GLScene.OpenGL4

GL_LUMINANCE32I_EXT

GLScene.OpenGL4

GL_LUMINANCE32UI_EXT

GLScene.OpenGL4

GL_LUMINANCE4

GLScene.OpenGL4

GL_LUMINANCE4_ALPHA4

GLScene.OpenGL4

GL_LUMINANCE4_ALPHA4_EXT

GLScene.OpenGL4

GL_LUMINANCE4_EXT

GLScene.OpenGL4

GL_LUMINANCE6_ALPHA2

GLScene.OpenGL4

GL_LUMINANCE6_ALPHA2_EXT

GLScene.OpenGL4

GL_LUMINANCE8

GLScene.OpenGL4

GL_LUMINANCE8I_EXT

GLScene.OpenGL4

GL_LUMINANCE8UI_EXT

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8_EXT

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8_SNORM

GLScene.OpenGL4

GL_LUMINANCE8_EXT

GLScene.OpenGL4

GL_LUMINANCE8_SNORM

GLScene.OpenGL4

GL_LUMINANCE_ALPHA

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16F_ARB

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32F_ARB

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA8I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA8UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT16_APPLE

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT16_ATI

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT32_APPLE

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT32_ATI

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_INTEGER_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_SNORM

GLScene.OpenGL4

GL_LUMINANCE_FLOAT16_APPLE

GLScene.OpenGL4

GL_LUMINANCE_FLOAT16_ATI

GLScene.OpenGL4

GL_LUMINANCE_FLOAT32_APPLE

GLScene.OpenGL4

GL_LUMINANCE_FLOAT32_ATI

GLScene.OpenGL4

GL_LUMINANCE_INTEGER_EXT

GLScene.OpenGL4

GL_LUMINANCE_SNORM

GLScene.OpenGL4

GL_MAD_ATI

GLScene.OpenGL4

GL_MAGNITUDE_BIAS_NV

GLScene.OpenGL4

GL_MAGNITUDE_SCALE_NV

GLScene.OpenGL4

GL_MAJOR_VERSION

GLScene.OpenGL4

GL_MANUAL_GENERATE_MIPMAP

GLScene.OpenGL4

GL_MAP1_BINORMAL_EXT

GLScene.OpenGL4

GL_MAP1_COLOR_4

GLScene.OpenGL4

GL_MAP1_GRID_DOMAIN

GLScene.OpenGL4

GL_MAP1_GRID_SEGMENTS

GLScene.OpenGL4

GL_MAP1_INDEX

GLScene.OpenGL4

GL_MAP1_NORMAL

GLScene.OpenGL4

GL_MAP1_TANGENT_EXT

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_1

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_2

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_3

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_4

GLScene.OpenGL4

GL_MAP1_VERTEX_3

GLScene.OpenGL4

GL_MAP1_VERTEX_4

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB0_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB10_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB11_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB12_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB13_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB14_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB15_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB1_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB2_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB3_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB4_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB5_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB6_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB7_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB8_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB9_4_NV

GLScene.OpenGL4

GL_MAP2_BINORMAL_EXT

GLScene.OpenGL4

GL_MAP2_COLOR_4

GLScene.OpenGL4

GL_MAP2_GRID_DOMAIN

GLScene.OpenGL4

GL_MAP2_GRID_SEGMENTS

GLScene.OpenGL4

GL_MAP2_INDEX

GLScene.OpenGL4

GL_MAP2_NORMAL

GLScene.OpenGL4

GL_MAP2_TANGENT_EXT

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_1

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_2

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_3

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_4

GLScene.OpenGL4

GL_MAP2_VERTEX_3

GLScene.OpenGL4

GL_MAP2_VERTEX_4

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB0_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB10_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB11_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB12_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB13_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB14_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB15_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB1_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB2_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB3_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB4_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB5_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB6_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB7_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB8_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB9_4_NV

GLScene.OpenGL4

GL_MAP_ATTRIB_U_ORDER_NV

GLScene.OpenGL4

GL_MAP_ATTRIB_V_ORDER_NV

GLScene.OpenGL4

GL_MAP_COHERENT_BIT

GLScene.OpenGL4

GL_MAP_COLOR

GLScene.OpenGL4

GL_MAP_FLUSH_EXPLICIT_BIT

GLScene.OpenGL4

GL_MAP_INVALIDATE_BUFFER_BIT

GLScene.OpenGL4

GL_MAP_INVALIDATE_RANGE_BIT

GLScene.OpenGL4

GL_MAP_PERSISTENT_BIT

GLScene.OpenGL4

GL_MAP_READ_BIT

GLScene.OpenGL4

GL_ARB_map_buffer_range

GL_MAP_STENCIL

GLScene.OpenGL4

GL_MAP_TESSELLATION_NV

GLScene.OpenGL4

GL_MAP_UNSYNCHRONIZED_BIT

GLScene.OpenGL4

GL_MAP_WRITE_BIT

GLScene.OpenGL4

GL_MATERIAL_SIDE_HINT_PGI

GLScene.OpenGL4

GL_MATRIX0_ARB

GLScene.OpenGL4

GL_MATRIX0_NV

GLScene.OpenGL4

GL_MATRIX10_ARB

GLScene.OpenGL4

GL_MATRIX11_ARB

GLScene.OpenGL4

GL_MATRIX12_ARB

GLScene.OpenGL4

GL_MATRIX13_ARB

GLScene.OpenGL4

GL_MATRIX14_ARB

GLScene.OpenGL4

GL_MATRIX15_ARB

GLScene.OpenGL4

GL_MATRIX16_ARB

GLScene.OpenGL4

GL_MATRIX17_ARB

GLScene.OpenGL4

GL_MATRIX18_ARB

GLScene.OpenGL4

GL_MATRIX19_ARB

GLScene.OpenGL4

GL_MATRIX1_ARB

GLScene.OpenGL4

GL_MATRIX1_NV

GLScene.OpenGL4

GL_MATRIX20_ARB

GLScene.OpenGL4

GL_MATRIX21_ARB

GLScene.OpenGL4

GL_MATRIX22_ARB

GLScene.OpenGL4

GL_MATRIX23_ARB

GLScene.OpenGL4

GL_MATRIX24_ARB

GLScene.OpenGL4

GL_MATRIX25_ARB

GLScene.OpenGL4

GL_MATRIX26_ARB

GLScene.OpenGL4

GL_MATRIX27_ARB

GLScene.OpenGL4

GL_MATRIX28_ARB

GLScene.OpenGL4

GL_MATRIX29_ARB

GLScene.OpenGL4

GL_MATRIX2_ARB

GLScene.OpenGL4

GL_MATRIX2_NV

GLScene.OpenGL4

GL_MATRIX30_ARB

GLScene.OpenGL4

GL_MATRIX31_ARB

GLScene.OpenGL4

GL_MATRIX3_ARB

GLScene.OpenGL4

GL_MATRIX3_NV

GLScene.OpenGL4

GL_MATRIX4_ARB

GLScene.OpenGL4

GL_MATRIX4_NV

GLScene.OpenGL4

GL_MATRIX5_ARB

GLScene.OpenGL4

GL_MATRIX5_NV

GLScene.OpenGL4

GL_MATRIX6_ARB

GLScene.OpenGL4

GL_MATRIX6_NV

GLScene.OpenGL4

GL_MATRIX7_ARB

GLScene.OpenGL4

GL_MATRIX7_NV

GLScene.OpenGL4

GL_MATRIX8_ARB

GLScene.OpenGL4

GL_MATRIX9_ARB

GLScene.OpenGL4

GL_MATRIX_EXT

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_MATRIX_MODE

GLScene.OpenGL4

GL_MATRIX_PALETTE_ARB

GLScene.OpenGL4

GL_ARB_matrix_palette

GL_MATRIX_STRIDE

GLScene.OpenGL4

GL_MAT_AMBIENT_AND_DIFFUSE_BIT_PGI

GLScene.OpenGL4

GL_MAT_AMBIENT_BIT_PGI

GLScene.OpenGL4

GL_MAT_COLOR_INDEXES_BIT_PGI

GLScene.OpenGL4

GL_MAT_DIFFUSE_BIT_PGI

GLScene.OpenGL4

GL_MAT_EMISSION_BIT_PGI

GLScene.OpenGL4

GL_MAT_SHININESS_BIT_PGI

GLScene.OpenGL4

GL_MAT_SPECULAR_BIT_PGI

GLScene.OpenGL4

GL_MAX

GLScene.OpenGL4

GL_MAX_3D_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_3D_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_4D_TEXTURE_SIZE_SGIS

GLScene.OpenGL4

GL_MAX_ACTIVE_LIGHTS_SGIX

GLScene.OpenGL4

GL_MAX_ARRAY_TEXTURE_LAYERS

GLScene.OpenGL4

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT

GLScene.OpenGL4

GL_MAX_ASYNC_DRAW_PIXELS_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_HISTOGRAM_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_READ_PIXELS_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_TEX_IMAGE_SGIX

GLScene.OpenGL4

GL_MAX_ATOMIC_COUNTER_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_ATOMIC_COUNTER_BUFFER_SIZE

GLScene.OpenGL4

GL_MAX_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT

GLScene.OpenGL4

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_CLIPMAP_DEPTH_SGIX

GLScene.OpenGL4

GL_MAX_CLIPMAP_VIRTUAL_DEPTH_SGIX

GLScene.OpenGL4

GL_MAX_CLIP_DISTANCES

GLScene.OpenGL4

GL_MAX_CLIP_PLANES

GLScene.OpenGL4

GL_MAX_COLOR_ATTACHMENTS

GLScene.OpenGL4

GL_MAX_COLOR_ATTACHMENTS_EXT

GLScene.OpenGL4

GL_MAX_COLOR_MATRIX_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI

GLScene.OpenGL4

GL_MAX_COLOR_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_MAX_COMBINED_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_COMBINED_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_COMBINED_CLIP_AND_CULL_DISTANCES

GLScene.OpenGL4

GL_MAX_COMBINED_COMPUTE_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_DIMENSIONS

GLScene.OpenGL4

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS_EXT

GLScene.OpenGL4

GL_MAX_COMBINED_SHADER_OUTPUT_RESOURCES

GLScene.OpenGL4

GL_MAX_COMBINED_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_COMBINED_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMPUTE_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_COMPUTE_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_COMPUTE_FIXED_GROUP_INVOCATIONS_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_FIXED_GROUP_SIZE_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_COMPUTE_LOCAL_INVOCATIONS

GLScene.OpenGL4

GL_MAX_COMPUTE_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_COMPUTE_SHARED_MEMORY_SIZE

GLScene.OpenGL4

GL_MAX_COMPUTE_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_COMPUTE_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_COMPUTE_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMPUTE_VARIABLE_GROUP_INVOCATIONS_ARB

GLScene.OpenGL4

GL_ARB_compute_variable_group_size

GL_MAX_COMPUTE_VARIABLE_GROUP_SIZE_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_WORK_GROUP_COUNT

GLScene.OpenGL4

GL_MAX_COMPUTE_WORK_GROUP_SIZE

GLScene.OpenGL4

GL_MAX_CONVOLUTION_HEIGHT

GLScene.OpenGL4

GL_MAX_CONVOLUTION_HEIGHT_EXT

GLScene.OpenGL4

GL_MAX_CONVOLUTION_WIDTH

GLScene.OpenGL4

GL_MAX_CONVOLUTION_WIDTH_EXT

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_CULL_DISTANCES

GLScene.OpenGL4

GL_MAX_DEBUG_GROUP_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_DEBUG_LOGGED_MESSAGES

GLScene.OpenGL4

GL_MAX_DEBUG_LOGGED_MESSAGES_AMD

GLScene.OpenGL4

GL_AMD_debug_output

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB

GLScene.OpenGL4

GL_MAX_DEBUG_MESSAGE_LENGTH

GLScene.OpenGL4

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB

GLScene.OpenGL4

GL_MAX_DEFORMATION_ORDER_SGIX

GLScene.OpenGL4

GL_MAX_DEPTH

GLScene.OpenGL4

GL_MAX_DEPTH_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_MAX_DRAW_BUFFERS

GLScene.OpenGL4

GL_MAX_DRAW_BUFFERS_ARB

GLScene.OpenGL4

GL_ARB_draw_buffers

GL_MAX_DRAW_BUFFERS_ATI

GLScene.OpenGL4

GL_ATI_draw_buffers

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES_EXT

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES_WIN

GLScene.OpenGL4

GL_MAX_ELEMENTS_VERTICES

GLScene.OpenGL4

GL_MAX_ELEMENTS_VERTICES_EXT

GLScene.OpenGL4

GL_EXT_draw_range_elements

GL_MAX_ELEMENTS_VERTICES_WIN

GLScene.OpenGL4

WIN_draw_range_elements

GL_MAX_ELEMENT_INDEX

GLScene.OpenGL4

GL_MAX_EVAL_ORDER

GLScene.OpenGL4

GL_MAX_EXT

GLScene.OpenGL4

GL_MAX_FOG_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_MAX_FRAGMENT_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_FRAGMENT_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_MAX_FRAGMENT_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_FRAGMENT_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET

GLScene.OpenGL4

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET_NV

GLScene.OpenGL4

GL_MAX_FRAGMENT_LIGHTS_SGIX

GLScene.OpenGL4

GL_MAX_FRAGMENT_PROGRAM_LOCAL_PARAMETERS_NV

GLScene.OpenGL4

GL_NV_fragment_program

GL_MAX_FRAGMENT_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_VECTORS

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_HEIGHT

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_LAYERS

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_SAMPLES

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_WIDTH

GLScene.OpenGL4

GL_MAX_FRAMEZOOM_FACTOR_SGIX

GLScene.OpenGL4

GL_MAX_GENERAL_COMBINERS_NV

GLScene.OpenGL4

GL_MAX_GEOMETRY_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_GEOMETRY_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_GEOMETRY_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_PROGRAM_INVOCATIONS_NV

GLScene.OpenGL4

GL_NV_gpu_program5

GL_MAX_GEOMETRY_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_MAX_GEOMETRY_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_HEIGHT

GLScene.OpenGL4

GL_MAX_IMAGE_SAMPLES

GLScene.OpenGL4

GL_MAX_IMAGE_SAMPLES_EXT

GLScene.OpenGL4

GL_MAX_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_IMAGE_UNITS_EXT

GLScene.OpenGL4

GL_EXT_shader_image_load_store

GL_MAX_INTEGER_SAMPLES

GLScene.OpenGL4

GL_MAX_LABEL_LENGTH

GLScene.OpenGL4

GL_MAX_LAYERS

GLScene.OpenGL4

GL_MAX_LIGHTS

GLScene.OpenGL4

GL_MAX_LIST_NESTING

GLScene.OpenGL4

GL_MAX_MAP_TESSELLATION_NV

GLScene.OpenGL4

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_MAX_MODELVIEW_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_NAME_LENGTH

GLScene.OpenGL4

GL_MAX_NAME_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_NUM_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_MAX_NUM_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_MAX_PALETTE_MATRICES_ARB

GLScene.OpenGL4

GL_MAX_PATCH_VERTICES

GLScene.OpenGL4

GL_MAX_PIXEL_MAP_TABLE

GLScene.OpenGL4

GL_MAX_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_MAX_PN_TRIANGLES_TESSELATION_LEVEL_ATI

GLScene.OpenGL4

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ATTRIB_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_CALL_DEPTH_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_EXEC_INSTRUCTIONS_NV

GLScene.OpenGL4

GL_NV_fragment_program2 and GL_NV_vertex_program2_option

GL_MAX_PROGRAM_GENERIC_ATTRIBS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_GENERIC_RESULTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_IF_DEPTH_NV

GLScene.OpenGL4

GL_NV_fragment_program2

GL_MAX_PROGRAM_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_LOOP_COUNT_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_LOOP_DEPTH_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_MATRICES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_PARAMETER_BUFFER_BINDINGS_NV

GLScene.OpenGL4

GL_NV_parameter_buffer_object

GL_MAX_PROGRAM_PARAMETER_BUFFER_SIZE_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_PATCH_ATTRIBS_NV

GLScene.OpenGL4

GL_NV_tessellation_program5

GL_MAX_PROGRAM_RESULT_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_SUBROUTINE_NUM_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_SUBROUTINE_PARAMETERS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_TEMPORARIES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXEL_OFFSET

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROJECTION_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_RATIONAL_EVAL_ORDER_NV

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV

GLScene.OpenGL4

GL_MAX_RENDERBUFFER_SIZE

GLScene.OpenGL4

GL_MAX_RENDERBUFFER_SIZE_EXT

GLScene.OpenGL4

GL_MAX_SAMPLES

GLScene.OpenGL4

GL_MAX_SAMPLES_EXT

GLScene.OpenGL4

GL_MAX_SAMPLE_MASK_WORDS

GLScene.OpenGL4

GL_MAX_SAMPLE_MASK_WORDS_NV

GLScene.OpenGL4

GL_MAX_SERVER_WAIT_TIMEOUT

GLScene.OpenGL4

GL_ARB_sync

GL_MAX_SHADER_BUFFER_ADDRESS_NV

GLScene.OpenGL4

GL_MAX_SHADER_COMPILER_THREADS_ARB

GLScene.OpenGL4

GL_ARB_parallel_shader_compile

GL_MAX_SHADER_STORAGE_BLOCK_SIZE

GLScene.OpenGL4

GL_MAX_SHADER_STORAGE_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_SHININESS_NV

GLScene.OpenGL4

GL_NV_light_max_exponent

GL_MAX_SPARSE_3D_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_SPARSE_ARRAY_TEXTURE_LAYERS_ARB

GLScene.OpenGL4

GL_MAX_SPARSE_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_SPOT_EXPONENT_NV

GLScene.OpenGL4

GL_MAX_SUBPIXEL_PRECISION_BIAS_BITS_NV

GLScene.OpenGL4

GL_MAX_SUBROUTINES

GLScene.OpenGL4

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_GEN_LEVEL

GLScene.OpenGL4

GL_MAX_TESS_PATCH_COMPONENTS

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE_EXT

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS_NV

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS_NV

GLScene.OpenGL4

GL_MAX_TEXTURE_LOD_BIAS

GLScene.OpenGL4

GL_MAX_TEXTURE_LOD_BIAS_EXT

GLScene.OpenGL4

GL_EXT_texture_lod_bias

GL_MAX_TEXTURE_MAX_ANISOTROPY

GLScene.OpenGL4

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT

GLScene.OpenGL4

GL_MAX_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_TEXTURE_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_TEXTURE_UNITS

GLScene.OpenGL4

GL_MAX_TEXTURE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_TRACK_MATRICES_NV

GLScene.OpenGL4

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS

GLScene.OpenGL4

GL_ARB_transform_feedback3

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_UNIFORM_BLOCK_SIZE

GLScene.OpenGL4

GL_MAX_UNIFORM_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_MAX_VARYING_COMPONENTS

GLScene.OpenGL4

GL_MAX_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_VARYING_FLOATS

GLScene.OpenGL4

GL_MAX_VARYING_FLOATS_ARB

GLScene.OpenGL4

GL_MAX_VARYING_VECTORS

GLScene.OpenGL4

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV

GLScene.OpenGL4

GL_MAX_VERTEX_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_VERTEX_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIBS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_BINDINGS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_RELATIVE_OFFSET

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_STRIDE

GLScene.OpenGL4

GL 4.4

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_EXT_bindable_uniform

GL_MAX_VERTEX_HINT_PGI

GLScene.OpenGL4

GL_MAX_VERTEX_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_VERTEX_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_STREAMS

GLScene.OpenGL4

GL_MAX_VERTEX_STREAMS_ATI

GLScene.OpenGL4

GL_ATI_vertex_streams

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_VECTORS

GLScene.OpenGL4

GL_MAX_VERTEX_UNITS_ARB

GLScene.OpenGL4

GL_ARB_vertex_blend

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_VIEWPORTS

GLScene.OpenGL4

GL_ARB_vertex_attrib_64bit

GL_MAX_VIEWPORT_DIMS

GLScene.OpenGL4

GL_MAX_VIEWS_OVR

GLScene.OpenGL4

GL_MAX_WIDTH

GLScene.OpenGL4

GL_MEDIUM_FLOAT

GLScene.OpenGL4

GL_MEDIUM_INT

GLScene.OpenGL4

GL_MIN

GLScene.OpenGL4

GL_MINMAX

GLScene.OpenGL4

GL_MINMAX_EXT

GLScene.OpenGL4

GL_MINMAX_FORMAT

GLScene.OpenGL4

GL_MINMAX_FORMAT_EXT

GLScene.OpenGL4

GL_MINMAX_SINK

GLScene.OpenGL4

GL_MINMAX_SINK_EXT

GLScene.OpenGL4

GL_MINOR_VERSION

GLScene.OpenGL4

GL_MIN_EXT

GLScene.OpenGL4

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET

GLScene.OpenGL4

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET_NV

GLScene.OpenGL4

GL_MIN_MAP_BUFFER_ALIGNMENT

GLScene.OpenGL4

GL_ARB_map_buffer_alignment

GL_MIN_PROGRAM_TEXEL_OFFSET

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

GLScene.OpenGL4

GL_ARB_texture_gather

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_NV

GLScene.OpenGL4

GL_MIN_SAMPLE_SHADING_VALUE

GLScene.OpenGL4

GL_MIN_SAMPLE_SHADING_VALUE_ARB

GLScene.OpenGL4

GL_MIN_SPARSE_LEVEL_ARB

GLScene.OpenGL4

GL_MIPMAP

GLScene.OpenGL4

GL_MIRRORED_REPEAT

GLScene.OpenGL4

GL_MIRRORED_REPEAT_ARB

GLScene.OpenGL4

GL_ARB_texture_mirrored_repeat

GL_MIRRORED_REPEAT_IBM

GLScene.OpenGL4

GL_IBM_texture_mirrored_repeat

GL_MIRROR_CLAMP_ATI

GLScene.OpenGL4

GL_ATI_texture_mirror_once

GL_MIRROR_CLAMP_EXT

GLScene.OpenGL4

GL_EXT_texture_mirror_clamp

GL_MIRROR_CLAMP_TO_BORDER_EXT

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE_ATI

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE_EXT

GLScene.OpenGL4

GL_MITER_REVERT_NV

GLScene.OpenGL4

GL_MITER_TRUNCATE_NV

GLScene.OpenGL4

GL_MODELVIEW

GLScene.OpenGL4

GL_MODELVIEW0_ARB

GLScene.OpenGL4

GL_MODELVIEW0_EXT

GLScene.OpenGL4

GL_MODELVIEW0_MATRIX_EXT

GLScene.OpenGL4

GL_MODELVIEW0_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_EXT_vertex_weighting

GL_MODELVIEW10_ARB

GLScene.OpenGL4

GL_MODELVIEW11_ARB

GLScene.OpenGL4

GL_MODELVIEW12_ARB

GLScene.OpenGL4

GL_MODELVIEW13_ARB

GLScene.OpenGL4

GL_MODELVIEW14_ARB

GLScene.OpenGL4

GL_MODELVIEW15_ARB

GLScene.OpenGL4

GL_MODELVIEW16_ARB

GLScene.OpenGL4

GL_MODELVIEW17_ARB

GLScene.OpenGL4

GL_MODELVIEW18_ARB

GLScene.OpenGL4

GL_MODELVIEW19_ARB

GLScene.OpenGL4

GL_MODELVIEW1_ARB

GLScene.OpenGL4

GL_MODELVIEW1_EXT

GLScene.OpenGL4

GL_MODELVIEW1_MATRIX_EXT

GLScene.OpenGL4

GL_MODELVIEW1_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_MODELVIEW20_ARB

GLScene.OpenGL4

GL_MODELVIEW21_ARB

GLScene.OpenGL4

GL_MODELVIEW22_ARB

GLScene.OpenGL4

GL_MODELVIEW23_ARB

GLScene.OpenGL4

GL_MODELVIEW24_ARB

GLScene.OpenGL4

GL_MODELVIEW25_ARB

GLScene.OpenGL4

GL_MODELVIEW26_ARB

GLScene.OpenGL4

GL_MODELVIEW27_ARB

GLScene.OpenGL4

GL_MODELVIEW28_ARB

GLScene.OpenGL4

GL_MODELVIEW29_ARB

GLScene.OpenGL4

GL_MODELVIEW2_ARB

GLScene.OpenGL4

GL_MODELVIEW30_ARB

GLScene.OpenGL4

GL_MODELVIEW31_ARB

GLScene.OpenGL4

GL_MODELVIEW3_ARB

GLScene.OpenGL4

GL_MODELVIEW4_ARB

GLScene.OpenGL4

GL_MODELVIEW5_ARB

GLScene.OpenGL4

GL_MODELVIEW6_ARB

GLScene.OpenGL4

GL_MODELVIEW7_ARB

GLScene.OpenGL4

GL_MODELVIEW8_ARB

GLScene.OpenGL4

GL_MODELVIEW9_ARB

GLScene.OpenGL4

GL_MODELVIEW_MATRIX

GLScene.OpenGL4

GL_MODELVIEW_PROJECTION_NV

GLScene.OpenGL4

GL_MODELVIEW_STACK_DEPTH

GLScene.OpenGL4

GL_MODULATE

GLScene.OpenGL4

GL_MODULATE_ADD_ATI

GLScene.OpenGL4

GL_ATI_texture_env_combine3

GL_MODULATE_SIGNED_ADD_ATI

GLScene.OpenGL4

GL_MODULATE_SUBTRACT_ATI

GLScene.OpenGL4

GL_MOVE_TO_CONTINUES_NV

GLScene.OpenGL4

GL_MOVE_TO_NV

GLScene.OpenGL4

GL_MOVE_TO_RESETS_NV

GLScene.OpenGL4

GL_MOV_ATI

GLScene.OpenGL4

GL_MULT

GLScene.OpenGL4

GL_MULTIPLY_KHR

GLScene.OpenGL4

GL_KHR_blend_equation_advanced

GL_MULTISAMPLE

GLScene.OpenGL4

GL_MULTISAMPLE_3DFX

GLScene.OpenGL4

GL_3DFX_multisample

GL_MULTISAMPLE_ARB

GLScene.OpenGL4

GL_ARB_multisample

GL_MULTISAMPLE_BIT

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_3DFX

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_EXT

GLScene.OpenGL4

GL_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_EXT_multisample

GL_MULTISAMPLE_FILTER_HINT_NV

GLScene.OpenGL4

GL_NV_multisample_filter_hint

GL_MULTISAMPLE_LINE_WIDTH_GRANULARITY_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_LINE_WIDTH_RANGE_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_SGIS

GLScene.OpenGL4

GL_SGIS_multisample

GL_MULTI_HULLS_NV

GLScene.OpenGL4

GL_MUL_ATI

GLScene.OpenGL4

GL_MVP_MATRIX_EXT

GLScene.OpenGL4

GL_N3F_V3F

GLScene.OpenGL4

GL_NAMED_STRING_LENGTH_ARB

GLScene.OpenGL4

GL_NAMED_STRING_TYPE_ARB

GLScene.OpenGL4

GL_NAME_LENGTH

GLScene.OpenGL4

GL_NAME_STACK_DEPTH

GLScene.OpenGL4

GL_NAND

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_BEGIN_HINT_PGI

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_END_HINT_PGI

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_HANDLE_PGI

GLScene.OpenGL4

GL_NEAREST

GLScene.OpenGL4

TextureMagFilter

GL_NEAREST_CLIPMAP_LINEAR_SGIX

GLScene.OpenGL4

GL_NEAREST_CLIPMAP_NEAREST_SGIX

GLScene.OpenGL4

GL_NEAREST_MIPMAP_LINEAR

GLScene.OpenGL4

GL_NEAREST_MIPMAP_NEAREST

GLScene.OpenGL4

TextureMinFilter

GL_NEGATE_BIT_ATI

GLScene.OpenGL4

GL_NEGATIVE_ONE_EXT

GLScene.OpenGL4

GL_NEGATIVE_ONE_TO_ONE

GLScene.OpenGL4

GL_NEGATIVE_W_EXT

GLScene.OpenGL4

GL_NEGATIVE_X_EXT

GLScene.OpenGL4

GL_NEGATIVE_Y_EXT

GLScene.OpenGL4

GL_NEGATIVE_Z_EXT

GLScene.OpenGL4

GL_NEVER

GLScene.OpenGL4

AlphaFunction

GL_NEXT_BUFFER_NV

GLScene.OpenGL4

GL_NEXT_VIDEO_CAPTURE_BUFFER_STATUS_NV

GLScene.OpenGL4

GL_NICEST

GLScene.OpenGL4

GL_NONE

GLScene.OpenGL4

DrawBufferMode

GL_NOOP

GLScene.OpenGL4

GL_NOR

GLScene.OpenGL4

GL_NORMALIZE

GLScene.OpenGL4

GL_NORMALIZED_RANGE_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY

GLScene.OpenGL4

GL_NORMAL_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_NORMAL_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_NORMAL_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_NORMAL_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_NORMAL_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_NORMAL_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_NORMAL_ARRAY_POINTER

GLScene.OpenGL4

GL_NORMAL_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_STRIDE

GLScene.OpenGL4

GL_NORMAL_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_TYPE

GLScene.OpenGL4

GL_NORMAL_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_NORMAL_BIT_PGI

GLScene.OpenGL4

GL_NORMAL_MAP

GLScene.OpenGL4

GL_NORMAL_MAP_ARB

GLScene.OpenGL4

GL_ARB_texture_cube_map

GL_NORMAL_MAP_EXT

GLScene.OpenGL4

GL_EXT_texture_cube_map

GL_NORMAL_MAP_NV

GLScene.OpenGL4

GL_NV_texgen_reflection

GL_NOTEQUAL

GLScene.OpenGL4

GL_NO_ERROR

GLScene.OpenGL4

ErrorCode

GL_NO_RESET_NOTIFICATION

GLScene.OpenGL4

GL_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

GL_NUM_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_NUM_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_NUM_COMPRESSED_TEXTURE_FORMATS

GLScene.OpenGL4

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB

GLScene.OpenGL4

GL_NUM_EXTENSIONS

GLScene.OpenGL4

GL_NUM_FILL_STREAMS_NV

GLScene.OpenGL4

GL_NUM_FRAGMENT_CONSTANTS_ATI

GLScene.OpenGL4

GL_NUM_FRAGMENT_REGISTERS_ATI

GLScene.OpenGL4

GL_NUM_GENERAL_COMBINERS_NV

GLScene.OpenGL4

GL_NUM_INPUT_INTERPOLATOR_COMPONENTS_ATI

GLScene.OpenGL4

GL_NUM_INSTRUCTIONS_PER_PASS_ATI

GLScene.OpenGL4

GL_NUM_INSTRUCTIONS_TOTAL_ATI

GLScene.OpenGL4

GL_NUM_LOOPBACK_COMPONENTS_ATI

GLScene.OpenGL4

GL_NUM_PASSES_ATI

GLScene.OpenGL4

GL_NUM_PROGRAM_BINARY_FORMATS

GLScene.OpenGL4

GL_NUM_SAMPLE_COUNTS

GLScene.OpenGL4

GL_ARB_internalformat_query

GL_NUM_SHADER_BINARY_FORMATS

GLScene.OpenGL4

GL_NUM_SHADING_LANGUAGE_VERSIONS

GLScene.OpenGL4

GL_VERSION_4_1 GL_VERSION_4_2 GL_VERSION_4_3

GL_NUM_SPARSE_LEVELS_ARB

GLScene.OpenGL4

GL_NUM_SPIR_V_EXTENSIONS

GLScene.OpenGL4

GL_NUM_VIDEO_CAPTURE_STREAMS_NV

GLScene.OpenGL4

GL_NUM_VIRTUAL_PAGE_SIZES_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_UNIFORMS_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_ATTACHED_OBJECTS_ARB

GLScene.OpenGL4

GL_OBJECT_BUFFER_SIZE_ATI

GLScene.OpenGL4

GL_OBJECT_BUFFER_USAGE_ATI

GLScene.OpenGL4

GL_OBJECT_COMPILE_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_DELETE_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_DISTANCE_TO_LINE_SGIS

GLScene.OpenGL4

GL_OBJECT_DISTANCE_TO_POINT_SGIS

GLScene.OpenGL4

GL_OBJECT_INFO_LOG_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_LINEAR

GLScene.OpenGL4

GL_OBJECT_LINE_SGIS

GLScene.OpenGL4

GL_OBJECT_LINK_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_PLANE

GLScene.OpenGL4

GL_OBJECT_POINT_SGIS

GLScene.OpenGL4

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_SUBTYPE_ARB

GLScene.OpenGL4

GL_OBJECT_TYPE

GLScene.OpenGL4

GL_OBJECT_TYPE_ARB

GLScene.OpenGL4

GL_OBJECT_VALIDATE_STATUS_ARB

GLScene.OpenGL4

GL_OCCLUSION_TEST_HP

GLScene.OpenGL4

GL_HP_occlusion_test

GL_OCCLUSION_TEST_RESULT_HP

GLScene.OpenGL4

GL_OFFSET

GLScene.OpenGL4

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_HILO_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV

GLScene.OpenGL4

GL_NV_texture_shader3

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_BIAS_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_MATRIX_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_BIAS_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_MATRIX_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_NV_texture_shader

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_SCALE_NV

GLScene.OpenGL4

GL_ONE

GLScene.OpenGL4

GL_ONE_EXT

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_ALPHA_EXT

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_COLOR_EXT

GLScene.OpenGL4

GL_ONE_MINUS_DST_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_DST_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_SRC1_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_SRC1_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_SRC_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_SRC_COLOR

GLScene.OpenGL4

GL_OPERAND0_ALPHA

GLScene.OpenGL4

GL_OPERAND0_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND0_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND0_RGB

GLScene.OpenGL4

GL_OPERAND0_RGB_ARB

GLScene.OpenGL4

GL_OPERAND0_RGB_EXT

GLScene.OpenGL4

GL_OPERAND1_ALPHA

GLScene.OpenGL4

GL_OPERAND1_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND1_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND1_RGB

GLScene.OpenGL4

GL_OPERAND1_RGB_ARB

GLScene.OpenGL4

GL_OPERAND1_RGB_EXT

GLScene.OpenGL4

GL_OPERAND2_ALPHA

GLScene.OpenGL4

GL_OPERAND2_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND2_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND2_RGB

GLScene.OpenGL4

GL_OPERAND2_RGB_ARB

GLScene.OpenGL4

GL_OPERAND2_RGB_EXT

GLScene.OpenGL4

GL_OPERAND3_ALPHA_NV

GLScene.OpenGL4

GL_OPERAND3_RGB_NV

GLScene.OpenGL4

GL_OP_ADD_EXT

GLScene.OpenGL4

GL_OP_CLAMP_EXT

GLScene.OpenGL4

GL_OP_CROSS_PRODUCT_EXT

GLScene.OpenGL4

GL_OP_DOT3_EXT

GLScene.OpenGL4

GL_OP_DOT4_EXT

GLScene.OpenGL4

GL_OP_EXP_BASE_2_EXT

GLScene.OpenGL4

GL_OP_FLOOR_EXT

GLScene.OpenGL4

GL_OP_FRAC_EXT

GLScene.OpenGL4

GL_OP_INDEX_EXT

GLScene.OpenGL4

GL_OP_LOG_BASE_2_EXT

GLScene.OpenGL4

GL_OP_MADD_EXT

GLScene.OpenGL4

GL_OP_MAX_EXT

GLScene.OpenGL4

GL_OP_MIN_EXT

GLScene.OpenGL4

GL_OP_MOV_EXT

GLScene.OpenGL4

GL_OP_MULTIPLY_MATRIX_EXT

GLScene.OpenGL4

GL_OP_MUL_EXT

GLScene.OpenGL4

GL_OP_NEGATE_EXT

GLScene.OpenGL4

GL_OP_POWER_EXT

GLScene.OpenGL4

GL_OP_RECIP_EXT

GLScene.OpenGL4

GL_OP_RECIP_SQRT_EXT

GLScene.OpenGL4

GL_OP_ROUND_EXT

GLScene.OpenGL4

GL_OP_SET_GE_EXT

GLScene.OpenGL4

GL_OP_SET_LT_EXT

GLScene.OpenGL4

GL_OP_SUB_EXT

GLScene.OpenGL4

GL_OR

GLScene.OpenGL4

GL_ORDER

GLScene.OpenGL4

GL_OR_INVERTED

GLScene.OpenGL4

GL_OR_REVERSE

GLScene.OpenGL4

GL_OUTPUT_COLOR0_EXT

GLScene.OpenGL4

GL_OUTPUT_COLOR1_EXT

GLScene.OpenGL4

GL_OUTPUT_FOG_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD0_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD10_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD11_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD12_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD13_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD14_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD15_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD16_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD17_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD18_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD19_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD1_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD20_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD21_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD22_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD23_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD24_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD25_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD26_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD27_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD28_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD29_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD2_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD30_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD31_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD3_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD4_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD5_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD6_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD7_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD8_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD9_EXT

GLScene.OpenGL4

GL_OUTPUT_VERTEX_EXT

GLScene.OpenGL4

GL_OUT_OF_MEMORY

GLScene.OpenGL4

GL_OVERLAY_KHR

GLScene.OpenGL4

GL_PACK_ALIGNMENT

GLScene.OpenGL4

GL_PACK_CMYK_HINT_EXT

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_DEPTH

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_PACK_IMAGE_DEPTH_SGIS

GLScene.OpenGL4

GL_PACK_IMAGE_HEIGHT

GLScene.OpenGL4

GL_PACK_IMAGE_HEIGHT_EXT

GLScene.OpenGL4

GL_PACK_LSB_FIRST

GLScene.OpenGL4

GL_PACK_RESAMPLE_OML

GLScene.OpenGL4

GL_OML_resample

GL_PACK_RESAMPLE_SGIX

GLScene.OpenGL4

GL_SGIX_resample

GL_PACK_ROW_BYTES_APPLE

GLScene.OpenGL4

GL_APPLE_row_bytes

GL_PACK_ROW_LENGTH

GLScene.OpenGL4

GL_PACK_SKIP_IMAGES

GLScene.OpenGL4

GL_PACK_SKIP_IMAGES_EXT

GLScene.OpenGL4

GL_EXT_texture3D

GL_PACK_SKIP_PIXELS

GLScene.OpenGL4

GL_PACK_SKIP_ROWS

GLScene.OpenGL4

GL_PACK_SKIP_VOLUMES_SGIS

GLScene.OpenGL4

GL_SGIS_texture4D

GL_PACK_SUBSAMPLE_RATE_SGIX

GLScene.OpenGL4

GL_SGIX_subsample

GL_PACK_SWAP_BYTES

GLScene.OpenGL4

GL_PARALLEL_ARRAYS_INTEL

GLScene.OpenGL4

GL_INTEL_parallel_arrays

GL_PARAMETER_BUFFER

GLScene.OpenGL4

GL_PARAMETER_BUFFER_BINDING

GLScene.OpenGL4

GL_PARTIAL_SUCCESS_NV

GLScene.OpenGL4

GL_PASS_THROUGH_NV

GLScene.OpenGL4

GL_PASS_THROUGH_TOKEN

GLScene.OpenGL4

GL_PATCHES

GLScene.OpenGL4

GL_ARB_tessellation_shader

GL_PATCH_DEFAULT_INNER_LEVEL

GLScene.OpenGL4

GL_PATCH_DEFAULT_OUTER_LEVEL

GLScene.OpenGL4

GL_PATCH_VERTICES

GLScene.OpenGL4

GL_PATH_CLIENT_LENGTH_NV

GLScene.OpenGL4

GL_PATH_COMMAND_COUNT_NV

GLScene.OpenGL4

GL_PATH_COMPUTED_LENGTH_NV

GLScene.OpenGL4

GL_PATH_COORD_COUNT_NV

GLScene.OpenGL4

GL_PATH_COVER_DEPTH_FUNC_NV

GLScene.OpenGL4

GL_PATH_DASH_ARRAY_COUNT_NV

GLScene.OpenGL4

GL_PATH_DASH_CAPS_NV

GLScene.OpenGL4

GL_PATH_DASH_OFFSET_NV

GLScene.OpenGL4

GL_PATH_DASH_OFFSET_RESET_NV

GLScene.OpenGL4

GL_PATH_END_CAPS_NV

GLScene.OpenGL4

GL_PATH_ERROR_POSITION_NV

GLScene.OpenGL4

GL_PATH_FILL_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_FILL_COVER_MODE_NV

GLScene.OpenGL4

GL_PATH_FILL_MASK_NV

GLScene.OpenGL4

GL_PATH_FILL_MODE_NV

GLScene.OpenGL4

GL_PATH_FOG_GEN_MODE_NV

GLScene.OpenGL4

GL_PATH_FORMAT_PS_NV

GLScene.OpenGL4

GL_PATH_FORMAT_SVG_NV

GLScene.OpenGL4

(4.3) GL_NV_path_rendering

GL_PATH_GEN_COEFF_NV

GLScene.OpenGL4

GL_PATH_GEN_COLOR_FORMAT_NV

GLScene.OpenGL4

GL_PATH_GEN_COMPONENTS_NV

GLScene.OpenGL4

GL_PATH_GEN_MODE_NV

GLScene.OpenGL4

GL_PATH_INITIAL_DASH_CAP_NV

GLScene.OpenGL4

GL_PATH_INITIAL_END_CAP_NV

GLScene.OpenGL4

GL_PATH_JOIN_STYLE_NV

GLScene.OpenGL4

GL_PATH_MITER_LIMIT_NV

GLScene.OpenGL4

GL_PATH_OBJECT_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_SAMPLE_QUALITY_NV

GLScene.OpenGL4

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV

GLScene.OpenGL4

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV

GLScene.OpenGL4

GL_PATH_STENCIL_FUNC_NV

GLScene.OpenGL4

GL_PATH_STENCIL_REF_NV

GLScene.OpenGL4

GL_PATH_STENCIL_VALUE_MASK_NV

GLScene.OpenGL4

GL_PATH_STROKE_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_STROKE_BOUND_NV

GLScene.OpenGL4

GL_PATH_STROKE_COVER_MODE_NV

GLScene.OpenGL4

GL_PATH_STROKE_MASK_NV

GLScene.OpenGL4

GL_PATH_STROKE_OVERSAMPLE_COUNT_NV

GLScene.OpenGL4

GL_PATH_STROKE_WIDTH_NV

GLScene.OpenGL4

GL_PATH_TERMINAL_DASH_CAP_NV

GLScene.OpenGL4

GL_PATH_TERMINAL_END_CAP_NV

GLScene.OpenGL4

GL_PERCENTAGE_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_AVAILABLE_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_SIZE_AMD

GLScene.OpenGL4

GL_PERFORMANCE_MONITOR_AMD

GLScene.OpenGL4

GL_PERSPECTIVE_CORRECTION_HINT

GLScene.OpenGL4

GL_PERTURB_EXT

GLScene.OpenGL4

GL_EXT_texture_perturb_normal

GL_PER_STAGE_CONSTANTS_NV

GLScene.OpenGL4

GL_NV_register_combiners2

GL_PHONG_HINT_WIN

GLScene.OpenGL4

GL_PHONG_WIN

GLScene.OpenGL4

GL_WIN_phong_shading

GL_PIXEL_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_PIXEL_BUFFER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_PIXEL_COUNTER_BITS_NV

GLScene.OpenGL4

GL_NV_occlusion_query

GL_PIXEL_COUNT_AVAILABLE_NV

GLScene.OpenGL4

GL_PIXEL_COUNT_NV

GLScene.OpenGL4

GL_PIXEL_CUBIC_WEIGHT_EXT

GLScene.OpenGL4

GL_PIXEL_FRAGMENT_ALPHA_SOURCE_SGIS

GLScene.OpenGL4

GL_PIXEL_FRAGMENT_RGB_SOURCE_SGIS

GLScene.OpenGL4

GL_PIXEL_GROUP_COLOR_SGIS

GLScene.OpenGL4

GL_PIXEL_MAG_FILTER_EXT

GLScene.OpenGL4

GL_PIXEL_MAP_A_TO_A

GLScene.OpenGL4

GL_PIXEL_MAP_A_TO_A_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_B_TO_B

GLScene.OpenGL4

GL_PIXEL_MAP_B_TO_B_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_G_TO_G

GLScene.OpenGL4

GL_PIXEL_MAP_G_TO_G_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_A

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_A_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_B

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_B_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_G

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_G_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_I

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_I_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_R

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_R_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_R_TO_R

GLScene.OpenGL4

GL_PIXEL_MAP_R_TO_R_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_S_TO_S

GLScene.OpenGL4

GL_PIXEL_MAP_S_TO_S_SIZE

GLScene.OpenGL4

GL_PIXEL_MIN_FILTER_EXT

GLScene.OpenGL4

GL_PIXEL_MODE_BIT

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER

GLScene.OpenGL4

GL_VERSION_2_1

GL_PIXEL_PACK_BUFFER_ARB

GLScene.OpenGL4

GL_ARB_pixel_buffer_object

GL_PIXEL_PACK_BUFFER_BINDING

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_pixel_buffer_object

GL_PIXEL_SUBSAMPLE_2424_SGIX

GLScene.OpenGL4

GL_PIXEL_SUBSAMPLE_4242_SGIX

GLScene.OpenGL4

GL_PIXEL_SUBSAMPLE_4444_SGIX

GLScene.OpenGL4

GL_PIXEL_TEXTURE_SGIS

GLScene.OpenGL4

GL_SGIS_pixel_texture

GL_PIXEL_TEX_GEN_ALPHA_LS_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_MS_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_NO_REPLACE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_REPLACE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_MODE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_Q_CEILING_SGIX

GLScene.OpenGL4

GL_SGIX_impact_pixel_texture

GL_PIXEL_TEX_GEN_Q_FLOOR_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_Q_ROUND_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_SGIX

GLScene.OpenGL4

GL_SGIX_pixel_texture

GL_PIXEL_TILE_BEST_ALIGNMENT_SGIX

GLScene.OpenGL4

GL_SGIX_pixel_tiles

GL_PIXEL_TILE_CACHE_INCREMENT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_CACHE_SIZE_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_DEPTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_HEIGHT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_WIDTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_HEIGHT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_WIDTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TRANSFORM_2D_EXT

GLScene.OpenGL4

GL_EXT_pixel_transform

GL_PIXEL_TRANSFORM_2D_MATRIX_EXT

GLScene.OpenGL4

GL_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_ARB

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_EXT

GLScene.OpenGL4

GL_PN_TRIANGLES_ATI

GLScene.OpenGL4

GL_ATI_pn_triangles

GL_PN_TRIANGLES_NORMAL_MODE_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_NORMAL_MODE_LINEAR_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_NORMAL_MODE_QUADRATIC_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_CUBIC_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_LINEAR_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_TESSELATION_LEVEL_ATI

GLScene.OpenGL4

GL_POINT

GLScene.OpenGL4

PolygonMode

GL_POINTS

GLScene.OpenGL4

BeginMode

GL_POINT_BIT

GLScene.OpenGL4

GL_POINT_DISTANCE_ATTENUATION

GLScene.OpenGL4

GL_POINT_DISTANCE_ATTENUATION_ARB

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_ARB

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_EXT

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_SGIS

GLScene.OpenGL4

GL_POINT_SIZE

GLScene.OpenGL4

GetPName

GL_POINT_SIZE_GRANULARITY

GLScene.OpenGL4

GL_POINT_SIZE_MAX

GLScene.OpenGL4

GL_POINT_SIZE_MAX_ARB

GLScene.OpenGL4

GL_POINT_SIZE_MAX_EXT

GLScene.OpenGL4

GL_POINT_SIZE_MAX_SGIS

GLScene.OpenGL4

GL_POINT_SIZE_MIN

GLScene.OpenGL4

GL_POINT_SIZE_MIN_ARB

GLScene.OpenGL4

GL_ARB_point_parameters

GL_POINT_SIZE_MIN_EXT

GLScene.OpenGL4

GL_EXT_point_parameters

GL_POINT_SIZE_MIN_SGIS

GLScene.OpenGL4

GL_SGIS_point_parameters

GL_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_POINT_SMOOTH

GLScene.OpenGL4

GL_POINT_SMOOTH_HINT

GLScene.OpenGL4

GL_POINT_SPRITE

GLScene.OpenGL4

GL_POINT_SPRITE_ARB

GLScene.OpenGL4

GL_ARB_point_sprite

GL_POINT_SPRITE_COORD_ORIGIN

GLScene.OpenGL4

GL_POINT_SPRITE_NV

GLScene.OpenGL4

GL_NV_point_sprite

GL_POINT_SPRITE_R_MODE_NV

GLScene.OpenGL4

GL_POINT_TOKEN

GLScene.OpenGL4

GL_POLYGON

GLScene.OpenGL4

GL_POLYGON_BIT

GLScene.OpenGL4

GL_POLYGON_MODE

GLScene.OpenGL4

GL_POLYGON_OFFSET_BIAS_EXT

GLScene.OpenGL4

GL_POLYGON_OFFSET_CLAMP

GLScene.OpenGL4

GL_POLYGON_OFFSET_EXT

GLScene.OpenGL4

GL_EXT_polygon_offset

GL_POLYGON_OFFSET_FACTOR

GLScene.OpenGL4

GL_POLYGON_OFFSET_FACTOR_EXT

GLScene.OpenGL4

GL_POLYGON_OFFSET_FILL

GLScene.OpenGL4

GL_POLYGON_OFFSET_LINE

GLScene.OpenGL4

GL_POLYGON_OFFSET_POINT

GLScene.OpenGL4

GL_POLYGON_OFFSET_UNITS

GLScene.OpenGL4

GL_POLYGON_SMOOTH

GLScene.OpenGL4

GL_POLYGON_SMOOTH_HINT

GLScene.OpenGL4

GL_POLYGON_STIPPLE

GLScene.OpenGL4

GL_POLYGON_STIPPLE_BIT

GLScene.OpenGL4

GL_POLYGON_TOKEN

GLScene.OpenGL4

GL_POSITION

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_COLOR_TABLE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_SCALE_SGI

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_COLOR_TABLE

GLScene.OpenGL4

GL_POST_CONVOLUTION_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_SCALE_EXT

GLScene.OpenGL4

GL_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_BIAS_RANGE_SGIX

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_BIAS_SGIX

GLScene.OpenGL4

GL_SGIX_texture_scale_bias

GL_POST_TEXTURE_FILTER_SCALE_RANGE_SGIX

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_SCALE_SGIX

GLScene.OpenGL4

GL_PREFER_DOUBLEBUFFER_HINT_PGI

GLScene.OpenGL4

GL_PGI_misc_hints

GL_PRESENT_DURATION_NV

GLScene.OpenGL4

GL_PRESENT_TIME_NV

GLScene.OpenGL4

GL_PRESERVE_ATI

GLScene.OpenGL4

GL_PREVIOUS

GLScene.OpenGL4

GL_PREVIOUS_ARB

GLScene.OpenGL4

GL_PREVIOUS_EXT

GLScene.OpenGL4

GL_PREVIOUS_TEXTURE_INPUT_NV

GLScene.OpenGL4

GL_PRIMARY_COLOR

GLScene.OpenGL4

GL_PRIMARY_COLOR_ARB

GLScene.OpenGL4

GL_PRIMARY_COLOR_EXT

GLScene.OpenGL4

GL_PRIMARY_COLOR_NV

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED_EXT

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED_NV

GLScene.OpenGL4

GL_PRIMITIVES_SUBMITTED

GLScene.OpenGL4

GL_PRIMITIVES_SUBMITTED_ARB

GLScene.OpenGL4

GL_PRIMITIVE_BOUNDING_BOX_ARB

GLScene.OpenGL4

GL_ARB_ES3_2_compatibility

GL_PRIMITIVE_ID_NV

GLScene.OpenGL4

GL_PRIMITIVE_RESTART

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_FIXED_INDEX

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_FOR_PATCHES_SUPPORTED

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_INDEX

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_INDEX_NV

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_NV

GLScene.OpenGL4

GL_NV_primitive_restart

GL_PROGRAM

GLScene.OpenGL4

GL_PROGRAMMABLE_SAMPLE_LOCATION_ARB

GLScene.OpenGL4

GL_PROGRAMMABLE_SAMPLE_LOCATION_TABLE_SIZE_ARB

GLScene.OpenGL4

GL_PROGRAM_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_PROGRAM_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_ATTRIBS_ARB

GLScene.OpenGL4

GL_PROGRAM_ATTRIB_COMPONENTS_NV

GLScene.OpenGL4

GL_NV_gpu_program4

GL_PROGRAM_BINARY_FORMATS

GLScene.OpenGL4

GL_PROGRAM_BINARY_LENGTH

GLScene.OpenGL4

GL_PROGRAM_BINARY_RETRIEVABLE_HINT

GLScene.OpenGL4

GL_ARB_get_program_binary

GL_PROGRAM_BINDING_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_POSITION_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_POSITION_NV

GLScene.OpenGL4

GL_PROGRAM_ERROR_STRING_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_STRING_NV

GLScene.OpenGL4

GL_PROGRAM_FORMAT_ARB

GLScene.OpenGL4

GL_PROGRAM_FORMAT_ASCII_ARB

GLScene.OpenGL4

GL_PROGRAM_INPUT

GLScene.OpenGL4

GL_PROGRAM_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_LENGTH_ARB

GLScene.OpenGL4

GL_PROGRAM_LENGTH_NV

GLScene.OpenGL4

GL_PROGRAM_MATRIX_EXT

GLScene.OpenGL4

GL_EXT_direct_state_access

GL_PROGRAM_MATRIX_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ATTRIBS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_PARAMETERS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEMPORARIES_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_OBJECT_ARB

GLScene.OpenGL4

1.4 GL_ARB_shader_objects

GL_PROGRAM_OUTPUT

GLScene.OpenGL4

GL_PROGRAM_PARAMETERS_ARB

GLScene.OpenGL4

GL_PROGRAM_PARAMETER_NV

GLScene.OpenGL4

GL_PROGRAM_PIPELINE

GLScene.OpenGL4

GL_PROGRAM_PIPELINE_BINDING

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE_ARB

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE_EXT

GLScene.OpenGL4

GL_PROGRAM_RESIDENT_NV

GLScene.OpenGL4

GL_PROGRAM_RESULT_COMPONENTS_NV

GLScene.OpenGL4

GL_PROGRAM_SEPARABLE

GLScene.OpenGL4

GL_PROGRAM_STRING_ARB

GLScene.OpenGL4

GL_PROGRAM_STRING_NV

GLScene.OpenGL4

GL_PROGRAM_TARGET_NV

GLScene.OpenGL4

GL_PROGRAM_TEMPORARIES_ARB

GLScene.OpenGL4

GL_PROGRAM_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB

GLScene.OpenGL4

GL_PROJECTION

GLScene.OpenGL4

GL_PROJECTION_MATRIX

GLScene.OpenGL4

GL_PROJECTION_STACK_DEPTH

GLScene.OpenGL4

GL_PROJECTIVE_2D_NV

GLScene.OpenGL4

GL_PROJECTIVE_3D_NV

GLScene.OpenGL4

GL_PROVOKING_VERTEX

GLScene.OpenGL4

GL_PROVOKING_VERTEX_EXT

GLScene.OpenGL4

GL_PROXY_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_HISTOGRAM

GLScene.OpenGL4

GL_PROXY_HISTOGRAM_EXT

GLScene.OpenGL4

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D

GLScene.OpenGL4

TextureTarget

GL_PROXY_TEXTURE_1D_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_3D

GLScene.OpenGL4

GL_PROXY_TEXTURE_3D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_4D_SGIS

GLScene.OpenGL4

GL_PROXY_TEXTURE_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_PURGEABLE_APPLE

GLScene.OpenGL4

GL_Q

GLScene.OpenGL4

GL_QUADRATIC_ATTENUATION

GLScene.OpenGL4

GL_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_QUADS

GLScene.OpenGL4

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION

GLScene.OpenGL4

GL_ARB_provoking_vertex

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_EXT_provoking_vertex

GL_QUAD_ALPHA4_SGIS

GLScene.OpenGL4

GL_QUAD_ALPHA8_SGIS

GLScene.OpenGL4

GL_QUAD_INTENSITY4_SGIS

GLScene.OpenGL4

GL_QUAD_INTENSITY8_SGIS

GLScene.OpenGL4

GL_QUAD_LUMINANCE4_SGIS

GLScene.OpenGL4

GL_QUAD_LUMINANCE8_SGIS

GLScene.OpenGL4

GL_QUAD_MESH_SUN

GLScene.OpenGL4

GL_SUN_mesh_array

GL_QUAD_STRIP

GLScene.OpenGL4

GL_QUAD_TEXTURE_SELECT_SGIS

GLScene.OpenGL4

GL_QUARTER_BIT_ATI

GLScene.OpenGL4

GL_QUERY

GLScene.OpenGL4

GL_QUERY_BUFFER

GLScene.OpenGL4

GL_QUERY_BUFFER_AMD

GLScene.OpenGL4

(4.3) GL_AMD_vertex_shader_viewport_index (4.3) GL_AMD_vertex_shader_layer (4.3) GL_NV_bindless_texture (4.3) GL_NV_shader_atomic_float (4.3) GL_AMD_query_buffer_object

GL_QUERY_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_QUERY_BUFFER_BINDING

GLScene.OpenGL4

GL_QUERY_BUFFER_BINDING_AMD

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT_NV

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT_NV

GLScene.OpenGL4

GL_QUERY_COUNTER_BITS

GLScene.OpenGL4

GL_QUERY_COUNTER_BITS_ARB

GLScene.OpenGL4

GL_QUERY_NO_WAIT

GLScene.OpenGL4

GL_QUERY_NO_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_NO_WAIT_NV

GLScene.OpenGL4

GL_QUERY_OBJECT_AMD

GLScene.OpenGL4

GL_QUERY_RESULT

GLScene.OpenGL4

GL_QUERY_RESULT_ARB

GLScene.OpenGL4

GL_QUERY_RESULT_AVAILABLE

GLScene.OpenGL4

GL_QUERY_RESULT_AVAILABLE_ARB

GLScene.OpenGL4

GL_QUERY_RESULT_NO_WAIT

GLScene.OpenGL4

GL_QUERY_RESULT_NO_WAIT_AMD

GLScene.OpenGL4

GL_QUERY_TARGET

GLScene.OpenGL4

GL_QUERY_WAIT

GLScene.OpenGL4

GL_QUERY_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_WAIT_NV

GLScene.OpenGL4

GL_NV_conditional_render

GL_R

GLScene.OpenGL4

GL_R11F_G11F_B10F

GLScene.OpenGL4

GL_R11F_G11F_B10F_EXT

GLScene.OpenGL4

GL_EXT_packed_float

GL_R16

GLScene.OpenGL4

GL_R16F

GLScene.OpenGL4

GL_R16I

GLScene.OpenGL4

GL_R16UI

GLScene.OpenGL4

GL_R16_SNORM

GLScene.OpenGL4

GL_R1UI_C3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_C4F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_C4UB_V3F_SUN

GLScene.OpenGL4

GL_R1UI_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_C4F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_V3F_SUN

GLScene.OpenGL4

GL_R32F

GLScene.OpenGL4

GL_R32I

GLScene.OpenGL4

GL_R32UI

GLScene.OpenGL4

GL_R3_G3_B2

GLScene.OpenGL4

PixelInternalFormat

GL_R8

GLScene.OpenGL4

GL_R8I

GLScene.OpenGL4

GL_R8UI

GLScene.OpenGL4

GL_R8_SNORM

GLScene.OpenGL4

GL_RASTERIZER_DISCARD

GLScene.OpenGL4

GL_RASTERIZER_DISCARD_EXT

GLScene.OpenGL4

GL_RASTERIZER_DISCARD_NV

GLScene.OpenGL4

GL_RASTER_POSITION_UNCLIPPED_IBM

GLScene.OpenGL4

GL_IBM_rasterpos_clip

GL_READ_BUFFER

GLScene.OpenGL4

GL_READ_FRAMEBUFFER

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_blit

GL_READ_ONLY

GLScene.OpenGL4

GL_READ_ONLY_ARB

GLScene.OpenGL4

GL_READ_PIXELS

GLScene.OpenGL4

GL_READ_PIXELS_FORMAT

GLScene.OpenGL4

GL_READ_PIXELS_TYPE

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_NV

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_POINTER_NV

GLScene.OpenGL4

GL_READ_WRITE

GLScene.OpenGL4

GL_READ_WRITE_ARB

GLScene.OpenGL4

GL_RECLAIM_MEMORY_HINT_PGI

GLScene.OpenGL4

GL_RECT_NV

GLScene.OpenGL4

GL_RED

GLScene.OpenGL4

GL_REDUCE

GLScene.OpenGL4

GL_REDUCE_EXT

GLScene.OpenGL4

GL_RED_BIAS

GLScene.OpenGL4

GL_RED_BITS

GLScene.OpenGL4

GL_RED_BIT_ATI

GLScene.OpenGL4

GL_RED_INTEGER

GLScene.OpenGL4

GL_RED_INTEGER_EXT

GLScene.OpenGL4

GL_RED_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_RED_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_INGR_color_clamp

GL_RED_SCALE

GLScene.OpenGL4

GL_RED_SNORM

GLScene.OpenGL4

GL_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_REFERENCE_PLANE_EQUATION_SGIX

GLScene.OpenGL4

GL_REFERENCE_PLANE_SGIX

GLScene.OpenGL4

GL_SGIX_reference_plane

GL_REFLECTION_MAP

GLScene.OpenGL4

GL_REFLECTION_MAP_ARB

GLScene.OpenGL4

GL_REFLECTION_MAP_EXT

GLScene.OpenGL4

GL_REFLECTION_MAP_NV

GLScene.OpenGL4

GL_REGISTER_COMBINERS_NV

GLScene.OpenGL4

GL_NV_register_combiners

GL_REG_0_ATI

GLScene.OpenGL4

GL_REG_10_ATI

GLScene.OpenGL4

GL_REG_11_ATI

GLScene.OpenGL4

GL_REG_12_ATI

GLScene.OpenGL4

GL_REG_13_ATI

GLScene.OpenGL4

GL_REG_14_ATI

GLScene.OpenGL4

GL_REG_15_ATI

GLScene.OpenGL4

GL_REG_16_ATI

GLScene.OpenGL4

GL_REG_17_ATI

GLScene.OpenGL4

GL_REG_18_ATI

GLScene.OpenGL4

GL_REG_19_ATI

GLScene.OpenGL4

GL_REG_1_ATI

GLScene.OpenGL4

GL_REG_20_ATI

GLScene.OpenGL4

GL_REG_21_ATI

GLScene.OpenGL4

GL_REG_22_ATI

GLScene.OpenGL4

GL_REG_23_ATI

GLScene.OpenGL4

GL_REG_24_ATI

GLScene.OpenGL4

GL_REG_25_ATI

GLScene.OpenGL4

GL_REG_26_ATI

GLScene.OpenGL4

GL_REG_27_ATI

GLScene.OpenGL4

GL_REG_28_ATI

GLScene.OpenGL4

GL_REG_29_ATI

GLScene.OpenGL4

GL_REG_2_ATI

GLScene.OpenGL4

GL_REG_30_ATI

GLScene.OpenGL4

GL_REG_31_ATI

GLScene.OpenGL4

GL_REG_3_ATI

GLScene.OpenGL4

GL_REG_4_ATI

GLScene.OpenGL4

GL_REG_5_ATI

GLScene.OpenGL4

GL_REG_6_ATI

GLScene.OpenGL4

GL_REG_7_ATI

GLScene.OpenGL4

GL_REG_8_ATI

GLScene.OpenGL4

GL_REG_9_ATI

GLScene.OpenGL4

GL_RELATIVE_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_HORIZONTAL_LINE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LARGE_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LARGE_CW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LINE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_MOVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMALL_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMALL_CW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_VERTICAL_LINE_TO_NV

GLScene.OpenGL4

GL_RELEASED_APPLE

GLScene.OpenGL4

GL_RENDER

GLScene.OpenGL4

GL_RENDERBUFFER

GLScene.OpenGL4

GL_RENDERBUFFER_ALPHA_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_BINDING

GLScene.OpenGL4

GL_RENDERBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_BLUE_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_RENDERBUFFER_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_framebuffer_multisample_coverage

GL_RENDERBUFFER_DEPTH_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_RENDERBUFFER_GREEN_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_HEIGHT

GLScene.OpenGL4

GL_RENDERBUFFER_HEIGHT_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_INTERNAL_FORMAT

GLScene.OpenGL4

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_RED_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_SAMPLES

GLScene.OpenGL4

GL_RENDERBUFFER_SAMPLES_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_multisample

GL_RENDERBUFFER_STENCIL_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_WIDTH

GLScene.OpenGL4

GL_RENDERBUFFER_WIDTH_EXT

GLScene.OpenGL4

GL_RENDERER

GLScene.OpenGL4

GL_RENDER_MODE

GLScene.OpenGL4

GL_REPEAT

GLScene.OpenGL4

TextureWrapMode

GL_REPLACE

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_POINTER_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_STRIDE_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_TYPE_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_SUN

GLScene.OpenGL4

GL_REPLACE_EXT

GLScene.OpenGL4

GL_REPLACE_MIDDLE_SUN

GLScene.OpenGL4

GL_REPLACE_OLDEST_SUN

GLScene.OpenGL4

GL_REPLACE_VALUE_AMD

GLScene.OpenGL4

GL_REPLICATE_BORDER

GLScene.OpenGL4

GL_REPLICATE_BORDER_HP

GLScene.OpenGL4

GL_RESAMPLE_AVERAGE_OML

GLScene.OpenGL4

GL_RESAMPLE_DECIMATE_OML

GLScene.OpenGL4

GL_RESAMPLE_DECIMATE_SGIX

GLScene.OpenGL4

GL_RESAMPLE_REPLICATE_OML

GLScene.OpenGL4

GL_RESAMPLE_REPLICATE_SGIX

GLScene.OpenGL4

GL_RESAMPLE_ZERO_FILL_OML

GLScene.OpenGL4

GL_RESAMPLE_ZERO_FILL_SGIX

GLScene.OpenGL4

GL_RESCALE_NORMAL

GLScene.OpenGL4

GL_RESCALE_NORMAL_EXT

GLScene.OpenGL4

GL_EXT_rescale_normal

GL_RESET_NOTIFICATION_STRATEGY

GLScene.OpenGL4

GL_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

GL_RESTART_PATH_NV

GLScene.OpenGL4

GL_RESTART_SUN

GLScene.OpenGL4

GL_SUN_triangle_list

GL_RETAINED_APPLE

GLScene.OpenGL4

GL_RETURN

GLScene.OpenGL4

GL_RG

GLScene.OpenGL4

GL_ARB_texture_rg

GL_RG16

GLScene.OpenGL4

GL_RG16F

GLScene.OpenGL4

GL_RG16I

GLScene.OpenGL4

GL_RG16UI

GLScene.OpenGL4

GL_RG16_SNORM

GLScene.OpenGL4

GL_RG32F

GLScene.OpenGL4

GL_RG32I

GLScene.OpenGL4

GL_RG32UI

GLScene.OpenGL4

GL_RG8

GLScene.OpenGL4

GL_RG8I

GLScene.OpenGL4

GL_RG8UI

GLScene.OpenGL4

GL_RG8_SNORM

GLScene.OpenGL4

GL_RGB

GLScene.OpenGL4

GL_RGB10

GLScene.OpenGL4

GL_RGB10_A2

GLScene.OpenGL4

GL_RGB10_A2UI

GLScene.OpenGL4

GL_ARB_texture_rgb10_a2ui

GL_RGB10_A2_EXT

GLScene.OpenGL4

GL_RGB10_EXT

GLScene.OpenGL4

GL_RGB12

GLScene.OpenGL4

GL_RGB12_EXT

GLScene.OpenGL4

GL_RGB16

GLScene.OpenGL4

GL_RGB16F

GLScene.OpenGL4

GL_RGB16F_ARB

GLScene.OpenGL4

GL_RGB16I

GLScene.OpenGL4

GL_RGB16I_EXT

GLScene.OpenGL4

GL_RGB16UI

GLScene.OpenGL4

GL_RGB16UI_EXT

GLScene.OpenGL4

GL_RGB16_EXT

GLScene.OpenGL4

GL_RGB16_SNORM

GLScene.OpenGL4

GL_RGB2_EXT

GLScene.OpenGL4

GL_RGB32F

GLScene.OpenGL4

GL_RGB32F_ARB

GLScene.OpenGL4

GL_RGB32I

GLScene.OpenGL4

GL_RGB32I_EXT

GLScene.OpenGL4

GL_RGB32UI

GLScene.OpenGL4

GL_RGB32UI_EXT

GLScene.OpenGL4

GL_RGB4

GLScene.OpenGL4

GL_RGB4_EXT

GLScene.OpenGL4

GL_RGB4_S3TC

GLScene.OpenGL4

GL_RGB5

GLScene.OpenGL4

GL_RGB565

GLScene.OpenGL4

GL_RGB5_A1

GLScene.OpenGL4

GL_RGB5_A1_EXT

GLScene.OpenGL4

GL_RGB5_EXT

GLScene.OpenGL4

GL_RGB8

GLScene.OpenGL4

GL_RGB8I

GLScene.OpenGL4

GL_RGB8I_EXT

GLScene.OpenGL4

GL_RGB8UI

GLScene.OpenGL4

GL_RGB8UI_EXT

GLScene.OpenGL4

GL_RGB8_EXT

GLScene.OpenGL4

GL_RGB8_SNORM

GLScene.OpenGL4

GL_RGB9_E5

GLScene.OpenGL4

GL_RGB9_E5_EXT

GLScene.OpenGL4

GL_EXT_texture_shared_exponent

GL_RGBA

GLScene.OpenGL4

GL_RGBA12

GLScene.OpenGL4

GL_RGBA12_EXT

GLScene.OpenGL4

GL_RGBA16

GLScene.OpenGL4

GL_RGBA16F

GLScene.OpenGL4

GL_RGBA16F_ARB

GLScene.OpenGL4

GL_RGBA16I

GLScene.OpenGL4

GL_RGBA16I_EXT

GLScene.OpenGL4

GL_RGBA16UI

GLScene.OpenGL4

GL_RGBA16UI_EXT

GLScene.OpenGL4

GL_RGBA16_EXT

GLScene.OpenGL4

GL_RGBA16_SNORM

GLScene.OpenGL4

GL_RGBA2

GLScene.OpenGL4

GL_RGBA2_EXT

GLScene.OpenGL4

GL_RGBA32F

GLScene.OpenGL4

GL_RGBA32F_ARB

GLScene.OpenGL4

GL_RGBA32I

GLScene.OpenGL4

GL_RGBA32I_EXT

GLScene.OpenGL4

GL_RGBA32UI

GLScene.OpenGL4

GL_RGBA32UI_EXT

GLScene.OpenGL4

GL_RGBA4

GLScene.OpenGL4

GL_RGBA4_EXT

GLScene.OpenGL4

GL_RGBA4_S3TC

GLScene.OpenGL4

GL_RGBA8

GLScene.OpenGL4

GL_RGBA8I

GLScene.OpenGL4

GL_RGBA8I_EXT

GLScene.OpenGL4

GL_RGBA8UI

GLScene.OpenGL4

GL_RGBA8UI_EXT

GLScene.OpenGL4

GL_RGBA8_EXT

GLScene.OpenGL4

GL_RGBA8_SNORM

GLScene.OpenGL4

GL_RGBA_FLOAT16_APPLE

GLScene.OpenGL4

GL_RGBA_FLOAT16_ATI

GLScene.OpenGL4

GL_RGBA_FLOAT32_APPLE

GLScene.OpenGL4

GL_RGBA_FLOAT32_ATI

GLScene.OpenGL4

GL_ATI_texture_float

GL_RGBA_FLOAT_MODE_ARB

GLScene.OpenGL4

GL_ARB_color_buffer_float

GL_RGBA_INTEGER

GLScene.OpenGL4

GL_RGBA_INTEGER_EXT

GLScene.OpenGL4

GL_RGBA_INTEGER_MODE_EXT

GLScene.OpenGL4

GL_EXT_texture_integer

GL_RGBA_MODE

GLScene.OpenGL4

GL_RGBA_S3TC

GLScene.OpenGL4

GL_RGBA_SNORM

GLScene.OpenGL4

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV

GLScene.OpenGL4

GL_RGB_FLOAT16_APPLE

GLScene.OpenGL4

GL_RGB_FLOAT16_ATI

GLScene.OpenGL4

GL_RGB_FLOAT32_APPLE

GLScene.OpenGL4

GL_RGB_FLOAT32_ATI

GLScene.OpenGL4

GL_RGB_INTEGER

GLScene.OpenGL4

GL_RGB_INTEGER_EXT

GLScene.OpenGL4

GL_RGB_RAW_422_APPLE

GLScene.OpenGL4

GL_RGB_S3TC

GLScene.OpenGL4

GL_S3_s3tc

GL_RGB_SCALE

GLScene.OpenGL4

GL_RGB_SCALE_ARB

GLScene.OpenGL4

GL_RGB_SCALE_EXT

GLScene.OpenGL4

GL_RGB_SNORM

GLScene.OpenGL4

GL_RG_INTEGER

GLScene.OpenGL4

GL_RG_SNORM

GLScene.OpenGL4

GL_RIGHT

GLScene.OpenGL4

GL_ROUND_NV

GLScene.OpenGL4

GL_S

GLScene.OpenGL4

GL_SAMPLER

GLScene.OpenGL4

GL_SAMPLER_1D

GLScene.OpenGL4

GL_SAMPLER_1D_ARB

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_1D_SHADOW

GLScene.OpenGL4

GL_SAMPLER_1D_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_2D

GLScene.OpenGL4

GL_SAMPLER_2D_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_VERSION_3_1

GL_SAMPLER_2D_RECT_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_RECT_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_RECT_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_3D

GLScene.OpenGL4

GL_SAMPLER_3D_ARB

GLScene.OpenGL4

GL_SAMPLER_BINDING

GLScene.OpenGL4

GL_ARB_sampler_objects

GL_SAMPLER_BUFFER

GLScene.OpenGL4

GL_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_AMD_vertex_shader_tesselator

GL_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_SAMPLER_CUBE

GLScene.OpenGL4

GL_SAMPLER_CUBE_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_SHADOW

GLScene.OpenGL4

GL_SAMPLER_CUBE_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_OBJECT_AMD

GLScene.OpenGL4

GL_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_SAMPLES

GLScene.OpenGL4

GL_SAMPLES_3DFX

GLScene.OpenGL4

GL_SAMPLES_ARB

GLScene.OpenGL4

GL_SAMPLES_EXT

GLScene.OpenGL4

GL_SAMPLES_PASSED

GLScene.OpenGL4

GL_SAMPLES_PASSED_ARB

GLScene.OpenGL4

1.4 GL_ARB_occlusion_query

GL_SAMPLES_SGIS

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_COVERAGE

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_MASK_EXT

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_MASK_SGIS

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_ARB

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_EXT

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_SGIS

GLScene.OpenGL4

GL_SAMPLE_BUFFERS

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_3DFX

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_EXT

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_SGIS

GLScene.OpenGL4

GL_SAMPLE_COVERAGE

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_ARB

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_INVERT

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_INVERT_ARB

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_VALUE

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_VALUE_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_PIXEL_GRID_HEIGHT_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_PIXEL_GRID_WIDTH_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_SUBPIXEL_BITS_ARB

GLScene.OpenGL4

GL_ARB_sample_locations

GL_SAMPLE_MASK

GLScene.OpenGL4

GL_SAMPLE_MASK_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_INVERT_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_INVERT_SGIS

GLScene.OpenGL4

GL_SAMPLE_MASK_NV

GLScene.OpenGL4

GL_SAMPLE_MASK_SGIS

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_NV

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_SGIS

GLScene.OpenGL4

GL_SAMPLE_PATTERN_EXT

GLScene.OpenGL4

GL_SAMPLE_PATTERN_SGIS

GLScene.OpenGL4

GL_SAMPLE_POSITION

GLScene.OpenGL4

GL_ARB_texture_multisample

GL_SAMPLE_POSITION_NV

GLScene.OpenGL4

GL_NV_explicit_multisample

GL_SAMPLE_SHADING

GLScene.OpenGL4

GL_VERSION_4_0

GL_SAMPLE_SHADING_ARB

GLScene.OpenGL4

GL_ARB_sample_shading

GL_SATURATE_BIT_ATI

GLScene.OpenGL4

GL_SCALAR_EXT

GLScene.OpenGL4

GL_SCALEBIAS_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_scalebias_hint

GL_SCALED_RESOLVE_FASTEST_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_multisample_blit_scaled

GL_SCALED_RESOLVE_NICEST_EXT

GLScene.OpenGL4

GL_SCALE_BY_FOUR_NV

GLScene.OpenGL4

GL_SCALE_BY_ONE_HALF_NV

GLScene.OpenGL4

GL_SCALE_BY_TWO_NV

GLScene.OpenGL4

GL_SCISSOR_BIT

GLScene.OpenGL4

GL_SCISSOR_BOX

GLScene.OpenGL4

GL_SCISSOR_TEST

GLScene.OpenGL4

GL_SCREEN_COORDINATES_REND

GLScene.OpenGL4

GL_REND_screen_coordinates

GL_SCREEN_KHR

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_POINTER

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_SIZE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_STRIDE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_TYPE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_SECONDARY_INTERPOLATOR_ATI

GLScene.OpenGL4

GL_SELECT

GLScene.OpenGL4

GL_SELECTION_BUFFER_POINTER

GLScene.OpenGL4

GL_SELECTION_BUFFER_SIZE

GLScene.OpenGL4

GL_SEPARABLE_2D

GLScene.OpenGL4

GL_SEPARABLE_2D_EXT

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS_EXT

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS_NV

GLScene.OpenGL4

GL_SEPARATE_SPECULAR_COLOR

GLScene.OpenGL4

GL_SEPARATE_SPECULAR_COLOR_EXT

GLScene.OpenGL4

GL_SET

GLScene.OpenGL4

GL_SET_AMD

GLScene.OpenGL4

(4.3) GL_AMD_stencil_operation_extended

GL_SHADER

GLScene.OpenGL4

GL_SHADER_BINARY_FORMAT_SPIR_V

GLScene.OpenGL4

4.6

GL_SHADER_BINARY_FORMAT_SPIR_V_ARB

GLScene.OpenGL4

GL_ARB_gl_spirv

GL_SHADER_COMPILER

GLScene.OpenGL4

GL_SHADER_CONSISTENT_NV

GLScene.OpenGL4

GL_SHADER_GLOBAL_ACCESS_BARRIER_BIT_NV

GLScene.OpenGL4

GL_NV_shader_buffer_store

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT

GLScene.OpenGL4

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_SHADER_IMAGE_ATOMIC

GLScene.OpenGL4

GL_SHADER_IMAGE_LOAD

GLScene.OpenGL4

GL_SHADER_IMAGE_STORE

GLScene.OpenGL4

GL_SHADER_INCLUDE_ARB

GLScene.OpenGL4

GL_ARB_shading_language_include

GL_SHADER_OBJECT_ARB

GLScene.OpenGL4

GL_SHADER_OPERATION_NV

GLScene.OpenGL4

GL_SHADER_SOURCE_LENGTH

GLScene.OpenGL4

GL_SHADER_STORAGE_BARRIER_BIT

GLScene.OpenGL4

GL_SHADER_STORAGE_BLOCK

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_BINDING

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_SIZE

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_START

GLScene.OpenGL4

GL_SHADER_TYPE

GLScene.OpenGL4

GL_SHADE_MODEL

GLScene.OpenGL4

GL_SHADING_LANGUAGE_VERSION

GLScene.OpenGL4

GL_SHADING_LANGUAGE_VERSION_ARB

GLScene.OpenGL4

GL_ARB_shading_language_100

GL_SHADOW_AMBIENT_SGIX

GLScene.OpenGL4

GL_SGIX_shadow_ambient

GL_SHADOW_ATTENUATION_EXT

GLScene.OpenGL4

GL_SHARED_TEXTURE_PALETTE_EXT

GLScene.OpenGL4

GL_EXT_shared_texture_palette

GL_SHARPEN_TEXTURE_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_SHININESS

GLScene.OpenGL4

GL_SHORT

GLScene.OpenGL4

GL_SIGNALED

GLScene.OpenGL4

GL_SIGNED_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_ALPHA_NV

GLScene.OpenGL4

GL_SIGNED_HILO16_NV

GLScene.OpenGL4

GL_SIGNED_HILO8_NV

GLScene.OpenGL4

GL_SIGNED_HILO_NV

GLScene.OpenGL4

GL_SIGNED_IDENTITY_NV

GLScene.OpenGL4

GL_SIGNED_INTENSITY8_NV

GLScene.OpenGL4

GL_SIGNED_INTENSITY_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE8_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE8_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE_ALPHA_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE_NV

GLScene.OpenGL4

GL_SIGNED_NEGATE_NV

GLScene.OpenGL4

GL_SIGNED_NORMALIZED

GLScene.OpenGL4

GL_SIGNED_RGB8_NV

GLScene.OpenGL4

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_RGBA8_NV

GLScene.OpenGL4

GL_SIGNED_RGBA_NV

GLScene.OpenGL4

GL_SIGNED_RGB_NV

GLScene.OpenGL4

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_TEST

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_WRITE

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_TEST

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_WRITE

GLScene.OpenGL4

GL_SINGLE_COLOR

GLScene.OpenGL4

GL_SINGLE_COLOR_EXT

GLScene.OpenGL4

GL_SKIP_COMPONENTS1_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS2_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS3_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS4_NV

GLScene.OpenGL4

GL_SKIP_DECODE_EXT

GLScene.OpenGL4

GL_SKIP_MISSING_GLYPH_NV

GLScene.OpenGL4

GL_SLICE_ACCUM_SUN

GLScene.OpenGL4

GL_SUN_slice_accum

GL_SLUMINANCE

GLScene.OpenGL4

GL_SLUMINANCE8

GLScene.OpenGL4

GL_SLUMINANCE8_ALPHA8

GLScene.OpenGL4

GL_SLUMINANCE8_ALPHA8_EXT

GLScene.OpenGL4

GL_SLUMINANCE8_EXT

GLScene.OpenGL4

GL_SLUMINANCE_ALPHA

GLScene.OpenGL4

GL_SLUMINANCE_ALPHA_EXT

GLScene.OpenGL4

GL_SLUMINANCE_EXT

GLScene.OpenGL4

GL_SMALL_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_SMALL_CW_ARC_TO_NV

GLScene.OpenGL4

GL_SMOOTH

GLScene.OpenGL4

GL_SMOOTH_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_SMOOTH_LINE_WIDTH_GRANULARITY

GLScene.OpenGL4

GL_SMOOTH_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_SMOOTH_POINT_SIZE_GRANULARITY

GLScene.OpenGL4

GL_SMOOTH_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_SMOOTH_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_SOFTLIGHT_KHR

GLScene.OpenGL4

GL_SOURCE0_ALPHA

GLScene.OpenGL4

GL_SOURCE0_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE0_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE0_RGB

GLScene.OpenGL4

GL_SOURCE0_RGB_ARB

GLScene.OpenGL4

GL_SOURCE0_RGB_EXT

GLScene.OpenGL4

GL_SOURCE1_ALPHA

GLScene.OpenGL4

GL_SOURCE1_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE1_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE1_RGB

GLScene.OpenGL4

GL_SOURCE1_RGB_ARB

GLScene.OpenGL4

GL_SOURCE1_RGB_EXT

GLScene.OpenGL4

GL_SOURCE2_ALPHA

GLScene.OpenGL4

GL_SOURCE2_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE2_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE2_RGB

GLScene.OpenGL4

GL_SOURCE2_RGB_ARB

GLScene.OpenGL4

GL_SOURCE2_RGB_EXT

GLScene.OpenGL4

GL_SOURCE3_ALPHA_NV

GLScene.OpenGL4

GL_SOURCE3_RGB_NV

GLScene.OpenGL4

GL_SPARE0_NV

GLScene.OpenGL4

GL_SPARE0_PLUS_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_SPARE1_NV

GLScene.OpenGL4

GL_SPARSE_BUFFER_PAGE_SIZE_ARB

GLScene.OpenGL4

GL_SPARSE_STORAGE_BIT_ARB

GLScene.OpenGL4

GL_ARB_sparse_buffer

GL_SPARSE_TEXTURE_FULL_ARRAY_CUBE_MIPMAPS_ARB

GLScene.OpenGL4

GL_SPECULAR

GLScene.OpenGL4

GL_SPHERE_MAP

GLScene.OpenGL4

GL_SPIR_V_BINARY

GLScene.OpenGL4

GL_SPIR_V_BINARY_ARB

GLScene.OpenGL4

GL_SPIR_V_EXTENSIONS

GLScene.OpenGL4

GL_SPOT_CUTOFF

GLScene.OpenGL4

GL_SPOT_DIRECTION

GLScene.OpenGL4

GL_SPOT_EXPONENT

GLScene.OpenGL4

GL_SPRITE_AXIAL_SGIX

GLScene.OpenGL4

GL_SPRITE_AXIS_SGIX

GLScene.OpenGL4

GL_SPRITE_EYE_ALIGNED_SGIX

GLScene.OpenGL4

GL_SPRITE_MODE_SGIX

GLScene.OpenGL4

GL_SPRITE_OBJECT_ALIGNED_SGIX

GLScene.OpenGL4

GL_SPRITE_SGIX

GLScene.OpenGL4

GL_SGIX_sprite

GL_SPRITE_TRANSLATION_SGIX

GLScene.OpenGL4

GL_SQUARE_NV

GLScene.OpenGL4

GL_SRC0_ALPHA

GLScene.OpenGL4

GL_SRC0_RGB

GLScene.OpenGL4

GL_SRC1_ALPHA

GLScene.OpenGL4

GL_SRC1_COLOR

GLScene.OpenGL4

GL_ARB_blend_func_extended

GL_SRC1_RGB

GLScene.OpenGL4

GL_SRC2_ALPHA

GLScene.OpenGL4

GL_SRC2_RGB

GLScene.OpenGL4

GL_SRC_ALPHA

GLScene.OpenGL4

GL_SRC_ALPHA_SATURATE

GLScene.OpenGL4

GL_SRC_COLOR

GLScene.OpenGL4

GL_SRGB

GLScene.OpenGL4

GL_SRGB8

GLScene.OpenGL4

GL_SRGB8_ALPHA8

GLScene.OpenGL4

GL_SRGB8_ALPHA8_EXT

GLScene.OpenGL4

GL_SRGB8_EXT

GLScene.OpenGL4

GL_SRGB_ALPHA

GLScene.OpenGL4

GL_SRGB_ALPHA_EXT

GLScene.OpenGL4

GL_SRGB_DECODE_ARB

GLScene.OpenGL4

GL_SRGB_EXT

GLScene.OpenGL4

GL_EXT_texture_sRGB

GL_SRGB_READ

GLScene.OpenGL4

GL_SRGB_WRITE

GLScene.OpenGL4

GL_STACK_OVERFLOW

GLScene.OpenGL4

GL_STACK_UNDERFLOW

GLScene.OpenGL4

GL_STANDARD_FONT_NAME_NV

GLScene.OpenGL4

GL_STATIC_ATI

GLScene.OpenGL4

GL_ATI_vertex_array_object

GL_STATIC_COPY

GLScene.OpenGL4

GL_STATIC_COPY_ARB

GLScene.OpenGL4

GL_STATIC_DRAW

GLScene.OpenGL4

GL_STATIC_DRAW_ARB

GLScene.OpenGL4

GL_STATIC_READ

GLScene.OpenGL4

GL_STATIC_READ_ARB

GLScene.OpenGL4

GL_STENCIL

GLScene.OpenGL4

GL_STENCIL_ATTACHMENT

GLScene.OpenGL4

GL_STENCIL_ATTACHMENT_EXT

GLScene.OpenGL4

GL_STENCIL_BACK_FAIL

GLScene.OpenGL4

GL_STENCIL_BACK_FAIL_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_FUNC

GLScene.OpenGL4

GL_STENCIL_BACK_FUNC_ATI

GLScene.OpenGL4

GL_ATI_separate_stencil

GL_STENCIL_BACK_OP_VALUE_AMD

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_FAIL

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_PASS

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_PASS_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_REF

GLScene.OpenGL4

GL_STENCIL_BACK_VALUE_MASK

GLScene.OpenGL4

GL_STENCIL_BACK_WRITEMASK

GLScene.OpenGL4

GL_STENCIL_BITS

GLScene.OpenGL4

GL_STENCIL_BUFFER

GLScene.OpenGL4

GL_STENCIL_BUFFER_BIT

GLScene.OpenGL4

GL_STENCIL_CLEAR_TAG_VALUE_EXT

GLScene.OpenGL4

GL_STENCIL_CLEAR_VALUE

GLScene.OpenGL4

GL_STENCIL_COMPONENTS

GLScene.OpenGL4

GL_STENCIL_FAIL

GLScene.OpenGL4

GL_STENCIL_FUNC

GLScene.OpenGL4

GL_STENCIL_INDEX

GLScene.OpenGL4

PixelFormat

GL_STENCIL_INDEX1

GLScene.OpenGL4

GL_STENCIL_INDEX16

GLScene.OpenGL4

GL_STENCIL_INDEX16_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX1_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX4

GLScene.OpenGL4

GL_STENCIL_INDEX4_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX8

GLScene.OpenGL4

GL_STENCIL_INDEX8_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX_EXT

GLScene.OpenGL4

GL_STENCIL_OP_VALUE_AMD

GLScene.OpenGL4

GL_STENCIL_PASS_DEPTH_FAIL

GLScene.OpenGL4

GL_STENCIL_PASS_DEPTH_PASS

GLScene.OpenGL4

GL_STENCIL_REF

GLScene.OpenGL4

GL_STENCIL_RENDERABLE

GLScene.OpenGL4

GL_STENCIL_TAG_BITS_EXT

GLScene.OpenGL4

GL_EXT_stencil_clear_tag

GL_STENCIL_TEST

GLScene.OpenGL4

GL_STENCIL_TEST_TWO_SIDE_EXT

GLScene.OpenGL4

GL_EXT_stencil_two_side

GL_STENCIL_VALUE_MASK

GLScene.OpenGL4

GL_STENCIL_WRITEMASK

GLScene.OpenGL4

GL_STEREO

GLScene.OpenGL4

GL_STORAGE_CACHED_APPLE

GLScene.OpenGL4

GL_STORAGE_CLIENT_APPLE

GLScene.OpenGL4

GL_STORAGE_PRIVATE_APPLE

GLScene.OpenGL4

GL_STORAGE_SHARED_APPLE

GLScene.OpenGL4

GL_STREAM_COPY

GLScene.OpenGL4

GL_STREAM_COPY_ARB

GLScene.OpenGL4

GL_STREAM_DRAW

GLScene.OpenGL4

GL_STREAM_DRAW_ARB

GLScene.OpenGL4

GL_STREAM_READ

GLScene.OpenGL4

GL_STREAM_READ_ARB

GLScene.OpenGL4

GL_STRICT_DEPTHFUNC_HINT_PGI

GLScene.OpenGL4

GL_STRICT_LIGHTING_HINT_PGI

GLScene.OpenGL4

GL_STRICT_SCISSOR_HINT_PGI

GLScene.OpenGL4

GL_SUBPIXEL_BITS

GLScene.OpenGL4

GL_SUBPIXEL_PRECISION_BIAS_X_BITS_NV

GLScene.OpenGL4

GL_SUBPIXEL_PRECISION_BIAS_Y_BITS_NV

GLScene.OpenGL4

GL_SUBSAMPLE_DISTANCE_AMD

GLScene.OpenGL4

GL_AMD_sample_positions

GL_SUBTRACT

GLScene.OpenGL4

GL_SUBTRACT_ARB

GLScene.OpenGL4

GL_SUB_ATI

GLScene.OpenGL4

GL_SUCCESS_NV

GLScene.OpenGL4

GL_SURFACE_MAPPED_NV

GLScene.OpenGL4

GL_SURFACE_REGISTERED_NV

GLScene.OpenGL4

GL_SURFACE_STATE_NV

GLScene.OpenGL4

GL_NV_vdpau_interop

GL_SWIZZLE_STQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STQ_DQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STRQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STRQ_DQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STR_ATI

GLScene.OpenGL4

GL_SWIZZLE_STR_DR_ATI

GLScene.OpenGL4

GL_SYNC_CL_EVENT_ARB

GLScene.OpenGL4

GL_ARB_cl_event

GL_SYNC_CL_EVENT_COMPLETE_ARB

GLScene.OpenGL4

GL_SYNC_CONDITION

GLScene.OpenGL4

GL_SYNC_FENCE

GLScene.OpenGL4

GL_SYNC_FLAGS

GLScene.OpenGL4

GL_SYNC_FLUSH_COMMANDS_BIT

GLScene.OpenGL4

GL_SYNC_GPU_COMMANDS_COMPLETE

GLScene.OpenGL4

GL_SYNC_STATUS

GLScene.OpenGL4

GL_SYNC_X11_FENCE_EXT

GLScene.OpenGL4

GL_EXT_x11_sync_object

GL_SYSTEM_FONT_NAME_NV

GLScene.OpenGL4

GL_T

GLScene.OpenGL4

GL_T2F_C3F_V3F

GLScene.OpenGL4

GL_T2F_C4F_N3F_V3F

GLScene.OpenGL4

GL_T2F_C4UB_V3F

GLScene.OpenGL4

GL_T2F_IUI_N3F_V2F_EXT

GLScene.OpenGL4

GL_T2F_IUI_N3F_V3F_EXT

GLScene.OpenGL4

GL_T2F_IUI_V2F_EXT

GLScene.OpenGL4

GL_T2F_IUI_V3F_EXT

GLScene.OpenGL4

GL_T2F_N3F_V3F

GLScene.OpenGL4

GL_T2F_V3F

GLScene.OpenGL4

GL_T4F_C4F_N3F_V4F

GLScene.OpenGL4

GL_T4F_V4F

GLScene.OpenGL4

GL_TABLE_TOO_LARGE

GLScene.OpenGL4

GL_TABLE_TOO_LARGE_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_coordinate_frame

GL_TANGENT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_TESSELLATION_FACTOR_AMD

GLScene.OpenGL4

GL_TESSELLATION_MODE_AMD

GLScene.OpenGL4

GL_TESS_CONTROL_OUTPUT_VERTICES

GLScene.OpenGL4

GL_TESS_CONTROL_PROGRAM_NV

GLScene.OpenGL4

GL_TESS_CONTROL_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_BIT

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_PATCHES

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_PATCHES_ARB

GLScene.OpenGL4

GL_TESS_CONTROL_SUBROUTINE

GLScene.OpenGL4

GL_TESS_CONTROL_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_TESS_CONTROL_TEXTURE

GLScene.OpenGL4

GL_TESS_EVALUATION_PROGRAM_NV

GLScene.OpenGL4

GL_TESS_EVALUATION_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_BIT

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_TESS_EVALUATION_SUBROUTINE

GLScene.OpenGL4

GL_TESS_EVALUATION_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_TESS_EVALUATION_TEXTURE

GLScene.OpenGL4

GL_TESS_GEN_MODE

GLScene.OpenGL4

GL_TESS_GEN_POINT_MODE

GLScene.OpenGL4

GL_TESS_GEN_SPACING

GLScene.OpenGL4

GL_TESS_GEN_VERTEX_ORDER

GLScene.OpenGL4

GL_TEXCOORD1_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD2_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD3_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD4_BIT_PGI

GLScene.OpenGL4

GL_TEXTURE

GLScene.OpenGL4

MatrixMode (for gl3.h, FBO attachment type)

GL_TEXTURE0

GLScene.OpenGL4

GL_VERSION_1_3

GL_TEXTURE0_ARB

GLScene.OpenGL4

GL_ARB_multitexture

GL_TEXTURE1

GLScene.OpenGL4

GL_TEXTURE10

GLScene.OpenGL4

GL_TEXTURE10_ARB

GLScene.OpenGL4

GL_TEXTURE11

GLScene.OpenGL4

GL_TEXTURE11_ARB

GLScene.OpenGL4

GL_TEXTURE12

GLScene.OpenGL4

GL_TEXTURE12_ARB

GLScene.OpenGL4

GL_TEXTURE13

GLScene.OpenGL4

GL_TEXTURE13_ARB

GLScene.OpenGL4

GL_TEXTURE14

GLScene.OpenGL4

GL_TEXTURE14_ARB

GLScene.OpenGL4

GL_TEXTURE15

GLScene.OpenGL4

GL_TEXTURE15_ARB

GLScene.OpenGL4

GL_TEXTURE16

GLScene.OpenGL4

GL_TEXTURE16_ARB

GLScene.OpenGL4

GL_TEXTURE17

GLScene.OpenGL4

GL_TEXTURE17_ARB

GLScene.OpenGL4

GL_TEXTURE18

GLScene.OpenGL4

GL_TEXTURE18_ARB

GLScene.OpenGL4

GL_TEXTURE19

GLScene.OpenGL4

GL_TEXTURE19_ARB

GLScene.OpenGL4

GL_TEXTURE1_ARB

GLScene.OpenGL4

GL_TEXTURE2

GLScene.OpenGL4

GL_TEXTURE20

GLScene.OpenGL4

GL_TEXTURE20_ARB

GLScene.OpenGL4

GL_TEXTURE21

GLScene.OpenGL4

GL_TEXTURE21_ARB

GLScene.OpenGL4

GL_TEXTURE22

GLScene.OpenGL4

GL_TEXTURE22_ARB

GLScene.OpenGL4

GL_TEXTURE23

GLScene.OpenGL4

GL_TEXTURE23_ARB

GLScene.OpenGL4

GL_TEXTURE24

GLScene.OpenGL4

GL_TEXTURE24_ARB

GLScene.OpenGL4

GL_TEXTURE25

GLScene.OpenGL4

GL_TEXTURE25_ARB

GLScene.OpenGL4

GL_TEXTURE26

GLScene.OpenGL4

GL_TEXTURE26_ARB

GLScene.OpenGL4

GL_TEXTURE27

GLScene.OpenGL4

GL_TEXTURE27_ARB

GLScene.OpenGL4

GL_TEXTURE28

GLScene.OpenGL4

GL_TEXTURE28_ARB

GLScene.OpenGL4

GL_TEXTURE29

GLScene.OpenGL4

GL_TEXTURE29_ARB

GLScene.OpenGL4

GL_TEXTURE2_ARB

GLScene.OpenGL4

GL_TEXTURE3

GLScene.OpenGL4

GL_TEXTURE30

GLScene.OpenGL4

GL_TEXTURE30_ARB

GLScene.OpenGL4

GL_TEXTURE31

GLScene.OpenGL4

GL_TEXTURE31_ARB

GLScene.OpenGL4

GL_TEXTURE3_ARB

GLScene.OpenGL4

GL_TEXTURE4

GLScene.OpenGL4

GL_TEXTURE4_ARB

GLScene.OpenGL4

GL_TEXTURE5

GLScene.OpenGL4

GL_TEXTURE5_ARB

GLScene.OpenGL4

GL_TEXTURE6

GLScene.OpenGL4

GL_TEXTURE6_ARB

GLScene.OpenGL4

GL_TEXTURE7

GLScene.OpenGL4

GL_TEXTURE7_ARB

GLScene.OpenGL4

GL_TEXTURE8

GLScene.OpenGL4

GL_TEXTURE8_ARB

GLScene.OpenGL4

GL_TEXTURE9

GLScene.OpenGL4

GL_TEXTURE9_ARB

GLScene.OpenGL4

GL_TEXTURE_1D

GLScene.OpenGL4

GL_TEXTURE_1D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_texture_array

GL_TEXTURE_1D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_2D

GLScene.OpenGL4

GL_TEXTURE_2D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_2D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_TEXTURE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_TEXTURE_3D

GLScene.OpenGL4

GL_TEXTURE_3D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_3D_EXT

GLScene.OpenGL4

GL_TEXTURE_4DSIZE_SGIS

GLScene.OpenGL4

GL_TEXTURE_4D_BINDING_SGIS

GLScene.OpenGL4

GL_TEXTURE_4D_SGIS

GLScene.OpenGL4

GL_TEXTURE_ALPHA_SIZE

GLScene.OpenGL4

GL_TEXTURE_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_ALPHA_TYPE

GLScene.OpenGL4

GL_TEXTURE_ALPHA_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_APPLICATION_MODE_EXT

GLScene.OpenGL4

GL_TEXTURE_BASE_LEVEL

GLScene.OpenGL4

GL_TEXTURE_BASE_LEVEL_SGIS

GLScene.OpenGL4

GL_TEXTURE_BINDING

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_MULTISAMPLE

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_3D

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_NV

GLScene.OpenGL4

GL_TEXTURE_BINDING_RENDERBUFFER_NV

GLScene.OpenGL4

GL_TEXTURE_BIT

GLScene.OpenGL4

GL_TEXTURE_BLUE_SIZE

GLScene.OpenGL4

GL_TEXTURE_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_BLUE_TYPE

GLScene.OpenGL4

GL_TEXTURE_BLUE_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_BORDER

GLScene.OpenGL4

GL_TEXTURE_BORDER_COLOR

GLScene.OpenGL4

GL_TEXTURE_BORDER_VALUES_NV

GLScene.OpenGL4

GL_TEXTURE_BUFFER

GLScene.OpenGL4

GL_TEXTURE_BUFFER_ARB

GLScene.OpenGL4

GL_ARB_texture_buffer_object

GL_TEXTURE_BUFFER_BINDING

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_texture_buffer_object

GL_TEXTURE_BUFFER_FORMAT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_FORMAT_ARB

GLScene.OpenGL4

GL_TEXTURE_BUFFER_FORMAT_EXT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_OFFSET

GLScene.OpenGL4

GL_TEXTURE_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_SIZE

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_CENTER_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_DEPTH_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_FRAME_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_LOD_OFFSET_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_OFFSET_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_VIRTUAL_DEPTH_SGIX

GLScene.OpenGL4

GL_TEXTURE_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_TEXTURE_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_SGI_texture_color_table

GL_TEXTURE_COLOR_WRITEMASK_SGIS

GLScene.OpenGL4

GL_SGIS_texture_color_mask

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB

GLScene.OpenGL4

GL_ARB_shadow_ambient

GL_TEXTURE_COMPARE_FUNC

GLScene.OpenGL4

GL_TEXTURE_COMPARE_FUNC_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPARE_MODE

GLScene.OpenGL4

GL_TEXTURE_COMPARE_MODE_ARB

GLScene.OpenGL4

GL_ARB_shadow

GL_TEXTURE_COMPARE_OPERATOR_SGIX

GLScene.OpenGL4

GL_TEXTURE_COMPARE_SGIX

GLScene.OpenGL4

GL_SGIX_shadow

GL_TEXTURE_COMPONENTS

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_IMAGE_SIZE

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPRESSION_HINT

GLScene.OpenGL4

GL_TEXTURE_COMPRESSION_HINT_ARB

GLScene.OpenGL4

GL_TEXTURE_CONSTANT_DATA_SUNX

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_POINTER

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_SIZE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_STRIDE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_TYPE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_NV

GLScene.OpenGL4

GL_TEXTURE_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_texture_multisample

GL_TEXTURE_CUBE_MAP

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_ARB_texture_cube_map_array

GL_TEXTURE_CUBE_MAP_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_SEAMLESS

GLScene.OpenGL4

GL_ARB_seamless_cube_map

GL_TEXTURE_DEFORMATION_BIT_SGIX

GLScene.OpenGL4

GL_FfdMaskSGIX

GL_TEXTURE_DEFORMATION_SGIX

GLScene.OpenGL4

GL_TEXTURE_DEPTH

GLScene.OpenGL4

GL_TEXTURE_DEPTH_EXT

GLScene.OpenGL4

GL_TEXTURE_DEPTH_SIZE

GLScene.OpenGL4

GL_TEXTURE_DEPTH_SIZE_ARB

GLScene.OpenGL4

GL_TEXTURE_DEPTH_TYPE

GLScene.OpenGL4

GL_TEXTURE_DEPTH_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_DS_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_DT_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_ENV

GLScene.OpenGL4

GL_TEXTURE_ENV_BIAS_SGIX

GLScene.OpenGL4

GL_SGIX_texture_add_env

GL_TEXTURE_ENV_COLOR

GLScene.OpenGL4

GL_TEXTURE_ENV_MODE

GLScene.OpenGL4

GL_TEXTURE_FETCH_BARRIER_BIT

GLScene.OpenGL4

GL_TEXTURE_FETCH_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TEXTURE_FILTER4_SIZE_SGIS

GLScene.OpenGL4

GL_TEXTURE_FILTER_CONTROL

GLScene.OpenGL4

GL_TEXTURE_FILTER_CONTROL_EXT

GLScene.OpenGL4

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS

GLScene.OpenGL4

GL_TEXTURE_FLOAT_COMPONENTS_NV

GLScene.OpenGL4

GL_TEXTURE_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_TEXTURE_GATHER

GLScene.OpenGL4

GL_TEXTURE_GATHER_SHADOW

GLScene.OpenGL4

GL_TEXTURE_GEN_MODE

GLScene.OpenGL4

GL_TEXTURE_GEN_Q

GLScene.OpenGL4

GL_TEXTURE_GEN_R

GLScene.OpenGL4

GL_TEXTURE_GEN_S

GLScene.OpenGL4

GL_TEXTURE_GEN_T

GLScene.OpenGL4

GL_TEXTURE_GEQUAL_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_GREEN_SIZE

GLScene.OpenGL4

GL_TEXTURE_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_GREEN_TYPE

GLScene.OpenGL4

GL_TEXTURE_GREEN_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_HEIGHT

GLScene.OpenGL4

GL_TEXTURE_HI_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_IMAGE_FORMAT

GLScene.OpenGL4

GL_TEXTURE_IMAGE_TYPE

GLScene.OpenGL4

GL_TEXTURE_IMMUTABLE_FORMAT

GLScene.OpenGL4

GL_ARB_texture_storage

GL_TEXTURE_IMMUTABLE_LEVELS

GLScene.OpenGL4

GL_TEXTURE_INDEX_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_SIZE

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_TYPE

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_INTERNAL_FORMAT

GLScene.OpenGL4

GL_TEXTURE_LEQUAL_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_LIGHTING_MODE_HP

GLScene.OpenGL4

GL_HP_texture_lighting

GL_TEXTURE_LIGHT_EXT

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_EXT

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_S_SGIX

GLScene.OpenGL4

GL_SGIX_texture_lod_bias

GL_TEXTURE_LOD_BIAS_T_SGIX

GLScene.OpenGL4

GL_TEXTURE_LO_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_SIZE

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_TYPE

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_MAG_FILTER

GLScene.OpenGL4

TextureParameterName

GL_TEXTURE_MAG_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_MATERIAL_FACE_EXT

GLScene.OpenGL4

GL_TEXTURE_MATERIAL_PARAMETER_EXT

GLScene.OpenGL4

GL_TEXTURE_MATRIX

GLScene.OpenGL4

GL_TEXTURE_MAX_ANISOTROPY

GLScene.OpenGL4

GL_TEXTURE_MAX_ANISOTROPY_EXT

GLScene.OpenGL4

GL_EXT_texture_filter_anisotropic

GL_TEXTURE_MAX_CLAMP_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_MAX_CLAMP_S_SGIX

GLScene.OpenGL4

GL_SGIX_texture_coordinate_clamp

GL_TEXTURE_MAX_CLAMP_T_SGIX

GLScene.OpenGL4

GL_TEXTURE_MAX_LEVEL

GLScene.OpenGL4

GL_TEXTURE_MAX_LEVEL_SGIS

GLScene.OpenGL4

GL_TEXTURE_MAX_LOD

GLScene.OpenGL4

GL_TEXTURE_MAX_LOD_SGIS

GLScene.OpenGL4

GL_TEXTURE_MIN_FILTER

GLScene.OpenGL4

GL_TEXTURE_MIN_LOD

GLScene.OpenGL4

GL_TEXTURE_MIN_LOD_SGIS

GLScene.OpenGL4

GL_SGIS_texture_lod

GL_TEXTURE_MULTI_BUFFER_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_texture_multi_buffer

GL_TEXTURE_NORMAL_EXT

GLScene.OpenGL4

GL_TEXTURE_POST_SPECULAR_HP

GLScene.OpenGL4

GL_TEXTURE_PRE_SPECULAR_HP

GLScene.OpenGL4

GL_TEXTURE_PRIORITY

GLScene.OpenGL4

GL_TEXTURE_PRIORITY_EXT

GLScene.OpenGL4

GL_EXT_texture_object

GL_TEXTURE_RANGE_LENGTH_APPLE

GLScene.OpenGL4

GL_APPLE_texture_range

GL_TEXTURE_RANGE_POINTER_APPLE

GLScene.OpenGL4

GL_TEXTURE_RECTANGLE

GLScene.OpenGL4

GL_TEXTURE_RECTANGLE_ARB

GLScene.OpenGL4

GL_ARB_texture_rectangle

GL_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GL_EXT_texture_rectangle

GL_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_NV_texture_rectangle

GL_TEXTURE_REDUCTION_MODE_ARB

GLScene.OpenGL4

GL_ARB_texture_filter_minmax

GL_TEXTURE_RED_SIZE

GLScene.OpenGL4

GL_TEXTURE_RED_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_RED_TYPE

GLScene.OpenGL4

GL_TEXTURE_RED_TYPE_ARB

GLScene.OpenGL4

GL_ARB_texture_float

GL_TEXTURE_RENDERBUFFER_DATA_STORE_BINDING_NV

GLScene.OpenGL4

GL_TEXTURE_RENDERBUFFER_NV

GLScene.OpenGL4

GL_TEXTURE_RESIDENT

GLScene.OpenGL4

GL_TEXTURE_RESIDENT_EXT

GLScene.OpenGL4

GL_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_TEXTURE_SHADER_NV

GLScene.OpenGL4

GL_TEXTURE_SHADOW

GLScene.OpenGL4

GL_TEXTURE_SHARED_SIZE

GLScene.OpenGL4

GL_TEXTURE_SHARED_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_SPARSE_ARB

GLScene.OpenGL4

GL_ARB_SPARSE_TEXTURE

GL_TEXTURE_SRGB_DECODE_EXT

GLScene.OpenGL4

GL_EXT_texture_sRGB_decode

GL_TEXTURE_STACK_DEPTH

GLScene.OpenGL4

GL_TEXTURE_STENCIL_SIZE

GLScene.OpenGL4

GL_TEXTURE_STENCIL_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_STORAGE_HINT_APPLE

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_A

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_A_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_B

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_B_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_G

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_G_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_R

GLScene.OpenGL4

GL_ARB_texture_swizzle

GL_TEXTURE_SWIZZLE_RGBA

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_RGBA_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_R_EXT

GLScene.OpenGL4

GL_EXT_texture_swizzle

GL_TEXTURE_TARGET

GLScene.OpenGL4

GL_TEXTURE_TOO_LARGE_EXT

GLScene.OpenGL4

GL_TEXTURE_UNSIGNED_REMAP_MODE_NV

GLScene.OpenGL4

GL_NV_texture_expand_normal

GL_TEXTURE_UPDATE_BARRIER_BIT

GLScene.OpenGL4

GL_TEXTURE_UPDATE_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TEXTURE_VIEW

GLScene.OpenGL4

GL_TEXTURE_VIEW_MIN_LAYER

GLScene.OpenGL4

GL_TEXTURE_VIEW_MIN_LEVEL

GLScene.OpenGL4

GL_TEXTURE_VIEW_NUM_LAYERS

GLScene.OpenGL4

GL_TEXTURE_VIEW_NUM_LEVELS

GLScene.OpenGL4

GL_TEXTURE_WIDTH

GLScene.OpenGL4

GetTextureParameter

GL_TEXTURE_WRAP_Q_SGIS

GLScene.OpenGL4

GL_TEXTURE_WRAP_R

GLScene.OpenGL4

GL_TEXTURE_WRAP_R_EXT

GLScene.OpenGL4

GL_TEXTURE_WRAP_S

GLScene.OpenGL4

GL_TEXTURE_WRAP_T

GLScene.OpenGL4

GL_TEXT_FRAGMENT_SHADER_ATI

GLScene.OpenGL4

GL_ATI_text_fragment_shader

GL_TIMEOUT_EXPIRED

GLScene.OpenGL4

GL_TIMEOUT_IGNORED

GLScene.OpenGL4

GL_TIMESTAMP

GLScene.OpenGL4

GL_TIME_ELAPSED

GLScene.OpenGL4

GL_ARB_timer_query

GL_TIME_ELAPSED_EXT

GLScene.OpenGL4

GL_EXT_timer_query

GL_TOP_LEVEL_ARRAY_SIZE

GLScene.OpenGL4

GL_TOP_LEVEL_ARRAY_STRIDE

GLScene.OpenGL4

GL_TRACK_MATRIX_NV

GLScene.OpenGL4

GL_TRACK_MATRIX_TRANSFORM_NV

GLScene.OpenGL4

GL_TRANSFORM_BIT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK

GLScene.OpenGL4

GL_ARB_texture_buffer_object_rgb32 GL_ARB_transform_feedback2

GL_TRANSFORM_FEEDBACK_ACTIVE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BARRIER_BIT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BINDING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BINDING_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_INDEX

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_NV

GLScene.OpenGL4

GL_NV_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_STRIDE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_NV

GLScene.OpenGL4

GL_NV_transform_feedback2

GL_TRANSFORM_FEEDBACK_OVERFLOW

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_OVERFLOW_ARB

GLScene.OpenGL4

GL_ARB_transform_feedback_overflow_query

GL_TRANSFORM_FEEDBACK_PAUSED

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_RECORD_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW_ARB

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT

GLScene.OpenGL4

GL_TRANSFORM_HINT_APPLE

GLScene.OpenGL4

GL_APPLE_transform_hint

GL_TRANSLATE_2D_NV

GLScene.OpenGL4

GL_TRANSLATE_3D_NV

GLScene.OpenGL4

GL_TRANSLATE_X_NV

GLScene.OpenGL4

GL_TRANSLATE_Y_NV

GLScene.OpenGL4

GL_TRANSPOSE_AFFINE_2D_NV

GLScene.OpenGL4

GL_TRANSPOSE_AFFINE_3D_NV

GLScene.OpenGL4

GL_TRANSPOSE_COLOR_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_COLOR_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_CURRENT_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_MODELVIEW_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB

GLScene.OpenGL4

GL_ARB_transpose_matrix

GL_TRANSPOSE_NV

GLScene.OpenGL4

GL_TRANSPOSE_PROGRAM_MATRIX_EXT

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTION_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTION_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTIVE_2D_NV

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTIVE_3D_NV

GLScene.OpenGL4

GL_TRANSPOSE_TEXTURE_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_TEXTURE_MATRIX_ARB

GLScene.OpenGL4

GL_TRIANGLES

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY_ARB

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY_EXT

GLScene.OpenGL4

GL_TRIANGLE_FAN

GLScene.OpenGL4

GL_TRIANGLE_LIST_SUN

GLScene.OpenGL4

GL_TRIANGLE_MESH_SUN

GLScene.OpenGL4

GL_TRIANGLE_STRIP

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY_ARB

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY_EXT

GLScene.OpenGL4

GL_TRIANGULAR_NV

GLScene.OpenGL4

GL_TRUE

GLScene.OpenGL4

GL_TYPE

GLScene.OpenGL4

GL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGL4

GL_UNDEFINED_APPLE

GLScene.OpenGL4

GL_UNDEFINED_VERTEX

GLScene.OpenGL4

GL_UNIFORM

GLScene.OpenGL4

GL_UNIFORM_ARRAY_STRIDE

GLScene.OpenGL4

GL_UNIFORM_ATOMIC_COUNTER_BUFFER_INDEX

GLScene.OpenGL4

GL_UNIFORM_BARRIER_BIT

GLScene.OpenGL4

GL_UNIFORM_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_UNIFORM_BLOCK

GLScene.OpenGL4

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS

GLScene.OpenGL4

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES

GLScene.OpenGL4

GL_UNIFORM_BLOCK_BINDING

GLScene.OpenGL4

GL_UNIFORM_BLOCK_DATA_SIZE

GLScene.OpenGL4

GL_UNIFORM_BLOCK_INDEX

GLScene.OpenGL4

GL_UNIFORM_BLOCK_NAME_LENGTH

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_UNIFORM_BUFFER

GLScene.OpenGL4

GL_ARB_uniform_buffer_object

GL_UNIFORM_BUFFER_BINDING

GLScene.OpenGL4

GL_UNIFORM_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_EXT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_SIZE

GLScene.OpenGL4

GL_UNIFORM_BUFFER_START

GLScene.OpenGL4

GL_UNIFORM_IS_ROW_MAJOR

GLScene.OpenGL4

GL_UNIFORM_MATRIX_STRIDE

GLScene.OpenGL4

GL_UNIFORM_NAME_LENGTH

GLScene.OpenGL4

GL_UNIFORM_OFFSET

GLScene.OpenGL4

GL_UNIFORM_SIZE

GLScene.OpenGL4

GL_UNIFORM_TYPE

GLScene.OpenGL4

GL_UNKNOWN_CONTEXT_RESET

GLScene.OpenGL4

GL_UNKNOWN_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_UNPACK_ALIGNMENT

GLScene.OpenGL4

GL_UNPACK_CLIENT_STORAGE_APPLE

GLScene.OpenGL4

GL_APPLE_client_storage

GL_UNPACK_CMYK_HINT_EXT

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_DEPTH

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_ARB_compressed_texture_pixel_storage

GL_UNPACK_CONSTANT_DATA_SUNX

GLScene.OpenGL4

GL_SUNX_constant_data

GL_UNPACK_IMAGE_DEPTH_SGIS

GLScene.OpenGL4

GL_UNPACK_IMAGE_HEIGHT

GLScene.OpenGL4

GL_UNPACK_IMAGE_HEIGHT_EXT

GLScene.OpenGL4

GL_UNPACK_LSB_FIRST

GLScene.OpenGL4

GL_UNPACK_RESAMPLE_OML

GLScene.OpenGL4

GL_UNPACK_RESAMPLE_SGIX

GLScene.OpenGL4

GL_UNPACK_ROW_BYTES_APPLE

GLScene.OpenGL4

GL_UNPACK_ROW_LENGTH

GLScene.OpenGL4

GL_UNPACK_SKIP_IMAGES

GLScene.OpenGL4

GL_UNPACK_SKIP_IMAGES_EXT

GLScene.OpenGL4

GL_UNPACK_SKIP_PIXELS

GLScene.OpenGL4

GL_UNPACK_SKIP_ROWS

GLScene.OpenGL4

GL_UNPACK_SKIP_VOLUMES_SGIS

GLScene.OpenGL4

GL_UNPACK_SUBSAMPLE_RATE_SGIX

GLScene.OpenGL4

GL_UNPACK_SWAP_BYTES

GLScene.OpenGL4

GL_UNSIGNALED

GLScene.OpenGL4

GL_UNSIGNED_BYTE

GLScene.OpenGL4

GL_UNSIGNED_BYTE_2_3_3_REV

GLScene.OpenGL4

GL_UNSIGNED_BYTE_3_3_2

GLScene.OpenGL4

GL_VERSION_1_2

GL_UNSIGNED_BYTE_3_3_2_EXT

GLScene.OpenGL4

GL_EXT_packed_pixels

GL_UNSIGNED_IDENTITY_NV

GLScene.OpenGL4

GL_UNSIGNED_INT

GLScene.OpenGL4

GL_UNSIGNED_INT16_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_AMD

GLScene.OpenGL4

GL_UNSIGNED_INT64_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC2_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC3_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC4_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_10F_11F_11F_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_10_10_10_2

GLScene.OpenGL4

GL_UNSIGNED_INT_10_10_10_2_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_2_10_10_10_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_5_9_9_9_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_5_9_9_9_REV_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_ATOMIC_COUNTER

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_RECT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_3D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_3D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_BUFFER

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_S8_S8_8_8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_3D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_3D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC2

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC2_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC3

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC3_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC4

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC4_EXT

GLScene.OpenGL4

GL_UNSIGNED_INVERT_NV

GLScene.OpenGL4

GL_UNSIGNED_NORMALIZED

GLScene.OpenGL4

GL_UNSIGNED_NORMALIZED_ARB

GLScene.OpenGL4

GL_UNSIGNED_SHORT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_1_5_5_5_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4_EXT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_5_5_1

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_5_5_1_EXT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_6_5

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_6_5_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_8_8_APPLE

GLScene.OpenGL4

GL_UNSIGNED_SHORT_8_8_REV_APPLE

GLScene.OpenGL4

GL_UPPER_LEFT

GLScene.OpenGL4

GL_USE_MISSING_GLYPH_NV

GLScene.OpenGL4

GL_UTF16_NV

GLScene.OpenGL4

GL_UTF8_NV

GLScene.OpenGL4

GL_V2F

GLScene.OpenGL4

GL_V3F

GLScene.OpenGL4

GL_VALIDATE_STATUS

GLScene.OpenGL4

GL_VARIABLE_A_NV

GLScene.OpenGL4

GL_VARIABLE_B_NV

GLScene.OpenGL4

GL_VARIABLE_C_NV

GLScene.OpenGL4

GL_VARIABLE_D_NV

GLScene.OpenGL4

GL_VARIABLE_E_NV

GLScene.OpenGL4

GL_VARIABLE_F_NV

GLScene.OpenGL4

GL_VARIABLE_G_NV

GLScene.OpenGL4

GL_VARIANT_ARRAY_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VARIANT_DATATYPE_EXT

GLScene.OpenGL4

GL_VARIANT_EXT

GLScene.OpenGL4

GL_VARIANT_VALUE_EXT

GLScene.OpenGL4

GL_VBO_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_ATI_meminfo

GL_VECTOR_EXT

GLScene.OpenGL4

GL_VENDOR

GLScene.OpenGL4

StringName

GL_VERSION

GLScene.OpenGL4

GL_VERTEX23_BIT_PGI

GLScene.OpenGL4

GL_VERTEX4_BIT_PGI

GLScene.OpenGL4

GL_VERTEX_ARRAY

GLScene.OpenGL4

GL_VERTEX_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_BINDING

GLScene.OpenGL4

GL_ARB_vertex_array_object

GL_VERTEX_ARRAY_BINDING_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_array_object

GL_VERTEX_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_VERTEX_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_vertex_array

GL_VERTEX_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_IBM_vertex_array_lists

GL_VERTEX_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_VERTEX_ARRAY_OBJECT_AMD

GLScene.OpenGL4

GL_VERTEX_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_VERTEX_ARRAY_POINTER

GLScene.OpenGL4

GL_VERTEX_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_array_range

GL_VERTEX_ARRAY_RANGE_LENGTH_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_NV

GLScene.OpenGL4

GL_NV_vertex_array_range

GL_VERTEX_ARRAY_RANGE_POINTER_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_POINTER_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_VALID_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV

GLScene.OpenGL4

GL_NV_vertex_array_range2

GL_VERTEX_ARRAY_SIZE

GLScene.OpenGL4

GL_VERTEX_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_STORAGE_HINT_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_STRIDE

GLScene.OpenGL4

GL_VERTEX_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_TYPE

GLScene.OpenGL4

GL_VERTEX_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY0_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY10_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY11_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY12_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY13_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY14_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY15_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY1_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY2_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY3_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY4_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY5_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY6_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY7_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY8_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY9_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT

GLScene.OpenGL4

GL_ARB_shader_image_load_store

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_DIVISOR

GLScene.OpenGL4

GL_VERSION_3_3

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB

GLScene.OpenGL4

GL_ARB_instanced_arrays

GL_VERTEX_ATTRIB_ARRAY_ENABLED

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_INTEGER

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT

GLScene.OpenGL4

GL_EXT_gpu_shader4

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_LONG

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_POINTER

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_SIZE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_STRIDE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_TYPE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV

GLScene.OpenGL4

GL_NV_vertex_buffer_unified_memory

GL_VERTEX_ATTRIB_BINDING

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_program_evaluators

GL_VERTEX_ATTRIB_MAP1_COEFF_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_DOMAIN_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_ORDER_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_SIZE_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_COEFF_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_DOMAIN_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_ORDER_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_SIZE_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_RELATIVE_OFFSET

GLScene.OpenGL4

GL_VERTEX_BINDING_DIVISOR

GLScene.OpenGL4

GL_VERTEX_BINDING_OFFSET

GLScene.OpenGL4

GL_VERTEX_BINDING_STRIDE

GLScene.OpenGL4

GL_VERTEX_BLEND_ARB

GLScene.OpenGL4

GL_VERTEX_CONSISTENT_HINT_PGI

GLScene.OpenGL4

GL_VERTEX_DATA_HINT_PGI

GLScene.OpenGL4

GL_PGI_vertex_hints

GL_VERTEX_ID_NV

GLScene.OpenGL4

GL_VERTEX_PRECLIP_HINT_SGIX

GLScene.OpenGL4

GL_VERTEX_PRECLIP_SGIX

GLScene.OpenGL4

GL_SGIX_vertex_preclip

GL_VERTEX_PROGRAM_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_BINDING_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_NV

GLScene.OpenGL4

GL_NV_vertex_program

GL_VERTEX_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE_NV

GLScene.OpenGL4

GL_VERTEX_SHADER

GLScene.OpenGL4

GL_VERTEX_SHADER_ARB

GLScene.OpenGL4

GL_ARB_vertex_shader

GL_VERTEX_SHADER_BINDING_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_BIT

GLScene.OpenGL4

GL_ARB_separate_shader_objects

GL_VERTEX_SHADER_EXT

GLScene.OpenGL4

GL_EXT_vertex_shader

GL_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_VERTEX_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_OPTIMIZED_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SOURCE_ATI

GLScene.OpenGL4

GL_VERTEX_STATE_PROGRAM_NV

GLScene.OpenGL4

GL_VERTEX_STREAM0_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM1_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM2_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM3_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM4_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM5_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM6_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM7_ATI

GLScene.OpenGL4

GL_VERTEX_SUBROUTINE

GLScene.OpenGL4

GL_VERTEX_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_VERTEX_TEXTURE

GLScene.OpenGL4

GL_VERTEX_WEIGHTING_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VERTICAL_LINE_TO_NV

GLScene.OpenGL4

GL_VERTICES_SUBMITTED

GLScene.OpenGL4

GL_VERTICES_SUBMITTED_ARB

GLScene.OpenGL4

GL_ARB_pipeline_statistics_query

GL_VIBRANCE_BIAS_NV

GLScene.OpenGL4

GL_VIBRANCE_SCALE_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_BINDING_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_INTERNAL_FORMAT_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_NV

GLScene.OpenGL4

GL_NV_video_capture

GL_VIDEO_BUFFER_PITCH_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FIELD_LOWER_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FIELD_UPPER_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FRAME_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FRAME_WIDTH_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_SURFACE_ORIGIN_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_TO_422_SUPPORTED_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MATRIX_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MAX_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MIN_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_OFFSET_NV

GLScene.OpenGL4

GL_VIEWPORT

GLScene.OpenGL4

GL_VIEWPORT_BIT

GLScene.OpenGL4

GL_VIEWPORT_BOUNDS_RANGE

GLScene.OpenGL4

GL_VIEWPORT_INDEX_PROVOKING_VERTEX

GLScene.OpenGL4

GL_VIEWPORT_SUBPIXEL_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_128_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_16_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_24_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_32_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_48_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_64_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_8_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_96_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_BPTC_FLOAT

GLScene.OpenGL4

GL_VIEW_CLASS_BPTC_UNORM

GLScene.OpenGL4

GL_VIEW_CLASS_RGTC1_RED

GLScene.OpenGL4

GL_VIEW_CLASS_RGTC2_RG

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT1_RGB

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT1_RGBA

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT3_RGBA

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT5_RGBA

GLScene.OpenGL4

GL_VIEW_COMPATIBILITY_CLASS

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_INDEX_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_X_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_Y_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_Z_ARB

GLScene.OpenGL4

GL_VOLATILE_APPLE

GLScene.OpenGL4

GL_WAIT_FAILED

GLScene.OpenGL4

GL_WEIGHTED_AVERAGE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_WEIGHT_SUM_UNITY_ARB

GLScene.OpenGL4

GL_WIDE_LINE_HINT_PGI

GLScene.OpenGL4

GL_WRAP_BORDER_SUN

GLScene.OpenGL4

GL_SUN_convolution_border_modes

GL_WRITE_DISCARD_NV

GLScene.OpenGL4

GL_WRITE_ONLY

GLScene.OpenGL4

GL_WRITE_ONLY_ARB

GLScene.OpenGL4

GL_WRITE_PIXEL_DATA_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_WRITE_PIXEL_DATA_RANGE_NV

GLScene.OpenGL4

GL_NV_pixel_data_range

GL_WRITE_PIXEL_DATA_RANGE_POINTER_NV

GLScene.OpenGL4

GL_W_EXT

GLScene.OpenGL4

GL_XOR

GLScene.OpenGL4

GL_X_EXT

GLScene.OpenGL4

GL_YCBAYCR8A_4224_NV

GLScene.OpenGL4

GL_YCBCR_422_APPLE

GLScene.OpenGL4

GL_APPLE_ycbcr_422

GL_YCBYCR8_422_NV

GLScene.OpenGL4

GL_YCRCBA_SGIX

GLScene.OpenGL4

GL_YCRCB_422_SGIX

GLScene.OpenGL4

GL_SGIX_ycrcb

GL_YCRCB_444_SGIX

GLScene.OpenGL4

GL_YCRCB_SGIX

GLScene.OpenGL4

GL_SGIX_ycrcba

GL_Y_EXT

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4A12Z4Y12Z4CR12Z4A12_4224_NV

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4CR12_444_NV

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4Y12Z4CR12_422_NV

GLScene.OpenGL4

GL_Z6Y10Z6CB10Z6A10Z6Y10Z6CR10Z6A10_4224_NV

GLScene.OpenGL4

GL_Z6Y10Z6CB10Z6Y10Z6CR10_422_NV

GLScene.OpenGL4

GL_ZERO

GLScene.OpenGL4

BlendingFactorDest

GL_ZERO_EXT

GLScene.OpenGL4

GL_ZERO_TO_ONE

GLScene.OpenGL4

GL_ZOOM_X

GLScene.OpenGL4

GL_ZOOM_Y

GLScene.OpenGL4

GL_Z_EXT

GLScene.OpenGL4

GRADIENT_TABLE_SIZE

GLS.ProcTextures

GravitationalConstant

GLS.PhysFields

GuiNullRect

GLS.Gui

G_DRAG

GLS.VerletTypes

HIDE_NODE

Formats.m3DSConst

HIDE_TRACK_TAG

Formats.m3DSConst

HIERARCHY

Formats.m3DSConst

HIGHPASS_DEFAULT_GAIN

OpenAL.Import

HIGHPASS_DEFAULT_GAINLF

OpenAL.Import

HIGHPASS_MAX_GAIN

OpenAL.Import

HIGHPASS_MAX_GAINLF

OpenAL.Import

HIGHPASS_MIN_GAIN

OpenAL.Import

Highpass filter

HIGHPASS_MIN_GAINLF

OpenAL.Import

HiShadowBiasMin3DS

Formats.m3DSConst

noninclusive minimum value for low shadow bias setting HI_SHADOW_BIAS chunk

HI_SHADOW_BIAS

Formats.m3DSConst

HotTrackTagMax3DS

Formats.m3DSConst

Minimum hot spot angle

HotTrackTagMin3DS

Formats.m3DSConst

Maximum camera FOV HOT_TRACK_TAG_KEY

HOT_TRACK_TAG

Formats.m3DSConst

HOT_TRACK_TAG_KEY

Formats.m3DSConst

ICCOMPRESSFRAMES_PADDING

Formats.VFW

*********************************************************************** ***********************************************************************

ICCOMPRESS_KEYFRAME

Formats.VFW

*********************************************************************** ***********************************************************************

ICDECOMPRESS_HURRYUP

Formats.VFW

*********************************************************************** ***********************************************************************

ICDECOMPRESS_NOTKEYFRAME

Formats.VFW

repeat last frame

ICDECOMPRESS_NULLFRAME

Formats.VFW

this frame is before real start

ICDECOMPRESS_PREROLL

Formats.VFW

don't draw just update screen

ICDECOMPRESS_UPDATE

Formats.VFW

don't draw just buffer (hurry up!)

ICDRAW_ANIMATE

Formats.VFW

draw to a HDC/HWND

ICDRAW_BUFFER

Formats.VFW

used to render data not draw it

ICDRAW_CONTINUE

Formats.VFW

expect palette animation

ICDRAW_FULLSCREEN

Formats.VFW

test for support

ICDRAW_HDC

Formats.VFW

draw to full screen

ICDRAW_HURRYUP

Formats.VFW

*********************************************************************** ***********************************************************************

ICDRAW_MEMORYDC

Formats.VFW

draw is a continuation of previous draw

ICDRAW_NOTKEYFRAME

Formats.VFW

repeat last frame

ICDRAW_NULLFRAME

Formats.VFW

this frame is before real start

ICDRAW_PREROLL

Formats.VFW

don't draw just update screen

ICDRAW_QUERY

Formats.VFW

*********************************************************************** ***********************************************************************

ICDRAW_RENDER

Formats.VFW

We're updating, as opposed to playing

ICDRAW_UPDATE

Formats.VFW

don't draw just buffer (hurry up!)

ICDRAW_UPDATING

Formats.VFW

DC is offscreen, by the way

ICERR_ABORT

Formats.VFW

ICERR_BADBITDEPTH

Formats.VFW

ICERR_BADFLAGS

Formats.VFW

ICERR_BADFORMAT

Formats.VFW

ICERR_BADHANDLE

Formats.VFW

ICERR_BADIMAGESIZE

Formats.VFW

ICERR_BADPARAM

Formats.VFW

ICERR_BADSIZE

Formats.VFW

ICERR_CANTUPDATE

Formats.VFW

ICERR_CUSTOM

Formats.VFW

ICERR_DONTDRAW

Formats.VFW

ICERR_ERROR

Formats.VFW

ICERR_GOTOKEYFRAME

Formats.VFW

ICERR_INTERNAL

Formats.VFW

ICERR_MEMORY

Formats.VFW

ICERR_NEWPALETTE

Formats.VFW

ICERR_OK

Formats.VFW

audc

ICERR_STOPDRAWING

Formats.VFW

ICERR_UNSUPPORTED

Formats.VFW

ICINSTALL_DRIVER

Formats.VFW

lParam is a DriverProc (function ptr)

ICINSTALL_DRIVERW

Formats.VFW

lParam is a HDRVR (driver handle)

ICINSTALL_FUNCTION

Formats.VFW

ICINSTALL_HDRV

Formats.VFW

lParam is a driver name (string)

ICINSTALL_UNICODE

Formats.VFW

– Values for wFlags of ICInstall ——————————————-

ICMF_ABOUT_QUERY

Formats.VFW

ICMF_CHOOSE_ALLCOMPRESSORS

Formats.VFW

allow expanded preview dialog

ICMF_CHOOSE_DATARATE

Formats.VFW

show KeyFrame Every box

ICMF_CHOOSE_KEYFRAME

Formats.VFW

defines for uiFlags

ICMF_CHOOSE_PREVIEW

Formats.VFW

show DataRate box

ICMF_COMPVARS_VALID

Formats.VFW

FLAGS for dwFlags element of COMPVARS structure: set this flag if you initialize COMPVARS before calling ICCompressorChoose

ICMF_CONFIGURE_QUERY

Formats.VFW

– Query macros ————————————————————-

ICMODE_COMPRESS

Formats.VFW

– Values for dwFlags of ICOpen() ——————————————-

ICMODE_DECOMPRESS

Formats.VFW

ICMODE_DRAW

Formats.VFW

ICMODE_FASTCOMPRESS

Formats.VFW

ICMODE_FASTDECOMPRESS

Formats.VFW

ICMODE_QUERY

Formats.VFW

ICM_ABOUT

Formats.VFW

show the configure dialog

ICM_COMPRESS

Formats.VFW

begin a series of compress calls.

ICM_COMPRESS_BEGIN

Formats.VFW

query support for compress

ICM_COMPRESS_END

Formats.VFW

compress a frame

ICM_COMPRESS_FRAMES_INFO

Formats.VFW

end a series of decompress calls

ICM_COMPRESS_GET_FORMAT

Formats.VFW

***********************************************************************
ICM specific messages.
***********************************************************************

ICM_COMPRESS_GET_SIZE

Formats.VFW

get compress format or size

ICM_COMPRESS_QUERY

Formats.VFW

get output size

ICM_CONFIGURE

Formats.VFW

Query info about the compressor

ICM_DECOMPRESS

Formats.VFW

start a series of decompress calls

ICM_DECOMPRESSEX

Formats.VFW

start a series of decompress calls

ICM_DECOMPRESSEX_BEGIN

Formats.VFW

get the default value for key frames

ICM_DECOMPRESSEX_END

Formats.VFW

decompress a frame

ICM_DECOMPRESSEX_QUERY

Formats.VFW

start a series of decompress calls

ICM_DECOMPRESS_BEGIN

Formats.VFW

query support for dempress

ICM_DECOMPRESS_END

Formats.VFW

decompress a frame

ICM_DECOMPRESS_GET_FORMAT

Formats.VFW

end of a series of compress calls.

ICM_DECOMPRESS_GET_PALETTE

Formats.VFW

fill in the DIB color table

ICM_DECOMPRESS_QUERY

Formats.VFW

get decompress format or size

ICM_DECOMPRESS_SET_PALETTE

Formats.VFW

end a series of decompress calls

ICM_DRAW

Formats.VFW

get value of decompress clock

ICM_DRAW_BEGIN

Formats.VFW

query support for dempress

ICM_DRAW_CHANGEPALETTE

Formats.VFW

Like ICGetDisplayFormat

ICM_DRAW_END

Formats.VFW

stop decompress clock

ICM_DRAW_FLUSH

Formats.VFW

realize palette for drawing

ICM_DRAW_GETTIME

Formats.VFW

end a series of draw calls

ICM_DRAW_GET_PALETTE

Formats.VFW

start a series of draw calls

ICM_DRAW_QUERY

Formats.VFW

fill in the DIB color table

ICM_DRAW_REALIZE

Formats.VFW

set correct value for decompress clock

ICM_DRAW_RENDERBUFFER

Formats.VFW

clear out buffered frames

ICM_DRAW_SETTIME

Formats.VFW

drawing window has moved or hidden

ICM_DRAW_START

Formats.VFW

get the palette needed for drawing

ICM_DRAW_START_PLAY

Formats.VFW

draw undrawn things in queue

ICM_DRAW_STOP

Formats.VFW

start decompress clock

ICM_DRAW_STOP_PLAY

Formats.VFW

start of a play

ICM_DRAW_SUGGESTFORMAT

Formats.VFW

end of a play

ICM_DRAW_WINDOW

Formats.VFW

generalized "render" message

ICM_FRAMERATE

Formats.VFW

– Constants for ICM_SET: —————————————————

ICM_GET

Formats.VFW

Tell the driver something

ICM_GETBUFFERSWANTED

Formats.VFW

for animating palette

ICM_GETDEFAULTKEYFRAMERATE

Formats.VFW

ask about prebuffering

ICM_GETDEFAULTQUALITY

Formats.VFW

show the about box

ICM_GETINFO

Formats.VFW

Set compressor state

ICM_GETQUALITY

Formats.VFW

get the default value for quality

ICM_GETSTATE

Formats.VFW

***********************************************************************
messages.
***********************************************************************

ICM_KEYFRAMERATE

Formats.VFW

FrmR

ICM_RESERVED

Formats.VFW

ICM_RESERVED_HIGH

Formats.VFW

ICM_RESERVED_LOW

Formats.VFW

ICM_SET

Formats.VFW

set the default value for quality

ICM_SETQUALITY

Formats.VFW

get the current value for quality

ICM_SETSTATE

Formats.VFW

Get compressor state

ICM_SET_STATUS_PROC

Formats.VFW

tell about compress to come

ICM_USER

Formats.VFW

*********************************************************************** ***********************************************************************

ICQUALITY_DEFAULT

Formats.VFW

ICQUALITY_HIGH

Formats.VFW

ICQUALITY_LOW

Formats.VFW

– quality flags ————————————————————

ICSTATUS_END

Formats.VFW

l = % done

ICSTATUS_ERROR

Formats.VFW

ICSTATUS_START

Formats.VFW

– Messages for Status callback ———————————————

ICSTATUS_STATUS

Formats.VFW

ICSTATUS_YIELD

Formats.VFW

l = error string (LPSTR)

ICTYPE_AUDIO

Formats.VFW

vidc

ICTYPE_VIDEO

Formats.VFW

ICVERSION

Formats.VFW

*************************************************************************** * * COMPMAN - Installable Compression Manager. * ***************************************************************************

IdentityHmgDblMatrix

GLScene.VectorGeometry

IdentityHmgMatrix

GLScene.VectorGeometry

IdentityMatrix

GLScene.VectorGeometry

IdentityQuaternion

GLScene.VectorGeometry

Quaternions

IDS_CAP_AUDIO_DROP_ERROR

Formats.VFW

"Error: Unable to initialize compressor."

IDS_CAP_AVI_DRAWDIB_ERROR

Formats.VFW

"Error: No audio data captured.\nCheck audio card settings."

IDS_CAP_AVI_INIT_ERROR

Formats.VFW

"Error while recording"

IDS_CAP_BEGIN

Formats.VFW

– String IDs from status and error callbacks ——————————-

IDS_CAP_CANTOPEN

Formats.VFW

"pal"

IDS_CAP_COMPRESSOR_ERROR

Formats.VFW

"Error: Unable to draw this data format."

IDS_CAP_DEFAVIEXT

Formats.VFW

"Error saving frame '%s'"

IDS_CAP_DEFPALEXT

Formats.VFW

"avi"

IDS_CAP_DRIVER_ERROR

Formats.VFW

"SaveAs: %2ld%% Hit Escape to abort."

IDS_CAP_END

Formats.VFW

"Capture Start"

IDS_CAP_ERRORDIBSAVE

Formats.VFW

"Error saving palette '%s'"

IDS_CAP_ERRORPALOPEN

Formats.VFW

"File '%s' exists – overwrite it?"

IDS_CAP_ERRORPALSAVE

Formats.VFW

"Error opening palette '%s'"

IDS_CAP_FILEEXISTS

Formats.VFW

"Out of memory"

IDS_CAP_FILE_OPEN_ERROR

Formats.VFW

"Error: Bad video size."

IDS_CAP_FILE_WRITE_ERROR

Formats.VFW

"Error: Cannot open capture file."

IDS_CAP_INFO

Formats.VFW

"Capture End"

IDS_CAP_MCI_CANT_STEP_ERROR

Formats.VFW

"Error: Unable to access MCI device."

IDS_CAP_MCI_CONTROL_ERROR

Formats.VFW

"Warning: Using default palette."

IDS_CAP_NODISKSPACE

Formats.VFW

"Unable to write to file '%s'.\nDisk may be full."

IDS_CAP_NO_AUDIO_CAP_ERROR

Formats.VFW

"Error: Unable to step MCI device."

IDS_CAP_NO_FRAME_CAP_ERROR

Formats.VFW

"Error: Unable to initialize for capture."

IDS_CAP_NO_PALETTE_WARN

Formats.VFW

"Warning: No frames captured.\nConfirm that vertical sync interrupts\nare configured and enabled."

IDS_CAP_OUTOFMEM

Formats.VFW

"%s"

IDS_CAP_READONLYFILE

Formats.VFW

"An error occurred while trying to run VidEdit."

IDS_CAP_RECORDING_ERROR

Formats.VFW

"Error: Cannot write to capture file. Disk may be full."

IDS_CAP_RECORDING_ERROR2

Formats.VFW

"Error: Cannot write to capture file. Data rate too high or disk full."

IDS_CAP_SAVEASPERCENT

Formats.VFW

"Set File Size"

IDS_CAP_SEQ_MSGSTART

Formats.VFW

"Cannot open '%s'"

IDS_CAP_SEQ_MSGSTOP

Formats.VFW

"Select OK to start capture\nof video sequence\nto %s."

IDS_CAP_SETFILESIZE

Formats.VFW

"There is no space to create a capture file on the specified device."

IDS_CAP_STAT_CAP_AUDIO

Formats.VFW

"Captured %ld frames"

IDS_CAP_STAT_CAP_FINI

Formats.VFW

"Setting up for capture - Please wait"

IDS_CAP_STAT_CAP_INIT

Formats.VFW

"Overlay window"

IDS_CAP_STAT_CAP_L_FRAMES

Formats.VFW

"%ld frames"

IDS_CAP_STAT_FRAMESDROPPED

Formats.VFW

"Captured %d.%03d sec. %ld frames (%ld dropped) (%d.%03d fps)"

IDS_CAP_STAT_I_FRAMES

Formats.VFW

"Computing optimal palette"

IDS_CAP_STAT_LIVE_MODE

Formats.VFW

– Status string IDs ——————————————————–

IDS_CAP_STAT_L_FRAMES

Formats.VFW

"%d frames"

IDS_CAP_STAT_OPTPAL_BUILD

Formats.VFW

"Building palette map"

IDS_CAP_STAT_OVERLAY_MODE

Formats.VFW

"Live window"

IDS_CAP_STAT_PALETTE_BUILD

Formats.VFW

"Finished capture, now writing frame %ld"

IDS_CAP_STAT_VIDEOAUDIO

Formats.VFW

"Captured %ld frames (%ld dropped) %d.%03d sec."

IDS_CAP_STAT_VIDEOCURRENT

Formats.VFW

"Capturing audio"

IDS_CAP_STAT_VIDEOONLY

Formats.VFW

"Captured %d.%03d sec. %ld frames (%ld dropped) (%d.%03d fps). %ld audio bytes (%d,%03d sps)"

IDS_CAP_VIDEDITERR

Formats.VFW

"Hit ESCAPE or click to end capture"

IDS_CAP_VIDEO_ADD_ERROR

Formats.VFW

"Error: Cannot prepare video buffers."

IDS_CAP_VIDEO_ALLOC_ERROR

Formats.VFW

"Error: Cannot open the video input device."

IDS_CAP_VIDEO_OPEN_ERROR

Formats.VFW

"Error: Bad wave size."

IDS_CAP_VIDEO_PREPARE_ERROR

Formats.VFW

"Error: Out of memory for video buffers."

IDS_CAP_VIDEO_SIZE_ERROR

Formats.VFW

"Error: Cannot add video buffers."

IDS_CAP_WAVE_ADD_ERROR

Formats.VFW

"Error: Cannot prepare wave buffers."

IDS_CAP_WAVE_ALLOC_ERROR

Formats.VFW

"Error: Cannot open the wave input device.\nCheck sample size, frequency, and channels."

IDS_CAP_WAVE_OPEN_ERROR

Formats.VFW

Driver specific error message

IDS_CAP_WAVE_PREPARE_ERROR

Formats.VFW

"Error: Out of memory for wave buffers."

IDS_CAP_WAVE_SIZE_ERROR

Formats.VFW

"Error: Cannot add wave buffers."

IDS_CAP_WRITEERROR

Formats.VFW

"The file '%s' is a read-only file."

ID_ALPH

Formats.LWO

SMOOTHING ANGLE RADIANS

ID_ANIM

Formats.LWO

IMAGE SEQUENCE

ID_BBOX

Formats.LWO

CLIP

ID_BRIT

Formats.LWO

CONTRAST

ID_BTEX

Formats.LWO

LUMINANCE TEXTURE

ID_CLIP

Formats.LWO

ENVELOPE

ID_COLR

Formats.LWO

Surfaces chunk

ID_CONT

Formats.LWO

COLOR CYCLING STILL

ID_CRVS

Formats.LWO

Polygons chunk

ID_CTEX

Formats.LWO

ALPHA MODE

ID_DESC

Formats.LWO

BOUNDING BOX

ID_DIFF

Formats.LWO

Luminosity

ID_DTEX

Formats.LWO

COLOR TEXTURE

ID_EDGE

Formats.LWO

REFRACTIVE INDEX

ID_ENVL

Formats.LWO

DISCONTINUOUS VERTEX MAP

ID_FLAG

Formats.LWO

Color chunk

ID_FLYR

Formats.LWO

IMAGE SEQUENCE

ID_FORM

Formats.LWO

Lightwave scene file

ID_GAMMA

Formats.LWO

HUE

ID_GLOS

Formats.LWO

Transparency

ID_HUE

Formats.LWO

SATURATION

ID_ICON

Formats.LWO

TEXT

ID_IFLT

Formats.LWO

NEGATIVE IMAGE

ID_IMCC

Formats.LWO

FLYER SEQUENCE

ID_IMSQ

Formats.LWO

ID_ISEQ

Formats.LWO

STILL IMAGE FILENAME

ID_LAYR

Formats.LWO

Lightwave Layered Object

ID_LTEX

Formats.LWO

TRANSPARENCY TEXTURE

ID_LUMI

Formats.LWO

Surface Flags

ID_LWLO

Formats.LWO

Lightwave Object version 1.0 - 5.x

ID_LWO2

Formats.LWO

ID_LWOB

Formats.LWO

IFF Form

ID_LWSC

Formats.LWO

NULL ID

ID_NEGA

Formats.LWO

GAMMA

ID_NULL

Formats.LWO

ID_PCHS

Formats.LWO

Curves chunk

ID_PFLT

Formats.LWO

IMAGE PLUG-IN FILTER

ID_PNTS

Formats.LWO

LAYER

ID_POLS

Formats.LWO

Surface Names chunk

ID_PTAG

Formats.LWO

TAGS?

ID_REFL

Formats.LWO

Specular

ID_RFLT

Formats.LWO

Sidedness

ID_RFOP

Formats.LWO

REFLECTION MODE (PRE 6.0)

ID_RIMG

Formats.LWO

REFLECTION OPTIONS

ID_RIND

Formats.LWO

REFLECTION MAP SEAM ANGLE

ID_RSAN

Formats.LWO

REFLECTION IMAGE

ID_RTEX

Formats.LWO

SPECULAR TEXTURE

ID_SATR

Formats.LWO

BRIGHTNESS

ID_SDAT

Formats.LWO

ID_SHDR

Formats.LWO

ID_SIDE

Formats.LWO

Glossiness SmallInt

ID_SMAN

Formats.LWO

EDGE TRANSPARENCY THRESHOLD

ID_SPEC

Formats.LWO

Diffuse

ID_SRFS

Formats.LWO

Points chunk

ID_STCC

Formats.LWO

PLUGIN ANIMATION

ID_STEX

Formats.LWO

DIFFUSE TEXTURE

ID_STIL

Formats.LWO

NAME

ID_SURF

Formats.LWO

Patches chunk

ID_TAAS

Formats.LWO

TEXTURE WRAP

ID_TAGS

Formats.LWO

VERTEX MAP

ID_TALP

Formats.LWO

TEXTURE IMG

ID_TAMP

Formats.LWO

TEXTURE VALUE

ID_TCLR

Formats.LWO

TEXTURE REFERENCE

ID_TCTR

Formats.LWO

TEXTURE SIZE

ID_TEXT

Formats.LWO

DESCRIPTION

ID_TFAL

Formats.LWO

TEXTURE CENTER

ID_TFLG

Formats.LWO

BUMP TEXTURE

ID_TFP0

Formats.LWO

TEXTURE AMPLITUDE

ID_TFP1

Formats.LWO

TEXTURE PARAMETERS

ID_TFP2

Formats.LWO

ID_TFRQ

Formats.LWO

ID_TIMG

Formats.LWO

ID_TIP0

Formats.LWO

ID_TIP1

Formats.LWO

ID_TIP2

Formats.LWO

ID_TOPC

Formats.LWO

ID_TRAN

Formats.LWO

Reflective

ID_TREF

Formats.LWO

TEXTURE VALUE

ID_TSIZ

Formats.LWO

TEXTURE FLAGS

ID_TSP0

Formats.LWO

ID_TSP1

Formats.LWO

ID_TSP2

Formats.LWO

ID_TTEX

Formats.LWO

REFLECTIION TEXTURE

ID_TVAL

Formats.LWO

TEXTURE COLOR

ID_TVEL

Formats.LWO

TEXTURE FALLOFF

ID_TWRP

Formats.LWO

ID_VDIF

Formats.LWO

Luminosity

ID_VLUM

Formats.LWO

Transparency

ID_VMAD

Formats.LWO

POLYGON TAG MAP

ID_VMAP

Formats.LWO

OBJECT

ID_VRFL

Formats.LWO

Specularity

ID_VSPC

Formats.LWO

Diffuse

ID_VTRN

Formats.LWO

Reflective

IID_IAVIEditStream

Formats.VFW

IID_IAVIFile

Formats.VFW

– GUIDs ——————————————————————–

IID_IAVIStream

Formats.VFW

IID_IAVIStreaming

Formats.VFW

IID_IGetFrame

Formats.VFW

IMSQ_FLAG_INTERLACE

Formats.LWO

IMSQ_FLAG_LOOP

Formats.LWO

infotypeDIGITIZATION_TIME

Formats.VFW

– New information chunk IDs ————————————————

infotypeSMPTE_TIME

Formats.VFW

mmioFOURCC ('I','D','I','T')

InitFaceArray3DS

Formats.m3DSConst

InitMatArray3DS

Formats.m3DSConst

InitNoExtras3DS

Formats.m3DSConst

Flags for initflags parameter

InitProcData3DS

Formats.m3DSConst

InitSmoothArray3DS

Formats.m3DSConst

InitTextArray3DS

Formats.m3DSConst

InitVertexArray3DS

Formats.m3DSConst

InitVFlagArray3DS

Formats.m3DSConst

InstanceNameStrMax3DS

Formats.m3DSConst

Maximum node name string size INSTANCE_NAME

INSTANCE_NAME

Formats.m3DSConst

INTERPCT

Formats.m3DSConst

IntPercentageMax3DS

Formats.m3DSConst

maximum color value in a channel INT_PERCENTAGE

INT_PERCENTAGE

Formats.m3DSConst

INVALID_CUFFT_HANDLE

CUDA.FourierTransform

INVALID_MODULEHANDLE_VALUE

ModuleLoader

Value designating an unassigned TModuleHandle od a failed loading

IsChunk

Formats.m3DSConst

kBrushes

Formats.Q3BSP

Stores the info of world models

kBrushSides

Formats.Q3BSP

Stores the brushes info (for collision)

kEntities

Formats.Q3BSP

KeyUsesBias3DS

Formats.m3DSConst

KeyUsesCont3DS

Formats.m3DSConst

KeyUsesEaseFrom3DS

Formats.m3DSConst

KeyUsesEaseTo3DS

Formats.m3DSConst

KeyUsesTension3DS

Formats.m3DSConst

flags the face as being at a texture coord v wrap seam flags used by the rflags field of the keyheader3DS structure

kFaces

Formats.Q3BSP

Stores the shader files (blending, anims..)

KFBiasMax3DS

Formats.m3DSConst

Minimum key spline bias

KFBiasMin3DS

Formats.m3DSConst

Maximum key spline continuity

KfBlurBranch3DS

Formats.m3DSConst

KFContinuityMax3DS

Formats.m3DSConst

Minimum key spline continuity

KFContinuityMin3DS

Formats.m3DSConst

Maximum key spline tension

KFCURTIME

Formats.m3DSConst

KFDATA

Formats.m3DSConst

Keyframe Chunk IDs

KFEaseFromMax3DS

Formats.m3DSConst

Minimum key spline ease from

KFEaseFromMin3DS

Formats.m3DSConst

Maximum key spline ease to

KFEaseToMax3DS

Formats.m3DSConst

Minimum key spline ease to

KFEaseToMin3DS

Formats.m3DSConst

Maximum key spline bias

KfFastNode3DS

Formats.m3DSConst

KFHDR

Formats.m3DSConst

KFHdrStrMax3DS

Formats.m3DSConst

Maximum lens size for camera KFHDR

KfHideNode3DS

Formats.m3DSConst

KfMorphMtl3DS

Formats.m3DSConst

KfMorphOb3DS

Formats.m3DSConst

KfMotionBlur3DS

Formats.m3DSConst

KfNodeAutoSmooth3DS

Formats.m3DSConst

KfNodeFrozen3DS

Formats.m3DSConst

KfNodeHasPath3DS

Formats.m3DSConst

For the flags2 field

KfNodeOff3DS

Formats.m3DSConst

flag settings for TKFMesh3DS, TKFOmni3DS, TKFCamera3DS, TKFAmbient and TKFSpot3DS ml: these flags correspond directly to NODE_RENDOB_HIDE etc. (see below), I don't know what these duplications are for... for the flags field

KFSEG

Formats.m3DSConst

KFTensionMax3DS

Formats.m3DSConst

Minimum key spline tension

KFTensionMin3DS

Formats.m3DSConst

Maximum morph smoothing angle Keyframe Spline Limits

kLeafBrushes

Formats.Q3BSP

Stores the leaf's indices into the faces

kLeafFaces

Formats.Q3BSP

Stores the leafs of the nodes

kLeafs

Formats.Q3BSP

Stores the BSP nodes

kLightmaps

Formats.Q3BSP

Stores the faces for the level

kLightVolumes

Formats.Q3BSP

Stores the lightmaps for the level

kMaxLumps

Formats.Q3BSP

Stores PVS and cluster info (visibility)

kMeshVerts

Formats.Q3BSP

Stores the level vertices

kModels

Formats.Q3BSP

Stores the leaf's indices into the brushes

KMOD_ALT

SDL.Import

KMOD_CAPS

SDL.Import

KMOD_CTRL

SDL.Import

KMOD_GUI

SDL.Import

KMOD_LALT

SDL.Import

KMOD_LCTRL

SDL.Import

KMOD_LGUI

SDL.Import

KMOD_LSHIFT

SDL.Import

KMOD_MODE

SDL.Import

KMOD_NONE

SDL.Import

** * Enumeration of valid key mods (possibly OR'd together). *

KMOD_NUM

SDL.Import

KMOD_RALT

SDL.Import

KMOD_RCTRL

SDL.Import

KMOD_RESERVED

SDL.Import

KMOD_RGUI

SDL.Import

KMOD_RSHIFT

SDL.Import

KMOD_SHIFT

SDL.Import

kNodes

Formats.Q3BSP

Stores the splitting planes

KNoID

Formats.m3DSConst

Maximum fall off angle

kPlanes

Formats.Q3BSP

Stores texture information

kShaders

Formats.Q3BSP

Stores the model vertices offsets

kTextures

Formats.Q3BSP

Stores player/object positions, etc...

kVertices

Formats.Q3BSP

Stores the brush surfaces info

kVisData

Formats.Q3BSP

Stores extra world lighting information

LayerFogBgnd

Formats.m3DSConst

Fog Flags

LAYER_FOG

Formats.m3DSConst

lcl_major

GLS.SceneForm

lcl_minor

GLS.SceneForm

lcl_release

GLS.SceneForm

lcl_release

GLS.Screen

libEGL

GLScene.OpenGL4

libGLES2

GLScene.OpenGL4

LibOpenCL

OpenCL.Import

LIGHT_NODE_TAG

Formats.m3DSConst

LineLen

GLS.FileOBJ

Allocate memory for the current line in chunks of LineLen Bytes.

LIN_COLOR_24

Formats.m3DSConst

LIN_COLOR_F

Formats.m3DSConst

listtypeAVIHEADER

Formats.VFW

mmioFOURCC('A', 'V', 'I', ' ')

listtypeAVIMOVIE

Formats.VFW

mmioFOURCC('s', 't', 'r', 'n')

listtypeAVIRECORD

Formats.VFW

mmioFOURCC('m', 'o', 'v', 'i')

listtypeSTREAMHEADER

Formats.VFW

mmioFOURCC('a', 'v', 'i', 'h')

llMax

GLScene.Logger

llMedium

GLScene.Logger

llMin

GLScene.Logger

LMAGIC

Formats.m3DSConst

LoShadowBiasMin3DS

Formats.m3DSConst

noninclusive minimum value for master scale LO_SHADOW_BIAS chunk

LOWPASS_DEFAULT_GAIN

OpenAL.Import

LOWPASS_DEFAULT_GAINHF

OpenAL.Import

LOWPASS_MAX_GAIN

OpenAL.Import

LOWPASS_MAX_GAINHF

OpenAL.Import

LOWPASS_MIN_GAIN

OpenAL.Import

Filter ranges and defaults. Lowpass filter

LOWPASS_MIN_GAINHF

OpenAL.Import

LO_SHADOW_BIAS

Formats.m3DSConst

L_TARGET_NODE_TAG

Formats.m3DSConst

M3DMAGIC

Formats.m3DSConst

3DS file Chunk IDs

M3D_KFVERSION

Formats.m3DSConst

M3D_VERSION

Formats.m3DSConst

MARK_NODE

Formats.m3DSConst

MasterScaleMin3DS

Formats.m3DSConst

MASTER_SCALE chunk

MASTER_SCALE

Formats.m3DSConst

MatACubicAMax3DS

Formats.m3DSConst

minimum reflection map aliasing

MatACubicAMin3DS

Formats.m3DSConst

minimum frame skip count

MatACubicFMin3DS

Formats.m3DSConst

maximum shading value MAT_ACUBIC_FMIN

MATMAGIC

Formats.m3DSConst

MatMapNameStrMax3DS

Formats.m3DSConst

Maximum floating point percentage MAT_MAPNAME

MatNameStrMax3DS

Formats.m3DSConst

maximum string length for filename MAT_NAME

MatShadingMax3DS

Formats.m3DSConst

minimum shading value

MatShadingMin3DS

Formats.m3DSConst

maximum string length for material name MAT_SHADING

MAT_ACUBIC

Formats.m3DSConst

MAT_ADDITIVE

Formats.m3DSConst

MAT_AMBIENT

Formats.m3DSConst

MAT_BUMPMAP

Formats.m3DSConst

MAT_BUMPMASK

Formats.m3DSConst

MAT_BUMP_PERCENT

Formats.m3DSConst

MAT_DECAL

Formats.m3DSConst

MAT_DIFFUSE

Formats.m3DSConst

MAT_ENTRY

Formats.m3DSConst

Material Chunk IDs

MAT_FACEMAP

Formats.m3DSConst

MAT_MAPNAME

Formats.m3DSConst

MAT_MAP_ANG

Formats.m3DSConst

MAT_MAP_BCOL

Formats.m3DSConst

MAT_MAP_COL1

Formats.m3DSConst

MAT_MAP_COL2

Formats.m3DSConst

MAT_MAP_GCOL

Formats.m3DSConst

MAT_MAP_RCOL

Formats.m3DSConst

MAT_MAP_TEXBLUR

Formats.m3DSConst

MAT_MAP_TEXBLUR_OLD

Formats.m3DSConst

MAT_MAP_TILING

Formats.m3DSConst

MAT_MAP_TILINGOLD

Formats.m3DSConst

MAT_MAP_UOFFSET

Formats.m3DSConst

MAT_MAP_USCALE

Formats.m3DSConst

MAT_MAP_VOFFSET

Formats.m3DSConst

MAT_MAP_VSCALE

Formats.m3DSConst

MAT_NAME

Formats.m3DSConst

MAT_OPACMAP

Formats.m3DSConst

MAT_OPACMASK

Formats.m3DSConst

MAT_PHONGSOFT

Formats.m3DSConst

MAT_REFBLUR

Formats.m3DSConst

MAT_REFLMAP

Formats.m3DSConst

MAT_REFLMASK

Formats.m3DSConst

MAT_SELFIMAP

Formats.m3DSConst

MAT_SELFIMASK

Formats.m3DSConst

MAT_SELF_ILLUM

Formats.m3DSConst

MAT_SELF_ILPCT

Formats.m3DSConst

MAT_SHADING

Formats.m3DSConst

MAT_SHIN2PCT

Formats.m3DSConst

MAT_SHIN3PCT

Formats.m3DSConst

MAT_SHININESS

Formats.m3DSConst

MAT_SHINMAP

Formats.m3DSConst

MAT_SHINMASK

Formats.m3DSConst

MAT_SPECMAP

Formats.m3DSConst

MAT_SPECMASK

Formats.m3DSConst

MAT_SPECULAR

Formats.m3DSConst

MAT_SUPERSMP

Formats.m3DSConst

MAT_SXP_BUMP_DATA

Formats.m3DSConst

MAT_SXP_BUMP_MASKDATA

Formats.m3DSConst

MAT_SXP_OPAC_DATA

Formats.m3DSConst

MAT_SXP_OPAC_MASKDATA

Formats.m3DSConst

MAT_SXP_REFL_MASKDATA

Formats.m3DSConst

MAT_SXP_SELFI_DATA

Formats.m3DSConst

MAT_SXP_SELFI_MASKDATA

Formats.m3DSConst

MAT_SXP_SHIN_DATA

Formats.m3DSConst

MAT_SXP_SHIN_MASKDATA

Formats.m3DSConst

MAT_SXP_SPEC_DATA

Formats.m3DSConst

MAT_SXP_SPEC_MASKDATA

Formats.m3DSConst

MAT_SXP_TEXT2_DATA

Formats.m3DSConst

MAT_SXP_TEXT2_MASKDATA

Formats.m3DSConst

MAT_SXP_TEXT_DATA

Formats.m3DSConst

MAT_SXP_TEXT_MASKDATA

Formats.m3DSConst

MAT_TEX2MAP

Formats.m3DSConst

MAT_TEX2MASK

Formats.m3DSConst

MAT_TEXMAP

Formats.m3DSConst

MAT_TEXMASK

Formats.m3DSConst

MAT_TRANSPARENCY

Formats.m3DSConst

MAT_TWO_SIDE

Formats.m3DSConst

MAT_USE_REFBLUR

Formats.m3DSConst

MAT_USE_XPFALL

Formats.m3DSConst

MAT_WIRE

Formats.m3DSConst

MAT_WIREABS

Formats.m3DSConst

MAT_WIRESIZE

Formats.m3DSConst

MAT_XPFALL

Formats.m3DSConst

MAT_XPFALLIN

Formats.m3DSConst

MaxColorAttachments

GLS.FBORenderer

MaxComp

GLScene.VectorGeometry

MaxDouble

GLScene.VectorGeometry

MaxExtended

GLScene.VectorGeometry

MaxSingle

GLScene.VectorGeometry

MaxTriangles

GLScene.Triangulation

MaxUserClasses

ODE.Import

ExportInitODEMarker

MaxVertices

GLScene.Triangulation

Set these as applicable

MaxVideoModes

GLS.Screen

MAX_HARDWARE_LIGHT

GLS.State

MAX_HARDWARE_TEXTURE_UNIT

GLS.State

MAX_HARDWARE_UNIFORM_BUFFER_BINDING

GLS.State

MAX_MATRIX_STACK_DEPTH

GLScene.PipelineTransform

MAX_MD2_FRAMES

Formats.MD2

MAX_MD2_SKINNAME

Formats.MD2

MAX_MD2_SKINS

Formats.MD2

MAX_MD2_TRIANGLES

Formats.MD2

MAX_MD2_VERTICES

Formats.MD2

MAX_MS3D_GROUPS

GLS.FileMS3D

MAX_MS3D_JOINTS

GLS.FileMS3D

MAX_MS3D_KEYFRAMES

GLS.FileMS3D

MAX_MS3D_MATERIALS

GLS.FileMS3D

MAX_MS3D_TRIANGLES

GLS.FileMS3D

MAX_MS3D_VERTICES

GLS.FileMS3D

MAX_OBJECT_STACK_DEPTH

GLS.Selection

MAX_SHADER_LIGHT

GLS.State

MAX_TEXTURES

Formats.Q3BSP

MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_NV_vertex_program3

MCIWNDF_NOAUTOSIZEMOVIE

Formats.VFW

no toolbar

MCIWNDF_NOAUTOSIZEWINDOW

Formats.VFW

– Window styles ————————————————————

MCIWNDF_NOERRORDLG

Formats.VFW

Give a record button

MCIWNDF_NOMENU

Formats.VFW

when window size changes

MCIWNDF_NOOPEN

Formats.VFW

Show Error Dlgs for MCI cmds?

MCIWNDF_NOPLAYBAR

Formats.VFW

when movie size changes

MCIWNDF_NOTIFYALL

Formats.VFW

tell parent of an error

MCIWNDF_NOTIFYANSI

Formats.VFW

tell all

MCIWNDF_NOTIFYERROR

Formats.VFW

tell parent of size change

MCIWNDF_NOTIFYMEDIA

Formats.VFW

tell parent of media change

MCIWNDF_NOTIFYMEDIAA

Formats.VFW

The MEDIA notification includes a text string. To receive notifications in ANSI instead of unicode set the MCIWNDF_NOTIFYANSI style bit. The macro below includes this bit by default unless you define UNICODE in your application.

MCIWNDF_NOTIFYMEDIAW

Formats.VFW

tell parent of media change

MCIWNDF_NOTIFYMODE

Formats.VFW

show all

MCIWNDF_NOTIFYPOS

Formats.VFW

tell parent of mode change

MCIWNDF_NOTIFYSIZE

Formats.VFW

tell parent of pos change

MCIWNDF_RECORD

Formats.VFW

MCIWNDF_SHOWALL

Formats.VFW

show mode in caption

MCIWNDF_SHOWMODE

Formats.VFW

show position in caption

MCIWNDF_SHOWNAME

Formats.VFW

no popup menu from RBUTTONDOWN

MCIWNDF_SHOWPOS

Formats.VFW

show name in caption

MCIWNDM_CAN_CONFIG

Formats.VFW

MCIWNDM_CAN_EJECT

Formats.VFW

MCIWNDM_CAN_PLAY

Formats.VFW

MCIWNDM_CAN_RECORD

Formats.VFW

MCIWNDM_CAN_SAVE

Formats.VFW

MCIWNDM_CAN_WINDOW

Formats.VFW

MCIWNDM_CHANGESTYLES

Formats.VFW

MCIWNDM_EJECT

Formats.VFW

MCIWNDM_GETACTIVETIMER

Formats.VFW

MCIWNDM_GETALIAS

Formats.VFW

MCIWNDM_GETDEVICE

Formats.VFW

MCIWNDM_GETDEVICEA

Formats.VFW

MCIWNDM_GETDEVICEID

Formats.VFW

all the text-related messages are defined out of order above (they need to be defined before the MCIWndOpen() macros

MCIWNDM_GETDEVICEW

Formats.VFW

MCIWNDM_GETEND

Formats.VFW

MCIWNDM_GETERROR

Formats.VFW

MCIWNDM_GETERRORA

Formats.VFW

MCIWNDM_GETERRORW

Formats.VFW

MCIWNDM_GETFILENAME

Formats.VFW

MCIWNDM_GETFILENAMEA

Formats.VFW

MCIWNDM_GETFILENAMEW

Formats.VFW

MCIWNDM_GETINACTIVETIMER

Formats.VFW

MCIWNDM_GETLENGTH

Formats.VFW

MCIWNDM_GETMODE

Formats.VFW

MCIWNDM_GETMODEA

Formats.VFW

MCIWNDM_GETMODEW

Formats.VFW

MCIWNDM_GETPALETTE

Formats.VFW

MCIWNDM_GETPOSITION

Formats.VFW

MCIWNDM_GETPOSITIONA

Formats.VFW

MCIWNDM_GETPOSITIONW

Formats.VFW

MCIWNDM_GETREPEAT

Formats.VFW

MCIWNDM_GETSPEED

Formats.VFW

MCIWNDM_GETSTART

Formats.VFW

MCIWNDM_GETSTYLES

Formats.VFW

MCIWNDM_GETTIMEFORMAT

Formats.VFW

MCIWNDM_GETTIMEFORMATA

Formats.VFW

MCIWNDM_GETTIMEFORMATW

Formats.VFW

MCIWNDM_GETVOLUME

Formats.VFW

MCIWNDM_GETZOOM

Formats.VFW

MCIWNDM_GET_DEST

Formats.VFW

MCIWNDM_GET_SOURCE

Formats.VFW

MCIWNDM_NEW

Formats.VFW

MCIWNDM_NEWA

Formats.VFW

MCIWNDM_NEWW

Formats.VFW

MCIWNDM_NOTIFYERROR

Formats.VFW

wp = hwnd, lp = fn

MCIWNDM_NOTIFYMEDIA

Formats.VFW

wp = hwnd

MCIWNDM_NOTIFYMODE

Formats.VFW

– Messages MCIWND will send to an app ————————————–

MCIWNDM_NOTIFYPOS

Formats.VFW

wp = hwnd, lp = mode

MCIWNDM_NOTIFYSIZE

Formats.VFW

wp = hwnd, lp = pos

MCIWNDM_OPEN

Formats.VFW

MCIWNDM_OPENA

Formats.VFW

MCIWNDM_OPENINTERFACE

Formats.VFW

MCIWNDM_OPENW

Formats.VFW

MCIWNDM_PALETTEKICK

Formats.VFW

MCIWNDM_PLAYFROM

Formats.VFW

MCIWNDM_PLAYREVERSE

Formats.VFW

MCIWNDM_PLAYTO

Formats.VFW

MCIWNDM_PUT_DEST

Formats.VFW

MCIWNDM_PUT_SOURCE

Formats.VFW

MCIWNDM_REALIZE

Formats.VFW

MCIWNDM_RETURNSTRING

Formats.VFW

MCIWNDM_RETURNSTRINGA

Formats.VFW

MCIWNDM_RETURNSTRINGW

Formats.VFW

MCIWNDM_SENDSTRING

Formats.VFW

– Map defaults to A ——————————————————–

MCIWNDM_SENDSTRINGA

Formats.VFW

– Define both A and W messages ———————————————

MCIWNDM_SENDSTRINGW

Formats.VFW

MCIWNDM_SETACTIVETIMER

Formats.VFW

MCIWNDM_SETINACTIVETIMER

Formats.VFW

MCIWNDM_SETOWNER

Formats.VFW

MCIWNDM_SETPALETTE

Formats.VFW

MCIWNDM_SETREPEAT

Formats.VFW

MCIWNDM_SETSPEED

Formats.VFW

MCIWNDM_SETTIMEFORMAT

Formats.VFW

MCIWNDM_SETTIMEFORMATA

Formats.VFW

MCIWNDM_SETTIMEFORMATW

Formats.VFW

MCIWNDM_SETTIMERS

Formats.VFW

MCIWNDM_SETVOLUME

Formats.VFW

MCIWNDM_SETZOOM

Formats.VFW

MCIWNDM_VALIDATEMEDIA

Formats.VFW

MCIWNDOPENF_NEW

Formats.VFW

– Flags for the MCIWndOpen command —————————————–

MCIWND_END

Formats.VFW

MCIWND_START

Formats.VFW

– Special seek values for START and END ————————————

MCIWND_WINDOW_CLASS

Formats.VFW

MDATA

Formats.m3DSConst

Mesh Chunk Ids

MDCFILE_IDENTITY

GLS.FileMDC

MDCFILE_VERSION

GLS.FileMDC

MDC_BASEVERTEX_FACTOR

GLS.FileMDC

MDC_COMPVERTEX_FACTOR

GLS.FileMDC

1/64;

MESH_COLOR

Formats.m3DSConst

MESH_MATRIX

Formats.m3DSConst

MESH_TEXTURE_INFO

Formats.m3DSConst

MESH_VERSION

Formats.m3DSConst

MidTexPoint

GLScene.VectorGeometry

MinComp

GLScene.VectorGeometry

1.1E+4932 <-Overflowing in c++;

MinDouble

GLScene.VectorGeometry

MinExtended

GLScene.VectorGeometry

MinSingle

GLScene.VectorGeometry

Ranges of the IEEE floating point types, including denormals with Math.pas compatible name

MinusXVector

GLScene.VectorGeometry

MinusYVector

GLScene.VectorGeometry

MinusZVector

GLScene.VectorGeometry

MLIBMAGIC

Formats.m3DSConst

MorphSmoothMax3DS

Formats.m3DSConst

Minimum morph smoothing angle

MorphSmoothMin3DS

Formats.m3DSConst

Maximum morph object name string size MORPH_SMOOTH

MorphTrackStrMax3DS

Formats.m3DSConst

Maximum instance name string size MORPH_TRACK

MORPH_SMOOTH

Formats.m3DSConst

MORPH_TRACK_TAG

Formats.m3DSConst

MORPH_TRACK_TAG_KEY

Formats.m3DSConst

MRT_BUFFERS

GLS.Context

Buffer ID's for Multiple-Render-Targets (using GL_ATI_draw_buffers)

MshMatGroupMin3DS

Formats.m3DSConst

minimum number of faces MshMatGroup3DS

MshMatGroupStrMax3DS

Formats.m3DSConst

minimum number of faces per material

MSH_BOXMAP

Formats.m3DSConst

MSH_MAT_GROUP

Formats.m3DSConst

MSH_MAT_GROUP_ENTRY

Formats.m3DSConst

M_BEVEL

Formats.m3DSConst

M_FIT

Formats.m3DSConst

M_SCALE

Formats.m3DSConst

M_TEETER

Formats.m3DSConst

M_TWIST

Formats.m3DSConst

NamedObjectStrMax3DS

Formats.m3DSConst

Maximum map name string size NAMED_OBJECT

NAMED_OBJECT

Formats.m3DSConst

NCameraFocMax3DS

Formats.m3DSConst

Minimum lens size for camera

NCameraFocMin3DS

Formats.m3DSConst

Maximum field of view for camera

NCameraFOVMax3DS

Formats.m3DSConst

Minimum field of view for camera

NCameraFOVMin3DS

Formats.m3DSConst

Maximum named object string size N_CAMERA

NETWORK_VIEW

Formats.m3DSConst

NEWTON_API

Newton.Import

.$DEFINE USE_DOUBLE_PRECISION

NEWTON_BROADPHASE_DEFAULT

Newton.Import

NEWTON_BROADPHASE_PERSINTENT

Newton.Import

NEWTON_DYNAMIC_ASYMETRIC_BODY

Newton.Import

NEWTON_DYNAMIC_BODY

Newton.Import

NEWTON_KINEMATIC_BODY

Newton.Import

NEWTON_MAJOR_VERSION

Newton.Import

NEWTON_MINOR_VERSION

Newton.Import

NMF_HEADER_TAG

GLS.FileNMF

NMF_TRIANGLE_TAG

GLS.FileNMF

NodeHdrStrMax3DS

Formats.m3DSConst

Maximum keyframe header name string size NODE_HDR

NodeTagCount

Formats.m3DSConst

NodeTags

Formats.m3DSConst

number of entries in node tag list

NODE_ANI_HIDDEN

Formats.m3DSConst

NODE_AUTO_SMOOTH

Formats.m3DSConst

NODE_BLUR_BRANCH

Formats.m3DSConst

NODE_CALC_PATH

Formats.m3DSConst

corresponds to mesh

NODE_FROZEN

Formats.m3DSConst

NODE_HAS_PATH

Formats.m3DSConst

Values for keyframer flags2

NODE_HDR

Formats.m3DSConst

NODE_ID

Formats.m3DSConst

NODE_MORPH_MTL

Formats.m3DSConst

NODE_MORPH_OB

Formats.m3DSConst

NODE_MOTION_BLUR

Formats.m3DSConst

NODE_OFF

Formats.m3DSConst

NODE_RENDOB_HIDE

Formats.m3DSConst

do RGB color transform Values for keyframer flags1

NoFalloff

Formats.m3DSConst

NotChunk

Formats.m3DSConst

NullBoundingBox

GLScene.GeometryBB

NullHmgPoint

GLScene.VectorGeometry

NullHmgVector

GLScene.VectorGeometry

NullTexPoint

GLScene.VectorGeometry

NullVector

GLScene.VectorGeometry

NULL_CHUNK

Formats.m3DSConst

—————– List of all chunk IDs ————————————-

N_AMBIENT_LIGHT

Formats.m3DSConst

N_CAMERA

Formats.m3DSConst

N_CAM_OLD

Formats.m3DSConst

N_DIRECT_LIGHT

Formats.m3DSConst

N_D_L_OLD

Formats.m3DSConst

N_TRI_OBJECT

Formats.m3DSConst

OBJECT_NODE_TAG

Formats.m3DSConst

OBJ_DOESNT_CAST

Formats.m3DSConst

OBJ_DONT_RCVSHADOW

Formats.m3DSConst

OBJ_FAST

Formats.m3DSConst

OBJ_FROZEN

Formats.m3DSConst

OBJ_HIDDEN

Formats.m3DSConst

OBJ_MATTE

Formats.m3DSConst

OBJ_PROCEDURAL

Formats.m3DSConst

OBJ_VIS_LOFTER

Formats.m3DSConst

ODEDLL

ODE.Import

********************************************************************
ODE precision:
ODE can be run in Single or Double precision, Single is less precise, but requires less memory.
If you choose to run in Single mode, you must deploy the single precision dll (this is default)
If you choose to run in Double mode, you must deploy the double precision dll (named ode_double.dll and located in the dll directory) Insert . before "$" to make ODEImport double based

OLD_MAT_GROUP

Formats.m3DSConst

opengl32

GLS.OpenGLAdapter

opengl32

GLScene.OpenGL4

O_CONSTS

Formats.m3DSConst

PARENT_NAME

Formats.m3DSConst

PARENT_OBJECT

Formats.m3DSConst

PATH_3D

Formats.m3DSConst

PATH_MATRIX

Formats.m3DSConst

PD_CAN_DRAW_DIB

Formats.VFW

– Display profiling ——————————————————–

PD_CAN_STRETCHDIB

Formats.VFW

if you can draw at all

PD_STRETCHDIB_1_1_OK

Formats.VFW

basicly RC_STRETCHDIB

PD_STRETCHDIB_1_2_OK

Formats.VFW

is it fast?

PD_STRETCHDIB_1_N_OK

Formats.VFW

...

PhysXDLL

PhysX.Import

PIVOT

Formats.m3DSConst

PIVOT_LIMITS

Formats.m3DSConst

PIVOT_OBJECT

Formats.m3DSConst

PIVOT_ORDER

Formats.m3DSConst

PointArrayMin3DS

Formats.m3DSConst

POINT_ARRAY

POINT_ARRAY

Formats.m3DSConst

POINT_ARRAY_ENTRY

Formats.m3DSConst

Trick Chunk Types For Open, Write, Close functions

POINT_FLAG_ARRAY

Formats.m3DSConst

POINT_FLAG_ARRAY_ENTRY

Formats.m3DSConst

POLS_FLAGS_MASK

Formats.LWO

POLS_TYPE_BONE

Formats.LWO

METABALL

POLS_TYPE_CURV

Formats.LWO

FACES

POLS_TYPE_FACE

Formats.LWO

PIXEL PLUG-IN FILTER

POLS_TYPE_MBAL

Formats.LWO

PATCH

POLS_TYPE_PTCH

Formats.LWO

CURVE

POLS_VCOUNT_MASK

Formats.LWO

LINEAR

POLY_2D

Formats.m3DSConst

POS_TRACK_TAG

Formats.m3DSConst

POS_TRACK_TAG_KEY

Formats.m3DSConst

PreferExternal

gnugettext

This is set to paramstr(0) or the name of the DLL you are creating.

PRESCALE

Formats.m3DSConst

PRE_POST_CONSTANT

Formats.LWO

RESET

PRE_POST_LINEAR

Formats.LWO

OFFSET REPEAT

PRE_POST_OFFSET

Formats.LWO

OSCILLATE

PRE_POST_OSCILLATE

Formats.LWO

REPEAT

PRE_POST_REPEAT

Formats.LWO

CONSTANT

PRE_POST_RESET

Formats.LWO

SMOOTH GROUP

PRIMARY_NODE

Formats.m3DSConst

draw node quickdraw style

ProcNameStrMax3DS

Formats.m3DSConst

maximim string length for MshMatGroup PROC_NAME

PROC_DATA

Formats.m3DSConst

PROC_NAME

Formats.m3DSConst

PTAG_TYPE_PART

Formats.LWO

SURFACE

PTAG_TYPE_SMGP

Formats.LWO

PARENT PART

PTAG_TYPE_SURF

Formats.LWO

SPOT MAP: ABSOLUTE VERTEX POSITIONS

P_ALPHANEG

Formats.m3DSConst

P_ALPH_ALPHA

Formats.m3DSConst

P_ALPH_BLUR

Formats.m3DSConst

Old Chunk

P_ALPH_C0

Formats.m3DSConst

P_ALPH_CUTOFF

Formats.m3DSConst

P_ALPH_IMAGE

Formats.m3DSConst

P_ALPH_KCOL

Formats.m3DSConst

P_ALPH_NONE

Formats.m3DSConst

P_ALPH_OP_KEY

Formats.m3DSConst

P_ALPH_OP_NOCONV

Formats.m3DSConst

P_ALPH_OP_PSEUDO

Formats.m3DSConst

Old Chunk

P_ALPH_PCOL

Formats.m3DSConst

Replaces pseudo

P_ALPH_PSEUDO

Formats.m3DSConst

P_ALPH_QUEIMG

Formats.m3DSConst

P_ALPH_QUES

Formats.m3DSConst

P_CUSTOM_SIZE

Formats.m3DSConst

P_PROC_DATA

Formats.m3DSConst

P_QUEUE_ALIGN

Formats.m3DSConst

P_QUEUE_ENTRY

Formats.m3DSConst

P_QUEUE_GRADIENT

Formats.m3DSConst

P_QUEUE_IMAGE

Formats.m3DSConst

P_QUEUE_KF

Formats.m3DSConst

P_QUEUE_MB_REPEAT

Formats.m3DSConst

P_QUEUE_MOTBLUR

Formats.m3DSConst

P_QUEUE_NONE

Formats.m3DSConst

P_QUEUE_OFFSET

Formats.m3DSConst

P_QUEUE_PROC

Formats.m3DSConst

P_QUEUE_RESIZE

Formats.m3DSConst

P_QUEUE_SOLID

Formats.m3DSConst

P_QUEUE_USEIGAMMA

Formats.m3DSConst

P_RANGES

Formats.m3DSConst

P_TRANNEG

Formats.m3DSConst

P_TRAN_FADEIN

Formats.m3DSConst

P_TRAN_FADEOUT

Formats.m3DSConst

P_TRAN_FRAMES

Formats.m3DSConst

P_TRAN_IMAGE

Formats.m3DSConst

P_TRAN_NONE

Formats.m3DSConst

QW_ERROR

BASS.Import

-1 (DWORD)

RAY_BIAS

Formats.m3DSConst

RelAll3DS

Formats.m3DSConst

RelFaceArray3ds

Formats.m3DSConst

RelMatArray3ds

Formats.m3DSConst

RelProcData3ds

Formats.m3DSConst

RelSmoothArray3ds

Formats.m3DSConst

RelTextArray3ds

Formats.m3DSConst

RelVertexArray3ds

Formats.m3DSConst

field codes for RelMeshObjField3ds

RelVFlagArray3ds

Formats.m3DSConst

ReReadMoFileOnSameLanguage

gnugettext

Set to False, to use the mo-file as independent copy in memory (you can update the file while it is in use)

RFOP_BACKDROP

Formats.LWO

RFOP_RAYTRACEANDBACKDROP

Formats.LWO

RFOP_RAYTRACEANDSPHERICALMAP

Formats.LWO

RFOP_SPHERICALMAP

Formats.LWO

RGBA_SIGNED_COMPONENTS_EXT

GLScene.OpenGL4

ROLL_TRACK_TAG

Formats.m3DSConst

ROLL_TRACK_TAG_KEY

Formats.m3DSConst

ROT_TRACK_TAG

Formats.m3DSConst

ROT_TRACK_TAG_KEY

Formats.m3DSConst

RW_SEEK_CUR

SDL.Import

**< Seek from the beginning of data *

RW_SEEK_END

SDL.Import

**< Seek relative to current read point *

RW_SEEK_SET

SDL.Import

SCENE_SELECTED

FmSceneEditor

SCL_TRACK_TAG

Formats.m3DSConst

SCL_TRACK_TAG_KEY

Formats.m3DSConst

SDLK_0

SDL.Import

SDLK_1

SDL.Import

SDLK_2

SDL.Import

SDLK_3

SDL.Import

SDLK_4

SDL.Import

SDLK_5

SDL.Import

SDLK_6

SDL.Import

SDLK_7

SDL.Import

SDLK_8

SDL.Import

SDLK_9

SDL.Import

SDLK_a

SDL.Import

SDLK_AC_BACK

SDL.Import

SDLK_AC_BOOKMARKS

SDL.Import

SDLK_AC_FORWARD

SDL.Import

SDLK_AC_HOME

SDL.Import

SDLK_AC_REFRESH

SDL.Import

SDLK_AC_SEARCH

SDL.Import

SDLK_AC_STOP

SDL.Import

SDLK_AGAIN

SDL.Import

SDLK_ALTERASE

SDL.Import

SDLK_AMPERSAND

SDL.Import

SDLK_APPLICATION

SDL.Import

SDLK_ASTERISK

SDL.Import

SDLK_AT

SDL.Import

SDLK_AUDIOMUTE

SDL.Import

SDLK_AUDIONEXT

SDL.Import

SDLK_AUDIOPLAY

SDL.Import

SDLK_AUDIOPREV

SDL.Import

SDLK_AUDIOSTOP

SDL.Import

SDLK_b

SDL.Import

SDLK_BACKQUOTE

SDL.Import

SDLK_BACKSLASH

SDL.Import

SDLK_BACKSPACE

SDL.Import

SDLK_BRIGHTNESSDOWN

SDL.Import

SDLK_BRIGHTNESSUP

SDL.Import

SDLK_c

SDL.Import

SDLK_CALCULATOR

SDL.Import

SDLK_CANCEL

SDL.Import

SDLK_CAPSLOCK

SDL.Import

SDLK_CARET

SDL.Import

SDLK_CLEAR

SDL.Import

SDLK_CLEARAGAIN

SDL.Import

SDLK_COLON

SDL.Import

SDLK_COMMA

SDL.Import

SDLK_COMPUTER

SDL.Import

SDLK_COPY

SDL.Import

SDLK_CRSEL

SDL.Import

SDLK_CURRENCYSUBUNIT

SDL.Import

SDLK_CURRENCYUNIT

SDL.Import

SDLK_CUT

SDL.Import

SDLK_d

SDL.Import

SDLK_DECIMALSEPARATOR

SDL.Import

SDLK_DELETE

SDL.Import

SDLK_DISPLAYSWITCH

SDL.Import

SDLK_DOLLAR

SDL.Import

SDLK_DOWN

SDL.Import

SDLK_e

SDL.Import

SDLK_EJECT

SDL.Import

SDLK_END

SDL.Import

SDLK_EQUALS

SDL.Import

SDLK_ESCAPE

SDL.Import

SDLK_EXCLAIM

SDL.Import

SDLK_EXECUTE

SDL.Import

SDLK_EXSEL

SDL.Import

SDLK_f

SDL.Import

SDLK_F1

SDL.Import

SDLK_F10

SDL.Import

SDLK_F11

SDL.Import

SDLK_F12

SDL.Import

SDLK_F13

SDL.Import

SDLK_F14

SDL.Import

SDLK_F15

SDL.Import

SDLK_F16

SDL.Import

SDLK_F17

SDL.Import

SDLK_F18

SDL.Import

SDLK_F19

SDL.Import

SDLK_F2

SDL.Import

SDLK_F20

SDL.Import

SDLK_F21

SDL.Import

SDLK_F22

SDL.Import

SDLK_F23

SDL.Import

SDLK_F24

SDL.Import

SDLK_F3

SDL.Import

SDLK_F4

SDL.Import

SDLK_F5

SDL.Import

SDLK_F6

SDL.Import

SDLK_F7

SDL.Import

SDLK_F8

SDL.Import

SDLK_F9

SDL.Import

SDLK_FIND

SDL.Import

SDLK_g

SDL.Import

SDLK_GREATER

SDL.Import

SDLK_h

SDL.Import

SDLK_HASH

SDL.Import

SDLK_HELP

SDL.Import

SDLK_HOME

SDL.Import

SDLK_i

SDL.Import

SDLK_INSERT

SDL.Import

SDLK_j

SDL.Import

SDLK_k

SDL.Import

SDLK_KBDILLUMDOWN

SDL.Import

SDLK_KBDILLUMTOGGLE

SDL.Import

SDLK_KBDILLUMUP

SDL.Import

SDLK_KP_0

SDL.Import

SDLK_KP_00

SDL.Import

SDLK_KP_000

SDL.Import

SDLK_KP_1

SDL.Import

SDLK_KP_2

SDL.Import

SDLK_KP_3

SDL.Import

SDLK_KP_4

SDL.Import

SDLK_KP_5

SDL.Import

SDLK_KP_6

SDL.Import

SDLK_KP_7

SDL.Import

SDLK_KP_8

SDL.Import

SDLK_KP_9

SDL.Import

SDLK_KP_A

SDL.Import

SDLK_KP_AMPERSAND

SDL.Import

SDLK_KP_AT

SDL.Import

SDLK_KP_B

SDL.Import

SDLK_KP_BACKSPACE

SDL.Import

SDLK_KP_BINARY

SDL.Import

SDLK_KP_C

SDL.Import

SDLK_KP_CLEAR

SDL.Import

SDLK_KP_CLEARENTRY

SDL.Import

SDLK_KP_COLON

SDL.Import

SDLK_KP_COMMA

SDL.Import

SDLK_KP_D

SDL.Import

SDLK_KP_DBLAMPERSAND

SDL.Import

SDLK_KP_DBLVERTICALBAR

SDL.Import

SDLK_KP_DECIMAL

SDL.Import

SDLK_KP_DIVIDE

SDL.Import

SDLK_KP_E

SDL.Import

SDLK_KP_ENTER

SDL.Import

SDLK_KP_EQUALS

SDL.Import

SDLK_KP_EQUALSAS400

SDL.Import

SDLK_KP_EXCLAM

SDL.Import

SDLK_KP_F

SDL.Import

SDLK_KP_GREATER

SDL.Import

SDLK_KP_HASH

SDL.Import

SDLK_KP_HEXADECIMAL

SDL.Import

SDLK_KP_LEFTBRACE

SDL.Import

SDLK_KP_LEFTPAREN

SDL.Import

SDLK_KP_LESS

SDL.Import

SDLK_KP_MEMADD

SDL.Import

SDLK_KP_MEMCLEAR

SDL.Import

SDLK_KP_MEMDIVIDE

SDL.Import

SDLK_KP_MEMMULTIPLY

SDL.Import

SDLK_KP_MEMRECALL

SDL.Import

SDLK_KP_MEMSTORE

SDL.Import

SDLK_KP_MEMSUBTRACT

SDL.Import

SDLK_KP_MINUS

SDL.Import

SDLK_KP_MULTIPLY

SDL.Import

SDLK_KP_OCTAL

SDL.Import

SDLK_KP_PERCENT

SDL.Import

SDLK_KP_PERIOD

SDL.Import

SDLK_KP_PLUS

SDL.Import

SDLK_KP_PLUSMINUS

SDL.Import

SDLK_KP_POWER

SDL.Import

SDLK_KP_RIGHTBRACE

SDL.Import

SDLK_KP_RIGHTPAREN

SDL.Import

SDLK_KP_SPACE

SDL.Import

SDLK_KP_TAB

SDL.Import

SDLK_KP_VERTICALBAR

SDL.Import

SDLK_KP_XOR

SDL.Import

SDLK_l

SDL.Import

SDLK_LALT

SDL.Import

SDLK_LCTRL

SDL.Import

SDLK_LEFT

SDL.Import

SDLK_LEFTBRACKET

SDL.Import

* Skip uppercase letters *

SDLK_LEFTPAREN

SDL.Import

SDLK_LESS

SDL.Import

SDLK_LGUI

SDL.Import

SDLK_LSHIFT

SDL.Import

SDLK_m

SDL.Import

SDLK_MAIL

SDL.Import

SDLK_MEDIASELECT

SDL.Import

SDLK_MENU

SDL.Import

SDLK_MINUS

SDL.Import

SDLK_MODE

SDL.Import

SDLK_MUTE

SDL.Import

SDLK_n

SDL.Import

SDLK_NUMLOCKCLEAR

SDL.Import

SDLK_o

SDL.Import

SDLK_OPER

SDL.Import

SDLK_OUT

SDL.Import

SDLK_p

SDL.Import

SDLK_PAGEDOWN

SDL.Import

SDLK_PAGEUP

SDL.Import

SDLK_PASTE

SDL.Import

SDLK_PAUSE

SDL.Import

SDLK_PERCENT

SDL.Import

SDLK_PERIOD

SDL.Import

SDLK_PLUS

SDL.Import

SDLK_POWER

SDL.Import

SDLK_PRINTSCREEN

SDL.Import

SDLK_PRIOR

SDL.Import

SDLK_q

SDL.Import

SDLK_QUESTION

SDL.Import

SDLK_QUOTE

SDL.Import

SDLK_QUOTEDBL

SDL.Import

SDLK_r

SDL.Import

SDLK_RALT

SDL.Import

SDLK_RCTRL

SDL.Import

SDLK_RETURN

SDL.Import

SDLK_RETURN2

SDL.Import

SDLK_RGUI

SDL.Import

SDLK_RIGHT

SDL.Import

SDLK_RIGHTBRACKET

SDL.Import

SDLK_RIGHTPAREN

SDL.Import

SDLK_RSHIFT

SDL.Import

SDLK_s

SDL.Import

SDLK_SCANCODE_MASK

SDL.Import

SDLK_SCROLLLOCK

SDL.Import

SDLK_SELECT

SDL.Import

SDLK_SEMICOLON

SDL.Import

SDLK_SEPARATOR

SDL.Import

SDLK_SLASH

SDL.Import

SDLK_SLEEP

SDL.Import

SDLK_SPACE

SDL.Import

SDLK_STOP

SDL.Import

SDLK_SYSREQ

SDL.Import

SDLK_t

SDL.Import

SDLK_TAB

SDL.Import

SDLK_THOUSANDSSEPARATOR

SDL.Import

SDLK_u

SDL.Import

SDLK_UNDERSCORE

SDL.Import

SDLK_UNDO

SDL.Import

SDLK_UNKNOWN

SDL.Import

SDLK_UP

SDL.Import

SDLK_v

SDL.Import

SDLK_VOLUMEDOWN

SDL.Import

SDLK_VOLUMEUP

SDL.Import

SDLK_w

SDL.Import

SDLK_WWW

SDL.Import

SDLK_x

SDL.Import

SDLK_y

SDL.Import

SDLK_z

SDL.Import

SDL_ADDEVENT

SDL.Import

SDL_ALPHA_OPAQUE

SDL.Import

** * Transparency definitions * * These define alpha as the opacity of a surface. *

SDL_ALPHA_TRANSPARENT

SDL.Import

SDL_APP_DIDENTERBACKGROUND

SDL.Import

**< The application is about to enter the background Called on iOS in applicationWillResignActive() Called on Android in onPause() *

SDL_APP_DIDENTERFOREGROUND

SDL.Import

**< The application is about to enter the foreground Called on iOS in applicationWillEnterForeground() Called on Android in onResume() *

SDL_APP_LOWMEMORY

SDL.Import

**< The application is being terminated by the OS Called on iOS in applicationWillTerminate() Called on Android in onDestroy() *

SDL_APP_TERMINATING

SDL.Import

* These application events have special meaning on iOS, see README.iOS for details *

SDL_APP_WILLENTERBACKGROUND

SDL.Import

**< The application is low on memory, free memory if possible. Called on iOS in applicationDidReceiveMemoryWarning() Called on Android in onLowMemory() *

SDL_APP_WILLENTERFOREGROUND

SDL.Import

**< The application did enter the background and may not get CPU for some time Called on iOS in applicationDidEnterBackground() Called on Android in onPause() *

SDL_ARRAYORDER_ABGR

SDL.Import

SDL_ARRAYORDER_ARGB

SDL.Import

SDL_ARRAYORDER_BGR

SDL.Import

SDL_ARRAYORDER_BGRA

SDL.Import

SDL_ARRAYORDER_NONE

SDL.Import

** Array component order, low byte -> high byte. *

SDL_ARRAYORDER_RGB

SDL.Import

SDL_ARRAYORDER_RGBA

SDL.Import

SDL_AUDIO_ALLOW_ANY_CHANGE

SDL.Import

SDL_AUDIO_ALLOW_CHANNELS_CHANGE

SDL.Import

SDL_AUDIO_ALLOW_FORMAT_CHANGE

SDL.Import

SDL_AUDIO_ALLOW_FREQUENCY_CHANGE

SDL.Import

** * Allow change flags * * Which audio format changes are allowed when opening a device. *

SDL_AUDIO_MASK_BITSIZE

SDL.Import

** * Audio flags *

SDL_AUDIO_MASK_DATATYPE

SDL.Import

SDL_AUDIO_MASK_ENDIAN

SDL.Import

SDL_AUDIO_MASK_SIGNED

SDL.Import

SDL_BIG_ENDIAN

SDL.Import

SDL_BITMAPORDER_1234

SDL.Import

SDL_BITMAPORDER_4321

SDL.Import

SDL_BITMAPORDER_NONE

SDL.Import

** Bitmap pixel order, high bit -> low bit. *

SDL_BLENDMODE_ADD

SDL.Import

**< dst = (src * A) + (dst * (1-A)) *

SDL_BLENDMODE_BLEND

SDL.Import

**< No blending *

SDL_BLENDMODE_MOD

SDL.Import

**< dst = (src * A) + dst *

SDL_BLENDMODE_NONE

SDL.Import

SDL_BUTTON_LEFT

SDL.Import

** * Used as a mask when testing buttons in buttonstate. * - Button 1: Left mouse button * - Button 2: Middle mouse button * - Button 3: Right mouse button *

SDL_BUTTON_LMASK

SDL.Import

SDL_BUTTON_MIDDLE

SDL.Import

SDL_BUTTON_MMASK

SDL.Import

SDL_BUTTON_RIGHT

SDL.Import

SDL_BUTTON_RMASK

SDL.Import

SDL_BUTTON_X1

SDL.Import

SDL_BUTTON_X1MASK

SDL.Import

SDL_BUTTON_X2

SDL.Import

SDL_BUTTON_X2MASK

SDL.Import

SDL_BYTEORDER

SDL.Import

SDL_CLIPBOARDUPDATE

SDL.Import

Clipboard events

SDL_COMMONEVENT

SDL.Import

Unused (do not remove) (needed in pascal?)

SDL_CONTROLLERAXISMOTION

SDL.Import

Game controller events

SDL_CONTROLLERBUTTONDOWN

SDL.Import

Game controller axis motion

SDL_CONTROLLERBUTTONUP

SDL.Import

Game controller button pressed

SDL_CONTROLLERDEVICEADDED

SDL.Import

Game controller button released

SDL_CONTROLLERDEVICEREMAPPED

SDL.Import

An opened Game controller has been removed

SDL_CONTROLLERDEVICEREMOVED

SDL.Import

A new Game controller has been inserted into the system

SDL_CONTROLLER_AXIS_INVALID

SDL.Import

** * The list of axes available from a controller *

SDL_CONTROLLER_AXIS_LEFTX

SDL.Import

SDL_CONTROLLER_AXIS_LEFTY

SDL.Import

SDL_CONTROLLER_AXIS_MAX

SDL.Import

SDL_CONTROLLER_AXIS_RIGHTX

SDL.Import

SDL_CONTROLLER_AXIS_RIGHTY

SDL.Import

SDL_CONTROLLER_AXIS_TRIGGERLEFT

SDL.Import

SDL_CONTROLLER_AXIS_TRIGGERRIGHT

SDL.Import

SDL_CONTROLLER_BUTTON_A

SDL.Import

SDL_CONTROLLER_BUTTON_B

SDL.Import

SDL_CONTROLLER_BUTTON_BACK

SDL.Import

SDL_CONTROLLER_BUTTON_DPAD_DOWN

SDL.Import

SDL_CONTROLLER_BUTTON_DPAD_LEFT

SDL.Import

SDL_CONTROLLER_BUTTON_DPAD_RIGHT

SDL.Import

SDL_CONTROLLER_BUTTON_DPAD_UP

SDL.Import

SDL_CONTROLLER_BUTTON_GUIDE

SDL.Import

SDL_CONTROLLER_BUTTON_INVALID

SDL.Import

** * The list of buttons available from a controller *

SDL_CONTROLLER_BUTTON_LEFTSHOULDER

SDL.Import

SDL_CONTROLLER_BUTTON_LEFTSTICK

SDL.Import

SDL_CONTROLLER_BUTTON_MAX

SDL.Import

SDL_CONTROLLER_BUTTON_RIGHTSHOULDER

SDL.Import

SDL_CONTROLLER_BUTTON_RIGHTSTICK

SDL.Import

SDL_CONTROLLER_BUTTON_START

SDL.Import

SDL_CONTROLLER_BUTTON_X

SDL.Import

SDL_CONTROLLER_BUTTON_Y

SDL.Import

SDL_DISABLE

SDL.Import

SDL_DOLLARGESTURE

SDL.Import

Gesture events

SDL_DOLLARRECORD

SDL.Import

SDL_DONTFREE

SDL.Import

**< Surface is RLE encoded *

SDL_DROPFILE

SDL.Import

Drag and drop events

SDL_ENABLE

SDL.Import

SDL_FINGERDOWN

SDL.Import

Touch events

SDL_FINGERMOTION

SDL.Import

SDL_FINGERUP

SDL.Import

SDL_FIRSTEVENT

SDL.Import

** * The types of events that can be delivered. *

SDL_GETEVENT

SDL.Import

SDL_GL_ACCELERATED_VISUAL

SDL.Import

SDL_GL_ACCUM_ALPHA_SIZE

SDL.Import

SDL_GL_ACCUM_BLUE_SIZE

SDL.Import

SDL_GL_ACCUM_GREEN_SIZE

SDL.Import

SDL_GL_ACCUM_RED_SIZE

SDL.Import

SDL_GL_ALPHA_SIZE

SDL.Import

SDL_GL_BLUE_SIZE

SDL.Import

SDL_GL_BUFFER_SIZE

SDL.Import

SDL_GL_CONTEXT_DEBUG_FLAG

SDL.Import

SDL_GL_CONTEXT_EGL

SDL.Import

SDL_GL_CONTEXT_FLAGS

SDL.Import

SDL_GL_CONTEXT_FORWARD_COMPATIBLE_FLAG

SDL.Import

SDL_GL_CONTEXT_MAJOR_VERSION

SDL.Import

SDL_GL_CONTEXT_MINOR_VERSION

SDL.Import

SDL_GL_CONTEXT_PROFILE_COMPATIBILITY

SDL.Import

SDL_GL_CONTEXT_PROFILE_CORE

SDL.Import

SDL_GL_CONTEXT_PROFILE_ES

SDL.Import

SDL_GL_CONTEXT_PROFILE_MASK

SDL.Import

SDL_GL_CONTEXT_RESET_ISOLATION_FLAG

SDL.Import

SDL_GL_CONTEXT_ROBUST_ACCESS_FLAG

SDL.Import

SDL_GL_DEPTH_SIZE

SDL.Import

SDL_GL_DOUBLEBUFFER

SDL.Import

SDL_GL_GREEN_SIZE

SDL.Import

SDL_GL_MULTISAMPLEBUFFERS

SDL.Import

SDL_GL_MULTISAMPLESAMPLES

SDL.Import

SDL_GL_RED_SIZE

SDL.Import

** * OpenGL configuration attributes *

SDL_GL_RETAINED_BACKING

SDL.Import

SDL_GL_SHARE_WITH_CURRENT_CONTEXT

SDL.Import

SDL_GL_STENCIL_SIZE

SDL.Import

SDL_GL_STEREO

SDL.Import

SDL_HAPTIC_AUTOCENTER

SDL.Import

** * Device can set autocenter. * * Device supports setting autocenter. * * SDL_HapticSetAutocenter *

SDL_HAPTIC_CARTESIAN

SDL.Import

** * Uses cartesian coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_CONSTANT

SDL.Import

** * Constant effect supported. * * Constant haptic effect. * * SDL_HapticCondition *

SDL_HAPTIC_CUSTOM

SDL.Import

** * Custom effect is supported. * * User defined custom haptic effect. *

SDL_HAPTIC_DAMPER

SDL.Import

** * Damper effect supported - uses axes velocity. * * Condition haptic effect that simulates dampening. Effect is based on the * axes velocity. * * SDL_HapticCondition *

SDL_HAPTIC_FRICTION

SDL.Import

** * Friction effect supported - uses axes movement. * * Condition haptic effect that simulates friction. Effect is based on the * axes movement. * * SDL_HapticCondition *

SDL_HAPTIC_GAIN

SDL.Import

** * Device can set global gain. * * Device supports setting the global gain. * * SDL_HapticSetGain *

SDL_HAPTIC_INERTIA

SDL.Import

** * Inertia effect supported - uses axes acceleration. * * Condition haptic effect that simulates inertia. Effect is based on the axes * acceleration. * * SDL_HapticCondition *

SDL_HAPTIC_INFINITY

SDL.Import

SDL_HAPTIC_INFINITY = 4294967295U;

SDL_HAPTIC_PAUSE

SDL.Import

** * Device can be paused. * * SDL_HapticPause * SDL_HapticUnpause *

SDL_HAPTIC_POLAR

SDL.Import

** * Uses polar coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_RAMP

SDL.Import

** * Ramp effect supported. * * Ramp haptic effect. * * SDL_HapticRamp *

SDL_HAPTIC_SAWTOOTHDOWN

SDL.Import

** * Sawtoothdown wave effect supported. * * Periodic haptic effect that simulates saw tooth down waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SAWTOOTHUP

SDL.Import

** * Sawtoothup wave effect supported. * * Periodic haptic effect that simulates saw tooth up waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SINE

SDL.Import

** * Sine wave effect supported. * * Periodic haptic effect that simulates sine waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SPHERICAL

SDL.Import

** * Uses spherical coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_SPRING

SDL.Import

** * Spring effect supported - uses axes position. * * Condition haptic effect that simulates a spring. Effect is based on the * axes position. * * SDL_HapticCondition *

SDL_HAPTIC_SQUARE

SDL.Import

** * Square wave effect supported. * * Periodic haptic effect that simulates square waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_STATUS

SDL.Import

** * Device can be queried for effect status. * * Device can be queried for effect status. * * SDL_HapticGetEffectStatus *

SDL_HAPTIC_TRIANGLE

SDL.Import

** * Triangle wave effect supported. * * Periodic haptic effect that simulates triangular waves. * * SDL_HapticPeriodic *

SDL_HAT_CENTERED

SDL.Import

** * Hat positions *

SDL_HAT_DOWN

SDL.Import

SDL_HAT_LEFT

SDL.Import

SDL_HAT_LEFTDOWN

SDL.Import

SDL_HAT_LEFTUP

SDL.Import

SDL_HAT_RIGHT

SDL.Import

SDL_HAT_RIGHTDOWN

SDL.Import

SDL_HAT_RIGHTUP

SDL.Import

SDL_HAT_UP

SDL.Import

SDL_HINT_ALLOW_TOPMOST

SDL.Import

/** * \brief If set to 0 then never set the top most bit on a SDL Window, even if the video mode expects it. * This is a debugging aid for developers and not expected to be used by end users. The default is "1" * * This variable can be set to the following values: * "0" - don't allow topmost * "1" - allow topmost */

SDL_HINT_FRAMEBUFFER_ACCELERATION

SDL.Import

* * \brief A variable controlling how 3D acceleration is used to accelerate the SDL screen surface. * * SDL can try to accelerate the SDL screen surface by using streaming * textures with a 3D rendering engine. This variable controls whether and * how this is done. * * This variable can be set to the following values: * "0" - Disable 3D acceleration * "1" - Enable 3D acceleration, using the default renderer. * "X" - Enable 3D acceleration, using X where X is one of the valid rendering drivers. (e.g. "direct3d", "opengl", etc.) * * By default SDL tries to make a best guess for each platform whether * to use acceleration or not.

SDL_HINT_GAMECONTROLLERCONFIG

SDL.Import

/** * \brief A variable that lets you manually hint extra gamecontroller db entries * * The variable should be newline delimited rows of gamecontroller config data, see SDL_gamecontroller.h * * This hint must be set before calling SDL_Init(SDL_INIT_GAMECONTROLLER) * You can update mappings after the system is initialized with SDL_GameControllerMappingForGUID() and SDL_GameControllerAddMapping() */

SDL_HINT_GRAB_KEYBOARD

SDL.Import

/** * \brief A variable controlling whether grabbing input grabs the keyboard * * This variable can be set to the following values: * "0" - Grab will affect only the mouse * "1" - Grab will affect mouse and keyboard * * By default SDL will not grab the keyboard so system shortcuts still work. */

SDL_HINT_IDLE_TIMER_DISABLED

SDL.Import

/** * \brief A variable controlling whether the idle timer is disabled on iOS. * * When an iOS app does not receive touches for some time, the screen is * dimmed automatically. For games where the accelerometer is the only input * this is problematic. This functionality can be disabled by setting this * hint. * * This variable can be set to the following values: * "0" - Enable idle timer * "1" - Disable idle timer */

SDL_HINT_JOYSTICK_ALLOW_BACKGROUND_EVENTS

SDL.Import

/** * \brief A variable that lets you enable joystick (and gamecontroller) events even when your app is in the background. * * The variable can be set to the following values: * "0" - Disable joystick & gamecontroller input events when the * application is in the background. * "1" - Enable joystick & gamecontroller input events when the * application is in the backgroumd. * * The default value is "0". This hint may be set at any time. */

SDL_HINT_ORIENTATIONS

SDL.Import

/** * \brief A variable controlling which orientations are allowed on iOS. * * In some circumstances it is necessary to be able to explicitly control * which UI orientations are allowed. * * This variable is a space delimited list of the following values: * "LandscapeLeft", "LandscapeRight", "Portrait" "PortraitUpsideDown" */

SDL_HINT_RENDER_DIRECT3D_THREADSAFE

SDL.Import

/** * \brief A hint that specifies whether the Direct3D device is initialized for thread-safe operations. * * By default the Direct3D device is created with thread-safety disabled. * * This variable can be set to the following values: * "0" - disable thread-safety (faster) * "1" - enable thread-safety (slower) */

SDL_HINT_RENDER_DRIVER

SDL.Import

/** * \brief A variable specifying which render driver to use. * * If the application doesn't pick a specific renderer to use, this variable * specifies the name of the preferred renderer. If the preferred renderer * can't be initialized, the normal default renderer is used. * * This variable is case insensitive and can be set to the following values: * "direct3d" * "opengl" * "opengles2" * "opengles" * "software" * * The default varies by platform, but it's the first one in the list that * is available on the current platform. */

SDL_HINT_RENDER_OPENGL_SHADERS

SDL.Import

/** * \brief A variable controlling whether the OpenGL render driver uses shaders if they are available. * * This variable can be set to the following values: * "0" - Disable shaders * "1" - Enable shaders * * By default shaders are used if OpenGL supports them. */

SDL_HINT_RENDER_SCALE_QUALITY

SDL.Import

/** * \brief A variable controlling the scaling quality * * This variable can be set to the following values: * "0" or "nearest" - Nearest pixel sampling * "1" or "linear" - Linear filtering (supported by OpenGL and Direct3D) * "2" or "best" - Currently this is the same as "linear" * * By default nearest pixel sampling is used */

SDL_HINT_RENDER_VSYNC

SDL.Import

/** * \brief A variable controlling whether updates to the SDL screen surface should be synchronized with the vertical refresh, to avoid tearing. * * This variable can be set to the following values: * "0" - Disable vsync * "1" - Enable vsync * * By default SDL does not sync screen surface updates with vertical refresh. */

SDL_HINT_TIMER_RESOLUTION

SDL.Import

/** * \brief A variable that controls the timer resolution, in milliseconds. * * The higher resolution the timer, the more frequently the CPU services * timer interrupts, and the more precise delays are, but this takes up * power and CPU time. This hint is only used on Windows 7 and earlier. * * See this blog post for more information: * http://randomascii.wordpress.com/2013/07/08/windows-timer-resolution-megawatts-wasted/ * * If this variable is set to "0", the system timer resolution is not set. * * The default value is "1". This hint may be set at any time. */

SDL_HINT_VIDEO_MINIMIZE_ON_FOCUS_LOSS

SDL.Import

/** * \brief Minimize your SDL_Window if it loses key focus when in Fullscreen mode. Defaults to true. * */

SDL_HINT_VIDEO_X11_XINERAMA

SDL.Import

/** * \brief A variable controlling whether the X11 Xinerama extension should be used. * * This variable can be set to the following values: * "0" - Disable Xinerama * "1" - Enable Xinerama * * By default SDL will use Xinerama if it is available. */

SDL_HINT_VIDEO_X11_XRANDR

SDL.Import

/** * \brief A variable controlling whether the X11 XRandR extension should be used. * * This variable can be set to the following values: * "0" - Disable XRandR * "1" - Enable XRandR * * By default SDL will not use XRandR because of window manager issues. */

SDL_HINT_VIDEO_X11_XVIDMODE

SDL.Import

/** * \brief A variable controlling whether the X11 VidMode extension should be used. * * This variable can be set to the following values: * "0" - Disable XVidMode * "1" - Enable XVidMode * * By default SDL will use XVidMode if it is available. */

SDL_HINT_XINPUT_ENABLED

SDL.Import

/** * \brief A variable that lets you disable the detection and use of Xinput gamepad devices * * The variable can be set to the following values: * "0" - Disable XInput timer (only uses direct input) * "1" - Enable XInput timer (the default) */

SDL_IGNORE

SDL.Import

SDL_INIT_AUDIO

SDL.Import

SDL_INIT_EVERYTHING

SDL.Import

Don't catch fatal signals

SDL_INIT_GAMECONTROLLER

SDL.Import

SDL_INIT_HAPTIC

SDL.Import

SDL_INIT_JOYSTICK

SDL.Import

SDL_INIT_NOPARACHUTE

SDL.Import

turn on game controller also implicitly does JOYSTICK

SDL_INIT_TIMER

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

SDL_INIT_VIDEO

SDL.Import

SDL_INVALID_SHAPE_ARGUMENT

SDL.Import

SDL_JOYAXISMOTION

SDL.Import

Joystick events

SDL_JOYBALLMOTION

SDL.Import

Joystick axis motion

SDL_JOYBUTTONDOWN

SDL.Import

Joystick hat position change

SDL_JOYBUTTONUP

SDL.Import

Joystick button pressed

SDL_JOYDEVICEADDED

SDL.Import

Joystick button released

SDL_JOYDEVICEREMOVED

SDL.Import

A new joystick has been inserted into the system

SDL_JOYHATMOTION

SDL.Import

Joystick trackball motion

SDL_KEYDOWN

SDL.Import

Keyboard events

SDL_KEYUP

SDL.Import

Key pressed

SDL_LASTEVENT

SDL.Import

** * This last event is only for bounding internal arrays (needed in pascal ??) *

SDL_LibName

SDL.Import

SDL_LIL_ENDIAN

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_byteorder.h //////////////////////////////////////////////// ///////////////////////////////////////////////////////////////////////////////////////////////////// SDL_byteorder.h constants The two types of endianness

SDL_MAJOR_VERSION

SDL.Import

* Printable format: "%d.%d.%d", MAJOR, MINOR, PATCHLEVEL *

SDL_MESSAGEBOX_BUTTON_ESCAPEKEY_DEFAULT

SDL.Import

**< Marks the default button when return is hit *

SDL_MESSAGEBOX_BUTTON_RETURNKEY_DEFAULT

SDL.Import

** * Flags for SDL_MessageBoxButtonData. *

SDL_MESSAGEBOX_ERROR

SDL.Import

** * SDL_MessageBox flags. If supported will display warning icon, etc. *

SDL_MESSAGEBOX_INFORMATION

SDL.Import

**< warning dialog *

SDL_MESSAGEBOX_WARNING

SDL.Import

**< error dialog *

SDL_MINOR_VERSION

SDL.Import

SDL_MIX_MAXVOLUME

SDL.Import

SDL_MOUSEBUTTONDOWN

SDL.Import

Mouse moved

SDL_MOUSEBUTTONUP

SDL.Import

Mouse button pressed

SDL_MOUSEMOTION

SDL.Import

Mouse events

SDL_MOUSEWHEEL

SDL.Import

Mouse button released

SDL_MULTIGESTURE

SDL.Import

SDL_MUTEX_TIMEDOUT

SDL.Import

** * Synchronization functions which can time out return this value * if they time out. *

SDL_NONSHAPEABLE_WINDOW

SDL.Import

** SDL_shape.h * * Header file for the shaped window API. *

SDL_NUM_SCANCODES

SDL.Import

* Add any other keys here. *

SDL_NUM_SYSTEM_CURSORS

SDL.Import

Hand

SDL_PACKEDLAYOUT_1010102

SDL.Import

SDL_PACKEDLAYOUT_1555

SDL.Import

SDL_PACKEDLAYOUT_2101010

SDL.Import

SDL_PACKEDLAYOUT_332

SDL.Import

SDL_PACKEDLAYOUT_4444

SDL.Import

SDL_PACKEDLAYOUT_5551

SDL.Import

SDL_PACKEDLAYOUT_565

SDL.Import

SDL_PACKEDLAYOUT_8888

SDL.Import

SDL_PACKEDLAYOUT_NONE

SDL.Import

** Packed component layout. *

SDL_PACKEDORDER_ABGR

SDL.Import

SDL_PACKEDORDER_ARGB

SDL.Import

SDL_PACKEDORDER_BGRA

SDL.Import

SDL_PACKEDORDER_BGRX

SDL.Import

SDL_PACKEDORDER_NONE

SDL.Import

** Packed component order, high bit -> low bit. *

SDL_PACKEDORDER_RGBA

SDL.Import

SDL_PACKEDORDER_RGBX

SDL.Import

SDL_PACKEDORDER_XBGR

SDL.Import

SDL_PACKEDORDER_XRGB

SDL.Import

SDL_PATCHLEVEL

SDL.Import

SDL_PEEKEVENT

SDL.Import

SDL_PIXELFORMAT_ABGR1555

SDL.Import

SDL_PIXELFORMAT_ABGR4444

SDL.Import

SDL_PIXELFORMAT_ABGR8888

SDL.Import

SDL_PIXELFORMAT_ARGB1555

SDL.Import

SDL_PIXELFORMAT_ARGB2101010

SDL.Import

SDL_PIXELFORMAT_ARGB4444

SDL.Import

SDL_PIXELFORMAT_ARGB8888

SDL.Import

SDL_PIXELFORMAT_BGR24

SDL.Import

SDL_PIXELFORMAT_BGR555

SDL.Import

SDL_PIXELFORMAT_BGR565

SDL.Import

SDL_PIXELFORMAT_BGR888

SDL.Import

SDL_PIXELFORMAT_BGRA4444

SDL.Import

SDL_PIXELFORMAT_BGRA5551

SDL.Import

SDL_PIXELFORMAT_BGRA8888

SDL.Import

SDL_PIXELFORMAT_BGRX8888

SDL.Import

SDL_PIXELFORMAT_INDEX1LSB

SDL.Import

SDL_PIXELFORMAT_INDEX1MSB

SDL.Import

SDL_PIXELFORMAT_INDEX4LSB

SDL.Import

SDL_PIXELFORMAT_INDEX4MSB

SDL.Import

SDL_PIXELFORMAT_INDEX8

SDL.Import

SDL_PIXELFORMAT_IYUV

SDL.Import

**< Planar mode: Y + U + V (3 planes) *

SDL_PIXELFORMAT_RGB24

SDL.Import

SDL_PIXELFORMAT_RGB332

SDL.Import

SDL_PIXELFORMAT_RGB444

SDL.Import

SDL_PIXELFORMAT_RGB555

SDL.Import

SDL_PIXELFORMAT_RGB565

SDL.Import

SDL_PIXELFORMAT_RGB888

SDL.Import

SDL_PIXELFORMAT_RGBA4444

SDL.Import

SDL_PIXELFORMAT_RGBA5551

SDL.Import

SDL_PIXELFORMAT_RGBA8888

SDL.Import

SDL_PIXELFORMAT_RGBX8888

SDL.Import

SDL_PIXELFORMAT_UNKNOWN

SDL.Import

#define SDL_BYTESPERPIXEL(X) \ (SDL_ISPIXELFORMAT_FOURCC(X) ? \ ((((X) == SDL_PIXELFORMAT_YUY2) || \ ((X) == SDL_PIXELFORMAT_UYVY) || \ ((X) == SDL_PIXELFORMAT_YVYU)) ? 2 : 1) : (((X) >> 0) & 0xFF))
#define SDL_ISPIXELFORMAT_INDEXED(format) \ (!SDL_ISPIXELFORMAT_FOURCC(format) && \ ((SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX1) || \ (SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX4) || \ (SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX8)))
#define SDL_ISPIXELFORMAT_ALPHA(format) \ (!SDL_ISPIXELFORMAT_FOURCC(format) && \ ((SDL_PIXELORDER(format) == SDL_PACKEDORDER_ARGB) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_RGBA) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_ABGR) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_BGRA)))
function SDL_IsPixelFormat_FOURCC(format: Variant);
{* Note: If you modify this list, update SDL_GetPixelFormatName() *

SDL_PIXELFORMAT_UYVY

SDL.Import

**< Packed mode: U0+Y0+V0+Y1 (1 plane) *

SDL_PIXELFORMAT_YUY2

SDL.Import

**< Packed mode: Y0+U0+Y1+V0 (1 plane) *

SDL_PIXELFORMAT_YV12

SDL.Import

**< Planar mode: Y + V + U (3 planes) *

SDL_PIXELFORMAT_YVYU

SDL.Import

**< Packed mode: Y0+V0+Y1+U0 (1 plane) *

SDL_PIXELTYPE_ARRAYF16

SDL.Import

SDL_PIXELTYPE_ARRAYF32

SDL.Import

SDL_PIXELTYPE_ARRAYU16

SDL.Import

SDL_PIXELTYPE_ARRAYU32

SDL.Import

SDL_PIXELTYPE_ARRAYU8

SDL.Import

SDL_PIXELTYPE_INDEX1

SDL.Import

SDL_PIXELTYPE_INDEX4

SDL.Import

SDL_PIXELTYPE_INDEX8

SDL.Import

SDL_PIXELTYPE_PACKED16

SDL.Import

SDL_PIXELTYPE_PACKED32

SDL.Import

SDL_PIXELTYPE_PACKED8

SDL.Import

SDL_PIXELTYPE_UNKNOWN

SDL.Import

** Pixel type. *

SDL_PREALLOC

SDL.Import

**< Just here for compatibility *

SDL_QUERY

SDL.Import

SDL_QUITEV

SDL.Import

Application events

SDL_RENDERER_ACCELERATED

SDL.Import

**< The renderer is a software fallback *

SDL_RENDERER_PRESENTVSYNC

SDL.Import

**< The renderer uses hardware acceleration *

SDL_RENDERER_SOFTWARE

SDL.Import

** * Flags used when creating a rendering context *

SDL_RENDERER_TARGETTEXTURE

SDL.Import

**< Present is synchronized with the refresh rate *

SDL_RLEACCEL

SDL.Import

**< Surface uses preallocated memory *

SDL_RWOPS_JNIFILE

SDL.Import

* Stdio file *

SDL_RWOPS_MEMORY

SDL.Import

* Android asset *

SDL_RWOPS_MEMORY_RO

SDL.Import

* Memory stream *

SDL_RWOPS_STDFILE

SDL.Import

* Win32 file *

SDL_RWOPS_UNKNOWN

SDL.Import

* RWops Types *

SDL_RWOPS_WINFILE

SDL.Import

* Unknown stream type *

SDL_SCANCODE_0

SDL.Import

SDL_SCANCODE_1

SDL.Import

SDL_SCANCODE_2

SDL.Import

SDL_SCANCODE_3

SDL.Import

SDL_SCANCODE_4

SDL.Import

SDL_SCANCODE_5

SDL.Import

SDL_SCANCODE_6

SDL.Import

SDL_SCANCODE_7

SDL.Import

SDL_SCANCODE_8

SDL.Import

SDL_SCANCODE_9

SDL.Import

SDL_SCANCODE_A

SDL.Import

** * Usage page $07 * * These values are from usage page $07 (USB keyboard page). *

SDL_SCANCODE_AC_BACK

SDL.Import

SDL_SCANCODE_AC_BOOKMARKS

SDL.Import

SDL_SCANCODE_AC_FORWARD

SDL.Import

SDL_SCANCODE_AC_HOME

SDL.Import

SDL_SCANCODE_AC_REFRESH

SDL.Import

SDL_SCANCODE_AC_SEARCH

SDL.Import

SDL_SCANCODE_AC_STOP

SDL.Import

SDL_SCANCODE_AGAIN

SDL.Import

SDL_SCANCODE_ALTERASE

SDL.Import

**< reserved *

SDL_SCANCODE_APOSTROPHE

SDL.Import

SDL_SCANCODE_APP1

SDL.Import

SDL_SCANCODE_APP2

SDL.Import

SDL_SCANCODE_APPLICATION

SDL.Import

**< This is the additional key that ISO * keyboards have over ANSI ones; * located between left shift and Y. * Produces GRAVE ACCENT and TILDE in a * US or UK Mac layout; REVERSE SOLIDUS * (backslash) and VERTICAL LINE in a * US or UK Windows layout; and * LESS-THAN SIGN and GREATER-THAN SIGN * in a Swiss German; German; or French * layout. *

SDL_SCANCODE_AUDIOMUTE

SDL.Import

SDL_SCANCODE_AUDIONEXT

SDL.Import

** * Usage page $0C * * These values are mapped from usage page $0C (USB consumer page). *

SDL_SCANCODE_AUDIOPLAY

SDL.Import

SDL_SCANCODE_AUDIOPREV

SDL.Import

SDL_SCANCODE_AUDIOSTOP

SDL.Import

SDL_SCANCODE_B

SDL.Import

SDL_SCANCODE_BACKSLASH

SDL.Import

SDL_SCANCODE_BACKSPACE

SDL.Import

SDL_SCANCODE_BRIGHTNESSDOWN

SDL.Import

** * Walther keys * * These are values that Christian Walther added (for mac keyboard?). *

SDL_SCANCODE_BRIGHTNESSUP

SDL.Import

SDL_SCANCODE_C

SDL.Import

SDL_SCANCODE_CALCULATOR

SDL.Import

SDL_SCANCODE_CANCEL

SDL.Import

SDL_SCANCODE_CAPSLOCK

SDL.Import

SDL_SCANCODE_CLEAR

SDL.Import

SDL_SCANCODE_CLEARAGAIN

SDL.Import

SDL_SCANCODE_COMMA

SDL.Import

**< Located in the top left corner (on both ANSI * and ISO keyboards). Produces GRAVE ACCENT and * TILDE in a US Windows layout and in US and UK * Mac layouts on ANSI keyboards; GRAVE ACCENT * and NOT SIGN in a UK Windows layout; SECTION * SIGN and PLUS-MINUS SIGN in US and UK Mac * layouts on ISO keyboards; SECTION SIGN and * DEGREE SIGN in a Swiss German layout (Mac: * only on ISO keyboards); CIRCUMFLEX ACCENT and * DEGREE SIGN in a German layout (Mac: only on * ISO keyboards); SUPERSCRIPT TWO and TILDE in a * French Windows layout; COMMERCIAL AT and * NUMBER SIGN in a French Mac layout on ISO * keyboards; and LESS-THAN SIGN and GREATER-THAN * SIGN in a Swiss German; German; or French Mac * layout on ANSI keyboards. *

SDL_SCANCODE_COMPUTER

SDL.Import

SDL_SCANCODE_COPY

SDL.Import

SDL_SCANCODE_CRSEL

SDL.Import

SDL_SCANCODE_CURRENCYSUBUNIT

SDL.Import

SDL_SCANCODE_CURRENCYUNIT

SDL.Import

SDL_SCANCODE_CUT

SDL.Import

SDL_SCANCODE_D

SDL.Import

SDL_SCANCODE_DECIMALSEPARATOR

SDL.Import

SDL_SCANCODE_DELETE

SDL.Import

SDL_SCANCODE_DISPLAYSWITCH

SDL.Import

SDL_SCANCODE_DOWN

SDL.Import

SDL_SCANCODE_E

SDL.Import

SDL_SCANCODE_EJECT

SDL.Import

SDL_SCANCODE_END

SDL.Import

SDL_SCANCODE_EQUALS

SDL.Import

SDL_SCANCODE_ESCAPE

SDL.Import

SDL_SCANCODE_EXECUTE

SDL.Import

SDL_SCANCODE_EXSEL

SDL.Import

SDL_SCANCODE_F

SDL.Import

SDL_SCANCODE_F1

SDL.Import

SDL_SCANCODE_F10

SDL.Import

SDL_SCANCODE_F11

SDL.Import

SDL_SCANCODE_F12

SDL.Import

SDL_SCANCODE_F13

SDL.Import

SDL_SCANCODE_F14

SDL.Import

SDL_SCANCODE_F15

SDL.Import

SDL_SCANCODE_F16

SDL.Import

SDL_SCANCODE_F17

SDL.Import

SDL_SCANCODE_F18

SDL.Import

SDL_SCANCODE_F19

SDL.Import

SDL_SCANCODE_F2

SDL.Import

SDL_SCANCODE_F20

SDL.Import

SDL_SCANCODE_F21

SDL.Import

SDL_SCANCODE_F22

SDL.Import

SDL_SCANCODE_F23

SDL.Import

SDL_SCANCODE_F24

SDL.Import

SDL_SCANCODE_F3

SDL.Import

SDL_SCANCODE_F4

SDL.Import

SDL_SCANCODE_F5

SDL.Import

SDL_SCANCODE_F6

SDL.Import

SDL_SCANCODE_F7

SDL.Import

SDL_SCANCODE_F8

SDL.Import

SDL_SCANCODE_F9

SDL.Import

SDL_SCANCODE_FIND

SDL.Import

SDL_SCANCODE_G

SDL.Import

SDL_SCANCODE_GRAVE

SDL.Import

SDL_SCANCODE_H

SDL.Import

SDL_SCANCODE_HELP

SDL.Import

SDL_SCANCODE_HOME

SDL.Import

**< insert on PC; help on some Mac keyboards (but does send code 73; not 117) *

SDL_SCANCODE_I

SDL.Import

SDL_SCANCODE_INSERT

SDL.Import

SDL_SCANCODE_INTERNATIONAL1

SDL.Import

SDL_SCANCODE_INTERNATIONAL2

SDL.Import

**< used on Asian keyboards; see footnotes in USB doc *

SDL_SCANCODE_INTERNATIONAL3

SDL.Import

SDL_SCANCODE_INTERNATIONAL4

SDL.Import

**< Yen *

SDL_SCANCODE_INTERNATIONAL5

SDL.Import

SDL_SCANCODE_INTERNATIONAL6

SDL.Import

SDL_SCANCODE_INTERNATIONAL7

SDL.Import

SDL_SCANCODE_INTERNATIONAL8

SDL.Import

SDL_SCANCODE_INTERNATIONAL9

SDL.Import

SDL_SCANCODE_J

SDL.Import

SDL_SCANCODE_K

SDL.Import

SDL_SCANCODE_KBDILLUMDOWN

SDL.Import

SDL_SCANCODE_KBDILLUMTOGGLE

SDL.Import

**< display mirroring{dual display switch; video mode switch *

SDL_SCANCODE_KBDILLUMUP

SDL.Import

SDL_SCANCODE_KP_0

SDL.Import

SDL_SCANCODE_KP_00

SDL.Import

SDL_SCANCODE_KP_000

SDL.Import

SDL_SCANCODE_KP_1

SDL.Import

SDL_SCANCODE_KP_2

SDL.Import

SDL_SCANCODE_KP_3

SDL.Import

SDL_SCANCODE_KP_4

SDL.Import

SDL_SCANCODE_KP_5

SDL.Import

SDL_SCANCODE_KP_6

SDL.Import

SDL_SCANCODE_KP_7

SDL.Import

SDL_SCANCODE_KP_8

SDL.Import

SDL_SCANCODE_KP_9

SDL.Import

SDL_SCANCODE_KP_A

SDL.Import

SDL_SCANCODE_KP_AMPERSAND

SDL.Import

SDL_SCANCODE_KP_AT

SDL.Import

SDL_SCANCODE_KP_B

SDL.Import

SDL_SCANCODE_KP_BACKSPACE

SDL.Import

SDL_SCANCODE_KP_BINARY

SDL.Import

SDL_SCANCODE_KP_C

SDL.Import

SDL_SCANCODE_KP_CLEAR

SDL.Import

SDL_SCANCODE_KP_CLEARENTRY

SDL.Import

SDL_SCANCODE_KP_COLON

SDL.Import

SDL_SCANCODE_KP_COMMA

SDL.Import

* SDL_SCANCODE_LOCKINGSCROLLLOCK = 132; *

SDL_SCANCODE_KP_D

SDL.Import

SDL_SCANCODE_KP_DBLAMPERSAND

SDL.Import

SDL_SCANCODE_KP_DBLVERTICALBAR

SDL.Import

SDL_SCANCODE_KP_DECIMAL

SDL.Import

SDL_SCANCODE_KP_DIVIDE

SDL.Import

**< num lock on PC; clear on Mac keyboards *

SDL_SCANCODE_KP_E

SDL.Import

SDL_SCANCODE_KP_ENTER

SDL.Import

SDL_SCANCODE_KP_EQUALS

SDL.Import

**< The USB document says this is a status flag; * not a physical key - but some Mac keyboards * do have a power key. *

SDL_SCANCODE_KP_EQUALSAS400

SDL.Import

SDL_SCANCODE_KP_EXCLAM

SDL.Import

SDL_SCANCODE_KP_F

SDL.Import

SDL_SCANCODE_KP_GREATER

SDL.Import

SDL_SCANCODE_KP_HASH

SDL.Import

SDL_SCANCODE_KP_HEXADECIMAL

SDL.Import

SDL_SCANCODE_KP_LEFTBRACE

SDL.Import

SDL_SCANCODE_KP_LEFTPAREN

SDL.Import

SDL_SCANCODE_KP_LESS

SDL.Import

SDL_SCANCODE_KP_MEMADD

SDL.Import

SDL_SCANCODE_KP_MEMCLEAR

SDL.Import

SDL_SCANCODE_KP_MEMDIVIDE

SDL.Import

SDL_SCANCODE_KP_MEMMULTIPLY

SDL.Import

SDL_SCANCODE_KP_MEMRECALL

SDL.Import

SDL_SCANCODE_KP_MEMSTORE

SDL.Import

SDL_SCANCODE_KP_MEMSUBTRACT

SDL.Import

SDL_SCANCODE_KP_MINUS

SDL.Import

SDL_SCANCODE_KP_MULTIPLY

SDL.Import

SDL_SCANCODE_KP_OCTAL

SDL.Import

SDL_SCANCODE_KP_PERCENT

SDL.Import

SDL_SCANCODE_KP_PERIOD

SDL.Import

SDL_SCANCODE_KP_PLUS

SDL.Import

SDL_SCANCODE_KP_PLUSMINUS

SDL.Import

SDL_SCANCODE_KP_POWER

SDL.Import

SDL_SCANCODE_KP_RIGHTBRACE

SDL.Import

SDL_SCANCODE_KP_RIGHTPAREN

SDL.Import

SDL_SCANCODE_KP_SPACE

SDL.Import

SDL_SCANCODE_KP_TAB

SDL.Import

SDL_SCANCODE_KP_VERTICALBAR

SDL.Import

SDL_SCANCODE_KP_XOR

SDL.Import

SDL_SCANCODE_L

SDL.Import

SDL_SCANCODE_LALT

SDL.Import

SDL_SCANCODE_LANG1

SDL.Import

SDL_SCANCODE_LANG2

SDL.Import

**< Hangul{English toggle *

SDL_SCANCODE_LANG3

SDL.Import

**< Hanja conversion *

SDL_SCANCODE_LANG4

SDL.Import

**< Katakana *

SDL_SCANCODE_LANG5

SDL.Import

**< Hiragana *

SDL_SCANCODE_LANG6

SDL.Import

**< Zenkaku{Hankaku *

SDL_SCANCODE_LANG7

SDL.Import

**< reserved *

SDL_SCANCODE_LANG8

SDL.Import

**< reserved *

SDL_SCANCODE_LANG9

SDL.Import

**< reserved *

SDL_SCANCODE_LCTRL

SDL.Import

SDL_SCANCODE_LEFT

SDL.Import

SDL_SCANCODE_LEFTBRACKET

SDL.Import

SDL_SCANCODE_LGUI

SDL.Import

**< alt; option *

SDL_SCANCODE_LSHIFT

SDL.Import

SDL_SCANCODE_M

SDL.Import

SDL_SCANCODE_MAIL

SDL.Import

SDL_SCANCODE_MEDIASELECT

SDL.Import

SDL_SCANCODE_MENU

SDL.Import

SDL_SCANCODE_MINUS

SDL.Import

SDL_SCANCODE_MODE

SDL.Import

**< windows; command (apple); meta *

SDL_SCANCODE_MUTE

SDL.Import

SDL_SCANCODE_N

SDL.Import

SDL_SCANCODE_NONUSBACKSLASH

SDL.Import

SDL_SCANCODE_NONUSHASH

SDL.Import

**< Located at the lower left of the return * key on ISO keyboards and at the right end * of the QWERTY row on ANSI keyboards. * Produces REVERSE SOLIDUS (backslash) and * VERTICAL LINE in a US layout; REVERSE * SOLIDUS and VERTICAL LINE in a UK Mac * layout; NUMBER SIGN and TILDE in a UK * Windows layout; DOLLAR SIGN and POUND SIGN * in a Swiss German layout; NUMBER SIGN and * APOSTROPHE in a German layout; GRAVE * ACCENT and POUND SIGN in a French Mac * layout; and ASTERISK and MICRO SIGN in a * French Windows layout. *

SDL_SCANCODE_NUMLOCKCLEAR

SDL.Import

SDL_SCANCODE_O

SDL.Import

SDL_SCANCODE_OPER

SDL.Import

SDL_SCANCODE_OUT

SDL.Import

SDL_SCANCODE_P

SDL.Import

SDL_SCANCODE_PAGEDOWN

SDL.Import

SDL_SCANCODE_PAGEUP

SDL.Import

SDL_SCANCODE_PASTE

SDL.Import

SDL_SCANCODE_PAUSE

SDL.Import

SDL_SCANCODE_PERIOD

SDL.Import

SDL_SCANCODE_POWER

SDL.Import

**< windows contextual menu; compose *

SDL_SCANCODE_PRINTSCREEN

SDL.Import

SDL_SCANCODE_PRIOR

SDL.Import

SDL_SCANCODE_Q

SDL.Import

SDL_SCANCODE_R

SDL.Import

SDL_SCANCODE_RALT

SDL.Import

SDL_SCANCODE_RCTRL

SDL.Import

**< windows; command (apple); meta *

SDL_SCANCODE_RETURN

SDL.Import

SDL_SCANCODE_RETURN2

SDL.Import

SDL_SCANCODE_RGUI

SDL.Import

**< alt gr; option *

SDL_SCANCODE_RIGHT

SDL.Import

SDL_SCANCODE_RIGHTBRACKET

SDL.Import

SDL_SCANCODE_RSHIFT

SDL.Import

SDL_SCANCODE_S

SDL.Import

SDL_SCANCODE_SCROLLLOCK

SDL.Import

SDL_SCANCODE_SELECT

SDL.Import

SDL_SCANCODE_SEMICOLON

SDL.Import

**< ISO USB keyboards actually use this code * instead of 49 for the same key; but all * OSes I've seen treat the two codes * identically. So; as an implementor; unless * your keyboard generates both of those * codes and your OS treats them differently; * you should generate SDL_SCANCODE_BACKSLASH * instead of this code. As a user; you * should not rely on this code because SDL * will never generate it with most (all?) * keyboards. *

SDL_SCANCODE_SEPARATOR

SDL.Import

SDL_SCANCODE_SLASH

SDL.Import

SDL_SCANCODE_SLEEP

SDL.Import

SDL_SCANCODE_SPACE

SDL.Import

SDL_SCANCODE_STOP

SDL.Import

SDL_SCANCODE_SYSREQ

SDL.Import

**< Erase-Eaze *

SDL_SCANCODE_T

SDL.Import

SDL_SCANCODE_TAB

SDL.Import

SDL_SCANCODE_THOUSANDSSEPARATOR

SDL.Import

SDL_SCANCODE_U

SDL.Import

SDL_SCANCODE_UNDO

SDL.Import

**< redo *

SDL_SCANCODE_UNKNOWN

SDL.Import

** * The SDL keyboard scancode representation. * * Values of this type are used to represent keyboard keys, among other places * in the SDL_Keysym.scancode key.keysym.scancode \endlink field of the * SDL_Event structure. * * The values in this enumeration are based on the USB usage page standard: * http://www.usb.org/developers/devclass_docs/Hut1_12v2.pdf *

SDL_SCANCODE_UP

SDL.Import

SDL_SCANCODE_V

SDL.Import

SDL_SCANCODE_VOLUMEDOWN

SDL.Import

SDL_SCANCODE_VOLUMEUP

SDL.Import

SDL_SCANCODE_W

SDL.Import

SDL_SCANCODE_WWW

SDL.Import

SDL_SCANCODE_X

SDL.Import

SDL_SCANCODE_Y

SDL.Import

SDL_SCANCODE_Z

SDL.Import

SDL_SWSURFACE

SDL.Import

** * Surface flags * * These are the currently supported flags for the ::SDL_surface. * * Used internally (read-only). *

SDL_SYSTEM_CURSOR_ARROW

SDL.Import

** * Cursor types for SDL_CreateSystemCursor. *

SDL_SYSTEM_CURSOR_CROSSHAIR

SDL.Import

Wait

SDL_SYSTEM_CURSOR_HAND

SDL.Import

Slashed circle or crossbones

SDL_SYSTEM_CURSOR_IBEAM

SDL.Import

Arrow

SDL_SYSTEM_CURSOR_NO

SDL.Import

Four pointed arrow pointing north, south, east, and west

SDL_SYSTEM_CURSOR_SIZEALL

SDL.Import

Double arrow pointing north and south

SDL_SYSTEM_CURSOR_SIZENESW

SDL.Import

Double arrow pointing northwest and southeast

SDL_SYSTEM_CURSOR_SIZENS

SDL.Import

Double arrow pointing west and east

SDL_SYSTEM_CURSOR_SIZENWSE

SDL.Import

Small wait cursor (or Wait if not available)

SDL_SYSTEM_CURSOR_SIZEWE

SDL.Import

Double arrow pointing northeast and southwest

SDL_SYSTEM_CURSOR_WAIT

SDL.Import

I-beam

SDL_SYSTEM_CURSOR_WAITARROW

SDL.Import

Crosshair

SDL_SYSWMEVENT

SDL.Import

Window state change

SDL_TEXTEDITING

SDL.Import

Key released

SDL_TEXTEDITINGEVENT_TEXT_SIZE

SDL.Import

SDL_TEXTINPUT

SDL.Import

Keyboard text editing (composition)

SDL_TEXTINPUTEVENT_TEXT_SIZE

SDL.Import

SDL_TOUCH_MOUSEID

SDL.Import

* Used as the device ID for mouse events simulated with touch input *

SDL_USEREVENT

SDL.Import

** Events SDL_USEREVENT through SDL_LASTEVENT are for your use, * and should be allocated with SDL_RegisterEvents() *

SDL_WINDOWEVENT

SDL.Import

Window events

SDL_WINDOWEVENT_CLOSE

SDL.Import

**< Window has lost keyboard focus *

SDL_WINDOWEVENT_ENTER

SDL.Import

**< Window has been restored to normal size and position *

SDL_WINDOWEVENT_EXPOSED

SDL.Import

**< Window has been hidden *

SDL_WINDOWEVENT_FOCUS_GAINED

SDL.Import

**< Window has lost mouse focus *

SDL_WINDOWEVENT_FOCUS_LOST

SDL.Import

**< Window has gained keyboard focus *

SDL_WINDOWEVENT_HIDDEN

SDL.Import

**< Window has been shown *

SDL_WINDOWEVENT_LEAVE

SDL.Import

**< Window has gained mouse focus *

SDL_WINDOWEVENT_MAXIMIZED

SDL.Import

**< Window has been minimized *

SDL_WINDOWEVENT_MINIMIZED

SDL.Import

**< The window size has changed; either as a result of an API call or through the system or user changing the window size. *

SDL_WINDOWEVENT_MOVED

SDL.Import

**< Window has been exposed and should be redrawn *

SDL_WINDOWEVENT_NONE

SDL.Import

** * Event subtype for window events *

SDL_WINDOWEVENT_RESIZED

SDL.Import

**< Window has been moved to data1; data2 *

SDL_WINDOWEVENT_RESTORED

SDL.Import

**< Window has been maximized *

SDL_WINDOWEVENT_SHOWN

SDL.Import

**< Never used *

SDL_WINDOWEVENT_SIZE_CHANGED

SDL.Import

**< Window has been resized to data1xdata2 *

SDL_WINDOWPOS_CENTERED

SDL.Import

SDL_WINDOWPOS_CENTERED_MASK

SDL.Import

** * Used to indicate that the window position should be centered. *

SDL_WINDOWPOS_UNDEFINED

SDL.Import

SDL_WINDOWPOS_UNDEFINED_MASK

SDL.Import

** * Used to indicate that you don't care what the window position is. *

SDL_WINDOW_BORDERLESS

SDL.Import

**< window is not visible *

SDL_WINDOW_FOREIGN

SDL.Import

SDL_WINDOW_FULLSCREEN

SDL.Import

** * The flags on a window * * SDL_GetWindowFlags() *

SDL_WINDOW_FULLSCREEN_DESKTOP

SDL.Import

**< window has mouse focus *

SDL_WINDOW_HIDDEN

SDL.Import

**< window is visible *

SDL_WINDOW_INPUT_FOCUS

SDL.Import

**< window has grabbed input focus *

SDL_WINDOW_INPUT_GRABBED

SDL.Import

**< window is maximized *

SDL_WINDOW_LACKS_SHAPE

SDL.Import

SDL_WINDOW_MAXIMIZED

SDL.Import

**< window is minimized *

SDL_WINDOW_MINIMIZED

SDL.Import

**< window can be resized *

SDL_WINDOW_MOUSE_FOCUS

SDL.Import

**< window has input focus *

SDL_WINDOW_OPENGL

SDL.Import

**< fullscreen window *

SDL_WINDOW_RESIZABLE

SDL.Import

**< no window decoration *

SDL_WINDOW_SHOWN

SDL.Import

**< window usable with OpenGL context *

SEARCH_ANY

Formats.VFW

SEARCH_BACKWARD

Formats.VFW

SEARCH_FORWARD

Formats.VFW

SEARCH_KEY

Formats.VFW

SEARCH_NEAREST

Formats.VFW

AVIFileExit

SERIALIZE_ID_BOX

Newton.Import

SERIALIZE_ID_CAPSULE

Newton.Import

SERIALIZE_ID_CHAMFERCYLINDER

Newton.Import

SERIALIZE_ID_CLOTH_PATCH

Newton.Import

SERIALIZE_ID_COMPOUND

Newton.Import

SERIALIZE_ID_CONE

Newton.Import

SERIALIZE_ID_CONVEXHULL

Newton.Import

SERIALIZE_ID_CYLINDER

Newton.Import

SERIALIZE_ID_DEFORMABLE_SOLID

Newton.Import

SERIALIZE_ID_FRACTURED_COMPOUND

Newton.Import

SERIALIZE_ID_HEIGHTFIELD

Newton.Import

SERIALIZE_ID_NULL

Newton.Import

SERIALIZE_ID_SCENE

Newton.Import

SERIALIZE_ID_SPHERE

Newton.Import

NEWTON_DEFORMABLE_BODY = 2;

SERIALIZE_ID_TREE

Newton.Import

SERIALIZE_ID_USERMESH

Newton.Import

ShadowFilterMax3DS

Formats.m3DSConst

inclusive minimum value for shadow filter

ShadowFilterMin3DS

Formats.m3DSConst

noninclusive minimum value for shadow range SHADOW_FILTER chunk

ShadowMapSizeMin3DS

Formats.m3DSConst

noninclusive minimum value for high shadow bias setting SHADOW_MAP_SIZE chunk

ShadowRangeMin3DS

Formats.m3DSConst

noninclusive minimum value for shadow samples SHADOW_RANGE chunk

ShadowSamplesMin3DS

Formats.m3DSConst

noninclusive minimum value for shadow map size SHADOW_SAMPLES chunk

SHADOW_FILTER

Formats.m3DSConst

SHADOW_MAP_SIZE

Formats.m3DSConst

SHADOW_RANGE

Formats.m3DSConst

SHADOW_SAMPLES

Formats.m3DSConst

SHAPE_2D

Formats.m3DSConst

SHAPE_HOOK

Formats.m3DSConst

SHAPE_NOT_OK

Formats.m3DSConst

SHAPE_OK

Formats.m3DSConst

Flags in shaper AFile that tell whether polys make up an ok shape

SIDE_BACK

Formats.LWO

SIDE_FRONT

Formats.LWO

SIDE_FRONT_AND_BACK

Formats.LWO

SIGN

GLS.FileVfsPAK

SIGN

GLS.FileZLIB

SIGN

GLS.PAKArchive

SIGN_COMPRESSED

GLS.FileVfsPAK

Signature for uncompressed - raw pak.

SMAGIC

Formats.m3DSConst

Smooth01Group3DS

Formats.m3DSConst

Smoothing group Flags used in the smootharray field of the TMesh3DS structure

Smooth02Group3DS

Formats.m3DSConst

Smooth03Group3DS

Formats.m3DSConst

Smooth04Group3DS

Formats.m3DSConst

Smooth05Group3DS

Formats.m3DSConst

Smooth06Group3DS

Formats.m3DSConst

Smooth07Group3DS

Formats.m3DSConst

Smooth08Group3DS

Formats.m3DSConst

Smooth09Group3DS

Formats.m3DSConst

Smooth10Group3DS

Formats.m3DSConst

Smooth11Group3DS

Formats.m3DSConst

Smooth12Group3DS

Formats.m3DSConst

Smooth13Group3DS

Formats.m3DSConst

Smooth14Group3DS

Formats.m3DSConst

Smooth15Group3DS

Formats.m3DSConst

Smooth16Group3DS

Formats.m3DSConst

Smooth17Group3DS

Formats.m3DSConst

Smooth18Group3DS

Formats.m3DSConst

Smooth19Group3DS

Formats.m3DSConst

Smooth20Group3DS

Formats.m3DSConst

Smooth21Group3DS

Formats.m3DSConst

Smooth22Group3DS

Formats.m3DSConst

Smooth23Group3DS

Formats.m3DSConst

Smooth24Group3DS

Formats.m3DSConst

Smooth25Group3DS

Formats.m3DSConst

Smooth26Group3DS

Formats.m3DSConst

Smooth27Group3DS

Formats.m3DSConst

Smooth28Group3DS

Formats.m3DSConst

Smooth29Group3DS

Formats.m3DSConst

Smooth30Group3DS

Formats.m3DSConst

Smooth31Group3DS

Formats.m3DSConst

Smooth32Group3DS

Formats.m3DSConst

SMOOTH_GROUP

Formats.m3DSConst

SMOOTH_GROUP_ENTRY

Formats.m3DSConst

sNOT_QUAD

GLScene.VectorTypesExt

SOLID_BGND

Formats.m3DSConst

SPOTLIGHT_NODE_TAG

Formats.m3DSConst

sSINGULAR

GLScene.VectorTypesExt

str3DSMapNotFound

GLScene.Strings

File3DS

strAlreadyRendering

GLScene.Strings

strBackwardContextFailed

GLScene.Strings

strBadPlanSize

GLScene.Strings

strBrokenObjectListArchive

GLScene.Strings

strCadencerNotDefined

GLScene.Strings

Cadencer

strCadencerNotDefinedEx

GLScene.Strings

strCamera

GLScene.Strings

strCameraRoot

GLScene.Strings

strCannotAlterAnActiveContext

GLScene.Strings

Context

strCantConvertImg

GLScene.Strings

Graphics

strConnectJoystick

GLScene.Strings

strContextActivationFailed

GLScene.Strings

strContextAlreadyCreated

GLScene.Strings

strContextDeactivationFailed

GLScene.Strings

strContextNotCreated

GLScene.Strings

strContextNotInit

GLScene.Strings

strCUDAEditor

GLScene.Strings

strCUTILFailed

GLScene.Strings

FilePGM

strCyclicRefMat

GLScene.Strings

Material

strDeleteContextFailed

GLScene.Strings

strDisplayList

GLScene.Strings

strDot

GLScene.Strings

General

strDriverNotSupportDebugRC

GLScene.Strings

strDriverNotSupportFRC

GLScene.Strings

strDriverNotSupportOESRC

GLScene.Strings

STREAMFILE_BUFFER

BASS.Import

STREAMFILE_BUFFERPUSH

BASS.Import

STREAMFILE_NOBUFFER

BASS.Import

end of user stream flag BASS_StreamCreateFileUser file systems

STREAMPROC_DEVICE

BASS.Import

push stream

STREAMPROC_DEVICE_3D

BASS.Import

device mix stream

STREAMPROC_DUMMY

BASS.Import

Special STREAMPROCs

STREAMPROC_PUSH

BASS.Import

"dummy" stream

streamtypeAUDIO

Formats.VFW

mmioFOURCC('v', 'i', 'd', 's')

streamtypeMIDI

Formats.VFW

mmioFOURCC('a', 'u', 'd', 's')

streamtypeTEXT

Formats.VFW

mmioFOURCC('m', 'i', 'd', 's')

streamtypeVIDEO

Formats.VFW

– Stream types for the <fccType> field of the stream header —————-

strError

GLScene.Strings

strError3DS_CLOSING_FILE

GLScene.Strings

strError3DS_CREATING_DATABASE

GLScene.Strings

strError3DS_GET_FAIL

GLScene.Strings

strError3DS_INIT_FAILED

GLScene.Strings

strError3DS_INVALID_ARG

GLScene.Strings

strError3DS_INVALID_CHUNK

GLScene.Strings

strError3DS_INVALID_DATA

GLScene.Strings

strError3DS_INVALID_DATABASE

GLScene.Strings

strError3DS_INVALID_INDEX

GLScene.Strings

strError3DS_NO_MEM

GLScene.Strings

strError3DS_NO_SUCH_FILE

GLScene.Strings

strError3DS_OPENING_FILE

GLScene.Strings

strError3DS_PUT_FAIL

GLScene.Strings

strError3DS_READING_DATABASE

GLScene.Strings

strError3DS_READING_FILE

GLScene.Strings

strError3DS_STRING_TOO_LONG

GLScene.Strings

strError3DS_UNFOUND_CHUNK

GLScene.Strings

strError3DS_WRITING_DATABASE

GLScene.Strings

strError3DS_WRITING_FILE

GLScene.Strings

strError3DS_WRONG_DATABASE

GLScene.Strings

strError3DS_WRONG_OBJECT

GLScene.Strings

strErrorEx

GLScene.Strings

strErrorLIB

GLScene.Strings

strFailCompilation

GLScene.Strings

strFailCreatePipe

GLScene.Strings

strFailedOpenFile

GLScene.Strings

strFailedOpenFileFromCurrentDir

GLScene.Strings

strFailedToShare

GLScene.Strings

strFailHWRC

GLScene.Strings

strFailMap

GLScene.Strings

strFailRunNVCC

GLScene.Strings

strFailToBindArrayToTex

GLScene.Strings

strFailUnmap

GLScene.Strings

strFFTFuncRetErr

GLScene.Strings

strFileNotFound

GLScene.Strings

strForwardContextFailed

GLScene.Strings

SceneContext

strFRC_created

GLScene.Strings

strFuncNotConnected

GLScene.Strings

strFuncRetErr

GLScene.Strings

strGLSceneEditor

GLScene.Strings

SceneEdit

strImageInvalid

GLScene.Strings

Textures

strIncompatibleContexts

GLScene.Strings

strIncompatibleTypes

GLScene.Strings

strInterleaveNotSupported

GLScene.Strings

strInvalidColor

GLScene.Strings

Utils

strInvalidContextReg

GLScene.Strings

strInvalidContextRegistration

GLScene.Strings

strInvalidFileSignature

GLScene.Strings

PersistentClasses

strInvalidGLContext

GLScene.Strings

strInvalidNotificationRemoval

GLScene.Strings

strInvalidParamType

GLScene.Strings

strInvalidType

GLScene.Strings

strInvalidValue

GLScene.Strings

strJoystickError

GLScene.Strings

strLaunchFailed

GLScene.Strings

strLayoutCategoryName

GLScene.Strings

strListIndexError

GLScene.Strings

strLocalizableCategoryName

GLScene.Strings

strMakeFloatingFail

GLScene.Strings

strMaterialNotFound

GLScene.Strings

strMaterialNotFoundInMatlib

GLScene.Strings

strMaterialNotFoundInMatlibEx

GLScene.Strings

strMatLibNotDefined

GLScene.Strings

Materials

strMissingResource

GLScene.Strings

strModuleAbsent

GLScene.Strings

CUDA strings

strNoActiveRC

GLScene.Strings

strNoDescriptionAvailable

GLScene.Strings

strNoDeviceToCreate

GLScene.Strings

strNoJoystickDriver

GLScene.Strings

Joystick

strNoNewTexture

GLScene.Strings

strNoRenderingContext

GLScene.Strings

SceneViewer

strNothing

GLScene.Strings

strObjectRoot

GLScene.Strings

strObjectsNotSupported

GLScene.Strings

strOCAdvancedGeometry

GLScene.Strings

strOCBasicGeometry

GLScene.Strings

Object categories in GLScene Registry

strOCDoodad

GLScene.Strings

strOCEnvironmentObjects

GLScene.Strings

strOCExperimental

GLScene.Strings

strOCGraphPlottingObjects

GLScene.Strings

strOCGuiObjects

GLScene.Strings

strOCHUDObjects

GLScene.Strings

strOCMeshObjects

GLScene.Strings

strOCParticleSystems

GLScene.Strings

strOCProxyObjects

GLScene.Strings

strOCSpecialObjects

GLScene.Strings

strOctreeMustBePreparedBeforeUse

GLScene.Strings

Octree

strOESRC_created

GLScene.Strings

strOESvsForwardRC

GLScene.Strings

strOnlyHostData

GLScene.Strings

strOpenGLCategoryName

GLScene.Strings

SceneRegister, strings additional to Designintf

strOpenGLError

GLScene.Strings

InitOpenGL

strOutOfAttribSize

GLScene.Strings

strOutOfElementSize

GLScene.Strings

strOutOfMemory

GLScene.Strings

strOutOfRange

GLScene.Strings

strPBufferRC_created

GLScene.Strings

strRequireFreeThread

GLScene.Strings

strSceneRoot

GLScene.Strings

Tree

strSceneViewerNotDefined

GLScene.Strings

strShaderNeedsAtLeastOneLightSource

GLScene.Strings

Shaders

strShaderNeedsAtLeastOneLightSourceEx

GLScene.Strings

strSizeMismatch

GLScene.Strings

strSourceFileNotFound

GLScene.Strings

strSphereStartStop

GLScene.Strings

strSphereTopBottom

GLScene.Strings

Objects

strStateCashMissing

GLScene.Strings

strSuccessCompilation

GLScene.Strings

strThreadBusy

GLScene.Strings

strTmpRC_Created

GLScene.Strings

strTooManyLights

GLScene.Strings

strUnableToCreateLegacyContext

GLScene.Strings

strUnBalancedBeginEndUpdate

GLScene.Strings

strUnbalancedContexActivations

GLScene.Strings

strUnbalansedUsage

GLScene.Strings

strUnknownArchive

GLScene.Strings

Common messages

strUnknownArchiveVersion

GLScene.Strings

strUnknownExtension

GLScene.Strings

strUnknownParam

GLScene.Strings

strUnknownType

GLScene.Strings

strUnsupportedType

GLScene.Strings

strVisualCategoryName

GLScene.Strings

strWrongBitmapCanvas

GLScene.Strings

strWrongParamSetup

GLScene.Strings

strWrongPrinter

GLScene.Strings

strWrongVersion

GLScene.Strings

strXCollectionEditor

GLScene.Strings

FXCollectionEditor

SURF_FLAG_ADDITIVE

Formats.LWO

SURF_FLAG_COLORFILTER

Formats.LWO

SURF_FLAG_COLORHIGHLIGHTS

Formats.LWO

SURF_FLAG_DOUBLESIDED

Formats.LWO

SURF_FLAG_LUMINOUS

Formats.LWO

SURF_FLAG_OPAQUEEDGE

Formats.LWO

SURF_FLAG_OUTLINE

Formats.LWO

SURF_FLAG_SHADOWALPHA

Formats.LWO

SURF_FLAG_SHARPTERMINATOR

Formats.LWO

SURF_FLAG_SMOOTHING

Formats.LWO

SURF_FLAG_TRANSPARENTEDGE

Formats.LWO

sWRONG_ELEMENT

GLScene.VectorTypesExt

sWRONG_SIZE

GLScene.VectorTypesExt

TangentAttributeName

GLS.Objects

TARGET_NODE_TAG

Formats.m3DSConst

TEX_ALPHA_SOURCE

Formats.m3DSConst

summed area table

TEX_DECAL

Formats.m3DSConst

MAT_TILING

TEX_DONT_USE_ALPHA

Formats.m3DSConst

tint for color

TEX_INVERT

Formats.m3DSConst

TEX_MIRROR

Formats.m3DSConst

TEX_NOWRAP

Formats.m3DSConst

TEX_RGB_TINT

Formats.m3DSConst

don't use map alpha

TEX_SAT

Formats.m3DSConst

TEX_TINT

Formats.m3DSConst

use ALPHA instead of RGB of map

TEX_UNUSED1

Formats.m3DSConst

TEX_VERTS

Formats.m3DSConst

TEX_VERTS_ENTRY

Formats.m3DSConst

TopFalloff

Formats.m3DSConst

TrackHeaderKeysMin3DS

Formats.m3DSConst

Maximum key spline ease from Track header Limits

TrackLockX3DS

Formats.m3DSConst

TrackLockY3DS

Formats.m3DSConst

TrackLockZ3DS

Formats.m3DSConst

TrackLoops3DS

Formats.m3DSConst

TrackNoLinkX3DS

Formats.m3DSConst

TrackNoLinkY3DS

Formats.m3DSConst

TrackNoLinkZ3DS

Formats.m3DSConst

TrackRepeats3DS

Formats.m3DSConst

TrackSingle3DS

Formats.m3DSConst

flags used by the track flags field

TRIMESH_FACE_NORMALS

ODE.Import

enum (* TRIMESH_FACE_NORMALS, TRIMESH_LAST_TRANSFORMATION ; *)

TRIMESH_LAST_TRANSFORMATION

ODE.Import

UseMemoryMappedFiles

gnugettext

Set to true, to prefer external *.mo over embedded translation

USE_BEVEL

Formats.m3DSConst

USE_BIT_MAP

Formats.m3DSConst

USE_CONTOUR

Formats.m3DSConst

Flags for Modeler options

USE_DISTANCE_CUE

Formats.m3DSConst

USE_FIT

Formats.m3DSConst

USE_FOG

Formats.m3DSConst

USE_LAYER_FOG

Formats.m3DSConst

USE_SCALE

Formats.m3DSConst

USE_SOLID_BGND

Formats.m3DSConst

USE_TEETER

Formats.m3DSConst

USE_TWEEN

Formats.m3DSConst

USE_TWIST

Formats.m3DSConst

USE_V_GRADIENT

Formats.m3DSConst

VCAPS_CAN_SCALE

Formats.VFW

dst rect can clip

VCAPS_DST_CAN_CLIP

Formats.VFW

src rect can clip

VCAPS_OVERLAY

Formats.VFW

– dwFlags of CHANNEL_CAPS ————————————————–

VCAPS_SRC_CAN_CLIP

Formats.VFW

overlay channel

VCSVersion

gnugettext

Set to True, to reread mo-file if the current language is selected again Subversion source code version control version information

VerticalScalingFactor

GLS.RandomHDS

VGradientMax3DS

Formats.m3DSConst

minimum value for gradient midpoint

VGradientMin3DS

Formats.m3DSConst

maximum string length for filename V_GRADIENT chunk

VHDR_DONE

Formats.VFW

– dwFlags field of VIDEOHDR ————————————————

VHDR_INQUEUE

Formats.VFW

Set if this header has been prepared

VHDR_KEYFRAME

Formats.VFW

Reserved for driver

VHDR_PREPARED

Formats.VFW

Done bit

VIDCF_COMPRESSFRAMES

Formats.VFW

supports inter-frame compress

VIDCF_CRUNCH

Formats.VFW

supports quality

VIDCF_DRAW

Formats.VFW

wants the compress all frames message

VIDCF_FASTTEMPORALC

Formats.VFW

supports drawing

VIDCF_FASTTEMPORALD

Formats.VFW

does not need prev frame on compress

VIDCF_QUALITY

Formats.VFW

– Flags for the <dwFlags> field of the <ICINFO> structure. ————

VIDCF_TEMPORAL

Formats.VFW

supports crunching to a frame size

VIDEO_CONFIGURE_CURRENT

Formats.VFW

VIDEO_CONFIGURE_GET

Formats.VFW

– videoConfigure (GET only) ————————————————

VIDEO_CONFIGURE_MAX

Formats.VFW

VIDEO_CONFIGURE_MIN

Formats.VFW

VIDEO_CONFIGURE_NOMINAL

Formats.VFW

VIDEO_CONFIGURE_QUERY

Formats.VFW

– videoConfigure (both GET and SET) —————————————-

VIDEO_CONFIGURE_QUERYSIZE

Formats.VFW

VIDEO_CONFIGURE_SET

Formats.VFW

– videoConfigure (SET only) ————————————————

VIDEO_DLG_QUERY

Formats.VFW

– Is a driver dialog available for this channel —————————-

VIDEO_EXTERNALIN

Formats.VFW

– Types of channels to open with the videoOpen function ——————–

VIDEO_EXTERNALOUT

Formats.VFW

VIDEO_IN

Formats.VFW

VIDEO_OUT

Formats.VFW

ViewCameraStrMax3DS

Formats.m3DSConst

maximum value for dimming factor VIEW_CAMERA

VIEWPORT_DATA

Formats.m3DSConst

VIEWPORT_DATA_3

Formats.m3DSConst

VIEWPORT_DATA_OLD

Formats.m3DSConst

VIEWPORT_LAYOUT

Formats.m3DSConst

VIEWPORT_LAYOUT_OLD

Formats.m3DSConst

Viewport description chunks

VIEWPORT_SIZE

Formats.m3DSConst

VIEW_BACK

Formats.m3DSConst

VIEW_BOTTOM

Formats.m3DSConst

VIEW_CAMERA

Formats.m3DSConst

VIEW_FRONT

Formats.m3DSConst

VIEW_LEFT

Formats.m3DSConst

VIEW_RIGHT

Formats.m3DSConst

VIEW_TOP

Formats.m3DSConst

VIEW_USER

Formats.m3DSConst

VIEW_WINDOW

Formats.m3DSConst

VK_MOUSEWHEELDOWN

GLScene.Keyboard

VK_MOUSEWHEELUP

GLScene.Keyboard

pseudo wheel keys (we squat F23/F24), see KeyboardNotifyWheelMoved

VMAP_TYPE_MNVW

Formats.LWO

WEIGHT MAP

VMAP_TYPE_MORF

Formats.LWO

RGBA MAP

VMAP_TYPE_PICK

Formats.LWO

SKELEGON?

VMAP_TYPE_RGB

Formats.LWO

UV MAP

VMAP_TYPE_RGBA

Formats.LWO

RGB MAP

VMAP_TYPE_SPOT

Formats.LWO

MORPH MAP: RELATIVE VERTEX DISPLACEMENT

VMAP_TYPE_TXUV

Formats.LWO

SUBPATCH WEIGHT MAP

VMAP_TYPE_WGHT

Formats.LWO

SELECTION SET

VPDATA

Formats.m3DSConst

Video Post

V_GRADIENT

Formats.m3DSConst

WGL_ACCELERATION_ARB

GLScene.OpenGL4

WGL_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_ACCELERATION_EXT

GLScene.OpenGL4

WGL_ACCESS_READ_ONLY_NV

GLScene.OpenGL4

WGL_NV_DX_interop

WGL_ACCESS_READ_ONLY_NV

GLScene.OpenGLTokens

WGL_NV_DX_interop (EXT #407)

WGL_ACCESS_READ_WRITE_NV

GLScene.OpenGL4

WGL_ACCESS_READ_WRITE_NV

GLScene.OpenGLTokens

WGL_ACCESS_WRITE_DISCARD_NV

GLScene.OpenGL4

WGL_ACCESS_WRITE_DISCARD_NV

GLScene.OpenGLTokens

WGL_ACCUM_ALPHA_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_ALPHA_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_ALPHA_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_BLUE_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_BLUE_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_BLUE_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_GREEN_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_GREEN_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_GREEN_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_RED_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_RED_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_RED_BITS_EXT

GLScene.OpenGL4

WGL_ALPHA_BITS_ARB

GLScene.OpenGL4

WGL_ALPHA_BITS_ARB

GLScene.OpenGLTokens

WGL_ALPHA_BITS_EXT

GLScene.OpenGL4

WGL_ALPHA_SHIFT_ARB

GLScene.OpenGL4

WGL_ALPHA_SHIFT_ARB

GLScene.OpenGLTokens

WGL_ALPHA_SHIFT_EXT

GLScene.OpenGL4

WGL_AUX0_ARB

GLScene.OpenGL4

WGL_AUX0_ARB

GLScene.OpenGLTokens

WGL_AUX1_ARB

GLScene.OpenGL4

WGL_AUX1_ARB

GLScene.OpenGLTokens

WGL_AUX2_ARB

GLScene.OpenGL4

WGL_AUX2_ARB

GLScene.OpenGLTokens

WGL_AUX3_ARB

GLScene.OpenGL4

WGL_AUX3_ARB

GLScene.OpenGLTokens

WGL_AUX4_ARB

GLScene.OpenGL4

WGL_AUX4_ARB

GLScene.OpenGLTokens

WGL_AUX5_ARB

GLScene.OpenGL4

WGL_AUX5_ARB

GLScene.OpenGLTokens

WGL_AUX6_ARB

GLScene.OpenGL4

WGL_AUX6_ARB

GLScene.OpenGLTokens

WGL_AUX7_ARB

GLScene.OpenGL4

WGL_AUX7_ARB

GLScene.OpenGLTokens

WGL_AUX8_ARB

GLScene.OpenGL4

WGL_AUX8_ARB

GLScene.OpenGLTokens

WGL_AUX9_ARB

GLScene.OpenGL4

WGL_AUX9_ARB

GLScene.OpenGLTokens

WGL_AUX_BUFFERS_ARB

GLScene.OpenGL4

WGL_AUX_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_AUX_BUFFERS_EXT

GLScene.OpenGL4

WGL_BACK_COLOR_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_BACK_COLOR_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_BACK_LEFT_ARB

GLScene.OpenGL4

WGL_BACK_LEFT_ARB

GLScene.OpenGLTokens

WGL_BACK_RIGHT_ARB

GLScene.OpenGL4

WGL_BACK_RIGHT_ARB

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_DEPTH_NV

GLScene.OpenGL4

WGL_NV_render_depth_texture

WGL_BIND_TO_TEXTURE_RECTANGLE_DEPTH_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_RGB_NV

GLScene.OpenGL4

WGL_NV_render_texture_rectangle

WGL_BIND_TO_TEXTURE_RGBA_ARB

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RGBA_ARB

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RGB_ARB

GLScene.OpenGL4

WGL_ARB_render_texture

WGL_BIND_TO_TEXTURE_RGB_ARB

GLScene.OpenGLTokens

ARB Extension #20 - WGL_ARB_render_texture

WGL_BIND_TO_VIDEO_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_VIDEO_RGB_AND_DEPTH_NV

GLScene.OpenGL4

WGL_BIND_TO_VIDEO_RGB_NV

GLScene.OpenGL4

WGL_NV_video_output

WGL_BLUE_BITS_ARB

GLScene.OpenGL4

WGL_BLUE_BITS_ARB

GLScene.OpenGLTokens

WGL_BLUE_BITS_EXT

GLScene.OpenGL4

WGL_BLUE_SHIFT_ARB

GLScene.OpenGL4

WGL_BLUE_SHIFT_ARB

GLScene.OpenGLTokens

WGL_BLUE_SHIFT_EXT

GLScene.OpenGL4

WGL_CLAMP_FRAGMENT_COLOR_ARB

GLScene.OpenGL4

WGL_CLAMP_READ_COLOR_ARB

GLScene.OpenGL4

WGL_CLAMP_VERTEX_COLOR_ARB

GLScene.OpenGL4

WGL_COLOR_BITS_ARB

GLScene.OpenGL4

WGL_COLOR_BITS_ARB

GLScene.OpenGLTokens

WGL_COLOR_BITS_EXT

GLScene.OpenGL4

WGL_COLOR_SAMPLES_NV

GLScene.OpenGL4

WGL_COLOR_SAMPLES_NV

GLScene.OpenGLTokens

unknown extension, where does it come from?

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGL4

WGL_ARB_create_context

WGL_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGL4

WGL_EXT_create_context_es2_profile

WGL_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGLTokens

EXT #400 WGL_EXT_create_context_es2_profile

WGL_CONTEXT_FLAGS_ARB

GLScene.OpenGL4

WGL_CONTEXT_FLAGS_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_LAYER_PLANE_ARB

GLScene.OpenGL4

WGL_CONTEXT_LAYER_PLANE_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGL4

WGL_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGLTokens

ARB Extension #55 - WGL_ARB_create_context see also WGL_ARB_create_context_profile (ARB #74)

WGL_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGL4

WGL_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGL4

WGL_ARB_create_context_profile

WGL_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGLTokens

ARB Extension #74 - WGL_ARB_create_context_profile see also WGL_ARB_create_context (ARB #55)

WGL_CONTEXT_RELEASE_BEHAVIOR_ARB

GLScene.OpenGL4

WGL_ARB_context_flush_control

WGL_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB

GLScene.OpenGL4

WGL_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB

GLScene.OpenGL4

WGL_CONTEXT_RESET_ISOLATION_BIT_ARB

GLScene.OpenGL4

WGL_ARB_robustness_application_isolation

WGL_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

WGL_CONTEXT_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

WGL_ARB_create_context_robustness

WGL_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

WGL_NV_multisample_coverage

WGL_CUBE_MAP_FACE_ARB

GLScene.OpenGL4

WGL_CUBE_MAP_FACE_ARB

GLScene.OpenGLTokens

WGL_DEPTH_BITS_ARB

GLScene.OpenGL4

WGL_DEPTH_BITS_ARB

GLScene.OpenGLTokens

WGL_DEPTH_BITS_EXT

GLScene.OpenGL4

WGL_DEPTH_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_DEPTH_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_DEPTH_COMPONENT_NV

GLScene.OpenGL4

WGL_DEPTH_FLOAT_EXT

GLScene.OpenGL4

WGL_EXT_depth_float

WGL_DEPTH_TEXTURE_FORMAT_NV

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_FRAMEBUFFER_I3D

GLScene.OpenGL4

WGL_I3D_digital_video_control

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_VALUE_I3D

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_CURSOR_INCLUDED_I3D

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_GAMMA_CORRECTED_I3D

GLScene.OpenGL4

WGL_DOUBLE_BUFFER_ARB

GLScene.OpenGL4

WGL_DOUBLE_BUFFER_ARB

GLScene.OpenGLTokens

WGL_DOUBLE_BUFFER_EXT

GLScene.OpenGL4

WGL_DRAW_TO_BITMAP_ARB

GLScene.OpenGL4

WGL_DRAW_TO_BITMAP_ARB

GLScene.OpenGLTokens

WGL_DRAW_TO_BITMAP_EXT

GLScene.OpenGL4

WGL_DRAW_TO_PBUFFER_ARB

GLScene.OpenGL4

WGL_ARB_pbuffer

WGL_DRAW_TO_PBUFFER_ARB

GLScene.OpenGLTokens

ARB Extension #11 - WGL_ARB_pbuffer

WGL_DRAW_TO_PBUFFER_EXT

GLScene.OpenGL4

WGL_EXT_pbuffer

WGL_DRAW_TO_WINDOW_ARB

GLScene.OpenGL4

WGL_DRAW_TO_WINDOW_ARB

GLScene.OpenGLTokens

WGL_DRAW_TO_WINDOW_EXT

GLScene.OpenGL4

WGL_ERROR_INCOMPATIBLE_AFFINITY_MASKS_NV

GLScene.OpenGL4

WGL_NV_gpu_affinity

WGL_ERROR_MISSING_AFFINITY_MASK_NV

GLScene.OpenGL4

WGL_FIXED_ONLY_ARB

GLScene.OpenGL4

WGL_FLOAT_COMPONENTS_NV

GLScene.OpenGL4

WGL_NV_float_buffer

WGL_FLOAT_COMPONENTS_NV

GLScene.OpenGLTokens

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGL4

WGL_ARB_framebuffer_sRGB

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGLTokens

ARB Extension #46 - GL_ARB_framebuffer_sRGB

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

WGL_FRONT_COLOR_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_ARB_buffer_region

WGL_FRONT_COLOR_BUFFER_BIT_ARB

GLScene.OpenGLTokens

—————— OpenGL v1.1 generic constants ——————– ARB Extension #4 - WGL_ARB_buffer_region

WGL_FRONT_LEFT_ARB

GLScene.OpenGL4

WGL_FRONT_LEFT_ARB

GLScene.OpenGLTokens

WGL_FRONT_RIGHT_ARB

GLScene.OpenGL4

WGL_FRONT_RIGHT_ARB

GLScene.OpenGLTokens

WGL_FULL_ACCELERATION_ARB

GLScene.OpenGL4

WGL_FULL_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_FULL_ACCELERATION_EXT

GLScene.OpenGL4

WGL_GAMMA_EXCLUDE_DESKTOP_I3D

GLScene.OpenGL4

WGL_GAMMA_TABLE_SIZE_I3D

GLScene.OpenGL4

WGL_I3D_gamma

WGL_GENERIC_ACCELERATION_ARB

GLScene.OpenGL4

WGL_GENERIC_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_GENERIC_ACCELERATION_EXT

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_DIGITAL_FIELD_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_DIGITAL_SYNC_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_BOTH_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_FALLING_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_RISING_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_FIELD_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_SYNC_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_TTL_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_MULTIVIEW_I3D

GLScene.OpenGL4

WGL_I3D_genlock

WGL_GPU_CLOCK_AMD

GLScene.OpenGL4

WGL_GPU_FASTEST_TARGET_GPUS_AMD

GLScene.OpenGL4

WGL_GPU_NUM_PIPES_AMD

GLScene.OpenGL4

WGL_GPU_NUM_RB_AMD

GLScene.OpenGL4

WGL_GPU_NUM_SIMD_AMD

GLScene.OpenGL4

WGL_GPU_NUM_SPI_AMD

GLScene.OpenGL4

WGL_GPU_OPENGL_VERSION_STRING_AMD

GLScene.OpenGL4

WGL_GPU_RAM_AMD

GLScene.OpenGL4

WGL_GPU_RENDERER_STRING_AMD

GLScene.OpenGL4

WGL_GPU_VENDOR_AMD

GLScene.OpenGL4

WGL_AMD_gpu_association

WGL_GREEN_BITS_ARB

GLScene.OpenGL4

WGL_GREEN_BITS_ARB

GLScene.OpenGLTokens

WGL_GREEN_BITS_EXT

GLScene.OpenGL4

WGL_GREEN_SHIFT_ARB

GLScene.OpenGL4

WGL_GREEN_SHIFT_ARB

GLScene.OpenGLTokens

WGL_GREEN_SHIFT_EXT

GLScene.OpenGL4

WGL_IMAGE_BUFFER_LOCK_I3D

GLScene.OpenGL4

WGL_IMAGE_BUFFER_MIN_ACCESS_I3D

GLScene.OpenGL4

WGL_I3D_image_buffer

WGL_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_HEIGHT_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_HEIGHT_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_MAX_PBUFFER_PIXELS_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_PIXELS_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_PIXELS_EXT

GLScene.OpenGL4

WGL_MAX_PBUFFER_WIDTH_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_WIDTH_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_MIPMAP_LEVEL_ARB

GLScene.OpenGL4

WGL_MIPMAP_LEVEL_ARB

GLScene.OpenGLTokens

WGL_MIPMAP_TEXTURE_ARB

GLScene.OpenGL4

WGL_MIPMAP_TEXTURE_ARB

GLScene.OpenGLTokens

WGL_NEED_PALETTE_ARB

GLScene.OpenGL4

WGL_NEED_PALETTE_ARB

GLScene.OpenGLTokens

WGL_NEED_PALETTE_EXT

GLScene.OpenGL4

WGL_NEED_SYSTEM_PALETTE_ARB

GLScene.OpenGL4

WGL_NEED_SYSTEM_PALETTE_ARB

GLScene.OpenGLTokens

WGL_NEED_SYSTEM_PALETTE_EXT

GLScene.OpenGL4

WGL_NO_ACCELERATION_ARB

GLScene.OpenGL4

WGL_NO_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_NO_ACCELERATION_EXT

GLScene.OpenGL4

WGL_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

WGL_NO_TEXTURE_ARB

GLScene.OpenGL4

WGL_NO_TEXTURE_ARB

GLScene.OpenGLTokens

WGL_NUMBER_OVERLAYS_ARB

GLScene.OpenGL4

WGL_NUMBER_OVERLAYS_ARB

GLScene.OpenGLTokens

WGL_NUMBER_OVERLAYS_EXT

GLScene.OpenGL4

WGL_NUMBER_PIXEL_FORMATS_ARB

GLScene.OpenGL4

WGL_ARB_pixel_format

WGL_NUMBER_PIXEL_FORMATS_ARB

GLScene.OpenGLTokens

ARB Extension #9 - WGL_ARB_pixel_format (no new tokens)

WGL_NUMBER_PIXEL_FORMATS_EXT

GLScene.OpenGL4

WGL_EXT_pixel_format

WGL_NUMBER_UNDERLAYS_ARB

GLScene.OpenGL4

WGL_NUMBER_UNDERLAYS_ARB

GLScene.OpenGLTokens

WGL_NUMBER_UNDERLAYS_EXT

GLScene.OpenGL4

WGL_NUM_VIDEO_CAPTURE_SLOTS_NV

GLScene.OpenGL4

WGL_NUM_VIDEO_SLOTS_NV

GLScene.OpenGL4

WGL_NV_present_video

WGL_OPTIMAL_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_OPTIMAL_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_PBUFFER_HEIGHT_ARB

GLScene.OpenGL4

WGL_PBUFFER_HEIGHT_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_PBUFFER_LARGEST_ARB

GLScene.OpenGL4

WGL_PBUFFER_LARGEST_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_LARGEST_EXT

GLScene.OpenGL4

WGL_PBUFFER_LOST_ARB

GLScene.OpenGL4

WGL_PBUFFER_LOST_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_WIDTH_ARB

GLScene.OpenGL4

WGL_PBUFFER_WIDTH_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_PIXEL_TYPE_ARB

GLScene.OpenGL4

WGL_PIXEL_TYPE_ARB

GLScene.OpenGLTokens

WGL_PIXEL_TYPE_EXT

GLScene.OpenGL4

WGL_RED_BITS_ARB

GLScene.OpenGL4

WGL_RED_BITS_ARB

GLScene.OpenGLTokens

WGL_RED_BITS_EXT

GLScene.OpenGL4

WGL_RED_SHIFT_ARB

GLScene.OpenGL4

WGL_RED_SHIFT_ARB

GLScene.OpenGLTokens

WGL_RED_SHIFT_EXT

GLScene.OpenGL4

WGL_RGBA_FLOAT_MODE_ARB

GLScene.OpenGL4

WGL_ARB_pixel_format_float

WGL_SAMPLES_3DFX

GLScene.OpenGL4

WGL_SAMPLES_ARB

GLScene.OpenGL4

WGL_SAMPLES_ARB

GLScene.OpenGLTokens

WGL_SAMPLES_EXT

GLScene.OpenGL4

WGL_SAMPLE_BUFFERS_3DFX

GLScene.OpenGL4

WGL_3DFX_multisample

WGL_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

WGL_ARB_multisample

WGL_SAMPLE_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_SAMPLE_BUFFERS_EXT

GLScene.OpenGL4

WGL_EXT_multisample

WGL_SHARE_ACCUM_ARB

GLScene.OpenGL4

WGL_SHARE_ACCUM_ARB

GLScene.OpenGLTokens

WGL_SHARE_ACCUM_EXT

GLScene.OpenGL4

WGL_SHARE_DEPTH_ARB

GLScene.OpenGL4

WGL_SHARE_DEPTH_ARB

GLScene.OpenGLTokens

WGL_SHARE_DEPTH_EXT

GLScene.OpenGL4

WGL_SHARE_STENCIL_ARB

GLScene.OpenGL4

WGL_SHARE_STENCIL_ARB

GLScene.OpenGLTokens

WGL_SHARE_STENCIL_EXT

GLScene.OpenGL4

WGL_STENCIL_BITS_ARB

GLScene.OpenGL4

WGL_STENCIL_BITS_ARB

GLScene.OpenGLTokens

WGL_STENCIL_BITS_EXT

GLScene.OpenGL4

WGL_STENCIL_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_STENCIL_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_STEREO_ARB

GLScene.OpenGL4

WGL_STEREO_ARB

GLScene.OpenGLTokens

WGL_STEREO_EXT

GLScene.OpenGL4

WGL_SUPPORT_GDI_ARB

GLScene.OpenGL4

WGL_SUPPORT_GDI_ARB

GLScene.OpenGLTokens

WGL_SUPPORT_GDI_EXT

GLScene.OpenGL4

WGL_SUPPORT_OPENGL_ARB

GLScene.OpenGL4

WGL_SUPPORT_OPENGL_ARB

GLScene.OpenGLTokens

WGL_SUPPORT_OPENGL_EXT

GLScene.OpenGL4

WGL_SWAP_COPY_ARB

GLScene.OpenGL4

WGL_SWAP_COPY_ARB

GLScene.OpenGLTokens

WGL_SWAP_COPY_EXT

GLScene.OpenGL4

WGL_SWAP_EXCHANGE_ARB

GLScene.OpenGL4

WGL_SWAP_EXCHANGE_ARB

GLScene.OpenGLTokens

WGL_SWAP_EXCHANGE_EXT

GLScene.OpenGL4

WGL_SWAP_LAYER_BUFFERS_ARB

GLScene.OpenGL4

WGL_SWAP_LAYER_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_SWAP_LAYER_BUFFERS_EXT

GLScene.OpenGL4

WGL_SWAP_METHOD_ARB

GLScene.OpenGL4

WGL_SWAP_METHOD_ARB

GLScene.OpenGLTokens

WGL_SWAP_METHOD_EXT

GLScene.OpenGL4

WGL_SWAP_UNDEFINED_ARB

GLScene.OpenGL4

WGL_SWAP_UNDEFINED_ARB

GLScene.OpenGLTokens

WGL_SWAP_UNDEFINED_EXT

GLScene.OpenGL4

WGL_TEXTURE_1D_ARB

GLScene.OpenGL4

WGL_TEXTURE_1D_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_2D_ARB

GLScene.OpenGL4

WGL_TEXTURE_2D_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_DEPTH_COMPONENT_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGBA_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGBA_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_RGB_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGB_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_RG_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RG_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_R_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_R_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FORMAT_ARB

GLScene.OpenGL4

WGL_TEXTURE_FORMAT_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

WGL_TEXTURE_RGBA_ARB

GLScene.OpenGL4

WGL_TEXTURE_RGBA_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_RGB_ARB

GLScene.OpenGL4

WGL_TEXTURE_RGB_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_TARGET_ARB

GLScene.OpenGL4

WGL_TEXTURE_TARGET_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_ALPHA_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_ALPHA_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_BLUE_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_BLUE_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_EXT

GLScene.OpenGL4

WGL_TRANSPARENT_GREEN_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_GREEN_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_INDEX_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_INDEX_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_RED_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_RED_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_VALUE_EXT

GLScene.OpenGL4

WGL_TYPE_COLORINDEX_ARB

GLScene.OpenGL4

WGL_TYPE_COLORINDEX_ARB

GLScene.OpenGLTokens

WGL_TYPE_COLORINDEX_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_ARB

GLScene.OpenGL4

WGL_TYPE_RGBA_ARB

GLScene.OpenGLTokens

WGL_TYPE_RGBA_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_FLOAT_ARB

GLScene.OpenGL4

WGL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGL4

WGL_ATI_pixel_format_float

WGL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGLTokens

WGL_ATI_pixel_format_float (#278)

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT

GLScene.OpenGLTokens

WGL_UNIQUE_ID_NV

GLScene.OpenGL4

WGL_NV_video_capture

WGL_VIDEO_OUT_ALPHA_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_AND_ALPHA_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_AND_DEPTH_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_DEPTH_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_FIELD_1

GLScene.OpenGL4

WGL_VIDEO_OUT_FIELD_2

GLScene.OpenGL4

WGL_VIDEO_OUT_FRAME

GLScene.OpenGL4

WGL_VIDEO_OUT_STACKED_FIELDS_1_2

GLScene.OpenGL4

WGL_VIDEO_OUT_STACKED_FIELDS_2_1

GLScene.OpenGL4

WHmgPoint

GLScene.VectorGeometry

WHmgVector

GLScene.VectorGeometry

WM_CAP_ABORT

Formats.VFW

WM_CAP_DLG_VIDEOCOMPRESSION

Formats.VFW

WM_CAP_DLG_VIDEODISPLAY

Formats.VFW

WM_CAP_DLG_VIDEOFORMAT

Formats.VFW

WM_CAP_DLG_VIDEOSOURCE

Formats.VFW

WM_CAP_DRIVER_CONNECT

Formats.VFW

WM_CAP_DRIVER_DISCONNECT

Formats.VFW

WM_CAP_DRIVER_GET_CAPS

Formats.VFW

WM_CAP_DRIVER_GET_NAME

Formats.VFW

WM_CAP_DRIVER_GET_NAMEA

Formats.VFW

WM_CAP_DRIVER_GET_NAMEW

Formats.VFW

WM_CAP_DRIVER_GET_VERSION

Formats.VFW

WM_CAP_DRIVER_GET_VERSIONA

Formats.VFW

WM_CAP_DRIVER_GET_VERSIONW

Formats.VFW

WM_CAP_EDIT_COPY

Formats.VFW

WM_CAP_END

Formats.VFW

WM_CAP_FILE_ALLOCATE

Formats.VFW

out of order to save on ifdefs

WM_CAP_FILE_GET_CAPTURE_FILE

Formats.VFW

WM_CAP_FILE_GET_CAPTURE_FILEA

Formats.VFW

WM_CAP_FILE_GET_CAPTURE_FILEW

Formats.VFW

WM_CAP_FILE_SAVEAS

Formats.VFW

WM_CAP_FILE_SAVEASA

Formats.VFW

WM_CAP_FILE_SAVEASW

Formats.VFW

WM_CAP_FILE_SAVEDIB

Formats.VFW

WM_CAP_FILE_SAVEDIBA

Formats.VFW

WM_CAP_FILE_SAVEDIBW

Formats.VFW

WM_CAP_FILE_SET_CAPTURE_FILE

Formats.VFW

WM_CAP_FILE_SET_CAPTURE_FILEA

Formats.VFW

WM_CAP_FILE_SET_CAPTURE_FILEW

Formats.VFW

WM_CAP_FILE_SET_INFOCHUNK

Formats.VFW

WM_CAP_GET_AUDIOFORMAT

Formats.VFW

WM_CAP_GET_CAPSTREAMPTR

Formats.VFW

WM_CAP_GET_MCI_DEVICE

Formats.VFW

WM_CAP_GET_MCI_DEVICEA

Formats.VFW

WM_CAP_GET_MCI_DEVICEW

Formats.VFW

WM_CAP_GET_SEQUENCE_SETUP

Formats.VFW

WM_CAP_GET_STATUS

Formats.VFW

WM_CAP_GET_USER_DATA

Formats.VFW

WM_CAP_GET_VIDEOFORMAT

Formats.VFW

WM_CAP_GRAB_FRAME

Formats.VFW

WM_CAP_GRAB_FRAME_NOSTOP

Formats.VFW

WM_CAP_PAL_AUTOCREATE

Formats.VFW

WM_CAP_PAL_MANUALCREATE

Formats.VFW

WM_CAP_PAL_OPEN

Formats.VFW

WM_CAP_PAL_OPENA

Formats.VFW

WM_CAP_PAL_OPENW

Formats.VFW

WM_CAP_PAL_PASTE

Formats.VFW

WM_CAP_PAL_SAVE

Formats.VFW

WM_CAP_PAL_SAVEA

Formats.VFW

WM_CAP_PAL_SAVEW

Formats.VFW

WM_CAP_SEQUENCE

Formats.VFW

WM_CAP_SEQUENCE_NOFILE

Formats.VFW

WM_CAP_SET_AUDIOFORMAT

Formats.VFW

WM_CAP_SET_CALLBACK_CAPCONTROL

Formats.VFW

Following added post VFW 1.1

WM_CAP_SET_CALLBACK_ERROR

Formats.VFW

WM_CAP_SET_CALLBACK_ERRORA

Formats.VFW

WM_CAP_SET_CALLBACK_ERRORW

Formats.VFW

WM_CAP_SET_CALLBACK_FRAME

Formats.VFW

WM_CAP_SET_CALLBACK_STATUS

Formats.VFW

WM_CAP_SET_CALLBACK_STATUSA

Formats.VFW

WM_CAP_SET_CALLBACK_STATUSW

Formats.VFW

WM_CAP_SET_CALLBACK_VIDEOSTREAM

Formats.VFW

WM_CAP_SET_CALLBACK_WAVESTREAM

Formats.VFW

WM_CAP_SET_CALLBACK_YIELD

Formats.VFW

WM_CAP_SET_MCI_DEVICE

Formats.VFW

WM_CAP_SET_MCI_DEVICEA

Formats.VFW

WM_CAP_SET_MCI_DEVICEW

Formats.VFW

WM_CAP_SET_OVERLAY

Formats.VFW

WM_CAP_SET_PREVIEW

Formats.VFW

WM_CAP_SET_PREVIEWRATE

Formats.VFW

WM_CAP_SET_SCALE

Formats.VFW

WM_CAP_SET_SCROLL

Formats.VFW

WM_CAP_SET_SEQUENCE_SETUP

Formats.VFW

WM_CAP_SET_USER_DATA

Formats.VFW

WM_CAP_SET_VIDEOFORMAT

Formats.VFW

WM_CAP_SINGLE_FRAME

Formats.VFW

WM_CAP_SINGLE_FRAME_CLOSE

Formats.VFW

WM_CAP_SINGLE_FRAME_OPEN

Formats.VFW

WM_CAP_START

Formats.VFW

UNICODE
The Win32 version of AVICAP on NT supports UNICODE applications: for each API or message that takes a char or string parameter, there are two versions, ApiNameA and ApiNameW. The default name ApiName is #defined to one or other depending on whether UNICODE is defined. Apps can call the A and W apis directly, and mix them.
The 32-bit AVICAP on NT uses unicode exclusively internally. ApiNameA() will be implemented as a call to ApiNameW() together with translation of strings. Defines start of the message range

WM_CAP_STOP

Formats.VFW

WM_CAP_UNICODE_END

Formats.VFW

Defines end of the message range

WM_CAP_UNICODE_START

Formats.VFW

XDATA_APPNAME

Formats.m3DSConst

XDATA_DOUBLE

Formats.m3DSConst

XDATA_ENTRY

Formats.m3DSConst

XDATA_FLOAT

Formats.m3DSConst

XDATA_GROUP

Formats.m3DSConst

XDATA_LONG

Formats.m3DSConst

XDATA_RFU1

Formats.m3DSConst

XDATA_RFU2

Formats.m3DSConst

XDATA_RFU3

Formats.m3DSConst

XDATA_RFU4

Formats.m3DSConst

XDATA_RFU5

Formats.m3DSConst

XDATA_RFU6

Formats.m3DSConst

XDATA_SECTION

Formats.m3DSConst

External Application Data

XDATA_SHORT

Formats.m3DSConst

XDATA_STRING

Formats.m3DSConst

XDATA_VOID

Formats.m3DSConst

XHmgPoint

GLScene.VectorGeometry

Standard homogeneous points

XHmgVector

GLScene.VectorGeometry

Standard homogeneous vectors

XLATE_RANGE

Formats.m3DSConst

XTexPoint

GLScene.VectorGeometry

TexPoints (2D space)

XVector

GLScene.VectorGeometry

standard vectors

XYHmgVector

GLScene.VectorGeometry

XYTexPoint

GLScene.VectorGeometry

XYVector

GLScene.VectorGeometry

XYZHmgVector

GLScene.VectorGeometry

XYZVector

GLScene.VectorGeometry

XYZWHmgVector

GLScene.VectorGeometry

XZHmgVector

GLScene.VectorGeometry

XZVector

GLScene.VectorGeometry

XZ_CURVE

Formats.m3DSConst

YHmgPoint

GLScene.VectorGeometry

YHmgVector

GLScene.VectorGeometry

YTexPoint

GLScene.VectorGeometry

YVector

GLScene.VectorGeometry

YZHmgVector

GLScene.VectorGeometry

YZVector

GLScene.VectorGeometry

YZ_CURVE

Formats.m3DSConst

ZHmgPoint

GLScene.VectorGeometry

ZHmgVector

GLScene.VectorGeometry

ZVector

GLScene.VectorGeometry

_priv_dParamLoStop

ODE.Import

These consts now have defined types

_priv_dParamLoStop2

ODE.Import

_priv_dParamLoStop3

ODE.Import


GLSysHelp v.2.5: All Functions and Procedures

All Functions and Procedures

Name Unit Description
AABBContainsAABB GLScene.GeometryBB

Determines to which extent one AABB contains another AABB
AABBContainsBSphere GLScene.GeometryBB

Determines to which extent an AABB contains a BSpher
AABBFitsInAABBAbsolute GLScene.GeometryBB

Checks whether one Bounding box aligned with the world axes fits within another Bounding box
AABBFromSweep GLScene.GeometryBB

Make an AABB that is formed by sweeping a sphere (or AABB) from Start to Dest
AABBInclude GLScene.GeometryBB

Resize the AABB if necessary to include p.
AABBIntersection GLScene.GeometryBB

Returns the intersection AABB of two AABBs. If the AABBs don't intersect, will return a degenerated AABB (plane, line or point).
AABBScale GLScene.GeometryBB

AABBToBB GLScene.GeometryBB

Converts an AABB to its canonical BB.
AABBToBB GLScene.GeometryBB

Transforms an AABB to a BB.
AABBToBSphere GLScene.GeometryBB

Convert an AABB to a BSphere
AABBToClipRect GLScene.GeometryBB

Projects an AABB and determines the extent of its projection as a clip rect.
AABBTransform GLScene.GeometryBB

AbsVector GLScene.VectorGeometry

Vector components are replaced by their Abs() value. }
AbsVector GLScene.VectorGeometry

Vector components are replaced by their Abs() value. }
ActiveSoundManager GLS.SoundManager

ActorAddForce PhysX.Import

ActorCount PhysX.Import

AddAABB GLScene.GeometryBB

AddBB GLScene.GeometryBB

Adds a BB into another BB. The original BB (c1) is extended if necessary to contain c2.
AddChild Formats.m3DSUtils

functions to retrieve/modify data related to materials, lights and objects (meshs)
AddChildOrdered Formats.m3DSUtils

AddDomainForComponent gnugettext

Add more domains that component strings can be extracted from. If a translation is not found in the default domain, this domain will be searched, too. This is useful when an application inherits components from a 3rd party component libraries
AddDomainForResourceString gnugettext

Add more domains that resourcestrings can be extracted from. If a translation is not found in the default domain, this domain will be searched, too. This is useful for adding mo files for certain runtime libraries and 3rd party component libraries
AddDomains gnugettext

AddPoint GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1. W coordinate is always 1.
AddSCODEGeomsToODESpace GLS.ODESkeletonColliders

After loading call this function to add all the geoms in a skeleton collider list to a given ODE space
AddVector GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1
AddVector GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1
AddVector GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1
AddVector GLScene.VectorGeometry

Sums up f to each component of the vector
AddVector GLScene.VectorGeometry

Sums up f to each component of the vector
AddVerletConstriantsToVerletWorld GLS.VerletTypes

After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.
AdjointMatrix GLScene.VectorGeometry

Adjoint of a 3x3 matrix, used in the computation of the inverse of a 3x3 matrix
AdjointMatrix GLScene.VectorGeometry

Adjoint of a 4x4 matrix, used in the computation of the inverse of a 4x4 matrix
AffineVectorEquals GLScene.VectorGeometry

True if X, Y and Z components are equal.
AffineVectorMake GLScene.VectorGeometry

AffineVectorMake GLScene.VectorGeometry

AlgorithmMStringToDouble PasDblStrUtils

AlgorithmMStringToDouble PasDblStrUtils

AlphaGammaBrightCorrection GLS.ImageUtils

alutExit OpenAL.Import

alutInit OpenAL.Import

Internal Alut functions
alutLoadWAVFile OpenAL.Import

alutLoadWAVMemory OpenAL.Import

alutUnloadWAV OpenAL.Import

AngleBetweenVectors GLScene.VectorGeometry

AngleBetweenVectors GLScene.VectorGeometry

Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians
AngleLerp GLScene.VectorGeometry

Calculates angular interpolation between start and stop at point t
AnglePreservingMatrixInvert GLScene.VectorGeometry

Finds the inverse of an angle preserving matrix. Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.
AnsiStartsText GLScene.Utils

StrUtils.pas
ApplicationFileIODefined GLS.ApplicationFileIO

Returns true if an ApplicationFileIO has been defined
ApplyBlendingModeEx GLSL.CustomShader

Exported procedures.
AppTime GLScene.Utils

Returns time in milisecond from application start.
ArcCosine GLScene.VectorGeometry

ArcCreateFileStream GLS.ArchiveManager

GLS.ApplicationFileIO These functions are used to automate loading User enters LoadFromFile and through these functions gets the result
ArcFileStreamExists GLS.ArchiveManager

ASESetPreferredLightmap GLS.FileASE

ASESetPreferredTexture GLS.FileASE

use this functions to select texture and lightmap from ASE file aSubMaterialIndex = -1 - means main material maps Default are: Texture - main material Diffuse map Lightmap - main material Ambient map
AVIBuildFilter Formats.VFW

AVIBuildFilterA Formats.VFW

AVIBuildFilterW Formats.VFW

Same as the flags for ICCompressorChoose (see compman.h) These determine what the compression options dialog for video streams will look like.
AVICapSM Formats.VFW

== AVICAP - Window class for AVI capture ====================================
AVIClearClipboard Formats.VFW

AVIFileAddRef Formats.VFW

AVIFileClose Formats.VFW

AVIStreamRelease
AVIFileCreateStream Formats.VFW

AVIFileCreateStreamA Formats.VFW

AVIFileCreateStreamW Formats.VFW

AVIFileEndRecord Formats.VFW

AVIFileExit Formats.VFW

Call this first!
AVIFileGetStream Formats.VFW

AVIFileInfo Formats.VFW

AVIFileInfoA Formats.VFW

AVIFileInfoW Formats.VFW

AVIFileInit Formats.VFW

– Functions —————————————————————-
AVIFileOpen Formats.VFW

AVIFileOpenA Formats.VFW

AVIFileOpenW Formats.VFW

AVIFileReadData Formats.VFW

AVIFileRelease Formats.VFW

AVIFileWriteData Formats.VFW

AVIGetFromClipboard Formats.VFW

AVIMakeCompressedStream Formats.VFW

mmioFOURCC('D', 'I', 'B', ' ')
AVIMakeFileFromStreams Formats.VFW

AVIBuildFilterA
AVIMakeStreamFromClipboard Formats.VFW

AVIPutFileOnClipboard Formats.VFW

– Clipboard routines ——————————————————-
AVISaveOptions Formats.VFW

AVISaveVA
AVISaveOptionsFree Formats.VFW

AVISaveV Formats.VFW

#define AVISave AVISaveA
AVISaveVA Formats.VFW

Non-portable: uses variable number of params EXTERN_C HRESULT CDECL AVISaveA (LPCSTR szFile, CLSID FAR *pclsidHandler, AVISAVECALLBACK lpfnCallback, int nStreams, PAVISTREAM pfile, LPAVICOMPRESSOPTIONS lpOptions, ...);
AVISaveVW Formats.VFW

Non-portable: uses variable number of params EXTERN_C HRESULT CDECL AVISaveW (LPCWSTR szFile, CLSID FAR *pclsidHandler, AVISAVECALLBACK lpfnCallback, int nStreams, PAVISTREAM pfile, LPAVICOMPRESSOPTIONS lpOptions, ...);
AVIStreamAddRef Formats.VFW

AVIStreamBeginStreaming Formats.VFW

AVIStreamClose Formats.VFW

AVIStreamFindSample Non-portable: this is alias for method name FindKeyFrame FindSample
AVIStreamCreate Formats.VFW

– Use to create disembodied streams —————————————-
AVIStreamDataSize Formats.VFW

AVIStreamEnd Formats.VFW

AVIStreamEndStreaming Formats.VFW

AVIStreamEndTime Formats.VFW

AVIStreamExit Formats.VFW

AVIFileInit
AVIStreamFindKeyFrame Formats.VFW

– Stuff to support backward compat. —————————————-
AVIStreamFindSample Formats.VFW

AVIStreamFormatSize Formats.VFW

AVIStreamGetFrame Formats.VFW

AVIStreamGetFrameClose Formats.VFW

AVIStreamGetFrameOpen Formats.VFW

– Helper functions for using IGetFrame ————————————-
AVIStreamInfo Formats.VFW

AVIStreamInfoA Formats.VFW

AVIStreamInfoW Formats.VFW

AVIStreamInit Formats.VFW

AVIFileRelease
AVIStreamIsKeyFrame Formats.VFW

AVIStreamLength Formats.VFW

AVIStreamLengthTime Formats.VFW

AVIStreamNearestKeyFrame Formats.VFW

AVIStreamNearestKeyFrameTime Formats.VFW

AVIStreamNearestSample Formats.VFW

AVIStreamNearestSampleTime Formats.VFW

AVIStreamNextKeyFrame Formats.VFW

AVIStreamNextKeyFrameTime Formats.VFW

AVIStreamNextSample Formats.VFW

AVIStreamNextSampleTime Formats.VFW

AVIStreamOpenFromFile Formats.VFW

AVIStreamOpenFromFileA Formats.VFW

– Shortcut function ——————————————————–
AVIStreamOpenFromFileW Formats.VFW

AVIStreamPrevKeyFrame Formats.VFW

AVIStreamPrevKeyFrameTime Formats.VFW

AVIStreamPrevSample Formats.VFW

AVIStreamPrevSampleTime Formats.VFW

AVIStreamRead Formats.VFW

AVIStreamReadData Formats.VFW

AVIStreamReadFormat Formats.VFW

AVIStreamRelease Formats.VFW

AVIStreamSampleSize Formats.VFW

AVIStreamSampleToSample Formats.VFW

– Helper macros ————————————————————
AVIStreamSampleToTime Formats.VFW

AVIStreamSetFormat Formats.VFW

AVIStreamStart Formats.VFW

Right now, these just use AVIStreamInfo() to get information, then return some of it. Can they be more efficient?
AVIStreamStartTime Formats.VFW

AVIStreamTimeToSample Formats.VFW

AVIStreamWrite Formats.VFW

AVIStreamWriteData Formats.VFW

aviTWOCC Formats.VFW

AxesBuildList GLS.Scene

Issues OpenGL calls for drawing X, Y, Z axes in a standard style.
BASS_IsLoaded BASS.Import

BASS_Load BASS.Import

BASS_SetEAXPreset BASS.Import

BASS_SPEAKER_N BASS.Import

external bassdll;
BASS_UnLoad BASS.Import

BBMaxX GLScene.GeometryBB

BBMaxY GLScene.GeometryBB

BBMaxZ GLScene.GeometryBB

BBMinX GLScene.GeometryBB

BBMinY GLScene.GeometryBB

BBMinZ GLScene.GeometryBB

BBToAABB GLScene.GeometryBB

Extract AABB information from a BB.
BBTransform GLScene.GeometryBB

BeginFPUOnlySection GLScene.VectorGeometry

Begins a FPU-only section. You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases. Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).
BGR24ToRGB24 GLS.Graphics

BGR24ToRGBA32 GLS.Graphics

BGRA32ToRGBA32 GLS.Graphics

bindtextdomain gnugettext

Border GLS.Memo

BoundingBoxesAreEqual GLScene.GeometryBB

BoundingBoxesAreEqual GLScene.GeometryBB

—————————————————————————— Bounding Box functions ——————————————————————————
BrightenRGBArray GLS.Graphics

BSphereContainsAABB GLScene.GeometryBB

Determines to which extent a BSphere contains an AABB
BSphereContainsBSphere GLScene.GeometryBB

Determines to which extent one BSphere contains another BSphere
BSphereIntersectsBSphere GLScene.GeometryBB

Determines if one BSphere intersects another BSphere
BSphereToAABB GLScene.GeometryBB

BSphereToAABB GLScene.GeometryBB

BSphereToAABB GLScene.GeometryBB

Convert a BSphere to an AABB
Build2DMipmap GLS.ImageUtils

BuildMeshCube GLS.MeshBuilder

—————- Build Meshes ——————-
BuildMeshCylinder GLS.MeshBuilder

BuildMeshCylinderAdv GLS.MeshBuilder

BuildMeshHemiCylinder GLS.MeshBuilder

BuildMeshHemiSphere GLS.MeshBuilder

Not implemented
BuildNonOrientedEdgesList GLS.MeshUtils

Builds a list of non-oriented (non duplicated) edges list. Each edge is represented by the two integers of its vertices, sorted in ascending order. If not nil then - triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation; - edgesTriangles is filled with the indices of the first index of the triangle in triangleIndices that have this edge. A maximum of two triangles can be referred by this list, and its final size will be that of the Result (ie. non oriented edges list)
BuildNormals GLS.MeshUtils

Builds normals for a triangles list. Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles. Returned list must be freed by caller.
BuildVectorCountOptimizedIndices GLS.MeshUtils

Builds a vector-count optimized indices list. The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used). The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.
CalcObjectSpaceLightVectors GLS.BumpmapHDS

Some useful methods for setting up bump maps.
CalcPlaneNormal GLScene.VectorGeometry

CalcPlaneNormal GLScene.VectorGeometry

CalcPlaneNormal GLScene.VectorGeometry

Calculate the normal of a plane defined by three points.
CalcTangentSpaceLightVectors GLS.BumpmapHDS

capCaptureAbort Formats.VFW

capCaptureGetSetup Formats.VFW

capCaptureSequence Formats.VFW

capCaptureSequenceNoFile Formats.VFW

capCaptureSetSetup Formats.VFW

capCaptureSingleFrame Formats.VFW

capCaptureSingleFrameClose Formats.VFW

capCaptureSingleFrameOpen Formats.VFW

capCaptureStop Formats.VFW

capCreateCaptureWindow Formats.VFW

capCreateCaptureWindowA Formats.VFW

– The only exported functions from AVICAP.DLL ——————————
capCreateCaptureWindowW Formats.VFW

capDlgVideoCompression Formats.VFW

capDlgVideoDisplay Formats.VFW

capDlgVideoFormat Formats.VFW

capDlgVideoSource Formats.VFW

capDriverConnect Formats.VFW

capDriverDisconnect Formats.VFW

capDriverGetCaps Formats.VFW

capDriverGetName Formats.VFW

capDriverGetVersion Formats.VFW

capEditCopy Formats.VFW

capFileAlloc Formats.VFW

capFileGetCaptureFile Formats.VFW

capFileSaveAs Formats.VFW

capFileSaveDIB Formats.VFW

capFileSetCaptureFile Formats.VFW

capFileSetInfoChunk Formats.VFW

capGetAudioFormat Formats.VFW

capGetAudioFormatSize Formats.VFW

capGetDriverDescription Formats.VFW

capCreateCaptureWindowA
capGetDriverDescriptionA Formats.VFW

capGetDriverDescriptionW Formats.VFW

capGetMCIDeviceName Formats.VFW

capGetStatus Formats.VFW

capGetUserData Formats.VFW

capGetVideoFormat Formats.VFW

capGetVideoFormatSize Formats.VFW

capGrabFrame Formats.VFW

capGrabFrameNoStop Formats.VFW

capOverlay Formats.VFW

capPaletteAuto Formats.VFW

capPaletteManual Formats.VFW

capPaletteOpen Formats.VFW

capPalettePaste Formats.VFW

capPaletteSave Formats.VFW

capPreview Formats.VFW

capPreviewRate Formats.VFW

capPreviewScale Formats.VFW

capSetAudioFormat Formats.VFW

capSetCallbackOnCapControl Formats.VFW

capSetCallbackOnError Formats.VFW

message wrapper macros are defined for the default messages only. Apps that wish to mix Ansi and UNICODE message sending will have to reference the _A and _W messages directly
capSetCallbackOnFrame Formats.VFW

capSetCallbackOnStatus Formats.VFW

capSetCallbackOnVideoStream Formats.VFW

capSetCallbackOnWaveStream Formats.VFW

capSetCallbackOnYield Formats.VFW

capSetMCIDeviceName Formats.VFW

capSetScrollPos Formats.VFW

capSetUserData Formats.VFW

capSetVideoFormat Formats.VFW

cbrt GLScene.Polynomials

Calculates the cube root of its parameter.
cgCompileProgram Cg.Import

cgConnectParameter Cg.Import

cgCopyProgram Cg.Import

cgCreateContext Cg.Import

** Context functions **
cgCreateParameter Cg.Import

** Parameter functions **
cgCreateParameterArray Cg.Import

cgCreateParameterMultiDimArray Cg.Import

cgCreateProgram Cg.Import

** Program functions **
cgCreateProgramFromFile Cg.Import

cgDestroyContext Cg.Import

cgDestroyParameter Cg.Import

cgDestroyProgram Cg.Import

cgDisconnectParameter Cg.Import

cgGetArrayDimension Cg.Import

cgGetArrayParameter Cg.Import

cgGetArraySize Cg.Import

cgGetArrayType Cg.Import

cgGetConnectedParameter Cg.Import

cgGetConnectedToParameter Cg.Import

cgGetEnum Cg.Import

cgGetEnumString Cg.Import

*** Enum Functions ***
cgGetError Cg.Import

** Error Functions **
cgGetErrorCallback Cg.Import

cgGetErrorString Cg.Import

cgGetFirstDependentParameter Cg.Import

cgGetFirstLeafParameter Cg.Import

cgGetFirstParameter Cg.Import

cgGetFirstProgram Cg.Import

cgGetFirstStructParameter Cg.Import

cgGetLastErrorString Cg.Import

cgGetLastListing Cg.Import

cgGetNamedParameter Cg.Import

cgGetNamedProgramParameter Cg.Import

cgGetNamedStructParameter Cg.Import

cgGetNamedUserType Cg.Import

cgGetNextLeafParameter Cg.Import

cgGetNextLeafParameter_depr1_1 Cg.Import

cgGetNextParameter Cg.Import

cgGetNextParameter_depr1_1 Cg.Import

*** Support for deprecated Cg 1.1 API ***
cgGetNextProgram Cg.Import

cgGetNumConnectedToParameters Cg.Import

cgGetNumParentTypes Cg.Import

cgGetNumUserTypes Cg.Import

cgGetParameterBaseResource Cg.Import

cgGetParameterContext Cg.Import

cgGetParameterDirection Cg.Import

cgGetParameterIndex Cg.Import

cgGetParameterName Cg.Import

cgGetParameterNamedType Cg.Import

cgGetParameterOrdinalNumber Cg.Import

cgGetParameterProgram Cg.Import

cgGetParameterResource Cg.Import

cgGetParameterResourceIndex Cg.Import

cgGetParameterSemantic Cg.Import

cgGetParameterType Cg.Import

cgGetParameterValues Cg.Import

cgGetParameterVariability Cg.Import

cgGetParentType Cg.Import

cgGetProfile Cg.Import

cgGetProfileString Cg.Import

** Profile Functions **
cgGetProgramContext Cg.Import

cgGetProgramProfile Cg.Import

cgGetProgramString Cg.Import

cgGetResource Cg.Import

cgGetResourceString Cg.Import

** Resource Functions **
cgGetString Cg.Import

*** Misc Functions ***
cgGetType Cg.Import

cgGetTypeString Cg.Import

** Type Functions **
cgGetUserType Cg.Import

cgGLBindProgram Cg.GL

cgGLDisableClientState Cg.GL

cgGLDisableProfile Cg.GL

cgGLDisableTextureParameter Cg.GL

cgGLEnableClientState Cg.GL

cgGLEnableProfile Cg.GL

cgGLEnableTextureParameter Cg.GL

cgGLGetLatestProfile Cg.GL

cgGLGetManageTextureParameters Cg.GL

cgGLGetMatrixParameterArraydc Cg.GL

cgGLGetMatrixParameterArraydr Cg.GL

cgGLGetMatrixParameterArrayfc Cg.GL

cgGLGetMatrixParameterArrayfr Cg.GL

cgGLGetMatrixParameterdc Cg.GL

cgGLGetMatrixParameterdr Cg.GL

cgGLGetMatrixParameterfc Cg.GL

cgGLGetMatrixParameterfr Cg.GL

cgGLGetParameter1d Cg.GL

cgGLGetParameter1f Cg.GL

cgGLGetParameter2d Cg.GL

cgGLGetParameter2f Cg.GL

cgGLGetParameter3d Cg.GL

cgGLGetParameter3f Cg.GL

cgGLGetParameter4d Cg.GL

cgGLGetParameter4f Cg.GL

cgGLGetParameterArray1d Cg.GL

cgGLGetParameterArray1f Cg.GL

cgGLGetParameterArray2d Cg.GL

cgGLGetParameterArray2f Cg.GL

cgGLGetParameterArray3d Cg.GL

cgGLGetParameterArray3f Cg.GL

cgGLGetParameterArray4d Cg.GL

cgGLGetParameterArray4f Cg.GL

cgGLGetProgramID Cg.GL

cgGLGetTextureEnum Cg.GL

cgGLGetTextureParameter Cg.GL

cgGLIsProfileSupported Cg.GL

***************************************************************************** *** Profile Functions ****************************************************************************
cgGLIsProgramLoaded Cg.GL

cgGLLoadProgram Cg.GL

***************************************************************************** *** Program Managment Functions ****************************************************************************
cgGLSetManageTextureParameters Cg.GL

cgGLSetMatrixParameterArraydc Cg.GL

cgGLSetMatrixParameterArraydr Cg.GL

cgGLSetMatrixParameterArrayfc Cg.GL

cgGLSetMatrixParameterArrayfr Cg.GL

cgGLSetMatrixParameterdc Cg.GL

cgGLSetMatrixParameterdr Cg.GL

***************************************************************************** *** Matrix Parameter Managment Functions ****************************************************************************
cgGLSetMatrixParameterfc Cg.GL

cgGLSetMatrixParameterfr Cg.GL

cgGLSetOptimalOptions Cg.GL

cgGLSetParameter1d Cg.GL

cgGLSetParameter1dv Cg.GL

cgGLSetParameter1f Cg.GL

***************************************************************************** *** Parameter Managment Functions ****************************************************************************
cgGLSetParameter1fv Cg.GL

cgGLSetParameter2d Cg.GL

cgGLSetParameter2dv Cg.GL

cgGLSetParameter2f Cg.GL

cgGLSetParameter2fv Cg.GL

cgGLSetParameter3d Cg.GL

cgGLSetParameter3dv Cg.GL

cgGLSetParameter3f Cg.GL

cgGLSetParameter3fv Cg.GL

cgGLSetParameter4d Cg.GL

cgGLSetParameter4dv Cg.GL

cgGLSetParameter4f Cg.GL

cgGLSetParameter4fv Cg.GL

cgGLSetParameterArray1d Cg.GL

cgGLSetParameterArray1f Cg.GL

cgGLSetParameterArray2d Cg.GL

cgGLSetParameterArray2f Cg.GL

cgGLSetParameterArray3d Cg.GL

cgGLSetParameterArray3f Cg.GL

cgGLSetParameterArray4d Cg.GL

cgGLSetParameterArray4f Cg.GL

cgGLSetParameterPointer Cg.GL

cgGLSetStateMatrixParameter Cg.GL

cgGLSetTextureParameter Cg.GL

***************************************************************************** *** Texture Parameter Managment Functions ****************************************************************************
cgGLUnbindProgram Cg.GL

cgIsContext Cg.Import

cgIsInterfaceType Cg.Import

cgIsParameter Cg.Import

cgIsParameterGlobal Cg.Import

cgIsParameterReferenced Cg.Import

cgIsParentType Cg.Import

cgIsProgram Cg.Import

cgIsProgramCompiled Cg.Import

cgSetArraySize Cg.Import

cgSetAutoCompile Cg.Import

cgSetErrorCallback Cg.Import

cgSetMatrixParameterdc Cg.Import

cgSetMatrixParameterdr Cg.Import

cgSetMatrixParameterfc Cg.Import

cgSetMatrixParameterfr Cg.Import

cgSetMultiDimArraySize Cg.Import

cgSetParameter1d Cg.Import

cgSetParameter1dv Cg.Import

cgSetParameter1f Cg.Import

cgSetParameter1fv Cg.Import

cgSetParameter2d Cg.Import

cgSetParameter2dv Cg.Import

cgSetParameter2f Cg.Import

cgSetParameter2fv Cg.Import

cgSetParameter3d Cg.Import

cgSetParameter3dv Cg.Import

cgSetParameter3f Cg.Import

cgSetParameter3fv Cg.Import

cgSetParameter4d Cg.Import

cgSetParameter4dv Cg.Import

cgSetParameter4f Cg.Import

cgSetParameter4fv Cg.Import

cgSetParameterSemantic Cg.Import

cgSetParameterVariability Cg.Import

CharToVirtualKeyCode GLScene.Keyboard

Returns the virtual keycode corresponding to the given char. The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.
CharToWideChar GLScene.Utils

CheckOpenGLError GLScene.OpenGL4

ChunkHeaderReport Formats.m3DSUtils

support functions for text output of chunk and database contents
ChunkTagToString Formats.m3DSUtils

ClampInteger GLScene.VectorGeometry

ClampInteger GLScene.VectorGeometry

ClampValue GLScene.VectorGeometry

Clamps aValue in the aMin-aMax interval
ClampValue GLScene.VectorGeometry

Clamps aValue in the aMin-INF interval
clBuildProgram OpenCL.Import

clCloneKernel OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clCompileProgram OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clCreateBuffer OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Memory Object APIs *//
clCreateCommandQueue OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Command Queue APIs *//
clCreateContext OpenCL.Import

clCreateContextFromType OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clCreateFromGLBuffer OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;
clCreateFromGLRenderbuffer OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;
clCreateFromGLTexture3D OpenCL.GL

CL_API_SUFFIX__VERSION_1_2;
clCreateImage OpenCL.Import

CL_API_SUFFIX__VERSION_1_1
clCreateKernel OpenCL.Import

Kernel Object APIs
clCreateKernelsInProgram OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clCreatePipe OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clCreateProgramWithBinary OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clCreateProgramWithBuiltInKernels OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clCreateProgramWithIL OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clCreateProgramWithSource OpenCL.Import

Program Object APIs
clCreateSamplerWithProperties OpenCL.Import

CL_API_SUFFIX__VERSION_2_0 * Sampler APIs *//
clCreateSubBuffer OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clCreateSubDevices OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clCreateUserEvent OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
ClearGLError GLScene.OpenGL4

Gets the oldest error and tries to clear the error queue
clEnqueueAcquireGLObjects OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;
clEnqueueBarrier OpenCL.Import

clEnqueueBarrierWithWaitList OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clEnqueueCopyBuffer OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clEnqueueCopyBufferRect OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueCopyBufferToImage OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueCopyImage OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clEnqueueCopyImageToBuffer OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueFillBuffer OpenCL.Import

CL_API_SUFFIX__VERSION_1_1
clEnqueueFillImage OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueMapBuffer OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueMapImage OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueMarkerWithWaitList OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueMigrateMemObjects OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueNativeKernel OpenCL.Import

clEnqueueNDRangeKernel OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clEnqueueReadBuffer OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Enqueued Commands APIs *//
clEnqueueReadBufferRect OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueReadImage OpenCL.Import

CL_API_SUFFIX__VERSION_1_1
clEnqueueReleaseGLObjects OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;
clEnqueueSVMFree OpenCL.Import

clEnqueueSVMMap OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clEnqueueSVMMemcpy OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueSVMmigrateMem OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clEnqueueSVMUnmap OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clEnqueueUnmapMemObject OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueWaitForEvents OpenCL.Import

CL_API_SUFFIX__VERSION_2_1
clEnqueueWriteBuffer OpenCL.Import

CL_API_SUFFIX__VERSION_1_1
clEnqueueWriteBufferRect OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clEnqueueWriteImage OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clFinish OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clFlush OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Flush and Finish APIs *//
clGetCommandQueueInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetContextInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetDeviceAndHostTimer OpenCL.Import

CL_API_SUFFIX__VERSION_2_1
clGetDeviceIDs OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Device APIs *//
clGetDeviceInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetEventInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetEventProfilingInfo OpenCL.Import

Profiling APIs
clGetExtensionFunctionAddressForPlatform OpenCL.Import

* Extension function access * * Returns the extension function address for the given function name, * or NULL if a valid function can not be found. The client must * check to make sure the address is not NULL, before using or * calling the returned function address. *
clGetGLContextInfoKHR OpenCL.GL

clGetGLObjectInfo OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;
clGetGLTextureInfo OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;
clGetHostTimer OpenCL.Import

CL_API_SUFFIX__VERSION_2_1
clGetImageInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetKernelArgInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetKernelInfo OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clGetKernelSubGroupInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetKernelWorkGroupInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clGetMemObjectInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetPipeInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetPlatformIDs OpenCL.Import

Platform API
clGetPlatformInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetProgramBuildInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetProgramInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clGetSamplerInfo OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clGetSupportedImageFormats OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
ClipToAABB GLScene.GeometryBB

Clips a position to an AABB
clLinkProgram OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
CloseCUDA CUDA.Import

CloseCUDART CUDA.Runtime

CloseCUFFT CUDA.FourierTransform

CloseCUTIL CUDA.Utility

CloseODE ODE.Import

CloseOpenCL OpenCL.Import

CloseOpenGL GLS.OpenGLAdapter

CloseOpenGL GLScene.OpenGL4

clReleaseCommandQueue OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clReleaseContext OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clReleaseDevice OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clReleaseEvent OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clReleaseKernel OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clReleaseMemObject OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clReleaseProgram OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clReleaseSampler OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clRetainCommandQueue OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clRetainContext OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clRetainDevice OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clRetainEvent OpenCL.Import

CL_API_SUFFIX__VERSION_1_1
clRetainKernel OpenCL.Import

CL_API_SUFFIX__VERSION_2_1
clRetainMemObject OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clRetainProgram OpenCL.Import

CL_API_SUFFIX__VERSION_2_1
clRetainSampler OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clSetDefaultDeviceCommandQueue OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clSetEventCallback OpenCL.Import

clSetKernelArg OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clSetKernelArgSVMPointer OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clSetKernelExecInfo OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clSetMemObjectDestructorCallback OpenCL.Import

clSetUserEventStatus OpenCL.Import

CL_API_SUFFIX__VERSION_1_0
clSVMAlloc OpenCL.Import

CL_API_SUFFIX__VERSION_1_1 * SVM Allocation APIs *//
clSVMFree OpenCL.Import

CL_API_SUFFIX__VERSION_2_0
clUnloadPlatformCompiler OpenCL.Import

CL_API_SUFFIX__VERSION_1_2
clWaitForEvents OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Event Object APIs *//
CollideAndSlide GLS.EllipseCollision

CollideWithWorld GLS.EllipseCollision

CombineVector GLScene.VectorGeometry

CombineVector GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f
CombineVector GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f
CombineVector GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f
CompareInteger GLScene.RedBlackTree

CompressedInternalFormatToOpenGL GLScene.TextureFormat

Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format
ComputeOrbitalElements GLS.SkyDome

Compute orbital elements for given Julian day.
ComputePlanetPosition GLS.SkyDome

ComputePlanetPosition GLS.SkyDome

Compute the planet position for given Julian day (in AU).
ConeContainsBSphere GLS.SpacePartition

Determines to which extent one Cone contains an BSphere
ConstArrayToString GLScene.Logger

ConvertDoubleToString PasDblStrUtils

ConvertdVector3ToAffineVector GLS.ODEUtils

ConvertdVector3ToAffineVector GLS.ODEUtils

ConvertdVector3ToVector3f GLS.ODEUtils

ConvertdVector3ToVector3f GLS.ODEUtils

Converting between ODE and GLScene formats
ConvertdVector3ToVector4f GLS.ODEUtils

ConvertdVector3ToVector4f GLS.ODEUtils

ConvertFansToList GLS.MeshUtils

ConvertImage GLS.ImageUtils

ConvertIndexedListToList GLS.MeshUtils

Expands an indexed structure into a non-indexed structure.
ConvertRotation GLScene.VectorGeometry

Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians)
ConvertStringToDouble PasDblStrUtils

ConvertStringToDouble PasDblStrUtils

ConvertStripToList GLS.MeshUtils

ConvertStripToList GLS.MeshUtils

ConvertStripToList GLS.MeshUtils

ConvertStripToList GLS.MeshUtils

Converts a triangle strips into a triangle list. Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.
ConvertVector3fTodVector3 GLS.ODEUtils

Converting between GLScene and ODE formats
ConvertVector3fToPdVector3 GLS.ODEUtils

ConvertVector4fTodVector3 GLS.ODEUtils

ConvertVector4fToPdVector3 GLS.ODEUtils

CopyBodyFromCube GLS.ODEUtils

CopyCubeSizeFromBox GLS.ODEUtils

CopyPosFromGeomToGL GLS.ODEUtils

CopyScreentoTexture GLSL.CustomShader

CopyScreentoTexture2 GLSL.CustomShader

Cosine_Interpolate GLS.Perlin

does a cosine interpolation
CreateAffineRotationMatrix GLScene.VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.
CreateBodyFromCube GLS.ODEUtils

CreateBox PhysX.Import

CreateCylinder PhysX.Import

CreateEditableStream Formats.VFW

– Editing routines ———————————————————
CreateGeomFromCube GLS.ODEUtils

CreateGraphicFromFile GLS.Texture

CreateGroundPlane PhysX.Import

CreateLookAtMatrix GLScene.VectorGeometry

CreateMatrixFromFrustum GLScene.VectorGeometry

CreateObjectSpaceNormalMap GLS.BumpmapHDS

CreateODEPlaneFromGLPlane GLS.ODEUtils

CreateOrthoMatrix GLScene.VectorGeometry

CreatePerspectiveMatrix GLScene.VectorGeometry

CreatePickMatrix GLScene.VectorGeometry

CreateResourceStream GLS.ApplicationFileIO

CreateRotationMatrix GLScene.VectorGeometry

CreateRotationMatrix GLScene.VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.
CreateRotationMatrixX GLScene.VectorGeometry

CreateRotationMatrixX GLScene.VectorGeometry

Creates matrix for rotation about x-axis (angle in rad)
CreateRotationMatrixY GLScene.VectorGeometry

CreateRotationMatrixY GLScene.VectorGeometry

Creates matrix for rotation about y-axis (angle in rad)
CreateRotationMatrixZ GLScene.VectorGeometry

CreateRotationMatrixZ GLScene.VectorGeometry

Creates matrix for rotation about z-axis (angle in rad)
CreateScaleAndTranslationMatrix GLScene.VectorGeometry

Creates a scale+translation matrix. Scale is applied BEFORE applying offset
CreateScaleMatrix GLScene.VectorGeometry

Creates scale matrix
CreateScaleMatrix GLScene.VectorGeometry

Creates scale matrix
CreateSphere PhysX.Import

CreateTangentSpaceNormalMap GLS.BumpmapHDS

CreateTempWnd GLS.WindowsContext

CreateTranslationMatrix GLScene.VectorGeometry

Creates translation matrix
CreateTranslationMatrix GLScene.VectorGeometry

Creates translation matrix
CreateTriMeshFromBaseMesh GLS.ODEUtils

This method requires you to manually deallocate vertices and indices when you're done with the trimesh
CreateVerletPlaneFromGLPlane GLS.VerletTypes

CSG_Operation GLS.MeshCSG

CubeWireframeBuildList GLS.Objects

Issues for a unit-size cube stippled wireframe
Cubic_Interpolate GLS.Perlin

does a cubic interpolation
Cubic_Interpolate_Strip GLS.Perlin

cubic interpolate 4 strips into one...
cudaGetLastErrorString CUDA.Runtime

cudppCompact CUDA.ParallelPrimitives

cudppDestroyPlan CUDA.ParallelPrimitives

cudppDestroySparseMatrix CUDA.ParallelPrimitives

cudppMultiScan CUDA.ParallelPrimitives

cudppPlan CUDA.ParallelPrimitives

Plan allocation (for scan, sort, and compact)
cudppRand CUDA.ParallelPrimitives

random number generation algorithms
cudppRandSeed CUDA.ParallelPrimitives

cudppScan CUDA.ParallelPrimitives

Scan and sort algorithms
cudppSegmentedScan CUDA.ParallelPrimitives

cudppSort CUDA.ParallelPrimitives

cudppSparseMatrix CUDA.ParallelPrimitives

Sparse matrix allocation
cudppSparseMatrixVectorMultiply CUDA.ParallelPrimitives

Sparse matrix-vector algorithms
CurrentGLContext GLS.Context

The TGLContext that is the currently active context, if any. Returns nil if no context is active.
dAreConnected ODE.Import

dAreConnectedExcluding ODE.Import

dBodyAddForce ODE.Import

—– dBody —–
dBodyAddForceAtPos ODE.Import

dBodyAddForceAtRelPos ODE.Import

dBodyAddRelForce ODE.Import

dBodyAddRelForceAtPos ODE.Import

dBodyAddRelForceAtRelPos ODE.Import

dBodyAddRelTorque ODE.Import

dBodyAddTorque ODE.Import

dBodyCopyPosition ODE.Import

dBodyCopyQuaternion ODE.Import

dBodyCopyRotation ODE.Import

dBodyCreate ODE.Import

dBodyDestroy ODE.Import

dBodyDisable ODE.Import

dBodyEnable ODE.Import

dBodyGetAngularDamping ODE.Import

dBodyGetAngularDampingThreshold ODE.Import

dBodyGetAngularVel ODE.Import

dBodyGetAutoDisableAngularThreshold ODE.Import

dBodyGetAutoDisableFlag ODE.Import

dBodyGetAutoDisableLinearThreshold ODE.Import

Auto-disable functions
dBodyGetAutoDisableSteps ODE.Import

dBodyGetAutoDisableTime ODE.Import

dBodyGetData ODE.Import

dBodyGetFiniteRotationAxis ODE.Import

dBodyGetFiniteRotationMode ODE.Import

dBodyGetForce ODE.Import

dBodyGetGravityMode ODE.Import

dBodyGetJoint ODE.Import

dBodyGetLinearDamping ODE.Import

dBodyGetLinearDampingThreshold ODE.Import

dBodyGetLinearVel ODE.Import

dBodyGetMass ODE.Import

dBodyGetMaxAngularSpeed ODE.Import

dBodyGetNumJoints ODE.Import

dBodyGetPointVel ODE.Import

dBodyGetPosition ODE.Import

dBodyGetPosRelPoint ODE.Import

dBodyGetQuaternion ODE.Import

dBodyGetRelPointPos ODE.Import

dBodyGetRelPointVel ODE.Import

dBodyGetRotation ODE.Import

dBodyGetTorque ODE.Import

dBodyIsEnabled ODE.Import

dBodySetAngularDamping ODE.Import

dBodySetAngularDampingThreshold ODE.Import

dBodySetAngularVel ODE.Import

dBodySetAutoDisableAngularThreshold ODE.Import

dBodySetAutoDisableAverageSamplesCount ODE.Import

dBodySetAutoDisableDefaults ODE.Import

dBodySetAutoDisableFlag ODE.Import

dBodySetAutoDisableLinearThreshold ODE.Import

dBodySetAutoDisableSteps ODE.Import

dBodySetAutoDisableTime ODE.Import

dBodySetDamping ODE.Import

dBodySetDampingDefaults ODE.Import

dBodySetData ODE.Import

dBodySetFiniteRotationAxis ODE.Import

dBodySetFiniteRotationMode ODE.Import

dBodySetForce ODE.Import

dBodySetGravityMode ODE.Import

dBodySetLinearDamping ODE.Import

damping functions
dBodySetLinearDampingThreshold ODE.Import

dBodySetLinearVel ODE.Import

dBodySetMass ODE.Import

dBodySetMaxAngularSpeed ODE.Import

dBodySetMovedCallback ODE.Import

dBodySetPosition ODE.Import

dBodySetQuaternion ODE.Import

dBodySetRotation ODE.Import

dBodySetTorque ODE.Import

dBodyToBodyDistance GLS.ODEUtils

dBodyVectorFromWorld ODE.Import

dBodyVectorToWorld ODE.Import

dBoxTouchesBox ODE.Import

dClearUpperTriangle ODE.Import

dCloseODE ODE.Import

dClosestLineSegmentPoints ODE.Import

—– Misc —–
dCollide ODE.Import

dCreateBox ODE.Import

Box
dCreateCapsule ODE.Import

dCapsule (a capped cylinder).
dCreateConvex ODE.Import

Convex
dCreateCylinder ODE.Import

dCylinder (not a capped cylinder).
dCreateGeom ODE.Import

—– dGeom —–
dCreateGeomClass ODE.Import

dCreateGeomTransform ODE.Import

Transform
dCreateHeightfield ODE.Import

Heightfield (incomplete)
dCreatePlane ODE.Import

Plane
dCreateRay ODE.Import

dRay
dCreateSphere ODE.Import

Sphere
dCreateTriMesh ODE.Import

TriMesh
dDot ODE.Import

dDot ODE.Import

—– Recreated —–
dDOT14 ODE.Import

dDOT14 ODE.Import

dDQfromW ODE.Import

DDSHeaderToGLEnum Formats.DXTC

DDStex GLS.FileDDS

DDStex GLS.FileDDS

DDStex GLS.FileDDS

function DDStex(aMatLib: TGLMaterialLibrary; aTexName, aDDSFileName: string; aSecondTexName: string = ''; aDDSLevel: integer = 0): TGLLibMaterial; overload;
DecodeDXT1toBitmap32 Formats.DXTC

DecodeDXT3toBitmap32 Formats.DXTC

DecodeDXT5toBitmap32 Formats.DXTC

DecodeTextureTarget GLScene.TextureFormat

DegToRadian GLScene.VectorGeometry

DegToRadian GLScene.VectorGeometry

—————————————————————————- Trigonometric functions —————————————————————————-
DeleteChunk Formats.m3DSUtils

support functions for chunk handling
DeRegisterCUDAComponentNameChangeEvent GLS.CUDA.APIComps

DeRegisterGLBaseSceneObjectNameChangeEvent GLS.Scene

Deregister an event handler triggered by any TGLBaseSceneObject Name change. See RegisterGLBaseSceneObjectNameChangeEvent.
DeRegisterGLBehaviourNameChangeEvent GLS.Scene

Deregister an event handler triggered by any TGLBaseSceneObject Name change. See RegisterGLBaseSceneObjectNameChangeEvent.
DeRegisterGLMaterialExNameChangeEvent GLS.MaterialEx

DeRegisterManager GLScene.Manager

DeRegisterXCollectionDestroyEvent GLScene.XCollection

DeRegisters event
DerivatedPolynom GLScene.Polynomials

Calculates the polynom's derivative
dGeomBoxGetLengths ODE.Import

dGeomBoxPointDepth ODE.Import

dGeomBoxSetLengths ODE.Import

dGeomCapsuleGetParams ODE.Import

dGeomCapsulePointDepth ODE.Import

dGeomCapsuleSetParams ODE.Import

dGeomClearOffset ODE.Import

dGeomCopyOffsetPosition ODE.Import

dGeomCopyOffsetRotation ODE.Import

dGeomCopyPosition ODE.Import

dGeomCopyQuaternion ODE.Import

dGeomCopyRotation ODE.Import

dGeomCylinderGetParams ODE.Import

dGeomCylinderSetParams ODE.Import

dGeomDestroy ODE.Import

dGeomDisable ODE.Import

dGeomEnable ODE.Import

dGeomGetAABB ODE.Import

dGeomGetBody ODE.Import

dGeomGetCategoryBits ODE.Import

dGeomGetClass ODE.Import

dGeomGetClassData ODE.Import

dGeomGetCollideBits ODE.Import

dGeomGetData ODE.Import

dGeomGetOffsetPosition ODE.Import

dGeomGetOffsetQuaternion ODE.Import

dGeomGetOffsetRotation ODE.Import

dGeomGetPosition ODE.Import

dGeomGetQuaternion ODE.Import

dGeomGetRotation ODE.Import

dGeomGetSpace ODE.Import

dGeomHeightfieldDataCreate ODE.Import

dGeomHeightfieldDataDestroy ODE.Import

dGeomHeightfieldDataSetBounds ODE.Import

dGeomHeightfieldGetHeightfieldData ODE.Import

dGeomHeightfieldSetHeightfieldData ODE.Import

dGeomIsEnabled ODE.Import

dGeomIsOffset ODE.Import

dGeomIsSpace ODE.Import

dGeomPlaneGetParams ODE.Import

dGeomPlanePointDepth ODE.Import

dGeomPlaneSetParams ODE.Import

dGeomRayGet ODE.Import

dGeomRayGetClosestHit ODE.Import

dGeomRayGetLength ODE.Import

dGeomRayGetParams ODE.Import

dGeomRaySet ODE.Import

dGeomRaySetClosestHit ODE.Import

dGeomRaySetLength ODE.Import

dGeomRaySetParams ODE.Import

dGeomSetBody ODE.Import

dGeomSetCategoryBits ODE.Import

dGeomSetCollideBits ODE.Import

dGeomSetConvex ODE.Import

dGeomSetData ODE.Import

dGeomSetOffsetPosition ODE.Import

dGeomSetOffsetQuaternion ODE.Import

dGeomSetOffsetRotation ODE.Import

dGeomSetOffsetWorldPosition ODE.Import

dGeomSetOffsetWorldQuaternion ODE.Import

dGeomSetOffsetWorldRotation ODE.Import

dGeomSetPosition ODE.Import

dGeomSetQuaternion ODE.Import

dGeomSetRotation ODE.Import

dGeomSphereGetRadius ODE.Import

dGeomSpherePointDepth ODE.Import

dGeomSphereSetRadius ODE.Import

dGeomTransformGetCleanup ODE.Import

dGeomTransformGetGeom ODE.Import

dGeomTransformGetInfo ODE.Import

dGeomTransformSetCleanup ODE.Import

dGeomTransformSetGeom ODE.Import

dGeomTransformSetInfo ODE.Import

dGeomTriMeshClearTCCache ODE.Import

dGeomTriMeshDataBuildDouble ODE.Import

dGeomTriMeshDataBuildDouble1 ODE.Import

dGeomTriMeshDataBuildSimple ODE.Import

dGeomTriMeshDataBuildSimple1 ODE.Import

dGeomTriMeshDataBuildSingle ODE.Import

dGeomTriMeshDataBuildSingle1 ODE.Import

dGeomTriMeshDataCreate ODE.Import

dGeomTriMeshDataDestroy ODE.Import

dGeomTriMeshDataSet ODE.Import

dGeomTriMeshDataUpdate ODE.Import

dGeomTriMeshEnableTC ODE.Import

dGeomTriMeshGetArrayCallback ODE.Import

dGeomTriMeshGetCallback ODE.Import

dGeomTriMeshGetData ODE.Import

dGeomTriMeshGetPoint ODE.Import

dGeomTriMeshGetRayCallback ODE.Import

dGeomTriMeshGetTriangle ODE.Import

dGeomTriMeshGetTriangleCount ODE.Import

dGeomTriMeshGetTriMeshDataID ODE.Import

dGeomTriMeshIsTCEnabled ODE.Import

dGeomTriMeshSetArrayCallback ODE.Import

dGeomTriMeshSetCallback ODE.Import

dGeomTriMeshSetData ODE.Import

dGeomTriMeshSetRayCallback ODE.Import

dgettext gnugettext

dgettext_NoExtract gnugettext

dHashSpaceCreate ODE.Import

dHashSpaceGetLevels ODE.Import

dHashSpaceSetLevels ODE.Import

dInfiniteAABB ODE.Import

dInitODE ODE.Import

added by PAR
dInitODE2 ODE.Import

DistanceBetweenAngles GLScene.VectorGeometry

Calculates the angular distance between two angles in radians. Result is in the [0; PI] range.
Div2 GLS.Graphics

DivideVector GLScene.VectorGeometry

DivideVector GLScene.VectorGeometry

Divides given vector by another vector. v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.
DivMod GLScene.VectorGeometry

dJointAddAMotorTorques ODE.Import

dJointAddHinge2Torques ODE.Import

dJointAddHingeTorque ODE.Import

dJointAddPistonForce ODE.Import

dJointAddPRTorque ODE.Import

dJointAddSliderForce ODE.Import

dJointAddUniversalTorques ODE.Import

dJointAttach ODE.Import

dJointCorrectHinge2 ODE.Import

dJointCreateAMotor ODE.Import

AMotor
dJointCreateBall ODE.Import

Ball
dJointCreateContact ODE.Import

Contact
dJointCreateFixed ODE.Import

Fixed
dJointCreateHinge ODE.Import

Hinge
dJointCreateHinge2 ODE.Import

Hinge2
dJointCreateLMotor ODE.Import

LMotor
dJointCreatePiston ODE.Import

Piston
dJointCreatePlane2D ODE.Import

Plane2D
dJointCreatePR ODE.Import

PR
dJointCreateSlider ODE.Import

Slider
dJointCreateUniversal ODE.Import

Universal
dJointDestroy ODE.Import

dJointGetAMotorAngle ODE.Import

dJointGetAMotorAngleRate ODE.Import

dJointGetAMotorAxis ODE.Import

dJointGetAMotorAxisRel ODE.Import

dJointGetAMotorMode ODE.Import

dJointGetAMotorNumAxes ODE.Import

dJointGetAMotorParam ODE.Import

dJointGetBallAnchor ODE.Import

dJointGetBallAnchor2 ODE.Import

dJointGetBody ODE.Import

dJointGetData ODE.Import

dJointGetFeedback ODE.Import

dJointGetHinge2Anchor ODE.Import

dJointGetHinge2Anchor2 ODE.Import

dJointGetHinge2Angle1 ODE.Import

dJointGetHinge2Angle1Rate ODE.Import

dJointGetHinge2Angle2Rate ODE.Import

dJointGetHinge2Axis1 ODE.Import

dJointGetHinge2Axis2 ODE.Import

dJointGetHinge2Param ODE.Import

dJointGetHingeAnchor ODE.Import

dJointGetHingeAnchor2 ODE.Import

dJointGetHingeAngle ODE.Import

dJointGetHingeAngleRate ODE.Import

dJointGetHingeAxis ODE.Import

dJointGetHingeParam ODE.Import

dJointGetLMotorAxis ODE.Import

dJointGetLMotorNumAxes ODE.Import

dJointGetLMotorParam ODE.Import

dJointGetPistonAnchor ODE.Import

dJointGetPistonAnchor2 ODE.Import

dJointGetPistonAngle ODE.Import

dJointGetPistonAngleRate ODE.Import

dJointGetPistonAxis ODE.Import

dJointGetPistonParam ODE.Import

dJointGetPistonPosition ODE.Import

dJointGetPistonRate ODE.Import

dJointGetPRAxis1 ODE.Import

dJointGetPRAxis2 ODE.Import

dJointGetPRParam ODE.Import

dJointGetSliderAxis ODE.Import

dJointGetSliderParam ODE.Import

dJointGetSliderPosition ODE.Import

dJointGetSliderPositionRate ODE.Import

dJointGetType ODE.Import

dJointGetUniversalAnchor ODE.Import

dJointGetUniversalAnchor2 ODE.Import

dJointGetUniversalAngle1 ODE.Import

dJointGetUniversalAngle1Rate ODE.Import

dJointGetUniversalAngle2 ODE.Import

dJointGetUniversalAngle2Rate ODE.Import

dJointGetUniversalAxis1 ODE.Import

dJointGetUniversalAxis2 ODE.Import

dJointGetUniversalParam ODE.Import

dJointGroupCreate ODE.Import

dJointGroupDestroy ODE.Import

—– dJoint —– normal joints
dJointGroupEmpty ODE.Import

dJointSetAMotorAngle ODE.Import

dJointSetAMotorAxis ODE.Import

dJointSetAMotorMode ODE.Import

dJointSetAMotorNumAxes ODE.Import

dJointSetAMotorParam ODE.Import

dJointSetBallAnchor ODE.Import

dJointSetData ODE.Import

dJointSetFeedback ODE.Import

callback routines for feedback of joints
dJointSetFixed ODE.Import

dJointSetHinge2Anchor ODE.Import

dJointSetHinge2Axis1 ODE.Import

dJointSetHinge2Axis2 ODE.Import

dJointSetHinge2Param ODE.Import

dJointSetHingeAnchor ODE.Import

dJointSetHingeAxis ODE.Import

dJointSetHingeParam ODE.Import

dJointSetLMotorAxis ODE.Import

dJointSetLMotorNumAxes ODE.Import

dJointSetLMotorParam ODE.Import

dJointSetPistonAnchor ODE.Import

dJointSetPistonAxis ODE.Import

dJointSetPistonAxisDelta ODE.Import

dJointSetPistonParam ODE.Import

dJointSetPlane2DAngleParam ODE.Import

dJointSetPlane2DXParam ODE.Import

dJointSetPlane2DYParam ODE.Import

dJointSetPRAnchor ODE.Import

dJointSetPRAxis1 ODE.Import

dJointSetPRAxis2 ODE.Import

dJointSetPRParam ODE.Import

dJointSetSliderAxis ODE.Import

dJointSetSliderParam ODE.Import

dJointSetUniversalAnchor ODE.Import

dJointSetUniversalAxis1 ODE.Import

dJointSetUniversalAxis2 ODE.Import

dJointSetUniversalParam ODE.Import

dMakeRandomMatrix ODE.Import

dMakeRandomVector ODE.Import

dMassAdd ODE.Import

dMassAdjust ODE.Import

dMassRotate ODE.Import

dMassSetBox ODE.Import

dMassSetBoxTotal ODE.Import

dMassSetCapsule ODE.Import

dMassSetCapsuleTotal ODE.Import

dMassSetCylinder ODE.Import

dMassSetCylinderTotal ODE.Import

dMassSetParameters ODE.Import

—– dMass —–
dMassSetSphere ODE.Import

dMassSetSphereTotal ODE.Import

dMassSetTrimesh ODE.Import

dMassSetTrimeshTotal ODE.Import

dMassSetZero ODE.Import

dMassTranslate ODE.Import

dMaxDifference ODE.Import

dMultiply0 ODE.Import

dMULTIPLY0_331 ODE.Import

dMULTIPLY0_333 ODE.Import

dMultiply1 ODE.Import

dMultiply2 ODE.Import

dngettext gnugettext

dNormalize3 ODE.Import

—– Math —–
dNormalize4 ODE.Import

DoTesselate GLS.PolygonTesselation

Tesselates the polygon outlined by the Vertexes. And adds them to the first facegroup of the Mesh.
dQFromAxisAndAngle ODE.Import

—– Rotation.h —–
dQfromR ODE.Import

dQMultiply0 ODE.Import

dQMultiply1 ODE.Import

dQMultiply2 ODE.Import

dQMultiply3 ODE.Import

dQSetIdentity ODE.Import

dQuadTreeSpaceCreate ODE.Import

dRandGetSeed ODE.Import

dRandInt ODE.Import

dRandReal ODE.Import

dRandSetSeed ODE.Import

DrawBox GLS.ODEUtils

DrawContours GLS.ROAMPatch

Draw contours on rendering terrain patches
DrawDibBegin Formats.VFW

– DrawDibBegin() - prepare to draw —————————————–
DrawDibChangePalette Formats.VFW

– DrawDibChangePalette() —————————————————
DrawDibClose Formats.VFW

– DrawDibClose() ———————————————————–
DrawDibDraw Formats.VFW

– DrawDibDraw() - actually draw a DIB to the screen ————————
DrawDibEnd Formats.VFW

– DrawDibEnd() ————————————————————-
DrawDibGetBuffer Formats.VFW

– DrawDibGetBuffer() ——————————————————-
DrawDibGetPalette Formats.VFW

– DrawDibGetPalette() - get the palette used for drawing DIBs ————–
DrawDibOpen Formats.VFW

– DrawDibOpen() ————————————————————
DrawDibProfileDisplay Formats.VFW

...
DrawDibRealize Formats.VFW

– DrawDibRealize() - realize the palette in a HDD ————————–
DrawDibSetPalette Formats.VFW

– DrawDibSetPalette() - set the palette used for drawing DIBs ————–
DrawDibStart Formats.VFW

– DrawDibStart() - start of streaming playback —————————–
DrawDibStop Formats.VFW

– DrawDibStop() - start of streaming playback ——————————
DrawDibTime Formats.VFW

DrawDibUpdate Formats.VFW

– DrawDibUpdate() - redraw last image (may only be valid with DDF_BUFFER) –
DrawTexturedScreenQuad GLSL.CustomShader

Probably need to give them proper names, instead of numbers...
DrawTexturedScreenQuad2 GLSL.CustomShader

DrawTexturedScreenQuad3 GLSL.CustomShader

DrawTexturedScreenQuad4 GLSL.CustomShader

DrawTexturedScreenQuad5 GLSL.CustomShader

DrawTexturedScreenQuad6 GLSL.CustomShader

dRFrom2Axes ODE.Import

dRFromAxisAndAngle ODE.Import

dRFromEulerAngles ODE.Import

dRfromQ ODE.Import

dRFromZAxis ODE.Import

dRSetIdentity ODE.Import

dsDrawBox GLS.ODEUtils

dsDrawBox GLS.ODEUtils

dSimpleSpaceCreate ODE.Import

dSpaceAdd ODE.Import

dSpaceClean ODE.Import

dSpaceCollide ODE.Import

dSpaceCollide2 ODE.Import

dSpaceDestroy ODE.Import

—– dSpace —–
dSpaceGetCleanup ODE.Import

dSpaceGetGeom ODE.Import

dSpaceGetNumGeoms ODE.Import

dSpaceQuery ODE.Import

dSpaceRemove ODE.Import

dSpaceSetCleanup ODE.Import

dTestMatrixComparison ODE.Import

dTestRand ODE.Import

return 1 if the random number generator is working.
dTestSolveLCP ODE.Import

DumpChunk Formats.m3DSUtils

DumpKeyHeader Formats.m3DSUtils

dVector3Length GLS.ODEUtils

dVector3Length GLS.ODEUtils

dWorldCreate ODE.Import

—– dWorld —–
dWorldDestroy ODE.Import

dWorldExportDIF ODE.Import

dWorldGetAngularDamping ODE.Import

dWorldGetAngularDampingThreshold ODE.Import

dWorldGetAutoDisableAngularAverageThreshold ODE.Import

dWorldGetAutoDisableAngularThreshold ODE.Import

dWorldGetAutoDisableAverageSamplesCount ODE.Import

dWorldGetAutoDisableFlag ODE.Import

dWorldGetAutoDisableLinearAverageThreshold ODE.Import

Auto-disable functions
dWorldGetAutoDisableLinearThreshold ODE.Import

dWorldGetAutoDisableSteps ODE.Import

dWorldGetAutoDisableTime ODE.Import

dWorldGetCFM ODE.Import

dWorldGetContactMaxCorrectingVel ODE.Import

dWorldGetContactSurfaceLayer ODE.Import

dWorldGetERP ODE.Import

dWorldGetGravity ODE.Import

dWorldGetLinearDamping ODE.Import

dWorldGetLinearDampingThreshold ODE.Import

Damping
dWorldGetMaxAngularSpeed ODE.Import

dWorldGetQuickStepNumIterations ODE.Import

dWorldGetQuickStepW ODE.Import

dWorldImpulseToForce ODE.Import

dWorldQuickStep ODE.Import

QuickStep
dWorldSetAngularDamping ODE.Import

dWorldSetAngularDampingThreshold ODE.Import

dWorldSetAutoDisableAngularAverageThreshold ODE.Import

dWorldSetAutoDisableAngularThreshold ODE.Import

dWorldSetAutoDisableAverageSamplesCount ODE.Import

dWorldSetAutoDisableFlag ODE.Import

dWorldSetAutoDisableLinearAverageThreshold ODE.Import

dWorldSetAutoDisableLinearThreshold ODE.Import

dWorldSetAutoDisableSteps ODE.Import

dWorldSetAutoDisableTime ODE.Import

dWorldSetCFM ODE.Import

dWorldSetContactMaxCorrectingVel ODE.Import

dWorldSetContactSurfaceLayer ODE.Import

dWorldSetDamping ODE.Import

dWorldSetERP ODE.Import

dWorldSetGravity ODE.Import

dWorldSetLinearDamping ODE.Import

dWorldSetLinearDampingThreshold ODE.Import

dWorldSetMaxAngularSpeed ODE.Import

dWorldSetQuickStepNumIterations ODE.Import

dWorldSetQuickStepW ODE.Import

dWorldStep ODE.Import

Step
ECAddBox GLS.DCE

Add a TriMesh box
ECAddEllipsoid GLS.DCE

Add a static ellipsoid
ECAddFreeForm GLS.DCE

Add freeform's octree data
ECAddTerrain GLS.DCE

Add the terrain as a TriMesh
ECResetColliders GLS.DCE

Set the collider lists to null
ECSetCollisionRange GLS.DCE

———————- DCE Misc functions ————————— Calculate and set the collision range
EditGLTextureImage GLS.TextureImageEditors

Invokes the editor for the given TGLTextureImage
EditStreamClone Formats.VFW

EditStreamCopy Formats.VFW

EditStreamCut Formats.VFW

EditStreamPaste Formats.VFW

EditStreamSetInfo Formats.VFW

EditStreamSetInfoA Formats.VFW

EditStreamSetInfoW Formats.VFW

EditStreamSetName Formats.VFW

EditStreamSetInfoA
EditStreamSetNameA Formats.VFW

EditStreamSetNameW Formats.VFW

EiselLemireStringToDouble PasDblStrUtils

EiselLemireStringToDouble PasDblStrUtils

EncodeGLTextureTarget GLScene.TextureFormat

EndFPUOnlySection GLScene.VectorGeometry

Ends a FPU-only section. See BeginFPUOnlySection
EvalPolynom GLScene.Polynomials

Computes polynom's value for given x
ExponateCrap GLS.Perlin

The function returning some integer based on the rootˆexponant concept, result is crap and is only for "random" usage... eg perlin.
ExtendedFrustumIntersectsBSphere GLS.SpacePartition

Determines if a extended frustum intersects an BSphere
ExtendedFrustumMake GLS.SpacePartition

Create an extended frustum from a number of values
ExtendedFrustumMakeFromSceneViewer GLS.SpacePartition

ExtendedFrustumMakeFromSceneViewer GLS.SpacePartition

Create an extended frustum from a GLSceneViewer - this makes the unit specific to the windows platform!
ExtractAABBCorners GLScene.GeometryBB

Extract the corners from an AABB
ExtractFrustumFromModelViewProjection GLScene.VectorGeometry

Extracts a TFrustum for combined modelview and projection matrices
FacesSmooth GLS.MeshBuilder

FallbackStringToDouble PasDblStrUtils

FallbackStringToDouble PasDblStrUtils

FastArcTangent2 GLScene.VectorGeometry

Fast ArcTangent2 approximation, about 0.07 rads accuracy
FastCheckCubeVsCube GLS.Collision

FastCheckCubeVsEllipsoid GLS.Collision

FastCheckCubeVsFace GLS.Collision

FastCheckCubeVsPoint GLS.Collision

FastCheckCubeVsSphere GLS.Collision

FastCheckEllipsoidVsCube GLS.Collision

FastCheckEllipsoidVsEllipsoid GLS.Collision

FastCheckEllipsoidVsPoint GLS.Collision

FastCheckEllipsoidVsSphere GLS.Collision

FastCheckFaceVsCube GLS.Collision

experimental
FastCheckFaceVsFace GLS.Collision

experimental
FastCheckPointVsCube GLS.Collision

FastCheckPointVsEllipsoid GLS.Collision

FastCheckPointVsPoint GLS.Collision

Fast Collision detection routines that are heavily specialized and just return a boolean
FastCheckPointVsSphere GLS.Collision

FastCheckSphereVsCube GLS.Collision

FastCheckSphereVsEllipsoid GLS.Collision

FastCheckSphereVsPoint GLS.Collision

FastCheckSphereVsSphere GLS.Collision

FileStreamExists GLS.ApplicationFileIO

Queries is a file stream corresponding to the fileName exists.
FillUniformAutoSetMethodList GLSL.ShaderParameter

FillUniformAutoSetMethodList GLSL.ShaderParameter

FindChunk Formats.m3DSUtils

FindChunkById Formats.LWO

ChunkFind procedures
FindClipByClipIndex Formats.LWO

FindCompatibleDataFormat GLScene.TextureFormat

Give compatible openGL image format and data type
FindCuFile GLS.CUDA.PropEditors

FindDDSCompatibleDataFormat Formats.DXTC

FindGLTextureImageClass GLS.Texture

Finds a registerer TGLTextureImageClass using its classname
FindGLTextureImageClassByFriendlyName GLS.Texture

Finds a registerer TGLTextureImageClass using its FriendlyName
FindManager GLScene.Manager

FindNamedObjectByIndex Formats.m3DSUtils

FindNextChunk Formats.m3DSUtils

FindRoot GLScene.Polynomials

Finds a root between min and max with a precision of epsilon. The evaluation of min/max must be of opposit sign
FindSurfaceByName Formats.LWO

FindSurfaceByTag Formats.LWO

FindUnitName GLScene.Utils

FindUnitName GLScene.Utils

FindVMapByName Formats.LWO

FindXCollectionItemClass GLScene.XCollection

Retrieves a registered TXCollectionItemClass from its classname
FixPathDelimiter GLScene.Utils

Replace path delimiter to delimiter of the current platform.
flip_blocks_dxtc1 Formats.DXTC

flip_blocks_dxtc3 Formats.DXTC

flip_blocks_dxtc5 Formats.DXTC

flip_dxt5_alpha Formats.DXTC

Float2rgbe GLScene.RGBE

FloatToHalf GLScene.Utils

FMOD_ErrorString FMOD.errors

Disable warning for unsafe types in Delphi 7
FMOD_Load FMOD.Import

If no library name is passed to FMOD_Load, then the default library name used. These are stub functions.
FMOD_Unload FMOD.Import

FMUSIC_FreeSong FMOD.Import

FMUSIC_GetBPM FMOD.Import

FMUSIC_GetGlobalVolume FMOD.Import

FMUSIC_GetMasterVolume FMOD.Import

FMUSIC_GetName FMOD.Import

Static song information functions.
FMUSIC_GetNumChannels FMOD.Import

FMUSIC_GetNumInstruments FMOD.Import

FMUSIC_GetNumOrders FMOD.Import

FMUSIC_GetNumPatterns FMOD.Import

FMUSIC_GetNumSamples FMOD.Import

FMUSIC_GetOpenState FMOD.Import

FMUSIC_GetOrder FMOD.Import

FMUSIC_GetPattern FMOD.Import

FMUSIC_GetPatternLength FMOD.Import

FMUSIC_GetPaused FMOD.Import

FMUSIC_GetRealChannel FMOD.Import

FMUSIC_GetRow FMOD.Import

FMUSIC_GetSample FMOD.Import

FMUSIC_GetSpeed FMOD.Import

FMUSIC_GetTime FMOD.Import

FMUSIC_GetType FMOD.Import

FMUSIC_GetUserData FMOD.Import

FMUSIC_IsFinished FMOD.Import

Runtime song information.
FMUSIC_IsPlaying FMOD.Import

FMUSIC_LoadSong FMOD.Import

Song management / playback functions.
FMUSIC_LoadSongEx FMOD.Import

FMUSIC_OptimizeChannels FMOD.Import

FMUSIC_PlaySong FMOD.Import

FMUSIC_SetInstCallback FMOD.Import

FMUSIC_SetLooping FMOD.Import

FMUSIC_SetMasterSpeed FMOD.Import

FMUSIC_SetMasterVolume FMOD.Import

FMUSIC_SetOrder FMOD.Import

FMUSIC_SetOrderCallback FMOD.Import

FMUSIC_SetPanSeperation FMOD.Import

FMUSIC_SetPaused FMOD.Import

FMUSIC_SetReverb FMOD.Import

Runtime song functions.
FMUSIC_SetRowCallback FMOD.Import

FMUSIC_SetSample FMOD.Import

FMUSIC_SetUserData FMOD.Import

FMUSIC_SetZxxCallback FMOD.Import

FMUSIC_StopAllSongs FMOD.Import

FMUSIC_StopSong FMOD.Import

FontManager GLS.SpaceText

FractalMiddlePointHDS GLS.RandomHDS

Fractal algorithm based on the middle-point displacement method. It is built in a way that it can be juxtaposed seamlessly to itself (cyclic boundaries)
FreeChunkData Formats.m3DSUtils

FromHex Formats.VFW

– Macro to get stream number out of a FOURCC ckid ————————–
FrustumContainsAABB GLScene.GeometryBB

Determines to which extent a frustum contains an AABB
FrustumContainsBSphere GLScene.GeometryBB

Determines to which extent a frustum contains a BSphere
FSOUND_3D_GetAttributes FMOD.Import

FSOUND_3D_GetMinMaxDistance FMOD.Import

FSOUND_3D_Listener_GetAttributes FMOD.Import

FSOUND_3D_Listener_SetAttributes FMOD.Import

FSOUND_3D_Listener_SetCurrent FMOD.Import

See also 3d sample and channel based functions above. Call FSOUND_Update once a frame to process 3d information.
FSOUND_3D_SetAttributes FMOD.Import

FSOUND_3D_SetDistanceFactor FMOD.Import

FSOUND_3D_SetDopplerFactor FMOD.Import

FSOUND_3D_SetMinMaxDistance FMOD.Import

FSOUND_3D_SetRolloffFactor FMOD.Import

FSOUND_CD_GetNumTracks FMOD.Import

FSOUND_CD_GetPaused FMOD.Import

FSOUND_CD_GetTrack FMOD.Import

FSOUND_CD_GetTrackLength FMOD.Import

FSOUND_CD_GetTrackTime FMOD.Import

FSOUND_CD_GetVolume FMOD.Import

FSOUND_CD_OpenTray FMOD.Import

FSOUND_CD_Play FMOD.Import

Note : 0 = default cdrom. Otherwise specify the drive letter, for example. 'D'.
FSOUND_CD_SetPaused FMOD.Import

FSOUND_CD_SetPlayMode FMOD.Import

FSOUND_CD_SetTrackTime FMOD.Import

FSOUND_CD_SetVolume FMOD.Import

FSOUND_CD_Stop FMOD.Import

FSOUND_Close FMOD.Import

FSOUND_DSP_ClearMixBuffer FMOD.Import

FSOUND_DSP_Create FMOD.Import

DSP Unit control and information functions.
FSOUND_DSP_Free FMOD.Import

FSOUND_DSP_GetActive FMOD.Import

FSOUND_DSP_GetBufferLength FMOD.Import

FSOUND_DSP_GetBufferLengthTotal FMOD.Import

Length of each DSP update
FSOUND_DSP_GetClearUnit FMOD.Import

Functions to get hold of FSOUND 'system DSP unit' handles.
FSOUND_DSP_GetClipAndCopyUnit FMOD.Import

FSOUND_DSP_GetFFTUnit FMOD.Import

FSOUND_DSP_GetMusicUnit FMOD.Import

FSOUND_DSP_GetPriority FMOD.Import

FSOUND_DSP_GetSFXUnit FMOD.Import

FSOUND_DSP_GetSpectrum FMOD.Import

Total buffer length due to FSOUND_SetBufferSize
FSOUND_DSP_MixBuffers FMOD.Import

Miscellaneous DSP functions Note for the spectrum analysis function to work, you have to enable the FFT DSP unit with the following code FSOUND_DSP_SetActive(FSOUND_DSP_GetFFTUnit(), TRUE); It is off by default to save cpu usage.
FSOUND_DSP_SetActive FMOD.Import

FSOUND_DSP_SetPriority FMOD.Import

FSOUND_File_SetCallbacks FMOD.Import

FSOUND_FX_Disable FMOD.Import

FSOUND_FX_Enable FMOD.Import

Functions to control DX8 only effects processing.

- FX enabled samples can only be played once at a time, not multiple times at once. - Sounds have to be created with FSOUND_HW2D or FSOUND_HW3D for this to work. - FSOUND_INIT_ENABLESYSTEMCHANNELFX can be used to apply hardware effect processing to the global mixed output of FMOD's software channels. - FSOUND_FX_Enable returns an FX handle that you can use to alter fx parameters. - FSOUND_FX_Enable can be called multiple times in a row, even on the same FX type, it will return a unique handle for each FX. - FSOUND_FX_Enable cannot be called if the sound is playing or locked. - FSOUND_FX_Disable must be called to reset/clear the FX from a channel.
FSOUND_FX_SetChorus FMOD.Import

FSOUND_FX_SetCompressor FMOD.Import

FSOUND_FX_SetDistortion FMOD.Import

FSOUND_FX_SetEcho FMOD.Import

FSOUND_FX_SetFlanger FMOD.Import

FSOUND_FX_SetGargle FMOD.Import

FSOUND_FX_SetI3DL2Reverb FMOD.Import

FSOUND_FX_SetParamEQ FMOD.Import

FSOUND_FX_SetWavesReverb FMOD.Import

FSOUND_GetAmplitude FMOD.Import

FSOUND_GetChannelsPlaying FMOD.Import

FSOUND_GetCPUUsage FMOD.Import

FSOUND_GetCurrentLevels FMOD.Import

FSOUND_GetCurrentPosition FMOD.Import

FSOUND_GetCurrentSample FMOD.Import

FSOUND_GetDriver FMOD.Import

FSOUND_GetDriverCaps FMOD.Import

FSOUND_GetDriverName FMOD.Import

FSOUND_GetError FMOD.Import

System information functions
FSOUND_GetFrequency FMOD.Import

FSOUND_GetLoopMode FMOD.Import

FSOUND_GetMaxChannels FMOD.Import

FSOUND_GetMaxSamples FMOD.Import

FSOUND_GetMemoryStats FMOD.Import

FSOUND_GetMixer FMOD.Import

FSOUND_GetMute FMOD.Import

FSOUND_GetNumDrivers FMOD.Import

FSOUND_GetNumHWChannels FMOD.Import

FSOUND_GetNumSubChannels FMOD.Import

FSOUND_GetOutput FMOD.Import

FSOUND_GetOutputHandle FMOD.Import

FSOUND_GetOutputRate FMOD.Import

FSOUND_GetPan FMOD.Import

FSOUND_GetPaused FMOD.Import

FSOUND_GetPriority FMOD.Import

FSOUND_GetReserved FMOD.Import

FSOUND_GetSFXMasterVolume FMOD.Import

function FSOUND_GetSpeakerMode: Integer; {$IFDEF UNIX} cdecl {$ELSE} stdcall {$ENDIF};
FSOUND_GetSubChannel FMOD.Import

FSOUND_GetSurround FMOD.Import

FSOUND_GetVersion FMOD.Import

FSOUND_GetVolume FMOD.Import

FSOUND_Init FMOD.Import

Main initialization / closedown functions. Note : Use FSOUND_INIT_USEDEFAULTMIDISYNTH with FSOUND_Init for software override with MIDI playback. : Use FSOUND_INIT_GLOBALFOCUS with FSOUND_Init to make sound audible no matter which window is in focus. (FSOUND_OUTPUT_DSOUND only)
FSOUND_IsPlaying FMOD.Import

Channel information functions
FSOUND_PlaySound FMOD.Import

Playing and stopping sounds. Note : Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you. Use FSOUND_ALL as the 'channel' variable to control ALL channels with one function call!
FSOUND_PlaySoundEx FMOD.Import

FSOUND_Record_GetDriver FMOD.Import

FSOUND_Record_GetDriverName FMOD.Import

FSOUND_Record_GetNumDrivers FMOD.Import

FSOUND_Record_GetPosition FMOD.Import

FSOUND_Record_SetDriver FMOD.Import

Recording initialization functions
FSOUND_Record_StartSample FMOD.Import

Recording functionality. Only one recording session will work at a time.
FSOUND_Record_Stop FMOD.Import

FSOUND_Reverb_GetChannelProperties FMOD.Import

FSOUND_Reverb_GetProperties FMOD.Import

FSOUND_Reverb_SetChannelProperties FMOD.Import

FSOUND_Reverb_SetProperties FMOD.Import

See structures above for definitions and information on the reverb parameters.
FSOUND_Sample_Alloc FMOD.Import

FSOUND_Sample_Free FMOD.Import

FSOUND_Sample_Get FMOD.Import

Sample information functions
FSOUND_Sample_GetDefaults FMOD.Import

FSOUND_Sample_GetDefaultsEx FMOD.Import

FSOUND_Sample_GetLength FMOD.Import

FSOUND_Sample_GetLoopPoints FMOD.Import

FSOUND_Sample_GetMinMaxDistance FMOD.Import

FSOUND_Sample_GetMode FMOD.Import

FSOUND_Sample_GetName FMOD.Import

FSOUND_Sample_Load FMOD.Import

Sample creation and management functions Note : Use FSOUND_LOADMEMORY flag with FSOUND_Sample_Load to load from memory. Use FSOUND_LOADRAW flag with FSOUND_Sample_Load to treat as as raw pcm data.
FSOUND_Sample_Lock FMOD.Import

FSOUND_Sample_SetDefaults FMOD.Import

FSOUND_Sample_SetDefaultsEx FMOD.Import

FSOUND_Sample_SetLoopPoints FMOD.Import

FSOUND_Sample_SetMaxPlaybacks FMOD.Import

FSOUND_Sample_SetMinMaxDistance FMOD.Import

FSOUND_Sample_SetMode FMOD.Import

Sample control functions
FSOUND_Sample_Unlock FMOD.Import

FSOUND_Sample_Upload FMOD.Import

FSOUND_SetBufferSize FMOD.Import

FSOUND_SetCurrentPosition FMOD.Import

FSOUND_SetDriver FMOD.Import

FSOUND_SetFrequency FMOD.Import

Functions to control playback of a channel. Note : FSOUND_ALL can be used on most of these functions as a channel value.
FSOUND_SetHWND FMOD.Import

FSOUND_SetLoopMode FMOD.Import

FSOUND_SetMaxHardwareChannels FMOD.Import

FSOUND_SetMemorySystem FMOD.Import

FSOUND_SetMinHardwareChannels FMOD.Import

FSOUND_SetMixer FMOD.Import

FSOUND_SetMute FMOD.Import

FSOUND_SetOutput FMOD.Import

PRE - FSOUND_Init functions. These can't be called after FSOUND_Init is called (they will fail). They set up FMOD system functionality.
FSOUND_SetPan FMOD.Import

FSOUND_SetPanSeperation FMOD.Import

FSOUND_SetPaused FMOD.Import

FSOUND_SetPriority FMOD.Import

FSOUND_SetReserved FMOD.Import

FSOUND_SetSFXMasterVolume FMOD.Import

FSOUND_SetSpeakerMode FMOD.Import

This is called to update 3d sound / non-realtime output
FSOUND_SetSurround FMOD.Import

FSOUND_SetVolume FMOD.Import

FSOUND_SetVolumeAbsolute FMOD.Import

FSOUND_StopSound FMOD.Import

FSOUND_Stream_AddSyncPoint FMOD.Import

FSOUND_Stream_Close FMOD.Import

FSOUND_Stream_Create FMOD.Import

FSOUND_Stream_CreateDSP FMOD.Import

FSOUND_Stream_DeleteSyncPoint FMOD.Import

FSOUND_Stream_FindTagField FMOD.Import

FSOUND_Stream_GetLength FMOD.Import

FSOUND_Stream_GetLengthMs FMOD.Import

FSOUND_Stream_GetMode FMOD.Import

FSOUND_Stream_GetNumSubStreams FMOD.Import

FSOUND_Stream_GetNumSyncPoints FMOD.Import

FSOUND_Stream_GetNumTagFields FMOD.Import

FSOUND_Stream_GetOpenState FMOD.Import

FSOUND_Stream_GetPosition FMOD.Import

FSOUND_Stream_GetSample FMOD.Import

FSOUND_Stream_GetSyncPoint FMOD.Import

FSOUND_Stream_GetSyncPointInfo FMOD.Import

FSOUND_Stream_GetTagField FMOD.Import

FSOUND_Stream_GetTime FMOD.Import

FSOUND_Stream_Net_GetBufferProperties FMOD.Import

FSOUND_Stream_Net_GetLastServerStatus FMOD.Import

FSOUND_Stream_Net_GetStatus FMOD.Import

FSOUND_Stream_Net_SetBufferProperties FMOD.Import

FSOUND_Stream_Net_SetMetadataCallback FMOD.Import

FSOUND_Stream_Net_SetProxy FMOD.Import

Internet streaming functions
FSOUND_Stream_Open FMOD.Import

FSOUND_Stream_Play FMOD.Import

FSOUND_Stream_PlayEx FMOD.Import

FSOUND_Stream_SetBufferSize FMOD.Import

Note : Use FSOUND_LOADMEMORY flag with FSOUND_Stream_Open to stream from memory. Use FSOUND_LOADRAW flag with FSOUND_Stream_Open to treat stream as raw pcm data. Use FSOUND_MPEGACCURATE flag with FSOUND_Stream_Open to open mpegs in 'accurate mode' for settime/gettime/getlengthms. Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you.
FSOUND_Stream_SetEndCallback FMOD.Import

FSOUND_Stream_SetLoopCount FMOD.Import

FSOUND_Stream_SetLoopPoints FMOD.Import

FSOUND_Stream_SetMode FMOD.Import

FSOUND_Stream_SetPosition FMOD.Import

FSOUND_Stream_SetSubStream FMOD.Import

FSOUND_Stream_SetSubStreamSentence FMOD.Import

FSOUND_Stream_SetSyncCallback FMOD.Import

FSOUND_Stream_SetTime FMOD.Import

FSOUND_Stream_Stop FMOD.Import

FSOUND_Update FMOD.Import

Runtime system level functions
G2_GetVertBoneIndex Formats.GL2

G2_GetVertBoneWeight Formats.GL2

G2_GetVertWeights Formats.GL2

GammaCorrectRGBArray GLS.Graphics

GenRandom GLScene.RandomLib

Used to call Random Number Generator. Remember to use Randomize if you don't want repeatable sequences.
GeometryOptimizationMode GLScene.VectorGeometry

Returns the detected optimization mode. Returned values is either 'FPU', '3DNow!' or 'SSE'
GetActiveLightsList GLSL.CustomShader

GetActor PhysX.Import

GetActorCMassGlobalPosition PhysX.Import

GetActorGlobalOrientation PhysX.Import

GetActorGlobalPosition PhysX.Import

GetActorMass PhysX.Import

GetAmbientLightMotion Formats.m3DSUtils

GetArchiveFileFormats GLS.ArchiveManager

getting a class of accessed archiver
GetArchiveManager GLS.ArchiveManager

Caution!!! Work for one archive manager only
GetAtmosphere Formats.m3DSUtils

functions to retrieve global settings of a specific 3DS database
GetBackground Formats.m3DSUtils

GetBestSelectorClass GLS.Selection

GetBodyFromGLSceneObject GLS.NGDManager

GetBodyFromGLSceneObject GLS.ODEManager

GetBodyFromObject GLS.ODEManager

Helper functions for extracting data from objects with different inheritance.
GetBodyPositionAsAffineVector GLS.ODEUtils

GetBoneParent GLS.NGDRagdoll

GetCameraByIndex Formats.m3DSUtils

GetCameraCount Formats.m3DSUtils

GetCameraMotion Formats.m3DSUtils

GetCameraMotionByIndex Formats.m3DSUtils

GetCameraNodeCount Formats.m3DSUtils

GetCameraNodeNameList Formats.m3DSUtils

GetChannelTypeAndNum GLS.CUDA.APIComps

GetChunkValue Formats.m3DSUtils

GetContentDir Formats.LWO

GetCurrentAssetPath GLScene.Utils

Get current path to assets from dir examples
GetCurrentColorDepth GLS.ImageUtils

Number of bits per pixel for the current desktop resolution.
GetCurrentLanguage gnugettext

GetCurrentRenderingObject GLS.Scene

getcurrenttextdomain gnugettext

GetDatabaseRelease Formats.m3DSUtils

GetDeviceLogicalPixelsX GLS.ImageUtils

Number of pixels per logical inch along the screen width for the device. Under Win32 awaits a HDC and returns its LOGPIXELSX.
GetElementAccessAddress CUDA.DataAccess

GetElementAccessSize CUDA.DataAccess

getenv GLS.SDL.Window

function putenv(const variable: PAnsiChar): integer;
GetFPSMovement GLS.FPSMovement

GetFPSMovement GLS.FPSMovement

GetGenericCompressedFormat GLScene.TextureFormat

Give generic compressed OpenGL texture format
GetGLRect GLScene.Utils

Rectangle as function
GetGLSceneObject GLS.ODEManager

GetGLSoundFileFormats GLS.SoundFileObjects

GetGLTextureImageClassesAsStrings GLS.Texture

Creates a TStrings with the list of registered TGLTextureImageClass. To be freed by caller.
GetImageLodNumber GLS.Graphics

Return an optimal number of texture pyramid
GetIndexFromResolution GLS.Screen

GetInertia GLS.Behaviours

Returns or creates the TGLBInertia within the given behaviours. This helper function is convenient way to access a TGLBInertia.
GetKfRelease Formats.m3DSUtils

GetKFSettings Formats.m3DSUtils

functions to retrieve/modify keyframer (animation) data
GetM3dMagicRelease Formats.m3DSUtils

version information
GetMaterialByIndex Formats.m3DSUtils

GetMaterialCount Formats.m3DSUtils

GetMatrixRec GLScene.VectorTypesExt

GetMeshByIndex Formats.m3DSUtils

GetMeshCount Formats.m3DSUtils

GetMeshRelease Formats.m3DSUtils

GetMeshSet Formats.m3DSUtils

GetModuleSymbol ModuleLoader

GetModuleSymbolEx ModuleLoader

GetMovement GLS.Movement

GetMovement GLS.Movement

GetNextIsoline GLS.Isolines

GetNGDDynamic GLS.NGDManager

GetNGDStatic GLS.NGDManager

Global function
GetObjectMotionByIndex Formats.m3DSUtils

GetObjectMotionByName Formats.m3DSUtils

GetObjectNodeCount Formats.m3DSUtils

GetObjectNodeNameList Formats.m3DSUtils

GetOdeDynamic GLS.ODEManager

GetODEHeightField GLS.ODEManager

Get and GetOrCreate functions for ODE HeightField
GetOdeStatic GLS.ODEManager

Get and GetOrCreate functions for ode behaviours
GetOmnilightByIndex Formats.m3DSUtils

GetOmnilightCount Formats.m3DSUtils

GetOmnilightMotionByIndex Formats.m3DSUtils

GetOmnilightMotionByName Formats.m3DSUtils

GetOmnilightNodeCount Formats.m3DSUtils

GetOmnilightNodeNameList Formats.m3DSUtils

GetOpenFileNamePreview Formats.VFW

GetOpenFileNamePreviewA Formats.VFW

== FilePreview dialog =======================================================
GetOpenFileNamePreviewW Formats.VFW

GetOrCreateAcceleration GLS.Behaviours

GetOrCreateAcceleration GLS.Behaviours

Returns or creates the TGLBAcceleration within the given behaviours. This helper function is convenient way to access a TGLBAcceleration.
GetOrCreateCollision GLS.Collision

Returns or creates the TGLBCollision within the given behaviours. This helper function is convenient way to access a TGLBCollision.
GetOrCreateCollision GLS.Collision

Returns or creates the TGLBCollision within the given object's behaviours. This helper function is convenient way to access a TGLBCollision.
GetOrCreateDCEDynamic GLS.DCE

GetOrCreateDCEDynamic GLS.DCE

GetOrCreateDCEStatic GLS.DCE

GetOrCreateDCEStatic GLS.DCE

GetOrCreateFireFX GLS.FireFX

Returns or creates the TGLBFireFX within the given behaviours. This helper function is convenient way to access a TGLBFireFX.
GetOrCreateFireFX GLS.FireFX

Returns or creates the TGLBFireFX within the given object's behaviours. This helper function is convenient way to access a TGLBFireFX.
GetOrCreateFPSMovement GLS.FPSMovement

GetOrCreateFPSMovement GLS.FPSMovement

GetOrCreateInertia GLS.Behaviours

GetOrCreateInertia GLS.Behaviours

GetOrCreateLibMaterial GLS.FileDDS

get or create material in material library
GetOrCreateMovement GLS.Movement

GetOrCreateMovement GLS.Movement

GetOrCreateNGDDynamic GLS.NGDManager

GetOrCreateNGDStatic GLS.NGDManager

GetOrCreateOdeDynamic GLS.ODEManager

GetOrCreateODEHeightField GLS.ODEManager

GetOrCreateOdeStatic GLS.ODEManager

GetOrCreateParticleInertia GLS.PhysInertias

Returns or creates the TGLParticleInertia within the given behaviours. This helper function is convenient way to access a TGLParticleInertia.
GetOrCreateParticleInertia GLS.PhysInertias

Returns or creates the TGLParticleInertia within the given object's behaviours. This helper function is convenient way to access a TGLParticleInertia.
GetOrCreateRigidBodyInertia GLS.PhysInertias

Returns or creates the TGLRigidBodyInertia within the given behaviours. This helper function is convenient way to access a TGLRigidBodyInertia.
GetOrCreateRigidBodyInertia GLS.PhysInertias

Returns or creates the TGLRigidBodyInertia within the given object's behaviours. This helper function is convenient way to access a TGLRigidBodyInertia.
GetOrCreateSoundEmitter GLS.SoundManager

GetOrCreateSoundEmitter GLS.SoundManager

GetOrCreateSourcePFX GLS.ParticleFX

Returns or creates the TGLBInertia within the given object's behaviours.
GetOrCreateThorFX GLS.ThorFX

Returns or creates the TGLBThorFX within the given object's effects.
GetProcAddressGLLib GLS.OpenGLAdapter

GetProcAddressGLS GLS.OpenGLAdapter

GetQuaternionRec GLScene.VectorTypesExt

GetRasterFileFormats GLS.Graphics

Read access to the list of registered vector file formats
GetResultsNx PhysX.Import

GetROAMTrianglesCapacity GLS.ROAMPatch

GetSafeTurnAngle GLScene.VectorGeometry

GetSafeTurnAngle GLScene.VectorGeometry

Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles
GetSaveFileNamePreview Formats.VFW

GetOpenFileNamePreviewA
GetSaveFileNamePreviewA Formats.VFW

GetSaveFileNamePreviewW Formats.VFW

GetServiceWindow GLS.Context

GetSoundLibraryByName GLS.SoundManager

GetSpotlightByIndex Formats.m3DSUtils

GetSpotlightCount Formats.m3DSUtils

GetSpotlightMotionByIndex Formats.m3DSUtils

GetSpotlightMotionByName Formats.m3DSUtils

GetSpotlightNodeCount Formats.m3DSUtils

GetSpotlightNodeNameList Formats.m3DSUtils

GetSqrt255Array GLScene.Utils

Returns a pointer to an array containing the results of "255*sqrt(i/255)".
GetSurfaceFromObject GLS.ODEManager

gettext gnugettext

GetTextureCombiners GLS.TextureCombiners

Parses a TC text description and setups combiners accordingly. *experimental* Knowledge of texture combiners is a requirement Syntax: pascal-like, one instruction per line, use '//' for comment.

Examples: Tex1:=Tex0; // replace texture 1 with texture 0 Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1

Accepted tokens: Tex0, Tex1, etc. : texture unit PrimaryColor, Col : the primary color ConstantColor, EnvCol : texture environment constant color

Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.
GetTextureElementSize GLScene.TextureFormat

GetTextureElementSize GLScene.TextureFormat

Give a pixel size in bytes from texture format or data format
gettext_NoExtract gnugettext

gettext_NoOp gnugettext

GetTranslatorNameAndEmail gnugettext

This returns an empty string if not translated or translator name is not specified.
GetUncompressedFormat GLScene.TextureFormat

Give uncompressed texture format and OpenGL color format
GetUniformAutoSetMethod GLSL.ShaderParameter

GetUniformAutoSetMethodName GLSL.ShaderParameter

GetValueFromStringsIndex GLScene.Utils

GetVectorFileFormats GLS.VectorFileObjects

Read access to the list of registered vector file formats
GetVectorRec GLScene.VectorTypesExt

GetViewport Formats.m3DSUtils

GetXCollectionClassesList GLScene.XCollection

GetXCollectionItemClassesList GLScene.XCollection

Creates and returns a copy of internal list of TXCollectionItem classes. Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.
Get_CUDA_API_Error_String CUDA.Import

Get_CUDA_FFT_Error_String CUDA.FourierTransform

glAccum GLScene.OpenGL4

GL functions and procedures
glAlphaFunc GLScene.OpenGL4

deprecated;
glAreTexturesResident GLScene.OpenGL4

deprecated;
glArrayElement GLScene.OpenGL4

deprecated;
glBegin GLScene.OpenGL4

deprecated;
glBindTexture GLScene.OpenGL4

deprecated;
glBitmap GLScene.OpenGL4

glBlendFunc GLScene.OpenGL4

deprecated;
glCallList GLScene.OpenGL4

glCallLists GLScene.OpenGL4

deprecated;
glClear GLScene.OpenGL4

deprecated;
glClearAccum GLScene.OpenGL4

glClearColor GLScene.OpenGL4

deprecated;
glClearDepth GLScene.OpenGL4

glClearIndex GLScene.OpenGL4

glClearStencil GLScene.OpenGL4

deprecated;
glClipPlane GLScene.OpenGL4

glColor3b GLScene.OpenGL4

deprecated;
glColor3bv GLScene.OpenGL4

deprecated;
glColor3d GLScene.OpenGL4

deprecated;
glColor3dv GLScene.OpenGL4

deprecated;
glColor3f GLScene.OpenGL4

deprecated;
glColor3fv GLScene.OpenGL4

deprecated;
glColor3i GLScene.OpenGL4

deprecated;
glColor3iv GLScene.OpenGL4

deprecated;
glColor3s GLScene.OpenGL4

deprecated;
glColor3sv GLScene.OpenGL4

deprecated;
glColor3ub GLScene.OpenGL4

deprecated;
glColor3ubv GLScene.OpenGL4

deprecated;
glColor3ui GLScene.OpenGL4

deprecated;
glColor3uiv GLScene.OpenGL4

deprecated;
glColor3us GLScene.OpenGL4

deprecated;
glColor3usv GLScene.OpenGL4

deprecated;
glColor4b GLScene.OpenGL4

deprecated;
glColor4bv GLScene.OpenGL4

deprecated;
glColor4d GLScene.OpenGL4

deprecated;
glColor4dv GLScene.OpenGL4

deprecated;
glColor4f GLScene.OpenGL4

deprecated;
glColor4fv GLScene.OpenGL4

deprecated;
glColor4i GLScene.OpenGL4

deprecated;
glColor4iv GLScene.OpenGL4

deprecated;
glColor4s GLScene.OpenGL4

deprecated;
glColor4sv GLScene.OpenGL4

deprecated;
glColor4ub GLScene.OpenGL4

deprecated;
glColor4ubv GLScene.OpenGL4

deprecated;
glColor4ui GLScene.OpenGL4

deprecated;
glColor4uiv GLScene.OpenGL4

deprecated;
glColor4us GLScene.OpenGL4

deprecated;
glColor4usv GLScene.OpenGL4

deprecated;
glColorMask GLScene.OpenGL4

deprecated;
glColorMaterial GLScene.OpenGL4

glColorPointer GLScene.OpenGL4

deprecated;
glCopyPixels GLScene.OpenGL4

deprecated;
glCopyTexImage1D GLScene.OpenGL4

deprecated;
glCopyTexImage2D GLScene.OpenGL4

glCopyTexSubImage1D GLScene.OpenGL4

glCopyTexSubImage2D GLScene.OpenGL4

GLCUDAEditorForm FmCUDAEditor

glCullFace GLScene.OpenGL4

glDeleteLists GLScene.OpenGL4

glDeleteTextures GLScene.OpenGL4

deprecated;
glDepthFunc GLScene.OpenGL4

glDepthMask GLScene.OpenGL4

glDepthRange GLScene.OpenGL4

GLDirectionFromGeom GLS.ODEUtils

glDisable GLScene.OpenGL4

glDisableClientState GLScene.OpenGL4

glDrawArrays GLScene.OpenGL4

deprecated;
glDrawBuffer GLScene.OpenGL4

glDrawElements GLScene.OpenGL4

glDrawPixels GLScene.OpenGL4

glEdgeFlag GLScene.OpenGL4

deprecated;
glEdgeFlagPointer GLScene.OpenGL4

deprecated;
glEdgeFlagv GLScene.OpenGL4

deprecated;
glEnable GLScene.OpenGL4

deprecated;
glEnableClientState GLScene.OpenGL4

glEnd GLScene.OpenGL4

deprecated;
glEndList GLScene.OpenGL4

deprecated;
GLEnumToDDSHeader Formats.DXTC

glEvalCoord1d GLScene.OpenGL4

deprecated;
glEvalCoord1dv GLScene.OpenGL4

deprecated;
glEvalCoord1f GLScene.OpenGL4

deprecated;
glEvalCoord1fv GLScene.OpenGL4

deprecated;
glEvalCoord2d GLScene.OpenGL4

deprecated;
glEvalCoord2dv GLScene.OpenGL4

deprecated;
glEvalCoord2f GLScene.OpenGL4

deprecated;
glEvalCoord2fv GLScene.OpenGL4

deprecated;
glEvalMesh1 GLScene.OpenGL4

deprecated;
glEvalMesh2 GLScene.OpenGL4

deprecated;
glEvalPoint1 GLScene.OpenGL4

deprecated;
glEvalPoint2 GLScene.OpenGL4

deprecated;
glFeedbackBuffer GLScene.OpenGL4

deprecated;
glFinish GLScene.OpenGL4

deprecated;
glFlush GLScene.OpenGL4

glFogf GLScene.OpenGL4

glFogfv GLScene.OpenGL4

deprecated;
glFogi GLScene.OpenGL4

deprecated;
glFogiv GLScene.OpenGL4

deprecated;
glFrontFace GLScene.OpenGL4

deprecated;
glFrustum GLScene.OpenGL4

glGenLists GLScene.OpenGL4

deprecated;
glGenTextures GLScene.OpenGL4

deprecated;
glGetBooleanv GLScene.OpenGL4

glGetClipPlane GLScene.OpenGL4

GLGetCursorPos GLS.Screen

glGetDoublev GLScene.OpenGL4

deprecated;
glGetError GLScene.OpenGL4

glGetFloatv GLScene.OpenGL4

glGetIntegerv GLScene.OpenGL4

glGetLightfv GLScene.OpenGL4

glGetLightiv GLScene.OpenGL4

deprecated;
glGetMapdv GLScene.OpenGL4

deprecated;
glGetMapfv GLScene.OpenGL4

deprecated;
glGetMapiv GLScene.OpenGL4

deprecated;
glGetMaterialfv GLScene.OpenGL4

deprecated;
glGetMaterialiv GLScene.OpenGL4

deprecated;
glGetPixelMapfv GLScene.OpenGL4

deprecated;
glGetPixelMapuiv GLScene.OpenGL4

deprecated;
glGetPixelMapusv GLScene.OpenGL4

deprecated;
glGetPointerv GLScene.OpenGL4

deprecated;
glGetPolygonStipple GLScene.OpenGL4

GLGetProcAddress GLScene.OpenGL4

——————————————————————————
GLGetScreenHeight GLS.Screen

GLGetScreenWidth GLS.Screen

glGetString GLScene.OpenGL4

deprecated;
glGetTexEnvfv GLScene.OpenGL4

glGetTexEnviv GLScene.OpenGL4

deprecated;
glGetTexGendv GLScene.OpenGL4

deprecated;
glGetTexGenfv GLScene.OpenGL4

deprecated;
glGetTexGeniv GLScene.OpenGL4

deprecated;
glGetTexImage GLScene.OpenGL4

deprecated;
glGetTexLevelParameterfv GLScene.OpenGL4

glGetTexLevelParameteriv GLScene.OpenGL4

glGetTexParameterfv GLScene.OpenGL4

glGetTexParameteriv GLScene.OpenGL4

glHint GLScene.OpenGL4

glIndexd GLScene.OpenGL4

deprecated;
glIndexdv GLScene.OpenGL4

deprecated;
glIndexf GLScene.OpenGL4

deprecated;
glIndexfv GLScene.OpenGL4

deprecated;
glIndexi GLScene.OpenGL4

deprecated;
glIndexiv GLScene.OpenGL4

deprecated;
glIndexMask GLScene.OpenGL4

glIndexPointer GLScene.OpenGL4

deprecated;
glIndexs GLScene.OpenGL4

deprecated;
glIndexsv GLScene.OpenGL4

deprecated;
glIndexub GLScene.OpenGL4

deprecated;
glIndexubv GLScene.OpenGL4

deprecated;
glInitNames GLScene.OpenGL4

deprecated;
glInterleavedArrays GLScene.OpenGL4

deprecated;
glIsEnabled GLScene.OpenGL4

deprecated;
glIsList GLScene.OpenGL4

glIsTexture GLScene.OpenGL4

GLLibMaterialPickerForm FmLibMaterialPicker

For registration in GLScene
glLightf GLScene.OpenGL4

deprecated;
glLightfv GLScene.OpenGL4

deprecated;
glLighti GLScene.OpenGL4

deprecated;
glLightiv GLScene.OpenGL4

deprecated;
glLightModelf GLScene.OpenGL4

glLightModelfv GLScene.OpenGL4

deprecated;
glLightModeli GLScene.OpenGL4

deprecated;
glLightModeliv GLScene.OpenGL4

deprecated;
glLineStipple GLScene.OpenGL4

deprecated;
glLineWidth GLScene.OpenGL4

deprecated;
glListBase GLScene.OpenGL4

GLLoadBitmapFromInstance GLS.ImageUtils

glLoadIdentity GLScene.OpenGL4

deprecated;
glLoadMatrixd GLScene.OpenGL4

deprecated;
glLoadMatrixf GLScene.OpenGL4

deprecated;
glLoadName GLScene.OpenGL4

deprecated;
glLogicOp GLScene.OpenGL4

deprecated;
glMap1d GLScene.OpenGL4

glMap1f GLScene.OpenGL4

deprecated;
glMap2d GLScene.OpenGL4

deprecated;
glMap2f GLScene.OpenGL4

deprecated;
glMapGrid1d GLScene.OpenGL4

deprecated;
glMapGrid1f GLScene.OpenGL4

deprecated;
glMapGrid2d GLScene.OpenGL4

deprecated;
glMapGrid2f GLScene.OpenGL4

deprecated;
GLMaterialEditorForm FmMaterialEditor

glMaterialf GLScene.OpenGL4

deprecated;
glMaterialfv GLScene.OpenGL4

deprecated;
glMateriali GLScene.OpenGL4

deprecated;
glMaterialiv GLScene.OpenGL4

deprecated;
GLMatrixFromGeom GLS.ODEUtils

glMatrixMode GLScene.OpenGL4

deprecated;
glMultMatrixd GLScene.OpenGL4

deprecated;
glMultMatrixf GLScene.OpenGL4

deprecated;
glNewList GLScene.OpenGL4

deprecated;
glNormal3b GLScene.OpenGL4

deprecated;
glNormal3bv GLScene.OpenGL4

deprecated;
glNormal3d GLScene.OpenGL4

deprecated;
glNormal3dv GLScene.OpenGL4

deprecated;
glNormal3f GLScene.OpenGL4

deprecated;
glNormal3fv GLScene.OpenGL4

deprecated;
glNormal3i GLScene.OpenGL4

deprecated;
glNormal3iv GLScene.OpenGL4

deprecated;
glNormal3s GLScene.OpenGL4

deprecated;
glNormal3sv GLScene.OpenGL4

deprecated;
glNormalPointer GLScene.OpenGL4

deprecated;
GLOKMessageBox GLS.ImageUtils

Returns the number of CPU cycles since startup. Use the similarly named CPU instruction.
glOrtho GLScene.OpenGL4

deprecated;
glPassThrough GLScene.OpenGL4

deprecated;
glPixelMapfv GLScene.OpenGL4

deprecated;
glPixelMapuiv GLScene.OpenGL4

deprecated;
glPixelMapusv GLScene.OpenGL4

deprecated;
glPixelStoref GLScene.OpenGL4

deprecated;
glPixelStorei GLScene.OpenGL4

glPixelTransferf GLScene.OpenGL4

glPixelTransferi GLScene.OpenGL4

deprecated;
glPixelZoom GLScene.OpenGL4

deprecated;
glPointSize GLScene.OpenGL4

deprecated;
glPolygonMode GLScene.OpenGL4

glPolygonOffset GLScene.OpenGL4

glPolygonStipple GLScene.OpenGL4

glPopAttrib GLScene.OpenGL4

deprecated;
glPopClientAttrib GLScene.OpenGL4

deprecated;
glPopMatrix GLScene.OpenGL4

deprecated;
glPopName GLScene.OpenGL4

deprecated;
glPrioritizeTextures GLScene.OpenGL4

deprecated;
glPushAttrib GLScene.OpenGL4

deprecated;
glPushClientAttrib GLScene.OpenGL4

deprecated;
glPushMatrix GLScene.OpenGL4

deprecated;
glPushName GLScene.OpenGL4

deprecated;
glRasterPos2d GLScene.OpenGL4

deprecated;
glRasterPos2dv GLScene.OpenGL4

deprecated;
glRasterPos2f GLScene.OpenGL4

deprecated;
glRasterPos2fv GLScene.OpenGL4

deprecated;
glRasterPos2i GLScene.OpenGL4

deprecated;
glRasterPos2iv GLScene.OpenGL4

deprecated;
glRasterPos2s GLScene.OpenGL4

deprecated;
glRasterPos2sv GLScene.OpenGL4

deprecated;
glRasterPos3d GLScene.OpenGL4

deprecated;
glRasterPos3dv GLScene.OpenGL4

deprecated;
glRasterPos3f GLScene.OpenGL4

deprecated;
glRasterPos3fv GLScene.OpenGL4

deprecated;
glRasterPos3i GLScene.OpenGL4

deprecated;
glRasterPos3iv GLScene.OpenGL4

deprecated;
glRasterPos3s GLScene.OpenGL4

deprecated;
glRasterPos3sv GLScene.OpenGL4

deprecated;
glRasterPos4d GLScene.OpenGL4

deprecated;
glRasterPos4dv GLScene.OpenGL4

deprecated;
glRasterPos4f GLScene.OpenGL4

deprecated;
glRasterPos4fv GLScene.OpenGL4

deprecated;
glRasterPos4i GLScene.OpenGL4

deprecated;
glRasterPos4iv GLScene.OpenGL4

deprecated;
glRasterPos4s GLScene.OpenGL4

deprecated;
glRasterPos4sv GLScene.OpenGL4

deprecated;
glReadBuffer GLScene.OpenGL4

deprecated;
glReadPixels GLScene.OpenGL4

glRectd GLScene.OpenGL4

glRectdv GLScene.OpenGL4

deprecated;
glRectf GLScene.OpenGL4

deprecated;
glRectfv GLScene.OpenGL4

deprecated;
glRecti GLScene.OpenGL4

deprecated;
glRectiv GLScene.OpenGL4

deprecated;
glRects GLScene.OpenGL4

deprecated;
glRectsv GLScene.OpenGL4

deprecated;
glRenderMode GLScene.OpenGL4

deprecated;
glRotated GLScene.OpenGL4

glRotatef GLScene.OpenGL4

deprecated;
glScaled GLScene.OpenGL4

deprecated;
glScalef GLScene.OpenGL4

deprecated;
GLSceneEditorForm FmSceneEditor

GLSceneMatrixToODER GLS.ODEUtils

glScissor GLScene.OpenGL4

deprecated;
glSelectBuffer GLScene.OpenGL4

GLSetCursorPos GLS.Screen

glShadeModel GLScene.OpenGL4

deprecated;
GLShaderEditorForm FmShaderMemo

GLShaderUniformEditor FmShaderUniformEditor

GLShowCursor GLS.Screen

GLSLogger GLScene.Logger

Inner logger. Converted to a function, because in case of a DLL and main app using this module, log is written to the same file on initialization and finalization, which is not what one might want. This also allows to create a GLSLogger with custom parameters for user's application, for example a different log path (Often the EXE application directory is read-only).
GLSLTypeComponentCount GLSL.ShaderParameter

GLSLTypeEnum GLSL.ShaderParameter

glStencilFunc GLScene.OpenGL4

deprecated;
glStencilMask GLScene.OpenGL4

glStencilOp GLScene.OpenGL4

GLStrToFloatDef GLScene.Utils

GLStrToFloatDef GLScene.Utils

GLStrToFloatDef GLScene.Utils

Added by PAL to fix problem with decimal separator in not En-US configurations Decimal separator in text descriptions of meshes for import/export is always '.' char But in System.SysUtils.TextToFloat is Windows char, maybe ',' or others...
glTexCoord1d GLScene.OpenGL4

glTexCoord1dv GLScene.OpenGL4

deprecated;
glTexCoord1f GLScene.OpenGL4

deprecated;
glTexCoord1fv GLScene.OpenGL4

deprecated;
glTexCoord1i GLScene.OpenGL4

deprecated;
glTexCoord1iv GLScene.OpenGL4

deprecated;
glTexCoord1s GLScene.OpenGL4

deprecated;
glTexCoord1sv GLScene.OpenGL4

deprecated;
glTexCoord2d GLScene.OpenGL4

deprecated;
glTexCoord2dv GLScene.OpenGL4

deprecated;
glTexCoord2f GLScene.OpenGL4

deprecated;
glTexCoord2fv GLScene.OpenGL4

deprecated;
glTexCoord2i GLScene.OpenGL4

deprecated;
glTexCoord2iv GLScene.OpenGL4

deprecated;
glTexCoord2s GLScene.OpenGL4

deprecated;
glTexCoord2sv GLScene.OpenGL4

deprecated;
glTexCoord3d GLScene.OpenGL4

deprecated;
glTexCoord3dv GLScene.OpenGL4

deprecated;
glTexCoord3f GLScene.OpenGL4

deprecated;
glTexCoord3fv GLScene.OpenGL4

deprecated;
glTexCoord3i GLScene.OpenGL4

deprecated;
glTexCoord3iv GLScene.OpenGL4

deprecated;
glTexCoord3s GLScene.OpenGL4

deprecated;
glTexCoord3sv GLScene.OpenGL4

deprecated;
glTexCoord4d GLScene.OpenGL4

deprecated;
glTexCoord4dv GLScene.OpenGL4

deprecated;
glTexCoord4f GLScene.OpenGL4

deprecated;
glTexCoord4fv GLScene.OpenGL4

deprecated;
glTexCoord4i GLScene.OpenGL4

deprecated;
glTexCoord4iv GLScene.OpenGL4

deprecated;
glTexCoord4s GLScene.OpenGL4

deprecated;
glTexCoord4sv GLScene.OpenGL4

deprecated;
glTexCoordPointer GLScene.OpenGL4

deprecated;
glTexEnvf GLScene.OpenGL4

deprecated;
glTexEnvfv GLScene.OpenGL4

deprecated;
glTexEnvi GLScene.OpenGL4

deprecated;
glTexEnviv GLScene.OpenGL4

deprecated;
glTexGend GLScene.OpenGL4

deprecated;
glTexGendv GLScene.OpenGL4

deprecated;
glTexGenf GLScene.OpenGL4

deprecated;
glTexGenfv GLScene.OpenGL4

deprecated;
glTexGeni GLScene.OpenGL4

deprecated;
glTexGeniv GLScene.OpenGL4

deprecated;
glTexImage1D GLScene.OpenGL4

deprecated;
glTexImage2D GLScene.OpenGL4

glTexParameterf GLScene.OpenGL4

glTexParameterfv GLScene.OpenGL4

glTexParameteri GLScene.OpenGL4

glTexParameteriv GLScene.OpenGL4

glTexSubImage1D GLScene.OpenGL4

glTexSubImage2D GLScene.OpenGL4

glTranslated GLScene.OpenGL4

glTranslatef GLScene.OpenGL4

deprecated;
gluBeginCurve GLS.OpenGLAdapter

gluBeginCurve GLScene.OpenGL4

gluBeginPolygon GLS.OpenGLAdapter

gluBeginPolygon GLScene.OpenGL4

gluBeginSurface GLS.OpenGLAdapter

gluBeginSurface GLScene.OpenGL4

gluBeginTrim GLS.OpenGLAdapter

gluBeginTrim GLScene.OpenGL4

gluBuild1DMipmaps GLS.OpenGLAdapter

gluBuild1DMipmaps GLScene.OpenGL4

gluBuild2DMipmaps GLS.OpenGLAdapter

gluBuild2DMipmaps GLScene.OpenGL4

gluCylinder GLS.OpenGLAdapter

gluCylinder GLScene.OpenGL4

gluDeleteNurbsRenderer GLS.OpenGLAdapter

gluDeleteNurbsRenderer GLScene.OpenGL4

gluDeleteQuadric GLS.OpenGLAdapter

gluDeleteQuadric GLScene.OpenGL4

gluDeleteTess GLS.OpenGLAdapter

gluDeleteTess GLScene.OpenGL4

gluDisk GLS.OpenGLAdapter

gluDisk GLScene.OpenGL4

gluEndCurve GLS.OpenGLAdapter

gluEndCurve GLScene.OpenGL4

gluEndPolygon GLS.OpenGLAdapter

gluEndPolygon GLScene.OpenGL4

gluEndSurface GLS.OpenGLAdapter

gluEndSurface GLScene.OpenGL4

gluEndTrim GLS.OpenGLAdapter

gluEndTrim GLScene.OpenGL4

gluErrorString GLS.OpenGLAdapter

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32; function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 Name 'wglUseFontBitmapsA'; function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 Name 'wglUseFontOutlinesA';
gluErrorString GLScene.OpenGL4

GLU utility functions and procedures
gluGetNurbsProperty GLS.OpenGLAdapter

gluGetNurbsProperty GLScene.OpenGL4

gluGetString GLS.OpenGLAdapter

gluGetString GLScene.OpenGL4

gluGetTessProperty GLS.OpenGLAdapter

gluGetTessProperty GLScene.OpenGL4

gluLoadSamplingMatrices GLS.OpenGLAdapter

gluLoadSamplingMatrices GLScene.OpenGL4

gluLookAt GLS.OpenGLAdapter

gluLookAt GLScene.OpenGL4

gluNewNurbsRenderer GLS.OpenGLAdapter

gluNewNurbsRenderer GLScene.OpenGL4

gluNewQuadric GLS.OpenGLAdapter

gluNewQuadric GLScene.OpenGL4

gluNewTess GLS.OpenGLAdapter

gluNewTess GLScene.OpenGL4

gluNextContour GLS.OpenGLAdapter

gluNextContour GLScene.OpenGL4

gluNurbsCallback GLS.OpenGLAdapter

gluNurbsCallback GLScene.OpenGL4

gluNurbsCurve GLS.OpenGLAdapter

gluNurbsCurve GLScene.OpenGL4

gluNurbsProperty GLS.OpenGLAdapter

gluNurbsProperty GLScene.OpenGL4

gluNurbsSurface GLS.OpenGLAdapter

gluNurbsSurface GLScene.OpenGL4

gluOrtho2D GLS.OpenGLAdapter

gluOrtho2D GLScene.OpenGL4

gluPartialDisk GLS.OpenGLAdapter

gluPartialDisk GLScene.OpenGL4

gluPerspective GLS.OpenGLAdapter

gluPerspective GLScene.OpenGL4

gluPickMatrix GLS.OpenGLAdapter

gluPickMatrix GLScene.OpenGL4

gluProject GLS.OpenGLAdapter

gluProject GLScene.OpenGL4

gluPwlCurve GLS.OpenGLAdapter

gluPwlCurve GLScene.OpenGL4

gluQuadricCallback GLS.OpenGLAdapter

gluQuadricCallback GLScene.OpenGL4

gluQuadricDrawStyle GLS.OpenGLAdapter

gluQuadricDrawStyle GLScene.OpenGL4

gluQuadricNormals GLS.OpenGLAdapter

gluQuadricNormals GLScene.OpenGL4

gluQuadricOrientation GLS.OpenGLAdapter

gluQuadricOrientation GLScene.OpenGL4

gluQuadricTexture GLS.OpenGLAdapter

gluQuadricTexture GLScene.OpenGL4

gluScaleImage GLS.OpenGLAdapter

gluScaleImage GLScene.OpenGL4

gluSphere GLS.OpenGLAdapter

gluSphere GLScene.OpenGL4

gluTessBeginContour GLS.OpenGLAdapter

gluTessBeginContour GLScene.OpenGL4

gluTessBeginPolygon GLS.OpenGLAdapter

gluTessBeginPolygon GLScene.OpenGL4

gluTessCallback GLS.OpenGLAdapter

gluTessCallback GLScene.OpenGL4

gluTessEndContour GLS.OpenGLAdapter

gluTessEndContour GLScene.OpenGL4

gluTessEndPolygon GLS.OpenGLAdapter

gluTessEndPolygon GLScene.OpenGL4

gluTessNormal GLS.OpenGLAdapter

gluTessNormal GLScene.OpenGL4

gluTessProperty GLS.OpenGLAdapter

gluTessProperty GLScene.OpenGL4

gluTessVertex GLS.OpenGLAdapter

gluTessVertex GLScene.OpenGL4

gluUnProject GLS.OpenGLAdapter

gluUnProject GLScene.OpenGL4

GLVectorEditorForm FmVectorEditor

glVertex2d GLScene.OpenGL4

deprecated;
glVertex2dv GLScene.OpenGL4

deprecated;
glVertex2f GLScene.OpenGL4

deprecated;
glVertex2fv GLScene.OpenGL4

deprecated;
glVertex2i GLScene.OpenGL4

deprecated;
glVertex2iv GLScene.OpenGL4

deprecated;
glVertex2s GLScene.OpenGL4

deprecated;
glVertex2sv GLScene.OpenGL4

deprecated;
glVertex3d GLScene.OpenGL4

deprecated;
glVertex3dv GLScene.OpenGL4

deprecated;
glVertex3f GLScene.OpenGL4

deprecated;
glVertex3fv GLScene.OpenGL4

deprecated;
glVertex3i GLScene.OpenGL4

deprecated;
glVertex3iv GLScene.OpenGL4

deprecated;
glVertex3s GLScene.OpenGL4

deprecated;
glVertex3sv GLScene.OpenGL4

deprecated;
glVertex4d GLScene.OpenGL4

deprecated;
glVertex4dv GLScene.OpenGL4

deprecated;
glVertex4f GLScene.OpenGL4

deprecated;
glVertex4fv GLScene.OpenGL4

deprecated;
glVertex4i GLScene.OpenGL4

deprecated;
glVertex4iv GLScene.OpenGL4

deprecated;
glVertex4s GLScene.OpenGL4

deprecated;
glVertex4sv GLScene.OpenGL4

deprecated;
glVertexPointer GLScene.OpenGL4

deprecated;
glViewport GLScene.OpenGL4

deprecated;
GMTDateTimeToJulianDay GLS.SkyDome

average earth radius in kilometers Converts a TDateTime (GMT+0) into the Julian day used for computations.
GraphicClassForExtension GLS.Graphics

Returns the TGraphicClass associated to the extension, if any. Accepts anExtension with or without the '.'
GUIComponentDialog FmGuiSkinEditor

GUILayoutEditorForm FmGuiLayoutEditor

HackTPictureRegisteredFormats GLS.Graphics

Adds to the passed TStrings the list of registered formats. Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').
HalfToFloat GLScene.Utils

HookIntoResourceStrings gnugettext

ICAbout Formats.VFW

ICClose Formats.VFW

ICCompress Formats.VFW

***********************************************************************

compression functions

************************************************************************/ /* * ICCompress() * * compress a single frame *
ICCompressBegin Formats.VFW

* ICCompressBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOuput) is supported. *
ICCompressEnd Formats.VFW

ICCompressGetFormat Formats.VFW

* ICCompressGetFormat() * * get the output format, (format of compressed data) * if lpbiOutput is NULL return the size in bytes needed for format. *
ICCompressGetFormatSize Formats.VFW

ICCompressGetSize Formats.VFW

* ICCompressSize() * * return the maximal size of a compressed frame *
ICCompressorChoose Formats.VFW

COMPVARS contains valid data

allows user to choose compressor, quality etc...
ICCompressorFree Formats.VFW

ICCompressQuery Formats.VFW

* ICCompressQuery() * * determines if compression from a source format (lpbiInput) to a dest * format (lpbiOuput) is supported. *
ICConfigure Formats.VFW

ICDecompress Formats.VFW

* ICDecompress() * * decompress a single frame *
ICDecompressBegin Formats.VFW

* ICDecompressBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *
ICDecompressEnd Formats.VFW

ICDecompressEx Formats.VFW

* ICDecompressEx() * * decompress a single frame *
ICDecompressExBegin Formats.VFW

* ICDecompressExBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *
ICDecompressExEnd Formats.VFW

ICDecompressExQuery Formats.VFW

* ICDecompressExQuery() *
ICDecompressGetFormat Formats.VFW

* ICDecompressGetFormat() * * get the output format, (format of un-compressed data) * if lpbiOutput is NULL return the size in bytes needed for format. *
ICDecompressGetFormatSize Formats.VFW

ICDecompressGetPalette Formats.VFW

* ICDecompressGetPalette() * * get the output palette *
ICDecompressOpen Formats.VFW

ICDecompressQuery Formats.VFW

* ICDecompressQuery() * * determines if compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *
ICDecompressSetPalette Formats.VFW

ICDraw Formats.VFW

* ICDraw() * * decompress data directly to the screen *
ICDrawBegin Formats.VFW

* ICDrawBegin() * * start decompressing data with format (lpbiInput) directly to the screen * * return zero if the decompressor supports drawing. *
ICDrawChangePalette Formats.VFW

ICDrawEnd Formats.VFW

ICDrawFlush Formats.VFW

ICDrawGetTime Formats.VFW

ICDrawOpen Formats.VFW

ICDrawQuery Formats.VFW

* ICDrawQuery() * * determines if the compressor is willing to render the specified format. *
ICDrawRealize Formats.VFW

ICDrawRenderBuffer Formats.VFW

ICDrawSetTime Formats.VFW

ICDrawStart Formats.VFW

ICDrawStartPlay Formats.VFW

ICDrawStop Formats.VFW

ICDrawStopPlay Formats.VFW

ICDrawSuggestFormat Formats.VFW

ICMessage is not supported on Win32, so provide a static inline function to do the same job
ICDrawWindow Formats.VFW

– Draw window macro ——————————————————–
ICGetBuffersWanted Formats.VFW

ICGetDefaultKeyFrameRate Formats.VFW

ICGetDefaultQuality Formats.VFW

– Get value macros ———————————————————
ICGetDisplayFormat Formats.VFW

ICGetInfo Formats.VFW

ICGetState Formats.VFW

– Get/Set state macros —————————————————–
ICGetStateSize Formats.VFW

ICImageCompress Formats.VFW

*********************************************************************** Higher level functions ***********************************************************************
ICImageDecompress Formats.VFW

ICInfo Formats.VFW

***********************************************************************

ICM function declarations

***********************************************************************
ICInstall Formats.VFW

ICLocate Formats.VFW

***********************************************************************

helper routines for DrawDib and MCIAVI...

***********************************************************************
ICOpen Formats.VFW

ICOpenFunction Formats.VFW

ICQueryAbout Formats.VFW

ICQueryConfigure Formats.VFW

ICRemove Formats.VFW

ICSendMessage Formats.VFW

ICSeqCompressFrame Formats.VFW

ICSeqCompressFrameEnd Formats.VFW

ICSeqCompressFrameStart Formats.VFW

don't only show those that can handle the input format or input data
ICSetState Formats.VFW

ICSetStatusProc Formats.VFW

ICMessage is not supported on NT
ID4ToInt Formats.LWO

ILength GLScene.VectorGeometry

ILength GLScene.VectorGeometry

Computes an integer length Result:=Sqrt(x*x+y*y)
ImageAlphaBottomRightPointColorTransparent GLS.ImageUtils

ImageAlphaFromIntensity GLS.ImageUtils

ImageAlphaInverseLuminance GLS.ImageUtils

ImageAlphaInverseLuminanceSqrt GLS.ImageUtils

ImageAlphaLuminance GLS.ImageUtils

ImageAlphaLuminanceSqrt GLS.ImageUtils

ImageAlphaOpaque GLS.ImageUtils

ImageAlphaSuperBlackTransparent GLS.ImageUtils

ImageAlphaTopLeftPointColorTransparent GLS.ImageUtils

ImageBellFilter GLS.ImageUtils

ImageBoxFilter GLS.ImageUtils

ImageHermiteFilter GLS.ImageUtils

ImageLanczos3Filter GLS.ImageUtils

ImageMitchellFilter GLS.ImageUtils

ImageSplineFilter GLS.ImageUtils

ImageTriangleFilter GLS.ImageUtils

IncludeInClipRect GLScene.GeometryBB

Extend the clip rect to include given coordinate.
IncreaseCoherency GLS.MeshUtils

Increases indices coherency wrt vertex caches. The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips). This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).
InflateGLRect GLScene.Utils

Increases or decreases the width and height of the specified rectangle. Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.
InformationDlg GLS.ImageUtils

Pops up a simple dialog with msg and an Ok button.
Init GLScene.VectorTypesExt

InitChunk Formats.m3DSUtils

InitCUDA CUDA.Import

InitCUDAFromLibrary CUDA.Import

InitCUDART CUDA.Runtime

InitCUDARTFromLibrary CUDA.Runtime

InitCUFFT CUDA.FourierTransform

InitCUFFTFromLibrary CUDA.FourierTransform

InitCUTIL CUDA.Utility

InitCUTILFromLibrary CUDA.Utility

InitFromLibraryOpenCL OpenCL.Import

InitializeRandomGenerator GLS.RandomHDS

Initialize_Contouring GLS.Isolines

InitNx PhysX.Import

InitObjectMotion Formats.m3DSUtils

InitODE ODE.Import

These are made public in the dynamic version MRQZZZ
InitOpenAL OpenAL.Import

InitOpenCL OpenCL.Import

CL_API_SUFFIX__VERSION_1_2 * Deprecated OpenCL 1.1 APIs *// clCreateImage2D(); clCreateImage3D(); clEnqueueMarker(); clEnqueueWaitForEvents(); clEnqueueBarrier(); clUnloadCompiler(); clGetExtensionFunctionAddress(); * Deprecated OpenCL 2.0 APIs *// clCreateCommandQueue(); clCreateSampler(); clEnqueueTask(); ————————————————————————-
InitOpenGL GLS.OpenGLAdapter

InitOpenGL GLScene.OpenGL4

InitOpenGLFromLibrary GLS.OpenGLAdapter

InitOpenGLFromLibrary GLScene.OpenGL4

InitTexture GLSL.CustomShader

InitTranslation GnuGetTextInit

InitTranslation has to be placed in the project file before "Application.Initialize" "Domains" is a list of all po/mo files needed by the application Calling sample: InitTranslation(['delphi10','indy10']);
InputDlg GLS.ImageUtils

Posp a simple dialog with a string input.
InternalFormatToOpenGLFormat GLScene.TextureFormat

Give a openGL texture format from GLScene texture format
InterpolateCombined GLScene.VectorGeometry

InterpolateCombinedFast GLScene.VectorGeometry

InterpolateCombinedFastPower GLScene.VectorGeometry

InterpolateCombinedSafe GLScene.VectorGeometry

InterpolateExp GLScene.VectorGeometry

InterpolateLn GLScene.VectorGeometry

InterpolatePower GLScene.VectorGeometry

There functions that do the same as "Lerp", but add some distortions
InterpolateSin GLScene.VectorGeometry

Only valid where Delta belongs to [0..1]
InterpolateSinAlt GLScene.VectorGeometry

"Alt" functions are valid everywhere
InterpolateTan GLScene.VectorGeometry

IntersectAABBs GLScene.GeometryBB

Determines if two AxisAlignedBoundingBoxes intersect. The matrices are the ones that convert one point to the other's AABB system
IntersectAABBsAbsolute GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide.
IntersectAABBsAbsoluteXY GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide in the XY plane.
IntersectAABBsAbsoluteXZ GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide in the XZ plane.
IntersectCubes GLS.Collision

Returns true when the bounding box cubes does intersect the other. Also true when the one cube does contain the other completely.
IntersectGLRect GLScene.Utils

IntersectLinePlane GLScene.VectorGeometry

Compute the intersection point "res" of a line with a plane. Return value: 0 : no intersection, line parallel to plane 1 : res is valid -1 : line is inside plane Adapted from: E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988
IntersectSphereBox GLScene.VectorGeometry

Compute intersection between a Sphere and a box. Up, Direction and Right must be normalized! Use CubDepth, CubeHeight and CubeWidth to scale TGLCube
IntersectTriangleBox GLScene.VectorGeometry

Compute intersection between a triangle and a box. Returns True if an intersection was found
InvertMatrix GLScene.VectorGeometry

Finds the inverse of a 3x3 matrix;
InvertMatrix GLScene.VectorGeometry

Finds the inverse of a 4x4 matrix
InvertTrianglesWinding GLS.MeshUtils

Inverts the triangles winding (vertex order).
InvokeInfoForm GLS.Scene

IsCgProfileSupported GLS.CgShader

Misc. global functions
IsColinear GLScene.VectorGeometry

Returns true if both vector are colinear
IsColinear GLScene.VectorGeometry

Returns true if both vector are colinear
IsColinear GLScene.VectorGeometry

Returns true if both vector are colinear
IsCompressedFormat GLScene.TextureFormat

IsCompressedFormat GLScene.TextureFormat

True if texture compressed
IsCUDAInitialized CUDA.Import

IsCUDARTInitialized CUDA.Runtime

IsCUFFTInitialized CUDA.FourierTransform

IsCUTILInitialized CUDA.Utility

IsDepthFormat GLScene.TextureFormat

IsDepthFormat GLScene.TextureFormat

True if depth texture
IsDirectoryWriteable GLScene.Utils

Determine if the directory is writable.
IsFloatFormat GLScene.TextureFormat

IsFloatFormat GLScene.TextureFormat

True if texture format is float
IsFogEnabled GLSL.CustomShader

IsFormatSupported GLScene.TextureFormat

True if texture format is supported by hardware or software
IsInCube GLScene.VectorGeometry

IsInCube GLScene.VectorGeometry

Returns True if p is in the cube defined by d.
IsInitializedOpenCL OpenCL.Import

IsInRange GLScene.VectorGeometry

IsInRange GLScene.VectorGeometry

Returns True if x is in [a; b]
IsInRect GLS.Gui

IsKeyDown GLScene.Keyboard

Check if the given virtual key is down. This function is just a wrapper for GetAsyncKeyState.
IsKeyDown GLScene.Keyboard

Check if the key corresponding to the given Char is down. The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad. The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).
IsLineIntersectQuad GLScene.VectorGeometry

Returns true if line intersect ABCD quad. Quad have to be flat and convex
IsLineIntersectTriangle GLScene.VectorGeometry

Returns true if line intersect ABC triangle
IsMainThread GLS.Context

IsMesaGL GLS.OpenGLAdapter

IsMesaGL GLScene.OpenGL4

IsOpenGLInitialized GLS.OpenGLAdapter

IsOpenGLInitialized GLScene.OpenGL4

IsOpenGLLoaded GLS.OpenGLAdapter

IsOpenGLLoaded GLScene.OpenGL4

IsOpenGLVersionMet GLScene.OpenGL4

IsPointInPolygon GLScene.VectorGeometry

PtInRegion
IsPowerOf2 GLScene.Utils

Returns True if value is a true power of two
ISqrt GLScene.VectorGeometry

Computes an integer sqrt approximation
IsServiceContextAvaible GLS.Context

IsSubComponent GLScene.Utils

Classes.pas
IsTargetSupported GLScene.TextureFormat

IsTargetSupported GLScene.TextureFormat

True if texture target supported
IsTargetSupportMipmap GLScene.TextureFormat

IsTargetSupportMipmap GLScene.TextureFormat

IsVersionMet GLS.OpenGLAdapter

IsVersionMet GLScene.OpenGL4

IsVolumeClipped GLScene.VectorGeometry

IsVolumeClipped GLScene.VectorGeometry

IsVolumeClipped GLScene.VectorGeometry

Determines if volume is clipped or not
Jpeg2Bmp GLS.FileJPEG

KeyboardNotifyWheelMoved GLScene.Keyboard

Use this procedure to notify a wheel movement and have it resurfaced as key stroke. Honoured by IsKeyDown and KeyPressed
KeyNameToVirtualKeyCode GLScene.Keyboard

Converts a key name to its virtual key code. The comparison is **NOT** case-sensitive, if no match is found, returns -1. The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.
KeyPressed GLScene.Keyboard

Returns the first pressed key whose virtual key code is >= to minVkCode. If no key is pressed, the return value is -1, this function does NOT wait for user input. If you don't care about multiple key presses, just don't use the parameter.
Lerp GLScene.VectorGeometry

Calculates linear interpolation between start and stop at point t
LibMat GLS.FileDDS

Linear_Interpolate GLS.Perlin

Useless for final output! Usefull for after interpolation, as its FAST!
LineLineDistance GLScene.VectorGeometry

Computes the closest distance between two lines
LnGamma GLScene.RandomLib

Logarithm to base e of the gamma function. Accurate to about 1.e-14. Programmer: Alan Miller Latest revision of Fortran 77 version - 28 February 1988
LoadAnsiStringFromFile GLScene.Utils

Returns the ansistring content of "filename".
LoadComponentFromFile GLScene.Utils

Loads component from a file.
LoadJPGtexture GLS.RandomHDS

Texture functions
LoadLW0FromStream Formats.LWO

LoadLWOFromFile Formats.LWO

LoadModule ModuleLoader

LoadModuleEx ModuleLoader

LoadOpenGL GLS.OpenGLAdapter

LoadOpenGL GLScene.OpenGL4

LoadOpenGLFromLibrary GLS.OpenGLAdapter

LoadOpenGLFromLibrary GLScene.OpenGL4

LoadQ3Anims GLS.FileQ3MD3

LoadQ3Anims GLS.FileQ3MD3

These procedures are helpers to load the Quake3 animation file data into an animation list. The NamePrefix parameter is used to determine which class of animation is extracted. eg NamePrefix='TORSO' will load all animations starting with 'TORSO_' like 'TORSO_STAND'
LoadQ3Skin GLS.FileQ3MD3

Quake3 Skin loading procedure. Use this procedure to apply textures to a GLActor. This doens't use the actors original preloaded materials so it may be a good idea to clear the actors material library before running this to keep everything nice and clean.
LoadResString gnugettext

Unicode-enabled way to get resourcestrings, automatically translated Use like this: ws:=LoadResStringW(@NameOfResourceString);
LoadResStringW gnugettext

LoadRGBEpixels GLScene.RGBE

LoadRLEpixels GLScene.RGBE

LoadSDLBMPFromStream SDL.Import

LoadStringFromFile GLScene.Utils

Returns the string content of "filename".
Logarithm2 GLScene.VectorGeometry

—————————————————————————- Exponential functions —————————————————————————–
LonLatToPos GLS.SkyDome

Computes position on the unit sphere of a star using Longitude and Latitude
MakeAffineDblVector GLScene.VectorGeometry

Miscellaneous functions
MAKEAVICKID Formats.VFW

MakeDblVector GLScene.VectorGeometry

MakeMeshHexahedron GLS.MeshBuilder

—————- Make Meshes ——————-
MakeMeshSphere GLS.MeshBuilder

MakeMeshTetrahedron GLS.MeshBuilder

Not implemented
MakeParallelProjectionMatrix GLScene.VectorGeometry

Creates a parallel projection matrix. Transformed points will projected on the plane along the specified direction
MakePoint GLScene.VectorGeometry

MakePoint GLScene.VectorGeometry

MakePoint GLScene.VectorGeometry

MakeReflectionMatrix GLScene.VectorGeometry

Builds a reflection matrix for the given plane. Reflection matrix allow implementing planar reflectors (mirrors)
MakeShadowMatrix GLScene.VectorGeometry

Creates a shadow projection matrix. Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos
MakeSubComponent GLScene.Utils

MakeTriangleAdjacencyList GLS.MeshUtils

Create list of indices of triangles with adjacency from triangle list
MakeVector GLScene.VectorGeometry

MakeVector GLScene.VectorGeometry

MakeVector GLScene.VectorGeometry

MakeVector GLScene.VectorGeometry

MatrixDecompose GLScene.VectorGeometry

Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it. Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan The coefficient of each transformation is returned in the corresponding element of the vector Tran. Returns true upon success, false if the matrix is singular.
MatrixDeterminant GLScene.VectorGeometry

Determinant of a 3x3 matrix
MatrixDeterminant GLScene.VectorGeometry

Determinant of a 4x4 matrix
MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

3x3
MatrixEquals GLScene.VectorGeometry

4x4
MatrixInvert GLScene.VectorGeometry

MatrixInvert GLScene.VectorGeometry

MatrixLerp GLScene.VectorGeometry

This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.
MatrixMultiply GLScene.VectorGeometry

Multiplies M1 by M2 and places result in MResult
MatrixMultiply GLScene.VectorGeometry

Multiplies two 3x3 matrices
MatrixMultiply GLScene.VectorGeometry

Multiplies two 4x4 matrices
MaxAbsXYZComponent GLScene.VectorGeometry

Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)
MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

Returns the maximum of given values.
MaxFloat GLScene.VectorGeometry

Returns the maximum value of the array.
MaxInteger GLScene.VectorGeometry

MaxInteger GLScene.VectorGeometry

MaxInteger GLScene.VectorGeometry

MaxInteger GLScene.VectorGeometry

MaxVector GLScene.VectorGeometry

MaxVector GLScene.VectorGeometry

Replace components of v with the max of v or v1 component. Maximum is computed per component
MaxXYZComponent GLScene.VectorGeometry

MaxXYZComponent GLScene.VectorGeometry

Returns the max of the X, Y and Z components of a vector (W is ignored)
MCIWndCanConfig Formats.VFW

MCIWndCanEject Formats.VFW

MCIWndCanPlay Formats.VFW

– Can macros —————————————————————
MCIWndCanRecord Formats.VFW

MCIWndCanSave Formats.VFW

MCIWndCanWindow Formats.VFW

MCIWndChangeStyles Formats.VFW

MCIWndClose Formats.VFW

MCIWndCreate Formats.VFW

MCIWndCreateA Formats.VFW

MCIWndCreateW Formats.VFW

MCIWndDestroy Formats.VFW

MCIWndEject Formats.VFW

MCIWndEnd Formats.VFW

MCIWndGetActiveTimer Formats.VFW

MCIWndGetAlias Formats.VFW

MCIWndGetDest Formats.VFW

MCIWndGetDevice Formats.VFW

MCIWndGetDeviceID Formats.VFW

MCIWndGetEnd Formats.VFW

MCIWndGetError Formats.VFW

MCIWndGetFileName Formats.VFW

MCIWndGetInactiveTimer Formats.VFW

MCIWndGetLength Formats.VFW

MCIWndGetMode Formats.VFW

MCIWndGetPalette Formats.VFW

#define MCIWndActivate(hwnd, f) (void)MCIWndSM(hwnd, WM_ACTIVATE, (WPARAM)(BOOL)(f), 0)
MCIWndGetPosition Formats.VFW

MCIWndGetPositionString Formats.VFW

MCIWndGetRepeat Formats.VFW

MCIWndGetSource Formats.VFW

MCIWndGetSpeed Formats.VFW

MCIWndGetStart Formats.VFW

MCIWndGetStyles Formats.VFW

MCIWndGetTimeFormat Formats.VFW

MCIWndGetVolume Formats.VFW

MCIWndGetZoom Formats.VFW

MCIWndHome Formats.VFW

MCIWndNew Formats.VFW

If you dont give a device it will use the current device....
MCIWndOpen Formats.VFW

MCIWndOpenDialog Formats.VFW

MCIWndOpenInterface Formats.VFW

MCIWndPaletteKick Formats.VFW

MCIWndPause Formats.VFW

MCIWndPlay Formats.VFW

MCIWndPlayFrom Formats.VFW

MCIWndPlayFromTo Formats.VFW

MCIWndPlayReverse Formats.VFW

MCIWndPlayTo Formats.VFW

MCIWndPutDest Formats.VFW

MCIWndPutSource Formats.VFW

MCIWndRealize Formats.VFW

MCIWndRecord Formats.VFW

MCIWndRegisterClass Formats.VFW

MCIWndCreateA
MCIWndResume Formats.VFW

MCIWndReturnString Formats.VFW

MCIWndSave Formats.VFW

MCIWndSaveDialog Formats.VFW

MCIWndSeek Formats.VFW

MCIWndSendString Formats.VFW

MCIWndSetActiveTimer Formats.VFW

MCIWndSetInactiveTimer Formats.VFW

MCIWndSetOwner Formats.VFW

MCIWndSetPalette Formats.VFW

MCIWndSetRepeat Formats.VFW

MCIWndSetSpeed Formats.VFW

MCIWndSetTimeFormat Formats.VFW

MCIWndSetTimers Formats.VFW

MCIWndSetVolume Formats.VFW

MCIWndSetZoom Formats.VFW

MCIWndSM Formats.VFW

MCIWnd

MCIWnd window class header file.

the MCIWnd window class is a window class for controling MCI devices MCI devices include, wave files, midi files, AVI Video, cd audio, vcr, video disc, and others..

to learn more about MCI and mci command sets see the "Microsoft Multimedia Programmers's guide" in the Win31 SDK

the easiest use of the MCIWnd class is like so:

hwnd = MCIWndCreate(hwndParent, hInstance, 0, "chimes.wav"); ... MCIWndPlay(hwnd); MCIWndStop(hwnd); MCIWndPause(hwnd); .... MCIWndDestroy(hwnd);

this will create a window with a play/pause, stop and a playbar and start the wave file playing.

mciwnd.h defines macros for all the most common MCI commands, but any string command can be used if needed.

Note: unlike the mciSendString() API, no alias or file name needs to be specifed, since the device to use is implied by the window handle.

MCIWndSendString(hwnd, "setaudio stream to 2");

(C) Copyright Microsoft Corp. 1991-1995. All rights reserved.

WIN32:

MCIWnd supports both ansi and unicode interfaces. For any message that takes or returns a text string, two versions of the message are defined, appended with A or W for Ansi or Wide Char. The message or api itself is defined to be one or other of these depending on whether you have UNICODE defined in your application. Thus for the api MCIWndCreate, there are in fact two apis, MCIWndCreateA and MCIWndCreateW. If you call MCIWndCreate, this will be re-routed to MCIWndCreateA unless UNICODE is defined when building your application. In any one application, you can mix calls to the Ansi and Unicode entrypoints.

If you use SendMessage instead of the macros below such as MCIWndOpen(), you will see that the messages have changed for WIN32, to support Ansi and Unicode entrypoints. In particular, MCI_OPEN has been replaced by MCWNDM_OPENA, or MCIWNDM_OPENW (MCIWNDM_OPEN is defined to be one or other of these).

Also, note that the WIN32 implementation of MCIWnd uses UNICODE so all apis and messages supporting ANSI strings do so by mapping them UNICODE strings and then calling the corresponding UNICODE entrypoint.
MCIWndStep Formats.VFW

MCIWndStop Formats.VFW

MCIWndUseFrames Formats.VFW

MCIWndUseTime Formats.VFW

MCIWndValidateMedia Formats.VFW

MC_UnCompressQuat Formats.GL2

MinAbsXYZComponent GLScene.VectorGeometry

Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)
MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

Returns the minimum of given values.
MinFloat GLScene.VectorGeometry

Returns the minimum value of the array.
MinInteger GLScene.VectorGeometry

MinInteger GLScene.VectorGeometry

MinInteger GLScene.VectorGeometry

MinInteger GLScene.VectorGeometry

MinPositiveCoef GLScene.Polynomials

Finds the minimum positive coef in the array in aMin. Returns true if such an item was found.
MinVector GLScene.VectorGeometry

MinVector GLScene.VectorGeometry

Replace components of v with the min of v or v1 component. Minimum is computed per component
MinXYZComponent GLScene.VectorGeometry

MinXYZComponent GLScene.VectorGeometry

Returns the min of the X, Y and Z components of a vector (W is ignored)
MKFOURCC Formats.VFW

***************************************************************************/ /* */ /* Macros */ /* */ /* should we define this?? */ /* */ /***************************************************************************
mmioFOURCC Formats.VFW

'1632'
MoveObjectAround GLScene.VectorGeometry

Extracted from Camera.MoveAroundTarget(pitch, turn)
nearCallBack GLS.ODEManager

ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer
NegateVector GLScene.VectorGeometry

Negates the vector
NegateVector GLScene.VectorGeometry

Negates the vector
NegateVector GLScene.VectorGeometry

Negates the vector
NewtonAlloc Newton.Import

NewtonAtomicAdd Newton.Import

NewtonAtomicSwap Newton.Import

NewtonBallGetJointAngle Newton.Import

NewtonBallGetJointForce Newton.Import

NewtonBallGetJointOmega Newton.Import

NewtonBallSetConeLimits Newton.Import

NewtonBallSetUserCallback Newton.Import

NewtonBodyAddForce Newton.Import

NewtonBodyAddImpulse Newton.Import

NewtonBodyAddTorque Newton.Import

NewtonBodyApplyImpulseArray Newton.Import

NewtonBodyApplyImpulsePair Newton.Import

NewtonBodyCalculateInverseDynamicsForce Newton.Import

NewtonBodyFindContact Newton.Import

NewtonBodyGetAABB Newton.Import

NewtonBodyGetAcceleration Newton.Import

NewtonBodyGetAlpha Newton.Import

NewtonBodyGetAngularDamping Newton.Import

NewtonBodyGetAutoSleep Newton.Import

NewtonBodyGetCentreOfMass Newton.Import

NewtonBodyGetCollidable Newton.Import

NewtonBodyGetCollision Newton.Import

NewtonBodyGetContinuousCollisionMode Newton.Import

NewtonBodyGetDestructorCallback Newton.Import

NewtonBodyGetFirstContactJoint Newton.Import

NewtonBodyGetFirstJoint Newton.Import

NewtonBodyGetForce Newton.Import

NewtonBodyGetForceAndTorqueCallback Newton.Import

NewtonBodyGetFreezeState Newton.Import

NewtonBodyGetGyroscopicTorque Newton.Import

NewtonBodyGetID Newton.Import

NewtonBodyGetInertiaMatrix Newton.Import

NewtonBodyGetInvInertiaMatrix Newton.Import

NewtonBodyGetInvMass Newton.Import

NewtonBodyGetJointRecursiveCollision Newton.Import

NewtonBodyGetLinearDamping Newton.Import

NewtonBodyGetMass Newton.Import

NewtonBodyGetMaterialGroupID Newton.Import

NewtonBodyGetMatrix Newton.Import

NewtonBodyGetNextContactJoint Newton.Import

NewtonBodyGetNextJoint Newton.Import

NewtonBodyGetOmega Newton.Import

NewtonBodyGetPointVelocity Newton.Import

NewtonBodyGetPosition Newton.Import

NewtonBodyGetRotation Newton.Import

NewtonBodyGetSerializedID Newton.Import

NewtonBodyGetSimulationState Newton.Import

NewtonBodyGetSleepState Newton.Import

NewtonBodyGetTorque Newton.Import

NewtonBodyGetTransformCallback Newton.Import

NewtonBodyGetType Newton.Import

NewtonBodyGetUserData Newton.Import

NewtonBodyGetVelocity Newton.Import

NewtonBodyGetWorld Newton.Import

NewtonBodyIntegrateVelocity Newton.Import

NewtonBodySetAngularDamping Newton.Import

NewtonBodySetAutoSleep Newton.Import

NewtonBodySetCentreOfMass Newton.Import

NewtonBodySetCollidable Newton.Import

NewtonBodySetCollision Newton.Import

NewtonBodySetCollisionScale Newton.Import

NewtonBodySetContinuousCollisionMode Newton.Import

NewtonBodySetDestructorCallback Newton.Import

NewtonBodySetForce Newton.Import

NewtonBodySetForceAndTorqueCallback Newton.Import

NewtonBodySetFreezeState Newton.Import

NewtonBodySetFullMassMatrix Newton.Import

NewtonBodySetGyroscopicTorque Newton.Import

NewtonBodySetJointRecursiveCollision Newton.Import

NewtonBodySetLinearDamping Newton.Import

NewtonBodySetMassMatrix Newton.Import

NewtonBodySetMassProperties Newton.Import

NewtonBodySetMaterialGroupID Newton.Import

NewtonBodySetMatrix Newton.Import

NewtonBodySetMatrixNoSleep Newton.Import

NewtonBodySetMatrixRecursive Newton.Import

NewtonBodySetOmega Newton.Import

NewtonBodySetOmegaNoSleep Newton.Import

NewtonBodySetSimulationState Newton.Import

NewtonBodySetSleepState Newton.Import

NewtonBodySetTorque Newton.Import

NewtonBodySetTransformCallback Newton.Import

NewtonBodySetUserData Newton.Import

NewtonBodySetVelocity Newton.Import

NewtonBodySetVelocityNoSleep Newton.Import

NewtonCalculateSpringDamperAcceleration Newton.Import

NewtonCollisionAggregateAddBody Newton.Import

NewtonCollisionAggregateCreate Newton.Import

**********************************************************************************************

collision aggregates, are a collision node on eh broad phase the serve as the root nod for a collection of rigid bodies that shared the property of being in close proximity all the time, they are similar to compound collision by the group bodies instead of collision instances These are good for speeding calculation calculation of rag doll, Vehicles or contractions of rigid bodied lined by joints. also for example if you know that many the life time of a group of bodies like the object on a house of a building will be localize to the confide of the building then warping the bodies under an aggregate will reduce collision calculation of almost an order of magnitude.

**********************************************************************************************
NewtonCollisionAggregateDestroy Newton.Import

NewtonCollisionAggregateGetSelfCollision Newton.Import

NewtonCollisionAggregateRemoveBody Newton.Import

NewtonCollisionAggregateSetSelfCollision Newton.Import

NewtonCollisionCalculateAABB Newton.Import

NewtonCollisionClosestPoint Newton.Import

NewtonCollisionCollide Newton.Import

NewtonCollisionCollideContinue Newton.Import

NewtonCollisionCreateInstance Newton.Import

**********************************************************************************************

General purpose collision library functions

**********************************************************************************************
NewtonCollisionDataPointer Newton.Import

NewtonCollisionForEachPolygonDo Newton.Import

NewtonCollisionGetInfo Newton.Import

NewtonCollisionGetMaterial Newton.Import

NewtonCollisionGetMatrix Newton.Import

NewtonCollisionGetMode Newton.Import

NewtonCollisionGetParentInstance Newton.Import

NewtonCollisionGetScale Newton.Import

NewtonCollisionGetSkinThickness Newton.Import

NewtonCollisionGetSubCollisionHandle Newton.Import

NewtonCollisionGetType Newton.Import

NewtonCollisionGetUserData Newton.Import

NewtonCollisionGetUserID Newton.Import

NewtonCollisionIntersectionTest Newton.Import

NewtonCollisionIsConvexShape Newton.Import

NewtonCollisionIsStaticShape Newton.Import

NewtonCollisionPointDistance Newton.Import

NewtonCollisionRayCast Newton.Import

NewtonCollisionSerialize Newton.Import

NewtonCollisionSetMaterial Newton.Import

NewtonCollisionSetMatrix Newton.Import

NewtonCollisionSetMode Newton.Import

NewtonCollisionSetScale Newton.Import

NewtonCollisionSetSkinThickness Newton.Import

NewtonCollisionSetUserData Newton.Import

NewtonCollisionSetUserID Newton.Import

NewtonCollisionSupportVertex Newton.Import

NewtonCompoundCollisionAddSubCollision Newton.Import

NewtonCompoundCollisionBeginAddRemove Newton.Import

NewtonCompoundCollisionEndAddRemove Newton.Import

NewtonCompoundCollisionGetCollisionFromNode Newton.Import

NewtonCompoundCollisionGetFirstNode Newton.Import

NewtonCompoundCollisionGetNextNode Newton.Import

NewtonCompoundCollisionGetNodeByIndex Newton.Import

NewtonCompoundCollisionGetNodeIndex Newton.Import

NewtonCompoundCollisionRemoveSubCollision Newton.Import

NewtonCompoundCollisionRemoveSubCollisionByIndex Newton.Import

NewtonCompoundCollisionSetSubCollisionMatrix Newton.Import

NewtonConstraintCreateBall Newton.Import

**********************************************************************************************

Ball and Socket joint functions

**********************************************************************************************
NewtonConstraintCreateCorkscrew Newton.Import

**********************************************************************************************

Corkscrew joint functions

**********************************************************************************************
NewtonConstraintCreateHinge Newton.Import

**********************************************************************************************

Hinge joint functions

**********************************************************************************************
NewtonConstraintCreateSlider Newton.Import

**********************************************************************************************

Slider joint functions

**********************************************************************************************
NewtonConstraintCreateUniversal Newton.Import

**********************************************************************************************

Universal joint functions

**********************************************************************************************
NewtonConstraintCreateUpVector Newton.Import

**********************************************************************************************

Up vector joint functions

**********************************************************************************************
NewtonConstraintCreateUserJoint Newton.Import

**********************************************************************************************

User defined bilateral Joint

**********************************************************************************************
NewtonContactGetCollision0 Newton.Import

NewtonContactGetCollision1 Newton.Import

NewtonContactGetCollisionID0 Newton.Import

NewtonContactGetCollisionID1 Newton.Import

NewtonContactGetMaterial Newton.Import

NewtonContactJointGetClosestDistance Newton.Import

NewtonContactJointGetContactCount Newton.Import

NewtonContactJointGetFirstContact Newton.Import

**********************************************************************************************

contact joints interface

**********************************************************************************************
NewtonContactJointGetNextContact Newton.Import

NewtonContactJointRemoveContact Newton.Import

NewtonContactJointResetIntraJointCollision Newton.Import

NewtonContactJointResetSelftJointCollision Newton.Import

NewtonConvexCollisionCalculateBuoyancyVolume Newton.Import

NewtonConvexCollisionCalculateInertialMatrix Newton.Import

NewtonConvexCollisionCalculateVolume Newton.Import

NewtonConvexHullGetFaceIndices Newton.Import

NewtonConvexHullGetVertexData Newton.Import

NewtonCorkscrewCalculateStopAccel Newton.Import

NewtonCorkscrewCalculateStopAlpha Newton.Import

NewtonCorkscrewGetJointAngle Newton.Import

NewtonCorkscrewGetJointForce Newton.Import

NewtonCorkscrewGetJointOmega Newton.Import

NewtonCorkscrewGetJointPosit Newton.Import

NewtonCorkscrewGetJointVeloc Newton.Import

NewtonCorkscrewSetUserCallback Newton.Import

NewtonCreate Newton.Import

NewtonCreateAsymetricDynamicBody Newton.Import

NewtonCreateBox Newton.Import

NewtonCreateCapsule Newton.Import

NewtonCreateChamferCylinder Newton.Import

NewtonCreateCollisionFromSerialization Newton.Import

***********************************************************************************************************

Collision serialization functions

***********************************************************************************************************
NewtonCreateCompoundCollision Newton.Import

**********************************************************************************************

compound collision primitives creation functions

**********************************************************************************************
NewtonCreateCompoundCollisionFromMesh Newton.Import

NewtonCreateCone Newton.Import

NewtonCreateConvexHull Newton.Import

NewtonCreateConvexHullFromMesh Newton.Import

NewtonCreateCylinder Newton.Import

NewtonCreateDeformableSolid Newton.Import

NewtonCreateDynamicBody Newton.Import

body manipulation functions
NewtonCreateFracturedCompoundCollision Newton.Import

**********************************************************************************************

Fractured compound collision primitives interface

**********************************************************************************************
NewtonCreateHeightFieldCollision Newton.Import

**********************************************************************************************

Static collision shapes functions

**********************************************************************************************
NewtonCreateKinematicBody Newton.Import

NewtonCreateMassSpringDamperSystem Newton.Import

**********************************************************************************************

particle system interface (soft bodies, individual, pressure bodies and cloth)

**********************************************************************************************
NewtonCreateNull Newton.Import

**********************************************************************************************

convex collision primitives creation functions

**********************************************************************************************
NewtonCreateSceneCollision Newton.Import

**********************************************************************************************

scene collision are static compound collision that can take polygonal static collisions

**********************************************************************************************
NewtonCreateSphere Newton.Import

NewtonCreateTetrahedraLinearBlendSkinWeightsChannel Newton.Import

NewtonCreateTreeCollision Newton.Import

NewtonCreateTreeCollisionFromMesh Newton.Import

NewtonCreateUserMeshCollision Newton.Import

***********************************************************************************************************

User Static mesh collision interface

***********************************************************************************************************
NewtonCurrentPlugin Newton.Import

NewtonDeformableMeshGetParticleArray Newton.Import

NewtonDeformableMeshGetParticleCount Newton.Import

NewtonDeformableMeshGetParticleStrideInBytes Newton.Import

NewtonDeserializeFromFile Newton.Import

NewtonDeserializeScene Newton.Import

NewtonDestroy Newton.Import

NewtonDestroyAllBodies Newton.Import

NewtonDestroyBody Newton.Import

NewtonDestroyCollision Newton.Import

NewtonDestroyJoint Newton.Import

NewtonDispachThreadJob Newton.Import

NewtonFindSerializedBody Newton.Import

NewtonFracturedCompoundCollisionGetVertexCount Newton.Import

NewtonFracturedCompoundCollisionGetVertexNormals Newton.Import

NewtonFracturedCompoundCollisionGetVertexPositions Newton.Import

NewtonFracturedCompoundCollisionGetVertexUVs Newton.Import

NewtonFracturedCompoundGetFirstSubMesh Newton.Import

NewtonFracturedCompoundGetMainMesh Newton.Import

NewtonFracturedCompoundGetNextSubMesh Newton.Import

NewtonFracturedCompoundIsNodeFreeToDetach Newton.Import

NewtonFracturedCompoundMeshPartGetFirstSegment Newton.Import

NewtonFracturedCompoundMeshPartGetIndexCount Newton.Import

NewtonFracturedCompoundMeshPartGetIndexStream Newton.Import

NewtonFracturedCompoundMeshPartGetMaterial Newton.Import

NewtonFracturedCompoundMeshPartGetNextSegment Newton.Import

NewtonFracturedCompoundNeighborNodeList Newton.Import

NewtonFracturedCompoundPlaneClip Newton.Import

NewtonFracturedCompoundSetCallbacks Newton.Import

NewtonFree Newton.Import

NewtonGetBroadphaseAlgorithm Newton.Import

NewtonGetContactMergeTolerance Newton.Import

NewtonGetEulerAngle Newton.Import

NewtonGetFirstPlugin Newton.Import

NewtonGetJointSerializationCallbacks Newton.Import

NewtonGetLastUpdateTime Newton.Import

NewtonGetMaxThreadsCount Newton.Import

NewtonGetMemoryUsed Newton.Import

NewtonGetNextPlugin Newton.Import

NewtonGetNumberOfSubsteps Newton.Import

NewtonGetParallelSolverOnLargeIsland Newton.Import

NewtonGetPluginString Newton.Import

NewtonGetPostUpdateCallback Newton.Import

NewtonGetPreferedPlugin Newton.Import

NewtonGetSolverIterations Newton.Import

NewtonGetThreadsCount Newton.Import

NewtonHeightFieldSetHorizontalDisplacement Newton.Import

NewtonHeightFieldSetUserRayCastCallback Newton.Import

NewtonHingeCalculateStopAlpha Newton.Import

NewtonHingeGetJointAngle Newton.Import

NewtonHingeGetJointForce Newton.Import

NewtonHingeGetJointOmega Newton.Import

NewtonHingeSetUserCallback Newton.Import

NewtonInvalidateCache Newton.Import

NewtonIslandGetBody Newton.Import

**********************************************************************************************

Simulation islands

**********************************************************************************************
NewtonIslandGetBodyAABB Newton.Import

NewtonJointGetBody0 Newton.Import

NewtonJointGetBody1 Newton.Import

NewtonJointGetCollisionState Newton.Import

NewtonJointGetInfo Newton.Import

NewtonJointGetStiffness Newton.Import

NewtonJointGetUserData Newton.Import

**********************************************************************************************

Common joint functions

**********************************************************************************************
NewtonJointIsActive Newton.Import

NewtonJointSetCollisionState Newton.Import

NewtonJointSetDestructor Newton.Import

NewtonJointSetStiffness Newton.Import

NewtonJointSetUserData Newton.Import

NewtonLoadPlugins Newton.Import

NewtonMaterialContactRotateTangentDirections Newton.Import

NewtonMaterialCreateGroupID Newton.Import

**********************************************************************************************

Physics Material Section

**********************************************************************************************
NewtonMaterialDestroyAllGroupID Newton.Import

NewtonMaterialGetBodyCollidingShape Newton.Import

NewtonMaterialGetContactFaceAttribute Newton.Import

NewtonMaterialGetContactForce Newton.Import

NewtonMaterialGetContactMaxNormalImpact Newton.Import

NewtonMaterialGetContactMaxTangentImpact Newton.Import

NewtonMaterialGetContactNormalSpeed Newton.Import

NewtonMaterialGetContactPenetration Newton.Import

NewtonMaterialGetContactPositionAndNormal Newton.Import

NewtonMaterialGetContactPruningTolerance Newton.Import

NewtonMaterialGetContactTangentDirections Newton.Import

NewtonMaterialGetContactTangentSpeed Newton.Import

NewtonMaterialGetDefaultGroupID Newton.Import

NewtonMaterialGetMaterialPairUserData Newton.Import

**********************************************************************************************

Physics Contact control functions

**********************************************************************************************
NewtonMaterialGetUserData Newton.Import

material definitions that can not be overwritten in function callback
NewtonMaterialJointResetIntraJointCollision Newton.Import

NewtonMaterialJointResetSelftJointCollision Newton.Import

NewtonMaterialSetAsSoftContact Newton.Import

NewtonMaterialSetCallbackUserData Newton.Import

deprecated, not longer continue collision is set on the material NEWTON_API void NewtonMaterialSetContinuousCollisionMode (const NewtonWorld* const newtonWorld, int id0, int id1, int state);
NewtonMaterialSetCollisionCallback Newton.Import

NewtonMaterialSetCompoundCollisionCallback Newton.Import

NewtonMaterialSetContactElasticity Newton.Import

NewtonMaterialSetContactFrictionCoef Newton.Import

NewtonMaterialSetContactFrictionState Newton.Import

NewtonMaterialSetContactGenerationCallback Newton.Import

NewtonMaterialSetContactNormalAcceleration Newton.Import

NewtonMaterialSetContactNormalDirection Newton.Import

NewtonMaterialSetContactPosition Newton.Import

NewtonMaterialSetContactPruningTolerance Newton.Import

NewtonMaterialSetContactSoftness Newton.Import

NewtonMaterialSetContactTangentAcceleration Newton.Import

NewtonMaterialSetContactTangentFriction Newton.Import

NewtonMaterialSetContactThickness Newton.Import

NewtonMaterialSetDefaultCollidable Newton.Import

NewtonMaterialSetDefaultElasticity Newton.Import

NewtonMaterialSetDefaultFriction Newton.Import

NewtonMaterialSetDefaultSoftness Newton.Import

NewtonMaterialSetSurfaceThickness Newton.Import

NewtonMeshAddBinormal Newton.Import

NewtonMeshAddLayer Newton.Import

NewtonMeshAddMaterial Newton.Import

NewtonMeshAddNormal Newton.Import

NewtonMeshAddPoint Newton.Import

NewtonMeshAddUV0 Newton.Import

NewtonMeshAddUV1 Newton.Import

NewtonMeshAddVertexColor Newton.Import

NewtonMeshApplyAngleBasedMapping Newton.Import

NewtonMeshApplyBoxMapping Newton.Import

NewtonMeshApplyCylindricalMapping Newton.Import

NewtonMeshApplySphericalMapping Newton.Import

NewtonMeshApplyTransform Newton.Import

NewtonMeshApproximateConvexDecomposition Newton.Import

NewtonMeshBeginBuild Newton.Import

NewtonMeshBeginFace Newton.Import

NewtonMeshBeginHandle Newton.Import

NewtonMeshBuildFromVertexListIndexList Newton.Import

NewtonMeshCalculateFaceNormal Newton.Import

NewtonMeshCalculateOOBB Newton.Import

NewtonMeshCalculateVertexNormals Newton.Import

NewtonMeshClearVertexFormat Newton.Import

NewtonMeshClip Newton.Import

NewtonMeshConvexMeshIntersection Newton.Import

NewtonMeshCreate Newton.Import

**********************************************************************************************

Mesh joint functions

**********************************************************************************************
NewtonMeshCreateConvexHull Newton.Import

NewtonMeshCreateFirstLayer Newton.Import

NewtonMeshCreateFirstSingleSegment Newton.Import

NewtonMeshCreateFromCollision Newton.Import

NewtonMeshCreateFromMesh Newton.Import

NewtonMeshCreateFromSerialization Newton.Import

NewtonMeshCreateNextLayer Newton.Import

NewtonMeshCreateNextSingleSegment Newton.Import

NewtonMeshCreateTetrahedraIsoSurface Newton.Import

NewtonMeshCreateVoronoiConvexDecomposition Newton.Import

NewtonMeshDestroy Newton.Import

NewtonMeshDifference Newton.Import

NewtonMeshEndBuild Newton.Import

NewtonMeshEndFace Newton.Import

NewtonMeshEndHandle Newton.Import

NewtonMeshFirstMaterial Newton.Import

NewtonMeshFixTJoints Newton.Import

NewtonMeshFlipWinding Newton.Import

NewtonMeshGetBinormalChannel Newton.Import

NewtonMeshGetEdgeIndices Newton.Import

NewtonMeshGetFaceIndexCount Newton.Import

NewtonMeshGetFaceIndices Newton.Import

NewtonMeshGetFaceMaterial Newton.Import

NewtonMeshGetFacePointIndices Newton.Import

NewtonMeshGetFaces Newton.Import

NewtonMeshGetFirstEdge Newton.Import

NewtonMeshGetFirstFace Newton.Import

NEWTON_API void NewtonMeshGetEdgePointIndices (const NewtonMesh* const mesh, const void* const edge, int* const v0, int* const v1);
NewtonMeshGetFirstPoint Newton.Import

NewtonMeshGetFirstVertex Newton.Import

NewtonMeshGetIndexToVertexMap Newton.Import

NewtonMeshGetNextEdge Newton.Import

NewtonMeshGetNextFace Newton.Import

NewtonMeshGetNextPoint Newton.Import

NewtonMeshGetNextVertex Newton.Import

NewtonMeshGetNormalChannel Newton.Import

NewtonMeshGetPointCount Newton.Import

NewtonMeshGetPointIndex Newton.Import

NewtonMeshGetTotalFaceCount Newton.Import

NewtonMeshGetTotalIndexCount Newton.Import

NewtonMeshGetUV0Channel Newton.Import

NewtonMeshGetUV1Channel Newton.Import

NewtonMeshGetVertexArray Newton.Import

NewtonMeshGetVertexBaseCount Newton.Import

NewtonMeshGetVertexChannel Newton.Import

NewtonMeshGetVertexColorChannel Newton.Import

NewtonMeshGetVertexCount Newton.Import

NewtonMeshGetVertexDoubleChannel Newton.Import

NewtonMeshGetVertexIndex Newton.Import

NewtonMeshGetVertexIndexFromPoint Newton.Import

NewtonMeshGetVertexStrideInByte Newton.Import

NewtonMeshGetVertexWeights Newton.Import

NewtonMeshHasBinormalChannel Newton.Import

NewtonMeshHasNormalChannel Newton.Import

NewtonMeshHasUV0Channel Newton.Import

NewtonMeshHasUV1Channel Newton.Import

NewtonMeshHasVertexColorChannel Newton.Import

NewtonMeshIntersection Newton.Import

NewtonMeshIsFaceOpen Newton.Import

NewtonMeshIsOpenMesh Newton.Import

NewtonMeshLoadOFF Newton.Import

NewtonMeshLoadTetrahedraMesh Newton.Import

NewtonMeshMaterialGetIndexCount Newton.Import

NewtonMeshMaterialGetIndexStream Newton.Import

NewtonMeshMaterialGetIndexStreamShort Newton.Import

NewtonMeshMaterialGetMaterial Newton.Import

NewtonMeshNextMaterial Newton.Import

NewtonMeshOptimize Newton.Import

NewtonMeshOptimizePoints Newton.Import

NewtonMeshOptimizeVertex Newton.Import

NewtonMeshPolygonize Newton.Import

NewtonMeshSaveOFF Newton.Import

NewtonMeshSerialize Newton.Import

NewtonMeshSetFaceMaterial Newton.Import

NewtonMeshSetVertexBaseCount Newton.Import

NewtonMeshSimplify Newton.Import

NewtonMeshTriangulate Newton.Import

NewtonMeshUnion Newton.Import

NewtonRemoveUnusedVertices Newton.Import

NewtonResetBroadphase Newton.Import

NewtonSceneCollisionAddSubCollision Newton.Import

NewtonSceneCollisionBeginAddRemove Newton.Import

NewtonSceneCollisionEndAddRemove Newton.Import

NewtonSceneCollisionGetCollisionFromNode Newton.Import

NewtonSceneCollisionGetFirstNode Newton.Import

NewtonSceneCollisionGetNextNode Newton.Import

NewtonSceneCollisionGetNodeByIndex Newton.Import

NewtonSceneCollisionGetNodeIndex Newton.Import

NewtonSceneCollisionRemoveSubCollision Newton.Import

NewtonSceneCollisionRemoveSubCollisionByIndex Newton.Import

NewtonSceneCollisionSetSubCollisionMatrix Newton.Import

NewtonSelectBroadphaseAlgorithm Newton.Import

NewtonSelectPlugin Newton.Import

NewtonSerializeScene Newton.Import

NewtonSerializeToFile Newton.Import

NewtonSetContactMergeTolerance Newton.Import

NewtonSetEulerAngle Newton.Import

transforms utility functions
NewtonSetIslandUpdateEvent Newton.Import

NewtonSetJointSerializationCallbacks Newton.Import

NewtonSetMemorySystem Newton.Import

NewtonSetNumberOfSubsteps Newton.Import

NewtonSetParallelSolverOnLargeIsland Newton.Import

NewtonSetPostUpdateCallback Newton.Import

NewtonSetSolverIterations Newton.Import

NewtonSetThreadsCount Newton.Import

NewtonSliderCalculateStopAccel Newton.Import

NewtonSliderGetJointForce Newton.Import

NewtonSliderGetJointPosit Newton.Import

NewtonSliderGetJointVeloc Newton.Import

NewtonSliderSetUserCallback Newton.Import

NewtonStaticCollisionSetDebugCallback Newton.Import

NewtonSyncThreadJobs Newton.Import

NewtonTreeCollisionAddFace Newton.Import

NewtonTreeCollisionBeginBuild Newton.Import

NewtonTreeCollisionEndBuild Newton.Import

NewtonTreeCollisionForEachFace Newton.Import

NewtonTreeCollisionGetFaceAttribute Newton.Import

NewtonTreeCollisionGetVertexListTriangleListInAABB Newton.Import

NewtonTreeCollisionSetFaceAttribute Newton.Import

NewtonTreeCollisionSetUserRayCastCallback Newton.Import

NewtonUniversalCalculateStopAlpha0 Newton.Import

NewtonUniversalCalculateStopAlpha1 Newton.Import

NewtonUniversalGetJointAngle0 Newton.Import

NewtonUniversalGetJointAngle1 Newton.Import

NewtonUniversalGetJointForce Newton.Import

NewtonUniversalGetJointOmega0 Newton.Import

NewtonUniversalGetJointOmega1 Newton.Import

NewtonUniversalSetUserCallback Newton.Import

NewtonUnloadPlugins Newton.Import

NewtonUpdate Newton.Import

NewtonUpdateAsync Newton.Import

NewtonUpVectorGetPin Newton.Import

NewtonUpVectorSetPin Newton.Import

NewtonUserJoinRowsCount Newton.Import

NewtonUserJointAddAngularRow Newton.Import

NewtonUserJointAddGeneralRow Newton.Import

NewtonUserJointAddLinearRow Newton.Import

NewtonUserJointCalculateRowZeroAcceleration Newton.Import

NewtonUserJointGetGeneralRow Newton.Import

NewtonUserJointGetRowAcceleration Newton.Import

NewtonUserJointGetRowForce Newton.Import

NewtonUserJointGetRowJacobian Newton.Import

NewtonUserJointGetSolverModel Newton.Import

NewtonUserJointMassScale Newton.Import

NewtonUserJointSetFeedbackCollectorCallback Newton.Import

NewtonUserJointSetRowAcceleration Newton.Import

NewtonUserJointSetRowMaximumFriction Newton.Import

NewtonUserJointSetRowMinimumFriction Newton.Import

NewtonUserJointSetRowSpringDamperAcceleration Newton.Import

NewtonUserJointSetRowStiffness Newton.Import

NewtonUserJointSetSolverModel Newton.Import

NewtonUserMeshCollisionContinuousOverlapTest Newton.Import

NewtonWaitForUpdateToFinish Newton.Import

NewtonWorldAddListener Newton.Import

NewtonWorldCollide Newton.Import

NewtonWorldConvexCast Newton.Import

NewtonWorldCriticalSectionLock Newton.Import

NewtonWorldCriticalSectionUnlock Newton.Import

NewtonWorldFindJoint Newton.Import

NewtonWorldFloatSize Newton.Import

NewtonWorldForEachBodyInAABBDo Newton.Import

NewtonWorldForEachJointDo Newton.Import

NewtonWorldGetBodyCount Newton.Import

world utility functions
NewtonWorldGetConstraintCount Newton.Import

NewtonWorldGetDestructorCallback Newton.Import

NewtonWorldGetFirstBody Newton.Import

NewtonWorldGetFirstMaterial Newton.Import

NewtonWorldGetListener Newton.Import

NewtonWorldGetListenerUserData Newton.Import

NewtonWorldGetNextBody Newton.Import

NewtonWorldGetNextMaterial Newton.Import

NewtonWorldGetUserData Newton.Import

NewtonWorldGetVersion Newton.Import

**********************************************************************************************

world control functions

**********************************************************************************************
NewtonWorldListenerDebug Newton.Import

NewtonWorldListenerGetBodyDestroyCallback Newton.Import

NewtonWorldListenerSetBodyDestroyCallback Newton.Import

NewtonWorldListenerSetDebugCallback Newton.Import

NewtonWorldListenerSetDestructorCallback Newton.Import

NewtonWorldListenerSetPostStepCallback Newton.Import

NewtonWorldListenerSetPostUpdateCallback Newton.Import

NewtonWorldListenerSetPreUpdateCallback Newton.Import

NewtonWorldRayCast Newton.Import

NewtonWorldSetCollisionConstructorDestructorCallback Newton.Import

NewtonWorldSetCreateDestroyContactCallback Newton.Import

NewtonWorldSetDestructorCallback Newton.Import

NewtonWorldSetUserData Newton.Import

NewtonYield Newton.Import

ngettext gnugettext

ngettext_NoExtract gnugettext

NoisyColor GLS.RandomHDS

NormalizeAngle GLScene.VectorGeometry

Normalize to an angle in the [-PI; +PI] range
NormalizeDegAngle GLScene.VectorGeometry

Normalize to an angle in the [-180; 180] range
NormalizeMatrix GLScene.VectorGeometry

Normalize the matrix and remove the translation component. The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)
NormalizePlane GLScene.VectorGeometry

Normalize a plane so that point evaluation = plane distance. }
NormalizeQuaternion GLScene.VectorGeometry

Normalizes the given quaternion
NormalizeVector GLScene.VectorGeometry

Returns the vector transformed to unit length Transforms a vector to unit length
NormalizeVector GLScene.VectorGeometry

Transforms a vector to unit length
NormalizeVector GLScene.VectorGeometry

Transforms a vector to unit length
NormalizeVectorArray GLScene.VectorGeometry

Transforms vectors to unit length
ObjectManager GLS.SceneRegister

Auto-create for object manager
ODERToGLSceneMatrix GLS.ODEUtils

ODERToGLSceneMatrix GLS.ODEUtils

ODERToGLSceneMatrix GLS.ODEUtils

OffsetAABB GLScene.GeometryBB

OffsetAABB GLScene.GeometryBB

Adds delta to min and max of the AABB.
OffsetBB GLScene.GeometryBB

OffsetBB GLScene.GeometryBB

Adds delta to min and max of the BB.
OffsetBBPoint GLScene.GeometryBB

The same as above but uses AddPoint() instead of AddVector().
OffsetFloatArray GLScene.VectorGeometry

OffsetFloatArray GLScene.VectorGeometry

OffsetFloatArray GLScene.VectorGeometry

Adds delta to values in the array. Array size must be a multiple of four
OpenGLFormatToInternalFormat GLScene.TextureFormat

Give a GLScene texture format from openGL texture format
OpenPictureDialog GLS.ImageUtils

Pops up a simple open picture dialog.
OptimizeMesh GLS.MeshBuilder

OptimizeMesh GLS.MeshBuilder

Optimize Mesh (list, default options)
OptimizeMesh GLS.MeshBuilder

OptimizeMesh (object, default options)
OptimizeMesh GLS.MeshBuilder

OptimizeMesh (object, with options)
PackRotationMatrix GLScene.VectorGeometry

Packs an homogeneous rotation matrix to 6 bytes. The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each. Deviation is typically below 0.01% and around 0.1% in worst case situations. Note: quaternion conversion is faster and more robust than an angle decomposition
PAKCreateFileStream GLS.FileVfsPAK

PAKFileStreamExists GLS.FileVfsPAK

ParseFloat GLScene.Utils

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.
ParseInteger GLScene.Utils

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.
Perlin_Random1 GLS.Perlin

just a random controlled by X
Perlin_Random1DStrip GLS.Perlin

generates a random strip
Perlin_Random2 GLS.Perlin

just a random controlled by X,Y
Pitch GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its X-axis
Pitch GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterRight
PixelFormatToColorBits GLS.ImageUtils

Returns the number of color bits associated to the given pixel format.
PlaneAABBIntersection GLScene.GeometryBB

Compute the intersection between a plane and the AABB
PlaneContainsBSphere GLScene.GeometryBB

Determines to which extent a plane contains a BSphere
PlaneEvaluatePoint GLScene.VectorGeometry

PlaneEvaluatePoint GLScene.VectorGeometry

Calculates the cross-product between the plane normal and plane to point vector. This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive. This function performs an homogeneous space dot-product.
PlaneIntersectAABB GLScene.GeometryBB

Checks if a plane (given by the normal+d) intersects the AABB
PlaneMake GLScene.VectorGeometry

PlaneMake GLScene.VectorGeometry

PlaneMake GLScene.VectorGeometry

Computes the parameters of a plane defined by a point and a normal.
PlaneMake GLScene.VectorGeometry

Computes the parameters of a plane defined by three points.
PlayOnWaveOut GLS.Sounds.WaveOut

PlayOnWaveOut GLS.Sounds.WaveOut

PointAdd GLScene.VectorGeometry

Returns the sum of two homogeneous vectors. W coordinate is always 1.
PointDiskOrthoProjection GLScene.VectorGeometry

Computes point to disk projection. Direction has to be normalized
PointDiskProjection GLScene.VectorGeometry

PointInAABB GLScene.GeometryBB

PointInAABB GLScene.GeometryBB

Checks if a point "p" is inside an AABB
PointInPolygon GLScene.VectorGeometry

The code below is from Wm. Randolph Franklin <wrf@ecse.rpi.edu> with some minor modifications for speed. It returns 1 for strictly interior points, 0 for strictly exterior, and 0 or 1 for points on the boundary
PointIsInHalfSpace GLScene.VectorGeometry

PointIsInHalfSpace GLScene.VectorGeometry

PointIsInHalfSpace GLScene.VectorGeometry

Returns true if point is in the half-space defined by a plane with normal. The plane itself is not considered to be in the tested halfspace.
PointLineClosestPoint GLScene.VectorGeometry

Computes closest point on a line
PointLineDistance GLScene.VectorGeometry

Computes algebraic distance between point and line
PointMake GLScene.VectorGeometry

PointMake GLScene.VectorGeometry

PointMake GLScene.VectorGeometry

PointPlaneDistance GLScene.VectorGeometry

PointPlaneDistance GLScene.VectorGeometry

PointPlaneDistance GLScene.VectorGeometry

Computes algebraic distance between point and plane. Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.
PointPlaneOrthoProjection GLScene.VectorGeometry

Computes point to plane projection. Plane and direction have to be normalized
PointPlaneProjection GLScene.VectorGeometry

PointProject GLScene.VectorGeometry

PointProject GLScene.VectorGeometry

Projects p on the line defined by o and direction. Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line
PointQuadOrthoProjection GLScene.VectorGeometry

Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex
PointQuadProjection GLScene.VectorGeometry

PointSegmentClosestPoint GLScene.VectorGeometry

PointSegmentClosestPoint GLScene.VectorGeometry

Computes closest point on a segment (a segment is a limited line)
PointSegmentDistance GLScene.VectorGeometry

Computes algebraic distance between segment and line (a segment is a limited line)
PointTriangleOrthoProjection GLScene.VectorGeometry

Computes point to triangle projection. Direction has to be normalized
PointTriangleProjection GLScene.VectorGeometry

PolygonArea GLScene.VectorGeometry

Computes the polygons's area. Points must be coplanar. Polygon needs not be convex
PolygonSignedArea GLScene.VectorGeometry

Computes a 2D polygon's signed area. Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex
PositionSceneObject GLS.ODEUtils

PositionSceneObjectForGeom GLS.ODEUtils

PowerInt64 GLScene.VectorGeometry

PowerInteger GLScene.VectorGeometry

Raise base to an integer
PowerSingle GLScene.VectorGeometry

Raise base to any power. For fractional exponents, or |exponents| > MaxInt, base must be > 0
PrecisionTimerLap GLScene.Utils

Computes time elapsed since timer start. Return time lap in seconds.
PrepareSinCosCache GLScene.VectorGeometry

Fills up the two given dynamic arrays with sin cos values. start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.
PrimerIsland GLS.RandomHDS

PrimerNull GLS.RandomHDS

Landscape primers
Project GLScene.VectorGeometry

QuaternionConjugate GLScene.VectorGeometry

Returns the conjugate of a quaternion
QuaternionFromAngleAxis GLScene.VectorGeometry

Constructs quaternion from angle (in deg) and axis
QuaternionFromEuler GLScene.VectorGeometry

Constructs quaternion from Euler angles in arbitrary order (angles in degrees)
QuaternionFromMatrix GLScene.VectorGeometry

Constructs a unit quaternion from a rotation matrix
QuaternionFromPoints GLScene.VectorGeometry

Constructs a unit quaternion from two points on unit sphere
QuaternionFromRollPitchYaw GLScene.VectorGeometry

Constructs quaternion from Euler angles
QuaternionMagnitude GLScene.VectorGeometry

Returns the magnitude of the quaternion
QuaternionMake GLScene.VectorGeometry

QuaternionMake GLScene.VectorGeometry

QuaternionMake GLScene.VectorGeometry

Creates a quaternion from the given values
QuaternionMultiply GLScene.VectorGeometry

Returns quaternion product qL * qR. Note: order is important! To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond
QuaternionSlerp GLScene.VectorGeometry

QuaternionSlerp GLScene.VectorGeometry

Spherical linear interpolation of unit quaternions with spins. QStart, QEnd - start and end unit quaternions t - interpolation parameter (0 to 1) Spin - number of extra spin rotations to involve
QuaternionToAffineMatrix GLScene.VectorGeometry

Constructs an affine rotation matrix from (possibly non-unit) quaternion
QuaternionToMatrix GLScene.VectorGeometry

Constructs a rotation matrix from (possibly non-unit) quaternion. Assumes matrix is used to multiply column vector on the left: vnew = mat vold. Works correctly for right-handed coordinate system and right-handed rotations
QuaternionToPoints GLScene.VectorGeometry

Converts a unit quaternion into two points on a unit sphere
QueryPerformanceCounter GLScene.Utils

Returns the current value of the highest-resolution counter. If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.
QueryPerformanceFrequency GLScene.Utils

Returns the frequency of the counter used by QueryPerformanceCounter. Return value is in ticks per second (Hz), returns False if no precision counter is available.
QuestionDlg GLS.ImageUtils

Pops up a simple question dialog with msg and yes/no buttons. Returns True if answer was "yes".
RadianToDeg GLScene.VectorGeometry

RadianToDeg GLScene.VectorGeometry

RaiseLastOSError GLScene.Utils

RaiseOpenGLError GLScene.OpenGL4

Clears all pending OpenGL errors
RandEmpiric GLScene.RandomLib

Random Number for Empiricle Distribution X[I] - middle of I-interval Fx[I] - cummulative empiricle distribution with values in [0..1]
RandExponent GLScene.RandomLib

RandGauss GLScene.RandomLib

Marsaglia-Bray algorithm
RandLogNorm GLScene.RandomLib

RandNorm GLScene.RandomLib

RandomColorVector GLS.ODEUtils

RandomPointOnSphere GLScene.VectorGeometry

Generates a random point on the unit sphere. Point repartition is correctly isotropic with no privilegied direction
Random_Beta GLScene.RandomLib

Random_Beta GLScene.RandomLib

Generates a random variate in [0,1] FROM A BETA DISTRIBUTION WITH DENSITY PROPORTIONAL TO BETA**(AA-1) * (1-BETA)**(BB-1). USING CHENG'S LOG LOGISTIC METHOD. AA = Shape PARAMETER FROM DISTRIBUTION (0 < REAL) BB = Shape PARAMETER FROM DISTRIBUTION (0 < REAL)
Random_Binomial1 GLScene.RandomLib

Random_Binomial1 GLScene.RandomLib

GENERATES A RANDOM BINOMIAL VARIATE USING C.D.Kemp's method. This algorithm is suitable when many random variates are required with the SAME parameter values for n & p. P = Bernoulli SUCCESS PROBABILITY (0 <= REAL <= 1) N = Number of Bernoulli trials (1 <= INTEGER) Reference: Kemp, C.D. (1986). `A modal method for generating binomial variables', Commun. Statist. - Theor. Meth. 15(3), 805-813.
Random_Binomial2 GLScene.RandomLib

FIRST –> Set FIRST = .TRUE. for the first call to perform initialization the set FIRST = .FALSE. for further calls using the same pair of parameter values (N, P). LOGICAL FIRST random_binomial2 <– A random deviate yielding the number of events from N independent trials, each of which has a probability of event P. INTEGER –> random_binomial Method: This is algorithm BTPE from: Kachitvichyanukul, V. and Schmeiser, B. W. Binomial Random Variate Generation. Communications of the ACM, 31, 2 (February, 1988) 216.
Random_Binomial2 GLScene.RandomLib

Generates a single random deviate from a binomial distribution whose number of trials is N and whose probability of an event in each trial is P.

Arguments N –> The number of trials in the binomial distribution from which a random deviate is to be generated. INTEGER N P –> The probability of an event in each trial of the binomial distribution from which a random deviate is to be generated. REAL P
Random_Cauchy GLScene.RandomLib

Random_Cauchy GLScene.RandomLib

Generate a random deviate from the standard Cauchy distribution
Random_ChiSq GLScene.RandomLib

Random_ChiSq GLScene.RandomLib

Generates a random variate from the chi-squared distribution with dff degrees of freedom.
Random_Exponential GLScene.RandomLib

Random_Exponential GLScene.RandomLib

Generates a random variate in [0,INFINITY) FROM A NEGATIVE EXPONENTIAL DlSTRIBUTION WlTH DENSITY PROPORTIONAL TO EXP(-random_exponential), USING INVERSION.
Random_Gamma GLScene.RandomLib

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL)
Random_Gamma GLScene.RandomLib

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL).
Random_Gamma1 GLScene.RandomLib

Uses the algorithm in Marsaglia, G. and Tsang, W.W. (2000) 'A simple method for generating gamma variables', Trans. om Math. Software (TOMS), vol.26(3), pp.363-372. Generates a random gamma deviate for shape parameter Shape >= 1.
Random_Inv_Gauss GLScene.RandomLib

Random_Inv_Gauss GLScene.RandomLib

Generates a random variate in [0,INFINITY] FROM A REPARAMETERISED GENERALISED INVERSE GAUSSIAN (GIG) DISTRIBUTION WITH DENSITY PROPORTIONAL TO GIG**(H-1) * EXP(-0.5*B*(GIG+1/GIG)) USING A RATIO METHOD.

h = PARAMETER OF DISTRIBUTION (0 <= REAL) b = PARAMETER OF DISTRIBUTION (0 < REAL)
Random_LogNormal GLScene.RandomLib

Adapted from approach suggested by Greg Hood, used with Permission.
Random_LogNormal GLScene.RandomLib

Adapted from approach suggested by Greg Hood, used with Permission.
Random_MVNorm GLScene.RandomLib

Random_MVNorm GLScene.RandomLib

GENERATES AN N VARIATE RANDOM NORMAL Vector USING A CHOLESKY DECOMPOSITION.

ARGUMENTS: N = NUMBER OF VARIATES IN Vector (INPUT,INTEGER >= 1) H(J) = J'TH ELEMENT OF Vector OF MEANS (INPUT,REAL) X(J) = J'TH ELEMENT OF DELIVERED Vector (OUTPUT,REAL)

D(J*(J-1)/2+I) = (I,J)'TH ELEMENT OF VARIANCE MATRIX (J> = I) (INPUT,REAL) F((J-1)*(2*N-J)/2+I) = (I,J)'TH ELEMENT OF LOWER TRIANGULAR DECOMPOSITION OF VARIANCE MATRIX (J <= I) (OUTPUT,REAL) ier = 1 if the input covariance matrix is not +ve definite = 0 otherwise
Random_Neg_Binomial GLScene.RandomLib

Random_Neg_Binomial GLScene.RandomLib

GENERATES A RANDOM NEGATIVE BINOMIAL VARIATE USING UNSTORED INVERSION AND/OR THE REPRODUCTIVE PROPERTY. SK = NUMBER OF FAILURES REQUIRED (Dagpunar's words!) = the `power' parameter of the negative binomial (0 < REAL) P = BERNOULLI SUCCESS PROBABILITY (0 < REAL < 1) THE PARAMETER H IS SET SO THAT UNSTORED INVERSION ONLY IS USED WHEN P <= H, OTHERWISE A COMBINATION OF UNSTORED INVERSION AND THE REPRODUCTIVE PROPERTY IS USED.
Random_Normal GLScene.RandomLib

Random_Normal GLScene.RandomLib

Random_Normal GLScene.RandomLib

Adapted from COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. Returns a normally distributed pseudo-random number with zero mean and unit variance. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves
Random_Normal GLScene.RandomLib

Adapted from the following Fortran 77 code ALGORITHM 712, COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves Returns a normally distributed pseudo-random number with zero mean and unit variance
Random_Poisson GLScene.RandomLib

Random_Poisson GLScene.RandomLib

Generates a single random deviate from a Poisson distribution with mean mu. Arguments: mu –> The mean of the Poisson distribution from which a random deviate is to be generated. REAL mu Method: For details see Ahrens, J.H. and Dieter, U. Computer Generation of Poisson Deviates From Modified Normal Distributions. ACM Trans. Math. Software, 8, 2 (June 1982),163-179

TABLES: COEFFICIENTS A0-A7 FOR STEP F. FACTORIALS FACT COEFFICIENTS A(K) - FOR PX = FK*V*V*SUM(A(K)*V**K)-DEL
Random_T GLScene.RandomLib

Random_T GLScene.RandomLib

Generates a random variate FROM A T DISTRIBUTION USING KINDERMAN AND MONAHAN'S RATIO METHOD. DF = DEGREES OF FREEDOM OF DISTRIBUTION (DF >= 1)
Random_von_Mises GLScene.RandomLib

Random_von_Mises GLScene.RandomLib

Algorithm VMD Arguments: k (real) - parameter of the von Mises distribution.
Random_Weibull GLScene.RandomLib

Random_Weibull GLScene.RandomLib

Generates a random variate from the Weibull distribution with probability density: a a-1 -x f(x) = a.x e
RandUniform GLScene.RandomLib

RandUniform GLScene.RandomLib

Uniform Random single numbers in RLow..RHigh range
RasterFileFormatExtensionByIndex GLS.Graphics

Returns an extension by its index in the internal image files dialogs filter. Use InternalImageFileFormatsFilter to obtain the filter.
RayCastAABBIntersect GLScene.GeometryBB

RayCastAABBIntersect GLScene.GeometryBB

Finds the intersection between a ray and an axis aligned bounding box.
RayCastBoxIntersect GLScene.VectorGeometry

Compute intersection between a ray and a box. Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil
RayCastIntersectsSphere GLScene.VectorGeometry

Determines if a ray will intersect with a given sphere
RayCastMinDistToPoint GLScene.VectorGeometry

Compute the min distance a ray will pass to a point
RayCastPlaneIntersect GLScene.VectorGeometry

Compute intersection between a ray and a plane. Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil
RayCastPlaneXZIntersect GLScene.VectorGeometry

RayCastSphereIntersect GLScene.VectorGeometry

Calculates the intersections between a sphere and a ray. Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined)
RayCastTriangleIntersect GLScene.VectorGeometry

Compute intersection between a ray and a triangle
ReadCRLFString GLScene.Utils

Read a CRLF terminated string from a stream. The CRLF is NOT in the returned string.
ReadExtensions GLScene.OpenGL4

ReadImplementationProperties GLScene.OpenGL4

ReadLine GLScene.Logger

ReadModuleData ModuleLoader

ReadMotorolaNumber Formats.LWO

ReadOpenALExtensions OpenAL.Import

ReadS0 Formats.LWO

ReadScreenImage GLS.Screen

ReadVideoModes GLS.Screen

ReadVXAsU4 Formats.LWO

ReadWGLExtensions GLScene.OpenGL4

ReadWGLImplementationProperties GLScene.OpenGL4

RectangleContains GLScene.VectorGeometry

Determine if BigRect completely contains SmallRect
RectanglesIntersect GLScene.VectorGeometry

Determine if 2 rectanges intersect
RectEquals GLScene.VectorGeometry

True if all components are equal.
Register GLS.CgRegister

using TGLLibMaterialNameProperty
Register GLS.CUDA.Register

Register GLS.FullScreenViewer

Register GLS.Physics.Register

Register GLS.Pythons.Script

Register GLS.SceneRegister

Register Components
Register GLS.SDL.Context

Register GLS.SDL.Window

function getenv(const name: PAnsiChar): PAnsiChar;
Register GLS.Sounds.Register

Register GLS.XCollectionRegister

RegisterArchiveFormat GLS.ArchiveManager

RegisterChunkClass Formats.LWO

RegisterCUDAComponentNameChangeEvent GLS.CUDA.APIComps

RegisterGLBaseSceneObjectNameChangeEvent GLS.Scene

Register an event handler triggered by any TGLBaseSceneObject Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by GLSceneEdit in the IDE.
RegisterGLBehaviourNameChangeEvent GLS.Scene

Register an event handler triggered by any TGLBehaviour Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.
RegisterGLContextClass GLS.Context

Drivers should register themselves via this function.
RegisterGLMaterialExNameChangeEvent GLS.MaterialEx

RegisterGLSceneObject GLS.ODEManager

GLODEObject register methods (used for joint object persistence)
RegisterGLTextureImageClass GLS.Texture

Register a TGLTextureImageClass (used for persistence and IDE purposes)
RegisterGLTextureImageEditor GLS.TextureImageEditors

RegisterInfoForm GLS.Scene

Registers the procedure call used to invoke the info form.
RegisterManager GLScene.Manager

RegisterRasterFormat GLS.Graphics

RegisterSoundFileFormat GLS.SoundFileObjects

RegisterTGraphicClassFileExtension GLS.Texture

RegisterUniformAutoSetMethod GLSL.ShaderParameter

RegisterVectorFileFormat GLS.VectorFileObjects

RegisterXCollectionDestroyEvent GLScene.XCollection

Registers an event to be called when an XCollection is destroyed
RegisterXCollectionItemClass GLScene.XCollection

Registers a TXCollectionItem subclass for persistence requirements
RelativePath GLScene.Utils

Remove if possible part of path witch leads to project executable.
ReleaseAmbientLightMotion Formats.m3DSUtils

ReleaseCamera Formats.m3DSUtils

ReleaseCameraMotion Formats.m3DSUtils

ReleaseChunk Formats.m3DSUtils

ReleaseChunkList Formats.m3DSUtils

ReleaseFontManager GLS.SpaceText

ReleaseGLCUDAEditorForm FmCUDAEditor

ReleaseGLSceneEditorForm FmSceneEditor

ReleaseGLShaderEditor FmShaderMemo

ReleaseGUILayoutEditorForm FmGuiLayoutEditor

ReleaseLibMaterialPickerForm FmLibMaterialPicker

ReleaseLight Formats.m3DSUtils

ReleaseMaterial Formats.m3DSUtils

ReleaseMaterialEditorForm FmMaterialEditor

ReleaseMeshObj Formats.m3DSUtils

ReleaseNx PhysX.Import

ReleaseObjectMotion Formats.m3DSUtils

ReleaseOmnilightMotion Formats.m3DSUtils

ReleaseShaderUniformEditor FmShaderUniformEditor

ReleaseSpotlightMotion Formats.m3DSUtils

ReleaseVectorEditorForm FmVectorEditor

ReleaseXCollectionEditor FmXCollectionEditor

Release_Memory_Isoline GLS.Isolines

RemapAndCleanupReferences GLS.MeshUtils

Alters a reference/indice pair and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.
remapIndices GLS.MeshUtils

Remaps a list of indices. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]
RemapIndicesToIndicesMap GLS.MeshUtils

Creates an indices map from a remap list. The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear? In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices. Any simpler documentation of this function welcome ;)
RemapReferences GLS.MeshUtils

RemapReferences GLS.MeshUtils

Alters a reference array and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.
RemapTrianglesIndices GLS.MeshUtils

Remaps a list of triangles vertex indices and remove degenerate triangles. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]
RemoveDomainForComponent gnugettext

RemoveDomainForResourceString gnugettext

RenderAABB GLS.SpacePartition

RenderAABB GLS.SpacePartition

Renders an AABB as a line
RenderGeomList GLS.ODEUtils

RenderSpatialPartitioning GLS.SpacePartition

Render a spacial partitioning descending from TGLSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation
RescaleImage GLS.ImageUtils

RestoreDefaultMode GLS.Screen

RetranslateComponent gnugettext

ReverseByteOrder Formats.LWO

RGB24ToRGBA32 GLS.Graphics

Rgbe2float GLScene.RGBE

RLength GLScene.VectorGeometry

Computes 1/Sqrt(Sqr(x)+Sqr(y)).
Roll GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its Z-axis
Roll GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterDirection
RotateVector GLScene.VectorGeometry

Rotates Vector about Axis with Angle radians
RotateVector GLScene.VectorGeometry

Rotates Vector about Axis with Angle radians
RotateVectorAroundY GLScene.VectorGeometry

Rotate given vector around the Y axis (alpha is in rad)
RoundDownToPowerOf2 GLScene.Utils

Round down to the nearest power of two, value must be strictly positive
RoundInt GLScene.VectorGeometry

RoundInt GLScene.VectorGeometry

Rounds the floating point value to the closest integer. Behaves like Round but returns a floating point value like Int.
RoundUpToPowerOf2 GLScene.Utils

Round ups to the nearest power of two, value must be positive
RSqrt GLScene.VectorGeometry

—————————————————————————— Miscellanious math functions —————————————————————————— Computes 1/Sqrt(v)
RstVector GLScene.VectorGeometry

RstVector GLScene.VectorGeometry

RyuDoubleToString PasDblStrUtils

RyuStringToDouble PasDblStrUtils

RyuStringToDouble PasDblStrUtils

SafeCurrentGLContext GLS.Context

SaveAnsiStringToFile GLScene.Utils

Saves ansistring "data" to "filename".
SaveComponentToFile GLScene.Utils

Saves component to a file.
SavePictureDialog GLS.ImageUtils

Pops up a simple save picture dialog.
SaveSDLBMPToStream SDL.Import

SaveStringToFile GLScene.Utils

Saves string "data" to "filename".
ScaleAndRound GLScene.VectorGeometry

Multiples i by s and returns the rounded result.
ScaleFloatArray GLScene.VectorGeometry

ScaleFloatArray GLScene.VectorGeometry

Multiplies values in the array by factor. This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items. Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available
ScaleMatrix GLScene.VectorGeometry

Multiplies all elements of a 3x3 matrix with a factor
ScaleMatrix GLScene.VectorGeometry

Multiplies all elements of a 4x4 matrix with a factor
ScaleVector GLScene.VectorGeometry

Scales given vector by a factor
ScaleVector GLScene.VectorGeometry

Scales given vector by a factor
ScaleVector GLScene.VectorGeometry

Scales given vector by a factor
ScaleVector GLScene.VectorGeometry

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.
ScaleVector GLScene.VectorGeometry

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.
SDK_Version PhysX.Import

SDLStreamCloseRWops SDL.Import

SDLStreamSetup SDL.Import

SDL_AddEventWatch SDL.Import

** * Add a function which is called when an event is added to the queue. *
SDL_AddHintCallback SDL.Import

SDL_AddTimer SDL.Import

** * Add a new timer to the pool of timers already running. * * A timer ID, or NULL when an error occurs. *
SDL_AllocFormat SDL.Import

** * Create an SDL_PixelFormat structure from a pixel format enum. *
SDL_AllocPalette SDL.Import

** * Create a palette structure with the specified number of color * entries. * * A new palette, or nil if there wasn't enough memory. * * The palette entries are initialized to white. * * SDL_FreePalette() *
SDL_AllocRW SDL.Import

*RWFrom functions*
SDL_AudioDeviceConnected SDL.Import

** * 1 if audio device is still functioning, zero if not, -1 on error. *
SDL_AudioInit SDL.Import

** * Initialization and cleanup * * These functions are used internally, and should not be used unless * you have a specific need to specify the audio driver you want to * use. You should normally use SDL_Init() or SDL_InitSubSystem(). *
SDL_AudioQuit SDL.Import

SDL_AUDIO_BITSIZE SDL.Import

SDL_AUDIO_ISBIGENDIAN SDL.Import

SDL_AUDIO_ISFLOAT SDL.Import

SDL_AUDIO_ISINT SDL.Import

SDL_AUDIO_ISLITTLEENDIAN SDL.Import

SDL_AUDIO_ISSIGNED SDL.Import

SDL_AUDIO_ISUNSIGNED SDL.Import

SDL_BITSPERPIXEL SDL.Import

SDL_BuildAudioCVT SDL.Import

** * This function takes a source format and rate and a destination format * and rate, and initializes the cvt structure with information needed * by SDL_ConvertAudio() to convert a buffer of audio data from one format * to the other. * * -1 if the format conversion is not supported, 0 if there's * no conversion needed, or 1 if the audio filter is set up. *
SDL_BYTESPERPIXEL SDL.Import

SDL_CalculateGammaRamp SDL.Import

** * Calculate a 256 entry gamma ramp for a gamma value. *
SDL_ClearError SDL.Import

SDL_ClearHints SDL.Import

/** * \brief Clear all hints * * This function is called during SDL_Quit() to free stored hints. */
SDL_CloseAudio SDL.Import

** * This function shuts down audio processing and closes the audio device. *
SDL_CloseAudioDevice SDL.Import

SDL_COMPILEDVERSION SDL.Import

** * This is the version number macro for the current SDL version. *
SDL_CondBroadcast SDL.Import

** * Restart all threads that are waiting on the condition variable. * * 0 or -1 on error. *
SDL_CondSignal SDL.Import

** * Restart one of the threads that are waiting on the condition variable. * * 0 or -1 on error. *
SDL_CondWait SDL.Import

** * Wait on the condition variable, unlocking the provided mutex. * * The mutex must be locked before entering this function! * * The mutex is re-locked once the condition variable is signaled. * * 0 when it is signaled, or -1 on error. *
SDL_CondWaitTimeout SDL.Import

** * Waits for at most ms milliseconds, and returns 0 if the condition * variable is signaled, SDL_MUTEX_TIMEDOUT if the condition is not * signaled in the allotted time, and -1 on error. * * On some platforms this function is implemented by looping with a * delay of 1 ms, and so should be avoided if possible. *
SDL_ConvertAudio SDL.Import

** * Once you have initialized the cvt structure using SDL_BuildAudioCVT(), * created an audio buffer cvt->buf, and filled it with cvt->len bytes of * audio data in the source format, this function will convert it in-place * to the desired format. * * The data conversion may expand the size of the audio data, so the buffer * cvt->buf should be allocated after the cvt structure is initialized by * SDL_BuildAudioCVT(), and should be cvt->len*cvt->len_mult bytes long. *
SDL_ConvertPixels SDL.Import

** * Copy a block of pixels of one format to another format * * 0 on success, or -1 if there was an error *
SDL_ConvertSurface SDL.Import

** * Creates a new surface of the specified format, and then copies and maps * the given surface to it so the blit of the converted surface will be as * fast as possible. If this function fails, it returns NULL. * * The flags parameter is passed to SDL_CreateRGBSurface() and has those * semantics. You can also pass SDL_RLEACCEL in the flags parameter and * SDL will try to RLE accelerate colorkey and alpha blits in the resulting * surface. *
SDL_ConvertSurfaceFormat SDL.Import

SDL_CreateColorCursor SDL.Import

** * Create a color cursor. * * SDL_FreeCursor() *
SDL_CreateCond SDL.Import

** * Create a condition variable. * * Typical use of condition variables: * * Thread A: * SDL_LockMutex(lock); * while ( not condition ) * begin * SDL_CondWait(cond, lock); * end; * SDL_UnlockMutex(lock); * * Thread B: * SDL_LockMutex(lock); * ... * condition := true; * ... * SDL_CondSignal(cond); * SDL_UnlockMutex(lock); * * There is some discussion whether to signal the condition variable * with the mutex locked or not. There is some potential performance * benefit to unlocking first on some platforms, but there are some * potential race conditions depending on how your code is structured. * * In general it's safer to signal the condition variable while the * mutex is locked. *
SDL_CreateCursor SDL.Import

** * Create a cursor, using the specified bitmap data and * mask (in MSB format). * * The cursor width must be a multiple of 8 bits. * * The cursor is created in black and white according to the following: * <table> * <tr><td> data </td><td> mask </td><td> resulting pixel on screen </td></tr> * <tr><td> 0 </td><td> 1 </td><td> White </td></tr> * <tr><td> 1 </td><td> 1 </td><td> Black </td></tr> * <tr><td> 0 </td><td> 0 </td><td> Transparent </td></tr> * <tr><td> 1 </td><td> 0 </td><td> Inverted color if possible, black * if not. </td></tr> * </table> * * SDL_FreeCursor() *
SDL_CreateMutex SDL.Import

** * Create a mutex, initialized unlocked. *
SDL_CreateRenderer SDL.Import

** * Create a 2D rendering context for a window. * * window The window where rendering is displayed. * index The index of the rendering driver to initialize, or -1 to * initialize the first one supporting the requested flags. * flags ::SDL_RendererFlags. * * A valid rendering context or NULL if there was an error. * * SDL_CreateSoftwareRenderer() * SDL_GetRendererInfo() * SDL_DestroyRenderer() *
SDL_CreateRGBSurface SDL.Import

** * Allocate and free an RGB surface. * * If the depth is 4 or 8 bits, an empty palette is allocated for the surface. * If the depth is greater than 8 bits, the pixel format is set using the * flags '[RGB]mask'. * * If the function runs out of memory, it will return NULL. * * flags The flags are obsolete and should be set to 0. *
SDL_CreateRGBSurfaceFrom SDL.Import

SDL_CreateSemaphore SDL.Import

** * Create a semaphore, initialized with value, returns NULL on failure. *
SDL_CreateShapedWindow SDL.Import

** * Create a window that can be shaped with the specified position, dimensions, and flags. * * title The title of the window, in UTF-8 encoding. * x The x position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * y The y position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * w The width of the window. * h The height of the window. * flags The flags for the window, a mask of SDL_WINDOW_BORDERLESS with any of the following: * SDL_WINDOW_OPENGL, SDL_WINDOW_INPUT_GRABBED, * SDL_WINDOW_SHOWN, SDL_WINDOW_RESIZABLE, * SDL_WINDOW_MAXIMIZED, SDL_WINDOW_MINIMIZED, * SDL_WINDOW_BORDERLESS is always set, and SDL_WINDOW_FULLSCREEN is always unset. * * The window created, or NULL if window creation failed. * * SDL_DestroyWindow() *
SDL_CreateSoftwareRenderer SDL.Import

** * Create a 2D software rendering context for a surface. * * surface The surface where rendering is done. * * A valid rendering context or NULL if there was an error. * * SDL_CreateRenderer() * SDL_DestroyRenderer() *
SDL_CreateSystemCursor SDL.Import

** * Create a system cursor. * * SDL_FreeCursor() *
SDL_CreateTexture SDL.Import

** * Create a texture for a rendering context. * * renderer The renderer. * format The format of the texture. * access One of the enumerated values in ::SDL_TextureAccess. * w The width of the texture in pixels. * h The height of the texture in pixels. * * The created texture is returned, or 0 if no rendering context was * active, the format was unsupported, or the width or height were out * of range. * * SDL_QueryTexture() * SDL_UpdateTexture() * SDL_DestroyTexture() *
SDL_CreateTextureFromSurface SDL.Import

** * Create a texture from an existing surface. * * renderer The renderer. * surface The surface containing pixel data used to fill the texture. * * The created texture is returned, or 0 on error. * * The surface is not modified or freed by this function. * * SDL_QueryTexture() * SDL_DestroyTexture() *
SDL_CreateThread SDL.Import

** * Create a thread. *
SDL_CreateThread SDL.Import

** * Create a thread. *
SDL_CreateWindow SDL.Import

** * Create a window with the specified position, dimensions, and flags. * * title The title of the window, in UTF-8 encoding. * x The x position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * y The y position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * w The width of the window. * h The height of the window. * flags The flags for the window, a mask of any of the following: * ::SDL_WINDOW_FULLSCREEN, ::SDL_WINDOW_OPENGL, * ::SDL_WINDOW_SHOWN, ::SDL_WINDOW_BORDERLESS, * ::SDL_WINDOW_RESIZABLE, ::SDL_WINDOW_MAXIMIZED, * ::SDL_WINDOW_MINIMIZED, ::SDL_WINDOW_INPUT_GRABBED. * * The id of the window created, or zero if window creation failed. * * SDL_DestroyWindow() *
SDL_CreateWindowAndRenderer SDL.Import

** * Create a window and default renderer * * width The width of the window * height The height of the window * window_flags The flags used to create the window * window A pointer filled with the window, or NULL on error * renderer A pointer filled with the renderer, or NULL on error * * 0 on success, or -1 on error *
SDL_CreateWindowFrom SDL.Import

** * Create an SDL window from an existing native window. * * data A pointer to driver-dependent window creation data * * The id of the window created, or zero if window creation failed. * * SDL_DestroyWindow() *
SDL_Delay SDL.Import

** * Wait a specified number of milliseconds before returning. *
SDL_DelEventWatch SDL.Import

** * Remove an event watch function added with SDL_AddEventWatch() *
SDL_DelHintCallback SDL.Import

/** * \brief Remove a function watching a particular hint * * \param name The hint being watched * \param callback The function being called when the hint value changes * \param userdata A pointer being passed to the callback function */
SDL_DestroyCond SDL.Import

** * Destroy a condition variable. *
SDL_DestroyMutex SDL.Import

** * Destroy a mutex. *
SDL_DestroyRenderer SDL.Import

** * Destroy the rendering context for a window and free associated * textures. * * SDL_CreateRenderer() *
SDL_DestroySemaphore SDL.Import

** * Destroy a semaphore. *
SDL_DestroyTexture SDL.Import

** * Destroy the specified texture. * * SDL_CreateTexture() * SDL_CreateTextureFromSurface() *
SDL_DestroyWindow SDL.Import

** * Destroy a window. *
SDL_DisableScreenSaver SDL.Import

** * Prevent the screen from being blanked by a screensaver * * SDL_IsScreenSaverEnabled() * SDL_EnableScreenSaver() *
SDL_EnableScreenSaver SDL.Import

** * Allow the screen to be blanked by a screensaver * * SDL_IsScreenSaverEnabled() * SDL_DisableScreenSaver() *
SDL_EnclosePoints SDL.Import

** * Calculate a minimal rectangle enclosing a set of points * * SDL_TRUE if any points were within the clipping rect *
SDL_Error SDL.Import

* SDL_Error() unconditionally returns -1. *
SDL_EventState SDL.Import

** * This function allows you to set the state of processing certain events. * - If state is set to SDL_IGNORE, that event will be automatically * dropped from the event queue and will not event be filtered. * - If state is set to SDL_ENABLE, that event will be processed * normally. * - If state is set to SDL_QUERY, SDL_EventState() will return the * current processing state of the specified event. *
SDL_FillRect SDL.Import

** * Performs a fast fill of the given rectangle with color. * * If rect is NULL, the whole surface will be filled with color. * * The color should be a pixel of the format used by the surface, and * can be generated by the SDL_MapRGB() function. * * 0 on success, or -1 on error. *
SDL_FillRects SDL.Import

SDL_FilterEvents SDL.Import

** * Run the filter function on the current event queue, removing any * events for which the filter returns 0. *
SDL_FlushEvent SDL.Import

** * This function clears events from the event queue *
SDL_FlushEvents SDL.Import

SDL_FreeCursor SDL.Import

** * Frees a cursor created with SDL_CreateCursor(). * * SDL_CreateCursor() *
SDL_FreeFormat SDL.Import

** * Free an SDL_PixelFormat structure. *
SDL_FreePalette SDL.Import

** * Free a palette created with SDL_AllocPalette(). * * SDL_AllocPalette() *
SDL_FreeRW SDL.Import

SDL_FreeSurface SDL.Import

SDL_FreeWAV SDL.Import

** * This function frees data previously allocated with SDL_LoadWAV_RW() *
SDL_GameControllerAddMapping SDL.Import

** * Add or update an existing mapping configuration * * 1 if mapping is added, 0 if updated, -1 on error *
SDL_GameControllerClose SDL.Import

** * Close a controller previously opened with SDL_GameControllerOpen(). *
SDL_GameControllerEventState SDL.Import

** * Enable/disable controller event polling. * * If controller events are disabled, you must call SDL_GameControllerUpdate() * yourself and check the state of the controller when you want controller * information. * * The state can be one of ::SDL_QUERY, ::SDL_ENABLE or ::SDL_IGNORE. *
SDL_GameControllerGetAttached SDL.Import

** * Returns SDL_TRUE if the controller has been opened and currently connected, * or SDL_FALSE if it has not. *
SDL_GameControllerGetAxis SDL.Import

** * Get the current state of an axis control on a game controller. * * The state is a value ranging from -32768 to 32767. * * The axis indices start at index 0. *
SDL_GameControllerGetAxisFromString SDL.Import

** * turn this string into a axis mapping *
SDL_GameControllerGetBindForAxis SDL.Import

** * Get the SDL joystick layer binding for this controller button mapping *
SDL_GameControllerGetBindForButton SDL.Import

** * Get the SDL joystick layer binding for this controller button mapping *
SDL_GameControllerGetButton SDL.Import

** * Get the current state of a button on a game controller. * * The button indices start at index 0. *
SDL_GameControllerGetButtonFromString SDL.Import

** * turn this string into a button mapping *
SDL_GameControllerGetJoystick SDL.Import

** * Get the underlying joystick object used by a controller *
SDL_GameControllerGetStringForAxis SDL.Import

** * turn this axis enum into a string mapping *
SDL_GameControllerGetStringForButton SDL.Import

** * turn this button enum into a string mapping *
SDL_GameControllerMapping SDL.Import

** * Get a mapping string for an open GameController * * the mapping string. Must be freed with SDL_free. Returns NULL if no mapping is available *
SDL_GameControllerMappingForGUID SDL.Import

** * Get a mapping string for a GUID * * the mapping string. Must be freed with SDL_free. Returns NULL if no mapping is available *
SDL_GameControllerName SDL.Import

** * Return the name for this currently opened controller *
SDL_GameControllerNameForIndex SDL.Import

** * Get the implementation dependent name of a game controller. * This can be called before any controllers are opened. * If no name can be found, this function returns NULL. *
SDL_GameControllerOpen SDL.Import

** * Open a game controller for use. * The index passed as an argument refers to the N'th game controller on the system. * This index is the value which will identify this controller in future controller * events. * * A controller identifier, or NULL if an error occurred. *
SDL_GameControllerUpdate SDL.Import

** * Update the current state of the open game controllers. * * This is called automatically by the event loop if any game controller * events are enabled. *
SDL_GetAudioDeviceName SDL.Import

** * Get the human-readable name of a specific audio device. * Must be a value between 0 and (number of audio devices-1). * Only valid after a successfully initializing the audio subsystem. * The values returned by this function reflect the latest call to * SDL_GetNumAudioDevices(); recall that function to redetect available * hardware. * * The string returned by this function is UTF-8 encoded, read-only, and * managed internally. You are not to free it. If you need to keep the * string for any length of time, you should make your own copy of it, as it * will be invalid next time any of several other SDL functions is called. *
SDL_GetAudioDeviceStatus SDL.Import

SDL_GetAudioDriver SDL.Import

SDL_GetAudioStatus SDL.Import

SDL_GetClipRect SDL.Import

** * Gets the clipping rectangle for the destination surface in a blit. * * rect must be a pointer to a valid rectangle which will be filled * with the correct values. *
SDL_GetClosestDisplayMode SDL.Import

** * Get the closest match to the requested display mode. * * mode The desired display mode * closest A pointer to a display mode to be filled in with the closest * match of the available display modes. * * The passed in value closest, or nil if no matching video mode * was available. * * The available display modes are scanned, and closest is filled in with the * closest mode matching the requested mode and returned. The mode format and * refresh_rate default to the desktop mode if they are 0. The modes are * scanned with size being first priority, format being second priority, and * finally checking the refresh_rate. If all the available modes are too * small, then nil is returned. * * SDL_GetNumDisplayModes() * SDL_GetDisplayMode() *
SDL_GetColorKey SDL.Import

** * Gets the color key (transparent pixel) in a blittable surface. * * surface The surface to update * key A pointer filled in with the transparent pixel in the native * surface format * * 0 on success, or -1 if the surface is not valid or colorkey is not * enabled. *
SDL_GetCurrentAudioDriver SDL.Import

** * This function returns the name of the current audio driver, or NULL * if no driver has been initialized. *
SDL_GetCurrentDisplayMode SDL.Import

** * Fill in information about the current display mode. *
SDL_GetCurrentVideoDriver SDL.Import

** * Returns the name of the currently initialized video driver. * * The name of the current video driver or nil if no driver * has been initialized * * SDL_GetNumVideoDrivers() * SDL_GetVideoDriver() *
SDL_GetCursor SDL.Import

** * Return the active cursor. *
SDL_GetDesktopDisplayMode SDL.Import

** * Fill in information about the desktop display mode. *
SDL_GetDisplayBounds SDL.Import

** * Get the desktop area represented by a display, with the primary * display located at 0,0 * * 0 on success, or -1 if the index is out of range. * * SDL_GetNumVideoDisplays() *
SDL_GetDisplayMode SDL.Import

** * Fill in information about a specific display mode. * * The display modes are sorted in this priority: * bits per pixel -> more colors to fewer colors * width -> largest to smallest * height -> largest to smallest * refresh rate -> highest to lowest * * SDL_GetNumDisplayModes() *
SDL_GetDisplayName SDL.Import

** * Get the name of a display in UTF-8 encoding * * The name of a display, or nil for an invalid display index. * * SDL_GetNumVideoDisplays() *
SDL_getenv GLS.SDL.Window

function SDL_getenv(const name: PAnsiChar): PAnsiChar; cdecl; external LibName;
SDL_GetError SDL.Import

SDL_GetEventFilter SDL.Import

** * Return the current event filter - can be used to "chain" filters. * If there is no event filter set, this function returns SDL_FALSE. *
SDL_GetEventState SDL.Import

SDL_GetHint SDL.Import

/** * \brief Get a hint * * \return The string value of a hint variable. */
SDL_GetKeyboardFocus SDL.Import

** * Get the window which currently has keyboard focus. *
SDL_GetKeyboardState SDL.Import

** * Get a snapshot of the current state of the keyboard. * * numkeys if non-nil, receives the length of the returned array. * * An array of key states. Indexes into this array are obtained by using SDL_Scancode values. * *
SDL_GetKeyFromName SDL.Import

** * Get a key code from a human-readable name * * key code, or SDLK_UNKNOWN if the name wasn't recognized * * SDL_Keycode *
SDL_GetKeyFromScancode SDL.Import

** * Get the key code corresponding to the given scancode according * to the current keyboard layout. * * See SDL_Keycode for details. * * SDL_GetKeyName() *
SDL_GetKeyName SDL.Import

** * Get a human-readable name for a key. * * A pointer to a UTF-8 string that stays valid at least until the next * call to this function. If you need it around any longer, you must * copy it. If the key doesn't have a name, this function returns an * empty string (""). * * SDL_Key *
SDL_GetModState SDL.Import

** * Get the current key modifier state for the keyboard. *
SDL_GetMouseFocus SDL.Import

** * Get the window which currently has mouse focus. *
SDL_GetMouseState SDL.Import

** * Retrieve the current state of the mouse. * * The current button state is returned as a button bitmask, which can * be tested using the SDL_BUTTON(X) macros, and x and y are set to the * mouse cursor position relative to the focus window for the currently * selected mouse. You can pass nil for either x or y. * * SDL_Button = 1 shl ((X)-1) *
SDL_GetNumAudioDevices SDL.Import

** * Get the number of available devices exposed by the current driver. * Only valid after a successfully initializing the audio subsystem. * Returns -1 if an explicit list of devices can't be determined; this is * not an error. For example, if SDL is set up to talk to a remote audio * server, it can't list every one available on the Internet, but it will * still allow a specific host to be specified to SDL_OpenAudioDevice(). * * In many common cases, when this function returns a value <= 0, it can still * successfully open the default device (NULL for first argument of * SDL_OpenAudioDevice()). *
SDL_GetNumAudioDrivers SDL.Import

** * Driver discovery functions * * These functions return the list of built in audio drivers, in the * order that they are normally initialized by default. *
SDL_GetNumDisplayModes SDL.Import

** * Returns the number of available display modes. * * SDL_GetDisplayMode() *
SDL_GetNumRenderDrivers SDL.Import

** * Get the number of 2D rendering drivers available for the current * display. * * A render driver is a set of code that handles rendering and texture * management on a particular display. Normally there is only one, but * some drivers may have several available with different capabilities. * * SDL_GetRenderDriverInfo() * SDL_CreateRenderer() *
SDL_GetNumTouchDevices SDL.Import

** * Get the number of registered touch devices. *
SDL_GetNumTouchFingers SDL.Import

** * Get the number of active fingers for a given touch device. *
SDL_GetNumVideoDisplays SDL.Import

** * Returns the number of available video displays. * * SDL_GetDisplayBounds() *
SDL_GetNumVideoDrivers SDL.Import

** * Get the number of video drivers compiled into SDL * * SDL_GetVideoDriver() *
SDL_GetPerformanceCounter SDL.Import

** * Get the current value of the high resolution counter *
SDL_GetPerformanceFrequency SDL.Import

** * Get the count per second of the high resolution counter *
SDL_GetPixelFormatName SDL.Import

** * Get the human readable name of a pixel format *
SDL_GetPlatform SDL.Import

** * Gets the name of the platform. *
SDL_GetPowerInfo SDL.Import

** * Get the current power supply details. * * secs Seconds of battery life left. You can pass a NULL here if * you don't care. Will return -1 if we can't determine a * value, or we're not running on a battery. * * pct Percentage of battery life left, between 0 and 100. You can * pass a NULL here if you don't care. Will return -1 if we * can't determine a value, or we're not running on a battery. * * The state of the battery (if any). *
SDL_GetRelativeMouseMode SDL.Import

** * Query whether relative mouse mode is enabled. * * SDL_SetRelativeMouseMode() *
SDL_GetRelativeMouseState SDL.Import

** * Retrieve the relative state of the mouse. * * The current button state is returned as a button bitmask, which can * be tested using the SDL_BUTTON(X) macros, and x and y are set to the * mouse deltas since the last call to SDL_GetRelativeMouseState(). *
SDL_GetRenderDrawBlendMode SDL.Import

** * Get the blend mode used for drawing operations. * * renderer The renderer from which blend mode should be queried. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 on error * * SDL_SetRenderDrawBlendMode() *
SDL_GetRenderDrawColor SDL.Import

** * Get the color used for drawing operations (Rect, Line and Clear). * * renderer The renderer from which drawing color should be queried. * r A pointer to the red value used to draw on the rendering target. * g A pointer to the green value used to draw on the rendering target. * b A pointer to the blue value used to draw on the rendering target. * a A pointer to the alpha value used to draw on the rendering target, * usually SDL_ALPHA_OPAQUE (255). * * 0 on success, or -1 on error *
SDL_GetRenderDriverInfo SDL.Import

** * Get information about a specific 2D rendering driver for the current * display. * * index The index of the driver to query information about. * info A pointer to an SDL_RendererInfo struct to be filled with * information on the rendering driver. * * 0 on success, -1 if the index was out of range. * * SDL_CreateRenderer() *
SDL_GetRenderer SDL.Import

** * Get the renderer associated with a window. *
SDL_GetRendererInfo SDL.Import

** * Get information about a rendering context. *
SDL_GetRendererOutputSize SDL.Import

** * Get the output size of a rendering context. *
SDL_GetRenderTarget SDL.Import

** * Get the current render target or NULL for the default render target. * * The current render target * * SDL_SetRenderTarget() *
SDL_GetRevision SDL.Import

** * Get the code revision of SDL that is linked against your program. * * Returns an arbitrary string (a hash value) uniquely identifying the * exact revision of the SDL library in use, and is only useful in comparing * against other revisions. It is NOT an incrementing number. *
SDL_GetRevisionNumber SDL.Import

** * Get the revision number of SDL that is linked against your program. * * Returns a number uniquely identifying the exact revision of the SDL * library in use. It is an incrementing number based on commits to * hg.libsdl.org. *
SDL_GetRGB SDL.Import

** * Get the RGB components from a pixel of the specified format. * * SDL_GetRGBA *
SDL_GetRGBA SDL.Import

** * Get the RGBA components from a pixel of the specified format. * * SDL_GetRGB *
SDL_GetScancodeFromKey SDL.Import

** * Get the scancode corresponding to the given key code according to the * current keyboard layout. * * See SDL_Scancode for details. * * SDL_GetScancodeName() *
SDL_GetScancodeFromName SDL.Import

** * Get a scancode from a human-readable name * * scancode, or SDL_SCANCODE_UNKNOWN if the name wasn't recognized * * SDL_Scancode *
SDL_GetScancodeName SDL.Import

** * Get a human-readable name for a scancode. * * A pointer to the name for the scancode. * * If the scancode doesn't have a name, this function returns * an empty string (""). * *
SDL_GetShapedWindowMode SDL.Import

** * Get the shape parameters of a shaped window. * * window The shaped window whose parameters should be retrieved. * shape_mode An empty shape-mode structure to fill, or NULL to check whether the window has a shape. * * 0 if the window has a shape and, provided shape_mode was not NULL, shape_mode has been filled with the mode * data, SDL_NONSHAPEABLE_WINDOW if the SDL_Window given is not a shaped window, or SDL_WINDOW_LACKS_SHAPE if * the SDL_Window* given is a shapeable window currently lacking a shape. * * SDL_WindowShapeMode * SDL_SetWindowShape *
SDL_GetSurfaceAlphaMod SDL.Import

** * Get the additional alpha value used in blit operations. * * surface The surface to query. * alpha A pointer filled in with the current alpha value. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceAlphaMod() *
SDL_GetSurfaceBlendMode SDL.Import

** * Get the blend mode used for blit operations. * * surface The surface to query. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceBlendMode() *
SDL_GetSurfaceColorMod SDL.Import

** * Get the additional color value used in blit operations. * * surface The surface to query. * r A pointer filled in with the current red color value. * g A pointer filled in with the current green color value. * b A pointer filled in with the current blue color value. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceColorMod() *
SDL_GetTextureAlphaMod SDL.Import

** * Get the additional alpha value used in render copy operations. * * texture The texture to query. * alpha A pointer filled in with the current alpha value. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureAlphaMod() *
SDL_GetTextureBlendMode SDL.Import

** * Get the blend mode used for texture copy operations. * * texture The texture to query. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureBlendMode() *
SDL_GetTextureColorMod SDL.Import

** * Get the additional color value used in render copy operations. * * texture The texture to query. * r A pointer filled in with the current red color value. * g A pointer filled in with the current green color value. * b A pointer filled in with the current blue color value. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureColorMod() *
SDL_GetThreadID SDL.Import

** * Get the thread identifier for the specified thread. * * Equivalent to SDL_ThreadID() if the specified thread is NULL. *
SDL_GetThreadName SDL.Import

** * Get the thread name, as it was specified in SDL_CreateThread(). * This function returns a pointer to a UTF-8 string that names the * specified thread, or NULL if it doesn't have a name. This is internal * memory, not to be free()'d by the caller, and remains valid until the * specified thread is cleaned up by SDL_WaitThread(). *
SDL_GetTicks SDL.Import

** * Get the number of milliseconds since the SDL library initialization. * * This value wraps if the program runs for more than ~49 days. *
SDL_GetTouchDevice SDL.Import

** * Get the touch ID with the given index, or 0 if the index is invalid. *
SDL_GetTouchFinger SDL.Import

** * Get the finger object of the given touch, with the given index. *
SDL_GetVersion SDL.Import

** * Get the version of SDL that is linked against your program. * * If you are linking to SDL dynamically, then it is possible that the * current version will be different than the version you compiled against. * This function returns the current version, while SDL_VERSION() is a * macro that tells you what version you compiled with. * * * compiled: TSDL_Version; * linked: TSDL_Version; * * SDL_VERSION(@compiled); * SDL_GetVersion(@linked); * WriteLn('We compiled against SDL version: ' + * IntToStr(compiled.major) + * IntToStr(compiled.minor) + * IntToStr(compiled.patch)); * WriteLn('But we linked against SDL version:' + * IntToStr(compiled.major) + * IntToStr(compiled.minor) + * IntToStr(compiled.patch)); * * * This function may be called safely at any time, even before SDL_Init(). * * SDL_VERSION *
SDL_GetVideoDriver SDL.Import

** * Get the name of a built in video driver. * * The video drivers are presented in the order in which they are * normally checked during initialization. * * SDL_GetNumVideoDrivers() *
SDL_GetWindowBrightness SDL.Import

** * Get the brightness (gamma correction) for a window. * * The last brightness value passed to SDL_SetWindowBrightness() * * SDL_SetWindowBrightness() *
SDL_GetWindowData SDL.Import

** * Retrieve the data pointer associated with a window. * * window The window to query. * name The name of the pointer. * * The value associated with 'name' * * SDL_SetWindowData() *
SDL_GetWindowDisplayIndex SDL.Import

** * Get the display index associated with a window. * * the display index of the display containing the center of the * window, or -1 on error. *
SDL_GetWindowDisplayMode SDL.Import

** * Fill in information about the display mode used when a fullscreen * window is visible. * * SDL_SetWindowDisplayMode() * SDL_SetWindowFullscreen() *
SDL_GetWindowFlags SDL.Import

** * Get the window flags. *
SDL_GetWindowFromID SDL.Import

** * Get a window from a stored ID, or nil if it doesn't exist. *
SDL_GetWindowGammaRamp SDL.Import

** * Get the gamma ramp for a window. * * red A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the red channel, or nil. * green A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the green channel, or nil. * blue A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the blue channel, or nil. * * 0 on success, or -1 if gamma ramps are unsupported. * * SDL_SetWindowGammaRamp() *
SDL_GetWindowGrab SDL.Import

** * Get a window's input grab mode. * * This returns SDL_TRUE if input is grabbed, and SDL_FALSE otherwise. * * SDL_SetWindowGrab() *
SDL_GetWindowID SDL.Import

** * Get the numeric ID of a window, for logging purposes. *
SDL_GetWindowMaximumSize SDL.Import

** * Get the maximum size of a window's client area. * * w Pointer to variable for storing the maximum width, may be nil * h Pointer to variable for storing the maximum height, may be nil * * SDL_GetWindowMinimumSize() * SDL_SetWindowMaximumSize() *
SDL_GetWindowMinimumSize SDL.Import

** * Get the minimum size of a window's client area. * * w Pointer to variable for storing the minimum width, may be nil * h Pointer to variable for storing the minimum height, may be nil * * SDL_GetWindowMaximumSize() * SDL_SetWindowMinimumSize() *
SDL_GetWindowPixelFormat SDL.Import

** * Get the pixel format associated with the window. *
SDL_GetWindowPosition SDL.Import

** * Get the position of a window. * * x Pointer to variable for storing the x position, may be nil * y Pointer to variable for storing the y position, may be nil * * SDL_SetWindowPosition() *
SDL_GetWindowSize SDL.Import

** * Get the size of a window's client area. * * w Pointer to variable for storing the width, may be nil * h Pointer to variable for storing the height, may be nil * * SDL_SetWindowSize() *
SDL_GetWindowSurface SDL.Import

** * Get the SDL surface associated with the window. * * The window's framebuffer surface, or nil on error. * * A new surface will be created with the optimal format for the window, * if necessary. This surface will be freed when the window is destroyed. * * You may not combine this with 3D or the rendering API on this window. * * SDL_UpdateWindowSurface() * SDL_UpdateWindowSurfaceRects() *
SDL_GetWindowTitle SDL.Import

** * Get the title of a window, in UTF-8 format. * * SDL_SetWindowTitle() *
SDL_GL_BindTexture SDL.Import

** * Bind the texture to the current OpenGL/ES/ES2 context for use with * OpenGL instructions. * * texture The SDL texture to bind * texw A pointer to a float that will be filled with the texture width * texh A pointer to a float that will be filled with the texture height * * 0 on success, or -1 if the operation is not supported *
SDL_GL_CreateContext SDL.Import

** * Create an OpenGL context for use with an OpenGL window, and make it * current. * * SDL_GL_DeleteContext() *
SDL_GL_DeleteContext SDL.Import

** * Delete an OpenGL context. * * SDL_GL_CreateContext() *
SDL_GL_ExtensionSupported SDL.Import

** * Return true if an OpenGL extension is supported for the current * context. *
SDL_GL_GetAttribute SDL.Import

** * Get the actual value for an attribute from the current context. *
SDL_GL_GetCurrentContext SDL.Import

** * Get the currently active OpenGL context. *
SDL_GL_GetCurrentWindow SDL.Import

** * Get the currently active OpenGL window. *
SDL_GL_GetProcAddress SDL.Import

** * Get the address of an OpenGL function. *
SDL_GL_GetSwapInterval SDL.Import

** * Get the swap interval for the current OpenGL context. * * 0 if there is no vertical retrace synchronization, 1 if the buffer * swap is synchronized with the vertical retrace, and -1 if late * swaps happen immediately instead of waiting for the next retrace. * If the system can't determine the swap interval, or there isn't a * valid current context, this will return 0 as a safe default. * * SDL_GL_SetSwapInterval() *
SDL_GL_LoadLibrary SDL.Import

** * Dynamically load an OpenGL library. * * path The platform dependent OpenGL library name, or nil to open the * default OpenGL library. * * 0 on success, or -1 if the library couldn't be loaded. * * This should be done after initializing the video driver, but before * creating any OpenGL windows. If no OpenGL library is loaded, the default * library will be loaded upon creation of the first OpenGL window. * * If you do this, you need to retrieve all of the GL functions used in * your program from the dynamic library using SDL_GL_GetProcAddress(). * * SDL_GL_GetProcAddress() * SDL_GL_UnloadLibrary() *
SDL_GL_MakeCurrent SDL.Import

** * Set up an OpenGL context for rendering into an OpenGL window. * * The context must have been created with a compatible window. *
SDL_GL_SetAttribute SDL.Import

** * Set an OpenGL window attribute before window creation. *
SDL_GL_SetSwapInterval SDL.Import

** * Set the swap interval for the current OpenGL context. * * interval 0 for immediate updates, 1 for updates synchronized with the * vertical retrace. If the system supports it, you may * specify -1 to allow late swaps to happen immediately * instead of waiting for the next retrace. * * 0 on success, or -1 if setting the swap interval is not supported. * * SDL_GL_GetSwapInterval() *
SDL_GL_SwapWindow SDL.Import

** * Swap the OpenGL buffers for a window, if double-buffering is * supported. *
SDL_GL_UnbindTexture SDL.Import

** * Unbind a texture from the current OpenGL/ES/ES2 context. * * texture The SDL texture to unbind * * 0 on success, or -1 if the operation is not supported *
SDL_GL_UnloadLibrary SDL.Import

** * Unload the OpenGL library previously loaded by SDL_GL_LoadLibrary(). * * SDL_GL_LoadLibrary() *
SDL_HapticClose SDL.Import

** * Closes a Haptic device previously opened with SDL_HapticOpen(). * * haptic Haptic device to close. *
SDL_HapticDestroyEffect SDL.Import

** * Destroys a haptic effect on the device. * * This will stop the effect if it's running. Effects are automatically * destroyed when the device is closed. * * haptic Device to destroy the effect on. * effect Identifier of the effect to destroy. * * SDL_HapticNewEffect *
SDL_HapticEffectSupported SDL.Import

** * Checks to see if effect is supported by haptic. * * haptic Haptic device to check on. * effect Effect to check to see if it is supported. * SDL_TRUE if effect is supported, SDL_FALSE if it isn't or -1 on error. * * SDL_HapticQuery * SDL_HapticNewEffect *
SDL_HapticGetEffectStatus SDL.Import

** * Gets the status of the current effect on the haptic device. * * Device must support the ::SDL_HAPTIC_STATUS feature. * * haptic Haptic device to query the effect status on. * effect Identifier of the effect to query its status. * 0 if it isn't playing, 1 if it is playing or -1 on error. * * SDL_HapticRunEffect * SDL_HapticStopEffect *
SDL_HapticIndex SDL.Import

** * Gets the index of a haptic device. * * haptic Haptic device to get the index of. * The index of the haptic device or -1 on error. * * SDL_HapticOpen * SDL_HapticOpened *
SDL_HapticName SDL.Import

** * Get the implementation dependent name of a Haptic device. * * This can be called before any joysticks are opened. * If no name can be found, this function returns NULL. * * device_index Index of the device to get its name. * Name of the device or NULL on error. * * SDL_NumHaptics *
SDL_HapticNewEffect SDL.Import

** * Creates a new haptic effect on the device. * * haptic Haptic device to create the effect on. * effect Properties of the effect to create. * The id of the effect on success or -1 on error. * * SDL_HapticUpdateEffect * SDL_HapticRunEffect * SDL_HapticDestroyEffect *
SDL_HapticNumAxes SDL.Import

** * Gets the number of haptic axes the device has. * * SDL_HapticDirection *
SDL_HapticNumEffects SDL.Import

** * Returns the number of effects a haptic device can store. * * On some platforms this isn't fully supported, and therefore is an * approximation. Always check to see if your created effect was actually * created and do not rely solely on SDL_HapticNumEffects(). * * haptic The haptic device to query effect max. * The number of effects the haptic device can store or * -1 on error. * * SDL_HapticNumEffectsPlaying * SDL_HapticQuery *
SDL_HapticNumEffectsPlaying SDL.Import

** * Returns the number of effects a haptic device can play at the same * time. * * This is not supported on all platforms, but will always return a value. * Added here for the sake of completeness. * * haptic The haptic device to query maximum playing effects. * The number of effects the haptic device can play at the same time * or -1 on error. * * SDL_HapticNumEffects * SDL_HapticQuery *
SDL_HapticOpen SDL.Import

** * Opens a Haptic device for usage. * * The index passed as an argument refers to the N'th Haptic device on this * system. * * When opening a haptic device, its gain will be set to maximum and * autocenter will be disabled. To modify these values use * SDL_HapticSetGain() and SDL_HapticSetAutocenter(). * * device_index Index of the device to open. * Device identifier or NULL on error. * * SDL_HapticIndex * SDL_HapticOpenFromMouse * SDL_HapticOpenFromJoystick * SDL_HapticClose * SDL_HapticSetGain * SDL_HapticSetAutocenter * SDL_HapticPause * SDL_HapticStopAll *
SDL_HapticOpened SDL.Import

** * Checks if the haptic device at index has been opened. * * device_index Index to check to see if it has been opened. * 1 if it has been opened or 0 if it hasn't. * * SDL_HapticOpen * SDL_HapticIndex *
SDL_HapticOpenFromJoystick SDL.Import

** * Opens a Haptic device for usage from a Joystick device. * * You must still close the haptic device seperately. It will not be closed * with the joystick. * * When opening from a joystick you should first close the haptic device before * closing the joystick device. If not, on some implementations the haptic * device will also get unallocated and you'll be unable to use force feedback * on that device. * * joystick Joystick to create a haptic device from. * A valid haptic device identifier on success or NULL on error. * * SDL_HapticOpen * SDL_HapticClose *
SDL_HapticOpenFromMouse SDL.Import

** * Tries to open a haptic device from the current mouse. * * The haptic device identifier or NULL on error. * * SDL_MouseIsHaptic * SDL_HapticOpen *
SDL_HapticPause SDL.Import

** * Pauses a haptic device. * * Device must support the SDL_HAPTIC_PAUSE feature. Call * SDL_HapticUnpause() to resume playback. * * Do not modify the effects nor add new ones while the device is paused. * That can cause all sorts of weird errors. * * haptic Haptic device to pause. * 0 on success or -1 on error. * * SDL_HapticUnpause *
SDL_HapticQuery SDL.Import

** * Gets the haptic devices supported features in bitwise matter. * * Example: * * if (SDL_HapticQueryEffects(haptic) & SDL_HAPTIC_CONSTANT) * printf("We have constant haptic effect!"); * * * * haptic The haptic device to query. * Haptic features in bitwise manner (OR'd). * * SDL_HapticNumEffects * SDL_HapticEffectSupported *
SDL_HapticRumbleInit SDL.Import

** * Initializes the haptic device for simple rumble playback. * * haptic Haptic device to initialize for simple rumble playback. * 0 on success or -1 on error. * * SDL_HapticOpen * SDL_HapticRumbleSupported * SDL_HapticRumblePlay * SDL_HapticRumbleStop *
SDL_HapticRumblePlay SDL.Import

** * Runs simple rumble on a haptic device * * haptic Haptic device to play rumble effect on. * strength Strength of the rumble to play as a 0-1 float value. * length Length of the rumble to play in milliseconds. * 0 on success or -1 on error. * * SDL_HapticRumbleSupported * SDL_HapticRumbleInit * SDL_HapticRumbleStop *
SDL_HapticRumbleStop SDL.Import

** * Stops the simple rumble on a haptic device. * * haptic Haptic to stop the rumble on. * 0 on success or -1 on error. * * SDL_HapticRumbleSupported * SDL_HapticRumbleInit * SDL_HapticRumblePlay *
SDL_HapticRumbleSupported SDL.Import

** * Checks to see if rumble is supported on a haptic device.. * * haptic Haptic device to check to see if it supports rumble. * SDL_TRUE if effect is supported, SDL_FALSE if it isn't or -1 on error. * * SDL_HapticRumbleInit * SDL_HapticRumblePlay * SDL_HapticRumbleStop *
SDL_HapticRunEffect SDL.Import

** * Runs the haptic effect on its associated haptic device. * * If iterations are ::SDL_HAPTIC_INFINITY, it'll run the effect over and over * repeating the envelope (attack and fade) every time. If you only want the * effect to last forever, set ::SDL_HAPTIC_INFINITY in the effect's length * parameter. * * haptic Haptic device to run the effect on. * effect Identifier of the haptic effect to run. * iterations Number of iterations to run the effect. Use * SDL_HAPTIC_INFINITY for infinity. * 0 on success or -1 on error. * * SDL_HapticStopEffect * SDL_HapticDestroyEffect * SDL_HapticGetEffectStatus *
SDL_HapticSetAutocenter SDL.Import

** * Sets the global autocenter of the device. * * Autocenter should be between 0 and 100. Setting it to 0 will disable * autocentering. * * Device must support the ::SDL_HAPTIC_AUTOCENTER feature. * * haptic Haptic device to set autocentering on. * autocenter Value to set autocenter to, 0 disables autocentering. * 0 on success or -1 on error. * * SDL_HapticQuery *
SDL_HapticSetGain SDL.Import

** * Sets the global gain of the device. * * Device must support the SDL_HAPTIC_GAIN feature. * * The user may specify the maximum gain by setting the environment variable * SDL_HAPTIC_GAIN_MAX which should be between 0 and 100. All calls to * SDL_HapticSetGain() will scale linearly using SDL_HAPTIC_GAIN_MAX as the * maximum. * * haptic Haptic device to set the gain on. * gain Value to set the gain to, should be between 0 and 100. * 0 on success or -1 on error. * * SDL_HapticQuery *
SDL_HapticStopAll SDL.Import

** * Stops all the currently playing effects on a haptic device. * * haptic Haptic device to stop. * 0 on success or -1 on error. *
SDL_HapticStopEffect SDL.Import

** * Stops the haptic effect on its associated haptic device. * * haptic Haptic device to stop the effect on. * effect Identifier of the effect to stop. * 0 on success or -1 on error. * * SDL_HapticRunEffect * SDL_HapticDestroyEffect *
SDL_HapticUnpause SDL.Import

** * Unpauses a haptic device. * * Call to unpause after SDL_HapticPause(). * * haptic Haptic device to pause. * 0 on success or -1 on error. * * SDL_HapticPause *
SDL_HapticUpdateEffect SDL.Import

** * Updates the properties of an effect. * * Can be used dynamically, although behaviour when dynamically changing * direction may be strange. Specifically the effect may reupload itself * and start playing from the start. You cannot change the type either when * running SDL_HapticUpdateEffect(). * * haptic Haptic device that has the effect. * effect Effect to update. * data New effect properties to use. * The id of the effect on success or -1 on error. * * SDL_HapticNewEffect * SDL_HapticRunEffect * SDL_HapticDestroyEffect *
SDL_HasEvent SDL.Import

** * Checks to see if certain event types are in the event queue. *
SDL_HasEvents SDL.Import

SDL_HasIntersection SDL.Import

** * Determine whether two rectangles intersect. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *
SDL_HasScreenKeyboardSupport SDL.Import

** * Returns whether the platform has some screen keyboard support. * * SDL_TRUE if some keyboard support is available else SDL_FALSE. * * Not all screen keyboard functions are supported on all platforms. * * SDL_IsScreenKeyboardShown() *
SDL_HideWindow SDL.Import

** * Hide a window. * * SDL_ShowWindow() *
SDL_Init SDL.Import

** * This function initializes the subsystems specified by flags * Unless the SDL_INIT_NOPARACHUTE flag is set, it will install cleanup * signal handlers for some commonly ignored fatal signals (like SIGSEGV). *
SDL_InitSubSystem SDL.Import

** * This function initializes specific SDL subsystems *
SDL_IntersectRect SDL.Import

** * Calculate the intersection of two rectangles. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *
SDL_IntersectRectAndLine SDL.Import

** * Calculate the intersection of a rectangle and line segment. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *
SDL_IsGameController SDL.Import

** * Is the joystick on this index supported by the game controller interface? *
SDL_IsScreenKeyboardShown SDL.Import

** * Returns whether the screen keyboard is shown for given window. * * window The window for which screen keyboard should be queried. * * Result - SDL_TRUE if screen keyboard is shown else SDL_FALSE. * * SDL_HasScreenKeyboardSupport() *
SDL_IsScreenSaverEnabled SDL.Import

** * Returns whether the screensaver is currently enabled (default on). * * SDL_EnableScreenSaver() * SDL_DisableScreenSaver() *
SDL_IsShapedWindow SDL.Import

** * Return whether the given window is a shaped window. * * window The window to query for being shaped. * * SDL_TRUE if the window is a window that can be shaped, SDL_FALSE if the window is unshaped or NULL. * SDL_CreateShapedWindow *
SDL_IsTextInputActive SDL.Import

** * Return whether or not Unicode text input events are enabled. * * SDL_StartTextInput() * SDL_StopTextInput() *
SDL_JoystickClose SDL.Import

** * Close a joystick previously opened with SDL_JoystickOpen(). *
SDL_JoystickEventState SDL.Import

** * Enable/disable joystick event polling. * * If joystick events are disabled, you must call SDL_JoystickUpdate() * yourself and check the state of the joystick when you want joystick * information. * * The state can be one of ::SDL_QUERY, ::SDL_ENABLE or ::SDL_IGNORE. *
SDL_JoystickGetAttached SDL.Import

** * Returns SDL_TRUE if the joystick has been opened and currently connected, or SDL_FALSE if it has not. *
SDL_JoystickGetAxis SDL.Import

** * Get the current state of an axis control on a joystick. * * The state is a value ranging from -32768 to 32767. * * The axis indices start at index 0. *
SDL_JoystickGetBall SDL.Import

** * Get the ball axis change since the last poll. * * 0, or -1 if you passed it invalid parameters. * * The ball indices start at index 0. *
SDL_JoystickGetButton SDL.Import

** * Get the current state of a button on a joystick. * * The button indices start at index 0. *
SDL_JoystickGetDeviceGUID SDL.Import

** * Return the GUID for the joystick at this index *
SDL_JoystickGetGUID SDL.Import

** * Return the GUID for this opened joystick *
SDL_JoystickGetGUIDFromString SDL.Import

** * convert a string into a joystick formatted guid *
SDL_JoystickGetGUIDString SDL.Import

** * Return a string representation for this guid. pszGUID must point to at least 33 bytes * (32 for the string plus a NULL terminator). *
SDL_JoystickGetHat SDL.Import

** * Get the current state of a POV hat on a joystick. * * The hat indices start at index 0. * * The return value is one of the following positions: * - SDL_HAT_CENTERED * - SDL_HAT_UP * - SDL_HAT_RIGHT * - SDL_HAT_DOWN * - SDL_HAT_LEFT * - SDL_HAT_RIGHTUP * - SDL_HAT_RIGHTDOWN * - SDL_HAT_LEFTUP * - SDL_HAT_LEFTDOWN *
SDL_JoystickInstanceID SDL.Import

** * Get the instance ID of an opened joystick or -1 if the joystick is invalid. *
SDL_JoystickIsHaptic SDL.Import

** * Checks to see if a joystick has haptic features. * * joystick Joystick to test for haptic capabilities. * 1 if the joystick is haptic, 0 if it isn't * or -1 if an error ocurred. * * SDL_HapticOpenFromJoystick *
SDL_JoystickName SDL.Import

** * Return the name for this currently opened joystick. * If no name can be found, this function returns NULL. *
SDL_JoystickNameForIndex SDL.Import

** * Get the implementation dependent name of a joystick. * This can be called before any joysticks are opened. * If no name can be found, this function returns NULL. *
SDL_JoystickNumAxes SDL.Import

** * Get the number of general axis controls on a joystick. *
SDL_JoystickNumBalls SDL.Import

** * Get the number of trackballs on a joystick. * * Joystick trackballs have only relative motion events associated * with them and their state cannot be polled. *
SDL_JoystickNumButtons SDL.Import

** * Get the number of buttons on a joystick. *
SDL_JoystickNumHats SDL.Import

** * Get the number of POV hats on a joystick. *
SDL_JoystickOpen SDL.Import

** * Open a joystick for use. * The index passed as an argument refers tothe N'th joystick on the system. * This index is the value which will identify this joystick in future joystick * events. * * A joystick identifier, or NULL if an error occurred. *
SDL_JoystickUpdate SDL.Import

** * Update the current state of the open joysticks. * * This is called automatically by the event loop if any joystick * events are enabled. *
SDL_LoadBMP SDL.Import

** * Load a surface from a file. * * Convenience macro. *
SDL_LoadBMP_RW SDL.Import

** * Load a surface from a seekable SDL data stream (memory or file). * * If freesrc is non-zero, the stream will be closed after being read. * * The new surface should be freed with SDL_FreeSurface(). * * the new surface, or NULL if there was an error. *
SDL_LoadDollarTemplates SDL.Import

** * Load Dollar Gesture templates from a file * * *
SDL_LoadFunction SDL.Import

** * Given an object handle, this function looks up the address of the * named function in the shared object and returns it. This address * is no longer valid after calling SDL_UnloadObject(). *
SDL_LoadObject SDL.Import

** * This function dynamically loads a shared object and returns a pointer * to the object handle (or NULL if there was an error). * The 'sofile' parameter is a system dependent name of the object file. *
SDL_LoadWAV SDL.Import

** * Loads a WAV from a file. * Compatibility convenience function. *
SDL_LoadWAV_RW SDL.Import

** * This function loads a WAVE from the data source, automatically freeing * that source if freesrc is non-zero. For example, to load a WAVE file, * you could do: * * SDL_LoadWAV_RW(SDL_RWFromFile("sample.wav", "rb"), 1, ...); * * * If this function succeeds, it returns the given SDL_AudioSpec, * filled with the audio data format of the wave data, and sets * *audio_buf to a malloc()'d buffer containing the audio data, * and sets *audio_len to the length of that audio buffer, in bytes. * You need to free the audio buffer with SDL_FreeWAV() when you are * done with it. * * This function returns NULL and sets the SDL error message if the * wave file cannot be opened, uses an unknown data format, or is * corrupt. Currently raw and MS-ADPCM WAVE files are supported. *
SDL_LockAudio SDL.Import

** * Audio lock functions * * The lock manipulated by these functions protects the callback function. * During a SDL_LockAudio()/SDL_UnlockAudio() pair, you can be guaranteed that * the callback function is not running. Do not call these from the callback * function or you will cause deadlock. *
SDL_LockAudioDevice SDL.Import

SDL_LockMutex SDL.Import

#define SDL_mutexP(m) SDL_LockMutex(m)
SDL_LockSurface SDL.Import

** * Sets up a surface for directly accessing the pixels. * * Between calls to SDL_LockSurface() / SDL_UnlockSurface(), you can write * to and read from surface.pixels, using the pixel format stored in * surface.format. Once you are done accessing the surface, you should * use SDL_UnlockSurface() to release it. * * Not all surfaces require locking. If SDL_MUSTLOCK(surface) evaluates * to 0, then you can read and write to the surface at any time, and the * pixel format of the surface will not change. * * No operating system or library calls should be made between lock/unlock * pairs, as critical system locks may be held during this time. * * SDL_LockSurface() returns 0, or -1 if the surface couldn't be locked. * * SDL_UnlockSurface() *
SDL_LockTexture SDL.Import

** * Lock a portion of the texture for write-only pixel access. * * texture The texture to lock for access, which was created with * SDL_TEXTUREACCESS_STREAMING. * rect A pointer to the rectangle to lock for access. If the rect * is NULL, the entire texture will be locked. * pixels This is filled in with a pointer to the locked pixels, * appropriately offset by the locked area. * pitch This is filled in with the pitch of the locked pixels. * * 0 on success, or -1 if the texture is not valid or was not created with ::SDL_TEXTUREACCESS_STREAMING. * * SDL_UnlockTexture() *
SDL_LowerBlit SDL.Import

** * This is a semi-private blit function and it performs low-level surface * blitting only. *
SDL_LowerBlitScaled SDL.Import

** * This is a semi-private blit function and it performs low-level surface * scaled blitting only. *
SDL_MapRGB SDL.Import

** * Maps an RGB triple to an opaque pixel value for a given pixel format. * * SDL_MapRGBA *
SDL_MapRGBA SDL.Import

** * Maps an RGBA quadruple to a pixel value for a given pixel format. * * SDL_MapRGB *
SDL_MasksToPixelFormatEnum SDL.Import

** * Convert a bpp and RGBA masks to an enumerated pixel format. * * The pixel format, or SDL_PIXELFORMAT_UNKNOWN if the conversion * wasn't possible. * * SDL_PixelFormatEnumToMasks() *
SDL_MaximizeWindow SDL.Import

** * Make a window as large as possible. * * SDL_RestoreWindow() *
SDL_MinimizeWindow SDL.Import

** * Minimize a window to an iconic representation. * * SDL_RestoreWindow() *
SDL_MixAudio SDL.Import

** * This takes two audio buffers of the playing audio format and mixes * them, performing addition, volume adjustment, and overflow clipping. * The volume ranges from 0 - 128, and should be set to ::SDL_MIX_MAXVOLUME * for full audio volume. Note this does not change hardware volume. * This is provided for convenience – you can mix your own audio data. *
SDL_MixAudioFormat SDL.Import

** * This works like SDL_MixAudio(), but you specify the audio format instead of * using the format of audio device 1. Thus it can be used when no audio * device is open at all. *
SDL_MouseIsHaptic SDL.Import

** * Gets whether or not the current mouse has haptic capabilities. * * SDL_TRUE if the mouse is haptic, SDL_FALSE if it isn't. * * SDL_HapticOpenFromMouse *
SDL_NumHaptics SDL.Import

** * Count the number of haptic devices attached to the system. * * Number of haptic devices detected on the system. *
SDL_NumJoysticks SDL.Import

** * Count the number of joysticks attached to the system right now *
SDL_OpenAudio SDL.Import

** * This function opens the audio device with the desired parameters, and * returns 0 if successful, placing the actual hardware parameters in the * structure pointed to by obtained. If obtained is NULL, the audio * data passed to the callback function will be guaranteed to be in the * requested format, and will be automatically converted to the hardware * audio format if necessary. This function returns -1 if it failed * to open the audio device, or couldn't set up the audio thread. * * When filling in the desired audio spec structure, * - desired->freq should be the desired audio frequency in samples-per- * second. * - desired->format should be the desired audio format. * - desired->samples is the desired size of the audio buffer, in * samples. This number should be a power of two, and may be adjusted by * the audio driver to a value more suitable for the hardware. Good values * seem to range between 512 and 8096 inclusive, depending on the * application and CPU speed. Smaller values yield faster response time, * but can lead to underflow if the application is doing heavy processing * and cannot fill the audio buffer in time. A stereo sample consists of * both right and left channels in LR ordering. * Note that the number of samples is directly related to time by the * following formula: ms := (samples*1000)/freq; * - desired->size is the size in bytes of the audio buffer, and is * calculated by SDL_OpenAudio(). * - desired->silence is the value used to set the buffer to silence, * and is calculated by SDL_OpenAudio(). * - desired->callback should be set to a function that will be called * when the audio device is ready for more data. It is passed a pointer * to the audio buffer, and the length in bytes of the audio buffer. * This function usually runs in a separate thread, and so you should * protect data structures that it accesses by calling SDL_LockAudio() * and SDL_UnlockAudio() in your code. * - desired->userdata is passed as the first parameter to your callback * function. * * The audio device starts out playing silence when it's opened, and should * be enabled for playing by calling SDL_PauseAudio(0) when you are ready * for your audio callback function to be called. Since the audio driver * may modify the requested size of the audio buffer, you should allocate * any local mixing buffers after you open the audio device. *
SDL_OpenAudioDevice SDL.Import

** * Open a specific audio device. Passing in a device name of NULL requests * the most reasonable default (and is equivalent to calling SDL_OpenAudio()). * * The device name is a UTF-8 string reported by SDL_GetAudioDeviceName(), but * some drivers allow arbitrary and driver-specific strings, such as a * hostname/IP address for a remote audio server, or a filename in the * diskaudio driver. * * 0 on error, a valid device ID that is >= 2 on success. * * SDL_OpenAudio(), unlike this function, always acts on device ID 1. *
SDL_PauseAudio SDL.Import

** * Pause audio functions * * These functions pause and unpause the audio callback processing. * They should be called with a parameter of 0 after opening the audio * device to start playing sound. This is so you can safely initialize * data for your callback function after opening the audio device. * Silence will be written to the audio device during the pause. *
SDL_PauseAudioDevice SDL.Import

SDL_PeepEvents SDL.Import

** * Checks the event queue for messages and optionally returns them. * * If action is SDL_ADDEVENT, up to numevents events will be added to * the back of the event queue. * * If action is SDL_PEEKEVENT, up to numevents events at the front * of the event queue, within the specified minimum and maximum type, * will be returned and will not be removed from the queue. * * If action is SDL_GETEVENT, up to numevents events at the front * of the event queue, within the specified minimum and maximum type, * will be returned and will be removed from the queue. * * Result: The number of events actually stored, or -1 if there was an error. * * This function is thread-safe. *
SDL_PIXELFLAG SDL.Import

//todo!! function SDL_DEFINE_PIXELFORMAT(type, order, layour, bit, bytes: UInt32): Result;

function SDL_DEFINE_PIXELFOURCC(A,B,C,D: Variant): Variant;

#define SDL_DEFINE_PIXELFORMAT(type, order, layout, bits, bytes) \ ((1 << 28) | ((type) << 24) | ((order) << 20) | ((layout) << 16) | \ ((bits) << 8) | ((bytes) << 0))
SDL_PixelFormatEnumToMasks SDL.Import

** * Convert one of the enumerated pixel formats to a bpp and RGBA masks. * * SDL_TRUE, or SDL_FALSE if the conversion wasn't possible. * * SDL_MasksToPixelFormatEnum() *
SDL_PIXELLAYOUT SDL.Import

SDL_PIXELORDER SDL.Import

SDL_PIXELTYPE SDL.Import

SDL_PollEvent SDL.Import

** * Polls for currently pending events. * * 1 if there are any pending events, or 0 if there are none available. * * event - If not nil, the next event is removed from the queue and * stored in that area. *
SDL_PumpEvents SDL.Import

** * Pumps the event loop, gathering events from the input devices. * * This function updates the event queue and internal input device state. * * This should only be run in the thread that sets the video mode. *
SDL_PushEvent SDL.Import

** * Add an event to the event queue. * * 1 on success, 0 if the event was filtered, or -1 if the event queue * was full or there was some other error. *
SDL_putenv GLS.SDL.Window

function SDL_putenv(const variable: PAnsiChar): integer; cdecl; external LibName;
SDL_QueryTexture SDL.Import

** * Query the attributes of a texture * * texture A texture to be queried. * format A pointer filled in with the raw format of the texture. The * actual format may differ, but pixel transfers will use this * format. * access A pointer filled in with the actual access to the texture. * w A pointer filled in with the width of the texture in pixels. * h A pointer filled in with the height of the texture in pixels. * * 0 on success, or -1 if the texture is not valid. *
SDL_Quit SDL.Import

** * This function cleans up all initialized subsystems. You should * call it upon all exit conditions. *
SDL_QuitSubSystem SDL.Import

** * This function cleans up specific SDL subsystems *
SDL_RaiseWindow SDL.Import

** * Raise a window above other windows and set the input focus. *
SDL_ReadBE16 SDL.Import

SDL_ReadBE32 SDL.Import

SDL_ReadBE64 SDL.Import

SDL_ReadLE16 SDL.Import

SDL_ReadLE32 SDL.Import

SDL_ReadLE64 SDL.Import

SDL_ReadU8 SDL.Import

** * Read endian functions * * Read an item of the specified endianness and return in native format. *
SDL_RecordGesture SDL.Import

** * Begin Recording a gesture on the specified touch, or all touches (-1) * * *
SDL_RectEmpty SDL.Import

changed from variant(b?????h!) to TSDL_Rect maybe PSDL_Rect?
SDL_RectEquals SDL.Import

** * Returns true if the two rectangles are equal. *
SDL_RegisterEvents SDL.Import

** * This function allocates a set of user-defined events, and returns * the beginning event number for that set of events. * * If there aren't enough user-defined events left, this function * returns (Uint32)-1 *
SDL_RemoveTimer SDL.Import

** * Remove a timer knowing its ID. * * A boolean value indicating success or failure. * * It is not safe to remove a timer multiple times. *
SDL_RenderClear SDL.Import

** * Clear the current rendering target with the drawing color * * This function clears the entire rendering target, ignoring the viewport. * * 0 on success, or -1 on error *
SDL_RenderCopy SDL.Import

** * Copy a portion of the texture to the current rendering target. * * renderer The renderer which should copy parts of a texture. * texture The source texture. * srcrect A pointer to the source rectangle, or NULL for the entire * texture. * dstrect A pointer to the destination rectangle, or NULL for the * entire rendering target. * * 0 on success, or -1 on error *
SDL_RenderCopyEx SDL.Import

** * Copy a portion of the source texture to the current rendering target, rotating it by angle around the given center * * renderer The renderer which should copy parts of a texture. * texture The source texture. * srcrect A pointer to the source rectangle, or NULL for the entire * texture. * dstrect A pointer to the destination rectangle, or NULL for the * entire rendering target. * angle An angle in degrees that indicates the rotation that will be applied to dstrect * center A pointer to a point indicating the point around which dstrect will be rotated (if NULL, rotation will be done aroud dstrect.w/2, dstrect.h/2) * flip An SDL_RendererFlip value stating which flipping actions should be performed on the texture * * 0 on success, or -1 on error *
SDL_RenderDrawLine SDL.Import

** * Draw a line on the current rendering target. * * renderer The renderer which should draw a line. * x1 The x coordinate of the start point. * y1 The y coordinate of the start point. * x2 The x coordinate of the end point. * y2 The y coordinate of the end point. * * 0 on success, or -1 on error *
SDL_RenderDrawLines SDL.Import

** * \brief Draw a series of connected lines on the current rendering target. * * \param renderer The renderer which should draw multiple lines. * \param points The points along the lines * \param count The number of points, drawing count-1 lines * * \return 0 on success, or -1 on error *
SDL_RenderDrawPoint SDL.Import

** * Draw a point on the current rendering target. * * renderer The renderer which should draw a point. * x The x coordinate of the point. * y The y coordinate of the point. * * 0 on success, or -1 on error *
SDL_RenderDrawPoints SDL.Import

** * Draw multiple points on the current rendering target. * * renderer The renderer which should draw multiple points. * points The points to draw * count The number of points to draw * * 0 on success, or -1 on error *
SDL_RenderDrawRect SDL.Import

** * Draw a rectangle on the current rendering target. * * renderer The renderer which should draw a rectangle. * rect A pointer to the destination rectangle, or NULL to outline the entire rendering target. * * 0 on success, or -1 on error *
SDL_RenderDrawRects SDL.Import

** * Draw some number of rectangles on the current rendering target. * * renderer The renderer which should draw multiple rectangles. * rects A pointer to an array of destination rectangles. * count The number of rectangles. * * 0 on success, or -1 on error *
SDL_RenderFillRect SDL.Import

** * Fill a rectangle on the current rendering target with the drawing color. * * renderer The renderer which should fill a rectangle. * rect A pointer to the destination rectangle, or NULL for the entire * rendering target. * * 0 on success, or -1 on error *
SDL_RenderFillRects SDL.Import

** * Fill some number of rectangles on the current rendering target with the drawing color. * * renderer The renderer which should fill multiple rectangles. * rects A pointer to an array of destination rectangles. * count The number of rectangles. * * 0 on success, or -1 on error *
SDL_RenderGetClipRect SDL.Import

** * Get the clip rectangle for the current target. * * renderer The renderer from which clip rectangle should be queried. * rect A pointer filled in with the current clip rectangle, or * an empty rectangle if clipping is disabled. * * SDL_RenderSetClipRect() *
SDL_RenderGetLogicalSize SDL.Import

** * Get device independent resolution for rendering * * renderer The renderer from which resolution should be queried. * w A pointer filled with the width of the logical resolution * h A pointer filled with the height of the logical resolution * * SDL_RenderSetLogicalSize() *
SDL_RenderGetScale SDL.Import

** * Get the drawing scale for the current target. * * renderer The renderer from which drawing scale should be queried. * scaleX A pointer filled in with the horizontal scaling factor * scaleY A pointer filled in with the vertical scaling factor * * SDL_RenderSetScale() *
SDL_RenderGetViewport SDL.Import

** * Get the drawing area for the current target. * * SDL_RenderSetViewport() *
SDL_RenderPresent SDL.Import

** * Update the screen with rendering performed. *
SDL_RenderReadPixels SDL.Import

** * Read pixels from the current rendering target. * * renderer The renderer from which pixels should be read. * rect A pointer to the rectangle to read, or NULL for the entire * render target. * format The desired format of the pixel data, or 0 to use the format * of the rendering target * pixels A pointer to be filled in with the pixel data * pitch The pitch of the pixels parameter. * * 0 on success, or -1 if pixel reading is not supported. * * This is a very slow operation, and should not be used frequently. *
SDL_RenderSetClipRect SDL.Import

** * Set the clip rectangle for the current target. * * renderer The renderer for which clip rectangle should be set. * rect A pointer to the rectangle to set as the clip rectangle, or * NULL to disable clipping. * * 0 on success, or -1 on error * * SDL_RenderGetClipRect() *
SDL_RenderSetLogicalSize SDL.Import

** * Set device independent resolution for rendering * * renderer The renderer for which resolution should be set. * w The width of the logical resolution * h The height of the logical resolution * * This function uses the viewport and scaling functionality to allow a fixed logical * resolution for rendering, regardless of the actual output resolution. If the actual * output resolution doesn't have the same aspect ratio the output rendering will be * centered within the output display. * * If the output display is a window, mouse events in the window will be filtered * and scaled so they seem to arrive within the logical resolution. * * If this function results in scaling or subpixel drawing by the * rendering backend, it will be handled using the appropriate * quality hints. * * SDL_RenderGetLogicalSize() * SDL_RenderSetScale() * SDL_RenderSetViewport() *
SDL_RenderSetScale SDL.Import

** * Set the drawing scale for rendering on the current target. * * renderer The renderer for which the drawing scale should be set. * scaleX The horizontal scaling factor * scaleY The vertical scaling factor * * The drawing coordinates are scaled by the x/y scaling factors * before they are used by the renderer. This allows resolution * independent drawing with a single coordinate system. * * If this results in scaling or subpixel drawing by the * rendering backend, it will be handled using the appropriate * quality hints. For best results use integer scaling factors. * * SDL_RenderGetScale() * SDL_RenderSetLogicalSize() *
SDL_RenderSetViewport SDL.Import

** * Set the drawing area for rendering on the current target. * * renderer The renderer for which the drawing area should be set. * rect The rectangle representing the drawing area, or NULL to set the viewport to the entire target. * * The x,y of the viewport rect represents the origin for rendering. * * 0 on success, or -1 on error * * If the window associated with the renderer is resized, the viewport is automatically reset. * * SDL_RenderGetViewport() * SDL_RenderSetLogicalSize() *
SDL_RenderTargetSupported SDL.Import

** * Determines whether a window supports the use of render targets * * renderer The renderer that will be checked * * SDL_TRUE if supported, SDL_FALSE if not. *
SDL_RestoreWindow SDL.Import

** * Restore the size and position of a minimized or maximized window. * * SDL_MaximizeWindow() * SDL_MinimizeWindow() *
SDL_RWclose SDL.Import

SDL_RWFromConstMem SDL.Import

SDL_RWFromFile SDL.Import

** * RWFrom functions * * Functions to create SDL_RWops structures from various data streams. *
SDL_RWFromFP SDL.Import

SDL_RWFromMem SDL.Import

SDL_RWread SDL.Import

SDL_RWseek SDL.Import

SDL_RWsize SDL.Import

** * Read/write macros * * Macros to easily read and write from an SDL_RWops structure. *
SDL_RWtell SDL.Import

SDL_RWwrite SDL.Import

SDL_SaveAllDollarTemplates SDL.Import

** * Save all currently loaded Dollar Gesture templates * * *
SDL_SaveBMP SDL.Import

** * Save a surface to a file. * * Convenience macro. *
SDL_SaveBMP_RW SDL.Import

** * Save a surface to a seekable SDL data stream (memory or file). * * If freedst is non-zero, the stream will be closed after being written. * * 0 if successful or -1 if there was an error. *
SDL_SaveDollarTemplate SDL.Import

** * Save a currently loaded Dollar Gesture template * * *
SDL_SemPost SDL.Import

** * Atomically increases the semaphore's count (not blocking). * * 0, or -1 on error. *
SDL_SemTryWait SDL.Import

** * Non-blocking variant of SDL_SemWait(). * * 0 if the wait succeeds, SDL_MUTEX_TIMEDOUT if the wait would * block, and -1 on error. *
SDL_SemValue SDL.Import

** * Returns the current count of the semaphore. *
SDL_SemWait SDL.Import

** * This function suspends the calling thread until the semaphore pointed * to by sem has a positive count. It then atomically decreases the * semaphore count. *
SDL_SemWaitTimeout SDL.Import

** * Variant of SDL_SemWait() with a timeout in milliseconds. * * 0 if the wait succeeds, ::SDL_MUTEX_TIMEDOUT if the wait does not * succeed in the allotted time, and -1 on error. * * On some platforms this function is implemented by looping with a * delay of 1 ms, and so should be avoided if possible. *
SDL_SetClipRect SDL.Import

** * Sets the clipping rectangle for the destination surface in a blit. * * If the clip rectangle is NULL, clipping will be disabled. * * If the clip rectangle doesn't intersect the surface, the function will * return SDL_FALSE and blits will be completely clipped. Otherwise the * function returns SDL_TRUE and blits to the surface will be clipped to * the intersection of the surface area and the clipping rectangle. * * Note that blits are automatically clipped to the edges of the source * and destination surfaces. *
SDL_SetColorKey SDL.Import

** * Sets the color key (transparent pixel) in a blittable surface. * * surface The surface to update * flag Non-zero to enable colorkey and 0 to disable colorkey * key The transparent pixel in the native surface format * * 0 on success, or -1 if the surface is not valid * * You can pass SDL_RLEACCEL to enable RLE accelerated blits. *
SDL_SetCursor SDL.Import

** * Set the active cursor. *
SDL_SetError SDL.Import

* SDL_SetError() unconditionally returns -1. *
SDL_SetEventFilter SDL.Import

** * Sets up a filter to process all events before they change internal state and * are posted to the internal event queue. * * If the filter returns 1, then the event will be added to the internal queue. * If it returns 0, then the event will be dropped from the queue, but the * internal state will still be updated. This allows selective filtering of * dynamically arriving events. * * Be very careful of what you do in the event filter function, as * it may run in a different thread! * * There is one caveat when dealing with the SDL_QUITEVENT event type. The * event filter is only called when the window manager desires to close the * application window. If the event filter returns 1, then the window will * be closed, otherwise the window will remain open if possible. * * If the quit event is generated by an interrupt signal, it will bypass the * internal queue and be delivered to the application at the next event poll. *
SDL_SetHint SDL.Import

/** * \brief Set a hint with normal priority * * \return SDL_TRUE if the hint was set, SDL_FALSE otherwise */
SDL_SetHintWithPriority SDL.Import

/** * \brief Set a hint with a specific priority * * The priority controls the behavior when setting a hint that already * has a value. Hints will replace existing hints of their priority and * lower. Environment variables are considered to have override priority. * * \return SDL_TRUE if the hint was set, SDL_FALSE otherwise */
SDL_SetModState SDL.Import

** * Set the current key modifier state for the keyboard. * * This does not change the keyboard state, only the key modifier flags. *
SDL_SetPaletteColors SDL.Import

** * Set a range of colors in a palette. * * palette The palette to modify. * colors An array of colors to copy into the palette. * firstcolor The index of the first palette entry to modify. * ncolors The number of entries to modify. * * 0 on success, or -1 if not all of the colors could be set. *
SDL_SetPixelFormatPalette SDL.Import

** * Set the palette for a pixel format structure. *
SDL_SetRelativeMouseMode SDL.Import

** * Set relative mouse mode. * * enabled Whether or not to enable relative mode * * 0 on success, or -1 if relative mode is not supported. * * While the mouse is in relative mode, the cursor is hidden, and the * driver will try to report continuous motion in the current window. * Only relative motion events will be delivered, the mouse position * will not change. * * This function will flush any pending mouse motion. * * SDL_GetRelativeMouseMode() *
SDL_SetRenderDrawBlendMode SDL.Import

** * Set the blend mode used for drawing operations (Fill and Line). * * renderer The renderer for which blend mode should be set. * blendMode SDL_BlendMode to use for blending. * * 0 on success, or -1 on error * * If the blend mode is not supported, the closest supported mode is * chosen. * * SDL_GetRenderDrawBlendMode() *
SDL_SetRenderDrawColor SDL.Import

** * Set the color used for drawing operations (Rect, Line and Clear). * * renderer The renderer for which drawing color should be set. * r The red value used to draw on the rendering target. * g The green value used to draw on the rendering target. * b The blue value used to draw on the rendering target. * a The alpha value used to draw on the rendering target, usually * SDL_ALPHA_OPAQUE (255). * * 0 on success, or -1 on error *
SDL_SetRenderTarget SDL.Import

** * Set a texture as the current rendering target. * * renderer The renderer. * texture The targeted texture, which must be created with the SDL_TEXTUREACCESS_TARGET flag, or NULL for the default render target * * 0 on success, or -1 on error * * SDL_GetRenderTarget() *
SDL_SetSurfaceAlphaMod SDL.Import

** * Set an additional alpha value used in blit operations. * * surface The surface to update. * alpha The alpha value multiplied into blit operations. * * 0 on success, or -1 if the surface is not valid. * * SDL_GetSurfaceAlphaMod() *
SDL_SetSurfaceBlendMode SDL.Import

** * Set the blend mode used for blit operations. * * surface The surface to update. * blendMode ::SDL_BlendMode to use for blit blending. * * 0 on success, or -1 if the parameters are not valid. * * SDL_GetSurfaceBlendMode() *
SDL_SetSurfaceColorMod SDL.Import

** * Set an additional color value used in blit operations. * * surface The surface to update. * r The red color value multiplied into blit operations. * g The green color value multiplied into blit operations. * b The blue color value multiplied into blit operations. * * 0 on success, or -1 if the surface is not valid. * * SDL_GetSurfaceColorMod() *
SDL_SetSurfacePalette SDL.Import

** * Set the palette used by a surface. * * 0, or -1 if the surface format doesn't use a palette. * * A single palette can be shared with many surfaces. *
SDL_SetSurfaceRLE SDL.Import

** * Sets the RLE acceleration hint for a surface. * * 0 on success, or -1 if the surface is not valid * * If RLE is enabled, colorkey and alpha blending blits are much faster, * but the surface must be locked before directly accessing the pixels. *
SDL_SetTextInputRect SDL.Import

** * Set the rectangle used to type Unicode text inputs. * This is used as a hint for IME and on-screen keyboard placement. * * SDL_StartTextInput() *
SDL_SetTextureAlphaMod SDL.Import

** * Set an additional alpha value used in render copy operations. * * texture The texture to update. * alpha The alpha value multiplied into copy operations. * * 0 on success, or -1 if the texture is not valid or alpha modulation * is not supported. * * SDL_GetTextureAlphaMod() *
SDL_SetTextureBlendMode SDL.Import

** * Set the blend mode used for texture copy operations. * * texture The texture to update. * blendMode ::SDL_BlendMode to use for texture blending. * * 0 on success, or -1 if the texture is not valid or the blend mode is * not supported. * * If the blend mode is not supported, the closest supported mode is * chosen. * * SDL_GetTextureBlendMode() *
SDL_SetTextureColorMod SDL.Import

** * Set an additional color value used in render copy operations. * * texture The texture to update. * r The red color value multiplied into copy operations. * g The green color value multiplied into copy operations. * b The blue color value multiplied into copy operations. * * 0 on success, or -1 if the texture is not valid or color modulation * is not supported. * * SDL_GetTextureColorMod() *
SDL_SetThreadPriority SDL.Import

** * Set the priority for the current thread *
SDL_SetWindowBordered SDL.Import

** * Set the border state of a window. * * This will add or remove the window's SDL_WINDOW_BORDERLESS flag and * add or remove the border from the actual window. This is a no-op if the * window's border already matches the requested state. * * window The window of which to change the border state. * bordered SDL_FALSE to remove border, SDL_TRUE to add border. * * You can't change the border state of a fullscreen window. * * SDL_GetWindowFlags() *
SDL_SetWindowBrightness SDL.Import

** * Set the brightness (gamma correction) for a window. * * 0 on success, or -1 if setting the brightness isn't supported. * * SDL_GetWindowBrightness() * SDL_SetWindowGammaRamp() *
SDL_SetWindowData SDL.Import

** * Associate an arbitrary named pointer with a window. * * window The window to associate with the pointer. * name The name of the pointer. * userdata The associated pointer. * * The previous value associated with 'name' * * The name is case-sensitive. * * SDL_GetWindowData() *
SDL_SetWindowDisplayMode SDL.Import

** * Set the display mode used when a fullscreen window is visible. * * By default the window's dimensions and the desktop format and refresh rate * are used. * * mode The mode to use, or nil for the default mode. * * 0 on success, or -1 if setting the display mode failed. * * SDL_GetWindowDisplayMode() * SDL_SetWindowFullscreen() *
SDL_SetWindowFullscreen SDL.Import

** * Set a window's fullscreen state. * * 0 on success, or -1 if setting the display mode failed. * * SDL_SetWindowDisplayMode() * SDL_GetWindowDisplayMode() *
SDL_SetWindowGammaRamp SDL.Import

** * Set the gamma ramp for a window. * * red The translation table for the red channel, or nil. * green The translation table for the green channel, or nil. * blue The translation table for the blue channel, or nil. * * 0 on success, or -1 if gamma ramps are unsupported. * * Set the gamma translation table for the red, green, and blue channels * of the video hardware. Each table is an array of 256 16-bit quantities, * representing a mapping between the input and output for that channel. * The input is the index into the array, and the output is the 16-bit * gamma value at that index, scaled to the output color precision. * * SDL_GetWindowGammaRamp() *
SDL_SetWindowGrab SDL.Import

** * Set a window's input grab mode. * * grabbed This is SDL_TRUE to grab input, and SDL_FALSE to release input. * * SDL_GetWindowGrab() *
SDL_SetWindowIcon SDL.Import

** * Set the icon for a window. * * icon The icon for the window. *
SDL_SetWindowMaximumSize SDL.Import

** * Set the maximum size of a window's client area. * * max_w The maximum width of the window, must be >0 * max_h The maximum height of the window, must be >0 * * You can't change the maximum size of a fullscreen window, it * automatically matches the size of the display mode. * * SDL_GetWindowMaximumSize() * SDL_SetWindowMinimumSize() *
SDL_SetWindowMinimumSize SDL.Import

** * Set the minimum size of a window's client area. * * min_w The minimum width of the window, must be >0 * min_h The minimum height of the window, must be >0 * * You can't change the minimum size of a fullscreen window, it * automatically matches the size of the display mode. * * SDL_GetWindowMinimumSize() * SDL_SetWindowMaximumSize() *
SDL_SetWindowPosition SDL.Import

** * Set the position of a window. * * window The window to reposition. * x The x coordinate of the window, SDL_WINDOWPOS_CENTERED, or * SDL_WINDOWPOS_UNDEFINED. * y The y coordinate of the window, SDL_WINDOWPOS_CENTERED, or * SDL_WINDOWPOS_UNDEFINED. * * The window coordinate origin is the upper left of the display. * * SDL_GetWindowPosition() *
SDL_SetWindowShape SDL.Import

** * Set the shape and parameters of a shaped window. * * window The shaped window whose parameters should be set. * shape A surface encoding the desired shape for the window. * shape_mode The parameters to set for the shaped window. * * 0 on success, SDL_INVALID_SHAPE_ARGUMENT on invalid an invalid shape argument, or SDL_NONSHAPEABLE_WINDOW * if the SDL_Window* given does not reference a valid shaped window. * * SDL_WindowShapeMode * SDL_GetShapedWindowMode. *
SDL_SetWindowSize SDL.Import

** * Set the size of a window's client area. * * w The width of the window, must be >0 * h The height of the window, must be >0 * * You can't change the size of a fullscreen window, it automatically * matches the size of the display mode. * * SDL_GetWindowSize() *
SDL_SetWindowTitle SDL.Import

** * Set the title of a window, in UTF-8 format. * * SDL_GetWindowTitle() *
SDL_ShowCursor SDL.Import

** * Toggle whether or not the cursor is shown. * * toggle 1 to show the cursor, 0 to hide it, -1 to query the current * state. * * 1 if the cursor is shown, or 0 if the cursor is hidden. *
SDL_ShowMessageBox SDL.Import

** * Create a modal message box. * * messageboxdata The SDL_MessageBoxData structure with title, text, etc. * buttonid The pointer to which user id of hit button should be copied. * * -1 on error, otherwise 0 and buttonid contains user id of button * hit or -1 if dialog was closed. * * This function should be called on the thread that created the parent * window, or on the main thread if the messagebox has no parent. It will * block execution of that thread until the user clicks a button or * closes the messagebox. *
SDL_ShowSimpleMessageBox SDL.Import

** * Create a simple modal message box * * flags SDL_MessageBoxFlags * title UTF-8 title text * message UTF-8 message text * window The parent window, or NULL for no parent * * 0 on success, -1 on error * * SDL_ShowMessageBox *
SDL_ShowWindow SDL.Import

** * Show a window. * * SDL_HideWindow() *
SDL_SoftStretch SDL.Import

** * Perform a fast, low quality, stretch blit between two surfaces of the * same pixel format. * * This function uses a static buffer, and is not thread-safe. *
SDL_StartTextInput SDL.Import

** * Start accepting Unicode text input events. * This function will show the on-screen keyboard if supported. * * SDL_StopTextInput() * SDL_SetTextInputRect() * SDL_HasScreenKeyboardSupport() *
SDL_StopTextInput SDL.Import

** * Stop receiving any text input events. * This function will hide the on-screen keyboard if supported. * * SDL_StartTextInput() * SDL_HasScreenKeyboardSupport() *
SDL_Swap32 SDL.Import

SDL_ThreadID SDL.Import

** * Get the thread identifier for the current thread. *
SDL_TLSCreate SDL.Import

* * SDL_TLSGet() * SDL_TLSSet() *
SDL_TLSGet SDL.Import

** * Get the value associated with a thread local storage ID for the current thread. * * id The thread local storage ID * * The value associated with the ID for the current thread, or NULL if no value has been set. * * SDL_TLSCreate() * SDL_TLSSet() *
SDL_TLSSet SDL.Import

** * Set the value associated with a thread local storage ID for the current thread. * * id The thread local storage ID * value The value to associate with the ID for the current thread * destructor_ A function called when the thread exits, to free the value. * * 0 on success, -1 on error * * SDL_TLSCreate() * SDL_TLSGet() *
SDL_TryLockMutex SDL.Import

** * Try to lock the mutex * * 0, SDL_MUTEX_TIMEDOUT, or -1 on error *
SDL_UnionRect SDL.Import

** * Calculate the union of two rectangles. *
SDL_UnloadObject SDL.Import

** * Unload a shared object from memory. *
SDL_UnlockAudio SDL.Import

SDL_UnlockAudioDevice SDL.Import

SDL_UnlockMutex SDL.Import

#define SDL_mutexV(m) SDL_UnlockMutex(m)
SDL_UnlockSurface SDL.Import

** SDL_LockSurface() *
SDL_UnlockTexture SDL.Import

** * Unlock a texture, uploading the changes to video memory, if needed. * * SDL_LockTexture() *
SDL_UpdateTexture SDL.Import

** * Update the given texture rectangle with new pixel data. * * texture The texture to update * rect A pointer to the rectangle of pixels to update, or NULL to * update the entire texture. * pixels The raw pixel data. * pitch The number of bytes between rows of pixel data. * * 0 on success, or -1 if the texture is not valid. * * This is a fairly slow function. *
SDL_UpdateWindowSurface SDL.Import

** * Copy the window surface to the screen. * * 0 on success, or -1 on error. * * SDL_GetWindowSurface() * SDL_UpdateWindowSurfaceRects() *
SDL_UpdateWindowSurfaceRects SDL.Import

** * Copy a number of rectangles on the window surface to the screen. * * 0 on success, or -1 on error. * * SDL_GetWindowSurface() * SDL_UpdateWindowSurfaceRect() *
SDL_UpperBlit SDL.Import

** * This is the public blit function, SDL_BlitSurface(), and it performs * rectangle validation and clipping before passing it to SDL_LowerBlit() *
SDL_UpperBlitScaled SDL.Import

** * This is the public scaled blit function, SDL_BlitScaled(), and it performs * rectangle validation and clipping before passing it to SDL_LowerBlitScaled() *
SDL_VERSION SDL.Import

** * Macro to determine SDL version program was compiled against. * * This macro fills in a SDL_version structure with the version of the * library you compiled against. This is determined by what header the * compiler uses. Note that if you dynamically linked the library, you might * have a slightly newer or older version at runtime. That version can be * determined with SDL_GetVersion(), which, unlike SDL_VERSION(), * is not a macro. * * x A pointer to a SDL_version struct to initialize. * * SDL_version * SDL_GetVersion *
SDL_VERSIONNUM SDL.Import

** * This macro turns the version numbers into a numeric value: * * (1,2,3) -> (1203) * * * This assumes that there will never be more than 100 patchlevels. *
SDL_VERSION_ATLEAST SDL.Import

** * This macro will evaluate to true if compiled with SDL at least X.Y.Z. *
SDL_VideoInit SDL.Import

** * Initialize the video subsystem, optionally specifying a video driver. * * driver_name Initialize a specific driver by name, or nil for the * default video driver. * * 0 on success, -1 on error * * This function initializes the video subsystem; setting up a connection * to the window manager, etc, and determines the available display modes * and pixel formats, but does not initialize a window or graphics mode. * * SDL_VideoQuit() *
SDL_VideoQuit SDL.Import

** * Shuts down the video subsystem. * * function closes all windows, and restores the original video mode. * * SDL_VideoInit() *
SDL_WaitEvent SDL.Import

** * Waits indefinitely for the next available event. * * 1, or 0 if there was an error while waiting for events. * * event - If not nil, the next event is removed from the queue and * stored in that area. *
SDL_WaitEventTimeout SDL.Import

** * Waits until the specified timeout (in milliseconds) for the next * available event. * * 1, or 0 if there was an error while waiting for events. * * event - If not nil, the next event is removed from the queue and * stored in that area. *
SDL_WaitThread SDL.Import

** * Wait for a thread to finish. * * The return code for the thread function is placed in the area * pointed to by status, if status is not NULL. *
SDL_WarpMouseInWindow SDL.Import

** * Moves the mouse to the given position within the window. * * window The window to move the mouse into, or nil for the current mouse focus * x The x coordinate within the window * y The y coordinate within the window * * This function generates a mouse motion event *
SDL_WasInit SDL.Import

** * This function returns a mask of the specified subsystems which have * previously been initialized. * * If flags is 0, it returns a mask of all initialized subsystems. *
SDL_WindowPos_IsCentered SDL.Import

SDL_WindowPos_IsUndefined SDL.Import

SDL_WriteBE16 SDL.Import

SDL_WriteBE32 SDL.Import

SDL_WriteBE64 SDL.Import

SDL_WriteLE16 SDL.Import

SDL_WriteLE32 SDL.Import

SDL_WriteLE64 SDL.Import

SDL_WriteU8 SDL.Import

** * Write endian functions * * Write an item of native format to the specified endianness. *
SegmentPlaneIntersection GLScene.VectorGeometry

Computes segment / plane intersection return false if there isn't an intersection
SegmentSegmentClosestPoint GLScene.VectorGeometry

Computes the closest points (2) given two segments
SegmentSegmentDistance GLScene.VectorGeometry

Computes the closest distance between two segments
SetAABB GLScene.GeometryBB

SetActorCMassGlobalPosition PhysX.Import

SetActorGlobalOrientation PhysX.Import

SetActorGlobalPosition PhysX.Import

SetActorMass PhysX.Import

SetAffineVector GLScene.VectorGeometry

SetBB GLScene.GeometryBB

SetElementAccessAddress CUDA.DataAccess

SetExeDirectory GLScene.Utils

SetFullscreenMode GLS.Screen

Changes to the video mode given by 'Index'
SetGLTextureImageClassesToStrings GLS.Texture

Defines a TStrings with the list of registered TGLTextureImageClass.
SetMatrix GLScene.VectorGeometry

SetMatrix GLScene.VectorGeometry

SetMatrix GLScene.VectorGeometry

—————————————————————————- Matrix functions —————————————————————————-
SetMatrixRow GLScene.VectorGeometry

SetPlane GLScene.VectorGeometry

Converts from single to double representation
SetROAMTrianglesCapacity GLS.ROAMPatch

Specifies the maximum number of ROAM triangles that may be allocated.
SetScreenSaverPassword GLS.ScreenSaver

Invokes the standard Windows dialog to set the password. May be invoked from your Properties/Configuration dialog.
setTransform GLS.ODEUtils

SetupTangentSpace GLS.BumpmapHDS

SetupVSync GLS.SceneViewer

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SFChmutov1 GLS.Isosurface

Chmutov-surface-1 (http://mathworld.wolfram.com)
SFChmutov2 GLS.Isosurface

Chmutov-surface-2 (http://mathworld.wolfram.com)
SFDoubleTorus GLS.Isosurface

Double torus Surface (phantasy!)
SFKleinBottle GLS.Isosurface

Klein Bottle (http://mathworld.wolfram.com)
SFMinkowski GLS.Isosurface

Minkowski space (http://mathworld.wolfram.com)
SFSphere GLS.Isosurface

Sphere surface
SFToroidal GLS.Isosurface

Toroidal surface (phantasy!)
ShiftObjectFromCenter GLScene.VectorGeometry

ShiftObjectFromCenter GLScene.VectorGeometry

AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced. ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center
ShowError Formats.m3DSUtils

error message routines
ShowErrorFormatted Formats.m3DSUtils

ShowHTMLUrl GLScene.Utils

SignStrict GLScene.VectorGeometry

Returns the sign of the x value using the (-1, 0, +1) convention
SimulateNx PhysX.Import

SinCosine GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta
SinCosine GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta
SinCosine GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius
SinCosine GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius
SizeOfFile GLScene.Utils

Returns the size of "filename". Returns 0 (zero) is file does not exists.
Smooth_Interpolate_Strip GLS.Perlin

smooth interpolate 3 strips into one...
SolveCubic GLScene.Polynomials

Computes the real roots of a real polynomial of the 3rd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3
SolveQuadric GLScene.Polynomials

Computes the real roots of a real polynomial of the 2nd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2
SolveQuartic GLScene.Polynomials

Computes the real roots of a real polynomial of the 4th degree. The polynomial is of the form: A(0) + A(1)*Z + ... + A(4)*Z**4
SortArrayAscending GLScene.VectorGeometry

Sorts given array in ascending order. NOTE : current implementation is a slow bubble sort...
SphereVisibleRadius GLScene.VectorGeometry

Computes the visible radius of a sphere in a perspective projection. This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.
StarRecordColor GLS.SkyDome

Computes star color from BV index (RGB) and magnitude (alpha)
StarRecordPositionYUp GLS.SkyDome

Computes position on the unit sphere of a star record (Y=up)
StarRecordPositionZUp GLS.SkyDome

Computes position on the unit sphere of a star record (Z=up)
StartAllMovements GLS.Movement

StartPrecisionTimer GLScene.Utils

Starts a precision timer. Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.
StopAllMovements GLS.Movement

StopPrecisionTimer GLScene.Utils

Computes time elapsed since timer start and stop timer. Return time lap in seconds.
Str2Float GLScene.Utils

Trying to read string otherwise using '.' as Decimal Separator
StreamFromFOURCC Formats.VFW

StringToColorAdvanced GLS.ImageUtils

Converts a string into color
StringToColorAdvancedSafe GLS.ImageUtils

Converts a string into color
StripifyMesh GLS.MeshUtils

Attempts to create as few as possible triangle strips to cover the mesh. The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality). The function returns a list of TGLIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller. If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.
StrToFloatDef GLScene.Utils

Similar to SysUtils.StrToFloatDef, but ignores user's locale
StrToGLSResType GLS.ApplicationFileIO

SubdivideTriangles GLS.MeshUtils

Subdivides mesh triangles. Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes. The procedure is not intended for real-time use.
SubtractVector GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1
SubtractVector GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1
SubtractVector GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1
TexPointArrayAdd GLScene.VectorGeometry

Adds delta to nb texpoints in src and places result in dest
TexPointArrayScaleAndAdd GLScene.VectorGeometry

TexPointCombine GLScene.VectorGeometry

Makes a linear combination of two texpoints
TexpointEquals GLScene.VectorGeometry

True if all components are equal.
TexPointLerp GLScene.VectorGeometry

Calculates linear interpolation between texpoint1 and texpoint2 at point t
TexPointMake GLScene.VectorGeometry

————————————————————————– Vector functions ————————————————————————–
textdomain gnugettext

TextureBlue GLS.RandomHDS

TextureBrownSoil GLS.RandomHDS

TextureDarkGray GLS.RandomHDS

TextureDarkGreen GLS.RandomHDS

TextureGreen GLS.RandomHDS

TextureSand GLS.RandomHDS

TextureWhite GLS.RandomHDS

ToDosPath Formats.LWO

ToHex Formats.VFW

– Macro to make a ckid for a chunk out of a TWOCC and a stream num (0-255) -
ToUnixPath Formats.LWO

TP_GlobalHandleClass gnugettext

TP_GlobalIgnoreClass gnugettext

TP_GlobalIgnoreClassProperty gnugettext

TP_Ignore gnugettext

TP_IgnoreClass gnugettext

TP_IgnoreClassProperty gnugettext

TranslateComponent gnugettext

TranslateMatrix GLScene.VectorGeometry

TranslateMatrix GLScene.VectorGeometry

Adds the translation vector into the matrix
TransposeMatrix GLScene.VectorGeometry

Computes transpose of 3x3 matrix
TransposeMatrix GLScene.VectorGeometry

Computes transpose of 4x4 matrix
TriangleArea GLScene.VectorGeometry

Computes the triangle's area
TriangleElevationSegments GLS.Isolines

Defines contouring segments inside a triangle using elevations
TriangleIntersectAABB GLScene.GeometryBB

Original source code by Tomas Akenine-Mцller Based on the paper "Fast 3D Triangle-Box Overlap Testing" http://www.cs.lth.se/home/Tomas_Akenine_Moller/pubs/tribox.pdf http://jgt.akpeters.com/papers/AkenineMoller01/ (code) Use separating axis theorem to test overlap between triangle and box need to test for overlap in these directions: 1) the (x,y,z)-directions (actually, since we use the AABB of the triangle we do not even need to test these) 2) normal of the triangle 3) crossproduct(edge from tri, {x,y,z}-directin) this gives 3x3=9 more tests Checks if a triangle (given by vertices v1, v2 and v3) intersects an AABB
TriangleSignedArea GLScene.VectorGeometry

Computes a 2D triangle's signed area. Only X and Y coordinates are used, Z is ignored
TrimAndSplitVersionString GLS.OpenGLAdapter

TrimAndSplitVersionString GLScene.OpenGL4

TryStringToColorAdvanced GLS.ImageUtils

Converts a string into color
Turn GLScene.VectorGeometry

Coordinate system manipulation functions Rotates the given coordinate system (represented by the matrix) around its Y-axis
Turn GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterUp
Tweener GLScene.AnimationUtils

Tweener GLScene.AnimationUtils

Tweener GLScene.AnimationUtils

Tweener GLScene.AnimationUtils

TWOCCFromFOURCC Formats.VFW

– Macro to get TWOCC chunk type out of a FOURCC ckid ———————–
UnApplyBlendingModeEx GLSL.CustomShader

UnifyTrianglesWinding GLS.MeshUtils

Attempts to unify triangle winding. Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)
UnloadModule ModuleLoader

UnloadOpenGL GLS.OpenGLAdapter

compatibility routines
UnloadOpenGL GLScene.OpenGL4

compatibility routines
UnPackRotationMatrix GLScene.VectorGeometry

Restores a packed rotation matrix. See PackRotationMatrix
UnpressGroup GLS.Windows

UnProject GLScene.VectorGeometry

UnregisterArchiveFormat GLS.ArchiveManager

UnregisterGLSceneObject GLS.ODEManager

UnRegisterGLTextureImageEditor GLS.TextureImageEditors

UnregisterRasterFormat GLS.Graphics

UnregisterSoundFileClass GLS.SoundFileObjects

UnregisterVectorFileClass GLS.VectorFileObjects

UnregisterXCollectionItemClass GLScene.XCollection

Removes a TXCollectionItem subclass from the list
UseCustomGLSLogger GLScene.Logger

UseLanguage gnugettext

Set language to use
UserLog GLScene.Logger

Return logger wich created by TGLSLogger component
Vector2bMake GLScene.VectorGeometry

Vector2bMake GLScene.VectorGeometry

Vector2bMake GLScene.VectorGeometry

Vector2dMake GLScene.VectorGeometry

Vector2dMake GLScene.VectorGeometry

Vector2dMake GLScene.VectorGeometry

Vector2fMake GLScene.VectorGeometry

Vector2fMake GLScene.VectorGeometry

Vector2fMake GLScene.VectorGeometry

2x
Vector2iMake GLScene.VectorGeometry

Vector2iMake GLScene.VectorGeometry

Vector2iMake GLScene.VectorGeometry

Vector2sMake GLScene.VectorGeometry

Vector2sMake GLScene.VectorGeometry

Vector2sMake GLScene.VectorGeometry

Vector3ADD ODE.Import

Vector3bMake GLScene.VectorGeometry

Vector3bMake GLScene.VectorGeometry

Vector3bMake GLScene.VectorGeometry

Vector3Cross ODE.Import

Vector3dMake GLScene.VectorGeometry

Vector3dMake GLScene.VectorGeometry

Vector3dMake GLScene.VectorGeometry

Vector3fMake GLScene.VectorGeometry

Vector3fMake GLScene.VectorGeometry

Vector3fMake GLScene.VectorGeometry

3x
Vector3iMake GLScene.VectorGeometry

Vector3iMake GLScene.VectorGeometry

Vector3iMake GLScene.VectorGeometry

Vector3Length ODE.Import

Vector3Make ODE.Import

Vector3ScalarMul ODE.Import

Vector3sMake GLScene.VectorGeometry

Vector3sMake GLScene.VectorGeometry

Vector3sMake GLScene.VectorGeometry

Vector3SUB ODE.Import

Vector4bMake GLScene.VectorGeometry

Vector4bMake GLScene.VectorGeometry

Vector4bMake GLScene.VectorGeometry

Vector4dMake GLScene.VectorGeometry

Vector4dMake GLScene.VectorGeometry

Vector4dMake GLScene.VectorGeometry

Vector4fMake GLScene.VectorGeometry

Vector4fMake GLScene.VectorGeometry

Vector4fMake GLScene.VectorGeometry

4x
Vector4iMake GLScene.VectorGeometry

Vector4iMake GLScene.VectorGeometry

Vector4iMake GLScene.VectorGeometry

Vector4sMake GLScene.VectorGeometry

Vector4sMake GLScene.VectorGeometry

Vector4sMake GLScene.VectorGeometry

VectorAbs GLScene.VectorGeometry

Returns a vector with components replaced by their Abs value. }
VectorAbs GLScene.VectorGeometry

Returns a vector with components replaced by their Abs value. }
VectorAdd GLScene.VectorGeometry

VectorAdd GLScene.VectorGeometry

VectorAdd GLScene.VectorGeometry

VectorAdd GLScene.VectorGeometry

Adds two vectors and places result in vr
VectorAdd GLScene.VectorGeometry

Returns the sum of two affine vectors
VectorAdd GLScene.VectorGeometry

Returns the sum of two homogeneous vectors
VectorAdd GLScene.VectorGeometry

Sums up f to each component of the vector
VectorAdd GLScene.VectorGeometry

Sums up f to each component of the vector
VectorAffineDblToFlt GLScene.VectorGeometry

Converts a vector containing double sized values into a vector with single sized values
VectorAffineFltToDbl GLScene.VectorGeometry

Converts a vector containing single sized values into a vector with double sized values
VectorAngleCombine GLScene.VectorGeometry

VectorAngleCosine GLScene.VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))
VectorAngleCosine GLScene.VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))
VectorAngleLerp GLScene.VectorGeometry

VectorArrayAdd GLScene.VectorGeometry

Adds delta to nb vectors in src and places result in dest
VectorArrayLerp GLScene.VectorGeometry

VectorArrayLerp GLScene.VectorGeometry

VectorArrayLerp GLScene.VectorGeometry

Calculates linear interpolation between vector arrays
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr, F1=1.0
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result
VectorCombine3 GLScene.VectorGeometry

VectorCombine3 GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result
VectorCombine3 GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result
VectorCombine3 GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr
VectorDblToFlt GLScene.VectorGeometry

Converts a vector containing double sized values into a vector with single sized values
VectorDistance GLScene.VectorGeometry

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...)
VectorDistance GLScene.VectorGeometry

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)
VectorDistance2 GLScene.VectorGeometry

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...
VectorDistance2 GLScene.VectorGeometry

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...(w component ignored)
VectorDivide GLS.EllipseCollision

VectorDivide GLScene.VectorGeometry

VectorDivide GLScene.VectorGeometry

VectorDotProduct GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y]
VectorDotProduct GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorDotProduct GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorDotProduct GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

function VectorEquals(const V1, V2: TVector3f): Boolean; overload; //declared further
VectorEquals GLScene.VectorGeometry

function VectorEquals(const V1, V2: TVector4f): Boolean; overload; //declared further
VectorEquals GLScene.VectorGeometry

True if all components are equal.
VectorEquals GLScene.VectorGeometry

True if all components are equal.
VectorFileFormatExtensionByIndex GLS.VectorFileObjects

Returns an extension by its index in the vector files dialogs filter. Use VectorFileFormatsFilter to obtain the filter.
VectorFileFormatsFilter GLS.VectorFileObjects

A file extension filter suitable for dialog's 'Filter' property
VectorFileFormatsSaveFilter GLS.VectorFileObjects

A file extension filter suitable for a savedialog's 'Filter' property
VectorFltToDbl GLScene.VectorGeometry

Converts a vector containing single sized values into a vector with double sized values
VectorIsNull GLScene.VectorGeometry

True if x=y=z=0, w ignored
VectorIsNull GLScene.VectorGeometry

True if x=y=z=0, w ignored
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation: sqrt(x*x+y*y+...). Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.
VectorLerp GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t
VectorLerp GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t
VectorLerp GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr
VectorLerp GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr
VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorMake GLScene.VectorGeometry

VectorMake GLScene.VectorGeometry

VectorMake GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreThen GLScene.VectorGeometry

3i
VectorMoreThen GLScene.VectorGeometry

3i
VectorMoreThen GLScene.VectorGeometry

3s
VectorMoreThen GLScene.VectorGeometry

3s
VectorMoreThen GLScene.VectorGeometry

4f
VectorMoreThen GLScene.VectorGeometry

4f
VectorMoreThen GLScene.VectorGeometry

4i
VectorMoreThen GLScene.VectorGeometry

4i
VectorMoreThen GLScene.VectorGeometry

4s
VectorMoreThen GLScene.VectorGeometry

4s
VectorMoreThen GLScene.VectorGeometry

ComparedNumber 3f
VectorMoreThen GLScene.VectorGeometry

Vector comparison functions: 3f
VectorNegate GLScene.VectorGeometry

VectorNegate GLScene.VectorGeometry

Negates the vector
VectorNorm GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = v.X*v.X + ... Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x * x + y * y Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNormalize GLScene.VectorGeometry

Returns the vector transformed to unit length
VectorNormalize GLScene.VectorGeometry

Returns the vector transformed to unit length
VectorNormalize GLScene.VectorGeometry

Returns the vector transformed to unit length (w component dropped)
VectorPerpendicular GLScene.VectorGeometry

Calculates a vector perpendicular to N. N is assumed to be of unit length, subtract out any component parallel to N
VectorReflect GLScene.VectorGeometry

Reflects vector V against N (assumes N is normalized)
VectorRotateAroundX GLScene.VectorGeometry

Returns given vector rotated around the X axis (alpha is in rad)
VectorRotateAroundY GLScene.VectorGeometry

Returns given vector rotated around the Y axis (alpha is in rad)
VectorRotateAroundY GLScene.VectorGeometry

Returns given vector rotated around the Y axis in vr (alpha is in rad)
VectorRotateAroundZ GLScene.VectorGeometry

Returns given vector rotated around the Z axis (alpha is in rad)
VectorScale GLScene.VectorGeometry

Returns a vector scaled by a factor
VectorScale GLScene.VectorGeometry

Returns a vector scaled by a factor
VectorScale GLScene.VectorGeometry

Returns a vector scaled by a factor
VectorScale GLScene.VectorGeometry

RScales given vector by another vector
VectorScale GLScene.VectorGeometry

Scales a vector by a factor and places result in vr
VectorScale GLScene.VectorGeometry

Scales a vector by a factor and places result in vr
VectorScale GLScene.VectorGeometry

Scales a vector by a factor and places result in vr
VectorScale GLScene.VectorGeometry

Scales given vector by another vector
VectorSpacing GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".
VectorSpacing GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".
VectorSpacing GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".
VectorSubtract GLScene.VectorGeometry

VectorSubtract GLScene.VectorGeometry

VectorSubtract GLScene.VectorGeometry

Returns V1-V2
VectorSubtract GLScene.VectorGeometry

Returns V1-V2
VectorSubtract GLScene.VectorGeometry

Returns V1-V2
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorTransform GLScene.VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix
VectorTransform GLScene.VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix
VectorTransform GLScene.VectorGeometry

Transforms an affine vector by multiplying it with a matrix
VectorTransform GLScene.VectorGeometry

Transforms an affine vector by multiplying it with a matrix
VerifyDelphiODE ODE.Import

VideoForWindowsVersion Formats.VFW

*************************************************************************** * * VideoForWindowsVersion() - returns version of VfW * **************************************************************************
VirtualKeyCodeToKeyName GLScene.Keyboard

Converts a virtual key code to its name. The name is expressed using the locale windows options.
WeldVertices GLS.MeshUtils

Welds all vertices separated by a distance inferior to weldRadius. Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter). The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex]. The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex. This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)
wglCopyContext GLS.OpenGLAdapter

TGLExtensionsAndEntryPoints —————————— Windows OpenGL (WGL) support functions {$IFDEF SUPPORT_WGL} function wglGetProcAddress(ProcName: PAnsiChar): Pointer; stdcall; external opengl32;
wglCopyContext GLScene.OpenGL4

wglCreateContext GLS.OpenGLAdapter

wglCreateContext GLScene.OpenGL4

wglCreateLayerContext GLS.OpenGLAdapter

wglCreateLayerContext GLScene.OpenGL4

wglDeleteContext GLS.OpenGLAdapter

wglDeleteContext GLScene.OpenGL4

wglDescribeLayerPlane GLScene.OpenGL4

wglGetCurrentContext GLS.OpenGLAdapter

function wglDescribeLayerPlane(p1: HDC; p2, p3: integer; p4: cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;
wglGetCurrentContext GLScene.OpenGL4

wglGetCurrentDC GLS.OpenGLAdapter

wglGetCurrentDC GLScene.OpenGL4

wglGetLayerPaletteEntries GLScene.OpenGL4

wglGetProcAddress GLScene.OpenGL4

wglMakeCurrent GLS.OpenGLAdapter

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;
wglMakeCurrent GLScene.OpenGL4

wglRealizeLayerPalette GLS.OpenGLAdapter

wglRealizeLayerPalette GLScene.OpenGL4

wglSetLayerPaletteEntries GLScene.OpenGL4

wglShareLists GLS.OpenGLAdapter

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;
wglShareLists GLScene.OpenGL4

wglSwapLayerBuffers GLS.OpenGLAdapter

wglSwapLayerBuffers GLScene.OpenGL4

wglSwapMultipleBuffers GLScene.OpenGL4

wglUseFontBitmaps GLScene.OpenGL4

wglUseFontBitmapsA GLScene.OpenGL4

wglUseFontBitmapsW GLScene.OpenGL4

wglUseFontOutlines GLScene.OpenGL4

wglUseFontOutlinesA GLScene.OpenGL4

wglUseFontOutlinesW GLScene.OpenGL4

WordToIntegerArray GLScene.Utils

Copies the values of Source to Dest (converting word values to integer values)
WriteCRLFString GLScene.Utils

Write the string and a CRLF in the stream
WriteModuleData ModuleLoader

WriteMotorolaNumber Formats.LWO

WriteS0 Formats.LWO

WriteU4AsVX Formats.LWO

XCollectionEditorForm FmXCollectionEditor

_ gnugettext

Main GNU gettext functions. See documentation for instructions on how to use them.
_putenv GLS.SDL.Window

—————————————————————————– Get Environment Routines ——————————————————————————


GLSysHelp v.2.5: All Identifiers

All Identifiers

Name

Unit

Description

AABBContainsAABB

GLScene.GeometryBB

Determines to which extent one AABB contains another AABB

AABBContainsBSphere

GLScene.GeometryBB

Determines to which extent an AABB contains a BSpher

AABBFitsInAABBAbsolute

GLScene.GeometryBB

Checks whether one Bounding box aligned with the world axes fits within another Bounding box

AABBFromSweep

GLScene.GeometryBB

Make an AABB that is formed by sweeping a sphere (or AABB) from Start to Dest

AABBInclude

GLScene.GeometryBB

Resize the AABB if necessary to include p.

AABBIntersection

GLScene.GeometryBB

Returns the intersection AABB of two AABBs. If the AABBs don't intersect, will return a degenerated AABB (plane, line or point).

AABBScale

GLScene.GeometryBB

AABBToBB

GLScene.GeometryBB

Converts an AABB to its canonical BB.

AABBToBB

GLScene.GeometryBB

Transforms an AABB to a BB.

AABBToBSphere

GLScene.GeometryBB

Convert an AABB to a BSphere

AABBToClipRect

GLScene.GeometryBB

Projects an AABB and determines the extent of its projection as a clip rect.

AABBTransform

GLScene.GeometryBB

AbsVector

GLScene.VectorGeometry

Vector components are replaced by their Abs() value. }

AbsVector

GLScene.VectorGeometry

Vector components are replaced by their Abs() value. }

ActiveSoundManager

GLS.SoundManager

ActiveVfsPAK

GLS.FileVfsPAK

ActorAddForce

PhysX.Import

ActorCount

PhysX.Import

ACubicFirst3DS

Formats.m3DSConst

maximum reflection map aliasing used with TAcubic3DS structure

ACubicFlat3DS

Formats.m3DSConst

AddAABB

GLScene.GeometryBB

AddBB

GLScene.GeometryBB

Adds a BB into another BB. The original BB (c1) is extended if necessary to contain c2.

AddChild

Formats.m3DSUtils

functions to retrieve/modify data related to materials, lights and objects (meshs)

AddChildOrdered

Formats.m3DSUtils

AddDomainForComponent

gnugettext

Add more domains that component strings can be extracted from. If a translation is not found in the default domain, this domain will be searched, too. This is useful when an application inherits components from a 3rd party component libraries

AddDomainForResourceString

gnugettext

Add more domains that resourcestrings can be extracted from. If a translation is not found in the default domain, this domain will be searched, too. This is useful for adding mo files for certain runtime libraries and 3rd party component libraries

AddDomains

gnugettext

AddPoint

GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1. W coordinate is always 1.

AddSCODEGeomsToODESpace

GLS.ODESkeletonColliders

After loading call this function to add all the geoms in a skeleton collider list to a given ODE space

AddVector

GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1

AddVector

GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1

AddVector

GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1

AddVector

GLScene.VectorGeometry

Sums up f to each component of the vector

AddVector

GLScene.VectorGeometry

Sums up f to each component of the vector

AddVerletConstriantsToVerletWorld

GLS.VerletTypes

After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.

AdjointMatrix

GLScene.VectorGeometry

Adjoint of a 3x3 matrix, used in the computation of the inverse of a 3x3 matrix

AdjointMatrix

GLScene.VectorGeometry

Adjoint of a 4x4 matrix, used in the computation of the inverse of a 4x4 matrix

AffineVectorEquals

GLScene.VectorGeometry

True if X, Y and Z components are equal.

AffineVectorMake

GLScene.VectorGeometry

AffineVectorMake

GLScene.VectorGeometry

ALAUXILIARYEFFECTSLOTF

OpenAL.Import

Set a floating point parameter for an Auxiliary Slot object.

ALAUXILIARYEFFECTSLOTFV

OpenAL.Import

ALAUXILIARYEFFECTSLOTI

OpenAL.Import

Set an integer parameter for a Auxiliary Slot object.

ALAUXILIARYEFFECTSLOTIV

OpenAL.Import

alBuffer3f

OpenAL.Import

alBuffer3i

OpenAL.Import

alBufferData

OpenAL.Import

Specify the data to be filled into a buffer.

alBufferf

OpenAL.Import

alBufferfv

OpenAL.Import

alBufferi

OpenAL.Import

set parameter for an buffer object

alBufferiv

OpenAL.Import

alcCaptureCloseDevice

OpenAL.Import

alcCaptureOpenDevice

OpenAL.Import

Capture functions

alcCaptureSamples

OpenAL.Import

alcCaptureStart

OpenAL.Import

alcCaptureStop

OpenAL.Import

alcCloseDevice

OpenAL.Import

alcCreateContext

OpenAL.Import

alc functions Context Support

alcDestroyContext

OpenAL.Import

alcGetContextsDevice

OpenAL.Import

alcGetCurrentContext

OpenAL.Import

alcGetEnumValue

OpenAL.Import

alcGetError

OpenAL.Import

Error Support Obtain the most recent Context error

alcGetIntegerv

OpenAL.Import

alcGetProcAddress

OpenAL.Import

alcGetString

OpenAL.Import

Query functions

alcIsExtensionPresent

OpenAL.Import

Extension support. Query for the presence of an extension, and obtain any appropriate function pointers and enum values.

alcMakeContextCurrent

OpenAL.Import

alcOpenDevice

OpenAL.Import

Device Management

alcProcessContext

OpenAL.Import

alcSuspendContext

OpenAL.Import

ALC_ALL_ATTRIBUTES

OpenAL.Import

ALC_ALL_DEVICES_SPECIFIER

OpenAL.Import

ALC_ATTRIBUTES_SIZE

OpenAL.Import

ALC_CAPTURE_DEFAULT_DEVICE_SPECIFIER

OpenAL.Import

ALC_CAPTURE_DEVICE_SPECIFIER

OpenAL.Import

Capture extension

ALC_CAPTURE_SAMPLES

OpenAL.Import

ALC_DEFAULT_ALL_DEVICES_SPECIFIER

OpenAL.Import

ALC_ENUMERATE_ALL_EXT enums

ALC_DEFAULT_DEVICE_SPECIFIER

OpenAL.Import

The Specifier string for default device

ALC_DEVICE_SPECIFIER

OpenAL.Import

ALC_EFX_MAJOR_VERSION

OpenAL.Import

Context definitions to be used with alcCreateContext. These values must be unique and not conflict with other al context values.

ALC_EFX_MINOR_VERSION

OpenAL.Import

ALC_EXTENSIONS

OpenAL.Import

ALC_EXT_EFX_NAME

OpenAL.Import

EFX Extension

ALC_FALSE

OpenAL.Import

Boolean False.

ALC_FREQUENCY

OpenAL.Import

followed by <int> Hz

ALC_INVALID

OpenAL.Import

bad value

ALC_INVALID_CONTEXT

OpenAL.Import

invalid context ID

ALC_INVALID_DEVICE

OpenAL.Import

No device

ALC_INVALID_ENUM

OpenAL.Import

bad enum

ALC_INVALID_VALUE

OpenAL.Import

bad value

ALC_MAJOR_VERSION

OpenAL.Import

ALC_MAX_AUXILIARY_SENDS

OpenAL.Import

ALC_MINOR_VERSION

OpenAL.Import

ALC_MONO_SOURCES

OpenAL.Import

followed by <int> Num of requested Mono (3D) Sources

ALC_NO_ERROR

OpenAL.Import

errors No error

ALC_OUT_OF_MEMORY

OpenAL.Import

Out of memory.

ALC_REFRESH

OpenAL.Import

followed by <int> Hz

ALC_STEREO_SOURCES

OpenAL.Import

followed by <int> Num of requested Stereo Sources

ALC_SYNC

OpenAL.Import

followed by AL_TRUE, AL_FALSE

ALC_TRUE

OpenAL.Import

Boolean True.

ALDELETEAUXILIARYEFFECTSLOTS

OpenAL.Import

Delete Auxiliary Slot objects.

alDeleteBuffers

OpenAL.Import

ALDELETEEFFECTS

OpenAL.Import

Delete Effect objects.

ALDELETEFILTERS

OpenAL.Import

Delete Filter objects.

alDeleteSources

OpenAL.Import

Delete Source objects.

alDisable

OpenAL.Import

alDistanceModel

OpenAL.Import

Global Parameters

alDopplerFactor

OpenAL.Import

alDopplerVelocity

OpenAL.Import

ALEFFECTF

OpenAL.Import

Set a floating point parameter for an Effect object.

ALEFFECTFV

OpenAL.Import

ALEFFECTI

OpenAL.Import

Set an integer parameter for an Effect object.

ALEFFECTIV

OpenAL.Import

alEnable

OpenAL.Import

END EAX extension OpenAL Maintenance Functions State Management and Query. Error Handling. Extension Support. Renderer State management.

ALFILTERF

OpenAL.Import

Set a floating point parameter for an Filter object.

ALFILTERFV

OpenAL.Import

ALFILTERI

OpenAL.Import

Set an integer parameter for a Filter object.

ALFILTERIV

OpenAL.Import

ALGENAUXILIARYEFFECTSLOTS

OpenAL.Import

Auxiliary Slot object functions Creates Auxiliary Slot objects.

alGenBuffers

OpenAL.Import

BUFFER Buffer objects are storage space for sample data. Buffers are referred to by Sources. There can be more than one Source using the same Buffer data. If Buffers have to be duplicated on a per-Source basis, the driver has to take care of allocation, copying, and deallocation as well as propagating buffer data changes. Buffer object generation.

ALGENEFFECTS

OpenAL.Import

EFX functions Effect object functions. Create Effect objects.

ALGENFILTERS

OpenAL.Import

Filter object functions Creates Filter objects.

alGenSources

OpenAL.Import

SOURCE Source objects are by default localized. Sources take the PCM data provided in the specified Buffer, apply Source-specific modifications, and then submit them to be mixed according to spatial arrangement etc. Create Source objects.

ALGETAUXILIARYEFFECTSLOTF

OpenAL.Import

Get a floating point parameter for a Auxiliary Slot object.

ALGETAUXILIARYEFFECTSLOTFV

OpenAL.Import

ALGETAUXILIARYEFFECTSLOTI

OpenAL.Import

Get an integer parameter for a Auxiliary Slot object.

ALGETAUXILIARYEFFECTSLOTIV

OpenAL.Import

alGetBoolean

OpenAL.Import

State retrieval.through return value ( for compatibility )

alGetBooleanv

OpenAL.Import

State retrieval.

alGetBuffer3f

OpenAL.Import

alGetBuffer3i

OpenAL.Import

alGetBufferf

OpenAL.Import

alGetBufferfv

OpenAL.Import

alGetBufferi

OpenAL.Import

read parameter for an buffer object

alGetBufferiv

OpenAL.Import

alGetDouble

OpenAL.Import

alGetDoublev

OpenAL.Import

ALGETEFFECTF

OpenAL.Import

Get a floating point parameter for an Effect object.

ALGETEFFECTFV

OpenAL.Import

ALGETEFFECTI

OpenAL.Import

Get an integer parameter for an Effect object.

ALGETEFFECTIV

OpenAL.Import

alGetEnumValue

OpenAL.Import

Obtain the integer value of an enumeration (usually an extension) with the name ename.

alGetError

OpenAL.Import

ERROR support. Obtain the most recent error generated in the AL state machine.

ALGETFILTERF

OpenAL.Import

Get a floating point parameter for a Filter object.

ALGETFILTERFV

OpenAL.Import

ALGETFILTERI

OpenAL.Import

Get an integer parameter for a Filter object.

ALGETFILTERIV

OpenAL.Import

alGetFloat

OpenAL.Import

alGetFloatv

OpenAL.Import

alGetInteger

OpenAL.Import

alGetIntegerv

OpenAL.Import

alGetListenerfv

OpenAL.Import

alGetListeneriv

OpenAL.Import

TODO: verder ontbrekende functies toevoegen. Retrieve listener information

alGetProcAddress

OpenAL.Import

Obtain the address of a function (usually an extension) with the name fname. All addresses are context-independent.

alGetSource3f

OpenAL.Import

Get three float scalar parameter for a Source object.

alGetSource3i

OpenAL.Import

Get three integer scalar parameter for a Source object.

alGetSourcef

OpenAL.Import

Get a float scalar parameter for a Source object.

alGetSourcefv

OpenAL.Import

Get a float vector parameter for a Source object.

alGetSourcei

OpenAL.Import

Get an integer scalar parameter for a Source object.

alGetSourceiv

OpenAL.Import

Get a integer vector parameter for a Source object.

alGetString

OpenAL.Import

AlgorithmMStringToDouble

PasDblStrUtils

AlgorithmMStringToDouble

PasDblStrUtils

alHint

OpenAL.Import

Application preferences for driver performance choices.

ALISAUXILIARYEFFECTSLOT

OpenAL.Import

Verify a handle is a valid Auxiliary Slot.

alIsBuffer

OpenAL.Import

ALISEFFECT

OpenAL.Import

Verify a handle is a valid Effect.

alIsEnabled

OpenAL.Import

alIsExtensionPresent

OpenAL.Import

EXTENSION support. Obtain the address of a function (usually an extension) with the name fname. All addresses are context-independent.

ALISFILTER

OpenAL.Import

Verify a handle is a valid Filter.

alIsSource

OpenAL.Import

Verify a handle is a valid Source.

alListener3f

OpenAL.Import

Listener Position. Listener Velocity.

alListener3i

OpenAL.Import

alListenerf

OpenAL.Import

LISTENER Listener is the sample position for a given context. The multi-channel (usually stereo) output stream generated by the mixer is parametrized by this Listener object: its position and velocity relative to Sources, within occluder and reflector geometry. Listener Gain: default 1.0f.

alListenerfv

OpenAL.Import

Listener Position: array [0..2] of TALfloat Listener Velocity: array [0..2] of TALfloat Listener Orientation: array [0..5] of TALfloat forward and up vector.

alListeneri

OpenAL.Import

Listener Environment: default 0.

alListeneriv

OpenAL.Import

ALLOC_SIZE

GLS.Isosurface

AlphaGammaBrightCorrection

GLS.ImageUtils

alSource3f

OpenAL.Import

Set a 3 float parameter for a Source object.

alSource3i

OpenAL.Import

Set an 3 integer parameter for a Source object.

alSourcef

OpenAL.Import

Set a float parameter for a Source object.

alSourcefv

OpenAL.Import

Set a float vector parameter for a Source object.

alSourcei

OpenAL.Import

Set an integer parameter for a Source object.

alSourceiv

OpenAL.Import

Set an integer vector parameter for a Source object.

alSourcePause

OpenAL.Import

Pause a source, temporarily remove it from the mixer list.

alSourcePausev

OpenAL.Import

alSourcePlay

OpenAL.Import

Activate a source, start replay.

alSourcePlayv

OpenAL.Import

vector forms of those functions we all love

alSourceQueueBuffers

OpenAL.Import

Queue stuff

alSourceRewind

OpenAL.Import

Rewind a souce. Stopped paused and playing sources, resets the offset into the PCM data and sets state to AL_INITIAL.

alSourceRewindv

OpenAL.Import

alSourceStop

OpenAL.Import

Stop a source, temporarily remove it from the mixer list, and reset its internal state to pre-Play. To remove a Source completely, it has to be deleted following Stop, or before Play.

alSourceStopv

OpenAL.Import

alSourceUnqueueBuffers

OpenAL.Import

alSpeedOfSound

OpenAL.Import

alutExit

OpenAL.Import

alutInit

OpenAL.Import

Internal Alut functions

alutLoadWAVFile

OpenAL.Import

alutLoadWAVMemory

OpenAL.Import

alutUnloadWAV

OpenAL.Import

AL_AIR_ABSORPTION_FACTOR

OpenAL.Import

AL_AUTOWAH_ATTACK_TIME

OpenAL.Import

Autowah Parameters

AL_AUTOWAH_DEFAULT_ATTACK_TIME

OpenAL.Import

AL_AUTOWAH_DEFAULT_PEAK_GAIN

OpenAL.Import

AL_AUTOWAH_DEFAULT_RELEASE_TIME

OpenAL.Import

AL_AUTOWAH_DEFAULT_RESONANCE

OpenAL.Import

AL_AUTOWAH_MAX_ATTACK_TIME

OpenAL.Import

AL_AUTOWAH_MAX_PEAK_GAIN

OpenAL.Import

AL_AUTOWAH_MAX_RELEASE_TIME

OpenAL.Import

AL_AUTOWAH_MAX_RESONANCE

OpenAL.Import

AL_AUTOWAH_MIN_ATTACK_TIME

OpenAL.Import

AL autowah effect parameter ranges and defaults

AL_AUTOWAH_MIN_PEAK_GAIN

OpenAL.Import

AL_AUTOWAH_MIN_RELEASE_TIME

OpenAL.Import

AL_AUTOWAH_MIN_RESONANCE

OpenAL.Import

AL_AUTOWAH_PEAK_GAIN

OpenAL.Import

AL_AUTOWAH_RELEASE_TIME

OpenAL.Import

AL_AUTOWAH_RESONANCE

OpenAL.Import

AL_AUXILIARY_SEND_FILTER

OpenAL.Import

AL_AUXILIARY_SEND_FILTER_GAINHF_AUTO

OpenAL.Import

AL_AUXILIARY_SEND_FILTER_GAIN_AUTO

OpenAL.Import

AL_BANDPASS_GAIN

OpenAL.Import

Bandpass Parameters

AL_BANDPASS_GAINHF

OpenAL.Import

AL_BANDPASS_GAINLF

OpenAL.Import

AL_BITS

OpenAL.Import

AL_BUFFER

OpenAL.Import

Indicate the buffer to provide sound samples. Type: ALuint. Range: any valid Buffer id.

AL_BUFFERS_PROCESSED

OpenAL.Import

AL_BUFFERS_QUEUED

OpenAL.Import

Buffer Queue params

AL_BYTE_OFFSET

OpenAL.Import

AL_CHANNELS

OpenAL.Import

AL_CHANNEL_MASK

OpenAL.Import

Specify the channel mask. (Creative) Type: ALuint Range: [0 - 255]

AL_CHORUS_DEFAULT_DELAY

OpenAL.Import

AL_CHORUS_DEFAULT_DEPTH

OpenAL.Import

AL_CHORUS_DEFAULT_FEEDBACK

OpenAL.Import

AL_CHORUS_DEFAULT_PHASE

OpenAL.Import

AL_CHORUS_DEFAULT_RATE

OpenAL.Import

AL_CHORUS_DEFAULT_WAVEFORM

OpenAL.Import

AL_CHORUS_DELAY

OpenAL.Import

AL_CHORUS_DEPTH

OpenAL.Import

AL_CHORUS_FEEDBACK

OpenAL.Import

AL_CHORUS_MAX_DELAY

OpenAL.Import

AL_CHORUS_MAX_DEPTH

OpenAL.Import

AL_CHORUS_MAX_FEEDBACK

OpenAL.Import

AL_CHORUS_MAX_PHASE

OpenAL.Import

AL_CHORUS_MAX_RATE

OpenAL.Import

AL_CHORUS_MAX_WAVEFORM

OpenAL.Import

AL_CHORUS_MIN_DELAY

OpenAL.Import

AL_CHORUS_MIN_DEPTH

OpenAL.Import

AL_CHORUS_MIN_FEEDBACK

OpenAL.Import

AL_CHORUS_MIN_PHASE

OpenAL.Import

AL_CHORUS_MIN_RATE

OpenAL.Import

AL_CHORUS_MIN_WAVEFORM

OpenAL.Import

AL chorus effect parameter ranges and defaults

AL_CHORUS_PHASE

OpenAL.Import

AL_CHORUS_RATE

OpenAL.Import

AL_CHORUS_WAVEFORM

OpenAL.Import

Chorus Parameters

AL_CHORUS_WAVEFORM_SINUSOID

OpenAL.Import

AL_CHORUS_WAVEFORM_TRIANGLE

OpenAL.Import

AL_COMPRESSOR_DEFAULT_ONOFF

OpenAL.Import

AL_COMPRESSOR_MAX_ONOFF

OpenAL.Import

AL_COMPRESSOR_MIN_ONOFF

OpenAL.Import

AL compressor effect parameter ranges and defaults

AL_COMPRESSOR_ONOFF

OpenAL.Import

Compressor Parameters

AL_CONE_INNER_ANGLE

OpenAL.Import

Directional source, inner cone angle, in degrees. Range: [0-360] Default: 360

AL_CONE_OUTER_ANGLE

OpenAL.Import

Directional source, outer cone angle, in degrees. Range: [0-360] Default: 360

AL_CONE_OUTER_GAIN

OpenAL.Import

Directional source, outer cone gain. Default: 0.0 Range: [0.0 - 1.0] Logarithmic

AL_CONE_OUTER_GAINHF

OpenAL.Import

AL_DEFAULT_AIR_ABSORPTION_FACTOR

OpenAL.Import

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAINHF_AUTO

OpenAL.Import

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAIN_AUTO

OpenAL.Import

AL_DEFAULT_CONE_OUTER_GAINHF

OpenAL.Import

AL_DEFAULT_DIRECT_FILTER_GAINHF_AUTO

OpenAL.Import

AL_DEFAULT_METERS_PER_UNIT

OpenAL.Import

Listener parameter value definitions, ranges and defaults. AL_MIN_METERS_PER_UNIT =FLT_MIN; AL_MAX_METERS_PER_UNIT =FLT_MAX;

AL_DEFAULT_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_DIRECTION

OpenAL.Import

Specify the current direction.

AL_DIRECT_FILTER

OpenAL.Import

Source definitions to be used with alSource functions. These values must be unique and not conflict with other al source values.

AL_DIRECT_FILTER_GAINHF_AUTO

OpenAL.Import

AL_DISTANCE_MODEL

OpenAL.Import

Distance models
used in conjunction with DistanceModel
implicit: NONE, which disances distance attenuation.

AL_DISTORTION_DEFAULT_EDGE

OpenAL.Import

AL_DISTORTION_DEFAULT_EQBANDWIDTH

OpenAL.Import

AL_DISTORTION_DEFAULT_EQCENTER

OpenAL.Import

AL_DISTORTION_DEFAULT_GAIN

OpenAL.Import

AL_DISTORTION_DEFAULT_LOWPASS_CUTOFF

OpenAL.Import

AL_DISTORTION_EDGE

OpenAL.Import

Distortion Parameters

AL_DISTORTION_EQBANDWIDTH

OpenAL.Import

AL_DISTORTION_EQCENTER

OpenAL.Import

AL_DISTORTION_GAIN

OpenAL.Import

AL_DISTORTION_LOWPASS_CUTOFF

OpenAL.Import

AL_DISTORTION_MAX_EDGE

OpenAL.Import

AL_DISTORTION_MAX_EQBANDWIDTH

OpenAL.Import

AL_DISTORTION_MAX_EQCENTER

OpenAL.Import

AL_DISTORTION_MAX_GAIN

OpenAL.Import

AL_DISTORTION_MAX_LOWPASS_CUTOFF

OpenAL.Import

AL_DISTORTION_MIN_EDGE

OpenAL.Import

AL distortion effect parameter ranges and defaults

AL_DISTORTION_MIN_EQBANDWIDTH

OpenAL.Import

AL_DISTORTION_MIN_EQCENTER

OpenAL.Import

AL_DISTORTION_MIN_GAIN

OpenAL.Import

AL_DISTORTION_MIN_LOWPASS_CUTOFF

OpenAL.Import

AL_DOPPLER_FACTOR

OpenAL.Import

Global tweakage. Doppler scale. Default 1.0

AL_DOPPLER_VELOCITY

OpenAL.Import

Tweaks speed of propagation.

AL_EAXREVERB_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_EAXREVERB_DECAY_HFLIMIT

OpenAL.Import

AL_EAXREVERB_DECAY_HFRATIO

OpenAL.Import

AL_EAXREVERB_DECAY_LFRATIO

OpenAL.Import

AL_EAXREVERB_DECAY_TIME

OpenAL.Import

AL_EAXREVERB_DEFAULT_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_EAXREVERB_DEFAULT_DECAY_HFLIMIT

OpenAL.Import

AL_EAXREVERB_DEFAULT_DECAY_HFRATIO

OpenAL.Import

AL_EAXREVERB_DEFAULT_DECAY_LFRATIO

OpenAL.Import

AL_EAXREVERB_DEFAULT_DECAY_TIME

OpenAL.Import

AL_EAXREVERB_DEFAULT_DENSITY

OpenAL.Import

AL_EAXREVERB_DEFAULT_DIFFUSION

OpenAL.Import

AL_EAXREVERB_DEFAULT_ECHO_DEPTH

OpenAL.Import

AL_EAXREVERB_DEFAULT_ECHO_TIME

OpenAL.Import

AL_EAXREVERB_DEFAULT_GAIN

OpenAL.Import

AL_EAXREVERB_DEFAULT_GAINHF

OpenAL.Import

AL_EAXREVERB_DEFAULT_GAINLF

OpenAL.Import

AL_EAXREVERB_DEFAULT_HFREFERENCE

OpenAL.Import

AL_EAXREVERB_DEFAULT_LATE_REVERB_DELAY

OpenAL.Import

AL_EAXREVERB_DEFAULT_LATE_REVERB_GAIN

OpenAL.Import

AL_EAXREVERB_DEFAULT_LATE_REVERB_PAN

OpenAL.Import

AL_EAXREVERB_DEFAULT_LFREFERENCE

OpenAL.Import

AL_EAXREVERB_DEFAULT_MODULATION_DEPTH

OpenAL.Import

AL_EAXREVERB_DEFAULT_MODULATION_TIME

OpenAL.Import

AL_EAXREVERB_DEFAULT_REFLECTIONS_DELAY

OpenAL.Import

AL_EAXREVERB_DEFAULT_REFLECTIONS_GAIN

OpenAL.Import

AL_EAXREVERB_DEFAULT_REFLECTIONS_PAN

OpenAL.Import

AL_EAXREVERB_DEFAULT_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_EAXREVERB_DENSITY

OpenAL.Import

EFX AEX extenstion Effect object definitions to be used with alEffect functions. Effect parameter value definitions, ranges, and defaults appear farther down in this file. AL EAXReverb effect parameters.

AL_EAXREVERB_DIFFUSION

OpenAL.Import

AL_EAXREVERB_ECHO_DEPTH

OpenAL.Import

AL_EAXREVERB_ECHO_TIME

OpenAL.Import

AL_EAXREVERB_GAIN

OpenAL.Import

AL_EAXREVERB_GAINHF

OpenAL.Import

AL_EAXREVERB_GAINLF

OpenAL.Import

AL_EAXREVERB_HFREFERENCE

OpenAL.Import

AL_EAXREVERB_LATE_REVERB_DELAY

OpenAL.Import

AL_EAXREVERB_LATE_REVERB_GAIN

OpenAL.Import

AL_EAXREVERB_LATE_REVERB_PAN

OpenAL.Import

AL_EAXREVERB_LFREFERENCE

OpenAL.Import

AL_EAXREVERB_MAX_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_EAXREVERB_MAX_DECAY_HFLIMIT

OpenAL.Import

AL_EAXREVERB_MAX_DECAY_HFRATIO

OpenAL.Import

AL_EAXREVERB_MAX_DECAY_LFRATIO

OpenAL.Import

AL_EAXREVERB_MAX_DECAY_TIME

OpenAL.Import

AL_EAXREVERB_MAX_DENSITY

OpenAL.Import

AL_EAXREVERB_MAX_DIFFUSION

OpenAL.Import

AL_EAXREVERB_MAX_ECHO_DEPTH

OpenAL.Import

AL_EAXREVERB_MAX_ECHO_TIME

OpenAL.Import

AL_EAXREVERB_MAX_GAIN

OpenAL.Import

AL_EAXREVERB_MAX_GAINHF

OpenAL.Import

AL_EAXREVERB_MAX_GAINLF

OpenAL.Import

AL_EAXREVERB_MAX_HFREFERENCE

OpenAL.Import

AL_EAXREVERB_MAX_LATE_REVERB_DELAY

OpenAL.Import

AL_EAXREVERB_MAX_LATE_REVERB_GAIN

OpenAL.Import

AL_EAXREVERB_MAX_LFREFERENCE

OpenAL.Import

AL_EAXREVERB_MAX_MODULATION_DEPTH

OpenAL.Import

AL_EAXREVERB_MAX_MODULATION_TIME

OpenAL.Import

AL_EAXREVERB_MAX_REFLECTIONS_DELAY

OpenAL.Import

AL_EAXREVERB_MAX_REFLECTIONS_GAIN

OpenAL.Import

AL_EAXREVERB_MAX_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_EAXREVERB_MIN_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_EAXREVERB_MIN_DECAY_HFLIMIT

OpenAL.Import

AL_EAXREVERB_MIN_DECAY_HFRATIO

OpenAL.Import

AL_EAXREVERB_MIN_DECAY_LFRATIO

OpenAL.Import

AL_EAXREVERB_MIN_DECAY_TIME

OpenAL.Import

AL_EAXREVERB_MIN_DENSITY

OpenAL.Import

Effect parameter structures, value definitions, ranges and defaults. AL reverb effect parameter ranges and defaults

AL_EAXREVERB_MIN_DIFFUSION

OpenAL.Import

AL_EAXREVERB_MIN_ECHO_DEPTH

OpenAL.Import

AL_EAXREVERB_MIN_ECHO_TIME

OpenAL.Import

AL_EAXREVERB_MIN_GAIN

OpenAL.Import

AL_EAXREVERB_MIN_GAINHF

OpenAL.Import

AL_EAXREVERB_MIN_GAINLF

OpenAL.Import

AL_EAXREVERB_MIN_HFREFERENCE

OpenAL.Import

AL_EAXREVERB_MIN_LATE_REVERB_DELAY

OpenAL.Import

AL_EAXREVERB_MIN_LATE_REVERB_GAIN

OpenAL.Import

AL_EAXREVERB_MIN_LFREFERENCE

OpenAL.Import

AL_EAXREVERB_MIN_MODULATION_DEPTH

OpenAL.Import

AL_EAXREVERB_MIN_MODULATION_TIME

OpenAL.Import

AL_EAXREVERB_MIN_REFLECTIONS_DELAY

OpenAL.Import

AL_EAXREVERB_MIN_REFLECTIONS_GAIN

OpenAL.Import

AL_EAXREVERB_MIN_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_EAXREVERB_MODULATION_DEPTH

OpenAL.Import

AL_EAXREVERB_MODULATION_TIME

OpenAL.Import

AL_EAXREVERB_REFLECTIONS_DELAY

OpenAL.Import

AL_EAXREVERB_REFLECTIONS_GAIN

OpenAL.Import

AL_EAXREVERB_REFLECTIONS_PAN

OpenAL.Import

AL_EAXREVERB_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_EAX_RAM_FREE

OpenAL.Import

AL_EAX_RAM_SIZE

OpenAL.Import

X-RAM enums

AL_ECHO_DAMPING

OpenAL.Import

AL_ECHO_DEFAULT_DAMPING

OpenAL.Import

AL_ECHO_DEFAULT_DELAY

OpenAL.Import

AL_ECHO_DEFAULT_FEEDBACK

OpenAL.Import

AL_ECHO_DEFAULT_LRDELAY

OpenAL.Import

AL_ECHO_DEFAULT_SPREAD

OpenAL.Import

AL_ECHO_DELAY

OpenAL.Import

Echo Parameters

AL_ECHO_FEEDBACK

OpenAL.Import

AL_ECHO_LRDELAY

OpenAL.Import

AL_ECHO_MAX_DAMPING

OpenAL.Import

AL_ECHO_MAX_DELAY

OpenAL.Import

AL_ECHO_MAX_FEEDBACK

OpenAL.Import

AL_ECHO_MAX_LRDELAY

OpenAL.Import

AL_ECHO_MAX_SPREAD

OpenAL.Import

AL_ECHO_MIN_DAMPING

OpenAL.Import

AL_ECHO_MIN_DELAY

OpenAL.Import

AL echo effect parameter ranges and defaults

AL_ECHO_MIN_FEEDBACK

OpenAL.Import

AL_ECHO_MIN_LRDELAY

OpenAL.Import

AL_ECHO_MIN_SPREAD

OpenAL.Import

AL_ECHO_SPREAD

OpenAL.Import

AL_EFFECTSLOT_AUXILIARY_SEND_AUTO

OpenAL.Import

AL_EFFECTSLOT_EFFECT

OpenAL.Import

Auxiliary Slot object definitions to be used with alAuxiliaryEffectSlot functions.

AL_EFFECTSLOT_GAIN

OpenAL.Import

AL_EFFECTSLOT_NULL

OpenAL.Import

Value to be used as an Auxiliary Slot ID to disable a source send..

AL_EFFECT_AUTOWAH

OpenAL.Import

AL_EFFECT_CHORUS

OpenAL.Import

AL_EFFECT_COMPRESSOR

OpenAL.Import

AL_EFFECT_DISTORTION

OpenAL.Import

AL_EFFECT_EAXREVERB

OpenAL.Import

Effect type definitions to be used with AL_EFFECT_TYPE.

AL_EFFECT_ECHO

OpenAL.Import

AL_EFFECT_EQUALIZER

OpenAL.Import

AL_EFFECT_FIRST_PARAMETER

OpenAL.Import

Effect type

AL_EFFECT_FLANGER

OpenAL.Import

AL_EFFECT_FREQUENCY_SHIFTER

OpenAL.Import

AL_EFFECT_LAST_PARAMETER

OpenAL.Import

AL_EFFECT_NULL

OpenAL.Import

Effect type definitions to be used with AL_EFFECT_TYPE.

AL_EFFECT_PITCH_SHIFTER

OpenAL.Import

AL_EFFECT_REVERB

OpenAL.Import

Can also be used as an Effect Object ID

AL_EFFECT_RING_MODULATOR

OpenAL.Import

AL_EFFECT_TYPE

OpenAL.Import

AL_EFFECT_VOCAL_MORPHER

OpenAL.Import

AL_EQUALIZER_DEFAULT_HIGH_CUTOFF

OpenAL.Import

AL_EQUALIZER_DEFAULT_HIGH_GAIN

OpenAL.Import

AL_EQUALIZER_DEFAULT_LOW_CUTOFF

OpenAL.Import

AL_EQUALIZER_DEFAULT_LOW_GAIN

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID1_CENTER

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID1_GAIN

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID1_WIDTH

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID2_CENTER

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID2_GAIN

OpenAL.Import

AL_EQUALIZER_DEFAULT_MID2_WIDTH

OpenAL.Import

AL_EQUALIZER_HIGH_CUTOFF

OpenAL.Import

AL_EQUALIZER_HIGH_GAIN

OpenAL.Import

AL_EQUALIZER_LOW_CUTOFF

OpenAL.Import

AL_EQUALIZER_LOW_GAIN

OpenAL.Import

Equalizer Parameters

AL_EQUALIZER_MAX_HIGH_CUTOFF

OpenAL.Import

AL_EQUALIZER_MAX_HIGH_GAIN

OpenAL.Import

AL_EQUALIZER_MAX_LOW_CUTOFF

OpenAL.Import

AL_EQUALIZER_MAX_LOW_GAIN

OpenAL.Import

AL_EQUALIZER_MAX_MID1_CENTER

OpenAL.Import

AL_EQUALIZER_MAX_MID1_GAIN

OpenAL.Import

AL_EQUALIZER_MAX_MID1_WIDTH

OpenAL.Import

AL_EQUALIZER_MAX_MID2_CENTER

OpenAL.Import

AL_EQUALIZER_MAX_MID2_GAIN

OpenAL.Import

AL_EQUALIZER_MAX_MID2_WIDTH

OpenAL.Import

AL_EQUALIZER_MID1_CENTER

OpenAL.Import

AL_EQUALIZER_MID1_GAIN

OpenAL.Import

AL_EQUALIZER_MID1_WIDTH

OpenAL.Import

AL_EQUALIZER_MID2_CENTER

OpenAL.Import

AL_EQUALIZER_MID2_GAIN

OpenAL.Import

AL_EQUALIZER_MID2_WIDTH

OpenAL.Import

AL_EQUALIZER_MIN_HIGH_CUTOFF

OpenAL.Import

AL_EQUALIZER_MIN_HIGH_GAIN

OpenAL.Import

AL_EQUALIZER_MIN_LOW_CUTOFF

OpenAL.Import

AL_EQUALIZER_MIN_LOW_GAIN

OpenAL.Import

AL equalizer effect parameter ranges and defaults

AL_EQUALIZER_MIN_MID1_CENTER

OpenAL.Import

AL_EQUALIZER_MIN_MID1_GAIN

OpenAL.Import

AL_EQUALIZER_MIN_MID1_WIDTH

OpenAL.Import

AL_EQUALIZER_MIN_MID2_CENTER

OpenAL.Import

AL_EQUALIZER_MIN_MID2_GAIN

OpenAL.Import

AL_EQUALIZER_MIN_MID2_WIDTH

OpenAL.Import

AL_EXPONENT_DISTANCE

OpenAL.Import

AL_EXPONENT_DISTANCE_CLAMPED

OpenAL.Import

AL_EXTENSIONS

OpenAL.Import

AL_FALSE

OpenAL.Import

Boolean False.

AL_FILTER_BANDPASS

OpenAL.Import

AL_FILTER_FIRST_PARAMETER

OpenAL.Import

Filter type

AL_FILTER_HIGHPASS

OpenAL.Import

AL_FILTER_LAST_PARAMETER

OpenAL.Import

AL_FILTER_LOWPASS

OpenAL.Import

Can also be used as a Filter Object ID

AL_FILTER_NULL

OpenAL.Import

Filter type definitions to be used with AL_FILTER_TYPE.

AL_FILTER_TYPE

OpenAL.Import

AL_FLANGER_DEFAULT_DELAY

OpenAL.Import

AL_FLANGER_DEFAULT_DEPTH

OpenAL.Import

AL_FLANGER_DEFAULT_FEEDBACK

OpenAL.Import

AL_FLANGER_DEFAULT_PHASE

OpenAL.Import

AL_FLANGER_DEFAULT_RATE

OpenAL.Import

AL_FLANGER_DEFAULT_WAVEFORM

OpenAL.Import

AL_FLANGER_DELAY

OpenAL.Import

AL_FLANGER_DEPTH

OpenAL.Import

AL_FLANGER_FEEDBACK

OpenAL.Import

AL_FLANGER_MAX_DELAY

OpenAL.Import

AL_FLANGER_MAX_DEPTH

OpenAL.Import

AL_FLANGER_MAX_FEEDBACK

OpenAL.Import

AL_FLANGER_MAX_PHASE

OpenAL.Import

AL_FLANGER_MAX_RATE

OpenAL.Import

AL_FLANGER_MAX_WAVEFORM

OpenAL.Import

AL_FLANGER_MIN_DELAY

OpenAL.Import

AL_FLANGER_MIN_DEPTH

OpenAL.Import

AL_FLANGER_MIN_FEEDBACK

OpenAL.Import

AL_FLANGER_MIN_PHASE

OpenAL.Import

AL_FLANGER_MIN_RATE

OpenAL.Import

AL_FLANGER_MIN_WAVEFORM

OpenAL.Import

AL flanger effect parameter ranges and defaults

AL_FLANGER_PHASE

OpenAL.Import

AL_FLANGER_RATE

OpenAL.Import

AL_FLANGER_WAVEFORM

OpenAL.Import

Flanger Parameters

AL_FLANGER_WAVEFORM_SINUSOID

OpenAL.Import

AL_FLANGER_WAVEFORM_TRIANGLE

OpenAL.Import

AL_FORMAT_MONO16

OpenAL.Import

AL_FORMAT_MONO8

OpenAL.Import

Sound samples: format specifier.

AL_FORMAT_STEREO16

OpenAL.Import

AL_FORMAT_STEREO8

OpenAL.Import

AL_FREQUENCY

OpenAL.Import

Sound samples: frequency, in units of Hertz [Hz]. This is the number of samples per second. Half of the sample frequency marks the maximum significant frequency component.

AL_FREQUENCY_SHIFTER_DEFAULT_FREQUENCY

OpenAL.Import

AL_FREQUENCY_SHIFTER_DEFAULT_LEFT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_DEFAULT_RIGHT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_DIRECTION_DOWN

OpenAL.Import

AL_FREQUENCY_SHIFTER_DIRECTION_OFF

OpenAL.Import

AL_FREQUENCY_SHIFTER_DIRECTION_UP

OpenAL.Import

AL_FREQUENCY_SHIFTER_FREQUENCY

OpenAL.Import

Frequencyshifter Parameters

AL_FREQUENCY_SHIFTER_LEFT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_MAX_FREQUENCY

OpenAL.Import

AL_FREQUENCY_SHIFTER_MAX_LEFT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_MAX_RIGHT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_MIN_FREQUENCY

OpenAL.Import

AL frequency shifter effect parameter ranges and defaults

AL_FREQUENCY_SHIFTER_MIN_LEFT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_MIN_RIGHT_DIRECTION

OpenAL.Import

AL_FREQUENCY_SHIFTER_RIGHT_DIRECTION

OpenAL.Import

AL_GAIN

OpenAL.Import

Indicate the gain (volume amplification) applied. Type: ALfloat. Range: ]0.0- ] A value of 1.0 means un-attenuated/unchanged. Each division by 2 equals an attenuation of -6dB. Each multiplicaton with 2 equals an amplification of +6dB. A value of 0.0 is meaningless with respect to a logarithmic scale; it is interpreted as zero volume - the channel is effectively disabled.

AL_HIGHPASS_GAIN

OpenAL.Import

Highpass Parameters

AL_HIGHPASS_GAINLF

OpenAL.Import

AL_ILLEGAL_COMMAND

OpenAL.Import

Illegal call.

AL_ILLEGAL_ENUM

OpenAL.Import

Invalid parameter passed to AL call.

AL_INITIAL

OpenAL.Import

AL_INVALID

OpenAL.Import

END EAX Extension bad value

AL_INVALID_ENUM

OpenAL.Import

AL_INVALID_NAME

OpenAL.Import

Invalid Name paramater passed to AL call.

AL_INVALID_OPERATION

OpenAL.Import

AL_INVALID_VALUE

OpenAL.Import

Invalid enum parameter value.

AL_INVERSE_DISTANCE

OpenAL.Import

AL_INVERSE_DISTANCE_CLAMPED

OpenAL.Import

AL_LINEAR_DISTANCE

OpenAL.Import

AL_LINEAR_DISTANCE_CLAMPED

OpenAL.Import

AL_LOOPING

OpenAL.Import

Indicate whether source is looping. Type: ALboolean? Range: [AL_TRUE, AL_FALSE] Default: FALSE.

AL_LOWPASS_GAIN

OpenAL.Import

Filter object definitions to be used with alFilter functions. Lowpass parameters.

AL_LOWPASS_GAINHF

OpenAL.Import

AL_MAX_AIR_ABSORPTION_FACTOR

OpenAL.Import

AL_MAX_AUXILIARY_SEND_FILTER_GAINHF_AUTO

OpenAL.Import

AL_MAX_AUXILIARY_SEND_FILTER_GAIN_AUTO

OpenAL.Import

AL_MAX_CONE_OUTER_GAINHF

OpenAL.Import

AL_MAX_DIRECT_FILTER_GAINHF_AUTO

OpenAL.Import

AL_MAX_DISTANCE

OpenAL.Import

Indicate distance above which sources are not attenuated using the inverse clamped distance model. Default: +inf Type: ALfloat Range: 0.0 - +inf

AL_MAX_GAIN

OpenAL.Import

Indicate maximum source attenuation Type: ALfloat Range: [0.0 - 1.0] Logarthmic

AL_MAX_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_METERS_PER_UNIT

OpenAL.Import

Listener definitions to be used with alListener functions. These values must be unique and not conflict with other al listener values.

AL_MIN_AIR_ABSORPTION_FACTOR

OpenAL.Import

Source parameter value definitions, ranges and defaults.

AL_MIN_AUXILIARY_SEND_FILTER_GAINHF_AUTO

OpenAL.Import

AL_MIN_AUXILIARY_SEND_FILTER_GAIN_AUTO

OpenAL.Import

AL_MIN_CONE_OUTER_GAINHF

OpenAL.Import

AL_MIN_DIRECT_FILTER_GAINHF_AUTO

OpenAL.Import

AL_MIN_GAIN

OpenAL.Import

Indicate minimum source attenuation Type: ALfloat Range: [0.0 - 1.0] Logarthmic

AL_MIN_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_NONE

OpenAL.Import

AL_NO_ERROR

OpenAL.Import

Errors: No Error.

AL_ORIENTATION

OpenAL.Import

Indicate listener orientation. at/up

AL_OUT_OF_MEMORY

OpenAL.Import

No mojo.

AL_PAUSED

OpenAL.Import

AL_PENDING

OpenAL.Import

AL_PITCH

OpenAL.Import

Specify the pitch to be applied, either at source, or on mixer results, at listener. Range: [0.5-2.0] Default: 1.0

AL_PITCH_SHIFTER_COARSE_TUNE

OpenAL.Import

Pitchshifter Parameters

AL_PITCH_SHIFTER_DEFAULT_COARSE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_DEFAULT_FINE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_FINE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_MAX_COARSE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_MAX_FINE_TUNE

OpenAL.Import

AL_PITCH_SHIFTER_MIN_COARSE_TUNE

OpenAL.Import

AL pitch shifter effect parameter ranges and defaults

AL_PITCH_SHIFTER_MIN_FINE_TUNE

OpenAL.Import

AL_PLAYING

OpenAL.Import

AL_POSITION

OpenAL.Import

Specify the current location in three dimensional space. OpenAL, like OpenGL, uses a right handed coordinate system, where in a frontal default view X (thumb) points right, Y points up (index finger), and Z points towards the viewer/camera (middle finger). To switch from a left handed coordinate system, flip the sign on the Z coordinate. Listener position is always in the world coordinate system.

AL_PROCESSED

OpenAL.Import

AL_REFERENCE_DISTANCE

OpenAL.Import

source specific reference distance Type: ALfloat Range: 0.0 - +inf At 0.0, no distance attenuation occurs. Default is 1.0.

AL_RENDERER

OpenAL.Import

AL_REVERB_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_REVERB_DECAY_HFLIMIT

OpenAL.Import

AL_REVERB_DECAY_HFRATIO

OpenAL.Import

AL_REVERB_DECAY_TIME

OpenAL.Import

AL_REVERB_DEFAULT_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_REVERB_DEFAULT_DECAY_HFLIMIT

OpenAL.Import

AL_REVERB_DEFAULT_DECAY_HFRATIO

OpenAL.Import

AL_REVERB_DEFAULT_DECAY_TIME

OpenAL.Import

AL_REVERB_DEFAULT_DENSITY

OpenAL.Import

AL_REVERB_DEFAULT_DIFFUSION

OpenAL.Import

AL_REVERB_DEFAULT_GAIN

OpenAL.Import

AL_REVERB_DEFAULT_GAINHF

OpenAL.Import

AL_REVERB_DEFAULT_LATE_REVERB_DELAY

OpenAL.Import

AL_REVERB_DEFAULT_LATE_REVERB_GAIN

OpenAL.Import

AL_REVERB_DEFAULT_REFLECTIONS_DELAY

OpenAL.Import

AL_REVERB_DEFAULT_REFLECTIONS_GAIN

OpenAL.Import

AL_REVERB_DEFAULT_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_REVERB_DENSITY

OpenAL.Import

Effect object definitions to be used with alEffect functions. Effect parameter value definitions, ranges, and defaults appear farther down in this file. Reverb Parameters

AL_REVERB_DIFFUSION

OpenAL.Import

AL_REVERB_GAIN

OpenAL.Import

AL_REVERB_GAINHF

OpenAL.Import

AL_REVERB_LATE_REVERB_DELAY

OpenAL.Import

AL_REVERB_LATE_REVERB_GAIN

OpenAL.Import

AL_REVERB_MAX_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_REVERB_MAX_DECAY_HFLIMIT

OpenAL.Import

AL_REVERB_MAX_DECAY_HFRATIO

OpenAL.Import

AL_REVERB_MAX_DECAY_TIME

OpenAL.Import

AL_REVERB_MAX_DENSITY

OpenAL.Import

AL_REVERB_MAX_DIFFUSION

OpenAL.Import

AL_REVERB_MAX_GAIN

OpenAL.Import

AL_REVERB_MAX_GAINHF

OpenAL.Import

AL_REVERB_MAX_LATE_REVERB_DELAY

OpenAL.Import

AL_REVERB_MAX_LATE_REVERB_GAIN

OpenAL.Import

AL_REVERB_MAX_REFLECTIONS_DELAY

OpenAL.Import

AL_REVERB_MAX_REFLECTIONS_GAIN

OpenAL.Import

AL_REVERB_MAX_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_REVERB_MIN_AIR_ABSORPTION_GAINHF

OpenAL.Import

AL_REVERB_MIN_DECAY_HFLIMIT

OpenAL.Import

AL_REVERB_MIN_DECAY_HFRATIO

OpenAL.Import

AL_REVERB_MIN_DECAY_TIME

OpenAL.Import

AL_REVERB_MIN_DENSITY

OpenAL.Import

Effect parameter structures, value definitions, ranges and defaults. AL reverb effect parameter ranges and defaults

AL_REVERB_MIN_DIFFUSION

OpenAL.Import

AL_REVERB_MIN_GAIN

OpenAL.Import

AL_REVERB_MIN_GAINHF

OpenAL.Import

AL_REVERB_MIN_LATE_REVERB_DELAY

OpenAL.Import

AL_REVERB_MIN_LATE_REVERB_GAIN

OpenAL.Import

AL_REVERB_MIN_REFLECTIONS_DELAY

OpenAL.Import

AL_REVERB_MIN_REFLECTIONS_GAIN

OpenAL.Import

AL_REVERB_MIN_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_REVERB_REFLECTIONS_DELAY

OpenAL.Import

AL_REVERB_REFLECTIONS_GAIN

OpenAL.Import

AL_REVERB_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_RING_MODULATOR_DEFAULT_FREQUENCY

OpenAL.Import

AL_RING_MODULATOR_DEFAULT_HIGHPASS_CUTOFF

OpenAL.Import

AL_RING_MODULATOR_DEFAULT_WAVEFORM

OpenAL.Import

AL_RING_MODULATOR_FREQUENCY

OpenAL.Import

Ringmodulator Parameters

AL_RING_MODULATOR_HIGHPASS_CUTOFF

OpenAL.Import

AL_RING_MODULATOR_MAX_FREQUENCY

OpenAL.Import

AL_RING_MODULATOR_MAX_HIGHPASS_CUTOFF

OpenAL.Import

AL_RING_MODULATOR_MAX_WAVEFORM

OpenAL.Import

AL_RING_MODULATOR_MIN_FREQUENCY

OpenAL.Import

AL ring modulator effect parameter ranges and defaults

AL_RING_MODULATOR_MIN_HIGHPASS_CUTOFF

OpenAL.Import

AL_RING_MODULATOR_MIN_WAVEFORM

OpenAL.Import

AL_RING_MODULATOR_SAWTOOTH

OpenAL.Import

AL_RING_MODULATOR_SINUSOID

OpenAL.Import

AL_RING_MODULATOR_SQUARE

OpenAL.Import

AL_RING_MODULATOR_WAVEFORM

OpenAL.Import

AL_ROLLOFF_FACTOR

OpenAL.Import

source specific rolloff factor Type: ALfloat Range: 0.0 - +inf

AL_ROOM_ROLLOFF_FACTOR

OpenAL.Import

AL_SAMPLE_OFFSET

OpenAL.Import

AL_SEC_OFFSET

OpenAL.Import

Source buffer position information

AL_SIZE

OpenAL.Import

AL_SOURCE_ABSOLUTE

OpenAL.Import

Indicate the type of AL_SOURCE. Sources can be spatialized AL_SOURCE_TYPE = $200; Indicate source has absolute coordinates.

AL_SOURCE_RELATIVE

OpenAL.Import

Indicate Source has relative coordinates.

AL_SOURCE_STATE

OpenAL.Import

Source state information.

AL_SOURCE_TYPE

OpenAL.Import

Source type (Static, Streaming or undetermined) Source is Static if a Buffer has been attached using AL_BUFFER Source is Streaming if one or more Buffers have been attached using alSourceQueueBuffers Source is undetermined when it has the NULL buffer attached

AL_SPEED_OF_SOUND

OpenAL.Import

Speed of Sound in units per second

AL_STATIC

OpenAL.Import

AL_STOPPED

OpenAL.Import

AL_STORAGE_ACCESSIBLE

OpenAL.Import

AL_STORAGE_AUTOMATIC

OpenAL.Import

AL_STORAGE_HARDWARE

OpenAL.Import

AL_STREAMING

OpenAL.Import

AL_TRUE

OpenAL.Import

Boolean True.

AL_UNDETERMINED

OpenAL.Import

AL_UNUSED

OpenAL.Import

AL_DATA =$2005; Buffer state. Not supported for public use (yet).

AL_VELOCITY

OpenAL.Import

Specify the current velocity in three dimensional space.

AL_VENDOR

OpenAL.Import

Context strings: Vendor Name.

AL_VERSION

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_RATE

OpenAL.Import

AL_VOCAL_MORPHER_DEFAULT_WAVEFORM

OpenAL.Import

AL_VOCAL_MORPHER_MAX_PHONEMEA

OpenAL.Import

AL_VOCAL_MORPHER_MAX_PHONEMEA_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_MAX_PHONEMEB

OpenAL.Import

AL_VOCAL_MORPHER_MAX_PHONEMEB_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_MAX_RATE

OpenAL.Import

AL_VOCAL_MORPHER_MAX_WAVEFORM

OpenAL.Import

AL_VOCAL_MORPHER_MIN_PHONEMEA

OpenAL.Import

AL vocal morpher effect parameter ranges and defaults

AL_VOCAL_MORPHER_MIN_PHONEMEA_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_MIN_PHONEMEB

OpenAL.Import

AL_VOCAL_MORPHER_MIN_PHONEMEB_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_MIN_RATE

OpenAL.Import

AL_VOCAL_MORPHER_MIN_WAVEFORM

OpenAL.Import

AL_VOCAL_MORPHER_PHONEMEA

OpenAL.Import

Vocalmorpher Parameters

AL_VOCAL_MORPHER_PHONEMEA_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_PHONEMEB

OpenAL.Import

AL_VOCAL_MORPHER_PHONEMEB_COARSE_TUNING

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_A

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_AA

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_AE

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_AH

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_AO

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_B

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_D

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_E

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_EH

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_ER

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_F

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_G

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_I

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_IH

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_IY

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_J

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_K

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_L

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_M

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_N

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_O

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_P

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_R

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_S

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_T

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_U

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_UH

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_UW

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_V

OpenAL.Import

AL_VOCAL_MORPHER_PHONEME_Z

OpenAL.Import

AL_VOCAL_MORPHER_RATE

OpenAL.Import

AL_VOCAL_MORPHER_WAVEFORM

OpenAL.Import

AL_VOCAL_MORPHER_WAVEFORM_SAWTOOTH

OpenAL.Import

AL_VOCAL_MORPHER_WAVEFORM_SINUSOID

OpenAL.Import

AL_VOCAL_MORPHER_WAVEFORM_TRIANGLE

OpenAL.Import

AMBIENT_LIGHT

Formats.m3DSConst

AMBIENT_NODE_TAG

Formats.m3DSConst

AngleBetweenVectors

GLScene.VectorGeometry

AngleBetweenVectors

GLScene.VectorGeometry

Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians

AngleLerp

GLScene.VectorGeometry

Calculates angular interpolation between start and stop at point t

AnglePreservingMatrixInvert

GLScene.VectorGeometry

Finds the inverse of an angle preserving matrix. Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.

AnsiStartsText

GLScene.Utils

StrUtils.pas

ApplicationFileIODefined

GLS.ApplicationFileIO

Returns true if an ApplicationFileIO has been defined

ApplyBlendingModeEx

GLSL.CustomShader

Exported procedures.

AppTime

GLScene.Utils

Returns time in milisecond from application start.

ArcCosine

GLScene.VectorGeometry

ArcCreateFileStream

GLS.ArchiveManager

GLS.ApplicationFileIO These functions are used to automate loading User enters LoadFromFile and through these functions gets the result

ArcFileStreamExists

GLS.ArchiveManager

ASESetPreferredLightmap

GLS.FileASE

ASESetPreferredTexture

GLS.FileASE

use this functions to select texture and lightmap from ASE file aSubMaterialIndex = -1 - means main material maps Default are: Texture - main material Diffuse map Lightmap - main material Ambient map

ATKEY1

Formats.m3DSConst

ATKEY2

Formats.m3DSConst

ATKEY3

Formats.m3DSConst

ATKEY4

Formats.m3DSConst

ATKEY5

Formats.m3DSConst

ATKEYFLAGS

Formats.m3DSConst

AUDIO_F32

SDL.Import

**< As above, but big-endian byte order *

AUDIO_F32LSB

SDL.Import

** * float32 support *

AUDIO_F32MSB

SDL.Import

**< 32-bit floating point samples *

AUDIO_S16

SDL.Import

AUDIO_S16LSB

SDL.Import

**< Unsigned 16-bit samples *

AUDIO_S16MSB

SDL.Import

**< As above, but big-endian byte order *

AUDIO_S32

SDL.Import

**< As above, but big-endian byte order *

AUDIO_S32LSB

SDL.Import

** * int32 support *

AUDIO_S32MSB

SDL.Import

**< 32-bit integer samples *

AUDIO_S8

SDL.Import

**< Unsigned 8-bit samples *

AUDIO_U16

SDL.Import

**< As above, but big-endian byte order *

AUDIO_U16LSB

SDL.Import

**< Signed 8-bit samples *

AUDIO_U16MSB

SDL.Import

**< Signed 16-bit samples *

AUDIO_U8

SDL.Import

** * Audio format flags * * Defaults to LSB byte order. *

AutoCreateHooks

gnugettext

This function will turn resourcestring hooks on or off, eventually with BPL file support. Please do not activate BPL file support when the package is in design mode.

AVIBuildFilter

Formats.VFW

AVIBuildFilterA

Formats.VFW

AVIBuildFilterW

Formats.VFW

Same as the flags for ICCompressorChoose (see compman.h) These determine what the compression options dialog for video streams will look like.

AVICapSM

Formats.VFW

== AVICAP - Window class for AVI capture ====================================

AVIClearClipboard

Formats.VFW

AVICOMPRESSF_DATARATE

Formats.VFW

interleave

AVICOMPRESSF_INTERLEAVE

Formats.VFW

Defines for the dwFlags field of the AVICOMPRESSOPTIONS struct Each of these flags determines if the appropriate field in the structure (dwInterleaveEvery, dwBytesPerSecond, and dwKeyFrameEvery) is payed attention to. See the autodoc in avisave.c for details.

AVICOMPRESSF_KEYFRAMES

Formats.VFW

use a data rate

AVICOMPRESSF_VALID

Formats.VFW

use keyframes

AVIERR_BADFLAGS

Formats.VFW

MAKE_AVIERR(104)

AVIERR_BADFORMAT

Formats.VFW

MAKE_AVIERR(101)

AVIERR_BADHANDLE

Formats.VFW

MAKE_AVIERR(107)

AVIERR_BADPARAM

Formats.VFW

MAKE_AVIERR(105)

AVIERR_BADSIZE

Formats.VFW

MAKE_AVIERR(106)

AVIERR_BUFFERTOOSMALL

Formats.VFW

MAKE_AVIERR(115)

AVIERR_CANTCOMPRESS

Formats.VFW

MAKE_AVIERR(116)

AVIERR_COMPRESSOR

Formats.VFW

MAKE_AVIERR(111)

AVIERR_ERROR

Formats.VFW

MAKE_AVIERR(198)

AVIERR_FILEOPEN

Formats.VFW

MAKE_AVIERR(110)

AVIERR_FILEREAD

Formats.VFW

MAKE_AVIERR(108)

AVIERR_FILEWRITE

Formats.VFW

MAKE_AVIERR(109)

AVIERR_INTERNAL

Formats.VFW

MAKE_AVIERR(103)

AVIERR_MEMORY

Formats.VFW

MAKE_AVIERR(102)

AVIERR_NOCOMPRESSOR

Formats.VFW

MAKE_AVIERR(112)

AVIERR_NODATA

Formats.VFW

MAKE_AVIERR(114)

AVIERR_OK

Formats.VFW

– Error handling ———————————————————–

AVIERR_READONLY

Formats.VFW

MAKE_AVIERR(113)

AVIERR_UNSUPPORTED

Formats.VFW

!!! Questions to be answered: How can you get a string form of these errors? Which of these errors should be replaced by errors in SCODE.H?

AVIERR_USERABORT

Formats.VFW

MAKE_AVIERR(117)

AVIFileAddRef

Formats.VFW

AVIFILECAPS_ALLKEYFRAMES

Formats.VFW

AVIFILECAPS_CANREAD

Formats.VFW

– Flags for dwCaps ———————————————————

AVIFILECAPS_CANWRITE

Formats.VFW

AVIFILECAPS_NOCOMPRESSION

Formats.VFW

AVIFileClose

Formats.VFW

AVIStreamRelease

AVIFileCreateStream

Formats.VFW

AVIFileCreateStreamA

Formats.VFW

AVIFileCreateStreamW

Formats.VFW

AVIFileEndRecord

Formats.VFW

AVIFileExit

Formats.VFW

Call this first!

AVIFileGetStream

Formats.VFW

AVIFILEHANDLER_CANACCEPTNONRGB

Formats.VFW

AVIFILEHANDLER_CANREAD

Formats.VFW

AVIFILEHANDLER_CANWRITE

Formats.VFW

AVIFileInfo

Formats.VFW

AVIFileInfoA

Formats.VFW

AVIFileInfoW

Formats.VFW

AVIFILEINFO_COPYRIGHTED

Formats.VFW

AVIFILEINFO_HASINDEX

Formats.VFW

– Flags for dwFlags ——————————————————–

AVIFILEINFO_ISINTERLEAVED

Formats.VFW

AVIFILEINFO_MUSTUSEINDEX

Formats.VFW

AVIFILEINFO_WASCAPTUREFILE

Formats.VFW

AVIFileInit

Formats.VFW

– Functions —————————————————————-

AVIFileOpen

Formats.VFW

AVIFileOpenA

Formats.VFW

AVIFileOpenW

Formats.VFW

AVIFileReadData

Formats.VFW

AVIFileRelease

Formats.VFW

AVIFileWriteData

Formats.VFW

AVIF_COPYRIGHTED

Formats.VFW

AVIF_HASINDEX

Formats.VFW

– flags for use in <dwFlags> in AVIFileHdr ———————————

AVIF_ISINTERLEAVED

Formats.VFW

AVIF_MUSTUSEINDEX

Formats.VFW

Index at end of file?

AVIF_TRUSTCKTYPE

Formats.VFW

AVIF_WASCAPTUREFILE

Formats.VFW

Use CKType to find key frames?

AVIGETFRAMEF_BESTDISPLAYFMT

Formats.VFW

Ansi - Unicode thunking.
Unicode or Ansi-only apps can call the avifile APIs. any Win32 app who wants to use any of the AVI COM interfaces must be UNICODE - the AVISTREAMINFO and AVIFILEINFO structures used in the Info methods of these interfaces are the unicode variants, and no thunking to or from ansi takes place except in the AVIFILE api entrypoints.
For Ansi/Unicode thunking: for each entrypoint or structure that uses chars or strings, two versions are declared in the Win32 version, ApiNameW and ApiNameA. The default name ApiName is #defined to one or other of these depending on whether UNICODE is defined (during compilation of the app that is including this header). The source will contain ApiName and ApiNameA (with ApiName being the Win16 implementation, and also #defined to ApiNameW, and ApiNameA being the thunk entrypoint).
For GetFrame::SetFormat - use the best format for the display

AVIGetFromClipboard

Formats.VFW

AVIIF_COMPUSE

Formats.VFW

this frame doesn't take any time

AVIIF_KEYFRAME

Formats.VFW

AVIIF_LIST

Formats.VFW

– Flags for AVI file index ————————————————-

AVIIF_NOTIME

Formats.VFW

– Flags for index ———————————————————-

AVIIF_TWOCC

Formats.VFW

AVIMakeCompressedStream

Formats.VFW

mmioFOURCC('D', 'I', 'B', ' ')

AVIMakeFileFromStreams

Formats.VFW

AVIBuildFilterA

AVIMakeStreamFromClipboard

Formats.VFW

AVIPutFileOnClipboard

Formats.VFW

– Clipboard routines ——————————————————-

AVISaveOptions

Formats.VFW

AVISaveVA

AVISaveOptionsFree

Formats.VFW

AVISaveV

Formats.VFW

#define AVISave AVISaveA

AVISaveVA

Formats.VFW

Non-portable: uses variable number of params EXTERN_C HRESULT CDECL AVISaveA (LPCSTR szFile, CLSID FAR *pclsidHandler, AVISAVECALLBACK lpfnCallback, int nStreams, PAVISTREAM pfile, LPAVICOMPRESSOPTIONS lpOptions, ...);

AVISaveVW

Formats.VFW

Non-portable: uses variable number of params EXTERN_C HRESULT CDECL AVISaveW (LPCWSTR szFile, CLSID FAR *pclsidHandler, AVISAVECALLBACK lpfnCallback, int nStreams, PAVISTREAM pfile, LPAVICOMPRESSOPTIONS lpOptions, ...);

AVISF_DISABLED

Formats.VFW

– Stream header ————————————————————

AVISF_VIDEO_PALCHANGES

Formats.VFW

AVIStreamAddRef

Formats.VFW

AVIStreamBeginStreaming

Formats.VFW

AVIStreamClose

Formats.VFW

AVIStreamFindSample Non-portable: this is alias for method name FindKeyFrame FindSample

AVIStreamCreate

Formats.VFW

– Use to create disembodied streams —————————————-

AVIStreamDataSize

Formats.VFW

AVIStreamEnd

Formats.VFW

AVIStreamEndStreaming

Formats.VFW

AVIStreamEndTime

Formats.VFW

AVIStreamExit

Formats.VFW

AVIFileInit

AVIStreamFindKeyFrame

Formats.VFW

– Stuff to support backward compat. —————————————-

AVIStreamFindSample

Formats.VFW

AVIStreamFormatSize

Formats.VFW

AVIStreamGetFrame

Formats.VFW

AVIStreamGetFrameClose

Formats.VFW

AVIStreamGetFrameOpen

Formats.VFW

– Helper functions for using IGetFrame ————————————-

AVIStreamInfo

Formats.VFW

AVIStreamInfoA

Formats.VFW

AVIStreamInfoW

Formats.VFW

AVISTREAMINFO_DISABLED

Formats.VFW

AVISTREAMINFO_FORMATCHANGES

Formats.VFW

AVIStreamInit

Formats.VFW

AVIFileRelease

AVIStreamIsKeyFrame

Formats.VFW

AVIStreamLength

Formats.VFW

AVIStreamLengthTime

Formats.VFW

AVIStreamNearestKeyFrame

Formats.VFW

AVIStreamNearestKeyFrameTime

Formats.VFW

AVIStreamNearestSample

Formats.VFW

AVIStreamNearestSampleTime

Formats.VFW

AVIStreamNextKeyFrame

Formats.VFW

AVIStreamNextKeyFrameTime

Formats.VFW

AVIStreamNextSample

Formats.VFW

AVIStreamNextSampleTime

Formats.VFW

AVIStreamOpenFromFile

Formats.VFW

AVIStreamOpenFromFileA

Formats.VFW

– Shortcut function ——————————————————–

AVIStreamOpenFromFileW

Formats.VFW

AVIStreamPrevKeyFrame

Formats.VFW

AVIStreamPrevKeyFrameTime

Formats.VFW

AVIStreamPrevSample

Formats.VFW

AVIStreamPrevSampleTime

Formats.VFW

AVIStreamRead

Formats.VFW

AVIStreamReadData

Formats.VFW

AVIStreamReadFormat

Formats.VFW

AVISTREAMREAD_CONVENIENT

Formats.VFW

AVIStreamRelease

Formats.VFW

AVIStreamSampleSize

Formats.VFW

AVIStreamSampleToSample

Formats.VFW

– Helper macros ————————————————————

AVIStreamSampleToTime

Formats.VFW

AVIStreamSetFormat

Formats.VFW

AVIStreamStart

Formats.VFW

Right now, these just use AVIStreamInfo() to get information, then return some of it. Can they be more efficient?

AVIStreamStartTime

Formats.VFW

AVIStreamTimeToSample

Formats.VFW

AVIStreamWrite

Formats.VFW

AVIStreamWriteData

Formats.VFW

aviTWOCC

Formats.VFW

AVI_HEADERSIZE

Formats.VFW

– The AVI File Header LIST chunk should be padded to this size ————-

AVSTREAMMASTER_AUDIO

Formats.VFW

Since Audio and Video streams generally use non-synchronized capture clocks, this flag determines whether the audio stream is to be considered the master or controlling clock when writing the AVI file:
AVSTREAMMASTER_AUDIO - Audio is master, video frame duration is forced to match audio duration (VFW 1.0, 1.1 default) AVSTREAMMASTER_NONE - No master, audio and video streams may be of different lengths

AVSTREAMMASTER_NONE

Formats.VFW

Audio master (VFW 1.0, 1.1)

AxesBuildList

GLS.Scene

Issues OpenGL calls for drawing X, Y, Z axes in a standard style.

BANDPASS_DEFAULT_GAIN

OpenAL.Import

BANDPASS_DEFAULT_GAINHF

OpenAL.Import

BANDPASS_DEFAULT_GAINLF

OpenAL.Import

BANDPASS_MAX_GAIN

OpenAL.Import

BANDPASS_MAX_GAINHF

OpenAL.Import

BANDPASS_MAX_GAINLF

OpenAL.Import

BANDPASS_MIN_GAIN

OpenAL.Import

Bandpass filter

BANDPASS_MIN_GAINHF

OpenAL.Import

BANDPASS_MIN_GAINLF

OpenAL.Import

bassdll

BASS.Import

libraries

BASSVERSION

BASS.Import

BASSVERSIONTEXT

BASS.Import

API version

BASS_3DALG_DEFAULT

BASS.Import

software 3D mixing algorithms (used with BASS_CONFIG_3DALGORITHM)

BASS_3DALG_FULL

BASS.Import

Uses normal left and right panning. The vertical axis is ignored except for scaling of volume due to distance. Doppler shift and volume scaling are still applied, but the 3D filtering is not performed. This is the most CPU efficient software implementation, but provides no virtual 3D audio effect. Head Related Transfer Function processing will not be done. Since only normal stereo panning is used, a channel using this algorithm may be accelerated by a 2D hardware voice if no free 3D hardware voices are available.

BASS_3DALG_LIGHT

BASS.Import

This algorithm gives the highest quality 3D audio effect, but uses more CPU. Requires Windows 98 2nd Edition or Windows 2000 that uses WDM drivers, if this mode is not available then BASS_3DALG_OFF will be used instead.

BASS_3DALG_OFF

BASS.Import

default algorithm (currently translates to BASS_3DALG_OFF)

BASS_3DMODE_NORMAL

BASS.Import

3D channel modes

BASS_3DMODE_OFF

BASS.Import

The channel's 3D position (position/velocity/ orientation) are relative to the listener. When the listener's position/velocity/orientation is changed with BASS_Set3DPosition, the channel's position relative to the listener does not change.

BASS_3DMODE_RELATIVE

BASS.Import

normal 3D processing

BASS_3DVECTOR

BASS.Import

3D vector (for 3D positions/velocities/orientations)

BASS_ACTIVE_PAUSED

BASS.Import

BASS_ACTIVE_PAUSED_DEVICE

BASS.Import

BASS_ACTIVE_PLAYING

BASS.Import

BASS_ACTIVE_STALLED

BASS.Import

BASS_ACTIVE_STOPPED

BASS.Import

flag: sync only once, else continuously BASS_ChannelIsActive return values

BASS_Apply3D

BASS.Import

external bassdll;

BASS_ASYNCFILE

BASS.Import

BASS_ATTRIB_BITRATE

BASS.Import

BASS_ATTRIB_BUFFER

BASS.Import

BASS_ATTRIB_CPU

BASS.Import

BASS_ATTRIB_DOWNLOADPROC

BASS.Import

BASS_ATTRIB_EAXMIX

BASS.Import

BASS_ATTRIB_FREQ

BASS.Import

Channel attributes

BASS_ATTRIB_GRANULE

BASS.Import

BASS_ATTRIB_MUSIC_ACTIVE

BASS.Import

BASS_ATTRIB_MUSIC_AMPLIFY

BASS.Import

BASS_ATTRIB_MUSIC_BPM

BASS.Import

BASS_ATTRIB_MUSIC_PANSEP

BASS.Import

BASS_ATTRIB_MUSIC_PSCALER

BASS.Import

BASS_ATTRIB_MUSIC_SPEED

BASS.Import

BASS_ATTRIB_MUSIC_VOL_CHAN

BASS.Import

BASS_ATTRIB_MUSIC_VOL_GLOBAL

BASS.Import

BASS_ATTRIB_MUSIC_VOL_INST

BASS.Import

+ channel #

BASS_ATTRIB_NET_RESUME

BASS.Import

BASS_ATTRIB_NOBUFFER

BASS.Import

BASS_ATTRIB_NORAMP

BASS.Import

BASS_ATTRIB_PAN

BASS.Import

BASS_ATTRIB_PUSH_LIMIT

BASS.Import

BASS_ATTRIB_SCANINFO

BASS.Import

BASS_ATTRIB_SRC

BASS.Import

BASS_ATTRIB_TAIL

BASS.Import

BASS_ATTRIB_USER

BASS.Import

BASS_ATTRIB_VBR

BASS.Import

BASS_ATTRIB_VOL

BASS.Import

BASS_ATTRIB_VOLDSP

BASS.Import

BASS_ATTRIB_VOLDSP_PRIORITY

BASS.Import

BASS_ChannelBytes2Seconds

BASS.Import

external bassdll;

BASS_ChannelFlags

BASS.Import

external bassdll;

BASS_ChannelGet3DAttributes

BASS.Import

external bassdll;

BASS_ChannelGet3DPosition

BASS.Import

external bassdll;

BASS_ChannelGetAttribute

BASS.Import

external bassdll;

BASS_ChannelGetAttributeEx

BASS.Import

external bassdll;

BASS_ChannelGetData

BASS.Import

external bassdll;

BASS_ChannelGetDevice

BASS.Import

external bassdll;

BASS_ChannelGetInfo

BASS.Import

external bassdll;

BASS_ChannelGetLength

BASS.Import

external bassdll;

BASS_ChannelGetLevel

BASS.Import

external bassdll;

BASS_ChannelGetLevelEx

BASS.Import

external bassdll;

BASS_ChannelGetPosition

BASS.Import

external bassdll;

BASS_ChannelGetTags

BASS.Import

external bassdll;

BASS_CHANNELINFO

BASS.Import

Channel info structure

BASS_ChannelIsActive

BASS.Import

external bassdll;

BASS_ChannelIsSliding

BASS.Import

external bassdll;

BASS_ChannelLock

BASS.Import

external bassdll;

BASS_ChannelPause

BASS.Import

external bassdll;

BASS_ChannelPlay

BASS.Import

external bassdll;

BASS_ChannelRemoveDSP

BASS.Import

external bassdll;

BASS_ChannelRemoveFX

BASS.Import

external bassdll;

BASS_ChannelRemoveLink

BASS.Import

external bassdll;

BASS_ChannelRemoveSync

BASS.Import

external bassdll;

BASS_ChannelSeconds2Bytes

BASS.Import

external bassdll;

BASS_ChannelSet3DAttributes

BASS.Import

external bassdll;

BASS_ChannelSet3DPosition

BASS.Import

external bassdll;

BASS_ChannelSetAttribute

BASS.Import

external bassdll;

BASS_ChannelSetAttributeEx

BASS.Import

external bassdll;

BASS_ChannelSetDevice

BASS.Import

external bassdll;

BASS_ChannelSetDSP

BASS.Import

external bassdll;

BASS_ChannelSetFX

BASS.Import

external bassdll;

BASS_ChannelSetLink

BASS.Import

external bassdll;

BASS_ChannelSetPosition

BASS.Import

external bassdll;

BASS_ChannelSetSync

BASS.Import

external bassdll;

BASS_ChannelSlideAttribute

BASS.Import

external bassdll;

BASS_ChannelStop

BASS.Import

external bassdll;

BASS_ChannelUpdate

BASS.Import

external bassdll;

BASS_CONFIG_3DALGORITHM

BASS.Import

BASS_CONFIG_AIRPLAY

BASS.Import

BASS_CONFIG_AM_DISABLE

BASS.Import

BASS_CONFIG_ANDROID_AAUDIO

BASS.Import

BASS_CONFIG_ANDROID_JAVAVM

BASS.Import

BASS_CONFIG_ANDROID_SESSIONID

BASS.Import

BASS_CONFIG_ASYNCFILE_BUFFER

BASS.Import

BASS_CONFIG_BUFFER

BASS.Import

some other mystery problem BASS_SetConfig options

BASS_CONFIG_CURVE_PAN

BASS.Import

BASS_CONFIG_CURVE_VOL

BASS.Import

BASS_CONFIG_DEV_BUFFER

BASS.Import

BASS_CONFIG_DEV_DEFAULT

BASS.Import

BASS_CONFIG_DEV_NONSTOP

BASS.Import

BASS_CONFIG_DEV_PERIOD

BASS.Import

BASS_CONFIG_FILENAME

BASS.Import

BASS_CONFIG_FLOAT

BASS.Import

BASS_CONFIG_FLOATDSP

BASS.Import

BASS_CONFIG_GVOL_MUSIC

BASS.Import

BASS_CONFIG_GVOL_SAMPLE

BASS.Import

BASS_CONFIG_GVOL_STREAM

BASS.Import

BASS_CONFIG_HANDLES

BASS.Import

BASS_CONFIG_IOS_MIXAUDIO

BASS.Import

BASS_CONFIG_IOS_NOCATEGORY

BASS.Import

BASS_CONFIG_IOS_SESSION

BASS.Import

BASS_CONFIG_IOS_SPEAKER

BASS.Import

BASS_CONFIG_LIBSSL

BASS.Import

BASS_CONFIG_MF_DISABLE

BASS.Import

BASS_CONFIG_MF_VIDEO

BASS.Import

BASS_CONFIG_MUSIC_VIRTUAL

BASS.Import

BASS_CONFIG_NET_AGENT

BASS.Import

BASS_SetConfigPtr options

BASS_CONFIG_NET_BUFFER

BASS.Import

BASS_CONFIG_NET_META

BASS.Import

BASS_CONFIG_NET_PASSIVE

BASS.Import

BASS_CONFIG_NET_PLAYLIST

BASS.Import

BASS_CONFIG_NET_PLAYLIST_DEPTH

BASS.Import

BASS_CONFIG_NET_PREBUF

BASS.Import

BASS_CONFIG_NET_PREBUF_WAIT

BASS.Import

BASS_CONFIG_NET_PROXY

BASS.Import

BASS_CONFIG_NET_READTIMEOUT

BASS.Import

BASS_CONFIG_NET_RESTRATE

BASS.Import

BASS_CONFIG_NET_SEEK

BASS.Import

BASS_CONFIG_NET_TIMEOUT

BASS.Import

BASS_CONFIG_NORAMP

BASS.Import

BASS_CONFIG_OGG_PRESCAN

BASS.Import

BASS_CONFIG_PAUSE_NOPLAY

BASS.Import

BASS_CONFIG_REC_BUFFER

BASS.Import

BASS_CONFIG_REC_DEFAULT

BASS.Import

BASS_CONFIG_REC_LOOPBACK

BASS.Import

BASS_CONFIG_REC_WASAPI

BASS.Import

BASS_CONFIG_SAMPLE_ONEHANDLE

BASS.Import

BASS_CONFIG_SRC

BASS.Import

BASS_CONFIG_SRC_SAMPLE

BASS.Import

BASS_CONFIG_THREAD

BASS.Import

BASS_CONFIG_UNICODE

BASS.Import

BASS_CONFIG_UPDATEPERIOD

BASS.Import

BASS_CONFIG_UPDATETHREADS

BASS.Import

BASS_CONFIG_VERIFY

BASS.Import

BASS_CONFIG_VERIFY_NET

BASS.Import

BASS_CONFIG_VISTA_SPEAKERS

BASS.Import

BASS_CONFIG_VISTA_TRUEPOS

BASS.Import

BASS_CONFIG_WASAPI_PERSIST

BASS.Import

BASS_CTYPE_MUSIC_IT

BASS.Import

BASS_CTYPE_MUSIC_MO3

BASS.Import

BASS_CTYPE_MUSIC_MOD

BASS.Import

BASS_CTYPE_MUSIC_MTM

BASS.Import

BASS_CTYPE_MUSIC_S3M

BASS.Import

BASS_CTYPE_MUSIC_XM

BASS.Import

BASS_CTYPE_RECORD

BASS.Import

BASS_CTYPE_SAMPLE

BASS.Import

BASS_CHANNELINFO types

BASS_CTYPE_STREAM

BASS.Import

BASS_CTYPE_STREAM_AIFF

BASS.Import

BASS_CTYPE_STREAM_AM

BASS.Import

BASS_CTYPE_STREAM_CA

BASS.Import

BASS_CTYPE_STREAM_DEVICE

BASS.Import

BASS_CTYPE_STREAM_DUMMY

BASS.Import

BASS_CTYPE_STREAM_MF

BASS.Import

BASS_CTYPE_STREAM_MP1

BASS.Import

BASS_CTYPE_STREAM_MP2

BASS.Import

BASS_CTYPE_STREAM_MP3

BASS.Import

BASS_CTYPE_STREAM_OGG

BASS.Import

BASS_CTYPE_STREAM_SAMPLE

BASS.Import

BASS_CTYPE_STREAM_VORBIS

BASS.Import

BASS_CTYPE_STREAM_WAV

BASS.Import

BASS_CTYPE_STREAM_WAV_FLOAT

BASS.Import

BASS_CTYPE_STREAM_WAV_PCM

BASS.Import

WAVE flag (LOWORD=codec)

BASS_DATA_AVAILABLE

BASS.Import

BASS_ChannelGetData flags

BASS_DATA_FFT1024

BASS.Import

512 FFT

BASS_DATA_FFT16384

BASS.Import

8192 FFT

BASS_DATA_FFT2048

BASS.Import

1024 FFT

BASS_DATA_FFT256

BASS.Import

flag: return floating-point sample data

BASS_DATA_FFT32768

BASS.Import

16384 FFT

BASS_DATA_FFT4096

BASS.Import

2048 FFT

BASS_DATA_FFT512

BASS.Import

256 sample FFT

BASS_DATA_FFT8192

BASS.Import

4096 FFT

BASS_DATA_FFT_COMPLEX

BASS.Import

FFT flag: pre-remove DC bias

BASS_DATA_FFT_INDIVIDUAL

BASS.Import

32768 FFT

BASS_DATA_FFT_NOWINDOW

BASS.Import

FFT flag: FFT for each channel, else all combined

BASS_DATA_FFT_NYQUIST

BASS.Import

FFT flag: return complex data

BASS_DATA_FFT_REMOVEDC

BASS.Import

FFT flag: no Hanning window

BASS_DATA_FIXED

BASS.Import

flag: don't remove data from recording buffer

BASS_DATA_FLOAT

BASS.Import

unused

BASS_DATA_NOREMOVE

BASS.Import

query how much data is buffered

BASS_DEVICEINFO

BASS.Import

plugin handle Device info structure

BASS_DEVICES_AIRPLAY

BASS.Import

BASS_GetDeviceInfo flags

BASS_DEVICE_16BITS

BASS.Import

unused

BASS_DEVICE_3D

BASS.Import

mono

BASS_DEVICE_8BITS

BASS.Import

BASS_Init flags

BASS_DEVICE_AUDIOTRACK

BASS.Import

limit output to stereo

BASS_DEVICE_CPSPEAKERS

BASS.Import

unused

BASS_DEVICE_DEFAULT

BASS.Import

BASS_DEVICE_DEFAULTCOM

BASS.Import

BASS_DEVICE_DMIX

BASS.Import

ignore speaker arrangement

BASS_DEVICE_DSOUND

BASS.Import

use AudioTrack output

BASS_DEVICE_ENABLED

BASS.Import

IDirectSound3DListener BASS_DEVICEINFO flags

BASS_DEVICE_FREQ

BASS.Import

use ALSA "dmix" plugin

BASS_DEVICE_INIT

BASS.Import

BASS_DEVICE_LATENCY

BASS.Import

reinitialize

BASS_DEVICE_LOOPBACK

BASS.Import

BASS_DEVICE_MONO

BASS.Import

unused

BASS_DEVICE_NOSPEAKER

BASS.Import

force enabling of speaker assignment

BASS_DEVICE_REINIT

BASS.Import

limit output to 16-bit

BASS_DEVICE_SOFTWARE

BASS.Import

use DirectSound output

BASS_DEVICE_SPEAKERS

BASS.Import

unused

BASS_DEVICE_STEREO

BASS.Import

set device sample rate

BASS_DEVICE_TYPE_DIGITAL

BASS.Import

BASS_DEVICE_TYPE_DISPLAYPORT

BASS.Import

BASS_DEVICE_TYPE_HANDSET

BASS.Import

BASS_DEVICE_TYPE_HDMI

BASS.Import

BASS_DEVICE_TYPE_HEADPHONES

BASS.Import

BASS_DEVICE_TYPE_HEADSET

BASS.Import

BASS_DEVICE_TYPE_LINE

BASS.Import

BASS_DEVICE_TYPE_MASK

BASS.Import

BASS_DEVICE_TYPE_MICROPHONE

BASS.Import

BASS_DEVICE_TYPE_NETWORK

BASS.Import

BASS_DEVICE_TYPE_SPDIF

BASS.Import

BASS_DEVICE_TYPE_SPEAKERS

BASS.Import

BASS_DX8_CHORUS

BASS.Import

BASS_DX8_COMPRESSOR

BASS.Import

BASS_DX8_DISTORTION

BASS.Import

BASS_DX8_ECHO

BASS.Import

BASS_DX8_FLANGER

BASS.Import

BASS_DX8_GARGLE

BASS.Import

BASS_DX8_I3DL2REVERB

BASS.Import

BASS_DX8_PARAMEQ

BASS.Import

BASS_DX8_PHASE_180

BASS.Import

BASS_DX8_PHASE_90

BASS.Import

BASS_DX8_PHASE_NEG_180

BASS.Import

BASS_DX8_PHASE_NEG_90

BASS.Import

BASS_DX8_PHASE_ZERO

BASS.Import

BASS_DX8_REVERB

BASS.Import

BASS_ErrorGetCode

BASS.Import

external bassdll;

BASS_ERROR_ALREADY

BASS.Import

device needs to be reinitialized

BASS_ERROR_BUFLOST

BASS.Import

can't find a free sound driver

BASS_ERROR_BUSY

BASS.Import

the channel/file has ended

BASS_ERROR_CODEC

BASS.Import

invalid BASS version (used by add-ons)

BASS_ERROR_CREATE

BASS.Import

no internet connection could be opened

BASS_ERROR_DECODE

BASS.Import

requested data/action is not available

BASS_ERROR_DENIED

BASS.Import

unsupported protocol

BASS_ERROR_DEVICE

BASS.Import

no EAX support

BASS_ERROR_DRIVER

BASS.Import

can't open the file

BASS_ERROR_DX

BASS.Import

the channel is/isn't a "decoding channel"

BASS_ERROR_EMPTY

BASS.Import

no hardware voices available

BASS_ERROR_ENDED

BASS.Import

codec is not available/supported

BASS_ERROR_FILEFORM

BASS.Import

connection timedout

BASS_ERROR_FILEOPEN

BASS.Import

memory error

BASS_ERROR_FORMAT

BASS.Import

invalid handle

BASS_ERROR_FREQ

BASS.Import

not playing

BASS_ERROR_HANDLE

BASS.Import

the sample buffer was lost

BASS_ERROR_ILLPARAM

BASS.Import

an illegal type was specified

BASS_ERROR_ILLTYPE

BASS.Import

can't get a free channel

BASS_ERROR_INIT

BASS.Import

invalid position

BASS_ERROR_MEM

BASS.Import

all is OK

BASS_ERROR_NO3D

BASS.Import

an illegal parameter was specified

BASS_ERROR_NOCHAN

BASS.Import

file does not contain audio

BASS_ERROR_NOEAX

BASS.Import

no 3D support

BASS_ERROR_NOFX

BASS.Import

couldn't create the file

BASS_ERROR_NOHW

BASS.Import

the stream is not a file stream

BASS_ERROR_NONET

BASS.Import

the file has no sample data

BASS_ERROR_NOPLAY

BASS.Import

illegal device number

BASS_ERROR_NOTAUDIO

BASS.Import

already initialized/paused/whatever

BASS_ERROR_NOTAVAIL

BASS.Import

effects are not available

BASS_ERROR_NOTFILE

BASS.Import

illegal sample rate

BASS_ERROR_POSITION

BASS.Import

unsupported sample format

BASS_ERROR_PROTOCOL

BASS.Import

unstreamable file

BASS_ERROR_REINIT

BASS.Import

SSL/HTTPS support isn't available

BASS_ERROR_SPEAKER

BASS.Import

unsupported file format

BASS_ERROR_SSL

BASS.Import

BASS_Start has not been successfully called

BASS_ERROR_START

BASS.Import

BASS_Init has not been successfully called

BASS_ERROR_TIMEOUT

BASS.Import

a sufficient DirectX version is not installed

BASS_ERROR_UNKNOWN

BASS.Import

access denied

BASS_ERROR_UNSTREAMABLE

BASS.Import

the device is busy

BASS_ERROR_VERSION

BASS.Import

unavailable speaker

BASS_FILEDATA_END

BASS.Import

BASS_StreamPutFileData options

BASS_FILEPOS_ASYNCBUF

BASS.Import

BASS_FILEPOS_AVAILABLE

BASS.Import

BASS_FILEPOS_BUFFER

BASS.Import

BASS_FILEPOS_BUFFERING

BASS.Import

BASS_FILEPOS_CONNECTED

BASS.Import

BASS_FILEPOS_CURRENT

BASS.Import

end & close the file BASS_StreamGetFilePosition modes

BASS_FILEPOS_DECODE

BASS.Import

BASS_FILEPOS_DOWNLOAD

BASS.Import

BASS_FILEPOS_END

BASS.Import

BASS_FILEPOS_SIZE

BASS.Import

BASS_FILEPOS_SOCKET

BASS.Import

BASS_FILEPOS_START

BASS.Import

BASS_FILEPROCS

BASS.Import

BASS_Free

BASS.Import

external bassdll;

BASS_FXGetParameters

BASS.Import

external bassdll;

BASS_FXReset

BASS.Import

external bassdll;

BASS_FXSetParameters

BASS.Import

external bassdll;

BASS_FXSetPriority

BASS.Import

external bassdll;

BASS_FX_DX8_CHORUS

BASS.Import

BASS_ChannelSetFX effect types

BASS_FX_DX8_COMPRESSOR

BASS.Import

BASS_FX_DX8_DISTORTION

BASS.Import

BASS_FX_DX8_ECHO

BASS.Import

BASS_FX_DX8_FLANGER

BASS.Import

BASS_FX_DX8_GARGLE

BASS.Import

BASS_FX_DX8_I3DL2REVERB

BASS.Import

BASS_FX_DX8_PARAMEQ

BASS.Import

BASS_FX_DX8_REVERB

BASS.Import

BASS_FX_VOLUME

BASS.Import

BASS_FX_VOLUME_PARAM

BASS.Import

BASS_Get3DFactors

BASS.Import

external bassdll;

BASS_Get3DPosition

BASS.Import

external bassdll;

BASS_GetConfig

BASS.Import

external bassdll;

BASS_GetConfigPtr

BASS.Import

external bassdll;

BASS_GetCPU

BASS.Import

external bassdll;

BASS_GetDevice

BASS.Import

external bassdll;

BASS_GetDeviceInfo

BASS.Import

external bassdll;

BASS_GetDSoundObject

BASS.Import

external bassdll;

BASS_GetEAXParameters

BASS.Import

external bassdll;

BASS_GetInfo

BASS.Import

external bassdll;

BASS_GetVersion

BASS.Import

external bassdll;

BASS_GetVolume

BASS.Import

external bassdll;

BASS_INFO

BASS.Import

BASS_Init

BASS.Import

external bassdll;

BASS_INPUT_OFF

BASS.Import

BASS_RecordSetInput flags

BASS_INPUT_ON

BASS.Import

BASS_INPUT_TYPE_ANALOG

BASS.Import

BASS_INPUT_TYPE_AUX

BASS.Import

BASS_INPUT_TYPE_CD

BASS.Import

BASS_INPUT_TYPE_DIGITAL

BASS.Import

BASS_INPUT_TYPE_LINE

BASS.Import

BASS_INPUT_TYPE_MASK

BASS.Import

BASS_INPUT_TYPE_MIC

BASS.Import

BASS_INPUT_TYPE_PHONE

BASS.Import

BASS_INPUT_TYPE_SPEAKER

BASS.Import

BASS_INPUT_TYPE_SYNTH

BASS.Import

BASS_INPUT_TYPE_UNDEF

BASS.Import

BASS_INPUT_TYPE_WAVE

BASS.Import

BASS_IOS_SESSION_AIRPLAY

BASS.Import

BASS_IOS_SESSION_AMBIENT

BASS.Import

BASS_IOS_SESSION_BTA2DP

BASS.Import

BASS_IOS_SESSION_BTHFP

BASS.Import

BASS_IOS_SESSION_DEACTIVATE

BASS.Import

BASS_IOS_SESSION_DISABLE

BASS.Import

BASS_IOS_SESSION_DUCK

BASS.Import

BASS_IOS_SESSION_MIX

BASS.Import

flag: thread-specific setting BASS_CONFIG_IOS_SESSION flags

BASS_IOS_SESSION_SPEAKER

BASS.Import

BASS_IsLoaded

BASS.Import

BASS_LEVEL_MONO

BASS.Import

FFT flag: return extra Nyquist value BASS_ChannelGetLevelEx flags

BASS_LEVEL_NOREMOVE

BASS.Import

apply VOL/PAN attributes to the levels

BASS_LEVEL_RMS

BASS.Import

get stereo level

BASS_LEVEL_STEREO

BASS.Import

get mono level

BASS_LEVEL_VOLPAN

BASS.Import

get RMS levels

BASS_Load

BASS.Import

BASS_MP3_IGNOREDELAY

BASS.Import

give server status info (HTTP/ICY tags) in DOWNLOADPROC

BASS_MP3_SETPOS

BASS.Import

ignore LAME/Xing/VBRI/iTunes delay & padding info

BASS_MusicFree

BASS.Import

external bassdll;

BASS_MusicLoad

BASS.Import

external bassdll;

BASS_MUSIC_3D

BASS.Import

BASS_MUSIC_AUTOFREE

BASS.Import

BASS_MUSIC_CALCLEN

BASS.Import

calculate playback length

BASS_MUSIC_DECODE

BASS.Import

BASS_MUSIC_FLOAT

BASS.Import

BASS_MUSIC_FT2MOD

BASS.Import

apply FastTracker 2 panning to XM files

BASS_MUSIC_FT2PAN

BASS.Import

surround sound (mode 2)

BASS_MUSIC_FX

BASS.Import

BASS_MUSIC_LOOP

BASS.Import

BASS_MUSIC_MONO

BASS.Import

BASS_MUSIC_NONINTER

BASS.Import

play .MOD as ProTracker 1 does

BASS_MUSIC_NOSAMPLE

BASS.Import

stop the music on a backwards jump effect

BASS_MUSIC_POSRESET

BASS.Import

sinc interpolated sample mixing

BASS_MUSIC_POSRESETEX

BASS.Import

stop all notes when moving position

BASS_MUSIC_PRESCAN

BASS.Import

BASS_MUSIC_PT1MOD

BASS.Import

play .MOD as FastTracker 2 does

BASS_MUSIC_RAMP

BASS.Import

BASS_MUSIC_RAMPS

BASS.Import

normal ramping

BASS_MUSIC_SINCINTER

BASS.Import

non-interpolated sample mixing

BASS_MUSIC_STOPBACK

BASS.Import

stop all notes and reset bmp/etc when moving position

BASS_MUSIC_SURROUND

BASS.Import

sensitive ramping

BASS_MUSIC_SURROUND2

BASS.Import

surround sound

BASS_NODEVICE

BASS.Import

flag: scan to the position BASS_ChannelSetDevice/GetDevice option

BASS_OBJECT_DS

BASS.Import

disable hardware/fastpath output DirectSound interfaces (for use with BASS_GetDSoundObject)

BASS_OBJECT_DS3DL

BASS.Import

IDirectSound

BASS_OK

BASS.Import

-1 (QWORD) Error codes returned by BASS_ErrorGetCode()

BASS_ORIGRES_FLOAT

BASS.Import

BASS_Pause

BASS.Import

external bassdll;

BASS_PLUGINFORM

BASS.Import

BASS_PluginFree

BASS.Import

external bassdll;

BASS_PluginGetInfo

BASS.Import

external bassdll;

BASS_PLUGININFO

BASS.Import

BASS_PluginLoad

BASS.Import

external bassdll;

BASS_PLUGIN_PROC

BASS.Import

MO3 flag BASS_PluginLoad flags

BASS_POS_BYTE

BASS.Import

+ sample #, MOD sample name : ANSI string BASS_ChannelGetLength/GetPosition/SetPosition modes

BASS_POS_DECODE

BASS.Import

flag: allow seeking to inexact position

BASS_POS_DECODETO

BASS.Import

flag: get the decoding (not playing) position

BASS_POS_END

BASS.Import

OGG bitstream number

BASS_POS_FLUSH

BASS.Import

loop start positiom

BASS_POS_INEXACT

BASS.Import

flag: seek relative to the current position

BASS_POS_LOOP

BASS.Import

trimmed end position

BASS_POS_MUSIC_ORDER

BASS.Import

byte position

BASS_POS_OGG

BASS.Import

order.row position, MAKELONG(order,row)

BASS_POS_RELATIVE

BASS.Import

flag: reset user file buffers

BASS_POS_RESET

BASS.Import

flag: flush decoder/FX buffers

BASS_POS_SCAN

BASS.Import

flag: decode to the position instead of seeking

BASS_RecordFree

BASS.Import

external bassdll;

BASS_RecordGetDevice

BASS.Import

external bassdll;

BASS_RecordGetDeviceInfo

BASS.Import

external bassdll;

BASS_RecordGetInfo

BASS.Import

external bassdll;

BASS_RecordGetInput

BASS.Import

external bassdll;

BASS_RecordGetInputName

BASS.Import

external bassdll;

BASS_RECORDINFO

BASS.Import

Recording device info structure

BASS_RecordInit

BASS.Import

external bassdll;

BASS_RecordSetDevice

BASS.Import

external bassdll;

BASS_RecordSetInput

BASS.Import

external bassdll;

BASS_RecordStart

BASS.Import

external bassdll;

BASS_RECORD_PAUSE

BASS.Import

BASS_SAMPLE

BASS.Import

Sample info structure

BASS_SampleCreate

BASS.Import

external bassdll;

BASS_SampleFree

BASS.Import

external bassdll;

BASS_SampleGetChannel

BASS.Import

external bassdll;

BASS_SampleGetChannels

BASS.Import

external bassdll;

BASS_SampleGetData

BASS.Import

external bassdll;

BASS_SampleGetInfo

BASS.Import

external bassdll;

BASS_SampleLoad

BASS.Import

external bassdll;

BASS_SampleSetData

BASS.Import

external bassdll;

BASS_SampleSetInfo

BASS.Import

external bassdll;

BASS_SampleStop

BASS.Import

external bassdll;

BASS_SAMPLE_3D

BASS.Import

looped

BASS_SAMPLE_8BITS

BASS.Import

WAVE_FORMAT_1M08 = $00000001; // 11.025 kHz, Mono, 8-bit WAVE_FORMAT_1S08 = $00000002; // 11.025 kHz, Stereo, 8-bit WAVE_FORMAT_1M16 = $00000004; // 11.025 kHz, Mono, 16-bit WAVE_FORMAT_1S16 = $00000008; // 11.025 kHz, Stereo, 16-bit WAVE_FORMAT_2M08 = $00000010; // 22.05 kHz, Mono, 8-bit WAVE_FORMAT_2S08 = $00000020; // 22.05 kHz, Stereo, 8-bit WAVE_FORMAT_2M16 = $00000040; // 22.05 kHz, Mono, 16-bit WAVE_FORMAT_2S16 = $00000080; // 22.05 kHz, Stereo, 16-bit WAVE_FORMAT_4M08 = $00000100; // 44.1 kHz, Mono, 8-bit WAVE_FORMAT_4S08 = $00000200; // 44.1 kHz, Stereo, 8-bit WAVE_FORMAT_4M16 = $00000400; // 44.1 kHz, Mono, 16-bit WAVE_FORMAT_4S16 = $00000800; // 44.1 kHz, Stereo, 16-bit

BASS_SAMPLE_FLOAT

BASS.Import

8 bit

BASS_SAMPLE_FX

BASS.Import

unused

BASS_SAMPLE_LOOP

BASS.Import

mono

BASS_SAMPLE_MONO

BASS.Import

32 bit floating-point

BASS_SAMPLE_MUTEMAX

BASS.Import

unused

BASS_SAMPLE_OVER_DIST

BASS.Import

override longest playing

BASS_SAMPLE_OVER_POS

BASS.Import

override lowest volume

BASS_SAMPLE_OVER_VOL

BASS.Import

unused

BASS_SAMPLE_SOFTWARE

BASS.Import

3D functionality

BASS_SAMPLE_VAM

BASS.Import

mute at max distance (3D only)

BASS_Set3DFactors

BASS.Import

external bassdll;

BASS_Set3DPosition

BASS.Import

external bassdll;

BASS_SetConfig

BASS.Import

Recording callback function. handle : The recording handle buffer : Buffer containing the recorded sample data length : Number of bytes user : The 'user' parameter value given when calling BASS_RecordStart RETURN : TRUE = continue recording, FALSE = stop

BASS_SetConfigPtr

BASS.Import

external bassdll;

BASS_SetDevice

BASS.Import

external bassdll;

BASS_SetEAXParameters

BASS.Import

external bassdll;

BASS_SetEAXPreset

BASS.Import

BASS_SetVolume

BASS.Import

external bassdll;

BASS_SLIDE_LOG

BASS.Import

+ instrument # BASS_ChannelSlideAttribute flags

BASS_SPEAKER_CENLFE

BASS.Import

rear speakers

BASS_SPEAKER_CENTER

BASS.Import

BASS_SPEAKER_FRONT

BASS.Import

don't load the samples Speaker assignment flags

BASS_SPEAKER_FRONTLEFT

BASS.Import

modifier: right

BASS_SPEAKER_FRONTRIGHT

BASS.Import

BASS_SPEAKER_LEFT

BASS.Import

side speakers (7.1)

BASS_SPEAKER_LFE

BASS.Import

BASS_SPEAKER_N

BASS.Import

external bassdll;

BASS_SPEAKER_REAR

BASS.Import

front speakers

BASS_SPEAKER_REAR2

BASS.Import

BASS_SPEAKER_REAR2LEFT

BASS.Import

BASS_SPEAKER_REAR2RIGHT

BASS.Import

BASS_SPEAKER_REARLEFT

BASS.Import

BASS_SPEAKER_REARRIGHT

BASS.Import

BASS_SPEAKER_RIGHT

BASS.Import

modifier: left

BASS_SPEAKER_SIDE

BASS.Import

center & LFE speakers (5.1)

BASS_SPEAKER_SIDELEFT

BASS.Import

BASS_SPEAKER_SIDERIGHT

BASS.Import

BASS_Start

BASS.Import

external bassdll;

BASS_Stop

BASS.Import

external bassdll;

BASS_StreamCreate

BASS.Import

external bassdll;

BASS_StreamCreateFile

BASS.Import

external bassdll;

BASS_StreamCreateFileUser

BASS.Import

external bassdll;

BASS_StreamCreateURL

BASS.Import

external bassdll;

BASS_StreamFree

BASS.Import

external bassdll;

BASS_StreamGetFilePosition

BASS.Import

external bassdll;

BASS_STREAMPROC_END

BASS.Import

BASS_StreamPutData

BASS.Import

external bassdll;

BASS_StreamPutFileData

BASS.Import

external bassdll;

BASS_STREAM_AUTOFREE

BASS.Import

scan file for accurate seeking and length

BASS_STREAM_BLOCK

BASS.Import

restrict the download rate of internet file streams

BASS_STREAM_DECODE

BASS.Import

download/play internet file stream in small blocks

BASS_STREAM_PRESCAN

BASS.Import

override furthest from listener (3D only)

BASS_STREAM_RESTRATE

BASS.Import

automatically free the stream when it stops/ends

BASS_STREAM_STATUS

BASS.Import

don't play the stream, only decode

BASS_SYNC_DEV_FAIL

BASS.Import

BASS_SYNC_DEV_FORMAT

BASS.Import

BASS_SYNC_DOWNLOAD

BASS.Import

Sync when playback has stalled. param: not used data : 0=stalled, 1=resumed

BASS_SYNC_END

BASS.Import

Sync when a channel reaches a position. param: position in bytes data : not used

BASS_SYNC_FREE

BASS.Import

Sync when downloading of an internet (or "buffered" user file) stream has ended. param: not used data : not used

BASS_SYNC_META

BASS.Import

Sync when a channel reaches the end. param: not used data : not used

BASS_SYNC_MIXTIME

BASS.Import

flag: call sync in other thread

BASS_SYNC_MUSICFX

BASS.Import

Sync when an instrument (sample for the non-instrument based formats) is played in a MOD music (not including retrigs). param: LOWORD=instrument (1=first) HIWORD=note (0=c0...119=b9, -1=all) data : LOWORD=note HIWORD=volume (0-64)

BASS_SYNC_MUSICINST

BASS.Import

Sync when a MOD music reaches an order:row position. param: LOWORD=order (0=first, -1=all) HIWORD=row (0=first, -1=all) data : LOWORD=order HIWORD=row

BASS_SYNC_MUSICPOS

BASS.Import

Sync when a channel's position is set. param: not used data : 0 = playback buffer not flushed, 1 = playback buffer flushed

BASS_SYNC_OGG_CHANGE

BASS.Import

Sync when the "sync" effect (XM/MTM/MOD: E8x/Wxx, IT/S3M: S2x) is used. param: 0:data=pos, 1:data="x" value data : param=0: LOWORD=order HIWORD=row, param=1: "x" value

BASS_SYNC_ONETIME

BASS.Import

flag: sync at mixtime, else at playtime

BASS_SYNC_POS

BASS.Import

Sync types (with BASS_ChannelSetSync() "param" and SYNCPROC "data" definitions) & flags.

BASS_SYNC_SETPOS

BASS.Import

Sync when a channel is freed. param: not used data : not used

BASS_SYNC_SLIDE

BASS.Import

Sync when metadata is received in a stream. param: not used data : pointer to the metadata

BASS_SYNC_STALL

BASS.Import

Sync when an attribute slide is completed. param: not used data : the type of slide completed (one of the BASS_SLIDE_xxx values)

BASS_SYNC_THREAD

BASS.Import

BASS_TAG_AM_MIME

BASS.Import

ID3v2 tags (2nd block) : variable length block

BASS_TAG_AM_NAME

BASS.Import

WAVE format : WAVEFORMATEEX structure

BASS_TAG_APE

BASS.Import

ICY metadata : ANSI string

BASS_TAG_APE_BINARY

BASS.Import

RIFF "smpl" chunk : TAG_SMPL structure

BASS_TAG_CA_CODEC

BASS.Import

Lyric3v2 tag : ASCII string

BASS_TAG_HTTP

BASS.Import

OGG comments : series of null-terminated UTF-8 strings

BASS_TAG_ICY

BASS.Import

HTTP headers : series of null-terminated ASCII strings

BASS_TAG_ID3

BASS.Import

don't remove data from recording buffer BASS_ChannelGetTags types : what's returned

BASS_TAG_ID3V2

BASS.Import

ID3v1 tags : TAG_ID3 structure

BASS_TAG_ID3V2_2

BASS.Import

Android Media codec name : ASCII string

BASS_TAG_LOCATION

BASS.Import

Android Media MIME type : ASCII string

BASS_TAG_LYRICS3

BASS.Import

OGG encoder : UTF-8 string

BASS_TAG_META

BASS.Import

ICY headers : series of null-terminated ANSI strings

BASS_TAG_MF

BASS.Import

CoreAudio codec info : TAG_CA_CODEC structure

BASS_TAG_MP4

BASS.Import

APEv2 tags : series of null-terminated UTF-8 strings

BASS_TAG_MUSIC_AUTH

BASS.Import

MOD order list : BYTE array of pattern numbers

BASS_TAG_MUSIC_CHAN

BASS.Import

+ instrument #, MOD instrument name : ANSI string

BASS_TAG_MUSIC_INST

BASS.Import

MOD author : UTF-8 string

BASS_TAG_MUSIC_MESSAGE

BASS.Import

MOD music name : ANSI string

BASS_TAG_MUSIC_NAME

BASS.Import

+ index #, binary APEv2 tag : TAG_APE_BINARY structure

BASS_TAG_MUSIC_ORDERS

BASS.Import

MOD message : ANSI string

BASS_TAG_MUSIC_SAMPLE

BASS.Import

+ channel #, MOD channel name : ANSI string

BASS_TAG_OGG

BASS.Import

ID3v2 tags : variable length block

BASS_TAG_RIFF_BEXT

BASS.Import

RIFF "INFO" tags : series of null-terminated ANSI strings

BASS_TAG_RIFF_CART

BASS.Import

RIFF/BWF "bext" tags : TAG_BEXT structure

BASS_TAG_RIFF_CUE

BASS.Import

RIFF "DISP" text tag : ANSI string

BASS_TAG_RIFF_DISP

BASS.Import

RIFF/BWF "cart" tags : TAG_CART structure

BASS_TAG_RIFF_INFO

BASS.Import

redirected URL : ASCII string

BASS_TAG_RIFF_SMPL

BASS.Import

RIFF "cue " chunk : TAG_CUE structure

BASS_TAG_VENDOR

BASS.Import

WMA tags : series of null-terminated UTF-8 strings

BASS_TAG_WAVEFORMAT

BASS.Import

Media Foundation tags : series of null-terminated UTF-8 strings

BASS_TAG_WMA

BASS.Import

MP4/iTunes metadata : series of null-terminated UTF-8 strings

BASS_UNICODE

BASS.Import

BASS_UnLoad

BASS.Import

BASS_Update

BASS.Import

external bassdll;

BASS_VAM_HARDWARE

BASS.Import

start recording paused DX7 voice allocation & management flags

BASS_VAM_SOFTWARE

BASS.Import

Play the sample in hardware. If no hardware voices are available then the "play" call will fail

BASS_VAM_TERM_DIST

BASS.Import

If there are no free hardware voices, the buffer to be terminated will be the one with the least time left to play.

BASS_VAM_TERM_PRIO

BASS.Import

If there are no free hardware voices, the buffer to be terminated will be one that was loaded/created with the BASS_SAMPLE_MUTEMAX flag and is beyond it's max distance. If there are no buffers that match this criteria, then the "play" call will fail.

BASS_VAM_TERM_TIME

BASS.Import

These flags enable hardware resource stealing... if the hardware has no available voices, a currently playing buffer will be stopped to make room for the new buffer. NOTE: only samples loaded/created with the BASS_SAMPLE_VAM flag are considered for termination by the DX7 voice management.

BBMaxX

GLScene.GeometryBB

BBMaxY

GLScene.GeometryBB

BBMaxZ

GLScene.GeometryBB

BBMinX

GLScene.GeometryBB

BBMinY

GLScene.GeometryBB

BBMinZ

GLScene.GeometryBB

BBToAABB

GLScene.GeometryBB

Extract AABB information from a BB.

BBTransform

GLScene.GeometryBB

BeginFPUOnlySection

GLScene.VectorGeometry

Begins a FPU-only section. You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases. Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).

BEHAVIOURS_SELECTED

FmSceneEditor

BGR24ToRGB24

GLS.Graphics

BGR24ToRGBA32

GLS.Graphics

BGRA32ToRGBA32

GLS.Graphics

bindtextdomain

gnugettext

BinormalAttributeName

GLS.Objects

BitMapStrMax3DS

Formats.m3DSConst

inclusive maximum value for shadow filter BITMAP chunk

BIT_MAP

Formats.m3DSConst

BI_1632

Formats.VFW

Handle to an Installable Compressor
this code in biCompression means the DIB must be accesed via 48 bit pointers! using *ONLY* the selector given.

BOOL

BASS.Import

Border

GLS.Memo

BottomFalloff

Formats.m3DSConst

BOUNDBOX

Formats.m3DSConst

BoundingBoxesAreEqual

GLScene.GeometryBB

BoundingBoxesAreEqual

GLScene.GeometryBB

—————————————————————————— Bounding Box functions ——————————————————————————

BrightenRGBArray

GLS.Graphics

BSphereContainsAABB

GLScene.GeometryBB

Determines to which extent a BSphere contains an AABB

BSphereContainsBSphere

GLScene.GeometryBB

Determines to which extent one BSphere contains another BSphere

BSphereIntersectsBSphere

GLScene.GeometryBB

Determines if one BSphere intersects another BSphere

BSphereToAABB

GLScene.GeometryBB

BSphereToAABB

GLScene.GeometryBB

BSphereToAABB

GLScene.GeometryBB

Convert a BSphere to an AABB

BufSize

GLS.FileOBJ

Load input data in chunks of BufSize Bytes.

Build2DMipmap

GLS.ImageUtils

BuildMeshCube

GLS.MeshBuilder

—————- Build Meshes ——————-

BuildMeshCylinder

GLS.MeshBuilder

BuildMeshCylinderAdv

GLS.MeshBuilder

BuildMeshHemiCylinder

GLS.MeshBuilder

BuildMeshHemiSphere

GLS.MeshBuilder

Not implemented

BuildNonOrientedEdgesList

GLS.MeshUtils

Builds a list of non-oriented (non duplicated) edges list. Each edge is represented by the two integers of its vertices, sorted in ascending order. If not nil then - triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation; - edgesTriangles is filled with the indices of the first index of the triangle in triangleIndices that have this edge. A maximum of two triangles can be referred by this list, and its final size will be that of the Result (ie. non oriented edges list)

BuildNormals

GLS.MeshUtils

Builds normals for a triangles list. Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles. Returned list must be freed by caller.

BuildVectorCountOptimizedIndices

GLS.MeshUtils

Builds a vector-count optimized indices list. The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used). The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.

ByteElement

CUDA.DataAccess

c180

GLScene.VectorGeometry

c180divPI

GLScene.VectorGeometry

c2PI

GLScene.VectorGeometry

c360

GLScene.VectorGeometry

c3PIdiv2

GLScene.VectorGeometry

c3PIdiv4

GLScene.VectorGeometry

CalcObjectSpaceLightVectors

GLS.BumpmapHDS

Some useful methods for setting up bump maps.

CalcPlaneNormal

GLScene.VectorGeometry

CalcPlaneNormal

GLScene.VectorGeometry

CalcPlaneNormal

GLScene.VectorGeometry

Calculate the normal of a plane defined by three points.

CalcTangentSpaceLightVectors

GLS.BumpmapHDS

cAllAttribBits

GLS.State

cAllColorComponents

GLS.State

cAllFrustrumParts

GLS.GeomObjects

callibname

OpenAL.Import

define ALUT to use alut.dll

cAllMeshPrimitive

GLS.State

cAllStatesChanged

GLScene.PipelineTransform

calutlibname

OpenAL.Import

CAMERA_NODE_TAG

Formats.m3DSConst

CAM_RANGES

Formats.m3DSConst

CAM_SEE_CONE

Formats.m3DSConst

capCaptureAbort

Formats.VFW

capCaptureGetSetup

Formats.VFW

capCaptureSequence

Formats.VFW

capCaptureSequenceNoFile

Formats.VFW

capCaptureSetSetup

Formats.VFW

capCaptureSingleFrame

Formats.VFW

capCaptureSingleFrameClose

Formats.VFW

capCaptureSingleFrameOpen

Formats.VFW

capCaptureStop

Formats.VFW

capCreateCaptureWindow

Formats.VFW

capCreateCaptureWindowA

Formats.VFW

– The only exported functions from AVICAP.DLL ——————————

capCreateCaptureWindowW

Formats.VFW

capDlgVideoCompression

Formats.VFW

capDlgVideoDisplay

Formats.VFW

capDlgVideoFormat

Formats.VFW

capDlgVideoSource

Formats.VFW

capDriverConnect

Formats.VFW

capDriverDisconnect

Formats.VFW

capDriverGetCaps

Formats.VFW

capDriverGetName

Formats.VFW

capDriverGetVersion

Formats.VFW

capEditCopy

Formats.VFW

capFileAlloc

Formats.VFW

capFileGetCaptureFile

Formats.VFW

capFileSaveAs

Formats.VFW

capFileSaveDIB

Formats.VFW

capFileSetCaptureFile

Formats.VFW

capFileSetInfoChunk

Formats.VFW

capGetAudioFormat

Formats.VFW

capGetAudioFormatSize

Formats.VFW

capGetDriverDescription

Formats.VFW

capCreateCaptureWindowA

capGetDriverDescriptionA

Formats.VFW

capGetDriverDescriptionW

Formats.VFW

capGetMCIDeviceName

Formats.VFW

capGetStatus

Formats.VFW

capGetUserData

Formats.VFW

capGetVideoFormat

Formats.VFW

capGetVideoFormatSize

Formats.VFW

capGrabFrame

Formats.VFW

capGrabFrameNoStop

Formats.VFW

capOverlay

Formats.VFW

capPaletteAuto

Formats.VFW

capPaletteManual

Formats.VFW

capPaletteOpen

Formats.VFW

capPalettePaste

Formats.VFW

capPaletteSave

Formats.VFW

capPreview

Formats.VFW

capPreviewRate

Formats.VFW

capPreviewScale

Formats.VFW

capSetAudioFormat

Formats.VFW

capSetCallbackOnCapControl

Formats.VFW

capSetCallbackOnError

Formats.VFW

message wrapper macros are defined for the default messages only. Apps that wish to mix Ansi and UNICODE message sending will have to reference the _A and _W messages directly

capSetCallbackOnFrame

Formats.VFW

capSetCallbackOnStatus

Formats.VFW

capSetCallbackOnVideoStream

Formats.VFW

capSetCallbackOnWaveStream

Formats.VFW

capSetCallbackOnYield

Formats.VFW

capSetMCIDeviceName

Formats.VFW

capSetScrollPos

Formats.VFW

capSetUserData

Formats.VFW

capSetVideoFormat

Formats.VFW

cAUToKilometers

GLS.SkyDome

(AU)

CBBBack

GLScene.GeometryBB

CBBBottom

GLScene.GeometryBB

CBBFront

GLScene.GeometryBB

CBBLeft

GLScene.GeometryBB

CBBPlans

GLScene.GeometryBB

CBBRight

GLScene.GeometryBB

CBBTop

GLScene.GeometryBB

cbrt

GLScene.Polynomials

Calculates the cube root of its parameter.

cColinearBias

GLScene.VectorGeometry

cDefaultActorOptions

GLS.VectorFileObjects

cDefaultCyborgOptions

GLS.SmartObjects

cDefaultFlareElements

GLS.LensFlare

cDefaultImposterOptions

GLS.Imposter

cDefaultMirrorOptions

GLS.Mirror

cDefaultNormalMapScale

GLS.Texture

cDefaultPointSize

GLS.Objects

cDefaultProxyOptions

GLS.Scene

cDefaultScreenSaverOptions

GLS.ScreenSaver

cDefaultSDLWindowOptions

GLS.SDL.Window

cDefaultShadowPlaneOptions

GLS.ShadowPlane

cDefaultSwizzleVector

GLScene.TextureFormat

cDefaultWaterPlaneOptions

GLS.WaterPlane

cDEFAULT_CONSTRAINT_FRICTION

GLS.VerletTypes

cDEFAULT_TIMER_INTERVAL

GLS.AsyncTimer

CDirPlan

GLScene.GeometryBB

cEarthRadius

GLS.SkyDome

astronomical units to kilometers

cECCloseDistance

GLS.EllipseCollision

CGbool

Cg.Import

cgCompileProgram

Cg.Import

cgConnectParameter

Cg.Import

CGcontext

Cg.Import

cgCopyProgram

Cg.Import

cgCreateContext

Cg.Import

** Context functions **

cgCreateParameter

Cg.Import

** Parameter functions **

cgCreateParameterArray

Cg.Import

cgCreateParameterMultiDimArray

Cg.Import

cgCreateProgram

Cg.Import

** Program functions **

cgCreateProgramFromFile

Cg.Import

cgDestroyContext

Cg.Import

cgDestroyParameter

Cg.Import

cgDestroyProgram

Cg.Import

cgDisconnectParameter

Cg.Import

CGenum

Cg.Import

CGerror

Cg.Import

CGerrorCallbackFunc

Cg.Import

cgGetArrayDimension

Cg.Import

cgGetArrayParameter

Cg.Import

cgGetArraySize

Cg.Import

cgGetArrayType

Cg.Import

cgGetConnectedParameter

Cg.Import

cgGetConnectedToParameter

Cg.Import

cgGetEnum

Cg.Import

cgGetEnumString

Cg.Import

*** Enum Functions ***

cgGetError

Cg.Import

** Error Functions **

cgGetErrorCallback

Cg.Import

cgGetErrorString

Cg.Import

cgGetFirstDependentParameter

Cg.Import

cgGetFirstLeafParameter

Cg.Import

cgGetFirstParameter

Cg.Import

cgGetFirstProgram

Cg.Import

cgGetFirstStructParameter

Cg.Import

cgGetLastErrorString

Cg.Import

cgGetLastListing

Cg.Import

cgGetNamedParameter

Cg.Import

cgGetNamedProgramParameter

Cg.Import

cgGetNamedStructParameter

Cg.Import

cgGetNamedUserType

Cg.Import

cgGetNextLeafParameter

Cg.Import

cgGetNextLeafParameter_depr1_1

Cg.Import

cgGetNextParameter

Cg.Import

cgGetNextParameter_depr1_1

Cg.Import

*** Support for deprecated Cg 1.1 API ***

cgGetNextProgram

Cg.Import

cgGetNumConnectedToParameters

Cg.Import

cgGetNumParentTypes

Cg.Import

cgGetNumUserTypes

Cg.Import

cgGetParameterBaseResource

Cg.Import

cgGetParameterContext

Cg.Import

cgGetParameterDirection

Cg.Import

cgGetParameterIndex

Cg.Import

cgGetParameterName

Cg.Import

cgGetParameterNamedType

Cg.Import

cgGetParameterOrdinalNumber

Cg.Import

cgGetParameterProgram

Cg.Import

cgGetParameterResource

Cg.Import

cgGetParameterResourceIndex

Cg.Import

cgGetParameterSemantic

Cg.Import

cgGetParameterType

Cg.Import

cgGetParameterValues

Cg.Import

cgGetParameterVariability

Cg.Import

cgGetParentType

Cg.Import

cgGetProfile

Cg.Import

cgGetProfileString

Cg.Import

** Profile Functions **

cgGetProgramContext

Cg.Import

cgGetProgramProfile

Cg.Import

cgGetProgramString

Cg.Import

cgGetResource

Cg.Import

cgGetResourceString

Cg.Import

** Resource Functions **

cgGetString

Cg.Import

*** Misc Functions ***

cgGetType

Cg.Import

cgGetTypeString

Cg.Import

** Type Functions **

cgGetUserType

Cg.Import

cgGLBindProgram

Cg.GL

cgGLDisableClientState

Cg.GL

cgGLDisableProfile

Cg.GL

cgGLDisableTextureParameter

Cg.GL

cgGLEnableClientState

Cg.GL

cgGLEnableProfile

Cg.GL

cgGLEnableTextureParameter

Cg.GL

CGGLenum

Cg.GL

cgGLGetLatestProfile

Cg.GL

cgGLGetManageTextureParameters

Cg.GL

cgGLGetMatrixParameterArraydc

Cg.GL

cgGLGetMatrixParameterArraydr

Cg.GL

cgGLGetMatrixParameterArrayfc

Cg.GL

cgGLGetMatrixParameterArrayfr

Cg.GL

cgGLGetMatrixParameterdc

Cg.GL

cgGLGetMatrixParameterdr

Cg.GL

cgGLGetMatrixParameterfc

Cg.GL

cgGLGetMatrixParameterfr

Cg.GL

cgGLGetParameter1d

Cg.GL

cgGLGetParameter1f

Cg.GL

cgGLGetParameter2d

Cg.GL

cgGLGetParameter2f

Cg.GL

cgGLGetParameter3d

Cg.GL

cgGLGetParameter3f

Cg.GL

cgGLGetParameter4d

Cg.GL

cgGLGetParameter4f

Cg.GL

cgGLGetParameterArray1d

Cg.GL

cgGLGetParameterArray1f

Cg.GL

cgGLGetParameterArray2d

Cg.GL

cgGLGetParameterArray2f

Cg.GL

cgGLGetParameterArray3d

Cg.GL

cgGLGetParameterArray3f

Cg.GL

cgGLGetParameterArray4d

Cg.GL

cgGLGetParameterArray4f

Cg.GL

cgGLGetProgramID

Cg.GL

cgGLGetTextureEnum

Cg.GL

cgGLGetTextureParameter

Cg.GL

cgGLIsProfileSupported

Cg.GL

***************************************************************************** *** Profile Functions ****************************************************************************

cgGLIsProgramLoaded

Cg.GL

CgGLlibrary

Cg.GL

cgGLLoadProgram

Cg.GL

***************************************************************************** *** Program Managment Functions ****************************************************************************

cgGLSetManageTextureParameters

Cg.GL

cgGLSetMatrixParameterArraydc

Cg.GL

cgGLSetMatrixParameterArraydr

Cg.GL

cgGLSetMatrixParameterArrayfc

Cg.GL

cgGLSetMatrixParameterArrayfr

Cg.GL

cgGLSetMatrixParameterdc

Cg.GL

cgGLSetMatrixParameterdr

Cg.GL

***************************************************************************** *** Matrix Parameter Managment Functions ****************************************************************************

cgGLSetMatrixParameterfc

Cg.GL

cgGLSetMatrixParameterfr

Cg.GL

cgGLSetOptimalOptions

Cg.GL

cgGLSetParameter1d

Cg.GL

cgGLSetParameter1dv

Cg.GL

cgGLSetParameter1f

Cg.GL

***************************************************************************** *** Parameter Managment Functions ****************************************************************************

cgGLSetParameter1fv

Cg.GL

cgGLSetParameter2d

Cg.GL

cgGLSetParameter2dv

Cg.GL

cgGLSetParameter2f

Cg.GL

cgGLSetParameter2fv

Cg.GL

cgGLSetParameter3d

Cg.GL

cgGLSetParameter3dv

Cg.GL

cgGLSetParameter3f

Cg.GL

cgGLSetParameter3fv

Cg.GL

cgGLSetParameter4d

Cg.GL

cgGLSetParameter4dv

Cg.GL

cgGLSetParameter4f

Cg.GL

cgGLSetParameter4fv

Cg.GL

cgGLSetParameterArray1d

Cg.GL

cgGLSetParameterArray1f

Cg.GL

cgGLSetParameterArray2d

Cg.GL

cgGLSetParameterArray2f

Cg.GL

cgGLSetParameterArray3d

Cg.GL

cgGLSetParameterArray3f

Cg.GL

cgGLSetParameterArray4d

Cg.GL

cgGLSetParameterArray4f

Cg.GL

cgGLSetParameterPointer

Cg.GL

cgGLSetStateMatrixParameter

Cg.GL

cgGLSetTextureParameter

Cg.GL

***************************************************************************** *** Texture Parameter Managment Functions ****************************************************************************

cgGLUnbindProgram

Cg.GL

cgIsContext

Cg.Import

cgIsInterfaceType

Cg.Import

cgIsParameter

Cg.Import

cgIsParameterGlobal

Cg.Import

cgIsParameterReferenced

Cg.Import

cgIsParentType

Cg.Import

cgIsProgram

Cg.Import

cgIsProgramCompiled

Cg.Import

CGLAbstractShaderUniform

GLS.MaterialEx

CGLBaseMaterialCollectionItem

GLS.MaterialEx

cGLBlendEquationToGLEnum

GLS.State

valid for src only

cGLBlendFunctionToGLEnum

GLS.State

cGLBufferBindingTarget

GLS.State

cGLComparisonFunctionToGLEnum

GLS.State

cGLCullFaceModeToGLEnum

GLS.State

cGLFaceWindingToGLEnum

GLS.State

cGLgsInTypes

GLSL.ShaderParameter

cGLgsOutTypes

GLSL.ShaderParameter

cGLHintToGLEnum

GLS.State

CgLibrary

Cg.Import

cGLLogicOpToGLEnum

GLS.State

cGLPolygonModeToGLEnum

GLS.State

cGLQueryTypeToGLEnum

GLS.State

cGLSLSamplerString

GLSL.ShaderParameter

cGLSLTypeString

GLSL.ShaderParameter

cGLStateToGLEnum

GLS.State

cGLStateTypeToGLEnum

GLS.State

cGLStencilOpToGLEnum

GLS.State

cGLTexTypeToGLEnum

GLS.State

CGparameter

Cg.Import

CGprofile

Cg.Import

CGprogram

Cg.Import

CGresource

Cg.Import

cgSetArraySize

Cg.Import

cgSetAutoCompile

Cg.Import

cgSetErrorCallback

Cg.Import

cgSetMatrixParameterdc

Cg.Import

cgSetMatrixParameterdr

Cg.Import

cgSetMatrixParameterfc

Cg.Import

cgSetMatrixParameterfr

Cg.Import

cgSetMultiDimArraySize

Cg.Import

cgSetParameter1d

Cg.Import

cgSetParameter1dv

Cg.Import

cgSetParameter1f

Cg.Import

cgSetParameter1fv

Cg.Import

cgSetParameter2d

Cg.Import

cgSetParameter2dv

Cg.Import

cgSetParameter2f

Cg.Import

cgSetParameter2fv

Cg.Import

cgSetParameter3d

Cg.Import

cgSetParameter3dv

Cg.Import

cgSetParameter3f

Cg.Import

cgSetParameter3fv

Cg.Import

cgSetParameter4d

Cg.Import

cgSetParameter4dv

Cg.Import

cgSetParameter4f

Cg.Import

cgSetParameter4fv

Cg.Import

cgSetParameterSemantic

Cg.Import

cgSetParameterVariability

Cg.Import

CGtype

Cg.Import

CG_DATATYPE_MACRO(Bool4x4,bool4x4,CG_BOOL4x4,4,4)

CG_ARRAY_DIMENSIONS_DO_NOT_MATCH_ERROR

Cg.Import

"Cannot bind the given parameters. Array types do not match."

CG_ARRAY_HAS_WRONG_DIMENSION_ERROR

Cg.Import

"Cannot bind the given parameters. Array dimensions do not match."

CG_ARRAY_PARAM_ERROR

Cg.Import

"The dimension value is invalid."

CG_ARRAY_TYPES_DO_NOT_MATCH_ERROR

Cg.Import

"Cannot bind the given parameters. Binding will form a cycle."

CG_BIND_CREATES_CYCLE_ERROR

Cg.Import

"The size value is invalid."

CG_CANNOT_DESTROY_PARAMETER_ERROR

Cg.Import

"The parameter could not be changed to the given variability."

CG_COMPILER_ERROR

Cg.Import

"No error has occurred."

CG_CONFLICTING_PARAMETER_TYPES_ERROR

Cg.Import

"A type being added to the context conflicts with an existing type."

CG_CONFLICTING_TYPES_ERROR

Cg.Import

"Index into the array is out of bounds."

CG_FALSE

Cg.Import

CG_FILE_READ_ERROR

Cg.Import

"The parameter must be a 4x4 matrix type."

CG_FILE_WRITE_ERROR

Cg.Import

"The file could not be read."

CG_GL_FRAGMENT

Cg.GL

CG_GL_MATRIX_IDENTITY

Cg.GL

CG_GL_MATRIX_INVERSE

Cg.GL

CG_GL_MATRIX_INVERSE_TRANSPOSE

Cg.GL

CG_GL_MATRIX_TRANSPOSE

Cg.GL

CG_GL_MODELVIEW_MATRIX

Cg.GL

CG_GL_MODELVIEW_PROJECTION_MATRIX

Cg.GL

CG_GL_PROJECTION_MATRIX

Cg.GL

CG_GL_TEXTURE_MATRIX

Cg.GL

CG_GL_VERTEX

Cg.GL

CG_INVALID_CONTEXT_HANDLE_ERROR

Cg.Import

"Memory allocation failed."

CG_INVALID_DIMENSION_ERROR

Cg.Import

"The variable arguments were specified incorrectly."

CG_INVALID_ENUMERANT_ERROR

Cg.Import

"The parameter is not of matrix type."

CG_INVALID_PARAMETER_ERROR

Cg.Import

"The compile returned an error."

CG_INVALID_PARAMETER_TYPE_ERROR

Cg.Import

"The parameter is not a program parameter."

CG_INVALID_PARAMETER_VARIABILITY_ERROR

Cg.Import

"The parameter must be global."

CG_INVALID_PARAM_HANDLE_ERROR

Cg.Import

"Invalid program handle."

CG_INVALID_PROFILE_ERROR

Cg.Import

"The parameter used is invalid."

CG_INVALID_PROGRAM_HANDLE_ERROR

Cg.Import

"Invalid context handle."

CG_INVALID_SIZE_ERROR

Cg.Import

"The parameter must be a resizable array."

CG_INVALID_VALUE_TYPE_ERROR

Cg.Import

"An unsupported GL extension was required to perform this operation."

CG_IS_NOT_PROGRAM_PARAMETER_ERROR

Cg.Import

"The two parameters being bound do not match."

CG_MEMORY_ALLOC_ERROR

Cg.Import

"nvparse could not successfully parse the output from the Cg compiler backend."

CG_NOT_4x4_MATRIX_ERROR

Cg.Import

"The enumerant parameter has an invalid value."

CG_NOT_MATRIX_PARAM_ERROR

Cg.Import

"An unknown value type was assigned to a parameter."

CG_NOT_ROOT_PARAMETER_ERROR

Cg.Import

"Cannot destroy the parameter. It is bound to other parameters or is not a root parameter."

CG_NO_ERROR

Cg.Import

# define CG_ERROR_MACRO(code, enum_name, new_enum_name, message) \ new_enum_name = code,

CG_NVPARSE_ERROR

Cg.Import

"The file could not be written."

CG_OUT_OF_ARRAY_BOUNDS_ERROR

Cg.Import

"The parameter must be an array."

CG_PARAMETERS_DO_NOT_MATCH_ERROR

Cg.Import

"The parameter is not a root parameter."

CG_PARAMETER_IS_NOT_RESIZABLE_ARRAY_ERROR

Cg.Import

"The type of the parameter is invalid."

CG_PARAMETER_IS_NOT_SHARED_ERROR

Cg.Import

"The parameters being bound have conflicting types."

CG_PROGRAM_BIND_ERROR

Cg.Import

"The program did could not load."

CG_PROGRAM_LOAD_ERROR

Cg.Import

"The profile is not supported."

CG_PROGRAM_NOT_LOADED_ERROR

Cg.Import

"The program could not bind."

CG_TRUE

Cg.Import

CG_TYPE_IS_NOT_DEFINED_IN_PROGRAM_ERROR

Cg.Import

"The array is has the wrong dimension."

CG_UNKNOWN_PROFILE_ERROR

Cg.Import

"Invalid parameter handle."

CG_UNSUPPORTED_GL_EXTENSION_ERROR

Cg.Import

"The program must be loaded before this operation may be used."

CG_VAR_ARG_ERROR

Cg.Import

"The specified profile is unknown."

CG_VERSION_1_2

Cg.Import

CG_VERSION_NUM

Cg.Import

CharToVirtualKeyCode

GLScene.Keyboard

Returns the virtual keycode corresponding to the given char. The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.

CharToWideChar

GLScene.Utils

CheckOpenGLError

GLScene.OpenGL4

cHTFHashTableSize

GLS.HeightTileFileHDS

cHTFQuadTableSize

GLS.HeightTileFileHDS

ChunkHeaderReport

Formats.m3DSUtils

support functions for text output of chunk and database contents

ChunkTagToString

Formats.m3DSUtils

ChunkType

Formats.m3DSConst

Trick Chunk Flags For ChunkSyntax function

ChunkUnique

Formats.m3DSConst

cImageDataFormat16bits

Formats.DXTC

cImageDataFormat24bits

Formats.DXTC

cImageDataFormat32bits

Formats.DXTC

cImageDataFormat8bits

Formats.DXTC

cInv2PI

GLScene.VectorGeometry

cInv360

GLScene.VectorGeometry

cJupiterOrbitalElements

GLS.SkyDome

(AU) heliocentric jupiter elements

ckidAVIMAINHDR

Formats.VFW

mmioFOURCC('h', 'd', 'r', 'l')

ckidAVINEWINDEX

Formats.VFW

mmioFOURCC('r', 'e', 'c', ' ')

ckidAVIPADDING

Formats.VFW

– Chunk id to use for extra chunks for padding —————————–

ckidSTREAMFORMAT

Formats.VFW

mmioFOURCC('s', 't', 'r', 'h')

ckidSTREAMHANDLERDATA

Formats.VFW

mmioFOURCC('s', 't', 'r', 'f')

ckidSTREAMHEADER

Formats.VFW

mmioFOURCC('s', 't', 'r', 'l')

ckidSTREAMNAME

Formats.VFW

mmioFOURCC('s', 't', 'r', 'd')

cktypeDIBbits

Formats.VFW

– Basic chunk types ——————————————————–

cktypeDIBcompressed

Formats.VFW

aviTWOCC('d', 'b')

cktypePALchange

Formats.VFW

aviTWOCC('d', 'c')

cktypeWAVEbytes

Formats.VFW

aviTWOCC('p', 'c')

ClampInteger

GLScene.VectorGeometry

ClampInteger

GLScene.VectorGeometry

ClampValue

GLScene.VectorGeometry

Clamps aValue in the aMin-aMax interval

ClampValue

GLScene.VectorGeometry

Clamps aValue in the aMin-INF interval

clBuildProgram

OpenCL.Import

clCloneKernel

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clCompileProgram

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clCreateBuffer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Memory Object APIs *//

clCreateCommandQueue

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Command Queue APIs *//

clCreateContext

OpenCL.Import

clCreateContextFromType

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clCreateFromGLBuffer

OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;

clCreateFromGLRenderbuffer

OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;

clCreateFromGLTexture3D

OpenCL.GL

CL_API_SUFFIX__VERSION_1_2;

clCreateImage

OpenCL.Import

CL_API_SUFFIX__VERSION_1_1

clCreateKernel

OpenCL.Import

Kernel Object APIs

clCreateKernelsInProgram

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clCreatePipe

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clCreateProgramWithBinary

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clCreateProgramWithBuiltInKernels

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clCreateProgramWithIL

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clCreateProgramWithSource

OpenCL.Import

Program Object APIs

clCreateSamplerWithProperties

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0 * Sampler APIs *//

clCreateSubBuffer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clCreateSubDevices

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clCreateUserEvent

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

ClearGLError

GLScene.OpenGL4

Gets the oldest error and tries to clear the error queue

clEnqueueAcquireGLObjects

OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;

clEnqueueBarrier

OpenCL.Import

clEnqueueBarrierWithWaitList

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clEnqueueCopyBuffer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clEnqueueCopyBufferRect

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueCopyBufferToImage

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueCopyImage

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clEnqueueCopyImageToBuffer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueFillBuffer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_1

clEnqueueFillImage

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueMapBuffer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueMapImage

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueMarkerWithWaitList

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueMigrateMemObjects

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueNativeKernel

OpenCL.Import

clEnqueueNDRangeKernel

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clEnqueueReadBuffer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Enqueued Commands APIs *//

clEnqueueReadBufferRect

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueReadImage

OpenCL.Import

CL_API_SUFFIX__VERSION_1_1

clEnqueueReleaseGLObjects

OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;

clEnqueueSVMFree

OpenCL.Import

clEnqueueSVMMap

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clEnqueueSVMMemcpy

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueSVMmigrateMem

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clEnqueueSVMUnmap

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clEnqueueUnmapMemObject

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueWaitForEvents

OpenCL.Import

CL_API_SUFFIX__VERSION_2_1

clEnqueueWriteBuffer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_1

clEnqueueWriteBufferRect

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clEnqueueWriteImage

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clFinish

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clFlush

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Flush and Finish APIs *//

clGetCommandQueueInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetContextInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetDeviceAndHostTimer

OpenCL.Import

CL_API_SUFFIX__VERSION_2_1

clGetDeviceIDs

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Device APIs *//

clGetDeviceInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetEventInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetEventProfilingInfo

OpenCL.Import

Profiling APIs

clGetExtensionFunctionAddressForPlatform

OpenCL.Import

* Extension function access * * Returns the extension function address for the given function name, * or NULL if a valid function can not be found. The client must * check to make sure the address is not NULL, before using or * calling the returned function address. *

clGetGLContextInfoKHR

OpenCL.GL

clGetGLObjectInfo

OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;

clGetGLTextureInfo

OpenCL.GL

CL_API_SUFFIX__VERSION_1_0;

clGetHostTimer

OpenCL.Import

CL_API_SUFFIX__VERSION_2_1

clGetImageInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetKernelArgInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetKernelInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clGetKernelSubGroupInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetKernelWorkGroupInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clGetMemObjectInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetPipeInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetPlatformIDs

OpenCL.Import

Platform API

clGetPlatformInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetProgramBuildInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetProgramInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clGetSamplerInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clGetSupportedImageFormats

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

ClipToAABB

GLScene.GeometryBB

Clips a position to an AABB

clLinkProgram

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

cLn10

GLScene.VectorGeometry

CLogSession

GLScene.Logger

Class reference to log session class

CloseCUDA

CUDA.Import

CloseCUDART

CUDA.Runtime

CloseCUFFT

CUDA.FourierTransform

CloseCUTIL

CUDA.Utility

ClosedPolygon2D

GLScene.VectorTypesExt

TPolygon3D = record Vertices: array of TPoint3DRec; function Length; end;

ClosedPolygon3D

GLScene.VectorTypesExt

CloseODE

ODE.Import

CloseOpenCL

OpenCL.Import

CloseOpenGL

GLS.OpenGLAdapter

CloseOpenGL

GLScene.OpenGL4

clReleaseCommandQueue

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clReleaseContext

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clReleaseDevice

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clReleaseEvent

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clReleaseKernel

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clReleaseMemObject

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clReleaseProgram

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clReleaseSampler

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clRetainCommandQueue

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clRetainContext

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clRetainDevice

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clRetainEvent

OpenCL.Import

CL_API_SUFFIX__VERSION_1_1

clRetainKernel

OpenCL.Import

CL_API_SUFFIX__VERSION_2_1

clRetainMemObject

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clRetainProgram

OpenCL.Import

CL_API_SUFFIX__VERSION_2_1

clRetainSampler

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clSetDefaultDeviceCommandQueue

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clSetEventCallback

OpenCL.Import

clSetKernelArg

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clSetKernelArgSVMPointer

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

clSetKernelExecInfo

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clSetMemObjectDestructorCallback

OpenCL.Import

clSetUserEventStatus

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

CLSID_AVIFile

Formats.VFW

CLSID_AVISimpleUnMarshal

Formats.VFW

clSVMAlloc

OpenCL.Import

CL_API_SUFFIX__VERSION_1_1 * SVM Allocation APIs *//

clSVMFree

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

clUnloadPlatformCompiler

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

clWaitForEvents

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0 * Event Object APIs *//

CL_A

OpenCL.Import

CL_ABGR

OpenCL.Import

CL_ADDRESS_CLAMP

OpenCL.Import

CL_ADDRESS_CLAMP_TO_EDGE

OpenCL.Import

CL_ADDRESS_MIRRORED_REPEAT

OpenCL.Import

CL_ADDRESS_NONE

OpenCL.Import

cl_addressing_mode

CL_ADDRESS_REPEAT

OpenCL.Import

CL_APT_CALL

OpenCL.Platform

*************************************************************************** * Copyright (c) 2008-2023 The Khronos Group Inc. * * Permission is hereby granted, free of charge, to any person obtaining a * copy of this software and/or associated documentation files (the * "Materials"), to deal in the Materials without restriction, including * without limitation the rights to use, copy, modify, merge, publish, * distribute, sublicense, and/or sell copies of the Materials, and to * permit persons to whom the Materials are furnished to do so, subject to * the following conditions: * * The above copyright notice and this permission notice shall be included * in all copies or substantial portions of the Materials. * * MODIFICATIONS TO THIS FILE MAY MEAN IT NO LONGER ACCURATELY REFLECTS * KHRONOS STANDARDS. THE UNMODIFIED, NORMATIVE VERSIONS OF KHRONOS * SPECIFICATIONS AND HEADER INFORMATION ARE LOCATED AT * https://www.khronos.org/registry/ * * THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE * MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS. *************************************************************************

CL_ARGB

OpenCL.Import

CL_BGRA

OpenCL.Import

CL_BLOCKING

OpenCL.Import

CL_BUFFER_CREATE_TYPE_REGION

OpenCL.Import

cl_buffer_create_type

CL_BUILD_ERROR

OpenCL.Import

CL_BUILD_IN_PROGRESS

OpenCL.Import

CL_BUILD_NONE

OpenCL.Import

CL_BUILD_PROGRAM_FAILURE

OpenCL.Import

CL_BUILD_SUCCESS

OpenCL.Import

cl_build_status

CL_CALLBACK

OpenCL.Platform

CL_CGL_SHAREGROUP_KHR

OpenCL.GL

CL_CHAR_BIT

OpenCL.Platform

Macro names and corresponding values defined by OpenCL

CL_CHAR_MAX

OpenCL.Platform

CL_CHAR_MIN

OpenCL.Platform

CL_COMMAND_ACQUIRE_GL_OBJECTS

OpenCL.Import

CL_COMMAND_BARRIER

OpenCL.Import

CL_COMMAND_COPY_BUFFER

OpenCL.Import

CL_COMMAND_COPY_BUFFER_RECT

OpenCL.Import

CL_COMMAND_COPY_BUFFER_TO_IMAGE

OpenCL.Import

CL_COMMAND_COPY_IMAGE

OpenCL.Import

CL_COMMAND_COPY_IMAGE_TO_BUFFER

OpenCL.Import

CL_COMMAND_FILL_BUFFER

OpenCL.Import

CL_COMMAND_FILL_IMAGE

OpenCL.Import

CL_COMMAND_MAP_BUFFER

OpenCL.Import

CL_COMMAND_MAP_IMAGE

OpenCL.Import

CL_COMMAND_MARKER

OpenCL.Import

CL_COMMAND_MIGRATE_MEM_OBJECTS

OpenCL.Import

CL_COMMAND_NATIVE_KERNEL

OpenCL.Import

CL_COMMAND_NDRANGE_KERNEL

OpenCL.Import

cl_command_type

CL_COMMAND_READ_BUFFER

OpenCL.Import

CL_COMMAND_READ_BUFFER_RECT

OpenCL.Import

CL_COMMAND_READ_IMAGE

OpenCL.Import

CL_COMMAND_RELEASE_GL_OBJECTS

OpenCL.Import

CL_COMMAND_SVM_FREE

OpenCL.Import

CL_COMMAND_SVM_MAP

OpenCL.Import

CL_COMMAND_SVM_MEMCPY

OpenCL.Import

CL_COMMAND_SVM_MEMFILL

OpenCL.Import

CL_COMMAND_SVM_UNMAP

OpenCL.Import

CL_COMMAND_TASK

OpenCL.Import

CL_COMMAND_UNMAP_MEM_OBJECT

OpenCL.Import

CL_COMMAND_USER

OpenCL.Import

CL_COMMAND_WRITE_BUFFER

OpenCL.Import

CL_COMMAND_WRITE_BUFFER_RECT

OpenCL.Import

CL_COMMAND_WRITE_IMAGE

OpenCL.Import

CL_COMPILER_NOT_AVAILABLE

OpenCL.Import

CL_COMPILE_PROGRAM_FAILURE

OpenCL.Import

CL_COMPLETE

OpenCL.Import

command execution status

CL_CONTEXT_DEVICES

OpenCL.Import

CL_CONTEXT_INTEROP_USER_SYNC

OpenCL.Import

CL_CONTEXT_NUM_DEVICES

OpenCL.Import

CL_CONTEXT_PLATFORM

OpenCL.Import

cl_context_properties

CL_CONTEXT_PROPERTIES

OpenCL.Import

CL_CONTEXT_REFERENCE_COUNT

OpenCL.Import

cl_context_info

CL_CURRENT_DEVICE_FOR_GL_CONTEXT_KHR

OpenCL.GL

* cl_gl_context_info *//

CL_DBL_DIG

OpenCL.Platform

0x1.0p-23f;

CL_DBL_EPSILON

OpenCL.Platform

0x1.0p-1022;

CL_DBL_MANT_DIG

OpenCL.Platform

CL_DBL_MAX

OpenCL.Platform

CL_DBL_MAX_10_EXP

OpenCL.Platform

CL_DBL_MAX_EXP

OpenCL.Platform

CL_DBL_MIN

OpenCL.Platform

0x1.fffffffffffffp1023;

CL_DBL_MIN_10_EXP

OpenCL.Platform

CL_DBL_MIN_EXP

OpenCL.Platform

CL_DBL_RADIX

OpenCL.Platform

CL_DEPTH

OpenCL.Import

CL_DEPTH_STENCIL

OpenCL.Import

CL_DEVICES_FOR_GL_CONTEXT_KHR

OpenCL.GL

CL_DEVICE_ADDRESS_BITS

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_L1_CACHE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_L2_CACHE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_L3_CACHE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_L4_CACHE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_NEXT_PARTITIONABLE

OpenCL.Import

CL_DEVICE_AFFINITY_DOMAIN_NUMA

OpenCL.Import

cl_device_affinity_domain

CL_DEVICE_AVAILABLE

OpenCL.Import

CL_DEVICE_BUILT_IN_KERNELS

OpenCL.Import

CL_DEVICE_COMPILER_AVAILABLE

OpenCL.Import

CL_DEVICE_DOUBLE_FP_CONFIG

OpenCL.Import

CL_DEVICE_ENDIAN_LITTLE

OpenCL.Import

CL_DEVICE_ERROR_CORRECTION_SUPPORT

OpenCL.Import

CL_DEVICE_EXECUTION_CAPABILITIES

OpenCL.Import

CL_DEVICE_EXTENSIONS

OpenCL.Import

CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE

OpenCL.Import

CL_DEVICE_GLOBAL_MEM_CACHE_SIZE

OpenCL.Import

CL_DEVICE_GLOBAL_MEM_CACHE_TYPE

OpenCL.Import

CL_DEVICE_GLOBAL_MEM_SIZE

OpenCL.Import

CL_DEVICE_GLOBAL_VARIABLE_PREFERRED_TOTAL_SIZE

OpenCL.Import

CL_DEVICE_HALF_FP_CONFIG

OpenCL.Import

CL_DEVICE_HOST_UNIFIED_MEMORY

OpenCL.Import

CL_DEVICE_IL_VERSION

OpenCL.Import

CL_DEVICE_IMAGE2D_MAX_HEIGHT

OpenCL.Import

CL_DEVICE_IMAGE2D_MAX_WIDTH

OpenCL.Import

CL_DEVICE_IMAGE3D_MAX_DEPTH

OpenCL.Import

CL_DEVICE_IMAGE3D_MAX_HEIGHT

OpenCL.Import

CL_DEVICE_IMAGE3D_MAX_WIDTH

OpenCL.Import

CL_DEVICE_IMAGE_BASE_ADDRESS_ALIGNMENT

OpenCL.Import

CL_DEVICE_IMAGE_MAX_ARRAY_SIZE

OpenCL.Import

CL_DEVICE_IMAGE_MAX_BUFFER_SIZE

OpenCL.Import

CL_DEVICE_IMAGE_PITCH_ALIGNMENT

OpenCL.Import

CL_DEVICE_IMAGE_SUPPORT

OpenCL.Import

CL_DEVICE_LINKER_AVAILABLE

OpenCL.Import

CL_DEVICE_LOCAL_MEM_SIZE

OpenCL.Import

CL_DEVICE_LOCAL_MEM_TYPE

OpenCL.Import

CL_DEVICE_MAX_CLOCK_FREQUENCY

OpenCL.Import

CL_DEVICE_MAX_COMPUTE_UNITS

OpenCL.Import

CL_DEVICE_MAX_CONSTANT_ARGS

OpenCL.Import

CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE

OpenCL.Import

CL_DEVICE_MAX_GLOBAL_VARIABLE_SIZE

OpenCL.Import

CL_DEVICE_MAX_MEM_ALLOC_SIZE

OpenCL.Import

CL_DEVICE_MAX_NUM_SUB_GROUPS

OpenCL.Import

CL_DEVICE_MAX_ON_DEVICE_EVENTS

OpenCL.Import

CL_DEVICE_MAX_ON_DEVICE_QUEUES

OpenCL.Import

CL_DEVICE_MAX_PARAMETER_SIZE

OpenCL.Import

CL_DEVICE_MAX_PIPE_ARGS

OpenCL.Import

CL_DEVICE_MAX_READ_IMAGE_ARGS

OpenCL.Import

CL_DEVICE_MAX_READ_WRITE_IMAGE_ARGS

OpenCL.Import

CL_DEVICE_MAX_SAMPLERS

OpenCL.Import

CL_DEVICE_MAX_WORK_GROUP_SIZE

OpenCL.Import

CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS

OpenCL.Import

CL_DEVICE_MAX_WORK_ITEM_SIZES

OpenCL.Import

CL_DEVICE_MAX_WRITE_IMAGE_ARGS

OpenCL.Import

CL_DEVICE_MEM_BASE_ADDR_ALIGN

OpenCL.Import

CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE

OpenCL.Import

CL_DEVICE_NAME

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_CHAR

OpenCL.Import

deprecated

CL_DEVICE_NATIVE_VECTOR_WIDTH_DOUBLE

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_FLOAT

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_HALF

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_INT

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_LONG

OpenCL.Import

CL_DEVICE_NATIVE_VECTOR_WIDTH_SHORT

OpenCL.Import

CL_DEVICE_NOT_AVAILABLE

OpenCL.Import

CL_DEVICE_NOT_FOUND

OpenCL.Import

CL_DEVICE_OPENCL_C_VERSION

OpenCL.Import

CL_DEVICE_PARENT_DEVICE

OpenCL.Import

CL_DEVICE_PARTITION_AFFINITY_DOMAIN

OpenCL.Import

CL_DEVICE_PARTITION_BY_AFFINITY_DOMAIN

OpenCL.Import

CL_DEVICE_PARTITION_BY_COUNTS

OpenCL.Import

CL_DEVICE_PARTITION_BY_COUNTS_LIST_END

OpenCL.Import

CL_DEVICE_PARTITION_EQUALLY

OpenCL.Import

cl_device_partition_property

CL_DEVICE_PARTITION_FAILED

OpenCL.Import

CL_DEVICE_PARTITION_MAX_SUB_DEVICES

OpenCL.Import

CL_DEVICE_PARTITION_PROPERTIES

OpenCL.Import

CL_DEVICE_PARTITION_TYPE

OpenCL.Import

CL_DEVICE_PIPE_MAX_ACTIVE_RESERVATIONS

OpenCL.Import

CL_DEVICE_PIPE_MAX_PACKET_SIZE

OpenCL.Import

CL_DEVICE_PLATFORM

OpenCL.Import

CL_DEVICE_PREFERRED_GLOBAL_ATOMIC_ALIGNMENT

OpenCL.Import

CL_DEVICE_PREFERRED_INTEROP_USER_SYNC

OpenCL.Import

CL_DEVICE_PREFERRED_LOCAL_ATOMIC_ALIGNMENT

OpenCL.Import

CL_DEVICE_PREFERRED_PLATFORM_ATOMIC_ALIGNMENT

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_CHAR

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_HALF

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG

OpenCL.Import

CL_DEVICE_PREFERRED_VECTOR_WIDTH_SHORT

OpenCL.Import

CL_DEVICE_PRINTF_BUFFER_SIZE

OpenCL.Import

CL_DEVICE_PROFILE

OpenCL.Import

CL_DEVICE_PROFILING_TIMER_RESOLUTION

OpenCL.Import

CL_DEVICE_QUEUE_ON_DEVICE_MAX_SIZE

OpenCL.Import

CL_DEVICE_QUEUE_ON_DEVICE_PREFERRED_SIZE

OpenCL.Import

CL_DEVICE_QUEUE_ON_DEVICE_PROPERTIES

OpenCL.Import

CL_DEVICE_QUEUE_ON_HOST_PROPERTIES

OpenCL.Import

deprecated

CL_DEVICE_QUEUE_PROPERTIES

OpenCL.Import

CL_DEVICE_REFERENCE_COUNT

OpenCL.Import

CL_DEVICE_SINGLE_FP_CONFIG

OpenCL.Import

CL_DEVICE_SUB_GROUP_INDEPENDENT_FORWARD_PROGRESS

OpenCL.Import

CL_DEVICE_SVM_ATOMICS

OpenCL.Import

CL_DEVICE_SVM_CAPABILITIES

OpenCL.Import

CL_DEVICE_SVM_COARSE_GRAIN_BUFFER

OpenCL.Import

cl_device_svm_capabilities

CL_DEVICE_SVM_FINE_GRAIN_BUFFER

OpenCL.Import

CL_DEVICE_SVM_FINE_GRAIN_SYSTEM

OpenCL.Import

CL_DEVICE_TYPE

OpenCL.Import

cl_device_info

CL_DEVICE_TYPE_ACCELERATOR

OpenCL.Import

CL_DEVICE_TYPE_ALL

OpenCL.Import

CL_DEVICE_TYPE_CPU

OpenCL.Import

CL_DEVICE_TYPE_CUSTOM

OpenCL.Import

CL_DEVICE_TYPE_DEFAULT

OpenCL.Import

cl_device_type - bitfield

CL_DEVICE_TYPE_GPU

OpenCL.Import

CL_DEVICE_VENDOR

OpenCL.Import

CL_DEVICE_VENDOR_ID

OpenCL.Import

CL_DEVICE_VERSION

OpenCL.Import

CL_DRIVER_VERSION

OpenCL.Import

CL_EGL_DISPLAY_KHR

OpenCL.GL

CL_EVENT_COMMAND_EXECUTION_STATUS

OpenCL.Import

CL_EVENT_COMMAND_QUEUE

OpenCL.Import

cl_event_info

CL_EVENT_COMMAND_TYPE

OpenCL.Import

CL_EVENT_CONTEXT

OpenCL.Import

CL_EVENT_REFERENCE_COUNT

OpenCL.Import

CL_EXEC_KERNEL

OpenCL.Import

cl_device_exec_capabilities - bitfield

CL_EXEC_NATIVE_KERNEL

OpenCL.Import

CL_EXEC_STATUS_ERROR_FOR_EVENTS_IN_WAIT_LIST

OpenCL.Import

CL_FALSE

OpenCL.Import

cl_bool

CL_FILTER_LINEAR

OpenCL.Import

CL_FILTER_NEAREST

OpenCL.Import

cl_filter_mode

CL_FLOAT

OpenCL.Import

CL_FLT_DIG

OpenCL.Platform

CL_FLT_EPSILON

OpenCL.Platform

0x1.0p-126f;

CL_FLT_MANT_DIG

OpenCL.Platform

CL_FLT_MAX

OpenCL.Platform

CL_FLT_MAX_10_EXP

OpenCL.Platform

CL_FLT_MAX_EXP

OpenCL.Platform

CL_FLT_MIN

OpenCL.Platform

0x1.fffffep127f;

CL_FLT_MIN_10_EXP

OpenCL.Platform

CL_FLT_MIN_EXP

OpenCL.Platform

CL_FLT_RADIX

OpenCL.Platform

CL_FP_CORRECTLY_ROUNDED_DIVIDE_SQRT

OpenCL.Import

CL_FP_DENORM

OpenCL.Import

cl_device_fp_config - bitfield

CL_FP_FMA

OpenCL.Import

CL_FP_INF_NAN

OpenCL.Import

CL_FP_ROUND_TO_INF

OpenCL.Import

CL_FP_ROUND_TO_NEAREST

OpenCL.Import

CL_FP_ROUND_TO_ZERO

OpenCL.Import

CL_FP_SOFT_FLOAT

OpenCL.Import

CL_GLOBAL

OpenCL.Import

CL_GLX_DISPLAY_KHR

OpenCL.GL

CL_GL_CONTEXT_KHR

OpenCL.GL

* Additional cl_context_properties *//

CL_GL_MIPMAP_LEVEL

OpenCL.GL

CL_GL_NUM_SAMPLES

OpenCL.GL

CL_GL_OBJECT_BUFFER

OpenCL.GL

* cl_gl_object_type = 0x2000 - 0x200F enum values are currently taken *//

CL_GL_OBJECT_RENDERBUFFER

OpenCL.GL

CL_GL_OBJECT_TEXTURE1D

OpenCL.GL

CL_GL_OBJECT_TEXTURE1D_ARRAY

OpenCL.GL

CL_GL_OBJECT_TEXTURE2D

OpenCL.GL

CL_GL_OBJECT_TEXTURE2D_ARRAY

OpenCL.GL

CL_GL_OBJECT_TEXTURE3D

OpenCL.GL

CL_GL_OBJECT_TEXTURE_BUFFER

OpenCL.GL

CL_GL_TEXTURE_TARGET

OpenCL.GL

* cl_gl_texture_info *//

CL_HALF_FLOAT

OpenCL.Import

CL_HUGE_VAL

OpenCL.Platform

CL_HUGE_VALF

OpenCL.Platform

(CL_INFINITY - CL_INFINITY);

CL_IMAGE_ARRAY_SIZE

OpenCL.Import

CL_IMAGE_BUFFER

OpenCL.Import

CL_IMAGE_DEPTH

OpenCL.Import

CL_IMAGE_ELEMENT_SIZE

OpenCL.Import

CL_IMAGE_FORMAT

OpenCL.Import

cl_image_info

CL_IMAGE_FORMAT_MISMATCH

OpenCL.Import

CL_IMAGE_FORMAT_NOT_SUPPORTED

OpenCL.Import

CL_IMAGE_HEIGHT

OpenCL.Import

CL_IMAGE_NUM_MIP_LEVELS

OpenCL.Import

CL_IMAGE_NUM_SAMPLES

OpenCL.Import

CL_IMAGE_ROW_PITCH

OpenCL.Import

CL_IMAGE_SLICE_PITCH

OpenCL.Import

CL_IMAGE_WIDTH

OpenCL.Import

CL_INFINITY

OpenCL.Platform

CL_INTENSITY

OpenCL.Import

CL_INT_MAX

OpenCL.Platform

CL_INT_MIN

OpenCL.Platform

CL_INVALID_ARG_INDEX

OpenCL.Import

CL_INVALID_ARG_SIZE

OpenCL.Import

CL_INVALID_ARG_VALUE

OpenCL.Import

CL_INVALID_BINARY

OpenCL.Import

CL_INVALID_BUFFER_SIZE

OpenCL.Import

CL_INVALID_BUILD_OPTIONS

OpenCL.Import

CL_INVALID_COMMAND_QUEUE

OpenCL.Import

CL_INVALID_COMPILER_OPTIONS

OpenCL.Import

CL_INVALID_CONTEXT

OpenCL.Import

CL_INVALID_DEVICE

OpenCL.Import

CL_INVALID_DEVICE_PARTITION_COUNT

OpenCL.Import

CL_INVALID_DEVICE_QUEUE

OpenCL.Import

CL_INVALID_DEVICE_TYPE

OpenCL.Import

CL_INVALID_EVENT

OpenCL.Import

CL_INVALID_EVENT_WAIT_LIST

OpenCL.Import

CL_INVALID_GLOBAL_OFFSET

OpenCL.Import

CL_INVALID_GLOBAL_WORK_SIZE

OpenCL.Import

CL_INVALID_GL_OBJECT

OpenCL.Import

CL_INVALID_GL_SHAREGROUP_REFERENCE_KHR

OpenCL.GL

* Additional Error Codes *//

CL_INVALID_HOST_PTR

OpenCL.Import

CL_INVALID_IMAGE_DESCRIPTOR

OpenCL.Import

CL_INVALID_IMAGE_FORMAT_DESCRIPTOR

OpenCL.Import

CL_INVALID_IMAGE_SIZE

OpenCL.Import

CL_INVALID_KERNEL

OpenCL.Import

CL_INVALID_KERNEL_ARGS

OpenCL.Import

CL_INVALID_KERNEL_DEFINITION

OpenCL.Import

CL_INVALID_KERNEL_NAME

OpenCL.Import

CL_INVALID_LINKER_OPTIONS

OpenCL.Import

CL_INVALID_MEM_OBJECT

OpenCL.Import

CL_INVALID_MIP_LEVEL

OpenCL.Import

CL_INVALID_OPERATION

OpenCL.Import

CL_INVALID_PIPE_SIZE

OpenCL.Import

CL_INVALID_PLATFORM

OpenCL.Import

CL_INVALID_PROGRAM

OpenCL.Import

CL_INVALID_PROGRAM_EXECUTABLE

OpenCL.Import

CL_INVALID_PROPERTY

OpenCL.Import

CL_INVALID_QUEUE_PROPERTIES

OpenCL.Import

CL_INVALID_SAMPLER

OpenCL.Import

CL_INVALID_SPEC_ID

OpenCL.Import

CL_INVALID_VALUE

OpenCL.Import

CL_INVALID_WORK_DIMENSION

OpenCL.Import

CL_INVALID_WORK_GROUP_SIZE

OpenCL.Import

CL_INVALID_WORK_ITEM_SIZE

OpenCL.Import

CL_KERNEL_ARG_ACCESS_NONE

OpenCL.Import

CL_KERNEL_ARG_ACCESS_QUALIFIER

OpenCL.Import

CL_KERNEL_ARG_ACCESS_READ_ONLY

OpenCL.Import

cl_kernel_arg_access_qualifier

CL_KERNEL_ARG_ACCESS_READ_WRITE

OpenCL.Import

CL_KERNEL_ARG_ACCESS_WRITE_ONLY

OpenCL.Import

CL_KERNEL_ARG_ADDRESS_CONSTANT

OpenCL.Import

CL_KERNEL_ARG_ADDRESS_GLOBAL

OpenCL.Import

cl_kernel_arg_address_qualifier

CL_KERNEL_ARG_ADDRESS_LOCAL

OpenCL.Import

CL_KERNEL_ARG_ADDRESS_PRIVATE

OpenCL.Import

CL_KERNEL_ARG_ADDRESS_QUALIFIER

OpenCL.Import

cl_kernel_arg_info

CL_KERNEL_ARG_INFO_NOT_AVAILABLE

OpenCL.Import

CL_KERNEL_ARG_NAME

OpenCL.Import

CL_KERNEL_ARG_TYPE_CONST

OpenCL.Import

CL_KERNEL_ARG_TYPE_NAME

OpenCL.Import

CL_KERNEL_ARG_TYPE_NONE

OpenCL.Import

cl_kernel_arg_type_qualifer

CL_KERNEL_ARG_TYPE_PIPE

OpenCL.Import

CL_KERNEL_ARG_TYPE_QUALIFIER

OpenCL.Import

CL_KERNEL_ARG_TYPE_RESTRICT

OpenCL.Import

CL_KERNEL_ARG_TYPE_VOLATILE

OpenCL.Import

CL_KERNEL_ATTRIBUTES

OpenCL.Import

CL_KERNEL_COMPILE_NUM_SUB_GROUPS

OpenCL.Import

CL_KERNEL_COMPILE_WORK_GROUP_SIZE

OpenCL.Import

CL_KERNEL_CONTEXT

OpenCL.Import

CL_KERNEL_EXEC_INFO_SVM_FINE_GRAIN_SYSTEM

OpenCL.Import

CL_KERNEL_EXEC_INFO_SVM_PTRS

OpenCL.Import

cl_kernel_exec_info

CL_KERNEL_FUNCTION_NAME

OpenCL.Import

cl_kernel_info

CL_KERNEL_GLOBAL_WORK_SIZE

OpenCL.Import

CL_KERNEL_LOCAL_MEM_SIZE

OpenCL.Import

CL_KERNEL_LOCAL_SIZE_FOR_SUB_GROUP_COUNT

OpenCL.Import

CL_KERNEL_MAX_NUM_SUB_GROUPS

OpenCL.Import

CL_KERNEL_MAX_SUB_GROUP_SIZE_FOR_NDRANGE

OpenCL.Import

cl_kernel_sub_group_info

CL_KERNEL_NUM_ARGS

OpenCL.Import

CL_KERNEL_PREFERRED_WORK_GROUP_SIZE_MULTIPLE

OpenCL.Import

CL_KERNEL_PRIVATE_MEM_SIZE

OpenCL.Import

CL_KERNEL_PROGRAM

OpenCL.Import

CL_KERNEL_REFERENCE_COUNT

OpenCL.Import

CL_KERNEL_SUB_GROUP_COUNT_FOR_NDRANGE

OpenCL.Import

CL_KERNEL_WORK_GROUP_SIZE

OpenCL.Import

cl_kernel_work_group_info

cl_khr_gl_sharing

OpenCL.GL

* cl_khr_gl_sharing extension *//

CL_LINKER_NOT_AVAILABLE

OpenCL.Import

CL_LINK_PROGRAM_FAILURE

OpenCL.Import

CL_LOCAL

OpenCL.Import

cl_device_local_mem_type

CL_LONG_MAX

OpenCL.Platform

CL_LONG_MIN

OpenCL.Platform

CL_LUMINANCE

OpenCL.Import

CL_MAP_FAILURE

OpenCL.Import

CL_MAP_READ

OpenCL.Import

cl_map_flags - bitfield

CL_MAP_WRITE

OpenCL.Import

CL_MAP_WRITE_INVALIDATE_REGION

OpenCL.Import

CL_MAXFLOAT

OpenCL.Platform

CL_MAX_SIZE_RESTRICTION_EXCEEDED

OpenCL.Import

CL_MEM_ALLOC_HOST_PTR

OpenCL.Import

CL_MEM_ASSOCIATED_MEMOBJECT

OpenCL.Import

CL_MEM_CONTEXT

OpenCL.Import

CL_MEM_COPY_HOST_PTR

OpenCL.Import

CL_MEM_COPY_OVERLAP

OpenCL.Import

CL_MEM_FLAGS

OpenCL.Import

CL_MEM_HOST_NO_ACCESS

OpenCL.Import

CL_MEM_HOST_PTR

OpenCL.Import

CL_MEM_HOST_READ_ONLY

OpenCL.Import

CL_MEM_HOST_WRITE_ONLY

OpenCL.Import

reserved (1 shl 6);

CL_MEM_KERNEL_READ_AND_WRITE

OpenCL.Import

used by cl_svm_mem_flags only

CL_MEM_MAP_COUNT

OpenCL.Import

CL_MEM_OBJECT_ALLOCATION_FAILURE

OpenCL.Import

CL_MEM_OBJECT_BUFFER

OpenCL.Import

cl_mem_object_type

CL_MEM_OBJECT_IMAGE1D

OpenCL.Import

CL_MEM_OBJECT_IMAGE1D_ARRAY

OpenCL.Import

CL_MEM_OBJECT_IMAGE1D_BUFFER

OpenCL.Import

CL_MEM_OBJECT_IMAGE2D

OpenCL.Import

CL_MEM_OBJECT_IMAGE2D_ARRAY

OpenCL.Import

CL_MEM_OBJECT_IMAGE3D

OpenCL.Import

CL_MEM_OBJECT_PIPE

OpenCL.Import

CL_MEM_OFFSET

OpenCL.Import

CL_MEM_READ_ONLY

OpenCL.Import

CL_MEM_READ_WRITE

OpenCL.Import

cl_mem_flags - bitfield

CL_MEM_REFERENCE_COUNT

OpenCL.Import

CL_MEM_SIZE

OpenCL.Import

CL_MEM_SVM_ATOMICS

OpenCL.Import

used by cl_svm_mem_flags only

CL_MEM_SVM_FINE_GRAIN_BUFFER

OpenCL.Import

CL_MEM_TYPE

OpenCL.Import

cl_mem_info

CL_MEM_USES_SVM_POINTER

OpenCL.Import

CL_MEM_USE_HOST_PTR

OpenCL.Import

CL_MEM_WRITE_ONLY

OpenCL.Import

CL_MIGRATE_MEM_OBJECT_CONTENT_UNDEFINED

OpenCL.Import

CL_MIGRATE_MEM_OBJECT_HOST

OpenCL.Import

cl_mem_migration_flags - bitfield

CL_MISALIGNED_SUB_BUFFER_OFFSET

OpenCL.Import

CL_M_1_PI

OpenCL.Platform

CL_M_1_PI_F

OpenCL.Platform

CL_M_2_PI

OpenCL.Platform

CL_M_2_PI_F

OpenCL.Platform

CL_M_2_SQRTPI

OpenCL.Platform

CL_M_2_SQRTPI_F

OpenCL.Platform

CL_M_E

OpenCL.Platform

0x1.0p-52;

CL_M_E_F

OpenCL.Platform

CL_M_LN10

OpenCL.Platform

CL_M_LN10_F

OpenCL.Platform

CL_M_LN2

OpenCL.Platform

CL_M_LN2_F

OpenCL.Platform

CL_M_LOG10E

OpenCL.Platform

CL_M_LOG10E_F

OpenCL.Platform

CL_M_LOG2E

OpenCL.Platform

CL_M_LOG2E_F

OpenCL.Platform

CL_M_PI

OpenCL.Platform

CL_M_PI_2

OpenCL.Platform

CL_M_PI_2_F

OpenCL.Platform

CL_M_PI_4

OpenCL.Platform

CL_M_PI_4_F

OpenCL.Platform

CL_M_PI_F

OpenCL.Platform

CL_M_SQRT1_2

OpenCL.Platform

CL_M_SQRT1_2_F

OpenCL.Platform

CL_M_SQRT2

OpenCL.Platform

CL_M_SQRT2_F

OpenCL.Platform

CL_NAN

OpenCL.Platform

CL_NONE

OpenCL.Import

cl_device_mem_cache_type

CL_NON_BLOCKING

OpenCL.Import

CL_OUT_OF_HOST_MEMORY

OpenCL.Import

CL_OUT_OF_RESOURCES

OpenCL.Import

CL_PIPE_MAX_PACKETS

OpenCL.Import

CL_PIPE_PACKET_SIZE

OpenCL.Import

cl_pipe_info

CL_PLATFORM_EXTENSIONS

OpenCL.Import

CL_PLATFORM_HOST_TIMER_RESOLUTION

OpenCL.Import

CL_PLATFORM_NAME

OpenCL.Import

CL_PLATFORM_PROFILE

OpenCL.Import

cl_platform_info

CL_PLATFORM_VENDOR

OpenCL.Import

CL_PLATFORM_VERSION

OpenCL.Import

CL_PROFILING_COMMAND_COMPLETE

OpenCL.Import

CL_PROFILING_COMMAND_END

OpenCL.Import

CL_PROFILING_COMMAND_QUEUED

OpenCL.Import

cl_profiling_info

CL_PROFILING_COMMAND_START

OpenCL.Import

CL_PROFILING_COMMAND_SUBMIT

OpenCL.Import

CL_PROFILING_INFO_NOT_AVAILABLE

OpenCL.Import

CL_PROGBRAM_BINARY_TYPE_NONE

OpenCL.Import

cl_program_binary_type

CL_PROGRAM_BINARIES

OpenCL.Import

CL_PROGRAM_BINARY_SIZES

OpenCL.Import

CL_PROGRAM_BINARY_TYPE

OpenCL.Import

CL_PROGRAM_BINARY_TYPE_COMPILED_OBJECT

OpenCL.Import

CL_PROGRAM_BINARY_TYPE_EXECUTABLE

OpenCL.Import

CL_PROGRAM_BINARY_TYPE_LIBRARY

OpenCL.Import

CL_PROGRAM_BUILD_GLOBAL_VARIABLE_TOTAL_SIZE

OpenCL.Import

CL_PROGRAM_BUILD_LOG

OpenCL.Import

CL_PROGRAM_BUILD_OPTIONS

OpenCL.Import

CL_PROGRAM_BUILD_STATUS

OpenCL.Import

cl_program_build_info

CL_PROGRAM_CONTEXT

OpenCL.Import

CL_PROGRAM_DEVICES

OpenCL.Import

CL_PROGRAM_IL

OpenCL.Import

CL_PROGRAM_KERNEL_NAMES

OpenCL.Import

CL_PROGRAM_NUM_DEVICES

OpenCL.Import

CL_PROGRAM_NUM_KERNELS

OpenCL.Import

CL_PROGRAM_REFERENCE_COUNT

OpenCL.Import

cl_program_info

CL_PROGRAM_SCOPE_GLOBAL_CTORS_PRESENT

OpenCL.Import

CL_PROGRAM_SCOPE_GLOBAL_DTORS_PRESENT

OpenCL.Import

CL_PROGRAM_SOURCE

OpenCL.Import

CL_QUEUED

OpenCL.Import

CL_QUEUE_CONTEXT

OpenCL.Import

cl_command_queue_info

CL_QUEUE_DEVICE

OpenCL.Import

CL_QUEUE_DEVICE_DEFAULT

OpenCL.Import

CL_QUEUE_ON_DEVICE

OpenCL.Import

CL_QUEUE_ON_DEVICE_DEFAULT

OpenCL.Import

CL_QUEUE_OUT_OF_ORDER_EXEC_MODE_ENABLE

OpenCL.Import

cl_command_queue_properties - bitfield

CL_QUEUE_PROFILING_ENABLE

OpenCL.Import

CL_QUEUE_PROPERTIES

OpenCL.Import

CL_QUEUE_REFERENCE_COUNT

OpenCL.Import

CL_QUEUE_SIZE

OpenCL.Import

CL_R

OpenCL.Import

cl_channel_order

CL_RA

OpenCL.Import

CL_READ_ONLY_CACHE

OpenCL.Import

CL_READ_WRITE_CACHE

OpenCL.Import

CL_RG

OpenCL.Import

CL_RGB

OpenCL.Import

CL_RGBA

OpenCL.Import

CL_RGBx

OpenCL.Import

CL_RGx

OpenCL.Import

CL_RUNNING

OpenCL.Import

CL_Rx

OpenCL.Import

CL_SAMPLER_ADDRESSING_MODE

OpenCL.Import

CL_SAMPLER_CONTEXT

OpenCL.Import

CL_SAMPLER_FILTER_MODE

OpenCL.Import

CL_SAMPLER_LOD_MAX

OpenCL.Import

CL_SAMPLER_LOD_MIN

OpenCL.Import

CL_SAMPLER_MIP_FILTER_MODE

OpenCL.Import

CL_SAMPLER_NORMALIZED_COORDS

OpenCL.Import

CL_SAMPLER_REFERENCE_COUNT

OpenCL.Import

cl_sampler_info

CL_sBGRA

OpenCL.Import

CL_SCHAR_MAX

OpenCL.Platform

CL_SCHAR_MIN

OpenCL.Platform

CL_SHRT_MAX

OpenCL.Platform

CL_SHRT_MIN

OpenCL.Platform

CL_SIGNED_INT16

OpenCL.Import

CL_SIGNED_INT32

OpenCL.Import

CL_SIGNED_INT8

OpenCL.Import

CL_SNORM_INT16

OpenCL.Import

CL_SNORM_INT8

OpenCL.Import

* cl_channel_type *//

CL_sRGB

OpenCL.Import

CL_sRGBA

OpenCL.Import

CL_sRGBx

OpenCL.Import

CL_SUBMITTED

OpenCL.Import

CL_SUCCESS

OpenCL.Import

Error Codes

CL_TRUE

OpenCL.Import

CL_UCHAR_MAX

OpenCL.Platform

CL_UINT_MAX

OpenCL.Platform

CL_ULONG_MAX

OpenCL.Platform

CL_UNORM_INT16

OpenCL.Import

CL_UNORM_INT24

OpenCL.Import

CL_UNORM_INT8

OpenCL.Import

CL_UNORM_INT_101010

OpenCL.Import

CL_UNORM_INT_101010_2

OpenCL.Import

CL_UNORM_SHORT_555

OpenCL.Import

CL_UNORM_SHORT_565

OpenCL.Import

CL_UNSIGNED_INT16

OpenCL.Import

CL_UNSIGNED_INT32

OpenCL.Import

CL_UNSIGNED_INT8

OpenCL.Import

CL_USHRT_MAX

OpenCL.Platform

CL_VERSION_1_0

OpenCL.Import

OpenCL Version

CL_VERSION_1_1

OpenCL.Import

CL_VERSION_1_2

OpenCL.Import

CL_VERSION_2_0

OpenCL.Import

CL_VERSION_2_1

OpenCL.Import

CL_VERSION_2_2

OpenCL.Import

CL_WGL_HDC_KHR

OpenCL.GL

CMAGIC

Formats.m3DSConst

cMarsOrbitalElements

GLS.SkyDome

(AU) heliocentric mars elements

cMaxArray

GLScene.VectorGeometry

cMaxContacts

GLS.ODERagdoll

cMaxVerts

GLS.Trail

cMercuryOrbitalElements

GLS.SkyDome

(Earth radii) heliocentric mercury elements

cMeshHexahedron

GLS.MeshBuilder

Hexahedron arrays for 6 parts

cMeshModeToGLEnum

GLS.Mesh

cMeshSphere

GLS.MeshBuilder

Front Quad Back Quad Top Quad Bottom Quad Right Quad Left Quad Sphere arrays for parts with 2 hemispheres

cMoonOrbitalElements

GLS.SkyDome

(AU) geocentric moon elements

CmtNX

GLS.Texture

CmtNY

GLS.Texture

CmtNZ

GLS.Texture

CmtPX

GLS.Texture

CmtPY

GLS.Texture

CmtPZ

GLS.Texture

cNeptuneOrbitalElements

GLS.SkyDome

(AU) heliocentric neptune elements

COctree_GROW_GRAVY

GLS.SpacePartition

COctree_LEAF_TRHESHOLD

GLS.SpacePartition

COctree_MAX_TREE_DEPTH

GLS.SpacePartition

CollideAndSlide

GLS.EllipseCollision

CollideWithWorld

GLS.EllipseCollision

ColorFMax3DS

Formats.m3DSConst

minimum color value in a channel

ColorFMin3DS

Formats.m3DSConst

maximum shadow map size COLOR_F

COLOR_24

Formats.m3DSConst

COLOR_F

Formats.m3DSConst

ColTrackTagMax3DS

Formats.m3DSConst

Minimum color value

ColTrackTagMin3DS

Formats.m3DSConst

Minimum number of keys in a track COL_TRACK_TAG_KEY

COL_TRACK_TAG

Formats.m3DSConst

COL_TRACK_TAG_KEY

Formats.m3DSConst

CombineVector

GLScene.VectorGeometry

CombineVector

GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CombineVector

GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CombineVector

GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CompareInteger

GLScene.RedBlackTree

ComponentNameString

gnugettext

CompressedInternalFormatToOpenGL

GLScene.TextureFormat

Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format

comptypeDIB

Formats.VFW

== AVISave routines and structures ==========================================

ComputeOrbitalElements

GLS.SkyDome

Compute orbital elements for given Julian day.

ComputePlanetPosition

GLS.SkyDome

ComputePlanetPosition

GLS.SkyDome

Compute the planet position for given Julian day (in AU).

ConeContainsBSphere

GLS.SpacePartition

Determines to which extent one Cone contains an BSphere

cOneHalf

GLScene.VectorGeometry

CONSOLE_MAX_COMMANDS

GLS.Console

ConstArrayToString

GLScene.Logger

CONTACTS_UNIMPORTANT

ODE.Import

Just generate any contacts (disables any contact refining).

Container

Formats.m3DSConst

CONTROLCALLBACK_CAPTURING

Formats.VFW

Waiting to start capture

CONTROLCALLBACK_PREROLL

Formats.VFW

– CapControlCallback states ————————————————

ConvertDoubleToString

PasDblStrUtils

ConvertdVector3ToAffineVector

GLS.ODEUtils

ConvertdVector3ToAffineVector

GLS.ODEUtils

ConvertdVector3ToVector3f

GLS.ODEUtils

ConvertdVector3ToVector3f

GLS.ODEUtils

Converting between ODE and GLScene formats

ConvertdVector3ToVector4f

GLS.ODEUtils

ConvertdVector3ToVector4f

GLS.ODEUtils

ConvertFansToList

GLS.MeshUtils

ConvertImage

GLS.ImageUtils

ConvertIndexedListToList

GLS.MeshUtils

Expands an indexed structure into a non-indexed structure.

ConvertRotation

GLScene.VectorGeometry

Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians)

ConvertStringToDouble

PasDblStrUtils

ConvertStringToDouble

PasDblStrUtils

ConvertStripToList

GLS.MeshUtils

ConvertStripToList

GLS.MeshUtils

ConvertStripToList

GLS.MeshUtils

ConvertStripToList

GLS.MeshUtils

Converts a triangle strips into a triangle list. Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.

ConvertVector3fTodVector3

GLS.ODEUtils

Converting between GLScene and ODE formats

ConvertVector3fToPdVector3

GLS.ODEUtils

ConvertVector4fTodVector3

GLS.ODEUtils

ConvertVector4fToPdVector3

GLS.ODEUtils

CopyBodyFromCube

GLS.ODEUtils

CopyCubeSizeFromBox

GLS.ODEUtils

CopyPosFromGeomToGL

GLS.ODEUtils

CopyScreentoTexture

GLSL.CustomShader

CopyScreentoTexture2

GLSL.CustomShader

Cosine_Interpolate

GLS.Perlin

does a cosine interpolation

cPERLIN_TABLE_SIZE

GLS.PerlinPFX

cPFXGranularity

GLS.ParticleFX

number of distance regions

cPFXNbRegions

GLS.ParticleFX

cPI

GLScene.VectorGeometry

cPIdiv180

GLScene.VectorGeometry

cPIdiv2

GLScene.VectorGeometry

cPIdiv4

GLScene.VectorGeometry

cPlutoOrbitalElements

GLS.SkyDome

(AU) heliocentric pluto elements

CreateAffineRotationMatrix

GLScene.VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.

CreateBodyFromCube

GLS.ODEUtils

CreateBox

PhysX.Import

CreateCylinder

PhysX.Import

CreateEditableStream

Formats.VFW

– Editing routines ———————————————————

CreateGeomFromCube

GLS.ODEUtils

CreateGraphicFromFile

GLS.Texture

CreateGroundPlane

PhysX.Import

CreateLookAtMatrix

GLScene.VectorGeometry

CreateMatrixFromFrustum

GLScene.VectorGeometry

CreateObjectSpaceNormalMap

GLS.BumpmapHDS

CreateODEPlaneFromGLPlane

GLS.ODEUtils

CreateOrthoMatrix

GLScene.VectorGeometry

CreatePerspectiveMatrix

GLScene.VectorGeometry

CreatePickMatrix

GLScene.VectorGeometry

CreateResourceStream

GLS.ApplicationFileIO

CreateRotationMatrix

GLScene.VectorGeometry

CreateRotationMatrix

GLScene.VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.

CreateRotationMatrixX

GLScene.VectorGeometry

CreateRotationMatrixX

GLScene.VectorGeometry

Creates matrix for rotation about x-axis (angle in rad)

CreateRotationMatrixY

GLScene.VectorGeometry

CreateRotationMatrixY

GLScene.VectorGeometry

Creates matrix for rotation about y-axis (angle in rad)

CreateRotationMatrixZ

GLScene.VectorGeometry

CreateRotationMatrixZ

GLScene.VectorGeometry

Creates matrix for rotation about z-axis (angle in rad)

CreateScaleAndTranslationMatrix

GLScene.VectorGeometry

Creates a scale+translation matrix. Scale is applied BEFORE applying offset

CreateScaleMatrix

GLScene.VectorGeometry

Creates scale matrix

CreateScaleMatrix

GLScene.VectorGeometry

Creates scale matrix

CreateSphere

PhysX.Import

CreateTangentSpaceNormalMap

GLS.BumpmapHDS

CreateTempWnd

GLS.WindowsContext

CreateTranslationMatrix

GLScene.VectorGeometry

Creates translation matrix

CreateTranslationMatrix

GLScene.VectorGeometry

Creates translation matrix

CreateTriMeshFromBaseMesh

GLS.ODEUtils

This method requires you to manually deallocate vertices and indices when you're done with the trimesh

CreateVerletPlaneFromGLPlane

GLS.VerletTypes

cSaturnOrbitalElements

GLS.SkyDome

(AU) heliocentric saturn elements

CSG_Operation

GLS.MeshCSG

cSunOrbitalElements

GLS.SkyDome

geocentric sun elements

cTilesHashSize

GLS.TerrainRenderer

cuArray3DCreate

CUDA.Import

cuArray3DGetDescriptor

CUDA.Import

cuArrayCreate

CUDA.Import

cuArrayDestroy

CUDA.Import

cuArrayGetDescriptor

CUDA.Import

CubeWireframeBuildList

GLS.Objects

Issues for a unit-size cube stippled wireframe

Cubic_Interpolate

GLS.Perlin

does a cubic interpolation

Cubic_Interpolate_Strip

GLS.Perlin

cubic interpolate 4 strips into one...

cuCtxAttach

CUDA.Import

cuCtxCreate

CUDA.Import

cuCtxDestroy

CUDA.Import

cuCtxDetach

CUDA.Import

cuCtxGetDevice

CUDA.Import

cuCtxPopCurrent

CUDA.Import

cuCtxPushCurrent

CUDA.Import

cuCtxSynchronize

CUDA.Import

CUDAAPIDLL

CUDA.Import

cudaBindTexture

CUDA.Runtime

*****************************************************************************

cudaBindTexture2D

CUDA.Runtime

cudaBindTextureToArray

CUDA.Runtime

cudaChooseDevice

CUDA.Runtime

cudaConfigureCall

CUDA.Runtime

***************************************************************************** * * * ****************************************************************************

CUDAContextManager

GLS.CUDA.Context

Static class of CUDA contexts manager

cudaCreateChannelDesc

CUDA.Runtime

cudaDriverGetVersion

CUDA.Runtime

cudaError_t

CUDA.Runtime

+//DEVICE_BUILTIN*/

cudaEventCreate

CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************

cudaEventCreateWithFlags

CUDA.Runtime

cudaEventDestroy

CUDA.Runtime

cudaEventElapsedTime

CUDA.Runtime

cudaEventQuery

CUDA.Runtime

cudaEventRecord

CUDA.Runtime

cudaEventSynchronize

CUDA.Runtime

cudaEvent_t

CUDA.Runtime

+//DEVICE_BUILTIN*/

cudaFree

CUDA.Runtime

cudaFreeArray

CUDA.Runtime

cudaFreeHost

CUDA.Runtime

cudaFuncGetAttributes

CUDA.Runtime

cudaFuncSetCacheConfig

CUDA.Runtime

cudaGetChannelDesc

CUDA.Runtime

cudaGetDevice

CUDA.Runtime

cudaGetDeviceCount

CUDA.Runtime

=*****************************************************************************

cudaGetDeviceProperties

CUDA.Runtime

cudaGetErrorString

CUDA.Runtime

cudaGetLastError

CUDA.Runtime

=*******************************************************************************/

cudaGetLastErrorString

CUDA.Runtime

cudaGetSymbolAddress

CUDA.Runtime

**************************************************************************** * * * * * * ****************************************************************************

cudaGetSymbolSize

CUDA.Runtime

cudaGetTextureAlignmentOffset

CUDA.Runtime

cudaGetTextureReference

CUDA.Runtime

cudaGLMapBufferObject

CUDA.Runtime

cudaGLMapBufferObjectAsync

CUDA.Runtime

cudaGLRegisterBufferObject

CUDA.Runtime

cudaGLSetBufferObjectMapFlags

CUDA.Runtime

cudaGLSetGLDevice

CUDA.Runtime

=*******************************************************************************/

cudaGLUnmapBufferObject

CUDA.Runtime

cudaGLUnmapBufferObjectAsync

CUDA.Runtime

cudaGLUnregisterBufferObject

CUDA.Runtime

cudaGraphicsGLRegisterBuffer

CUDA.Runtime

cudaGraphicsGLRegisterImage

CUDA.Runtime

cudaGraphicsMapResources

CUDA.Runtime

cudaGraphicsResourceGetMappedPointer

CUDA.Runtime

cudaGraphicsResourceSetMapFlags

CUDA.Runtime

cudaGraphicsSubResourceGetMappedArray

CUDA.Runtime

cudaGraphicsUnmapResources

CUDA.Runtime

cudaGraphicsUnregisterResource

CUDA.Runtime

cudaHostAlloc

CUDA.Runtime

cudaHostGetDevicePointer

CUDA.Runtime

cudaHostGetFlags

CUDA.Runtime

cudaLaunch

CUDA.Runtime

cudaMalloc

CUDA.Runtime

cudaMalloc3D

CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************

cudaMalloc3DArray

CUDA.Runtime

cudaMallocArray

CUDA.Runtime

cudaMallocHost

CUDA.Runtime

cudaMallocPitch

CUDA.Runtime

cudaMemcpy

CUDA.Runtime

cudaMemcpy2D

CUDA.Runtime

cudaMemcpy2DArrayToArray

CUDA.Runtime

cudaMemcpy2DAsync

CUDA.Runtime

cudaMemcpy2DFromArray

CUDA.Runtime

cudaMemcpy2DFromArrayAsync

CUDA.Runtime

cudaMemcpy2DToArray

CUDA.Runtime

cudaMemcpy2DToArrayAsync

CUDA.Runtime

cudaMemcpy3D

CUDA.Runtime

cudaMemcpy3DAsync

CUDA.Runtime

cudaMemcpyArrayToArray

CUDA.Runtime

cudaMemcpyAsync

CUDA.Runtime

=*****************************************************************************

cudaMemcpyFromArray

CUDA.Runtime

cudaMemcpyFromArrayAsync

CUDA.Runtime

cudaMemcpyFromSymbol

CUDA.Runtime

cudaMemcpyFromSymbolAsync

CUDA.Runtime

cudaMemcpyToArray

CUDA.Runtime

cudaMemcpyToArrayAsync

CUDA.Runtime

cudaMemcpyToSymbol

CUDA.Runtime

cudaMemcpyToSymbolAsync

CUDA.Runtime

cudaMemGetInfo

CUDA.Runtime

cudaMemset

CUDA.Runtime

***************************************************************************** * * * * * * ****************************************************************************

cudaMemset2D

CUDA.Runtime

cudaMemset3D

CUDA.Runtime

CUDARTDLLNAMES

CUDA.Runtime

CUDART_2_OVER_PI

CUDA.Runtime

CUDART_2_OVER_PI_F

CUDA.Runtime

CUDART_3PIO4

CUDA.Runtime

CUDART_3PIO4_F

CUDA.Runtime

CUDART_INF

CUDA.Runtime

double precision constants */

CUDART_INF_F

CUDA.Runtime

single precision constants

CUDART_L2E

CUDA.Runtime

CUDART_L2E_F

CUDA.Runtime

CUDART_L2E_HI

CUDA.Runtime

CUDART_L2E_LO

CUDA.Runtime

CUDART_L2T

CUDA.Runtime

CUDART_L2T_F

CUDA.Runtime

CUDART_LG2

CUDA.Runtime

CUDART_LG2_F

CUDA.Runtime

CUDART_LG2_HI

CUDA.Runtime

CUDART_LG2_LO

CUDA.Runtime

CUDART_LG2_X_1024

CUDA.Runtime

CUDART_LG2_X_1075

CUDA.Runtime

CUDART_LGE

CUDA.Runtime

CUDART_LGE_F

CUDA.Runtime

CUDART_LGE_HI

CUDA.Runtime

CUDART_LGE_LO

CUDA.Runtime

CUDART_LN2

CUDA.Runtime

CUDART_LN2_F

CUDA.Runtime

CUDART_LN2_HI

CUDA.Runtime

CUDART_LN2_LO

CUDA.Runtime

CUDART_LN2_X_1024

CUDA.Runtime

CUDART_LN2_X_1025

CUDA.Runtime

CUDART_LN2_X_1075

CUDA.Runtime

CUDART_LNPI

CUDA.Runtime

CUDART_LNPI_F

CUDA.Runtime

CUDART_LNT

CUDA.Runtime

CUDART_LNT_F

CUDA.Runtime

CUDART_LNT_HI

CUDA.Runtime

CUDART_LNT_LO

CUDA.Runtime

CUDART_MAX_NORMAL_F

CUDA.Runtime

CUDART_MIN_DENORM

CUDA.Runtime

CUDART_MIN_DENORM_F

CUDA.Runtime

CUDART_NAN

CUDA.Runtime

CUDART_NAN_F

CUDA.Runtime

CUDART_NEG_ZERO

CUDA.Runtime

CUDART_NEG_ZERO_F

CUDA.Runtime

CUDART_NORM_HUGE_F

CUDA.Runtime

CUDART_ONE

CUDA.Runtime

CUDART_ONE_F

CUDA.Runtime

CUDART_PI

CUDA.Runtime

CUDART_PIO2

CUDA.Runtime

CUDART_PIO2_F

CUDA.Runtime

CUDART_PIO2_HI

CUDA.Runtime

CUDART_PIO2_LO

CUDA.Runtime

CUDART_PIO4

CUDA.Runtime

CUDART_PIO4_F

CUDA.Runtime

CUDART_PIO4_HI

CUDA.Runtime

CUDART_PIO4_LO

CUDA.Runtime

CUDART_PI_F

CUDA.Runtime

CUDART_PI_HI

CUDA.Runtime

CUDART_PI_LO

CUDA.Runtime

CUDART_REMQUO_BITS_F

CUDA.Runtime

CUDART_REMQUO_MASK_F

CUDA.Runtime

CUDART_SQRT_2PI_HI

CUDA.Runtime

CUDART_SQRT_2PI_LO

CUDA.Runtime

CUDART_SQRT_HALF

CUDA.Runtime

CUDART_SQRT_HALF_F

CUDA.Runtime

CUDART_SQRT_PIO2_HI

CUDA.Runtime

CUDART_SQRT_PIO2_LO

CUDA.Runtime

CUDART_SQRT_TWO

CUDA.Runtime

CUDART_SQRT_TWO_F

CUDA.Runtime

CUDART_THIRD

CUDA.Runtime

CUDART_THIRD_F

CUDA.Runtime

CUDART_TRIG_PLOSS

CUDA.Runtime

CUDART_TRIG_PLOSS_F

CUDA.Runtime

CUDART_TWOTHIRD

CUDA.Runtime

CUDART_TWO_TO_126_F

CUDA.Runtime

CUDART_TWO_TO_23

CUDA.Runtime

CUDART_TWO_TO_23_F

CUDA.Runtime

CUDART_TWO_TO_24_F

CUDA.Runtime

CUDART_TWO_TO_31_F

CUDA.Runtime

CUDART_TWO_TO_32_F

CUDA.Runtime

CUDART_TWO_TO_52

CUDA.Runtime

CUDART_TWO_TO_54

CUDA.Runtime

CUDART_TWO_TO_M1022

CUDA.Runtime

CUDART_TWO_TO_M126_F

CUDA.Runtime

CUDART_TWO_TO_M54

CUDA.Runtime

CUDART_ZERO

CUDA.Runtime

CUDART_ZERO_F

CUDA.Runtime

cudaRuntimeGetVersion

CUDA.Runtime

cudaSetDevice

CUDA.Runtime

cudaSetDeviceFlags

CUDA.Runtime

cudaSetDoubleForDevice

CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************

cudaSetDoubleForHost

CUDA.Runtime

cudaSetupArgument

CUDA.Runtime

cudaSetValidDevices

CUDA.Runtime

cudaStreamCreate

CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************

cudaStreamDestroy

CUDA.Runtime

cudaStreamQuery

CUDA.Runtime

cudaStreamSynchronize

CUDA.Runtime

cudaStream_t

CUDA.Runtime

+//DEVICE_BUILTIN*/

cudaThreadExit

CUDA.Runtime

****************************************************************************** * * * * * * ******************************************************************************

cudaThreadGetLimit

CUDA.Runtime

cudaThreadSetLimit

CUDA.Runtime

cudaThreadSynchronize

CUDA.Runtime

cudaUnbindTexture

CUDA.Runtime

cudaWGLGetDevice

CUDA.Runtime

CUDA_ERROR_ALREADY_ACQUIRED

CUDA.Import

< No binary for GPU

CUDA_ERROR_ALREADY_MAPPED

CUDA.Import

< Array is mapped

CUDA_ERROR_ARRAY_IS_MAPPED

CUDA.Import

< Unmap failed

CUDA_ERROR_CONTEXT_ALREADY_CURRENT

CUDA.Import

< Invalid context

CUDA_ERROR_DEINITIALIZED

CUDA.Import

< Driver not initialized

CUDA_ERROR_FILE_NOT_FOUND

CUDA.Import

< Invalid source

CUDA_ERROR_INVALID_CONTEXT

CUDA.Import

< Invalid kernel image

CUDA_ERROR_INVALID_DEVICE

CUDA.Import

< No CUDA-capable device available

CUDA_ERROR_INVALID_HANDLE

CUDA.Import

< File not found

CUDA_ERROR_INVALID_IMAGE

CUDA.Import

< Invalid device

CUDA_ERROR_INVALID_SOURCE

CUDA.Import

< Mapped resource not available for access as a pointer

CUDA_ERROR_INVALID_VALUE

CUDA.Import

< No errors

CUDA_ERROR_LAUNCH_FAILED

CUDA.Import

< CUDA not ready

CUDA_ERROR_LAUNCH_INCOMPATIBLE_TEXTURING

CUDA.Import

< Launch exceeded timeout

CUDA_ERROR_LAUNCH_OUT_OF_RESOURCES

CUDA.Import

< Launch failed

CUDA_ERROR_LAUNCH_TIMEOUT

CUDA.Import

< Launch exceeded resources

CUDA_ERROR_MAP_FAILED

CUDA.Import

< Context already current

CUDA_ERROR_NOT_FOUND

CUDA.Import

< Invalid handle

CUDA_ERROR_NOT_INITIALIZED

CUDA.Import

< Out of memory

CUDA_ERROR_NOT_MAPPED

CUDA.Import

< Already acquired

CUDA_ERROR_NOT_MAPPED_AS_ARRAY

CUDA.Import

< Not mapped

CUDA_ERROR_NOT_MAPPED_AS_POINTER

CUDA.Import

< Mapped resource not available for access as an array

CUDA_ERROR_NOT_READY

CUDA.Import

< Not found

CUDA_ERROR_NO_BINARY_FOR_GPU

CUDA.Import

< Already mapped

CUDA_ERROR_NO_DEVICE

CUDA.Import

< Driver deinitialized

CUDA_ERROR_OUT_OF_MEMORY

CUDA.Import

< Invalid value

CUDA_ERROR_POINTER_IS_64BIT

CUDA.Import

< Launch with incompatible texturing

CUDA_ERROR_SIZE_IS_64BIT

CUDA.Import

< Attempted to retrieve 64-bit pointer via 32-bit API function

CUDA_ERROR_UNKNOWN

CUDA.Import

< Attempted to retrieve 64-bit size via 32-bit API function

CUDA_ERROR_UNMAP_FAILED

CUDA.Import

< Map failed

CUDA_SUCCESS

CUDA.Import

cuDeviceComputeCapability

CUDA.Import

cuDeviceGet

CUDA.Import

cuDeviceGetAttribute

CUDA.Import

cuDeviceGetCount

CUDA.Import

cuDeviceGetName

CUDA.Import

cuDeviceGetProperties

CUDA.Import

cuDeviceTotalMem

CUDA.Import

cudppCompact

CUDA.ParallelPrimitives

cudppDestroyPlan

CUDA.ParallelPrimitives

cudppDestroySparseMatrix

CUDA.ParallelPrimitives

CUDPPDLL

CUDA.ParallelPrimitives

————————————————————- cuDPP – CUDA Data Parallel Primitives library ————————————————————- $Revision: 4567 $ $Date: 2020-05-17 ————————————————————- This source code is distributed under the terms of license.txt in the root directory of this source distribution. ————————————————————-

cudppMultiScan

CUDA.ParallelPrimitives

cudppPlan

CUDA.ParallelPrimitives

Plan allocation (for scan, sort, and compact)

cudppRand

CUDA.ParallelPrimitives

random number generation algorithms

cudppRandSeed

CUDA.ParallelPrimitives

cudppScan

CUDA.ParallelPrimitives

Scan and sort algorithms

cudppSegmentedScan

CUDA.ParallelPrimitives

cudppSort

CUDA.ParallelPrimitives

cudppSparseMatrix

CUDA.ParallelPrimitives

Sparse matrix allocation

cudppSparseMatrixVectorMultiply

CUDA.ParallelPrimitives

Sparse matrix-vector algorithms

CUDPP_INVALID_HANDLE

CUDA.ParallelPrimitives

cuDriverGetVersion

CUDA.Import

cuEventCreate

CUDA.Import

cuEventDestroy

CUDA.Import

cuEventElapsedTime

CUDA.Import

cuEventQuery

CUDA.Import

cuEventRecord

CUDA.Import

cuEventSynchronize

CUDA.Import

cufftDestroy

CUDA.FourierTransform

CUFFTDLLNAMES

CUDA.FourierTransform

cufftExecC2C

CUDA.FourierTransform

cufftExecC2R

CUDA.FourierTransform

cufftExecD2Z

CUDA.FourierTransform

cufftExecR2C

CUDA.FourierTransform

cufftExecZ2D

CUDA.FourierTransform

cufftExecZ2Z

CUDA.FourierTransform

cufftPlan1d

CUDA.FourierTransform

cufftPlan2d

CUDA.FourierTransform

cufftPlan3d

CUDA.FourierTransform

cufftPlanMany

CUDA.FourierTransform

cufftSetCompatibilityMode

CUDA.FourierTransform

cufftSetStream

CUDA.FourierTransform

CUFFT_ALLOC_FAILED

CUDA.FourierTransform

CUFFT_C2C

CUDA.FourierTransform

Complex (interleaved) to Real

CUFFT_C2R

CUDA.FourierTransform

Real to Complex (interleaved)

CUFFT_COMPATIBILITY_FFTW

CUDA.FourierTransform

CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC

CUDA.FourierTransform

CUFFT_COMPATIBILITY_FFTW_PADDING

CUDA.FourierTransform

The default value

CUFFT_COMPATIBILITY_NORMAL

CUDA.FourierTransform

CUFFT_D2Z

CUDA.FourierTransform

Complex to Complex, interleaved

CUFFT_EXEC_FAILED

CUDA.FourierTransform

CUFFT_FORWARD

CUDA.FourierTransform

CUFFT transform directions

CUFFT_INTERNAL_ERROR

CUDA.FourierTransform

CUFFT_INVALID_PLAN

CUDA.FourierTransform

CUFFT_INVALID_SIZE

CUDA.FourierTransform

CUFFT_INVALID_TYPE

CUDA.FourierTransform

CUFFT_INVALID_VALUE

CUDA.FourierTransform

CUFFT_INVERSE

CUDA.FourierTransform

Forward FFT

CUFFT_R2C

CUDA.FourierTransform

Inverse FFT CUFFT supports the following transform types

CUFFT_SETUP_FAILED

CUDA.FourierTransform

CUFFT_SUCCESS

CUDA.FourierTransform

CUFFT_Z2D

CUDA.FourierTransform

Double to Double-Complex

CUFFT_Z2Z

CUDA.FourierTransform

Double-Complex to Double

cuFuncGetAttribute

CUDA.Import

cuFuncSetBlockShape

CUDA.Import

cuFuncSetSharedSize

CUDA.Import

cuGLCtxCreate

CUDA.Import

cuGLInit

CUDA.Import

cuGLMapBufferObject

CUDA.Import

cuGLMapBufferObjectAsync

CUDA.Import

cuGLRegisterBufferObject

CUDA.Import

cuGLSetBufferObjectMapFlags

CUDA.Import

cuGLUnmapBufferObject

CUDA.Import

cuGLUnmapBufferObjectAsync

CUDA.Import

cuGLUnregisterBufferObject

CUDA.Import

cuGraphicsGLRegisterBuffer

CUDA.Import

cuGraphicsGLRegisterImage

CUDA.Import

cuGraphicsMapResources

CUDA.Import

cuGraphicsResourceGetMappedPointer

CUDA.Import

cuGraphicsResourceSetMapFlags

CUDA.Import

cuGraphicsSubResourceGetMappedArray

CUDA.Import

cuGraphicsUnmapResources

CUDA.Import

cuGraphicsUnregisterResource

CUDA.Import

cuInit

CUDA.Import

cuLaunch

CUDA.Import

cuLaunchGrid

CUDA.Import

cuLaunchGridAsync

CUDA.Import

cuMemAlloc

CUDA.Import

cuMemAllocHost

CUDA.Import

cuMemAllocPitch

CUDA.Import

cuMemcpy2D

CUDA.Import

cuMemcpy2DAsync

CUDA.Import

cuMemcpy2DUnaligned

CUDA.Import

cuMemcpy3D

CUDA.Import

cuMemcpy3DAsync

CUDA.Import

cuMemcpyAtoA

CUDA.Import

cuMemcpyAtoD

CUDA.Import

cuMemcpyAtoH

CUDA.Import

cuMemcpyAtoHAsync

CUDA.Import

cuMemcpyDtoA

CUDA.Import

cuMemcpyDtoD

CUDA.Import

cuMemcpyDtoDAsync

CUDA.Import

cuMemcpyDtoH

CUDA.Import

cuMemcpyDtoHAsync

CUDA.Import

cuMemcpyHtoA

CUDA.Import

cuMemcpyHtoAAsync

CUDA.Import

cuMemcpyHtoD

CUDA.Import

cuMemcpyHtoDAsync

CUDA.Import

cuMemFree

CUDA.Import

cuMemFreeHost

CUDA.Import

cuMemGetAddressRange

CUDA.Import

cuMemGetInfo

CUDA.Import

cuMemHostAlloc

CUDA.Import

cuMemHostGetDevicePointer

CUDA.Import

cuMemHostGetFlags

CUDA.Import

cuMemsetD16

CUDA.Import

cuMemsetD2D16

CUDA.Import

cuMemsetD2D32

CUDA.Import

cuMemsetD2D8

CUDA.Import

cuMemsetD32

CUDA.Import

cuMemsetD8

CUDA.Import

cuModuleGetFunction

CUDA.Import

cuModuleGetGlobal

CUDA.Import

cuModuleGetTexRef

CUDA.Import

cuModuleLoad

CUDA.Import

cuModuleLoadData

CUDA.Import

cuModuleLoadDataEx

CUDA.Import

cuModuleLoadFatBinary

CUDA.Import

cuModuleUnload

CUDA.Import

cuParamSetf

CUDA.Import

cuParamSeti

CUDA.Import

cuParamSetSize

CUDA.Import

cuParamSetTexRef

CUDA.Import

cuParamSetv

CUDA.Import

cUranusOrbitalElements

GLS.SkyDome

(AU) heliocentric uranus elements

CurrentGLContext

GLS.Context

The TGLContext that is the currently active context, if any. Returns nil if no context is active.

CURV_CONTINUITY_FIRST

Formats.LWO

CURV_CONTINUITY_LAST

Formats.LWO

cuStreamCreate

CUDA.Import

cuStreamDestroy

CUDA.Import

cuStreamQuery

CUDA.Import

cuStreamSynchronize

CUDA.Import

cutComparef

CUDA.Utility

cutComparefe

CUDA.Utility

cutComparefet

CUDA.Utility

cutComparei

CUDA.Utility

cutCompareL2fe

CUDA.Utility

cutCompareub

CUDA.Utility

cutCompareube

CUDA.Utility

cutCompareubt

CUDA.Utility

cutCompareuit

CUDA.Utility

cutCreateTimer

CUDA.Utility

cutDeleteTimer

CUDA.Utility

cuTexRefCreate

CUDA.Import

cuTexRefDestroy

CUDA.Import

cuTexRefGetAddress

CUDA.Import

cuTexRefGetAddressMode

CUDA.Import

cuTexRefGetArray

CUDA.Import

cuTexRefGetFilterMode

CUDA.Import

cuTexRefGetFlags

CUDA.Import

cuTexRefGetFormat

CUDA.Import

cuTexRefSetAddress

CUDA.Import

cuTexRefSetAddress2D

CUDA.Import

cuTexRefSetAddressMode

CUDA.Import

cuTexRefSetArray

CUDA.Import

cuTexRefSetFilterMode

CUDA.Import

cuTexRefSetFlags

CUDA.Import

cuTexRefSetFormat

CUDA.Import

cutFindFilePath

CUDA.Utility

cutFree

CUDA.Utility

cutGetAverageTimerValue

CUDA.Utility

cutGetTimerValue

CUDA.Utility

CUTILDLL

CUDA.Utility

cutLoadPGMf

CUDA.Utility

cutLoadPGMi

CUDA.Utility

cutLoadPGMs

CUDA.Utility

cutLoadPGMub

CUDA.Utility

cutLoadPPM4ub

CUDA.Utility

cutLoadPPMub

CUDA.Utility

cutResetTimer

CUDA.Utility

cutSavePGMf

CUDA.Utility

cutSavePGMi

CUDA.Utility

cutSavePGMs

CUDA.Utility

cutSavePGMub

CUDA.Utility

cutSavePPM4ub

CUDA.Utility

cutSavePPMub

CUDA.Utility

cutStartTimer

CUDA.Utility

cutStopTimer

CUDA.Utility

cuWGLGetDevice

CUDA.Import

CU_MEMHOSTALLOC_DEVICEMAP

CUDA.Import

* If set, host memory is mapped into CUDA address space and * ::cuMemHostGetDevicePointer() may be called on the host pointer. * Flag for ::cuMemHostAlloc()

CU_MEMHOSTALLOC_PORTABLE

CUDA.Import

* If set, host memory is portable between CUDA contexts. * Flag for ::cuMemHostAlloc()

CU_MEMHOSTALLOC_WRITECOMBINED

CUDA.Import

* If set, host memory is allocated as write-combined - fast to write, * faster to DMA, slow to read except via SSE4 streaming load instruction * (MOVNTDQA). * Flag for ::cuMemHostAlloc()

CU_PARAM_TR_DEFAULT

CUDA.Import

* For texture references loaded into the module, use default texunit from * texture reference.

CU_TRSA_OVERRIDE_FORMAT

CUDA.Import

* Override the texref format with a format inferred from the array. * Flag for ::cuTexRefSetArray()

CU_TRSF_NORMALIZED_COORDINATES

CUDA.Import

* Use normalized texture coordinates in the range [0,1) instead of [0,dim). * Flag for ::cuTexRefSetFlags()

CU_TRSF_READ_AS_INTEGER

CUDA.Import

* Read the texture as integers rather than promoting the values to floats * in the range [0,1]. * Flag for ::cuTexRefSetFlags()

cVenusOrbitalElements

GLS.SkyDome

(AU) heliocentric venus elements

cVertexModeToGLEnum

GLS.Mesh

C_ALL_LINES

Formats.m3DSConst

C_ALPHA_SPLIT

Formats.m3DSConst

C_ANG_THRESH

Formats.m3DSConst

C_ANIMLENGTH

Formats.m3DSConst

C_APPLY_DISP_GAMMA

Formats.m3DSConst

C_APPLY_FBUF_GAMMA

Formats.m3DSConst

OBSOLETE

C_APPLY_FILE_GAMMA

Formats.m3DSConst

OBSOLETE

C_ARCH_DENOM

Formats.m3DSConst

C_ASNAPS

Formats.m3DSConst

C_AUTO_REFLECT

Formats.m3DSConst

C_AUTO_SMOOTH

Formats.m3DSConst

C_AUTO_UNIFY

Formats.m3DSConst

C_AUTO_WELD

Formats.m3DSConst

C_BACKUP_FILE

Formats.m3DSConst

system options

C_BACK_TYPE

Formats.m3DSConst

C_BGND_METHOD

Formats.m3DSConst

C_BGND_PRES_RATIO

Formats.m3DSConst

C_BGTYPE

Formats.m3DSConst

C_BIAS_DEFAULT

Formats.m3DSConst

C_BITMAP_DRAWER

Formats.m3DSConst

C_BLUR_DUR

Formats.m3DSConst

C_BLUR_FRAMES

Formats.m3DSConst

C_BLUR_SAMPLES

Formats.m3DSConst

C_BOOLTYPE

Formats.m3DSConst

C_BOOLWELD

Formats.m3DSConst

Booleans

C_CAMNAME

Formats.m3DSConst

C_COMM_PORT

Formats.m3DSConst

C_CONESEGS

Formats.m3DSConst

C_CONESIDES

Formats.m3DSConst

C_CONSTS

Formats.m3DSConst

C_CONT_DEFAULT

Formats.m3DSConst

C_CUBDRAWER

Formats.m3DSConst

C_CURMTL_FROM_MESH

Formats.m3DSConst

C_CURTIME

Formats.m3DSConst

C_CUR_MNAME

Formats.m3DSConst

C_DETAIL

Formats.m3DSConst

C_DISP_GAMMA

Formats.m3DSConst

C_DITHER_24

Formats.m3DSConst

C_DITHER_256

Formats.m3DSConst

C_DXFNAME_SRC

Formats.m3DSConst

C_DXF_SMOOTH_ANG

Formats.m3DSConst

C_EDITOR_OK

Formats.m3DSConst

C_ETAPE

Formats.m3DSConst

C_FBUF_GAMMA

Formats.m3DSConst

C_FILE_IN_GAMMA

Formats.m3DSConst

C_FILE_OUT_GAMMA

Formats.m3DSConst

C_FLIDRAWER

Formats.m3DSConst

C_FLIFILE

Formats.m3DSConst

C_FONTSEL

Formats.m3DSConst

C_FORCE_WIRE

Formats.m3DSConst

OBSOLETE

C_FROZ_DISPLAY

Formats.m3DSConst

3d frozen display

C_GAMMA_CORRECT

Formats.m3DSConst

C_GEOSMOOTH

Formats.m3DSConst

C_GET_SHAPE_MAKE_FACES

Formats.m3DSConst

C_GRIDS

Formats.m3DSConst

C_GRID_RANGE

Formats.m3DSConst

C_HEBOT

Formats.m3DSConst

C_HEDEG

Formats.m3DSConst

C_HEDIR

Formats.m3DSConst

C_HEHT

Formats.m3DSConst

C_HEMISEGS

Formats.m3DSConst

C_HESEG

Formats.m3DSConst

C_HETOP

Formats.m3DSConst

C_HETURNS

Formats.m3DSConst

C_HI_CONTRAST

Formats.m3DSConst

C_HOT_CHECK

Formats.m3DSConst

C_HOT_METHOD

Formats.m3DSConst

C_IN_DEVICE

Formats.m3DSConst

C_JPEG_COMPRESSION

Formats.m3DSConst

C_KEYFRAMER_OK

Formats.m3DSConst

C_KF_SHOW_BACKFACE

Formats.m3DSConst

C_KTAPE

Formats.m3DSConst

C_LMTS_ID

GLS.FileLMTS

C_LMTS_SUBS

GLS.FileLMTS

C_LMTS_TEXFNLEN

GLS.FileLMTS

C_LMTS_TEXT

GLS.FileLMTS

C_LMTS_TRIS

GLS.FileLMTS

C_LMTS_VER

GLS.FileLMTS

C_LOFTER_OK

Formats.m3DSConst

C_LOFT_L_REPEAT

Formats.m3DSConst

C_LOFT_UV_NORMALIZE

Formats.m3DSConst

C_LOFT_WITH_TEXTURE

Formats.m3DSConst

C_LOFT_W_REPEAT

Formats.m3DSConst

C_LO_CONTRAST

Formats.m3DSConst

Contrast

C_LTAPE

Formats.m3DSConst

C_LTNAME

Formats.m3DSConst

C_MAPDRAWER

Formats.m3DSConst

C_MAPDRAWER1

Formats.m3DSConst

C_MAPDRAWER2

Formats.m3DSConst

C_MAPDRAWER3

Formats.m3DSConst

C_MAPDRAWER4

Formats.m3DSConst

C_MAPDRAWER5

Formats.m3DSConst

C_MAPDRAWER6

Formats.m3DSConst

C_MAPDRAWER7

Formats.m3DSConst

C_MAPDRAWER8

Formats.m3DSConst

C_MAPDRAWER9

Formats.m3DSConst

C_MAPDRAWER_ENTRY

Formats.m3DSConst

C_MAPTYPE

Formats.m3DSConst

C_MAP_DISPLAY

Formats.m3DSConst

C_MAP_MATRIX

Formats.m3DSConst

C_MAP_MATRIX_OLD

Formats.m3DSConst

C_MAP_SCALE

Formats.m3DSConst

C_MAP_WID_HT

Formats.m3DSConst

C_MAP_XYZ

Formats.m3DSConst

C_MASTER_AMBIENT

Formats.m3DSConst

C_MASTER_SCALES

Formats.m3DSConst

C_MBLUR_DITHER

Formats.m3DSConst

C_MDRAWER

Formats.m3DSConst

C_MD_CE

Formats.m3DSConst

C_MD_CS

Formats.m3DSConst

C_MD_PDET

Formats.m3DSConst

C_MD_SDET

Formats.m3DSConst

C_MD_SML

Formats.m3DSConst

C_MD_SMW

Formats.m3DSConst

C_MEDTILE

Formats.m3DSConst

C_MESHSEL

Formats.m3DSConst

C_MESHUNSEL

Formats.m3DSConst

C_MFILE

Formats.m3DSConst

C_MFTSYM

Formats.m3DSConst

C_MODDRAWER

Formats.m3DSConst

C_MODFILE

Formats.m3DSConst

C_MODICOUNT

Formats.m3DSConst

C_MODMODEL

Formats.m3DSConst

C_MODWMODE

Formats.m3DSConst

C_MSCALE

Formats.m3DSConst

C_MSCSYM

Formats.m3DSConst

C_MSHAX

Formats.m3DSConst

C_MSHCP

Formats.m3DSConst

C_MSHLOCAL

Formats.m3DSConst

C_MTLDRAWER

Formats.m3DSConst

C_MTLFILE

Formats.m3DSConst

C_MTTSYM

Formats.m3DSConst

C_NET_FIELD_ORDER

Formats.m3DSConst

C_NET_USE_GAMMA

Formats.m3DSConst

C_NET_USE_VPOST

Formats.m3DSConst

Special network-use chunks

C_NGPARMS

Formats.m3DSConst

C_NTH_SERIAL_NUM

Formats.m3DSConst

C_NUM_FORMAT

Formats.m3DSConst

C_OBJECT_MBLUR

Formats.m3DSConst

C_OBNAME

Formats.m3DSConst

C_OPTIMIZE_LOFT

Formats.m3DSConst

C_PALFILE

Formats.m3DSConst

C_PAL_TYPE

Formats.m3DSConst

C_PDRAWER

Formats.m3DSConst

C_PFILE

Formats.m3DSConst

C_PICKSIZE

Formats.m3DSConst

C_PIXEL_SIZE

Formats.m3DSConst

C_POLYSEL

Formats.m3DSConst

C_POLYUNSEL

Formats.m3DSConst

C_PREVMODE

Formats.m3DSConst

C_PRISMSEGS

Formats.m3DSConst

C_PRISMSIDES

Formats.m3DSConst

C_PROGMODE

Formats.m3DSConst

C_PTHLEVEL

Formats.m3DSConst

C_PV_DOFNUM

Formats.m3DSConst

C_PV_FPS

Formats.m3DSConst

C_PV_FROM

Formats.m3DSConst

C_PV_METHOD

Formats.m3DSConst

C_PV_NTH

Formats.m3DSConst

C_PV_RNG

Formats.m3DSConst

C_PV_TO

Formats.m3DSConst

C_PV_TYPE

Formats.m3DSConst

C_QUIKSTUFF

Formats.m3DSConst

C_RAX

Formats.m3DSConst

C_RAY_SHADOWS

Formats.m3DSConst

C_REFLIP

Formats.m3DSConst

C_RENDER_ALL

Formats.m3DSConst

C_RENDTYPE

Formats.m3DSConst

C_REND_FIELDS

Formats.m3DSConst

C_REND_FROM

Formats.m3DSConst

C_REND_NTH

Formats.m3DSConst

C_REND_TO

Formats.m3DSConst

C_REND_TSTEP

Formats.m3DSConst

C_RGB_AA

Formats.m3DSConst

C_RGB_ANIMTYPE

Formats.m3DSConst

C_RGB_COMPRESS

Formats.m3DSConst

C_RGB_DISPDEV

Formats.m3DSConst

C_RGB_FILE

Formats.m3DSConst

C_RGB_HARDDEV

Formats.m3DSConst

C_RGB_HIDE

Formats.m3DSConst

C_RGB_MAPSW

Formats.m3DSConst

C_RGB_OUTPUT

Formats.m3DSConst

C_RGB_OVASPECT

Formats.m3DSConst

C_RGB_OVH

Formats.m3DSConst

C_RGB_OVW

Formats.m3DSConst

C_RGB_PATH

Formats.m3DSConst

C_RGB_PICTYPE

Formats.m3DSConst

C_RGB_RMODE

Formats.m3DSConst

C_RGB_SHADOW

Formats.m3DSConst

C_RGB_TODISK

Formats.m3DSConst

C_RGB_TWOSIDE

Formats.m3DSConst

C_RIPDRAWER

Formats.m3DSConst

C_RIPFILE

Formats.m3DSConst

C_RND_MIP

Formats.m3DSConst

C_RND_TURBO

Formats.m3DSConst

C_SAFE_FRAME

Formats.m3DSConst

C_SAVE_LAST

Formats.m3DSConst

C_SEE_3D

Formats.m3DSConst

C_SEE_CAMERAS

Formats.m3DSConst

C_SEE_LIGHTS

Formats.m3DSConst

C_SEG_END

Formats.m3DSConst

C_SEG_START

Formats.m3DSConst

C_SEL_ITEMTOG

Formats.m3DSConst

C_SEL_RESET

Formats.m3DSConst

C_SHAPER_OK

Formats.m3DSConst

C_SHOOK

Formats.m3DSConst

C_SHOW_1STVERT

Formats.m3DSConst

C_SHPDRAWER

Formats.m3DSConst

C_SHPFILE

Formats.m3DSConst

C_SHPLOCAL

Formats.m3DSConst

C_SMOOTHING

Formats.m3DSConst

C_SMOOTH_ANG

Formats.m3DSConst

C_SNAPS

Formats.m3DSConst

C_SPHSEGS

Formats.m3DSConst

C_SRDEG

Formats.m3DSConst

C_SRDIAM

Formats.m3DSConst

C_SRDIR

Formats.m3DSConst

C_SRSEG

Formats.m3DSConst

C_SS_THRESH

Formats.m3DSConst

C_STAPE

Formats.m3DSConst

C_STICKY_KEYINF

Formats.m3DSConst

C_SUPER_BLACK

Formats.m3DSConst

C_SUPER_SAMPLE

Formats.m3DSConst

C_SXP_BUMP_DATA

Formats.m3DSConst

C_SXP_BUMP_MASKDATA

Formats.m3DSConst

C_SXP_OPAC_DATA

Formats.m3DSConst

C_SXP_OPAC_MASKDATA

Formats.m3DSConst

C_SXP_REFL_MASKDATA

Formats.m3DSConst

C_SXP_SELFI_DATA

Formats.m3DSConst

C_SXP_SELFI_MASKDATA

Formats.m3DSConst

C_SXP_SHIN_DATA

Formats.m3DSConst

C_SXP_SHIN_MASKDATA

Formats.m3DSConst

C_SXP_SPEC_DATA

Formats.m3DSConst

C_SXP_SPEC_MASKDATA

Formats.m3DSConst

C_SXP_TEXT2_DATA

Formats.m3DSConst

C_SXP_TEXT2_MASKDATA

Formats.m3DSConst

C_SXP_TEXT_DATA

Formats.m3DSConst

C_SXP_TEXT_MASKDATA

Formats.m3DSConst

C_TAB_BASES

Formats.m3DSConst

C_TAB_DIVS

Formats.m3DSConst

C_TDRAWER

Formats.m3DSConst

C_TENS_DEFAULT

Formats.m3DSConst

C_TESS_TENSION

Formats.m3DSConst

C_TESS_TYPE

Formats.m3DSConst

C_TEXTURE_BLUR_DEFAULT

Formats.m3DSConst

C_TGA_DEPTH

Formats.m3DSConst

C_TILE_XY

Formats.m3DSConst

C_TORSEGS

Formats.m3DSConst

C_TORSIDES

Formats.m3DSConst

C_TUBESEGS

Formats.m3DSConst

C_TUBESIDES

Formats.m3DSConst

C_TXDRAWER

Formats.m3DSConst

C_TXFILE

Formats.m3DSConst

C_TX_STRING

Formats.m3DSConst

C_USERAX

Formats.m3DSConst

C_USE_ALPHA

Formats.m3DSConst

C_VERTMARK

Formats.m3DSConst

C_VIEW_PRES_RATIO

Formats.m3DSConst

C_VP_FROM

Formats.m3DSConst

C_VP_NTH

Formats.m3DSConst

C_VP_TO

Formats.m3DSConst

C_VP_TSTEP

Formats.m3DSConst

C_VTR_FRAMES

Formats.m3DSConst

C_VTR_HD

Formats.m3DSConst

C_VTR_HDTL

Formats.m3DSConst

C_VTR_IN

Formats.m3DSConst

C_VTR_PK

Formats.m3DSConst

C_VTR_SH

Formats.m3DSConst

C_VTR_TL

Formats.m3DSConst

C_WELD_LOFT

Formats.m3DSConst

C_WELD_THRESHOLD

Formats.m3DSConst

C_WORKMTL

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS

Formats.m3DSConst

Material chunks

C_WORK_MTLS_2

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_3

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_4

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_5

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_6

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_7

Formats.m3DSConst

Old-style – now ignored

C_WORK_MTLS_8

Formats.m3DSConst

Old-style – now ignored

C_ZCLIP_POINT

Formats.m3DSConst

D3D11_RESOURCE_DIMENSION_BUFFER

Formats.DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE1D

Formats.DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE2D

Formats.DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE3D

Formats.DXTC

D3D11_RESOURCE_DIMENSION_UNKNOWN

Formats.DXTC

); TD3D11_RESOURCE_DIMENSION = (

DAMP_SHIFT

GLS.ProcTextures

dAreConnected

ODE.Import

dAreConnectedExcluding

ODE.Import

dBodyAddForce

ODE.Import

—– dBody —–

dBodyAddForceAtPos

ODE.Import

dBodyAddForceAtRelPos

ODE.Import

dBodyAddRelForce

ODE.Import

dBodyAddRelForceAtPos

ODE.Import

dBodyAddRelForceAtRelPos

ODE.Import

dBodyAddRelTorque

ODE.Import

dBodyAddTorque

ODE.Import

dBodyCopyPosition

ODE.Import

dBodyCopyQuaternion

ODE.Import

dBodyCopyRotation

ODE.Import

dBodyCreate

ODE.Import

dBodyDestroy

ODE.Import

dBodyDisable

ODE.Import

dBodyEnable

ODE.Import

dBodyGetAngularDamping

ODE.Import

dBodyGetAngularDampingThreshold

ODE.Import

dBodyGetAngularVel

ODE.Import

dBodyGetAutoDisableAngularThreshold

ODE.Import

dBodyGetAutoDisableFlag

ODE.Import

dBodyGetAutoDisableLinearThreshold

ODE.Import

Auto-disable functions

dBodyGetAutoDisableSteps

ODE.Import

dBodyGetAutoDisableTime

ODE.Import

dBodyGetData

ODE.Import

dBodyGetFiniteRotationAxis

ODE.Import

dBodyGetFiniteRotationMode

ODE.Import

dBodyGetForce

ODE.Import

dBodyGetGravityMode

ODE.Import

dBodyGetJoint

ODE.Import

dBodyGetLinearDamping

ODE.Import

dBodyGetLinearDampingThreshold

ODE.Import

dBodyGetLinearVel

ODE.Import

dBodyGetMass

ODE.Import

dBodyGetMaxAngularSpeed

ODE.Import

dBodyGetNumJoints

ODE.Import

dBodyGetPointVel

ODE.Import

dBodyGetPosition

ODE.Import

dBodyGetPosRelPoint

ODE.Import

dBodyGetQuaternion

ODE.Import

dBodyGetRelPointPos

ODE.Import

dBodyGetRelPointVel

ODE.Import

dBodyGetRotation

ODE.Import

dBodyGetTorque

ODE.Import

dBodyIsEnabled

ODE.Import

dBodySetAngularDamping

ODE.Import

dBodySetAngularDampingThreshold

ODE.Import

dBodySetAngularVel

ODE.Import

dBodySetAutoDisableAngularThreshold

ODE.Import

dBodySetAutoDisableAverageSamplesCount

ODE.Import

dBodySetAutoDisableDefaults

ODE.Import

dBodySetAutoDisableFlag

ODE.Import

dBodySetAutoDisableLinearThreshold

ODE.Import

dBodySetAutoDisableSteps

ODE.Import

dBodySetAutoDisableTime

ODE.Import

dBodySetDamping

ODE.Import

dBodySetDampingDefaults

ODE.Import

dBodySetData

ODE.Import

dBodySetFiniteRotationAxis

ODE.Import

dBodySetFiniteRotationMode

ODE.Import

dBodySetForce

ODE.Import

dBodySetGravityMode

ODE.Import

dBodySetLinearDamping

ODE.Import

damping functions

dBodySetLinearDampingThreshold

ODE.Import

dBodySetLinearVel

ODE.Import

dBodySetMass

ODE.Import

dBodySetMaxAngularSpeed

ODE.Import

dBodySetMovedCallback

ODE.Import

dBodySetPosition

ODE.Import

dBodySetQuaternion

ODE.Import

dBodySetRotation

ODE.Import

dBodySetTorque

ODE.Import

dBodyToBodyDistance

GLS.ODEUtils

dBodyVectorFromWorld

ODE.Import

dBodyVectorToWorld

ODE.Import

dBoxClass

ODE.Import

dBoxTouchesBox

ODE.Import

dCapsuleClass

ODE.Import

DCEBox

GLS.DCE

dClearUpperTriangle

ODE.Import

dCloseODE

ODE.Import

dClosestLineSegmentPoints

ODE.Import

—– Misc —–

dCollide

ODE.Import

dContactApprox0

ODE.Import

dContactApprox1

ODE.Import

dContactApprox1_1

ODE.Import

dContactApprox1_2

ODE.Import

dContactBounce

ODE.Import

dContactFDir1

ODE.Import

dContactMotion1

ODE.Import

dContactMotion2

ODE.Import

dContactMotionN

ODE.Import

dContactMu2

ODE.Import

These consts now have defined types

dContactSlip1

ODE.Import

dContactSlip2

ODE.Import

dContactSoftCFM

ODE.Import

dContactSoftERP

ODE.Import

dConvexClass

ODE.Import

dCreateBox

ODE.Import

Box

dCreateCapsule

ODE.Import

dCapsule (a capped cylinder).

dCreateConvex

ODE.Import

Convex

dCreateCylinder

ODE.Import

dCylinder (not a capped cylinder).

dCreateGeom

ODE.Import

—– dGeom —–

dCreateGeomClass

ODE.Import

dCreateGeomTransform

ODE.Import

Transform

dCreateHeightfield

ODE.Import

Heightfield (incomplete)

dCreatePlane

ODE.Import

Plane

dCreateRay

ODE.Import

dRay

dCreateSphere

ODE.Import

Sphere

dCreateTriMesh

ODE.Import

TriMesh

DCUE_BGND

Formats.m3DSConst

dCylinderClass

ODE.Import

DDF_ANIMATE

Formats.VFW

dont draw frame, just decompress

DDF_BACKGROUNDPAL

Formats.VFW

use DisplayDib

DDF_BUFFER

Formats.VFW

allow palette animation

DDF_DONTDRAW

Formats.VFW

draw params are the same

DDF_FULLSCREEN

Formats.VFW

just draw it with GDI

DDF_HALFTONE

Formats.VFW

hurry up please!

DDF_HURRYUP

Formats.VFW

this is a partial frame update, hint

DDF_JUSTDRAWIT

Formats.VFW

always buffer image

DDF_NOTKEYFRAME

Formats.VFW

Realize palette in background

DDF_PREROLL

Formats.VFW

always halftone

DDF_SAME_DIB

Formats.VFW

Builing up a non-keyframe

DDF_SAME_DRAW

Formats.VFW

HDC same as last call (all setup)

DDF_SAME_HDC

Formats.VFW

re-draw the last DIB

DDF_SAME_SIZE

Formats.VFW

DDF_UPDATE

Formats.VFW

********************************************************************
DrawDib Flags
*********************************************************************

dDot

ODE.Import

dDot

ODE.Import

—– Recreated —–

dDOT14

ODE.Import

dDOT14

ODE.Import

DDPF_A

Formats.DXTC

DDPF_ALPHAPIXELS

Formats.DXTC

DDPF_FOURCC

Formats.DXTC

DDPF_L

Formats.DXTC

DDPF_LA

Formats.DXTC

DDPF_RGB

Formats.DXTC

DDPF_RGBA

Formats.DXTC

dDQfromW

ODE.Import

DDSCAPS2_CUBEMAP

Formats.DXTC

DDSCAPS2_CUBEMAP_NEGATIVEX

Formats.DXTC

DDSCAPS2_CUBEMAP_NEGATIVEY

Formats.DXTC

DDSCAPS2_CUBEMAP_NEGATIVEZ

Formats.DXTC

DDSCAPS2_CUBEMAP_POSITIVEX

Formats.DXTC

DDSCAPS2_CUBEMAP_POSITIVEY

Formats.DXTC

DDSCAPS2_CUBEMAP_POSITIVEZ

Formats.DXTC

DDSCAPS2_VOLUME

Formats.DXTC

DDSCAPS_COMPLEX

Formats.DXTC

DDSCAPS_MIPMAP

Formats.DXTC

DDSCAPS_TEXTURE

Formats.DXTC

DDSD_CAPS

Formats.DXTC

DDSD_DEPTH

Formats.DXTC

DDSD_HEIGHT

Formats.DXTC

DDSD_LINEARSIZE

Formats.DXTC

DDSD_MIPMAPCOUNT

Formats.DXTC

DDSD_PITCH

Formats.DXTC

DDSD_PIXELFORMAT

Formats.DXTC

DDSD_WIDTH

Formats.DXTC

DDSHeaderToGLEnum

Formats.DXTC

DDStex

GLS.FileDDS

DDStex

GLS.FileDDS

DDStex

GLS.FileDDS

function DDStex(aMatLib: TGLMaterialLibrary; aTexName, aDDSFileName: string; aSecondTexName: string = ''; aDDSLevel: integer = 0): TGLLibMaterial; overload;

DebugMode

GLS.PhysInertias

Debug_Tri

GLS.EllipseCollision

.$DEFINE DEBUG

DecodeDXT1toBitmap32

Formats.DXTC

DecodeDXT3toBitmap32

Formats.DXTC

DecodeDXT5toBitmap32

Formats.DXTC

DecodeTextureTarget

GLScene.TextureFormat

DefaultInstance

gnugettext

DefaultTextDomain

gnugettext

***************************************************************************

DEFAULT_VIEW

Formats.m3DSConst

DefFace3DS

Formats.m3DSConst

DefKeyHeader3DS

Formats.m3DSConst

DefKFRotKey3DS

Formats.m3DSConst

DefObjMat3DS

Formats.m3DSConst

DEFORM_LIMIT

Formats.m3DSConst

DefPoint3DS

Formats.m3DSConst

Basic structure default contents for ease of initialization

DefTextVert3DS

Formats.m3DSConst

DefTrackHeader3DS

Formats.m3DSConst

DegToRadian

GLScene.VectorGeometry

DegToRadian

GLScene.VectorGeometry

—————————————————————————- Trigonometric functions —————————————————————————-

DeleteChunk

Formats.m3DSUtils

support functions for chunk handling

DeRegisterCUDAComponentNameChangeEvent

GLS.CUDA.APIComps

DeRegisterGLBaseSceneObjectNameChangeEvent

GLS.Scene

Deregister an event handler triggered by any TGLBaseSceneObject Name change. See RegisterGLBaseSceneObjectNameChangeEvent.

DeRegisterGLBehaviourNameChangeEvent

GLS.Scene

Deregister an event handler triggered by any TGLBaseSceneObject Name change. See RegisterGLBaseSceneObjectNameChangeEvent.

DeRegisterGLMaterialExNameChangeEvent

GLS.MaterialEx

DeRegisterManager

GLScene.Manager

DeRegisterXCollectionDestroyEvent

GLScene.XCollection

DeRegisters event

DerivatedPolynom

GLScene.Polynomials

Calculates the polynom's derivative

dFirstSpaceClass

ODE.Import

dFirstUserClass

ODE.Import

dFloat

Newton.Import

dFloat64

Newton.Import

dGeomBoxGetLengths

ODE.Import

dGeomBoxPointDepth

ODE.Import

dGeomBoxSetLengths

ODE.Import

dGeomCapsuleGetParams

ODE.Import

dGeomCapsulePointDepth

ODE.Import

dGeomCapsuleSetParams

ODE.Import

dGeomClearOffset

ODE.Import

dGeomCopyOffsetPosition

ODE.Import

dGeomCopyOffsetRotation

ODE.Import

dGeomCopyPosition

ODE.Import

dGeomCopyQuaternion

ODE.Import

dGeomCopyRotation

ODE.Import

dGeomCylinderGetParams

ODE.Import

dGeomCylinderSetParams

ODE.Import

dGeomDestroy

ODE.Import

dGeomDisable

ODE.Import

dGeomEnable

ODE.Import

dGeomGetAABB

ODE.Import

dGeomGetBody

ODE.Import

dGeomGetCategoryBits

ODE.Import

dGeomGetClass

ODE.Import

dGeomGetClassData

ODE.Import

dGeomGetCollideBits

ODE.Import

dGeomGetData

ODE.Import

dGeomGetOffsetPosition

ODE.Import

dGeomGetOffsetQuaternion

ODE.Import

dGeomGetOffsetRotation

ODE.Import

dGeomGetPosition

ODE.Import

dGeomGetQuaternion

ODE.Import

dGeomGetRotation

ODE.Import

dGeomGetSpace

ODE.Import

dGeomHeightfieldDataCreate

ODE.Import

dGeomHeightfieldDataDestroy

ODE.Import

dGeomHeightfieldDataSetBounds

ODE.Import

dGeomHeightfieldGetHeightfieldData

ODE.Import

dGeomHeightfieldSetHeightfieldData

ODE.Import

dGeomIsEnabled

ODE.Import

dGeomIsOffset

ODE.Import

dGeomIsSpace

ODE.Import

dGeomNumClasses

ODE.Import

dGeomPlaneGetParams

ODE.Import

dGeomPlanePointDepth

ODE.Import

dGeomPlaneSetParams

ODE.Import

dGeomRayGet

ODE.Import

dGeomRayGetClosestHit

ODE.Import

dGeomRayGetLength

ODE.Import

dGeomRayGetParams

ODE.Import

dGeomRaySet

ODE.Import

dGeomRaySetClosestHit

ODE.Import

dGeomRaySetLength

ODE.Import

dGeomRaySetParams

ODE.Import

dGeomSetBody

ODE.Import

dGeomSetCategoryBits

ODE.Import

dGeomSetCollideBits

ODE.Import

dGeomSetConvex

ODE.Import

dGeomSetData

ODE.Import

dGeomSetOffsetPosition

ODE.Import

dGeomSetOffsetQuaternion

ODE.Import

dGeomSetOffsetRotation

ODE.Import

dGeomSetOffsetWorldPosition

ODE.Import

dGeomSetOffsetWorldQuaternion

ODE.Import

dGeomSetOffsetWorldRotation

ODE.Import

dGeomSetPosition

ODE.Import

dGeomSetQuaternion

ODE.Import

dGeomSetRotation

ODE.Import

dGeomSphereGetRadius

ODE.Import

dGeomSpherePointDepth

ODE.Import

dGeomSphereSetRadius

ODE.Import

dGeomTransformClass

ODE.Import

dGeomTransformGetCleanup

ODE.Import

dGeomTransformGetGeom

ODE.Import

dGeomTransformGetInfo

ODE.Import

dGeomTransformSetCleanup

ODE.Import

dGeomTransformSetGeom

ODE.Import

dGeomTransformSetInfo

ODE.Import

dGeomTriMeshClearTCCache

ODE.Import

dGeomTriMeshDataBuildDouble

ODE.Import

dGeomTriMeshDataBuildDouble1

ODE.Import

dGeomTriMeshDataBuildSimple

ODE.Import

dGeomTriMeshDataBuildSimple1

ODE.Import

dGeomTriMeshDataBuildSingle

ODE.Import

dGeomTriMeshDataBuildSingle1

ODE.Import

dGeomTriMeshDataCreate

ODE.Import

dGeomTriMeshDataDestroy

ODE.Import

dGeomTriMeshDataSet

ODE.Import

dGeomTriMeshDataUpdate

ODE.Import

dGeomTriMeshEnableTC

ODE.Import

dGeomTriMeshGetArrayCallback

ODE.Import

dGeomTriMeshGetCallback

ODE.Import

dGeomTriMeshGetData

ODE.Import

dGeomTriMeshGetPoint

ODE.Import

dGeomTriMeshGetRayCallback

ODE.Import

dGeomTriMeshGetTriangle

ODE.Import

dGeomTriMeshGetTriangleCount

ODE.Import

dGeomTriMeshGetTriMeshDataID

ODE.Import

dGeomTriMeshIsTCEnabled

ODE.Import

dGeomTriMeshSetArrayCallback

ODE.Import

dGeomTriMeshSetCallback

ODE.Import

dGeomTriMeshSetData

ODE.Import

dGeomTriMeshSetRayCallback

ODE.Import

dgettext

gnugettext

dgettext_NoExtract

gnugettext

dHashSpaceClass

ODE.Import

dHashSpaceCreate

ODE.Import

dHashSpaceGetLevels

ODE.Import

dHashSpaceSetLevels

ODE.Import

dHeightFieldClass

ODE.Import

dInfiniteAABB

ODE.Import

dInitODE

ODE.Import

added by PAR

dInitODE2

ODE.Import

DisabledDebugCollision

ODE.Import

DisabledDebugGeom

ODE.Import

DISABLE_NODE

Formats.m3DSConst

DistanceBetweenAngles

GLScene.VectorGeometry

Calculates the angular distance between two angles in radians. Result is in the [0; PI] range.

DistanceCueMax3DS

Formats.m3DSConst

minimum value for dimming factor

DistanceCueMin3DS

Formats.m3DSConst

maximum value for fogging plane density DISTANCE_CUE

DISTANCE_CUE

Formats.m3DSConst

Div2

GLS.Graphics

DivideVector

GLScene.VectorGeometry

DivideVector

GLScene.VectorGeometry

Divides given vector by another vector. v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.

DivMod

GLScene.VectorGeometry

dJointAddAMotorTorques

ODE.Import

dJointAddHinge2Torques

ODE.Import

dJointAddHingeTorque

ODE.Import

dJointAddPistonForce

ODE.Import

dJointAddPRTorque

ODE.Import

dJointAddSliderForce

ODE.Import

dJointAddUniversalTorques

ODE.Import

dJointAttach

ODE.Import

dJointCorrectHinge2

ODE.Import

dJointCreateAMotor

ODE.Import

AMotor

dJointCreateBall

ODE.Import

Ball

dJointCreateContact

ODE.Import

Contact

dJointCreateFixed

ODE.Import

Fixed

dJointCreateHinge

ODE.Import

Hinge

dJointCreateHinge2

ODE.Import

Hinge2

dJointCreateLMotor

ODE.Import

LMotor

dJointCreatePiston

ODE.Import

Piston

dJointCreatePlane2D

ODE.Import

Plane2D

dJointCreatePR

ODE.Import

PR

dJointCreateSlider

ODE.Import

Slider

dJointCreateUniversal

ODE.Import

Universal

dJointDestroy

ODE.Import

dJointGetAMotorAngle

ODE.Import

dJointGetAMotorAngleRate

ODE.Import

dJointGetAMotorAxis

ODE.Import

dJointGetAMotorAxisRel

ODE.Import

dJointGetAMotorMode

ODE.Import

dJointGetAMotorNumAxes

ODE.Import

dJointGetAMotorParam

ODE.Import

dJointGetBallAnchor

ODE.Import

dJointGetBallAnchor2

ODE.Import

dJointGetBody

ODE.Import

dJointGetData

ODE.Import

dJointGetFeedback

ODE.Import

dJointGetHinge2Anchor

ODE.Import

dJointGetHinge2Anchor2

ODE.Import

dJointGetHinge2Angle1

ODE.Import

dJointGetHinge2Angle1Rate

ODE.Import

dJointGetHinge2Angle2Rate

ODE.Import

dJointGetHinge2Axis1

ODE.Import

dJointGetHinge2Axis2

ODE.Import

dJointGetHinge2Param

ODE.Import

dJointGetHingeAnchor

ODE.Import

dJointGetHingeAnchor2

ODE.Import

dJointGetHingeAngle

ODE.Import

dJointGetHingeAngleRate

ODE.Import

dJointGetHingeAxis

ODE.Import

dJointGetHingeParam

ODE.Import

dJointGetLMotorAxis

ODE.Import

dJointGetLMotorNumAxes

ODE.Import

dJointGetLMotorParam

ODE.Import

dJointGetPistonAnchor

ODE.Import

dJointGetPistonAnchor2

ODE.Import

dJointGetPistonAngle

ODE.Import

dJointGetPistonAngleRate

ODE.Import

dJointGetPistonAxis

ODE.Import

dJointGetPistonParam

ODE.Import

dJointGetPistonPosition

ODE.Import

dJointGetPistonRate

ODE.Import

dJointGetPRAxis1

ODE.Import

dJointGetPRAxis2

ODE.Import

dJointGetPRParam

ODE.Import

dJointGetSliderAxis

ODE.Import

dJointGetSliderParam

ODE.Import

dJointGetSliderPosition

ODE.Import

dJointGetSliderPositionRate

ODE.Import

dJointGetType

ODE.Import

dJointGetUniversalAnchor

ODE.Import

dJointGetUniversalAnchor2

ODE.Import

dJointGetUniversalAngle1

ODE.Import

dJointGetUniversalAngle1Rate

ODE.Import

dJointGetUniversalAngle2

ODE.Import

dJointGetUniversalAngle2Rate

ODE.Import

dJointGetUniversalAxis1

ODE.Import

dJointGetUniversalAxis2

ODE.Import

dJointGetUniversalParam

ODE.Import

dJointGroupCreate

ODE.Import

dJointGroupDestroy

ODE.Import

—– dJoint —– normal joints

dJointGroupEmpty

ODE.Import

dJointSetAMotorAngle

ODE.Import

dJointSetAMotorAxis

ODE.Import

dJointSetAMotorMode

ODE.Import

dJointSetAMotorNumAxes

ODE.Import

dJointSetAMotorParam

ODE.Import

dJointSetBallAnchor

ODE.Import

dJointSetData

ODE.Import

dJointSetFeedback

ODE.Import

callback routines for feedback of joints

dJointSetFixed

ODE.Import

dJointSetHinge2Anchor

ODE.Import

dJointSetHinge2Axis1

ODE.Import

dJointSetHinge2Axis2

ODE.Import

dJointSetHinge2Param

ODE.Import

dJointSetHingeAnchor

ODE.Import

dJointSetHingeAxis

ODE.Import

dJointSetHingeParam

ODE.Import

dJointSetLMotorAxis

ODE.Import

dJointSetLMotorNumAxes

ODE.Import

dJointSetLMotorParam

ODE.Import

dJointSetPistonAnchor

ODE.Import

dJointSetPistonAxis

ODE.Import

dJointSetPistonAxisDelta

ODE.Import

dJointSetPistonParam

ODE.Import

dJointSetPlane2DAngleParam

ODE.Import

dJointSetPlane2DXParam

ODE.Import

dJointSetPlane2DYParam

ODE.Import

dJointSetPRAnchor

ODE.Import

dJointSetPRAxis1

ODE.Import

dJointSetPRAxis2

ODE.Import

dJointSetPRParam

ODE.Import

dJointSetSliderAxis

ODE.Import

dJointSetSliderParam

ODE.Import

dJointSetUniversalAnchor

ODE.Import

dJointSetUniversalAxis1

ODE.Import

dJointSetUniversalAxis2

ODE.Import

dJointSetUniversalParam

ODE.Import

dJOINT_INGROUP

ODE.Import

These consts now have defined types if this flag is set, the joint was allocated in a joint group

dJOINT_REVERSE

ODE.Import

if this flag is set, the joint was attached with arguments (0,body). our convention is to treat all attaches as (body,0), i.e. so node[0].body is always nonzero, so this flag records the fact that the arguments were swapped

dJOINT_TWOBODIES

ODE.Import

if this flag is set, the joint can not have just one body attached to it, it must have either zero or two bodies attached

dLastSpaceClass

ODE.Import

dLastUserClass

ODE.Import

DLLocalShadow2FMax3DS

Formats.m3DSConst

minimum shadow map size

DLLocalShadow2FMin3DS

Formats.m3DSConst

maximum shadow map size

DLLocalShadow2SMax3DS

Formats.m3DSConst

minimum shadow map size

DLLocalShadow2SMin3DS

Formats.m3DSConst

maximum for hotspot and falloff cones DL_LOCAL_SHADOW2

dLong

Newton.Import

DLSpotlightMax3DS

Formats.m3DSConst

minimum for hotspot and falloff cones

DLSpotlightMin3DS

Formats.m3DSConst

maximum string length for axp process DL_SPOTLIGHT

DL_ATTENUATE

Formats.m3DSConst

DL_EXCLUDE

Formats.m3DSConst

DL_INNER_RANGE

Formats.m3DSConst

DL_LOCAL_SHADOW

Formats.m3DSConst

DL_LOCAL_SHADOW2

Formats.m3DSConst

DL_MULTIPLIER

Formats.m3DSConst

DL_OFF

Formats.m3DSConst

DL_OUTER_RANGE

Formats.m3DSConst

DL_RANGE

Formats.m3DSConst

DL_RAYSHAD

Formats.m3DSConst

DL_RAY_BIAS

Formats.m3DSConst

DL_SEE_CONE

Formats.m3DSConst

DL_SHADOWED

Formats.m3DSConst

DL_SPOTLIGHT

Formats.m3DSConst

DL_SPOT_ASPECT

Formats.m3DSConst

DL_SPOT_OVERSHOOT

Formats.m3DSConst

DL_SPOT_PROJECTOR

Formats.m3DSConst

DL_SPOT_RECTANGULAR

Formats.m3DSConst

DL_SPOT_ROLL

Formats.m3DSConst

Not used in R3

dMakeRandomMatrix

ODE.Import

dMakeRandomVector

ODE.Import

dMassAdd

ODE.Import

dMassAdjust

ODE.Import

dMassRotate

ODE.Import

dMassSetBox

ODE.Import

dMassSetBoxTotal

ODE.Import

dMassSetCapsule

ODE.Import

dMassSetCapsuleTotal

ODE.Import

dMassSetCylinder

ODE.Import

dMassSetCylinderTotal

ODE.Import

dMassSetParameters

ODE.Import

—– dMass —–

dMassSetSphere

ODE.Import

dMassSetSphereTotal

ODE.Import

dMassSetTrimesh

ODE.Import

dMassSetTrimeshTotal

ODE.Import

dMassSetZero

ODE.Import

dMassTranslate

ODE.Import

dMaxDifference

ODE.Import

dMultiply0

ODE.Import

dMULTIPLY0_331

ODE.Import

dMULTIPLY0_333

ODE.Import

dMultiply1

ODE.Import

dMultiply2

ODE.Import

dngettext

gnugettext

dNormalize3

ODE.Import

—– Math —–

dNormalize4

ODE.Import

DomainString

gnugettext

DoTesselate

GLS.PolygonTesselation

Tesselates the polygon outlined by the Vertexes. And adds them to the first facegroup of the Mesh.

DoubleElement

CUDA.DataAccess

DOWNLOADPROC

BASS.Import

User file stream callback function. action : The action to perform, one of BASS_FILE_xxx values. param1 : Depends on "action" param2 : Depends on "action" user : The 'user' parameter value given when calling BASS_StreamCreate RETURN : Depends on "action"

dParamBounce

ODE.Import

dParamBounce1

ODE.Import

dParamBounce2

ODE.Import

dParamBounce3

ODE.Import

dParamCFM

ODE.Import

dParamCFM1

ODE.Import

dParamCFM2

ODE.Import

dParamCFM3

ODE.Import

dParamERP

ODE.Import

dParamERP1

ODE.Import

dParamERP2

ODE.Import

dParamERP3

ODE.Import

dParamFMax

ODE.Import

dParamFMax1

ODE.Import

dParamFMax2

ODE.Import

dParamFMax3

ODE.Import

dParamFudgeFactor

ODE.Import

dParamFudgeFactor1

ODE.Import

dParamFudgeFactor2

ODE.Import

dParamFudgeFactor3

ODE.Import

dParamGroup

ODE.Import

dParamGroup1

ODE.Import

dParamGroup2

ODE.Import

SECOND AXEL parameters for limits and motors

dParamGroup3

ODE.Import

THIRD AXEL parameters for limits and motors

dParamHiStop

ODE.Import

dParamHiStop1

ODE.Import

dParamHiStop2

ODE.Import

dParamHiStop3

ODE.Import

dParamLoStop

ODE.Import

dParamLoStop1

ODE.Import

dParamLoStop2

ODE.Import

dParamLoStop3

ODE.Import

dParamStopCFM

ODE.Import

dParamStopCFM1

ODE.Import

dParamStopCFM2

ODE.Import

dParamStopCFM3

ODE.Import

dParamStopERP

ODE.Import

dParamStopERP1

ODE.Import

dParamStopERP2

ODE.Import

dParamStopERP3

ODE.Import

dParamSuspensionCFM

ODE.Import

dParamSuspensionCFM1

ODE.Import

dParamSuspensionCFM2

ODE.Import

dParamSuspensionCFM3

ODE.Import

dParamSuspensionERP

ODE.Import

parameters for suspension

dParamSuspensionERP1

ODE.Import

parameters for suspension

dParamSuspensionERP2

ODE.Import

parameters for suspension

dParamSuspensionERP3

ODE.Import

parameters for suspension

dParamVel

ODE.Import

dParamVel1

ODE.Import

dParamVel2

ODE.Import

dParamVel3

ODE.Import

dPlaneClass

ODE.Import

dQFromAxisAndAngle

ODE.Import

—– Rotation.h —–

dQfromR

ODE.Import

dQMultiply0

ODE.Import

dQMultiply1

ODE.Import

dQMultiply2

ODE.Import

dQMultiply3

ODE.Import

dQSetIdentity

ODE.Import

dQuadTreeSpaceClass

ODE.Import

dQuadTreeSpaceCreate

ODE.Import

dRandGetSeed

ODE.Import

dRandInt

ODE.Import

dRandReal

ODE.Import

dRandSetSeed

ODE.Import

DrawBox

GLS.ODEUtils

DrawContours

GLS.ROAMPatch

Draw contours on rendering terrain patches

DrawDibBegin

Formats.VFW

– DrawDibBegin() - prepare to draw —————————————–

DrawDibChangePalette

Formats.VFW

– DrawDibChangePalette() —————————————————

DrawDibClose

Formats.VFW

– DrawDibClose() ———————————————————–

DrawDibDraw

Formats.VFW

– DrawDibDraw() - actually draw a DIB to the screen ————————

DrawDibEnd

Formats.VFW

– DrawDibEnd() ————————————————————-

DrawDibGetBuffer

Formats.VFW

– DrawDibGetBuffer() ——————————————————-

DrawDibGetPalette

Formats.VFW

– DrawDibGetPalette() - get the palette used for drawing DIBs ————–

DrawDibOpen

Formats.VFW

– DrawDibOpen() ————————————————————

DrawDibProfileDisplay

Formats.VFW

...

DrawDibRealize

Formats.VFW

– DrawDibRealize() - realize the palette in a HDD ————————–

DrawDibSetPalette

Formats.VFW

– DrawDibSetPalette() - set the palette used for drawing DIBs ————–

DrawDibStart

Formats.VFW

– DrawDibStart() - start of streaming playback —————————–

DrawDibStop

Formats.VFW

– DrawDibStop() - start of streaming playback ——————————

DrawDibTime

Formats.VFW

DrawDibUpdate

Formats.VFW

– DrawDibUpdate() - redraw last image (may only be valid with DDF_BUFFER) –

DrawTexturedScreenQuad

GLSL.CustomShader

Probably need to give them proper names, instead of numbers...

DrawTexturedScreenQuad2

GLSL.CustomShader

DrawTexturedScreenQuad3

GLSL.CustomShader

DrawTexturedScreenQuad4

GLSL.CustomShader

DrawTexturedScreenQuad5

GLSL.CustomShader

DrawTexturedScreenQuad6

GLSL.CustomShader

dRayClass

ODE.Import

dRFrom2Axes

ODE.Import

dRFromAxisAndAngle

ODE.Import

dRFromEulerAngles

ODE.Import

dRfromQ

ODE.Import

dRFromZAxis

ODE.Import

dRSetIdentity

ODE.Import

DSCAPS_CERTIFIED

BASS.Import

device does not have hardware DirectSound support

DSCAPS_EMULDRIVER

BASS.Import

BASS_INFO flags (from DSOUND.H)

DSCAPS_HARDWARE

BASS.Import

device driver has been certified by Microsoft

DSCCAPS_CERTIFIED

BASS.Import

device does not have hardware DirectSound recording support

DSCCAPS_EMULDRIVER

BASS.Import

hardware mixed BASS_RECORDINFO flags (from DSOUND.H)

dsDrawBox

GLS.ODEUtils

dsDrawBox

GLS.ODEUtils

dSimpleSpaceClass

ODE.Import

dSimpleSpaceCreate

ODE.Import

dSpaceAdd

ODE.Import

dSpaceClean

ODE.Import

dSpaceCollide

ODE.Import

dSpaceCollide2

ODE.Import

dSpaceDestroy

ODE.Import

—– dSpace —–

dSpaceGetCleanup

ODE.Import

dSpaceGetGeom

ODE.Import

dSpaceGetNumGeoms

ODE.Import

dSpaceQuery

ODE.Import

dSpaceRemove

ODE.Import

dSpaceSetCleanup

ODE.Import

dSphereClass

ODE.Import

DSPPROC

BASS.Import

Sync callback function. NOTE: a sync callback function should be very quick as other syncs cannot be processed until it has finished. If the sync is a "mixtime" sync, then other streams and MOD musics can not be mixed until it's finished either. handle : The sync that has occured channel: Channel that the sync occured in data : Additional data associated with the sync's occurance user : The 'user' parameter given when calling BASS_ChannelSetSync

DSPROPERTY_EAXBUFFER_AIRABSORPTIONFACTOR

OpenAL.Import

DSPROPERTY_EAXBUFFER_ALLPARAMETERS

OpenAL.Import

DSPROPERTY_EAXBUFFER_COMMITDEFERREDSETTINGS

OpenAL.Import

DSPROPERTY_EAXBUFFER_DEFERRED

OpenAL.Import

changes take effect immediately

DSPROPERTY_EAXBUFFER_DIRECT

OpenAL.Import

DSPROPERTY_EAXBUFFER_DIRECTHF

OpenAL.Import

DSPROPERTY_EAXBUFFER_FLAG

OpenAL.Import

DSPROPERTY_EAXBUFFER_IMMEDIATE

OpenAL.Import

OR these flags with property id

DSPROPERTY_EAXBUFFER_NONE

OpenAL.Import

For compatibility with future EAX versions: DSPROPSETID_EAX_BufferProperties = DSPROPSETID_EAX20_BufferProperties; Enumeration DSPROPERTY_EAX_BUFFERPROPERTY

DSPROPERTY_EAXBUFFER_OBSTRUCTION

OpenAL.Import

DSPROPERTY_EAXBUFFER_OBSTRUCTIONLFRATIO

OpenAL.Import

DSPROPERTY_EAXBUFFER_OCCLUSION

OpenAL.Import

DSPROPERTY_EAXBUFFER_OCCLUSIONLFRATIO

OpenAL.Import

DSPROPERTY_EAXBUFFER_OCCLUSIONROOMRATIO

OpenAL.Import

DSPROPERTY_EAXBUFFER_OUTSIDEVOLUMEHF

OpenAL.Import

DSPROPERTY_EAXBUFFER_ROOM

OpenAL.Import

DSPROPERTY_EAXBUFFER_ROOMHF

OpenAL.Import

DSPROPERTY_EAXBUFFER_ROOMROLLOFFFACTOR

OpenAL.Import

DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF

OpenAL.Import

DSPROPERTY_EAXLISTENER_ALLPARAMETERS

OpenAL.Import

DSPROPERTY_EAXLISTENER_COMMITDEFERREDSETTINGS

OpenAL.Import

DSPROPERTY_EAXLISTENER_DECAYHFRATIO

OpenAL.Import

DSPROPERTY_EAXLISTENER_DECAYTIME

OpenAL.Import

DSPROPERTY_EAXLISTENER_DEFERRED

OpenAL.Import

changes take effect immediately

DSPROPERTY_EAXLISTENER_ENVIRONMENT

OpenAL.Import

DSPROPERTY_EAXLISTENER_ENVIRONMENTDIFFUSION

OpenAL.Import

DSPROPERTY_EAXLISTENER_ENVIRONMENTSIZE

OpenAL.Import

DSPROPERTY_EAXLISTENER_FLAGS

OpenAL.Import

DSPROPERTY_EAXLISTENER_IMMEDIATE

OpenAL.Import

OR these flags with property id

DSPROPERTY_EAXLISTENER_NONE

OpenAL.Import

For compatibility with future EAX versions: DSPROPSETID_EAX_ListenerProperties = DSPROPSETID_EAX20_ListenerProperties; DSPROPSETID_EAX_SourceProperties = DSPROPSETID_EAX20_BufferProperties; Enumerations DSPROPERTY_EAX_LISTENERPROPERTY

DSPROPERTY_EAXLISTENER_REFLECTIONS

OpenAL.Import

DSPROPERTY_EAXLISTENER_REFLECTIONSDELAY

OpenAL.Import

DSPROPERTY_EAXLISTENER_REVERB

OpenAL.Import

DSPROPERTY_EAXLISTENER_REVERBDELAY

OpenAL.Import

DSPROPERTY_EAXLISTENER_ROOM

OpenAL.Import

DSPROPERTY_EAXLISTENER_ROOMHF

OpenAL.Import

DSPROPERTY_EAXLISTENER_ROOMROLLOFFFACTOR

OpenAL.Import

DSPROPERTY_EAX_BUFFERPROPERTY

OpenAL.Import

DSPROPERTY_EAX_LISTENERPROPERTY

OpenAL.Import

EAX extension

DSPROPSETID_EAX20_BufferProperties

OpenAL.Import

DSPROPSETID_EAX20_ListenerProperties

OpenAL.Import

END EFX extension EAX extension

dSweepAndPruneSpaceClass

ODE.Import

dTestMatrixComparison

ODE.Import

dTestRand

ODE.Import

return 1 if the random number generator is working.

dTestSolveLCP

ODE.Import

DTriangle

GLScene.Triangulation

Created Triangles, vv# are the vertex pointers

dTriMeshClass

ODE.Import

DUMMY

Formats.m3DSConst

Dummy Chunk that sometimes appears in 3DS files created by prerelease 3D Studio R2

DummyName3DS

Formats.m3DSConst

DumpChunk

Formats.m3DSUtils

DumpKeyHeader

Formats.m3DSUtils

dVector3Length

GLS.ODEUtils

dVector3Length

GLS.ODEUtils

DVertex

GLScene.Triangulation

Points (Vertices)

DVM_CONFIGURE_END

Formats.VFW

DVM_CONFIGURE_START

Formats.VFW

DVM_DST_RECT

Formats.VFW

DVM_FORMAT

Formats.VFW

DVM_PALETTE

Formats.VFW

DVM_PALETTERGB555

Formats.VFW

DVM_SRC_RECT

Formats.VFW

DVM_USER

Formats.VFW

== Configure messages =======================================================

DV_ERR_13

Formats.VFW

DV_ERR_ALLOCATED

Formats.VFW

out of memory

DV_ERR_BADDEVICEID

Formats.VFW

device is allocated

DV_ERR_BADERRNUM

Formats.VFW

DV_ERR_BADFORMAT

Formats.VFW

DV_ERR_BADINSTALL

Formats.VFW

HW not detected

DV_ERR_BASE

Formats.VFW

No error

DV_ERR_CONFIG1

Formats.VFW

DV_ERR_CONFIG2

Formats.VFW

DV_ERR_CREATEPALETTE

Formats.VFW

Can not get Profile

DV_ERR_DMA_CONFLICT

Formats.VFW

I/O conflict detected

DV_ERR_FLAGS

Formats.VFW

DV_ERR_INT_CONFLICT

Formats.VFW

DMA conflict detected

DV_ERR_INVALHANDLE

Formats.VFW

DV_ERR_IO_CONFLICT

Formats.VFW

Mem conflict detected

DV_ERR_LASTERROR

Formats.VFW

Can not run in standard mode

DV_ERR_MEM_CONFLICT

Formats.VFW

out of buffers

DV_ERR_NOMEM

Formats.VFW

function not suported

DV_ERR_NONSPECIFIC

Formats.VFW

Error Base

DV_ERR_NOTDETECTED

Formats.VFW

number of channels exceeded

DV_ERR_NOTSUPPORTED

Formats.VFW

DV_ERR_NO_BUFFERS

Formats.VFW

DV_ERR_OK

Formats.VFW

– Error return values ——————————————————

DV_ERR_PARAM1

Formats.VFW

DV_ERR_PARAM2

Formats.VFW

DV_ERR_PROTECT_ONLY

Formats.VFW

Interrupt conflict detected

DV_ERR_SIZEFIELD

Formats.VFW

DV_ERR_STILLPLAYING

Formats.VFW

unsupported video format

DV_ERR_SYNC

Formats.VFW

header not prepared

DV_ERR_TOOMANYCHANNELS

Formats.VFW

device is synchronous

DV_ERR_UNPREPARED

Formats.VFW

still something playing

DV_ERR_USER_MSG

Formats.VFW

DV_VM_CLOSE

Formats.VFW

Obsolete messages

DV_VM_DATA

Formats.VFW

DV_VM_ERROR

Formats.VFW

DV_VM_OPEN

Formats.VFW

Note that the values for all installable driver callback messages are identical, (ie. MM_DRVM_DATA has the same value for capture drivers, installable video codecs, and the audio compression manager).

DWORD

BASS.Import

DWord

SDL.Import

dWorldCreate

ODE.Import

—– dWorld —–

dWorldDestroy

ODE.Import

dWorldExportDIF

ODE.Import

dWorldGetAngularDamping

ODE.Import

dWorldGetAngularDampingThreshold

ODE.Import

dWorldGetAutoDisableAngularAverageThreshold

ODE.Import

dWorldGetAutoDisableAngularThreshold

ODE.Import

dWorldGetAutoDisableAverageSamplesCount

ODE.Import

dWorldGetAutoDisableFlag

ODE.Import

dWorldGetAutoDisableLinearAverageThreshold

ODE.Import

Auto-disable functions

dWorldGetAutoDisableLinearThreshold

ODE.Import

dWorldGetAutoDisableSteps

ODE.Import

dWorldGetAutoDisableTime

ODE.Import

dWorldGetCFM

ODE.Import

dWorldGetContactMaxCorrectingVel

ODE.Import

dWorldGetContactSurfaceLayer

ODE.Import

dWorldGetERP

ODE.Import

dWorldGetGravity

ODE.Import

dWorldGetLinearDamping

ODE.Import

dWorldGetLinearDampingThreshold

ODE.Import

Damping

dWorldGetMaxAngularSpeed

ODE.Import

dWorldGetQuickStepNumIterations

ODE.Import

dWorldGetQuickStepW

ODE.Import

dWorldImpulseToForce

ODE.Import

dWorldQuickStep

ODE.Import

QuickStep

dWorldSetAngularDamping

ODE.Import

dWorldSetAngularDampingThreshold

ODE.Import

dWorldSetAutoDisableAngularAverageThreshold

ODE.Import

dWorldSetAutoDisableAngularThreshold

ODE.Import

dWorldSetAutoDisableAverageSamplesCount

ODE.Import

dWorldSetAutoDisableFlag

ODE.Import

dWorldSetAutoDisableLinearAverageThreshold

ODE.Import

dWorldSetAutoDisableLinearThreshold

ODE.Import

dWorldSetAutoDisableSteps

ODE.Import

dWorldSetAutoDisableTime

ODE.Import

dWorldSetCFM

ODE.Import

dWorldSetContactMaxCorrectingVel

ODE.Import

dWorldSetContactSurfaceLayer

ODE.Import

dWorldSetDamping

ODE.Import

dWorldSetERP

ODE.Import

dWorldSetGravity

ODE.Import

dWorldSetLinearDamping

ODE.Import

dWorldSetLinearDampingThreshold

ODE.Import

dWorldSetMaxAngularSpeed

ODE.Import

dWorldSetQuickStepNumIterations

ODE.Import

dWorldSetQuickStepW

ODE.Import

dWorldStep

ODE.Import

Step

DW_ERROR

BASS.Import

Use these to test for error from functions that return a DWORD or QWORD

dxBodyDisabled

ODE.Import

use finite rotations only along axis

dxBodyFlagFiniteRotation

ODE.Import

These consts now have defined types

dxBodyFlagFiniteRotationAxis

ODE.Import

use finite rotations

dxBodyNoGravity

ODE.Import

body is disabled

DXGI_FORMAT_A8_UNORM

Formats.DXTC

DXGI_FORMAT_B5G5R5A1_UNORM

Formats.DXTC

DXGI_FORMAT_B5G6R5_UNORM

Formats.DXTC

DXGI_FORMAT_B8G8R8A8_TYPELESS

Formats.DXTC

DXGI_FORMAT_B8G8R8A8_UNORM

Formats.DXTC

DXGI_FORMAT_B8G8R8A8_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_B8G8R8X8_TYPELESS

Formats.DXTC

DXGI_FORMAT_B8G8R8X8_UNORM

Formats.DXTC

DXGI_FORMAT_B8G8R8X8_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_BC1_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC1_UNORM

Formats.DXTC

DXGI_FORMAT_BC1_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_BC2_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC2_UNORM

Formats.DXTC

DXGI_FORMAT_BC2_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_BC3_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC3_UNORM

Formats.DXTC

DXGI_FORMAT_BC3_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_BC4_SNORM

Formats.DXTC

DXGI_FORMAT_BC4_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC4_UNORM

Formats.DXTC

DXGI_FORMAT_BC5_SNORM

Formats.DXTC

DXGI_FORMAT_BC5_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC5_UNORM

Formats.DXTC

DXGI_FORMAT_BC6H_SF16

Formats.DXTC

DXGI_FORMAT_BC6H_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC6H_UF16

Formats.DXTC

DXGI_FORMAT_BC7_TYPELESS

Formats.DXTC

DXGI_FORMAT_BC7_UNORM

Formats.DXTC

DXGI_FORMAT_BC7_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_D16_UNORM

Formats.DXTC

DXGI_FORMAT_D24_UNORM_S8_UINT

Formats.DXTC

DXGI_FORMAT_D32_FLOAT

Formats.DXTC

DXGI_FORMAT_D32_FLOAT_S8X24_UINT

Formats.DXTC

DXGI_FORMAT_FORCE_UINT

Formats.DXTC

TDXGI_FORMAT = (

DXGI_FORMAT_G8R8_G8B8_UNORM

Formats.DXTC

DXGI_FORMAT_R10G10B10A2_TYPELESS

Formats.DXTC

DXGI_FORMAT_R10G10B10A2_UINT

Formats.DXTC

DXGI_FORMAT_R10G10B10A2_UNORM

Formats.DXTC

DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM

Formats.DXTC

DXGI_FORMAT_R11G11B10_FLOAT

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_FLOAT

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_SINT

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_SNORM

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_TYPELESS

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_UINT

Formats.DXTC

DXGI_FORMAT_R16G16B16A16_UNORM

Formats.DXTC

DXGI_FORMAT_R16G16_FLOAT

Formats.DXTC

DXGI_FORMAT_R16G16_SINT

Formats.DXTC

DXGI_FORMAT_R16G16_SNORM

Formats.DXTC

DXGI_FORMAT_R16G16_TYPELESS

Formats.DXTC

DXGI_FORMAT_R16G16_UINT

Formats.DXTC

DXGI_FORMAT_R16G16_UNORM

Formats.DXTC

DXGI_FORMAT_R16_FLOAT

Formats.DXTC

DXGI_FORMAT_R16_SINT

Formats.DXTC

DXGI_FORMAT_R16_SNORM

Formats.DXTC

DXGI_FORMAT_R16_TYPELESS

Formats.DXTC

DXGI_FORMAT_R16_UINT

Formats.DXTC

DXGI_FORMAT_R16_UNORM

Formats.DXTC

DXGI_FORMAT_R1_UNORM

Formats.DXTC

DXGI_FORMAT_R24G8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R24_UNORM_X8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32G32B32A32_FLOAT

Formats.DXTC

DXGI_FORMAT_R32G32B32A32_SINT

Formats.DXTC

DXGI_FORMAT_R32G32B32A32_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32G32B32A32_UINT

Formats.DXTC

DXGI_FORMAT_R32G32B32_FLOAT

Formats.DXTC

DXGI_FORMAT_R32G32B32_SINT

Formats.DXTC

DXGI_FORMAT_R32G32B32_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32G32B32_UINT

Formats.DXTC

DXGI_FORMAT_R32G32_FLOAT

Formats.DXTC

DXGI_FORMAT_R32G32_SINT

Formats.DXTC

DXGI_FORMAT_R32G32_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32G32_UINT

Formats.DXTC

DXGI_FORMAT_R32G8X24_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32_FLOAT

Formats.DXTC

DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32_SINT

Formats.DXTC

DXGI_FORMAT_R32_TYPELESS

Formats.DXTC

DXGI_FORMAT_R32_UINT

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_SINT

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_SNORM

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_UINT

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_UNORM

Formats.DXTC

DXGI_FORMAT_R8G8B8A8_UNORM_SRGB

Formats.DXTC

DXGI_FORMAT_R8G8_B8G8_UNORM

Formats.DXTC

DXGI_FORMAT_R8G8_SINT

Formats.DXTC

DXGI_FORMAT_R8G8_SNORM

Formats.DXTC

DXGI_FORMAT_R8G8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R8G8_UINT

Formats.DXTC

DXGI_FORMAT_R8G8_UNORM

Formats.DXTC

DXGI_FORMAT_R8_SINT

Formats.DXTC

DXGI_FORMAT_R8_SNORM

Formats.DXTC

DXGI_FORMAT_R8_TYPELESS

Formats.DXTC

DXGI_FORMAT_R8_UINT

Formats.DXTC

DXGI_FORMAT_R8_UNORM

Formats.DXTC

DXGI_FORMAT_R9G9B9E5_SHAREDEXP

Formats.DXTC

DXGI_FORMAT_UNKNOWN

Formats.DXTC

DXGI_FORMAT_X24_TYPELESS_G8_UINT

Formats.DXTC

DXGI_FORMAT_X32_TYPELESS_G8X24_UINT

Formats.DXTC

DXT3AlphaBlock

Formats.DXTC

DXT5AlphaBlock

Formats.DXTC

DXTColBlock

Formats.DXTC

EAXBUFFERFLAGS_DIRECTHFAUTO

OpenAL.Import

Used by DSPROPERTY_EAXBUFFER_FLAGS TRUE: value is computed automatically - property is an offset FALSE: value is used directly
Note: The number and order of flags may change in future EAX versions. To insure future compatibility, use flag defines as follows: myFlags = EAXBUFFERFLAGS_DIRECTHFAUTO | EAXBUFFERFLAGS_ROOMAUTO; instead of: myFlags = 0x00000003;

EAXBUFFERFLAGS_RESERVED

OpenAL.Import

affects DSPROPERTY_EAXBUFFER_ROOMHF

EAXBUFFERFLAGS_ROOMAUTO

OpenAL.Import

affects DSPROPERTY_EAXBUFFER_DIRECTHF

EAXBUFFERFLAGS_ROOMHFAUTO

OpenAL.Import

affects DSPROPERTY_EAXBUFFER_ROOM

EAXBUFFER_DEFAULTAIRABSORPTIONFACTOR

OpenAL.Import

EAXBUFFER_DEFAULTDIRECT

OpenAL.Import

EAXBUFFER_DEFAULTDIRECTHF

OpenAL.Import

EAXBUFFER_DEFAULTFLAGS

OpenAL.Import

EAXBUFFER_DEFAULTOBSTRUCTION

OpenAL.Import

EAXBUFFER_DEFAULTOBSTRUCTIONLFRATIO

OpenAL.Import

EAXBUFFER_DEFAULTOCCLUSION

OpenAL.Import

EAXBUFFER_DEFAULTOCCLUSIONLFRATIO

OpenAL.Import

EAXBUFFER_DEFAULTOCCLUSIONROOMRATIO

OpenAL.Import

EAXBUFFER_DEFAULTOUTSIDEVOLUMEHF

OpenAL.Import

EAXBUFFER_DEFAULTROOM

OpenAL.Import

EAXBUFFER_DEFAULTROOMHF

OpenAL.Import

EAXBUFFER_DEFAULTROOMROLLOFFFACTOR

OpenAL.Import

EAXBUFFER_MAXAIRABSORPTIONFACTOR

OpenAL.Import

EAXBUFFER_MAXDIRECT

OpenAL.Import

EAXBUFFER_MAXDIRECTHF

OpenAL.Import

EAXBUFFER_MAXOBSTRUCTION

OpenAL.Import

EAXBUFFER_MAXOBSTRUCTIONLFRATIO

OpenAL.Import

EAXBUFFER_MAXOCCLUSION

OpenAL.Import

EAXBUFFER_MAXOCCLUSIONLFRATIO

OpenAL.Import

EAXBUFFER_MAXOCCLUSIONROOMRATIO

OpenAL.Import

EAXBUFFER_MAXOUTSIDEVOLUMEHF

OpenAL.Import

EAXBUFFER_MAXROOM

OpenAL.Import

EAXBUFFER_MAXROOMHF

OpenAL.Import

EAXBUFFER_MAXROOMROLLOFFFACTOR

OpenAL.Import

EAXBUFFER_MINAIRABSORPTIONFACTOR

OpenAL.Import

EAXBUFFER_MINDIRECT

OpenAL.Import

reserved future use property ranges and defaults:

EAXBUFFER_MINDIRECTHF

OpenAL.Import

EAXBUFFER_MINOBSTRUCTION

OpenAL.Import

EAXBUFFER_MINOBSTRUCTIONLFRATIO

OpenAL.Import

EAXBUFFER_MINOCCLUSION

OpenAL.Import

EAXBUFFER_MINOCCLUSIONLFRATIO

OpenAL.Import

EAXBUFFER_MINOCCLUSIONROOMRATIO

OpenAL.Import

EAXBUFFER_MINOUTSIDEVOLUMEHF

OpenAL.Import

EAXBUFFER_MINROOM

OpenAL.Import

EAXBUFFER_MINROOMHF

OpenAL.Import

EAXBUFFER_MINROOMROLLOFFFACTOR

OpenAL.Import

EAXGet

OpenAL.Import

EAXGetBufferMode

OpenAL.Import

EAXLISTENERFLAGS_DECAYHFLIMIT

OpenAL.Import

late reverberation delay time This flag limits high-frequency decay time according to air absorption.

EAXLISTENERFLAGS_DECAYTIMESCALE

OpenAL.Import

Used by DSPROPERTY_EAXLISTENER_FLAGS
Note: The number and order of flags may change in future EAX versions. It is recommended to use the flag defines as follows: myFlags = EAXLISTENERFLAGS_DECAYTIMESCALE | EAXLISTENERFLAGS_REVERBSCALE; instead of: myFlags = 0x00000009;
These flags determine what properties are affected by environment size.

EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE

OpenAL.Import

reflection level

EAXLISTENERFLAGS_REFLECTIONSSCALE

OpenAL.Import

reverberation decay time

EAXLISTENERFLAGS_RESERVED

OpenAL.Import

EAXLISTENERFLAGS_REVERBDELAYSCALE

OpenAL.Import

reflections level

EAXLISTENERFLAGS_REVERBSCALE

OpenAL.Import

initial reflection delay time

EAXLISTENER_DEFAULTAIRABSORPTIONHF

OpenAL.Import

EAXLISTENER_DEFAULTDECAYHFRATIO

OpenAL.Import

EAXLISTENER_DEFAULTDECAYTIME

OpenAL.Import

EAXLISTENER_DEFAULTENVIRONMENT

OpenAL.Import

EAXLISTENER_DEFAULTENVIRONMENTDIFFUSION

OpenAL.Import

EAXLISTENER_DEFAULTENVIRONMENTSIZE

OpenAL.Import

EAXLISTENER_DEFAULTFLAGS

OpenAL.Import

EAXLISTENER_DEFAULTREFLECTIONS

OpenAL.Import

EAXLISTENER_DEFAULTREFLECTIONSDELAY

OpenAL.Import

EAXLISTENER_DEFAULTREVERB

OpenAL.Import

EAXLISTENER_DEFAULTREVERBDELAY

OpenAL.Import

EAXLISTENER_DEFAULTROOM

OpenAL.Import

EAXLISTENER_DEFAULTROOMHF

OpenAL.Import

EAXLISTENER_DEFAULTROOMROLLOFFFACTOR

OpenAL.Import

EAXLISTENER_MAXAIRABSORPTIONHF

OpenAL.Import

EAXLISTENER_MAXDECAYHFRATIO

OpenAL.Import

EAXLISTENER_MAXDECAYTIME

OpenAL.Import

EAXLISTENER_MAXENVIRONMENT

OpenAL.Import

EAXLISTENER_MAXENVIRONMENTDIFFUSION

OpenAL.Import

EAXLISTENER_MAXENVIRONMENTSIZE

OpenAL.Import

EAXLISTENER_MAXREFLECTIONS

OpenAL.Import

EAXLISTENER_MAXREFLECTIONSDELAY

OpenAL.Import

EAXLISTENER_MAXREVERB

OpenAL.Import

EAXLISTENER_MAXREVERBDELAY

OpenAL.Import

EAXLISTENER_MAXROOM

OpenAL.Import

EAXLISTENER_MAXROOMHF

OpenAL.Import

EAXLISTENER_MAXROOMROLLOFFFACTOR

OpenAL.Import

EAXLISTENER_MINAIRABSORPTIONHF

OpenAL.Import

EAXLISTENER_MINDECAYHFRATIO

OpenAL.Import

EAXLISTENER_MINDECAYTIME

OpenAL.Import

EAXLISTENER_MINENVIRONMENT

OpenAL.Import

EAXLISTENER_MINENVIRONMENTDIFFUSION

OpenAL.Import

EAXLISTENER_MINENVIRONMENTSIZE

OpenAL.Import

EAXLISTENER_MINREFLECTIONS

OpenAL.Import

EAXLISTENER_MINREFLECTIONSDELAY

OpenAL.Import

EAXLISTENER_MINREVERB

OpenAL.Import

EAXLISTENER_MINREVERBDELAY

OpenAL.Import

EAXLISTENER_MINROOM

OpenAL.Import

reserved future use property ranges and defaults:

EAXLISTENER_MINROOMHF

OpenAL.Import

EAXLISTENER_MINROOMROLLOFFFACTOR

OpenAL.Import

EAXSet

OpenAL.Import

EAX functions

EAXSetBufferMode

OpenAL.Import

X-RAM functions

EAX_ENVIRONMENT_ALLEY

BASS.Import

EAX_ENVIRONMENT_ALLEY

OpenAL.Import

EAX_ENVIRONMENT_ARENA

BASS.Import

EAX_ENVIRONMENT_ARENA

OpenAL.Import

EAX_ENVIRONMENT_AUDITORIUM

BASS.Import

EAX_ENVIRONMENT_AUDITORIUM

OpenAL.Import

EAX_ENVIRONMENT_BATHROOM

BASS.Import

EAX_ENVIRONMENT_BATHROOM

OpenAL.Import

EAX_ENVIRONMENT_CARPETEDHALLWAY

BASS.Import

EAX_ENVIRONMENT_CARPETEDHALLWAY

OpenAL.Import

EAX_ENVIRONMENT_CAVE

BASS.Import

EAX_ENVIRONMENT_CAVE

OpenAL.Import

EAX_ENVIRONMENT_CITY

BASS.Import

EAX_ENVIRONMENT_CITY

OpenAL.Import

EAX_ENVIRONMENT_CONCERTHALL

BASS.Import

EAX_ENVIRONMENT_CONCERTHALL

OpenAL.Import

EAX_ENVIRONMENT_COUNT

BASS.Import

total number of environments

EAX_ENVIRONMENT_COUNT

OpenAL.Import

EAX_ENVIRONMENT_DIZZY

BASS.Import

EAX_ENVIRONMENT_DIZZY

OpenAL.Import

EAX_ENVIRONMENT_DRUGGED

BASS.Import

EAX_ENVIRONMENT_DRUGGED

OpenAL.Import

EAX_ENVIRONMENT_FOREST

BASS.Import

EAX_ENVIRONMENT_FOREST

OpenAL.Import

EAX_ENVIRONMENT_GENERIC

BASS.Import

EAX environments, use with BASS_SetEAXParameters

EAX_ENVIRONMENT_GENERIC

OpenAL.Import

used by DSPROPERTY_EAXLISTENER_ENVIRONMENT Enummetation

EAX_ENVIRONMENT_HALLWAY

BASS.Import

EAX_ENVIRONMENT_HALLWAY

OpenAL.Import

EAX_ENVIRONMENT_HANGAR

BASS.Import

EAX_ENVIRONMENT_HANGAR

OpenAL.Import

EAX_ENVIRONMENT_LIVINGROOM

BASS.Import

EAX_ENVIRONMENT_LIVINGROOM

OpenAL.Import

EAX_ENVIRONMENT_MOUNTAINS

BASS.Import

EAX_ENVIRONMENT_MOUNTAINS

OpenAL.Import

EAX_ENVIRONMENT_PADDEDCELL

BASS.Import

EAX_ENVIRONMENT_PADDEDCELL

OpenAL.Import

EAX_ENVIRONMENT_PARKINGLOT

BASS.Import

EAX_ENVIRONMENT_PARKINGLOT

OpenAL.Import

EAX_ENVIRONMENT_PLAIN

BASS.Import

EAX_ENVIRONMENT_PLAIN

OpenAL.Import

EAX_ENVIRONMENT_PSYCHOTIC

BASS.Import

EAX_ENVIRONMENT_PSYCHOTIC

OpenAL.Import

EAX_ENVIRONMENT_QUARRY

BASS.Import

EAX_ENVIRONMENT_QUARRY

OpenAL.Import

EAX_ENVIRONMENT_ROOM

BASS.Import

EAX_ENVIRONMENT_ROOM

OpenAL.Import

EAX_ENVIRONMENT_SEWERPIPE

BASS.Import

EAX_ENVIRONMENT_SEWERPIPE

OpenAL.Import

EAX_ENVIRONMENT_STONECORRIDOR

BASS.Import

EAX_ENVIRONMENT_STONECORRIDOR

OpenAL.Import

EAX_ENVIRONMENT_STONEROOM

BASS.Import

EAX_ENVIRONMENT_STONEROOM

OpenAL.Import

EAX_ENVIRONMENT_UNDERWATER

BASS.Import

EAX_ENVIRONMENT_UNDERWATER

OpenAL.Import

EAX_MATERIAL_BRICKWALL

OpenAL.Import

Brick wall material preset

EAX_MATERIAL_BRICKWALLLF

OpenAL.Import

EAX_MATERIAL_BRICKWALLROOMRATIO

OpenAL.Import

EAX_MATERIAL_CURTAIN

OpenAL.Import

Curtain material preset

EAX_MATERIAL_CURTAINLF

OpenAL.Import

EAX_MATERIAL_CURTAINROOMRATIO

OpenAL.Import

EAX_MATERIAL_DOUBLEWINDOW

OpenAL.Import

Double window material preset

EAX_MATERIAL_DOUBLEWINDOWHF

OpenAL.Import

EAX_MATERIAL_DOUBLEWINDOWROOMRATIO

OpenAL.Import

EAX_MATERIAL_SINGLEWINDOW

OpenAL.Import

Material transmission presets 3 values in this order: 1: occlusion (or obstruction) 2: occlusion LF Ratio (or obstruction LF Ratio) 3: occlusion Room Ratio Single window material preset

EAX_MATERIAL_SINGLEWINDOWLF

OpenAL.Import

EAX_MATERIAL_SINGLEWINDOWROOMRATIO

OpenAL.Import

EAX_MATERIAL_STONEWALL

OpenAL.Import

Stone wall material preset

EAX_MATERIAL_STONEWALLLF

OpenAL.Import

EAX_MATERIAL_STONEWALLROOMRATIO

OpenAL.Import

EAX_MATERIAL_THICKDOOR

OpenAL.Import

Thick door material preset

EAX_MATERIAL_THICKDOORLF

OpenAL.Import

EAX_MATERIAL_THICKDOORROOMRTATION

OpenAL.Import

EAX_MATERIAL_THINDOOR

OpenAL.Import

Thin door material preset

EAX_MATERIAL_THINDOORLF

OpenAL.Import

EAX_MATERIAL_THINDOORROOMRATIO

OpenAL.Import

EAX_MATERIAL_WOODWALL

OpenAL.Import

Wood wall material preset

EAX_MATERIAL_WOODWALLLF

OpenAL.Import

EAX_MATERIAL_WOODWALLROOMRATIO

OpenAL.Import

ECAddBox

GLS.DCE

Add a TriMesh box

ECAddEllipsoid

GLS.DCE

Add a static ellipsoid

ECAddFreeForm

GLS.DCE

Add freeform's octree data

ECAddTerrain

GLS.DCE

Add the terrain as a TriMesh

ECgBombShaderException

GLS.CgBombShader

ECgShaderException

GLS.CgShader

Define OutputCompilerWarnings to output Cg compiler warnings to a file. Useful for detecting bugs caused by using uninitialized value, implicit type cast, etc.

ECResetColliders

GLS.DCE

Set the collider lists to null

ECSetCollisionRange

GLS.DCE

———————- DCE Misc functions ————————— Calculate and set the collision range

EDDSException

Formats.DDSImage

EditGLTextureImage

GLS.TextureImageEditors

Invokes the editor for the given TGLTextureImage

EditStreamClone

Formats.VFW

EditStreamCopy

Formats.VFW

EditStreamCut

Formats.VFW

EditStreamPaste

Formats.VFW

EditStreamSetInfo

Formats.VFW

EditStreamSetInfoA

Formats.VFW

EditStreamSetInfoW

Formats.VFW

EditStreamSetName

Formats.VFW

EditStreamSetInfoA

EditStreamSetNameA

Formats.VFW

EditStreamSetNameW

Formats.VFW

EFFECTS_SELECTED

FmSceneEditor

EFilerException

GLScene.XCollection

EFXEAXREVERBPROPERTIES

OpenAL.Import

EFXLOWPASSFILTER

OpenAL.Import

EFXUtilLibHandle

OpenAL.Import

EGGAnsi2WideConvError

gnugettext

EGGComponentError

gnugettext

EGGIOError

gnugettext

EGGProgrammingError

gnugettext

EGLAtmosphereException

GLS.Atmosphere

EGLCameraController

GLS.CameraController

EGLConsoleException

GLS.Console

EGLContext

GLS.Context

EGLCustomShaderException

GLSL.CustomShader

EGLFile3DS

GLS.File3DS

EGLImageUtils

GLS.ImageUtils

EGLMotionBlurException

GLS.Blur

EGLOBJFileError

GLS.FileOBJ

EGLOSError

GLScene.Utils

EGLPostShaderHolderException

GLSL.PostEffects

EGLProxyException

GLS.ProxyObjects

EGLROAMException

GLS.ROAMPatch

Exception use by splitter for SafeTesselation

EGLShader

GLS.Context

EGLShaderException

GLS.Texture

EGLSLBumpShaderException

GLSL.BumpShaders

EGLSLDiffuseSpecularShaderException

GLSL.DiffuseSpecularShader

EGLSLShaderException

GLSL.Shader

EGLUtilsException

GLScene.Utils

EGnuGettext

gnugettext

EInvalidArchiveFile

GLS.ArchiveManager

EInvalidRasterFile

GLS.Graphics

EInvalidVectorFile

GLS.VectorFileObjects

EiselLemireStringToDouble

PasDblStrUtils

EiselLemireStringToDouble

PasDblStrUtils

EmptyHmgMatrix

GLScene.VectorGeometry

EmptyMatrix

GLScene.VectorGeometry

EncodeGLTextureTarget

GLScene.TextureFormat

EndFPUOnlySection

GLScene.VectorGeometry

Ends a FPU-only section. See BeginFPUOnlySection

ENVL_CHAN

Formats.LWO

SPAN

ENVL_KEY

Formats.LWO

POST

ENVL_NAME

Formats.LWO

CHAN

ENVL_POST

Formats.LWO

PRE-BEHAVIOUR

ENVL_PRE

Formats.LWO

ICON

ENVL_SPAN

Formats.LWO

KEY

EOpenALError

GLS.Sounds.OpenAL

EOpenGLError

GLS.OpenGLAdapter

EOpenGLError

GLScene.OpenGL4

EPasJSONMergeError

PasJSON

EPasJSONSyntaxError

PasJSON

EPBuffer

GLS.Context

EPSILON

GLScene.VectorGeometry

Some very small numbers

EPSILON2

GLScene.VectorGeometry

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB

GLScene.OpenGL4

ERROR_INVALID_PIXEL_TYPE_ARB

GLScene.OpenGL4

WGL_ARB_make_current_read

ERROR_INVALID_PIXEL_TYPE_EXT

GLScene.OpenGL4

WGL_EXT_make_current_read

ERROR_INVALID_PROFILE_ARB

GLScene.OpenGL4

ERROR_INVALID_PROFILE_ARB

GLScene.OpenGLTokens

ERROR_INVALID_VERSION_ARB

GLScene.OpenGL4

ERROR_INVALID_VERSION_ARB

GLScene.OpenGLTokens

ERR_MAX_ARGS

SDL.Import

ERR_MAX_STRLEN

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_error.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

ESDLError

GLS.SDL.Window

Generic SDL or SDLWindow exception

ETexture

GLS.Texture

ETextureCombinerError

GLS.TextureCombiners

ETGAException

GLS.FileTGA

EvalPolynom

GLScene.Polynomials

Computes polynom's value for given x

ExecutableFilename

gnugettext

ExponateCrap

GLS.Perlin

The function returning some integer based on the rootˆexponant concept, result is crap and is only for "random" usage... eg perlin.

ExPtTolerance

GLScene.Triangulation

ExtendedFrustumIntersectsBSphere

GLS.SpacePartition

Determines if a extended frustum intersects an BSphere

ExtendedFrustumMake

GLS.SpacePartition

Create an extended frustum from a number of values

ExtendedFrustumMakeFromSceneViewer

GLS.SpacePartition

ExtendedFrustumMakeFromSceneViewer

GLS.SpacePartition

Create an extended frustum from a GLSceneViewer - this makes the unit specific to the windows platform!

ExtractAABBCorners

GLScene.GeometryBB

Extract the corners from an AABB

ExtractFrustumFromModelViewProjection

GLScene.VectorGeometry

Extracts a TFrustum for combined modelview and projection matrices

EZBufferException

GLS.zBuffer

FaceABVisable3DS

Formats.m3DSConst

flags the BC edge as visible

FaceArrayMin3DS

Formats.m3DSConst

minimum number of vertices FACE_ARRAY

FaceBCVisable3DS

Formats.m3DSConst

flags the CA edge as visible

FaceCAVisable3DS

Formats.m3DSConst

—————- Constants for commonly used structures ——————– Flags used by the flag field of the Mesh3DS structure

FacesSmooth

GLS.MeshBuilder

FaceUWrap3DS

Formats.m3DSConst

flags the AB edge as visible

FaceVWrap3DS

Formats.m3DSConst

flags the face as being at a texture coord u wrap seam

FACE_ARRAY

Formats.m3DSConst

FACE_ARRAY_ENTRY

Formats.m3DSConst

FACE_POLYGON

Formats.Q3BSP

FallbackStringToDouble

PasDblStrUtils

FallbackStringToDouble

PasDblStrUtils

FallTrackTagMax3DS

Formats.m3DSConst

Minimum fall off angle

FallTrackTagMin3DS

Formats.m3DSConst

Maximum hot spot angle FALL_TRACK_TAG_KEY

FALL_TRACK_TAG

Formats.m3DSConst

FALL_TRACK_TAG_KEY

Formats.m3DSConst

FastArcTangent2

GLScene.VectorGeometry

Fast ArcTangent2 approximation, about 0.07 rads accuracy

FastCheckCubeVsCube

GLS.Collision

FastCheckCubeVsEllipsoid

GLS.Collision

FastCheckCubeVsFace

GLS.Collision

FastCheckCubeVsPoint

GLS.Collision

FastCheckCubeVsSphere

GLS.Collision

FastCheckEllipsoidVsCube

GLS.Collision

FastCheckEllipsoidVsEllipsoid

GLS.Collision

FastCheckEllipsoidVsPoint

GLS.Collision

FastCheckEllipsoidVsSphere

GLS.Collision

FastCheckFaceVsCube

GLS.Collision

experimental

FastCheckFaceVsFace

GLS.Collision

experimental

FastCheckPointVsCube

GLS.Collision

FastCheckPointVsEllipsoid

GLS.Collision

FastCheckPointVsPoint

GLS.Collision

Fast Collision detection routines that are heavily specialized and just return a boolean

FastCheckPointVsSphere

GLS.Collision

FastCheckSphereVsCube

GLS.Collision

FastCheckSphereVsEllipsoid

GLS.Collision

FastCheckSphereVsPoint

GLS.Collision

FastCheckSphereVsSphere

GLS.Collision

FAST_NODE

Formats.m3DSConst

FileAttrStrMax3DS

Formats.m3DSConst

3DS file attributes

FILECLOSEPROC

BASS.Import

User file stream callback functions

FILELENPROC

BASS.Import

FilenameString

gnugettext

FileNameStrMax3DS

Formats.m3DSConst

————– constants that define various value ranges for specific chunks 3DS filename

FILEREADPROC

BASS.Import

FILESEEKPROC

BASS.Import

FileStreamExists

GLS.ApplicationFileIO

Queries is a file stream corresponding to the fileName exists.

FillUniformAutoSetMethodList

GLSL.ShaderParameter

FillUniformAutoSetMethodList

GLSL.ShaderParameter

FindChunk

Formats.m3DSUtils

FindChunkById

Formats.LWO

ChunkFind procedures

FindClipByClipIndex

Formats.LWO

FindCompatibleDataFormat

GLScene.TextureFormat

Give compatible openGL image format and data type

FindCuFile

GLS.CUDA.PropEditors

FindDDSCompatibleDataFormat

Formats.DXTC

FindGLTextureImageClass

GLS.Texture

Finds a registerer TGLTextureImageClass using its classname

FindGLTextureImageClassByFriendlyName

GLS.Texture

Finds a registerer TGLTextureImageClass using its FriendlyName

FindManager

GLScene.Manager

FindNamedObjectByIndex

Formats.m3DSUtils

FindNextChunk

Formats.m3DSUtils

FindRoot

GLScene.Polynomials

Finds a root between min and max with a precision of epsilon. The evaluation of min/max must be of opposit sign

FindSurfaceByName

Formats.LWO

FindSurfaceByTag

Formats.LWO

FindUnitName

GLScene.Utils

FindUnitName

GLScene.Utils

FindVMapByName

Formats.LWO

FindXCollectionItemClass

GLScene.XCollection

Retrieves a registered TXCollectionItemClass from its classname

FIND_ANY

Formats.VFW

find key frame.

FIND_DIR

Formats.VFW

– Flags for AVIStreamFindSample ——————————————–

FIND_FORMAT

Formats.VFW

find any (non-empty) sample

FIND_FROM_START

Formats.VFW

go backward

FIND_INDEX

Formats.VFW

return physical size

FIND_KEY

Formats.VFW

type mask

FIND_LENGTH

Formats.VFW

return logical position

FIND_NEXT

Formats.VFW

direction

FIND_OFFSET

Formats.VFW

return logical size

FIND_POS

Formats.VFW

return mask

FIND_PREV

Formats.VFW

go forward

FIND_RET

Formats.VFW

find format change

FIND_SIZE

Formats.VFW

return physical position

FIND_TYPE

Formats.VFW

start at the logical beginning

FixPathDelimiter

GLScene.Utils

Replace path delimiter to delimiter of the current platform.

flip_blocks_dxtc1

Formats.DXTC

flip_blocks_dxtc3

Formats.DXTC

flip_blocks_dxtc5

Formats.DXTC

flip_dxt5_alpha

Formats.DXTC

Float

Newton.Import

Float

SDL.Import

Float2rgbe

GLScene.RGBE

FloatElement

CUDA.DataAccess

FloatPercentageMax3DS

Formats.m3DSConst

Maximum integer percentage FLOAT_PERCENTAGE

FloatToHalf

GLScene.Utils

FLOAT_PERCENTAGE

Formats.m3DSConst

FMOD_DLL

FMOD.Import

FMOD_ErrorString

FMOD.errors

Disable warning for unsafe types in Delphi 7

FMOD_Load

FMOD.Import

If no library name is passed to FMOD_Load, then the default library name used. These are stub functions.

FMOD_Unload

FMOD.Import

FMOD_VERSION

FMOD.types

Force four-byte enums

FMUSIC_FreeSong

FMOD.Import

FMUSIC_GetBPM

FMOD.Import

FMUSIC_GetGlobalVolume

FMOD.Import

FMUSIC_GetMasterVolume

FMOD.Import

FMUSIC_GetName

FMOD.Import

Static song information functions.

FMUSIC_GetNumChannels

FMOD.Import

FMUSIC_GetNumInstruments

FMOD.Import

FMUSIC_GetNumOrders

FMOD.Import

FMUSIC_GetNumPatterns

FMOD.Import

FMUSIC_GetNumSamples

FMOD.Import

FMUSIC_GetOpenState

FMOD.Import

FMUSIC_GetOrder

FMOD.Import

FMUSIC_GetPattern

FMOD.Import

FMUSIC_GetPatternLength

FMOD.Import

FMUSIC_GetPaused

FMOD.Import

FMUSIC_GetRealChannel

FMOD.Import

FMUSIC_GetRow

FMOD.Import

FMUSIC_GetSample

FMOD.Import

FMUSIC_GetSpeed

FMOD.Import

FMUSIC_GetTime

FMOD.Import

FMUSIC_GetType

FMOD.Import

FMUSIC_GetUserData

FMOD.Import

FMUSIC_IsFinished

FMOD.Import

Runtime song information.

FMUSIC_IsPlaying

FMOD.Import

FMUSIC_LoadSong

FMOD.Import

Song management / playback functions.

FMUSIC_LoadSongEx

FMOD.Import

FMUSIC_OptimizeChannels

FMOD.Import

FMUSIC_PlaySong

FMOD.Import

FMUSIC_SetInstCallback

FMOD.Import

FMUSIC_SetLooping

FMOD.Import

FMUSIC_SetMasterSpeed

FMOD.Import

FMUSIC_SetMasterVolume

FMOD.Import

FMUSIC_SetOrder

FMOD.Import

FMUSIC_SetOrderCallback

FMOD.Import

FMUSIC_SetPanSeperation

FMOD.Import

FMUSIC_SetPaused

FMOD.Import

FMUSIC_SetReverb

FMOD.Import

Runtime song functions.

FMUSIC_SetRowCallback

FMOD.Import

FMUSIC_SetSample

FMOD.Import

FMUSIC_SetUserData

FMOD.Import

FMUSIC_SetZxxCallback

FMOD.Import

FMUSIC_StopAllSongs

FMOD.Import

FMUSIC_StopSong

FMOD.Import

FOG

Formats.m3DSConst

FogMax3DS

Formats.m3DSConst

minimum value for fogging plane density

FogMin3DS

Formats.m3DSConst

maximum value for gradient midpoint FOG chunk

FOG_BGND

Formats.m3DSConst

FontManager

GLS.SpaceText

FONT_CHARS_COUNT

GLScene.Utils

formtypeAVI

Formats.VFW

– form types, list types and chunk types ———————————–

FOURCC_A16B16G16R16

Formats.DXTC

FOURCC_A16B16G16R16F

Formats.DXTC

FOURCC_A1R5G5B5

Formats.DXTC

FOURCC_A2B10G10R10

Formats.DXTC

FOURCC_A2R10G10B10

Formats.DXTC

FOURCC_A32B32G32R32F

Formats.DXTC

FOURCC_A4L4

Formats.DXTC

FOURCC_A4R4G4B4

Formats.DXTC

FOURCC_A8

Formats.DXTC

FOURCC_A8B8G8R8

Formats.DXTC

FOURCC_A8L8

Formats.DXTC

FOURCC_A8R3G3B2

Formats.DXTC

FOURCC_A8R8G8B8

Formats.DXTC

FOURCC_ATI1

Formats.DXTC

FOURCC_ATI2

Formats.DXTC

FOURCC_D16

Formats.DXTC

FOURCC_D16_LOCKABLE

Formats.DXTC

FOURCC_D24X8

Formats.DXTC

FOURCC_D32

Formats.DXTC

FOURCC_D32F_LOCKABLE

Formats.DXTC

FOURCC_DX10

Formats.DXTC

DX10 header indicator

FOURCC_DXT1

Formats.DXTC

FOURCC_DXT2

Formats.DXTC

FOURCC_DXT3

Formats.DXTC

FOURCC_DXT4

Formats.DXTC

FOURCC_DXT5

Formats.DXTC

FOURCC_G16R16

Formats.DXTC

FOURCC_G16R16F

Formats.DXTC

FOURCC_G32R32F

Formats.DXTC

FOURCC_L16

Formats.DXTC

FOURCC_L8

Formats.DXTC

FOURCC_R16F

Formats.DXTC

Floating point surface formats s10e5 formats (16-bits per channel)

FOURCC_R32F

Formats.DXTC

IEEE s23e8 formats (32-bits per channel)

FOURCC_R3G3B2

Formats.DXTC

FOURCC_R5G6B5

Formats.DXTC

FOURCC_R8G8B8

Formats.DXTC

FOURCC_UNKNOWN

Formats.DXTC

FOURCC_X1R5G5B5

Formats.DXTC

FOURCC_X4R4G4B4

Formats.DXTC

FOURCC_X8B8G8R8

Formats.DXTC

FOURCC_X8R8G8B8

Formats.DXTC

FOVTrackTagMax3DS

Formats.m3DSConst

Minimum camera FOV

FOVTrackTagMin3DS

Formats.m3DSConst

Maximum color value FOV_TRACK_TAG_KEY

FOV_TRACK_TAG

Formats.m3DSConst

FOV_TRACK_TAG_KEY

Formats.m3DSConst

FractalMiddlePointHDS

GLS.RandomHDS

Fractal algorithm based on the middle-point displacement method. It is built in a way that it can be juxtaposed seamlessly to itself (cyclic boundaries)

FreeChunkData

Formats.m3DSUtils

FromHex

Formats.VFW

– Macro to get stream number out of a FOURCC ckid ————————–

FrustumContainsAABB

GLScene.GeometryBB

Determines to which extent a frustum contains an AABB

FrustumContainsBSphere

GLScene.GeometryBB

Determines to which extent a frustum contains a BSphere

FSOUND_16BITS

FMOD.types

For 8 bit samples.

FSOUND_2D

FMOD.types

Attempts to make samples use 3d hardware acceleration. (if the card supports it)

FSOUND_3D_GetAttributes

FMOD.Import

FSOUND_3D_GetMinMaxDistance

FMOD.Import

FSOUND_3D_Listener_GetAttributes

FMOD.Import

FSOUND_3D_Listener_SetAttributes

FMOD.Import

FSOUND_3D_Listener_SetCurrent

FMOD.Import

See also 3d sample and channel based functions above. Call FSOUND_Update once a frame to process 3d information.

FSOUND_3D_SetAttributes

FMOD.Import

FSOUND_3D_SetDistanceFactor

FMOD.Import

FSOUND_3D_SetDopplerFactor

FMOD.Import

FSOUND_3D_SetMinMaxDistance

FMOD.Import

FSOUND_3D_SetRolloffFactor

FMOD.Import

FSOUND_8BITS

FMOD.types

For bidirectional looping samples. (no effect if in hardware).

FSOUND_ALL

FMOD.types

value to allocate a sample that is NOT managed by FSOUND or placed in a sample slot.

FSOUND_CAPS_EAX2

FMOD.types

This driver supports hardware accelerated 3d sound.

FSOUND_CAPS_EAX3

FMOD.types

This driver supports EAX 2 reverb

FSOUND_CAPS_HARDWARE

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_CAPS
[DESCRIPTION] Driver description bitfields. Use FSOUND_Driver_GetCaps to determine if a driver enumerated has the settings you are after. The enumerated driver depends on the output mode, see FSOUND_OUTPUTTYPES
[SEE_ALSO] FSOUND_GetDriverCaps FSOUND_OUTPUTTYPES ]

FSOUND_CD_GetNumTracks

FMOD.Import

FSOUND_CD_GetPaused

FMOD.Import

FSOUND_CD_GetTrack

FMOD.Import

FSOUND_CD_GetTrackLength

FMOD.Import

FSOUND_CD_GetTrackTime

FMOD.Import

FSOUND_CD_GetVolume

FMOD.Import

FSOUND_CD_OpenTray

FMOD.Import

FSOUND_CD_Play

FMOD.Import

Note : 0 = default cdrom. Otherwise specify the drive letter, for example. 'D'.

FSOUND_CD_PLAYCONTINUOUS

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_CDPLAYMODES
[DESCRIPTION] Playback method for a CD Audio track, using FSOUND_CD_SetPlayMode
[SEE_ALSO] FSOUND_CD_SetPlayMode FSOUND_CD_Play ]

FSOUND_CD_PLAYLOOPED

FMOD.types

Plays the specified track then stops.

FSOUND_CD_PLAYONCE

FMOD.types

Starts from the current track and plays to end of CD.

FSOUND_CD_PLAYRANDOM

FMOD.types

Plays the specified track looped, forever until stopped manually.

FSOUND_CD_SetPaused

FMOD.Import

FSOUND_CD_SetPlayMode

FMOD.Import

FSOUND_CD_SetTrackTime

FMOD.Import

FSOUND_CD_SetVolume

FMOD.Import

FSOUND_CD_Stop

FMOD.Import

FSOUND_Close

FMOD.Import

FSOUND_DELTA

FMOD.types

For user created source data containing signed data.

FSOUND_DSP_ClearMixBuffer

FMOD.Import

FSOUND_DSP_Create

FMOD.Import

DSP Unit control and information functions.

FSOUND_DSP_DEFAULTPRIORITY_CLEARUNIT

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_DSP_PRIORITIES
[DESCRIPTION] These default priorities are used by FMOD internal system DSP units. They describe the position of the DSP chain, and the order of how audio processing is executed. You can actually through the use of FSOUND_DSP_GetxxxUnit (where xxx is the name of the DSP unit), disable or even change the priority of a DSP unit.
[SEE_ALSO] FSOUND_DSP_Create FSOUND_DSP_SetPriority FSOUND_DSP_GetSpectrum ]

FSOUND_DSP_DEFAULTPRIORITY_CLIPANDCOPYUNIT

FMOD.types

This reads data for FSOUND_DSP_GetSpectrum, so it comes after user units

FSOUND_DSP_DEFAULTPRIORITY_FFTUNIT

FMOD.types

User priority, use this as reference for your own DSP units

FSOUND_DSP_DEFAULTPRIORITY_MUSICUNIT

FMOD.types

DSP SFX unit - done second

FSOUND_DSP_DEFAULTPRIORITY_SFXUNIT

FMOD.types

DSP CLEAR unit - done first

FSOUND_DSP_DEFAULTPRIORITY_USER

FMOD.types

DSP MUSIC unit - done third

FSOUND_DSP_Free

FMOD.Import

FSOUND_DSP_GetActive

FMOD.Import

FSOUND_DSP_GetBufferLength

FMOD.Import

FSOUND_DSP_GetBufferLengthTotal

FMOD.Import

Length of each DSP update

FSOUND_DSP_GetClearUnit

FMOD.Import

Functions to get hold of FSOUND 'system DSP unit' handles.

FSOUND_DSP_GetClipAndCopyUnit

FMOD.Import

FSOUND_DSP_GetFFTUnit

FMOD.Import

FSOUND_DSP_GetMusicUnit

FMOD.Import

FSOUND_DSP_GetPriority

FMOD.Import

FSOUND_DSP_GetSFXUnit

FMOD.Import

FSOUND_DSP_GetSpectrum

FMOD.Import

Total buffer length due to FSOUND_SetBufferSize

FSOUND_DSP_MixBuffers

FMOD.Import

Miscellaneous DSP functions Note for the spectrum analysis function to work, you have to enable the FFT DSP unit with the following code FSOUND_DSP_SetActive(FSOUND_DSP_GetFFTUnit(), TRUE); It is off by default to save cpu usage.

FSOUND_DSP_SetActive

FMOD.Import

FSOUND_DSP_SetPriority

FMOD.Import

FSOUND_ENABLEFX

FMOD.types

2D hardware sounds. allows hardware specific effects

FSOUND_File_SetCallbacks

FMOD.Import

FSOUND_FORCEMONO

FMOD.types

For FSOUND_Stream_OpenFile - for accurate FSOUND_Stream_GetLengthMs/FSOUND_Stream_SetTime. WARNING, see FSOUND_Stream_OpenFile for inital opening time performance issues.

FSOUND_FORMAT_MPEG

FMOD.types

FSOUND_FORMAT_OGGVORBIS

FMOD.types

FSOUND_FREE

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_CHANNELSAMPLEMODE
[DESCRIPTION] Miscellaneous values for FMOD functions.
[SEE_ALSO] FSOUND_PlaySound FSOUND_PlaySoundEx FSOUND_Sample_Alloc FSOUND_Sample_Load FSOUND_SetPan ]

FSOUND_FX_Disable

FMOD.Import

FSOUND_FX_Enable

FMOD.Import

Functions to control DX8 only effects processing.
- FX enabled samples can only be played once at a time, not multiple times at once. - Sounds have to be created with FSOUND_HW2D or FSOUND_HW3D for this to work. - FSOUND_INIT_ENABLESYSTEMCHANNELFX can be used to apply hardware effect processing to the global mixed output of FMOD's software channels. - FSOUND_FX_Enable returns an FX handle that you can use to alter fx parameters. - FSOUND_FX_Enable can be called multiple times in a row, even on the same FX type, it will return a unique handle for each FX. - FSOUND_FX_Enable cannot be called if the sound is playing or locked. - FSOUND_FX_Disable must be called to reset/clear the FX from a channel.

FSOUND_FX_SetChorus

FMOD.Import

FSOUND_FX_SetCompressor

FMOD.Import

FSOUND_FX_SetDistortion

FMOD.Import

FSOUND_FX_SetEcho

FMOD.Import

FSOUND_FX_SetFlanger

FMOD.Import

FSOUND_FX_SetGargle

FMOD.Import

FSOUND_FX_SetI3DL2Reverb

FMOD.Import

FSOUND_FX_SetParamEQ

FMOD.Import

FSOUND_FX_SetWavesReverb

FMOD.Import

FSOUND_GCADPCM

FMOD.types

For FSOUND_Stream_OpenFile - Causes stream to open in the background and not block the foreground app - stream plays only when ready.

FSOUND_GetAmplitude

FMOD.Import

FSOUND_GetChannelsPlaying

FMOD.Import

FSOUND_GetCPUUsage

FMOD.Import

FSOUND_GetCurrentLevels

FMOD.Import

FSOUND_GetCurrentPosition

FMOD.Import

FSOUND_GetCurrentSample

FMOD.Import

FSOUND_GetDriver

FMOD.Import

FSOUND_GetDriverCaps

FMOD.Import

FSOUND_GetDriverName

FMOD.Import

FSOUND_GetError

FMOD.Import

System information functions

FSOUND_GetFrequency

FMOD.Import

FSOUND_GetLoopMode

FMOD.Import

FSOUND_GetMaxChannels

FMOD.Import

FSOUND_GetMaxSamples

FMOD.Import

FSOUND_GetMemoryStats

FMOD.Import

FSOUND_GetMixer

FMOD.Import

FSOUND_GetMute

FMOD.Import

FSOUND_GetNumDrivers

FMOD.Import

FSOUND_GetNumHWChannels

FMOD.Import

FSOUND_GetNumSubChannels

FMOD.Import

FSOUND_GetOutput

FMOD.Import

FSOUND_GetOutputHandle

FMOD.Import

FSOUND_GetOutputRate

FMOD.Import

FSOUND_GetPan

FMOD.Import

FSOUND_GetPaused

FMOD.Import

FSOUND_GetPriority

FMOD.Import

FSOUND_GetReserved

FMOD.Import

FSOUND_GetSFXMasterVolume

FMOD.Import

function FSOUND_GetSpeakerMode: Integer; {$IFDEF UNIX} cdecl {$ELSE} stdcall {$ENDIF};

FSOUND_GetSubChannel

FMOD.Import

FSOUND_GetSurround

FMOD.Import

FSOUND_GetVersion

FMOD.Import

FSOUND_GetVolume

FMOD.Import

FSOUND_HW2D

FMOD.types

For forcing stereo streams and samples to be mono - needed if using FSOUND_HW3D and stereo data - incurs a small speed hit for streams

FSOUND_HW3D

FMOD.types

For user created source data stored using IT215 compression.

FSOUND_Init

FMOD.Import

Main initialization / closedown functions. Note : Use FSOUND_INIT_USEDEFAULTMIDISYNTH with FSOUND_Init for software override with MIDI playback. : Use FSOUND_INIT_GLOBALFOCUS with FSOUND_Init to make sound audible no matter which window is in focus. (FSOUND_OUTPUT_DSOUND only)

FSOUND_INIT_ACCURATEVULEVELS

FMOD.types

For DirectSound output - Allows FSOUND_FX api to be used on global software mixer output!

FSOUND_INIT_DONTLATENCYADJUST

FMOD.types

PS2 only - By default FMOD uses DMA CH0 for mixing, CH1 for uploads, this flag swaps them around.

FSOUND_INIT_DSOUND_DEFERRED

FMOD.types

PS2 only - Turns on volume ramping system to remove hardware clicks.

FSOUND_INIT_DSOUND_HRTF_FULL

FMOD.types

Win32 only - For DirectSound output. FSOUND_HW3D buffers use a slightly higher quality algorithm when 3d hardware acceleration is not present.

FSOUND_INIT_DSOUND_HRTF_LIGHT

FMOD.types

Win32 only - For DirectSound output. 3D commands are batched together and executed at FSOUND_Update.

FSOUND_INIT_ENABLESYSTEMCHANNELFX

FMOD.types

For DirectSound output - sound is not muted when window is out of focus.

FSOUND_INIT_GC_INITLIBS

FMOD.types

Callbacks are not latency adjusted, and are called at mix time. Also information functions are immediate.

FSOUND_INIT_GLOBALFOCUS

FMOD.types

Causes MIDI playback to force software decoding.

FSOUND_INIT_PS2_DISABLECORE0REVERB

FMOD.types

This latency adjusts FSOUND_GetCurrentLevels, but incurs a small cpu and memory hit.

FSOUND_INIT_PS2_DISABLECORE1REVERB

FMOD.types

PS2 only - Disable reverb on CORE 0 to regain SRAM.

FSOUND_INIT_PS2_SWAPDMACORES

FMOD.types

PS2 only - Disable reverb on CORE 1 to regain SRAM.

FSOUND_INIT_PS2_USEVOLUMERAMPING

FMOD.types

Turns off fmod streamer thread, and makes streaming update from FSOUND_Update called by the user.

FSOUND_INIT_PSP_SILENCEONUNDERRUN

FMOD.types

XBox only - By default directsound attenuates all sound by 6db to avoid clipping/distortion. CAUTION. If you use this flag you are responsible for the final mix to make sure clipping / distortion doesn't happen.

FSOUND_INIT_STREAM_FROM_MAIN_THREAD

FMOD.types

Gamecube only - Initializes GC audio libraries.

FSOUND_INIT_USEDEFAULTMIDISYNTH

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_INIT_FLAGS
[DESCRIPTION] Initialization flags. Use them with FSOUND_Init in the flags parameter to change various behaviour.
FSOUND_INIT_ENABLESYSTEMCHANNELFX Is an init mode which enables the FSOUND mixer buffer to be affected by DirectX 8 effects. Note that due to limitations of DirectSound, FSOUND_Init may fail if this is enabled because the buffersize is too small. This can be fixed with FSOUND_SetBufferSize. Increase the BufferSize until it works. When it is enabled you can use the FSOUND_FX api, and use FSOUND_SYSTEMCHANNEL as the channel id when setting parameters.
[SEE_ALSO] FSOUND_Init ]

FSOUND_INIT_XBOX_REMOVEHEADROOM

FMOD.types

Win32 only - For DirectSound output. FSOUND_HW3D buffers use full quality 3d playback when 3d hardware acceleration is not present.

FSOUND_IsPlaying

FMOD.Import

Channel information functions

FSOUND_IT214

FMOD.types

For user created source data stored as delta values.

FSOUND_IT215

FMOD.types

For user created source data stored using IT214 compression.

FSOUND_LOADMEMORY

FMOD.types

For a streamimg sound where you feed the data to it. */

FSOUND_LOADMEMORYIOP

FMOD.types

For PS2 only - Sample/Stream is forced to use hardware voices 24-47

FSOUND_LOADRAW

FMOD.types

"name" will be interpreted as a pointer to data for streaming and samples.

FSOUND_LOOP_BIDI

FMOD.types

For forward looping samples.

FSOUND_LOOP_NORMAL

FMOD.types

For non looping samples.

FSOUND_LOOP_OFF

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_MODES
[DESCRIPTION] Sample description bitfields, OR them together for loading and describing samples. NOTE. If the file format being loaded already has a defined format, such as WAV or MP3, then trying to override the pre-defined format with a new set of format flags will not work. For example, an 8 bit WAV file will not load as 16bit if you specify FSOUND_16BITS. It will just ignore the flag and go ahead loading it as 8bits. For these type of formats the only flags you can specify that will really alter the behaviour of how it is loaded, are the following.
Looping behaviour - FSOUND_LOOP_OFF, FSOUND_LOOP_NORMAL, FSOUND_LOOP_BIDI Load destination - FSOUND_HW3D, FSOUND_HW2D, FSOUND_2D Loading behaviour - FSOUND_NONBLOCKING, FSOUND_LOADMEMORY, FSOUND_LOADRAW, FSOUND_MPEGACCURATE, FSOUND_MPEGHALFRATE, FSOUND_FORCEMONO Playback behaviour - FSOUND_STREAMABLE, FSOUND_ENABLEFX PlayStation 2 only - FSOUND_USECORE0, FSOUND_USECORE1, FSOUND_LOADMEMORYIOP
See flag descriptions for what these do. ]

FSOUND_MONO

FMOD.types

For 16 bit samples.

FSOUND_MPEGACCURATE

FMOD.types

Will ignore file format and treat as raw pcm.

FSOUND_MPEGHALFRATE

FMOD.types

Allows DX8 FX to be played back on a sound. Requires DirectX 8 - Note these sounds cannot be played more than once, be 8 bit, be less than a certain size, or have a changing frequency

FSOUND_MULTICHANNEL

FMOD.types

For Gamecube only - Contents are compressed as Gamecube DSP-ADPCM format

FSOUND_NONBLOCKING

FMOD.types

For PS2 only - Contents are compressed as Sony VAG format */

FSOUND_NORMAL

FMOD.types

For PS2 only - "name" will be interpreted as a pointer to data for streaming and samples. The address provided will be an IOP address

FSOUND_PlaySound

FMOD.Import

Playing and stopping sounds. Note : Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you. Use FSOUND_ALL as the 'channel' variable to control ALL channels with one function call!

FSOUND_PlaySoundEx

FMOD.Import

FSOUND_PRESET_ALLEY

FMOD.presets

FSOUND_PRESET_ARENA

FMOD.presets

FSOUND_PRESET_AUDITORIUM

FMOD.presets

FSOUND_PRESET_BATHROOM

FMOD.presets

FSOUND_PRESET_CARPETTEDHALLWAY

FMOD.presets

FSOUND_PRESET_CAVE

FMOD.presets

FSOUND_PRESET_CITY

FMOD.presets

FSOUND_PRESET_CONCERTHALL

FMOD.presets

FSOUND_PRESET_DIZZY

FMOD.presets

FSOUND_PRESET_DRUGGED

FMOD.presets

Non I3DL2 presets

FSOUND_PRESET_FOREST

FMOD.presets

FSOUND_PRESET_GENERIC

FMOD.presets

FSOUND_PRESET_HALLWAY

FMOD.presets

FSOUND_PRESET_HANGAR

FMOD.presets

FSOUND_PRESET_LIVINGROOM

FMOD.presets

FSOUND_PRESET_MOUNTAINS

FMOD.presets

FSOUND_PRESET_OFF

FMOD.presets

[DEFINE_START] [ [NAME] FSOUND_REVERB_PRESETS
[DESCRIPTION] A set of predefined environment PARAMETERS, created by Creative Labs These are used to initialize an FSOUND_REVERB_PROPERTIES structure statically. ie FSOUND_REVERB_PROPERTIES prop = FSOUND_PRESET_GENERIC;
[SEE_ALSO] FSOUND_Reverb_SetProperties ]

FSOUND_PRESET_PADDEDCELL

FMOD.presets

FSOUND_PRESET_PARKINGLOT

FMOD.presets

FSOUND_PRESET_PLAIN

FMOD.presets

FSOUND_PRESET_PSYCHOTIC

FMOD.presets

FSOUND_PRESET_QUARRY

FMOD.presets

FSOUND_PRESET_ROOM

FMOD.presets

FSOUND_PRESET_SEWERPIPE

FMOD.presets

FSOUND_PRESET_STONECORRIDOR

FMOD.presets

FSOUND_PRESET_STONEROOM

FMOD.presets

FSOUND_PRESET_UNDERWATER

FMOD.presets

FSOUND_PROTOCOL_HTTP

FMOD.types

FSOUND_PROTOCOL_ICECAST

FMOD.types

FSOUND_PROTOCOL_SHOUTCAST

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_STATUS_FLAGS
[DESCRIPTION] These values describe the protocol and format of an internet stream. Use FSOUND_Stream_Net_GetStatus to retrieve this information for an open internet stream.
[SEE_ALSO] FSOUND_Stream_Net_GetStatus ]

FSOUND_Record_GetDriver

FMOD.Import

FSOUND_Record_GetDriverName

FMOD.Import

FSOUND_Record_GetNumDrivers

FMOD.Import

FSOUND_Record_GetPosition

FMOD.Import

FSOUND_Record_SetDriver

FMOD.Import

Recording initialization functions

FSOUND_Record_StartSample

FMOD.Import

Recording functionality. Only one recording session will work at a time.

FSOUND_Record_Stop

FMOD.Import

FSOUND_REVERBFLAGS_DECAYHFLIMIT

FMOD.types

EnvironmentSize affects late reverberation delay time

FSOUND_REVERBFLAGS_DECAYTIMESCALE

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_REVERB_FLAGS
[DESCRIPTION] Values for the Flags member of the FSOUND_REVERB_PROPERTIES structure.
[SEE_ALSO] FSOUND_REVERB_PROPERTIES ]

FSOUND_REVERBFLAGS_DEFAULT

FMOD.types

PS2 Only - Reverb is applied to CORE1 (hw voices 24-47)

FSOUND_REVERBFLAGS_ECHOTIMESCALE

FMOD.types

AirAbsorptionHF affects DecayHFRatio

FSOUND_REVERBFLAGS_MODULATIONTIMESCALE

FMOD.types

EnvironmentSize affects echo time

FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE

FMOD.types

EnvironmentSize affects reflection level

FSOUND_REVERBFLAGS_REFLECTIONSSCALE

FMOD.types

EnvironmentSize affects reverberation decay time

FSOUND_REVERBFLAGS_REVERBDELAYSCALE

FMOD.types

EnvironmentSize affects reflections level

FSOUND_REVERBFLAGS_REVERBSCALE

FMOD.types

EnvironmentSize affects initial reflection delay time

FSOUND_REVERB_CHANNELFLAGS_DEFAULT

FMOD.types

Automatic setting of 'RoomHF' due to distance from listener

FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO

FMOD.types

[DEFINE_START] [ [NAME] FSOUND_REVERB_CHANNELFLAGS
[DESCRIPTION] Values for the Flags member of the FSOUND_REVERB_CHANNELPROPERTIES structure.
[SEE_ALSO] FSOUND_REVERB_CHANNELPROPERTIES ]

FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO

FMOD.types

Automatic setting of 'Direct' due to distance from listener

FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO

FMOD.types

Automatic setting of 'Room' due to distance from listener

FSOUND_REVERB_FLAGS_CORE0

FMOD.types

EnvironmentSize affects modulation time

FSOUND_REVERB_FLAGS_CORE1

FMOD.types

PS2 Only - Reverb is applied to CORE0 (hw voices 0-23)

FSOUND_Reverb_GetChannelProperties

FMOD.Import

FSOUND_Reverb_GetProperties

FMOD.Import

FSOUND_Reverb_SetChannelProperties

FMOD.Import

FSOUND_Reverb_SetProperties

FMOD.Import

See structures above for definitions and information on the reverb parameters.

FSOUND_Sample_Alloc

FMOD.Import

FSOUND_Sample_Free

FMOD.Import

FSOUND_Sample_Get

FMOD.Import

Sample information functions

FSOUND_Sample_GetDefaults

FMOD.Import

FSOUND_Sample_GetDefaultsEx

FMOD.Import

FSOUND_Sample_GetLength

FMOD.Import

FSOUND_Sample_GetLoopPoints

FMOD.Import

FSOUND_Sample_GetMinMaxDistance

FMOD.Import

FSOUND_Sample_GetMode

FMOD.Import

FSOUND_Sample_GetName

FMOD.Import

FSOUND_Sample_Load

FMOD.Import

Sample creation and management functions Note : Use FSOUND_LOADMEMORY flag with FSOUND_Sample_Load to load from memory. Use FSOUND_LOADRAW flag with FSOUND_Sample_Load to treat as as raw pcm data.

FSOUND_Sample_Lock

FMOD.Import

FSOUND_Sample_SetDefaults

FMOD.Import

FSOUND_Sample_SetDefaultsEx

FMOD.Import

FSOUND_Sample_SetLoopPoints

FMOD.Import

FSOUND_Sample_SetMaxPlaybacks

FMOD.Import

FSOUND_Sample_SetMinMaxDistance

FMOD.Import

FSOUND_Sample_SetMode

FMOD.Import

Sample control functions

FSOUND_Sample_Unlock

FMOD.Import

FSOUND_Sample_Upload

FMOD.Import

FSOUND_SetBufferSize

FMOD.Import

FSOUND_SetCurrentPosition

FMOD.Import

FSOUND_SetDriver

FMOD.Import

FSOUND_SetFrequency

FMOD.Import

Functions to control playback of a channel. Note : FSOUND_ALL can be used on most of these functions as a channel value.

FSOUND_SetHWND

FMOD.Import

FSOUND_SetLoopMode

FMOD.Import

FSOUND_SetMaxHardwareChannels

FMOD.Import

FSOUND_SetMemorySystem

FMOD.Import

FSOUND_SetMinHardwareChannels

FMOD.Import

FSOUND_SetMixer

FMOD.Import

FSOUND_SetMute

FMOD.Import

FSOUND_SetOutput

FMOD.Import

PRE - FSOUND_Init functions. These can't be called after FSOUND_Init is called (they will fail). They set up FMOD system functionality.

FSOUND_SetPan

FMOD.Import

FSOUND_SetPanSeperation

FMOD.Import

FSOUND_SetPaused

FMOD.Import

FSOUND_SetPriority

FMOD.Import

FSOUND_SetReserved

FMOD.Import

FSOUND_SetSFXMasterVolume

FMOD.Import

FSOUND_SetSpeakerMode

FMOD.Import

This is called to update 3d sound / non-realtime output

FSOUND_SetSurround

FMOD.Import

FSOUND_SetVolume

FMOD.Import

FSOUND_SetVolumeAbsolute

FMOD.Import

FSOUND_SIGNED

FMOD.types

For user created source data containing unsigned samples.

FSOUND_SPEAKERMODES

FMOD.types

The audio is played through a speaker arrangement of surround speakers with a subwoofer.

FSOUND_STEREO

FMOD.types

For mono samples.

FSOUND_STEREOPAN

FMOD.types

for a channel index , this flag will affect ALL channels available! Not supported by every function.

FSOUND_StopSound

FMOD.Import

FSOUND_STREAMABLE

FMOD.types

Ignores any 3d processing. Overrides FSOUND_HW3D. Located in software.

FSOUND_Stream_AddSyncPoint

FMOD.Import

FSOUND_Stream_Close

FMOD.Import

FSOUND_Stream_Create

FMOD.Import

FSOUND_Stream_CreateDSP

FMOD.Import

FSOUND_Stream_DeleteSyncPoint

FMOD.Import

FSOUND_Stream_FindTagField

FMOD.Import

FSOUND_Stream_GetLength

FMOD.Import

FSOUND_Stream_GetLengthMs

FMOD.Import

FSOUND_Stream_GetMode

FMOD.Import

FSOUND_Stream_GetNumSubStreams

FMOD.Import

FSOUND_Stream_GetNumSyncPoints

FMOD.Import

FSOUND_Stream_GetNumTagFields

FMOD.Import

FSOUND_Stream_GetOpenState

FMOD.Import

FSOUND_Stream_GetPosition

FMOD.Import

FSOUND_Stream_GetSample

FMOD.Import

FSOUND_Stream_GetSyncPoint

FMOD.Import

FSOUND_Stream_GetSyncPointInfo

FMOD.Import

FSOUND_Stream_GetTagField

FMOD.Import

FSOUND_Stream_GetTime

FMOD.Import

FSOUND_Stream_Net_GetBufferProperties

FMOD.Import

FSOUND_Stream_Net_GetLastServerStatus

FMOD.Import

FSOUND_Stream_Net_GetStatus

FMOD.Import

FSOUND_Stream_Net_SetBufferProperties

FMOD.Import

FSOUND_Stream_Net_SetMetadataCallback

FMOD.Import

FSOUND_Stream_Net_SetProxy

FMOD.Import

Internet streaming functions

FSOUND_Stream_Open

FMOD.Import

FSOUND_Stream_Play

FMOD.Import

FSOUND_Stream_PlayEx

FMOD.Import

FSOUND_Stream_SetBufferSize

FMOD.Import

Note : Use FSOUND_LOADMEMORY flag with FSOUND_Stream_Open to stream from memory. Use FSOUND_LOADRAW flag with FSOUND_Stream_Open to treat stream as raw pcm data. Use FSOUND_MPEGACCURATE flag with FSOUND_Stream_Open to open mpegs in 'accurate mode' for settime/gettime/getlengthms. Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you.

FSOUND_Stream_SetEndCallback

FMOD.Import

FSOUND_Stream_SetLoopCount

FMOD.Import

FSOUND_Stream_SetLoopPoints

FMOD.Import

FSOUND_Stream_SetMode

FMOD.Import

FSOUND_Stream_SetPosition

FMOD.Import

FSOUND_Stream_SetSubStream

FMOD.Import

FSOUND_Stream_SetSubStreamSentence

FMOD.Import

FSOUND_Stream_SetSyncCallback

FMOD.Import

FSOUND_Stream_SetTime

FMOD.Import

FSOUND_Stream_Stop

FMOD.Import

FSOUND_SYSTEMCHANNEL

FMOD.types

value for FSOUND_SetPan so that stereo sounds are not played at half volume. See FSOUND_SetPan for more on this.

FSOUND_SYSTEMSAMPLE

FMOD.types

special 'channel' ID for all channel based functions that want to alter the global FSOUND software mixing output

FSOUND_UNMANAGED

FMOD.types

value to play on any free channel, or to allocate a sample in a free sample slot.

FSOUND_UNSIGNED

FMOD.types

For stereo samples.

FSOUND_Update

FMOD.Import

Runtime system level functions

FSOUND_USECORE0

FMOD.types

For PS2 only - Contents are interleaved into a multi-channel (more than stereo) format

FSOUND_USECORE1

FMOD.types

For PS2 only - Sample/Stream is forced to use hardware voices 00-23

FSOUND_VAG

FMOD.types

For XBOX only - Contents are compressed as XADPCM */

FSOUND_XADPCM

FMOD.types

For FMODCE only - decodes mpeg streams using a lower quality decode, but faster execution

G2_GetVertBoneIndex

Formats.GL2

G2_GetVertBoneWeight

Formats.GL2

G2_GetVertWeights

Formats.GL2

GammaCorrectRGBArray

GLS.Graphics

GCUDAHostElementAccess

CUDA.DataAccess

GenRandom

GLScene.RandomLib

Used to call Random Number Generator. Remember to use Randomize if you don't want repeatable sequences.

GeometryOptimizationMode

GLScene.VectorGeometry

Returns the detected optimization mode. Returned values is either 'FPU', '3DNow!' or 'SSE'

GetActiveLightsList

GLSL.CustomShader

GetActor

PhysX.Import

GetActorCMassGlobalPosition

PhysX.Import

GetActorGlobalOrientation

PhysX.Import

GetActorGlobalPosition

PhysX.Import

GetActorMass

PhysX.Import

GetAmbientLightMotion

Formats.m3DSUtils

GetArchiveFileFormats

GLS.ArchiveManager

getting a class of accessed archiver

GetArchiveManager

GLS.ArchiveManager

Caution!!! Work for one archive manager only

GetAtmosphere

Formats.m3DSUtils

functions to retrieve global settings of a specific 3DS database

GetBackground

Formats.m3DSUtils

GetBestSelectorClass

GLS.Selection

GetBodyFromGLSceneObject

GLS.NGDManager

GetBodyFromGLSceneObject

GLS.ODEManager

GetBodyFromObject

GLS.ODEManager

Helper functions for extracting data from objects with different inheritance.

GetBodyPositionAsAffineVector

GLS.ODEUtils

GetBoneParent

GLS.NGDRagdoll

GetCameraByIndex

Formats.m3DSUtils

GetCameraCount

Formats.m3DSUtils

GetCameraMotion

Formats.m3DSUtils

GetCameraMotionByIndex

Formats.m3DSUtils

GetCameraNodeCount

Formats.m3DSUtils

GetCameraNodeNameList

Formats.m3DSUtils

GetChannelTypeAndNum

GLS.CUDA.APIComps

GetChunkValue

Formats.m3DSUtils

GetContentDir

Formats.LWO

GetCurrentAssetPath

GLScene.Utils

Get current path to assets from dir examples

GetCurrentColorDepth

GLS.ImageUtils

Number of bits per pixel for the current desktop resolution.

GetCurrentLanguage

gnugettext

GetCurrentRenderingObject

GLS.Scene

getcurrenttextdomain

gnugettext

GetDatabaseRelease

Formats.m3DSUtils

GetDeviceLogicalPixelsX

GLS.ImageUtils

Number of pixels per logical inch along the screen width for the device. Under Win32 awaits a HDC and returns its LOGPIXELSX.

GetElementAccessAddress

CUDA.DataAccess

GetElementAccessSize

CUDA.DataAccess

getenv

GLS.SDL.Window

function putenv(const variable: PAnsiChar): integer;

GetFPSMovement

GLS.FPSMovement

GetFPSMovement

GLS.FPSMovement

GetGenericCompressedFormat

GLScene.TextureFormat

Give generic compressed OpenGL texture format

GetGLRect

GLScene.Utils

Rectangle as function

GetGLSceneObject

GLS.ODEManager

GetGLSoundFileFormats

GLS.SoundFileObjects

GetGLTextureImageClassesAsStrings

GLS.Texture

Creates a TStrings with the list of registered TGLTextureImageClass. To be freed by caller.

GetImageLodNumber

GLS.Graphics

Return an optimal number of texture pyramid

GetIndexFromResolution

GLS.Screen

GetInertia

GLS.Behaviours

Returns or creates the TGLBInertia within the given behaviours. This helper function is convenient way to access a TGLBInertia.

GetKfRelease

Formats.m3DSUtils

GetKFSettings

Formats.m3DSUtils

functions to retrieve/modify keyframer (animation) data

GetM3dMagicRelease

Formats.m3DSUtils

version information

GetMaterialByIndex

Formats.m3DSUtils

GetMaterialCount

Formats.m3DSUtils

GetMatrixRec

GLScene.VectorTypesExt

GetMeshByIndex

Formats.m3DSUtils

GetMeshCount

Formats.m3DSUtils

GetMeshRelease

Formats.m3DSUtils

GetMeshSet

Formats.m3DSUtils

GetModuleSymbol

ModuleLoader

GetModuleSymbolEx

ModuleLoader

GetMovement

GLS.Movement

GetMovement

GLS.Movement

GetNextIsoline

GLS.Isolines

GetNGDDynamic

GLS.NGDManager

GetNGDStatic

GLS.NGDManager

Global function

GetObjectMotionByIndex

Formats.m3DSUtils

GetObjectMotionByName

Formats.m3DSUtils

GetObjectNodeCount

Formats.m3DSUtils

GetObjectNodeNameList

Formats.m3DSUtils

GetOdeDynamic

GLS.ODEManager

GetODEHeightField

GLS.ODEManager

Get and GetOrCreate functions for ODE HeightField

GetOdeStatic

GLS.ODEManager

Get and GetOrCreate functions for ode behaviours

GetOmnilightByIndex

Formats.m3DSUtils

GetOmnilightCount

Formats.m3DSUtils

GetOmnilightMotionByIndex

Formats.m3DSUtils

GetOmnilightMotionByName

Formats.m3DSUtils

GetOmnilightNodeCount

Formats.m3DSUtils

GetOmnilightNodeNameList

Formats.m3DSUtils

GetOpenFileNamePreview

Formats.VFW

GetOpenFileNamePreviewA

Formats.VFW

== FilePreview dialog =======================================================

GetOpenFileNamePreviewW

Formats.VFW

GetOrCreateAcceleration

GLS.Behaviours

GetOrCreateAcceleration

GLS.Behaviours

Returns or creates the TGLBAcceleration within the given behaviours. This helper function is convenient way to access a TGLBAcceleration.

GetOrCreateCollision

GLS.Collision

Returns or creates the TGLBCollision within the given behaviours. This helper function is convenient way to access a TGLBCollision.

GetOrCreateCollision

GLS.Collision

Returns or creates the TGLBCollision within the given object's behaviours. This helper function is convenient way to access a TGLBCollision.

GetOrCreateDCEDynamic

GLS.DCE

GetOrCreateDCEDynamic

GLS.DCE

GetOrCreateDCEStatic

GLS.DCE

GetOrCreateDCEStatic

GLS.DCE

GetOrCreateFireFX

GLS.FireFX

Returns or creates the TGLBFireFX within the given behaviours. This helper function is convenient way to access a TGLBFireFX.

GetOrCreateFireFX

GLS.FireFX

Returns or creates the TGLBFireFX within the given object's behaviours. This helper function is convenient way to access a TGLBFireFX.

GetOrCreateFPSMovement

GLS.FPSMovement

GetOrCreateFPSMovement

GLS.FPSMovement

GetOrCreateInertia

GLS.Behaviours

GetOrCreateInertia

GLS.Behaviours

GetOrCreateLibMaterial

GLS.FileDDS

get or create material in material library

GetOrCreateMovement

GLS.Movement

GetOrCreateMovement

GLS.Movement

GetOrCreateNGDDynamic

GLS.NGDManager

GetOrCreateNGDStatic

GLS.NGDManager

GetOrCreateOdeDynamic

GLS.ODEManager

GetOrCreateODEHeightField

GLS.ODEManager

GetOrCreateOdeStatic

GLS.ODEManager

GetOrCreateParticleInertia

GLS.PhysInertias

Returns or creates the TGLParticleInertia within the given behaviours. This helper function is convenient way to access a TGLParticleInertia.

GetOrCreateParticleInertia

GLS.PhysInertias

Returns or creates the TGLParticleInertia within the given object's behaviours. This helper function is convenient way to access a TGLParticleInertia.

GetOrCreateRigidBodyInertia

GLS.PhysInertias

Returns or creates the TGLRigidBodyInertia within the given behaviours. This helper function is convenient way to access a TGLRigidBodyInertia.

GetOrCreateRigidBodyInertia

GLS.PhysInertias

Returns or creates the TGLRigidBodyInertia within the given object's behaviours. This helper function is convenient way to access a TGLRigidBodyInertia.

GetOrCreateSoundEmitter

GLS.SoundManager

GetOrCreateSoundEmitter

GLS.SoundManager

GetOrCreateSourcePFX

GLS.ParticleFX

Returns or creates the TGLBInertia within the given object's behaviours.

GetOrCreateThorFX

GLS.ThorFX

Returns or creates the TGLBThorFX within the given object's effects.

GetProcAddressGLLib

GLS.OpenGLAdapter

GetProcAddressGLS

GLS.OpenGLAdapter

GetQuaternionRec

GLScene.VectorTypesExt

GetRasterFileFormats

GLS.Graphics

Read access to the list of registered vector file formats

GetResultsNx

PhysX.Import

GetROAMTrianglesCapacity

GLS.ROAMPatch

GetSafeTurnAngle

GLScene.VectorGeometry

GetSafeTurnAngle

GLScene.VectorGeometry

Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles

GetSaveFileNamePreview

Formats.VFW

GetOpenFileNamePreviewA

GetSaveFileNamePreviewA

Formats.VFW

GetSaveFileNamePreviewW

Formats.VFW

GetServiceWindow

GLS.Context

GetSoundLibraryByName

GLS.SoundManager

GetSpotlightByIndex

Formats.m3DSUtils

GetSpotlightCount

Formats.m3DSUtils

GetSpotlightMotionByIndex

Formats.m3DSUtils

GetSpotlightMotionByName

Formats.m3DSUtils

GetSpotlightNodeCount

Formats.m3DSUtils

GetSpotlightNodeNameList

Formats.m3DSUtils

GetSqrt255Array

GLScene.Utils

Returns a pointer to an array containing the results of "255*sqrt(i/255)".

GetSurfaceFromObject

GLS.ODEManager

gettext

gnugettext

GetTextureCombiners

GLS.TextureCombiners

Parses a TC text description and setups combiners accordingly. *experimental* Knowledge of texture combiners is a requirement Syntax: pascal-like, one instruction per line, use '//' for comment.
Examples: Tex1:=Tex0; // replace texture 1 with texture 0 Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1
Accepted tokens: Tex0, Tex1, etc. : texture unit PrimaryColor, Col : the primary color ConstantColor, EnvCol : texture environment constant color
Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.

GetTextureElementSize

GLScene.TextureFormat

GetTextureElementSize

GLScene.TextureFormat

Give a pixel size in bytes from texture format or data format

gettext_NoExtract

gnugettext

gettext_NoOp

gnugettext

GetTranslatorNameAndEmail

gnugettext

This returns an empty string if not translated or translator name is not specified.

GetUncompressedFormat

GLScene.TextureFormat

Give uncompressed texture format and OpenGL color format

GetUniformAutoSetMethod

GLSL.ShaderParameter

GetUniformAutoSetMethodName

GLSL.ShaderParameter

GetValueFromStringsIndex

GLScene.Utils

GetVectorFileFormats

GLS.VectorFileObjects

Read access to the list of registered vector file formats

GetVectorRec

GLScene.VectorTypesExt

GetViewport

Formats.m3DSUtils

GetXCollectionClassesList

GLScene.XCollection

GetXCollectionItemClassesList

GLScene.XCollection

Creates and returns a copy of internal list of TXCollectionItem classes. Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.

Get_CUDA_API_Error_String

CUDA.Import

Get_CUDA_FFT_Error_String

CUDA.FourierTransform

GL

GLS.Context

glAccum

GLScene.OpenGL4

GL functions and procedures

glActiveStencilFaceEXT

GLScene.OpenGL4

GL_EXT_stencil_two_side (EXT #268)

glActiveTexture

GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.3 Core ########################################################### promoted to core v1.3 from GL_ARB_multitexture (#1)

glActiveTextureARB

GLScene.OpenGL4

GL_ARB_multitexture (ARB #1)

glActiveVaryingNV

GLScene.OpenGL4

glAddSwapHintRectWIN

GLScene.OpenGL4

GL_WIN_swap_hint (extension # not found)

glAlphaFunc

GLScene.OpenGL4

deprecated;

glAreProgramsResidentNV

GLScene.OpenGL4

GL_NV_vertex_program (EXT #233)

glAreTexturesResident

GLScene.OpenGL4

deprecated;

glAreTexturesResidentEXT

GLScene.OpenGL4

glArrayElement

GLScene.OpenGL4

deprecated;

glArrayElementArrayEXT

GLScene.OpenGL4

########################################################### function and procedure definitions for Vendor/EXT extensions ########################################################### Unknown Vendor/EXT functions

glAttachObjectARB

GLScene.OpenGL4

glAttachShader

GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)

glBegin

GLScene.OpenGL4

deprecated;

glBeginConditionalRender

GLScene.OpenGL4

glBeginConditionalRenderNV

GLScene.OpenGL4

GL_NV_conditional_render (#346)

glBeginOcclusionQueryNV

GLScene.OpenGL4

glBeginQuery

GLScene.OpenGL4

glBeginQueryARB

GLScene.OpenGL4

glBeginQueryIndexed

GLScene.OpenGL4

glBeginSceneEXT

GLScene.OpenGL4

GL_EXT_scene_marker (EXT #120)

glBeginTransformFeedback

GLScene.OpenGL4

glBeginTransformFeedbackEXT

GLScene.OpenGL4

glBeginTransformFeedbackNV

GLScene.OpenGL4

glBindAttribLocation

GLScene.OpenGL4

glBindAttribLocationARB

GLScene.OpenGL4

GL_ARB_vertex_shader (ARB #31)

glBindBuffer

GLScene.OpenGL4

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)

glBindBufferARB

GLScene.OpenGL4

GL_ARB_vertex_buffer_object (ARB #28)

glBindBufferBase

GLScene.OpenGL4

glBindBufferBaseEXT

GLScene.OpenGL4

glBindBufferBaseNV

GLScene.OpenGL4

glBindBufferOffsetEXT

GLScene.OpenGL4

glBindBufferOffsetNV

GLScene.OpenGL4

glBindBufferRange

GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_transform_feedback

glBindBufferRangeEXT

GLScene.OpenGL4

GL_EXT_transform_feedback (#352)

glBindBufferRangeNV

GLScene.OpenGL4

GL_NV_transform_feedback (#341)

glBindFragDataLocation

GLScene.OpenGL4

glBindFragDataLocationEXT

GLScene.OpenGL4

glBindFragDataLocationIndexed

GLScene.OpenGL4

GL_ARB_blend_func_extended (ARB #78)

glBindFramebuffer

GLScene.OpenGL4

glBindFramebufferEXT

GLScene.OpenGL4

glBindProgramARB

GLScene.OpenGL4

glBindProgramNV

GLScene.OpenGL4

glBindRenderbuffer

GLScene.OpenGL4

glBindRenderbufferEXT

GLScene.OpenGL4

glBindSampler

GLScene.OpenGL4

glBindTexture

GLScene.OpenGL4

deprecated;

glBindTextureEXT

GLScene.OpenGL4

glBindTransformFeedback

GLScene.OpenGL4

GL_ARB_transform_feedback2 (ARB #93)

glBindVertexArray

GLScene.OpenGL4

GL_ARB_vertex_array_object (ARB #54)

GLbitfield

GLScene.OpenGL4

glBitmap

GLScene.OpenGL4

glBlendColor

GLScene.OpenGL4

——————- OpenGL extension function/procedure definitions —————— ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.2 Core ########################################################### promoted to core v1.2 from GL_EXT_blend_color (#2)

glBlendColorEXT

GLScene.OpenGL4

GL_EXT_blend_color (EXT #2)

glBlendEquation

GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_blend_minmax (#37)

glBlendEquationEXT

GLScene.OpenGL4

GL_EXT_blend_minmax (EXT #37)

glBlendEquationi

GLScene.OpenGL4

GL_ARB_draw_buffers_blend (ARB #69)

glBlendEquationSeparate

GLScene.OpenGL4

promoted to core v1.5 from GL_EXT_shadow_funcs (#267) (no functions or procedures) ########################################################### function and procedure definitions for extensions integrated into OpenGL 2.0 Core ########################################################### promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)

glBlendEquationSeparateEXT

GLScene.OpenGL4

GL_EXT_blend_equation_separate (EXT #299)

glBlendEquationSeparatei

GLScene.OpenGL4

glBlendFunc

GLScene.OpenGL4

deprecated;

glBlendFunci

GLScene.OpenGL4

glBlendFuncSeparate

GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.4 Core ########################################################### promoted to core v1.4 from GL_EXT_blend_func_separate (#173)

glBlendFuncSeparateEXT

GLScene.OpenGL4

GL_EXT_blend_func_separate (EXT #173)

glBlendFuncSeparatei

GLScene.OpenGL4

glBlitFramebuffer

GLScene.OpenGL4

glBlitFramebufferEXT

GLScene.OpenGL4

GL_EXT_framebuffer_blit (#316)

GLboolean

GLScene.OpenGL4

glBufferAddressRangeNV

GLScene.OpenGL4

GL_NV_vertex_buffer_unified_memory (#380)

glBufferData

GLScene.OpenGL4

glBufferDataARB

GLScene.OpenGL4

glBufferSubData

GLScene.OpenGL4

glBufferSubDataARB

GLScene.OpenGL4

GLbyte

GLScene.OpenGL4

glCallList

GLScene.OpenGL4

glCallLists

GLScene.OpenGL4

deprecated;

glCheckFramebufferStatus

GLScene.OpenGL4

glCheckFramebufferStatusEXT

GLScene.OpenGL4

glClampColor

GLScene.OpenGL4

glClampColorARB

GLScene.OpenGL4

GL_ARB_color_buffer_float (ARB #39)

GLclampd

GLScene.OpenGL4

GLclampf

GLScene.OpenGL4

glClear

GLScene.OpenGL4

deprecated;

glClearAccum

GLScene.OpenGL4

glClearBufferfi

GLScene.OpenGL4

glClearBufferfv

GLScene.OpenGL4

glClearBufferiv

GLScene.OpenGL4

New commands in OpenGL 3.0

glClearBufferuiv

GLScene.OpenGL4

glClearColor

GLScene.OpenGL4

deprecated;

glClearColorIiEXT

GLScene.OpenGL4

GL_EXT_texture_integer (#343)

glClearColorIuiEXT

GLScene.OpenGL4

glClearDepth

GLScene.OpenGL4

glClearIndex

GLScene.OpenGL4

glClearStencil

GLScene.OpenGL4

deprecated;

glClientActiveTexture

GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_multitexture (#1)

glClientActiveTextureARB

GLScene.OpenGL4

glClientWaitSync

GLScene.OpenGL4

glClipPlane

GLScene.OpenGL4

glColor3b

GLScene.OpenGL4

deprecated;

glColor3bv

GLScene.OpenGL4

deprecated;

glColor3d

GLScene.OpenGL4

deprecated;

glColor3dv

GLScene.OpenGL4

deprecated;

glColor3f

GLScene.OpenGL4

deprecated;

glColor3fv

GLScene.OpenGL4

deprecated;

glColor3i

GLScene.OpenGL4

deprecated;

glColor3iv

GLScene.OpenGL4

deprecated;

glColor3s

GLScene.OpenGL4

deprecated;

glColor3sv

GLScene.OpenGL4

deprecated;

glColor3ub

GLScene.OpenGL4

deprecated;

glColor3ubv

GLScene.OpenGL4

deprecated;

glColor3ui

GLScene.OpenGL4

deprecated;

glColor3uiv

GLScene.OpenGL4

deprecated;

glColor3us

GLScene.OpenGL4

deprecated;

glColor3usv

GLScene.OpenGL4

deprecated;

glColor4b

GLScene.OpenGL4

deprecated;

glColor4bv

GLScene.OpenGL4

deprecated;

glColor4d

GLScene.OpenGL4

deprecated;

glColor4dv

GLScene.OpenGL4

deprecated;

glColor4f

GLScene.OpenGL4

deprecated;

glColor4fv

GLScene.OpenGL4

deprecated;

glColor4i

GLScene.OpenGL4

deprecated;

glColor4iv

GLScene.OpenGL4

deprecated;

glColor4s

GLScene.OpenGL4

deprecated;

glColor4sv

GLScene.OpenGL4

deprecated;

glColor4ub

GLScene.OpenGL4

deprecated;

glColor4ubv

GLScene.OpenGL4

deprecated;

glColor4ui

GLScene.OpenGL4

deprecated;

glColor4uiv

GLScene.OpenGL4

deprecated;

glColor4us

GLScene.OpenGL4

deprecated;

glColor4usv

GLScene.OpenGL4

deprecated;

glColorFormatNV

GLScene.OpenGL4

glColorMask

GLScene.OpenGL4

deprecated;

glColorMaski

GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_draw_buffers2

glColorMaskIndexedEXT

GLScene.OpenGL4

GL_EXT_draw_buffers2 (#340)

glColorMaterial

GLScene.OpenGL4

glColorP3ui

GLScene.OpenGL4

glColorP3uiv

GLScene.OpenGL4

glColorP4ui

GLScene.OpenGL4

glColorP4uiv

GLScene.OpenGL4

glColorPointer

GLScene.OpenGL4

deprecated;

glColorSubTable

GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)

glColorSubTableExt

GLScene.OpenGL4

glColorTable

GLScene.OpenGL4

OpenGL 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)

glColorTableEXT

GLScene.OpenGL4

GL_EXT_paletted_texture (EXT #78)

glColorTableParameterfv

GLScene.OpenGL4

deprecated;

glColorTableParameteriv

GLScene.OpenGL4

deprecated;

glCombinerInputNV

GLScene.OpenGL4

glCombinerOutputNV

GLScene.OpenGL4

glCombinerParameterfNV

GLScene.OpenGL4

glCombinerParameterfvNV

GLScene.OpenGL4

GL_NV_register_combiners (EXT #191)

glCombinerParameteriNV

GLScene.OpenGL4

glCombinerParameterivNV

GLScene.OpenGL4

glCompileShader

GLScene.OpenGL4

glCompileShaderARB

GLScene.OpenGL4

glCompressedTexImage1D

GLScene.OpenGL4

glCompressedTexImage1DARB

GLScene.OpenGL4

glCompressedTexImage2D

GLScene.OpenGL4

glCompressedTexImage2DARB

GLScene.OpenGL4

glCompressedTexImage3D

GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_texture_compression (#12)

glCompressedTexImage3DARB

GLScene.OpenGL4

GL_ARB_texture_compression (ARB #12)

glCompressedTexSubImage1D

GLScene.OpenGL4

glCompressedTexSubImage1DARB

GLScene.OpenGL4

glCompressedTexSubImage2D

GLScene.OpenGL4

glCompressedTexSubImage2DARB

GLScene.OpenGL4

glCompressedTexSubImage3D

GLScene.OpenGL4

glCompressedTexSubImage3DARB

GLScene.OpenGL4

GLContextManager

GLS.Context

glConvolutionFilter1D

GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)

glConvolutionFilter2D

GLScene.OpenGL4

deprecated;

glConvolutionParameterf

GLScene.OpenGL4

deprecated;

glConvolutionParameterfv

GLScene.OpenGL4

deprecated;

glConvolutionParameteri

GLScene.OpenGL4

deprecated;

glConvolutionParameteriv

GLScene.OpenGL4

deprecated;

glCopyBufferSubData

GLScene.OpenGL4

GL_ARB_copy_buffer (ARB #59)

glCopyColorSubTable

GLScene.OpenGL4

deprecated;

glCopyColorTable

GLScene.OpenGL4

deprecated;

glCopyConvolutionFilter1D

GLScene.OpenGL4

deprecated;

glCopyConvolutionFilter2D

GLScene.OpenGL4

deprecated;

glCopyImageSubDataNV

GLScene.OpenGL4

GL_NV_copy_image (#376)

glCopyPixels

GLScene.OpenGL4

deprecated;

glCopyTexImage1D

GLScene.OpenGL4

deprecated;

glCopyTexImage1DEXT

GLScene.OpenGL4

GL_EXT_copy_texture (EXT #10)

glCopyTexImage2D

GLScene.OpenGL4

glCopyTexImage2DEXT

GLScene.OpenGL4

glCopyTexSubImage1D

GLScene.OpenGL4

glCopyTexSubImage1DEXT

GLScene.OpenGL4

glCopyTexSubImage2D

GLScene.OpenGL4

glCopyTexSubImage2DEXT

GLScene.OpenGL4

glCopyTexSubImage3D

GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_copy_texture

glCopyTexSubImage3DEXT

GLScene.OpenGL4

glCreateProgram

GLScene.OpenGL4

glCreateProgramObjectARB

GLScene.OpenGL4

glCreateShader

GLScene.OpenGL4

glCreateShaderObjectARB

GLScene.OpenGL4

GLCUDAEditorForm

FmCUDAEditor

glCullFace

GLScene.OpenGL4

glCurrentPaletteMatrixARB

GLScene.OpenGL4

GL_ARB_matrix_palette (ARB #16) {deprecated?}

glDeleteBuffers

GLScene.OpenGL4

glDeleteBuffersARB

GLScene.OpenGL4

glDeleteFencesNV

GLScene.OpenGL4

glDeleteFramebuffers

GLScene.OpenGL4

glDeleteFramebuffersEXT

GLScene.OpenGL4

glDeleteLists

GLScene.OpenGL4

glDeleteObjectARB

GLScene.OpenGL4

GL_ARB_shader_objects (ARB #30)

glDeleteOcclusionQueriesNV

GLScene.OpenGL4

glDeleteProgram

GLScene.OpenGL4

glDeleteProgramsARB

GLScene.OpenGL4

glDeleteProgramsNV

GLScene.OpenGL4

glDeleteQueries

GLScene.OpenGL4

glDeleteQueriesARB

GLScene.OpenGL4

glDeleteRenderbuffers

GLScene.OpenGL4

glDeleteRenderbuffersEXT

GLScene.OpenGL4

glDeleteSamplers

GLScene.OpenGL4

glDeleteShader

GLScene.OpenGL4

glDeleteSync

GLScene.OpenGL4

glDeleteTextures

GLScene.OpenGL4

deprecated;

glDeleteTexturesEXT

GLScene.OpenGL4

glDeleteTransformFeedbacks

GLScene.OpenGL4

glDeleteVertexArrays

GLScene.OpenGL4

glDepthBoundsEXT

GLScene.OpenGL4

GL_EXT_depth_bounds_test (EXT #297)

glDepthFunc

GLScene.OpenGL4

glDepthMask

GLScene.OpenGL4

glDepthRange

GLScene.OpenGL4

glDetachObjectARB

GLScene.OpenGL4

glDetachShader

GLScene.OpenGL4

GLDirectionFromGeom

GLS.ODEUtils

glDisable

GLScene.OpenGL4

glDisableClientState

GLScene.OpenGL4

glDisablei

GLScene.OpenGL4

glDisableIndexedEXT

GLScene.OpenGL4

glDisableVertexAttribArray

GLScene.OpenGL4

glDisableVertexAttribArrayARB

GLScene.OpenGL4

GLdouble

GLScene.OpenGL4

glDrawArrays

GLScene.OpenGL4

deprecated;

glDrawArraysIndirect

GLScene.OpenGL4

GL_ARB_draw_indirect (ARB #87)

glDrawArraysInstanced

GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.1 Core ###########################################################

glDrawArraysInstancedARB

GLScene.OpenGL4

GL_ARB_draw_instanced (ARB #44)

glDrawArraysInstancedEXT

GLScene.OpenGL4

GL_EXT_draw_instanced (#327)

glDrawBuffer

GLScene.OpenGL4

glDrawBuffers

GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_draw_buffers (#37)

glDrawBuffersARB

GLScene.OpenGL4

GL_ARB_DrawBuffers (ARB #37)

glDrawBuffersATI

GLScene.OpenGL4

GL_ATI_draw_buffers (EXT #277)

glDrawElements

GLScene.OpenGL4

glDrawElementsBaseVertex

GLScene.OpenGL4

GL_ARB_draw_elements_base_vertex (ARB #62)

glDrawElementsIndirect

GLScene.OpenGL4

glDrawElementsInstanced

GLScene.OpenGL4

glDrawElementsInstancedARB

GLScene.OpenGL4

glDrawElementsInstancedBaseVertex

GLScene.OpenGL4

glDrawElementsInstancedEXT

GLScene.OpenGL4

glDrawPixels

GLScene.OpenGL4

glDrawRangeElements

GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)

glDrawRangeElementsBaseVertex

GLScene.OpenGL4

glDrawRangeElementsEXT

GLScene.OpenGL4

GL_EXT_draw_range_elements (EXT #112)

glDrawTransformFeedback

GLScene.OpenGL4

glDrawTransformFeedbackStream

GLScene.OpenGL4

GL_ARB_transform_feedback3 (ARB #94)

glEdgeFlag

GLScene.OpenGL4

deprecated;

glEdgeFlagFormatNV

GLScene.OpenGL4

glEdgeFlagPointer

GLScene.OpenGL4

deprecated;

glEdgeFlagv

GLScene.OpenGL4

deprecated;

glEnable

GLScene.OpenGL4

deprecated;

glEnableClientState

GLScene.OpenGL4

glEnablei

GLScene.OpenGL4

glEnableIndexedEXT

GLScene.OpenGL4

glEnableVertexAttribArray

GLScene.OpenGL4

glEnableVertexAttribArrayARB

GLScene.OpenGL4

glEnd

GLScene.OpenGL4

deprecated;

glEndConditionalRender

GLScene.OpenGL4

glEndConditionalRenderNV

GLScene.OpenGL4

glEndList

GLScene.OpenGL4

deprecated;

glEndOcclusionQueryNV

GLScene.OpenGL4

glEndQuery

GLScene.OpenGL4

glEndQueryARB

GLScene.OpenGL4

glEndQueryIndexed

GLScene.OpenGL4

glEndSceneEXT

GLScene.OpenGL4

glEndTransformFeedback

GLScene.OpenGL4

glEndTransformFeedbackEXT

GLScene.OpenGL4

glEndTransformFeedbackNV

GLScene.OpenGL4

GLenum

GLScene.OpenGL4

GLEnumToDDSHeader

Formats.DXTC

glEvalCoord1d

GLScene.OpenGL4

deprecated;

glEvalCoord1dv

GLScene.OpenGL4

deprecated;

glEvalCoord1f

GLScene.OpenGL4

deprecated;

glEvalCoord1fv

GLScene.OpenGL4

deprecated;

glEvalCoord2d

GLScene.OpenGL4

deprecated;

glEvalCoord2dv

GLScene.OpenGL4

deprecated;

glEvalCoord2f

GLScene.OpenGL4

deprecated;

glEvalCoord2fv

GLScene.OpenGL4

deprecated;

glEvalMesh1

GLScene.OpenGL4

deprecated;

glEvalMesh2

GLScene.OpenGL4

deprecated;

glEvalPoint1

GLScene.OpenGL4

deprecated;

glEvalPoint2

GLScene.OpenGL4

deprecated;

glExecuteProgramNV

GLScene.OpenGL4

glFeedbackBuffer

GLScene.OpenGL4

deprecated;

glFenceSync

GLScene.OpenGL4

GL_ARB_sync (ARB #66)

glFinalCombinerInputNV

GLScene.OpenGL4

glFinish

GLScene.OpenGL4

deprecated;

glFinishFenceNV

GLScene.OpenGL4

GLfloat

GLScene.OpenGL4

glFlush

GLScene.OpenGL4

glFlushMappedBufferRange

GLScene.OpenGL4

glFlushVertexArrayRangeNV

GLScene.OpenGL4

GL_NV_vertex_array_range (EXT #190)

glFogCoordd

GLScene.OpenGL4

deprecated;

glFogCoorddEXT

GLScene.OpenGL4

glFogCoorddv

GLScene.OpenGL4

deprecated;

glFogCoorddvEXT

GLScene.OpenGL4

glFogCoordf

GLScene.OpenGL4

promoted to core v1.4 from GL_EXT_fog_coord (#149)

glFogCoordfEXT

GLScene.OpenGL4

GL_EXT_fog_coord (EXT #149)

glFogCoordFormatNV

GLScene.OpenGL4

glFogCoordfv

GLScene.OpenGL4

deprecated;

glFogCoordfvEXT

GLScene.OpenGL4

glFogCoordPointer

GLScene.OpenGL4

deprecated;

glFogCoordPointerEXT

GLScene.OpenGL4

glFogf

GLScene.OpenGL4

glFogfv

GLScene.OpenGL4

deprecated;

glFogi

GLScene.OpenGL4

deprecated;

glFogiv

GLScene.OpenGL4

deprecated;

glFramebufferRenderbuffer

GLScene.OpenGL4

glFramebufferRenderbufferEXT

GLScene.OpenGL4

glFramebufferTexture

GLScene.OpenGL4

glFramebufferTexture1D

GLScene.OpenGL4

glFramebufferTexture1DEXT

GLScene.OpenGL4

glFramebufferTexture2D

GLScene.OpenGL4

glFramebufferTexture2DEXT

GLScene.OpenGL4

glFramebufferTexture3D

GLScene.OpenGL4

glFramebufferTexture3DEXT

GLScene.OpenGL4

glFramebufferTextureARB

GLScene.OpenGL4

glFramebufferTextureEXT

GLScene.OpenGL4

glFramebufferTextureFaceARB

GLScene.OpenGL4

glFramebufferTextureFaceEXT

GLScene.OpenGL4

glFramebufferTextureLayer

GLScene.OpenGL4

glFramebufferTextureLayerARB

GLScene.OpenGL4

glFramebufferTextureLayerEXT

GLScene.OpenGL4

glFrameTerminatorGREMEDY

GLScene.OpenGL4

Special Gremedy debugger extension

glFrontFace

GLScene.OpenGL4

deprecated;

glFrustum

GLScene.OpenGL4

glGenBuffers

GLScene.OpenGL4

glGenBuffersARB

GLScene.OpenGL4

glGenerateMipmap

GLScene.OpenGL4

glGenerateMipmapEXT

GLScene.OpenGL4

glGenFencesNV

GLScene.OpenGL4

GL_NV_fence (EXT #222)

glGenFramebuffers

GLScene.OpenGL4

glGenFramebuffersEXT

GLScene.OpenGL4

glGenLists

GLScene.OpenGL4

deprecated;

glGenOcclusionQueriesNV

GLScene.OpenGL4

GL_NV_occlusion_query (EXT #261)

glGenProgramsARB

GLScene.OpenGL4

glGenProgramsNV

GLScene.OpenGL4

glGenQueries

GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.5 Core ########################################################### promoted to core v1.5 from GL_ARB_occlusion_query (#29)

glGenQueriesARB

GLScene.OpenGL4

GL_ARB_occlusion_query (ARB #29)

glGenRenderbuffers

GLScene.OpenGL4

glGenRenderbuffersEXT

GLScene.OpenGL4

glGenSamplers

GLScene.OpenGL4

GL_ARB_sampler_objects (ARB #81)

glGenTextures

GLScene.OpenGL4

deprecated;

glGenTexturesEXT

GLScene.OpenGL4

GL_EXT_texture_object (EXT #20)

glGenTransformFeedbacks

GLScene.OpenGL4

glGenVertexArrays

GLScene.OpenGL4

glGetActiveAttrib

GLScene.OpenGL4

glGetActiveAttribARB

GLScene.OpenGL4

glGetActiveSubroutineName

GLScene.OpenGL4

glGetActiveSubroutineUniformiv

GLScene.OpenGL4

glGetActiveSubroutineUniformName

GLScene.OpenGL4

glGetActiveUniform

GLScene.OpenGL4

glGetActiveUniformARB

GLScene.OpenGL4

glGetActiveUniformBlockiv

GLScene.OpenGL4

glGetActiveUniformBlockName

GLScene.OpenGL4

glGetActiveUniformName

GLScene.OpenGL4

glGetActiveUniformsiv

GLScene.OpenGL4

glGetActiveVaryingNV

GLScene.OpenGL4

glGetAttachedObjectsARB

GLScene.OpenGL4

glGetAttachedShaders

GLScene.OpenGL4

glGetAttribLocation

GLScene.OpenGL4

glGetAttribLocationARB

GLScene.OpenGL4

glGetBooleanIndexedvEXT

GLScene.OpenGL4

glGetBooleani_v

GLScene.OpenGL4

glGetBooleanv

GLScene.OpenGL4

glGetBufferParameteri64v

GLScene.OpenGL4

glGetBufferParameteriv

GLScene.OpenGL4

glGetBufferParameterivARB

GLScene.OpenGL4

glGetBufferParameterui64vNV

GLScene.OpenGL4

glGetBufferPointerv

GLScene.OpenGL4

glGetBufferPointervARB

GLScene.OpenGL4

glGetBufferSubData

GLScene.OpenGL4

glGetBufferSubDataARB

GLScene.OpenGL4

glGetClipPlane

GLScene.OpenGL4

glGetColorTable

GLScene.OpenGL4

deprecated;

glGetColorTableEXT

GLScene.OpenGL4

glGetColorTableParameterfv

GLScene.OpenGL4

deprecated;

glGetColorTableParameterfvEXT

GLScene.OpenGL4

glGetColorTableParameteriv

GLScene.OpenGL4

deprecated;

glGetColorTableParameterivEXT

GLScene.OpenGL4

glGetCombinerInputParameterfvNV

GLScene.OpenGL4

glGetCombinerInputParameterivNV

GLScene.OpenGL4

glGetCombinerOutputParameterfvNV

GLScene.OpenGL4

glGetCombinerOutputParameterivNV

GLScene.OpenGL4

glGetCompressedTexImage

GLScene.OpenGL4

glGetCompressedTexImageARB

GLScene.OpenGL4

glGetConvolutionFilter

GLScene.OpenGL4

deprecated;

glGetConvolutionParameterfv

GLScene.OpenGL4

deprecated;

glGetConvolutionParameteriv

GLScene.OpenGL4

deprecated;

GLGetCursorPos

GLS.Screen

glGetDoublev

GLScene.OpenGL4

deprecated;

glGetError

GLScene.OpenGL4

glGetFenceivNV

GLScene.OpenGL4

glGetFinalCombinerInputParameterfvNV

GLScene.OpenGL4

glGetFinalCombinerInputParameterivNV

GLScene.OpenGL4

glGetFloatv

GLScene.OpenGL4

glGetFragDataIndex

GLScene.OpenGL4

glGetFragDataLocation

GLScene.OpenGL4

glGetFragDataLocationEXT

GLScene.OpenGL4

glGetFramebufferAttachmentParameteriv

GLScene.OpenGL4

glGetFramebufferAttachmentParameterivEXT

GLScene.OpenGL4

glGetHandleARB

GLScene.OpenGL4

glGetHistogram

GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)

glGetHistogramParameterfv

GLScene.OpenGL4

deprecated;

glGetHistogramParameteriv

GLScene.OpenGL4

deprecated;

glGetInfoLogARB

GLScene.OpenGL4

glGetInteger64i_v

GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.2 Core ###########################################################

glGetInteger64v

GLScene.OpenGL4

glGetIntegerIndexedvEXT

GLScene.OpenGL4

glGetIntegeri_v

GLScene.OpenGL4

glGetIntegerui64i_vNV

GLScene.OpenGL4

glGetIntegerui64vNV

GLScene.OpenGL4

glGetIntegerv

GLScene.OpenGL4

glGetLightfv

GLScene.OpenGL4

glGetLightiv

GLScene.OpenGL4

deprecated;

glGetMapdv

GLScene.OpenGL4

deprecated;

glGetMapfv

GLScene.OpenGL4

deprecated;

glGetMapiv

GLScene.OpenGL4

deprecated;

glGetMaterialfv

GLScene.OpenGL4

deprecated;

glGetMaterialiv

GLScene.OpenGL4

deprecated;

glGetMinmax

GLScene.OpenGL4

deprecated;

glGetMinmaxParameterfv

GLScene.OpenGL4

deprecated;

glGetMinmaxParameteriv

GLScene.OpenGL4

deprecated;

glGetMultisamplefv

GLScene.OpenGL4

glGetNamedBufferParameterui64vNV

GLScene.OpenGL4

glGetObjectParameterfvARB

GLScene.OpenGL4

glGetObjectParameterivARB

GLScene.OpenGL4

glGetOcclusionQueryivNV

GLScene.OpenGL4

glGetOcclusionQueryuivNV

GLScene.OpenGL4

glGetPixelMapfv

GLScene.OpenGL4

deprecated;

glGetPixelMapuiv

GLScene.OpenGL4

deprecated;

glGetPixelMapusv

GLScene.OpenGL4

deprecated;

glGetPointerv

GLScene.OpenGL4

deprecated;

glGetPolygonStipple

GLScene.OpenGL4

GLGetProcAddress

GLScene.OpenGL4

——————————————————————————

glGetProgramEnvParameterdvARB

GLScene.OpenGL4

glGetProgramEnvParameterfvARB

GLScene.OpenGL4

glGetProgramInfoLog

GLScene.OpenGL4

glGetProgramiv

GLScene.OpenGL4

glGetProgramivARB

GLScene.OpenGL4

glGetProgramivNV

GLScene.OpenGL4

glGetProgramLocalParameterdvARB

GLScene.OpenGL4

glGetProgramLocalParameterfvARB

GLScene.OpenGL4

glGetProgramParameterdvNV

GLScene.OpenGL4

glGetProgramParameterfvNV

GLScene.OpenGL4

glGetProgramStageiv

GLScene.OpenGL4

glGetProgramStringARB

GLScene.OpenGL4

glGetProgramStringNV

GLScene.OpenGL4

glGetQueryIndexediv

GLScene.OpenGL4

glGetQueryiv

GLScene.OpenGL4

glGetQueryivARB

GLScene.OpenGL4

glGetQueryObjecti64v

GLScene.OpenGL4

glGetQueryObjecti64vEXT

GLScene.OpenGL4

GL_EXT_timer_query (#319)

glGetQueryObjectiv

GLScene.OpenGL4

glGetQueryObjectivARB

GLScene.OpenGL4

glGetQueryObjectui64v

GLScene.OpenGL4

glGetQueryObjectui64vEXT

GLScene.OpenGL4

glGetQueryObjectuiv

GLScene.OpenGL4

glGetQueryObjectuivARB

GLScene.OpenGL4

glGetRenderbufferParameteriv

GLScene.OpenGL4

glGetRenderbufferParameterivEXT

GLScene.OpenGL4

glGetSamplerParameterfv

GLScene.OpenGL4

glGetSamplerParameterIfv

GLScene.OpenGL4

glGetSamplerParameterIiv

GLScene.OpenGL4

glGetSamplerParameteriv

GLScene.OpenGL4

GLGetScreenHeight

GLS.Screen

GLGetScreenWidth

GLS.Screen

glGetSeparableFilter

GLScene.OpenGL4

deprecated;

glGetShaderInfoLog

GLScene.OpenGL4

glGetShaderiv

GLScene.OpenGL4

glGetShaderSource

GLScene.OpenGL4

glGetShaderSourceARB

GLScene.OpenGL4

glGetString

GLScene.OpenGL4

deprecated;

glGetStringi

GLScene.OpenGL4

glGetSubroutineIndex

GLScene.OpenGL4

glGetSubroutineUniformLocation

GLScene.OpenGL4

GL_ARB_shader_subroutine (ARB #90)

glGetSynciv

GLScene.OpenGL4

glGetTexEnvfv

GLScene.OpenGL4

glGetTexEnviv

GLScene.OpenGL4

deprecated;

glGetTexGendv

GLScene.OpenGL4

deprecated;

glGetTexGenfv

GLScene.OpenGL4

deprecated;

glGetTexGeniv

GLScene.OpenGL4

deprecated;

glGetTexImage

GLScene.OpenGL4

deprecated;

glGetTexLevelParameterfv

GLScene.OpenGL4

glGetTexLevelParameteriv

GLScene.OpenGL4

glGetTexParameterfv

GLScene.OpenGL4

glGetTexParameterIiv

GLScene.OpenGL4

glGetTexParameterIivEXT

GLScene.OpenGL4

glGetTexParameterIuiv

GLScene.OpenGL4

glGetTexParameterIuivEXT

GLScene.OpenGL4

glGetTexParameteriv

GLScene.OpenGL4

glGetTrackMatrixivNV

GLScene.OpenGL4

glGetTransformFeedbackVarying

GLScene.OpenGL4

glGetTransformFeedbackVaryingEXT

GLScene.OpenGL4

glGetTransformFeedbackVaryingNV

GLScene.OpenGL4

glGetUniformBlockIndex

GLScene.OpenGL4

glGetUniformBufferSizeEXT

GLScene.OpenGL4

glGetUniformdv

GLScene.OpenGL4

glGetUniformfv

GLScene.OpenGL4

glGetUniformfvARB

GLScene.OpenGL4

glGetUniformIndices

GLScene.OpenGL4

GL_ARB_uniform_buffer_object (ARB #57)

glGetUniformiv

GLScene.OpenGL4

glGetUniformivARB

GLScene.OpenGL4

glGetUniformLocation

GLScene.OpenGL4

glGetUniformLocationARB

GLScene.OpenGL4

glGetUniformOffsetEXT

GLScene.OpenGL4

glGetUniformSubroutineuiv

GLScene.OpenGL4

glGetUniformui64vNV

GLScene.OpenGL4

glGetUniformuiv

GLScene.OpenGL4

glGetUniformuivEXT

GLScene.OpenGL4

glGetVaryingLocationNV

GLScene.OpenGL4

glGetVertexAttribdv

GLScene.OpenGL4

glGetVertexAttribdvARB

GLScene.OpenGL4

glGetVertexAttribdvNV

GLScene.OpenGL4

glGetVertexAttribfv

GLScene.OpenGL4

glGetVertexAttribfvARB

GLScene.OpenGL4

glGetVertexAttribfvNV

GLScene.OpenGL4

glGetVertexAttribIiv

GLScene.OpenGL4

glGetVertexAttribIivEXT

GLScene.OpenGL4

glGetVertexAttribIuiv

GLScene.OpenGL4

glGetVertexAttribIuivEXT

GLScene.OpenGL4

glGetVertexAttribiv

GLScene.OpenGL4

glGetVertexAttribivARB

GLScene.OpenGL4

glGetVertexAttribivNV

GLScene.OpenGL4

glGetVertexAttribPointerv

GLScene.OpenGL4

glGetVertexAttribPointervARB

GLScene.OpenGL4

glGetVertexAttribPointervNV

GLScene.OpenGL4

GLhandleARB

GLScene.OpenGL4

glHint

GLScene.OpenGL4

glHistogram

GLScene.OpenGL4

deprecated;

glIndexd

GLScene.OpenGL4

deprecated;

glIndexdv

GLScene.OpenGL4

deprecated;

glIndexf

GLScene.OpenGL4

deprecated;

glIndexFormatNV

GLScene.OpenGL4

glIndexFuncEXT

GLScene.OpenGL4

GL_EXT_index_func (EXT #95)

glIndexfv

GLScene.OpenGL4

deprecated;

glIndexi

GLScene.OpenGL4

deprecated;

glIndexiv

GLScene.OpenGL4

deprecated;

glIndexMask

GLScene.OpenGL4

glIndexMaterialEXT

GLScene.OpenGL4

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} GL_EXT_index_material (EXT #94)

glIndexPointer

GLScene.OpenGL4

deprecated;

glIndexs

GLScene.OpenGL4

deprecated;

glIndexsv

GLScene.OpenGL4

deprecated;

glIndexub

GLScene.OpenGL4

deprecated;

glIndexubv

GLScene.OpenGL4

deprecated;

glInitNames

GLScene.OpenGL4

deprecated;

GLint

GLScene.OpenGL4

GLint64

GLScene.OpenGL4

GLint64EXT

GLScene.OpenGL4

glInterleavedArrays

GLScene.OpenGL4

deprecated;

glIsBuffer

GLScene.OpenGL4

glIsBufferARB

GLScene.OpenGL4

glIsBufferResidentNV

GLScene.OpenGL4

glIsEnabled

GLScene.OpenGL4

deprecated;

glIsEnabledi

GLScene.OpenGL4

glIsEnabledIndexedEXT

GLScene.OpenGL4

glIsFenceNV

GLScene.OpenGL4

glIsFramebuffer

GLScene.OpenGL4

glIsFramebufferEXT

GLScene.OpenGL4

glIsList

GLScene.OpenGL4

glIsNamedBufferResidentNV

GLScene.OpenGL4

glIsOcclusionQueryNV

GLScene.OpenGL4

glIsProgram

GLScene.OpenGL4

glIsProgramARB

GLScene.OpenGL4

glIsProgramNV

GLScene.OpenGL4

glIsQuery

GLScene.OpenGL4

glIsQueryARB

GLScene.OpenGL4

glIsRenderbuffer

GLScene.OpenGL4

GL_ARB_framebuffer_object (ARB #45)

glIsRenderbufferEXT

GLScene.OpenGL4

GL_EXT_framebuffer_object (EXT #310)

glIsSampler

GLScene.OpenGL4

glIsShader

GLScene.OpenGL4

glIsSync

GLScene.OpenGL4

glIsTexture

GLScene.OpenGL4

glIsTextureEXT

GLScene.OpenGL4

glIsTransformFeedback

GLScene.OpenGL4

glIsVertexArray

GLScene.OpenGL4

GLLibMaterialPickerForm

FmLibMaterialPicker

For registration in GLScene

glLightf

GLScene.OpenGL4

deprecated;

glLightfv

GLScene.OpenGL4

deprecated;

glLighti

GLScene.OpenGL4

deprecated;

glLightiv

GLScene.OpenGL4

deprecated;

glLightModelf

GLScene.OpenGL4

glLightModelfv

GLScene.OpenGL4

deprecated;

glLightModeli

GLScene.OpenGL4

deprecated;

glLightModeliv

GLScene.OpenGL4

deprecated;

glLineStipple

GLScene.OpenGL4

deprecated;

glLineWidth

GLScene.OpenGL4

deprecated;

glLinkProgram

GLScene.OpenGL4

glLinkProgramARB

GLScene.OpenGL4

glListBase

GLScene.OpenGL4

GLLoadBitmapFromInstance

GLS.ImageUtils

glLoadIdentity

GLScene.OpenGL4

deprecated;

glLoadMatrixd

GLScene.OpenGL4

deprecated;

glLoadMatrixf

GLScene.OpenGL4

deprecated;

glLoadName

GLScene.OpenGL4

deprecated;

glLoadProgramNV

GLScene.OpenGL4

glLoadTransposeMatrixd

GLScene.OpenGL4

deprecated;

glLoadTransposeMatrixdARB

GLScene.OpenGL4

glLoadTransposeMatrixf

GLScene.OpenGL4

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix

glLoadTransposeMatrixfARB

GLScene.OpenGL4

GL_ARB_transpose_matrix (ARB #3)

glLockArraysEXT

GLScene.OpenGL4

GL_EXT_compiled_vertex_array (EXT #97)

glLogicOp

GLScene.OpenGL4

deprecated;

glMakeBufferNonResidentNV

GLScene.OpenGL4

glMakeBufferResidentNV

GLScene.OpenGL4

GL_NV_shader_buffer_load (#379)

glMakeNamedBufferNonResidentNV

GLScene.OpenGL4

glMakeNamedBufferResidentNV

GLScene.OpenGL4

glMap1d

GLScene.OpenGL4

glMap1f

GLScene.OpenGL4

deprecated;

glMap2d

GLScene.OpenGL4

deprecated;

glMap2f

GLScene.OpenGL4

deprecated;

glMapBuffer

GLScene.OpenGL4

glMapBufferARB

GLScene.OpenGL4

glMapBufferRange

GLScene.OpenGL4

GL_ARB_map_buffer_range (ARB #50)

glMapGrid1d

GLScene.OpenGL4

deprecated;

glMapGrid1f

GLScene.OpenGL4

deprecated;

glMapGrid2d

GLScene.OpenGL4

deprecated;

glMapGrid2f

GLScene.OpenGL4

deprecated;

GLMaterialEditorForm

FmMaterialEditor

glMaterialf

GLScene.OpenGL4

deprecated;

glMaterialfv

GLScene.OpenGL4

deprecated;

glMateriali

GLScene.OpenGL4

deprecated;

glMaterialiv

GLScene.OpenGL4

deprecated;

GLMatrixFromGeom

GLS.ODEUtils

glMatrixIndexPointerARB

GLScene.OpenGL4

glMatrixIndexubvARB

GLScene.OpenGL4

glMatrixIndexuivARB

GLScene.OpenGL4

glMatrixIndexusvARB

GLScene.OpenGL4

glMatrixMode

GLScene.OpenGL4

deprecated;

glMinmax

GLScene.OpenGL4

deprecated;

glMinSampleShading

GLScene.OpenGL4

GL_ARB_sample_shading (ARB #70)

glMultiDrawArrays

GLScene.OpenGL4

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)

glMultiDrawArraysEXT

GLScene.OpenGL4

GL_EXT_multi_draw_arrays (EXT #148)

glMultiDrawElements

GLScene.OpenGL4

glMultiDrawElementsBaseVertex

GLScene.OpenGL4

glMultiDrawElementsEXT

GLScene.OpenGL4

glMultiTexCoord1d

GLScene.OpenGL4

deprecated;

glMultiTexCoord1dARB

GLScene.OpenGL4

glMultiTexCoord1dV

GLScene.OpenGL4

deprecated;

glMultiTexCoord1dVARB

GLScene.OpenGL4

glMultiTexCoord1f

GLScene.OpenGL4

deprecated;

glMultiTexCoord1fARB

GLScene.OpenGL4

glMultiTexCoord1fV

GLScene.OpenGL4

deprecated;

glMultiTexCoord1fVARB

GLScene.OpenGL4

glMultiTexCoord1i

GLScene.OpenGL4

deprecated;

glMultiTexCoord1iARB

GLScene.OpenGL4

glMultiTexCoord1iV

GLScene.OpenGL4

deprecated;

glMultiTexCoord1iVARB

GLScene.OpenGL4

glMultiTexCoord1s

GLScene.OpenGL4

deprecated;

glMultiTexCoord1sARB

GLScene.OpenGL4

glMultiTexCoord1sV

GLScene.OpenGL4

deprecated;

glMultiTexCoord1sVARB

GLScene.OpenGL4

glMultiTexCoord2d

GLScene.OpenGL4

deprecated;

glMultiTexCoord2dARB

GLScene.OpenGL4

glMultiTexCoord2dv

GLScene.OpenGL4

deprecated;

glMultiTexCoord2dvARB

GLScene.OpenGL4

glMultiTexCoord2f

GLScene.OpenGL4

deprecated;

glMultiTexCoord2fARB

GLScene.OpenGL4

glMultiTexCoord2fv

GLScene.OpenGL4

deprecated;

glMultiTexCoord2fvARB

GLScene.OpenGL4

glMultiTexCoord2i

GLScene.OpenGL4

deprecated;

glMultiTexCoord2iARB

GLScene.OpenGL4

glMultiTexCoord2iv

GLScene.OpenGL4

deprecated;

glMultiTexCoord2ivARB

GLScene.OpenGL4

glMultiTexCoord2s

GLScene.OpenGL4

deprecated;

glMultiTexCoord2sARB

GLScene.OpenGL4

glMultiTexCoord2sv

GLScene.OpenGL4

deprecated;

glMultiTexCoord2svARB

GLScene.OpenGL4

glMultiTexCoord3d

GLScene.OpenGL4

deprecated;

glMultiTexCoord3dARB

GLScene.OpenGL4

glMultiTexCoord3dv

GLScene.OpenGL4

deprecated;

glMultiTexCoord3dvARB

GLScene.OpenGL4

glMultiTexCoord3f

GLScene.OpenGL4

deprecated;

glMultiTexCoord3fARB

GLScene.OpenGL4

glMultiTexCoord3fv

GLScene.OpenGL4

deprecated;

glMultiTexCoord3fvARB

GLScene.OpenGL4

glMultiTexCoord3i

GLScene.OpenGL4

deprecated;

glMultiTexCoord3iARB

GLScene.OpenGL4

glMultiTexCoord3iv

GLScene.OpenGL4

deprecated;

glMultiTexCoord3ivARB

GLScene.OpenGL4

glMultiTexCoord3s

GLScene.OpenGL4

deprecated;

glMultiTexCoord3sARB

GLScene.OpenGL4

glMultiTexCoord3sv

GLScene.OpenGL4

deprecated;

glMultiTexCoord3svARB

GLScene.OpenGL4

glMultiTexCoord4d

GLScene.OpenGL4

deprecated;

glMultiTexCoord4dARB

GLScene.OpenGL4

glMultiTexCoord4dv

GLScene.OpenGL4

deprecated;

glMultiTexCoord4dvARB

GLScene.OpenGL4

glMultiTexCoord4f

GLScene.OpenGL4

deprecated;

glMultiTexCoord4fARB

GLScene.OpenGL4

glMultiTexCoord4fv

GLScene.OpenGL4

deprecated;

glMultiTexCoord4fvARB

GLScene.OpenGL4

glMultiTexCoord4i

GLScene.OpenGL4

deprecated;

glMultiTexCoord4iARB

GLScene.OpenGL4

glMultiTexCoord4iv

GLScene.OpenGL4

deprecated;

glMultiTexCoord4ivARB

GLScene.OpenGL4

glMultiTexCoord4s

GLScene.OpenGL4

deprecated;

glMultiTexCoord4sARB

GLScene.OpenGL4

glMultiTexCoord4sv

GLScene.OpenGL4

deprecated;

glMultiTexCoord4svARB

GLScene.OpenGL4

glMultiTexCoordP1ui

GLScene.OpenGL4

glMultiTexCoordP1uiv

GLScene.OpenGL4

glMultiTexCoordP2ui

GLScene.OpenGL4

glMultiTexCoordP2uiv

GLScene.OpenGL4

glMultiTexCoordP3ui

GLScene.OpenGL4

glMultiTexCoordP3uiv

GLScene.OpenGL4

glMultiTexCoordP4ui

GLScene.OpenGL4

glMultiTexCoordP4uiv

GLScene.OpenGL4

glMultMatrixd

GLScene.OpenGL4

deprecated;

glMultMatrixf

GLScene.OpenGL4

deprecated;

glMultTransposeMatrixd

GLScene.OpenGL4

deprecated;

glMultTransposeMatrixdARB

GLScene.OpenGL4

glMultTransposeMatrixf

GLScene.OpenGL4

deprecated;

glMultTransposeMatrixfARB

GLScene.OpenGL4

glNewList

GLScene.OpenGL4

deprecated;

glNormal3b

GLScene.OpenGL4

deprecated;

glNormal3bv

GLScene.OpenGL4

deprecated;

glNormal3d

GLScene.OpenGL4

deprecated;

glNormal3dv

GLScene.OpenGL4

deprecated;

glNormal3f

GLScene.OpenGL4

deprecated;

glNormal3fv

GLScene.OpenGL4

deprecated;

glNormal3i

GLScene.OpenGL4

deprecated;

glNormal3iv

GLScene.OpenGL4

deprecated;

glNormal3s

GLScene.OpenGL4

deprecated;

glNormal3sv

GLScene.OpenGL4

deprecated;

glNormalFormatNV

GLScene.OpenGL4

glNormalP3ui

GLScene.OpenGL4

glNormalP3uiv

GLScene.OpenGL4

glNormalPointer

GLScene.OpenGL4

deprecated;

GLOKMessageBox

GLS.ImageUtils

Returns the number of CPU cycles since startup. Use the similarly named CPU instruction.

GLOpenGL

GLS.InitOpenGL

glOrtho

GLScene.OpenGL4

deprecated;

glPassThrough

GLScene.OpenGL4

deprecated;

glPatchParameterfv

GLScene.OpenGL4

glPatchParameteri

GLScene.OpenGL4

GL_ARB_tessellation_shader (ARB #91)

glPauseTransformFeedback

GLScene.OpenGL4

glPixelMapfv

GLScene.OpenGL4

deprecated;

glPixelMapuiv

GLScene.OpenGL4

deprecated;

glPixelMapusv

GLScene.OpenGL4

deprecated;

glPixelStoref

GLScene.OpenGL4

deprecated;

glPixelStorei

GLScene.OpenGL4

glPixelTransferf

GLScene.OpenGL4

glPixelTransferi

GLScene.OpenGL4

deprecated;

glPixelZoom

GLScene.OpenGL4

deprecated;

glPointParameterf

GLScene.OpenGL4

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)

glPointParameterfARB

GLScene.OpenGL4

GL_ARB_point_parameter (ARB #14)

glPointParameterfv

GLScene.OpenGL4

glPointParameterfvARB

GLScene.OpenGL4

glPointParameteri

GLScene.OpenGL4

glPointParameteriNV

GLScene.OpenGL4

GL_NV_point_sprite (EXT #262)

glPointParameteriv

GLScene.OpenGL4

glPointParameterivNV

GLScene.OpenGL4

glPointSize

GLScene.OpenGL4

deprecated;

glPolygonMode

GLScene.OpenGL4

glPolygonOffset

GLScene.OpenGL4

glPolygonOffsetEXT

GLScene.OpenGL4

GL_EXT_polygon_offset (EXT #3)

glPolygonStipple

GLScene.OpenGL4

glPopAttrib

GLScene.OpenGL4

deprecated;

glPopClientAttrib

GLScene.OpenGL4

deprecated;

glPopMatrix

GLScene.OpenGL4

deprecated;

glPopName

GLScene.OpenGL4

deprecated;

glPrimitiveRestartIndex

GLScene.OpenGL4

glPrimitiveRestartIndexNV

GLScene.OpenGL4

glPrimitiveRestartNV

GLScene.OpenGL4

GL_NV_primitive_restart (EXT #285)

glPrioritizeTextures

GLScene.OpenGL4

deprecated;

glPrioritizeTexturesEXT

GLScene.OpenGL4

glProgramEnvParameter4dARB

GLScene.OpenGL4

glProgramEnvParameter4dvARB

GLScene.OpenGL4

glProgramEnvParameter4fARB

GLScene.OpenGL4

glProgramEnvParameter4fvARB

GLScene.OpenGL4

glProgramEnvParameters4fvEXT

GLScene.OpenGL4

GL_EXT_gpu_program_parameters (EXT #320)

glProgramLocalParameter4dARB

GLScene.OpenGL4

glProgramLocalParameter4dvARB

GLScene.OpenGL4

glProgramLocalParameter4fARB

GLScene.OpenGL4

glProgramLocalParameter4fvARB

GLScene.OpenGL4

glProgramLocalParameters4fvEXT

GLScene.OpenGL4

glProgramParameter4dNV

GLScene.OpenGL4

glProgramParameter4dvNV

GLScene.OpenGL4

glProgramParameter4fNV

GLScene.OpenGL4

glProgramParameter4fvNV

GLScene.OpenGL4

glProgramParameteri

GLScene.OpenGL4

glProgramParameteriARB

GLScene.OpenGL4

GL_ARB_geometry_shader4 (ARB #47)

glProgramParameteriEXT

GLScene.OpenGL4

GL_EXT_geometry_shader4 (EXT #324)

glProgramParameters4dvNV

GLScene.OpenGL4

glProgramParameters4fvNV

GLScene.OpenGL4

glProgramStringARB

GLScene.OpenGL4

glProgramUniform1dEXT

GLScene.OpenGL4

glProgramUniformXXX only valid if EXT_direct_state_access is available

glProgramUniform1dvEXT

GLScene.OpenGL4

glProgramUniform2dEXT

GLScene.OpenGL4

glProgramUniform2dvEXT

GLScene.OpenGL4

glProgramUniform3dEXT

GLScene.OpenGL4

glProgramUniform3dvEXT

GLScene.OpenGL4

glProgramUniform4dEXT

GLScene.OpenGL4

glProgramUniform4dvEXT

GLScene.OpenGL4

glProgramUniformMatrix2dvEXT

GLScene.OpenGL4

glProgramUniformMatrix2x3dvEXT

GLScene.OpenGL4

glProgramUniformMatrix2x4dvEXT

GLScene.OpenGL4

glProgramUniformMatrix3dvEXT

GLScene.OpenGL4

glProgramUniformMatrix3x2dvEXT

GLScene.OpenGL4

glProgramUniformMatrix3x4dvEXT

GLScene.OpenGL4

glProgramUniformMatrix4dvEXT

GLScene.OpenGL4

glProgramUniformMatrix4x2dvEXT

GLScene.OpenGL4

glProgramUniformMatrix4x3dvEXT

GLScene.OpenGL4

glProgramUniformui64NV

GLScene.OpenGL4

glProgramUniformui64vNV

GLScene.OpenGL4

glProgramVertexLimitNV

GLScene.OpenGL4

GL_NV_geometry_program4 (EXT #323)

glProvokingVertex

GLScene.OpenGL4

GL_ARB_provoking_vertex (ARB #64)

glPushAttrib

GLScene.OpenGL4

deprecated;

glPushClientAttrib

GLScene.OpenGL4

deprecated;

glPushMatrix

GLScene.OpenGL4

deprecated;

glPushName

GLScene.OpenGL4

deprecated;

glQueryCounter

GLScene.OpenGL4

GL_ARB_timer_query (ARB #85)

glRasterPos2d

GLScene.OpenGL4

deprecated;

glRasterPos2dv

GLScene.OpenGL4

deprecated;

glRasterPos2f

GLScene.OpenGL4

deprecated;

glRasterPos2fv

GLScene.OpenGL4

deprecated;

glRasterPos2i

GLScene.OpenGL4

deprecated;

glRasterPos2iv

GLScene.OpenGL4

deprecated;

glRasterPos2s

GLScene.OpenGL4

deprecated;

glRasterPos2sv

GLScene.OpenGL4

deprecated;

glRasterPos3d

GLScene.OpenGL4

deprecated;

glRasterPos3dv

GLScene.OpenGL4

deprecated;

glRasterPos3f

GLScene.OpenGL4

deprecated;

glRasterPos3fv

GLScene.OpenGL4

deprecated;

glRasterPos3i

GLScene.OpenGL4

deprecated;

glRasterPos3iv

GLScene.OpenGL4

deprecated;

glRasterPos3s

GLScene.OpenGL4

deprecated;

glRasterPos3sv

GLScene.OpenGL4

deprecated;

glRasterPos4d

GLScene.OpenGL4

deprecated;

glRasterPos4dv

GLScene.OpenGL4

deprecated;

glRasterPos4f

GLScene.OpenGL4

deprecated;

glRasterPos4fv

GLScene.OpenGL4

deprecated;

glRasterPos4i

GLScene.OpenGL4

deprecated;

glRasterPos4iv

GLScene.OpenGL4

deprecated;

glRasterPos4s

GLScene.OpenGL4

deprecated;

glRasterPos4sv

GLScene.OpenGL4

deprecated;

glReadBuffer

GLScene.OpenGL4

deprecated;

glReadPixels

GLScene.OpenGL4

glRectd

GLScene.OpenGL4

glRectdv

GLScene.OpenGL4

deprecated;

glRectf

GLScene.OpenGL4

deprecated;

glRectfv

GLScene.OpenGL4

deprecated;

glRecti

GLScene.OpenGL4

deprecated;

glRectiv

GLScene.OpenGL4

deprecated;

glRects

GLScene.OpenGL4

deprecated;

glRectsv

GLScene.OpenGL4

deprecated;

glRenderbufferStorage

GLScene.OpenGL4

glRenderbufferStorageEXT

GLScene.OpenGL4

glRenderbufferStorageMultisample

GLScene.OpenGL4

glRenderbufferStorageMultisampleEXT

GLScene.OpenGL4

GL_EXT_framebuffer_multisample (#317)

glRenderMode

GLScene.OpenGL4

deprecated;

glRequestResidentProgramsNV

GLScene.OpenGL4

glResetHistogram

GLScene.OpenGL4

deprecated;

glResetMinmax

GLScene.OpenGL4

deprecated;

glResizeBuffersMESA

GLScene.OpenGL4

GL_MESA_resize_buffers (EXT #196)

glResumeTransformFeedback

GLScene.OpenGL4

glRotated

GLScene.OpenGL4

glRotatef

GLScene.OpenGL4

deprecated;

glSampleCoverage

GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_multisample (#5)

glSampleCoverageARB

GLScene.OpenGL4

GL_ARB_multisample (ARB #5)

glSampleMaskEXT

GLScene.OpenGL4

GL_EXT_multisample (EXT #209)

glSampleMaski

GLScene.OpenGL4

glSampleMaskSGIS

GLScene.OpenGL4

GL_SGIS_multisample (EXT #25)

glSamplePassARB

GLScene.OpenGL4

########################################################### function and procedure definitions for ARB approved extensions ########################################################### unknown ARB extension

glSamplePatternEXT

GLScene.OpenGL4

glSamplePatternSGIS

GLScene.OpenGL4

glSamplerParameterf

GLScene.OpenGL4

glSamplerParameterfv

GLScene.OpenGL4

glSamplerParameteri

GLScene.OpenGL4

glSamplerParameterIiv

GLScene.OpenGL4

glSamplerParameterIuiv

GLScene.OpenGL4

glSamplerParameteriv

GLScene.OpenGL4

glScaled

GLScene.OpenGL4

deprecated;

glScalef

GLScene.OpenGL4

deprecated;

GLSceneEditorForm

FmSceneEditor

GLSceneMatrixToODER

GLS.ODEUtils

GLSCENE_REVISION

GLS.Scene

GLSCENE_VERSION

GLS.Scene

glScissor

GLScene.OpenGL4

deprecated;

glSecondaryColor3b

GLScene.OpenGL4

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)

glSecondaryColor3bEXT

GLScene.OpenGL4

GL_EXT_secondary_color (EXT #145)

glSecondaryColor3bv

GLScene.OpenGL4

deprecated;

glSecondaryColor3bvEXT

GLScene.OpenGL4

glSecondaryColor3d

GLScene.OpenGL4

deprecated;

glSecondaryColor3dEXT

GLScene.OpenGL4

glSecondaryColor3dv

GLScene.OpenGL4

deprecated;

glSecondaryColor3dvEXT

GLScene.OpenGL4

glSecondaryColor3f

GLScene.OpenGL4

deprecated;

glSecondaryColor3fEXT

GLScene.OpenGL4

glSecondaryColor3fv

GLScene.OpenGL4

deprecated;

glSecondaryColor3fvEXT

GLScene.OpenGL4

glSecondaryColor3i

GLScene.OpenGL4

deprecated;

glSecondaryColor3iEXT

GLScene.OpenGL4

glSecondaryColor3iv

GLScene.OpenGL4

deprecated;

glSecondaryColor3ivEXT

GLScene.OpenGL4

glSecondaryColor3s

GLScene.OpenGL4

deprecated;

glSecondaryColor3sEXT

GLScene.OpenGL4

glSecondaryColor3sv

GLScene.OpenGL4

deprecated;

glSecondaryColor3svEXT

GLScene.OpenGL4

glSecondaryColor3ub

GLScene.OpenGL4

deprecated;

glSecondaryColor3ubEXT

GLScene.OpenGL4

glSecondaryColor3ubv

GLScene.OpenGL4

deprecated;

glSecondaryColor3ubvEXT

GLScene.OpenGL4

glSecondaryColor3ui

GLScene.OpenGL4

deprecated;

glSecondaryColor3uiEXT

GLScene.OpenGL4

glSecondaryColor3uiv

GLScene.OpenGL4

deprecated;

glSecondaryColor3uivEXT

GLScene.OpenGL4

glSecondaryColor3us

GLScene.OpenGL4

deprecated;

glSecondaryColor3usEXT

GLScene.OpenGL4

glSecondaryColor3usv

GLScene.OpenGL4

deprecated;

glSecondaryColor3usvEXT

GLScene.OpenGL4

glSecondaryColorFormatNV

GLScene.OpenGL4

glSecondaryColorP3ui

GLScene.OpenGL4

glSecondaryColorP3uiv

GLScene.OpenGL4

glSecondaryColorPointer

GLScene.OpenGL4

deprecated;

glSecondaryColorPointerEXT

GLScene.OpenGL4

glSelectBuffer

GLScene.OpenGL4

glSeparableFilter2D

GLScene.OpenGL4

deprecated;

GLSetCursorPos

GLS.Screen

glSetFenceNV

GLScene.OpenGL4

glShadeModel

GLScene.OpenGL4

deprecated;

GLShaderEditorForm

FmShaderMemo

glShaderSource

GLScene.OpenGL4

glShaderSourceARB

GLScene.OpenGL4

GLShaderUniformEditor

FmShaderUniformEditor

GLshort

GLScene.OpenGL4

GLShowCursor

GLS.Screen

GLsizei

GLScene.OpenGL4

GLSkinEditorForm

FmGuiSkinEditor

GLSLogger

GLScene.Logger

Inner logger. Converted to a function, because in case of a DLL and main app using this module, log is written to the same file on initialization and finalization, which is not what one might want. This also allows to create a GLSLogger with custom parameters for user's application, for example a different log path (Often the EXE application directory is read-only).

GLSLTypeComponentCount

GLSL.ShaderParameter

GLSLTypeEnum

GLSL.ShaderParameter

glsShaderMaxLightSources

GLSL.CustomShader

glStencilClearTagEXT

GLScene.OpenGL4

GL_EXT_stencil_clear_tag (EXT #314)

glStencilFunc

GLScene.OpenGL4

deprecated;

glStencilFuncSeparate

GLScene.OpenGL4

glStencilMask

GLScene.OpenGL4

glStencilMaskSeparate

GLScene.OpenGL4

glStencilOp

GLScene.OpenGL4

glStencilOpSeparate

GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)

glStringMarkerGREMEDY

GLScene.OpenGL4

GLStrToFloatDef

GLScene.Utils

GLStrToFloatDef

GLScene.Utils

GLStrToFloatDef

GLScene.Utils

Added by PAL to fix problem with decimal separator in not En-US configurations Decimal separator in text descriptions of meshes for import/export is always '.' char But in System.SysUtils.TextToFloat is Windows char, maybe ',' or others...

GLS_RC_DDS_Type

GLS.ApplicationFileIO

GLS_RC_JPG_Type

GLS.ApplicationFileIO

GLS_RC_String_Type

GLS.ApplicationFileIO

GLS_RC_XML_Type

GLS.ApplicationFileIO

GLS_VERTEX_ATTR_NUM

GLS.State

glTbufferMask3DFX

GLScene.OpenGL4

GL_3DFX_tbuffer (EXT #208)

glTessellationFactorAMD

GLScene.OpenGL4

GL_AMD_vertex_shader_tessellator (#363)

glTessellationModeAMD

GLScene.OpenGL4

glTestFenceNV

GLScene.OpenGL4

glTexBuffer

GLScene.OpenGL4

glTexBufferARB

GLScene.OpenGL4

GL_ARB_texture_buffer_object (ARB #51)

glTexBufferEXT

GLScene.OpenGL4

GL_EXT_packed_float (#328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (#329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (#330)

glTexCoord1d

GLScene.OpenGL4

glTexCoord1dv

GLScene.OpenGL4

deprecated;

glTexCoord1f

GLScene.OpenGL4

deprecated;

glTexCoord1fv

GLScene.OpenGL4

deprecated;

glTexCoord1i

GLScene.OpenGL4

deprecated;

glTexCoord1iv

GLScene.OpenGL4

deprecated;

glTexCoord1s

GLScene.OpenGL4

deprecated;

glTexCoord1sv

GLScene.OpenGL4

deprecated;

glTexCoord2d

GLScene.OpenGL4

deprecated;

glTexCoord2dv

GLScene.OpenGL4

deprecated;

glTexCoord2f

GLScene.OpenGL4

deprecated;

glTexCoord2fv

GLScene.OpenGL4

deprecated;

glTexCoord2i

GLScene.OpenGL4

deprecated;

glTexCoord2iv

GLScene.OpenGL4

deprecated;

glTexCoord2s

GLScene.OpenGL4

deprecated;

glTexCoord2sv

GLScene.OpenGL4

deprecated;

glTexCoord3d

GLScene.OpenGL4

deprecated;

glTexCoord3dv

GLScene.OpenGL4

deprecated;

glTexCoord3f

GLScene.OpenGL4

deprecated;

glTexCoord3fv

GLScene.OpenGL4

deprecated;

glTexCoord3i

GLScene.OpenGL4

deprecated;

glTexCoord3iv

GLScene.OpenGL4

deprecated;

glTexCoord3s

GLScene.OpenGL4

deprecated;

glTexCoord3sv

GLScene.OpenGL4

deprecated;

glTexCoord4d

GLScene.OpenGL4

deprecated;

glTexCoord4dv

GLScene.OpenGL4

deprecated;

glTexCoord4f

GLScene.OpenGL4

deprecated;

glTexCoord4fv

GLScene.OpenGL4

deprecated;

glTexCoord4i

GLScene.OpenGL4

deprecated;

glTexCoord4iv

GLScene.OpenGL4

deprecated;

glTexCoord4s

GLScene.OpenGL4

deprecated;

glTexCoord4sv

GLScene.OpenGL4

deprecated;

glTexCoordFormatNV

GLScene.OpenGL4

glTexCoordP1ui

GLScene.OpenGL4

glTexCoordP1uiv

GLScene.OpenGL4

glTexCoordP2ui

GLScene.OpenGL4

glTexCoordP2uiv

GLScene.OpenGL4

glTexCoordP3ui

GLScene.OpenGL4

glTexCoordP3uiv

GLScene.OpenGL4

glTexCoordP4ui

GLScene.OpenGL4

glTexCoordP4uiv

GLScene.OpenGL4

glTexCoordPointer

GLScene.OpenGL4

deprecated;

glTexEnvf

GLScene.OpenGL4

deprecated;

glTexEnvfv

GLScene.OpenGL4

deprecated;

glTexEnvi

GLScene.OpenGL4

deprecated;

glTexEnviv

GLScene.OpenGL4

deprecated;

glTexGend

GLScene.OpenGL4

deprecated;

glTexGendv

GLScene.OpenGL4

deprecated;

glTexGenf

GLScene.OpenGL4

deprecated;

glTexGenfv

GLScene.OpenGL4

deprecated;

glTexGeni

GLScene.OpenGL4

deprecated;

glTexGeniv

GLScene.OpenGL4

deprecated;

glTexImage1D

GLScene.OpenGL4

deprecated;

glTexImage2D

GLScene.OpenGL4

glTexImage2DMultisample

GLScene.OpenGL4

GL_ARB_texture_multisample (ARB #67)

glTexImage3D

GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_texture3D (#6)

glTexImage3DEXT

GLScene.OpenGL4

GL_EXT_texture3D (EXT #6)

glTexImage3DMultisample

GLScene.OpenGL4

glTexParameterf

GLScene.OpenGL4

glTexParameterfv

GLScene.OpenGL4

glTexParameteri

GLScene.OpenGL4

glTexParameterIiv

GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_texture_integer glClearColorIi: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glClearColorIui: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF}

glTexParameterIivEXT

GLScene.OpenGL4

glTexParameterIuiv

GLScene.OpenGL4

glTexParameterIuivEXT

GLScene.OpenGL4

glTexParameteriv

GLScene.OpenGL4

glTexSubImage1D

GLScene.OpenGL4

glTexSubImage1DEXT

GLScene.OpenGL4

GL_EXT_subtexture (EXT #9)

glTexSubImage2D

GLScene.OpenGL4

glTexSubImage2DEXT

GLScene.OpenGL4

glTexSubImage3D

GLScene.OpenGL4

glTexSubImage3DEXT

GLScene.OpenGL4

glTextureColorMaskSGIS

GLScene.OpenGL4

GL_SGIS_texture_color_mask (EXT #214)

glTFUseEmbeddedColors

GLS.FileGLTF

glTrackMatrixNV

GLScene.OpenGL4

glTransformFeedbackAttribsNV

GLScene.OpenGL4

glTransformFeedbackVaryings

GLScene.OpenGL4

glTransformFeedbackVaryingsEXT

GLScene.OpenGL4

glTransformFeedbackVaryingsNV

GLScene.OpenGL4

glTranslated

GLScene.OpenGL4

glTranslatef

GLScene.OpenGL4

deprecated;

glu32

GLS.OpenGLAdapter

glu32

GLScene.OpenGL4

gluBeginCurve

GLS.OpenGLAdapter

gluBeginCurve

GLScene.OpenGL4

gluBeginPolygon

GLS.OpenGLAdapter

gluBeginPolygon

GLScene.OpenGL4

gluBeginSurface

GLS.OpenGLAdapter

gluBeginSurface

GLScene.OpenGL4

gluBeginTrim

GLS.OpenGLAdapter

gluBeginTrim

GLScene.OpenGL4

gluBuild1DMipmaps

GLS.OpenGLAdapter

gluBuild1DMipmaps

GLScene.OpenGL4

gluBuild2DMipmaps

GLS.OpenGLAdapter

gluBuild2DMipmaps

GLScene.OpenGL4

GLubyte

GLScene.OpenGL4

gluCylinder

GLS.OpenGLAdapter

gluCylinder

GLScene.OpenGL4

gluDeleteNurbsRenderer

GLS.OpenGLAdapter

gluDeleteNurbsRenderer

GLScene.OpenGL4

gluDeleteNurbsTessellatorEXT

GLScene.OpenGL4

gluDeleteQuadric

GLS.OpenGLAdapter

gluDeleteQuadric

GLScene.OpenGL4

gluDeleteTess

GLS.OpenGLAdapter

gluDeleteTess

GLScene.OpenGL4

gluDisk

GLS.OpenGLAdapter

gluDisk

GLScene.OpenGL4

gluEndCurve

GLS.OpenGLAdapter

gluEndCurve

GLScene.OpenGL4

gluEndPolygon

GLS.OpenGLAdapter

gluEndPolygon

GLScene.OpenGL4

gluEndSurface

GLS.OpenGLAdapter

gluEndSurface

GLScene.OpenGL4

gluEndTrim

GLS.OpenGLAdapter

gluEndTrim

GLScene.OpenGL4

gluErrorString

GLS.OpenGLAdapter

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32; function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 Name 'wglUseFontBitmapsA'; function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 Name 'wglUseFontOutlinesA';

gluErrorString

GLScene.OpenGL4

GLU utility functions and procedures

gluGetNurbsProperty

GLS.OpenGLAdapter

gluGetNurbsProperty

GLScene.OpenGL4

gluGetString

GLS.OpenGLAdapter

gluGetString

GLScene.OpenGL4

gluGetTessProperty

GLS.OpenGLAdapter

gluGetTessProperty

GLScene.OpenGL4

GLuint

GLScene.OpenGL4

GLuint64

GLScene.OpenGL4

GLuint64EXT

GLScene.OpenGL4

gluLoadSamplingMatrices

GLS.OpenGLAdapter

gluLoadSamplingMatrices

GLScene.OpenGL4

gluLookAt

GLS.OpenGLAdapter

gluLookAt

GLScene.OpenGL4

gluNewNurbsRenderer

GLS.OpenGLAdapter

gluNewNurbsRenderer

GLScene.OpenGL4

gluNewNurbsTessellatorEXT

GLScene.OpenGL4

gluNewQuadric

GLS.OpenGLAdapter

gluNewQuadric

GLScene.OpenGL4

gluNewTess

GLS.OpenGLAdapter

gluNewTess

GLScene.OpenGL4

gluNextContour

GLS.OpenGLAdapter

gluNextContour

GLScene.OpenGL4

glUniform1d

GLScene.OpenGL4

GL_ARB_gpu_shader_fp64 (ARB #89)

glUniform1dv

GLScene.OpenGL4

glUniform1f

GLScene.OpenGL4

glUniform1fARB

GLScene.OpenGL4

glUniform1fv

GLScene.OpenGL4

glUniform1fvARB

GLScene.OpenGL4

glUniform1i

GLScene.OpenGL4

glUniform1iARB

GLScene.OpenGL4

glUniform1iv

GLScene.OpenGL4

glUniform1ivARB

GLScene.OpenGL4

glUniform1ui

GLScene.OpenGL4

glUniform1uiEXT

GLScene.OpenGL4

glUniform1uiv

GLScene.OpenGL4

glUniform1uivEXT

GLScene.OpenGL4

glUniform2d

GLScene.OpenGL4

glUniform2dv

GLScene.OpenGL4

glUniform2f

GLScene.OpenGL4

glUniform2fARB

GLScene.OpenGL4

glUniform2fv

GLScene.OpenGL4

glUniform2fvARB

GLScene.OpenGL4

glUniform2i

GLScene.OpenGL4

glUniform2iARB

GLScene.OpenGL4

glUniform2iv

GLScene.OpenGL4

glUniform2ivARB

GLScene.OpenGL4

glUniform2ui

GLScene.OpenGL4

glUniform2uiEXT

GLScene.OpenGL4

glUniform2uiv

GLScene.OpenGL4

glUniform2uivEXT

GLScene.OpenGL4

glUniform3d

GLScene.OpenGL4

glUniform3dv

GLScene.OpenGL4

glUniform3f

GLScene.OpenGL4

glUniform3fARB

GLScene.OpenGL4

glUniform3fv

GLScene.OpenGL4

glUniform3fvARB

GLScene.OpenGL4

glUniform3i

GLScene.OpenGL4

glUniform3iARB

GLScene.OpenGL4

glUniform3iv

GLScene.OpenGL4

glUniform3ivARB

GLScene.OpenGL4

glUniform3ui

GLScene.OpenGL4

glUniform3uiEXT

GLScene.OpenGL4

glUniform3uiv

GLScene.OpenGL4

glUniform3uivEXT

GLScene.OpenGL4

glUniform4d

GLScene.OpenGL4

glUniform4dv

GLScene.OpenGL4

glUniform4f

GLScene.OpenGL4

glUniform4fARB

GLScene.OpenGL4

glUniform4fv

GLScene.OpenGL4

glUniform4fvARB

GLScene.OpenGL4

glUniform4i

GLScene.OpenGL4

glUniform4iARB

GLScene.OpenGL4

glUniform4iv

GLScene.OpenGL4

glUniform4ivARB

GLScene.OpenGL4

glUniform4ui

GLScene.OpenGL4

glUniform4uiEXT

GLScene.OpenGL4

glUniform4uiv

GLScene.OpenGL4

glUniform4uivEXT

GLScene.OpenGL4

glUniformBlockBinding

GLScene.OpenGL4

glUniformBufferEXT

GLScene.OpenGL4

GL_EXT_bindable_uniform (#342)

glUniformMatrix2dv

GLScene.OpenGL4

glUniformMatrix2fv

GLScene.OpenGL4

glUniformMatrix2fvARB

GLScene.OpenGL4

glUniformMatrix2x3dv

GLScene.OpenGL4

glUniformMatrix2x3fv

GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 2.1 Core ###########################################################

glUniformMatrix2x4dv

GLScene.OpenGL4

glUniformMatrix2x4fv

GLScene.OpenGL4

glUniformMatrix3dv

GLScene.OpenGL4

glUniformMatrix3fv

GLScene.OpenGL4

glUniformMatrix3fvARB

GLScene.OpenGL4

glUniformMatrix3x2dv

GLScene.OpenGL4

glUniformMatrix3x2fv

GLScene.OpenGL4

glUniformMatrix3x4dv

GLScene.OpenGL4

glUniformMatrix3x4fv

GLScene.OpenGL4

glUniformMatrix4dv

GLScene.OpenGL4

glUniformMatrix4fv

GLScene.OpenGL4

glUniformMatrix4fvARB

GLScene.OpenGL4

glUniformMatrix4x2dv

GLScene.OpenGL4

glUniformMatrix4x2fv

GLScene.OpenGL4

glUniformMatrix4x3dv

GLScene.OpenGL4

glUniformMatrix4x3fv

GLScene.OpenGL4

glUniformSubroutinesuiv

GLScene.OpenGL4

glUniformui64NV

GLScene.OpenGL4

glUniformui64vNV

GLScene.OpenGL4

glUnlockArraysEXT

GLScene.OpenGL4

glUnmapBuffer

GLScene.OpenGL4

glUnmapBufferARB

GLScene.OpenGL4

gluNurbsCallback

GLS.OpenGLAdapter

gluNurbsCallback

GLScene.OpenGL4

gluNurbsCallbackDataEXT

GLScene.OpenGL4

GL_ARB_draw_indirect (ARB #87) GL_ARB_gpu_shader5 (ARB #88) (none) GL_ARB_gpu_shader_fp64 (ARB #89) GL_ARB_shader_subroutine (ARB #90) GL_ARB_tessellation_shader (ARB #91) GL_ARB_texture_buffer_object_rgb32 (ARB #92) (none) GL_ARB_transform_feedback2 (ARB #93) GL_ARB_transform_feedback3 (ARB #94) GL_VERSION_4_1 ########################################################### function and procedure definitions for GLU extensions ########################################################### GLU extensions

gluNurbsCurve

GLS.OpenGLAdapter

gluNurbsCurve

GLScene.OpenGL4

gluNurbsProperty

GLS.OpenGLAdapter

gluNurbsProperty

GLScene.OpenGL4

gluNurbsSurface

GLS.OpenGLAdapter

gluNurbsSurface

GLScene.OpenGL4

gluOrtho2D

GLS.OpenGLAdapter

gluOrtho2D

GLScene.OpenGL4

gluPartialDisk

GLS.OpenGLAdapter

gluPartialDisk

GLScene.OpenGL4

gluPerspective

GLS.OpenGLAdapter

gluPerspective

GLScene.OpenGL4

gluPickMatrix

GLS.OpenGLAdapter

gluPickMatrix

GLScene.OpenGL4

gluProject

GLS.OpenGLAdapter

gluProject

GLScene.OpenGL4

gluPwlCurve

GLS.OpenGLAdapter

gluPwlCurve

GLScene.OpenGL4

gluQuadricCallback

GLS.OpenGLAdapter

gluQuadricCallback

GLScene.OpenGL4

gluQuadricDrawStyle

GLS.OpenGLAdapter

gluQuadricDrawStyle

GLScene.OpenGL4

gluQuadricNormals

GLS.OpenGLAdapter

gluQuadricNormals

GLScene.OpenGL4

gluQuadricOrientation

GLS.OpenGLAdapter

gluQuadricOrientation

GLScene.OpenGL4

gluQuadricTexture

GLS.OpenGLAdapter

gluQuadricTexture

GLScene.OpenGL4

gluScaleImage

GLS.OpenGLAdapter

gluScaleImage

GLScene.OpenGL4

glUseProgram

GLScene.OpenGL4

glUseProgramObjectARB

GLScene.OpenGL4

GLushort

GLScene.OpenGL4

gluSphere

GLS.OpenGLAdapter

gluSphere

GLScene.OpenGL4

gluTessBeginContour

GLS.OpenGLAdapter

gluTessBeginContour

GLScene.OpenGL4

gluTessBeginPolygon

GLS.OpenGLAdapter

gluTessBeginPolygon

GLScene.OpenGL4

gluTessCallback

GLS.OpenGLAdapter

gluTessCallback

GLScene.OpenGL4

gluTessEndContour

GLS.OpenGLAdapter

gluTessEndContour

GLScene.OpenGL4

gluTessEndPolygon

GLS.OpenGLAdapter

gluTessEndPolygon

GLScene.OpenGL4

gluTessNormal

GLS.OpenGLAdapter

gluTessNormal

GLScene.OpenGL4

gluTessProperty

GLS.OpenGLAdapter

gluTessProperty

GLScene.OpenGL4

gluTessVertex

GLS.OpenGLAdapter

gluTessVertex

GLScene.OpenGL4

gluUnProject

GLS.OpenGLAdapter

gluUnProject

GLScene.OpenGL4

GLU_AUTO_LOAD_MATRIX

GLScene.OpenGL4

GLU_AUTO_LOAD_MATRIX

GLScene.OpenGLTokens

NURBS constants NurbsProperty

GLU_BEGIN

GLScene.OpenGL4

GLU_BEGIN

GLScene.OpenGLTokens

Names without "TESS_" prefix

GLU_CCW

GLScene.OpenGL4

GLU_CCW

GLScene.OpenGLTokens

GLU_CULLING

GLScene.OpenGL4

GLU_CULLING

GLScene.OpenGLTokens

GLU_CW

GLScene.OpenGL4

GLU_CW

GLScene.OpenGLTokens

Contours types – obsolete!

GLU_DISPLAY_MODE

GLScene.OpenGL4

GLU_DISPLAY_MODE

GLScene.OpenGLTokens

GLU_DOMAIN_DISTANCE

GLScene.OpenGL4

GLU_DOMAIN_DISTANCE

GLScene.OpenGLTokens

GLU_EDGE_FLAG

GLScene.OpenGL4

GLU_EDGE_FLAG

GLScene.OpenGLTokens

GLU_END

GLScene.OpenGL4

GLU_END

GLScene.OpenGLTokens

GLU_ERROR

GLScene.OpenGL4

GLU_ERROR

GLScene.OpenGLTokens

GLU_EXTENSIONS

GLScene.OpenGL4

GLU_EXTERIOR

GLScene.OpenGL4

GLU_EXTERIOR

GLScene.OpenGLTokens

GLU_FALSE

GLScene.OpenGL4

GLU_FILL

GLScene.OpenGL4

GLU_FLAT

GLScene.OpenGL4

GLU_INCOMPATIBLE_GL_VERSION

GLScene.OpenGL4

GLU_INSIDE

GLScene.OpenGL4

GLU_INTERIOR

GLScene.OpenGL4

GLU_INTERIOR

GLScene.OpenGLTokens

GLU_INVALID_ENUM

GLScene.OpenGL4

GLU

GLU_INVALID_VALUE

GLScene.OpenGL4

GLU_LINE

GLScene.OpenGL4

GLU_MAP1_TRIM_2

GLScene.OpenGL4

GLU_MAP1_TRIM_2

GLScene.OpenGLTokens

NurbsTrim

GLU_MAP1_TRIM_3

GLScene.OpenGL4

GLU_MAP1_TRIM_3

GLScene.OpenGLTokens

GLU_NONE

GLScene.OpenGL4

GLU_NURBS_ERROR1

GLScene.OpenGL4

GLU_NURBS_ERROR1

GLScene.OpenGLTokens

NurbsErrors

GLU_NURBS_ERROR10

GLScene.OpenGL4

GLU_NURBS_ERROR10

GLScene.OpenGLTokens

GLU_NURBS_ERROR11

GLScene.OpenGL4

GLU_NURBS_ERROR11

GLScene.OpenGLTokens

GLU_NURBS_ERROR12

GLScene.OpenGL4

GLU_NURBS_ERROR12

GLScene.OpenGLTokens

GLU_NURBS_ERROR13

GLScene.OpenGL4

GLU_NURBS_ERROR13

GLScene.OpenGLTokens

GLU_NURBS_ERROR14

GLScene.OpenGL4

GLU_NURBS_ERROR14

GLScene.OpenGLTokens

GLU_NURBS_ERROR15

GLScene.OpenGL4

GLU_NURBS_ERROR15

GLScene.OpenGLTokens

GLU_NURBS_ERROR16

GLScene.OpenGL4

GLU_NURBS_ERROR16

GLScene.OpenGLTokens

GLU_NURBS_ERROR17

GLScene.OpenGL4

GLU_NURBS_ERROR17

GLScene.OpenGLTokens

GLU_NURBS_ERROR18

GLScene.OpenGL4

GLU_NURBS_ERROR18

GLScene.OpenGLTokens

GLU_NURBS_ERROR19

GLScene.OpenGL4

GLU_NURBS_ERROR19

GLScene.OpenGLTokens

GLU_NURBS_ERROR2

GLScene.OpenGL4

GLU_NURBS_ERROR2

GLScene.OpenGLTokens

GLU_NURBS_ERROR20

GLScene.OpenGL4

GLU_NURBS_ERROR20

GLScene.OpenGLTokens

GLU_NURBS_ERROR21

GLScene.OpenGL4

GLU_NURBS_ERROR21

GLScene.OpenGLTokens

GLU_NURBS_ERROR22

GLScene.OpenGL4

GLU_NURBS_ERROR22

GLScene.OpenGLTokens

GLU_NURBS_ERROR23

GLScene.OpenGL4

GLU_NURBS_ERROR23

GLScene.OpenGLTokens

GLU_NURBS_ERROR24

GLScene.OpenGL4

GLU_NURBS_ERROR24

GLScene.OpenGLTokens

GLU_NURBS_ERROR25

GLScene.OpenGL4

GLU_NURBS_ERROR25

GLScene.OpenGLTokens

GLU_NURBS_ERROR26

GLScene.OpenGL4

GLU_NURBS_ERROR26

GLScene.OpenGLTokens

GLU_NURBS_ERROR27

GLScene.OpenGL4

GLU_NURBS_ERROR27

GLScene.OpenGLTokens

GLU_NURBS_ERROR28

GLScene.OpenGL4

GLU_NURBS_ERROR28

GLScene.OpenGLTokens

GLU_NURBS_ERROR29

GLScene.OpenGL4

GLU_NURBS_ERROR29

GLScene.OpenGLTokens

GLU_NURBS_ERROR3

GLScene.OpenGL4

GLU_NURBS_ERROR3

GLScene.OpenGLTokens

GLU_NURBS_ERROR30

GLScene.OpenGL4

GLU_NURBS_ERROR30

GLScene.OpenGLTokens

GLU_NURBS_ERROR31

GLScene.OpenGL4

GLU_NURBS_ERROR31

GLScene.OpenGLTokens

GLU_NURBS_ERROR32

GLScene.OpenGL4

GLU_NURBS_ERROR32

GLScene.OpenGLTokens

GLU_NURBS_ERROR33

GLScene.OpenGL4

GLU_NURBS_ERROR33

GLScene.OpenGLTokens

GLU_NURBS_ERROR34

GLScene.OpenGL4

GLU_NURBS_ERROR34

GLScene.OpenGLTokens

GLU_NURBS_ERROR35

GLScene.OpenGL4

GLU_NURBS_ERROR35

GLScene.OpenGLTokens

GLU_NURBS_ERROR36

GLScene.OpenGL4

GLU_NURBS_ERROR36

GLScene.OpenGLTokens

GLU_NURBS_ERROR37

GLScene.OpenGL4

GLU_NURBS_ERROR37

GLScene.OpenGLTokens

GLU_NURBS_ERROR4

GLScene.OpenGL4

GLU_NURBS_ERROR4

GLScene.OpenGLTokens

GLU_NURBS_ERROR5

GLScene.OpenGL4

GLU_NURBS_ERROR5

GLScene.OpenGLTokens

GLU_NURBS_ERROR6

GLScene.OpenGL4

GLU_NURBS_ERROR6

GLScene.OpenGLTokens

GLU_NURBS_ERROR7

GLScene.OpenGL4

GLU_NURBS_ERROR7

GLScene.OpenGLTokens

GLU_NURBS_ERROR8

GLScene.OpenGL4

GLU_NURBS_ERROR8

GLScene.OpenGLTokens

GLU_NURBS_ERROR9

GLScene.OpenGL4

GLU_NURBS_ERROR9

GLScene.OpenGLTokens

GLU_OUTLINE_PATCH

GLScene.OpenGL4

GLU_OUTLINE_PATCH

GLScene.OpenGLTokens

GLU_OUTLINE_POLYGON

GLScene.OpenGL4

GLU_OUTLINE_POLYGON

GLScene.OpenGLTokens

NurbsDisplay

GLU_OUTSIDE

GLScene.OpenGL4

GLU_OUT_OF_MEMORY

GLScene.OpenGL4

GLU_PARAMETRIC_ERROR

GLScene.OpenGL4

GLU_PARAMETRIC_ERROR

GLScene.OpenGLTokens

GLU_PARAMETRIC_TOLERANCE

GLScene.OpenGL4

GLU_PARAMETRIC_TOLERANCE

GLScene.OpenGLTokens

GLU_PATH_LENGTH

GLScene.OpenGL4

GLU_PATH_LENGTH

GLScene.OpenGLTokens

NurbsSampling

GLU_POINT

GLScene.OpenGL4

GLU_SAMPLING_METHOD

GLScene.OpenGL4

GLU_SAMPLING_METHOD

GLScene.OpenGLTokens

GLU_SAMPLING_TOLERANCE

GLScene.OpenGL4

GLU_SAMPLING_TOLERANCE

GLScene.OpenGLTokens

GLU_SILHOUETTE

GLScene.OpenGL4

GLU_SMOOTH

GLScene.OpenGL4

GLU_TESS_BEGIN

GLScene.OpenGL4

GLU_TESS_BEGIN

GLScene.OpenGLTokens

********** GLU generic constants ********** TessCallback

GLU_TESS_BEGIN_DATA

GLScene.OpenGL4

GLU_TESS_BEGIN_DATA

GLScene.OpenGLTokens

TGLUTessCombineProc

GLU_TESS_BOUNDARY_ONLY

GLScene.OpenGL4

GLU_TESS_COMBINE

GLScene.OpenGL4

GLU_TESS_COMBINE

GLScene.OpenGLTokens

TGLUTessEdgeFlagProc

GLU_TESS_COMBINE_DATA

GLScene.OpenGL4

GLU_TESS_COMBINE_DATA

GLScene.OpenGLTokens

TGLUTessEdgeFlagDataProc

GLU_TESS_COORD_TOO_LARGE

GLScene.OpenGL4

GLU_TESS_COORD_TOO_LARGE

GLScene.OpenGLTokens

GLU_TESS_EDGE_FLAG

GLScene.OpenGL4

GLU_TESS_EDGE_FLAG

GLScene.OpenGLTokens

TGLUTessErrorProc

GLU_TESS_EDGE_FLAG_DATA

GLScene.OpenGL4

GLU_TESS_EDGE_FLAG_DATA

GLScene.OpenGLTokens

TGLUTessErrorDataProc

GLU_TESS_END

GLScene.OpenGL4

GLU_TESS_END

GLScene.OpenGLTokens

TGLUTessVertexProc

GLU_TESS_END_DATA

GLScene.OpenGL4

GLU_TESS_END_DATA

GLScene.OpenGLTokens

TGLUTessVertexDataProc

GLU_TESS_ERROR

GLScene.OpenGL4

GLU_TESS_ERROR

GLScene.OpenGLTokens

TGLUTessEndProc

GLU_TESS_ERROR1

GLScene.OpenGL4

GLU_TESS_ERROR1

GLScene.OpenGLTokens

TGLUTessCombineDataProc TessError

GLU_TESS_ERROR2

GLScene.OpenGL4

GLU_TESS_ERROR2

GLScene.OpenGLTokens

GLU_TESS_ERROR3

GLScene.OpenGL4

GLU_TESS_ERROR3

GLScene.OpenGLTokens

GLU_TESS_ERROR4

GLScene.OpenGL4

GLU_TESS_ERROR4

GLScene.OpenGLTokens

GLU_TESS_ERROR5

GLScene.OpenGL4

GLU_TESS_ERROR5

GLScene.OpenGLTokens

GLU_TESS_ERROR6

GLScene.OpenGL4

GLU_TESS_ERROR6

GLScene.OpenGLTokens

GLU_TESS_ERROR7

GLScene.OpenGL4

GLU_TESS_ERROR7

GLScene.OpenGLTokens

GLU_TESS_ERROR8

GLScene.OpenGL4

GLU_TESS_ERROR8

GLScene.OpenGLTokens

GLU_TESS_ERROR_DATA

GLScene.OpenGL4

GLU_TESS_ERROR_DATA

GLScene.OpenGLTokens

TGLUTessEndDataProc

GLU_TESS_MAX_COORD

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_CONTOUR

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_CONTOUR

GLScene.OpenGLTokens

GLU_TESS_MISSING_BEGIN_POLYGON

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_POLYGON

GLScene.OpenGLTokens

GLU_TESS_MISSING_END_CONTOUR

GLScene.OpenGL4

GLU_TESS_MISSING_END_CONTOUR

GLScene.OpenGLTokens

GLU_TESS_MISSING_END_POLYGON

GLScene.OpenGL4

GLU_TESS_MISSING_END_POLYGON

GLScene.OpenGLTokens

GLU_TESS_NEED_COMBINE_CALLBACK

GLScene.OpenGL4

GLU_TESS_NEED_COMBINE_CALLBACK

GLScene.OpenGLTokens

GLU_TESS_TOLERANCE

GLScene.OpenGL4

GLU_TESS_VERTEX

GLScene.OpenGL4

GLU_TESS_VERTEX

GLScene.OpenGLTokens

TGLUTessBeginProc

GLU_TESS_VERTEX_DATA

GLScene.OpenGL4

GLU_TESS_VERTEX_DATA

GLScene.OpenGLTokens

TGLUTessBeginDataProc

GLU_TESS_WINDING_ABS_GEQ_TWO

GLScene.OpenGL4

GLU_TESS_WINDING_NEGATIVE

GLScene.OpenGL4

GLU_TESS_WINDING_NONZERO

GLScene.OpenGL4

GLU_TESS_WINDING_ODD

GLScene.OpenGL4

GLU_TESS_WINDING_POSITIVE

GLScene.OpenGL4

GLU_TESS_WINDING_RULE

GLScene.OpenGL4

GLU_TRUE

GLScene.OpenGL4

GLU_UNKNOWN

GLScene.OpenGL4

GLU_UNKNOWN

GLScene.OpenGLTokens

GLU_U_STEP

GLScene.OpenGL4

GLU_U_STEP

GLScene.OpenGLTokens

GLU_VERSION

GLScene.OpenGL4

GLU_VERSION_1_3

GLScene.OpenGL4

GLU_VERTEX

GLScene.OpenGL4

GLU_VERTEX

GLScene.OpenGLTokens

GLU_V_STEP

GLScene.OpenGL4

GLU_V_STEP

GLScene.OpenGLTokens

glValidateProgram

GLScene.OpenGL4

glValidateProgramARB

GLScene.OpenGL4

GLVectorEditorForm

FmVectorEditor

glVertex2d

GLScene.OpenGL4

deprecated;

glVertex2dv

GLScene.OpenGL4

deprecated;

glVertex2f

GLScene.OpenGL4

deprecated;

glVertex2fv

GLScene.OpenGL4

deprecated;

glVertex2i

GLScene.OpenGL4

deprecated;

glVertex2iv

GLScene.OpenGL4

deprecated;

glVertex2s

GLScene.OpenGL4

deprecated;

glVertex2sv

GLScene.OpenGL4

deprecated;

glVertex3d

GLScene.OpenGL4

deprecated;

glVertex3dv

GLScene.OpenGL4

deprecated;

glVertex3f

GLScene.OpenGL4

deprecated;

glVertex3fv

GLScene.OpenGL4

deprecated;

glVertex3i

GLScene.OpenGL4

deprecated;

glVertex3iv

GLScene.OpenGL4

deprecated;

glVertex3s

GLScene.OpenGL4

deprecated;

glVertex3sv

GLScene.OpenGL4

deprecated;

glVertex4d

GLScene.OpenGL4

deprecated;

glVertex4dv

GLScene.OpenGL4

deprecated;

glVertex4f

GLScene.OpenGL4

deprecated;

glVertex4fv

GLScene.OpenGL4

deprecated;

glVertex4i

GLScene.OpenGL4

deprecated;

glVertex4iv

GLScene.OpenGL4

deprecated;

glVertex4s

GLScene.OpenGL4

deprecated;

glVertex4sv

GLScene.OpenGL4

deprecated;

glVertexArrayRangeNV

GLScene.OpenGL4

glVertexAttrib1d

GLScene.OpenGL4

glVertexAttrib1dARB

GLScene.OpenGL4

GL_ARB_vertex_program (ARB #26)

glVertexAttrib1dNV

GLScene.OpenGL4

glVertexAttrib1dv

GLScene.OpenGL4

glVertexAttrib1dvARB

GLScene.OpenGL4

glVertexAttrib1dvNV

GLScene.OpenGL4

glVertexAttrib1f

GLScene.OpenGL4

glVertexAttrib1fARB

GLScene.OpenGL4

glVertexAttrib1fNV

GLScene.OpenGL4

glVertexAttrib1fv

GLScene.OpenGL4

glVertexAttrib1fvARB

GLScene.OpenGL4

glVertexAttrib1fvNV

GLScene.OpenGL4

glVertexAttrib1s

GLScene.OpenGL4

glVertexAttrib1sARB

GLScene.OpenGL4

glVertexAttrib1sNV

GLScene.OpenGL4

glVertexAttrib1sv

GLScene.OpenGL4

glVertexAttrib1svARB

GLScene.OpenGL4

glVertexAttrib1svNV

GLScene.OpenGL4

glVertexAttrib2d

GLScene.OpenGL4

glVertexAttrib2dARB

GLScene.OpenGL4

glVertexAttrib2dNV

GLScene.OpenGL4

glVertexAttrib2dv

GLScene.OpenGL4

glVertexAttrib2dvARB

GLScene.OpenGL4

glVertexAttrib2dvNV

GLScene.OpenGL4

glVertexAttrib2f

GLScene.OpenGL4

glVertexAttrib2fARB

GLScene.OpenGL4

glVertexAttrib2fNV

GLScene.OpenGL4

glVertexAttrib2fv

GLScene.OpenGL4

glVertexAttrib2fvARB

GLScene.OpenGL4

glVertexAttrib2fvNV

GLScene.OpenGL4

glVertexAttrib2s

GLScene.OpenGL4

glVertexAttrib2sARB

GLScene.OpenGL4

glVertexAttrib2sNV

GLScene.OpenGL4

glVertexAttrib2sv

GLScene.OpenGL4

glVertexAttrib2svARB

GLScene.OpenGL4

glVertexAttrib2svNV

GLScene.OpenGL4

glVertexAttrib3d

GLScene.OpenGL4

glVertexAttrib3dARB

GLScene.OpenGL4

glVertexAttrib3dNV

GLScene.OpenGL4

glVertexAttrib3dv

GLScene.OpenGL4

glVertexAttrib3dvARB

GLScene.OpenGL4

glVertexAttrib3dvNV

GLScene.OpenGL4

glVertexAttrib3f

GLScene.OpenGL4

glVertexAttrib3fARB

GLScene.OpenGL4

glVertexAttrib3fNV

GLScene.OpenGL4

glVertexAttrib3fv

GLScene.OpenGL4

glVertexAttrib3fvARB

GLScene.OpenGL4

glVertexAttrib3fvNV

GLScene.OpenGL4

glVertexAttrib3s

GLScene.OpenGL4

glVertexAttrib3sARB

GLScene.OpenGL4

glVertexAttrib3sNV

GLScene.OpenGL4

glVertexAttrib3sv

GLScene.OpenGL4

glVertexAttrib3svARB

GLScene.OpenGL4

glVertexAttrib3svNV

GLScene.OpenGL4

glVertexAttrib4bv

GLScene.OpenGL4

glVertexAttrib4bvARB

GLScene.OpenGL4

glVertexAttrib4d

GLScene.OpenGL4

glVertexAttrib4dARB

GLScene.OpenGL4

glVertexAttrib4dNV

GLScene.OpenGL4

glVertexAttrib4dv

GLScene.OpenGL4

glVertexAttrib4dvARB

GLScene.OpenGL4

glVertexAttrib4dvNV

GLScene.OpenGL4

glVertexAttrib4f

GLScene.OpenGL4

glVertexAttrib4fARB

GLScene.OpenGL4

glVertexAttrib4fNV

GLScene.OpenGL4

glVertexAttrib4fv

GLScene.OpenGL4

glVertexAttrib4fvARB

GLScene.OpenGL4

glVertexAttrib4fvNV

GLScene.OpenGL4

glVertexAttrib4iv

GLScene.OpenGL4

glVertexAttrib4ivARB

GLScene.OpenGL4

glVertexAttrib4Nbv

GLScene.OpenGL4

glVertexAttrib4NbvARB

GLScene.OpenGL4

glVertexAttrib4Niv

GLScene.OpenGL4

glVertexAttrib4NivARB

GLScene.OpenGL4

glVertexAttrib4Nsv

GLScene.OpenGL4

glVertexAttrib4NsvARB

GLScene.OpenGL4

glVertexAttrib4Nub

GLScene.OpenGL4

glVertexAttrib4NubARB

GLScene.OpenGL4

glVertexAttrib4Nubv

GLScene.OpenGL4

glVertexAttrib4NubvARB

GLScene.OpenGL4

glVertexAttrib4Nuiv

GLScene.OpenGL4

glVertexAttrib4NuivARB

GLScene.OpenGL4

glVertexAttrib4Nusv

GLScene.OpenGL4

glVertexAttrib4NusvARB

GLScene.OpenGL4

glVertexAttrib4s

GLScene.OpenGL4

glVertexAttrib4sARB

GLScene.OpenGL4

glVertexAttrib4sNV

GLScene.OpenGL4

glVertexAttrib4sv

GLScene.OpenGL4

glVertexAttrib4svARB

GLScene.OpenGL4

glVertexAttrib4svNV

GLScene.OpenGL4

glVertexAttrib4ubv

GLScene.OpenGL4

glVertexAttrib4ubvARB

GLScene.OpenGL4

glVertexAttrib4ubvNV

GLScene.OpenGL4

glVertexAttrib4uiv

GLScene.OpenGL4

glVertexAttrib4uivARB

GLScene.OpenGL4

glVertexAttrib4usv

GLScene.OpenGL4

glVertexAttrib4usvARB

GLScene.OpenGL4

glVertexAttribDivisorARB

GLScene.OpenGL4

GL_ARB_instanced_arrays (ARB #49)

glVertexAttribFormatNV

GLScene.OpenGL4

glVertexAttribI1i

GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.0 Core ###########################################################

glVertexAttribI1iEXT

GLScene.OpenGL4

GL_EXT_gpu_shader4 (EXT #326)

glVertexAttribI1iv

GLScene.OpenGL4

glVertexAttribI1ivEXT

GLScene.OpenGL4

glVertexAttribI1ui

GLScene.OpenGL4

glVertexAttribI1uiEXT

GLScene.OpenGL4

glVertexAttribI1uiv

GLScene.OpenGL4

glVertexAttribI1uivEXT

GLScene.OpenGL4

glVertexAttribI2i

GLScene.OpenGL4

glVertexAttribI2iEXT

GLScene.OpenGL4

glVertexAttribI2iv

GLScene.OpenGL4

glVertexAttribI2ivEXT

GLScene.OpenGL4

glVertexAttribI2ui

GLScene.OpenGL4

glVertexAttribI2uiEXT

GLScene.OpenGL4

glVertexAttribI2uiv

GLScene.OpenGL4

glVertexAttribI2uivEXT

GLScene.OpenGL4

glVertexAttribI3i

GLScene.OpenGL4

glVertexAttribI3iEXT

GLScene.OpenGL4

glVertexAttribI3iv

GLScene.OpenGL4

glVertexAttribI3ivEXT

GLScene.OpenGL4

glVertexAttribI3ui

GLScene.OpenGL4

glVertexAttribI3uiEXT

GLScene.OpenGL4

glVertexAttribI3uiv

GLScene.OpenGL4

glVertexAttribI3uivEXT

GLScene.OpenGL4

glVertexAttribI4bv

GLScene.OpenGL4

glVertexAttribI4bvEXT

GLScene.OpenGL4

glVertexAttribI4i

GLScene.OpenGL4

glVertexAttribI4iEXT

GLScene.OpenGL4

glVertexAttribI4iv

GLScene.OpenGL4

glVertexAttribI4ivEXT

GLScene.OpenGL4

glVertexAttribI4sv

GLScene.OpenGL4

glVertexAttribI4svEXT

GLScene.OpenGL4

glVertexAttribI4ubv

GLScene.OpenGL4

glVertexAttribI4ubvEXT

GLScene.OpenGL4

glVertexAttribI4ui

GLScene.OpenGL4

glVertexAttribI4uiEXT

GLScene.OpenGL4

glVertexAttribI4uiv

GLScene.OpenGL4

glVertexAttribI4uivEXT

GLScene.OpenGL4

glVertexAttribI4usv

GLScene.OpenGL4

glVertexAttribI4usvEXT

GLScene.OpenGL4

glVertexAttribIFormatNV

GLScene.OpenGL4

glVertexAttribIPointer

GLScene.OpenGL4

glVertexAttribIPointerEXT

GLScene.OpenGL4

glVertexAttribP1ui

GLScene.OpenGL4

glVertexAttribP1uiv

GLScene.OpenGL4

glVertexAttribP2ui

GLScene.OpenGL4

glVertexAttribP2uiv

GLScene.OpenGL4

glVertexAttribP3ui

GLScene.OpenGL4

glVertexAttribP3uiv

GLScene.OpenGL4

glVertexAttribP4ui

GLScene.OpenGL4

glVertexAttribP4uiv

GLScene.OpenGL4

glVertexAttribPointer

GLScene.OpenGL4

glVertexAttribPointerARB

GLScene.OpenGL4

glVertexAttribPointerNV

GLScene.OpenGL4

glVertexAttribs1dvNV

GLScene.OpenGL4

glVertexAttribs1fvNV

GLScene.OpenGL4

glVertexAttribs1svNV

GLScene.OpenGL4

glVertexAttribs2dvNV

GLScene.OpenGL4

glVertexAttribs2fvNV

GLScene.OpenGL4

glVertexAttribs2svNV

GLScene.OpenGL4

glVertexAttribs3dvNV

GLScene.OpenGL4

glVertexAttribs3fvNV

GLScene.OpenGL4

glVertexAttribs3svNV

GLScene.OpenGL4

glVertexAttribs4dvNV

GLScene.OpenGL4

glVertexAttribs4fvNV

GLScene.OpenGL4

glVertexAttribs4svNV

GLScene.OpenGL4

glVertexAttribs4ubvNV

GLScene.OpenGL4

glVertexBlendARB

GLScene.OpenGL4

glVertexFormatNV

GLScene.OpenGL4

glVertexP2ui

GLScene.OpenGL4

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)

glVertexP2uiv

GLScene.OpenGL4

glVertexP3ui

GLScene.OpenGL4

glVertexP3uiv

GLScene.OpenGL4

glVertexP4ui

GLScene.OpenGL4

glVertexP4uiv

GLScene.OpenGL4

glVertexPointer

GLScene.OpenGL4

deprecated;

glViewport

GLScene.OpenGL4

deprecated;

glWaitSync

GLScene.OpenGL4

glWeightbvARB

GLScene.OpenGL4

GL_ARB_vertex_blend (ARB #15) {deprecated?}

glWeightdvARB

GLScene.OpenGL4

glWeightfvARB

GLScene.OpenGL4

glWeightivARB

GLScene.OpenGL4

glWeightPointerARB

GLScene.OpenGL4

glWeightsvARB

GLScene.OpenGL4

glWeightubvARB

GLScene.OpenGL4

glWeightuivARB

GLScene.OpenGL4

glWeightusvARB

GLScene.OpenGL4

glWindowPos2d

GLScene.OpenGL4

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)

glWindowPos2dARB

GLScene.OpenGL4

GL_ARB_window_pos (ARB #25)

glWindowPos2dv

GLScene.OpenGL4

deprecated;

glWindowPos2dvARB

GLScene.OpenGL4

glWindowPos2f

GLScene.OpenGL4

deprecated;

glWindowPos2fARB

GLScene.OpenGL4

glWindowPos2fv

GLScene.OpenGL4

deprecated;

glWindowPos2fvARB

GLScene.OpenGL4

glWindowPos2i

GLScene.OpenGL4

deprecated;

glWindowPos2iARB

GLScene.OpenGL4

glWindowPos2iv

GLScene.OpenGL4

deprecated;

glWindowPos2ivARB

GLScene.OpenGL4

glWindowPos2s

GLScene.OpenGL4

deprecated;

glWindowPos2sARB

GLScene.OpenGL4

glWindowPos2sv

GLScene.OpenGL4

deprecated;

glWindowPos2svARB

GLScene.OpenGL4

glWindowPos3d

GLScene.OpenGL4

deprecated;

glWindowPos3dARB

GLScene.OpenGL4

glWindowPos3dv

GLScene.OpenGL4

deprecated;

glWindowPos3dvARB

GLScene.OpenGL4

glWindowPos3f

GLScene.OpenGL4

deprecated;

glWindowPos3fARB

GLScene.OpenGL4

glWindowPos3fv

GLScene.OpenGL4

deprecated;

glWindowPos3fvARB

GLScene.OpenGL4

glWindowPos3i

GLScene.OpenGL4

deprecated;

glWindowPos3iARB

GLScene.OpenGL4

glWindowPos3iv

GLScene.OpenGL4

deprecated;

glWindowPos3ivARB

GLScene.OpenGL4

glWindowPos3s

GLScene.OpenGL4

deprecated;

glWindowPos3sARB

GLScene.OpenGL4

glWindowPos3sv

GLScene.OpenGL4

deprecated;

glWindowPos3svARB

GLScene.OpenGL4

GLwithoutContext

GLS.Context

GLX_ACCUM_ALPHA_SIZE

GLScene.OpenGL4

GLX_ACCUM_BLUE_SIZE

GLScene.OpenGL4

GLX_ACCUM_BUFFER_BIT

GLScene.OpenGL4

GLX_ACCUM_GREEN_SIZE

GLScene.OpenGL4

GLX_ACCUM_RED_SIZE

GLScene.OpenGL4

GLX_ALPHA_SIZE

GLScene.OpenGL4

GLX_ARB_context_flush_control

GLScene.OpenGL4

GLX

GLX_ARB_create_context

GLScene.OpenGL4

GLX

GLX_ARB_create_context_profile

GLScene.OpenGL4

GLX

GLX_ARB_create_context_robustness

GLScene.OpenGL4

GLX

GLX_ARB_fbconfig_float

GLScene.OpenGL4

GLX

GLX_ARB_framebuffer_sRGB

GLScene.OpenGL4

GLX

GLX_ARB_get_proc_address

GLScene.OpenGL4

GLX

GLX_ARB_multisample

GLScene.OpenGL4

GLX

GLX_ARB_vertex_buffer_object

GLScene.OpenGL4

GLX

GLX_AUX0_EXT

GLScene.OpenGL4

GLX_AUX1_EXT

GLScene.OpenGL4

GLX_AUX2_EXT

GLScene.OpenGL4

GLX_AUX3_EXT

GLScene.OpenGL4

GLX_AUX4_EXT

GLScene.OpenGL4

GLX_AUX5_EXT

GLScene.OpenGL4

GLX_AUX6_EXT

GLScene.OpenGL4

GLX_AUX7_EXT

GLScene.OpenGL4

GLX_AUX8_EXT

GLScene.OpenGL4

GLX_AUX9_EXT

GLScene.OpenGL4

GLX_AUX_BUFFERS

GLScene.OpenGL4

GLX_AUX_BUFFERS_BIT

GLScene.OpenGL4

GLX_BACK_EXT

GLScene.OpenGL4

GLX_BACK_LEFT_BUFFER_BIT

GLScene.OpenGL4

GLX_BACK_LEFT_EXT

GLScene.OpenGL4

GLX_BACK_RIGHT_BUFFER_BIT

GLScene.OpenGL4

GLX_BACK_RIGHT_EXT

GLScene.OpenGL4

GLX_BIND_TO_MIPMAP_TEXTURE_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_RGBA_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_RGB_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_TARGETS_EXT

GLScene.OpenGL4

GLX_BLUE_SIZE

GLScene.OpenGL4

GLX_BUFFER_SIZE

GLScene.OpenGL4

GLX_COLOR_INDEX_BIT

GLScene.OpenGL4

GLX_COLOR_INDEX_TYPE

GLScene.OpenGL4

GLX_CONFIG_CAVEAT

GLScene.OpenGL4

GLX_CONTEXT_ALLOW_BUFFER_BYTE_ORDER_MISMATCH_ARB

GLScene.OpenGL4

GLX_ARB_vertex_buffer_object

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGL4

GLX_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context_profile

GLX_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context

GLX_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGL4

GLX_EXT_create_context_es2_profile

GLX_CONTEXT_FLAGS_ARB

GLScene.OpenGL4

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGL4

GLX_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGL4

GLX_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGL4

GLX_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGL4

GLX_CONTEXT_RELEASE_BEHAVIOR_ARB

GLScene.OpenGL4

GLX_ARB_context_flush_control

GLX_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB

GLScene.OpenGL4

GLX_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB

GLScene.OpenGL4

GLX_CONTEXT_RESET_ISOLATION_BIT_ARB

GLScene.OpenGL4

GLX_ARB_robustness_application_isolation

GLX_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

GLX_CONTEXT_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context_robustness

GLX_DAMAGED

GLScene.OpenGL4

GLX_DEPTH_BUFFER_BIT

GLScene.OpenGL4

GLX_DEPTH_SIZE

GLScene.OpenGL4

GLX_DIRECT_COLOR

GLScene.OpenGL4

GLX_DIRECT_COLOR_EXT

GLScene.OpenGL4

GLX_DONT_CARE

GLScene.OpenGL4

GLX_DOUBLEBUFFER

GLScene.OpenGL4

GLX_DRAWABLE_TYPE

GLScene.OpenGL4

GLX_EVENT_MASK

GLScene.OpenGL4

GLX_EXTENSIONS

GLScene.OpenGL4

GLX_EXT_create_context_es2_profile

GLScene.OpenGL4

GLX

GLX_EXT_fbconfig_packed_float

GLScene.OpenGL4

GLX

GLX_EXT_framebuffer_sRGB

GLScene.OpenGL4

GLX

GLX_EXT_import_context

GLScene.OpenGL4

GLX

GLX_EXT_swap_control

GLScene.OpenGL4

GLX

GLX_EXT_texture_from_pixmap

GLScene.OpenGL4

GLX

GLX_EXT_visual_info

GLScene.OpenGL4

GLX

GLX_EXT_visual_rating

GLScene.OpenGL4

GLX

GLX_FBCONFIG_ID

GLScene.OpenGL4

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGL4

GLX_ARB_framebuffer_sRGB

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_sRGB

GLX_FRONT_EXT

GLScene.OpenGL4

GLX_FRONT_LEFT_BUFFER_BIT

GLScene.OpenGL4

GLX_FRONT_LEFT_EXT

GLScene.OpenGL4

GLX_FRONT_RIGHT_BUFFER_BIT

GLScene.OpenGL4

GLX_FRONT_RIGHT_EXT

GLScene.OpenGL4

GLX_GRAY_SCALE

GLScene.OpenGL4

GLX_GRAY_SCALE_EXT

GLScene.OpenGL4

GLX_GREEN_SIZE

GLScene.OpenGL4

GLX_HEIGHT

GLScene.OpenGL4

GLX_LARGEST_PBUFFER

GLScene.OpenGL4

GLX_LATE_SWAPS_TEAR_EXT

GLScene.OpenGL4

GL_EXT_Late_Swaps

GLX_LEVEL

GLScene.OpenGL4

GLX_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

GLX_MAX_PBUFFER_HEIGHT

GLScene.OpenGL4

GLX_MAX_PBUFFER_PIXELS

GLScene.OpenGL4

GLX_MAX_PBUFFER_WIDTH

GLScene.OpenGL4

GLX_MAX_SWAP_INTERVAL_EXT

GLScene.OpenGL4

GLX_MIPMAP_TEXTURE_EXT

GLScene.OpenGL4

GLX_NONE

GLScene.OpenGL4

GLX_NONE_EXT

GLScene.OpenGL4

GLX_NON_CONFORMANT_CONFIG

GLScene.OpenGL4

GLX_NON_CONFORMANT_VISUAL_EXT

GLScene.OpenGL4

GLX_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

GLX_PBUFFER

GLScene.OpenGL4

GLX_PBUFFER_BIT

GLScene.OpenGL4

GLX_PBUFFER_CLOBBER_MASK

GLScene.OpenGL4

GLX_PBUFFER_HEIGHT

GLScene.OpenGL4

GLX_PBUFFER_WIDTH

GLScene.OpenGL4

GLX_PIXMAP_BIT

GLScene.OpenGL4

GLX_PRESERVED_CONTENTS

GLScene.OpenGL4

GLX_PSEUDO_COLOR

GLScene.OpenGL4

GLX_PSEUDO_COLOR_EXT

GLScene.OpenGL4

GLX_RED_SIZE

GLScene.OpenGL4

GLX_RENDER_TYPE

GLScene.OpenGL4

GLX_RGBA

GLScene.OpenGL4

GLX_RGBA_BIT

GLScene.OpenGL4

GLX_RGBA_FLOAT_BIT

GLScene.OpenGL4

GLX_RGBA_FLOAT_BIT_ARB

GLScene.OpenGL4

GLX_RGBA_FLOAT_TYPE

GLScene.OpenGL4

GLX_RGBA_FLOAT_TYPE_ARB

GLScene.OpenGL4

GLX_ARB_fbconfig_float

GLX_RGBA_TYPE

GLScene.OpenGL4

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT

GLScene.OpenGL4

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT

GLScene.OpenGL4

GLX_SAMPLES

GLScene.OpenGL4

GLX_SAMPLES_ARB

GLScene.OpenGL4

GLX_SAMPLE_BUFFERS

GLScene.OpenGL4

GLX_VERSION_1_4

GLX_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

GLX_ARB_multisample

GLX_SAVED

GLScene.OpenGL4

GLX_SCREEN

GLScene.OpenGL4

GLX_SCREEN_EXT

GLScene.OpenGL4

GLX_SHARE_CONTEXT_EXT

GLScene.OpenGL4

GLX_EXT_import_context

GLX_SLOW_CONFIG

GLScene.OpenGL4

GLX_SLOW_VISUAL_EXT

GLScene.OpenGL4

GLX_STATIC_COLOR

GLScene.OpenGL4

GLX_STATIC_COLOR_EXT

GLScene.OpenGL4

GLX_STATIC_GRAY

GLScene.OpenGL4

GLX_STATIC_GRAY_EXT

GLScene.OpenGL4

GLX_STENCIL_BUFFER_BIT

GLScene.OpenGL4

GLX_STENCIL_SIZE

GLScene.OpenGL4

GLX_STEREO

GLScene.OpenGL4

GLX_SWAP_INTERVAL_EXT

GLScene.OpenGL4

GLX_EXT_swap_control

GLX_TEXTURE_1D_BIT_EXT

GLScene.OpenGL4

GLX_EXT_fbconfig_packed_float GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1; GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008; GLX_EXT_framebuffer_sRGB GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2; GLX_EXT_texture_from_pixmap

GLX_TEXTURE_1D_EXT

GLScene.OpenGL4

GLX_TEXTURE_2D_BIT_EXT

GLScene.OpenGL4

GLX_TEXTURE_2D_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_NONE_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_RGBA_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_RGB_EXT

GLScene.OpenGL4

GLX_TEXTURE_RECTANGLE_BIT_EXT

GLScene.OpenGL4

GLX_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GLX_TEXTURE_TARGET_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_ALPHA_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_ALPHA_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_BLUE_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_BLUE_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_GREEN_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_GREEN_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_RED_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_RED_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_RGB

GLScene.OpenGL4

GLX_TRANSPARENT_RGB_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_TYPE

GLScene.OpenGL4

GLX_TRANSPARENT_TYPE_EXT

GLScene.OpenGL4

GLX_TRUE_COLOR

GLScene.OpenGL4

GLX_TRUE_COLOR_EXT

GLScene.OpenGL4

GLX_USE_GL

GLScene.OpenGL4

GLX_VENDOR

GLScene.OpenGL4

GLX 1.1 and later:

GLX_VERSION

GLScene.OpenGL4

GLX_VERSION_1_4

GLScene.OpenGL4

GLX

GLX_VISUAL_CAVEAT_EXT

GLScene.OpenGL4

GLX_EXT_visual_rating

GLX_VISUAL_ID

GLScene.OpenGL4

GLX_VISUAL_ID_EXT

GLScene.OpenGL4

GLX_WIDTH

GLScene.OpenGL4

GLX_WINDOW

GLScene.OpenGL4

GLX_WINDOW_BIT

GLScene.OpenGL4

GLX_VERSION_1_3

GLX_X_RENDERABLE

GLScene.OpenGL4

GLX_X_VISUAL_TYPE

GLScene.OpenGL4

GLX_X_VISUAL_TYPE_EXT

GLScene.OpenGL4

GLX_EXT_visual_info

GLX_Y_INVERTED_EXT

GLScene.OpenGL4

GL_1PASS_EXT

GLScene.OpenGL4

GL_1PASS_SGIS

GLScene.OpenGL4

GL_2D

GLScene.OpenGL4

GL_2PASS_0_EXT

GLScene.OpenGL4

GL_2PASS_0_SGIS

GLScene.OpenGL4

GL_2PASS_1_EXT

GLScene.OpenGL4

GL_2PASS_1_SGIS

GLScene.OpenGL4

GL_2X_BIT_ATI

GLScene.OpenGL4

GL_2_BYTES

GLScene.OpenGL4

GL_3D

GLScene.OpenGL4

GL_3DFX_multisample

GLScene.OpenGL4

GL_3DFX_tbuffer

GLScene.OpenGL4

GL_3DFX_texture_compression_FXT1

GLScene.OpenGL4

GL_3D_COLOR

GLScene.OpenGL4

GL_3D_COLOR_TEXTURE

GLScene.OpenGL4

GL_3_BYTES

GLScene.OpenGL4

GL_422_AVERAGE_EXT

GLScene.OpenGL4

GL_422_EXT

GLScene.OpenGL4

GL_EXT_422_pixels

GL_422_REV_AVERAGE_EXT

GLScene.OpenGL4

GL_422_REV_EXT

GLScene.OpenGL4

GL_4D_COLOR_TEXTURE

GLScene.OpenGL4

GL_4PASS_0_EXT

GLScene.OpenGL4

GL_4PASS_0_SGIS

GLScene.OpenGL4

GL_4PASS_1_EXT

GLScene.OpenGL4

GL_4PASS_1_SGIS

GLScene.OpenGL4

GL_4PASS_2_EXT

GLScene.OpenGL4

GL_4PASS_2_SGIS

GLScene.OpenGL4

GL_4PASS_3_EXT

GLScene.OpenGL4

GL_4PASS_3_SGIS

GLScene.OpenGL4

GL_4X_BIT_ATI

GLScene.OpenGL4

GL_4_BYTES

GLScene.OpenGL4

GL_8X_BIT_ATI

GLScene.OpenGL4

GL_ABGR_EXT

GLScene.OpenGL4

GL_EXT_abgr

GL_ACCUM

GLScene.OpenGL4

GL_ACCUM_ADJACENT_PAIRS_NV

GLScene.OpenGL4

GL_ACCUM_ALPHA_BITS

GLScene.OpenGL4

GL_ACCUM_BLUE_BITS

GLScene.OpenGL4

GL_ACCUM_BUFFER_BIT

GLScene.OpenGL4

GL_ACCUM_CLEAR_VALUE

GLScene.OpenGL4

GL_ACCUM_GREEN_BITS

GLScene.OpenGL4

GL_ACCUM_RED_BITS

GLScene.OpenGL4

GL_ACTIVE_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_ACTIVE_ATTRIBUTES

GLScene.OpenGL4

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_PROGRAM

GLScene.OpenGL4

GL_ACTIVE_PROGRAM_EXT

GLScene.OpenGL4

GL_EXT_separate_shader_objects

GL_ACTIVE_RESOURCES

GLScene.OpenGL4

GL_ACTIVE_STENCIL_FACE_EXT

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINES

GLScene.OpenGL4

GL_ARB_shader_subroutine

GL_ACTIVE_SUBROUTINE_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORMS

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_TEXTURE

GLScene.OpenGL4

GL_ACTIVE_TEXTURE_ARB

GLScene.OpenGL4

GL_ACTIVE_UNIFORMS

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_ACTIVE_VARYINGS_NV

GLScene.OpenGL4

GL_ACTIVE_VARYING_MAX_LENGTH_NV

GLScene.OpenGL4

GL_ACTIVE_VERTEX_UNITS_ARB

GLScene.OpenGL4

GL_ADD

GLScene.OpenGL4

GL_ADD_ATI

GLScene.OpenGL4

GL_ADD_SIGNED

GLScene.OpenGL4

GL_ADD_SIGNED_ARB

GLScene.OpenGL4

GL_ADD_SIGNED_EXT

GLScene.OpenGL4

GL_ADJACENT_PAIRS_NV

GLScene.OpenGL4

GL_AFFINE_2D_NV

GLScene.OpenGL4

GL_AFFINE_3D_NV

GLScene.OpenGL4

GL_ALIASED_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_ALIASED_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_ALLOW_DRAW_FRG_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_MEM_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_OBJ_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_WIN_HINT_PGI

GLScene.OpenGL4

GL_ALL_ATTRIB_BITS

GLScene.OpenGL4

GL_ALL_BARRIER_BITS

GLScene.OpenGL4

GL_ALL_BARRIER_BITS_EXT

GLScene.OpenGL4

GL_ALL_COMPLETED_NV

GLScene.OpenGL4

GL_NV_fence

GL_ALL_SHADER_BITS

GLScene.OpenGL4

GL_ALPHA

GLScene.OpenGL4

GL_ALPHA12

GLScene.OpenGL4

GL_ALPHA12_EXT

GLScene.OpenGL4

GL_ALPHA16

GLScene.OpenGL4

GL_ALPHA16F_ARB

GLScene.OpenGL4

GL_ALPHA16I_EXT

GLScene.OpenGL4

GL_ALPHA16UI_EXT

GLScene.OpenGL4

GL_ALPHA16_EXT

GLScene.OpenGL4

GL_ALPHA16_SNORM

GLScene.OpenGL4

GL_ALPHA32F_ARB

GLScene.OpenGL4

GL_ALPHA32I_EXT

GLScene.OpenGL4

GL_ALPHA32UI_EXT

GLScene.OpenGL4

GL_ALPHA4

GLScene.OpenGL4

GL_ALPHA4_EXT

GLScene.OpenGL4

GL_EXT_texture

GL_ALPHA8

GLScene.OpenGL4

GL_ALPHA8I_EXT

GLScene.OpenGL4

GL_ALPHA8UI_EXT

GLScene.OpenGL4

GL_ALPHA8_EXT

GLScene.OpenGL4

GL_ALPHA8_SNORM

GLScene.OpenGL4

GL_ALPHA_BIAS

GLScene.OpenGL4

GL_ALPHA_BITS

GLScene.OpenGL4

GL_ALPHA_FLOAT16_APPLE

GLScene.OpenGL4

GL_ALPHA_FLOAT16_ATI

GLScene.OpenGL4

GL_ALPHA_FLOAT32_APPLE

GLScene.OpenGL4

GL_ALPHA_FLOAT32_ATI

GLScene.OpenGL4

GL_ALPHA_INTEGER

GLScene.OpenGL4

GL_ALPHA_INTEGER_EXT

GLScene.OpenGL4

GL_ALPHA_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_ALPHA_MAX_SGIX

GLScene.OpenGL4

GL_ALPHA_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_ALPHA_MIN_SGIX

GLScene.OpenGL4

GL_SGIX_blend_alpha_minmax

GL_ALPHA_SCALE

GLScene.OpenGL4

GL_ALPHA_SNORM

GLScene.OpenGL4

GL_EXT_texture_snorm

GL_ALPHA_TEST

GLScene.OpenGL4

GL_ALPHA_TEST_FUNC

GLScene.OpenGL4

GL_ALPHA_TEST_REF

GLScene.OpenGL4

GL_ALREADY_SIGNALED

GLScene.OpenGL4

GL_ALWAYS

GLScene.OpenGL4

GL_ALWAYS_FAST_HINT_PGI

GLScene.OpenGL4

GL_ALWAYS_SOFT_HINT_PGI

GLScene.OpenGL4

GL_AMBIENT

GLScene.OpenGL4

GL_AMBIENT_AND_DIFFUSE

GLScene.OpenGL4

GL_AMD_conservative_depth

GLScene.OpenGL4

GL 4.6

GL_AMD_debug_output

GLScene.OpenGL4

GL 4.6

GL_AMD_depth_clamp_separate

GLScene.OpenGL4

GL 4.6

GL_AMD_draw_buffers_blend

GLScene.OpenGL4

GL 4.6

GL_AMD_name_gen_delete

GLScene.OpenGL4

GL 4.6

GL_AMD_performance_monitor

GLScene.OpenGL4

GL 4.6

GL_AMD_pinned_memory

GLScene.OpenGL4

GL 4.3

GL_AMD_query_buffer_object

GLScene.OpenGL4

GL 4.3

GL_AMD_seamless_cubemap_per_texture

GLScene.OpenGL4

GL 4.6

GL_AMD_shader_stencil_export

GLScene.OpenGL4

GL 4.6

GL_AMD_stencil_operation_extended

GLScene.OpenGL4

GL 4.3

GL_AMD_texture_texture4

GLScene.OpenGL4

GL 4.6

GL_AMD_transform_feedback3_lines_triangles

GLScene.OpenGL4

GL 4.6

GL_AMD_vertex_shader_layer

GLScene.OpenGL4

GL 4.3

GL_AMD_vertex_shader_tesselator

GLScene.OpenGL4

GL 4.6

GL_AMD_vertex_shader_viewport_index

GLScene.OpenGL4

GL 4.3

GL_AND

GLScene.OpenGL4

GL_AND_INVERTED

GLScene.OpenGL4

GL_AND_REVERSE

GLScene.OpenGL4

GL_ANY_SAMPLES_PASSED

GLScene.OpenGL4

GL_ARB_occlusion_query2

GL_ANY_SAMPLES_PASSED_CONSERVATIVE

GLScene.OpenGL4

GL_APPLE_aux_depth_stencil

GLScene.OpenGL4

GL_APPLE_client_storage

GLScene.OpenGL4

GL_APPLE_element_array

GLScene.OpenGL4

GL_APPLE_fence

GLScene.OpenGL4

GL_APPLE_float_pixels

GLScene.OpenGL4

GL_APPLE_object_purgeable

GLScene.OpenGL4

GL_APPLE_rgb_422

GLScene.OpenGL4

GL_APPLE_row_bytes

GLScene.OpenGL4

GL_APPLE_specular_vector

GLScene.OpenGL4

GL_APPLE_texture_range

GLScene.OpenGL4

GL_APPLE_transform_hint

GLScene.OpenGL4

GL_APPLE_vertex_array_object

GLScene.OpenGL4

GL_APPLE_vertex_array_range

GLScene.OpenGL4

GL_APPLE_vertex_program_evaluators

GLScene.OpenGL4

GL_APPLE_ycbcr_422

GLScene.OpenGL4

GL_ARB_arrays_of_arrays

GLScene.OpenGL4

GL 4.3

GL_ARB_base_instance

GLScene.OpenGL4

GL 4.2

GL_ARB_bindless_texture

GLScene.OpenGL4

GL 4.4

GL_ARB_blend_func_extended

GLScene.OpenGL4

GL_ARB_buffer_storage

GLScene.OpenGL4

GL 4.4

GL_ARB_clear_buffer_object

GLScene.OpenGL4

GL 4.3

GL_ARB_clear_texture

GLScene.OpenGL4

GL 4.4

GL_ARB_clip_control

GLScene.OpenGL4

GL 4.5

GL_ARB_cl_event

GLScene.OpenGL4

GL 4.6

GL_ARB_color_buffer_float

GLScene.OpenGL4

GL_ARB_compatibility

GLScene.OpenGL4

GL_ARB_compressed_texture_pixel_storage

GLScene.OpenGL4

GL 4.2

GL_ARB_compute_shader

GLScene.OpenGL4

GL 4.3

GL_ARB_compute_variable_group_size

GLScene.OpenGL4

GL 4.6

GL_ARB_conditional_render_inverted

GLScene.OpenGL4

GL 4.5

GL_ARB_conservative_depth

GLScene.OpenGL4

GL 4.2

GL_ARB_copy_buffer

GLScene.OpenGL4

GL_ARB_copy_image

GLScene.OpenGL4

GL 4.3

GL_ARB_cull_distance

GLScene.OpenGL4

GL 4.5

GL_ARB_debug_output

GLScene.OpenGL4

GL 4.6

GL_ARB_depth_buffer_float

GLScene.OpenGL4

GL_ARB_depth_clamp

GLScene.OpenGL4

GL_ARB_depth_texture

GLScene.OpenGL4

GL_ARB_derivative_control

GLScene.OpenGL4

GL 4.5

GL_ARB_direct_state_access

GLScene.OpenGL4

GL 4.5

GL_ARB_draw_buffers

GLScene.OpenGL4

GL_ARB_draw_buffers_blend

GLScene.OpenGL4

GL_ARB_draw_elements_base_vertex

GLScene.OpenGL4

GL_ARB_draw_indirect

GLScene.OpenGL4

GL_ARB_draw_instanced

GLScene.OpenGL4

GL_ARB_enhanced_layouts

GLScene.OpenGL4

GL 4.4

GL_ARB_ES2_compatibility

GLScene.OpenGL4

GL_ARB_ES3_1_compatibility

GLScene.OpenGL4

GL 4.5

GL_ARB_ES3_2_compatibility

GLScene.OpenGL4

GL_ARB_ES3_compatibility

GLScene.OpenGL4

GL 4.3

GL_ARB_explicit_attrib_location

GLScene.OpenGL4

GL_ARB_explicit_uniform_location

GLScene.OpenGL4

GL 4.3

GL_ARB_fragment_coord_conventions

GLScene.OpenGL4

GL_ARB_fragment_layer_viewport

GLScene.OpenGL4

GL 4.3

GL_ARB_fragment_program

GLScene.OpenGL4

GL_ARB_fragment_program_shadow

GLScene.OpenGL4

GL_ARB_fragment_shader

GLScene.OpenGL4

GL_ARB_fragment_shader_interlock

GLScene.OpenGL4

GL_ARB_framebuffer_no_attachments

GLScene.OpenGL4

GL 4.3

GL_ARB_framebuffer_object

GLScene.OpenGL4

GL_ARB_framebuffer_sRGB

GLScene.OpenGL4

GL_ARB_geometry_shader4

GLScene.OpenGL4

GL_ARB_get_program_binary

GLScene.OpenGL4

GL_ARB_get_texture_sub_image

GLScene.OpenGL4

GL 4.5

GL_ARB_gl_spirv

GLScene.OpenGL4

GL 4.6

GL_ARB_gpu_shader5

GLScene.OpenGL4

GL_ARB_gpu_shader_fp64

GLScene.OpenGL4

GL_ARB_gpu_shader_int64

GLScene.OpenGL4

GL_ARB_half_float_pixel

GLScene.OpenGL4

GL_ARB_half_float_vertex

GLScene.OpenGL4

GL_ARB_imaging

GLScene.OpenGL4

GL_ARB_indirect_parameters

GLScene.OpenGL4

GL 4.6

GL_ARB_instanced_arrays

GLScene.OpenGL4

GL_ARB_internalformat_query

GLScene.OpenGL4

GL 4.2

GL_ARB_internalformat_query2

GLScene.OpenGL4

GL 4.3

GL_ARB_invalidate_subdata

GLScene.OpenGL4

GL 4.3

GL_ARB_map_buffer_alignment

GLScene.OpenGL4

GL 4.2

GL_ARB_map_buffer_range

GLScene.OpenGL4

GL_ARB_matrix_palette

GLScene.OpenGL4

GL_ARB_multisample

GLScene.OpenGL4

GL_ARB_multitexture

GLScene.OpenGL4

GL_ARB_multi_bind

GLScene.OpenGL4

GL 4.4

GL_ARB_multi_draw_indirect

GLScene.OpenGL4

GL 4.3

GL_ARB_occlusion_query

GLScene.OpenGL4

GL_ARB_occlusion_query2

GLScene.OpenGL4

GL_ARB_parallel_shader_compile

GLScene.OpenGL4

GL_ARB_pipeline_statistics_query

GLScene.OpenGL4

GL 4.6

GL_ARB_pixel_buffer_object

GLScene.OpenGL4

GL_ARB_point_parameters

GLScene.OpenGL4

GL_ARB_point_sprite

GLScene.OpenGL4

GL_ARB_polygon_offset_clamp

GLScene.OpenGL4

GL 4.6

GL_ARB_post_depth_coverage

GLScene.OpenGL4

GL_ARB_program_interface_query

GLScene.OpenGL4

GL 4.3

GL_ARB_provoking_vertex

GLScene.OpenGL4

GL_ARB_query_buffer_object

GLScene.OpenGL4

GL 4.4

GL_ARB_robustness

GLScene.OpenGL4

GL 4.6

GL_ARB_robust_buffer_access_behavior

GLScene.OpenGL4

GL 4.3

GL_ARB_sampler_objects

GLScene.OpenGL4

GL_ARB_sample_locations

GLScene.OpenGL4

GL_ARB_sample_shading

GLScene.OpenGL4

GL_ARB_seamless_cube_map

GLScene.OpenGL4

GL_ARB_separate_shader_objects

GLScene.OpenGL4

GL_ARB_shader_atomic_counters

GLScene.OpenGL4

GL 4.2

GL_ARB_shader_atomic_counter_ops

GLScene.OpenGL4

GL 4.6

GL_ARB_shader_ballot

GLScene.OpenGL4

GL_ARB_shader_bit_encoding

GLScene.OpenGL4

GL_ARB_shader_clock

GLScene.OpenGL4

GL_ARB_shader_draw_parameters

GLScene.OpenGL4

GL 4.6

GL_ARB_shader_group_vote

GLScene.OpenGL4

GL 4.6

GL_ARB_shader_image_load_store

GLScene.OpenGL4

GL 4.2

GL_ARB_shader_image_size

GLScene.OpenGL4

GL 4.3

GL_ARB_shader_objects

GLScene.OpenGL4

GL_ARB_shader_precision

GLScene.OpenGL4

GL_ARB_shader_stencil_export

GLScene.OpenGL4

GL 4.6

GL_ARB_shader_storage_buffer_object

GLScene.OpenGL4

GL 4.3

GL_ARB_shader_subroutine

GLScene.OpenGL4

GL_ARB_shader_texture_image_samples

GLScene.OpenGL4

GL 4.5

GL_ARB_shader_texture_lod

GLScene.OpenGL4

GL_ARB_shader_viewport_layer_array

GLScene.OpenGL4

GL_ARB_shading_language_100

GLScene.OpenGL4

GL_ARB_shading_language_420pack

GLScene.OpenGL4

GL 4.2

GL_ARB_shading_language_include

GLScene.OpenGL4

GL_ARB_shading_language_packing

GLScene.OpenGL4

GL 4.2

GL_ARB_shadow

GLScene.OpenGL4

GL_ARB_shadow_ambient

GLScene.OpenGL4

GL_ARB_sparse_texture

GLScene.OpenGL4

GL 4.4

GL_ARB_sparse_texture2

GLScene.OpenGL4

GL_ARB_sparse_texture_clamp

GLScene.OpenGL4

GL_ARB_spirv_extensions

GLScene.OpenGL4

GL 4.6

GL_ARB_stencil_texturing

GLScene.OpenGL4

GL 4.3

GL_ARB_sync

GLScene.OpenGL4

GL_ARB_tessellation_shader

GLScene.OpenGL4

GL_ARB_texture_barrier

GLScene.OpenGL4

GL 4.5

GL_ARB_texture_border_clamp

GLScene.OpenGL4

GL_ARB_texture_buffer_object

GLScene.OpenGL4

GL_ARB_texture_buffer_object_rgb32

GLScene.OpenGL4

GL_ARB_texture_buffer_range

GLScene.OpenGL4

GL 4.3

GL_ARB_texture_compression

GLScene.OpenGL4

GL_ARB_texture_compression_bptc

GLScene.OpenGL4

GL_ARB_texture_compression_rgtc

GLScene.OpenGL4

GL_ARB_texture_cube_map

GLScene.OpenGL4

GL_ARB_texture_cube_map_array

GLScene.OpenGL4

GL_ARB_texture_env_add

GLScene.OpenGL4

GL_ARB_texture_env_combine

GLScene.OpenGL4

GL_ARB_texture_env_crossbar

GLScene.OpenGL4

GL_ARB_texture_env_dot3

GLScene.OpenGL4

GL_ARB_texture_filter_anisotropic

GLScene.OpenGL4

GL 4.6

GL_ARB_texture_filter_minmax

GLScene.OpenGL4

GL_ARB_texture_float

GLScene.OpenGL4

GL_ARB_texture_gather

GLScene.OpenGL4

GL_ARB_texture_mirrored_repeat

GLScene.OpenGL4

GL_ARB_texture_mirror_clamp_to_edge

GLScene.OpenGL4

GL 4.4

GL_ARB_texture_multisample

GLScene.OpenGL4

GL_ARB_texture_non_power_of_two

GLScene.OpenGL4

GL_ARB_texture_query_levels

GLScene.OpenGL4

GL 4.3

GL_ARB_texture_query_lod

GLScene.OpenGL4

GL_ARB_texture_rectangle

GLScene.OpenGL4

GL_ARB_texture_rg

GLScene.OpenGL4

GL_ARB_texture_rgb10_a2ui

GLScene.OpenGL4

GL_ARB_texture_stencil8

GLScene.OpenGL4

GL 4.4

GL_ARB_texture_storage

GLScene.OpenGL4

GL 4.2

GL_ARB_texture_storage_multisample

GLScene.OpenGL4

GL 4.3

GL_ARB_texture_swizzle

GLScene.OpenGL4

GL_ARB_texture_view

GLScene.OpenGL4

GL 4.3

GL_ARB_timer_query

GLScene.OpenGL4

GL_ARB_transform_feedback2

GLScene.OpenGL4

GL_ARB_transform_feedback3

GLScene.OpenGL4

GL_ARB_transform_feedback_instanced

GLScene.OpenGL4

GL 4.2

GL_ARB_transform_feedback_overflow_query

GLScene.OpenGL4

GL 4.6

GL_ARB_transpose_matrix

GLScene.OpenGL4

GL_ARB_uniform_buffer_object

GLScene.OpenGL4

GL_ARB_vertex_array_bgra

GLScene.OpenGL4

GL_ARB_vertex_array_object

GLScene.OpenGL4

GL_ARB_vertex_attrib_64bit

GLScene.OpenGL4

GL_ARB_vertex_attrib_binding

GLScene.OpenGL4

GL 4.3

GL_ARB_vertex_blend

GLScene.OpenGL4

GL_ARB_vertex_buffer_object

GLScene.OpenGL4

GL_ARB_vertex_program

GLScene.OpenGL4

GL_ARB_vertex_shader

GLScene.OpenGL4

GL_ARB_vertex_type_10f_11f_11f_rev

GLScene.OpenGL4

GL 4.4

GL_ARB_vertex_type_2_10_10_10_rev

GLScene.OpenGL4

GL_ARB_viewport_array

GLScene.OpenGL4

GL_ARB_window_pos

GLScene.OpenGL4

GL_ARC_TO_NV

GLScene.OpenGL4

GL_ARRAY_BUFFER

GLScene.OpenGL4

GL_ARRAY_BUFFER_ARB

GLScene.OpenGL4

GL_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT

GLScene.OpenGL4

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT

GLScene.OpenGL4

GL_EXT_compiled_vertex_array

GL_ARRAY_OBJECT_BUFFER_ATI

GLScene.OpenGL4

GL_ARRAY_OBJECT_OFFSET_ATI

GLScene.OpenGL4

GL_ARRAY_SIZE

GLScene.OpenGL4

GL_ARRAY_STRIDE

GLScene.OpenGL4

GL_ASE_MAX_SMOOTH_GROUPS

GLS.FileASE

maximum material submaterials

GL_ASE_MAX_SUBMATERIALS

GLS.FileASE

maximum texture channels

GL_ASE_MAX_TEXTURE_MAPS

GLS.FileASE

maximum smoothing groups

GL_ASE_MAX_TEXURE_CHANNELS

GLS.FileASE

GL_ASYNC_DRAW_PIXELS_SGIX

GLScene.OpenGL4

GL_ASYNC_HISTOGRAM_SGIX

GLScene.OpenGL4

GL_SGIX_async_histogram

GL_ASYNC_MARKER_SGIX

GLScene.OpenGL4

GL_SGIX_async

GL_ASYNC_READ_PIXELS_SGIX

GLScene.OpenGL4

GL_ASYNC_TEX_IMAGE_SGIX

GLScene.OpenGL4

GL_SGIX_async_pixel

GL_ATI_draw_buffers

GLScene.OpenGL4

GL 4.6

GL_ATI_element_array

GLScene.OpenGL4

GL 4.6

GL_ATI_envmap_bumpmap

GLScene.OpenGL4

GL 4.6

GL_ATI_fragment_shader

GLScene.OpenGL4

GL 4.6

GL_ATI_map_object_buffer

GLScene.OpenGL4

GL 4.6

GL_ATI_meminfo

GLScene.OpenGL4

GL 4.6

GL_ATI_pn_triangles

GLScene.OpenGL4

GL 4.6

GL_ATI_separate_stencil

GLScene.OpenGL4

GL 4.6

GL_ATI_texture_env_combine3

GLScene.OpenGL4

GL 4.6

GL_ATI_texture_float

GLScene.OpenGL4

GL 4.6

GL_ATI_texture_mirror_once

GLScene.OpenGL4

GL 4.6

GL_ATI_text_fragment_shader

GLScene.OpenGL4

GL 4.6

GL_ATI_vertex_array_object

GLScene.OpenGL4

GL 4.6

GL_ATI_vertex_attrib_array_object

GLScene.OpenGL4

GL 4.6

GL_ATI_vertex_streams

GLScene.OpenGL4

GL 4.6

GL_ATOMIC_COUNTER_BARRIER_BIT

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER

GLScene.OpenGL4

GL_ARB_shader_atomic_counters

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTER_INDICES

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_BINDING

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_DATA_SIZE

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_INDEX

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_SIZE

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_START

GLScene.OpenGL4

GL_ATTACHED_SHADERS

GLScene.OpenGL4

GL_ATTENUATION_EXT

GLScene.OpenGL4

GL_ATTRIB_ARRAY_POINTER_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_SIZE_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_STRIDE_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_TYPE_NV

GLScene.OpenGL4

GL_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_AUTO_GENERATE_MIPMAP

GLScene.OpenGL4

GL_AUTO_NORMAL

GLScene.OpenGL4

GL_AUX0

GLScene.OpenGL4

GL_AUX1

GLScene.OpenGL4

GL_AUX2

GLScene.OpenGL4

GL_AUX3

GLScene.OpenGL4

GL_AUX_BUFFERS

GLScene.OpenGL4

GL_AUX_DEPTH_STENCIL_APPLE

GLScene.OpenGL4

GL_APPLE_aux_depth_stencil

GL_AVERAGE_EXT

GLScene.OpenGL4

GL_AVERAGE_HP

GLScene.OpenGL4

GL_BACK

GLScene.OpenGL4

GL_BACK_LEFT

GLScene.OpenGL4

GL_BACK_NORMALS_HINT_PGI

GLScene.OpenGL4

GL_BACK_PRIMARY_COLOR_NV

GLScene.OpenGL4

GL_BACK_RIGHT

GLScene.OpenGL4

GL_BACK_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_BEVEL_NV

GLScene.OpenGL4

GL_BGR

GLScene.OpenGL4

GL_BGRA

GLScene.OpenGL4

GL_BGRA_EXT

GLScene.OpenGL4

GL_BGRA_INTEGER

GLScene.OpenGL4

GL_BGRA_INTEGER_EXT

GLScene.OpenGL4

GL_BGR_EXT

GLScene.OpenGL4

GL_EXT_bgra

GL_BGR_INTEGER

GLScene.OpenGL4

GL_BGR_INTEGER_EXT

GLScene.OpenGL4

GL_BIAS_BIT_ATI

GLScene.OpenGL4

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV

GLScene.OpenGL4

GL_BINORMAL_ARRAY_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_BITMAP

GLScene.OpenGL4

GL_BITMAP_TOKEN

GLScene.OpenGL4

GL_BLEND

GLScene.OpenGL4

GL_BLEND_ADVANCED_COHERENT_KHR

GLScene.OpenGL4

GL_KHR_blend_equation_advanced_coherent

GL_BLEND_COLOR

GLScene.OpenGL4

GL_BLEND_COLOR_EXT

GLScene.OpenGL4

GL_BLEND_DST

GLScene.OpenGL4

GL_BLEND_DST_ALPHA

GLScene.OpenGL4

GL_BLEND_DST_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_DST_RGB

GLScene.OpenGL4

GL_VERSION_1_4

GL_BLEND_DST_RGB_EXT

GLScene.OpenGL4

GL_EXT_blend_func_separate

GL_BLEND_EQUATION

GLScene.OpenGL4

GL_BLEND_EQUATION_ALPHA

GLScene.OpenGL4

GL_BLEND_EQUATION_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_EQUATION_EXT

GLScene.OpenGL4

GL_BLEND_EQUATION_RGB

GLScene.OpenGL4

GL_VERSION_2_0

GL_BLEND_EQUATION_RGB_EXT

GLScene.OpenGL4

GL_EXT_blend_equation_separate

GL_BLEND_SRC

GLScene.OpenGL4

GL_BLEND_SRC_ALPHA

GLScene.OpenGL4

GL_BLEND_SRC_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_SRC_RGB

GLScene.OpenGL4

GL_BLEND_SRC_RGB_EXT

GLScene.OpenGL4

GL_BLOCK_INDEX

GLScene.OpenGL4

GL_BLUE

GLScene.OpenGL4

GL_BLUE_BIAS

GLScene.OpenGL4

GL_BLUE_BITS

GLScene.OpenGL4

GL_BLUE_BIT_ATI

GLScene.OpenGL4

GL_BLUE_INTEGER

GLScene.OpenGL4

GL_BLUE_INTEGER_EXT

GLScene.OpenGL4

GL_BLUE_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_BLUE_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_BLUE_SCALE

GLScene.OpenGL4

GL_BOLD_BIT_NV

GLScene.OpenGL4

GL_BOOL

GLScene.OpenGL4

GL_BOOL_ARB

GLScene.OpenGL4

GL_BOOL_VEC2

GLScene.OpenGL4

GL_BOOL_VEC2_ARB

GLScene.OpenGL4

GL_BOOL_VEC3

GLScene.OpenGL4

GL_BOOL_VEC3_ARB

GLScene.OpenGL4

GL_BOOL_VEC4

GLScene.OpenGL4

GL_BOOL_VEC4_ARB

GLScene.OpenGL4

GL_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV

GLScene.OpenGL4

GL_BUFFER

GLScene.OpenGL4

GL_BUFFER_ACCESS

GLScene.OpenGL4

GL_BUFFER_ACCESS_ARB

GLScene.OpenGL4

GL_BUFFER_ACCESS_FLAGS

GLScene.OpenGL4

GL_BUFFER_BINDING

GLScene.OpenGL4

GL_BUFFER_DATA_SIZE

GLScene.OpenGL4

GL_BUFFER_GPU_ADDRESS_NV

GLScene.OpenGL4

GL_NV_shader_buffer_load

GL_BUFFER_IMMUTABLE_STORAGE

GLScene.OpenGL4

GL_BUFFER_MAPPED

GLScene.OpenGL4

GL_BUFFER_MAPPED_ARB

GLScene.OpenGL4

GL_BUFFER_MAP_LENGTH

GLScene.OpenGL4

GL_BUFFER_MAP_OFFSET

GLScene.OpenGL4

GL_BUFFER_MAP_POINTER

GLScene.OpenGL4

GL_BUFFER_MAP_POINTER_ARB

GLScene.OpenGL4

GL_BUFFER_OBJECT_APPLE

GLScene.OpenGL4

GL_APPLE_object_purgeable

GL_BUFFER_SIZE

GLScene.OpenGL4

GL_VERSION_1_5

GL_BUFFER_SIZE_ARB

GLScene.OpenGL4

GL_ARB_vertex_buffer_object

GL_BUFFER_STORAGE_FLAGS

GLScene.OpenGL4

GL_BUFFER_UPDATE_BARRIER_BIT

GLScene.OpenGL4

GL_BUFFER_UPDATE_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_BUFFER_USAGE

GLScene.OpenGL4

GL_BUFFER_USAGE_ARB

GLScene.OpenGL4

GL_BUFFER_VARIABLE

GLScene.OpenGL4

GL_BUMP_ENVMAP_ATI

GLScene.OpenGL4

GL_BUMP_NUM_TEX_UNITS_ATI

GLScene.OpenGL4

GL_BUMP_ROT_MATRIX_ATI

GLScene.OpenGL4

GL_ATI_envmap_bumpmap

GL_BUMP_ROT_MATRIX_SIZE_ATI

GLScene.OpenGL4

GL_BUMP_TARGET_ATI

GLScene.OpenGL4

GL_BUMP_TEX_UNITS_ATI

GLScene.OpenGL4

GL_BYTE

GLScene.OpenGL4

DataType

GL_C3F_V3F

GLScene.OpenGL4

GL_C4F_N3F_V3F

GLScene.OpenGL4

GL_C4UB_V2F

GLScene.OpenGL4

GL_C4UB_V3F

GLScene.OpenGL4

GL_CALLIGRAPHIC_FRAGMENT_SGIX

GLScene.OpenGL4

GL_SGIX_calligraphic_fragment

GL_CAVEAT_SUPPORT

GLScene.OpenGL4

GL_CCW

GLScene.OpenGL4

GL_CIRCULAR_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_CIRCULAR_CW_ARC_TO_NV

GLScene.OpenGL4

GL_CIRCULAR_TANGENT_ARC_TO_NV

GLScene.OpenGL4

GL_CLAMP

GLScene.OpenGL4

GL_CLAMP_FRAGMENT_COLOR

GLScene.OpenGL4

GL_CLAMP_FRAGMENT_COLOR_ARB

GLScene.OpenGL4

GL_CLAMP_READ_COLOR

GLScene.OpenGL4

GL_CLAMP_READ_COLOR_ARB

GLScene.OpenGL4

GL_CLAMP_TO_BORDER

GLScene.OpenGL4

GL_CLAMP_TO_BORDER_ARB

GLScene.OpenGL4

GL_ARB_texture_border_clamp

GL_CLAMP_TO_EDGE

GLScene.OpenGL4

GL_CLAMP_TO_EDGE_EXT

GLScene.OpenGL4

GL_EXT_texture_edge_clamp

GL_CLAMP_TO_EDGE_SGIS

GLScene.OpenGL4

GL_SGIS_texture_edge_clamp

GL_CLAMP_VERTEX_COLOR

GLScene.OpenGL4

GL_CLAMP_VERTEX_COLOR_ARB

GLScene.OpenGL4

GL_CLEAR

GLScene.OpenGL4

LogicOp

GL_CLEAR_BUFFER

GLScene.OpenGL4

GL_CLEAR_TEXTURE

GLScene.OpenGL4

GL_CLIENT_ACTIVE_TEXTURE

GLScene.OpenGL4

GL_CLIENT_ACTIVE_TEXTURE_ARB

GLScene.OpenGL4

GL_CLIENT_ALL_ATTRIB_BITS

GLScene.OpenGL4

GL_CLIENT_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_CLIENT_MAPPED_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_CLIENT_PIXEL_STORE_BIT

GLScene.OpenGL4

GL_CLIENT_STORAGE_BIT

GLScene.OpenGL4

GL_CLIENT_VERTEX_ARRAY_BIT

GLScene.OpenGL4

GL_CLIPPING_INPUT_PRIMITIVES

GLScene.OpenGL4

GL_CLIPPING_INPUT_PRIMITIVES_ARB

GLScene.OpenGL4

GL_CLIPPING_OUTPUT_PRIMITIVES

GLScene.OpenGL4

GL_CLIPPING_OUTPUT_PRIMITIVES_ARB

GLScene.OpenGL4

GL_CLIP_DEPTH_MODE

GLScene.OpenGL4

GL_CLIP_DISTANCE0

GLScene.OpenGL4

GL_CLIP_DISTANCE1

GLScene.OpenGL4

GL_CLIP_DISTANCE2

GLScene.OpenGL4

GL_CLIP_DISTANCE3

GLScene.OpenGL4

GL_CLIP_DISTANCE4

GLScene.OpenGL4

GL_CLIP_DISTANCE5

GLScene.OpenGL4

GL_CLIP_DISTANCE6

GLScene.OpenGL4

GL_CLIP_DISTANCE7

GLScene.OpenGL4

GL_CLIP_DISTANCE_NV

GLScene.OpenGL4

GL_CLIP_FAR_HINT_PGI

GLScene.OpenGL4

GL_CLIP_NEAR_HINT_PGI

GLScene.OpenGL4

GL_CLIP_ORIGIN

GLScene.OpenGL4

GL_CLIP_PLANE0

GLScene.OpenGL4

GL_CLIP_PLANE1

GLScene.OpenGL4

GL_CLIP_PLANE2

GLScene.OpenGL4

GL_CLIP_PLANE3

GLScene.OpenGL4

GL_CLIP_PLANE4

GLScene.OpenGL4

GL_CLIP_PLANE5

GLScene.OpenGL4

GL_CLIP_VOLUME_CLIPPING_HINT_EXT

GLScene.OpenGL4

GL_EXT_clip_volume_hint

GL_CLOSE_PATH_NV

GLScene.OpenGL4

GL_CMYKA_EXT

GLScene.OpenGL4

GL_CMYK_EXT

GLScene.OpenGL4

GL_EXT_cmyka

GL_CND0_ATI

GLScene.OpenGL4

GL_CND_ATI

GLScene.OpenGL4

GL_COEFF

GLScene.OpenGL4

GL_COLOR

GLScene.OpenGL4

PixelCopyType

GL_COLOR3_BIT_PGI

GLScene.OpenGL4

GL_COLOR4_BIT_PGI

GLScene.OpenGL4

GL_COLORBURN_KHR

GLScene.OpenGL4

GL_COLORDODGE_KHR

GLScene.OpenGL4

GL_COLOR_ALPHA_PAIRING_ATI

GLScene.OpenGL4

GL_COLOR_ARRAY

GLScene.OpenGL4

GL_COLOR_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_COLOR_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_COLOR_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_COLOR_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_COLOR_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_COLOR_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_COLOR_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_COLOR_ARRAY_POINTER

GLScene.OpenGL4

GL_COLOR_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_SIZE

GLScene.OpenGL4

GL_COLOR_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_STRIDE

GLScene.OpenGL4

GL_COLOR_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_TYPE

GLScene.OpenGL4

GL_COLOR_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT0

GLScene.OpenGL4

GL_COLOR_ATTACHMENT0_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT1

GLScene.OpenGL4

GL_COLOR_ATTACHMENT10

GLScene.OpenGL4

GL_COLOR_ATTACHMENT10_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT11

GLScene.OpenGL4

GL_COLOR_ATTACHMENT11_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT12

GLScene.OpenGL4

GL_COLOR_ATTACHMENT12_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT13

GLScene.OpenGL4

GL_COLOR_ATTACHMENT13_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT14

GLScene.OpenGL4

GL_COLOR_ATTACHMENT14_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT15

GLScene.OpenGL4

GL_COLOR_ATTACHMENT15_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT1_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT2

GLScene.OpenGL4

GL_COLOR_ATTACHMENT2_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT3

GLScene.OpenGL4

GL_COLOR_ATTACHMENT3_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT4

GLScene.OpenGL4

GL_COLOR_ATTACHMENT4_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT5

GLScene.OpenGL4

GL_COLOR_ATTACHMENT5_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT6

GLScene.OpenGL4

GL_COLOR_ATTACHMENT6_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT7

GLScene.OpenGL4

GL_COLOR_ATTACHMENT7_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT8

GLScene.OpenGL4

GL_COLOR_ATTACHMENT8_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT9

GLScene.OpenGL4

GL_COLOR_ATTACHMENT9_EXT

GLScene.OpenGL4

GL_COLOR_BUFFER_BIT

GLScene.OpenGL4

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI

GLScene.OpenGL4

GL_COLOR_CLEAR_VALUE

GLScene.OpenGL4

GL_COLOR_COMPONENTS

GLScene.OpenGL4

GL_COLOR_ENCODING

GLScene.OpenGL4

GL_COLOR_FLOAT_APPLE

GLScene.OpenGL4

GL_COLOR_INDEX

GLScene.OpenGL4

GL_COLOR_INDEX12_EXT

GLScene.OpenGL4

GL_COLOR_INDEX16_EXT

GLScene.OpenGL4

GL_COLOR_INDEX1_EXT

GLScene.OpenGL4

GL_EXT_paletted_texture

GL_COLOR_INDEX2_EXT

GLScene.OpenGL4

GL_COLOR_INDEX4_EXT

GLScene.OpenGL4

GL_COLOR_INDEX8_EXT

GLScene.OpenGL4

GL_COLOR_INDEXES

GLScene.OpenGL4

GL_COLOR_LOGIC_OP

GLScene.OpenGL4

GL_COLOR_MATERIAL

GLScene.OpenGL4

GL_COLOR_MATERIAL_FACE

GLScene.OpenGL4

GL_COLOR_MATERIAL_PARAMETER

GLScene.OpenGL4

GL_COLOR_MATRIX

GLScene.OpenGL4

GL_COLOR_MATRIX_SGI

GLScene.OpenGL4

GL_SGI_color_matrix

GL_COLOR_MATRIX_STACK_DEPTH

GLScene.OpenGL4

GL_COLOR_MATRIX_STACK_DEPTH_SGI

GLScene.OpenGL4

GL_COLOR_RENDERABLE

GLScene.OpenGL4

GL_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_COLOR_SUM

GLScene.OpenGL4

GL_COLOR_SUM_ARB

GLScene.OpenGL4

GL_ARB_vertex_program

GL_COLOR_SUM_CLAMP_NV

GLScene.OpenGL4

GL_COLOR_SUM_EXT

GLScene.OpenGL4

GL_EXT_secondary_color

GL_COLOR_TABLE

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_BIAS

GLScene.OpenGL4

GL_COLOR_TABLE_BIAS_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_SCALE

GLScene.OpenGL4

GL_COLOR_TABLE_SCALE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_SGI_color_table

GL_COLOR_TABLE_WIDTH

GLScene.OpenGL4

GL_COLOR_TABLE_WIDTH_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_WIDTH_SGI

GLScene.OpenGL4

GL_COLOR_WRITEMASK

GLScene.OpenGL4

GL_COMBINE

GLScene.OpenGL4

GL_COMBINE4_NV

GLScene.OpenGL4

GL_NV_texture_env_combine4

GL_COMBINER0_NV

GLScene.OpenGL4

GL_COMBINER1_NV

GLScene.OpenGL4

GL_COMBINER2_NV

GLScene.OpenGL4

GL_COMBINER3_NV

GLScene.OpenGL4

GL_COMBINER4_NV

GLScene.OpenGL4

GL_COMBINER5_NV

GLScene.OpenGL4

GL_COMBINER6_NV

GLScene.OpenGL4

GL_COMBINER7_NV

GLScene.OpenGL4

GL_COMBINER_AB_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_COMBINER_AB_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINER_BIAS_NV

GLScene.OpenGL4

GL_COMBINER_CD_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_COMBINER_CD_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINER_COMPONENT_USAGE_NV

GLScene.OpenGL4

GL_COMBINER_INPUT_NV

GLScene.OpenGL4

GL_COMBINER_MAPPING_NV

GLScene.OpenGL4

GL_COMBINER_MUX_SUM_NV

GLScene.OpenGL4

GL_COMBINER_SCALE_NV

GLScene.OpenGL4

GL_COMBINER_SUM_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINE_ALPHA

GLScene.OpenGL4

GL_COMBINE_ALPHA_ARB

GLScene.OpenGL4

GL_COMBINE_ALPHA_EXT

GLScene.OpenGL4

GL_COMBINE_ARB

GLScene.OpenGL4

GL_ARB_texture_env_combine

GL_COMBINE_EXT

GLScene.OpenGL4

GL_EXT_texture_env_combine

GL_COMBINE_RGB

GLScene.OpenGL4

GL_COMBINE_RGB_ARB

GLScene.OpenGL4

GL_COMBINE_RGB_EXT

GLScene.OpenGL4

GL_COMMAND_BARRIER_BIT

GLScene.OpenGL4

GL_COMMAND_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT

GLScene.OpenGL4

GL_COMPARE_REF_TO_TEXTURE

GLScene.OpenGL4

GL_VERSION_3_0

GL_COMPARE_R_TO_TEXTURE

GLScene.OpenGL4

GL_COMPARE_R_TO_TEXTURE_ARB

GLScene.OpenGL4

GL_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_COMPILE

GLScene.OpenGL4

GL_COMPILE_AND_EXECUTE

GLScene.OpenGL4

GL_COMPILE_STATUS

GLScene.OpenGL4

GL_COMPLETION_STATUS_ARB

GLScene.OpenGL4

GL_COMPRESSED_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_ALPHA_ARB

GLScene.OpenGL4

GL_ARB_texture_compression

GL_COMPRESSED_INTENSITY

GLScene.OpenGL4

GL_COMPRESSED_INTENSITY_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI

GLScene.OpenGLTokens

GL_ATI_texture_compression_3dc

GL_COMPRESSED_LUMINANCE_ALPHA_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_LATC1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_latc

GL_COMPRESSED_R11_EAC

GLScene.OpenGL4

GL_COMPRESSED_RED

GLScene.OpenGL4

GL_COMPRESSED_RED_GREEN_RGTC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_RED_RGTC1

GLScene.OpenGL4

GL_ARB_texture_compression_rgtc

GL_COMPRESSED_RED_RGTC1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_rgtc

GL_COMPRESSED_RG

GLScene.OpenGL4

GL_COMPRESSED_RG11_EAC

GLScene.OpenGL4

GL_COMPRESSED_RGB

GLScene.OpenGL4

GL_COMPRESSED_RGB8_ETC2

GLScene.OpenGL4

GL_COMPRESSED_RGB8_PUNCHTHROUGH_ALPHA1_ETC2

GLScene.OpenGL4

GL_COMPRESSED_RGBA

GLScene.OpenGL4

GL_COMPRESSED_RGBA8_ETC2_EAC

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_105_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_106_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_108_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_110_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_12x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_12x12_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_4x4_KHR

GLScene.OpenGL4

4.3 GL_KHR_texture_compression_astc_hdr

GL_COMPRESSED_RGBA_ASTC_5x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_5x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_6x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_6x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB

GLScene.OpenGL4

GL_ARB_texture_compression_bptc

GL_COMPRESSED_RGBA_FXT1_3DFX

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGB_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_FXT1_3DFX

GLScene.OpenGL4

GL_3DFX_texture_compression_FXT1

GL_COMPRESSED_RGB_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_s3tc

GL_COMPRESSED_RG_RGTC2

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_R11_EAC

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_RGTC1

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RG11_EAC

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RG_RGTC2

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x12_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_4x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ETC2_EAC

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ETC2

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_PUNCHTHROUGH_ALPHA1_ETC2

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_TEXTURE_FORMATS

GLScene.OpenGL4

GL_COMPRESSED_TEXTURE_FORMATS_ARB

GLScene.OpenGL4

GL_COMPUTE_LOCAL_WORK_SIZE

GLScene.OpenGL4

GL_COMPUTE_SHADER

GLScene.OpenGL4

GL_COMPUTE_SHADER_BIT

GLScene.OpenGL4

GL_COMPUTE_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_COMPUTE_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_COMPUTE_SUBROUTINE

GLScene.OpenGL4

GL_COMPUTE_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_COMPUTE_TEXTURE

GLScene.OpenGL4

GL_COMP_BIT_ATI

GLScene.OpenGL4

GL_CONDITION_SATISFIED

GLScene.OpenGL4

GL_CONSERVATIVE_RASTERIZATION_NV

GLScene.OpenGL4

GL_NV_conservative_raster

GL_CONSERVATIVE_RASTER_DILATE_GRANULARITY_NV

GLScene.OpenGL4

GL_CONSERVATIVE_RASTER_DILATE_NV

GLScene.OpenGL4

GL_NV_conservative_raster_dilate

GL_CONSERVATIVE_RASTER_DILATE_RANGE_NV

GLScene.OpenGL4

GL_CONSERVE_MEMORY_HINT_PGI

GLScene.OpenGL4

GL_CONSTANT

GLScene.OpenGL4

GL_CONSTANT_ALPHA

GLScene.OpenGL4

GL_CONSTANT_ALPHA_EXT

GLScene.OpenGL4

GL_CONSTANT_ARB

GLScene.OpenGL4

GL_CONSTANT_ATTENUATION

GLScene.OpenGL4

GL_CONSTANT_BORDER

GLScene.OpenGL4

GL_CONSTANT_BORDER_HP

GLScene.OpenGL4

GL_CONSTANT_COLOR0_NV

GLScene.OpenGL4

GL_CONSTANT_COLOR1_NV

GLScene.OpenGL4

GL_CONSTANT_COLOR_ARB

GLScene.OpenGL4

GL_ARB_imaging

GL_CONSTANT_COLOR_EXT

GLScene.OpenGL4

GL_EXT_blend_color

GL_CONSTANT_EXT

GLScene.OpenGL4

GL_CONST_EYE_NV

GLScene.OpenGL4

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT

GLScene.OpenGL4

GL_CONTEXT_CORE_PROFILE_BIT

GLScene.OpenGL4

GL_VERSION_3_2

GL_CONTEXT_FLAGS

GLScene.OpenGL4

GL_CONTEXT_FLAG_DEBUG_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_NO_ERROR_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_NO_ERROR_BIT_KHR

GLScene.OpenGL4

GL_KHR_no_error

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

GL_ARB_robustness

GL_CONTEXT_LOST

GLScene.OpenGL4

GL 4.5

GL_CONTEXT_PROFILE_MASK

GLScene.OpenGL4

GL_CONTEXT_RELEASE_BEHAVIOR

GLScene.OpenGL4

GL_CONTEXT_RELEASE_BEHAVIOR_FLUSH

GLScene.OpenGL4

GL_CONTEXT_ROBUST_ACCESS

GLScene.OpenGL4

GL_KHR_robustness

GL_CONTINUOUS_AMD

GLScene.OpenGL4

GL_CONVEX_HULL_NV

GLScene.OpenGL4

GL_CONVOLUTION_1D

GLScene.OpenGL4

GL_CONVOLUTION_1D_EXT

GLScene.OpenGL4

GL_EXT_convolution

GL_CONVOLUTION_2D

GLScene.OpenGL4

GL_CONVOLUTION_2D_EXT

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_COLOR

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_COLOR_HP

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_MODE

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_MODE_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_BIAS

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_BIAS_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_SCALE

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_SCALE_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FORMAT

GLScene.OpenGL4

GL_CONVOLUTION_FORMAT_EXT

GLScene.OpenGL4

GL_CONVOLUTION_HEIGHT

GLScene.OpenGL4

GL_CONVOLUTION_HEIGHT_EXT

GLScene.OpenGL4

GL_CONVOLUTION_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_convolution_accuracy

GL_CONVOLUTION_WIDTH

GLScene.OpenGL4

GL_CONVOLUTION_WIDTH_EXT

GLScene.OpenGL4

GL_CON_0_ATI

GLScene.OpenGL4

GL_CON_10_ATI

GLScene.OpenGL4

GL_CON_11_ATI

GLScene.OpenGL4

GL_CON_12_ATI

GLScene.OpenGL4

GL_CON_13_ATI

GLScene.OpenGL4

GL_CON_14_ATI

GLScene.OpenGL4

GL_CON_15_ATI

GLScene.OpenGL4

GL_CON_16_ATI

GLScene.OpenGL4

GL_CON_17_ATI

GLScene.OpenGL4

GL_CON_18_ATI

GLScene.OpenGL4

GL_CON_19_ATI

GLScene.OpenGL4

GL_CON_1_ATI

GLScene.OpenGL4

GL_CON_20_ATI

GLScene.OpenGL4

GL_CON_21_ATI

GLScene.OpenGL4

GL_CON_22_ATI

GLScene.OpenGL4

GL_CON_23_ATI

GLScene.OpenGL4

GL_CON_24_ATI

GLScene.OpenGL4

GL_CON_25_ATI

GLScene.OpenGL4

GL_CON_26_ATI

GLScene.OpenGL4

GL_CON_27_ATI

GLScene.OpenGL4

GL_CON_28_ATI

GLScene.OpenGL4

GL_CON_29_ATI

GLScene.OpenGL4

GL_CON_2_ATI

GLScene.OpenGL4

GL_CON_30_ATI

GLScene.OpenGL4

GL_CON_31_ATI

GLScene.OpenGL4

GL_CON_3_ATI

GLScene.OpenGL4

GL_CON_4_ATI

GLScene.OpenGL4

GL_CON_5_ATI

GLScene.OpenGL4

GL_CON_6_ATI

GLScene.OpenGL4

GL_CON_7_ATI

GLScene.OpenGL4

GL_CON_8_ATI

GLScene.OpenGL4

GL_CON_9_ATI

GLScene.OpenGL4

GL_COORD_REPLACE

GLScene.OpenGL4

GL_COORD_REPLACE_ARB

GLScene.OpenGL4

GL_COORD_REPLACE_NV

GLScene.OpenGL4

GL_COPY

GLScene.OpenGL4

GL_COPY_INVERTED

GLScene.OpenGL4

GL_COPY_PIXEL_TOKEN

GLScene.OpenGL4

GL_COPY_READ_BUFFER

GLScene.OpenGL4

GL_COPY_READ_BUFFER_BINDING

GLScene.OpenGL4

GL_ARB_copy_buffer

GL_COPY_WRITE_BUFFER

GLScene.OpenGL4

GL_COPY_WRITE_BUFFER_BINDING

GLScene.OpenGL4

GL_COUNTER_RANGE_AMD

GLScene.OpenGL4

GL_COUNTER_TYPE_AMD

GLScene.OpenGL4

GL_AMD_performance_monitor

GL_COUNT_DOWN_NV

GLScene.OpenGL4

GL_COUNT_UP_NV

GLScene.OpenGL4

GL_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_multisample_coverage

GL_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_CUBIC_EXT

GLScene.OpenGL4

GL_CUBIC_HP

GLScene.OpenGL4

GL_CULL_FACE

GLScene.OpenGL4

GL_CULL_FACE_MODE

GLScene.OpenGL4

GL_CULL_FRAGMENT_NV

GLScene.OpenGL4

GL_CULL_MODES_NV

GLScene.OpenGL4

GL_CULL_VERTEX_EXT

GLScene.OpenGL4

GL_EXT_cull_vertex

GL_CULL_VERTEX_EYE_POSITION_EXT

GLScene.OpenGL4

GL_CULL_VERTEX_IBM

GLScene.OpenGL4

GL_IBM_cull_vertex

GL_CULL_VERTEX_OBJECT_POSITION_EXT

GLScene.OpenGL4

GL_CURRENT_ATTRIB_NV

GLScene.OpenGL4

GL_CURRENT_BINORMAL_EXT

GLScene.OpenGL4

GL_CURRENT_BIT

GLScene.OpenGL4

GL_CURRENT_COLOR

GLScene.OpenGL4

GL_CURRENT_FOG_COORD

GLScene.OpenGL4

GL_CURRENT_FOG_COORDINATE

GLScene.OpenGL4

GL_CURRENT_FOG_COORDINATE_EXT

GLScene.OpenGL4

GL_CURRENT_INDEX

GLScene.OpenGL4

GL_CURRENT_MATRIX_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_INDEX_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_NV

GLScene.OpenGL4

GL_CURRENT_MATRIX_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_STACK_DEPTH_NV

GLScene.OpenGL4

GL_CURRENT_NORMAL

GLScene.OpenGL4

GL_CURRENT_OCCLUSION_QUERY_ID_NV

GLScene.OpenGL4

GL_CURRENT_PALETTE_MATRIX_ARB

GLScene.OpenGL4

GL_CURRENT_PROGRAM

GLScene.OpenGL4

GL_CURRENT_QUERY

GLScene.OpenGL4

GL_CURRENT_QUERY_ARB

GLScene.OpenGL4

GL_CURRENT_RASTER_COLOR

GLScene.OpenGL4

GL_CURRENT_RASTER_DISTANCE

GLScene.OpenGL4

GL_CURRENT_RASTER_INDEX

GLScene.OpenGL4

GL_CURRENT_RASTER_NORMAL_SGIX

GLScene.OpenGL4

GL_CURRENT_RASTER_POSITION

GLScene.OpenGL4

GL_CURRENT_RASTER_POSITION_VALID

GLScene.OpenGL4

GL_CURRENT_RASTER_SECONDARY_COLOR

GLScene.OpenGL4

GL_CURRENT_RASTER_TEXTURE_COORDS

GLScene.OpenGL4

GL_CURRENT_SECONDARY_COLOR

GLScene.OpenGL4

GL_CURRENT_SECONDARY_COLOR_EXT

GLScene.OpenGL4

GL_CURRENT_TANGENT_EXT

GLScene.OpenGL4

GL_CURRENT_TEXTURE_COORDS

GLScene.OpenGL4

GL_CURRENT_TIME_NV

GLScene.OpenGL4

GL_CURRENT_VERTEX_ATTRIB

GLScene.OpenGL4

GL_CURRENT_VERTEX_ATTRIB_ARB

GLScene.OpenGL4

GL_CURRENT_VERTEX_EXT

GLScene.OpenGL4

GL_CURRENT_VERTEX_WEIGHT_EXT

GLScene.OpenGL4

GL_CURRENT_WEIGHT_ARB

GLScene.OpenGL4

GL_CW

GLScene.OpenGL4

FrontFaceDirection

GL_DARKEN_KHR

GLScene.OpenGL4

GL_DATA_BUFFER_AMD

GLScene.OpenGL4

GL_AMD_name_gen_delete

GL_DEBUG_CALLBACK_FUNCTION

GLScene.OpenGL4

GL_DEBUG_CALLBACK_FUNCTION_ARB

GLScene.OpenGL4

GL_DEBUG_CALLBACK_USER_PARAM

GLScene.OpenGL4

GL_DEBUG_CALLBACK_USER_PARAM_ARB

GLScene.OpenGL4

GL_DEBUG_CATEGORY_API_ERROR_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_APPLICATION_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_DEPRECATION_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_OTHER_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_PERFORMANCE_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_SHADER_COMPILER_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_UNDEFINED_BEHAVIOR_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_WINDOW_SYSTEM_AMD

GLScene.OpenGL4

GL_DEBUG_GROUP_STACK_DEPTH

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES_AMD

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES_ARB

GLScene.OpenGL4

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH

GLScene.OpenGL4

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB

GLScene.OpenGL4

GL_DEBUG_OUTPUT

GLScene.OpenGL4

GL_DEBUG_OUTPUT_SYNCHRONOUS

GLScene.OpenGL4

(4.3) GL_KHR_debug

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB

GLScene.OpenGL4

GL_ARB_debug_output

GL_DEBUG_SEVERITY_HIGH

GLScene.OpenGL4

GL_DEBUG_SEVERITY_HIGH_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_HIGH_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_NOTIFICATION

GLScene.OpenGL4

GL_DEBUG_SOURCE_API

GLScene.OpenGL4

GL_DEBUG_SOURCE_API_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_APPLICATION

GLScene.OpenGL4

GL_DEBUG_SOURCE_APPLICATION_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_OTHER

GLScene.OpenGL4

GL_DEBUG_SOURCE_OTHER_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_SHADER_COMPILER

GLScene.OpenGL4

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_THIRD_PARTY

GLScene.OpenGL4

GL_DEBUG_SOURCE_THIRD_PARTY_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_WINDOW_SYSTEM

GLScene.OpenGL4

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR

GLScene.OpenGL4

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_ERROR

GLScene.OpenGL4

GL_DEBUG_TYPE_ERROR_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_MARKER

GLScene.OpenGL4

GL_DEBUG_TYPE_OTHER

GLScene.OpenGL4

GL_DEBUG_TYPE_OTHER_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_PERFORMANCE

GLScene.OpenGL4

GL_DEBUG_TYPE_PERFORMANCE_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_POP_GROUP

GLScene.OpenGL4

GL_DEBUG_TYPE_PORTABILITY

GLScene.OpenGL4

GL_DEBUG_TYPE_PORTABILITY_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_PUSH_GROUP

GLScene.OpenGL4

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR

GLScene.OpenGL4

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB

GLScene.OpenGL4

GL_DECAL

GLScene.OpenGL4

GL_DECODE_EXT

GLScene.OpenGL4

GL_DECR

GLScene.OpenGL4

GL_DECR_WRAP

GLScene.OpenGL4

GL_DECR_WRAP_EXT

GLScene.OpenGL4

GL_DEFORMATIONS_MASK_SGIX

GLScene.OpenGL4

GL_DELETE_STATUS

GLScene.OpenGL4

GL_DEPENDENT_AR_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_GB_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_HILO_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_RGB_TEXTURE_3D_NV

GLScene.OpenGL4

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DEPTH

GLScene.OpenGL4

GL_DEPTH24_STENCIL8

GLScene.OpenGL4

GL_DEPTH24_STENCIL8_EXT

GLScene.OpenGL4

GL_DEPTH32F_STENCIL8

GLScene.OpenGL4

GL_DEPTH_ATTACHMENT

GLScene.OpenGL4

GL_DEPTH_ATTACHMENT_EXT

GLScene.OpenGL4

GL_DEPTH_BIAS

GLScene.OpenGL4

GL_DEPTH_BITS

GLScene.OpenGL4

GL_DEPTH_BOUNDS_EXT

GLScene.OpenGL4

GL_DEPTH_BOUNDS_TEST_EXT

GLScene.OpenGL4

GL_EXT_depth_bounds_test

GL_DEPTH_BUFFER

GLScene.OpenGL4

GL_DEPTH_BUFFER_BIT

GLScene.OpenGL4

AttribMask

GL_DEPTH_BUFFER_FLOAT_MODE_NV

GLScene.OpenGL4

GL_DEPTH_CLAMP

GLScene.OpenGL4

GL_ARB_depth_clamp

GL_DEPTH_CLAMP_FAR_AMD

GLScene.OpenGL4

GL_DEPTH_CLAMP_NEAR_AMD

GLScene.OpenGL4

GL_AMD_depth_clamp_separate

GL_DEPTH_CLAMP_NV

GLScene.OpenGL4

GL_NV_depth_clamp

GL_DEPTH_CLEAR_VALUE

GLScene.OpenGL4

GL_DEPTH_COMPONENT

GLScene.OpenGL4

GL_DEPTH_COMPONENT16

GLScene.OpenGL4

GL_DEPTH_COMPONENT16_ARB

GLScene.OpenGL4

GL_ARB_depth_texture

GL_DEPTH_COMPONENT16_SGIX

GLScene.OpenGL4

GL_SGIX_depth_texture

GL_DEPTH_COMPONENT24

GLScene.OpenGL4

GL_DEPTH_COMPONENT24_ARB

GLScene.OpenGL4

GL_DEPTH_COMPONENT24_SGIX

GLScene.OpenGL4

GL_DEPTH_COMPONENT32

GLScene.OpenGL4

GL_DEPTH_COMPONENT32F

GLScene.OpenGL4

GL_ARB_depth_buffer_float

GL_DEPTH_COMPONENT32_ARB

GLScene.OpenGL4

GL_DEPTH_COMPONENT32_SGIX

GLScene.OpenGL4

GL_DEPTH_COMPONENTS

GLScene.OpenGL4

GL_DEPTH_FUNC

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_COUNTERS_SGIX

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_MAX_SGIX

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_SGIX

GLScene.OpenGL4

GL_SGI_depth_pass_instrument

GL_DEPTH_RANGE

GLScene.OpenGL4

GL_DEPTH_RENDERABLE

GLScene.OpenGL4

GL_DEPTH_SCALE

GLScene.OpenGL4

GL_DEPTH_STENCIL

GLScene.OpenGL4

GL_DEPTH_STENCIL_ATTACHMENT

GLScene.OpenGL4

GL_DEPTH_STENCIL_EXT

GLScene.OpenGL4

GL_EXT_packed_depth_stencil

GL_DEPTH_STENCIL_NV

GLScene.OpenGL4

GL_NV_packed_depth_stencil

GL_DEPTH_STENCIL_TEXTURE_MODE

GLScene.OpenGL4

GL_DEPTH_STENCIL_TO_BGRA_NV

GLScene.OpenGL4

GL_DEPTH_STENCIL_TO_RGBA_NV

GLScene.OpenGL4

GL_NV_copy_depth_to_color

GL_DEPTH_TEST

GLScene.OpenGL4

GL_DEPTH_TEXTURE_MODE

GLScene.OpenGL4

GL_DEPTH_TEXTURE_MODE_ARB

GLScene.OpenGL4

GL_DEPTH_WRITEMASK

GLScene.OpenGL4

GL_DETAIL_TEXTURE_2D_BINDING_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_2D_SGIS

GLScene.OpenGL4

GL_SGIS_detail_texture

GL_DETAIL_TEXTURE_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_LEVEL_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_MODE_SGIS

GLScene.OpenGL4

GL_DIFFERENCE_KHR

GLScene.OpenGL4

GL_DIFFUSE

GLScene.OpenGL4

GL_DISCARD_ATI

GLScene.OpenGL4

GL_DISCARD_NV

GLScene.OpenGL4

GL_DISCRETE_AMD

GLScene.OpenGL4

GL_DISPATCH_INDIRECT_BUFFER

GLScene.OpenGL4

GL_DISPATCH_INDIRECT_BUFFER_BINDING

GLScene.OpenGL4

GL_DISPLAY_LIST

GLScene.OpenGL4

GL_DISTANCE_ATTENUATION_EXT

GLScene.OpenGL4

GL_DISTANCE_ATTENUATION_SGIS

GLScene.OpenGL4

GL_DITHER

GLScene.OpenGL4

GL_DOMAIN

GLScene.OpenGL4

GL_DONT_CARE

GLScene.OpenGL4

HintMode

GL_DOT2_ADD_ATI

GLScene.OpenGL4

GL_DOT3_ATI

GLScene.OpenGL4

GL_DOT3_RGB

GLScene.OpenGL4

GL_DOT3_RGBA

GLScene.OpenGL4

GL_DOT3_RGBA_ARB

GLScene.OpenGL4

GL_DOT3_RGBA_EXT

GLScene.OpenGL4

GL_DOT3_RGB_ARB

GLScene.OpenGL4

GL_ARB_texture_env_dot3

GL_DOT3_RGB_EXT

GLScene.OpenGL4

GL_EXT_texture_env_dot3

GL_DOT4_ATI

GLScene.OpenGL4

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_DEPTH_REPLACE_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_PASS_THROUGH_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_1D_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_3D_NV

GLScene.OpenGL4

GL_NV_texture_shader2

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_DOUBLE

GLScene.OpenGL4

GL_DOUBLEBUFFER

GLScene.OpenGL4

GL_DOUBLE_MAT2

GLScene.OpenGL4

GL_DOUBLE_MAT2x3

GLScene.OpenGL4

GL_DOUBLE_MAT2x3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT2x4

GLScene.OpenGL4

GL_DOUBLE_MAT2x4_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3

GLScene.OpenGL4

GL_DOUBLE_MAT3x2

GLScene.OpenGL4

GL_DOUBLE_MAT3x2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3x4

GLScene.OpenGL4

GL_DOUBLE_MAT3x4_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4

GLScene.OpenGL4

GL_DOUBLE_MAT4x2

GLScene.OpenGL4

GL_DOUBLE_MAT4x2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4x3

GLScene.OpenGL4

GL_DOUBLE_MAT4x3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4_EXT

GLScene.OpenGL4

GL_DOUBLE_VEC2

GLScene.OpenGL4

GL_ARB_gpu_shader_fp64

GL_DOUBLE_VEC2_EXT

GLScene.OpenGL4

reuse GL_DOUBLE

GL_DOUBLE_VEC3

GLScene.OpenGL4

GL_DOUBLE_VEC3_EXT

GLScene.OpenGL4

GL_DOUBLE_VEC4

GLScene.OpenGL4

GL_DOUBLE_VEC4_EXT

GLScene.OpenGL4

GL_DRAW_BUFFER

GLScene.OpenGL4

GL_DRAW_BUFFER0

GLScene.OpenGL4

GL_DRAW_BUFFER0_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER0_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER1

GLScene.OpenGL4

GL_DRAW_BUFFER10

GLScene.OpenGL4

GL_DRAW_BUFFER10_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER10_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER11

GLScene.OpenGL4

GL_DRAW_BUFFER11_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER11_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER12

GLScene.OpenGL4

GL_DRAW_BUFFER12_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER12_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER13

GLScene.OpenGL4

GL_DRAW_BUFFER13_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER13_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER14

GLScene.OpenGL4

GL_DRAW_BUFFER14_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER14_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER15

GLScene.OpenGL4

GL_DRAW_BUFFER15_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER15_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER1_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER1_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER2

GLScene.OpenGL4

GL_DRAW_BUFFER2_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER2_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER3

GLScene.OpenGL4

GL_DRAW_BUFFER3_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER3_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER4

GLScene.OpenGL4

GL_DRAW_BUFFER4_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER4_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER5

GLScene.OpenGL4

GL_DRAW_BUFFER5_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER5_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER6

GLScene.OpenGL4

GL_DRAW_BUFFER6_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER6_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER7

GLScene.OpenGL4

GL_DRAW_BUFFER7_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER7_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER8

GLScene.OpenGL4

GL_DRAW_BUFFER8_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER8_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER9

GLScene.OpenGL4

GL_DRAW_BUFFER9_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER9_ATI

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_DRAW_INDIRECT_ADDRESS_NV

GLScene.OpenGL4

GL_DRAW_INDIRECT_BUFFER

GLScene.OpenGL4

GL_ARB_draw_indirect

GL_DRAW_INDIRECT_BUFFER_BINDING

GLScene.OpenGL4

GL_DRAW_INDIRECT_LENGTH_NV

GLScene.OpenGL4

GL_DRAW_INDIRECT_UNIFIED_NV

GLScene.OpenGL4

GL_DRAW_PIXELS_APPLE

GLScene.OpenGL4

GL_APPLE_fence

GL_DRAW_PIXEL_TOKEN

GLScene.OpenGL4

GL_DSDT8_MAG8_INTENSITY8_NV

GLScene.OpenGL4

GL_DSDT8_MAG8_NV

GLScene.OpenGL4

GL_DSDT8_NV

GLScene.OpenGL4

GL_DSDT_MAG_INTENSITY_NV

GLScene.OpenGL4

GL_DSDT_MAG_NV

GLScene.OpenGL4

GL_DSDT_MAG_VIB_NV

GLScene.OpenGL4

GL_DSDT_NV

GLScene.OpenGL4

GL_DST_ALPHA

GLScene.OpenGL4

GL_DST_COLOR

GLScene.OpenGL4

BlendingFactorSrc

GL_DS_BIAS_NV

GLScene.OpenGL4

GL_DS_SCALE_NV

GLScene.OpenGL4

GL_DT_BIAS_NV

GLScene.OpenGL4

GL_DT_SCALE_NV

GLScene.OpenGL4

GL_DU8DV8_ATI

GLScene.OpenGL4

GL_DUAL_ALPHA12_SGIS

GLScene.OpenGL4

GL_DUAL_ALPHA16_SGIS

GLScene.OpenGL4

GL_DUAL_ALPHA4_SGIS

GLScene.OpenGL4

GL_SGIS_texture_select

GL_DUAL_ALPHA8_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY12_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY16_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY4_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY8_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE12_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE16_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE4_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE8_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE_ALPHA4_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE_ALPHA8_SGIS

GLScene.OpenGL4

GL_DUAL_TEXTURE_SELECT_SGIS

GLScene.OpenGL4

GL_DUDV_ATI

GLScene.OpenGL4

GL_DUP_FIRST_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_DUP_LAST_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_DYNAMIC_ATI

GLScene.OpenGL4

GL_DYNAMIC_COPY

GLScene.OpenGL4

GL_DYNAMIC_COPY_ARB

GLScene.OpenGL4

GL_DYNAMIC_DRAW

GLScene.OpenGL4

GL_DYNAMIC_DRAW_ARB

GLScene.OpenGL4

GL_DYNAMIC_READ

GLScene.OpenGL4

GL_DYNAMIC_READ_ARB

GLScene.OpenGL4

GL_DYNAMIC_STORAGE_BIT

GLScene.OpenGL4

GL_EDGEFLAG_BIT_PGI

GLScene.OpenGL4

GL_EDGE_FLAG

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_POINTER

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_STRIDE

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_EIGHTH_BIT_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_ELEMENT_ARRAY_APPLE

GLScene.OpenGL4

GL_APPLE_element_array

GL_ELEMENT_ARRAY_ATI

GLScene.OpenGL4

GL_ATI_element_array

GL_ELEMENT_ARRAY_BARRIER_BIT

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_ARB

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_ELEMENT_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_ELEMENT_ARRAY_POINTER_APPLE

GLScene.OpenGL4

GL_ELEMENT_ARRAY_POINTER_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_TYPE_APPLE

GLScene.OpenGL4

GL_ELEMENT_ARRAY_TYPE_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_UNIFIED_NV

GLScene.OpenGL4

GL_EMBOSS_CONSTANT_NV

GLScene.OpenGL4

GL_EMBOSS_LIGHT_NV

GLScene.OpenGL4

GL_NV_texgen_emboss

GL_EMBOSS_MAP_NV

GLScene.OpenGL4

GL_EMISSION

GLScene.OpenGL4

GL_ENABLE_BIT

GLScene.OpenGL4

GL_EQUAL

GLScene.OpenGL4

GL_EQUIV

GLScene.OpenGL4

GL_EVAL_2D_NV

GLScene.OpenGL4

GL_NV_evaluators

GL_EVAL_BIT

GLScene.OpenGL4

GL_EVAL_FRACTIONAL_TESSELLATION_NV

GLScene.OpenGL4

GL_EVAL_TRIANGULAR_2D_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB0_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB10_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB11_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB12_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB13_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB14_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB15_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB1_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB2_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB3_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB4_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB5_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB6_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB7_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB8_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB9_NV

GLScene.OpenGL4

GL_EXCLUSION_KHR

GLScene.OpenGL4

GL_EXP

GLScene.OpenGL4

GL_EXP2

GLScene.OpenGL4

GL_EXPAND_NEGATE_NV

GLScene.OpenGL4

GL_EXPAND_NORMAL_NV

GLScene.OpenGL4

GL_EXTENSIONS

GLScene.OpenGL4

GL_EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD

GLScene.OpenGL4

(4.3) GL_AMD_pinned_memory

GL_EXT_422_pixels

GLScene.OpenGL4

GL 4.6

GL_EXT_abgr

GLScene.OpenGL4

GL 4.6

GL_EXT_bgra

GLScene.OpenGL4

GL 4.6

GL_EXT_bindable_uniform

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_color

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_equation_separate

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_func_separate

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_logic_op

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_minmax

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_subtract

GLScene.OpenGL4

GL 4.6

GL_EXT_clip_volume_hint

GLScene.OpenGL4

GL 4.6

GL_EXT_cmyka

GLScene.OpenGL4

GL 4.6

GL_EXT_color_matrix

GLScene.OpenGL4

GL 4.6

GL_EXT_color_subtable

GLScene.OpenGL4

GL 4.6

GL_EXT_compiled_vertex_array

GLScene.OpenGL4

GL 4.6

GL_EXT_convolution

GLScene.OpenGL4

GL 4.6

GL_EXT_coordinate_frame

GLScene.OpenGL4

GL 4.6

GL_EXT_copy_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_cull_vertex

GLScene.OpenGL4

GL 4.6

GL_EXT_depth_bounds_test

GLScene.OpenGL4

GL 4.6

GL_EXT_direct_state_access

GLScene.OpenGL4

GL 4.6

GL_EXT_draw_buffers2

GLScene.OpenGL4

GL 4.6

GL_EXT_draw_instanced

GLScene.OpenGL4

GL 4.6

GL_EXT_draw_range_elements

GLScene.OpenGL4

GL 4.6

GL_EXT_fog_coord

GLScene.OpenGL4

GL 4.6

GL_EXT_framebuffer_blit

GLScene.OpenGL4

GL 4.6

GL_EXT_framebuffer_multisample

GLScene.OpenGL4

GL 4.6

GL_EXT_framebuffer_object

GLScene.OpenGL4

GL 4.6

GL_EXT_framebuffer_sRGB

GLScene.OpenGL4

GL 4.6

GL_EXT_geometry_shader4

GLScene.OpenGL4

GL 4.6

GL_EXT_gpu_program_parameters

GLScene.OpenGL4

GL 4.6

GL_EXT_gpu_shader4

GLScene.OpenGL4

GL 4.6

GL_EXT_histogram

GLScene.OpenGL4

GL 4.6

GL_EXT_index_array_formats

GLScene.OpenGL4

GL 4.6

GL_EXT_index_func

GLScene.OpenGL4

GL 4.6

GL_EXT_index_material

GLScene.OpenGL4

GL 4.6

GL_EXT_index_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_light_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_misc_attribute

GLScene.OpenGL4

GL 4.6

GL_EXT_multisample

GLScene.OpenGL4

GL 4.6

GL_EXT_multi_draw_arrays

GLScene.OpenGL4

GL 4.6

GL_EXT_packed_depth_stencil

GLScene.OpenGL4

GL 4.6

GL_EXT_packed_float

GLScene.OpenGL4

GL 4.6

GL_EXT_packed_pixels

GLScene.OpenGL4

GL 4.6

GL_EXT_paletted_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_pixel_buffer_object

GLScene.OpenGL4

GL 4.6

GL_EXT_pixel_transform

GLScene.OpenGL4

GL 4.6

GL_EXT_pixel_transform_color_table

GLScene.OpenGL4

GL 4.6

GL_EXT_point_parameters

GLScene.OpenGL4

GL 4.6

GL_EXT_polygon_offset

GLScene.OpenGL4

GL 4.6

GL_EXT_provoking_vertex

GLScene.OpenGL4

GL 4.6

GL_EXT_rescale_normal

GLScene.OpenGL4

GL 4.6

GL_EXT_secondary_color

GLScene.OpenGL4

GL 4.6

GL_EXT_separate_shader_objects

GLScene.OpenGL4

GL 4.6

GL_EXT_separate_specular_color

GLScene.OpenGL4

GL 4.6

GL_EXT_shader_image_load_store

GLScene.OpenGL4

GL 4.6

GL_EXT_shadow_funcs

GLScene.OpenGL4

GL 4.6

GL_EXT_shared_texture_palette

GLScene.OpenGL4

GL 4.6

GL_EXT_stencil_clear_tag

GLScene.OpenGL4

GL 4.6

GL_EXT_stencil_two_side

GLScene.OpenGL4

GL 4.6

GL_EXT_stencil_wrap

GLScene.OpenGL4

GL 4.6

GL_EXT_subtexture

GLScene.OpenGL4

GL 4.6

GL_EXT_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_texture3D

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_array

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_buffer_object

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_compression_dxt1

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_compression_latc

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_compression_rgtc

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_compression_s3tc

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_cube_map

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_edge_clamp

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_env_add

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_env_combine

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_env_dot3

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_filter_anisotropic

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_integer

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_lod_bias

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_mirror_clamp

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_object

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_perturb_normal

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_rectangle

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_shared_exponent

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_snorm

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_sRGB

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_sRGB_decode

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_swizzle

GLScene.OpenGL4

GL 4.6

GL_EXT_timer_query

GLScene.OpenGL4

GL 4.6

GL_EXT_transform_feedback

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_array

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_array_bgra

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_attrib_64bit

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_shader

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_weighting

GLScene.OpenGL4

GL 4.6

GL_EYE_DISTANCE_TO_LINE_SGIS

GLScene.OpenGL4

GL_EYE_DISTANCE_TO_POINT_SGIS

GLScene.OpenGL4

GL_SGIS_point_line_texgen

GL_EYE_LINEAR

GLScene.OpenGL4

GL_EYE_LINE_SGIS

GLScene.OpenGL4

GL_EYE_PLANE

GLScene.OpenGL4

GL_EYE_PLANE_ABSOLUTE_NV

GLScene.OpenGL4

GL_EYE_POINT_SGIS

GLScene.OpenGL4

GL_EYE_RADIAL_NV

GLScene.OpenGL4

GL_E_TIMES_F_NV

GLScene.OpenGL4

GL_FACTOR_MAX_AMD

GLScene.OpenGL4

GL_FACTOR_MIN_AMD

GLScene.OpenGL4

GL_AMD_blend_minmax_factor

GL_FAILURE_NV

GLScene.OpenGL4

GL_FALSE

GLScene.OpenGL4

GL_FASTEST

GLScene.OpenGL4

GL_FEEDBACK

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_POINTER

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_SIZE

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_TYPE

GLScene.OpenGL4

GL_FENCE_APPLE

GLScene.OpenGL4

GL_FENCE_CONDITION_NV

GLScene.OpenGL4

GL_FENCE_STATUS_NV

GLScene.OpenGL4

GL_FfdMaskSGIX

GLScene.OpenGL4

GL 4.6

GL_FIELDS_NV

GLScene.OpenGL4

GL_FIELD_LOWER_NV

GLScene.OpenGL4

GL_FIELD_UPPER_NV

GLScene.OpenGL4

GL_FILE_NAME_NV

GLScene.OpenGL4

GL_FILL

GLScene.OpenGL4

GL_FILTER

GLScene.OpenGL4

GL_FILTER4_SGIS

GLScene.OpenGL4

GL_SGIS_texture_filter4

GL_FIRST_TO_REST_NV

GLScene.OpenGL4

GL_FIRST_VERTEX_CONVENTION

GLScene.OpenGL4

GL_FIRST_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_FIXED

GLScene.OpenGL4

GL_ARB_ES2_compatibility

GL_FIXED_ONLY

GLScene.OpenGL4

GL_FIXED_ONLY_ARB

GLScene.OpenGL4

GL_FLAT

GLScene.OpenGL4

GL_FLOAT

GLScene.OpenGL4

GL_FLOAT16_NV

GLScene.OpenGL4

GL_FLOAT16_VEC2_NV

GLScene.OpenGL4

GL_FLOAT16_VEC3_NV

GLScene.OpenGL4

GL_FLOAT16_VEC4_NV

GLScene.OpenGL4

GL_FLOAT_32_UNSIGNED_INT_24_8_REV

GLScene.OpenGL4

GL_FLOAT_32_UNSIGNED_INT_24_8_REV_NV

GLScene.OpenGL4

GL_NV_depth_buffer_float

GL_FLOAT_CLEAR_COLOR_VALUE_NV

GLScene.OpenGL4

GL_FLOAT_MAT2

GLScene.OpenGL4

GL_FLOAT_MAT2x3

GLScene.OpenGL4

GL_FLOAT_MAT2x4

GLScene.OpenGL4

GL_FLOAT_MAT2_ARB

GLScene.OpenGL4

GL_FLOAT_MAT3

GLScene.OpenGL4

GL_FLOAT_MAT3x2

GLScene.OpenGL4

GL_FLOAT_MAT3x4

GLScene.OpenGL4

GL_FLOAT_MAT3_ARB

GLScene.OpenGL4

GL_FLOAT_MAT4

GLScene.OpenGL4

GL_FLOAT_MAT4x2

GLScene.OpenGL4

GL_FLOAT_MAT4x3

GLScene.OpenGL4

GL_FLOAT_MAT4_ARB

GLScene.OpenGL4

GL_FLOAT_R16_NV

GLScene.OpenGL4

GL_FLOAT_R32_NV

GLScene.OpenGL4

GL_FLOAT_RG16_NV

GLScene.OpenGL4

GL_FLOAT_RG32_NV

GLScene.OpenGL4

GL_FLOAT_RGB16_NV

GLScene.OpenGL4

GL_FLOAT_RGB32_NV

GLScene.OpenGL4

GL_FLOAT_RGBA16_NV

GLScene.OpenGL4

GL_FLOAT_RGBA32_NV

GLScene.OpenGL4

GL_FLOAT_RGBA_MODE_NV

GLScene.OpenGL4

GL_FLOAT_RGBA_NV

GLScene.OpenGL4

GL_FLOAT_RGB_NV

GLScene.OpenGL4

GL_FLOAT_RG_NV

GLScene.OpenGL4

GL_FLOAT_R_NV

GLScene.OpenGL4

GL_NV_float_buffer

GL_FLOAT_VEC2

GLScene.OpenGL4

GL_FLOAT_VEC2_ARB

GLScene.OpenGL4

GL_FLOAT_VEC3

GLScene.OpenGL4

GL_FLOAT_VEC3_ARB

GLScene.OpenGL4

GL_FLOAT_VEC4

GLScene.OpenGL4

GL_FLOAT_VEC4_ARB

GLScene.OpenGL4

GL_FOG

GLScene.OpenGL4

GL_FOG_BIT

GLScene.OpenGL4

GL_FOG_COLOR

GLScene.OpenGL4

GL_FOG_COORD

GLScene.OpenGL4

GL_FOG_COORDINATE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_POINTER

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_STRIDE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_TYPE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_SOURCE

GLScene.OpenGL4

GL_FOG_COORDINATE_SOURCE_EXT

GLScene.OpenGL4

GL_EXT_fog_coord

GL_FOG_COORD_ARRAY

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_POINTER

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_STRIDE

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_TYPE

GLScene.OpenGL4

GL_FOG_COORD_SRC

GLScene.OpenGL4

GL_FOG_DENSITY

GLScene.OpenGL4

GL_FOG_DISTANCE_MODE_NV

GLScene.OpenGL4

GL_NV_fog_distance

GL_FOG_END

GLScene.OpenGL4

GL_FOG_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_FOG_FUNC_SGIS

GLScene.OpenGL4

GL_SGIS_fog_function

GL_FOG_HINT

GLScene.OpenGL4

GL_FOG_INDEX

GLScene.OpenGL4

GL_FOG_MODE

GLScene.OpenGL4

GL_FOG_OFFSET_SGIX

GLScene.OpenGL4

GL_SGIX_fog_offset

GL_FOG_OFFSET_VALUE_SGIX

GLScene.OpenGL4

GL_FOG_SCALE_SGIX

GLScene.OpenGL4

GL_SGIX_fog_scale

GL_FOG_SCALE_VALUE_SGIX

GLScene.OpenGL4

GL_FOG_SPECULAR_TEXTURE_WIN

GLScene.OpenGL4

GL_WIN_specular_fog

GL_FOG_START

GLScene.OpenGL4

GL_FONT_ASCENDER_NV

GLScene.OpenGL4

GL_FONT_DESCENDER_NV

GLScene.OpenGL4

GL_FONT_HAS_KERNING_NV

GLScene.OpenGL4

GL_FONT_HEIGHT_NV

GLScene.OpenGL4

GL_FONT_MAX_ADVANCE_HEIGHT_NV

GLScene.OpenGL4

GL_FONT_MAX_ADVANCE_WIDTH_NV

GLScene.OpenGL4

GL_FONT_UNDERLINE_POSITION_NV

GLScene.OpenGL4

GL_FONT_UNDERLINE_THICKNESS_NV

GLScene.OpenGL4

GL_FONT_UNITS_PER_EM_NV

GLScene.OpenGL4

GL_FONT_X_MAX_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_X_MIN_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_Y_MAX_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_Y_MIN_BOUNDS_NV

GLScene.OpenGL4

GL_FORCE_BLUE_TO_ONE_NV

GLScene.OpenGL4

GL_FORMAT_SUBSAMPLE_244_244_OML

GLScene.OpenGL4

GL_FORMAT_SUBSAMPLE_24_24_OML

GLScene.OpenGL4

GL_OML_subsample

GL_FRACTIONAL_EVEN

GLScene.OpenGL4

GL_FRACTIONAL_ODD

GLScene.OpenGL4

GL_FRAGMENT_COLOR_EXT

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_FACE_SGIX

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_PARAMETER_SGIX

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_SGIX

GLScene.OpenGL4

GL_FRAGMENT_DEPTH

GLScene.OpenGL4

GL_FRAGMENT_DEPTH_EXT

GLScene.OpenGL4

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS

GLScene.OpenGL4

GL_FRAGMENT_LIGHT0_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT1_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT2_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT3_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT4_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT5_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT6_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT7_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHTING_SGIX

GLScene.OpenGL4

GL_SGIX_fragment_lighting

GL_FRAGMENT_LIGHT_MODEL_AMBIENT_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_LOCAL_VIEWER_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_NORMAL_INTERPOLATION_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_TWO_SIDE_SGIX

GLScene.OpenGL4

GL_FRAGMENT_MATERIAL_EXT

GLScene.OpenGL4

GL_EXT_light_texture

GL_FRAGMENT_NORMAL_EXT

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_ARB

GLScene.OpenGL4

GL_ARB_fragment_program

GL_FRAGMENT_PROGRAM_BINDING_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_INTERPOLATION_OFFSET_BITS_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_FRAGMENT_SHADER

GLScene.OpenGL4

GL_FRAGMENT_SHADER_ARB

GLScene.OpenGL4

GL_ARB_fragment_shader

GL_FRAGMENT_SHADER_ATI

GLScene.OpenGL4

GL_ATI_fragment_shader

GL_FRAGMENT_SHADER_BIT

GLScene.OpenGL4

GL_FRAGMENT_SHADER_DERIVATIVE_HINT

GLScene.OpenGL4

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB

GLScene.OpenGL4

1.4

GL_FRAGMENT_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_FRAGMENT_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_FRAGMENT_SUBROUTINE

GLScene.OpenGL4

GL_FRAGMENT_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_FRAGMENT_TEXTURE

GLScene.OpenGL4

GL_FRAMEBUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_BASE_VIEW_INDEX_OVR

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_NUM_VIEWS_OVR

GLScene.OpenGL4

GL_OVR_multiview

GL_FRAMEBUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_FRAMEBUFFER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_BLEND

GLScene.OpenGL4

GL_FRAMEBUFFER_COMPLETE

GLScene.OpenGL4

GL_FRAMEBUFFER_COMPLETE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_FIXED_SAMPLE_LOCATIONS

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_HEIGHT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_LAYERS

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_SAMPLES

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_WIDTH

GLScene.OpenGL4

GL_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_object

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT

GLScene.OpenGLTokens

Vendor/EXT extensions constants, in extension number order

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_VIEW_TARGETS_OVR

GLScene.OpenGL4

GL_FRAMEBUFFER_PROGRAMMABLE_SAMPLE_LOCATIONS_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_RENDERABLE

GLScene.OpenGL4

GL_FRAMEBUFFER_RENDERABLE_LAYERED

GLScene.OpenGL4

GL_FRAMEBUFFER_SAMPLE_LOCATION_PIXEL_GRID_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_SRGB

GLScene.OpenGL4

GL_ARB_framebuffer_sRGB

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_SRGB_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_STATUS_ERROR_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_UNDEFINED

GLScene.OpenGL4

GL_FRAMEBUFFER_UNSUPPORTED

GLScene.OpenGL4

GL_FRAMEBUFFER_UNSUPPORTED_EXT

GLScene.OpenGL4

GL_FRAMEZOOM_FACTOR_SGIX

GLScene.OpenGL4

GL_FRAMEZOOM_SGIX

GLScene.OpenGL4

GL_SGIX_framezoom

GL_FRAME_NV

GLScene.OpenGL4

GL_NV_present_video

GL_FRONT

GLScene.OpenGL4

GL_FRONT_AND_BACK

GLScene.OpenGL4

GL_FRONT_FACE

GLScene.OpenGL4

GL_FRONT_LEFT

GLScene.OpenGL4

GL_FRONT_RIGHT

GLScene.OpenGL4

GL_FULL_RANGE_EXT

GLScene.OpenGL4

GL_FULL_STIPPLE_HINT_PGI

GLScene.OpenGL4

GL_FULL_SUPPORT

GLScene.OpenGL4

GL_FUNC_ADD

GLScene.OpenGL4

GL_FUNC_ADD_EXT

GLScene.OpenGL4

GL_EXT_blend_minmax

GL_FUNC_REVERSE_SUBTRACT

GLScene.OpenGL4

GL_FUNC_REVERSE_SUBTRACT_EXT

GLScene.OpenGL4

GL_FUNC_SUBTRACT

GLScene.OpenGL4

GL_FUNC_SUBTRACT_EXT

GLScene.OpenGL4

GL_EXT_blend_subtract

GL_GENERATE_MIPMAP

GLScene.OpenGL4

GL_GENERATE_MIPMAP_HINT

GLScene.OpenGL4

GL_GENERATE_MIPMAP_HINT_SGIS

GLScene.OpenGL4

GL_GENERATE_MIPMAP_SGIS

GLScene.OpenGL4

GL_SGIS_generate_mipmap

GL_GENERIC_ATTRIB_NV

GLScene.OpenGL4

GL_GEOMETRY_DEFORMATION_BIT_SGIX

GLScene.OpenGL4

GL_GEOMETRY_DEFORMATION_SGIX

GLScene.OpenGL4

GL_SGIX_polynomial_ffd

GL_GEOMETRY_INPUT_TYPE

GLScene.OpenGL4

GL_GEOMETRY_INPUT_TYPE_ARB

GLScene.OpenGL4

GL_GEOMETRY_INPUT_TYPE_EXT

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE_ARB

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE_EXT

GLScene.OpenGL4

GL_GEOMETRY_PROGRAM_NV

GLScene.OpenGL4

GL_NV_geometry_program4

GL_GEOMETRY_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_GEOMETRY_SHADER

GLScene.OpenGL4

GL_GEOMETRY_SHADER_ARB

GLScene.OpenGL4

GL_GEOMETRY_SHADER_BIT

GLScene.OpenGL4

GL_GEOMETRY_SHADER_EXT

GLScene.OpenGL4

GL_EXT_geometry_shader4

GL_GEOMETRY_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_ARB_gpu_shader5

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED

GLScene.OpenGL4

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED_ARB

GLScene.OpenGL4

GL_GEOMETRY_SUBROUTINE

GLScene.OpenGL4

GL_GEOMETRY_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_GEOMETRY_TEXTURE

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT_ARB

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT_EXT

GLScene.OpenGL4

GL_GEQUAL

GLScene.OpenGL4

GL_GET_TEXTURE_IMAGE_FORMAT

GLScene.OpenGL4

GL_GET_TEXTURE_IMAGE_TYPE

GLScene.OpenGL4

GL_GLOBAL_ALPHA_FACTOR_SUN

GLScene.OpenGL4

GL_GLOBAL_ALPHA_SUN

GLScene.OpenGL4

GL_SUN_global_alpha

GL_GLYPH_HAS_KERNING_NV

GLScene.OpenGL4

GL_GLYPH_HEIGHT_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV

GLScene.OpenGL4

GL_GLYPH_WIDTH_BIT_NV

GLScene.OpenGL4

GL_GPU_ADDRESS_NV

GLScene.OpenGL4

GL_GREATER

GLScene.OpenGL4

GL_GREEN

GLScene.OpenGL4

GL_GREEN_BIAS

GLScene.OpenGL4

GL_GREEN_BITS

GLScene.OpenGL4

GL_GREEN_BIT_ATI

GLScene.OpenGL4

GL_GREEN_INTEGER

GLScene.OpenGL4

GL_GREEN_INTEGER_EXT

GLScene.OpenGL4

GL_GREEN_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_GREEN_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_GREEN_SCALE

GLScene.OpenGL4

GL_GUILTY_CONTEXT_RESET

GLScene.OpenGL4

GL_GUILTY_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_HALF_APPLE

GLScene.OpenGL4

GL_APPLE_float_pixels

GL_HALF_BIAS_NEGATE_NV

GLScene.OpenGL4

GL_HALF_BIAS_NORMAL_NV

GLScene.OpenGL4

GL_HALF_BIT_ATI

GLScene.OpenGL4

GL_HALF_FLOAT

GLScene.OpenGL4

GL_ARB_half_float_vertex

GL_HALF_FLOAT_ARB

GLScene.OpenGL4

GL_ARB_half_float_pixel

GL_HALF_FLOAT_NV

GLScene.OpenGL4

GL_NV_half_float

GL_HARDLIGHT_KHR

GLScene.OpenGL4

GL_HIGH_FLOAT

GLScene.OpenGL4

GL_HIGH_INT

GLScene.OpenGL4

GL_HILO16_NV

GLScene.OpenGL4

GL_HILO8_NV

GLScene.OpenGL4

GL_HILO_NV

GLScene.OpenGL4

GL_HINT_BIT

GLScene.OpenGL4

GL_HISTOGRAM

GLScene.OpenGL4

GL_HISTOGRAM_ALPHA_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_BLUE_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_EXT

GLScene.OpenGL4

GL_EXT_histogram

GL_HISTOGRAM_FORMAT

GLScene.OpenGL4

GL_HISTOGRAM_FORMAT_EXT

GLScene.OpenGL4

GL_HISTOGRAM_GREEN_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_LUMINANCE_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_RED_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_RED_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_SINK

GLScene.OpenGL4

GL_HISTOGRAM_SINK_EXT

GLScene.OpenGL4

GL_HISTOGRAM_WIDTH

GLScene.OpenGL4

GL_HISTOGRAM_WIDTH_EXT

GLScene.OpenGL4

GL_HI_BIAS_NV

GLScene.OpenGL4

GL_HI_SCALE_NV

GLScene.OpenGL4

GL_HORIZONTAL_LINE_TO_NV

GLScene.OpenGL4

GL_HP_convolution_border_modes

GLScene.OpenGL4

GL 4.6

GL_HP_image_transform

GLScene.OpenGL4

GL 4.6

GL_HP_occlusion_test

GLScene.OpenGL4

GL 4.6

GL_HP_texture_lighting

GLScene.OpenGL4

GL 4.6

GL_HSL_COLOR_KHR

GLScene.OpenGL4

GL_HSL_HUE_KHR

GLScene.OpenGL4

GL_HSL_LUMINOSITY_KHR

GLScene.OpenGL4

GL_HSL_SATURATION_KHR

GLScene.OpenGL4

GL_IBM_cull_vertex

GLScene.OpenGL4

GL 4.6

GL_IBM_multimode_draw_arrays

GLScene.OpenGL4

GL 4.6

GL_IBM_rasterpos_clip

GLScene.OpenGL4

GL 4.6

GL_IBM_texture_mirrored_repeat

GLScene.OpenGL4

GL 4.6

GL_IBM_vertex_array_lists

GLScene.OpenGL4

GL 4.6

GL_IDENTITY_NV

GLScene.OpenGL4

GL_IGNORE_BORDER_HP

GLScene.OpenGL4

GL_HP_convolution_border_modes

GL_IMAGE_1D

GLScene.OpenGL4

GL_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_1D_EXT

GLScene.OpenGL4

GL_IMAGE_2D

GLScene.OpenGL4

GL_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_2D_EXT

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_IMAGE_2D_RECT

GLScene.OpenGL4

GL_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_IMAGE_3D

GLScene.OpenGL4

GL_IMAGE_3D_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_ACCESS

GLScene.OpenGL4

GL_IMAGE_BINDING_ACCESS_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_FORMAT

GLScene.OpenGL4

GL_IMAGE_BINDING_FORMAT_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYER

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYERED

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYERED_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYER_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LEVEL

GLScene.OpenGL4

GL_IMAGE_BINDING_LEVEL_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_NAME

GLScene.OpenGL4

GL_IMAGE_BINDING_NAME_EXT

GLScene.OpenGL4

GL_IMAGE_BUFFER

GLScene.OpenGL4

GL_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_IMAGE_CLASS_10_10_10_2

GLScene.OpenGL4

GL_IMAGE_CLASS_11_11_10

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_8

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_8

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_8

GLScene.OpenGL4

GL_IMAGE_COMPATIBILITY_CLASS

GLScene.OpenGL4

GL_IMAGE_CUBE

GLScene.OpenGL4

GL_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_CUBIC_WEIGHT_HP

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_BY_CLASS

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_BY_SIZE

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_TYPE

GLScene.OpenGL4

GL_IMAGE_MAG_FILTER_HP

GLScene.OpenGL4

GL_IMAGE_MIN_FILTER_HP

GLScene.OpenGL4

GL_IMAGE_PIXEL_FORMAT

GLScene.OpenGL4

GL_IMAGE_PIXEL_TYPE

GLScene.OpenGL4

GL_IMAGE_ROTATE_ANGLE_HP

GLScene.OpenGL4

GL_IMAGE_ROTATE_ORIGIN_X_HP

GLScene.OpenGL4

GL_IMAGE_ROTATE_ORIGIN_Y_HP

GLScene.OpenGL4

GL_IMAGE_SCALE_X_HP

GLScene.OpenGL4

GL_HP_image_transform

GL_IMAGE_SCALE_Y_HP

GLScene.OpenGL4

GL_IMAGE_TEXEL_SIZE

GLScene.OpenGL4

GL_IMAGE_TRANSFORM_2D_HP

GLScene.OpenGL4

GL_IMAGE_TRANSLATE_X_HP

GLScene.OpenGL4

GL_IMAGE_TRANSLATE_Y_HP

GLScene.OpenGL4

GL_IMPLEMENTATION_COLOR_READ_FORMAT

GLScene.OpenGL4

GL_IMPLEMENTATION_COLOR_READ_TYPE

GLScene.OpenGL4

GL_INCR

GLScene.OpenGL4

GL_INCR_WRAP

GLScene.OpenGL4

GL_INCR_WRAP_EXT

GLScene.OpenGL4

GL_EXT_stencil_wrap

GL_INDEX

GLScene.OpenGL4

GL_INDEX_ARRAY

GLScene.OpenGL4

GL_INDEX_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_INDEX_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_INDEX_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_INDEX_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_INDEX_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_INDEX_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_INDEX_ARRAY_POINTER

GLScene.OpenGL4

GL_INDEX_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_STRIDE

GLScene.OpenGL4

GL_INDEX_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_TYPE

GLScene.OpenGL4

GL_INDEX_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_INDEX_BITS

GLScene.OpenGL4

GL_INDEX_BIT_PGI

GLScene.OpenGL4

GL_INDEX_CLEAR_VALUE

GLScene.OpenGL4

GL_INDEX_LOGIC_OP

GLScene.OpenGL4

GL_INDEX_MATERIAL_EXT

GLScene.OpenGL4

GL_EXT_index_material

GL_INDEX_MATERIAL_FACE_EXT

GLScene.OpenGL4

GL_INDEX_MATERIAL_PARAMETER_EXT

GLScene.OpenGL4

GL_INDEX_MODE

GLScene.OpenGL4

GL_INDEX_OFFSET

GLScene.OpenGL4

GL_INDEX_SHIFT

GLScene.OpenGL4

GL_INDEX_TEST_EXT

GLScene.OpenGL4

GL_EXT_index_func

GL_INDEX_TEST_FUNC_EXT

GLScene.OpenGL4

GL_INDEX_TEST_REF_EXT

GLScene.OpenGL4

GL_INDEX_WRITEMASK

GLScene.OpenGL4

GL_INFO_LOG_LENGTH

GLScene.OpenGL4

GL_INGR_blend_func_separate

GLScene.OpenGL4

GL 4.6

GL_INGR_color_clamp

GLScene.OpenGL4

GL 4.6

GL_INGR_interlace_read

GLScene.OpenGL4

GL 4.6

GL_INGR_palette_buffer

GLScene.OpenGL4

GL 4.6

GL_INNOCENT_CONTEXT_RESET

GLScene.OpenGL4

GL_INNOCENT_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_INSTRUMENT_BUFFER_POINTER_SGIX

GLScene.OpenGL4

GL_SGIX_instruments

GL_INSTRUMENT_MEASUREMENTS_SGIX

GLScene.OpenGL4

GL_INT

GLScene.OpenGL4

GL_INT16_NV

GLScene.OpenGL4

GL_INT16_VEC2_NV

GLScene.OpenGL4

GL_INT16_VEC3_NV

GLScene.OpenGL4

GL_INT16_VEC4_NV

GLScene.OpenGL4

GL_INT64_ARB

GLScene.OpenGL4

GL_ARB_gpu_shader_int64

GL_INT64_NV

GLScene.OpenGL4

GL_NV_gpu_shader5

GL_INT64_VEC2_ARB

GLScene.OpenGL4

GL_INT64_VEC2_NV

GLScene.OpenGL4

GL_INT64_VEC3_ARB

GLScene.OpenGL4

GL_INT64_VEC3_NV

GLScene.OpenGL4

GL_INT64_VEC4_ARB

GLScene.OpenGL4

GL_INT64_VEC4_NV

GLScene.OpenGL4

GL_INT8_NV

GLScene.OpenGL4

GL_INT8_VEC2_NV

GLScene.OpenGL4

GL_INT8_VEC3_NV

GLScene.OpenGL4

GL_INT8_VEC4_NV

GLScene.OpenGL4

GL_INTEL_framebuffer_CMAA

GLScene.OpenGL4

GL 4.6

GL_INTEL_parallel_arrays

GLScene.OpenGL4

GL 4.6

GL_INTEL_texture_scissor

GLScene.OpenGL4

GL 4.6

GL_INTENSITY

GLScene.OpenGL4

GL_INTENSITY12

GLScene.OpenGL4

GL_INTENSITY12_EXT

GLScene.OpenGL4

GL_INTENSITY16

GLScene.OpenGL4

GL_INTENSITY16F_ARB

GLScene.OpenGL4

GL_INTENSITY16I_EXT

GLScene.OpenGL4

GL_INTENSITY16UI_EXT

GLScene.OpenGL4

GL_INTENSITY16_EXT

GLScene.OpenGL4

GL_INTENSITY16_SNORM

GLScene.OpenGL4

GL_INTENSITY32F_ARB

GLScene.OpenGL4

GL_INTENSITY32I_EXT

GLScene.OpenGL4

GL_INTENSITY32UI_EXT

GLScene.OpenGL4

GL_INTENSITY4

GLScene.OpenGL4

GL_INTENSITY4_EXT

GLScene.OpenGL4

GL_INTENSITY8

GLScene.OpenGL4

GL_INTENSITY8I_EXT

GLScene.OpenGL4

GL_INTENSITY8UI_EXT

GLScene.OpenGL4

GL_INTENSITY8_EXT

GLScene.OpenGL4

GL_INTENSITY8_SNORM

GLScene.OpenGL4

GL_INTENSITY_EXT

GLScene.OpenGL4

GL_INTENSITY_FLOAT16_APPLE

GLScene.OpenGL4

GL_INTENSITY_FLOAT16_ATI

GLScene.OpenGL4

GL_INTENSITY_FLOAT32_APPLE

GLScene.OpenGL4

GL_INTENSITY_FLOAT32_ATI

GLScene.OpenGL4

GL_INTENSITY_SNORM

GLScene.OpenGL4

GL_INTERLACE_OML

GLScene.OpenGL4

GL_OML_interlace

GL_INTERLACE_READ_INGR

GLScene.OpenGL4

GL_INGR_interlace_read

GL_INTERLACE_READ_OML

GLScene.OpenGL4

GL_INTERLACE_SGIX

GLScene.OpenGL4

GL_SGIX_interlace

GL_INTERLEAVED_ATTRIBS

GLScene.OpenGL4

GL_INTERLEAVED_ATTRIBS_EXT

GLScene.OpenGL4

GL_INTERLEAVED_ATTRIBS_NV

GLScene.OpenGL4

GL_INTERNALFORMAT_ALPHA_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_ALPHA_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_BLUE_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_BLUE_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_DEPTH_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_DEPTH_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_GREEN_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_GREEN_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_PREFERRED

GLScene.OpenGL4

GL_INTERNALFORMAT_RED_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_RED_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_SHARED_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_STENCIL_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_STENCIL_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_SUPPORTED

GLScene.OpenGL4

GL_INTERPOLATE

GLScene.OpenGL4

GL_INTERPOLATE_ARB

GLScene.OpenGL4

GL_INTERPOLATE_EXT

GLScene.OpenGL4

GL_INT_2_10_10_10_REV

GLScene.OpenGL4

reuse GL_UNSIGNED_INT_2_10_10_10_REV

GL_INT_IMAGE_1D

GLScene.OpenGL4

GL_INT_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_1D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D

GLScene.OpenGL4

GL_INT_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_RECT

GLScene.OpenGL4

GL_INT_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_INT_IMAGE_3D

GLScene.OpenGL4

GL_INT_IMAGE_3D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_BUFFER

GLScene.OpenGL4

GL_INT_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_INT_IMAGE_CUBE

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_1D

GLScene.OpenGL4

GL_INT_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_1D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D

GLScene.OpenGL4

GL_INT_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_RECT_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_3D

GLScene.OpenGL4

GL_INT_SAMPLER_3D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_INT_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_INT_VEC2

GLScene.OpenGL4

GL_INT_VEC2_ARB

GLScene.OpenGL4

GL_INT_VEC3

GLScene.OpenGL4

GL_INT_VEC3_ARB

GLScene.OpenGL4

GL_INT_VEC4

GLScene.OpenGL4

GL_INT_VEC4_ARB

GLScene.OpenGL4

GL_INVALID_ENUM

GLScene.OpenGL4

GL_INVALID_FRAMEBUFFER_OPERATION

GLScene.OpenGL4

GL_ARB_framebuffer_object

GL_INVALID_FRAMEBUFFER_OPERATION_EXT

GLScene.OpenGL4

GL_INVALID_INDEX

GLScene.OpenGL4

GL_INVALID_OPERATION

GLScene.OpenGL4

GL_INVALID_VALUE

GLScene.OpenGL4

GL_INVARIANT_DATATYPE_EXT

GLScene.OpenGL4

GL_INVARIANT_EXT

GLScene.OpenGL4

GL_INVARIANT_VALUE_EXT

GLScene.OpenGL4

GL_INVERSE_NV

GLScene.OpenGL4

GL_INVERSE_TRANSPOSE_NV

GLScene.OpenGL4

GL_INVERT

GLScene.OpenGL4

GL_INVERTED_SCREEN_W_REND

GLScene.OpenGL4

GL_IR_INSTRUMENT1_SGIX

GLScene.OpenGL4

GL_SGIX_ir_instrument1

GL_ISOLINES

GLScene.OpenGL4

GL_IS_PER_PATCH

GLScene.OpenGL4

GL_IS_ROW_MAJOR

GLScene.OpenGL4

GL_ITALIC_BIT_NV

GLScene.OpenGL4

GL_IUI_N3F_V2F_EXT

GLScene.OpenGL4

GL_IUI_N3F_V3F_EXT

GLScene.OpenGL4

GL_IUI_V2F_EXT

GLScene.OpenGL4

GL_EXT_index_array_formats

GL_IUI_V3F_EXT

GLScene.OpenGL4

GL_KEEP

GLScene.OpenGL4

StencilOp

GL_KHR_blend_equation_advanced

GLScene.OpenGL4

GL 4.5

GL_KHR_blend_equation_advanced_coherent

GLScene.OpenGL4

GL 4.5

GL_KHR_context_flush_control

GLScene.OpenGL4

GL 4.5

GL_KHR_debug

GLScene.OpenGL4

GL 4.3

GL_KHR_no_error

GLScene.OpenGL4

GL 4.6

GL_KHR_robustness

GLScene.OpenGL4

GL 4.5

GL_KHR_robust_buffer_access_behavior

GLScene.OpenGL4

GL 4.5

GL_LARGE_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_LARGE_CW_ARC_TO_NV

GLScene.OpenGL4

GL_LAST_VERTEX_CONVENTION

GLScene.OpenGL4

GL_LAST_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_LAST_VIDEO_CAPTURE_STATUS_NV

GLScene.OpenGL4

GL_LAYER_NV

GLScene.OpenGL4

GL_LAYER_PROVOKING_VERTEX

GLScene.OpenGL4

GL_LEFT

GLScene.OpenGL4

GL_LEQUAL

GLScene.OpenGL4

GL_LERP_ATI

GLScene.OpenGL4

GL_LESS

GLScene.OpenGL4

GL_LIGHT0

GLScene.OpenGL4

GL_LIGHT1

GLScene.OpenGL4

GL_LIGHT2

GLScene.OpenGL4

GL_LIGHT3

GLScene.OpenGL4

GL_LIGHT4

GLScene.OpenGL4

GL_LIGHT5

GLScene.OpenGL4

GL_LIGHT6

GLScene.OpenGL4

GL_LIGHT7

GLScene.OpenGL4

GL_LIGHTEN_KHR

GLScene.OpenGL4

GL_LIGHTING

GLScene.OpenGL4

GL_LIGHTING_BIT

GLScene.OpenGL4

GL_LIGHT_ENV_MODE_SGIX

GLScene.OpenGL4

GL_LIGHT_MODEL_AMBIENT

GLScene.OpenGL4

GL_LIGHT_MODEL_COLOR_CONTROL

GLScene.OpenGL4

GL_LIGHT_MODEL_COLOR_CONTROL_EXT

GLScene.OpenGL4

GL_EXT_separate_specular_color

GL_LIGHT_MODEL_LOCAL_VIEWER

GLScene.OpenGL4

GL_LIGHT_MODEL_SPECULAR_VECTOR_APPLE

GLScene.OpenGL4

GL_APPLE_specular_vector

GL_LIGHT_MODEL_TWO_SIDE

GLScene.OpenGL4

GL_LINE

GLScene.OpenGL4

GL_LINEAR

GLScene.OpenGL4

GL_LINEAR_ATTENUATION

GLScene.OpenGL4

GL_LINEAR_CLIPMAP_LINEAR_SGIX

GLScene.OpenGL4

GL_SGIX_clipmap

GL_LINEAR_CLIPMAP_NEAREST_SGIX

GLScene.OpenGL4

GL_LINEAR_DETAIL_ALPHA_SGIS

GLScene.OpenGL4

GL_LINEAR_DETAIL_COLOR_SGIS

GLScene.OpenGL4

GL_LINEAR_DETAIL_SGIS

GLScene.OpenGL4

GL_LINEAR_MIPMAP_LINEAR

GLScene.OpenGL4

GL_LINEAR_MIPMAP_NEAREST

GLScene.OpenGL4

GL_LINEAR_SHARPEN_ALPHA_SGIS

GLScene.OpenGL4

GL_LINEAR_SHARPEN_COLOR_SGIS

GLScene.OpenGL4

GL_LINEAR_SHARPEN_SGIS

GLScene.OpenGL4

GL_SGIS_sharpen_texture

GL_LINES

GLScene.OpenGL4

GL_LINES_ADJACENCY

GLScene.OpenGL4

GL_LINES_ADJACENCY_ARB

GLScene.OpenGL4

GL_ARB_geometry_shader4

GL_LINES_ADJACENCY_EXT

GLScene.OpenGL4

GL_LINE_BIT

GLScene.OpenGL4

GL_LINE_LOOP

GLScene.OpenGL4

GL_LINE_RESET_TOKEN

GLScene.OpenGL4

GL_LINE_SMOOTH

GLScene.OpenGL4

GL_LINE_SMOOTH_HINT

GLScene.OpenGL4

GL_LINE_STIPPLE

GLScene.OpenGL4

GL_LINE_STIPPLE_PATTERN

GLScene.OpenGL4

GL_LINE_STIPPLE_REPEAT

GLScene.OpenGL4

GL_LINE_STRIP

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY_ARB

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY_EXT

GLScene.OpenGL4

GL_LINE_TOKEN

GLScene.OpenGL4

GL_LINE_TO_NV

GLScene.OpenGL4

GL_LINE_WIDTH

GLScene.OpenGL4

GL_LINE_WIDTH_GRANULARITY

GLScene.OpenGL4

GL_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_LINK_STATUS

GLScene.OpenGL4

GL_LIST_BASE

GLScene.OpenGL4

GL_LIST_BIT

GLScene.OpenGL4

GL_LIST_INDEX

GLScene.OpenGL4

GL_LIST_MODE

GLScene.OpenGL4

GL_LIST_PRIORITY_SGIX

GLScene.OpenGL4

GL_SGIX_list_priority

GL_LOAD

GLScene.OpenGL4

GL_LOCAL_CONSTANT_DATATYPE_EXT

GLScene.OpenGL4

GL_LOCAL_CONSTANT_EXT

GLScene.OpenGL4

GL_LOCAL_CONSTANT_VALUE_EXT

GLScene.OpenGL4

GL_LOCAL_EXT

GLScene.OpenGL4

GL_LOCATION

GLScene.OpenGL4

GL_LOCATION_COMPONENT

GLScene.OpenGL4

GL_LOCATION_INDEX

GLScene.OpenGL4

GL_LOGIC_OP

GLScene.OpenGL4

GL_LOGIC_OP_MODE

GLScene.OpenGL4

GL_LOSE_CONTEXT_ON_RESET

GLScene.OpenGL4

GL_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

GL_LOWER_LEFT

GLScene.OpenGL4

GL_LOW_FLOAT

GLScene.OpenGL4

GL_LOW_INT

GLScene.OpenGL4

GL_LO_BIAS_NV

GLScene.OpenGL4

GL_LO_SCALE_NV

GLScene.OpenGL4

GL_LUMINANCE

GLScene.OpenGL4

GL_LUMINANCE12

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA12

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA12_EXT

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA4

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA4_EXT

GLScene.OpenGL4

GL_LUMINANCE12_EXT

GLScene.OpenGL4

GL_LUMINANCE16

GLScene.OpenGL4

GL_LUMINANCE16F_ARB

GLScene.OpenGL4

GL_LUMINANCE16I_EXT

GLScene.OpenGL4

GL_LUMINANCE16UI_EXT

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16_EXT

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16_SNORM

GLScene.OpenGL4

GL_LUMINANCE16_EXT

GLScene.OpenGL4

GL_LUMINANCE16_SNORM

GLScene.OpenGL4

GL_LUMINANCE32F_ARB

GLScene.OpenGL4

GL_LUMINANCE32I_EXT

GLScene.OpenGL4

GL_LUMINANCE32UI_EXT

GLScene.OpenGL4

GL_LUMINANCE4

GLScene.OpenGL4

GL_LUMINANCE4_ALPHA4

GLScene.OpenGL4

GL_LUMINANCE4_ALPHA4_EXT

GLScene.OpenGL4

GL_LUMINANCE4_EXT

GLScene.OpenGL4

GL_LUMINANCE6_ALPHA2

GLScene.OpenGL4

GL_LUMINANCE6_ALPHA2_EXT

GLScene.OpenGL4

GL_LUMINANCE8

GLScene.OpenGL4

GL_LUMINANCE8I_EXT

GLScene.OpenGL4

GL_LUMINANCE8UI_EXT

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8_EXT

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8_SNORM

GLScene.OpenGL4

GL_LUMINANCE8_EXT

GLScene.OpenGL4

GL_LUMINANCE8_SNORM

GLScene.OpenGL4

GL_LUMINANCE_ALPHA

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16F_ARB

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32F_ARB

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA8I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA8UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT16_APPLE

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT16_ATI

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT32_APPLE

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT32_ATI

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_INTEGER_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_SNORM

GLScene.OpenGL4

GL_LUMINANCE_FLOAT16_APPLE

GLScene.OpenGL4

GL_LUMINANCE_FLOAT16_ATI

GLScene.OpenGL4

GL_LUMINANCE_FLOAT32_APPLE

GLScene.OpenGL4

GL_LUMINANCE_FLOAT32_ATI

GLScene.OpenGL4

GL_LUMINANCE_INTEGER_EXT

GLScene.OpenGL4

GL_LUMINANCE_SNORM

GLScene.OpenGL4

GL_MAD_ATI

GLScene.OpenGL4

GL_MAGNITUDE_BIAS_NV

GLScene.OpenGL4

GL_MAGNITUDE_SCALE_NV

GLScene.OpenGL4

GL_MAJOR_VERSION

GLScene.OpenGL4

GL_MANUAL_GENERATE_MIPMAP

GLScene.OpenGL4

GL_MAP1_BINORMAL_EXT

GLScene.OpenGL4

GL_MAP1_COLOR_4

GLScene.OpenGL4

GL_MAP1_GRID_DOMAIN

GLScene.OpenGL4

GL_MAP1_GRID_SEGMENTS

GLScene.OpenGL4

GL_MAP1_INDEX

GLScene.OpenGL4

GL_MAP1_NORMAL

GLScene.OpenGL4

GL_MAP1_TANGENT_EXT

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_1

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_2

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_3

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_4

GLScene.OpenGL4

GL_MAP1_VERTEX_3

GLScene.OpenGL4

GL_MAP1_VERTEX_4

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB0_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB10_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB11_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB12_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB13_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB14_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB15_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB1_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB2_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB3_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB4_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB5_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB6_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB7_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB8_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB9_4_NV

GLScene.OpenGL4

GL_MAP2_BINORMAL_EXT

GLScene.OpenGL4

GL_MAP2_COLOR_4

GLScene.OpenGL4

GL_MAP2_GRID_DOMAIN

GLScene.OpenGL4

GL_MAP2_GRID_SEGMENTS

GLScene.OpenGL4

GL_MAP2_INDEX

GLScene.OpenGL4

GL_MAP2_NORMAL

GLScene.OpenGL4

GL_MAP2_TANGENT_EXT

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_1

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_2

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_3

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_4

GLScene.OpenGL4

GL_MAP2_VERTEX_3

GLScene.OpenGL4

GL_MAP2_VERTEX_4

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB0_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB10_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB11_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB12_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB13_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB14_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB15_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB1_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB2_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB3_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB4_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB5_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB6_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB7_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB8_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB9_4_NV

GLScene.OpenGL4

GL_MAP_ATTRIB_U_ORDER_NV

GLScene.OpenGL4

GL_MAP_ATTRIB_V_ORDER_NV

GLScene.OpenGL4

GL_MAP_COHERENT_BIT

GLScene.OpenGL4

GL_MAP_COLOR

GLScene.OpenGL4

GL_MAP_FLUSH_EXPLICIT_BIT

GLScene.OpenGL4

GL_MAP_INVALIDATE_BUFFER_BIT

GLScene.OpenGL4

GL_MAP_INVALIDATE_RANGE_BIT

GLScene.OpenGL4

GL_MAP_PERSISTENT_BIT

GLScene.OpenGL4

GL_MAP_READ_BIT

GLScene.OpenGL4

GL_ARB_map_buffer_range

GL_MAP_STENCIL

GLScene.OpenGL4

GL_MAP_TESSELLATION_NV

GLScene.OpenGL4

GL_MAP_UNSYNCHRONIZED_BIT

GLScene.OpenGL4

GL_MAP_WRITE_BIT

GLScene.OpenGL4

GL_MATERIAL_SIDE_HINT_PGI

GLScene.OpenGL4

GL_MATRIX0_ARB

GLScene.OpenGL4

GL_MATRIX0_NV

GLScene.OpenGL4

GL_MATRIX10_ARB

GLScene.OpenGL4

GL_MATRIX11_ARB

GLScene.OpenGL4

GL_MATRIX12_ARB

GLScene.OpenGL4

GL_MATRIX13_ARB

GLScene.OpenGL4

GL_MATRIX14_ARB

GLScene.OpenGL4

GL_MATRIX15_ARB

GLScene.OpenGL4

GL_MATRIX16_ARB

GLScene.OpenGL4

GL_MATRIX17_ARB

GLScene.OpenGL4

GL_MATRIX18_ARB

GLScene.OpenGL4

GL_MATRIX19_ARB

GLScene.OpenGL4

GL_MATRIX1_ARB

GLScene.OpenGL4

GL_MATRIX1_NV

GLScene.OpenGL4

GL_MATRIX20_ARB

GLScene.OpenGL4

GL_MATRIX21_ARB

GLScene.OpenGL4

GL_MATRIX22_ARB

GLScene.OpenGL4

GL_MATRIX23_ARB

GLScene.OpenGL4

GL_MATRIX24_ARB

GLScene.OpenGL4

GL_MATRIX25_ARB

GLScene.OpenGL4

GL_MATRIX26_ARB

GLScene.OpenGL4

GL_MATRIX27_ARB

GLScene.OpenGL4

GL_MATRIX28_ARB

GLScene.OpenGL4

GL_MATRIX29_ARB

GLScene.OpenGL4

GL_MATRIX2_ARB

GLScene.OpenGL4

GL_MATRIX2_NV

GLScene.OpenGL4

GL_MATRIX30_ARB

GLScene.OpenGL4

GL_MATRIX31_ARB

GLScene.OpenGL4

GL_MATRIX3_ARB

GLScene.OpenGL4

GL_MATRIX3_NV

GLScene.OpenGL4

GL_MATRIX4_ARB

GLScene.OpenGL4

GL_MATRIX4_NV

GLScene.OpenGL4

GL_MATRIX5_ARB

GLScene.OpenGL4

GL_MATRIX5_NV

GLScene.OpenGL4

GL_MATRIX6_ARB

GLScene.OpenGL4

GL_MATRIX6_NV

GLScene.OpenGL4

GL_MATRIX7_ARB

GLScene.OpenGL4

GL_MATRIX7_NV

GLScene.OpenGL4

GL_MATRIX8_ARB

GLScene.OpenGL4

GL_MATRIX9_ARB

GLScene.OpenGL4

GL_MATRIX_EXT

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_MATRIX_MODE

GLScene.OpenGL4

GL_MATRIX_PALETTE_ARB

GLScene.OpenGL4

GL_ARB_matrix_palette

GL_MATRIX_STRIDE

GLScene.OpenGL4

GL_MAT_AMBIENT_AND_DIFFUSE_BIT_PGI

GLScene.OpenGL4

GL_MAT_AMBIENT_BIT_PGI

GLScene.OpenGL4

GL_MAT_COLOR_INDEXES_BIT_PGI

GLScene.OpenGL4

GL_MAT_DIFFUSE_BIT_PGI

GLScene.OpenGL4

GL_MAT_EMISSION_BIT_PGI

GLScene.OpenGL4

GL_MAT_SHININESS_BIT_PGI

GLScene.OpenGL4

GL_MAT_SPECULAR_BIT_PGI

GLScene.OpenGL4

GL_MAX

GLScene.OpenGL4

GL_MAX_3D_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_3D_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_4D_TEXTURE_SIZE_SGIS

GLScene.OpenGL4

GL_MAX_ACTIVE_LIGHTS_SGIX

GLScene.OpenGL4

GL_MAX_ARRAY_TEXTURE_LAYERS

GLScene.OpenGL4

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT

GLScene.OpenGL4

GL_MAX_ASYNC_DRAW_PIXELS_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_HISTOGRAM_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_READ_PIXELS_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_TEX_IMAGE_SGIX

GLScene.OpenGL4

GL_MAX_ATOMIC_COUNTER_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_ATOMIC_COUNTER_BUFFER_SIZE

GLScene.OpenGL4

GL_MAX_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT

GLScene.OpenGL4

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_CLIPMAP_DEPTH_SGIX

GLScene.OpenGL4

GL_MAX_CLIPMAP_VIRTUAL_DEPTH_SGIX

GLScene.OpenGL4

GL_MAX_CLIP_DISTANCES

GLScene.OpenGL4

GL_MAX_CLIP_PLANES

GLScene.OpenGL4

GL_MAX_COLOR_ATTACHMENTS

GLScene.OpenGL4

GL_MAX_COLOR_ATTACHMENTS_EXT

GLScene.OpenGL4

GL_MAX_COLOR_MATRIX_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI

GLScene.OpenGL4

GL_MAX_COLOR_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_MAX_COMBINED_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_COMBINED_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_COMBINED_CLIP_AND_CULL_DISTANCES

GLScene.OpenGL4

GL_MAX_COMBINED_COMPUTE_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_DIMENSIONS

GLScene.OpenGL4

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS_EXT

GLScene.OpenGL4

GL_MAX_COMBINED_SHADER_OUTPUT_RESOURCES

GLScene.OpenGL4

GL_MAX_COMBINED_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_COMBINED_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMPUTE_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_COMPUTE_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_COMPUTE_FIXED_GROUP_INVOCATIONS_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_FIXED_GROUP_SIZE_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_COMPUTE_LOCAL_INVOCATIONS

GLScene.OpenGL4

GL_MAX_COMPUTE_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_COMPUTE_SHARED_MEMORY_SIZE

GLScene.OpenGL4

GL_MAX_COMPUTE_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_COMPUTE_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_COMPUTE_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMPUTE_VARIABLE_GROUP_INVOCATIONS_ARB

GLScene.OpenGL4

GL_ARB_compute_variable_group_size

GL_MAX_COMPUTE_VARIABLE_GROUP_SIZE_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_WORK_GROUP_COUNT

GLScene.OpenGL4

GL_MAX_COMPUTE_WORK_GROUP_SIZE

GLScene.OpenGL4

GL_MAX_CONVOLUTION_HEIGHT

GLScene.OpenGL4

GL_MAX_CONVOLUTION_HEIGHT_EXT

GLScene.OpenGL4

GL_MAX_CONVOLUTION_WIDTH

GLScene.OpenGL4

GL_MAX_CONVOLUTION_WIDTH_EXT

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_CULL_DISTANCES

GLScene.OpenGL4

GL_MAX_DEBUG_GROUP_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_DEBUG_LOGGED_MESSAGES

GLScene.OpenGL4

GL_MAX_DEBUG_LOGGED_MESSAGES_AMD

GLScene.OpenGL4

GL_AMD_debug_output

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB

GLScene.OpenGL4

GL_MAX_DEBUG_MESSAGE_LENGTH

GLScene.OpenGL4

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB

GLScene.OpenGL4

GL_MAX_DEFORMATION_ORDER_SGIX

GLScene.OpenGL4

GL_MAX_DEPTH

GLScene.OpenGL4

GL_MAX_DEPTH_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_MAX_DRAW_BUFFERS

GLScene.OpenGL4

GL_MAX_DRAW_BUFFERS_ARB

GLScene.OpenGL4

GL_ARB_draw_buffers

GL_MAX_DRAW_BUFFERS_ATI

GLScene.OpenGL4

GL_ATI_draw_buffers

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES_EXT

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES_WIN

GLScene.OpenGL4

GL_MAX_ELEMENTS_VERTICES

GLScene.OpenGL4

GL_MAX_ELEMENTS_VERTICES_EXT

GLScene.OpenGL4

GL_EXT_draw_range_elements

GL_MAX_ELEMENTS_VERTICES_WIN

GLScene.OpenGL4

WIN_draw_range_elements

GL_MAX_ELEMENT_INDEX

GLScene.OpenGL4

GL_MAX_EVAL_ORDER

GLScene.OpenGL4

GL_MAX_EXT

GLScene.OpenGL4

GL_MAX_FOG_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_MAX_FRAGMENT_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_FRAGMENT_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_MAX_FRAGMENT_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_FRAGMENT_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET

GLScene.OpenGL4

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET_NV

GLScene.OpenGL4

GL_MAX_FRAGMENT_LIGHTS_SGIX

GLScene.OpenGL4

GL_MAX_FRAGMENT_PROGRAM_LOCAL_PARAMETERS_NV

GLScene.OpenGL4

GL_NV_fragment_program

GL_MAX_FRAGMENT_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_VECTORS

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_HEIGHT

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_LAYERS

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_SAMPLES

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_WIDTH

GLScene.OpenGL4

GL_MAX_FRAMEZOOM_FACTOR_SGIX

GLScene.OpenGL4

GL_MAX_GENERAL_COMBINERS_NV

GLScene.OpenGL4

GL_MAX_GEOMETRY_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_GEOMETRY_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_GEOMETRY_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_PROGRAM_INVOCATIONS_NV

GLScene.OpenGL4

GL_NV_gpu_program5

GL_MAX_GEOMETRY_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_MAX_GEOMETRY_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_HEIGHT

GLScene.OpenGL4

GL_MAX_IMAGE_SAMPLES

GLScene.OpenGL4

GL_MAX_IMAGE_SAMPLES_EXT

GLScene.OpenGL4

GL_MAX_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_IMAGE_UNITS_EXT

GLScene.OpenGL4

GL_EXT_shader_image_load_store

GL_MAX_INTEGER_SAMPLES

GLScene.OpenGL4

GL_MAX_LABEL_LENGTH

GLScene.OpenGL4

GL_MAX_LAYERS

GLScene.OpenGL4

GL_MAX_LIGHTS

GLScene.OpenGL4

GL_MAX_LIST_NESTING

GLScene.OpenGL4

GL_MAX_MAP_TESSELLATION_NV

GLScene.OpenGL4

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_MAX_MODELVIEW_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_NAME_LENGTH

GLScene.OpenGL4

GL_MAX_NAME_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_NUM_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_MAX_NUM_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_MAX_PALETTE_MATRICES_ARB

GLScene.OpenGL4

GL_MAX_PATCH_VERTICES

GLScene.OpenGL4

GL_MAX_PIXEL_MAP_TABLE

GLScene.OpenGL4

GL_MAX_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_MAX_PN_TRIANGLES_TESSELATION_LEVEL_ATI

GLScene.OpenGL4

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ATTRIB_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_CALL_DEPTH_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_EXEC_INSTRUCTIONS_NV

GLScene.OpenGL4

GL_NV_fragment_program2 and GL_NV_vertex_program2_option

GL_MAX_PROGRAM_GENERIC_ATTRIBS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_GENERIC_RESULTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_IF_DEPTH_NV

GLScene.OpenGL4

GL_NV_fragment_program2

GL_MAX_PROGRAM_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_LOOP_COUNT_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_LOOP_DEPTH_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_MATRICES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_PARAMETER_BUFFER_BINDINGS_NV

GLScene.OpenGL4

GL_NV_parameter_buffer_object

GL_MAX_PROGRAM_PARAMETER_BUFFER_SIZE_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_PATCH_ATTRIBS_NV

GLScene.OpenGL4

GL_NV_tessellation_program5

GL_MAX_PROGRAM_RESULT_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_SUBROUTINE_NUM_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_SUBROUTINE_PARAMETERS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_TEMPORARIES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXEL_OFFSET

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROJECTION_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_RATIONAL_EVAL_ORDER_NV

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV

GLScene.OpenGL4

GL_MAX_RENDERBUFFER_SIZE

GLScene.OpenGL4

GL_MAX_RENDERBUFFER_SIZE_EXT

GLScene.OpenGL4

GL_MAX_SAMPLES

GLScene.OpenGL4

GL_MAX_SAMPLES_EXT

GLScene.OpenGL4

GL_MAX_SAMPLE_MASK_WORDS

GLScene.OpenGL4

GL_MAX_SAMPLE_MASK_WORDS_NV

GLScene.OpenGL4

GL_MAX_SERVER_WAIT_TIMEOUT

GLScene.OpenGL4

GL_ARB_sync

GL_MAX_SHADER_BUFFER_ADDRESS_NV

GLScene.OpenGL4

GL_MAX_SHADER_COMPILER_THREADS_ARB

GLScene.OpenGL4

GL_ARB_parallel_shader_compile

GL_MAX_SHADER_STORAGE_BLOCK_SIZE

GLScene.OpenGL4

GL_MAX_SHADER_STORAGE_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_SHININESS_NV

GLScene.OpenGL4

GL_NV_light_max_exponent

GL_MAX_SPARSE_3D_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_SPARSE_ARRAY_TEXTURE_LAYERS_ARB

GLScene.OpenGL4

GL_MAX_SPARSE_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_SPOT_EXPONENT_NV

GLScene.OpenGL4

GL_MAX_SUBPIXEL_PRECISION_BIAS_BITS_NV

GLScene.OpenGL4

GL_MAX_SUBROUTINES

GLScene.OpenGL4

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_GEN_LEVEL

GLScene.OpenGL4

GL_MAX_TESS_PATCH_COMPONENTS

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE_EXT

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS_NV

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS_NV

GLScene.OpenGL4

GL_MAX_TEXTURE_LOD_BIAS

GLScene.OpenGL4

GL_MAX_TEXTURE_LOD_BIAS_EXT

GLScene.OpenGL4

GL_EXT_texture_lod_bias

GL_MAX_TEXTURE_MAX_ANISOTROPY

GLScene.OpenGL4

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT

GLScene.OpenGL4

GL_MAX_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_TEXTURE_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_TEXTURE_UNITS

GLScene.OpenGL4

GL_MAX_TEXTURE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_TRACK_MATRICES_NV

GLScene.OpenGL4

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS

GLScene.OpenGL4

GL_ARB_transform_feedback3

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_UNIFORM_BLOCK_SIZE

GLScene.OpenGL4

GL_MAX_UNIFORM_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_MAX_VARYING_COMPONENTS

GLScene.OpenGL4

GL_MAX_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_VARYING_FLOATS

GLScene.OpenGL4

GL_MAX_VARYING_FLOATS_ARB

GLScene.OpenGL4

GL_MAX_VARYING_VECTORS

GLScene.OpenGL4

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV

GLScene.OpenGL4

GL_MAX_VERTEX_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_VERTEX_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIBS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_BINDINGS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_RELATIVE_OFFSET

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_STRIDE

GLScene.OpenGL4

GL 4.4

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_EXT_bindable_uniform

GL_MAX_VERTEX_HINT_PGI

GLScene.OpenGL4

GL_MAX_VERTEX_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_VERTEX_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_STREAMS

GLScene.OpenGL4

GL_MAX_VERTEX_STREAMS_ATI

GLScene.OpenGL4

GL_ATI_vertex_streams

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_VECTORS

GLScene.OpenGL4

GL_MAX_VERTEX_UNITS_ARB

GLScene.OpenGL4

GL_ARB_vertex_blend

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_VIEWPORTS

GLScene.OpenGL4

GL_ARB_vertex_attrib_64bit

GL_MAX_VIEWPORT_DIMS

GLScene.OpenGL4

GL_MAX_VIEWS_OVR

GLScene.OpenGL4

GL_MAX_WIDTH

GLScene.OpenGL4

GL_MEDIUM_FLOAT

GLScene.OpenGL4

GL_MEDIUM_INT

GLScene.OpenGL4

GL_MESA_resize_buffers

GLScene.OpenGL4

GL 4.6

GL_MESA_window_pos

GLScene.OpenGL4

GL 4.6

GL_MIN

GLScene.OpenGL4

GL_MINMAX

GLScene.OpenGL4

GL_MINMAX_EXT

GLScene.OpenGL4

GL_MINMAX_FORMAT

GLScene.OpenGL4

GL_MINMAX_FORMAT_EXT

GLScene.OpenGL4

GL_MINMAX_SINK

GLScene.OpenGL4

GL_MINMAX_SINK_EXT

GLScene.OpenGL4

GL_MINOR_VERSION

GLScene.OpenGL4

GL_MIN_EXT

GLScene.OpenGL4

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET

GLScene.OpenGL4

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET_NV

GLScene.OpenGL4

GL_MIN_MAP_BUFFER_ALIGNMENT

GLScene.OpenGL4

GL_ARB_map_buffer_alignment

GL_MIN_PROGRAM_TEXEL_OFFSET

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

GLScene.OpenGL4

GL_ARB_texture_gather

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_NV

GLScene.OpenGL4

GL_MIN_SAMPLE_SHADING_VALUE

GLScene.OpenGL4

GL_MIN_SAMPLE_SHADING_VALUE_ARB

GLScene.OpenGL4

GL_MIN_SPARSE_LEVEL_ARB

GLScene.OpenGL4

GL_MIPMAP

GLScene.OpenGL4

GL_MIRRORED_REPEAT

GLScene.OpenGL4

GL_MIRRORED_REPEAT_ARB

GLScene.OpenGL4

GL_ARB_texture_mirrored_repeat

GL_MIRRORED_REPEAT_IBM

GLScene.OpenGL4

GL_IBM_texture_mirrored_repeat

GL_MIRROR_CLAMP_ATI

GLScene.OpenGL4

GL_ATI_texture_mirror_once

GL_MIRROR_CLAMP_EXT

GLScene.OpenGL4

GL_EXT_texture_mirror_clamp

GL_MIRROR_CLAMP_TO_BORDER_EXT

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE_ATI

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE_EXT

GLScene.OpenGL4

GL_MITER_REVERT_NV

GLScene.OpenGL4

GL_MITER_TRUNCATE_NV

GLScene.OpenGL4

GL_MODELVIEW

GLScene.OpenGL4

GL_MODELVIEW0_ARB

GLScene.OpenGL4

GL_MODELVIEW0_EXT

GLScene.OpenGL4

GL_MODELVIEW0_MATRIX_EXT

GLScene.OpenGL4

GL_MODELVIEW0_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_EXT_vertex_weighting

GL_MODELVIEW10_ARB

GLScene.OpenGL4

GL_MODELVIEW11_ARB

GLScene.OpenGL4

GL_MODELVIEW12_ARB

GLScene.OpenGL4

GL_MODELVIEW13_ARB

GLScene.OpenGL4

GL_MODELVIEW14_ARB

GLScene.OpenGL4

GL_MODELVIEW15_ARB

GLScene.OpenGL4

GL_MODELVIEW16_ARB

GLScene.OpenGL4

GL_MODELVIEW17_ARB

GLScene.OpenGL4

GL_MODELVIEW18_ARB

GLScene.OpenGL4

GL_MODELVIEW19_ARB

GLScene.OpenGL4

GL_MODELVIEW1_ARB

GLScene.OpenGL4

GL_MODELVIEW1_EXT

GLScene.OpenGL4

GL_MODELVIEW1_MATRIX_EXT

GLScene.OpenGL4

GL_MODELVIEW1_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_MODELVIEW20_ARB

GLScene.OpenGL4

GL_MODELVIEW21_ARB

GLScene.OpenGL4

GL_MODELVIEW22_ARB

GLScene.OpenGL4

GL_MODELVIEW23_ARB

GLScene.OpenGL4

GL_MODELVIEW24_ARB

GLScene.OpenGL4

GL_MODELVIEW25_ARB

GLScene.OpenGL4

GL_MODELVIEW26_ARB

GLScene.OpenGL4

GL_MODELVIEW27_ARB

GLScene.OpenGL4

GL_MODELVIEW28_ARB

GLScene.OpenGL4

GL_MODELVIEW29_ARB

GLScene.OpenGL4

GL_MODELVIEW2_ARB

GLScene.OpenGL4

GL_MODELVIEW30_ARB

GLScene.OpenGL4

GL_MODELVIEW31_ARB

GLScene.OpenGL4

GL_MODELVIEW3_ARB

GLScene.OpenGL4

GL_MODELVIEW4_ARB

GLScene.OpenGL4

GL_MODELVIEW5_ARB

GLScene.OpenGL4

GL_MODELVIEW6_ARB

GLScene.OpenGL4

GL_MODELVIEW7_ARB

GLScene.OpenGL4

GL_MODELVIEW8_ARB

GLScene.OpenGL4

GL_MODELVIEW9_ARB

GLScene.OpenGL4

GL_MODELVIEW_MATRIX

GLScene.OpenGL4

GL_MODELVIEW_PROJECTION_NV

GLScene.OpenGL4

GL_MODELVIEW_STACK_DEPTH

GLScene.OpenGL4

GL_MODULATE

GLScene.OpenGL4

GL_MODULATE_ADD_ATI

GLScene.OpenGL4

GL_ATI_texture_env_combine3

GL_MODULATE_SIGNED_ADD_ATI

GLScene.OpenGL4

GL_MODULATE_SUBTRACT_ATI

GLScene.OpenGL4

GL_MOVE_TO_CONTINUES_NV

GLScene.OpenGL4

GL_MOVE_TO_NV

GLScene.OpenGL4

GL_MOVE_TO_RESETS_NV

GLScene.OpenGL4

GL_MOV_ATI

GLScene.OpenGL4

GL_MULT

GLScene.OpenGL4

GL_MULTIPLY_KHR

GLScene.OpenGL4

GL_KHR_blend_equation_advanced

GL_MULTISAMPLE

GLScene.OpenGL4

GL_MULTISAMPLE_3DFX

GLScene.OpenGL4

GL_3DFX_multisample

GL_MULTISAMPLE_ARB

GLScene.OpenGL4

GL_ARB_multisample

GL_MULTISAMPLE_BIT

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_3DFX

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_EXT

GLScene.OpenGL4

GL_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_EXT_multisample

GL_MULTISAMPLE_FILTER_HINT_NV

GLScene.OpenGL4

GL_NV_multisample_filter_hint

GL_MULTISAMPLE_LINE_WIDTH_GRANULARITY_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_LINE_WIDTH_RANGE_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_SGIS

GLScene.OpenGL4

GL_SGIS_multisample

GL_MULTI_HULLS_NV

GLScene.OpenGL4

GL_MUL_ATI

GLScene.OpenGL4

GL_MVP_MATRIX_EXT

GLScene.OpenGL4

GL_N3F_V3F

GLScene.OpenGL4

GL_NAMED_STRING_LENGTH_ARB

GLScene.OpenGL4

GL_NAMED_STRING_TYPE_ARB

GLScene.OpenGL4

GL_NAME_LENGTH

GLScene.OpenGL4

GL_NAME_STACK_DEPTH

GLScene.OpenGL4

GL_NAND

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_BEGIN_HINT_PGI

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_END_HINT_PGI

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_HANDLE_PGI

GLScene.OpenGL4

GL_NEAREST

GLScene.OpenGL4

TextureMagFilter

GL_NEAREST_CLIPMAP_LINEAR_SGIX

GLScene.OpenGL4

GL_NEAREST_CLIPMAP_NEAREST_SGIX

GLScene.OpenGL4

GL_NEAREST_MIPMAP_LINEAR

GLScene.OpenGL4

GL_NEAREST_MIPMAP_NEAREST

GLScene.OpenGL4

TextureMinFilter

GL_NEGATE_BIT_ATI

GLScene.OpenGL4

GL_NEGATIVE_ONE_EXT

GLScene.OpenGL4

GL_NEGATIVE_ONE_TO_ONE

GLScene.OpenGL4

GL_NEGATIVE_W_EXT

GLScene.OpenGL4

GL_NEGATIVE_X_EXT

GLScene.OpenGL4

GL_NEGATIVE_Y_EXT

GLScene.OpenGL4

GL_NEGATIVE_Z_EXT

GLScene.OpenGL4

GL_NEVER

GLScene.OpenGL4

AlphaFunction

GL_NEXT_BUFFER_NV

GLScene.OpenGL4

GL_NEXT_VIDEO_CAPTURE_BUFFER_STATUS_NV

GLScene.OpenGL4

GL_NICEST

GLScene.OpenGL4

GL_NONE

GLScene.OpenGL4

DrawBufferMode

GL_NOOP

GLScene.OpenGL4

GL_NOR

GLScene.OpenGL4

GL_NORMALIZE

GLScene.OpenGL4

GL_NORMALIZED_RANGE_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY

GLScene.OpenGL4

GL_NORMAL_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_NORMAL_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_NORMAL_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_NORMAL_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_NORMAL_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_NORMAL_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_NORMAL_ARRAY_POINTER

GLScene.OpenGL4

GL_NORMAL_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_STRIDE

GLScene.OpenGL4

GL_NORMAL_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_TYPE

GLScene.OpenGL4

GL_NORMAL_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_NORMAL_BIT_PGI

GLScene.OpenGL4

GL_NORMAL_MAP

GLScene.OpenGL4

GL_NORMAL_MAP_ARB

GLScene.OpenGL4

GL_ARB_texture_cube_map

GL_NORMAL_MAP_EXT

GLScene.OpenGL4

GL_EXT_texture_cube_map

GL_NORMAL_MAP_NV

GLScene.OpenGL4

GL_NV_texgen_reflection

GL_NOTEQUAL

GLScene.OpenGL4

GL_NO_ERROR

GLScene.OpenGL4

ErrorCode

GL_NO_RESET_NOTIFICATION

GLScene.OpenGL4

GL_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

GL_NUM_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_NUM_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_NUM_COMPRESSED_TEXTURE_FORMATS

GLScene.OpenGL4

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB

GLScene.OpenGL4

GL_NUM_EXTENSIONS

GLScene.OpenGL4

GL_NUM_FILL_STREAMS_NV

GLScene.OpenGL4

GL_NUM_FRAGMENT_CONSTANTS_ATI

GLScene.OpenGL4

GL_NUM_FRAGMENT_REGISTERS_ATI

GLScene.OpenGL4

GL_NUM_GENERAL_COMBINERS_NV

GLScene.OpenGL4

GL_NUM_INPUT_INTERPOLATOR_COMPONENTS_ATI

GLScene.OpenGL4

GL_NUM_INSTRUCTIONS_PER_PASS_ATI

GLScene.OpenGL4

GL_NUM_INSTRUCTIONS_TOTAL_ATI

GLScene.OpenGL4

GL_NUM_LOOPBACK_COMPONENTS_ATI

GLScene.OpenGL4

GL_NUM_PASSES_ATI

GLScene.OpenGL4

GL_NUM_PROGRAM_BINARY_FORMATS

GLScene.OpenGL4

GL_NUM_SAMPLE_COUNTS

GLScene.OpenGL4

GL_ARB_internalformat_query

GL_NUM_SHADER_BINARY_FORMATS

GLScene.OpenGL4

GL_NUM_SHADING_LANGUAGE_VERSIONS

GLScene.OpenGL4

GL_VERSION_4_1 GL_VERSION_4_2 GL_VERSION_4_3

GL_NUM_SPARSE_LEVELS_ARB

GLScene.OpenGL4

GL_NUM_SPIR_V_EXTENSIONS

GLScene.OpenGL4

GL_NUM_VIDEO_CAPTURE_STREAMS_NV

GLScene.OpenGL4

GL_NUM_VIRTUAL_PAGE_SIZES_ARB

GLScene.OpenGL4

GL_NV_bindless_texture

GLScene.OpenGL4

GL 4.3

GL_NV_blend_square

GLScene.OpenGL4

GL 4.6

GL_NV_conditional_render

GLScene.OpenGL4

GL 4.6

GL_NV_conservative_raster

GLScene.OpenGL4

GL 4.6

GL_NV_conservative_raster_dilate

GLScene.OpenGL4

GL 4.6

GL_NV_copy_depth_to_color

GLScene.OpenGL4

GL 4.6

GL_NV_copy_image

GLScene.OpenGL4

GL 4.6

GL_NV_depth_buffer_float

GLScene.OpenGL4

GL 4.6

GL_NV_depth_clamp

GLScene.OpenGL4

GL 4.6

GL_NV_evaluators

GLScene.OpenGL4

GL 4.6

GL_NV_explicit_multisample

GLScene.OpenGL4

GL 4.6

GL_NV_fence

GLScene.OpenGL4

GL 4.6

GL_NV_float_buffer

GLScene.OpenGL4

GL 4.6

GL_NV_fog_distance

GLScene.OpenGL4

GL 4.6

GL_NV_fragment_program

GLScene.OpenGL4

GL 4.6

GL_NV_fragment_program2

GLScene.OpenGL4

GL 4.6

GL_NV_fragment_program4

GLScene.OpenGL4

GL 4.6

GL_NV_fragment_program_option

GLScene.OpenGL4

GL 4.6

GL_NV_framebuffer_multisample_coverage

GLScene.OpenGL4

GL 4.6

GL_NV_geometry_program4

GLScene.OpenGL4

GL 4.6

GL_NV_gpu_program4

GLScene.OpenGL4

GL 4.6

GL_NV_gpu_program5

GLScene.OpenGL4

GL 4.6

GL_NV_gpu_shader5

GLScene.OpenGL4

GL 4.6

GL_NV_half_float

GLScene.OpenGL4

GL 4.6

GL_NV_light_max_exponent

GLScene.OpenGL4

GL 4.6

GL_NV_multisample_coverage

GLScene.OpenGL4

GL 4.6

GL_NV_multisample_filter_hint

GLScene.OpenGL4

GL 4.6

GL_NV_occlusion_query

GLScene.OpenGL4

GL 4.6

GL_NV_packed_depth_stencil

GLScene.OpenGL4

GL 4.6

GL_NV_parameter_buffer_object

GLScene.OpenGL4

GL 4.6

GL_NV_parameter_buffer_object2

GLScene.OpenGL4

GL 4.6

GL_NV_path_rendering

GLScene.OpenGL4

GL 4.3

GL_NV_pixel_data_range

GLScene.OpenGL4

GL 4.6

GL_NV_point_sprite

GLScene.OpenGL4

GL 4.6

GL_NV_present_video

GLScene.OpenGL4

GL 4.6

GL_NV_primitive_restart

GLScene.OpenGL4

GL 4.6

GL_NV_register_combiners

GLScene.OpenGL4

GL 4.6

GL_NV_register_combiners2

GLScene.OpenGL4

GL 4.6

GL_NV_shader_atomic_float

GLScene.OpenGL4

GL 4.3

GL_NV_shader_buffer_load

GLScene.OpenGL4

GL 4.6

GL_NV_shader_buffer_store

GLScene.OpenGL4

GL 4.6

GL_NV_tessellation_program5

GLScene.OpenGL4

GL 4.6

GL_NV_texgen_emboss

GLScene.OpenGL4

GL 4.6

GL_NV_texgen_reflection

GLScene.OpenGL4

GL 4.6

GL_NV_texture_barrier

GLScene.OpenGL4

GL 4.6

GL_NV_texture_compression_vtc

GLScene.OpenGL4

GL 4.6

GL_NV_texture_env_combine4

GLScene.OpenGL4

GL 4.6

GL_NV_texture_expand_normal

GLScene.OpenGL4

GL 4.6

GL_NV_texture_rectangle

GLScene.OpenGL4

GL 4.6

GL_NV_texture_shader

GLScene.OpenGL4

GL 4.6

GL_NV_texture_shader2

GLScene.OpenGL4

GL 4.6

GL_NV_texture_shader3

GLScene.OpenGL4

GL 4.6

GL_NV_transform_feedback

GLScene.OpenGL4

GL 4.6

GL_NV_transform_feedback2

GLScene.OpenGL4

GL 4.6

GL_NV_vdpau_interop

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_array_range

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_array_range2

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_attrib_integer_64bit

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_buffer_unified_memory

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program1_1

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program2

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program2_option

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program3

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program4

GLScene.OpenGL4

GL 4.6

GL_NV_video_capture

GLScene.OpenGL4

GL 4.6

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_UNIFORMS_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_ATTACHED_OBJECTS_ARB

GLScene.OpenGL4

GL_OBJECT_BUFFER_SIZE_ATI

GLScene.OpenGL4

GL_OBJECT_BUFFER_USAGE_ATI

GLScene.OpenGL4

GL_OBJECT_COMPILE_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_DELETE_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_DISTANCE_TO_LINE_SGIS

GLScene.OpenGL4

GL_OBJECT_DISTANCE_TO_POINT_SGIS

GLScene.OpenGL4

GL_OBJECT_INFO_LOG_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_LINEAR

GLScene.OpenGL4

GL_OBJECT_LINE_SGIS

GLScene.OpenGL4

GL_OBJECT_LINK_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_PLANE

GLScene.OpenGL4

GL_OBJECT_POINT_SGIS

GLScene.OpenGL4

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_SUBTYPE_ARB

GLScene.OpenGL4

GL_OBJECT_TYPE

GLScene.OpenGL4

GL_OBJECT_TYPE_ARB

GLScene.OpenGL4

GL_OBJECT_VALIDATE_STATUS_ARB

GLScene.OpenGL4

GL_OCCLUSION_TEST_HP

GLScene.OpenGL4

GL_HP_occlusion_test

GL_OCCLUSION_TEST_RESULT_HP

GLScene.OpenGL4

GL_OFFSET

GLScene.OpenGL4

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_HILO_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV

GLScene.OpenGL4

GL_NV_texture_shader3

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_BIAS_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_MATRIX_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_BIAS_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_MATRIX_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_NV_texture_shader

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_SCALE_NV

GLScene.OpenGL4

GL_OML_interlace

GLScene.OpenGL4

GL 4.6

GL_OML_resample

GLScene.OpenGL4

GL 4.6

GL_OML_subsample

GLScene.OpenGL4

GL 4.6

GL_ONE

GLScene.OpenGL4

GL_ONE_EXT

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_ALPHA_EXT

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_COLOR_EXT

GLScene.OpenGL4

GL_ONE_MINUS_DST_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_DST_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_SRC1_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_SRC1_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_SRC_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_SRC_COLOR

GLScene.OpenGL4

GL_OPERAND0_ALPHA

GLScene.OpenGL4

GL_OPERAND0_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND0_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND0_RGB

GLScene.OpenGL4

GL_OPERAND0_RGB_ARB

GLScene.OpenGL4

GL_OPERAND0_RGB_EXT

GLScene.OpenGL4

GL_OPERAND1_ALPHA

GLScene.OpenGL4

GL_OPERAND1_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND1_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND1_RGB

GLScene.OpenGL4

GL_OPERAND1_RGB_ARB

GLScene.OpenGL4

GL_OPERAND1_RGB_EXT

GLScene.OpenGL4

GL_OPERAND2_ALPHA

GLScene.OpenGL4

GL_OPERAND2_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND2_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND2_RGB

GLScene.OpenGL4

GL_OPERAND2_RGB_ARB

GLScene.OpenGL4

GL_OPERAND2_RGB_EXT

GLScene.OpenGL4

GL_OPERAND3_ALPHA_NV

GLScene.OpenGL4

GL_OPERAND3_RGB_NV

GLScene.OpenGL4

GL_OP_ADD_EXT

GLScene.OpenGL4

GL_OP_CLAMP_EXT

GLScene.OpenGL4

GL_OP_CROSS_PRODUCT_EXT

GLScene.OpenGL4

GL_OP_DOT3_EXT

GLScene.OpenGL4

GL_OP_DOT4_EXT

GLScene.OpenGL4

GL_OP_EXP_BASE_2_EXT

GLScene.OpenGL4

GL_OP_FLOOR_EXT

GLScene.OpenGL4

GL_OP_FRAC_EXT

GLScene.OpenGL4

GL_OP_INDEX_EXT

GLScene.OpenGL4

GL_OP_LOG_BASE_2_EXT

GLScene.OpenGL4

GL_OP_MADD_EXT

GLScene.OpenGL4

GL_OP_MAX_EXT

GLScene.OpenGL4

GL_OP_MIN_EXT

GLScene.OpenGL4

GL_OP_MOV_EXT

GLScene.OpenGL4

GL_OP_MULTIPLY_MATRIX_EXT

GLScene.OpenGL4

GL_OP_MUL_EXT

GLScene.OpenGL4

GL_OP_NEGATE_EXT

GLScene.OpenGL4

GL_OP_POWER_EXT

GLScene.OpenGL4

GL_OP_RECIP_EXT

GLScene.OpenGL4

GL_OP_RECIP_SQRT_EXT

GLScene.OpenGL4

GL_OP_ROUND_EXT

GLScene.OpenGL4

GL_OP_SET_GE_EXT

GLScene.OpenGL4

GL_OP_SET_LT_EXT

GLScene.OpenGL4

GL_OP_SUB_EXT

GLScene.OpenGL4

GL_OR

GLScene.OpenGL4

GL_ORDER

GLScene.OpenGL4

GL_OR_INVERTED

GLScene.OpenGL4

GL_OR_REVERSE

GLScene.OpenGL4

GL_OUTPUT_COLOR0_EXT

GLScene.OpenGL4

GL_OUTPUT_COLOR1_EXT

GLScene.OpenGL4

GL_OUTPUT_FOG_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD0_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD10_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD11_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD12_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD13_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD14_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD15_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD16_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD17_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD18_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD19_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD1_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD20_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD21_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD22_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD23_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD24_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD25_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD26_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD27_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD28_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD29_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD2_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD30_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD31_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD3_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD4_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD5_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD6_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD7_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD8_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD9_EXT

GLScene.OpenGL4

GL_OUTPUT_VERTEX_EXT

GLScene.OpenGL4

GL_OUT_OF_MEMORY

GLScene.OpenGL4

GL_OVERLAY_KHR

GLScene.OpenGL4

GL_OVR_multiview

GLScene.OpenGL4

GL 4.6

GL_OVR_multiview2

GLScene.OpenGL4

GL 4.6

GL_PACK_ALIGNMENT

GLScene.OpenGL4

GL_PACK_CMYK_HINT_EXT

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_DEPTH

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_PACK_IMAGE_DEPTH_SGIS

GLScene.OpenGL4

GL_PACK_IMAGE_HEIGHT

GLScene.OpenGL4

GL_PACK_IMAGE_HEIGHT_EXT

GLScene.OpenGL4

GL_PACK_LSB_FIRST

GLScene.OpenGL4

GL_PACK_RESAMPLE_OML

GLScene.OpenGL4

GL_OML_resample

GL_PACK_RESAMPLE_SGIX

GLScene.OpenGL4

GL_SGIX_resample

GL_PACK_ROW_BYTES_APPLE

GLScene.OpenGL4

GL_APPLE_row_bytes

GL_PACK_ROW_LENGTH

GLScene.OpenGL4

GL_PACK_SKIP_IMAGES

GLScene.OpenGL4

GL_PACK_SKIP_IMAGES_EXT

GLScene.OpenGL4

GL_EXT_texture3D

GL_PACK_SKIP_PIXELS

GLScene.OpenGL4

GL_PACK_SKIP_ROWS

GLScene.OpenGL4

GL_PACK_SKIP_VOLUMES_SGIS

GLScene.OpenGL4

GL_SGIS_texture4D

GL_PACK_SUBSAMPLE_RATE_SGIX

GLScene.OpenGL4

GL_SGIX_subsample

GL_PACK_SWAP_BYTES

GLScene.OpenGL4

GL_PARALLEL_ARRAYS_INTEL

GLScene.OpenGL4

GL_INTEL_parallel_arrays

GL_PARAMETER_BUFFER

GLScene.OpenGL4

GL_PARAMETER_BUFFER_BINDING

GLScene.OpenGL4

GL_PARTIAL_SUCCESS_NV

GLScene.OpenGL4

GL_PASS_THROUGH_NV

GLScene.OpenGL4

GL_PASS_THROUGH_TOKEN

GLScene.OpenGL4

GL_PATCHES

GLScene.OpenGL4

GL_ARB_tessellation_shader

GL_PATCH_DEFAULT_INNER_LEVEL

GLScene.OpenGL4

GL_PATCH_DEFAULT_OUTER_LEVEL

GLScene.OpenGL4

GL_PATCH_VERTICES

GLScene.OpenGL4

GL_PATH_CLIENT_LENGTH_NV

GLScene.OpenGL4

GL_PATH_COMMAND_COUNT_NV

GLScene.OpenGL4

GL_PATH_COMPUTED_LENGTH_NV

GLScene.OpenGL4

GL_PATH_COORD_COUNT_NV

GLScene.OpenGL4

GL_PATH_COVER_DEPTH_FUNC_NV

GLScene.OpenGL4

GL_PATH_DASH_ARRAY_COUNT_NV

GLScene.OpenGL4

GL_PATH_DASH_CAPS_NV

GLScene.OpenGL4

GL_PATH_DASH_OFFSET_NV

GLScene.OpenGL4

GL_PATH_DASH_OFFSET_RESET_NV

GLScene.OpenGL4

GL_PATH_END_CAPS_NV

GLScene.OpenGL4

GL_PATH_ERROR_POSITION_NV

GLScene.OpenGL4

GL_PATH_FILL_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_FILL_COVER_MODE_NV

GLScene.OpenGL4

GL_PATH_FILL_MASK_NV

GLScene.OpenGL4

GL_PATH_FILL_MODE_NV

GLScene.OpenGL4

GL_PATH_FOG_GEN_MODE_NV

GLScene.OpenGL4

GL_PATH_FORMAT_PS_NV

GLScene.OpenGL4

GL_PATH_FORMAT_SVG_NV

GLScene.OpenGL4

(4.3) GL_NV_path_rendering

GL_PATH_GEN_COEFF_NV

GLScene.OpenGL4

GL_PATH_GEN_COLOR_FORMAT_NV

GLScene.OpenGL4

GL_PATH_GEN_COMPONENTS_NV

GLScene.OpenGL4

GL_PATH_GEN_MODE_NV

GLScene.OpenGL4

GL_PATH_INITIAL_DASH_CAP_NV

GLScene.OpenGL4

GL_PATH_INITIAL_END_CAP_NV

GLScene.OpenGL4

GL_PATH_JOIN_STYLE_NV

GLScene.OpenGL4

GL_PATH_MITER_LIMIT_NV

GLScene.OpenGL4

GL_PATH_OBJECT_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_SAMPLE_QUALITY_NV

GLScene.OpenGL4

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV

GLScene.OpenGL4

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV

GLScene.OpenGL4

GL_PATH_STENCIL_FUNC_NV

GLScene.OpenGL4

GL_PATH_STENCIL_REF_NV

GLScene.OpenGL4

GL_PATH_STENCIL_VALUE_MASK_NV

GLScene.OpenGL4

GL_PATH_STROKE_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_STROKE_BOUND_NV

GLScene.OpenGL4

GL_PATH_STROKE_COVER_MODE_NV

GLScene.OpenGL4

GL_PATH_STROKE_MASK_NV

GLScene.OpenGL4

GL_PATH_STROKE_OVERSAMPLE_COUNT_NV

GLScene.OpenGL4

GL_PATH_STROKE_WIDTH_NV

GLScene.OpenGL4

GL_PATH_TERMINAL_DASH_CAP_NV

GLScene.OpenGL4

GL_PATH_TERMINAL_END_CAP_NV

GLScene.OpenGL4

GL_PERCENTAGE_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_AVAILABLE_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_SIZE_AMD

GLScene.OpenGL4

GL_PERFORMANCE_MONITOR_AMD

GLScene.OpenGL4

GL_PERSPECTIVE_CORRECTION_HINT

GLScene.OpenGL4

GL_PERTURB_EXT

GLScene.OpenGL4

GL_EXT_texture_perturb_normal

GL_PER_STAGE_CONSTANTS_NV

GLScene.OpenGL4

GL_NV_register_combiners2

GL_PGI_misc_hints

GLScene.OpenGL4

GL 4.6

GL_PGI_vertex_hints

GLScene.OpenGL4

GL 4.6

GL_PHONG_HINT_WIN

GLScene.OpenGL4

GL_PHONG_WIN

GLScene.OpenGL4

GL_WIN_phong_shading

GL_PIXEL_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_PIXEL_BUFFER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_PIXEL_COUNTER_BITS_NV

GLScene.OpenGL4

GL_NV_occlusion_query

GL_PIXEL_COUNT_AVAILABLE_NV

GLScene.OpenGL4

GL_PIXEL_COUNT_NV

GLScene.OpenGL4

GL_PIXEL_CUBIC_WEIGHT_EXT

GLScene.OpenGL4

GL_PIXEL_FRAGMENT_ALPHA_SOURCE_SGIS

GLScene.OpenGL4

GL_PIXEL_FRAGMENT_RGB_SOURCE_SGIS

GLScene.OpenGL4

GL_PIXEL_GROUP_COLOR_SGIS

GLScene.OpenGL4

GL_PIXEL_MAG_FILTER_EXT

GLScene.OpenGL4

GL_PIXEL_MAP_A_TO_A

GLScene.OpenGL4

GL_PIXEL_MAP_A_TO_A_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_B_TO_B

GLScene.OpenGL4

GL_PIXEL_MAP_B_TO_B_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_G_TO_G

GLScene.OpenGL4

GL_PIXEL_MAP_G_TO_G_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_A

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_A_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_B

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_B_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_G

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_G_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_I

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_I_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_R

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_R_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_R_TO_R

GLScene.OpenGL4

GL_PIXEL_MAP_R_TO_R_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_S_TO_S

GLScene.OpenGL4

GL_PIXEL_MAP_S_TO_S_SIZE

GLScene.OpenGL4

GL_PIXEL_MIN_FILTER_EXT

GLScene.OpenGL4

GL_PIXEL_MODE_BIT

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER

GLScene.OpenGL4

GL_VERSION_2_1

GL_PIXEL_PACK_BUFFER_ARB

GLScene.OpenGL4

GL_ARB_pixel_buffer_object

GL_PIXEL_PACK_BUFFER_BINDING

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_pixel_buffer_object

GL_PIXEL_SUBSAMPLE_2424_SGIX

GLScene.OpenGL4

GL_PIXEL_SUBSAMPLE_4242_SGIX

GLScene.OpenGL4

GL_PIXEL_SUBSAMPLE_4444_SGIX

GLScene.OpenGL4

GL_PIXEL_TEXTURE_SGIS

GLScene.OpenGL4

GL_SGIS_pixel_texture

GL_PIXEL_TEX_GEN_ALPHA_LS_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_MS_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_NO_REPLACE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_REPLACE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_MODE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_Q_CEILING_SGIX

GLScene.OpenGL4

GL_SGIX_impact_pixel_texture

GL_PIXEL_TEX_GEN_Q_FLOOR_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_Q_ROUND_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_SGIX

GLScene.OpenGL4

GL_SGIX_pixel_texture

GL_PIXEL_TILE_BEST_ALIGNMENT_SGIX

GLScene.OpenGL4

GL_SGIX_pixel_tiles

GL_PIXEL_TILE_CACHE_INCREMENT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_CACHE_SIZE_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_DEPTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_HEIGHT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_WIDTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_HEIGHT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_WIDTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TRANSFORM_2D_EXT

GLScene.OpenGL4

GL_EXT_pixel_transform

GL_PIXEL_TRANSFORM_2D_MATRIX_EXT

GLScene.OpenGL4

GL_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_ARB

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_EXT

GLScene.OpenGL4

GL_PN_TRIANGLES_ATI

GLScene.OpenGL4

GL_ATI_pn_triangles

GL_PN_TRIANGLES_NORMAL_MODE_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_NORMAL_MODE_LINEAR_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_NORMAL_MODE_QUADRATIC_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_CUBIC_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_LINEAR_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_TESSELATION_LEVEL_ATI

GLScene.OpenGL4

GL_POINT

GLScene.OpenGL4

PolygonMode

GL_POINTS

GLScene.OpenGL4

BeginMode

GL_POINT_BIT

GLScene.OpenGL4

GL_POINT_DISTANCE_ATTENUATION

GLScene.OpenGL4

GL_POINT_DISTANCE_ATTENUATION_ARB

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_ARB

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_EXT

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_SGIS

GLScene.OpenGL4

GL_POINT_SIZE

GLScene.OpenGL4

GetPName

GL_POINT_SIZE_GRANULARITY

GLScene.OpenGL4

GL_POINT_SIZE_MAX

GLScene.OpenGL4

GL_POINT_SIZE_MAX_ARB

GLScene.OpenGL4

GL_POINT_SIZE_MAX_EXT

GLScene.OpenGL4

GL_POINT_SIZE_MAX_SGIS

GLScene.OpenGL4

GL_POINT_SIZE_MIN

GLScene.OpenGL4

GL_POINT_SIZE_MIN_ARB

GLScene.OpenGL4

GL_ARB_point_parameters

GL_POINT_SIZE_MIN_EXT

GLScene.OpenGL4

GL_EXT_point_parameters

GL_POINT_SIZE_MIN_SGIS

GLScene.OpenGL4

GL_SGIS_point_parameters

GL_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_POINT_SMOOTH

GLScene.OpenGL4

GL_POINT_SMOOTH_HINT

GLScene.OpenGL4

GL_POINT_SPRITE

GLScene.OpenGL4

GL_POINT_SPRITE_ARB

GLScene.OpenGL4

GL_ARB_point_sprite

GL_POINT_SPRITE_COORD_ORIGIN

GLScene.OpenGL4

GL_POINT_SPRITE_NV

GLScene.OpenGL4

GL_NV_point_sprite

GL_POINT_SPRITE_R_MODE_NV

GLScene.OpenGL4

GL_POINT_TOKEN

GLScene.OpenGL4

GL_POLYGON

GLScene.OpenGL4

GL_POLYGON_BIT

GLScene.OpenGL4

GL_POLYGON_MODE

GLScene.OpenGL4

GL_POLYGON_OFFSET_BIAS_EXT

GLScene.OpenGL4

GL_POLYGON_OFFSET_CLAMP

GLScene.OpenGL4

GL_POLYGON_OFFSET_EXT

GLScene.OpenGL4

GL_EXT_polygon_offset

GL_POLYGON_OFFSET_FACTOR

GLScene.OpenGL4

GL_POLYGON_OFFSET_FACTOR_EXT

GLScene.OpenGL4

GL_POLYGON_OFFSET_FILL

GLScene.OpenGL4

GL_POLYGON_OFFSET_LINE

GLScene.OpenGL4

GL_POLYGON_OFFSET_POINT

GLScene.OpenGL4

GL_POLYGON_OFFSET_UNITS

GLScene.OpenGL4

GL_POLYGON_SMOOTH

GLScene.OpenGL4

GL_POLYGON_SMOOTH_HINT

GLScene.OpenGL4

GL_POLYGON_STIPPLE

GLScene.OpenGL4

GL_POLYGON_STIPPLE_BIT

GLScene.OpenGL4

GL_POLYGON_TOKEN

GLScene.OpenGL4

GL_POSITION

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_COLOR_TABLE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_SCALE_SGI

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_COLOR_TABLE

GLScene.OpenGL4

GL_POST_CONVOLUTION_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_SCALE_EXT

GLScene.OpenGL4

GL_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_BIAS_RANGE_SGIX

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_BIAS_SGIX

GLScene.OpenGL4

GL_SGIX_texture_scale_bias

GL_POST_TEXTURE_FILTER_SCALE_RANGE_SGIX

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_SCALE_SGIX

GLScene.OpenGL4

GL_PREFER_DOUBLEBUFFER_HINT_PGI

GLScene.OpenGL4

GL_PGI_misc_hints

GL_PRESENT_DURATION_NV

GLScene.OpenGL4

GL_PRESENT_TIME_NV

GLScene.OpenGL4

GL_PRESERVE_ATI

GLScene.OpenGL4

GL_PREVIOUS

GLScene.OpenGL4

GL_PREVIOUS_ARB

GLScene.OpenGL4

GL_PREVIOUS_EXT

GLScene.OpenGL4

GL_PREVIOUS_TEXTURE_INPUT_NV

GLScene.OpenGL4

GL_PRIMARY_COLOR

GLScene.OpenGL4

GL_PRIMARY_COLOR_ARB

GLScene.OpenGL4

GL_PRIMARY_COLOR_EXT

GLScene.OpenGL4

GL_PRIMARY_COLOR_NV

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED_EXT

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED_NV

GLScene.OpenGL4

GL_PRIMITIVES_SUBMITTED

GLScene.OpenGL4

GL_PRIMITIVES_SUBMITTED_ARB

GLScene.OpenGL4

GL_PRIMITIVE_BOUNDING_BOX_ARB

GLScene.OpenGL4

GL_ARB_ES3_2_compatibility

GL_PRIMITIVE_ID_NV

GLScene.OpenGL4

GL_PRIMITIVE_RESTART

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_FIXED_INDEX

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_FOR_PATCHES_SUPPORTED

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_INDEX

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_INDEX_NV

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_NV

GLScene.OpenGL4

GL_NV_primitive_restart

GL_PROGRAM

GLScene.OpenGL4

GL_PROGRAMMABLE_SAMPLE_LOCATION_ARB

GLScene.OpenGL4

GL_PROGRAMMABLE_SAMPLE_LOCATION_TABLE_SIZE_ARB

GLScene.OpenGL4

GL_PROGRAM_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_PROGRAM_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_ATTRIBS_ARB

GLScene.OpenGL4

GL_PROGRAM_ATTRIB_COMPONENTS_NV

GLScene.OpenGL4

GL_NV_gpu_program4

GL_PROGRAM_BINARY_FORMATS

GLScene.OpenGL4

GL_PROGRAM_BINARY_LENGTH

GLScene.OpenGL4

GL_PROGRAM_BINARY_RETRIEVABLE_HINT

GLScene.OpenGL4

GL_ARB_get_program_binary

GL_PROGRAM_BINDING_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_POSITION_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_POSITION_NV

GLScene.OpenGL4

GL_PROGRAM_ERROR_STRING_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_STRING_NV

GLScene.OpenGL4

GL_PROGRAM_FORMAT_ARB

GLScene.OpenGL4

GL_PROGRAM_FORMAT_ASCII_ARB

GLScene.OpenGL4

GL_PROGRAM_INPUT

GLScene.OpenGL4

GL_PROGRAM_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_LENGTH_ARB

GLScene.OpenGL4

GL_PROGRAM_LENGTH_NV

GLScene.OpenGL4

GL_PROGRAM_MATRIX_EXT

GLScene.OpenGL4

GL_EXT_direct_state_access

GL_PROGRAM_MATRIX_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ATTRIBS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_PARAMETERS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEMPORARIES_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_OBJECT_ARB

GLScene.OpenGL4

1.4 GL_ARB_shader_objects

GL_PROGRAM_OUTPUT

GLScene.OpenGL4

GL_PROGRAM_PARAMETERS_ARB

GLScene.OpenGL4

GL_PROGRAM_PARAMETER_NV

GLScene.OpenGL4

GL_PROGRAM_PIPELINE

GLScene.OpenGL4

GL_PROGRAM_PIPELINE_BINDING

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE_ARB

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE_EXT

GLScene.OpenGL4

GL_PROGRAM_RESIDENT_NV

GLScene.OpenGL4

GL_PROGRAM_RESULT_COMPONENTS_NV

GLScene.OpenGL4

GL_PROGRAM_SEPARABLE

GLScene.OpenGL4

GL_PROGRAM_STRING_ARB

GLScene.OpenGL4

GL_PROGRAM_STRING_NV

GLScene.OpenGL4

GL_PROGRAM_TARGET_NV

GLScene.OpenGL4

GL_PROGRAM_TEMPORARIES_ARB

GLScene.OpenGL4

GL_PROGRAM_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB

GLScene.OpenGL4

GL_PROJECTION

GLScene.OpenGL4

GL_PROJECTION_MATRIX

GLScene.OpenGL4

GL_PROJECTION_STACK_DEPTH

GLScene.OpenGL4

GL_PROJECTIVE_2D_NV

GLScene.OpenGL4

GL_PROJECTIVE_3D_NV

GLScene.OpenGL4

GL_PROVOKING_VERTEX

GLScene.OpenGL4

GL_PROVOKING_VERTEX_EXT

GLScene.OpenGL4

GL_PROXY_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_HISTOGRAM

GLScene.OpenGL4

GL_PROXY_HISTOGRAM_EXT

GLScene.OpenGL4

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D

GLScene.OpenGL4

TextureTarget

GL_PROXY_TEXTURE_1D_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_3D

GLScene.OpenGL4

GL_PROXY_TEXTURE_3D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_4D_SGIS

GLScene.OpenGL4

GL_PROXY_TEXTURE_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_PURGEABLE_APPLE

GLScene.OpenGL4

GL_Q

GLScene.OpenGL4

GL_QUADRATIC_ATTENUATION

GLScene.OpenGL4

GL_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_QUADS

GLScene.OpenGL4

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION

GLScene.OpenGL4

GL_ARB_provoking_vertex

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_EXT_provoking_vertex

GL_QUAD_ALPHA4_SGIS

GLScene.OpenGL4

GL_QUAD_ALPHA8_SGIS

GLScene.OpenGL4

GL_QUAD_INTENSITY4_SGIS

GLScene.OpenGL4

GL_QUAD_INTENSITY8_SGIS

GLScene.OpenGL4

GL_QUAD_LUMINANCE4_SGIS

GLScene.OpenGL4

GL_QUAD_LUMINANCE8_SGIS

GLScene.OpenGL4

GL_QUAD_MESH_SUN

GLScene.OpenGL4

GL_SUN_mesh_array

GL_QUAD_STRIP

GLScene.OpenGL4

GL_QUAD_TEXTURE_SELECT_SGIS

GLScene.OpenGL4

GL_QUARTER_BIT_ATI

GLScene.OpenGL4

GL_QUERY

GLScene.OpenGL4

GL_QUERY_BUFFER

GLScene.OpenGL4

GL_QUERY_BUFFER_AMD

GLScene.OpenGL4

(4.3) GL_AMD_vertex_shader_viewport_index (4.3) GL_AMD_vertex_shader_layer (4.3) GL_NV_bindless_texture (4.3) GL_NV_shader_atomic_float (4.3) GL_AMD_query_buffer_object

GL_QUERY_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_QUERY_BUFFER_BINDING

GLScene.OpenGL4

GL_QUERY_BUFFER_BINDING_AMD

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT_NV

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT_NV

GLScene.OpenGL4

GL_QUERY_COUNTER_BITS

GLScene.OpenGL4

GL_QUERY_COUNTER_BITS_ARB

GLScene.OpenGL4

GL_QUERY_NO_WAIT

GLScene.OpenGL4

GL_QUERY_NO_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_NO_WAIT_NV

GLScene.OpenGL4

GL_QUERY_OBJECT_AMD

GLScene.OpenGL4

GL_QUERY_RESULT

GLScene.OpenGL4

GL_QUERY_RESULT_ARB

GLScene.OpenGL4

GL_QUERY_RESULT_AVAILABLE

GLScene.OpenGL4

GL_QUERY_RESULT_AVAILABLE_ARB

GLScene.OpenGL4

GL_QUERY_RESULT_NO_WAIT

GLScene.OpenGL4

GL_QUERY_RESULT_NO_WAIT_AMD

GLScene.OpenGL4

GL_QUERY_TARGET

GLScene.OpenGL4

GL_QUERY_WAIT

GLScene.OpenGL4

GL_QUERY_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_WAIT_NV

GLScene.OpenGL4

GL_NV_conditional_render

GL_R

GLScene.OpenGL4

GL_R11F_G11F_B10F

GLScene.OpenGL4

GL_R11F_G11F_B10F_EXT

GLScene.OpenGL4

GL_EXT_packed_float

GL_R16

GLScene.OpenGL4

GL_R16F

GLScene.OpenGL4

GL_R16I

GLScene.OpenGL4

GL_R16UI

GLScene.OpenGL4

GL_R16_SNORM

GLScene.OpenGL4

GL_R1UI_C3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_C4F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_C4UB_V3F_SUN

GLScene.OpenGL4

GL_R1UI_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_C4F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_V3F_SUN

GLScene.OpenGL4

GL_R32F

GLScene.OpenGL4

GL_R32I

GLScene.OpenGL4

GL_R32UI

GLScene.OpenGL4

GL_R3_G3_B2

GLScene.OpenGL4

PixelInternalFormat

GL_R8

GLScene.OpenGL4

GL_R8I

GLScene.OpenGL4

GL_R8UI

GLScene.OpenGL4

GL_R8_SNORM

GLScene.OpenGL4

GL_RASTERIZER_DISCARD

GLScene.OpenGL4

GL_RASTERIZER_DISCARD_EXT

GLScene.OpenGL4

GL_RASTERIZER_DISCARD_NV

GLScene.OpenGL4

GL_RASTER_POSITION_UNCLIPPED_IBM

GLScene.OpenGL4

GL_IBM_rasterpos_clip

GL_READ_BUFFER

GLScene.OpenGL4

GL_READ_FRAMEBUFFER

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_blit

GL_READ_ONLY

GLScene.OpenGL4

GL_READ_ONLY_ARB

GLScene.OpenGL4

GL_READ_PIXELS

GLScene.OpenGL4

GL_READ_PIXELS_FORMAT

GLScene.OpenGL4

GL_READ_PIXELS_TYPE

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_NV

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_POINTER_NV

GLScene.OpenGL4

GL_READ_WRITE

GLScene.OpenGL4

GL_READ_WRITE_ARB

GLScene.OpenGL4

GL_RECLAIM_MEMORY_HINT_PGI

GLScene.OpenGL4

GL_RECT_NV

GLScene.OpenGL4

GL_RED

GLScene.OpenGL4

GL_REDUCE

GLScene.OpenGL4

GL_REDUCE_EXT

GLScene.OpenGL4

GL_RED_BIAS

GLScene.OpenGL4

GL_RED_BITS

GLScene.OpenGL4

GL_RED_BIT_ATI

GLScene.OpenGL4

GL_RED_INTEGER

GLScene.OpenGL4

GL_RED_INTEGER_EXT

GLScene.OpenGL4

GL_RED_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_RED_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_INGR_color_clamp

GL_RED_SCALE

GLScene.OpenGL4

GL_RED_SNORM

GLScene.OpenGL4

GL_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_REFERENCE_PLANE_EQUATION_SGIX

GLScene.OpenGL4

GL_REFERENCE_PLANE_SGIX

GLScene.OpenGL4

GL_SGIX_reference_plane

GL_REFLECTION_MAP

GLScene.OpenGL4

GL_REFLECTION_MAP_ARB

GLScene.OpenGL4

GL_REFLECTION_MAP_EXT

GLScene.OpenGL4

GL_REFLECTION_MAP_NV

GLScene.OpenGL4

GL_REGISTER_COMBINERS_NV

GLScene.OpenGL4

GL_NV_register_combiners

GL_REG_0_ATI

GLScene.OpenGL4

GL_REG_10_ATI

GLScene.OpenGL4

GL_REG_11_ATI

GLScene.OpenGL4

GL_REG_12_ATI

GLScene.OpenGL4

GL_REG_13_ATI

GLScene.OpenGL4

GL_REG_14_ATI

GLScene.OpenGL4

GL_REG_15_ATI

GLScene.OpenGL4

GL_REG_16_ATI

GLScene.OpenGL4

GL_REG_17_ATI

GLScene.OpenGL4

GL_REG_18_ATI

GLScene.OpenGL4

GL_REG_19_ATI

GLScene.OpenGL4

GL_REG_1_ATI

GLScene.OpenGL4

GL_REG_20_ATI

GLScene.OpenGL4

GL_REG_21_ATI

GLScene.OpenGL4

GL_REG_22_ATI

GLScene.OpenGL4

GL_REG_23_ATI

GLScene.OpenGL4

GL_REG_24_ATI

GLScene.OpenGL4

GL_REG_25_ATI

GLScene.OpenGL4

GL_REG_26_ATI

GLScene.OpenGL4

GL_REG_27_ATI

GLScene.OpenGL4

GL_REG_28_ATI

GLScene.OpenGL4

GL_REG_29_ATI

GLScene.OpenGL4

GL_REG_2_ATI

GLScene.OpenGL4

GL_REG_30_ATI

GLScene.OpenGL4

GL_REG_31_ATI

GLScene.OpenGL4

GL_REG_3_ATI

GLScene.OpenGL4

GL_REG_4_ATI

GLScene.OpenGL4

GL_REG_5_ATI

GLScene.OpenGL4

GL_REG_6_ATI

GLScene.OpenGL4

GL_REG_7_ATI

GLScene.OpenGL4

GL_REG_8_ATI

GLScene.OpenGL4

GL_REG_9_ATI

GLScene.OpenGL4

GL_RELATIVE_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_HORIZONTAL_LINE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LARGE_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LARGE_CW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LINE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_MOVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMALL_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMALL_CW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_VERTICAL_LINE_TO_NV

GLScene.OpenGL4

GL_RELEASED_APPLE

GLScene.OpenGL4

GL_RENDER

GLScene.OpenGL4

GL_RENDERBUFFER

GLScene.OpenGL4

GL_RENDERBUFFER_ALPHA_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_BINDING

GLScene.OpenGL4

GL_RENDERBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_BLUE_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_RENDERBUFFER_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_framebuffer_multisample_coverage

GL_RENDERBUFFER_DEPTH_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_RENDERBUFFER_GREEN_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_HEIGHT

GLScene.OpenGL4

GL_RENDERBUFFER_HEIGHT_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_INTERNAL_FORMAT

GLScene.OpenGL4

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_RED_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_SAMPLES

GLScene.OpenGL4

GL_RENDERBUFFER_SAMPLES_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_multisample

GL_RENDERBUFFER_STENCIL_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_WIDTH

GLScene.OpenGL4

GL_RENDERBUFFER_WIDTH_EXT

GLScene.OpenGL4

GL_RENDERER

GLScene.OpenGL4

GL_RENDER_MODE

GLScene.OpenGL4

GL_REND_screen_coordinates

GLScene.OpenGL4

GL 4.6

GL_REPEAT

GLScene.OpenGL4

TextureWrapMode

GL_REPLACE

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_POINTER_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_STRIDE_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_TYPE_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_SUN

GLScene.OpenGL4

GL_REPLACE_EXT

GLScene.OpenGL4

GL_REPLACE_MIDDLE_SUN

GLScene.OpenGL4

GL_REPLACE_OLDEST_SUN

GLScene.OpenGL4

GL_REPLACE_VALUE_AMD

GLScene.OpenGL4

GL_REPLICATE_BORDER

GLScene.OpenGL4

GL_REPLICATE_BORDER_HP

GLScene.OpenGL4

GL_RESAMPLE_AVERAGE_OML

GLScene.OpenGL4

GL_RESAMPLE_DECIMATE_OML

GLScene.OpenGL4

GL_RESAMPLE_DECIMATE_SGIX

GLScene.OpenGL4

GL_RESAMPLE_REPLICATE_OML

GLScene.OpenGL4

GL_RESAMPLE_REPLICATE_SGIX

GLScene.OpenGL4

GL_RESAMPLE_ZERO_FILL_OML

GLScene.OpenGL4

GL_RESAMPLE_ZERO_FILL_SGIX

GLScene.OpenGL4

GL_RESCALE_NORMAL

GLScene.OpenGL4

GL_RESCALE_NORMAL_EXT

GLScene.OpenGL4

GL_EXT_rescale_normal

GL_RESET_NOTIFICATION_STRATEGY

GLScene.OpenGL4

GL_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

GL_RESTART_PATH_NV

GLScene.OpenGL4

GL_RESTART_SUN

GLScene.OpenGL4

GL_SUN_triangle_list

GL_RETAINED_APPLE

GLScene.OpenGL4

GL_RETURN

GLScene.OpenGL4

GL_RG

GLScene.OpenGL4

GL_ARB_texture_rg

GL_RG16

GLScene.OpenGL4

GL_RG16F

GLScene.OpenGL4

GL_RG16I

GLScene.OpenGL4

GL_RG16UI

GLScene.OpenGL4

GL_RG16_SNORM

GLScene.OpenGL4

GL_RG32F

GLScene.OpenGL4

GL_RG32I

GLScene.OpenGL4

GL_RG32UI

GLScene.OpenGL4

GL_RG8

GLScene.OpenGL4

GL_RG8I

GLScene.OpenGL4

GL_RG8UI

GLScene.OpenGL4

GL_RG8_SNORM

GLScene.OpenGL4

GL_RGB

GLScene.OpenGL4

GL_RGB10

GLScene.OpenGL4

GL_RGB10_A2

GLScene.OpenGL4

GL_RGB10_A2UI

GLScene.OpenGL4

GL_ARB_texture_rgb10_a2ui

GL_RGB10_A2_EXT

GLScene.OpenGL4

GL_RGB10_EXT

GLScene.OpenGL4

GL_RGB12

GLScene.OpenGL4

GL_RGB12_EXT

GLScene.OpenGL4

GL_RGB16

GLScene.OpenGL4

GL_RGB16F

GLScene.OpenGL4

GL_RGB16F_ARB

GLScene.OpenGL4

GL_RGB16I

GLScene.OpenGL4

GL_RGB16I_EXT

GLScene.OpenGL4

GL_RGB16UI

GLScene.OpenGL4

GL_RGB16UI_EXT

GLScene.OpenGL4

GL_RGB16_EXT

GLScene.OpenGL4

GL_RGB16_SNORM

GLScene.OpenGL4

GL_RGB2_EXT

GLScene.OpenGL4

GL_RGB32F

GLScene.OpenGL4

GL_RGB32F_ARB

GLScene.OpenGL4

GL_RGB32I

GLScene.OpenGL4

GL_RGB32I_EXT

GLScene.OpenGL4

GL_RGB32UI

GLScene.OpenGL4

GL_RGB32UI_EXT

GLScene.OpenGL4

GL_RGB4

GLScene.OpenGL4

GL_RGB4_EXT

GLScene.OpenGL4

GL_RGB4_S3TC

GLScene.OpenGL4

GL_RGB5

GLScene.OpenGL4

GL_RGB565

GLScene.OpenGL4

GL_RGB5_A1

GLScene.OpenGL4

GL_RGB5_A1_EXT

GLScene.OpenGL4

GL_RGB5_EXT

GLScene.OpenGL4

GL_RGB8

GLScene.OpenGL4

GL_RGB8I

GLScene.OpenGL4

GL_RGB8I_EXT

GLScene.OpenGL4

GL_RGB8UI

GLScene.OpenGL4

GL_RGB8UI_EXT

GLScene.OpenGL4

GL_RGB8_EXT

GLScene.OpenGL4

GL_RGB8_SNORM

GLScene.OpenGL4

GL_RGB9_E5

GLScene.OpenGL4

GL_RGB9_E5_EXT

GLScene.OpenGL4

GL_EXT_texture_shared_exponent

GL_RGBA

GLScene.OpenGL4

GL_RGBA12

GLScene.OpenGL4

GL_RGBA12_EXT

GLScene.OpenGL4

GL_RGBA16

GLScene.OpenGL4

GL_RGBA16F

GLScene.OpenGL4

GL_RGBA16F_ARB

GLScene.OpenGL4

GL_RGBA16I

GLScene.OpenGL4

GL_RGBA16I_EXT

GLScene.OpenGL4

GL_RGBA16UI

GLScene.OpenGL4

GL_RGBA16UI_EXT

GLScene.OpenGL4

GL_RGBA16_EXT

GLScene.OpenGL4

GL_RGBA16_SNORM

GLScene.OpenGL4

GL_RGBA2

GLScene.OpenGL4

GL_RGBA2_EXT

GLScene.OpenGL4

GL_RGBA32F

GLScene.OpenGL4

GL_RGBA32F_ARB

GLScene.OpenGL4

GL_RGBA32I

GLScene.OpenGL4

GL_RGBA32I_EXT

GLScene.OpenGL4

GL_RGBA32UI

GLScene.OpenGL4

GL_RGBA32UI_EXT

GLScene.OpenGL4

GL_RGBA4

GLScene.OpenGL4

GL_RGBA4_EXT

GLScene.OpenGL4

GL_RGBA4_S3TC

GLScene.OpenGL4

GL_RGBA8

GLScene.OpenGL4

GL_RGBA8I

GLScene.OpenGL4

GL_RGBA8I_EXT

GLScene.OpenGL4

GL_RGBA8UI

GLScene.OpenGL4

GL_RGBA8UI_EXT

GLScene.OpenGL4

GL_RGBA8_EXT

GLScene.OpenGL4

GL_RGBA8_SNORM

GLScene.OpenGL4

GL_RGBA_FLOAT16_APPLE

GLScene.OpenGL4

GL_RGBA_FLOAT16_ATI

GLScene.OpenGL4

GL_RGBA_FLOAT32_APPLE

GLScene.OpenGL4

GL_RGBA_FLOAT32_ATI

GLScene.OpenGL4

GL_ATI_texture_float

GL_RGBA_FLOAT_MODE_ARB

GLScene.OpenGL4

GL_ARB_color_buffer_float

GL_RGBA_INTEGER

GLScene.OpenGL4

GL_RGBA_INTEGER_EXT

GLScene.OpenGL4

GL_RGBA_INTEGER_MODE_EXT

GLScene.OpenGL4

GL_EXT_texture_integer

GL_RGBA_MODE

GLScene.OpenGL4

GL_RGBA_S3TC

GLScene.OpenGL4

GL_RGBA_SNORM

GLScene.OpenGL4

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV

GLScene.OpenGL4

GL_RGB_FLOAT16_APPLE

GLScene.OpenGL4

GL_RGB_FLOAT16_ATI

GLScene.OpenGL4

GL_RGB_FLOAT32_APPLE

GLScene.OpenGL4

GL_RGB_FLOAT32_ATI

GLScene.OpenGL4

GL_RGB_INTEGER

GLScene.OpenGL4

GL_RGB_INTEGER_EXT

GLScene.OpenGL4

GL_RGB_RAW_422_APPLE

GLScene.OpenGL4

GL_RGB_S3TC

GLScene.OpenGL4

GL_S3_s3tc

GL_RGB_SCALE

GLScene.OpenGL4

GL_RGB_SCALE_ARB

GLScene.OpenGL4

GL_RGB_SCALE_EXT

GLScene.OpenGL4

GL_RGB_SNORM

GLScene.OpenGL4

GL_RG_INTEGER

GLScene.OpenGL4

GL_RG_SNORM

GLScene.OpenGL4

GL_RIGHT

GLScene.OpenGL4

GL_ROUND_NV

GLScene.OpenGL4

GL_S

GLScene.OpenGL4

GL_S3_s3tc

GLScene.OpenGL4

GL 4.6

GL_SAMPLER

GLScene.OpenGL4

GL_SAMPLER_1D

GLScene.OpenGL4

GL_SAMPLER_1D_ARB

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_1D_SHADOW

GLScene.OpenGL4

GL_SAMPLER_1D_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_2D

GLScene.OpenGL4

GL_SAMPLER_2D_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_VERSION_3_1

GL_SAMPLER_2D_RECT_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_RECT_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_RECT_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_3D

GLScene.OpenGL4

GL_SAMPLER_3D_ARB

GLScene.OpenGL4

GL_SAMPLER_BINDING

GLScene.OpenGL4

GL_ARB_sampler_objects

GL_SAMPLER_BUFFER

GLScene.OpenGL4

GL_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_AMD_vertex_shader_tesselator

GL_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_SAMPLER_CUBE

GLScene.OpenGL4

GL_SAMPLER_CUBE_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_SHADOW

GLScene.OpenGL4

GL_SAMPLER_CUBE_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_OBJECT_AMD

GLScene.OpenGL4

GL_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_SAMPLES

GLScene.OpenGL4

GL_SAMPLES_3DFX

GLScene.OpenGL4

GL_SAMPLES_ARB

GLScene.OpenGL4

GL_SAMPLES_EXT

GLScene.OpenGL4

GL_SAMPLES_PASSED

GLScene.OpenGL4

GL_SAMPLES_PASSED_ARB

GLScene.OpenGL4

1.4 GL_ARB_occlusion_query

GL_SAMPLES_SGIS

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_COVERAGE

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_MASK_EXT

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_MASK_SGIS

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_ARB

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_EXT

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_SGIS

GLScene.OpenGL4

GL_SAMPLE_BUFFERS

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_3DFX

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_EXT

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_SGIS

GLScene.OpenGL4

GL_SAMPLE_COVERAGE

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_ARB

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_INVERT

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_INVERT_ARB

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_VALUE

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_VALUE_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_PIXEL_GRID_HEIGHT_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_PIXEL_GRID_WIDTH_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_SUBPIXEL_BITS_ARB

GLScene.OpenGL4

GL_ARB_sample_locations

GL_SAMPLE_MASK

GLScene.OpenGL4

GL_SAMPLE_MASK_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_INVERT_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_INVERT_SGIS

GLScene.OpenGL4

GL_SAMPLE_MASK_NV

GLScene.OpenGL4

GL_SAMPLE_MASK_SGIS

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_NV

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_SGIS

GLScene.OpenGL4

GL_SAMPLE_PATTERN_EXT

GLScene.OpenGL4

GL_SAMPLE_PATTERN_SGIS

GLScene.OpenGL4

GL_SAMPLE_POSITION

GLScene.OpenGL4

GL_ARB_texture_multisample

GL_SAMPLE_POSITION_NV

GLScene.OpenGL4

GL_NV_explicit_multisample

GL_SAMPLE_SHADING

GLScene.OpenGL4

GL_VERSION_4_0

GL_SAMPLE_SHADING_ARB

GLScene.OpenGL4

GL_ARB_sample_shading

GL_SATURATE_BIT_ATI

GLScene.OpenGL4

GL_SCALAR_EXT

GLScene.OpenGL4

GL_SCALEBIAS_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_scalebias_hint

GL_SCALED_RESOLVE_FASTEST_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_multisample_blit_scaled

GL_SCALED_RESOLVE_NICEST_EXT

GLScene.OpenGL4

GL_SCALE_BY_FOUR_NV

GLScene.OpenGL4

GL_SCALE_BY_ONE_HALF_NV

GLScene.OpenGL4

GL_SCALE_BY_TWO_NV

GLScene.OpenGL4

GL_SCISSOR_BIT

GLScene.OpenGL4

GL_SCISSOR_BOX

GLScene.OpenGL4

GL_SCISSOR_TEST

GLScene.OpenGL4

GL_SCREEN_COORDINATES_REND

GLScene.OpenGL4

GL_REND_screen_coordinates

GL_SCREEN_KHR

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_POINTER

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_SIZE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_STRIDE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_TYPE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_SECONDARY_INTERPOLATOR_ATI

GLScene.OpenGL4

GL_SELECT

GLScene.OpenGL4

GL_SELECTION_BUFFER_POINTER

GLScene.OpenGL4

GL_SELECTION_BUFFER_SIZE

GLScene.OpenGL4

GL_SEPARABLE_2D

GLScene.OpenGL4

GL_SEPARABLE_2D_EXT

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS_EXT

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS_NV

GLScene.OpenGL4

GL_SEPARATE_SPECULAR_COLOR

GLScene.OpenGL4

GL_SEPARATE_SPECULAR_COLOR_EXT

GLScene.OpenGL4

GL_SET

GLScene.OpenGL4

GL_SET_AMD

GLScene.OpenGL4

(4.3) GL_AMD_stencil_operation_extended

GL_SGIS_detail_texture

GLScene.OpenGL4

GL 4.6

GL_SGIS_fog_function

GLScene.OpenGL4

GL 4.6

GL_SGIS_generate_mipmap

GLScene.OpenGL4

GL 4.6

GL_SGIS_multisample

GLScene.OpenGL4

GL 4.6

GL_SGIS_pixel_texture

GLScene.OpenGL4

GL 4.6

GL_SGIS_point_line_texgen

GLScene.OpenGL4

GL 4.6

GL_SGIS_point_parameters

GLScene.OpenGL4

GL 4.6

GL_SGIS_sharpen_texture

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture4D

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_border_clamp

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_color_mask

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_edge_clamp

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_filter4

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_lod

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_select

GLScene.OpenGL4

GL 4.6

GL_SGIX_async

GLScene.OpenGL4

GL 4.6

GL_SGIX_async_histogram

GLScene.OpenGL4

GL 4.6

GL_SGIX_async_pixel

GLScene.OpenGL4

GL 4.6

GL_SGIX_blend_alpha_minmax

GLScene.OpenGL4

GL 4.6

GL_SGIX_calligraphic_fragment

GLScene.OpenGL4

GL 4.6

GL_SGIX_clipmap

GLScene.OpenGL4

GL 4.6

GL_SGIX_convolution_accuracy

GLScene.OpenGL4

GL 4.6

GL_SGIX_depth_pass_instrument

GLScene.OpenGL4

GL 4.6

GL_SGIX_depth_texture

GLScene.OpenGL4

GL 4.6

GL_SGIX_flush_raster

GLScene.OpenGL4

GL 4.6

GL_SGIX_fog_offset

GLScene.OpenGL4

GL 4.6

GL_SGIX_fog_scale

GLScene.OpenGL4

GL 4.6

GL_SGIX_fragment_lighting

GLScene.OpenGL4

GL 4.6

GL_SGIX_framezoom

GLScene.OpenGL4

GL 4.6

GL_SGIX_igloo_interface

GLScene.OpenGL4

GL 4.6

GL_SGIX_impact_pixel_texture

GLScene.OpenGL4

GL 4.6

GL_SGIX_instruments

GLScene.OpenGL4

GL 4.6

GL_SGIX_interlace

GLScene.OpenGL4

GL 4.6

GL_SGIX_ir_instrument1

GLScene.OpenGL4

GL 4.6

GL_SGIX_list_priority

GLScene.OpenGL4

GL 4.6

GL_SGIX_pixel_texture

GLScene.OpenGL4

GL 4.6

GL_SGIX_pixel_tiles

GLScene.OpenGL4

GL 4.6

GL_SGIX_polynomial_ffd

GLScene.OpenGL4

GL 4.6

GL_SGIX_reference_plane

GLScene.OpenGL4

GL 4.6

GL_SGIX_resample

GLScene.OpenGL4

GL 4.6

GL_SGIX_scalebias_hint

GLScene.OpenGL4

GL 4.6

GL_SGIX_shadow

GLScene.OpenGL4

GL 4.6

GL_SGIX_shadow_ambient

GLScene.OpenGL4

GL 4.6

GL_SGIX_sprite

GLScene.OpenGL4

GL 4.6

GL_SGIX_subsample

GLScene.OpenGL4

GL 4.6

GL_SGIX_tag_sample_buffer

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_add_env

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_coordinate_clamp

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_lod_bias

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_multi_buffer

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_scale_bias

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_select

GLScene.OpenGL4

GL 4.6

GL_SGIX_vertex_preclip

GLScene.OpenGL4

GL 4.6

GL_SGIX_ycrcb

GLScene.OpenGL4

GL 4.6

GL_SGIX_ycrcba

GLScene.OpenGL4

GL 4.6

GL_SGIX_ycrcb_subsample

GLScene.OpenGL4

GL 4.6

GL_SGI_color_matrix

GLScene.OpenGL4

GL 4.6

GL_SGI_color_table

GLScene.OpenGL4

GL 4.6

GL_SGI_depth_pass_instrument

GLScene.OpenGL4

GL 4.6

GL_SGI_texture_color_table

GLScene.OpenGL4

GL 4.6

GL_SHADER

GLScene.OpenGL4

GL_SHADER_BINARY_FORMAT_SPIR_V

GLScene.OpenGL4

4.6

GL_SHADER_BINARY_FORMAT_SPIR_V_ARB

GLScene.OpenGL4

GL_ARB_gl_spirv

GL_SHADER_COMPILER

GLScene.OpenGL4

GL_SHADER_CONSISTENT_NV

GLScene.OpenGL4

GL_SHADER_GLOBAL_ACCESS_BARRIER_BIT_NV

GLScene.OpenGL4

GL_NV_shader_buffer_store

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT

GLScene.OpenGL4

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_SHADER_IMAGE_ATOMIC

GLScene.OpenGL4

GL_SHADER_IMAGE_LOAD

GLScene.OpenGL4

GL_SHADER_IMAGE_STORE

GLScene.OpenGL4

GL_SHADER_INCLUDE_ARB

GLScene.OpenGL4

GL_ARB_shading_language_include

GL_SHADER_OBJECT_ARB

GLScene.OpenGL4

GL_SHADER_OPERATION_NV

GLScene.OpenGL4

GL_SHADER_SOURCE_LENGTH

GLScene.OpenGL4

GL_SHADER_STORAGE_BARRIER_BIT

GLScene.OpenGL4

GL_SHADER_STORAGE_BLOCK

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_BINDING

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_SIZE

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_START

GLScene.OpenGL4

GL_SHADER_TYPE

GLScene.OpenGL4

GL_SHADE_MODEL

GLScene.OpenGL4

GL_SHADING_LANGUAGE_VERSION

GLScene.OpenGL4

GL_SHADING_LANGUAGE_VERSION_ARB

GLScene.OpenGL4

GL_ARB_shading_language_100

GL_SHADOW_AMBIENT_SGIX

GLScene.OpenGL4

GL_SGIX_shadow_ambient

GL_SHADOW_ATTENUATION_EXT

GLScene.OpenGL4

GL_SHARED_TEXTURE_PALETTE_EXT

GLScene.OpenGL4

GL_EXT_shared_texture_palette

GL_SHARPEN_TEXTURE_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_SHININESS

GLScene.OpenGL4

GL_SHORT

GLScene.OpenGL4

GL_SIGNALED

GLScene.OpenGL4

GL_SIGNED_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_ALPHA_NV

GLScene.OpenGL4

GL_SIGNED_HILO16_NV

GLScene.OpenGL4

GL_SIGNED_HILO8_NV

GLScene.OpenGL4

GL_SIGNED_HILO_NV

GLScene.OpenGL4

GL_SIGNED_IDENTITY_NV

GLScene.OpenGL4

GL_SIGNED_INTENSITY8_NV

GLScene.OpenGL4

GL_SIGNED_INTENSITY_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE8_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE8_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE_ALPHA_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE_NV

GLScene.OpenGL4

GL_SIGNED_NEGATE_NV

GLScene.OpenGL4

GL_SIGNED_NORMALIZED

GLScene.OpenGL4

GL_SIGNED_RGB8_NV

GLScene.OpenGL4

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_RGBA8_NV

GLScene.OpenGL4

GL_SIGNED_RGBA_NV

GLScene.OpenGL4

GL_SIGNED_RGB_NV

GLScene.OpenGL4

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_TEST

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_WRITE

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_TEST

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_WRITE

GLScene.OpenGL4

GL_SINGLE_COLOR

GLScene.OpenGL4

GL_SINGLE_COLOR_EXT

GLScene.OpenGL4

GL_SKIP_COMPONENTS1_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS2_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS3_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS4_NV

GLScene.OpenGL4

GL_SKIP_DECODE_EXT

GLScene.OpenGL4

GL_SKIP_MISSING_GLYPH_NV

GLScene.OpenGL4

GL_SLICE_ACCUM_SUN

GLScene.OpenGL4

GL_SUN_slice_accum

GL_SLUMINANCE

GLScene.OpenGL4

GL_SLUMINANCE8

GLScene.OpenGL4

GL_SLUMINANCE8_ALPHA8

GLScene.OpenGL4

GL_SLUMINANCE8_ALPHA8_EXT

GLScene.OpenGL4

GL_SLUMINANCE8_EXT

GLScene.OpenGL4

GL_SLUMINANCE_ALPHA

GLScene.OpenGL4

GL_SLUMINANCE_ALPHA_EXT

GLScene.OpenGL4

GL_SLUMINANCE_EXT

GLScene.OpenGL4

GL_SMALL_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_SMALL_CW_ARC_TO_NV

GLScene.OpenGL4

GL_SMOOTH

GLScene.OpenGL4

GL_SMOOTH_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_SMOOTH_LINE_WIDTH_GRANULARITY

GLScene.OpenGL4

GL_SMOOTH_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_SMOOTH_POINT_SIZE_GRANULARITY

GLScene.OpenGL4

GL_SMOOTH_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_SMOOTH_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_SOFTLIGHT_KHR

GLScene.OpenGL4

GL_SOURCE0_ALPHA

GLScene.OpenGL4

GL_SOURCE0_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE0_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE0_RGB

GLScene.OpenGL4

GL_SOURCE0_RGB_ARB

GLScene.OpenGL4

GL_SOURCE0_RGB_EXT

GLScene.OpenGL4

GL_SOURCE1_ALPHA

GLScene.OpenGL4

GL_SOURCE1_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE1_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE1_RGB

GLScene.OpenGL4

GL_SOURCE1_RGB_ARB

GLScene.OpenGL4

GL_SOURCE1_RGB_EXT

GLScene.OpenGL4

GL_SOURCE2_ALPHA

GLScene.OpenGL4

GL_SOURCE2_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE2_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE2_RGB

GLScene.OpenGL4

GL_SOURCE2_RGB_ARB

GLScene.OpenGL4

GL_SOURCE2_RGB_EXT

GLScene.OpenGL4

GL_SOURCE3_ALPHA_NV

GLScene.OpenGL4

GL_SOURCE3_RGB_NV

GLScene.OpenGL4

GL_SPARE0_NV

GLScene.OpenGL4

GL_SPARE0_PLUS_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_SPARE1_NV

GLScene.OpenGL4

GL_SPARSE_BUFFER_PAGE_SIZE_ARB

GLScene.OpenGL4

GL_SPARSE_STORAGE_BIT_ARB

GLScene.OpenGL4

GL_ARB_sparse_buffer

GL_SPARSE_TEXTURE_FULL_ARRAY_CUBE_MIPMAPS_ARB

GLScene.OpenGL4

GL_SPECULAR

GLScene.OpenGL4

GL_SPHERE_MAP

GLScene.OpenGL4

GL_SPIR_V_BINARY

GLScene.OpenGL4

GL_SPIR_V_BINARY_ARB

GLScene.OpenGL4

GL_SPIR_V_EXTENSIONS

GLScene.OpenGL4

GL_SPOT_CUTOFF

GLScene.OpenGL4

GL_SPOT_DIRECTION

GLScene.OpenGL4

GL_SPOT_EXPONENT

GLScene.OpenGL4

GL_SPRITE_AXIAL_SGIX

GLScene.OpenGL4

GL_SPRITE_AXIS_SGIX

GLScene.OpenGL4

GL_SPRITE_EYE_ALIGNED_SGIX

GLScene.OpenGL4

GL_SPRITE_MODE_SGIX

GLScene.OpenGL4

GL_SPRITE_OBJECT_ALIGNED_SGIX

GLScene.OpenGL4

GL_SPRITE_SGIX

GLScene.OpenGL4

GL_SGIX_sprite

GL_SPRITE_TRANSLATION_SGIX

GLScene.OpenGL4

GL_SQUARE_NV

GLScene.OpenGL4

GL_SRC0_ALPHA

GLScene.OpenGL4

GL_SRC0_RGB

GLScene.OpenGL4

GL_SRC1_ALPHA

GLScene.OpenGL4

GL_SRC1_COLOR

GLScene.OpenGL4

GL_ARB_blend_func_extended

GL_SRC1_RGB

GLScene.OpenGL4

GL_SRC2_ALPHA

GLScene.OpenGL4

GL_SRC2_RGB

GLScene.OpenGL4

GL_SRC_ALPHA

GLScene.OpenGL4

GL_SRC_ALPHA_SATURATE

GLScene.OpenGL4

GL_SRC_COLOR

GLScene.OpenGL4

GL_SRGB

GLScene.OpenGL4

GL_SRGB8

GLScene.OpenGL4

GL_SRGB8_ALPHA8

GLScene.OpenGL4

GL_SRGB8_ALPHA8_EXT

GLScene.OpenGL4

GL_SRGB8_EXT

GLScene.OpenGL4

GL_SRGB_ALPHA

GLScene.OpenGL4

GL_SRGB_ALPHA_EXT

GLScene.OpenGL4

GL_SRGB_DECODE_ARB

GLScene.OpenGL4

GL_SRGB_EXT

GLScene.OpenGL4

GL_EXT_texture_sRGB

GL_SRGB_READ

GLScene.OpenGL4

GL_SRGB_WRITE

GLScene.OpenGL4

GL_STACK_OVERFLOW

GLScene.OpenGL4

GL_STACK_UNDERFLOW

GLScene.OpenGL4

GL_STANDARD_FONT_NAME_NV

GLScene.OpenGL4

GL_STATIC_ATI

GLScene.OpenGL4

GL_ATI_vertex_array_object

GL_STATIC_COPY

GLScene.OpenGL4

GL_STATIC_COPY_ARB

GLScene.OpenGL4

GL_STATIC_DRAW

GLScene.OpenGL4

GL_STATIC_DRAW_ARB

GLScene.OpenGL4

GL_STATIC_READ

GLScene.OpenGL4

GL_STATIC_READ_ARB

GLScene.OpenGL4

GL_STENCIL

GLScene.OpenGL4

GL_STENCIL_ATTACHMENT

GLScene.OpenGL4

GL_STENCIL_ATTACHMENT_EXT

GLScene.OpenGL4

GL_STENCIL_BACK_FAIL

GLScene.OpenGL4

GL_STENCIL_BACK_FAIL_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_FUNC

GLScene.OpenGL4

GL_STENCIL_BACK_FUNC_ATI

GLScene.OpenGL4

GL_ATI_separate_stencil

GL_STENCIL_BACK_OP_VALUE_AMD

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_FAIL

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_PASS

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_PASS_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_REF

GLScene.OpenGL4

GL_STENCIL_BACK_VALUE_MASK

GLScene.OpenGL4

GL_STENCIL_BACK_WRITEMASK

GLScene.OpenGL4

GL_STENCIL_BITS

GLScene.OpenGL4

GL_STENCIL_BUFFER

GLScene.OpenGL4

GL_STENCIL_BUFFER_BIT

GLScene.OpenGL4

GL_STENCIL_CLEAR_TAG_VALUE_EXT

GLScene.OpenGL4

GL_STENCIL_CLEAR_VALUE

GLScene.OpenGL4

GL_STENCIL_COMPONENTS

GLScene.OpenGL4

GL_STENCIL_FAIL

GLScene.OpenGL4

GL_STENCIL_FUNC

GLScene.OpenGL4

GL_STENCIL_INDEX

GLScene.OpenGL4

PixelFormat

GL_STENCIL_INDEX1

GLScene.OpenGL4

GL_STENCIL_INDEX16

GLScene.OpenGL4

GL_STENCIL_INDEX16_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX1_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX4

GLScene.OpenGL4

GL_STENCIL_INDEX4_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX8

GLScene.OpenGL4

GL_STENCIL_INDEX8_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX_EXT

GLScene.OpenGL4

GL_STENCIL_OP_VALUE_AMD

GLScene.OpenGL4

GL_STENCIL_PASS_DEPTH_FAIL

GLScene.OpenGL4

GL_STENCIL_PASS_DEPTH_PASS

GLScene.OpenGL4

GL_STENCIL_REF

GLScene.OpenGL4

GL_STENCIL_RENDERABLE

GLScene.OpenGL4

GL_STENCIL_TAG_BITS_EXT

GLScene.OpenGL4

GL_EXT_stencil_clear_tag

GL_STENCIL_TEST

GLScene.OpenGL4

GL_STENCIL_TEST_TWO_SIDE_EXT

GLScene.OpenGL4

GL_EXT_stencil_two_side

GL_STENCIL_VALUE_MASK

GLScene.OpenGL4

GL_STENCIL_WRITEMASK

GLScene.OpenGL4

GL_STEREO

GLScene.OpenGL4

GL_STORAGE_CACHED_APPLE

GLScene.OpenGL4

GL_STORAGE_CLIENT_APPLE

GLScene.OpenGL4

GL_STORAGE_PRIVATE_APPLE

GLScene.OpenGL4

GL_STORAGE_SHARED_APPLE

GLScene.OpenGL4

GL_STREAM_COPY

GLScene.OpenGL4

GL_STREAM_COPY_ARB

GLScene.OpenGL4

GL_STREAM_DRAW

GLScene.OpenGL4

GL_STREAM_DRAW_ARB

GLScene.OpenGL4

GL_STREAM_READ

GLScene.OpenGL4

GL_STREAM_READ_ARB

GLScene.OpenGL4

GL_STRICT_DEPTHFUNC_HINT_PGI

GLScene.OpenGL4

GL_STRICT_LIGHTING_HINT_PGI

GLScene.OpenGL4

GL_STRICT_SCISSOR_HINT_PGI

GLScene.OpenGL4

GL_SUBPIXEL_BITS

GLScene.OpenGL4

GL_SUBPIXEL_PRECISION_BIAS_X_BITS_NV

GLScene.OpenGL4

GL_SUBPIXEL_PRECISION_BIAS_Y_BITS_NV

GLScene.OpenGL4

GL_SUBSAMPLE_DISTANCE_AMD

GLScene.OpenGL4

GL_AMD_sample_positions

GL_SUBTRACT

GLScene.OpenGL4

GL_SUBTRACT_ARB

GLScene.OpenGL4

GL_SUB_ATI

GLScene.OpenGL4

GL_SUCCESS_NV

GLScene.OpenGL4

GL_SUNX_constant_data

GLScene.OpenGL4

GL 4.6

GL_SUN_convolution_border_modes

GLScene.OpenGL4

GL 4.6

GL_SUN_global_alpha

GLScene.OpenGL4

GL 4.6

GL_SUN_mesh_array

GLScene.OpenGL4

GL 4.6

GL_SUN_slice_accum

GLScene.OpenGL4

GL 4.6

GL_SUN_triangle_list

GLScene.OpenGL4

GL 4.6

GL_SUN_vertex

GLScene.OpenGL4

GL 4.6

GL_SURFACE_MAPPED_NV

GLScene.OpenGL4

GL_SURFACE_REGISTERED_NV

GLScene.OpenGL4

GL_SURFACE_STATE_NV

GLScene.OpenGL4

GL_NV_vdpau_interop

GL_SWIZZLE_STQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STQ_DQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STRQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STRQ_DQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STR_ATI

GLScene.OpenGL4

GL_SWIZZLE_STR_DR_ATI

GLScene.OpenGL4

GL_SYNC_CL_EVENT_ARB

GLScene.OpenGL4

GL_ARB_cl_event

GL_SYNC_CL_EVENT_COMPLETE_ARB

GLScene.OpenGL4

GL_SYNC_CONDITION

GLScene.OpenGL4

GL_SYNC_FENCE

GLScene.OpenGL4

GL_SYNC_FLAGS

GLScene.OpenGL4

GL_SYNC_FLUSH_COMMANDS_BIT

GLScene.OpenGL4

GL_SYNC_GPU_COMMANDS_COMPLETE

GLScene.OpenGL4

GL_SYNC_STATUS

GLScene.OpenGL4

GL_SYNC_X11_FENCE_EXT

GLScene.OpenGL4

GL_EXT_x11_sync_object

GL_SYSTEM_FONT_NAME_NV

GLScene.OpenGL4

GL_T

GLScene.OpenGL4

GL_T2F_C3F_V3F

GLScene.OpenGL4

GL_T2F_C4F_N3F_V3F

GLScene.OpenGL4

GL_T2F_C4UB_V3F

GLScene.OpenGL4

GL_T2F_IUI_N3F_V2F_EXT

GLScene.OpenGL4

GL_T2F_IUI_N3F_V3F_EXT

GLScene.OpenGL4

GL_T2F_IUI_V2F_EXT

GLScene.OpenGL4

GL_T2F_IUI_V3F_EXT

GLScene.OpenGL4

GL_T2F_N3F_V3F

GLScene.OpenGL4

GL_T2F_V3F

GLScene.OpenGL4

GL_T4F_C4F_N3F_V4F

GLScene.OpenGL4

GL_T4F_V4F

GLScene.OpenGL4

GL_TABLE_TOO_LARGE

GLScene.OpenGL4

GL_TABLE_TOO_LARGE_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_coordinate_frame

GL_TANGENT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_TESSELLATION_FACTOR_AMD

GLScene.OpenGL4

GL_TESSELLATION_MODE_AMD

GLScene.OpenGL4

GL_TESS_CONTROL_OUTPUT_VERTICES

GLScene.OpenGL4

GL_TESS_CONTROL_PROGRAM_NV

GLScene.OpenGL4

GL_TESS_CONTROL_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_BIT

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_PATCHES

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_PATCHES_ARB

GLScene.OpenGL4

GL_TESS_CONTROL_SUBROUTINE

GLScene.OpenGL4

GL_TESS_CONTROL_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_TESS_CONTROL_TEXTURE

GLScene.OpenGL4

GL_TESS_EVALUATION_PROGRAM_NV

GLScene.OpenGL4

GL_TESS_EVALUATION_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_BIT

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_TESS_EVALUATION_SUBROUTINE

GLScene.OpenGL4

GL_TESS_EVALUATION_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_TESS_EVALUATION_TEXTURE

GLScene.OpenGL4

GL_TESS_GEN_MODE

GLScene.OpenGL4

GL_TESS_GEN_POINT_MODE

GLScene.OpenGL4

GL_TESS_GEN_SPACING

GLScene.OpenGL4

GL_TESS_GEN_VERTEX_ORDER

GLScene.OpenGL4

GL_TEXCOORD1_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD2_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD3_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD4_BIT_PGI

GLScene.OpenGL4

GL_TEXTURE

GLScene.OpenGL4

MatrixMode (for gl3.h, FBO attachment type)

GL_TEXTURE0

GLScene.OpenGL4

GL_VERSION_1_3

GL_TEXTURE0_ARB

GLScene.OpenGL4

GL_ARB_multitexture

GL_TEXTURE1

GLScene.OpenGL4

GL_TEXTURE10

GLScene.OpenGL4

GL_TEXTURE10_ARB

GLScene.OpenGL4

GL_TEXTURE11

GLScene.OpenGL4

GL_TEXTURE11_ARB

GLScene.OpenGL4

GL_TEXTURE12

GLScene.OpenGL4

GL_TEXTURE12_ARB

GLScene.OpenGL4

GL_TEXTURE13

GLScene.OpenGL4

GL_TEXTURE13_ARB

GLScene.OpenGL4

GL_TEXTURE14

GLScene.OpenGL4

GL_TEXTURE14_ARB

GLScene.OpenGL4

GL_TEXTURE15

GLScene.OpenGL4

GL_TEXTURE15_ARB

GLScene.OpenGL4

GL_TEXTURE16

GLScene.OpenGL4

GL_TEXTURE16_ARB

GLScene.OpenGL4

GL_TEXTURE17

GLScene.OpenGL4

GL_TEXTURE17_ARB

GLScene.OpenGL4

GL_TEXTURE18

GLScene.OpenGL4

GL_TEXTURE18_ARB

GLScene.OpenGL4

GL_TEXTURE19

GLScene.OpenGL4

GL_TEXTURE19_ARB

GLScene.OpenGL4

GL_TEXTURE1_ARB

GLScene.OpenGL4

GL_TEXTURE2

GLScene.OpenGL4

GL_TEXTURE20

GLScene.OpenGL4

GL_TEXTURE20_ARB

GLScene.OpenGL4

GL_TEXTURE21

GLScene.OpenGL4

GL_TEXTURE21_ARB

GLScene.OpenGL4

GL_TEXTURE22

GLScene.OpenGL4

GL_TEXTURE22_ARB

GLScene.OpenGL4

GL_TEXTURE23

GLScene.OpenGL4

GL_TEXTURE23_ARB

GLScene.OpenGL4

GL_TEXTURE24

GLScene.OpenGL4

GL_TEXTURE24_ARB

GLScene.OpenGL4

GL_TEXTURE25

GLScene.OpenGL4

GL_TEXTURE25_ARB

GLScene.OpenGL4

GL_TEXTURE26

GLScene.OpenGL4

GL_TEXTURE26_ARB

GLScene.OpenGL4

GL_TEXTURE27

GLScene.OpenGL4

GL_TEXTURE27_ARB

GLScene.OpenGL4

GL_TEXTURE28

GLScene.OpenGL4

GL_TEXTURE28_ARB

GLScene.OpenGL4

GL_TEXTURE29

GLScene.OpenGL4

GL_TEXTURE29_ARB

GLScene.OpenGL4

GL_TEXTURE2_ARB

GLScene.OpenGL4

GL_TEXTURE3

GLScene.OpenGL4

GL_TEXTURE30

GLScene.OpenGL4

GL_TEXTURE30_ARB

GLScene.OpenGL4

GL_TEXTURE31

GLScene.OpenGL4

GL_TEXTURE31_ARB

GLScene.OpenGL4

GL_TEXTURE3_ARB

GLScene.OpenGL4

GL_TEXTURE4

GLScene.OpenGL4

GL_TEXTURE4_ARB

GLScene.OpenGL4

GL_TEXTURE5

GLScene.OpenGL4

GL_TEXTURE5_ARB

GLScene.OpenGL4

GL_TEXTURE6

GLScene.OpenGL4

GL_TEXTURE6_ARB

GLScene.OpenGL4

GL_TEXTURE7

GLScene.OpenGL4

GL_TEXTURE7_ARB

GLScene.OpenGL4

GL_TEXTURE8

GLScene.OpenGL4

GL_TEXTURE8_ARB

GLScene.OpenGL4

GL_TEXTURE9

GLScene.OpenGL4

GL_TEXTURE9_ARB

GLScene.OpenGL4

GL_TEXTURE_1D

GLScene.OpenGL4

GL_TEXTURE_1D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_texture_array

GL_TEXTURE_1D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_2D

GLScene.OpenGL4

GL_TEXTURE_2D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_2D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_TEXTURE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_TEXTURE_3D

GLScene.OpenGL4

GL_TEXTURE_3D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_3D_EXT

GLScene.OpenGL4

GL_TEXTURE_4DSIZE_SGIS

GLScene.OpenGL4

GL_TEXTURE_4D_BINDING_SGIS

GLScene.OpenGL4

GL_TEXTURE_4D_SGIS

GLScene.OpenGL4

GL_TEXTURE_ALPHA_SIZE

GLScene.OpenGL4

GL_TEXTURE_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_ALPHA_TYPE

GLScene.OpenGL4

GL_TEXTURE_ALPHA_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_APPLICATION_MODE_EXT

GLScene.OpenGL4

GL_TEXTURE_BASE_LEVEL

GLScene.OpenGL4

GL_TEXTURE_BASE_LEVEL_SGIS

GLScene.OpenGL4

GL_TEXTURE_BINDING

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_MULTISAMPLE

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_3D

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_NV

GLScene.OpenGL4

GL_TEXTURE_BINDING_RENDERBUFFER_NV

GLScene.OpenGL4

GL_TEXTURE_BIT

GLScene.OpenGL4

GL_TEXTURE_BLUE_SIZE

GLScene.OpenGL4

GL_TEXTURE_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_BLUE_TYPE

GLScene.OpenGL4

GL_TEXTURE_BLUE_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_BORDER

GLScene.OpenGL4

GL_TEXTURE_BORDER_COLOR

GLScene.OpenGL4

GL_TEXTURE_BORDER_VALUES_NV

GLScene.OpenGL4

GL_TEXTURE_BUFFER

GLScene.OpenGL4

GL_TEXTURE_BUFFER_ARB

GLScene.OpenGL4

GL_ARB_texture_buffer_object

GL_TEXTURE_BUFFER_BINDING

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_texture_buffer_object

GL_TEXTURE_BUFFER_FORMAT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_FORMAT_ARB

GLScene.OpenGL4

GL_TEXTURE_BUFFER_FORMAT_EXT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_OFFSET

GLScene.OpenGL4

GL_TEXTURE_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_SIZE

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_CENTER_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_DEPTH_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_FRAME_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_LOD_OFFSET_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_OFFSET_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_VIRTUAL_DEPTH_SGIX

GLScene.OpenGL4

GL_TEXTURE_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_TEXTURE_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_SGI_texture_color_table

GL_TEXTURE_COLOR_WRITEMASK_SGIS

GLScene.OpenGL4

GL_SGIS_texture_color_mask

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB

GLScene.OpenGL4

GL_ARB_shadow_ambient

GL_TEXTURE_COMPARE_FUNC

GLScene.OpenGL4

GL_TEXTURE_COMPARE_FUNC_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPARE_MODE

GLScene.OpenGL4

GL_TEXTURE_COMPARE_MODE_ARB

GLScene.OpenGL4

GL_ARB_shadow

GL_TEXTURE_COMPARE_OPERATOR_SGIX

GLScene.OpenGL4

GL_TEXTURE_COMPARE_SGIX

GLScene.OpenGL4

GL_SGIX_shadow

GL_TEXTURE_COMPONENTS

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_IMAGE_SIZE

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPRESSION_HINT

GLScene.OpenGL4

GL_TEXTURE_COMPRESSION_HINT_ARB

GLScene.OpenGL4

GL_TEXTURE_CONSTANT_DATA_SUNX

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_POINTER

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_SIZE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_STRIDE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_TYPE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_NV

GLScene.OpenGL4

GL_TEXTURE_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_texture_multisample

GL_TEXTURE_CUBE_MAP

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_ARB_texture_cube_map_array

GL_TEXTURE_CUBE_MAP_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_SEAMLESS

GLScene.OpenGL4

GL_ARB_seamless_cube_map

GL_TEXTURE_DEFORMATION_BIT_SGIX

GLScene.OpenGL4

GL_FfdMaskSGIX

GL_TEXTURE_DEFORMATION_SGIX

GLScene.OpenGL4

GL_TEXTURE_DEPTH

GLScene.OpenGL4

GL_TEXTURE_DEPTH_EXT

GLScene.OpenGL4

GL_TEXTURE_DEPTH_SIZE

GLScene.OpenGL4

GL_TEXTURE_DEPTH_SIZE_ARB

GLScene.OpenGL4

GL_TEXTURE_DEPTH_TYPE

GLScene.OpenGL4

GL_TEXTURE_DEPTH_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_DS_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_DT_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_ENV

GLScene.OpenGL4

GL_TEXTURE_ENV_BIAS_SGIX

GLScene.OpenGL4

GL_SGIX_texture_add_env

GL_TEXTURE_ENV_COLOR

GLScene.OpenGL4

GL_TEXTURE_ENV_MODE

GLScene.OpenGL4

GL_TEXTURE_FETCH_BARRIER_BIT

GLScene.OpenGL4

GL_TEXTURE_FETCH_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TEXTURE_FILTER4_SIZE_SGIS

GLScene.OpenGL4

GL_TEXTURE_FILTER_CONTROL

GLScene.OpenGL4

GL_TEXTURE_FILTER_CONTROL_EXT

GLScene.OpenGL4

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS

GLScene.OpenGL4

GL_TEXTURE_FLOAT_COMPONENTS_NV

GLScene.OpenGL4

GL_TEXTURE_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_TEXTURE_GATHER

GLScene.OpenGL4

GL_TEXTURE_GATHER_SHADOW

GLScene.OpenGL4

GL_TEXTURE_GEN_MODE

GLScene.OpenGL4

GL_TEXTURE_GEN_Q

GLScene.OpenGL4

GL_TEXTURE_GEN_R

GLScene.OpenGL4

GL_TEXTURE_GEN_S

GLScene.OpenGL4

GL_TEXTURE_GEN_T

GLScene.OpenGL4

GL_TEXTURE_GEQUAL_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_GREEN_SIZE

GLScene.OpenGL4

GL_TEXTURE_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_GREEN_TYPE

GLScene.OpenGL4

GL_TEXTURE_GREEN_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_HEIGHT

GLScene.OpenGL4

GL_TEXTURE_HI_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_IMAGE_FORMAT

GLScene.OpenGL4

GL_TEXTURE_IMAGE_TYPE

GLScene.OpenGL4

GL_TEXTURE_IMMUTABLE_FORMAT

GLScene.OpenGL4

GL_ARB_texture_storage

GL_TEXTURE_IMMUTABLE_LEVELS

GLScene.OpenGL4

GL_TEXTURE_INDEX_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_SIZE

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_TYPE

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_INTERNAL_FORMAT

GLScene.OpenGL4

GL_TEXTURE_LEQUAL_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_LIGHTING_MODE_HP

GLScene.OpenGL4

GL_HP_texture_lighting

GL_TEXTURE_LIGHT_EXT

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_EXT

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_S_SGIX

GLScene.OpenGL4

GL_SGIX_texture_lod_bias

GL_TEXTURE_LOD_BIAS_T_SGIX

GLScene.OpenGL4

GL_TEXTURE_LO_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_SIZE

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_TYPE

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_MAG_FILTER

GLScene.OpenGL4

TextureParameterName

GL_TEXTURE_MAG_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_MATERIAL_FACE_EXT

GLScene.OpenGL4

GL_TEXTURE_MATERIAL_PARAMETER_EXT

GLScene.OpenGL4

GL_TEXTURE_MATRIX

GLScene.OpenGL4

GL_TEXTURE_MAX_ANISOTROPY

GLScene.OpenGL4

GL_TEXTURE_MAX_ANISOTROPY_EXT

GLScene.OpenGL4

GL_EXT_texture_filter_anisotropic

GL_TEXTURE_MAX_CLAMP_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_MAX_CLAMP_S_SGIX

GLScene.OpenGL4

GL_SGIX_texture_coordinate_clamp

GL_TEXTURE_MAX_CLAMP_T_SGIX

GLScene.OpenGL4

GL_TEXTURE_MAX_LEVEL

GLScene.OpenGL4

GL_TEXTURE_MAX_LEVEL_SGIS

GLScene.OpenGL4

GL_TEXTURE_MAX_LOD

GLScene.OpenGL4

GL_TEXTURE_MAX_LOD_SGIS

GLScene.OpenGL4

GL_TEXTURE_MIN_FILTER

GLScene.OpenGL4

GL_TEXTURE_MIN_LOD

GLScene.OpenGL4

GL_TEXTURE_MIN_LOD_SGIS

GLScene.OpenGL4

GL_SGIS_texture_lod

GL_TEXTURE_MULTI_BUFFER_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_texture_multi_buffer

GL_TEXTURE_NORMAL_EXT

GLScene.OpenGL4

GL_TEXTURE_POST_SPECULAR_HP

GLScene.OpenGL4

GL_TEXTURE_PRE_SPECULAR_HP

GLScene.OpenGL4

GL_TEXTURE_PRIORITY

GLScene.OpenGL4

GL_TEXTURE_PRIORITY_EXT

GLScene.OpenGL4

GL_EXT_texture_object

GL_TEXTURE_RANGE_LENGTH_APPLE

GLScene.OpenGL4

GL_APPLE_texture_range

GL_TEXTURE_RANGE_POINTER_APPLE

GLScene.OpenGL4

GL_TEXTURE_RECTANGLE

GLScene.OpenGL4

GL_TEXTURE_RECTANGLE_ARB

GLScene.OpenGL4

GL_ARB_texture_rectangle

GL_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GL_EXT_texture_rectangle

GL_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_NV_texture_rectangle

GL_TEXTURE_REDUCTION_MODE_ARB

GLScene.OpenGL4

GL_ARB_texture_filter_minmax

GL_TEXTURE_RED_SIZE

GLScene.OpenGL4

GL_TEXTURE_RED_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_RED_TYPE

GLScene.OpenGL4

GL_TEXTURE_RED_TYPE_ARB

GLScene.OpenGL4

GL_ARB_texture_float

GL_TEXTURE_RENDERBUFFER_DATA_STORE_BINDING_NV

GLScene.OpenGL4

GL_TEXTURE_RENDERBUFFER_NV

GLScene.OpenGL4

GL_TEXTURE_RESIDENT

GLScene.OpenGL4

GL_TEXTURE_RESIDENT_EXT

GLScene.OpenGL4

GL_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_TEXTURE_SHADER_NV

GLScene.OpenGL4

GL_TEXTURE_SHADOW

GLScene.OpenGL4

GL_TEXTURE_SHARED_SIZE

GLScene.OpenGL4

GL_TEXTURE_SHARED_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_SPARSE_ARB

GLScene.OpenGL4

GL_ARB_SPARSE_TEXTURE

GL_TEXTURE_SRGB_DECODE_EXT

GLScene.OpenGL4

GL_EXT_texture_sRGB_decode

GL_TEXTURE_STACK_DEPTH

GLScene.OpenGL4

GL_TEXTURE_STENCIL_SIZE

GLScene.OpenGL4

GL_TEXTURE_STENCIL_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_STORAGE_HINT_APPLE

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_A

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_A_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_B

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_B_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_G

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_G_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_R

GLScene.OpenGL4

GL_ARB_texture_swizzle

GL_TEXTURE_SWIZZLE_RGBA

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_RGBA_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_R_EXT

GLScene.OpenGL4

GL_EXT_texture_swizzle

GL_TEXTURE_TARGET

GLScene.OpenGL4

GL_TEXTURE_TOO_LARGE_EXT

GLScene.OpenGL4

GL_TEXTURE_UNSIGNED_REMAP_MODE_NV

GLScene.OpenGL4

GL_NV_texture_expand_normal

GL_TEXTURE_UPDATE_BARRIER_BIT

GLScene.OpenGL4

GL_TEXTURE_UPDATE_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TEXTURE_VIEW

GLScene.OpenGL4

GL_TEXTURE_VIEW_MIN_LAYER

GLScene.OpenGL4

GL_TEXTURE_VIEW_MIN_LEVEL

GLScene.OpenGL4

GL_TEXTURE_VIEW_NUM_LAYERS

GLScene.OpenGL4

GL_TEXTURE_VIEW_NUM_LEVELS

GLScene.OpenGL4

GL_TEXTURE_WIDTH

GLScene.OpenGL4

GetTextureParameter

GL_TEXTURE_WRAP_Q_SGIS

GLScene.OpenGL4

GL_TEXTURE_WRAP_R

GLScene.OpenGL4

GL_TEXTURE_WRAP_R_EXT

GLScene.OpenGL4

GL_TEXTURE_WRAP_S

GLScene.OpenGL4

GL_TEXTURE_WRAP_T

GLScene.OpenGL4

GL_TEXT_FRAGMENT_SHADER_ATI

GLScene.OpenGL4

GL_ATI_text_fragment_shader

GL_TIMEOUT_EXPIRED

GLScene.OpenGL4

GL_TIMEOUT_IGNORED

GLScene.OpenGL4

GL_TIMESTAMP

GLScene.OpenGL4

GL_TIME_ELAPSED

GLScene.OpenGL4

GL_ARB_timer_query

GL_TIME_ELAPSED_EXT

GLScene.OpenGL4

GL_EXT_timer_query

GL_TOP_LEVEL_ARRAY_SIZE

GLScene.OpenGL4

GL_TOP_LEVEL_ARRAY_STRIDE

GLScene.OpenGL4

GL_TRACK_MATRIX_NV

GLScene.OpenGL4

GL_TRACK_MATRIX_TRANSFORM_NV

GLScene.OpenGL4

GL_TRANSFORM_BIT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK

GLScene.OpenGL4

GL_ARB_texture_buffer_object_rgb32 GL_ARB_transform_feedback2

GL_TRANSFORM_FEEDBACK_ACTIVE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BARRIER_BIT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BINDING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BINDING_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_INDEX

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_NV

GLScene.OpenGL4

GL_NV_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_STRIDE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_NV

GLScene.OpenGL4

GL_NV_transform_feedback2

GL_TRANSFORM_FEEDBACK_OVERFLOW

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_OVERFLOW_ARB

GLScene.OpenGL4

GL_ARB_transform_feedback_overflow_query

GL_TRANSFORM_FEEDBACK_PAUSED

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_RECORD_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW_ARB

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT

GLScene.OpenGL4

GL_TRANSFORM_HINT_APPLE

GLScene.OpenGL4

GL_APPLE_transform_hint

GL_TRANSLATE_2D_NV

GLScene.OpenGL4

GL_TRANSLATE_3D_NV

GLScene.OpenGL4

GL_TRANSLATE_X_NV

GLScene.OpenGL4

GL_TRANSLATE_Y_NV

GLScene.OpenGL4

GL_TRANSPOSE_AFFINE_2D_NV

GLScene.OpenGL4

GL_TRANSPOSE_AFFINE_3D_NV

GLScene.OpenGL4

GL_TRANSPOSE_COLOR_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_COLOR_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_CURRENT_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_MODELVIEW_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB

GLScene.OpenGL4

GL_ARB_transpose_matrix

GL_TRANSPOSE_NV

GLScene.OpenGL4

GL_TRANSPOSE_PROGRAM_MATRIX_EXT

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTION_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTION_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTIVE_2D_NV

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTIVE_3D_NV

GLScene.OpenGL4

GL_TRANSPOSE_TEXTURE_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_TEXTURE_MATRIX_ARB

GLScene.OpenGL4

GL_TRIANGLES

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY_ARB

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY_EXT

GLScene.OpenGL4

GL_TRIANGLE_FAN

GLScene.OpenGL4

GL_TRIANGLE_LIST_SUN

GLScene.OpenGL4

GL_TRIANGLE_MESH_SUN

GLScene.OpenGL4

GL_TRIANGLE_STRIP

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY_ARB

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY_EXT

GLScene.OpenGL4

GL_TRIANGULAR_NV

GLScene.OpenGL4

GL_TRUE

GLScene.OpenGL4

GL_TYPE

GLScene.OpenGL4

GL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGL4

GL_UNDEFINED_APPLE

GLScene.OpenGL4

GL_UNDEFINED_VERTEX

GLScene.OpenGL4

GL_UNIFORM

GLScene.OpenGL4

GL_UNIFORM_ARRAY_STRIDE

GLScene.OpenGL4

GL_UNIFORM_ATOMIC_COUNTER_BUFFER_INDEX

GLScene.OpenGL4

GL_UNIFORM_BARRIER_BIT

GLScene.OpenGL4

GL_UNIFORM_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_UNIFORM_BLOCK

GLScene.OpenGL4

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS

GLScene.OpenGL4

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES

GLScene.OpenGL4

GL_UNIFORM_BLOCK_BINDING

GLScene.OpenGL4

GL_UNIFORM_BLOCK_DATA_SIZE

GLScene.OpenGL4

GL_UNIFORM_BLOCK_INDEX

GLScene.OpenGL4

GL_UNIFORM_BLOCK_NAME_LENGTH

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_UNIFORM_BUFFER

GLScene.OpenGL4

GL_ARB_uniform_buffer_object

GL_UNIFORM_BUFFER_BINDING

GLScene.OpenGL4

GL_UNIFORM_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_EXT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_SIZE

GLScene.OpenGL4

GL_UNIFORM_BUFFER_START

GLScene.OpenGL4

GL_UNIFORM_IS_ROW_MAJOR

GLScene.OpenGL4

GL_UNIFORM_MATRIX_STRIDE

GLScene.OpenGL4

GL_UNIFORM_NAME_LENGTH

GLScene.OpenGL4

GL_UNIFORM_OFFSET

GLScene.OpenGL4

GL_UNIFORM_SIZE

GLScene.OpenGL4

GL_UNIFORM_TYPE

GLScene.OpenGL4

GL_UNKNOWN_CONTEXT_RESET

GLScene.OpenGL4

GL_UNKNOWN_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_UNPACK_ALIGNMENT

GLScene.OpenGL4

GL_UNPACK_CLIENT_STORAGE_APPLE

GLScene.OpenGL4

GL_APPLE_client_storage

GL_UNPACK_CMYK_HINT_EXT

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_DEPTH

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_ARB_compressed_texture_pixel_storage

GL_UNPACK_CONSTANT_DATA_SUNX

GLScene.OpenGL4

GL_SUNX_constant_data

GL_UNPACK_IMAGE_DEPTH_SGIS

GLScene.OpenGL4

GL_UNPACK_IMAGE_HEIGHT

GLScene.OpenGL4

GL_UNPACK_IMAGE_HEIGHT_EXT

GLScene.OpenGL4

GL_UNPACK_LSB_FIRST

GLScene.OpenGL4

GL_UNPACK_RESAMPLE_OML

GLScene.OpenGL4

GL_UNPACK_RESAMPLE_SGIX

GLScene.OpenGL4

GL_UNPACK_ROW_BYTES_APPLE

GLScene.OpenGL4

GL_UNPACK_ROW_LENGTH

GLScene.OpenGL4

GL_UNPACK_SKIP_IMAGES

GLScene.OpenGL4

GL_UNPACK_SKIP_IMAGES_EXT

GLScene.OpenGL4

GL_UNPACK_SKIP_PIXELS

GLScene.OpenGL4

GL_UNPACK_SKIP_ROWS

GLScene.OpenGL4

GL_UNPACK_SKIP_VOLUMES_SGIS

GLScene.OpenGL4

GL_UNPACK_SUBSAMPLE_RATE_SGIX

GLScene.OpenGL4

GL_UNPACK_SWAP_BYTES

GLScene.OpenGL4

GL_UNSIGNALED

GLScene.OpenGL4

GL_UNSIGNED_BYTE

GLScene.OpenGL4

GL_UNSIGNED_BYTE_2_3_3_REV

GLScene.OpenGL4

GL_UNSIGNED_BYTE_3_3_2

GLScene.OpenGL4

GL_VERSION_1_2

GL_UNSIGNED_BYTE_3_3_2_EXT

GLScene.OpenGL4

GL_EXT_packed_pixels

GL_UNSIGNED_IDENTITY_NV

GLScene.OpenGL4

GL_UNSIGNED_INT

GLScene.OpenGL4

GL_UNSIGNED_INT16_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_AMD

GLScene.OpenGL4

GL_UNSIGNED_INT64_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC2_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC3_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC4_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_10F_11F_11F_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_10_10_10_2

GLScene.OpenGL4

GL_UNSIGNED_INT_10_10_10_2_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_2_10_10_10_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_5_9_9_9_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_5_9_9_9_REV_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_ATOMIC_COUNTER

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_RECT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_3D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_3D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_BUFFER

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_S8_S8_8_8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_3D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_3D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC2

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC2_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC3

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC3_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC4

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC4_EXT

GLScene.OpenGL4

GL_UNSIGNED_INVERT_NV

GLScene.OpenGL4

GL_UNSIGNED_NORMALIZED

GLScene.OpenGL4

GL_UNSIGNED_NORMALIZED_ARB

GLScene.OpenGL4

GL_UNSIGNED_SHORT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_1_5_5_5_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4_EXT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_5_5_1

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_5_5_1_EXT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_6_5

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_6_5_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_8_8_APPLE

GLScene.OpenGL4

GL_UNSIGNED_SHORT_8_8_REV_APPLE

GLScene.OpenGL4

GL_UPPER_LEFT

GLScene.OpenGL4

GL_USE_MISSING_GLYPH_NV

GLScene.OpenGL4

GL_UTF16_NV

GLScene.OpenGL4

GL_UTF8_NV

GLScene.OpenGL4

GL_V2F

GLScene.OpenGL4

GL_V3F

GLScene.OpenGL4

GL_VALIDATE_STATUS

GLScene.OpenGL4

GL_VARIABLE_A_NV

GLScene.OpenGL4

GL_VARIABLE_B_NV

GLScene.OpenGL4

GL_VARIABLE_C_NV

GLScene.OpenGL4

GL_VARIABLE_D_NV

GLScene.OpenGL4

GL_VARIABLE_E_NV

GLScene.OpenGL4

GL_VARIABLE_F_NV

GLScene.OpenGL4

GL_VARIABLE_G_NV

GLScene.OpenGL4

GL_VARIANT_ARRAY_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VARIANT_DATATYPE_EXT

GLScene.OpenGL4

GL_VARIANT_EXT

GLScene.OpenGL4

GL_VARIANT_VALUE_EXT

GLScene.OpenGL4

GL_VBO_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_ATI_meminfo

GL_VECTOR_EXT

GLScene.OpenGL4

GL_VENDOR

GLScene.OpenGL4

StringName

GL_VERSION

GLScene.OpenGL4

GL_VERSION_4_0

GLScene.OpenGL4

GL_VERSION_4_1

GLScene.OpenGL4

GL_VERSION_4_2

GLScene.OpenGL4

GL_VERSION_4_3

GLScene.OpenGL4

GL_VERSION_4_4

GLScene.OpenGL4

GL_VERSION_4_5

GLScene.OpenGL4

GL_VERSION_4_6

GLScene.OpenGL4

GL_VERTEX23_BIT_PGI

GLScene.OpenGL4

GL_VERTEX4_BIT_PGI

GLScene.OpenGL4

GL_VERTEX_ARRAY

GLScene.OpenGL4

GL_VERTEX_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_BINDING

GLScene.OpenGL4

GL_ARB_vertex_array_object

GL_VERTEX_ARRAY_BINDING_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_array_object

GL_VERTEX_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_VERTEX_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_vertex_array

GL_VERTEX_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_IBM_vertex_array_lists

GL_VERTEX_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_VERTEX_ARRAY_OBJECT_AMD

GLScene.OpenGL4

GL_VERTEX_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_VERTEX_ARRAY_POINTER

GLScene.OpenGL4

GL_VERTEX_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_array_range

GL_VERTEX_ARRAY_RANGE_LENGTH_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_NV

GLScene.OpenGL4

GL_NV_vertex_array_range

GL_VERTEX_ARRAY_RANGE_POINTER_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_POINTER_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_VALID_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV

GLScene.OpenGL4

GL_NV_vertex_array_range2

GL_VERTEX_ARRAY_SIZE

GLScene.OpenGL4

GL_VERTEX_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_STORAGE_HINT_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_STRIDE

GLScene.OpenGL4

GL_VERTEX_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_TYPE

GLScene.OpenGL4

GL_VERTEX_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY0_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY10_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY11_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY12_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY13_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY14_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY15_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY1_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY2_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY3_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY4_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY5_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY6_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY7_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY8_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY9_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT

GLScene.OpenGL4

GL_ARB_shader_image_load_store

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_DIVISOR

GLScene.OpenGL4

GL_VERSION_3_3

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB

GLScene.OpenGL4

GL_ARB_instanced_arrays

GL_VERTEX_ATTRIB_ARRAY_ENABLED

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_INTEGER

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT

GLScene.OpenGL4

GL_EXT_gpu_shader4

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_LONG

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_POINTER

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_SIZE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_STRIDE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_TYPE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV

GLScene.OpenGL4

GL_NV_vertex_buffer_unified_memory

GL_VERTEX_ATTRIB_BINDING

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_program_evaluators

GL_VERTEX_ATTRIB_MAP1_COEFF_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_DOMAIN_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_ORDER_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_SIZE_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_COEFF_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_DOMAIN_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_ORDER_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_SIZE_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_RELATIVE_OFFSET

GLScene.OpenGL4

GL_VERTEX_BINDING_DIVISOR

GLScene.OpenGL4

GL_VERTEX_BINDING_OFFSET

GLScene.OpenGL4

GL_VERTEX_BINDING_STRIDE

GLScene.OpenGL4

GL_VERTEX_BLEND_ARB

GLScene.OpenGL4

GL_VERTEX_CONSISTENT_HINT_PGI

GLScene.OpenGL4

GL_VERTEX_DATA_HINT_PGI

GLScene.OpenGL4

GL_PGI_vertex_hints

GL_VERTEX_ID_NV

GLScene.OpenGL4

GL_VERTEX_PRECLIP_HINT_SGIX

GLScene.OpenGL4

GL_VERTEX_PRECLIP_SGIX

GLScene.OpenGL4

GL_SGIX_vertex_preclip

GL_VERTEX_PROGRAM_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_BINDING_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_NV

GLScene.OpenGL4

GL_NV_vertex_program

GL_VERTEX_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE_NV

GLScene.OpenGL4

GL_VERTEX_SHADER

GLScene.OpenGL4

GL_VERTEX_SHADER_ARB

GLScene.OpenGL4

GL_ARB_vertex_shader

GL_VERTEX_SHADER_BINDING_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_BIT

GLScene.OpenGL4

GL_ARB_separate_shader_objects

GL_VERTEX_SHADER_EXT

GLScene.OpenGL4

GL_EXT_vertex_shader

GL_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_VERTEX_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_OPTIMIZED_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SOURCE_ATI

GLScene.OpenGL4

GL_VERTEX_STATE_PROGRAM_NV

GLScene.OpenGL4

GL_VERTEX_STREAM0_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM1_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM2_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM3_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM4_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM5_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM6_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM7_ATI

GLScene.OpenGL4

GL_VERTEX_SUBROUTINE

GLScene.OpenGL4

GL_VERTEX_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_VERTEX_TEXTURE

GLScene.OpenGL4

GL_VERTEX_WEIGHTING_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VERTICAL_LINE_TO_NV

GLScene.OpenGL4

GL_VERTICES_SUBMITTED

GLScene.OpenGL4

GL_VERTICES_SUBMITTED_ARB

GLScene.OpenGL4

GL_ARB_pipeline_statistics_query

GL_VIBRANCE_BIAS_NV

GLScene.OpenGL4

GL_VIBRANCE_SCALE_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_BINDING_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_INTERNAL_FORMAT_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_NV

GLScene.OpenGL4

GL_NV_video_capture

GL_VIDEO_BUFFER_PITCH_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FIELD_LOWER_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FIELD_UPPER_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FRAME_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FRAME_WIDTH_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_SURFACE_ORIGIN_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_TO_422_SUPPORTED_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MATRIX_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MAX_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MIN_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_OFFSET_NV

GLScene.OpenGL4

GL_VIEWPORT

GLScene.OpenGL4

GL_VIEWPORT_BIT

GLScene.OpenGL4

GL_VIEWPORT_BOUNDS_RANGE

GLScene.OpenGL4

GL_VIEWPORT_INDEX_PROVOKING_VERTEX

GLScene.OpenGL4

GL_VIEWPORT_SUBPIXEL_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_128_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_16_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_24_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_32_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_48_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_64_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_8_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_96_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_BPTC_FLOAT

GLScene.OpenGL4

GL_VIEW_CLASS_BPTC_UNORM

GLScene.OpenGL4

GL_VIEW_CLASS_RGTC1_RED

GLScene.OpenGL4

GL_VIEW_CLASS_RGTC2_RG

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT1_RGB

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT1_RGBA

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT3_RGBA

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT5_RGBA

GLScene.OpenGL4

GL_VIEW_COMPATIBILITY_CLASS

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_INDEX_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_X_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_Y_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_Z_ARB

GLScene.OpenGL4

GL_VOLATILE_APPLE

GLScene.OpenGL4

GL_WAIT_FAILED

GLScene.OpenGL4

GL_WEIGHTED_AVERAGE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_WEIGHT_SUM_UNITY_ARB

GLScene.OpenGL4

GL_WIDE_LINE_HINT_PGI

GLScene.OpenGL4

GL_WIN_phong_shading

GLScene.OpenGL4

WGL

GL_WIN_specular_fog

GLScene.OpenGL4

WGL

GL_WRAP_BORDER_SUN

GLScene.OpenGL4

GL_SUN_convolution_border_modes

GL_WRITE_DISCARD_NV

GLScene.OpenGL4

GL_WRITE_ONLY

GLScene.OpenGL4

GL_WRITE_ONLY_ARB

GLScene.OpenGL4

GL_WRITE_PIXEL_DATA_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_WRITE_PIXEL_DATA_RANGE_NV

GLScene.OpenGL4

GL_NV_pixel_data_range

GL_WRITE_PIXEL_DATA_RANGE_POINTER_NV

GLScene.OpenGL4

GL_W_EXT

GLScene.OpenGL4

GL_XOR

GLScene.OpenGL4

GL_X_EXT

GLScene.OpenGL4

GL_YCBAYCR8A_4224_NV

GLScene.OpenGL4

GL_YCBCR_422_APPLE

GLScene.OpenGL4

GL_APPLE_ycbcr_422

GL_YCBYCR8_422_NV

GLScene.OpenGL4

GL_YCRCBA_SGIX

GLScene.OpenGL4

GL_YCRCB_422_SGIX

GLScene.OpenGL4

GL_SGIX_ycrcb

GL_YCRCB_444_SGIX

GLScene.OpenGL4

GL_YCRCB_SGIX

GLScene.OpenGL4

GL_SGIX_ycrcba

GL_Y_EXT

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4A12Z4Y12Z4CR12Z4A12_4224_NV

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4CR12_444_NV

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4Y12Z4CR12_422_NV

GLScene.OpenGL4

GL_Z6Y10Z6CB10Z6A10Z6Y10Z6CR10Z6A10_4224_NV

GLScene.OpenGL4

GL_Z6Y10Z6CB10Z6Y10Z6CR10_422_NV

GLScene.OpenGL4

GL_ZERO

GLScene.OpenGL4

BlendingFactorDest

GL_ZERO_EXT

GLScene.OpenGL4

GL_ZERO_TO_ONE

GLScene.OpenGL4

GL_ZOOM_X

GLScene.OpenGL4

GL_ZOOM_Y

GLScene.OpenGL4

GL_Z_EXT

GLScene.OpenGL4

GMTDateTimeToJulianDay

GLS.SkyDome

average earth radius in kilometers Converts a TDateTime (GMT+0) into the Julian day used for computations.

GRADIENT_TABLE_SIZE

GLS.ProcTextures

GraphicClassForExtension

GLS.Graphics

Returns the TGraphicClass associated to the extension, if any. Accepts anExtension with or without the '.'

GravitationalConstant

GLS.PhysFields

GRedBlackTree

GLScene.RedBlackTree

GRedBlackTree.TRBNode

GLScene.RedBlackTree

GUIComponentDialog

FmGuiSkinEditor

GUILayoutEditorForm

FmGuiLayoutEditor

GuiNullRect

GLS.Gui

G_DRAG

GLS.VerletTypes

HackTPictureRegisteredFormats

GLS.Graphics

Adds to the passed TStrings the list of registered formats. Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').

HalfElement

CUDA.DataAccess

HalfToFloat

GLScene.Utils

HCHANNEL

BASS.Import

sample handle

HDRAWDIB

Formats.VFW

************************************************************************* * * DRAWDIB - Routines for drawing to the display. * ************************************************************************

HDSP

BASS.Import

synchronizer handle

HFX

BASS.Import

DSP handle

HGPUNV

CUDA.Import

HGPUNV

GLScene.OpenGL4

HGPUNV

GLScene.OpenGLTokens

HIC

Formats.VFW

HIDE_NODE

Formats.m3DSConst

HIDE_TRACK_TAG

Formats.m3DSConst

HIERARCHY

Formats.m3DSConst

HIGHPASS_DEFAULT_GAIN

OpenAL.Import

HIGHPASS_DEFAULT_GAINLF

OpenAL.Import

HIGHPASS_MAX_GAIN

OpenAL.Import

HIGHPASS_MAX_GAINLF

OpenAL.Import

HIGHPASS_MIN_GAIN

OpenAL.Import

Highpass filter

HIGHPASS_MIN_GAINLF

OpenAL.Import

HiShadowBiasMin3DS

Formats.m3DSConst

noninclusive minimum value for low shadow bias setting HI_SHADOW_BIAS chunk

HI_SHADOW_BIAS

Formats.m3DSConst

HMODULE

OpenAL.Import

HMUSIC

BASS.Import

HookIntoResourceStrings

gnugettext

HotTrackTagMax3DS

Formats.m3DSConst

Minimum hot spot angle

HotTrackTagMin3DS

Formats.m3DSConst

Maximum camera FOV HOT_TRACK_TAG_KEY

HOT_TRACK_TAG

Formats.m3DSConst

HOT_TRACK_TAG_KEY

Formats.m3DSConst

HPBUFFERARB

GLScene.OpenGL4

HPBUFFERARB

GLScene.OpenGLTokens

HPLUGIN

BASS.Import

effect handle

HRECORD

BASS.Import

sample stream handle

HSAMPLE

BASS.Import

MOD music handle

HSTREAM

BASS.Import

sample playback handle

HSYNC

BASS.Import

recording handle

HVIDEO

Formats.VFW

== VIDEO - Video capture driver interface ===================================

HVIDEOINPUTDEVICENV

GLScene.OpenGL4

HVIDEOINPUTDEVICENV

GLScene.OpenGLTokens

IAVIEditStream

Formats.VFW

IAVIFile

Formats.VFW

– AVIFile ——————————————————————

IAVIStream

Formats.VFW

- - - - - - - - */
/****** AVI Stream Interface ******************************************

IAVIStreaming

Formats.VFW

ICAbout

Formats.VFW

ICClose

Formats.VFW

ICCompress

Formats.VFW

***********************************************************************
compression functions
************************************************************************/ /* * ICCompress() * * compress a single frame *

ICCompressBegin

Formats.VFW

* ICCompressBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOuput) is supported. *

ICCompressEnd

Formats.VFW

ICCOMPRESSFRAMES_PADDING

Formats.VFW

*********************************************************************** ***********************************************************************

ICCompressGetFormat

Formats.VFW

* ICCompressGetFormat() * * get the output format, (format of compressed data) * if lpbiOutput is NULL return the size in bytes needed for format. *

ICCompressGetFormatSize

Formats.VFW

ICCompressGetSize

Formats.VFW

* ICCompressSize() * * return the maximal size of a compressed frame *

ICCompressorChoose

Formats.VFW

COMPVARS contains valid data
allows user to choose compressor, quality etc...

ICCompressorFree

Formats.VFW

ICCompressQuery

Formats.VFW

* ICCompressQuery() * * determines if compression from a source format (lpbiInput) to a dest * format (lpbiOuput) is supported. *

ICCOMPRESS_KEYFRAME

Formats.VFW

*********************************************************************** ***********************************************************************

ICConfigure

Formats.VFW

ICDecompress

Formats.VFW

* ICDecompress() * * decompress a single frame *

ICDecompressBegin

Formats.VFW

* ICDecompressBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *

ICDecompressEnd

Formats.VFW

ICDecompressEx

Formats.VFW

* ICDecompressEx() * * decompress a single frame *

ICDecompressExBegin

Formats.VFW

* ICDecompressExBegin() * * start compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *

ICDecompressExEnd

Formats.VFW

ICDecompressExQuery

Formats.VFW

* ICDecompressExQuery() *

ICDecompressGetFormat

Formats.VFW

* ICDecompressGetFormat() * * get the output format, (format of un-compressed data) * if lpbiOutput is NULL return the size in bytes needed for format. *

ICDecompressGetFormatSize

Formats.VFW

ICDecompressGetPalette

Formats.VFW

* ICDecompressGetPalette() * * get the output palette *

ICDecompressOpen

Formats.VFW

ICDecompressQuery

Formats.VFW

* ICDecompressQuery() * * determines if compression from a source format (lpbiInput) to a dest * format (lpbiOutput) is supported. *

ICDecompressSetPalette

Formats.VFW

ICDECOMPRESS_HURRYUP

Formats.VFW

*********************************************************************** ***********************************************************************

ICDECOMPRESS_NOTKEYFRAME

Formats.VFW

repeat last frame

ICDECOMPRESS_NULLFRAME

Formats.VFW

this frame is before real start

ICDECOMPRESS_PREROLL

Formats.VFW

don't draw just update screen

ICDECOMPRESS_UPDATE

Formats.VFW

don't draw just buffer (hurry up!)

ICDraw

Formats.VFW

* ICDraw() * * decompress data directly to the screen *

ICDrawBegin

Formats.VFW

* ICDrawBegin() * * start decompressing data with format (lpbiInput) directly to the screen * * return zero if the decompressor supports drawing. *

ICDrawChangePalette

Formats.VFW

ICDrawEnd

Formats.VFW

ICDrawFlush

Formats.VFW

ICDrawGetTime

Formats.VFW

ICDrawOpen

Formats.VFW

ICDrawQuery

Formats.VFW

* ICDrawQuery() * * determines if the compressor is willing to render the specified format. *

ICDrawRealize

Formats.VFW

ICDrawRenderBuffer

Formats.VFW

ICDrawSetTime

Formats.VFW

ICDrawStart

Formats.VFW

ICDrawStartPlay

Formats.VFW

ICDrawStop

Formats.VFW

ICDrawStopPlay

Formats.VFW

ICDrawSuggestFormat

Formats.VFW

ICMessage is not supported on Win32, so provide a static inline function to do the same job

ICDrawWindow

Formats.VFW

– Draw window macro ——————————————————–

ICDRAW_ANIMATE

Formats.VFW

draw to a HDC/HWND

ICDRAW_BUFFER

Formats.VFW

used to render data not draw it

ICDRAW_CONTINUE

Formats.VFW

expect palette animation

ICDRAW_FULLSCREEN

Formats.VFW

test for support

ICDRAW_HDC

Formats.VFW

draw to full screen

ICDRAW_HURRYUP

Formats.VFW

*********************************************************************** ***********************************************************************

ICDRAW_MEMORYDC

Formats.VFW

draw is a continuation of previous draw

ICDRAW_NOTKEYFRAME

Formats.VFW

repeat last frame

ICDRAW_NULLFRAME

Formats.VFW

this frame is before real start

ICDRAW_PREROLL

Formats.VFW

don't draw just update screen

ICDRAW_QUERY

Formats.VFW

*********************************************************************** ***********************************************************************

ICDRAW_RENDER

Formats.VFW

We're updating, as opposed to playing

ICDRAW_UPDATE

Formats.VFW

don't draw just buffer (hurry up!)

ICDRAW_UPDATING

Formats.VFW

DC is offscreen, by the way

ICERR_ABORT

Formats.VFW

ICERR_BADBITDEPTH

Formats.VFW

ICERR_BADFLAGS

Formats.VFW

ICERR_BADFORMAT

Formats.VFW

ICERR_BADHANDLE

Formats.VFW

ICERR_BADIMAGESIZE

Formats.VFW

ICERR_BADPARAM

Formats.VFW

ICERR_BADSIZE

Formats.VFW

ICERR_CANTUPDATE

Formats.VFW

ICERR_CUSTOM

Formats.VFW

ICERR_DONTDRAW

Formats.VFW

ICERR_ERROR

Formats.VFW

ICERR_GOTOKEYFRAME

Formats.VFW

ICERR_INTERNAL

Formats.VFW

ICERR_MEMORY

Formats.VFW

ICERR_NEWPALETTE

Formats.VFW

ICERR_OK

Formats.VFW

audc

ICERR_STOPDRAWING

Formats.VFW

ICERR_UNSUPPORTED

Formats.VFW

ICGetBuffersWanted

Formats.VFW

ICGetDefaultKeyFrameRate

Formats.VFW

ICGetDefaultQuality

Formats.VFW

– Get value macros ———————————————————

ICGetDisplayFormat

Formats.VFW

ICGetInfo

Formats.VFW

ICGetState

Formats.VFW

– Get/Set state macros —————————————————–

ICGetStateSize

Formats.VFW

ICImageCompress

Formats.VFW

*********************************************************************** Higher level functions ***********************************************************************

ICImageDecompress

Formats.VFW

ICInfo

Formats.VFW

***********************************************************************
ICM function declarations
***********************************************************************

ICInstall

Formats.VFW

ICINSTALL_DRIVER

Formats.VFW

lParam is a DriverProc (function ptr)

ICINSTALL_DRIVERW

Formats.VFW

lParam is a HDRVR (driver handle)

ICINSTALL_FUNCTION

Formats.VFW

ICINSTALL_HDRV

Formats.VFW

lParam is a driver name (string)

ICINSTALL_UNICODE

Formats.VFW

– Values for wFlags of ICInstall ——————————————-

ICLocate

Formats.VFW

***********************************************************************
helper routines for DrawDib and MCIAVI...
***********************************************************************

ICMF_ABOUT_QUERY

Formats.VFW

ICMF_CHOOSE_ALLCOMPRESSORS

Formats.VFW

allow expanded preview dialog

ICMF_CHOOSE_DATARATE

Formats.VFW

show KeyFrame Every box

ICMF_CHOOSE_KEYFRAME

Formats.VFW

defines for uiFlags

ICMF_CHOOSE_PREVIEW

Formats.VFW

show DataRate box

ICMF_COMPVARS_VALID

Formats.VFW

FLAGS for dwFlags element of COMPVARS structure: set this flag if you initialize COMPVARS before calling ICCompressorChoose

ICMF_CONFIGURE_QUERY

Formats.VFW

– Query macros ————————————————————-

ICMODE_COMPRESS

Formats.VFW

– Values for dwFlags of ICOpen() ——————————————-

ICMODE_DECOMPRESS

Formats.VFW

ICMODE_DRAW

Formats.VFW

ICMODE_FASTCOMPRESS

Formats.VFW

ICMODE_FASTDECOMPRESS

Formats.VFW

ICMODE_QUERY

Formats.VFW

ICM_ABOUT

Formats.VFW

show the configure dialog

ICM_COMPRESS

Formats.VFW

begin a series of compress calls.

ICM_COMPRESS_BEGIN

Formats.VFW

query support for compress

ICM_COMPRESS_END

Formats.VFW

compress a frame

ICM_COMPRESS_FRAMES_INFO

Formats.VFW

end a series of decompress calls

ICM_COMPRESS_GET_FORMAT

Formats.VFW

***********************************************************************
ICM specific messages.
***********************************************************************

ICM_COMPRESS_GET_SIZE

Formats.VFW

get compress format or size

ICM_COMPRESS_QUERY

Formats.VFW

get output size

ICM_CONFIGURE

Formats.VFW

Query info about the compressor

ICM_DECOMPRESS

Formats.VFW

start a series of decompress calls

ICM_DECOMPRESSEX

Formats.VFW

start a series of decompress calls

ICM_DECOMPRESSEX_BEGIN

Formats.VFW

get the default value for key frames

ICM_DECOMPRESSEX_END

Formats.VFW

decompress a frame

ICM_DECOMPRESSEX_QUERY

Formats.VFW

start a series of decompress calls

ICM_DECOMPRESS_BEGIN

Formats.VFW

query support for dempress

ICM_DECOMPRESS_END

Formats.VFW

decompress a frame

ICM_DECOMPRESS_GET_FORMAT

Formats.VFW

end of a series of compress calls.

ICM_DECOMPRESS_GET_PALETTE

Formats.VFW

fill in the DIB color table

ICM_DECOMPRESS_QUERY

Formats.VFW

get decompress format or size

ICM_DECOMPRESS_SET_PALETTE

Formats.VFW

end a series of decompress calls

ICM_DRAW

Formats.VFW

get value of decompress clock

ICM_DRAW_BEGIN

Formats.VFW

query support for dempress

ICM_DRAW_CHANGEPALETTE

Formats.VFW

Like ICGetDisplayFormat

ICM_DRAW_END

Formats.VFW

stop decompress clock

ICM_DRAW_FLUSH

Formats.VFW

realize palette for drawing

ICM_DRAW_GETTIME

Formats.VFW

end a series of draw calls

ICM_DRAW_GET_PALETTE

Formats.VFW

start a series of draw calls

ICM_DRAW_QUERY

Formats.VFW

fill in the DIB color table

ICM_DRAW_REALIZE

Formats.VFW

set correct value for decompress clock

ICM_DRAW_RENDERBUFFER

Formats.VFW

clear out buffered frames

ICM_DRAW_SETTIME

Formats.VFW

drawing window has moved or hidden

ICM_DRAW_START

Formats.VFW

get the palette needed for drawing

ICM_DRAW_START_PLAY

Formats.VFW

draw undrawn things in queue

ICM_DRAW_STOP

Formats.VFW

start decompress clock

ICM_DRAW_STOP_PLAY

Formats.VFW

start of a play

ICM_DRAW_SUGGESTFORMAT

Formats.VFW

end of a play

ICM_DRAW_WINDOW

Formats.VFW

generalized "render" message

ICM_FRAMERATE

Formats.VFW

– Constants for ICM_SET: —————————————————

ICM_GET

Formats.VFW

Tell the driver something

ICM_GETBUFFERSWANTED

Formats.VFW

for animating palette

ICM_GETDEFAULTKEYFRAMERATE

Formats.VFW

ask about prebuffering

ICM_GETDEFAULTQUALITY

Formats.VFW

show the about box

ICM_GETINFO

Formats.VFW

Set compressor state

ICM_GETQUALITY

Formats.VFW

get the default value for quality

ICM_GETSTATE

Formats.VFW

***********************************************************************
messages.
***********************************************************************

ICM_KEYFRAMERATE

Formats.VFW

FrmR

ICM_RESERVED

Formats.VFW

ICM_RESERVED_HIGH

Formats.VFW

ICM_RESERVED_LOW

Formats.VFW

ICM_SET

Formats.VFW

set the default value for quality

ICM_SETQUALITY

Formats.VFW

get the current value for quality

ICM_SETSTATE

Formats.VFW

Get compressor state

ICM_SET_STATUS_PROC

Formats.VFW

tell about compress to come

ICM_USER

Formats.VFW

*********************************************************************** ***********************************************************************

ICOpen

Formats.VFW

ICOpenFunction

Formats.VFW

ICQUALITY_DEFAULT

Formats.VFW

ICQUALITY_HIGH

Formats.VFW

ICQUALITY_LOW

Formats.VFW

– quality flags ————————————————————

ICQueryAbout

Formats.VFW

ICQueryConfigure

Formats.VFW

ICRemove

Formats.VFW

ICSendMessage

Formats.VFW

ICSeqCompressFrame

Formats.VFW

ICSeqCompressFrameEnd

Formats.VFW

ICSeqCompressFrameStart

Formats.VFW

don't only show those that can handle the input format or input data

ICSetState

Formats.VFW

ICSetStatusProc

Formats.VFW

ICMessage is not supported on NT

ICSTATUS_END

Formats.VFW

l = % done

ICSTATUS_ERROR

Formats.VFW

ICSTATUS_START

Formats.VFW

– Messages for Status callback ———————————————

ICSTATUS_STATUS

Formats.VFW

ICSTATUS_YIELD

Formats.VFW

l = error string (LPSTR)

ICTYPE_AUDIO

Formats.VFW

vidc

ICTYPE_VIDEO

Formats.VFW

ICVERSION

Formats.VFW

*************************************************************************** * * COMPMAN - Installable Compression Manager. * ***************************************************************************

ID4ToInt

Formats.LWO

IdentityHmgDblMatrix

GLScene.VectorGeometry

IdentityHmgMatrix

GLScene.VectorGeometry

IdentityMatrix

GLScene.VectorGeometry

IdentityQuaternion

GLScene.VectorGeometry

Quaternions

IDS_CAP_AUDIO_DROP_ERROR

Formats.VFW

"Error: Unable to initialize compressor."

IDS_CAP_AVI_DRAWDIB_ERROR

Formats.VFW

"Error: No audio data captured.\nCheck audio card settings."

IDS_CAP_AVI_INIT_ERROR

Formats.VFW

"Error while recording"

IDS_CAP_BEGIN

Formats.VFW

– String IDs from status and error callbacks ——————————-

IDS_CAP_CANTOPEN

Formats.VFW

"pal"

IDS_CAP_COMPRESSOR_ERROR

Formats.VFW

"Error: Unable to draw this data format."

IDS_CAP_DEFAVIEXT

Formats.VFW

"Error saving frame '%s'"

IDS_CAP_DEFPALEXT

Formats.VFW

"avi"

IDS_CAP_DRIVER_ERROR

Formats.VFW

"SaveAs: %2ld%% Hit Escape to abort."

IDS_CAP_END

Formats.VFW

"Capture Start"

IDS_CAP_ERRORDIBSAVE

Formats.VFW

"Error saving palette '%s'"

IDS_CAP_ERRORPALOPEN

Formats.VFW

"File '%s' exists – overwrite it?"

IDS_CAP_ERRORPALSAVE

Formats.VFW

"Error opening palette '%s'"

IDS_CAP_FILEEXISTS

Formats.VFW

"Out of memory"

IDS_CAP_FILE_OPEN_ERROR

Formats.VFW

"Error: Bad video size."

IDS_CAP_FILE_WRITE_ERROR

Formats.VFW

"Error: Cannot open capture file."

IDS_CAP_INFO

Formats.VFW

"Capture End"

IDS_CAP_MCI_CANT_STEP_ERROR

Formats.VFW

"Error: Unable to access MCI device."

IDS_CAP_MCI_CONTROL_ERROR

Formats.VFW

"Warning: Using default palette."

IDS_CAP_NODISKSPACE

Formats.VFW

"Unable to write to file '%s'.\nDisk may be full."

IDS_CAP_NO_AUDIO_CAP_ERROR

Formats.VFW

"Error: Unable to step MCI device."

IDS_CAP_NO_FRAME_CAP_ERROR

Formats.VFW

"Error: Unable to initialize for capture."

IDS_CAP_NO_PALETTE_WARN

Formats.VFW

"Warning: No frames captured.\nConfirm that vertical sync interrupts\nare configured and enabled."

IDS_CAP_OUTOFMEM

Formats.VFW

"%s"

IDS_CAP_READONLYFILE

Formats.VFW

"An error occurred while trying to run VidEdit."

IDS_CAP_RECORDING_ERROR

Formats.VFW

"Error: Cannot write to capture file. Disk may be full."

IDS_CAP_RECORDING_ERROR2

Formats.VFW

"Error: Cannot write to capture file. Data rate too high or disk full."

IDS_CAP_SAVEASPERCENT

Formats.VFW

"Set File Size"

IDS_CAP_SEQ_MSGSTART

Formats.VFW

"Cannot open '%s'"

IDS_CAP_SEQ_MSGSTOP

Formats.VFW

"Select OK to start capture\nof video sequence\nto %s."

IDS_CAP_SETFILESIZE

Formats.VFW

"There is no space to create a capture file on the specified device."

IDS_CAP_STAT_CAP_AUDIO

Formats.VFW

"Captured %ld frames"

IDS_CAP_STAT_CAP_FINI

Formats.VFW

"Setting up for capture - Please wait"

IDS_CAP_STAT_CAP_INIT

Formats.VFW

"Overlay window"

IDS_CAP_STAT_CAP_L_FRAMES

Formats.VFW

"%ld frames"

IDS_CAP_STAT_FRAMESDROPPED

Formats.VFW

"Captured %d.%03d sec. %ld frames (%ld dropped) (%d.%03d fps)"

IDS_CAP_STAT_I_FRAMES

Formats.VFW

"Computing optimal palette"

IDS_CAP_STAT_LIVE_MODE

Formats.VFW

– Status string IDs ——————————————————–

IDS_CAP_STAT_L_FRAMES

Formats.VFW

"%d frames"

IDS_CAP_STAT_OPTPAL_BUILD

Formats.VFW

"Building palette map"

IDS_CAP_STAT_OVERLAY_MODE

Formats.VFW

"Live window"

IDS_CAP_STAT_PALETTE_BUILD

Formats.VFW

"Finished capture, now writing frame %ld"

IDS_CAP_STAT_VIDEOAUDIO

Formats.VFW

"Captured %ld frames (%ld dropped) %d.%03d sec."

IDS_CAP_STAT_VIDEOCURRENT

Formats.VFW

"Capturing audio"

IDS_CAP_STAT_VIDEOONLY

Formats.VFW

"Captured %d.%03d sec. %ld frames (%ld dropped) (%d.%03d fps). %ld audio bytes (%d,%03d sps)"

IDS_CAP_VIDEDITERR

Formats.VFW

"Hit ESCAPE or click to end capture"

IDS_CAP_VIDEO_ADD_ERROR

Formats.VFW

"Error: Cannot prepare video buffers."

IDS_CAP_VIDEO_ALLOC_ERROR

Formats.VFW

"Error: Cannot open the video input device."

IDS_CAP_VIDEO_OPEN_ERROR

Formats.VFW

"Error: Bad wave size."

IDS_CAP_VIDEO_PREPARE_ERROR

Formats.VFW

"Error: Out of memory for video buffers."

IDS_CAP_VIDEO_SIZE_ERROR

Formats.VFW

"Error: Cannot add video buffers."

IDS_CAP_WAVE_ADD_ERROR

Formats.VFW

"Error: Cannot prepare wave buffers."

IDS_CAP_WAVE_ALLOC_ERROR

Formats.VFW

"Error: Cannot open the wave input device.\nCheck sample size, frequency, and channels."

IDS_CAP_WAVE_OPEN_ERROR

Formats.VFW

Driver specific error message

IDS_CAP_WAVE_PREPARE_ERROR

Formats.VFW

"Error: Out of memory for wave buffers."

IDS_CAP_WAVE_SIZE_ERROR

Formats.VFW

"Error: Cannot add wave buffers."

IDS_CAP_WRITEERROR

Formats.VFW

"The file '%s' is a read-only file."

IDTFConverterFileName

GLS.File3DPDF

global variable for accing the IDTF->U3D converter

ID_ALPH

Formats.LWO

SMOOTHING ANGLE RADIANS

ID_ANIM

Formats.LWO

IMAGE SEQUENCE

ID_BBOX

Formats.LWO

CLIP

ID_BRIT

Formats.LWO

CONTRAST

ID_BTEX

Formats.LWO

LUMINANCE TEXTURE

ID_CLIP

Formats.LWO

ENVELOPE

ID_COLR

Formats.LWO

Surfaces chunk

ID_CONT

Formats.LWO

COLOR CYCLING STILL

ID_CRVS

Formats.LWO

Polygons chunk

ID_CTEX

Formats.LWO

ALPHA MODE

ID_DESC

Formats.LWO

BOUNDING BOX

ID_DIFF

Formats.LWO

Luminosity

ID_DTEX

Formats.LWO

COLOR TEXTURE

ID_EDGE

Formats.LWO

REFRACTIVE INDEX

ID_ENVL

Formats.LWO

DISCONTINUOUS VERTEX MAP

ID_FLAG

Formats.LWO

Color chunk

ID_FLYR

Formats.LWO

IMAGE SEQUENCE

ID_FORM

Formats.LWO

Lightwave scene file

ID_GAMMA

Formats.LWO

HUE

ID_GLOS

Formats.LWO

Transparency

ID_HUE

Formats.LWO

SATURATION

ID_ICON

Formats.LWO

TEXT

ID_IFLT

Formats.LWO

NEGATIVE IMAGE

ID_IMCC

Formats.LWO

FLYER SEQUENCE

ID_IMSQ

Formats.LWO

ID_ISEQ

Formats.LWO

STILL IMAGE FILENAME

ID_LAYR

Formats.LWO

Lightwave Layered Object

ID_LTEX

Formats.LWO

TRANSPARENCY TEXTURE

ID_LUMI

Formats.LWO

Surface Flags

ID_LWLO

Formats.LWO

Lightwave Object version 1.0 - 5.x

ID_LWO2

Formats.LWO

ID_LWOB

Formats.LWO

IFF Form

ID_LWSC

Formats.LWO

NULL ID

ID_NEGA

Formats.LWO

GAMMA

ID_NULL

Formats.LWO

ID_PCHS

Formats.LWO

Curves chunk

ID_PFLT

Formats.LWO

IMAGE PLUG-IN FILTER

ID_PNTS

Formats.LWO

LAYER

ID_POLS

Formats.LWO

Surface Names chunk

ID_PTAG

Formats.LWO

TAGS?

ID_REFL

Formats.LWO

Specular

ID_RFLT

Formats.LWO

Sidedness

ID_RFOP

Formats.LWO

REFLECTION MODE (PRE 6.0)

ID_RIMG

Formats.LWO

REFLECTION OPTIONS

ID_RIND

Formats.LWO

REFLECTION MAP SEAM ANGLE

ID_RSAN

Formats.LWO

REFLECTION IMAGE

ID_RTEX

Formats.LWO

SPECULAR TEXTURE

ID_SATR

Formats.LWO

BRIGHTNESS

ID_SDAT

Formats.LWO

ID_SHDR

Formats.LWO

ID_SIDE

Formats.LWO

Glossiness SmallInt

ID_SMAN

Formats.LWO

EDGE TRANSPARENCY THRESHOLD

ID_SPEC

Formats.LWO

Diffuse

ID_SRFS

Formats.LWO

Points chunk

ID_STCC

Formats.LWO

PLUGIN ANIMATION

ID_STEX

Formats.LWO

DIFFUSE TEXTURE

ID_STIL

Formats.LWO

NAME

ID_SURF

Formats.LWO

Patches chunk

ID_TAAS

Formats.LWO

TEXTURE WRAP

ID_TAGS

Formats.LWO

VERTEX MAP

ID_TALP

Formats.LWO

TEXTURE IMG

ID_TAMP

Formats.LWO

TEXTURE VALUE

ID_TCLR

Formats.LWO

TEXTURE REFERENCE

ID_TCTR

Formats.LWO

TEXTURE SIZE

ID_TEXT

Formats.LWO

DESCRIPTION

ID_TFAL

Formats.LWO

TEXTURE CENTER

ID_TFLG

Formats.LWO

BUMP TEXTURE

ID_TFP0

Formats.LWO

TEXTURE AMPLITUDE

ID_TFP1

Formats.LWO

TEXTURE PARAMETERS

ID_TFP2

Formats.LWO

ID_TFRQ

Formats.LWO

ID_TIMG

Formats.LWO

ID_TIP0

Formats.LWO

ID_TIP1

Formats.LWO

ID_TIP2

Formats.LWO

ID_TOPC

Formats.LWO

ID_TRAN

Formats.LWO

Reflective

ID_TREF

Formats.LWO

TEXTURE VALUE

ID_TSIZ

Formats.LWO

TEXTURE FLAGS

ID_TSP0

Formats.LWO

ID_TSP1

Formats.LWO

ID_TSP2

Formats.LWO

ID_TTEX

Formats.LWO

REFLECTIION TEXTURE

ID_TVAL

Formats.LWO

TEXTURE COLOR

ID_TVEL

Formats.LWO

TEXTURE FALLOFF

ID_TWRP

Formats.LWO

ID_VDIF

Formats.LWO

Luminosity

ID_VLUM

Formats.LWO

Transparency

ID_VMAD

Formats.LWO

POLYGON TAG MAP

ID_VMAP

Formats.LWO

OBJECT

ID_VRFL

Formats.LWO

Specularity

ID_VSPC

Formats.LWO

Diffuse

ID_VTRN

Formats.LWO

Reflective

IGetFrame

Formats.VFW

The functions 'BeginExtraction' and 'EndExtraction' have actually the names 'Begin' and 'End', but we cannot use that identifiers for obvious reasons.

IGLInitializable

GLS.Scene

Interface to objects that need initialization

IGLMaterialLibrarySupported

GLS.Material

an interface for proper TGLLibMaterialNameProperty support

IGLPostShader

GLSL.CustomShader

Used in the TGLPostShaderHolder component.

IGLShaderDescription

GLSL.CustomShader

This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.

IGLTextureNotifyAble

GLS.Texture

IGnuGettextInstanceWhenNewLanguageListener

gnugettext

*—————————————————————————— Interface to implement if you want to register as a language change listener ——————————————————————————-

IID_IAVIEditStream

Formats.VFW

IID_IAVIFile

Formats.VFW

– GUIDs ——————————————————————–

IID_IAVIStream

Formats.VFW

IID_IAVIStreaming

Formats.VFW

IID_IGetFrame

Formats.VFW

ILength

GLScene.VectorGeometry

ILength

GLScene.VectorGeometry

Computes an integer length Result:=Sqrt(x*x+y*y)

ImageAlphaBottomRightPointColorTransparent

GLS.ImageUtils

ImageAlphaFromIntensity

GLS.ImageUtils

ImageAlphaInverseLuminance

GLS.ImageUtils

ImageAlphaInverseLuminanceSqrt

GLS.ImageUtils

ImageAlphaLuminance

GLS.ImageUtils

ImageAlphaLuminanceSqrt

GLS.ImageUtils

ImageAlphaOpaque

GLS.ImageUtils

ImageAlphaSuperBlackTransparent

GLS.ImageUtils

ImageAlphaTopLeftPointColorTransparent

GLS.ImageUtils

ImageBellFilter

GLS.ImageUtils

ImageBoxFilter

GLS.ImageUtils

ImageHermiteFilter

GLS.ImageUtils

ImageLanczos3Filter

GLS.ImageUtils

ImageMitchellFilter

GLS.ImageUtils

ImageSplineFilter

GLS.ImageUtils

ImageTriangleFilter

GLS.ImageUtils

IMSQ_FLAG_INTERLACE

Formats.LWO

IMSQ_FLAG_LOOP

Formats.LWO

IncludeFilePath

GLS.CgShader

Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.

IncludeInClipRect

GLScene.GeometryBB

Extend the clip rect to include given coordinate.

IncreaseCoherency

GLS.MeshUtils

Increases indices coherency wrt vertex caches. The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips). This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).

InflateGLRect

GLScene.Utils

Increases or decreases the width and height of the specified rectangle. Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.

InformationDlg

GLS.ImageUtils

Pops up a simple dialog with msg and an Ok button.

infotypeDIGITIZATION_TIME

Formats.VFW

– New information chunk IDs ————————————————

infotypeSMPTE_TIME

Formats.VFW

mmioFOURCC ('I','D','I','T')

Init

GLScene.VectorTypesExt

InitChunk

Formats.m3DSUtils

InitCUDA

CUDA.Import

InitCUDAFromLibrary

CUDA.Import

InitCUDART

CUDA.Runtime

InitCUDARTFromLibrary

CUDA.Runtime

InitCUFFT

CUDA.FourierTransform

InitCUFFTFromLibrary

CUDA.FourierTransform

InitCUTIL

CUDA.Utility

InitCUTILFromLibrary

CUDA.Utility

InitFaceArray3DS

Formats.m3DSConst

InitFromLibraryOpenCL

OpenCL.Import

InitializeRandomGenerator

GLS.RandomHDS

Initialize_Contouring

GLS.Isolines

InitMatArray3DS

Formats.m3DSConst

InitNoExtras3DS

Formats.m3DSConst

Flags for initflags parameter

InitNx

PhysX.Import

InitObjectMotion

Formats.m3DSUtils

InitODE

ODE.Import

These are made public in the dynamic version MRQZZZ

InitOpenAL

OpenAL.Import

InitOpenCL

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2 * Deprecated OpenCL 1.1 APIs *// clCreateImage2D(); clCreateImage3D(); clEnqueueMarker(); clEnqueueWaitForEvents(); clEnqueueBarrier(); clUnloadCompiler(); clGetExtensionFunctionAddress(); * Deprecated OpenCL 2.0 APIs *// clCreateCommandQueue(); clCreateSampler(); clEnqueueTask(); ————————————————————————-

InitOpenGL

GLS.OpenGLAdapter

InitOpenGL

GLScene.OpenGL4

InitOpenGLFromLibrary

GLS.OpenGLAdapter

InitOpenGLFromLibrary

GLScene.OpenGL4

InitProcData3DS

Formats.m3DSConst

InitSmoothArray3DS

Formats.m3DSConst

InitTextArray3DS

Formats.m3DSConst

InitTexture

GLSL.CustomShader

InitTranslation

GnuGetTextInit

InitTranslation has to be placed in the project file before "Application.Initialize" "Domains" is a list of all po/mo files needed by the application Calling sample: InitTranslation(['delphi10','indy10']);

InitVertexArray3DS

Formats.m3DSConst

InitVFlagArray3DS

Formats.m3DSConst

InputDlg

GLS.ImageUtils

Posp a simple dialog with a string input.

InstanceNameStrMax3DS

Formats.m3DSConst

Maximum node name string size INSTANCE_NAME

INSTANCE_NAME

Formats.m3DSConst

int

Formats.VFW

IntElement

CUDA.DataAccess

InternalFormatToOpenGLFormat

GLScene.TextureFormat

Give a openGL texture format from GLScene texture format

INTERPCT

Formats.m3DSConst

InterpolateCombined

GLScene.VectorGeometry

InterpolateCombinedFast

GLScene.VectorGeometry

InterpolateCombinedFastPower

GLScene.VectorGeometry

InterpolateCombinedSafe

GLScene.VectorGeometry

InterpolateExp

GLScene.VectorGeometry

InterpolateLn

GLScene.VectorGeometry

InterpolatePower

GLScene.VectorGeometry

There functions that do the same as "Lerp", but add some distortions

InterpolateSin

GLScene.VectorGeometry

Only valid where Delta belongs to [0..1]

InterpolateSinAlt

GLScene.VectorGeometry

"Alt" functions are valid everywhere

InterpolateTan

GLScene.VectorGeometry

IntersectAABBs

GLScene.GeometryBB

Determines if two AxisAlignedBoundingBoxes intersect. The matrices are the ones that convert one point to the other's AABB system

IntersectAABBsAbsolute

GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide.

IntersectAABBsAbsoluteXY

GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide in the XY plane.

IntersectAABBsAbsoluteXZ

GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide in the XZ plane.

IntersectCubes

GLS.Collision

Returns true when the bounding box cubes does intersect the other. Also true when the one cube does contain the other completely.

IntersectGLRect

GLScene.Utils

IntersectLinePlane

GLScene.VectorGeometry

Compute the intersection point "res" of a line with a plane. Return value: 0 : no intersection, line parallel to plane 1 : res is valid -1 : line is inside plane Adapted from: E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988

IntersectSphereBox

GLScene.VectorGeometry

Compute intersection between a Sphere and a box. Up, Direction and Right must be normalized! Use CubDepth, CubeHeight and CubeWidth to scale TGLCube

IntersectTriangleBox

GLScene.VectorGeometry

Compute intersection between a triangle and a box. Returns True if an intersection was found

IntPercentageMax3DS

Formats.m3DSConst

maximum color value in a channel INT_PERCENTAGE

intptr_t

OpenCL.Platform

INT_PERCENTAGE

Formats.m3DSConst

INVALID_CUFFT_HANDLE

CUDA.FourierTransform

INVALID_MODULEHANDLE_VALUE

ModuleLoader

Value designating an unassigned TModuleHandle od a failed loading

InvertMatrix

GLScene.VectorGeometry

Finds the inverse of a 3x3 matrix;

InvertMatrix

GLScene.VectorGeometry

Finds the inverse of a 4x4 matrix

InvertTrianglesWinding

GLS.MeshUtils

Inverts the triangles winding (vertex order).

InvokeInfoForm

GLS.Scene

IsCgProfileSupported

GLS.CgShader

Misc. global functions

IsChunk

Formats.m3DSConst

IsColinear

GLScene.VectorGeometry

Returns true if both vector are colinear

IsColinear

GLScene.VectorGeometry

Returns true if both vector are colinear

IsColinear

GLScene.VectorGeometry

Returns true if both vector are colinear

IsCompressedFormat

GLScene.TextureFormat

IsCompressedFormat

GLScene.TextureFormat

True if texture compressed

IsCUDAInitialized

CUDA.Import

IsCUDARTInitialized

CUDA.Runtime

IsCUFFTInitialized

CUDA.FourierTransform

IsCUTILInitialized

CUDA.Utility

IsDepthFormat

GLScene.TextureFormat

IsDepthFormat

GLScene.TextureFormat

True if depth texture

IsDesignTime

GLScene.Utils

IsDirectoryWriteable

GLScene.Utils

Determine if the directory is writable.

IsFloatFormat

GLScene.TextureFormat

IsFloatFormat

GLScene.TextureFormat

True if texture format is float

IsFogEnabled

GLSL.CustomShader

IsFormatSupported

GLScene.TextureFormat

True if texture format is supported by hardware or software

IShaderParameter

GLSL.ShaderParameter

IsInCube

GLScene.VectorGeometry

IsInCube

GLScene.VectorGeometry

Returns True if p is in the cube defined by d.

IsInitializedOpenCL

OpenCL.Import

IsInRange

GLScene.VectorGeometry

IsInRange

GLScene.VectorGeometry

Returns True if x is in [a; b]

IsInRect

GLS.Gui

IsKeyDown

GLScene.Keyboard

Check if the given virtual key is down. This function is just a wrapper for GetAsyncKeyState.

IsKeyDown

GLScene.Keyboard

Check if the key corresponding to the given Char is down. The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad. The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).

IsLineIntersectQuad

GLScene.VectorGeometry

Returns true if line intersect ABCD quad. Quad have to be flat and convex

IsLineIntersectTriangle

GLScene.VectorGeometry

Returns true if line intersect ABC triangle

IsMainThread

GLS.Context

IsMesaGL

GLS.OpenGLAdapter

IsMesaGL

GLScene.OpenGL4

IsODEInitialized

ODE.Import

IsOpenGLInitialized

GLS.OpenGLAdapter

IsOpenGLInitialized

GLScene.OpenGL4

IsOpenGLLoaded

GLS.OpenGLAdapter

IsOpenGLLoaded

GLScene.OpenGL4

IsOpenGLVersionMet

GLScene.OpenGL4

IsPointInPolygon

GLScene.VectorGeometry

PtInRegion

IsPowerOf2

GLScene.Utils

Returns True if value is a true power of two

ISqrt

GLScene.VectorGeometry

Computes an integer sqrt approximation

IsServiceContextAvaible

GLS.Context

IsSubComponent

GLScene.Utils

Classes.pas

IsTargetSupported

GLScene.TextureFormat

IsTargetSupported

GLScene.TextureFormat

True if texture target supported

IsTargetSupportMipmap

GLScene.TextureFormat

IsTargetSupportMipmap

GLScene.TextureFormat

IsVersionMet

GLS.OpenGLAdapter

IsVersionMet

GLScene.OpenGL4

IsVolumeClipped

GLScene.VectorGeometry

IsVolumeClipped

GLScene.VectorGeometry

IsVolumeClipped

GLScene.VectorGeometry

Determines if volume is clipped or not

Jpeg2Bmp

GLS.FileJPEG

kBrushes

Formats.Q3BSP

Stores the info of world models

kBrushSides

Formats.Q3BSP

Stores the brushes info (for collision)

kEntities

Formats.Q3BSP

KeyboardNotifyWheelMoved

GLScene.Keyboard

Use this procedure to notify a wheel movement and have it resurfaced as key stroke. Honoured by IsKeyDown and KeyPressed

KeyNameToVirtualKeyCode

GLScene.Keyboard

Converts a key name to its virtual key code. The comparison is **NOT** case-sensitive, if no match is found, returns -1. The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.

KeyPressed

GLScene.Keyboard

Returns the first pressed key whose virtual key code is >= to minVkCode. If no key is pressed, the return value is -1, this function does NOT wait for user input. If you don't care about multiple key presses, just don't use the parameter.

KeyUsesBias3DS

Formats.m3DSConst

KeyUsesCont3DS

Formats.m3DSConst

KeyUsesEaseFrom3DS

Formats.m3DSConst

KeyUsesEaseTo3DS

Formats.m3DSConst

KeyUsesTension3DS

Formats.m3DSConst

flags the face as being at a texture coord v wrap seam flags used by the rflags field of the keyheader3DS structure

kFaces

Formats.Q3BSP

Stores the shader files (blending, anims..)

KFBiasMax3DS

Formats.m3DSConst

Minimum key spline bias

KFBiasMin3DS

Formats.m3DSConst

Maximum key spline continuity

KfBlurBranch3DS

Formats.m3DSConst

KFContinuityMax3DS

Formats.m3DSConst

Minimum key spline continuity

KFContinuityMin3DS

Formats.m3DSConst

Maximum key spline tension

KFCURTIME

Formats.m3DSConst

KFDATA

Formats.m3DSConst

Keyframe Chunk IDs

KFEaseFromMax3DS

Formats.m3DSConst

Minimum key spline ease from

KFEaseFromMin3DS

Formats.m3DSConst

Maximum key spline ease to

KFEaseToMax3DS

Formats.m3DSConst

Minimum key spline ease to

KFEaseToMin3DS

Formats.m3DSConst

Maximum key spline bias

KfFastNode3DS

Formats.m3DSConst

KFHDR

Formats.m3DSConst

KFHdrStrMax3DS

Formats.m3DSConst

Maximum lens size for camera KFHDR

KfHideNode3DS

Formats.m3DSConst

KfMorphMtl3DS

Formats.m3DSConst

KfMorphOb3DS

Formats.m3DSConst

KfMotionBlur3DS

Formats.m3DSConst

KfNodeAutoSmooth3DS

Formats.m3DSConst

KfNodeFrozen3DS

Formats.m3DSConst

KfNodeHasPath3DS

Formats.m3DSConst

For the flags2 field

KfNodeOff3DS

Formats.m3DSConst

flag settings for TKFMesh3DS, TKFOmni3DS, TKFCamera3DS, TKFAmbient and TKFSpot3DS ml: these flags correspond directly to NODE_RENDOB_HIDE etc. (see below), I don't know what these duplications are for... for the flags field

KFSEG

Formats.m3DSConst

KFTensionMax3DS

Formats.m3DSConst

Minimum key spline tension

KFTensionMin3DS

Formats.m3DSConst

Maximum morph smoothing angle Keyframe Spline Limits

kLeafBrushes

Formats.Q3BSP

Stores the leaf's indices into the faces

kLeafFaces

Formats.Q3BSP

Stores the leafs of the nodes

kLeafs

Formats.Q3BSP

Stores the BSP nodes

kLightmaps

Formats.Q3BSP

Stores the faces for the level

kLightVolumes

Formats.Q3BSP

Stores the lightmaps for the level

kMaxLumps

Formats.Q3BSP

Stores PVS and cluster info (visibility)

kMeshVerts

Formats.Q3BSP

Stores the level vertices

kModels

Formats.Q3BSP

Stores the leaf's indices into the brushes

KMOD_ALT

SDL.Import

KMOD_CAPS

SDL.Import

KMOD_CTRL

SDL.Import

KMOD_GUI

SDL.Import

KMOD_LALT

SDL.Import

KMOD_LCTRL

SDL.Import

KMOD_LGUI

SDL.Import

KMOD_LSHIFT

SDL.Import

KMOD_MODE

SDL.Import

KMOD_NONE

SDL.Import

** * Enumeration of valid key mods (possibly OR'd together). *

KMOD_NUM

SDL.Import

KMOD_RALT

SDL.Import

KMOD_RCTRL

SDL.Import

KMOD_RESERVED

SDL.Import

KMOD_RGUI

SDL.Import

KMOD_RSHIFT

SDL.Import

KMOD_SHIFT

SDL.Import

kNodes

Formats.Q3BSP

Stores the splitting planes

KNoID

Formats.m3DSConst

Maximum fall off angle

kPlanes

Formats.Q3BSP

Stores texture information

kShaders

Formats.Q3BSP

Stores the model vertices offsets

kTextures

Formats.Q3BSP

Stores player/object positions, etc...

kVertices

Formats.Q3BSP

Stores the brush surfaces info

kVisData

Formats.Q3BSP

Stores extra world lighting information

Language

GLScene.Strings

String constants that are used for internationalization
To build your project with a single language's translations in the executable itself, define one of the next languages
Language $DEFINE 2-character locale id ——————- ———- ——————— English LANG_EN en French LANG_FR fr German LANG_DE de Italian LANG_IT it Japanese LANG_JP jp Russian LANG_RU ru Spanish LANG_ES es

LanguageString

gnugettext

LayerFogBgnd

Formats.m3DSConst

Fog Flags

LAYER_FOG

Formats.m3DSConst

lcl_major

GLS.SceneForm

lcl_minor

GLS.SceneForm

lcl_release

GLS.SceneForm

lcl_release

GLS.Screen

Lerp

GLScene.VectorGeometry

Calculates linear interpolation between start and stop at point t

libEGL

GLScene.OpenGL4

libGLES2

GLScene.OpenGL4

LibHandle

OpenAL.Import

LibMat

GLS.FileDDS

LibOpenCL

OpenCL.Import

LIGHT_NODE_TAG

Formats.m3DSConst

Linear_Interpolate

GLS.Perlin

Useless for final output! Usefull for after interpolation, as its FAST!

LineLen

GLS.FileOBJ

Allocate memory for the current line in chunks of LineLen Bytes.

LineLineDistance

GLScene.VectorGeometry

Computes the closest distance between two lines

LIN_COLOR_24

Formats.m3DSConst

LIN_COLOR_F

Formats.m3DSConst

listtypeAVIHEADER

Formats.VFW

mmioFOURCC('A', 'V', 'I', ' ')

listtypeAVIMOVIE

Formats.VFW

mmioFOURCC('s', 't', 'r', 'n')

listtypeAVIRECORD

Formats.VFW

mmioFOURCC('m', 'o', 'v', 'i')

listtypeSTREAMHEADER

Formats.VFW

mmioFOURCC('a', 'v', 'i', 'h')

lkPrefix

GLScene.Logger

llMax

GLScene.Logger

llMedium

GLScene.Logger

llMessageLimit

GLScene.Logger

llMin

GLScene.Logger

LMAGIC

Formats.m3DSConst

LnGamma

GLScene.RandomLib

Logarithm to base e of the gamma function. Accurate to about 1.e-14. Programmer: Alan Miller Latest revision of Fortran 77 version - 28 February 1988

LoadAnsiStringFromFile

GLScene.Utils

Returns the ansistring content of "filename".

LoadComponentFromFile

GLScene.Utils

Loads component from a file.

LoadJPGtexture

GLS.RandomHDS

Texture functions

LoadLW0FromStream

Formats.LWO

LoadLWOFromFile

Formats.LWO

LoadModule

ModuleLoader

LoadModuleEx

ModuleLoader

LoadOpenGL

GLS.OpenGLAdapter

LoadOpenGL

GLScene.OpenGL4

LoadOpenGLFromLibrary

GLS.OpenGLAdapter

LoadOpenGLFromLibrary

GLScene.OpenGL4

LoadQ3Anims

GLS.FileQ3MD3

LoadQ3Anims

GLS.FileQ3MD3

These procedures are helpers to load the Quake3 animation file data into an animation list. The NamePrefix parameter is used to determine which class of animation is extracted. eg NamePrefix='TORSO' will load all animations starting with 'TORSO_' like 'TORSO_STAND'

LoadQ3Skin

GLS.FileQ3MD3

Quake3 Skin loading procedure. Use this procedure to apply textures to a GLActor. This doens't use the actors original preloaded materials so it may be a good idea to clear the actors material library before running this to keep everything nice and clean.

LoadResString

gnugettext

Unicode-enabled way to get resourcestrings, automatically translated Use like this: ws:=LoadResStringW(@NameOfResourceString);

LoadResStringW

gnugettext

LoadRGBEpixels

GLScene.RGBE

LoadRLEpixels

GLScene.RGBE

LoadSDLBMPFromStream

SDL.Import

LoadStringFromFile

GLScene.Utils

Returns the string content of "filename".

Logarithm2

GLScene.VectorGeometry

—————————————————————————- Exponential functions —————————————————————————–

LONG

Formats.VFW

LonLatToPos

GLS.SkyDome

Computes position on the unit sphere of a star using Longitude and Latitude

LoShadowBiasMin3DS

Formats.m3DSConst

noninclusive minimum value for master scale LO_SHADOW_BIAS chunk

LOWPASS_DEFAULT_GAIN

OpenAL.Import

LOWPASS_DEFAULT_GAINHF

OpenAL.Import

LOWPASS_MAX_GAIN

OpenAL.Import

LOWPASS_MAX_GAINHF

OpenAL.Import

LOWPASS_MIN_GAIN

OpenAL.Import

Filter ranges and defaults. Lowpass filter

LOWPASS_MIN_GAINHF

OpenAL.Import

LO_SHADOW_BIAS

Formats.m3DSConst

L_TARGET_NODE_TAG

Formats.m3DSConst

M3DMAGIC

Formats.m3DSConst

3DS file Chunk IDs

M3D_KFVERSION

Formats.m3DSConst

M3D_VERSION

Formats.m3DSConst

MakeAffineDblVector

GLScene.VectorGeometry

Miscellaneous functions

MAKEAVICKID

Formats.VFW

MakeDblVector

GLScene.VectorGeometry

MakeMeshHexahedron

GLS.MeshBuilder

—————- Make Meshes ——————-

MakeMeshSphere

GLS.MeshBuilder

MakeMeshTetrahedron

GLS.MeshBuilder

Not implemented

MakeParallelProjectionMatrix

GLScene.VectorGeometry

Creates a parallel projection matrix. Transformed points will projected on the plane along the specified direction

MakePoint

GLScene.VectorGeometry

MakePoint

GLScene.VectorGeometry

MakePoint

GLScene.VectorGeometry

MakeReflectionMatrix

GLScene.VectorGeometry

Builds a reflection matrix for the given plane. Reflection matrix allow implementing planar reflectors (mirrors)

MakeShadowMatrix

GLScene.VectorGeometry

Creates a shadow projection matrix. Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos

MakeSubComponent

GLScene.Utils

MakeTriangleAdjacencyList

GLS.MeshUtils

Create list of indices of triangles with adjacency from triangle list

MakeVector

GLScene.VectorGeometry

MakeVector

GLScene.VectorGeometry

MakeVector

GLScene.VectorGeometry

MakeVector

GLScene.VectorGeometry

MARK_NODE

Formats.m3DSConst

MasterScaleMin3DS

Formats.m3DSConst

MASTER_SCALE chunk

MASTER_SCALE

Formats.m3DSConst

MatACubicAMax3DS

Formats.m3DSConst

minimum reflection map aliasing

MatACubicAMin3DS

Formats.m3DSConst

minimum frame skip count

MatACubicFMin3DS

Formats.m3DSConst

maximum shading value MAT_ACUBIC_FMIN

MATMAGIC

Formats.m3DSConst

MatMapNameStrMax3DS

Formats.m3DSConst

Maximum floating point percentage MAT_MAPNAME

MatNameStrMax3DS

Formats.m3DSConst

maximum string length for filename MAT_NAME

MatrixDecompose

GLScene.VectorGeometry

Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it. Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan The coefficient of each transformation is returned in the corresponding element of the vector Tran. Returns true upon success, false if the matrix is singular.

MatrixDeterminant

GLScene.VectorGeometry

Determinant of a 3x3 matrix

MatrixDeterminant

GLScene.VectorGeometry

Determinant of a 4x4 matrix

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

3x3

MatrixEquals

GLScene.VectorGeometry

4x4

MatrixInvert

GLScene.VectorGeometry

MatrixInvert

GLScene.VectorGeometry

MatrixLerp

GLScene.VectorGeometry

This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.

MatrixMultiply

GLScene.VectorGeometry

Multiplies M1 by M2 and places result in MResult

MatrixMultiply

GLScene.VectorGeometry

Multiplies two 3x3 matrices

MatrixMultiply

GLScene.VectorGeometry

Multiplies two 4x4 matrices

MatShadingMax3DS

Formats.m3DSConst

minimum shading value

MatShadingMin3DS

Formats.m3DSConst

maximum string length for material name MAT_SHADING

MAT_ACUBIC

Formats.m3DSConst

MAT_ADDITIVE

Formats.m3DSConst

MAT_AMBIENT

Formats.m3DSConst

MAT_BUMPMAP

Formats.m3DSConst

MAT_BUMPMASK

Formats.m3DSConst

MAT_BUMP_PERCENT

Formats.m3DSConst

MAT_DECAL

Formats.m3DSConst

MAT_DIFFUSE

Formats.m3DSConst

MAT_ENTRY

Formats.m3DSConst

Material Chunk IDs

MAT_FACEMAP

Formats.m3DSConst

MAT_MAPNAME

Formats.m3DSConst

MAT_MAP_ANG

Formats.m3DSConst

MAT_MAP_BCOL

Formats.m3DSConst

MAT_MAP_COL1

Formats.m3DSConst

MAT_MAP_COL2

Formats.m3DSConst

MAT_MAP_GCOL

Formats.m3DSConst

MAT_MAP_RCOL

Formats.m3DSConst

MAT_MAP_TEXBLUR

Formats.m3DSConst

MAT_MAP_TEXBLUR_OLD

Formats.m3DSConst

MAT_MAP_TILING

Formats.m3DSConst

MAT_MAP_TILINGOLD

Formats.m3DSConst

MAT_MAP_UOFFSET

Formats.m3DSConst

MAT_MAP_USCALE

Formats.m3DSConst

MAT_MAP_VOFFSET

Formats.m3DSConst

MAT_MAP_VSCALE

Formats.m3DSConst

MAT_NAME

Formats.m3DSConst

MAT_OPACMAP

Formats.m3DSConst

MAT_OPACMASK

Formats.m3DSConst

MAT_PHONGSOFT

Formats.m3DSConst

MAT_REFBLUR

Formats.m3DSConst

MAT_REFLMAP

Formats.m3DSConst

MAT_REFLMASK

Formats.m3DSConst

MAT_SELFIMAP

Formats.m3DSConst

MAT_SELFIMASK

Formats.m3DSConst

MAT_SELF_ILLUM

Formats.m3DSConst

MAT_SELF_ILPCT

Formats.m3DSConst

MAT_SHADING

Formats.m3DSConst

MAT_SHIN2PCT

Formats.m3DSConst

MAT_SHIN3PCT

Formats.m3DSConst

MAT_SHININESS

Formats.m3DSConst

MAT_SHINMAP

Formats.m3DSConst

MAT_SHINMASK

Formats.m3DSConst

MAT_SPECMAP

Formats.m3DSConst

MAT_SPECMASK

Formats.m3DSConst

MAT_SPECULAR

Formats.m3DSConst

MAT_SUPERSMP

Formats.m3DSConst

MAT_SXP_BUMP_DATA

Formats.m3DSConst

MAT_SXP_BUMP_MASKDATA

Formats.m3DSConst

MAT_SXP_OPAC_DATA

Formats.m3DSConst

MAT_SXP_OPAC_MASKDATA

Formats.m3DSConst

MAT_SXP_REFL_MASKDATA

Formats.m3DSConst

MAT_SXP_SELFI_DATA

Formats.m3DSConst

MAT_SXP_SELFI_MASKDATA

Formats.m3DSConst

MAT_SXP_SHIN_DATA

Formats.m3DSConst

MAT_SXP_SHIN_MASKDATA

Formats.m3DSConst

MAT_SXP_SPEC_DATA

Formats.m3DSConst

MAT_SXP_SPEC_MASKDATA

Formats.m3DSConst

MAT_SXP_TEXT2_DATA

Formats.m3DSConst

MAT_SXP_TEXT2_MASKDATA

Formats.m3DSConst

MAT_SXP_TEXT_DATA

Formats.m3DSConst

MAT_SXP_TEXT_MASKDATA

Formats.m3DSConst

MAT_TEX2MAP

Formats.m3DSConst

MAT_TEX2MASK

Formats.m3DSConst

MAT_TEXMAP

Formats.m3DSConst

MAT_TEXMASK

Formats.m3DSConst

MAT_TRANSPARENCY

Formats.m3DSConst

MAT_TWO_SIDE

Formats.m3DSConst

MAT_USE_REFBLUR

Formats.m3DSConst

MAT_USE_XPFALL

Formats.m3DSConst

MAT_WIRE

Formats.m3DSConst

MAT_WIREABS

Formats.m3DSConst

MAT_WIRESIZE

Formats.m3DSConst

MAT_XPFALL

Formats.m3DSConst

MAT_XPFALLIN

Formats.m3DSConst

MaxAbsXYZComponent

GLScene.VectorGeometry

Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)

MaxColorAttachments

GLS.FBORenderer

MaxComp

GLScene.VectorGeometry

MaxDouble

GLScene.VectorGeometry

MaxExtended

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

Returns the maximum of given values.

MaxFloat

GLScene.VectorGeometry

Returns the maximum value of the array.

MaxInteger

GLScene.VectorGeometry

MaxInteger

GLScene.VectorGeometry

MaxInteger

GLScene.VectorGeometry

MaxInteger

GLScene.VectorGeometry

MaxSingle

GLScene.VectorGeometry

MaxTriangles

GLScene.Triangulation

MaxUserClasses

ODE.Import

ExportInitODEMarker

MaxVector

GLScene.VectorGeometry

MaxVector

GLScene.VectorGeometry

Replace components of v with the max of v or v1 component. Maximum is computed per component

MaxVertices

GLScene.Triangulation

Set these as applicable

MaxVideoModes

GLS.Screen

MaxXYZComponent

GLScene.VectorGeometry

MaxXYZComponent

GLScene.VectorGeometry

Returns the max of the X, Y and Z components of a vector (W is ignored)

MAX_HARDWARE_LIGHT

GLS.State

MAX_HARDWARE_TEXTURE_UNIT

GLS.State

MAX_HARDWARE_UNIFORM_BUFFER_BINDING

GLS.State

MAX_MATRIX_STACK_DEPTH

GLScene.PipelineTransform

MAX_MD2_FRAMES

Formats.MD2

MAX_MD2_SKINNAME

Formats.MD2

MAX_MD2_SKINS

Formats.MD2

MAX_MD2_TRIANGLES

Formats.MD2

MAX_MD2_VERTICES

Formats.MD2

MAX_MS3D_GROUPS

GLS.FileMS3D

MAX_MS3D_JOINTS

GLS.FileMS3D

MAX_MS3D_KEYFRAMES

GLS.FileMS3D

MAX_MS3D_MATERIALS

GLS.FileMS3D

MAX_MS3D_TRIANGLES

GLS.FileMS3D

MAX_MS3D_VERTICES

GLS.FileMS3D

MAX_OBJECT_STACK_DEPTH

GLS.Selection

MAX_SHADER_LIGHT

GLS.State

MAX_TEXTURES

Formats.Q3BSP

MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_NV_vertex_program3

MCIWndCanConfig

Formats.VFW

MCIWndCanEject

Formats.VFW

MCIWndCanPlay

Formats.VFW

– Can macros —————————————————————

MCIWndCanRecord

Formats.VFW

MCIWndCanSave

Formats.VFW

MCIWndCanWindow

Formats.VFW

MCIWndChangeStyles

Formats.VFW

MCIWndClose

Formats.VFW

MCIWndCreate

Formats.VFW

MCIWndCreateA

Formats.VFW

MCIWndCreateW

Formats.VFW

MCIWndDestroy

Formats.VFW

MCIWndEject

Formats.VFW

MCIWndEnd

Formats.VFW

MCIWNDF_NOAUTOSIZEMOVIE

Formats.VFW

no toolbar

MCIWNDF_NOAUTOSIZEWINDOW

Formats.VFW

– Window styles ————————————————————

MCIWNDF_NOERRORDLG

Formats.VFW

Give a record button

MCIWNDF_NOMENU

Formats.VFW

when window size changes

MCIWNDF_NOOPEN

Formats.VFW

Show Error Dlgs for MCI cmds?

MCIWNDF_NOPLAYBAR

Formats.VFW

when movie size changes

MCIWNDF_NOTIFYALL

Formats.VFW

tell parent of an error

MCIWNDF_NOTIFYANSI

Formats.VFW

tell all

MCIWNDF_NOTIFYERROR

Formats.VFW

tell parent of size change

MCIWNDF_NOTIFYMEDIA

Formats.VFW

tell parent of media change

MCIWNDF_NOTIFYMEDIAA

Formats.VFW

The MEDIA notification includes a text string. To receive notifications in ANSI instead of unicode set the MCIWNDF_NOTIFYANSI style bit. The macro below includes this bit by default unless you define UNICODE in your application.

MCIWNDF_NOTIFYMEDIAW

Formats.VFW

tell parent of media change

MCIWNDF_NOTIFYMODE

Formats.VFW

show all

MCIWNDF_NOTIFYPOS

Formats.VFW

tell parent of mode change

MCIWNDF_NOTIFYSIZE

Formats.VFW

tell parent of pos change

MCIWNDF_RECORD

Formats.VFW

MCIWNDF_SHOWALL

Formats.VFW

show mode in caption

MCIWNDF_SHOWMODE

Formats.VFW

show position in caption

MCIWNDF_SHOWNAME

Formats.VFW

no popup menu from RBUTTONDOWN

MCIWNDF_SHOWPOS

Formats.VFW

show name in caption

MCIWndGetActiveTimer

Formats.VFW

MCIWndGetAlias

Formats.VFW

MCIWndGetDest

Formats.VFW

MCIWndGetDevice

Formats.VFW

MCIWndGetDeviceID

Formats.VFW

MCIWndGetEnd

Formats.VFW

MCIWndGetError

Formats.VFW

MCIWndGetFileName

Formats.VFW

MCIWndGetInactiveTimer

Formats.VFW

MCIWndGetLength

Formats.VFW

MCIWndGetMode

Formats.VFW

MCIWndGetPalette

Formats.VFW

#define MCIWndActivate(hwnd, f) (void)MCIWndSM(hwnd, WM_ACTIVATE, (WPARAM)(BOOL)(f), 0)

MCIWndGetPosition

Formats.VFW

MCIWndGetPositionString

Formats.VFW

MCIWndGetRepeat

Formats.VFW

MCIWndGetSource

Formats.VFW

MCIWndGetSpeed

Formats.VFW

MCIWndGetStart

Formats.VFW

MCIWndGetStyles

Formats.VFW

MCIWndGetTimeFormat

Formats.VFW

MCIWndGetVolume

Formats.VFW

MCIWndGetZoom

Formats.VFW

MCIWndHome

Formats.VFW

MCIWNDM_CAN_CONFIG

Formats.VFW

MCIWNDM_CAN_EJECT

Formats.VFW

MCIWNDM_CAN_PLAY

Formats.VFW

MCIWNDM_CAN_RECORD

Formats.VFW

MCIWNDM_CAN_SAVE

Formats.VFW

MCIWNDM_CAN_WINDOW

Formats.VFW

MCIWNDM_CHANGESTYLES

Formats.VFW

MCIWNDM_EJECT

Formats.VFW

MCIWNDM_GETACTIVETIMER

Formats.VFW

MCIWNDM_GETALIAS

Formats.VFW

MCIWNDM_GETDEVICE

Formats.VFW

MCIWNDM_GETDEVICEA

Formats.VFW

MCIWNDM_GETDEVICEID

Formats.VFW

all the text-related messages are defined out of order above (they need to be defined before the MCIWndOpen() macros

MCIWNDM_GETDEVICEW

Formats.VFW

MCIWNDM_GETEND

Formats.VFW

MCIWNDM_GETERROR

Formats.VFW

MCIWNDM_GETERRORA

Formats.VFW

MCIWNDM_GETERRORW

Formats.VFW

MCIWNDM_GETFILENAME

Formats.VFW

MCIWNDM_GETFILENAMEA

Formats.VFW

MCIWNDM_GETFILENAMEW

Formats.VFW

MCIWNDM_GETINACTIVETIMER

Formats.VFW

MCIWNDM_GETLENGTH

Formats.VFW

MCIWNDM_GETMODE

Formats.VFW

MCIWNDM_GETMODEA

Formats.VFW

MCIWNDM_GETMODEW

Formats.VFW

MCIWNDM_GETPALETTE

Formats.VFW

MCIWNDM_GETPOSITION

Formats.VFW

MCIWNDM_GETPOSITIONA

Formats.VFW

MCIWNDM_GETPOSITIONW

Formats.VFW

MCIWNDM_GETREPEAT

Formats.VFW

MCIWNDM_GETSPEED

Formats.VFW

MCIWNDM_GETSTART

Formats.VFW

MCIWNDM_GETSTYLES

Formats.VFW

MCIWNDM_GETTIMEFORMAT

Formats.VFW

MCIWNDM_GETTIMEFORMATA

Formats.VFW

MCIWNDM_GETTIMEFORMATW

Formats.VFW

MCIWNDM_GETVOLUME

Formats.VFW

MCIWNDM_GETZOOM

Formats.VFW

MCIWNDM_GET_DEST

Formats.VFW

MCIWNDM_GET_SOURCE

Formats.VFW

MCIWNDM_NEW

Formats.VFW

MCIWNDM_NEWA

Formats.VFW

MCIWNDM_NEWW

Formats.VFW

MCIWNDM_NOTIFYERROR

Formats.VFW

wp = hwnd, lp = fn

MCIWNDM_NOTIFYMEDIA

Formats.VFW

wp = hwnd

MCIWNDM_NOTIFYMODE

Formats.VFW

– Messages MCIWND will send to an app ————————————–

MCIWNDM_NOTIFYPOS

Formats.VFW

wp = hwnd, lp = mode

MCIWNDM_NOTIFYSIZE

Formats.VFW

wp = hwnd, lp = pos

MCIWNDM_OPEN

Formats.VFW

MCIWNDM_OPENA

Formats.VFW

MCIWNDM_OPENINTERFACE

Formats.VFW

MCIWNDM_OPENW

Formats.VFW

MCIWNDM_PALETTEKICK

Formats.VFW

MCIWNDM_PLAYFROM

Formats.VFW

MCIWNDM_PLAYREVERSE

Formats.VFW

MCIWNDM_PLAYTO

Formats.VFW

MCIWNDM_PUT_DEST

Formats.VFW

MCIWNDM_PUT_SOURCE

Formats.VFW

MCIWNDM_REALIZE

Formats.VFW

MCIWNDM_RETURNSTRING

Formats.VFW

MCIWNDM_RETURNSTRINGA

Formats.VFW

MCIWNDM_RETURNSTRINGW

Formats.VFW

MCIWNDM_SENDSTRING

Formats.VFW

– Map defaults to A ——————————————————–

MCIWNDM_SENDSTRINGA

Formats.VFW

– Define both A and W messages ———————————————

MCIWNDM_SENDSTRINGW

Formats.VFW

MCIWNDM_SETACTIVETIMER

Formats.VFW

MCIWNDM_SETINACTIVETIMER

Formats.VFW

MCIWNDM_SETOWNER

Formats.VFW

MCIWNDM_SETPALETTE

Formats.VFW

MCIWNDM_SETREPEAT

Formats.VFW

MCIWNDM_SETSPEED

Formats.VFW

MCIWNDM_SETTIMEFORMAT

Formats.VFW

MCIWNDM_SETTIMEFORMATA

Formats.VFW

MCIWNDM_SETTIMEFORMATW

Formats.VFW

MCIWNDM_SETTIMERS

Formats.VFW

MCIWNDM_SETVOLUME

Formats.VFW

MCIWNDM_SETZOOM

Formats.VFW

MCIWNDM_VALIDATEMEDIA

Formats.VFW

MCIWndNew

Formats.VFW

If you dont give a device it will use the current device....

MCIWndOpen

Formats.VFW

MCIWndOpenDialog

Formats.VFW

MCIWNDOPENF_NEW

Formats.VFW

– Flags for the MCIWndOpen command —————————————–

MCIWndOpenInterface

Formats.VFW

MCIWndPaletteKick

Formats.VFW

MCIWndPause

Formats.VFW

MCIWndPlay

Formats.VFW

MCIWndPlayFrom

Formats.VFW

MCIWndPlayFromTo

Formats.VFW

MCIWndPlayReverse

Formats.VFW

MCIWndPlayTo

Formats.VFW

MCIWndPutDest

Formats.VFW

MCIWndPutSource

Formats.VFW

MCIWndRealize

Formats.VFW

MCIWndRecord

Formats.VFW

MCIWndRegisterClass

Formats.VFW

MCIWndCreateA

MCIWndResume

Formats.VFW

MCIWndReturnString

Formats.VFW

MCIWndSave

Formats.VFW

MCIWndSaveDialog

Formats.VFW

MCIWndSeek

Formats.VFW

MCIWndSendString

Formats.VFW

MCIWndSetActiveTimer

Formats.VFW

MCIWndSetInactiveTimer

Formats.VFW

MCIWndSetOwner

Formats.VFW

MCIWndSetPalette

Formats.VFW

MCIWndSetRepeat

Formats.VFW

MCIWndSetSpeed

Formats.VFW

MCIWndSetTimeFormat

Formats.VFW

MCIWndSetTimers

Formats.VFW

MCIWndSetVolume

Formats.VFW

MCIWndSetZoom

Formats.VFW

MCIWndSM

Formats.VFW

MCIWnd
MCIWnd window class header file.
the MCIWnd window class is a window class for controling MCI devices MCI devices include, wave files, midi files, AVI Video, cd audio, vcr, video disc, and others..
to learn more about MCI and mci command sets see the "Microsoft Multimedia Programmers's guide" in the Win31 SDK
the easiest use of the MCIWnd class is like so:
hwnd = MCIWndCreate(hwndParent, hInstance, 0, "chimes.wav"); ... MCIWndPlay(hwnd); MCIWndStop(hwnd); MCIWndPause(hwnd); .... MCIWndDestroy(hwnd);
this will create a window with a play/pause, stop and a playbar and start the wave file playing.
mciwnd.h defines macros for all the most common MCI commands, but any string command can be used if needed.
Note: unlike the mciSendString() API, no alias or file name needs to be specifed, since the device to use is implied by the window handle.
MCIWndSendString(hwnd, "setaudio stream to 2");
(C) Copyright Microsoft Corp. 1991-1995. All rights reserved.
WIN32:
MCIWnd supports both ansi and unicode interfaces. For any message that takes or returns a text string, two versions of the message are defined, appended with A or W for Ansi or Wide Char. The message or api itself is defined to be one or other of these depending on whether you have UNICODE defined in your application. Thus for the api MCIWndCreate, there are in fact two apis, MCIWndCreateA and MCIWndCreateW. If you call MCIWndCreate, this will be re-routed to MCIWndCreateA unless UNICODE is defined when building your application. In any one application, you can mix calls to the Ansi and Unicode entrypoints.
If you use SendMessage instead of the macros below such as MCIWndOpen(), you will see that the messages have changed for WIN32, to support Ansi and Unicode entrypoints. In particular, MCI_OPEN has been replaced by MCWNDM_OPENA, or MCIWNDM_OPENW (MCIWNDM_OPEN is defined to be one or other of these).
Also, note that the WIN32 implementation of MCIWnd uses UNICODE so all apis and messages supporting ANSI strings do so by mapping them UNICODE strings and then calling the corresponding UNICODE entrypoint.

MCIWndStep

Formats.VFW

MCIWndStop

Formats.VFW

MCIWndUseFrames

Formats.VFW

MCIWndUseTime

Formats.VFW

MCIWndValidateMedia

Formats.VFW

MCIWND_END

Formats.VFW

MCIWND_START

Formats.VFW

– Special seek values for START and END ————————————

MCIWND_WINDOW_CLASS

Formats.VFW

MC_UnCompressQuat

Formats.GL2

MDATA

Formats.m3DSConst

Mesh Chunk Ids

MDCFILE_IDENTITY

GLS.FileMDC

MDCFILE_VERSION

GLS.FileMDC

MDC_BASEVERTEX_FACTOR

GLS.FileMDC

MDC_COMPVERTEX_FACTOR

GLS.FileMDC

1/64;

MESH_COLOR

Formats.m3DSConst

MESH_MATRIX

Formats.m3DSConst

MESH_TEXTURE_INFO

Formats.m3DSConst

MESH_VERSION

Formats.m3DSConst

MidTexPoint

GLScene.VectorGeometry

MinAbsXYZComponent

GLScene.VectorGeometry

Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)

MinComp

GLScene.VectorGeometry

1.1E+4932 <-Overflowing in c++;

MinDouble

GLScene.VectorGeometry

MinExtended

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

Returns the minimum of given values.

MinFloat

GLScene.VectorGeometry

Returns the minimum value of the array.

MinInteger

GLScene.VectorGeometry

MinInteger

GLScene.VectorGeometry

MinInteger

GLScene.VectorGeometry

MinInteger

GLScene.VectorGeometry

MinPositiveCoef

GLScene.Polynomials

Finds the minimum positive coef in the array in aMin. Returns true if such an item was found.

MinSingle

GLScene.VectorGeometry

Ranges of the IEEE floating point types, including denormals with Math.pas compatible name

MinusXVector

GLScene.VectorGeometry

MinusYVector

GLScene.VectorGeometry

MinusZVector

GLScene.VectorGeometry

MinVector

GLScene.VectorGeometry

MinVector

GLScene.VectorGeometry

Replace components of v with the min of v or v1 component. Minimum is computed per component

MinXYZComponent

GLScene.VectorGeometry

MinXYZComponent

GLScene.VectorGeometry

Returns the min of the X, Y and Z components of a vector (W is ignored)

MKFOURCC

Formats.VFW

***************************************************************************/ /* */ /* Macros */ /* */ /* should we define this?? */ /* */ /***************************************************************************

MLIBMAGIC

Formats.m3DSConst

mmioFOURCC

Formats.VFW

'1632'

MorphSmoothMax3DS

Formats.m3DSConst

Minimum morph smoothing angle

MorphSmoothMin3DS

Formats.m3DSConst

Maximum morph object name string size MORPH_SMOOTH

MorphTrackStrMax3DS

Formats.m3DSConst

Maximum instance name string size MORPH_TRACK

MORPH_SMOOTH

Formats.m3DSConst

MORPH_TRACK_TAG

Formats.m3DSConst

MORPH_TRACK_TAG_KEY

Formats.m3DSConst

MoveObjectAround

GLScene.VectorGeometry

Extracted from Camera.MoveAroundTarget(pitch, turn)

MRT_BUFFERS

GLS.Context

Buffer ID's for Multiple-Render-Targets (using GL_ATI_draw_buffers)

MsgIdString

gnugettext

MshMatGroupMin3DS

Formats.m3DSConst

minimum number of faces MshMatGroup3DS

MshMatGroupStrMax3DS

Formats.m3DSConst

minimum number of faces per material

MSH_BOXMAP

Formats.m3DSConst

MSH_MAT_GROUP

Formats.m3DSConst

MSH_MAT_GROUP_ENTRY

Formats.m3DSConst

M_BEVEL

Formats.m3DSConst

M_FIT

Formats.m3DSConst

M_SCALE

Formats.m3DSConst

M_TEETER

Formats.m3DSConst

M_TWIST

Formats.m3DSConst

NamedObjectStrMax3DS

Formats.m3DSConst

Maximum map name string size NAMED_OBJECT

NAMED_OBJECT

Formats.m3DSConst

NCameraFocMax3DS

Formats.m3DSConst

Minimum lens size for camera

NCameraFocMin3DS

Formats.m3DSConst

Maximum field of view for camera

NCameraFOVMax3DS

Formats.m3DSConst

Minimum field of view for camera

NCameraFOVMin3DS

Formats.m3DSConst

Maximum named object string size N_CAMERA

nearCallBack

GLS.ODEManager

ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer

NegateVector

GLScene.VectorGeometry

Negates the vector

NegateVector

GLScene.VectorGeometry

Negates the vector

NegateVector

GLScene.VectorGeometry

Negates the vector

NETWORK_VIEW

Formats.m3DSConst

NewtonAlloc

Newton.Import

NewtonAllocMemory

Newton.Import

Newton callback functions

NewtonApplyForceAndTorque

Newton.Import

NewtonAtomicAdd

Newton.Import

NewtonAtomicSwap

Newton.Import

NewtonBallCallback

Newton.Import

NewtonBallGetJointAngle

Newton.Import

NewtonBallGetJointForce

Newton.Import

NewtonBallGetJointOmega

Newton.Import

NewtonBallSetConeLimits

Newton.Import

NewtonBallSetUserCallback

Newton.Import

NewtonBodyAddForce

Newton.Import

NewtonBodyAddImpulse

Newton.Import

NewtonBodyAddTorque

Newton.Import

NewtonBodyApplyImpulseArray

Newton.Import

NewtonBodyApplyImpulsePair

Newton.Import

NewtonBodyCalculateInverseDynamicsForce

Newton.Import

NewtonBodyDestructor

Newton.Import

NewtonBodyFindContact

Newton.Import

NewtonBodyGetAABB

Newton.Import

NewtonBodyGetAcceleration

Newton.Import

NewtonBodyGetAlpha

Newton.Import

NewtonBodyGetAngularDamping

Newton.Import

NewtonBodyGetAutoSleep

Newton.Import

NewtonBodyGetCentreOfMass

Newton.Import

NewtonBodyGetCollidable

Newton.Import

NewtonBodyGetCollision

Newton.Import

NewtonBodyGetContinuousCollisionMode

Newton.Import

NewtonBodyGetDestructorCallback

Newton.Import

NewtonBodyGetFirstContactJoint

Newton.Import

NewtonBodyGetFirstJoint

Newton.Import

NewtonBodyGetForce

Newton.Import

NewtonBodyGetForceAndTorqueCallback

Newton.Import

NewtonBodyGetFreezeState

Newton.Import

NewtonBodyGetGyroscopicTorque

Newton.Import

NewtonBodyGetID

Newton.Import

NewtonBodyGetInertiaMatrix

Newton.Import

NewtonBodyGetInvInertiaMatrix

Newton.Import

NewtonBodyGetInvMass

Newton.Import

NewtonBodyGetJointRecursiveCollision

Newton.Import

NewtonBodyGetLinearDamping

Newton.Import

NewtonBodyGetMass

Newton.Import

NewtonBodyGetMaterialGroupID

Newton.Import

NewtonBodyGetMatrix

Newton.Import

NewtonBodyGetNextContactJoint

Newton.Import

NewtonBodyGetNextJoint

Newton.Import

NewtonBodyGetOmega

Newton.Import

NewtonBodyGetPointVelocity

Newton.Import

NewtonBodyGetPosition

Newton.Import

NewtonBodyGetRotation

Newton.Import

NewtonBodyGetSerializedID

Newton.Import

NewtonBodyGetSimulationState

Newton.Import

NewtonBodyGetSleepState

Newton.Import

NewtonBodyGetTorque

Newton.Import

NewtonBodyGetTransformCallback

Newton.Import

NewtonBodyGetType

Newton.Import

NewtonBodyGetUserData

Newton.Import

NewtonBodyGetVelocity

Newton.Import

NewtonBodyGetWorld

Newton.Import

NewtonBodyIntegrateVelocity

Newton.Import

NewtonBodyIterator

Newton.Import

NewtonBodySetAngularDamping

Newton.Import

NewtonBodySetAutoSleep

Newton.Import

NewtonBodySetCentreOfMass

Newton.Import

NewtonBodySetCollidable

Newton.Import

NewtonBodySetCollision

Newton.Import

NewtonBodySetCollisionScale

Newton.Import

NewtonBodySetContinuousCollisionMode

Newton.Import

NewtonBodySetDestructorCallback

Newton.Import

NewtonBodySetForce

Newton.Import

NewtonBodySetForceAndTorqueCallback

Newton.Import

NewtonBodySetFreezeState

Newton.Import

NewtonBodySetFullMassMatrix

Newton.Import

NewtonBodySetGyroscopicTorque

Newton.Import

NewtonBodySetJointRecursiveCollision

Newton.Import

NewtonBodySetLinearDamping

Newton.Import

NewtonBodySetMassMatrix

Newton.Import

NewtonBodySetMassProperties

Newton.Import

NewtonBodySetMaterialGroupID

Newton.Import

NewtonBodySetMatrix

Newton.Import

NewtonBodySetMatrixNoSleep

Newton.Import

NewtonBodySetMatrixRecursive

Newton.Import

NewtonBodySetOmega

Newton.Import

NewtonBodySetOmegaNoSleep

Newton.Import

NewtonBodySetSimulationState

Newton.Import

NewtonBodySetSleepState

Newton.Import

NewtonBodySetTorque

Newton.Import

NewtonBodySetTransformCallback

Newton.Import

NewtonBodySetUserData

Newton.Import

NewtonBodySetVelocity

Newton.Import

NewtonBodySetVelocityNoSleep

Newton.Import

NewtonCalculateSpringDamperAcceleration

Newton.Import

NewtonCollisionAggregateAddBody

Newton.Import

NewtonCollisionAggregateCreate

Newton.Import

**********************************************************************************************
collision aggregates, are a collision node on eh broad phase the serve as the root nod for a collection of rigid bodies that shared the property of being in close proximity all the time, they are similar to compound collision by the group bodies instead of collision instances These are good for speeding calculation calculation of rag doll, Vehicles or contractions of rigid bodied lined by joints. also for example if you know that many the life time of a group of bodies like the object on a house of a building will be localize to the confide of the building then warping the bodies under an aggregate will reduce collision calculation of almost an order of magnitude.
**********************************************************************************************

NewtonCollisionAggregateDestroy

Newton.Import

NewtonCollisionAggregateGetSelfCollision

Newton.Import

NewtonCollisionAggregateRemoveBody

Newton.Import

NewtonCollisionAggregateSetSelfCollision

Newton.Import

NewtonCollisionCalculateAABB

Newton.Import

NewtonCollisionClosestPoint

Newton.Import

NewtonCollisionCollide

Newton.Import

NewtonCollisionCollideContinue

Newton.Import

NewtonCollisionCopyConstructionCallback

Newton.Import

NewtonCollisionCreateInstance

Newton.Import

**********************************************************************************************
General purpose collision library functions
**********************************************************************************************

NewtonCollisionDataPointer

Newton.Import

NewtonCollisionDestructorCallback

Newton.Import

NewtonCollisionForEachPolygonDo

Newton.Import

NewtonCollisionGetInfo

Newton.Import

NewtonCollisionGetMaterial

Newton.Import

NewtonCollisionGetMatrix

Newton.Import

NewtonCollisionGetMode

Newton.Import

NewtonCollisionGetParentInstance

Newton.Import

NewtonCollisionGetScale

Newton.Import

NewtonCollisionGetSkinThickness

Newton.Import

NewtonCollisionGetSubCollisionHandle

Newton.Import

NewtonCollisionGetType

Newton.Import

NewtonCollisionGetUserData

Newton.Import

NewtonCollisionGetUserID

Newton.Import

NewtonCollisionIntersectionTest

Newton.Import

NewtonCollisionIsConvexShape

Newton.Import

NewtonCollisionIsStaticShape

Newton.Import

NewtonCollisionIterator

Newton.Import

NewtonCollisionPointDistance

Newton.Import

NewtonCollisionRayCast

Newton.Import

NewtonCollisionSerialize

Newton.Import

NewtonCollisionSetMaterial

Newton.Import

NewtonCollisionSetMatrix

Newton.Import

NewtonCollisionSetMode

Newton.Import

NewtonCollisionSetScale

Newton.Import

NewtonCollisionSetSkinThickness

Newton.Import

NewtonCollisionSetUserData

Newton.Import

NewtonCollisionSetUserID

Newton.Import

NewtonCollisionSupportVertex

Newton.Import

NewtonCollisionTreeRayCastCallback

Newton.Import

NewtonCompoundCollisionAddSubCollision

Newton.Import

NewtonCompoundCollisionBeginAddRemove

Newton.Import

NewtonCompoundCollisionEndAddRemove

Newton.Import

NewtonCompoundCollisionGetCollisionFromNode

Newton.Import

NewtonCompoundCollisionGetFirstNode

Newton.Import

NewtonCompoundCollisionGetNextNode

Newton.Import

NewtonCompoundCollisionGetNodeByIndex

Newton.Import

NewtonCompoundCollisionGetNodeIndex

Newton.Import

NewtonCompoundCollisionRemoveSubCollision

Newton.Import

NewtonCompoundCollisionRemoveSubCollisionByIndex

Newton.Import

NewtonCompoundCollisionSetSubCollisionMatrix

Newton.Import

NewtonConstraintCreateBall

Newton.Import

**********************************************************************************************
Ball and Socket joint functions
**********************************************************************************************

NewtonConstraintCreateCorkscrew

Newton.Import

**********************************************************************************************
Corkscrew joint functions
**********************************************************************************************

NewtonConstraintCreateHinge

Newton.Import

**********************************************************************************************
Hinge joint functions
**********************************************************************************************

NewtonConstraintCreateSlider

Newton.Import

**********************************************************************************************
Slider joint functions
**********************************************************************************************

NewtonConstraintCreateUniversal

Newton.Import

**********************************************************************************************
Universal joint functions
**********************************************************************************************

NewtonConstraintCreateUpVector

Newton.Import

**********************************************************************************************
Up vector joint functions
**********************************************************************************************

NewtonConstraintCreateUserJoint

Newton.Import

**********************************************************************************************
User defined bilateral Joint
**********************************************************************************************

NewtonConstraintDestructor

Newton.Import

NewtonContactGetCollision0

Newton.Import

NewtonContactGetCollision1

Newton.Import

NewtonContactGetCollisionID0

Newton.Import

NewtonContactGetCollisionID1

Newton.Import

NewtonContactGetMaterial

Newton.Import

NewtonContactJointGetClosestDistance

Newton.Import

NewtonContactJointGetContactCount

Newton.Import

NewtonContactJointGetFirstContact

Newton.Import

**********************************************************************************************
contact joints interface
**********************************************************************************************

NewtonContactJointGetNextContact

Newton.Import

NewtonContactJointRemoveContact

Newton.Import

NewtonContactJointResetIntraJointCollision

Newton.Import

NewtonContactJointResetSelftJointCollision

Newton.Import

NewtonContactsProcess

Newton.Import

NewtonConvexCollisionCalculateBuoyancyVolume

Newton.Import

NewtonConvexCollisionCalculateInertialMatrix

Newton.Import

NewtonConvexCollisionCalculateVolume

Newton.Import

NewtonConvexHullGetFaceIndices

Newton.Import

NewtonConvexHullGetVertexData

Newton.Import

NewtonCorkscrewCalculateStopAccel

Newton.Import

NewtonCorkscrewCalculateStopAlpha

Newton.Import

NewtonCorkscrewCallback

Newton.Import

NewtonCorkscrewGetJointAngle

Newton.Import

NewtonCorkscrewGetJointForce

Newton.Import

NewtonCorkscrewGetJointOmega

Newton.Import

NewtonCorkscrewGetJointPosit

Newton.Import

NewtonCorkscrewGetJointVeloc

Newton.Import

NewtonCorkscrewSetUserCallback

Newton.Import

NewtonCreate

Newton.Import

NewtonCreateAsymetricDynamicBody

Newton.Import

NewtonCreateBox

Newton.Import

NewtonCreateCapsule

Newton.Import

NewtonCreateChamferCylinder

Newton.Import

NewtonCreateCollisionFromSerialization

Newton.Import

***********************************************************************************************************
Collision serialization functions
***********************************************************************************************************

NewtonCreateCompoundCollision

Newton.Import

**********************************************************************************************
compound collision primitives creation functions
**********************************************************************************************

NewtonCreateCompoundCollisionFromMesh

Newton.Import

NewtonCreateCone

Newton.Import

NewtonCreateContactCallback

Newton.Import

NewtonCreateConvexHull

Newton.Import

NewtonCreateConvexHullFromMesh

Newton.Import

NewtonCreateCylinder

Newton.Import

NewtonCreateDeformableSolid

Newton.Import

NewtonCreateDynamicBody

Newton.Import

body manipulation functions

NewtonCreateFracturedCompoundCollision

Newton.Import

**********************************************************************************************
Fractured compound collision primitives interface
**********************************************************************************************

NewtonCreateHeightFieldCollision

Newton.Import

**********************************************************************************************
Static collision shapes functions
**********************************************************************************************

NewtonCreateKinematicBody

Newton.Import

NewtonCreateMassSpringDamperSystem

Newton.Import

**********************************************************************************************
particle system interface (soft bodies, individual, pressure bodies and cloth)
**********************************************************************************************

NewtonCreateNull

Newton.Import

**********************************************************************************************
convex collision primitives creation functions
**********************************************************************************************

NewtonCreateSceneCollision

Newton.Import

**********************************************************************************************
scene collision are static compound collision that can take polygonal static collisions
**********************************************************************************************

NewtonCreateSphere

Newton.Import

NewtonCreateTetrahedraLinearBlendSkinWeightsChannel

Newton.Import

NewtonCreateTreeCollision

Newton.Import

NewtonCreateTreeCollisionFromMesh

Newton.Import

NewtonCreateUserMeshCollision

Newton.Import

***********************************************************************************************************
User Static mesh collision interface
***********************************************************************************************************

NewtonCurrentPlugin

Newton.Import

NewtonDeformableMeshGetParticleArray

Newton.Import

NewtonDeformableMeshGetParticleCount

Newton.Import

NewtonDeformableMeshGetParticleStrideInBytes

Newton.Import

NewtonDeserializeCallback

Newton.Import

NewtonDeserializeFromFile

Newton.Import

NewtonDeserializeScene

Newton.Import

NewtonDestroy

Newton.Import

NewtonDestroyAllBodies

Newton.Import

NewtonDestroyBody

Newton.Import

NewtonDestroyCollision

Newton.Import

NewtonDestroyContactCallback

Newton.Import

NewtonDestroyJoint

Newton.Import

NewtonDispachThreadJob

Newton.Import

NewtonFindSerializedBody

Newton.Import

NewtonFractureCompoundCollisionOnEmitChunk

Newton.Import

NewtonFractureCompoundCollisionOnEmitCompoundFractured

Newton.Import

NewtonFractureCompoundCollisionReconstructMainMeshCallBack

Newton.Import

NewtonFracturedCompoundCollisionGetVertexCount

Newton.Import

NewtonFracturedCompoundCollisionGetVertexNormals

Newton.Import

NewtonFracturedCompoundCollisionGetVertexPositions

Newton.Import

NewtonFracturedCompoundCollisionGetVertexUVs

Newton.Import

NewtonFracturedCompoundGetFirstSubMesh

Newton.Import

NewtonFracturedCompoundGetMainMesh

Newton.Import

NewtonFracturedCompoundGetNextSubMesh

Newton.Import

NewtonFracturedCompoundIsNodeFreeToDetach

Newton.Import

NewtonFracturedCompoundMeshPartGetFirstSegment

Newton.Import

NewtonFracturedCompoundMeshPartGetIndexCount

Newton.Import

NewtonFracturedCompoundMeshPartGetIndexStream

Newton.Import

NewtonFracturedCompoundMeshPartGetMaterial

Newton.Import

NewtonFracturedCompoundMeshPartGetNextSegment

Newton.Import

NewtonFracturedCompoundNeighborNodeList

Newton.Import

NewtonFracturedCompoundPlaneClip

Newton.Import

NewtonFracturedCompoundSetCallbacks

Newton.Import

NewtonFree

Newton.Import

NewtonFreeMemory

Newton.Import

NewtonGetBroadphaseAlgorithm

Newton.Import

NewtonGetContactMergeTolerance

Newton.Import

NewtonGetEulerAngle

Newton.Import

NewtonGetFirstPlugin

Newton.Import

NewtonGetJointSerializationCallbacks

Newton.Import

NewtonGetLastUpdateTime

Newton.Import

NewtonGetMaxThreadsCount

Newton.Import

NewtonGetMemoryUsed

Newton.Import

NewtonGetNextPlugin

Newton.Import

NewtonGetNumberOfSubsteps

Newton.Import

NewtonGetParallelSolverOnLargeIsland

Newton.Import

NewtonGetPluginString

Newton.Import

NewtonGetPostUpdateCallback

Newton.Import

NewtonGetPreferedPlugin

Newton.Import

NewtonGetSolverIterations

Newton.Import

NewtonGetThreadsCount

Newton.Import

NewtonGetTimeInMicrosencondsCallback

Newton.Import

NewtonHeightFieldRayCastCallback

Newton.Import

NewtonHeightFieldSetHorizontalDisplacement

Newton.Import

NewtonHeightFieldSetUserRayCastCallback

Newton.Import

NewtonHingeCalculateStopAlpha

Newton.Import

NewtonHingeCallback

Newton.Import

NewtonHingeGetJointAngle

Newton.Import

NewtonHingeGetJointForce

Newton.Import

NewtonHingeGetJointOmega

Newton.Import

NewtonHingeSetUserCallback

Newton.Import

NewtonInvalidateCache

Newton.Import

NewtonIslandGetBody

Newton.Import

**********************************************************************************************
Simulation islands
**********************************************************************************************

NewtonIslandGetBodyAABB

Newton.Import

NewtonIslandUpdate

Newton.Import

NewtonJobTask

Newton.Import

NewtonJointGetBody0

Newton.Import

NewtonJointGetBody1

Newton.Import

NewtonJointGetCollisionState

Newton.Import

NewtonJointGetInfo

Newton.Import

NewtonJointGetStiffness

Newton.Import

NewtonJointGetUserData

Newton.Import

**********************************************************************************************
Common joint functions
**********************************************************************************************

NewtonJointIsActive

Newton.Import

NewtonJointIterator

Newton.Import

NewtonJointSetCollisionState

Newton.Import

NewtonJointSetDestructor

Newton.Import

NewtonJointSetStiffness

Newton.Import

NewtonJointSetUserData

Newton.Import

NewtonLoadPlugins

Newton.Import

NewtonMaterialContactRotateTangentDirections

Newton.Import

NewtonMaterialCreateGroupID

Newton.Import

**********************************************************************************************
Physics Material Section
**********************************************************************************************

NewtonMaterialDestroyAllGroupID

Newton.Import

NewtonMaterialGetBodyCollidingShape

Newton.Import

NewtonMaterialGetContactFaceAttribute

Newton.Import

NewtonMaterialGetContactForce

Newton.Import

NewtonMaterialGetContactMaxNormalImpact

Newton.Import

NewtonMaterialGetContactMaxTangentImpact

Newton.Import

NewtonMaterialGetContactNormalSpeed

Newton.Import

NewtonMaterialGetContactPenetration

Newton.Import

NewtonMaterialGetContactPositionAndNormal

Newton.Import

NewtonMaterialGetContactPruningTolerance

Newton.Import

NewtonMaterialGetContactTangentDirections

Newton.Import

NewtonMaterialGetContactTangentSpeed

Newton.Import

NewtonMaterialGetDefaultGroupID

Newton.Import

NewtonMaterialGetMaterialPairUserData

Newton.Import

**********************************************************************************************
Physics Contact control functions
**********************************************************************************************

NewtonMaterialGetUserData

Newton.Import

material definitions that can not be overwritten in function callback

NewtonMaterialJointResetIntraJointCollision

Newton.Import

NewtonMaterialJointResetSelftJointCollision

Newton.Import

NewtonMaterialSetAsSoftContact

Newton.Import

NewtonMaterialSetCallbackUserData

Newton.Import

deprecated, not longer continue collision is set on the material NEWTON_API void NewtonMaterialSetContinuousCollisionMode (const NewtonWorld* const newtonWorld, int id0, int id1, int state);

NewtonMaterialSetCollisionCallback

Newton.Import

NewtonMaterialSetCompoundCollisionCallback

Newton.Import

NewtonMaterialSetContactElasticity

Newton.Import

NewtonMaterialSetContactFrictionCoef

Newton.Import

NewtonMaterialSetContactFrictionState

Newton.Import

NewtonMaterialSetContactGenerationCallback

Newton.Import

NewtonMaterialSetContactNormalAcceleration

Newton.Import

NewtonMaterialSetContactNormalDirection

Newton.Import

NewtonMaterialSetContactPosition

Newton.Import

NewtonMaterialSetContactPruningTolerance

Newton.Import

NewtonMaterialSetContactSoftness

Newton.Import

NewtonMaterialSetContactTangentAcceleration

Newton.Import

NewtonMaterialSetContactTangentFriction

Newton.Import

NewtonMaterialSetContactThickness

Newton.Import

NewtonMaterialSetDefaultCollidable

Newton.Import

NewtonMaterialSetDefaultElasticity

Newton.Import

NewtonMaterialSetDefaultFriction

Newton.Import

NewtonMaterialSetDefaultSoftness

Newton.Import

NewtonMaterialSetSurfaceThickness

Newton.Import

NewtonMeshAddBinormal

Newton.Import

NewtonMeshAddLayer

Newton.Import

NewtonMeshAddMaterial

Newton.Import

NewtonMeshAddNormal

Newton.Import

NewtonMeshAddPoint

Newton.Import

NewtonMeshAddUV0

Newton.Import

NewtonMeshAddUV1

Newton.Import

NewtonMeshAddVertexColor

Newton.Import

NewtonMeshApplyAngleBasedMapping

Newton.Import

NewtonMeshApplyBoxMapping

Newton.Import

NewtonMeshApplyCylindricalMapping

Newton.Import

NewtonMeshApplySphericalMapping

Newton.Import

NewtonMeshApplyTransform

Newton.Import

NewtonMeshApproximateConvexDecomposition

Newton.Import

NewtonMeshBeginBuild

Newton.Import

NewtonMeshBeginFace

Newton.Import

NewtonMeshBeginHandle

Newton.Import

NewtonMeshBuildFromVertexListIndexList

Newton.Import

NewtonMeshCalculateFaceNormal

Newton.Import

NewtonMeshCalculateOOBB

Newton.Import

NewtonMeshCalculateVertexNormals

Newton.Import

NewtonMeshClearVertexFormat

Newton.Import

NewtonMeshClip

Newton.Import

NewtonMeshConvexMeshIntersection

Newton.Import

NewtonMeshCreate

Newton.Import

**********************************************************************************************
Mesh joint functions
**********************************************************************************************

NewtonMeshCreateConvexHull

Newton.Import

NewtonMeshCreateFirstLayer

Newton.Import

NewtonMeshCreateFirstSingleSegment

Newton.Import

NewtonMeshCreateFromCollision

Newton.Import

NewtonMeshCreateFromMesh

Newton.Import

NewtonMeshCreateFromSerialization

Newton.Import

NewtonMeshCreateNextLayer

Newton.Import

NewtonMeshCreateNextSingleSegment

Newton.Import

NewtonMeshCreateTetrahedraIsoSurface

Newton.Import

NewtonMeshCreateVoronoiConvexDecomposition

Newton.Import

NewtonMeshDestroy

Newton.Import

NewtonMeshDifference

Newton.Import

NewtonMeshEndBuild

Newton.Import

NewtonMeshEndFace

Newton.Import

NewtonMeshEndHandle

Newton.Import

NewtonMeshFirstMaterial

Newton.Import

NewtonMeshFixTJoints

Newton.Import

NewtonMeshFlipWinding

Newton.Import

NewtonMeshGetBinormalChannel

Newton.Import

NewtonMeshGetEdgeIndices

Newton.Import

NewtonMeshGetFaceIndexCount

Newton.Import

NewtonMeshGetFaceIndices

Newton.Import

NewtonMeshGetFaceMaterial

Newton.Import

NewtonMeshGetFacePointIndices

Newton.Import

NewtonMeshGetFaces

Newton.Import

NewtonMeshGetFirstEdge

Newton.Import

NewtonMeshGetFirstFace

Newton.Import

NEWTON_API void NewtonMeshGetEdgePointIndices (const NewtonMesh* const mesh, const void* const edge, int* const v0, int* const v1);

NewtonMeshGetFirstPoint

Newton.Import

NewtonMeshGetFirstVertex

Newton.Import

NewtonMeshGetIndexToVertexMap

Newton.Import

NewtonMeshGetNextEdge

Newton.Import

NewtonMeshGetNextFace

Newton.Import

NewtonMeshGetNextPoint

Newton.Import

NewtonMeshGetNextVertex

Newton.Import

NewtonMeshGetNormalChannel

Newton.Import

NewtonMeshGetPointCount

Newton.Import

NewtonMeshGetPointIndex

Newton.Import

NewtonMeshGetTotalFaceCount

Newton.Import

NewtonMeshGetTotalIndexCount

Newton.Import

NewtonMeshGetUV0Channel

Newton.Import

NewtonMeshGetUV1Channel

Newton.Import

NewtonMeshGetVertexArray

Newton.Import

NewtonMeshGetVertexBaseCount

Newton.Import

NewtonMeshGetVertexChannel

Newton.Import

NewtonMeshGetVertexColorChannel

Newton.Import

NewtonMeshGetVertexCount

Newton.Import

NewtonMeshGetVertexDoubleChannel

Newton.Import

NewtonMeshGetVertexIndex

Newton.Import

NewtonMeshGetVertexIndexFromPoint

Newton.Import

NewtonMeshGetVertexStrideInByte

Newton.Import

NewtonMeshGetVertexWeights

Newton.Import

NewtonMeshHasBinormalChannel

Newton.Import

NewtonMeshHasNormalChannel

Newton.Import

NewtonMeshHasUV0Channel

Newton.Import

NewtonMeshHasUV1Channel

Newton.Import

NewtonMeshHasVertexColorChannel

Newton.Import

NewtonMeshIntersection

Newton.Import

NewtonMeshIsFaceOpen

Newton.Import

NewtonMeshIsOpenMesh

Newton.Import

NewtonMeshLoadOFF

Newton.Import

NewtonMeshLoadTetrahedraMesh

Newton.Import

NewtonMeshMaterialGetIndexCount

Newton.Import

NewtonMeshMaterialGetIndexStream

Newton.Import

NewtonMeshMaterialGetIndexStreamShort

Newton.Import

NewtonMeshMaterialGetMaterial

Newton.Import

NewtonMeshNextMaterial

Newton.Import

NewtonMeshOptimize

Newton.Import

NewtonMeshOptimizePoints

Newton.Import

NewtonMeshOptimizeVertex

Newton.Import

NewtonMeshPolygonize

Newton.Import

NewtonMeshSaveOFF

Newton.Import

NewtonMeshSerialize

Newton.Import

NewtonMeshSetFaceMaterial

Newton.Import

NewtonMeshSetVertexBaseCount

Newton.Import

NewtonMeshSimplify

Newton.Import

NewtonMeshTriangulate

Newton.Import

NewtonMeshUnion

Newton.Import

NewtonOnAABBOverlap

Newton.Import

NewtonOnBodyDeserializationCallback

Newton.Import

NewtonOnBodySerializationCallback

Newton.Import

NewtonOnCompoundSubCollisionAABBOverlap

Newton.Import

NewtonOnContactGeneration

Newton.Import

NewtonOnJointDeserializationCallback

Newton.Import

NewtonOnJointSerializationCallback

Newton.Import

NewtonOnUserCollisionSerializationCallback

Newton.Import

user collision callbacks

NewtonPostUpdateCallback

Newton.Import

NewtonRemoveUnusedVertices

Newton.Import

NewtonReportProgress

Newton.Import

NewtonResetBroadphase

Newton.Import

NewtonSceneCollisionAddSubCollision

Newton.Import

NewtonSceneCollisionBeginAddRemove

Newton.Import

NewtonSceneCollisionEndAddRemove

Newton.Import

NewtonSceneCollisionGetCollisionFromNode

Newton.Import

NewtonSceneCollisionGetFirstNode

Newton.Import

NewtonSceneCollisionGetNextNode

Newton.Import

NewtonSceneCollisionGetNodeByIndex

Newton.Import

NewtonSceneCollisionGetNodeIndex

Newton.Import

NewtonSceneCollisionRemoveSubCollision

Newton.Import

NewtonSceneCollisionRemoveSubCollisionByIndex

Newton.Import

NewtonSceneCollisionSetSubCollisionMatrix

Newton.Import

NewtonSelectBroadphaseAlgorithm

Newton.Import

NewtonSelectPlugin

Newton.Import

NewtonSerializeCallback

Newton.Import

NewtonSerializeScene

Newton.Import

NewtonSerializeToFile

Newton.Import

NewtonSetContactMergeTolerance

Newton.Import

NewtonSetEulerAngle

Newton.Import

transforms utility functions

NewtonSetIslandUpdateEvent

Newton.Import

NewtonSetJointSerializationCallbacks

Newton.Import

NewtonSetMemorySystem

Newton.Import

NewtonSetNumberOfSubsteps

Newton.Import

NewtonSetParallelSolverOnLargeIsland

Newton.Import

NewtonSetPostUpdateCallback

Newton.Import

NewtonSetSolverIterations

Newton.Import

NewtonSetThreadsCount

Newton.Import

NewtonSetTransform

Newton.Import

NewtonSliderCalculateStopAccel

Newton.Import

NewtonSliderCallback

Newton.Import

NewtonSliderGetJointForce

Newton.Import

NewtonSliderGetJointPosit

Newton.Import

NewtonSliderGetJointVeloc

Newton.Import

NewtonSliderSetUserCallback

Newton.Import

NewtonStaticCollisionSetDebugCallback

Newton.Import

NewtonSyncThreadJobs

Newton.Import

NewtonTreeCollisionAddFace

Newton.Import

NewtonTreeCollisionBeginBuild

Newton.Import

NewtonTreeCollisionCallback

Newton.Import

NewtonTreeCollisionEndBuild

Newton.Import

NewtonTreeCollisionFaceCallback

Newton.Import

NewtonTreeCollisionForEachFace

Newton.Import

NewtonTreeCollisionGetFaceAttribute

Newton.Import

NewtonTreeCollisionGetVertexListTriangleListInAABB

Newton.Import

NewtonTreeCollisionSetFaceAttribute

Newton.Import

NewtonTreeCollisionSetUserRayCastCallback

Newton.Import

NewtonUniversalCalculateStopAlpha0

Newton.Import

NewtonUniversalCalculateStopAlpha1

Newton.Import

NewtonUniversalCallback

Newton.Import

NewtonUniversalGetJointAngle0

Newton.Import

NewtonUniversalGetJointAngle1

Newton.Import

NewtonUniversalGetJointForce

Newton.Import

NewtonUniversalGetJointOmega0

Newton.Import

NewtonUniversalGetJointOmega1

Newton.Import

NewtonUniversalSetUserCallback

Newton.Import

NewtonUnloadPlugins

Newton.Import

NewtonUpdate

Newton.Import

NewtonUpdateAsync

Newton.Import

NewtonUpVectorGetPin

Newton.Import

NewtonUpVectorSetPin

Newton.Import

NewtonUserBilateralCallback

Newton.Import

NewtonUserBilateralGetInfoCallback

Newton.Import

NewtonUserJoinRowsCount

Newton.Import

NewtonUserJointAddAngularRow

Newton.Import

NewtonUserJointAddGeneralRow

Newton.Import

NewtonUserJointAddLinearRow

Newton.Import

NewtonUserJointCalculateRowZeroAcceleration

Newton.Import

NewtonUserJointGetGeneralRow

Newton.Import

NewtonUserJointGetRowAcceleration

Newton.Import

NewtonUserJointGetRowForce

Newton.Import

NewtonUserJointGetRowJacobian

Newton.Import

NewtonUserJointGetSolverModel

Newton.Import

NewtonUserJointMassScale

Newton.Import

NewtonUserJointSetFeedbackCollectorCallback

Newton.Import

NewtonUserJointSetRowAcceleration

Newton.Import

NewtonUserJointSetRowMaximumFriction

Newton.Import

NewtonUserJointSetRowMinimumFriction

Newton.Import

NewtonUserJointSetRowSpringDamperAcceleration

Newton.Import

NewtonUserJointSetRowStiffness

Newton.Import

NewtonUserJointSetSolverModel

Newton.Import

NewtonUserMeshCollisionAABBTest

Newton.Import

NewtonUserMeshCollisionCollideCallback

Newton.Import

NewtonUserMeshCollisionContinuousOverlapTest

Newton.Import

NewtonUserMeshCollisionDestroyCallback

Newton.Import

NewtonUserMeshCollisionGetCollisionInfo

Newton.Import

NewtonUserMeshCollisionGetFacesInAABB

Newton.Import

NewtonUserMeshCollisionRayHitCallback

Newton.Import

NewtonWaitForUpdateToFinish

Newton.Import

NewtonWorldAddListener

Newton.Import

NewtonWorldCollide

Newton.Import

NewtonWorldConvexCast

Newton.Import

NewtonWorldCriticalSectionLock

Newton.Import

NewtonWorldCriticalSectionUnlock

Newton.Import

NewtonWorldDestroyListenerCallback

Newton.Import

NewtonWorldDestructorCallback

Newton.Import

NewtonWorldFindJoint

Newton.Import

NewtonWorldFloatSize

Newton.Import

NewtonWorldForEachBodyInAABBDo

Newton.Import

NewtonWorldForEachJointDo

Newton.Import

NewtonWorldGetBodyCount

Newton.Import

world utility functions

NewtonWorldGetConstraintCount

Newton.Import

NewtonWorldGetDestructorCallback

Newton.Import

NewtonWorldGetFirstBody

Newton.Import

NewtonWorldGetFirstMaterial

Newton.Import

NewtonWorldGetListener

Newton.Import

NewtonWorldGetListenerUserData

Newton.Import

NewtonWorldGetNextBody

Newton.Import

NewtonWorldGetNextMaterial

Newton.Import

NewtonWorldGetUserData

Newton.Import

NewtonWorldGetVersion

Newton.Import

**********************************************************************************************
world control functions
**********************************************************************************************

NewtonWorldListenerBodyDestroyCallback

Newton.Import

NewtonWorldListenerDebug

Newton.Import

NewtonWorldListenerDebugCallback

Newton.Import

NewtonWorldListenerGetBodyDestroyCallback

Newton.Import

NewtonWorldListenerSetBodyDestroyCallback

Newton.Import

NewtonWorldListenerSetDebugCallback

Newton.Import

NewtonWorldListenerSetDestructorCallback

Newton.Import

NewtonWorldListenerSetPostStepCallback

Newton.Import

NewtonWorldListenerSetPostUpdateCallback

Newton.Import

NewtonWorldListenerSetPreUpdateCallback

Newton.Import

NewtonWorldRayCast

Newton.Import

NewtonWorldRayFilterCallback

Newton.Import

NewtonWorldRayPrefilterCallback

Newton.Import

NewtonWorldSetCollisionConstructorDestructorCallback

Newton.Import

NewtonWorldSetCreateDestroyContactCallback

Newton.Import

NewtonWorldSetDestructorCallback

Newton.Import

NewtonWorldSetUserData

Newton.Import

NewtonWorldUpdateListenerCallback

Newton.Import

NewtonYield

Newton.Import

NEWTON_API

Newton.Import

.$DEFINE USE_DOUBLE_PRECISION

NEWTON_BROADPHASE_DEFAULT

Newton.Import

NEWTON_BROADPHASE_PERSINTENT

Newton.Import

NEWTON_DYNAMIC_ASYMETRIC_BODY

Newton.Import

NEWTON_DYNAMIC_BODY

Newton.Import

NEWTON_KINEMATIC_BODY

Newton.Import

NEWTON_MAJOR_VERSION

Newton.Import

NEWTON_MINOR_VERSION

Newton.Import

ngettext

gnugettext

ngettext_NoExtract

gnugettext

NMF_HEADER_TAG

GLS.FileNMF

NMF_TRIANGLE_TAG

GLS.FileNMF

NodeHdrStrMax3DS

Formats.m3DSConst

Maximum keyframe header name string size NODE_HDR

NodeTagCount

Formats.m3DSConst

NodeTags

Formats.m3DSConst

number of entries in node tag list

NODE_ANI_HIDDEN

Formats.m3DSConst

NODE_AUTO_SMOOTH

Formats.m3DSConst

NODE_BLUR_BRANCH

Formats.m3DSConst

NODE_CALC_PATH

Formats.m3DSConst

corresponds to mesh

NODE_FROZEN

Formats.m3DSConst

NODE_HAS_PATH

Formats.m3DSConst

Values for keyframer flags2

NODE_HDR

Formats.m3DSConst

NODE_ID

Formats.m3DSConst

NODE_MORPH_MTL

Formats.m3DSConst

NODE_MORPH_OB

Formats.m3DSConst

NODE_MOTION_BLUR

Formats.m3DSConst

NODE_OFF

Formats.m3DSConst

NODE_RENDOB_HIDE

Formats.m3DSConst

do RGB color transform Values for keyframer flags1

NoFalloff

Formats.m3DSConst

NoisyColor

GLS.RandomHDS

NormalizeAngle

GLScene.VectorGeometry

Normalize to an angle in the [-PI; +PI] range

NormalizeDegAngle

GLScene.VectorGeometry

Normalize to an angle in the [-180; 180] range

NormalizeMatrix

GLScene.VectorGeometry

Normalize the matrix and remove the translation component. The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)

NormalizePlane

GLScene.VectorGeometry

Normalize a plane so that point evaluation = plane distance. }

NormalizeQuaternion

GLScene.VectorGeometry

Normalizes the given quaternion

NormalizeVector

GLScene.VectorGeometry

Returns the vector transformed to unit length Transforms a vector to unit length

NormalizeVector

GLScene.VectorGeometry

Transforms a vector to unit length

NormalizeVector

GLScene.VectorGeometry

Transforms a vector to unit length

NormalizeVectorArray

GLScene.VectorGeometry

Transforms vectors to unit length

NotChunk

Formats.m3DSConst

NullBoundingBox

GLScene.GeometryBB

NullHmgPoint

GLScene.VectorGeometry

NullHmgVector

GLScene.VectorGeometry

NullTexPoint

GLScene.VectorGeometry

NullVector

GLScene.VectorGeometry

NULL_CHUNK

Formats.m3DSConst

—————– List of all chunk IDs ————————————-

N_AMBIENT_LIGHT

Formats.m3DSConst

N_CAMERA

Formats.m3DSConst

N_CAM_OLD

Formats.m3DSConst

N_DIRECT_LIGHT

Formats.m3DSConst

N_D_L_OLD

Formats.m3DSConst

N_TRI_OBJECT

Formats.m3DSConst

ObjectManager

GLS.SceneRegister

Auto-create for object manager

OBJECT_NODE_TAG

Formats.m3DSConst

OBJ_DOESNT_CAST

Formats.m3DSConst

OBJ_DONT_RCVSHADOW

Formats.m3DSConst

OBJ_FAST

Formats.m3DSConst

OBJ_FROZEN

Formats.m3DSConst

OBJ_HIDDEN

Formats.m3DSConst

OBJ_MATTE

Formats.m3DSConst

OBJ_PROCEDURAL

Formats.m3DSConst

OBJ_VIS_LOFTER

Formats.m3DSConst

ODEDLL

ODE.Import

********************************************************************
ODE precision:
ODE can be run in Single or Double precision, Single is less precise, but requires less memory.
If you choose to run in Single mode, you must deploy the single precision dll (this is default)
If you choose to run in Double mode, you must deploy the double precision dll (named ode_double.dll and located in the dll directory) Insert . before "$" to make ODEImport double based

ODERToGLSceneMatrix

GLS.ODEUtils

ODERToGLSceneMatrix

GLS.ODEUtils

ODERToGLSceneMatrix

GLS.ODEUtils

OffsetAABB

GLScene.GeometryBB

OffsetAABB

GLScene.GeometryBB

Adds delta to min and max of the AABB.

OffsetBB

GLScene.GeometryBB

OffsetBB

GLScene.GeometryBB

Adds delta to min and max of the BB.

OffsetBBPoint

GLScene.GeometryBB

The same as above but uses AddPoint() instead of AddVector().

OffsetFloatArray

GLScene.VectorGeometry

OffsetFloatArray

GLScene.VectorGeometry

OffsetFloatArray

GLScene.VectorGeometry

Adds delta to values in the array. Array size must be a multiple of four

OLD_MAT_GROUP

Formats.m3DSConst

opengl32

GLS.OpenGLAdapter

opengl32

GLScene.OpenGL4

OpenGLFormatToInternalFormat

GLScene.TextureFormat

Give a GLScene texture format from openGL texture format

OpenPictureDialog

GLS.ImageUtils

Pops up a simple open picture dialog.

OptimizeMesh

GLS.MeshBuilder

OptimizeMesh

GLS.MeshBuilder

Optimize Mesh (list, default options)

OptimizeMesh

GLS.MeshBuilder

OptimizeMesh (object, default options)

OptimizeMesh

GLS.MeshBuilder

OptimizeMesh (object, with options)

O_CONSTS

Formats.m3DSConst

PAABB

GLScene.GeometryBB

PAArray

GLS.zBuffer

PackRotationMatrix

GLScene.VectorGeometry

Packs an homogeneous rotation matrix to 6 bytes. The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each. Deviation is typically below 0.01% and around 0.1% in worst case situations. Note: quaternion conversion is faster and more robust than an angle decomposition

PACubic3DS

Formats.m3DSTypes

used by AddMaterial3DS

PAffineByteVector

GLScene.VectorGeometry

PAffineDblVector

GLScene.VectorGeometry

PAffineExtVector

GLScene.VectorGeometry

PAffineFltVector

GLScene.VectorGeometry

PAffineIntVector

GLScene.VectorGeometry

PAffineMatrix

GLScene.VectorGeometry

PAffinePtrVector

GLScene.VectorGeometry

PAffineVector

GLScene.VectorGeometry

PAffineVectorArray

GLScene.VectorGeometry

Arrays of vectors

PAffineWordVector

GLScene.VectorGeometry

PAKCreateFileStream

GLS.FileVfsPAK

PAKFileStreamExists

GLS.FileVfsPAK

PALbitfield

OpenAL.Import

PALboolean

OpenAL.Import

PALbyte

OpenAL.Import

PALCboolean

OpenAL.Import

PALCbyte

OpenAL.Import

PALCchar

OpenAL.Import

PALCcontext

OpenAL.Import

PALCdevice

OpenAL.Import

PALCdouble

OpenAL.Import

PALCenum

OpenAL.Import

PALCfloat

OpenAL.Import

PALchar

OpenAL.Import

PALCint

OpenAL.Import

PALclampd

OpenAL.Import

PALclampf

OpenAL.Import

PALCshort

OpenAL.Import

PALCsizei

OpenAL.Import

PALCubyte

OpenAL.Import

PALCuint

OpenAL.Import

PALCushort

OpenAL.Import

PALCvoid

OpenAL.Import

PALdouble

OpenAL.Import

PALenum

OpenAL.Import

PALfloat

OpenAL.Import

PALint

OpenAL.Import

PALshort

OpenAL.Import

PALsizei

OpenAL.Import

PALuByte

OpenAL.Import

PALuint

OpenAL.Import

PALushort

OpenAL.Import

PALvoid

OpenAL.Import

PANG4

Formats.LWO

PANIMChunk

Formats.B3D

PARENT_NAME

Formats.m3DSConst

PARENT_OBJECT

Formats.m3DSConst

ParseFloat

GLScene.Utils

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.

ParseInteger

GLScene.Utils

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.

PATH_3D

Formats.m3DSConst

PATH_MATRIX

Formats.m3DSConst

PAtmosphere3DS

Formats.m3DSTypes

PAVICOMPRESSOPTIONS

Formats.VFW

Make sure it matches the AutoDoc in avisave.c !!!

PAVIFileInfo

Formats.VFW

PAVIFileInfoA

Formats.VFW

PAVIFileInfoW

Formats.VFW

– AVIFILEINFO ————————————————————–

PAVIINDEXENTRY

Formats.VFW

these bits are for compressor use

PAVIPALCHANGE

Formats.VFW

– Palette change chunk (used in video streams) —————————–

PAVIStream

GLS.AVIRecorder

PAVIStreamHeader

Formats.VFW

PAVIStreamInfo

Formats.VFW

PAVIStreamInfoA

Formats.VFW

PAVIStreamInfoW

Formats.VFW

for Unicode/Ansi thunking we need to declare three versions of this!

PB3DChunk

Formats.B3D

PBackground3DS

Formats.m3DSTypes

PBASS_PLUGINFORMS

BASS.Import

PBASS_PLUGININFO

BASS.Import

PBB3DChunk

Formats.B3D

PBitmap3DS

Formats.m3DSTypes

Cubic reflection Map defintion

PBitmapBgnd3DS

Formats.m3DSTypes

PBitMapName

Formats.m3DSTypes

PBONEChunk

Formats.B3D

PBoundBox

Formats.m3DSTypes

PBRUSChunk

Formats.B3D

PBSPFace

Formats.Q3BSP

PBSPLightmap

Formats.Q3BSP

PBSPTexture

Formats.Q3BSP

PBSPVertex

Formats.Q3BSP

PByteArray

GLScene.VectorGeometry

PByteRaster

GLS.HeightData

PByteVector

GLScene.VectorGeometry

Types to specify continous streams of a specific type switch off range checking to access values beyond the limits

PCamera3DS

Formats.m3DSTypes

PCamRanges

Formats.m3DSTypes

PCamRanges3DS

Formats.m3DSTypes

Camera atomosphere Ranges

PCAPDRIVERCAPS

Formats.VFW

– Structures —————————————————————

PCAPINFOCHUNK

Formats.VFW

No master

PCAPSTATUS

Formats.VFW

PCAPTUREPARMS

Formats.VFW

Default values in parenthesis

PCardinalArray

Formats.m3DSTypes

PCardinalArray

GLScene.VectorGeometry

PCardinalVector

GLScene.VectorGeometry

PCGcontext

Cg.Import

PCGerror

Cg.Import

* The following macro invocations define error codes returned by various cg * API functions. * * The macros have the form : * * CG_ERROR_MACRO(code, enum_name, message) * * code : The integer error code associated with the error. * enum_name : The name of enumerant of the error code in the API. * message : A description string associated with the error. *

PCGparameter

Cg.Import

PCGprogram

Cg.Import

PCHANNEL_CAPS

Formats.VFW

– Channel capabilities structure ——————————————-

PChar3DS

Formats.m3DSTypes

PCharCG

Cg.Import

***********************************************************************

PCharInfo

GLS.BitmapFont

PChunk3DS

Formats.m3DSTypes

PChunkList

Formats.m3DSTypes

PChunkList3DS

Formats.m3DSTypes

PChunkListEntry3DS

Formats.m3DSTypes

internal database representation of file information

Pcl_addressing_mode

OpenCL.Import

Pcl_bitfield

OpenCL.Import

Pcl_bool

OpenCL.Import

* WARNING! Unlike cl_ types in cl_platform.h, cl_bool is not guaranteed to be the same size as the bool in kernels. *//

Pcl_buffer_create_type

OpenCL.Import

Pcl_buffer_region

OpenCL.Import

Pcl_build_status

OpenCL.Import

Pcl_channel_order

OpenCL.Import

Pcl_channel_type

OpenCL.Import

Pcl_char

OpenCL.Platform

Pcl_command_queue

OpenCL.Import

Pcl_command_queue_info

OpenCL.Import

Pcl_command_queue_properties

OpenCL.Import

Pcl_command_type

OpenCL.Import

Pcl_context

OpenCL.Import

Pcl_context_info

OpenCL.Import

Pcl_context_properties

OpenCL.Import

Pcl_device_affinity_domain

OpenCL.Import

Pcl_device_exec_capabilities

OpenCL.Import

Pcl_device_fp_config

OpenCL.Import

Pcl_device_id

OpenCL.Import

Pcl_device_info

OpenCL.Import

Pcl_device_local_mem_type

OpenCL.Import

Pcl_device_mem_cache_type

OpenCL.Import

Pcl_device_partition_property

OpenCL.Import

Pcl_device_svm_capabilities

OpenCL.Import

Pcl_device_type

OpenCL.Import

Pcl_double

OpenCL.Platform

Pcl_event

OpenCL.Import

Pcl_event_info

OpenCL.Import

Pcl_filter_mode

OpenCL.Import

Pcl_float

OpenCL.Platform

Pcl_GLsync

OpenCL.GL

Pcl_gl_context_info

OpenCL.GL

Pcl_gl_object_type

OpenCL.GL

Pcl_gl_platform_info

OpenCL.GL

Pcl_gl_texture_info

OpenCL.GL

Pcl_half

OpenCL.Platform

Pcl_image_desc

OpenCL.Import

Pcl_image_format

OpenCL.Import

Pcl_image_info

OpenCL.Import

Pcl_int

OpenCL.Platform

Pcl_kernel

OpenCL.Import

Pcl_kernel_arg_access_qualifier

OpenCL.Import

Pcl_kernel_arg_address_qualifier

OpenCL.Import

Pcl_kernel_arg_info

OpenCL.Import

Pcl_kernel_arg_type_qualifier

OpenCL.Import

Pcl_kernel_exec_info

OpenCL.Import

Pcl_kernel_info

OpenCL.Import

Pcl_kernel_sub_group_info

OpenCL.Import

Pcl_kernel_work_group_info

OpenCL.Import

Pcl_long

OpenCL.Platform

Pcl_map_flags

OpenCL.Import

Pcl_mem

OpenCL.Import

Pcl_mem_flags

OpenCL.Import

Pcl_mem_info

OpenCL.Import

Pcl_mem_migration_flag

OpenCL.Import

Pcl_mem_object_type

OpenCL.Import

Pcl_pipe_info

OpenCL.Import

Pcl_pipe_properties

OpenCL.Import

Pcl_platform_id

OpenCL.Import

Pcl_platform_info

OpenCL.Import

Pcl_profiling_info

OpenCL.Import

Pcl_program

OpenCL.Import

Pcl_program_binary_type

OpenCL.Import

Pcl_program_build_info

OpenCL.Import

Pcl_program_info

OpenCL.Import

Pcl_queue_properties

OpenCL.Import

Pcl_sampler

OpenCL.Import

Pcl_sampler_info

OpenCL.Import

Pcl_sampler_properties

OpenCL.Import

Pcl_short

OpenCL.Platform

Pcl_svm_mem_flags

OpenCL.Import

Pcl_uchar

OpenCL.Platform

Pcl_uint

OpenCL.Platform

Pcl_ulong

OpenCL.Platform

Pcl_ushort

OpenCL.Platform

PColor24

Formats.m3DSTypes

PColorF

Formats.m3DSTypes

inner datatypes not followed by a '3DS' to show they are locally used (mostly as a part of another chunk or while collecting specific data)

PColr12

Formats.LWO

PColr4

Formats.LWO

PColTrackTag

Formats.m3DSTypes

PCOMPVARS

Formats.VFW

Structure used by ICSeqCompressFrame and ICCompressorChoose routines Make sure this matches the autodoc in icm.c!

PCUarray

CUDA.Import

CUDA array

PCUcontext

CUDA.Import

CUDA context

PcudaArray

CUDA.Runtime

PcudaChannelFormatDesc

CUDA.Runtime

+//DEVICE_BUILTIN*/

PCudaDeviceProp

CUDA.Runtime

+//DEVICE_BUILTIN*/

PCUDA_ARRAY_DESCRIPTOR

CUDA.Import

Array descriptor

PCUDA_MEMCPY2D

CUDA.Import

2D memory copy parameters

PCUevent

CUDA.Import

CUDA event

PcufftComplex

CUDA.FourierTransform

PcufftDoubleComplex

CUDA.FourierTransform

PcufftDoubleReal

CUDA.FourierTransform

PcufftReal

CUDA.FourierTransform

PCUfunction

CUDA.Import

CUDA function

PCUgraphicsResource

CUDA.Import

PCUmodule

CUDA.Import

CUDA module

PCUstream

CUDA.Import

CUDA stream

PCUtexref

CUDA.Import

CUDA texture reference

Pd3Axis

ODE.Import

PDatabase3DS

Formats.m3DSTypes

PdContact

ODE.Import

PdContactGeom

ODE.Import

PDCueSettings3DS

Formats.m3DSTypes

PdFloat

Newton.Import

PdFloat64

Newton.Import

PdGeomClass

ODE.Import

PdInteger3

ODE.Import

PdIntegerArray

ODE.Import

PDistanceCue

Formats.m3DSTypes

PDlExclude

Formats.m3DSTypes

PDlInnerRange

Formats.m3DSTypes

PDlLocalShadow2

Formats.m3DSTypes

PDlMultiplier

Formats.m3DSTypes

PdLong

Newton.Import

PDlOuterRange

Formats.m3DSTypes

PDlRayBias

Formats.m3DSTypes

PDlSpotAspect

Formats.m3DSTypes

PDlSpotlight

Formats.m3DSTypes

PDlSpotProjector

Formats.m3DSTypes

PDlSpotRoll

Formats.m3DSTypes

PdMass

ODE.Import

PdMatrix3

ODE.Import

PdMatrix3_As3x4

ODE.Import

PdMatrix4

ODE.Import

PdMatrix6

ODE.Import

PdObject

ODE.Import

PDoubleArray

GLScene.VectorGeometry

PDoubleVector

GLScene.VectorGeometry

PdQuaternion

ODE.Import

array[0..3] of TdReal;

PDRAWDIBTIME

Formats.VFW

– DrawDibTime() - for debugging purposes only ——————————

PdReal

ODE.Import

PdRealArray

ODE.Import

PdRealHugeArray

ODE.Import

PdVector3

ODE.Import

Q: Why isn't TdVector3 = array[0..2] of TdReal? A: Because of SIMD alignment.

PdVector3Array

ODE.Import

PdVector4

ODE.Import

PdxBody

ODE.Import

PdxGeom

ODE.Import

PdxHashSpace

ODE.Import

//currently the space 'container' is just a list of the geoms in the space. struct dxHashSpace : public dxSpace { dxGeom *first; int global_minlevel; // smallest hash table level to put AABBs in int global_maxlevel; // objects that need a level larger than this will be // put in a "big objects" list instead of a hash table void destroy(); void add (dGeomID); void remove (dGeomID); void collide (void *data, dNearCallback *callback); int query (dGeomID); };

PdxHeightfieldData

ODE.Import

PdxJoint

ODE.Import

PdxJointBall

ODE.Import

PdxJointGroup

ODE.Import

Pointers to internal ODE structures to reproduce C++ classes in Delphi

PdxJointHinge

ODE.Import

PdxJointHinge2

ODE.Import

PdxJointLimitMotor

ODE.Import

PdxJointLimitMotor3

ODE.Import

PdxJointNode

ODE.Import

PdxJointPiston

ODE.Import

PdxJointPR

ODE.Import

PdxJointSlider

ODE.Import

PdxJointUniversial

ODE.Import

PdxPosR

ODE.Import

position vector and rotation matrix for geometry objects that are not connected to bodies.

PdxSimpleSpace

ODE.Import

//simple space - reports all nˆ2 object intersections struct dxSimpleSpace : public dxSpace { dGeomID first; void destroy(); void add (dGeomID); void remove (dGeomID); void collide (void *data, dNearCallback *callback); int query (dGeomID); };

PdxSpace

ODE.Import

struct dxSpace : public dBase { int type; // don't want to use RTTI virtual void destroy()=0; virtual void add (dGeomID)=0; virtual void remove (dGeomID)=0; virtual void collide (void *data, dNearCallback *callback)=0; virtual int query (dGeomID)=0; };

PDXT3AlphaBlock

Formats.DXTC

PDXT5AlphaBlock

Formats.DXTC

PDXTColBlock

Formats.DXTC

PdxTriMeshData

ODE.Import

PdxWorld

ODE.Import

PD_CAN_DRAW_DIB

Formats.VFW

– Display profiling ——————————————————–

PD_CAN_STRETCHDIB

Formats.VFW

if you can draw at all

PD_STRETCHDIB_1_1_OK

Formats.VFW

basicly RC_STRETCHDIB

PD_STRETCHDIB_1_2_OK

Formats.VFW

is it fast?

PD_STRETCHDIB_1_N_OK

Formats.VFW

...

PEaxBufferProperties

OpenAL.Import

PEaxListenerProperties

OpenAL.Import

PEFXEAXREVERBPROPERTIES

OpenAL.Import

PEFXLOWPASSFILTER

OpenAL.Import

Perlin_Random1

GLS.Perlin

just a random controlled by X

Perlin_Random1DStrip

GLS.Perlin

generates a random strip

Perlin_Random2

GLS.Perlin

just a random controlled by X,Y

PExtendedArray

GLScene.VectorGeometry

PExtendedVector

GLScene.VectorGeometry

PF4

Formats.LWO

PF4Array

Formats.LWO

PFace3DS

Formats.m3DSTypes

PFaceArray

Formats.m3DSTypes

PFaceList

Formats.m3DSTypes

PFallTrackTag

Formats.m3DSTypes

PFastCollisionChecker

GLS.Collision

PFColor3DS

Formats.m3DSTypes

PFColorList

Formats.m3DSTypes

PFloat

GLScene.VectorGeometry

Data types needed for 3D graphics calculation, included are 'C like' aliases for each type (to be conformal with OpenGL types)

PFloat

Newton.Import

PFloat

SDL.Import

PFloatArray

GLScene.VectorGeometry

PFloatPercentage

Formats.m3DSTypes

PFloatVector

GLScene.VectorGeometry

PFMusicModule

FMOD.types

PFNGLACTIVESHADERPROGRAMPROC

GLScene.OpenGLTokens

PFNGLACTIVESTENCILFACEEXTPROC

GLScene.OpenGLTokens

GL_EXT_stencil_two_side (EXT #268)

PFNGLACTIVETEXTUREARBPROC

GLScene.OpenGLTokens

GL_ARB_multitexture (ARB #1)

PFNGLACTIVETEXTUREPROC

GLScene.OpenGLTokens

deprecated; core 1.3 promoted to core v1.3 from GL_ARB_multitexture (#1)

PFNGLACTIVEVARYINGNVPROC

GLScene.OpenGLTokens

PFNGLADDSWAPHINTRECTWINPROC

GLScene.OpenGLTokens

GL_WIN_swap_hint (extension # not found)

PFNGLAREPROGRAMSRESIDENTNVPROC

GLScene.OpenGLTokens

GL_NV_vertex_program (EXT #233)

PFNGLARETEXTURESRESIDENTEXTPROC

GLScene.OpenGLTokens

PFNGLARRAYELEMENTARRAYEXTPROC

GLScene.OpenGLTokens

EXT/Vendor extensions Unknown Vendor/EXT functions

PFNGLATTACHOBJECTARBPROC

GLScene.OpenGLTokens

PFNGLATTACHSHADERPROC

GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)

PFNGLBEGINCONDITIONALRENDERNVPROC

GLScene.OpenGLTokens

GL_NV_conditional_render (EXT #346)

PFNGLBEGINCONDITIONALRENDERPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_NV_conditional_render

PFNGLBEGINOCCLUSIONQUERYNVPROC

GLScene.OpenGLTokens

PFNGLBEGINQUERYARBPROC

GLScene.OpenGLTokens

PFNGLBEGINQUERYINDEXEDPROC

GLScene.OpenGLTokens

PFNGLBEGINQUERYPROC

GLScene.OpenGLTokens

PFNGLBEGINSCENEEXTPROC

GLScene.OpenGLTokens

GL_EXT_scene_marker (EXT #120)

PFNGLBEGINTRANSFORMFEEDBACKEXTPROC

GLScene.OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKNVPROC

GLScene.OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLBINDATTRIBLOCATIONARBPROC

GLScene.OpenGLTokens

GL_ARB_vertex_shader (ARB #31)

PFNGLBINDATTRIBLOCATIONPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFERARBPROC

GLScene.OpenGLTokens

GL_ARB_vertex_buffer_object (ARB #28)

PFNGLBINDBUFFERBASEEXTPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFERBASENVPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFERBASEPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFEROFFSETEXTPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFEROFFSETNVPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFERPROC

GLScene.OpenGLTokens

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)

PFNGLBINDBUFFERRANGEEXTPROC

GLScene.OpenGLTokens

GL_EXT_transform_feedback (EXT #352)

PFNGLBINDBUFFERRANGENVPROC

GLScene.OpenGLTokens

GL_NV_transform_feedback (EXT #341)

PFNGLBINDBUFFERRANGEPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_transform_feedback

PFNGLBindBuffersBase

GLScene.OpenGLTokens

PFNGLBindBuffersRange

GLScene.OpenGLTokens

PFNGLBINDFRAGDATALOCATIONEXTPROC

GLScene.OpenGLTokens

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC

GLScene.OpenGLTokens

GL_ARB_blend_func_extended (ARB #78)

PFNGLBINDFRAGDATALOCATIONPROC

GLScene.OpenGLTokens

PFNGLBINDFRAMEBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLBINDFRAMEBUFFERPROC

GLScene.OpenGLTokens

PFNGLBindImageTextures

GLScene.OpenGLTokens

PFNGLBINDMULTITEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLBINDPROGRAMARBPROC

GLScene.OpenGLTokens

PFNGLBINDPROGRAMNVPROC

GLScene.OpenGLTokens

PFNGLBINDPROGRAMPIPELINEPROC

GLScene.OpenGLTokens

PFNGLBINDRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLBINDRENDERBUFFERPROC

GLScene.OpenGLTokens

PFNGLBINDSAMPLERPROC

GLScene.OpenGLTokens

PFNGLBindSamplers

GLScene.OpenGLTokens

PFNGLBINDTEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLBindTextures

GLScene.OpenGLTokens

PFNGLBINDTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

GL_ARB_transform_feedback2 (ARB #93)

PFNGLBINDVERTEXARRAYPROC

GLScene.OpenGLTokens

GL_ARB_vertex_array_object (ARB #54)

PFNGLBindVertexBuffer

GLScene.OpenGLTokens

GL_ARB_vertex_attrib_binding (ARB #125)

PFNGLBindVertexBuffers

GLScene.OpenGLTokens

PFNGLBLENDCOLOREXTPROC

GLScene.OpenGLTokens

GL_EXT_blend_color (EXT #2)

PFNGLBLENDCOLORPROC

GLScene.OpenGLTokens

====================================================================== core 1.2 promoted to core v1.2 from GL_EXT_blend_color (#2)

PFNGLBLENDEQUATIONEXTPROC

GLScene.OpenGLTokens

GL_EXT_blend_minmax (EXT #37)

PFNGLBLENDEQUATIONIARBPROC

GLScene.OpenGLTokens

GL_ARB_draw_buffers_blend (ARB #69)

PFNGLBLENDEQUATIONIPROC

GLScene.OpenGLTokens

Core 4.0 promoted to core v4.0 from GL_ARB_draw_buffers_blend (ARB #69)

PFNGLBLENDEQUATIONPROC

GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_blend_minmax (#37)

PFNGLBLENDEQUATIONSEPARATEEXTPROC

GLScene.OpenGLTokens

GL_EXT_blend_equation_separate (EXT #299)

PFNGLBLENDEQUATIONSEPARATEIARBPROC

GLScene.OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEIPROC

GLScene.OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEPROC

GLScene.OpenGLTokens

core 2.0 promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)

PFNGLBLENDFUNCIARBPROC

GLScene.OpenGLTokens

PFNGLBLENDFUNCIPROC

GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEEXTPROC

GLScene.OpenGLTokens

GL_EXT_blend_func_separate (EXT #173)

PFNGLBLENDFUNCSEPARATEIARBPROC

GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEIPROC

GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEPROC

GLScene.OpenGLTokens

deprecated; core 1.4 promoted to core v1.4 from GL_EXT_blend_func_separate (#173)

PFNGLBLITFRAMEBUFFEREXTPROC

GLScene.OpenGLTokens

GL_EXT_framebuffer_blit (EXT #316)

PFNGLBLITFRAMEBUFFERPROC

GLScene.OpenGLTokens

PFNGLBUFFERADDRESSRANGENVPROC

GLScene.OpenGLTokens

GL_NV_vertex_buffer_unified_memory (EXT #380)

PFNGLBUFFERDATAARBPROC

GLScene.OpenGLTokens

PFNGLBUFFERDATAPROC

GLScene.OpenGLTokens

PFNGLBufferStorage

GLScene.OpenGLTokens

PFNGLBUFFERSUBDATAARBPROC

GLScene.OpenGLTokens

PFNGLBUFFERSUBDATAPROC

GLScene.OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC

GLScene.OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSPROC

GLScene.OpenGLTokens

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC

GLScene.OpenGLTokens

PFNGLCLAMPCOLORARBPROC

GLScene.OpenGLTokens

GL_ARB_color_buffer_float (ARB #39)

PFNGLCLAMPCOLORPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_ARB_color_buffer_float

PFNGLClearBufferData

GLScene.OpenGLTokens

GL_ARB_clear_buffer_object (ARB #121)

PFNGLCLEARBUFFERFIPROC

GLScene.OpenGLTokens

PFNGLCLEARBUFFERFVPROC

GLScene.OpenGLTokens

PFNGLCLEARBUFFERIVPROC

GLScene.OpenGLTokens

New commands in OpenGL 3.0

PFNGLClearBufferSubData

GLScene.OpenGLTokens

PFNGLCLEARBUFFERUIVPROC

GLScene.OpenGLTokens

PFNGLCLEARCOLORIIEXTPROC

GLScene.OpenGLTokens

GL_EXT_texture_integer (EXT #343)

PFNGLCLEARCOLORIUIEXTPROC

GLScene.OpenGLTokens

PFNGLCLEARDEPTHFPROC

GLScene.OpenGLTokens

PFNGLClearNamedBufferData

GLScene.OpenGLTokens

PFNGLClearNamedBufferSubData

GLScene.OpenGLTokens

PFNGLClearTexImage

GLScene.OpenGLTokens

PFNGLClearTexSubImage

GLScene.OpenGLTokens

PFNGLCLIENTACTIVETEXTUREARBPROC

GLScene.OpenGLTokens

PFNGLCLIENTACTIVETEXTUREPROC

GLScene.OpenGLTokens

core 1.3 deprecated promoted to core v1.3 from GL_ARB_multitexture (#1)

PFNGLCLIENTATTRIBDEFAULTEXTPROC

GLScene.OpenGLTokens

GL_EXT_direct_state_access

PFNGLCLIENTWAITSYNCPROC

GLScene.OpenGLTokens

PFNGLCOLORFORMATNVPROC

GLScene.OpenGLTokens

PFNGLCOLORMASKINDEXEDEXTPROC

GLScene.OpenGLTokens

GL_EXT_draw_buffers2 (EXT #340)

PFNGLCOLORMASKIPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_draw_buffers2

PFNGLCOLORP3UIPROC

GLScene.OpenGLTokens

PFNGLCOLORP3UIVPROC

GLScene.OpenGLTokens

PFNGLCOLORP4UIPROC

GLScene.OpenGLTokens

PFNGLCOLORP4UIVPROC

GLScene.OpenGLTokens

PFNGLCOLORSUBTABLEEXTPROC

GLScene.OpenGLTokens

PFNGLCOLORSUBTABLEPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)

PFNGLCOLORTABLEEXTPROC

GLScene.OpenGLTokens

GL_EXT_paletted_texture (EXT #78)

PFNGLCOLORTABLEPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOLORTABLEPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOLORTABLEPROC

GLScene.OpenGLTokens

core 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)

PFNGLCOMBINERINPUTNVPROC

GLScene.OpenGLTokens

PFNGLCOMBINEROUTPUTNVPROC

GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERFNVPROC

GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERFVNVPROC

GLScene.OpenGLTokens

GL_NV_register_combiners (EXT #191)

PFNGLCOMBINERPARAMETERINVPROC

GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLCOMPILESHADERARBPROC

GLScene.OpenGLTokens

PFNGLCOMPILESHADERPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC

GLScene.OpenGLTokens

GL_ARB_texture_compression (ARB #12)

PFNGLCOMPRESSEDTEXIMAGE3DPROC

GLScene.OpenGLTokens

promoted to core v1.3 from GL_ARB_texture_compression (#12)

PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCONVOLUTIONFILTER1DPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)

PFNGLCONVOLUTIONFILTER2DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCONVOLUTIONPARAMETERFPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCONVOLUTIONPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCONVOLUTIONPARAMETERIPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCONVOLUTIONPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOPYBUFFERSUBDATAPROC

GLScene.OpenGLTokens

GL_ARB_copy_buffer (ARB #59)

PFNGLCOPYCOLORSUBTABLEPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOPYCOLORTABLEPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOPYCONVOLUTIONFILTER1DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOPYCONVOLUTIONFILTER2DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCopyImageSubData

GLScene.OpenGLTokens

GL_ARB_copy_image (ARB #123)

PFNGLCOPYIMAGESUBDATANVPROC

GLScene.OpenGLTokens

GL_NV_copy_image (EXT #376)

PFNGLCOPYMULTITEXIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYMULTITEXIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYPATHNVPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXIMAGE1DEXTPROC

GLScene.OpenGLTokens

GL_EXT_copy_texture (EXT #10)

PFNGLCOPYTEXIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DPROC

GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_copy_texture

PFNGLCOPYTEXTUREIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXTUREIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOVERFILLPATHINSTANCEDNVPROC

GLScene.OpenGLTokens

PFNGLCOVERFILLPATHNVPROC

GLScene.OpenGLTokens

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC

GLScene.OpenGLTokens

PFNGLCOVERSTROKEPATHNVPROC

GLScene.OpenGLTokens

PFNGLCREATEPROGRAMOBJECTARBPROC

GLScene.OpenGLTokens

PFNGLCREATEPROGRAMPROC

GLScene.OpenGLTokens

PFNGLCREATESHADEROBJECTARBPROC

GLScene.OpenGLTokens

PFNGLCREATESHADERPROC

GLScene.OpenGLTokens

PFNGLCREATESHADERPROGRAMVPROC

GLScene.OpenGLTokens

PFNGLCreateSyncFromCLevent

GLScene.OpenGLTokens

GL_ARB_robustness_isolation (ARB #126) (no entry points) GL_ARB_cl_event (ARB #103)

PFNGLCURRENTPALETTEMATRIXARBPROC

GLScene.OpenGLTokens

GL_ARB_matrix_palette (ARB #16) {deprecated?}

PFNGLDEBUGMESSAGECALLBACKARBPROC

GLScene.OpenGLTokens

PFNGLDEBUGMESSAGECONTROLARBPROC

GLScene.OpenGLTokens

GL_ARB_debug_output (ARB #104)

PFNGLDEBUGMESSAGEINSERTARBPROC

GLScene.OpenGLTokens

PFNGLDELETEBUFFERSARBPROC

GLScene.OpenGLTokens

PFNGLDELETEBUFFERSPROC

GLScene.OpenGLTokens

PFNGLDELETEFENCESNVPROC

GLScene.OpenGLTokens

PFNGLDELETEFRAMEBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLDELETEFRAMEBUFFERSPROC

GLScene.OpenGLTokens

PFNGLDELETEOBJECTARBPROC

GLScene.OpenGLTokens

GL_ARB_shader_objects (ARB #30)

PFNGLDELETEOCCLUSIONQUERIESNVPROC

GLScene.OpenGLTokens

PFNGLDELETEPATHSNVPROC

GLScene.OpenGLTokens

PFNGLDELETEPROGRAMPIPELINESPROC

GLScene.OpenGLTokens

PFNGLDELETEPROGRAMPROC

GLScene.OpenGLTokens

PFNGLDELETEPROGRAMSARBPROC

GLScene.OpenGLTokens

PFNGLDELETEPROGRAMSNVPROC

GLScene.OpenGLTokens

PFNGLDELETEQUERIESARBPROC

GLScene.OpenGLTokens

PFNGLDELETEQUERIESPROC

GLScene.OpenGLTokens

PFNGLDELETERENDERBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLDELETERENDERBUFFERSPROC

GLScene.OpenGLTokens

PFNGLDELETESAMPLERSPROC

GLScene.OpenGLTokens

PFNGLDELETESHADERPROC

GLScene.OpenGLTokens

PFNGLDELETESYNCPROC

GLScene.OpenGLTokens

PFNGLDELETETEXTURESEXTPROC

GLScene.OpenGLTokens

PFNGLDELETETRANSFORMFEEDBACKSPROC

GLScene.OpenGLTokens

PFNGLDELETEVERTEXARRAYSPROC

GLScene.OpenGLTokens

PFNGLDEPTHBOUNDSEXTPROC

GLScene.OpenGLTokens

GL_EXT_depth_bounds_test (EXT #297)

PFNGLDEPTHRANGEARRAYVPROC

GLScene.OpenGLTokens

PFNGLDEPTHRANGEFPROC

GLScene.OpenGLTokens

PFNGLDEPTHRANGEINDEXEDPROC

GLScene.OpenGLTokens

PFNGLDETACHOBJECTARBPROC

GLScene.OpenGLTokens

PFNGLDETACHSHADERPROC

GLScene.OpenGLTokens

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLDISABLEINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLDISABLEIPROC

GLScene.OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC

GLScene.OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYPROC

GLScene.OpenGLTokens

PFNGLDispatchCompute

GLScene.OpenGLTokens

GL_ARB_compute_shader (ARB #122)

PFNGLDispatchComputeIndirect

GLScene.OpenGLTokens

PFNGLDRAWARRAYSINDIRECTPROC

GLScene.OpenGLTokens

GL_ARB_draw_indirect (ARB #87)

PFNGLDRAWARRAYSINSTANCEDARBPROC

GLScene.OpenGLTokens

GL_ARB_draw_instanced (ARB #44)

PFNGLDRAWARRAYSINSTANCEDEXTPROC

GLScene.OpenGLTokens

GL_EXT_draw_instanced (EXT #327)

PFNGLDRAWARRAYSINSTANCEDPROC

GLScene.OpenGLTokens

Core 3.1 New commands in OpenGL 3.1

PFNGLDRAWBUFFERSARBPROC

GLScene.OpenGLTokens

GL_ARB_DrawBuffers (ARB #37)

PFNGLDRAWBUFFERSATIPROC

GLScene.OpenGLTokens

GL_ATI_draw_buffers (EXT #277)

PFNGLDRAWBUFFERSPROC

GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_draw_buffers (#37)

PFNGLDRAWELEMENTSBASEVERTEXPROC

GLScene.OpenGLTokens

GL_ARB_draw_elements_base_vertex (ARB #62)

PFNGLDRAWELEMENTSINDIRECTPROC

GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDARBPROC

GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC

GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDEXTPROC

GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDPROC

GLScene.OpenGLTokens

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC

GLScene.OpenGLTokens

PFNGLDRAWRANGEELEMENTSEXTPROC

GLScene.OpenGLTokens

GL_EXT_draw_range_elements (EXT #112)

PFNGLDRAWRANGEELEMENTSPROC

GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)

PFNGLDRAWTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC

GLScene.OpenGLTokens

GL_ARB_transform_feedback3 (ARB #94)

PFNGLEDGEFLAGFORMATNVPROC

GLScene.OpenGLTokens

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLENABLEINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLENABLEIPROC

GLScene.OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYARBPROC

GLScene.OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYPROC

GLScene.OpenGLTokens

PFNGLENDCONDITIONALRENDERNVPROC

GLScene.OpenGLTokens

PFNGLENDCONDITIONALRENDERPROC

GLScene.OpenGLTokens

PFNGLENDOCCLUSIONQUERYNVPROC

GLScene.OpenGLTokens

PFNGLENDQUERYARBPROC

GLScene.OpenGLTokens

PFNGLENDQUERYINDEXEDPROC

GLScene.OpenGLTokens

PFNGLENDQUERYPROC

GLScene.OpenGLTokens

PFNGLENDSCENEEXTPROC

GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKEXTPROC

GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKNVPROC

GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLEXECUTEPROGRAMNVPROC

GLScene.OpenGLTokens

PFNGLFENCESYNCPROC

GLScene.OpenGLTokens

GL_ARB_sync (ARB #66)

PFNGLFINALCOMBINERINPUTNVPROC

GLScene.OpenGLTokens

PFNGLFINISHFENCENVPROC

GLScene.OpenGLTokens

PFNGLFLUSHMAPPEDBUFFERRANGEPROC

GLScene.OpenGLTokens

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC

GLScene.OpenGLTokens

PFNGLFLUSHVERTEXARRAYRANGENVPROC

GLScene.OpenGLTokens

GL_NV_vertex_array_range (EXT #190)

PFNGLFOGCOORDDEXTPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDDPROC

GLScene.OpenGLTokens

deprecated;

PFNGLFOGCOORDDVEXTPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDDVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLFOGCOORDFEXTPROC

GLScene.OpenGLTokens

GL_EXT_fog_coord (EXT #149)

PFNGLFOGCOORDFORMATNVPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDFPROC

GLScene.OpenGLTokens

core 1.4 deprecated promoted to core v1.4 from GL_EXT_fog_coord (#149)

PFNGLFOGCOORDFVEXTPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLFOGCOORDPOINTEREXTPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDPOINTERPROC

GLScene.OpenGLTokens

deprecated;

PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLFramebufferParameteri

GLScene.OpenGLTokens

GL_ARB_debug_group ARB_debug_group reuses entry points from KHR_debug GL_ARB_debug_label ARB_debug_label reuses entry points from KHR_debug GL_ARB_debug_output2 GL_ARB_ES3_compatibility GL_ARB_explicit_uniform_location GL_ARB_fragment_layer_viewport GL_ARB_framebuffer_no_attachments (ARB #130)

PFNGLFRAMEBUFFERREADBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFERPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREARBPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREPROC

GLScene.OpenGLTokens

PFNGLFRAMETERMINATORGREMEDYPROC

GLScene.OpenGLTokens

GL_GREMEDY_frame_terminator (EXT #345)

PFNGLGENBUFFERSARBPROC

GLScene.OpenGLTokens

PFNGLGENBUFFERSPROC

GLScene.OpenGLTokens

PFNGLGENERATEMIPMAPEXTPROC

GLScene.OpenGLTokens

PFNGLGENERATEMIPMAPPROC

GLScene.OpenGLTokens

PFNGLGENERATEMULTITEXMIPMAPEXTPROC

GLScene.OpenGLTokens

PFNGLGENERATETEXTUREMIPMAPEXTPROC

GLScene.OpenGLTokens

PFNGLGENFENCESNVPROC

GLScene.OpenGLTokens

GL_NV_fence (EXT #222)

PFNGLGENFRAMEBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLGENFRAMEBUFFERSPROC

GLScene.OpenGLTokens

PFNGLGENOCCLUSIONQUERIESNVPROC

GLScene.OpenGLTokens

GL_NV_occlusion_query (EXT #261)

PFNGLGENPATHSNVPROC

GLScene.OpenGLTokens

GL_NV_path_rendering

PFNGLGENPROGRAMPIPELINESPROC

GLScene.OpenGLTokens

PFNGLGENPROGRAMSARBPROC

GLScene.OpenGLTokens

PFNGLGENPROGRAMSNVPROC

GLScene.OpenGLTokens

PFNGLGENQUERIESARBPROC

GLScene.OpenGLTokens

GL_ARB_occlusion_query (ARB #29)

PFNGLGENQUERIESPROC

GLScene.OpenGLTokens

deprecated; core 1.5 promoted to core v1.5 from GL_ARB_occlusion_query (#29)

PFNGLGENRENDERBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLGENRENDERBUFFERSPROC

GLScene.OpenGLTokens

PFNGLGENSAMPLERSPROC

GLScene.OpenGLTokens

GL_ARB_sampler_objects (ARB #81)

PFNGLGENTEXTURESEXTPROC

GLScene.OpenGLTokens

GL_EXT_texture_object (EXT #20)

PFNGLGENTRANSFORMFEEDBACKSPROC

GLScene.OpenGLTokens

PFNGLGENVERTEXARRAYSPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEATTRIBARBPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEATTRIBPROC

GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINENAMEPROC

GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC

GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMARBPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKIVPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMNAMEPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMSIVPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEVARYINGNVPROC

GLScene.OpenGLTokens

PFNGLGETATTACHEDOBJECTSARBPROC

GLScene.OpenGLTokens

PFNGLGETATTACHEDSHADERSPROC

GLScene.OpenGLTokens

PFNGLGETATTRIBLOCATIONARBPROC

GLScene.OpenGLTokens

PFNGLGETATTRIBLOCATIONPROC

GLScene.OpenGLTokens

PFNGLGETBOOLEANINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETBOOLEANI_VPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERI64VPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERIVARBPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERUI64VNVPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPOINTERVARBPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPOINTERVPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERSUBDATAARBPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERSUBDATAPROC

GLScene.OpenGLTokens

PFNGLGETCOLORTABLEEXTPROC

GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCOLORTABLEPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCOLORTABLEPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC

GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC

GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEPROC

GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC

GLScene.OpenGLTokens

PFNGLGETCONVOLUTIONFILTERPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCONVOLUTIONPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCONVOLUTIONPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETDEBUGMESSAGELOGARBPROC

GLScene.OpenGLTokens

PFNGLGETDOUBLEINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETDOUBLEI_VPROC

GLScene.OpenGLTokens

PFNGLGETFENCEIVNVPROC

GLScene.OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLGETFLOATINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETFLOATI_VPROC

GLScene.OpenGLTokens

PFNGLGETFRAGDATAINDEXPROC

GLScene.OpenGLTokens

PFNGLGETFRAGDATALOCATIONEXTPROC

GLScene.OpenGLTokens

PFNGLGETFRAGDATALOCATIONPROC

GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLGetFramebufferParameteriv

GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETGRAPHICSRESETSTATUSARBPROC

GLScene.OpenGLTokens

GL_ARB_robustness (ARB #105)

PFNGLGETHANDLEARBPROC

GLScene.OpenGLTokens

PFNGLGETHISTOGRAMPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETHISTOGRAMPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETHISTOGRAMPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)

PFNGLGETINFOLOGARBPROC

GLScene.OpenGLTokens

PFNGLGETINTEGER64I_VPROC

GLScene.OpenGLTokens

Core 3.2

PFNGLGETINTEGER64VPROC

GLScene.OpenGLTokens

PFNGLGETINTEGERINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETINTEGERI_VPROC

GLScene.OpenGLTokens

PFNGLGETINTEGERUI64I_VNVPROC

GLScene.OpenGLTokens

PFNGLGETINTEGERUI64VNVPROC

GLScene.OpenGLTokens

PFNGLGetInternalformati64v

GLScene.OpenGLTokens

GL_ARB_internalformat_query2 (ARB #131)

PFNGLGETMINMAXPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETMINMAXPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETMINMAXPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETMULTISAMPLEFVPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXENVFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXENVIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXGENDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXGENFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXGENIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXIMAGEEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGetNamedFramebufferParameteriv

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNCOLORTABLEARBPROC

GLScene.OpenGLTokens

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC

GLScene.OpenGLTokens

PFNGLGETNCONVOLUTIONFILTERARBPROC

GLScene.OpenGLTokens

PFNGLGETNHISTOGRAMARBPROC

GLScene.OpenGLTokens

PFNGLGETNMAPDVARBPROC

GLScene.OpenGLTokens

PFNGLGETNMAPFVARBPROC

GLScene.OpenGLTokens

PFNGLGETNMAPIVARBPROC

GLScene.OpenGLTokens

PFNGLGETNMINMAXARBPROC

GLScene.OpenGLTokens

PFNGLGETNPIXELMAPFVARBPROC

GLScene.OpenGLTokens

PFNGLGETNPIXELMAPUIVARBPROC

GLScene.OpenGLTokens

PFNGLGETNPIXELMAPUSVARBPROC

GLScene.OpenGLTokens

PFNGLGETNPOLYGONSTIPPLEARBPROC

GLScene.OpenGLTokens

PFNGLGETNSEPARABLEFILTERARBPROC

GLScene.OpenGLTokens

PFNGLGETNTEXIMAGEARBPROC

GLScene.OpenGLTokens

PFNGLGETNUNIFORMDVARBPROC

GLScene.OpenGLTokens

PFNGLGETNUNIFORMFVARBPROC

GLScene.OpenGLTokens

PFNGLGETNUNIFORMIVARBPROC

GLScene.OpenGLTokens

PFNGLGETNUNIFORMUIVARBPROC

GLScene.OpenGLTokens

PFNGLGetObjectLabel

GLScene.OpenGLTokens

PFNGLGETOBJECTPARAMETERFVARBPROC

GLScene.OpenGLTokens

PFNGLGETOBJECTPARAMETERIVARBPROC

GLScene.OpenGLTokens

PFNGLGetObjectPtrLabel

GLScene.OpenGLTokens

PFNGLGETOCCLUSIONQUERYIVNVPROC

GLScene.OpenGLTokens

PFNGLGETOCCLUSIONQUERYUIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHCOLORGENFVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHCOLORGENIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHCOMMANDSNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHCOORDSNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHDASHARRAYNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHLENGTHNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHMETRICRANGENVPROC

GLScene.OpenGLTokens

PFNGLGETPATHMETRICSNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHSPACINGNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHTEXGENFVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHTEXGENIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPOINTERINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMBINARYPROC

GLScene.OpenGLTokens

GL_ARB_get_program_binary (ARB #96)

PFNGLGETPROGRAMENVPARAMETERDVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMENVPARAMETERFVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMINFOLOGPROC

GLScene.OpenGLTokens

PFNGLGetProgramInterfaceiv

GLScene.OpenGLTokens

GL_ARB_program_interface_query (ARB #134)

PFNGLGETPROGRAMIVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMIVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMPARAMETERDVNVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMPIPELINEINFOLOGPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMPIPELINEIVPROC

GLScene.OpenGLTokens

PFNGLGetProgramResourceIndex

GLScene.OpenGLTokens

PFNGLGetProgramResourceiv

GLScene.OpenGLTokens

PFNGLGetProgramResourceLocation

GLScene.OpenGLTokens

PFNGLGetProgramResourceLocationIndex

GLScene.OpenGLTokens

PFNGLGetProgramResourceName

GLScene.OpenGLTokens

PFNGLGETPROGRAMSTAGEIVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMSTRINGARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMSTRINGNVPROC

GLScene.OpenGLTokens

PFNGLGETQUERYINDEXEDIVPROC

GLScene.OpenGLTokens

PFNGLGETQUERYIVARBPROC

GLScene.OpenGLTokens

PFNGLGETQUERYIVPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTI64VEXTPROC

GLScene.OpenGLTokens

GL_EXT_timer_query (EXT #319)

PFNGLGETQUERYOBJECTI64VPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTIVARBPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTIVPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUI64VEXTPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUI64VPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUIVARBPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUIVPROC

GLScene.OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERFVPROC

GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIFVPROC

GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIIVPROC

GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLGETSEPARABLEFILTERPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETSHADERINFOLOGPROC

GLScene.OpenGLTokens

PFNGLGETSHADERIVPROC

GLScene.OpenGLTokens

PFNGLGETSHADERPRECISIONFORMATPROC

GLScene.OpenGLTokens

PFNGLGETSHADERSOURCEARBPROC

GLScene.OpenGLTokens

PFNGLGETSHADERSOURCEPROC

GLScene.OpenGLTokens

PFNGLGETSTRINGIPROC

GLScene.OpenGLTokens

PFNGLGETSUBROUTINEINDEXPROC

GLScene.OpenGLTokens

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC

GLScene.OpenGLTokens

GL_ARB_shader_subroutine (ARB #90)

PFNGLGETSYNCIVPROC

GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIIVPROC

GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIUIVPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREIMAGEEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTRACKMATRIXIVNVPROC

GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC

GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC

GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMBLOCKINDEXPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMBUFFERSIZEEXTPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMDVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMFVARBPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMFVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMINDICESPROC

GLScene.OpenGLTokens

GL_ARB_uniform_buffer_object (ARB #57)

PFNGLGETUNIFORMIVARBPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMIVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMLOCATIONARBPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMLOCATIONPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMOFFSETEXTPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMSUBROUTINEUIVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMUI64VNVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMUIVPROC

GLScene.OpenGLTokens

PFNGLGETVARYINGLOCATIONNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVARBPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVARBPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIIVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVARBPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBLDVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVARBPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVPROC

GLScene.OpenGLTokens

PFNGLHISTOGRAMPROC

GLScene.OpenGLTokens

deprecated;

PFNGLINDEXFORMATNVPROC

GLScene.OpenGLTokens

PFNGLINDEXFUNCEXTPROC

GLScene.OpenGLTokens

GL_EXT_index_func (EXT #95)

PFNGLINDEXMATERIALEXTPROC

GLScene.OpenGLTokens

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; GL_EXT_index_material (EXT #94)

PFNGLINTERPOLATEPATHSNVPROC

GLScene.OpenGLTokens

PFNGLInvalidateBufferData

GLScene.OpenGLTokens

PFNGLInvalidateBufferSubData

GLScene.OpenGLTokens

PFNGLInvalidateFramebuffer

GLScene.OpenGLTokens

PFNGLInvalidateSubFramebuffer

GLScene.OpenGLTokens

PFNGLInvalidateTexImage

GLScene.OpenGLTokens

PFNGLInvalidateTexSubImage

GLScene.OpenGLTokens

GL_ARB_invalidate_subdata (ARB #132)

PFNGLISBUFFERARBPROC

GLScene.OpenGLTokens

PFNGLISBUFFERPROC

GLScene.OpenGLTokens

PFNGLISBUFFERRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLISENABLEDINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLISENABLEDIPROC

GLScene.OpenGLTokens

PFNGLISFENCENVPROC

GLScene.OpenGLTokens

PFNGLISFRAMEBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLISFRAMEBUFFERPROC

GLScene.OpenGLTokens

PFNGLISNAMEDBUFFERRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLISOCCLUSIONQUERYNVPROC

GLScene.OpenGLTokens

PFNGLISPATHNVPROC

GLScene.OpenGLTokens

PFNGLISPOINTINFILLPATHNVPROC

GLScene.OpenGLTokens

PFNGLISPOINTINSTROKEPATHNVPROC

GLScene.OpenGLTokens

PFNGLISPROGRAMARBPROC

GLScene.OpenGLTokens

PFNGLISPROGRAMNVPROC

GLScene.OpenGLTokens

PFNGLISPROGRAMPIPELINEPROC

GLScene.OpenGLTokens

PFNGLISPROGRAMPROC

GLScene.OpenGLTokens

PFNGLISQUERYARBPROC

GLScene.OpenGLTokens

PFNGLISQUERYPROC

GLScene.OpenGLTokens

PFNGLISRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

GL_EXT_framebuffer_object (EXT #310)

PFNGLISRENDERBUFFERPROC

GLScene.OpenGLTokens

GL_ARB_framebuffer_object (ARB #45)

PFNGLISSAMPLERPROC

GLScene.OpenGLTokens

PFNGLISSHADERPROC

GLScene.OpenGLTokens

PFNGLISSYNCPROC

GLScene.OpenGLTokens

PFNGLISTEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLISTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLISVERTEXARRAYPROC

GLScene.OpenGLTokens

PFNGLLINKPROGRAMARBPROC

GLScene.OpenGLTokens

PFNGLLINKPROGRAMPROC

GLScene.OpenGLTokens

PFNGLLOADPROGRAMNVPROC

GLScene.OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDARBPROC

GLScene.OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDPROC

GLScene.OpenGLTokens

deprecated;

PFNGLLOADTRANSPOSEMATRIXFARBPROC

GLScene.OpenGLTokens

GL_ARB_transpose_matrix (ARB #3)

PFNGLLOADTRANSPOSEMATRIXFPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix

PFNGLLOCKARRAYSEXTPROC

GLScene.OpenGLTokens

GL_EXT_compiled_vertex_array (EXT #97)

PFNGLMAKEBUFFERNONRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLMAKEBUFFERRESIDENTNVPROC

GLScene.OpenGLTokens

GL_NV_shader_buffer_load (EXT #379)

PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLMAPBUFFERARBPROC

GLScene.OpenGLTokens

PFNGLMAPBUFFERPROC

GLScene.OpenGLTokens

PFNGLMAPBUFFERRANGEPROC

GLScene.OpenGLTokens

GL_ARB_map_buffer_range (ARB #50)

PFNGLMAPNAMEDBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLMAPNAMEDBUFFERRANGEEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXFRUSTUMEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXINDEXPOINTERARBPROC

GLScene.OpenGLTokens

PFNGLMATRIXINDEXUBVARBPROC

GLScene.OpenGLTokens

PFNGLMATRIXINDEXUIVARBPROC

GLScene.OpenGLTokens

PFNGLMATRIXINDEXUSVARBPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADIDENTITYEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXMULTDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXMULTFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXORTHOEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXPOPEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXPUSHEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXROTATEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXROTATEFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXSCALEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXSCALEFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXTRANSLATEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXTRANSLATEFEXTPROC

GLScene.OpenGLTokens

PFNGLMINMAXPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMINSAMPLESHADINGARBPROC

GLScene.OpenGLTokens

GL_ARB_sample_shading (ARB #70)

PFNGLMINSAMPLESHADINGPROC

GLScene.OpenGLTokens

promoted to core v4.0 from GL_ARB_sample_shading (ARB #70)

PFNGLMULTIDRAWARRAYSEXTPROC

GLScene.OpenGLTokens

GL_EXT_multi_draw_arrays (EXT #148)

PFNGLMultiDrawArraysIndirect

GLScene.OpenGLTokens

GL_ARB_multi_draw_indirect (ARB #133)

PFNGLMULTIDRAWARRAYSPROC

GLScene.OpenGLTokens

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)

PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC

GLScene.OpenGLTokens

PFNGLMULTIDRAWELEMENTSEXTPROC

GLScene.OpenGLTokens

PFNGLMultiDrawElementsIndirect

GLScene.OpenGLTokens

PFNGLMULTIDRAWELEMENTSPROC

GLScene.OpenGLTokens

PFNGLMULTITEXBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1DVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1FARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1FVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1IARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1IVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1SARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1SVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2DARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2DVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2FARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2FVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2IARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2IVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2SARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2SVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3DARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3DVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3FARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3FVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3IARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3IVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3SARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3SVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4DARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4DVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4FARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4FVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4IARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4IVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4SARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4SVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORDP1UIPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP1UIVPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP2UIPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP2UIVPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP3UIPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP3UIVPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP4UIPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP4UIVPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDPOINTEREXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXENVFEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXENVFVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXENVIEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXENVIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENDEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENDVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENFEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENFVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENIEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERFEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDARBPROC

GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTTRANSPOSEMATRIXFARBPROC

GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXFPROC

GLScene.OpenGLTokens

deprecated;

PFNGLNAMEDBUFFERDATAEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDBUFFERSUBDATAEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC

GLScene.OpenGLTokens

PFNGLNamedFramebufferParameteri

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMSTRINGEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC

GLScene.OpenGLTokens

PFNGLNORMALFORMATNVPROC

GLScene.OpenGLTokens

PFNGLNORMALP3UIPROC

GLScene.OpenGLTokens

PFNGLNORMALP3UIVPROC

GLScene.OpenGLTokens

PFNGLObjectLabel

GLScene.OpenGLTokens

PFNGLObjectPtrLabel

GLScene.OpenGLTokens

PFNGLPATCHPARAMETERFVPROC

GLScene.OpenGLTokens

PFNGLPATCHPARAMETERIPROC

GLScene.OpenGLTokens

GL_ARB_tessellation_shader (ARB #91)

PFNGLPATHCOLORGENNVPROC

GLScene.OpenGLTokens

PFNGLPATHCOMMANDSNVPROC

GLScene.OpenGLTokens

PFNGLPATHCOORDSNVPROC

GLScene.OpenGLTokens

PFNGLPATHCOVERDEPTHFUNCNVPROC

GLScene.OpenGLTokens

PFNGLPATHDASHARRAYNVPROC

GLScene.OpenGLTokens

PFNGLPATHFOGGENNVPROC

GLScene.OpenGLTokens

PFNGLPATHGLYPHRANGENVPROC

GLScene.OpenGLTokens

PFNGLPATHGLYPHSNVPROC

GLScene.OpenGLTokens

PFNGLPATHPARAMETERFNVPROC

GLScene.OpenGLTokens

PFNGLPATHPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLPATHPARAMETERINVPROC

GLScene.OpenGLTokens

PFNGLPATHPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLPATHSTENCILDEPTHOFFSETNVPROC

GLScene.OpenGLTokens

PFNGLPATHSTENCILFUNCNVPROC

GLScene.OpenGLTokens

PFNGLPATHSTRINGNVPROC

GLScene.OpenGLTokens

PFNGLPATHSUBCOMMANDSNVPROC

GLScene.OpenGLTokens

PFNGLPATHSUBCOORDSNVPROC

GLScene.OpenGLTokens

PFNGLPATHTEXGENNVPROC

GLScene.OpenGLTokens

PFNGLPAUSETRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLPOINTALONGPATHNVPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERFARBPROC

GLScene.OpenGLTokens

GL_ARB_point_parameter (ARB #14)

PFNGLPOINTPARAMETERFPROC

GLScene.OpenGLTokens

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)

PFNGLPOINTPARAMETERFVARBPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERFVPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERINVPROC

GLScene.OpenGLTokens

GL_NV_point_sprite (EXT #262)

PFNGLPOINTPARAMETERIPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLPOLYGONOFFSETEXTPROC

GLScene.OpenGLTokens

GL_EXT_polygon_offset (EXT #3)

PFNGLPopDebugGroup

GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXNVPROC

GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXPROC

GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTNVPROC

GLScene.OpenGLTokens

GL_NV_primitive_restart (EXT #285)

PFNGLPRIORITIZETEXTURESEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMBINARYPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DVARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FVARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC

GLScene.OpenGLTokens

GL_EXT_gpu_program_parameters (EXT #320)

PFNGLPROGRAMLOCALPARAMETER4DARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4DNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4DVNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4FNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4FVNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERIARBPROC

GLScene.OpenGLTokens

GL_ARB_geometry_shader4 (ARB #47)

PFNGLPROGRAMPARAMETERIEXTPROC

GLScene.OpenGLTokens

GL_EXT_geometry_shader4 (EXT #324)

PFNGLPROGRAMPARAMETERIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERS4DVNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERS4FVNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMSTRINGARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1FPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1IPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1IVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1UIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1UIVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2FPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2IPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2IVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2UIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2UIVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3FPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3IPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3IVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3UIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3UIVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4FPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4IPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4IVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4UIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4UIVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMUI64NVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMUI64VNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMVERTEXLIMITNVPROC

GLScene.OpenGLTokens

GL_NV_geometry_program4 (EXT #323)

PFNGLPROVOKINGVERTEXPROC

GLScene.OpenGLTokens

GL_ARB_provoking_vertex (ARB #64)

PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC

GLScene.OpenGLTokens

PFNGLPushDebugGroup

GLScene.OpenGLTokens

GL_ARB_shader_stencil_export (ARB #106) (no entry points) GL_KHR_debug (ARB #119)

PFNGLQUERYCOUNTERPROC

GLScene.OpenGLTokens

GL_ARB_timer_query (ARB #85)

PFNGLREADNPIXELSARBPROC

GLScene.OpenGLTokens

PFNGLRELEASESHADERCOMPILERPROC

GLScene.OpenGLTokens

GL_ARB_ES2_compatibility (ARB #95)

PFNGLRENDERBUFFERSTORAGEEXTPROC

GLScene.OpenGLTokens

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC

GLScene.OpenGLTokens

GL_EXT_framebuffer_multisample (EXT #317)

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC

GLScene.OpenGLTokens

PFNGLRENDERBUFFERSTORAGEPROC

GLScene.OpenGLTokens

PFNGLREQUESTRESIDENTPROGRAMSNVPROC

GLScene.OpenGLTokens

PFNGLRESETHISTOGRAMPROC

GLScene.OpenGLTokens

deprecated;

PFNGLRESETMINMAXPROC

GLScene.OpenGLTokens

deprecated;

PFNGLRESIZEBUFFERSMESAPROC

GLScene.OpenGLTokens

GL_MESA_resize_buffers (EXT #196)

PFNGLRESUMETRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLSAMPLECOVERAGEARBPROC

GLScene.OpenGLTokens

GL_ARB_multisample (ARB #5)

PFNGLSAMPLECOVERAGEPROC

GLScene.OpenGLTokens

promoted to core v1.3 from GL_ARB_multisample (#5)

PFNGLSAMPLEMASKEXTPROC

GLScene.OpenGLTokens

GL_EXT_multisample (EXT #209)

PFNGLSAMPLEMASKIPROC

GLScene.OpenGLTokens

PFNGLSAMPLEMASKSGISPROC

GLScene.OpenGLTokens

GL_SGIS_multisample (EXT #25)

PFNGLSAMPLEPASSARBPROC

GLScene.OpenGLTokens

ARB Extensions unknown ARB extension

PFNGLSAMPLEPATTERNEXTPROC

GLScene.OpenGLTokens

PFNGLSAMPLEPATTERNSGISPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERFPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERFVPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIIVPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIUIVPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLSCISSORARRAYVPROC

GLScene.OpenGLTokens

PFNGLSCISSORINDEXEDPROC

GLScene.OpenGLTokens

PFNGLSCISSORINDEXEDVPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3BEXTPROC

GLScene.OpenGLTokens

GL_EXT_secondary_color (EXT #145)

PFNGLSECONDARYCOLOR3BPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)

PFNGLSECONDARYCOLOR3BVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3BVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3DEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3DVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3FEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3FVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3IEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3IVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3SEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3SVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3UBEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UBPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3UBVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UBVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3UIEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UIPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3UIVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3USEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3USPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3USVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3USVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLORFORMATNVPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLORP3UIPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLORP3UIVPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLORPOINTEREXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLORPOINTERPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSEPARABLEFILTER2DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSETFENCENVPROC

GLScene.OpenGLTokens

PFNGLSHADERBINARYPROC

GLScene.OpenGLTokens

PFNGLSHADERSOURCEARBPROC

GLScene.OpenGLTokens

PFNGLSHADERSOURCEPROC

GLScene.OpenGLTokens

PFNGLShaderStorageBlockBinding

GLScene.OpenGLTokens

GL_ARB_robust_buffer_access_behavior (ARB #135) (no entry points) GL_ARB_shader_image_size (ARB #136) (no entry points) GL_ARB_shader_storage_buffer_object (ARB #137)

PFNGLSTENCILCLEARTAGEXTPROC

GLScene.OpenGLTokens

GL_EXT_stencil_clear_tag (EXT #314)

PFNGLSTENCILFILLPATHINSTANCEDNVPROC

GLScene.OpenGLTokens

PFNGLSTENCILFILLPATHNVPROC

GLScene.OpenGLTokens

PFNGLSTENCILFUNCSEPARATEPROC

GLScene.OpenGLTokens

PFNGLSTENCILMASKSEPARATEPROC

GLScene.OpenGLTokens

PFNGLSTENCILOPSEPARATEPROC

GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)

PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC

GLScene.OpenGLTokens

PFNGLSTENCILSTROKEPATHNVPROC

GLScene.OpenGLTokens

PFNGLSTRINGMARKERGREMEDYPROC

GLScene.OpenGLTokens

GL_GREMEDY_string_marker (EXT #311)

PFNGLTBUFFERMASK3DFXPROC

GLScene.OpenGLTokens

GL_3DFX_tbuffer (EXT #208)

PFNGLTESSELLATIONFACTORAMDPROC

GLScene.OpenGLTokens

GL_AMD_vertex_shader_tessellator (EXT #363)

PFNGLTESSELLATIONMODEAMDPROC

GLScene.OpenGLTokens

PFNGLTESTFENCENVPROC

GLScene.OpenGLTokens

PFNGLTEXBUFFERARBPROC

GLScene.OpenGLTokens

GL_ARB_texture_buffer_object (ARB #51)

PFNGLTEXBUFFEREXTPROC

GLScene.OpenGLTokens

GL_EXT_packed_float (EXT #328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (EXT #329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (EXT #330)

PFNGLTEXBUFFERPROC

GLScene.OpenGLTokens

PFNGLTexBufferRange

GLScene.OpenGLTokens

GL_ARB_stencil_texturing (ARB #138) (no entry points) GL_ARB_texture_buffer_range (ARB #139)

PFNGLTEXCOORDFORMATNVPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP1UIPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP1UIVPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP2UIPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP2UIVPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP3UIPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP3UIVPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP4UIPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP4UIVPROC

GLScene.OpenGLTokens

PFNGLTEXIMAGE2DMULTISAMPLEPROC

GLScene.OpenGLTokens

GL_ARB_texture_multisample (ARB #67)

PFNGLTEXIMAGE3DEXTPROC

GLScene.OpenGLTokens

GL_EXT_texture3D (EXT #6)

PFNGLTEXIMAGE3DMULTISAMPLEPROC

GLScene.OpenGLTokens

PFNGLTEXIMAGE3DPROC

GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_texture3D (#6)

PFNGLTEXPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXPARAMETERIIVPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_texture_integer

PFNGLTEXPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXPARAMETERIUIVPROC

GLScene.OpenGLTokens

PFNGLTexStorage2DMultisample

GLScene.OpenGLTokens

GL_ARB_texture_query_levels (ARB #140) (no entry points) GL_ARB_texture_storage_multisample (ARB #141)

PFNGLTexStorage3DMultisample

GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

GL_EXT_subtexture (EXT #9)

PFNGLTEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE3DPROC

GLScene.OpenGLTokens

PFNGLTEXTUREBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLTextureBufferRange

GLScene.OpenGLTokens

PFNGLTEXTURECOLORMASKSGISPROC

GLScene.OpenGLTokens

GL_SGIS_texture_color_mask (EXT #214)

PFNGLTEXTUREIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTURERENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLTextureStorage2DMultisample

GLScene.OpenGLTokens

PFNGLTextureStorage3DMultisample

GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLTextureView

GLScene.OpenGLTokens

GL_ARB_texture_view (ARB #124)

PFNGLTRACKMATRIXNVPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMPATHNVPROC

GLScene.OpenGLTokens

PFNGLUDELETENURBSTESSELLATOREXTPROC

GLScene.OpenGLTokens

PFNGLUNEWNURBSTESSELLATOREXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1DPROC

GLScene.OpenGLTokens

GL_ARB_gpu_shader_fp64 (ARB #89)

PFNGLUNIFORM1DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1FARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1FPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1IARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1IPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1IVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1IVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1UIEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1UIPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1UIVEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1UIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2DPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2FARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2FPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2IARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2IPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2IVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2IVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2UIEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2UIPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2UIVEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2UIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3DPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3FARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3FPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3IARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3IPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3IVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3IVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3UIEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3UIPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3UIVEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3UIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4DPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4FARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4FPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4IARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4IPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4IVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4IVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4UIEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4UIPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4UIVEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4UIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMBLOCKBINDINGPROC

GLScene.OpenGLTokens

PFNGLUNIFORMBUFFEREXTPROC

GLScene.OpenGLTokens

GL_EXT_bindable_uniform (EXT #342)

PFNGLUNIFORMMATRIX2DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X3DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X3FVPROC

GLScene.OpenGLTokens

core 2.1 new commands in OpenGL 2.1

PFNGLUNIFORMMATRIX2X4DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X4FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X2DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X2FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X4DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X4FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X2DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X2FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X3DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X3FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMSUBROUTINESUIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMUI64NVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMUI64VNVPROC

GLScene.OpenGLTokens

PFNGLUNLOCKARRAYSEXTPROC

GLScene.OpenGLTokens

PFNGLUNMAPBUFFERARBPROC

GLScene.OpenGLTokens

PFNGLUNMAPBUFFERPROC

GLScene.OpenGLTokens

PFNGLUNMAPNAMEDBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLUNURBSCALLBACKDATAEXTPROC

GLScene.OpenGLTokens

GLU extensions (might not be same naming as c versions?)

PFNGLUSEPROGRAMOBJECTARBPROC

GLScene.OpenGLTokens

PFNGLUSEPROGRAMPROC

GLScene.OpenGLTokens

PFNGLUSEPROGRAMSTAGESPROC

GLScene.OpenGLTokens

GL_ARB_separate_shader_objects (ARB #97)

PFNGLVALIDATEPROGRAMARBPROC

GLScene.OpenGLTokens

PFNGLVALIDATEPROGRAMPIPELINEPROC

GLScene.OpenGLTokens

PFNGLVALIDATEPROGRAMPROC

GLScene.OpenGLTokens

PFNGLVertexArrayBindVertexBuffer

GLScene.OpenGLTokens

PFNGLVERTEXARRAYRANGENVPROC

GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribBinding

GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribFormat

GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribIFormat

GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribLFormat

GLScene.OpenGLTokens

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC

GLScene.OpenGLTokens

VertexArrayVertexAttribLOffsetEXT only valid if EXT_direct_state_access is available

PFNGLVertexArrayVertexBindingDivisor

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DARBPROC

GLScene.OpenGLTokens

GL_ARB_vertex_program (ARB #26)

PFNGLVERTEXATTRIB1DNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4BVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4BVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4IVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NBVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NBVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NIVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NSVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NSVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUIVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUSVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUSVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UIVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4USVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4USVPROC

GLScene.OpenGLTokens

PFNGLVertexAttribBinding

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBDIVISORARBPROC

GLScene.OpenGLTokens

GL_ARB_instanced_arrays (ARB #49)

PFNGLVERTEXATTRIBDIVISORPROC

GLScene.OpenGLTokens

Core 3.3

PFNGLVertexAttribFormat

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBFORMATNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1IEXTPROC

GLScene.OpenGLTokens

GL_EXT_gpu_shader4 (EXT #326)

PFNGLVERTEXATTRIBI1IPROC

GLScene.OpenGLTokens

Core 3.0 promoted to core v3.0 from GL_EXT_gpu_shader4

PFNGLVERTEXATTRIBI1IVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4BVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4BVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4SVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UBVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UBVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4USVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4USVPROC

GLScene.OpenGLTokens

PFNGLVertexAttribIFormat

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIFORMATNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIPOINTEREXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIPOINTERPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL1DPROC

GLScene.OpenGLTokens

GL_ARB_shader_precision (ARB #98) (no entry points) GL_ARB_vertex_attrib_64bit (ARB #99)

PFNGLVERTEXATTRIBL1DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL2DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL2DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL3DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL3DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL4DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL4DVPROC

GLScene.OpenGLTokens

PFNGLVertexAttribLFormat

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBLPOINTERPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP1UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP1UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP2UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP2UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP3UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP3UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP4UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP4UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4UBVNVPROC

GLScene.OpenGLTokens

PFNGLVertexBindingDivisor

GLScene.OpenGLTokens

PFNGLVERTEXBLENDARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXFORMATNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXP2UIPROC

GLScene.OpenGLTokens

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)

PFNGLVERTEXP2UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXP3UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXP3UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXP4UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXP4UIVPROC

GLScene.OpenGLTokens

PFNGLVIEWPORTARRAYVPROC

GLScene.OpenGLTokens

GL_ARB_viewport_array (ARB #100)

PFNGLVIEWPORTINDEXEDFPROC

GLScene.OpenGLTokens

PFNGLVIEWPORTINDEXEDFVPROC

GLScene.OpenGLTokens

PFNGLWAITSYNCPROC

GLScene.OpenGLTokens

PFNGLWEIGHTBVARBPROC

GLScene.OpenGLTokens

GL_ARB_vertex_blend (ARB #15) {deprecated?}

PFNGLWEIGHTDVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTFVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTIVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTPATHSNVPROC

GLScene.OpenGLTokens

PFNGLWEIGHTPOINTERARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTSVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTUBVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTUIVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTUSVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2DARBPROC

GLScene.OpenGLTokens

GL_ARB_window_pos (ARB #25)

PFNGLWINDOWPOS2DPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)

PFNGLWINDOWPOS2DVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2FARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2FVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2IARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2IVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2SARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2SVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3DARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3DVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3FARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3FVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3IARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3IVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3SARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3SVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3SVPROC

GLScene.OpenGLTokens

deprecated;

PFNWGLALLOCATEMEMORYNVPROC

GLScene.OpenGLTokens

PFNWGLBINDTEXIMAGEARBPROC

GLScene.OpenGLTokens

WGL_ARB_render_texture (ARB #20)

PFNWGLCHOOSEPIXELFORMATARBPROC

GLScene.OpenGLTokens

PFNWGLCREATEAFFINITYDCNVPROC

GLScene.OpenGLTokens

PFNWGLCREATEBUFFERREGIONARBPROC

GLScene.OpenGLTokens

WGL WGL - ARB WGL_buffer_region (ARB #4)

PFNWGLCREATECONTEXTATTRIBSARBPROC

GLScene.OpenGLTokens

WGL_ARB_create_context (ARB #55)

PFNWGLCREATEPBUFFERARBPROC

GLScene.OpenGLTokens

WGL_ARB_pbuffer (ARB #11)

PFNWGLDELETEBUFFERREGIONARBPROC

GLScene.OpenGLTokens

PFNWGLDELETEDCNVPROC

GLScene.OpenGLTokens

PFNWGLDESTROYPBUFFERARBPROC

GLScene.OpenGLTokens

PFNWGLDXCLOSEDEVICEPROC

GLScene.OpenGLTokens

PFNWGLDXLOCKOBJECTSPROC

GLScene.OpenGLTokens

PFNWGLDXOBJECTACCESSPROC

GLScene.OpenGLTokens

PFNWGLDXOPENDEVICEPROC

GLScene.OpenGLTokens

PFNWGLDXREGISTEROBJECTPROC

GLScene.OpenGLTokens

PFNWGLDXSETRESOURCESHAREHANDLEPROC

GLScene.OpenGLTokens

WGL_NV_DX_interop (EXT #407)

PFNWGLDXUNLOCKOBJECTSNVPROC

GLScene.OpenGLTokens

PFNWGLDXUNREGISTEROBJECTPROC

GLScene.OpenGLTokens

PFNWGLENUMGPUDEVICESNVPROC

GLScene.OpenGLTokens

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC

GLScene.OpenGLTokens

PFNWGLENUMGPUSNVPROC

GLScene.OpenGLTokens

WGL_NV_gpu_affinity (EXT #355)

PFNWGLFREEMEMORYNVPROC

GLScene.OpenGLTokens

PFNWGLGETCURRENTREADDCARBPROC

GLScene.OpenGLTokens

PFNWGLGETEXTENSIONSSTRINGARBPROC

GLScene.OpenGLTokens

WGL_ARB_extensions_string (ARB #8)

PFNWGLGETPBUFFERDCARBPROC

GLScene.OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBFVARBPROC

GLScene.OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBIVARBPROC

GLScene.OpenGLTokens

WGL_ARB_pixel_format (ARB #9)

PFNWGLGETSWAPINTERVALEXTPROC

GLScene.OpenGLTokens

PFNWGLMAKECONTEXTCURRENTARBPROC

GLScene.OpenGLTokens

WGL_make_current_read (ARB #10)

PFNWGLQUERYPBUFFERARBPROC

GLScene.OpenGLTokens

PFNWGLRELEASEPBUFFERDCARBPROC

GLScene.OpenGLTokens

PFNWGLRELEASETEXIMAGEARBPROC

GLScene.OpenGLTokens

PFNWGLRESTOREBUFFERREGIONARBPROC

GLScene.OpenGLTokens

PFNWGLSAVEBUFFERREGIONARBPROC

GLScene.OpenGLTokens

PFNWGLSETPBUFFERATTRIBARBPROC

GLScene.OpenGLTokens

PFNWGLSWAPINTERVALEXTPROC

GLScene.OpenGLTokens

WGL - EXT WGL_EXT_swap_control (EXT #172)

PFog

Formats.m3DSTypes

PFogSettings3DS

Formats.m3DSTypes

FallOff to the Bottom

PFontEntry

GLS.SpaceText

holds an entry in the font manager list (used in TGLSpaceText)

PFovTrackTag

Formats.m3DSTypes

PFrustum

GLScene.VectorGeometry

PFSoundDSPUnit

FMOD.types

PFSoundSample

FMOD.types

FMOD defined types

PFSoundStream

FMOD.types

PFSoundVector

FMOD.types

PFSyncPoint

FMOD.types

PFXPointerList

GLS.ParticleFX

PGLbitfield

GLScene.OpenGL4

PGLbitfield

GLScene.OpenGLTokens

UINT

PGLboolean

GLScene.OpenGL4

PGLboolean

GLScene.OpenGLTokens

PGLbyte

GLScene.OpenGL4

PGLbyte

GLScene.OpenGLTokens

PGLChar

GLScene.OpenGL4

PGLchar

GLScene.OpenGLTokens

PGLclampd

GLScene.OpenGL4

PGLclampd

GLScene.OpenGLTokens

PGLclampf

GLScene.OpenGL4

PGLclampf

GLScene.OpenGLTokens

PGLdouble

GLScene.OpenGL4

PGLdouble

GLScene.OpenGLTokens

PGLenum

GLScene.OpenGL4

PGLenum

GLScene.OpenGLTokens

PGLFireParticle

GLS.FireFX

PGLFireParticleArray

GLS.FireFX

PGLfloat

GLScene.OpenGL4

PGLfloat

GLScene.OpenGLTokens

PGLhalf

GLScene.OpenGLTokens

PGLhandleARB

GLScene.OpenGL4

PGLhandleARB

GLScene.OpenGLTokens

PGLHeightTile

GLS.HeightTileFileHDS

PGLHeightTileInfo

GLS.HeightTileFileHDS

PGLint

GLScene.OpenGL4

PGLint

GLScene.OpenGLTokens

PGLint64

GLScene.OpenGL4

PGLint64

GLScene.OpenGLTokens

PGLint64EXT

GLScene.OpenGL4

PGLint64EXT

GLScene.OpenGLTokens

PGLintptr

GLScene.OpenGL4

PGLintptr

GLScene.OpenGLTokens

PGLIsoline

GLS.Isolines

PGLMatrix

GLScene.VectorTypes

The matrix by default

PGLOctreeNode

GLS.Octree

PGLParticleArray

GLS.ParticleFX

PGLPCharArray

GLScene.OpenGL4

PGLPCharArray

GLScene.OpenGLTokens

PGLPixel24

GLS.Graphics

PGLPixel32

GLS.Graphics

PGLPixel32Array

GLS.Graphics

PGLPointer

GLScene.OpenGL4

PGLPointer

GLScene.OpenGLTokens

PGLRCHandle

GLS.Context

PGLRenderContextInfo

GLS.RenderContextInfo

PGLshort

GLScene.OpenGL4

PGLshort

GLScene.OpenGLTokens

PGLsizei

GLScene.OpenGL4

PGLsizei

GLScene.OpenGLTokens

PGLsizeiptr

GLScene.OpenGLTokens

PGLStarRecord

GLS.SkyDome

PGLsync

GLScene.OpenGLTokens

PGLubyte

GLScene.OpenGL4

PGLubyte

GLScene.OpenGLTokens

PGLuint

GLScene.OpenGL4

PGLuint

GLScene.OpenGLTokens

PGLuint

OpenCL.GL

PGLuint64

GLScene.OpenGL4

PGLuint64

GLScene.OpenGLTokens

PGLuint64EXT

GLScene.OpenGL4

PGLuint64EXT

GLScene.OpenGLTokens

PGLUNurbs

GLScene.OpenGL4

PGLUNurbs

GLScene.OpenGLTokens

PGLUNurbsObj

GLScene.OpenGL4

PGLUNurbsObj

GLScene.OpenGLTokens

PGLUQuadric

GLScene.OpenGL4

PGLUQuadric

GLScene.OpenGLTokens

PGLUQuadricObj

GLScene.OpenGL4

PGLUQuadricObj

GLScene.OpenGLTokens

PGLushort

GLScene.OpenGL4

PGLushort

GLScene.OpenGLTokens

PGLUTesselator

GLScene.OpenGL4

PGLUTesselator

GLScene.OpenGLTokens

PGLUTesselatorObj

GLScene.OpenGL4

PGLUTesselatorObj

GLScene.OpenGLTokens

PGLUTriangulatorObj

GLScene.OpenGL4

PGLUTriangulatorObj

GLScene.OpenGLTokens

PGLvdpauSurfaceNV

GLScene.OpenGLTokens

PGLVector

GLScene.VectorTypes

The vector by default

PGLVertexBoneWeightArray

GLS.VectorFileObjects

PGLVertexData

GLS.Mesh

PGLVertexDataArray

GLS.Mesh

PGLVertexRec

GLS.Objects

PGLVerticesBoneWeights

GLS.VectorFileObjects

PGLVideoMode

GLS.Screen

PGLvoid

GLScene.OpenGL4

PGLvoid

GLScene.OpenGLTokens

PGNGLGETBUFFERPARAMETERUI64VNV

GLScene.OpenGLTokens

PGPUDEVICE

GLScene.OpenGL4

PGPUDEVICE

GLScene.OpenGLTokens

PgTransformationRec

GLScene.PipelineTransform

PHalfFloat

GLScene.Utils

PHGPUNV

GLScene.OpenGL4

—————————- OpenGL Utility (GLU) types ——————–

PHGPUNV

GLScene.OpenGLTokens

PHideTrackTag

Formats.m3DSTypes

PHiShadowBias

Formats.m3DSTypes

PHmgBoundingBox

GLScene.GeometryBB

Structure for storing Bounding Boxes

PHomogeneousByteVector

GLScene.VectorGeometry

Common vector and matrix types with predefined limits indices correspond like: x -> 0 y -> 1 z -> 2 w -> 3

PHomogeneousDblVector

GLScene.VectorGeometry

PHomogeneousExtVector

GLScene.VectorGeometry

PHomogeneousFltVector

GLScene.VectorGeometry

PHomogeneousIntVector

GLScene.VectorGeometry

PHomogeneousMatrix

GLScene.VectorGeometry

PHomogeneousPtrVector

GLScene.VectorGeometry

PHomogeneousVector

GLScene.VectorGeometry

some simplified names

PHomogeneousWordVector

GLScene.VectorGeometry

PHotTrackTag

Formats.m3DSTypes

PHVIDEO

Formats.VFW

PHVIDEOINPUTDEVICENV

GLScene.OpenGL4

PHVIDEOINPUTDEVICENV

GLScene.OpenGLTokens

PhysXDLL

PhysX.Import

PI1

Formats.LWO

PI2

Formats.LWO

PI4

Formats.LWO

PICCOMPRESS

Formats.VFW

PICCOMPRESSFRAMES

Formats.VFW

PICDECOMPRESS

Formats.VFW

this frame is not a key frame

PICDECOMPRESSEX

Formats.VFW

PICDRAW

Formats.VFW

this frame is not a key frame

PICDRAWBEGIN

Formats.VFW

please buffer this data offscreen, we will need to update it

PICDRAWSUGGEST

Formats.VFW

PICINFO

Formats.VFW

*********************************************************************** ***********************************************************************

PICOPEN

Formats.VFW

*********************************************************************** ***********************************************************************

PICPALETTE

Formats.VFW

*********************************************************************** ***********************************************************************

PICSETSTATUSPROC

Formats.VFW

PID4

Formats.LWO

PInstanceName

Formats.m3DSTypes

PInt

SDL.Import

PInteger

Newton.Import

PIntegerArray

Formats.m3DSTypes

PIntegerArray

GLS.HeightTileFileHDS

PIntegerArray

GLScene.VectorGeometry

PIntegerVector

GLScene.VectorGeometry

PIntermediateFormatArray

GLS.ImageUtils

PIntPercentage

Formats.m3DSTypes

Pintptr_t

OpenCL.Platform

PIpasData

Formats.m3DSTypes

Pitch

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its X-axis

Pitch

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterRight

PIVOT

Formats.m3DSConst

PIVOT_LIMITS

Formats.m3DSConst

PIVOT_OBJECT

Formats.m3DSConst

PIVOT_ORDER

Formats.m3DSConst

PixelFormatToColorBits

GLS.ImageUtils

Returns the number of color bits associated to the given pixel format.

PKeyHeader3DS

Formats.m3DSTypes

PKeyHeaderList

Formats.m3DSTypes

PKEYSChunk

Formats.B3D

PKFAmbient3DS

Formats.m3DSTypes

Ambient Light animation

PKFCamera3DS

Formats.m3DSTypes

PKFCurtime

Formats.m3DSTypes

PKFHdr

Formats.m3DSTypes

PKFId

Formats.m3DSTypes

PKFKeyInfo3DS

Formats.m3DSTypes

PKFMesh3DS

Formats.m3DSTypes

used by ObjectMotion3DS

PKFMorphKey3DS

Formats.m3DSTypes

PKFMorphKeyList

Formats.m3DSTypes

Name of Target Morph object

PKFOmni3DS

Formats.m3DSTypes

used by OmnilightMotion3DS

PKFRotKey3DS

Formats.m3DSTypes

PKFRotKeyList

Formats.m3DSTypes

PKFSeg

Formats.m3DSTypes

PKFSegment3DS

Formats.m3DSTypes

PKFSets3DS

Formats.m3DSTypes

PKFSpot3DS

Formats.m3DSTypes

PlaneAABBIntersection

GLScene.GeometryBB

Compute the intersection between a plane and the AABB

PlaneContainsBSphere

GLScene.GeometryBB

Determines to which extent a plane contains a BSphere

PlaneEvaluatePoint

GLScene.VectorGeometry

PlaneEvaluatePoint

GLScene.VectorGeometry

Calculates the cross-product between the plane normal and plane to point vector. This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive. This function performs an homogeneous space dot-product.

PlaneIntersectAABB

GLScene.GeometryBB

Checks if a plane (given by the normal+d) intersects the AABB

PlaneMake

GLScene.VectorGeometry

PlaneMake

GLScene.VectorGeometry

PlaneMake

GLScene.VectorGeometry

Computes the parameters of a plane defined by a point and a normal.

PlaneMake

GLScene.VectorGeometry

Computes the parameters of a plane defined by three points.

PLayerFog

Formats.m3DSTypes

PLayerFogSettings3DS

Formats.m3DSTypes

PlayOnWaveOut

GLS.Sounds.WaveOut

PlayOnWaveOut

GLS.Sounds.WaveOut

PLight3DS

Formats.m3DSTypes

omni and spotlight settings

PLinColor24

Formats.m3DSTypes

PLinColorF

Formats.m3DSTypes

PLiteAttenuate3DS

Formats.m3DSTypes

Light Attenuation settings

PLMTS

GLS.FileLMTS

PLMTS_Header

GLS.FileLMTS

max texture filename length

PLMTS_Subset

GLS.FileLMTS

PLMTS_TexData

GLS.FileLMTS

PLMTS_Vertex

GLS.FileLMTS

PLONG

Formats.VFW

PLongWordArray

GLScene.VectorGeometry

PLongWordVector

GLScene.VectorGeometry

PLoShadowBias

Formats.m3DSTypes

PLWChunkRec

Formats.LWO

Lightwave Chunk Struct - Used in TLWOReadCallback

PLWPolyTagMap

Formats.LWO

PLWSubChunkRec

Formats.LWO

Lightwave SubChunk Struct - Used in TLWOReadCallback

PM3dVersion

Formats.m3DSTypes

PMainAVIHeader

Formats.VFW

size of AVI header list

PMapInfo3DS

Formats.m3DSTypes

Texture Map icon placement

PMapSet3DS

Formats.m3DSTypes

Bit Map definition Structure to all Map settings

PMasterScale

Formats.m3DSTypes

PMatAcubic

Formats.m3DSTypes

PMatBumpPercent

Formats.m3DSTypes

PMaterial3DS

Formats.m3DSTypes

PMatMapAng

Formats.m3DSTypes

PMatMapBCol

Formats.m3DSTypes

PMatMapCol1

Formats.m3DSTypes

PMatMapCol2

Formats.m3DSTypes

PMatMapGCol

Formats.m3DSTypes

PMatMapname

Formats.m3DSTypes

PMatMapRCol

Formats.m3DSTypes

PMatMapTexblur

Formats.m3DSTypes

PMatMapTiling

Formats.m3DSTypes

PMatMapUOffset

Formats.m3DSTypes

PMatMapUScale

Formats.m3DSTypes

PMatMapVOffset

Formats.m3DSTypes

PMatMapVScale

Formats.m3DSTypes

PMatName

Formats.m3DSTypes

PMatrix4f

GLScene.VectorTypes

the matrix by default

PMatrixArray

GLScene.VectorGeometry

PMatrixRec

GLScene.VectorTypesExt

PMatShading

Formats.m3DSTypes

PMatWireSize

Formats.m3DSTypes

PMD2AliasFrame

Formats.MD2

PMD2VertexIndex

Formats.MD2

PMDCTagFrame

GLS.FileMDC

PMDCTagName

GLS.FileMDC

PMesh3DS

Formats.m3DSTypes

Mesh object definition

PMESHChunk

Formats.B3D

PMeshColor

Formats.m3DSTypes

PMeshMatrix

Formats.m3DSTypes

Mesh definition

PMeshSet3DS

Formats.m3DSTypes

PMeshTextureInfo

Formats.m3DSTypes

PMeshVersion

Formats.m3DSTypes

PMorphSmooth

Formats.m3DSTypes

PMorphTrackTag

Formats.m3DSTypes

pMS3DComment

GLS.FileMS3D

PMS3DJointArray

GLS.FileMS3D

PMS3DKeyframePositionArray

GLS.FileMS3D

PMS3DKeyframeRotationArray

GLS.FileMS3D

PMS3DTriangleArray

GLS.FileMS3D

PMS3DVertexArray

GLS.FileMS3D

pMS3D_vertex_ex_t

GLS.FileMS3D

PMshBoxmap

Formats.m3DSTypes

PMshMatGroup

Formats.m3DSTypes

PNamedObject

Formats.m3DSTypes

PNCamera

Formats.m3DSTypes

PNDirectLight

Formats.m3DSTypes

PNewtonAcyclicArticulation

Newton.Import

PNewtonAllocMemory

Newton.Import

PNewtonApplyForceAndTorque

Newton.Import

PNewtonBallCallback

Newton.Import

PNewtonBody

Newton.Import

PNewtonBodyDestructor

Newton.Import

PNewtonBodyIterator

Newton.Import

PNewtonBoxParam

Newton.Import

PNewtonCapsuleParam

Newton.Import

PNewtonChamferCylinderParam

Newton.Import

PNewtonCollision

Newton.Import

PNewtonCollisionCopyConstructionCallback

Newton.Import

PNewtonCollisionDestructorCallback

Newton.Import

PNewtonCollisionInfoRecord

Newton.Import

PNewtonCollisionIterator

Newton.Import

PNewtonCollisionMaterial

Newton.Import

PNewtonCollisionTreeParam

Newton.Import

PNewtonCollisionTreeRayCastCallback

Newton.Import

PNewtonCompoundCollisionParam

Newton.Import

PNewtonConeParam

Newton.Import

PNewtonConstraintDestructor

Newton.Import

PNewtonContactsProcess

Newton.Import

PNewtonConvexHullParam

Newton.Import

PNewtonCorkscrewCallback

Newton.Import

PNewtonCreateContactCallback

Newton.Import

PNewtonCylinderParam

Newton.Import

PNewtonDeformableMeshParam

Newton.Import

PNewtonDeformableMeshSegment

Newton.Import

PNewtonDeserializeCallback

Newton.Import

PNewtonDestroyContactCallback

Newton.Import

PNewtonFractureCompoundCollisionOnEmitChunk

Newton.Import

PNewtonFractureCompoundCollisionOnEmitCompoundFractured

Newton.Import

PNewtonFractureCompoundCollisionReconstructMainMeshCallBack

Newton.Import

PNewtonFracturedCompoundMeshPart

Newton.Import

PNewtonFreeMemory

Newton.Import

PNewtonGetTimeInMicrosencondsCallback

Newton.Import

PNewtonHeightFieldCollisionParam

Newton.Import

PNewtonHeightFieldRayCastCallback

Newton.Import

PNewtonHingeCallback

Newton.Import

PNewtonHingeSliderUpdateDesc

Newton.Import

PNewtonImmediateModeConstraint

Newton.Import

PNewtonInverseDynamics

Newton.Import

PNewtonIslandUpdate

Newton.Import

PNewtonJobTask

Newton.Import

PNewtonJoint

Newton.Import

PNewtonJointIterator

Newton.Import

PNewtonJointRecord

Newton.Import

PNewtonMaterial

Newton.Import

PNewtonMaterialData

Newton.Import

PNewtonMesh

Newton.Import

PNewtonMeshDoubleData

Newton.Import

PNewtonMeshFloatData

Newton.Import

PNewtonMeshVertexFormat

Newton.Import

PNewtonOnAABBOverlap

Newton.Import

PNewtonOnBodyDeserializationCallback

Newton.Import

PNewtonOnBodySerializationCallback

Newton.Import

PNewtonOnCompoundSubCollisionAABBOverlap

Newton.Import

PNewtonOnContactGeneration

Newton.Import

PNewtonOnJointDeserializationCallback

Newton.Import

PNewtonOnJointSerializationCallback

Newton.Import

PNewtonOnUserCollisionSerializationCallback

Newton.Import

PNewtonPostUpdateCallback

Newton.Import

PNewtonReportProgress

Newton.Import

PNewtonSceneCollisionParam

Newton.Import

PNewtonSceneProxy

Newton.Import

PNewtonSerializeCallback

Newton.Import

PNewtonSetTransform

Newton.Import

PNewtonSliderCallback

Newton.Import

PNewtonSphereParam

Newton.Import

PNewtonTaperedCapsuleParam

Newton.Import

PNewtonTaperedCylinderParam

Newton.Import

PNewtonTreeCollisionCallback

Newton.Import

PNewtonTreeCollisionFaceCallback

Newton.Import

PNewtonUniversalCallback

Newton.Import

PNewtonUserBilateralCallback

Newton.Import

PNewtonUserBilateralGetInfoCallback

Newton.Import

PNewtonUserContactPoint

Newton.Import

PNewtonUserMeshCollisionAABBTest

Newton.Import

PNewtonUserMeshCollisionCollideCallback

Newton.Import

PNewtonUserMeshCollisionCollideDesc

Newton.Import

PNewtonUserMeshCollisionDestroyCallback

Newton.Import

PNewtonUserMeshCollisionGetCollisionInfo

Newton.Import

PNewtonUserMeshCollisionGetFacesInAABB

Newton.Import

PNewtonUserMeshCollisionRayHitCallback

Newton.Import

PNewtonUserMeshCollisionRayHitDesc

Newton.Import

PNewtonWorld

Newton.Import

PNewtonWorldConvexCastReturnInfo

Newton.Import

PNewtonWorldDestroyListenerCallback

Newton.Import

PNewtonWorldDestructorCallback

Newton.Import

PNewtonWorldListenerBodyDestroyCallback

Newton.Import

PNewtonWorldListenerDebugCallback

Newton.Import

PNewtonWorldRayFilterCallback

Newton.Import

PNewtonWorldRayPrefilterCallback

Newton.Import

PNewtonWorldUpdateListenerCallback

Newton.Import

PNODEChunk

Formats.B3D

PNodeHdr

Formats.m3DSTypes

PNodeList

Formats.m3DSTypes

3D Studio .MLI file

PObjMat3DS

Formats.m3DSTypes

Material assignments by face

PObjMatList

Formats.m3DSTypes

POConsts

Formats.m3DSTypes

POCTFace

Formats.OCT

POCTLightmap

Formats.OCT

POctreeTriangleInfo

GLS.Octree

Stores information about an intersected triangle

PointAdd

GLScene.VectorGeometry

Returns the sum of two homogeneous vectors. W coordinate is always 1.

PointArrayMin3DS

Formats.m3DSConst

POINT_ARRAY

PointDiskOrthoProjection

GLScene.VectorGeometry

Computes point to disk projection. Direction has to be normalized

PointDiskProjection

GLScene.VectorGeometry

PointInAABB

GLScene.GeometryBB

PointInAABB

GLScene.GeometryBB

Checks if a point "p" is inside an AABB

PointInPolygon

GLScene.VectorGeometry

The code below is from Wm. Randolph Franklin <wrf@ecse.rpi.edu> with some minor modifications for speed. It returns 1 for strictly interior points, 0 for strictly exterior, and 0 or 1 for points on the boundary

PointIsInHalfSpace

GLScene.VectorGeometry

PointIsInHalfSpace

GLScene.VectorGeometry

PointIsInHalfSpace

GLScene.VectorGeometry

Returns true if point is in the half-space defined by a plane with normal. The plane itself is not considered to be in the tested halfspace.

PointLineClosestPoint

GLScene.VectorGeometry

Computes closest point on a line

PointLineDistance

GLScene.VectorGeometry

Computes algebraic distance between point and line

PointMake

GLScene.VectorGeometry

PointMake

GLScene.VectorGeometry

PointMake

GLScene.VectorGeometry

PointPlaneDistance

GLScene.VectorGeometry

PointPlaneDistance

GLScene.VectorGeometry

PointPlaneDistance

GLScene.VectorGeometry

Computes algebraic distance between point and plane. Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.

PointPlaneOrthoProjection

GLScene.VectorGeometry

Computes point to plane projection. Plane and direction have to be normalized

PointPlaneProjection

GLScene.VectorGeometry

PointProject

GLScene.VectorGeometry

PointProject

GLScene.VectorGeometry

Projects p on the line defined by o and direction. Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line

PointQuadOrthoProjection

GLScene.VectorGeometry

Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex

PointQuadProjection

GLScene.VectorGeometry

PointSegmentClosestPoint

GLScene.VectorGeometry

PointSegmentClosestPoint

GLScene.VectorGeometry

Computes closest point on a segment (a segment is a limited line)

PointSegmentDistance

GLScene.VectorGeometry

Computes algebraic distance between segment and line (a segment is a limited line)

PointTriangleOrthoProjection

GLScene.VectorGeometry

Computes point to triangle projection. Direction has to be normalized

PointTriangleProjection

GLScene.VectorGeometry

POINT_ARRAY

Formats.m3DSConst

POINT_ARRAY_ENTRY

Formats.m3DSConst

Trick Chunk Types For Open, Write, Close functions

POINT_FLAG_ARRAY

Formats.m3DSConst

POINT_FLAG_ARRAY_ENTRY

Formats.m3DSConst

POLS_FLAGS_MASK

Formats.LWO

POLS_TYPE_BONE

Formats.LWO

METABALL

POLS_TYPE_CURV

Formats.LWO

FACES

POLS_TYPE_FACE

Formats.LWO

PIXEL PLUG-IN FILTER

POLS_TYPE_MBAL

Formats.LWO

PATCH

POLS_TYPE_PTCH

Formats.LWO

CURVE

POLS_VCOUNT_MASK

Formats.LWO

LINEAR

PolygonArea

GLScene.VectorGeometry

Computes the polygons's area. Points must be coplanar. Polygon needs not be convex

PolygonSignedArea

GLScene.VectorGeometry

Computes a 2D polygon's signed area. Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex

POLY_2D

Formats.m3DSConst

POrthoView3DS

Formats.m3DSTypes

PositionSceneObject

GLS.ODEUtils

PositionSceneObjectForGeom

GLS.ODEUtils

POS_TRACK_TAG

Formats.m3DSConst

POS_TRACK_TAG_KEY

Formats.m3DSConst

PowerInt64

GLScene.VectorGeometry

PowerInteger

GLScene.VectorGeometry

Raise base to an integer

PowerSingle

GLScene.VectorGeometry

Raise base to any power. For fractional exponents, or |exponents| > MaxInt, base must be > 0

PPALvoid

OpenAL.Import

PParticleReference

GLS.ParticleFX

PParticleReferenceArray

GLS.ParticleFX

PPasDblStrUtilsBoolean

PasDblStrUtils

PPasDblStrUtilsChar

PasDblStrUtils

PPasDblStrUtilsDouble

PasDblStrUtils

PPasDblStrUtilsInt16

PasDblStrUtils

PPasDblStrUtilsInt32

PasDblStrUtils

PPasDblStrUtilsInt64

PasDblStrUtils

PPasDblStrUtilsInt8

PasDblStrUtils

PPasDblStrUtilsNativeInt

PasDblStrUtils

PPasDblStrUtilsNativeUInt

PasDblStrUtils

PPasDblStrUtilsPointer

PasDblStrUtils

PPasDblStrUtilsPtrInt

PasDblStrUtils

PPasDblStrUtilsPtrUInt

PasDblStrUtils

PPasDblStrUtilsRawByteChar

PasDblStrUtils

PPasDblStrUtilsRawByteCharSet

PasDblStrUtils

PPasDblStrUtilsRawByteString

PasDblStrUtils

PPasDblStrUtilsRoundingMode

PasDblStrUtils

PPasDblStrUtilsString

PasDblStrUtils

PPasDblStrUtilsUInt16

PasDblStrUtils

PPasDblStrUtilsUInt32

PasDblStrUtils

PPasDblStrUtilsUInt64

PasDblStrUtils

PPasDblStrUtilsUInt8

PasDblStrUtils

PPasDblStrUtilsUTF16Char

PasDblStrUtils

PPasDblStrUtilsUTF16String

PasDblStrUtils

PPasDblStrUtilsUTF8Char

PasDblStrUtils

PPasDblStrUtilsUTF8String

PasDblStrUtils

PPasJSONChar

PasJSON

PPasJSONDouble

PasJSON

PPasJSONEncoding

PasJSON

PPasJSONFloat

PasJSON

PPasJSONInt16

PasJSON

PPasJSONInt32

PasJSON

PPasJSONInt64

PasJSON

PPasJSONInt8

PasJSON

PPasJSONModeFlag

PasJSON

PPasJSONModeFlags

PasJSON

PPasJSONNativeInt

PasJSON

PPasJSONNativeUInt

PasJSON

PPasJSONPointer

PasJSON

PPasJSONPointers

PasJSON

PPasJSONPtrDiff

PasJSON

PPasJSONPtrInt

PasJSON

PPasJSONPtrUInt

PasJSON

PPasJSONRawByteChar

PasJSON

PPasJSONRawByteString

PasJSON

PPasJSONSize

PasJSON

PPasJSONSizeInt

PasJSON

PPasJSONSizeUInt

PasJSON

PPasJSONUInt16

PasJSON

PPasJSONUInt32

PasJSON

PPasJSONUInt64

PasJSON

PPasJSONUInt8

PasJSON

PPasJSONUInt8Array

PasJSON

PPasJSONUTF16Char

PasJSON

PPasJSONUTF16String

PasJSON

PPasJSONUTF8String

PasJSON

PPasJSONVoid

PasJSON

PPCharCG

Cg.Import

PPCUgraphicsResource

CUDA.Import

CUDA graphics interop resource

PPdObject

ODE.Import

PPdxGeom

ODE.Import

PPFXRegion

GLS.ParticleFX

PPHeightTileInfo

GLS.HeightTileFileHDS

PPivot

Formats.m3DSTypes

PPoint2DRec

GLScene.VectorTypesExt

PPoint3DRec

GLScene.VectorTypesExt

PPoint3DS

Formats.m3DSTypes

PPointArray

Formats.m3DSTypes

PPointer

Newton.Import

PPointerArray

GLScene.VectorGeometry

PPointerVector

GLScene.VectorGeometry

PPointFlagArray

Formats.m3DSTypes

PPointList

Formats.m3DSTypes

PPosTrackTag

Formats.m3DSTypes

PPPasJSONChar

PasJSON

PPPasJSONDouble

PasJSON

PPPasJSONFloat

PasJSON

PPPasJSONInt16

PasJSON

PPPasJSONInt32

PasJSON

PPPasJSONInt64

PasJSON

PPPasJSONInt8

PasJSON

PPPasJSONNativeInt

PasJSON

PPPasJSONNativeUInt

PasJSON

PPPasJSONPointer

PasJSON

PPPasJSONPointers

PasJSON

PPPasJSONPtrDiff

PasJSON

PPPasJSONPtrInt

PasJSON

PPPasJSONPtrUInt

PasJSON

PPPasJSONRawByteChar

PasJSON

PPPasJSONRawByteString

PasJSON

PPPasJSONSize

PasJSON

PPPasJSONSizeInt

PasJSON

PPPasJSONSizeUInt

PasJSON

PPPasJSONUInt16

PasJSON

PPPasJSONUInt32

PasJSON

PPPasJSONUInt64

PasJSON

PPPasJSONUInt8

PasJSON

PPPasJSONUInt8Array

PasJSON

PPPasJSONUTF16Char

PasJSON

PPPasJSONUTF16String

PasJSON

PPPasJSONUTF8String

PasJSON

PPPasJSONVoid

PasJSON

PProcName

Formats.m3DSTypes

PPSDL_Renderer

SDL.Import

** * A structure representing rendering state *

PPSDL_Window

SDL.Import

PPUInt8

SDL.Import

PQuaternion

GLScene.VectorGeometry

q = ([x, y, z], w)

PQuaternionArray

GLScene.VectorGeometry

PRayBias

Formats.m3DSTypes

PrecisionTimerLap

GLScene.Utils

Computes time elapsed since timer start. Return time lap in seconds.

PreferExternal

gnugettext

This is set to paramstr(0) or the name of the DLL you are creating.

PrepareSinCosCache

GLScene.VectorGeometry

Fills up the two given dynamic arrays with sin cos values. start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.

PRESCALE

Formats.m3DSConst

PRE_POST_CONSTANT

Formats.LWO

RESET

PRE_POST_LINEAR

Formats.LWO

OFFSET REPEAT

PRE_POST_OFFSET

Formats.LWO

OSCILLATE

PRE_POST_OSCILLATE

Formats.LWO

REPEAT

PRE_POST_REPEAT

Formats.LWO

CONSTANT

PRE_POST_RESET

Formats.LWO

SMOOTH GROUP

PRGBA32F

GLS.ImageUtils

PRIMARY_NODE

Formats.m3DSConst

draw node quickdraw style

PrimerIsland

GLS.RandomHDS

PrimerNull

GLS.RandomHDS

Landscape primers

PROAMTriangleNode

GLS.ROAMPatch

ProcNameStrMax3DS

Formats.m3DSConst

maximim string length for MshMatGroup PROC_NAME

PROC_DATA

Formats.m3DSConst

PROC_NAME

Formats.m3DSConst

Project

GLScene.VectorGeometry

PRollTrackTag

Formats.m3DSTypes

PRotTrackTag

Formats.m3DSTypes

PScaleTrackTag

Formats.m3DSTypes

PSceneObjectEntry

GLS.ObjectManager

PSDLPantalla

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// *** KTI *** //////////////////////////////////////////////// ///////////////////////////////////////////////////////////////////////////////////////////////////// SDLPantalla contiene la ventana SDL el Render donde se pinta y el zoom de los ejes X e Y

PSDL_AudioCVT

SDL.Import

PSDL_AudioSpec

SDL.Import

** * The calculated values in this structure are calculated by SDL_OpenAudio(). *

PSDL_BlendMode

SDL.Import

** * The blend mode used in SDL_RenderCopy() and drawing operations. *

PSDL_BlitMap

SDL.Import

** * A collection of pixels used in software blitting. * * This structure should be treated as read-only, except for \c pixels, * which, if not NULL, contains the raw pixel data for the surface. *

PSDL_Color

SDL.Import

PSDL_Colour

SDL.Import

PSDL_Cond

SDL.Import

* The SDL condition variable structure, defined in SDL_cond.c *

PSDL_Cursor

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_mouse.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

PSDL_DisplayMode

SDL.Import

** * The structure that defines a display mode * * SDL_GetNumDisplayModes() * SDL_GetDisplayMode() * SDL_GetDesktopDisplayMode() * SDL_GetCurrentDisplayMode() * SDL_GetClosestDisplayMode() * SDL_SetWindowDisplayMode() * SDL_GetWindowDisplayMode() *

PSDL_Event

SDL.Import

** * General event structure *

PSDL_EventFilter

SDL.Import

PSDL_Finger

SDL.Import

PSDL_FingerID

SDL.Import

PSDL_GameController

SDL.Import

* The gamecontroller structure used to identify an SDL game controller *

PSDL_Haptic

SDL.Import

** * SDL_Haptic * * The haptic structure used to identify an SDL haptic. * * SDL_HapticOpen * SDL_HapticOpenFromJoystick * SDL_HapticClose *

PSDL_HapticEffect

SDL.Import

** * The generic template for any haptic effect. * * All values max at 32767 (0x7FFF). Signed values also can be negative. * Time values unless specified otherwise are in milliseconds. * * You can also pass SDL_HAPTIC_INFINITY to length instead of a 0-32767 * value. Neither delay, interval, attack_length nor fade_length support * SDL_HAPTIC_INFINITY. Fade will also not be used since effect never ends. * * Additionally, the SDL_HAPTIC_RAMP effect does not support a duration of * SDL_HAPTIC_INFINITY. * * Button triggers may not be supported on all devices, it is advised to not * use them if possible. Buttons start at index 1 instead of index 0 like * the joystick. * * If both attack_length and fade_level are 0, the envelope is not used, * otherwise both values are used. * * Common parts: * * // Replay - All effects have this * Uint32 length; // Duration of effect (ms). * Uint16 delay; // Delay before starting effect. * * // Trigger - All effects have this * Uint16 button; // Button that triggers effect. * Uint16 interval; // How soon before effect can be triggered again. * * // Envelope - All effects except condition effects have this * Uint16 attack_length; // Duration of the attack (ms). * Uint16 attack_level; // Level at the start of the attack. * Uint16 fade_length; // Duration of the fade out (ms). * Uint16 fade_level; // Level at the end of the fade. * * * * Here we have an example of a constant effect evolution in time: * Strength ˆ | | effect level –> _________________ | / \ | / \ | / \ | / \ | attack_level –> | \ | | | <— fade_level | +————————————————–> Time [–] [—] attack_length fade_length
[——————][———————–] delay length
* * Note either the attack_level or the fade_level may be above the actual * effect level. * * SDL_HapticConstant * SDL_HapticPeriodic * SDL_HapticCondition * SDL_HapticRamp * SDL_HapticCustom *

PSDL_Joystick

SDL.Import

* The joystick structure used to identify an SDL joystick *

PSDL_KeyCode

SDL.Import

** * The SDL virtual key representation. * * Values of this type are used to represent keyboard keys using the current * layout of the keyboard. These values include Unicode values representing * the unmodified character that would be generated by pressing the key, or * an SDLK_* constant for those keys that do not generate characters. *

PSDL_KeyMod

SDL.Import

PSDL_Keysym

SDL.Import

** * The SDL keysym structure, used in key events. *

PSDL_MessageBoxButtonData

SDL.Import

** * Individual button data. *

PSDL_MessageBoxColor

SDL.Import

** * RGB value used in a message box color scheme *

PSDL_MessageBoxColorScheme

SDL.Import

** * A set of colors to use for message box dialogs *

PSDL_MessageBoxColorType

SDL.Import

PSDL_MessageBoxData

SDL.Import

** * MessageBox structure containing title, text, window, etc. *

PSDL_Mutex

SDL.Import

PSDL_Mutex = Pointer; //todo!

PSDL_Palette

SDL.Import

PSDL_PixelFormat

SDL.Import

** * Everything in the pixel format structure is read-only. *

PSDL_Point

SDL.Import

** * The structure that defines a point * * SDL_EnclosePoints *

PSDL_Rect

SDL.Import

** * A rectangle, with the origin at the upper left. * * SDL_RectEmpty * SDL_RectEquals * SDL_HasIntersection * SDL_IntersectRect * SDL_UnionRect * SDL_EnclosePoints *

PSDL_Renderer

SDL.Import

PSDL_RendererFlags

SDL.Import

**< The renderer supports rendering to texture *

PSDL_RendererFlip

SDL.Import

** * Flip constants for SDL_RenderCopyEx *

PSDL_RendererInfo

SDL.Import

** * Information on the capabilities of a render driver or context. *

PSDL_RWops

SDL.Import

* Read-Only memory stream *

PSDL_ScanCode

SDL.Import

**< not a key, just marks the number of scancodes for array bounds *

PSDL_Sem

SDL.Import

* The SDL semaphore structure, defined in SDL_sem.c *

PSDL_Surface

SDL.Import

PSDL_SystemCursor

SDL.Import

PSDL_SysWMEvent

SDL.Import

** * A video driver dependent system event (event.syswm.*) * This event is disabled by default, you can enable it with SDL_EventState() * * If you want to use this event, you should include SDL_syswm.h. *

PSDL_SysWMinfo

SDL.Import

The Windows custom window manager information structure

PSDL_SysWMmsg

SDL.Import

The windows custom event structure

PSDL_Texture

SDL.Import

** * An efficient driver-specific representation of pixel data *

PSDL_TextureAccess

SDL.Import

** * The access pattern allowed for a texture. *

PSDL_TextureModulate

SDL.Import

** * The texture channel modulation used in SDL_RenderCopy(). *

PSDL_Thread

SDL.Import

PSDL_Thread = Pointer;

PSDL_ThreadFunction

SDL.Import

* The function passed to SDL_CreateThread() It is passed a void* user context parameter and returns an int. *

PSDL_TouchID

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_touch.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

PSDL_Version

SDL.Import

** * Information the version of SDL in use. * * Represents the library's version as three levels: major revision * (increments with massive changes, additions, and enhancements), * minor revision (increments with backwards-compatible changes to the * major revision), and patchlevel (increments with fixes to the minor * revision). * * SDL_VERSION * SDL_GetVersion *

PSDL_Window

SDL.Import

PSDL_WindowShapeMode

SDL.Import

** A struct that tags the SDL_WindowShapeParams union with an enum describing the type of its contents. *

PSDL_WindowShaper

SDL.Import

* Define the SDL window-shaper structure *

PSDL_WindowUserData

SDL.Import

PShadowFilter

Formats.m3DSTypes

PShadowMapSize

Formats.m3DSTypes

PShadowRange

Formats.m3DSTypes

PShadowSamples

Formats.m3DSTypes

PShadowSets3DS

Formats.m3DSTypes

PShortInt

SDL.Import

PShortIntArray

GLS.HeightTileFileHDS

PSingleArray

GLScene.VectorGeometry

PSingleList

Formats.m3DSTypes

PSingleRaster

GLS.HeightData

PSInt16

SDL.Import

PSInt64

SDL.Import

PSInt8

SDL.Import

Psize_t

OpenCL.Platform

Psmallint

Newton.Import

PSmallIntArray

GLS.HeightData

PSmallIntArray

GLS.HeightTileFileHDS

PSmallIntRaster

GLS.HeightData

PSmoothGroup

Formats.m3DSTypes

PSoundFileFormat

GLS.SoundFileObjects

PSpotCone3DS

Formats.m3DSTypes

Cone visibility settings

PSpotLight3DS

Formats.m3DSTypes

spotlight settings

PSpotProjector3DS

Formats.m3DSTypes

spotlight projectio Bitmap

PSpotShadow3DS

Formats.m3DSTypes

Spotlight shadow settings

PSqrt255Array

GLScene.Utils

PTAG_APE_BINARY

BASS.Import

Binary APEv2 tag structure

PTAG_BEXT

BASS.Import

BWF "bext" tag structure

PTAG_ID3

BASS.Import

ID3v1 tag structure

PTAG_TYPE_PART

Formats.LWO

SURFACE

PTAG_TYPE_SMGP

Formats.LWO

PARENT PART

PTAG_TYPE_SURF

Formats.LWO

SPOT MAP: ABSOLUTE VERTEX POSITIONS

PTdJointFeedback

ODE.Import

PTexPoint

GLScene.VectorGeometry

PTexPointArray

GLScene.VectorGeometry

PTEXSChunk

Formats.B3D

PTextureReference

CUDA.Runtime

PTexVert3DS

Formats.m3DSTypes

PTexVertList

Formats.m3DSTypes

PTexVerts

Formats.m3DSTypes

PThorpoint

GLS.ThorFX

PThorpointArray

GLS.ThorFX

PTrackHeader3DS

Formats.m3DSTypes

PTriangleRecArray

GLScene.VectorTypesExt

PTRISChunk

Formats.B3D

PU1

Formats.LWO

PU2

Formats.LWO

PU2Array

Formats.LWO

PU4

Formats.LWO

PU4Array

Formats.LWO

PUInt16

SDL.Import

PUInt32

SDL.Import

PUInt8

SDL.Import

PUInt8Array

SDL.Import

PUnknown

Formats.VFW

PUserView3DS

Formats.m3DSTypes

PVec12

Formats.LWO

PVec12Array

Formats.LWO

PVector2f

GLScene.VectorGeometry

PVector4f

GLScene.VectorTypes

PVectorArray

GLScene.VectorGeometry

PVectorRec

GLScene.VectorTypesExt

PVertArray

GLScene.VectorTypesExt

PVertex

GLScene.VectorGeometry

PVertex2DArr

GLS.Isolines

PVertexData

Formats.B3D

PVGradient

Formats.m3DSTypes

PVGradientBgnd3DS

Formats.m3DSTypes

Color of Solid background

PVIDEOHDR

Formats.VFW

– Video data block header ————————————————–

PViewCamera

Formats.m3DSTypes

PViewport3DS

Formats.m3DSTypes

PViewportData

Formats.m3DSTypes

PViewportData3

Formats.m3DSTypes

PViewportLayout

Formats.m3DSTypes

PViewportSize

Formats.m3DSTypes

PViewSize3DS

Formats.m3DSTypes

PViewStandard

Formats.m3DSTypes

PViewUser

Formats.m3DSTypes

PVOID

Formats.VFW

*************************************************************************** * * types * **************************************************************************

PVoxelData

GLScene.VectorTypesExt

PVoxelRec

GLScene.VectorTypesExt

PVRTSChunk

Formats.B3D

PWGLSwap

GLScene.OpenGL4

PWGLswap

GLScene.OpenGLTokens

========= Windows types ==============

PWordList

Formats.m3DSTypes

PWordVector

GLScene.VectorGeometry

PXDataAppName

Formats.m3DSTypes

PXDataDouble

Formats.m3DSTypes

PXDataEntry

Formats.m3DSTypes

PXDataFloat

Formats.m3DSTypes

PXDataLong

Formats.m3DSTypes

PXDataRaw3DS

Formats.m3DSTypes

PXDataShort

Formats.m3DSTypes

PXDataString

Formats.m3DSTypes

PXDataVoid

Formats.m3DSTypes

PZArray

GLS.zBuffer

P_ALPHANEG

Formats.m3DSConst

P_ALPH_ALPHA

Formats.m3DSConst

P_ALPH_BLUR

Formats.m3DSConst

Old Chunk

P_ALPH_C0

Formats.m3DSConst

P_ALPH_CUTOFF

Formats.m3DSConst

P_ALPH_IMAGE

Formats.m3DSConst

P_ALPH_KCOL

Formats.m3DSConst

P_ALPH_NONE

Formats.m3DSConst

P_ALPH_OP_KEY

Formats.m3DSConst

P_ALPH_OP_NOCONV

Formats.m3DSConst

P_ALPH_OP_PSEUDO

Formats.m3DSConst

Old Chunk

P_ALPH_PCOL

Formats.m3DSConst

Replaces pseudo

P_ALPH_PSEUDO

Formats.m3DSConst

P_ALPH_QUEIMG

Formats.m3DSConst

P_ALPH_QUES

Formats.m3DSConst

P_CUSTOM_SIZE

Formats.m3DSConst

P_PROC_DATA

Formats.m3DSConst

P_QUEUE_ALIGN

Formats.m3DSConst

P_QUEUE_ENTRY

Formats.m3DSConst

P_QUEUE_GRADIENT

Formats.m3DSConst

P_QUEUE_IMAGE

Formats.m3DSConst

P_QUEUE_KF

Formats.m3DSConst

P_QUEUE_MB_REPEAT

Formats.m3DSConst

P_QUEUE_MOTBLUR

Formats.m3DSConst

P_QUEUE_NONE

Formats.m3DSConst

P_QUEUE_OFFSET

Formats.m3DSConst

P_QUEUE_PROC

Formats.m3DSConst

P_QUEUE_RESIZE

Formats.m3DSConst

P_QUEUE_SOLID

Formats.m3DSConst

P_QUEUE_USEIGAMMA

Formats.m3DSConst

P_RANGES

Formats.m3DSConst

P_TRANNEG

Formats.m3DSConst

P_TRAN_FADEIN

Formats.m3DSConst

P_TRAN_FADEOUT

Formats.m3DSConst

P_TRAN_FRAMES

Formats.m3DSConst

P_TRAN_IMAGE

Formats.m3DSConst

P_TRAN_NONE

Formats.m3DSConst

QuaternionConjugate

GLScene.VectorGeometry

Returns the conjugate of a quaternion

QuaternionFromAngleAxis

GLScene.VectorGeometry

Constructs quaternion from angle (in deg) and axis

QuaternionFromEuler

GLScene.VectorGeometry

Constructs quaternion from Euler angles in arbitrary order (angles in degrees)

QuaternionFromMatrix

GLScene.VectorGeometry

Constructs a unit quaternion from a rotation matrix

QuaternionFromPoints

GLScene.VectorGeometry

Constructs a unit quaternion from two points on unit sphere

QuaternionFromRollPitchYaw

GLScene.VectorGeometry

Constructs quaternion from Euler angles

QuaternionMagnitude

GLScene.VectorGeometry

Returns the magnitude of the quaternion

QuaternionMake

GLScene.VectorGeometry

QuaternionMake

GLScene.VectorGeometry

QuaternionMake

GLScene.VectorGeometry

Creates a quaternion from the given values

QuaternionMultiply

GLScene.VectorGeometry

Returns quaternion product qL * qR. Note: order is important! To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond

QuaternionSlerp

GLScene.VectorGeometry

QuaternionSlerp

GLScene.VectorGeometry

Spherical linear interpolation of unit quaternions with spins. QStart, QEnd - start and end unit quaternions t - interpolation parameter (0 to 1) Spin - number of extra spin rotations to involve

QuaternionToAffineMatrix

GLScene.VectorGeometry

Constructs an affine rotation matrix from (possibly non-unit) quaternion

QuaternionToMatrix

GLScene.VectorGeometry

Constructs a rotation matrix from (possibly non-unit) quaternion. Assumes matrix is used to multiply column vector on the left: vnew = mat vold. Works correctly for right-handed coordinate system and right-handed rotations

QuaternionToPoints

GLScene.VectorGeometry

Converts a unit quaternion into two points on a unit sphere

QueryPerformanceCounter

GLScene.Utils

Returns the current value of the highest-resolution counter. If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.

QueryPerformanceFrequency

GLScene.Utils

Returns the frequency of the counter used by QueryPerformanceCounter. Return value is in ticks per second (Hz), returns False if no precision counter is available.

QuestionDlg

GLS.ImageUtils

Pops up a simple question dialog with msg and yes/no buttons. Returns True if answer was "yes".

QWORD

BASS.Import

QW_ERROR

BASS.Import

-1 (DWORD)

RadianToDeg

GLScene.VectorGeometry

RadianToDeg

GLScene.VectorGeometry

RaiseLastOSError

GLScene.Utils

RaiseOpenGLError

GLScene.OpenGL4

Clears all pending OpenGL errors

RandEmpiric

GLScene.RandomLib

Random Number for Empiricle Distribution X[I] - middle of I-interval Fx[I] - cummulative empiricle distribution with values in [0..1]

RandExponent

GLScene.RandomLib

RandGauss

GLScene.RandomLib

Marsaglia-Bray algorithm

RandLogNorm

GLScene.RandomLib

RandNorm

GLScene.RandomLib

RandomColorVector

GLS.ODEUtils

RandomPointOnSphere

GLScene.VectorGeometry

Generates a random point on the unit sphere. Point repartition is correctly isotropic with no privilegied direction

Random_Beta

GLScene.RandomLib

Random_Beta

GLScene.RandomLib

Generates a random variate in [0,1] FROM A BETA DISTRIBUTION WITH DENSITY PROPORTIONAL TO BETA**(AA-1) * (1-BETA)**(BB-1). USING CHENG'S LOG LOGISTIC METHOD. AA = Shape PARAMETER FROM DISTRIBUTION (0 < REAL) BB = Shape PARAMETER FROM DISTRIBUTION (0 < REAL)

Random_Binomial1

GLScene.RandomLib

Random_Binomial1

GLScene.RandomLib

GENERATES A RANDOM BINOMIAL VARIATE USING C.D.Kemp's method. This algorithm is suitable when many random variates are required with the SAME parameter values for n & p. P = Bernoulli SUCCESS PROBABILITY (0 <= REAL <= 1) N = Number of Bernoulli trials (1 <= INTEGER) Reference: Kemp, C.D. (1986). `A modal method for generating binomial variables', Commun. Statist. - Theor. Meth. 15(3), 805-813.

Random_Binomial2

GLScene.RandomLib

FIRST –> Set FIRST = .TRUE. for the first call to perform initialization the set FIRST = .FALSE. for further calls using the same pair of parameter values (N, P). LOGICAL FIRST random_binomial2 <– A random deviate yielding the number of events from N independent trials, each of which has a probability of event P. INTEGER –> random_binomial Method: This is algorithm BTPE from: Kachitvichyanukul, V. and Schmeiser, B. W. Binomial Random Variate Generation. Communications of the ACM, 31, 2 (February, 1988) 216.

Random_Binomial2

GLScene.RandomLib

Generates a single random deviate from a binomial distribution whose number of trials is N and whose probability of an event in each trial is P.
Arguments N –> The number of trials in the binomial distribution from which a random deviate is to be generated. INTEGER N P –> The probability of an event in each trial of the binomial distribution from which a random deviate is to be generated. REAL P

Random_Cauchy

GLScene.RandomLib

Random_Cauchy

GLScene.RandomLib

Generate a random deviate from the standard Cauchy distribution

Random_ChiSq

GLScene.RandomLib

Random_ChiSq

GLScene.RandomLib

Generates a random variate from the chi-squared distribution with dff degrees of freedom.

Random_Exponential

GLScene.RandomLib

Random_Exponential

GLScene.RandomLib

Generates a random variate in [0,INFINITY) FROM A NEGATIVE EXPONENTIAL DlSTRIBUTION WlTH DENSITY PROPORTIONAL TO EXP(-random_exponential), USING INVERSION.

Random_Gamma

GLScene.RandomLib

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL)

Random_Gamma

GLScene.RandomLib

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL).

Random_Gamma1

GLScene.RandomLib

Uses the algorithm in Marsaglia, G. and Tsang, W.W. (2000) 'A simple method for generating gamma variables', Trans. om Math. Software (TOMS), vol.26(3), pp.363-372. Generates a random gamma deviate for shape parameter Shape >= 1.

Random_Inv_Gauss

GLScene.RandomLib

Random_Inv_Gauss

GLScene.RandomLib

Generates a random variate in [0,INFINITY] FROM A REPARAMETERISED GENERALISED INVERSE GAUSSIAN (GIG) DISTRIBUTION WITH DENSITY PROPORTIONAL TO GIG**(H-1) * EXP(-0.5*B*(GIG+1/GIG)) USING A RATIO METHOD.
h = PARAMETER OF DISTRIBUTION (0 <= REAL) b = PARAMETER OF DISTRIBUTION (0 < REAL)

Random_LogNormal

GLScene.RandomLib

Adapted from approach suggested by Greg Hood, used with Permission.

Random_LogNormal

GLScene.RandomLib

Adapted from approach suggested by Greg Hood, used with Permission.

Random_MVNorm

GLScene.RandomLib

Random_MVNorm

GLScene.RandomLib

GENERATES AN N VARIATE RANDOM NORMAL Vector USING A CHOLESKY DECOMPOSITION.
ARGUMENTS: N = NUMBER OF VARIATES IN Vector (INPUT,INTEGER >= 1) H(J) = J'TH ELEMENT OF Vector OF MEANS (INPUT,REAL) X(J) = J'TH ELEMENT OF DELIVERED Vector (OUTPUT,REAL)
D(J*(J-1)/2+I) = (I,J)'TH ELEMENT OF VARIANCE MATRIX (J> = I) (INPUT,REAL) F((J-1)*(2*N-J)/2+I) = (I,J)'TH ELEMENT OF LOWER TRIANGULAR DECOMPOSITION OF VARIANCE MATRIX (J <= I) (OUTPUT,REAL) ier = 1 if the input covariance matrix is not +ve definite = 0 otherwise

Random_Neg_Binomial

GLScene.RandomLib

Random_Neg_Binomial

GLScene.RandomLib

GENERATES A RANDOM NEGATIVE BINOMIAL VARIATE USING UNSTORED INVERSION AND/OR THE REPRODUCTIVE PROPERTY. SK = NUMBER OF FAILURES REQUIRED (Dagpunar's words!) = the `power' parameter of the negative binomial (0 < REAL) P = BERNOULLI SUCCESS PROBABILITY (0 < REAL < 1) THE PARAMETER H IS SET SO THAT UNSTORED INVERSION ONLY IS USED WHEN P <= H, OTHERWISE A COMBINATION OF UNSTORED INVERSION AND THE REPRODUCTIVE PROPERTY IS USED.

Random_Normal

GLScene.RandomLib

Random_Normal

GLScene.RandomLib

Random_Normal

GLScene.RandomLib

Adapted from COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. Returns a normally distributed pseudo-random number with zero mean and unit variance. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves

Random_Normal

GLScene.RandomLib

Adapted from the following Fortran 77 code ALGORITHM 712, COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves Returns a normally distributed pseudo-random number with zero mean and unit variance

Random_Poisson

GLScene.RandomLib

Random_Poisson

GLScene.RandomLib

Generates a single random deviate from a Poisson distribution with mean mu. Arguments: mu –> The mean of the Poisson distribution from which a random deviate is to be generated. REAL mu Method: For details see Ahrens, J.H. and Dieter, U. Computer Generation of Poisson Deviates From Modified Normal Distributions. ACM Trans. Math. Software, 8, 2 (June 1982),163-179
TABLES: COEFFICIENTS A0-A7 FOR STEP F. FACTORIALS FACT COEFFICIENTS A(K) - FOR PX = FK*V*V*SUM(A(K)*V**K)-DEL

Random_T

GLScene.RandomLib

Random_T

GLScene.RandomLib

Generates a random variate FROM A T DISTRIBUTION USING KINDERMAN AND MONAHAN'S RATIO METHOD. DF = DEGREES OF FREEDOM OF DISTRIBUTION (DF >= 1)

Random_von_Mises

GLScene.RandomLib

Random_von_Mises

GLScene.RandomLib

Algorithm VMD Arguments: k (real) - parameter of the von Mises distribution.

Random_Weibull

GLScene.RandomLib

Random_Weibull

GLScene.RandomLib

Generates a random variate from the Weibull distribution with probability density: a a-1 -x f(x) = a.x e

RandUniform

GLScene.RandomLib

RandUniform

GLScene.RandomLib

Uniform Random single numbers in RLow..RHigh range

RasterFileFormatExtensionByIndex

GLS.Graphics

Returns an extension by its index in the internal image files dialogs filter. Use InternalImageFileFormatsFilter to obtain the filter.

RawByteString

gnugettext

RawUtf8String

gnugettext

RayCastAABBIntersect

GLScene.GeometryBB

RayCastAABBIntersect

GLScene.GeometryBB

Finds the intersection between a ray and an axis aligned bounding box.

RayCastBoxIntersect

GLScene.VectorGeometry

Compute intersection between a ray and a box. Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil

RayCastIntersectsSphere

GLScene.VectorGeometry

Determines if a ray will intersect with a given sphere

RayCastMinDistToPoint

GLScene.VectorGeometry

Compute the min distance a ray will pass to a point

RayCastPlaneIntersect

GLScene.VectorGeometry

Compute intersection between a ray and a plane. Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil

RayCastPlaneXZIntersect

GLScene.VectorGeometry

RayCastSphereIntersect

GLScene.VectorGeometry

Calculates the intersections between a sphere and a ray. Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined)

RayCastTriangleIntersect

GLScene.VectorGeometry

Compute intersection between a ray and a triangle

RAY_BIAS

Formats.m3DSConst

ReadCRLFString

GLScene.Utils

Read a CRLF terminated string from a stream. The CRLF is NOT in the returned string.

ReadExtensions

GLScene.OpenGL4

ReadImplementationProperties

GLScene.OpenGL4

ReadLine

GLScene.Logger

ReadModuleData

ModuleLoader

ReadMotorolaNumber

Formats.LWO

ReadOpenALExtensions

OpenAL.Import

ReadS0

Formats.LWO

ReadScreenImage

GLS.Screen

ReadVideoModes

GLS.Screen

ReadVXAsU4

Formats.LWO

ReadWGLExtensions

GLScene.OpenGL4

ReadWGLImplementationProperties

GLScene.OpenGL4

RECORDPROC

BASS.Import

DSP callback function. NOTE: A DSP function should obviously be as quick as possible... other DSP functions, streams and MOD musics can not be processed until it's finished. handle : The DSP handle channel: Channel that the DSP is being applied to buffer : Buffer to apply the DSP to length : Number of bytes in the buffer user : The 'user' parameter given when calling BASS_ChannelSetDSP

RectangleContains

GLScene.VectorGeometry

Determine if BigRect completely contains SmallRect

RectanglesIntersect

GLScene.VectorGeometry

Determine if 2 rectanges intersect

RectEquals

GLScene.VectorGeometry

True if all components are equal.

Register

GLS.CgRegister

using TGLLibMaterialNameProperty

Register

GLS.CUDA.Register

Register

GLS.FullScreenViewer

Register

GLS.Physics.Register

Register

GLS.Pythons.Script

Register

GLS.SceneRegister

Register Components

Register

GLS.SDL.Context

Register

GLS.SDL.Window

function getenv(const name: PAnsiChar): PAnsiChar;

Register

GLS.Sounds.Register

Register

GLS.XCollectionRegister

RegisterArchiveFormat

GLS.ArchiveManager

RegisterChunkClass

Formats.LWO

RegisterCUDAComponentNameChangeEvent

GLS.CUDA.APIComps

RegisterGLBaseSceneObjectNameChangeEvent

GLS.Scene

Register an event handler triggered by any TGLBaseSceneObject Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by GLSceneEdit in the IDE.

RegisterGLBehaviourNameChangeEvent

GLS.Scene

Register an event handler triggered by any TGLBehaviour Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.

RegisterGLContextClass

GLS.Context

Drivers should register themselves via this function.

RegisterGLMaterialExNameChangeEvent

GLS.MaterialEx

RegisterGLSceneObject

GLS.ODEManager

GLODEObject register methods (used for joint object persistence)

RegisterGLTextureImageClass

GLS.Texture

Register a TGLTextureImageClass (used for persistence and IDE purposes)

RegisterGLTextureImageEditor

GLS.TextureImageEditors

RegisterInfoForm

GLS.Scene

Registers the procedure call used to invoke the info form.

RegisterManager

GLScene.Manager

RegisterRasterFormat

GLS.Graphics

RegisterSoundFileFormat

GLS.SoundFileObjects

RegisterTGraphicClassFileExtension

GLS.Texture

RegisterUniformAutoSetMethod

GLSL.ShaderParameter

RegisterVectorFileFormat

GLS.VectorFileObjects

RegisterXCollectionDestroyEvent

GLScene.XCollection

Registers an event to be called when an XCollection is destroyed

RegisterXCollectionItemClass

GLScene.XCollection

Registers a TXCollectionItem subclass for persistence requirements

RelAll3DS

Formats.m3DSConst

RelativePath

GLScene.Utils

Remove if possible part of path witch leads to project executable.

ReleaseAmbientLightMotion

Formats.m3DSUtils

ReleaseCamera

Formats.m3DSUtils

ReleaseCameraMotion

Formats.m3DSUtils

ReleaseChunk

Formats.m3DSUtils

ReleaseChunkList

Formats.m3DSUtils

ReleaseFontManager

GLS.SpaceText

ReleaseGLCUDAEditorForm

FmCUDAEditor

ReleaseGLSceneEditorForm

FmSceneEditor

ReleaseGLShaderEditor

FmShaderMemo

ReleaseGUILayoutEditorForm

FmGuiLayoutEditor

ReleaseLibMaterialPickerForm

FmLibMaterialPicker

ReleaseLight

Formats.m3DSUtils

ReleaseMaterial

Formats.m3DSUtils

ReleaseMaterialEditorForm

FmMaterialEditor

ReleaseMeshObj

Formats.m3DSUtils

ReleaseNx

PhysX.Import

ReleaseObjectMotion

Formats.m3DSUtils

ReleaseOmnilightMotion

Formats.m3DSUtils

ReleaseShaderUniformEditor

FmShaderUniformEditor

ReleaseSpotlightMotion

Formats.m3DSUtils

ReleaseVectorEditorForm

FmVectorEditor

ReleaseXCollectionEditor

FmXCollectionEditor

Release_Memory_Isoline

GLS.Isolines

RelFaceArray3ds

Formats.m3DSConst

RelMatArray3ds

Formats.m3DSConst

RelProcData3ds

Formats.m3DSConst

RelSmoothArray3ds

Formats.m3DSConst

RelTextArray3ds

Formats.m3DSConst

RelVertexArray3ds

Formats.m3DSConst

field codes for RelMeshObjField3ds

RelVFlagArray3ds

Formats.m3DSConst

RemapAndCleanupReferences

GLS.MeshUtils

Alters a reference/indice pair and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.

remapIndices

GLS.MeshUtils

Remaps a list of indices. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

RemapIndicesToIndicesMap

GLS.MeshUtils

Creates an indices map from a remap list. The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear? In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices. Any simpler documentation of this function welcome ;)

RemapReferences

GLS.MeshUtils

RemapReferences

GLS.MeshUtils

Alters a reference array and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.

RemapTrianglesIndices

GLS.MeshUtils

Remaps a list of triangles vertex indices and remove degenerate triangles. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

RemoveDomainForComponent

gnugettext

RemoveDomainForResourceString

gnugettext

RenderAABB

GLS.SpacePartition

RenderAABB

GLS.SpacePartition

Renders an AABB as a line

RenderGeomList

GLS.ODEUtils

RenderSpatialPartitioning

GLS.SpacePartition

Render a spacial partitioning descending from TGLSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation

ReReadMoFileOnSameLanguage

gnugettext

Set to False, to use the mo-file as independent copy in memory (you can update the file while it is in use)

RescaleImage

GLS.ImageUtils

RestoreDefaultMode

GLS.Screen

RetranslateComponent

gnugettext

ReverseByteOrder

Formats.LWO

RFOP_BACKDROP

Formats.LWO

RFOP_RAYTRACEANDBACKDROP

Formats.LWO

RFOP_RAYTRACEANDSPHERICALMAP

Formats.LWO

RFOP_SPHERICALMAP

Formats.LWO

RGB24ToRGBA32

GLS.Graphics

RGBA_SIGNED_COMPONENTS_EXT

GLScene.OpenGL4

Rgbe2float

GLScene.RGBE

RLength

GLScene.VectorGeometry

Computes 1/Sqrt(Sqr(x)+Sqr(y)).

Roll

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its Z-axis

Roll

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterDirection

ROLL_TRACK_TAG

Formats.m3DSConst

ROLL_TRACK_TAG_KEY

Formats.m3DSConst

RotateVector

GLScene.VectorGeometry

Rotates Vector about Axis with Angle radians

RotateVector

GLScene.VectorGeometry

Rotates Vector about Axis with Angle radians

RotateVectorAroundY

GLScene.VectorGeometry

Rotate given vector around the Y axis (alpha is in rad)

ROT_TRACK_TAG

Formats.m3DSConst

ROT_TRACK_TAG_KEY

Formats.m3DSConst

RoundDownToPowerOf2

GLScene.Utils

Round down to the nearest power of two, value must be strictly positive

RoundInt

GLScene.VectorGeometry

RoundInt

GLScene.VectorGeometry

Rounds the floating point value to the closest integer. Behaves like Round but returns a floating point value like Int.

RoundUpToPowerOf2

GLScene.Utils

Round ups to the nearest power of two, value must be positive

RSqrt

GLScene.VectorGeometry

—————————————————————————— Miscellanious math functions —————————————————————————— Computes 1/Sqrt(v)

RstVector

GLScene.VectorGeometry

RstVector

GLScene.VectorGeometry

RW_SEEK_CUR

SDL.Import

**< Seek from the beginning of data *

RW_SEEK_END

SDL.Import

**< Seek relative to current read point *

RW_SEEK_SET

SDL.Import

RyuDoubleToString

PasDblStrUtils

RyuStringToDouble

PasDblStrUtils

RyuStringToDouble

PasDblStrUtils

SafeCurrentGLContext

GLS.Context

SaveAnsiStringToFile

GLScene.Utils

Saves ansistring "data" to "filename".

SaveComponentToFile

GLScene.Utils

Saves component to a file.

SavePictureDialog

GLS.ImageUtils

Pops up a simple save picture dialog.

SaveSDLBMPToStream

SDL.Import

SaveStringToFile

GLScene.Utils

Saves string "data" to "filename".

ScaleAndRound

GLScene.VectorGeometry

Multiples i by s and returns the rounded result.

ScaleFloatArray

GLScene.VectorGeometry

ScaleFloatArray

GLScene.VectorGeometry

Multiplies values in the array by factor. This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items. Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available

ScaleMatrix

GLScene.VectorGeometry

Multiplies all elements of a 3x3 matrix with a factor

ScaleMatrix

GLScene.VectorGeometry

Multiplies all elements of a 4x4 matrix with a factor

ScaleVector

GLScene.VectorGeometry

Scales given vector by a factor

ScaleVector

GLScene.VectorGeometry

Scales given vector by a factor

ScaleVector

GLScene.VectorGeometry

Scales given vector by a factor

ScaleVector

GLScene.VectorGeometry

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

ScaleVector

GLScene.VectorGeometry

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

SCENE_SELECTED

FmSceneEditor

SCL_TRACK_TAG

Formats.m3DSConst

SCL_TRACK_TAG_KEY

Formats.m3DSConst

SDK_Version

PhysX.Import

SDLK_0

SDL.Import

SDLK_1

SDL.Import

SDLK_2

SDL.Import

SDLK_3

SDL.Import

SDLK_4

SDL.Import

SDLK_5

SDL.Import

SDLK_6

SDL.Import

SDLK_7

SDL.Import

SDLK_8

SDL.Import

SDLK_9

SDL.Import

SDLK_a

SDL.Import

SDLK_AC_BACK

SDL.Import

SDLK_AC_BOOKMARKS

SDL.Import

SDLK_AC_FORWARD

SDL.Import

SDLK_AC_HOME

SDL.Import

SDLK_AC_REFRESH

SDL.Import

SDLK_AC_SEARCH

SDL.Import

SDLK_AC_STOP

SDL.Import

SDLK_AGAIN

SDL.Import

SDLK_ALTERASE

SDL.Import

SDLK_AMPERSAND

SDL.Import

SDLK_APPLICATION

SDL.Import

SDLK_ASTERISK

SDL.Import

SDLK_AT

SDL.Import

SDLK_AUDIOMUTE

SDL.Import

SDLK_AUDIONEXT

SDL.Import

SDLK_AUDIOPLAY

SDL.Import

SDLK_AUDIOPREV

SDL.Import

SDLK_AUDIOSTOP

SDL.Import

SDLK_b

SDL.Import

SDLK_BACKQUOTE

SDL.Import

SDLK_BACKSLASH

SDL.Import

SDLK_BACKSPACE

SDL.Import

SDLK_BRIGHTNESSDOWN

SDL.Import

SDLK_BRIGHTNESSUP

SDL.Import

SDLK_c

SDL.Import

SDLK_CALCULATOR

SDL.Import

SDLK_CANCEL

SDL.Import

SDLK_CAPSLOCK

SDL.Import

SDLK_CARET

SDL.Import

SDLK_CLEAR

SDL.Import

SDLK_CLEARAGAIN

SDL.Import

SDLK_COLON

SDL.Import

SDLK_COMMA

SDL.Import

SDLK_COMPUTER

SDL.Import

SDLK_COPY

SDL.Import

SDLK_CRSEL

SDL.Import

SDLK_CURRENCYSUBUNIT

SDL.Import

SDLK_CURRENCYUNIT

SDL.Import

SDLK_CUT

SDL.Import

SDLK_d

SDL.Import

SDLK_DECIMALSEPARATOR

SDL.Import

SDLK_DELETE

SDL.Import

SDLK_DISPLAYSWITCH

SDL.Import

SDLK_DOLLAR

SDL.Import

SDLK_DOWN

SDL.Import

SDLK_e

SDL.Import

SDLK_EJECT

SDL.Import

SDLK_END

SDL.Import

SDLK_EQUALS

SDL.Import

SDLK_ESCAPE

SDL.Import

SDLK_EXCLAIM

SDL.Import

SDLK_EXECUTE

SDL.Import

SDLK_EXSEL

SDL.Import

SDLK_f

SDL.Import

SDLK_F1

SDL.Import

SDLK_F10

SDL.Import

SDLK_F11

SDL.Import

SDLK_F12

SDL.Import

SDLK_F13

SDL.Import

SDLK_F14

SDL.Import

SDLK_F15

SDL.Import

SDLK_F16

SDL.Import

SDLK_F17

SDL.Import

SDLK_F18

SDL.Import

SDLK_F19

SDL.Import

SDLK_F2

SDL.Import

SDLK_F20

SDL.Import

SDLK_F21

SDL.Import

SDLK_F22

SDL.Import

SDLK_F23

SDL.Import

SDLK_F24

SDL.Import

SDLK_F3

SDL.Import

SDLK_F4

SDL.Import

SDLK_F5

SDL.Import

SDLK_F6

SDL.Import

SDLK_F7

SDL.Import

SDLK_F8

SDL.Import

SDLK_F9

SDL.Import

SDLK_FIND

SDL.Import

SDLK_g

SDL.Import

SDLK_GREATER

SDL.Import

SDLK_h

SDL.Import

SDLK_HASH

SDL.Import

SDLK_HELP

SDL.Import

SDLK_HOME

SDL.Import

SDLK_i

SDL.Import

SDLK_INSERT

SDL.Import

SDLK_j

SDL.Import

SDLK_k

SDL.Import

SDLK_KBDILLUMDOWN

SDL.Import

SDLK_KBDILLUMTOGGLE

SDL.Import

SDLK_KBDILLUMUP

SDL.Import

SDLK_KP_0

SDL.Import

SDLK_KP_00

SDL.Import

SDLK_KP_000

SDL.Import

SDLK_KP_1

SDL.Import

SDLK_KP_2

SDL.Import

SDLK_KP_3

SDL.Import

SDLK_KP_4

SDL.Import

SDLK_KP_5

SDL.Import

SDLK_KP_6

SDL.Import

SDLK_KP_7

SDL.Import

SDLK_KP_8

SDL.Import

SDLK_KP_9

SDL.Import

SDLK_KP_A

SDL.Import

SDLK_KP_AMPERSAND

SDL.Import

SDLK_KP_AT

SDL.Import

SDLK_KP_B

SDL.Import

SDLK_KP_BACKSPACE

SDL.Import

SDLK_KP_BINARY

SDL.Import

SDLK_KP_C

SDL.Import

SDLK_KP_CLEAR

SDL.Import

SDLK_KP_CLEARENTRY

SDL.Import

SDLK_KP_COLON

SDL.Import

SDLK_KP_COMMA

SDL.Import

SDLK_KP_D

SDL.Import

SDLK_KP_DBLAMPERSAND

SDL.Import

SDLK_KP_DBLVERTICALBAR

SDL.Import

SDLK_KP_DECIMAL

SDL.Import

SDLK_KP_DIVIDE

SDL.Import

SDLK_KP_E

SDL.Import

SDLK_KP_ENTER

SDL.Import

SDLK_KP_EQUALS

SDL.Import

SDLK_KP_EQUALSAS400

SDL.Import

SDLK_KP_EXCLAM

SDL.Import

SDLK_KP_F

SDL.Import

SDLK_KP_GREATER

SDL.Import

SDLK_KP_HASH

SDL.Import

SDLK_KP_HEXADECIMAL

SDL.Import

SDLK_KP_LEFTBRACE

SDL.Import

SDLK_KP_LEFTPAREN

SDL.Import

SDLK_KP_LESS

SDL.Import

SDLK_KP_MEMADD

SDL.Import

SDLK_KP_MEMCLEAR

SDL.Import

SDLK_KP_MEMDIVIDE

SDL.Import

SDLK_KP_MEMMULTIPLY

SDL.Import

SDLK_KP_MEMRECALL

SDL.Import

SDLK_KP_MEMSTORE

SDL.Import

SDLK_KP_MEMSUBTRACT

SDL.Import

SDLK_KP_MINUS

SDL.Import

SDLK_KP_MULTIPLY

SDL.Import

SDLK_KP_OCTAL

SDL.Import

SDLK_KP_PERCENT

SDL.Import

SDLK_KP_PERIOD

SDL.Import

SDLK_KP_PLUS

SDL.Import

SDLK_KP_PLUSMINUS

SDL.Import

SDLK_KP_POWER

SDL.Import

SDLK_KP_RIGHTBRACE

SDL.Import

SDLK_KP_RIGHTPAREN

SDL.Import

SDLK_KP_SPACE

SDL.Import

SDLK_KP_TAB

SDL.Import

SDLK_KP_VERTICALBAR

SDL.Import

SDLK_KP_XOR

SDL.Import

SDLK_l

SDL.Import

SDLK_LALT

SDL.Import

SDLK_LCTRL

SDL.Import

SDLK_LEFT

SDL.Import

SDLK_LEFTBRACKET

SDL.Import

* Skip uppercase letters *

SDLK_LEFTPAREN

SDL.Import

SDLK_LESS

SDL.Import

SDLK_LGUI

SDL.Import

SDLK_LSHIFT

SDL.Import

SDLK_m

SDL.Import

SDLK_MAIL

SDL.Import

SDLK_MEDIASELECT

SDL.Import

SDLK_MENU

SDL.Import

SDLK_MINUS

SDL.Import

SDLK_MODE

SDL.Import

SDLK_MUTE

SDL.Import

SDLK_n

SDL.Import

SDLK_NUMLOCKCLEAR

SDL.Import

SDLK_o

SDL.Import

SDLK_OPER

SDL.Import

SDLK_OUT

SDL.Import

SDLK_p

SDL.Import

SDLK_PAGEDOWN

SDL.Import

SDLK_PAGEUP

SDL.Import

SDLK_PASTE

SDL.Import

SDLK_PAUSE

SDL.Import

SDLK_PERCENT

SDL.Import

SDLK_PERIOD

SDL.Import

SDLK_PLUS

SDL.Import

SDLK_POWER

SDL.Import

SDLK_PRINTSCREEN

SDL.Import

SDLK_PRIOR

SDL.Import

SDLK_q

SDL.Import

SDLK_QUESTION

SDL.Import

SDLK_QUOTE

SDL.Import

SDLK_QUOTEDBL

SDL.Import

SDLK_r

SDL.Import

SDLK_RALT

SDL.Import

SDLK_RCTRL

SDL.Import

SDLK_RETURN

SDL.Import

SDLK_RETURN2

SDL.Import

SDLK_RGUI

SDL.Import

SDLK_RIGHT

SDL.Import

SDLK_RIGHTBRACKET

SDL.Import

SDLK_RIGHTPAREN

SDL.Import

SDLK_RSHIFT

SDL.Import

SDLK_s

SDL.Import

SDLK_SCANCODE_MASK

SDL.Import

SDLK_SCROLLLOCK

SDL.Import

SDLK_SELECT

SDL.Import

SDLK_SEMICOLON

SDL.Import

SDLK_SEPARATOR

SDL.Import

SDLK_SLASH

SDL.Import

SDLK_SLEEP

SDL.Import

SDLK_SPACE

SDL.Import

SDLK_STOP

SDL.Import

SDLK_SYSREQ

SDL.Import

SDLK_t

SDL.Import

SDLK_TAB

SDL.Import

SDLK_THOUSANDSSEPARATOR

SDL.Import

SDLK_u

SDL.Import

SDLK_UNDERSCORE

SDL.Import

SDLK_UNDO

SDL.Import

SDLK_UNKNOWN

SDL.Import

SDLK_UP

SDL.Import

SDLK_v

SDL.Import

SDLK_VOLUMEDOWN

SDL.Import

SDLK_VOLUMEUP

SDL.Import

SDLK_w

SDL.Import

SDLK_WWW

SDL.Import

SDLK_x

SDL.Import

SDLK_y

SDL.Import

SDLK_z

SDL.Import

SDLStreamCloseRWops

SDL.Import

SDLStreamSetup

SDL.Import

SDL_ADDEVENT

SDL.Import

SDL_AddEventWatch

SDL.Import

** * Add a function which is called when an event is added to the queue. *

SDL_AddHintCallback

SDL.Import

SDL_AddTimer

SDL.Import

** * Add a new timer to the pool of timers already running. * * A timer ID, or NULL when an error occurs. *

SDL_AllocFormat

SDL.Import

** * Create an SDL_PixelFormat structure from a pixel format enum. *

SDL_AllocPalette

SDL.Import

** * Create a palette structure with the specified number of color * entries. * * A new palette, or nil if there wasn't enough memory. * * The palette entries are initialized to white. * * SDL_FreePalette() *

SDL_AllocRW

SDL.Import

*RWFrom functions*

SDL_ALPHA_OPAQUE

SDL.Import

** * Transparency definitions * * These define alpha as the opacity of a surface. *

SDL_ALPHA_TRANSPARENT

SDL.Import

SDL_APP_DIDENTERBACKGROUND

SDL.Import

**< The application is about to enter the background Called on iOS in applicationWillResignActive() Called on Android in onPause() *

SDL_APP_DIDENTERFOREGROUND

SDL.Import

**< The application is about to enter the foreground Called on iOS in applicationWillEnterForeground() Called on Android in onResume() *

SDL_APP_LOWMEMORY

SDL.Import

**< The application is being terminated by the OS Called on iOS in applicationWillTerminate() Called on Android in onDestroy() *

SDL_APP_TERMINATING

SDL.Import

* These application events have special meaning on iOS, see README.iOS for details *

SDL_APP_WILLENTERBACKGROUND

SDL.Import

**< The application is low on memory, free memory if possible. Called on iOS in applicationDidReceiveMemoryWarning() Called on Android in onLowMemory() *

SDL_APP_WILLENTERFOREGROUND

SDL.Import

**< The application did enter the background and may not get CPU for some time Called on iOS in applicationDidEnterBackground() Called on Android in onPause() *

SDL_ARRAYORDER_ABGR

SDL.Import

SDL_ARRAYORDER_ARGB

SDL.Import

SDL_ARRAYORDER_BGR

SDL.Import

SDL_ARRAYORDER_BGRA

SDL.Import

SDL_ARRAYORDER_NONE

SDL.Import

** Array component order, low byte -> high byte. *

SDL_ARRAYORDER_RGB

SDL.Import

SDL_ARRAYORDER_RGBA

SDL.Import

SDL_AudioDeviceConnected

SDL.Import

** * 1 if audio device is still functioning, zero if not, -1 on error. *

SDL_AudioInit

SDL.Import

** * Initialization and cleanup * * These functions are used internally, and should not be used unless * you have a specific need to specify the audio driver you want to * use. You should normally use SDL_Init() or SDL_InitSubSystem(). *

SDL_AudioQuit

SDL.Import

SDL_AUDIO_ALLOW_ANY_CHANGE

SDL.Import

SDL_AUDIO_ALLOW_CHANNELS_CHANGE

SDL.Import

SDL_AUDIO_ALLOW_FORMAT_CHANGE

SDL.Import

SDL_AUDIO_ALLOW_FREQUENCY_CHANGE

SDL.Import

** * Allow change flags * * Which audio format changes are allowed when opening a device. *

SDL_AUDIO_BITSIZE

SDL.Import

SDL_AUDIO_ISBIGENDIAN

SDL.Import

SDL_AUDIO_ISFLOAT

SDL.Import

SDL_AUDIO_ISINT

SDL.Import

SDL_AUDIO_ISLITTLEENDIAN

SDL.Import

SDL_AUDIO_ISSIGNED

SDL.Import

SDL_AUDIO_ISUNSIGNED

SDL.Import

SDL_AUDIO_MASK_BITSIZE

SDL.Import

** * Audio flags *

SDL_AUDIO_MASK_DATATYPE

SDL.Import

SDL_AUDIO_MASK_ENDIAN

SDL.Import

SDL_AUDIO_MASK_SIGNED

SDL.Import

SDL_BIG_ENDIAN

SDL.Import

SDL_BITMAPORDER_1234

SDL.Import

SDL_BITMAPORDER_4321

SDL.Import

SDL_BITMAPORDER_NONE

SDL.Import

** Bitmap pixel order, high bit -> low bit. *

SDL_BITSPERPIXEL

SDL.Import

SDL_BLENDMODE_ADD

SDL.Import

**< dst = (src * A) + (dst * (1-A)) *

SDL_BLENDMODE_BLEND

SDL.Import

**< No blending *

SDL_BLENDMODE_MOD

SDL.Import

**< dst = (src * A) + dst *

SDL_BLENDMODE_NONE

SDL.Import

SDL_BuildAudioCVT

SDL.Import

** * This function takes a source format and rate and a destination format * and rate, and initializes the cvt structure with information needed * by SDL_ConvertAudio() to convert a buffer of audio data from one format * to the other. * * -1 if the format conversion is not supported, 0 if there's * no conversion needed, or 1 if the audio filter is set up. *

SDL_BUTTON_LEFT

SDL.Import

** * Used as a mask when testing buttons in buttonstate. * - Button 1: Left mouse button * - Button 2: Middle mouse button * - Button 3: Right mouse button *

SDL_BUTTON_LMASK

SDL.Import

SDL_BUTTON_MIDDLE

SDL.Import

SDL_BUTTON_MMASK

SDL.Import

SDL_BUTTON_RIGHT

SDL.Import

SDL_BUTTON_RMASK

SDL.Import

SDL_BUTTON_X1

SDL.Import

SDL_BUTTON_X1MASK

SDL.Import

SDL_BUTTON_X2

SDL.Import

SDL_BUTTON_X2MASK

SDL.Import

SDL_BYTEORDER

SDL.Import

SDL_BYTESPERPIXEL

SDL.Import

SDL_CalculateGammaRamp

SDL.Import

** * Calculate a 256 entry gamma ramp for a gamma value. *

SDL_ClearError

SDL.Import

SDL_ClearHints

SDL.Import

/** * \brief Clear all hints * * This function is called during SDL_Quit() to free stored hints. */

SDL_CLIPBOARDUPDATE

SDL.Import

Clipboard events

SDL_CloseAudio

SDL.Import

** * This function shuts down audio processing and closes the audio device. *

SDL_CloseAudioDevice

SDL.Import

SDL_COMMONEVENT

SDL.Import

Unused (do not remove) (needed in pascal?)

SDL_COMPILEDVERSION

SDL.Import

** * This is the version number macro for the current SDL version. *

SDL_CondBroadcast

SDL.Import

** * Restart all threads that are waiting on the condition variable. * * 0 or -1 on error. *

SDL_CondSignal

SDL.Import

** * Restart one of the threads that are waiting on the condition variable. * * 0 or -1 on error. *

SDL_CondWait

SDL.Import

** * Wait on the condition variable, unlocking the provided mutex. * * The mutex must be locked before entering this function! * * The mutex is re-locked once the condition variable is signaled. * * 0 when it is signaled, or -1 on error. *

SDL_CondWaitTimeout

SDL.Import

** * Waits for at most ms milliseconds, and returns 0 if the condition * variable is signaled, SDL_MUTEX_TIMEDOUT if the condition is not * signaled in the allotted time, and -1 on error. * * On some platforms this function is implemented by looping with a * delay of 1 ms, and so should be avoided if possible. *

SDL_CONTROLLERAXISMOTION

SDL.Import

Game controller events

SDL_CONTROLLERBUTTONDOWN

SDL.Import

Game controller axis motion

SDL_CONTROLLERBUTTONUP

SDL.Import

Game controller button pressed

SDL_CONTROLLERDEVICEADDED

SDL.Import

Game controller button released

SDL_CONTROLLERDEVICEREMAPPED

SDL.Import

An opened Game controller has been removed

SDL_CONTROLLERDEVICEREMOVED

SDL.Import

A new Game controller has been inserted into the system

SDL_CONTROLLER_AXIS_INVALID

SDL.Import

** * The list of axes available from a controller *

SDL_CONTROLLER_AXIS_LEFTX

SDL.Import

SDL_CONTROLLER_AXIS_LEFTY

SDL.Import

SDL_CONTROLLER_AXIS_MAX

SDL.Import

SDL_CONTROLLER_AXIS_RIGHTX

SDL.Import

SDL_CONTROLLER_AXIS_RIGHTY

SDL.Import

SDL_CONTROLLER_AXIS_TRIGGERLEFT

SDL.Import

SDL_CONTROLLER_AXIS_TRIGGERRIGHT

SDL.Import

SDL_CONTROLLER_BUTTON_A

SDL.Import

SDL_CONTROLLER_BUTTON_B

SDL.Import

SDL_CONTROLLER_BUTTON_BACK

SDL.Import

SDL_CONTROLLER_BUTTON_DPAD_DOWN

SDL.Import

SDL_CONTROLLER_BUTTON_DPAD_LEFT

SDL.Import

SDL_CONTROLLER_BUTTON_DPAD_RIGHT

SDL.Import

SDL_CONTROLLER_BUTTON_DPAD_UP

SDL.Import

SDL_CONTROLLER_BUTTON_GUIDE

SDL.Import

SDL_CONTROLLER_BUTTON_INVALID

SDL.Import

** * The list of buttons available from a controller *

SDL_CONTROLLER_BUTTON_LEFTSHOULDER

SDL.Import

SDL_CONTROLLER_BUTTON_LEFTSTICK

SDL.Import

SDL_CONTROLLER_BUTTON_MAX

SDL.Import

SDL_CONTROLLER_BUTTON_RIGHTSHOULDER

SDL.Import

SDL_CONTROLLER_BUTTON_RIGHTSTICK

SDL.Import

SDL_CONTROLLER_BUTTON_START

SDL.Import

SDL_CONTROLLER_BUTTON_X

SDL.Import

SDL_CONTROLLER_BUTTON_Y

SDL.Import

SDL_ConvertAudio

SDL.Import

** * Once you have initialized the cvt structure using SDL_BuildAudioCVT(), * created an audio buffer cvt->buf, and filled it with cvt->len bytes of * audio data in the source format, this function will convert it in-place * to the desired format. * * The data conversion may expand the size of the audio data, so the buffer * cvt->buf should be allocated after the cvt structure is initialized by * SDL_BuildAudioCVT(), and should be cvt->len*cvt->len_mult bytes long. *

SDL_ConvertPixels

SDL.Import

** * Copy a block of pixels of one format to another format * * 0 on success, or -1 if there was an error *

SDL_ConvertSurface

SDL.Import

** * Creates a new surface of the specified format, and then copies and maps * the given surface to it so the blit of the converted surface will be as * fast as possible. If this function fails, it returns NULL. * * The flags parameter is passed to SDL_CreateRGBSurface() and has those * semantics. You can also pass SDL_RLEACCEL in the flags parameter and * SDL will try to RLE accelerate colorkey and alpha blits in the resulting * surface. *

SDL_ConvertSurfaceFormat

SDL.Import

SDL_CreateColorCursor

SDL.Import

** * Create a color cursor. * * SDL_FreeCursor() *

SDL_CreateCond

SDL.Import

** * Create a condition variable. * * Typical use of condition variables: * * Thread A: * SDL_LockMutex(lock); * while ( not condition ) * begin * SDL_CondWait(cond, lock); * end; * SDL_UnlockMutex(lock); * * Thread B: * SDL_LockMutex(lock); * ... * condition := true; * ... * SDL_CondSignal(cond); * SDL_UnlockMutex(lock); * * There is some discussion whether to signal the condition variable * with the mutex locked or not. There is some potential performance * benefit to unlocking first on some platforms, but there are some * potential race conditions depending on how your code is structured. * * In general it's safer to signal the condition variable while the * mutex is locked. *

SDL_CreateCursor

SDL.Import

** * Create a cursor, using the specified bitmap data and * mask (in MSB format). * * The cursor width must be a multiple of 8 bits. * * The cursor is created in black and white according to the following: * <table> * <tr><td> data </td><td> mask </td><td> resulting pixel on screen </td></tr> * <tr><td> 0 </td><td> 1 </td><td> White </td></tr> * <tr><td> 1 </td><td> 1 </td><td> Black </td></tr> * <tr><td> 0 </td><td> 0 </td><td> Transparent </td></tr> * <tr><td> 1 </td><td> 0 </td><td> Inverted color if possible, black * if not. </td></tr> * </table> * * SDL_FreeCursor() *

SDL_CreateMutex

SDL.Import

** * Create a mutex, initialized unlocked. *

SDL_CreateRenderer

SDL.Import

** * Create a 2D rendering context for a window. * * window The window where rendering is displayed. * index The index of the rendering driver to initialize, or -1 to * initialize the first one supporting the requested flags. * flags ::SDL_RendererFlags. * * A valid rendering context or NULL if there was an error. * * SDL_CreateSoftwareRenderer() * SDL_GetRendererInfo() * SDL_DestroyRenderer() *

SDL_CreateRGBSurface

SDL.Import

** * Allocate and free an RGB surface. * * If the depth is 4 or 8 bits, an empty palette is allocated for the surface. * If the depth is greater than 8 bits, the pixel format is set using the * flags '[RGB]mask'. * * If the function runs out of memory, it will return NULL. * * flags The flags are obsolete and should be set to 0. *

SDL_CreateRGBSurfaceFrom

SDL.Import

SDL_CreateSemaphore

SDL.Import

** * Create a semaphore, initialized with value, returns NULL on failure. *

SDL_CreateShapedWindow

SDL.Import

** * Create a window that can be shaped with the specified position, dimensions, and flags. * * title The title of the window, in UTF-8 encoding. * x The x position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * y The y position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * w The width of the window. * h The height of the window. * flags The flags for the window, a mask of SDL_WINDOW_BORDERLESS with any of the following: * SDL_WINDOW_OPENGL, SDL_WINDOW_INPUT_GRABBED, * SDL_WINDOW_SHOWN, SDL_WINDOW_RESIZABLE, * SDL_WINDOW_MAXIMIZED, SDL_WINDOW_MINIMIZED, * SDL_WINDOW_BORDERLESS is always set, and SDL_WINDOW_FULLSCREEN is always unset. * * The window created, or NULL if window creation failed. * * SDL_DestroyWindow() *

SDL_CreateSoftwareRenderer

SDL.Import

** * Create a 2D software rendering context for a surface. * * surface The surface where rendering is done. * * A valid rendering context or NULL if there was an error. * * SDL_CreateRenderer() * SDL_DestroyRenderer() *

SDL_CreateSystemCursor

SDL.Import

** * Create a system cursor. * * SDL_FreeCursor() *

SDL_CreateTexture

SDL.Import

** * Create a texture for a rendering context. * * renderer The renderer. * format The format of the texture. * access One of the enumerated values in ::SDL_TextureAccess. * w The width of the texture in pixels. * h The height of the texture in pixels. * * The created texture is returned, or 0 if no rendering context was * active, the format was unsupported, or the width or height were out * of range. * * SDL_QueryTexture() * SDL_UpdateTexture() * SDL_DestroyTexture() *

SDL_CreateTextureFromSurface

SDL.Import

** * Create a texture from an existing surface. * * renderer The renderer. * surface The surface containing pixel data used to fill the texture. * * The created texture is returned, or 0 on error. * * The surface is not modified or freed by this function. * * SDL_QueryTexture() * SDL_DestroyTexture() *

SDL_CreateThread

SDL.Import

** * Create a thread. *

SDL_CreateThread

SDL.Import

** * Create a thread. *

SDL_CreateWindow

SDL.Import

** * Create a window with the specified position, dimensions, and flags. * * title The title of the window, in UTF-8 encoding. * x The x position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * y The y position of the window, ::SDL_WINDOWPOS_CENTERED, or * ::SDL_WINDOWPOS_UNDEFINED. * w The width of the window. * h The height of the window. * flags The flags for the window, a mask of any of the following: * ::SDL_WINDOW_FULLSCREEN, ::SDL_WINDOW_OPENGL, * ::SDL_WINDOW_SHOWN, ::SDL_WINDOW_BORDERLESS, * ::SDL_WINDOW_RESIZABLE, ::SDL_WINDOW_MAXIMIZED, * ::SDL_WINDOW_MINIMIZED, ::SDL_WINDOW_INPUT_GRABBED. * * The id of the window created, or zero if window creation failed. * * SDL_DestroyWindow() *

SDL_CreateWindowAndRenderer

SDL.Import

** * Create a window and default renderer * * width The width of the window * height The height of the window * window_flags The flags used to create the window * window A pointer filled with the window, or NULL on error * renderer A pointer filled with the renderer, or NULL on error * * 0 on success, or -1 on error *

SDL_CreateWindowFrom

SDL.Import

** * Create an SDL window from an existing native window. * * data A pointer to driver-dependent window creation data * * The id of the window created, or zero if window creation failed. * * SDL_DestroyWindow() *

SDL_Delay

SDL.Import

** * Wait a specified number of milliseconds before returning. *

SDL_DelEventWatch

SDL.Import

** * Remove an event watch function added with SDL_AddEventWatch() *

SDL_DelHintCallback

SDL.Import

/** * \brief Remove a function watching a particular hint * * \param name The hint being watched * \param callback The function being called when the hint value changes * \param userdata A pointer being passed to the callback function */

SDL_DestroyCond

SDL.Import

** * Destroy a condition variable. *

SDL_DestroyMutex

SDL.Import

** * Destroy a mutex. *

SDL_DestroyRenderer

SDL.Import

** * Destroy the rendering context for a window and free associated * textures. * * SDL_CreateRenderer() *

SDL_DestroySemaphore

SDL.Import

** * Destroy a semaphore. *

SDL_DestroyTexture

SDL.Import

** * Destroy the specified texture. * * SDL_CreateTexture() * SDL_CreateTextureFromSurface() *

SDL_DestroyWindow

SDL.Import

** * Destroy a window. *

SDL_DISABLE

SDL.Import

SDL_DisableScreenSaver

SDL.Import

** * Prevent the screen from being blanked by a screensaver * * SDL_IsScreenSaverEnabled() * SDL_EnableScreenSaver() *

SDL_DOLLARGESTURE

SDL.Import

Gesture events

SDL_DOLLARRECORD

SDL.Import

SDL_DONTFREE

SDL.Import

**< Surface is RLE encoded *

SDL_DROPFILE

SDL.Import

Drag and drop events

SDL_ENABLE

SDL.Import

SDL_EnableScreenSaver

SDL.Import

** * Allow the screen to be blanked by a screensaver * * SDL_IsScreenSaverEnabled() * SDL_DisableScreenSaver() *

SDL_EnclosePoints

SDL.Import

** * Calculate a minimal rectangle enclosing a set of points * * SDL_TRUE if any points were within the clipping rect *

SDL_Error

SDL.Import

* SDL_Error() unconditionally returns -1. *

SDL_EventState

SDL.Import

** * This function allows you to set the state of processing certain events. * - If state is set to SDL_IGNORE, that event will be automatically * dropped from the event queue and will not event be filtered. * - If state is set to SDL_ENABLE, that event will be processed * normally. * - If state is set to SDL_QUERY, SDL_EventState() will return the * current processing state of the specified event. *

SDL_FillRect

SDL.Import

** * Performs a fast fill of the given rectangle with color. * * If rect is NULL, the whole surface will be filled with color. * * The color should be a pixel of the format used by the surface, and * can be generated by the SDL_MapRGB() function. * * 0 on success, or -1 on error. *

SDL_FillRects

SDL.Import

SDL_FilterEvents

SDL.Import

** * Run the filter function on the current event queue, removing any * events for which the filter returns 0. *

SDL_FINGERDOWN

SDL.Import

Touch events

SDL_FINGERMOTION

SDL.Import

SDL_FINGERUP

SDL.Import

SDL_FIRSTEVENT

SDL.Import

** * The types of events that can be delivered. *

SDL_FlushEvent

SDL.Import

** * This function clears events from the event queue *

SDL_FlushEvents

SDL.Import

SDL_FreeCursor

SDL.Import

** * Frees a cursor created with SDL_CreateCursor(). * * SDL_CreateCursor() *

SDL_FreeFormat

SDL.Import

** * Free an SDL_PixelFormat structure. *

SDL_FreePalette

SDL.Import

** * Free a palette created with SDL_AllocPalette(). * * SDL_AllocPalette() *

SDL_FreeRW

SDL.Import

SDL_FreeSurface

SDL.Import

SDL_FreeWAV

SDL.Import

** * This function frees data previously allocated with SDL_LoadWAV_RW() *

SDL_GameControllerAddMapping

SDL.Import

** * Add or update an existing mapping configuration * * 1 if mapping is added, 0 if updated, -1 on error *

SDL_GameControllerClose

SDL.Import

** * Close a controller previously opened with SDL_GameControllerOpen(). *

SDL_GameControllerEventState

SDL.Import

** * Enable/disable controller event polling. * * If controller events are disabled, you must call SDL_GameControllerUpdate() * yourself and check the state of the controller when you want controller * information. * * The state can be one of ::SDL_QUERY, ::SDL_ENABLE or ::SDL_IGNORE. *

SDL_GameControllerGetAttached

SDL.Import

** * Returns SDL_TRUE if the controller has been opened and currently connected, * or SDL_FALSE if it has not. *

SDL_GameControllerGetAxis

SDL.Import

** * Get the current state of an axis control on a game controller. * * The state is a value ranging from -32768 to 32767. * * The axis indices start at index 0. *

SDL_GameControllerGetAxisFromString

SDL.Import

** * turn this string into a axis mapping *

SDL_GameControllerGetBindForAxis

SDL.Import

** * Get the SDL joystick layer binding for this controller button mapping *

SDL_GameControllerGetBindForButton

SDL.Import

** * Get the SDL joystick layer binding for this controller button mapping *

SDL_GameControllerGetButton

SDL.Import

** * Get the current state of a button on a game controller. * * The button indices start at index 0. *

SDL_GameControllerGetButtonFromString

SDL.Import

** * turn this string into a button mapping *

SDL_GameControllerGetJoystick

SDL.Import

** * Get the underlying joystick object used by a controller *

SDL_GameControllerGetStringForAxis

SDL.Import

** * turn this axis enum into a string mapping *

SDL_GameControllerGetStringForButton

SDL.Import

** * turn this button enum into a string mapping *

SDL_GameControllerMapping

SDL.Import

** * Get a mapping string for an open GameController * * the mapping string. Must be freed with SDL_free. Returns NULL if no mapping is available *

SDL_GameControllerMappingForGUID

SDL.Import

** * Get a mapping string for a GUID * * the mapping string. Must be freed with SDL_free. Returns NULL if no mapping is available *

SDL_GameControllerName

SDL.Import

** * Return the name for this currently opened controller *

SDL_GameControllerNameForIndex

SDL.Import

** * Get the implementation dependent name of a game controller. * This can be called before any controllers are opened. * If no name can be found, this function returns NULL. *

SDL_GameControllerOpen

SDL.Import

** * Open a game controller for use. * The index passed as an argument refers to the N'th game controller on the system. * This index is the value which will identify this controller in future controller * events. * * A controller identifier, or NULL if an error occurred. *

SDL_GameControllerUpdate

SDL.Import

** * Update the current state of the open game controllers. * * This is called automatically by the event loop if any game controller * events are enabled. *

SDL_GetAudioDeviceName

SDL.Import

** * Get the human-readable name of a specific audio device. * Must be a value between 0 and (number of audio devices-1). * Only valid after a successfully initializing the audio subsystem. * The values returned by this function reflect the latest call to * SDL_GetNumAudioDevices(); recall that function to redetect available * hardware. * * The string returned by this function is UTF-8 encoded, read-only, and * managed internally. You are not to free it. If you need to keep the * string for any length of time, you should make your own copy of it, as it * will be invalid next time any of several other SDL functions is called. *

SDL_GetAudioDeviceStatus

SDL.Import

SDL_GetAudioDriver

SDL.Import

SDL_GetAudioStatus

SDL.Import

SDL_GetClipRect

SDL.Import

** * Gets the clipping rectangle for the destination surface in a blit. * * rect must be a pointer to a valid rectangle which will be filled * with the correct values. *

SDL_GetClosestDisplayMode

SDL.Import

** * Get the closest match to the requested display mode. * * mode The desired display mode * closest A pointer to a display mode to be filled in with the closest * match of the available display modes. * * The passed in value closest, or nil if no matching video mode * was available. * * The available display modes are scanned, and closest is filled in with the * closest mode matching the requested mode and returned. The mode format and * refresh_rate default to the desktop mode if they are 0. The modes are * scanned with size being first priority, format being second priority, and * finally checking the refresh_rate. If all the available modes are too * small, then nil is returned. * * SDL_GetNumDisplayModes() * SDL_GetDisplayMode() *

SDL_GetColorKey

SDL.Import

** * Gets the color key (transparent pixel) in a blittable surface. * * surface The surface to update * key A pointer filled in with the transparent pixel in the native * surface format * * 0 on success, or -1 if the surface is not valid or colorkey is not * enabled. *

SDL_GetCurrentAudioDriver

SDL.Import

** * This function returns the name of the current audio driver, or NULL * if no driver has been initialized. *

SDL_GetCurrentDisplayMode

SDL.Import

** * Fill in information about the current display mode. *

SDL_GetCurrentVideoDriver

SDL.Import

** * Returns the name of the currently initialized video driver. * * The name of the current video driver or nil if no driver * has been initialized * * SDL_GetNumVideoDrivers() * SDL_GetVideoDriver() *

SDL_GetCursor

SDL.Import

** * Return the active cursor. *

SDL_GetDesktopDisplayMode

SDL.Import

** * Fill in information about the desktop display mode. *

SDL_GetDisplayBounds

SDL.Import

** * Get the desktop area represented by a display, with the primary * display located at 0,0 * * 0 on success, or -1 if the index is out of range. * * SDL_GetNumVideoDisplays() *

SDL_GetDisplayMode

SDL.Import

** * Fill in information about a specific display mode. * * The display modes are sorted in this priority: * bits per pixel -> more colors to fewer colors * width -> largest to smallest * height -> largest to smallest * refresh rate -> highest to lowest * * SDL_GetNumDisplayModes() *

SDL_GetDisplayName

SDL.Import

** * Get the name of a display in UTF-8 encoding * * The name of a display, or nil for an invalid display index. * * SDL_GetNumVideoDisplays() *

SDL_getenv

GLS.SDL.Window

function SDL_getenv(const name: PAnsiChar): PAnsiChar; cdecl; external LibName;

SDL_GetError

SDL.Import

SDL_GETEVENT

SDL.Import

SDL_GetEventFilter

SDL.Import

** * Return the current event filter - can be used to "chain" filters. * If there is no event filter set, this function returns SDL_FALSE. *

SDL_GetEventState

SDL.Import

SDL_GetHint

SDL.Import

/** * \brief Get a hint * * \return The string value of a hint variable. */

SDL_GetKeyboardFocus

SDL.Import

** * Get the window which currently has keyboard focus. *

SDL_GetKeyboardState

SDL.Import

** * Get a snapshot of the current state of the keyboard. * * numkeys if non-nil, receives the length of the returned array. * * An array of key states. Indexes into this array are obtained by using SDL_Scancode values. * *

SDL_GetKeyFromName

SDL.Import

** * Get a key code from a human-readable name * * key code, or SDLK_UNKNOWN if the name wasn't recognized * * SDL_Keycode *

SDL_GetKeyFromScancode

SDL.Import

** * Get the key code corresponding to the given scancode according * to the current keyboard layout. * * See SDL_Keycode for details. * * SDL_GetKeyName() *

SDL_GetKeyName

SDL.Import

** * Get a human-readable name for a key. * * A pointer to a UTF-8 string that stays valid at least until the next * call to this function. If you need it around any longer, you must * copy it. If the key doesn't have a name, this function returns an * empty string (""). * * SDL_Key *

SDL_GetModState

SDL.Import

** * Get the current key modifier state for the keyboard. *

SDL_GetMouseFocus

SDL.Import

** * Get the window which currently has mouse focus. *

SDL_GetMouseState

SDL.Import

** * Retrieve the current state of the mouse. * * The current button state is returned as a button bitmask, which can * be tested using the SDL_BUTTON(X) macros, and x and y are set to the * mouse cursor position relative to the focus window for the currently * selected mouse. You can pass nil for either x or y. * * SDL_Button = 1 shl ((X)-1) *

SDL_GetNumAudioDevices

SDL.Import

** * Get the number of available devices exposed by the current driver. * Only valid after a successfully initializing the audio subsystem. * Returns -1 if an explicit list of devices can't be determined; this is * not an error. For example, if SDL is set up to talk to a remote audio * server, it can't list every one available on the Internet, but it will * still allow a specific host to be specified to SDL_OpenAudioDevice(). * * In many common cases, when this function returns a value <= 0, it can still * successfully open the default device (NULL for first argument of * SDL_OpenAudioDevice()). *

SDL_GetNumAudioDrivers

SDL.Import

** * Driver discovery functions * * These functions return the list of built in audio drivers, in the * order that they are normally initialized by default. *

SDL_GetNumDisplayModes

SDL.Import

** * Returns the number of available display modes. * * SDL_GetDisplayMode() *

SDL_GetNumRenderDrivers

SDL.Import

** * Get the number of 2D rendering drivers available for the current * display. * * A render driver is a set of code that handles rendering and texture * management on a particular display. Normally there is only one, but * some drivers may have several available with different capabilities. * * SDL_GetRenderDriverInfo() * SDL_CreateRenderer() *

SDL_GetNumTouchDevices

SDL.Import

** * Get the number of registered touch devices. *

SDL_GetNumTouchFingers

SDL.Import

** * Get the number of active fingers for a given touch device. *

SDL_GetNumVideoDisplays

SDL.Import

** * Returns the number of available video displays. * * SDL_GetDisplayBounds() *

SDL_GetNumVideoDrivers

SDL.Import

** * Get the number of video drivers compiled into SDL * * SDL_GetVideoDriver() *

SDL_GetPerformanceCounter

SDL.Import

** * Get the current value of the high resolution counter *

SDL_GetPerformanceFrequency

SDL.Import

** * Get the count per second of the high resolution counter *

SDL_GetPixelFormatName

SDL.Import

** * Get the human readable name of a pixel format *

SDL_GetPlatform

SDL.Import

** * Gets the name of the platform. *

SDL_GetPowerInfo

SDL.Import

** * Get the current power supply details. * * secs Seconds of battery life left. You can pass a NULL here if * you don't care. Will return -1 if we can't determine a * value, or we're not running on a battery. * * pct Percentage of battery life left, between 0 and 100. You can * pass a NULL here if you don't care. Will return -1 if we * can't determine a value, or we're not running on a battery. * * The state of the battery (if any). *

SDL_GetRelativeMouseMode

SDL.Import

** * Query whether relative mouse mode is enabled. * * SDL_SetRelativeMouseMode() *

SDL_GetRelativeMouseState

SDL.Import

** * Retrieve the relative state of the mouse. * * The current button state is returned as a button bitmask, which can * be tested using the SDL_BUTTON(X) macros, and x and y are set to the * mouse deltas since the last call to SDL_GetRelativeMouseState(). *

SDL_GetRenderDrawBlendMode

SDL.Import

** * Get the blend mode used for drawing operations. * * renderer The renderer from which blend mode should be queried. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 on error * * SDL_SetRenderDrawBlendMode() *

SDL_GetRenderDrawColor

SDL.Import

** * Get the color used for drawing operations (Rect, Line and Clear). * * renderer The renderer from which drawing color should be queried. * r A pointer to the red value used to draw on the rendering target. * g A pointer to the green value used to draw on the rendering target. * b A pointer to the blue value used to draw on the rendering target. * a A pointer to the alpha value used to draw on the rendering target, * usually SDL_ALPHA_OPAQUE (255). * * 0 on success, or -1 on error *

SDL_GetRenderDriverInfo

SDL.Import

** * Get information about a specific 2D rendering driver for the current * display. * * index The index of the driver to query information about. * info A pointer to an SDL_RendererInfo struct to be filled with * information on the rendering driver. * * 0 on success, -1 if the index was out of range. * * SDL_CreateRenderer() *

SDL_GetRenderer

SDL.Import

** * Get the renderer associated with a window. *

SDL_GetRendererInfo

SDL.Import

** * Get information about a rendering context. *

SDL_GetRendererOutputSize

SDL.Import

** * Get the output size of a rendering context. *

SDL_GetRenderTarget

SDL.Import

** * Get the current render target or NULL for the default render target. * * The current render target * * SDL_SetRenderTarget() *

SDL_GetRevision

SDL.Import

** * Get the code revision of SDL that is linked against your program. * * Returns an arbitrary string (a hash value) uniquely identifying the * exact revision of the SDL library in use, and is only useful in comparing * against other revisions. It is NOT an incrementing number. *

SDL_GetRevisionNumber

SDL.Import

** * Get the revision number of SDL that is linked against your program. * * Returns a number uniquely identifying the exact revision of the SDL * library in use. It is an incrementing number based on commits to * hg.libsdl.org. *

SDL_GetRGB

SDL.Import

** * Get the RGB components from a pixel of the specified format. * * SDL_GetRGBA *

SDL_GetRGBA

SDL.Import

** * Get the RGBA components from a pixel of the specified format. * * SDL_GetRGB *

SDL_GetScancodeFromKey

SDL.Import

** * Get the scancode corresponding to the given key code according to the * current keyboard layout. * * See SDL_Scancode for details. * * SDL_GetScancodeName() *

SDL_GetScancodeFromName

SDL.Import

** * Get a scancode from a human-readable name * * scancode, or SDL_SCANCODE_UNKNOWN if the name wasn't recognized * * SDL_Scancode *

SDL_GetScancodeName

SDL.Import

** * Get a human-readable name for a scancode. * * A pointer to the name for the scancode. * * If the scancode doesn't have a name, this function returns * an empty string (""). * *

SDL_GetShapedWindowMode

SDL.Import

** * Get the shape parameters of a shaped window. * * window The shaped window whose parameters should be retrieved. * shape_mode An empty shape-mode structure to fill, or NULL to check whether the window has a shape. * * 0 if the window has a shape and, provided shape_mode was not NULL, shape_mode has been filled with the mode * data, SDL_NONSHAPEABLE_WINDOW if the SDL_Window given is not a shaped window, or SDL_WINDOW_LACKS_SHAPE if * the SDL_Window* given is a shapeable window currently lacking a shape. * * SDL_WindowShapeMode * SDL_SetWindowShape *

SDL_GetSurfaceAlphaMod

SDL.Import

** * Get the additional alpha value used in blit operations. * * surface The surface to query. * alpha A pointer filled in with the current alpha value. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceAlphaMod() *

SDL_GetSurfaceBlendMode

SDL.Import

** * Get the blend mode used for blit operations. * * surface The surface to query. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceBlendMode() *

SDL_GetSurfaceColorMod

SDL.Import

** * Get the additional color value used in blit operations. * * surface The surface to query. * r A pointer filled in with the current red color value. * g A pointer filled in with the current green color value. * b A pointer filled in with the current blue color value. * * 0 on success, or -1 if the surface is not valid. * * SDL_SetSurfaceColorMod() *

SDL_GetTextureAlphaMod

SDL.Import

** * Get the additional alpha value used in render copy operations. * * texture The texture to query. * alpha A pointer filled in with the current alpha value. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureAlphaMod() *

SDL_GetTextureBlendMode

SDL.Import

** * Get the blend mode used for texture copy operations. * * texture The texture to query. * blendMode A pointer filled in with the current blend mode. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureBlendMode() *

SDL_GetTextureColorMod

SDL.Import

** * Get the additional color value used in render copy operations. * * texture The texture to query. * r A pointer filled in with the current red color value. * g A pointer filled in with the current green color value. * b A pointer filled in with the current blue color value. * * 0 on success, or -1 if the texture is not valid. * * SDL_SetTextureColorMod() *

SDL_GetThreadID

SDL.Import

** * Get the thread identifier for the specified thread. * * Equivalent to SDL_ThreadID() if the specified thread is NULL. *

SDL_GetThreadName

SDL.Import

** * Get the thread name, as it was specified in SDL_CreateThread(). * This function returns a pointer to a UTF-8 string that names the * specified thread, or NULL if it doesn't have a name. This is internal * memory, not to be free()'d by the caller, and remains valid until the * specified thread is cleaned up by SDL_WaitThread(). *

SDL_GetTicks

SDL.Import

** * Get the number of milliseconds since the SDL library initialization. * * This value wraps if the program runs for more than ~49 days. *

SDL_GetTouchDevice

SDL.Import

** * Get the touch ID with the given index, or 0 if the index is invalid. *

SDL_GetTouchFinger

SDL.Import

** * Get the finger object of the given touch, with the given index. *

SDL_GetVersion

SDL.Import

** * Get the version of SDL that is linked against your program. * * If you are linking to SDL dynamically, then it is possible that the * current version will be different than the version you compiled against. * This function returns the current version, while SDL_VERSION() is a * macro that tells you what version you compiled with. * * * compiled: TSDL_Version; * linked: TSDL_Version; * * SDL_VERSION(@compiled); * SDL_GetVersion(@linked); * WriteLn('We compiled against SDL version: ' + * IntToStr(compiled.major) + * IntToStr(compiled.minor) + * IntToStr(compiled.patch)); * WriteLn('But we linked against SDL version:' + * IntToStr(compiled.major) + * IntToStr(compiled.minor) + * IntToStr(compiled.patch)); * * * This function may be called safely at any time, even before SDL_Init(). * * SDL_VERSION *

SDL_GetVideoDriver

SDL.Import

** * Get the name of a built in video driver. * * The video drivers are presented in the order in which they are * normally checked during initialization. * * SDL_GetNumVideoDrivers() *

SDL_GetWindowBrightness

SDL.Import

** * Get the brightness (gamma correction) for a window. * * The last brightness value passed to SDL_SetWindowBrightness() * * SDL_SetWindowBrightness() *

SDL_GetWindowData

SDL.Import

** * Retrieve the data pointer associated with a window. * * window The window to query. * name The name of the pointer. * * The value associated with 'name' * * SDL_SetWindowData() *

SDL_GetWindowDisplayIndex

SDL.Import

** * Get the display index associated with a window. * * the display index of the display containing the center of the * window, or -1 on error. *

SDL_GetWindowDisplayMode

SDL.Import

** * Fill in information about the display mode used when a fullscreen * window is visible. * * SDL_SetWindowDisplayMode() * SDL_SetWindowFullscreen() *

SDL_GetWindowFlags

SDL.Import

** * Get the window flags. *

SDL_GetWindowFromID

SDL.Import

** * Get a window from a stored ID, or nil if it doesn't exist. *

SDL_GetWindowGammaRamp

SDL.Import

** * Get the gamma ramp for a window. * * red A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the red channel, or nil. * green A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the green channel, or nil. * blue A pointer to a 256 element array of 16-bit quantities to hold * the translation table for the blue channel, or nil. * * 0 on success, or -1 if gamma ramps are unsupported. * * SDL_SetWindowGammaRamp() *

SDL_GetWindowGrab

SDL.Import

** * Get a window's input grab mode. * * This returns SDL_TRUE if input is grabbed, and SDL_FALSE otherwise. * * SDL_SetWindowGrab() *

SDL_GetWindowID

SDL.Import

** * Get the numeric ID of a window, for logging purposes. *

SDL_GetWindowMaximumSize

SDL.Import

** * Get the maximum size of a window's client area. * * w Pointer to variable for storing the maximum width, may be nil * h Pointer to variable for storing the maximum height, may be nil * * SDL_GetWindowMinimumSize() * SDL_SetWindowMaximumSize() *

SDL_GetWindowMinimumSize

SDL.Import

** * Get the minimum size of a window's client area. * * w Pointer to variable for storing the minimum width, may be nil * h Pointer to variable for storing the minimum height, may be nil * * SDL_GetWindowMaximumSize() * SDL_SetWindowMinimumSize() *

SDL_GetWindowPixelFormat

SDL.Import

** * Get the pixel format associated with the window. *

SDL_GetWindowPosition

SDL.Import

** * Get the position of a window. * * x Pointer to variable for storing the x position, may be nil * y Pointer to variable for storing the y position, may be nil * * SDL_SetWindowPosition() *

SDL_GetWindowSize

SDL.Import

** * Get the size of a window's client area. * * w Pointer to variable for storing the width, may be nil * h Pointer to variable for storing the height, may be nil * * SDL_SetWindowSize() *

SDL_GetWindowSurface

SDL.Import

** * Get the SDL surface associated with the window. * * The window's framebuffer surface, or nil on error. * * A new surface will be created with the optimal format for the window, * if necessary. This surface will be freed when the window is destroyed. * * You may not combine this with 3D or the rendering API on this window. * * SDL_UpdateWindowSurface() * SDL_UpdateWindowSurfaceRects() *

SDL_GetWindowTitle

SDL.Import

** * Get the title of a window, in UTF-8 format. * * SDL_SetWindowTitle() *

SDL_GL_ACCELERATED_VISUAL

SDL.Import

SDL_GL_ACCUM_ALPHA_SIZE

SDL.Import

SDL_GL_ACCUM_BLUE_SIZE

SDL.Import

SDL_GL_ACCUM_GREEN_SIZE

SDL.Import

SDL_GL_ACCUM_RED_SIZE

SDL.Import

SDL_GL_ALPHA_SIZE

SDL.Import

SDL_GL_BindTexture

SDL.Import

** * Bind the texture to the current OpenGL/ES/ES2 context for use with * OpenGL instructions. * * texture The SDL texture to bind * texw A pointer to a float that will be filled with the texture width * texh A pointer to a float that will be filled with the texture height * * 0 on success, or -1 if the operation is not supported *

SDL_GL_BLUE_SIZE

SDL.Import

SDL_GL_BUFFER_SIZE

SDL.Import

SDL_GL_CONTEXT_DEBUG_FLAG

SDL.Import

SDL_GL_CONTEXT_EGL

SDL.Import

SDL_GL_CONTEXT_FLAGS

SDL.Import

SDL_GL_CONTEXT_FORWARD_COMPATIBLE_FLAG

SDL.Import

SDL_GL_CONTEXT_MAJOR_VERSION

SDL.Import

SDL_GL_CONTEXT_MINOR_VERSION

SDL.Import

SDL_GL_CONTEXT_PROFILE_COMPATIBILITY

SDL.Import

SDL_GL_CONTEXT_PROFILE_CORE

SDL.Import

SDL_GL_CONTEXT_PROFILE_ES

SDL.Import

SDL_GL_CONTEXT_PROFILE_MASK

SDL.Import

SDL_GL_CONTEXT_RESET_ISOLATION_FLAG

SDL.Import

SDL_GL_CONTEXT_ROBUST_ACCESS_FLAG

SDL.Import

SDL_GL_CreateContext

SDL.Import

** * Create an OpenGL context for use with an OpenGL window, and make it * current. * * SDL_GL_DeleteContext() *

SDL_GL_DeleteContext

SDL.Import

** * Delete an OpenGL context. * * SDL_GL_CreateContext() *

SDL_GL_DEPTH_SIZE

SDL.Import

SDL_GL_DOUBLEBUFFER

SDL.Import

SDL_GL_ExtensionSupported

SDL.Import

** * Return true if an OpenGL extension is supported for the current * context. *

SDL_GL_GetAttribute

SDL.Import

** * Get the actual value for an attribute from the current context. *

SDL_GL_GetCurrentContext

SDL.Import

** * Get the currently active OpenGL context. *

SDL_GL_GetCurrentWindow

SDL.Import

** * Get the currently active OpenGL window. *

SDL_GL_GetProcAddress

SDL.Import

** * Get the address of an OpenGL function. *

SDL_GL_GetSwapInterval

SDL.Import

** * Get the swap interval for the current OpenGL context. * * 0 if there is no vertical retrace synchronization, 1 if the buffer * swap is synchronized with the vertical retrace, and -1 if late * swaps happen immediately instead of waiting for the next retrace. * If the system can't determine the swap interval, or there isn't a * valid current context, this will return 0 as a safe default. * * SDL_GL_SetSwapInterval() *

SDL_GL_GREEN_SIZE

SDL.Import

SDL_GL_LoadLibrary

SDL.Import

** * Dynamically load an OpenGL library. * * path The platform dependent OpenGL library name, or nil to open the * default OpenGL library. * * 0 on success, or -1 if the library couldn't be loaded. * * This should be done after initializing the video driver, but before * creating any OpenGL windows. If no OpenGL library is loaded, the default * library will be loaded upon creation of the first OpenGL window. * * If you do this, you need to retrieve all of the GL functions used in * your program from the dynamic library using SDL_GL_GetProcAddress(). * * SDL_GL_GetProcAddress() * SDL_GL_UnloadLibrary() *

SDL_GL_MakeCurrent

SDL.Import

** * Set up an OpenGL context for rendering into an OpenGL window. * * The context must have been created with a compatible window. *

SDL_GL_MULTISAMPLEBUFFERS

SDL.Import

SDL_GL_MULTISAMPLESAMPLES

SDL.Import

SDL_GL_RED_SIZE

SDL.Import

** * OpenGL configuration attributes *

SDL_GL_RETAINED_BACKING

SDL.Import

SDL_GL_SetAttribute

SDL.Import

** * Set an OpenGL window attribute before window creation. *

SDL_GL_SetSwapInterval

SDL.Import

** * Set the swap interval for the current OpenGL context. * * interval 0 for immediate updates, 1 for updates synchronized with the * vertical retrace. If the system supports it, you may * specify -1 to allow late swaps to happen immediately * instead of waiting for the next retrace. * * 0 on success, or -1 if setting the swap interval is not supported. * * SDL_GL_GetSwapInterval() *

SDL_GL_SHARE_WITH_CURRENT_CONTEXT

SDL.Import

SDL_GL_STENCIL_SIZE

SDL.Import

SDL_GL_STEREO

SDL.Import

SDL_GL_SwapWindow

SDL.Import

** * Swap the OpenGL buffers for a window, if double-buffering is * supported. *

SDL_GL_UnbindTexture

SDL.Import

** * Unbind a texture from the current OpenGL/ES/ES2 context. * * texture The SDL texture to unbind * * 0 on success, or -1 if the operation is not supported *

SDL_GL_UnloadLibrary

SDL.Import

** * Unload the OpenGL library previously loaded by SDL_GL_LoadLibrary(). * * SDL_GL_LoadLibrary() *

SDL_HapticClose

SDL.Import

** * Closes a Haptic device previously opened with SDL_HapticOpen(). * * haptic Haptic device to close. *

SDL_HapticDestroyEffect

SDL.Import

** * Destroys a haptic effect on the device. * * This will stop the effect if it's running. Effects are automatically * destroyed when the device is closed. * * haptic Device to destroy the effect on. * effect Identifier of the effect to destroy. * * SDL_HapticNewEffect *

SDL_HapticEffectSupported

SDL.Import

** * Checks to see if effect is supported by haptic. * * haptic Haptic device to check on. * effect Effect to check to see if it is supported. * SDL_TRUE if effect is supported, SDL_FALSE if it isn't or -1 on error. * * SDL_HapticQuery * SDL_HapticNewEffect *

SDL_HapticGetEffectStatus

SDL.Import

** * Gets the status of the current effect on the haptic device. * * Device must support the ::SDL_HAPTIC_STATUS feature. * * haptic Haptic device to query the effect status on. * effect Identifier of the effect to query its status. * 0 if it isn't playing, 1 if it is playing or -1 on error. * * SDL_HapticRunEffect * SDL_HapticStopEffect *

SDL_HapticIndex

SDL.Import

** * Gets the index of a haptic device. * * haptic Haptic device to get the index of. * The index of the haptic device or -1 on error. * * SDL_HapticOpen * SDL_HapticOpened *

SDL_HapticName

SDL.Import

** * Get the implementation dependent name of a Haptic device. * * This can be called before any joysticks are opened. * If no name can be found, this function returns NULL. * * device_index Index of the device to get its name. * Name of the device or NULL on error. * * SDL_NumHaptics *

SDL_HapticNewEffect

SDL.Import

** * Creates a new haptic effect on the device. * * haptic Haptic device to create the effect on. * effect Properties of the effect to create. * The id of the effect on success or -1 on error. * * SDL_HapticUpdateEffect * SDL_HapticRunEffect * SDL_HapticDestroyEffect *

SDL_HapticNumAxes

SDL.Import

** * Gets the number of haptic axes the device has. * * SDL_HapticDirection *

SDL_HapticNumEffects

SDL.Import

** * Returns the number of effects a haptic device can store. * * On some platforms this isn't fully supported, and therefore is an * approximation. Always check to see if your created effect was actually * created and do not rely solely on SDL_HapticNumEffects(). * * haptic The haptic device to query effect max. * The number of effects the haptic device can store or * -1 on error. * * SDL_HapticNumEffectsPlaying * SDL_HapticQuery *

SDL_HapticNumEffectsPlaying

SDL.Import

** * Returns the number of effects a haptic device can play at the same * time. * * This is not supported on all platforms, but will always return a value. * Added here for the sake of completeness. * * haptic The haptic device to query maximum playing effects. * The number of effects the haptic device can play at the same time * or -1 on error. * * SDL_HapticNumEffects * SDL_HapticQuery *

SDL_HapticOpen

SDL.Import

** * Opens a Haptic device for usage. * * The index passed as an argument refers to the N'th Haptic device on this * system. * * When opening a haptic device, its gain will be set to maximum and * autocenter will be disabled. To modify these values use * SDL_HapticSetGain() and SDL_HapticSetAutocenter(). * * device_index Index of the device to open. * Device identifier or NULL on error. * * SDL_HapticIndex * SDL_HapticOpenFromMouse * SDL_HapticOpenFromJoystick * SDL_HapticClose * SDL_HapticSetGain * SDL_HapticSetAutocenter * SDL_HapticPause * SDL_HapticStopAll *

SDL_HapticOpened

SDL.Import

** * Checks if the haptic device at index has been opened. * * device_index Index to check to see if it has been opened. * 1 if it has been opened or 0 if it hasn't. * * SDL_HapticOpen * SDL_HapticIndex *

SDL_HapticOpenFromJoystick

SDL.Import

** * Opens a Haptic device for usage from a Joystick device. * * You must still close the haptic device seperately. It will not be closed * with the joystick. * * When opening from a joystick you should first close the haptic device before * closing the joystick device. If not, on some implementations the haptic * device will also get unallocated and you'll be unable to use force feedback * on that device. * * joystick Joystick to create a haptic device from. * A valid haptic device identifier on success or NULL on error. * * SDL_HapticOpen * SDL_HapticClose *

SDL_HapticOpenFromMouse

SDL.Import

** * Tries to open a haptic device from the current mouse. * * The haptic device identifier or NULL on error. * * SDL_MouseIsHaptic * SDL_HapticOpen *

SDL_HapticPause

SDL.Import

** * Pauses a haptic device. * * Device must support the SDL_HAPTIC_PAUSE feature. Call * SDL_HapticUnpause() to resume playback. * * Do not modify the effects nor add new ones while the device is paused. * That can cause all sorts of weird errors. * * haptic Haptic device to pause. * 0 on success or -1 on error. * * SDL_HapticUnpause *

SDL_HapticQuery

SDL.Import

** * Gets the haptic devices supported features in bitwise matter. * * Example: * * if (SDL_HapticQueryEffects(haptic) & SDL_HAPTIC_CONSTANT) * printf("We have constant haptic effect!"); * * * * haptic The haptic device to query. * Haptic features in bitwise manner (OR'd). * * SDL_HapticNumEffects * SDL_HapticEffectSupported *

SDL_HapticRumbleInit

SDL.Import

** * Initializes the haptic device for simple rumble playback. * * haptic Haptic device to initialize for simple rumble playback. * 0 on success or -1 on error. * * SDL_HapticOpen * SDL_HapticRumbleSupported * SDL_HapticRumblePlay * SDL_HapticRumbleStop *

SDL_HapticRumblePlay

SDL.Import

** * Runs simple rumble on a haptic device * * haptic Haptic device to play rumble effect on. * strength Strength of the rumble to play as a 0-1 float value. * length Length of the rumble to play in milliseconds. * 0 on success or -1 on error. * * SDL_HapticRumbleSupported * SDL_HapticRumbleInit * SDL_HapticRumbleStop *

SDL_HapticRumbleStop

SDL.Import

** * Stops the simple rumble on a haptic device. * * haptic Haptic to stop the rumble on. * 0 on success or -1 on error. * * SDL_HapticRumbleSupported * SDL_HapticRumbleInit * SDL_HapticRumblePlay *

SDL_HapticRumbleSupported

SDL.Import

** * Checks to see if rumble is supported on a haptic device.. * * haptic Haptic device to check to see if it supports rumble. * SDL_TRUE if effect is supported, SDL_FALSE if it isn't or -1 on error. * * SDL_HapticRumbleInit * SDL_HapticRumblePlay * SDL_HapticRumbleStop *

SDL_HapticRunEffect

SDL.Import

** * Runs the haptic effect on its associated haptic device. * * If iterations are ::SDL_HAPTIC_INFINITY, it'll run the effect over and over * repeating the envelope (attack and fade) every time. If you only want the * effect to last forever, set ::SDL_HAPTIC_INFINITY in the effect's length * parameter. * * haptic Haptic device to run the effect on. * effect Identifier of the haptic effect to run. * iterations Number of iterations to run the effect. Use * SDL_HAPTIC_INFINITY for infinity. * 0 on success or -1 on error. * * SDL_HapticStopEffect * SDL_HapticDestroyEffect * SDL_HapticGetEffectStatus *

SDL_HapticSetAutocenter

SDL.Import

** * Sets the global autocenter of the device. * * Autocenter should be between 0 and 100. Setting it to 0 will disable * autocentering. * * Device must support the ::SDL_HAPTIC_AUTOCENTER feature. * * haptic Haptic device to set autocentering on. * autocenter Value to set autocenter to, 0 disables autocentering. * 0 on success or -1 on error. * * SDL_HapticQuery *

SDL_HapticSetGain

SDL.Import

** * Sets the global gain of the device. * * Device must support the SDL_HAPTIC_GAIN feature. * * The user may specify the maximum gain by setting the environment variable * SDL_HAPTIC_GAIN_MAX which should be between 0 and 100. All calls to * SDL_HapticSetGain() will scale linearly using SDL_HAPTIC_GAIN_MAX as the * maximum. * * haptic Haptic device to set the gain on. * gain Value to set the gain to, should be between 0 and 100. * 0 on success or -1 on error. * * SDL_HapticQuery *

SDL_HapticStopAll

SDL.Import

** * Stops all the currently playing effects on a haptic device. * * haptic Haptic device to stop. * 0 on success or -1 on error. *

SDL_HapticStopEffect

SDL.Import

** * Stops the haptic effect on its associated haptic device. * * haptic Haptic device to stop the effect on. * effect Identifier of the effect to stop. * 0 on success or -1 on error. * * SDL_HapticRunEffect * SDL_HapticDestroyEffect *

SDL_HapticUnpause

SDL.Import

** * Unpauses a haptic device. * * Call to unpause after SDL_HapticPause(). * * haptic Haptic device to pause. * 0 on success or -1 on error. * * SDL_HapticPause *

SDL_HapticUpdateEffect

SDL.Import

** * Updates the properties of an effect. * * Can be used dynamically, although behaviour when dynamically changing * direction may be strange. Specifically the effect may reupload itself * and start playing from the start. You cannot change the type either when * running SDL_HapticUpdateEffect(). * * haptic Haptic device that has the effect. * effect Effect to update. * data New effect properties to use. * The id of the effect on success or -1 on error. * * SDL_HapticNewEffect * SDL_HapticRunEffect * SDL_HapticDestroyEffect *

SDL_HAPTIC_AUTOCENTER

SDL.Import

** * Device can set autocenter. * * Device supports setting autocenter. * * SDL_HapticSetAutocenter *

SDL_HAPTIC_CARTESIAN

SDL.Import

** * Uses cartesian coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_CONSTANT

SDL.Import

** * Constant effect supported. * * Constant haptic effect. * * SDL_HapticCondition *

SDL_HAPTIC_CUSTOM

SDL.Import

** * Custom effect is supported. * * User defined custom haptic effect. *

SDL_HAPTIC_DAMPER

SDL.Import

** * Damper effect supported - uses axes velocity. * * Condition haptic effect that simulates dampening. Effect is based on the * axes velocity. * * SDL_HapticCondition *

SDL_HAPTIC_FRICTION

SDL.Import

** * Friction effect supported - uses axes movement. * * Condition haptic effect that simulates friction. Effect is based on the * axes movement. * * SDL_HapticCondition *

SDL_HAPTIC_GAIN

SDL.Import

** * Device can set global gain. * * Device supports setting the global gain. * * SDL_HapticSetGain *

SDL_HAPTIC_INERTIA

SDL.Import

** * Inertia effect supported - uses axes acceleration. * * Condition haptic effect that simulates inertia. Effect is based on the axes * acceleration. * * SDL_HapticCondition *

SDL_HAPTIC_INFINITY

SDL.Import

SDL_HAPTIC_INFINITY = 4294967295U;

SDL_HAPTIC_PAUSE

SDL.Import

** * Device can be paused. * * SDL_HapticPause * SDL_HapticUnpause *

SDL_HAPTIC_POLAR

SDL.Import

** * Uses polar coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_RAMP

SDL.Import

** * Ramp effect supported. * * Ramp haptic effect. * * SDL_HapticRamp *

SDL_HAPTIC_SAWTOOTHDOWN

SDL.Import

** * Sawtoothdown wave effect supported. * * Periodic haptic effect that simulates saw tooth down waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SAWTOOTHUP

SDL.Import

** * Sawtoothup wave effect supported. * * Periodic haptic effect that simulates saw tooth up waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SINE

SDL.Import

** * Sine wave effect supported. * * Periodic haptic effect that simulates sine waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_SPHERICAL

SDL.Import

** * Uses spherical coordinates for the direction. * * SDL_HapticDirection *

SDL_HAPTIC_SPRING

SDL.Import

** * Spring effect supported - uses axes position. * * Condition haptic effect that simulates a spring. Effect is based on the * axes position. * * SDL_HapticCondition *

SDL_HAPTIC_SQUARE

SDL.Import

** * Square wave effect supported. * * Periodic haptic effect that simulates square waves. * * SDL_HapticPeriodic *

SDL_HAPTIC_STATUS

SDL.Import

** * Device can be queried for effect status. * * Device can be queried for effect status. * * SDL_HapticGetEffectStatus *

SDL_HAPTIC_TRIANGLE

SDL.Import

** * Triangle wave effect supported. * * Periodic haptic effect that simulates triangular waves. * * SDL_HapticPeriodic *

SDL_HasEvent

SDL.Import

** * Checks to see if certain event types are in the event queue. *

SDL_HasEvents

SDL.Import

SDL_HasIntersection

SDL.Import

** * Determine whether two rectangles intersect. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *

SDL_HasScreenKeyboardSupport

SDL.Import

** * Returns whether the platform has some screen keyboard support. * * SDL_TRUE if some keyboard support is available else SDL_FALSE. * * Not all screen keyboard functions are supported on all platforms. * * SDL_IsScreenKeyboardShown() *

SDL_HAT_CENTERED

SDL.Import

** * Hat positions *

SDL_HAT_DOWN

SDL.Import

SDL_HAT_LEFT

SDL.Import

SDL_HAT_LEFTDOWN

SDL.Import

SDL_HAT_LEFTUP

SDL.Import

SDL_HAT_RIGHT

SDL.Import

SDL_HAT_RIGHTDOWN

SDL.Import

SDL_HAT_RIGHTUP

SDL.Import

SDL_HAT_UP

SDL.Import

SDL_HideWindow

SDL.Import

** * Hide a window. * * SDL_ShowWindow() *

SDL_HintPriority

SDL.Import

/** * \brief An enumeration of hint priorities */

SDL_HINT_ALLOW_TOPMOST

SDL.Import

/** * \brief If set to 0 then never set the top most bit on a SDL Window, even if the video mode expects it. * This is a debugging aid for developers and not expected to be used by end users. The default is "1" * * This variable can be set to the following values: * "0" - don't allow topmost * "1" - allow topmost */

SDL_HINT_FRAMEBUFFER_ACCELERATION

SDL.Import

* * \brief A variable controlling how 3D acceleration is used to accelerate the SDL screen surface. * * SDL can try to accelerate the SDL screen surface by using streaming * textures with a 3D rendering engine. This variable controls whether and * how this is done. * * This variable can be set to the following values: * "0" - Disable 3D acceleration * "1" - Enable 3D acceleration, using the default renderer. * "X" - Enable 3D acceleration, using X where X is one of the valid rendering drivers. (e.g. "direct3d", "opengl", etc.) * * By default SDL tries to make a best guess for each platform whether * to use acceleration or not.

SDL_HINT_GAMECONTROLLERCONFIG

SDL.Import

/** * \brief A variable that lets you manually hint extra gamecontroller db entries * * The variable should be newline delimited rows of gamecontroller config data, see SDL_gamecontroller.h * * This hint must be set before calling SDL_Init(SDL_INIT_GAMECONTROLLER) * You can update mappings after the system is initialized with SDL_GameControllerMappingForGUID() and SDL_GameControllerAddMapping() */

SDL_HINT_GRAB_KEYBOARD

SDL.Import

/** * \brief A variable controlling whether grabbing input grabs the keyboard * * This variable can be set to the following values: * "0" - Grab will affect only the mouse * "1" - Grab will affect mouse and keyboard * * By default SDL will not grab the keyboard so system shortcuts still work. */

SDL_HINT_IDLE_TIMER_DISABLED

SDL.Import

/** * \brief A variable controlling whether the idle timer is disabled on iOS. * * When an iOS app does not receive touches for some time, the screen is * dimmed automatically. For games where the accelerometer is the only input * this is problematic. This functionality can be disabled by setting this * hint. * * This variable can be set to the following values: * "0" - Enable idle timer * "1" - Disable idle timer */

SDL_HINT_JOYSTICK_ALLOW_BACKGROUND_EVENTS

SDL.Import

/** * \brief A variable that lets you enable joystick (and gamecontroller) events even when your app is in the background. * * The variable can be set to the following values: * "0" - Disable joystick & gamecontroller input events when the * application is in the background. * "1" - Enable joystick & gamecontroller input events when the * application is in the backgroumd. * * The default value is "0". This hint may be set at any time. */

SDL_HINT_ORIENTATIONS

SDL.Import

/** * \brief A variable controlling which orientations are allowed on iOS. * * In some circumstances it is necessary to be able to explicitly control * which UI orientations are allowed. * * This variable is a space delimited list of the following values: * "LandscapeLeft", "LandscapeRight", "Portrait" "PortraitUpsideDown" */

SDL_HINT_RENDER_DIRECT3D_THREADSAFE

SDL.Import

/** * \brief A hint that specifies whether the Direct3D device is initialized for thread-safe operations. * * By default the Direct3D device is created with thread-safety disabled. * * This variable can be set to the following values: * "0" - disable thread-safety (faster) * "1" - enable thread-safety (slower) */

SDL_HINT_RENDER_DRIVER

SDL.Import

/** * \brief A variable specifying which render driver to use. * * If the application doesn't pick a specific renderer to use, this variable * specifies the name of the preferred renderer. If the preferred renderer * can't be initialized, the normal default renderer is used. * * This variable is case insensitive and can be set to the following values: * "direct3d" * "opengl" * "opengles2" * "opengles" * "software" * * The default varies by platform, but it's the first one in the list that * is available on the current platform. */

SDL_HINT_RENDER_OPENGL_SHADERS

SDL.Import

/** * \brief A variable controlling whether the OpenGL render driver uses shaders if they are available. * * This variable can be set to the following values: * "0" - Disable shaders * "1" - Enable shaders * * By default shaders are used if OpenGL supports them. */

SDL_HINT_RENDER_SCALE_QUALITY

SDL.Import

/** * \brief A variable controlling the scaling quality * * This variable can be set to the following values: * "0" or "nearest" - Nearest pixel sampling * "1" or "linear" - Linear filtering (supported by OpenGL and Direct3D) * "2" or "best" - Currently this is the same as "linear" * * By default nearest pixel sampling is used */

SDL_HINT_RENDER_VSYNC

SDL.Import

/** * \brief A variable controlling whether updates to the SDL screen surface should be synchronized with the vertical refresh, to avoid tearing. * * This variable can be set to the following values: * "0" - Disable vsync * "1" - Enable vsync * * By default SDL does not sync screen surface updates with vertical refresh. */

SDL_HINT_TIMER_RESOLUTION

SDL.Import

/** * \brief A variable that controls the timer resolution, in milliseconds. * * The higher resolution the timer, the more frequently the CPU services * timer interrupts, and the more precise delays are, but this takes up * power and CPU time. This hint is only used on Windows 7 and earlier. * * See this blog post for more information: * http://randomascii.wordpress.com/2013/07/08/windows-timer-resolution-megawatts-wasted/ * * If this variable is set to "0", the system timer resolution is not set. * * The default value is "1". This hint may be set at any time. */

SDL_HINT_VIDEO_MINIMIZE_ON_FOCUS_LOSS

SDL.Import

/** * \brief Minimize your SDL_Window if it loses key focus when in Fullscreen mode. Defaults to true. * */

SDL_HINT_VIDEO_X11_XINERAMA

SDL.Import

/** * \brief A variable controlling whether the X11 Xinerama extension should be used. * * This variable can be set to the following values: * "0" - Disable Xinerama * "1" - Enable Xinerama * * By default SDL will use Xinerama if it is available. */

SDL_HINT_VIDEO_X11_XRANDR

SDL.Import

/** * \brief A variable controlling whether the X11 XRandR extension should be used. * * This variable can be set to the following values: * "0" - Disable XRandR * "1" - Enable XRandR * * By default SDL will not use XRandR because of window manager issues. */

SDL_HINT_VIDEO_X11_XVIDMODE

SDL.Import

/** * \brief A variable controlling whether the X11 VidMode extension should be used. * * This variable can be set to the following values: * "0" - Disable XVidMode * "1" - Enable XVidMode * * By default SDL will use XVidMode if it is available. */

SDL_HINT_XINPUT_ENABLED

SDL.Import

/** * \brief A variable that lets you disable the detection and use of Xinput gamepad devices * * The variable can be set to the following values: * "0" - Disable XInput timer (only uses direct input) * "1" - Enable XInput timer (the default) */

SDL_IGNORE

SDL.Import

SDL_Init

SDL.Import

** * This function initializes the subsystems specified by flags * Unless the SDL_INIT_NOPARACHUTE flag is set, it will install cleanup * signal handlers for some commonly ignored fatal signals (like SIGSEGV). *

SDL_InitSubSystem

SDL.Import

** * This function initializes specific SDL subsystems *

SDL_INIT_AUDIO

SDL.Import

SDL_INIT_EVERYTHING

SDL.Import

Don't catch fatal signals

SDL_INIT_GAMECONTROLLER

SDL.Import

SDL_INIT_HAPTIC

SDL.Import

SDL_INIT_JOYSTICK

SDL.Import

SDL_INIT_NOPARACHUTE

SDL.Import

turn on game controller also implicitly does JOYSTICK

SDL_INIT_TIMER

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

SDL_INIT_VIDEO

SDL.Import

SDL_IntersectRect

SDL.Import

** * Calculate the intersection of two rectangles. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *

SDL_IntersectRectAndLine

SDL.Import

** * Calculate the intersection of a rectangle and line segment. * * SDL_TRUE if there is an intersection, SDL_FALSE otherwise. *

SDL_INVALID_SHAPE_ARGUMENT

SDL.Import

SDL_IsGameController

SDL.Import

** * Is the joystick on this index supported by the game controller interface? *

SDL_IsScreenKeyboardShown

SDL.Import

** * Returns whether the screen keyboard is shown for given window. * * window The window for which screen keyboard should be queried. * * Result - SDL_TRUE if screen keyboard is shown else SDL_FALSE. * * SDL_HasScreenKeyboardSupport() *

SDL_IsScreenSaverEnabled

SDL.Import

** * Returns whether the screensaver is currently enabled (default on). * * SDL_EnableScreenSaver() * SDL_DisableScreenSaver() *

SDL_IsShapedWindow

SDL.Import

** * Return whether the given window is a shaped window. * * window The window to query for being shaped. * * SDL_TRUE if the window is a window that can be shaped, SDL_FALSE if the window is unshaped or NULL. * SDL_CreateShapedWindow *

SDL_IsTextInputActive

SDL.Import

** * Return whether or not Unicode text input events are enabled. * * SDL_StartTextInput() * SDL_StopTextInput() *

SDL_JOYAXISMOTION

SDL.Import

Joystick events

SDL_JOYBALLMOTION

SDL.Import

Joystick axis motion

SDL_JOYBUTTONDOWN

SDL.Import

Joystick hat position change

SDL_JOYBUTTONUP

SDL.Import

Joystick button pressed

SDL_JOYDEVICEADDED

SDL.Import

Joystick button released

SDL_JOYDEVICEREMOVED

SDL.Import

A new joystick has been inserted into the system

SDL_JOYHATMOTION

SDL.Import

Joystick trackball motion

SDL_JoystickClose

SDL.Import

** * Close a joystick previously opened with SDL_JoystickOpen(). *

SDL_JoystickEventState

SDL.Import

** * Enable/disable joystick event polling. * * If joystick events are disabled, you must call SDL_JoystickUpdate() * yourself and check the state of the joystick when you want joystick * information. * * The state can be one of ::SDL_QUERY, ::SDL_ENABLE or ::SDL_IGNORE. *

SDL_JoystickGetAttached

SDL.Import

** * Returns SDL_TRUE if the joystick has been opened and currently connected, or SDL_FALSE if it has not. *

SDL_JoystickGetAxis

SDL.Import

** * Get the current state of an axis control on a joystick. * * The state is a value ranging from -32768 to 32767. * * The axis indices start at index 0. *

SDL_JoystickGetBall

SDL.Import

** * Get the ball axis change since the last poll. * * 0, or -1 if you passed it invalid parameters. * * The ball indices start at index 0. *

SDL_JoystickGetButton

SDL.Import

** * Get the current state of a button on a joystick. * * The button indices start at index 0. *

SDL_JoystickGetDeviceGUID

SDL.Import

** * Return the GUID for the joystick at this index *

SDL_JoystickGetGUID

SDL.Import

** * Return the GUID for this opened joystick *

SDL_JoystickGetGUIDFromString

SDL.Import

** * convert a string into a joystick formatted guid *

SDL_JoystickGetGUIDString

SDL.Import

** * Return a string representation for this guid. pszGUID must point to at least 33 bytes * (32 for the string plus a NULL terminator). *

SDL_JoystickGetHat

SDL.Import

** * Get the current state of a POV hat on a joystick. * * The hat indices start at index 0. * * The return value is one of the following positions: * - SDL_HAT_CENTERED * - SDL_HAT_UP * - SDL_HAT_RIGHT * - SDL_HAT_DOWN * - SDL_HAT_LEFT * - SDL_HAT_RIGHTUP * - SDL_HAT_RIGHTDOWN * - SDL_HAT_LEFTUP * - SDL_HAT_LEFTDOWN *

SDL_JoystickInstanceID

SDL.Import

** * Get the instance ID of an opened joystick or -1 if the joystick is invalid. *

SDL_JoystickIsHaptic

SDL.Import

** * Checks to see if a joystick has haptic features. * * joystick Joystick to test for haptic capabilities. * 1 if the joystick is haptic, 0 if it isn't * or -1 if an error ocurred. * * SDL_HapticOpenFromJoystick *

SDL_JoystickName

SDL.Import

** * Return the name for this currently opened joystick. * If no name can be found, this function returns NULL. *

SDL_JoystickNameForIndex

SDL.Import

** * Get the implementation dependent name of a joystick. * This can be called before any joysticks are opened. * If no name can be found, this function returns NULL. *

SDL_JoystickNumAxes

SDL.Import

** * Get the number of general axis controls on a joystick. *

SDL_JoystickNumBalls

SDL.Import

** * Get the number of trackballs on a joystick. * * Joystick trackballs have only relative motion events associated * with them and their state cannot be polled. *

SDL_JoystickNumButtons

SDL.Import

** * Get the number of buttons on a joystick. *

SDL_JoystickNumHats

SDL.Import

** * Get the number of POV hats on a joystick. *

SDL_JoystickOpen

SDL.Import

** * Open a joystick for use. * The index passed as an argument refers tothe N'th joystick on the system. * This index is the value which will identify this joystick in future joystick * events. * * A joystick identifier, or NULL if an error occurred. *

SDL_JoystickUpdate

SDL.Import

** * Update the current state of the open joysticks. * * This is called automatically by the event loop if any joystick * events are enabled. *

SDL_KEYDOWN

SDL.Import

Keyboard events

SDL_KEYUP

SDL.Import

Key pressed

SDL_LASTEVENT

SDL.Import

** * This last event is only for bounding internal arrays (needed in pascal ??) *

SDL_LibName

SDL.Import

SDL_LIL_ENDIAN

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_byteorder.h //////////////////////////////////////////////// ///////////////////////////////////////////////////////////////////////////////////////////////////// SDL_byteorder.h constants The two types of endianness

SDL_LoadBMP

SDL.Import

** * Load a surface from a file. * * Convenience macro. *

SDL_LoadBMP_RW

SDL.Import

** * Load a surface from a seekable SDL data stream (memory or file). * * If freesrc is non-zero, the stream will be closed after being read. * * The new surface should be freed with SDL_FreeSurface(). * * the new surface, or NULL if there was an error. *

SDL_LoadDollarTemplates

SDL.Import

** * Load Dollar Gesture templates from a file * * *

SDL_LoadFunction

SDL.Import

** * Given an object handle, this function looks up the address of the * named function in the shared object and returns it. This address * is no longer valid after calling SDL_UnloadObject(). *

SDL_LoadObject

SDL.Import

** * This function dynamically loads a shared object and returns a pointer * to the object handle (or NULL if there was an error). * The 'sofile' parameter is a system dependent name of the object file. *

SDL_LoadWAV

SDL.Import

** * Loads a WAV from a file. * Compatibility convenience function. *

SDL_LoadWAV_RW

SDL.Import

** * This function loads a WAVE from the data source, automatically freeing * that source if freesrc is non-zero. For example, to load a WAVE file, * you could do: * * SDL_LoadWAV_RW(SDL_RWFromFile("sample.wav", "rb"), 1, ...); * * * If this function succeeds, it returns the given SDL_AudioSpec, * filled with the audio data format of the wave data, and sets * *audio_buf to a malloc()'d buffer containing the audio data, * and sets *audio_len to the length of that audio buffer, in bytes. * You need to free the audio buffer with SDL_FreeWAV() when you are * done with it. * * This function returns NULL and sets the SDL error message if the * wave file cannot be opened, uses an unknown data format, or is * corrupt. Currently raw and MS-ADPCM WAVE files are supported. *

SDL_LockAudio

SDL.Import

** * Audio lock functions * * The lock manipulated by these functions protects the callback function. * During a SDL_LockAudio()/SDL_UnlockAudio() pair, you can be guaranteed that * the callback function is not running. Do not call these from the callback * function or you will cause deadlock. *

SDL_LockAudioDevice

SDL.Import

SDL_LockMutex

SDL.Import

#define SDL_mutexP(m) SDL_LockMutex(m)

SDL_LockSurface

SDL.Import

** * Sets up a surface for directly accessing the pixels. * * Between calls to SDL_LockSurface() / SDL_UnlockSurface(), you can write * to and read from surface.pixels, using the pixel format stored in * surface.format. Once you are done accessing the surface, you should * use SDL_UnlockSurface() to release it. * * Not all surfaces require locking. If SDL_MUSTLOCK(surface) evaluates * to 0, then you can read and write to the surface at any time, and the * pixel format of the surface will not change. * * No operating system or library calls should be made between lock/unlock * pairs, as critical system locks may be held during this time. * * SDL_LockSurface() returns 0, or -1 if the surface couldn't be locked. * * SDL_UnlockSurface() *

SDL_LockTexture

SDL.Import

** * Lock a portion of the texture for write-only pixel access. * * texture The texture to lock for access, which was created with * SDL_TEXTUREACCESS_STREAMING. * rect A pointer to the rectangle to lock for access. If the rect * is NULL, the entire texture will be locked. * pixels This is filled in with a pointer to the locked pixels, * appropriately offset by the locked area. * pitch This is filled in with the pitch of the locked pixels. * * 0 on success, or -1 if the texture is not valid or was not created with ::SDL_TEXTUREACCESS_STREAMING. * * SDL_UnlockTexture() *

SDL_LowerBlit

SDL.Import

** * This is a semi-private blit function and it performs low-level surface * blitting only. *

SDL_LowerBlitScaled

SDL.Import

** * This is a semi-private blit function and it performs low-level surface * scaled blitting only. *

SDL_MAJOR_VERSION

SDL.Import

* Printable format: "%d.%d.%d", MAJOR, MINOR, PATCHLEVEL *

SDL_MapRGB

SDL.Import

** * Maps an RGB triple to an opaque pixel value for a given pixel format. * * SDL_MapRGBA *

SDL_MapRGBA

SDL.Import

** * Maps an RGBA quadruple to a pixel value for a given pixel format. * * SDL_MapRGB *

SDL_MasksToPixelFormatEnum

SDL.Import

** * Convert a bpp and RGBA masks to an enumerated pixel format. * * The pixel format, or SDL_PIXELFORMAT_UNKNOWN if the conversion * wasn't possible. * * SDL_PixelFormatEnumToMasks() *

SDL_MaximizeWindow

SDL.Import

** * Make a window as large as possible. * * SDL_RestoreWindow() *

SDL_MESSAGEBOX_BUTTON_ESCAPEKEY_DEFAULT

SDL.Import

**< Marks the default button when return is hit *

SDL_MESSAGEBOX_BUTTON_RETURNKEY_DEFAULT

SDL.Import

** * Flags for SDL_MessageBoxButtonData. *

SDL_MESSAGEBOX_ERROR

SDL.Import

** * SDL_MessageBox flags. If supported will display warning icon, etc. *

SDL_MESSAGEBOX_INFORMATION

SDL.Import

**< warning dialog *

SDL_MESSAGEBOX_WARNING

SDL.Import

**< error dialog *

SDL_MinimizeWindow

SDL.Import

** * Minimize a window to an iconic representation. * * SDL_RestoreWindow() *

SDL_MINOR_VERSION

SDL.Import

SDL_MixAudio

SDL.Import

** * This takes two audio buffers of the playing audio format and mixes * them, performing addition, volume adjustment, and overflow clipping. * The volume ranges from 0 - 128, and should be set to ::SDL_MIX_MAXVOLUME * for full audio volume. Note this does not change hardware volume. * This is provided for convenience – you can mix your own audio data. *

SDL_MixAudioFormat

SDL.Import

** * This works like SDL_MixAudio(), but you specify the audio format instead of * using the format of audio device 1. Thus it can be used when no audio * device is open at all. *

SDL_MIX_MAXVOLUME

SDL.Import

SDL_MOUSEBUTTONDOWN

SDL.Import

Mouse moved

SDL_MOUSEBUTTONUP

SDL.Import

Mouse button pressed

SDL_MouseIsHaptic

SDL.Import

** * Gets whether or not the current mouse has haptic capabilities. * * SDL_TRUE if the mouse is haptic, SDL_FALSE if it isn't. * * SDL_HapticOpenFromMouse *

SDL_MOUSEMOTION

SDL.Import

Mouse events

SDL_MOUSEWHEEL

SDL.Import

Mouse button released

SDL_MULTIGESTURE

SDL.Import

SDL_MUTEX_TIMEDOUT

SDL.Import

** * Synchronization functions which can time out return this value * if they time out. *

SDL_NONSHAPEABLE_WINDOW

SDL.Import

** SDL_shape.h * * Header file for the shaped window API. *

SDL_NumHaptics

SDL.Import

** * Count the number of haptic devices attached to the system. * * Number of haptic devices detected on the system. *

SDL_NumJoysticks

SDL.Import

** * Count the number of joysticks attached to the system right now *

SDL_NUM_SCANCODES

SDL.Import

* Add any other keys here. *

SDL_NUM_SYSTEM_CURSORS

SDL.Import

Hand

SDL_OpenAudio

SDL.Import

** * This function opens the audio device with the desired parameters, and * returns 0 if successful, placing the actual hardware parameters in the * structure pointed to by obtained. If obtained is NULL, the audio * data passed to the callback function will be guaranteed to be in the * requested format, and will be automatically converted to the hardware * audio format if necessary. This function returns -1 if it failed * to open the audio device, or couldn't set up the audio thread. * * When filling in the desired audio spec structure, * - desired->freq should be the desired audio frequency in samples-per- * second. * - desired->format should be the desired audio format. * - desired->samples is the desired size of the audio buffer, in * samples. This number should be a power of two, and may be adjusted by * the audio driver to a value more suitable for the hardware. Good values * seem to range between 512 and 8096 inclusive, depending on the * application and CPU speed. Smaller values yield faster response time, * but can lead to underflow if the application is doing heavy processing * and cannot fill the audio buffer in time. A stereo sample consists of * both right and left channels in LR ordering. * Note that the number of samples is directly related to time by the * following formula: ms := (samples*1000)/freq; * - desired->size is the size in bytes of the audio buffer, and is * calculated by SDL_OpenAudio(). * - desired->silence is the value used to set the buffer to silence, * and is calculated by SDL_OpenAudio(). * - desired->callback should be set to a function that will be called * when the audio device is ready for more data. It is passed a pointer * to the audio buffer, and the length in bytes of the audio buffer. * This function usually runs in a separate thread, and so you should * protect data structures that it accesses by calling SDL_LockAudio() * and SDL_UnlockAudio() in your code. * - desired->userdata is passed as the first parameter to your callback * function. * * The audio device starts out playing silence when it's opened, and should * be enabled for playing by calling SDL_PauseAudio(0) when you are ready * for your audio callback function to be called. Since the audio driver * may modify the requested size of the audio buffer, you should allocate * any local mixing buffers after you open the audio device. *

SDL_OpenAudioDevice

SDL.Import

** * Open a specific audio device. Passing in a device name of NULL requests * the most reasonable default (and is equivalent to calling SDL_OpenAudio()). * * The device name is a UTF-8 string reported by SDL_GetAudioDeviceName(), but * some drivers allow arbitrary and driver-specific strings, such as a * hostname/IP address for a remote audio server, or a filename in the * diskaudio driver. * * 0 on error, a valid device ID that is >= 2 on success. * * SDL_OpenAudio(), unlike this function, always acts on device ID 1. *

SDL_PACKEDLAYOUT_1010102

SDL.Import

SDL_PACKEDLAYOUT_1555

SDL.Import

SDL_PACKEDLAYOUT_2101010

SDL.Import

SDL_PACKEDLAYOUT_332

SDL.Import

SDL_PACKEDLAYOUT_4444

SDL.Import

SDL_PACKEDLAYOUT_5551

SDL.Import

SDL_PACKEDLAYOUT_565

SDL.Import

SDL_PACKEDLAYOUT_8888

SDL.Import

SDL_PACKEDLAYOUT_NONE

SDL.Import

** Packed component layout. *

SDL_PACKEDORDER_ABGR

SDL.Import

SDL_PACKEDORDER_ARGB

SDL.Import

SDL_PACKEDORDER_BGRA

SDL.Import

SDL_PACKEDORDER_BGRX

SDL.Import

SDL_PACKEDORDER_NONE

SDL.Import

** Packed component order, high bit -> low bit. *

SDL_PACKEDORDER_RGBA

SDL.Import

SDL_PACKEDORDER_RGBX

SDL.Import

SDL_PACKEDORDER_XBGR

SDL.Import

SDL_PACKEDORDER_XRGB

SDL.Import

SDL_PATCHLEVEL

SDL.Import

SDL_PauseAudio

SDL.Import

** * Pause audio functions * * These functions pause and unpause the audio callback processing. * They should be called with a parameter of 0 after opening the audio * device to start playing sound. This is so you can safely initialize * data for your callback function after opening the audio device. * Silence will be written to the audio device during the pause. *

SDL_PauseAudioDevice

SDL.Import

SDL_PEEKEVENT

SDL.Import

SDL_PeepEvents

SDL.Import

** * Checks the event queue for messages and optionally returns them. * * If action is SDL_ADDEVENT, up to numevents events will be added to * the back of the event queue. * * If action is SDL_PEEKEVENT, up to numevents events at the front * of the event queue, within the specified minimum and maximum type, * will be returned and will not be removed from the queue. * * If action is SDL_GETEVENT, up to numevents events at the front * of the event queue, within the specified minimum and maximum type, * will be returned and will be removed from the queue. * * Result: The number of events actually stored, or -1 if there was an error. * * This function is thread-safe. *

SDL_PIXELFLAG

SDL.Import

//todo!! function SDL_DEFINE_PIXELFORMAT(type, order, layour, bit, bytes: UInt32): Result;
function SDL_DEFINE_PIXELFOURCC(A,B,C,D: Variant): Variant;
#define SDL_DEFINE_PIXELFORMAT(type, order, layout, bits, bytes) \ ((1 << 28) | ((type) << 24) | ((order) << 20) | ((layout) << 16) | \ ((bits) << 8) | ((bytes) << 0))

SDL_PixelFormatEnumToMasks

SDL.Import

** * Convert one of the enumerated pixel formats to a bpp and RGBA masks. * * SDL_TRUE, or SDL_FALSE if the conversion wasn't possible. * * SDL_MasksToPixelFormatEnum() *

SDL_PIXELFORMAT_ABGR1555

SDL.Import

SDL_PIXELFORMAT_ABGR4444

SDL.Import

SDL_PIXELFORMAT_ABGR8888

SDL.Import

SDL_PIXELFORMAT_ARGB1555

SDL.Import

SDL_PIXELFORMAT_ARGB2101010

SDL.Import

SDL_PIXELFORMAT_ARGB4444

SDL.Import

SDL_PIXELFORMAT_ARGB8888

SDL.Import

SDL_PIXELFORMAT_BGR24

SDL.Import

SDL_PIXELFORMAT_BGR555

SDL.Import

SDL_PIXELFORMAT_BGR565

SDL.Import

SDL_PIXELFORMAT_BGR888

SDL.Import

SDL_PIXELFORMAT_BGRA4444

SDL.Import

SDL_PIXELFORMAT_BGRA5551

SDL.Import

SDL_PIXELFORMAT_BGRA8888

SDL.Import

SDL_PIXELFORMAT_BGRX8888

SDL.Import

SDL_PIXELFORMAT_INDEX1LSB

SDL.Import

SDL_PIXELFORMAT_INDEX1MSB

SDL.Import

SDL_PIXELFORMAT_INDEX4LSB

SDL.Import

SDL_PIXELFORMAT_INDEX4MSB

SDL.Import

SDL_PIXELFORMAT_INDEX8

SDL.Import

SDL_PIXELFORMAT_IYUV

SDL.Import

**< Planar mode: Y + U + V (3 planes) *

SDL_PIXELFORMAT_RGB24

SDL.Import

SDL_PIXELFORMAT_RGB332

SDL.Import

SDL_PIXELFORMAT_RGB444

SDL.Import

SDL_PIXELFORMAT_RGB555

SDL.Import

SDL_PIXELFORMAT_RGB565

SDL.Import

SDL_PIXELFORMAT_RGB888

SDL.Import

SDL_PIXELFORMAT_RGBA4444

SDL.Import

SDL_PIXELFORMAT_RGBA5551

SDL.Import

SDL_PIXELFORMAT_RGBA8888

SDL.Import

SDL_PIXELFORMAT_RGBX8888

SDL.Import

SDL_PIXELFORMAT_UNKNOWN

SDL.Import

#define SDL_BYTESPERPIXEL(X) \ (SDL_ISPIXELFORMAT_FOURCC(X) ? \ ((((X) == SDL_PIXELFORMAT_YUY2) || \ ((X) == SDL_PIXELFORMAT_UYVY) || \ ((X) == SDL_PIXELFORMAT_YVYU)) ? 2 : 1) : (((X) >> 0) & 0xFF))
#define SDL_ISPIXELFORMAT_INDEXED(format) \ (!SDL_ISPIXELFORMAT_FOURCC(format) && \ ((SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX1) || \ (SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX4) || \ (SDL_PIXELTYPE(format) == SDL_PIXELTYPE_INDEX8)))
#define SDL_ISPIXELFORMAT_ALPHA(format) \ (!SDL_ISPIXELFORMAT_FOURCC(format) && \ ((SDL_PIXELORDER(format) == SDL_PACKEDORDER_ARGB) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_RGBA) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_ABGR) || \ (SDL_PIXELORDER(format) == SDL_PACKEDORDER_BGRA)))
function SDL_IsPixelFormat_FOURCC(format: Variant);
{* Note: If you modify this list, update SDL_GetPixelFormatName() *

SDL_PIXELFORMAT_UYVY

SDL.Import

**< Packed mode: U0+Y0+V0+Y1 (1 plane) *

SDL_PIXELFORMAT_YUY2

SDL.Import

**< Packed mode: Y0+U0+Y1+V0 (1 plane) *

SDL_PIXELFORMAT_YV12

SDL.Import

**< Planar mode: Y + V + U (3 planes) *

SDL_PIXELFORMAT_YVYU

SDL.Import

**< Packed mode: Y0+V0+Y1+U0 (1 plane) *

SDL_PIXELLAYOUT

SDL.Import

SDL_PIXELORDER

SDL.Import

SDL_PIXELTYPE

SDL.Import

SDL_PIXELTYPE_ARRAYF16

SDL.Import

SDL_PIXELTYPE_ARRAYF32

SDL.Import

SDL_PIXELTYPE_ARRAYU16

SDL.Import

SDL_PIXELTYPE_ARRAYU32

SDL.Import

SDL_PIXELTYPE_ARRAYU8

SDL.Import

SDL_PIXELTYPE_INDEX1

SDL.Import

SDL_PIXELTYPE_INDEX4

SDL.Import

SDL_PIXELTYPE_INDEX8

SDL.Import

SDL_PIXELTYPE_PACKED16

SDL.Import

SDL_PIXELTYPE_PACKED32

SDL.Import

SDL_PIXELTYPE_PACKED8

SDL.Import

SDL_PIXELTYPE_UNKNOWN

SDL.Import

** Pixel type. *

SDL_PollEvent

SDL.Import

** * Polls for currently pending events. * * 1 if there are any pending events, or 0 if there are none available. * * event - If not nil, the next event is removed from the queue and * stored in that area. *

SDL_PREALLOC

SDL.Import

**< Just here for compatibility *

SDL_PumpEvents

SDL.Import

** * Pumps the event loop, gathering events from the input devices. * * This function updates the event queue and internal input device state. * * This should only be run in the thread that sets the video mode. *

SDL_PushEvent

SDL.Import

** * Add an event to the event queue. * * 1 on success, 0 if the event was filtered, or -1 if the event queue * was full or there was some other error. *

SDL_putenv

GLS.SDL.Window

function SDL_putenv(const variable: PAnsiChar): integer; cdecl; external LibName;

SDL_QUERY

SDL.Import

SDL_QueryTexture

SDL.Import

** * Query the attributes of a texture * * texture A texture to be queried. * format A pointer filled in with the raw format of the texture. The * actual format may differ, but pixel transfers will use this * format. * access A pointer filled in with the actual access to the texture. * w A pointer filled in with the width of the texture in pixels. * h A pointer filled in with the height of the texture in pixels. * * 0 on success, or -1 if the texture is not valid. *

SDL_Quit

SDL.Import

** * This function cleans up all initialized subsystems. You should * call it upon all exit conditions. *

SDL_QUITEV

SDL.Import

Application events

SDL_QuitSubSystem

SDL.Import

** * This function cleans up specific SDL subsystems *

SDL_RaiseWindow

SDL.Import

** * Raise a window above other windows and set the input focus. *

SDL_ReadBE16

SDL.Import

SDL_ReadBE32

SDL.Import

SDL_ReadBE64

SDL.Import

SDL_ReadLE16

SDL.Import

SDL_ReadLE32

SDL.Import

SDL_ReadLE64

SDL.Import

SDL_ReadU8

SDL.Import

** * Read endian functions * * Read an item of the specified endianness and return in native format. *

SDL_RecordGesture

SDL.Import

** * Begin Recording a gesture on the specified touch, or all touches (-1) * * *

SDL_RectEmpty

SDL.Import

changed from variant(b?????h!) to TSDL_Rect maybe PSDL_Rect?

SDL_RectEquals

SDL.Import

** * Returns true if the two rectangles are equal. *

SDL_RegisterEvents

SDL.Import

** * This function allocates a set of user-defined events, and returns * the beginning event number for that set of events. * * If there aren't enough user-defined events left, this function * returns (Uint32)-1 *

SDL_RemoveTimer

SDL.Import

** * Remove a timer knowing its ID. * * A boolean value indicating success or failure. * * It is not safe to remove a timer multiple times. *

SDL_RenderClear

SDL.Import

** * Clear the current rendering target with the drawing color * * This function clears the entire rendering target, ignoring the viewport. * * 0 on success, or -1 on error *

SDL_RenderCopy

SDL.Import

** * Copy a portion of the texture to the current rendering target. * * renderer The renderer which should copy parts of a texture. * texture The source texture. * srcrect A pointer to the source rectangle, or NULL for the entire * texture. * dstrect A pointer to the destination rectangle, or NULL for the * entire rendering target. * * 0 on success, or -1 on error *

SDL_RenderCopyEx

SDL.Import

** * Copy a portion of the source texture to the current rendering target, rotating it by angle around the given center * * renderer The renderer which should copy parts of a texture. * texture The source texture. * srcrect A pointer to the source rectangle, or NULL for the entire * texture. * dstrect A pointer to the destination rectangle, or NULL for the * entire rendering target. * angle An angle in degrees that indicates the rotation that will be applied to dstrect * center A pointer to a point indicating the point around which dstrect will be rotated (if NULL, rotation will be done aroud dstrect.w/2, dstrect.h/2) * flip An SDL_RendererFlip value stating which flipping actions should be performed on the texture * * 0 on success, or -1 on error *

SDL_RenderDrawLine

SDL.Import

** * Draw a line on the current rendering target. * * renderer The renderer which should draw a line. * x1 The x coordinate of the start point. * y1 The y coordinate of the start point. * x2 The x coordinate of the end point. * y2 The y coordinate of the end point. * * 0 on success, or -1 on error *

SDL_RenderDrawLines

SDL.Import

** * \brief Draw a series of connected lines on the current rendering target. * * \param renderer The renderer which should draw multiple lines. * \param points The points along the lines * \param count The number of points, drawing count-1 lines * * \return 0 on success, or -1 on error *

SDL_RenderDrawPoint

SDL.Import

** * Draw a point on the current rendering target. * * renderer The renderer which should draw a point. * x The x coordinate of the point. * y The y coordinate of the point. * * 0 on success, or -1 on error *

SDL_RenderDrawPoints

SDL.Import

** * Draw multiple points on the current rendering target. * * renderer The renderer which should draw multiple points. * points The points to draw * count The number of points to draw * * 0 on success, or -1 on error *

SDL_RenderDrawRect

SDL.Import

** * Draw a rectangle on the current rendering target. * * renderer The renderer which should draw a rectangle. * rect A pointer to the destination rectangle, or NULL to outline the entire rendering target. * * 0 on success, or -1 on error *

SDL_RenderDrawRects

SDL.Import

** * Draw some number of rectangles on the current rendering target. * * renderer The renderer which should draw multiple rectangles. * rects A pointer to an array of destination rectangles. * count The number of rectangles. * * 0 on success, or -1 on error *

SDL_RENDERER_ACCELERATED

SDL.Import

**< The renderer is a software fallback *

SDL_RENDERER_PRESENTVSYNC

SDL.Import

**< The renderer uses hardware acceleration *

SDL_RENDERER_SOFTWARE

SDL.Import

** * Flags used when creating a rendering context *

SDL_RENDERER_TARGETTEXTURE

SDL.Import

**< Present is synchronized with the refresh rate *

SDL_RenderFillRect

SDL.Import

** * Fill a rectangle on the current rendering target with the drawing color. * * renderer The renderer which should fill a rectangle. * rect A pointer to the destination rectangle, or NULL for the entire * rendering target. * * 0 on success, or -1 on error *

SDL_RenderFillRects

SDL.Import

** * Fill some number of rectangles on the current rendering target with the drawing color. * * renderer The renderer which should fill multiple rectangles. * rects A pointer to an array of destination rectangles. * count The number of rectangles. * * 0 on success, or -1 on error *

SDL_RenderGetClipRect

SDL.Import

** * Get the clip rectangle for the current target. * * renderer The renderer from which clip rectangle should be queried. * rect A pointer filled in with the current clip rectangle, or * an empty rectangle if clipping is disabled. * * SDL_RenderSetClipRect() *

SDL_RenderGetLogicalSize

SDL.Import

** * Get device independent resolution for rendering * * renderer The renderer from which resolution should be queried. * w A pointer filled with the width of the logical resolution * h A pointer filled with the height of the logical resolution * * SDL_RenderSetLogicalSize() *

SDL_RenderGetScale

SDL.Import

** * Get the drawing scale for the current target. * * renderer The renderer from which drawing scale should be queried. * scaleX A pointer filled in with the horizontal scaling factor * scaleY A pointer filled in with the vertical scaling factor * * SDL_RenderSetScale() *

SDL_RenderGetViewport

SDL.Import

** * Get the drawing area for the current target. * * SDL_RenderSetViewport() *

SDL_RenderPresent

SDL.Import

** * Update the screen with rendering performed. *

SDL_RenderReadPixels

SDL.Import

** * Read pixels from the current rendering target. * * renderer The renderer from which pixels should be read. * rect A pointer to the rectangle to read, or NULL for the entire * render target. * format The desired format of the pixel data, or 0 to use the format * of the rendering target * pixels A pointer to be filled in with the pixel data * pitch The pitch of the pixels parameter. * * 0 on success, or -1 if pixel reading is not supported. * * This is a very slow operation, and should not be used frequently. *

SDL_RenderSetClipRect

SDL.Import

** * Set the clip rectangle for the current target. * * renderer The renderer for which clip rectangle should be set. * rect A pointer to the rectangle to set as the clip rectangle, or * NULL to disable clipping. * * 0 on success, or -1 on error * * SDL_RenderGetClipRect() *

SDL_RenderSetLogicalSize

SDL.Import

** * Set device independent resolution for rendering * * renderer The renderer for which resolution should be set. * w The width of the logical resolution * h The height of the logical resolution * * This function uses the viewport and scaling functionality to allow a fixed logical * resolution for rendering, regardless of the actual output resolution. If the actual * output resolution doesn't have the same aspect ratio the output rendering will be * centered within the output display. * * If the output display is a window, mouse events in the window will be filtered * and scaled so they seem to arrive within the logical resolution. * * If this function results in scaling or subpixel drawing by the * rendering backend, it will be handled using the appropriate * quality hints. * * SDL_RenderGetLogicalSize() * SDL_RenderSetScale() * SDL_RenderSetViewport() *

SDL_RenderSetScale

SDL.Import

** * Set the drawing scale for rendering on the current target. * * renderer The renderer for which the drawing scale should be set. * scaleX The horizontal scaling factor * scaleY The vertical scaling factor * * The drawing coordinates are scaled by the x/y scaling factors * before they are used by the renderer. This allows resolution * independent drawing with a single coordinate system. * * If this results in scaling or subpixel drawing by the * rendering backend, it will be handled using the appropriate * quality hints. For best results use integer scaling factors. * * SDL_RenderGetScale() * SDL_RenderSetLogicalSize() *

SDL_RenderSetViewport

SDL.Import

** * Set the drawing area for rendering on the current target. * * renderer The renderer for which the drawing area should be set. * rect The rectangle representing the drawing area, or NULL to set the viewport to the entire target. * * The x,y of the viewport rect represents the origin for rendering. * * 0 on success, or -1 on error * * If the window associated with the renderer is resized, the viewport is automatically reset. * * SDL_RenderGetViewport() * SDL_RenderSetLogicalSize() *

SDL_RenderTargetSupported

SDL.Import

** * Determines whether a window supports the use of render targets * * renderer The renderer that will be checked * * SDL_TRUE if supported, SDL_FALSE if not. *

SDL_RestoreWindow

SDL.Import

** * Restore the size and position of a minimized or maximized window. * * SDL_MaximizeWindow() * SDL_MinimizeWindow() *

SDL_RLEACCEL

SDL.Import

**< Surface uses preallocated memory *

SDL_RWclose

SDL.Import

SDL_RWFromConstMem

SDL.Import

SDL_RWFromFile

SDL.Import

** * RWFrom functions * * Functions to create SDL_RWops structures from various data streams. *

SDL_RWFromFP

SDL.Import

SDL_RWFromMem

SDL.Import

SDL_RWOPS_JNIFILE

SDL.Import

* Stdio file *

SDL_RWOPS_MEMORY

SDL.Import

* Android asset *

SDL_RWOPS_MEMORY_RO

SDL.Import

* Memory stream *

SDL_RWOPS_STDFILE

SDL.Import

* Win32 file *

SDL_RWOPS_UNKNOWN

SDL.Import

* RWops Types *

SDL_RWOPS_WINFILE

SDL.Import

* Unknown stream type *

SDL_RWread

SDL.Import

SDL_RWseek

SDL.Import

SDL_RWsize

SDL.Import

** * Read/write macros * * Macros to easily read and write from an SDL_RWops structure. *

SDL_RWtell

SDL.Import

SDL_RWwrite

SDL.Import

SDL_SaveAllDollarTemplates

SDL.Import

** * Save all currently loaded Dollar Gesture templates * * *

SDL_SaveBMP

SDL.Import

** * Save a surface to a file. * * Convenience macro. *

SDL_SaveBMP_RW

SDL.Import

** * Save a surface to a seekable SDL data stream (memory or file). * * If freedst is non-zero, the stream will be closed after being written. * * 0 if successful or -1 if there was an error. *

SDL_SaveDollarTemplate

SDL.Import

** * Save a currently loaded Dollar Gesture template * * *

SDL_SCANCODE_0

SDL.Import

SDL_SCANCODE_1

SDL.Import

SDL_SCANCODE_2

SDL.Import

SDL_SCANCODE_3

SDL.Import

SDL_SCANCODE_4

SDL.Import

SDL_SCANCODE_5

SDL.Import

SDL_SCANCODE_6

SDL.Import

SDL_SCANCODE_7

SDL.Import

SDL_SCANCODE_8

SDL.Import

SDL_SCANCODE_9

SDL.Import

SDL_SCANCODE_A

SDL.Import

** * Usage page $07 * * These values are from usage page $07 (USB keyboard page). *

SDL_SCANCODE_AC_BACK

SDL.Import

SDL_SCANCODE_AC_BOOKMARKS

SDL.Import

SDL_SCANCODE_AC_FORWARD

SDL.Import

SDL_SCANCODE_AC_HOME

SDL.Import

SDL_SCANCODE_AC_REFRESH

SDL.Import

SDL_SCANCODE_AC_SEARCH

SDL.Import

SDL_SCANCODE_AC_STOP

SDL.Import

SDL_SCANCODE_AGAIN

SDL.Import

SDL_SCANCODE_ALTERASE

SDL.Import

**< reserved *

SDL_SCANCODE_APOSTROPHE

SDL.Import

SDL_SCANCODE_APP1

SDL.Import

SDL_SCANCODE_APP2

SDL.Import

SDL_SCANCODE_APPLICATION

SDL.Import

**< This is the additional key that ISO * keyboards have over ANSI ones; * located between left shift and Y. * Produces GRAVE ACCENT and TILDE in a * US or UK Mac layout; REVERSE SOLIDUS * (backslash) and VERTICAL LINE in a * US or UK Windows layout; and * LESS-THAN SIGN and GREATER-THAN SIGN * in a Swiss German; German; or French * layout. *

SDL_SCANCODE_AUDIOMUTE

SDL.Import

SDL_SCANCODE_AUDIONEXT

SDL.Import

** * Usage page $0C * * These values are mapped from usage page $0C (USB consumer page). *

SDL_SCANCODE_AUDIOPLAY

SDL.Import

SDL_SCANCODE_AUDIOPREV

SDL.Import

SDL_SCANCODE_AUDIOSTOP

SDL.Import

SDL_SCANCODE_B

SDL.Import

SDL_SCANCODE_BACKSLASH

SDL.Import

SDL_SCANCODE_BACKSPACE

SDL.Import

SDL_SCANCODE_BRIGHTNESSDOWN

SDL.Import

** * Walther keys * * These are values that Christian Walther added (for mac keyboard?). *

SDL_SCANCODE_BRIGHTNESSUP

SDL.Import

SDL_SCANCODE_C

SDL.Import

SDL_SCANCODE_CALCULATOR

SDL.Import

SDL_SCANCODE_CANCEL

SDL.Import

SDL_SCANCODE_CAPSLOCK

SDL.Import

SDL_SCANCODE_CLEAR

SDL.Import

SDL_SCANCODE_CLEARAGAIN

SDL.Import

SDL_SCANCODE_COMMA

SDL.Import

**< Located in the top left corner (on both ANSI * and ISO keyboards). Produces GRAVE ACCENT and * TILDE in a US Windows layout and in US and UK * Mac layouts on ANSI keyboards; GRAVE ACCENT * and NOT SIGN in a UK Windows layout; SECTION * SIGN and PLUS-MINUS SIGN in US and UK Mac * layouts on ISO keyboards; SECTION SIGN and * DEGREE SIGN in a Swiss German layout (Mac: * only on ISO keyboards); CIRCUMFLEX ACCENT and * DEGREE SIGN in a German layout (Mac: only on * ISO keyboards); SUPERSCRIPT TWO and TILDE in a * French Windows layout; COMMERCIAL AT and * NUMBER SIGN in a French Mac layout on ISO * keyboards; and LESS-THAN SIGN and GREATER-THAN * SIGN in a Swiss German; German; or French Mac * layout on ANSI keyboards. *

SDL_SCANCODE_COMPUTER

SDL.Import

SDL_SCANCODE_COPY

SDL.Import

SDL_SCANCODE_CRSEL

SDL.Import

SDL_SCANCODE_CURRENCYSUBUNIT

SDL.Import

SDL_SCANCODE_CURRENCYUNIT

SDL.Import

SDL_SCANCODE_CUT

SDL.Import

SDL_SCANCODE_D

SDL.Import

SDL_SCANCODE_DECIMALSEPARATOR

SDL.Import

SDL_SCANCODE_DELETE

SDL.Import

SDL_SCANCODE_DISPLAYSWITCH

SDL.Import

SDL_SCANCODE_DOWN

SDL.Import

SDL_SCANCODE_E

SDL.Import

SDL_SCANCODE_EJECT

SDL.Import

SDL_SCANCODE_END

SDL.Import

SDL_SCANCODE_EQUALS

SDL.Import

SDL_SCANCODE_ESCAPE

SDL.Import

SDL_SCANCODE_EXECUTE

SDL.Import

SDL_SCANCODE_EXSEL

SDL.Import

SDL_SCANCODE_F

SDL.Import

SDL_SCANCODE_F1

SDL.Import

SDL_SCANCODE_F10

SDL.Import

SDL_SCANCODE_F11

SDL.Import

SDL_SCANCODE_F12

SDL.Import

SDL_SCANCODE_F13

SDL.Import

SDL_SCANCODE_F14

SDL.Import

SDL_SCANCODE_F15

SDL.Import

SDL_SCANCODE_F16

SDL.Import

SDL_SCANCODE_F17

SDL.Import

SDL_SCANCODE_F18

SDL.Import

SDL_SCANCODE_F19

SDL.Import

SDL_SCANCODE_F2

SDL.Import

SDL_SCANCODE_F20

SDL.Import

SDL_SCANCODE_F21

SDL.Import

SDL_SCANCODE_F22

SDL.Import

SDL_SCANCODE_F23

SDL.Import

SDL_SCANCODE_F24

SDL.Import

SDL_SCANCODE_F3

SDL.Import

SDL_SCANCODE_F4

SDL.Import

SDL_SCANCODE_F5

SDL.Import

SDL_SCANCODE_F6

SDL.Import

SDL_SCANCODE_F7

SDL.Import

SDL_SCANCODE_F8

SDL.Import

SDL_SCANCODE_F9

SDL.Import

SDL_SCANCODE_FIND

SDL.Import

SDL_SCANCODE_G

SDL.Import

SDL_SCANCODE_GRAVE

SDL.Import

SDL_SCANCODE_H

SDL.Import

SDL_SCANCODE_HELP

SDL.Import

SDL_SCANCODE_HOME

SDL.Import

**< insert on PC; help on some Mac keyboards (but does send code 73; not 117) *

SDL_SCANCODE_I

SDL.Import

SDL_SCANCODE_INSERT

SDL.Import

SDL_SCANCODE_INTERNATIONAL1

SDL.Import

SDL_SCANCODE_INTERNATIONAL2

SDL.Import

**< used on Asian keyboards; see footnotes in USB doc *

SDL_SCANCODE_INTERNATIONAL3

SDL.Import

SDL_SCANCODE_INTERNATIONAL4

SDL.Import

**< Yen *

SDL_SCANCODE_INTERNATIONAL5

SDL.Import

SDL_SCANCODE_INTERNATIONAL6

SDL.Import

SDL_SCANCODE_INTERNATIONAL7

SDL.Import

SDL_SCANCODE_INTERNATIONAL8

SDL.Import

SDL_SCANCODE_INTERNATIONAL9

SDL.Import

SDL_SCANCODE_J

SDL.Import

SDL_SCANCODE_K

SDL.Import

SDL_SCANCODE_KBDILLUMDOWN

SDL.Import

SDL_SCANCODE_KBDILLUMTOGGLE

SDL.Import

**< display mirroring{dual display switch; video mode switch *

SDL_SCANCODE_KBDILLUMUP

SDL.Import

SDL_SCANCODE_KP_0

SDL.Import

SDL_SCANCODE_KP_00

SDL.Import

SDL_SCANCODE_KP_000

SDL.Import

SDL_SCANCODE_KP_1

SDL.Import

SDL_SCANCODE_KP_2

SDL.Import

SDL_SCANCODE_KP_3

SDL.Import

SDL_SCANCODE_KP_4

SDL.Import

SDL_SCANCODE_KP_5

SDL.Import

SDL_SCANCODE_KP_6

SDL.Import

SDL_SCANCODE_KP_7

SDL.Import

SDL_SCANCODE_KP_8

SDL.Import

SDL_SCANCODE_KP_9

SDL.Import

SDL_SCANCODE_KP_A

SDL.Import

SDL_SCANCODE_KP_AMPERSAND

SDL.Import

SDL_SCANCODE_KP_AT

SDL.Import

SDL_SCANCODE_KP_B

SDL.Import

SDL_SCANCODE_KP_BACKSPACE

SDL.Import

SDL_SCANCODE_KP_BINARY

SDL.Import

SDL_SCANCODE_KP_C

SDL.Import

SDL_SCANCODE_KP_CLEAR

SDL.Import

SDL_SCANCODE_KP_CLEARENTRY

SDL.Import

SDL_SCANCODE_KP_COLON

SDL.Import

SDL_SCANCODE_KP_COMMA

SDL.Import

* SDL_SCANCODE_LOCKINGSCROLLLOCK = 132; *

SDL_SCANCODE_KP_D

SDL.Import

SDL_SCANCODE_KP_DBLAMPERSAND

SDL.Import

SDL_SCANCODE_KP_DBLVERTICALBAR

SDL.Import

SDL_SCANCODE_KP_DECIMAL

SDL.Import

SDL_SCANCODE_KP_DIVIDE

SDL.Import

**< num lock on PC; clear on Mac keyboards *

SDL_SCANCODE_KP_E

SDL.Import

SDL_SCANCODE_KP_ENTER

SDL.Import

SDL_SCANCODE_KP_EQUALS

SDL.Import

**< The USB document says this is a status flag; * not a physical key - but some Mac keyboards * do have a power key. *

SDL_SCANCODE_KP_EQUALSAS400

SDL.Import

SDL_SCANCODE_KP_EXCLAM

SDL.Import

SDL_SCANCODE_KP_F

SDL.Import

SDL_SCANCODE_KP_GREATER

SDL.Import

SDL_SCANCODE_KP_HASH

SDL.Import

SDL_SCANCODE_KP_HEXADECIMAL

SDL.Import

SDL_SCANCODE_KP_LEFTBRACE

SDL.Import

SDL_SCANCODE_KP_LEFTPAREN

SDL.Import

SDL_SCANCODE_KP_LESS

SDL.Import

SDL_SCANCODE_KP_MEMADD

SDL.Import

SDL_SCANCODE_KP_MEMCLEAR

SDL.Import

SDL_SCANCODE_KP_MEMDIVIDE

SDL.Import

SDL_SCANCODE_KP_MEMMULTIPLY

SDL.Import

SDL_SCANCODE_KP_MEMRECALL

SDL.Import

SDL_SCANCODE_KP_MEMSTORE

SDL.Import

SDL_SCANCODE_KP_MEMSUBTRACT

SDL.Import

SDL_SCANCODE_KP_MINUS

SDL.Import

SDL_SCANCODE_KP_MULTIPLY

SDL.Import

SDL_SCANCODE_KP_OCTAL

SDL.Import

SDL_SCANCODE_KP_PERCENT

SDL.Import

SDL_SCANCODE_KP_PERIOD

SDL.Import

SDL_SCANCODE_KP_PLUS

SDL.Import

SDL_SCANCODE_KP_PLUSMINUS

SDL.Import

SDL_SCANCODE_KP_POWER

SDL.Import

SDL_SCANCODE_KP_RIGHTBRACE

SDL.Import

SDL_SCANCODE_KP_RIGHTPAREN

SDL.Import

SDL_SCANCODE_KP_SPACE

SDL.Import

SDL_SCANCODE_KP_TAB

SDL.Import

SDL_SCANCODE_KP_VERTICALBAR

SDL.Import

SDL_SCANCODE_KP_XOR

SDL.Import

SDL_SCANCODE_L

SDL.Import

SDL_SCANCODE_LALT

SDL.Import

SDL_SCANCODE_LANG1

SDL.Import

SDL_SCANCODE_LANG2

SDL.Import

**< Hangul{English toggle *

SDL_SCANCODE_LANG3

SDL.Import

**< Hanja conversion *

SDL_SCANCODE_LANG4

SDL.Import

**< Katakana *

SDL_SCANCODE_LANG5

SDL.Import

**< Hiragana *

SDL_SCANCODE_LANG6

SDL.Import

**< Zenkaku{Hankaku *

SDL_SCANCODE_LANG7

SDL.Import

**< reserved *

SDL_SCANCODE_LANG8

SDL.Import

**< reserved *

SDL_SCANCODE_LANG9

SDL.Import

**< reserved *

SDL_SCANCODE_LCTRL

SDL.Import

SDL_SCANCODE_LEFT

SDL.Import

SDL_SCANCODE_LEFTBRACKET

SDL.Import

SDL_SCANCODE_LGUI

SDL.Import

**< alt; option *

SDL_SCANCODE_LSHIFT

SDL.Import

SDL_SCANCODE_M

SDL.Import

SDL_SCANCODE_MAIL

SDL.Import

SDL_SCANCODE_MEDIASELECT

SDL.Import

SDL_SCANCODE_MENU

SDL.Import

SDL_SCANCODE_MINUS

SDL.Import

SDL_SCANCODE_MODE

SDL.Import

**< windows; command (apple); meta *

SDL_SCANCODE_MUTE

SDL.Import

SDL_SCANCODE_N

SDL.Import

SDL_SCANCODE_NONUSBACKSLASH

SDL.Import

SDL_SCANCODE_NONUSHASH

SDL.Import

**< Located at the lower left of the return * key on ISO keyboards and at the right end * of the QWERTY row on ANSI keyboards. * Produces REVERSE SOLIDUS (backslash) and * VERTICAL LINE in a US layout; REVERSE * SOLIDUS and VERTICAL LINE in a UK Mac * layout; NUMBER SIGN and TILDE in a UK * Windows layout; DOLLAR SIGN and POUND SIGN * in a Swiss German layout; NUMBER SIGN and * APOSTROPHE in a German layout; GRAVE * ACCENT and POUND SIGN in a French Mac * layout; and ASTERISK and MICRO SIGN in a * French Windows layout. *

SDL_SCANCODE_NUMLOCKCLEAR

SDL.Import

SDL_SCANCODE_O

SDL.Import

SDL_SCANCODE_OPER

SDL.Import

SDL_SCANCODE_OUT

SDL.Import

SDL_SCANCODE_P

SDL.Import

SDL_SCANCODE_PAGEDOWN

SDL.Import

SDL_SCANCODE_PAGEUP

SDL.Import

SDL_SCANCODE_PASTE

SDL.Import

SDL_SCANCODE_PAUSE

SDL.Import

SDL_SCANCODE_PERIOD

SDL.Import

SDL_SCANCODE_POWER

SDL.Import

**< windows contextual menu; compose *

SDL_SCANCODE_PRINTSCREEN

SDL.Import

SDL_SCANCODE_PRIOR

SDL.Import

SDL_SCANCODE_Q

SDL.Import

SDL_SCANCODE_R

SDL.Import

SDL_SCANCODE_RALT

SDL.Import

SDL_SCANCODE_RCTRL

SDL.Import

**< windows; command (apple); meta *

SDL_SCANCODE_RETURN

SDL.Import

SDL_SCANCODE_RETURN2

SDL.Import

SDL_SCANCODE_RGUI

SDL.Import

**< alt gr; option *

SDL_SCANCODE_RIGHT

SDL.Import

SDL_SCANCODE_RIGHTBRACKET

SDL.Import

SDL_SCANCODE_RSHIFT

SDL.Import

SDL_SCANCODE_S

SDL.Import

SDL_SCANCODE_SCROLLLOCK

SDL.Import

SDL_SCANCODE_SELECT

SDL.Import

SDL_SCANCODE_SEMICOLON

SDL.Import

**< ISO USB keyboards actually use this code * instead of 49 for the same key; but all * OSes I've seen treat the two codes * identically. So; as an implementor; unless * your keyboard generates both of those * codes and your OS treats them differently; * you should generate SDL_SCANCODE_BACKSLASH * instead of this code. As a user; you * should not rely on this code because SDL * will never generate it with most (all?) * keyboards. *

SDL_SCANCODE_SEPARATOR

SDL.Import

SDL_SCANCODE_SLASH

SDL.Import

SDL_SCANCODE_SLEEP

SDL.Import

SDL_SCANCODE_SPACE

SDL.Import

SDL_SCANCODE_STOP

SDL.Import

SDL_SCANCODE_SYSREQ

SDL.Import

**< Erase-Eaze *

SDL_SCANCODE_T

SDL.Import

SDL_SCANCODE_TAB

SDL.Import

SDL_SCANCODE_THOUSANDSSEPARATOR

SDL.Import

SDL_SCANCODE_U

SDL.Import

SDL_SCANCODE_UNDO

SDL.Import

**< redo *

SDL_SCANCODE_UNKNOWN

SDL.Import

** * The SDL keyboard scancode representation. * * Values of this type are used to represent keyboard keys, among other places * in the SDL_Keysym.scancode key.keysym.scancode \endlink field of the * SDL_Event structure. * * The values in this enumeration are based on the USB usage page standard: * http://www.usb.org/developers/devclass_docs/Hut1_12v2.pdf *

SDL_SCANCODE_UP

SDL.Import

SDL_SCANCODE_V

SDL.Import

SDL_SCANCODE_VOLUMEDOWN

SDL.Import

SDL_SCANCODE_VOLUMEUP

SDL.Import

SDL_SCANCODE_W

SDL.Import

SDL_SCANCODE_WWW

SDL.Import

SDL_SCANCODE_X

SDL.Import

SDL_SCANCODE_Y

SDL.Import

SDL_SCANCODE_Z

SDL.Import

SDL_SemPost

SDL.Import

** * Atomically increases the semaphore's count (not blocking). * * 0, or -1 on error. *

SDL_SemTryWait

SDL.Import

** * Non-blocking variant of SDL_SemWait(). * * 0 if the wait succeeds, SDL_MUTEX_TIMEDOUT if the wait would * block, and -1 on error. *

SDL_SemValue

SDL.Import

** * Returns the current count of the semaphore. *

SDL_SemWait

SDL.Import

** * This function suspends the calling thread until the semaphore pointed * to by sem has a positive count. It then atomically decreases the * semaphore count. *

SDL_SemWaitTimeout

SDL.Import

** * Variant of SDL_SemWait() with a timeout in milliseconds. * * 0 if the wait succeeds, ::SDL_MUTEX_TIMEDOUT if the wait does not * succeed in the allotted time, and -1 on error. * * On some platforms this function is implemented by looping with a * delay of 1 ms, and so should be avoided if possible. *

SDL_SetClipRect

SDL.Import

** * Sets the clipping rectangle for the destination surface in a blit. * * If the clip rectangle is NULL, clipping will be disabled. * * If the clip rectangle doesn't intersect the surface, the function will * return SDL_FALSE and blits will be completely clipped. Otherwise the * function returns SDL_TRUE and blits to the surface will be clipped to * the intersection of the surface area and the clipping rectangle. * * Note that blits are automatically clipped to the edges of the source * and destination surfaces. *

SDL_SetColorKey

SDL.Import

** * Sets the color key (transparent pixel) in a blittable surface. * * surface The surface to update * flag Non-zero to enable colorkey and 0 to disable colorkey * key The transparent pixel in the native surface format * * 0 on success, or -1 if the surface is not valid * * You can pass SDL_RLEACCEL to enable RLE accelerated blits. *

SDL_SetCursor

SDL.Import

** * Set the active cursor. *

SDL_SetError

SDL.Import

* SDL_SetError() unconditionally returns -1. *

SDL_SetEventFilter

SDL.Import

** * Sets up a filter to process all events before they change internal state and * are posted to the internal event queue. * * If the filter returns 1, then the event will be added to the internal queue. * If it returns 0, then the event will be dropped from the queue, but the * internal state will still be updated. This allows selective filtering of * dynamically arriving events. * * Be very careful of what you do in the event filter function, as * it may run in a different thread! * * There is one caveat when dealing with the SDL_QUITEVENT event type. The * event filter is only called when the window manager desires to close the * application window. If the event filter returns 1, then the window will * be closed, otherwise the window will remain open if possible. * * If the quit event is generated by an interrupt signal, it will bypass the * internal queue and be delivered to the application at the next event poll. *

SDL_SetHint

SDL.Import

/** * \brief Set a hint with normal priority * * \return SDL_TRUE if the hint was set, SDL_FALSE otherwise */

SDL_SetHintWithPriority

SDL.Import

/** * \brief Set a hint with a specific priority * * The priority controls the behavior when setting a hint that already * has a value. Hints will replace existing hints of their priority and * lower. Environment variables are considered to have override priority. * * \return SDL_TRUE if the hint was set, SDL_FALSE otherwise */

SDL_SetModState

SDL.Import

** * Set the current key modifier state for the keyboard. * * This does not change the keyboard state, only the key modifier flags. *

SDL_SetPaletteColors

SDL.Import

** * Set a range of colors in a palette. * * palette The palette to modify. * colors An array of colors to copy into the palette. * firstcolor The index of the first palette entry to modify. * ncolors The number of entries to modify. * * 0 on success, or -1 if not all of the colors could be set. *

SDL_SetPixelFormatPalette

SDL.Import

** * Set the palette for a pixel format structure. *

SDL_SetRelativeMouseMode

SDL.Import

** * Set relative mouse mode. * * enabled Whether or not to enable relative mode * * 0 on success, or -1 if relative mode is not supported. * * While the mouse is in relative mode, the cursor is hidden, and the * driver will try to report continuous motion in the current window. * Only relative motion events will be delivered, the mouse position * will not change. * * This function will flush any pending mouse motion. * * SDL_GetRelativeMouseMode() *

SDL_SetRenderDrawBlendMode

SDL.Import

** * Set the blend mode used for drawing operations (Fill and Line). * * renderer The renderer for which blend mode should be set. * blendMode SDL_BlendMode to use for blending. * * 0 on success, or -1 on error * * If the blend mode is not supported, the closest supported mode is * chosen. * * SDL_GetRenderDrawBlendMode() *

SDL_SetRenderDrawColor

SDL.Import

** * Set the color used for drawing operations (Rect, Line and Clear). * * renderer The renderer for which drawing color should be set. * r The red value used to draw on the rendering target. * g The green value used to draw on the rendering target. * b The blue value used to draw on the rendering target. * a The alpha value used to draw on the rendering target, usually * SDL_ALPHA_OPAQUE (255). * * 0 on success, or -1 on error *

SDL_SetRenderTarget

SDL.Import

** * Set a texture as the current rendering target. * * renderer The renderer. * texture The targeted texture, which must be created with the SDL_TEXTUREACCESS_TARGET flag, or NULL for the default render target * * 0 on success, or -1 on error * * SDL_GetRenderTarget() *

SDL_SetSurfaceAlphaMod

SDL.Import

** * Set an additional alpha value used in blit operations. * * surface The surface to update. * alpha The alpha value multiplied into blit operations. * * 0 on success, or -1 if the surface is not valid. * * SDL_GetSurfaceAlphaMod() *

SDL_SetSurfaceBlendMode

SDL.Import

** * Set the blend mode used for blit operations. * * surface The surface to update. * blendMode ::SDL_BlendMode to use for blit blending. * * 0 on success, or -1 if the parameters are not valid. * * SDL_GetSurfaceBlendMode() *

SDL_SetSurfaceColorMod

SDL.Import

** * Set an additional color value used in blit operations. * * surface The surface to update. * r The red color value multiplied into blit operations. * g The green color value multiplied into blit operations. * b The blue color value multiplied into blit operations. * * 0 on success, or -1 if the surface is not valid. * * SDL_GetSurfaceColorMod() *

SDL_SetSurfacePalette

SDL.Import

** * Set the palette used by a surface. * * 0, or -1 if the surface format doesn't use a palette. * * A single palette can be shared with many surfaces. *

SDL_SetSurfaceRLE

SDL.Import

** * Sets the RLE acceleration hint for a surface. * * 0 on success, or -1 if the surface is not valid * * If RLE is enabled, colorkey and alpha blending blits are much faster, * but the surface must be locked before directly accessing the pixels. *

SDL_SetTextInputRect

SDL.Import

** * Set the rectangle used to type Unicode text inputs. * This is used as a hint for IME and on-screen keyboard placement. * * SDL_StartTextInput() *

SDL_SetTextureAlphaMod

SDL.Import

** * Set an additional alpha value used in render copy operations. * * texture The texture to update. * alpha The alpha value multiplied into copy operations. * * 0 on success, or -1 if the texture is not valid or alpha modulation * is not supported. * * SDL_GetTextureAlphaMod() *

SDL_SetTextureBlendMode

SDL.Import

** * Set the blend mode used for texture copy operations. * * texture The texture to update. * blendMode ::SDL_BlendMode to use for texture blending. * * 0 on success, or -1 if the texture is not valid or the blend mode is * not supported. * * If the blend mode is not supported, the closest supported mode is * chosen. * * SDL_GetTextureBlendMode() *

SDL_SetTextureColorMod

SDL.Import

** * Set an additional color value used in render copy operations. * * texture The texture to update. * r The red color value multiplied into copy operations. * g The green color value multiplied into copy operations. * b The blue color value multiplied into copy operations. * * 0 on success, or -1 if the texture is not valid or color modulation * is not supported. * * SDL_GetTextureColorMod() *

SDL_SetThreadPriority

SDL.Import

** * Set the priority for the current thread *

SDL_SetWindowBordered

SDL.Import

** * Set the border state of a window. * * This will add or remove the window's SDL_WINDOW_BORDERLESS flag and * add or remove the border from the actual window. This is a no-op if the * window's border already matches the requested state. * * window The window of which to change the border state. * bordered SDL_FALSE to remove border, SDL_TRUE to add border. * * You can't change the border state of a fullscreen window. * * SDL_GetWindowFlags() *

SDL_SetWindowBrightness

SDL.Import

** * Set the brightness (gamma correction) for a window. * * 0 on success, or -1 if setting the brightness isn't supported. * * SDL_GetWindowBrightness() * SDL_SetWindowGammaRamp() *

SDL_SetWindowData

SDL.Import

** * Associate an arbitrary named pointer with a window. * * window The window to associate with the pointer. * name The name of the pointer. * userdata The associated pointer. * * The previous value associated with 'name' * * The name is case-sensitive. * * SDL_GetWindowData() *

SDL_SetWindowDisplayMode

SDL.Import

** * Set the display mode used when a fullscreen window is visible. * * By default the window's dimensions and the desktop format and refresh rate * are used. * * mode The mode to use, or nil for the default mode. * * 0 on success, or -1 if setting the display mode failed. * * SDL_GetWindowDisplayMode() * SDL_SetWindowFullscreen() *

SDL_SetWindowFullscreen

SDL.Import

** * Set a window's fullscreen state. * * 0 on success, or -1 if setting the display mode failed. * * SDL_SetWindowDisplayMode() * SDL_GetWindowDisplayMode() *

SDL_SetWindowGammaRamp

SDL.Import

** * Set the gamma ramp for a window. * * red The translation table for the red channel, or nil. * green The translation table for the green channel, or nil. * blue The translation table for the blue channel, or nil. * * 0 on success, or -1 if gamma ramps are unsupported. * * Set the gamma translation table for the red, green, and blue channels * of the video hardware. Each table is an array of 256 16-bit quantities, * representing a mapping between the input and output for that channel. * The input is the index into the array, and the output is the 16-bit * gamma value at that index, scaled to the output color precision. * * SDL_GetWindowGammaRamp() *

SDL_SetWindowGrab

SDL.Import

** * Set a window's input grab mode. * * grabbed This is SDL_TRUE to grab input, and SDL_FALSE to release input. * * SDL_GetWindowGrab() *

SDL_SetWindowIcon

SDL.Import

** * Set the icon for a window. * * icon The icon for the window. *

SDL_SetWindowMaximumSize

SDL.Import

** * Set the maximum size of a window's client area. * * max_w The maximum width of the window, must be >0 * max_h The maximum height of the window, must be >0 * * You can't change the maximum size of a fullscreen window, it * automatically matches the size of the display mode. * * SDL_GetWindowMaximumSize() * SDL_SetWindowMinimumSize() *

SDL_SetWindowMinimumSize

SDL.Import

** * Set the minimum size of a window's client area. * * min_w The minimum width of the window, must be >0 * min_h The minimum height of the window, must be >0 * * You can't change the minimum size of a fullscreen window, it * automatically matches the size of the display mode. * * SDL_GetWindowMinimumSize() * SDL_SetWindowMaximumSize() *

SDL_SetWindowPosition

SDL.Import

** * Set the position of a window. * * window The window to reposition. * x The x coordinate of the window, SDL_WINDOWPOS_CENTERED, or * SDL_WINDOWPOS_UNDEFINED. * y The y coordinate of the window, SDL_WINDOWPOS_CENTERED, or * SDL_WINDOWPOS_UNDEFINED. * * The window coordinate origin is the upper left of the display. * * SDL_GetWindowPosition() *

SDL_SetWindowShape

SDL.Import

** * Set the shape and parameters of a shaped window. * * window The shaped window whose parameters should be set. * shape A surface encoding the desired shape for the window. * shape_mode The parameters to set for the shaped window. * * 0 on success, SDL_INVALID_SHAPE_ARGUMENT on invalid an invalid shape argument, or SDL_NONSHAPEABLE_WINDOW * if the SDL_Window* given does not reference a valid shaped window. * * SDL_WindowShapeMode * SDL_GetShapedWindowMode. *

SDL_SetWindowSize

SDL.Import

** * Set the size of a window's client area. * * w The width of the window, must be >0 * h The height of the window, must be >0 * * You can't change the size of a fullscreen window, it automatically * matches the size of the display mode. * * SDL_GetWindowSize() *

SDL_SetWindowTitle

SDL.Import

** * Set the title of a window, in UTF-8 format. * * SDL_GetWindowTitle() *

SDL_ShowCursor

SDL.Import

** * Toggle whether or not the cursor is shown. * * toggle 1 to show the cursor, 0 to hide it, -1 to query the current * state. * * 1 if the cursor is shown, or 0 if the cursor is hidden. *

SDL_ShowMessageBox

SDL.Import

** * Create a modal message box. * * messageboxdata The SDL_MessageBoxData structure with title, text, etc. * buttonid The pointer to which user id of hit button should be copied. * * -1 on error, otherwise 0 and buttonid contains user id of button * hit or -1 if dialog was closed. * * This function should be called on the thread that created the parent * window, or on the main thread if the messagebox has no parent. It will * block execution of that thread until the user clicks a button or * closes the messagebox. *

SDL_ShowSimpleMessageBox

SDL.Import

** * Create a simple modal message box * * flags SDL_MessageBoxFlags * title UTF-8 title text * message UTF-8 message text * window The parent window, or NULL for no parent * * 0 on success, -1 on error * * SDL_ShowMessageBox *

SDL_ShowWindow

SDL.Import

** * Show a window. * * SDL_HideWindow() *

SDL_SoftStretch

SDL.Import

** * Perform a fast, low quality, stretch blit between two surfaces of the * same pixel format. * * This function uses a static buffer, and is not thread-safe. *

SDL_StartTextInput

SDL.Import

** * Start accepting Unicode text input events. * This function will show the on-screen keyboard if supported. * * SDL_StopTextInput() * SDL_SetTextInputRect() * SDL_HasScreenKeyboardSupport() *

SDL_StopTextInput

SDL.Import

** * Stop receiving any text input events. * This function will hide the on-screen keyboard if supported. * * SDL_StartTextInput() * SDL_HasScreenKeyboardSupport() *

SDL_Swap32

SDL.Import

SDL_SWSURFACE

SDL.Import

** * Surface flags * * These are the currently supported flags for the ::SDL_surface. * * Used internally (read-only). *

SDL_SYSTEM_CURSOR_ARROW

SDL.Import

** * Cursor types for SDL_CreateSystemCursor. *

SDL_SYSTEM_CURSOR_CROSSHAIR

SDL.Import

Wait

SDL_SYSTEM_CURSOR_HAND

SDL.Import

Slashed circle or crossbones

SDL_SYSTEM_CURSOR_IBEAM

SDL.Import

Arrow

SDL_SYSTEM_CURSOR_NO

SDL.Import

Four pointed arrow pointing north, south, east, and west

SDL_SYSTEM_CURSOR_SIZEALL

SDL.Import

Double arrow pointing north and south

SDL_SYSTEM_CURSOR_SIZENESW

SDL.Import

Double arrow pointing northwest and southeast

SDL_SYSTEM_CURSOR_SIZENS

SDL.Import

Double arrow pointing west and east

SDL_SYSTEM_CURSOR_SIZENWSE

SDL.Import

Small wait cursor (or Wait if not available)

SDL_SYSTEM_CURSOR_SIZEWE

SDL.Import

Double arrow pointing northeast and southwest

SDL_SYSTEM_CURSOR_WAIT

SDL.Import

I-beam

SDL_SYSTEM_CURSOR_WAITARROW

SDL.Import

Crosshair

SDL_SYSWMEVENT

SDL.Import

Window state change

SDL_TEXTEDITING

SDL.Import

Key released

SDL_TEXTEDITINGEVENT_TEXT_SIZE

SDL.Import

SDL_TEXTINPUT

SDL.Import

Keyboard text editing (composition)

SDL_TEXTINPUTEVENT_TEXT_SIZE

SDL.Import

SDL_ThreadID

SDL.Import

** * Get the thread identifier for the current thread. *

SDL_TLSCreate

SDL.Import

* * SDL_TLSGet() * SDL_TLSSet() *

SDL_TLSGet

SDL.Import

** * Get the value associated with a thread local storage ID for the current thread. * * id The thread local storage ID * * The value associated with the ID for the current thread, or NULL if no value has been set. * * SDL_TLSCreate() * SDL_TLSSet() *

SDL_TLSSet

SDL.Import

** * Set the value associated with a thread local storage ID for the current thread. * * id The thread local storage ID * value The value to associate with the ID for the current thread * destructor_ A function called when the thread exits, to free the value. * * 0 on success, -1 on error * * SDL_TLSCreate() * SDL_TLSGet() *

SDL_TOUCH_MOUSEID

SDL.Import

* Used as the device ID for mouse events simulated with touch input *

SDL_TryLockMutex

SDL.Import

** * Try to lock the mutex * * 0, SDL_MUTEX_TIMEDOUT, or -1 on error *

SDL_UnionRect

SDL.Import

** * Calculate the union of two rectangles. *

SDL_UnloadObject

SDL.Import

** * Unload a shared object from memory. *

SDL_UnlockAudio

SDL.Import

SDL_UnlockAudioDevice

SDL.Import

SDL_UnlockMutex

SDL.Import

#define SDL_mutexV(m) SDL_UnlockMutex(m)

SDL_UnlockSurface

SDL.Import

** SDL_LockSurface() *

SDL_UnlockTexture

SDL.Import

** * Unlock a texture, uploading the changes to video memory, if needed. * * SDL_LockTexture() *

SDL_UpdateTexture

SDL.Import

** * Update the given texture rectangle with new pixel data. * * texture The texture to update * rect A pointer to the rectangle of pixels to update, or NULL to * update the entire texture. * pixels The raw pixel data. * pitch The number of bytes between rows of pixel data. * * 0 on success, or -1 if the texture is not valid. * * This is a fairly slow function. *

SDL_UpdateWindowSurface

SDL.Import

** * Copy the window surface to the screen. * * 0 on success, or -1 on error. * * SDL_GetWindowSurface() * SDL_UpdateWindowSurfaceRects() *

SDL_UpdateWindowSurfaceRects

SDL.Import

** * Copy a number of rectangles on the window surface to the screen. * * 0 on success, or -1 on error. * * SDL_GetWindowSurface() * SDL_UpdateWindowSurfaceRect() *

SDL_UpperBlit

SDL.Import

** * This is the public blit function, SDL_BlitSurface(), and it performs * rectangle validation and clipping before passing it to SDL_LowerBlit() *

SDL_UpperBlitScaled

SDL.Import

** * This is the public scaled blit function, SDL_BlitScaled(), and it performs * rectangle validation and clipping before passing it to SDL_LowerBlitScaled() *

SDL_USEREVENT

SDL.Import

** Events SDL_USEREVENT through SDL_LASTEVENT are for your use, * and should be allocated with SDL_RegisterEvents() *

SDL_VERSION

SDL.Import

** * Macro to determine SDL version program was compiled against. * * This macro fills in a SDL_version structure with the version of the * library you compiled against. This is determined by what header the * compiler uses. Note that if you dynamically linked the library, you might * have a slightly newer or older version at runtime. That version can be * determined with SDL_GetVersion(), which, unlike SDL_VERSION(), * is not a macro. * * x A pointer to a SDL_version struct to initialize. * * SDL_version * SDL_GetVersion *

SDL_VERSIONNUM

SDL.Import

** * This macro turns the version numbers into a numeric value: * * (1,2,3) -> (1203) * * * This assumes that there will never be more than 100 patchlevels. *

SDL_VERSION_ATLEAST

SDL.Import

** * This macro will evaluate to true if compiled with SDL at least X.Y.Z. *

SDL_VideoInit

SDL.Import

** * Initialize the video subsystem, optionally specifying a video driver. * * driver_name Initialize a specific driver by name, or nil for the * default video driver. * * 0 on success, -1 on error * * This function initializes the video subsystem; setting up a connection * to the window manager, etc, and determines the available display modes * and pixel formats, but does not initialize a window or graphics mode. * * SDL_VideoQuit() *

SDL_VideoQuit

SDL.Import

** * Shuts down the video subsystem. * * function closes all windows, and restores the original video mode. * * SDL_VideoInit() *

SDL_WaitEvent

SDL.Import

** * Waits indefinitely for the next available event. * * 1, or 0 if there was an error while waiting for events. * * event - If not nil, the next event is removed from the queue and * stored in that area. *

SDL_WaitEventTimeout

SDL.Import

** * Waits until the specified timeout (in milliseconds) for the next * available event. * * 1, or 0 if there was an error while waiting for events. * * event - If not nil, the next event is removed from the queue and * stored in that area. *

SDL_WaitThread

SDL.Import

** * Wait for a thread to finish. * * The return code for the thread function is placed in the area * pointed to by status, if status is not NULL. *

SDL_WarpMouseInWindow

SDL.Import

** * Moves the mouse to the given position within the window. * * window The window to move the mouse into, or nil for the current mouse focus * x The x coordinate within the window * y The y coordinate within the window * * This function generates a mouse motion event *

SDL_WasInit

SDL.Import

** * This function returns a mask of the specified subsystems which have * previously been initialized. * * If flags is 0, it returns a mask of all initialized subsystems. *

SDL_WINDOWEVENT

SDL.Import

Window events

SDL_WINDOWEVENT_CLOSE

SDL.Import

**< Window has lost keyboard focus *

SDL_WINDOWEVENT_ENTER

SDL.Import

**< Window has been restored to normal size and position *

SDL_WINDOWEVENT_EXPOSED

SDL.Import

**< Window has been hidden *

SDL_WINDOWEVENT_FOCUS_GAINED

SDL.Import

**< Window has lost mouse focus *

SDL_WINDOWEVENT_FOCUS_LOST

SDL.Import

**< Window has gained keyboard focus *

SDL_WINDOWEVENT_HIDDEN

SDL.Import

**< Window has been shown *

SDL_WINDOWEVENT_LEAVE

SDL.Import

**< Window has gained mouse focus *

SDL_WINDOWEVENT_MAXIMIZED

SDL.Import

**< Window has been minimized *

SDL_WINDOWEVENT_MINIMIZED

SDL.Import

**< The window size has changed; either as a result of an API call or through the system or user changing the window size. *

SDL_WINDOWEVENT_MOVED

SDL.Import

**< Window has been exposed and should be redrawn *

SDL_WINDOWEVENT_NONE

SDL.Import

** * Event subtype for window events *

SDL_WINDOWEVENT_RESIZED

SDL.Import

**< Window has been moved to data1; data2 *

SDL_WINDOWEVENT_RESTORED

SDL.Import

**< Window has been maximized *

SDL_WINDOWEVENT_SHOWN

SDL.Import

**< Never used *

SDL_WINDOWEVENT_SIZE_CHANGED

SDL.Import

**< Window has been resized to data1xdata2 *

SDL_WINDOWPOS_CENTERED

SDL.Import

SDL_WINDOWPOS_CENTERED_MASK

SDL.Import

** * Used to indicate that the window position should be centered. *

SDL_WindowPos_IsCentered

SDL.Import

SDL_WindowPos_IsUndefined

SDL.Import

SDL_WINDOWPOS_UNDEFINED

SDL.Import

SDL_WINDOWPOS_UNDEFINED_MASK

SDL.Import

** * Used to indicate that you don't care what the window position is. *

SDL_WINDOW_BORDERLESS

SDL.Import

**< window is not visible *

SDL_WINDOW_FOREIGN

SDL.Import

SDL_WINDOW_FULLSCREEN

SDL.Import

** * The flags on a window * * SDL_GetWindowFlags() *

SDL_WINDOW_FULLSCREEN_DESKTOP

SDL.Import

**< window has mouse focus *

SDL_WINDOW_HIDDEN

SDL.Import

**< window is visible *

SDL_WINDOW_INPUT_FOCUS

SDL.Import

**< window has grabbed input focus *

SDL_WINDOW_INPUT_GRABBED

SDL.Import

**< window is maximized *

SDL_WINDOW_LACKS_SHAPE

SDL.Import

SDL_WINDOW_MAXIMIZED

SDL.Import

**< window is minimized *

SDL_WINDOW_MINIMIZED

SDL.Import

**< window can be resized *

SDL_WINDOW_MOUSE_FOCUS

SDL.Import

**< window has input focus *

SDL_WINDOW_OPENGL

SDL.Import

**< fullscreen window *

SDL_WINDOW_RESIZABLE

SDL.Import

**< no window decoration *

SDL_WINDOW_SHOWN

SDL.Import

**< window usable with OpenGL context *

SDL_WriteBE16

SDL.Import

SDL_WriteBE32

SDL.Import

SDL_WriteBE64

SDL.Import

SDL_WriteLE16

SDL.Import

SDL_WriteLE32

SDL.Import

SDL_WriteLE64

SDL.Import

SDL_WriteU8

SDL.Import

** * Write endian functions * * Write an item of native format to the specified endianness. *

SEARCH_ANY

Formats.VFW

SEARCH_BACKWARD

Formats.VFW

SEARCH_FORWARD

Formats.VFW

SEARCH_KEY

Formats.VFW

SEARCH_NEAREST

Formats.VFW

AVIFileExit

SegmentPlaneIntersection

GLScene.VectorGeometry

Computes segment / plane intersection return false if there isn't an intersection

SegmentSegmentClosestPoint

GLScene.VectorGeometry

Computes the closest points (2) given two segments

SegmentSegmentDistance

GLScene.VectorGeometry

Computes the closest distance between two segments

SERIALIZE_ID_BOX

Newton.Import

SERIALIZE_ID_CAPSULE

Newton.Import

SERIALIZE_ID_CHAMFERCYLINDER

Newton.Import

SERIALIZE_ID_CLOTH_PATCH

Newton.Import

SERIALIZE_ID_COMPOUND

Newton.Import

SERIALIZE_ID_CONE

Newton.Import

SERIALIZE_ID_CONVEXHULL

Newton.Import

SERIALIZE_ID_CYLINDER

Newton.Import

SERIALIZE_ID_DEFORMABLE_SOLID

Newton.Import

SERIALIZE_ID_FRACTURED_COMPOUND

Newton.Import

SERIALIZE_ID_HEIGHTFIELD

Newton.Import

SERIALIZE_ID_NULL

Newton.Import

SERIALIZE_ID_SCENE

Newton.Import

SERIALIZE_ID_SPHERE

Newton.Import

NEWTON_DEFORMABLE_BODY = 2;

SERIALIZE_ID_TREE

Newton.Import

SERIALIZE_ID_USERMESH

Newton.Import

SetAABB

GLScene.GeometryBB

SetActorCMassGlobalPosition

PhysX.Import

SetActorGlobalOrientation

PhysX.Import

SetActorGlobalPosition

PhysX.Import

SetActorMass

PhysX.Import

SetAffineVector

GLScene.VectorGeometry

SetBB

GLScene.GeometryBB

SetElementAccessAddress

CUDA.DataAccess

SetExeDirectory

GLScene.Utils

SetFullscreenMode

GLS.Screen

Changes to the video mode given by 'Index'

SetGLTextureImageClassesToStrings

GLS.Texture

Defines a TStrings with the list of registered TGLTextureImageClass.

SetMatrix

GLScene.VectorGeometry

SetMatrix

GLScene.VectorGeometry

SetMatrix

GLScene.VectorGeometry

—————————————————————————- Matrix functions —————————————————————————-

SetMatrixRow

GLScene.VectorGeometry

SetPlane

GLScene.VectorGeometry

Converts from single to double representation

SetROAMTrianglesCapacity

GLS.ROAMPatch

Specifies the maximum number of ROAM triangles that may be allocated.

SetScreenSaverPassword

GLS.ScreenSaver

Invokes the standard Windows dialog to set the password. May be invoked from your Properties/Configuration dialog.

setTransform

GLS.ODEUtils

SetupTangentSpace

GLS.BumpmapHDS

SetupVSync

GLS.SceneViewer

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SFChmutov1

GLS.Isosurface

Chmutov-surface-1 (http://mathworld.wolfram.com)

SFChmutov2

GLS.Isosurface

Chmutov-surface-2 (http://mathworld.wolfram.com)

SFDoubleTorus

GLS.Isosurface

Double torus Surface (phantasy!)

SFKleinBottle

GLS.Isosurface

Klein Bottle (http://mathworld.wolfram.com)

SFMinkowski

GLS.Isosurface

Minkowski space (http://mathworld.wolfram.com)

SFSphere

GLS.Isosurface

Sphere surface

SFToroidal

GLS.Isosurface

Toroidal surface (phantasy!)

sH2

GLS.Navigator

ShadowFilterMax3DS

Formats.m3DSConst

inclusive minimum value for shadow filter

ShadowFilterMin3DS

Formats.m3DSConst

noninclusive minimum value for shadow range SHADOW_FILTER chunk

ShadowMapSizeMin3DS

Formats.m3DSConst

noninclusive minimum value for high shadow bias setting SHADOW_MAP_SIZE chunk

ShadowRangeMin3DS

Formats.m3DSConst

noninclusive minimum value for shadow samples SHADOW_RANGE chunk

ShadowSamplesMin3DS

Formats.m3DSConst

noninclusive minimum value for shadow map size SHADOW_SAMPLES chunk

SHADOW_FILTER

Formats.m3DSConst

SHADOW_MAP_SIZE

Formats.m3DSConst

SHADOW_RANGE

Formats.m3DSConst

SHADOW_SAMPLES

Formats.m3DSConst

SHAPE_2D

Formats.m3DSConst

SHAPE_HOOK

Formats.m3DSConst

SHAPE_NOT_OK

Formats.m3DSConst

SHAPE_OK

Formats.m3DSConst

Flags in shaper AFile that tell whether polys make up an ok shape

ShiftObjectFromCenter

GLScene.VectorGeometry

ShiftObjectFromCenter

GLScene.VectorGeometry

AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced. ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center

ShortElement

CUDA.DataAccess

ShowError

Formats.m3DSUtils

error message routines

ShowErrorFormatted

Formats.m3DSUtils

ShowHTMLUrl

GLScene.Utils

SIDE_BACK

Formats.LWO

SIDE_FRONT

Formats.LWO

SIDE_FRONT_AND_BACK

Formats.LWO

SIGN

GLS.FileVfsPAK

SIGN

GLS.FileZLIB

SIGN

GLS.PAKArchive

SignStrict

GLScene.VectorGeometry

Returns the sign of the x value using the (-1, 0, +1) convention

SIGN_COMPRESSED

GLS.FileVfsPAK

Signature for uncompressed - raw pak.

SimulateNx

PhysX.Import

SinCosine

GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta

SinCosine

GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta

SinCosine

GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius

SinCosine

GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius

SInt16

SDL.Import

SInt32

SDL.Import

SInt64

SDL.Import

SInt8

SDL.Import

SizeOfFile

GLScene.Utils

Returns the size of "filename". Returns 0 (zero) is file does not exists.

size_t

SDL.Import

SMAGIC

Formats.m3DSConst

Smooth01Group3DS

Formats.m3DSConst

Smoothing group Flags used in the smootharray field of the TMesh3DS structure

Smooth02Group3DS

Formats.m3DSConst

Smooth03Group3DS

Formats.m3DSConst

Smooth04Group3DS

Formats.m3DSConst

Smooth05Group3DS

Formats.m3DSConst

Smooth06Group3DS

Formats.m3DSConst

Smooth07Group3DS

Formats.m3DSConst

Smooth08Group3DS

Formats.m3DSConst

Smooth09Group3DS

Formats.m3DSConst

Smooth10Group3DS

Formats.m3DSConst

Smooth11Group3DS

Formats.m3DSConst

Smooth12Group3DS

Formats.m3DSConst

Smooth13Group3DS

Formats.m3DSConst

Smooth14Group3DS

Formats.m3DSConst

Smooth15Group3DS

Formats.m3DSConst

Smooth16Group3DS

Formats.m3DSConst

Smooth17Group3DS

Formats.m3DSConst

Smooth18Group3DS

Formats.m3DSConst

Smooth19Group3DS

Formats.m3DSConst

Smooth20Group3DS

Formats.m3DSConst

Smooth21Group3DS

Formats.m3DSConst

Smooth22Group3DS

Formats.m3DSConst

Smooth23Group3DS

Formats.m3DSConst

Smooth24Group3DS

Formats.m3DSConst

Smooth25Group3DS

Formats.m3DSConst

Smooth26Group3DS

Formats.m3DSConst

Smooth27Group3DS

Formats.m3DSConst

Smooth28Group3DS

Formats.m3DSConst

Smooth29Group3DS

Formats.m3DSConst

Smooth30Group3DS

Formats.m3DSConst

Smooth31Group3DS

Formats.m3DSConst

Smooth32Group3DS

Formats.m3DSConst

SMOOTH_GROUP

Formats.m3DSConst

SMOOTH_GROUP_ENTRY

Formats.m3DSConst

Smooth_Interpolate_Strip

GLS.Perlin

smooth interpolate 3 strips into one...

sNOT_QUAD

GLScene.VectorTypesExt

SOLID_BGND

Formats.m3DSConst

SolveCubic

GLScene.Polynomials

Computes the real roots of a real polynomial of the 3rd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3

SolveQuadric

GLScene.Polynomials

Computes the real roots of a real polynomial of the 2nd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2

SolveQuartic

GLScene.Polynomials

Computes the real roots of a real polynomial of the 4th degree. The polynomial is of the form: A(0) + A(1)*Z + ... + A(4)*Z**4

SortArrayAscending

GLScene.VectorGeometry

Sorts given array in ascending order. NOTE : current implementation is a slow bubble sort...

SphereVisibleRadius

GLScene.VectorGeometry

Computes the visible radius of a sphere in a perspective projection. This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.

SPOTLIGHT_NODE_TAG

Formats.m3DSConst

sSINGULAR

GLScene.VectorTypesExt

StarRecordColor

GLS.SkyDome

Computes star color from BV index (RGB) and magnitude (alpha)

StarRecordPositionYUp

GLS.SkyDome

Computes position on the unit sphere of a star record (Y=up)

StarRecordPositionZUp

GLS.SkyDome

Computes position on the unit sphere of a star record (Z=up)

StartAllMovements

GLS.Movement

StartPrecisionTimer

GLScene.Utils

Starts a precision timer. Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.

STLUseEmbeddedColors

GLS.FileSTL

StopAllMovements

GLS.Movement

StopPrecisionTimer

GLScene.Utils

Computes time elapsed since timer start and stop timer. Return time lap in seconds.

Str2Float

GLScene.Utils

Trying to read string otherwise using '.' as Decimal Separator

str3DSMapNotFound

GLScene.Strings

File3DS

strAlreadyRendering

GLScene.Strings

strBackwardContextFailed

GLScene.Strings

strBadPlanSize

GLScene.Strings

strBrokenObjectListArchive

GLScene.Strings

strCadencerNotDefined

GLScene.Strings

Cadencer

strCadencerNotDefinedEx

GLScene.Strings

strCamera

GLScene.Strings

strCameraRoot

GLScene.Strings

strCannotAlterAnActiveContext

GLScene.Strings

Context

strCantConvertImg

GLScene.Strings

Graphics

strConnectJoystick

GLScene.Strings

strContextActivationFailed

GLScene.Strings

strContextAlreadyCreated

GLScene.Strings

strContextDeactivationFailed

GLScene.Strings

strContextNotCreated

GLScene.Strings

strContextNotInit

GLScene.Strings

strCUDAEditor

GLScene.Strings

strCUTILFailed

GLScene.Strings

FilePGM

strCyclicRefMat

GLScene.Strings

Material

strDeleteContextFailed

GLScene.Strings

strDisplayList

GLScene.Strings

strDot

GLScene.Strings

General

strDriverNotSupportDebugRC

GLScene.Strings

strDriverNotSupportFRC

GLScene.Strings

strDriverNotSupportOESRC

GLScene.Strings

STREAMFILE_BUFFER

BASS.Import

STREAMFILE_BUFFERPUSH

BASS.Import

STREAMFILE_NOBUFFER

BASS.Import

end of user stream flag BASS_StreamCreateFileUser file systems

StreamFromFOURCC

Formats.VFW

STREAMPROC

BASS.Import

callback function types

STREAMPROC_DEVICE

BASS.Import

push stream

STREAMPROC_DEVICE_3D

BASS.Import

device mix stream

STREAMPROC_DUMMY

BASS.Import

Special STREAMPROCs

STREAMPROC_PUSH

BASS.Import

"dummy" stream

streamtypeAUDIO

Formats.VFW

mmioFOURCC('v', 'i', 'd', 's')

streamtypeMIDI

Formats.VFW

mmioFOURCC('a', 'u', 'd', 's')

streamtypeTEXT

Formats.VFW

mmioFOURCC('m', 'i', 'd', 's')

streamtypeVIDEO

Formats.VFW

– Stream types for the <fccType> field of the stream header —————-

strError

GLScene.Strings

strError3DS_CLOSING_FILE

GLScene.Strings

strError3DS_CREATING_DATABASE

GLScene.Strings

strError3DS_GET_FAIL

GLScene.Strings

strError3DS_INIT_FAILED

GLScene.Strings

strError3DS_INVALID_ARG

GLScene.Strings

strError3DS_INVALID_CHUNK

GLScene.Strings

strError3DS_INVALID_DATA

GLScene.Strings

strError3DS_INVALID_DATABASE

GLScene.Strings

strError3DS_INVALID_INDEX

GLScene.Strings

strError3DS_NO_MEM

GLScene.Strings

strError3DS_NO_SUCH_FILE

GLScene.Strings

strError3DS_OPENING_FILE

GLScene.Strings

strError3DS_PUT_FAIL

GLScene.Strings

strError3DS_READING_DATABASE

GLScene.Strings

strError3DS_READING_FILE

GLScene.Strings

strError3DS_STRING_TOO_LONG

GLScene.Strings

strError3DS_UNFOUND_CHUNK

GLScene.Strings

strError3DS_WRITING_DATABASE

GLScene.Strings

strError3DS_WRITING_FILE

GLScene.Strings

strError3DS_WRONG_DATABASE

GLScene.Strings

strError3DS_WRONG_OBJECT

GLScene.Strings

strErrorEx

GLScene.Strings

strErrorLIB

GLScene.Strings

strFailCompilation

GLScene.Strings

strFailCreatePipe

GLScene.Strings

strFailedOpenFile

GLScene.Strings

strFailedOpenFileFromCurrentDir

GLScene.Strings

strFailedToShare

GLScene.Strings

strFailHWRC

GLScene.Strings

strFailMap

GLScene.Strings

strFailRunNVCC

GLScene.Strings

strFailToBindArrayToTex

GLScene.Strings

strFailUnmap

GLScene.Strings

strFFTFuncRetErr

GLScene.Strings

strFileNotFound

GLScene.Strings

strForwardContextFailed

GLScene.Strings

SceneContext

strFRC_created

GLScene.Strings

strFuncNotConnected

GLScene.Strings

strFuncRetErr

GLScene.Strings

strGLSceneEditor

GLScene.Strings

SceneEdit

strImageInvalid

GLScene.Strings

Textures

strIncompatibleContexts

GLScene.Strings

strIncompatibleTypes

GLScene.Strings

String3DS

Formats.m3DSTypes

String64

Formats.m3DSTypes

StringCG

Cg.Import

StringToColorAdvanced

GLS.ImageUtils

Converts a string into color

StringToColorAdvancedSafe

GLS.ImageUtils

Converts a string into color

strInterleaveNotSupported

GLScene.Strings

strInvalidColor

GLScene.Strings

Utils

strInvalidContextReg

GLScene.Strings

strInvalidContextRegistration

GLScene.Strings

strInvalidFileSignature

GLScene.Strings

PersistentClasses

strInvalidGLContext

GLScene.Strings

strInvalidNotificationRemoval

GLScene.Strings

strInvalidParamType

GLScene.Strings

strInvalidType

GLScene.Strings

strInvalidValue

GLScene.Strings

StripifyMesh

GLS.MeshUtils

Attempts to create as few as possible triangle strips to cover the mesh. The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality). The function returns a list of TGLIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller. If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.

strJoystickError

GLScene.Strings

strLaunchFailed

GLScene.Strings

strLayoutCategoryName

GLScene.Strings

strListIndexError

GLScene.Strings

strLocalizableCategoryName

GLScene.Strings

strMakeFloatingFail

GLScene.Strings

strMaterialNotFound

GLScene.Strings

strMaterialNotFoundInMatlib

GLScene.Strings

strMaterialNotFoundInMatlibEx

GLScene.Strings

strMatLibNotDefined

GLScene.Strings

Materials

strMissingResource

GLScene.Strings

strModuleAbsent

GLScene.Strings

CUDA strings

strNoActiveRC

GLScene.Strings

strNoDescriptionAvailable

GLScene.Strings

strNoDeviceToCreate

GLScene.Strings

strNoJoystickDriver

GLScene.Strings

Joystick

strNoNewTexture

GLScene.Strings

strNoRenderingContext

GLScene.Strings

SceneViewer

strNothing

GLScene.Strings

strObjectRoot

GLScene.Strings

strObjectsNotSupported

GLScene.Strings

strOCAdvancedGeometry

GLScene.Strings

strOCBasicGeometry

GLScene.Strings

Object categories in GLScene Registry

strOCDoodad

GLScene.Strings

strOCEnvironmentObjects

GLScene.Strings

strOCExperimental

GLScene.Strings

strOCGraphPlottingObjects

GLScene.Strings

strOCGuiObjects

GLScene.Strings

strOCHUDObjects

GLScene.Strings

strOCMeshObjects

GLScene.Strings

strOCParticleSystems

GLScene.Strings

strOCProxyObjects

GLScene.Strings

strOCSpecialObjects

GLScene.Strings

strOctreeMustBePreparedBeforeUse

GLScene.Strings

Octree

strOESRC_created

GLScene.Strings

strOESvsForwardRC

GLScene.Strings

strOnlyHostData

GLScene.Strings

strOpenGLCategoryName

GLScene.Strings

SceneRegister, strings additional to Designintf

strOpenGLError

GLScene.Strings

InitOpenGL

strOutOfAttribSize

GLScene.Strings

strOutOfElementSize

GLScene.Strings

strOutOfMemory

GLScene.Strings

strOutOfRange

GLScene.Strings

strPBufferRC_created

GLScene.Strings

strRequireFreeThread

GLScene.Strings

strSceneRoot

GLScene.Strings

Tree

strSceneViewerNotDefined

GLScene.Strings

strShaderNeedsAtLeastOneLightSource

GLScene.Strings

Shaders

strShaderNeedsAtLeastOneLightSourceEx

GLScene.Strings

strSizeMismatch

GLScene.Strings

strSourceFileNotFound

GLScene.Strings

strSphereStartStop

GLScene.Strings

strSphereTopBottom

GLScene.Strings

Objects

strStateCashMissing

GLScene.Strings

strSuccessCompilation

GLScene.Strings

strThreadBusy

GLScene.Strings

strTmpRC_Created

GLScene.Strings

StrToFloatDef

GLScene.Utils

Similar to SysUtils.StrToFloatDef, but ignores user's locale

StrToGLSResType

GLS.ApplicationFileIO

strTooManyLights

GLScene.Strings

strUnableToCreateLegacyContext

GLScene.Strings

strUnBalancedBeginEndUpdate

GLScene.Strings

strUnbalancedContexActivations

GLScene.Strings

strUnbalansedUsage

GLScene.Strings

strUnknownArchive

GLScene.Strings

Common messages

strUnknownArchiveVersion

GLScene.Strings

strUnknownExtension

GLScene.Strings

strUnknownParam

GLScene.Strings

strUnknownType

GLScene.Strings

strUnsupportedType

GLScene.Strings

strVisualCategoryName

GLScene.Strings

strWrongBitmapCanvas

GLScene.Strings

strWrongParamSetup

GLScene.Strings

strWrongPrinter

GLScene.Strings

strWrongVersion

GLScene.Strings

strXCollectionEditor

GLScene.Strings

FXCollectionEditor

SubdivideTriangles

GLS.MeshUtils

Subdivides mesh triangles. Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes. The procedure is not intended for real-time use.

SubtractVector

GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1

SubtractVector

GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1

SubtractVector

GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1

SURF_FLAG_ADDITIVE

Formats.LWO

SURF_FLAG_COLORFILTER

Formats.LWO

SURF_FLAG_COLORHIGHLIGHTS

Formats.LWO

SURF_FLAG_DOUBLESIDED

Formats.LWO

SURF_FLAG_LUMINOUS

Formats.LWO

SURF_FLAG_OPAQUEEDGE

Formats.LWO

SURF_FLAG_OUTLINE

Formats.LWO

SURF_FLAG_SHADOWALPHA

Formats.LWO

SURF_FLAG_SHARPTERMINATOR

Formats.LWO

SURF_FLAG_SMOOTHING

Formats.LWO

SURF_FLAG_TRANSPARENTEDGE

Formats.LWO

sW2

GLS.Navigator

sWRONG_ELEMENT

GLScene.VectorTypesExt

sWRONG_SIZE

GLScene.VectorTypesExt

SYNCPROC

BASS.Import

Internet stream download callback function. buffer : Buffer containing the downloaded data... NULL=end of download length : Number of bytes in the buffer user : The 'user' parameter value given when calling BASS_StreamCreateURL

T1DPerlinArray

GLS.Perlin

T2DPerlinArray

GLS.Perlin

T48BitBlock

GLS.ImageUtils

TAABB

GLScene.GeometryBB

Structure for storing Axis Aligned Bounding Boxes

TAABBCorners

GLScene.GeometryBB

Structure for storing the corners of an AABB, used with ExtractAABBCorners

TAABBOverlapEvent

GLS.NGDManager

TAArray

GLS.zBuffer

TAArrayIdx

GLS.zBuffer

TACubic3DS

Formats.m3DSTypes

TAffineByteMatrix

GLScene.VectorGeometry

TAffineByteVector

GLScene.VectorGeometry

TAffineDblMatrix

GLScene.VectorGeometry

TAffineDblVector

GLScene.VectorGeometry

TAffineExtMatrix

GLScene.VectorGeometry

TAffineExtVector

GLScene.VectorGeometry

TAffineFltMatrix

GLScene.VectorGeometry

TAffineFltVector

GLScene.VectorGeometry

TAffineIntMatrix

GLScene.VectorGeometry

TAffineIntVector

GLScene.VectorGeometry

TAffineMatrix

GLScene.VectorGeometry

TAffinePtrVector

GLScene.VectorGeometry

TAffineVector

GLScene.VectorGeometry

TAffineVectorArray

GLScene.VectorGeometry

TAffineWordMatrix

GLScene.VectorGeometry

TAffineWordVector

GLScene.VectorGeometry

TAG_APE_BINARY

BASS.Import

TAG_BEXT

BASS.Import

TAG_ID3

BASS.Import

TALbitfield

OpenAL.Import

OpenAL bitfields.

TALboolean

OpenAL.Import

OpenAL boolean type.

TALbyte

OpenAL.Import

OpenAL 8bit signed byte.

TALCboolean

OpenAL.Import

ALC boolean type.

TALCbyte

OpenAL.Import

ALC 8bit signed byte.

TALCchar

OpenAL.Import

ALC character type

TALCcontext

OpenAL.Import

ALC context

TALCdevice

OpenAL.Import

ALC device

TALCdouble

OpenAL.Import

ALC 64bit double point type.

TALCenum

OpenAL.Import

ALC enumerations.

TALCfloat

OpenAL.Import

ALC 32bit floating point type.

TALchar

OpenAL.Import

character

TALCint

OpenAL.Import

ALC 32bit signed integer type.

TALclampd

OpenAL.Import

Openal clamped double.

TALclampf

OpenAL.Import

OpenAL clamped float.

TALCshort

OpenAL.Import

ALC 16bit signed short integer type.

TALCsizei

OpenAL.Import

ALC 32bit type.

TALCubyte

OpenAL.Import

ALC 8bit unsigned byte.

TALCuint

OpenAL.Import

ALC 32bit unsigned integer type.

TALCushort

OpenAL.Import

ALC 16bit unsigned short integer type.

TALCvoid

OpenAL.Import

ALC void type

TALdouble

OpenAL.Import

OpenAL 64bit double point type.

TALenum

OpenAL.Import

OpenAL enumerations.

TALfloat

OpenAL.Import

OpenAL 32bit floating point type.

TALint

OpenAL.Import

OpenAL 32bit signed integer type.

TALshort

OpenAL.Import

OpenAL 16bit signed short integer type.

TALsizei

OpenAL.Import

OpenAL 32bit type.

TALuByte

OpenAL.Import

OpenAL 8bit unsigned byte.

TALuint

OpenAL.Import

OpenAL 32bit unsigned integer type.

TALushort

OpenAL.Import

OpenAL 16bit unsigned short integer type.

TALvoid

OpenAL.Import

OpenAL void type

TAMFloatVector

GLScene.RandomLib

Used as a Dynamic Vector

TAndroidIO

SDL.Import

TANG4

Formats.LWO

TangentAttributeName

GLS.Objects

TANIMChunk

Formats.B3D

TApplyForceAndTorqueEvent

GLS.NGDManager

TARGET_NODE_TAG

Formats.m3DSConst

TArray3DExt

GLScene.VectorTypesExt

TASETextureMap

GLS.FileASE

TAsmProgFileProperty

GLS.SceneRegister

TAtmosphere3DS

Formats.m3DSTypes

TAtmosphereType3DS

Formats.m3DSTypes

TAVICOMPRESSOPTIONS

Formats.VFW

TAVICompressor

GLS.AVIRecorder

TAVIFileInfo

Formats.VFW

TAVIFileInfoA

Formats.VFW

TAVIFileInfoW

Formats.VFW

TAVIImageRetrievalMode

GLS.AVIRecorder

Image retrieval mode for frame capture. Following modes are supported: irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution

TAVIINDEXENTRY

Formats.VFW

TAVIPALCHANGE

Formats.VFW

TAVIRecorderPostProcessEvent

GLS.AVIRecorder

TAVIRecorderState

GLS.AVIRecorder

TAVISAVECALLBACK

Formats.VFW

TAVISizeRestriction

GLS.AVIRecorder

Frame size restriction. Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.

TAVIStreamHeader

Formats.VFW

TAVIStreamInfo

Formats.VFW

TAVIStreamInfoA

Formats.VFW

TAVIStreamInfoW

Formats.VFW

TB3DChunk

Formats.B3D

TB3DChunkType

Formats.B3D

TB3DMaterial

Formats.B3D

TB3DNode

Formats.B3D

TB3DTexture

Formats.B3D

TBackground3DS

Formats.m3DSTypes

TBackgroundType3DS

Formats.m3DSTypes

enumerate list of possible backgrounds used in file

TBASS3DAlgorithm

GLS.Sounds.BASS

TBASSModuleHandle

BASS.Import

This function is defined in the implementation part of this unit. It is not part of BASS.DLL but an extra function which makes it easier to set the predefined EAX environments. env : a EAX_ENVIRONMENT_xxx constant

TBASS_PLUGINFORMS

BASS.Import

TBB3DChunk

Formats.B3D

TBitmap3DS

Formats.m3DSTypes

TBitmapBgnd3DS

Formats.m3DSTypes

TBodyFlags

ODE.Import

Change: New Type added, syntax enforcement

TBodyList

ODE.Import

TBONEChunk

Formats.B3D

TBoneMatrixObj

GLS.ProxyObjects

An object containing the bone matrix for TGLActorProxy.

TBorderType

GLS.Memo

TBoundBox

Formats.m3DSTypes

TBoxRec

GLScene.VectorTypesExt

TBRUSChunk

Formats.B3D

TBSPBBox

Formats.Q3BSP

TBSPClusterVisibility

GLS.MeshBSP

TBSPCullingSphere

GLS.MeshBSP

TBSPFace

Formats.Q3BSP

TBSPHeader

Formats.Q3BSP

TBSphere

GLScene.GeometryBB

Structure for storing BoundingSpheres. Similar to TAABB

TBSPLeaf

Formats.Q3BSP

TBSPLightmap

Formats.Q3BSP

TBSPLump

Formats.Q3BSP

TBSPMeshObject

GLS.MeshBSP

A BSP mesh object. Stores the geometry information, BSP rendering options and offers some basic BSP utility methods. Geometry information is indexed in the facegroups, the 1st facegroup (of index 0) being the root node of the BSP tree.

TBSPModel

Formats.Q3BSP

TBSPNode

Formats.Q3BSP

TBSPRenderContextInfo

GLS.MeshBSP

TBSPRenderSort

GLS.MeshBSP

TBSPTexture

Formats.Q3BSP

TBSPVertex

Formats.Q3BSP

TBSPVisData

Formats.Q3BSP

TBumpMethod

GLSL.BumpShaders

TBumpOption

GLSL.BumpShaders

TBumpOptions

GLSL.BumpShaders

Enable parallax offset mapping

TBumpSpace

GLSL.BumpShaders

TByteArray

GLS.HeightData

to CreateMonochromeBitmap

TByteMatrixArr

GLS.Isolines

TByteRaster

GLS.HeightData

TByteVector

GLScene.VectorGeometry

TByteVectorArr

GLS.Isolines

TCadencableCustomCgShader

GLS.CgShader

Allows to use a Cadencer, which is used for noise generation in many shaders.

TCalcPointEvent

GLS.ThorFX

TCamera3DS

Formats.m3DSTypes

TCamRanges

Formats.m3DSTypes

TCamRanges3DS

Formats.m3DSTypes

TCAPCONTROLCALLBACK

Formats.VFW

TCAPDRIVERCAPS

Formats.VFW

TCAPERRORCALLBACK

Formats.VFW

TCAPERRORCALLBACKA

Formats.VFW

TCAPERRORCALLBACKW

Formats.VFW

TCAPINFOCHUNK

Formats.VFW

TCAPSTATUS

Formats.VFW

TCAPSTATUSCALLBACK

Formats.VFW

TCAPSTATUSCALLBACKA

Formats.VFW

TCAPSTATUSCALLBACKW

Formats.VFW

TCAPTUREPARMS

Formats.VFW

TCAPVIDEOCALLBACK

Formats.VFW

TCAPWAVECALLBACK

Formats.VFW

TCAPYIELDCALLBACK

Formats.VFW

– Callback definitions —————————————————–

TCardinalArray

Formats.m3DSTypes

TCardinalVector

GLScene.VectorGeometry

TCastArray

GLS.Isolines

TCellPos

GLS.Memo

TCellSize

GLS.Memo

TCgApplyEvent

GLS.CgShader

TCgBombShader

GLS.CgBombShader

TCGbool

Cg.Import

TCgCustomBombShader

GLS.CgBombShader

Just a good-looking shader.

TCGenum

Cg.Import

"Connecting the parameters failed because The type of the source parameter is not defined within the given program or does not match the type with the same name in the program."

TCGerror

Cg.Import

TCGerrorCallbackFunc

Cg.Import

TCgFPProfile

GLS.CgShader

Available fragment program profile

TCgFragmentProgram

GLS.CgShader

TCGGLenum

Cg.GL

***************************************************************************

TCgParameter

GLS.CgShader

Wrapper around a Cg parameter of the main program.

TCGprofile

Cg.Import

* The following macro invocations define the supported CG profiles. * * The macros have the form : * * CG_PROFILE_MACRO(name, compiler_id, compiler_opt) * * name : The name of the profile. Used consistently with the API. * compiler_id : The identifier string for the profile used by the compiler. * compiler_id_caps : compiler_id in caps. * compiler_opt : The command-line switch used to force compilation into * the profile. * int_id : Integer enumerant associated with this bind location. * vertex_profile : Non-zero if this is a vertex profile, otherwise it * is considered to be a fragment profile. * *

TCgProgram

GLS.CgShader

Wrapper around a Cg program.

TcgProgramType

GLS.CgShader

TCGresource

Cg.Import

* The following macro invocations define the supported CG basic hardware * bind locations. * * The macros have the form : * * CG_BINDLOCATION_MACRO(name, compiler_name, enum_int) * * name : The name of the location. * enum_name : The C enumerant. * compiler_name : The name of the location within the compiler syntax. * int_id : Integer enumerant associated with this bind location. * addressable : The bind location must have an integer address * associated with it. * ParamType : the cgParamType of this register. *

TCgShader

GLS.CgShader

TCgShaderEvent

GLS.CgShader

TCGtype

Cg.Import

* The following macro invocations define the supported CG basic data types. * * The macros have the form : * * CG_DATATYPE_MACRO(name, compiler_name, nrows, ncols) * * name : The name of the data type. * compiler_name : The name of the data type within the compiler syntax. * enum_name : The C enumerant. * nrows : Number of rows for matrix types. Should be 0 other-wise. * ncols : Number of columns for matrix types. Should be 0 * other-wise. *

TCgUnApplyEvent

GLS.CgShader

TCgVertexProgram

GLS.CgShader

TCgVPProfile

GLS.CgShader

Available vertex program profile

TChannelTypeAndNum

GLS.CUDA.APIComps

TCHANNEL_CAPS

Formats.VFW

TCharInfo

GLS.BitmapFont

TCharStyle

GLS.Memo

TChunk3DS

Formats.m3DSTypes

finally the chunk definition

TChunkData

Formats.m3DSTypes

to avoid zillion type casts, we use this variant record for chunk data, effectively this defines the same pointer differently for different chunk types this is only possible because all types are just pointers

TChunkList

Formats.m3DSTypes

TChunkList3DS

Formats.m3DSTypes

list of cross references

TChunkListEntry3DS

Formats.m3DSTypes

cross reference between Name and Chunk

TClose

SDL.Import

** * Close and free an allocated SDL_RWops structure. * * 0 if successful or -1 on write error when flushing data. *

Tcl_addressing_mode

OpenCL.Import

Tcl_bitfield

OpenCL.Import

Tcl_bool

OpenCL.Import

Tcl_buffer_create_type

OpenCL.Import

Tcl_buffer_region

OpenCL.Import

Tcl_build_status

OpenCL.Import

Tcl_channel_order

OpenCL.Import

Tcl_channel_type

OpenCL.Import

Tcl_char

OpenCL.Platform

scalar types

Tcl_char16

OpenCL.Platform

Tcl_char2

OpenCL.Platform

* Vector types * * Note: OpenCL requires that all types be naturally aligned. * This means that vector types must be naturally aligned. * For example, a vector of four floats must be aligned to * a 16 byte boundary (calculated as 4 * the natural 4-byte * alignment of the float). The alignment qualifiers here * will only function properly if your compiler supports them * and if you don't actively work to defeat them. For example, * in order for a cl_float4 to be 16 byte aligned in a struct, * the start of the struct must itself be 16-byte aligned. * * Maintaining proper alignment is the user's responsibility.

Tcl_char4

OpenCL.Platform

Tcl_char8

OpenCL.Platform

Tcl_command_queue

OpenCL.Import

Tcl_command_queue_info

OpenCL.Import

Tcl_command_queue_properties

OpenCL.Import

Tcl_command_type

OpenCL.Import

Tcl_context

OpenCL.Import

Tcl_context_info

OpenCL.Import

Tcl_context_notify

OpenCL.Import

CL_API_SUFFIX__VERSION_2_1 * Context APIs *//

Tcl_context_properties

OpenCL.Import

Tcl_destructor_notify

OpenCL.Import

CL_API_SUFFIX__VERSION_2_0

Tcl_device_affinity_domain

OpenCL.Import

Tcl_device_exec_capabilities

OpenCL.Import

Tcl_device_fp_config

OpenCL.Import

Tcl_device_id

OpenCL.Import

Tcl_device_info

OpenCL.Import

Tcl_device_local_mem_type

OpenCL.Import

Tcl_device_mem_cache_type

OpenCL.Import

Tcl_device_partition_property

OpenCL.Import

Tcl_device_svm_capabilities

OpenCL.Import

Tcl_device_type

OpenCL.Import

Tcl_double

OpenCL.Platform

Tcl_double16

OpenCL.Platform

Tcl_double2

OpenCL.Platform

Tcl_double4

OpenCL.Platform

Tcl_double8

OpenCL.Platform

Tcl_EnqueueNativeKernel

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

Tcl_EnqueueSVM_fn

OpenCL.Import

CL_API_SUFFIX__VERSION_1_2

Tcl_event

OpenCL.Import

Tcl_event_info

OpenCL.Import

Tcl_event_notify

OpenCL.Import

CL_API_SUFFIX__VERSION_1_1

Tcl_filter_mode

OpenCL.Import

Tcl_float

OpenCL.Platform

Tcl_float16

OpenCL.Platform

Tcl_float2

OpenCL.Platform

Tcl_float4

OpenCL.Platform

Tcl_float8

OpenCL.Platform

Tcl_gl_context_info

OpenCL.GL

Tcl_gl_object_type

OpenCL.GL

Tcl_gl_platform_info

OpenCL.GL

Tcl_gl_texture_info

OpenCL.GL

Tcl_half

OpenCL.Platform

Tcl_image_desc

OpenCL.Import

Tcl_image_format

OpenCL.Import

Tcl_image_info

OpenCL.Import

Tcl_int

OpenCL.Platform

Tcl_int16

OpenCL.Platform

Tcl_int2

OpenCL.Platform

Tcl_int4

OpenCL.Platform

Tcl_int8

OpenCL.Platform

Tcl_kernel

OpenCL.Import

Tcl_kernel_arg_access_qualifier

OpenCL.Import

Tcl_kernel_arg_address_qualifier

OpenCL.Import

Tcl_kernel_arg_info

OpenCL.Import

Tcl_kernel_arg_type_qualifier

OpenCL.Import

Tcl_kernel_exec_info

OpenCL.Import

Tcl_kernel_info

OpenCL.Import

Tcl_kernel_sub_group_info

OpenCL.Import

Tcl_kernel_work_group_info

OpenCL.Import

Tcl_long

OpenCL.Platform

Tcl_long16

OpenCL.Platform

Tcl_long2

OpenCL.Platform

Tcl_long4

OpenCL.Platform

Tcl_long8

OpenCL.Platform

Tcl_map_flags

OpenCL.Import

Tcl_mem

OpenCL.Import

Tcl_mem_flags

OpenCL.Import

Tcl_mem_info

OpenCL.Import

Tcl_mem_migration_flag

OpenCL.Import

Tcl_mem_object_type

OpenCL.Import

Tcl_pipe_info

OpenCL.Import

Tcl_pipe_properties

OpenCL.Import

Tcl_platform_id

OpenCL.Import

Tcl_platform_info

OpenCL.Import

Tcl_profiling_info

OpenCL.Import

Tcl_program

OpenCL.Import

Tcl_programbuilt_notify

OpenCL.Import

CL_API_SUFFIX__VERSION_1_0

Tcl_program_binary_type

OpenCL.Import

Tcl_program_build_info

OpenCL.Import

Tcl_program_info

OpenCL.Import

Tcl_queue_properties

OpenCL.Import

Tcl_sampler

OpenCL.Import

Tcl_sampler_info

OpenCL.Import

Tcl_sampler_properties

OpenCL.Import

Tcl_short

OpenCL.Platform

Tcl_short16

OpenCL.Platform

Tcl_short2

OpenCL.Platform

Tcl_short4

OpenCL.Platform

Tcl_short8

OpenCL.Platform

Tcl_svm_mem_flags

OpenCL.Import

Tcl_uchar

OpenCL.Platform

Tcl_uchar16

OpenCL.Platform

Tcl_uchar2

OpenCL.Platform

Tcl_uchar4

OpenCL.Platform

Tcl_uchar8

OpenCL.Platform

Tcl_uint

OpenCL.Platform

Tcl_uint16

OpenCL.Platform

Tcl_uint2

OpenCL.Platform

Tcl_uint4

OpenCL.Platform

Tcl_uint8

OpenCL.Platform

Tcl_ulong

OpenCL.Platform

Tcl_ulong16

OpenCL.Platform

Tcl_ulong2

OpenCL.Platform

Tcl_ulong4

OpenCL.Platform

Tcl_ulong8

OpenCL.Platform

Tcl_ushort

OpenCL.Platform

Tcl_ushort16

OpenCL.Platform

Tcl_ushort2

OpenCL.Platform

Tcl_ushort4

OpenCL.Platform

Tcl_ushort8

OpenCL.Platform

TCollisionBoundingMode

GLS.Collision

Defines how fine collision bounding is for a particular object. Possible values are : cbmPoint : the object is punctual and may only collide with volumes cbmSphere : the object is defined by its bounding sphere (radius is the max of axis-aligned dimensions) cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid cbmCube : the object is defined by a bounding axis-aligned "cube" cbmFaces : the object is defined by its faces (needs object-level support, if unavailable, uses cbmCube code)

TCollisionConstraintTypes

GLS.VerletTypes

TCollisionConstraintTypesSet

GLS.VerletTypes

TCollisionIteratorEvent

GLS.NGDManager

Events for Newton Callback

TColor24

Formats.m3DSTypes

TColorF

Formats.m3DSTypes

TColr12

Formats.LWO

TColr12DynArray

Formats.LWO

TColr4

Formats.LWO

TColTrackTag

Formats.m3DSTypes

TCombinerCache

GLS.TextureCombiners

TCombinerCommand

GLS.TextureCombiners

TCommand

GLS.Memo

TCompressionLevel

GLS.ArchiveManager

TCOMPVARS

Formats.VFW

TConeStyle3DS

Formats.m3DSTypes

Spotlight projection cone shape

TContactProcessEvent

GLS.NGDManager

TCoronaTangentLookup

GLS.Imposter

TCSGOperation

GLS.MeshCSG

TCuAddresMode

GLS.CUDA.APIComps

TCUaddress_mode

CUDA.Import

Texture reference addressing modes

TCUarray

CUDA.Import

TcuArray3DCreate

CUDA.Import

TcuArray3DGetDescriptor

CUDA.Import

TcuArrayCreate

CUDA.Import

TcuArrayDestroy

CUDA.Import

TcuArrayGetDescriptor

CUDA.Import

TCUarray_cubemap_face

CUDA.Import

Array indices for cube faces

TCUarray_format

CUDA.Import

Array formats

TCubicSpline

GLScene.Spline

3D cubic spline handler class. This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline. Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector. Note : X, Y & Z are actually interpolated independently.

TCubicSplineMatrix

GLScene.Spline

TCUcomputemode

CUDA.Import

Compute Modes

TCUcontext

CUDA.Import

TcuCtxAttach

CUDA.Import

TcuCtxCreate

CUDA.Import

TcuCtxDestroy

CUDA.Import

TcuCtxDetach

CUDA.Import

TcuCtxGetDevice

CUDA.Import

TcuCtxPopCurrent

CUDA.Import

TcuCtxPushCurrent

CUDA.Import

TcuCtxSynchronize

CUDA.Import

TCUctx_flags

CUDA.Import

Context creation flags

TcudaArray

CUDA.Runtime

+//DEVICE_BUILTIN*/

TCUDAChange

GLS.CUDA.APIComps

TCUDAChanges

GLS.CUDA.APIComps

TCudaChannelFormatDesc

CUDA.Runtime

TCudaChannelFormatKind

CUDA.Runtime

+//DEVICE_BUILTIN*/

TCUDAChannelNum

GLS.CUDA.APIComps

TCUDAChannelType

GLS.CUDA.APIComps

TCUDAComponent

GLS.CUDA.APIComps

TCUDAComponentClass

GLS.CUDA.APIComps

TCUDAConstant

GLS.CUDA.APIComps

TCUDAConstantInfo

CUDA.Parser

TCUDAContext

GLS.CUDA.Context

TCUDAContextList

GLS.CUDA.Context

TCUDACustomFeedBackMesh

GLS.CUDA.Graphics

====================================================

TCUDADevice

GLS.CUDA.Context

TCUDADeviceList

GLS.CUDA.Context

TCudaDeviceProp

CUDA.Runtime

TCUDADimensions

GLS.CUDA.Context

TcudaError

CUDA.Runtime

TcudaExtent

CUDA.Runtime

+//DEVICE_BUILTIN*/

TCUDAFeedbackMesh

GLS.CUDA.Graphics

TCUDAFFTdir

GLS.CUDA.FFTPlan

TCUDAFFTPlan

GLS.CUDA.FFTPlan

TCUDAFFTransform

GLS.CUDA.FFTPlan

TCUDAFuncArgInfo

CUDA.Parser

TcudaFuncAttributes

CUDA.Import

* CUDA function attributes

TcudaFuncCache

CUDA.Import

* * CUDA function cache configurations

TCUDAFuncInfo

CUDA.Parser

TCUDAFuncParam

GLS.CUDA.APIComps

TCUDAFunction

GLS.CUDA.APIComps

TCUDAGeometryResource

GLS.CUDA.Graphics

TCudaGLMapFlags

CUDA.Runtime

TCUDAGraphicResource

GLS.CUDA.APIComps

Abstract class of graphic resources.

TCUDAHandleList

GLS.CUDA.Context

TCUDAHandlesMaster

GLS.CUDA.Context

TCUDAImageResource

GLS.CUDA.Graphics

TcudaLimit

CUDA.Import

* * CUDA Limits

TCUDAMapping

GLS.CUDA.APIComps

TcudaMemcpy3DParms

CUDA.Runtime

+//DEVICE_BUILTIN*/

TcudaMemcpyKind

CUDA.Runtime

+//DEVICE_BUILTIN*/

TCUDAMemData

GLS.CUDA.APIComps

TCUDAMemMapFlag

GLS.CUDA.APIComps

TCUDAMemMapFlags

GLS.CUDA.APIComps

Fast write, slow read

TCUDAMemType

GLS.CUDA.APIComps

TCUDAModule

GLS.CUDA.APIComps

TCUDAModuleInfo

CUDA.Parser

TcudaPitchedPtr

CUDA.Runtime

+//DEVICE_BUILTIN*/

TcudaPos

CUDA.Runtime

+//DEVICE_BUILTIN*/

TcudaRoundMode

CUDA.FourierTransform

TCUDATexRefInfo

CUDA.Parser

TCUDATexture

GLS.CUDA.APIComps

TcudaTextureAddressMode

CUDA.Runtime

TcudaTextureFilterMode

CUDA.Runtime

TcudaTextureReadMode

CUDA.Runtime

TCUDAType

CUDA.Parser

TCUDAUniform

GLS.CUDA.APIComps

TCUDA_ARRAY3D_DESCRIPTOR

CUDA.Import

3D array descriptor

TCUDA_ARRAY_DESCRIPTOR

CUDA.Import

TCUDA_MEMCPY2D

CUDA.Import

TCUDA_MEMCPY3D

CUDA.Import

3D memory copy parameters

TCUdevice

CUDA.Import

CUDA device

TcuDeviceComputeCapability

CUDA.Import

TcuDeviceGet

CUDA.Import

TcuDeviceGetAttribute

CUDA.Import

TcuDeviceGetCount

CUDA.Import

TcuDeviceGetName

CUDA.Import

TcuDeviceGetProperties

CUDA.Import

TCUdeviceptr

CUDA.Import

CUDA device pointer

TcuDeviceTotalMem

CUDA.Import

TCUdevice_attribute

CUDA.Import

Device properties

TCUdevprop

CUDA.Import

Legacy device properties

TCUDPPAlgorithm

CUDA.ParallelPrimitives

Maximum of two operands

TCUDPPConfiguration

CUDA.ParallelPrimitives

Placeholder at end of enum

TCUDPPDatatype

CUDA.ParallelPrimitives

Each key has an associated value

TCUDPPHandle

CUDA.ParallelPrimitives

TCUDPPOperator

CUDA.ParallelPrimitives

Float type (C float)

TCUDPPOption

CUDA.ParallelPrimitives

Unknown or untraceable error.

TCUDPPResult

CUDA.ParallelPrimitives

TcuDriverGetVersion

CUDA.Import

TCUevent

CUDA.Import

TcuEventCreate

CUDA.Import

TcuEventDestroy

CUDA.Import

TcuEventElapsedTime

CUDA.Import

TcuEventQuery

CUDA.Import

TcuEventRecord

CUDA.Import

TcuEventSynchronize

CUDA.Import

TCUevent_flags

CUDA.Import

Event creation flags

TcufftCompatibility

CUDA.FourierTransform

Certain R2C and C2R transforms go much more slowly when FFTW memory layout and behaviour is required. The default is "best performance", which means not-compatible-with-fftw. Use the cufftSetCompatibilityMode API to enable exact FFTW-like behaviour.
These flags can be ORed together to select precise FFTW compatibility behaviour. The two levels presently supported are:
CUFFT_COMPATIBILITY_FFTW_PADDING Inserts extra padding between packed in-place transforms for batched transforms with power-of-2 size.
CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC Guarantees FFTW-compatible output for non-symmetric complex inputs for transforms with power-of-2 size. This is only useful for artificial (i.e. random) datasets as actual data will always be symmetric if it has come from the real plane. If you don't understand what this means, you probably don't have to use it.
CUFFT_COMPATIBILITY_FFTW For convenience, enables all FFTW compatibility modes at once.

TcufftComplex

CUDA.FourierTransform

TcufftDestroy

CUDA.FourierTransform

TcufftDoubleComplex

CUDA.FourierTransform

TcufftDoubleReal

CUDA.FourierTransform

TcufftExecC2C

CUDA.FourierTransform

TcufftExecC2R

CUDA.FourierTransform

TcufftExecD2Z

CUDA.FourierTransform

TcufftExecR2C

CUDA.FourierTransform

TcufftExecZ2D

CUDA.FourierTransform

TcufftExecZ2Z

CUDA.FourierTransform

TcufftHandle

CUDA.FourierTransform

CUFFT API function return values CUFFT defines and supports the following data types cufftHandle is a handle type used to store and access CUFFT plans.

TcufftPlan1d

CUDA.FourierTransform

TcufftPlan2d

CUDA.FourierTransform

TcufftPlan3d

CUDA.FourierTransform

TcufftPlanMany

CUDA.FourierTransform

TcufftReal

CUDA.FourierTransform

TcufftRealfloat

CUDA.FourierTransform

TcufftResult

CUDA.FourierTransform

TcufftSetCompatibilityMode

CUDA.FourierTransform

TcufftSetStream

CUDA.FourierTransform

TcufftType

CUDA.FourierTransform

TCuFilterMode

GLS.CUDA.APIComps

TCUfilter_mode

CUDA.Import

Texture reference filtering modes

TcuFuncGetAttribute

CUDA.Import

TcuFuncSetBlockShape

CUDA.Import

TcuFuncSetSharedSize

CUDA.Import

TCUfunction

CUDA.Import

TCUfunction_attribute

CUDA.Import

Function properties

TcuGLCtxCreate

CUDA.Import

TcuGLInit

CUDA.Import

TcuGLMapBufferObject

CUDA.Import

TcuGLMapBufferObjectAsync

CUDA.Import

TCUGLmap_flags

CUDA.Import

Flags to map or unmap a resource

TcuGLRegisterBufferObject

CUDA.Import

TcuGLSetBufferObjectMapFlags

CUDA.Import

TcuGLUnmapBufferObject

CUDA.Import

TcuGLUnmapBufferObjectAsync

CUDA.Import

TcuGLUnregisterBufferObject

CUDA.Import

TcuGraphicsGLRegisterBuffer

CUDA.Import

TcuGraphicsGLRegisterImage

CUDA.Import

TCUgraphicsMapResourceFlags

CUDA.Import

Flags for mapping and unmapping interop resources

TcuGraphicsMapResources

CUDA.Import

TCUgraphicsRegisterFlags

CUDA.Import

Flags to register a graphics resource

TCUgraphicsResource

CUDA.Import

TcuGraphicsResourceGetMappedPointer

CUDA.Import

TcuGraphicsResourceSetMapFlags

CUDA.Import

TcuGraphicsSubResourceGetMappedArray

CUDA.Import

TcuGraphicsUnmapResources

CUDA.Import

TcuGraphicsUnregisterResource

CUDA.Import

TcuInit

CUDA.Import

TCUjit_fallback

CUDA.Import

Cubin matching fallback strategies

TCUjit_option

CUDA.Import

Online compiler options

TCUjit_target

CUDA.Import

Online compilation targets

TcuLaunch

CUDA.Import

TcuLaunchGrid

CUDA.Import

TcuLaunchGridAsync

CUDA.Import

TcuMemAlloc

CUDA.Import

TcuMemAllocHost

CUDA.Import

TcuMemAllocPitch

CUDA.Import

TcuMemcpy2D

CUDA.Import

TcuMemcpy2DAsync

CUDA.Import

TcuMemcpy2DUnaligned

CUDA.Import

TcuMemcpy3D

CUDA.Import

TcuMemcpy3DAsync

CUDA.Import

TcuMemcpyAtoA

CUDA.Import

TcuMemcpyAtoD

CUDA.Import

TcuMemcpyAtoH

CUDA.Import

TcuMemcpyAtoHAsync

CUDA.Import

TcuMemcpyDtoA

CUDA.Import

TcuMemcpyDtoD

CUDA.Import

TcuMemcpyDtoDAsync

CUDA.Import

TcuMemcpyDtoH

CUDA.Import

TcuMemcpyDtoHAsync

CUDA.Import

TcuMemcpyHtoA

CUDA.Import

TcuMemcpyHtoAAsync

CUDA.Import

TcuMemcpyHtoD

CUDA.Import

TcuMemcpyHtoDAsync

CUDA.Import

TcuMemFree

CUDA.Import

TcuMemFreeHost

CUDA.Import

TcuMemGetAddressRange

CUDA.Import

TcuMemGetInfo

CUDA.Import

TcuMemHostAlloc

CUDA.Import

TcuMemHostGetDevicePointer

CUDA.Import

TcuMemHostGetFlags

CUDA.Import

TCUmemorytype

CUDA.Import

Memory types

TcuMemsetD16

CUDA.Import

TcuMemsetD2D16

CUDA.Import

TcuMemsetD2D32

CUDA.Import

TcuMemsetD2D8

CUDA.Import

TcuMemsetD32

CUDA.Import

TcuMemsetD8

CUDA.Import

TCUmodule

CUDA.Import

TcuModuleGetFunction

CUDA.Import

TcuModuleGetGlobal

CUDA.Import

TcuModuleGetTexRef

CUDA.Import

TcuModuleLoad

CUDA.Import

TcuModuleLoadData

CUDA.Import

TcuModuleLoadDataEx

CUDA.Import

TcuModuleLoadFatBinary

CUDA.Import

TcuModuleUnload

CUDA.Import

TcuParamSetf

CUDA.Import

TcuParamSeti

CUDA.Import

TcuParamSetSize

CUDA.Import

TcuParamSetTexRef

CUDA.Import

TcuParamSetv

CUDA.Import

TCUresult

CUDA.Import

************************************ ** ** Error codes ** ***********************************/ Error codes

TCustomCgShader

GLS.CgShader

TCUstream

CUDA.Import

TcuStreamCreate

CUDA.Import

TcuStreamDestroy

CUDA.Import

TcuStreamQuery

CUDA.Import

TcuStreamSynchronize

CUDA.Import

TCUtexref

CUDA.Import

TcuTexRefCreate

CUDA.Import

TcuTexRefDestroy

CUDA.Import

TcuTexRefGetAddress

CUDA.Import

TcuTexRefGetAddressMode

CUDA.Import

TcuTexRefGetArray

CUDA.Import

TcuTexRefGetFilterMode

CUDA.Import

TcuTexRefGetFlags

CUDA.Import

TcuTexRefGetFormat

CUDA.Import

TcuTexRefSetAddress

CUDA.Import

TcuTexRefSetAddress2D

CUDA.Import

TcuTexRefSetAddressMode

CUDA.Import

TcuTexRefSetArray

CUDA.Import

TcuTexRefSetFilterMode

CUDA.Import

TcuTexRefSetFlags

CUDA.Import

TcuTexRefSetFormat

CUDA.Import

TcuWGLGetDevice

CUDA.Import

Td3Axis

ODE.Import

TD3DMatrix

GLScene.VectorTypes

TD3DVector

GLScene.VectorTypes

TdAABB

ODE.Import

No typedef for AABB

TdAABBTestFn

ODE.Import

TdAngularMotorModeNumbers

ODE.Import

TDatabase3DS

Formats.m3DSTypes

file database

TDBType3DS

Formats.m3DSTypes

Database type settings

TDCECollision

GLS.DCE

TDCECollisionEvent

GLS.DCE

TDCECollisionSelection

GLS.DCE

Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: ccsDCEStandard: Collides bodies if A.layer <= B.layer ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0)

TDCEObjectCollisionEvent

GLS.DCE

TDCEShape

GLS.DCE

Only csEllipsoid can have dynamic behaviour

TDCESlideOrBounce

GLS.DCE

TdColliderFn

ODE.Import

TDComplete

GLScene.Triangulation

TdContact

ODE.Import

TdContactGeom

ODE.Import

TdContactType

ODE.Import

Change: New Type added, syntax enforcement

TDCueSettings3DS

Formats.m3DSTypes

distance cue atmosphere parameters

TDDPIXELFORMAT

Formats.DXTC

TDDSHeader

Formats.DXTC

TDDSImage

Formats.DDSImage

TDDSURFACEDESC2

Formats.DXTC

TDDS_HEADER_DXT10

Formats.DXTC

);

TDebugLogger

gnugettext

TDebugProc

GLScene.OpenGLTokens

TDebugProcAMD

GLScene.OpenGLTokens

TDEdges

GLScene.Triangulation

TDelimiters

GLS.Memo

TdErrorType

ODE.Import

TDeSerializeEvent

GLS.NGDManager

TDESolver

GLS.PhysManager

need to have state array(s) seperate from inertias to allow for implicit & explicit methods

TDESolverEuler

GLS.PhysManager

TDESolverExplicit

GLS.PhysManager

explicit e.g. Euler, Mid-point, Runge-Kutta integration

TDESolverImplicit

GLS.PhysManager

implicit e.g. Verlet Integration

TDESolverRungeKutta4

GLS.PhysManager

TDESolverType

GLS.PhysManager

only ssEuler is usable at the moment

TDESolverVerlet

GLS.PhysManager

TdGeomClass

ODE.Import

typedef struct dGeomClass { int bytes; dGetColliderFnFn *collider; dGetAABBFn *aabb; dAABBTestFn *aabb_test; dGeomDtorFn *dtor; } dGeomClass;

TdGeomDtorFn

ODE.Import

TdGeomSpaceData

ODE.Import

typedef struct dGeomSpaceData { dGeomID next; } dGeomSpaceData;

TdGetAABBFn

ODE.Import

TdGetColliderFnFn

ODE.Import

TDim

GLScene.VectorTypesExt

TDim3

CUDA.Import

TdInteger3

ODE.Import

TdIntegerArray

ODE.Import

Tri-list collider

TDirPlan

GLScene.GeometryBB

TDistanceCue

Formats.m3DSTypes

TdJointFeedback

ODE.Import

TdJointGroupID

ODE.Import

TdJointID

ODE.Import

TdJointTypeNumbers

ODE.Import

TDlInnerRange

Formats.m3DSTypes

TDlLocalShadow2

Formats.m3DSTypes

TDlMultiplier

Formats.m3DSTypes

TDlOuterRange

Formats.m3DSTypes

TDlRayBias

Formats.m3DSTypes

TDlSpotAspect

Formats.m3DSTypes

TDlSpotlight

Formats.m3DSTypes

TDlSpotRoll

Formats.m3DSTypes

TdMass

ODE.Import

TdMatrix3

ODE.Import

typedef dReal dMatrix3[4*3];

TdMatrix3_As3x4

ODE.Import

TdMatrix4

ODE.Import

typedef dReal dMatrix4[4*4];

TdMatrix6

ODE.Import

typedef dReal dMatrix6[8*6];

TdMovedCallback

ODE.Import

Whenever a body has its position or rotation changed during the timestep, the callback will be called (with body as the argument). Use it to know which body may need an update in an external structure (like a 3D engine).

TdNearCallback

ODE.Import

Collission callback structure

TdObject

ODE.Import

TDomain

gnugettext

*—————————————————————————— Handles all issues regarding a specific domain. Don't use this class. It's for internal use. ——————————————————————————-

TDoubleArray

GLScene.Polynomials

TDoubleArray

GLScene.VectorTypesExt

TDoubleHmgPlane

GLScene.VectorGeometry

TDoubleVector

GLScene.VectorGeometry

TDProgressEvent

GLScene.Triangulation

TdQuaternion

ODE.Import

typedef dReal dQuaternion[4];

TDRAWDIBTIME

Formats.VFW

TdReal

ODE.Import

body is not influenced by gravity

TdRealArray

ODE.Import

TdRealHugeArray

ODE.Import

TdSurfaceParameters

ODE.Import

TDTriangle

GLScene.Triangulation

TdTriArrayCallback

ODE.Import

Per object callback. Allows the user to get the list of triangles in 1 shot. Maybe we should remove this one.

TdTriCallback

ODE.Import

Per triangle callback. Allows the user to say if he wants a collision with a particular triangle.

TdTriRayCallback

ODE.Import

Allows the user to say if a ray collides with a triangle on barycentric coords. The user can for example sample a texture with alpha transparency to determine if a collision should occur.

TDumpLevel

Formats.m3DSTypes

for TStringList —————- commonly used structures ———————————-

TdVector3

ODE.Import

typedef dReal dVector33[4];

TdVector3Array

ODE.Import

TdVector4

ODE.Import

typedef dReal dVector4[4];

TDVertex

GLScene.Triangulation

TdxAutoDisable

ODE.Import

TdxBody

ODE.Import

TdxContactParameters

ODE.Import

TdxDampingParameters

ODE.Import

TDXFile

Formats.X

TDXFileHeader

Formats.X

TDXFrame

Formats.X

TdxGeom

ODE.Import

// common data for all geometry objects. the class-specific data area follows // this structure. pos and R will either point to a separately allocated // buffer (if body is 0 - pos points to the dxPosR object) or to the pos and // R of the body (if body nonzero). struct dxGeom { // a dGeomID is a pointer to this dxGeomClass *_class; // class of this object void *data; // user data pointer dBodyID body; // dynamics body associated with this object (if any) dReal *pos; // pointer to object's position vector dReal *R; // pointer to object's rotation matrix dSpaceID spaceid; // the space this object is in dGeomSpaceData space; // reserved for use by space this object is in dReal *space_aabb; // ptr to aabb array held by dSpaceCollide() fn // class-specific data follows here, with proper alignment. };

TdxHashSpace

ODE.Import

Copies settings from TdxSpace, beacause pascal doeasn't do inheritance for records

TdxHeightfieldData

ODE.Import

TdxJoint

ODE.Import

TdxJointAMotor

ODE.Import

TdxJointBall

ODE.Import

TdxJointFixed

ODE.Import

TdxJointGroup

ODE.Import

TdxJointHinge

ODE.Import

TdxJointHinge2

ODE.Import

TdxJointLimitMotor

ODE.Import

TdxJointLimitMotor3

ODE.Import

TdxJointLMotor

ODE.Import

TdxJointNode

ODE.Import

TdxJointNull

ODE.Import

TdxJointPiston

ODE.Import

TdxJointPlane2D

ODE.Import

TdxJointPR

ODE.Import

TdxJointSlider

ODE.Import

TdxJointUniversial

ODE.Import

TDXMaterial

Formats.X

TDXMaterialList

Formats.X

TDXMesh

Formats.X

TDXNode

Formats.X

TdxPosR

ODE.Import

TdxQuadTreeSpace

ODE.Import

TdxQuickStepParameters

ODE.Import

TdxSimpleSpace

ODE.Import

Copies settings from TdxSpace, beacause pascal doeasn't do inheritance for records

TdxSpace

ODE.Import

TdxTriMeshData

ODE.Import

struct dxTriMeshData{ Model BVTree; MeshInterface Mesh;
dxTriMeshData(); ~dxTriMeshData();
void Build(const void* Vertices, int VertexStide, int VertexCount, const void* Indices, int IndexCount, int TriStride, const void* Normals, bool Single);
/* aabb in model space */ dVector3 AABBCenter; dVector3 AABBExtents;
/* data for use in collison resolution */ const void* Normals; Matrix4x4 last_trans; };

TdxWorld

ODE.Import

struct dxWorld : public dBase { dxBody *firstbody; // body linked list dxJoint *firstjoint; // joint linked list int nb,nj; // number of bodies and joints in lists dVector3 gravity; // gravity vector (m/s/s) dReal global_erp; // global error reduction parameter dReal global_cfm; // global costraint force mixing parameter };

TEaseType

GLScene.AnimationUtils

TEaxBufferProperties

OpenAL.Import

Use this structure for DSPROPERTY_EAXBUFFER_ALLPARAMETERS - all levels are hundredths of decibels
NOTE: This structure may change in future EAX versions. It is recommended to initialize fields by name: myBuffer.lDirect = 0; myBuffer.lDirectHF = -200; ... myBuffer.dwFlags = myFlags /* see EAXBUFFERFLAGS below */ ; instead of: myBuffer = { 0, -200, ... , 0x00000003 };

TEaxListenerProperties

OpenAL.Import

Use this structure for DSPROPERTY_EAXLISTENER_ALLPARAMETERS - all levels are hundredths of decibels - all times are in seconds - the reference for high frequency controls is 5 kHz
NOTE: This structure may change in future EAX versions. It is recommended to initialize fields by name: myListener.lRoom = -1000; myListener.lRoomHF = -100; ... myListener.dwFlags = myFlags /* see EAXLISTENERFLAGS below */ ; instead of: myListener = { -1000, -100, ... , 0x00000009 }; If you want to save and load presets in binary form, you should define your own structure to insure future compatibility.

TECCollider

GLS.EllipseCollision

TECColliderList

GLS.EllipseCollision

TECColliderShape

GLS.EllipseCollision

TECCollisionPacket

GLS.EllipseCollision

TECContact

GLS.EllipseCollision

TECContactList

GLS.EllipseCollision

TECFreeForm

GLS.EllipseCollision

Ellipsoid collision FreeForm

TECFreeFormList

GLS.EllipseCollision

TECMovePack

GLS.EllipseCollision

TECObjectInfo

GLS.EllipseCollision

Object collision properties

TECPlane

GLS.EllipseCollision

The Ellipsoid collision class

TECTriangle

GLS.EllipseCollision

Ellipsoid collision Triangle

TECTriMesh

GLS.EllipseCollision

Ellipsoid collision Mesh

TECTriMeshList

GLS.EllipseCollision

TEulerOrder

GLScene.VectorGeometry

—————————————————————————- Quaternion functions —————————————————————————-

TExecutable

gnugettext

*—————————————————————————— Helper class for invoking events. ——————————————————————————-

TexPointArrayAdd

GLScene.VectorGeometry

Adds delta to nb texpoints in src and places result in dest

TexPointArrayScaleAndAdd

GLScene.VectorGeometry

TexPointCombine

GLScene.VectorGeometry

Makes a linear combination of two texpoints

TexpointEquals

GLScene.VectorGeometry

True if all components are equal.

TexPointLerp

GLScene.VectorGeometry

Calculates linear interpolation between texpoint1 and texpoint2 at point t

TexPointMake

GLScene.VectorGeometry

————————————————————————– Vector functions ————————————————————————–

textdomain

gnugettext

TExtendedVector

GLScene.VectorGeometry

TextureBlue

GLS.RandomHDS

TextureBrownSoil

GLS.RandomHDS

TextureDarkGray

GLS.RandomHDS

TextureDarkGreen

GLS.RandomHDS

TextureGreen

GLS.RandomHDS

TextureSand

GLS.RandomHDS

TextureWhite

GLS.RandomHDS

TEX_ALPHA_SOURCE

Formats.m3DSConst

summed area table

TEX_DECAL

Formats.m3DSConst

MAT_TILING

TEX_DONT_USE_ALPHA

Formats.m3DSConst

tint for color

TEX_INVERT

Formats.m3DSConst

TEX_MIRROR

Formats.m3DSConst

TEX_NOWRAP

Formats.m3DSConst

TEX_RGB_TINT

Formats.m3DSConst

don't use map alpha

TEX_SAT

Formats.m3DSConst

TEX_TINT

Formats.m3DSConst

use ALPHA instead of RGB of map

TEX_UNUSED1

Formats.m3DSConst

TEX_VERTS

Formats.m3DSConst

TEX_VERTS_ENTRY

Formats.m3DSConst

TF4

Formats.LWO

TF4Array

Formats.LWO

TF4DynArray

Formats.LWO

TFace3DS

Formats.m3DSTypes

Face List element

TFaceArray

Formats.m3DSTypes

TFaceList

Formats.m3DSTypes

TFaceRec

GLScene.VectorTypesExt

TFallTrackTag

Formats.m3DSTypes

TFastCollisionChecker

GLS.Collision

TFColor3DS

Formats.m3DSTypes

RGB Color components

TFColorList

Formats.m3DSTypes

TFeedBackMeshLaunching

GLS.CUDA.Graphics

TFeedBackMeshPrimitive

GLS.CUDA.Graphics

TFGBezierSurface

GLS.ParametricSurfaces

A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.

TFGBSPNode

GLS.MeshBSP

A node in the BSP tree. The description does not explicitly differentiates nodes and leafs, nodes are referred by their index.

TFGIndexTexCoordList

GLS.VectorFileObjects

Adds per index texture coordinates to its ancestor. Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.

TFGPolygon

GLS.Portal

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

TFGPortalPolygon

GLS.Portal

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

TFGVertexIndexList

GLS.VectorFileObjects

A face group based on an indexlist. The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.

TFGVertexNormalTexIndexList

GLS.VectorFileObjects

Adds normals and texcoords indices. Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.

TFile3DS

Formats.m3DS

The main class that supplies the user with all available data from a specific 3DS file. The data is currently read only, but the class might be finished sometime later...

TFileB3D

Formats.B3D

TFileGLA

Formats.GL2

Ghoul2 Animation structure

TFileGLM

Formats.GL2

Ghoul2 Model structure

TFileMD2

Formats.MD2

TFileMD3

Formats.MD3

MD3 Main file class

TFileNMF

GLS.FileNMF

TFileSection

GLS.FileVfsPAK

TFileSection

GLS.FileZLIB

TFileSection

GLS.PAKArchive

TFilterType3DS

Formats.m3DSTypes

TFindCuFileFunc

GLS.CUDA.Compiler

TFinishTaskEvent

GLS.Context

TFloatPercentage

Formats.m3DSTypes

TFloatVector

GLScene.VectorGeometry

TFMetaDataCallback

FMOD.types

TFModErrors

FMOD.types

[ENUM] [ [DESCRIPTION] On failure of commands in FMOD, use FSOUND_GetError to attain what happened.
[SEE_ALSO] FSOUND_GetError ]

TFMusicCallback

FMOD.types

TFMusicTypes

FMOD.types

[ENUM] [ [DESCRIPTION] These definitions describe the type of song being played.
[SEE_ALSO] FMUSIC_GetType ]

TFog

Formats.m3DSTypes

TFogDistance

GLS.Scene

Fog distance calculation mode. fdDefault: let OpenGL use its default formula fdEyeRadial: uses radial "true" distance (best quality) fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.

TFogMode

GLS.Scene

TFogSettings3DS

Formats.m3DSTypes

Fog atmosphere parameters

TFontEntry

GLS.SpaceText

TFontManager

GLS.SpaceText

Manages a list of fonts for which display lists were created.

TFOURCC

Formats.DXTC

TFovTrackTag

Formats.m3DSTypes

TFractionErosion

GLS.RandomHDS

TFrustum

GLScene.VectorGeometry

TFSoundAllocCallback

FMOD.types

TFSoundCloseCallback

FMOD.types

TFSoundDSPCallback

FMOD.types

TFSoundFreeCallback

FMOD.types

TFSoundFXModes

FMOD.types

[ENUM] [ [DESCRIPTION] These values are used with FSOUND_FX_Enable to enable DirectX 8 FX for a channel.
[SEE_ALSO] FSOUND_FX_Enable FSOUND_FX_Disable FSOUND_FX_SetChorus FSOUND_FX_SetCompressor FSOUND_FX_SetDistortion FSOUND_FX_SetEcho FSOUND_FX_SetFlanger FSOUND_FX_SetGargle FSOUND_FX_SetI3DL2Reverb FSOUND_FX_SetParamEQ FSOUND_FX_SetWavesReverb ]

TFSoundMixerTypes

FMOD.types

[ENUM] [ [DESCRIPTION] These mixer types are used with FSOUND_SetMixer, to choose which mixer to use, or to act upon for other reasons using FSOUND_GetMixer. It is not necessary to set the mixer. FMOD will autodetect the best mixer for you.
[SEE_ALSO] FSOUND_SetMixer FSOUND_GetMixer ]

TFSoundOpenCallback

FMOD.types

TFSoundOutputTypes

FMOD.types

[ENUM] [ [DESCRIPTION] These output types are used with FSOUND_SetOutput, to choose which output driver to use.
FSOUND_OUTPUT_DSOUND will not support hardware 3d acceleration if the sound card driver does not support DirectX 6 Voice Manager Extensions.
FSOUND_OUTPUT_WINMM is recommended for NT and CE.
[SEE_ALSO] FSOUND_SetOutput FSOUND_GetOutput ]

TFSoundReadCallback

FMOD.types

TFSoundReallocCallback

FMOD.types

TFSoundReverbChannelProperties

FMOD.types

[STRUCTURE] [ [DESCRIPTION] Structure defining the properties for a reverb source, related to a FSOUND channel. For more indepth descriptions of the reverb properties under win32, please see the EAX3 documentation at http://developer.creative.com/ under the 'downloads' section. If they do not have the EAX3 documentation, then most information can be attained from the EAX2 documentation, as EAX3 only adds some more parameters and functionality on top of EAX2.
Note the default reverb properties are the same as the FSOUND_PRESET_GENERIC preset. Note that integer values that typically range from -10,000 to 1000 are represented in decibels, and are of a logarithmic scale, not linear, wheras float values are typically linear. PORTABILITY: Each member has the platform it supports in braces ie (win32/xbox). Some reverb parameters are only supported in win32 and some only on xbox. If all parameters are set then the reverb should product a similar effect on either platform. Linux and FMODCE do not support the reverb api.
The numerical values listed below are the maximum, minimum and default values for each variable respectively.
[SEE_ALSO] FSOUND_Reverb_SetChannelProperties FSOUND_Reverb_GetChannelProperties FSOUND_REVERB_CHANNELFLAGS ]

TFSoundReverbProperties

FMOD.types

[STRUCT_START] [ [NAME] FSOUND_REVERB_PROPERTIES
[DESCRIPTION] Structure defining a reverb environment.
[REMARKS] For more indepth descriptions of the reverb properties under win32, please see the EAX2/EAX3 documentation at http://developer.creative.com/ under the 'downloads' section. If they do not have the EAX3 documentation, then most information can be attained from the EAX2 documentation, as EAX3 only adds some more parameters and functionality on top of EAX2. Note the default reverb properties are the same as the FSOUND_PRESET_GENERIC preset. Note that integer values that typically range from -10,000 to 1000 are represented in decibels, and are of a logarithmic scale, not linear, wheras float values are typically linear. PORTABILITY: Each member has the platform it supports in braces ie (win32/xbox). Some reverb parameters are only supported in win32 and some only on xbox. If all parameters are set then the reverb should product a similar effect on either platform. Only WIN32 supports the reverb api.
The numerical values listed below are the maximum, minimum and default values for each variable respectively.
[SEE_ALSO] FSOUND_Reverb_SetProperties FSOUND_Reverb_GetProperties FSOUND_REVERB_PRESETS FSOUND_REVERB_FLAGS ]

TFSoundSeekCallback

FMOD.types

TFSoundSpeakerModes

FMOD.types

[ENUM] [ [DESCRIPTION] These are speaker types defined for use with the FSOUND_SetSpeakerMode command. Note - Only reliably works with FSOUND_OUTPUT_DSOUND or FSOUND_OUTPUT_XBOX output modes. Other output modes will only interpret FSOUND_SPEAKERMODE_MONO and set everything else to be stereo.
[SEE_ALSO] FSOUND_SetSpeakerMode
[REMARKS] Note - Only reliably works with FSOUND_OUTPUT_DSOUND or FSOUND_OUTPUT_XBOX output modes. Other output modes will only interpret FSOUND_SPEAKERMODE_MONO and set everything else to be stereo.
Using either DolbyDigital or DTS will use whatever 5.1 digital mode is available if destination hardware is unsure. ]

TFSoundStreamCallback

FMOD.types

Callback types

TFSoundStreamNetStatus

FMOD.types

[ENUM] [ [DESCRIPTION] Status values for internet streams. Use FSOUND_Stream_Net_GetStatus to get the current status of an internet stream.
[SEE_ALSO] FSOUND_Stream_Net_GetStatus ]

TFSoundTagFieldType

FMOD.types

[ENUM] [ [DESCRIPTION] Describes the type of a particular tag field.
[SEE_ALSO] FSOUND_Stream_GetNumTagFields FSOUND_Stream_GetTagField FSOUND_Stream_FindTagField ]

TFSoundTellCallback

FMOD.types

TFSoundTOCTag

FMOD.types

[STRUCTURE] [ [DESCRIPTION] Structure defining a CD table of contents. This structure is returned as a tag from FSOUND_Stream_FindTagField when the tag name "CD_TOC" is specified. Note: All tracks on the CD - including data tracks- will be represented in this structure so it's use for anything other than generating disc id information is not recommended. See the cdda example program for info on retrieving and using this structure.
[SEE_ALSO] FSOUND_Stream_Open FSOUND_Stream_FindTagField ]

TFSoundVector

FMOD.types

TFullPos

GLS.Memo

TFXPointerList

GLS.ParticleFX

TGClipRect

GLScene.GeometryBB

TGDelaunay2D

GLScene.Triangulation

TGDelaunay2D is a class for Delaunay triangulation of arbitrary points Credit to Paul Bourke (http://paulbourke.net/) for the original Fortran 77 Program :)) Conversion to Visual Basic by EluZioN (EluZioN@casesladder.com) Conversion from VB to Delphi6 by Dr Steve Evans (steve@lociuk.com) June 2002 Update by Dr Steve Evans: Heap memory allocation added to prevent stack overflow when MaxVertices and MaxTriangles are very large. Additional Updates in June 2002: Bug in InCircle function fixed. Radius r := Sqrt(rsqr). Check for duplicate points added when inserting new point. For speed, all points pre-sorted in x direction using quicksort algorithm and triangles flagged when no longer needed. The circumcircle centre and radius of the triangles are now stored to improve calculation time. You can use this code however you like providing the above credits remain in tact

TGeomList

ODE.Import

TGetLineAttrsEvent

GLS.Memo

TGetPluralForm

gnugettext

Set Discard to false if output should still go to ordinary debug log

TGetTerrainBoundsEvent

GLS.TerrainRenderer

TGL1DPerlin

GLS.Perlin

TGL2DPerlin

GLS.Perlin

TGL2DPerlinOctav

GLS.Perlin

TGL3DSVectorFile

GLS.File3DS

The 3DStudio vector file. Uses an upgraded version if a 3DS import library by Mike Lischke. (http://www.lishcke-online.de). A 3DS file may contain material information and require textures when loading.

TGLABone

Formats.GL2

TGLAbsoluteHUDText

GLS.HUDObjects

Position (X, Y and X) is in absolute coordinates. This component converts them to screen coordinates and renderes text there.

TGLAbstractLibMaterial

GLS.Material

TGLAbstractLibMaterials

GLS.Material

TGLAbstractMaterialLibrary

GLS.Material

TGLAbstractMemoObject

GLS.Memo

TGLAbstractShaderUniform

GLS.MaterialEx

TGLAbstractTexture

GLS.MaterialEx

TGLAcceptMouseQuery

GLS.Windows

TGLACompQuatBone

Formats.GL2

TGLActiveAttrib

GLSL.Shader

TGLActiveAttribArray

GLSL.Shader

TGLActor

GLS.VectorFileObjects

Mesh class specialized in animated meshes. The TGLActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TGLAnimationController components).

TGLActorAnimation

GLS.VectorFileObjects

An actor animation sequence. An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property). An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TGLAnimationControler.

TGLActorAnimationMode

GLS.VectorFileObjects

Defines how an actor plays between its StartFrame and EndFrame. aamNone : no animation is performed aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward aamExternal : Allows for external animation control

TGLActorAnimationName

GLS.VectorFileObjects

TGLActorAnimationReference

GLS.VectorFileObjects

TGLActorAnimations

GLS.VectorFileObjects

Collection of actor animations sequences.

TGLActorFrameInterpolation

GLS.VectorFileObjects

Actor frame-interpolation mode. - afpNone : no interpolation, display CurrentFrame only - afpLinear : perform linear interpolation between current and next frame

TGLActorOption

GLS.VectorFileObjects

Miscellanious actor options. aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance.

TGLActorOptions

GLS.VectorFileObjects

TGLActorProxy

GLS.ProxyObjects

A proxy object specialized for Actors.

TGLActorProxyAnimationMode

GLS.ProxyObjects

pamLoop mode was too difficalt to implement, so it was discarded ...for now. pamPlayOnce only works if Actor.AnimationMode <> aamNone.

TGLAdvancedBlurImagePrepareEvent

GLS.Blur

TGLAdvancedLabel

GLS.Windows

TGLAFIOCreateFileStream

GLS.ApplicationFileIO

TGLAFIOFileStreamEvent

GLS.ApplicationFileIO

TGLAFIOFileStreamExists

GLS.ApplicationFileIO

TGLAFIOFileStreamExistsEvent

GLS.ApplicationFileIO

TGLAHeader

Formats.GL2

TGlAlphaFunc

GLS.Material

TGLAngleLimit180

GLS.Objects

TGLAngleLimit360

GLS.Objects

TGLAnimatedSprite

GLS.AnimatedSprite

An animated version for using offset texture coordinate animation.

TGLAnimationControler

GLS.VectorFileObjects

Controls the blending of an additionnal skeletal animation into an actor. The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TGLActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.

TGLAnimationNameProperty

GLS.SceneRegister

TGLAnnulus

GLS.GeomObjects

An annulus is a cylinder that can be made hollow (pipe-like)

TGLAnnulusPart

GLS.GeomObjects

TGLAnnulusParts

GLS.GeomObjects

TGLAntiAliasing

GLS.Context

TGLApplicationFileIO

GLS.ApplicationFileIO

Allows specifying a custom behaviour for CreateFileStream. The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable. If multiple ApplicationFileIO components exist in the application, the last one created will be the active one.

TGLApplicationResource

GLS.ApplicationFileIO

TGLARBFragmentProgramHandle

GLS.Context

TGLARBGeometryProgramHandle

GLS.Context

TGLARBProgramHandle

GLS.Context

TGLARBVertexProgramHandle

GLS.Context

TGLArcDirection

GLS.Canvas

TGLArchiveFileFormat

GLS.ArchiveManager

The type to record a registered class

TGLArchiveFileFormatsList

GLS.ArchiveManager

The list of registered classes

TGLArray

GLS.InitOpenGL

TGLArrowArc

GLS.GeomObjects

Draws an arrowhead (Sliced Torus + cone). The arrow head is a cone that shares the attributes of the Torus (ie stacks/slices, materials etc). This is useful for displaying a movement (eg twist) or other arc arrows that might be required. By default the bottom arrow is off

TGLArrowArcPart

GLS.GeomObjects

TGLArrowArcParts

GLS.GeomObjects

TGLArrowHeadStyle

GLS.GeomObjects

TGLArrowLine

GLS.GeomObjects

Draws an arrowhead (cylinder + cone). The arrow head is a cone that shares the attributes of the cylinder (ie stacks/slices, materials etc). Seems to work ok. This is useful for displaying a vector based field (eg velocity) or other arrows that might be required. By default the bottom arrow is off

TGLArrowLinePart

GLS.GeomObjects

TGLArrowLineParts

GLS.GeomObjects

TGLASEFace

GLS.FileASE

ASE mesh face

TGLASEFaceList

GLS.FileASE

ASE mesh faces list

TGLASEFaceTexure

GLS.FileASE

maximum texture maps face texture channel indices

TGLASEFaceTexureChannels

GLS.FileASE

face texture channels

TGLASEMaterial

GLS.FileASE

TGLASEMaterialList

GLS.FileASE

TGLASEMaterialTextureMap

GLS.FileASE

TGLASEMaterialTextureMaps

GLS.FileASE

TGLASEMeshObject

GLS.FileASE

ASE geom object, represents single mesh object; contains: vertices, faces, verice indices, faces and vertices normals, channels of texture coordinates and indices, scaling and location info; this object used only to store ASE data temporary to copy supported piece of it into GLScene TGLMeshObject

TGLASESmoothingGroups

GLS.FileASE

TGLASESubMaterial

GLS.FileASE

TGLASESubMaterialList

GLS.FileASE

TGLASEVectorFile

GLS.FileASE

ASE vector file parser

TGLASkeleton

Formats.GL2

TGLASkeletonOffsets

Formats.GL2

14 bytes

TGLAsmShader

GLSL.AsmShader

TGLAsmShaderEvent

GLSL.AsmShader

TGLAsmShaderParameter

GLSL.AsmShader

TGLAsmShaderUnUplyEvent

GLSL.AsmShader

TGLASMVertexProgram

GLS.MaterialEx

TGLAsteroidData

GLS.SkyDome

Asteroid Comet spheres..NOT DebrisAsteroid

TGLAsyncHDS

GLS.AsyncHDS

TGLAsyncHDThread

GLS.AsyncHDS

TGLAsyncTimer

GLS.AsyncTimer

Asynchronous timer component (actual 1 ms resolution, if CPU fast enough). Keep in mind timer resolution is obtained in-between events, but events are not triggered every x ms. For instance if you set the interval to 5 ms, and your Timer event takes 1 ms to complete, Timer events will actually be triggered every 5+1=6 ms (that's why it's "asynchronous"). This component is based on ThreadedTimer by Carlos Barbosa.

TGLAtmosphere

GLS.Atmosphere

TGLAtmosphereBlendingMode

GLS.Atmosphere

With atmosphere options: - aabmOneMinusSrcAlpha is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big; - bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).

TGLAVectorFile

GLS.FileGL2

TGLAVIRecorder

GLS.AVIRecorder

Component to make it easy to record GLScene frames into an AVI file.

TGLB3DVectorFile

GLS.FileB3D

TGLBAcceleration

GLS.Behaviours

Applies a constant acceleration to a TGLBInertia.

TGLBallAndSocketJoint

GLS.PhysJoints

TGLBaseAnimationControler

GLS.VectorFileObjects

Base class for skeletal animation control.

TGLBaseArchive

GLS.ArchiveManager

BaseArchive class

TGLBaseArchiveClass

GLS.ArchiveManager

TGLBaseBehaviour

GLS.Scene

Base class for implementing behaviours in TGLScene. Behaviours are regrouped in a collection attached to a TGLBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...). Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses : stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.)
Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object). NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function

TGLBaseComponent

GLS.Windows

TGLBaseConnectivity

GLS.Silhouette

TGLBaseControl

GLS.Windows

TGLBaseCustomGLSLBumpShader

GLSL.BumpShaders

An abstract class.

TGLBaseCustomGLSLBumpShaderMT

GLSL.BumpShaders

An abstract class.

TGLBaseCustomGLSLDiffuseSpecular

GLSL.DiffuseSpecularShader

Abstract class.

TGLBaseFontControl

GLS.Windows

TGLBaseForceFieldEmitter

GLS.PhysManager

A base for different types of force-field behaviours

TGLBaseGLSLDiffuseSpecularShaderMT

GLSL.DiffuseSpecularShader

Abstract class.

TGLBaseGuiObject

GLS.Gui

TGLBaseImage

GLS.Graphics

TGLBaseImageClass

GLS.Graphics

TGLBaseInertia

GLS.PhysManager

purpose of TGLBaseInertia is to allow for inertias that may be constrained to 1 or 2 dimensions Shouldn't be used directly, instead use TGLParticleInertia (for a 3D particle) TGLRigidBodyInertia (for a 3D rigid-body) or define a new sub-class e.g. TGL1DParticleInertia, this will allow for faster speed

TGLBaseJoint

GLS.PhysJoints

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

TGLBaseLink

GLS.PhysJoints

TGLBaseMaterialCollectionItem

GLS.MaterialEx

TGLBaseMesh

GLS.VectorFileObjects

Base class for mesh objects.

TGLBaseMeshConnectivity

GLS.BaseMeshSilhouette

TGLBaseMeshObject

GLS.VectorFileObjects

A base class for mesh objects. The class introduces a set of vertices and normals for the object but does no rendering of its own

TGLBasePerlin

GLS.Perlin

TGLBasePerlinOctav

GLS.Perlin

TGLBaseRandomHDS

GLS.RandomHDS

This class introduces all the basic properties of random landscape. No method implemented though. It is used as a descendant for - TGLCustomRandomLandscape: one tile landscape (cyclic or not) - TGLTiledRndLandscape: "infinite" landscapes (grids of TGLCustomRandomLandscape)

TGLBaseSceneObject

GLS.Scene

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged

TGLBaseSceneObjectSelectionEditor

GLS.SceneRegister

Selection editor for TGLBaseSceneObject. Allows units to be added to the uses clause automatically when behaviours/effects are added to a TGLBaseSceneObject at design-time.

TGLBaseSelectTechnique

GLS.Selection

TGLBaseSelectTechniqueClass

GLS.Selection

TGLBaseShaderModel

GLS.MaterialEx

TGLBaseSoundSource

GLS.SoundManager

Base class for origin of sound playback.

TGLBaseSpacePartition

GLS.SpacePartition

Basic space partition, does not implement any actual space partitioning

TGLBaseSpritePFXManager

GLS.ParticleFX

Base class for sprite-based particles FX managers. The particles are made of optionally centered single-textured quads.

TGLBaseTextControl

GLS.Windows

TGLBaseVerletNode

GLS.VerletTypes

Basic Verlet Node

TGLBCollision

GLS.Collision

Collision detection behaviour. Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms. An object may have multiple TGLBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.

TGLBehaviour

GLS.Scene

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

TGLBehaviourClass

GLS.Scene

TGLBehaviours

GLS.Scene

Holds a list of TGLBehaviour objects. This object expects itself to be owned by a TGLBaseSceneObject. As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TGLBehaviour subclasses.

TGLBExplosionFX

GLS.ExplosionFx

TGLBFireFX

GLS.FireFX

Fire special effect. This effect works as a client of TFireFXManager

TGLBFPSMovement

GLS.FPSMovement

TGLBInertia

GLS.Behaviours

Simple translation and rotation Inertia behaviour. Stores translation and rotation speeds, to which you can apply accelerations. Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).

TGLbitfield

GLScene.OpenGL4

TGLbitfield

GLScene.OpenGLTokens

TGLBitmap32

GLS.Graphics

TGLBitmapFont

GLS.BitmapFont

See TGLCustomBitmapFont. This class only publuishes some of the properties.

TGLBitmapFontRange

GLS.BitmapFont

An individual character range in a bitmap font. A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).

TGLBitmapFontRanges

GLS.BitmapFont

TGLBitmapHDS

GLS.HeightData

Bitmap-based Height Data Source. The image is automatically wrapped if requested data is out of picture Size, or if requested data is larger than the picture. The internal format is an 8 bit bitmap whose dimensions are a power of two, if the original image does not comply, it is StretchDraw'ed on a monochrome (gray) bitmap.

TGLBlankImage

GLS.Texture

A texture image with no specified content, only a size. This texture image type is of use if the context of your texture is calculated at run-time (with a TGLMemoryViewer for instance).

TGLBlankTIE

GLS.TextureImageEditors

TGLBlendedLerpInfo

GLS.VectorFileObjects

Small structure to store a weighted lerp for use in blending

TGLBlendEquation

GLS.State

TGLBlendFunction

GLS.State

TGLBlendingMode

GLS.Material

Simplified blending options. bmOpaque : disable blending bmTransparency : uses standard alpha blending bmAdditive : activates additive blending (with saturation) bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise) bmAlphaTest100 : uses opaque blending, with alpha-testing at 100% bmModulate : uses modulation blending bmCustom : uses TGLBlendingParameters options

TGLBlendingModeEx

GLSL.CustomShader

Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.

TGLBlendingParameters

GLS.Material

TGLBlur

GLS.Blur

TGLBlurkind

GLS.Blur

TGLBlurPreset

GLS.Blur

TGLBMPImage

GLS.FileBMP

TGLboolean

GLScene.OpenGL4

TGLboolean

GLScene.OpenGLTokens

=========== OpenGL types ============

TGLBooleanOcclusionQueryHandle

GLS.Context

TGLBSoundEmitter

GLS.SoundManager

A sound emitter behaviour, plug it on any object to make it noisy. This behaviour is just an interface to a TGLSoundSource, for editing convenience.

TGLBThorFX

GLS.ThorFX

Thor special effect

TGLBuffer

GLS.InitOpenGL

TGLBufferBindingTarget

GLS.State

TGLBufferI

GLS.InitOpenGL

TGLBufferObjectHandle

GLS.Context

Manages a handle to a Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TGLBufferU

GLS.InitOpenGL

TGLBufferV

GLS.InitOpenGL

TGLBumpmapHDS

GLS.BumpmapHDS

An Height Data Source that generates elevation bumpmaps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.

TGLBumpShader

GLSL.BumpShaders

A generic bump shader.

TGLButton

GLS.Windows

TGLbyte

GLScene.OpenGL4

TGLbyte

GLScene.OpenGLTokens

TGLCadencedComponent

GLS.Cadencer

TGLCadencer

GLS.Cadencer

This component allows auto-progression of animation. Basicly dropping this component and linking it to your TGLScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene). The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).

TGLCadencerMode

GLS.Cadencer

Determines how the TGLCadencer operates. - cmManual : you must trigger progress manually (in your code) - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.

TGLCadencerTimeReference

GLS.Cadencer

Determines which time reference the TGLCadencer should use. - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems) - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems) - cmExternal : the CurrentTime property is used

TGLCamera

GLS.Scene

Camera object. This object is commonly referred by TGLSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

TGLCameraController

GLS.CameraController

TGLCameraInvarianceMode

GLS.Scene

TGLCameraInvariantObject

GLS.Scene

Base class for camera invariant objects. Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

TGLCameraJob

GLS.CameraController

TGLCameraJobEvent

GLS.CameraController

TGLCameraJobList

GLS.CameraController

TGLCameraKeepFOVMode

GLS.Scene

TGLCameraStyle

GLS.Scene

TGLCanvas

GLS.Canvas

A simple Canvas-like interface for OpenGL. This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points. This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner. All coordinates are internally maintained with floating point precision. Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).

TGLCapsule

GLS.GeomObjects

Capsule object, can also be used to make truncated cones

TGLCapType

GLS.Objects

TGLCelShader

GLSL.ShapeShaders

A generic cel shader.

TGLCelShaderGetIntensity

GLSL.ShapeShaders

An event for user defined cel intensity.

TGLCelShaderOption

GLSL.ShapeShaders

A shader that applies cel shading through a vertex program and shade definition texture. Cel shading options: csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.

TGLCelShaderOptions

GLSL.ShapeShaders

TGLCgBombShaderTextureSource

GLS.CgBombShader

TGLCGPostTransformationShader

GLS.CgPostTransformationShader

TGLchar

GLScene.OpenGLTokens

TGLCheckBox

GLS.Windows

TGLclampd

GLScene.OpenGL4

TGLclampd

GLScene.OpenGLTokens

TGLclampf

GLScene.OpenGL4

TGLCollisionManager

GLS.Collision

TGLCollisionState

GLS.FPSMovement

TGLCollisionStates

GLS.FPSMovement

TGLColorComponent

GLS.State

TSingleCullFaceMode = cmFront..cmBack;

TGLColorDepth

GLS.Scene

TGLColorMask

GLS.State

TGLColorProperty

GLS.SceneRegister

TGLColorProxy

GLS.ProxyObjects

A proxy object with its own color. This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.

TGLComparisonFunction

GLS.State

TGLCompositeImage

GLS.CompositeImage

TGLCone

GLS.GeomObjects

A cone object

TGLConePart

GLS.GeomObjects

TGLConeParts

GLS.GeomObjects

TGLConeSP

GLS.SpacePartition

Describes a cone, and is used for cone collision

TGLConnectivity

GLS.Silhouette

TGLConsole

GLS.Console

TGLConsoleCommand

GLS.Console

A wrapper for a console command.

TGLConsoleCommandList

GLS.Console

TGLConsoleControls

GLS.Console

TGLConsoleMatchList

GLS.Console

TGLConsoleOption

GLS.Console

TGLConsoleOptions

GLS.Console

remove quotes when a command line is parsed

TGLConsoleStringList

GLS.Console

A class that checks for duplicates.

TGLContactPoint

GLS.FPSMovement

TGLContext

GLS.Context

Wrapper around an OpenGL rendering context. The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection. This is a virtual abstract a class, and platform-specific subclasses must be used. All rendering context share the same lists

TGLContextAcceleration

GLS.Context

TGLContextClass

GLS.Context

TGLContextHandle

GLS.Context

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses

TGLContextLayer

GLS.Context

TGLContextManager

GLS.Context

Stores and manages all the TGLContext objects.

TGLContextNotification

GLS.Context

TGLContextOption

GLS.Scene

Options for the rendering context. roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering. roRenderToWindows: ignored (legacy). roTwoSideLighting: enables two-side lighting model. roStereo: enables stereo support in the driver (need to test with a stereo device...) roDestinationAlpha: request an Alpha channel for the rendered output roNoColorBuffer: don't request a color buffer (color depth setting ignored) roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling. roForwardContext: force OpenGL forward context

TGLContextOptions

GLS.Scene

TGLContour

GLS.MultiPolygon

TGLContourClass

GLS.MultiPolygon

TGLContourNodes

GLS.MultiPolygon

TGLContours

GLS.MultiPolygon

TGLCoordinatesProperty

GLS.SceneRegister

TGLCube

GLS.Objects

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TGLFreeForm and a material library. Ref: https://mathworld.wolfram.com/Cube.html

TGLCubeMapImage

GLS.Texture

A texture image used for specifying and stroing a cube map. Not unlike TGLPictureImage, but storing 6 of them instead of just one. Saving & loading as a whole currently not supported.

TGLCubeMapTarget

GLS.Texture

TGLCubePart

GLS.Objects

TGLCubeParts

GLS.Objects

TGLCUDA

GLS.CUDA.APIComps

TGLCUDACompiler

GLS.CUDA.Compiler

TGLCUDACompilerEditor

GLS.CUDA.PropEditors

TGLCUDACompilerOutput

GLS.CUDA.Compiler

VCL.Dialogs,

TGLCUDACompilerSourceProperty

GLS.CUDA.PropEditors

TGLCUDADevice

GLS.CUDA.Context

TGLCUDADeviceProperty

GLS.CUDA.PropEditors

TGLCUDAEditor

GLS.CUDA.PropEditors

TGLCUDAEditorForm

FmCUDAEditor

TGLCUDARealArch

GLS.CUDA.Compiler

sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown

TGLCUDARealArchs

GLS.CUDA.Compiler

TGLCUDAVirtArch

GLS.CUDA.Compiler

compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support

TGLCullFaceMode

GLS.State

TGLCullingMode

GLS.SpacePartition

TGLCustomAsmShader

GLSL.AsmShader

TGLCustomAtmosphere

GLS.Atmosphere

This class imitates an atmosphere around a planet

TGLCustomBitmapFont

GLS.BitmapFont

Provides access to individual characters in a BitmapFont. Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column). Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap. Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.

TGLCustomCadencedComponent

GLS.Cadencer

Adds a property to connect/subscribe to a cadencer.

TGLCustomCGPostTransformationShader

GLS.CgPostTransformationShader

TGLCustomConsole

GLS.Console

TGLCustomControl

GLS.Windows

TGLCustomGLSLBumpShader

GLSL.BumpShaders

TGLCustomGLSLBumpShaderAM

GLSL.BumpShaders

One Light shaders.

TGLCustomGLSLBumpShaderMT

GLSL.BumpShaders

TGLCustomGLSLDiffuseSpecularShader

GLSL.DiffuseSpecularShader

******** Single Light ************

TGLCustomGLSLDiffuseSpecularShaderMT

GLSL.DiffuseSpecularShader

TGLCustomGLSLFurShader

GLSL.ShapeShaders

Custom class for Fur Shader

TGLCustomGLSLGlassShader

GLSL.ShapeShaders

Custom class for Glass shader: Environment mapping and refraction mapping using the fresnel terms

TGLCustomGLSLIvoryShader

GLSL.ShapeShaders

Custom class for a shader that simulate Ivory Material

TGLCustomGLSLLatticeShader

GLSL.ShapeShaders

Custom class for GLSLLatticeShader. A shader that simulate Lattice with Diffuse/Specular and support Texture

TGLCustomGLSLMLBumpShader

GLSL.BumpShaders

MultiLight shaders.

TGLCustomGLSLMLBumpShaderMT

GLSL.BumpShaders

TGLCustomGLSLMLDiffuseSpecularShader

GLSL.DiffuseSpecularShader

TGLCustomGLSLMLDiffuseSpecularShaderMT

GLSL.DiffuseSpecularShader

TGLCustomGLSLPostBlurShader

GLSL.PostShaders

Custom class for GLSLPostBlurShader. A shader that blurs the entire scene

TGLCustomGLSLPostDreamVisionShader

GLSL.PostShaders

Custom class for GLSLPostDreamVisionShader. A shader that simulate a grayscale threshold vision (aka dream) of the entire scene

TGLCustomGLSLPostFrostShader

GLSL.PostShaders

Custom class for GLSLPostFrostShader. A shader that frost of the entire scene

TGLCustomGLSLPostNightVisionShader

GLSL.PostShaders

Custom class for GLSLPostNightVisionShader. A shader that simulate a Night Vision of the scene throw a mask if enabled, or of the entire scene

TGLCustomGLSLPostPixelateShader

GLSL.PostShaders

Custom class for GLSLPostPixelateShader. A shader that pixelate of the entire scene

TGLCustomGLSLPostPosterizeShader

GLSL.PostShaders

Custom class for GLSLPostPosterizeShader. A shader that posterize of the entire scene

TGLCustomGLSLPostThermalVisionShader

GLSL.PostShaders

A shader that simulate a Thermal Vision of the entire scene

TGLCustomGLSLPostTroubleShader

GLSL.PostShaders

Custom class for GLSLPostTroubleShader. A shader that trouble of the entire scene. v2 This Shader is experimental it can do smooth the scene or double the scene and it's depends of PixelX, PixelY and Freq values if they are less than 1 or greater the effects will be very different

TGLCustomGLSLSemShader

GLSL.ShapeShaders

Custom class for SEM Shader : Spherical Environment Mapping

TGLCustomGLSLShader

GLSL.Shader

TGLCustomGLSLSimpleErosionShader

GLSL.ShapeShaders

Custom class for a shader that Erode surface object

TGLCustomGLSLSimpleGoochShader

GLSL.ShapeShaders

Custom class for Gooch Shader

TGLCustomGLSLSimpleLatticeShader

GLSL.ShapeShaders

Custom class for a shader that simulate Lattice

TGLCustomGLSLToonShader

GLSL.ShapeShaders

Custom class for Toon Shader

TGLCustomGLSLVertexDisplacementShader

GLSL.ShapeShaders

VertexDisplacement shader: Basic Vertex Displacement with Perlin Noise You can Improved it: The vertex displacement can be done by reading a 2D or 3D texture. It can be done along the normal or the tangent. It can be scaled, twisted, modulated, inverted... Converted from : https://www.clicktorelease.com/blog/vertex-displacement-noise-3d-webgl-glsl-three-js At this time only one light source is supported

TGLCustomHDS

GLS.HeightData

An Height Data Source for custom use. Provides event handlers for the various requests to be implemented application-side (for application-specific needs).

TGLCustomPFXManager

GLS.ParticleFX

A particles FX manager offering events for customization/experimentation. This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager. If the events aren't handled, nothing will be rendered.

TGLCustomRandomHDS

GLS.RandomHDS

Base structure for all random landscape objects. It can't be used directly since its BuildHeightField procedure is abstract. Use one of its descendants instead.

TGLCustomRenderEvent

GLS.Windows

TGLCustomSceneObject

GLS.Scene

Extended base scene object class with a material property. The material allows defining a color and texture for the object, see TGLMaterial

TGLCustomShader

GLSL.CustomShader

A pure abstract class, must be overriden.

TGLCustomShaderCombiner

GLSL.ShaderCombiner

TGLCustomShaderParameter

GLSL.CustomShader

Wrapper around a parameter of the main program.

TGLCustomSpritePFXManager

GLS.ParticleFX

A sprite-based particles FX managers using user-specified code to prepare the texture

TGLCyborg

GLS.SmartObjects

The Cyborg class specialized as a smart actor with AI. The TGLCyborg provides a quick interface to animated actors based on morph or skeleton frames, it is capable of performing frame interpolation and thinking blending (via TGLThinkingController components).

TGLCyborgManager

GLS.CyborgManager

TGLCyborgOption

GLS.SmartObjects

TGLCyborgOptions

GLS.SmartObjects

TGLCyborgReference

GLS.SmartObjects

TGLCyborgSenceOrgans

GLS.SmartObjects

TGLCyborgThinkMode

GLS.SmartObjects

TGLCyborgThinks

GLS.SmartObjects

TGLCyborgThinksList

GLS.SmartObjects

A list of thinking periods for TGLCyborgThinkMode

TGLCylinder

GLS.GeomObjects

Cylinder object, can also be used to make truncated cones

TGLCylinderAlignment

GLS.GeomObjects

TGLCylinderBase

GLS.GeomObjects

Base class to cylinder-like objects that introduces the basic cylinder description properties. Be aware teh default slices and stacks make up for a high-poly cylinder, unless you're after high-quality lighting it is recommended to reduce the Stacks property to 1.

TGLCylinderPart

GLS.GeomObjects

TGLCylinderParts

GLS.GeomObjects

TGLCylinderProperties

GLS.MeshBuilder

Properties of a cylinder with 8 parts for 2 hemicylinders using 6 points to make each part for hemidisk caps and side surfaces

TGLDamping

GLS.Behaviours

Holds parameters for a basic damping model by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass. Formulas: damping = constant + linear * Speed + quadratic * Speedˆ2 accel = damping / Mass That's just basic physics. A note on the components: constant: use it for solid friction (will stop abruptly an object after decreasing its speed. linear: linear friction damping. quadratic: expresses viscosity

TGLDampingFieldEmitter

GLS.PhysFields

TGLDataFile

GLS.ApplicationFileIO

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

TGLDataFileCapabilities

GLS.ApplicationFileIO

TGLDataFileCapability

GLS.ApplicationFileIO

TGLDataFileClass

GLS.ApplicationFileIO

TGLDCEDynamic

GLS.DCE

TGLDCEManager

GLS.DCE

The Dynamic Collision Engine Manager class

TGLDCEStatic

GLS.DCE

TGLDDSDetailLevels

GLS.FileDDS

TGLDDSImage

GLS.FileDDS

TGLDEBUGPROCARB

GLScene.OpenGLTokens

TGLDELVectorFile

GLS.FileDEL

The DEL vector file (tetrahedra irregular network)

TGLDepthCompareFunc

GLS.Texture

Specifies the depth comparison function.

TGLDepthFunction

GLS.State

TGLDepthPrecision

GLS.Scene

TGLDepthProperties

GLS.Material

TGLDepthRBO

GLS.FBORenderer

TGLDepthTextureMode

GLS.Texture

Specifies how depth values should be treated during filtering and texture application

TGLDirectOpenGL

GLS.Scene

Provides a way to issue direct OpenGL calls during the rendering. You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.

TGLDirectRenderEvent

GLS.Scene

Event for user-specific rendering in a TGLDirectOpenGL object.

TGLDisk

GLS.GeomObjects

A Disk object that may not be complete, it can have a hole (controlled by the InnerRadius property) and can only be a slice (controlled by the StartAngle and SweepAngle properties).

TGLDisplayOptions

GLS.Screen

TGLDodecahedron

GLS.GeomObjects

TGLdouble

GLScene.OpenGL4

TGLdouble

GLScene.OpenGLTokens

TGLDrawState

GLS.RenderContextInfo

TGLDstBlendFunction

GLS.State

TGLDummyCube

GLS.Objects

A simple cube, invisible at run-time. This is a usually non-visible object -except at design-time- used for building hierarchies or groups, when some kind of joint or movement mechanism needs be described, you can use DummyCubes. DummyCube's barycenter is its children's barycenter. The DummyCube can optionnally amalgamate all its children into a single display list (see Amalgamate property).

TGLDXFVectorFile

GLS.FileDXF

TGLDynamicImposterBuilder

GLS.Imposter

TGLDynamicPFXManager

GLS.ParticleFX

An abstract PFX manager for simple dynamic particles. Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).

TGLDynamicTextureImage

GLS.DynamicTexture

Allows for fast updating of the texture at runtime

TGLEarthSkyDome

GLS.SkyDome

Render a skydome like what can be seen on earth. Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render exoplanet atmospheres too. The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TGLEarthSkyDome.

TGLEarthSkydomeOption

GLS.SkyDome

TGLEarthSkydomeOptions

GLS.SkyDome

TGLEdge

GLS.VerletClothify

TGLEdgeDetector

GLS.VerletClothify

TGLEdgeList

GLS.VerletClothify

TGLEdit

GLS.Windows

TGLEffect

GLS.Scene

A rendering effect that can be applied to SceneObjects. ObjectEffect is a subclass of behaviour that gets a chance to Render an object-related special effect. TGLEffect should not be used as base class for custom effects, instead you should use the following base classes : TGLObjectPreEffect is rendered before owner object render TGLObjectPostEffect is rendered after the owner object render TGLObjectAfterEffect is rendered at the end of the scene rendering NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function

TGLEffectClass

GLS.Scene

TGLEffects

GLS.Scene

Holds a list of object effects. This object expects itself to be owned by a TGLBaseSceneObject.

TGLEnabledRenderBuffer

GLS.FBORenderer

———————– GLS.FBORenderer classes ————————–

TGLEnabledRenderBuffers

GLS.FBORenderer

TGLEnum

GLScene.OpenGL4

TGLenum

GLScene.OpenGLTokens

TGLEParticleMask

GLS.EParticleMasksManager

TGLEParticleMasks

GLS.EParticleMasksManager

TGLEParticleMasksManager

GLS.EParticleMasksManager

TGLEProjectedParticleMask

GLS.EParticleMasksManager

TGLExtendedFrustum

GLS.SpacePartition

Extended frustum, used for fast intersection testing

TGLExtensionsAndEntryPoints

GLS.OpenGLAdapter

TGLExtrusionSolid

GLS.Extrusion

Extrudes a complex Polygon into Z direction. For contour description see TGLMultiPolygonBase. properties Parts, Height (or should we better cal it Depth, because its in Z?), Stacks, Normals and NormalDirection are equivalent to TGLRevolutionSolid. If Normals=nsSmooth and the angle between two consecutive normals along the contour is less than MinSmoothAngle, smoothing is done, otherweise flat normals are used. This makes it possible to have smooth normals on sharp edged contours.

TGLExtrusionSolidPart

GLS.Extrusion

TGLExtrusionSolidParts

GLS.Extrusion

TGLFace

GLS.VerletClothify

Class that represents a face. This structure is not used for rendering, but for extracting info from meshes

TGLFaceCulling

GLS.Material

TGLFaceExtractor

GLS.VerletClothify

Class that extracts faces from a GLBaseMesh

TGLFaceGroup

GLS.VectorFileObjects

Describes a face group of a TGLMeshObject. Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object". Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.

TGLFaceGroupConnectivity

GLS.BaseMeshSilhouette

TGLFaceGroupMeshMode

GLS.VectorFileObjects

Known descriptions for face group mesh modes. - fgmmTriangles : issue all vertices with GL_TRIANGLES. - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP. - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle. - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN. - fgmmQuads : issue all vertices with GL_QUADS.

TGLFaceGroups

GLS.VectorFileObjects

A list of TGLFaceGroup objects.

TGLFaceList

GLS.VerletClothify

List of faces

TGLFaceProperties

GLS.Material

Stores basic face lighting properties. The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools. You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).

TGLFaceWinding

GLS.State

Describe what kind of winding has a front face

TGLFBOClearOption

GLS.FBORenderer

TGLFBOClearOptions

GLS.FBORenderer

TGLFBORenderer

GLS.FBORenderer

TGLFBOTargetVisibility

GLS.FBORenderer

TGLFeedback

GLS.Feedback

An object encapsulating the OpenGL feedback rendering mode.

TGLFeedbackMode

GLS.Feedback

TGLFile3DSActor

GLS.File3DSSceneObjects

TGLFile3DSAnimationData

GLS.File3DS

A record that holds all the information that is used during 3ds animation.

TGLFile3DSAnimationKeyList

GLS.File3DS

TGLFile3DSAnimationKeys

GLS.File3DS

An abstract class that describes how to interpolate animation keys.

TGLFile3DSAnimKeysClassType

GLS.File3DS

Used only for serialization. There probably is a more efficient way to do it.

TGLFile3DSCamera

GLS.File3DSSceneObjects

TGLFile3DSCameraObject

GLS.File3DS

A 3ds-specific camera.

TGLFile3DSColorAnimationKeys

GLS.File3DS

TGLFile3DSDummyObject

GLS.File3DS

A 3ds-specific TGLMorphableMeshObject.

TGLFile3DSFreeForm

GLS.File3DSSceneObjects

TGLFile3DSLight

GLS.File3DSSceneObjects

TGLFile3DSLightHotSpotAnimationKeys

GLS.File3DS

TGLFile3DSMeshObject

GLS.File3DS

A 3ds-specific mesh object.

TGLFile3DSOmniLightObject

GLS.File3DS

A 3ds-specific omni light.

TGLFile3DSPositionAnimationKeys

GLS.File3DS

TGLFile3DSRollAnimationKeys

GLS.File3DS

TGLFile3DSRotationAnimationKeys

GLS.File3DS

TGLFile3DSScaleAnimationKeys

GLS.File3DS

TGLFile3DSSpotLightCutOffAnimationKeys

GLS.File3DS

TGLFile3DSSpotLightObject

GLS.File3DS

A 3ds-specific spot light.

TGLFireFXManager

GLS.FireFX

Fire special effect manager. Defines the looks and behaviour of a particle system that can be made to look fire-like.

TGLFireParticle

GLS.FireFX

TGLFireParticleArray

GLS.FireFX

TGLFixedFunctionProperties

GLS.MaterialEx

TGLFlareElement

GLS.LensFlare

TGLFlareElements

GLS.LensFlare

TGLFlareGradient

GLS.LensFlare

The actual gradients between two colors are, of course, calculated by OpenGL. The start and end colors of a gradient are stored to represent the color of lens flare elements.

TGLFlatText

GLS.BitmapFont

A 2D text displayed and positionned in 3D coordinates. The FlatText uses a character font defined and stored by a TGLBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

TGLFlatTextOption

GLS.BitmapFont

TGLFlatTextOptions

GLS.BitmapFont

TGLfloat

GLScene.OpenGL4

TGLfloat

GLScene.OpenGLTokens

TGLFocusControl

GLS.Windows

TGLFogEnvironment

GLS.Scene

Parameters for fog environment in a scene. The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.

TGLForce

GLS.PhysForces

TGLForces

GLS.PhysManager

TGLForceType

GLS.PhysForces

TGLForm

GLS.Windows

TGLFormCanClose

GLS.Windows

TGLFormCanRequest

GLS.Windows

TGLFormCloseOptions

GLS.Windows

TGLFormMove

GLS.Windows

TGLFormNotify

GLS.Windows

TGLFPSMovementManager

GLS.FPSMovement

TGLFractalArchipelago

GLS.RandomHDS

TGLFractalHDS

GLS.RandomHDS

Random landscape based on the middle-point displacement algorithm

TGLFragmentProgram

GLSL.CustomShader

TGLFragmentShaderHandle

GLS.Context

Manages a handle to a Fragment Shader Object

TGLFrameBuffer

GLS.FBORenderer

TGLFrameBufferAttachment

GLS.MaterialEx

TGLFramebufferHandle

GLS.Context

Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered

TGLFramebufferStatus

GLS.Context

TGLFreeForm

GLS.VectorFileObjects

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

TGLFreeFormProxy

GLS.ProxyObjects

A proxy object specialized for FreeForms.

TGLFrustrum

GLS.GeomObjects

A frustrum is a pyramid with the top chopped off. The height of the imaginary pyramid is ApexHeight, the height of the frustrum is Height. If ApexHeight and Height are the same, the frustrum degenerates into a pyramid. Height cannot be greater than ApexHeight.

TGLFrustrumPart

GLS.GeomObjects

TGLFrustrumParts

GLS.GeomObjects

TGLFullScreenResolution

GLS.SceneForm

Defines how GLSceneForm will handle fullscreen request fcWindowMaximize: Use current resolution (just maximize form and hide OS bars) fcNearestResolution: Change to nearest valid resolution from current window size fcManualResolution: Use FFullScreenVideoMode settings

TGLFullScreenVideoMode

GLS.SceneForm

Screen mode settings

TGLFullScreenViewer

GLS.FullScreenViewer

A FullScreen viewer. This non visual viewer will, when activated, use the full screen as rendering surface. It will also switch/restore videomode depending on the required width/height. This is performed by creating an underlying TForm and using its surface for rendering OpenGL, "decent" ICDs will automatically use PageFlipping instead of BlockTransfer (slower buffer flipping mode used for windowed OpenGL). Note: if you terminate the application either via a kill or in the IDE, the original resolution isn't restored.

TGLGameMenu

GLS.GameMenu

Classic game menu interface made of several lines.

TGLGameMenuScale

GLS.GameMenu

TGLGeometryProgram

GLSL.CustomShader

TGLGeometryShaderHandle

GLS.Context

Manages a handle to a Geometry Shader Object

TGLGizmo

GLS.Gizmo

TGLGizmoAcceptEvent

GLS.Gizmo

TGLGizmoAxis

GLS.Gizmo

TGLGizmoElement

GLS.Gizmo

TGLGizmoElements

GLS.Gizmo

TGLGizmoEx

GLS.GizmoEx

TGLGizmoExAcceptEvent

GLS.GizmoEx

TGLGizmoExActionHistoryCollection

GLS.GizmoEx

TGLGizmoExActionHistoryItem

GLS.GizmoEx

TGLGizmoExAxis

GLS.GizmoEx

TGLGizmoExAxisSelected

GLS.GizmoEx

TGLGizmoExObjectCollection

GLS.GizmoEx

TGLGizmoExObjectItem

GLS.GizmoEx

TGLGizmoExOperation

GLS.GizmoEx

TGLGizmoExOperationMode

GLS.GizmoEx

TGLGizmoExPickMode

GLS.GizmoEx

TGLGizmoExReferenceCoordinateSystem

GLS.GizmoEx

TGLGizmoExSelectionRegion

GLS.GizmoEx

TGLGizmoExSelRec

GLS.GizmoEx

TGLGizmoExUIArrowLine

GLS.GizmoEx

TGLGizmoExUIDisk

GLS.GizmoEx

TGLGizmoExUIFlatText

GLS.GizmoEx

TGLGizmoExUIFrustrum

GLS.GizmoEx

Gizmo objects

TGLGizmoExUILines

GLS.GizmoEx

TGLGizmoExUIPolygon

GLS.GizmoEx

TGLGizmoExUISphere

GLS.GizmoEx

TGLGizmoExUITorus

GLS.GizmoEx

TGLGizmoExVisibleInfoLabel

GLS.GizmoEx

TGLGizmoExVisibleInfoLabels

GLS.GizmoEx

TGLGizmoOperation

GLS.Gizmo

TGLGizmoPickCube

GLS.Gizmo

TGLGizmoPickMode

GLS.Gizmo

TGLGizmoPickTorus

GLS.Gizmo

TGLGizmoRayCastHitData

GLS.Gizmo

TGLGizmoUndoCollection

GLS.Gizmo

TGLGizmoUndoItem

GLS.Gizmo

TGLGizmoUpdateEvent

GLS.Gizmo

TGLGizmoVisibleInfoLabel

GLS.Gizmo

TGLGizmoVisibleInfoLabels

GLS.Gizmo

TGLglTFVectorFile

GLS.FileGLTF

The glTF format is a runtime asset delivery format for GL APIs: WebGL, OpenGL ES OpenGL and Vulkan.

TGLGRDVectorFile

GLS.FileGRD

The GRD file represents ascii grid formats in 2D/3D. This is a format for storing regular grid values as a matrices of cell centers. The format supports variations and subformats. This importer works for Sutfer, ArcInfo and GMS formats

TGLGrowMethod

GLS.SpacePartition

TGLgsInTypes

GLSL.ShaderParameter

TGLgsOutTypes

GLSL.ShaderParameter

TGLGTSVectorFile

GLS.FileGTS

The GTS vector file (GNU Triangulated Surface library). It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces. Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices). http://gts.sourceforge.net/

TGLGuiComponent

GLS.Gui

TGLGuiComponentList

GLS.Gui

TGLGuiComponentName

GLS.Gui

TGLGuiElement

GLS.Gui

TGLGuiElementList

GLS.Gui

TGLGuiElementName

GLS.Gui

TGLGuiLayout

GLS.Gui

TGLGUILayoutEditor

GLS.SceneRegister

TGLhalf

GLScene.OpenGLTokens

TGLhandleARB

GLScene.OpenGLTokens

TGLHDRImage

GLS.FileHDR

TGLHeightData

GLS.HeightData

TGLHeightData = class (TObject)

TGLHeightDataClass

GLS.HeightData

TGLHeightDataPostRenderEvent

GLS.TerrainRenderer

TGLHeightDataSource

GLS.HeightData

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TGLHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TGLHeightData with its "Release" method) Pre-loading : specify a list of TGLHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task.

TGLHeightDataSourceFilter

GLS.HeightData

Height Data Source Filter. This component sits between the TGLTerrainRenderer, and a real TGLHeightDataSource. i.e. TGLTerrainRenderer links to this. This links to the real TGLHeightDataSource. Use the 'HeightDataSource' property, to link to a source HDS. The 'OnSourceDataFetched' event then gives you the opportunity to make any changes, or link in a texture to the TGLHeightData object, BEFORE it is cached. It bypasses the cache of the source HDS, by calling the source's StartPreparingData procedure directly. The TGLHeightData objects are then cached by THIS component, AFTER you have made your changes. This eliminates the need to copy and release the TGLHeightData object from the Source HDS's cache, before linking your texture. See the new version of TGLBumpmapHDS for an example. (LIN) To create your own HDSFilters, Derive from this component, and override the PreparingData procedure.

TGLHeightDataState

GLS.HeightData

Possible states for a TGLHeightData. hdsQueued : the data has been queued for loading hdsPreparing : the data is currently loading or being prepared for use hdsReady : the data is fully loaded and ready for use hdsNone : the height data does not exist for this tile

TGLHeightDataThread

GLS.HeightData

A thread specialized for processing TGLHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly

TGLHeightDataType

GLS.HeightData

Determines the type of data stored in a TGLHeightData. There are 3 data types (8 bits unsigned, signed 16 bits and 32 bits). Conversions: (128*(ByteValue-128)) = SmallIntValue = Round(SingleValue). The 'hdtDefault' type is used for request only, and specifies that the default type for the source should be used.

TGLHeightDataUser

GLS.HeightData

TGLHeightField

GLS.Graph

Renders a sampled height-field. HeightFields are used to materialize z=f(x, y) surfaces, you can use it to render anything from math formulas to statistics. Most important properties of an height field are its sampling scales (X & Y) that determine the extents and the resolution of the base grid. The component will then invoke it OnGetHeight event to retrieve Z values for all of the grid points (values are retrieved only once for each point). Each point may have an additionnal color and texture coordinate.

TGLHeightFieldColorMode

GLS.Graph

TGLHeightFieldGetHeight2Event

GLS.Graph

TGLHeightFieldGetHeightEvent

GLS.Graph

TGLHeightFieldOption

GLS.Graph

TGLHeightFieldOptions

GLS.Graph

TGLHeightTile

GLS.HeightTileFileHDS

TGLHeightTileFile

GLS.HeightTileFileHDS

Interfaces a Tiled file

TGLHeightTileFileHDS

GLS.HeightTileFileHDS

—————- TGLHeightTileFileHDS class ———————– An Height Data Source for the HTF format.

TGLHeightTileInfo

GLS.HeightTileFileHDS

TGLHexahedron

GLS.GeomObjects

TGLHexahedronProperties

GLS.MeshBuilder

Properties of a hexahedron with 6 quad parts

TGLHiddenLineShader

GLSL.LineShaders

TGLHintType

GLS.State

TGLHookesSpring

GLS.PhysForces

TGLHookesString

GLS.PhysForces

TGLHUDSprite

GLS.HUDObjects

A rectangular area, NOT perspective projected. (x, y) coordinates map directly to the viewport (in pixels) and refer the center of the area. The coordinate system is that of an equivalent TCanvas, ie. top-left point is the origin (0, 0). The z component is ignored and Z-Buffer is disabled when rendering. Using TGLHUDSprite in 2D only scenes : The most convenient way to use a TGLHUDSprite as a simple 2D sprite with blending capabilities (transparency or additive), is to set the texture mode to tmModulate, in FrontProperties, to use the Emission color to control coloring/intensity, and finally use the Diffuse color's alpha to control transparency (while setting the other RGB components to 0). You can also control aplha-blending by defining a <1 value in the sprite's AlphaChannel field. This provides you with hardware accelerated, alpha-blended blitting. Note : since TGLHUDSprite works in absolute coordinates, TGLProxyObject can't be used to duplicate an hud sprite.

TGLHUDText

GLS.HUDObjects

A 2D text displayed and positionned in 2D coordinates. The HUDText uses a character font defined and stored by a TGLBitmapFont component. The text can be scaled and rotated (2D), the layout and alignment can also be controled.

TGLIcosahedron

GLS.GeomObjects

TGLIDTFVectorFile

GLS.File3DPDF

The IDTF vector file (Intermediate Data Text File). Used for converting to IDTF -> U3D -> 3D PDF

TGLImage

GLS.Graphics

Contains and manipulates a 32 bits (24+8) bitmap. This is the base class for preparing and manipulating textures in GLS.Scene, this function does not rely on a windows handle and should be used for in-memory manipulations only. 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL. The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.

TGLImageClassProperty

GLS.SceneRegister

TGLImageDataFormat

Formats.DXTC

TGLImageLevelDesc

GLS.Graphics

TGLImageLODRange

GLS.Graphics

TGLImagePiramid

GLS.Graphics

TGLImmaterialSceneObject

GLS.Scene

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.

TGLImposter

GLS.Imposter

TGLImposterBuilder

GLS.Imposter

Abstract ImposterBuilder class.

TGLInertiaTensor

GLS.PhysInertias

Stores Inertia Tensor for TGLRigidBodyInertia model

TGLInfoForm

FmInfo

TGLInitializableObjectList

GLS.Scene

Just a list of objects that support IGLInitializable.

TGLint

GLScene.OpenGL4

TGLint

GLScene.OpenGLTokens

TGLint64

GLScene.OpenGL4

TGLint64

GLScene.OpenGLTokens

TGLint64EXT

GLScene.OpenGL4

TGLint64EXT

GLScene.OpenGLTokens

TglInternalCompression

GLScene.TextureFormat

Texture compression option. If OpenGL supports it, this will activate a compressed texture format: tcDefault : uses global default compression option tcNone : do not use compression tcStandard : use standard compression, average quality, average rate tcHighQuality : choose a high-quality, low-speed compression tcHighSpeed : choose a high-speed, low-quality compression

TglInternalFormat

GLScene.TextureFormat

TGLInterpolationType

GLScene.VectorGeometry

TGLintptr

GLScene.OpenGL4

the size of these depend on platform (32bit or 64bit)

TGLintptr

GLScene.OpenGLTokens

the size of these depend on platform (32bit or 64bit)

TGLIsoline

GLS.Isolines

TGLIsolines

GLS.Isolines

TGLIsolineState

GLS.Isolines

TGLIsoSurfaceExtractor

GLS.Isosurface

3D isosurface extractor class. This class allows to calculate and exctract isosurfaces from scalar field voxel models using a given isovalue

TGLJoint

GLS.PhysJoints

TGLJoystick

GLS.Joystick

A component interfacing the Joystick via the (regular) windows API.

TGLJPEGImage

GLS.FileJPEG

TGLLabel

GLS.Windows

TGLLandTile

GLS.RandomHDS

TMapOfLandscapes: array of array of TGLBaseRandomHDS;

TGLLayoutEditorForm

FmGuiLayoutEditor

TGLlConsoleEvent

GLS.Console

Event called when used presses the "Enter"

TGLLeavedSpacePartition

GLS.SpacePartition

Implements a list of all leaves added to the space partition, _not_ a good solution, but it can be used as a benchmark against more complex methods

TGLLensFlare

GLS.LensFlare

TGLLibArchive

GLS.ArchiveManager

Using the collection item for simultaneous work with several archives

TGLLibArchives

GLS.ArchiveManager

TGLLibAsmProgNameProperty

GLS.SceneRegister

TGLLibAttachmentNameProperty

GLS.SceneRegister

TGLLibCombinerNameProperty

GLS.SceneRegister

TGLLibMaterial

GLS.Material

Material in a material library. Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).

TGLLibMaterialEx

GLS.MaterialEx

TGLLibMaterialName

GLS.Material

TGLLibMaterialNameProperty

GLS.SceneRegister

TGLLibMaterialPickerForm

FmLibMaterialPicker

TGLLibMaterialProperty

GLS.MaterialEx

TGLLibMaterials

GLS.Material

A collection of materials, mainly used in material libraries.

TGLLibMaterialsEx

GLS.MaterialEx

TGLLibSamplerNameProperty

GLS.SceneRegister

TGLLibShaderNameProperty

GLS.SceneRegister

TGLLibTextureNameProperty

GLS.SceneRegister

TGLLifeColoredPFXManager

GLS.ParticleFX

Base PFX manager for particles with life colors. Particles have a core and edge color, for subclassing.

TGLLightmapBounds

GLS.MeshLines

TGLLightSource

GLS.Scene

Standard light source. The standard GLScene light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle). Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property. Lightsources are managed in a specific object by the TGLScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

TGLLightSourceEnum

GLSL.CustomShader

TGLLightSourceSet

GLSL.CustomShader

TGLLightSourceState

GLS.State

TGLLightStyle

GLS.Scene

Defines the various styles for lightsources. lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering)

TGLLimitType

GLS.Scene

IDs for limit determination

TGLLineBase

GLS.Objects

Base class for line objects. Introduces line style properties (width, color...)

TGLLineCollection

GLS.MeshLines

TGLLineItem

GLS.MeshLines

TGLLineNode

GLS.MeshLines

Specialized Node for use in a TGLLines objects. Adds a Width property

TGLLineNodes

GLS.MeshLines

Specialized collection for Nodes in TGLMeshLines objects. Stores TGLLineNode items.

TGLLineNodesAspect

GLS.Objects

Possible aspects for the nodes of a TLine.

TGLLineOperation

GLS.MeshLines

TGLLineParticle

GLS.LinePFX

Linear particle.

TGLLinePFXManager

GLS.LinePFX

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.

TGLLines

GLS.Objects

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.

TGLLineSettings

GLSL.LineShaders

TGLLinesNode

GLS.Objects

Specialized Node for use in a TGLLines objects. Adds a Color property (TGLColor) }

TGLLinesNodes

GLS.Objects

Specialized collection for Nodes in a TGLLines objects. Stores TGLLinesNode items

TGLLinesOption

GLS.Objects

TGLLinesOptions

GLS.Objects

TGLLineSplineMode

GLS.Objects

Available spline modes for a TLine.

TGLLink

GLS.PhysJoints

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

TGLListHandle

GLS.Context

Manages a handle to a display list

TGLLMTSVectorFile

GLS.FileLMTS

TGLLODStreamingState

GLS.Graphics

TGLLogicOp

GLS.State

TGLLWOVectorFile

GLS.FileLWO

TGLMagFilter

GLS.Texture

TGLMapCollection

GLS.FPSMovement

TGLMapCollectionItem

GLS.FPSMovement

TGLMapCollectionItemClass

GLS.FPSMovement

TGLMarchingCube

GLS.Isosurface

TGLMaterial

GLS.Material

Describes a rendering material. A material is basically a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping. An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TGLLibMaterial (taken for a material library). The TGLLibMaterial has more advanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps.

TGLMaterialComponentName

GLS.MaterialEx

TGLMaterialComponentNameProperty

GLS.SceneRegister

TGLMaterialEditorForm

FmMaterialEditor

TGLMaterialLevel

GLS.State

TGLMaterialLibrary

GLS.Material

Stores a set of materials, to be used and shared by scene objects. Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time. Materials in a material library also feature advanced control properties like texture coordinates transforms.

TGLMaterialLibraryEditor

GLS.SceneRegister

Editor for material library.

TGLMaterialLibraryEx

GLS.MaterialEx

TGLMaterialLibraryItem

GLS.MaterialScript

TGLMaterialLibraryItems

GLS.MaterialScript

TGLMaterialMultiProxy

GLS.MaterialMultiProxy

Multiple Proxy object. This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).

TGLMaterialMultiProxyMaster

GLS.MaterialMultiProxy

MasterObject description for a MultiProxy object.

TGLMaterialMultiProxyMasters

GLS.MaterialMultiProxy

Collection of TGLMaterialMultiProxyMaster.

TGLMaterialOption

GLS.Material

Control special rendering options for a material. moIgnoreFog : fog is deactivated when the material is rendered

TGLMaterialOptions

GLS.Material

TGLMaterialProperty

GLS.SceneRegister

TGLMaterialProxy

GLS.ProxyObjects

A proxy object with its own material. This proxy object can take a mesh from one master and a materia from a material library.

TGLMaterialScripter

GLS.MaterialScript

TGLMatLibComponents

GLS.MaterialEx

TGLMatrix

GLScene.VectorTypes

TGLMD2VectorFile

GLS.FileMD2

The MD2 vector file (Quake2 actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TGLActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap). Based on code by Roger Cao.

TGLMD3VectorFile

GLS.FileMD3

TGLMD5VectorFile

GLS.FileMD5

TGLMDCVectorFile

GLS.FileMDC

TGLMemoryViewer

GLS.Scene

Component to render a scene to memory only. This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).

TGLMesh

GLS.Mesh

Basic mesh object. Each mesh holds a set of vertices and a Mode value defines how they make up the mesh (triangles, strips...)

TGLMeshAutoCentering

GLS.VectorFileObjects

TGLMeshAutoCenterings

GLS.VectorFileObjects

TGLMeshLines

GLS.MeshLines

TGLMeshMode

GLS.Mesh

TGLMeshMorphTarget

GLS.VectorFileObjects

A morph target, stores alternate lists of vertices and normals.

TGLMeshMorphTargetList

GLS.VectorFileObjects

A list of TGLMeshMorphTarget objects.

TGLMeshNormalsOrientation

GLS.VectorFileObjects

Determines how normals orientation is defined in a mesh. - mnoDefault : uses default orientation - mnoInvert : inverse of default orientation - mnoAutoSolid : autocalculate to make the mesh globally solid - mnoAutoHollow : autocalculate to make the mesh globally hollow

TGLMeshObject

GLS.VectorFileObjects

Base mesh class. Introduces base methods and properties for mesh objects. Subclasses are named "TGLMOxxx".

TGLMeshObjectList

GLS.VectorFileObjects

A list of TGLMeshObject objects.

TGLMeshObjectListClass

GLS.VectorFileObjects

TGLMeshObjectMode

GLS.VectorFileObjects

TGLMeshObjectRenderingOption

GLS.VectorFileObjects

Rendering options per TGLMeshObject.moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list

TGLMeshObjectRenderingOptions

GLS.VectorFileObjects

TGLMeshObjectVerletNode

GLS.VerletClothify

TGLMeshOptimizerOption

GLS.MeshBuilder

TGLMeshOptimizerOptions

GLS.MeshBuilder

TGLMeshPrimitive

GLS.State

TGLMeshPrimitives

GLS.State

TGLMHeader

Formats.GL2

TGLMinFilter

GLS.Texture

TGLMirror

GLS.Mirror

A simple plane mirror. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered). It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.

TGLMirrorOption

GLS.Mirror

TGLMirrorOptions

GLS.Mirror

TGLMLODInfo

Formats.GL2

TGLMLODs

Formats.GL2

TGLMLODSurfaceOffsets

Formats.GL2

TGLMoonRingData

GLS.SkyDome

3ds files and DebrisAsteroid too

TGLMorphableMeshObject

GLS.VectorFileObjects

Mesh object with support for morph targets. The morph targets allow to change vertices and normals according to pre-existing "morph targets".

TGLMotionBlur

GLS.Blur

This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders. Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;) I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup.

TGLMouseAction

GLS.Windows

TGLMovement

GLS.Movement

TGLMovementPath

GLS.Movement

TGLMovementPaths

GLS.Movement

TGLMovementRotationMode

GLS.Movement

TGLMoveToPosJob

GLS.CameraController

TGLMP3File

GLS.FileMP3

Support for MP3 format. *Partial* support only, access to PCMData is NOT supported.

TGLMS3DVectorFile

GLS.FileMS3D

The MilkShape vector file. By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!

TGLMSurface

Formats.GL2

TGLMSurfaceHeader

Formats.GL2

TGLMSurfaceHeirachy

Formats.GL2

TGLMSurfaceHeirachyOffsets

Formats.GL2

TGLMTLFile

GLS.FileOBJ

A simple class that know how to extract infos from a mtl file. mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more): materials begin with a 'newmtl' command followed by material name *Kd command defines the diffuse color *map_Kd command defines the diffuse texture image *Ka/map_Ka define the ambient color and texmap *Ks/map_Ks define the specular color and texmap *Ke/map_Ke define the self-illumination/lightmap texmap map_Bump specifies the bump map *d specifies transparency (alpha-channel, range [0; 1]) map_d specifies the opcaity texture map Ns defines the specular exponent or shininess or phong specular (?) Ni is the refraction index (greater than 1) *illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting)

TGLMTriangle

Formats.GL2

TGLMultiMaterialShader

GLSL.MultiMaterialShader

TGLMultiPolygon

GLS.MultiPolygon

A polygon that can have holes and multiple contours. Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).

TGLMultiPolygonBase

GLS.MultiPolygon

Multipolygon is defined with multiple contours. The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator). The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one. Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended. TGLMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of GLS.VectorLists.

TGLMultiProxy

GLS.MultiProxy

Multiple Proxy object. This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).

TGLMultiProxyMaster

GLS.MultiProxy

MasterObject description for a MultiProxy object

TGLMultiProxyMasters

GLS.MultiProxy

Collection of TGLMultiProxyMaster.

TGLMultisampleImage

GLS.MultiSampleImage

TGLMultitextureCoordinator

GLS.XOpenGL

TGLMultitexturingProperties

GLS.MaterialEx

TGLMVectorFile

GLS.FileGL2

TGLMVertex

Formats.GL2

TGLNaviCube

GLS.Navigator

TGLNavigator

GLS.Navigator

TGLNavigator is the component for moving a TGLBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor. The four calls to get you started is TurnHorisontal : it turns left and right. TurnVertical : it turns up and down. MoveForward : moves back and forth. FlyForward : moves back and forth in the movingobject's direction The three properties to get you started is MovingObject : The Object that you are moving. UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't more like Descent. AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane...(no tilt and flying) InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal

TGLNavigatorAbstractParameters

GLS.SmoothNavigator

Includes a basic set of parameters that control the smoothness of movement.

TGLNavigatorAdjustDistanceParameters

GLS.SmoothNavigator

The wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work

TGLNavigatorAdjustDistanceParametersEx

GLS.SmoothNavigator

The wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.

TGLNavigatorGeneralParameters

GLS.SmoothNavigator

The wrapper for all general inertia parameters. These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.

TGLNavigatorInertiaParameters

GLS.SmoothNavigator

The wrapper for all parameters that affect the smoothness of movement

TGLNavigatorMoveAroundParameters

GLS.SmoothNavigator

The wrapper for all parameters that effect how the TGLBaseSceneObject.MoveObjectAround() procedure works

TGLNavigatorSmoothChangeItem

GLS.SmoothNavigator

Includes a basic set of parameters that control the smoothness of movement.

TGLNavigatorSmoothChangeItemClass

GLS.SmoothNavigator

TGLNavigatorSmoothChangeItems

GLS.SmoothNavigator

XCollection of TGLNavigatorSmoothChangeItem.

TGLNavigatorSmoothChangeSingle

GLS.SmoothNavigator

Smoothly change any Single value, so it will become TargetValue in the end.

TGLNavigatorSmoothChangeSingleGetEvent

GLS.SmoothNavigator

TGLNavigatorSmoothChangeSingleSetEvent

GLS.SmoothNavigator

TGLNavigatorSmoothChangeVector

GLS.SmoothNavigator

Smoothly change any Vector4f value, so it will become TargetValue in the end.

TGLNavigatorSmoothChangeVectorGetEvent

GLS.SmoothNavigator

TGLNavigatorSmoothChangeVectorSetEvent

GLS.SmoothNavigator

TGLNGDBehaviour

GLS.NGDManager

Basis structures for Behaviour style implementations.

TGLNGDBehaviourList

GLS.NGDManager

TGLNGDCollisions

GLS.NGDManager

TGLNGDDebugOption

GLS.NGDManager

TGLNGDDynamic

GLS.NGDManager

TGLNGDFrictionModels

GLS.NGDManager

TGLNGDHeightField

GLS.NGDManager

TComponent TList TWriter TReader TPersistent Samevalue isZero to compare single NGD.Joints, // old joints Physics.NewtonImport, // new version 4.0 PGLVector TGLVector TGLMatrix PGLMatrix NullHmgVector... TGLAffineVectorList for Tree TXCollection file function For show debug cube cone freeform...

TGLNGDJoint

GLS.NGDManager

TGLNGDJointBallAndSocket

GLS.NGDManager

TGLNGDJointHinge

GLS.NGDManager

TGLNGDJointKinematicController

GLS.NGDManager

TGLNGDJointPin

GLS.NGDManager

TGLNGDJointPin2

GLS.NGDManager

TGLNGDJointPivot

GLS.NGDManager

TGLNGDJoints

GLS.NGDManager

TGLNGDJointSlider

GLS.NGDManager

TGLNGDManager

GLS.NGDManager

TGLNGDManagerDebug

GLS.NGDManager

TGLNGDManagerDebugs

GLS.NGDManager

TGLNGDPickedActions

GLS.NGDManager

TGLNGDSolverModels

GLS.NGDManager

TGLNGDStatic

GLS.NGDManager

TGLNGDSurfaceItem

GLS.NGDManager

TGLNGDSurfacePair

GLS.NGDManager

TGLNMFVectorFile

GLS.FileNMF

TGLNode

GLS.Nodes

TGLNodedLines

GLS.Objects

Class that defines lines via a series of nodes. Base class, does not render anything

TGLNodes

GLS.Nodes

TGLNodesClass

GLS.Nodes

TGLNonVisualViewer

GLS.Scene

Base class for non-visual viewer. Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.

TGLNormalDirection

GLS.Scene

TGLNormalMapSpace

GLS.BumpmapHDS

TGLNormalSmoothing

GLS.Objects

Determines how and if normals are smoothed. - nsFlat : facetted look - nsSmooth : smooth look - nsNone : unlighted rendering, usefull for decla texturing

TGLNurbsVectorFile

GLS.FileNurbs

TGLObjectAfterEffect

GLS.Scene

An object effect that gets rendered at scene's end. No particular OpenGL matrices or material should be assumed.

TGLObjectBBChange

GLS.Scene

TGLObjectBBChanges

GLS.Scene

TGLObjectChange

GLS.Scene

Used to describe the changes in an object, which have to be reflected in the scene

TGLObjectChanges

GLS.Scene

TGLObjectManager

GLS.ObjectManager

TGLObjectPostEffect

GLS.Scene

An object effect that gets rendered after owner object's render. The current OpenGL matrices and material are that of the owner object.

TGLObjectPreEffect

GLS.Scene

An object effect that gets rendered before owner object's render. The current OpenGL matrices and material are that of the owner object.

TGLObjectsSorting

GLS.RenderContextInfo

Determines if objects are sorted, and how. Sorting is done level by level (and not for all entities), values are : osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst osNone : do not sort objects. osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. osRenderNearestFirst : render objects whose Position is the nearest to the camera first.

TGLObjectStyle

GLS.Scene

Possible styles/options for a GLScene object. Allowed styles are: osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered

TGLObjectStyles

GLS.Scene

TGLOBJVectorFile

GLS.FileOBJ

TGLOcclusionQueryHandle

GLS.Context

Manages a handle to an occlusion query. Requires OpenGL 1.5+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TGLOctahedron

GLS.GeomObjects

TGLOCTGLVectorFile

GLS.FileOCT

The OCT vector file (FSRad output).

TGLOctree

GLS.Octree

Manages an Octree containing references to triangles.

TGLOctreeNode

GLS.Octree

TGLOctreeSpacePartition

GLS.SpacePartition

Implements octrees

TGLODEBehaviour

GLS.ODEManager

Basis structures for behaviour style implementations

TGLODECollisionEvent

GLS.ODEManager

TGLODECollisionSurface

GLS.ODEManager

TGLODECollisionSurfaceMode

GLS.ODEManager

TGLODEContactPoint

GLS.ODEManager

TGLODECustomCollider

GLS.ODEManager

The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms. Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE

TGLODECustomCollisionEvent

GLS.ODEManager

TGLODEDynamic

GLS.ODEManager

TGLODEElementBase

GLS.ODEManager

TGLODEElementBox

GLS.ODEManager

ODE box implementation

TGLODEElementCapsule

GLS.ODEManager

ODE capped cylinder implementation

TGLODEElementClass

GLS.ODEManager

TGLODEElementCylinder

GLS.ODEManager

ODE cylinder implementation

TGLODEElementPlane

GLS.ODEManager

ODE plane implementation

TGLODEElements

GLS.ODEManager

TGLODEElementSphere

GLS.ODEManager

ODE sphere implementation

TGLODEElementTriMesh

GLS.ODEManager

ODE tri-mesh implementation

TGLODEGetParamCallback

GLS.ODEManager

TGLODEHeightField

GLS.ODEManager

Add this behaviour to a TGLHeightField or TGLTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.

TGLODEJointBall

GLS.ODEManager

ODE ball joint implementation

TGLODEJointBase

GLS.ODEManager

Base structures for ODE Joints

TGLODEJointFixed

GLS.ODEManager

ODE fixed joint implementation

TGLODEJointHinge

GLS.ODEManager

ODE hinge joint implementation

TGLODEJointHinge2

GLS.ODEManager

ODE hinge2 joint implementation

TGLODEJointList

GLS.ODEManager

Component front-end for storing ODE Joints

TGLODEJointOption

GLS.ODEManager

TGLODEJointOptions

GLS.ODEManager

TGLODEJointParams

GLS.ODEManager

TGLODEJoints

GLS.ODEManager

An XCollection decendant for ODE Joints

TGLODEJointSlider

GLS.ODEManager

ODE slider joint implementation

TGLODEJointUniversal

GLS.ODEManager

ODE universal joint implementation

TGLODEManager

GLS.ODEManager

The visual component to manage behaviours of ODE objects

TGLODEObjectCollisionEvent

GLS.ODEManager

TGLODERagdoll

GLS.ODERagdoll

TGLODERagdollBone

GLS.ODERagdoll

TGLODERagdollCube

GLS.ODERagdoll

TGLODERagdollDummyJoint

GLS.ODERagdoll

TGLODERagdollHingeJoint

GLS.ODERagdoll

TGLODERagdollUniversalJoint

GLS.ODERagdoll

TGLODERagdollWorld

GLS.ODERagdoll

TGLODESetParamCallback

GLS.ODEManager

TGLODESolverMethod

GLS.ODEManager

TGLODEStatic

GLS.ODEManager

TGLODESurfaceModes

GLS.ODEManager

TGLOnCustomPostEffectEvent

GLSL.PostEffects

TGLOnLightsChanged

GLS.State

TGLOpenGL

GLS.InitOpenGL

TGLOrbitalElements

GLS.SkyDome

For recomputation of TOrbitalElementsData

TGLOrbitToPosAdvJob

GLS.CameraController

TGLOrbitToPosJob

GLS.CameraController

TGLOutlineShader

GLSL.LineShaders

TGLPackPBOHandle

GLS.Context

Manages a handle to PBO Pixel Pack Buffer. When bound, commands such as ReadPixels write their data into a buffer object.

TGLPanel

GLS.Windows

TGLParticle

GLS.ParticleFX

Base class for particles. The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).

TGLParticleArray

GLS.ParticleFX

TGLParticleClass

GLS.ParticleFX

TGLParticleEvent

GLS.Particles

TGLParticleFXEffect

GLS.ParticleFX

Base class for linking scene objects to a particle FX manager.

TGLParticleFXManager

GLS.ParticleFX

Base class for particle FX managers. Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer. Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).

TGLParticleFXRenderer

GLS.ParticleFX

Rendering interface for scene-wide particle FX. A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately. This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.

TGLParticleInertia

GLS.PhysInertias

TGLParticleList

GLS.ParticleFX

List of particles. This list is managed with particles and performance in mind, make sure to check methods doc.

TGLParticles

GLS.Particles

Manager object of a particle system. Particles in a TGLParticles system are described as normal scene objects, however their children are to be : "particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. "live particle" : the other objects (index>0), this ones are rendered and receive progression events. TGLParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and GLScene objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle. All direct access to a TGLParticles children should be avoided. For high-performance particle systems of basic particles, you should look into GLParticleFX instead, TGLParticles being rather focused on complex particles.

TGLPathNode

GLS.Movement

TGLPathNodes

GLS.Movement

TGLPerlin3DNoise

GLS.PerlinPFX

Generates Perlin Noise in the [-1; 1] range. 2D noise requests are taken in the Z=0 slice

TGLPerlinHDS

GLS.Perlin

TGLPerlinHDSThread

GLS.Perlin

TGLPerlinInterpolation

GLS.Perlin

TGLPerlinOctav

GLS.Perlin

TGLPerlinPFXManager

GLS.PerlinPFX

A sprite-based particles FX manager using perlin-based sprites. This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles. The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.

TGLPersistentImage

GLS.Texture

Stores any image compatible with Delphi's TPicture mechanism. The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour of TImage. Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)

TGLPersistentTIE

GLS.TextureImageEditors

TGLPGMImage

GLS.FilePGM

TGLPhongShader

GLSL.PhongShader

TGLPhysManager

GLS.PhysManager

The Simple Physics Interaction (SPI) manager can only deal with objects from one scene More than one physics manager can be assigned to a scene

TGLPicFileImage

GLS.Texture

Uses a picture whose data is found in a file (only filename is stored). The image is unloaded after upload to OpenGL.

TGLPicFileTIE

GLS.TextureImageEditors

TGLPickList

GLS.Selection

List class for object picking. This list is used to store the results of a PickObjects call.

TGLPictureImage

GLS.Texture

Base class for image data classes internally based on a TPicture.

TGLPipe

GLS.Extrusion

A solid object generated by extruding a circle along a trajectory. Texture coordinates NOT supported yet.

TGLPipeNode

GLS.Extrusion

TGLPipeNodes

GLS.Extrusion

TGLPixel24

GLS.Graphics

TGLPixel32

GLS.Graphics

TGLPixel32Array

GLS.Graphics

TGLPlane

GLS.Objects

A simple plane object. Note that a plane is always made of a single quad (two triangles) and the tiling is only applied to texture coordinates.

TGLPlaneStyle

GLS.Objects

TGLPlaneStyles

GLS.Objects

TGLPlanetData

GLS.SkyDome

TGLPLYVectorFile

GLS.FilePLY

The PLY vector file aka Stanford Triangle Format. This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.

TGLPNGImage

GLS.FilePNG

TGLPointLightPFXManager

GLS.ParticleFX

A sprite-based particles FX managers using point light maps. The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property. This PFX manager renders particles similar to what you can get with TGLPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.

TGLPointParameters

GLS.Objects

Point parameters as in ARB_point_parameters. Make sure to read the ARB_point_parameters spec if you want to understand what each parameter does.

TGLPoints

GLS.Objects

Renders a set of non-transparent colored points. The points positions and their color are defined through the Positions and Colors properties

TGLPointStyle

GLS.Objects

TGLPolygon

GLS.GeomObjects

A basic polygon object. The contour is described by the Nodes and SplineMode properties, it should be planar and is automatically tessellated. Texture coordinates are deduced from X and Y coordinates only. This object allows only for polygons described by a single contour, if you need "complex polygons" with holes, patches and cutouts, see GLS.MultiPolygon.

TGLPolygonBase

GLS.Objects

Base class for objects based on a polygon

TGLPolygonList

GLS.MultiPolygon

TGLPolygonMode

GLS.State

TGLPolygonPart

GLS.GeomObjects

TGLPolygonParts

GLS.GeomObjects

TGLPolygonPFXManager

GLS.ParticleFX

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.

TGLPolyTet

GLS.Polyhedra

A PolyTet object that handles polygyns for tetrahedron

TGLPopupMenu

GLS.Windows

TGLPopupMenuClick

GLS.Windows

TGLPortal

GLS.Portal

Portal Renderer class.

TGLPortalMeshObjectList

GLS.Portal

A mesh object list that handles portal rendering. The items are treated as being sectors.

TGLPostEffect

GLSL.PostEffects

Provides a simple way to producing post-effects without shaders. It is slow as hell, but it's worth it in some cases.

TGLPostEffectBuffer

GLSL.PostEffects

TGLPostEffectColor

GLSL.PostEffects

TGLPostEffectPreset

GLSL.PostEffects

Some presets for TGLPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.

TGLPostShaderCollection

GLSL.PostEffects

TGLPostShaderCollectionItem

GLSL.PostEffects

TGLPostShaderHolder

GLSL.PostEffects

A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.

TGLPrimitiveQueryHandle

GLS.Context

Manages a handle to a primitive query. Requires OpenGL 3.0+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TGLPrismaticJoint

GLS.PhysJoints

TGLProcTextureNoise

GLS.ProcTextures

TGLProcTextureNoiseTIE

GLS.TextureImageEditors

TGLProgram

GLS.InitOpenGL

TGLProgramHandle

GLS.Context

Manages a GLSL Program Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user

TGLProjectedTextures

GLS.ProjectedTextures

Projected Textures Manager. Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).

TGLProjectedTexturesStyle

GLS.ProjectedTextures

Possible styles of texture projection. Possible values: ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures).

TGLProxyObject

GLS.Scene

A full proxy object. This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own. Use it for duplicates of an object.

TGLProxyObjectClass

GLS.Scene

TGLProxyObjectOption

GLS.Scene

Defines which features are taken from the master object.

TGLProxyObjectOptions

GLS.Scene

TGLPythonEngine

GLS.Pythons.Script

This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TGLScriptPython) retain it's assigned compiler from design to run -time.

TGLQ3BSPVectorFile

GLS.FileQ3BSP

The Q3BSP vector file (Quake III BSP).

TGLQuadricObject

GLS.Objects

Base class for quadric objects. Introduces some basic Quadric interaction functions (the actual quadric math is part of the GLU library).

TGLQuadtreeSpacePartition

GLS.SpacePartition

Implements quadtrees. Quadtrees are hardcoded to completely ignore the Y axis, only using X and Z to determine positioning. This means that they're well suited for 2d-ish situations (landscapes with trees for instance) but not for fully 3d situations (space fighting)

TGLQueryHandle

GLS.Context

Manages a handle to a query. Do not use this class directly, use one of its subclasses instead.

TGLQueryType

GLS.State

TGLRadialGravityEmitter

GLS.PhysFields

TGLRagdolBone

GLS.Ragdoll

TGLRagdolBoneList

GLS.Ragdoll

TGLRagdolJoint

GLS.Ragdoll

TGLRagdoll

GLS.Ragdoll

TGLRasterFileFormat

GLS.Graphics

TGLRasterFileFormatsList

GLS.Graphics

Stores registered raster file formats.

TGLRCHandle

GLS.Context

TGLRCOption

GLS.Context

TGLRCOptions

GLS.Context

TGLRenderbuffer

GLS.FBORenderer

TGLRenderbufferHandle

GLS.Context

Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).

TGLRenderContextClippingInfo

GLS.RenderContextInfo

TGLRenderContextInfo

GLS.RenderContextInfo

Stores contextual info useful during rendering methods.

TGLRenderPoint

GLS.Scene

Scene object that allows other objects to issue rendering at some point. This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase. Callbacks must be explicitly unregistered.

TGLResolutionIndependantHUDText

GLS.HUDObjects

Position (X and Y) is expected in a [0..1] range (from Screen size) This component converts this position to the actual screen position and renders the text there. This way a HUD text always appears to be in the the same place, regardless of the currect screen resolution. Note: this still does not solve the font scaling problem.

TGLResolutionProperty

GLS.SceneRegister

TGLResourceStream

GLS.ApplicationFileIO

TGLResourceType

GLS.CUDA.APIComps

TGLReuseableDefaultEditor

GLS.SceneRegister

Editor copied from DsgnIntf. Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TGLSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! and he did that again in D7! Grrr...

TGLRevoluteJoint

GLS.PhysJoints

TGLRevolutionSolid

GLS.Extrusion

A solid object generated by rotating a curve along the Y axis. The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF). The TGLRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution. If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.

TGLRevolutionSolidPart

GLS.Extrusion

TGLRevolutionSolidParts

GLS.Extrusion

TGLRigidBodyInertia

GLS.PhysInertias

A more complex model than TGLBInertia for Inertia

TGLROAMPatch

GLS.ROAMPatch

TGLSamplerHandle

GLS.Context

Manages a handle to a sampler

TGLSamplingScale

GLS.Graph

TGLSArchiveManager

GLS.ArchiveManager

ArchiveManager class

TGLSArchiveManagerEditor

GLS.SceneRegister

Editor for Archive Manager

TGLScene

GLS.Scene

Scene component class. The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TGLBaseSceneObject. It will usually contain one or more TGLCamera object, which can be referred by a Viewer component for rendering purposes. The scene's objects can be accessed directly from code (as regular components), but those are edited with a specific editor (double-click on the TGLScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TGLBaseSceneObject.

TGLSceneBuffer

GLS.Scene

Encapsulates a frame/rendering buffer.

TGLSceneEditor

GLS.SceneRegister

TGLSceneEditorForm

FmSceneEditor

TGLSceneForm

GLS.SceneForm

TGLSceneObj

GLS.SpacePartition

Object for holding glscene objects in a spatial partitioning

TGLSceneObject

GLS.Scene

Base class for standard scene objects. Publishes the Material property.

TGLSceneObjectClass

GLS.Scene

TGLSceneObjectEntry

GLS.ObjectManager

holds a relation between an scene object class, its global identification, its location in the object stock and its icon reference

TGLSceneOperation

GLS.Scene

Flags for design notification

TGLSceneRootObject

GLS.Scene

This class shall be used only as a hierarchy root. It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations. Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.

TGLSceneViewer

GLS.SceneViewer

Component where the GLScene objects get rendered. This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap. It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form). This viewer also allows to define rendering options such as fog, face culling, depth testing, etc. and can take care of framerate calculation.

TGLSceneViewerEditor

GLS.SceneRegister

TGLSceneViewerMode

GLS.Scene

TGLScreenControlingContext

GLS.Context

A TGLContext with screen control property and methods. This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API. TGLSceneViewer won't use them, TGLMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass

TGLScreenDepth

GLS.FullScreenViewer

TGLScreenSaver

GLS.ScreenSaver

Drop this component on your main form to make it a screensaver. You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab). How this component works : At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) At run-time, once its props are loaded, this component will parse the command line and trigger relevant events Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible) There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).

TGLScriptBase

GLS.ScriptBase

The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.

TGLScriptLibrary

GLS.ScriptBase

Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.

TGLScriptPython

GLS.Pythons.Script

Implements Python scripting functionality through the abstracted GLS.ScriptBase

TGLScripts

GLS.ScriptBase

XCollection descendant for storing and handling scripts.

TGLScriptState

GLS.ScriptBase

TGLScrollbar

GLS.Windows

TGLSCustomMemo

GLS.Memo

TGLSectoredSpacePartition

GLS.SpacePartition

Implements sectored space partitioning, sectored space partitions include Octrees, Quadtrees and BSP-trees

TGLSectorMeshObject

GLS.Portal

A portal renderer sector.

TGLSectorNode

GLS.SpacePartition

Implements a SectorNode node. Each node can have 0 or 8 children, each child being a portion of the size of the parent. For quadtrees, that's 1/4, for octrees, it's 1/8

TGLSectorNodeArray

GLS.SpacePartition

TGLSelectRenderModeTechnique

GLS.Selection

TglSeparateTextureWrap

GLScene.TextureFormat

Texture addressing rules

TGLShadeModel

GLS.Scene

TGLShader

GLS.InitOpenGL

TGLShader

GLS.Material

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

TGLShaderClass

GLS.Material

TGLShaderCombiner

GLSL.ShaderCombiner

TGLShaderCombinerType

GLSL.ShaderCombiner

MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader. sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself
TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.

TGLShaderEditorProperty

GLS.SceneRegister

TGLShaderEvent

GLSL.CustomShader

TGLShaderEx

GLS.MaterialEx

TGLShaderF

GLS.InitOpenGL

TGLShaderFailedInitAction

GLS.Material

Defines what to do if for some reason shader failed to initialize. fiaSilentdisable: just disable it fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage fiaReRaiseException: Re-raises the exception fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;)

TGLShaderFogSupport

GLSL.CustomShader

TGLShaderG

GLS.InitOpenGL

TGLShaderHandle

GLS.Context

Manages a handle to a Shader Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead

TGLShaderHandleClass

GLS.Context

TGLShaderItem

GLS.MaterialScript

TGLShaderItems

GLS.MaterialScript

TGLShaderLightSourceState

GLS.State

TGLShaderModel3

GLS.MaterialEx

TGLShaderModel4

GLS.MaterialEx

TGLShaderModel5

GLS.MaterialEx

TGLShaderProgram

GLSL.CustomShader

A custom shader program.

TGLShaderStyle

GLS.Material

Define GLShader style application relatively to a material. ssHighLevel: shader is applied before material application, and unapplied after material unapplication ssLowLevel: shader is applied after material application, and unapplied before material unapplication ssReplace: shader is applied in place of the material (and material is completely ignored)

TGLShaderType

GLS.MaterialEx

TGLShaderUnAplyEvent

GLSL.CustomShader

TGLShaderUniform

GLS.MaterialEx

TGLShaderUniformDSA

GLS.MaterialEx

TGLShaderUniformEditor

FmShaderUniformEditor

TGLShaderUniformTexture

GLS.MaterialEx

TGLShaderV

GLS.InitOpenGL

TGLShadowCastingMode

GLS.ShadowVolume

Determines when a caster should actually produce a shadow; scmAlways : Caster always produces a shadow, ignoring visibility scmVisible : Caster casts shadow if the object has visible=true scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true scmParentVisible : Caster produces shadow if parent has visible=true scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting)

TGLShadowHDS

GLS.ShadowHDS

An Height Data Source that generates terrain shadow maps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.

TGLShadowPlane

GLS.ShadowPlane

A simple shadow plane. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered). If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently. You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones

TGLShadowVolume

GLS.ShadowVolume

Simple shadow volumes. Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection. Shadow volumes require that the buffer allows stencil buffers, GLSceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly. Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.

TGLShadowVolumeCapping

GLS.ShadowVolume

Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option. Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera.
svcDefault : Default behaviour svcAlways : Always generates caps svcNever : Never generates caps

TGLShadowVolumeCaster

GLS.ShadowVolume

Specifies an individual shadow caster. Can be a light or an opaque object.

TGLShadowVolumeCasters

GLS.ShadowVolume

Collection of TGLShadowVolumeCaster.

TGLShadowVolumeLight

GLS.ShadowVolume

Specifies an individual shadow casting light.

TGLShadowVolumeMode

GLS.ShadowVolume

Shadow rendering modes. svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) svmOff : no shadowing will take place

TGLShadowVolumeOccluder

GLS.ShadowVolume

Specifies an individual shadow casting occluder.

TGLShadowVolumeOption

GLS.ShadowVolume

Shadow volume rendering options/optimizations. svoShowVolumes : make the shadow volumes visible svoDesignVisible : the shadow are visible at design-time svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface

TGLShadowVolumeOptions

GLS.ShadowVolume

TGLShininess

GLS.Material

TGLshort

GLScene.OpenGL4

TGLshort

GLScene.OpenGLTokens

TGLSilhouette

GLS.Silhouette

Base class storing a volume silhouette. Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system. This is the base class, you can use the TGLSilhouette subclass if you need some helper methods for generating the indexed sets.

TGLSilhouetteParameters

GLS.Silhouette

Silouhette generation parameters. SeenFrom and LightDirection are expected in local coordinates.

TGLSimpleNavigation

GLS.SimpleNavigation

TGLSimpleNavigationAction

GLS.SimpleNavigation

TGLSimpleNavigationCustomActionEvent

GLS.SimpleNavigation

TGLSimpleNavigationKeyCombination

GLS.SimpleNavigation

TGLSimpleNavigationKeyCombinations

GLS.SimpleNavigation

TGLSimpleNavigationOption

GLS.SimpleNavigation

TGLSimpleNavigationOptions

GLS.SimpleNavigation

Show FPS

TGLSize

GLS.RenderContextInfo

TGLsizei

GLScene.OpenGL4

TGLsizei

GLScene.OpenGLTokens

TGLsizeiptr

GLScene.OpenGL4

TGLsizeiptr

GLScene.OpenGLTokens

TGLSkeleton

GLS.VectorFileObjects

Main skeleton object. This class stores the bones hierarchy and animation frames. It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.

TGLSkeletonBone

GLS.VectorFileObjects

A skeleton bone or node and its children. This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TGLSkeletonFrame, but the calculated bone matrices are stored here.

TGLSkeletonBoneList

GLS.VectorFileObjects

A list of skeleton bones

TGLSkeletonCollider

GLS.VectorFileObjects

A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.

TGLSkeletonColliderList

GLS.VectorFileObjects

List class for storing TGLSkeletonCollider objects

TGLSkeletonFrame

GLS.VectorFileObjects

Stores position and rotation for skeleton joints. If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty)

TGLSkeletonFrameList

GLS.VectorFileObjects

A list of TGLSkeletonFrame objects

TGLSkeletonFrameTransform

GLS.VectorFileObjects

TGLSkeletonMeshObject

GLS.VectorFileObjects

A mesh object with vertice bone attachments. The class adds per vertex bone weights to the standard morphable mesh. The TGLVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method. When BonesPerVertex is 1, the weight is ignored (set to 1.0).

TGLSkeletonRootBoneList

GLS.VectorFileObjects

This list store skeleton root bones exclusively

TGLSkinEditorForm

FmGuiSkinEditor

TGLSkyBox

GLS.SkyDome

TGLSkyBoxStyle

GLS.SkyDome

————————- SkyBox class ————————-

TGLSkyDome

GLS.SkyDome

Renders a sky dome always centered on the camera. If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system. The skydome is described by "bands", each "band" is a horizontal cut of a sphere, and you can have as many bands as you wish

TGLSkyDomeBand

GLS.SkyDome

——————— SkyDome classes —————————–

TGLSkyDomeBands

GLS.SkyDome

TGLSkyDomeOption

GLS.SkyDome

TGLSkyDomeOptions

GLS.SkyDome

TGLSkyDomeStar

GLS.SkyDome

TGLSkyDomeStars

GLS.SkyDome

TGLSLBumpShader

GLSL.BumpShaders

TGLSLBumpShaderAM

GLSL.BumpShaders

TGLSLBumpShaderMT

GLSL.BumpShaders

One light shaders.

TGLSLDataType

GLSL.ShaderParameter

TGLSLDiffuseSpecularShader

GLSL.DiffuseSpecularShader

TGLSLDiffuseSpecularShaderMT

GLSL.DiffuseSpecularShader

******** Published Stuff ************

TGLSLFurShader

GLSL.ShapeShaders

TGLSLGlassShader

GLSL.ShapeShaders

TGLSLHandle

GLS.Context

Base class for GLSL handles (programs and shaders). Do not use this class directly, use one of its subclasses instead

TGLSLIvoryShader

GLSL.ShapeShaders

TGLSLLatticeShader

GLSL.ShapeShaders

TGLSLMLBumpShader

GLSL.BumpShaders

Multi light shaders.

TGLSLMLBumpShaderMT

GLSL.BumpShaders

TGLSLMLDiffuseSpecularShader

GLSL.DiffuseSpecularShader

TGLSLMLDiffuseSpecularShaderMT

GLSL.DiffuseSpecularShader

TGLSLogger

GLScene.Logger

Abstract class for control logging.

TGLSLPostBlurShader

GLSL.PostShaders

TGLSLPostDreamVisionShader

GLSL.PostShaders

TGLSLPostFrostShader

GLSL.PostShaders

TGLSLPostNightVisionShader

GLSL.PostShaders

TGLSLPostPixelateShader

GLSL.PostShaders

TGLSLPostPosterizeShader

GLSL.PostShaders

TGLSLPostThermalVisionShader

GLSL.PostShaders

TGLSLPostTroubleShader

GLSL.PostShaders

TGLSLProjectedTextures

GLSL.ProjectedTextures

Projected Texture Manager. Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.

TGLSLProjectedTexturesStyle

GLSL.ProjectedTextures

TGLSLSamplerType

GLSL.ShaderParameter

TGLSLSemShader

GLSL.ShapeShaders

TGLSLShader

GLSL.Shader

TGLSLShaderEvent

GLSL.Shader

TGLSLShaderEventEx

GLSL.Shader

TGLSLShaderParameter

GLSL.Shader

Wrapper around a parameter of a GLSL program.

TGLSLShaderUnApplyEvent

GLSL.Shader

TGLSLSimpleErosionShader

GLSL.ShapeShaders

TGLSLSimpleGoochShader

GLSL.ShapeShaders

TGLSLSimpleLatticeShader

GLSL.ShapeShaders

TGLSLTextureEmitter

GLSL.ProjectedTextures

A projected texture emmiter. Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader

TGLSLTextureEmitterItem

GLSL.ProjectedTextures

Specifies an item on the TGLSLTextureEmitters collection.

TGLSLTextureEmitters

GLSL.ProjectedTextures

Collection of TGLSLTextureEmitter.

TGLSLToonShader

GLSL.ShapeShaders

TGLSLVertexDisplacementShader

GLSL.ShapeShaders

TGLSmartSwarmMode

GLS.SmartObjects

TGLSMBASS

GLS.Sounds.BASS

TGLSMDVectorFile

GLS.FileSMD

The SMD vector file is Half-life's skeleton format. The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames. This reader curently reads both, but requires that the main file (the one with mesh data) be read first.

TGLSMemo

GLS.Memo

TGLSMemoAbstractScrollableObject

GLS.Memo

TGLSMemoDelCharUndo

GLS.Memo

TGLSMemoDeleteBufUndo

GLS.Memo

TGLSMEmoDelLineUndo

GLS.Memo

TGLSMemoGutter

GLS.Memo

TGLSMemoInsCharUndo

GLS.Memo

TGLSMemoPasteUndo

GLS.Memo

TGLSMemoScrollBar

GLS.Memo

TGLSMemoSelUndo

GLS.Memo

TGLSMemoStringList

GLS.Memo

TGLSMemoStrings

GLS.Memo

TGLSMemoUndo

GLS.Memo

TGLSMemoUndoList

GLS.Memo

TGLSMFMOD

GLS.Sounds.FMOD

TGLSmoothNavigator

GLS.SmoothNavigator

The component for moving a TGLBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor. It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.

TGLSmoothOrbitToPos

GLS.CameraController

TGLSmoothOrbitToPosAdvJob

GLS.CameraController

TGLSmoothUserInterface

GLS.SmoothNavigator

The component which reads the userinput and transform it into action. Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....

TGLSMOpenAL

GLS.Sounds.OpenAL

TGLSMVectorFile

GLS.VectorFileObjects

GLSM (GLScene Mesh) vector file. This corresponds to the 'native' GLScene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GLScene features.

TGLSMWaveOut

GLS.Sounds.WaveOut

Basic sound manager based on WinMM waveOut function. This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality. Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).

TGLSoundEnvironment

GLS.SoundManager

EAX standard sound environments.

TGLSoundFile

GLS.SoundFileObjects

Abstract base class for different Sound file formats. The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TGLSoundFile is very similar to TGraphic (see Delphi Help). Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.

TGLSoundFileClass

GLS.SoundFileObjects

TGLSoundFileFormat

GLS.SoundFileObjects

TGLSoundFileFormatsList

GLS.SoundFileObjects

TGLSoundFileProperty

GLS.SceneRegister

TGLSoundLibrary

GLS.SoundManager

TGLSoundLibrarySelectionEditor

GLS.SceneRegister

Selection editor for TGLSoundLibrary Allows units to be added to the uses clause automatically when sound files are loaded into a TGLSoundLibrary at design-time.

TGLSoundManager

GLS.SoundManager

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

TGLSoundNameProperty

GLS.SceneRegister

TGLSoundSample

GLS.SoundManager

Platform Specific
.NET Stores a single PCM coded sound sample.

TGLSoundSamples

GLS.SoundManager

TGLSoundSampling

GLS.SoundFileObjects

Defines a sound sampling quality.

TGLSoundSource

GLS.SoundManager

Origin of sound playback. Just publishes the 'Origin' property. Note that the "orientation" is the the source's Direction, ie. the "Z" vector.

TGLSoundSourceChange

GLS.SoundManager

TGLSoundSourceChanges

GLS.SoundManager

TGLSoundSources

GLS.SoundManager

TGLSourcePFXDispersionMode

GLS.ParticleFX

TGLSourcePFXEffect

GLS.ParticleFX

Simple Particles Source.

TGLSourcePFXPositionMode

GLS.ParticleFX

TGLSourcePFXVelocityMode

GLS.ParticleFX

TGLSpacePartitionLeaf

GLS.SpacePartition

Used to store the actual objects in the SpacePartition

TGLSpacePartitionLeafList

GLS.SpacePartition

List for storing space partition leaves

TGLSpacePartitionLeafS

GLS.SpacePartition

The Space Partition updating for a bounding sphere

TGLSpaceText

GLS.SpaceText

Renders a text in 3D.

TGLSpaceTextCharRange

GLS.SpaceText

TGLSphere

GLS.Objects

A sphere object. The sphere can have to and bottom caps, as well as being just a slice of sphere. Ref: https://mathworld.wolfram.com/Sphere.html Ref: https://mathworld.wolfram.com/GeodesicDome.html

TGLSphereProperties

GLS.MeshBuilder

Properties of a sphere with two hemispheres using 5 points to make each hemisphere part

TGLSprite

GLS.Objects

A rectangular area, perspective projected, but always facing the camera. A TGLSprite is perspective projected and as such is scaled with distance, if you want a 2D sprite that does not get scaled, see TGLHUDSprite.

TGLSpriteAnimation

GLS.AnimatedSprite

Animations define how the texture coordinates for each offset are to be determined.

TGLSpriteAnimationList

GLS.AnimatedSprite

A collection for storing SpriteAnimation objects.

TGLSpriteAnimationMode

GLS.AnimatedSprite

Sets the current animation playback mode: samNone - No playback, the animation does not progress. samPlayOnce - Plays the animation once then switches to samNone. samLoop - Play the animation forward in a continuous loop. samLoopBackward - Same as samLoop but reversed direction. samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached.

TGLSpriteAnimFrame

GLS.AnimatedSprite

Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.

TGLSpriteAnimFrameList

GLS.AnimatedSprite

TGLSpriteAnimMargins

GLS.AnimatedSprite

Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.

TGLSpriteFrameDimensions

GLS.AnimatedSprite

Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.

TGLSSynHiMemo

GLS.Memo

————————————————————– SYNTAX MEMO - declaration ————————————————————–

TGLStarData

GLS.SkyDome

TGLStarRecord

GLS.SkyDome

TGLStarSysData

GLS.SkyDome

TGLState

GLS.State

Reflects all relevant (binary) states of OpenGL subsystem

TGLStateCache

GLS.State

Manages an application-side cache of OpenGL states and parameters. Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context

TGLStates

GLS.State

TGLStateType

GLS.State

TGLStateTypes

GLS.State

TGLStaticImposterBuilder

GLS.Imposter

Builds imposters whose texture is a catalog of prerendered views.

TGLStaticImposterBuilderCorona

GLS.Imposter

Describes a set of orientation in a corona fashion.

TGLStaticImposterBuilderCoronas

GLS.Imposter

TGLStencilFunction

GLS.State

TGLStencilOp

GLS.State

TGLStencilPrecision

GLS.FBORenderer

TGLStencilRBO

GLS.FBORenderer

TGLStiffnessSetVH

GLS.VerletTypes

TGLStiffnessVH

GLS.VerletTypes

TGLSTLVectorFile

GLS.FileSTL

TGLString

GLScene.OpenGL4

TGLStringGrid

GLS.Windows

TGLSuperellipsoid

GLS.Objects

A Superellipsoid object. The Superellipsoid can have top and bottom caps, as well as being just a slice of Superellipsoid. Ref: https://mathworld.wolfram.com/Superellipse.html

TGLSwartSwarm

GLS.SmartObjects

Synchronize self thinking with an other thinkers in the swarm Copies Ai/Current/End values,ThinkingMode and GridInterpolation. procedure Synchronize(IntelSwarm: TGLIntelSwarm);

TglSwizzleVector

GLScene.TextureFormat

TGLsync

GLScene.OpenGL4

TGLsync

GLScene.OpenGLTokens

TGLTeapot

GLS.GeomObjects

The classic teapot. The only use of this object is as placeholder for testing...

TGLTerrainBaseHDS

GLS.HeightData

TerrainBase-based Height Data Source. This component takes its data from the TerrainBase Gobal Terrain Model. Though it can be used directly, the resolution of the TerrainBase dataset isn't high enough for accurate short-range representation and the data should rather be used as basis for further (fractal) refinement. TerrainBase is freely available from the National Geophysical Data Center and World Data Center web site (http://ngdc.noaa.com). (this component expects to find "tbase.bin" in the current directory).

TGLTerrainRenderer

GLS.TerrainRenderer

Basic terrain renderer. This renderer uses no sophisticated meshing, it just builds and maintains a set of terrain tiles, performs basic visibility culling and renders its stuff. You can use it has a base class/sample for more specialized terrain renderers. The Terrain heightdata is retrieved directly from a TGLHeightDataSource, and expressed as z=f(x, y) data.

TGLTessControlShaderHandle

GLS.Context

Manages a handle to a Tessellation Control Shader Object

TGLTessEvaluationShaderHandle

GLS.Context

Manages a handle to a Tessellation Evaluation Shader Object

TGLTetrahedron

GLS.GeomObjects

This objects has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

TGLTexCombineShader

GLSL.TextureShaders

A shader that can setup the texture combiner.

TGLTextAdjust

GLS.SpaceText

TGLTextHorzAdjust

GLS.SpaceText

Note: haAligned, haCentrically, haFitIn have not been implemented!

TGLTexture

GLS.Texture

Defines basic texturing properties. You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default). A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TGLTextureImageAlpha).

TGLTextureArray

GLS.FBORenderer

TGLTextureBufferHandle

GLS.Context

Manages a handle to a Buffer Texture. (TBO)

TGLTextureChange

GLS.Texture

TGLTextureChanges

GLS.Texture

TGLTextureCombiner

GLS.MaterialEx

TglTextureCompareMode

GLScene.TextureFormat

Specifies the texture comparison mode for currently bound depth textures. That is, a texture whose internal format is tfDEPTH_COMPONENT*

TGLTextureCompression

GLS.Texture

TGLTexturedHDS

GLS.TexturedHDS

TGLTextureEmitter

GLS.ProjectedTextures

A projected texture emmiter. It's material property will be used as the projected texture. Can be places anywhere in the scene.

TGLTextureEmitterItem

GLS.ProjectedTextures

Specifies an item on the TGLTextureEmitters collection.

TGLTextureEmitters

GLS.ProjectedTextures

Collection of TGLTextureEmitter.

TGLTextureEx

GLS.Texture

TGLTextureExItem

GLS.Texture

TglTextureFilteringQuality

GLScene.TextureFormat

Filtering quality

TGLTextureFormat

GLS.Texture

Texture format for OpenGL (rendering) use. Internally, GLScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:

TGLTextureHandle

GLS.Context

Manages a handle to a texture

TGLTextureImage

GLS.Texture

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

TGLTextureImageAlpha

GLS.Texture

Defines how and if Alpha channel is defined for a texture image. tiaDefault : uses the alpha channel in the image if any tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) tiaOpaque : alpha channel is uniformously set to 1.0 tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque.

TGLTextureImageClass

GLS.Texture

TGLTextureImageEditor

GLS.TextureImageEditors

TGLTextureImageEditorClass

GLS.TextureImageEditors

TGLTextureImageEx

GLS.MaterialEx

TGLTextureImageProperty

GLS.SceneRegister

TGLTextureLensFlare

GLS.TexLensFlare

TGLTextureMappingMode

GLS.Texture

TGLTextureMode

GLS.Texture

TGLTextureNeededEvent

GLS.Texture

TGLTextureProperties

GLS.MaterialEx

TGLTextureProperty

GLS.SceneRegister

TGLTextureSampler

GLS.MaterialEx

TGLTextureSharingShader

GLSL.TextureShaders

TGLTextureSharingShaderMaterial

GLSL.TextureShaders

TGLTextureSharingShaderMaterials

GLSL.TextureShaders

TglTextureSwizzle

GLScene.TextureFormat

TGLTextureSwizzling

GLS.MaterialEx

Swizzle the components of a texture fetches in shader or fixed-function pipeline.

TglTextureTarget

GLScene.TextureFormat

TGLTextureWrap

GLS.Texture

TGLTextVertAdjust

GLS.SpaceText

TGLTGAImage

Formats.TGA

TGLThorFXManager

GLS.ThorFX

Thor special effect manager.

TGLTiledArea

GLS.TilePlane

Stores tile information in a tiled area. Each tile stores an integer value with zero the default value, assumed as "empty".

TGLTiledAreaRow

GLS.TilePlane

Stores row information for a tiled area.

TGLTiledRndLandscape

GLS.RandomHDS

TGLTilePlane

GLS.TilePlane

A tiled textured plane. This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering. Its bounding dimensions are determined by its painted tile.

TGLTimeEventsMGR

GLS.TimeEventsMgr

TGLTimerQueryHandle

GLS.Context

Manages a handle to a timer query. Requires GL_EXT_timer_query extension. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TGLTINVectorFile

GLS.FileTIN

The TIN vector file (triangle irregular network). It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files). This format is encountered in the DEM/DTED world and used in place of grids.

TGLTorus

GLS.GeomObjects

A Torus object

TGLTorusPart

GLS.GeomObjects

TGLTorusParts

GLS.GeomObjects

TGLTrail

GLS.Trail

TGLTransformFeedbackBufferHandle

GLS.Context

Manages a handle to a Transform Feedback Buffer Object. Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.

TGLTransformFeedBackMode

GLSL.CustomShader

TGLTree

GLS.Tree

TGLTreeBranch

GLS.Tree

TGLTreeBranches

GLS.Tree

TGLTreeBranchNoise

GLS.Tree

TGLTreeLeaves

GLS.Tree

TGLType1Link

GLS.PhysJoints

// Type 1 Two-Link Manipulator // // _ ________ // / \ \ // / \/________/ // / / // / / // / / // / / // / / // \_/ //

TGLType2Link

GLS.PhysJoints

// Type 2 Two-Link Manipulator // ___ // / \___________________ // | + |___________________| // \ / // | | // | | // | | // | | // | | // | | // __|_|__ // |___.___| //

TGLType3Link

GLS.PhysJoints

// Type 3 Two-Link Manipulator // _______ // _________| |__ // <-|_________| |__|-> // |__ __| // | | // | | // | | // | | // | | // _|_|_ // |__.__|

TGLType4Link

GLS.PhysJoints

TGLType5Link

GLS.PhysJoints

// Type 5 Two-Link Manipulator // // _ // ________|_|__ // <-|_____________|-> // | | // | | // | | // | | // | | // __| |__ // |__| |__| // |_| // | // V //

TGLType6Link

GLS.PhysJoints

TGLType7Link

GLS.PhysJoints

TGLType8Link

GLS.PhysJoints

TGLU3DVectorFile

GLS.File3DPDF

The U3D vector file (using IDTF and U3DConverter).

TGLubyte

GLScene.OpenGL4

TGLubyte

GLScene.OpenGLTokens

TGLuint

GLScene.OpenGL4

TGLuint

GLScene.OpenGLTokens

TGLuint64

GLScene.OpenGL4

TGLuint64

GLScene.OpenGLTokens

TGLuint64EXT

GLScene.OpenGL4

TGLuint64EXT

GLScene.OpenGLTokens

TGLUniformBufferHandle

GLS.Context

Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program

TGLUniformGravityEmitter

GLS.PhysFields

GLS.RigidBodyInertia

TGLUnpackPBOHandle

GLS.Context

Manages a handle to PBO Pixel Unpack Buffer. When bound, commands such as DrawPixels read their data from a buffer object

TGLUNurbs

GLScene.OpenGL4

TGLUNurbs

GLScene.OpenGLTokens

——————- OpenGL Utility (GLU) types —————- GLU types

TGLUNurbsErrorProc

GLScene.OpenGL4

GLUNurbsCallback

TGLUNurbsErrorProc

GLScene.OpenGLTokens

TGLUNurbsObj

GLScene.OpenGL4

backwards compatibility

TGLUNurbsObj

GLScene.OpenGLTokens

backwards compatibility

TGLUQuadric

GLScene.OpenGL4

TGLUQuadric

GLScene.OpenGLTokens

TGLUQuadricErrorProc

GLScene.OpenGL4

GLUQuadricCallback

TGLUQuadricErrorProc

GLScene.OpenGLTokens

Callback function prototypes

TGLUQuadricObj

GLScene.OpenGL4

TGLUQuadricObj

GLScene.OpenGLTokens

TGLUserInputCommand

GLS.Console

Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...

TGLUserInterface

GLS.Navigator

TGLUserInterface is the component which reads the user input and transform it into action. The four calls to get you started is MouseLookActivate : set us up the bomb. MouseLookDeActivate : defuses it. Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. MouseSpeed : Also known as mouse sensitivity. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....

TGLUserShader

GLSL.UserShader

TGLushort

GLScene.OpenGL4

TGLushort

GLScene.OpenGLTokens

TGLUTessBeginDataProc

GLScene.OpenGL4

TGLUTessBeginDataProc

GLScene.OpenGLTokens

TGLUTessBeginProc

GLScene.OpenGL4

GLUTessCallback

TGLUTessBeginProc

GLScene.OpenGLTokens

TGLUTessCombineDataProc

GLScene.OpenGL4

TGLUTessCombineDataProc

GLScene.OpenGLTokens

TGLUTessCombineProc

GLScene.OpenGL4

TGLUTessCombineProc

GLScene.OpenGLTokens

TGLUTessEdgeFlagDataProc

GLScene.OpenGL4

TGLUTessEdgeFlagDataProc

GLScene.OpenGLTokens

TGLUTessEdgeFlagProc

GLScene.OpenGL4

TGLUTessEdgeFlagProc

GLScene.OpenGLTokens

TGLUTesselator

GLScene.OpenGL4

TGLUTesselator

GLScene.OpenGLTokens

TGLUTesselatorObj

GLScene.OpenGL4

TGLUTesselatorObj

GLScene.OpenGLTokens

TGLUTessEndDataProc

GLScene.OpenGL4

TGLUTessEndDataProc

GLScene.OpenGLTokens

TGLUTessEndProc

GLScene.OpenGL4

TGLUTessEndProc

GLScene.OpenGLTokens

TGLUTessErrorDataProc

GLScene.OpenGL4

TGLUTessErrorDataProc

GLScene.OpenGLTokens

TGLUTessErrorProc

GLScene.OpenGL4

TGLUTessErrorProc

GLScene.OpenGLTokens

TGLUTessVertexDataProc

GLScene.OpenGL4

TGLUTessVertexDataProc

GLScene.OpenGLTokens

TGLUTessVertexProc

GLScene.OpenGL4

TGLUTessVertexProc

GLScene.OpenGLTokens

TGLUTriangulatorObj

GLScene.OpenGL4

TGLUTriangulatorObj

GLScene.OpenGLTokens

TGLVBOArrayBufferHandle

GLS.Context

Manages a handle to VBO Array Buffer. Typically used to store vertices, normals, texcoords, etc.

TGLVBOBuffer

GLS.VectorFileObjects

TGLVBOBuffers

GLS.VectorFileObjects

TGLVBOElementArrayHandle

GLS.Context

Manages a handle to VBO Element Array Buffer. Typically used to store vertex indices.

TGLVBOHandle

GLS.Context

Manages a handle to an Vertex Buffer Object, VBO. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.

TGLvdpauSurfaceNV

GLScene.OpenGLTokens

TGLVector

GLScene.VectorTypes

TGLVectorEditorForm

FmVectorEditor

TGLVectorFile

GLS.VectorFileObjects

Abstract base class for different vector file formats. The actual implementation for these files (3DS, DXF..) must be done separately. The concept for TGLVectorFile is very similar to TGraphic

TGLVectorFileClass

GLS.VectorFileObjects

TGLVectorFileFormat

GLS.VectorFileObjects

TGLVectorFileFormatsList

GLS.VectorFileObjects

Stores registered vector file formats

TGLVectorPool

GLS.MultiPolygon

Page oriented pointer array, with persistent pointer target memory. In TGLVectorList a pointer to a vector will not be valid any more after a call to SetCapacity, which might be done implicitely during Add. The TGLVectorPool keeps memory in its original position during its whole lifetime.

TGLVerletAirResistance

GLS.VerletTypes

TGLVerletCapsule

GLS.VerletTypes

Capsule shaped verlet constraint in a skeleton collider

TGLVerletConstraint

GLS.VerletTypes

TGLVerletConstraintList

GLS.VerletTypes

TGLVerletDualConstraint

GLS.VerletTypes

TGLVerletDualForce

GLS.VerletTypes

A verlet force that applies to two specified nodes.

TGLVerletEdge

GLS.VerletTypes

Verlet edges simulate rigid collission edges

TGLVerletEdgeList

GLS.VerletTypes

TGLVerletFloor

GLS.VerletTypes

Floor Collision Constraint

TGLVerletForce

GLS.VerletTypes

Generic verlet force.

TGLVerletForceList

GLS.VerletTypes

TGLVerletFrictionCapsule

GLS.VerletTypes

Capsule collision Friction Constraint.

TGLVerletFrictionCube

GLS.VerletTypes

Cube Сollision Friction Constraint.

TGLVerletFrictionCylinder

GLS.VerletTypes

Cylinder collision Friction Constraint. The cylinder is considered infinite by this constraint.

TGLVerletFrictionSphere

GLS.VerletTypes

Sphere Сollision Friction Constraint

TGLVerletGlobalConstraint

GLS.VerletTypes

TGLVerletGlobalForce

GLS.VerletTypes

A global force (applied to all verlet nodes).

TGLVerletGlobalFrictionConstraint

GLS.VerletTypes

TGLVerletGlobalFrictionConstraintBox

GLS.VerletTypes

TGLVerletGlobalFrictionConstraintSP

GLS.VerletTypes

TGLVerletGlobalFrictionConstraintSphere

GLS.VerletTypes

TGLVerletGravity

GLS.VerletTypes

TGLVerletGroupConstraint

GLS.VerletTypes

TGLVerletGroupForce

GLS.VerletTypes

A verlet force that applies to a specified group of nodes.

TGLVerletHair

GLS.VerletTypes

Verlet Hair class

TGLVerletHeightField

GLS.VerletTypes

HeightField collision constraint (punctual!)

TGLVerletHeightFieldOnNeedHeight

GLS.VerletTypes

TGLVerletNode

GLS.VerletTypes

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.

TGLVerletNodeClass

GLS.VerletTypes

TGLVerletNodeList

GLS.VerletTypes

TGLVerletRigidBody

GLS.VerletTypes

Rigid body verlet Collision constraint. Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. EXPERIMENTAL, STILL DOES NOT WORK!

TGLVerletSkeletonCollider

GLS.VerletTypes

Base Verlet Skeleton Collider class.

TGLVerletSlider

GLS.VerletTypes

Slider constraint. Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.

TGLVerletSphere

GLS.VerletTypes

Sphere shaped verlet constraint in a skeleton collider

TGLVerletSpring

GLS.VerletTypes

TGLVerletStick

GLS.VerletTypes

Stick Verlet Collision Constraint. Imposes a fixed distance between two nodes

TGLVerletWorld

GLS.VerletTypes

TGLVertexArrayHandle

GLS.Context

Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state

TGLVertexAttribute

GLS.CUDA.Graphics

TGLVertexAttributes

GLS.CUDA.Graphics

TGLVertexBoneWeight

GLS.VectorFileObjects

TGLVertexBoneWeightArray

GLS.VectorFileObjects

TGLVertexBoneWeightDynArray

GLS.VectorFileObjects

TGLVertexData

GLS.Mesh

TGLVertexDataArray

GLS.Mesh

TGLVertexList

Formats.MD2

TGLVertexList

GLS.Mesh

Stores an interlaced vertex list for direct use in OpenGL. Locking (hardware passthrough) is supported, see "Locked" property for details.

TGLVertexMode

GLS.Mesh

TGLVertexProgram

GLSL.CustomShader

TGLVertexRec

GLS.Objects

TGLVertexShaderHandle

GLS.Context

Manages a handle to a Vertex Shader Object

TGLVerticesBoneWeights

GLS.VectorFileObjects

TGLVfsPAK

GLS.FileVfsPAK

TGLVideoMode

GLS.Screen

TGLVirtualHandle

GLS.Context

A context handle with event-based handle allocation and destruction

TGLVirtualHandleEvent

GLS.Context

TGLVirtualHandleTransf

GLS.Context

Transferable virtual handle

TGLVisibilityCulling

GLS.RenderContextInfo

Determines the visibility culling mode. Culling is done level by level, allowed values are: vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone vcNone : no visibility culling is performed vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).

TGLVisibilityDeterminationEvent

GLS.Objects

TGLVORVectorFile

GLS.FileVOR

TGLVRMLVectorFile

GLS.FileVRML

TGLVSyncMode

GLS.Context

TGLWaterPlane

GLS.WaterPlane

TGLWaterPlaneOption

GLS.WaterPlane

TGLWaterPlaneOptions

GLS.WaterPlane

TGLWAVFile

GLS.FileWAV

Support for Windows WAV format.

TGLWindowAttribute

GLS.Screen

window attributes

TGLWindowAttributes

GLS.Screen

TGLWindowFitting

GLS.Screen

window-to-screen fitting

TGLWindowsBitmapFont

GLS.WindowsFont

A bitmap font automatically built from a TFont. It works like a TGLBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders in GLScene as close to that font as posible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations. Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.

TGLWindowsContext

GLS.WindowsContext

A context driver for standard Windows OpenGL (via MS OpenGL).

TGLXVectorFile

GLS.FileX

TGLXYZGrid

GLS.Graph

An XYZ Grid object. Renders an XYZ grid using lines

TGLXYZGridLinesStyle

GLS.Graph

Rendering Style for grid lines. - glsLine : a single line is used for each grid line (from Min to Max), this provides the fastest rendering - glsSegments : line segments are used between each node of the grid, this enhances perspective and quality, at the expense of computing power.

TGLXYZGridPart

GLS.Graph

TGLXYZGridParts

GLS.Graph

TGLzBuffer

GLS.zBuffer

TGLZoomToDistanceJob

GLS.CameraController

TGLZShadows

GLS.zBuffer

TGnuGettextInstance

gnugettext

*—————————————————————————— The main translation engine. ——————————————————————————-

TgOnMatricesPush

GLScene.PipelineTransform

TgPipelineTransformationState

GLScene.PipelineTransform

TgPipelineTransformationStates

GLScene.PipelineTransform

TGPUDEVICE

GLScene.OpenGL4

TGPUDEVICE

GLScene.OpenGLTokens

TGSilhouetteStyle

GLS.Silhouette

TgTransformation

GLScene.PipelineTransform

TgTransformationRec

GLScene.PipelineTransform

TGUIAlignments

GLS.Gui

TGUIDrawResult

GLS.Gui

TGUIRect

GLS.Gui

TGutterClickEvent

GLS.Memo

————————————————————–

TGutterDrawEvent

GLS.Memo

THalfFloat

CUDA.DataAccess

THalfFloat

GLScene.Utils

THat

SDL.Import

** * Get the SDL joystick layer binding for this controller button/axis mapping *

THDRImage

Formats.HDRImage

THDTextureCoordinatesMode

GLS.HeightData

THideTrackTag

Formats.m3DSTypes

THiShadowBias

Formats.m3DSTypes

THmgBoundingBox

GLScene.GeometryBB

THmgPlane

GLScene.VectorGeometry

A plane equation. Defined by its equation A.x+B.y+C.z+D , a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here. The typename is just here for easing up data manipulation

THomogeneousByteMatrix

GLScene.VectorGeometry

Matrices

THomogeneousByteVector

GLScene.VectorGeometry

THomogeneousDblMatrix

GLScene.VectorGeometry

THomogeneousDblVector

GLScene.VectorGeometry

THomogeneousExtMatrix

GLScene.VectorGeometry

THomogeneousExtVector

GLScene.VectorGeometry

THomogeneousFltMatrix

GLScene.VectorGeometry

THomogeneousFltVector

GLScene.VectorGeometry

THomogeneousIntMatrix

GLScene.VectorGeometry

THomogeneousIntVector

GLScene.VectorGeometry

THomogeneousMatrix

GLScene.VectorGeometry

THomogeneousPtrVector

GLScene.VectorGeometry

THomogeneousVector

GLScene.VectorGeometry

THomogeneousWordMatrix

GLScene.VectorGeometry

THomogeneousWordVector

GLScene.VectorGeometry

THotTrackTag

Formats.m3DSTypes

THTFHeader

GLS.HeightTileFileHDS

TI1

Formats.LWO

TI2

Formats.LWO

TI4

Formats.LWO

TICCOMPRESS

Formats.VFW

TICCOMPRESSFRAMES

Formats.VFW

TICCompressProc

Formats.VFW

TICDECOMPRESS

Formats.VFW

TICDECOMPRESSEX

Formats.VFW

TICDRAW

Formats.VFW

TICDRAWBEGIN

Formats.VFW

TICDRAWSUGGEST

Formats.VFW

TICINFO

Formats.VFW

TICOPEN

Formats.VFW

TICPALETTE

Formats.VFW

TICSETSTATUSPROC

Formats.VFW

TICStatusProc

Formats.VFW

return nonzero means abort operation in progress

TID4

Formats.LWO

TID4DynArray

Formats.LWO

TIDELogProc

GLScene.Logger

TIdleEvent

GLS.AsyncHDS

TImageAlphaProc

GLS.ImageUtils

TImageFilterFunction

GLS.ImageUtils

TImposter

GLS.Imposter

Base class for imposters manipulation and handling. Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.
Note: Remeber to enable Destination Alpha on your viewer.

TImposterLoadedEvent

GLS.Imposter

Used CPPB procedure instead of Delphi function TLoadingImposterEvent = procedure (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter; var result : TGLBitmap32) of object;

TImposterOption

GLS.Imposter

Imposter rendering options. Following options are supported: impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing

TImposterOptions

GLS.Imposter

TImposterReference

GLS.Imposter

TIndexList

Formats.MD2

TInfoLabelCoordType

GLS.GizmoEx

TIntegerArray

Formats.m3DSTypes

TIntegerArray

GLS.HeightTileFileHDS

Access to large tiled height data files. Performance vs Raw file accesses (for perfect tile match): Cached data: "Smooth" terrain 1:2 to 1:10 Random terrain 1:1
Non-cached data: "Smooth" terrain 1:100 to 1:1000 Random terrain 1:100

TIntegerArray

GLScene.VectorTypesExt

Extended may be replaced with BigDecimals

TIntegerClamp

GLS.RandomHDS

TIntegerVector

GLScene.VectorGeometry

TIntermediateFormat

GLS.ImageUtils

Relative sample radius for filtering

TIntermediateFormatArray

GLS.ImageUtils

TIntPercentage

Formats.m3DSTypes

TInvokeInfoForm

GLS.Scene

TIpasData

Formats.m3DSTypes

TIsDefaultTile

GLS.RandomHDS

TJointFlag

ODE.Import

Change: New Type added, syntax enforcement

TJointInfo1

ODE.Import

info returned by getInfo1 function. the constraint dimension is m (<=6). i.e. that is the total number of rows in the jacobian. `nub' is the number of unbounded variables (which have lo,hi = -/+ infinity).

TJointInfo2

ODE.Import

info returned by getInfo2 function

TJointParams

ODE.Import

TJointParams = ( parameters for limits and motors Change: New Type added, sintax enforcement

TJoyAxis

GLS.Joystick

TJoyPos

GLS.Joystick

TJoystickButton

GLS.Joystick

TJoystickButtons

GLS.Joystick

TJoystickDesignMode

GLS.Joystick

TJoystickEvent

GLS.Joystick

TJoystickID

GLS.Joystick

TKeyFramer

Formats.m3DS

TKeyHeader3DS

Formats.m3DSTypes

Animation key settings

TKeyHeaderList

Formats.m3DSTypes

TKEYSChunk

Formats.B3D

TKFAmbient3DS

Formats.m3DSTypes

TKFCamera3DS

Formats.m3DSTypes

TKFCurtime

Formats.m3DSTypes

TKFHdr

Formats.m3DSTypes

TKFId

Formats.m3DSTypes

TKFKeyInfo3DS

Formats.m3DSTypes

TKFMesh3DS

Formats.m3DSTypes

TKFMorphKey3DS

Formats.m3DSTypes

Object Morph key

TKFMorphKeyList

Formats.m3DSTypes

TKFOmni3DS

Formats.m3DSTypes

TKFRotKey3DS

Formats.m3DSTypes

Rotation key

TKFRotKeyList

Formats.m3DSTypes

TKFSeg

Formats.m3DSTypes

TKFSegment3DS

Formats.m3DSTypes

TKFSets3DS

Formats.m3DSTypes

TKFSpot3DS

Formats.m3DSTypes

TLandTileInfo

GLS.RandomHDS

TLayerFog

Formats.m3DSTypes

TLayerFogFalloff3DS

Formats.m3DSTypes

distance cue atmospheric

TLayerFogSettings3DS

Formats.m3DSTypes

layered Fog atmosphere parameters

TLifeErosion

GLS.RandomHDS

TLight3DS

Formats.m3DSTypes

TLightDir2TexEnvColor

GLS.MaterialEx

TLightRecord

GLSL.DiffuseSpecularShader

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas

TLinColor24

Formats.m3DSTypes

TLinColorF

Formats.m3DSTypes

TLineProp

GLS.Memo

TLiteAttenuate3DS

Formats.m3DSTypes

TLMTS

GLS.FileLMTS

TLMTS_Header

GLS.FileLMTS

TLMTS_Subset

GLS.FileLMTS

TLMTS_TexData

GLS.FileLMTS

TLMTS_Vertex

GLS.FileLMTS

TLoadingImposterEvent

GLS.Imposter

Imposter loading events

TLoadProgress

Formats.m3DS

TLogBufferFlushThread

GLScene.Logger

Thread that periodically flushes the buffer to disk.

TLogBufferingMode

GLScene.Logger

How log is buffered.

TLogCheckSizeThread

GLScene.Logger

Thread that checks file size and splits the file if nessesary.

TLogLevel

GLScene.Logger

Levels of importance of log messages

TLogLevels

GLScene.Logger

Log level setting type

TLogMessageLimitAction

GLScene.Logger

What to do when number of messages exceeds message limit.

TLogSession

GLScene.Logger

Abstract Logger class

TLogTimeFormat

GLScene.Logger

Log date and time setting type

TLongWordVector

GLScene.VectorGeometry

TLoShadowBias

Formats.m3DSTypes

TLWChunk

Formats.LWO

TLWChunkClass

Formats.LWO

TLWChunkFind

Formats.LWO

TLWChunkList

Formats.LWO

TLWChunkRec

Formats.LWO

TLWClip

Formats.LWO

TLWContentDir

Formats.LWO

TLWContentNotify

Formats.LWO

TLWLayr

Formats.LWO

TLWObjectFile

Formats.LWO

TLWOReadCallback

Formats.LWO

TLWParentChunk

Formats.LWO

TLWPnts

Formats.LWO

TLWPntsInfo

Formats.LWO

TLWPntsInfoDynArray

Formats.LWO

TLWPols

Formats.LWO

TLWPolsDynArray

Formats.LWO

TLWPolsInfo

Formats.LWO

TLWPolsInfoDynArray

Formats.LWO

TLWPolyTagMap

Formats.LWO

TLWPolyTagMapDynArray

Formats.LWO

TLWPTag

Formats.LWO

TLWSubChunk

Formats.LWO

TLWSubChunkRec

Formats.LWO

TLWSurf

Formats.LWO

TLWTags

Formats.LWO

TLWVertexMap

Formats.LWO

Value Map

TLWVertexMapDynArray

Formats.LWO

TLWVMap

Formats.LWO

TM3dVersion

Formats.m3DSTypes

TMainAVIHeader

Formats.VFW

TMapInfo3DS

Formats.m3DSTypes

TMapOfSingle

GLS.RandomHDS

TMapOfVector

GLS.RandomHDS

TMapSet3DS

Formats.m3DSTypes

TMapTexCoordMode

GLS.XOpenGL

TMarkDirtyEvent

GLS.HeightData

TMarkStyle

GLS.Trail

TMasterScale

Formats.m3DSTypes

TMatAcubic

Formats.m3DSTypes

TMatBumpPercent

Formats.m3DSTypes

TMaterial3DS

Formats.m3DSTypes

TMaterialInfo

GLS.FileLMTS

TMaterialList

Formats.m3DS

Progress : TProgressBar;
This allows to use something like that:
procedure TSomeForm.CreateForm(Sender: TObject); begin .... 3DSReader.OnProgress := LoadProgress; .... end; procedure TSomeForm.LoadProgress(StreamPos, StreamMax : Longint); begin if StreamMax <> 0 then Progress.MaxValue := StreamMax; Progress.Position := StreamPos; end; —– support classes —– All structure data of a 3DS file is actually held in TFile3DS.FDatabase as a tree with lots of links across the various chunks. For convinience and speed the data of the chunks is collected into some special structures (FMaterialList etc.) and presented to the user by the following helper classes:

TMatMapAng

Formats.m3DSTypes

TMatMapBCol

Formats.m3DSTypes

TMatMapCol1

Formats.m3DSTypes

TMatMapCol2

Formats.m3DSTypes

TMatMapGCol

Formats.m3DSTypes

TMatMapRCol

Formats.m3DSTypes

TMatMapTexblur

Formats.m3DSTypes

TMatMapTiling

Formats.m3DSTypes

TMatMapUOffset

Formats.m3DSTypes

TMatMapUScale

Formats.m3DSTypes

TMatMapVOffset

Formats.m3DSTypes

TMatMapVScale

Formats.m3DSTypes

TMatrix2b

GLScene.VectorTypes

TMatrix2d

GLScene.VectorTypes

=========== Matrices ============

TMatrix2DArray

GLScene.VectorTypesExt

Matrix Arrays

TMatrix2DRec

GLScene.VectorTypesExt

TMatrix2DType

GLScene.VectorTypesExt

———————– Matrix types ———————–

TMatrix2e

GLScene.VectorTypes

TMatrix2f

GLScene.VectorTypes

TMatrix2i

GLScene.VectorTypes

TMatrix2p

GLScene.VectorTypes

TMatrix2s

GLScene.VectorTypes

TMatrix2w

GLScene.VectorTypes

TMatrix3b

GLScene.VectorTypes

TMatrix3d

GLScene.VectorTypes

TMatrix3DArray

GLScene.VectorTypesExt

TMatrix3DRec

GLScene.VectorTypesExt

TMatrix3DType

GLScene.VectorTypesExt

TMatrix3e

GLScene.VectorTypes

TMatrix3f

GLScene.VectorTypes

TMatrix3i

GLScene.VectorTypes

TMatrix3p

GLScene.VectorTypes

TMatrix3s

GLScene.VectorTypes

TMatrix3w

GLScene.VectorTypes

TMatrix4b

GLScene.VectorTypes

TMatrix4d

GLScene.VectorTypes

TMatrix4e

GLScene.VectorTypes

TMatrix4f

GLScene.VectorTypes

TMatrix4i

GLScene.VectorTypes

TMatrix4p

GLScene.VectorTypes

TMatrix4s

GLScene.VectorTypes

TMatrix4w

GLScene.VectorTypes

TMatrixArr

GLS.Isolines

TMatrixArray

GLScene.VectorGeometry

Some simplified names

TMatrixExt

GLScene.VectorTypesExt

TMatrixRec

GLScene.VectorTypesExt

TMatShading

Formats.m3DSTypes

TMatWireSize

Formats.m3DSTypes

TMaxCLODTrianglesReachedEvent

GLS.TerrainRenderer

TMD2AliasFrame

Formats.MD2

TMD2Header

Formats.MD2

TMD2Triangle

Formats.MD2

TMD2TriangleVertex

Formats.MD2

TMD2VertexIndex

Formats.MD2

TMD3Bone

Formats.MD3

TMD3Frame = record min_bound,max_bounds, local_origin : TVector3f; radius : single; name : array[0..15] of char; end;

TMD3Face

Formats.MD3

TMD3Header

Formats.MD3

TMD3MeshData

Formats.MD3

TMD3MeshHeader

Formats.MD3

TMD3Skin

Formats.MD3

TMD3Tag

Formats.MD3

Quake3 MD3 structure types

TMD3TagList

GLS.FileQ3MD3

This class is used to extract the tag transform information stored in the MD3 files. The data is used to offset each part of the model based on the parent parts animation state.

TMD3TexCoord

Formats.MD3

TMD3Triangle

Formats.MD3

TMDCAngle

GLS.FileMDC

TMDCBaseFrame

GLS.FileMDC

TMDCBaseVertex

GLS.FileMDC

TMDCBorderFrame

GLS.FileMDC

TMDCCompFrame

GLS.FileMDC

TMDCCompVertex

GLS.FileMDC

TMDCFileHeader

GLS.FileMDC

TMDCPoint

GLS.FileMDC

3/64;

TMDCSkin

GLS.FileMDC

TMDCSurfaceHeader

GLS.FileMDC

TMDCTag

GLS.FileMDC

TMDCTagFrame

GLS.FileMDC

TMDCTagName

GLS.FileMDC

TMDCTexCoord

GLS.FileMDC

TMDCTriangle

GLS.FileMDC

TMem

SDL.Import

TMesh2DArray

GLScene.VectorTypesExt

TMesh2DVert

GLScene.VectorTypesExt

————————– Mesh simple record types ————————–

TMesh3DArray

GLScene.VectorTypesExt

TMesh3DS

Formats.m3DSTypes

TMesh3DVert

GLScene.VectorTypesExt

TMESHChunk

Formats.B3D

TMeshColor

Formats.m3DSTypes

TMeshMatrix

Formats.m3DSTypes

TMeshSet3DS

Formats.m3DSTypes

TMeshTextureInfo

Formats.m3DSTypes

TMeshVersion

Formats.m3DSTypes

TMipmapGenerationMode

GLS.MaterialEx

TMirrorShapes

GLS.Mirror

TModuleHandle

ModuleLoader

Handle to a loaded DLL

TMoFile

gnugettext

*—————————————————————————— Handles .mo files, in separate files or inside the exe file. Don't use this class. It's for internal use. ——————————————————————————-

TMOParametricSurface

GLS.ParametricSurfaces

TMorphSmooth

Formats.m3DSTypes

TMorphTrackTag

Formats.m3DSTypes

TMS3DComment

GLS.FileMS3D

TMS3DCommentList

GLS.FileMS3D

TMS3DGroup

GLS.FileMS3D

typedef struct (* byte flags; // SELECTED | HIDDEN char name[32]; // word numtriangles; // word triangleIndices[numtriangles]; // the groups group the triangles char materialIndex; // -1 = no material *) ms3d_group_t;

TMS3DHeader

GLS.FileMS3D

typdef struct (* char id[10]; // always "MS3D000000" int version; // 4 *) ms3d_header_t;

TMS3DJoint

GLS.FileMS3D

TMS3DJointArray

GLS.FileMS3D

TMS3DJointBase

GLS.FileMS3D

typedef struct (* byte flags; // SELECTED | DIRTY char name[32]; // char parentName[32]; // float rotation[3]; // local reference matrix float position[3];
word numKeyFramesRot; // word numKeyFramesTrans; //
ms3d_keyframe_rot_t keyFramesRot[numKeyFramesRot]; // local animation matrices ms3d_keyframe_pos_t keyFramesTrans[numKeyFramesTrans]; // local animation matrices *) ms3d_joint_t;

TMS3DKeyframePosition

GLS.FileMS3D

typedef struct (* float time; // time in seconds float position[3]; // local position *) ms3d_keyframe_pos_t;

TMS3DKeyframePositionArray

GLS.FileMS3D

TMS3DKeyframeRotation

GLS.FileMS3D

typedef struct (* float time; // time in seconds float rotation[3]; // x, y, z angles *) ms3d_keyframe_rot_t;

TMS3DKeyframeRotationArray

GLS.FileMS3D

TMS3DMaterial

GLS.FileMS3D

typedef struct (* char name[32]; // float ambient[4]; // float diffuse[4]; // float specular[4]; // float emissive[4]; // float shininess; // 0.0f - 128.0f float transparency; // 0.0f - 1.0f char mode; // 0, 1, 2 is unused now char texture[128]; // texture.bmp char alphamap[128]; // alpha.bmp *) ms3d_material_t;

TMS3DTriangle

GLS.FileMS3D

typedef struct (* word flags; // SELECTED | SELECTED2 | HIDDEN word vertexIndices[3]; // float vertexNormals[3][3]; // float s[3]; // float t[3]; // byte smoothingGroup; // 1 - 32 byte groupIndex; // *) ms3d_triangle_t;

TMS3DTriangleArray

GLS.FileMS3D

TMS3DVertex

GLS.FileMS3D

typedef struct (* byte flags; // SELECTED | SELECTED2 | HIDDEN float vertex[3]; // char boneId; // -1 = no bone byte referenceCount; *) ms3d_vertex_t;

TMS3DVertexArray

GLS.FileMS3D

TMS3D_vertex_ex_t

GLS.FileMS3D

TMshBoxmap

Formats.m3DSTypes

TMshMatGroup

Formats.m3DSTypes

TNCamera

Formats.m3DSTypes

TNDirectLight

Formats.m3DSTypes

TNewTilePreparedEvent

GLS.AsyncHDS

TNewTilePreparedEvent

GLS.BumpmapHDS

TNewTilePreparedEvent

GLS.ShadowHDS

TNewtonBoxParam

Newton.Import

TNewtonCapsuleParam

Newton.Import

TNewtonChamferCylinderParam

Newton.Import

TNewtonCollisionInfoRecord

Newton.Import

TNewtonCollisionMaterial

Newton.Import

TNewtonCollisionNullParam

Newton.Import

TNewtonCollisionTreeParam

Newton.Import

TNewtonCompoundCollisionParam

Newton.Import

TNewtonConeParam

Newton.Import

TNewtonConvexHullParam

Newton.Import

TNewtonCylinderParam

Newton.Import

TNewtonDeformableMeshParam

Newton.Import

TNewtonFuncLinkRecord

Newton.Import

PNewtonSerializeHandle = ˆPointer; PNewtonMeshHandle = ˆPointer; PNewtonMeshVertex = ˆPointer; PNewtonMeshPoint = ˆPointer; PNewtonMeshEdge = ˆPointer; PNewtonMeshFace = ˆPointer; PNewtonListener = ˆPointer;

TNewtonHeightFieldCollisionParam

Newton.Import

TNewtonHingeSliderUpdateDesc

Newton.Import

TNewtonImmediateModeConstraint

Newton.Import

TNewtonJointRecord

Newton.Import

TNewtonMaterialData

Newton.Import

TNewtonMeshDoubleData

Newton.Import

data structure for interfacing with NewtonMesh

TNewtonMeshFloatData

Newton.Import

TNewtonMeshVertexFormat

Newton.Import

TNewtonRagdoll

GLS.NGDRagdoll

TNewtonSceneCollisionParam

Newton.Import

TNewtonSphereParam

Newton.Import

TNewtonTaperedCapsuleParam

Newton.Import

TNewtonTaperedCylinderParam

Newton.Import

TNewtonUserContactPoint

Newton.Import

TNewtonUserMeshCollisionCollideDesc

Newton.Import

TNewtonUserMeshCollisionRayHitDesc

Newton.Import

TNewtonWorldConvexCastReturnInfo

Newton.Import

TNmHeader

GLS.FileNMF

TNmRawTriangle

GLS.FileNMF

TNODEChunk

Formats.B3D

TNodeHdr

Formats.m3DSTypes

TNodeList

Formats.m3DSTypes

TObjectCollisionEvent

GLS.Collision

TObjectList

Formats.m3DS

TObjMat3DS

Formats.m3DSTypes

TObjMatList

Formats.m3DSTypes

TOConsts

Formats.m3DSTypes

TOCTFace

Formats.OCT

TOCTFile

Formats.OCT

TOCTHeader

Formats.OCT

TOCTLight

Formats.OCT

TOCTLightmap

Formats.OCT

TOctreeTriangleInfo

GLS.Octree

TOCTTexture

Formats.OCT

TOCTVertex

Formats.OCT

ToDosPath

Formats.LWO

ToHex

Formats.VFW

– Macro to make a ckid for a chunk out of a TWOCC and a stream num (0-255) -

TOnAsmProgSetting

GLS.MaterialEx

TOnBeforeKernelLaunch

GLS.CUDA.Graphics

TOnCreateLandTile

GLS.RandomHDS

TOnCustomForce

GLS.PhysForces

TOnCustomPerspective

GLS.Scene

TOnDebugLine

gnugettext

***************************************************************************

TOnDoApplyEvent

GLSL.UserShader

TOnDoUnApplyEvent

GLSL.UserShader

TOnDrawTexture

GLS.RandomHDS

Function type to use for topography-based texture

TOnHeightDataDirtyEvent

GLS.HeightData

TOnOpenGLInteropInit

GLS.CUDA.Context

TOnPrepareHandleData

GLS.Context

TOnUniformInitialize

GLS.MaterialEx

TOnUniformSetting

GLS.MaterialEx

TopFalloff

Formats.m3DSConst

TOptimise

GLS.zBuffer

TOrbitalElementsData

GLS.SkyDome

TOrthoView3DS

Formats.m3DSTypes

Used to describe Top, Bottom, left, right, front and back views

ToUnixPath

Formats.LWO

TPackedRotationMatrix

GLScene.VectorGeometry

TPAKArchive

GLS.PAKArchive

TPakHeader

GLS.FileVfsPAK

TPakHeader

GLS.PAKArchive

TParametricSurfaceBasis

GLS.ParametricSurfaces

psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.

TParametricSurfaceRenderer

GLS.ParametricSurfaces

psrGLScene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenGL uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.

TParticleReference

GLS.ParticleFX

PFX region rendering structures

TParticleReferenceArray

GLS.ParticleFX

TPasDblStrUtilsBoolean

PasDblStrUtils

TPasDblStrUtilsChar

PasDblStrUtils

TPasDblStrUtilsDouble

PasDblStrUtils

TPasDblStrUtilsInt16

PasDblStrUtils

TPasDblStrUtilsInt32

PasDblStrUtils

TPasDblStrUtilsInt64

PasDblStrUtils

TPasDblStrUtilsInt8

PasDblStrUtils

TPasDblStrUtilsNativeInt

PasDblStrUtils

TPasDblStrUtilsNativeUInt

PasDblStrUtils

TPasDblStrUtilsOutputMode

PasDblStrUtils

TPasDblStrUtilsPointer

PasDblStrUtils

TPasDblStrUtilsPtrInt

PasDblStrUtils

TPasDblStrUtilsPtrUInt

PasDblStrUtils

TPasDblStrUtilsRawByteChar

PasDblStrUtils

TPasDblStrUtilsRawByteCharSet

PasDblStrUtils

TPasDblStrUtilsRawByteString

PasDblStrUtils

TPasDblStrUtilsRoundingMode

PasDblStrUtils

TPasDblStrUtilsString

PasDblStrUtils

TPasDblStrUtilsUInt16

PasDblStrUtils

TPasDblStrUtilsUInt32

PasDblStrUtils

TPasDblStrUtilsUInt64

PasDblStrUtils

TPasDblStrUtilsUInt8

PasDblStrUtils

TPasDblStrUtilsUTF16Char

PasDblStrUtils

TPasDblStrUtilsUTF16String

PasDblStrUtils

TPasDblStrUtilsUTF8Char

PasDblStrUtils

TPasDblStrUtilsUTF8String

PasDblStrUtils

TPasJSON

PasJSON

TPasJSONChar

PasJSON

TPasJSONDouble

PasJSON

TPasJSONEncoding

PasJSON

TPasJSONFloat

PasJSON

TPasJSONFloats

PasJSON

TPasJSONInt16

PasJSON

TPasJSONInt32

PasJSON

TPasJSONInt64

PasJSON

TPasJSONInt8

PasJSON

TPasJSONItem

PasJSON

TPasJSONItemArray

PasJSON

TPasJSONItemArray.TPasJSONItemArrayEnumerator

PasJSON

TPasJSONItemBoolean

PasJSON

TPasJSONItemNull

PasJSON

TPasJSONItemNumber

PasJSON

TPasJSONItemObject

PasJSON

TPasJSONItemObject.TPasJSONItemObjectEnumerator

PasJSON

TPasJSONItemObjectProperties

PasJSON

TPasJSONItemObjectProperty

PasJSON

TPasJSONItems

PasJSON

TPasJSONItemString

PasJSON

TPasJSONMergeFlag

PasJSON

TPasJSONMergeFlags

PasJSON

TPasJSONModeFlag

PasJSON

TPasJSONModeFlags

PasJSON

TPasJSONNativeInt

PasJSON

TPasJSONNativeUInt

PasJSON

TPasJSONPointer

PasJSON

TPasJSONPointers

PasJSON

TPasJSONPtrDiff

PasJSON

TPasJSONPtrInt

PasJSON

TPasJSONPtrUInt

PasJSON

TPasJSONRawByteChar

PasJSON

TPasJSONRawByteString

PasJSON

TPasJSONSize

PasJSON

TPasJSONSizeInt

PasJSON

TPasJSONSizeUInt

PasJSON

TPasJSONUInt16

PasJSON

TPasJSONUInt32

PasJSON

TPasJSONUInt64

PasJSON

TPasJSONUInt8

PasJSON

TPasJSONUInt8Array

PasJSON

TPasJSONUTF16Char

PasJSON

TPasJSONUTF16String

PasJSON

TPasJSONUTF8String

PasJSON

TPatchPostRenderEvent

GLS.TerrainRenderer

TPathTravelStartEvent

GLS.Movement

Event for path related event

TPathTravelStopEvent

GLS.Movement

TpfnSDL_CurrentBeginThread

SDL.Import

TpfnSDL_CurrentEndThread

SDL.Import

TPFXCreateParticleEvent

GLS.ParticleFX

TPFXDirectRenderEvent

GLS.ParticleFX

TPFXGetParticleCountEvent

GLS.ParticleFX

TPFXLifeColor

GLS.ParticleFX

TPFXLifeColors

GLS.ParticleFX

TPFXParticleProgress

GLS.ParticleFX

TPFXPrepareTextureImageEvent

GLS.ParticleFX

TPFXProgressEvent

GLS.ParticleFX

TPFXRegion

GLS.ParticleFX

TPFXSortAccuracy

GLS.ParticleFX

TPickRecord

GLS.Selection

TPickSortType

GLS.Selection

TPickSubObjects

GLS.Selection

TPictureFileProperty

GLS.SceneRegister

TPipeNodesColorMode

GLS.Extrusion

TPipeNormalMode

GLS.Extrusion

TPipePart

GLS.Extrusion

TPipeParts

GLS.Extrusion

TPipeTexCoordMode

GLS.Extrusion

TPivot

Formats.m3DSTypes

TPlanBB

GLScene.GeometryBB

TPlanIndices

GLScene.GeometryBB

TPoint2DArray

GLScene.VectorTypesExt

TPoint2DRec

GLScene.VectorTypesExt

TPoint3DArray

GLScene.VectorTypesExt

TPoint3DRec

GLScene.VectorTypesExt

TPoint3DS

Formats.m3DSTypes

3D point structure

TPointArray

Formats.m3DSTypes

TPointerArray

GLS.ImageUtils

TPointerVector

GLScene.VectorGeometry

TPointFlagArray

Formats.m3DSTypes

TPointList

Formats.m3DSTypes

TPolygon2D

GLScene.VectorTypesExt

———————– Polygon types ———————–

TPolygon3D

GLScene.VectorTypesExt

TPolyhedronArray

GLScene.VectorTypesExt

———————– Polyhedron types ———————–

TPosTrackTag

Formats.m3DSTypes

TPrecisionSetting

GLS.CgShader

TProcAffineAffineAffine

GLS.Octree

TProcInt

GLS.Octree

TProjectTargetNameFunc

GLScene.Utils

TP_GlobalHandleClass

gnugettext

TP_GlobalIgnoreClass

gnugettext

TP_GlobalIgnoreClassProperty

gnugettext

TP_Ignore

gnugettext

TP_IgnoreClass

gnugettext

TP_IgnoreClassProperty

gnugettext

TQ3BSP

Formats.Q3BSP

TQuat3DRec

GLScene.VectorTypesExt

————————– Quaternion simple record types ————————–

TQuatArray

GLScene.VectorTypesExt

TQuaternion

GLScene.VectorGeometry

TQuaternionArray

GLScene.VectorGeometry

TQuaternionHelper

GLScene.VectorTypesExt

TQuaternionRec

GLScene.VectorTypesExt

TrackHeaderKeysMin3DS

Formats.m3DSConst

Maximum key spline ease from Track header Limits

TrackLockX3DS

Formats.m3DSConst

TrackLockY3DS

Formats.m3DSConst

TrackLockZ3DS

Formats.m3DSConst

TrackLoops3DS

Formats.m3DSConst

TrackNoLinkX3DS

Formats.m3DSConst

TrackNoLinkY3DS

Formats.m3DSConst

TrackNoLinkZ3DS

Formats.m3DSConst

TrackRepeats3DS

Formats.m3DSConst

TrackSingle3DS

Formats.m3DSConst

flags used by the track flags field

TRainErosion

GLS.RandomHDS

TRandomGenFunction

GLScene.RandomLib

Used for passing Random Number Generators

TranslateComponent

gnugettext

TranslatedUnicodeString

gnugettext

TranslateMatrix

GLScene.VectorGeometry

TranslateMatrix

GLScene.VectorGeometry

Adds the translation vector into the matrix

TransposeMatrix

GLScene.VectorGeometry

Computes transpose of 3x3 matrix

TransposeMatrix

GLScene.VectorGeometry

Computes transpose of 4x4 matrix

TRayBias

Formats.m3DSTypes

TRBColor

GLScene.RedBlackTree

TRColorEditor

FRColorEditor

TRCOptions

GLScene.OpenGL4

TRead

SDL.Import

** * Read up to maxnum objects each of size size from the data * stream to the area pointed at by ptr. * * the number of objects read, or 0 at error or end of file. *

TRectangle

GLScene.VectorGeometry

TRelativeCoordinate

GLS.RandomHDS

TReleaseLevel

Formats.m3DSTypes

TResolution

GLS.Screen

TRFaceEditor

FRFaceEditor

TRGBPixel

GLS.Blur

TRGBPixelBuffer

GLS.Blur

TriangleArea

GLScene.VectorGeometry

Computes the triangle's area

TriangleElevationSegments

GLS.Isolines

Defines contouring segments inside a triangle using elevations

TriangleIntersectAABB

GLScene.GeometryBB

Original source code by Tomas Akenine-Mцller Based on the paper "Fast 3D Triangle-Box Overlap Testing" http://www.cs.lth.se/home/Tomas_Akenine_Moller/pubs/tribox.pdf http://jgt.akpeters.com/papers/AkenineMoller01/ (code) Use separating axis theorem to test overlap between triangle and box need to test for overlap in these directions: 1) the (x,y,z)-directions (actually, since we use the AABB of the triangle we do not even need to test these) 2) normal of the triangle 3) crossproduct(edge from tri, {x,y,z}-directin) this gives 3x3=9 more tests Checks if a triangle (given by vertices v1, v2 and v3) intersects an AABB

TriangleSignedArea

GLScene.VectorGeometry

Computes a 2D triangle's signed area. Only X and Y coordinates are used, Z is ignored

TrimAndSplitVersionString

GLS.OpenGLAdapter

TrimAndSplitVersionString

GLScene.OpenGL4

TRIMESH_FACE_NORMALS

ODE.Import

enum (* TRIMESH_FACE_NORMALS, TRIMESH_LAST_TRANSFORMATION ; *)

TRIMESH_LAST_TRANSFORMATION

ODE.Import

TRMapSet3DS

Formats.m3DSTypes

TRMaterialPreview

FRMaterialPreview

TROAMRenderPoint

GLS.ROAMPatch

TROAMTriangleNode

GLS.ROAMPatch

TRollTrackTag

Formats.m3DSTypes

TRotTrackTag

Formats.m3DSTypes

TRTextureEdit

FRTextureEdit

TRTrackBarEdit

FRTrackBarEdit

TryStringToColorAdvanced

GLS.ImageUtils

Converts a string into color

TsbState

GLS.Memo

TScalarField

GLScene.VectorTypesExt

TScalarFieldInt

GLScene.VectorTypesExt

if data are made on integer XYZ index may be replaced with BigIntegers

TScalarValue

GLScene.VectorTypesExt

———————– Point types ———————–

TScaleTrackTag

Formats.m3DSTypes

TSCODEBase

GLS.ODESkeletonColliders

Base ODE skeleton collider class

TSCODEBox

GLS.ODESkeletonColliders

Box shaped ODE geom in a skeleton collider

TSCODECCylinder

GLS.ODESkeletonColliders

Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider

TSCODESphere

GLS.ODESkeletonColliders

Sphere shaped ODE geom in a skeleton collider

TScreenSaverOption

GLS.ScreenSaver

Options d'automatisation du screen-saver. ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer)

TScreenSaverOptions

GLS.ScreenSaver

TScreenSaverPreviewEvent

GLS.ScreenSaver

This event is fired when screen saver should start in preview mode. The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).

TScrollMode

GLS.Memo

TSDLContext

GLS.SDL.Context

A context driver for OpenGL via SDL (libsdl.org). Due to limitations of SDL: you may have only one SDL window opened at any time (you cannot have memory viewers) closing the SDL window will terminate the application

TSDLEvent

GLS.SDL.Window

TSDLPantalla

SDL.Import

TSDLViewer

GLS.SDL.Context

A viewer using SDL. Beware: only one at a time, no other viewers allowed! Will also close the application when the window is closed!

TSDLWindow

GLS.SDL.Window

A basic SDL-based window (non-visual component). Only a limited subset of SDL's features are available, and this window is heavily oriented toward using it for OpenGL rendering. Be aware SDL is currently limited to a single window at any time... so you may have multiple components, but only one can be used

TSDLWindowOption

GLS.SDL.Window

Specifies optional settings for the SDL window. Those options are a simplified subset of the SDL options: voDoubleBuffer: create a double-buffered window voOpenGL: requires OpenGL capability for the window voResizable: window should be resizable voFullScreen: requires a full screen "window" (screen resolution may be changed) voStencilBuffer: requires a stencil buffer (8bits, use along voOpenGL)

TSDLWindowOptions

GLS.SDL.Window

TSDLWindowPixelDepth

GLS.SDL.Window

Pixel Depth options. vpd16bits: 16bpp graphics (565) (and 16 bits depth buffer for OpenGL) vpd24bits: 24bpp graphics (565) (and 24 bits depth buffer for OpenGL)

TSDL_AudioCallback

SDL.Import

** * This function is called when the audio device needs more data. * * userdata An application-specific parameter saved in * the SDL_AudioSpec structure * stream A pointer to the audio data buffer. * len The length of that buffer in bytes. * * Once the callback returns, the buffer will no longer be valid. * Stereo samples are stored in a LRLRLR ordering. *

TSDL_AudioCVT

SDL.Import

** * A structure to hold a set of audio conversion filters and buffers. *

TSDL_AudioDeviceID

SDL.Import

** * SDL Audio Device IDs. * * A successful call to SDL_OpenAudio() is always device id 1, and legacy * SDL audio APIs assume you want this device ID. SDL_OpenAudioDevice() calls * always returns devices >= 2 on success. The legacy calls are good both * for backwards compatibility and when you don't care about multiple, * specific, or capture devices. *

TSDL_AudioFilter

SDL.Import

TSDL_AudioFormat

SDL.Import

** * Audio format flags. * * These are what the 16 bits in SDL_AudioFormat currently mean... * (Unspecified bits are always zero). * * ++———————–sample is signed if set || || ++———–sample is bigendian if set || || || || ++—sample is float if set || || || || || || +—sample bit size—+ || || || | | 15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00 * * There are macros in SDL 2.0 and later to query these bits. *

TSDL_AudioSpec

SDL.Import

TSDL_AudioStatus

SDL.Import

** * Audio state * * Get the current audio state. *

TSDL_BlendMode

SDL.Import

TSDL_Blit

SDL.Import

** * The type of function used for surface blitting functions. *

TSDL_BlitMap

SDL.Import

TSDL_Bool

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDLtype_s.h / SDL_stdinc.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

TSDL_Color

SDL.Import

TSDL_Colour

SDL.Import

TSDL_CommonEvent

SDL.Import

** * Fields shared by every event *

TSDL_ControllerAxisEvent

SDL.Import

** * Game controller axis motion event structure (event.caxis.*) *

TSDL_ControllerButtonEvent

SDL.Import

** * Game controller button event structure (event.cbutton.*) *

TSDL_ControllerDeviceEvent

SDL.Import

** * Controller device event structure (event.cdevice.*) *

TSDL_DisplayMode

SDL.Import

TSDL_DollarGestureEvent

SDL.Import

* (event.dgesture.*) *

TSDL_DropEvent

SDL.Import

** * An event used to request a file open by the system (event.drop.*) * This event is disabled by default, you can enable it with SDL_EventState() * If you enable this event, you must free the filename in the event. *

TSDL_Error

SDL.Import

TSDL_ErrorCode

SDL.Import

#define SDL_OutOfMemory() SDL_Error(SDL_ENOMEM) #define SDL_Unsupported() SDL_Error(SDL_UNSUPPORTED) #define SDL_InvalidParamError(param) SDL_SetError("Parameter '%s' is invalid", (param))

TSDL_Event

SDL.Import

TSDL_EventAction

SDL.Import

TSDL_EventFilter

SDL.Import

TSDL_EventType

SDL.Import

TSDL_Finger

SDL.Import

TSDL_FingerID

SDL.Import

TSDL_GameController

SDL.Import

TSDL_GameControllerAxis

SDL.Import

TSDL_GameControllerBindType

SDL.Import

todo

TSDL_GameControllerButton

SDL.Import

TSDL_GameControllerButtonBind

SDL.Import

TSDL_GestureID

SDL.Import

///////////////////////////////////////////////////////////////////////////////////////////////////// /////////////////// SDL_gesture.h //////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////////////////////////////////

TSDL_GLattr

SDL.Import

TSDL_GLContext

SDL.Import

** * An opaque handle to an OpenGL context. *

TSDL_GLcontextFlag

SDL.Import

TSDL_GLprofile

SDL.Import

TSDL_Haptic

SDL.Import

TSDL_HapticCondition

SDL.Import

** * A structure containing a template for a Condition effect. * * The struct handles the following effects: * - SDL_HAPTIC_SPRING: Effect based on axes position. * - SDL_HAPTIC_DAMPER: Effect based on axes velocity. * - SDL_HAPTIC_INERTIA: Effect based on axes acceleration. * - SDL_HAPTIC_FRICTION: Effect based on axes movement. * * Direction is handled by condition internals instead of a direction member. * The condition effect specific members have three parameters. The first * refers to the X axis, the second refers to the Y axis and the third * refers to the Z axis. The right terms refer to the positive side of the * axis and the left terms refer to the negative side of the axis. Please * refer to the ::SDL_HapticDirection diagram for which side is positive and * which is negative. * * SDL_HapticDirection * SDL_HAPTIC_SPRING * SDL_HAPTIC_DAMPER * SDL_HAPTIC_INERTIA * SDL_HAPTIC_FRICTION * SDL_HapticEffect *

TSDL_HapticConstant

SDL.Import

** * A structure containing a template for a Constant effect. * * The struct is exclusive to the ::SDL_HAPTIC_CONSTANT effect. * * A constant effect applies a constant force in the specified direction * to the joystick. * * SDL_HAPTIC_CONSTANT * SDL_HapticEffect *

TSDL_HapticCustom

SDL.Import

** * A structure containing a template for the ::SDL_HAPTIC_CUSTOM effect. * * A custom force feedback effect is much like a periodic effect, where the * application can define its exact shape. You will have to allocate the * data yourself. Data should consist of channels * samples Uint16 samples. * * If channels is one, the effect is rotated using the defined direction. * Otherwise it uses the samples in data for the different axes. * * SDL_HAPTIC_CUSTOM * SDL_HapticEffect *

TSDL_HapticDirection

SDL.Import

** * Structure that represents a haptic direction. * * Directions can be specified by: * - SDL_HAPTIC_POLAR : Specified by polar coordinates. * - SDL_HAPTIC_CARTESIAN : Specified by cartesian coordinates. * - SDL_HAPTIC_SPHERICAL : Specified by spherical coordinates. * * Cardinal directions of the haptic device are relative to the positioning * of the device. North is considered to be away from the user. * * The following diagram represents the cardinal directions: * .–. |__| .——-. |=.| |.—–.| |–| || || | | |'—–'| |__|~')_____(' [ COMPUTER ]
North (0,-1) ˆ | | (1,0) West <—-[ HAPTIC ]—-> East (-1,0) | | v South (0,1)
[ USER ] \|||/ (o o) —ooO-(_)-Ooo—
* * If type is SDL_HAPTIC_POLAR, direction is encoded by hundredths of a * degree starting north and turning clockwise. ::SDL_HAPTIC_POLAR only uses * the first dir parameter. The cardinal directions would be: * - North: 0 (0 degrees) * - East: 9000 (90 degrees) * - South: 18000 (180 degrees) * - West: 27000 (270 degrees) * * If type is SDL_HAPTIC_CARTESIAN, direction is encoded by three positions * (X axis, Y axis and Z axis (with 3 axes)). ::SDL_HAPTIC_CARTESIAN uses * the first three dir parameters. The cardinal directions would be: * - North: 0,-1, 0 * - East: -1, 0, 0 * - South: 0, 1, 0 * - West: 1, 0, 0 * * The Z axis represents the height of the effect if supported, otherwise * it's unused. In cartesian encoding (1, 2) would be the same as (2, 4), you * can use any multiple you want, only the direction matters. * * If type is SDL_HAPTIC_SPHERICAL, direction is encoded by two rotations. * The first two dir parameters are used. The dir parameters are as * follows (all values are in hundredths of degrees): * - Degrees from (1, 0) rotated towards (0, 1). * - Degrees towards (0, 0, 1) (device needs at least 3 axes). * * * Example of force coming from the south with all encodings (force coming * from the south means the user will have to pull the stick to counteract): * * SDL_HapticDirection direction; * * // Cartesian directions * direction.type = SDL_HAPTIC_CARTESIAN; // Using cartesian direction encoding. * direction.dir[0] = 0; // X position * direction.dir[1] = 1; // Y position * // Assuming the device has 2 axes, we don't need to specify third parameter. * * // Polar directions * direction.type = SDL_HAPTIC_POLAR; // We'll be using polar direction encoding. * direction.dir[0] = 18000; // Polar only uses first parameter * * // Spherical coordinates * direction.type = SDL_HAPTIC_SPHERICAL; // Spherical encoding * direction.dir[0] = 9000; // Since we only have two axes we don't need more parameters. * * * SDL_HAPTIC_POLAR * SDL_HAPTIC_CARTESIAN * SDL_HAPTIC_SPHERICAL * SDL_HapticEffect * SDL_HapticNumAxes *

TSDL_HapticEffect

SDL.Import

TSDL_HapticPeriodic

SDL.Import

** * A structure containing a template for a Periodic effect. * * The struct handles the following effects: * - SDL_HAPTIC_SINE * - SDL_HAPTIC_SQUARE * - SDL_HAPTIC_TRIANGLE * - SDL_HAPTIC_SAWTOOTHUP * - SDL_HAPTIC_SAWTOOTHDOWN * * A periodic effect consists in a wave-shaped effect that repeats itself * over time. The type determines the shape of the wave and the parameters * determine the dimensions of the wave. * * Phase is given by hundredth of a cycle meaning that giving the phase a value * of 9000 will displace it 25% of its period. Here are sample values: * - 0: No phase displacement. * - 9000: Displaced 25% of its period. * - 18000: Displaced 50% of its period. * - 27000: Displaced 75% of its period. * - 36000: Displaced 100% of its period, same as 0, but 0 is preferred. * * Examples: * SDL_HAPTIC_SINE __ __ __ __ / \ / \ / \ / / \__/ \__/ \__/
SDL_HAPTIC_SQUARE __ __ __ __ __ | | | | | | | | | | | |__| |__| |__| |__| |
SDL_HAPTIC_TRIANGLE /\ /\ /\ /\ /\ / \ / \ / \ / \ / / \/ \/ \/ \/
SDL_HAPTIC_SAWTOOTHUP /| /| /| /| /| /| /| / | / | / | / | / | / | / | / |/ |/ |/ |/ |/ |/ |
SDL_HAPTIC_SAWTOOTHDOWN \ |\ |\ |\ |\ |\ |\ | \ | \ | \ | \ | \ | \ | \ | \| \| \| \| \| \| \|
* * SDL_HAPTIC_SINE * SDL_HAPTIC_SQUARE * SDL_HAPTIC_TRIANGLE * SDL_HAPTIC_SAWTOOTHUP * SDL_HAPTIC_SAWTOOTHDOWN * SDL_HapticEffect *

TSDL_HapticRamp

SDL.Import

** * A structure containing a template for a Ramp effect. * * This struct is exclusively for the ::SDL_HAPTIC_RAMP effect. * * The ramp effect starts at start strength and ends at end strength. * It augments in linear fashion. If you use attack and fade with a ramp * the effects get added to the ramp effect making the effect become * quadratic instead of linear. * * SDL_HAPTIC_RAMP * SDL_HapticEffect *

TSDL_HintCallback

SDL.Import

/** * \brief Add a function to watch a particular hint * * \param name The hint to watch * \param callback The function to call when the hint value changes * \param userdata A pointer to pass to the callback function */

TSDL_JoyAxisEvent

SDL.Import

** * Joystick axis motion event structure (event.jaxis.*) *

TSDL_JoyBallEvent

SDL.Import

** * Joystick trackball motion event structure (event.jball.*) *

TSDL_JoyButtonEvent

SDL.Import

** * Joystick button event structure (event.jbutton.*) *

TSDL_JoyDeviceEvent

SDL.Import

** * Joystick device event structure (event.jdevice.*) *

TSDL_JoyHatEvent

SDL.Import

** * Joystick hat position change event structure (event.jhat.*) *

TSDL_JoystickGUID

SDL.Import

* A structure that encodes the stable unique id for a joystick device *

TSDL_JoystickID

SDL.Import

TSDL_KeyboardEvent

SDL.Import

** * Keyboard button event structure (event.key.*) *

TSDL_KeyCode

SDL.Import

TSDL_KeyMod

SDL.Import

TSDL_Keysym

SDL.Import

TSDL_MessageBoxButtonData

SDL.Import

TSDL_MessageBoxButtonFlags

SDL.Import

**< Marks the default button when escape is hit *

TSDL_MessageBoxColor

SDL.Import

TSDL_MessageBoxColorScheme

SDL.Import

TSDL_MessageBoxColorType

SDL.Import

TSDL_MessageBoxData

SDL.Import

TSDL_MessageBoxFlags

SDL.Import

**< informational dialog *

TSDL_MouseButtonEvent

SDL.Import

** * Mouse button event structure (event.button.*) *

TSDL_MouseMotionEvent

SDL.Import

** * Mouse motion event structure (event.motion.*) *

TSDL_MouseWheelEvent

SDL.Import

** * Mouse wheel event structure (event.wheel.*) *

TSDL_MultiGestureEvent

SDL.Import

** * Multiple Finger Gesture Event (event.mgesture.*) *

TSDL_Mutex

SDL.Import

***KTI***

TSDL_Palette

SDL.Import

TSDL_PixelFormat

SDL.Import

TSDL_Point

SDL.Import

TSDL_PowerState

SDL.Import

** * The basic state for the system's power supply. *

TSDL_QuitEvent

SDL.Import

** * The "quit requested" event *

TSDL_Rect

SDL.Import

TSDL_RendererFlags

SDL.Import

TSDL_RendererFlip

SDL.Import

TSDL_RendererInfo

SDL.Import

TSDL_RWops

SDL.Import

TSDL_ScanCode

SDL.Import

TSDL_Surface

SDL.Import

TSDL_SystemCursor

SDL.Import

TSDL_SysWMEvent

SDL.Import

TSDL_SysWMinfo

SDL.Import

TSDL_SysWMmsg

SDL.Import

TSDL_TextEditingEvent

SDL.Import

** * Keyboard text editing event structure (event.edit.*) *

TSDL_TextInputEvent

SDL.Import

** * Keyboard text input event structure (event.text.*) *

TSDL_TextureAccess

SDL.Import

TSDL_TextureModulate

SDL.Import

TSDL_Thread

SDL.Import

TSDL_ThreadFunction

SDL.Import

TSDL_ThreadID

SDL.Import

* The SDL thread ID *

TSDL_ThreadPriority

SDL.Import

* The SDL thread priority * * Note: On many systems you require special privileges to set high priority. *

TSDL_TimerCallback

SDL.Import

** * Function prototype for the timer callback function. * * The callback function is passed the current timer interval and returns * the next timer interval. If the returned value is the same as the one * passed in, the periodic alarm continues, otherwise a new alarm is * scheduled. If the callback returns 0, the periodic alarm is cancelled. *

TSDL_TimerID

SDL.Import

** * Definition of the timer ID type. *

TSDL_TLSID

SDL.Import

TSDL_TouchFingerEvent

SDL.Import

** * Touch finger event structure (event.tfinger.*) *

TSDL_TouchID

SDL.Import

TSDL_UserEvent

SDL.Import

** * A user-defined event type (event.user.*) *

TSDL_Version

SDL.Import

TSDL_Window

SDL.Import

* Define the SDL window structure, corresponding to toplevel windows *

TSDL_WindowEvent

SDL.Import

** * Window state change event data (event.window.*) *

TSDL_WindowEventID

SDL.Import

**< The window manager requests that the window be closed *

TSDL_WindowFlags

SDL.Import

**< window not created by SDL *

TSDL_WindowShapeMode

SDL.Import

TSDL_WindowShapeParams

SDL.Import

** A union containing parameters for shaped windows. *

TSDL_WindowShaper

SDL.Import

TSDL_WindowUserData

SDL.Import

TSeaErosion

GLS.RandomHDS

TSeek

SDL.Import

** * Seek to offset relative to whence, one of stdio's whence values: * RW_SEEK_SET, RW_SEEK_CUR, RW_SEEK_END * * the final offset in the data stream, or -1 on error. *

TSerializeEvent

GLS.NGDManager

TServiceContextTask

GLS.Context

TSetSubItemsEvent

FmSceneEditor

TSetTextureTargetsEvent

GLS.FBORenderer

TSetTransformEvent

GLS.NGDManager

TShaderFileProperty

GLS.SceneRegister

TShaderMemoForm

FmShaderMemo

TShadeType3DS

Formats.m3DSTypes

used for shading field in TMaterial3DS structure

TShadowFilter

Formats.m3DSTypes

TShadowMapSize

Formats.m3DSTypes

TShadowPlaneOption

GLS.ShadowPlane

TShadowPlaneOptions

GLS.ShadowPlane

TShadowRange

Formats.m3DSTypes

TShadowSamples

Formats.m3DSTypes

TShadowSets3DS

Formats.m3DSTypes

global Shadow settings

TShadowStyle3DS

Formats.m3DSTypes

TShortIntArray

GLS.HeightTileFileHDS

TSIBLigthing

GLS.Imposter

TSingleArray

GLScene.VectorGeometry

TSingleClamp

GLS.RandomHDS

TSingleList

Formats.m3DSTypes

TSingleRaster

GLS.HeightData

TSize

SDL.Import

** * Return the size of the file in this rwops, or -1 if unknown *

Tsize_t

OpenCL.Platform

TSmallintArray

GLS.HeightData

TSmallIntArray

GLS.HeightTileFileHDS

TSmallIntRaster

GLS.HeightData

TSmoothGroup

Formats.m3DSTypes

TSolidBgnd3DS

Formats.m3DSTypes

Name of background Bitmap

TSourceDataFetchedEvent

GLS.HeightData

TSpaceContains

GLScene.GeometryBB

Result type for space intersection tests, like AABBContainsAABB or BSphereContainsAABB

TSpecularMode

GLSL.BumpShaders

TSPOctreeNode

GLS.SpacePartition

** OCTTREE Implements sector node that handles octrees

TSpotCone3DS

Formats.m3DSTypes

TSpotLight3DS

Formats.m3DSTypes

TSpotProjector3DS

Formats.m3DSTypes

TSpotShadow3DS

Formats.m3DSTypes

TSPQuadtreeNode

GLS.SpacePartition

** QUADTREE Implements sector node that handles quadtrees

TSpriteColorMode

GLS.ParticleFX

Sprite color modes. scmFade: vertex coloring is used to fade inner-outer scmInner: vertex coloring uses inner color only scmOuter: vertex coloring uses outer color only scmNone: vertex coloring is NOT used (colors are ignored)

TSpritesPerTexture

GLS.ParticleFX

Sprites per sprite texture for the SpritePFX.

TSqrt255Array

GLScene.Utils

TStartPreparingDataEvent

GLS.HeightData

TStateArray

GLS.PhysManager

TDESolver = procedure((*RigidBody:TGLRigidBody;*)DeltaTime:Real) of object;

TStateRecord

GLS.State

TStaticImposter

GLS.Imposter

Imposter class whose texture contains several views from different angles.

TStdio

SDL.Import

TSteps

GLS.RandomHDS

TSTLFace

GLS.FileSTL

TSTLHeader

GLS.FileSTL

TSTLVertex

GLS.FileSTL

TStyleList

GLS.Memo

TSubdivideEdgeEvent

GLS.MeshUtils

TTargetType3DS

Formats.m3DSTypes

TTaskProcedure

GLS.Context

TTerrainHighResStyle

GLS.TerrainRenderer

TTerrainOcclusionTesselate

GLS.TerrainRenderer

TTexPoint

GLScene.VectorGeometry

TTexPointArray

GLScene.VectorGeometry

TTEXSChunk

Formats.B3D

TTextureReference

CUDA.Runtime

TTexVert3DS

Formats.m3DSTypes

Texture assignment coordinate

TTexVertList

Formats.m3DSTypes

TTexVerts

Formats.m3DSTypes

TTGAImage

GLS.FileTGA

TGA image load/save capable class. TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.

TTGLFile3DSPositionAnimationKeys

GLS.File3DS

TThorpoint

GLS.ThorFX

TThorpointArray

GLS.ThorFX

TThreadBmp32

GLS.ShadowHDS

TThreadID

SDL.Import

** * SDL_thread.h * * We compile SDL into a DLL. This means, that it's the DLL which * creates a new thread for the calling process with the SDL_CreateThread() * API. There is a problem with this, that only the RTL of the SDL.DLL will * be initialized for those threads, and not the RTL of the calling * application! * * To solve this, we make a little hack here. * * We'll always use the caller's _beginthread() and _endthread() APIs to * start a new thread. This way, if it's the SDL.DLL which uses this API, * then the RTL of SDL.DLL will be used to create the new thread, and if it's * the application, then the RTL of the application will be used. * * So, in short: * Always use the _beginthread() and _endthread() of the calling runtime * library! *

TTileManagementFlag

GLS.TerrainRenderer

TTileManagementFlags

GLS.TerrainRenderer

TTileType3DS

Formats.m3DSTypes

used for tiling field in TBitmap3DS structure

TTimeEvent

GLS.TimeEventsMgr

TTimeEventProc

GLS.TimeEventsMgr

TTimeEvents

GLS.TimeEventsMgr

TTimeEventType

GLS.TimeEventsMgr

TTintType3DS

Formats.m3DSTypes

TTokenType

GLS.Memo

TTouchEvent

GLS.SceneViewer

TTrackHeader3DS

Formats.m3DSTypes

Global track settings

TTransformations

GLScene.VectorGeometry

Used to describe a sequence of transformations in following order: [Sx][Sy][Sz][ShearXY][ShearXZ][ShearZY][Rx][Ry][Rz][Tx][Ty][Tz][P(x,y,z,w)] constants are declared for easier access (see MatrixDecompose below)

TTranslator

gnugettext

Translates a component (form, frame etc.) to the currently selected language. Put TranslateComponent(self) in the OnCreate event of all your forms. See the manual for documentation on these functions

TTransType

GLScene.VectorGeometry

TTriangleRec

GLScene.VectorTypesExt

TTriangleRecArray

GLScene.VectorTypesExt

TTRISChunk

Formats.B3D

TU1

Formats.LWO

TU1DynArray

Formats.LWO

TU2

Formats.LWO

TU2Array

Formats.LWO

TU2DynArray

Formats.LWO

TU4

Formats.LWO

TU48BitBlock

GLS.ImageUtils

TU4Array

Formats.LWO

TU4DynArray

Formats.LWO

TUBOStates

GLS.State

TUInt8Array

SDL.Import

TUndoChangeEvent

GLS.Memo

TUniformAutoSetMethod

GLSL.ShaderParameter

TUniformAutoSetProperty

GLS.SceneRegister

TUnknown

SDL.Import

TUpdateSpacePartion

GLS.VerletTypes

Turn

GLScene.VectorGeometry

Coordinate system manipulation functions Rotates the given coordinate system (represented by the matrix) around its Y-axis

Turn

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterUp

TUseDirtyTiles

GLS.AsyncHDS

Determines if/how dirty tiles are displayed and when they are released. When a tile is maked as dirty, a replacement is queued immediately. However, the replacement cant be used until the HDThread has finished preparing it. Dirty tiles can be deleted as soon as they are no longer used/displayed. Possible states for a TUseDirtyTiles. hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, before allowing the renderer to switch over to the new set of tiles. (This prevents a fading checkerbox effect.)

TUserView3DS

Formats.m3DSTypes

TVec12

Formats.LWO

TS0 = PAnsiChar;

TVec12Array

Formats.LWO

TVec12DynArray

Formats.LWO

TVector2b

GLScene.VectorTypes

TVector2d

GLScene.VectorTypes

=========== Vectors ============ 2

TVector2DArray

GLScene.VectorTypesExt

Vector Arrays

TVector2DRec

GLScene.VectorTypesExt

TVector2DType

GLScene.VectorTypesExt

———————– Vector types ———————–

TVector2e

GLScene.VectorTypes

TVector2f

GLScene.VectorTypes

TVector2h

GLScene.VectorTypes

TVector2i

GLScene.VectorTypes

TVector2p

GLScene.VectorTypes

TVector2s

GLScene.VectorTypes

TVector2sb

GLScene.VectorTypes

TVector2ui

GLScene.VectorTypes

TVector2w

GLScene.VectorTypes

TVector3b

GLScene.VectorTypes

TVector3d

GLScene.VectorTypes

3

TVector3DArray

GLScene.VectorTypesExt

TVector3DRec

GLScene.VectorTypesExt

TVector3DType

GLScene.VectorTypesExt

TVector3e

GLScene.VectorTypes

TVector3f

GLScene.VectorTypes

TVector3h

GLScene.VectorTypes

TVector3i

GLScene.VectorTypes

TVector3p

GLScene.VectorTypes

TVector3s

GLScene.VectorTypes

TVector3sb

GLScene.VectorTypes

TVector3ui

GLScene.VectorTypes

TVector3w

GLScene.VectorTypes

TVector4b

GLScene.VectorTypes

TVector4d

GLScene.VectorTypes

4

TVector4e

GLScene.VectorTypes

TVector4f

GLScene.VectorTypes

TVector4h

GLScene.VectorTypes

TVector4i

GLScene.VectorTypes

TVector4p

GLScene.OpenGL4

TVector4p

GLScene.VectorTypes

TVector4s

GLScene.VectorTypes

TVector4sb

GLScene.VectorTypes

TVector4ui

GLScene.VectorTypes

TVector4w

GLScene.VectorTypes

TVectorArr

GLS.Isolines

TVectorArray

GLScene.VectorGeometry

TVectorExt

GLScene.VectorTypesExt

TVectorHelper

GLScene.VectorTypesExt

TVectorL4D

GLS.Isolines

TVectorL4I

GLS.Isolines

TVectorRec

GLScene.VectorTypesExt

TVertArray

GLScene.VectorTypesExt

TVertex

GLScene.VectorGeometry

TVertex2DArr

GLS.Isolines

TVertexArray

GLScene.VectorTypesExt

TVertexData

Formats.B3D

TVertexRec

GLScene.VectorTypesExt

TVertexWeightList

GLS.FileMS3D

TVGradient

Formats.m3DSTypes

TVGradientBgnd3DS

Formats.m3DSTypes

TVIDEOHDR

Formats.VFW

TViewport3DS

Formats.m3DSTypes

Viewport structure details the kind of View in a viewport

TViewportData

Formats.m3DSTypes

TViewportData3

Formats.m3DSTypes

TViewportLayout

Formats.m3DSTypes

TViewportSize

Formats.m3DSTypes

TViewSize3DS

Formats.m3DSTypes

TViewStandard

Formats.m3DSTypes

TViewType3DS

Formats.m3DSTypes

TViewUser

Formats.m3DSTypes

TVirtualKeyCode

GLScene.Keyboard

TVORFace

GLS.FileVOR

TVORHeader

GLS.FileVOR

TVORVertex

GLS.FileVOR

TVoxelData

GLScene.VectorTypesExt

TVoxelRec

GLScene.VectorTypesExt

TVoxelStatus

GLScene.VectorTypesExt

Voxel types

TVRMLIntegerArray

Formats.VRML

TVRMLMaterial

Formats.VRML

TVRMLNode

Formats.VRML

TVRMLParser

Formats.VRML

TVRMLShapeHints

Formats.VRML

TVRMLSingleArray

Formats.VRML

TVRMLTransform

Formats.VRML

TVRMLUse

Formats.VRML

TVRTSChunk

Formats.B3D

Tweener

GLScene.AnimationUtils

Tweener

GLScene.AnimationUtils

Tweener

GLScene.AnimationUtils

Tweener

GLScene.AnimationUtils

TWGLSwap

GLScene.OpenGL4

TWGLswap

GLScene.OpenGLTokens

TWindowShapeMode

SDL.Import

** An enum denoting the specific type of contents present in an SDL_WindowShapeParams union. *

TWindowsIO

SDL.Import

TWindowsIOBuffer

SDL.Import

TWOCC

Formats.VFW

TWOCCFromFOURCC

Formats.VFW

– Macro to get TWOCC chunk type out of a FOURCC ckid ———————–

TWordList

Formats.m3DSTypes

TWordVector

GLScene.VectorGeometry

TWrite

SDL.Import

** * Write exactly num objects each of size size from the area * pointed at by ptr to data stream. * * the number of objects written, or 0 at error or end of file. *

TXCollection

GLScene.XCollection

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

TXCollectionEditorForm

FmXCollectionEditor

TXCollectionItem

GLScene.XCollection

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

TXCollectionItemClass

GLScene.XCollection

TXCollectionProperty

GLS.XCollectionRegister

TXDataDouble

Formats.m3DSTypes

TXDataEntry

Formats.m3DSTypes

TXDataFloat

Formats.m3DSTypes

TXDataLong

Formats.m3DSTypes

TXDataRaw3DS

Formats.m3DSTypes

TXDataShort

Formats.m3DSTypes

TXDataVoid

Formats.m3DSTypes

TZArray

GLS.zBuffer

TZArrayIdx

GLS.zBuffer

TZCompressedMode

GLS.FileVfsPAK

Signature for compressed pak.

TZLibArchive

GLS.FileZLIB

TZLibHeader

GLS.FileZLIB

Signature for compressed zlib.

T_cl_command_queue

OpenCL.Import

T_cl_context

OpenCL.Import

T_cl_device_id

OpenCL.Import

T_cl_event

OpenCL.Import

T_cl_kernel

OpenCL.Import

T_cl_mem

OpenCL.Import

T_cl_platform_id

OpenCL.Import

T_cl_program

OpenCL.Import

T_cl_sampler

OpenCL.Import

UByteElement

CUDA.DataAccess

UInt16

SDL.Import

UInt32

SDL.Import

UInt8

SDL.Import

UIntElement

CUDA.DataAccess

UnApplyBlendingModeEx

GLSL.CustomShader

UnicodeString

gnugettext

***************************************************************************

UnifyTrianglesWinding

GLS.MeshUtils

Attempts to unify triangle winding. Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)

UnloadModule

ModuleLoader

UnloadOpenGL

GLS.OpenGLAdapter

compatibility routines

UnloadOpenGL

GLScene.OpenGL4

compatibility routines

UnPackRotationMatrix

GLScene.VectorGeometry

Restores a packed rotation matrix. See PackRotationMatrix

UnpressGroup

GLS.Windows

UnProject

GLScene.VectorGeometry

UnregisterArchiveFormat

GLS.ArchiveManager

UnregisterGLSceneObject

GLS.ODEManager

UnRegisterGLTextureImageEditor

GLS.TextureImageEditors

UnregisterRasterFormat

GLS.Graphics

UnregisterSoundFileClass

GLS.SoundFileObjects

UnregisterVectorFileClass

GLS.VectorFileObjects

UnregisterXCollectionItemClass

GLScene.XCollection

Removes a TXCollectionItem subclass from the list

UseCustomGLSLogger

GLScene.Logger

UseLanguage

gnugettext

Set language to use

UseMemoryMappedFiles

gnugettext

Set to true, to prefer external *.mo over embedded translation

UserLog

GLScene.Logger

Return logger wich created by TGLSLogger component

USE_BEVEL

Formats.m3DSConst

USE_BIT_MAP

Formats.m3DSConst

USE_CONTOUR

Formats.m3DSConst

Flags for Modeler options

USE_DISTANCE_CUE

Formats.m3DSConst

USE_FIT

Formats.m3DSConst

USE_FOG

Formats.m3DSConst

USE_LAYER_FOG

Formats.m3DSConst

USE_SCALE

Formats.m3DSConst

USE_SOLID_BGND

Formats.m3DSConst

USE_TEETER

Formats.m3DSConst

USE_TWEEN

Formats.m3DSConst

USE_TWIST

Formats.m3DSConst

USE_V_GRADIENT

Formats.m3DSConst

UShortElement

CUDA.DataAccess

vAFIOCreateFileStream

GLS.ApplicationFileIO

vAFIOFileStreamExists

GLS.ApplicationFileIO

VCAPS_CAN_SCALE

Formats.VFW

dst rect can clip

VCAPS_DST_CAN_CLIP

Formats.VFW

src rect can clip

VCAPS_OVERLAY

Formats.VFW

– dwFlags of CHANNEL_CAPS ————————————————–

VCAPS_SRC_CAN_CLIP

Formats.VFW

overlay channel

vContextActivationFailureOccurred

GLS.Context

vCounterFrequency

GLS.Scene

VCSVersion

gnugettext

Set to True, to reread mo-file if the current language is selected again Subversion source code version control version information

vCurrentGLContext

GLS.Context

vCurrentRenderingObject

GLS.Scene

vCurrentVideoMode

GLS.Screen

vCustomColliderClass

GLS.ODEManager

vCustomColliderClassNum

GLS.ODEManager

vDDSDetailLevel

GLS.FileDDS

Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.

vDefaultMeshOptimizerOptions

GLS.MeshBuilder

vDefaultTextureCompression

GLScene.TextureFormat

vDefaultTextureFormat

GLScene.TextureFormat

Vector2bMake

GLScene.VectorGeometry

Vector2bMake

GLScene.VectorGeometry

Vector2bMake

GLScene.VectorGeometry

Vector2dMake

GLScene.VectorGeometry

Vector2dMake

GLScene.VectorGeometry

Vector2dMake

GLScene.VectorGeometry

Vector2fMake

GLScene.VectorGeometry

Vector2fMake

GLScene.VectorGeometry

Vector2fMake

GLScene.VectorGeometry

2x

Vector2iMake

GLScene.VectorGeometry

Vector2iMake

GLScene.VectorGeometry

Vector2iMake

GLScene.VectorGeometry

Vector2sMake

GLScene.VectorGeometry

Vector2sMake

GLScene.VectorGeometry

Vector2sMake

GLScene.VectorGeometry

Vector3ADD

ODE.Import

Vector3bMake

GLScene.VectorGeometry

Vector3bMake

GLScene.VectorGeometry

Vector3bMake

GLScene.VectorGeometry

Vector3Cross

ODE.Import

Vector3dMake

GLScene.VectorGeometry

Vector3dMake

GLScene.VectorGeometry

Vector3dMake

GLScene.VectorGeometry

Vector3fMake

GLScene.VectorGeometry

Vector3fMake

GLScene.VectorGeometry

Vector3fMake

GLScene.VectorGeometry

3x

Vector3iMake

GLScene.VectorGeometry

Vector3iMake

GLScene.VectorGeometry

Vector3iMake

GLScene.VectorGeometry

Vector3Length

ODE.Import

Vector3Make

ODE.Import

Vector3ScalarMul

ODE.Import

Vector3sMake

GLScene.VectorGeometry

Vector3sMake

GLScene.VectorGeometry

Vector3sMake

GLScene.VectorGeometry

Vector3SUB

ODE.Import

Vector4bMake

GLScene.VectorGeometry

Vector4bMake

GLScene.VectorGeometry

Vector4bMake

GLScene.VectorGeometry

Vector4dMake

GLScene.VectorGeometry

Vector4dMake

GLScene.VectorGeometry

Vector4dMake

GLScene.VectorGeometry

Vector4fMake

GLScene.VectorGeometry

Vector4fMake

GLScene.VectorGeometry

Vector4fMake

GLScene.VectorGeometry

4x

Vector4iMake

GLScene.VectorGeometry

Vector4iMake

GLScene.VectorGeometry

Vector4iMake

GLScene.VectorGeometry

Vector4sMake

GLScene.VectorGeometry

Vector4sMake

GLScene.VectorGeometry

Vector4sMake

GLScene.VectorGeometry

VectorAbs

GLScene.VectorGeometry

Returns a vector with components replaced by their Abs value. }

VectorAbs

GLScene.VectorGeometry

Returns a vector with components replaced by their Abs value. }

VectorAdd

GLScene.VectorGeometry

VectorAdd

GLScene.VectorGeometry

VectorAdd

GLScene.VectorGeometry

VectorAdd

GLScene.VectorGeometry

Adds two vectors and places result in vr

VectorAdd

GLScene.VectorGeometry

Returns the sum of two affine vectors

VectorAdd

GLScene.VectorGeometry

Returns the sum of two homogeneous vectors

VectorAdd

GLScene.VectorGeometry

Sums up f to each component of the vector

VectorAdd

GLScene.VectorGeometry

Sums up f to each component of the vector

VectorAffineDblToFlt

GLScene.VectorGeometry

Converts a vector containing double sized values into a vector with single sized values

VectorAffineFltToDbl

GLScene.VectorGeometry

Converts a vector containing single sized values into a vector with double sized values

VectorAngleCombine

GLScene.VectorGeometry

VectorAngleCosine

GLScene.VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

VectorAngleCosine

GLScene.VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

VectorAngleLerp

GLScene.VectorGeometry

VectorArrayAdd

GLScene.VectorGeometry

Adds delta to nb vectors in src and places result in dest

VectorArrayLerp

GLScene.VectorGeometry

VectorArrayLerp

GLScene.VectorGeometry

VectorArrayLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector arrays

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr, F1=1.0

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine3

GLScene.VectorGeometry

VectorCombine3

GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCombine3

GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCombine3

GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorDblToFlt

GLScene.VectorGeometry

Converts a vector containing double sized values into a vector with single sized values

VectorDistance

GLScene.VectorGeometry

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...)

VectorDistance

GLScene.VectorGeometry

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)

VectorDistance2

GLScene.VectorGeometry

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...

VectorDistance2

GLScene.VectorGeometry

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...(w component ignored)

VectorDivide

GLS.EllipseCollision

VectorDivide

GLScene.VectorGeometry

VectorDivide

GLScene.VectorGeometry

VectorDotProduct

GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y]

VectorDotProduct

GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorDotProduct

GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorDotProduct

GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

function VectorEquals(const V1, V2: TVector3f): Boolean; overload; //declared further

VectorEquals

GLScene.VectorGeometry

function VectorEquals(const V1, V2: TVector4f): Boolean; overload; //declared further

VectorEquals

GLScene.VectorGeometry

True if all components are equal.

VectorEquals

GLScene.VectorGeometry

True if all components are equal.

VectorFileFormatExtensionByIndex

GLS.VectorFileObjects

Returns an extension by its index in the vector files dialogs filter. Use VectorFileFormatsFilter to obtain the filter.

VectorFileFormatsFilter

GLS.VectorFileObjects

A file extension filter suitable for dialog's 'Filter' property

VectorFileFormatsSaveFilter

GLS.VectorFileObjects

A file extension filter suitable for a savedialog's 'Filter' property

VectorFltToDbl

GLScene.VectorGeometry

Converts a vector containing single sized values into a vector with double sized values

VectorIsNull

GLScene.VectorGeometry

True if x=y=z=0, w ignored

VectorIsNull

GLScene.VectorGeometry

True if x=y=z=0, w ignored

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation: sqrt(x*x+y*y+...). Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.

VectorLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t

VectorLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t

VectorLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

VectorLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorMake

GLScene.VectorGeometry

VectorMake

GLScene.VectorGeometry

VectorMake

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreThen

GLScene.VectorGeometry

3i

VectorMoreThen

GLScene.VectorGeometry

3i

VectorMoreThen

GLScene.VectorGeometry

3s

VectorMoreThen

GLScene.VectorGeometry

3s

VectorMoreThen

GLScene.VectorGeometry

4f

VectorMoreThen

GLScene.VectorGeometry

4f

VectorMoreThen

GLScene.VectorGeometry

4i

VectorMoreThen

GLScene.VectorGeometry

4i

VectorMoreThen

GLScene.VectorGeometry

4s

VectorMoreThen

GLScene.VectorGeometry

4s

VectorMoreThen

GLScene.VectorGeometry

ComparedNumber 3f

VectorMoreThen

GLScene.VectorGeometry

Vector comparison functions: 3f

VectorNegate

GLScene.VectorGeometry

VectorNegate

GLScene.VectorGeometry

Negates the vector

VectorNorm

GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = v.X*v.X + ... Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x * x + y * y Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNormalize

GLScene.VectorGeometry

Returns the vector transformed to unit length

VectorNormalize

GLScene.VectorGeometry

Returns the vector transformed to unit length

VectorNormalize

GLScene.VectorGeometry

Returns the vector transformed to unit length (w component dropped)

VectorPerpendicular

GLScene.VectorGeometry

Calculates a vector perpendicular to N. N is assumed to be of unit length, subtract out any component parallel to N

VectorReflect

GLScene.VectorGeometry

Reflects vector V against N (assumes N is normalized)

VectorRotateAroundX

GLScene.VectorGeometry

Returns given vector rotated around the X axis (alpha is in rad)

VectorRotateAroundY

GLScene.VectorGeometry

Returns given vector rotated around the Y axis (alpha is in rad)

VectorRotateAroundY

GLScene.VectorGeometry

Returns given vector rotated around the Y axis in vr (alpha is in rad)

VectorRotateAroundZ

GLScene.VectorGeometry

Returns given vector rotated around the Z axis (alpha is in rad)

VectorScale

GLScene.VectorGeometry

Returns a vector scaled by a factor

VectorScale

GLScene.VectorGeometry

Returns a vector scaled by a factor

VectorScale

GLScene.VectorGeometry

Returns a vector scaled by a factor

VectorScale

GLScene.VectorGeometry

RScales given vector by another vector

VectorScale

GLScene.VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

GLScene.VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

GLScene.VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

GLScene.VectorGeometry

Scales given vector by another vector

VectorSpacing

GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".

VectorSpacing

GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".

VectorSpacing

GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".

VectorSubtract

GLScene.VectorGeometry

VectorSubtract

GLScene.VectorGeometry

VectorSubtract

GLScene.VectorGeometry

Returns V1-V2

VectorSubtract

GLScene.VectorGeometry

Returns V1-V2

VectorSubtract

GLScene.VectorGeometry

Returns V1-V2

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorTransform

GLScene.VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix

VectorTransform

GLScene.VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix

VectorTransform

GLScene.VectorGeometry

Transforms an affine vector by multiplying it with a matrix

VectorTransform

GLScene.VectorGeometry

Transforms an affine vector by multiplying it with a matrix

vEdgeInfoReserveSize

GLS.MeshUtils

VerifyDelphiODE

ODE.Import

VerticalScalingFactor

GLS.RandomHDS

vFindCuFileFunc

GLS.CUDA.Compiler

vFontManagerMsgID

GLS.SpaceText

vGhoul2LevelOfDetail

GLS.FileGL2

vGhoul2MaxBonesPerVertex

GLS.FileGL2

Highest detail level by default

vGLFile3DSSceneObjects_RenderCameraAndLights

GLS.File3DSSceneObjects

vGLFile3DS_EnableAnimation

GLS.File3DS

If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TGLFreeForm.AutoCentering does now work correctly. - TGLMeshObject.vertices return values different from TGLMeshObject.ExtractTriangles()

vGLFile3DS_FixDefaultUpAxisY

GLS.File3DS

If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vGLFile3DS_EnableAnimation = true)

vGLFile3DS_LoadedStaticFrame

GLS.File3DS

If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vGLFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.

vGLFile3DS_UseTextureEx

GLS.File3DS

If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.

vGLFileOBJ_SplitMesh

GLS.FileOBJ

If enabled, main mesh will be splitted into multiple mesh from facegroup data.

vGLFileOCTAllocateMaterials

GLS.FileOCT

Scaling factor, 1.0 = unchanged

vGLFileOCTLightmapBrightness

GLS.FileOCT

vGLFileOCTLightmapGammaCorrection

GLS.FileOCT

Scaling factor, 1.0 = unchanged

vGLFileQ3BSPLoadMaterials

GLS.FileQ3BSP

scaling factor, 1.0 = unchanged

vGLSmartObjectsAllocate

GLS.SmartObjects

vGLSmartObjectsEnableByDefault

GLS.SmartObjects

vGLVectorFileObjectsAllocateMaterials

GLS.VectorFileObjects

vGLVectorFileObjectsEnableVBOByDefault

GLS.VectorFileObjects

Flag to avoid loading materials (useful for IDE Extentions or scene editors)

VGradientMax3DS

Formats.m3DSConst

minimum value for gradient midpoint

VGradientMin3DS

Formats.m3DSConst

maximum string length for filename V_GRADIENT chunk

VHDR_DONE

Formats.VFW

– dwFlags field of VIDEOHDR ————————————————

VHDR_INQUEUE

Formats.VFW

Set if this header has been prepared

VHDR_KEYFRAME

Formats.VFW

Reserved for driver

VHDR_PREPARED

Formats.VFW

Done bit

VIDCF_COMPRESSFRAMES

Formats.VFW

supports inter-frame compress

VIDCF_CRUNCH

Formats.VFW

supports quality

VIDCF_DRAW

Formats.VFW

wants the compress all frames message

VIDCF_FASTTEMPORALC

Formats.VFW

supports drawing

VIDCF_FASTTEMPORALD

Formats.VFW

does not need prev frame on compress

VIDCF_QUALITY

Formats.VFW

– Flags for the <dwFlags> field of the <ICINFO> structure. ————

VIDCF_TEMPORAL

Formats.VFW

supports crunching to a frame size

vIDELogProc

GLScene.Logger

VideoForWindowsVersion

Formats.VFW

*************************************************************************** * * VideoForWindowsVersion() - returns version of VfW * **************************************************************************

VIDEO_CONFIGURE_CURRENT

Formats.VFW

VIDEO_CONFIGURE_GET

Formats.VFW

– videoConfigure (GET only) ————————————————

VIDEO_CONFIGURE_MAX

Formats.VFW

VIDEO_CONFIGURE_MIN

Formats.VFW

VIDEO_CONFIGURE_NOMINAL

Formats.VFW

VIDEO_CONFIGURE_QUERY

Formats.VFW

– videoConfigure (both GET and SET) —————————————-

VIDEO_CONFIGURE_QUERYSIZE

Formats.VFW

VIDEO_CONFIGURE_SET

Formats.VFW

– videoConfigure (SET only) ————————————————

VIDEO_DLG_QUERY

Formats.VFW

– Is a driver dialog available for this channel —————————-

VIDEO_EXTERNALIN

Formats.VFW

– Types of channels to open with the videoOpen function ——————–

VIDEO_EXTERNALOUT

Formats.VFW

VIDEO_IN

Formats.VFW

VIDEO_OUT

Formats.VFW

ViewCameraStrMax3DS

Formats.m3DSConst

maximum value for dimming factor VIEW_CAMERA

VIEWPORT_DATA

Formats.m3DSConst

VIEWPORT_DATA_3

Formats.m3DSConst

VIEWPORT_DATA_OLD

Formats.m3DSConst

VIEWPORT_LAYOUT

Formats.m3DSConst

VIEWPORT_LAYOUT_OLD

Formats.m3DSConst

Viewport description chunks

VIEWPORT_SIZE

Formats.m3DSConst

VIEW_BACK

Formats.m3DSConst

VIEW_BOTTOM

Formats.m3DSConst

VIEW_CAMERA

Formats.m3DSConst

VIEW_FRONT

Formats.m3DSConst

VIEW_LEFT

Formats.m3DSConst

VIEW_RIGHT

Formats.m3DSConst

VIEW_TOP

Formats.m3DSConst

VIEW_USER

Formats.m3DSConst

VIEW_WINDOW

Formats.m3DSConst

vIgnoreOpenGLErrors

GLS.Context

vIgnoreOpenGLErrors

GLScene.OpenGL4

Raises an EOpenGLError with 'msg' error string

vImageScaleFilterWidth

GLS.ImageUtils

vImprovedFixingOpenTriangleEdge

GLS.MeshUtils

VirtualKeyCodeToKeyName

GLScene.Keyboard

Converts a virtual key code to its name. The name is expressed using the locale windows options.

VK_MOUSEWHEELDOWN

GLScene.Keyboard

VK_MOUSEWHEELUP

GLScene.Keyboard

pseudo wheel keys (we squat F23/F24), see KeyboardNotifyWheelMoved

vLastWheelDelta

GLScene.Keyboard

vMainThread

GLS.Context

VMAP_TYPE_MNVW

Formats.LWO

WEIGHT MAP

VMAP_TYPE_MORF

Formats.LWO

RGBA MAP

VMAP_TYPE_PICK

Formats.LWO

SKELEGON?

VMAP_TYPE_RGB

Formats.LWO

UV MAP

VMAP_TYPE_RGBA

Formats.LWO

RGB MAP

VMAP_TYPE_SPOT

Formats.LWO

MORPH MAP: RELATIVE VERTEX DISPLACEMENT

VMAP_TYPE_TXUV

Formats.LWO

SUBPATCH WEIGHT MAP

VMAP_TYPE_WGHT

Formats.LWO

SELECTION SET

vMD5TextureExtensions

GLS.FileMD5

vNumberVideoModes

GLS.Screen

vODEObjectRegister

GLS.ODEManager

vODERagdoll_cDensity

GLS.ODERagdoll

vODERagdoll_cMass

GLS.ODERagdoll

VORUseEmbeddedColors

GLS.FileVOR

VPDATA

Formats.m3DSConst

Video Post

vProjectTargetName

GLScene.Utils

vQ3BSPLightmapBrightness

GLS.FileQ3BSP

vQ3BSPLightmapGammaCorrection

GLS.FileQ3BSP

Q3 lightmaps are quite dark, we brighten them a lot by default

vSIMD

GLScene.VectorGeometry

This var is adjusted during "initialization", current values are + 0 : use standard optimized FPU code + 1 : use 3DNow! optimized code (requires K6-2/3 CPU) + 2 : use Intel SSE code (Pentium III, NOT IMPLEMENTED YET !)

vUseWindowTrackingHook

GLS.WindowsContext

This boolean controls a hook-based tracking of top-level forms destruction, with the purpose of being able to properly release OpenGL contexts before they are (improperly) released by some drivers upon top-level form destruction

vVerboseGLSMErrors

GLS.SoundManager

If this variable is true, errors in GLSM may be displayed to the user

vVerticalFlipDDS

GLS.Graphics

vVideoModes

GLS.Screen

V_GRADIENT

Formats.m3DSConst

WeldVertices

GLS.MeshUtils

Welds all vertices separated by a distance inferior to weldRadius. Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter). The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex]. The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex. This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)

wglAllocateMemoryNV

GLScene.OpenGL4

wglBindTexImageARB

GLScene.OpenGL4

WGL_ARB_render_texture (ARB #20)

wglChoosePixelFormatARB

GLScene.OpenGL4

wglCopyContext

GLS.OpenGLAdapter

TGLExtensionsAndEntryPoints —————————— Windows OpenGL (WGL) support functions {$IFDEF SUPPORT_WGL} function wglGetProcAddress(ProcName: PAnsiChar): Pointer; stdcall; external opengl32;

wglCopyContext

GLScene.OpenGL4

wglCreateAffinityDCNV

GLScene.OpenGL4

wglCreateBufferRegionARB

GLScene.OpenGL4

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### WGL_buffer_region (ARB #4)

wglCreateContext

GLS.OpenGLAdapter

wglCreateContext

GLScene.OpenGL4

wglCreateContextAttribsARB

GLScene.OpenGL4

WGL_ARB_create_context (ARB #55)

wglCreateLayerContext

GLS.OpenGLAdapter

wglCreateLayerContext

GLScene.OpenGL4

wglCreatePbufferARB

GLScene.OpenGL4

WGL_ARB_pbuffer (ARB #11)

wglDeleteBufferRegionARB

GLScene.OpenGL4

wglDeleteContext

GLS.OpenGLAdapter

wglDeleteContext

GLScene.OpenGL4

wglDeleteDCNV

GLScene.OpenGL4

wglDescribeLayerPlane

GLScene.OpenGL4

wglDestroyPbufferARB

GLScene.OpenGL4

wglEnumGpuDevicesNV

GLScene.OpenGL4

wglEnumGpusFromAffinityDCNV

GLScene.OpenGL4

wglEnumGpusNV

GLScene.OpenGL4

WGL_NV_gpu_affinity

wglFreeMemoryNV

GLScene.OpenGL4

wglGetCurrentContext

GLS.OpenGLAdapter

function wglDescribeLayerPlane(p1: HDC; p2, p3: integer; p4: cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;

wglGetCurrentContext

GLScene.OpenGL4

wglGetCurrentDC

GLS.OpenGLAdapter

wglGetCurrentDC

GLScene.OpenGL4

wglGetCurrentReadDCARB

GLScene.OpenGL4

wglGetExtensionsStringARB

GLScene.OpenGL4

WGL_ARB_extensions_string (ARB #8)

wglGetLayerPaletteEntries

GLScene.OpenGL4

wglGetPbufferDCARB

GLScene.OpenGL4

wglGetPixelFormatAttribfvARB

GLScene.OpenGL4

wglGetPixelFormatAttribivARB

GLScene.OpenGL4

WGL_ARB_pixel_format (ARB #9)

wglGetProcAddress

GLScene.OpenGL4

wglGetSwapIntervalEXT

GLScene.OpenGL4

wglMakeContextCurrentARB

GLScene.OpenGL4

WGL_make_current_read (ARB #10)

wglMakeCurrent

GLS.OpenGLAdapter

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;

wglMakeCurrent

GLScene.OpenGL4

wglQueryPbufferARB

GLScene.OpenGL4

wglRealizeLayerPalette

GLS.OpenGLAdapter

wglRealizeLayerPalette

GLScene.OpenGL4

wglReleasePbufferDCARB

GLScene.OpenGL4

wglReleaseTexImageARB

GLScene.OpenGL4

wglRestoreBufferRegionARB

GLScene.OpenGL4

wglSaveBufferRegionARB

GLScene.OpenGL4

wglSetLayerPaletteEntries

GLScene.OpenGL4

wglSetPbufferAttribARB

GLScene.OpenGL4

wglShareLists

GLS.OpenGLAdapter

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;

wglShareLists

GLScene.OpenGL4

WGLSWAP

GLScene.OpenGL4

WGLSWAP

GLScene.OpenGLTokens

wglSwapIntervalEXT

GLScene.OpenGL4

########################################################### function and procedure definitions for Vendor/EXT WGL extensions ########################################################### WGL_EXT_swap_control (EXT #172)

wglSwapLayerBuffers

GLS.OpenGLAdapter

wglSwapLayerBuffers

GLScene.OpenGL4

wglSwapMultipleBuffers

GLScene.OpenGL4

wglUseFontBitmaps

GLScene.OpenGL4

wglUseFontBitmapsA

GLScene.OpenGL4

wglUseFontBitmapsW

GLScene.OpenGL4

wglUseFontOutlines

GLScene.OpenGL4

wglUseFontOutlinesA

GLScene.OpenGL4

wglUseFontOutlinesW

GLScene.OpenGL4

WGL_3DFX_multisample

GLScene.OpenGL4

WGL

WGL_3DL_stereo_control

GLScene.OpenGL4

WGL

WGL_ACCELERATION_ARB

GLScene.OpenGL4

WGL_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_ACCELERATION_EXT

GLScene.OpenGL4

WGL_ACCESS_READ_ONLY_NV

GLScene.OpenGL4

WGL_NV_DX_interop

WGL_ACCESS_READ_ONLY_NV

GLScene.OpenGLTokens

WGL_NV_DX_interop (EXT #407)

WGL_ACCESS_READ_WRITE_NV

GLScene.OpenGL4

WGL_ACCESS_READ_WRITE_NV

GLScene.OpenGLTokens

WGL_ACCESS_WRITE_DISCARD_NV

GLScene.OpenGL4

WGL_ACCESS_WRITE_DISCARD_NV

GLScene.OpenGLTokens

WGL_ACCUM_ALPHA_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_ALPHA_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_ALPHA_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_BLUE_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_BLUE_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_BLUE_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_GREEN_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_GREEN_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_GREEN_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_RED_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_RED_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_RED_BITS_EXT

GLScene.OpenGL4

WGL_ALPHA_BITS_ARB

GLScene.OpenGL4

WGL_ALPHA_BITS_ARB

GLScene.OpenGLTokens

WGL_ALPHA_BITS_EXT

GLScene.OpenGL4

WGL_ALPHA_SHIFT_ARB

GLScene.OpenGL4

WGL_ALPHA_SHIFT_ARB

GLScene.OpenGLTokens

WGL_ALPHA_SHIFT_EXT

GLScene.OpenGL4

WGL_AMD_gpu_association

GLScene.OpenGL4

WGL

WGL_ARB_buffer_region

GLScene.OpenGL4

WGL

WGL_ARB_context_flush_control

GLScene.OpenGL4

WGL

WGL_ARB_create_context

GLScene.OpenGL4

WGL

WGL_ARB_create_context_profile

GLScene.OpenGL4

WGL

WGL_ARB_create_context_robustness

GLScene.OpenGL4

WGL

WGL_ARB_extensions_string

GLScene.OpenGL4

WGL

WGL_ARB_framebuffer_sRGB

GLScene.OpenGL4

WGL

WGL_ARB_make_current_read

GLScene.OpenGL4

WGL

WGL_ARB_multisample

GLScene.OpenGL4

WGL

WGL_ARB_pbuffer

GLScene.OpenGL4

WGL

WGL_ARB_pixel_format

GLScene.OpenGL4

WGL

WGL_ARB_pixel_format_float

GLScene.OpenGL4

WGL

WGL_ARB_render_texture

GLScene.OpenGL4

WGL

WGL_ATI_pixel_format_float

GLScene.OpenGL4

WGL

WGL_AUX0_ARB

GLScene.OpenGL4

WGL_AUX0_ARB

GLScene.OpenGLTokens

WGL_AUX1_ARB

GLScene.OpenGL4

WGL_AUX1_ARB

GLScene.OpenGLTokens

WGL_AUX2_ARB

GLScene.OpenGL4

WGL_AUX2_ARB

GLScene.OpenGLTokens

WGL_AUX3_ARB

GLScene.OpenGL4

WGL_AUX3_ARB

GLScene.OpenGLTokens

WGL_AUX4_ARB

GLScene.OpenGL4

WGL_AUX4_ARB

GLScene.OpenGLTokens

WGL_AUX5_ARB

GLScene.OpenGL4

WGL_AUX5_ARB

GLScene.OpenGLTokens

WGL_AUX6_ARB

GLScene.OpenGL4

WGL_AUX6_ARB

GLScene.OpenGLTokens

WGL_AUX7_ARB

GLScene.OpenGL4

WGL_AUX7_ARB

GLScene.OpenGLTokens

WGL_AUX8_ARB

GLScene.OpenGL4

WGL_AUX8_ARB

GLScene.OpenGLTokens

WGL_AUX9_ARB

GLScene.OpenGL4

WGL_AUX9_ARB

GLScene.OpenGLTokens

WGL_AUX_BUFFERS_ARB

GLScene.OpenGL4

WGL_AUX_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_AUX_BUFFERS_EXT

GLScene.OpenGL4

WGL_BACK_COLOR_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_BACK_COLOR_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_BACK_LEFT_ARB

GLScene.OpenGL4

WGL_BACK_LEFT_ARB

GLScene.OpenGLTokens

WGL_BACK_RIGHT_ARB

GLScene.OpenGL4

WGL_BACK_RIGHT_ARB

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_DEPTH_NV

GLScene.OpenGL4

WGL_NV_render_depth_texture

WGL_BIND_TO_TEXTURE_RECTANGLE_DEPTH_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_RGB_NV

GLScene.OpenGL4

WGL_NV_render_texture_rectangle

WGL_BIND_TO_TEXTURE_RGBA_ARB

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RGBA_ARB

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RGB_ARB

GLScene.OpenGL4

WGL_ARB_render_texture

WGL_BIND_TO_TEXTURE_RGB_ARB

GLScene.OpenGLTokens

ARB Extension #20 - WGL_ARB_render_texture

WGL_BIND_TO_VIDEO_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_VIDEO_RGB_AND_DEPTH_NV

GLScene.OpenGL4

WGL_BIND_TO_VIDEO_RGB_NV

GLScene.OpenGL4

WGL_NV_video_output

WGL_BLUE_BITS_ARB

GLScene.OpenGL4

WGL_BLUE_BITS_ARB

GLScene.OpenGLTokens

WGL_BLUE_BITS_EXT

GLScene.OpenGL4

WGL_BLUE_SHIFT_ARB

GLScene.OpenGL4

WGL_BLUE_SHIFT_ARB

GLScene.OpenGLTokens

WGL_BLUE_SHIFT_EXT

GLScene.OpenGL4

WGL_CLAMP_FRAGMENT_COLOR_ARB

GLScene.OpenGL4

WGL_CLAMP_READ_COLOR_ARB

GLScene.OpenGL4

WGL_CLAMP_VERTEX_COLOR_ARB

GLScene.OpenGL4

WGL_COLOR_BITS_ARB

GLScene.OpenGL4

WGL_COLOR_BITS_ARB

GLScene.OpenGLTokens

WGL_COLOR_BITS_EXT

GLScene.OpenGL4

WGL_COLOR_SAMPLES_NV

GLScene.OpenGL4

WGL_COLOR_SAMPLES_NV

GLScene.OpenGLTokens

unknown extension, where does it come from?

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGL4

WGL_ARB_create_context

WGL_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGL4

WGL_EXT_create_context_es2_profile

WGL_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGLTokens

EXT #400 WGL_EXT_create_context_es2_profile

WGL_CONTEXT_FLAGS_ARB

GLScene.OpenGL4

WGL_CONTEXT_FLAGS_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_LAYER_PLANE_ARB

GLScene.OpenGL4

WGL_CONTEXT_LAYER_PLANE_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGL4

WGL_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGLTokens

ARB Extension #55 - WGL_ARB_create_context see also WGL_ARB_create_context_profile (ARB #74)

WGL_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGL4

WGL_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGL4

WGL_ARB_create_context_profile

WGL_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGLTokens

ARB Extension #74 - WGL_ARB_create_context_profile see also WGL_ARB_create_context (ARB #55)

WGL_CONTEXT_RELEASE_BEHAVIOR_ARB

GLScene.OpenGL4

WGL_ARB_context_flush_control

WGL_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB

GLScene.OpenGL4

WGL_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB

GLScene.OpenGL4

WGL_CONTEXT_RESET_ISOLATION_BIT_ARB

GLScene.OpenGL4

WGL_ARB_robustness_application_isolation

WGL_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

WGL_CONTEXT_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

WGL_ARB_create_context_robustness

WGL_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

WGL_NV_multisample_coverage

WGL_CUBE_MAP_FACE_ARB

GLScene.OpenGL4

WGL_CUBE_MAP_FACE_ARB

GLScene.OpenGLTokens

WGL_DEPTH_BITS_ARB

GLScene.OpenGL4

WGL_DEPTH_BITS_ARB

GLScene.OpenGLTokens

WGL_DEPTH_BITS_EXT

GLScene.OpenGL4

WGL_DEPTH_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_DEPTH_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_DEPTH_COMPONENT_NV

GLScene.OpenGL4

WGL_DEPTH_FLOAT_EXT

GLScene.OpenGL4

WGL_EXT_depth_float

WGL_DEPTH_TEXTURE_FORMAT_NV

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_FRAMEBUFFER_I3D

GLScene.OpenGL4

WGL_I3D_digital_video_control

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_VALUE_I3D

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_CURSOR_INCLUDED_I3D

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_GAMMA_CORRECTED_I3D

GLScene.OpenGL4

WGL_DOUBLE_BUFFER_ARB

GLScene.OpenGL4

WGL_DOUBLE_BUFFER_ARB

GLScene.OpenGLTokens

WGL_DOUBLE_BUFFER_EXT

GLScene.OpenGL4

WGL_DRAW_TO_BITMAP_ARB

GLScene.OpenGL4

WGL_DRAW_TO_BITMAP_ARB

GLScene.OpenGLTokens

WGL_DRAW_TO_BITMAP_EXT

GLScene.OpenGL4

WGL_DRAW_TO_PBUFFER_ARB

GLScene.OpenGL4

WGL_ARB_pbuffer

WGL_DRAW_TO_PBUFFER_ARB

GLScene.OpenGLTokens

ARB Extension #11 - WGL_ARB_pbuffer

WGL_DRAW_TO_PBUFFER_EXT

GLScene.OpenGL4

WGL_EXT_pbuffer

WGL_DRAW_TO_WINDOW_ARB

GLScene.OpenGL4

WGL_DRAW_TO_WINDOW_ARB

GLScene.OpenGLTokens

WGL_DRAW_TO_WINDOW_EXT

GLScene.OpenGL4

WGL_ERROR_INCOMPATIBLE_AFFINITY_MASKS_NV

GLScene.OpenGL4

WGL_NV_gpu_affinity

WGL_ERROR_MISSING_AFFINITY_MASK_NV

GLScene.OpenGL4

WGL_EXT_create_context_es2_profile

GLScene.OpenGL4

WGL

WGL_EXT_depth_float

GLScene.OpenGL4

WGL

WGL_EXT_display_color_table

GLScene.OpenGL4

WGL

WGL_EXT_extensions_string

GLScene.OpenGL4

WGL

WGL_EXT_make_current_read

GLScene.OpenGL4

WGL

WGL_EXT_multisample

GLScene.OpenGL4

WGL

WGL_EXT_pbuffer

GLScene.OpenGL4

WGL

WGL_EXT_pixel_format

GLScene.OpenGL4

WGL

WGL_EXT_swap_control

GLScene.OpenGL4

WGL

WGL_FIXED_ONLY_ARB

GLScene.OpenGL4

WGL_FLOAT_COMPONENTS_NV

GLScene.OpenGL4

WGL_NV_float_buffer

WGL_FLOAT_COMPONENTS_NV

GLScene.OpenGLTokens

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGL4

WGL_ARB_framebuffer_sRGB

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGLTokens

ARB Extension #46 - GL_ARB_framebuffer_sRGB

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

WGL_FRONT_COLOR_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_ARB_buffer_region

WGL_FRONT_COLOR_BUFFER_BIT_ARB

GLScene.OpenGLTokens

—————— OpenGL v1.1 generic constants ——————– ARB Extension #4 - WGL_ARB_buffer_region

WGL_FRONT_LEFT_ARB

GLScene.OpenGL4

WGL_FRONT_LEFT_ARB

GLScene.OpenGLTokens

WGL_FRONT_RIGHT_ARB

GLScene.OpenGL4

WGL_FRONT_RIGHT_ARB

GLScene.OpenGLTokens

WGL_FULL_ACCELERATION_ARB

GLScene.OpenGL4

WGL_FULL_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_FULL_ACCELERATION_EXT

GLScene.OpenGL4

WGL_GAMMA_EXCLUDE_DESKTOP_I3D

GLScene.OpenGL4

WGL_GAMMA_TABLE_SIZE_I3D

GLScene.OpenGL4

WGL_I3D_gamma

WGL_GENERIC_ACCELERATION_ARB

GLScene.OpenGL4

WGL_GENERIC_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_GENERIC_ACCELERATION_EXT

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_DIGITAL_FIELD_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_DIGITAL_SYNC_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_BOTH_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_FALLING_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_RISING_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_FIELD_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_SYNC_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_TTL_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_MULTIVIEW_I3D

GLScene.OpenGL4

WGL_I3D_genlock

WGL_GPU_CLOCK_AMD

GLScene.OpenGL4

WGL_GPU_FASTEST_TARGET_GPUS_AMD

GLScene.OpenGL4

WGL_GPU_NUM_PIPES_AMD

GLScene.OpenGL4

WGL_GPU_NUM_RB_AMD

GLScene.OpenGL4

WGL_GPU_NUM_SIMD_AMD

GLScene.OpenGL4

WGL_GPU_NUM_SPI_AMD

GLScene.OpenGL4

WGL_GPU_OPENGL_VERSION_STRING_AMD

GLScene.OpenGL4

WGL_GPU_RAM_AMD

GLScene.OpenGL4

WGL_GPU_RENDERER_STRING_AMD

GLScene.OpenGL4

WGL_GPU_VENDOR_AMD

GLScene.OpenGL4

WGL_AMD_gpu_association

WGL_GREEN_BITS_ARB

GLScene.OpenGL4

WGL_GREEN_BITS_ARB

GLScene.OpenGLTokens

WGL_GREEN_BITS_EXT

GLScene.OpenGL4

WGL_GREEN_SHIFT_ARB

GLScene.OpenGL4

WGL_GREEN_SHIFT_ARB

GLScene.OpenGLTokens

WGL_GREEN_SHIFT_EXT

GLScene.OpenGL4

WGL_I3D_digital_video_control

GLScene.OpenGL4

WGL

WGL_I3D_gamma

GLScene.OpenGL4

WGL

WGL_I3D_genlock

GLScene.OpenGL4

WGL

WGL_I3D_image_buffer

GLScene.OpenGL4

WGL

WGL_I3D_swap_frame_lock

GLScene.OpenGL4

WGL

WGL_I3D_swap_frame_usage

GLScene.OpenGL4

WGL

WGL_IMAGE_BUFFER_LOCK_I3D

GLScene.OpenGL4

WGL_IMAGE_BUFFER_MIN_ACCESS_I3D

GLScene.OpenGL4

WGL_I3D_image_buffer

WGL_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_HEIGHT_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_HEIGHT_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_MAX_PBUFFER_PIXELS_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_PIXELS_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_PIXELS_EXT

GLScene.OpenGL4

WGL_MAX_PBUFFER_WIDTH_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_WIDTH_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_MIPMAP_LEVEL_ARB

GLScene.OpenGL4

WGL_MIPMAP_LEVEL_ARB

GLScene.OpenGLTokens

WGL_MIPMAP_TEXTURE_ARB

GLScene.OpenGL4

WGL_MIPMAP_TEXTURE_ARB

GLScene.OpenGLTokens

WGL_NEED_PALETTE_ARB

GLScene.OpenGL4

WGL_NEED_PALETTE_ARB

GLScene.OpenGLTokens

WGL_NEED_PALETTE_EXT

GLScene.OpenGL4

WGL_NEED_SYSTEM_PALETTE_ARB

GLScene.OpenGL4

WGL_NEED_SYSTEM_PALETTE_ARB

GLScene.OpenGLTokens

WGL_NEED_SYSTEM_PALETTE_EXT

GLScene.OpenGL4

WGL_NO_ACCELERATION_ARB

GLScene.OpenGL4

WGL_NO_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_NO_ACCELERATION_EXT

GLScene.OpenGL4

WGL_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

WGL_NO_TEXTURE_ARB

GLScene.OpenGL4

WGL_NO_TEXTURE_ARB

GLScene.OpenGLTokens

WGL_NUMBER_OVERLAYS_ARB

GLScene.OpenGL4

WGL_NUMBER_OVERLAYS_ARB

GLScene.OpenGLTokens

WGL_NUMBER_OVERLAYS_EXT

GLScene.OpenGL4

WGL_NUMBER_PIXEL_FORMATS_ARB

GLScene.OpenGL4

WGL_ARB_pixel_format

WGL_NUMBER_PIXEL_FORMATS_ARB

GLScene.OpenGLTokens

ARB Extension #9 - WGL_ARB_pixel_format (no new tokens)

WGL_NUMBER_PIXEL_FORMATS_EXT

GLScene.OpenGL4

WGL_EXT_pixel_format

WGL_NUMBER_UNDERLAYS_ARB

GLScene.OpenGL4

WGL_NUMBER_UNDERLAYS_ARB

GLScene.OpenGLTokens

WGL_NUMBER_UNDERLAYS_EXT

GLScene.OpenGL4

WGL_NUM_VIDEO_CAPTURE_SLOTS_NV

GLScene.OpenGL4

WGL_NUM_VIDEO_SLOTS_NV

GLScene.OpenGL4

WGL_NV_present_video

WGL_NV_copy_image

GLScene.OpenGL4

WGL

WGL_NV_DX_interop

GLScene.OpenGL4

WGL

WGL_NV_float_buffer

GLScene.OpenGL4

WGL

WGL_NV_gpu_affinity

GLScene.OpenGL4

WGL

WGL_NV_multisample_coverage

GLScene.OpenGL4

WGL

WGL_NV_present_video

GLScene.OpenGL4

WGL

WGL_NV_render_depth_texture

GLScene.OpenGL4

WGL

WGL_NV_render_texture_rectangle

GLScene.OpenGL4

WGL

WGL_NV_swap_group

GLScene.OpenGL4

WGL

WGL_NV_vertex_array_range

GLScene.OpenGL4

WGL

WGL_NV_video_capture

GLScene.OpenGL4

WGL

WGL_NV_video_output

GLScene.OpenGL4

WGL

WGL_OML_sync_control

GLScene.OpenGL4

WGL

WGL_OPTIMAL_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_OPTIMAL_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_PBUFFER_HEIGHT_ARB

GLScene.OpenGL4

WGL_PBUFFER_HEIGHT_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_PBUFFER_LARGEST_ARB

GLScene.OpenGL4

WGL_PBUFFER_LARGEST_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_LARGEST_EXT

GLScene.OpenGL4

WGL_PBUFFER_LOST_ARB

GLScene.OpenGL4

WGL_PBUFFER_LOST_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_WIDTH_ARB

GLScene.OpenGL4

WGL_PBUFFER_WIDTH_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_PIXEL_TYPE_ARB

GLScene.OpenGL4

WGL_PIXEL_TYPE_ARB

GLScene.OpenGLTokens

WGL_PIXEL_TYPE_EXT

GLScene.OpenGL4

WGL_RED_BITS_ARB

GLScene.OpenGL4

WGL_RED_BITS_ARB

GLScene.OpenGLTokens

WGL_RED_BITS_EXT

GLScene.OpenGL4

WGL_RED_SHIFT_ARB

GLScene.OpenGL4

WGL_RED_SHIFT_ARB

GLScene.OpenGLTokens

WGL_RED_SHIFT_EXT

GLScene.OpenGL4

WGL_RGBA_FLOAT_MODE_ARB

GLScene.OpenGL4

WGL_ARB_pixel_format_float

WGL_SAMPLES_3DFX

GLScene.OpenGL4

WGL_SAMPLES_ARB

GLScene.OpenGL4

WGL_SAMPLES_ARB

GLScene.OpenGLTokens

WGL_SAMPLES_EXT

GLScene.OpenGL4

WGL_SAMPLE_BUFFERS_3DFX

GLScene.OpenGL4

WGL_3DFX_multisample

WGL_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

WGL_ARB_multisample

WGL_SAMPLE_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_SAMPLE_BUFFERS_EXT

GLScene.OpenGL4

WGL_EXT_multisample

WGL_SHARE_ACCUM_ARB

GLScene.OpenGL4

WGL_SHARE_ACCUM_ARB

GLScene.OpenGLTokens

WGL_SHARE_ACCUM_EXT

GLScene.OpenGL4

WGL_SHARE_DEPTH_ARB

GLScene.OpenGL4

WGL_SHARE_DEPTH_ARB

GLScene.OpenGLTokens

WGL_SHARE_DEPTH_EXT

GLScene.OpenGL4

WGL_SHARE_STENCIL_ARB

GLScene.OpenGL4

WGL_SHARE_STENCIL_ARB

GLScene.OpenGLTokens

WGL_SHARE_STENCIL_EXT

GLScene.OpenGL4

WGL_STENCIL_BITS_ARB

GLScene.OpenGL4

WGL_STENCIL_BITS_ARB

GLScene.OpenGLTokens

WGL_STENCIL_BITS_EXT

GLScene.OpenGL4

WGL_STENCIL_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_STENCIL_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_STEREO_ARB

GLScene.OpenGL4

WGL_STEREO_ARB

GLScene.OpenGLTokens

WGL_STEREO_EXT

GLScene.OpenGL4

WGL_SUPPORT_GDI_ARB

GLScene.OpenGL4

WGL_SUPPORT_GDI_ARB

GLScene.OpenGLTokens

WGL_SUPPORT_GDI_EXT

GLScene.OpenGL4

WGL_SUPPORT_OPENGL_ARB

GLScene.OpenGL4

WGL_SUPPORT_OPENGL_ARB

GLScene.OpenGLTokens

WGL_SUPPORT_OPENGL_EXT

GLScene.OpenGL4

WGL_SWAP_COPY_ARB

GLScene.OpenGL4

WGL_SWAP_COPY_ARB

GLScene.OpenGLTokens

WGL_SWAP_COPY_EXT

GLScene.OpenGL4

WGL_SWAP_EXCHANGE_ARB

GLScene.OpenGL4

WGL_SWAP_EXCHANGE_ARB

GLScene.OpenGLTokens

WGL_SWAP_EXCHANGE_EXT

GLScene.OpenGL4

WGL_SWAP_LAYER_BUFFERS_ARB

GLScene.OpenGL4

WGL_SWAP_LAYER_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_SWAP_LAYER_BUFFERS_EXT

GLScene.OpenGL4

WGL_SWAP_METHOD_ARB

GLScene.OpenGL4

WGL_SWAP_METHOD_ARB

GLScene.OpenGLTokens

WGL_SWAP_METHOD_EXT

GLScene.OpenGL4

WGL_SWAP_UNDEFINED_ARB

GLScene.OpenGL4

WGL_SWAP_UNDEFINED_ARB

GLScene.OpenGLTokens

WGL_SWAP_UNDEFINED_EXT

GLScene.OpenGL4

WGL_TEXTURE_1D_ARB

GLScene.OpenGL4

WGL_TEXTURE_1D_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_2D_ARB

GLScene.OpenGL4

WGL_TEXTURE_2D_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_DEPTH_COMPONENT_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGBA_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGBA_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_RGB_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGB_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_RG_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RG_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_R_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_R_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FORMAT_ARB

GLScene.OpenGL4

WGL_TEXTURE_FORMAT_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

WGL_TEXTURE_RGBA_ARB

GLScene.OpenGL4

WGL_TEXTURE_RGBA_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_RGB_ARB

GLScene.OpenGL4

WGL_TEXTURE_RGB_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_TARGET_ARB

GLScene.OpenGL4

WGL_TEXTURE_TARGET_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_ALPHA_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_ALPHA_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_BLUE_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_BLUE_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_EXT

GLScene.OpenGL4

WGL_TRANSPARENT_GREEN_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_GREEN_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_INDEX_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_INDEX_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_RED_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_RED_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_VALUE_EXT

GLScene.OpenGL4

WGL_TYPE_COLORINDEX_ARB

GLScene.OpenGL4

WGL_TYPE_COLORINDEX_ARB

GLScene.OpenGLTokens

WGL_TYPE_COLORINDEX_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_ARB

GLScene.OpenGL4

WGL_TYPE_RGBA_ARB

GLScene.OpenGLTokens

WGL_TYPE_RGBA_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_FLOAT_ARB

GLScene.OpenGL4

WGL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGL4

WGL_ATI_pixel_format_float

WGL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGLTokens

WGL_ATI_pixel_format_float (#278)

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT

GLScene.OpenGLTokens

WGL_UNIQUE_ID_NV

GLScene.OpenGL4

WGL_NV_video_capture

WGL_VIDEO_OUT_ALPHA_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_AND_ALPHA_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_AND_DEPTH_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_DEPTH_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_FIELD_1

GLScene.OpenGL4

WGL_VIDEO_OUT_FIELD_2

GLScene.OpenGL4

WGL_VIDEO_OUT_FRAME

GLScene.OpenGL4

WGL_VIDEO_OUT_STACKED_FIELDS_1_2

GLScene.OpenGL4

WGL_VIDEO_OUT_STACKED_FIELDS_2_1

GLScene.OpenGL4

WHmgPoint

GLScene.VectorGeometry

WHmgVector

GLScene.VectorGeometry

WIN_draw_range_elements

GLScene.OpenGL4

WGL

WIN_swap_hint

GLScene.OpenGL4

WGL

WM_CAP_ABORT

Formats.VFW

WM_CAP_DLG_VIDEOCOMPRESSION

Formats.VFW

WM_CAP_DLG_VIDEODISPLAY

Formats.VFW

WM_CAP_DLG_VIDEOFORMAT

Formats.VFW

WM_CAP_DLG_VIDEOSOURCE

Formats.VFW

WM_CAP_DRIVER_CONNECT

Formats.VFW

WM_CAP_DRIVER_DISCONNECT

Formats.VFW

WM_CAP_DRIVER_GET_CAPS

Formats.VFW

WM_CAP_DRIVER_GET_NAME

Formats.VFW

WM_CAP_DRIVER_GET_NAMEA

Formats.VFW

WM_CAP_DRIVER_GET_NAMEW

Formats.VFW

WM_CAP_DRIVER_GET_VERSION

Formats.VFW

WM_CAP_DRIVER_GET_VERSIONA

Formats.VFW

WM_CAP_DRIVER_GET_VERSIONW

Formats.VFW

WM_CAP_EDIT_COPY

Formats.VFW

WM_CAP_END

Formats.VFW

WM_CAP_FILE_ALLOCATE

Formats.VFW

out of order to save on ifdefs

WM_CAP_FILE_GET_CAPTURE_FILE

Formats.VFW

WM_CAP_FILE_GET_CAPTURE_FILEA

Formats.VFW

WM_CAP_FILE_GET_CAPTURE_FILEW

Formats.VFW

WM_CAP_FILE_SAVEAS

Formats.VFW

WM_CAP_FILE_SAVEASA

Formats.VFW

WM_CAP_FILE_SAVEASW

Formats.VFW

WM_CAP_FILE_SAVEDIB

Formats.VFW

WM_CAP_FILE_SAVEDIBA

Formats.VFW

WM_CAP_FILE_SAVEDIBW

Formats.VFW

WM_CAP_FILE_SET_CAPTURE_FILE

Formats.VFW

WM_CAP_FILE_SET_CAPTURE_FILEA

Formats.VFW

WM_CAP_FILE_SET_CAPTURE_FILEW

Formats.VFW

WM_CAP_FILE_SET_INFOCHUNK

Formats.VFW

WM_CAP_GET_AUDIOFORMAT

Formats.VFW

WM_CAP_GET_CAPSTREAMPTR

Formats.VFW

WM_CAP_GET_MCI_DEVICE

Formats.VFW

WM_CAP_GET_MCI_DEVICEA

Formats.VFW

WM_CAP_GET_MCI_DEVICEW

Formats.VFW

WM_CAP_GET_SEQUENCE_SETUP

Formats.VFW

WM_CAP_GET_STATUS

Formats.VFW

WM_CAP_GET_USER_DATA

Formats.VFW

WM_CAP_GET_VIDEOFORMAT

Formats.VFW

WM_CAP_GRAB_FRAME

Formats.VFW

WM_CAP_GRAB_FRAME_NOSTOP

Formats.VFW

WM_CAP_PAL_AUTOCREATE

Formats.VFW

WM_CAP_PAL_MANUALCREATE

Formats.VFW

WM_CAP_PAL_OPEN

Formats.VFW

WM_CAP_PAL_OPENA

Formats.VFW

WM_CAP_PAL_OPENW

Formats.VFW

WM_CAP_PAL_PASTE

Formats.VFW

WM_CAP_PAL_SAVE

Formats.VFW

WM_CAP_PAL_SAVEA

Formats.VFW

WM_CAP_PAL_SAVEW

Formats.VFW

WM_CAP_SEQUENCE

Formats.VFW

WM_CAP_SEQUENCE_NOFILE

Formats.VFW

WM_CAP_SET_AUDIOFORMAT

Formats.VFW

WM_CAP_SET_CALLBACK_CAPCONTROL

Formats.VFW

Following added post VFW 1.1

WM_CAP_SET_CALLBACK_ERROR

Formats.VFW

WM_CAP_SET_CALLBACK_ERRORA

Formats.VFW

WM_CAP_SET_CALLBACK_ERRORW

Formats.VFW

WM_CAP_SET_CALLBACK_FRAME

Formats.VFW

WM_CAP_SET_CALLBACK_STATUS

Formats.VFW

WM_CAP_SET_CALLBACK_STATUSA

Formats.VFW

WM_CAP_SET_CALLBACK_STATUSW

Formats.VFW

WM_CAP_SET_CALLBACK_VIDEOSTREAM

Formats.VFW

WM_CAP_SET_CALLBACK_WAVESTREAM

Formats.VFW

WM_CAP_SET_CALLBACK_YIELD

Formats.VFW

WM_CAP_SET_MCI_DEVICE

Formats.VFW

WM_CAP_SET_MCI_DEVICEA

Formats.VFW

WM_CAP_SET_MCI_DEVICEW

Formats.VFW

WM_CAP_SET_OVERLAY

Formats.VFW

WM_CAP_SET_PREVIEW

Formats.VFW

WM_CAP_SET_PREVIEWRATE

Formats.VFW

WM_CAP_SET_SCALE

Formats.VFW

WM_CAP_SET_SCROLL

Formats.VFW

WM_CAP_SET_SEQUENCE_SETUP

Formats.VFW

WM_CAP_SET_USER_DATA

Formats.VFW

WM_CAP_SET_VIDEOFORMAT

Formats.VFW

WM_CAP_SINGLE_FRAME

Formats.VFW

WM_CAP_SINGLE_FRAME_CLOSE

Formats.VFW

WM_CAP_SINGLE_FRAME_OPEN

Formats.VFW

WM_CAP_START

Formats.VFW

UNICODE
The Win32 version of AVICAP on NT supports UNICODE applications: for each API or message that takes a char or string parameter, there are two versions, ApiNameA and ApiNameW. The default name ApiName is #defined to one or other depending on whether UNICODE is defined. Apps can call the A and W apis directly, and mix them.
The 32-bit AVICAP on NT uses unicode exclusively internally. ApiNameA() will be implemented as a call to ApiNameW() together with translation of strings. Defines start of the message range

WM_CAP_STOP

Formats.VFW

WM_CAP_UNICODE_END

Formats.VFW

Defines end of the message range

WM_CAP_UNICODE_START

Formats.VFW

WordToIntegerArray

GLScene.Utils

Copies the values of Source to Dest (converting word values to integer values)

WriteCRLFString

GLScene.Utils

Write the string and a CRLF in the stream

WriteModuleData

ModuleLoader

WriteMotorolaNumber

Formats.LWO

WriteS0

Formats.LWO

WriteU4AsVX

Formats.LWO

XCollectionEditorForm

FmXCollectionEditor

XDATA_APPNAME

Formats.m3DSConst

XDATA_DOUBLE

Formats.m3DSConst

XDATA_ENTRY

Formats.m3DSConst

XDATA_FLOAT

Formats.m3DSConst

XDATA_GROUP

Formats.m3DSConst

XDATA_LONG

Formats.m3DSConst

XDATA_RFU1

Formats.m3DSConst

XDATA_RFU2

Formats.m3DSConst

XDATA_RFU3

Formats.m3DSConst

XDATA_RFU4

Formats.m3DSConst

XDATA_RFU5

Formats.m3DSConst

XDATA_RFU6

Formats.m3DSConst

XDATA_SECTION

Formats.m3DSConst

External Application Data

XDATA_SHORT

Formats.m3DSConst

XDATA_STRING

Formats.m3DSConst

XDATA_VOID

Formats.m3DSConst

xgl

GLS.Context

XHmgPoint

GLScene.VectorGeometry

Standard homogeneous points

XHmgVector

GLScene.VectorGeometry

Standard homogeneous vectors

XLATE_RANGE

Formats.m3DSConst

XTexPoint

GLScene.VectorGeometry

TexPoints (2D space)

XVector

GLScene.VectorGeometry

standard vectors

XYHmgVector

GLScene.VectorGeometry

XYTexPoint

GLScene.VectorGeometry

XYVector

GLScene.VectorGeometry

XYZHmgVector

GLScene.VectorGeometry

XYZVector

GLScene.VectorGeometry

XYZWHmgVector

GLScene.VectorGeometry

XZHmgVector

GLScene.VectorGeometry

XZVector

GLScene.VectorGeometry

XZ_CURVE

Formats.m3DSConst

YHmgPoint

GLScene.VectorGeometry

YHmgVector

GLScene.VectorGeometry

YTexPoint

GLScene.VectorGeometry

YVector

GLScene.VectorGeometry

YZHmgVector

GLScene.VectorGeometry

YZVector

GLScene.VectorGeometry

YZ_CURVE

Formats.m3DSConst

ZHmgPoint

GLScene.VectorGeometry

ZHmgVector

GLScene.VectorGeometry

ZVector

GLScene.VectorGeometry

_

gnugettext

Main GNU gettext functions. See documentation for instructions on how to use them.

_CGcontext

Cg.Import

_CGparameter

Cg.Import

_CGprogram

Cg.Import

_EFXEAXREVERBPROPERTIES

OpenAL.Import

END EFX AEX extension EFX utils version 1.0

_EFXLOWPASSFILTER

OpenAL.Import

_priv_dParamLoStop

ODE.Import

These consts now have defined types

_priv_dParamLoStop2

ODE.Import

_priv_dParamLoStop3

ODE.Import

_putenv

GLS.SDL.Window

—————————————————————————– Get Environment Routines ——————————————————————————

_WGLSWAP

GLScene.OpenGL4

_WGLSWAP

GLScene.OpenGLTokens

__GLsync

OpenCL.GL


GLSysHelp v.2.5: Legend

Legend

Marker | Visibility
Strict Private | Strict Private
Private | Private
Strict Protected | Strict Protected
Protected | Protected
Public | Public
Published | Published
Automated | Automated
Implicit | Implicit